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User Guide Conventions

In order to clearly differentiate between references to objects, actions, literal 
entries, and user-supplied information, the following conventions are used in this 
user guide:

• Menu selections and buttons are shown in bold, and the steps in a menu path 
are represented with “>”.  For example:

Select Edit > STP Connection Configuration from the menu.

The Add button is not enabled when the STP Connection Configuration 
menu opens.

• Commands and entries that must be entered exactly as shown in this 
document are shown in the 10 point Courier bold font.  For example:

Using a text editor (such as Notepad) add the following lines to the 
AUTOEXEC.BAT file:
SET FTRA_HOME=”C:\<download_directory>”
SET JRE_HOME=”C:\Program Files\Java\j2re1.4.0_01”

• User-specific information is shown in italics and enclosed in “<>”.  For 
example, the name of the folder you wish to use as the download directory in 
the previous example is shown as <download_directory>.

Overview

The FTP-Based Table Retrieve Application (FTRA) is designed in conjunction with 
the FTP Retrieve and Replace feature to transfer EAGLE 5 ISS database tables 
using an FTP session to a remote server for offline processing.  The FTRA is a 
stand-alone application that interfaces with one or more STPs.  Database tables 
can be retrieved from the EAGLE 5 ISS, using the EAGLE 5 ISS’s retrieve 
commands.  The output of these retrieve commands is converted to CSV (comma 
separated value) files.  EAGLE 5 ISS commands in the form of a command file can 
be read into the FTRA where they are validated and sent to the selected STP.  Logs 
are provided for event tracking and error message display.

The FTRA provides the following features through the use of a graphical user 
interface:

• STP Connection Configuration.

• STP Connectivity Test.

• FTP Server Configuration.

• Retrieving the EAGLE 5 ISS database tables with the results converted to CSV 
files.

• Automated or manual retrieval of database tables from multiple STPs with the 
command line interface.  The results are converted to CSV files.
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• Validation of the command files before being sent to the  STP.

• Command file editing

• Viewing the log files for event tracking and error message display.

Hardware and Software Requirements

To run the offline application, a workstation on a Windows or Unix platform is 
required.  

The Windows workstation requires that the following hardware and software are 
installed:

• Operating system – Windows® 98 or later

• Processor speed – Pentium III, 750 MHz or faster

• RAM – Minimum 128 MB

• Disk space – Minimum 500 MB plus 500 MB for each configured STP

• A CD-ROM drive

• 10/100BaseT Ethernet connection to the LAN

• Static IP addressing

• JavaTM 2 Runtime Environment (JRE) 1.4.0 or later.

The Unix workstation requires that the following hardware and software are 
installed:

• Operating system – Solaris 7 or later

• Processor speed – 500 MHz or faster

• RAM – Minimum 512 MB

• Disk space – Minimum 500 MB plus 500 MB for each configured STP

• CD-ROM drive

• 10/100BaseT Ethernet connection to the LAN

• Static IP addressing

• Java™ 2 Runtime Environment (JRE) 1.4.0 or later
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To configure the EAGLE 5 ISS for the FTP Retrieve and Replace feature, these 
requirements must be met:

• The IP User Interface feature is enabled and activated.  The status of the IP 
User interface feature is shown in the EAGLE 5 ISS rtrv-ctrl-feat 
command output.  If the IP User Interface feature is not enabled and activated, 
perform the “Activating Controlled Features” procedure in the Database 
Administration Manual - System Management and enable and activate the IP 
User Interface.  

• Up to three IPSMs are installed and configured in the database.  The IPSMs 
are shown with the entry IPSM in the TYPE column of the EAGLE 5 ISS 
rtrv-card output.  If IPSMs are not shown in the rtrv-card output, perform 
the “Adding an IPSM” procedure in the Database Administration Manual - 
System Management and add the IPSMs.  

• If the EAGLE 5 ISS is running release 30.2 or greater, and you wish to use a 
secure connection for the FTRA to EAGLE 5 ISS communication, make sure 
the Eagle OA&M IP Security Enhancements feature is enabled and activated.  
This can be verified by entering the rtrv-ctrl-feat command at the EAGLE 
5 ISS.  If the Eagle OA&M IP Security Enhancements feature is not enabled or 
activated, perform the “Activating the Eagle OA&M IP Security 
Enhancements Controlled Feature” procedure in the Database Administration 
Manual - System Management and enable and activate the Eagle OA&M IP 
Security Enhancements feature. 

• GPSM-II cards must be installed in card locations 1113 and 1115.  The GPSM-II 
cards in card locations 1113 and 1115 are shown with the entry GPSM in the 
TYPE column of the EAGLE 5 ISS rtrv-card output.  

• TDMs, P/N 870-0774-10 or later, installed in card locations 1114 and 1116.  
Visually verify that these TDMs are installed in the EAGLE 5 ISS.

CAUTION: Never install or initialize MCAP cards in card locations 1113 
and 1115 after GPSM-II cards have been installed and features that require 
GPSM-II cards have been provisioned.  Attempting to initialize MCAP 
cards with features requiring GPSM-II cards will cause a system outage.  
Before replacing existing GPSM-II or MCAP cards (if the EAGLE 5 ISS 
currently has MCAP cards installed) in card locations 1113 or 1115, or 
replacing TDMs in card locations 1114 and 1116, contact the Customer Care 
Center at one of the following locations:

• Tekelec, UK

Phone: +44 1784 467 804
Fax: +44 1784 477 120
Email: ecsc@tekelec.com
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• Tekelec, USA

Phone (within the continental US) 888-367-8552 (888-FOR-TKLC)
(outside the continental US) +1 919-460-2150.

Email: support@tekelec.com.

Using the FTRA Application

The following is an overview of the steps required to use the FTRA application.

1. Install the FTRA software on the PC (personal computer) – refer to the 
“Software Installation”section.

2. Start the FTRA application – refer to the “FTRA Initialization” section on page 
28.

3. Select the current STP that the database tables will be retrieved from, or that 
the command files will be sent to – refer to the “Selecting the Current STP” 
procedure on page 57.

If you wish to use another STP, and that STP is not shown in the STP Name 
field of the STP Connection Configuration window, refer to the “Adding an 
STP Configuration Record” procedure on page 35 and add the new STP.

4. Before database tables can be retrieved from the EAGLE 5 ISS, or command 
files can be sent to the EAGLE 5 ISS, the FTP server configuration information 
for that EAGLE 5 ISS must be configured – refer to the “FTP Server 
Configuration” section on page 66.

5. To retrieve database tables from the selected STP, select the commands for the 
database tables you wish to retrieve in the Retrieve Tables Window – refer to 
the “Retrieve Database Tables from an STP” section on page 71.

6. To send commands to the selected STP, go to the Update Tables Window and 
select the command file to be sent, or create a command file – refer to the 
“Updating Database Tables in the Selected STP” section on page 97.

7. Exit the FTRA application – refer to the “Exit the FTRA” section on page 29.
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Software Installation

The FTRA software can be installed locally or remotely through a LAN.  The 
software installation can be accomplished in 5 to 10 minutes if the Java™ 2 
Runtime Environment has been previously installed.  

If the Java™ 2 Runtime Environment software has not been installed, you can 
install the Java™ 2 Runtime Environment software from the FTRA CD or 
download the Java™ 2 Runtime Environment software from Sun Microsystems’ 
web site (for installation on the Unix platform).  Should you decide to download 
the Java™ 2 Runtime Environment software from Sun Microsystems’ web site, the 
software installation can take from 30 to 90 minutes, depending on the download 
speed of your internet connection.  The FTRA is not providing service during this 
time.  If the FTRA is being upgraded, it will not be necessary to recreate 
directories or environment variables that already exist.

If problems are encountered while installing the FTRA software, contact the 
Customer Care Center.  Refer to page 3 for the contact information.

If the FTRA software is being installed for the first time, perform one of these 
procedures:

• “FTRA Software Installation on Windows - FTRA 1.0”

• “FTRA Software Installation on Windows - FTRA 2.x or Greater” on page 14

• “FTRA Software Installation on Unix” on page 24

If the FTRA software is being upgraded from FTRA 1.0 to FTRA 2.x or greater, 
perform one of these procedures:

• “Upgrade to FTRA 2.x or Greater on Windows” on page 26

• “Upgrade to FTRA 2.x or Greater on Unix” on page 27

Procedure – FTRA Software Installation on Windows - FTRA 1.0

1. Place the FTRA CD in the CD-ROM drive.

a. To see the contents of the FTRA CD, double click on the My Computer 
icon on the desktop of your computer.  This will open Windows Explorer.

b. Click on the Folders tab at the top of the Windows Explorer menu.  The 
drives in your computer are displayed.

c. Select the CD drive by clicking on the CD drive in the Folders pane of 
Windows Explorer.  The contents of the CD are displayed as shown in 
Figure 1 on page 6.
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Figure 1. Exploring the FTRA CD Using Windows Explorer

2. Install the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 from 
the CD.  

You may not need to install the Java™ 2 Runtime Environment Standard 
Edition Version 1.4.0 software if it is already installed on your computer.  
Perform the following steps to verify this.

a. Go to Start Menu > Settings > Control Panel > Add or Remove 
Programs.  All the programs installed on your computer are displayed.

b. If the  Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software is installed on your computer as shown in Figure 2 on page 7, 
go to step 3.  If the  Java™ 2 Runtime Environment Standard Edition 
Version 1.4.0 software is not installed on your computer, continue with 
this step.
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Figure 2. Add or Remove Programs Window

Install the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software on your computer by performing these steps.

a. Select the CD drive on your computer.

b. Select the windows folder on the CD drive.  The executable files for 
installing the FTRA software and the Java™ 2 Runtime Environment 
Standard Edition Version 1.4.0 software are displayed.

c. Double-click on the j2re-1_4_0_01_windows-i586-l icon.  The 
InstallShield Wizard opens.  Follow the InstallShield Wizard 
instructions.  When prompted, click this Yes or Next buttons, as 
appropriate, to proceed with the installation procedure.

d. The InstallShield Wizard asks you to choose the destination location for 
the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software.  You may change the destination location by clicking the 
Browse button as shown in Figure 3 on page 8, or you may use the 
default destination location given in the wizard.  Record the path 
information, either the default path or the new path you have chosen.  
The path information will be required in step 7. 
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Figure 3. Java Runtime-Environment Installshield Wizard

3. Create a folder that the FTRA software will be installed into (the 
<base_directory>), for example, C:\ftra. 

The new folder can be created on any drive on your computer.  Perform the 
following steps to create the folder.  For this example, a new folder named ftra 
is created on the C: drive.

a. Select the C: drive from Windows Explorer.

b. Right click and select New > Folder as shown in Figure 4 on page 9. A 
folder named New is created.
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Figure 4. Creating a New Folder for FTRA Installation

c. Rename this folder to ftra as shown in Figure 5.

Figure 5. Rename New Folder to FTRA



10 910-3489-001 Rev D, October 2006

FTP-Based Table Retrieve Application (FTRA) User Guide

NOTE: Make sure that there is no previous installation of the FTRA 
software inside the ftra folder on your computer.  If a previous installation 
of the FTRA software is inside the ftra folder, you may choose a different 
name for your <base_directory> or you may choose to remove or rename 
you previous FTRA installation.

4. Create a bin directory inside the <base_directory> by performing these steps.

a. From Windows Explorer, select the <base_directory>.

b. Right click and select New > Folder.

c. Rename the new folder to bin as shown in Figure 6.

Figure 6. Creating the bin Folder - FTRA 1.0

5. Copy the ftra_install.exe file from the FTRA CD to the 
<base_directory>\bin folder by performing these steps.

a. In Windows Explorer, select the CD drive on your computer and select 
the windows folder.

b. Copy the ftra_install.exe file from the windows folder to the 
<base_directory>\bin folder as shown in Figure 7 on page 11. 
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Figure 7. Copy the ftra_install.exe File

6. Extract the FTRA files to the <base_directory>\bin folder.

From Windows Explorer, double-click on the ftra_install.exe file.  The 
FTRA program files are extracted and placed inside the <base_directory>\bin 
folder.  The contents of the <base_directory>\bin folder is shown in Figure 8. 

Figure 8. FTRA bin Folder Contents - FTRA 1.0
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7. Set the required system/user environment variables.

The method for defining environment variables differs between Windows 
systems.

Windows 2000 or Windows XP Operating System

a. Right-click the My Computer icon on the desktop and select Properties.  

b. In the Advanced tab, click Environment Variables and then click New 
as shown in Figure 9.

c. Under User variables, and enter the following variable names and their 
values.

FTRA_HOME = C:\<base_directory created for FTRA> (typically, C:\ftra)

JRE_HOME = C:\Program Files\Java\j2re1.4.0_01 
(typically, the folder where Java is installed, and the Java path information 
recorded in step 2.) 

Figure 9. Setting the FTRA Environment Variables
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Windows NT® Operating System

NOTE: Installing the FTRA software on a computer using the Windows 
NT operating system is supported only on computers using Windows NT 
4.0.

a. Right-click the My Computer icon on the desktop and select Properties.

b. In the Environment tab, select any user environment variable, enter the 
new variable names and values, and click Set.

c. Under User variables, and enter the following variable names and their 
values.

FTRA_HOME = C:\<base_directory created for FTRA> (typically, C:\ftra)

JRE_HOME = C:\Program Files\Java\j2re1.4.0_01 
(typically, the folder where Java is installed, and the Java path information 
recorded in step 2.) 

Windows 98 Operating System

Using a text editor (such as Notepad) open the AUTOEXEC.BAT file and add 
the following lines to the end of the AUTOEXEC.BAT file.

SET FTRA_HOME=”C:\<base_directory created for FTRA>” (typically, C:\ftra)

SET JRE_HOME=”C:\Program Files\Java\j2re1.4.0_01” (typically, the 
folder where Java is installed, and the Java path information recorded in step 
2.)

NOTE: If the directory name has spaces, or is over eight characters in 
length, the DOS short name may be required to define the environment 
variable.  For example, using the JRE_HOME environment variable above, 
the  variable would be defined as “C:\Progra~1\Java\j2re1.4.0_01” 
(without the quotes) with the maximum eight characters for the directory 
name.

8. Create an FTRA shortcut on your desktop.

a. Using Windows Explorer, open the <base_directory>\bin folder.

b. Right-click on the ftra.bat file then select Create Shortcut as shown in 
Figure 10 on page 14.  A shortcut to the ftra.bat file is created in the 
<base_directory>\bin folder.

c. Cut and paste this shortcut to the desktop.
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Figure 10. Creating FTRA Shortcut - FTRA 1.0

NOTE: On multi-user systems, the shortcut should be placed in the 
Default User or All Users desktop folder in order to make it available to all 
users.

Procedure – FTRA Software Installation on Windows - FTRA 2.x or Greater

1. Place the FTRA CD in the CD-ROM drive.

a. To see the contents of the FTRA CD, double click on the My Computer 
icon on the desktop of your computer.  This will open Windows 
Explorer.

b. Click on the Folders tab at the top of the Windows Explorer menu.  The 
drives in your computer are displayed.

c. Select the CD drive by clicking on the CD drive in the Folders pane of 
Windows Explorer.  The contents of the CD are displayed as shown in 
Figure 11 on page 15.
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Figure 11. Exploring the FTRA CD Using Windows Explorer

2. Install the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 from 
the CD.  

You may not need to install the Java™ 2 Runtime Environment Standard 
Edition Version 1.4.0 software if it is already installed on your computer.  
Perform the following steps to verify this.

a. Go to Start Menu > Settings > Control Panel > Add or Remove 
Programs.  All the programs installed on your computer are displayed.

b. If the  Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software is installed on your computer as shown in Figure 12 on page 16, 
go to step 3.  If the  Java™ 2 Runtime Environment Standard Edition 
Version 1.4.0 software is not installed on your computer, continue with 
this step.
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Figure 12. Add or Remove Programs Window

Install the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software on your computer by performing these steps.

a. Select the CD drive on your computer.

b. Select the windows folder on the CD drive.  The executable files for 
installing the FTRA software and the Java™ 2 Runtime Environment 
Standard Edition Version 1.4.0 software are displayed.

c. Double-click on the j2re-1_4_0_01_windows-i586-l icon.  The 
InstallShield Wizard opens.  Follow the InstallShield Wizard 
instructions.  When prompted, click this Yes or Next buttons, as 
appropriate, to proceed with the installation procedure.

d. The InstallShield Wizard asks you to choose the destination location for 
the Java™ 2 Runtime Environment Standard Edition Version 1.4.0 
software.  You may change the destination location by clicking the 
Browse button as shown in Figure 13 on page 17, or you may use the 
default destination location given in the wizard.  Record the path 
information, either the default path or the new path you have chosen.  
The path information will be required in step 6. 
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Figure 13. Java Runtime-Environment Installshield Wizard

3. Create a folder that the FTRA software will be installed into (the 
<base_directory>), for example, C:\ftra. 

The new folder can be created on any drive on your computer.  Perform the 
following steps to create the folder.  For this example, a new folder named ftra 
is created on the C: drive.

a. Select the C: drive from Windows Explorer.

b. Right click and select New > Folder as shown in Figure 14 on page 18. A 
folder named New is created.
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Figure 14. Creating a New Folder for FTRA Installation

c. Rename this folder to ftra as shown in Figure 15.

Figure 15. Rename New Folder to FTRA
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NOTE: Make sure that there is no previous installation of the FTRA 
software inside the ftra folder on your computer.  If a previous installation 
of the FTRA software is inside the ftra folder, you may choose a different 
name for your <base_directory> or you may choose to remove or rename 
you previous FTRA installation.

4. Copy the ftra_install.exe file from the FTRA CD to the <base_directory> 
folder by performing these steps.

a. In Windows Explorer, select the CD drive on your computer and select 
the windows folder.

b. Copy the ftra_install.exe file from the windows folder to the 
<base_directory> as shown in Figure 16. 

Figure 16. Copy the ftra_install.exe File

5. Extract the FTRA program files using only the command prompt.  Do not use 
a Windows Explorer window to extract the FTRA program files.

a. Open the Windows command prompt.

b. Change directory to the FTRA <base_directory>.

c. Enter the command ftra_install -d as shown in Figure 17 on page 20.  
The FTRA program files are extracted to the FTRA <base_directory>.
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Figure 17. Extracting FTRA 2.x or Greater Program Files

6. Set the required system/user environment variables.

The method for defining environment variables differs between Windows 
systems.

Windows 2000 or Windows XP Operating System

a. Right-click the My Computer icon on the desktop and select Properties.  

b. In the Advanced tab, click Environment Variables and then click New 
as shown in Figure 18 on page 21.

c. Under User variables, and enter the following variable names and their 
values.

FTRA_HOME = C:\<base_directory created for FTRA> (typically, C:\ftra)

JRE_HOME = C:\Program Files\Java\j2re1.4.0_01 
(typically, the folder where Java is installed, and the Java path information 
recorded in step 2.) 



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 21

Figure 18. Setting the FTRA Environment Variables

Windows NT® Operating System

NOTE: Installing the FTRA software on a computer using the Windows 
NT operating system is supported only on computers using Windows NT 
4.0.

a. Right-click the My Computer icon on the desktop and select Properties.

b. In the Environment tab, select any user environment variable, enter the 
new variable names and values, and click Set.

c. Under User variables, and enter the following variable names and their 
values.

FTRA_HOME = C:\<base_directory created for FTRA> (typically, C:\ftra)

JRE_HOME = C:\Program Files\Java\j2re1.4.0_01 
(typically, the folder where Java is installed, and the Java path information 
recorded in step 2.) 

Windows 98 Operating System

Using a text editor (such as Notepad) open the AUTOEXEC.BAT file and add 
the following lines to the end of the AUTOEXEC.BAT file.

SET FTRA_HOME=”C:\<base_directory created for FTRA>” (typically, C:\ftra)

SET JRE_HOME=”C:\Program Files\Java\j2re1.4.0_01” (typically, the 
folder where Java is installed, and the Java path information recorded in step 
2.)
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NOTE: If the directory name has spaces, or is over eight characters in 
length, the DOS short name may be required to define the environment 
variable.  For example, using the JRE_HOME environment variable above, 
the  variable would be defined as “C:\Progra~1\Java\j2re1.4.0_01” 
(without the quotes) with the maximum eight characters for the directory 
name.

7. Create an FTRA shortcut on your desktop.

a. Using Windows Explorer, open the <base_directory>\bin folder.

b. Right-click on the ftra.bat file then select Create Shortcut as shown in 
Figure 19.  A shortcut to the ftra.bat file is created in the 
<base_directory>\bin folder.

c. Cut and paste this shortcut to the desktop.

Figure 19. Creating FTRA Shortcut - FTRA 2.x

NOTE: On multi-user systems, the shortcut should be placed in the 
Default User or All Users desktop folder in order to make it available to all 
users.
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Procedure – Java™ 2 Runtime Environment Installation from the FTRA CD

1. Place the FTRA CD in the CD-ROM drive.

2. Install the Java™ 2 Runtime Environment, SE V1.4.0 software from the FTRA 
CD.

To install the Java™ 2 Runtime Environment, SE V1.4.0 software from the 
FTRA CD, open FileManager and go to the CDROM drive.  From 
FileManager, double-click on the j2re-1_4_1_01-solaris-sparc.sh file.

3. Log in to the Unix workstation with root access priviedges.

4. Go to the /usr directory by entering this command.

cd /usr

5. Verify that you are in the /usr directory by entering this command.

pwd

6. Copy the Java installation file from the FTRA CD to the /usr directory by 
entering this command.

cp <path to the FTRA CD>/j2re1_4_0_01-solsparc.sh 

NOTE: You should be in the /usr directory, and there should be a 
directory named jr2re-1_4_1_01-solaris-sparc.sh (use the pwd and ls 
commands to verify that the jr2re-1_4_1_01-solaris-sparc.sh directory is in 
the /usr directory.

7. Create a symbolic link to Java by entering this command.

ln -s j2re1_4_0_01 java

NOTE: If a Java link already exists in the directory (use the ls -l 
command to verify that the link exists), remove the existing link first by 
entering this command, rm java.

8. Verify that the symbolic link was created by entering this command.

ls -l /usr/java

After you have completed this procedure, perform the “FTRA Software 
Installation on Unix” procedure on page 24.
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Procedure – Java™ 2 Runtime Environment Installation from Sun 
Microsystem’s Website

To install the Java™ 2 Runtime Environment (JRE) 1.4.0 from Sun Microsystem’s 
web site, enter the following address into your web browser and follow the 
product installation instructions. 

http://java.sun.com/j2se/1.4/jre/install-solaris.html

Procedure FTRA Software Installation on Unix

NOTE: Before performing this procedure, make sure the Java™ 2 
Runtime Environment software has been installed by performing either the 
“Java™ 2 Runtime Environment Installation from the FTRA CD” procedure 
on page 23 or the “Java™ 2 Runtime Environment Installation from Sun 
Microsystem’s Website” procedure on page 24.

1. Log into the workstation as root.

2. Set the required environment variables by adding the following lines to the 
user's .cshrc file:

setenv FTRA_HOME ’/FTRA’ 

setenv JRE_HOME ’/usr/j2rel.4.0_01’

3. Create an FTRA directory in by entering this command.

mkdir /FTRA

4. Go into this newly created directory and verify that this directory is empty by 
entering these commands.

cd /FTRA

ls -l

5. Copy the FTRA file (ftra_install.tar) from the CD to this directory by 
entering this command.

cp <path to the ftra_install.tar file on the FTRA CD> /FTRA

6. The FTRA file (ftra_install.tar) is zipped on the FTRA CD and will need 
to be expanded after the FTRA file is copied to the FTRA directory.  Enter this 
command to expand the file.

tar -xvf ftra_install.tar

http://java.sun.com/j2se/1.4/jre/install-solaris.html
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7. View the directory and verify that all the files were expanded into the FTRA 
directory by entering this command.

ls -l

8. Create a global user account for FTRA by entering these commands.

useradd -d /export/home/<username>/-s/sbin/csh <username>

passwd <username>

9. Create a home directory for the user created in step 8 by entering this 
comamnd.

mkdir /export/home/<user>

10. Change the ownership of the directory created in step 9 to the username 
added in step 8 by performing this command.

chown <username added in step 8>

11. Exit the workstation as root by entering this command.

su -newusr; cd

12. Go to the directory created in step 9 by entering this command.

cd /<directory name created in step 9>

13. Verify the correct user by entering the following command in Shell.

echo $USER

14. Verify that the Shell is CSH by entering this command.

echo $SHELL

If you are not in Shell, enter the command csh.

15. Create a .cshrc file by entering this command.

cat .cshrc

setenv FTRA_HOME ’/FTRA’

setenv JRE_HOME ’/usr/j2rel.4.0_01’
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16. Go to the home directory and list the .cshrc file by entering these commands.

cd

ls -al .cshrc

17. Make sure you are in the home directory of the current user by entering this 
command.

pwd

18. Source the runtime environment variables by entering these commands.

cd

source .cshrc

19. Verify that the environment variable locations match what was specified in 
step 15, without the trailing slash, by entering these commands.

echo $FTRA_HOME; echo $JRE_HOME

Example output: FTRA_HOME= /FTRA

                              JRE_HOME=/usr/j2rel.4.0_01

20. To launch the FTRA from the command line, enter this command.

$FTRA_HOME/bin/ftra

Procedure – Upgrade to FTRA 2.x or Greater on Windows

1. Place the FTRA CD in the CD-ROM drive.

2. From Windows Explorer, copy the ftra_install.exe file from the FTRA CD to 
the existing folder containing the FTRA software.  For details on the folder 
containing the FTRA software, see step 3 on page 8.
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3. Extract the FTRA program files from the FTRA CD using only the command 
prompt.  Do not use a Windows Explorer window for the extraction.  From the 
Windows command line, the MS-DOS prompt, enter the command 
ftra_install -d.  The ftra_install -d command creates all the required 
directories and extracts the program files.  During the execution of the 
ftra_install -d command, you will be asked if you wish to overwrite an 
existing file.  Answer yes for the upgrade to continue.  When the 
ftra_install -d command has finished executing, the FTRA software has 
been installed.

4. Start the FTRA software.  See the “FTRA Initialization” section on page 28 for 
more information on starting the FTRA software.  The existing STP 
Connection Configuration data will automatically be converted during the 
FTRA system initialization.

Procedure – Upgrade to FTRA 2.x or Greater on Unix

1. Place the FTRA CD in the CD-ROM drive.

2. From FileManager, copy the ftra_install.tar file from the FTRA CD to the 
existing directory containing the FTRA software by entering this command. 

cp <path to the ftra_install.tar file on the FTRA CD> /FTRA

3. From FileManager, right-click on the ftra_install.tar file that was copied from 
the FTRA CD, not the ftra_install.tar file on the FTRA CD, and select 
Archive Unpack.  This will create the sub-directories and extract the program 
files into the existing directory containing the FTRA software.

NOTE: The Archive Unpack function is only available when using the 
CDE (Common Desktop Environment) X-window File Manager.  If the CDE 
is not being used, the Unix tar command should be used to extract the 
program files.  Please refer to the man pages for the tar command for more 
information about using the tar command.

When the extraction of the FTRA program files has completed, the FTRA 
software has been installed.

4. Start the FTRA software.  See the “FTRA Initialization” section on page 28 for 
more information on starting the FTRA software.  The existing STP 
Connection Configuration data will automatically be converted during the 
FTRA system initialization.
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FTRA Initialization

To start the FTRA, double-click the FTRA icon on the desktop.  When the 
application starts, the FTP-Based Table Retrieve Application window is 
displayed.  See Figure 20.  The Initializing window opens and displays the 
message “Initializing, please wait………” until the initialization process has been 
completed.

Figure 20. FTP-Based Table Retrieve Application Window

Table 1 shows the description of the menus in the FTP-Based Table Retrieve 
Application window.

Table 1. FTP-Based Table Retrieve Application Menu 
Description 

Item Description

File Selects the Exit menu.

Edit Selects the STP Connection Configuration menu, the FTP Server 
Configuration menu, or the Commands menu

View Selects these logs:

• The Retrieve Tables Log

• The Update Tables Log

• The System Log.

Help Selects the About FTRA window.
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Exit the FTRA 

To close the FTP-Based Table Retrieve Application window and exit the FTRA, 
either select File > Exit from the File menu, see Figure 21, or click the close 
window button in the upper right hand corner of the window.  

Figure 21. File Menu in the FTP-Based Table Retrieve 
Application Window

The Exit? confirmation window (see Figure 22) opens with “You are about to exit. 
Continue?”  Click OK to exit and close the application.  The Exit window (see 
Figure 23 on page 30) is displayed until the Exit process is completed.  To cancel 
the exit and resume using the application, click Cancel.

Figure 22. Exit Confirmation Window

Close Button
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Figure 23. Exit Window
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STP Connection Configuration Menu

Before database tables can be retrieved from an STP, or command files can be sent 
to an STP, the STP must be defined as an STP configuration record in the STP 
Connection Configuration database.  The STP configuration record is configured 
and selected using the STP Connection Configuration Menu window.

The STP Connection Configuration Menu window is displayed by selecting 
Edit > STP Connection Configuration.  See Figure 24.  

Figure 24. Edit Menu

The STP Connection Configuration Menu window, see Figure 25 (FTRA 1.0) or 
Figure 26 on page 32 (FTRA 2.0 or greater), can be used also to delete and modify 
an STP configuration record.  

Figure 25. STP Connection Configuration Menu Window 
(FTRA 1.0)
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Figure 26. STP Connection Configuration Menu Window 
(FTRA 2.0 or greater)

Table 2 shows the description of the fields, buttons, and boxes in the STP 
Connection Configuration Menu window.

Table 2. STP Connection Configuration Menu Description 

Item Description

Fields

STP Name Contains the STP Names.  The STP name must contain at least one 
alphanumeric character and a maximum of 64 upper-case alphanumeric 
characters.  The STP Name will always be entered in uppercase regardless 
of the Caps Lock key setting on your keyboard. 
This field also provides a drop down list for selecting stored STP 
configuration records.

IP Address 
(FTRA 1.0 only) 

The IP address of the associated STP (used for telnet sessions).   The IP 
address is the IP address of an IPSM in the associated EAGLE 5 ISS.

Primary IP 
Address (FTRA 
2.0 or greater)

The primary IP address of the associated STP (used for telnet sessions). 
The FTRA uses this IP address first when connecting to the STP.  The 
primary IP address is the IP address of an IPSM in the associated EAGLE 
5 ISS.
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Backup IP 
Address (FTRA 
2.0 or greater)

The backup IP address of the associated STP (used for telnet sessions).  
The FTRA uses this IP address when the connection using the primary IP 
address fails.  The backup IP address should be the IP address of another 
IPSM in the same EAGLE 5 ISS.

STP UserName The user name assigned to the user by the STP system administrator 
(used for telnet sessions).

STP Password The password assigned to the user by the STP system administrator (used 
for telnet sessions).

FTP UserName The FTP user name assigned to the user by the  administrator (used for 
FTP).  Any FTP user name with symbols must be enclosed within double 
quotation marks (for example, to specify the FTP user name mylogin#1, 
you would enter “mylogin#1”). 

FTP Password The FTP password assigned to the user by the  administrator (used for 
FTP).

Buttons

Refresh Displays the data of the STP configuration record typed in the STP Name 
field.  If an STP name is selected from the STP Name drop down list, the 
data fields are automatically displayed.

Test Verifies that the FTRA can successfully connect and login to the EAGLE 
5 ISS through an available telnet terminal at the specified IP address.  
For FTRA 1.0, the STP Connection Configuration Menu window has only 
one Test button.  
For FTRA 2.0 or greater, the STP Connection Configuration Menu 
window has two Test buttons, one for the Primary IP address, and one for 
the Backup IP address.  

Select Selects the displayed STP name to be connected to the FTRA.  The STP 
Selection Change window opens to verify if you want to proceed.

Add Adds a newly entered STP configuration record and associated data to 
the STP Connection Configuration database.

Modify Modifies the fields of the displayed STP configuration record.

Delete Deletes the displayed STP configuration record and associated data from 
the STP Connection Configuration database.

Close Closes the STP Connection Configuration Menu window.

Table 2. STP Connection Configuration Menu Description  (Continued)

Item Description
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Boxes

Secure 
Connection 
(FTRA 2.0 or 
greater)

Enables the FTRA to use a secure IP connection to the STP.  
To use a secure connection for the FTRA to EAGLE 5 ISS communication, 
make sure the EAGLE 5 ISS is running release 30.2 or greater and that the 
Eagle OA&M IP Security Enhancements feature is enabled and activated.  
This can be verified by entering the rtrv-ctrl-feat command at the 
EAGLE 5 ISS.  If the Eagle OA&M IP Security Enhancements feature is not 
enabled or activated, perform the “Activating the Eagle OA&M IP 
Security Enhancements Controlled Feature” procedure in the Database 
Administration Manual - System Management and enable and activate the 
Eagle OA&M IP Security Enhancements feature.

NOTE: This box should be unchecked if the Eagle OA&M IP 
Security Enhancements feature is not enabled or activated, and 
will not be enabled or activated.

If this box is checked, the public key fingerprint for the EAGLE 5 ISS 
specified in this window must be installed onto the FTRA for the FTRA 
and the specified EAGLE 5 ISS to use a secure connection.  After this STP 
is added to the STP Connection Configuration database, add the public 
key fingerprint to the FTRA by performing the “Secure EAGLE 5 ISS Host 
Key Provisioning” procedure on page 60. 

Use STP and FTP 
UserNames, 
Passwords for all 
STPs Box

All the STP and FTP user names and passwords of all the provisioned 
STPs are changed to the user name and password of the displayed STP 
name.  This change occurs only when the Add or Modify buttons are 
used.

Table 2. STP Connection Configuration Menu Description  (Continued)

Item Description
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Adding an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table 
Retrieve Application window.  See Figure 24 on page 31.  The STP 
Connection Configuration Menu window opens.  See Figure 25 on page 31.  
The Add button is not enabled when the STP Connection Configuration 
Menu window opens.

2. Enter the STP name in the STP Name field of the STP Connection 
Configuration Menu window.  The STP name must contain at least one 
alphanumeric character, with a maximum of 64 upper-case characters 
(alphanumeric, letters and numbers, and spaces).  See Figure 28 on page 36 
(FTRA 1.0) or Figure 29 on page 36 (FTRA 2.0 or greater).  The STP Name will 
always be entered in uppercase regardless of the Caps Lock key setting on 
your keyboard.

If characters other then alphanumeric characters or spaces are included in the 
STP name, the Invalid STP Name warning window is displayed.  See Figure 
27.  If the Invalid STP Name window appears, click OK, and reenter the STP 
name in the STP Name field with the correct characters.

NOTE: When the new STP name is entered into the STP Name field, the 
Add button is enabled.   If the STP name matches an existing STP name in 
the STP Connection Configuration database, the Add button is disabled.  If 
you wish to display the existing STP names, go to the “Displaying an 
Existing STP Configuration Record” procedure on page 40.

NOTE: If the “Use STP and FTP UserNames and Passwords for all STPs” 
box is checked when the Add button is clicked, all the user names and 
passwords for all provisioned STP Names are changed to those of the added 
STP name.

NOTE: Existing STP configuration records can be changed.  Go to the 
“Modifying an Existing STP Configuration Record” procedure on page 53 
to change an existing STP configuration record.

Figure 27. Invalid STP Name Error Message
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Figure 28. Adding an STP Configuration Record (FTRA 1.0)

Figure 29. Adding an STP Configuration Record 
(FTRA 2.0 or greater)



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 37

3. Enter the IP address of the STP in the IP Address field (FTRA 1.0).  If the FTRA 
is running version 2.0 or greater, enter the IP address you wish to use to 
connect to the STP in the Primary IP Address field, and a backup IP address 
in the Backup IP Address field.  See Figure 28 on page 36 (FTRA 1.0) or Figure 
29 on page 36 (FTRA 2.0 or greater).  

CAUTION: If the backup IP address is not entered for FTRAs running 2.0 
or greater, the FTRA will not be able to connect to the STP when the 
connection to the STP using the primary IP address fails.  It is 
recommended that you specify a backup IP address for the STP.

If the format of the IP address (FTRA 1.0), or the primary and backup IP 
addresses (FTRA 2.0 or greater) is not entered correctly, the Invalid IP 
Address warning window is displayed.  See Figure 30.  If the Invalid IP 
Address window appears, click OK, and reenter the IP address in the IP 
Address field (FTRA 1.0) or the primary or backup IP addresses (FTRA 2.0 or 
greater) in the Primary IP Address or Backup IP Address fields in the correct 
format.

Figure 30. Invalid IP Address Error Message

4. Enter the STP user name for this STP in the STP UserName field.  The user 
name is assigned to the user by the STP system administrator for telnet 
sessions.  See Figure 28 on page 36 (FTRA 1.0) or Figure 29 on page 36 (FTRA 
2.0 or greater).  If the format of the STP user name is not correct, the Invalid 
STP User Name warning window is displayed.  See Figure 31.  If the Invalid 
STP User Name window appears, click OK, and re-enter the STP user name 
in the STP UserName field.

Figure 31. Invalid STP User Name Error Message
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5. Enter the STP password for this STP in the STP Password field.  The 
password is assigned to the user by the EAGLE 5 ISS system administrator for 
telnet sessions.  See Figure 28 on page 36 (FTRA 1.0) or Figure 29 on page 36 
(FTRA 2.0 or greater).   If the format of the STP password is not correct, the 
Invalid STP Password warning window is displayed.  See Figure 32.  If the 
Invalid STP Password window appears, click OK, and re-enter the STP 
password in the STP Password field.

NOTE: The STP Password field does not check for invalid EAGLE 5 ISS 
passwords.  The passwords are validated by the EAGLE 5 ISS when the 
FTRA attempts a connection to the EAGLE 5 ISS.  The requirements for the 
format of EAGLE 5 ISS passwords is shown in the output of the EAGLE 5 
ISS’s rtrv-secu-dflt command.

Figure 32. Invalid STP Password Error Message

6. Enter the FTP user name assigned by the FTP server administrator in the FTP 
UserName field.  See Figure 28 on page 36 (FTRA 1.0) or Figure 29 on page 36 
(FTRA 2.0 or greater).   Any FTP user name with symbols must be enclosed 
within double quotation marks (for example, to specify the FTP user name 
mylogin#1, you would enter “mylogin#1”).  If the format of the FTP user 
name is not correct, the Invalid FTP User Name warning window is 
displayed.  See Figure 33.  If the Invalid FTP User Name window appears, 
click OK, and re-enter the FTP user name in the FTP UserName field.

NOTE: Any firewall between the FTRA and the FTP server configured in 
the FTP Server Configuration Menu window (Figure 62 on page 67), must 
allow FTPs to the IP address specified in the FTP Server Configuration 
Menu window.

Figure 33. Invalid FTP User Name Error Message
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7. Enter the FTP password assigned by the FTP server administrator in the FTP 
Password field.  See Figure 28 on page 36 (FTRA 1.0) or Figure 29 on page 36 
(FTRA 2.0 or greater).   If the format of the STP user name is not correct, the 
Invalid FTP Password warning window is displayed.  See Figure 34.  If the 
Invalid FTP Password window appears, click OK, and re-enter the FTP 
password in the FTP Password field.

Figure 34. Invalid FTP Password Error Message

NOTE: If you are running FTRA 1.0, or running FTRA 2.0 or greater and 
not enabling a secure connection to the STP, skip this step and go to step 9.

8. To enable a secure connection between the FTRA and the STP being added in 
this procedure, click in the Secure Connection box.  
Make sure the EAGLE 5 ISS is running release 30.2 or greater and that the 
Eagle OA&M IP Security Enhancements feature is enabled and activated.  
This can be verified by entering the rtrv-ctrl-feat command at the EAGLE 
5 ISS.  If the Eagle OA&M IP Security Enhancements feature is not enabled or 
activated, perform the “Activating the Eagle OA&M IP Security 
Enhancements Controlled Feature” procedure in the Database Administration 
Manual - System Management and enable and activate the Eagle OA&M IP 
Security Enhancements feature.

9. Click the Add button.  See Figure 28 on page 36 (FTRA 1.0) or Figure 29 on 
page 36 (FTRA 2.0 or greater).  The newly entered STP Name and associated 
data is added to the STP Connection Configuration database, and the STP 
Added window (Figure 35) is displayed.  Click OK to continue.

Figure 35. STP Added Window

10. Verify the addition of the new STP name.  See the “Displaying an Existing STP 
Configuration Record” procedure on page 40.
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Displaying an Existing STP Configuration Record

An existing STP configuration record can be displayed by either selecting the STP 
Name from the STP Name drop down list, or by re-entering the STP name in the 
STP Name field in the STP Connection Configuration Menu window and 
clicking the Refresh button.  

To Use the STP Name Drop Down List

Procedure

1. In the STP Connection Configuration Menu window, click on the STP Name 
drop down list.  The STP Name drop down list opens.  Move the cursor to the 
STP name to be selected.  Click on the desired STP name in the drop down list.  
See Figure 36 (FTRA 1.0) or Figure 37 on page 41 (FTRA 2.0 or greater).  

Figure 36. Selecting an STP Name from the STP Name Drop 
Down List (FTRA 1.0)
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Figure 37. Selecting an STP Name from the STP Name Drop 
Down List (FTRA 2.0 or greater)
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2. When the STP name is selected in step 1, the STP configuration record for the 
specified STP is displayed.  See Figure 38 (FTRA 1.0) or Figure 39 on page 43 
(FTRA 2.0 or greater).  The Refresh, Test, Select, Delete, and Close buttons 
are enabled.

Figure 38. STP Name Selected from the STP Name Drop 
Down List (FTRA 1.0)



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 43

Figure 39. STP Name Selected from the STP Name Drop 
Down List (FTRA 2.0 or greater)
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To Enter the STP Name

Procedure

1. Type the STP name in the STP Name field in the STP Connection 
Configuration Menu window.  See Figure 40 (FTRA 1.0) or Figure 41 on page 
45 (FTRA 2.0 or greater).  The Refresh, Test, Select, Delete, and Close buttons 
are enabled.

Figure 40. Selecting a STP Configuration Record by Typing in 
the STP Name Field (FTRA 1.0)
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Figure 41. Selecting a STP Configuration Record by Typing in 
the STP Name Field (FTRA 2.0 or greater)
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2. Click the Refresh button.  The STP configuration record for the specified STP 
is displayed.  See Figure 42 (FTRA 1.0) or Figure 43 on page 47 (FTRA 2.0 or 
greater).

Figure 42. STP Configuration Record (FTRA 1.0)
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Figure 43. STP Configuration Record (FTRA 2.0 or greater)

3. If the STP name was entered incorrectly, or is not in the STP configuration 
record database, the “STP Name does not exist” error message is displayed.  
See Figure 44. 

Figure 44. STP Name Does Not Exist Error Message
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Testing an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table 
Retrieve Application window.  See Figure 24 on page 31.  The STP 
Connection Configuration Menu window opens.  See Figure 25 on page 31.

2. Display the STP configuration record being modified.  Go to the “Displaying 
an Existing STP Configuration Record” procedure on page 40.

3. Click the Test button.  The Connectivity Test Log window opens.  See Figure 
45 and Figure 46 on page 49.  The Connectivity Test Log contains the events of 
the Test process and any error messages that may have occurred.  The 
Connectivity Test Log window opens at the start of the Test process and is 
automatically cleared whenever a subsequent Test process is initiated.

Figure 45. Connectivity Test Log Window with No Errors

Stp Connectivity Test Process Manager: Stp Connectivity Test Begun
Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
Telnet Terminal Session Manager: Session Connected: 10.1.2.10:8080
Telnet Terminal Session Manager: Terminal 17 Enabled
Telnet Terminal Session Manager: User "eagle" Login Attempt: 1
Telnet Terminal Session Manager: User "eagle" Login Accepted
Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1
Telnet Terminal Session Manager: User "eagle" Logout Accepted
Stp Connectivity Test Process Manager: Stp Connectivity Test Complete Without Errors
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Figure 46. Connectivity Test Log Window with Errors

4. When the test is complete, the Command Complete window opens.  See 
Figure 47.  Click OK to continue.

Figure 47. Command Complete Connectivity Test Window

Connectivity Test Log File Menu

The File menu in the Connectivity Test Log window, shown in Figure 48 on page 
50, provides these selections:

• Clearing the Connectivity Test Log display

• Printing the Connectivity Test Log

• Saving the Connectivity Test Log to a file

• Closing the Connectivity Test Log window.

Stp Connectivity Test Process Manager: Testing stp4
Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
Telnet Terminal Session Manager: Session Not Connected: 10.1.2.1:8080
Stp Connectivity Test Process Manager: Test Complete With Errors
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Figure 48. File Menu in the Connectivity Test Log Window

Clearing the Connectivity Test Log Display

The display can be cleared, enabling new entries to be captured to the log.  Once 
the log is cleared, the existing entries are lost unless the log is save to a file or 
printed before the display is cleared. 

Procedure

1. Select File > Clear Display in the Connectivity Test Log window.  See Figure 
48.  The Connectivity Test Log display clears.

Stp Connectivity Test Process Manager: Stp Connectivity Test Begun
Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
Telnet Terminal Session Manager: Session Connected: 10.1.2.10:8080
Telnet Terminal Session Manager: Terminal 17 Enabled
Telnet Terminal Session Manager: User "eagle" Login Attempt: 1
Telnet Terminal Session Manager: User "eagle" Login Accepted
Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1
Telnet Terminal Session Manager: User "eagle" Logout Accepted
Stp Connectivity Test Process Manager: Stp Connectivity Test Complete Without Errors

Clear Display

Print

Save

Close
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Printing the Connectivity Test Log

Procedure

1. Select File > Print in the Connectivity Test Log window.  See Figure 48 on 
page 50.  The Print window opens.  See Figure 49.

Figure 49. Print Window

2. Configure the printer settings.

3. To print the Connectivity Test Log, click the OK button in the Print window.  
The current contents of the Connectivity Test Log are printed.

4. If you decide not to print the Connectivity Test Log, click the Cancel button in 
the Print window.
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Saving the Connectivity Test Log to a File

Procedure

1. Select File > Save in the Connectivity Test Log window.  See Figure 48 on 
page 50.   The Save window opens.  See Figure 50.

Figure 50. Save Window

2. Select a location for the file, and enter the file name and file type (with either 
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use 
Microsoft Word to open the file, even if it was saved as a .txt file. 

NOTE: If you decide not to save the file, do not perform steps 3 and 4, but 
click Cancel in the Save window.

3. Click the Save button.  A Saved file confirmation window opens with “Data 
saved to file.” See Figure 51.

Figure 51. Saved File Confirmation Window
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4. To save the file, click OK in the Saved file confirmation window to continue. 

Closing the Connectivity Test Log Window

Procedure

1. Select File > Close in the Connectivity Test Log window, or click the close 
window button in the upper right hand corner of the Connectivity Test Log 
window.  See Figure 48 on page 50.  The Connectivity Test Log window 
closes.

Modifying an Existing STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table 
Retrieve Application window.  See Figure 24 on page 31.  The STP 
Connection Configuration Menu window opens.  See Figure 25 on page 31.

2. Display the STP configuration record being modified.  Go to the “Displaying 
an Existing STP Configuration Record” procedure on page 40.

3. Select and change the STP configuration record parameters.  The Modify 
button is enabled when new data is entered into any of the fields, or when the 
Use STP and FTP UserNames and Passwords for all STPs box is checked.

NOTE: The STP name cannot be changed.

If the IP address, STP user name, or STP password is not entered correctly, an 
error message is displayed.  See Figure 30 on page 37, Figure 31 on page 37, or 
Figure 32 on page 38.  If the FTP user name and FTP password are not entered, 
an error message is displayed.  See Figure 33 on page 38 or Figure 34 on page 
39
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4. To apply the changes, click the Modify button.  See Figure 52 (FTRA 1.0) or 
Figure 53 on page 55 (FTRA 2.0 or greater).  The displayed STP configuration 
record is modified, and all fields are cleared.  To confirm that the STP 
configuration data has been modified, the STP Data Modified window is 
displayed (Figure 54 on page 56).  Click OK in the STP Data Modified 
window to continue.

CAUTION: If the Use STP and FTP UserNames and Passwords for all 
STPs box is checked, then all user names and passwords for all STPs in the 
STP Configuration database are changed to the user name and password for 
the displayed STP.

Figure 52. Modifying STP Configuration Record 
Parameters (FTRA 1.0)

The user changed the
IP address enabling
the Modify button
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Figure 53. Modifying STP Configuration Record 
Parameters (FTRA 2.0 or greater)

CAUTION: If the Use STP and FTP UserNames and Passwords for all 
STPs box is checked, then all user names and passwords for all STPs in the 
STP Configuration database are changed to the user name and password for 
the displayed STP.

CAUTION: It is recommended that the setting for the Secure Connection 
box is not changed, unless you have verified that the new setting for the 
Secure Connection box will match the state of the Eagle OA&M IP Security 
Enhancements feature on the STP.   The state of the Eagle OA&M IP 
Security Enhancements feature can be verified by entering the 
rtrv-ctrl-feat command at the EAGLE 5 ISS.  If the Eagle OA&M IP 
Security Enhancements feature is not enabled or activated, the Secure 
Connection box should be unchecked.  If the Eagle OA&M IP Security 
Enhancements feature is enabled and activated, the Secure Connection box 
should be checked.  To change the state of the Eagle OA&M IP Security 
Enhancements feature, perform the “Activating the Eagle OA&M IP 
Security Enhancements Controlled Feature” procedure in the Database 
Administration Manual - System Management.

The user changed
the IP addresses

enabling the
Modify Button
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Figure 54. STP Data Modified Window

NOTE: If the STP configuration record being changed is shown in the 
Current STP Selected: field, a Modify Warning window is displayed.  See 
Figure 55.

Figure 55. Modify Warning Window

Click Yes to continue.

If you do not wish to apply the changes, click the Refresh button in the STP 
Connection Configuration Menu window.  This resets the STP configuration 
record values.

5. Verify that the changes were made.  See the “Displaying an Existing STP 
Configuration Record” procedure on page 40.

Deleting an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table 
Retrieve Application window.  See Figure 24 on page 31.  The STP 
Connection Configuration Menu window opens.  See Figure 25 on page 31.
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2. Display the STP configuration record being deleted.  Go to the “Displaying an 
Existing STP Configuration Record” procedure on page 40.  The Delete button 
is enabled when an existing STP configuration record is displayed.

3. To delete the STP configuration record, click the Delete button.   The Delete 
STP window opens. See Figure 56.

Figure 56. Delete STP Window

Click OK, to delete the STP configuration record.  The STP configuration 
record is deleted.

If you do not wish to delete the STP configuration record, click Cancel.

4. Verify the STP name is no longer in the STP Connection Configuration 
database.  Go to the “Displaying an Existing STP Configuration Record” 
procedure on page 40.

Selecting the Current STP

Before retrieving database tables from an EAGLE 5 ISS, or sending commands to 
an EAGLE 5 ISS, that STP name must be shown in the STP Connection 
Configuration Menu window as the current STP.   The Current STP Selected: 
indicator in the STP Connection Configuration Menu window shows which STP 
is the current STP.

Procedure

1. Display an existing STP configuration record.  Go to the “Displaying an 
Existing STP Configuration Record” procedure on page 40.
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2. Click the Select button.  

If the selected STP is different from the STP shown as the current STP, the STP 
Selection Change window opens and displays “Warning: Selecting a different 
STP will purge existing table data.  Do you want to proceed?” See Figure 57.

Figure 57. STP Selection Change Window

3. To proceed and select the STP name as the current STP, click the Yes button in 
the STP Selection Change window.  The existing data table is purged.

NOTE: To purge the data tables, a flag is set so that any of the existing 
table data already stored in the offline database will not be used. 

The selected STP name appears in the title bar of the window, and Current 
STP Selected: <STP Name> appears in the STP Connection Configuration 
Menu.  See Figure 58 (FTRA 1.0) or Figure 59 on page 59 (FTRA 2.0 or greater). 

Figure 58. Current STP Selected (FTRA 1.0)

Current STP Selected



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 59

Figure 59. Current STP Selected (FTRA 2.0 or greater)

4. If you do not wish to use the STP name selected in step 2, click the No button  
in the STP Selection Change window.  The current STP configuration record 
is displayed.

Current STP Selected
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Secure EAGLE 5 ISS Host Key Provisioning

An EAGLE 5 ISS using secure connections has a unique host key for each IPSM in 
the EAGLE 5 ISS.  This key is used by the FTRA (FTRA 2.0 or greater) to positively 
identify or authenticate each IPSM’s telnet server on the EAGLE 5 ISS.  The FTRA 
will not connect to an unauthenticated server.  The FTRA authenticates the server 
by matching it’s pre-installed host key with the key received from the EAGLE 5 
ISS when the connection between the EAGLE 5 ISS and the FTRA is made.

This procedure installs the public host key fingerprint, generated when the IPSM 
is installed into the EAGLE 5 ISS, reinitialized using the init-card command, or 
when the IPSM is brought into service with the alw-card or rst-card 
commands, into the FTRA.  This procedure must be performed for each IPSM on 
each EAGLE 5 ISS that the FTRA will connect to, but only for EAGLE 5 ISSs using 
secure connections to connect to the FTRA.  This procedure must be performed 
before any secure connection between the EAGLE 5 ISS and the FTRA can be 
initiated. 

NOTE: Once the IPSM is installed into the EAGLE 5 ISS, the public host 
key fingerprint for the IPSM will change only when power to the IPSM is 
disrupted by removing the IPSM from the shelf, then reinserting the IPSM 
into the shelf, or as the result of any event that interrupts power to the 
IPSM.  Reinitializing the IPSM will not change the public host key 
fingerprint for the IPSM.  This procedure will have to be performed for 
each public host key fingerprint on the EAGLE 5 ISS that has changed.

The public host key fingerprint is added to the FTRA’s hosts.xml file.  If the public 
host key fingerprint has not been added to the FTRA’s hosts.xml file, and you try 
to initiate a secure connection to the EAGLE 5 ISS, you will receive the following 
warning message (Figure 60).

Figure 60. IP Address Warning Message

If the warning message shown in Figure 60 is received, either clear the Secure 
Connection check box in the STP Configuration Record for the STP (see the 
“Modifying an Existing STP Configuration Record” procedure on page 53), or 
add the public host key fingerprint to the FTRA’s hosts.xml file using the 
procedure on page 62.
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The verification that the keys are installed on the FTRA is called strict host key 
checking.  By default, strict host key checking is on.  This enforces server (EAGLE 
5 ISS) strong authentication, designed to provide security between the FTRA and 
the EAGLE 5 ISS.  This also prevents a hostile server from tricking the FTRA into 
exposing any EAGLE 5 ISS login and password combinations.

CAUTION: Do not set strict host key checking to off, unless your network 
is in a controlled and secure environment.  If you set strict host key 
checking to off, the Connectivity Test Log will warn you each time you try 
to connect that the EAGLE 5 ISS public host key fingerprint has not been 
added to the hosts.xml file on the FTRA.

To set the strict host key flag:

1. Open the application start file using any text file editor.  On the Windows 
platform, open the ftra.bat file.  On the UNIX platform, open the ftra file.

2. Insert into the application start file, one of these text strings, depending on 
whether you want strict host key checking on or off.

• -DstrictHostKeyChecking=1 for setting strict host key checking to on 
(this is the default setting).

• -DstrictHostKeyChecking=0 for setting strict host key checking to off

This text string can be inserted anywhere between the %JRE_HOME%\bin\java 
and -cp text strings as shown in the following example.

%JRE_HOME%\bin\java -Dstricthostkeychecking=1 -Ddebuglevel=2 
-Dsshtools.home=%FTRA2_HOME% -Dftra2rootdir=%FTRA2_HOME% -cp ftra3.jar 
com.tekelec.ftra.gui.InterfaceSelector %1

3. Save the changes and close the application start file.
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Procedure

1. On the EAGLE 5 ISS, enter the rtrv-trm command.  The location of the IPSM 
is shown in the LOC column with the TELNET terminal type.

This is an example of the possible output.

rlghncxa03w 05-09-17 15:08:45 GMT EAGLE5 34.0.0
TRM  TYPE     COMM        FC    TMOUT MXINV DURAL
1    VT320    9600-7-E-1  SW    30    5     99:59:59
2    KSR      9600-7-E-1  HW    30    5     INDEF
3    PRINTER  4800-7-E-1  HW    30    0     00:00:00
4    VT320    2400-7-E-1  BOTH  30    5     00:30:00
5    VT320    9600-7-O-1  NONE  30    5     00:00:30
6    VT320    9600-7-E-2  SW    30    9     INDEF
7    PRINTER  9600-7-N-2  HW    30    5     00:30:00
8    KSR     19200-7-E-2  BOTH  30    5     00:30:00
9    VT320    9600-7-E-1  SW    30    7     00:30:00
10   VT320    9600-7-E-1  HW    30    5     00:30:00
11   VT320    4800-7-E-1  HW    30    5     00:30:00
12   PRINTER  9600-7-E-1  HW    30    4     00:30:00
13   VT320    9600-7-O-1  NONE  30    5     00:30:00
14   VT320    9600-7-E-2  SW    30    8     00:30:00
15   VT320    9600-7-N-2  HW    30    5     00:30:00
16   VT320    9600-7-E-2  BOTH  30    3     00:30:00

TRM  TYPE      LOC              TMOUT MXINV DURAL      SECURE
17   TELNET    1111             60    5     00:30:00   yes
18   TELNET    1111             60    5     00:30:00   yes
19   TELNET    1111             60    5     00:30:00   yes
20   TELNET    1111             60    5     00:30:00   yes
21   TELNET    1111             60    5     00:30:00   yes
22   TELNET    1111             60    5     00:30:00   yes
24   TELNET    1111             60    5     00:30:00   yes

TRM  TRAF LINK SA  SYS PU  DB  UIMRD
1    NO   YES  NO  YES NO  YES YES
2    NO   NO   NO  NO  NO  NO  NO
3    YES  YES  YES NO  YES YES YES
4    YES  NO   NO  NO  NO  NO  NO
5    NO   YES  NO  NO  NO  NO  YES
6    NO   NO   YES NO  NO  NO  NO
7    YES  YES  YES YES YES YES YES
8    NO   NO   NO  NO  YES NO  YES
9    NO   YES  NO  NO  NO  YES NO
10   NO   NO   NO  NO  NO  NO  YES
11   YES  YES  YES YES YES YES YES
12   YES  YES  YES YES YES YES YES
13   NO   YES  NO  NO  NO  NO  YES
14   NO   NO   YES NO  NO  NO  NO
15   YES  YES  YES NO  YES YES YES
16   NO   NO   NO  NO  YES NO  YES
17   NO   NO   NO  NO  NO  NO  NO
18   NO   NO   NO  NO  NO  NO  NO
19   NO   NO   NO  NO  NO  NO  NO
20   NO   NO   NO  NO  NO  NO  NO
21   NO   NO   NO  NO  NO  NO  NO
22   NO   NO   NO  NO  NO  NO  NO
23   NO   NO   NO  NO  NO  NO  NO
24   NO   NO   NO  NO  NO  NO  NO
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2. Display the IP address assigned to the IPSM using the rtrv-ip-lnk 
command, specifying the card location of the IPSM shown in step 1 and the 
port=a parameter.  For this example, enter this command.  
rtrv-ip-lnk:loc=1111:port=a

The following is an example of the possible output.
rlghncxa03w 05-09-17 15:08:45 GMT EAGLE5 34.0.0
LOC   PORT IPADDR           SUBMASK        DUPLEX SPEED MACTYPE AUTO MCAST
1111  A    192.168.54.96    255.255.255.0  HALF   100   DIX     NO   NO

NOTE: If the Security Administration (SA) setting for all the terminals 
assigned to the IPSM specified in this procedure is set to YES, see the 
rtrv-trm output in step 1, skip this step and go to step 4.

3. Change the Security Administration setting on the terminals assigned to the 
IPSM with the chg-trm command and specifying the number of the terminals 
whose Security Administration setting is NO, and with the sa=yes parameter.

chg-trm:sa=yes:trm=<TELNET terminal number>

When the chg-trm command has successfully completed, this message 
should appear.
rlghncxa03w 05-09-17 15:08:45 GMT EAGLE5 34.0.0
CHG-TRM: MASP A - COMPLTD

NOTE: When the IPSM is installed into the EAGLE 5 ISS, UIM 1493 is 
generated.  UIM 1493 contains the DSA key fingerprint to be added to the 
hosts.xml file.  If you recorded the DSA key fingerprint for the IPSM when 
UIM 1493 was generated, skip step 4 and go to step 5.
CAUTION: If you are performing step 4 from a telnet terminal, make sure 
the step is being performed from a telnet terminal that is not assigned to the 
IPSM being initialized.  When the IPSM is initialized, you will lose all 
telnet connections supported by the IPSM being initialized.

4. Obtain the DSA key fingerprint for the IPSM by performing the init-card 
command and specifying the location of the IPSM.  For this example, enter 
this command.
init-card:loc=1111

After the init-card command has been executed, UIM 1494 is generated.  
The DSA key fingerprint is at the end of the output, in the hexadecimal 
format, and shown in bold in this output example.  
rlghncxa03w 05-09-17 15:08:45 GMT EAGLE5 34.0.0
0021.1494    CARD 1111     INFO    SSH Host Keys Loaded
             DSA Server Host Key FTRA-formatted Fingerprint=
             84 7c 92 8b c 7c d8 19 1c 6 4b de 5c 8f c5 4d
             Report Date:05-03-17  Time:15:08:45

NOTE: If you wish to change the public host key fingerprint on the IPSM, 
remove and reinsert the IPSM.  The public host key fingerprint does not 
change until the IPSM loses power.  However, contact the Customer Care 
Center before removing and reinserting the IPSM.  Refer to page 3 for the 
contact information.
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5. Edit the FTRA hosts.xml file (in the $FTRA_HOME/cfg directory on Unix or 
%FTRA_HOME%\cfg folder on Windows), using any text file editor.  Add 
the:

• IPSM IP address from the rtrv-ip-lnk output shown in step 2

• DSA public key fingerprint, shown in either the output of UIM 1493, 
when the IPSM was installed, or from the output of UIM 1494 when the 
init-card command was performed in step 4 in the following format:

<AllowHost HostName="<IPSM IP Address>" Fingerprint="767: <DSA public key fingerprint>"/>

NOTE: The value 767 preceding the DSA public key fingerprint is the 
length of the key in bytes.  On your EAGLE 5 ISS, this value may be 
different.  refer to the FTRA Connectivity Test Log to verify this value.  The 
outputs of UIM 1493 or 1494 do not contain this value.

The following is a sample /ftra/cfg/hosts.xml file before the new DSA 
fingerprint information is added.

======================================
<?xml version="1.0" encoding="UTF-8"?>

<HostAuthorizations>
<AllowHost HostName="192.168.54.36" Fingerprint="767: 4a 9 ec d3 70 34 d2 91 
f7 8b 75 a8 95 37 98 35"/>
<AllowHost HostName="192.168.54.216" Fingerprint="767: bc 76 ac 53 1e fd 72 16 
3e 9c dc d7 23 25 6 59"/>
///-----
/// Add new fingerprints HERE, after last allowed host in the above list.
///-----
</HostAuthorizations>
======================================

The sample /ftra/cfg/hosts.xml file after the new DSA fingerprint information 
is added.

===========================================
<?xml version="1.0" encoding="UTF-8"?>

<HostAuthorizations>
<AllowHost HostName="192.168.54.36" Fingerprint="767: 4a 9 ec d3 70 34 d2 91 
f7 8b 75 a8 95 37 98 35"/>
<AllowHost HostName="192.168.54.216" Fingerprint="767: bc 76 ac 53 1e fd 72 16 
3e 9c dc d7 23 25 6 59"/>
<AllowHost HostName="192.168.54.96" Fingerprint="767: 84 7c 92 8b c 7c d8 19 
1c 6 4b de 5c 8f c5 4d"/>
///-----
/// Add new fingerprints HERE, after last allowed host in the above list.
///-----
</HostAuthorizations>
===========================================

NOTE: There should be no duplicate IP addresses in this file.
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6. Save the file and exit the text editor.

7. A secure connection can now be established to the IP address used in this 
procedure.  Either add the STP containing the IP address to the STP 
Configuration Record (see the “Adding an STP Configuration Record” 
procedure on page 35), or if the IP address is already defined in the STP 
Configuration Record, change the existing record for this STP with the IP 
address used in this procedure (see the “Modifying an Existing STP 
Configuration Record” procedure on page 53).  Whether adding a new STP 
record, or changing an existing STP record, make sure the Secure Connection 
check box is checked. 

8. After the STP record has been added or changed to use a secure connection, 
test the connection by performing the “Testing an STP Configuration Record” 
procedure on page 48.  If the connection test is passed, the public host key 
fingerprint is successfully installed.

If the connection is refused, make sure that the key information for the EAGLE 
5 ISS and the FTRA shown in the Connectivity Test Log match.  The 
Connectivity Test Log shows both the key received from the EAGLE 5 ISS host 
and the key contained in the hosts.xml file for the EAGLE 5 ISS host.  The 
following is an example from the Connectivity Test Log containing a host key 
mismatch. The key received from the EAGLE 5 ISS host is shown in bold.  The 
key contained in the hosts.xml file is shown in bold underline.
2003-07-11 14:22:56.117: Stp Connectivity Test Process Manager: Testing STP11805011201
2003-07-11 14:22:56.227: Telnet Terminal Session Manager: Initiating Secure Telnet Session 
with Eagle: 192.168.53.71:22
2003-07-11 14:22:56.808: HostKeyVerification: ERROR: Host 192.168.53.71 cannot be 
authenticated due to a mismatched entry for this host in the hosts.xml file. The host key 
supplied by 192.168.53.71 is: 768: bb 7d 79 a2 7d ae 5d 5a 45 e2 44 58 cd 8a bd 83.
The current allowed key for 192.168.53.71 is: 768: ab 7d 79 a2 7d ae 5d 5a 45 e2 44 58 cd 
8a bd 83.

2003-07-11 14:22:56.828: HostKeyVerification: Connection rejected...onHostKeyMismatch
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FTP Server Configuration

An FTP server must be configured on the EAGLE 5 ISS using the FTP Server 
Configuration menu before database tables can be retrieved from the EAGLE 5 
ISS, or command files can be sent to the EAGLE 5 ISS.

NOTE: If the Secure Connection box in the STP Connection 
Configuration Menu window (applies only in FTRA 2.0 or greater) is 
checked, the IP address specified in the FTP Server Configuration menu 
must be the IP address of a secure FTP server.  If the Secure Connection box 
in the STP Connection Configuration Menu window is not checked, the IP 
address specified in the FTP Server Configuration menu must be the IP 
address of a FTP server.

NOTE: Any firewall between the FTRA and the FTP server configured in 
the FTP Server Configuration Menu window (Figure 62 on page 67), must 
allow FTPs to the IP address specified in the FTP Server Configuration 
Menu window.

Procedure

1. Select Edit > FTP Server Configuration from the FTP-based Table Retrieve 
Application menu.  See Figure 61.

Figure 61. FTP Server Configuration Menu in the FTP-Based 
Table Retrieve Application Window

The FTP Server Configuration Menu window opens.  See Figure 62 on page 67 
and Table 3 on page 67.

STP Connection Configuration

FTP Server Configuration

Commands

FTP Server Configuration
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Figure 62. FTP Server Configuration Menu Window

2. Enter the IP address of the STP in the IP Address field.  See .

NOTE: If the format is not entered correctly, the Invalid IP Address 
warning window is displayed.  See Figure 63 on page 68.

Table 3. FTP Server Configuration Menu Window Descriptions 

Item Description

Fields

IP Address The IP Address of the associated STP

Path The complete path to the data tables transfer directory on the 
STP.

This directory must be given complete read/write/execute 
permissions for all users.  From Windows, this is commonly 
administered from within the FTP server software.  From 
Unix, this is done with the chmod command.  Please refer to 
your PC system documentation or Unix man pages for full 
details on setting directory permissions.

Subpath The value used by the path parameter of the EAGLE 5 ISS 
ent-ftp-serv/chg-ftp-serv commands.  The subpath is 
relative to the user's default directory upon FTP login.  A file 
separator ('\' or '/') is not used to begin the subpath string.

Buttons

Browse Opens the Select Starting Directory window to initiate a 
directory/file selection dialog for the data tables.

Set Stores the FTP server configuration data. 

Close Closes the FTP Server Configuration Menu window.
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Figure 63. Invalid IP Address Error Message

3. Enter the path for the FTP temporary data table storage area or click the 
Browse button.  

If the Browse button is clicked, the Select Starting Directory window opens 
to select the location for the temporary data table storage area to be entered in 
Path field.  See Figure 64 and Table 4 on page 69.

This directory must be given complete read/write/execute permissions for all 
users.  From Windows, this is commonly administered from within the FTP 
server software.  From Unix, this is done with the chmod command.  Please 
refer to your PC system documentation or Unix man pages for full details on 
setting directory permissions.

Figure 64. Select Starting Directory Window
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4. Enter the Subpath.  The subpath must always be the last part of the path.  The 
subpath is relative to the user's default directory upon FTP login.  A file 
separator ('\' or '/') is not used to begin the subpath string.  If an invalid 
Subpath is entered, a warning window opens.  See Figure 65.

Figure 65. Invalid Subpath Window

Table 4. Select Starting Directory Window Descriptions 

Item Description

Fields

Look in: A drop down menu that allows the user to browse 
through the directory structures.

File Name: The name of the file to be selected.

Files of type: A drop down menu that allows the user to select all files 
of a particular type.

Buttons

Select Takes the contents of the File Name field and loads it 
into the Path field of the menu

Cancel Closes the Select Starting Directory window.
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5. Click the Set button.  See Figure 66. 

Figure 66. FTP Server Configuration Example

The FTP Server Data Set window opens.  See Figure 67. 

Figure 67. FTP Server Data Set Window

Click OK to continue.
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Retrieve Database Tables from an STP

Retrieve Tables Window

The Retrieve Tables window (see Figure 69 on page 72) is used to select the 
database tables you wish to retrieve from the selected STP.  The Retrieve Tables 
window contains a list of predefined retrieve commands.  Any number of the 
retrieve commands can be selected from the Command List box and moved to the 
Selected Commands box.  Clicking the Retrieve button causes the database tables 
associated with the selected retrieve commands to be transferred from the 
selected STP.  

The Retrieve from STP and Retrieve from Local Database buttons determine 
whether new database tables are retrieved from the selected STP or if existing 
tables already retrieved from that STP will be used.  If no tables exist for the 
selected STP, the Retrieve from Local Database button will be grayed out.  

The output from the retrieve commands is converted to CSV files.  When the 
retrieve operation is completed, the Command Complete window opens 
notifying the user if the retrieve was executed with or without errors.  The 
Retrieve Tables Log opens allowing the user to view the events.

CAUTION: Starting with FTRA 2.0, if you attempt to retrieve and convert 
the database tables for these GTT commands (rtrv-tt, rtrv-gtt) and 
these EGTT commands (rtrv-gttsel, rtrv-gttset, rtrv-gta) in the same 
retrieve tables request, you will receive a warning (Figure 68) that errors can 
be caused by attempting to retrieve and convert the GTT and EGTT 
database tables from the same EAGLE 5 ISS.  

You may only retrieve and convert the tables corresponding to which 
feature is on, GTT or EGTT.  If the EGTT feature is on, shown in the 
rtrv-feat output, the database tables for the rtrv-gttsel, rtrv-gttset, 
and rtrv-gta commands can be retrieved and converted.  If the EGTT 
feature is off, the database tables for the rtrv-tt and rtrv-gtt commands 
can be retrieved and converted.

The errors will be caused when the retrieved GTT and EGTT database 
tables are converted to CSV files.  Because only one set of the database 
tables, GTT or EGTT, can be retrieved, only that set of the database tables 
can be converted.  The error will occur when the attempt is made to convert 
that database tables that could not be retrieved.

Figure 68. GTT Warning Window
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Figure 69. Retrieve Tables Window

Table 5 on page 73 shows the description of the fields and buttons in the Retrieve 
Tables window.
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In FTRA releases 1.x and 2.x, the FTRA could operate only with one release of the 
EAGLE 5 ISS.  Starting with FTRA 3.0, the FTRA can operate with any of these 
EAGLE 5 ISS releases: 29.0, 30.0, 30.2, 31.3, 31.6, 31.9, 32.0 and later.  EAGLE 5 ISS 
releases 32.0 and later are supported if that release supports CSV file output.  

Table 5. Retrieve Tables Window Description 

Item Description

Fields

Command List Contains a predefined list of retrieve commands. 

Selected 
Commands

These commands are used to determine which database 
tables are retrieved from the selected STP.
From one to all of the retrieve commands can be selected 
for retrieval.

Buttons

Add Moves the highlighted commands from the Command 
List box to the Selected Commands box. 

Remove Moves any highlighted commands in the Selected 
Commands box back to the Command List box and 
places them in the Command List box in alphabetical 
order.

Reset Moves all commands in the Command List box to the 
Selected Commands box.  All highlights in the Selected 
Commands box are removed.

Retrieve Initiates the retrieval of all the selected database tables 
represented by the selected retrieve commands.  The 
database tables are transferred using an FTP connection 
and converted to CSV files.

Store Stores the commands in the Selected Commands box 
which will be used by the Command Line Interface.  This 
list is maintained even when the FTRA is shut down and 
restarted. 

Load Loads the commands into the Selected Commands box 
which are currently stored for Command Line Interface 
usage. This allows the user to verify rtrv commands 
which will be executed by the Command Line Interface.

Retrieve from 
STP

Retrieves the database tables, based on the selected 
retrieve commands, from the selected STP instead of 
using the tables previously retrieved.

Retrieve from 
Local Database

When selected, the FTRA uses the database table 
previously retrieved from the selected STP.

Close Closes the Commands Menu window.
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When a Retrieve Tables command is performed, FTRA 3.0 verifies that the 
EAGLE 5 ISS is running one of the supported releases.  If the EAGLE 5 ISS release 
is not supported, an error message is displayed and the Retrieve Tables command 
is terminated.  See Figure 70.

Figure 70. Retrieve Table Log - Release Not Compatible Error

If the EAGLE 5 ISS release is supported, the Retrieve Tables command is 
performed and operations on the FTRA can continue.

2005-01-31 15:40:22:442: Retrieve Process Manager: Purging FTP Transfer Area
2005-01-31 15:40:22:473: Retrieve Process Manager: Purging STP Data Area for: DANSTP1
2005-01-31 15:40:22:489: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle: 192.168.54.51:23
2005-01-31 15:40:22:505: Telnet Terminal Session Manager: Session Connected: 192.168.54.51:1699
2005-01-31 15:40:23:676: Telnet Terminal Session Manager: Sending Eagle Command: 18
2005-01-31 15:40:23:895: Telnet Terminal Session Manager: Terminal 18 Enabled
2005-01-31 15:40:24:895: Telnet Terminal Session Manager: User “eagle” Login Attempt: 1
2005-01-31 15:40:25:911: Telnet Terminal Session Manager: Sending Eagle Command: login:uid=eagle
2005-01-31 15:40:28:223: Telnet Terminal Session Manager: User “eagle” Login Accepted
2005-01-31 15:40:28:223: Telnet Terminal Session Manager: Sending rtrv-gpl command to Eagle
2005-01-31 15:40:29:239: Telnet Terminal Session Manager: Sending Eagle Command: rtrv-gpl
2005-01-31 15:40:34:38: Telnet Terminal Session Manager: Received string029-051-030
2005-01-31 15:40:34:395: Telnet Terminal Session Manager: FTRA not supported for this Eagle Release:null
2005-01-31 15:40:34:505: Retrieve Process Manager: Telnet Terminal Session Complete With Errors
2005-01-31 15:40:34:52: Retrieve Process Manager: Closing Connections, Please Wait
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Procedure

1. Select Edit > Commands > Retrieve Tables from the FTP-Based Table 
Retrieve Application window.  See Figure 71.  The Retrieve Tables window 
opens.  See Figure 69 on page 72.

Figure 71. Commands Menu in the FTP-Based Table Retrieve 
Application Window

2. To select commands in the Command List box of the Retrieve Tables window, 
perform one of these steps:

a. To select a single command, click on the command and it is highlighted.  
See Figure 72.

Figure 72. Selecting a Command
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b. To select a range of commands, click on the first command and while 
holding down the Shift key, click on the last command to be selected.  
All the commands in between the selected commands are highlighted, 
along with the selected commands.  See Figure 73.

Figure 73. Selecting a Range of Commands

c. To select multiple commands, select the first command, then hold down 
the Ctrl key and click on each of commands to be selected.  The selected 
commands are highlighted.  See Figure 74 on page 77.  

NOTE: If you have selected any of these GTT commands (rtrv-tt, 
rtrv-gtt) and these EGTT commands (rtrv-gttsel, rtrv-gttset, 
rtrv-gta) in substeps b or c, see the Caution on page 71.
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Figure 74. Selecting Multiple Commands
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3. To move the commands selected in step 2 to the Selected Commands box, 
click the Add button.  The commands are moved to Selected Commands box.  
See Figure 75, Figure 76 on page 79, and Figure 77 on page 80.

Figure 75. Adding a Command to the Selected Commands 
Box
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Figure 76. Adding a Range of Commands to the Selected 
Commands Box
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Figure 77. Adding Multiple Commands to Selected Commands 
Box

NOTE: If no commands are being moved from the Selected Commands 
box to the Command List box, skip step 4 and go to step 5.

4. To remove commands from the Selected Commands box, perform one of 
these steps:

a. In the Selected Commands box, click on the command to be removed 
and it is highlighted.  Click the Remove button.  The highlighted 
command is moved to the Command List box.  See Figure 78 on page 81.

b. To select a range of multiple commands to be removed, click on the first  
command and while holding down the Shift key, click on the last 
command to be removed.  Click the Remove button.  All highlighted 
commands are moved to the Command List box.

c. Hold down the Ctrl key and click on each of commands to be removed.  
Click the Remove button.  Only the highlighted commands are moved to 
Command List side.  See Figure 79 on page 81.

NOTE: When a command is removed from the Selected Commands box, 
the command is placed in the Command List box in alphabetical order.

d. Click the Reset button.  All commands in the Command List box are 
moved to the Selected Commands box.  All highlights in the Selected 
Commands box are removed.
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Figure 78. Command Selected to be Removed in the Selected 
Commands Box

Figure 79. Command Removed from the Selected Commands 
Box
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NOTE: If command information from only the selected STP is being 
retrieved, and the Command Line Interface is not being used, skip step 5 
and go to step 6.

5. To store the selected commands for the Command Line Interface, click the 
Store button on the Commands Menu window.  The Command Data Stored 
window opens.  See Figure 80.

Figure 80. Command Data Stored Window

Click OK to continue.

To verify what retrieve commands are stored, click the Load button.  The 
stored commands appear in the Selected Commands box, as shown in Figure 
75 on page 78, Figure 76 on page 79, or Figure 77 on page 80.

To use the Command Line Interface, go to the “Command Line Interface” 
section on page 93.

NOTE: If database tables are to be retrieved from the selected STP, skip 
step 6 and go to step 7.

6. To generate CSV files from database tables already retrieved from the selected 
STP, select the Retrieve from Local Database button after selecting the 
desired commands.  See Figure 81 on page 83.  Click the Retrieve button.
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Figure 81. Retrieving Database Tables from the Local Database

NOTE: If step 6 was performed, skip step 7.  This procedure is finished.

7. Retrieve the database tables from the selected STP corresponding to the 
commands selected in step 2 by selecting the Retrieve from STP button, then 
click the Retrieve button.  The Retrieve Tables Log window opens (see Figure 
82 on page 84) and displays the message “Processing Retrieve Request, Please 
Wait” until the retrieve process completes.

NOTE: The telnet terminals on the EAGLE 5 ISS to which FTRA will be 
connecting should have their terminal settings set to all=no (use the 
EAGLE 5 ISS command chg-trm:trm=<telnet terminal>:all=no to make 
this setting; use the EAGLE 5 ISS command rtrv-trm to verify the EAGLE 
5 ISS terminal settings).  On an STP with heavy UIM output, this prevents 
the FTRA's terminal from being flooded with unrelated output, which 
could unnecessarily backlog command responses during FTRA operation.

NOTE: If you are retrieving the database tables for any of these GTT 
commands (rtrv-tt, rtrv-gtt) and any of these EGTT commands 
(rtrv-gttsel, rtrv-gttset, rtrv-gta), see the Caution on page 71.
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Figure 82. Retrieve Tables Log Window - Processing Retrieve 
Request

This message is displayed until the retrieve process completes.  The 
Command Complete window opens. 

a. If no errors occurred, the text ”Retrieve Tables processing completed 
without errors.” “Please check Retrieve Tables Log for Results.” appears 
in the Command Complete window.  See Figure 83.

Figure 83. Command Complete Window Without Errors

Click OK, to continue.

b. If errors occurred, the text ”Retrieve Tables processing completed with 
errors.” “Please check Retrieve Tables Log for Results.” appears in the 
Command Complete window.  See Figure 84 on page 85.

2002-09-03 09:04:57.716: Retrieve Process Manager: Purging Existing Tables For: stp1
2002-09-03 09:04:57.796: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-09-03 09:04:57.806: Telnet Terminal Session Manager: Session Connected: 10.1.2.10:8080
2002-09-03 09:04:58.988: Telnet Terminal Session Manager: Terminal 17 Enabled
2002-09-03 09:04:59.989: Telnet Terminal Session Manager: User "eagle" Login Attempt: 1
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Figure 84. Command Complete Window With Errors

The Retrieve Table Log window opens.  See Figure 85 on page 86 and Figure 
86 on page 87.  Click OK, to continue.
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Retrieve Tables Log 

The Retrieve Tables Log contains the events of the retrieve processing and any 
error messages that may have occurred.  The Retrieve Tables Log window is 
opened after database tables have been retrieved from an STP and is displayed 
until the retrieve processing is complete (see Figure 82 on page 84).

The Retrieve Tables Log displays the information of the CSV files generated for 
the selected retrieve commands. The filenames of the CSV files are displayed in 
ascending order except for the filename of the rtrv-stp CSV file. Since the 
rtrv-stp command CSV is not generated by the CSVGEN(X) utility, the CSV 
filename for the rtrv-stp command is not displayed in the sorted order with 
other CSV filenames, but it is displayed as the last entry in the filenames list.  
Since the Retrieve Tables Log is generated by the CSVGEN(X) utility, no record of 
processing the rtrv-stp command is displayed in this log. See Figure 87 on page 
87 for an example of the Retrieve Tables Log when the rtrv-stp command is 
processed.

The log is automatically cleared when the next set of database tables are retrieved 
from an STP.  Selecting View > Retrieve Tables Log from the menu also opens 
the Retrieve Tables Log window.  See Figure 85 and Figure 86 on page 87.

Figure 85. Retrieve Tables Log Window without Errors

2002-12-05 08:19:09.488: Retrieve Process Manager: Purging FTP File Transfer Area
2002-12-05 08:19:09.579: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-12-05 08:19:09.639: Telnet Terminal Session Manager: Session Connected: 10.2.1.74:8080
2002-12-05 08:19:10.8: Telnet Terminal Session Manager: Sending Eagle Command: 17
2002-12-05 08:19:10.911: Telnet Terminal Session Manager: Terminal 17 Enabled
2002-12-05 08:19:11.912: Telnet Terminal Session Manager: User "eagle" Login Attempt: 1
2002-12-05 08:19:12.923: Telnet Terminal Session Manager: Sending Eagle Command: login=uid=eagle
2002-12-05 08:19:14.205: Telnet Terminal Session Manager: User "eagle" Login Accepted
2002-12-05 08:19:14.215: Telnet Terminal Session Manager: Analyzing FTP-SERV APP=USER Accounts on Eagle
2002-12-05 08:19:15.247: Telnet Terminal Session Manager: Sending Eagle Command: rtrv-ftp-serv:app=user
2002-12-05 08:19:15.758: Telnet Terminal Session Manager: Updating Eagle FTP SERV Table
2002-12-05 08:19:16.769: Telnet Terminal Session Manager: Sending Eagle Command: dlt-ftp-serv:app=user:ipaddr=1.2.3.4
2002-12-05 08:19:16.899: Telnet Terminal Session Manager: Updating Eagle FTP SERV Table
2002-12-05 08:19:17.911: Telnet Terminal Session Manager: Sending Eagle Command: dlt-ftp-serv:app=user:ipaddr=100.101.102.1
2002-12-05 08:19:18.071: Telnet Terminal Session Manager: Updating Eagle FTP SERV Table
2002-12-05 08:19:19.082: Telnet Terminal Session Manager: Sending Eagle Command: ent-ftp-serv:app=user:ipaddr=10.2.1.74:login=e
2002-12-05 08:19:20.324: Telnet Terminal Session Manager: Instructing Eagle to Activate Table Transfers
2002-12-05 08:19:21.346: Telnet Terminal Session Manager: Sending Eagle Command: ACT-FTP-TRNS:ACTION=PUT:FILETYPE=ALL
2002-12-05 08:19:21.556: Telnet Terminal Session Manager: ALL Fileset Table Transfer Started, This May Take Several Minutes
2002-12-05 08:19:21.666: Telnet Terminal Session Manager: ALL Fileset Table Transfer Complete
2002-12-05 08:19:21.776: Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1
2002-12-05 08:19:22.828: Telnet Terminal Session Manager: Sending Eagle Command: logout
2002-12-05 08:19:22.978: Telnet Terminal Session Manager: User "eagle" Logout Accepted



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 87

Figure 86. Retrieve Table Log with Errors

Figure 87. Retrieve Table Log with the RTRV-STP Command

2002-08-20 12:23:58.683: Retrieve Process Manager: Purging Existing Tables
2002-08-20 12:23:58.804: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-08-20 12:24:19.754: Telnet Terminal Session Manager: Session Not Connected: 10.1.2.10:8080
2002-08-20 12:24:19.774: Retrieve Process Manager: Telnet Terminal Session Test Complete With Errors

2006-09-27 15:42:39.584: Retrieve Process Manager: The Following .CSV Files Have Been Generated:
2006-09-27 15:42:39.599:                      F:\sw_ftra\stp\EAGLE\csv\card_20020914_1321.csv
2006-09-27 15:42:39.615:                      F:\sw_ftra\stp\EAGLE\csv\ls_20020914_1321.csv
2006-09-27 15:42:39.631:                      F:\sw_ftra\stp\EAGLE\csv\stp_20020914_1321.csv
2006-09-27 15:42:39.865: Retrieve Process Manager: Closing Connections, Please Wait
CVSGEN: Begin Initializing DRMS (23 MB).

CSVGEN: Skipped Initializing DRMS Tables.

CSVGEN: Completed Initializing DRMS.

LINE 1: rtrv-card

   tekelecstp 06-09-27 15:42:39 EST  36.0.0-57.4.0
   Command Accepted
   F:\sw_ftra\stp\EAGLE\csv\card_20020914_1321.csv file generated
;

LINE 2: rtrv-ls

   tekelecstp 06-09-27 15:42:39 EST  36.0.0-57.4.0
   Command Accepted
   F:\sw_ftra\stp\EAGLE\csv\ls_20020914_1321.csv file generated
;

LINE 3: exit
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Retrieve Tables Log File Menu

The File menu in the Retrieve Tables Log window, shown in Figure 88, provides 
these selections:

• Clearing the Retrieve Tables Log display

• Printing the Retrieve Tables Log

• Saving the Retrieve Tables Log to a file

• Closing the Retrieve Tables Log window.

Figure 88. File Menu in the Retrieve Tables Log Window

Clearing the Retrieve Tables Log Display

The display can be cleared, enabling new entries to be captured to the log.  Once 
the log is cleared, the existing entries are lost unless the log is save to a file or 
printed before the display is cleared. 

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Clear Display in the Retrieve Tables Log window.  See Figure 88.

                         22.64                       c:\ftra2\bin\feat_20020820_1226.csv
PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

LINE 1: rtrv-feat

    tekelecstp  02-08-20  12:26:21  EST  Rel 29.0.0-46.0.0
    Command Accepted
    feat_20020820_1226.csv file generated
;

LINE 2: exit

Clear Display

Print

Save

Close
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2. Select View > Retrieve Tables Log from the View menu in the FTP-based 
Table Retrieve Application window.  See Figure 89.  The Retrieve Tables Log 
window opens.

Figure 89. View Menu

3. Select File > Clear Display in the Retrieve Tables Log window.  The Retrieve 
Tables Log display clears.

Printing the Retrieve Tables Log

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Print in the Retrieve Tables Log window.  See Figure 88 on page 
88.

2. Select View > Retrieve Tables Log from the View menu in the FTP-based 
Table Retrieve Application window.  See Figure 89.  The Retrieve Tables Log 
opens.

3. Select File > Print in the Retrieve Tables Log window.  The Print window 
opens.  See Figure 90 on page 90.
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Figure 90. Print Window

4. Configure the printer settings.

5. To print the Retrieve Tables Log, click the OK button in the Print window.  
The current contents of the Retrieve Tables Log are printed.

6. If you decide not to print the Retrieve Tables Log, click the Cancel button in 
the Print window.

Saving the Retrieve Tables Log to a File

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Save in the Retrieve Tables Log window.  See Figure 88 on page 
88.

2. Select View > Retrieve Tables Log from the View menu in the FTP-based 
Table Retrieve Application window.  See Figure 89 on page 89.  The Retrieve 
Tables Log window opens.

3. Select File > Save in the Retrieve Tables Log window.  The Save window 
opens.  See Figure 91 on page 91.
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Figure 91. Save Window

4. Select a location for the file, and enter the file name and file type (with either 
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use 
Microsoft Word to open the file, even if it was saved as a .txt file. 

NOTE: If you decide not to save the file, do not perform steps 5 and 6, but  
click Cancel in the Save window.

5. Click the Save button.  A Saved file confirmation window opens with “Data 
saved to file.” See Figure 92.

Figure 92. Saved File Confirmation Window

6. To save the file, click OK in the Saved file confirmation window to continue. 
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Closing the Retrieve Tables Log Window

Procedure

1. Select File > Close in the Retrieve Tables Log window, or click the close 
window button in the upper right hand corner of the Retrieve Tables Log 
window.  See Figure 88 on page 88.  The Retrieve Tables Log window closes.
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Command Line Interface

The FTRA Command Line Interface allows the user to retrieve the same database 
tables, using the EAGLE 5 ISS’s retrieve commands, from all configured STPs in 
the STP configuration database.  The Store and Load buttons in the Retrieve 
Tables window are used to select these retrieve commands.  See “Retrieve 
Database Tables from an STP” on page 71.

Before the Command Line Interface can be started, you must exit the FTRA 
application.  To start the Command Line Interface retrieve process, enter the 
ftra -c command at the DOS command prompt (in Windows) or at a shell 
command prompt (in UNIX).  

The user can automate this retrieve process through the use of external 
scheduling software such as Task Scheduler (on the Windows platform) and 
“cron” (on the Unix platform).  Please refer to the platform's scheduling program 
for specifics on how to use the external scheduling software.  For example, on the 
Unix platform, enter the man crontab command.  

Procedure – Command Line Interface Manual Start

1. Exit the FTRA application.  See “Exit the FTRA” on page 29.

2. On the Windows platform, at a DOS prompt, go to the \bin directory of the 
FTRA <install_directory> location. 

3. On the Unix platform, at a shell prompt, go to the /bin directory of the FTRA 
<install_directory> location.

4. Enter the ftra -c command (see Figure 93 on page 94 or Figure 94 on page 
94).  The stored rtrv commands are sent to all provisioned STPs.  The data 
tables are retrieved and converted to the CSV file format. 
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Figure 93. FTRA Windows Command Line Interface

Figure 94. FTRA UNIX Command Line Interface

C:\ftra\bin>ftra -c
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Procedure – Command Line Interface Automatic Start

1. Enter the ftra -c command, the path to the bin directory of the FTRA 
<install_directory>, the start time of the external scheduling software such as 
Task Scheduler (in Windows, see Figure 95) and “cron” (in Unix, see Figure 96 
on page 96).

When the start time is reached, The stored rtrv commands are sent to all 
provisioned STPs.  The data tables are retrieved and converted to CSV file 
format.

NOTE: If you are using “cron” on the Unix workstation, it might be 
necessary to create a wrapper script for FTRA, in order to correctly set 
environment variables.  For an example of the wrapper script, see Figure 97 
on page 96.

Figure 95. FTRA Windows Task Scheduler
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Figure 96. UNIX cron Job Scheduled using crontab

NOTE:  The last line shows that the FTRA is scheduled to run at 3:00 AM 
Monday through Friday.

Figure 97. CRON FTRA Wrapper Script



FTP-Based Table Retrieve Application (FTRA) User Guide

910-3489-001 Rev D, October 2006 97

Updating Database Tables in the Selected STP

The Update Tables window (see Figure 98) is used to send EAGLE 5 ISS 
commands to the selected STP.  The commands, in the form of a command file, are 
validated before being sent. 

To send the command file to the selected STP, the command file is selected by 
entering the path and file name of the command file, or by selecting the file name 
of the command file from the Select window.  The command file is then validated 
by clicking the Validate button in the Update Tables window.  When the 
validation is completed, the Update Validation Complete window appears.  
From the Update Validation Complete window the command file can be edited, 
sent to the selected STP, or the Update Validation Complete window can be 
closed without sending the command file to the selected STP.  The Update Tables 
Log contains the events of the command validation and any error messages that 
may have occurred.

Figure 98. Update Tables Window
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Table 6 shows the description of the fields and buttons in the Update Tables 
window.

Validating a Command File

Procedure

1. Select Edit > Commands > Update Tables in the FTP-based Table Retrieve 
Application window.  See Figure 99.  The Update Tables window opens.  See 
Figure 98 on page 97.

Figure 99. Edit Menu

Table 6. Update Tables Window Description 

Item Description

Fields

Command 
File

The path and file name of the command file are entered here.  
A command file contains the EAGLE 5 ISS commands used to 
modify database tables of the STP.

Stop on error 
box

If the box is checked, and an error is found during the 
validation of the commands, the validation stops and no 
further commands are validated.  If the box is not checked, all 
commands are processed regardless of errors.  The error 
results are displayed in the Update Tables Log.

Buttons

Browse Opens the Select window to select the command file to send 
to the selected STP.

Validate Validates the EAGLE 5 ISS commands using the offline 
database.

Close Closes the Commands Menu window.
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2. Perform one of these steps.

a. Enter the path and name of the command file in the Command File field.  
See Figure 100.

Figure 100. Update Tables with a Command File Selected

b. Click the Browse button.  The Select window is opened.   See Figure 101 
on page 100.  Find the folder containing the command file and click on 
the command file name.  The command file name is highlighted.  Click 
the Select button.  The Select window disappears and the Update 
Tables window appears with the path and file name of the selected 
command file entered in the Command File field.

If you wish to cancel the command file selection process in the Select 
window, click the Cancel button.

Table 7 on page 100 shows the description of the buttons in the Select 
window.

C:\ftra2\scripts\feat.txt
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Figure 101. Select Window

Table 7. Select Window Descriptions 

Item Description

Fields

Look in: A drop down menu allowing the user to browse through 
the directory structures.

File Name: The name of the file to be selected.

Files of type: A drop down menu that selects all files.

Buttons

Select The contents of the File Name field and the path to the 
filename is loaded into the Command File field of the 
Update Tables window.

Cancel Closes the Select window.
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3. If you wish to have the command validation stop if any errors are found, 
check the Stop on error box in the Update Tables window.  See Figure 102.  If 
you wish to have the command validation processed regardless of any errors, 
uncheck the Stop on error box.  The error results are displayed in the Update 
Tables Log.

Figure 102. Update Tables Window with a Command File 
Selected and Stop on Error Box Checked

C:\ftra2\scripts\feat.txt
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4. Click the Validate button.  The Update Tables Log window opens at the 
beginning of the validate process and displays the “Processing Validate 
Request, Please Wait” message until the validation of the command file is 
complete.  See Figure 103.

Figure 103. Update Tables Log Window - Processing Retrieve 
Request

The Update Validation Complete window opens.  See the “Update Validation 
Complete Window” section on page 103.

5. The Update Tables Log window opens.  It contains the events and error 
messages generated during the validation.  See Figure 113 on page 108, Figure 
114 on page 109, and Figure 115 on page 110 for Update Tables Log examples.

NOTE: If there is no entry in the Command File field and the Validate 
button is clicked, a warning message is displayed stating that a command 
file name must be entered.  See Figure 104.

Figure 104. Must Enter Command Script File Name 
Message

    VGTT  = off   MGTT  = off   MPC  = off
    ITUDUPPC  = off   GFLEX  = off   LNP18MIL  = off
    GSMSCRN  = off   GPORT  = off   LNP48MIL  = off
    MEASPLAT  = off   TSCSYNC  = off   E5IS  = off
;

LINE 6: rtrv-feat

    tekelecstp  02-09-03  09:20:05  EST  Rel 29.0.0-46.0.0
    rtrv-feat
    Command entered at terminal #4.
    EAGLE FEATURE LIST

    GTT  = off   GWS  = off   NRT  = off
    X25G  = off   LAN  = off   CRMD  = off
    SEAS  = off   LFS  = off   MTPRS  = off
    LNP  = off   FAN  = on   DSTN5000  = off
    WNP  = off   CNCF  = off   LNP12MIL  = off
    TLNP  = off   SCCPCNV  = off   TCAPCNV  = off
    IPISUP  = off   DYNRTK  = off   X252000  = off
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Update Validation Complete Window

When the command validation has completed, the Update Validation Complete 
window opens notifying the user if the commands validated with or without 
errors.  From the Update Validation Complete window, the command file can be 
edited, sent to the selected STP, or the window can be closed without sending the 
command file to the selected STP.  See Figure 105.

Figure 105. Update Validation Complete Window without 
Errors

Table 8 shows the description of the buttons in the Update Validation Complete 
window.

Table 8. Update Validation Complete Window Description 

Item Description

Edit Opens the Command File Editor window and allows the user 
to make changes to the command file.  To edit a command file, 
go to the “Editing a Command File” section on page 105.

Commit Sends the commands in the command file to the STP.  A 
Command Complete window opens and the Update Tables 
Log is updated.  See the “Sending a Command File to the 
Selected STP” section on page 104.
If the Update Tables validation completed with errors the 
Commit button is not displayed.

Stop Closes the Update Validation Complete window without 
sending the commands in the command file to the STP.
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Update Validation Complete Window with Errors

If the Update Validation Complete window shows that errors have occurred, the 
command file can be edited or the window can be closed without sending the 
command file to the selected STP.  See Figure 106.  There is no Commit button in 
this window; this prevents the sending of invalid commands. 

To fix the errors in the command file, click the Edit button, then go to the “Editing 
a Command File” section on page 105.

Figure 106. Update Validation Complete Window with 
Errors

Sending a Command File to the Selected STP 

To send the command file, click the Commit button in the Update Validation 
Complete window.  The Commit button is shown only on the Update Validation 
Complete without Errors window.  See Figure 105 on page 103.  The validated 
command file is sent to the selected STP.

The Command Complete window opens and displays: “Update Tables 
processing completed without errors” and “Please check Update Tables Log for 
results.” See Figure 107.  Click OK, to continue.  The Update Tables Log contains 
the commit processing events.  See Figure 113 on page 108.

Figure 107. Command Complete Window
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Stop Without Sending or Editing a Command 
File

To stop the process without sending or editing a command file, click the Stop 
button in the Update Validation Complete window.  See Figure 105 on page 103.  
The Update Validation Complete window is closed.  No changes are made to the 
command file and the command file is not sent to the selected STP.

Editing a Command File

To edit a command file, click the Edit button in the Update Validation Complete 
window.  The Command File Editor window is opened.  See Figure 108.

Figure 108. Command File Editor Window

When the editing is complete, the command file can be saved without sending the 
command file to the selected STP, saved and sent to the selected STP without any 
further validation, or the command file can be closed without saving the changes 
to the command file.  

chg-feat:fan=on
rtrv-feat
|
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Procedure

1. Click the Edit button in the Update Validation Complete window.  See Figure 
105 on page 103.  The Command File Editor window opens.  See Figure 108 
on page 105.

NOTE: The hourglass is displayed until the Command File Editor 
window is closed.

NOTE: If an attempt is made to close the Update Tables window while 
the Command File Editor window is opened, the Command In progress, 
Cannot Close Window warning message is displayed.  See Figure 109.

Figure 109. Command In progress, Cannot Close Window

2. Edit the command file.  Figure 110 shows a command file with an invalid 
command.  In this example, the invalid command is chg-feat:.  This 
command should be removed from the command file, or have a correct 
parameter and value added to it.  

Figure 110. Command File Editor with Invalid Command

Invalid commandchg-feat:
chg-feat:fan=on
rtrv-feat
|

Invalid Command
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3. When the editing is complete, perform one of these steps.

a. Select File > Save from the Command File Editor window (see Figure 
111).  The command file is saved and the Command File Editor window 
remains open.  The command file is not sent to the selected STP.  The 
command file can be validated again in the Update Tables window.

Figure 111. File Menu in the Command File Editor Window

b. Select File > Save and Commit from the Command File Editor window 
(see Figure 111).  The command file is saved and the Command File 
Editor window closes.  The Command Complete window opens and 
displays: “Update Tables processing completed without errors.  Please 
check Update Tables Log for results.”  Click OK, to continue.  See Figure 
112.  The command file is sent to the selected STP.  The Update Tables 
Log contains the commit processing events.  See Figure 113 on page 108

Figure 112. Command Complete Window

c. Select File > Quit from the Command File Editor window (see Figure 
111).  The Command File Editor window closes.  The command file is 
not sent to the selected STP.  If changes to the command file have been 
made, a window is displayed asking if you want to save the changes.

Save

Save and Commit

Quit
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Update Tables Log Window

The Update Tables Log contains the processing events and any error messages 
that may have occurred during the validation and sending of a command file.  
The Update Tables Log window is opened at the beginning of the validation 
process and displays “Processing Validate Request, Please Wait” (Figure 103 on 
page 102) until the command file validation is completed.  The Update Tables 
Log window is automatically cleared when the next command file validation is 
started.  Selecting View > Update Tables Log from the menu can also open the 
Update Tables Log window. 

See Figure 113, Figure 114 on page 109, Figure 115 on page 110, and Figure 116 on 
page 111 for the Update Tables Log window examples.

Figure 113. Update Tables Log Window after the Commit 
Command Completed

   ITUMTPRS = off   SLSOCB = off   EGTT  = off
   VGTT  = off   MGTT  = off   MPC   = off
   ITUDUPPC = off    GFLEX  = off    LNP18MIL = off
   GSMSCRN = off     GPORT  = off    LNP48MIL = off
   MEASPLAT = off    TSCSYNC = off    E5IS  = off
;

LINE 4: exit
2002-08-21 09:17:50.844: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-08-21 09:17:51.034: Telnet Terminal Session Manager: Session Conneted: 66.26.93.175:8080
2002-08-21 09:17:52.276: Telnet Terminal Session Manager: Terminal 17 Enabled
2002-08-21 09:17:53.287: Telnet Terminal Session Manager: User "eagle" Login Attempt: 1
2002-08-21 09:17:55.521: Telnet Terminal Session Manager: User "eagle" Login Accepted
2002-08-21 09:17:55.651: Telnet Terminal Session Manager: Sending Command Updates to Eagle
2002-08-21 09:17:55.781: Telnet Terminal Session Manager: Sending Eagle Command:
2002-08-21 09:17:56.913: Telnet Terminal Session Manager: Sending Eagle Command: chg-feat:fan=on
2002-08-21 09:17:58.044: Telnet Terminal Session Manager: Sending Eagle Command: rtrv-feat
2002-08-21 09:17:59.176: Telnet Terminal Session Manager: Sending Eagle Command: exit
2002-08-21 09:18:00.308: Telnet Terminal Session Manager: Sending Eagle Command: exit
2002-08-21 09:18:01.439: Telnet Terminal Session Manager: Sending Eagle Command: exit
2002-08-21 09:18:02.571: Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1
2002-08-21 09:18:03.703: Telnet Terminal Session Manager: User "eagle" Logout Accepted
2002-08-21 09:18:04.103:  Commit Process Manager: Telnet Terminal Session Complete Without Errors
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Figure 114. Update Tables Log

2002-08-20 12:30:48.803:               cmd.exe/C c:\ftra2\bin\update.bat
2002-08-20 12:30:49.414: Table Updates: c:\ftra2\bin\update.bat Exit Code is: 0
2002-08-20 12:30:49.424: Table Updates: c:\ftra2\bin\update.bat Execution Complete
2002-08-20 12:30:49.434: Table Updates: c:\ftra2\bin\update.bat Executed Successfully
2002-08-20 12:30:49.444: Cmd Rej Search: Searching For Input Command Errors
PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

LINE 1: chg-feat:fan=on

    tekelecstp  02-07-26  09:01:20 EST  Rel 29.0.0-46.0.0
    chg-feat:fan=on
    Command entered at terminal #4.
    CHG-FEAT: MASP A - COMPLTD
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Figure 115. Update Tables Log with Stop on Error Box Checked 
in the Update Tables Window

Error message

2002-08-21 10:07:03.318: Validate Process Manager: Instructing PCTEST to Perform Updates
2002-08-21 10:07:03.328: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Created Successfully
2002-08-21 10:07:03.348: Terminal Security And Feature Change: Executing the following cmds:
2002-08-21 10:07:03.358:                                    cmd.exe/C c:\ftra2\bin\chgtrm.bat
2002-08-21 10:07:03.619: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Exit Code is: 0
2002-08-21 10:07:03.629: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Execution Complete
2002-08-21 10:07:03.649: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Executed Successfully
2002-08-21 10:07:03.669: Table Updates: c:\ftra2\bin\update.bat Created Successfully
2002-08-21 10:07:03.679: Table Updates: Executing the following cmds:
2002-08-21 10:07:03.689:               cmd.exe/C c:\ftra2\bin\update.bat
2002-08-21 10:07:04.29: Table Updates: c:\ftra2\bin\update.bat Exit Code is: 0
2002-08-21 10:07:04.31: Table Updates: c:\ftra2\bin\update.bat Execution Complete
2002-08-21 10:07:04.32: Table Updates: c:\ftra2\bin\update.bat Executed Successfully
2002-08-21 10:07:04.33: Cmd Rej Search: Searching for Input Command Errors
2002-08-21 10:07:04.35: Validate Process Manager: Command File C:\ftra\scripts\feat.txt Contains Errors, See Results Below
PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

LINE 1: chg-feat

    tekelecstp  02-08-16  10:07:04  EST  Rel 29.0.0-46.0.0
    chg-feat
    Command entered at terminal #4.
E2136 Cmd Rej: At least one optional parameter is required

    CHG-FEAT: MASP A - Command Aborted

Error message

Command from the
command file
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Figure 116. Update Tables Log with Stop on Error Box NOT 
Checked Error in the Update Tables Window 

Figure 110 on page 106 shows an example of a command file that produced the 
error shown in Figure 116.

Error message

2002-08-21 10:12:11.417: Validate Process Manager: Instructing PCTEST to Perform Updates
2002-08-21 10:12:11.417: Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Created Successfully
2002-08-21 10:12:11.417: Terminal Security and Feature Change: Executing the following cmds:
2002-08-21 10:12:11.417:                                cmd.exe/C c:\ftra2\bin\chgtrm.bat
2002-08-21 10:12:11.417: Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Exit Code is: 0
2002-08-21 10:12:11.417: Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Execution Complete
2002-08-21 10:12:11.417: Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Executed Successfully
2002-08-21 10:12:11.417: Table Updates: c:\ftra2\bin\update.bat Created Successfully
2002-08-21 10:12:11.417: Table Updates: Executing the following cmds:
2002-08-21 10:12:11.417:             cmd.exe/C c:\ftra2\bin\update.bat

2002-08-21 10:12:11.417: Table Updates: C:\ftra2\bin\update.bat Exit Code is: 0
2002-08-21 10:12:11.417: Table Updates: C:\ftra2\bin\update.bat Execution Complete
2002-08-21 10:12:11.417: Table Updates: C:\ftra2\bin\update.bat Executed Successfully
2002-08-21 10:12:11.417: Cmd Rej Search: Searching For Input Command Errors
2002-08-21 10:12:11.417: Validate Process Manager: Command File C:\ftra\scripts\command_files\feat.txt Contains Errors, See Results Below.
PCTEST: Begin Initializing DRMS (10MB)

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10MB)

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

Error message
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Figure 116. Update Tables Log with Stop on Error Box NOT 
Checked Error in the Update Tables Window (Continued)

File Menu in the Update Tables Log Window

The File menu in the Update Tables Log window, shown in Figure 117 on page 
113, provides the user with the following selections:

• Clearing the Update Tables Log display.

• Printing the Update Tables Log.

• Saving the Update Tables Log to a file.

• Closing the Update Tables Log window.

Commands from the
command file

LINE 1: chg-feat

    tekelecstp  02-08-20  12:33:27  EST  Rel 29.0.0-46.0.0
    chg-feat:
    Command entered at terminal #4.
E2136 Cmd Rej: At least one optional parameter is required

       CHG-FEAT: MASP A - Command Aborted

LINE 2: chg-feat:fan=on

    tekelecstp  02-08-20  12:33:27  EST  Rel 29.0.0-46.0.0
    chg-feat:fan=on
    Command entered at terminal #4.
    CHG-FEAT: MASP A - COMPLTD
;

LINE 3: rtrv-feat
    tekelecstp  02-08-20  12:33:27  EST  Rel 29.0.0-46.0.0
    rtrv-feat
    Command entered at terminal #4.
    EAGLE FEATURE LIST

    GTT  = on    GWS  = off   NRT  = off
    X25G  = off   LAN  = off   CRMD  = off
    SEAS  = off   LFS  = off   MTPRS  = off
    LNP  = off   FAN  = on   DSTN5000  = off
    WNP  = off  CNCF  = off   LNP12MIL  = off
    TLNP  = off   SCCPCNV  = off  TCAPCNV  = off
    IPISUP  = off   DYNRTK  = off   X252000  = off
    INP  =off   PLNP  = off   NCR  = off
    ITUMTPRS  = off   SLSOCB  = off   EGTT  = off
    VGTT  = off   MGTT  = off   MPC  = off
    ITUDUPPC  = off   GFLEX  = off   LNP18MIL  = off
    GSMSCRN  = off   GPORT  = off   LNP48MIL  = off
    MEASPLAT  = off   TSCSYNC  = off   E5IS  = off
;

LINE 4: exit

Commands from the
command file
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Figure 117. File Menu in the Update Tables Log Window 

Clearing the Update Tables Log Display

The display can be cleared, enabling new entries to be captured to the log.  Once 
the log is cleared, the existing entries are lost unless the log is save to a file or 
printed before the display is cleared. 

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Clear Display in the Update Tables Log window.  See Figure 117.

2. Select View > Update Tables Log in the FTP-based Table Retrieve 
Application window.  See Figure 118.  The Update Tables Log window opens.

Figure 118. View Menu

2002-08-21 10:25:59 .184: Tab le Updates: c:\ftra2\b in \update .bat Execution Com ple te
2002-08-21 10:25:59 .194: Tab le Updates: c:\ftra2\b in \update .bat Executed  Successfu lly
2002-08-21 10:25:59 .204: Cm d  Re j Search : Search ing  For Inpu t Com m and E rrors
PCTEST: Beg in  In itia liz ing  D RM S (10  M B ).

PCTEST: Skipped  In itia liz ing  DRM S Tab les.

PCTEST: Com p le ted In itia liz ing D RM S.

PCTEST: Beg in  In itia liz ing  D RM S (10  M B ).

PCTEST: Skipped  In itia liz ing  DRM S Tab les.

PCTEST: Com p le ted In itia liz ing D RM S.

LIN E 1: rtrv-fea t
    teke lecstp   02-08-21   10:25:59   EST   Re l 29 .0.0 -46 .0 .0
    r trv-fea t
    C om m and  en tered a t te rm ina l # 4.
    EAG LE FEATURE LIST

    G TT   =  on    GW S  =  o ff   N RT   =  o ff
    X 25G   =  o ff   LAN   =  o ff   CRM D   =  off
    SEAS  =  off   LFS  =  off   M TPRS  =  o ff
    LNP   =  o ff   FAN   =  on   DSTN5000  =  off
    W NP   =  o ff  CN CF  =  o ff   LN P12M IL   =  o ff
    T LNP   =  o ff   SCCPCNV   =  off  TCAPCNV   =  o ff
    IPISUP  =  off   DYN RTK  =  off   X252000  =  off
    INP   =off   P LN P  =  off   NCR   =  off
    ITUM TPRS  =  off   SLSO CB  =  off   EG TT   =  off
    V GTT   =  o ff   M G TT  =  off   M PC   =  o ff
    ITUDUPPC   =  o ff   G FLEX   =  o ff   LN P18M IL  =  o ff
    G SM SCRN   =  o ff   G PO RT   =  o ff   LN P48M IL  =  o ff
    M EASPLAT   =  o ff   TSCSYN C   =  o ff   E5IS  =  o ff
;

LIN E 2 : ex it

C lea r D isp lay

P rin t

Sa ve

C lose
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3. Select File > Clear Display in the Update Tables Log window.  The Update 
Tables Log display clears.

Printing the Update Tables Log

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Print from the Update Tables Log window.  See Figure 117 on 
page 113.

2. Select View > Update Tables Log in the FTP-based Table Retrieve 
Application window.  See Figure 118 on page 113.  The Update Tables Log 
opens.

3. Select File > Print from the Update Tables Log window.   The Print window 
opens.  See Figure 119.

Figure 119. Print Window

4. Configure the printer settings.
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5. To print the Update Tables Log, click the OK button.  The current contents of 
the Update Tables Log are printed.

6. If you do not wish to print the Update Tables Log, click the Cancel button.

Saving the Update Tables Log to a File

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Save from the Update Tables Log window.  See Figure 117 on 
page 113.

2. Select View > Update Tables Log in the FTP-based Table Retrieve 
Application window.  See Figure 118 on page 113.  The Update Tables Log 
opens.

3. Select File > Save in the Update Tables Log window.  The Save window 
opens.  See Figure 120. 

Figure 120. Save Window
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4. Select a location for the file, and enter the file name and file type (with either 
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use 
Microsoft Word to open the file even if it was saved as a .txt file. 

5. To save the file, click the Save button.  A Saved file confirmation window 
opens with “Data saved to file.” See Figure 121.  Click OK, to continue.

Figure 121. Saved Confirmation Window

6. If you do not wish to save the file, click the Cancel button in the Save 
window.

Closing the Update Tables Log Window

Procedure

1. Select File > Close in the Update Tables Log window, or click the close 
window button in the upper right hand corner of the Update Tables Log 
window.  See Figure 117 on page 113.  The Update Tables Log window closes.
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The System Log

The System Log contains an event history and any errors that have occurred 
when database tables are retrieved from an STP, or command files are sent to an 
STP.  See Figure 122.

Figure 122. System Log Window 

File Menu in the System Log Window

The File menu in the System Log window, shown in Figure 123 on page 118, 
provides these selections:

• Clearing the System Log display.

• Printing the System Log.

• Saving the System Log to a file.

• Closing the System Log window.

2002-08-26 08:31:10.509: Communications: Initialization Sequence Started
2002-08-26 08:31:10.539: Communications: Initialization Sequence Complete
2002-08-26 08:34:01.168: Command Request Handler: Process Command Request
2002-08-26 08:34:01.178: Retrieve Command Request Handler: Process Command Request
2002-08-26 08:34:01.258: Retrieve Process Manager: Process Begun For: stp1
2002-08-26 08:34:20.126: Retrieve Process Manager: Process Complete For: stp1
2002-08-26 08:34:58.612: Command Request Handler: Process Command Request
2002-08-26 08:34:58.622: Update Tables Command Request Handler: Process Command Request
2002-08-26 08:34:58.632: Update Tables Submit Action Handler: Process Command Request
2002-08-26 08:34:58.662: Validate Process Manager: Process Begun For: stp1
2002-08-26 08:34:59.113: Validate Process Manager: Process Complete For: stp1
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Figure 123. File Menu in the System Log Window 

Clearing the System Log Display

The display can be cleared, enabling new entries to be captured to the log.  Once 
the log is cleared, the existing entries are lost unless the log is saved to a file or 
printed before the display is cleared. 

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application 
window.  See Figure 124.  The System Log window opens. 

Figure 124. View Menu

2. Select File > Clear Display in the System Log window.  See Figure 123.  The 
System Log display clears.

2002-08-26 08:31:10.509: Communications: Initialization Sequence Started
2002-08-26 08:31:10.539: Communications: Initialization Sequence Complete
2002-08-26 08:34:01.168: Command Request Handler: Process Command Request
2002-08-26 08:34:01.178: Retrieve Command Request Handler: Process Command Request
2002-08-26 08:34:01.258: Retrieve Process Manager: Process Begun For: stp1
2002-08-26 08:34:20.126: Retrieve Process Manager: Process Complete For: stp1
2002-08-26 08:34:58.612: Command Request Handler: Process Command Request
2002-08-26 08:34:58.622: Update Tables Command Request Handler: Process Command Request
2002-08-26 08:34:58.632: Update Tables Submit Action Handler: Process Command Request
2002-08-26 08:34:58.662: Validate Process Manager: Process Begun For: stp1
2002-08-26 08:34:59.113: Validate Process Manager: Process Complete For: stp1

Clear Display

Print

Save

Close
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Printing the System Log

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application 
window.  See Figure 124 on page 118.  The System Log window opens.

2. Select File > Print in the System Log window.  The Print window opens.  See 
Figure 125.

Figure 125. Print Window

3. Configure the printer settings.

4. To print the System Log, click the OK button.  The current contents of the 
System Log are printed.

5. If you decide not to print the System Log, click the Cancel button.
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Saving the System Log to a File

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application 
window.  See Figure 124 on page 118.  The System Log opens.

2. Select File > Save in the System Log window.  The Save window opens.  See 
Figure 126.

Figure 126. Save Window

3. Select a location for the file, and enter the file name and file type (with either 
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use 
Microsoft Word to open the file even if it was saved as a .txt file. 
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4. To save the System Log to a file, click the Save button.  A Saved file 
confirmation opens with “Data saved to file”.  See Figure 127.  Click OK to 
continue.

Figure 127. Saved Confirmation Window

5. If you do not wish to save the System Log to a file, click the Cancel button in 
the Save window.

Closing the System Log Window

Procedure

1. Select File > Close in the System Log window, or click the close window 
button in the upper right hand corner of the System Log window.  The 
System Log window closes.
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About FTRA Window 

The About FTRA window displays the version level of the FTRA and copyright 
information.   To display the About FTRA window, select Help > About in the 
FTP-based Table Retrieve Application window.  See Figure 128.

Figure 128. Help Menu

The About FTRA window opens.  See Figure 129.  Click OK, to continue.

Figure 129. Typical About FTRA Window
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SSH/SFTP Error Codes

Table 9 and Table 10 on page 137 contain a list of the error codes that can be 
generated when making a secure connection between the FTRA, version 2.0 or 
greater, and the EAGLE 5 ISS.  Each error code contains a brief description of the 
error and the suggested recovery action.

This section also contains procedures, following Tables 9 and 10, for testing 
connectivity and network problems, and to verify that the setup for making 
secure connections is correct.

If secure connections to the EAGLE 5 ISS cannot be made, verify that the Eagle 
OA&M IP Security Enhancements feature is enabled and activated by entering the 
rtrv-ctrl-feat command at the EAGLE 5 ISS before performing any of the 
actions in Tables 9 and 10.  If the Eagle OA&M IP Security Enhancements feature 
is not enabled or activated, perform the “Activating the Eagle O&AM IP Security 
Enhancements Controlled Feature” procedure in the Database Administration 
Manual - System Management and enable and activate the Eagle OA&M IP Security 
Enhancements feature.

If any of the errors shown in Table 9 or Table 10 on page 137 are encountered after 
the recovery procedure is verified, contact the Customer Care Center.  Refer to 
page 3 for the contact information.

Table 9. FTP/SFTP/SSH Error Codes 

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery

User Errors

594 Invalid Path Verify that the path is valid in the FTP 
Server Configuration Menu window (see 
Figure 62 on page 67).

598 The SSHD daemon is not 
running on the destination 
system or the server IP address 
unavailable.

Verify that the IP address exists on 
network with a ping (Refer to the 
“Connectivity Test – I” section on page 140 
and the “Connectivity Test - II” section on 
page 141). If the IP address exists on 
network then verify that SSHD daemon is 
running on the destination machine using 
the ps -ef|grep sshd command.

629 The SFTP daemon is not 
running

Verify that the subsystem entry in the 
sshd_config file on the destination 
station is specified and points to the SFTP 
daemon.
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633 User login failure. Verify that the Username and Password in 
the STP Connection Configuration Menu 
window, (see Table 2 on page 32) is valid 
and an account exists for the username 
and password on the SSHD server host.

SFTP Errors

595 File open failed. Invalid file name in the download list, or 
out of resources.  Report this issue to the 
Customer Care Center immediately.  Refer 
to page 3 for the contact information.

596 The file name is already 
specified.

Report this issue to the Customer Care 
Center immediately.  (Internal SFTP 
implementation error).  Refer to page 3 for 
the contact information.

SFTP Client Errors

597 SFTP client packet send failure Perform these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

598 The SFTP connection is closed.

599 SFTP packet read failure

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery
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600 SFTP protocol error.  The 
received message is larger than 
the expected packet size.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
the tests in “Network Outage Trouble 
Shooting” section on page 142. If the error 
persists, report the issue to the Customer 
Care Center.  Refer to page 3 for the contact 
information.

601 Undefined Notify the Customer Care Center.  Refer to 
page 3 for the contact information.

608 SFTP received a invalid ID in 
the response received during a 
read operation on remote 
directory.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
the tests in “Network Outage Trouble 
Shooting” section on page 142. If the error 
persists, report the issue to the Customer 
Care Center.  Refer to page 3 for the contact 
information.

609 SFTP: Handle mismatch error. 
This error is displayed when 
there is a failure to receive an 
expected handle upon 
successful READ/WRITE/
CREAT/TRUNC/EXCL of a file 
using SSH_FXP_OPEN on 
remote server.

610 Unexpected SSH2_FXP_ATTRS.

611 Unexpected SSH_FXP_NAME.  
SFTP using the 
SSH_FXP_OPENDIR opens a 
directory for reading. The 
server responds to this request 
with either a SSH_FXP_NAME 
or a SSH_FXP_STATUS 
message. This error code 
implies that an unexpected 
SSH_FXP_NAME is received.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
the tests in “Network Outage Trouble 
Shooting” section on page 142. 

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery
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612 The SFTP client uses the  
SSH_FXP_REALPATH request 
to have the server localize any 
given path name to an absolute 
path.  This is useful for 
converting path names 
containing “..” components or 
relative pathnames without a 
leading slash into absolute 
paths. This error implies that 
there is a failure during this 
operation

Check if the access to the path specified in 
the FTP Server Configuration Menu 
window (see Figure 62 on page 67) is 
accessible and re-try the connection.

613 The SSH_FXP_READLINK 
request is used by the SFTP 
client to read the target of a 
symbolic link. The server will 
respond with a 
SSH_FXP_NAME packet 
containing only one name and a 
dummy attributes value.  The 
name in the returned packet 
contains the target of the link. 
This failure implies that there is 
a failure during the READLINK 
operation.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
the tests in “Network Outage Trouble 
Shooting” section on page 142. 

614 The SFTP client receives 
SSH_FXP_DATA as a response 
to any file operations from the 
server. This error implies that 
the client received an 
unexpected SSH_FXP_NAME 
from the server.

615 The SFTP client received more 
data than expected.

616 The SFTP client failed to read 
the data from the file descriptor 
of the file specified for transfer.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery
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SSH Client Errors

617 Excessive identity files. This 
error means that there are 
excessive identity files.  
OpenSSH implementation 
contains the maximum of 100 
identity files or the client 
configuration file is corrupted.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

624 The debug levels allowed for 
SSH protocol in openSSH is 0-9.  
There is either an error in the 
client configuration file, or the 
client configuration file is 
corrupted.

625 Failure to read the client 
configuration file.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.626 Invalid compression level is 

specified in the client 
configuration file.

627 SSH failure to setup the IO with 
the server.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

628 SSH failure to open the channel 
for the SSH connection with the 
server.

629 SSH failure to setup the channel 
for the SSH connection with the 
server.

630 SSH failure to verify the SSH 
client host key.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery
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631 SSH user authentication failure. 
Please verify that only the 
password authentication is set 
to “yes” in the SSH server 
configuration file.  Refer to the 
SSHD server configuration 
provided by vendor of the 
product. The FTRA and the 
EAGLE 5 ISS is compatible with 
openSSH 3.0.2p1.

Report the issue to the Customer Care 
Center if the problem persists after the 
SSHD configuration file is verified.  Refer 
to page 3 for the contact information.

632 The authentication method is 
NULL in the client software.  
This error is a failure to set the 
null authentication method.

Report this issue to the Customer Care 
Center.  Refer to page 3 for the contact 
information.

633 Permission is denied by the 
server due to authentication 
failure.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

640 A bad message was received 
during the SSH authentication.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
Network 

Client Error 
Code

Description Action/Recovery
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641 Missing authentication context, 
encountered during the SSH 
user authorization.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

642 Failure during the public key 
read/verification operation.

643 Undefined SFTP/SSH error.

644 Unexpected SSH_FXP_STATUS 
error.  An invalid status was 
received by the SFTP server.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

645 A bad option was specified in 
the SSH client on the EAGLE 5 
ISS.

646 An unsupported escape 
character was used in the SSH 
client on the EAGLE 5 ISS.

647 An unsupported cipher type 
was used in the SSH client on 
the EAGLE 5 ISS.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
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Client Error 
Code

Description Action/Recovery
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648 An unsupported MAC type was 
used in the SSH client on the 
EAGLE 5 ISS.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

649 A bad port was used in the SSH 
client on the EAGLE 5 ISS.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.656 Bad forwarding was used in the 

SSH client on the EAGLE 5 ISS.

657 Bad forwarding ports were 
specified in the SSH client on 
the EAGLE 5 ISS.

658 A bad dynamic port was 
specified in the SSH client on 
the EAGLE 5 ISS.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
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659 The host was not specified in 
the SSH client on the EAGLE 5 
ISS.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
Generic 
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Client Error 
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Description Action/Recovery



132 910-3489-001 Rev D, October 2006

FTP-Based Table Retrieve Application (FTRA) User Guide

660 An invalid option or argument 
was specified in the SSH client 
on the EAGLE 5 ISS.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

661 The hostname was not specified 
in the SSH client on the EAGLE 
5 ISS.

663 The SSH client was unable to 
load the cipher type on the 
EAGLE 5 ISS.

664 Asynchronous IO is not 
supported on IPSM, SSH client 
error.

665 Compression is already enabled 
in the SSH client on the EAGLE 
5 ISS.

666 Unknown cipher number on the 
SSH client on the EAGLE 5 ISS.

667 The SSH client key length is 
invalid.

668 No key is available on the SSH 
client on the EAGLE 5 ISS.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
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669 The secure connection was 
closed by the remote server, 
refer to the error on the 
SFTP/SSHD server side.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

670 Connection failure due to 
network outage or the 
connection was lost due to a 
faulty SSHD/SFTP server or 
network.

671 An unexpected packet type was 
received from the SFTP/SSHD 
server.

672 A bad packet length was 
received from the SSHD/SFTP 
server.

673 A cryptographic attack was 
detected by the SSH client.  
Please notify the local system 
administrator.

Report the issue to the Customer Care 
Center.  Refer to page 3 for the contact 
information.  This is not a software 
problem but there is a security threat.  The 
keys/authentication may have to be 
updated immediately.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)

SFTP/SSH 
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674 The SSH/SFTP client on the 
EAGLE 5 ISS failed to read from 
the remote side.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

675 Corrupted check bytes were 
detected on the SSH/SFTP 
client on the EAGLE 5 ISS.

676 Corrupted MAC on input was 
detected by the SSH/SFTP 
client on the EAGLE 5 ISS.

Verify that the sshtools.xml file provided 
with FTRA software has the field as 
shown:

<!-- The Message Authentication Code 
configuration, add or override default mac 
implementations -->

<MacConfiguration>

<DefaultAlgorithm>hmac-md5</DefaultAlgo
rithm>

</MacConfiguration>

677 Corrupted pad on input was 
detected by the SSH/SFTP 
client on the EAGLE 5 ISS.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.

678 SSH/SFTP tried to close a 
connection that is already 
closed.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)
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679 The SSH/SFTP client on the 
EAGLE 5 ISS failed to write to 
the remote side.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

680 SSH/SFTP tried to set the 
packet size twice.

Report this issue to the Customer Care 
Center immediately.  Refer to page 3 for 
the contact information.681 A bad packet size was detected 

by the SSH/SFTP client on the 
EAGLE 5 ISS.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)
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SSH/SFTP Connection/Setup Errors

682 The connection timed out when 
SSH tried to connect to SSHD.

Verify that the SFTP/SSHD version is 
compatible with openSSH 3.0.2p1. Verify 
there is no network outage by performing 
these tests:

• “FTP Server Verification” on page 140

• “SFTP /SSHD Server Verification” on page 
140

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” on 
page 142.

Make any fixes necessary and retry the 
connection.

If the problem persists, report the issue to 
the Customer Care Center.  Refer to page 3 
for the contact information.

683 The SSH connection was 
refused by the remote server.

684 The SSHD server is 
unreachable.

685 The network has reset.

686 The SSH/SFTP connection has 
been aborted.

687 The SFTP/SSH connection has 
been reset by the peer.

688 Failed to allocate network 
buffers.

689 The SSH/SFTP socket is already 
connected.

690 The SSH/SFTP socket is not 
connected.

691 The network channel is down.

692 The SSHD/SFTP server 
connection host is down.

693 SFTP client channel read failure.

694 SFTP client channel write 
failure.

695 SFTP client channel open 
failure.

Table 9. FTP/SFTP/SSH Error Codes  (Continued)
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Table 10. Generic Network Error Codes 

SFTP/SSH/
Generic 
Network 

Client Error 
Code

Description Action/Recovery

40 A destination address is required. Verify that there is an FTP server 
entry on the EAGLE 5 ISS using the  
rtrv-ftp-serv command, and re-try 
the connection 

41 Protocol wrong type for socket Report this issue to the Customer 
Care Center.  Refer to page 3 for the 
contact information.42 The protocol is not available.

43 The protocol is not supported.

44 The socket type is not supported.

45 The operation is not supported on the 
socket.

46 The protocol family is not supported.

47 The address family is not supported.

48 The address is already in use.

49 The requested address cannot be 
assigned.

50 Socket operation on non-socket

51 The network is unreachable. Verify that the connection tests and 
network outage numbers match as 
shown in these sections:

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” 
on page 142.

Make any fixes necessary and retry 
the connection.

If the problem persists, report the 
issue to the Customer Care Center.  
Refer to page 3 for the contact 
information.

52 The network dropped the connection 
on reset.

53 Software caused the connection to 
abort.

Report this issue to the Customer 
Care Center.  Refer to page 3 for the 
contact information.
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54 The connection was reset by the peer. Verify that the connection tests pass 
and network outage numbers are 
within the allowed limits as shown in 
these sections:

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” 
on page 142.

Make any fixes necessary and retry 
the connection.

If the problem persists, report the 
issue to the Customer Care Center.  
Refer to page 3 for the contact 
information.

55 No buffer space available. Report this issue to the Customer 
Care Center.  Refer to page 3 for the 
contact information.56 The socket is already connected.

57 The socket is not connected.

58 Can't send after socket shutdown

59 Too many references: can't splice

60 The connection timed out. Perform these tests and verify that the 
FTP server address responds to the 
ping command from the ISPM.

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

61 The connection was refused. Verify that there is a FTP server 
daemon is running on the remote 
station by performing the “FTP Server 
Verification” test on page 140.

Table 10. Generic Network Error Codes  (Continued)
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62 The network is down. Verify that the connection tests pass 
and network outage numbers are 
within the allowed limits as shown in 
these sections:

• “Connectivity Test – I” on page 140

• “Connectivity Test - II” on page 141

• “Network Outage Trouble Shooting” 
on page 142.

Make any fixes necessary and retry 
the connection.

If the problem persists, report the 
issue to the Customer Care Center.  
Refer to page 3 for the contact 
information.

65 There is no route to the host.

67 The host is down.

30 Read-only file system

32 Broken pipe Report the issue to the Customer Care 
Center.  Refer to page 3 for the contact 
information.35 Unsupported value

Table 10. Generic Network Error Codes  (Continued)
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Troubleshooting Procedures

FTP Server Verification

Component: The FTP server IP address shown in the FTP Server Configuration 
Menu window (see Figure 62 on page 67).

Supported Version/Specification: Any FTP server compliant with IETF RFC 959.

Test: On the Unix platform, execute the netstat -a|grep 21 command to verify 
that the FTP server is running on the machine with the IP address shown in the 
FTP Server Configuration Menu window (Figure 62 on page 67).

Expected Result:

Unix>  netstat -a | grep 21
*.32821              *.*                0      0     0      0 LISTEN
f5e15218 stream-ord f5ee8880        0 /var/adm/atria/almd    , The system and 

process specific variable will change.

On the Windows platform, check the Task Manager to verify that the FTP 
daemon is running.

SFTP /SSHD Server Verification

Component: The SSHD/SFTP server IP address shown in the FTP Server 
Configuration Menu window (see Figure 62 on page 67).

Supported Version/Specification: Version compatible with openSSH 3.0.2p1.

Test: On the Unix platform, execute the ps -f|grep sshd command.  Please 
refer to Unix MAN pages for help with ps command. 

On the Windows platform, use the Task Manager to verify that the sshd daemon 
process in running.

Expected Result:

Unix> ps -ef|grep sshd
user   26912 26886  0 13:28:07 pts/5    0:00 grep sshd
root   411     1  0   Jul 24 ?        4:35 /usr/local/sbin/sshd  Note: The 

user/system/path variables depends on the server.   

On the Windows platform, check the Task Manager to verify that the FTP 
daemon is running.

Connectivity Test – I

Component: Connectivity Test - I.

Supported Version/Specification: N/A
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Test: To verify that there is a network connection available between the EAGLE 5 
ISS and the FTP/SFTP server shown in the FTP Server Configuration Menu 
window (see Figure 62 on page 67). 

On an EAGLE 5 ISS terminal, enter the pass:loc=xxxx:cmd="ping 
yy.yy.yy.yy" command, where xxxx is location of IPSM associated with the IP 
address entered in the STP Connection Configuration Menu window, (see Table 
2 on page 32), and yy.yy.yy.yy is the IP address of the FTP/SFTP server shown 
in the FTP Server Configuration Menu window (see Figure 62 on page 67).

Expected Result:

NOTE: The RTT time and data sizes may vary .                                                                                                                                  
> pass:loc=xxxx:cmd="ping yy.yy.yy.yy"
Command Accepted - Processing
    rlghncxa03w 05-09-31 13:57:59 GMT  EAGLE5 34.0.0
    pass:loc=xxxx:cmd="ping yy.yy.yy.yy"
    Command entered at terminal #5.
;
    rlghncxa03w 05-09-31 13:57:59 GMT  EAGLE5 34.0.0
    PASS: Command sent to card
;
    rlghncxa03w 05-09-31 13:57:59 GMT  EAGLE5 34.0.0
    PING command in progress
;
    rlghncxa03w 05-09-31 13:57:59 GMT  EAGLE5 34.0.0
;
    rlghncxa03w 05-09-31 13:58:01 GMT  EAGLE5 34.0.0
    PING yy.yy.yy.yy: 56 data bytes
    64 bytes from yy.yy.yy.yy: icmp_seq=0. time=10. ms
    64 bytes from yy.yy.yy.yy: icmp_seq=1. time=5. ms
    64 bytes from yy.yy.yy.yy: icmp_seq=2. time=5. ms
    ----yy.yy.yy.yy PING Statistics----
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip (ms)  min/avg/max = 5/6/10
    PING command complete

Connectivity Test - II

Component: Connectivity Test - II.

Supported Version/Specification: N/A.

Test:  To verify that there is a network connection available between the EAGLE 5 
ISS and FTP/SFTP server shown in the FTP Server Configuration Menu window 
(see Figure 62 on page 67).

Execute the ping -s zz.zz.zz.zz command on the FTP server machine where 
zz.zz.zz.zz is the IP address of the EAGLE 5 ISS shown in the STP Connection 
Configuration Menu window (see Table 2 on page 32).

Expected Result: 

ping -s zz.zz.zz.zz
PING zz.zz.zz.zz: 56 data bytes
64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seq=0. time=5. ms
64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seq=1. time=4. ms
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64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seq=2. time=5. ms
64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seq=3. time=4. ms

----zz.zz.zz.zz PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 4/4/5

Network Outage Trouble Shooting

Component: Network Outage Troubleshooting

Supported Version/Specification: N/A.

Test: To verify the TCP/IP traffic/network statistics are within the Tekelec 
supported network statistics. 

At the EAGLE 5 ISS, enter the pass:loc=xxxx:cmd="netstat -p tcp" 
command at the EAGLE 5 ISS terminal, where xxxx is location of the IPSM 
associated with the IP address entered in the STP Connection Configuration 
Menu window, (see Table 2 on page 32), and analyze the data from output which 
is similar to the following example output.

NOTE: The specific information for the command may vary depending 
upon the system used.
> pass:loc=3102:cmd="netstat -p tcp"
Command Accepted - Processing
    rlghncxa03w 05-09-31 19:32:52 GMT  EAGLE5 34.0.0
    pass:loc=3102:cmd="netstat -p tcp"
    Command entered at terminal #5.
;
    rlghncxa03w 05-09-31 19:32:52 GMT  EAGLE5 34.0.0
    PASS: Command sent to card
;
    rlghncxa03w 05-09-31 19:32:52 GMT  EAGLE5 34.0.0
    TCP:
        161 packets sent
                156 data packets (28411 bytes)
                0 data packet (0 byte) retransmitted
                5 ack-only packets (1 delayed)
                0 URG only packet
                0 window probe packet
                0 window update packet
                0 control packet
        161 packets received
                156 acks (for 28255 bytes)
                0 duplicate ack+C2
                0 ack for unsent data
                5 packets (9 bytes) received in-sequence
                0 completely duplicate packet (0 byte)
                0 packet with some dup. data (0 byte duped)
                0 out-of-order packet (0 byte)
                0 packet (0 byte) of data after window
                0 window probe
                0 window update packet
                0 packet received after close
                0 discarded for bad checksum
                0 discarded for bad header offset field
                0 discarded because packet too short
        0 connection request
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        1 connection accept
        1 connection established (including accepts)
        0 connection closed (including 0 drop)
        0 embryonic connection dropped
        156 segments updated rtt (of 157 attempts)
        0 retransmit timeout
                0 connection dropped by rexmit timeout
        0 persist timeout
        0 keepalive timeout
                0 keepalive probe sent
                0 connection dropped by keepalive
        0 pcb cache lookup failed

;

    rlghncxa03w 05-09-31 19:32:52 GMT  EAGLE5 34.0.0

    NETSTAT command complete

Expected Result:

The network outage causes the TCP/IP problems like:

• Network latency

• Packet drop

• Duplicate packets.

If the TCP Packet Delay, TCP Packet Loss, TCP Packet Error, or TCP Out of Order 
values are greater than the values shown in Table 11, fix the network problems 
and retry the connection.

SSH/SFTP/SFTPD/SSHD Protocol Troubleshooting

For more information on SSH/SFTP/SFTPD/SSHD protocol troubleshooting, 
refer to SSH, the Secure Shell: The Definitive Guide, First Edition, Barrett and 
Silverman, O’Reilly, February 2001.

Table 11. TCP Fault Tolerance Table for FTP/SFTP 

Protocol Fault Threshold Value

SFTP/FTP TCP Packet Delay 175 milliseconds

SFTP/ FTP TCP Packet Loss 40% packet loss

SFTP/ FTP TCP Packet Errors 10%

SFTP/ FTP TCP Out of Order 30% of packets with offset of 30 packets
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Symbols
.doc file extension, 52, 91, 116, 120
.txt file extension, 52, 91, 116, 120

Numerics
30 - Read-only file system, 139
32 - Broken pipe, 139
35 - Unsupported value, 139
40 - A destination address is required, 137
41 - Protocol wrong type for socket, 137
42 - The protocol is not available, 137
43 - The protocol is not supported, 137
44 - The socket type is not supported, 137
45 - The operation is not supported on the 

socket, 137
46 - The protocol family is not 

supported, 137
47 - The address family is not 

supported, 137
48 - The address is already in use, 137
49 - The requested address cannot be 

assigned, 137
50 - Socket operation on non-socket, 137
51 - The network is unreachable, 137
52 - The network dropped the connection on 

reset, 137
53 - Software caused the connection to 

abort, 137
54 - The connection was reset by the 

peer, 138
55 - No buffer space available, 138
56 - The socket is already connected, 138
569 - The file name is already specified, 124
57 - The socket is not connected, 138
58 - Can’t send after socket shutdown, 138
59 - Too many references: can’t splice, 138
595 - File open failed, 124
597 - SFTP client packet send failure, 124
598 - The SFTP connection is closed, 124
599 - SFTP packet read failure, 124
60 - The connection timed out, 138
600 - SFTP protocol error, 125
601 - Undefined, 125

608 - SFTP received a invalid ID in the 
response received during a read 
operation on remote directory, 125

609 - SFTP: Handle mismatch error, 125
61 - The connection was refused, 138
610 - Unexpected SSH2_FXP_ATTRS, 125
611 - Unexpected SSH_FXP_NAME, 125
612 - SSH_FXP_REALPATH request 

failure, 126
613 - SSH_FXP_READLINK request 

failure, 126
614 - unexpected SSH_FXP_NAME, 126
615 - The SFTP client received more data 

than expected, 126
616 - The SFTP client failed to read the data 

from the file descriptor, 126
617 - Excessive identity files, 127
62 - The network is down, 139
624 - The debug levels allowed for SSH 

protocol in openSSH is 0-9, 127
625 - Failure to read the client configuration 

file, 127
626 - Invalid compression level is specified in 

the client configuration file, 127
627 - SSH failure to setup the IO with the 

server, 127
628 - SSH failure to open the channel for the 

SSH connection with the server, 127
629 - SSH failure to setup the channel for the 

SSH connection with the server, 127
630 - SSH failure to verify the SSH client host 

key, 127
631 - SSH user authentication failure, 128
632 - The authentication method is NULL in 

the client software, 128
633 - Permission is denied by the server due 

to authentication failure, 128
633 - User login failure, 124
640 - A bad message was received during the 

SSH authentication, 128
641 - Missing authentication context, 

encountered during the SSH user 
authorization, 129

642 - Failure during the public key 
read/verification operation, 129

Index
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643 - Undefined SFTP/SSH error, 129
644 - Unexpected SSH_FXP_STATUS 

error, 129
645 - A bad option was specified in the SSH 

client on the EAGLE 5 ISS, 129
646 - An unsupported escape character was 

used in the SSH client on the EAGLE 5 
ISS, 129

647 - An unsupported cipher type was used 
in the SSH client on the EAGLE 5 
ISS, 129

648 - An unsupported MAC type was used in 
the SSH client on the EAGLE 5 ISS, 130

649 - A bad port was used in the SSH client 
on the EAGLE 5 ISS, 130

65 - There is no route to the host, 139
656 - Bad forwarding was used in the SSH 

client on the EAGLE 5 ISS, 130
657 - Bad forwarding ports were specified in 

the SSH client on the EAGLE 5 ISS, 130
658 - A bad dynamic port was specified in 

the SSH client on the EAGLE 5 ISS, 130
659 - The host was not specified in the SSH 

client on the EAGLE 5 ISS, 131
660 - An invalid option or argument was 

specified in the SSH client on the EAGLE 
5 ISS, 132

661 - The hostname was not specified in the 
SSH client on the EAGLE 5 ISS, 132

663 - The SSH client was unable to load the 
cipher type on the EAGLE 5 ISS, 132

664 - Asynchronous IO is not supported on 
IPSM, SSH client error, 132

665 - Compression is already enabled in the 
SSH client on the EAGLE 5 ISS, 132

666 - Unknown cipher number on the SSH 
client on the EAGLE 5 ISS, 132

667 - The SSH client key length is 
invalid, 132

668 - No key is available on the SSH client on 
the EAGLE 5 ISS, 132

669 - The secure connection was closed by 
the remote server, 133

67 - The host is down, 139
670 - Connection failure due to network 

outage or the connection was lost due to 
a faulty SSHD/SFTP server or 
network, 133

671 - An unexpected packet type was 
received from the SFTP/SSHD 
server, 133

672 - A bad packet length was received from 
the SSHD/SFTP server, 133

673 - A cryptographic attack was detected by 
the SSH client, 133

674 - The SSH/SFTP client on the EAGLE 5 
ISS failed to read from the remote 
side, 134

675 - Corrupted check bytes were detected 
on the SSH/SFTP client on the EAGLE 5 
ISS, 134

676 - Corrupted MAC on input was detected 
by the SSH/SFTP client on the EAGLE 5 
ISS, 134

677 - Corrupted pad on input was detected 
by the SSH/SFTP client on the EAGLE 5 
ISS, 134

678 - SSH/SFTP tried to close a connection 
that is already closed, 134

679 - The SSH/SFTP client on the EAGLE 5 
ISS failed to write to the remote 
side, 135

680 - SSH/SFTP tried to set the packet size 
twice, 135

681 - A bad packet size was detected by the 
SSH/SFTP client on the EAGLE 5 
ISS, 135

682 - The connection timed out when SSH 
tried to connect to SSHD, 136

683 - The SSH connection was refused by the 
remote server, 136

684 - The SSHD server is unreachable, 136
685 - The network has reset, 136
686 - The SSH/SFTP connection has been 

aborted, 136
687 - The SFTP/SSH connection has been 

reset by the peer, 136
688 - Failed to allocate network buffers, 136
689 - The SSH/SFTP socket is already 

connected, 136
690 - The SSH/SFTP socket is not 

connected, 136
691 - The network channel is down, 136
692 - The SSHD/SFTP server connection host 

is down, 136
693 - SFTP client channel read failure, 136
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694 - SFTP client channel write failure, 136
695 - SFTP client channel open failure, 136

A
A bad dynamic port was specified in the SSH 

client on the EAGLE 5 ISS - Error code 
658, 130

A bad message was received during the SSH 
authentication - Error code 640, 128

A bad option was specified in the SSH client 
on the EAGLE 5 ISS - Error code 
645, 129

A bad packet length was received from the 
SSHD/SFTP server - Error code 
672, 133

A bad packet size was detected by the 
SSH/SFTP client on the EAGLE 5 ISS - 
Error code 681, 135

A bad port was used in the SSH client on the 
EAGLE 5 ISS - Error code 649, 130

A cryptographic attack was detected by the 
SSH client - Error code 673, 133

A destination address is required - Error 
code 40, 137

About FTRA window, 28, 122
Activating Controlled Features 

procedure, 3
Activating the Eagle OA&M IP Security 

Enhancements Controlled Feature 
procedure, 3, 34, 39, 55, 123

Add button, 1, 33, 35, 39, 78
Retrieve Tables, 73

Adding
Command to the Selected Commands 

Box, 78
Multiple Commands to the Selected 

Commands Box, 80
Range of Commands to the Selected 

Commands Box, 79
STP Configuration Record, 35, 65

Adding an STP Configuration Record
FTRA 1.0, 35, 36, 37, 38, 39
FTRA 2.0, 35, 36, 37, 38, 39

alw-card command, 60
An invalid option or argument was specified 

in the SSH client on the EAGLE 5 ISS - 
Error code 660, 132

An unexpected packet type was received 
from the SFTP/SSHD server - Error code 
671, 133

An unsupported cipher type was used in the 
SSH client on the EAGLE 5 ISS - Error 
code 647, 129

An unsupported escape character was used 
in the SSH client on the EAGLE 5 ISS - 
Error code 646, 129

An unsupported MAC type was used in the 
SSH client on the EAGLE 5 ISS - Error 
code 648, 130

Application, FTRA
exiting, 4, 29
starting, 4
using, 4

Asynchronous IO is not supported on IPSM, 
SSH client error - Error code 664, 132

AUTOEXEC.BAT, 13, 21

B
Backup IP Address - FTRA 2.0, 37
Backup IP Address - FTRA 2.0 or 

greater, 33
Backup IP Address Field - FTRA 2.0 or 

greater, 33, 37
Bad forwarding ports were specified in the 

SSH client on the EAGLE 5 ISS - Error 
code 657, 130

Bad forwarding was used in the SSH client 
on the EAGLE 5 ISS - Error code 
656, 130

Box
Command List, 71, 73, 75, 80
Secure Connection - FTRA 2.0 or 

greater, 34, 39, 55, 60, 65, 66
Selected Commands, 71, 73, 78, 80, 82

Adding a Command, 78
Adding a Range of Commands, 79
Adding Multiple Commands, 80
Command Removed, 81
Command Selected to be 

Removed, 81
Stop on error

Update Tables, 101
Stop on error, Update Tables 

window, 98, 101, 110, 111, 112
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Use STP and FTP UserNames, 
Passwords for all STPs, 34, 35, 53, 
54, 55

Broken pipe - Error code 32, 139
Browse button

FTP Server Configuration Menu, 67, 68
Update Tables, 98, 99

Button
Add, 1, 33, 35, 39, 73, 78
Browse

FTP Server Configuration 
Menu, 67, 68

Update Tables window, 98, 99
Cancel, 51

Print window
Retrieve Tables Log, 90
System Log, 119
Update Tables Log, 115

Save window
Retrieve Tables Log, 91
System Log, 121
Update Tables Log, 116

Select Starting Directory 
window, 69

Select window, 99, 100
Close, 33, 42, 44, 67

Retrieve Tables, 73
Update Tables, 98

Commit, Update Validation Complete 
window, 103, 104

Delete, 33, 42, 44, 57
Edit, Update Validation Complete 

window, 103, 104, 105, 106
Load, 73, 82, 93
Modify, 33, 53, 54
Refresh, 33, 40, 42, 44, 46, 56
Remove, 73, 80
Reset, 73, 80
Retrieve, 71, 73, 82, 83
Retrieve from Local Database, 71, 73, 82
Retrieve from STP, 71, 73, 83
Save

Retrieve Tables Log, 91
System Log, 121
Update Tables Log, 116

Select, 33, 42, 44
Select Starting Directory 

window, 69

Select window, 99, 100
Set, 70

FTP Server Configuration Menu, 67
Stop, Update Validation Complete 

window, 103
Store, 73, 82, 93
Test, 33, 42, 44, 48
Validate, 98, 102

Update Tables window, 97

C
Can’t send after socket shutdown - Error 

code 58, 138
Cancel button, 51

Print window
Retrieve Tables Log, 90
System Log, 119
Update Tables Log window, 115

Save window
Retrieve Tables Log, 91
System Log, 121
Update Tables Log, 116

Select Starting Directory window, 69
Select window, 99, 100

Card
GPSM-II, 3
IPSM, 3
MCAP, 3
TDM, 3

CD-ROM drive, 2, 5, 14, 23
chg-ftp-serv EAGLE 5 ISS command, 67
chg-trm command, 63
chg-trm:trm=:all=no EAGLE 5 ISS 

command, 83
chmod command, 67, 68
Clearing the display

Connectivity Test Log, 49, 50
Retrieve Tables Log, 88
System Log, 117, 118
Update Tables Log, 112, 113

Close button
FTP Connection Configuration 

Menu, 67
Retrieve Tables window, 73
STP Connection Configuration 

Menu, 33, 42, 44
Update Tables, 98
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Closing
Connectivity Test Log window, 49, 53
Retrieve Tables Log window, 88, 92
System Log window, 117, 121
Update Tables Log window, 112, 116

Command
EAGLE 5 ISS

alw-card, 60
chg-ftp-serv, 67
chg-trm, 63
chg-trm:trm=:all=no, 83
ent-ftp-serv, 67
init-card, 60, 63, 64
pass:loc=xxxx

cmd="netstat -p tcp", 142
cmd="ping yy.yy.yy.yy", 141

rst-card, 60
rtrv, 73, 93, 95
rtrv-card, 3
rtrv-ctrl-feat, 3, 34, 39, 55, 123
rtrv-feat, 71
rtrv-ftp-serv, 137
rtrv-gta, 71, 76, 83
rtrv-gtt, 71, 76, 83
rtrv-gttsel, 71, 76, 83
rtrv-gttset, 71, 76, 83
rtrv-ip-lnk, 63, 64
rtrv-secu-dflt, 38
rtrv-stp, 86, 87
rtrv-trm, 62, 63, 83
rtrv-tt, 71, 76, 83

FTRA
ftra -c, 93, 95

Selecting, 75
Command Complete

Connectivity Test window, 49
Retrieve Tables window, 71, 84, 85
Update Tables window, 103, 104, 107

Command File
Editing, 2, 105
Editor window, 103, 105, 106, 107

File Menu, 107
File Menu, 107
Invalid Command, 106

Field, Update Tables window, 99, 100, 
102

Selected, Update Tables window, 99
Stop on error box checked, 101

Sending to the Selected STP, 104
Command files, sending to the EAGLE 5 

ISS, 4
Command In progress, Cannot Close 

Window message, 106
Command Line Interface, 1, 73, 82, 93

Automatic Start, 95
Manual Start, 93
UNIX, 94
Windows, 94

Command List
Box, 71, 73, 75, 80
Field

Retrieve Tables window, 73
Update Tables window, 98

Side, 80
command prompt

DOS, 93
shell, 93

Command Removed from the Selected 
Commands Box, 81

Command Selected to be Removed in the 
Selected Commands Box, 81

Commands
EAGLE 5 ISS, 1, 97, 98

EGTT
rtrv-gta, 71, 76, 83
rtrv-gttsel, 71, 76, 83
rtrv-gttset, 71, 76, 83

GTT
rtrv-gtt, 71, 76, 83
rtrv-tt, 71, 76, 83

Menu, 28
Menu window, 73, 82, 98
Selecting a Range, 76
Selecting Multiple, 77

Commit button, Update Validation 
Complete window, 103, 104

Compression is already enabled in the SSH 
client on the EAGLE 5 ISS - Error code 
665, 132

Configuration record, STP, 31, 32, 33, 35, 
40, 42, 44, 45, 46, 47, 48, 53, 54, 55, 56, 57, 
59, 60, 65
FTRA 1.0, 46
FTRA 2.0, 46, 47
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Configuration record, STP - FTRA 1.0
Adding, 35, 36, 37, 38, 39

Configuration record, STP - FTRA 2.0
Adding, 35, 36, 37, 38, 39

Configuring the EAGLE 5 ISS, 3
Connection failure due to network outage or 

the connection was lost due to a faulty 
SSHD/SFTP server or network - Error 
code 670, 133

Connectivity Test - I procedure, 140
Connectivity Test - II procedure, 141
Connectivity Test Log, 48, 49, 50, 51, 52

Clearing the Display, 49, 50
closing, 49, 53
File Menu, 49
Print window, 51
Printing, 49, 51
Save window, 52
saved file confirmation window, 52, 53
saving to a file, 49, 52
window, 48, 49, 50, 51, 52, 53, 61, 64, 65

errors, 49
no errors, 48

Connectivity Test Log window
File Menu, 49, 50

copyright information, 122
Corrupted check bytes were detected on the 

SSH/SFTP client on the EAGLE 5 ISS - 
Error code 675, 134

Corrupted MAC on input was detected by 
the SSH/SFTP client on the EAGLE 5 ISS 
- Error code 676, 134

Corrupted pad on input was detected by the 
SSH/SFTP client on the EAGLE 5 ISS - 
Error code 677, 134

cron, 93, 95, 96
CRON FTRA Wrapper Script, 96
crontab, 96
CSV file format, 1, 71, 73, 82, 93, 95
Current STP

Selected, 58
FTRA 1.0, 58
FTRA 2.0, 59

Selected: field, 56
Selecting, 4, 57

Customer Care Center, 3, 5, 63, 123, 124, 
125, 126, 127, 128, 129, 130, 131, 132, 133, 
134, 135, 136, 137, 138, 139

D
Database Administration Manual - System 

Management, 3, 34, 39, 55, 123
Database tables, retrieving from the EAGLE 

5 ISS, 4
Database, STP Connection 

Configuration, 31, 33, 34, 35, 39, 57
Delete button, 33, 42, 44, 57
Delete STP Data window, 57
Deleting an STP Configuration Record, 56
Description

Retrieve Tables window, 73
Update Tables window, 98

Disk space, 2
Display

Clearing
Connectivity Test Log, 49, 50
Retrieve Tables Log, 88
System Log, 117, 118
Update Tables Log, 112, 113

Displaying an Existing STP Configuration 
Record, 40

DOS, 13, 22
DOS command prompt, 93
Drop down list

STP Name, 33, 40
FTRA 1.0, 40, 42
FTRA 2.0, 40, 41, 42, 43

DSA Key Fingerprint, 63, 64
Duplicate packets, 143

E
EAGLE 5 ISS

Telnet terminals, 33, 63, 83
UIM - Unsolicited Information 

Message, 63, 64, 83
EAGLE 5 ISS Card

GPSM-II, 3
IPSM, 3
MCAP, 3
TDM, 3

EAGLE 5 ISS chg-ftp-serv command, 67
EAGLE 5 ISS chg-trm:trm=:all=no 

command, 83
EAGLE 5 ISS command

alw-card, 60
chg-ftp-serv, 67
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chg-trm, 63
chg-trm:trm=:all=no, 83
ent-ftp-serv, 67
init-card, 60, 63, 64
pass:loc=xxxx

cmd="netstat -p tcp", 142
cmd="ping yy.yy.yy.yy", 141

rst-card, 60
rtrv, 73, 93, 95
rtrv-card, 3
rtrv-ctrl-feat, 3, 34, 39, 55, 123
rtrv-feat, 71
rtrv-ftp-serv, 137
rtrv-gta, 71, 76, 83
rtrv-gtt, 71, 76, 83
rtrv-gttsel, 71, 76, 83
rtrv-gttset, 71, 76, 83
rtrv-ip-lnk, 63, 64
rtrv-secu-dflt, 38
rtrv-stp, 86, 87
rtrv-trm, 62, 63, 83
rtrv-tt, 71, 76, 83

EAGLE 5 ISS command files
sending, 4

EAGLE 5 ISS commands, 1, 97, 98
EAGLE 5 ISS configuration, 3
EAGLE 5 ISS database tables

retrieving, 4
EAGLE 5 ISS EGTT commands

rtrv-gta, 71, 76, 83
rtrv-gttsel, 71, 76, 83
rtrv-gttset, 71, 76, 83

EAGLE 5 ISS ent-ftp-serv command, 67
EAGLE 5 ISS Feature

EGTT, 71
FTP Retrieve and Replace, 3
GTT, 71
IP User Interface, 3

EAGLE 5 ISS feature
Eagle OA&M IP Security 

Enhancements, 3, 34, 39, 55, 123
EAGLE 5 ISS GTT commands

rtrv-gtt, 71, 76, 83
rtrv-tt, 71, 76, 83

EAGLE 5 ISS Manual, Database 
Administration Manual - System 
Management, 3, 34, 39, 55, 123

EAGLE 5 ISS pass:loc=xxxx
cmd="netstat -p tcp" command, 142
cmd="ping yy.yy.yy.yy" 

command, 141
EAGLE 5 ISS procedure

Activating Controlled Features, 3
Activating the Eagle OA&M IP Security 

Enhancements Controlled 
Feature, 3, 34, 39, 55, 123

EAGLE 5 ISS Public Host Key 
Fingerprint, 60, 61, 63, 65

EAGLE 5 ISS Public Key Fingerprint, 34, 
63, 64

EAGLE 5 ISS release 30.2 or greater, 3, 34, 
39

EAGLE 5 ISS rtrv-card command, 3
EAGLE 5 ISS rtrv-ctrl-feat command, 3, 34, 

39, 55, 123
EAGLE 5 ISS rtrv-feat command, 71
EAGLE 5 ISS rtrv-ftp-serv command, 137
EAGLE 5 ISS rtrv-gta command, 71, 76, 83
EAGLE 5 ISS rtrv-gtt command, 71, 76, 83
EAGLE 5 ISS rtrv-gttsel command, 71, 76, 

83
EAGLE 5 ISS rtrv-gttset command, 71, 76, 

83
EAGLE 5 ISS rtrv-secu-dflt command, 38
EAGLE 5 ISS rtrv-stp command, 86, 87
EAGLE 5 ISS rtrv-trm command, 83
EAGLE 5 ISS rtrv-tt command, 71, 76, 83
Eagle OA&M IP Security Enhancements 

feature, 3, 34, 39, 55, 123
Edit button, Update Validation Complete 

window, 103, 104, 105, 106
Edit menu

FTP-Based Table Retrieve 
Application, 31, 98

Editing a Command File, 105
EGTT commands

EAGLE 5 ISS
rtrv-gta, 71, 76, 83
rtrv-gttsel, 71, 76, 83
rtrv-gttset, 71, 76, 83

EGTT Feature, 71
Entering an STP Name, 44
ent-ftp-serv EAGLE 5 ISS command, 67
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Environment variable
FTRA_HOME, 1, 12, 13, 20, 21, 24
JRE_HOME, 1, 12, 13, 20, 21, 22, 24
system, 12, 20, 24
user, 12, 13, 20, 21, 24

Error code
30 - Read-only file system, 139
32 - Broken pipe, 139
35 - Unsupported value, 139
40 - A destination address is 

required, 137
41 - Protocol wrong type for socket, 137
42 - The protocol is not available, 137
43 - The protocol is not supported, 137
44 - The socket type is not 

supported, 137
45 - The operation is not supported on 

the socket, 137
46 - The protocol family is not 

supported, 137
47 - The address family is not 

supported, 137
48 - The address is already in use, 137
49 - The requested address cannot be 

assigned, 137
50 - Socket operation on 

non-socket, 137
51 - The network is unreachable, 137
52 - The network dropped the connection 

on reset, 137
53 - Software caused the connection to 

abort, 137
54 - The connection was reset by the 

peer, 138
55 - No buffer space available, 138
56 - The socket is already 

connected, 138
57 - The socket is not connected, 138
58 - Can’t send after socket 

shutdown, 138
59 - Too many references: can’t 

splice, 138
595 - File open failed, 124
596 - The file name is already 

specified, 124
597 - SFTP client packet send 

failure, 124
598 - The SFTP connection is closed, 124

599 - SFTP packet read failure, 124
60 - The connection timed out, 138
600 - SFTP protocol error, 125
601 - Undefined, 125
608 - SFTP received a invalid ID in the 

response received during a read 
operation on remote directory, 125

609 - SFTP: Handle mismatch error, 125
61 - The connection was refused, 138
610 - Unexpected 

SSH2_FXP_ATTRS, 125
611 - Unexpected 

SSH_FXP_NAME, 125
612 - SSH_FXP_REALPATH request 

failure, 126
613 - SSH_FXP_READLINK request 

failure, 126
614 - unexpected 

SSH_FXP_NAME, 126
615 - The SFTP client received more data 

than expected, 126
616 - The SFTP client failed to read the 

data from the file descriptor, 126
617 - Excessive identity files, 127
62 - The network is down, 139
624 - The debug levels allowed for SSH 

protocol in openSSH is 0-9, 127
625 - Failure to read the client 

configuration file, 127
626 - Invalid compression level is 

specified in the client configuration 
file, 127

627 - SSH failure to setup the IO with the 
server, 127

628 - SSH failure to open the channel for 
the SSH connection with the 
server, 127

629 - SSH failure to setup the channel for 
the SSH connection with the 
server, 127

630 - SSH failure to verify the SSH client 
host key, 127

631 - SSH user authentication 
failure, 128

632 - The authentication method is NULL 
in the client software, 128

633 - Permission is denied by the server 
due to authentication failure, 128
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633 - User login failure, 124
640 - A bad message was received during 

the SSH authentication, 128
641 - Missing authentication context, 

encountered during the SSH user 
authorization, 129

642 - Failure during the public key 
read/verification operation, 129

643 - Undefined SFTP/SSH error, 129
644 - Unexpected SSH_FXP_STATUS 

error, 129
645 - A bad option was specified in the 

SSH client on the EAGLE 5 ISS, 129
646 - An unsupported escape character 

was used in the SSH client on the 
EAGLE 5 ISS, 129

647 - An unsupported cipher type was 
used in the SSH client on the EAGLE 
5 ISS, 129

648 - An unsupported MAC type was 
used in the SSH client on the EAGLE 
5 ISS, 130

649 - A bad port was used in the SSH 
client on the EAGLE 5 ISS, 130

65 - There is no route to the host, 139
656 - Bad forwarding was used in the 

SSH client on the EAGLE 5 ISS, 130
657 - Bad forwarding ports were 

specified in the SSH client on the 
EAGLE 5 ISS, 130

658 - A bad dynamic port was specified 
in the SSH client on the EAGLE 5 
ISS, 130

659 - The host was not specified in the 
SSH client on the EAGLE 5 ISS, 131

660 - An invalid option or argument was 
specified in the SSH client on the 
EAGLE 5 ISS, 132

661 - The hostname was not specified in 
the SSH client on the EAGLE 5 
ISS, 132

663 - The SSH client was unable to load 
the cipher type on the EAGLE 5 
ISS, 132

664 - Asynchronous IO is not supported 
on IPSM, SSH client error, 132

665 - Compression is already enabled in 
the SSH client on the EAGLE 5 
ISS, 132

666 - Unknown cipher number on the 
SSH client on the EAGLE 5 ISS, 132

667 - The SSH client key length is 
invalid, 132

668 - No key is available on the SSH client 
on the EAGLE 5 ISS, 132

669 - The secure connection was closed 
by the remote server, 133

67 - The host is down, 139
670 - Connection failure due to network 

outage or the connection was lost due 
to a faulty SSHD/SFTP server or 
network, 133

671 - An unexpected packet type was 
received from the SFTP/SSHD 
server, 133

672 - A bad packet length was received 
from the SSHD/SFTP server, 133

673 - A cryptographic attack was 
detected by the SSH client, 133

674 - The SSH/SFTP client on the EAGLE 
5 ISS failed to read from the remote 
side, 134

675 - Corrupted check bytes were 
detected on the SSH/SFTP client on 
the EAGLE 5 ISS, 134

676 - Corrupted MAC on input was 
detected by the SSH/SFTP client on 
the EAGLE 5 ISS, 134

677 - Corrupted pad on input was 
detected by the SSH/SFTP client on 
the EAGLE 5 ISS, 134

678 - SSH/SFTP tried to close a 
connection that is already 
closed, 134

679 - The SSH/SFTP client on the EAGLE 
5 ISS failed to write to the remote 
side, 135

680 - SSH/SFTP tried to set the packet 
size twice, 135

681 - A bad packet size was detected by 
the SSH/SFTP client on the EAGLE 5 
ISS, 135

682 - The connection timed out when 
SSH tried to connect to SSHD, 136
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683 - The SSH connection was refused by 
the remote server, 136

684 - The SSHD server is 
unreachable, 136

685 - The network has reset, 136
686 - The SSH/SFTP connection has been 

aborted, 136
687 - The SFTP/SSH connection has been 

reset by the peer, 136
688 - Failed to allocate network 

buffers, 136
689 - The SSH/SFTP socket is already 

connected, 136
690 - The SSH/SFTP socket is not 

connected, 136
691 - The network channel is down, 136
692 - The SSHD/SFTP server connection 

host is down, 136
693 - SFTP client channel read 

failure, 136
694 - SFTP client channel write 

failure, 136
695 - SFTP client channel open 

failure, 136
Error Codes

FTP, 123
Generic Network, 137
SFTP, 123
SSH, 123

Error message
STP Name does not exist, 47

Errors
SFTP, 124
SFTP Client, 124
SSH Client, 127
SSH/SFTP Connection/Setup, 136

Errors - contacting the Customer Care 
Center, 3, 5, 63, 123, 124, 125, 126, 127, 
128, 129, 130, 131, 132, 133, 134, 135, 136, 
137, 138, 139

Ethernet connection, 2
Excessive identity files - Error code 617, 127
Exit Confirmation window, 29
Exit menu, 28
Exit window, 29, 30
Exiting the FTRA application, 4, 29

F
Failed to allocate network buffers - Error 

code 688, 136
Failure during the public key 

read/verification operation - Error code 
642, 129

Failure to read the client configuration file - 
Error code 625, 127

Feature
Eagle OA&M IP Security 

Enhancements, 3, 34, 39, 55, 123
EGTT, 71
FTP Retrieve and Replace, 3
GTT, 71
IP User Interface, 3

Field
Command File, Update Tables 

window, 99, 100, 102
Command List

Retrieve Tables, 73
Update Tables, 98

Current STP Selected:, 56
File Name:, 69

Select Starting Directory 
window, 69

Select window, 100
Files of type:

Select Starting Directory 
window, 69

Select window, 100
FTP Password, 33, 39
FTP UserName, 33, 38
IP Address, 67

Backup - FTRA 2.0 or greater, 33, 37
Primary - FTRA 2.0 or greater, 32, 

37
IP Address - FTRA 1.0, 32, 37
Look in:

Select Staring Directory 
window, 69

Select window, 100
Path, 67
Selected Commands, Retrieve 

Tables, 73
STP Name, 4, 32, 33, 35, 40, 44

STP name typed
FTRA 1.0, 44
FTRA 2.0, 44, 45
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STP Password, 33, 38
STP UserName, 33, 37
Subpath, 67

file extension
.doc, 52, 91, 116, 120
.txt, 52, 91, 116, 120

File format
CSV, 1, 71, 73, 82, 93, 95

File menu
Command File Editor window, 107
Connectivity Test Log, 49, 50
FTP-Based Table Retrieve Application 

window, 29
Retrieve Tables Log, 88
System Log, 117, 118
Update Tables Log, 112, 113

File Name: Field
Select Starting Directory window, 69
Select window, 100

File open failed - Error code 595, 124
FileManager, 23
Files of type: Field

Select Starting Directory window, 69
Select window, 100

Fingerprint
Key

DSA, 63, 64
Public Host Key

EAGLE 5 ISS, 60, 61, 63, 65
Public Key

EAGLE 5 ISS, 34, 63, 64
flag - strict host key, 61
FTP Error Codes, 123
FTP Password Field, 33, 39
FTP Retrieve and Replace Feature, 3
FTP server, 66, 140

secure, 66
FTP Server Configuration, 1, 4, 66

Menu, 28, 66
Browse button, 67, 68
Close button, 67
IP Address, 66, 140
IP Address Field, 67
Path Field, 67
Set button, 67, 70
Subpath Field, 67

Menu window, 38, 66, 67, 123, 126, 140, 
141

FTP Server Data Set window, 70
FTP Server Verification procedure, 140
FTP UserName Field, 33, 38
FTP-Based Table Retrieve Application

Edit Menu, 31, 66, 98
File Menu, 29
Help Menu, 122
View Menu, 89, 113, 118
window, 28, 29, 35, 48, 53, 56, 75, 89, 90, 

98, 113, 114, 115, 118, 119, 120, 122
File menu, 29

FTRA
Command

ftra -c, 93, 95
Initialization, 28
STP IP connection

secure, 34, 39
version level, 122

FTRA 1.0
Current STP Selected, 58
STP Configuration Record, 46

Adding, 35, 36, 37, 38, 39
STP Connection Configuration Menu

IP Address, 33, 37
IP Address Field, 32
STP Name drop down list, 40, 42
STP name typed, 44

FTRA 1.0 - software
installing

Windows, 5
FTRA 2.0

Current STP Selected, 59
FTP Server, 66
Secure FTP Server, 66
STP Configuration Record, 46, 47

Adding, 35, 36, 37, 38, 39
STP Connection Configuration

Menu window, 66
STP Connection Configuration Menu

Backup IP Address, 33
Backup IP Address Field, 37
IP Address

Backup, 33, 37
Primary, 32, 37

Primary IP Address, 33
Primary IP Address Field, 37
Secure Connection Box, 34, 39, 55, 

60, 65, 66
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STP Name drop down list, 40, 41, 
42, 43

STP name typed, 44, 45
FTRA 2.x or greater - software

installing
Windows, 14

FTRA application
exiting, 4, 29
starting, 4
using, 4

ftra -c command, 93, 95
ftra file, 61
FTRA icon, 28
FTRA Requirements

Hardware, 2
Unix Workstation, 2
Windows Workstation, 2

Software, 2
Unix Workstation, 2
Windows Workstation, 2

FTRA software
installing, 4, 5

Unix, 24
FTRA window

GTT Warning window, 71
Retrieve Tables, 4, 71, 72, 75, 93

description, 73
GTT Warning window, 71

Update Tables, 4, 97, 98, 99, 100, 101, 
106, 107, 110, 111, 112
description, 98
Select, description, 100
Update Validation Complete, 102, 

103, 104
Update Validation Complete with 

errors, 104
ftra.bat, 61
FTRA_HOME environment variable, 1, 12, 

13, 20, 21, 24

G
Generic Network Error Codes, 137
GPSM-II, 3
GTT commands

EAGLE 5 ISS
rtrv-gtt, 71, 76, 83
rtrv-tt, 71, 76, 83

GTT Feature, 71
GTT Warning window, 71

H
Hardware Requirements, 2

Unix Workstation, 2
Windows Workstation, 2

Help menu
FTP-Based Table Retrieve 

Application, 122
hexadecimal, 63
Host Key - Secure EAGLE 5 ISS

Provisioning, 60
host key checking - strict, 61
Host Key Fingerprint

Public
EAGLE 5 ISS, 60, 61, 63, 65

host key flag - strict, 61
hosts.xml, 60, 61, 63, 64, 65

I
Icon, FTRA, 28
init-card command, 60, 63, 64
Initializing the FTRA, 28
Initializing window, 28
Installing

FTRA software, 4, 5
Unix, 24
Windows - FTRA 1.0, 5
Windows - FTRA 2.x or greater, 14

Java 2 Runtime Environment 
software, 6, 15, 23

InstallShield Wizard, 7, 16
Invalid compression level is specified in the 

client configuration file - Error code 
626, 127

Invalid FTP Password warning 
window, 39

Invalid FTP User Name warning 
window, 38

Invalid IP Address warning window, 37, 
67, 68

Invalid STP Name Error Message 
window, 35

Invalid STP Name warning window, 35
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Invalid STP Password warning 
window, 38

Invalid STP User Name warning 
window, 37

IP Address, 32, 33, 66, 140, 141, 142
Backup - FTRA 2.0, 37
Backup - FTRA 2.0 or greater, 33
IPSM, 63, 64
Primary - FTRA 2.0, 37
Primary - FTRA 2.0 or greater, 33

IP address, 33
IP Address - FTRA 1.0, 37
IP Address Field, 67

Backup - FTRA 2.0 or greater, 33, 37
Primary - FTRA 2.0 or greater, 32, 37

IP Address Field - FTRA 1.0, 32, 37
IP Address warning message, 60
IP connection

FTRA and STP
secure, 34, 39

IP User Interface Feature, 3
IPSM, 3, 60, 62, 63, 64, 141, 142
IPSM IP Address, 63, 64

J
Java 2 Runtime Environment, 2, 5, 6, 7, 12, 

13, 15, 16, 20, 21, 23, 24
software, installing, 6, 15, 23

JRE - Java Runtime Environment, 2, 24
JRE_HOME environment variable, 1, 12, 

13, 20, 21, 22, 24

K
Key Fingerprint

DSA, 63, 64
Public

EAGLE 5 ISS, 34, 63, 64

L
Load button, 73, 82, 93
Log

Connectivity Test, 48, 49, 50, 51, 52
window, File Menu, 49, 50

Retrieve Tables, 28, 71, 84, 86, 88, 89, 90
window, File Menu, 88

System, 28, 117, 118, 119, 120, 121
closing, 117, 121
window, 117, 118, 119, 120, 121

File menu, 117, 118
Update Tables, 28, 97, 98, 101, 102, 103, 

104, 107, 108, 109, 110, 111, 112, 113, 
114, 115
window, 102, 108, 112, 113, 114, 

115, 116
Commit Command 

Completed, 108
File Menu, 112, 113

Look in: Field
Select Starting Directory window, 69
Select window, 100

M
MCAP, 3
Menu

Commands, 28
Connectivity Test Log

File, 49
Edit

FTP-Based Table Retrieve 
Application, 31, 98

Exit, 28
File

Command File Editor window, 107
Connectivity Test Log window, 49, 

50
FTP-Based Table Retrieve 

Application window, 29
Retrieve Tables Log window, 88
System Log window, 117, 118
Update Tables Log window, 112, 

113
FTP Server Configuration, 28, 66

Browse button, 67, 68
Set button, 67

FTP-Based Table Retrieve 
Application, 66

Help
FTP-Based Table Retrieve 

Application, 122
Retrieve Tables Log

File, 88
STP Connection Configuration, 28, 31
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View
FTP-Based Table Retrieve 

Application, 89, 113, 118
Message

Command In Progress, Cannot Close 
Window, 106

IP Address warning, 60
Must Enter Command Script File 

Name, 102
Processing Validate Request, Please 

Wait, 102, 108
Update Tables processing completed 

without errors, 107
Missing authentication context, encountered 

during the SSH user authorization - Error 
code 641, 129

Modify button, 33, 53, 54
Modify Warning window, 56
Modifying an Existing STP Configuration 

Record, 53, 60, 65
Must Enter Command Script File Name 

message, 102

N
netstat -a|grep 21, 140
Network latency, 143
No buffer space available - Error code 

55, 138
No key is available on the SSH client on the 

EAGLE 5 ISS - Error code 668, 132

O
openSSH 3.0.2p1, 125, 126, 127, 128, 129, 

130, 131, 133, 134, 135, 136, 140
Operating system, 2

Windows 2000, 12, 20
Windows 98, 13, 21
Windows NT, 13, 21
Windows XP, 12, 20

P
Packet drop, 143
pass:loc=xxxx

cmd="netstat -p tcp" EAGLE 5 ISS 
command, 142

cmd="ping yy.yy.yy.yy" EAGLE 5 ISS 
command, 141

Path Field, 67
path parameter, 67
Permission is denied by the server due to 

authentication failure - Error code 
633, 128

ping -s zz.zz.zz.zz command, 141
Primary IP Address - FTRA 2.0, 37
Primary IP Address - FTRA 2.0 or 

greater, 33
Primary IP Address Field - FTRA 2.0 or 

greater, 32, 37
Print window

Cancel button
Update Tables Log, 115

Connectivity Test Log, 51
Retrieve Tables Log, 90
System Log, 119
Update Tables Log, 114

Printing
Connectivity Test Log, 49, 51
Retrieve Tables Log, 88, 89
System Log, 117, 119
Update Tables Log, 112, 114

Problems - contacting the Customer Care 
Center, 3, 5, 63, 123, 124, 125, 126, 127, 
128, 129, 130, 131, 132, 133, 134, 135, 136, 
137, 138, 139

Procedure
Activating Controlled Features, 3
Activating the Eagle OA&M IP Security 

Enhancements Controlled 
Feature, 3, 34, 39, 55, 123

Connectivity Test - I, 140
Connectivity Test - II, 141
FTP Server Verification, 140
SFTP Server Verification, 140
SSHD Server Verification, 140

Processing Retrieve Request
Update Tables Log window, 102

Processing Validate Request, Please Wait 
message, 102, 108

Processor speed, 2
Protocol Troubleshooting, 143
Protocol wrong type for socket - Error code 

41, 137
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Provisioning the Secure EAGLE 5 ISS Host 
Key, 60

ps, 140
ps -ef|grep sshd, 123
ps -f|grep sshd, 140
Public Host Key Fingerprint

EAGLE 5 ISS, 60, 61, 63, 65
Public Key Fingerprint

EAGLE 5 ISS, 34, 63, 64

R
RAM, 2
Read-only file system - Error code 30, 139
Record, STP configuration, 31
Refresh button, 33, 40, 42, 44, 46, 56
release 30.2 or greater - EAGLE 5 ISS, 3, 34, 

39
Release Not Compatible Error - Retrieve 

Tables Log window, 74
Remove button, 73, 80
Requirements

Hardware, 2
Unix Workstation, 2
Windows Workstation, 2

Software, 2
Unix Workstation, 2
Windows Workstation, 2

Reset button, 73, 80
Retrieve button, 71, 73, 82, 83
Retrieve Database Tables from an STP, 71
Retrieve from Local Database button, 71, 

73, 82
Retrieve from STP button, 71, 73, 83
Retrieve Tables

Command List Box, 71, 73, 75, 80
Selected Commands Box, 71, 73, 78, 80, 

82
Retrieve Tables Log, 28, 71, 84, 86, 88, 89, 90

Clearing the Display, 88
closing, 88, 92
File Menu, 88
Print window, 90
Printing, 88, 89
Save window, 90, 91
saved file confirmation window, 91
saving to a file, 88, 90

Retrieve Tables Log window, 83, 85, 86, 88, 
89, 90, 92
File Menu, 88
Processing Retrieve Request, 84
Release Not Compatible Error, 74
with Errors, 87
with the RTRV-STP Command, 87
without Errors, 86

Retrieve Tables window, 4, 71, 72, 75, 93
Add button, 73, 78
Close button, 73
description, 73
GTT Warning window, 71
Load button, 73, 82, 93
Remove button, 73, 80
Reset button, 73, 80
Retrieve button, 71, 73, 82, 83
Retrieve from Local Database 

button, 71, 73, 82
Retrieve from STP button, 71, 73, 83
Store button, 73, 82, 93

Retrieving EAGLE 5 ISS database tables, 1, 
4

rst-card command, 60
rtrv commands, 73, 93, 95
rtrv-card EAGLE 5 ISS command, 3
rtrv-ctrl-feat EAGLE 5 ISS command, 3, 34, 

39, 55, 123
rtrv-feat EAGLE 5 ISS command, 71
rtrv-ftp-serv EAGLE 5 ISS command, 137
rtrv-gta EAGLE 5 ISS command, 71, 76, 83
rtrv-gtt EAGLE 5 ISS command, 71, 76, 83
rtrv-gttsel EAGLE 5 ISS command, 71, 76, 

83
rtrv-gttset EAGLE 5 ISS command, 71, 76, 

83
rtrv-ip-lnk command, 63, 64
rtrv-secu-dflt EAGLE 5 ISS command, 38
rtrv-stp EAGLE 5 ISS command, 86, 87
rtrv-trm command, 62, 63
rtrv-trm EAGLE 5 ISS command, 83
rtrv-tt EAGLE 5 ISS command, 71, 76, 83

S
Save button

Retrieve Tables Log
Save window, 91
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System Log Save window, 121
Update Tables Log Save window, 116

Save window
Cancel button

System Log, 121
Update Tables Log, 116

Connectivity Test Log, 52
Retrieve Tables Log, 90, 91
System Log, 120, 121
Update Tables Log, 115, 116

Saved File Confirmation window
Connectivity Test Log, 52, 53
Retrieve Tables Log, 91
System Log, 121
Update Tables Log, 116

Saving to a file
Connectivity Test Log, 49, 52
Retrieve Tables Log, 88, 90
System Log, 117, 120
Update Tables Log, 112, 115

secure connection, 3, 34, 60
Secure Connection Box - FTRA 2.0 or 

greater, 34, 39, 55, 60, 65, 66
Secure EAGLE 5 ISS Host Key 

Provisioning, 60
Secure FTP server, 66
Secure Host Key - EAGLE 5 ISS

Provisioning, 60
secure IP connection between FTRA and 

STP, 34, 39
Security Administration, 63
Select button, 33, 42, 44

Select Starting Directory window, 69
Select window, 99, 100

Select Starting Directory window, 67, 68, 69
Cancel button, 69
Select button, 69

Select window
Cancel button, 99, 100
description, 100
Select button, 99, 100
Update Tables, 97, 98, 99, 100

Selected Commands
Box, 71, 73, 78, 80, 82

Adding a Command, 78
Adding a Range of Commands, 79
Adding Multiple Commands, 80
Command Selected Removed, 81

Command Selected to be 
Removed, 81

Field, Retrieve Tables window, 73
Selected STP, 1, 4, 58, 71, 73, 82, 83, 97, 98, 

103, 104, 105, 107
Sending a Command File, 104

Selecting
Command, 75
Current STP, 4, 57
Multiple Commands, 77
Range of Commands, 76

Sending a Command File to the Selected 
STP, 104

Sending EAGLE 5 ISS command files, 4
Server

FTP - FTRA 2.0, 66
FTP, Configuration, 4
Secure FTP - FTRA 2.0, 66

Set button, 70
FTP Server Configuration Menu, 67

SFTP client channel open failure - Error code 
695, 136

SFTP client channel read failure - Error code 
693, 136

SFTP client channel write failure - Error code 
694, 136

SFTP Client Errors, 124
SFTP client packet send failure - Error code 

597, 124
SFTP Connection Errors, 136
SFTP Error Codes, 123
SFTP Errors, 124
SFTP packet read failure - Error code 

599, 124
SFTP protocol error - Error code 600, 125
SFTP received a invalid ID in the response 

received during a read operation on 
remote directory - Error code 608, 125

SFTP Server, 133, 136, 140
SFTP Server Verification procedure, 140
SFTP Setup Errors, 136
SFTP/SSH Error Codes, 123
SFTP: Handle mismatch error - Error code 

609, 125
Shell command prompt, 93
Socket operation on non-socket - Error code 

50, 137
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Software
FTRA

Installing, 4, 5
Unix, 24

FTRA 1.0
Installing

Windows, 5
FTRA 2.x or greater

Installing
Windows, 14

Java 2 Runtime Environment
installing, 6, 15, 23

Software caused the connection to abort - 
Error code 53, 137

Software Requirements, 2
Unix Workstation, 2
Windows Workstation, 2

SSH Client Errors, 127
SSH Connection Errors, 136
SSH Error Codes, 123
SSH failure to open the channel for the SSH 

connection with the server - Error code 
628, 127

SSH failure to setup the channel for the SSH 
connection with the server - Error code 
629, 127

SSH failure to setup the IO with the server - 
Error code 627, 127

SSH failure to verify the SSH client host key 
- Error code 630, 127

SSH Setup Errors, 136
SSH user authentication failure - Error code 

631, 128
SSH, the Secure Shell: The Definitive 

Guide, 143
SSH/SFTP Error Codes, 123
SSH/SFTP tried to close a connection that is 

already closed - Error code 678, 134
SSH/SFTP tried to set the packet size twice - 

Error code 680, 135
SSH_FXP_READLINK request failure - Error 

code 613, 126
SSH_FXP_REALPATH request failure - 

Error code 612, 126
SSHD Server, 133, 136, 140
SSHD Server Verification procedure, 140
sshtools.xml, 134
Starting the FTRA application, 4

Stop button, Update Validation Complete 
window, 103

Stop on error box
Update Tables window, 98, 101, 110, 

111, 112
Stop on error box Checked

Command File Selected
Update Tables window, 101

Stop Without Sending or Editing a 
Command File, 105

Store button, 73, 82, 93
STP

FTRA IP connection
secure, 34, 39

Retrieve Database Tables, 71
selecting current, 4

STP Added window, 39
STP Configuration Record, 31, 32, 33, 35, 

40, 42, 44, 45, 46, 47, 48, 53, 54, 55, 56, 57, 
59, 60, 65
Adding, 35, 65
Deleting, 56
Displaying, 40
FTRA 1.0, 46
FTRA 2.0, 46, 47
Modifying, 53, 60, 65
testing, 48

STP Configuration Record - FTRA 1.0
Adding, 35, 36, 37, 38, 39

STP Configuration Record - FTRA 2.0
Adding, 35, 36, 37, 38, 39

STP Connection Configuration, 1
Database, 31, 33, 34, 35, 39, 57
Menu, 28, 31
Menu window, 31, 32, 33, 35, 40, 44, 48, 

53, 56, 57, 58, 124, 141, 142
FTRA 1.0, 31
FTRA 2.0, 66
FTRA 2.0 or greater, 31, 32

STP Connection Configuration Menu
Add button, 1, 33, 35, 39
Close button, 33, 42, 44
Delete button, 33, 42, 44, 57
FTP Password Field, 33, 39
FTP UserName Field, 33, 38
IP Address, 33, 141, 142

Backup - FTRA 2.0, 37
Backup - FTRA 2.0 or greater, 33
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Primary - FTRA 2.0, 37
Primary - FTRA 2.0 or greater, 33

IP Address - FTRA 1.0, 37
IP Address Field

Backup - FTRA 2.0 or greater, 33, 37
Primary - FTRA 2.0 or greater, 32, 

37
IP Address Field - FTRA 1.0, 32, 37
Modify button, 33, 53, 54
Refresh button, 33, 40, 42, 44, 46, 56
Secure Connection Box - FTRA 2.0 or 

greater, 34, 39, 55, 60, 65, 66
Select button, 33, 44
STP Name drop down list, 33, 40

FTRA 1.0, 40, 42
FTRA 2.0, 40, 41, 42, 43

STP Name Field, 4, 32, 33, 35, 40, 44
STP name typed

FTRA 1.0, 44
FTRA 2.0, 44, 45

STP Password Field, 33, 38
STP UserName Field, 33, 37
Test button, 33, 42, 44, 48
Use STP and FTP UserNames, 

Passwords for all STPs Box, 34, 35, 
53, 54, 55

STP Connectivity Test, 1
STP Data Modified window, 54, 56
STP Name, 32, 33, 34, 35, 39, 40, 41, 42, 44, 

47, 53, 57, 58, 59
entering, 44

STP Name does not exist error message, 47
STP Name drop down list, 33, 40

FTRA 1.0, 40, 42
FTRA 2.0, 40, 41, 42, 43

STP Name Field, 4, 32, 33, 35, 40, 44
STP name typed

FTRA 1.0, 44
FTRA 2.0, 44, 45

STP Password Field, 33, 38
STP Selection Change window, 33, 58, 59
STP UserName Field, 33, 37
strict host key checking, 61
strict host key flag, 61
Subpath Field, 67
Sun Microsystems, 5, 24

Support - contacting the Customer Care 
Center, 3, 5, 63, 123, 124, 125, 126, 127, 
128, 129, 130, 131, 132, 133, 134, 135, 136, 
137, 138, 139

system environment variable, 12, 20
System Log, 28, 117, 118, 119, 120, 121

Clearing the Display, 117, 118
closing, 117, 121
Print window, 119
Printing, 117, 119
Save window, 120, 121
saved file confirmation window, 121
saving to a file, 117, 120

System Log window, 117, 118, 119, 120, 121
Cancel button, 119
File menu, 117, 118

T
Task Scheduler

Windows, 93, 95
TCP Out of Order, 143
TCP Packet Delay, 143
TCP Packet Error, 143
TCP Packet Errors, 143
TCP Packet Loss, 143
TDM, 3
Technical Assistance - contacting the 

Customer Care Center, 3, 5, 63, 123, 
124, 125, 126, 127, 128, 129, 130, 131, 132, 
133, 134, 135, 136, 137, 138, 139

telnet server, 60
Telnet terminals, 33, 63, 83
Terminals

EAGLE 5 ISS
Telnet, 33, 63, 83

Test button, 33, 42, 44, 48
Testing an STP Configuration Record, 48
The address family is not supported - Error 

code 47, 137
The address is already in use - Error code 

48, 137
The authentication method is NULL in the 

client software - Error code 632, 128
The connection timed out - Error code 

60, 138
The connection timed out when SSH tried to 

connect to SSHD - Error code 682, 136
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The connection was refused - Error code 
61, 138

The connection was reset by the peer - Error 
code 54, 138

The debug levels allowed for SSH protocol in 
openSSH is 0-9 - Error code 624, 127

The file name is already specified - Error 
code 596, 124

The host is down - Error code 67, 139
The host was not specified in the SSH client 

on the EAGLE 5 ISS - Error code 
659, 131

The hostname was not specified in the SSH 
client on the EAGLE 5 ISS - Error code 
661, 132

The network channel is down - Error code 
691, 136

The network dropped the connection on 
reset - Error code 52, 137

The network has reset - Error code 685, 136
The network is down - Error code 62, 139
The network is unreachable - Error code 

51, 137
The operation is not supported on the socket 

- Error code 45, 137
The protocol family is not supported - Error 

code 46, 137
The protocol is not available - Error code 

42, 137
The protocol is not supported - Error code 

43l, 137
The requested address cannot be assigned - 

Error code 49, 137
The secure connection was closed by the 

remote server - Error code 669, 133
The SFTP client failed to read the data from 

the file descriptor - Error code 616, 126
The SFTP client received more data than 

expected - Error code 615, 126
The SFTP connection is closed - Error code 

598, 124
The SFTP/SSH connection has been reset by 

the peer - Error code 687, 136
The socket is already connected - Error code 

56, 138
The socket is not connected - Error code 

57, 138

The socket type is not supported - Error code 
44, 137

The SSH client key length is invalid - Error 
code 667, 132

The SSH client was unable to load the cipher 
type on the EAGLE 5 ISS - Error code 
663, 132

The SSH connection was refused by the 
remote server - Error code 683, 136

The SSH/SFTP client on the EAGLE 5 ISS 
failed to read from the remote side - Error 
code 674, 134

The SSH/SFTP client on the EAGLE 5 ISS 
failed to write to the remote side - Error 
code 679, 135

The SSH/SFTP connection has been aborted 
- Error code 686, 136

The SSH/SFTP socket is already connected - 
Error code 689, 136

The SSH/SFTP socket is not connected - 
Error code 690, 136

The SSHD server is unreachable - Error code 
684, 136

The SSHD/SFTP server connection host is 
down - Error code 692, 136

There is no route to the host - Error code 
65, 139

Too many references: can’t splice - Error 
code 59, 138

Troubleshooting Procedures, 140

U
UIM - Unsolicited Information Message

EAGLE 5 ISS, 63, 64, 83
UIM 1493, 63, 64
UIM 1494, 63, 64
Undefined - Error code 601, 125
Undefined SFTP/SSH error - Error code 

643, 129
Unexpected SSH_FXP_NAME - Error code 

611, 125
unexpected SSH_FXP_NAME - Error code 

614, 126
Unexpected SSH_FXP_STATUS error - Error 

code 644, 129
Unexpected SSH2_FXP_ATTRS - Error code 

610, 125
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Unix Workstation Requirements, 2
Unknown cipher number on the SSH client 

on the EAGLE 5 ISS - Error code 
666, 132

Unsupported value - Error code 35, 139
Update Tables Log, 28, 97, 98, 101, 102, 103, 

104, 107, 108, 109, 110, 111, 112, 113, 114, 
115
Clearing the Display, 112, 113
closing, 112, 116
Print window, 114
Printing, 112, 114
Save window, 115, 116
saved file confirmation window, 116
saving to a file, 112, 115

Update Tables Log window, 102, 108, 112, 
113, 114, 115, 116
Commit Command Completed, 108
File Menu, 112
File menu, 112, 113
Processing Retrieve Request, 102

Update Tables processing completed 
without errors message, 107

Update Tables window, 4, 97, 98, 99, 100, 
101, 106, 107, 110, 111, 112
Browse button, 98, 99
Close button, 98
Command File field, 99, 100, 102
Command File Selected, 99

Stop on error box Checked, 101
description, 98
Select window, description, 100
Update Validation Complete Window

Update Tables
Update Validation 

Complete, 102, 103, 104
Update Validation Complete 

window, 97, 103, 105, 106
with errors Window

Update Tables
Update Validation Complete

with errors, 104
Validate button, 97, 98, 102

Update Validation Complete window, 97, 
102, 103, 104, 105, 106
description, 103
with errors, 104
without errors, 104

Updating Database Tables in the Selected 
STP, 97

Use STP and FTP UserNames, Passwords for 
all STPs Box, 34, 35, 53, 54, 55

user environment variables, 12, 20
User Guide Conventions, 1
User login failure - Error code 633, 124
Using the FTRA application, 4

V
Validate button

Update Tables, 98, 102
Update Tables window, 97

Validating command files, 2
Variable

environment
FTRA_HOME, 1, 12, 13, 20, 21, 24
JRE_HOME, 1, 12, 13, 20, 21, 22, 24

system environment, 12, 20, 24
user environment, 12, 13, 20, 21, 24

Version level, 122
View menu

FTP-Based Table Retrieve 
Application, 89, 113, 118

Viewing log files, 2

W
Window

About FTRA, 28, 122
Command Complete Connectivity 

Test, 49
Command File Editor, 103, 105, 106, 

107
File Menu, 107
Invalid Command, 106

Command File Editor window
File Menu, 107

Commands Menu, 73, 82, 98
Connectivity Test Log, 48, 49, 50, 51, 52, 

53, 61, 64, 65
closing, 49, 53
File Menu, 49, 50
Print, 51
Save, 52
Saved file confirmation, 52, 53
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with errors, 49
with no errors, 48

Exit, 29, 30
Exit Confirmation, 29
FTP Server Configuration Menu, 38, 66, 

67, 123, 126, 140, 141
FTP Server Data Set, 70
FTP-Based Table Retrieve 

Application, 28, 29, 35, 48, 53, 56, 75, 
89, 90, 98, 113, 114, 115, 118, 119, 120, 
122

GTT Warning, 71
Initializing, 28
Invalid FTP Password warning, 39
Invalid FTP User Name warning, 38
Invalid IP Address warning, 37, 67, 68
Invalid STP Name Error Message, 35
Invalid STP Name warning, 35
Invalid STP Password warning, 38
Invalid STP User Name warning, 37
Modify Warning, 56
Print

Retrieve Tables Log, 90
Update Tables Log, 115

Retrieve Tables, 4, 71, 72, 75, 93
Add button, 73, 78
Close button, 73
Command Complete, 71, 84, 85
Command List Field, 73
description, 73
GTT Warning, 71
Load button, 73, 82, 93
Remove button, 73, 80
Reset button, 73, 80
Retrieve button, 71, 73, 82, 83
Retrieve from Local Database 

button, 71, 73, 82
Retrieve from STP button, 71, 73, 83
Selected Commands Field, 73
Store button, 73, 82, 93

Retrieve Tables Log, 83, 85, 86, 88, 89, 
90, 92
closing, 88, 92
File Menu, 88
Print, 90
Processing Retrieve Request, 84
Release Not Compatible Error, 74
Save, 90, 91

Saved file confirmation, 91
with Errors, 87
with the RTRV-STP Command, 87
without Errors, 86

Save
Retrieve Tables window, 91

Select
File Name: Field, 100
Files of type: Field, 100
Look in: Field, 100
Update Tables, 97, 98, 99, 100

Select Starting Directory, 67, 68, 69
File Name: Field, 69
Files of type: Field, 69
Look in: Field, 69

Select, description, 100
STP Added, 39
STP Connection Configuration 

Menu, 31, 32, 33, 35, 40, 44, 48, 53, 
56, 57, 58, 124, 141, 142
FTRA 1.0, 31
FTRA 2.0, 66
FTRA 2.0 or greater, 31, 32

STP Data Deleted, 57
STP Data Modified, 54, 56
STP Selection Change, 33, 58, 59
System Log, 117, 118, 119, 120, 121

closing, 117, 121
File Menu, 117, 118
Print, 119
Print window

Cancel button, 119
Save, 120, 121
Saved file confirmation, 121

Update Tables, 4, 97, 98, 99, 100, 101, 
106, 107, 110, 111, 112
Browse button, 98, 99
Close button, 98
Command Complete, 103, 104, 107
Command File field, 99, 100, 102
Command File Selected, 99
Command List Field, 98
description, 98
Select, description, 100
Stop on error box, 98, 101, 110, 111, 

112
Update Validation Complete, 103
Validate button, 97, 98, 102
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Update Tables Log, 102, 108, 112, 113, 
114, 115, 116
closing, 112, 116
Commit Command 

Completed, 108
File Menu, 112, 113
Print, 114
Processing Retrieve Request, 102
Save, 115, 116
Saved file confirmation, 116

Update Validation Complete, 97, 102, 
103, 104, 105, 106
Commit button, 103, 104
description, 103
Edit button, 103, 104, 105, 106
Stop button, 103
with errors, 104
without errors, 104

Windows 2000 operating system, 12, 20
Windows 98 operating system, 13, 21
Windows Explorer, 5, 14
Windows NT operating system, 13, 21
Windows Task Scheduler, 93, 95
Windows Workstation Requirements, 2
Windows XP operating system, 12, 20
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