3.20 Hyper-V related services fail to start on Oracle Linux 7 update 3 guest with UEK R4 kernel under Windows Hyper-V Server

For an Oracle Linux 7 update 3 guest with UEK R4 kernel running on Windows Hyper-V Server, the hypervkvpd and hypervvssd services fail to start if the Hyper-V packages are at version 0-0.29.20160216git.el7.

The workaround is to downgrade the package version to 0-0.26.20150402git.el7 for the following packages:

  • hyperv-daemons

  • hyperv-daemons-license

  • hypervfcopyd

  • hypervkvpd

  • hypervvssd

These userspace packages are available in both the ol7_latest yum repository and in the ol7_x86_64_UEKR4 ULN channel.

Use the yum utility to downgrade the packages. For example:

  1. Stop any running Hyper-V services:

    # systemctl stop hypervfcopyd.service
    # systemctl stop hypervkvpd.service
    # systemctl stop hypervvssd.service
  2. Downgrade the packages:

    # yum downgrade hyperv*
  3. Restart the Hyper-V services:

    # systemctl restart hypervfcopyd.service
    # systemctl restart hypervkvpd.service
    # systemctl restart hypervvssd.service
  4. Modify your Yum configuration to exclude the Hyper-V packages from future updates. For example:

    # echo "exclude = hyperv*" >> /etc/yum.conf

    Remember that you may want to remove this exclude at a later date when this issue is resolved.

(Bug ID 24745861)