1.5 MySQL Community and MariaDB Packages

Note that the MySQL Community packages in this release update have been updated from MySQL Community 5.6 to MySQL Community 5.7.

In the initial release of Oracle Linux 7, the MySQL Community 5.6 packages were provided on the Oracle Linux 7 full installation DVD image but were not installable using the Anaconda installer or kickstart. The ISO image for this update to Oracle Linux 7 provides support for installing either MySQL 5.7 or MariaDB by using either the Anaconda installer or kickstart.

It is not possible to install MySQL and MariaDB on the same system as package conflicts exist. Installing the MySQL packages replaces any conflicting MariaDB packages.

By default, neither MySQL 5.7 packages nor MariaDB packages are installed. It is possible to install either the MySQL 5.7 package group or the MariaDB package group on a system by using the graphical installer or kickstart, but not both package groups.

To install the MySQL 5.7 packages using kickstart, specify the @mysql package group in the %packages section. If you also specify @mariadb, it is ignored.

To install the MariaDB packages using kickstart, specify @mariadb but not @mysql in the %packages section.

Note

If you want to install MariaDB, you must deselect the MySQL repository. Otherwise, MySQL is installed even if you select only the MariaDB group. (Bug ID 22238684)

The MySQL Community 5.7, MySQL Community 5.6 and MySQL Community 5.5 packages are also available on the Unbreakable Linux Network (ULN) and Oracle Linux yum server.