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FTP-Based Table Retrieve Application (FTRA)

Overview

The FIP-Based Table Retrieve Application (FTRA) is designed in conjunction with
the FIP Retrieve and Replace feature to transfer EAGLE 5 ISS database tables
using an FTP session to a remote server for offline processing. The FTRA is a
stand-alone application that interfaces with one or more STPs. Database tables
can be retrieved from the EAGLE 5 ISS, using the EAGLE 5 ISS’s retrieve
commands. The output of these retrieve commands is converted to CSV (comma
separated value) files. EAGLE 5 ISS commands in the form of a command file can
be read into the FTRA where they are validated and sent to the selected STP. Logs
are provided for event tracking and error message display.

The FTRA provides the following features through the use of a graphical user
interface:

¢ STP Connection Configuration.
¢ STP Connectivity Test.
e FIP Server Configuration.

* Retrieving the EAGLE 5 ISS database tables with the results converted to CSV
tiles.

¢ Automated or manual retrieval of database tables from multiple STPs with
the command line interface. The results are converted to CSV files.

¢ Configuration provisioning for automated retrieval of database tables from
multiple STPs.

¢ Validation of the command files before being sent to the STP
¢ Validation of STP database update command files using an offline database
¢ Command file editing

¢ Viewing the log files for event tracking and error message display.
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Document Conventions

In order to clearly differentiate between references to objects, actions, literal
entries, and user-supplied information, the following conventions are used in this
user guide:

¢ Menu selections and buttons are shown in bold, and the steps in a menu path
are represented with “>”. For example:

Select Edit > STP Connection Configuration from the menu.

The Add button is not enabled when the STP Connection Configuration
menu opens.

¢ Commands and entries that must be entered exactly as shown in this
document are shown in the 10 point Courier bold font. For example:

Using a text editor (such as Notepad) add the following lines to the
AUTOEXEC.BAT file:

SET FTRA HOME="C:\<download_directory>"

SET JRE HOME="C:\Program Files\Java\j2rel.4.0 01~

¢ User-specific information is shown in italics and enclosed in “<>". For
example, the name of the folder you wish to use as the download directory in
the previous example is shown as <download_directory>.

Documentation Packaging and Updates

Customer documentation is updated whenever significant changes that affect
EAGLE 5 ISS operation or configuration are made.

The document part number is shown on the title page along with the current
revision of the document, the date of publication, and, if applicable, the software
release that the document covers. The bottom of each page contains the document
part number and the date of publication.

Documentation Admonishments

Admonishments are icons and text that may appear in this and other EAGLE 5
ISS manuals that alert the reader to assure personal safety, to minimize possible
service interruptions, and to warn of the potential for equipment damage.

Following are the admonishments, listed in descending order of priority.

DANGER:
@ (This icon and text indicate the possibility of personal injury.)
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WARNING:

CAUTION:
A (This icon and text indicate the possibility of service interruption.)

(This icon and text indicate the possibility of equipment damage.)

Customer Care Center

The Customer Care Center offers a point of contact through which customers can
receive support for problems that may be encountered during the use of Tekelec’s
products. The Customer Care Center is staffed with highly trained engineers to
provide solutions to your technical questions and issues seven days a week,
twenty-four hours a day. A variety of service programs are available through the
Customer Care Center to maximize the performance of Tekelec products that
meet and exceed customer needs.

To receive technical assistance, call the Customer Care Center at one of the
following locations:

e Tekelec, UK

Phone: +44 1784 467 804
Fax: +44 1784 477 120
Email: ecscetekelec.com

e Tekelec, USA

Phone (within the continental US) 888-367-8552 (888-FOR-TKLC)
(outside the continental US) +1 919-460-2150.

Email: support@tekelec.com.

When your call is received, the Customer Care Center issues a Customer Service
Report (CSR). Each CSR includes an individual tracking number. When a CSR is
issued, the Customer Care Center determines the classification of the trouble. The
CSR contains the serial number of the system, problem symptoms, and messages.
The Customer Care Center assigns the CSR to a primary engineer, who will work
to solve the problem. The Customer Care Center closes the CSR when the
problem is resolved.

If a critical problem exists, the Customer Care Center initiates emergency
procedures (see the following topic, “Emergency Response”).
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Emergency Response

If a critical service situation occurs, the Customer Care Center offers emergency
response twenty-four hours a day, seven days a week. The emergency response
provides immediate coverage, automatic escalation, and other features to ensure a
rapid resolution to the problem.

A critical situation is defined as an EAGLE 5 ISS or LSMS problem that severely
affects service, traffic, or maintenance capabilities, and requires immediate
corrective action. Critical problems affect service or system operation, resulting in:

¢ Failure in the system that prevents transaction processing

¢ Reduction in EAGLE 5 ISS capacity or in EAGLE 5 ISS traffic-handling
capability

¢ Inability to restart the EAGLE 5 ISS

¢ Corruption of the database

¢ Inability to perform maintenance or recovery operations

¢ Inability to provide any required critical or major trouble notification

* Any other problem severely affecting service, capacity, traffic, and billing.
Maintenance capabilities may be defined as critical by prior discussion and
agreement with the Customer Care Center.
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FTRA Initialization

To start the FTRA, double-click the FTRA icon on the desktop. When the
application starts, the FTP-Based Table Retrieve Application window is
displayed. See Figure 1. The Initializing window opens and displays the message

“Initializing, please wait......... ” until the initialization process has been
completed.
Figure 1. FTP-Based Table Retrieve Application Window

h‘:‘,; FTP-based Table Retrieve Application <> - 100 x|
File Edit View Help

Initializing

Initializing, please wait

Table 1 shows the description of the menus in the FTP-Based Table Retrieve
Application window.

Table 1. FIP-Based Table Retrieve Application Menu

Description
Item Description
File Selects the Exit menu.
Edit Selects the STP Connection Configuration menu, the FTP Server

Configuration menu, or the Commands menu

View Selects these logs:
¢ The Retrieve Tables Log
¢ The Update Tables Log

® The System Log.
Help Selects the About FTRA window.
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Exit the FTRA

To close the FTP-Based Table Retrieve Application window and exit the FTRA,
either select File > Exit from the File menu, see Figure 2, or click the close window
button in the upper right hand corner of the window.

Figure 2. File Menu in the FTP-Based Table Retrieve
Application Window

B FTP-based Table Retrieve Application <>
Edit View Help

The Exit? confirmation window (see Figure 3) opens with “You are about to exit.
Continue?” Click OK to exit and close the application. The Exit window (see
Figure 4 on page 4) is displayed until the Exit process is completed. To cancel the
exit and resume using the application, click Cancel.

Figure 3. Exit Confirmation Window

A You are about to exit. Continue?

| @ || Cancel|
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Figure 4. Exit Window

?':; FTP-based Table Retrieve Application <=
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STP Connection Configuration Menu

Before database tables can be retrieved from an STP, or command files can be sent
to an STP, the STP must be defined as an STP configuration record in the STP
Connection Configuration database. The STP configuration record is configured
and selected using the STP Connection Configuration Menu window.

The STP Connection Configuration Menu window is displayed by selecting
Edit > STP Connection Configuration. See Figure 5.

Figure 5. Edit Menu
@, FTP-based Table Retrieve Application <stpl: -0l x|
File View Help
FTP Server Configuration
Commands
Figure 6. STP Connection Configuration Menu Window
(FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2>
File Edit View Help

STP Connection Configuration Menu

Current STP Selected: STP 2

STP Name
| | A | | Refresh |
Primary IP Address

| [ test ]
Back-Up IP Address

| [ Test ]

[_] Secure Connection
STP UserName

STP Password

FTP UserName

[_] Use STP and FTP UserNames, Passwords for all STPs

FTP Password

| Select | aa | meay | Do | Clse |

Table 2 shows the description of the fields, buttons, and boxes in the STP
Connection Configuration Menu window.
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Table 2. STP Connection Configuration Menu Description
Item Description
Fields

STP Name Contains the STP Names. The STP name must contain at least one
alphanumeric character and a maximum of 64 upper-case alphanumeric
characters. The STP Name will always be entered in uppercase regardless
of the Caps Lock key setting on your keyboard.

This field also provides a drop down list for selecting stored STP
configuration records.

Primary IP The primary IP address of the associated STP (used for telnet sessions).

Address (FTRA | The FTRA uses this IP address first when connecting to the STP. The

4.0) primary IP address is the IP address of an IPSM in the associated EAGLE
5ISS.

Backup IP The backup IP address of the associated STP (used for telnet sessions).

Address (FTRA | The FTRA uses this IP address when the connection using the primary IP

4.0) address fails. The backup IP address should be the IP address of another
IPSM in the same EAGLE 5 ISS.

STP UserName | The user name assigned to the user by the STP system administrator
(used for telnet sessions).

STP Password The password assigned to the user by the STP system administrator (used
for telnet sessions).

FTP UserName | The FTP user name assigned to the user by the administrator (used for
FTP). Any FIP user name with symbols must be enclosed within double
quotation marks (for example, to specify the FTP user name mylogin#1,
you would enter “mylogin#1”).

FTP Password The FTP password assigned to the user by the administrator (used for
FTP).

Buttons

Refresh Displays the data of the STP configuration record typed in the STP Name
tield. If an STP name is selected from the STP Name drop down list, the
data fields are automatically displayed.

Test Verifies that the FTRA can successfully connect and login to the EAGLE
5 ISS through an available telnet terminal at the specified IP address.
For FTRA 4.0, the STP Connection Configuration Menu window has two
Test buttons, one for the Primary IP address, and one for the Backup IP
address.

Select Selects the displayed STP name to be connected to the FTRA. The STP
Selection Change window opens to verify if you want to proceed.

Add Adds a newly entered STP configuration record and associated data to
the STP Connection Configuration database.

Modify Modifies the fields of the displayed STP configuration record.
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Table 2. STP Connection Configuration Menu Description (Continued)
Item Description
Delete Deletes the displayed STP configuration record and associated data from

the STP Connection Configuration database.

Close

Closes the STP Connection Configuration Menu window.

Secure
Connection
(FTRA 4.0)

Enables the FTRA to use a secure IP connection to the STP.

To use a secure connection for the FTRA to EAGLE 5 ISS communication,
make sure the EAGLE 5 ISS is running release 30.2 or greater and that the
Eagle OA&M IP Security Enhancements feature is enabled and activated.
This can be verified by entering the rtrv-ctrl-feat command at the
EAGLE5ISS. If the Eagle OA&M IP Security Enhancements feature is not
enabled or activated, perform the “Activating the Eagle OA&M IP
Security Enhancements Controlled Feature” procedure in the Database
Administration Manual - System Management and enable and activate the
Eagle OA&M IP Security Enhancements feature.

NOTE: This box should be unchecked if the Eagle OA&M IP
Security Enhancements feature is not enabled or activated, and
will not be enabled or activated.

If this box is checked, the public key fingerprint for the EAGLE 5 ISS
specified in this window must be installed onto the FTRA for the FTRA
and the specified EAGLE 5 ISS to use a secure connection. After this STP
is added to the STP Connection Configuration database, add the public
key fingerprint to the FTRA by performing the “Secure EAGLE 5 ISS Host
Key Provisioning” procedure on page 29.

Use STP and FTIP
UserNames,
Passwords for all
STPs Box

All the STP and FTP user names and passwords of all the provisioned
STPs are changed to the user name and password of the displayed STP
name. This change occurs only when the Add or Modify buttons are used.

910-4919-001 Rev B, April 2007 2-7




User Guide

FTP-Based Table Retrieve Application (FTRA)

Adding an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table

Retrieve Application window. See Figure 5 on page 5. The STP Connection
Configuration Menu window opens. The Add button is not enabled when
the STP Connection Configuration Menu window opens.

Enter the STP name in the STP Name field of the STP Connection
Configuration Menu window. The STP name must contain at least one
alphanumeric character, with a maximum of 64 upper-case characters
(alphanumeric, letters and numbers, and spaces). or Figure 8 on page 9
(FTRA 4.0). The STP Name will always be entered in uppercase regardless of
the Caps Lock key setting on your keyboard.

If characters other then alphanumeric characters or spaces are included in the
STP name, the Invalid STP Name warning window is displayed. See Figure
7.If the Invalid STP Name window appears, click OK, and reenter the STP
name in the STP Name field with the correct characters.

NOTE: When the new STP name is entered into the STP Name field, the
Add button is enabled. If the STP name matches an existing STP name in
the STP Connection Configuration database, the Add button is disabled. If
you wish to display the existing STP names, go to the “Displaying an
Existing STP Configuration Record” procedure on page 13.

NOTE: If the “Use STP and FTP UserNames and Passwords for all STPs”
box is checked when the Add button is clicked, all the user names and
passwords for all provisioned STP Names are changed to those of the
added STP name.

NOTE: Existing STP configuration records can be changed. Go to the
“Modifying an Existing STP Configuration Record” procedure on page 23
to change an existing STP configuration record.

Figure 7. Invalid STP Name Error Message

Warning

Invalid STP Name
2 . Letters, humhers and spaces only
Maximum length 64 characters
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Figure 8. Adding an STP Configuration Record
(FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2>
File Edit View Help

STP Connection Configuration Menu =

Current STP Selected: 5TP 2

Primary IP Address
10234

Back-Up IP Address
10235

["] Secure Connection

STP UserHame
|eag|e

STP Password

Lo

FTP Userdame
|eag|e1 |

FTP Password

|

[_] Use STP and FTP UserNames, Passwords for all STPs

© select | A0 | ooy | Delete | Close

3. Enter the IP address want to connect to the STP in the Primary IP Address
tield, and a backup IP address in the Backup IP Address field. See Figure 8 on
page 9 (FTRA 4.0).

the FTRA will not be able to connect to the STP when the connection to the
STP using the primary IP address fails. It is recommended that you specify
a backup IP address for the STP.

j CAUTION: If the backup IP address is not entered for FTRAs running 4.0,

If the primary and backup IP addresses (FTRA 4.0) are not entered correctly,
the Invalid IP Address warning window is displayed. See Figure 9. If the
Invalid IP Address window appears, click OK, and re-enter the IP address in
the primary or backup IP addresses box (FTRA 4.0) in the Primary IP Address
or Backup IP Address fields in the correct format.
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Figure 9. Invalid IP Address Error Message

Invalid IP Address

4. Enter the STP user name for this STP in the STP UserName field. The user
name is assigned to the user by the STP system administrator for telnet
sessions. See Figure 8 on page 9 (FIRA 4.0). If the format of the STP user
name is not correct, the Invalid STP User Name warning window is
displayed. See Figure 10. If the Invalid STP User Name window appears,
click OK, and re-enter the STP user name in the STP UserName field.

Figure 10. Invalid STP User Name Error Message

Invalid STP Username

5. Enter the STP password for this STP in the STP Password field. The password
is assigned to the user by the EAGLE 5 ISS system administrator for telnet
sessions. See Figure 8 on page 9 (FIRA 4.0). If the format of the STP
password is not correct, the Invalid STP Password warning window is
displayed. See Figure 11. If the Invalid STP Password window appears, click
OK, and re-enter the STP password in the STP Password field.

NOTE: The STP Password field does not check for invalid EAGLE 5 ISS
passwords. The passwords are validated by the EAGLE 5 ISS when the
FTRA attempts a connection to the EAGLE 5 ISS. The requirements for the
format of EAGLE 5 ISS passwords is shown in the output of the EAGLE 5
ISS’s rtrv-secu-dflt command.

Figure 11. Invalid STP Password Error Message

Invalid STP Password
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6. Enter the FTP user name assigned by the FIP server administrator in the FTP
UserName field. See Figure 8 on page 9 (FIRA 4.0). Any FIP user name with
symbols must be enclosed within double quotation marks (for example, to
specify the FTP user name mylogin#1, you would enter “mylogin#1~). If the
format of the FIP user name is not correct, the Invalid FTP User Name
warning window is displayed. See Figure 12. If the Invalid FTP User Name
window appears, click OK, and re-enter the FTP user name in the FTP
UserName field.

NOTE: Any firewall between the FTRA and the FTP server configured in
the FTP Server Configuration Menu window (Figure 35 on page 36), must
allow FTPs to the IP address specified in the FTP Server Configuration
Menu window.

Figure 12. Invalid FTP User Name Error Message
warning . x|

Invalid FTP Username

7. Enter the FTP password assigned by the FIP server administrator in the FTP
Password field. See Figure 8 on page 9 (FTRA 4.0). If the format of the FTP
password is not correct, the Invalid FTP Password warning window is
displayed. See Figure 13. If the Invalid FTP Password window appears, click
OK, and re-enter the FIP password in the FTP Password field.

Figure 13. Invalid FTP Password Error Message

warning x|

Invalid FTP Password

NOTE: If you are running FTRA 4.0 and not enabling a secure connection
to the STP, skip this step and go to step 9.

8. To enable a secure connection between the FIRA and the STP being added in
this procedure, click in the Secure Connection box.

Make sure the EAGLE 5 ISS is running release 30.2 or greater and that the
Eagle OA&M IP Security Enhancements feature is enabled and activated. This
can be verified by entering the rtrv-ctrl-feat command at the EAGLE 5
ISS. If the Eagle OA&M IP Security Enhancements feature is not enabled or
activated, perform the “Activating the Eagle OA&M IP Security
Enhancements Controlled Feature” procedure in the Database Administration
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Manual - System Management and enable and activate the Eagle OA&M IP
Security Enhancements feature.

9. Click the Add button. See Figure 8 on page 9 (FITRA 4.0). The newly entered
STP Name and associated data is added to the STP Connection Configuration
database, and the STP Added window (Figure 14) is displayed. Click OK to
continue.

Figure 14. STP Added Window

Information |

%ﬁ STP Added

10. Verify the addition of the new STP name. See the “Displaying an Existing STP
Configuration Record” procedure on page 13.
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Displaying an Existing STP Configuration Record
An existing STP configuration record can be displayed by either selecting the STP
Name from the STP Name drop down list, or by re-entering the STP name in the

STP Name field in the STP Connection Configuration Menu window and
clicking the Refresh button.

To Use the STP Name Drop Down List

Procedure

1. Inthe STP Connection Configuration Menu window;, click on the STP Name
drop down list. The STP Name drop down list opens. Move the cursor to the
STP name to be selected. Click on the desired STP name in the drop down list.
See Figure 15 on page 13 (FTRA 4.0).

Figure 15. Selecting an STP Name from the STP Name Drop
Down List (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2> =15
File Edit View Help

STP Connection Configuration Menu

Current STP Selected: STP 2

STP Name

| hd | | Refresh |
STP 1 Test
3TF 3
STFP B
5TP 2 Test

STP UserName

STP Password

FTP UserName

[_] Use STP and FTP UserNames, Passwords for all STPs

FTP Password

| select | o0 | wes | et | Clese
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2. When the STP name is selected in step 1, the STP configuration record for the
specified STP is displayed. See Figure 16 on page 14 (FITRA 4.0). The Refresh,
Test, Select, Delete, and Close buttons are enabled.

Figure 16. STP Name Selected from the STP Name Drop
Down List (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2>
File Edit Yiew Help

STP Connection Configuration Menu

Current 5TP Selected: STP 2
STP Name
TP 4 \v| | Refresh |

Primary IP Address
10238 || Test |
Back-Up IP Address
10239 || Test |

[¥] Secure Connection

STP UserName
|eag le |

STP Password

| |

FTP UserName
eaplet |

FTP Password

|

[C] Use STP and FTP UserNames, Passwords far all STPs

select || || mosiy | | close

To Enter the STP Name

Procedure

1. Type the STP name in the STP Name field in the STP Connection
Configuration Menu window. See Figure 17 on page 15 (FTRA 4.0). The
Refresh, Test, Select, Delete, and Close buttons are enabled.
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Figure 17. Selecting a STP Configuration Record by Typing in
the STP Name Field (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2=
File Edit View Help

STP Connection Configuration Menu

Current STP Selected: STP 2
STP Name

ST § \v| | Refresh |
Primary IP Address

|| Test |
Back-Up IP Address

L Test |

[_] Secure Connection
STP UserName

STP Password

FTP Userdame

[C] Use STP and FTP UserNames, Passwords for all STPs

FTP Password

| Selet | 40wl | Delete || Close

2. Click the Refresh button. The STP configuration record for the specified STP
is displayed. See Figure 18 on page 16 (FITRA 4.0).

910-4919-001 Rev B, April 2007 2-15



User Guide FTP-Based Table Retrieve Application (FTRA)

Figure 18. STP Configuration Record (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2>
File Edit Yiew Help

STP Connection Configuration Men

Current STP Selected: STP 2

STP Hame

I5TP 5 'v| | Refresh |
Primary IP Address

102310 L Test |

Back-Up IP Address
102311 | Test |

[¥] Secure Connection

STP UserName
|eag le |

STP Password

|

FTP UserName
user2 |

FTP Password

|

[C] Use STP and FTP UserMames, Passwords for all STPs

| select | 400wk | Delete || Close

3. If the STP name was entered incorrectly, or is not in the STP configuration
record database, the “STP Name does not exist” error message is displayed.
See Figure 19.

Figure 19. STP Name Does Not Exist Error Message

STP Hame does not exist
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Testing an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FIP-Based Table

Retrieve Application window. See Figure 5 on page 5. The STP Connection
Configuration Menu window opens.

2. Display the STP configuration record being modified. Go to the “Displaying
an Existing STP Configuration Record” procedure on page 13.

3. Click the Test button. The Connectivity Test Log window opens. See Figure
20 and Figure 21 on page 18. The Connectivity Test Log contains the events of
the Test process and any error messages that may have occurred. The
Connectivity Test Log window opens at the start of the Test process and is
automatically cleared whenever a subsequent Test process is initiated.

Figure 20. Connectivity Test Log Window with No Errors

& FTP-based Table Retrieve Application <=
File Edit Wiew Help

=10/ ]

Connectivity Test Log
File

Stp Connectivity Test Process Manager: Stp Connectivity Test Begun

Telnet Terminal Session Manager: Initiating Telnet Session with Eagle

Telnet Terminal Session Manager: Session Connected: 10.1.2.10:8080

Telnet Terminal Session Manager: Terminal 17 Enabled

Telnet Terminal Session Manager: User "eagle" Login Attempt: 1

Telnet Terminal Session Manager: User "eagle" Login Accepted

Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1

Telnet Terminal Session Manager: User "eagle" Logout Accepted

Stp Connectivity Test Process Manager: Stp Connectivity Test Complete Without Errors
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Figure 21. Connectivity Test Log Window with Errors

& FTP-based Table Retrieve Application <>

_|o) x|
File Edit Yiew Help

Connhecthity Test Log -

File

Stp Connectivity Test Process Manager: Testing stp4
Telnet Terminal Session Manager: Initiating Telnet Session with Eagle

Telnet Terminal Session Manager: Session Not Connected: 10.1.2.1:8080
Stp Connectivity Test Process Manager: Test Complete With Errors

4.

When the test is complete, the Command Complete window opens. See
Figure 22. Click OK to continue.

Figure 22. Command Complete Connectivity Test Window

Command Complete

Connectivity Test completed without errors.
Please check Connectivity Test Log for results.

0K

Connectivity Test Log File Menu

2-18

The File menu in the Connectivity Test Log window, shown in Figure 23 on page
19, provides these selections:

Clearing the Connectivity Test Log display
Printing the Connectivity Test Log
Saving the Connectivity Test Log to a file

Closing the Connectivity Test Log window.
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Figure 23. File Menu in the Connectivity Test Log Window

& FTP-based Table Retrieve Application <=

=10l

File Edit Yiew Help

Connectivity Test Log
File

Clear Display Test Process Manager: Stp Connectivity Test Begun
Print session Manager: Initiating Telnet Session with Eagle

session Manager: Session Connected: 10.1.2.10:8080
Save session Manager: Terminal 17 Enabled

Close session Manager: User "eagle" Login Attempt: 1
reney ronnmar Session Manager: User "eagle” Login Accepted
Telnet Terminal Session Manager: User "eagle" Logout Attempt: 1
Telnet Terminal Session Manager: User "eagle" Logout Accepted
Stp Connectivity Test Process Manager: Stp Connectivity Test Complete Without Errors

Clearing the Connectivity Test Log Display
The display can be cleared, enabling new entries to be captured to the log. Once

the log is cleared, the existing entries are lost unless the log is save to a file or
printed before the display is cleared.

Procedure

1. Select File > Clear Display in the Connectivity Test Log window. See Figure
23. The Connectivity Test Log display clears.

Printing the Connectivity Test Log

Procedure

1. Select File > Print in the Connectivity Test Log window. See Figure 23 on
page 19. The Print window opens. See Figure 24.
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Figure 24. Print Window

21|

— Printer

[ arme:

Propertiesz. .. |

Status: Feady
Tupe: HF Lazerlet 8150 PCL &
wihere: HFLazerlet@1 505 enies

Cormment; [ Frint to file

— Print range Copies

LU | Mumber of copies: 1 :

° Pages from: |1 b |'|

i~ Selection Iﬁl I Collate

| (0] I Cancel |

2. Configure the printer settings.

3. To print the Connectivity Test Log, click the OK button in the Print window.
The current contents of the Connectivity Test Log are printed.

4. If you decide not to print the Connectivity Test Log, click the Cancel button in
the Print window.

Saving the Connectivity Test Log to a File

Procedure

1. Select File > Save in the Connectivity Test Log window. See Figure 23 on
page 19. The Save window opens. See Figure 25.
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Figure 25. Save Window

Look In: |Ij logfiles - | @ @ @ @E

[y trvD72302.doc
[ sws072302.doc

File Mame:  |Contestlf3002.doc |

Files of Type: | Al Files ~|

Save || Cancel |

2. Select a location for the file, and enter the file name and file type (with either
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use
Microsoft Word to open the file, even if it was saved as a .txt file.

NOTE: If you decide not to save the file, do not perform steps 3 and 4, but
click Cancel in the Save window.

3. Click the Save button. A Saved file confirmation window opens with “Data
saved to file.” See Figure 26.

Figure 26. Saved File Confirmation Window
x|

ﬁ Data saved to file

4. To save the file, click OK in the Saved file confirmation window to continue.
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Closing the Connectivity Test Log Window

Procedure

1. Select File > Close in the Connectivity Test Log window, or click the close
window button in the upper right hand corner of the Connectivity Test Log
window. See Figure 23 on page 19. The Connectivity Test Log window closes.
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Modifying an Existing STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table
Retrieve Application window. See Figure 5 on page 5. The STP Connection
Configuration Menu window opens.

2. Display the STP configuration record being modified. Go to the “Displaying
an Existing STP Configuration Record” procedure on page 13.

3. Select and change the STP configuration record parameters. The Modify
button is enabled when new data is entered into any of the fields, or when the
Use STP and FTP UserNames and Passwords for all STPs box is checked.

NOTE: The STP name cannot be changed.

If the IP address, STP user name, or STP password is not entered correctly, an
error message is displayed. See Figure 9 on page 10, Figure 10 on page 10, or
Figure 11 on page 10. If the FIP user name and FIP password are not entered,
an error message is displayed. See Figure 12 on page 11 or Figure 13 on page
11

4. To apply the changes, click the Modify button. See Figure 27 on page 24
(FTRA 4.0). The displayed STP configuration record is modified, and all fields
are cleared. To confirm that the STP configuration data has been modified, the
STP Data Modified window is displayed (Figure 28 on page 25). Click OK in
the STP Data Modified window to continue.
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Figure 27. Modifying STP Configuration Record
Parameters (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 2>
File Edit View Help

STP Connection Configuration Men

Current STP Selected: STP 2
STP Hame
TP 6 'v| | Refresh |

Primary IP Address

102364 | | rest |
Back-Up IP Address

0238w | | rest |
[_] Secure Connection

STP UserName

eagle | The user changed
STP Password the IP addresses
frossass | enabling the
Modify Button

FTP Userdame
|user2 |

FTP Password

|

[C] Use STP and FTP LiserNames, Passwiords for all STPs

Cseet s || Mody || peete || close |

CAUTION: If the Use STP and FTP UserNames and Passwords for all
STPs box is checked, then all user names and passwords for all STPs in the
STP Configuration database are changed to the user name and password for
the displayed STP.

CAUTION: Itis recommended that the setting for the Secure Connection
box is not changed, unless you have verified that the new setting for the
Secure Connection box will match the state of the Eagle OA&M IP Security
Enhancements feature on the STP. The state of the Eagle OA&M IP
Security Enhancements feature can be verified by entering the
rtrv-ctrl-feat command at the EAGLE 5 ISS. If the Eagle OA&M IP
Security Enhancements feature is not enabled or activated, the Secure
Connection box should be unchecked. If the Eagle OA&M IP Security
Enhancements feature is enabled and activated, the Secure Connection box
should be checked. To change the state of the Eagle OA&M IP Security
Enhancements feature, perform the “Activating the Eagle OA&M IP
Security Enhancements Controlled Feature” procedure in the Database
Administration Manual - System Management.

> B
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Figure 28. STP Data Modified Window

Information x|

J%}g STP Data Modified

NOTE: If the STP configuration record being changed is shown in the
Current STP Selected: field, a Modify Warning window is displayed. See
Figure 29.

Figure 29. Modify Warning Window

WARNING: Modifving currenthy selected STP.
= & Areyou sure?

fes Mo

Click Yes to continue.

If you do not wish to apply the changes, click the Refresh button in the STP
Connection Configuration Menu window. This resets the STP configuration
record values.

5. Verify that the changes were made. See the “Displaying an Existing STP
Configuration Record” procedure on page 13.
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Deleting an STP Configuration Record

Procedure

1. Select Edit > STP Connection Configuration from the FTP-Based Table
Retrieve Application window. See Figure 5 on page 5. The STP Connection
Configuration Menu window opens.

2. Display the STP configuration record being deleted. Go to the “Displaying an
Existing STP Configuration Record” procedure on page 13. The Delete button
is enabled when an existing STP configuration record is displayed.

3. To delete the STP configuration record, click the Delete button. The Delete
STP window opens. See Figure 30.

Figure 30. Delete STP Window

Delete STP x|

Delete this STP and all of its assocaiated data.
S 2 Continue?

OK Cancel

Click OK, to delete the STP configuration record. The STP configuration
record is deleted.

If you do not wish to delete the STP configuration record, click Cancel.

4. Verity the STP name is no longer in the STP Connection Configuration
database. Go to the “Displaying an Existing STP Configuration Record”
procedure on page 13.
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Selecting the Current STP

Before retrieving database tables from an EAGLE 5 ISS, or sending commands to
an EAGLE 5 ISS, that STP name must be shown in the STP Connection
Configuration Menu window as the current STP. The Current STP Selected:
indicator in the STP Connection Configuration Menu window shows which STP
is the current STP.

Procedure

1. Display an existing STP configuration record. Go to the “Displaying an
Existing STP Configuration Record” procedure on page 13.

2. Click the Select button.

If the selected STP is different from the STP shown as the current STP, the STP
Selection Change window opens and displays “Warning: Selecting a different
STP will purge existing table data. Do you want to proceed?” See Figure 31.

Figure 31. STP Selection Change Window

& STP Selection Change

WARNING: Selecting a different STP will purge existing table data.
o Do you want to proceed?

Yes Ho

3. To proceed and select the STP name as the current STP, click the Yes button in
the STP Selection Change window. The existing data table is purged.

NOTE: To purge the data tables, a flag is set so that any of the existing
table data already stored in the offline database will not be used.

The selected STP name appears in the title bar of the window, and Current
STP Selected: <STP Name> appears in the STP Connection Configuration
Menu. See Figure 32 on page 28 (FTRA 4.0).
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Figure 32. Current STP Selected (FTRA 4.0)

£ FTP-based Table Retrieve Application <STP 6>
File Edit View Help

STP Connection Configuration Menu :

Current STP Selected: STP 6 < Current STP Selected

STP Hame
3TPE

Primary IP Address
10236

Back-Up IP Address
10237

[¥] Secure Connection

STP Userlame
|e anle

STP Password

T

FTP Userlame
|u ser2 |

FTP Password

|

[l Use STP and FTP UserNames, Passwords for all STPs

| | s oo || peete || Close

4. If you do not wish to use the STP name selected in step 2, click the No button
in the STP Selection Change window. The current STP configuration record
is displayed.
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Secure EAGLE 5 ISS Host Key Provisioning

An EAGLE 5 ISS using secure connections has a unique host key for each IPSM in
the EAGLE 5 ISS. This key is used by the FTRA (FITRA 4.0) to positively identify or
authenticate each IPSM’s telnet server on the EAGLE 5 ISS. The FTRA will not
connect to an unauthenticated server. The FTRA authenticates the server by
matching its preinstalled host key with the key received from the EAGLE 5 ISS
when the connection between the EAGLE 5 ISS and the FTRA is made.

This procedure installs the public host key fingerprint, generated when the IPSM
is installed into the EAGLE 5 ISS, re initialized using the init-card command, or
when the IPSM is brought into service with the alw-card or rst-card
commands, into the FTRA. This procedure must be performed for each IPSM on
each EAGLE 5 ISS that the FTRA will connect to, but only for EAGLE 5 ISSs using
secure connections to connect to the FTRA. This procedure must be performed
before any secure connection between the EAGLE 5 ISS and the FTRA can be
initiated.

NOTE: Once the IPSM is installed into the EAGLE 5 ISS, the public host
key fingerprint for the IPSM will change only when power to the IPSM is
disrupted by removing the IPSM from the shelf, then reinserting the IPSM
into the shelf, or as the result of any event that interrupts power to the
IPSM. Re initializing the IPSM will not change the public host key
fingerprint for the IPSM. This procedure will have to be performed for each
public host key fingerprint on the EAGLE 5 ISS that has changed.

The public host key fingerprint is added to the FTRA’s hosts.xml file. If the public
host key fingerprint has not been added to the FTRA’s hosts.xml file, and you try
to initiate a secure connection to the EAGLE 5 ISS, you will receive the following
warning message (Figure 33).

Figure 33. IP Address Warning Message

- o

Missing IP

STP Primary IP address is missing from host.xmil file.
You must clear the Secure Connection check hox to use this IP address.

If the warning message shown in Figure 33 is received, either clear the Secure
Connection check box in the STP Configuration Record for the STP (see the
“Modifying an Existing STP Configuration Record” procedure on page 23), or add
the public host key fingerprint to the FTRA’s hosts.xml file using the procedure
on page 31.
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The verification that the keys are installed on the FTRA is called strict host key
checking. By default, strict host key checking is on. This enforces server (EAGLE 5
ISS) strong authentication, designed to provide security between the FTRA and
the EAGLE 5 ISS. This also prevents a hostile server from tricking the FIRA into
exposing any EAGLE 5 ISS login and password combinations.

CAUTION: Do not set strict host key checking to off, unless your network
is in a controlled and secure environment. If you set strict host key
checking to off, the Connectivity Test Log will warn you each time you try
to connect that the EAGLE 5 ISS public host key fingerprint has not been
added to the hosts.xml file on the FTRA.

To set the strict host key flag:

1.

Open the application start file using any text file editor. On the Windows
platform, open the £tra.bat file. On the UNIX platform, open the ftra file.

Insert into the application start file, one of these text strings, depending on
whether you want strict host key checking on or off.

* -DstrictHostKeyChecking=1 for setting strict host key checking to on
(this is the default setting).

* -DstrictHostKeyChecking=0 for setting strict host key checking to off
This text string can be inserted anywhere between the $JRE_HOME%\bin\java
and -cp text strings as shown in the following example.

$JRE_HOME%\bin\java -Dstricthostkeychecking=1 -Ddebuglevel=2
-Dsshtools.home=%FTRA2_HOME% -Dftra2rootdir=%FTRA2 HOME% -cp ftra3.jar
com.tekelec.ftra.gui.InterfaceSelector %1

Save the changes and close the application start file.
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Procedure

User Guide

1. On the EAGLE 51SS, enter the rtrv-trm command. The location of the IPSM
is shown in the L.oc column with the TELNET terminal type.

This is an example of the possible output.

rlghncxa03w 05-09-17 15:08:45 GMT EAGLE5 34.0.0

TRM TYPE COMM FC TMOUT MXINV DURAL
1 VT320 9600-7-E-1 SW 30 5 99:59:
2 KSR 9600-7-E-1 HW 30 5 INDEF
3 PRINTER 4800-7-E-1 HW 30 0 00:00
4 VT320 2400-7-E-1 BOTH 30 5 00:30
5 VT320 9600-7-0-1 NONE 30 5 00:00
6 VT320 9600-7-E-2 SW 30 9 INDEF
7 PRINTER 9600-7-N-2 HW 30 5 00:30:
8 KSR 19200-7-E-2 BOTH 30 5 00:30:
9 VT320 9600-7-E-1 SW 30 7 00:30:
10 VT320 9600-7-E-1 HW 30 5 00:30:
11 VT320 4800-7-E-1 HW 30 5 00:30:
12 PRINTER 9600-7-E-1 HW 30 4 00:30:
13 VT320 9600-7-0-1 NONE 30 5 00:30:
14 VT320 9600-7-E-2 SW 30 8 00:30:
15 VT320 9600-7-N-2 HW 30 5 00:30:
16 VT320 9600-7-E-2 BOTH 30 3 00:30:
TRM TYPE LoC TMOUT MXINV DURAL
17 TELNET 1111 60 5 00:30:
18 TELNET 1111 60 5 00:30:
19 TELNET 1111 60 5 00:30:
20 TELNET 1111 60 5 00:30:
21 TELNET 1111 60 5 00:30:
22 TELNET 1111 60 5 00:30:
24 TELNET 1111 60 5 00:30:

TRM TRAF LINK SA SYS PU DB UIMRD

1 NO YES NO YES NO YES YES
2 NO NO NO NO NO NO NO
3 YES YES YES NO YES YES YES
4 YES NO NO NO NO NO NO
5 NO YES NO NO NO NO YES
6 NO NO YES NO NO NO NO
7 YES YES YES YES YES YES YES
8 NO NO NO NO YES NO YES
9 NO YES NO NO NO YES NO
10 NO NO NO NO NO NO YES
11 YES YES YES YES YES YES YES
12 YES YES YES YES YES YES YES
13 NO YES NO NO NO NO YES
14 NO NO YES NO NO NO NO
15 YES YES YES NO YES YES YES
16 NO NO NO NO YES NO YES
17 NO NO NO NO NO NO NO
18 NO NO NO NO NO NO NO
19 NO NO NO NO NO NO NO
20 NO NO NO NO NO NO NO
21 NO NO NO NO NO NO NO
22 NO NO NO NO NO NO NO
23 NO NO NO NO NO NO NO
24 NO NO NO NO NO NO NO

59

:00
:00
:30

00
00
00
00
00
00
00
00
00
00

00
00
00
00
00
00
00

SECURE
yes
yes
yes
yes
yes
yes
yes
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Display the IP address assigned to the IPSM using the rtrv-ip-1nk
command, specifying the card location of the IPSM shown in step 1 and the
port=a parameter. For this example, enter this command.

rtrv-ip-lnk:loc=1111l:port=a
The following is an example of the possible output.

rlghncxaO3w 05-09-17 15:08:45 GMT EAGLES5 34.0.0
LOC PORT IPADDR SUBMASK DUPLEX SPEED MACTYPE AUTO MCAST
1111 A 192.168.54.96 255.255.255.0 HALF 100 DIX NO NO

NOTE: If the Security Administration (sa) setting for all the terminals
assigned to the IPSM specified in this procedure is set to YES, see the
rtrv-trm output in step 1, skip this step and go to step 4.

Change the Security Administration setting on the terminals assigned to the

IPSM with the chg- trm command and specifying the number of the terminals
whose Security Administration setting is No, and with the sa=yes parameter.

chg-trm:sa=yes:trm=<TELNET terminal number>
When the chg- trm command has successfully completed, this message
should appear.

rlghncxaO3w 05-09-17 15:08:45 GMT EAGLES5 34.0.0
CHG-TRM: MASP A - COMPLTD

NOTE: When the IPSM is installed into the EAGLE 5 ISS, UIM 1493 is
generated. UIM 1493 contains the DSA key fingerprint to be added to the
hosts.xml file. If you recorded the DSA key fingerprint for the IPSM when
UIM 1493 was generated, skip step 4 and go to step 5.

CAUTION: If you are performing step 4 from a telnet terminal, make sure
the step is being performed from a telnet terminal that is not assigned to the
IPSM being initialized. When the IPSM is initialized, you will lose all
telnet connections supported by the IPSM being initialized.

Obtain the DSA key fingerprint for the IPSM by performing the init-card
command and specifying the location of the IPSM. For this example, enter this
command.

init-card:loc=1111

After the init-card command has been executed, UIM 1494 is generated.
The DSA key fingerprint is at the end of the output, in the hexadecimal
format, and shown in bold in this output example.

rlghncxaO3w 05-09-17 15:08:45 GMT EAGLES5 34.0.0

0021.1494 CARD 1111 INFO SSH Host Keys Loaded
DSA Server Host Key FTRA-formatted Fingerprint=
84 7c 92 8b c 7c d8 19 1lc 6 4b de 5c 8f c5 4d
Report Date:05-03-17 Time:15:08:45

NOTE: If you wish to change the public host key fingerprint on the IPSM,
remove and reinsert the IPSM. The public host key fingerprint does not
change until the IPSM loses power. However, contact the Customer Care
Center before removing and reinserting the IPSM. Refer to page 4 for the
contact information.

910-4919-001 Rev B, April 2007



FTP-Based Table Retrieve Application (FTRA) User Guide

5. Edit the FTRA hosts.xml file (in the $SFTRA_HOME/cfg directory on Unix or
%FTRA_HOME% \cfg folder on Windows), using any text file editor. Add
the:

e IPSM IP address from the rtrv-ip-1nk output shown in step 2

* DSA public key fingerprint, shown in either the output of UIM 1493, when
the IPSM was installed, or from the output of UIM 1494 when the
init-card command was performed in step 4 in the following format:

<AllowHost HostName="<IPSM IP Address>" Fingerprint="767: <DSA public key
fingerprint>"/>

NOTE: The value 767 preceding the DSA public key fingerprint is the
length of the key in bytes. On your EAGLE 5 ISS, this value may be
different. refer to the FTRA Connectivity Test Log to verify this value. The
outputs of UIM 1493 or 1494 do not contain this value.

The following is a sample /ftra/cfg/hosts.xml file before the new DSA
fingerprint information is added.

<?xml version="1.0" encoding="UTF-8"?>

<HostAuthorizations>

<AllowHost HostName="192.168.54.36" Fingerprint="767: 4a 9 ec d3 70 34 d2 91
£7 8b 75 a8 95 37 98 35"/>

<AllowHost HostName="192.168.54.216" Fingerprint="767: bc 76 ac 53 le fd 72 16
3e 9c dc d7 23 25 6 59"/>

The sample /ftra/cfg/hosts.xml file after the new DSA fingerprint information
is added.

<?xml version="1.0" encoding="UTF-8"?>

<HostAuthorizations>

<AllowHost HostName="192.168.54.36" Fingerprint="767: 4a 9 ec d3 70 34 d2 91
£7 8b 75 a8 95 37 98 35"/>

<AllowHost HostName="192.168.54.216" Fingerprint="767: bc 76 ac 53 le fd 72 16
3e 9c dc 47 23 25 6 59"/>

<AllowHost HostName="192.168.54.96" Fingerprint="767: 84 7c 92 8b c 7c d8 19
lc 6 4b de 5c 8f c5 44"/>

NOTE: There should be no duplicate IP addresses in this file.
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Save the file and exit the text editor.

A secure connection can now be established to the IP address used in this
procedure. Either add the STP containing the IP address to the STP
Configuration Record (see the “Adding an STP Configuration Record”
procedure on page 8), or if the IP address is already defined in the STP
Configuration Record, change the existing record for this STP with the IP
address used in this procedure (see the “Modifying an Existing STP
Configuration Record” procedure on page 23). Whether adding a new STP
record, or changing an existing STP record, make sure the Secure Connection
check box is checked.

After the STP record has been added or changed to use a secure connection,
test the connection by performing the “Testing an STP Configuration Record”
procedure on page 17. If the connection test is passed, the public host key
fingerprint is successfully installed.

If the connection is refused, make sure that the key information for the
EAGLE 5 ISS and the FTRA shown in the Connectivity Test Log match. The
Connectivity Test Log shows both the key received from the EAGLE 5 ISS host
and the key contained in the hosts.xml file for the EAGLE 5 ISS host. The
following is an example from the Connectivity Test Log containing a host key
mismatch. The key received from the EAGLE 5 ISS host is shown in bold. The
key contained in the hosts.xml file is shown in bold underline.

2003-07-11 14:22:56.117: Stp Connectivity Test Process Manager: Testing STP11805011201
2003-07-11 14:22:56.227: Telnet Terminal Session Manager: Initiating Secure Telnet
Session with Eagle: 192.168.53.71:22

2003-07-11 14:22:56.808: HostKeyVerification: ERROR: Host 192.168.53.71 cannot be
authenticated due to a mismatched entry for this host in the hosts.xml file. The host key
supplied by 192.168.53.71 is: 768: bb 7d 79 a2 7d ae 5d 5a 45 e2 44 58 cd 8a bd 83.

The current allowed key for 192.168.53.71 is: 768: ab 7d 79 a2 7d ae 5d 5a 45 e2 44 58 cd

8a bd 83.

2003-07-11 14:22:56.828: HostKeyVerification: Connection rejected...onHostKeyMismatch
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FTP Server Configuration

An FTP server must be configured on the EAGLE 5 ISS using the FTP Server
Configuration menu before database tables can be retrieved from the EAGLE 5
ISS, or command files can be sent to the EAGLE 5 ISS.

NOTE: If the Secure Connection box in the STP Connection
Configuration Menu window is checked, the IP address specified in the
FTP Server Configuration menu must be the IP address of a secure FTP
server. If the Secure Connection box in the STP Connection Configuration
Menu window is not checked, the IP address specified in the FTP Server
Configuration menu must be the IP address of a FTP server.

NOTE: Any firewall between the FTRA and the FTP server configured in
the FTP Server Configuration Menu window (Figure 35 on page 36), must
allow FTPs to the IP address specified in the FTP Server Configuration
Menu window.

Procedure

1. Select Edit > FTP Server Configuration from the FTP-based Table Retrieve
Application menu. See Figure 34.

Figure 34. FTP Server Configuration Menu in the FTP-Based
Table Retrieve Application Window

rf,@_..“.} FTP-based Table Retrieve Application <stplz ;IQIEI
File View Help

The FTP Server Configuration Menu window opens. See Figure 35 on page
36 and Table 3 on page 36.
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Figure 35. FTP Server Configuration Menu Window

E&r FTP-based Table Retrieve Application <stpl> ;lglﬁl
File Edit View Help

FTP Server Configuration Menu
IP Address

|| | | Browse

Subpath

Table 3. FIP Server Configuration Menu Window Descriptions
Item Description
Fields
IP Address The IP Address of the associated STP
Path The complete path to the data tables transfer directory on the
STP.

This directory must be given complete read /write/execute
permissions for all users. From Windows, this is commonly
administered from within the FIP server software. From
Unix, this is done with the chmod command. Please refer to
your PC system documentation or Unix man pages for full
details on setting directory permissions.

Subpath The value used by the path parameter of the EAGLE 5 ISS
ent-ftp-serv/chg-£ftp-serv commands. The subpath is
relative to the user's default directory upon FIP login. A file
separator ('\' or '/') is not used to begin the subpath string.

Buttons
Browse Opens the Select Starting Directory window to initiate a
directory/file selection dialog for the data tables.
Set Stores the FIP server configuration data.
Close Closes the FTP Server Configuration Menu window.

2. Enter the IP address of the STP in the IP Address field.

NOTE: If the format is not entered correctly, the Invalid IP Address
warning window is displayed. See Figure 36 on page 37.
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Figure 36. Invalid IP Address Error Message

Invalid IP Address

3. Enter the path for the FIP temporary data table storage area or click the
Browse button.

If the Browse button is clicked, the Select Starting Directory window opens
to select the location for the temporary data table storage area to be entered in
Path field. See Figure 37 and Table 4 on page 38.

This directory must be given complete read /write/execute permissions for all
users. From Windows, this is commonly administered from within the FTP
server software. From Unix, this is done with the chmod command. Please
refer to your PC system documentation or Unix man pages for full details on
setting directory permissions.

Figure 37. Select Starting Directory Window

& Select Starting Directory il

Look In: ‘Ijﬂraz v| @ @ @ @E

[T bin
[ cfy
Ctp
— log
Cstp

Select
Cancel

File Name:  |Cifra2iip |

Files of Tyne: | All Files -
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Select Starting Directory Window Descriptions

Item Description
Fields
Look in: A drop down menu that allows the user to browse
through the directory structures.
File Name: The name of the file to be selected.
Files of type: | A drop down menu that allows the user to select all files
of a particular type.
Buttons
Select Takes the contents of the File Name field and loads it

into the Path field of the menu

Cancel Closes the Select Starting Directory window.

4. Enter the Subpath. The subpath must always be the last part of the path. The
subpath is relative to the user's default directory upon FTP login. A file
separator ('\' or '/') is not used to begin the subpath string. If an invalid
Subpath is entered, a warning window opens. See Figure 38.

Figure 38. Invalid Subpath Window

Invalid Sub Path - Sub Path must be a subset of the Path

5. Click the Set button. See Figure 39
Figure 39. FTP Server Configuration Example

E@g FTP-based Table Retrieve Application <stpl>

File Edit View Help

E FTP Server Configuration Menu

IP Address
10123 |

Path
Wa Aitp ‘ | Browse

Subpath
v
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The FTP Server Data Set window opens. See Figure 40.
Figure 40. FIP Server Data Set Window

Information |

FTP Server Data Set

Click OK to continue.
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Retrieve Database Tables from an STP

Retrieve Tables Window

2-40

The Retrieve Tables window (see Figure 42 on page 41) is used to select the
database tables you wish to retrieve from the selected STP. The Retrieve Tables
window contains a list of predefined retrieve commands. Any number of the
retrieve commands can be selected from the Command List box and moved to
the Selected Commands box. Clicking the Retrieve button causes the database
tables associated with the selected retrieve commands to be transferred from the
selected STP.

The Retrieve from STP and Retrieve from Local Database buttons determine
whether new database tables are retrieved from the selected STP or if existing
tables already retrieved from that STP will be used. If no tables exist for the
selected STP, the Retrieve from Local Database button will be grayed out.

The output from the retrieve commands is converted to CSV files. When the
retrieve operation is completed, the Command Complete window opens
notifying the user if the retrieve was executed with or without errors. The
Retrieve Tables Log opens allowing the user to view the events.

CAUTION: With FTRA 4.0, if you attempt to retrieve and convert the
database tables for these GTT commands (rtrv-tt, rtrv-gtt) and these
EGTT commands (rtrv-gttsel, rtrv-gttset, rtrv-gta) in the same
retrieve tables request, you will receive a warning (Figure 41) that errors can
be caused by attempting to retrieve and convert the GTT and EGTT
database tables from the same EAGLE 5 ISS.

You may only retrieve and convert the tables corresponding to which
feature is on, GTT or EGTT. If the EGTT feature is on, shown in the
rtrv-feat output, the database tables for the rtrv-gttsel, rtrv-gttset,
and rtrv-gta commands can be retrieved and converted. If the EGTT
feature is off, the database tables for the rtrv-tt and rtrv-gtt commands
can be retrieved and converted.

The errors will be caused when the retrieved GTT and EGTT database
tables are converted to CSV files. Because only one set of the database
tables, GTT or EGTT, can be retrieved, only that set of the database tables
can be converted. The error will occur when the attempt is made to convert
that database tables that could not be retrieved.

Figure 41. GTT Warning Window
Retrieve Tables |

§ WABNING: You have selected both GTT and EGTT commands.
= & This will cause errors, continue?

Yes No
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Figure 42. Retrieve Tables Window

& FTP-based Table Retrieve Application <5TP6=

] commands Menu

 Retriove Tables | Upate Tables |
Command List Selected Commands:
rins-card
rire-ctrl-feat
rire-dstn
rtre.gtt
rnels
rinemap
rre-rie
rtnv-slk
rtngit
rire-feat
rirv-stpopts
rire-sid

i®) Ratrieve from STP

) Retrieve from Local Database

Reset | Retrieve | | Store | Load

Table 5 on page 41 shows the description of the fields and buttons in the Retrieve
Tables window.

Table 5. Retrieve Tables Window Description
Item Description
Fields
Command List Contains a predefined list of retrieve commands.
Selected These commands are used to determine which database
Commands tables are retrieved from the selected STP.

From one to all of the retrieve commands can be selected
for retrieval.

Buttons

Add Moves the highlighted commands from the Command
List box to the Selected Commands box.
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Table 5. Retrieve Tables Window Description (Continued)

Item

Description

Remove

Moves any highlighted commands in the Selected
Commands box back to the Command List box and
places them in the Command List box in alphabetical
order.

Reset

Moves all commands in the Command List box to the
Selected Commands box. All highlights in the Selected
Commands box are removed.

Retrieve

Initiates the retrieval of all the selected database tables
represented by the selected retrieve commands. The
database tables are transferred using an FTP connection
and converted to CSV files.

Store

Stores the commands in the Selected Commands box
which will be used by the Command Line Interface. This
list is maintained even when the FTRA is shut down and
restarted.

Load

Loads the commands into the Selected Commands box
which are currently stored for Command Line Interface
usage. This allows the user to verify rtrv commands

which will be executed by the Command Line Interface.

Retrieve from
STP

Retrieves the database tables, based on the selected
retrieve commands, from the selected STP instead of
using the tables previously retrieved.

Retrieve from
Local Database

When selected, the FTRA uses the database table
previously retrieved from the selected STP.

Close

Closes the Commands Menu window.

In FTRA 4.0 the EAGLE 5 ISS release 32.0 and later are supported if that release
supports CSV file output.

When a Retrieve Tables command is performed, FTRA 4.0 verifies that the
EAGLE 5 ISS is running one of the supported releases. If the EAGLE 5 ISS release
is not supported, an error message is displayed and the Retrieve Tables command
is terminated. See Figure 43.
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Figure 43. Retrieve Table Log - Release Not Compatible Error

& FTP-based Table Retrieve Application <DANSTP1 > N [=] 1|
File Edit View Help

o‘d E

Retrieve Tables Log -
File

2005-01-31 15:40:22:442: Retrieve Process Manager: Purging FTP Transfer Area

2005-01-31 15:40:22:473: Retrieve Process Manager: Purging STP Data Area for: DANSTP1

2005-01-31 15:40:22:489: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle: 192.168.54.51:23
2005-01-31 15:40:22:505: Telnet Terminal Session Manager: Session Connected: 192.168.54.51:1699
2005-01-31 15:40:23:676: Telnet Terminal Session Manager: Sending Eagle Command: 18

2005-01-31 15:40:23:895: Telnet Terminal Session Manager: Terminal 18 Enabled

2005-01-31 15:40:24:895: Telnet Terminal Session Manager: User “eagle” Login Attempt: 1

2005-01-31 15:40:25:911: Telnet Terminal Session Manager: Sending Eagle Command: login:uid=eagle
2005-01-31 15:40:28:223: Telnet Terminal Session Manager: User “eagle” Login Accepted

2005-01-31 15:40:28:223: Telnet Terminal Session Manager: Sending rtrv-gpl command to Eagle
2005-01-31 15:40:29:239: Telnet Terminal Session Manager: Sending Eagle Command: rtrv-gpl

2005-01-31 15:40:34:38: Telnet Terminal Session Manager: Received string029-051-030

2005-01-31 15:40:34:395: Telnet Terminal Session Manager: FTRA not supported for this Eagle Release:null
2005-01-31 15:40:34:505: Retrieve Process Manager: Telnet Terminal Session Complete With Errors
2005-01-31 15:40:34:52: Retrieve Process Manager: Closing Connections, Please Wait

If the EAGLE 5 ISS release is supported, the Retrieve Tables command is
performed and operations on the FTRA can continue.

Procedure

1. Select Edit > Commands > Retrieve Tables from the FIP-Based Table
Retrieve Application window. See Figure 44. The Retrieve Tables window
opens. See Figure 42 on page 41.

Figure 44. Commands Menu in the FTP-Based Table Retrieve
Application Window

‘,;’3; FTP-based Table Retrieve Application <stpl>

View Help

STP Connection Configuration
FTP Server Configuration
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2. To select commands in the Command List box of the Retrieve Tables
window, perform one of these steps:To select a single command, click on the
command and it is highlighted. See Figure 45.

Figure 45. Selecting a Command

{& FTP-based Table Retrieve Application <STP6> f:@|g|

File Edit View Help

5] commands Menu

| Retrieve Tables | Update Tables |
Command List
rirv-card
rtrv-ctrl-feat
rtrv.dsin
Tirv-git
riry-1s
riremap
rtrv-rte

Md_'
(=

-

(%) Retrieve from STP

) Refrieve from Local Database

Reset || Retrieve store || Load |

Close

a. To select a range of commands, click on the first command and while
holding down the Shift key, click on the last command to be selected. All
the commands in between the selected commands are highlighted, along
with the selected commands. See Figure 46.
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Figure 46. Selecting a Range of Commands

£ FTP-based Table Retrieve Application <STP6>

File Edit View Help

[F] commands Menu

Retriews Tables | Upda Tabhes |
Command List Selected Commands

-
|—

rirv-scr-blkdpec
rtrv-scr-hlkopc
rins.scr.cipa
nry-scr-cypa
rtry-scr-dpc
rtrv-scr-opc
rinv-scrset
Mny-scr-sio
nry-scri
rtrv-scr-aftpc
rirv-scr-destfld 5
rirv-stp |
(@ Retrieve from STP

() Retriewe from Local Database

Store Load |

b. To select multiple commands, select the first command, then hold down
the Ctrl key and click on each of commands to be selected. The selected
commands are highlighted. See Figure 47 on page 46.

NOTE: If you have selected any of these GTT commands (rtrv-tt,
rtrv-gtt) and these EGTT commands (rtrv-gttsel, rtrv-gttset,
rtrv-gta) in substeps b or ¢, see the Caution on page 40.
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Figure 47. Selecting Multiple Commands

Commands Menu

Retrieve Tables

Command List Selected Commanis
rtrv-card
rtrv-ctri-feat
rtry-dstn
rtre-git
rrv-ls
rtry-map
rtrv-rte
rtrv-slk
rtrv-tt
rtrv-feat
rtre-stpopts
rv-sid

IC

-

® Retrieve from STP
i) Retrieve from Local Database

Reset || Retrieve | | Store || Load |

3. To move the commands selected in step 2 to the Selected Commands box,
click the Add button. The commands are moved to Selected Commands box.
See Figure 48, Figure 49 on page 48, and Figure 50 on page 49.
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Figure 48.
Box

& FTP-based Table Retrieve Application <5TP6=

Commands Menu

Adding a Command to the Selected Commands

User Guide

File Edit ‘iew Help

Retrieve Tables

Command List
rirv-card
rtrv-ctri-feat
rirv-dstn
rtrv-git
rirv-ls
rtre-map
rtre-rte
rtrv-slk
rtrv-tt
rtrv-stpopts
rtrv-sid
rtre-ita

Selected Commands

rtrv-feat

-

(@ Retrieve from STP
) Retrieve from Local Database

Store | | Load |
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Figure 49. Adding a Range of Commands to the Selected
Commands Box

& FTP-based Table Retrieve Application <STP6=

File Edit View Help

Commands Menu

Retrieve Tables

2-48

Command List

rtrv-ctrl-feat
rtry-getsel
rirv-gttset
rtrv-scr-hikdpc
rtrv-scr-hlkopc
rtrv-scr-cdpa
rtrv-scr-cgpa
rtrv-scr-ipc
rtry-scr-opc
rtrv-screet
rtrv-scr-sio
rtrv-scr-it

Selected Commands

rtrv-card
rtrv-idstn
rirv-feat
rtrv-gta
rtrv-gtt
rtrels
rtrv-map
rtrv-rte
rtrv-sid
rtrv-slk
rtrv-stpopts
rtrv-tt

-

i@ Retrieve from STP

i_) Retrieve from Local Database

Store | | Load |
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Figure 50. Adding Multiple Commands to Selected Commands

Box
Commands Menu
[ Retrieve Tables |  Update Tables
Command List Selected Commands
rtrv-ctri-feat rtrv-card =l
rtru-dstn rtru-feat
rtrv-ls rtrv-gtt
rtrv-rte rtrv-map
rtru-tt rtrv-sid
rtrv-stpopts rtrv-slk
rtrv-gta B
rtrv-ittsel
rirv-gttset
Remaowve
rtrv-scr-hikdpc
rtre-scr-blkopc =
rtrv-scr-cdpa - -
i@ Retrieve from STP
Reset | | Retrieve | | Store | | Load |
Close

NOTE: If no commands are being moved from the Selected Commands
box to the Command List box, skip step 4 and go to step 5.

4. To remove commands from the Selected Commands box, perform one of
these steps:

a. In the Selected Commands box, click on the command to be removed
and it is highlighted. Click the Remove button. The highlighted
command is moved to the Command List box. See Figure 51 on page 50.

b. To select a range of multiple commands to be removed, click on the first
command and while holding down the Shift key, click on the last
command to be removed. Click the Remove button. All highlighted
commands are moved to the Command List box.

c. Hold down the Ctrl key and click on each of commands to be removed.
Click the Remove button. Only the highlighted commands are moved to
Command List side. See Figure 52 on page 50.

NOTE: When a command is removed from the Selected Commands box,
the command is placed in the Command List box in alphabetical order.

d. Click the Reset button. All commands in the Command List box are
moved to the Selected Commands box. All highlights in the Selected
Commands box are removed.
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Figure 51.

FTP-Based Table Retrieve Application (FTRA)

Command Selected to be Removed in the Selected
Commands Box

Commands Menu

Retrieve Tables
Command List Selected Commands
rtrv-ctri-feat rtry-card -~
rtrv-dstn rirv_feat
rirv-ls rtrv-gtt
rtrv-rte /-map
rtrv-tt rtrv-sid
rtrv-stpopts rtrv-slk
rtrv-gta
rtrv-gitsel
rtrv-gttset
rtrv-scr-hlkdpc
rirv-scr-blkopc
rrv-scr-cdpa =
@ Retrieve from STP
) Retrieve from Local Database
Reset | | Retrieve | Store | | Load |
Close
Figure 52. Command Removed from the Selected Commands

Box

Commands Menu

Commantl List Selected Commands

rtrv-ctri-feat rtrv-card = |

rtrv-dstn rtrv-feat

rirv-gta rtrv-git

rtrv-gttsel rtrv-sid

rtrv-gttset rtrv-slk

rtrv-ls

rtrv-map

rtrv-rte

rtrv-scr-aftpc

rtrv-scr-blkdpc

rtrv-scr-blkopc

rtrv-scr-cidpa =
i@ Retrieve from STP
) Retrieve from Local Database

Reset | | Retrieve | Store | | Load |
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NOTE: If command information from only the selected STP is being
retrieved, and the Command Line Interface is not being used, skip step 5
and go to step 6.

5. To store the selected commands for the Command Line Interface, click the
Store button on the Commands Menu window. The Command Data Stored
window opens. See Figure 53.

Figure 53. Command Data Stored Window

Information d

J;Lg Command Data Stored

OK

Click OK to continue.

To verify what retrieve commands are stored, click the Load button. The
stored commands appear in the Selected Commands box, as shown in Figure
48 on page 47, Figure 49 on page 48, or Figure 50 on page 49.

To use the Command Line Interface, go to the “Command Line Interface”
section on page 61.

NOTE: If database tables are to be retrieved from the selected STP, skip
step 6 and go to step 7.

6. To generate CSV files from database tables already retrieved from the selected
STP, select the Retrieve from Local Database button after selecting the desired
commands. See Figure 54 on page 52. Click the Retrieve button.
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Figure 54. Retrieving Database Tables from the Local Database

Commands Menu

[ Retrieve Tables | Update Tables
Command List Selected Commands
rtrv-card
rtrv-ctrl-feat
rtrv-dstn
rtry-feat
rtrv-gta e
rtrv-gtt 2l
rtrv-gttsel
rtrv-gitset
rrvls
rtrv-map
rrv-rte
rtrv-scr-aftpc

[ »

-

Ll

_! Retrieve from STP
{®) Retrieve from Local Database

Reset || Retrieve Load

NOTE: If step 6 was performed, skip step 7. This procedure is finished.

7. Retrieve the database tables from the selected STP corresponding to the
commands selected in step 2 by selecting the Retrieve from STP button, then
click the Retrieve button. The Retrieve Tables Log window opens (see Figure
55 on page 53) and displays the message “Processing Retrieve Request, Please
Wait” until the retrieve process completes.

NOTE: The telnet terminals on the EAGLE 5 ISS to which FTRA will be
connecting should have their terminal settings set to all=no (use the
EAGLE 5ISS command chg-trm: trm=<telnet terminal>:all=no to
make this setting; use the EAGLE 5 ISS command rtrv-trm to verify the
EAGLE 5 ISS terminal settings). On an STP with heavy UIM output, this
prevents the FTRA's terminal from being flooded with unrelated output,
which could unnecessarily backlog command responses during FTRA
operation.

NOTE: If you are retrieving the database tables for any of these GTT
commands (rtrv-tt, rtrv-gtt) and any of these EGTT commands
(rtrv-gttsel, rtrv-gttset, rtrv-gta), see the Caution on page 40.
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Figure 55. Retrieve Tables Log Window - Processing Retrieve
Request
& FTP-based Table Retrieve Application <stpl = - |E||1|
File Edit View Help
Retrieve Tables Lo
File

Processing Retrieve Request, Please Wait

2002-09-03 09:04:57.716: Retrieve Process Manager: Purging Existing Tables For: stpl
2002-09-03 09:04:57.796: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-09-03 09:04:57.806: Telnet Terminal Session Manager: Session Connected: 10.1.2.10:8080
2002-09-03 09:04:58.988: Telnet Terminal Session Manager: Terminal 17 Enabled

2002-09-03 09:04:59.989: Telnet Terminal Session Manager: User "eagle" Login Attempt: 1

This message is displayed until the retrieve process completes. The Command
Complete window opens.

a. Ifno errors occurred, the text “Retrieve Tables processing completed
without errors.” “Please check Retrieve Tables Log for Results.” appears
in the Command Complete window. See Figure 56.

Figure 56. Command Complete Window Without Errors

Command Complete

Retrieve Tables processing completed without errors.
Please check Retrieve Tahles Log for results.

Click OK, to continue.

b. If errors occurred, the text “Retrieve Tables processing completed with
errors.” “Please check Retrieve Tables Log for Results.” appears in the
Command Complete window. See Figure 57 on page 54.
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Figure 57. Command Complete Window With Errors

& Command Complete

,JQI Retrieve Tables processing completed with errors.

Please check Retrieve Tables Log for results.

The Retrieve Table Log window opens. See Figure 58 on page 55 and Figure
59 on page 55. Click OK, to continue.

Retrieve Tables Log

The Retrieve Tables Log contains the events of the retrieve processing and any
error messages that may have occurred. The Retrieve Tables Log window is
opened after database tables have been retrieved from an STP and is displayed
until the retrieve processing is complete (see Figure 55 on page 53).

The Retrieve Tables Log displays the information of the CSV files generated for
the selected retrieve commands. The filenames of the CSV files are displayed in
ascending order except for the filename of the rtrv-stp CSV file. Since the
rtrv-stp command CSV is not generated by the CSVGEN(X) utility, the CSV
filename for the rtrv-stp command is not displayed in the sorted order with
other CSV filenames, but it is displayed as the last entry in the filenames list.
Since the Retrieve Tables Log is generated by the CSVGEN(X) utility, no record of
processing the rtrv-stp command is displayed in this log. See Figure 60 on page
56 for an example of the Retrieve Tables Log when the rtrv-stp command is
processed.

The log is automatically cleared when the next set of database tables are retrieved
from an STP. Selecting View > Retrieve Tables Log from the menu also opens the
Retrieve Tables Log window. See Figure 58 and Figure 59 on page 55.
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Retrieve Tables Log Window without Errors

& FTP-based Table Retrieve Application <stpl >

File Edit Yiew Help

Retrieve Tables Log

File

2002-12-05 08:19:10.911:
2002-12-05 08:19:11.912:
2002-12-05 08:19:12.923:
2002-12-05 08:19:14.205:
2002-12-05 08:19:14.215:
2002-12-05 08:19:15.247:
2002-12-05 08:19:15.758:
2002-12-05 08:19:16.769:
2002-12-05 08:19:16.899:
2002-12-05 08:19:17.911:
2002-12-05 08:19:18.071:
2002-12-05 08:19:19.082:
2002-12-05 08:19:20.324:
2002-12-05 08:19:21.346:
2002-12-05 08:19:21.556:
2002-12-05 08:19:21.666:
2002-12-05 08:19:21.776:
2002-12-05 08:19:22.828:
2002-12-05 08:19:22.978:

4

Figure 59.

Telnet Terminal Session Manager

2002-12-05 08:19:09.488: Retrieve Process Manager: Purging FTP File Transfer Area
2002-12-05 08:19:09.579: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-12-05 08:19:09.639: Telnet Terminal Session Manager: Session Connected: 10.2.1.74:8080
2002-12-05 08:19:10.8: Telnet Terminal Session Manager: Sending Eagle Command: 17

Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager: Sending Eagle Command: ent-ftp-serv:app=user:ipaddr=10.2.1.74:login=e
Telnet Terminal Session Manager:

Terminal 17 Enabled

User "eagle" Login Attempt: 1

Sending Eagle Command: login=uid=eagle

User "eagle" Login Accepted

Analyzing FTP-SERV APP=USER Accounts on Eagle

Sending Eagle Command: rtrv-ftp-serv:app=user

Updating Eagle FTP SERV Table

Sending Eagle Command: dIt-ftp-serv:app=user:ipaddr=1.2.3.4
Updating Eagle FTP SERV Table

Sending Eagle Command: dlt-ftp-serv:app=user:ipaddr=100.101.102.1
Updating Eagle FTP SERV Table

Instructing Eagle to Activate Table Transfers

: Sending Eagle Command: ACT-FTP-TRNS:ACTION=PUT:FILETYPE=ALL
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:

ALL Fileset Table Transfer Started, This May Take Several Minutes
ALL Fileset Table Transfer Complete

User "eagle" Logout Attempt: 1

Sending Eagle Command: logout

User "eagle" Logout Accepted

=10l =]

o E

Retrieve Table Log with Errors

t% FTP-based Table Retrieve Application <stp3>

File Edit Wiew Help

Retrieve Tables Log

File
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2002-08-20 12:23:58.683: Retrieve Process Manager: Purging Existing Tables

2002-08-20 12:23:58.804: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle
2002-08-20 12:24:19.754: Telnet Terminal Session Manager: Session Not Connected: 10.1.2.10:8080
2002-08-20 12:24:19.774: Retrieve Process Manager: Telnet Terminal Session Test Complete With Errors
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Figure 60. Retrieve Table Log with the RTRV-STP Command

{& FTP-based Table Retrieve Application <EAGLE=>
File Edit ‘iew Help

S=1ES

Retrieve Tables Log

File

2006-09-27 15:42:39.584: Retrieve Process Manager: The Following .CSV Files Have Been Generated:
2006-09-27 15:42:39.599: F:\sw_ftra\stp\EAGLE\csv\card_20020914_1321.csv
2006-09-27 15:42:39.615: F:\sw_ftra\stp\EAGLE\csv\ls_20020914_1321.csv
2006-09-27 15:42:39.631: F:\sw_ftra\stp\EAGLE\csv\stp_20020914_1321.csv
2006-09-27 15:42:39.865: Retrieve Process Manager: Closing Connections, Please Wait

CVSGEN: Begin Initializing DRMS (23 MB).
CSVGEN: Skipped Initializing DRMS Tables.

CSVGEN: Completed Initializing DRMS.

LINE 1: rtrv-card

tekelecstp 06-09-27 15:42:39 EST 36.0.0-57.4.0
Command Accepted
F:\sw_ftra\stp\EAGLE\csv\card_20020914_1321.csv file generated

i
LINE 2: rtrv-Is

tekelecstp 06-09-27 15:42:39 EST 36.0.0-57.4.0
Command Accepted
F:\sw_ftra\stp\EAGLE\csv\ls_20020914_1321.csv file generated

’

LINE 3: exit

Retrieve Tables Log File Menu

The File menu in the Retrieve Tables Log window, shown in Figure 61, provides
these selections:

2-56

Clearing the Retrieve Tables Log display
Printing the Retrieve Tables Log
Saving the Retrieve Tables Log to a file

Closing the Retrieve Tables Log window.
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Figure 61. File Menu in the Retrieve Tables Log Window
& FTP-based Table Retrieve Application <stpl> o |EI|5|
File Edit View Help

Clear Display 22.64 c:\ftra2\bin\feat_20020820_1226.csv
Print tializing DRMS (10 MB).

Save Initializing DRMS Tables.
Close

ruieoi. wonmnpieeed Initializiing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).
PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

LINE 1: rtrv-feat

tekelecstp 02-08-20 12:26:21 EST Rel 29.0.0-46.0.0
Command Accepted
feat_20020820_1226.csv file generated

LINE 2: exit

Clearing the Retrieve Tables Log Display
The display can be cleared, enabling new entries to be captured to the log. Once

the log is cleared, the existing entries are lost unless the log is saved to a file or
printed before the display is cleared.

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

Select File > Clear Display in the Retrieve Tables Log window. See Figure 61.

Select View > Retrieve Tables Log from the View menu in the FTP-based

Table Retrieve Application window. See Figure 62. The Retrieve Tables Log
window opens.

910-4919-001 Rev B, April 2007 2-57



User Guide FTP-Based Table Retrieve Application (FTRA)

Figure 62. View Menu

F,@.‘; FTP-based Table Retrieve Application <STP7>
File Edit

Retrieve Tables Log

Update Tables Loy
System Log

3. Select File > Clear Display in the Retrieve Tables Log window. The Retrieve
Tables Log display clears.

Printing the Retrieve Tables Log

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Print in the Retrieve Tables Log window. See Figure 61 on page
57.

2. Select View > Retrieve Tables Log from the View menu in the FTP-based
Table Retrieve Application window. See Figure 62. The Retrieve Tables Log
opens.

3. Select File > Print in the Retrieve Tables Log window. The Print window
opens. See Figure 63 on page 58.

Figure 63. Print Window

pane 2|

r— Frinter
Marme: M ailsLazerjet 8150 Properties. . |
Statuz: Feady

Type: HP Lazer)et 8150 PCL B
Where:  HPLaszerlet81505eries

Comment: ™ Print ko file

— Print range Copies

i Murnber of copies: |1 3:
" Pages fn:nm:|1 tD:|1

" Selection |j| I~ Callate
’TI Caticel |
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4. Configure the printer settings.

5. To print the Retrieve Tables Log, click the OK button in the Print window. The
current contents of the Retrieve Tables Log are printed.

6. If you decide not to print the Retrieve Tables Log, click the Cancel button in
the Print window.

Saving the Retrieve Tables Log to a File

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Save in the Retrieve Tables Log window. See Figure 61 on page
57.

2. Select View > Retrieve Tables Log from the View menu in the FTP-based
Table Retrieve Application window. See Figure 62 on page 58. The Retrieve
Tables Log window opens.

3. Select File > Save in the Retrieve Tables Log window. The Save window
opens. See Figure 64 on page 59.

Figure 64. Save Window

x|

Look In: ‘ﬁ logfiles "| @ @ @ @E

[ rtrv072302.doc

File Hame: |r1er?DzED2.duc |

Files of Type: | AllFiles -

Save H Cancel |
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4. Select a location for the file, and enter the file name and file type (with either
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use
Microsoft Word to open the file, even if it was saved as a .txt file.

NOTE: If you decide not to save the file, do not perform steps 5 and 6, but
click Cancel in the Save window.

5. Click the Save button. A Saved file confirmation window opens with “Data
saved to file.” See Figure 65.

Figure 65. Saved File Confirmation Window

ﬁ Data saved to file

6. To save the file, click OK in the Saved file confirmation window to continue.

Closing the Retrieve Tables Log Window

Procedure

1. Select File > Close in the Retrieve Tables Log window;, or click the close
window button in the upper right hand corner of the Retrieve Tables Log
window. See Figure 61 on page 57. The Retrieve Tables Log window closes.
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Command Line Interface

The FTRA Command Line Interface allows the user to retrieve the same database
tables, using the EAGLE 5 ISS’s retrieve commands, from all configured STPs in
the STP configuration database. The Store and Load buttons in the Retrieve
Tables window are used to select these retrieve commands. See “Retrieve
Database Tables from an STP” on page 40.

The Command Line Interface for FTRA 4.0 allows the user to change the STP
Username and Password for an STP already configured in the system.

Before the Command Line Interface can be started, you must exit the FTRA
application. To start the Command Line Interface retrieve process, enter the (ftra
-c) at the DOS command prompt (in Windows) or at a shell command prompt (in
UNIX).

For modifying the Username and Password for an STP, three command line

arguments have to be specified with the “-c” option (ftra —c stpname username
password).

The user can automate this retrieve process through the use of external
scheduling software such as Scheduled Task (on the Windows platform) and
“cron” (on the Unix platform). Please refer to the platform's scheduling program
for specifics on how to use the external scheduling software. For example, on the
Unix platform, enter the man crontab command.

Procedure - Command Line Interface Manual Start

1. Exit the FTRA application. See “Exit the FTRA” on page 3.

2. On the Windows platform, at a DOS prompt, go to the \bin directory of the
FTRA <install_directory> location.

3. On the Unix platform, at a shell prompt, go to the /bin directory of the FTRA
<install_directory> location.

4. Enter the ftra -c stpname username password command (see Figure 66 on
page 62 or Figure 68 on page 63). The stored rtrv commands are then sent to
the provisioned STP. The data tables are retrieved and converted to the CSV
tile format.

Result: The username and password shall be modified in the STP
configuration for the specified stpname.

NOTE: The parameters specified in the command line are case sensitive.
For example, an stpname specified as EAGLE, Eagle or eagle shall be
treated separately.
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Figure 66. FTRA Windows Command Line Interface

SWINNT Y System32ywomd.exe

C:nfrrashiniftra —c

Figure 67. FTRA Windows Command Line Interface to modify STP

data.
o CIAWINDOWSAsystem 32%cmd .exe

inoced ftra

:nftra>cd bin

infFtrashin?fetra —¢ EAGLE eagle eaglel23_
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Figure 68. FTRA UNIX Command Line Interface

[?S]derry[fesport homeSgwheeleldsftrasbinl: . Aftra —C

Figure 69. FTRA UNIX Command Line Interface to modify STP data.

| [?S5]jerry [/fexport/home/gwheeled/Ftrasbin]l: ./ftra -c EAGLE
eagle eaglel 23
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Figure 70. FTRA Windows Scheduled Task
O @ 21
Task | Schedue] Settings |
CAWINNT ST acksMtra job
Aun | C:\tha\bin\ftra bat -¢
Browsze, . I

Statis | C:\ftra\bin

Lommerts:

FAun as |DDHAIH\.usemamd Setpazzword.. I

W Enabled [scheduled tazk runs at zpecified time]

ok | cance | spob |
Figure 71. FTRA Windows Scheduled Task to modify STP data

fira

7 &

Task Cchedule | Settings Securi&y.
C:\WwWINDDWSMNT azkshftrajob

Run: [ C:\frahbin\ftra bat -c EAGLE eagle eagle123

Skart irt C:\frabin

Comments:

Run as: (ASIA\GUR1D544 [ Setpasswod.. |

[C1Run only if logged om

Enabled [scheduled task muns at specihed bme]

Ok ] [ Cancel ] [ Apply
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Figure 72. UNIX cron job scheduled via crontab (note: last line shows
FTRA scheduled to run at 3am Monday through Friday

_ Text Editor — crontabHGad.0 j
Eile Edit Format Options Help |

#ident "@{H)root 1.19 98/07/06 SMI” F*osVr4.0 1,131
#

# The root crontab should be used to perform accounting data collection.
#

# The rtec command is run to adjust the real time clock if and when

# daylight sawings time changes.

0.4 fetc/cron.d/logchecker

0 fusrf1ib/newsyslog

0 fusr/libffsinfs/nfsfind

12 **=* [ -x Jusr/shin/rtc ] && Afusr/shin/rtc -c » fdew/null 2:8&1

an 3 = = *= [ -» fusrflibh/gss/gsscred_clean 1 && fusr/1ihsgss/gsscred_cle
03 **1-5 fhonefuserl/ftra/bin/ftra

ono o
(TR TN ]
* 4+ #
* 4 #

¥
I )

Figure 73. FTRA wrapper script example for Unix (might be necessary if
running from cron)

file Edit Format Options Help

I[FTR&HE!-E#takahchtra
JRE_MOME=/tekelec/java/j2rel.4.0_01
grport FTRA_HOME

grport JRE_HOME
Jtekelec/ftra/bin/ftra —c

i 15
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Figure 74. FTRA wrapper script example on Unix for modifying STP
configuration (might be necessary if running from cron)

Hindow Edit Options

FTRA_HOHE=/tekelec/ftra
JRE_HOHE=/tekelec/ java/ j2rel,.d,0_01

export FTRA_HOHE

export JTE_HOHE

/tekelec/Ttrasbin/ftra —c EAGLE eagle eaglel?3f

T L oF O+ OGTo: o obpo¥ o¢oEomoORT RTOREOE

"ftra_wrapper”™ [New filel =il

Procedure - Command Line Interface Automatic Start

1. To automate the FTRA retrieve process, enter the "ftra -c" command, the path
to the bin directory of FTRA i.e. <install_directory> and the start time in the
external scheduling software such as Scheduled Tasks (in Windows, see
Figure 103 on page 90) or "cron" (in Unix, see Figure 104 on page 91).

Result: When the start time is reached, the stored rtrv commands are sent to
all the provisioned STPs. The data tables are retrieved and converted to CSV
file format for the stored rtrv commands.

However, to automate the FTRA retrieve process using three command line
parameters, enter the ftra -c¢ stpname username password command, the
path to the bin directory of the FTRA such as <install_directory>, and the start
time in the external scheduling software such as Scheduled Tasks (on
Windows) or "cron" (on Unix).

Result: The username and password shall be modified in the STP
configuration for the specified stpname. When the start time is reached, the
stored rtrv commands are sent to all the provisioned STPs. The data tables
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will be retrieved and converted to csv file format for the stored rtrv

commands. See Figure 99 on page 87 for example.

NOTE: If you are using “cron” on the Unix workstation, it might be
necessary to create a wrapper script for FTRA, in order to correctly set
environment variables. For an example of the wrapper script, see Figure 77

on page 70.

Table 6. FIRA - Eagle Compatibility Matrix

FITRA | FTRA | FTRA | FTRA | FTRA | FTRA | FITRA
1.0 1.1 2.0 2.1 2.2 3.0 4.0
Eagle 28.x |N N N N N N N
and earlier
Eagle29.0 |Y N N N N Y Y
Eagle 30.0 |N Y Y N N Y Y
Eagle30.2 |N N Y N N Y Y
Eagle31.3 |N N N Y N Y Y
Eagle 31.6 |N N N N Y Y Y
Eagle 319 |N N N N Y Y Y
Eagle 32.0 |N N N N N Y* Y*
Eagle35.0 |N N N N N Y* Y*
and later Y
Legend:

N - Not supported.

Y - Supported. (CSVGen installed from FTRA install CD.)
Y* - Supported. (CSVGen transferred from Eagle TDM.)

Y** - Supported. (rtrv-stp command support, command line support for
modifying STP data.)

All other releases of Eagle that are not listed are not officially supported by any
release of FTRA.
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Updating Database Tables in the Selected STP

The Update Tables window (see Figure 75) is used to send EAGLE 5 ISS
commands to the selected STP. The commands, in the form of a command file, are
validated before being sent.

To send the command file to the selected STP, the command file is selected by
entering the path and file name of the command file, or by selecting the file name
of the command file from the Select window. The command file is then validated
by clicking the Validate button in the Update Tables window. When the
validation is completed, the Update Validation Complete window appears. From
the Update Validation Complete window the command file can be edited, sent to
the selected STP, or the Update Validation Complete window can be closed
without sending the command file to the selected STP. The Update Tables Log
contains the events of the command validation and any error messages that may
have occurred.

Figure 75. Update Tables Window

‘,;".?; FTP-based Table Retrieve Application <STP7> = |E||£|
File Edit “iew Help

Commands Men

Update Tables |

Command File

| Browse |

[C] Stop on error

Table 7 shows the description of the fields and buttons in the Update Tables
window.
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Table 7. Update Tables Window Description

Item Description
Fields
Command The path and file name of the command file are entered here.
File A command file contains the EAGLE 5 ISS commands used to

modify database tables of the STP.

Stop on error | If the box is checked, and an error is found during the

box validation of the commands, the validation stops and no
further commands are validated. If the box is not checked, all
commands are processed regardless of errors. The error
results are displayed in the Update Tables Log.

Buttons
Browse Opens the Select window to select the command file to send
to the selected STP.
Validate Validates the EAGLE 5 ISS commands using the offline
database.
Close Closes the Commands Menu window.

Validating a Command File

Procedure

1. Select Edit > Commands > Update Tables in the FTP-based Table Retrieve
Application window. See Figure 76. The Update Tables window opens. See
Figure 75 on page 68.

Figure 76. Edit Menu

F@ FTP-hased Table Retrieve Application <stplz> ngﬂ
File View Help

STP Connection Configuration
FTP Server Configuration

2. Perform one of these steps.

a. Enter the path and name of the command file in the Command File field.
See Figure 77.

b. Click the Browse button. The Select window is opened. See Figure 77
on page 70. Find the folder containing the command file and click on the
command file name. The command file name is highlighted. Click the
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Select button. The Select window disappears and the Update Tables
window appears with the path and file name of the selected command
tile entered in the Command File field.

If you wish to cancel the command file selection process in the Select
window, click the Cancel button.

Table 8 on page 70 shows the description of the buttons in the Select
window.

Figure 77. Select Window

X
Look In: ‘ SCripts - | @ @ @ @E
[} card.txt [ gttsel.txt [} scr-blkdpe.txt [ scr-sio.tst
[ ctrifeattxt [ ottsettxt [ scr-blkope.txt [ scr-ttixt
[ dstn.txt [ Is.txt [ scr-cdpatst [ ] scrsettst
D feat.txt D map.txt D scr-cgpa.txt D sid.txt
[ ftpcmds.dat [ rtedst [ scr-destfdtzt [ slktxt
D gtatxt D rtrvcmds.scr D sCr-dpc.ixt D stpopts.txt
|__"’] gtt.txt |j| scr-aftpe.txt D Scr-opc.txt D bt
File Name: |feat.t=£t |
Files of Type: | Al Files -|
| Select | | Cancel ‘
Table 8. Select Window Descriptions
Item Description
Fields
Look in: A drop down menu allowing the user to browse through
the directory structures.
File Name: The name of the file to be selected.
Files of type: | A drop down menu that selects all files.
Buttons
Select The contents of the File Name field and the path to the
filename is loaded into the Command File field of the
Update Tables window.
Cancel Closes the Select window.
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3. If you wish to have the command validation stop if any errors are found,
check the Stop on error box in the Update Tables window. See Figure 78. If
you wish to have the command validation processed regardless of any errors,
uncheck the Stop on error box. The error results are displayed in the Update
Tables Log.

Figure 78. Update Tables Window with a Command File
Selected and Stop on Error Box Checked

,‘.'5; FTP-based Table Retrieve Application <STP7> : = |E||i
File Edit View Help

Commands Menu

Update Tables |

Command File

[ c\fraziscriptsifeat.bt | Browse |
vi

4. Click the Validate button. The Update Tables Log window opens at the
beginning of the validate process and displays the “Processing Validate
Request, Please Wait” message until the validation of the command file is
complete. See Figure 79.
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Figure 79. Update Tables Log Window - Processing Retrieve
Request

& FTP-based Table Retrieve Application <stpl > - | Dlﬂ
File Edit View Help

Update Tables Log
File

Processing Validate Request, Please Wait

VGTT =off MGIT =off MPC = off
ITUDUPPC = off GFLEX = off LNP18MIL = off
GSMSCRN = off GPORT = off LNP48MIL = off
MEASPLAT = off TSCSYNC = off E5IS = off

LINE 6: rtrv-feat

tekelecstp 02-09-03 09:20:05 EST Rel 29.0.0-46.0.0
rtrv-feat

Command entered at terminal #4.

EAGLE FEATURE LIST

GIT =off GWS =off NRT = off

X25G =off LAN =off CRMD = off

SEAS =off LFS =off MTPRS = off

LNP =off FAN =on DSTN5000 = off
WNP =off CNCF = off LNP12MIL = off
TLNP = off SCCPCNV = off TCAPCNV = off
IPISUP = off DYNRTK = off X252000 = off

The Update Validation Complete window opens. See the “Update Validation
Complete Window” section on page 73.

5. The Update Tables Log window opens. It contains the events and error
messages generated during the validation. See Figure 89 on page 78, Figure 90
on page 79, and Figure 91 on page 80 for Update Tables Log examples.

NOTE: If there is no entry in the Command File field and the Validate
button is clicked, a warning message is displayed stating that a command
file name must be entered. See Figure 80.

Figure 80. Must Enter Command Script File Name
Message

Must enter Command Script file name
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When the command validation has completed, the Update Validation Complete

window opens notifying the user if the commands validated with or without

errors. From the Update Validation Complete window, the command file can be
edited, sent to the selected STP, or the window can be closed without sending the
command file to the selected STP. See Figure 81.

Figure 81. Update Validation Complete Window without
Errors

Update ¥alidation Complete ﬂ

ﬁ Update Tables validation completed without errors.
J;L?g See Update Tahles Log for results.
Press Edit to ednt command file;
Commit to update Eagle;
Stop to end without commit.

| Eait || commit|| stop |

Table 9 shows the description of the buttons in the Update Validation Complete

window.

Table 9. Update Validation Complete Window Description

Item

Description

Edit

Opens the Command File Editor window and allows the user
to make changes to the command file. To edit a command file,
go to the “Editing a Command File” section on page 75.

Commit

Sends the commands in the command file to the STP. A
Command Complete window opens and the Update Tables
Log is updated. See the “Sending a Command File to the
Selected STP” section on page 74.

If the Update Tables validation completed with errors the
Commit button is not displayed.

Stop

Closes the Update Validation Complete window without
sending the commands in the command file to the STP.
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Update Validation Complete Window with Errors

If the Update Validation Complete window shows that errors have occurred, the
command file can be edited or the window can be closed without sending the
command file to the selected STP. See Figure 82. There is no Commit button in
this window; this prevents the sending of invalid commands.

To fix the errors in the command file, click the Edit button, then go to the “Editing
a Command File” section on page 75.

Figure 82. Update Validation Complete Window with
Errors

Update ¥alidation Complete ﬂ

Update Tables validation completed with errors.
See Update Tahles Log for results.

Press Edit to edit command file;

Stop to end without commit.

[ean || stp |

Sending a Command File to the Selected STP

To send the command file, click the Commit button in the Update Validation
Complete window. The Commit button is shown only on the Update Validation
Complete without Errors window. See Figure 81 on page 73. The validated
command file is sent to the selected STP.

The Command Complete window opens and displays: “Update Tables
processing completed without errors” and “Please check Update Tables Log for
results.” See Figure 83. Click OK, to continue. The Update Tables Log contains the
commit processing events. See Figure 89 on page 78.

Figure 83. Command Complete Window

& Command Complete x|

] Update Tables processing completed without errors.

Please check Update Tables Log for results.
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Stop Without Sending or Editing a Command File

To stop the process without sending or editing a command file, click the Stop
button in the Update Validation Complete window. See Figure 81 on page 73.
The Update Validation Complete window is closed. No changes are made to the
command file and the command file is not sent to the selected STP.

Editing a Command File

To edit a command file, click the Edit button in the Update Validation Complete
window. The Command File Editor window is opened. See Figure 84.

Figure 84. Command File Editor Window

& FTP-based Table Retrieve Application <STP7>

(ol x|
File Edit View Help

Command File Edito
File

chg-feat:fan=on
rtrv-feat

| Browse |

When the editing is complete, the command file can be saved without sending the
command file to the selected STP, saved and sent to the selected STP without any

further validation, or the command file can be closed without saving the changes
to the command file.
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Procedure

1. Click the Edit button in the Update Validation Complete window. See Figure

81 on page 73. The Command File Editor window opens. See Figure 84 on
page 75.

NOTE: The hourglass is displayed until the Command File Editor
window is closed.

NOTE: If an attempt is made to close the Update Tables window while

the Command File Editor window is opened, the Command In progress,
Cannot Close Window warning message is displayed. See Figure 85.

Figure 85. Command In progress, Cannot Close Window

Command in progress, cannot close window.

2. Edit the command file. Figure 86 shows a command file with an invalid
command. In this example, the invalid command is chg- feat:. This
command should be removed from the command file, or have a correct
parameter and value added to it.

Figure 86. Command File Editor with Invalid Command

& FTP-based Table Retrieve Application <STP7>

= [m 3]
File Edit View Help

Command File Edito
File

chg-feat: Invalid Command

chg-feat:fan=on

||'trv—feat | Browse |
Validate
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3. When the editing is complete, perform one of these steps.

a. Select File > Save from the Command File Editor window (see Figure

87). The command file is saved and the Command File Editor window
remains open. The command file is not sent to the selected STP. The
command file can be validated again in the Update Tables window.

Figure 87. File Menu in the Command File Editor Window

& FTP-based Table Retrieve Application <STPT>

i [m] 3]
File Edit View Help

Command File Editor

Save
Save and Commit
| Browse |
Validate

. Select File > Save and Commit from the Command File Editor window
(see Figure 87). The command file is saved and the Command File Editor
window closes. The Command Complete window opens and displays:
“Update Tables processing completed without errors. Please check
Update Tables Log for results. Click OK, to continue. See Figure 88. The
command file is sent to the selected STP. The Update Tables Log contains
the commit processing events. See Figure 89 on page 78

Figure 88. Command Complete Window

€. command Complete

@ Updlate Tables processing completed without errors.
Please check Update Tables Log for results,

c. Select File > Quit from the Command File Editor window (see Figure

87). The Command File Editor window closes. The command file is not
sent to the selected STP. If changes to the command file have been made,
a window is displayed asking if you want to save the changes.
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Update Tables Log Window

The Update Tables Log contains the processing events and any error messages
that may have occurred during the validation and sending of a command file. The
Update Tables Log window is opened at the beginning of the validation process
and displays “Processing Validate Request, Please Wait” (Figure 79 on page 72)
until the command file validation is completed. The Update Tables Log window
is automatically cleared when the next command file validation is started.
Selecting View > Update Tables Log from the menu can also open the Update
Tables Log window.

See Figure 89, Figure 90 on page 79, Figure 91 on page 80, and Figure 92 on page
81 for the Update Tables Log window examples.

Figure 89. Update Tables Log Window after the Commit
Command Completed
8 F1P-based Table Retrieve Application <stpl> =181l
File Edit View Help
Update Tables Log n‘ I:f E

File

ITUMTPRS = off SLSOCB = off EGTT = off
VGTT =off MGTT =off MPC = off
ITUDUPPC = off GFLEX = off LNP18MIL = off
GSMSCRN = off GPORT = off LNP48MIL = off
MEASPLAT = off TSCSYNC = off E5IS = off

r

LINE 4: exit

2002-08-21 09:17:50.844: Telnet Terminal Session Manager: Initiating Telnet Session with Eagle

2002-08-21 09:17:51.034:
2002-08-21 09:17:52.276:
2002-08-21 09:17:53.287:
2002-08-21 09:17:55.521:
2002-08-21 09:17:55.651:
2002-08-21 09:17:55.781:
2002-08-21 09:17:56.913:
2002-08-21 09:17:58.044:
2002-08-21 09:17:59.176:
2002-08-21 09:18:00.308:
2002-08-21 09:18:01.439:
2002-08-21 09:18:02.571:
2002-08-21 09:18:03.703:

2002-08-21 09:18:04.103

: Commit Process Manager: Telnet Terminal Session Complete Without Errors

Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:
Telnet Terminal Session Manager:

Session Conneted: 66.26.93.175:8080

Terminal 17 Enabled

User "eagle" Login Attempt: 1

User "eagle" Login Accepted
Sending Command Updates to Eagle
Sending Eagle Command:
Sending Eagle Command:
Sending Eagle Command:
Sending Eagle Command:
Sending Eagle Command:
Sending Eagle Command:
User "eagle" Logout Attempt: 1
User "eagle" Logout Accepted

chg-feat:fan=on
rtrv-feat

exit

exit

exit
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Figure 90. Update Tables Log

g@; FTP-based Table Retrieve Application <stp1:

File Edit View Help

Update Tables Log

User Guide

=10| ]

g [

File

2002-08-20 12:30:48.803: and.exe/C c:\ftra2\bin\update.bat

2002-08-20 12:30:49.414: Table Updates: c:\ftra2\bin\update.bat Exit Code is: 0
2002-08-20 12:30:49.424: Table Updates: c:\ftra2\bin\update.bat Execution Complete
2002-08-20 12:30:49.434: Table Updates: c:\ftra2\bin\update.bat Executed Successfully
2002-08-20 12:30:49.444: Cmd Rej Search: Searching For Input Command Errors
PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

LINE 1: chg-feat:fan=on
tekelecstp 02-07-26 09:01:20 EST Rel 29.0.046.0.0
chg-feat:fan=on

Command entered at terminal #4.
CHG-FEAT: MASP A - COMPLTD

-
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Figure 91. Update Tables Log with Stop on Error Box Checked
in the Update Tables Window

@ FTP-based Table Retrieve Application <stp1> —18]x]

File Edit View Help

] update Tables Log o e |

File

2002-08-21 10:07:03.318: Validate Process Manager: Instructing PCTEST to Perform Updates =
2002-08-21 10:07:03.328: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Created Successfully 7
2002-08-21 10:07:03.348: Terminal Security And Feature Change: Executing the following cmds:

2002-08-21 10:07:03.358: cmd.exe/C c:\ftra2\bin\chgtrm.bat

2002-08-21 10:07:03.619: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Exit Code is: 0

2002-08-21 10:07:03.629: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Execution Complete

2002-08-21 10:07:03.649: Terminal Security And Feature Change: c:\ftra2\bin\chgtrm.bat Executed Successfully

2002-08-21 10:07:03.669: Table Updates: c:\ftra2\bin\update.bat Created Successfully

2002-08-21 10:07:03.679: Table Updates: Executing the following cmds:

2002-08-21 10:07:03.689: cmd.exe/C c:\ftra2\bin\update.bat

2002-08-21 10:07:04.29: Table Updates: c:\ftra2\bin\update.bat Exit Code is: 0

2002-08-21 10:07:04.31: Table Updates: c:\ftra2\bin\update.bat Execution Complete

2002-08-21 10:07:04.32: Table Updates: c:\ftra2\bin\update.bat Executed Successfully

2002-08-21 10:07:04.33: Cmd Rej Search: Searching for Input Command Errors

2002-08-21 10:07:04.35: Validate Process Manager: Command File C:\ftra\scripts\feat.txt Contains Errors, See Results Below
PCTEST: Begin Initializing DRMS (10 MB).

PCTEST: Skipped Initializing DRMS Tables.
PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB). Error message

PCTEST: Skipped Initializing DRMS Tables. =

PCTEST: Completed Initializing DRMS.
LINE 1: chg-feat

tekelecstp 02-08-16 10:07:04 EST Rel 29.0.0-46.0.0 Command from the
chg-feat «¢

Command entered at terminal #4. command file
E2136 Cmd Rej: At least one optional parameter is required

CHG-FEAT: MASP A - Command Aborted
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Figure 92.

File Edit View Help

Update Tables Log with Stop on Error Box NOT
Checked Error in the Update Tables Window

User Guide

[ update Tables Loy

File

2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:

2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:
2002-08-21 10:12:11.417:

Validate Process Manager: Instructing PCTEST to Perform Updates
Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Created Successfully
Terminal Security and Feature Change: Executing the following cmds:
cmd.exe/C c:\ftra2\bin\chgtrm.bat

Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Exit Code is: 0
Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Execution Complete
Terminal Security and Feature Change: c:\ftra2\bin\chgtrm.bat Executed Successfully
Table Updates: c:\ftra2\bin\update.bat Created Successfully
Table Updates: Executing the following cmds:

cmd.exe/C c:\ftra2\bin\update.bat

Table Updates: C:\ftra2\bin\update.bat Exit Code is: 0

Table Updates: C:\ftra2\bin\update.bat Execution Complete
Table Updates: C:\ftra2\bin\update.bat Executed Successfully
Cmd Rej Search: Searching For Input Command Errors

2002-08-21 10:12:11.417: Validate Process Manager: Command File C:\ftra\scripts\command_files\feat.txt Contains Errors, See Results Below.
PCTEST: Begin Initializing DRMS (10MB)

PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10MB)
PCTEST: Skipped Initializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

Figure 86 on page 76 shows an example of a command file that produced the error
shown in Figure 92.
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Figure 93. Update Tables Log with Stop on Error Box NOT
Checked Error in the Update Tables Window (continued)

& FTP-based Table Retrieve Application <stp1: . =] |
File Edit View Help
] upuate Tables Log Ealln
File

D

LINE 1: chg-feat
tekelecstp 02-08-20 12:33:27 EST Rel 29.0.0-46.0.0
chg-feat:

Command entered at terminal #4.
E2136 Cmd Rej: At least one optional parameter is required
CHG-FEAT: MASP A - Command Aborted

LINE 2: chg-feat:fan=on

Commands from the
command file

tekelecstp 02-08-20 12:33:27 EST Rel 29.0.0-46.0.0

chg-feat:fan=on

Command entered at terminal #4.

CHG-FEAT: MASP A - COMPLTD
LINE 3: rtrv-feat

tekelecstp 02-08-20 12:33:27 EST Rel 29.0.0-46.0.0

rtrv-feat
Command entered at terminal #4.
EAGLE FEATURE LIST

GIT =on GWS =off NRT = off

X25G =off LAN =off CRMD = off

SEAS =off LFS =off MTPRS = off

LNP =off FAN =on DSTN5000 = off

WNP = off CNCF = off LNP12MIL = off

TLNP =off SCCPCNV = off TCAPCNV = off
IPISUP = off DYNRTK = off X252000 = off
INP =off PLNP =off NCR = off

ITUMTPRS = off SLSOCB = off EGTT = off
VGTT =off MGIT =off MPC = off
ITUDUPPC = off GFLEX =off LNP18MIL = off
GSMSCRN = off GPORT = off LNP48MIL = off
MEASPLAT = off TSCSYNC =off ESIS = off

i

LINE 4: exit

File Menu in the Update Tables Log Window

The File menu in the Update Tables Log window, shown in Figure 94 on page 83,
provides the user with the following selections:

¢ C(Clearing the Update Tables Log display.
¢ Printing the Update Tables Log.

¢ Saving the Update Tables Log to a file.

¢ C(Closing the Update Tables Log window.
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Figure 94. File Menu in the Update Tables Log Window

& FTP-based Table Retrieve Application <stpl >

=) |
File Edit View Help

Clundate tantesLog = = = 0 o o 0

—_—
e E
Clear Display :59.184: Table Updates: c:\ftra2\bin\update.bat Execution Complete
. :59.194: Table Updates: c:\ftra2\bin\update.bat Executed Successfully
Print :59.204: Cmd Rej Search: Searching For Input Command Errors
save tializing DRMS (10 MB).
Close [nitializing DRMS Tables.

PCTEST: Completed Initializing DRMS.

PCTEST: Begin Initializing DRMS (10 MB).
PCTEST: Skipped Initializing DRMS Tables.
PCTEST: Completed Initializing DRMS.

LINE 1: rtrv-feat
tekelecstp 02-08-21 10:25:59 EST Rel 29.0.0-46.0.0
rtrv-feat
Command entered at terminal #4.

EAGLE FEATURE LIST

GTT =on GWS = off NRT = off
X25G = off LAN = off CRMD = off
SEAS = off LFS = off MTPRS = off
LNP = off FAN = on DSTN5000 = off

TLNP = off SCCPCNV = off TCAPCNV = off
IPISUP = off DYNRTK = off X252000 = off
INP =off PLNP = off NCR = off

ITUMTPRS = off SLSOCB = off EGTT = off
VGTT = off MGTT = off MPC = off
ITUDUPPC = off GFLEX = off LNP18MIL = off
GSMSCRN = off GPORT = off LNP48MIL = off
MEASPLAT = off TSCSYNC = off ES5IS = off

i

LINE 2: exit

Clearing the Update Tables Log Display

The display can be cleared, enabling new entries to be captured to the log. Once
the log is cleared, the existing entries are lost unless the log is save to a file or
printed before the display is cleared.

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Clear Display in the Update Tables Log window. See Figure 94.

2. Select View > Update Tables Log in the FTP-based Table Retrieve
Application window. See Figure 95. The Update Tables Log window opens.

Figure 95. View Menu

E&.} FTP-based Table Retrieve Application <STP
File Edit
Retrieve Tables Log

Update Tahles Log
System Log
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3. Select File > Clear Display in the Update Tables Log window. The Update
Tables Log display clears.

Printing the Update Tables Log

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Print from the Update Tables Log window. See Figure 94 on page
83.

2. Select View > Update Tables Log in the FTP-based Table Retrieve
Application window. See Figure 95 on page 83. The Update Tables Log opens.

3. Select File > Print from the Update Tables Log window. The Print window
opens. See Figure 96.

Figure 96. Print Window

— Printer

Marme; b ailsLazenet 8150 Properties... |

Status: Ready
Type: HF Lazerlet 8150 PCL B
Where:  HPLaserlet81505enes

Comment; [ Prirt ta file

— Print range Copies

Chl Mumber of copies: |1 3:

" Pages fn:nm:l'l tn:l'l_

= Selection Ijl ™ Callate
’TI Cancel |

4. Configure the printer settings.

5. To print the Update Tables Log, click the OK button. The current contents of
the Update Tables Log are printed.
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6. If you do not wish to print the Update Tables Log, click the Cancel button.

Saving the Update Tables Log to a File

Procedure

NOTE: Perform either step 1 or steps 2 and 3.

1. Select File > Save from the Update Tables Log window. See Figure 94.

2. Select View > Update Tables Log in the FTP-based Table Retrieve
Application window. See Figure 95 on page 83. The Update Tables Log opens.

3. Select File > Save in the Update Tables Log window. The Save window
opens. See Figure 97.

Figure 97. Save Window

x|

Look In: ‘ﬁ loufiles "| @ @ @ @E

[ rtrv072302.doc

File Hame: |updateﬂ?2502.duc |

Files of Type: | All Files -

Save H Cancel |

4. Select a location for the file, and enter the file name and file type (with either
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use
Microsoft Word to open the file even if it was saved as a .txt file.

5. To save the file, click the Save button. A Saved file confirmation window
opens with “Data saved to file.” See Figure 98. Click OK, to continue.
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Figure 98. Saved Confirmation Window

ﬁ Data saved to file

6. If you do not wish to save the file, click the Cancel button in the Save
window.

Closing the Update Tables Log Window

Procedure

1. Select File > Close in the Update Tables Log window, or click the close
window button in the upper right hand corner of the Update Tables Log
window. See Figure 94 on page 83. The Update Tables Log window closes.
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The System Log

The System Log contains an event history and any errors that have occurred when

database tables are retrieved from an STP, or command files are sent to an STP. See
Figure 99.

Figure 99. System Log Window

& FTP-based Table Retrieve Application <stpl>

=10l x|

File Edit View Help

System Log -
File

2002-08-26 08:31:10.509: Communications: Initialization Sequence Started

2002-08-26 08:31:10.539: Communications: Initialization Sequence Complete

2002-08-26 08:34:01.168: Command Request Handler: Process Command Request
2002-08-26 08:34:01.178: Retrieve Command Request Handler: Process Command Request
2002-08-26 08:34:01.258: Retrieve Process Manager: Process Begun For: stpl

2002-08-26 08:34:20.126: Retrieve Process Manager: Process Complete For: stpl
2002-08-26 08:34:58.612: Command Request Handler: Process Command Request
2002-08-26 08:34:58.622: Update Tables Command Request Handler: Process Command Request
2002-08-26 08:34:58.632: Update Tables Submit Action Handler: Process Command Request
2002-08-26 08:34:58.662: Validate Process Manager: Process Begun For: stpl

2002-08-26 08:34:59.113: Validate Process Manager: Process Complete For: stpl

File Menu in the System Log Window

The File menu in the System Log window, shown in Figure 100 on page 88,
provides these selections:

¢ Clearing the System Log display.
¢ Printing the System Log.

¢ Saving the System Log to a file.

¢ C(Closing the System Log window.
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Figure 100.  File Menu in the System Log Window

E&- FTP-based Table Retrieve Application <stplZ

- 10 =

File Edit View Help
System Log o =
File
Clear Display :10.509: Communications: Initialization Sequence Started
Print :10.539: Communications: Initialization Sequence Complete

:01.168: Command Request Handler: Process Command Request
Save :01.178: Retrieve Command Request Handler: Process Command Request
Close :01.258: Retrieve Process Manager: Process Begun For: stpl

2zuuz-uo-20 vo.>1:20.126: Retrieve Process Manager: Process Complete For: stpl
2002-08-26 08:34:58.612: Command Request Handler: Process Command Request
2002-08-26 08:34:58.622: Update Tables Command Request Handler: Process Command Request

2002-08-26 08:34:58.632: Update Tables Submit Action Handler: Process Command Request
Validate Process Manager: Process Begun For: stpl
Validate Process Manager: Process Complete For: stpl

2002-08-26 08:34:58.662:
2002-08-26 08:34:59.113:

Clearing the System Log Display
The display can be cleared, enabling new entries to be captured to the log. Once

the log is cleared, the existing entries are lost unless the log is saved to a file or
printed before the display is cleared.

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application
window. See Figure 101. The System Log window opens.

Figure 101.  View Menu

F&.‘; FTP-based Table Retrieve Application <STP7>
File Edit
Retrieve Tables Log

Update Tables Log
System Log

2. Select File > Clear Display in the System Log window. See Figure 100. The
System Log display clears.
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Printing the System Log

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application
window. See Figure 101 on page 88. The System Log window opens.

2. Select File > Print in the System Log window. The Print window opens. See

Figure 102.
Figure 102.  Print Window
pent 2| x|
 Printer
I ame: Sy ailsLazerjet 8150 Properties... |
Statuz: Feady

Type: HP Lazer)et 8150 PCL B
Where:  HPLaserlet81505ernies

Commett; [~ Print to file

— Print range Copies

Lo Mumber of copies: |1 3:
" Pages fr-:-m:|1 tn:|1

" Selection Ijl T Callate

(] I Cancel |

3. Configure the printer settings.

4. To print the System Log, click the OK button. The current contents of the
System Log are printed.

5. If you decide not to print the System Log, click the Cancel button.
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Saving the System Log to a File

Procedure

1. Select View > System Log in the FTP-based Table Retrieve Application
window. See Figure 101 on page 88. The System Log opens.

2. Select File > Save in the System Log window. The Save window opens. See
Figure 103.

Figure 103.  Save Window

Look In: ‘Ij logfiles v| @ @ @ @E

[ rtrv072302.doc

File Name:  |sys072302.doc |

Files of Type: | All Files ~|

Save H Cancel |

3. Select a location for the file, and enter the file name and file type (with either
the .doc or .txt extensions).

NOTE: The .doc file type is recommended, although the user can use
Microsoft Word to open the file even if it was saved as a .txt file.

4. To save the System Log to a file, click the Save button. A Saved file
confirmation opens with “Data saved to file”. See Figure 104. Click OK to
continue.
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Figure 104.  Saved Confirmation Window

ﬁ Data saved to file

5. If you do not wish to save the System Log to a file, click the Cancel button in
the Save window.

Closing the System Log Window

Procedure

1. Select File > Close in the System Log window, or click the close window
button in the upper right hand corner of the System Log window. The System
Log window closes.
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About FTRA Window

The About FTRA window displays the version level of the FTRA and copyright
information. To display the About FTRA window, select Help > About in the
FIP-based Table Retrieve Application window. See Figure 105.

Figure 105.  Help Menu

E{%— FTP-based Table Retrieve Application <STP7 >

File Edit View

The About FTRA window opens. See Figure 106. Click OK, to continue.
Figure 106.  Typical About FTRA Window

X
_'—' FTP-based Tahle Retrieve Application
-_— "‘ o - FTRA Version 3.0-40.6.0

¢ c) Copyright 2005
VaN |
TEKEL'EC http://‘www.tekelec.com
[ oK |

FTRA release 4.0
The following sub-sections detail the changes that were made to FTRA Release
4.0.

Change summary.
The following enhancements have been included in FTRA Release 4.0:

1. Support for rtrv-stp command.

2. Support to change the STP Username and Password for an STP whose
configuration already exists in the system through the Command Line.

The second identified enhancement has introduced some minor changes to the
Command Line Interface.
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RTRV-STP Command.

The rtrv-stp command is added to the list of rtrv commands supported on FTRA.
The rtrv-stp command provides a consolidated report of STP configuration on a
system-wide basis.

NOTE: The rtrv-stp functionality is supported on Eagle Release 35.0 or
later.

Retrieve Tables

This added functionality provided in FTRA Release 4.0 changes the display of the
Retrieve Table Window. A new command rtrv-stp is added to the retrieve
command list as shown in Figures 107.

Figure 107.  Retrieve Tables window with rtrv-stp command selected for
retrieval.

& FTP-based Table Retrieve Application <> X :.Lg.[.’ﬁ.l

Command List Selected Commands

| »

rtrv-scr-cgpa
rrv-scr-destild
rtrv-scr-dpc
rtrv-scr-opc
ry-scr-sio
rirv-scr-it
rtry-scrset
rirv-sid
rtrv-sik
rirv-stpopts
rtrv-tt

-

& Retrieve from STP

O Retrieve from Local Database

Reset | Retieve | | e | Load |

Close

RTRV-STP Command Retrieval Session

The FTRA retrieval session when rtrv-stp command is supported on EAGLE is
shown in Figures 108. If the command is not supported on EAGLE, an error will
be displayed and the retrieval session will be terminated (refer “STP data
modified through CLL.” on page 95).
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Figure 108.  Successful Retrieval Session for rtrv-stp command

=10{%]

it FTP-based Table Retrieve Application <EAGLE>

File Edit View Help
D Retrieve Tables Log e R S B D e U s e e B e e L e p e e |:|lr |'_'|‘
File

Processing Retrieve Request, Pl

uccessiul RTRW-STP Comimand.

Figure 109.  Rtrv-stp Command unsupported on EAGLE release

=]

j= FTP-based Table Retrieve Application <EAGLE>
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Command line interface

FTRA 4.0 supports modifying the STP Username and STP Password through the
CLI for an STP whose configuration already exists in the system. Using the CLI
the STP username and password can be modified in the system configuration
without interacting with the GUI. Figure 110 shows the FTRA command line
interface for modifying the STP Username and STP Password through the CLI for
an STP “EAGLE".

After successfully updating the STP parameters in the system configuration, a
message will be displayed as shown in the Figure 110.

Figure 110. = STP data modified through CLL

WINNT  system32'cmd.exe - ftra -c EAGLE eagle -

C:ssw_ftrasbindftra —c EAGLE eagle eaglel23

C:ssw_ftrasbin>C:\Progra™sdavasj2rel .4 .25%binNjava -Dftra2rootdir=Cisswu_ftra -Ds
shtoo ls.home=F:\subnittedssw_ftra —cp C:hsw_ftrasbhinnftra. jar;iC:hsw_ftraslibsssh
tools . jar;Cinsw_Ftraslibsapache—log4dj. jar;Cissw_ftraslibsjbel. jar; Coivsw_ftraslihb
nsunxml. jar;Civsw_ftraslibyjavaxml. jar com.tekelec.ftra.gui.InterfaceSelector -c
FAGLE eagle eaglel23

Data Modif ied for STP EAGLE

If the user supplied STP name doesn’t match with one of the existing STP(s)
configured in the system, an error message shall be displayed as shown in Figure
111 on page 96.
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Figure 111.  Invalid STP name

stem3d2'cmd.exe

C:nsw_ftrasbinXftra —c¢ EAGLE eagle eaglel2l

C:ssw_ftrasbin>CasProgra™lsJavasj2rel .4 .2%binNjava -DftraZrootdir=C:\sw_ftra —Ds
shtools.home=F:\subnitted\sw_ftra —cp C:\sw_ftrasbinnftra. jariC:\sw_ftraslibsssh
tools . jar;C:ssw_ftraslibhapache—log4j. jar;C:ssw_ftraslibsjbel. jar; Cissw_ftraslih
“gunxml. jar;C:ihnsw_ftraslibh\javaxml. jar com.tekelec.ftra.gui.InterfaceSelector -c

FAGLE eagle eaglel23

Mo such STP Mame found in the existing STP configuration.

C:\sw_ftrashind_

If the user supplies a wrong number of arguments through the command line
then the error message as shown in Figure 112 on page 96 is displayed.

Figure 112.  Invalid number of arguments.

C:nsw_ftrasbhin?>ftra —c¢ EAGLE eagle

C:\sw_ftrarbin>C=\Progra™isJavasj2rel .4.2 \bin\java -DftraZrootdir=C:\gw_ftra —Ds
shtools.home=F:\subnittedssw_ftra —cp CG:\sw_ftrasbinnftra.jar;C:nsw_ftraslibsssh
tools . jar;Cinsw_Ftraslibhapache—logdj. jar;Cissw_ftraslibsjbel. jar;Cissw_ftraslib

“sunxml. jar;Cinsw_ftraslibhjavaxml. jar com.tekelec.ftra.gui.InterfaceSelector —c
EAGLE eagle

Invalid number of arguments

C:\sw_ftra‘hin)

Version Information

FTRA Release 4.0 displays an “About FTRA” window. Figure 149 shows the new
FTRA Version string and updated copyright information.
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Figure 113.  About FTRA Display Window
x

A—— FTP-based Table Retrieve Application
W '_ FTRA Version 4.0-40.9.0

¢ c) Copyright 2006
r//“‘\\‘ tT-jltfalec =
TEKELEC hitpiivewrw tekelec.com
OK|
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SSH/SFTP Error Codes

Table 10 and Table 11 on page 113 contain a list of the error codes that can be
generated when making a secure connection between the FIRA, version 4.0, and
the EAGLE 5 ISS. Each error code contains a brief description of the error and the
suggested recovery action.

This section also contains procedures, following Tables 10 and 11, for testing
connectivity and network problems, and to verify that the setup for making
secure connections is correct.

If secure connections to the EAGLE 5 ISS cannot be made, verify that the Eagle
OA&M IP Security Enhancements feature is enabled and activated by entering
the rtrv-ctrl-feat command at the EAGLE 5 ISS before performing any of the
actions in Tables 10 and 11. If the Eagle OA&M IP Security Enhancements feature
is not enabled or activated, perform the “Activating the Eagle O&AM IP Security
Enhancements Controlled Feature” procedure in the Database Administration
Manual - System Management and enable and activate the Eagle OA&M IP Security
Enhancements feature.

If any of the errors shown in Table 10 or Table 11 on page 113 are encountered
after the recovery procedure is verified, contact the Customer Care Center. Refer
to page 4 for the contact information.

Table 10. FIP/SFIP/SSH Error Codes

SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
User Errors
594 Invalid Path Verify that the path is valid in the FTP
Server Configuration Menu window (see
Figure 35 on page 36).
598 The SSHD daemon is not Verify that the IP address exists on
running on the destination network with a ping (Refer to the
system or the server IP address | “Connectivity Test —1” section on page 116
unavailable. and the “Connectivity Test - II” section on

page 117). If the IP address exists on
network then verify that SSHD daemon is
running on the destination machine using
the ps -ef|grep sshd command.

629 The SFTP daemon is not Verify that the subsystem entry in the
running sshd_config file on the destination
station is specified and points to the SFTP
daemon.
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FTP/SFIP/SSH Error Codes (Continued)

SFTP/SSH
Generic
Network
Client Error
Code

Description

Action/Recovery

633 User login failure.

Verify that the Username and Password in
the STP Connection Configuration Menu
window, (see Table 2 on page 6) is valid
and an account exists for the username
and password on the SSHD server host.

SFTP Errors

595 File open failed.

Invalid file name in the download list, or
out of resources. Report this issue to the
Customer Care Center immediately. Refer
to page 4 for the contact information.

596 The file name is already

specified.

Report this issue to the Customer Care
Center immediately. (Internal SFTP
implementation error). Refer to page 4 for
the contact information.

SFTP Client Errors

597 SFTP client packet send failure

598 The SFTP connection is closed.

599 SFTP packet read failure

Perform these tests:
e “FIP Server Verification” on page 116

e “SFTP /SSHD Server Verification” on
page 116

e “Connectivity Test —1” on page 116
¢ “Connectivity Test - II” on page 117

¢ “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the
connection.

If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code

600 SFTP protocol error. The Verify that the SFTP/SSHD version is
received message is larger than | compatible with openSSH 3.0.2p1. Verify
the expected packet size. there is no network outage by performing

the tests in “Network Outage Trouble
Shooting” section on page 118. If the error
persists, report the issue to the Customer
Care Center. Refer to page 4 for the contact
information.

601 Undefined Notify the Customer Care Center. Refer to

page 4 for the contact information.

608 SFTP received a invalid ID in Verify that the SFTP/SSHD version is
the response received during a | compatible with openSSH 3.0.2p1. Verify
read operation on remote there is no network outage by performing
directory. the tests in “Network Outage Trouble

609 SETP: Handle mismatch error. Shoqting” section on page 118. If the error
This error is displaved when persists, report the issue to the Customer

play
there is a failure to receive an Care Ceqter. Refer to page 4 for the contact
information.
expected handle upon
successful READ/WRITE/
CREAT/TRUNC/EXCL of a file
using SSH_FXP_OPEN on
remote server.

610 Unexpected SSH2_FXP_ATTRS.

611 Unexpected SSH_FXP_NAME. | Verify that the SFTP/SSHD version is
SFIP using the compatible with openSSH 3.0.2p1. Verify
SSH_FXP_OPENDIR opens a there is no network outage by performing
directory for reading. The the tests in “Network Outage Trouble
server responds to this request | Shooting” section on page 118.
with either a SSH_FXP_NAME
or a SSH_FXP_STATUS
message. This error code
implies that an unexpected
SSH_FXP_NAME is received.
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FTP/SFTP/SSH Error Codes (Continued)

SFTP/SSH
Generic
Network
Client Error
Code

Description

Action/Recovery

612

The SFTP client uses the
SSH_FXP_REALPATH request
to have the server localize any
given path name to an absolute
path. This is useful for
converting path names
containing “..” components or
relative pathnames without a
leading slash into absolute
paths. This error implies that
there is a failure during this
operation

Check if the access to the path specified in

the FTP Server Configuration Menu
window (see Figure 35 on page 36) is
accessible and re-try the connection.

613

The SSH_FXP_READLINK
request is used by the SFIP
client to read the target of a
symbolic link. The server will
respond with a
SSH_FXP_NAME packet
containing only one name and a
dummy attributes value. The
name in the returned packet
contains the target of the link.
This failure implies that there is
a failure during the READLINK
operation.

614

The SFTP client receives
SSH_FXP_DATA as a response
to any file operations from the
server. This error implies that
the client received an
unexpected SSH_FXP_NAME
from the server.

615

The SFTP client received more
data than expected.

Verify that the SFTP/SSHD version is

compatible with openSSH 3.0.2p1. Verify

there is no network outage by perform
the tests in “Network Outage Trouble
Shooting” section on page 118.

ing

616

The SFTP client failed to read
the data from the file descriptor
of the file specified for transfer.

Report this issue to the Customer Care

Center immediately. Refer to page 4 for the

contact information.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
SSH Client Errors
617 Excessive identity files. This Report this issue to the Customer Care
error means that there are Center immediately. Refer to page 4 for the
excessive identity files. contact information.
OpenSSH implementation
contains the maximum of 100
identity files or the client
configuration file is corrupted.
624 The debug levels allowed for
SSH protocol in openSSH is 0-9.
There is either an error in the
client configuration file, or the
client configuration file is
corrupted.
625 Failure to read the client Report this issue to the Customer Care
configuration file. Center immediately. Refer to page 4 for the
626 Invalid compression level is contact information.
specified in the client
configuration file.
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Table 10. FTP/SFIP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code

627 SSH failure to setup the IO with | Verify that the SFTP/SSHD version is
the server. compatible with openSSH 3.0.2p1. Verify

628 SSH failure to open the channel :ﬁere {[S I}[O‘ network outage by performing
for the SSH connection with the | 7 ¢>¢ 15t
server. e “FIP Server Verification” on page 116

629 SSH failure to setup the channel | o “gpETp /SSHD Server Verification” on
for the SSH connection with the 116

page
server.

630 SSH failure to verify the SSH * “Connectivity Test ~1" on page 116
client host key. ¢ “Connectivity Test - II” on page 117

*  “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the

connection.

If the problem persists, report the issue to

the Customer Care Center. Refer to page 4

for the contact information.

631 SSH user authentication failure. | Report the issue to the Customer Care
Please verify that only the Center if the problem persists after the
password authentication is set | SSHD configuration file is verified. Refer
to “yes” in the SSH server to page 4 for the contact information.
configuration file. Refer to the
SSHD server configuration
provided by vendor of the
product. The FTRA and the
EAGLE 5 ISS is compatible with
openSSH 3.0.2p1.

632 The authentication method is Report this issue to the Customer Care
NULL in the client software. Center. Refer to page 4 for the contact
This error is a failure to set the |information.
null authentication method.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code

633 Permission is denied by the Verify that the SFTP/SSHD version is
server due to authentication compatible with openSSH 3.0.2p1. Verify
failure. there is no network outage by performing

640 A bad message was received these tests:
during the SSH authentication. e “FTIP Server Verification” on page 116

e “SFIP /SSHD Server Verification” on
page 116

¢ “Connectivity Test —1” on page 116

e “Connectivity Test - II” on page 117

*  “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the

connection.

If the problem persists, report the issue to

the Customer Care Center. Refer to page 4

for the contact information.

641 Missing authentication context, | Report this issue to the Customer Care
encountered during the SSH Center immediately. Refer to page 4 for the
user authorization. contact information.

642 Failure during the public key
read /verification operation.

643 Undefined SFIP/SSH error.
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Table 10.  FTP/SFIP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
644 Unexpected SSH_FXP_STATUS Verify that the SFTP/SSHD version
error. An invalid status was is compatible with openSSH
received by the SFTP server. 3.0.2p1. Verify there is no network
645 A bad option was specified in outage by performing these tests:
the SSH client on the EAGLE 5 “FTP Server Verification” on page
ISS. 116
646 An unsupported escape “SFTP /SSHD Server Verification”
character was used in the SSH on page 116
client on the EAGLE 5 ISS.
“Connectivity Test —1” on page 116
“Connectivity Test - II” on page 117
“Network Outage Trouble
Shooting” on page 118.
Make any fixes necessary and retry the
connection.
If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.
647 An unsupported cipher type Report this issue to the Customer Care
was used in the SSH clienton | Center immediately. Refer to page 4 for the
the EAGLE 5 ISS. contact information.
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Table 10.  FTP/SFIP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
648 Anunsupported MAC type was | Verify that the SFTP/SSHD version is
used in the SSH client on the compatible with openSSH 3.0.2p1. Verify
EAGLE 5 ISS. there is no network outage by performing
these tests:
e “FIP Server Verification” on page 116
e “SFTP /SSHD Server Verification” on
page 116
¢ “Connectivity Test —1” on page 116
e “Connectivity Test - II” on page 117
*  “Network Outage Trouble Shooting”
on page 118.
Make any fixes necessary and retry the
connection.
If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.
649 A bad port was used in the SSH | Report this issue to the Customer Care
client on the EAGLE 5 ISS. Center immediately. Refer to page 4 for the
656 Bad forwarding was used in the contact information.
SSH client on the EAGLE 5 ISS.
657 Bad forwarding ports were
specified in the SSH client on
the EAGLE 5 ISS.
658 A bad dynamic port was
specified in the SSH client on
the EAGLE 5 ISS.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
659 The host was not specified in Verify that the SFTP/SSHD version is

ISS.

the SSH client on the EAGLE 5

compatible with openSSH 3.0.2p1. Verify
there is no network outage by performing
these tests:

e “FIP Server Verification” on page 116

e “SFTP /SSHD Server Verification” on
page 116

¢ “Connectivity Test —1” on page 116
e “Connectivity Test - II” on page 117

¢ “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the
connection.

If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code

660 An invalid option or argument | Report this issue to the Customer Care
was specified in the SSH client | Center immediately. Refer to page 4 for the
on the EAGLE 5 ISS. contact information.

661 The hostname was not specified
in the SSH client on the EAGLE
5 ISS.

663 The SSH client was unable to
load the cipher type on the
EAGLE 5 ISS.

664 Asynchronous IO is not
supported on IPSM, SSH client
error.

665 Compression is already enabled
in the SSH client on the EAGLE
5ISS.

666 Unknown cipher number on the
SSH client on the EAGLE 5 ISS.

667 The SSH client key length is
invalid.

668 No key is available on the SSH | Report this issue to the Customer Care
client on the EAGLE 5 ISS. Center immediately. Refer to page 4 for the

contact information.
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Table 10.  FIP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
669 The secure connection was Verify that the SFTP/SSHD version is
closed by the remote server, compatible with openSSH 3.0.2p1. Verify
refer to the error on the there is no network outage by performing
SFTP/SSHD server side. these tests:
670 Connection failure due to e “FIP Server Verification” on page 116
network outage or the
connection was lost due to a e “SFIP /SSHD Server Verification” on
faulty SSHD/SFIP server or page 116
network. ¢ “Connectivity Test —1” on page 116
671 An unexpected packet typewas | =, .. ”
received from the SFTP /SSHD Connectivity Test - II” on page 117
server. *  “Network Outage Trouble Shooting”
672 A bad packet length was on page 118.
received from the SSHD/SFIP | nfake any fixes necessary and retry the
Server. connection.
If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.
673 A cryptographic attack was Report the issue to the Customer Care
detected by the SSH client. Center. Refer to page 4 for the contact
Please notify the local system information. This is not a software
administrator. problem but there is a security threat. The
keys/authentication may have to be
updated immediately.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)

SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
674 The SSH/SFTP client on the Verify that the SFTP/SSHD version is
EAGLE 5 ISS failed to read from | compatible with openSSH 3.0.2p1. Verify
the remote side. there is no network outage by performing
675 Corrupted check bytes were these tests:
detected on the SSH/SFTP e “FIP Server Verification” on page 116
client on the EAGLE 5 ISS.

e “SFTP /SSHD Server Verification” on
page 116

¢ “Connectivity Test —1” on page 116
e “Connectivity Test - II” on page 117

*  “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the
connection.

If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.

676 Corrupted MAC on input was | Verify that the sshtools.xml file provided
detected by the SSH/SFIP with FTRA software has the field as
client on the EAGLE 5 ISS. shown:

<!-- The Message Authentication Code
configuration, add or override default mac
implementations -->

<MacConfiguration>

<DefaultAlgorithm>hmac-md5</Default

Algorithm>
</MacConfiguration>
677 Corrupted pad on input was Report this issue to the Customer Care
detected by the SSH/SFIP Center immediately. Refer to page 4 for the
client on the EAGLE 5 ISS. contact information.
678 SSH/SFIP tried to close a
connection that is already
closed.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)

SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
679 The SSH/SFIP client on the Verify that the SFTP/SSHD version is
EAGLE 5 ISS failed to write to | compatible with openSSH 3.0.2p1. Verify
the remote side. there is no network outage by performing

these tests:
e “FIP Server Verification” on page 116

e “SFTP /SSHD Server Verification” on
page 116

¢ “Connectivity Test —1” on page 116
e “Connectivity Test - II” on page 117

*  “Network Outage Trouble Shooting”
on page 118.

Make any fixes necessary and retry the
connection.

If the problem persists, report the issue to
the Customer Care Center. Refer to page 4
for the contact information.

680 SSH/SFIP tried to set the Report this issue to the Customer Care
packet size twice. Center immediately. Refer to page 4 for the
681 A bad packet size was detected contact information.
by the SSH/SFIP client on the
EAGLE 5ISS.
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Table 10. FTP/SFTP/SSH Error Codes (Continued)
SFTP/SSH Description Action/Recovery
Generic
Network
Client Error
Code
SSH/SFTP Connection/Setup Errors
682 The connection timed out when | Verify that the SFTP/SSHD version is
SSH tried to connect to SSHD. | compatible with openSSH 3.0.2p1. Verify
633 The SSH connection was there is no network outage by performing
these tests:
refused by the remote server.
684 The SSHD server is e “FIP Server Verification” on page 116
unreachable. e “SFTP /SSHD Server Verification” on
685 The network has reset. page 116
686 The SSH/SFIP connection has | ® “Connectivity Test —I” on page 116
been aborted. o
e “Connectivity Test - II” on page 117
687 The SFTP/SSH connection has
been reset by the peer. *  “Network Outage Trouble Shooting”
on page 118.
688 Failed to allocate network
buffers. Make any fixes necessary and retry the
689 The SSH/SFIP socket is already connection.
connected. If the problem persists, report the issue to
690 The SSH/SFTP socket is not ’;he (}Zlustomer (;a;'e Cent'er. Refer to page 4
connected. or the contact information.
691 The network channel is down.
692 The SSHD/SFTP server
connection host is down.
693 SFIP client channel read failure.
694 SFIP client channel write
failure.
695 SFTP client channel open
failure.
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Table 11.  Generic Network Error Codes
SFTP/SSH/ Description Action/Recovery
Generic
Network
Client Error
Code
40 A destination address is required. Verify that there is an FTP server
entry on the EAGLE 5 ISS using the
rtrv-ftp-servcommand,andre-try
the connection
41 Protocol wrong type for socket Report this issue to the Customer
. - Care Center. Refer to page 4 for the
42 The protocol is not available. contact information.
43 The protocol is not supported.
44 The socket type is not supported.
45 The operation is not supported on the
socket.
46 The protocol family is not supported.
47 The address family is not supported.
48 The address is already in use.
49 The requested address cannot be
assigned.
50 Socket operation on non-socket
51 The network is unreachable. Verify that the connection tests and
. network outage numbers match as
52 The network dropped the connection | (o054 cea sections:
on reset.
¢ “Connectivity Test —I” on page
116
e “Connectivity Test - II” on page
117
¢ “Network Outage Trouble
Shooting” on page 118.
Make any fixes necessary and retry
the connection.
If the problem persists, report the
issue to the Customer Care Center.
Refer to page 4 for the contact
information.
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Table 11. Generic Network Error Codes (Continued)

SFTP/SSH/ Description Action/Recovery
Generic
Network

Client Error

Code
53 Software caused the connection to Report this issue to the Customer
abort. Care Center. Refer to page 4 for the
contact information.

54 The connection was reset by the peer. | Verify that the connection tests pass
and network outage numbers are
within the allowed limits as shown in
these sections:

e “Connectivity Test —I” on page
116

e “Connectivity Test - II” on page
117

¢ “Network Outage Trouble
Shooting” on page 118.

Make any fixes necessary and retry

the connection.

If the problem persists, report the

issue to the Customer Care Center.

Refer to page 4 for the contact

information.

55 No buffer space available. Report this issue to the Customer

- Care Center. Refer to page 4 for the

56 The socket is already connected. contact information.

57 The socket is not connected.

58 Can't send after socket shutdown

59 Too many references: can't splice

60 The connection timed out. Perform these tests and verify that the
FTP server address responds to the
ping command from the ISPM.
¢ “Connectivity Test —I” on page 116
¢ “Connectivity Test - II” on page 117

61 The connection was refused. Verify that there is a FTP server
daemon is running on the remote
station by performing the “FIP Server
Verification” test on page 116.
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Table 11. Generic Network Error Codes (Continued)
SFTP/SSH/ Description Action/Recovery
Generic
Network
Client Error
Code
62 The network is down. Verify that the connection tests pass
; and network outage numbers are
65 There is no route to the host. within the allowed limits as shown in
67 The host is down. these sections:
30 Read-only file system ¢ “Connectivity Test —I” on page
116
¢ “Connectivity Test - II” on page
117
¢ “Network Outage Trouble
Shooting” on page 118.
Make any fixes necessary and retry
the connection.
If the problem persists, report the
issue to the Customer Care Center.
Refer to page 4 for the contact
information.
32 Broken pipe Report the issue to the Customer Care
Center. Refer to page 4 for the contact
35 Unsupported value information.
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Troubleshooting Procedures

FIP Server Verification

Component: The FIP server IP address shown in the FTP Server Configuration
Menu window (see Figure 35 on page 36).

Supported Version/Specification: Any FTP server compliant with IETF RFC 959.

Test: On the Unix platform, execute the netstat -a|grep 21 command to verify
that the FTP server is running on the machine with the IP address shown in the
FTP Server Configuration Menu window (Figure 35 on page 36).

Expected Result:

Unix> netstat -a | grep 21

*.32821 LK 0 0 0 0 LISTEN

f5e15218 stream-ord f£5ee8880 0 /var/adm/atria/almd , The system and
process specific variable will change.

On the Windows platform, check the Task Manager to verify that the FTP daemon
is running.
SFTP /SSHD Server Verification

Component: The SSHD/SFIP server IP address shown in the FTP Server
Configuration Menu window (see Figure 35 on page 36).

Supported Version/Specification: Version compatible with openSSH 3.0.2p1.

Test: On the Unix platform, execute the ps -f|grep sshd command. Please refer
to Unix MAN pages for help with ps command.

On the Windows platform, use the Task Manager to verify that the sshd daemon
process in running.

Expected Result:
Unix> ps -ef|grep sshd
user 26912 26886 0 13:28:07 pts/5 0:00 grep sshd
root 411 1 0 Jul 24 ? 4:35 /usr/local/sbin/sshd Note: The

user/system/path variables depends on the server.

On the Windows platform, check the Task Manager to verify that the FIP daemon
is running.

Connectivity Test — 1
Component: Connectivity Test - I.

Supported Version/Specification: N/A
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Test: To verify that there is a network connection available between the EAGLE 5
ISS and the FTP/SFIP server shown in the FITP Server Configuration Menu
window (see Figure 35 on page 36).

On an EAGLE 5 ISS terminal, enter the pass: loc=xxxx:cmd="ping
yy.yy.yy.yy" command, where xxxx is location of IPSM associated with the IP
address entered in the STP Connection Configuration Menu window, (see Table
2 on page 6), and yy .yy .yy.yy is the IP address of the FIP/SFTP server shown in
the FTP Server Configuration Menu window (see Figure 35 on page 36).

Expected Result:
NOTE: TheRTTtimeand datasizesmayvary.

> pass:loc=xxxx:cmd="ping yy.yy.yy.yy"
Command Accepted - Processing
rlghncxaO3w 05-09-31 13:57:59 GMT EAGLE5 34.0.0

pass:loc=xxxx:cmd="ping yy.yy.yy.yy"
Command entered at terminal #5.

rlghncxaO3w 05-09-31 13:57:59 GMT EAGLE5 34.0.0
PASS: Command sent to card

rlghncxaO3w 05-09-31 13:57:59 GMT EAGLE5 34.0.0
PING command in progress

rlghncxaO3w 05-09-31 13:57:59 GMT EAGLE5 34.0.0

rlghncxaO3w 05-09-31 13:58:01 GMT EAGLE5 34.0.0

PING yy.yy.Yy.Yy: 56 data bytes

64 bytes from yy.yy.yy.yy: icmp_seg=0. time=10. ms

64 bytes from yy.yy.yy.yy: icmp_seg=1. time=5. ms

64 bytes from yy.yy.yy.yy: icmp_seg=2. time=5. ms
----yy.yy.yy.yy PING Statistics----

3 packets transmitted, 3 packets received, 0% packet loss
round-trip (ms) min/avg/max = 5/6/10

PING command complete

Connectivity Test - II
Component: Connectivity Test - I

Supported Version/Specification: N/A.

Test: To verify that there is a network connection available between the EAGLE 5
ISS and FTP/SFIP server shown in the FTP Server Configuration Menu window
(see Figure 35 on page 36).

Execute the ping -s zz.zz.zz.zz command on the FTP server machine where
zz.zz.2z.z2z is the IP address of the EAGLE 5 ISS shown in the STP Connection
Configuration Menu window (see Table 2 on page 6).

Expected Result:

ping -s zz.zz.zz.z2z

PING zz.zz.zz.zz: 56 data bytes

64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seg=0. time=5. ms
64 bytes from e1011501-3-a (zz.zz.zz.zz): icmp_seg=1. time=4. ms
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64 bytes from e1011501-3-a (zz.zz.zz.2z2Z):
64 bytes from e€1011501-3-a (zz.zz.zz.2z2Z):

----2z.27z.zz.zz PING Statistics----

4 packets transmitted, 4 packets received,

round-trip (ms) min/avg/max = 4/4/5

Network Outage Trouble Shooting

Component: Network Outage Troubleshooting

Supported Version/Specification: N/A.

icmp seg=2. time=5. ms
icmp seg=3. time=4. ms

0% packet loss

Test: To verify the TCP/IP traffic/network statistics are within the Tekelec

supported network statistics.

At the EAGLE 5 ISS, enter the pass:loc=xxxx:cmd="netstat -p tcp"
command at the EAGLE 5 ISS terminal, where xxxx is location of the IPSM
associated with the IP address entered in the STP Connection Configuration
Menu window, (see Table 2 on page 6), and analyze the data from output which is

similar to the following example output.

NOTE: The specific information for the command may vary depending

upon the system used.

> pass:loc=3102:cmd="netstat -p tcp"
Command Accepted - Processing

rlghncxaO3w 05-09-31 19:32:52 GMT EAGLE5 34.0.0

pass:loc=3102:cmd="netstat -p tcp"

Command entered at terminal #5.

rlghncxa0O3w 05-09-31 19:32:52 GMT EAGLE5 34.0.0

PASS: Command sent to card

rlghncxa0O3w 05-09-31 19:32:52 GMT EAGLE5 34.0.0

TCP:
161 packets sent

156 data packets (28411 bytes)
data packet (0 byte)
ack-only packets (1 delayed)

URG only packet
window probe packet

o O O Ul o

0 control packet
161 packets received

156 acks (for 28255 bytes)

duplicate ack+C2
ack for unsent data

out-of-order packet

window probe

O O O 0O O O o o o ul oo

window update packet

window update packet

packet received after close

discarded for bad checksum

discarded for bad header offset field

retransmitted

packets (9 bytes) received in-sequence
completely duplicate packet
packet with some dup. data

(0 byte)
(0 byte duped)

packet (0 byte) of data after window

0 discarded because packet too short

0 connection request
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Table 12.

connection accept
connection established (including accepts)
connection closed (including 0 drop)
0 embryonic connection dropped
156 segments updated rtt (of 157 attempts)
0 retransmit timeout
0 connection dropped by rexmit timeout
0 persist timeout
0 keepalive timeout
0 keepalive probe sent
0 connection dropped by keepalive
0 pcb cache lookup failed

or R

rlghncxa0O3w 05-09-31 19:32:52 GMT EAGLE5 34.0.0
NETSTAT command complete
Expected Result:
The network outage causes the TCP/IP problems like:
¢ Network latency
e Packet drop
¢ Duplicate packets.

If the TCP Packet Delay, TCP Packet Loss, TCP Packet Error, or TCP Out of Order
values are greater than the values shown in Table 12, fix the network problems
and retry the connection.

TCP Fault Tolerance Table for FIP /SFIP

Protocol Fault Threshold Value

SFTP/FTP TCP Packet Delay | 175 milliseconds

SFTP/ FTP | TCP Packet Loss 40% packet loss

SFTP/ FTP TCP Packet Errors 10%

SFTP/ FTP | TCP Out of Order | 30% of packets with offset of 30 packets

SSH/SFTP/SFTPD/SSHD Protocol Troubleshooting

For more information on SSH/SFIP/SFIPD/SSHD protocol troubleshooting,
refer to SSH, the Secure Shell: The Definitive Guide, First Edition, Barrett and
Silverman, O’Reilly, February 2001.
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.doc file extension 2-21, 2-60, 2-85, 2-90
.xt file extension 2-21, 2-60, 2-85, 2-90

30 - Read-only file system 2-115

32 - Broken pipe 2-115

35 - Unsupported value 2-115

40 - A destination address is required 2-113

41 - Protocol wrong type for socket 2-113

42 - The protocol is not available 2-113

43 - The protocol is not supported 2-113

44 - The socket type is not supported 2-113

45 - The operation is not supported on the
socket 2-113

46 - The protocol family is not supported
2-113

47 - The address family is not supported
2-113

48 - The address is already in use 2-113

49 - The requested address cannot be
assigned 2-113

50 - Socket operation on non-socket 2-113

51 - The network is unreachable 2-113

52 - The network dropped the connection on
reset 2-113

53 - Software caused the connection to abort
2-114

54 - The connection was reset by the peer
2-114

55 - No buffer space available 2-114

56 - The socket is already connected 2-114

569 - The file name is already specified 2-99

57 - The socket is not connected 2-114

58 - Can’t send after socket shutdown 2-114

59 - Too many references: can’t splice 2-114

595 - File open failed 2-99

597 - SFTP client packet send failure 2-99

598 - The SFTP connection is closed 2-99

599 - SFTP packet read failure 2-99

60 - The connection timed out 2-114

600 - SFTP protocol error 2-100
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601 - Undefined 2-100

608 - SFTP received a invalid ID in the
response received during a read
operation on remote directory 2-100

609 - SFTP: Handle mismatch error 2-100

61 - The connection was refused 2-114

610 - Unexpected SSH2_FXP_ATTRS 2-100

611 - Unexpected SSH_FXP_NAME 2-100

612 - SSH_FXP_REALPATH request failure
2-101

613 - SSH_FXP_READLINK request failure
2-101

614 - unexpected SSH_FXP_NAME 2-101

615 - The SFTP client received more data
than expected 2-101

616 - The SFTP client failed to read the data
from the file descriptor 2-101

617 - Excessive identity files 2-102

62 - The network is down 2-115

624 - The debug levels allowed for SSH
protocol in openSSH is 0-9 2-102

625 - Failure to read the client configuration
file 2-102

626 - Invalid compression level is specified in
the client configuration file 2-102

627 - SSH failure to setup the IO with the
server 2-103

628 - SSH failure to open the channel for the
SSH connection with the server
2-103

629 - SSH failure to setup the channel for the
SSH connection with the server
2-103

630 - SSH failure to verify the SSH client host
key 2-103

631 - SSH user authentication failure 2-103

632 - The authentication method is NULL in
the client software 2-103

633 - Permission is denied by the server due
to authentication failure 2-104

633 - User login failure 2-99
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640 - A bad message was received during the
SSH authentication 2-104

641 - Missing authentication context,
encountered during the SSH user
authorization 2-104

642 - Failure during the public key
read /verification operation 2-104

643 - Undefined SFTP/SSH error 2-104

644 - Unexpected SSH_FXP_STATUS error
2-105

645 - A bad option was specified in the SSH
client on the EAGLE 5 ISS 2-105

646 - An unsupported escape character was
used in the SSH client on the EAGLE
51SS 2-105

647 - An unsupported cipher type was used
in the SSH client on the EAGLE 5 ISS
2-105

648 - An unsupported MAC type was used in
the SSH client on the EAGLE 5 ISS
2-106

649 - A bad port was used in the SSH client
on the EAGLE 51SS 2-106

65 - There is no route to the host 2-115

656 - Bad forwarding was used in the SSH
client on the EAGLE 5 ISS 2-106

657 - Bad forwarding ports were specified in
the SSH client on the EAGLE 5 ISS
2-106

658 - A bad dynamic port was specified in
the SSH client on the EAGLE 5 ISS
2-106

659 - The host was not specified in the SSH
client on the EAGLE 5 ISS 2-107

660 - An invalid option or argument was
specified in the SSH client on the
EAGLE51SS 2-108

661 - The hostname was not specified in the
SSH client on the EAGLE 5ISS 2-108

663 - The SSH client was unable to load the
cipher type on the EAGLE 5 ISS
2-108

664 - Asynchronous IO is not supported on
IPSM, SSH client error 2-108

665 - Compression is already enabled in the
SSH client on the EAGLE 5ISS 2-108

666 - Unknown cipher number on the SSH
client on the EAGLE 5 ISS 2-108
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667 - The SSH client key length is invalid
2-108

668 - No key is available on the SSH client on
the EAGLE 5ISS 2-108

669 - The secure connection was closed by
the remote server 2-109

67 - The host is down 2-115

670 - Connection failure due to network
outage or the connection was lost due
to a faulty SSHD/SFTP server or
network 2-109

671 - An unexpected packet type was
received from the SFTP /SSHD server
2-109

672 - A bad packet length was received from
the SSHD/SFTP server 2-109

673 - A cryptographic attack was detected by
the SSH client 2-109

674 - The SSH/SFTP client on the EAGLE 5
ISS failed to read from the remote
side 2-110

675 - Corrupted check bytes were detected
on the SSH/SFTP client on the
EAGLE51ISS 2-110

676 - Corrupted MAC on input was detected
by the SSH/SFTP client on the
EAGLE51ISS 2-110

677 - Corrupted pad on input was detected
by the SSH/SFTP client on the
EAGLE51ISS 2-110

678 - SSH/SFTP tried to close a connection
that is already closed 2-110

679 - The SSH/SFTP client on the EAGLE 5
ISS failed to write to the remote side
2-111

680 - SSH/SFTP tried to set the packet size
twice 2-111

681 - A bad packet size was detected by the
SSH/SFTP client on the EAGLE 5 ISS
2-111

682 - The connection timed out when SSH
tried to connect to SSHD 2-112

683 - The SSH connection was refused by the
remote server 2-112

684 - The SSHD server is unreachable 2-112

685 - The network has reset 2-112

686 - The SSH/SFTP connection has been
aborted 2-112
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687 - The SFTP/SSH connection has been
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EAGLE 5 ISS - Error code 649 2-106
A cryptographic attack was detected by the
SSH client - Error code 673 2-109
A destination address is required - Error
code 40 2-113
About FTRA window 2-2, 2-92
Activating the Eagle OA&M IP Security
Enhancements Controlled Feature
procedure 2-7, 2-11, 2-24, 2-98
Add button 1-3, 2-6, 2-8, 2-12, 2-46
Retrieve Tables 2-41
Adding
Command to the Selected Commands
Box 2-47
Multiple Commands to the Selected
Commands Box 2-49
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Range of Commands to the Selected
Commands Box 2-48
STP Configuration Record 2-8, 2-34
Adding an STP Configuration Record
FTRA 2.0 2-8, 29, 2-10, 2-11, 2-12
alw-card command 2-29
An invalid option or argument was specified
in the SSH client on the EAGLE 5 ISS
- Error code 660 2-108
An unexpected packet type was received
from the SFTP/SSHD server - Error
code 671 2-109
An unsupported cipher type was used in the
SSH client on the EAGLE 5 ISS - Error
code 647 2-105
An unsupported escape character was used
in the SSH client on the EAGLE 5 ISS
- Error code 646 2-105
An unsupported MAC type was used in the
SSH client on the EAGLE 5 ISS - Error
code 648 2-106
Application, FTRA
exiting 2-3
Asynchronous IO is not supported on IPSM,
SSH client error - Error code 664
2-108

B
Backup IP Address - FTRA 2.0 2-9
Backup IP Address - FTRA 2.0 or greater 2-6
Backup IP Address Field - FTRA 2.0 or
greater 2-6, 2-9
Bad forwarding ports were specified in the
SSH client on the EAGLE 5 ISS - Error
code 657 2-106
Bad forwarding was used in the SSH client
on the EAGLE 5 ISS - Error code 656
2-106
Box
Command List 2-40, 2-41, 2-42, 2-44, 2-49
Secure Connection - FTRA 2.0 or greater
2-7, 2-11, 2-24, 2-29, 2-34, 2-35
Selected Commands 2-40, 2-41, 2-42,
2-46, 2-49, 2-51
Adding a Command 2-47
Adding a Range of Commands 2-48
Adding Multiple Commands 2-49
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Command Removed 2-50
Command Selected to be Removed
2-50
Stop on error
Update Tables 2-71
Stop on error, Update Tables window
2-69, 2-71, 2-80, 2-81, 2-82
Use STP and FTP UserNames, Passwords
for all STPs 2-7, 2-8, 2-23, 2-24
Broken pipe - Error code 32 2-115
Browse button
FTP Server Configuration Menu 2-36,
2-37
Update Tables 2-69
Button
Add 1-3, 2-6, 2-8, 2-12, 2-41, 2-46
Browse
FTP Server Configuration Menu
2-36, 2-37
Update Tables window 2-69
Cancel 2-20
Print window
Retrieve Tables Log 2-59
System Log 2-89
Update Tables Log 2-85
Save window
Retrieve Tables Log 2-60
System Log 2-91
Update Tables Log 2-86
Select Starting Directory window
2-38
Select window 2-70
Close 2-7,2-14, 2-36
Retrieve Tables 2-42
Update Tables 2-69
Commit, Update Validation Complete
window 2-73, 2-74
Delete 2-7, 2-14, 2-26
Edit, Update Validation Complete
window 2-73, 2-74, 2-75, 2-76
Load 2-42, 2-51, 2-61
Modify 2-6, 2-23
Refresh 2-6, 2-13, 2-14, 2-15, 2-25
Remove 2-42, 2-49
Reset 2-42, 2-49
Retrieve 2-40, 2-42, 2-51, 2-52
Retrieve from Local Database 2-40, 2-42,
2-51

Index-4

Retrieve from STP 2-40, 2-42, 2-52
Save
Retrieve Tables Log 2-60
System Log 2-90
Update Tables Log 2-85
Select 2-6, 2-14
Select Starting Directory window
2-38
Select window 2-70
Set 2-38
FTP Server Configuration Menu 2-36
Stop, Update Validation Complete
window 2-73
Store 2-42, 2-51, 2-61
Test 2-6, 2-14, 2-17
Validate 2-69, 2-71, 2-72
Update Tables window 2-68

C
Can’t send after socket shutdown - Error
code 58 2-114
Cancel button 2-20
Print window
Retrieve Tables Log 2-59
System Log 2-89
Update Tables Log window 2-85
Save window
Retrieve Tables Log 2-60
System Log 2-91
Update Tables Log 2-86
Select Starting Directory window 2-38
Select window 2-70
chg-ftp-serv EAGLE 5 ISS command 2-36
chg-trm command 2-32
chg-trm:trm=:all=no EAGLE 5ISS command
2-52
chmod command 2-36, 2-37
Clearing the display
Connectivity Test Log 2-18, 2-19
Retrieve Tables Log 2-56, 2-57
System Log 2-87, 2-88
Update Tables Log 2-82, 2-83
Close button
FTP Connection Configuration Menu
2-36
Retrieve Tables window 2-42
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STP Connection Configuration Menu
2-7,2-14
Update Tables 2-69
Closing
Connectivity Test Log window 2-18, 2-22
Retrieve Tables Log window 2-56, 2-60
System Log window 2-87, 2-91
Update Tables Log window 2-82, 2-86
Command
EAGLE 5 ISS
alw-card 2-29
chg-ftp-serv 2-36
chg-trm 2-32
chg-trm:trm=:all=no 2-52
ent-ftp-serv 2-36
init-card 2-29, 2-32, 2-33
pass:loc=xxxx
cmd="netstat -p tcp" 2-118
cmd="ping yy.yy.yy.yy" 2-117
rst-card 2-29
rtrv 2-42, 2-61, 2-66
rtrv-ctrl-feat 2-7, 2-11, 2-24, 2-98
rtrv-feat 2-40
rtrv-ftp-serv 2-113
rtrv-gta 2-40, 2-45, 2-52
rtrv-gtt 2-40, 2-45, 2-52
rtrv-gttsel 2-40, 2-45, 2-52
rtrv-gttset 2-40, 2-45, 2-52
rtrv-ip-Ink 2-32, 2-33
rtrv-secu-dflt 2-10
rtrv-stp 2-54, 2-56
rtrv-trm 2-31, 2-32, 2-52
rtrv-tt 2-40, 2-45, 2-52
FTRA
ftra -c 2-61, 2-66
Selecting 2-44
Command Complete
Connectivity Test window 2-18
Retrieve Tables window 2-40, 2-53, 2-54
Update Tables window 2-73, 2-74, 2-77
Command File
Editing 1-2, 2-75
Editor window 2-73, 2-75, 2-76, 2-77

File Menu 2-77

File Menu 2-77
Invalid Command 2-76
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Field, Update Tables window 2-69, 2-70,
2-72
Selected, Update Tables window
Stop on error box checked 2-71
Sending to the Selected STP 2-74
Command In progress, Cannot Close
Window message 2-76
Command Line Interface 1-2, 2-42, 2-51,
2-61
Automatic Start 2-66
Manual Start 2-61
UNIX 2-63
Windows 2-62
Command List
Box 2-40, 2-41, 2-42, 2-44, 2-49
Field
Retrieve Tables window 2-41
Update Tables window 2-69
Side 2-49
command prompt
DOS 2-61
shell 2-61
Command Removed from the Selected
Commands Box 2-50
Command Selected to be Removed in the
Selected Commands Box 2-50
Commands
EAGLE5ISS 1-2, 2-68, 2-69
EGTT
rtrv-gta 2-40, 2-45, 2-52
rtrv-gttsel 2-40, 2-45, 2-52
rtrv-gttset 2-40, 2-45, 2-52
GTIT
rtrv-gtt 2-40, 2-45, 2-52
rtrv-tt 2-40, 2-45, 2-52
Menu 2-2
Menu window 2-42, 2-51, 2-69
Selecting a Range 2-45
Selecting Multiple 2-46
Commit button, Update Validation
Complete window 2-73, 2-74
Compression is already enabled in the SSH
client on the EAGLE 5 ISS - Error
code 665 2-108
Configuration record, STP 2-5, 2-6, 2-7, 2-8,
2-13, 2-14, 2-15, 2-16, 2-17, 2-23, 2-24,
2-25, 2-26, 2-27, 2-28, 2-29, 2-34
FTRA 2.0 2-15, 2-16
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Configuration record, STP - FTRA 2.0
Adding 2-8, 2-9, 2-10, 2-11, 2-12
Connection failure due to network outage or
the connection was lost due to a
faulty SSHD /SFTP server or network
- Error code 670 2-109
Connectivity Test - I procedure 2-116
Connectivity Test - I procedure 2-117
Connectivity Test Log 2-17, 2-18, 2-19, 2-20
Clearing the Display 2-18, 2-19
closing 2-18, 2-22
File Menu 2-18
Print window 2-19, 2-20
Printing 2-18, 2-19
Save window 2-20
saved file confirmation window 2-21
saving to a file 2-18, 2-20
window 2-17, 2-18, 2-19, 2-20, 2-22, 2-30,
2-33, 2-34
errors 2-18
no errors 2-17
Connectivity Test Log window
File Menu 2-18, 2-19
copyright information 2-92
Corrupted check bytes were detected on the
SSH /SFTP client on the EAGLE 5 ISS
- Error code 675 2-110
Corrupted MAC on input was detected by
the SSH/SFTP client on the EAGLE 5
ISS - Error code 676 2-110
Corrupted pad on input was detected by the
SSH/SFTP client on the EAGLE 5 ISS
- Error code 677 2-110
cron 2-61, 2-66, 2-67
CSV file format 1-2, 2-40, 2-42, 2-51, 2-61,
2-66
Current STP
Selected 2-27
FTRA 2.0 2-28
Selected: field 2-25
Selecting 2-27
Customer Care Center 1-4, 2-32, 2-98, 2-99,
2-100, 2-101, 2-102, 2-103, 2-104,
2-105, 2-106, 2-107, 2-108, 2-109,
2-110, 2-111, 2-112, 2-113, 2-114,
2-115

Index-6

D
Database Administration Manual - System
Management 2-7, 2-11, 2-24, 2-98
Database, STP Connection Configuration
2-5, 2-6, 2-7, 2-8, 2-12, 2-26
Delete button 2-7, 2-14, 2-26
Delete STP Data window 2-26
Deleting an STP Configuration Record 2-26
Description
Retrieve Tables window 2-41
Update Tables window 2-69
Display
Clearing
Connectivity Test Log 2-18, 2-19
Retrieve Tables Log 2-56, 2-57
System Log 2-87, 2-88
Update Tables Log 2-82, 2-83
Displaying an Existing STP Configuration
Record 2-13
DOS command prompt 2-61
Drop down list
STP Name 2-6, 2-13
FTRA 2.0 2-13, 2-14
DSA Key Fingerprint 2-32, 2-33
Duplicate packets 2-119

E
EAGLE 5 1SS
Telnet terminals 2-6, 2-32, 2-52
UIM - Unsolicited Information Message
2-32, 2-33, 2-52
EAGLE 5 ISS chg-ftp-serv command 2-36
EAGLESISS chg-trm:trm=:all=no command
2-52
EAGLE 5 ISS command
alw-card 2-29
chg-ftp-serv 2-36
chg-trm 2-32
chg-trm:trm=:all=no 2-52
ent-ftp-serv 2-36
init-card 2-29, 2-32, 2-33
pass:loc=xxxx
cmd="netstat -p tcp" 2-118
cmd="ping yy.yy.yy.yy" 2-117
rst-card 2-29
rtrv 2-42, 2-61, 2-66
rtrv-ctrl-feat 2-7, 2-11, 2-24, 2-98
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rtrv-feat 2-40
rtrv-ftp-serv 2-113
rtrv-gta 2-40, 2-45, 2-52
rtrv-gtt 2-40, 2-45, 2-52
rtrv-gttsel 2-40, 2-45, 2-52
rtrv-gttset 2-40, 2-45, 2-52
rtrv-ip-Ink 2-32, 2-33
rtrv-secu-dflt 2-10
rtrv-stp 2-54, 2-56
rtrv-trm 2-31, 2-32, 2-52
rtrv-tt 2-40, 2-45, 2-52
EAGLE 5 ISS commands 1-2, 2-68, 2-69
EAGLE 5 ISS EGTT commands
rtrv-gta 2-40, 2-45, 2-52
rtrv-gttsel 2-40, 2-45, 2-52
rtrv-gttset 2-40, 2-45, 2-52
EAGLE 5 ISS ent-ftp-serv command 2-36
EAGLE 5 ISS Feature
EGTT 2-40
GTT 2-40
EAGLE 5 ISS feature
Eagle OA&M IP Security Enhancements
2-7, 2-11, 2-12, 2-24, 2-98
EAGLE 5 ISS GTT commands
rtrv-gtt 2-40, 2-45, 2-52
rtrv-tt 2-40, 2-45, 2-52
EAGLE 5 ISS Manual, Database
Administration Manual - System
Management 2-7, 2-11, 2-24, 2-98
EAGLE 5 ISS pass:loc=xxxx
cmd="netstat -p tcp" command 2-118

cmd="ping yy.yy.yy.yy" command 2-117

EAGLE 5 ISS procedure
Activating the Eagle OA&M IP Security

Enhancements Controlled Feature
2-7, 2-11, 2-24, 2-98

EAGLE 5 ISS Public Host Key Fingerprint
2-29, 2-30, 2-32, 2-34

EAGLE 5 ISS Public Key Fingerprint 2-7,
2-32, 2-33

EAGLE 5 ISS release 30.2 or greater 2-7, 2-11

EAGLE 5 ISS rtrv-ctrl-feat command 2-7,
2-11, 2-24, 2-98

EAGLE 5 ISS rtrv-feat command 2-40

EAGLE 5 ISS rtrv-ftp-serv command 2-113

EAGLE 5 ISS rtrv-gta command 2-40, 2-45,
2-52

909-4919-001 Rev B, April 2007

EAGLE 5 ISS rtrv-gtt command 2-40, 2-45,
2-52
EAGLE 5 ISS rtrv-gttsel command 2-40,
2-45, 2-52
EAGLE 5 ISS rtrv-gttset command 2-40,
2-45, 2-52
EAGLE 5 ISS rtrv-secu-dflt command 2-10
EAGLE 5 ISS rtrv-stp command 2-54, 2-56
EAGLE 5 ISS rtrv-trm command 2-52
EAGLE 5 ISS rtrv-tt command 2-40, 2-45,
2-52
Eagle OA&M IP Security Enhancements
feature 2-7, 2-11, 2-12, 2-24, 2-98
Edit button, Update Validation Complete
window 2-73, 2-74, 2-75, 2-76
Edit menu
FTP-Based Table Retrieve Application
2-5, 2-69
Editing a Command File 2-75
EGTT commands
EAGLE 51ISS
rtrv-gta 2-40, 2-45, 2-52
rtrv-gttsel 2-40, 2-45, 2-52
rtrv-gttset 2-40, 2-45, 2-52
EGTT Feature 2-40
Emergency response 1-5
Entering an STP Name 2-14
ent-ftp-serv EAGLE 5 ISS command 2-36
Environment variable
FTRA_HOME 1-3
JRE_HOME 1-3
Error code
30 - Read-only file system 2-115
32 - Broken pipe 2-115
35 - Unsupported value 2-115
40 - A destination address is required
2-113
41 - Protocol wrong type for socket 2-113
42 - The protocol is not available 2-113
43 - The protocol is not supported 2-113
44 - The socket type is not supported
2-113
45 - The operation is not supported on the
socket 2-113
46 - The protocol family is not supported
2-113
47 - The address family is not supported
2-113
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48 - The address is already in use 2-113

49 - The requested address cannot be
assigned 2-113

50 - Socket operation on non-socket 2-113

51 - The network is unreachable 2-113

52 - The network dropped the connection
onreset 2-113

53 - Software caused the connection to
abort 2-114

54 - The connection was reset by the peer
2-114

55 - No buffer space available 2-114

56 - The socket is already connected 2-114

57 - The socket is not connected 2-114

58 - Can't send after socket shutdown
2-114

59 - Too many references: can’t splice
2-114

595 - File open failed 2-99

596 - The file name is already specified
2-99

597 - SFTP client packet send failure 2-99

598 - The SFTP connection is closed 2-99

599 - SFTP packet read failure 2-99

60 - The connection timed out 2-114

600 - SFTP protocol error 2-100

601 - Undefined 2-100

608 - SFTP received a invalid ID in the
response received during a read
operation on remote directory 2-100

609 - SFTP: Handle mismatch error 2-100

61 - The connection was refused 2-114

610 - Unexpected SSH2_FXP_ATTRS
2-100

611 - Unexpected SSH_FXP_NAME
2-100

612 - SSH_FXP_REALPATH request
failure 2-101

613 - SSH_FXP_READLINK request
failure 2-101

614 - unexpected SSH_FXP_NAME 2-101

615 - The SFTP client received more data
than expected 2-101

616 - The SFTP client failed to read the
data from the file descriptor 2-101

617 - Excessive identity files 2-102

62 - The network is down 2-115

Index-8

624 - The debug levels allowed for SSH
protocol in openSSH is 0-9 2-102

625 - Failure to read the client
configuration file 2-102

626 - Invalid compression level is
specified in the client configuration
file 2-102

627 - SSH failure to setup the IO with the
server 2-103

628 - SSH failure to open the channel for
the SSH connection with the server
2-103

629 - SSH failure to setup the channel for
the SSH connection with the server
2-103

630 - SSH failure to verify the SSH client
host key 2-103

631 - SSH user authentication failure
2-103

632 - The authentication method is NULL
in the client software 2-103

633 - Permission is denied by the server
due to authentication failure 2-104

633 - User login failure 2-99

640 - A bad message was received during
the SSH authentication 2-104

641 - Missing authentication context,
encountered during the SSH user
authorization 2-104

642 - Failure during the public key
read /verification operation 2-104

643 - Undefined SFTP/SSH error 2-104

644 - Unexpected SSH_FXP_STATUS
error 2-105

645 - A bad option was specified in the
SSH client on the EAGLE 5ISS 2-105

646 - An unsupported escape character
was used in the SSH client on the
EAGLE51ISS 2-105

647 - An unsupported cipher type was
used in the SSH client on the EAGLE
51SS 2-105

648 - An unsupported MAC type was
used in the SSH client on the EAGLE
51ISS 2-106

649 - A bad port was used in the SSH
client on the EAGLE 5 ISS 2-106

65 - There is no route to the host 2-115
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656 - Bad forwarding was used in the SSH
client on the EAGLE 5 ISS 2-106

657 - Bad forwarding ports were specified
in the SSH client on the EAGLE 5 ISS
2-106

658 - A bad dynamic port was specified in
the SSH client on the EAGLE 5 ISS
2-106

659 - The host was not specified in the
SSH client on the EAGLE 5 ISS 2-107

660 - An invalid option or argument was
specified in the SSH client on the
EAGLE51SS 2-108

661 - The hostname was not specified in
the SSH client on the EAGLE 5 ISS
2-108

663 - The SSH client was unable to load
the cipher type on the EAGLE 5 ISS
2-108

664 - Asynchronous IO is not supported
on IPSM, SSH client error 2-108

665 - Compression is already enabled in
the SSH client on the EAGLE 5 ISS
2-108

666 - Unknown cipher number on the SSH
client on the EAGLE 5 ISS 2-108

667 - The SSH client key length is invalid
2-108

668 - No key is available on the SSH client
on the EAGLE 51SS 2-108

669 - The secure connection was closed by
the remote server 2-109

67 - The host is down 2-115

670 - Connection failure due to network
outage or the connection was lost due
to a faulty SSHD/SFTP server or
network 2-109

671 - An unexpected packet type was
received from the SFTP /SSHD server
2-109

672 - A bad packet length was received
from the SSHD/SFTP server 2-109

673 - A cryptographic attack was detected
by the SSH client 2-109

674 - The SSH/SFTP client on the EAGLE
5 ISS failed to read from the remote
side 2-110
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675 - Corrupted check bytes were
detected on the SSH/SFTP client on
the EAGLE51ISS 2-110

676 - Corrupted MAC on input was
detected by the SSH/SFTP client on
the EAGLE 51SS 2-110

677 - Corrupted pad on input was
detected by the SSH/SFTP client on
the EAGLE51ISS 2-110

678 - SSH/SFTP tried to close a
connection that is already closed
2-110

679 - The SSH /SFTP client on the EAGLE
51SS failed to write to the remote side
2-111

680 - SSH/SFTP tried to set the packet size
twice 2-111

681 - A bad packet size was detected by
the SSH/SFTP client on the EAGLE 5
ISS 2-111

682 - The connection timed out when SSH
tried to connect to SSHD 2-112

683 - The SSH connection was refused by
the remote server 2-112

684 - The SSHD server is unreachable
2-112

685 - The network has reset 2-112

686 - The SSH/SFTP connection has been
aborted 2-112

687 - The SFTP /SSH connection has been
reset by the peer 2-112

688 - Failed to allocate network buffers
2-112

689 - The SSH/SFTP socket is already
connected 2-112

690 - The SSH/SFTP socket is not
connected 2-112

691 - The network channel is down 2-112

692 - The SSHD/SFTP server connection
host is down 2-112

693 - SFTP client channel read failure
2-112

694 - SFTP client channel write failure
2-112

695 - SFTP client channel open failure
2-112

Error Codes

FIP 2-98
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Generic Network 2-113
SFTP 2-98
SSH 2-98
Error message
STP Name does not exist 2-16
Errors
SFTP 2-99
SFTP Client 2-99
SSH Client 2-102
SSH/SFTP Connection/Setup 2-112
Errors - contacting the Customer Care Center
1-4, 2-32, 2-98, 2-99, 2-100, 2-101,
2-102, 2-103, 2-104, 2-105, 2-106,
2-107, 2-108, 2-109, 2-110, 2-111,
2-112, 2-113, 2-114, 2-115
Excessive identity files - Error code 617
2-102
Exit Confirmation window 2-3
Exit menu 2-2
Exit window 2-3, 2-4
Exiting the FTRA application 2-3

F
Failed to allocate network buffers - Error
code 688 2-112
Failure during the public key
read /verification operation - Error
code 642 2-104
Failure to read the client configuration file -
Error code 625 2-102
Feature
Eagle OA&M IP Security Enhancements
2-7,2-11, 2-12, 2-24, 2-98
EGTT 2-40
GTT 2-40
Field
Command File, Update Tables window
2-69, 2-70, 2-72
Command List
Retrieve Tables 2-41
Update Tables 2-69
Current STP Selected: 2-25
File Name: 2-38
Select Starting Directory window
2-38
Select window 2-70
Files of type:

Index-10

Select Starting Directory window
2-38
Select window 2-70
FTP Password 2-6, 2-11
FTP UserName 2-6, 2-11
IP Address 2-36
Backup - FTRA 2.0 or greater 2-6, 2-9
Primary - FTRA 2.0 or greater 2-6,

2-9
Look in:
Select Staring Directory window
2-38
Select window 2-70
Path 2-36
Selected Commands, Retrieve Tables
2-41
STP Name 2-6, 2-8, 2-13, 2-14
STP name typed

FTRA 2.0 2-14, 2-15
STP Password 2-6, 2-10
STP UserName 2-6, 2-10
Subpath 2-36
file extension
.doc 2-21, 2-60, 2-85, 2-90
txt 2-21, 2-60, 2-85, 2-90
File format
CSV 1-2, 2-40, 2-42, 2-51, 2-61, 2-66
File menu
Command File Editor window 2-77
Connectivity Test Log 2-18, 2-19
FTP-Based Table Retrieve Application
window 2-3
Retrieve Tables Log 2-56, 2-57
System Log 2-87, 2-88
Update Tables Log 2-82, 2-83
File Name: Field
Select Starting Directory window 2-38
Select window 2-70
File open failed - Error code 595 2-99
Files of type: Field
Select Starting Directory window 2-38
Select window 2-70
Fingerprint
Key
DSA 2-32, 2-33
Public Host Key
EAGLE51SS 2-29, 2-30, 2-32, 2-34
Public Key
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EAGLE5ISS 2-7, 2-32, 2-33
flag - strict host key 2-30
FTP Error Codes 2-98
FTP Password Field 2-6, 2-11
FTP server 2-35, 2-116
secure 2-35
FTP Server Configuration 1-2, 2-35
Menu 2-2, 2-35
Browse button 2-36, 2-37
Close button 2-36
IP Address 2-35, 2-116
IP Address Field 2-36
Path Field 2-36
Set button 2-36, 2-38
Subpath Field 2-36
Menu window 2-11, 2-35, 2-36, 2-98,
2-101, 2-116, 2-117
FTP Server Data Set window 2-39
FTP Server Verification procedure 2-116
FTP UserName Field 2-6, 2-11
FTP-Based Table Retrieve Application
Edit Menu 2-5, 2-35, 2-69
File Menu 2-3
Help Menu 2-92
View Menu 2-58, 2-83, 2-88
window 2-2, 2-8, 2-17, 2-23, 2-26, 2-43,
2-57,2-58, 2-59, 2-69, 2-83, 2-84, 2-85,
2-88, 2-89, 2-90, 2-92
File menu 2-3
FTRA
Command
ftra -c 2-61, 2-66
Initialization 2-2
STP IP connection
secure 2-7, 2-11
version level 2-92
FTRA 2.0
Current STP Selected 2-28
FTP Server 2-35
Secure FTP Server 2-35
STP Configuration Record 2-15, 2-16
Adding 2-8, 2-9, 2-10, 2-11, 2-12
STP Connection Configuration
Menu window 2-35
STP Connection Configuration Menu
Backup IP Address 2-6
Backup IP Address Field 2-9
IP Address
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Backup 2-6, 2-9
Primary 2-6, 2-9
Primary IP Address 2-6
Primary IP Address Field 2-9
Secure Connection Box 2-7, 2-11,
2-24,2-29, 2-34, 2-35
STP Name drop down list 2-13, 2-14
STP name typed 2-14, 2-15
FTRA application
exiting 2-3
ftra -c command 2-61, 2-66
ftra file 2-30
FITRA icon 2-2
FTRA window
GTT Warning window 2-40
Retrieve Tables 2-40, 2-41, 2-43, 2-44,
2-61
description 2-41
GTT Warning window 2-40
Update Tables 2-68, 2-69, 2-70, 2-71,
2-76, 2-77, 2-80, 2-81, 2-82
description 2-69
Select, description 2-70
Update Validation Complete
2-73, 2-74
Update Validation Complete with er-
rors 2-74

2-72,

ftra.bat 2-30
FTRA_HOME environment variable 1-3

G

Generic Network Error Codes 2-113

GTT commands

EAGLE 5 ISS

rtrv-gtt 2-40, 2-45, 2-52
rtrv-tt 2-40, 2-45, 2-52

GTT Feature 2-40

GTT Warning window 2-40

H
Help menu
FTP-Based Table Retrieve Application
2-92
hexadecimal 2-32
Host Key - Secure EAGLE 5 ISS
Provisioning 2-29
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host key checking - strict 2-30
Host Key Fingerprint
Public
EAGLE 5 ISS 2-29, 2-30, 2-32, 2-34
host key flag - strict 2-30
hosts.xml 2-29, 2-30, 2-32, 2-33, 2-34

|

Icon, FTRA 2-2

init-card command 2-29, 2-32, 2-33

Initializing the FTRA 2-2

Initializing window 2-2

Invalid compression level is specified in the
client configuration file - Error code

626 2-102

Invalid FTP Password warning window
2-11

Invalid FTP User Name warning window
2-11

Invalid IP Address warning window 2-9,
2-10, 2-36, 2-37

Invalid STP Name Error Message window
2-8

Invalid STP Name warning window 2-8
Invalid STP Password warning window
2-10
Invalid STP User Name warning window
2-10
IP Address 2-6, 2-35, 2-116, 2-117, 2-118
Backup - FTRA 2.0 2-9
Backup - FTRA 2.0 or greater 2-6
IPSM 2-32, 2-33
Primary - FTRA 2.0 2-9
Primary - FITRA 2.0 or greater 2-6
IP address 2-6
IP Address Field 2-36
Backup - FTRA 2.0 or greater 2-6, 2-9
Primary - FITRA 2.0 or greater 2-6, 2-9
IP Address warning message 2-29
IP connection
FTRA and STP
secure 2-7, 2-11
IPSM 2-29, 2-31, 2-32, 2-33, 2-117, 2-118
IPSM IP Address 2-32, 2-33

J
JRE_HOME environment variable 1-3
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K
Key Fingerprint

DSA 2-32, 2-33

Public

EAGLE 51ISS 2-7, 2-32, 2-33

L
Load button 2-42, 2-51, 2-61
Log

Connectivity Test 2-17, 2-18, 2-19, 2-20
window, File Menu 2-18, 2-19
Retrieve Tables 2-2, 2-40, 2-53, 2-54, 2-56,
2-58, 2-59
window, File Menu 2-56, 2-57
System 2-2, 2-87, 2-88, 2-89, 2-90, 2-91
closing 2-87, 2-91
window 2-87, 2-88, 2-89, 2-90, 2-91
File menu 2-87, 2-88
Update Tables 2-2, 2-68, 2-69, 2-71, 2-72,
2-73,2-74,2-77,2-78, 2-79, 2-80, 2-81,
2-82, 2-83, 2-84, 2-85
window 2-71, 2-72, 2-78, 2-82, 2-83,
2-84, 2-85, 2-86
Commit Command Completed
2-78
File Menu 2-82, 2-83
Look in: Field
Select Starting Directory window 2-38
Select window 2-70

M
manual
admonishments 1-3
Menu
Commands 2-2
Connectivity Test Log
File 2-18
Edit
FTP-Based Table Retrieve Applica-
tion 2-5, 2-69
Exit 2-2
File

Command File Editor window 2-77

Connectivity Test Log window 2-18,
2-19

FTP-Based Table Retrieve Applica-
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tion window 2-3
Retrieve Tables Log window 2-56,
2-57
System Log window 2-87, 2-88
Update Tables Log window 2-82,
2-83
FTP Server Configuration 2-2, 2-35
Browse button 2-36, 2-37
Set button 2-36
FTP-Based Table Retrieve Application
2-35
Help
FTP-Based Table Retrieve Applica-
tion 2-92
Retrieve Tables Log
File 2-56
STP Connection Configuration 2-2, 2-5
View
FTP-Based Table Retrieve Applica-
tion 2-58, 2-83, 2-88
Message
Command In Progress, Cannot Close
Window 2-76
IP Address warning 2-29
Must Enter Command Script File Name
2-72
Processing Validate Request, Please Wait
2-71, 2-78
Update Tables processing completed
without errors 2-77
Missing authentication context, encountered
during the SSH user authorization -
Error code 641 2-104
Modify button 2-6, 2-23
Modify Warning window 2-25
Modifying an Existing STP Configuration
Record 2-23, 2-29, 2-34
Must Enter Command Script File Name
message 2-72

N

netstat -a |l grep 21 2-116

Network latency 2-119

No buffer space available - Error code 55
2-114

No key is available on the SSH client on the
EAGLE 5 ISS - Error code 668 2-108
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(o)

openSSH 3.0.2p1 2-100, 2-101, 2-103, 2-104,
2-105, 2-106, 2-107, 2-109, 2-110,
2-111, 2-112, 2-116

P
Packet drop 2-119
pass:loc=xxxx
cmd="netstat -p tcp" EAGLE 5 ISS
command 2-118
cmd="ping yy.yy.yy.yy" EAGLE 5 ISS
command 2-117
Path Field 2-36
path parameter 2-36
Permission is denied by the server due to
authentication failure - Error code
633 2-104
ping -s zz.zz.zz.zz command 2-117
Primary IP Address - FTRA 2.0 2-9
Primary IP Address - FTRA 2.0 or greater 2-6
Primary IP Address Field - FTRA 2.0 or
greater 2-6, 2-9
Print window
Cancel button
Update Tables Log 2-85
Connectivity Test Log 2-19, 2-20
Retrieve Tables Log 2-58, 2-59
System Log 2-89
Update Tables Log 2-84
Printing
Connectivity Test Log 2-18, 2-19
Retrieve Tables Log 2-56, 2-58
System Log 2-87, 2-89
Update Tables Log 2-82, 2-84
Problems - contacting the Customer Care
Center 1-4, 2-32, 2-98, 2-99, 2-100,
2-101, 2-102, 2-103, 2-104, 2-105,
2-106, 2-107, 2-108, 2-109, 2-110,
2-111, 2-112, 2-113, 2-114, 2-115
Procedure
Activating the Eagle OA&M IP Security
Enhancements Controlled Feature
2-7, 2-11, 2-24, 2-98
Connectivity Test -1 2-116
Connectivity Test - II 2-117
FTP Server Verification 2-116
SFTP Server Verification 2-116
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SSHD Server Verification 2-116
Processing Retrieve Request
Update Tables Log window 2-72
Processing Validate Request, Please Wait
message 2-71, 2-78
Protocol Troubleshooting 2-119
Protocol wrong type for socket - Error code
41 2-113
Provisioning the Secure EAGLE 5 ISS Host
Key 2-29
ps 2-116
ps -ef | grep sshd 2-98
ps -fl grep sshd 2-116
Public Host Key Fingerprint
EAGLE 5 ISS 2-29, 2-30, 2-32, 2-34
Public Key Fingerprint
EAGLE5ISS 2-7, 2-32, 2-33

R
Read-only file system - Error code 30 2-115
Record, STP configuration 2-5
Refresh button 2-6, 2-13, 2-14, 2-15, 2-25
release 30.2 or greater - EAGLE 5 ISS 2-7,
2-11
Release Not Compatible Error - Retrieve
Tables Log window 2-43
Remove button 2-42, 2-49
Reset button 2-42, 2-49
Retrieve button 2-40, 2-42, 2-51, 2-52
Retrieve Database Tables from an STP 2-40
Retrieve from Local Database button 2-40,
2-42, 2-51
Retrieve from STP button 2-40, 2-42, 2-52
Retrieve Tables
Command List Box 2-40, 2-41, 2-42, 2-44,
2-49
Selected Commands Box 2-40, 2-41, 2-42,
2-46, 2-49, 2-51
Retrieve Tables Log 2-2, 2-40, 2-53, 2-54,
2-56, 2-58, 2-59
Clearing the Display 2-56, 2-57
closing 2-56, 2-60
File Menu 2-56
Print window 2-58, 2-59
Printing 2-56, 2-58
Save window 2-59, 2-60
saved file confirmation window 2-60
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saving to a file 2-56, 2-59
Retrieve Tables Log window 2-52, 2-54,
2-56, 2-57, 2-58, 2-59, 2-60
File Menu 2-56, 2-57
Processing Retrieve Request 2-53
Release Not Compatible Error 2-43
with Errors 2-55
with the RTRV-STP Command 2-56
without Errors 2-55
Retrieve Tables window 2-40, 2-41, 2-43,
2-44, 2-61
Add button 2-41, 2-46
Close button 2-42
description 2-41
GTT Warning window 2-40
Load button 2-42, 2-51, 2-61
Remove button 2-42, 2-49
Reset button 2-42, 2-49
Retrieve button 2-40, 2-42, 2-51, 2-52
Retrieve from Local Database button
2-40, 2-42, 2-51
Retrieve from STP button 2-40, 2-42, 2-52
Store button 2-42, 2-51, 2-61
Retrieving EAGLE 5 ISS database tables 1-2
rst-card command 2-29
rtrv commands 2-42, 2-61, 2-66
rtrv-ctrl-feat EAGLE 5 ISS command 2-7,
2-11, 2-24, 2-98
rtrv-feat EAGLE 5 ISS command 2-40
rtrv-ftp-serv EAGLE 5 ISS command 2-113
rtrv-gta EAGLE 5 ISS command 2-40, 2-45,
2-52
rtrv-gtt EAGLE 5 ISS command 2-40, 2-45,
2-52
rtrv-gttsel EAGLE 5 ISS command 2-40,
2-45, 2-52
rtrv-gttset EAGLE 5 ISS command  2-40,
2-45, 2-52
rtrv-ip-Ink command 2-32, 2-33
rtrv-secu-dflt EAGLE 5 ISS command 2-10
rtrv-stp EAGLE 5 ISS command 2-54, 2-56
rtrv-trm command 2-31, 2-32
rtrv-trm EAGLE 5 ISS command 2-52
rtrv-tt EAGLE 5 ISS command 2-40, 2-45,
2-52

909-4919-001 Rev B, April 2007


Molly
Rectangle


S

Save button
Retrieve Tables Log
Save window 2-60
System Log Save window 2-90
Update Tables Log Save window 2-85
Save window
Cancel button
System Log 2-91
Update Tables Log 2-86
Connectivity Test Log 2-20
Retrieve Tables Log 2-59, 2-60
System Log 2-90, 2-91
Update Tables Log 2-85, 2-86
Saved File Confirmation window
Connectivity Test Log 2-21
Retrieve Tables Log 2-60
System Log 2-90, 2-91
Update Tables Log 2-85, 2-86
Saving to a file
Connectivity Test Log 2-18, 2-20
Retrieve Tables Log 2-56, 2-59
System Log 2-87, 2-90
Update Tables Log 2-82, 2-85
secure connection 2-7, 2-29
Secure Connection Box - FTRA 2.0 or greater
2-7,2-11, 2-24, 2-29, 2-34, 2-35
Secure EAGLE 5 ISS Host Key Provisioning
2-29
Secure FTP server 2-35
Secure Host Key - EAGLE 5 ISS
Provisioning 2-29
secure IP connection between FTRA and STP
2-7,2-11
Security Administration 2-32
Select button 2-6, 2-14
Select Starting Directory window 2-38
Select window 2-70
Select Starting Directory window 2-36, 2-37,
2-38
Cancel button 2-38
Select button 2-38
Select window
Cancel button 2-70
description 2-70
Select button 2-70
Update Tables 2-68, 2-69, 2-70
Selected Commands
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Box 2-40, 2-41, 2-42, 2-46, 2-49, 2-51
Adding a Command 2-47
Adding a Range of Commands 2-48
Adding Multiple Commands 2-49
Command Selected Removed 2-50
Command Selected to be Removed
2-50
Field, Retrieve Tables window 2-41
Selected STP 1-2, 2-27, 2-40, 2-41, 2-42, 2-51,
2-52, 2-68, 2-69, 2-73, 2-74, 2-75, 2-77
Sending a Command File 2-74
Selecting
Command 2-44
Current STP 2-27
Multiple Commands 2-46
Range of Commands 2-45
Sending a Command File to the Selected STP
2-74
Server
FTP - FTRA 2.0 2-35
Secure FTP - FTRA 2.0 2-35
Set button 2-38
FTP Server Configuration Menu 2-36
SFTP client channel open failure - Error code
695 2-112
SFTP client channel read failure - Error code
693 2-112
SFTP client channel write failure - Error code
694 2-112
SFTP Client Errors 2-99
SFTP client packet send failure - Error code
597 2-99
SFTP Connection Errors 2-112
SFTP Error Codes 2-98
SFTP Errors 2-99
SFTP packet read failure - Error code 599
2-99
SFTP protocol error - Error code 600 2-100
SFTP received a invalid ID in the response
received during a read operation on
remote directory - Error code 608
2-100
SFTP Server 2-109, 2-112, 2-116
SFTP Server Verification procedure 2-116
SFTP Setup Errors 2-112
SFTP/SSH Error Codes 2-98
SFTP: Handle mismatch error - Error code
609 2-100
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Shell command prompt 2-61
Socket operation on non-socket - Error code
50 2-113
Software caused the connection to abort -
Error code 53 2-114
SSH Client Errors 2-102
SSH Connection Errors 2-112
SSH Error Codes 2-98
SSH failure to open the channel for the SSH
connection with the server - Error
code 628 2-103
SSH failure to setup the channel for the SSH
connection with the server - Error
code 629 2-103
SSH failure to setup the IO with the server -
Error code 627 2-103
SSH failure to verify the SSH client host key
- Error code 630 2-103
SSH Setup Errors 2-112
SSH user authentication failure - Error code
631 2-103
SSH, the Secure Shell: The Definitive Guide
2-119
SSH/SFTP Error Codes 2-98
SSH /SFTP tried to close a connection that is
already closed - Error code 678 2-110
SSH/SFTP tried to set the packet size twice -
Error code 680 2-111
SSH_FXP_READLINK request failure - Error
code 613 2-101
SSH_FXP_REALPATH request failure -
Error code 612 2-101
SSHD Server 2-109, 2-112, 2-116
SSHD Server Verification procedure 2-116
sshtools.xml 2-110
Stop button, Update Validation Complete
window 2-73
Stop on error box
Update Tables window 2-69, 2-71, 2-80,
2-81, 2-82
Stop on error box Checked
Command File Selected
Update Tables window 2-71
Stop Without Sending or Editing a
Command File 2-75
Store button 2-42, 2-51, 2-61
STP
FTRA IP connection
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secure 2-7,2-11
Retrieve Database Tables 2-40
STP Added window 2-12
STP Configuration Record 2-5, 2-6, 2-7, 2-8,
2-13, 2-14, 2-15, 2-16, 2-17, 2-23, 2-24,
2-25, 2-26, 2-27, 2-28, 2-29, 2-34
Adding 2-8, 2-34
Deleting 2-26
Displaying 2-13
FTRA 2.0 2-15, 2-16
Modifying 2-23, 2-29, 2-34
testing 2-17
STP Configuration Record - FTRA 2.0
Adding 2-8, 2-9, 2-10, 2-11, 2-12
STP Connection Configuration 1-2
Database 2-5, 2-6, 2-7, 2-8, 2-12, 2-26
Menu 2-2, 2-5
Menu window 2-5, 2-6, 2-7, 2-8, 2-13,
2-14,2-17,2-23, 2-25, 2-26, 2-27, 2-99,
2-117, 2-118
FTRA 2.0 2-35
FTRA 2.0 or greater 2-5
STP Connection Configuration Menu
Add button 1-3, 2-6, 2-8, 2-12
Close button 2-7, 2-14
Delete button 2-7, 2-14, 2-26
FTP Password Field 2-6, 2-11
FTP UserName Field 2-6, 2-11
IP Address 2-117, 2-118
Backup - FTRA 2.0 2-9
Backup - FTRA 2.0 or greater 2-6
Primary - FTRA 2.0 2-9
Primary - FTRA 2.0 or greater 2-6
IP Address Field
Backup - FTRA 2.0 or greater 2-6, 2-9
Primary - FTRA 2.0 or greater 2-6,
2-9
Modify button 2-6, 2-23
Refresh button 2-6, 2-13, 2-14, 2-15, 2-25
Secure Connection Box - FTRA 2.0 or
greater 2-7, 2-11, 2-24, 2-29, 2-34,
2-35
Select button 2-6, 2-14
STP Name drop down list 2-6, 2-13
FTRA 2.0 2-13, 2-14
STP Name Field 2-6, 2-8, 2-13, 2-14
STP name typed
FTRA 2.0 2-14, 2-15
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STP Password Field 2-6, 2-10
STP UserName Field 2-6, 2-10
Test button 2-6, 2-14, 2-17
Use STP and FTP UserNames, Passwords
for all STPs Box 2-7, 2-8, 2-23, 2-24
STP Connectivity Test 1-2
STP Data Modified window 2-23, 2-25
STP Name 2-6, 2-7, 2-8, 2-12, 2-13, 2-14,
2-16, 2-23, 2-26, 2-27, 2-28
entering 2-14
STP Name does not exist error message 2-16
STP Name drop down list 2-6, 2-13
FTRA 2.0 2-13, 2-14
STP Name Field 2-6, 2-8, 2-13, 2-14
STP name typed
FTRA 2.0 2-14, 2-15
STP Password Field 2-6, 2-10
STP Selection Change window 2-6, 2-27,
2-28
STP UserName Field 2-6, 2-10
strict host key checking 2-30
strict host key flag 2-30
Subpath Field 2-36
Support - contacting the Customer Care
Center 1-4, 2-32, 2-98, 2-99, 2-100,
2-101, 2-102, 2-103, 2-104, 2-105,
2-106, 2-107, 2-108, 2-109, 2-110,
2-111, 2-112, 2-113, 2-114, 2-115
System Log 2-2, 2-87, 2-88, 2-89, 2-90, 2-91
Clearing the Display 2-87, 2-88
closing 2-87, 2-91
Print window 2-89
Printing 2-87, 2-89
Save window 2-90, 2-91
saved file confirmation window 2-90,
2-91
saving to a file 2-87, 2-90
System Log window 2-87, 2-88, 2-89, 2-90,
291
Cancel button 2-89
File menu 2-87, 2-88

T
Task Scheduler
Windows 2-61, 2-66
TCP Out of Order 2-119
TCP Packet Delay 2-119
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TCP Packet Error 2-119

TCP Packet Errors 2-119

TCP Packet Loss 2-119

Technical Assistance - contacting the
Customer Care Center 1-4, 2-32,
2-98, 2-99, 2-100, 2-101, 2-102, 2-103,
2-104, 2-105, 2-106, 2-107, 2-108,
2-109, 2-110, 2-111, 2-112, 2-113,
2-114, 2-115

telnet server 2-29

Telnet terminals 2-6, 2-32, 2-52

Terminals

EAGLE 5 ISS

Telnet 2-6, 2-32, 2-52

Test button 2-6, 2-14, 2-17

Testing an STP Configuration Record 2-17

The address family is not supported - Error
code 47 2-113

The address is already in use - Error code 48
2-113

The authentication method is NULL in the
client software - Error code 632 2-103

The connection timed out - Error code 60
2-114

The connection timed out when SSH tried to
connect to SSHD - Error code 682
2-112

The connection was refused - Error code 61
2-114

The connection was reset by the peer - Error
code 54 2-114

The debuglevels allowed for SSH protocol in
openSSH is 0-9 - Error code 624 2-102

The file name is already specified - Error
code 596 2-99

The host is down - Error code 67 2-115

The host was not specified in the SSH client
on the EAGLE 5 ISS - Error code 659
2-107

The hostname was not specified in the SSH
client on the EAGLE 5 ISS - Error
code 661 2-108

The network channel is down - Error code
691 2-112

The network dropped the connection on
reset - Error code 52 2-113

The network has reset - Error code 685 2-112

The network is down - Error code 62 2-115
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The network is unreachable - Error code 51
2-113

The operation is not supported on the socket
- Error code 45 2-113

The protocol family is not supported - Error
code 46 2-113

The protocol is not available - Error code 42
2-113

The protocol is not supported - Error code
431 2-113

The requested address cannot be assigned -
Error code 49 2-113

The secure connection was closed by the
remote server - Error code 669 2-109

The SFTP client failed to read the data from
the file descriptor - Error code 616
2-101

The SFTP client received more data than
expected - Error code 615 2-101

The SFTP connection is closed - Error code
598 2-99

The SFTP/SSH connection has been reset by
the peer - Error code 687 2-112

The socket is already connected - Error code
56 2-114

The socket is not connected - Error code 57
2-114

The socket type is not supported - Error code
44 2-113

The SSH client key length is invalid - Error
code 667 2-108

The SSH client was unable to load the cipher
type on the EAGLE 5 ISS - Error code
663 2-108

The SSH connection was refused by the
remote server - Error code 683 2-112

The SSH/SFTP client on the EAGLE 5 ISS
failed to read from the remote side -
Error code 674 2-110

The SSH/SFTP client on the EAGLE 5 ISS
failed to write to the remote side -
Error code 679 2-111

The SSH/SFTP connection has been aborted
- Error code 686 2-112

The SSH/SFTP socket is already connected -
Error code 689 2-112

The SSH/SFTP socket is not connected -
Error code 690 2-112
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The SSHD server is unreachable - Error code
684 2-112

The SSHD /SFTP server connection host is
down - Error code 692 2-112

There is no route to the host - Error code 65
2-115

Too many references: can’t splice - Error
code 59 2-114

Troubleshooting Procedures 2-116

U
UIM - Unsolicited Information Message
EAGLE51ISS 2-32, 2-33, 2-52
UIM 1493 2-32, 2-33
UIM 1494 2-32, 2-33
Undefined - Error code 601 2-100
Undefined SFTP/SSH error - Error code 643
2-104
Unexpected SSH_FXP_NAME - Error code
611 2-100
unexpected SSH_FXP_NAME - Error code
614 2-101
Unexpected SSH_FXP_STATUS error - Error
code 644 2-105
Unexpected SSH2_FXP_ATTRS - Error code
610 2-100
Unknown cipher number on the SSH client
on the EAGLE 5 ISS - Error code 666
2-108
Unsupported value - Error code 35 2-115
Update Tables Log 2-2, 2-68, 2-69, 2-71,
2-72,2-73,2-74,2-77,2-78, 2-79, 2-80,
2-81, 2-82, 2-83, 2-84, 2-85
Clearing the Display 2-82, 2-83
closing 2-82, 2-86
Print window 2-84
Printing 2-82, 2-84
Save window 2-85, 2-86
saved file confirmation window 2-85,
2-86
saving to a file 2-82, 2-85
Update Tables Log window 2-71, 2-72, 2-78,
2-82, 2-83, 2-84, 2-85, 2-86
Commit Command Completed 2-78
File Menu 2-82
File menu 2-82, 2-83
Processing Retrieve Request 2-72
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Update Tables processing completed
without errors message 2-77
Update Tables window 2-68, 2-69, 2-70,
2-71, 2-76, 2-77, 2-80, 2-81, 2-82
Browse button 2-69
Close button 2-69
Command File field 2-69, 2-70, 2-72
Command File Selected
Stop on error box Checked 2-71
description 2-69
Select window, description 2-70
Update Validation Complete Window
Update Tables
Update Validation
2-72, 2-73, 2-74
Update Validation Complete window
2-68, 2-73, 2-75, 2-76
with errors Window
Update Tables
Update Validation Complete
with errors 2-74
Validate button 2-68, 2-69, 2-71, 2-72
Update Validation Complete window 2-68,
2-72, 2-73, 2-74, 2-75, 2-76
description 2-73
with errors 2-74
without errors 2-74
Updating Database Tables in the Selected
STP 2-68
Use STP and FTP UserNames, Passwords for
all STPs Box 2-7, 2-8, 2-23, 2-24
User login failure - Error code 633 2-99

Complete

\'}
Validate button
Update Tables 2-69, 2-71, 2-72
Update Tables window 2-68
Validating command files 1-2
Variable
environment
FTRA_HOME 1-3
JRE_HOME 1-3
Version level 2-92
View menu
FTP-Based Table Retrieve Application
2-58, 2-83, 2-88
Viewing log files 1-2
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w
Window
About FTRA 2-2, 2-92
Command Complete Connectivity Test
2-18
Command File Editor 2-73, 2-75, 2-76,
2-77
File Menu 2-77
Invalid Command 2-76
Command File Editor window
File Menu 2-77
Commands Menu 2-42, 2-51, 2-69
Connectivity Test Log 2-17, 2-18, 2-19,
2-20, 2-22, 2-30, 2-33, 2-34
closing 2-18, 2-22
File Menu 2-18, 2-19
Print 2-19, 2-20
Save 2-20
Saved file confirmation 2-21
with errors 2-18
with no errors 2-17
Exit 2-3, 2-4
Exit Confirmation 2-3
FTP Server Configuration Menu 2-11,
2-35, 2-36, 2-98, 2-101, 2-116, 2-117
FTP Server Data Set 2-39
FTP-Based Table Retrieve Application
2-2,2-8, 2-17, 2-23, 2-26, 2-43, 2-57,
2-58, 2-59, 2-69, 2-83, 2-84, 2-85, 2-88,
2-89, 2-90, 2-92
GTT Warning 2-40
Initializing 2-2
Invalid FTP Password warning 2-11
Invalid FTP User Name warning 2-11
Invalid IP Address warning 2-9, 2-10,
2-36, 2-37
Invalid STP Name Error Message 2-8
Invalid STP Name warning 2-8
Invalid STP Password warning 2-10
Invalid STP User Name warning 2-10
Modify Warning 2-25
Print
Retrieve Tables Log 2-59
Update Tables Log 2-85
Retrieve Tables 2-40, 2-41, 2-43, 2-44,
2-61
Add button 2-41, 2-46
Close button 2-42
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Command Complete 2-40, 2-53, 2-54
Command List Field 2-41
description 2-41

GTT Warning 2-40

Load button 2-42, 2-51, 2-61
Remove button 2-42, 2-49

Reset button 2-42, 2-49

Retrieve button 2-40, 2-42, 2-51, 2-52

Retrieve from Local Database button

2-40, 2-42, 2-51
Retrieve from STP button 2-40, 2-42,
2-52
Selected Commands Field 2-41
Store button 2-42, 2-51, 2-61
Retrieve Tables Log 2-52, 2-54, 2-56, 2-57,
2-58, 2-59, 2-60
closing 2-56, 2-60
File Menu 2-56, 2-57
Print 2-58, 2-59
Processing Retrieve Request 2-53
Release Not Compatible Error 2-43
Save 2-59, 2-60
Saved file confirmation 2-60
with Errors 2-55
with the RTRV-STP Command 2-56
without Errors 2-55
Save
Retrieve Tables window 2-60
Select
File Name: Field 2-70
Files of type: Field 2-70
Look in: Field 2-70
Update Tables 2-68, 2-69, 2-70
Select Starting Directory 2-36, 2-37, 2-38
File Name: Field 2-38
Files of type: Field 2-38
Look in: Field 2-38
Select, description 2-70
STP Added 2-12
STP Connection Configuration Menu
2-5, 2-6, 2-7, 2-8, 2-13, 2-14, 2-17,
2-23, 2-25, 2-26, 2-27, 2-99, 2-117,
2-118
FTRA 2.0 2-35
FTRA 2.0 or greater 2-5
STP Data Deleted 2-26
STP Data Modified 2-23, 2-25
STP Selection Change 2-6, 2-27, 2-28
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System Log 2-87, 2-88, 2-89, 2-90, 2-91

closing 2-87, 2-91

File Menu 2-87, 2-88

Print 2-89

Print window

Cancel button 2-89

Save 2-90, 2-91

Saved file confirmation 2-90, 2-91
Update Tables 2-68, 2-69, 2-70, 2-71,

2-76, 2-77, 2-80, 2-81, 2-82

Browse button 2-69

Close button 2-69

Command Complete 2-73, 2-74, 2-77

Command File field 2-69, 2-70, 2-72

Command List Field 2-69

description 2-69

Select, description 2-70

Stop on error box 2-69, 2-71, 2-80,

2-81, 2-82

Update Validation Complete 2-73

Validate button 2-68, 2-69, 2-71, 2-72
Update Tables Log 2-71, 2-72, 2-78, 2-82,

2-83, 2-84, 2-85, 2-86

closing 2-82, 2-86

Commit Command Completed 2-78

File Menu 2-82, 2-83

Print 2-84

Processing Retrieve Request 2-72

Save 2-85, 2-86

Saved file confirmation 2-85, 2-86
Update Validation Complete 2-68, 2-72,

2-73, 2-74, 2-75, 2-76

Commit button 2-73, 2-74

description 2-73

Edit button 2-73, 2-74, 2-75, 2-76

Stop button 2-73

with errors 2-74

without errors 2-74

Windows Task Scheduler 2-61, 2-66
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