8 Submitting Batch Versions

This chapter contains the following topics:

8.1 Understanding Batch Version Submission

You can submit batch versions from the following Oracle JD Edwards EnterpriseOne locations:

  • The JD Edwards EnterpriseOne Batch Versions (P98305) Windows client or P98305W web-client application.

    • Select Batch Versions from the Report Management (GH9111) menu.

    • Select Report Versions from the Tools menu in JD Edwards Solution Explorer.

  • The EnterpriseOne Menu.

  • From a report located on the Report menu within an application.

  • From another batch version using report interconnects.

Before you can process batch versions on the enterprise server, you must ensure that:

  • The associated batch applications are checked in and have been deployed to the enterprise server.

  • The batch version specifications reside on the enterprise server.

When you use report interconnects, you must ensure that all associated batch applications and batch versions reside on the enterprise server prior to processing. If you need to copy batch version specifications to the enterprise server, ensure that the associated batch application already resides on that server.

See "Understanding Logic and Processing," "Working with Report Interconnects" in the JD Edwards EnterpriseOne Tools Report Design Aid Guide.

When a batch version exists only on the workstation, you must first submit the version specifications to the server where the associated report specifications reside. You can accomplish this by selecting the Submit Version Specifications Only option on the Advanced Version Prompting form.

When you modify a batch version and run the modified version on the workstation, the local modified version specifications run. If you want to run the modified version on the enterprise server, you need to submit the version specifications to the server.

See Copying Batch Version Specifications to an Enterprise Server.

When you submit batch versions, you can modify the data selection and data sequencing, and select from advanced functions. You can also:

  • View the report on screen.

  • Send the report to a printer.

  • Export the report to a CSV file.

  • Export the report to another software program using OSA (output stream access).

8.1.1 Data Selection and Data Sequencing

Data selection and data sequencing values are stored in JD Edwards EnterpriseOne Report Design Aid (RDA) specification (RDASPEC) files, which can exist on the client as well as on the server. In Terminal Server environments, multiple users share the same set of client RDASPEC files, so changes made to the specifications by one user are immediately visible to all other users of the same terminal server.

When you submit a batch version, you can modify the data selection and data sequencing from the Version Prompting form. Any modifications that you make to the batch version from this form affect the current submission only. Values that you enter during submission are used for processing, but are not saved and are not seen during the next report submission. If no prompting occurs, the values that exist locally at submission time are used by the system during processing. Values that you enter in Version List or in RDA are saved in the RDASPEC files.

This table provides some data selection and data sequencing scenarios:

Scenario Description
Batch versions submitted locally from the Microsoft Windows client. You might be prompted for data selection and data sequencing. The values that you specify during prompting are retained in memory, but are not saved to the local RDASPEC files. The values in memory are then passed along to the job as it processes. If you are not prompted for data selection and data sequencing, the job loads data selection and data sequence values from the local RDASPEC files at runtime.
Batch versions submitted on the server from the Microsoft Windows client. The system copies the data selection and data sequencing specifications related to the version into packed files and sends them to the server. When the job processes on the server, the system merges the packed files into the specifications on the server, which are then used to run the job.

If you are prompted for data selection and data sequencing during submission, the values retained in memory are copied into the packed files instead of the corresponding RDASPEC information. The system then uses the data selection and data sequencing values that you enter at submission when the job executes.

Batch versions submitted from the web client. You can override data selection and data sequencing at runtime. You also have the option of defining data selection and data sequencing from the Row menu.

Note:

When you define data selection and data sequencing outside of RDA, either at runtime or from the Work With Batch Versions-Available Versions form, the definition only affects the first level-one section of the report template. If you have other level-one sections in the report template that need to use the same data selection and data sequencing as the first level-one section, you must define these sections to adopt the settings from the first level-one section. You can accomplish this by calling system functions in event rules on the additional level-one sections.

Data selection uses Boolean logic to determine which records to include in the report. Boolean logic uses operators such as And and Or.

Use And to include only the data that two or more fields in a record have in common. For example, suppose you need a list of customers who are located in New York City. You might use the two fields Location and Search Type in the criteria:

Search Type = C (customer)

And

Location = New York

Use Or logic to include all records that meet one of the sets of criteria. For example, if you need to find any New York City record or any customer record, you would indicate the same information for Location and Search Type using these criteria:

Search Type = C (customer)

Or

Location = New York

The Section Data Sequencing form that you see at runtime is slightly different from the one that you see in RDA. You can still see the Columns Available on the left and the Columns Sorted on the right. The form also indicates the sort order of ascending or descending and whether page breaks are set. You can modify both the sort order and the page break options on this form.

8.1.2 Processing Options

Processing option values are stored in the Versions List (F983051) table for each batch version. This table is centrally located and can be accessed by all JD Edwards EnterpriseOne users within a specific environment. Jobs running on client machines and jobs running on servers all access the same table.

Processing option values that you enter during submission are used at runtime. If prompting is not available, values that exist at submission are used at runtime. Values that you enter during submission are saved in the Versions List table and are displayed the next time that you submit that version. When another user runs the same batch version, the processing option values defined by the previous user display. You can, however, override the processing options for the submission or you can create a new version that includes the processing option values that meet your business requirements. If you define the processing options for a version to execute as a blind execution, the processing option template does not display at submission and other users cannot modify the values.

This table provides some data selection and data sequencing scenarios:

Scenario Description
Batch versions submitted locally. During submission of a batch version, you might be prompted for processing option values. The system stores the processing option values that you specify in the Versions List table. When the job is executed, the system retrieves the processing option values from this table.
Batch versions submitted on the server. The submission process begins in the same way as when a batch version is submitted locally. However, the system sends this job and the associated processing option values to the server. On the server, the system stores the processing option values in the Job Control Status Master (F986110) table. When the job is executed, the system retrieves the processing option values from the Job Control Status Master table instead of the Versions List table.

8.1.3 Advanced Option Overrides

Advanced options enable you to override the processing location and use a variety of logging features. You can select from these advanced options when submitting batch versions:

  • Override Location.

  • Logging (JDE.log).

  • Tracing (JDEDEBUG.log).

  • Override Job Queue.

  • UBE Logging Level.

  • Submit Version Specifications Only.

Note:

For advanced options that apply to BI Publisher for JD Edwards EnterpriseOne functionality, see JD Edwards EnterpriseOne Tools BI Publisher for JD Edwards EnterpriseOne Guide.

8.1.4 Printer Selections

Print properties are passed from the report template to the batch version. You can modify print properties from the File menu in RDA. When you modify properties that are located on the File menu, the modifications are not passed to batch versions that existed before launching RDA to make the modification. For existing batch versions, you need to also make the modification in the versions that you want to affect. Any new batch versions that you create after the modification include the update.

When you submit batch versions to a printer, the system looks first for the printer defined in RDA. If no printer is defined in RDA, the system uses the default printer defined in the JD Edwards EnterpriseOne Printers (P98616) application.

The system determines a printer based on this hierarchical structure:

  1. Printer defined at runtime.

  2. Printer defined in RDA.

    The printer definition becomes part of the report specifications.

  3. Printer defined in the JD Edwards EnterpriseOne Printers application using this hierarchy:

    1. Specific report defined for the user or role.

    2. Specific report defined for *PUBLIC.

    3. All reports defined for the user or role.

    4. All reports defined for *PUBLIC.

When you submit batch versions to a printer, you can use the Printer Selection form to select print options from these tabs:

  • Printer Selection

  • Print Property

  • Document Setup

  • Advanced

See "Understanding Print Properties at Runtime" in the JD Edwards EnterpriseOne Tools Report Printing Administration Technologies Guide.

8.1.5 CSV Files

In addition to viewing the CSV file, you can manipulate the report data after the report finishes processing.

When you export batch versions to CSV:

  • A CSV file is created in the PrintQueue directory.

  • A PDF file is created in the PrintQueue directory.

  • The CSV file displays in a spreadsheet program such as Microsoft Excel or Lotus 123, which launches automatically if you are running the batch version locally. If you are running the batch version on a server, select View CSV from the Oracle's JD Edwards EnterpriseOne Work With Servers (P986116) application to launch the spreadsheet application and view the file.

You can select to output reports to a CSV file from the following locations:

  • RDA for the report template.

  • RDA for the batch version.

  • Versions List at runtime.

Reports do not always export to other programs perfectly. For example, group sections with several one-character data fields might need some cleanup, such as justifying the data or deleting blank columns.

8.1.6 OSA Interface

You can select to output to third-party software programs using OSA. OSA interfaces enable the third-party program to process and format the report data concurrently.

Benefits of using OSA include:

  • The elimination of manually formatting output, as you must do with CSV output.

  • Using the processing power of the target software program.

8.2 Submitting Batch Versions from the Microsoft Windows Client

This section provides overviews of batch versions submitted on the server from the Microsoft Windows client and batch versions submitted locally from the Microsoft Windows client and discusses how to run batch versions from the Microsoft Windows client.

8.2.1 Understanding Batch Versions Submitted on the Server from the Microsoft Windows Client

From the Microsoft Windows client, you can process batch versions:

  • On the enterprise server.

  • Locally on the workstation.

In most business environments, you submit batch versions to a designated enterprise server that can manage the processing needs more efficiently than the workstation. The system administrator defines whether the system automatically processes and prints the output, or places the job on hold in the queue.

When you submit batch versions to the server for processing, they are sent to a job queue. Version specifications and information required to process the batch version are sent from the workstation to the server.

From the JD Edwards EnterpriseOne Work With Servers application you can:

  • Monitor the progress of the job in the queue.

  • Change the priority of the job.

  • View the report output in the following formats when the processing is complete:

    • PDF

    • CSV

    • OSA

  • View logs.

  • Print the report.

Additionally, if the batch version is associated with a report definition, you can:

  • View report definition jobs.

  • View report definition output.

  • View report definition source.

  • Republish a report definition.

See "Embedded BI Publisher for JD Edwards EnterpriseOne" in the JD Edwards EnterpriseOne Tools BI Publisher for JD Edwards EnterpriseOne Guide

When you select to process batch versions on the enterprise server, you have the following options:

Runtime Options for Processing on the Server Description
Modify printer selection. Enables you to change the printer used for the report and select the number of copies to print.
Override the location. Enables you to override the processing location; when you submit the batch version, the system presents you with a list of available servers from which to choose.
Modify paper type. Enables you to change the orientation of the report, the paper size, and the paper source.
Define output options. Enables you to output the report to a CSV file or use OSA interfaces to output to a third-party product.
Modify printer definition language. Enables you to select a new printer definition language as supported by the printer that is defined for the report.

8.2.2 Understanding Batch Versions Submitted Locally from the Microsoft Windows Client

Sometimes processing batch versions locally is not only beneficial but necessary. If you are processing batch versions where the data selection limits the number of records fetched, processing locally is not a performance concern. Processing locally might be necessary to help narrow down issues that you encounter during processing. When batch versions process locally but do not process successfully on the server, this might indicate that the issue is specific to the server. Processing batch versions locally places the logs on the workstation for ease in reviewing processing concerns.

Since the typical system configuration defines batch versions to process on an enterprise server, you need to override the processing location to process batch versions locally.

When you process batch versions locally, you can select these methods of output:

  • On Screen

  • To Printer

  • Export to CSV

  • OSA Interface Name

See Also:

8.2.3 Forms Used to Submit Batch Versions from the Microsoft Windows Client

Form Name FormID Navigation Usage
Work With Batch Versions - Available Versions W98305A EnterpriseOne Life Cycle Tools, Report Management (GH9111), Batch Versions Enter the name of a batch application and select from available batch versions.
Version Prompting W98305D Select a batch version and click Select on the Work With Batch Versions - Available Versions form. Override data selection and data sequencing. Submit batch versions.
Advanced Version Prompting W98305I Click Advanced on the Form menu on the Version Prompting form. Override the processing location for a single batch version submission.
JD Edwards Data Sources W98305B Click Submit on the Version Prompting form. Select a data source for processing a single batch version submission. Select LOCAL to process batch versions locally.
Report Output Destination W98UBEA Click Submit on the Version Prompting form. Select output option for batch version.
Printer Selection W986162B Click To Printer on the Report Output Destination form when submitting batch versions locally.

Click Submit on the Version Prompting form when submitting batch versions to an enterprise server.

Select printer options and output the report to a printer.

8.2.4 Running Batch Versions from the Microsoft Windows Client

Select a batch version from the Work With Batch Versions - Available Versions form.

8.2.4.1 Overriding Advanced Options

Access the Advanced Version Prompting form.

Override Location

Select this option to define a different location in which the batch version processes. You must have permissions for this option. When you submit the batch version for processing, you can select a new location from a list of available data sources on the JDE Data Source form. Data sources include the enterprise servers available on the network and the local workstation.

Submit Version Specifications Only

Select this option to submit version specifications to the server without processing the batch version locally or on the server. The associated report template specifications must already reside on the server to use this feature.

Logging (JDE.log)

Select this option to enable logging for the execution of the batch job on the server. To enable logging on the workstation, you must modify the output setting in the workstation jde.ini. However, be aware that this output setting affects all JD Edwards EnterpriseOne logging. You can select this option without selecting the Tracing option.

Tracing (JDEDEBUG.log)

Select this option to enable tracing for the execution of the batch job on the server. You cannot select this option without selecting the Logging option. The system selects the Logging option for you when you select the Tracing option.

Override Job Queue

Select this option to submit the batch job to another available queue by overriding the job queue as defined for batch versions in both the jde.ini and the specifications. You must have permissions for this option.

UBE Logging Level

Enter a value from 0–6 to indicate the level of detail to be captured in the logs. This option in used in partnership with the logging options. When you select a high value to receive more technical information, you also receive all the information for the lower values. For example, when you enter a value of 3 (object level messages), you also receive information for 2 (section level messages), 1 (informative messages), and 0 (error messages).

Submit with Report Definition

Select this option to submit the batch version with a report definition. This option is only available if a report definition has been associated with the version.

Prompt for Report Definition

Select this option to prompt the user to select a report definition other than the default to be used for the submission. All batch applications that use this batch version as their source of data and have either no source version specified or this specific version specified will be available for submission.

8.2.4.2 Overriding Data Selection and Data Sequencing

Access the Version Prompting form

Data Selection

Select this option to override the current data selection. You can append to the current selection, modify the current selection, or delete the current selection and add new criteria.

Data Sequencing

Select this option to override the current data sequencing. You can add to the current sequencing, modify the current sequencing, or delete the current sequencing and add new information.

8.2.4.3 Submitting the Batch Version

The options that you select on this form override settings specified in the report itself, but apply to the current batch process only.

Access the Report Output Destination form.

On Screen

Select this option to view the report online in a PDF format. The report is readable with Adobe Reader.

To Printer

Select this option to send the report to the defined printer. The system looks first for a printer defined in Report Design Aid, if no printer is defined, the system uses the default printer defined in the JD Edwards EnterpriseOne Printers application.

Export to CSV

Select this option to create a CSV file. When you select this option, the report can be viewed in a default CSV viewer, such as Microsoft Excel or Lotus 1-2-3.

OSA Interface Name

Select this option to pass data to third-party programs during batch processing, enabling those programs to process and format the data concurrently. An OSA interface must already be defined before you can select this option.

8.2.4.4 Overriding Printer Selection

Access the Printer Selection form.

Printer Name

The name of the printer that is defined in either RDA or the JD Edwards EnterpriseOne Printers application. You can override the printer from the Form menu.

Printer Location

The location of the printer that is defined in either RDA or the JD Edwards EnterpriseOne Printers application.

Printer Model

The model of the printer that is defined in either RDA or the JD Edwards EnterpriseOne Printers application.

Number of Copies

Enter the number of copies to print. The default value is one. You can enter a value from 1–9999.

8.2.4.5 Overriding Print Properties

Select the Print Property tab.

Portrait

Select this option to print the report on a page that is longer than it is wide.

Landscape

Select this option to print the report on a page that is wider than it is long. This is the default orientation defined for reports.

Number of Copies

Displays the number of copies entered on the Printer Selection tab. Changing the value here changes the value on the Printer Selection tab as well.

Paper Type

Displays the paper type as it is defined in either RDA or the JD Edwards EnterpriseOne Printers application. You can override this selection.

8.2.4.6 Overriding Document Setup

Select the Document Setup tab.

PDF (Portable Document Format)

Outputs the report to a PDF file that can be read by Adobe Reader. This option cannot be modified.

Printer Definition Language File

Select this option to output the report to a PDL file.

Print Immediate

Select this option to print the report immediately instead of sitting in a queue.

CSV (Comma Delimited)

Select this option to export the report to a CSV file.

OSA Interface Name

Select this option to output the report to a third-party software program.

8.2.4.7 Overriding Advanced Properties

Select the Advanced tab.

Postscript

Displays the type of printer definition language defined. The system selects this option based on the printer that is defined.

PCL

Displays the type of printer definition language defined. The system selects this option based on the printer that is defined.

Line Printer

Displays the type of printer definition language defined. The system selects this option based on the printer that is defined.

Custom

Displays the type of printer definition language defined. Option is selected by the system based on the printer that is defined.

8.3 Submitting Batch Versions from the Web Client

This section discusses batch versions submitted from the web client and lists the forms used to submit batch versions from the web client.

8.3.1 Understanding Batch Versions Submitted from the Web Client

On the web client, you can double-click a report from a menu or access the Submit Jobs application to submit batch versions. All batch versions submitted from the web client are processed on the server.

To make a new report template available from the web client, perform these steps:

  1. Check in the report template and all associated batch versions.

  2. Include the report template and batch versions in a package.

  3. Deploy the package to the enterprise server.

  4. Generate the report template and associated batch versions to HTML.

When you create a new batch version from Microsoft Windows for a report template that has already been deployed and generated to HTML, perform these steps to make the new batch version available from the web client:

  1. Check in the version specifications.

  2. Copy the version specifications to the server.

  3. Generate the batch version to HTML.

This table describes runtime options available when you process batch versions from the web client:

Runtime Options from the Web Client Description
Override the location Enables you to override the processing location; when you submit the batch version, the system presents you with a list of available servers from which to choose.
Modify printer selection Enables you to change the printer used for the report and select the number of copies to print.
Modify paper type Enables you to change the orientation of the report, the paper size, and the paper source.
Define output options Enables you to output the report to a CSV file or use OSA interfaces to output to a third-party product.
Modify printer definition language Enables you to select a new printer definition language as supported by the printer defined for the report.

To increase performance for viewing reports on the web client, the system administrator can activate the page-at-a-time functionality. The settings to activate the page-at-a-time functionality are located in the jde.ini and the jas.ini. The page-at-a-time functionality enables you to view portions of the report while the report continues loading.

8.3.2 Forms Used to Submit Batch Versions from the Web Client

Form Name FormID Navigation Usage
Submit Job - Work With Batch Versions - Available Versions W98305WA EnterpriseOne Menu, Submit Job Enter the name of a batch application and select from available batch versions.
Submit Job - Version Prompting W98305WD Select a batch version and click Select on the Submit Job - Work With Batch Versions - Available Versions form.

Select an option on the Submit Job - Advanced Version Prompting form and click OK.

Submit batch versions.
Submit Job - Advanced Version Prompting W98305WI Click Advanced on the Form menu on the Submit Job - Version Prompting form. Select Override Location to override the processing location for a single batch version submission.
Submit Job - EnterpriseOne Data Sources W98305WC Click Submit on the Submit Job- Version Prompting form. Select a data source for processing a single batch version submission. LOCAL is not an option on the web client.
Printer Selection W986162B Click Submit on the Submit Job - Version Prompting form. Select printer options and output the report to a printer.

8.4 Submitting Table Conversions from the Microsoft Windows Client

This section provides an overview of table conversions submitted from the Microsoft Windows client and discusses how to submit table conversions from the Microsoft Windows client.

8.4.1 Understanding Table Conversions Submitted from the Microsoft Windows Client

Versions of table conversions use different properties than versions of batch applications. When you submit versions of table conversions from the Microsoft Windows client you can select these options:

  • Properties.

  • Override Location.

  • Submit Version Specifications Only.

  • Override Job Queue.

8.4.2 Forms Used to Submit Table Conversions from the Microsoft Windows Client

Form Name FormID Navigation Usage
Work With Batch Versions - Available Versions W98305A EnterpriseOne Life Cycle Tools, Report Management (GH9111), Batch Versions Enter the name of a table conversion template and select from available batch versions.
Table Conversion Prompting W98305P Select a version of a table conversion and click Select on the Work With Batch Versions - Available Versions form. Override properties, processing location and job queue. Copy version specifications to the server and submit versions for processing.

8.4.3 Running Table Conversions from the Microsoft Windows Client

Access the Table Conversion Prompting form.

Properties

Select this option to override the tables conversion properties. The system displays the Properties form when you submit the version.

Submit Version Specifications Only

Select this option to copy the version specifications to the server.

Override Location

Select this option to override the location where the version processes. The system displays the JD Edwards Data Sources form when you submit the version.

Override Job Queue

Select this option to override the job queue. The system displays the Job Queue Search form when you submit the version.

8.5 Submitting Table Conversions from the Web Client

This section provides an overview of table conversions submitted from the web client and discusses how to submit table conversions from the web client.

8.5.1 Understanding Table Conversions Submitted from the Web Client

When submitting versions of table conversions from the web client you cannot modify properties. You can select and modify processing options. You can also select these options:

  • Override Location.

  • Override Job Queue.

  • Submit Version Specifications Only.

  • Data Selection.

8.5.2 Forms Used to Submit Table Conversions from the Web Client

Form Name FormID Navigation Usage
Submit Job - Work With Batch Versions - Available Versions W98305WA EnterpriseOne Menu, Submit Job Enter the name of a table conversion template and select from available batch versions.
Submit Job - Table Conversion Prompting W98305WO Select a version of a table conversion and click Select on the Work With Batch Versions - Available Versions form. Override processing location and job queue. Submit versions for processing.

8.5.3 Running Table Conversions from the Web Client

Access the Submit Job - Table Conversion Prompting form.

Override Location

Select this option to override the location where the version processes. The system displays the Submit Job - EnterpriseOne Data Sources form when you submit the version.

Override Job Queue

Select this option to override the job queue. The system displays the Submit Job - Job Queue Search form when you submit the version.

Submit Version Specifications Only

Select this option to copy the version specifications to the server.

Data Selection

Select this option to override the current data selection. You can append to the current selection, modify the current selection, or delete the current selection and add new criterion.

8.6 Submitting at the Command Line

Using the command line on the enterprise server, you can define third-party software applications to submit batch jobs for processing in EnterpriseOne.

JD Edwards EnterpriseOne accepts two types of batch submission command lines, rubube and runubexml.

This section discusses how to:

  • Submit batch versions using runube.

  • Submit batch versions using runube with UNIX and IBM i.

  • Submit batch versions using runubexml.

8.6.1 Submitting Batch Versions Using runube

The runube command line requires no input files. It is a direct command line that enables you to define:

  • Which report and version to run.

  • Which job queue to use.

  • How the queue is controlled.

  • Whether the report is printed or held.

  • The location where the report is output.

You cannot enter processing option values or modify data selection and data sequencing using runube from the command line.

This is the format of the runube command line:

runubeUID PWD ENV ROLE REP VER JQ B/I P/H S/D PTR

This table describes each of the command line components:

Component Description
runube The name of the executable that submits the job.
UID A JD Edwards EnterpriseOne user ID. You must have permissions to run the report. (If using UNIX or IBM i see other options in the Submitting Batch Versions Using runube with UNIX and IBM i section.)
PWD The JD Edwards EnterpriseOne password corresponding to the JD Edwards EnterpriseOne user ID. (If using UNIX or IBM i see other options in the Submitting Batch Versions Using runube with UNIX and IBM i section.)
ENV The JD Edwards EnterpriseOne environment.
ROLE The JD Edwards EnterpriseOne role.
REP The object name of the report to be processed, such as R014021.
VER The name of the version of the report to be processed; such as XJDE0001. You must enter a version name; you cannot submit a report template.
JQ The name of the job queue to which the system should route the batch job, such as QBATCH.
B/I The processing mode. Enter B to use batch processing. In this case, the system assigns the report a place in the queue.

Enter I for interactive mode, which runs the report immediately outside of the JD Edwards EnterpriseOne queuing mechanism.

P/H The hold code. Enter P to send the output to a printer immediately after the job completes.

Enter H to hold the processed file without printing. You can print the job later using the Oracle's JD Edwards EnterpriseOne Work With Servers program (P986116) located on the Report Management menu (GH9111).

S/D The save code. Enter S to save the file after processing is complete. The delete option (D) is reserved for future functionality.
PTR The printer ID. If you do not enter a printer, the system uses the printer assigned as the default printer based on your JD Edwards EnterpriseOne user ID, role, environment, host name, report name, and version name.

Important:

If you submit this command in a UNIX or IBM i environment, you should be aware of the possible security risk. Any user with access to the UNIX or IBM i system can view this command line, including the password, while the runube command is processing.

8.6.2 Submitting Batch Versions Using runube with UNIX and IBM i

When you submit reports in a UNIX or IBM i environment using the runube command, users with access to the system can view the command line while it is running. Because the command line contains a password, this password is exposed to any user who accesses the command line while it is running. These solutions address this security concern:

  • Define the command to prompt the user for a user ID and password.

  • Create a text file that includes the user ID and password.

Note:

Although the command line security concern only applies to UNIX and IBM i, the prompting functionality and the password text file functionality can be used on any server platform, including Microsoft Windows.

8.6.2.1 Prompt for User ID and Password

Instead of entering the password in the runube command line, you can modify the command line to prompt the user for a JD Edwards EnterpriseOne user ID and password when the command is submitted. To accomplish this, enter -P as the UID and eliminate the password parameter.

This is the format of the command line when prompting for the JD Edwards EnterpriseOne user ID and password:

runubeUID ENV ROLE REP VER JQ B/I P/H S/D PTR

When the user presses enter, the system prompts the user for their JD Edwards EnterpriseOne user ID and password. This table describes the JD Edwards EnterpriseOne user ID and password components:

Component Description
UID Enter -P to prompt for a JD Edwards EnterpriseOne user ID and password.
PWD Do not enter a password parameter.

8.6.2.2 Create a Text File for User ID and Password

Another option to enhance runube security in a UNIX or IBM i environment is to create a text file. When the runube command is submitted, the system reads the text file and uses the JD Edwards EnterpriseOne user ID and password as indicated in the text file.

In the text file, enter the JD Edwards EnterpriseOne user ID on the first line and the JD Edwards EnterpriseOne password on the second line, as indicated by this example:

UID
PWD

In the runube command line, enter one of these options as the UID:

  • -F

    The system reads the file where the JD Edwards EnterpriseOne user ID and password reside and closes the file. The file remains intact.

    Caution:

    This poses its own security risk as the file with the JD Edwards EnterpriseOne user ID and password remain in the system.
  • -Fe

    The system reads the file where the JD Edwards EnterpriseOne user ID and password reside, encrypts the password if it is not already encrypted, and then writes the encrypted password to the file and closes the file.

  • -D

    The system reads the file where the JD Edwards EnterpriseOne user ID and password reside and deletes the file. This is the recommended option.

This is the format of the runube command line when using a text file:

runubeUID PWD ENV ROLE REP VER JQ B/I P/H S/D PTR

Component Description
UID Enter -F or -Fe -D so that the system knows to fetch the JD Edwards EnterpriseOne user ID and password from a file.
PWD Enter the entire path and file name of the text file where the JD Edwards EnterpriseOne user ID and password reside.

8.6.3 Submitting Batch Versions Using runubexml

The runubexml command line requires an XML input file to provide instructions on processing the report. Using this command is nearly as flexible as submitting a batch process directly within JD Edwards EnterpriseOne. This method enables you to override:

  • Processing options

  • Data selection

  • Data sequencing

You must have an XML input file available for each processing variation of each batch version that you want to run.

To use runubexml, you must create an XML input file which provides JD Edwards EnterpriseOne with batch processing instructions. If you are routinely submitting the same reports with the same options for processing, consider creating several XML files for each report.

Create and submit an XML file that provides JD Edwards EnterpriseOne with:

  • Your JD Edwards EnterpriseOne user ID.

  • Your JD Edwards EnterpriseOne password.

  • The JD Edwards EnterpriseOne environment to access.

  • The name of the report.

  • The name of the batch version to be processed.

The system returns a new XML input file that defines the report version and any associated processing option values. You can modify this input file and create several variations of it.

You can run the XML input file as often as required. Changing the input file does not modify the batch version that is saved in JD Edwards EnterpriseOne. The input file only provides the JD Edwards EnterpriseOne batch processing engine with data; JD Edwards EnterpriseOne does not maintain any connection between the XML input file and the report upon which it is based. If you modify the report template in JD Edwards EnterpriseOne and you want those modifications to be reflected in the output you receive with the XML input file, you must either modify the existing input file or generate a new input file.

8.6.3.1 Generating and Editing the Input XML File

You must use a file called jdeRequest.xml to instruct the system to create an XML input file based on a JD Edwards EnterpriseOne report. If you do not have this file available, run this command:

runubexml G CREATE_XML jdeRequest.xml

This command generates the jdeRequest.xml file, which appears as:

<?xml version="1.0" encoding="UTF-8" ?>
  <jdeRequest type="ube" user="MYUSERID" pwd="MYPASSWD" environment="MYENV" role=
"MYROLE" session="">
        <!--This document is automatically generated by the J.D. Edwards APIs-->
        <ACTION TYPE="CREATE_XML" TEMPLATE_TYPE="LAUNCH_JOB">
                <REPORT_NAME VALUE="MYREPORT"/>
                <REPORT_VERSION VALUE="MYVERSION"/>
                <JARGON_SYSTEM_CODE VALUE="1"/>
                <COMMENTS VALUE="1"/>
                <DATA_TYPING VALUE="1"/>
                <BUSINESS_VIEW VALUE="0"/>
                <PRINTER_INFORMATION VALUE="0"/>
                <POPULATED VALUE="1"/>
        </ACTION>
 </jdeRequest>

This table describes the modifications required by the jdeRequest.xml file:

Component Description
user ="MYUSERID" Substitute MYUSERID with your JD Edwards EnterpriseOne user id.
pwd = "MYPASSWD" Substitute MYPASSWD with your JD Edwards EnterpriseOne password. The password must be submitted in plain text; therefore, the jdeRequest.xml file should be kept in a secure location on the file system.
environment ="MYENV" Substitute MYENV with the name of the appropriate JD Edwards EnterpriseOne environment.
role ="'MYROLE" Substitute MYROLE with your JD Edwards EnterpriseOne role.
REPORT_NAME VALUE ="MYREPORT" Substitute MYREPORT with the object name of the report, such as R014021, on which to base the parameters for the XML input file.
REPORT_VERSION VALUE = "MYVERSION" Substitute MYVERSION with the name of the batch version on which to base the parameters for the XML input file, such as XJDE0001. This is a required value; you cannot base the XML input file on a report template.
JARGON_SYSTEM_CODE VALUE Enter 1 to enable jargon overrides. Enter 0 to disable jargon.
COMMENTS VALUE Enter 1 to view XML comments in the xml file. Enter 0 to suppress comments.
DATA_TYPING VALUE Enter 1 to view the data type (numeric, alpha, and so on.) populating the fields. Enter 0 to suppress data type identification.
BUSINESS_VIEW VALUE Enter 1 to view which business view columns are being used to generate the report. Enter 0 to suppress business view data.
PRINTER INFORMATION VALUE Enter 1 to view printer information for the printer to be used for the report. Enter 0 to suppress printer information.

Note: Even though print values are displayed in both the jdeRequest.xml and the input XML file, you cannot override printer values with the XML input file.

POPULATED VALUE Enter 1 to populate the resulting XML input file with the settings and options specified for the batch version. Enter 0 to generate a blank XML input file. Typically, you want to enter 1 in this field.

8.6.3.2 Submitting the XML Input File for Processing

After you have edited and saved the jdeRequest.xml, run this command:

runubexml S jdeRequest.xmlFilenamexml

Substitute Filename with the name that you want to call this file. Oracle recommends naming the file after the report and version upon which it is based, such as R014021_XJDE0001. The runubexml command submits the jdeRequest.xml file for processing and returns the input XML file that you require to run the batch job.

At this point, you can edit Filename.xml. For example, you can modify the processing options, data selection, or data sequencing. Create several input files based on the same batch version with slightly different processing option values. This saves you time if you run the variations on a regular basis.

Important:

The input XML file is precisely formatted according to JD Edwards EnterpriseOne input specifications. Altering the format of the file beyond modifying input values might result in errors when the file is run.

8.6.3.3 Submitting the XML Input File for Running the Batch Job

After creating, modifying, and saving the XML input file, use this command line to process the batch application that the file defines:

runubexml SFilename.xml jdeResponse.xml

Substitute Filename with the name that you gave the XML input file. This command submits the XML input file for processing and returns the results (including error messages) in a file called jdeResponse.xml.

8.6.3.4 Encrypting the Password Before Submitting Batch Versions Using runubexml

Starting with EnterpriseOne Tools release 9.1 Update 4, there is a new option available to encrypt the password inside the input XML file for runubexml. After you edit and save the jdeRequest.xml as explained in the 0section, run this command to encrypt the password inside jdeRequest.xml:

runubexml E ENCRYPT_V1 jdeRequest.xml

This option should be run before you run runubexml S. When you use the option runubexml E ENCRYPT_V1, the password field (pwd=) inside jdeRequest.xml will be encrypted if it is not already encrypted. You can then use this jdeRequest.xml file with runubexml S option to prepare and submit the batch job.