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Introduction

Purpose of this documentation

This documentation:

* Gives a conceptual overview of the application's purpose, architecture, and functionality
* Describes the pages and fields on the application GUI (Graphical User Interface)
¢ Provides procedures for using the application interface

* Explains the organization of, and how to use, the documentation

Document organization

This document is organized into the following chapters:

* About SDS contains general information about the SDS documentation, the organization of this
manual, and how to get technical assistance.

* Confiquration describes the SDS Configuration menus options and their associated functions.
Maintenance describes the SDS Maintenance menu options and their associated functions.

Scope and Audience

This guide is intended for trained and qualified system operators and administrators who are
responsible for managing an SDS system.

Documentation Admonishments

Admonishments are icons and text throughout this manual that alert the reader to assure personal
safety, to minimize possible service interruptions, and to warn of the potential for equipment damage.

Table 1: Admonishments

Icon Description

Danger:

(This icon and text indicate the possibility of
personal injury.)

DANGER

Warning;:

(This icon and text indicate the possibility of
WARNING equipment damage.)
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Icon Description

Caution:

(This icon and text indicate the possibility of
CAUTION service interruption.)

Topple:
(This icon and text indicate the possibility of
TOPPLE personal injury and equipment damage.)

Customer Care Center

The Tekelec Customer Care Center is your initial point of contact for all product support needs. A
representative takes your call or email, creates a Customer Service Request (CSR) and directs your
requests to the Tekelec Technical Assistance Center (TAC). Each CSR includes an individual tracking
number. Together with TAC Engineers, the representative will help you resolve your request.

The Customer Care Center is available 24 hours a day, 7 days a week, 365 days a year, and is linked
to TAC Engineers around the globe.

Tekelec TAC Engineers are available to provide solutions to your technical questions and issues 7
days a week, 24 hours a day. After a CSR is issued, the TAC Engineer determines the classification of
the trouble. If a critical problem exists, emergency procedures are initiated. If the problem is not critical,
normal support procedures apply. A primary Technical Engineer is assigned to work on the CSR and
provide a solution to the problem. The CSR is closed when the problem is resolved.

Tekelec Technical Assistance Centers are located around the globe in the following locations:

Tekelec - Global
Email (All Regions): support@tekelec.com
¢ USA and Canada
Phone:
1-888-FOR-TKLC or 1-888-367-8552 (toll-free, within continental USA and Canada)
1-919-460-2150 (outside continental USA and Canada)
TAC Regional Support Office Hours:
8:00 a.m. through 5:00 p.m. (GMT minus 5 hours), Monday through Friday, excluding holidays
¢ Caribbean and Latin America (CALA)
Phone:
+1-919-460-2150
TAC Regional Support Office Hours (except Brazil):
10:00 a.m. through 7:00 p.m. (GMT minus 6 hours), Monday through Friday, excluding holidays

* Argentina

910-6552-001 Revision A, September 2013 4



Introduction

Phone:
0-800-555-5246 (toll-free)
* Brazil
Phone:
0-800-891-4341 (toll-free)
TAC Regional Support Office Hours:
8:00 a.m. through 5:48 p.m. (GMT minus 3 hours), Monday through Friday, excluding holidays
¢ Chile
Phone:
1230-020-555-5468
* Colombia
Phone:
01-800-912-0537
* Dominican Republic
Phone:
1-888-367-8552
* Mexico
Phone:
001-888-367-8552
¢ Peru
Phone:
0800-53-087
¢ Puerto Rico
Phone:
1-888-367-8552 (1-888-FOR-TKLC)
* Venezuela
Phone:
0800-176-6497

¢ Europe, Middle East, and Africa

Regional Office Hours:
8:30 a.m. through 5:00 p.m. (GMT), Monday through Friday, excluding holidays

* Signaling

Phone:
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+44 1784 467 804 (within UK)

e Software Solutions
Phone:

+33 389 3354 00

* Asia
¢ India
Phone:
+91-124-465-5098 or +1-919-460-2150

TAC Regional Support Office Hours:
10:00 a.m. through 7:00 p.m. (GMT plus 5 1/2 hours), Monday through Saturday, excluding
holidays
¢ Singapore
Phone:
+65 6796 2288
TAC Regional Support Office Hours:

9:00 a.m. through 6:00 p.m. (GMT plus 8 hours), Monday through Friday, excluding holidays

Emergency Response

In the event of a critical service situation, emergency response is offered by the Tekelec Customer Care
Center 24 hours a day, 7 days a week. The emergency response provides immediate coverage, automatic
escalation, and other features to ensure that the critical situation is resolved as rapidly as possible.

A critical situation is defined as a problem with the installed equipment that severely affects service,
traffic, or maintenance capabilities, and requires immediate corrective action. Critical situations affect
service and/or system operation resulting in one or several of these situations:

* A total system failure that results in loss of all transaction processing capability

¢ Significant reduction in system capacity or traffic handling capability

* Loss of the system’s ability to perform automatic system reconfiguration

* Inability to restart a processor or the system

* Corruption of system databases that requires service affecting corrective actions

* Loss of access for maintenance or recovery operations

* Loss of the system ability to provide any required critical or major trouble notification

Any other problem severely affecting service, capacity/traffic, billing, and maintenance capabilities
may be defined as critical by prior discussion and agreement with the Tekelec Customer Care Center.
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Related Publications

The Diameter Signaling Router (DSR) documentation set includes the following publications, which
provide information for the configuration and use of DSR and related applications.

Getting Started includes a product overview, system architecture, and functions. It also explains the
DSR GUI features including user interface elements, main menu options, supported browsers, and
common user interface widgets.

Feature Notice describes new features in the current release, provides the hardware baseline for this
release, and explains how to find customer documentation on the Customer Support Site.

Roadmap to Hardware Documentation provides links to access manufacturer online documentation for
hardware related to the DSR.

Operation, Administration, and Maintenance (OAM) Guide provides information on system-level
configuration and administration tasks for the advanced functions of the DSR, both for initial setup
and maintenance.

Communication Agent User Guide explains how to use the Communication Agent GUI pages to configure
Remote Servers, Connection Groups, and Routed Servers, and to maintain configured connections.

Diameter and Mediation User Guide explains how to use the Diameter GUI pages to manage the
configuration and maintenance of Local and Peer Nodes, connections, Configuration Sets, Peer Routing
Rules, Application Routing Rules, and System and DNS options; explains how to configure and use
Diameter Mediation; and describes DSR capacity and congestion controls.

IP Front End (IPFE) User Guide explains how to the use the IPFE GUI pages to configure IPFE to
distribute IPv4 and IPv6 connections from multiple clients to multiple nodes.

Range-Based Address Resolution (RBAR) User Guide explains how to use the RBAR GUI pages to configure
RBAR to route Diameter end-to-end transactions based on Diameter Application ID, Command Code,
Routing Entity Type, and Routing Entity address ranges and individual addresses.

Full-Address Based Resolution (FABR) User Guide explains how to use the FABR GUI pages to configure
FABR to resolve designated Diameter server addresses based on Diameter Application ID, Command
Code, Routing Entity Type, and Routing Entity addresses.

Charging Proxy Application (CPA) and Offline Charging Solution User Guide describes the Offline Charging
Solution and explains how to use the CPA GUI pages to set System Options for CPA, configure the
CPA's Message Copy capability, and configure the Session Binding Repository for CPA.

Policy DRA User Guide describes the topology and functions of the Policy Diameter Routing Agent
(Policy DRA) DSR application and the Policy Session Binding Repository, and explains how to use
the GUI pages to configure Policy DRA.

DSR Alarms, KPIs, and Measurements Reference Guide provides detailed descriptions of alarms, events,
Key Performance Indicators (KPIs), and measurements; indicates actions to take to resolve an alarm,
event, or unusual Diameter measurement value; and explains how to generate reports containing
current alarm, event, KPI, and measurement information.

DSR Administration Guide describes DSR architecture, functions, configuration, and tools and utilities
(IPsec, Import/Export, DIH, and database backups); and provides references to other publications for
more detailed information.
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Locate Product Documentation on the Customer Support Site

Access to Tekelec's Customer Support site is restricted to current Tekelec customers only. This section
describes how to log into the Tekelec Customer Support site and locate a document. Viewing the
document requires Adobe Acrobat Reader, which can be downloaded at www.adobe.com.

1.

Log into the Tekelec Customer Support site.

Note: If you have not registered for this new site, click the Register Here link. Have your customer
number available. The response time for registration requests is 24 to 48 hours.

Click the Product Support tab.

Use the Search field to locate a document by its part number, release number, document name, or
document type. The Search field accepts both full and partial entries.

Click a subject folder to browse through a list of related files.
To download a file to your location, right-click the file name and select Save Target As.
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This section of documentation describe the SDS
application, its GUI, the system architecture, and
centralized configuration.

Subscriber Database Server (SDS) provides the
central provisioning of the Full-Address Based
Resolution (FABR) data. The SDS, which is deployed
geo-redundantly at a Primary and Disaster recovery
site, connects with the Query Server and the Data
Processor Site Operation Administration and
Maintenance (DP SOAM) servers at each Diameter
Signaling Router (DSR) site or a standalone DP site
to replicate and recover provisioned data to the
associated components.



About SDS

Introduction to SDS

The SDS/DP system consists of a Primary Provisioning Site, a Disaster Recovery (DR) Provisioning
Site, and up to 24 DSR Signaling Site servers with redundant DP SOAM servers and up to 10 DP
blades. Each Provisioning Site has an active/standby pair of servers in a high availability (HA)
configuration and a third server configured as a Query Server.

The SDS/DP system is built upon the AppWorks platform. This platform provides a variety of services
such as site-based GUI, HA capabilities (active/standby switchover and DR switchover), and database
functionality (replication, backup, restore).

Every server within the SDS/DP system collects measurements, alarms and events data. This
functionality is provided by AppWorks. Every server sends its traps directly to the customer’s SNMP
Manager. Every server can collect measurement data. This measurement data is merged up in reverse
direction of replication. The DP measurements are sent to the Active DP SOAM server, which sends
the measurements from all DP servers and itself to the Primary Provisioning Site’s Active SDS.

This introduction will familiarize you with the basic operation, features, and components of SDS.

SDS functionality

SDS provides the following functionality:

¢ SDS Database - Stores subscriber data needed by the DSR FABR application
* GUlI-based provisioning

¢ Support SOAP over HTTP and XML over TCP as provisioning interfaces

* SQL Interface - At query server for query only

* CSV and/or XML format export and import of database contents

* Real Time replication to:

* Local standby server at Primary site

* Local query server at Primary site

e Each server at Disaster Recovery site

¢ Each DP SOAM and DP at up to 24 DSR sites

* DP - DB Processor — A server that has a replica of the SDS database and is available for query by
DSR FABR applications

¢ Automatic scheduled NPA Split processing
* Provisioning Measurements and KPIs
e Alarms, Events and Logs for all interfaces

* DB Audit - Replication audit within replicas and Active SDS, and remote audit between SDS and
HLR Router

* Query Server

* Backup and Restore of SDS database components

¢ Disaster Recovery SDS -Geo-diverse site

¢ Automated Performance Data Export (APDE)

* Manage and associate routing destinations for routing entities that represent Subscriber identities
¢ Monitor exceptions

* Subscriber identity grouping
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¢ Blacklist support
* Address resolution - Full address, as well as prefix address support

System Architecture

SDS consists of an active/standby pair of SDS servers in an HA configuration, a third SDS server
configured as a Query Server, an optional DR SDS, redundant DP SOAM servers, and up to 10 DPs

(Database Processor) servers. An SDS can have up to 24 sites, each capable of supporting up to 512
remote signaling points.

This figure provides an overview of the SDS architecture.
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Figure 1: SDS System Diagram

SDS Components

SDS

The SDS is one active and one standby HP RMS server running the SDS application and operating in
a high availability configuration. It accepts subscriber data provisioned by the customer over SOAP
or XML and replicates it to the DR SDS, the Query Server, and all underlying SDSes. It also provides
a GUI which is used for configuration, user administration, and the viewing of alarms and
measurements.
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SDS distributes all successful incoming subscriber provisioning data, independent of source, to all
downstream Network Elements (NE)s and to the DR SDS at a rate of up to 200 provisioning database
updates per second. In order to ensure the database levels of the Network Elements are less than the
database levels of the SDS and DR SDS, the active provisioning site SDS provisions the DR SDS prior
to updating the Network Elements.

DR SDS

The DR SDS is a geographically independent SDS component. The DR SDS has the same hardware
configuration and network accessibility as the SDS.

The DR SDS's databases are kept up to date through real-time replication of subscriber and application
data from the Active SDS. Under normal operating conditions, the DR SDS does not provision any
downstream systems but if made Active, it will take over all the functions of the Active SDS including
the provisioning and database replication to underlying DP SOAMs.

DP SOAM

The DP SOAM is the combination of an active and a standby application server running the DP SOAM
application and operating in a high availability configuration. It accepts subscriber data replicated
from the Active SDS and in turn replicates it to all underlying DPs located in the same physical frame.
DP SOAM also provides a GUI used for local DP configuration and viewing alarms and measurements
details specific to components located within the frame (DP SOAM, DP).

The DP SOAM supports up to 10 DPs.

Query Server

The Query Server is an independent application server containing a replicated version of the
provisioning database. It accepts replicated subscriber data from the SDS and stores it in a customer
accessible MySQL database. A Query Server is located in the same physical frame as each SDS
component (SDS / DR SDS).

Network Element

Network Elements are containers that group and create relationships between servers in the network.
There are two types of Network Elements:

¢ SDS: such as the SDS and the DR SDS
* DP SOAM: contains a pair of DP SOAM servers and one or more DP servers

The system can support two SDS Network Elements and up to 24 DP SOAM Network Elements.

DPs

The Data Processors (DP) are HP C-Class blades with the SDS application installed that are configured
for DP functionality. They accept replicated subscriber data from the local DP SOAM and store it in
a subscriber database.

The DP are servers that are configured for DP functionality. They accept replicated subscriber data
from the local DP SOAM and store it in a subscriber database. The DPs are used for processing queries
from the DSR Message Processor (MP) for destination address resolution. DP receives database queries
that include user identities such as MSISDN, IMSI or URI and destination types and return the resolved
destination’s address FQDN and/or realm values.
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Each DSR Signaling Site can support multiple DP servers deployed in a single frame in order to scale
query capacity (by increments of 50,000 QPS per DP). Each DSR Signaling Site can support up to 10
DPs; however, only 2 DPs are supported in the initial release.

The DP servers all contain a copy of the same SDS data. They are configured in an active/active mode.
The DSR’s MP is responsible for load-balancing requests across DP servers.

The DP server runs on a HP C-Class blade. The DP is deployed at each DSR site on Data Processor
(DP) blades with n+m redundancy. Initially n=1 and m=1.

Distributed configuration

The SDS supports centralized configurations:
¢ Centralized configuration:

¢ All subscriber data configuration and maintenance occurs at the SDS level
¢ Application management, such as configuring servers, occurs at the SDS level

Due to distributed configuration:

¢ AllOAM Administration, Configuration, and Status & Manage tasks can only be performed when
you are logged into an active SDS.

* SDS tasks related to the subscriber database are only available when logged into an active SDS,
with the exception of querying the database.

e All Alarms, KPIs, Measurements, and Events are accessible from the SDS.

Centralized configuration

Subscriber provisioning data is provisioned at the active server of the Primary SDS cluster and replicated
to all servers on the network. System configuration and subscriber data is provisioned at the active
server of the Primary SDS cluster, replicated to all other SDS, and then replicated to the active DP
SOAM of each Network Element.

SOAP/XML

The main method of subscriber data provisioning is SOAP or XML Interfaces. They allow one or
several independent information systems supplied and maintained by the network operator to be
used for provisioning databases and for configuring systems. Through the SOAP /XML interfaces,
independent information systems may add, delete, change or retrieve information about any
Destinations Routing Entities.

GUI Provisioning

Local provisioning can be done using the SDS GUI. The GUI can be used to manage Provisioning
setup, to make direct changes to the subscriber database entries, and to perform application operations,
management, and provisioning.

This table shows the GUI options available when logged into an SDS.
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Table 2: SDS Main Menu Options

About SDS

Menu Item

Function

Administration

All options available:

e Users

* Groups

® Sessions

¢ Single Sign-On
e Authorized IPs
¢ Options

¢ SNMP

e ISO

¢ Upgrade

* Software Versions
e Export Server

Configuration

All options available:

¢ Network Elements
e Services

e Resource Domains
e Servers

* Server Groups

¢ Network

Alarms & Events

All options available:

e View Active
¢ View History
¢ View Trap Log

Security Log

All options available:

¢ View History

Status & Manage

All options available:

¢ Network Elements
e Server

e HA

¢ Database

e KPIs

e Processes

e Tasks

¢ Files

Measurements

All options available:

¢ Report
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Menu Item

Function

Communication Agent

All options available:

¢ Configuration
¢ Maintenance

SDS

Configuration:

¢ Options

¢ Connections

e NAI Hosts

e Destinations

¢ Destination Map
¢ Routing Entities
¢ Subscribers

e Blacklist

Maintenance:

¢ Connections

¢ Command Log

* Relay Exception Log
¢ Import Status

* Routing Entities

¢ Export

* Remote Audit

* Query

¢ NPA Splits

910-6552-001 Revision A, September 2013
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The SDS Configuration menu options allow you
to configure provisioning options and view, insert,
edit, and delete provisioning connections, NAI
hosts, destinations, and routing entities.

The available database menu options will vary based
on the type of server you are logged into and the
permissions assigned to your group. If you do not
see a menu option you need, make sure you are
logged into the appropriate type of server and ask
your administrator to make sure the group your
user ID belongs to has the appropriate permissions.
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Configuration

Options configuration

The Options page allows you to control how the mechanized interface works and controls features
such as Import and Export.

Provisioning options

Connections between the application and the provisioning client are set up using the Connections
page (for more information, see Connections configuration. The Options page allows you to manage
configuration options for these connections. Use this page to configure:

* Whether to allow connections and the maximum number of connections allowed

* Number of seconds of inactivity allowed before a connection is timed out

*  Whether to log provisioning messages

* Number of seconds allowed between a transaction being committed and becoming durable
¢ TCP listening ports

* Whether to allow to importing from and exporting to a Remote Host

Import options

The status of provisioning imports can be viewed using the SDS Maintenance Import page. For more
information, see Import Status maintenance. Provisioning imports from a remote host are configured
through the SDS Configuration Options page. Use this page to configure:

* Whether provisioning imports are enabled

* Remote host information, including the IP address, username, password, and import directory
name

¢ Whether the import mode is blocking or non-blocking

Export options

Provisioning exports are scheduled through the SDS Configuration Export page and the export status
can be viewed through the SDS Maintenance Export Status page. For more information about this
see Import Status maintenance. Use the SDS Configuration Options page to configure:

¢ Whether or not exports are allowed to be copied from this server to the remote host

* Remote host information, including the IP address, username, password, and export directory
name

¢  Whether the export mode is blocking or non-blocking

Options configuration elements

This table describes the fields on the Options page.
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Table 3: Options Configuration Elements

Configuration

Element

Description

Data Input Notes

Display Command Output

If checked, the commands and
responses will be displayed on
the GUI when provisioning data.

Format: Check box
Range: Checked, Unchecked
Default: Unchecked

Allow Connections

If checked, incoming
provisioning connections are
allowed.

Format: Check box
Range: Checked, Unchecked
Default: Checked

Max Transaction Size

The maximum number of
database manipulation
commands per transaction.

Format: Digits only
Range: 1-100
Default: 50

Log Provisioning Messages

If checked, all incoming and
outgoing provisioning messages
will be logged in the command
log.

Format: Check box
Range: Checked, Unchecked
Default: Checked

Transaction Durability Timeout

The number of seconds allowed
between a transaction being
committed and it becoming
durable. If Transaction
Durability Timeout lapses,
DURABILITY_TIMEOUT (1024)
response is sent to the
originating client. The associated
request should be resent to
ensure that the request was
committed.

Format: Digits only; seconds
Range: 2-3600
Default: 5

Remote Import Enabled

If checked, import files are
imported from a remote host.

Format: Check box
Range: Checked, Unchecked
Default: Unchecked

Remote Import Mode

If set to Non-Blocking, updates
are allowed on all provisioning
connections while the remote

import operation is in progress.

If set to Blocking, updates are
not allowed.

Format: Pulldown menu
Range: Non-Blocking, Blocking
Default: Non-Blocking

Remote Import Host IP Address

The IP address of remote import
host periodically queried for
import files.

Format: Alphanumeric

Range: 0-15 characters

910-6552-001 Revision A, September 2013
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Element

Description

Data Input Notes

Remote Import User

The Username for remote import
host user.

Format: Alphanumeric

Range: 0-255 characters

Remote Import Password

The password to exchange ssh
keys with the remote import
host. The password is cleared
from this table after the keys
have been exchanged.

Format: Alphanumeric

Range: 0-255 characters

Remote Import Directory

The directory where import files
exist on the remote import host.

Format: Alphanumeric

Range: 0-255 characters

Export Mode

If set to Non-Blocking, updates
are allowed on all provisioning
connections while the export
operation is in progress.

If set to Blocking, updates are
not allowed.

Format: Pulldown menu
Range: Non-Blocking, Blocking
Default: Non-Blocking

Remote Export Transfers
Enabled

If checked, export files will be
copied to the remote export host.

Format: Check box
Range: Checked, Unchecked
Default: Unchecked

Remote Export Host IP Address

The IP address of the remote
export host to where export files
may be configured automatically
transferred.

Format: Alphanumeric

Range: 0-15 characters

Remote Export User

The username for remote export
host user.

Format: Alphanumeric

Range: 0-255 characters

Remote Export Password

The Password to exchange ssh
keys with the remote export
host. The password is cleared
from this table after the keys
have been exchanged.

Format: Alphanumeric

Range: 0-255 characters

Remote Export Directory

If export is configured, the
export files are transferred to the
location on the remote export
host.

Format: Alphanumeric

Range: 0-255 characters

Remote Audit Receive Window
Size

The maximum number of
retrieval messages that can be
received and buffered by the
Provisioning Database
Application on the remote
system. After this amount is
reached, no more messages will

910-6552-001 Revision A, September 2013

Format: Digits only
Range: 5-2500
Default: 500
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Element

Description

Data Input Notes

be sent until acknowledgments
are received from the remote
system.

Remote Audit Send Message
Rate

The maximum rate of
messages/second in which
retrieval messages will be sent
to the Provisioning Database
Application on the remote
systems.

Format: Digits only
Range: 5-2500
Default: 500

Remote Audit Number Range
Limit

The maximum number of
records that can be queried per
request message.

Format: Digits only
Range: 100-100000
Default: 1000

PDB Relay Enabled

Whether or not to relay
successful incoming
provisioning requests to a
Provisioning Database
Application on a remote system.

Note: This feature requires that
the Log Provisioning Messages
option is enabled.

Format: Check box
Range: Checked, Unchecked
Default: Unchecked

PDB Relay Primary Remote
System VIP Address

The VIP address of the primary
remote system of that the
Provisioning Database
Application is running.

Note: Changes to the VIP
address listening port do not
take affect until PDB Relay is
restarted.

Format: Alphanumeric

Range: 0-15 characters

PDB Relay Disaster Recovery
Remote System VIP Address

The VIP address of the Disaster
Recovery remote system on
which the Provisioning Database
Application is running.

Note: Changes to the VIP
address do not take affect until
PDB Relay is restarted.

Format: Alphanumeric

Range: 0-15 characters

PDB Relay Remote System Port

The TCP listening port of the
Provisioning Database
Application on the remote
system.

Note: Changes to the TCP
listening port do not take affect
until PDB Relay is restarted.

Format: Digits only
Range: 0-65535
Default: 5873

910-6552-001 Revision A, September 2013
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Element

Description

Data Input Notes

PDB Relay Receive Window Size

The maximum number of
provisioning commands that can
be received and buffered by the
Provisioning Database
Application on the remote
system. After this amount is
reached, no more commands will
be sent until acknowledgments
are received from the remote
system.

Format: Digits only
Range: 5-2500
Default: 500

PDB Relay Send Command Rate

The maximum rate (in
commands/second) in which
commands will be relayed /sent
to the Provisioning Database
Application on remote system.

Format: Digits only
Range: 5-2500
Default: 500

PDB Relay Timestamp
(read-only)

The timestamp of the last
provisioning message relayed to
the Provisioning Database
Application on the remote
system.

Format: Read-only timestamp

XML Interface Port

XML interface TCP (unsecured)
listening port.

To disable this port, set it to O.

Note: Changes to the TCP
listening port do not take effect
until the 'xds' process is
restarted. You must also specify
a different port other than the
SOAP interface.

Format: Digits only
Range: 0-65535
Default: 5875

XML Interface Idle Timeout

The maximum number of
seconds that an open connection
will remain active without a
request being sent before the
connection is dropped.

Format: Digits only; seconds
Range: 1-86400
Default: 1200

Maximum XML Connections

The maximum number of
simultaneous XML interface
client connections.

Note: Changes to the Maximum
XML Connections option do not
take effect until the 'xds' process
is restarted.

Format: Digits only
Range: 1-120
Default: 120
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Element

Description

Data Input Notes

SOAP Interface Port

The SOAP interface TCP
listening port.

To disable this port, set it to O.

Note: Changes to the TCP
listening port do not take effect
until the 'xds' process is
restarted. You must also specify
a different port other than the
XML interface.

Format: Digits only
Range: 0-65535
Default: 5876

SOAP Interface Idle Timeout

The maximum time (in seconds)
that an open connection will
remain active without a request
being sent, before the connection
is dropped.

Format: Digits only
Range = 1-86400
Default = 1200

Maximum SOAP Connections

The maximum number of
simultaneous SOAP interface
client connections.

Note: Changes to the Maximum
SOAP Connections option do not
take effect until the "xds' process
is restarted.

Format: Digits only
Range: 1-120
Default: 120

SOAP Secure Mode

If set to Secure, the SOAP
interface operates in secure
mode (using SSL).

Note: Changes to the SOAP
Secure Mode option do not take
effect until the 'xds' process is
restarted.

Format: Pulldown menu
Range: Secure, Unsecure

Default: Unsecure

Maximum Transaction Lifetime

The maximum number of
seconds that a transaction will
remain open before
automatically being rolled back
if a commit or rollback is not
performed.

To disable this timeout, set it to
0.

Format: Digits only; seconds
Range: 0-3600
Default: 60

Editing options

You can only perform this task when logged into the active SDS server.

1. Select SDS > Configuration > Options.
The SDS Configuration Options page appears.
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2. Modify the options you want to change by entering information in the appropriate fields.

For a detailed explanation about the options and valid input for these fields, see Options configuration
elements.

Click Apply.
If field validations succeed, the changes are saved and you remain on the same page. A successful
update message appears.

If the page contains any values that are not valid or are out of range, an error message appears.

Connections configuration

The Connections page allows you to manage the configuration for servers permitted to establish a
connection to the active Primary Provisioning Site's Active SDS Server. Only the servers specified in
the Connections list are allowed to remotely connect to the server and execute commands.

Note: Connection options must be set prior to configuring connections. For more information about
these options, see Options configuration.

SDS allows up to 120 simultaneous provisioning connections and supports secure and unsecure SOAP
connections. While the application is capable of supporting 120 connections, the maximum number
of connections allowed can be limited using the Options page. For more information about this option,
see Options configuration.

From the Connections page, you can:

Filter the list of servers to display only the desired servers.

View the list of servers allowed to establish a remote connection and each server's permissions.
Configure the SDS to allow connection requests from remote servers.

Modify the System ID, IP address, and permissions for listed servers.

Delete servers from the connections list.

Connections configuration elements

This table describes the fields on the Connections View page.

Table 4: Connections Configuration Elements

Element Description Data Input Notes
Action columns Selectable columns where you | Format: Selectable items.
can choose to edit or delete
selections.
Filter fields Pulldown menu of available Format: Selectable list.

filters and additional fields to
modify the search options.

System ID Identification for the system Format: Alphanumeric

Range: 1-8 characters
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Element Description Data Input Notes
IP Address IP address of the client that will | Format: Alphanumeric
connect to SDS

Range: IPV4 dot-decimal
nqtation (where x  is 1-255 and
x is 0-255.

Permission Database permissions for this [ Format: Pulldown list

client Range: READ_ONLY,

READ_WRITE
Default: READ_ONLY

Viewing connections

You can perform this task when logged into an SDS or from the DP SOAM GUL

Select SDS > Configuration > Connections.
The Connections page appears.

The currently allowed connections are listed in the table.

Inserting connections

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Connections.
The Connections page appears.

Click Insert.
The SDS Configuration Connections [Insert] page appears.

Enter a system ID in the System ID field.

. Enter a unique IP address for the connection in the IP Address field.

5. Select the permissions level for the connection from the Permissions pulldown menu.

* Select READ_ONLY to grant read-only access for the client with this connection. This is the
default.

* Select READ_WRITE to grant read and write access for the client with this connection.

Perform one of the following:

¢ C(lick OK to save the connection and return to the SDS configuration connections page.
¢ Click Apply to save the connection and remain on this page.
* Click Cancel to return to the SDS Configuration Connections page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

* Any required field is empty; no value was entered or selected
¢ The entry in any field is not valid (wrong data type or out of the valid range)
¢ The IP Address is not unique; it already exists in the system
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Editing connections

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Connections.
The SDS Configuration Connections page appears.

Locate the connection you want to edit and click Edit.
The SDS Configuration Connections [Edit] page appears.

Edit the System ID, IP Address, and/or Permission for the connection.

For more information about these fields, see Connections confiquration elements.

Perform one of the following:

* Click OK to save the changes and return to the SDS configuration connections page.

¢ Click Apply to save the changes and remain on this page.

If field validations succeed, the connection is saved.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:
¢ If the entry in any field is not valid or are out of range

e If a required field is empty (not entered)
* If the IP Address is not unique

Deleting connections

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Connections.
The SDS Configuration Connections page appears.

Locate the connection you want to delete and click Delete.
A popup confirmation window appears.

Perform one of the following actions:

e (lick OK to delete the connection.

¢ Click Cancel to cancel the delete function and return to the SDS Configuration Connections
page.

NAI Hosts configuration

The NAI Hosts page allows you to manage the Network Access Identifier (NAI) host systems that are
used for provisioning NAI User-associated routing entities.

From the NAI Hosts page, you can:

Filter the list of hosts to display only the desired hosts.
View the NAI Hosts configured for NAI User.

Add a NAI Host.

Delete a NAI Host.
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This table describes the fields on the NAI Hosts View and Insert pages.

Table 5: NAI Hosts Configuration Elements

Element

Description

Data Input Notes

NAI Host

Network Access Identifier
hostname

Format: alphanumeric (A-Z, a-z,
0-1) and special characters:
period (.), hyphen (-), plus (+),
underscore (_), At sign (@),
dollar sign ($), pound or number
sign (#), forward slash (/),
double quote ("), asterisk (*),
exclamation point (!), and colon

)

Range: 1-64 characters

Viewing NAI hosts

You can perform this task when logged into an SDS or from the DP SOAM GUL

Select SDS > Configuration > NAI Hosts.
The SDS Configuration NAI Hosts page appears.

The current NAI hosts are listed in the table.

Inserting NAI hosts

You can only perform this task when logged into the Active Primary SDS.

1. Select SDS > Configuration > NAI Hosts.
The SDS Configuration NAI Hosts page appears.

2. Click Insert.
The SDS Configuration NAI Hosts [Insert] page appears.

3. Enter a unique hostname in the NAI Host field.

4. Perform one of the following;:

¢ Click OK to save the hostname and return to the SDS configuration NAI Hosts page.

¢ Click Apply to save the hostname and remain on this page.

* Click Cancel to return to the SDS Configuration NAI Hosts page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

* The required field is empty; no value was entered.

* The entry in the NAI Host field contains an invalid character.
¢ The hostname is not unique; it already exists in the system.
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You can only perform this task when logged into the Active Primary SDS.

Before performing this task, disable and delete any association that may exist between the NAI host
and routing entity (NAI User or Wildcard NAI User).

1. Select SDS > Configuration > NAI Hosts.
The SDS Configuration NAI Hosts page appears.

2. Locate the NAI host you want to delete and click Delete.
A popup confirmation window appears.

3. Perform one of the following actions:

* C(lick OK to delete the NAI Host.
¢ Click Cancel to cancel the delete function and return to the SDS Configuration NAI Hosts

page.

If OK is clicked and the following condition exists, an error message appears:

¢ The NAI Host is in use by a routing entity.

Destinations configuration

The Destinations page allows you to manage routing destinations used by routing entities.

From the SDS Configuration Destination page, you can perform the following actions:

¢ Retrieve information for a specific Destination.

¢ Add a Destination.

* Update the information associated with an existing Destination.
* Delete a Destination.

Destinations configuration elements

This table describes the fields on the Destination Retrieve, Add, Update, and Delete tabs.

Table 6: Destinations Configuration Elements

Element Description Data Input Notes
Retrieve and Delete tabs
Name Name of the destination
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27



Configuration

Element

Description

Data Input Notes

exclamation point (!), and colon
)

Range: 1-32 characters; cannot
start with a digit and must

contain at least one alpha
character.

Add and Update tabs

Name

Name of the destination

Format: Alphanumeric (A-Z, a-z,
0-1) and special characters:
period (.), hyphen (-), plus (+),
underscore (_), At sign (@),
dollar sign ($), pound or number
sign (#), forward slash (/),
double quote ("), asterisk (*),
exclamation point (!), and colon
()

Range: 1-32 characters; cannot
start with a digit and must
contain at least one alpha
character.

Type

Type of destination

Format: Pulldown list

e IMS HSS

e LTE HSS

e PCRF

e OCF

e OFCS

e AAA

e User defined 1
e User defined 2

FQDN

Unique fully qualified domain
name

Format: String consisting of a list
of labels separated by dots. A
label might contain letters, digits,
dash (-), and underscore (_). A
label must begin with a letter or
underscore, and must end with
a letter or digit. Underscore can
be used only as the first
character.

Range: 0-255 characters

Realm

Realm
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Element Description Data Input Notes

label must begin with a letter or
underscore, and must end with
a letter or digit. Underscore can
be used only as the first
character.

Range: 0-255 characters

Retrieving destinations

You can perform this task when logged into an SDS or from the DP SOAM GUL

1.

Select SDS > Configuration > Destinations.
The SDS Configuration Destinations page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

Enter the destination you want to view in the Name field.

Note: For a list of Destinations, select SDS > Maintenance > Query; then, select Destination from
the Data pulldown list.

Click Retrieve.
The destination appears.

Adding destinations

You can only perform this task when logged into the Active Primary SDS.

1.

NS kW

Select SDS > Configuration > Destinations.
The SDS Configuration Destinations page appears.

Select the Add tab.
The Add tab appears.

Enter a unique name in the Name field.

Select the type of destination from the Type pulldown list.

Enter a fully-qualified domain name (FQDN) in the FQDN field.

Enter the realm in the Realm field.

Click Add to save the destination.

When Add is clicked and any of the following conditions exist, an error message appears:

* The entry in any field is not valid (wrong data type).
¢ The Destination name is not unique; it already exists in the system.

Updating destinations

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Destinations.
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The SDS Configuration Destinations page appears.

2. Select the Update tab.
The Update tab appears.

3. Enter the destination you want to update in the Name field. Click Lookup.
The Update tab appears. with the destination information.

4. Edit the FQDN and/or Realm fields.
Use the keyword none to clear the attribute.

For more information about these fields, see Destinations configuration elements.

' Important: When updating a destination, you are permitted to leave both the FQDN
andRealm empty. This action is permitted and the destination is retained despite
having no data for these attributes.

5. Click Update to save the changes to the destination.
When Update is clicked and any of the following conditions exist, an error message appears:

* The entry in any field is not valid (wrong data type).
¢ The Destination and its associated change exists.

Deleting destinations

You can only perform this task when logged into the Active Primary SDS.

A Destination cannot be deleted while any routing entity, NAI/Wildcard User, or Destination remains
associated with them. Before you perform this task, disable and delete any connections that use the
Destination

1. Select SDS > Configuration > Destinations.
The SDS Configuration Destinations page appears.
2. Select the Delete tab.

3. Enter a valid destination you want to delete in the Name field. Click Delete.
A popup confirmation window appears.

4. Perform one of the following actions:
¢ Click OK to delete the destination.
* C(lick Cancel to cancel the delete function and return to the SDS Configuration Destinations
page.
If OK is clicked and the following condition exists, an error message appears:
* No updates were made to the database.
¢ Field Name contains invalid character(s).

* Object currently in use; destination is used by a route.
* Object currently in use; destination is used by a destination map.
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Destination map configuration

The Destination map page allows you to add, modify, or delete additional data on an existing
Destination.

From the Destination Map page, you can associate a destination to a HLR Router Network entity.

Destination map configuration elements

The SDS -> Configuration -> Destination Map page displays information in a tabular format. The
following table describes elements on this page.

Table 7: Destination Map Elements

Element Description Data Input Notes
Action columns Selectable columns where you | Format: Selectable items.
can choose to edit or delete
selections.
Filter fields Pulldown menu of available Format: Selectable list.

filters and additional fields to
modify the search options.

Destination Destination field. Format: Alphanumeric

Range: 1-32 characters

Network Entity The E.164 address of a service | Format: Numeric

node used by HLR Router. Range: 8-15 characters

Viewing Destination Map connections

Use this page to view the list of Destination Map entries.

Select SDS > Configuration > Destination Map.
The Destination Map page appears.

The current destination maps are listed in the destination map table.

Inserting Destination Maps

Use this page to manually add a destination map to the database. A Destination and Network Entity
must be provided when adding a Destination Map entry. The Destination value must match a name
of an existing Destination entry. The OK and Apply buttons are disabled until a character is entered
into either the Destination or Network Entity field.

Note: You can only perform this task when logged into the Active Primary SDS.
1. Select SDS > Configuration > Destination Map.
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The Destination Map page appears.
2. Click Insert.
The Destination Map [Insert] page appears.

3. Enter a Destination name in the Destination field. The name must match a Destination name that
has already been entered into the database.

4. Enter a E.164 address for the server node for the Network Entity in the Network Entity field.
5. Perform one of the following:

* C(lick OK to save the destination map and return to the Destinations Map page.
¢ Click Apply to save the destination map and remain on this page.
¢ Click Cancel to return to the Destinations Map page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

* Missing required information in the Destination field.

* Missing required information in the Network Entity field.

¢ Invalid characters in the Destination field.

¢ Only digits are allowed in the Network Entity field.

¢ The Network Entity field must contain at least eight digits.

* Destination not found.

* The Destination’s type must be IMSHSS to have a Destination Map entry.

Editing Destination Maps

Use this page to manually change an existing destination map in the database. The OK and Apply
buttons are disabled until a character is entered into either the Destination or Network Entity field.

You can only perform this task when logged into the Active Primary SDS.
Note: A service node must be provided when modifying a destination map.

1. Select SDS > Configuration > Destination Map.
The Destination Map page appears.

2. Locate the map you want to edit and click Edit.
The Destination Map [Edit] page appears.

3. Edit the E.164 address for the server node in the Network Entity field.
4. Perform one of the following;:
¢ Click OK to save the destination map and return to the Destination Map page.

¢ Click Apply to save the destination map and remain on this page.
¢ Click Cancel to return to the Destination Map page without saving the changes.

If OK or Apply is clicked and any of the following conditions exist, an error message appears:

* Missing required information in the Network Entity field.
* Only digits are allowed in the Network Entity field.
¢ The Network Entity field must contain eight digits.
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Deleting Destination Maps

This page allows you to manually delete a destination map from the database. A Destination Map
cannot be deleted while any IMSI or MSISDN routing entities remain associated with the destination.

Note: You can only perform this task when logged into the Active Primary SDS.

1. Select SDS > Configuration > Destination Map.
The Destination Map page appears.

2. Locate the map you want to delete and click Delete.
A popup confirmation window appears.

3. Perform one of the following actions:

¢ (lick OK to delete the map.
¢ Click Cancel to cancel the delete function and return to the Destination Map page.

If OK is clicked and any of the following conditions exist, and error message appears:

* Destination is in use by a route.

Routing entities configuration

The Routing Entities page allows you to manage the supported routing entities:

e IMSI

e MSISDN

e NAI User

e Wildcard NAI User Prefix
e IMSI Prefix

e MSISDN Prefix

Note: A routing entity can be a stand-alone routing entity or a routing entity that is part of a subscriber
(group of related routing entities and Account ID values).

From the SDS Configuration Routing Entities page, you can perform the following actions:

* Retrieve information for a specific Routing Entity.

¢ Add a supported Routing Entity.

¢ Update the information associated with an existing Routing Entity.
* Delete a Routing Entity.

Routing entities configuration elements
This table describes the fields on the Routing Entities Retrieve, Add, Update, and Delete tabs.

Table 8: Routing Entities Configuration Elements

Element Description Data Input Notes

Retrieve and Delete tabs
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Element

Description

Data Input Notes

Type

Type of supported routing entity

Format: pulldown list

Range: One of the following -
MSISDN, IMSI, NAI User,
Wildcard NAI User, MSISDN
Prefix, IMSI Prefix

Address (Except WC NAI User)

The routing entity address

Format: alphanumeric and
underscore

Range: Depends on Type

* MSISDN: 8-15 digits
e IMSI: 10-15 digits
e NAI User: 1-64 characters

e MSISDN Prefix and IMSI
Prefix: 1 - 15 digits

Address Prefix (WC NAI User
Only)

The routing entity address

Wildcard NAI User: 1-64
characters

NAI Host

NAI Host; available only when
NAI User or Wildcard NAI User
is selected as the Type It is not
visible when Type is MSISDN,
IMSI, MSISDN Prefix, or IMSI
Prefix.

Format: pulldown list

Range: available NAI Hosts

Add and Update tabs

Type

Type of supported routing entity

Format: pulldown list

Range: One of the following -
MSISDN, IMSI, NAI User,
Wildcard NAI User, MSISDN
Prefix, IMSI Prefix

Note: If Type is MSISDN or
IMSI on the Update tab and the
Address is part of a Subscriber
that has more than 1 MSISDN or
IMSI routing entity, the update
is automatically applied to all of
the subscriber’s MSISDN and
IMSI routing entities

Address (Except WC NAI User)

The routing entity address
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Element

Description

Data Input Notes

e MSISDN Prefix and IMSI
Prefix: 1 - 15 digits

Address Prefix (WC NAI User
Only)

The routing entity address

Wildcard NAI User: 1-64
characters

NAI Host NAI Host; available only when | Format: pulldown list
NAI User or Wildcard NAI User .
is selected as the Type It is not Range: available NAT Hosts
visible when Type is MSISDN,
IMSI, MSISDN Prefix, or IMSI
Prefix.
IMS HSS IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available IMS HSS
destinations
LTE HSS LTE HSS destination Format: pulldown list
(available on the Add tab only) Range: available LTE HSS
destination
PCRF IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available PCRF
destinations
OCSs IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available OCS
destinations
OfCS IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available OfCS
destinations
AAA IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available AAA
destinations
User defined 1 IMS HSS destination Format: pulldown list
(available on the Add tab only) Range: available User defined 1
destinations
User defined 2 IMS HSS destination Format: pulldown list

(available on the Add tab only)

Range: available User defined 2
destinations
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Retrieving routing entities

You can perform this task when logged into an SDS or from the DP SOAM GUIL

Before performing this task, make sure that Destinations and NAI Hosts have been configured.

1.

Select SDS > Configuration > Routing Entities.
The SDS Configuration Routing Entities page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

2. Select the type of routing entity from the Type pulldown list.

Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note: The Address field requirements depend on the type of blacklist routing entity. For more
information on this field, see Blacklist configuration elements.

If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

Click Retrieve.
When Retrieve is clicked and the following condition exists, an error message appears:

¢ If either MSISDN or IMSI was selected as the Type, and a non-digit character was entered.
¢ TField Address contains invalid characters.

Adding routing entities

You can only perform this task when logged into the Active Primary SDS.

Before performing this task, make sure that Destinations and NAI Hosts have been configured.

1.

Select SDS > Configuration > Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Add tab.

Select the type of routing entity from the Type pulldown list.

. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note: The Address field requirements depend on the type of blacklist routing entity. For more
information on this field, see Blacklist configuration elements.

If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

Select the associated destination(s) from the applicable destination(s) pulldown list.

At least one destination must be selected, although a destination can selected for each of the
destination types.

Click Add.
When Add is clicked and any of the following conditions exist, an error message appears:

¢ Either MSISDN or IMSI was selected as the Type and a non-digit character was entered.
e At least one destination was not selected.
¢ Field Address contains invalid characters.
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Updating routing entities

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Update tab.

8.

Select the type of routing entity from the Type pulldown list.

. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note: The Address or Address Prefix field requirements vary depending on the type of routing
entity. For more information on this field, see Routing entities configuration elements.

If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

Click Lookup.
Note: If the route was not located during the Lookup, an error message appears.

The Update tab appears with the routing entity information.

Edit the appropriate destination(s).

For more information about these fields, see Routing entities configuration elements.

' Important: Although atleast one destination is required when adding a routing entity,

there is no minimum requirement for destinations when updating the routing entity.
For example, all of the destinations could possibly be set to NONE.

Click Update.

Deleting routing entities

You can only perform this task when logged into the Active Primary SDS.

1.

Select SDS > Configuration > Routing Entities.
The SDS Configuration Routing Entities page appears.

2. Select the Delete tab.
3. Select the type of routing entity from the Type pulldown list.

4. Enter the route identifier for the routing entity in the Address or Address Prefix field.

Note: The Value field requirements depend on the type of identifier. For more information about
this field, see Subscribers elements.

If NAI User or Wildcard NAI User is selected as the Type, select a NAI host from the NAI Host
pulldown list.

If Type is MSISDN or IMSI and the Address is part of a Subscriber that has more than 1 MSISDN
and/or IMSI value, only the entered value is deleted (not all routing entities for the subscriber). If
you want to delete the whole subscriber, you must do this from the SDS > Configuration >
Subscriber [Delete].

If Type is MSISDN or IMSI and the Address is part of a Subscriber that has only 1 MSISDN or IMSI
value, the routing entity will not be deleted; the subscriber must be deleted.
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6. Click Delete.
A popup confirmation window appears.

7. Perform one of the following actions:

¢ (lick OK to delete the connection.

¢ C(Click Cancel to cancel the delete function and return to the SDS Configuration Routing Entities
page.

If OK is clicked and any of the following conditions exist, an error message appears:

¢ Either MSISDN or IMSI was selected as the Type and a non-digit character was entered in the
Route field

¢ The route identifier was not found.
e TField Address contains invalid characters.

Subscribers

SDS Subscriber Identity Grouping (Subscribers page) allows you to group a customer-specified account
ID, multiple MSISDN routing entities and multiple IMSI routing entities together into one Subscriber.
After a Subscriber (a group of related routing entities and an optional Account ID value) is created,
you can update destinations for all of the related routing entities, read all data from the subscriber
and delete the subscriber by using any of the subscriber’s addresses (for example, account ID, MSISDN,
or IMSI). You can also modify addresses within a subscriber by specifying any of the subscriber’s
addresses.

Restrictions

e This is a provisioning-only feature.

¢ The relationships between routing entities is only available on A-level servers, which are the SDS
servers and the Query server.

The following restrictions apply to all Subscribers that contain a group of related MSISDN and IMSI
routing entities and an optional Account ID. These rules do not apply to stand-alone routing entities.

¢ Every subscriber must have at least 1 routing entity (MSISDN or IMSI).
* All of the subscriber’s routing entities must have the same destination values.

* Every subscriber can be accessed by specifying any of its routing entity values or its Account ID
value.

* When you create a new subscriber, destinations are optional. If you do not specify a destination,
destinations are set based upon the existing routing entities.

* All provisioning commands are for a single subscriber. All specified accountid, imsi, and msisdn
values must be assigned to one subscriber or they can exist in a stand-alone routing entity.

From the Subscriber page, you can do the following:

* Retrieve information for a specific Subscriber.
¢ Create a Subscriber.

* Modify a previously defined Subscriber.

* Delete a selected Subscriber.
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Subscribers elements

Use the SDS Configuration Subscribers page to manage SDS Subscribers. This table describes fields
on this page.

Table 9: Subscribers Elements

Element Description Data Input Notes

Field Type of data in the Value field |Format: pulldown list
used to find desired Subscriber

(Account ID, MSISDN,, IMSI) One of the following - Account

ID, MSISDN, or IMSI
Default: Account ID

Value The value of the Account ID, Format: Integer
MSISDN or IMSI values for the

subscriber Range limits depends on Field

value:

* Account ID: 1-26 digits
e MSISDN: 8-15 digits

* IMSI: 10-15 digits

Default: blank

Retrieving subscribers

Use this process to retrieve information about a single Subscriber and all of the Subscriber's routing
entities.

You can perform this task when logged into an SDS or from the DP SOAM GUL
Before performing this task, make sure that Destinations have been configured.

1. Select SDS > Configuration > Subscribers.
The SDS Configuration Subscribers page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

2. Select the type of identifier from the Field pulldown list.
3. Enter the identifier for the subscriber in the Value field.

Note: The Value field requirements depend on the type of identifier. For more information about
this field, see Subscribers elements.

4. Click Retrieve.
When Retrieve is clicked and the following condition exists, an error message appears:

* A non-digit was entered for the Value field.
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Creating Subscribers

Use this process to create a new subscriber and group the specified MSISDN, IMSI, and Account ID
values into one Subscriber record. The specified MSISDN and IMSI values can be for existing stand-alone
or new MSISDN or IMSI routing entities. If the MSISDN or IMSI value does not exist as a stand-alone
routing entity, the routing entity is automatically added, and the MSISDN or IMSI value is added to
the Subscriber. All destination values from existing stand-alone routing entities must be the same
prior to applying the values that you enter on the Subscribers Create page.

Specifying destinations is optional. You can check the Inherit Destinations checkbox to inherit the
current destination values from a subscriber’s existing routing entity.

Before performing this task, make sure that Destinations have been configured.

If no MSISDN or IMSI values currently exist as a stand-alone entry, then at least one destination must
be provided.

At least one MSISDN or IMSI value must exist for the Subscriber.
1. Select SDS > Configuration > Subscribers.

The SDS Configuration Subscribers page appears.
2. Select the Create tab.

3. Enter an Account ID to associate a unique number to the Subscriber's account.

Note: This is an optional field and contains a value 1-26 digits in length.

4. Enter MSISDN values to associate MSISDNSs with the subscriber. Click Add, Remove, or Clear All
to implement your updates. A maximum of 6 MSISDNs are supported. At least one destination
must be provided when creating a new MSISDN or IMSIL.

5. Enter IMSI values to associate IMSIs with the subscriber. Click Add, Remove, or Clear All to
implement your updates. A maximum of 6 IMSIs are supported. At least one destination must be
provided when creating a new MSISDN or IMSL

6. Optionally, select Inherit Destination to inherit the current destination values from a subscriber’s
existing routing entity.

Note: If checked, all of the destination values are grayed out.

7. Select from any of the following pulldown lists to name one of each type of destination.

e IMS HHS

e LTE HSS

e PCRF

e OCS

e OfCS

e AAA

e User defined 1
e User defined 2

Modifying Subscribers

This page allows you to locate and modify a single Subscriber.
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Use this procedure to update the identification (MSISDN, IMSI, and Account ID) values for a Subscriber
and/or update the Subscriber’s destination values.

1.

Select SDS > Configuration > Subscribers.
The SDS Configuration Subscribers page appears.

Select the Modify tab.
The SDS Configuration Subscribers page appears.
Select the type of identifier from the Field pulldown menu (Account ID, MSISDN, or IMSI).

Enter one of the Account ID, MSISDN or IMSI values for the subscriber in the Value field. For more
information about this field, see Subscribers elements.

Note: The Value field requirements depend on the type of identifier data. For more information
about this field, see Subscribers elements.

Click Lookup.

If the Subscriber is located, this page will be populated with information previously defined for
the selected Subscriber. At least one MSISDN or IMSI value must exist for the Subscriber. For more
information about these fields, see Creating Subscribers.

Note: Destinations must be configured before you can enter a route using them.

Modify the fields on this page as needed.

Click Modify to complete the task.
A popup confirmation appears to complete the task.

Deleting Subscribers

Follow these steps to delete the Subscriber and all of the Subscriber’s routing entities.

Note: Global Data Delete permission is required for this function.

1.

Select SDS > Configuration > Subscriber.
The SDS Configuration Subscriber page appears.

2. Select the Delete tab.

Select the type of identifier data from the Field pulldown list.
Enter the identifier for the subscriber in the Value field.

Note: The Value field requirements depend onthe type of identifier. For more information about
this field, see Subscribers elements.

Click Delete.
A popup confirmation window appears.

Perform one of the following actions:

¢ Click OK to delete the Subscriber.

¢ Click Cancel to cancel the delete function and return to the SDS Configuration Subscriber
page.

After you press Delete, a warning dialog box is displayed that indicates that all associated MSISDNs
and IMSIs will also be deleted.
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Blacklist

The Blacklist function (Blacklist page) allows you to provision IMSI and MSISDN Blacklist values
that can be searched prior to searching the MSISDN or IMSI Routing Entities to determine if a value
is blacklisted.

Both MSISDN and IMSI blacklist data is supported in SDS/DP systems.
From the SDS Configuration Blacklist page, you can perform the following actions:

* Retrieve a previously defined blacklist value
¢ Add a new blacklist value
* Delete an existing blacklist value

Blacklist configuration elements

This table describes the fields on the Blacklist Retrieve, Add, and Delete tabs.

Table 10: Blacklist Configuration Elements

Element Description Data Input Notes
Type Type of routing entity to Format: pulldown list
blacklist Range: One of the following -
MSISDN or IMSI
Address The routing entity address Format: alphanumeric and
underscore

Range: Depends on Type

e MSISDN: 8-15 digits
e IMSI: 10-15 digits

Retrieving blacklist values

Follow these steps to retrieve a single MSISDN or IMSI Blacklist value. These are values that will not
be routed to a destination.

1. Select SDS > Configuration > Blacklist.
The SDS Configuration Blacklist page appears.

By default, the Retrieve tab is the viewable tab. If not, select the Retrieve tab.

2. Select the type of blacklist routing entity from the Type pulldown list.
3. Enter the route identifier for the routing entity in the Address field.

Note: The Address field requirements depend on the type of blacklist routing entity. For more
information on this field, see Blacklist configuration elements.

4. Click Retrieve.
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When Retrieve is clicked and the following condition exists, an error message appears:

¢ If a non-digit character was entered.

Adding blacklist values

Follow these steps to add a single MSISDN or IMSI Blacklist value. These are values that will not be
routed to a destination.

1. Select SDS > Configuration > Blacklist.
The SDS Configuration Blacklist page appears.

2. Select the Add tab.
3. Select the type of blacklist routing entity from the Type pulldown list.
4. Enter the blacklist route identifier for the routing entity in the Address field.

Note: The Address field requirements depend on the type of blacklist routing entity. For more
information on this field, see Blacklist configuration elements.

Note: .

5. Click Add.
When Add is clicked and any of the following conditions exist, an error message appears:

¢ If a non-digit character was entered.
¢ The value entered for the MSISSDN or IMSI value already exists in the routing entities table.

Deleting blacklist values

Follow these steps to delete a single MSISDN or IMSI Blacklist value.
Note: Global Data Delete permission is required for this function.

1. Select SDS > Configuration > Blacklist.
The SDS Configuration Blacklist page appears.

2. Select the Delete tab.
3. Select the type of blacklist routing entity from the Type pulldown list.
4. Enter the blacklist route identifier for the routing entity in the Address.

Note: The Value field requirements depend on the type of blacklist routing entity. For more
information about this field, see Blacklist configuration elements

5. Click Delete.
A popup confirmation window appears.

6. Perform one of the following actions:

* C(lick OK to delete the blacklist.
¢ Click Cancel to cancel the delete function and return to the SDS Configuration Blacklist page.

If OK is clicked and any of the following conditions exist, an error message appears:

¢ If a non-digit character was entered.
* The route identifier was not found.
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e Address contains invalid characters.
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The Maintenance menu options allow you to query
and audit data, view up-to-date status of the
database and various features, initiate import and
exports.

From the maintenance menu on an SDS you can:
* Query the database for specified:

e MSISDN

e MSISDN Prefix

e MSISDN Blacklist

e IMSI

e IMSI Prefix

e IMSI Blacklist

e NAI user

¢ Wildcard NAI user ranges

¢ View provisioning connections, command logs,
relay exception logs, and the status of imports
and exports

¢ Configure and manage NPA Splits

* Schedule exports

¢ Perform remote audits

When you are logged into an DP SOAM you cannot
request a remote audit, update splits, or schedule
an export on the DP SOAM GUL

The available menu options will vary based on the
type of server you are logged into and the

permissions assigned to your group. If you do not
see a menu option you need, please make sure you
are logged into the appropriate type of server and
ask your administrator to make sure the group your
user ID belongs to has the appropriate permissions.

The SDS Maintenance pages provide maintenance
information related to provisioning connections and
data. With this page you can monitor provisioning
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connections; view every provisioning message
exchanged between provisioning systems in the
command log, view the status of imports and
exports; open import and export files and import
result logs.

All provisioning maintenance tasks are only
available when logged into an SDS.
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The SDS -> Maintenance -> Connections page allows you to view the “currently in-use” external
connections. A list of all provisioning connections established to the system can be viewed. A display
filter can be applied for a specified search. The information is displayed in tabular format.

Any local connections (including the one from the GUI itself) are not included.

Connections maintenance elements

The SDS -> Maintenance -> Connections page displays information in a tabular format. Table 11:
Connections Maintenance Elements describes elements on the SDS -> Maintenance -> Connections

page.

Table 11: Connections Maintenance Elements

Field Definition Data Notes

Timestamp Time the connection was established | Format: Year-Month-Day
Hour-Minute-Second

CID Connection ID N/A

Remote IP IP address for the remote client Format: Valid IP address

Remote Port

Port used for the remote client
connection

Format: Valid port number

Version

Version of API this client application is
using

Default: 1.0

Cnx Manager

Connection manager

Options: Pdba, Xds, XmlImport,
XmlExport, PdbRelay, PdbAudit

Txn Mode

Database transaction mode

Range:

¢ normal: All updates must be
sent inside a transaction
explicitly begun and ended
by begin_txn and
end_txn/abort_txn requests
respectively.

¢ single: Transactions are
implicitly begun and ended
for individual update requests

Default: normal

Idle Timeout

Number of minutes the connection can
be idle before it is automatically timed
out.
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Range:

¢ 0 (the connection is never
terminated)
e 1 -44640 minutes
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Field Definition Data Notes
Default: 0

Viewing connections status

Use this task to view a list of information of all provisioning connections established to the system.
The listing of connections may be filtered.

1. Select SDS > Maintenance > Connections.

The SDS Maintenance Connections page appears. All provisioning connections are displayed in
tabular form. The fields are described in Connections maintenance elements.

2. Select the category by which to perform the filtering.

Table 12: Connection Status filtering categories

Category Desscription

Timestamp Time the connection was established.

CID The Connection ID to filter on.

Remote IP IP address for the remote client.

Remote Port Port used for the remote client connection.

Version Version of API this client application is using.

Txn Mode Database transaction mode.

Idle Timeout Number of minutes the connection can be idle before it is
automatically timed out.

3. Choose the filtering operator.

Table 13: Connection Status filtering operators

Operator Description

= Is equal to

I= Is not equal to

> Is greather than

>= Is equal to or greater than

< Is less than

<= Is equal to or less than

Like Is Like (wildcard is * character)
Is Null has no entry (is zero)
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4. Enter the target character string to filter on in the text box.

5. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 14: Connection status refresh time

Maintenance

Time Description
15 15 seconds
30 30 seconds
Off Off (default)

6. Click Go to show results.

Command Log maintenance

The SDS -> Maintenance -> Command Log page shows a table that contains a history of commands
and their responses. This table shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI.

Every provisioning message exchanged between provisioning systems is written to the command log
and is stored for up to seven days.

Command Log maintenance elements

The SDS -> Maintenance -> Command Log page displays information in a tabular format. This table
describes elements on the SDS -> Maintenance -> Command Log page.

Table 15: Command Log Maintenance Elements

Element Description

Timestamp Date and time the command was logged
System ID System identifier of the originating client
CID Client connection identifier

Text Exact command and response message

Viewing maintenance command logs history

Use this task to view a list of information of a history of commands and their responses. The history
is displayed as a table that shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI. The history may be filtered by

category.

Note: You can use Max entries to display to control the total number of entries displayed on the page.
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1. Select SDS > Maintenance > Command Log.
The SDS Maintenance Command Log page appears.

2. Select the category by which to perform the filtering.

Table 16: Command Log filtering categories

Category Description

None Show all commands

System ID equal to... A hidden text box becomes visible for you to enter the System
ID to filter on.

CID equal to... A hidden text box becomes visible for you to enter the

Connection ID to filter on.

Log text contains...

A hidden text box becomes visible for you to enter one or more
keywords to filter on.

Error responses

Shows all commands with error responses.

Time range...

When selected, hidden select boxes for “From” and “To” times
become visible for you to enter the time range to filter on.

3. Click Display to show results.

When results are filtered, the highlighted text RESULTS FILTERED is displayed at the bottom of

the results.

Relay Exception Log

The SDS -> Maintenance -> Relay Exception Log page shows a table that contains all types of
exceptions (unexpected results) that are found while processing SDS to HLRR relay or export
functionality. Consequently, all fields do not always contain data. All entries in the Relay Exception
Log contain enough data so that you can determine what SDS data caused the exception.

Ideally, the Relay Exception Log would be empty, which means that SDS has all of the data required
to create an HLRR provisioning command and all of the required Network Entities are provisioned
for HLR Router. Because the most likely cause of an error would be associated with relaying new
provisioning commands to HLRR, the Relay Exception Log displays column headings for exceptions
created by pdbrelay. Deviations for other creators are described below:

¢ If no command is relayed to HLRR, the Derived Relay Request value will be None.

¢ If the Creator value is not equal to pdbr el ay, the Derived Relay Request value from the SDS
Command Log section will be blank.

Relay Exception Log maintenance elements

The SDS -> Maintenance -> Relay Exception Log page displays information in a tabular format. This
table contains a list of exceptions found while processing data that should be relayed from SDS to

HLRR.
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Note: Display limit must be a numeric integer greater than zero.

The following table describes elements on the SDS -> Maintenance -> Relay Exception Log page.

Table 17: Exception Log Maintenance Elements

Element Description

Timestamp Date and time when the exception occurred
Seq Num Exception sequence number

Creator Name of process that created the exception
Reason Reason that the exception was created

Derived Relay Request Command created and relayed to HLR Router
Command Command text from the SDS Command Log
Seq Num Sequence number form the SDS Command Log
Timestamp Timestamp from the SDS Command Log

Viewing exception logs history

Use this task to view a list of information of a history of commands and their responses. The history
is displayed as a table that shows the Timestamp, System ID, CID, and the Text of the commands
received from both remote and local connections, including the GUI. The history may be filtered by

category.

Note: You can use Max entries to display to control the total number of entries displayed on the page.

1. Select SDS > Maintenance > Relay Exception Log.
The SDS Relay Exception Log page appears.

2. Select the category by which to perform the filtering.

Table 18: Relay Exception Log filtering categories

Category

Description

None

Show all commands

Exception Seq Num equal to...

A hidden text box becomes visible for you to enter the
Exception Sequence Number to filter on.

Exception Creator equal to...

A hidden text box becomes visible for you to enter the
Exception Creator to filter on.

Exception Reason text contains...

A hidden text box becomes visible for you to enter one or more
Exception Reasons keywords to filter on.

Exception Time range...

When selected, hidden select boxes for “From” and “To” times
become visible for you to enter the time range to filter on.

Command text contains...

A hidden text box becomes visible for you to enter Command
text to filter on.
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3. Click Display to show results.

When results are filtered, the highlighted text RESULTS FILTERED is displayed at the bottom of
the results.

Import Status maintenance

Allows an operator to view the status of all Imports.

Data can be imported from a provisioning import file to add new, or update existing, data in the
database. Imports are not scheduled through the user interface but import settings are configured
with the provisioning options page.

Import files that are placed in a specific location on a remote server (Remote Import Directory) are
detected within five minutes and automatically downloaded via SSH File Transfer Protocol (SFIP) to
the file management storage area. For a file to be imported, it must:

* be properly named following the naming convention. For more information see the SDS
Administration Manual.
* have been placed in the remote directory after the time when provisioning import last ran

* must not have been previously imported. A file that has already been imported into the local
directory will not be imported again, even if its status is Failed.

Note: To import a previously Failed file, correct the file as necessary, rename the file, and then

place the renamed file in the remote directory.

Once fully downloaded, each file is automatically imported into the Provisioning Database sequentially
in the order in which their download completed. The provisioning import file is an ASCII text file that
contains a series of database manipulation requests in provisioning format.

The SDS Maintenance Import Status page allows you to view the status of provisioning imports.
Import records with a status of Completed or Failed can be deleted from this table.

Import Status maintenance elements

The SDS -> Maintenance -> Import Status page displays information in a tabular format. Table 19:
Import Status Maintenance Elements describes elements on the SDS -> Maintenance -> Import Status

page.

Table 19: Import Status Maintenance Elements

Field Description

Action Allows user to delete import file entries.
Import File Name of import file

Time Queued Time the import was queued

Time Started Time the import started

Time Completed Time the import completed
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Field Description

Progress Percentage of import progress

Result Log Name/heading of result log

Pass Count The number of successful import commands
Fail Count The number of unsuccessful import commands
Status Status of the import

Viewing import files

This task allows you to view the status of all Imports. Imports are not scheduled through the GUL
They are initiated by the presence of a file placed in the Remote Import Directory.

¢ If the filename in the Import File or Result Log column exceeds 24 characters, it is truncated at 22

uor

characters and the characters “...
the filename was truncated.

are appended to the end of the truncated string to signify that

¢ The filenames in both the Import File or Result Log columns are hyperlinks. You can click on the
links to view the files as text or to save them locally.

* You cannot edit an imported file using this form.

* You may delete an Import Status record if the Status is Completed, or Failed.

1. Select SDS > Maintenance > Import Status.

The SDS Maintenance Import Status page appears. All provisioning connections are displayed
in tabular form. The display fields are described in Import Status maintenance elements.

2. Select the category by which to perform the filtering.

Table 20: Import Status filtering categories

Category

Description

Time Queued

Time the import was queued

Time Started

Time the import started

Time Completed Time the import completed

Progress Percentage of import progress

Pass Count The number of successful import commands
Fail Count The number of unsuccessful import commands
Status Status of the import

3. Choose the filtering operator.

910-6552-001 Revision A, September 2013

53



Table 21: Connection Status filtering operators

Maintenance

Operator Description

= Is equal to

I= Is not equal to

> Is greater than

>= Is equal to or greater than

< Is less than

<= Is equal to or less than

Like Is Like (wildcard is * character)
Is Null has no entry (is zero)

Table 22: Connection status refresh time

4. Enter the target character string to filter on in the text box.
5. Use Auto Refresh to select the time interval for the status to be refreshed.

Time Description
15 15 seconds
30 30 seconds
Off Off (default)

6. Click Go to show results.
7. To delete an import record, click on the associated Delete link.

Note: The import record can only be deleted if the Status is Completed, or Failed.

A confirmation dialog to complete the delete action appears. For all other imports, the Delete action
is inactive (grayed-out).

Export maintenance

Provisioning data can be exported to an ASCII file in either XML or CVS format using the application
user interface. The SDS Maintenance Export pages allow you to view the status, progress, and data
count information for scheduled provisioning exports. You may use exported records to do data
manipulation of subscriber data.

Note: Export is a time consuming operation recommended to be scheduled during off-peak hours.
SDS operators can schedule one-time or recurring exports.
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Exported data may also be offloaded to a remote server. The exported text file is also available to be
downloaded from the ‘file transfer area’. Export is a periodic task. Any changes done to export table
shall take effect on next export period. The following is the functionality of Export:

* You can configure and schedule data export on a daily, weekly or monthly basis.
* The exported files will be sFTPed or transferred via SSH to a server configured on SDS.
¢ Data can be exported to a file in XML commands or CSV format.

* You can export subscriber data (in XML or CSV format) as shown in Table 23: Interfaces for Subscriber
Data Types:

Table 23: Interfaces for Subscriber Data Types

Subscriber |GUI (add, |[SOAP XML Export | CSV Export [ SQL Query | HLRR
Data Type [change, and/or XML [ and Import | and Import | (from Query
delete and | (add, Server)
query) change,
delete and
query)
MSISDN yes yes yes yes yes yes
IMSI yes yes yes yes yes yes
NAI User |yes yes yes yes yes no
Wildcard | yes no no yes yes no
NAI User
NAI Host |yes no no yes yes no
Destination |yes no no yes yes no
Destination | yes no no no yes no
Map
MSISDN yes no no yes yes no
Prefix
IMSI Prefix |yes no no yes yes no
MSISDN yes no no yes yes no
Blacklist
IMSI Prefix |yes no no yes yes no
Subscriber | yes yes yes yes yes no
Schedule

The SDS -> Maintenance -> Export -> Schedule page displays information in a tabular format for all
exports scheduled for this system.
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Export Schedule maintenance elements

Table 24: Export Schedule Maintenance Elements describes elements on the SDS -> Maintenance -> Export
-> Schedule page.

Table 24: Export Schedule Maintenance Elements

Field Description

Action Edit or Delete scheduled export

Identifier Name of export file

File format Format of the export file (CSV, XML, or HLRR)
Export Data Type of data to export

First Export The first time this export is scheduled to run
Next Export The next time this export is scheduled to run
Repeat How often to repeat export

Comment Purpose of export

Additionally, you can insert an export schedule by clicking on the [Insert] button on the page.

Viewing export schedule
The SDS -> Maintenance -> Export -> Schedule page shows the scheduled exports for this system.
1. Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears. All exports are displayed in tabular form.
The display fields are described in Export Schedule maintenance elements.

¢ (lick on the [Insert] button, located on the bottom of the page, to insert a new export schedule.
¢ (lick Edit in the Action column on an export record to edit that export.
¢ C(lick Delete in the Action column on an export record to delete that export.

2. Select the category by which to perform the filtering.

Table 25: Export Schedule filtering categories

Field Description

Identifier Name of export file

File format Format of the export file (CSV, XML, or HLRR)
Export Data Type of data to export

First Export The first time this export is scheduled to run
Next Export The next time this export is scheduled to run
Repeat How often to repeat export
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Field

Description

Comment

Purpose of export

Choose the filtering operator.

Table 26: Export Schedule filtering operators

Operator Description

= Is equal to

I= Is not equal to

> Is greather than

>= Is equal to or greater than

< Is less than

<= Is equal to or less than

Like Is Like (wildcard is * character)
Is Null has no entry (is zero)

4. Enter the target character string to filter on in the text box.

5.

Click Go to show results.

Inserting an export schedule

The SDS -> Maintenance -> Export -> Schedule [Insert] page allows you to create an export for this
system.

The field or fields highlighted in yellow are keys and must be unique within this table in order to be
successful. Fields marked with a red asterisk (*) require a value.

1.

4. Use the radio buttons csv, xml or hlrr to choose the File Format of the export file.

Select SDS -> Maintenance -> Export -> Schedule.

The SDS Maintenance Export Schedule page appears.

Click on the [Insert] button located on the bottom of the page.

The SDS Maintenance Insert Export Schedule page appears.

Enter an identifying string for the scheduled export in the Identifier text box.

The identifier must be 4 to 12 characters.

From the Export Data drop down list, select the type of data to be exported.

The available type data selections are csv or xml file format.
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Table 27: Export Data Types

Type of Data csv Format xml Format hlrr Format
All all formats listed all formats listed all formats listed
MSISDN X X X

MSISDN Blacklist X

MSISDN Prefix X

IMSI X X X

IMSI Blacklist X

IMSI Prefix X

NAI User X X

Wildcard NAI User X

NAI Host X

Destinations X

Subscribers X X

Note: For HLRR-formatted exports of "All" data, a pop-up appears warning that, because of updates
to the PDB Relay Timestamp, the HLRR-formatted exports must only be run as part of the HLR
Router Bulk Load Procedure.

Note: For HLRR-formatted exports of "All" data, the PDB Relay feature must be disabled before
an export will succeed.

Use the appropriate drop down list to select the initial date at which this export should run.
Use the appropriate drop down list to select the initial time at which this export should run.
Use the appropriate drop down list to select how often this export should be repeated.

© ® N

In the Comment text box, enter text that may be used to describe the purpose of this export.

Note: You can enter up to 255 characters for a comment.

10. Perform one of these actions:

¢ Click OK. If field validations succeed, the new export is saved and the previous page appears.
If the page contains any values that are not valid, or if a required field is empty, an error message
appears.

¢ Click Apply. If field validations succeed, the new export is saved and you remain on the same
page.
¢ Click Cancel to abort changes on this page and return to the previous page.

Editing an export schedule

The SDS -> Maintenance -> Export -> Schedule [Edit] page allows you to manually change an existing
export job by editing an entry in the Export Schedule.
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The field or fields highlighted in yellow are keys and must be unique within this table in order to be
successful. Fields marked with a red asterisk (*) require a value.

1.

Select SDS -> Maintenance -> Export -> Schedule.
The SDS Maintenance Export Schedule page appears.

Click Edit in the Action column of the export record to be edited.
The SDS Maintenance Edit Export Schedule page appears.

Enter an identifying string for the scheduled export in the Identifier text box.

The identifier must be 4 to 12 characters.

4. Use the radio buttons csv, xml or hlrr to choose the File Format of the export file.

© ® NS

From the Export Data drop down list, select the type of data to be exported.

The available type data selections are csv and xml file format.

Table 28: Export Data Types

Type of Data csv Format xml Format hlrr Format
All all formats listed all formats listed all formats listed
MSISDN X X X

MSISDN Blacklist X

MSISDN Prefix X

IMSI X X X

IMSI Blacklist X

IMSI Prefix X

NAI User X X

Wildcard NAI User X

NAI Host X

Destinations X

Subscribers X X

Use the appropriate drop down list to select the initial date at which this export should run.
Use the appropriate drop down list to select the initial time at which this export should run.
Use the appropriate drop down list to select how often this export should be repeated.

In the Comment text box, enter text that may be used to describe the purpose of this export.

Note: You can enter up to 255 characters for a comment.

10. Perform one of these actions:
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¢ Click OK. If field validations succeed, the new export is saved and the previous page appears.
If the page contains any values that are not valid, or if a required field is empty, an error message
appears.

¢ Click Apply. If field validations succeed, the new export is saved and you remain on the same
page.
* (lick Cancel to abort changes on this page and return to the previous page.

Deleting an export schedule

The SDS -> Maintenance -> Export -> Schedule [Delete] page allows you to manually delete an
export job by deleting an entry from the Export Schedule Table.

1. Select SDS -> Maintenance -> Export -> Schedule.
The SDS Maintenance Export Schedule page appears.

2. Click Delete in the Action column of the export record to be deleted.
A confirmation dialogue box opens, "Are you sure you want to delete this row?"

¢ Click OK to confirm the action to delete the export record and return to the SDS -> Maintenance
-> Export -> Schedule page.

¢ C(Click Cancel to abort the delete action and return to the SDS -> Maintenance -> Export ->
Schedule page.

Status

The SDS -> Maintenance -> Export -> Status page displays information in a tabular format and shows
all in-progress and completed scheduled exports in this system.

Export Status maintenance elements

Table 29: Export Status Maintenance Elements describes elements on the SDS -> Maintenance -> Export
-> Status page.

Table 29: Export Status Maintenance Elements

Field Description

Export File Name of export file

Time Queued Time the export was queued

Time Started Time the export started

Time Completed Time the export completed
Subscribers Number of exported Subscribers
MSISDNs Number of MSISDNS exported
IMSIs Number of IMSIs exported

MSISDN Prefix Number of MSISDI Prefixes exported
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Field Description

IMSI Prefix Number of IMSI Prefixes exported

MSISDN Blacklist Number of MSISDI Blacklists exported

IMSI Blacklist Number of IMSI Blacklists exported

NAI Hosts Number of NAI Hosts exported

NAI Users Number of NAI Users exported

Wildcard NAIs Number of Wildcard NAIs exported

Destinations Number of Destinations exported

Status Status of export

Comment Descriptive text about export. This field is
optional, so it may be blank.

Viewing export status

The SDS -> Maintenance -> Export -> Status page shows the status of all in-progress and completed
scheduled exports for this system.

If the filename in the Export File column exceeds 24 characters, it is truncated at 22 characters and

uor

the characters “...” are appended to the end of the truncated string to signify that the filename was
truncated.

The filenames in the Export File column are hyperlinks. You can click on the links to view the files
as text or to save them locally.

You can not modify or delete an export record using this form.
Records are automatically removed after 7 days.

Select SDS -> Maintenance -> Export -> Status.

The SDS Maintenance Export Status page appears. All exports are displayed in tabular form. The
display fields are described in Export Status maintenance elements.

Select the category by which to perform the filtering.

Table 30: Export Status filtering categories

Category Description

Time Queued Time the import was queued

Time Started Time the import started

Time Completed Time the import completed
Subscribers Number of Subscribers exported
MSISDNs Number of MSISDNS exported

IMSIs Number of IMSIs exported

MSISDN Prefix Number of MSISDN Prefixes exported
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Category Description

IMSI Prefix Number of IMSI Prefixes exported

MSISDN Blacklist Number of MSISDN Blacklists exported

IMSI Blacklist Number of IMSI Blacklists exported

NAI Hosts Number of NAI Hosts exported

NAI Users Number of NAI Users exported

Wildcard NAIs Number of Wildcard NAls exported

Destinations Number of Destinations exported

Status Status of export

Comment Descriptive text about export. This field is
optional, so it may be blank.

3. Choose the filtering operator.

Table 31: Export Status filtering operators

Operator Description

= Is equal to

1= Is not equal to

> Is greater than

>= Is equal to or greater than

< Is less than

<= Is equal to or less than

Like Is Like (wildcard is * character)
Is Null has no entry (is zero)

4. Enter the target character string to filter on in the text box.
5. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 32: Export status refresh time

Time Description
15 15 seconds
30 30 seconds
Off Off (default)

6. Click Go to show results.
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Remote Audit

The SDS Maintenance Remote Audit menu option allows you to access an on-demand ability to
initiate an audit of the remote HLR Router provisioning database and flag any differences found
between the SDS and the HLR Router databases. This provisioning database audit includes MSISDNss
and, IMSIs and their associated Network Entity address values, which are extracted from the Destination
Map table.

When you submit an audit request on the SDS GUI maintenance page, a PDBI client called pdbaudit
connects to the local PDBA and to the remote PDBA running on the HLR Router system. It sends
request commands to both PDBAs, compares the response data, and reports any discrepancies between
the two databases. Then you can check the status and review the results of the audit on the SDS GUI
status page.

SDS supports manual audit runs between the SDS master data base instance and the HLR Router data
base instance. Configurable automated audit runs are those runs that run at configured times to verify
the accuracy of SDS master and HLR Router data base instances. A manual audit allows specification
of audit between SDS master and HLR Router data base instances, based on some data range (for
example, audit IMSI range) or single MSISDN or IMSI value.

SDS supports an on-demand ability to initiate an audit of the remote HLR Router provisioning database
and flag any differences found between the SDS and the HLR Router databases. HLR Router
provisioning data to be audited can be specified in one of two ways - by a single range of numbers,
or by an input file containing multiple ranges of numbers. Using an input file allows an operator to
specify multiple IMSI and MSISDN ranges at one time versus scheduling multiple remote HLR Router
audits on a single range.

Use the following tabs to view the status of the database remote audits and to request a site-wide
database audit of a specified subset of provisioning data:

¢ The Remote Audit Status tab allows you to view all pending, completed, and failed database
remote audits of data performed throughout the system.

* The Remote Audit Request tab allows you to request a remote audit between SDS and HLR Router
data using a subset of MSISDN or IMSI values.

Since each node is responsible for managing its own resources, some nodes may decide to delay
or cancel the requested audit in order to maintain sufficient resources to process signaling traffic.

Remote Audit elements

The SDS Maintenance Remote Audit page consists of two tabs: Status and Request. Each tab contains
their own associated elements described in Table 33: Remote Audit Request Elements and Table 34: Remote
Audit Status Elements.

Table 33: Remote Audit Request Elements

Element Description
Data Type Type of audit; MSISDN or IMSL
Audit By Audit type; Range or File.
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Element

Description

Start of Range

request.

Starting address of data to be included in this audit

End of Range

Ending address of data to be included in this audit
request. This field is optional.

Input File

in this audit.

File that contains ranges of values to be included

Note: You can type 80 or more characters, but only
80 character file names are supported.

Comment

optional.

Optional text used to provide information about
the audit. For example, an explanation of the
purpose or the audit owner's name. This field is

Table 34: Remote Audit Status Elements

Element Description Description
Action Available actions. Format: Selectable word
Type Type of data being audited. Format: MSISDN or IMSI
Range/File Range of data being audited or | Format: Digits only
file name that contains ranges of . .
data being audited. Range: 8 - 15 digits for MSISDN
Range: 10 - 15 for IMSI
Remote IP IP address for Remote HLR Format: Digits only

Router system used for auditing.

Range: 8 - 15 digits for MSISDN
Range: 10 - 15 for IMSI

Remote Port

Port for Remote HLR Router
system used for auditing.

Format: Digits only

Start Time/Completion Time

Date and time audit started and
completed.

Format: Time notation

State

Current state of the Remote
audit.

Format: Alpha

* Submitted
¢ Queued

¢ InProgress
e Aborting

e Aborted

¢ Failed

¢ Completed

Audited

Total number of records audited.

Format: Digits
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Element

Description

Description

Same

Number of matched records on
both SDS and the Remote HLR
Router system.

Format: Digits

Diff

Number of mismatched records
between SDS and Remote HLR
Router system.

Format: Digits

Missing

Number of SDS records that are
missing on the Remote HLR
Router system.

Format: Digits

Extra

Number of HLR Router records
that are missing on the local SDS
system.

Format: Digits

Unknown

Number of records in SDS
and/or HLR Router on which a
retrieve data command timed
out.

Format: Digits

Errors

Number of errors that occurred
during the audit. See trace log
for more information.

Format: Digits

Report

Name of generated remote audit

report

Format: Alphanumeric

Viewing the status of a remote audit

The SDS -> Maintenance -> Remote Audit page allows you to view all pending, completed, and

failed remote database audits of data performed throughout the system.

1. Select SDS -> Maintenance -> Remote Audit.
The SDS Maintenance Remote Audit page appears.

2. Select the Status tab.

The SDS -> Maintenance -> Remote Audit page appears. All audits are displayed in tabular form.
The display fields are described in Remote Audit elements.

3. Select the category by which to perform the filtering.

4. Choose the filtering operator.

Table 35: Remote Audit filtering operators

Operator Description

= Is equal to

I= Is not equal to
> Is greater than
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Operator Description

>= Is equal to or greater than

< Is less than

<= Is equal to or less than

Like Is Like (wildcard is * character)
Is Null Has no entry (is zero)

5. Enter the target character string to filter on in the text box.
6. Use Auto Refresh to select the time interval for the status to be refreshed.

Table 36: Remote Audit display refresh time

Time Description
15 15 seconds
30 30 seconds
Off Off (default)

7. Click Go to show results.

Requesting a remote audit

You can use this task to request a site-wide remote database audit of a specified subset of MSISDN,
IMSI, NAI User or Wildcard NAI User data. The request is sent to all nodes and the results are merged
back up to SDS. Because each node is responsible for managing its own resources, some nodes might
decide to delay or cancel the requested audit in order to maintain sufficient resources to process
signaling traffic.

Note: A valid input file name can be up to 80 characters in length.

1. Select SDS -> Maintenance -> Remote Audit.
The SDS Maintenance Remote Audit page appears.
2. Select the Request tab.
3. Select the type of data you want included in the audit from the Data Type pulldown list.

If you select NAI User or Wildcard NAI User, go to Step 5.

4. Select a range for Audit By, enter data in the following fields:

* Start of Range field: Starting address of data to be included in this audit. This must be between
8 and 15 digits for MSISDN or 10-15 for IMSI.

* End of Range field: Ending address of data to be included in this audit. This is an optional field
that, if used, must be between 8 and 15 digits for MSISDN or 10-15 for IMSL

5. Provide the file name that contains ranges of values to be included in this audit.
6. Enter any text about the audit you want to include in the Comment field, if needed.
7. Click Request.
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The database audit request is made. The status of the request can be viewed on the SDS -> Maintenance

-> Remote Audit page.

Query

The SDS Maintenance Query page allows you to query database information for a single provisioning
database entry, or for a range of the same type of provisioning database entries, on an available server.
Any server that hosts a copy of the provisioning database can be used. Query options include MSISDN,
IMS]I, Destination, NAI Host, NAI User, Wildcard NAI User, Counts, Counts by Destination, and DB

Level.

Querying a server for provisioning data allows you to see if data is being replicated correctly to each
server, and allows you to see if adjustments to data management or to the subscriber database need

to be made.

Query elements

The SDS Maintenance Query page consists of query entry dialogue boxes and results display. Not
all elements of the entry dialogue boxes or query results may be used once the "Data" type is selected.
All elements available through Query entry dialogue boxes are presented in Table 37: Query Entry
Elements. All elements available through Query results display, in alphabetical order, are presented

in Table 38: Query Results Elements.

Table 37: Query Entry Elements

Element Description Data Input Notes
Data Type of data to include in query | Format: Drop down list
Range: MSISDN, IMSI, MSISDN
Prefix, IMSI Prefix, MSISDN
Blacklist, IMSI Blacklist, NAI
Host, NAI User, Wildcard NAI
User, Destination, Counts,
Counts by Destination, DB Level
Default: MSISDN
Start Address Starting address of data to be | Format: Digits only
included in this query (applies Range: 8 - 15 digits for MSISDN
to MSISDN, IMSI, MSISDN .
. . or MSISDN Blacklist, 10 - 15 for
Prefix, IMSI Prefix, MSISDN .
Blacklist and IMSI Blacklist IMSI or IMS Blacklist, 1 - 15 for
MSISDN or IMSI Prefix
query requests only)
End Address Ending address of data to be Format: Digits only

included in this query (applies
to MSISDN, IMSI, MSISDN
Prefix, IMSI Prefix, MSISDN
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Element Description Data Input Notes
Blacklist and IMSI Blacklist Default: blank
query requests only)
NAI Host NAI Host to query applies to [ NAI Host defaults to the first
NAI users only one configured in the table.
Server Server on which to run the query | Format: Alphanumeric

Range: up to 35 characters

Default: local server

Table 38: Query Results Elements

Result Element

Description

Data Value Selected

AAA

AAA Destination record (with
type= aaa) or blank for none

MSISDN, IMSI, NAI User,
Wildcard NAI User, MSISDN

digits identifying the MSISDN
Blacklist value

Prefix, IMSI Prefix

Destination(s) Unique text used to identify a | Counts, Counts by Destination
Destination

FQDN A 1-255 character string for the | Destination
Diameter FQDN for the
Destination. The value can be
null

Host A unique string of 1 -64 NAI User, Wildcard NAI User,
characters for NAI Host Name. | NAI Host

IMSI(s) A unique string of 10-15 decimal | IMSI, Counts, Counts by
digits identifying the IMSI Destination

IMSI Blacklist A unique string of 10-15 decimal | IMSI Blacklist, Counts
digits identifying the IMSI
Blacklist value

IMSI Prefix A unique string of 1-15 decimal | IMSI Prefix, Counts, Counts by
digits identifying the IMSI Prefix | Destination

IMSHSS IMS HSS Destination record MSISDN, IMSI, NAI User,
(with type= imsHss) or blank for | Wildcard NAI User, MSISDN
none Prefix, IMSI Prefix

LTEHSS LTE HSS Destination record MSISDN, IMSI, NAI User,
(with type= lteHss) or blank for | Wildcard NAI User, MSISDN
none Prefix, IMSI Prefix

MSISDN(s) A unique string of 8-15 decimal [ MSISDN, Counts, Counts by
digits identifying the MSISDN [ Destination

MSISDN Blacklist A unique string of 8-15 decimal | MSISDN Blacklist, Counts
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Result Element

Description

Data Value Selected

MSISDN Prefix A unique string of 1-15 decimal | MSISDN Prefix, Counts, Counts
digits identifying the MSISDN | by Destination
Prefix
NAI Host Number of NAI hosts Counts
NAI User A string of 1-64 characters for the | NAI User, Counts, Counts by
NAI User Name Destination
Name A unique string of 1-32 Destination
characters to identify the
Destination
OCs OCS Destination record (with | MSISDN, IMSI, NAI User,
type= ocs) or blank for none Wildcard NAI User, MSISDN
Prefix, IMSI Prefix
OfCS OFCS Destination record (with | MSISDN, IMSI, NAI User,
type= ofcs) or blank for none Wildcard NAI User, MSISDN
Prefix, IMSI Prefix
PCRF PCRF Destination record (with | MSISDN, IMSI, NAI User,
type= pcrf) or blank for none | Wildcard NAI User, MSISDN
Prefix, IMSI Prefix
Realm A 1-255 character string for the | Destination
Diameter Realm for the
Destination. The value can be
null
Type Destination type Destination
USERDEF1 UserDef1 Destination record MSISDN, IMSI, NAI User,
(with type= userDefl) or blank | Wildcard NAI User, MSISDN
for none Prefix, IMSI Prefix
USERDEF2 UserDef2 Destination record MSISDN, IMSI, NAI User,
(with type= userDef2) or blank | Wildcard NAI User, MSISDN
for none Prefix, IMSI Prefix
Wildcard NAI User A string of 1-64 characters for the | Wildcard NAI User, Counts,
wild carded NAI User Name. | Counts by Destination
DB Level Numeric value of Database level | DB Level

Running a query (MSISDN, IMSI, MSISDN Prefix, IMSI Prefix, MSISDN Blacklist,
IMSI Blacklist)

Use this task to query a single (or range of) MSISDN, IMSI, MSISDN Prefix, IMSI Prefix, MSISDN
Blacklist, IMSI Blacklist values on any server within the system.

1. Select SDS > Maintenance > Query.
The SDS Maintenance Query page appears.
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Select a value from the Data pulldown list.

Enter the starting address of data to be included in this query in the Start Address field.
Enter the ending address of data to be included in this query in the End Address field.
Select the server you want to run the query on in the Server pulldown list.

Click Query.

The query is run and any relevant data is displayed on the page. See Table 38: Query Results Elements.

Running a query (NAI User)

You can use this task to query all of the NAI Users on any host and server within the server within
the system.

1.

ANl

Select SDS > Maintenance > Query.
The SDS Maintenance Query page appears.

Select NAI User from the Data pulldown list.

Select the NAI Host to be included in this query in the NAI Host field.
Select the server you want to run the query on in the Server pulldown list.
Click Query.

The query is run and any relevant data is displayed on the page. See Table 38: Query Results Elements.

Running a query (Wildcard NAI User, NAI Host, Destination, Counts, Counts by
Destination, or DB Level)

You can use this task to query all of the following:

Wildcard NAI User

NAI Host

Destination

Counts

Counts by Destination Users on any server within the system
Select SDS > Maintenance > Query.

The SDS Maintenance Query page appears.

Select one of the following from the Data pulldown list:

¢ Wildcard NAI User

e NAI Host

¢ Destination

¢ Counts

¢ Counts by Destination
e DB Level

Select the server you want to run the query on in the Server pulldown list.
Click Query.

The query is run and any relevant data is displayed on the page. See Table 38: Query Results Elements.
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NPA Splits maintenance

Use this selection when you want to manage an NPA split in advance of a Permissive Dialing Period.

NPA Split refers to the telephone-numbering scheme that subdivides an old area code (old NPA) by
the creation of a new area code (new NPA). This is necessary when the number of telephones in an
old area code (old NPA) grows to an excessive number. As new area codes are defined (new NPA),
some existing exchanges (NXX) may be assigned to the new area code (new NPA) from the old area
code (old NPA).

The split is in the Pending state until it becomes Active on the Start date of the PDP. While in the
Active state, Dialed Numbers (DN) in the split's NXX can use either the old NPA or the new NPA.
After the split becomes complete on the End date of the PDP, only the new NPA can be used in a DN.

To manage NPA splits through the GUI, you must have group permission access to NPA Splits and
NPA Split Maintenance.

NPA Splits elements

Use the SDS Maintenance NPA Splits page to manage NPA splits. This table describes fields on this
page.

Table 39: NPA Splits Maintenance Elements

Element Description Data Input Notes
Old NPA The Numbering Plan Area that | Format: Integer
the DNs will be split from. Range: 200 - 999, 3-digit number

(Retrieve splits in which this
NPA was the old NPA) Default: blank

New NPA The Numbering Plan Area that | Format: Integer

the DNs will be split to. (Retrieve . .
splits in which this NPA was the Range: 200 - 999, 3-digit number

new NPA) Default: blank
NXX The exchange code value for this | Format: Integer
split. (Retrieve splits in which . ) s
this NXX was the NXX.) Range: 000 - 999, 3-digit number

On the Modify and Delete tabs, Default: blank

an All selection box is also
available. If this box is check
marked (the default) when the
Modify or Delete button is
clicked, all NXXs are modified
or deleted.
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Element Description Data Input Notes

PDP Start The start of the Permissive Format: Pulldown menus

Dialing Period for this split. .

Grayeg if NPA split is af:)tive. Range: Valid date

e This date cannot be in the Default: Tomorrow's date
past, and must be before the
PDP End date.

e Activation occurs within the
first 15 minutes of the PDP
Start date.

¢ If today's date is entered,
activation occurs within 15
minutes of the Create or
Modify button being clicked.

¢ This field only appears on the
Create and Modify tabs.

PDP End The end of the Permissive Format: Pulldown menus

Dialing Period for this split. Range: Valid date

¢ This date cannot be in the
past, and must be after the
PDP Start date.

¢ Termination occurs within
the first 15 minutes of the
PDP End date.

* The date cannot be changed
once the NPA split is
complete.

Default: Tomorrow's date + 90
days

¢ This field only appears on the
Create and Modify tabs.

Viewing NPA Splits
Use this task to display active or non-active NPA Split information.

From the View Tab, all NPA Split information can be displayed. Each field can be used as a filter
option when viewing NPA splits.

If you click View while all three fields are empty, the GUI displays all NPA splits found in the PDB

database. If the Save Results checkbox is check marked, the results are also saved to a CSV file named
NpaSpl i t Report. gui admi n. <t i mest anp>. csv. This file can then be viewed and downloaded
in the SDS file management area (Status & Manage > Files>).

1. Select SDS > Maintenance > NPA Splits.
The SDS Maintenance NPA Splits page appears, with the View tab displayed.
2. Add search criteria to the fields in the Value column, as desired.

3. To save results of NPA split information to a file for further viewing and/or processing, click to
check mark Save Results.
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4. Click View.

The NPA splits in the PDB database that match the criteria entered are shown on the bottom of the
page. For information about how to filter this information, see NPA Splits elements .

If Save Results was checked, the CSV file is generated.

Creating an NPA Split

From within the Create Tab, you can create NPA Splits.

Use this procedure to create an NPA split and define its characteristics, including the old NPA code,
the new NPA code, the central office exchange (NXX) code(s) to be transferred to the new NPA, and
the beginning and ending dates of the Permissive Dialing Period (PDP).

1. Select SDS > Maintenance > NPA Splits
The SDS Maintenance NPA Splits page appears.

2. Click the Create tab.
The NPA Splits Create table appears.

3. Enter data to provision an NPA split. Values must be entered for Old NPA, New NPA, and NXX.
If dates are entered in the PDP Start and/or PDP End dates, these dates must be greater than
today's date.

For more information about these fields, see NPA Splits elements.
4. Click Create.
The NPA Split record is provisioned. Its state is initialized to Pending.

Modifying an NPA Split

Use this procedure to modify the start and/or end the Permissive Dialing Period (PDP) dates of one
or more existing NPA splits.

1. Select SDS > Maintenance > NPA Splits.
The SDS Maintenance NPA Splits page appears.

2. Click the Modify tab.
The NPA Splits Modify page appears.

3. Enter the Old NPA, New NPA, and NXX fields to select the NPA to modify. To modify all NXX,
leave the All selection box check marked.

4. Enter the PDP Start and/or PDP End dates, as needed.

Both the PDP Start and PDP End dates can be modified for pending splits. Only the PDP End date
can be modified for active splits. Neither can be modified for completed splits. The PDP End date
must be greater than today’s date.

For more information about these fields, see NPA Splits elements.
5. Click Modify.
The NPA splits are updated.
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Deleting an NPA Split

Use this procedure to delete NPA Splits whose Permissive Dialing Period is pending or has expired.

1.

5.

Select SDS > Maintenance > NPA Splits.
The SDS Maintenance NPA Splits page appears.

Select the Delete tab.
The NPA Splits Delete tab appears.

Enter values into the fields to select the NPA splits you want to delete. To delete all NXX, leave
the All selection box check marked.

Click Delete.
A confirmation pop up window appears, asking if you are sure you want to delete this NPA split.

Click OK to continue with the deletion.

The selected NP splits are deleted, and a Delete successful message is displayed.
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AAA

APDE

CID

DP

DP SOAM

DR

DSR
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Authentication, Authorization, and
Accounting (Rx Diameter
command)

Automated Performance Data
Export

Connection ID

Data Processor

The repository of subscriber data
on the individual DSR node
elements. The DP hosts the full
address resolution database.

Data Processor System Operations,
Administration, and Maintenance

Disaster Recovery

Data Set Ready
Diameter Signaling Router

A set of co-located Message
Processors which share common
Diameter routing tables and are
supported by a pair of OAM
servers. A DSR Network Element
may consist of one or more
Diameter nodes.

Delete Subscriber Data Request
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FABR

FQDN

GUI

HA

HLRR

HSS
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Full Address Based Resolution

Provides an enhanced DSR routing
capability to enable network
operators to resolve the designated
Diameter server addresses based
on individual user identity
addresses in the incoming
Diameter request messages.

Fully qualified domain name

The complete domain name for a
specific computer on the Internet
(for example, www.tekelec.com).

A domain name that specifies its
exact location in the tree hierarchy
of the DNS.

Graphical User Interface

The term given to that set of items
and facilities which provide the
user with a graphic means for
manipulating screen data rather
than being limited to character
based commands.

High Availability

High Availability refers to a system
or component that operates on a
continuous basis by utilizing
redundant connectivity, thereby
circumventing unplanned outages.

HLR Router

Home Subscriber Server

A central database for subscriber
information.
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IP Multimedia Subsystem

These are central integration
platforms for controlling mobile
communications services, customer
management and accounting for
mobile communications services
based on IP. The IMS concept is
supported by 3GPP and the UMTS
Forum and is designed to provide
a wide range of application
scenarios for individual and group
communication.

Internet Protocol

IP specifies the format of packets,
also called datagrams, and the
addressing scheme. The network
layer for the TCP/IP protocol suite
widely used on Ethernet networks,
defined in STD 5, RFC 791. IP is a
connectionless, best-effort packet
switching protocol. It provides
packet routing, fragmentation and
re-assembly through the data link
layer.

Long Term Evolution

The next-generation network
beyond 3G. In addition to enabling
fixed to mobile migrations of
Internet applications such as Voice
over IP (VolP), video streaming,
music downloading, mobile TV,
and many others, LTE networks
will also provide the capacity to
support an explosion in demand
for connectivity from a new
generation of consumer devices
tailored to those new mobile
applications.
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Network Element

An independent and identifiable
piece of equipment closely
associated with at least one
processor, and within a single
location.

In a 2-Tiered DSR OAM system,
this includes the NOAM and all
MPs underneath it. In a 3-Tiered
DSR OAM system, this includes the
NOAM, the SOAM, and all MPs
associated with the SOAM.

Network Entity

Number Plan Area

The North American “Area
Codes.” (3 digits: 2- to-9, 0-or 1,
0-to-9. Middle digit to expand
soon).

Central Office Exchange Code

Online Charging Server

Policy and Charging Rules
Function

The ability to dynamically control
access, services, network capacity,
and charges in a network.

Maintains rules regarding a
subscriber’s use of network
resources. Responds to CCR and
AAR messages. Periodically sends
RAR messages. All policy sessions
for a given subscriber, originating
anywhere in the network, must be
processed by the same PCRF.
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Permissive Dialing Period

RAM Management Services
Rack Mount Server

Subscriber Database Server

Subscriber Database Server (SDS)
provides the central provisioning
of the Full-Address Based
Resolution (FABR) data. The SDS,
which is deployed geo-redundantly
ata Primary and Disaster recovery
site, connects with the Query
Server and the Data Processor
System Operations,
Administration, and Maintenance
(DP SOAM) servers at each
Diameter Signaling Router (DSR)
site or a standalone DP site to
replicate and recover provisioned
data to the associated components.

Simple Network Management
Protocol.

An industry-wide standard
protocol used for network
management. The SNMP agent
maintains data variables that
represent aspects of the network.
These variables are called managed
objects and are stored in a
management information base
(MIB). The SNMP protocol
arranges managed objects into
groups.

System Operations,
Administration, and Maintenance
Site Operations, Administration,
and Maintenance
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Transfer-Cluster-Prohibited
Transfer Control Protocol

Transmission Control Protocol

A connection-oriented protocol
used by applications on networked
hosts to connect to one another and
to exchange streams of data in a
reliable and in-order manner.

eXtensible Markup Language

A version of the Standard
Generalized Markup Language
(SGML) that allows Web
developers to create customized
tags for additional functionality.

Glossary

80



	Library
	Configuration and Maintenance Guide Help
	Introduction
	Purpose of this documentation
	Document organization
	Scope and Audience
	Documentation Admonishments
	Customer Care Center
	Emergency Response
	Related Publications
	Locate Product Documentation on the Customer Support Site

	About SDS
	Introduction to SDS
	SDS functionality

	System Architecture
	SDS Components

	Distributed configuration
	Centralized configuration


	Configuration
	Options configuration
	Options configuration elements
	Editing options

	Connections configuration
	Connections configuration elements
	Viewing connections
	Inserting connections
	Editing connections
	Deleting connections

	NAI Hosts configuration
	NAI Hosts configuration elements
	Viewing NAI hosts
	Inserting NAI hosts
	Deleting NAI hosts

	Destinations configuration
	Destinations configuration elements
	Retrieving destinations
	Adding destinations
	Updating destinations
	Deleting destinations

	Destination map configuration
	Destination map configuration elements
	Viewing Destination Map connections
	Inserting Destination Maps
	Editing Destination Maps
	Deleting Destination Maps

	Routing entities configuration
	Routing entities configuration elements
	Retrieving routing entities
	Adding routing entities
	Updating routing entities
	Deleting routing entities

	Subscribers
	Subscribers elements
	Retrieving subscribers
	Creating Subscribers
	Modifying Subscribers
	Deleting Subscribers

	Blacklist
	Blacklist configuration elements
	Retrieving blacklist values
	Adding blacklist values
	Deleting blacklist values


	Maintenance
	Connections maintenance
	Connections maintenance elements
	Viewing connections status

	Command Log maintenance
	Command Log maintenance elements
	Viewing maintenance command logs history

	Relay Exception Log
	Relay Exception Log maintenance elements
	Viewing exception logs history

	Import Status maintenance
	Import Status maintenance elements
	Viewing import files

	Export maintenance
	Schedule
	Export Schedule maintenance elements
	Viewing export schedule
	Inserting an export schedule
	Editing an export schedule
	Deleting an export schedule

	Status
	Export Status maintenance elements
	Viewing export status


	Remote Audit
	Remote Audit elements
	Viewing the status of a remote audit
	Requesting a remote audit

	Query
	Query elements
	Running a query (MSISDN, IMSI, MSISDN Prefix, IMSI Prefix, MSISDN Blacklist, IMSI Blacklist)
	Running a query (NAI User)
	Running a query (Wildcard NAI User, NAI Host, Destination, Counts, Counts by Destination, or DB Level)

	NPA Splits maintenance
	NPA Splits elements
	Viewing NPA Splits
	Creating an NPA Split
	Modifying an NPA Split
	Deleting an NPA Split


	Glossary
	Index


