Endeca.Navigation Namespace

[image]

Endeca Presentation API
Endeca.Navigation Namespace
Send Feedback

Classes

Class | Description
Public class AggrERec
A class composed of multiple records, all sharing a similarity.
Public class AggrERecList
List of Endeca aggregated records (AggrERec objects) exposed as an IList.
Public class AnalyticsStatementResult
Contains the result of an Analytics statement.
Public class AssocDimLocations
Class encapsulating a list of dimension locations associated by their dimension.
Public class AssocDimLocationsList
List of associated dimension location groups exposed as an IList.
Public class AssocNavigationRefs
Class encapsulating a group of value intersection references that all share a similar set of dimensions. That is, every set of values in this group are from the same set of dimensions.
Public class AssocNavigationRefsList
List of value intersection groups exposed as an IList.
Public class AuthHttpENEConnection
An extention of HttpENEConnection that provides connections to Endeca MDEX Engines that require authentication. Use instances of this class to connect to an Endeca MDEX Engine via the Endeca Access Control System.
Public class Dimension
Core component of a navigation state query encapsulating all information known about a dimension at the navigation state.
Public class DimensionList
List of dimensions (Dimension objects).
Public class DimensionSearchResult
Result class for a value search query. Class includes values queried for as well as other information about the query.
Public class DimensionSearchResultGroup
Class encapsulating a group of value intersection references that all share a similar set of dimensions. That is, every set of values in this group are from the same set of dimensions.
Public class DimensionSearchResultGroupList
List of value intersection groups exposed as an IList.
Public class DimGroup
Class encapsulating a group of dimensions.
Public class DimGroupList
List of dimension groups exposed as an IList.
Public class DimLocation
DimLocation represents a specific location in a dimension.
Public class DimLocationList
List containing DimLocation objects exposed as an IList.
Public class DimSearchRefinementConfig
Class representing a refinement config for dimension search. The only option available in this class is the ability to turn counts on or off.
Public class DimSearchRefinementConfigList
Class that encapsulates a collection of dimension search refinement config (DimSearchRefinementConfig) objects.
Public class DimSearchResult
Result class for a value search query. Class includes values queried for as well as other information about the query.
Public class DimVal
A dimension value is the lowest-level building block that compose dimensions, navigations, and classifications of records.
Public class DimValIdList
List of dimension value IDs.
Public class DimValList
A list of dimension values (DimVal objects).
Public class DisabledRefinementsConfig
This class represents the configuration of the Disabled Refinement results that will be returned with the query results. The methods of this class allow configuration of the base nav state to be used to compute the Disabled Refinements.
Public class EmptyENEQueryException
Exception signalling that the query method was called with an empty query object. Exception comes from the fact that a query object did not express any requests to the Endeca MDEX Engine.
Public class ENEAuthenticationException
The exception thrown when authentication fails
Public class ENEConnectionException
Exception represents an error dealing with the communication with an Endeca MDEX Engine from an IENEConnection.
Public class ENEException
Exception represents an exception that comes from the Endeca MDEX Engine. Often this means that the IENEConnection was able to contact the MDEX Engine but the MDEX Engine responded with an error.
Public class ENEQuery
An object used for expressing queries to an Endeca MDEX Engine.
Public class ENEQueryException
Abstract exception representing a general error while attempting to query the Endeca MDEX engine.
Public class ENEQueryInfo
An object that generates and stores logging-specific query information.
Public class ENEQueryResults
Result object returned from a query to an Endeca MDEX Engine.
Public class ENEQueryToolkit
ENEQueryToolkit provides static methods for managing the value of the primary URL query parameter in a navigation query. This parameter specifies the list of refinement dimensions that were used to generate the current query results. Managing the parameter's value allows you to maintain application state.
Public class ERec
ERec class is composed of properties and dimension values it is tagged by.
Public class ERecCompoundSearchKey
Key with which a record set can be or is text group searched by.
Public class ERecCompoundSearchKeyList
Collection of record compound search keys exposed as an IList.
Public class ERecEnumerator
List containing ERec or AggrERec objects exposed as an IList.
Public class ERecIdList
List of record specifications. Primarily used to generate URLs and MDEX Engine queries.
Public class ERecList
List of Endeca records exposed as an IList.
Public class ERecRank
Class representing a relevance ranking on a navigation record set.
Public class ERecRollupKey
Key with which a record set can or is rolled up by.
Public class ERecRollupKeyList
Collection of record rollup keys exposed as an IList.
Public class ERecSearch
Class representing a search on a navigation record set.
Public class ERecSearchKey
Key with which a record set can be or is text searched by.
Public class ERecSearchKeyList
Collection of record search keys exposed as an IList.
Public class ERecSearchList
Class that encapsulates a collection of ERecSearch objects, each of which represents a record search.
Public class ERecSortKey
Key with which a record set can or is sorted by.
Public class ERecSortKeyList
Collection of record sort keys exposed as an IList.
Public class ESearchAutoSuggestion
ESearchAutoSuggestion represents a single alternate spelling suggestion made by the Endeca MDEX Engine when a record search is performed.
Public class ESearchDYMSuggestion
ESearchDYMSuggestion represents a single alternate spelling suggestion made by the Endeca MDEX Engine when a text search is performed.
Public class ESearchReport
ESearchReport objects contain detailed information about record searches.
Public class ESearchReport..::..Mode
Enumeration of Endeca search modes.
Public class ETInstrumentor
Class that instruments HTML pages for use with the Web-based tools package.
Public class FieldList
An IList of Endeca property or dimension names that will be used to specify which values will be returned for each record in the result set of a navigation query. The Selection setter property is used to set the FieldList for the query.
Public class GlobalDimSearchRefinementConfig
Class representing a global refinement config for dimension search. The options currently available in this class are the ability to turn counts on or off, the ability to specify the number of results to return, and the ability to specify whether the synonyms should be returned.
Public class HttpENEConnection
Provides a connection to an Endeca MDEX Engine over HTTP. Also provides a mechanism for issuing queries to the MDEX Engine.
Public class InternalException
Exception signalling that an internal error has occured in the system. Internal errors often signal an unexpected error in the execution of the system.
Public class KeyProperties
Class providing access to a collection of properties associated with a given Endeca Dimension or Property key.
Public class Navigation
Top-level object returned from an Endeca MDEX Engine. The Navigation object serves as a container for several components (such as navigation descriptors, record set, etc.) that together compose a navigation.
Public class NavigationRefsList
List of navigation refinement values exposed as an IList. Each element of the list is a DimValList referencing a navigation state.
Public class OptionalBoolean
Class representing an
CopyC#
bool
 or an unset value. Unlike an
CopyC#
bool
, an
CopyC#
OptionalBool
 may be empty.
Public class OptionalInt
Class representing an
CopyC#
int
 or an unset value. Unlike an
CopyC#
int
, an
CopyC#
OptionalInt
 may be empty.
Public class PartialENEQueryException
Exception that is triggered if there is a query that does not completely express a query with all necessary parameter.
Public class Property
Class representing an Endeca name/value property pair.
Public class PropertyMap
Class providing access to a collection of properties.
Public class RangeFilter
Class representing a range filter on a navigation record set.
Public class RangeFilterList
Class that encapsulates a collection of range filters (RangeFilter objects).
Public class RefinementConfig
Class representing a dynamic refinement config for a dimension value. This will determine how refinements are computed under this dimension value. Use of a dynamic refinement config will suppress generation of a "More..." child dimension value. You can determine whether there are more refinements than the ones shown by looking at the "DGraph.More" property on the refinements' parent dimension value. Any of the settings in this class can be set explicitly or defaulted to use the corresponding dimension's settings in developer studio.
Public class | RefinementConfigBase
Public class RefinementConfigList
Class that encapsulates a collection of dynamic refinement config (RefinementConfig) objects.
Public class StratifiedDimVal
Class representing the assignment of a dimension value to a specific stratum for sorting. Dimension values are sorted by their assigned strata and then by whatever the refinement sorting method for the dimension is (via static ranking, dynamic ranking, dynamic refinement configs, etc). Dimension values not explicitly assigned a strata are assigned the strata 0.
Public class StratifiedDimValList
Class that encapsulates a collection of stratified dimension values (StratifiedDimVal) objects.
Public class Supplement
Class representing supplemental information and data for a navigation query.
Public class SupplementList
List of supplements (Supplement objects) exposed as an IList.
Public class UrlENEQuery
An object used for formulating queries to an Endeca MDEX Engine through the use of an input URL.
Public class UrlENEQueryParseException
Exception representing an error while parsing a URL for a UrlENEQuery.
Public class UrlGen
A generic toolkit for manipulating and generating URL query strings.
Public class VersionMismatchException
Exception signalling the mismatch of two incompatible modules in the system while processing the query. Most often this exception is used to signal a mismatch between the IENEConnection and the Endeca MDEX Engine itself.

Interfaces

 | Interface | Description
Public interface | IENEConnection | A connection with an Endeca MDEX Engine. With a connection, queries can be issued to the MDEX Engine and ENEQueryResults are returned. The only current type of connection offered is the HttpENEConnection.
Public interface | IPropertyContainer | Interface for an object that has properties and has those properties exposed as a PropertyMap. The purpose for this interface is to allow common code to be used in the extraction of any object that supports this interface, for example building tag libraries around property containers.

Enumerations

 | Enumeration | Description
Public enumeration | RefinementConfig..::..DynamicRankingState |
Public enumeration | RefinementConfig..::..DynamicRankOrderState |
© 2003, 2014 Oracle and/or its affiliates. All rights reserved.


AggrERec Class

[image]

Endeca Presentation API
AggrERec Class
Members See Also Send Feedback
A class composed of multiple records, all sharing a similarity.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AggrERec : IPropertyContainer
Visual Basic
Public Class AggrERec _
    Implements IPropertyContainer
Visual C++
public ref class AggrERec : IPropertyContainer

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AggrERec

See Also

AggrERec Members


AggrERec Members

[image] [image]

Endeca Presentation API
AggrERec Members
AggrERec Class Methods Properties See Also Send Feedback

The AggrERec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ERecs | Gets the ERec objects of this aggregated record.
Public property | Id | Obsolete. Gets the ID of the aggregated record.
Public property | Properties | Gets the properties of the aggregated record.
Public property | Representative | Gets the representative record of the aggregated record.
Public property | Spec | Gets the specification of the aggregated record.
Public property | TotalNumERecs | Gets the total number of ERec objects aggregated in this aggregated Endeca record.

See Also

AggrERec Class


AggrERec Methods

[image] [image]

Endeca Presentation API
AggrERec Methods
AggrERec Class See Also Send Feedback

The AggrERec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AggrERec Class


AggrERec Properties

[image] [image]

Endeca Presentation API
AggrERec Properties
AggrERec Class See Also Send Feedback

The AggrERec type exposes the following members.

Properties

 | Name | Description
Public property | ERecs | Gets the ERec objects of this aggregated record.
Public property | Id | Obsolete. Gets the ID of the aggregated record.
Public property | Properties | Gets the properties of the aggregated record.
Public property | Representative | Gets the representative record of the aggregated record.
Public property | Spec | Gets the specification of the aggregated record.
Public property | TotalNumERecs | Gets the total number of ERec objects aggregated in this aggregated Endeca record.

See Also

AggrERec Class


ERecs Property

[image]

Endeca Presentation API
AggrERec..::..ERecs Property
AggrERec Class See Also Send Feedback
Gets the ERec objects of this aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecList ERecs { get; }
Visual Basic
Public Overridable ReadOnly Property ERecs As ERecList
    Get
Visual C++
public:
virtual property ERecList^ ERecs {
    ERecList^ get ();
}

Field Value

ERec objects of the aggregated record.

Remarks

This list may contain all records of the aggregated record, a subset or none, based on the nature of the query that retrieved the aggregated record. In the case there are none an empty ERecList will still be returned.

See Also

AggrERec Class


Id Property

[image]

Endeca Presentation API
AggrERec..::..Id Property
AggrERec Class See Also Send Feedback
Gets the ID of the aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")]
public virtual long Id { get; }
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")> _
Public Overridable ReadOnly Property Id As Long
    Get
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")]
public:
virtual property long long Id {
    long long get ();
}

Field Value

The ID of the aggregated record.

Exceptions

Exception | Condition
System..::..Exception | Thrown when the specification is not a numeric value.

See Also

AggrERec Class


Properties Property

[image]

Endeca Presentation API
AggrERec..::..Properties Property
AggrERec Class See Also Send Feedback
Gets the properties of the aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap Properties { get; }
Visual Basic
Public Overridable ReadOnly Property Properties As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

The properties of this aggregated record.

Implements

IPropertyContainer..::..Properties

Remarks

If the aggregated record does not have any properties, an empty PropertyMap will still be returned.

See Also

AggrERec Class


Representative Property

[image]

Endeca Presentation API
AggrERec..::..Representative Property
AggrERec Class See Also Send Feedback
Gets the representative record of the aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERec Representative { get; }
Visual Basic
Public Overridable ReadOnly Property Representative As ERec
    Get
Visual C++
public:
virtual property ERec^ Representative {
    ERec^ get ();
}

Field Value

Representative record for aggregated record or null if the records of the aggregated record were not retrieved during the query.

Remarks

If the number of records per aggregated record is set to zero in the query this method will return null.

See Also

AggrERec Class


Spec Property

[image]

Endeca Presentation API
AggrERec..::..Spec Property
AggrERec Class See Also Send Feedback
Gets the specification of the aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Spec { get; }
Visual Basic
Public Overridable ReadOnly Property Spec As String
    Get
Visual C++
public:
virtual property String^ Spec {
    String^ get ();
}

Field Value

The specification of the aggregated record.

See Also

AggrERec Class


TotalNumERecs Property

[image]

Endeca Presentation API
AggrERec..::..TotalNumERecs Property
AggrERec Class See Also Send Feedback
Gets the total number of ERec objects aggregated in this aggregated Endeca record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long TotalNumERecs { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumERecs As Long
    Get
Visual C++
public:
virtual property long long TotalNumERecs {
    long long get ();
}

Field Value

The total number of ERec objects that compose this aggregated Endeca record.

Remarks

Based on the query, it is possible that a subset of the entire set of Endeca records (ERec objects) of the aggregated record are returned or none at all. This method returns the total number that exist.

See Also

AggrERec Class


AggrERecList Class

[image]

Endeca Presentation API
AggrERecList Class
Members See Also Send Feedback
List of Endeca aggregated records (AggrERec objects) exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AggrERecList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class AggrERecList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class AggrERecList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AggrERecList

See Also

AggrERecList Members


AggrERecList Members

[image] [image]

Endeca Presentation API
AggrERecList Members
AggrERecList Class Methods Properties See Also Send Feedback

The AggrERecList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AggrERecList.
Public method | CopyTo | Copies the entire AggrERecList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AggrERecList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AggrERecList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AggrERecList.
Public property | IsFixedSize | Gets a value indicating whether the AggrERecList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AggrERecList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AggrERecList is synchronized (thread-safe).
Public property | Item | Gets the AggrERec at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AggrERecList Class


AggrERecList Methods

[image] [image]

Endeca Presentation API
AggrERecList Methods
AggrERecList Class See Also Send Feedback

The AggrERecList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AggrERecList.
Public method | CopyTo | Copies the entire AggrERecList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AggrERecList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AggrERecList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AggrERecList Class


Add Method

[image]

Endeca Presentation API
AggrERecList..::..Add Method
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the AggrERecList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


Clear Method

[image]

Endeca Presentation API
AggrERecList..::..Clear Method
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


Contains Method

[image]

Endeca Presentation API
AggrERecList..::..Contains Method
AggrERecList Class See Also Send Feedback
Determines whether an element is in the AggrERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AggrERecList.

Return Value

true if item is found in the AggrERecList.

Implements

IList..::..Contains(Object)

See Also

AggrERecList Class


CopyTo Method

[image]

Endeca Presentation API
AggrERecList..::..CopyTo Method
AggrERecList Class See Also Send Feedback
Copies the entire AggrERecList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from AggrERecList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source AggrERecList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source AggrERecList be cast automatically to the type of the destination array.

See Also

AggrERecList Class


GetEnumerator Method

[image]

Endeca Presentation API
AggrERecList..::..GetEnumerator Method
AggrERecList Class See Also Send Feedback
Returns an enumerator for the entire AggrERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire AggrERecList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

AggrERecList Class


IndexOf Method

[image]

Endeca Presentation API
AggrERecList..::..IndexOf Method
AggrERecList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the AggrERecList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AggrERecList.

Return Value

The zero-based index of the first occurrence of item within the entire AggrERecList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

AggrERecList Class


Insert Method

[image]

Endeca Presentation API
AggrERecList..::..Insert Method
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


Remove Method

[image]

Endeca Presentation API
AggrERecList..::..Remove Method
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from AggrERecList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


RemoveAt Method

[image]

Endeca Presentation API
AggrERecList..::..RemoveAt Method
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


AggrERecList Properties

[image] [image]

Endeca Presentation API
AggrERecList Properties
AggrERecList Class See Also Send Feedback

The AggrERecList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AggrERecList.
Public property | IsFixedSize | Gets a value indicating whether the AggrERecList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AggrERecList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AggrERecList is synchronized (thread-safe).
Public property | Item | Gets the AggrERec at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AggrERecList Class


Count Property

[image]

Endeca Presentation API
AggrERecList..::..Count Property
AggrERecList Class See Also Send Feedback
Gets the number of elements actually contained in the AggrERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the AggrERecList.

Implements

ICollection..::..Count

See Also

AggrERecList Class


IsFixedSize Property

[image]

Endeca Presentation API
AggrERecList..::..IsFixedSize Property
AggrERecList Class See Also Send Feedback
Gets a value indicating whether the AggrERecList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the AggrERecList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

AggrERecList Class


IsReadOnly Property

[image]

Endeca Presentation API
AggrERecList..::..IsReadOnly Property
AggrERecList Class See Also Send Feedback
Gets a value indicating whether the AggrERecList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the AggrERecList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

AggrERecList Class


IsSynchronized Property

[image]

Endeca Presentation API
AggrERecList..::..IsSynchronized Property
AggrERecList Class See Also Send Feedback
Gets a value indicating whether access to the AggrERecList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the AggrERecList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

AggrERecList Class


Item Property

[image]

Endeca Presentation API
AggrERecList..::..Item Property
AggrERecList Class See Also Send Feedback
Gets the AggrERec at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The AggrERec at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

AggrERecList Class


SyncRoot Property

[image]

Endeca Presentation API
AggrERecList..::..SyncRoot Property
AggrERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the AggrERecList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AggrERecList Class


AnalyticsStatementResult Class

[image]

Endeca Presentation API
AnalyticsStatementResult Class
Members See Also Send Feedback
Contains the result of an Analytics statement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AnalyticsStatementResult
Visual Basic
Public Class AnalyticsStatementResult
Visual C++
public ref class AnalyticsStatementResult

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AnalyticsStatementResult

See Also

AnalyticsStatementResult Members


AnalyticsStatementResult Members

[image] [image]

Endeca Presentation API
AnalyticsStatementResult Members
AnalyticsStatementResult Class Methods Properties See Also Send Feedback

The AnalyticsStatementResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ERecIter | Returns an enumerator that provides access to the records associated with the statement.
Public property | Error | Returns the error message for this statement, or null if no error was encountered when processing this statement.
Public property | Name | Returns the statement name.
Public property | ReturnedNumERecs | Returns the total number of records that match the Analytics statement.
Public property | TotalNumERecs | Returns the number of records returned in this particular request.

See Also

AnalyticsStatementResult Class


AnalyticsStatementResult Methods

[image] [image]

Endeca Presentation API
AnalyticsStatementResult Methods
AnalyticsStatementResult Class See Also Send Feedback

The AnalyticsStatementResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsStatementResult Class


AnalyticsStatementResult Properties

[image] [image]

Endeca Presentation API
AnalyticsStatementResult Properties
AnalyticsStatementResult Class See Also Send Feedback

The AnalyticsStatementResult type exposes the following members.

Properties

 | Name | Description
Public property | ERecIter | Returns an enumerator that provides access to the records associated with the statement.
Public property | Error | Returns the error message for this statement, or null if no error was encountered when processing this statement.
Public property | Name | Returns the statement name.
Public property | ReturnedNumERecs | Returns the total number of records that match the Analytics statement.
Public property | TotalNumERecs | Returns the number of records returned in this particular request.

See Also

AnalyticsStatementResult Class


ERecIter Property

[image]

Endeca Presentation API
AnalyticsStatementResult..::..ERecIter Property
AnalyticsStatementResult Class See Also Send Feedback
Returns an enumerator that provides access to the records associated with the statement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator ERecIter { get; }
Visual Basic
Public Overridable ReadOnly Property ERecIter As IEnumerator
    Get
Visual C++
public:
virtual property IEnumerator^ ERecIter {
    IEnumerator^ get ();
}

See Also

AnalyticsStatementResult Class


Error Property

[image]

Endeca Presentation API
AnalyticsStatementResult..::..Error Property
AnalyticsStatementResult Class See Also Send Feedback
Returns the error message for this statement, or null if no error was encountered when processing this statement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Error { get; }
Visual Basic
Public Overridable ReadOnly Property Error As String
    Get
Visual C++
public:
virtual property String^ Error {
    String^ get ();
}

See Also

AnalyticsStatementResult Class


Name Property

[image]

Endeca Presentation API
AnalyticsStatementResult..::..Name Property
AnalyticsStatementResult Class See Also Send Feedback
Returns the statement name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

See Also

AnalyticsStatementResult Class


ReturnedNumERecs Property

[image]

Endeca Presentation API
AnalyticsStatementResult..::..ReturnedNumERecs Property
AnalyticsStatementResult Class See Also Send Feedback
Returns the total number of records that match the Analytics statement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long ReturnedNumERecs { get; }
Visual Basic
Public Overridable ReadOnly Property ReturnedNumERecs As Long
    Get
Visual C++
public:
virtual property long long ReturnedNumERecs {
    long long get ();
}

See Also

AnalyticsStatementResult Class


TotalNumERecs Property

[image]

Endeca Presentation API
AnalyticsStatementResult..::..TotalNumERecs Property
AnalyticsStatementResult Class See Also Send Feedback
Returns the number of records returned in this particular request.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long TotalNumERecs { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumERecs As Long
    Get
Visual C++
public:
virtual property long long TotalNumERecs {
    long long get ();
}

See Also

AnalyticsStatementResult Class


AssocDimLocations Class

[image]

Endeca Presentation API
AssocDimLocations Class
Members See Also Send Feedback
Class encapsulating a list of dimension locations associated by their dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AssocDimLocations : IList,
    ICollection, IEnumerable
Visual Basic
Public Class AssocDimLocations _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class AssocDimLocations : IList,
    ICollection, IEnumerable

Remarks

In an AssocDimLocations object, the dimension locations (DimLocation objects) are all from the same dimension. The DimLocation objects are returned as part of an Endeca record via an AssocDimLocationsList object in the ERec data structure. The dimension locations designate the record's location within the dimension hierarchy.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AssocDimLocations

See Also

AssocDimLocations Members


AssocDimLocations Members

[image] [image]

Endeca Presentation API
AssocDimLocations Members
AssocDimLocations Class Methods Properties See Also Send Feedback

The AssocDimLocations type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocDimLocations.
Public method | CopyTo | Copies the entire AssocDimLocations to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocDimLocations.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocDimLocations or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocDimLocations.
Public property | DimRoot | Gets the root value of the dimension all the locations these assocatiated locations are from.
Public property | IsFixedSize | Gets a value indicating whether the AssocDimLocations has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocDimLocations is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocDimLocations is synchronized (thread-safe).
Public property | Item | Gets the DimLocation at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.
Public property | TotalNumLocations | Gets the total number of dimension locations belonging to this dimension.

See Also

AssocDimLocations Class


AssocDimLocations Methods

[image] [image]

Endeca Presentation API
AssocDimLocations Methods
AssocDimLocations Class See Also Send Feedback

The AssocDimLocations type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocDimLocations.
Public method | CopyTo | Copies the entire AssocDimLocations to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocDimLocations.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocDimLocations or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssocDimLocations Class


Add Method

[image]

Endeca Presentation API
AssocDimLocations..::..Add Method
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the AssocDimLocations.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


Clear Method

[image]

Endeca Presentation API
AssocDimLocations..::..Clear Method
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


Contains Method

[image]

Endeca Presentation API
AssocDimLocations..::..Contains Method
AssocDimLocations Class See Also Send Feedback
Determines whether an element is in the AssocDimLocations.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocDimLocations.

Return Value

true if item is found in the AssocDimLocations.

Implements

IList..::..Contains(Object)

See Also

AssocDimLocations Class


CopyTo Method

[image]

Endeca Presentation API
AssocDimLocations..::..CopyTo Method
AssocDimLocations Class See Also Send Feedback
Copies the entire AssocDimLocations to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from AssocDimLocations. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source AssocDimLocations is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source AssocDimLocations be cast automatically to the type of the destination array.

See Also

AssocDimLocations Class


GetEnumerator Method

[image]

Endeca Presentation API
AssocDimLocations..::..GetEnumerator Method
AssocDimLocations Class See Also Send Feedback
Returns an enumerator for the entire AssocDimLocations.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire AssocDimLocations

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

AssocDimLocations Class


IndexOf Method

[image]

Endeca Presentation API
AssocDimLocations..::..IndexOf Method
AssocDimLocations Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the AssocDimLocations or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocDimLocations.

Return Value

The zero-based index of the first occurrence of item within the entire AssocDimLocations, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

AssocDimLocations Class


Insert Method

[image]

Endeca Presentation API
AssocDimLocations..::..Insert Method
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


Remove Method

[image]

Endeca Presentation API
AssocDimLocations..::..Remove Method
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from AssocDimLocations.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


RemoveAt Method

[image]

Endeca Presentation API
AssocDimLocations..::..RemoveAt Method
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


AssocDimLocations Properties

[image] [image]

Endeca Presentation API
AssocDimLocations Properties
AssocDimLocations Class See Also Send Feedback

The AssocDimLocations type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocDimLocations.
Public property | DimRoot | Gets the root value of the dimension all the locations these assocatiated locations are from.
Public property | IsFixedSize | Gets a value indicating whether the AssocDimLocations has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocDimLocations is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocDimLocations is synchronized (thread-safe).
Public property | Item | Gets the DimLocation at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.
Public property | TotalNumLocations | Gets the total number of dimension locations belonging to this dimension.

See Also

AssocDimLocations Class


Count Property

[image]

Endeca Presentation API
AssocDimLocations..::..Count Property
AssocDimLocations Class See Also Send Feedback
Gets the number of elements actually contained in the AssocDimLocations.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the AssocDimLocations.

Implements

ICollection..::..Count

See Also

AssocDimLocations Class


DimRoot Property

[image]

Endeca Presentation API
AssocDimLocations..::..DimRoot Property
AssocDimLocations Class See Also Send Feedback
Gets the root value of the dimension all the locations these assocatiated locations are from.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal DimRoot { get; }
Visual Basic
Public Overridable ReadOnly Property DimRoot As DimVal
    Get
Visual C++
public:
virtual property DimVal^ DimRoot {
    DimVal^ get ();
}

Field Value

Root value (DimVal object) from the common dimension of these locations.

See Also

AssocDimLocations Class


IsFixedSize Property

[image]

Endeca Presentation API
AssocDimLocations..::..IsFixedSize Property
AssocDimLocations Class See Also Send Feedback
Gets a value indicating whether the AssocDimLocations has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the AssocDimLocations is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

AssocDimLocations Class


IsReadOnly Property

[image]

Endeca Presentation API
AssocDimLocations..::..IsReadOnly Property
AssocDimLocations Class See Also Send Feedback
Gets a value indicating whether the AssocDimLocations is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the AssocDimLocations is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

AssocDimLocations Class


IsSynchronized Property

[image]

Endeca Presentation API
AssocDimLocations..::..IsSynchronized Property
AssocDimLocations Class See Also Send Feedback
Gets a value indicating whether access to the AssocDimLocations is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the AssocDimLocations is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

AssocDimLocations Class


Item Property

[image]

Endeca Presentation API
AssocDimLocations..::..Item Property
AssocDimLocations Class See Also Send Feedback
Gets the DimLocation at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimLocation at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

AssocDimLocations Class


SyncRoot Property

[image]

Endeca Presentation API
AssocDimLocations..::..SyncRoot Property
AssocDimLocations Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the AssocDimLocations.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocations Class


TotalNumLocations Property

[image]

Endeca Presentation API
AssocDimLocations..::..TotalNumLocations Property
AssocDimLocations Class See Also Send Feedback
Gets the total number of dimension locations belonging to this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long TotalNumLocations { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumLocations As Long
    Get
Visual C++
public:
virtual property long long TotalNumLocations {
    long long get ();
}

Field Value

Total number of dimension locations of this group.

Remarks

Depending on the nature of the query where an associated dimension locations is obtained, the collection may only contain a subset of the locations of the group. This method gets the total number of the locations.

Class invariant:

CopyC#
TotalNumberLocations >= Elements.Size()

See Also

AssocDimLocations Class


AssocDimLocationsList Class

[image]

Endeca Presentation API
AssocDimLocationsList Class
Members See Also Send Feedback
List of associated dimension location groups exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AssocDimLocationsList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class AssocDimLocationsList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class AssocDimLocationsList : IList,
    ICollection, IEnumerable

Remarks

The dimension location groups are AssocDimLocations objects. Note that for a given AssocDimLocations, the dimension locations are all from the same dimension.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AssocDimLocationsList

See Also

AssocDimLocationsList Members


AssocDimLocationsList Members

[image] [image]

Endeca Presentation API
AssocDimLocationsList Members
AssocDimLocationsList Class Methods Properties See Also Send Feedback

The AssocDimLocationsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocDimLocationsList.
Public method | CopyTo | Copies the entire AssocDimLocationsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssocDimLocations(Int64) | Gets the AssocDimLocations that is from the dimension whose ID is dimensionId.
Public method | GetAssocDimLocations(String) | Gets the AssocDimLocations that is from the dimension wit the name dimensionName.
Public method | GetEnumerator | Returns an enumerator for the entire AssocDimLocationsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocDimLocationsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocDimLocationsList.
Public property | IsFixedSize | Gets a value indicating whether the AssocDimLocationsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocDimLocationsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocDimLocationsList is synchronized (thread-safe).
Public property | Item | Gets the AssocDimLocations at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocDimLocationsList Class


AssocDimLocationsList Methods

[image] [image]

Endeca Presentation API
AssocDimLocationsList Methods
AssocDimLocationsList Class See Also Send Feedback

The AssocDimLocationsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocDimLocationsList.
Public method | CopyTo | Copies the entire AssocDimLocationsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAssocDimLocations(Int64) | Gets the AssocDimLocations that is from the dimension whose ID is dimensionId.
Public method | GetAssocDimLocations(String) | Gets the AssocDimLocations that is from the dimension wit the name dimensionName.
Public method | GetEnumerator | Returns an enumerator for the entire AssocDimLocationsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocDimLocationsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssocDimLocationsList Class


Add Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..Add Method
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the AssocDimLocationsList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


Clear Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..Clear Method
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


Contains Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..Contains Method
AssocDimLocationsList Class See Also Send Feedback
Determines whether an element is in the AssocDimLocationsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocDimLocationsList.

Return Value

true if item is found in the AssocDimLocationsList.

Implements

IList..::..Contains(Object)

See Also

AssocDimLocationsList Class


CopyTo Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..CopyTo Method
AssocDimLocationsList Class See Also Send Feedback
Copies the entire AssocDimLocationsList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from AssocDimLocationsList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source AssocDimLocationsList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source AssocDimLocationsList be cast automatically to the type of the destination array.

See Also

AssocDimLocationsList Class


GetAssocDimLocations Method

[image] [image]

Endeca Presentation API
AssocDimLocationsList..::..GetAssocDimLocations Method
AssocDimLocationsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAssocDimLocations(Int64) | Gets the AssocDimLocations that is from the dimension whose ID is dimensionId.
Public method | GetAssocDimLocations(String) | Gets the AssocDimLocations that is from the dimension wit the name dimensionName.

See Also

AssocDimLocationsList Class
AssocDimLocationsList Members


GetAssocDimLocations Method (Int64)

[image]

Endeca Presentation API
AssocDimLocationsList..::..GetAssocDimLocations Method (Int64)
AssocDimLocationsList Class See Also Send Feedback
Gets the AssocDimLocations that is from the dimension whose ID is dimensionId.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AssocDimLocations GetAssocDimLocations(
    long dimensionId
)
Visual Basic
Public Overridable Function GetAssocDimLocations ( _
    dimensionId As Long _
) As AssocDimLocations
Visual C++
public:
virtual AssocDimLocations^ GetAssocDimLocations(
    long long dimensionId
)

Parameters

dimensionId
Type: System..::..Int64
Dimension ID of the dimension to which the AssocDimLocations belong.

Return Value

AssocDimLocations with a dimension ID of dimensionId.

Remarks

Returns null if no AssocDimLocations can be found with associated with dimension ID dimensionId.

See Also

AssocDimLocationsList Class
GetAssocDimLocations Overload


GetAssocDimLocations Method (String)

[image]

Endeca Presentation API
AssocDimLocationsList..::..GetAssocDimLocations Method (String)
AssocDimLocationsList Class See Also Send Feedback
Gets the AssocDimLocations that is from the dimension wit the name dimensionName.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AssocDimLocations GetAssocDimLocations(
    string dimensionName
)
Visual Basic
Public Overridable Function GetAssocDimLocations ( _
    dimensionName As String _
) As AssocDimLocations
Visual C++
public:
virtual AssocDimLocations^ GetAssocDimLocations(
    String^ dimensionName
)

Parameters

dimensionName
Type: System..::..String
Name of the dimension name to which the AssocDimLocations belong.

Return Value

AssocDimLocations with a dimension name of dimensionName.

Remarks

Returns null if no AssocDimLocations can be found with from the dimension named dimensionName.

See Also

AssocDimLocationsList Class
GetAssocDimLocations Overload


GetEnumerator Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..GetEnumerator Method
AssocDimLocationsList Class See Also Send Feedback
Returns an enumerator for the entire AssocDimLocationsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire AssocDimLocationsList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

AssocDimLocationsList Class


IndexOf Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..IndexOf Method
AssocDimLocationsList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the AssocDimLocationsList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocDimLocationsList.

Return Value

The zero-based index of the first occurrence of item within the entire AssocDimLocationsList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

AssocDimLocationsList Class


Insert Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..Insert Method
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


Remove Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..Remove Method
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from AssocDimLocationsList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


RemoveAt Method

[image]

Endeca Presentation API
AssocDimLocationsList..::..RemoveAt Method
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


AssocDimLocationsList Properties

[image] [image]

Endeca Presentation API
AssocDimLocationsList Properties
AssocDimLocationsList Class See Also Send Feedback

The AssocDimLocationsList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocDimLocationsList.
Public property | IsFixedSize | Gets a value indicating whether the AssocDimLocationsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocDimLocationsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocDimLocationsList is synchronized (thread-safe).
Public property | Item | Gets the AssocDimLocations at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocDimLocationsList Class


Count Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..Count Property
AssocDimLocationsList Class See Also Send Feedback
Gets the number of elements actually contained in the AssocDimLocationsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the AssocDimLocationsList.

Implements

ICollection..::..Count

See Also

AssocDimLocationsList Class


IsFixedSize Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..IsFixedSize Property
AssocDimLocationsList Class See Also Send Feedback
Gets a value indicating whether the AssocDimLocationsList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the AssocDimLocationsList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

AssocDimLocationsList Class


IsReadOnly Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..IsReadOnly Property
AssocDimLocationsList Class See Also Send Feedback
Gets a value indicating whether the AssocDimLocationsList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the AssocDimLocationsList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

AssocDimLocationsList Class


IsSynchronized Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..IsSynchronized Property
AssocDimLocationsList Class See Also Send Feedback
Gets a value indicating whether access to the AssocDimLocationsList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the AssocDimLocationsList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

AssocDimLocationsList Class


Item Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..Item Property
AssocDimLocationsList Class See Also Send Feedback
Gets the AssocDimLocations at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The AssocDimLocations at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

AssocDimLocationsList Class


SyncRoot Property

[image]

Endeca Presentation API
AssocDimLocationsList..::..SyncRoot Property
AssocDimLocationsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the AssocDimLocationsList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocDimLocationsList Class


AssocNavigationRefs Class

[image]

Endeca Presentation API
AssocNavigationRefs Class
Members See Also Send Feedback
Class encapsulating a group of value intersection references that all share a similar set of dimensions. That is, every set of values in this group are from the same set of dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AssocNavigationRefs : IList,
    ICollection, IEnumerable
Visual Basic
Public Class AssocNavigationRefs _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class AssocNavigationRefs : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AssocNavigationRefs

See Also

AssocNavigationRefs Members


AssocNavigationRefs Members

[image] [image]

Endeca Presentation API
AssocNavigationRefs Members
AssocNavigationRefs Class Methods Properties See Also Send Feedback

The AssocNavigationRefs type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocNavigationRefs.
Public method | CopyTo | Copies the entire AssocNavigationRefs to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocNavigationRefs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefs or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocNavigationRefs.
Public property | DimRoots | Gets the roots of the set of dimensions that all the intersections in this group share and are from.
Public property | IsFixedSize | Gets a value indicating whether the AssocNavigationRefs has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocNavigationRefs is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocNavigationRefs is synchronized (thread-safe).
Public property | Item | Gets the DimValList at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocNavigationRefs Class


AssocNavigationRefs Methods

[image] [image]

Endeca Presentation API
AssocNavigationRefs Methods
AssocNavigationRefs Class See Also Send Feedback

The AssocNavigationRefs type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocNavigationRefs.
Public method | CopyTo | Copies the entire AssocNavigationRefs to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocNavigationRefs.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefs or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssocNavigationRefs Class


Add Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..Add Method
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the AssocNavigationRefs.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


Clear Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..Clear Method
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


Contains Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..Contains Method
AssocNavigationRefs Class See Also Send Feedback
Determines whether an element is in the AssocNavigationRefs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocNavigationRefs.

Return Value

true if item is found in the AssocNavigationRefs.

Implements

IList..::..Contains(Object)

See Also

AssocNavigationRefs Class


CopyTo Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..CopyTo Method
AssocNavigationRefs Class See Also Send Feedback
Copies the entire AssocNavigationRefs to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from AssocNavigationRefs. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source AssocNavigationRefs is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source AssocNavigationRefs be cast automatically to the type of the destination array.

See Also

AssocNavigationRefs Class


GetEnumerator Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..GetEnumerator Method
AssocNavigationRefs Class See Also Send Feedback
Returns an enumerator for the entire AssocNavigationRefs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire AssocNavigationRefs

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

AssocNavigationRefs Class


IndexOf Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..IndexOf Method
AssocNavigationRefs Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefs or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocNavigationRefs.

Return Value

The zero-based index of the first occurrence of item within the entire AssocNavigationRefs, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

AssocNavigationRefs Class


Insert Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..Insert Method
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


Remove Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..Remove Method
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from AssocNavigationRefs.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


RemoveAt Method

[image]

Endeca Presentation API
AssocNavigationRefs..::..RemoveAt Method
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


AssocNavigationRefs Properties

[image] [image]

Endeca Presentation API
AssocNavigationRefs Properties
AssocNavigationRefs Class See Also Send Feedback

The AssocNavigationRefs type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocNavigationRefs.
Public property | DimRoots | Gets the roots of the set of dimensions that all the intersections in this group share and are from.
Public property | IsFixedSize | Gets a value indicating whether the AssocNavigationRefs has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocNavigationRefs is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocNavigationRefs is synchronized (thread-safe).
Public property | Item | Gets the DimValList at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocNavigationRefs Class


Count Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..Count Property
AssocNavigationRefs Class See Also Send Feedback
Gets the number of elements actually contained in the AssocNavigationRefs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the AssocNavigationRefs.

Implements

ICollection..::..Count

See Also

AssocNavigationRefs Class


DimRoots Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..DimRoots Property
AssocNavigationRefs Class See Also Send Feedback
Gets the roots of the set of dimensions that all the intersections in this group share and are from.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList DimRoots { get; }
Visual Basic
Public Overridable ReadOnly Property DimRoots As DimValList
    Get
Visual C++
public:
virtual property DimValList^ DimRoots {
    DimValList^ get ();
}

Field Value

DimValList containing the roots of the dimensions.

See Also

AssocNavigationRefs Class


IsFixedSize Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..IsFixedSize Property
AssocNavigationRefs Class See Also Send Feedback
Gets a value indicating whether the AssocNavigationRefs has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the AssocNavigationRefs is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

AssocNavigationRefs Class


IsReadOnly Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..IsReadOnly Property
AssocNavigationRefs Class See Also Send Feedback
Gets a value indicating whether the AssocNavigationRefs is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the AssocNavigationRefs is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

AssocNavigationRefs Class


IsSynchronized Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..IsSynchronized Property
AssocNavigationRefs Class See Also Send Feedback
Gets a value indicating whether access to the AssocNavigationRefs is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the AssocNavigationRefs is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

AssocNavigationRefs Class


Item Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..Item Property
AssocNavigationRefs Class See Also Send Feedback
Gets the DimValList at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimValList at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

AssocNavigationRefs Class


SyncRoot Property

[image]

Endeca Presentation API
AssocNavigationRefs..::..SyncRoot Property
AssocNavigationRefs Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the AssocNavigationRefs.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefs Class


AssocNavigationRefsList Class

[image]

Endeca Presentation API
AssocNavigationRefsList Class
Members See Also Send Feedback
List of value intersection groups exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AssocNavigationRefsList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class AssocNavigationRefsList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class AssocNavigationRefsList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..AssocNavigationRefsList

See Also

AssocNavigationRefsList Members


AssocNavigationRefsList Members

[image] [image]

Endeca Presentation API
AssocNavigationRefsList Members
AssocNavigationRefsList Class Methods Properties See Also Send Feedback

The AssocNavigationRefsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocNavigationRefsList.
Public method | CopyTo | Copies the entire AssocNavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocNavigationRefsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocNavigationRefsList.
Public property | IsFixedSize | Gets a value indicating whether the AssocNavigationRefsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocNavigationRefsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocNavigationRefsList is synchronized (thread-safe).
Public property | Item | Gets the AssocNavigationRefs at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocNavigationRefsList Class


AssocNavigationRefsList Methods

[image] [image]

Endeca Presentation API
AssocNavigationRefsList Methods
AssocNavigationRefsList Class See Also Send Feedback

The AssocNavigationRefsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the AssocNavigationRefsList.
Public method | CopyTo | Copies the entire AssocNavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire AssocNavigationRefsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssocNavigationRefsList Class


Add Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Add Method
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the AssocNavigationRefsList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


Clear Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Clear Method
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


Contains Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Contains Method
AssocNavigationRefsList Class See Also Send Feedback
Determines whether an element is in the AssocNavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocNavigationRefsList.

Return Value

true if item is found in the AssocNavigationRefsList.

Implements

IList..::..Contains(Object)

See Also

AssocNavigationRefsList Class


CopyTo Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..CopyTo Method
AssocNavigationRefsList Class See Also Send Feedback
Copies the entire AssocNavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from AssocNavigationRefsList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source AssocNavigationRefsList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source AssocNavigationRefsList be cast automatically to the type of the destination array.

See Also

AssocNavigationRefsList Class


GetEnumerator Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..GetEnumerator Method
AssocNavigationRefsList Class See Also Send Feedback
Returns an enumerator for the entire AssocNavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire AssocNavigationRefsList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

AssocNavigationRefsList Class


IndexOf Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..IndexOf Method
AssocNavigationRefsList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the AssocNavigationRefsList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the AssocNavigationRefsList.

Return Value

The zero-based index of the first occurrence of item within the entire AssocNavigationRefsList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

AssocNavigationRefsList Class


Insert Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Insert Method
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


Remove Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Remove Method
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from AssocNavigationRefsList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


RemoveAt Method

[image]

Endeca Presentation API
AssocNavigationRefsList..::..RemoveAt Method
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


AssocNavigationRefsList Properties

[image] [image]

Endeca Presentation API
AssocNavigationRefsList Properties
AssocNavigationRefsList Class See Also Send Feedback

The AssocNavigationRefsList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the AssocNavigationRefsList.
Public property | IsFixedSize | Gets a value indicating whether the AssocNavigationRefsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the AssocNavigationRefsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the AssocNavigationRefsList is synchronized (thread-safe).
Public property | Item | Gets the AssocNavigationRefs at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

AssocNavigationRefsList Class


Count Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Count Property
AssocNavigationRefsList Class See Also Send Feedback
Gets the number of elements actually contained in the AssocNavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the AssocNavigationRefsList.

Implements

ICollection..::..Count

See Also

AssocNavigationRefsList Class


IsFixedSize Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..IsFixedSize Property
AssocNavigationRefsList Class See Also Send Feedback
Gets a value indicating whether the AssocNavigationRefsList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the AssocNavigationRefsList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

AssocNavigationRefsList Class


IsReadOnly Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..IsReadOnly Property
AssocNavigationRefsList Class See Also Send Feedback
Gets a value indicating whether the AssocNavigationRefsList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the AssocNavigationRefsList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

AssocNavigationRefsList Class


IsSynchronized Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..IsSynchronized Property
AssocNavigationRefsList Class See Also Send Feedback
Gets a value indicating whether access to the AssocNavigationRefsList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the AssocNavigationRefsList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

AssocNavigationRefsList Class


Item Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..Item Property
AssocNavigationRefsList Class See Also Send Feedback
Gets the AssocNavigationRefs at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The AssocNavigationRefs at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

AssocNavigationRefsList Class


SyncRoot Property

[image]

Endeca Presentation API
AssocNavigationRefsList..::..SyncRoot Property
AssocNavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the AssocNavigationRefsList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

AssocNavigationRefsList Class


AuthHttpENEConnection Class

[image]

Endeca Presentation API
AuthHttpENEConnection Class
Members See Also Send Feedback
An extention of HttpENEConnection that provides connections to Endeca MDEX Engines that require authentication. Use instances of this class to connect to an Endeca MDEX Engine via the Endeca Access Control System.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class AuthHttpENEConnection : HttpENEConnection
Visual Basic
<SerializableAttribute> _
Public Class AuthHttpENEConnection _
    Inherits HttpENEConnection
Visual C++
[SerializableAttribute]
public ref class AuthHttpENEConnection : public HttpENEConnection

Remarks

Deprecated: This class may not be available in future versions of the Presentation API.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..HttpENEConnection
Endeca.Navigation..::..AuthHttpENEConnection

See Also

AuthHttpENEConnection Members


AuthHttpENEConnection Members

[image] [image]

Endeca Presentation API
AuthHttpENEConnection Members
AuthHttpENEConnection Class Constructors Methods Properties See Also Send Feedback

The AuthHttpENEConnection type exposes the following members.

Constructors

 | Name | Description
Public method | AuthHttpENEConnection()()()() | Default empty constructor.
Public method | AuthHttpENEConnection(String, Int32) | Constructor for connection to the Endeca MDEX Engine over HTTP.
Public method | AuthHttpENEConnection(String, String) | Constructor for connection to the Endeca MDEX Engine over HTTP.

Methods

 | Name | Description
Public method | AddHttpHeader | Add an HTTP header to the query request (Inherited from HttpENEConnection.)
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository (Inherited from HttpENEConnection.)
Public method | EnableSSL(X509Certificate) | Enables ssl (Inherited from HttpENEConnection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Login | Authenticate a user
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Issues a query against the MDEX Engine. (Overrides HttpENEConnection..::..Query(ENEQuery).)
Public method | SetPort | Sets the port of the MDEX Engine. (Inherited from HttpENEConnection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Hostname | Get and sets the hostname of the MDEX Engine. (Inherited from HttpENEConnection.)
Public property | MaxUrl | Get and set the maximum URL length (Inherited from HttpENEConnection.)
Public property | Port | Gets and sets the port of the MDEX Engine. (Inherited from HttpENEConnection.)

See Also

AuthHttpENEConnection Class


AuthHttpENEConnection Constructor

[image] [image]

Endeca Presentation API
AuthHttpENEConnection Constructor
AuthHttpENEConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AuthHttpENEConnection()()()() | Default empty constructor.
Public method | AuthHttpENEConnection(String, Int32) | Constructor for connection to the Endeca MDEX Engine over HTTP.
Public method | AuthHttpENEConnection(String, String) | Constructor for connection to the Endeca MDEX Engine over HTTP.

See Also

AuthHttpENEConnection Class
AuthHttpENEConnection Members


AuthHttpENEConnection Constructor

[image]

Endeca Presentation API
AuthHttpENEConnection Constructor
AuthHttpENEConnection Class See Also Send Feedback
Default empty constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AuthHttpENEConnection()
Visual Basic
Public Sub New
Visual C++
public:
AuthHttpENEConnection()

Remarks

Hostname and port need to be set and the Login(IAuthCredentialRequestHandler) method will need to be called before the Query(ENEQuery) method is called, else an ENEQueryException will be thrown.

See Also

AuthHttpENEConnection Class
AuthHttpENEConnection Overload


AuthHttpENEConnection Constructor (String, Int32)

[image]

Endeca Presentation API
AuthHttpENEConnection Constructor (String, Int32)
AuthHttpENEConnection Class See Also Send Feedback
Constructor for connection to the Endeca MDEX Engine over HTTP.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AuthHttpENEConnection(
    string hostname,
    int port
)
Visual Basic
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
AuthHttpENEConnection(
    String^ hostname,
    int port
)

Parameters

hostname
Type: System..::..String
Hostname or IP address of the MDEX Engine. Example: 127.0.0.1 or engine.endeca.com.
port
Type: System..::..Int32
Port of the MDEX Engine. Example: 5001.

Remarks

A user must be authenticated with Login(IAuthCredentialRequestHandler) before the Query(ENEQuery) method is called, otherwise an ENEAuthenticationException will be thrown.

See Also

AuthHttpENEConnection Class
AuthHttpENEConnection Overload


AuthHttpENEConnection Constructor (String, String)

[image]

Endeca Presentation API
AuthHttpENEConnection Constructor (String, String)
AuthHttpENEConnection Class See Also Send Feedback
Constructor for connection to the Endeca MDEX Engine over HTTP.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AuthHttpENEConnection(
    string hostname,
    string port
)
Visual Basic
Public Sub New ( _
    hostname As String, _
    port As String _
)
Visual C++
public:
AuthHttpENEConnection(
    String^ hostname,
    String^ port
)

Parameters

hostname
Type: System..::..String
Hostname or IP address of the MDEX Engine. Example: 127.0.0.1 or engine.endeca.com.
port
Type: System..::..String
Port of the MDEX Engine. Example: 5001.

Remarks

A user must be authenticated with Login(IAuthCredentialRequestHandler) before the Query(ENEQuery) method is called, otherwise an ENEAuthenticationException will be thrown.

See Also

AuthHttpENEConnection Class
AuthHttpENEConnection Overload


AuthHttpENEConnection Methods

[image] [image]

Endeca Presentation API
AuthHttpENEConnection Methods
AuthHttpENEConnection Class See Also Send Feedback

The AuthHttpENEConnection type exposes the following members.

Methods

 | Name | Description
Public method | AddHttpHeader | Add an HTTP header to the query request (Inherited from HttpENEConnection.)
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository (Inherited from HttpENEConnection.)
Public method | EnableSSL(X509Certificate) | Enables ssl (Inherited from HttpENEConnection.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Login | Authenticate a user
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Issues a query against the MDEX Engine. (Overrides HttpENEConnection..::..Query(ENEQuery).)
Public method | SetPort | Sets the port of the MDEX Engine. (Inherited from HttpENEConnection.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthHttpENEConnection Class


EnableSSL Method

[image] [image]

Endeca Presentation API
AuthHttpENEConnection..::..EnableSSL Method
AuthHttpENEConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository (Inherited from HttpENEConnection.)
Public method | EnableSSL(X509Certificate) | Enables ssl (Inherited from HttpENEConnection.)

See Also

AuthHttpENEConnection Class
AuthHttpENEConnection Members


Login Method

[image]

Endeca Presentation API
AuthHttpENEConnection..::..Login Method
AuthHttpENEConnection Class See Also Send Feedback
Authenticate a user

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Login(
    IAuthCredentialRequestHandler handler
)
Visual Basic
Public Overridable Sub Login ( _
    handler As IAuthCredentialRequestHandler _
)
Visual C++
public:
virtual void Login(
    IAuthCredentialRequestHandler^ handler
)

Parameters

handler
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler
An object instance that provides the mechanism to obtain credentials for authentication purposes.

See Also

AuthHttpENEConnection Class


Query Method

[image]

Endeca Presentation API
AuthHttpENEConnection..::..Query Method
AuthHttpENEConnection Class See Also Send Feedback
Issues a query against the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override ENEQueryResults Query(
    ENEQuery neq
)
Visual Basic
Public Overrides Function Query ( _
    neq As ENEQuery _
) As ENEQueryResults
Visual C++
public:
virtual ENEQueryResults^ Query(
    ENEQuery^ neq
) override

Parameters

neq
Type: Endeca.Navigation..::..ENEQuery
The ENEQuery object containing the navigation, record, etc. type requests to the MDEX Engine.

Return Value

An ENEQueryResults object which contains the resultant objects returned by the MDEX Engine in response to the query neq.

Implements

IENEConnection..::..Query(ENEQuery)

Exceptions

Exception | Condition
Endeca.Navigation..::..ENEQueryException | If there is a problem making the query. Possible subclasses of ENEQueryException that could be thrown are ENEConnectionException, EmptyENEQueryException, PartialENEQueryException, ENEException, and VersionMismatchException.

See Also

AuthHttpENEConnection Class


AuthHttpENEConnection Properties

[image] [image]

Endeca Presentation API
AuthHttpENEConnection Properties
AuthHttpENEConnection Class See Also Send Feedback

The AuthHttpENEConnection type exposes the following members.

Properties

 | Name | Description
Public property | Hostname | Get and sets the hostname of the MDEX Engine. (Inherited from HttpENEConnection.)
Public property | MaxUrl | Get and set the maximum URL length (Inherited from HttpENEConnection.)
Public property | Port | Gets and sets the port of the MDEX Engine. (Inherited from HttpENEConnection.)

See Also

AuthHttpENEConnection Class


Dimension Class

[image]

Endeca Presentation API
Dimension Class
Members See Also Send Feedback
Core component of a navigation state query encapsulating all information known about a dimension at the navigation state.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Dimension
Visual Basic
Public Class Dimension
Visual C++
public ref class Dimension

Remarks

A dimension is a collection of related dimension values (DimVal objects), organized into a tree. The top-most dimension value in a dimension tree is known as the dimension root. A dimension root always has the same name as its dimension.

Each dimension can belong to only a single dimension group (DimGroup object). If a dimension is not assigned to an explicit dimension group, it is placed in an implicit dimension group of its own. These implicit groups have no name and an ID of zero.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..Dimension

See Also

Dimension Members


Dimension Members

[image] [image]

Endeca Presentation API
Dimension Members
Dimension Class Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsImplicit | Determines if the dimension is fully implicit.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ancestors | Gets the ancestors pertinent to this dimension.
Public property | CompletePath | Returns the complete path of the dimension values consolidating ancestors, descriptor, and implicits in this order.
Public property | Descriptor | Gets the descriptor for this dimension.
Public property | DimGroupId | Gets the ID of the dimension group to which this dimension belongs.
Public property | DimGroupName | Gets the name of the dimension group to which this dimension belongs.
Public property | Id | Gets the ID of the dimension.
Public property | ImplicitLocations | Gets the implicit dimension locations contained in this dimension.
Public property | Intermediates | Gets the intermediate non-navigable refinements that have been selected and do not affect the query terms.
Public property | Name | Gets the name of the dimension.
Public property | RefinementParent | Gets the refinements' parent value in this dimension.
Public property | Refinements | Gets the refinements available and retrieved in this dimension.
Public property | Root | Gets the root dimension value of this dimension.

See Also

Dimension Class


Dimension Methods

[image] [image]

Endeca Presentation API
Dimension Methods
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsImplicit | Determines if the dimension is fully implicit.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dimension Class


IsImplicit Method

[image]

Endeca Presentation API
Dimension..::..IsImplicit Method
Dimension Class See Also Send Feedback
Determines if the dimension is fully implicit.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsImplicit()
Visual Basic
Public Overridable Function IsImplicit As Boolean
Visual C++
public:
virtual bool IsImplicit()

Return Value

true if the dimension is fully implicit, and false if the dimenension contains any valid refinements or a descriptor.

Remarks

A dimension is considered fully implicit if the dimension has no non-implicit refinements and has no descriptors. That is, the dimension no longer has any refinements that would narrow the size of the results set and has not had any selections made to it.

See Also

Dimension Class


Dimension Properties

[image] [image]

Endeca Presentation API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

 | Name | Description
Public property | Ancestors | Gets the ancestors pertinent to this dimension.
Public property | CompletePath | Returns the complete path of the dimension values consolidating ancestors, descriptor, and implicits in this order.
Public property | Descriptor | Gets the descriptor for this dimension.
Public property | DimGroupId | Gets the ID of the dimension group to which this dimension belongs.
Public property | DimGroupName | Gets the name of the dimension group to which this dimension belongs.
Public property | Id | Gets the ID of the dimension.
Public property | ImplicitLocations | Gets the implicit dimension locations contained in this dimension.
Public property | Intermediates | Gets the intermediate non-navigable refinements that have been selected and do not affect the query terms.
Public property | Name | Gets the name of the dimension.
Public property | RefinementParent | Gets the refinements' parent value in this dimension.
Public property | Refinements | Gets the refinements available and retrieved in this dimension.
Public property | Root | Gets the root dimension value of this dimension.

See Also

Dimension Class


Ancestors Property

[image]

Endeca Presentation API
Dimension..::..Ancestors Property
Dimension Class See Also Send Feedback
Gets the ancestors pertinent to this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList Ancestors { get; }
Visual Basic
Public Overridable ReadOnly Property Ancestors As DimValList
    Get
Visual C++
public:
virtual property DimValList^ Ancestors {
    DimValList^ get ();
}

Field Value

Ancestors of the descriptor of this dimension. If there is no descriptor or the descriptor has no ancestors, the DimValList returned will be empty.

Remarks

Will still return an empty DimValList if there are no ancestors. Ancestors will only appear if there is a descriptor for this dimension and if the descriptor has ancestors in the hierarchy of the dimension. Does not include the dimension root value. Ancestors are ordered from parent to child.

See Also

Dimension Class


CompletePath Property

[image]

Endeca Presentation API
Dimension..::..CompletePath Property
Dimension Class See Also Send Feedback
Returns the complete path of the dimension values consolidating ancestors, descriptor, and implicits in this order.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList CompletePath { get; }
Visual Basic
Public Overridable ReadOnly Property CompletePath As DimValList
    Get
Visual C++
public:
virtual property DimValList^ CompletePath {
    DimValList^ get ();
}

Field Value

Complete list (as a DimValList object) of dimension values from the dimension.

Remarks

Implicits are the the dimension values (DimVal objects) that are implicitly shared by all of the results in the remaining result set.

In the case where refinements are present in this dimension, the complete path will offer the complete path of dimension values, from the dimension root, ancestors, descriptor, implicit dimension values, and intermediates to the refinement parent.

In the case where there are multiple assignment of dimension values to a record in the result set, and there are no refinements remaining in this dimension, the complete path will offer one of the complete branches of implicit dimension values.

At the minimal case, this list would return the root dimension value of the dimension.

See Also

Dimension Class


Descriptor Property

[image]

Endeca Presentation API
Dimension..::..Descriptor Property
Dimension Class See Also Send Feedback
Gets the descriptor for this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal Descriptor { get; }
Visual Basic
Public Overridable ReadOnly Property Descriptor As DimVal
    Get
Visual C++
public:
virtual property DimVal^ Descriptor {
    DimVal^ get ();
}

Field Value

Descriptor (DimVal object) for this dimension, or null if there is none.

Remarks

If there is no descriptor in this dimension, null is returned.

See Also

Dimension Class


DimGroupId Property

[image]

Endeca Presentation API
Dimension..::..DimGroupId Property
Dimension Class See Also Send Feedback
Gets the ID of the dimension group to which this dimension belongs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimGroupId { get; }
Visual Basic
Public Overridable ReadOnly Property DimGroupId As Long
    Get
Visual C++
public:
virtual property long long DimGroupId {
    long long get ();
}

Field Value

ID of the dimension group to which this dimension belongs or 0 if it does not belong to a group.

Remarks

If the dimension does not belong to a dimension group, the method will return 0.

See Also

Dimension Class


DimGroupName Property

[image]

Endeca Presentation API
Dimension..::..DimGroupName Property
Dimension Class See Also Send Feedback
Gets the name of the dimension group to which this dimension belongs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimGroupName { get; }
Visual Basic
Public Overridable ReadOnly Property DimGroupName As String
    Get
Visual C++
public:
virtual property String^ DimGroupName {
    String^ get ();
}

Field Value

Name of the dimension group (DimGroup object) to which this dimension belongs or null if it does not belong to a group.

Remarks

If the dimension does not belong to a dimension group, the method will return null.

See Also

Dimension Class


Id Property

[image]

Endeca Presentation API
Dimension..::..Id Property
Dimension Class See Also Send Feedback
Gets the ID of the dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long Id { get; }
Visual Basic
Public Overridable ReadOnly Property Id As Long
    Get
Visual C++
public:
virtual property long long Id {
    long long get ();
}

Field Value

ID of the dimension.

See Also

Dimension Class


ImplicitLocations Property

[image]

Endeca Presentation API
Dimension..::..ImplicitLocations Property
Dimension Class See Also Send Feedback
Gets the implicit dimension locations contained in this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimLocationList ImplicitLocations { get; }
Visual Basic
Public Overridable ReadOnly Property ImplicitLocations As DimLocationList
    Get
Visual C++
public:
virtual property DimLocationList^ ImplicitLocations {
    DimLocationList^ get ();
}

Field Value

List of intermediates. If there are no intermediates an empty DimLocationList will be returned.

See Also

Dimension Class


Intermediates Property

[image]

Endeca Presentation API
Dimension..::..Intermediates Property
Dimension Class See Also Send Feedback
Gets the intermediate non-navigable refinements that have been selected and do not affect the query terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList Intermediates { get; }
Visual Basic
Public Overridable ReadOnly Property Intermediates As DimValList
    Get
Visual C++
public:
virtual property DimValList^ Intermediates {
    DimValList^ get ();
}

Field Value

List of intermediates. If there are no intermediates an empty DimValList will be returned.

Remarks

If there are no intermediates an empty DimValList will be returned. Intermediates are ordered from parent to child.

See Also

Dimension Class


Name Property

[image]

Endeca Presentation API
Dimension..::..Name Property
Dimension Class See Also Send Feedback
Gets the name of the dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name of the dimension.

See Also

Dimension Class


RefinementParent Property

[image]

Endeca Presentation API
Dimension..::..RefinementParent Property
Dimension Class See Also Send Feedback
Gets the refinements' parent value in this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal RefinementParent { get; }
Visual Basic
Public Overridable ReadOnly Property RefinementParent As DimVal
    Get
Visual C++
public:
virtual property DimVal^ RefinementParent {
    DimVal^ get ();
}

Field Value

Refinements' parent value (DimVal object) in this dimension. Returns null if there are no more refinement possiblities in this dimension.

Remarks

The parent value is the parent of the refinement options available with respect to the current navigation state in this dimension hierarchy. Returns null if there are no more refinements possible in this dimension.

See Also

Dimension Class


Refinements Property

[image]

Endeca Presentation API
Dimension..::..Refinements Property
Dimension Class See Also Send Feedback
Gets the refinements available and retrieved in this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList Refinements { get; }
Visual Basic
Public Overridable ReadOnly Property Refinements As DimValList
    Get
Visual C++
public:
virtual property DimValList^ Refinements {
    DimValList^ get ();
}

Field Value

Refinements available in this dimension. Returns an empty DimValList if no refinements are available.

Remarks

Returns an empty DimValList when there are no refinements available. It is possible that while the refinements may return a empty set, refinements are still possible if not all the refinements were retrieved from the MDEX Engine in the original query. Refinements are ordered by the higher ranking to lower ranking where the rankings are determined by the settings in the MDEX Engine and the data.

Each member of this refinement list can be added to the Descriptors and will yield at least one results.

See Also

Dimension Class


Root Property

[image]

Endeca Presentation API
Dimension..::..Root Property
Dimension Class See Also Send Feedback
Gets the root dimension value of this dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal Root { get; }
Visual Basic
Public Overridable ReadOnly Property Root As DimVal
    Get
Visual C++
public:
virtual property DimVal^ Root {
    DimVal^ get ();
}

Field Value

The root dimension value (DimVal object) of this dimension.

See Also

Dimension Class


DimensionList Class

[image]

Endeca Presentation API
DimensionList Class
Members See Also Send Feedback
List of dimensions (Dimension objects).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimensionList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class DimensionList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimensionList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimensionList

See Also

DimensionList Members


DimensionList Members

[image] [image]

Endeca Presentation API
DimensionList Members
DimensionList Class Methods Properties See Also Send Feedback

The DimensionList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimensionList.
Public method | CopyTo | Copies the entire DimensionList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimensionList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimensionList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimensionList.
Public property | IsFixedSize | Gets a value indicating whether the DimensionList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimensionList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimensionList is synchronized (thread-safe).
Public property | Item | Gets the Dimension at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimensionList Class


DimensionList Methods

[image] [image]

Endeca Presentation API
DimensionList Methods
DimensionList Class See Also Send Feedback

The DimensionList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimensionList.
Public method | CopyTo | Copies the entire DimensionList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimensionList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimensionList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionList Class


Add Method

[image]

Endeca Presentation API
DimensionList..::..Add Method
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimensionList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


Clear Method

[image]

Endeca Presentation API
DimensionList..::..Clear Method
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


Contains Method

[image]

Endeca Presentation API
DimensionList..::..Contains Method
DimensionList Class See Also Send Feedback
Determines whether an element is in the DimensionList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimensionList.

Return Value

true if item is found in the DimensionList.

Implements

IList..::..Contains(Object)

See Also

DimensionList Class


CopyTo Method

[image]

Endeca Presentation API
DimensionList..::..CopyTo Method
DimensionList Class See Also Send Feedback
Copies the entire DimensionList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimensionList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimensionList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimensionList be cast automatically to the type of the destination array.

See Also

DimensionList Class


GetDimension Method

[image] [image]

Endeca Presentation API
DimensionList..::..GetDimension Method
DimensionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.

See Also

DimensionList Class
DimensionList Members


GetDimension Method (Int64)

[image]

Endeca Presentation API
DimensionList..::..GetDimension Method (Int64)
DimensionList Class See Also Send Feedback
Gets the Dimension with the ID dimensionId from this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Dimension GetDimension(
    long dimensionId
)
Visual Basic
Public Overridable Function GetDimension ( _
    dimensionId As Long _
) As Dimension
Visual C++
public:
virtual Dimension^ GetDimension(
    long long dimensionId
)

Parameters

dimensionId
Type: System..::..Int64
ID of the dimension to get.

Return Value

Dimension with the ID dimensionId or null if the dimension is not found.

Remarks

If the dimension is not found in this list, null is returned. Note that when dealing with multi-select dimensions, it is possible for the list to have multiple Dimension objects for the same dimension. In this case, several share the same ID and this method does not define which one is returned.

See Also

DimensionList Class
GetDimension Overload


GetDimension Method (String)

[image]

Endeca Presentation API
DimensionList..::..GetDimension Method (String)
DimensionList Class See Also Send Feedback
Gets the Dimension with the name dimensionName from this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Dimension GetDimension(
    string dimensionName
)
Visual Basic
Public Overridable Function GetDimension ( _
    dimensionName As String _
) As Dimension
Visual C++
public:
virtual Dimension^ GetDimension(
    String^ dimensionName
)

Parameters

dimensionName
Type: System..::..String
Name of the dimension to get.

Return Value

Dimension with the name dimensionName or null if no such dimension is found.

Remarks

If the dimension is not found in this list null is returned. Note that several Dimension objects may share the same name and in this case this method does not define which one is returned.

See Also

DimensionList Class
GetDimension Overload


GetEnumerator Method

[image]

Endeca Presentation API
DimensionList..::..GetEnumerator Method
DimensionList Class See Also Send Feedback
Returns an enumerator for the entire DimensionList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimensionList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimensionList Class


IndexOf Method

[image]

Endeca Presentation API
DimensionList..::..IndexOf Method
DimensionList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimensionList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimensionList.

Return Value

The zero-based index of the first occurrence of item within the entire DimensionList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimensionList Class


Insert Method

[image]

Endeca Presentation API
DimensionList..::..Insert Method
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


Remove Method

[image]

Endeca Presentation API
DimensionList..::..Remove Method
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimensionList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


RemoveAt Method

[image]

Endeca Presentation API
DimensionList..::..RemoveAt Method
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


DimensionList Properties

[image] [image]

Endeca Presentation API
DimensionList Properties
DimensionList Class See Also Send Feedback

The DimensionList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimensionList.
Public property | IsFixedSize | Gets a value indicating whether the DimensionList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimensionList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimensionList is synchronized (thread-safe).
Public property | Item | Gets the Dimension at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimensionList Class


Count Property

[image]

Endeca Presentation API
DimensionList..::..Count Property
DimensionList Class See Also Send Feedback
Gets the number of elements actually contained in the DimensionList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimensionList.

Implements

ICollection..::..Count

See Also

DimensionList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimensionList..::..IsFixedSize Property
DimensionList Class See Also Send Feedback
Gets a value indicating whether the DimensionList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimensionList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimensionList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimensionList..::..IsReadOnly Property
DimensionList Class See Also Send Feedback
Gets a value indicating whether the DimensionList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimensionList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimensionList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimensionList..::..IsSynchronized Property
DimensionList Class See Also Send Feedback
Gets a value indicating whether access to the DimensionList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimensionList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimensionList Class


Item Property

[image]

Endeca Presentation API
DimensionList..::..Item Property
DimensionList Class See Also Send Feedback
Gets the Dimension at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The Dimension at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimensionList Class


SyncRoot Property

[image]

Endeca Presentation API
DimensionList..::..SyncRoot Property
DimensionList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimensionList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionList Class


DimensionSearchResult Class

[image]

Endeca Presentation API
DimensionSearchResult Class
Members See Also Send Feedback
Result class for a value search query. Class includes values queried for as well as other information about the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimensionSearchResult
Visual Basic
Public Class DimensionSearchResult
Visual C++
public ref class DimensionSearchResult

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimensionSearchResult

See Also

DimensionSearchResult Members


DimensionSearchResult Members

[image] [image]

Endeca Presentation API
DimensionSearchResult Members
DimensionSearchResult Class Methods Properties See Also Send Feedback

The DimensionSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimensionSearchResultGroup(Int64) | Gets the result group with id dimId. Returns null is no group can be found.
Public method | GetDimensionSearchResultGroup(DimValIdList) | Gets the result group with ids in the list dimIds. Returns null if no group can be found.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ESearchReports | Gets the IDictionary of ESearchReports for this dimension search result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.
Public property | ESearchReportsComplete | Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports
Public property | Item | Gets the result group at the specified index.
Public property | NumResultGroups | Gets the number of result groups.
Public property | Results | Gets the results grouped by dimension group. Returns an empty list if there are no results.
Public property | Supplements | Gets the supplements to this dimension search result.
Public property | TotalNumResults | Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

See Also

DimensionSearchResult Class


DimensionSearchResult Methods

[image] [image]

Endeca Presentation API
DimensionSearchResult Methods
DimensionSearchResult Class See Also Send Feedback

The DimensionSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimensionSearchResultGroup(Int64) | Gets the result group with id dimId. Returns null is no group can be found.
Public method | GetDimensionSearchResultGroup(DimValIdList) | Gets the result group with ids in the list dimIds. Returns null if no group can be found.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSearchResult Class


GetDimensionSearchResultGroup Method

[image] [image]

Endeca Presentation API
DimensionSearchResult..::..GetDimensionSearchResultGroup Method
DimensionSearchResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDimensionSearchResultGroup(Int64) | Gets the result group with id dimId. Returns null is no group can be found.
Public method | GetDimensionSearchResultGroup(DimValIdList) | Gets the result group with ids in the list dimIds. Returns null if no group can be found.

See Also

DimensionSearchResult Class
DimensionSearchResult Members


GetDimensionSearchResultGroup Method (Int64)

[image]

Endeca Presentation API
DimensionSearchResult..::..GetDimensionSearchResultGroup Method (Int64)
DimensionSearchResult Class See Also Send Feedback
Gets the result group with id dimId. Returns null is no group can be found.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionSearchResultGroup GetDimensionSearchResultGroup(
    long dimId
)
Visual Basic
Public Overridable Function GetDimensionSearchResultGroup ( _
    dimId As Long _
) As DimensionSearchResultGroup
Visual C++
public:
virtual DimensionSearchResultGroup^ GetDimensionSearchResultGroup(
    long long dimId
)

Parameters

dimId
Type: System..::..Int64
The single dimension ID to search for.

Return Value

Result group with dimension id dimId.

See Also

DimensionSearchResult Class
GetDimensionSearchResultGroup Overload


GetDimensionSearchResultGroup Method (DimValIdList)

[image]

Endeca Presentation API
DimensionSearchResult..::..GetDimensionSearchResultGroup Method (DimValIdList)
DimensionSearchResult Class See Also Send Feedback
Gets the result group with ids in the list dimIds. Returns null if no group can be found.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionSearchResultGroup GetDimensionSearchResultGroup(
    DimValIdList dimIds
)
Visual Basic
Public Overridable Function GetDimensionSearchResultGroup ( _
    dimIds As DimValIdList _
) As DimensionSearchResultGroup
Visual C++
public:
virtual DimensionSearchResultGroup^ GetDimensionSearchResultGroup(
    DimValIdList^ dimIds
)

Parameters

dimIds
Type: Endeca.Navigation..::..DimValIdList
The list of dimension IDs to search.

Return Value

Result group with dimension ids dimIds.

See Also

DimensionSearchResult Class
GetDimensionSearchResultGroup Overload


DimensionSearchResult Properties

[image] [image]

Endeca Presentation API
DimensionSearchResult Properties
DimensionSearchResult Class See Also Send Feedback

The DimensionSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | ESearchReports | Gets the IDictionary of ESearchReports for this dimension search result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.
Public property | ESearchReportsComplete | Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports
Public property | Item | Gets the result group at the specified index.
Public property | NumResultGroups | Gets the number of result groups.
Public property | Results | Gets the results grouped by dimension group. Returns an empty list if there are no results.
Public property | Supplements | Gets the supplements to this dimension search result.
Public property | TotalNumResults | Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

See Also

DimensionSearchResult Class


ESearchReports Property

[image]

Endeca Presentation API
DimensionSearchResult..::..ESearchReports Property
DimensionSearchResult Class See Also Send Feedback
Gets the IDictionary of ESearchReports for this dimension search result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionary ESearchReports { get; }
Visual Basic
Public Overridable ReadOnly Property ESearchReports As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ ESearchReports {
    IDictionary^ get ();
}

Field Value

An IDictionary of ESearchReport, keyed by the search term.

See Also

DimensionSearchResult Class


ESearchReportsComplete Property

[image]

Endeca Presentation API
DimensionSearchResult..::..ESearchReportsComplete Property
DimensionSearchResult Class See Also Send Feedback
Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionary ESearchReportsComplete { get; }
Visual Basic
Public Overridable ReadOnly Property ESearchReportsComplete As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ ESearchReportsComplete {
    IDictionary^ get ();
}

Field Value

An IDictionary of IList of ESearchReport, keyed by the search term.

See Also

DimensionSearchResult Class


Item Property

[image]

Endeca Presentation API
DimensionSearchResult..::..Item Property
DimensionSearchResult Class See Also Send Feedback
Gets the result group at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    index As Integer _
) As Object
    Get
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::..Int32
The position of the desired result group.

Field Value

The result group at the specified index.

See Also

DimensionSearchResult Class


NumResultGroups Property

[image]

Endeca Presentation API
DimensionSearchResult..::..NumResultGroups Property
DimensionSearchResult Class See Also Send Feedback
Gets the number of result groups.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int NumResultGroups { get; }
Visual Basic
Public Overridable ReadOnly Property NumResultGroups As Integer
    Get
Visual C++
public:
virtual property int NumResultGroups {
    int get ();
}

Field Value

Number of result groups.

See Also

DimensionSearchResult Class


Results Property

[image]

Endeca Presentation API
DimensionSearchResult..::..Results Property
DimensionSearchResult Class See Also Send Feedback
Gets the results grouped by dimension group. Returns an empty list if there are no results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionSearchResultGroupList Results { get; }
Visual Basic
Public Overridable ReadOnly Property Results As DimensionSearchResultGroupList
    Get
Visual C++
public:
virtual property DimensionSearchResultGroupList^ Results {
    DimensionSearchResultGroupList^ get ();
}

Field Value

Results grouped by dimension group.

See Also

DimensionSearchResult Class


Supplements Property

[image]

Endeca Presentation API
DimensionSearchResult..::..Supplements Property
DimensionSearchResult Class See Also Send Feedback
Gets the supplements to this dimension search result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual SupplementList Supplements { get; internal set; }
Visual Basic
Public Overridable Property Supplements As SupplementList
    Get
    Friend Set
Visual C++
public:
virtual property SupplementList^ Supplements {
    SupplementList^ get ();
    internal: void set (SupplementList^ value);
}

Field Value

A SupplementList containing the supplements to this dimension search result.

Remarks

Returns an empty set if there are no supplements.

See Also

DimensionSearchResult Class


TotalNumResults Property

[image]

Endeca Presentation API
DimensionSearchResult..::..TotalNumResults Property
DimensionSearchResult Class See Also Send Feedback
Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int TotalNumResults { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumResults As Integer
    Get
Visual C++
public:
virtual property int TotalNumResults {
    int get ();
}

Field Value

Total number of search results.

See Also

DimensionSearchResult Class


DimensionSearchResultGroup Class

[image]

Endeca Presentation API
DimensionSearchResultGroup Class
Members See Also Send Feedback
Class encapsulating a group of value intersection references that all share a similar set of dimensions. That is, every set of values in this group are from the same set of dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimensionSearchResultGroup
Visual Basic
Public Class DimensionSearchResultGroup
Visual C++
public ref class DimensionSearchResultGroup

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimensionSearchResultGroup

See Also

DimensionSearchResultGroup Members


DimensionSearchResultGroup Members

[image] [image]

Endeca Presentation API
DimensionSearchResultGroup Members
DimensionSearchResultGroup Class Methods Properties See Also Send Feedback

The DimensionSearchResultGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of results actually contained in this result group.
Public property | Item | Gets the dimension location list at the specified index.
Public property | Roots | Gets the roots of this result group.
Public property | TotalNumResults | Gets the total number of results for this result group found even if not all of them were returned because of the parameters of the query.

See Also

DimensionSearchResultGroup Class


DimensionSearchResultGroup Methods

[image] [image]

Endeca Presentation API
DimensionSearchResultGroup Methods
DimensionSearchResultGroup Class See Also Send Feedback

The DimensionSearchResultGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSearchResultGroup Class


DimensionSearchResultGroup Properties

[image] [image]

Endeca Presentation API
DimensionSearchResultGroup Properties
DimensionSearchResultGroup Class See Also Send Feedback

The DimensionSearchResultGroup type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of results actually contained in this result group.
Public property | Item | Gets the dimension location list at the specified index.
Public property | Roots | Gets the roots of this result group.
Public property | TotalNumResults | Gets the total number of results for this result group found even if not all of them were returned because of the parameters of the query.

See Also

DimensionSearchResultGroup Class


Count Property

[image]

Endeca Presentation API
DimensionSearchResultGroup..::..Count Property
DimensionSearchResultGroup Class See Also Send Feedback
Gets the number of results actually contained in this result group.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

Number of results actually contained in this result group.

See Also

DimensionSearchResultGroup Class


Item Property

[image]

Endeca Presentation API
DimensionSearchResultGroup..::..Item Property
DimensionSearchResultGroup Class See Also Send Feedback
Gets the dimension location list at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; }
Visual Basic
Public Overridable ReadOnly Default Property Item ( _
    index As Integer _
) As Object
    Get
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::..Int32
The position of the desired dimension location list.

Field Value

The result at the specified index.

See Also

DimensionSearchResultGroup Class


Roots Property

[image]

Endeca Presentation API
DimensionSearchResultGroup..::..Roots Property
DimensionSearchResultGroup Class See Also Send Feedback
Gets the roots of this result group.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList Roots { get; }
Visual Basic
Public Overridable ReadOnly Property Roots As DimValList
    Get
Visual C++
public:
virtual property DimValList^ Roots {
    DimValList^ get ();
}

Field Value

Roots of this result group.

See Also

DimensionSearchResultGroup Class


TotalNumResults Property

[image]

Endeca Presentation API
DimensionSearchResultGroup..::..TotalNumResults Property
DimensionSearchResultGroup Class See Also Send Feedback
Gets the total number of results for this result group found even if not all of them were returned because of the parameters of the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int TotalNumResults { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumResults As Integer
    Get
Visual C++
public:
virtual property int TotalNumResults {
    int get ();
}

Field Value

Total number of results for the group.

See Also

DimensionSearchResultGroup Class


DimensionSearchResultGroupList Class

[image]

Endeca Presentation API
DimensionSearchResultGroupList Class
Members See Also Send Feedback
List of value intersection groups exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimensionSearchResultGroupList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class DimensionSearchResultGroupList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimensionSearchResultGroupList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimensionSearchResultGroupList

See Also

DimensionSearchResultGroupList Members


DimensionSearchResultGroupList Members

[image] [image]

Endeca Presentation API
DimensionSearchResultGroupList Members
DimensionSearchResultGroupList Class Methods Properties See Also Send Feedback

The DimensionSearchResultGroupList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimensionSearchResultGroupList.
Public method | CopyTo | Copies the entire DimensionSearchResultGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimensionSearchResultGroupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimensionSearchResultGroupList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimensionSearchResultGroupList.
Public property | IsFixedSize | Gets a value indicating whether the DimensionSearchResultGroupList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimensionSearchResultGroupList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimensionSearchResultGroupList is synchronized (thread-safe).
Public property | Item | Gets the DimensionSearchResultGroup at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimensionSearchResultGroupList Class


DimensionSearchResultGroupList Methods

[image] [image]

Endeca Presentation API
DimensionSearchResultGroupList Methods
DimensionSearchResultGroupList Class See Also Send Feedback

The DimensionSearchResultGroupList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimensionSearchResultGroupList.
Public method | CopyTo | Copies the entire DimensionSearchResultGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimensionSearchResultGroupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimensionSearchResultGroupList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSearchResultGroupList Class


Add Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Add Method
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimensionSearchResultGroupList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


Clear Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Clear Method
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


Contains Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Contains Method
DimensionSearchResultGroupList Class See Also Send Feedback
Determines whether an element is in the DimensionSearchResultGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimensionSearchResultGroupList.

Return Value

true if item is found in the DimensionSearchResultGroupList.

Implements

IList..::..Contains(Object)

See Also

DimensionSearchResultGroupList Class


CopyTo Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..CopyTo Method
DimensionSearchResultGroupList Class See Also Send Feedback
Copies the entire DimensionSearchResultGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimensionSearchResultGroupList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimensionSearchResultGroupList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimensionSearchResultGroupList be cast automatically to the type of the destination array.

See Also

DimensionSearchResultGroupList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..GetEnumerator Method
DimensionSearchResultGroupList Class See Also Send Feedback
Returns an enumerator for the entire DimensionSearchResultGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimensionSearchResultGroupList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimensionSearchResultGroupList Class


IndexOf Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..IndexOf Method
DimensionSearchResultGroupList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimensionSearchResultGroupList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimensionSearchResultGroupList.

Return Value

The zero-based index of the first occurrence of item within the entire DimensionSearchResultGroupList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimensionSearchResultGroupList Class


Insert Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Insert Method
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


Remove Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Remove Method
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimensionSearchResultGroupList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


RemoveAt Method

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..RemoveAt Method
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


DimensionSearchResultGroupList Properties

[image] [image]

Endeca Presentation API
DimensionSearchResultGroupList Properties
DimensionSearchResultGroupList Class See Also Send Feedback

The DimensionSearchResultGroupList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimensionSearchResultGroupList.
Public property | IsFixedSize | Gets a value indicating whether the DimensionSearchResultGroupList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimensionSearchResultGroupList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimensionSearchResultGroupList is synchronized (thread-safe).
Public property | Item | Gets the DimensionSearchResultGroup at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimensionSearchResultGroupList Class


Count Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Count Property
DimensionSearchResultGroupList Class See Also Send Feedback
Gets the number of elements actually contained in the DimensionSearchResultGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimensionSearchResultGroupList.

Implements

ICollection..::..Count

See Also

DimensionSearchResultGroupList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..IsFixedSize Property
DimensionSearchResultGroupList Class See Also Send Feedback
Gets a value indicating whether the DimensionSearchResultGroupList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimensionSearchResultGroupList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimensionSearchResultGroupList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..IsReadOnly Property
DimensionSearchResultGroupList Class See Also Send Feedback
Gets a value indicating whether the DimensionSearchResultGroupList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimensionSearchResultGroupList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimensionSearchResultGroupList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..IsSynchronized Property
DimensionSearchResultGroupList Class See Also Send Feedback
Gets a value indicating whether access to the DimensionSearchResultGroupList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimensionSearchResultGroupList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimensionSearchResultGroupList Class


Item Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..Item Property
DimensionSearchResultGroupList Class See Also Send Feedback
Gets the DimensionSearchResultGroup at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimensionSearchResultGroup at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimensionSearchResultGroupList Class


SyncRoot Property

[image]

Endeca Presentation API
DimensionSearchResultGroupList..::..SyncRoot Property
DimensionSearchResultGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimensionSearchResultGroupList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimensionSearchResultGroupList Class


DimGroup Class

[image]

Endeca Presentation API
DimGroup Class
Members See Also Send Feedback
Class encapsulating a group of dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimGroup : IList, ICollection,
    IEnumerable
Visual Basic
Public Class DimGroup _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimGroup : IList,
    ICollection, IEnumerable

Remarks

Dimension groups provide a way to impose relationships on dimensions (Dimension objects). By creating a dimension group, dimensions can be organized for presentation purposes. Each explicit dimension group must be given a name; a unique ID is generated when the data is indexed.

If a dimension is not assigned to an explicit dimension group, it is placed in an implicit dimension group of its own. These implicit groups have no name and an ID of zero.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimGroup

See Also

DimGroup Members


DimGroup Members

[image] [image]

Endeca Presentation API
DimGroup Members
DimGroup Class Methods Properties See Also Send Feedback

The DimGroup type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimGroup.
Public method | CopyTo | Copies the entire DimGroup to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimGroup.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimGroup or in a portion of it.
Public method | Insert | This operation is not supported.
Public method | IsExplicit | Determines if the dimension group is an explicit or implicit dimension group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimGroup.
Public property | Id | Gets the ID of the dimension group.
Public property | IsFixedSize | Gets a value indicating whether the DimGroup has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimGroup is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimGroup is synchronized (thread-safe).
Public property | Item | Gets the Dimension at the specified index. The set operation is not supported.
Public property | Name | Gets the name of the dimension group.
Public property | SyncRoot | This operation is not supported.

See Also

DimGroup Class


DimGroup Methods

[image] [image]

Endeca Presentation API
DimGroup Methods
DimGroup Class See Also Send Feedback

The DimGroup type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimGroup.
Public method | CopyTo | Copies the entire DimGroup to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimGroup.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimGroup or in a portion of it.
Public method | Insert | This operation is not supported.
Public method | IsExplicit | Determines if the dimension group is an explicit or implicit dimension group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimGroup Class


Add Method

[image]

Endeca Presentation API
DimGroup..::..Add Method
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimGroup.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


Clear Method

[image]

Endeca Presentation API
DimGroup..::..Clear Method
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


Contains Method

[image]

Endeca Presentation API
DimGroup..::..Contains Method
DimGroup Class See Also Send Feedback
Determines whether an element is in the DimGroup.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimGroup.

Return Value

true if item is found in the DimGroup.

Implements

IList..::..Contains(Object)

See Also

DimGroup Class


CopyTo Method

[image]

Endeca Presentation API
DimGroup..::..CopyTo Method
DimGroup Class See Also Send Feedback
Copies the entire DimGroup to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimGroup. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimGroup is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimGroup be cast automatically to the type of the destination array.

See Also

DimGroup Class


GetDimension Method

[image] [image]

Endeca Presentation API
DimGroup..::..GetDimension Method
DimGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDimension(Int64) | Gets the Dimension with the ID dimensionId from this list.
Public method | GetDimension(String) | Gets the Dimension with the name dimensionName from this list.

See Also

DimGroup Class
DimGroup Members


GetDimension Method (Int64)

[image]

Endeca Presentation API
DimGroup..::..GetDimension Method (Int64)
DimGroup Class See Also Send Feedback
Gets the Dimension with the ID dimensionId from this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Dimension GetDimension(
    long dimensionId
)
Visual Basic
Public Overridable Function GetDimension ( _
    dimensionId As Long _
) As Dimension
Visual C++
public:
virtual Dimension^ GetDimension(
    long long dimensionId
)

Parameters

dimensionId
Type: System..::..Int64
ID of the Dimension to get.

Return Value

Dimension with the ID dimensionId or null if no dimension is found.

Remarks

Note that when dealing with multi-select dimensions, it is possible to have a list with multiple Dimension objects for the same dimension. In this case, several share the same ID and this method does not define which one is returned.

See Also

DimGroup Class
GetDimension Overload


GetDimension Method (String)

[image]

Endeca Presentation API
DimGroup..::..GetDimension Method (String)
DimGroup Class See Also Send Feedback
Gets the Dimension with the name dimensionName from this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Dimension GetDimension(
    string dimensionName
)
Visual Basic
Public Overridable Function GetDimension ( _
    dimensionName As String _
) As Dimension
Visual C++
public:
virtual Dimension^ GetDimension(
    String^ dimensionName
)

Parameters

dimensionName
Type: System..::..String
Name of the Dimension to get.

Return Value

Dimension with the name dimensionName or null if no dimension was found.

Remarks

If the dimension is not found in this list, null is returned. Several dimensions may share the same name and in this case this method does not define which one is returned.

See Also

DimGroup Class
GetDimension Overload


GetEnumerator Method

[image]

Endeca Presentation API
DimGroup..::..GetEnumerator Method
DimGroup Class See Also Send Feedback
Returns an enumerator for the entire DimGroup.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimGroup

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimGroup Class


IndexOf Method

[image]

Endeca Presentation API
DimGroup..::..IndexOf Method
DimGroup Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimGroup or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimGroup.

Return Value

The zero-based index of the first occurrence of item within the entire DimGroup, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimGroup Class


Insert Method

[image]

Endeca Presentation API
DimGroup..::..Insert Method
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


IsExplicit Method

[image]

Endeca Presentation API
DimGroup..::..IsExplicit Method
DimGroup Class See Also Send Feedback
Determines if the dimension group is an explicit or implicit dimension group.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsExplicit()
Visual Basic
Public Overridable Function IsExplicit As Boolean
Visual C++
public:
virtual bool IsExplicit()

Return Value

true if the dimension group is an explicit dimension; false if it is an implicit dimension group.

See Also

DimGroup Class


Remove Method

[image]

Endeca Presentation API
DimGroup..::..Remove Method
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimGroup.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


RemoveAt Method

[image]

Endeca Presentation API
DimGroup..::..RemoveAt Method
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


DimGroup Properties

[image] [image]

Endeca Presentation API
DimGroup Properties
DimGroup Class See Also Send Feedback

The DimGroup type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimGroup.
Public property | Id | Gets the ID of the dimension group.
Public property | IsFixedSize | Gets a value indicating whether the DimGroup has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimGroup is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimGroup is synchronized (thread-safe).
Public property | Item | Gets the Dimension at the specified index. The set operation is not supported.
Public property | Name | Gets the name of the dimension group.
Public property | SyncRoot | This operation is not supported.

See Also

DimGroup Class


Count Property

[image]

Endeca Presentation API
DimGroup..::..Count Property
DimGroup Class See Also Send Feedback
Gets the number of elements actually contained in the DimGroup.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimGroup.

Implements

ICollection..::..Count

See Also

DimGroup Class


Id Property

[image]

Endeca Presentation API
DimGroup..::..Id Property
DimGroup Class See Also Send Feedback
Gets the ID of the dimension group.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long Id { get; }
Visual Basic
Public Overridable ReadOnly Property Id As Long
    Get
Visual C++
public:
virtual property long long Id {
    long long get ();
}

Field Value

ID of the dimension group. Returns 0 if the dimension group does not have an ID (i.e., is an implicit dimension group).

See Also

DimGroup Class


IsFixedSize Property

[image]

Endeca Presentation API
DimGroup..::..IsFixedSize Property
DimGroup Class See Also Send Feedback
Gets a value indicating whether the DimGroup has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimGroup is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimGroup Class


IsReadOnly Property

[image]

Endeca Presentation API
DimGroup..::..IsReadOnly Property
DimGroup Class See Also Send Feedback
Gets a value indicating whether the DimGroup is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimGroup is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimGroup Class


IsSynchronized Property

[image]

Endeca Presentation API
DimGroup..::..IsSynchronized Property
DimGroup Class See Also Send Feedback
Gets a value indicating whether access to the DimGroup is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimGroup is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimGroup Class


Item Property

[image]

Endeca Presentation API
DimGroup..::..Item Property
DimGroup Class See Also Send Feedback
Gets the Dimension at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The Dimension at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimGroup Class


Name Property

[image]

Endeca Presentation API
DimGroup..::..Name Property
DimGroup Class See Also Send Feedback
Gets the name of the dimension group.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

Name of the dimension group, or null if it does not have a name (i.e., is an implicit dimension group).

See Also

DimGroup Class


SyncRoot Property

[image]

Endeca Presentation API
DimGroup..::..SyncRoot Property
DimGroup Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimGroup.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroup Class


DimGroupList Class

[image]

Endeca Presentation API
DimGroupList Class
Members See Also Send Feedback
List of dimension groups exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimGroupList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class DimGroupList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimGroupList : IList,
    ICollection, IEnumerable

Remarks

The dimension groups (DimGroup objects) can be explicit dimension groups (which have a name and a unique ID) or implicit dimension groups (which have no name and an ID of zero).

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimGroupList

See Also

DimGroupList Members


DimGroupList Members

[image] [image]

Endeca Presentation API
DimGroupList Members
DimGroupList Class Methods Properties See Also Send Feedback

The DimGroupList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimGroupList.
Public method | CopyTo | Copies the entire DimGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimGroup | Gets the DimGroup with the name dimensionGroupName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimGroupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimGroupList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimGroupList.
Public property | IsFixedSize | Gets a value indicating whether the DimGroupList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimGroupList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimGroupList is synchronized (thread-safe).
Public property | Item | Gets the DimGroup at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimGroupList Class


DimGroupList Methods

[image] [image]

Endeca Presentation API
DimGroupList Methods
DimGroupList Class See Also Send Feedback

The DimGroupList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimGroupList.
Public method | CopyTo | Copies the entire DimGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDimGroup | Gets the DimGroup with the name dimensionGroupName from this list.
Public method | GetEnumerator | Returns an enumerator for the entire DimGroupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimGroupList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimGroupList Class


Add Method

[image]

Endeca Presentation API
DimGroupList..::..Add Method
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimGroupList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


Clear Method

[image]

Endeca Presentation API
DimGroupList..::..Clear Method
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


Contains Method

[image]

Endeca Presentation API
DimGroupList..::..Contains Method
DimGroupList Class See Also Send Feedback
Determines whether an element is in the DimGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimGroupList.

Return Value

true if item is found in the DimGroupList.

Implements

IList..::..Contains(Object)

See Also

DimGroupList Class


CopyTo Method

[image]

Endeca Presentation API
DimGroupList..::..CopyTo Method
DimGroupList Class See Also Send Feedback
Copies the entire DimGroupList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimGroupList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimGroupList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimGroupList be cast automatically to the type of the destination array.

See Also

DimGroupList Class


GetDimGroup Method

[image]

Endeca Presentation API
DimGroupList..::..GetDimGroup Method
DimGroupList Class See Also Send Feedback
Gets the DimGroup with the name dimensionGroupName from this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimGroup GetDimGroup(
    string dimensionGroupName
)
Visual Basic
Public Overridable Function GetDimGroup ( _
    dimensionGroupName As String _
) As DimGroup
Visual C++
public:
virtual DimGroup^ GetDimGroup(
    String^ dimensionGroupName
)

Parameters

dimensionGroupName
Type: System..::..String
The name of the dimension group to find.

Return Value

Dimension group with the name dimensionGroupName or null if the dimension group is not found.

Remarks

If the dimension group is not found in this list null is returned.

See Also

DimGroupList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimGroupList..::..GetEnumerator Method
DimGroupList Class See Also Send Feedback
Returns an enumerator for the entire DimGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimGroupList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimGroupList Class


IndexOf Method

[image]

Endeca Presentation API
DimGroupList..::..IndexOf Method
DimGroupList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimGroupList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimGroupList.

Return Value

The zero-based index of the first occurrence of item within the entire DimGroupList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimGroupList Class


Insert Method

[image]

Endeca Presentation API
DimGroupList..::..Insert Method
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


Remove Method

[image]

Endeca Presentation API
DimGroupList..::..Remove Method
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimGroupList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


RemoveAt Method

[image]

Endeca Presentation API
DimGroupList..::..RemoveAt Method
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


DimGroupList Properties

[image] [image]

Endeca Presentation API
DimGroupList Properties
DimGroupList Class See Also Send Feedback

The DimGroupList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimGroupList.
Public property | IsFixedSize | Gets a value indicating whether the DimGroupList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimGroupList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimGroupList is synchronized (thread-safe).
Public property | Item | Gets the DimGroup at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimGroupList Class


Count Property

[image]

Endeca Presentation API
DimGroupList..::..Count Property
DimGroupList Class See Also Send Feedback
Gets the number of elements actually contained in the DimGroupList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimGroupList.

Implements

ICollection..::..Count

See Also

DimGroupList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimGroupList..::..IsFixedSize Property
DimGroupList Class See Also Send Feedback
Gets a value indicating whether the DimGroupList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimGroupList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimGroupList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimGroupList..::..IsReadOnly Property
DimGroupList Class See Also Send Feedback
Gets a value indicating whether the DimGroupList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimGroupList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimGroupList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimGroupList..::..IsSynchronized Property
DimGroupList Class See Also Send Feedback
Gets a value indicating whether access to the DimGroupList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimGroupList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimGroupList Class


Item Property

[image]

Endeca Presentation API
DimGroupList..::..Item Property
DimGroupList Class See Also Send Feedback
Gets the DimGroup at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimGroup at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimGroupList Class


SyncRoot Property

[image]

Endeca Presentation API
DimGroupList..::..SyncRoot Property
DimGroupList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimGroupList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimGroupList Class


DimLocation Class

[image]

Endeca Presentation API
DimLocation Class
Members See Also Send Feedback
DimLocation represents a specific location in a dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimLocation
Visual Basic
Public Class DimLocation
Visual C++
public ref class DimLocation

Remarks

The dimension location comprises one dimension value (DimVal object) and a DimValList that contains all of the dimension location’s ancestors (also DimVal objects) up to, but not including, the dimension root.

DimLocation objects are returned as part of an Endeca record, via an AssocDimLocationsList object in the ERec data structure. The dimension locations designate the record’s location within the dimension hierarchy.

Note that when returned in an AssocDimLocations object, the dimension locations are all from the same dimension. However, when returned in a DimLocationList object, the dimension locations can be from different dimensions (which is typically the result of a compound dimension search).

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimLocation

See Also

DimLocation Members


DimLocation Members

[image] [image]

Endeca Presentation API
DimLocation Members
DimLocation Class Methods Properties See Also Send Feedback

The DimLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ancestors | Gets the ancestors of the dimension location.
Public property | DimValue | Gets the dimension value of this dimension location.

See Also

DimLocation Class


DimLocation Methods

[image] [image]

Endeca Presentation API
DimLocation Methods
DimLocation Class See Also Send Feedback

The DimLocation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimLocation Class


DimLocation Properties

[image] [image]

Endeca Presentation API
DimLocation Properties
DimLocation Class See Also Send Feedback

The DimLocation type exposes the following members.

Properties

 | Name | Description
Public property | Ancestors | Gets the ancestors of the dimension location.
Public property | DimValue | Gets the dimension value of this dimension location.

See Also

DimLocation Class


Ancestors Property

[image]

Endeca Presentation API
DimLocation..::..Ancestors Property
DimLocation Class See Also Send Feedback
Gets the ancestors of the dimension location.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValList Ancestors { get; }
Visual Basic
Public Overridable ReadOnly Property Ancestors As DimValList
    Get
Visual C++
public:
virtual property DimValList^ Ancestors {
    DimValList^ get ();
}

Field Value

A DimValList object containing the ancestors of this dimension location.

Remarks

Ancestors are ordered from parent to child (the list does not include the dimension root).

See Also

DimLocation Class


DimValue Property

[image]

Endeca Presentation API
DimLocation..::..DimValue Property
DimLocation Class See Also Send Feedback
Gets the dimension value of this dimension location.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal DimValue { get; }
Visual Basic
Public Overridable ReadOnly Property DimValue As DimVal
    Get
Visual C++
public:
virtual property DimVal^ DimValue {
    DimVal^ get ();
}

Field Value

Dimension value (DimVal object) of this DimLocation.

See Also

DimLocation Class


DimLocationList Class

[image]

Endeca Presentation API
DimLocationList Class
Members See Also Send Feedback
List containing DimLocation objects exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimLocationList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class DimLocationList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimLocationList : IList,
    ICollection, IEnumerable

Remarks

Unlike AssocDimLocations objects, the DimLocation objects in a DimLocationList can be from different dimensions. Therefore, the contents of a DimLocationList often contain values from different dimensions. As such, the intended use of this class is to return results from a compound dimension search. Each individual compound dimension search result is a DimLocationList and typically contains dimension values from multiple dimensions.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimLocationList

See Also

DimLocationList Members


DimLocationList Members

[image] [image]

Endeca Presentation API
DimLocationList Members
DimLocationList Class Methods Properties See Also Send Feedback

The DimLocationList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether a DimLocation element is in the DimLocationList.
Public method | CopyTo | Copies the entire DimLocationList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimLocationList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an element in the DimLocationList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimLocationList.
Public property | IsFixedSize | Gets a value indicating whether the DimLocationList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimLocationList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimLocationList is synchronized (thread-safe).
Public property | Item | Gets the DimLocation at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimLocationList Class


DimLocationList Methods

[image] [image]

Endeca Presentation API
DimLocationList Methods
DimLocationList Class See Also Send Feedback

The DimLocationList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether a DimLocation element is in the DimLocationList.
Public method | CopyTo | Copies the entire DimLocationList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimLocationList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an element in the DimLocationList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimLocationList Class


Add Method

[image]

Endeca Presentation API
DimLocationList..::..Add Method
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimLocationList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


Clear Method

[image]

Endeca Presentation API
DimLocationList..::..Clear Method
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


Contains Method

[image]

Endeca Presentation API
DimLocationList..::..Contains Method
DimLocationList Class See Also Send Feedback
Determines whether a DimLocation element is in the DimLocationList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The DimLocation object to locate in the DimLocationList.

Return Value

true if item is found in the DimLocationList.

Implements

IList..::..Contains(Object)

See Also

DimLocationList Class


CopyTo Method

[image]

Endeca Presentation API
DimLocationList..::..CopyTo Method
DimLocationList Class See Also Send Feedback
Copies the entire DimLocationList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimLocationList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimLocationList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimLocationList be cast automatically to the type of the destination array.

See Also

DimLocationList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimLocationList..::..GetEnumerator Method
DimLocationList Class See Also Send Feedback
Returns an enumerator for the entire DimLocationList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimLocationList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimLocationList Class


IndexOf Method

[image]

Endeca Presentation API
DimLocationList..::..IndexOf Method
DimLocationList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an element in the DimLocationList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The DimLocation object to locate in the DimLocationList.

Return Value

The zero-based index of the first occurrence of item within the entire DimLocationList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimLocationList Class


Insert Method

[image]

Endeca Presentation API
DimLocationList..::..Insert Method
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


Remove Method

[image]

Endeca Presentation API
DimLocationList..::..Remove Method
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimLocationList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


RemoveAt Method

[image]

Endeca Presentation API
DimLocationList..::..RemoveAt Method
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


DimLocationList Properties

[image] [image]

Endeca Presentation API
DimLocationList Properties
DimLocationList Class See Also Send Feedback

The DimLocationList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimLocationList.
Public property | IsFixedSize | Gets a value indicating whether the DimLocationList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimLocationList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimLocationList is synchronized (thread-safe).
Public property | Item | Gets the DimLocation at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimLocationList Class


Count Property

[image]

Endeca Presentation API
DimLocationList..::..Count Property
DimLocationList Class See Also Send Feedback
Gets the number of elements actually contained in the DimLocationList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of DimLocation objects actually contained in the DimLocationList.

Implements

ICollection..::..Count

See Also

DimLocationList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimLocationList..::..IsFixedSize Property
DimLocationList Class See Also Send Feedback
Gets a value indicating whether the DimLocationList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimLocationList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimLocationList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimLocationList..::..IsReadOnly Property
DimLocationList Class See Also Send Feedback
Gets a value indicating whether the DimLocationList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimLocationList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimLocationList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimLocationList..::..IsSynchronized Property
DimLocationList Class See Also Send Feedback
Gets a value indicating whether access to the DimLocationList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimLocationList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimLocationList Class


Item Property

[image]

Endeca Presentation API
DimLocationList..::..Item Property
DimLocationList Class See Also Send Feedback
Gets the DimLocation at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimLocation at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimLocationList Class


SyncRoot Property

[image]

Endeca Presentation API
DimLocationList..::..SyncRoot Property
DimLocationList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimLocationList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimLocationList Class


DimSearchRefinementConfig Class

[image]

Endeca Presentation API
DimSearchRefinementConfig Class
Members See Also Send Feedback
Class representing a refinement config for dimension search. The only option available in this class is the ability to turn counts on or off.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimSearchRefinementConfig : RefinementConfigBase
Visual Basic
Public Class DimSearchRefinementConfig _
    Inherits RefinementConfigBase
Visual C++
public ref class DimSearchRefinementConfig : public RefinementConfigBase

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RefinementConfigBase
Endeca.Navigation..::..DimSearchRefinementConfig

See Also

DimSearchRefinementConfig Members


DimSearchRefinementConfig Members

[image] [image]

Endeca Presentation API
DimSearchRefinementConfig Members
DimSearchRefinementConfig Class Constructors Methods Properties See Also Send Feedback

The DimSearchRefinementConfig type exposes the following members.

Constructors

Name Description
Public method DimSearchRefinementConfig
Default constructor where the
CopyC#
dimValId
 specifies the dimension value this dimension search refinement config is associated with.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId | (Inherited from RefinementConfigBase.)
Protected method | parseShowCounts | (Inherited from RefinementConfigBase.)
Protected method | parseSynonyms | (Inherited from RefinementConfigBase.)
Public method | ToString | Returns the string representation of the dimension search refinement config.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config. (Inherited from RefinementConfigBase.)
Public property | NumResults | Accessor which gets/sets the maximum number of results to return for the dimension.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)

See Also

DimSearchRefinementConfig Class


DimSearchRefinementConfig Constructor

[image]

Endeca Presentation API
DimSearchRefinementConfig Constructor
DimSearchRefinementConfig Class See Also Send Feedback
Default constructor where the
CopyC#
dimValId
 specifies the dimension value this dimension search refinement config is associated with.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DimSearchRefinementConfig(
    long dimValId
)
Visual Basic
Public Sub New ( _
    dimValId As Long _
)
Visual C++
public:
DimSearchRefinementConfig(
    long long dimValId
)

Parameters

dimValId
Type: System..::..Int64
Specifies which dimension value this dimension search refinement config is associated with.

See Also

DimSearchRefinementConfig Class


DimSearchRefinementConfig Methods

[image] [image]

Endeca Presentation API
DimSearchRefinementConfig Methods
DimSearchRefinementConfig Class See Also Send Feedback

The DimSearchRefinementConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId | (Inherited from RefinementConfigBase.)
Protected method | parseShowCounts | (Inherited from RefinementConfigBase.)
Protected method | parseSynonyms | (Inherited from RefinementConfigBase.)
Public method | ToString | Returns the string representation of the dimension search refinement config.

See Also

DimSearchRefinementConfig Class


ToString Method

[image]

Endeca Presentation API
DimSearchRefinementConfig..::..ToString Method
DimSearchRefinementConfig Class See Also Send Feedback
Returns the string representation of the dimension search refinement config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

The string representation of the dimension search refinement config.

See Also

DimSearchRefinementConfig Class


DimSearchRefinementConfig Properties

[image] [image]

Endeca Presentation API
DimSearchRefinementConfig Properties
DimSearchRefinementConfig Class See Also Send Feedback

The DimSearchRefinementConfig type exposes the following members.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config. (Inherited from RefinementConfigBase.)
Public property | NumResults | Accessor which gets/sets the maximum number of results to return for the dimension.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)

See Also

DimSearchRefinementConfig Class


NumResults Property

[image]

Endeca Presentation API
DimSearchRefinementConfig..::..NumResults Property
DimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets the maximum number of results to return for the dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalInt NumResults { get; set; }
Visual Basic
Public Property NumResults As OptionalInt
    Get
    Set
Visual C++
public:
property OptionalInt^ NumResults {
    OptionalInt^ get ();
    void set (OptionalInt^ value);
}

See Also

DimSearchRefinementConfig Class


DimSearchRefinementConfigList Class

[image]

Endeca Presentation API
DimSearchRefinementConfigList Class
Members See Also Send Feedback
Class that encapsulates a collection of dimension search refinement config (DimSearchRefinementConfig) objects.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimSearchRefinementConfigList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class DimSearchRefinementConfigList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimSearchRefinementConfigList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimSearchRefinementConfigList

See Also

DimSearchRefinementConfigList Members


DimSearchRefinementConfigList Members

[image] [image]

Endeca Presentation API
DimSearchRefinementConfigList Members
DimSearchRefinementConfigList Class Constructors Methods Properties See Also Send Feedback

The DimSearchRefinementConfigList type exposes the following members.

Constructors

 | Name | Description
Public method | DimSearchRefinementConfigList | Default constructor that creates an empty list.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
DimSearchRefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the DimSearchRefinementConfigList.
Public method Contains
Determines whether an element is in the DimSearchRefinementConfigList.
Public method CopyTo
Copies the entire DimSearchRefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire DimSearchRefinementConfigList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the DimSearchRefinementConfigList or in a portion of it.
Public method Insert
Inserts an element into the DimSearchRefinementConfigList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the DimSearchRefinementConfigList.
Public method RemoveAt
Removes the element at the specified index of the DimSearchRefinementConfigList.
Public method ToString
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimSearchRefinementConfigList.
Public property | GlobalDimSearchRefinementConfig | Accessor which gets/sets the global dimension search configuration associated with this refinement config.
Public property | IsFixedSize | Gets a value indicating whether the DimSearchRefinementConfigList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimSearchRefinementConfigList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimSearchRefinementConfigList is synchronized (thread-safe).
Public property | Item | Gets and sets the DimSearchRefinementConfig at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

DimSearchRefinementConfigList Class


DimSearchRefinementConfigList Constructor

[image]

Endeca Presentation API
DimSearchRefinementConfigList Constructor
DimSearchRefinementConfigList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DimSearchRefinementConfigList()
Visual Basic
Public Sub New
Visual C++
public:
DimSearchRefinementConfigList()

See Also

DimSearchRefinementConfigList Class


DimSearchRefinementConfigList Methods

[image] [image]

Endeca Presentation API
DimSearchRefinementConfigList Methods
DimSearchRefinementConfigList Class See Also Send Feedback

The DimSearchRefinementConfigList type exposes the following members.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
DimSearchRefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the DimSearchRefinementConfigList.
Public method Contains
Determines whether an element is in the DimSearchRefinementConfigList.
Public method CopyTo
Copies the entire DimSearchRefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire DimSearchRefinementConfigList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the DimSearchRefinementConfigList or in a portion of it.
Public method Insert
Inserts an element into the DimSearchRefinementConfigList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the DimSearchRefinementConfigList.
Public method RemoveAt
Removes the element at the specified index of the DimSearchRefinementConfigList.
Public method ToString
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

See Also

DimSearchRefinementConfigList Class


Add Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Add Method
DimSearchRefinementConfigList Class See Also Send Feedback
Inserts the specified
CopyC#
DimSearchRefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The offset of the element
elementAt
Type: System..::..Object
The element to be inserted.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If index is out of range.

See Also

DimSearchRefinementConfigList Class


Clear Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Clear Method
DimSearchRefinementConfigList Class See Also Send Feedback
Removes all the elements from the DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The DimSearchRefinementConfigList is read-only. -or- The DimSearchRefinementConfigList has a fixed-size.

See Also

DimSearchRefinementConfigList Class


Contains Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Contains Method
DimSearchRefinementConfigList Class See Also Send Feedback
Determines whether an element is in the DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimSearchRefinementConfigList.

Return Value

true if item is found in the DimSearchRefinementConfigList.

Implements

IList..::..Contains(Object)

See Also

DimSearchRefinementConfigList Class


CopyTo Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..CopyTo Method
DimSearchRefinementConfigList Class See Also Send Feedback
Copies the entire DimSearchRefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimSearchRefinementConfigList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimSearchRefinementConfigList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimSearchRefinementConfigList be cast automatically to the type of the destination array.

See Also

DimSearchRefinementConfigList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..GetEnumerator Method
DimSearchRefinementConfigList Class See Also Send Feedback
Returns an enumerator for the entire DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimSearchRefinementConfigList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimSearchRefinementConfigList Class


IndexOf Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..IndexOf Method
DimSearchRefinementConfigList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimSearchRefinementConfigList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimSearchRefinementConfigList.

Return Value

The zero-based index of the first occurrence of item within the entire DimSearchRefinementConfigList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimSearchRefinementConfigList Class


Insert Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Insert Method
DimSearchRefinementConfigList Class See Also Send Feedback
Inserts an element into the DimSearchRefinementConfigList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The DimSearchRefinementConfigList is read-only. -or- The DimSearchRefinementConfigList has a fixed-size.

See Also

DimSearchRefinementConfigList Class


Remove Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Remove Method
DimSearchRefinementConfigList Class See Also Send Feedback
Removes the first occurence of a specified object from the DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimSearchRefinementConfigList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The DimSearchRefinementConfigList is read-only. -or- The DimSearchRefinementConfigList has a fixed-size.

See Also

DimSearchRefinementConfigList Class


RemoveAt Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..RemoveAt Method
DimSearchRefinementConfigList Class See Also Send Feedback
Removes the element at the specified index of the DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The DimSearchRefinementConfigList is read-only. -or- The DimSearchRefinementConfigList has a fixed-size.

See Also

DimSearchRefinementConfigList Class


ToString Method

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..ToString Method
DimSearchRefinementConfigList Class See Also Send Feedback
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.DimSearchRefinementConfigList.ToString"]

See Also

DimSearchRefinementConfigList Class


DimSearchRefinementConfigList Properties

[image] [image]

Endeca Presentation API
DimSearchRefinementConfigList Properties
DimSearchRefinementConfigList Class See Also Send Feedback

The DimSearchRefinementConfigList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimSearchRefinementConfigList.
Public property | GlobalDimSearchRefinementConfig | Accessor which gets/sets the global dimension search configuration associated with this refinement config.
Public property | IsFixedSize | Gets a value indicating whether the DimSearchRefinementConfigList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimSearchRefinementConfigList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimSearchRefinementConfigList is synchronized (thread-safe).
Public property | Item | Gets and sets the DimSearchRefinementConfig at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

DimSearchRefinementConfigList Class


Count Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Count Property
DimSearchRefinementConfigList Class See Also Send Feedback
Gets the number of elements actually contained in the DimSearchRefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimSearchRefinementConfigList.

Implements

ICollection..::..Count

See Also

DimSearchRefinementConfigList Class


GlobalDimSearchRefinementConfig Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..GlobalDimSearchRefinementConfig Property
DimSearchRefinementConfigList Class See Also Send Feedback
Accessor which gets/sets the global dimension search configuration associated with this refinement config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GlobalDimSearchRefinementConfig GlobalDimSearchRefinementConfig { get; set; }
Visual Basic
Public Property GlobalDimSearchRefinementConfig As GlobalDimSearchRefinementConfig
    Get
    Set
Visual C++
public:
property GlobalDimSearchRefinementConfig^ GlobalDimSearchRefinementConfig {
    GlobalDimSearchRefinementConfig^ get ();
    void set (GlobalDimSearchRefinementConfig^ value);
}

See Also

DimSearchRefinementConfigList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..IsFixedSize Property
DimSearchRefinementConfigList Class See Also Send Feedback
Gets a value indicating whether the DimSearchRefinementConfigList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimSearchRefinementConfigList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

DimSearchRefinementConfigList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..IsReadOnly Property
DimSearchRefinementConfigList Class See Also Send Feedback
Gets a value indicating whether the DimSearchRefinementConfigList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimSearchRefinementConfigList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

DimSearchRefinementConfigList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..IsSynchronized Property
DimSearchRefinementConfigList Class See Also Send Feedback
Gets a value indicating whether access to the DimSearchRefinementConfigList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimSearchRefinementConfigList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimSearchRefinementConfigList Class


Item Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..Item Property
DimSearchRefinementConfigList Class See Also Send Feedback
Gets and sets the DimSearchRefinementConfig at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The DimSearchRefinementConfig at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

DimSearchRefinementConfigList Class


SyncRoot Property

[image]

Endeca Presentation API
DimSearchRefinementConfigList..::..SyncRoot Property
DimSearchRefinementConfigList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimSearchRefinementConfigList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimSearchRefinementConfigList Class


DimSearchResult Class

[image]

Endeca Presentation API
DimSearchResult Class
Members See Also Send Feedback
Result class for a value search query. Class includes values queried for as well as other information about the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimSearchResult
Visual Basic
Public Class DimSearchResult
Visual C++
public ref class DimSearchResult

Remarks

Deprecated: This class may not be available in future versions of the Presentation API.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimSearchResult

See Also

DimSearchResult Members


DimSearchResult Members

[image] [image]

Endeca Presentation API
DimSearchResult Members
DimSearchResult Class Methods Properties See Also Send Feedback

The DimSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Results | Gets the results grouped by dimension.
Public property | TotalNumResults | Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

See Also

DimSearchResult Class


DimSearchResult Methods

[image] [image]

Endeca Presentation API
DimSearchResult Methods
DimSearchResult Class See Also Send Feedback

The DimSearchResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimSearchResult Class


DimSearchResult Properties

[image] [image]

Endeca Presentation API
DimSearchResult Properties
DimSearchResult Class See Also Send Feedback

The DimSearchResult type exposes the following members.

Properties

 | Name | Description
Public property | Results | Gets the results grouped by dimension.
Public property | TotalNumResults | Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

See Also

DimSearchResult Class


Results Property

[image]

Endeca Presentation API
DimSearchResult..::..Results Property
DimSearchResult Class See Also Send Feedback
Gets the results grouped by dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AssocDimLocationsList Results { get; }
Visual Basic
Public Overridable ReadOnly Property Results As AssocDimLocationsList
    Get
Visual C++
public:
virtual property AssocDimLocationsList^ Results {
    AssocDimLocationsList^ get ();
}

Field Value

The results grouped by dimension.

Remarks

Returns an empty list if there are no results.

See Also

DimSearchResult Class


TotalNumResults Property

[image]

Endeca Presentation API
DimSearchResult..::..TotalNumResults Property
DimSearchResult Class See Also Send Feedback
Gets the total number of value results found even if not all of them were returned because of the parameters of the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int TotalNumResults { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumResults As Integer
    Get
Visual C++
public:
virtual property int TotalNumResults {
    int get ();
}

Field Value

Total number of search results.

See Also

DimSearchResult Class


DimVal Class

[image]

Endeca Presentation API
DimVal Class
Members See Also Send Feedback
A dimension value is the lowest-level building block that compose dimensions, navigations, and classifications of records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimVal : IPropertyContainer
Visual Basic
Public Class DimVal _
    Implements IPropertyContainer
Visual C++
public ref class DimVal : IPropertyContainer

Remarks

A Dimension is a collection of related dimension values, organized into a tree. The top-most dimension value in a dimension tree is known as the dimension root. A dimension root always has the same name as its dimension. Every dimension value has a unique ID.

Dimension values are tags that classify the records in a data set. Tagging a record with a dimension value identifies the record as a valid result when that dimension value is selected in a navigation query.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimVal

See Also

DimVal Members


DimVal Members

[image] [image]

Endeca Presentation API
DimVal Members
DimVal Class Methods Properties See Also Send Feedback

The DimVal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLeaf | Indicates if this dimension value is a leaf.
Public method | IsMultiSelectAnd | Indicates if this dimension value supports "multi-select and" functionality
Public method | IsMultiSelectOr | Indicates if this dimension value supports "multi-select or" functionality
Public method | IsNavigable | Indicates if this dimension value is navigable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimensionId | Gets the ID of the dimension to which this dimension value belongs.
Public property | DimensionName | Gets the name of the dimension to which this dimension value belongs.
Public property | Id | Gets the ID of this dimension value.
Public property | Name | Gets the name of this dimension value.
Public property | Properties | Gets the properties associated with this dimension value.
Public property | Synonyms | Gets the list of synonyms associated with this dimension value.

See Also

DimVal Class


DimVal Methods

[image] [image]

Endeca Presentation API
DimVal Methods
DimVal Class See Also Send Feedback

The DimVal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLeaf | Indicates if this dimension value is a leaf.
Public method | IsMultiSelectAnd | Indicates if this dimension value supports "multi-select and" functionality
Public method | IsMultiSelectOr | Indicates if this dimension value supports "multi-select or" functionality
Public method | IsNavigable | Indicates if this dimension value is navigable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimVal Class


IsLeaf Method

[image]

Endeca Presentation API
DimVal..::..IsLeaf Method
DimVal Class See Also Send Feedback
Indicates if this dimension value is a leaf.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsLeaf()
Visual Basic
Public Overridable Function IsLeaf As Boolean
Visual C++
public:
virtual bool IsLeaf()

Return Value

true if this dimension value is a leaf (has no child dimension values). false if it is not (has child dimension values).

See Also

DimVal Class


IsMultiSelectAnd Method

[image]

Endeca Presentation API
DimVal..::..IsMultiSelectAnd Method
DimVal Class See Also Send Feedback
Indicates if this dimension value supports "multi-select and" functionality

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool IsMultiSelectAnd()
Visual Basic
Public Function IsMultiSelectAnd As Boolean
Visual C++
public:
bool IsMultiSelectAnd()

Return Value

true if this dimension value is "multi-select and" capable, false if it is not.

See Also

DimVal Class


IsMultiSelectOr Method

[image]

Endeca Presentation API
DimVal..::..IsMultiSelectOr Method
DimVal Class See Also Send Feedback
Indicates if this dimension value supports "multi-select or" functionality

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool IsMultiSelectOr()
Visual Basic
Public Function IsMultiSelectOr As Boolean
Visual C++
public:
bool IsMultiSelectOr()

Return Value

true if this dimension value is "multi-select or" capable, false if it is not.

See Also

DimVal Class


IsNavigable Method

[image]

Endeca Presentation API
DimVal..::..IsNavigable Method
DimVal Class See Also Send Feedback
Indicates if this dimension value is navigable.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsNavigable()
Visual Basic
Public Overridable Function IsNavigable As Boolean
Visual C++
public:
virtual bool IsNavigable()

Return Value

true if this dimension value is navigable, false if it is not.

Remarks

If the dimension value is navigable, it can be placed in the navigation state or classify a record.

See Also

DimVal Class


DimVal Properties

[image] [image]

Endeca Presentation API
DimVal Properties
DimVal Class See Also Send Feedback

The DimVal type exposes the following members.

Properties

 | Name | Description
Public property | DimensionId | Gets the ID of the dimension to which this dimension value belongs.
Public property | DimensionName | Gets the name of the dimension to which this dimension value belongs.
Public property | Id | Gets the ID of this dimension value.
Public property | Name | Gets the name of this dimension value.
Public property | Properties | Gets the properties associated with this dimension value.
Public property | Synonyms | Gets the list of synonyms associated with this dimension value.

See Also

DimVal Class


DimensionId Property

[image]

Endeca Presentation API
DimVal..::..DimensionId Property
DimVal Class See Also Send Feedback
Gets the ID of the dimension to which this dimension value belongs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimensionId { get; }
Visual Basic
Public Overridable ReadOnly Property DimensionId As Long
    Get
Visual C++
public:
virtual property long long DimensionId {
    long long get ();
}

Field Value

ID of the Dimension to which this dimension value belongs.

See Also

DimVal Class


DimensionName Property

[image]

Endeca Presentation API
DimVal..::..DimensionName Property
DimVal Class See Also Send Feedback
Gets the name of the dimension to which this dimension value belongs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimensionName { get; }
Visual Basic
Public Overridable ReadOnly Property DimensionName As String
    Get
Visual C++
public:
virtual property String^ DimensionName {
    String^ get ();
}

Field Value

Name of the Dimension to which this dimension value belongs.

See Also

DimVal Class


Id Property

[image]

Endeca Presentation API
DimVal..::..Id Property
DimVal Class See Also Send Feedback
Gets the ID of this dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long Id { get; }
Visual Basic
Public Overridable ReadOnly Property Id As Long
    Get
Visual C++
public:
virtual property long long Id {
    long long get ();
}

Field Value

The ID of this dimension value.

Remarks

Every dimension value has a unique ID.

See Also

DimVal Class


Name Property

[image]

Endeca Presentation API
DimVal..::..Name Property
DimVal Class See Also Send Feedback
Gets the name of this dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

The name of this dimension value.

See Also

DimVal Class


Properties Property

[image]

Endeca Presentation API
DimVal..::..Properties Property
DimVal Class See Also Send Feedback
Gets the properties associated with this dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap Properties { get; }
Visual Basic
Public Overridable ReadOnly Property Properties As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

A PropertyMap containing the properties associated with this dimension value.

Implements

IPropertyContainer..::..Properties

Remarks

This method will still return a valid but empty property list if there are no properties associated with this dimension value.

See Also

DimVal Class


Synonyms Property

[image]

Endeca Presentation API
DimVal..::..Synonyms Property
DimVal Class See Also Send Feedback
Gets the list of synonyms associated with this dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual List<string> Synonyms { get; }
Visual Basic
Public Overridable ReadOnly Property Synonyms As List(Of String)
    Get
Visual C++
public:
virtual property List<String^>^ Synonyms {
    List<String^>^ get ();
}

Field Value

An IList of string objects that are names of synonyms associated with this dimension value. If there are no synonyms, a valid list will still be returned.

Remarks

This method will still return a valid but empty IList if there are no synonyms associated with this dimension value.

See Also

DimVal Class


DimValIdList Class

[image]

Endeca Presentation API
DimValIdList Class
Members See Also Send Feedback
List of dimension value IDs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class DimValIdList : IList,
    ICollection, IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class DimValIdList _
    Implements IList, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class DimValIdList : IList,
    ICollection, IEnumerable

Remarks

Every dimension value (DimVal object) has a unique ID. A DimValIdList object contains a list of dimension value IDs. Typically, the developer does not create and populate the DimValIdList object, but instead it is returned by get properties such as DimSearchDimensions. Note that while DimValIdList objects are lists of dimension value IDs, DimValList objects are lists of the actual dimension values.

DimValIdList objects are primarily used to generate MDEX Engine queries. For example, dimension value IDs are used before executing a basic navigation query, as the input argument to the NavDescriptors property setter. There will be a one-to-one mapping between the IDs in the DimValIdList argument and the dimension values (DimVal objects) that are returned by the query.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimValIdList

See Also

DimValIdList Members


DimValIdList Members

[image] [image]

Endeca Presentation API
DimValIdList Members
DimValIdList Class Constructors Methods Properties See Also Send Feedback

The DimValIdList type exposes the following members.

Constructors

 | Name | Description
Public method | DimValIdList()()()() | Default constructor that will contain an empty list.
Public method | DimValIdList(String) | Constructor that takes a string-based set of dimension value IDs. The constructor parses and populates the list with the string.
Public method | DimValIdList(DimValList) | Constructor that takes a dimension value list and extracts the IDs from the DimVal objects in the list.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | AddDimValue | Adds a dimension value ID to the DimValIdList. The ID is extracted from val, which is a dimension value.
Public method | AddDimValueId | Adds a dimension value ID to the DimValIdList.
Public method | Clear | Removes all the elements from the DimValIdList.
Public method | Contains | Determines whether an element is in the DimValIdList.
Public method | CopyTo | Copies the entire DimValIdList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimValIdList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimValIdList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | Removes the element at the specified index of the DimValIdList.
Public method | ToString | Generates the string-based representation of the DimValIdList by returning a space-delimited sequence of dimension value IDs.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimValIdList.
Public property | IsFixedSize | Gets a value indicating whether the DimValIdList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimValIdList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimValIdList is synchronized (thread-safe).
Public property | Item | Gets the Int64 at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimValIdList Class


DimValIdList Constructor

[image] [image]

Endeca Presentation API
DimValIdList Constructor
DimValIdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DimValIdList()()()() | Default constructor that will contain an empty list.
Public method | DimValIdList(String) | Constructor that takes a string-based set of dimension value IDs. The constructor parses and populates the list with the string.
Public method | DimValIdList(DimValList) | Constructor that takes a dimension value list and extracts the IDs from the DimVal objects in the list.

See Also

DimValIdList Class
DimValIdList Members


DimValIdList Constructor

[image]

Endeca Presentation API
DimValIdList Constructor
DimValIdList Class See Also Send Feedback
Default constructor that will contain an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DimValIdList()
Visual Basic
Public Sub New
Visual C++
public:
DimValIdList()

See Also

DimValIdList Class
DimValIdList Overload


DimValIdList Constructor (String)

[image]

Endeca Presentation API
DimValIdList Constructor (String)
DimValIdList Class See Also Send Feedback
Constructor that takes a string-based set of dimension value IDs. The constructor parses and populates the list with the string.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DimValIdList(
    string ids
)
Visual Basic
Public Sub New ( _
    ids As String _
)
Visual C++
public:
DimValIdList(
    String^ ids
)

Parameters

ids
Type: System..::..String
Space-delimited sequence of dimension value IDs.

Remarks

The string is expected to be a space-delimited sequence of unsigned ints.

See Also

DimValIdList Class
DimValIdList Overload


DimValIdList Constructor (DimValList)

[image]

Endeca Presentation API
DimValIdList Constructor (DimValList)
DimValIdList Class See Also Send Feedback
Constructor that takes a dimension value list and extracts the IDs from the DimVal objects in the list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DimValIdList(
    DimValList values
)
Visual Basic
Public Sub New ( _
    values As DimValList _
)
Visual C++
public:
DimValIdList(
    DimValList^ values
)

Parameters

values
Type: Endeca.Navigation..::..DimValList
DimValList from which the dimension value IDs will be extracted.

See Also

DimValIdList Class
DimValIdList Overload


DimValIdList Methods

[image] [image]

Endeca Presentation API
DimValIdList Methods
DimValIdList Class See Also Send Feedback

The DimValIdList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | AddDimValue | Adds a dimension value ID to the DimValIdList. The ID is extracted from val, which is a dimension value.
Public method | AddDimValueId | Adds a dimension value ID to the DimValIdList.
Public method | Clear | Removes all the elements from the DimValIdList.
Public method | Contains | Determines whether an element is in the DimValIdList.
Public method | CopyTo | Copies the entire DimValIdList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimValIdList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the DimValIdList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | Removes the element at the specified index of the DimValIdList.
Public method | ToString | Generates the string-based representation of the DimValIdList by returning a space-delimited sequence of dimension value IDs.

See Also

DimValIdList Class


Add Method

[image]

Endeca Presentation API
DimValIdList..::..Add Method
DimValIdList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimValIdList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValIdList Class


AddDimValue Method

[image]

Endeca Presentation API
DimValIdList..::..AddDimValue Method
DimValIdList Class See Also Send Feedback
Adds a dimension value ID to the DimValIdList. The ID is extracted from val, which is a dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddDimValue(
    DimVal val
)
Visual Basic
Public Overridable Sub AddDimValue ( _
    val As DimVal _
)
Visual C++
public:
virtual void AddDimValue(
    DimVal^ val
)

Parameters

val
Type: Endeca.Navigation..::..DimVal
DimVal object from which the ID will be extracted.

See Also

DimValIdList Class


AddDimValueId Method

[image]

Endeca Presentation API
DimValIdList..::..AddDimValueId Method
DimValIdList Class See Also Send Feedback
Adds a dimension value ID to the DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddDimValueId(
    long id
)
Visual Basic
Public Overridable Sub AddDimValueId ( _
    id As Long _
)
Visual C++
public:
virtual void AddDimValueId(
    long long id
)

Parameters

id
Type: System..::..Int64
Dimension value ID to add to the list.

See Also

DimValIdList Class


Clear Method

[image]

Endeca Presentation API
DimValIdList..::..Clear Method
DimValIdList Class See Also Send Feedback
Removes all the elements from the DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The DimValIdList is read-only. -or- The DimValIdList has a fixed-size.

See Also

DimValIdList Class


Contains Method

[image]

Endeca Presentation API
DimValIdList..::..Contains Method
DimValIdList Class See Also Send Feedback
Determines whether an element is in the DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimValIdList.

Return Value

true if item is found in the DimValIdList.

Implements

IList..::..Contains(Object)

See Also

DimValIdList Class


CopyTo Method

[image]

Endeca Presentation API
DimValIdList..::..CopyTo Method
DimValIdList Class See Also Send Feedback
Copies the entire DimValIdList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimValIdList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimValIdList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimValIdList be cast automatically to the type of the destination array.

See Also

DimValIdList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimValIdList..::..GetEnumerator Method
DimValIdList Class See Also Send Feedback
Returns an enumerator for the entire DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimValIdList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimValIdList Class


IndexOf Method

[image]

Endeca Presentation API
DimValIdList..::..IndexOf Method
DimValIdList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the DimValIdList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the DimValIdList.

Return Value

The zero-based index of the first occurrence of item within the entire DimValIdList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimValIdList Class


Insert Method

[image]

Endeca Presentation API
DimValIdList..::..Insert Method
DimValIdList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValIdList Class


Remove Method

[image]

Endeca Presentation API
DimValIdList..::..Remove Method
DimValIdList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimValIdList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValIdList Class


RemoveAt Method

[image]

Endeca Presentation API
DimValIdList..::..RemoveAt Method
DimValIdList Class See Also Send Feedback
Removes the element at the specified index of the DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The DimValIdList is read-only. -or- The DimValIdList has a fixed-size.

See Also

DimValIdList Class


ToString Method

[image]

Endeca Presentation API
DimValIdList..::..ToString Method
DimValIdList Class See Also Send Feedback
Generates the string-based representation of the DimValIdList by returning a space-delimited sequence of dimension value IDs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

Space-delimited sequence of dimension value IDs.

See Also

DimValIdList Class


DimValIdList Properties

[image] [image]

Endeca Presentation API
DimValIdList Properties
DimValIdList Class See Also Send Feedback

The DimValIdList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimValIdList.
Public property | IsFixedSize | Gets a value indicating whether the DimValIdList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimValIdList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimValIdList is synchronized (thread-safe).
Public property | Item | Gets the Int64 at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimValIdList Class


Count Property

[image]

Endeca Presentation API
DimValIdList..::..Count Property
DimValIdList Class See Also Send Feedback
Gets the number of elements actually contained in the DimValIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the DimValIdList.

Implements

ICollection..::..Count

See Also

DimValIdList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimValIdList..::..IsFixedSize Property
DimValIdList Class See Also Send Feedback
Gets a value indicating whether the DimValIdList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimValIdList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

DimValIdList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimValIdList..::..IsReadOnly Property
DimValIdList Class See Also Send Feedback
Gets a value indicating whether the DimValIdList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimValIdList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

DimValIdList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimValIdList..::..IsSynchronized Property
DimValIdList Class See Also Send Feedback
Gets a value indicating whether access to the DimValIdList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimValIdList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimValIdList Class


Item Property

[image]

Endeca Presentation API
DimValIdList..::..Item Property
DimValIdList Class See Also Send Feedback
Gets the Int64 at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The Int64 at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimValIdList Class


SyncRoot Property

[image]

Endeca Presentation API
DimValIdList..::..SyncRoot Property
DimValIdList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimValIdList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValIdList Class


DimValList Class

[image]

Endeca Presentation API
DimValList Class
Members See Also Send Feedback
A list of dimension values (DimVal objects).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DimValList : IList, ICollection,
    IEnumerable
Visual Basic
Public Class DimValList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class DimValList : IList,
    ICollection, IEnumerable

Remarks

DimValList objects are returned from the MDEX Engine by various get properties. For example, Refinements returns a DimValList object containing the refinements in a given dimension.

Note that a DimValIdList{@link } is a list of dimension value IDs, while a DimValList is a list of the actual dimension values (DimVal objects).

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DimValList

See Also

DimValList Members


DimValList Members

[image] [image]

Endeca Presentation API
DimValList Members
DimValList Class Methods Properties See Also Send Feedback

The DimValList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimValList.
Public method | CopyTo | Copies the entire DimValList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimValList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an element in the DimValList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimValList.
Public property | IsFixedSize | Gets a value indicating whether the DimValList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimValList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimValList is synchronized (thread-safe).
Public property | Item | Gets the DimVal at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimValList Class


DimValList Methods

[image] [image]

Endeca Presentation API
DimValList Methods
DimValList Class See Also Send Feedback

The DimValList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the DimValList.
Public method | CopyTo | Copies the entire DimValList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire DimValList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an element in the DimValList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimValList Class


Add Method

[image]

Endeca Presentation API
DimValList..::..Add Method
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the DimValList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


Clear Method

[image]

Endeca Presentation API
DimValList..::..Clear Method
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


Contains Method

[image]

Endeca Presentation API
DimValList..::..Contains Method
DimValList Class See Also Send Feedback
Determines whether an element is in the DimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The DimVal to locate in the DimValList.

Return Value

true if item is found in the DimValList.

Implements

IList..::..Contains(Object)

See Also

DimValList Class


CopyTo Method

[image]

Endeca Presentation API
DimValList..::..CopyTo Method
DimValList Class See Also Send Feedback
Copies the entire DimValList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from DimValList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source DimValList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source DimValList be cast automatically to the type of the destination array.

See Also

DimValList Class


GetEnumerator Method

[image]

Endeca Presentation API
DimValList..::..GetEnumerator Method
DimValList Class See Also Send Feedback
Returns an enumerator for the entire DimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire DimValList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

DimValList Class


IndexOf Method

[image]

Endeca Presentation API
DimValList..::..IndexOf Method
DimValList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an element in the DimValList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The DimVal to locate in the DimValList.

Return Value

The zero-based index of the first occurrence of item within the entire DimValList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

DimValList Class


Insert Method

[image]

Endeca Presentation API
DimValList..::..Insert Method
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


Remove Method

[image]

Endeca Presentation API
DimValList..::..Remove Method
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from DimValList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


RemoveAt Method

[image]

Endeca Presentation API
DimValList..::..RemoveAt Method
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


DimValList Properties

[image] [image]

Endeca Presentation API
DimValList Properties
DimValList Class See Also Send Feedback

The DimValList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the DimValList.
Public property | IsFixedSize | Gets a value indicating whether the DimValList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the DimValList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the DimValList is synchronized (thread-safe).
Public property | Item | Gets the DimVal at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

DimValList Class


Count Property

[image]

Endeca Presentation API
DimValList..::..Count Property
DimValList Class See Also Send Feedback
Gets the number of elements actually contained in the DimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of DimVal objects actually contained in the DimValList.

Implements

ICollection..::..Count

See Also

DimValList Class


IsFixedSize Property

[image]

Endeca Presentation API
DimValList..::..IsFixedSize Property
DimValList Class See Also Send Feedback
Gets a value indicating whether the DimValList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the DimValList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

DimValList Class


IsReadOnly Property

[image]

Endeca Presentation API
DimValList..::..IsReadOnly Property
DimValList Class See Also Send Feedback
Gets a value indicating whether the DimValList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the DimValList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

DimValList Class


IsSynchronized Property

[image]

Endeca Presentation API
DimValList..::..IsSynchronized Property
DimValList Class See Also Send Feedback
Gets a value indicating whether access to the DimValList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the DimValList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

DimValList Class


Item Property

[image]

Endeca Presentation API
DimValList..::..Item Property
DimValList Class See Also Send Feedback
Gets the DimVal at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimVal at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

DimValList Class


SyncRoot Property

[image]

Endeca Presentation API
DimValList..::..SyncRoot Property
DimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the DimValList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

DimValList Class


DisabledRefinementsConfig Class

[image]

Endeca Presentation API
DisabledRefinementsConfig Class
Members See Also Send Feedback
This class represents the configuration of the Disabled Refinement results that will be returned with the query results. The methods of this class allow configuration of the base nav state to be used to compute the Disabled Refinements.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class DisabledRefinementsConfig
Visual Basic
Public Class DisabledRefinementsConfig
Visual C++
public ref class DisabledRefinementsConfig

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..DisabledRefinementsConfig

See Also

DisabledRefinementsConfig Members


DisabledRefinementsConfig Members

[image] [image]

Endeca Presentation API
DisabledRefinementsConfig Members
DisabledRefinementsConfig Class Constructors Methods Properties See Also Send Feedback

The DisabledRefinementsConfig type exposes the following members.

Constructors

 | Name | Description
Public method | DisabledRefinementsConfig | Initializes a new instance of the DisabledRefinementsConfig class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | getDimensionInBase | Gets whether nav selections from the dimension specified is part of the base nav state
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setDimensionInBase | Sets whether a dimension is part of the base nav state.
Public method | ToString | Returns a string representation suitable of UrlENEQuery

Properties

 | Name | Description
Public property | EQLFilterInBase | Gets and sets whether the EQL filter is part of the base nav state. Defaults to false.
Public property | RangeFilterInBase | Gets and sets whether range filters are part of the base nav state. Defaults to false.
Public property | TextSearchInBase | Gets and sets whether text searches are part of the base nav state. Defaults to false.

See Also

DisabledRefinementsConfig Class


DisabledRefinementsConfig Constructor

[image]

Endeca Presentation API
DisabledRefinementsConfig Constructor
DisabledRefinementsConfig Class See Also Send Feedback
Initializes a new instance of the DisabledRefinementsConfig class

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public DisabledRefinementsConfig()
Visual Basic
Public Sub New
Visual C++
public:
DisabledRefinementsConfig()

See Also

DisabledRefinementsConfig Class


DisabledRefinementsConfig Methods

[image] [image]

Endeca Presentation API
DisabledRefinementsConfig Methods
DisabledRefinementsConfig Class See Also Send Feedback

The DisabledRefinementsConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | getDimensionInBase | Gets whether nav selections from the dimension specified is part of the base nav state
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setDimensionInBase | Sets whether a dimension is part of the base nav state.
Public method | ToString | Returns a string representation suitable of UrlENEQuery

See Also

DisabledRefinementsConfig Class


getDimensionInBase Method

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..getDimensionInBase Method
DisabledRefinementsConfig Class See Also Send Feedback
Gets whether nav selections from the dimension specified is part of the base nav state

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool getDimensionInBase(
    long dimensionId
)
Visual Basic
Public Function getDimensionInBase ( _
    dimensionId As Long _
) As Boolean
Visual C++
public:
bool getDimensionInBase(
    long long dimensionId
)

Parameters

dimensionId
Type: System..::..Int64
The ID of the dimension specified

Return Value

true if nav selections from this dimension are part of the base nav state. false otherwise.

See Also

DisabledRefinementsConfig Class


setDimensionInBase Method

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..setDimensionInBase Method
DisabledRefinementsConfig Class See Also Send Feedback
Sets whether a dimension is part of the base nav state.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void setDimensionInBase(
    long dimensionId,
    bool include
)
Visual Basic
Public Sub setDimensionInBase ( _
    dimensionId As Long, _
    include As Boolean _
)
Visual C++
public:
void setDimensionInBase(
    long long dimensionId,
    bool include
)

Parameters

dimensionId
Type: System..::..Int64
The ID of the dimension under consideration
include
Type: System..::..Boolean
true if the dimension is to be included in the base nav state. false otherwise.

See Also

DisabledRefinementsConfig Class


ToString Method

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..ToString Method
DisabledRefinementsConfig Class See Also Send Feedback
Returns a string representation suitable of UrlENEQuery

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToString()
Visual Basic
Public Function ToString As String
Visual C++
public:
String^ ToString()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.DisabledRefinementsConfig.ToString"]

See Also

DisabledRefinementsConfig Class


DisabledRefinementsConfig Properties

[image] [image]

Endeca Presentation API
DisabledRefinementsConfig Properties
DisabledRefinementsConfig Class See Also Send Feedback

The DisabledRefinementsConfig type exposes the following members.

Properties

 | Name | Description
Public property | EQLFilterInBase | Gets and sets whether the EQL filter is part of the base nav state. Defaults to false.
Public property | RangeFilterInBase | Gets and sets whether range filters are part of the base nav state. Defaults to false.
Public property | TextSearchInBase | Gets and sets whether text searches are part of the base nav state. Defaults to false.

See Also

DisabledRefinementsConfig Class


EQLFilterInBase Property

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..EQLFilterInBase Property
DisabledRefinementsConfig Class See Also Send Feedback
Gets and sets whether the EQL filter is part of the base nav state. Defaults to false.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool EQLFilterInBase { get; set; }
Visual Basic
Public Property EQLFilterInBase As Boolean
    Get
    Set
Visual C++
public:
property bool EQLFilterInBase {
    bool get ();
    void set (bool value);
}

See Also

DisabledRefinementsConfig Class


RangeFilterInBase Property

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..RangeFilterInBase Property
DisabledRefinementsConfig Class See Also Send Feedback
Gets and sets whether range filters are part of the base nav state. Defaults to false.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool RangeFilterInBase { get; set; }
Visual Basic
Public Property RangeFilterInBase As Boolean
    Get
    Set
Visual C++
public:
property bool RangeFilterInBase {
    bool get ();
    void set (bool value);
}

See Also

DisabledRefinementsConfig Class


TextSearchInBase Property

[image]

Endeca Presentation API
DisabledRefinementsConfig..::..TextSearchInBase Property
DisabledRefinementsConfig Class See Also Send Feedback
Gets and sets whether text searches are part of the base nav state. Defaults to false.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool TextSearchInBase { get; set; }
Visual Basic
Public Property TextSearchInBase As Boolean
    Get
    Set
Visual C++
public:
property bool TextSearchInBase {
    bool get ();
    void set (bool value);
}

See Also

DisabledRefinementsConfig Class


EmptyENEQueryException Class

[image]

Endeca Presentation API
EmptyENEQueryException Class
Members See Also Send Feedback
Exception signalling that the query method was called with an empty query object. Exception comes from the fact that a query object did not express any requests to the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class EmptyENEQueryException : ENEQueryException
Visual Basic
Public Class EmptyENEQueryException _
    Inherits ENEQueryException
Visual C++
public ref class EmptyENEQueryException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..EmptyENEQueryException

See Also

EmptyENEQueryException Members


EmptyENEQueryException Members

[image] [image]

Endeca Presentation API
EmptyENEQueryException Members
EmptyENEQueryException Class Methods Properties See Also Send Feedback

The EmptyENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EmptyENEQueryException Class


EmptyENEQueryException Methods

[image] [image]

Endeca Presentation API
EmptyENEQueryException Methods
EmptyENEQueryException Class See Also Send Feedback

The EmptyENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

EmptyENEQueryException Class


EmptyENEQueryException Properties

[image] [image]

Endeca Presentation API
EmptyENEQueryException Properties
EmptyENEQueryException Class See Also Send Feedback

The EmptyENEQueryException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

EmptyENEQueryException Class


ENEAuthenticationException Class

[image]

Endeca Presentation API
ENEAuthenticationException Class
Members See Also Send Feedback
The exception thrown when authentication fails

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEAuthenticationException : ENEQueryException
Visual Basic
Public Class ENEAuthenticationException _
    Inherits ENEQueryException
Visual C++
public ref class ENEAuthenticationException : public ENEQueryException

Remarks

Deprecated: This class may not be available in future versions of the Presentation API.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..ENEAuthenticationException

See Also

ENEAuthenticationException Members


ENEAuthenticationException Members

[image] [image]

Endeca Presentation API
ENEAuthenticationException Members
ENEAuthenticationException Class Constructors Methods Properties See Also Send Feedback

The ENEAuthenticationException type exposes the following members.

Constructors

 | Name | Description
Protected method | ENEAuthenticationException()()()() | Initializes a new instance of the ENEAuthenticationException class
Protected method | ENEAuthenticationException(String) | The exception thrown when authentication fails. Includes a message.
Protected method | ENEAuthenticationException(String, Exception) | The exception thrown when authentication fails. Includes a message and an Exception instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEAuthenticationException Class


ENEAuthenticationException Constructor

[image] [image]

Endeca Presentation API
ENEAuthenticationException Constructor
ENEAuthenticationException Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ENEAuthenticationException()()()() | Initializes a new instance of the ENEAuthenticationException class
Protected method | ENEAuthenticationException(String) | The exception thrown when authentication fails. Includes a message.
Protected method | ENEAuthenticationException(String, Exception) | The exception thrown when authentication fails. Includes a message and an Exception instance.

See Also

ENEAuthenticationException Class
ENEAuthenticationException Members


ENEAuthenticationException Constructor

[image]

Endeca Presentation API
ENEAuthenticationException Constructor
ENEAuthenticationException Class See Also Send Feedback
Initializes a new instance of the ENEAuthenticationException class

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected internal ENEAuthenticationException()
Visual Basic
Protected Friend Sub New
Visual C++
protected public:
ENEAuthenticationException()

See Also

ENEAuthenticationException Class
ENEAuthenticationException Overload


ENEAuthenticationException Constructor (String)

[image]

Endeca Presentation API
ENEAuthenticationException Constructor (String)
ENEAuthenticationException Class See Also Send Feedback
The exception thrown when authentication fails. Includes a message.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected internal ENEAuthenticationException(
    string s
)
Visual Basic
Protected Friend Sub New ( _
    s As String _
)
Visual C++
protected public:
ENEAuthenticationException(
    String^ s
)

Parameters

s
Type: System..::..String
The message that describes the current exception.

See Also

ENEAuthenticationException Class
ENEAuthenticationException Overload


ENEAuthenticationException Constructor (String, Exception)

[image]

Endeca Presentation API
ENEAuthenticationException Constructor (String, Exception)
ENEAuthenticationException Class See Also Send Feedback
The exception thrown when authentication fails. Includes a message and an Exception instance.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected internal ENEAuthenticationException(
    string s,
    Exception e
)
Visual Basic
Protected Friend Sub New ( _
    s As String, _
    e As Exception _
)
Visual C++
protected public:
ENEAuthenticationException(
    String^ s,
    Exception^ e
)

Parameters

s
Type: System..::..String
The message that describes the current exception.
e
Type: System..::..Exception
The Exception instance that caused the current exception.

See Also

ENEAuthenticationException Class
ENEAuthenticationException Overload


ENEAuthenticationException Methods

[image] [image]

Endeca Presentation API
ENEAuthenticationException Methods
ENEAuthenticationException Class See Also Send Feedback

The ENEAuthenticationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ENEAuthenticationException Class


ENEAuthenticationException Properties

[image] [image]

Endeca Presentation API
ENEAuthenticationException Properties
ENEAuthenticationException Class See Also Send Feedback

The ENEAuthenticationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEAuthenticationException Class


ENEConnectionException Class

[image]

Endeca Presentation API
ENEConnectionException Class
Members See Also Send Feedback
Exception represents an error dealing with the communication with an Endeca MDEX Engine from an IENEConnection.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEConnectionException : ENEQueryException
Visual Basic
Public Class ENEConnectionException _
    Inherits ENEQueryException
Visual C++
public ref class ENEConnectionException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..ENEConnectionException

See Also

ENEConnectionException Members


ENEConnectionException Members

[image] [image]

Endeca Presentation API
ENEConnectionException Members
ENEConnectionException Class Constructors Methods Properties See Also Send Feedback

The ENEConnectionException type exposes the following members.

Constructors

 | Name | Description
Public method | ENEConnectionException()()()() | Initialized a new instance of ENEConnectionException.
Public method | ENEConnectionException(String) | Initialized a new instance of ENEConnectionException with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEConnectionException Class


ENEConnectionException Constructor

[image] [image]

Endeca Presentation API
ENEConnectionException Constructor
ENEConnectionException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ENEConnectionException()()()() | Initialized a new instance of ENEConnectionException.
Public method | ENEConnectionException(String) | Initialized a new instance of ENEConnectionException with a specified error message.

See Also

ENEConnectionException Class
ENEConnectionException Members


ENEConnectionException Constructor

[image]

Endeca Presentation API
ENEConnectionException Constructor
ENEConnectionException Class See Also Send Feedback
Initialized a new instance of ENEConnectionException.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEConnectionException()
Visual Basic
Public Sub New
Visual C++
public:
ENEConnectionException()

See Also

ENEConnectionException Class
ENEConnectionException Overload


ENEConnectionException Constructor (String)

[image]

Endeca Presentation API
ENEConnectionException Constructor (String)
ENEConnectionException Class See Also Send Feedback
Initialized a new instance of ENEConnectionException with a specified error message.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEConnectionException(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
ENEConnectionException(
    String^ s
)

Parameters

s
Type: System..::..String
The message that describes the error.

See Also

ENEConnectionException Class
ENEConnectionException Overload


ENEConnectionException Methods

[image] [image]

Endeca Presentation API
ENEConnectionException Methods
ENEConnectionException Class See Also Send Feedback

The ENEConnectionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ENEConnectionException Class


ENEConnectionException Properties

[image] [image]

Endeca Presentation API
ENEConnectionException Properties
ENEConnectionException Class See Also Send Feedback

The ENEConnectionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEConnectionException Class


ENEException Class

[image]

Endeca Presentation API
ENEException Class
Members See Also Send Feedback
Exception represents an exception that comes from the Endeca MDEX Engine. Often this means that the IENEConnection was able to contact the MDEX Engine but the MDEX Engine responded with an error.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEException : ENEQueryException
Visual Basic
Public Class ENEException _
    Inherits ENEQueryException
Visual C++
public ref class ENEException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..ENEException

See Also

ENEException Members


ENEException Members

[image] [image]

Endeca Presentation API
ENEException Members
ENEException Class Constructors Methods Properties See Also Send Feedback

The ENEException type exposes the following members.

Constructors

 | Name | Description
Public method | ENEException()()()() | Initialized a new instance of ENEException.
Public method | ENEException(String) | Initialized a new instance of ENEException with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEException Class


ENEException Constructor

[image] [image]

Endeca Presentation API
ENEException Constructor
ENEException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ENEException()()()() | Initialized a new instance of ENEException.
Public method | ENEException(String) | Initialized a new instance of ENEException with a specified error message.

See Also

ENEException Class
ENEException Members


ENEException Constructor

[image]

Endeca Presentation API
ENEException Constructor
ENEException Class See Also Send Feedback
Initialized a new instance of ENEException.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEException()
Visual Basic
Public Sub New
Visual C++
public:
ENEException()

See Also

ENEException Class
ENEException Overload


ENEException Constructor (String)

[image]

Endeca Presentation API
ENEException Constructor (String)
ENEException Class See Also Send Feedback
Initialized a new instance of ENEException with a specified error message.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEException(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
ENEException(
    String^ s
)

Parameters

s
Type: System..::..String
The message that describes the error.

See Also

ENEException Class
ENEException Overload


ENEException Methods

[image] [image]

Endeca Presentation API
ENEException Methods
ENEException Class See Also Send Feedback

The ENEException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ENEException Class


ENEException Properties

[image] [image]

Endeca Presentation API
ENEException Properties
ENEException Class See Also Send Feedback

The ENEException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEException Class


ENEQuery Class

[image]

Endeca Presentation API
ENEQuery Class
Members See Also Send Feedback
An object used for expressing queries to an Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class ENEQuery
Visual Basic
<SerializableAttribute> _
Public Class ENEQuery
Visual C++
[SerializableAttribute]
public ref class ENEQuery

Remarks

An ENEQuery object is used with a Query method (of HttpENEConnection or AuthHttpENEConnection) to query an MDEX Engine, which then returns an ENEQueryResults object.

The ENEQuery object can contain one of each of the following: a record query, a navigation query, an aggregated record query, a dimension search query, and/or a navigation search.

While there are many query options, only a few critical setters are necessary to make basic queries:

  • Basic navigation queries require a setting NavDescriptors.
  • Basic record queries require a setting ERec.
  • Basic aggregated record queries require setting AggrERec, AggrERecRollupKey, and AggrERecNavDescriptors.
  • Basic dimension search queries require a setting DimSearchTerms.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ENEQuery
Endeca.Navigation..::..UrlENEQuery

See Also

ENEQuery Members


ENEQuery Members

[image] [image]

Endeca Presentation API
ENEQuery Members
ENEQuery Class Constructors Methods Fields Properties See Also Send Feedback

The ENEQuery type exposes the following members.

Constructors

 | Name | Description
Public method | ENEQuery | Zero argument default constructor.

Methods

 | Name | Description
Public method | AddSelection | Adds the field named fieldName to the set of fields that should be returned for each record in the result set.
Public method | ContainsAggrERecQuery | Returns if this query includes a aggregated record query.
Public method | ContainsDimSearchQuery | Returns if this query includes a dimension search query.
Public method | ContainsERecQuery | Returns if this query includes a record query.
Public method | ContainsERecsQuery | Returns if this query includes a query for records.
Public method | ContainsNavQuery | Returns whether the query includes a navigation query.
Public method | ContainsQuery | Returns whether the query is querying for any of a navigation, record, dimension search, or a value set search.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNavActiveSortKeys | Get the list of sort keys with which the navigation query's records will be sorted.
Public method | GetNavSortKey | Obsolete. Gets the sort key with which the navigation query's records will be sorted.
Public method | GetNavSortOrder | Obsolete. Gets the sort order with which the navigation query's records will be sorted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNavActiveSortKeys | Set the list of sort keys with which the navigation query's records will be sorted.
Public method | SetNavSortKey | Obsolete. Sets the sort key with which the navigation query's records will be sorted.
Public method | SetNavSortOrder | Obsolete. Sets the sort order with which the navigation query's records will be sorted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALL_ERECS_PER_AGGR | All records that compose a aggregated record will be returned.
DIM_SEARCH_ALL_DIM_VALUES | All matches from dimension search will be returned from each dimension.
KEY_PROPS_NONE | Request that no key properties will be returned.
MAX_BULK_ERECS_AVAILABLE | All the records that are associated with the current navigation state should be returned through the bulk record iterator.
NAV_SORT_ASCENDING | Sort the navigation query's matching records in ascending order.
NAV_SORT_DESCENDING | Sort the navigation query's matching records in descending order.
ONE_EREC_PER_AGGR | One of the records that compose a aggregated record will be returned.
ZERO_ERECS_PER_AGGR | None of the records that compose a aggregated record will be returned.

Properties

Name Description
Public property AggrERec Obsolete.
Gets or sets the Id of the aggregated record to be queried for.
Public property AggrERecActiveSortKeys
Get the list of sort keys with which the aggregated records representative records will be sorted.
Public property AggrERecNavDescriptors
Gets or sets the navigation values which the aggregated record will be composed in relation to.
Public property AggrERecNavRangeFilters
Gets or sets the navigation range filters which the aggregated record will be composed in relation to.
Public property AggrERecNavRecordFilter
Gets or sets the record filter which the aggregated record will be composed in relation to.
Public property AggrERecRollupKey
Gets or sets the rollup key the aggregated record is composed by.
Public property AggrERecSpec
Gets or sets the specification of the aggregated record to be queried for.
Public property AggrERecStructureExpr
Gets or sets the structure expression used to filter members of the aggregated record.
Public property AnalyticsQuery
Gets and sets the AnalyticsQuery instance that represents the Analytics query that will be sent to the MDEX Engine. On set, if the query is malformed, it will not be set on the HttpENEConnection and a SyntaxException is thrown. An AnalyticsQuery instance can be built programmatically or by calling the parseQuery(String) method.
Public property DimSearchCompound
Gets and sets whether dimension search will include compound results.
Public property DimSearchDimension
Gets and sets the dimension which which the dimension search can search from.
Public property DimSearchDimensions
Gets and sets the dimensions which which the dimension search can search from.
Public property DimSearchNavDescriptors
Gets and sets the navigation values that describe a navigation state that restrict the number of values that can be searched from.
Public property DimSearchNavRangeFilters
Gets and sets the navigation range filters that restrict the dimension search.
Public property DimSearchNavRecordFilter
Gets and sets the record filter that will restrict the dimension search results.
Public property DimSearchNavRecordStructureExpr
Gets and sets the structure expression that will restrict the dimension search results.
Public property DimSearchNumDimValues Obsolete.
Gets and sets the number of values returned from each dimension for value search.
Public property DimSearchOpts
Gets and sets the option set that dimension search will use.
Public property DimSearchRankResults
Gets and sets how the dimension search will order its results.
Public property DimSearchRefinementConfigs
Gets and sets the list of refinement configs to be used by the MDEX Engine for dimension search
Public property DimSearchResultsOffset
Gets and sets the offset with which the dimension search will begin returning results per dimension.
Public property DimSearchRollupKey
Gets and sets the rollup key which the records of the dimension search query should use to create aggregated counts. By setting a rollupKey with this method, aggregated counts are returned as the value for the
CopyC#
Dgraph.AggrBins
 key of the
CopyC#
DimVal
 object's
CopyC#
PropertyMap
.
Public property DimSearchTerms
Gets and sets the search terms the dimension search will use.
Public property ERec
Sets the Id of the record to be queried for.
Public property ERecs
Gets or sets the Ids of the records to be queried for.
Public property LanguageId
Gets and sets the ISO639 language code to be used for this query. The language id is sent to the MDEX Engine when the query is executed, and specifies the language of any text portion of the query. For example: search terms.
Public property NavAggrERecsOffset
Gets and sets the offset into the navigation aggregated record list for navigation query.
Public property NavAllRefinements
Gets and sets the query such that the navigation query will return with all the refinements possible for all dimensions.
Public property NavDescriptors
Gets and sets the navigation descriptor IDs describing the navigation object to be queried for.
Public property NavDisabledRefinementsConfig
Gets and sets the disabled refinements config.
Public property NavERecSearchComputeAlternativePhrasings
Gets and sets if the fulltext search should turn on the compute-autophrase feature.
Public property NavERecSearchDidYouMean
Gets and sets if the fulltext search should turn on the did you mean feature.
Public property NavERecSearches
Gets and sets the navigation record searches to perform on the records of the navigation query.
Public property NavERecSearchRewriteQueryWithAnAlternativePhrasing
Gets and sets if the fulltext search should turn on the rewrite-autophrase feature.
Public property NavERecsOffset
Gets and sets the offset into the navigation record list for navigation query.
Public property NavERecsPerAggrERec
Gets and sets the max number of records to be returned in each aggregated record.
Public property NavExposedRefinements
Gets and sets the set of refinements that should be exposed / returned with the navigation query.
Public property NavKeyProperties
Get and sets the number of key properties to be returned.
Public property NavMerchPreviewTime
Gets and sets the merch preview time on this navigation query.
Public property NavMerchRuleFilter
Gets and sets the merch rule filter on this navigation query.
Public property NavNumAggrERecs
Gets and sets the max number of aggregated records returned for the navigation query.
Public property NavNumBulkAggrERecs
Gets and sets the max number of aggregated records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all aggregated records for the navigation query will be returned.
Public property NavNumBulkERecs
Gets and sets the max number of records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all records for the navigation query will be returned.
Public property NavNumERecs
Get and sets the max number of records returned for the navigation query.
Public property NavOpts
Gets and sets the option set that navigation queries will use.
Public property NavRangeFilters
Gets and sets the navigation range filters on this navigation query.
Public property NavRecordFilter
Gets and sets the record filters on this navigation query.
Public property NavRecordStructureExpr
Gets and sets the structure expression on this navigation query.
Public property NavRefinementConfigs
Gets and sets the list of dynamic refinement configs to be used by the MDEX Engine.
Public property NavRelRankERecRank
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
Public property NavRelRankERecSearch Obsolete.
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
Public property NavRollupKey
Gets and sets the rollup key with which the records of the navigation query should be rolled up with to create aggregated records.
Public property NavStratifiedDimVals
Gets and sets the list stratified dim vals for use during refinement ranking by the MDEX engine.
Public property Profiles
Gets and sets the set of profiles that describe the application end user.
Public property QueryInfo
Gets and sets the ENEQueryInfo object.
Public property Selection
Gets and sets the select list for the query.

See Also

ENEQuery Class


ENEQuery Constructor

[image]

Endeca Presentation API
ENEQuery Constructor
ENEQuery Class See Also Send Feedback
Zero argument default constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEQuery()
Visual Basic
Public Sub New
Visual C++
public:
ENEQuery()

Remarks

Without specifying specific query fields, querying with this will yield a EmptyENEQueryException.

See Also

ENEQuery Class


ENEQuery Fields

[image] [image]

Endeca Presentation API
ENEQuery Fields
ENEQuery Class See Also Send Feedback

The ENEQuery type exposes the following members.

Fields

Name | Description
ALL_ERECS_PER_AGGR | All records that compose a aggregated record will be returned.
DIM_SEARCH_ALL_DIM_VALUES | All matches from dimension search will be returned from each dimension.
KEY_PROPS_NONE | Request that no key properties will be returned.
MAX_BULK_ERECS_AVAILABLE | All the records that are associated with the current navigation state should be returned through the bulk record iterator.
NAV_SORT_ASCENDING | Sort the navigation query's matching records in ascending order.
NAV_SORT_DESCENDING | Sort the navigation query's matching records in descending order.
ONE_EREC_PER_AGGR | One of the records that compose a aggregated record will be returned.
ZERO_ERECS_PER_AGGR | None of the records that compose a aggregated record will be returned.

See Also

ENEQuery Class


ALL_ERECS_PER_AGGR Field

[image]

Endeca Presentation API
ENEQuery..::..ALL_ERECS_PER_AGGR Field
ENEQuery Class See Also Send Feedback
All records that compose a aggregated record will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int ALL_ERECS_PER_AGGR
Visual Basic
Public Const ALL_ERECS_PER_AGGR As Integer
Visual C++
public:
literal int ALL_ERECS_PER_AGGR

See Also

ENEQuery Class


DIM_SEARCH_ALL_DIM_VALUES Field

[image]

Endeca Presentation API
ENEQuery..::..DIM_SEARCH_ALL_DIM_VALUES Field
ENEQuery Class See Also Send Feedback
All matches from dimension search will be returned from each dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIM_SEARCH_ALL_DIM_VALUES
Visual Basic
Public Const DIM_SEARCH_ALL_DIM_VALUES As Integer
Visual C++
public:
literal int DIM_SEARCH_ALL_DIM_VALUES

See Also

ENEQuery Class


KEY_PROPS_NONE Field

[image]

Endeca Presentation API
ENEQuery..::..KEY_PROPS_NONE Field
ENEQuery Class See Also Send Feedback
Request that no key properties will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string KEY_PROPS_NONE
Visual Basic
Public Const KEY_PROPS_NONE As String
Visual C++
public:
literal String^ KEY_PROPS_NONE

See Also

ENEQuery Class


MAX_BULK_ERECS_AVAILABLE Field

[image]

Endeca Presentation API
ENEQuery..::..MAX_BULK_ERECS_AVAILABLE Field
ENEQuery Class See Also Send Feedback
All the records that are associated with the current navigation state should be returned through the bulk record iterator.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MAX_BULK_ERECS_AVAILABLE
Visual Basic
Public Const MAX_BULK_ERECS_AVAILABLE As Integer
Visual C++
public:
literal int MAX_BULK_ERECS_AVAILABLE

See Also

ENEQuery Class


NAV_SORT_ASCENDING Field

[image]

Endeca Presentation API
ENEQuery..::..NAV_SORT_ASCENDING Field
ENEQuery Class See Also Send Feedback
Sort the navigation query's matching records in ascending order.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NAV_SORT_ASCENDING
Visual Basic
Public Const NAV_SORT_ASCENDING As Integer
Visual C++
public:
literal int NAV_SORT_ASCENDING

See Also

ENEQuery Class


NAV_SORT_DESCENDING Field

[image]

Endeca Presentation API
ENEQuery..::..NAV_SORT_DESCENDING Field
ENEQuery Class See Also Send Feedback
Sort the navigation query's matching records in descending order.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NAV_SORT_DESCENDING
Visual Basic
Public Const NAV_SORT_DESCENDING As Integer
Visual C++
public:
literal int NAV_SORT_DESCENDING

See Also

ENEQuery Class


ONE_EREC_PER_AGGR Field

[image]

Endeca Presentation API
ENEQuery..::..ONE_EREC_PER_AGGR Field
ENEQuery Class See Also Send Feedback
One of the records that compose a aggregated record will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int ONE_EREC_PER_AGGR
Visual Basic
Public Const ONE_EREC_PER_AGGR As Integer
Visual C++
public:
literal int ONE_EREC_PER_AGGR

See Also

ENEQuery Class


ZERO_ERECS_PER_AGGR Field

[image]

Endeca Presentation API
ENEQuery..::..ZERO_ERECS_PER_AGGR Field
ENEQuery Class See Also Send Feedback
None of the records that compose a aggregated record will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int ZERO_ERECS_PER_AGGR
Visual Basic
Public Const ZERO_ERECS_PER_AGGR As Integer
Visual C++
public:
literal int ZERO_ERECS_PER_AGGR

See Also

ENEQuery Class


ENEQuery Methods

[image] [image]

Endeca Presentation API
ENEQuery Methods
ENEQuery Class See Also Send Feedback

The ENEQuery type exposes the following members.

Methods

 | Name | Description
Public method | AddSelection | Adds the field named fieldName to the set of fields that should be returned for each record in the result set.
Public method | ContainsAggrERecQuery | Returns if this query includes a aggregated record query.
Public method | ContainsDimSearchQuery | Returns if this query includes a dimension search query.
Public method | ContainsERecQuery | Returns if this query includes a record query.
Public method | ContainsERecsQuery | Returns if this query includes a query for records.
Public method | ContainsNavQuery | Returns whether the query includes a navigation query.
Public method | ContainsQuery | Returns whether the query is querying for any of a navigation, record, dimension search, or a value set search.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNavActiveSortKeys | Get the list of sort keys with which the navigation query's records will be sorted.
Public method | GetNavSortKey | Obsolete. Gets the sort key with which the navigation query's records will be sorted.
Public method | GetNavSortOrder | Obsolete. Gets the sort order with which the navigation query's records will be sorted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNavActiveSortKeys | Set the list of sort keys with which the navigation query's records will be sorted.
Public method | SetNavSortKey | Obsolete. Sets the sort key with which the navigation query's records will be sorted.
Public method | SetNavSortOrder | Obsolete. Sets the sort order with which the navigation query's records will be sorted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ENEQuery Class


AddSelection Method

[image]

Endeca Presentation API
ENEQuery..::..AddSelection Method
ENEQuery Class See Also Send Feedback
Adds the field named fieldName to the set of fields that should be returned for each record in the result set.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void AddSelection(
    string fieldName
)
Visual Basic
Public Sub AddSelection ( _
    fieldName As String _
)
Visual C++
public:
void AddSelection(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String

Field Value

The name of an Endeca property or dimension.

See Also

ENEQuery Class


ContainsAggrERecQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsAggrERecQuery Method
ENEQuery Class See Also Send Feedback
Returns if this query includes a aggregated record query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsAggrERecQuery()
Visual Basic
Public Overridable Function ContainsAggrERecQuery As Boolean
Visual C++
public:
virtual bool ContainsAggrERecQuery()

Return Value

true if query includes a aggregated record query. false if it does not.

See Also

ENEQuery Class


ContainsDimSearchQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsDimSearchQuery Method
ENEQuery Class See Also Send Feedback
Returns if this query includes a dimension search query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsDimSearchQuery()
Visual Basic
Public Overridable Function ContainsDimSearchQuery As Boolean
Visual C++
public:
virtual bool ContainsDimSearchQuery()

Return Value

true if query includes a dimension search query. false if it does not.

See Also

ENEQuery Class


ContainsERecQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsERecQuery Method
ENEQuery Class See Also Send Feedback
Returns if this query includes a record query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsERecQuery()
Visual Basic
Public Overridable Function ContainsERecQuery As Boolean
Visual C++
public:
virtual bool ContainsERecQuery()

Return Value

true if query includes a record query. false if it does not.

Remarks

This method is synonymous with ContainsERecsQuery()()()() and here for completeness when requesting only one record.

See Also

ENEQuery Class


ContainsERecsQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsERecsQuery Method
ENEQuery Class See Also Send Feedback
Returns if this query includes a query for records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsERecsQuery()
Visual Basic
Public Overridable Function ContainsERecsQuery As Boolean
Visual C++
public:
virtual bool ContainsERecsQuery()

Return Value

true if query includes a query for one or more records. false if it does not.

See Also

ENEQuery Class


ContainsNavQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsNavQuery Method
ENEQuery Class See Also Send Feedback
Returns whether the query includes a navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsNavQuery()
Visual Basic
Public Overridable Function ContainsNavQuery As Boolean
Visual C++
public:
virtual bool ContainsNavQuery()

Return Value

true if query includes a requests for a navigation object and false if it does not.

See Also

ENEQuery Class


ContainsQuery Method

[image]

Endeca Presentation API
ENEQuery..::..ContainsQuery Method
ENEQuery Class See Also Send Feedback
Returns whether the query is querying for any of a navigation, record, dimension search, or a value set search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsQuery()
Visual Basic
Public Overridable Function ContainsQuery As Boolean
Visual C++
public:
virtual bool ContainsQuery()

Return Value

false if a navigation, record, dimension search, value set search are specified in query. true if none are.

See Also

ENEQuery Class


GetNavActiveSortKeys Method

[image]

Endeca Presentation API
ENEQuery..::..GetNavActiveSortKeys Method
ENEQuery Class See Also Send Feedback
Get the list of sort keys with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSortKeyList GetNavActiveSortKeys()
Visual Basic
Public Overridable Function GetNavActiveSortKeys As ERecSortKeyList
Visual C++
public:
virtual ERecSortKeyList^ GetNavActiveSortKeys()

Field Value

The list of keys that will be used to sort the records. The order of the keys is significant. The first key is the primary sort criterion, the second key is the secondary sort criterion, etc.

Return Value

ERecSortKeyList - The sort keys used in this query. The records are sorted by the first key in the list, resolving ties with the second key. Ties on the second key are resolved using the third key, and so forth.

See Also

ENEQuery Class


GetNavSortKey Method

[image]

Endeca Presentation API
ENEQuery..::..GetNavSortKey Method
ENEQuery Class See Also Send Feedback
Gets the sort key with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")]
public virtual string GetNavSortKey()
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")> _
Public Overridable Function GetNavSortKey As String
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")]
public:
virtual String^ GetNavSortKey()

Return Value

The sort key of the navigation query. Returns null if there is no sort key specified.

Remarks

Deprecated: This method may not be available in future versions of the Presentation API. Use GetNavActiveSortKeys() instead.

See Also

ENEQuery Class


GetNavSortOrder Method

[image]

Endeca Presentation API
ENEQuery..::..GetNavSortOrder Method
ENEQuery Class See Also Send Feedback
Gets the sort order with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")]
public virtual int GetNavSortOrder()
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")> _
Public Overridable Function GetNavSortOrder As Integer
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use GetNavActiveSortKeys() instead.")]
public:
virtual int GetNavSortOrder()

Return Value

NAV_SORT_ASCENDING if ascending, NAV_SORT_DESCENDING if descending.

Remarks

Deprecated: This method may not be available in future versions of the Presentation API. Use GetNavActiveSortKeys() instead

See Also

ENEQuery Class


SetNavActiveSortKeys Method

[image]

Endeca Presentation API
ENEQuery..::..SetNavActiveSortKeys Method
ENEQuery Class See Also Send Feedback
Set the list of sort keys with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNavActiveSortKeys(
    ERecSortKeyList criteria
)
Visual Basic
Public Overridable Sub SetNavActiveSortKeys ( _
    criteria As ERecSortKeyList _
)
Visual C++
public:
virtual void SetNavActiveSortKeys(
    ERecSortKeyList^ criteria
)

Parameters

criteria
Type: Endeca.Navigation..::..ERecSortKeyList
The ERecSortKeyList used to sort the navigation query's records.

See Also

ENEQuery Class


SetNavSortKey Method

[image]

Endeca Presentation API
ENEQuery..::..SetNavSortKey Method
ENEQuery Class See Also Send Feedback
Sets the sort key with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")]
public virtual void SetNavSortKey(
    string key
)
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")> _
Public Overridable Sub SetNavSortKey ( _
    key As String _
)
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")]
public:
virtual void SetNavSortKey(
    String^ key
)

Parameters

key
Type: System..::..String
The String used to sort the navigation query's records.

Remarks

Deprecated: This method may not be available in future versions of the Presentation API. Use SetNavActiveSortKeys() instead.

See Also

ENEQuery Class


SetNavSortOrder Method

[image]

Endeca Presentation API
ENEQuery..::..SetNavSortOrder Method
ENEQuery Class See Also Send Feedback
Sets the sort order with which the navigation query's records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")]
public virtual void SetNavSortOrder(
    int order
)
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")> _
Public Overridable Sub SetNavSortOrder ( _
    order As Integer _
)
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use SetNavActiveSortKeys() instead.")]
public:
virtual void SetNavSortOrder(
    int order
)

Parameters

order
Type: System..::..Int32
The int specifying the sort order. The sort order can either be NAV_SORT_ASCENDING or NAV_SORT_DESCENDING. Defaults to ascending and is only applied if the a sort key is present in query as well.

Remarks

Deprecated: This method may not be available in future versions of the Presentation API. Use SetNavActiveSortKeys() instead.

See Also

ENEQuery Class


ENEQuery Properties

[image] [image]

Endeca Presentation API
ENEQuery Properties
ENEQuery Class See Also Send Feedback

The ENEQuery type exposes the following members.

Properties

Name Description
Public property AggrERec Obsolete.
Gets or sets the Id of the aggregated record to be queried for.
Public property AggrERecActiveSortKeys
Get the list of sort keys with which the aggregated records representative records will be sorted.
Public property AggrERecNavDescriptors
Gets or sets the navigation values which the aggregated record will be composed in relation to.
Public property AggrERecNavRangeFilters
Gets or sets the navigation range filters which the aggregated record will be composed in relation to.
Public property AggrERecNavRecordFilter
Gets or sets the record filter which the aggregated record will be composed in relation to.
Public property AggrERecRollupKey
Gets or sets the rollup key the aggregated record is composed by.
Public property AggrERecSpec
Gets or sets the specification of the aggregated record to be queried for.
Public property AggrERecStructureExpr
Gets or sets the structure expression used to filter members of the aggregated record.
Public property AnalyticsQuery
Gets and sets the AnalyticsQuery instance that represents the Analytics query that will be sent to the MDEX Engine. On set, if the query is malformed, it will not be set on the HttpENEConnection and a SyntaxException is thrown. An AnalyticsQuery instance can be built programmatically or by calling the parseQuery(String) method.
Public property DimSearchCompound
Gets and sets whether dimension search will include compound results.
Public property DimSearchDimension
Gets and sets the dimension which which the dimension search can search from.
Public property DimSearchDimensions
Gets and sets the dimensions which which the dimension search can search from.
Public property DimSearchNavDescriptors
Gets and sets the navigation values that describe a navigation state that restrict the number of values that can be searched from.
Public property DimSearchNavRangeFilters
Gets and sets the navigation range filters that restrict the dimension search.
Public property DimSearchNavRecordFilter
Gets and sets the record filter that will restrict the dimension search results.
Public property DimSearchNavRecordStructureExpr
Gets and sets the structure expression that will restrict the dimension search results.
Public property DimSearchNumDimValues Obsolete.
Gets and sets the number of values returned from each dimension for value search.
Public property DimSearchOpts
Gets and sets the option set that dimension search will use.
Public property DimSearchRankResults
Gets and sets how the dimension search will order its results.
Public property DimSearchRefinementConfigs
Gets and sets the list of refinement configs to be used by the MDEX Engine for dimension search
Public property DimSearchResultsOffset
Gets and sets the offset with which the dimension search will begin returning results per dimension.
Public property DimSearchRollupKey
Gets and sets the rollup key which the records of the dimension search query should use to create aggregated counts. By setting a rollupKey with this method, aggregated counts are returned as the value for the
CopyC#
Dgraph.AggrBins
 key of the
CopyC#
DimVal
 object's
CopyC#
PropertyMap
.
Public property DimSearchTerms
Gets and sets the search terms the dimension search will use.
Public property ERec
Sets the Id of the record to be queried for.
Public property ERecs
Gets or sets the Ids of the records to be queried for.
Public property LanguageId
Gets and sets the ISO639 language code to be used for this query. The language id is sent to the MDEX Engine when the query is executed, and specifies the language of any text portion of the query. For example: search terms.
Public property NavAggrERecsOffset
Gets and sets the offset into the navigation aggregated record list for navigation query.
Public property NavAllRefinements
Gets and sets the query such that the navigation query will return with all the refinements possible for all dimensions.
Public property NavDescriptors
Gets and sets the navigation descriptor IDs describing the navigation object to be queried for.
Public property NavDisabledRefinementsConfig
Gets and sets the disabled refinements config.
Public property NavERecSearchComputeAlternativePhrasings
Gets and sets if the fulltext search should turn on the compute-autophrase feature.
Public property NavERecSearchDidYouMean
Gets and sets if the fulltext search should turn on the did you mean feature.
Public property NavERecSearches
Gets and sets the navigation record searches to perform on the records of the navigation query.
Public property NavERecSearchRewriteQueryWithAnAlternativePhrasing
Gets and sets if the fulltext search should turn on the rewrite-autophrase feature.
Public property NavERecsOffset
Gets and sets the offset into the navigation record list for navigation query.
Public property NavERecsPerAggrERec
Gets and sets the max number of records to be returned in each aggregated record.
Public property NavExposedRefinements
Gets and sets the set of refinements that should be exposed / returned with the navigation query.
Public property NavKeyProperties
Get and sets the number of key properties to be returned.
Public property NavMerchPreviewTime
Gets and sets the merch preview time on this navigation query.
Public property NavMerchRuleFilter
Gets and sets the merch rule filter on this navigation query.
Public property NavNumAggrERecs
Gets and sets the max number of aggregated records returned for the navigation query.
Public property NavNumBulkAggrERecs
Gets and sets the max number of aggregated records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all aggregated records for the navigation query will be returned.
Public property NavNumBulkERecs
Gets and sets the max number of records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all records for the navigation query will be returned.
Public property NavNumERecs
Get and sets the max number of records returned for the navigation query.
Public property NavOpts
Gets and sets the option set that navigation queries will use.
Public property NavRangeFilters
Gets and sets the navigation range filters on this navigation query.
Public property NavRecordFilter
Gets and sets the record filters on this navigation query.
Public property NavRecordStructureExpr
Gets and sets the structure expression on this navigation query.
Public property NavRefinementConfigs
Gets and sets the list of dynamic refinement configs to be used by the MDEX Engine.
Public property NavRelRankERecRank
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
Public property NavRelRankERecSearch Obsolete.
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
Public property NavRollupKey
Gets and sets the rollup key with which the records of the navigation query should be rolled up with to create aggregated records.
Public property NavStratifiedDimVals
Gets and sets the list stratified dim vals for use during refinement ranking by the MDEX engine.
Public property Profiles
Gets and sets the set of profiles that describe the application end user.
Public property QueryInfo
Gets and sets the ENEQueryInfo object.
Public property Selection
Gets and sets the select list for the query.

See Also

ENEQuery Class


AggrERec Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERec Property
ENEQuery Class See Also Send Feedback
Gets or sets the Id of the aggregated record to be queried for.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use AggrERecSpec instead.")]
public virtual long AggrERec { get; set; }
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use AggrERecSpec instead.")> _
Public Overridable Property AggrERec As Long
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use AggrERecSpec instead.")]
public:
virtual property long long AggrERec {
    long long get ();
    void set (long long value);
}

Field Value

The aggregated record Id of the aggregated record being queried for.

Remarks

Deprecated: This method may not be supported in future versions of the MDEX Engine API. Use AggrERecSpec instead.

See Also

ENEQuery Class


AggrERecActiveSortKeys Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecActiveSortKeys Property
ENEQuery Class See Also Send Feedback
Get the list of sort keys with which the aggregated records representative records will be sorted.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSortKeyList AggrERecActiveSortKeys { get; set; }
Visual Basic
Public Overridable Property AggrERecActiveSortKeys As ERecSortKeyList
    Get
    Set
Visual C++
public:
virtual property ERecSortKeyList^ AggrERecActiveSortKeys {
    ERecSortKeyList^ get ();
    void set (ERecSortKeyList^ value);
}

Field Value

The list of keys that will be used to sort the records. The order of the keys is significant. The first key is the primary sort criterion, the second key is the secondary sort criterion, and so on. null if no order is specified (in which case the default sort, if any, will be used.

See Also

ENEQuery Class


AggrERecNavDescriptors Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecNavDescriptors Property
ENEQuery Class See Also Send Feedback
Gets or sets the navigation values which the aggregated record will be composed in relation to.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValIdList AggrERecNavDescriptors { get; set; }
Visual Basic
Public Overridable Property AggrERecNavDescriptors As DimValIdList
    Get
    Set
Visual C++
public:
virtual property DimValIdList^ AggrERecNavDescriptors {
    DimValIdList^ get ();
    void set (DimValIdList^ value);
}

Field Value

Navigation value Ids of the aggregated record is relative to. null if none are specified.

See Also

ENEQuery Class


AggrERecNavRangeFilters Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecNavRangeFilters Property
ENEQuery Class See Also Send Feedback
Gets or sets the navigation range filters which the aggregated record will be composed in relation to.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RangeFilterList AggrERecNavRangeFilters { get; set; }
Visual Basic
Public Overridable Property AggrERecNavRangeFilters As RangeFilterList
    Get
    Set
Visual C++
public:
virtual property RangeFilterList^ AggrERecNavRangeFilters {
    RangeFilterList^ get ();
    void set (RangeFilterList^ value);
}

Field Value

The navigation range filters the aggregated record is composed relative to. null if none is present.

See Also

ENEQuery Class


AggrERecNavRecordFilter Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecNavRecordFilter Property
ENEQuery Class See Also Send Feedback
Gets or sets the record filter which the aggregated record will be composed in relation to.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string AggrERecNavRecordFilter { get; set; }
Visual Basic
Public Overridable Property AggrERecNavRecordFilter As String
    Get
    Set
Visual C++
public:
virtual property String^ AggrERecNavRecordFilter {
    String^ get ();
    void set (String^ value);
}

Field Value

The record filter the aggregated record is composed relative to. null if none is present.

See Also

ENEQuery Class


AggrERecRollupKey Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecRollupKey Property
ENEQuery Class See Also Send Feedback
Gets or sets the rollup key the aggregated record is composed by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string AggrERecRollupKey { get; set; }
Visual Basic
Public Overridable Property AggrERecRollupKey As String
    Get
    Set
Visual C++
public:
virtual property String^ AggrERecRollupKey {
    String^ get ();
    void set (String^ value);
}

Field Value

Rollup key to compose the aggregated record. null if none are specified.

See Also

ENEQuery Class


AggrERecSpec Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecSpec Property
ENEQuery Class See Also Send Feedback
Gets or sets the specification of the aggregated record to be queried for.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string AggrERecSpec { get; set; }
Visual Basic
Public Overridable Property AggrERecSpec As String
    Get
    Set
Visual C++
public:
virtual property String^ AggrERecSpec {
    String^ get ();
    void set (String^ value);
}

Field Value

The aggregated record specification of the aggregated record being queried for.

See Also

ENEQuery Class


AggrERecStructureExpr Property

[image]

Endeca Presentation API
ENEQuery..::..AggrERecStructureExpr Property
ENEQuery Class See Also Send Feedback
Gets or sets the structure expression used to filter members of the aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string AggrERecStructureExpr { get; set; }
Visual Basic
Public Overridable Property AggrERecStructureExpr As String
    Get
    Set
Visual C++
public:
virtual property String^ AggrERecStructureExpr {
    String^ get ();
    void set (String^ value);
}

Field Value

The structure expression used to filter members of the aggregated record. null if none is present.

See Also

ENEQuery Class


AnalyticsQuery Property

[image]

Endeca Presentation API
ENEQuery..::..AnalyticsQuery Property
ENEQuery Class See Also Send Feedback
Gets and sets the AnalyticsQuery instance that represents the Analytics query that will be sent to the MDEX Engine. On set, if the query is malformed, it will not be set on the HttpENEConnection and a SyntaxException is thrown. An AnalyticsQuery instance can be built programmatically or by calling the parseQuery(String) method.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AnalyticsQuery AnalyticsQuery { get; set; }
Visual Basic
Public Overridable Property AnalyticsQuery As AnalyticsQuery
    Get
    Set
Visual C++
public:
virtual property AnalyticsQuery^ AnalyticsQuery {
    AnalyticsQuery^ get ();
    void set (AnalyticsQuery^ value);
}

Field Value

The Analytics query to run.

See Also

ENEQuery Class


DimSearchCompound Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchCompound Property
ENEQuery Class See Also Send Feedback
Gets and sets whether dimension search will include compound results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool DimSearchCompound { get; set; }
Visual Basic
Public Overridable Property DimSearchCompound As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DimSearchCompound {
    bool get ();
    void set (bool value);
}

Field Value

Dimension search options.

See Also

ENEQuery Class


DimSearchDimension Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchDimension Property
ENEQuery Class See Also Send Feedback
Gets and sets the dimension which which the dimension search can search from.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimSearchDimension { get; set; }
Visual Basic
Public Overridable Property DimSearchDimension As Long
    Get
    Set
Visual C++
public:
virtual property long long DimSearchDimension {
    long long get ();
    void set (long long value);
}

Field Value

The dimension Ids of the dimensions that the dimension search can search from.

Remarks

If none is specified, dimension search searches from all dimensions.

See Also

ENEQuery Class


DimSearchDimensions Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchDimensions Property
ENEQuery Class See Also Send Feedback
Gets and sets the dimensions which which the dimension search can search from.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValIdList DimSearchDimensions { get; set; }
Visual Basic
Public Overridable Property DimSearchDimensions As DimValIdList
    Get
    Set
Visual C++
public:
virtual property DimValIdList^ DimSearchDimensions {
    DimValIdList^ get ();
    void set (DimValIdList^ value);
}

Field Value

The dimension Ids of the dimensions that the dimension search can search from.

Remarks

If none is specified, dimension search searches from all dimensions.

See Also

ENEQuery Class


DimSearchNavDescriptors Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchNavDescriptors Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation values that describe a navigation state that restrict the number of values that can be searched from.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValIdList DimSearchNavDescriptors { get; set; }
Visual Basic
Public Overridable Property DimSearchNavDescriptors As DimValIdList
    Get
    Set
Visual C++
public:
virtual property DimValIdList^ DimSearchNavDescriptors {
    DimValIdList^ get ();
    void set (DimValIdList^ value);
}

Field Value

Values that describe a navigation state restriction on the searchable values.

Remarks

By specifying a navigation restriction, the dimension search is not made from the entire space of values, but instead just the values that are still available as refinements from the specified navigation state.

See Also

ENEQuery Class


DimSearchNavRangeFilters Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchNavRangeFilters Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation range filters that restrict the dimension search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RangeFilterList DimSearchNavRangeFilters { get; set; }
Visual Basic
Public Overridable Property DimSearchNavRangeFilters As RangeFilterList
    Get
    Set
Visual C++
public:
virtual property RangeFilterList^ DimSearchNavRangeFilters {
    RangeFilterList^ get ();
    void set (RangeFilterList^ value);
}

Field Value

The navigation range filters that restrict this dimension search query or null if none are present.

Remarks

Range filters limit the navigation record restrictions.

See Also

ENEQuery Class


DimSearchNavRecordFilter Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchNavRecordFilter Property
ENEQuery Class See Also Send Feedback
Gets and sets the record filter that will restrict the dimension search results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimSearchNavRecordFilter { get; set; }
Visual Basic
Public Overridable Property DimSearchNavRecordFilter As String
    Get
    Set
Visual C++
public:
virtual property String^ DimSearchNavRecordFilter {
    String^ get ();
    void set (String^ value);
}

Field Value

The record filter for the dimension search query. null if none is present.

See Also

ENEQuery Class


DimSearchNavRecordStructureExpr Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchNavRecordStructureExpr Property
ENEQuery Class See Also Send Feedback
Gets and sets the structure expression that will restrict the dimension search results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimSearchNavRecordStructureExpr { get; set; }
Visual Basic
Public Overridable Property DimSearchNavRecordStructureExpr As String
    Get
    Set
Visual C++
public:
virtual property String^ DimSearchNavRecordStructureExpr {
    String^ get ();
    void set (String^ value);
}

Field Value

The structure expression for the dimension search query. null if none is present.

See Also

ENEQuery Class


DimSearchNumDimValues Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchNumDimValues Property
ENEQuery Class See Also Send Feedback
Gets and sets the number of values returned from each dimension for value search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use DimSearchRefinementConfigs instead.")]
public virtual int DimSearchNumDimValues { get; set; }
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use DimSearchRefinementConfigs instead.")> _
Public Overridable Property DimSearchNumDimValues As Integer
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use DimSearchRefinementConfigs instead.")]
public:
virtual property int DimSearchNumDimValues {
    int get ();
    void set (int value);
}

Field Value

Number of values returned from each dimension. -1 indicates all and is the default.

Remarks

Defaults to all (DIM_SEARCH_ALL_DIM_VALUES). Deprecated: This method may not be available in future versions of the Presentation API. Use DimSearchRefinementConfigs.GlobalDimSearchRefinementConfig.NumResults instead.

See Also

ENEQuery Class


DimSearchOpts Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchOpts Property
ENEQuery Class See Also Send Feedback
Gets and sets the option set that dimension search will use.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimSearchOpts { get; set; }
Visual Basic
Public Overridable Property DimSearchOpts As String
    Get
    Set
Visual C++
public:
virtual property String^ DimSearchOpts {
    String^ get ();
    void set (String^ value);
}

Field Value

Dimension search options.

See Also

ENEQuery Class


DimSearchRankResults Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchRankResults Property
ENEQuery Class See Also Send Feedback
Gets and sets how the dimension search will order its results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool DimSearchRankResults { get; set; }
Visual Basic
Public Overridable Property DimSearchRankResults As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DimSearchRankResults {
    bool get ();
    void set (bool value);
}

Field Value

true means that relevance ranking is used to sort dimension results, while false means that default dimension value ranking (alpha, numeric, or manual, as set in Developer Studio) is used.

Remarks

Default is false.

See Also

ENEQuery Class


DimSearchRefinementConfigs Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchRefinementConfigs Property
ENEQuery Class See Also Send Feedback
Gets and sets the list of refinement configs to be used by the MDEX Engine for dimension search

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimSearchRefinementConfigList DimSearchRefinementConfigs { get; set; }
Visual Basic
Public Overridable Property DimSearchRefinementConfigs As DimSearchRefinementConfigList
    Get
    Set
Visual C++
public:
virtual property DimSearchRefinementConfigList^ DimSearchRefinementConfigs {
    DimSearchRefinementConfigList^ get ();
    void set (DimSearchRefinementConfigList^ value);
}

Field Value

A
CopyC#
RefinementConfigList
 that encapsulates all refinement configs to be used by the MDEX Engine for dimension search. null if none have been specified.

See Also

ENEQuery Class


DimSearchResultsOffset Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchResultsOffset Property
ENEQuery Class See Also Send Feedback
Gets and sets the offset with which the dimension search will begin returning results per dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimSearchResultsOffset { get; set; }
Visual Basic
Public Overridable Property DimSearchResultsOffset As Long
    Get
    Set
Visual C++
public:
virtual property long long DimSearchResultsOffset {
    long long get ();
    void set (long long value);
}

Field Value

The offset into each dimension search result dimension.

Remarks

Defaults to 0.

See Also

ENEQuery Class


DimSearchRollupKey Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchRollupKey Property
ENEQuery Class See Also Send Feedback
Gets and sets the rollup key which the records of the dimension search query should use to create aggregated counts. By setting a rollupKey with this method, aggregated counts are returned as the value for the
CopyC#
Dgraph.AggrBins
 key of the
CopyC#
DimVal
 object's
CopyC#
PropertyMap
.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimSearchRollupKey { get; set; }
Visual Basic
Public Overridable Property DimSearchRollupKey As String
    Get
    Set
Visual C++
public:
virtual property String^ DimSearchRollupKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The Endeca property or dimension that will be used to roll up the counts of the dimension search query in order to create aggregated counts.

See Also

ENEQuery Class


DimSearchTerms Property

[image]

Endeca Presentation API
ENEQuery..::..DimSearchTerms Property
ENEQuery Class See Also Send Feedback
Gets and sets the search terms the dimension search will use.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string DimSearchTerms { get; set; }
Visual Basic
Public Overridable Property DimSearchTerms As String
    Get
    Set
Visual C++
public:
virtual property String^ DimSearchTerms {
    String^ get ();
    void set (String^ value);
}

Field Value

Dimension search terms.

Remarks

The form is that of the end user input, that is decoded and untokenized.

See Also

ENEQuery Class


ERec Property

[image]

Endeca Presentation API
ENEQuery..::..ERec Property
ENEQuery Class See Also Send Feedback
Sets the Id of the record to be queried for.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long ERec { set; }
Visual Basic
Public Overridable WriteOnly Property ERec As Long
    Set
Visual C++
public:
virtual property long long ERec {
    void set (long long value);
}

Field Value

The record Id of the record being queried for.

Remarks

This property is shorthand for ERecIdList property used when only requesting one record.

See Also

ENEQuery Class


ERecs Property

[image]

Endeca Presentation API
ENEQuery..::..ERecs Property
ENEQuery Class See Also Send Feedback
Gets or sets the Ids of the records to be queried for.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecIdList ERecs { get; set; }
Visual Basic
Public Overridable Property ERecs As ERecIdList
    Get
    Set
Visual C++
public:
virtual property ERecIdList^ ERecs {
    ERecIdList^ get ();
    void set (ERecIdList^ value);
}

Field Value

The record Ids in the query or null if there were none.

Remarks

If only one record has been queried for this method still returns a ERecIdList of one element.

See Also

ENEQuery Class


LanguageId Property

[image]

Endeca Presentation API
ENEQuery..::..LanguageId Property
ENEQuery Class See Also Send Feedback
Gets and sets the ISO639 language code to be used for this query. The language id is sent to the MDEX Engine when the query is executed, and specifies the language of any text portion of the query. For example: search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string LanguageId { get; set; }
Visual Basic
Public Overridable Property LanguageId As String
    Get
    Set
Visual C++
public:
virtual property String^ LanguageId {
    String^ get ();
    void set (String^ value);
}

Field Value

The String representing an ISO639 language code.

See Also

ENEQuery Class


NavAggrERecsOffset Property

[image]

Endeca Presentation API
ENEQuery..::..NavAggrERecsOffset Property
ENEQuery Class See Also Send Feedback
Gets and sets the offset into the navigation aggregated record list for navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavAggrERecsOffset { get; set; }
Visual Basic
Public Overridable Property NavAggrERecsOffset As Long
    Get
    Set
Visual C++
public:
virtual property long long NavAggrERecsOffset {
    long long get ();
    void set (long long value);
}

Field Value

The offset in the navigation aggregated record list for navigation query.

Remarks

Defaults to an offset of 0 if not set. Only applicable when a aggregated record set is queried for.

See Also

ENEQuery Class


NavAllRefinements Property

[image]

Endeca Presentation API
ENEQuery..::..NavAllRefinements Property
ENEQuery Class See Also Send Feedback
Gets and sets the query such that the navigation query will return with all the refinements possible for all dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool NavAllRefinements { get; set; }
Visual Basic
Public Overridable Property NavAllRefinements As Boolean
    Get
    Set
Visual C++
public:
virtual property bool NavAllRefinements {
    bool get ();
    void set (bool value);
}

Field Value

true if all refinements will be returned from the navigation. false if they will not.

Remarks

If this method sets it to false, refinements must be requested for explcitly via setting the NavExposedRefinements property. The latter, is the default behavior.

See Also

ENEQuery Class


NavDescriptors Property

[image]

Endeca Presentation API
ENEQuery..::..NavDescriptors Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation descriptor IDs describing the navigation object to be queried for.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValIdList NavDescriptors { get; set; }
Visual Basic
Public Overridable Property NavDescriptors As DimValIdList
    Get
    Set
Visual C++
public:
virtual property DimValIdList^ NavDescriptors {
    DimValIdList^ get ();
    void set (DimValIdList^ value);
}

Field Value

The descriptor IDs of the navigation being queried for. Returns null if there is none.

Remarks

The resulting navigation object's descriptor dimensions will be ordered in the same order as these descriptors.

See Also

ENEQuery Class


NavDisabledRefinementsConfig Property

[image]

Endeca Presentation API
ENEQuery..::..NavDisabledRefinementsConfig Property
ENEQuery Class See Also Send Feedback
Gets and sets the disabled refinements config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DisabledRefinementsConfig NavDisabledRefinementsConfig { get; set; }
Visual Basic
Public Overridable Property NavDisabledRefinementsConfig As DisabledRefinementsConfig
    Get
    Set
Visual C++
public:
virtual property DisabledRefinementsConfig^ NavDisabledRefinementsConfig {
    DisabledRefinementsConfig^ get ();
    void set (DisabledRefinementsConfig^ value);
}

Field Value

The config for disabled refinements. A null value means no disabled refinements will be returned.

See Also

ENEQuery Class


NavERecSearchComputeAlternativePhrasings Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecSearchComputeAlternativePhrasings Property
ENEQuery Class See Also Send Feedback
Gets and sets if the fulltext search should turn on the compute-autophrase feature.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool NavERecSearchComputeAlternativePhrasings { get; set; }
Visual Basic
Public Overridable Property NavERecSearchComputeAlternativePhrasings As Boolean
    Get
    Set
Visual C++
public:
virtual property bool NavERecSearchComputeAlternativePhrasings {
    bool get ();
    void set (bool value);
}

Field Value

true if the compute-autophrase feature is enabled, false if it is not.

Remarks

Only used if a fulltext search query is being made with the navigation. Defaults to false

See Also

ENEQuery Class


NavERecSearchDidYouMean Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecSearchDidYouMean Property
ENEQuery Class See Also Send Feedback
Gets and sets if the fulltext search should turn on the did you mean feature.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool NavERecSearchDidYouMean { get; set; }
Visual Basic
Public Overridable Property NavERecSearchDidYouMean As Boolean
    Get
    Set
Visual C++
public:
virtual property bool NavERecSearchDidYouMean {
    bool get ();
    void set (bool value);
}

Field Value

true if the did you mean feature is enabled, false if it is not.

Remarks

Only used if a fulltext search query is being made with the navigation. Defaults to false

See Also

ENEQuery Class


NavERecSearches Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecSearches Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation record searches to perform on the records of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSearchList NavERecSearches { get; set; }
Visual Basic
Public Overridable Property NavERecSearches As ERecSearchList
    Get
    Set
Visual C++
public:
virtual property ERecSearchList^ NavERecSearches {
    ERecSearchList^ get ();
    void set (ERecSearchList^ value);
}

Field Value

Navigation record searches applied to records of the navigation. null if none have been previously specified.

Remarks

The individual elements of this list are applied in a conjunctive manner in that each search narrows and restricts the results of navigation record list.

See Also

ENEQuery Class


NavERecSearchRewriteQueryWithAnAlternativePhrasing Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecSearchRewriteQueryWithAnAlternativePhrasing Property
ENEQuery Class See Also Send Feedback
Gets and sets if the fulltext search should turn on the rewrite-autophrase feature.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool NavERecSearchRewriteQueryWithAnAlternativePhrasing { get; set; }
Visual Basic
Public Overridable Property NavERecSearchRewriteQueryWithAnAlternativePhrasing As Boolean
    Get
    Set
Visual C++
public:
virtual property bool NavERecSearchRewriteQueryWithAnAlternativePhrasing {
    bool get ();
    void set (bool value);
}

Field Value

true if the rewrite-autophrase feature is enabled, false if it is not.

Remarks

Only used if a fulltext search query is being made with the navigation. Defaults to false

See Also

ENEQuery Class


NavERecsOffset Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecsOffset Property
ENEQuery Class See Also Send Feedback
Gets and sets the offset into the navigation record list for navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavERecsOffset { get; set; }
Visual Basic
Public Overridable Property NavERecsOffset As Long
    Get
    Set
Visual C++
public:
virtual property long long NavERecsOffset {
    long long get ();
    void set (long long value);
}

Field Value

The offset in the navigation record list for navigation query.

Remarks

Defaults to an offset of 0 if not set.

See Also

ENEQuery Class


NavERecsPerAggrERec Property

[image]

Endeca Presentation API
ENEQuery..::..NavERecsPerAggrERec Property
ENEQuery Class See Also Send Feedback
Gets and sets the max number of records to be returned in each aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int NavERecsPerAggrERec { get; set; }
Visual Basic
Public Overridable Property NavERecsPerAggrERec As Integer
    Get
    Set
Visual C++
public:
virtual property int NavERecsPerAggrERec {
    int get ();
    void set (int value);
}

Field Value

Max number of records to return per aggregated record.

Remarks

Defaults to one. Only applicable for aggregated record navigation queries. Values possible include ALL_ERECS_PER_AGGR, ONE_EREC_PER_AGGR, or ZERO_ERECS_PER_AGGR.

See Also

ENEQuery Class


NavExposedRefinements Property

[image]

Endeca Presentation API
ENEQuery..::..NavExposedRefinements Property
ENEQuery Class See Also Send Feedback
Gets and sets the set of refinements that should be exposed / returned with the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimValIdList NavExposedRefinements { get; set; }
Visual Basic
Public Overridable Property NavExposedRefinements As DimValIdList
    Get
    Set
Visual C++
public:
virtual property DimValIdList^ NavExposedRefinements {
    DimValIdList^ get ();
    void set (DimValIdList^ value);
}

Field Value

Parents of the refinements that should be returned with the navigation query. null if none have been specified.

Remarks

The refinements specifies a list of value Ids that correlate to the parents of the refinements that should be returned with the query. If the NavAllRefinements returns false, no refinements will be returned and thus refinements must be specified via this set method to be returned. If NavAllRefinements returns true this method will be ignored unless it includes non-navigable values.

See Also

ENEQuery Class


NavKeyProperties Property

[image]

Endeca Presentation API
ENEQuery..::..NavKeyProperties Property
ENEQuery Class See Also Send Feedback
Get and sets the number of key properties to be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavKeyProperties { get; set; }
Visual Basic
Public Overridable Property NavKeyProperties As String
    Get
    Set
Visual C++
public:
virtual property String^ NavKeyProperties {
    String^ get ();
    void set (String^ value);
}

Field Value

For the setter, use KEY_PROPS_NONE to request that no key properties be returned.

See Also

ENEQuery Class


NavMerchPreviewTime Property

[image]

Endeca Presentation API
ENEQuery..::..NavMerchPreviewTime Property
ENEQuery Class See Also Send Feedback
Gets and sets the merch preview time on this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavMerchPreviewTime { get; set; }
Visual Basic
Public Overridable Property NavMerchPreviewTime As String
    Get
    Set
Visual C++
public:
virtual property String^ NavMerchPreviewTime {
    String^ get ();
    void set (String^ value);
}

Field Value

The merch preview time of this query or null if none exists.

See Also

ENEQuery Class


NavMerchRuleFilter Property

[image]

Endeca Presentation API
ENEQuery..::..NavMerchRuleFilter Property
ENEQuery Class See Also Send Feedback
Gets and sets the merch rule filter on this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavMerchRuleFilter { get; set; }
Visual Basic
Public Overridable Property NavMerchRuleFilter As String
    Get
    Set
Visual C++
public:
virtual property String^ NavMerchRuleFilter {
    String^ get ();
    void set (String^ value);
}

Field Value

The merch rule filter of this query or null if none exists.

See Also

ENEQuery Class


NavNumAggrERecs Property

[image]

Endeca Presentation API
ENEQuery..::..NavNumAggrERecs Property
ENEQuery Class See Also Send Feedback
Gets and sets the max number of aggregated records returned for the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavNumAggrERecs { get; set; }
Visual Basic
Public Overridable Property NavNumAggrERecs As Long
    Get
    Set
Visual C++
public:
virtual property long long NavNumAggrERecs {
    long long get ();
    void set (long long value);
}

Field Value

Max number of aggregated records to be returned from a navigation query.

Remarks

Defaults to 10. Only applicable for aggregated record navigation queries.

See Also

ENEQuery Class


NavNumBulkAggrERecs Property

[image]

Endeca Presentation API
ENEQuery..::..NavNumBulkAggrERecs Property
ENEQuery Class See Also Send Feedback
Gets and sets the max number of aggregated records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all aggregated records for the navigation query will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavNumBulkAggrERecs { get; set; }
Visual Basic
Public Overridable Property NavNumBulkAggrERecs As Long
    Get
    Set
Visual C++
public:
virtual property long long NavNumBulkAggrERecs {
    long long get ();
    void set (long long value);
}

Field Value

Max number of bulk aggregated records to return for the navigation query.

Remarks

Defaults to 0.

See Also

ENEQuery Class


NavNumBulkERecs Property

[image]

Endeca Presentation API
ENEQuery..::..NavNumBulkERecs Property
ENEQuery Class See Also Send Feedback
Gets and sets the max number of records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all records for the navigation query will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavNumBulkERecs { get; set; }
Visual Basic
Public Overridable Property NavNumBulkERecs As Long
    Get
    Set
Visual C++
public:
virtual property long long NavNumBulkERecs {
    long long get ();
    void set (long long value);
}

Field Value

Max number of bulk records to return for the navigation query.

Remarks

Defaults to 0.

See Also

ENEQuery Class


NavNumERecs Property

[image]

Endeca Presentation API
ENEQuery..::..NavNumERecs Property
ENEQuery Class See Also Send Feedback
Get and sets the max number of records returned for the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NavNumERecs { get; set; }
Visual Basic
Public Overridable Property NavNumERecs As Long
    Get
    Set
Visual C++
public:
virtual property long long NavNumERecs {
    long long get ();
    void set (long long value);
}

Field Value

Max number of records to return for the navigation query.

Remarks

Defaults to 10.

See Also

ENEQuery Class


NavOpts Property

[image]

Endeca Presentation API
ENEQuery..::..NavOpts Property
ENEQuery Class See Also Send Feedback
Gets and sets the option set that navigation queries will use.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavOpts { get; set; }
Visual Basic
Public Overridable Property NavOpts As String
    Get
    Set
Visual C++
public:
virtual property String^ NavOpts {
    String^ get ();
    void set (String^ value);
}

Field Value

Navigation query options.

See Also

ENEQuery Class


NavRangeFilters Property

[image]

Endeca Presentation API
ENEQuery..::..NavRangeFilters Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation range filters on this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RangeFilterList NavRangeFilters { get; set; }
Visual Basic
Public Overridable Property NavRangeFilters As RangeFilterList
    Get
    Set
Visual C++
public:
virtual property RangeFilterList^ NavRangeFilters {
    RangeFilterList^ get ();
    void set (RangeFilterList^ value);
}

Field Value

The navigation range filters of this query or null if none are returned.

Remarks

Range filters limit the record results of the query.

See Also

ENEQuery Class


NavRecordFilter Property

[image]

Endeca Presentation API
ENEQuery..::..NavRecordFilter Property
ENEQuery Class See Also Send Feedback
Gets and sets the record filters on this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavRecordFilter { get; set; }
Visual Basic
Public Overridable Property NavRecordFilter As String
    Get
    Set
Visual C++
public:
virtual property String^ NavRecordFilter {
    String^ get ();
    void set (String^ value);
}

Field Value

The record filter for this query or null if none is set.

Remarks

Record filters are boolean expressions that limit the record results of the query.

See Also

ENEQuery Class


NavRecordStructureExpr Property

[image]

Endeca Presentation API
ENEQuery..::..NavRecordStructureExpr Property
ENEQuery Class See Also Send Feedback
Gets and sets the structure expression on this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavRecordStructureExpr { get; set; }
Visual Basic
Public Overridable Property NavRecordStructureExpr As String
    Get
    Set
Visual C++
public:
virtual property String^ NavRecordStructureExpr {
    String^ get ();
    void set (String^ value);
}

Field Value

The structure expression for this query or null if none is set.

Remarks

Structure expressions enable navigation on the structure of records.

See Also

ENEQuery Class


NavRefinementConfigs Property

[image]

Endeca Presentation API
ENEQuery..::..NavRefinementConfigs Property
ENEQuery Class See Also Send Feedback
Gets and sets the list of dynamic refinement configs to be used by the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RefinementConfigList NavRefinementConfigs { get; set; }
Visual Basic
Public Overridable Property NavRefinementConfigs As RefinementConfigList
    Get
    Set
Visual C++
public:
virtual property RefinementConfigList^ NavRefinementConfigs {
    RefinementConfigList^ get ();
    void set (RefinementConfigList^ value);
}

Field Value

A
CopyC#
RefinementConfigList
 that encapsulates all dynamic refinement configs to be used by the MDEX Engine. null if none have been specified.

See Also

ENEQuery Class


NavRelRankERecRank Property

[image]

Endeca Presentation API
ENEQuery..::..NavRelRankERecRank Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecRank NavRelRankERecRank { get; set; }
Visual Basic
Public Overridable Property NavRelRankERecRank As ERecRank
    Get
    Set
Visual C++
public:
virtual property ERecRank^ NavRelRankERecRank {
    ERecRank^ get ();
    void set (ERecRank^ value);
}

Field Value

Navigation relevance rank record search applied to records of the navigation. null if none have been previously specified.

Remarks

See Also

ENEQuery Class


NavRelRankERecSearch Property

[image]

Endeca Presentation API
ENEQuery..::..NavRelRankERecSearch Property
ENEQuery Class See Also Send Feedback
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use NavRelRankERecRank instead.")]
public virtual ERecSearch NavRelRankERecSearch { get; set; }
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use NavRelRankERecRank instead.")> _
Public Overridable Property NavRelRankERecSearch As ERecSearch
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use NavRelRankERecRank instead.")]
public:
virtual property ERecSearch^ NavRelRankERecSearch {
    ERecSearch^ get ();
    void set (ERecSearch^ value);
}

Field Value

Navigation relevance rank record search applied to records of the navigation. null if none have been previously specified.

Remarks

Deprecated: This method may not be available in future versions of the Presentation API. Use NavRelRankERecRank instead.

See Also

ENEQuery Class


NavRollupKey Property

[image]

Endeca Presentation API
ENEQuery..::..NavRollupKey Property
ENEQuery Class See Also Send Feedback
Gets and sets the rollup key with which the records of the navigation query should be rolled up with to create aggregated records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string NavRollupKey { get; set; }
Visual Basic
Public Overridable Property NavRollupKey As String
    Get
    Set
Visual C++
public:
virtual property String^ NavRollupKey {
    String^ get ();
    void set (String^ value);
}

Field Value

The rollup key of the navigation. null if none is specified.

Remarks

By setting a key with this method, records will not be returned by the navigation query but instead Aggr Records will be returned.

See Also

ENEQuery Class


NavStratifiedDimVals Property

[image]

Endeca Presentation API
ENEQuery..::..NavStratifiedDimVals Property
ENEQuery Class See Also Send Feedback
Gets and sets the list stratified dim vals for use during refinement ranking by the MDEX engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual StratifiedDimValList NavStratifiedDimVals { get; set; }
Visual Basic
Public Overridable Property NavStratifiedDimVals As StratifiedDimValList
    Get
    Set
Visual C++
public:
virtual property StratifiedDimValList^ NavStratifiedDimVals {
    StratifiedDimValList^ get ();
    void set (StratifiedDimValList^ value);
}

Field Value

A
CopyC#
StratifiedDimValList
 that encapsulates all the strata to be used for refinement ranking in the MDEX engine. null if none have been specified.

See Also

ENEQuery Class


Profiles Property

[image]

Endeca Presentation API
ENEQuery..::..Profiles Property
ENEQuery Class See Also Send Feedback
Gets and sets the set of profiles that describe the application end user.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual StringCollection Profiles { get; set; }
Visual Basic
Public Overridable Property Profiles As StringCollection
    Get
    Set
Visual C++
public:
virtual property StringCollection^ Profiles {
    StringCollection^ get ();
    void set (StringCollection^ value);
}

Field Value

The set of profiles describing the application end user. Returns null if profiles were not specified.

Remarks

Changing the StringCollection returned will change the set of profiles that will be sent to the Endeca MDEX Engine.

See Also

ENEQuery Class


QueryInfo Property

[image]

Endeca Presentation API
ENEQuery..::..QueryInfo Property
ENEQuery Class See Also Send Feedback
Gets and sets the ENEQueryInfo object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ENEQueryInfo QueryInfo { get; set; }
Visual Basic
Public Overridable Property QueryInfo As ENEQueryInfo
    Get
    Set
Visual C++
public:
virtual property ENEQueryInfo^ QueryInfo {
    ENEQueryInfo^ get ();
    void set (ENEQueryInfo^ value);
}

Field Value

ENEQueryInfo object.

Remarks

This object is used to store information for the back end to log, such as Session Ids and Query Ids. These will be used later in generating log analysis reports.

See Also

ENEQuery Class


Selection Property

[image]

Endeca Presentation API
ENEQuery..::..Selection Property
ENEQuery Class See Also Send Feedback
Gets and sets the select list for the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual FieldList Selection { get; set; }
Visual Basic
Public Overridable Property Selection As FieldList
    Get
    Set
Visual C++
public:
virtual property FieldList^ Selection {
    FieldList^ get ();
    void set (FieldList^ value);
}

Field Value

The list of fields to return with each record in the query results, for navigation, record, and aggregated record queries. Does not affect dimension search queries.

See Also

ENEQuery Class


ENEQueryException Class

[image]

Endeca Presentation API
ENEQueryException Class
Members See Also Send Feedback
Abstract exception representing a general error while attempting to query the Endeca MDEX engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public abstract class ENEQueryException : Exception
Visual Basic
Public MustInherit Class ENEQueryException _
    Inherits Exception
Visual C++
public ref class ENEQueryException abstract : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..EmptyENEQueryException
Endeca.Navigation..::..ENEAuthenticationException
Endeca.Navigation..::..ENEConnectionException
Endeca.Navigation..::..ENEException
Endeca.Navigation..::..PartialENEQueryException
Endeca.Navigation..::..UrlENEQueryParseException
Endeca.Navigation..::..VersionMismatchException

See Also

ENEQueryException Members


ENEQueryException Members

[image] [image]

Endeca Presentation API
ENEQueryException Members
ENEQueryException Class Methods Properties See Also Send Feedback

The ENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEQueryException Class


ENEQueryException Methods

[image] [image]

Endeca Presentation API
ENEQueryException Methods
ENEQueryException Class See Also Send Feedback

The ENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ENEQueryException Class


ENEQueryException Properties

[image] [image]

Endeca Presentation API
ENEQueryException Properties
ENEQueryException Class See Also Send Feedback

The ENEQueryException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ENEQueryException Class


ENEQueryInfo Class

[image]

Endeca Presentation API
ENEQueryInfo Class
Members See Also Send Feedback
An object that generates and stores logging-specific query information.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEQueryInfo
Visual Basic
Public Class ENEQueryInfo
Visual C++
public ref class ENEQueryInfo

Remarks

ENEQueryInfo is used to create and store logging-specific query information, such as a session ID and query ID. The resulting ENEQueryInfo object can then passed to the Endeca MDEX Engine in an ENEQuery object by using the QueryInfo setting property. The information in the ENEQueryInfo object is then entered into the Dgraph log by the MDEX Engine. Note that a logging alternative to this class is to use the Endeca Log Server and the Endeca Logging API.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ENEQueryInfo

See Also

ENEQueryInfo Members


ENEQueryInfo Members

[image] [image]

Endeca Presentation API
ENEQueryInfo Members
ENEQueryInfo Class Constructors Methods Properties See Also Send Feedback

The ENEQueryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ENEQueryInfo()()()() | Constructor. Basic constructor for the ENEQueryInfo.
Public method | ENEQueryInfo(String) | Constructor. Takes in sessionId and sets it as the value for the sid key. The constructor automatically generates the query ID and sets it as the value for the rid key.
Public method | ENEQueryInfo(String, String) | Constructor. Takes in sessionId and queryId and sets the IDs as logging parameters for the sid and rid keys respectively.

Methods

 | Name | Description
Public method | Add | Adds a key/value pair to the ENEQueryInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | QueryIdentifier | Gets the value of the Query ID key or sets it to a specified String.
Public property | SessionIdentifier | Gets the value of the Session ID key or sets it to a specified String.

See Also

ENEQueryInfo Class


ENEQueryInfo Constructor

[image] [image]

Endeca Presentation API
ENEQueryInfo Constructor
ENEQueryInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ENEQueryInfo()()()() | Constructor. Basic constructor for the ENEQueryInfo.
Public method | ENEQueryInfo(String) | Constructor. Takes in sessionId and sets it as the value for the sid key. The constructor automatically generates the query ID and sets it as the value for the rid key.
Public method | ENEQueryInfo(String, String) | Constructor. Takes in sessionId and queryId and sets the IDs as logging parameters for the sid and rid keys respectively.

See Also

ENEQueryInfo Class
ENEQueryInfo Members


ENEQueryInfo Constructor

[image]

Endeca Presentation API
ENEQueryInfo Constructor
ENEQueryInfo Class See Also Send Feedback
Constructor. Basic constructor for the ENEQueryInfo.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEQueryInfo()
Visual Basic
Public Sub New
Visual C++
public:
ENEQueryInfo()

Remarks

Generates two key/value pairs automatically: the session ID (the sid key) and the query ID (the rid key). This functionality, however, is deprecated and instead developers should generate their own IDs and use the Add(String, String) method to set them in the object.

See Also

ENEQueryInfo Class
ENEQueryInfo Overload


ENEQueryInfo Constructor (String)

[image]

Endeca Presentation API
ENEQueryInfo Constructor (String)
ENEQueryInfo Class See Also Send Feedback
Constructor. Takes in sessionId and sets it as the value for the sid key. The constructor automatically generates the query ID and sets it as the value for the rid key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEQueryInfo(
    string sessionId
)
Visual Basic
Public Sub New ( _
    sessionId As String _
)
Visual C++
public:
ENEQueryInfo(
    String^ sessionId
)

Parameters

sessionId
Type: System..::..String
Session ID to pass on as logging information with the sid key.

Remarks

Future versions of the MDEX Engine API may not support this constructor. Instead, this functionailty is preserved by calling the basic constructor for ENEQueryInfo followed by Add(String, String) with the IDs and their respective keys.

See Also

ENEQueryInfo Class
ENEQueryInfo Overload


ENEQueryInfo Constructor (String, String)

[image]

Endeca Presentation API
ENEQueryInfo Constructor (String, String)
ENEQueryInfo Class See Also Send Feedback
Constructor. Takes in sessionId and queryId and sets the IDs as logging parameters for the sid and rid keys respectively.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ENEQueryInfo(
    string sessionId,
    string queryId
)
Visual Basic
Public Sub New ( _
    sessionId As String, _
    queryId As String _
)
Visual C++
public:
ENEQueryInfo(
    String^ sessionId,
    String^ queryId
)

Parameters

sessionId
Type: System..::..String
Session ID to pass on as logging information with the sid key.
queryId
Type: System..::..String
Query ID to pass on as logging information with the rid key.

Remarks

Future versions of the MDEX Engine API may not support this constructor. Instead, this functionailty is preserved by calling the basic constructor for ENEQueryInfo followed by Add(String, String) with the IDs and their respective keys.

See Also

ENEQueryInfo Class
ENEQueryInfo Overload


ENEQueryInfo Methods

[image] [image]

Endeca Presentation API
ENEQueryInfo Methods
ENEQueryInfo Class See Also Send Feedback

The ENEQueryInfo type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a key/value pair to the ENEQueryInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ENEQueryInfo Class


Add Method

[image]

Endeca Presentation API
ENEQueryInfo..::..Add Method
ENEQueryInfo Class See Also Send Feedback
Adds a key/value pair to the ENEQueryInfo object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    string key,
    string val
)
Visual Basic
Public Overridable Sub Add ( _
    key As String, _
    val As String _
)
Visual C++
public:
virtual void Add(
    String^ key,
    String^ val
)

Parameters

key
Type: System..::..String
The key for the key/value pair to be added to the ENEQueryInfo object.
val
Type: System..::..String
The value for the key.

Remarks

An application may call this method as many times as needed, as each call adds to the key/value pairs being stored in the ENEQueryInfo object. This method will discard keys or values that are NULL or empty strings.

All the key/value pairs will be logged in the Dgraph log when the ENEQueryInfo object is passed to the MDEX Engine with the the QueryInfo setting property.

Note that the current implementation of the basic constructor automatically generates two keys (sid and rid) and their values. This current behavior is deprecated. Therefore, developers should instead generate their own session and query IDs and use this method to override the values of the sid and rid keys.

See Also

ENEQueryInfo Class


ENEQueryInfo Properties

[image] [image]

Endeca Presentation API
ENEQueryInfo Properties
ENEQueryInfo Class See Also Send Feedback

The ENEQueryInfo type exposes the following members.

Properties

 | Name | Description
Public property | QueryIdentifier | Gets the value of the Query ID key or sets it to a specified String.
Public property | SessionIdentifier | Gets the value of the Session ID key or sets it to a specified String.

See Also

ENEQueryInfo Class


QueryIdentifier Property

[image]

Endeca Presentation API
ENEQueryInfo..::..QueryIdentifier Property
ENEQueryInfo Class See Also Send Feedback
Gets the value of the Query ID key or sets it to a specified String.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string QueryIdentifier { get; set; }
Visual Basic
Public Overridable Property QueryIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ QueryIdentifier {
    String^ get ();
    void set (String^ value);
}

Field Value

Query ID of the query.

Remarks

This method may not be supported in future versions of the MDEX Engine API. Instead, one should use the Add(String, String) method instead.

See Also

ENEQueryInfo Class


SessionIdentifier Property

[image]

Endeca Presentation API
ENEQueryInfo..::..SessionIdentifier Property
ENEQueryInfo Class See Also Send Feedback
Gets the value of the Session ID key or sets it to a specified String.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string SessionIdentifier { get; set; }
Visual Basic
Public Overridable Property SessionIdentifier As String
    Get
    Set
Visual C++
public:
virtual property String^ SessionIdentifier {
    String^ get ();
    void set (String^ value);
}

Field Value

Session ID (the sid key value) of the query.

Remarks

This set property may not be supported in future versions of the MDEX Engine API. Use the Add(String, String) method instead.

See Also

ENEQueryInfo Class


ENEQueryResults Class

[image]

Endeca Presentation API
ENEQueryResults Class
Members See Also Send Feedback
Result object returned from a query to an Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEQueryResults
Visual Basic
Public Class ENEQueryResults
Visual C++
public ref class ENEQueryResults

Remarks

The ENEQueryResults object is returned by the Query method of the HttpENEConnection and AuthHttpENEConnection classes. The ENEQueryResults object encapsulates these four objects: Navigation, ERecList, AggrERec, and DimensionSearchResult. The ENEQueryResults object also contains the total time (in seconds) that was spent waiting for the MDEX Engine to respond.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ENEQueryResults

See Also

ENEQueryResults Members


ENEQueryResults Members

[image] [image]

Endeca Presentation API
ENEQueryResults Members
ENEQueryResults Class Methods Properties See Also Send Feedback

The ENEQueryResults type exposes the following members.

Methods

 | Name | Description
Public method | ContainsAggrERec | Indicates whether this query results object contains an Endeca aggregated record.
Public method | ContainsDimensionSearch | Indicates whether this query results object contains a dimension search results object.
Public method | ContainsDimSearch | Indicates whether this query results object contains a dimension search results object.
Public method | ContainsERec | Indicates whether this query results object contains an Endeca record.
Public method | ContainsERecs | Indicates whether this query results object contains one or more Endeca records.
Public method | ContainsNavigation | Indicates whether this query results object contains a Navigation object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AggrERec | Gets the Endeca aggregated record object result.
Public property | DimensionSearch | Gets the dimension search object result.
Public property | DimSearch | Obsolete. Gets the dimension search object result.
Public property | ERec | Gets the Endeca record object result.
Public property | ERecs | Gets the Endeca records for the result.
Public property | Navigation | Gets the navigation object result.
Public property | TotalNetworkAndComputeTime | Gets the total number of seconds spent waiting for the MDEX Engine to respond to all queries.

See Also

ENEQueryResults Class


ENEQueryResults Methods

[image] [image]

Endeca Presentation API
ENEQueryResults Methods
ENEQueryResults Class See Also Send Feedback

The ENEQueryResults type exposes the following members.

Methods

 | Name | Description
Public method | ContainsAggrERec | Indicates whether this query results object contains an Endeca aggregated record.
Public method | ContainsDimensionSearch | Indicates whether this query results object contains a dimension search results object.
Public method | ContainsDimSearch | Indicates whether this query results object contains a dimension search results object.
Public method | ContainsERec | Indicates whether this query results object contains an Endeca record.
Public method | ContainsERecs | Indicates whether this query results object contains one or more Endeca records.
Public method | ContainsNavigation | Indicates whether this query results object contains a Navigation object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ENEQueryResults Class


ContainsAggrERec Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsAggrERec Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains an Endeca aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsAggrERec()
Visual Basic
Public Overridable Function ContainsAggrERec As Boolean
Visual C++
public:
virtual bool ContainsAggrERec()

Return Value

true if an aggregated record (AggrERec object) is present, or false if not.

See Also

ENEQueryResults Class


ContainsDimensionSearch Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsDimensionSearch Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains a dimension search results object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsDimensionSearch()
Visual Basic
Public Overridable Function ContainsDimensionSearch As Boolean
Visual C++
public:
virtual bool ContainsDimensionSearch()

Return Value

true if a dimension search object (DimensionSearchResult) is present, or false if not.

See Also

ENEQueryResults Class


ContainsDimSearch Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsDimSearch Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains a dimension search results object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsDimSearch()
Visual Basic
Public Overridable Function ContainsDimSearch As Boolean
Visual C++
public:
virtual bool ContainsDimSearch()

Return Value

true if a dimension search results object is present, false if not.

See Also

ENEQueryResults Class


ContainsERec Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsERec Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains an Endeca record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsERec()
Visual Basic
Public Overridable Function ContainsERec As Boolean
Visual C++
public:
virtual bool ContainsERec()

Return Value

true if an Endeca record (ERec object) is present, or false if not.

See Also

ENEQueryResults Class


ContainsERecs Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsERecs Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains one or more Endeca records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsERecs()
Visual Basic
Public Overridable Function ContainsERecs As Boolean
Visual C++
public:
virtual bool ContainsERecs()

Return Value

true if at least one Endeca record (ERec object) is present, or false if not.

See Also

ENEQueryResults Class


ContainsNavigation Method

[image]

Endeca Presentation API
ENEQueryResults..::..ContainsNavigation Method
ENEQueryResults Class See Also Send Feedback
Indicates whether this query results object contains a Navigation object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool ContainsNavigation()
Visual Basic
Public Overridable Function ContainsNavigation As Boolean
Visual C++
public:
virtual bool ContainsNavigation()

Return Value

true if a Navigation object is present, or false if not.

See Also

ENEQueryResults Class


ENEQueryResults Properties

[image] [image]

Endeca Presentation API
ENEQueryResults Properties
ENEQueryResults Class See Also Send Feedback

The ENEQueryResults type exposes the following members.

Properties

 | Name | Description
Public property | AggrERec | Gets the Endeca aggregated record object result.
Public property | DimensionSearch | Gets the dimension search object result.
Public property | DimSearch | Obsolete. Gets the dimension search object result.
Public property | ERec | Gets the Endeca record object result.
Public property | ERecs | Gets the Endeca records for the result.
Public property | Navigation | Gets the navigation object result.
Public property | TotalNetworkAndComputeTime | Gets the total number of seconds spent waiting for the MDEX Engine to respond to all queries.

See Also

ENEQueryResults Class


AggrERec Property

[image]

Endeca Presentation API
ENEQueryResults..::..AggrERec Property
ENEQueryResults Class See Also Send Feedback
Gets the Endeca aggregated record object result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AggrERec AggrERec { get; }
Visual Basic
Public Overridable ReadOnly Property AggrERec As AggrERec
    Get
Visual C++
public:
virtual property AggrERec^ AggrERec {
    AggrERec^ get ();
}

Field Value

The aggregated record requested (an AggrERec object), or null if none is present in the ENEQueryResults.

See Also

ENEQueryResults Class


DimensionSearch Property

[image]

Endeca Presentation API
ENEQueryResults..::..DimensionSearch Property
ENEQueryResults Class See Also Send Feedback
Gets the dimension search object result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionSearchResult DimensionSearch { get; }
Visual Basic
Public Overridable ReadOnly Property DimensionSearch As DimensionSearchResult
    Get
Visual C++
public:
virtual property DimensionSearchResult^ DimensionSearch {
    DimensionSearchResult^ get ();
}

Field Value

Dimension search result (DimensionSearchResult object), or null if none is present in the ENEQueryResults.

See Also

ENEQueryResults Class


DimSearch Property

[image]

Endeca Presentation API
ENEQueryResults..::..DimSearch Property
ENEQueryResults Class See Also Send Feedback
Gets the dimension search object result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This property may not be supported in future versions of the MDEX Engine API. Use DimensionSearch instead.")]
public virtual DimSearchResult DimSearch { get; }
Visual Basic
<ObsoleteAttribute("This property may not be supported in future versions of the MDEX Engine API. Use DimensionSearch instead.")> _
Public Overridable ReadOnly Property DimSearch As DimSearchResult
    Get
Visual C++
[ObsoleteAttribute(L"This property may not be supported in future versions of the MDEX Engine API. Use DimensionSearch instead.")]
public:
virtual property DimSearchResult^ DimSearch {
    DimSearchResult^ get ();
}

Field Value

Dimension search result (DimSearchResult object), or null if none is present in the ENEQueryResults.

See Also

ENEQueryResults Class


ERec Property

[image]

Endeca Presentation API
ENEQueryResults..::..ERec Property
ENEQueryResults Class See Also Send Feedback
Gets the Endeca record object result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERec ERec { get; }
Visual Basic
Public Overridable ReadOnly Property ERec As ERec
    Get
Visual C++
public:
virtual property ERec^ ERec {
    ERec^ get ();
}

Field Value

The record requested (an ERec object), or null if none is present in the ENEQueryResults.

Remarks

If more than one record was requested, this method returns the first one. See ERecs if more than one record was requested.

See Also

ENEQueryResults Class


ERecs Property

[image]

Endeca Presentation API
ENEQueryResults..::..ERecs Property
ENEQueryResults Class See Also Send Feedback
Gets the Endeca records for the result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecList ERecs { get; }
Visual Basic
Public Overridable ReadOnly Property ERecs As ERecList
    Get
Visual C++
public:
virtual property ERecList^ ERecs {
    ERecList^ get ();
}

Field Value

An ERecList object containing the records requested, or null if none is present in the ENEQueryResults.

Remarks

If one or more records were requested, this method returns a record list containing all the records.

See Also

ENEQueryResults Class


Navigation Property

[image]

Endeca Presentation API
ENEQueryResults..::..Navigation Property
ENEQueryResults Class See Also Send Feedback
Gets the navigation object result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Navigation Navigation { get; }
Visual Basic
Public Overridable ReadOnly Property Navigation As Navigation
    Get
Visual C++
public:
virtual property Navigation^ Navigation {
    Navigation^ get ();
}

Field Value

A Navigation object, or null if none is present in the ENEQueryResults.

See Also

ENEQueryResults Class


TotalNetworkAndComputeTime Property

[image]

Endeca Presentation API
ENEQueryResults..::..TotalNetworkAndComputeTime Property
ENEQueryResults Class See Also Send Feedback
Gets the total number of seconds spent waiting for the MDEX Engine to respond to all queries.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual double TotalNetworkAndComputeTime { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNetworkAndComputeTime As Double
    Get
Visual C++
public:
virtual property double TotalNetworkAndComputeTime {
    double get ();
}

Field Value

The total time includes network communication time and computation time, plus time spent waiting in the MDEX Engine's request queue.

See Also

ENEQueryResults Class


ENEQueryToolkit Class

[image]

Endeca Presentation API
ENEQueryToolkit Class
Members See Also Send Feedback
ENEQueryToolkit provides static methods for managing the value of the primary URL query parameter in a navigation query. This parameter specifies the list of refinement dimensions that were used to generate the current query results. Managing the parameter's value allows you to maintain application state.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ENEQueryToolkit
Visual Basic
Public Class ENEQueryToolkit
Visual C++
public ref class ENEQueryToolkit

Remarks

With ENEQueryToolkit, you can update the list of refinement dimensions to reflect the user's latest refinement selection. That selection may require the addition of a new refinement dimension, the removal of a dimension, or the substitution of one dimension ID for another (as in the case where the user selects a refinement from a nested dimension hierarchy).

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ENEQueryToolkit

See Also

ENEQueryToolkit Members


ENEQueryToolkit Members

[image] [image]

Endeca Presentation API
ENEQueryToolkit Members
ENEQueryToolkit Class Methods See Also Send Feedback

The ENEQueryToolkit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsImplicitRefinement | Determines if a dimension value refinement is an implicit refinement within the context of a given dimension.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveDescriptor | Generates the navigation descriptors of the ENEQuery after removing a descriptor.
 | SelectAncestor | Generates the navigation descriptors of the ENEQuery for a selected ancestor.
 | SelectRefinement | Method to generate the navigation descriptors of the ENEQuery for a selected refinement. Generates the navigation descriptors of the ENEQuery for a selected refinement. * descriptors that are ancestors of the refinements are removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ENEQueryToolkit Class


ENEQueryToolkit Methods

[image] [image]

Endeca Presentation API
ENEQueryToolkit Methods
ENEQueryToolkit Class See Also Send Feedback

The ENEQueryToolkit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsImplicitRefinement | Determines if a dimension value refinement is an implicit refinement within the context of a given dimension.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveDescriptor | Generates the navigation descriptors of the ENEQuery after removing a descriptor.
 | SelectAncestor | Generates the navigation descriptors of the ENEQuery for a selected ancestor.
 | SelectRefinement | Method to generate the navigation descriptors of the ENEQuery for a selected refinement. Generates the navigation descriptors of the ENEQuery for a selected refinement. * descriptors that are ancestors of the refinements are removed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ENEQueryToolkit Class


IsImplicitRefinement Method

[image]

Endeca Presentation API
ENEQueryToolkit..::..IsImplicitRefinement Method
ENEQueryToolkit Class See Also Send Feedback
Determines if a dimension value refinement is an implicit refinement within the context of a given dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static bool IsImplicitRefinement(
    Dimension dim,
    DimVal refinement
)
Visual Basic
Public Shared Function IsImplicitRefinement ( _
    dim As Dimension, _
    refinement As DimVal _
) As Boolean
Visual C++
public:
static bool IsImplicitRefinement(
    Dimension^ dim,
    DimVal^ refinement
)

Parameters

dim
Type: Endeca.Navigation..::..Dimension
The dimension (a Dimension object) in which the given refinement should be checked.
refinement
Type: Endeca.Navigation..::..DimVal
The refinement (a DimVal object) to check for contraction.

Return Value

true if refinement is an implicit refinement within the dimension dim, or false otherwise.

Remarks

An implicit refinement is one that is assigned to all records visible in the current navigation state. In other words, an implicit refinement is one whose selection will not actually narrow the current set of result records.

See Also

ENEQueryToolkit Class


RemoveDescriptor Method

[image]

Endeca Presentation API
ENEQueryToolkit..::..RemoveDescriptor Method
ENEQueryToolkit Class See Also Send Feedback
Generates the navigation descriptors of the ENEQuery after removing a descriptor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static DimValIdList RemoveDescriptor(
    Navigation n,
    DimVal descriptor
)
Visual Basic
Public Shared Function RemoveDescriptor ( _
    n As Navigation, _
    descriptor As DimVal _
) As DimValIdList
Visual C++
public:
static DimValIdList^ RemoveDescriptor(
    Navigation^ n,
    DimVal^ descriptor
)

Parameters

n
Type: Endeca.Navigation..::..Navigation
The current Navigation object.
descriptor
Type: Endeca.Navigation..::..DimVal
The descriptor (a DimVal object) which will be removed.

Return Value

A DimValIdList object containing the IDs of the new navigation query descriptors after the removal of the descriptor (specified by the descriptor parameter).

Remarks

Removes the specified navigation descriptor (the descriptor parameter) from the set of descriptors in the Navigation object and generates a new set of navigation values for the ENEQuery. The order of the descriptors in the new navigation query remains the same as the order in the current Navigation object (specified by the n parameter), with the descriptor removed. Ancestors of the descriptor do not remain after the descriptor has been removed.

See Also

ENEQueryToolkit Class


SelectAncestor Method

[image]

Endeca Presentation API
ENEQueryToolkit..::..SelectAncestor Method
ENEQueryToolkit Class See Also Send Feedback
Generates the navigation descriptors of the ENEQuery for a selected ancestor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static DimValIdList SelectAncestor(
    Navigation n,
    DimVal ancestor,
    DimVal descriptor
)
Visual Basic
Public Shared Function SelectAncestor ( _
    n As Navigation, _
    ancestor As DimVal, _
    descriptor As DimVal _
) As DimValIdList
Visual C++
public:
static DimValIdList^ SelectAncestor(
    Navigation^ n,
    DimVal^ ancestor,
    DimVal^ descriptor
)

Parameters

n
Type: Endeca.Navigation..::..Navigation
The current Navigation object.
ancestor
Type: Endeca.Navigation..::..DimVal
The ancestor (a DimVal object) which will be used to generate new navigation values.
descriptor
Type: Endeca.Navigation..::..DimVal
The descriptor (a DimVal object) which will be replaced with its ancestor.

Return Value

A DimValIdList object containing the IDs of the new navigation query descriptors after the current navigation descriptor is replaced with its ancestor.

Remarks

This method replaces the specified navigation descriptor (the descriptor parameter) with the ancestor dimension value (the ancestor parameter), and generates a new set of navigation values for the ENEQuery. The order of the descriptors remains the same as the order in the current Navigation object. However, the specified ancestor is substituted for the specified descriptor.

See Also

ENEQueryToolkit Class


SelectRefinement Method

[image]

Endeca Presentation API
ENEQueryToolkit..::..SelectRefinement Method
ENEQueryToolkit Class See Also Send Feedback
Method to generate the navigation descriptors of the ENEQuery for a selected refinement. Generates the navigation descriptors of the ENEQuery for a selected refinement. * descriptors that are ancestors of the refinements are removed.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static DimValIdList SelectRefinement(
    Navigation n,
    DimVal refinement
)
Visual Basic
Public Shared Function SelectRefinement ( _
    n As Navigation, _
    refinement As DimVal _
) As DimValIdList
Visual C++
public:
static DimValIdList^ SelectRefinement(
    Navigation^ n,
    DimVal^ refinement
)

Parameters

n
Type: Endeca.Navigation..::..Navigation
The current Navigation object.
refinement
Type: Endeca.Navigation..::..DimVal
The refinement dimension value (a DimVal object) that will be used to reduce the current record set.

Return Value

A DimValIdList object containing the IDs of the new navigation query descriptors after the addition of the specified refinement value to the existing set of navigation descriptors in the Navigation object specified by the n parameter.

Remarks

This method adds a refinement value to the set of navigation descriptors already existing in a Navigation object and generates a new set of navigation values for the ENEQuery. In general, new refinements are placed at the end of the descriptor list. Existing descriptors that are ancestors of the refinements are removed.

See Also

ENEQueryToolkit Class


ERec Class

[image]

Endeca Presentation API
ERec Class
Members See Also Send Feedback
ERec class is composed of properties and dimension values it is tagged by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERec : IPropertyContainer
Visual Basic
Public Class ERec _
    Implements IPropertyContainer
Visual C++
public ref class ERec : IPropertyContainer

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERec

See Also

ERec Members


ERec Members

[image] [image]

Endeca Presentation API
ERec Members
ERec Class Methods Properties See Also Send Feedback

The ERec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DimValues | Gets the dimension values tagged to the record.
Public property | Id | Obsolete. Gets the ID for this record.
Public property | Properties | Gets the properties for this record. If there are no properties for a record, an empty PropertyMap will be returned.
Public property | Spec | Gets the specification of the record.

See Also

ERec Class


ERec Methods

[image] [image]

Endeca Presentation API
ERec Methods
ERec Class See Also Send Feedback

The ERec type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERec Class


ERec Properties

[image] [image]

Endeca Presentation API
ERec Properties
ERec Class See Also Send Feedback

The ERec type exposes the following members.

Properties

 | Name | Description
Public property | DimValues | Gets the dimension values tagged to the record.
Public property | Id | Obsolete. Gets the ID for this record.
Public property | Properties | Gets the properties for this record. If there are no properties for a record, an empty PropertyMap will be returned.
Public property | Spec | Gets the specification of the record.

See Also

ERec Class


DimValues Property

[image]

Endeca Presentation API
ERec..::..DimValues Property
ERec Class See Also Send Feedback
Gets the dimension values tagged to the record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AssocDimLocationsList DimValues { get; }
Visual Basic
Public Overridable ReadOnly Property DimValues As AssocDimLocationsList
    Get
Visual C++
public:
virtual property AssocDimLocationsList^ DimValues {
    AssocDimLocationsList^ get ();
}

Field Value

The values tagged to the record are organized by dimension. An empty list is returned if there are no dimension values tagged to the record.

Remarks

The dimension values are organized by dimensions and each value manifested as a position which includes the value and its ancestors in the dimension's hierarchy. Based on how this record was obtained, these tagged values may or may not be present.

See Also

ERec Class


Id Property

[image]

Endeca Presentation API
ERec..::..Id Property
ERec Class See Also Send Feedback
Gets the ID for this record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")]
public virtual long Id { get; }
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")> _
Public Overridable ReadOnly Property Id As Long
    Get
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use Spec instead.")]
public:
virtual property long long Id {
    long long get ();
}

Field Value

The ID for this record.

Exceptions

Exception | Condition
System..::..Exception | Thrown when the specification is not a numeric value.

See Also

ERec Class


Properties Property

[image]

Endeca Presentation API
ERec..::..Properties Property
ERec Class See Also Send Feedback
Gets the properties for this record. If there are no properties for a record, an empty PropertyMap will be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap Properties { get; }
Visual Basic
Public Overridable ReadOnly Property Properties As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

Properties for this record.

Implements

IPropertyContainer..::..Properties

See Also

ERec Class


Spec Property

[image]

Endeca Presentation API
ERec..::..Spec Property
ERec Class See Also Send Feedback
Gets the specification of the record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Spec { get; }
Visual Basic
Public Overridable ReadOnly Property Spec As String
    Get
Visual C++
public:
virtual property String^ Spec {
    String^ get ();
}

Field Value

The specification of the record.

See Also

ERec Class


ERecCompoundSearchKey Class

[image]

Endeca Presentation API
ERecCompoundSearchKey Class
Members See Also Send Feedback
Key with which a record set can be or is text group searched by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecCompoundSearchKey
Visual Basic
Public Class ERecCompoundSearchKey
Visual C++
public ref class ERecCompoundSearchKey

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecCompoundSearchKey

See Also

ERecCompoundSearchKey Members


ERecCompoundSearchKey Members

[image] [image]

Endeca Presentation API
ERecCompoundSearchKey Members
ERecCompoundSearchKey Class Methods Properties See Also Send Feedback

The ERecCompoundSearchKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this text search key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Get the name of this text group search key.

See Also

ERecCompoundSearchKey Class


ERecCompoundSearchKey Methods

[image] [image]

Endeca Presentation API
ERecCompoundSearchKey Methods
ERecCompoundSearchKey Class See Also Send Feedback

The ERecCompoundSearchKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this text search key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecCompoundSearchKey Class


IsActive Method

[image]

Endeca Presentation API
ERecCompoundSearchKey..::..IsActive Method
ERecCompoundSearchKey Class See Also Send Feedback
Returns whether the key is active. Returns whether this text search key is being applied.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsActive()
Visual Basic
Public Overridable Function IsActive As Boolean
Visual C++
public:
virtual bool IsActive()

Return Value

true if the key is being applied, and false if it is not.

See Also

ERecCompoundSearchKey Class


ERecCompoundSearchKey Properties

[image] [image]

Endeca Presentation API
ERecCompoundSearchKey Properties
ERecCompoundSearchKey Class See Also Send Feedback

The ERecCompoundSearchKey type exposes the following members.

Properties

 | Name | Description
Public property | Name | Get the name of this text group search key.

See Also

ERecCompoundSearchKey Class


Name Property

[image]

Endeca Presentation API
ERecCompoundSearchKey..::..Name Property
ERecCompoundSearchKey Class See Also Send Feedback
Get the name of this text group search key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

Name of this text search key or null if it is not specified.

See Also

ERecCompoundSearchKey Class


ERecCompoundSearchKeyList Class

[image]

Endeca Presentation API
ERecCompoundSearchKeyList Class
Members See Also Send Feedback
Collection of record compound search keys exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecCompoundSearchKeyList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class ERecCompoundSearchKeyList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecCompoundSearchKeyList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecCompoundSearchKeyList

See Also

ERecCompoundSearchKeyList Members


ERecCompoundSearchKeyList Members

[image] [image]

Endeca Presentation API
ERecCompoundSearchKeyList Members
ERecCompoundSearchKeyList Class Methods Properties See Also Send Feedback

The ERecCompoundSearchKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecCompoundSearchKeyList.
Public method | CopyTo | Copies the entire ERecCompoundSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecCompoundSearchKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the ERecCompoundSearchKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecCompoundSearchKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecCompoundSearchKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecCompoundSearchKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecCompoundSearchKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecCompoundSearchKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecCompoundSearchKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecCompoundSearchKeyList Class


ERecCompoundSearchKeyList Methods

[image] [image]

Endeca Presentation API
ERecCompoundSearchKeyList Methods
ERecCompoundSearchKeyList Class See Also Send Feedback

The ERecCompoundSearchKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecCompoundSearchKeyList.
Public method | CopyTo | Copies the entire ERecCompoundSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecCompoundSearchKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the ERecCompoundSearchKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecCompoundSearchKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecCompoundSearchKeyList Class


Add Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Add Method
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the ERecCompoundSearchKeyList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


Clear Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Clear Method
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


Contains Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Contains Method
ERecCompoundSearchKeyList Class See Also Send Feedback
Determines whether an element is in the ERecCompoundSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecCompoundSearchKeyList.

Return Value

true if item is found in the ERecCompoundSearchKeyList.

Implements

IList..::..Contains(Object)

See Also

ERecCompoundSearchKeyList Class


CopyTo Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..CopyTo Method
ERecCompoundSearchKeyList Class See Also Send Feedback
Copies the entire ERecCompoundSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecCompoundSearchKeyList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecCompoundSearchKeyList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecCompoundSearchKeyList be cast automatically to the type of the destination array.

See Also

ERecCompoundSearchKeyList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..GetEnumerator Method
ERecCompoundSearchKeyList Class See Also Send Feedback
Returns an enumerator for the entire ERecCompoundSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecCompoundSearchKeyList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecCompoundSearchKeyList Class


GetKey Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..GetKey Method
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets the ERecCompoundSearchKey with the name name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecCompoundSearchKey GetKey(
    string name
)
Visual Basic
Public Overridable Function GetKey ( _
    name As String _
) As ERecCompoundSearchKey
Visual C++
public:
virtual ERecCompoundSearchKey^ GetKey(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the ERecCompoundSearchKey to get.

Return Value

The record compound search key specified with name. Returns null if key with specified name could not be found.

See Also

ERecCompoundSearchKeyList Class


IndexOf Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..IndexOf Method
ERecCompoundSearchKeyList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecCompoundSearchKeyList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecCompoundSearchKeyList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecCompoundSearchKeyList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecCompoundSearchKeyList Class


Insert Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Insert Method
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


Remove Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Remove Method
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecCompoundSearchKeyList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


RemoveAt Method

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..RemoveAt Method
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


ERecCompoundSearchKeyList Properties

[image] [image]

Endeca Presentation API
ERecCompoundSearchKeyList Properties
ERecCompoundSearchKeyList Class See Also Send Feedback

The ERecCompoundSearchKeyList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecCompoundSearchKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecCompoundSearchKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecCompoundSearchKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecCompoundSearchKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecCompoundSearchKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecCompoundSearchKeyList Class


Count Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Count Property
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecCompoundSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecCompoundSearchKeyList.

Implements

ICollection..::..Count

See Also

ERecCompoundSearchKeyList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..IsFixedSize Property
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecCompoundSearchKeyList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecCompoundSearchKeyList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

ERecCompoundSearchKeyList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..IsReadOnly Property
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecCompoundSearchKeyList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecCompoundSearchKeyList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

ERecCompoundSearchKeyList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..IsSynchronized Property
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets a value indicating whether access to the ERecCompoundSearchKeyList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecCompoundSearchKeyList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecCompoundSearchKeyList Class


Item Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..Item Property
ERecCompoundSearchKeyList Class See Also Send Feedback
Gets the ERecCompoundSearchKey at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The ERecCompoundSearchKey at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

ERecCompoundSearchKeyList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecCompoundSearchKeyList..::..SyncRoot Property
ERecCompoundSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecCompoundSearchKeyList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecCompoundSearchKeyList Class


ERecEnumerator Class

[image]

Endeca Presentation API
ERecEnumerator Class
Members See Also Send Feedback
List containing ERec or AggrERec objects exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecEnumerator : IEnumerator
Visual Basic
Public Class ERecEnumerator _
    Implements IEnumerator
Visual C++
public ref class ERecEnumerator : IEnumerator

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecEnumerator

See Also

ERecEnumerator Members


ERecEnumerator Members

[image] [image]

Endeca Presentation API
ERecEnumerator Members
ERecEnumerator Class Methods Properties See Also Send Feedback

The ERecEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNext | Return true if additional ERecs are available from this ERecEnumerator.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances to the next ERec.
Public method | Reset | Not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of ERecs available from this ERecEnumerator.
Public property | Current | Gets the current ERec.

See Also

ERecEnumerator Class


ERecEnumerator Methods

[image] [image]

Endeca Presentation API
ERecEnumerator Methods
ERecEnumerator Class See Also Send Feedback

The ERecEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNext | Return true if additional ERecs are available from this ERecEnumerator.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances to the next ERec.
Public method | Reset | Not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecEnumerator Class


HasNext Method

[image]

Endeca Presentation API
ERecEnumerator..::..HasNext Method
ERecEnumerator Class See Also Send Feedback
Return true if additional ERecs are available from this ERecEnumerator.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool HasNext()
Visual Basic
Public Function HasNext As Boolean
Visual C++
public:
bool HasNext()

Return Value

'true' if additional records are available from this ERecEnumerator.

See Also

ERecEnumerator Class


MoveNext Method

[image]

Endeca Presentation API
ERecEnumerator..::..MoveNext Method
ERecEnumerator Class See Also Send Feedback
Advances to the next ERec.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext() sealed

Return Value

'true' if additional records are available from this ERecEnumerator.

Implements

IEnumerator..::..MoveNext()()()()

See Also

ERecEnumerator Class


Reset Method

[image]

Endeca Presentation API
ERecEnumerator..::..Reset Method
ERecEnumerator Class See Also Send Feedback
Not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
virtual void Reset() sealed

Implements

IEnumerator..::..Reset()()()()

See Also

ERecEnumerator Class


ERecEnumerator Properties

[image] [image]

Endeca Presentation API
ERecEnumerator Properties
ERecEnumerator Class See Also Send Feedback

The ERecEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of ERecs available from this ERecEnumerator.
Public property | Current | Gets the current ERec.

See Also

ERecEnumerator Class


Count Property

[image]

Endeca Presentation API
ERecEnumerator..::..Count Property
ERecEnumerator Class See Also Send Feedback
Gets the number of ERecs available from this ERecEnumerator.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public long Count { get; }
Visual Basic
Public ReadOnly Property Count As Long
    Get
Visual C++
public:
property long long Count {
    long long get ();
}

Field Value

The count of ERec or AggrERec available from this ERecEnumerator.

See Also

ERecEnumerator Class


Current Property

[image]

Endeca Presentation API
ERecEnumerator..::..Current Property
ERecEnumerator Class See Also Send Feedback
Gets the current ERec.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Field Value

The current ERec or AggrERec for this ERecEnumerator.

Implements

IEnumerator..::..Current

See Also

ERecEnumerator Class


ERecIdList Class

[image]

Endeca Presentation API
ERecIdList Class
Members See Also Send Feedback
List of record specifications. Primarily used to generate URLs and MDEX Engine queries.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class ERecIdList : IList, ICollection,
    IEnumerable
Visual Basic
<SerializableAttribute> _
Public Class ERecIdList _
    Implements IList, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
public ref class ERecIdList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecIdList

See Also

ERecIdList Members


ERecIdList Members

[image] [image]

Endeca Presentation API
ERecIdList Members
ERecIdList Class Constructors Methods Properties See Also Send Feedback

The ERecIdList type exposes the following members.

Constructors

 | Name | Description
Public method | ERecIdList()()()() | Default constructor. Creates a new, empty ERecIdList.
Public method | ERecIdList(Int64) | Obsolete. Constructor that takes a single ID and makes a record ID list with only one element.
Public method | ERecIdList(String) | Constructor that takes a string-based set of record specifications and parses and populates the list with the string.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the ERecIdList.
Public method | AddERecId | Obsolete. Adds a record ID to the list.
Public method | AddERecSpec | Adds a record specification to the list.
Public method | Clear | Removes all the elements from the ERecIdList.
Public method | Contains | Determines whether an element is in the ERecIdList.
Public method | CopyTo | Copies the entire ERecIdList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecIdList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecIdList or in a portion of it.
Public method | Insert | Inserts an element into the ERecIdList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurence of a specified object from the ERecIdList.
Public method | RemoveAt | Removes the element at the specified index of the ERecIdList.
Public method | ToString | Generates the string-based representation of the list by returning a space-delimited sequence of record IDs.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecIdList.
Public property | IsFixedSize | Gets a value indicating whether the ERecIdList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecIdList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecIdList is synchronized (thread-safe).
Public property | Item | Gets or sets the Int64 at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecIdList Class


ERecIdList Constructor

[image] [image]

Endeca Presentation API
ERecIdList Constructor
ERecIdList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ERecIdList()()()() | Default constructor. Creates a new, empty ERecIdList.
Public method | ERecIdList(Int64) | Obsolete. Constructor that takes a single ID and makes a record ID list with only one element.
Public method | ERecIdList(String) | Constructor that takes a string-based set of record specifications and parses and populates the list with the string.

See Also

ERecIdList Class
ERecIdList Members


ERecIdList Constructor

[image]

Endeca Presentation API
ERecIdList Constructor
ERecIdList Class See Also Send Feedback
Default constructor. Creates a new, empty ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecIdList()
Visual Basic
Public Sub New
Visual C++
public:
ERecIdList()

See Also

ERecIdList Class
ERecIdList Overload


ERecIdList Constructor (Int64)

[image]

Endeca Presentation API
ERecIdList Constructor (Int64)
ERecIdList Class See Also Send Feedback
Constructor that takes a single ID and makes a record ID list with only one element.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use a string form instead.")]
public ERecIdList(
    long erecId
)
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use a string form instead.")> _
Public Sub New ( _
    erecId As Long _
)
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use a string form instead.")]
public:
ERecIdList(
    long long erecId
)

Parameters

erecId
Type: System..::..Int64
Single record ID member of this list.

See Also

ERecIdList Class
ERecIdList Overload


ERecIdList Constructor (String)

[image]

Endeca Presentation API
ERecIdList Constructor (String)
ERecIdList Class See Also Send Feedback
Constructor that takes a string-based set of record specifications and parses and populates the list with the string.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecIdList(
    string ids
)
Visual Basic
Public Sub New ( _
    ids As String _
)
Visual C++
public:
ERecIdList(
    String^ ids
)

Parameters

ids
Type: System..::..String
Space-delimited sequence of record specifications.

Remarks

The string is expected to be a space-delimited sequence of specifications.

See Also

ERecIdList Class
ERecIdList Overload


ERecIdList Methods

[image] [image]

Endeca Presentation API
ERecIdList Methods
ERecIdList Class See Also Send Feedback

The ERecIdList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the ERecIdList.
Public method | AddERecId | Obsolete. Adds a record ID to the list.
Public method | AddERecSpec | Adds a record specification to the list.
Public method | Clear | Removes all the elements from the ERecIdList.
Public method | Contains | Determines whether an element is in the ERecIdList.
Public method | CopyTo | Copies the entire ERecIdList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecIdList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecIdList or in a portion of it.
Public method | Insert | Inserts an element into the ERecIdList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurence of a specified object from the ERecIdList.
Public method | RemoveAt | Removes the element at the specified index of the ERecIdList.
Public method | ToString | Generates the string-based representation of the list by returning a space-delimited sequence of record IDs.

See Also

ERecIdList Class


Add Method

[image]

Endeca Presentation API
ERecIdList..::..Add Method
ERecIdList Class See Also Send Feedback
Adds an object to the end of the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Int64 to be added to the end of the ERecIdList.

Return Value

The ERecIdList index at which the item has been added.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecIdList is read-only. -or- The ERecIdList has a fixed-size.

See Also

ERecIdList Class


AddERecId Method

[image]

Endeca Presentation API
ERecIdList..::..AddERecId Method
ERecIdList Class See Also Send Feedback
Adds a record ID to the list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use a AddERecSpec instead.")]
public virtual void AddERecId(
    long id
)
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use a AddERecSpec instead.")> _
Public Overridable Sub AddERecId ( _
    id As Long _
)
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use a AddERecSpec instead.")]
public:
virtual void AddERecId(
    long long id
)

Parameters

id
Type: System..::..Int64
ID to add to the list.

See Also

ERecIdList Class


AddERecSpec Method

[image]

Endeca Presentation API
ERecIdList..::..AddERecSpec Method
ERecIdList Class See Also Send Feedback
Adds a record specification to the list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddERecSpec(
    string spec
)
Visual Basic
Public Overridable Sub AddERecSpec ( _
    spec As String _
)
Visual C++
public:
virtual void AddERecSpec(
    String^ spec
)

Parameters

spec
Type: System..::..String
Specification to add to the list.

See Also

ERecIdList Class


Clear Method

[image]

Endeca Presentation API
ERecIdList..::..Clear Method
ERecIdList Class See Also Send Feedback
Removes all the elements from the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecIdList is read-only. -or- The ERecIdList has a fixed-size.

See Also

ERecIdList Class


Contains Method

[image]

Endeca Presentation API
ERecIdList..::..Contains Method
ERecIdList Class See Also Send Feedback
Determines whether an element is in the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecIdList.

Return Value

true if item is found in the ERecIdList.

Implements

IList..::..Contains(Object)

See Also

ERecIdList Class


CopyTo Method

[image]

Endeca Presentation API
ERecIdList..::..CopyTo Method
ERecIdList Class See Also Send Feedback
Copies the entire ERecIdList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecIdList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecIdList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecIdList be cast automatically to the type of the destination array.

See Also

ERecIdList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecIdList..::..GetEnumerator Method
ERecIdList Class See Also Send Feedback
Returns an enumerator for the entire ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecIdList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecIdList Class


IndexOf Method

[image]

Endeca Presentation API
ERecIdList..::..IndexOf Method
ERecIdList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecIdList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecIdList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecIdList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecIdList Class


Insert Method

[image]

Endeca Presentation API
ERecIdList..::..Insert Method
ERecIdList Class See Also Send Feedback
Inserts an element into the ERecIdList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Int64 to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecIdList is read-only. -or- The ERecIdList has a fixed-size.

See Also

ERecIdList Class


Remove Method

[image]

Endeca Presentation API
ERecIdList..::..Remove Method
ERecIdList Class See Also Send Feedback
Removes the first occurence of a specified object from the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecIdList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecIdList is read-only. -or- The ERecIdList has a fixed-size.

See Also

ERecIdList Class


RemoveAt Method

[image]

Endeca Presentation API
ERecIdList..::..RemoveAt Method
ERecIdList Class See Also Send Feedback
Removes the element at the specified index of the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The ERecIdList is read-only. -or- The ERecIdList has a fixed-size.

See Also

ERecIdList Class


ToString Method

[image]

Endeca Presentation API
ERecIdList..::..ToString Method
ERecIdList Class See Also Send Feedback
Generates the string-based representation of the list by returning a space-delimited sequence of record IDs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

Space-delimited sequence of record IDs.

See Also

ERecIdList Class


ERecIdList Properties

[image] [image]

Endeca Presentation API
ERecIdList Properties
ERecIdList Class See Also Send Feedback

The ERecIdList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecIdList.
Public property | IsFixedSize | Gets a value indicating whether the ERecIdList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecIdList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecIdList is synchronized (thread-safe).
Public property | Item | Gets or sets the Int64 at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecIdList Class


Count Property

[image]

Endeca Presentation API
ERecIdList..::..Count Property
ERecIdList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecIdList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecIdList.

Implements

ICollection..::..Count

See Also

ERecIdList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecIdList..::..IsFixedSize Property
ERecIdList Class See Also Send Feedback
Gets a value indicating whether the ERecIdList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecIdList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

ERecIdList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecIdList..::..IsReadOnly Property
ERecIdList Class See Also Send Feedback
Gets a value indicating whether the ERecIdList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecIdList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

ERecIdList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecIdList..::..IsSynchronized Property
ERecIdList Class See Also Send Feedback
Gets a value indicating whether access to the ERecIdList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecIdList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecIdList Class


Item Property

[image]

Endeca Presentation API
ERecIdList..::..Item Property
ERecIdList Class See Also Send Feedback
Gets or sets the Int64 at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The Int64 at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecIdList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecIdList..::..SyncRoot Property
ERecIdList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecIdList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecIdList Class


ERecList Class

[image]

Endeca Presentation API
ERecList Class
Members See Also Send Feedback
List of Endeca records exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecList : IList, ICollection,
    IEnumerable
Visual Basic
Public Class ERecList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecList

See Also

ERecList Members


ERecList Members

[image] [image]

Endeca Presentation API
ERecList Members
ERecList Class Methods Properties See Also Send Feedback

The ERecList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecList.
Public method | CopyTo | Copies the entire ERecList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecList.
Public property | IsFixedSize | Gets a value indicating whether the ERecList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecList is synchronized (thread-safe).
Public property | Item | Gets the ERec at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecList Class


ERecList Methods

[image] [image]

Endeca Presentation API
ERecList Methods
ERecList Class See Also Send Feedback

The ERecList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecList.
Public method | CopyTo | Copies the entire ERecList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecList Class


Add Method

[image]

Endeca Presentation API
ERecList..::..Add Method
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the ERecList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


Clear Method

[image]

Endeca Presentation API
ERecList..::..Clear Method
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


Contains Method

[image]

Endeca Presentation API
ERecList..::..Contains Method
ERecList Class See Also Send Feedback
Determines whether an element is in the ERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecList.

Return Value

true if item is found in the ERecList.

Implements

IList..::..Contains(Object)

See Also

ERecList Class


CopyTo Method

[image]

Endeca Presentation API
ERecList..::..CopyTo Method
ERecList Class See Also Send Feedback
Copies the entire ERecList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecList be cast automatically to the type of the destination array.

See Also

ERecList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecList..::..GetEnumerator Method
ERecList Class See Also Send Feedback
Returns an enumerator for the entire ERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecList Class


IndexOf Method

[image]

Endeca Presentation API
ERecList..::..IndexOf Method
ERecList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecList Class


Insert Method

[image]

Endeca Presentation API
ERecList..::..Insert Method
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


Remove Method

[image]

Endeca Presentation API
ERecList..::..Remove Method
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


RemoveAt Method

[image]

Endeca Presentation API
ERecList..::..RemoveAt Method
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


ERecList Properties

[image] [image]

Endeca Presentation API
ERecList Properties
ERecList Class See Also Send Feedback

The ERecList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecList.
Public property | IsFixedSize | Gets a value indicating whether the ERecList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecList is synchronized (thread-safe).
Public property | Item | Gets the ERec at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecList Class


Count Property

[image]

Endeca Presentation API
ERecList..::..Count Property
ERecList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecList.

Implements

ICollection..::..Count

See Also

ERecList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecList..::..IsFixedSize Property
ERecList Class See Also Send Feedback
Gets a value indicating whether the ERecList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

ERecList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecList..::..IsReadOnly Property
ERecList Class See Also Send Feedback
Gets a value indicating whether the ERecList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

ERecList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecList..::..IsSynchronized Property
ERecList Class See Also Send Feedback
Gets a value indicating whether access to the ERecList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecList Class


Item Property

[image]

Endeca Presentation API
ERecList..::..Item Property
ERecList Class See Also Send Feedback
Gets the ERec at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the ERec to get.

Field Value

The ERec at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

ERecList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecList..::..SyncRoot Property
ERecList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecList Class


ERecRank Class

[image]

Endeca Presentation API
ERecRank Class
Members See Also Send Feedback
Class representing a relevance ranking on a navigation record set.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecRank
Visual Basic
Public Class ERecRank
Visual C++
public ref class ERecRank

Remarks

A relevance ranking is composed of four elements:

  • search keyThe name of an Endeca property or dimension (if enabled for record search) or an Endeca search interface. The search key indicates which field of the records to search the terms against.
  • termsThe strings that are used to rank the records, such as raspberry flavor (which may be a quoted phrase).
  • strategyThe relevance ranking strategy to be used.
  • matchThe matchmode to be used (e.g., mode matchany). This is optional, and may be set to null. In this case, the match mode will default to matchany.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecRank

See Also

ERecRank Members


ERecRank Members

[image] [image]

Endeca Presentation API
ERecRank Members
ERecRank Class Constructors Methods Properties See Also Send Feedback

The ERecRank type exposes the following members.

Constructors

 | Name | Description
Public method | ERecRank()()()() | Default empty constructor.
Public method | ERecRank(String, String, String) | Constructor specifying the key and the terms of the search.
Public method | ERecRank(String, String, String, String) | Constructor specifying the key, terms, and options of the search.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key of this ERecRank.
Public property | MatchMode | Gets the match mode of this ERecRank
Public property | Strategy | Gets the strategy of this ERecRank
Public property | Terms | Gets the terms of this ERecRank.

See Also

ERecRank Class


ERecRank Constructor

[image] [image]

Endeca Presentation API
ERecRank Constructor
ERecRank Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ERecRank()()()() | Default empty constructor.
Public method | ERecRank(String, String, String) | Constructor specifying the key and the terms of the search.
Public method | ERecRank(String, String, String, String) | Constructor specifying the key, terms, and options of the search.

See Also

ERecRank Class
ERecRank Members


ERecRank Constructor

[image]

Endeca Presentation API
ERecRank Constructor
ERecRank Class See Also Send Feedback
Default empty constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecRank()
Visual Basic
Public Sub New
Visual C++
public:
ERecRank()

See Also

ERecRank Class
ERecRank Overload


ERecRank Constructor (String, String, String)

[image]

Endeca Presentation API
ERecRank Constructor (String, String, String)
ERecRank Class See Also Send Feedback
Constructor specifying the key and the terms of the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecRank(
    string key,
    string terms,
    string strategy
)
Visual Basic
Public Sub New ( _
    key As String, _
    terms As String, _
    strategy As String _
)
Visual C++
public:
ERecRank(
    String^ key,
    String^ terms,
    String^ strategy
)

Parameters

key
Type: System..::..String
The key (an Endeca property, dimension, or search interface) of the records with which to search.
terms
Type: System..::..String
The terms of the search.
strategy
Type: System..::..String
The ranking strategy to be used. (May be null.)

Remarks

The match mode is set to null (and thus defaults to matchany).

See Also

ERecRank Class
ERecRank Overload


ERecRank Constructor (String, String, String, String)

[image]

Endeca Presentation API
ERecRank Constructor (String, String, String, String)
ERecRank Class See Also Send Feedback
Constructor specifying the key, terms, and options of the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecRank(
    string key,
    string terms,
    string strategy,
    string match
)
Visual Basic
Public Sub New ( _
    key As String, _
    terms As String, _
    strategy As String, _
    match As String _
)
Visual C++
public:
ERecRank(
    String^ key,
    String^ terms,
    String^ strategy,
    String^ match
)

Parameters

key
Type: System..::..String
The key (an Endeca property, dimension, or search interface) of the records with which to search.
terms
Type: System..::..String
The terms of the search.
strategy
Type: System..::..String
The ranking strategy to be used. (May be null.) The match mode to be used. (May be null.)
match
Type: System..::..String

See Also

ERecRank Class
ERecRank Overload


ERecRank Methods

[image] [image]

Endeca Presentation API
ERecRank Methods
ERecRank Class See Also Send Feedback

The ERecRank type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecRank Class


ERecRank Properties

[image] [image]

Endeca Presentation API
ERecRank Properties
ERecRank Class See Also Send Feedback

The ERecRank type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key of this ERecRank.
Public property | MatchMode | Gets the match mode of this ERecRank
Public property | Strategy | Gets the strategy of this ERecRank
Public property | Terms | Gets the terms of this ERecRank.

See Also

ERecRank Class


Key Property

[image]

Endeca Presentation API
ERecRank..::..Key Property
ERecRank Class See Also Send Feedback
Gets the key of this ERecRank.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Field Value

The key (an Endeca property, dimension, or search interface) of the ERecRank.

See Also

ERecRank Class


MatchMode Property

[image]

Endeca Presentation API
ERecRank..::..MatchMode Property
ERecRank Class See Also Send Feedback
Gets the match mode of this ERecRank

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string MatchMode { get; }
Visual Basic
Public Overridable ReadOnly Property MatchMode As String
    Get
Visual C++
public:
virtual property String^ MatchMode {
    String^ get ();
}

Field Value

The match mode of the ERecRank.

See Also

ERecRank Class


Strategy Property

[image]

Endeca Presentation API
ERecRank..::..Strategy Property
ERecRank Class See Also Send Feedback
Gets the strategy of this ERecRank

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Strategy { get; }
Visual Basic
Public Overridable ReadOnly Property Strategy As String
    Get
Visual C++
public:
virtual property String^ Strategy {
    String^ get ();
}

Field Value

The strategy of the ERecRank.

See Also

ERecRank Class


Terms Property

[image]

Endeca Presentation API
ERecRank..::..Terms Property
ERecRank Class See Also Send Feedback
Gets the terms of this ERecRank.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As String
    Get
Visual C++
public:
virtual property String^ Terms {
    String^ get ();
}

Field Value

The terms of the ERecRank.

See Also

ERecRank Class


ERecRollupKey Class

[image]

Endeca Presentation API
ERecRollupKey Class
Members See Also Send Feedback
Key with which a record set can or is rolled up by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecRollupKey
Visual Basic
Public Class ERecRollupKey
Visual C++
public ref class ERecRollupKey

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecRollupKey

See Also

ERecRollupKey Members


ERecRollupKey Members

[image] [image]

Endeca Presentation API
ERecRollupKey Members
ERecRollupKey Class Methods Properties See Also Send Feedback

The ERecRollupKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this rollup key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Get the name of this rollup key.

See Also

ERecRollupKey Class


ERecRollupKey Methods

[image] [image]

Endeca Presentation API
ERecRollupKey Methods
ERecRollupKey Class See Also Send Feedback

The ERecRollupKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this rollup key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecRollupKey Class


IsActive Method

[image]

Endeca Presentation API
ERecRollupKey..::..IsActive Method
ERecRollupKey Class See Also Send Feedback
Returns whether the key is active. Returns whether this rollup key is being applied.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsActive()
Visual Basic
Public Overridable Function IsActive As Boolean
Visual C++
public:
virtual bool IsActive()

Return Value

Returns true if the key is being applied to records, and false if it is not.

See Also

ERecRollupKey Class


ERecRollupKey Properties

[image] [image]

Endeca Presentation API
ERecRollupKey Properties
ERecRollupKey Class See Also Send Feedback

The ERecRollupKey type exposes the following members.

Properties

 | Name | Description
Public property | Name | Get the name of this rollup key.

See Also

ERecRollupKey Class


Name Property

[image]

Endeca Presentation API
ERecRollupKey..::..Name Property
ERecRollupKey Class See Also Send Feedback
Get the name of this rollup key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

Name of this rollup key or null if it is not specified.

See Also

ERecRollupKey Class


ERecRollupKeyList Class

[image]

Endeca Presentation API
ERecRollupKeyList Class
Members See Also Send Feedback
Collection of record rollup keys exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecRollupKeyList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class ERecRollupKeyList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecRollupKeyList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecRollupKeyList

See Also

ERecRollupKeyList Members


ERecRollupKeyList Members

[image] [image]

Endeca Presentation API
ERecRollupKeyList Members
ERecRollupKeyList Class Methods Properties See Also Send Feedback

The ERecRollupKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecRollupKeyList.
Public method | CopyTo | Copies the entire ERecRollupKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecRollupKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets ERecRollupKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecRollupKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecRollupKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecRollupKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecRollupKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecRollupKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecRollupKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecRollupKeyList Class


ERecRollupKeyList Methods

[image] [image]

Endeca Presentation API
ERecRollupKeyList Methods
ERecRollupKeyList Class See Also Send Feedback

The ERecRollupKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecRollupKeyList.
Public method | CopyTo | Copies the entire ERecRollupKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecRollupKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets ERecRollupKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecRollupKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecRollupKeyList Class


Add Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..Add Method
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the ERecRollupKeyList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


Clear Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..Clear Method
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


Contains Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..Contains Method
ERecRollupKeyList Class See Also Send Feedback
Determines whether an element is in the ERecRollupKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecRollupKeyList.

Return Value

true if item is found in the ERecRollupKeyList.

Implements

IList..::..Contains(Object)

See Also

ERecRollupKeyList Class


CopyTo Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..CopyTo Method
ERecRollupKeyList Class See Also Send Feedback
Copies the entire ERecRollupKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecRollupKeyList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecRollupKeyList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecRollupKeyList be cast automatically to the type of the destination array.

See Also

ERecRollupKeyList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..GetEnumerator Method
ERecRollupKeyList Class See Also Send Feedback
Returns an enumerator for the entire ERecRollupKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecRollupKeyList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecRollupKeyList Class


GetKey Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..GetKey Method
ERecRollupKeyList Class See Also Send Feedback
Gets ERecRollupKey with the name name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecRollupKey GetKey(
    string name
)
Visual Basic
Public Overridable Function GetKey ( _
    name As String _
) As ERecRollupKey
Visual C++
public:
virtual ERecRollupKey^ GetKey(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the ERecRollupKey to get.

Return Value

Returns the ERecRollupKey specified with name. Returns null if key with specified name could not be found.

See Also

ERecRollupKeyList Class


IndexOf Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..IndexOf Method
ERecRollupKeyList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecRollupKeyList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecRollupKeyList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecRollupKeyList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecRollupKeyList Class


Insert Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..Insert Method
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


Remove Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..Remove Method
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecRollupKeyList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


RemoveAt Method

[image]

Endeca Presentation API
ERecRollupKeyList..::..RemoveAt Method
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


ERecRollupKeyList Properties

[image] [image]

Endeca Presentation API
ERecRollupKeyList Properties
ERecRollupKeyList Class See Also Send Feedback

The ERecRollupKeyList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecRollupKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecRollupKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecRollupKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecRollupKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecRollupKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecRollupKeyList Class


Count Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..Count Property
ERecRollupKeyList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecRollupKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecRollupKeyList.

Implements

ICollection..::..Count

See Also

ERecRollupKeyList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..IsFixedSize Property
ERecRollupKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecRollupKeyList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecRollupKeyList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

ERecRollupKeyList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..IsReadOnly Property
ERecRollupKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecRollupKeyList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecRollupKeyList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

ERecRollupKeyList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..IsSynchronized Property
ERecRollupKeyList Class See Also Send Feedback
Gets a value indicating whether access to the ERecRollupKeyList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecRollupKeyList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecRollupKeyList Class


Item Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..Item Property
ERecRollupKeyList Class See Also Send Feedback
Gets the ERecRollupKey at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The ERecRollupKey at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

ERecRollupKeyList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecRollupKeyList..::..SyncRoot Property
ERecRollupKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecRollupKeyList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecRollupKeyList Class


ERecSearch Class

[image]

Endeca Presentation API
ERecSearch Class
Members See Also Send Feedback
Class representing a search on a navigation record set.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSearch
Visual Basic
Public Class ERecSearch
Visual C++
public ref class ERecSearch

Remarks

A record search is composed of three elements:

  • search keyThe name of an Endeca property or dimension (if enabled for record search) or an Endeca search interface. The search key indicates which field of the records to search the terms against.
  • termsThe strings that are being searched, such as raspberry flavor (which may be a quoted phrase).
  • optionsThe search options, such as the search mode (e.g., mode matchany) and relevance ranking options. This element is optional and can therefore be null.

Note that ERecSearch objects are encapsulated in ERecSearchList objects when sent to or returned from the MDEX Engine.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSearch

See Also

ERecSearch Members


ERecSearch Members

[image] [image]

Endeca Presentation API
ERecSearch Members
ERecSearch Class Constructors Methods Properties See Also Send Feedback

The ERecSearch type exposes the following members.

Constructors

 | Name | Description
Public method | ERecSearch()()()() | Default empty constructor.
Public method | ERecSearch(String, String) | Constructor specifying the key and the terms of the search.
Public method | ERecSearch(String, String, String) | Constructor specifying the key, terms, and options of the search.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the key of this ERecSearch.
Public property | Opts | Gets the options of this ERecSearch
Public property | Terms | Gets the terms of this ERecSearch.

See Also

ERecSearch Class


ERecSearch Constructor

[image] [image]

Endeca Presentation API
ERecSearch Constructor
ERecSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ERecSearch()()()() | Default empty constructor.
Public method | ERecSearch(String, String) | Constructor specifying the key and the terms of the search.
Public method | ERecSearch(String, String, String) | Constructor specifying the key, terms, and options of the search.

See Also

ERecSearch Class
ERecSearch Members


ERecSearch Constructor

[image]

Endeca Presentation API
ERecSearch Constructor
ERecSearch Class See Also Send Feedback
Default empty constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSearch()
Visual Basic
Public Sub New
Visual C++
public:
ERecSearch()

See Also

ERecSearch Class
ERecSearch Overload


ERecSearch Constructor (String, String)

[image]

Endeca Presentation API
ERecSearch Constructor (String, String)
ERecSearch Class See Also Send Feedback
Constructor specifying the key and the terms of the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSearch(
    string key,
    string terms
)
Visual Basic
Public Sub New ( _
    key As String, _
    terms As String _
)
Visual C++
public:
ERecSearch(
    String^ key,
    String^ terms
)

Parameters

key
Type: System..::..String
The key (an Endeca property, dimension, or search interface) of the records with which to search.
terms
Type: System..::..String
The terms of the search.

Remarks

The search options are set to null.

See Also

ERecSearch Class
ERecSearch Overload


ERecSearch Constructor (String, String, String)

[image]

Endeca Presentation API
ERecSearch Constructor (String, String, String)
ERecSearch Class See Also Send Feedback
Constructor specifying the key, terms, and options of the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSearch(
    string key,
    string terms,
    string opts
)
Visual Basic
Public Sub New ( _
    key As String, _
    terms As String, _
    opts As String _
)
Visual C++
public:
ERecSearch(
    String^ key,
    String^ terms,
    String^ opts
)

Parameters

key
Type: System..::..String
The key (an Endeca property, dimension, or search interface) of the records with which to search.
terms
Type: System..::..String
The terms of the search.
opts
Type: System..::..String
Sequence of key/value pairs delimited by the space character.

See Also

ERecSearch Class
ERecSearch Overload


ERecSearch Methods

[image] [image]

Endeca Presentation API
ERecSearch Methods
ERecSearch Class See Also Send Feedback

The ERecSearch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSearch Class


ERecSearch Properties

[image] [image]

Endeca Presentation API
ERecSearch Properties
ERecSearch Class See Also Send Feedback

The ERecSearch type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the key of this ERecSearch.
Public property | Opts | Gets the options of this ERecSearch
Public property | Terms | Gets the terms of this ERecSearch.

See Also

ERecSearch Class


Key Property

[image]

Endeca Presentation API
ERecSearch..::..Key Property
ERecSearch Class See Also Send Feedback
Gets the key of this ERecSearch.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Field Value

The key (an Endeca property, dimension, or search interface) of the ERecSearch.

See Also

ERecSearch Class


Opts Property

[image]

Endeca Presentation API
ERecSearch..::..Opts Property
ERecSearch Class See Also Send Feedback
Gets the options of this ERecSearch

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Opts { get; }
Visual Basic
Public Overridable ReadOnly Property Opts As String
    Get
Visual C++
public:
virtual property String^ Opts {
    String^ get ();
}

Field Value

The options of the ERecSearch.

See Also

ERecSearch Class


Terms Property

[image]

Endeca Presentation API
ERecSearch..::..Terms Property
ERecSearch Class See Also Send Feedback
Gets the terms of this ERecSearch.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As String
    Get
Visual C++
public:
virtual property String^ Terms {
    String^ get ();
}

Field Value

The terms of the ERecSearch.

See Also

ERecSearch Class


ERecSearchKey Class

[image]

Endeca Presentation API
ERecSearchKey Class
Members See Also Send Feedback
Key with which a record set can be or is text searched by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSearchKey
Visual Basic
Public Class ERecSearchKey
Visual C++
public ref class ERecSearchKey

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSearchKey

See Also

ERecSearchKey Members


ERecSearchKey Members

[image] [image]

Endeca Presentation API
ERecSearchKey Members
ERecSearchKey Class Methods Properties See Also Send Feedback

The ERecSearchKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this text search key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Get the name of this text search key.

See Also

ERecSearchKey Class


ERecSearchKey Methods

[image] [image]

Endeca Presentation API
ERecSearchKey Methods
ERecSearchKey Class See Also Send Feedback

The ERecSearchKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this text search key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSearchKey Class


IsActive Method

[image]

Endeca Presentation API
ERecSearchKey..::..IsActive Method
ERecSearchKey Class See Also Send Feedback
Returns whether the key is active. Returns whether this text search key is being applied.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsActive()
Visual Basic
Public Overridable Function IsActive As Boolean
Visual C++
public:
virtual bool IsActive()

Return Value

Returns true if the key is being applied, and false if it is not.

See Also

ERecSearchKey Class


ERecSearchKey Properties

[image] [image]

Endeca Presentation API
ERecSearchKey Properties
ERecSearchKey Class See Also Send Feedback

The ERecSearchKey type exposes the following members.

Properties

 | Name | Description
Public property | Name | Get the name of this text search key.

See Also

ERecSearchKey Class


Name Property

[image]

Endeca Presentation API
ERecSearchKey..::..Name Property
ERecSearchKey Class See Also Send Feedback
Get the name of this text search key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

Name of this text search key or null if it is not specified.

See Also

ERecSearchKey Class


ERecSearchKeyList Class

[image]

Endeca Presentation API
ERecSearchKeyList Class
Members See Also Send Feedback
Collection of record search keys exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSearchKeyList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class ERecSearchKeyList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecSearchKeyList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSearchKeyList

See Also

ERecSearchKeyList Members


ERecSearchKeyList Members

[image] [image]

Endeca Presentation API
ERecSearchKeyList Members
ERecSearchKeyList Class Methods Properties See Also Send Feedback

The ERecSearchKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecSearchKeyList.
Public method | CopyTo | Copies the entire ERecSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSearchKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets ERecSearchKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecSearchKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecSearchKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSearchKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSearchKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSearchKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecSearchKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSearchKeyList Class


ERecSearchKeyList Methods

[image] [image]

Endeca Presentation API
ERecSearchKeyList Methods
ERecSearchKeyList Class See Also Send Feedback

The ERecSearchKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the ERecSearchKeyList.
Public method | CopyTo | Copies the entire ERecSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSearchKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets ERecSearchKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecSearchKeyList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSearchKeyList Class


Add Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..Add Method
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the ERecSearchKeyList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


Clear Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..Clear Method
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


Contains Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..Contains Method
ERecSearchKeyList Class See Also Send Feedback
Determines whether an element is in the ERecSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecSearchKeyList.

Return Value

true if item is found in the ERecSearchKeyList.

Implements

IList..::..Contains(Object)

See Also

ERecSearchKeyList Class


CopyTo Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..CopyTo Method
ERecSearchKeyList Class See Also Send Feedback
Copies the entire ERecSearchKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecSearchKeyList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecSearchKeyList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecSearchKeyList be cast automatically to the type of the destination array.

See Also

ERecSearchKeyList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..GetEnumerator Method
ERecSearchKeyList Class See Also Send Feedback
Returns an enumerator for the entire ERecSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecSearchKeyList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecSearchKeyList Class


GetKey Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..GetKey Method
ERecSearchKeyList Class See Also Send Feedback
Gets ERecSearchKey with the name name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSearchKey GetKey(
    string name
)
Visual Basic
Public Overridable Function GetKey ( _
    name As String _
) As ERecSearchKey
Visual C++
public:
virtual ERecSearchKey^ GetKey(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the ERecSearchKey to get.

Return Value

Returns the ERecSearchKey specified with name. Returns null if key could with name could not be found.

See Also

ERecSearchKeyList Class


IndexOf Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..IndexOf Method
ERecSearchKeyList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecSearchKeyList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecSearchKeyList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecSearchKeyList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecSearchKeyList Class


Insert Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..Insert Method
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


Remove Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..Remove Method
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecSearchKeyList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


RemoveAt Method

[image]

Endeca Presentation API
ERecSearchKeyList..::..RemoveAt Method
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


ERecSearchKeyList Properties

[image] [image]

Endeca Presentation API
ERecSearchKeyList Properties
ERecSearchKeyList Class See Also Send Feedback

The ERecSearchKeyList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecSearchKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSearchKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSearchKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSearchKeyList is synchronized (thread-safe).
Public property | Item | Gets the ERecSearchKey at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSearchKeyList Class


Count Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..Count Property
ERecSearchKeyList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecSearchKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecSearchKeyList.

Implements

ICollection..::..Count

See Also

ERecSearchKeyList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..IsFixedSize Property
ERecSearchKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecSearchKeyList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecSearchKeyList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

ERecSearchKeyList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..IsReadOnly Property
ERecSearchKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecSearchKeyList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecSearchKeyList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

ERecSearchKeyList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..IsSynchronized Property
ERecSearchKeyList Class See Also Send Feedback
Gets a value indicating whether access to the ERecSearchKeyList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecSearchKeyList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecSearchKeyList Class


Item Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..Item Property
ERecSearchKeyList Class See Also Send Feedback
Gets the ERecSearchKey at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The ERecSearchKey at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

ERecSearchKeyList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecSearchKeyList..::..SyncRoot Property
ERecSearchKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecSearchKeyList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchKeyList Class


ERecSearchList Class

[image]

Endeca Presentation API
ERecSearchList Class
Members See Also Send Feedback
Class that encapsulates a collection of ERecSearch objects, each of which represents a record search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSearchList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class ERecSearchList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecSearchList : IList,
    ICollection, IEnumerable

Remarks

ERecSearchList objects are returned from the MDEX Engine by the NavERecSearches getter property. The setter version of NavERecSearches will set an ERecSearchList list of record searches to perform on the records of a navigation query. Note that the UrlENEQuery class inherits the property from ENEQuery.

If required by an application, an ERecSearchList object can be created with the default constructor and the list can then be populated with ERecSearch objects by using the Add(Int32, Object) method.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSearchList

See Also

ERecSearchList Members


ERecSearchList Members

[image] [image]

Endeca Presentation API
ERecSearchList Members
ERecSearchList Class Constructors Methods Properties See Also Send Feedback

The ERecSearchList type exposes the following members.

Constructors

 | Name | Description
Public method | ERecSearchList | Default constructor that creates an empty list.

Methods

 | Name | Description
Public method | Add | Inserts the ERecSearch object at the specified position in this list.
Public method | Clear | Removes all the ERecSearch elements from the ERecSearchList.
Public method | Contains | Determines whether an ERecSearch is in the ERecSearchList.
Public method | CopyTo | Copies the entire ERecSearchList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSearchList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an ERecSearch in the ERecSearchList or in a portion of it.
Public method | Insert | Inserts an ERecSearch object into the ERecSearchList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the ERecSearch at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified ERecSearch object from the ERecSearchList.
Public method | RemoveAt | Removes the ERecSearch element at the specified index of the ERecSearchList.
Public method | Set | Replaces the ERecSearch at the specified position in this list with a new ERecSearch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of ERecSearch objects actually contained in the ERecSearchList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSearchList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSearchList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSearchList is synchronized (thread-safe).
Public property | Item | Gets and sets the ERecSearch at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSearchList Class


ERecSearchList Constructor

[image]

Endeca Presentation API
ERecSearchList Constructor
ERecSearchList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSearchList()
Visual Basic
Public Sub New
Visual C++
public:
ERecSearchList()

See Also

ERecSearchList Class


ERecSearchList Methods

[image] [image]

Endeca Presentation API
ERecSearchList Methods
ERecSearchList Class See Also Send Feedback

The ERecSearchList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts the ERecSearch object at the specified position in this list.
Public method | Clear | Removes all the ERecSearch elements from the ERecSearchList.
Public method | Contains | Determines whether an ERecSearch is in the ERecSearchList.
Public method | CopyTo | Copies the entire ERecSearchList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSearchList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of an ERecSearch in the ERecSearchList or in a portion of it.
Public method | Insert | Inserts an ERecSearch object into the ERecSearchList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the ERecSearch at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified ERecSearch object from the ERecSearchList.
Public method | RemoveAt | Removes the ERecSearch element at the specified index of the ERecSearchList.
Public method | Set | Replaces the ERecSearch at the specified position in this list with a new ERecSearch.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSearchList Class


Add Method

[image]

Endeca Presentation API
ERecSearchList..::..Add Method
ERecSearchList Class See Also Send Feedback
Inserts the ERecSearch object at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to add.
elementAt
Type: System..::..Object
The ERecSearch to be inserted.

Remarks

Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecSearchList Class


Clear Method

[image]

Endeca Presentation API
ERecSearchList..::..Clear Method
ERecSearchList Class See Also Send Feedback
Removes all the ERecSearch elements from the ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecSearchList is read-only. -or- The ERecSearchList has a fixed-size.

See Also

ERecSearchList Class


Contains Method

[image]

Endeca Presentation API
ERecSearchList..::..Contains Method
ERecSearchList Class See Also Send Feedback
Determines whether an ERecSearch is in the ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The ERecSearch to locate in the ERecSearchList.

Return Value

true if item is found in the ERecSearchList.

Implements

IList..::..Contains(Object)

See Also

ERecSearchList Class


CopyTo Method

[image]

Endeca Presentation API
ERecSearchList..::..CopyTo Method
ERecSearchList Class See Also Send Feedback
Copies the entire ERecSearchList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecSearchList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecSearchList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecSearchList be cast automatically to the type of the destination array.

See Also

ERecSearchList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecSearchList..::..GetEnumerator Method
ERecSearchList Class See Also Send Feedback
Returns an enumerator for the entire ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecSearchList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecSearchList Class


IndexOf Method

[image]

Endeca Presentation API
ERecSearchList..::..IndexOf Method
ERecSearchList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of an ERecSearch in the ERecSearchList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The ERecSearch to locate in the ERecSearchList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecSearchList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecSearchList Class


Insert Method

[image]

Endeca Presentation API
ERecSearchList..::..Insert Method
ERecSearchList Class See Also Send Feedback
Inserts an ERecSearch object into the ERecSearchList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The ERecSearch to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The ERecSearchList is read-only. -or- The ERecSearchList has a fixed-size.

See Also

ERecSearchList Class


Remove Method

[image] [image]

Endeca Presentation API
ERecSearchList..::..Remove Method
ERecSearchList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Int32) | Removes the ERecSearch at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified ERecSearch object from the ERecSearchList.

See Also

ERecSearchList Class
ERecSearchList Members


Remove Method (Int32)

[image]

Endeca Presentation API
ERecSearchList..::..Remove Method (Int32)
ERecSearchList Class See Also Send Feedback
Removes the ERecSearch at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Return Value

The ERecSearch previously at position index.

Remarks

Shifts any subsequent elements to the left (subtracts one from their indices).

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | index is out of range.

See Also

ERecSearchList Class
Remove Overload


Remove Method (Object)

[image]

Endeca Presentation API
ERecSearchList..::..Remove Method (Object)
ERecSearchList Class See Also Send Feedback
Removes the first occurence of a specified ERecSearch object from the ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The ERecSearch to remove from ERecSearchList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecSearchList is read-only. -or- The ERecSearchList has a fixed-size.

See Also

ERecSearchList Class
Remove Overload


RemoveAt Method

[image]

Endeca Presentation API
ERecSearchList..::..RemoveAt Method
ERecSearchList Class See Also Send Feedback
Removes the ERecSearch element at the specified index of the ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The ERecSearchList is read-only. -or- The ERecSearchList has a fixed-size.

See Also

ERecSearchList Class


Set Method

[image]

Endeca Presentation API
ERecSearchList..::..Set Method
ERecSearchList Class See Also Send Feedback
Replaces the ERecSearch at the specified position in this list with a new ERecSearch.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Set(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Function Set ( _
    index As Integer, _
    elementAt As Object _
) As Object
Visual C++
public:
virtual Object^ Set(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to set.
elementAt
Type: System..::..Object
The ERecSearch to be set.

Return Value

Returns the ERecSearch that was previously at index.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecSearchList Class


ERecSearchList Properties

[image] [image]

Endeca Presentation API
ERecSearchList Properties
ERecSearchList Class See Also Send Feedback

The ERecSearchList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of ERecSearch objects actually contained in the ERecSearchList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSearchList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSearchList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSearchList is synchronized (thread-safe).
Public property | Item | Gets and sets the ERecSearch at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSearchList Class


Count Property

[image]

Endeca Presentation API
ERecSearchList..::..Count Property
ERecSearchList Class See Also Send Feedback
Gets the number of ERecSearch objects actually contained in the ERecSearchList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of ERecSearch objects actually contained in the ERecSearchList.

Implements

ICollection..::..Count

See Also

ERecSearchList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecSearchList..::..IsFixedSize Property
ERecSearchList Class See Also Send Feedback
Gets a value indicating whether the ERecSearchList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecSearchList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

ERecSearchList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecSearchList..::..IsReadOnly Property
ERecSearchList Class See Also Send Feedback
Gets a value indicating whether the ERecSearchList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecSearchList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

ERecSearchList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecSearchList..::..IsSynchronized Property
ERecSearchList Class See Also Send Feedback
Gets a value indicating whether access to the ERecSearchList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecSearchList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecSearchList Class


Item Property

[image]

Endeca Presentation API
ERecSearchList..::..Item Property
ERecSearchList Class See Also Send Feedback
Gets and sets the ERecSearch at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The ERecSearch at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecSearchList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecSearchList..::..SyncRoot Property
ERecSearchList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecSearchList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSearchList Class


ERecSortKey Class

[image]

Endeca Presentation API
ERecSortKey Class
Members See Also Send Feedback
Key with which a record set can or is sorted by.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSortKey : IComparable
Visual Basic
Public Class ERecSortKey _
    Implements IComparable
Visual C++
public ref class ERecSortKey : IComparable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSortKey

See Also

ERecSortKey Members


ERecSortKey Members

[image] [image]

Endeca Presentation API
ERecSortKey Members
ERecSortKey Class Constructors Methods Fields Properties See Also Send Feedback

The ERecSortKey type exposes the following members.

Constructors

 | Name | Description
Public method | ERecSortKey(String) | Create a new relevance rank sort key.
Public method | ERecSortKey(String, Boolean) | Create a new alpha-numeric sort key that specifies a sort on a property and the order with which to sort with regard to that property.
Public method | ERecSortKey(String, Boolean, Double, Double) | Create a new geocode sort key that specifies a sort on a geocode property, the reference geocode and the order with which to sort with regard to that property.

Methods

 | Name | Description
Public method | CompareTo | Compares the current ERecSortKey to the specified ERecSortKeyobject.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrder | Gets the direction the sort key has been applied to record set if the sort key has been applied, is active.
Public method | GetReferenceLatitude | Gets the latitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.
Public method | GetReferenceLongitude | Gets the longitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this sort key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetGeocode | Sets the coordinates of the reference point if this is a geocode sort key.
Public method | SetOrder | Sets whether or not the sort on this key will be ascending.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ALPHA_NUM_SORT_KEY | This is a sort key for a non-Geocode typed property.
ASCENDING | Sort key application in ascending direction.
DESCENDING | Sort key application in descending direction.
GEOCODE_SORT_KEY | This is a sort key for a Geocode typed property.
NOT_ACTIVE | Sort key not applied.
RELRANK_SORT_KEY | This is a sort key for a relevance rank module.

Properties

 | Name | Description
Public property | Name | Gets the name of this sort key.
Public property | Type | Gets the type of the sort key.

See Also

ERecSortKey Class


ERecSortKey Constructor

[image] [image]

Endeca Presentation API
ERecSortKey Constructor
ERecSortKey Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ERecSortKey(String) | Create a new relevance rank sort key.
Public method | ERecSortKey(String, Boolean) | Create a new alpha-numeric sort key that specifies a sort on a property and the order with which to sort with regard to that property.
Public method | ERecSortKey(String, Boolean, Double, Double) | Create a new geocode sort key that specifies a sort on a geocode property, the reference geocode and the order with which to sort with regard to that property.

See Also

ERecSortKey Class
ERecSortKey Members


ERecSortKey Constructor (String)

[image]

Endeca Presentation API
ERecSortKey Constructor (String)
ERecSortKey Class See Also Send Feedback
Create a new relevance rank sort key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSortKey(
    string relRankModule
)
Visual Basic
Public Sub New ( _
    relRankModule As String _
)
Visual C++
public:
ERecSortKey(
    String^ relRankModule
)

Parameters

relRankModule
Type: System..::..String
The module and its parameters. Only modules that are independent of a text search may be used. Parameters may be given by following the name with '(', then comma separated parameters, then ')'. Relevance rank modules used in sort keys must be prefixed by "Endeca.", so this text will be added by this constructor if it is missing.

See Also

ERecSortKey Class
ERecSortKey Overload


ERecSortKey Constructor (String, Boolean)

[image]

Endeca Presentation API
ERecSortKey Constructor (String, Boolean)
ERecSortKey Class See Also Send Feedback
Create a new alpha-numeric sort key that specifies a sort on a property and the order with which to sort with regard to that property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSortKey(
    string name,
    bool isAscending
)
Visual Basic
Public Sub New ( _
    name As String, _
    isAscending As Boolean _
)
Visual C++
public:
ERecSortKey(
    String^ name,
    bool isAscending
)

Parameters

name
Type: System..::..String
The name to assign to the sort key.
isAscending
Type: System..::..Boolean
A bool specifying whether this sort key is ascending.

See Also

ERecSortKey Class
ERecSortKey Overload


ERecSortKey Constructor (String, Boolean, Double, Double)

[image]

Endeca Presentation API
ERecSortKey Constructor (String, Boolean, Double, Double)
ERecSortKey Class See Also Send Feedback
Create a new geocode sort key that specifies a sort on a geocode property, the reference geocode and the order with which to sort with regard to that property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSortKey(
    string name,
    bool isAscending,
    double lat,
    double lon
)
Visual Basic
Public Sub New ( _
    name As String, _
    isAscending As Boolean, _
    lat As Double, _
    lon As Double _
)
Visual C++
public:
ERecSortKey(
    String^ name,
    bool isAscending,
    double lat,
    double lon
)

Parameters

name
Type: System..::..String
The name to assign to the sort key.
isAscending
Type: System..::..Boolean
A bool specifying whether this sort key is ascending.
lat
Type: System..::..Double
The latitude of the reference point for this geocode sort key.
lon
Type: System..::..Double
The longitude of the reference point for this geocode sort key.

See Also

ERecSortKey Class
ERecSortKey Overload


ERecSortKey Fields

[image] [image]

Endeca Presentation API
ERecSortKey Fields
ERecSortKey Class See Also Send Feedback

The ERecSortKey type exposes the following members.

Fields

Name | Description
ALPHA_NUM_SORT_KEY | This is a sort key for a non-Geocode typed property.
ASCENDING | Sort key application in ascending direction.
DESCENDING | Sort key application in descending direction.
GEOCODE_SORT_KEY | This is a sort key for a Geocode typed property.
NOT_ACTIVE | Sort key not applied.
RELRANK_SORT_KEY | This is a sort key for a relevance rank module.

See Also

ERecSortKey Class


ALPHA_NUM_SORT_KEY Field

[image]

Endeca Presentation API
ERecSortKey..::..ALPHA_NUM_SORT_KEY Field
ERecSortKey Class See Also Send Feedback
This is a sort key for a non-Geocode typed property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int ALPHA_NUM_SORT_KEY
Visual Basic
Public Const ALPHA_NUM_SORT_KEY As Integer
Visual C++
public:
literal int ALPHA_NUM_SORT_KEY

See Also

ERecSortKey Class


ASCENDING Field

[image]

Endeca Presentation API
ERecSortKey..::..ASCENDING Field
ERecSortKey Class See Also Send Feedback
Sort key application in ascending direction.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int ASCENDING
Visual Basic
Public Const ASCENDING As Integer
Visual C++
public:
literal int ASCENDING

See Also

ERecSortKey Class


DESCENDING Field

[image]

Endeca Presentation API
ERecSortKey..::..DESCENDING Field
ERecSortKey Class See Also Send Feedback
Sort key application in descending direction.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static int DESCENDING
Visual Basic
Public Shared DESCENDING As Integer
Visual C++
public:
static int DESCENDING

See Also

ERecSortKey Class


GEOCODE_SORT_KEY Field

[image]

Endeca Presentation API
ERecSortKey..::..GEOCODE_SORT_KEY Field
ERecSortKey Class See Also Send Feedback
This is a sort key for a Geocode typed property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GEOCODE_SORT_KEY
Visual Basic
Public Const GEOCODE_SORT_KEY As Integer
Visual C++
public:
literal int GEOCODE_SORT_KEY

See Also

ERecSortKey Class


NOT_ACTIVE Field

[image]

Endeca Presentation API
ERecSortKey..::..NOT_ACTIVE Field
ERecSortKey Class See Also Send Feedback
Sort key not applied.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NOT_ACTIVE
Visual Basic
Public Const NOT_ACTIVE As Integer
Visual C++
public:
literal int NOT_ACTIVE

See Also

ERecSortKey Class


RELRANK_SORT_KEY Field

[image]

Endeca Presentation API
ERecSortKey..::..RELRANK_SORT_KEY Field
ERecSortKey Class See Also Send Feedback
This is a sort key for a relevance rank module.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int RELRANK_SORT_KEY
Visual Basic
Public Const RELRANK_SORT_KEY As Integer
Visual C++
public:
literal int RELRANK_SORT_KEY

See Also

ERecSortKey Class


ERecSortKey Methods

[image] [image]

Endeca Presentation API
ERecSortKey Methods
ERecSortKey Class See Also Send Feedback

The ERecSortKey type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares the current ERecSortKey to the specified ERecSortKeyobject.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrder | Gets the direction the sort key has been applied to record set if the sort key has been applied, is active.
Public method | GetReferenceLatitude | Gets the latitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.
Public method | GetReferenceLongitude | Gets the longitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Returns whether the key is active. Returns whether this sort key is being applied.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetGeocode | Sets the coordinates of the reference point if this is a geocode sort key.
Public method | SetOrder | Sets whether or not the sort on this key will be ascending.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSortKey Class


CompareTo Method

[image]

Endeca Presentation API
ERecSortKey..::..CompareTo Method
ERecSortKey Class See Also Send Feedback
Compares the current ERecSortKey to the specified ERecSortKeyobject.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int CompareTo(
    Object obj
)
Visual Basic
Public Overridable Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: System..::..Object
The object to compare with the current object.

Return Value

Returns 1 if the key of the current object is greater than the key of the sent in object. Returns -1 if the key of the current object is less than the key of the sent in object. Otherwise, this method returns the result of comparing the names of the sort keys.

Implements

IComparable..::..CompareTo(Object)

See Also

ERecSortKey Class


GetOrder Method

[image]

Endeca Presentation API
ERecSortKey..::..GetOrder Method
ERecSortKey Class See Also Send Feedback
Gets the direction the sort key has been applied to record set if the sort key has been applied, is active.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int GetOrder()
Visual Basic
Public Overridable Function GetOrder As Integer
Visual C++
public:
virtual int GetOrder()

Return Value

Returns ASCENDING if the sort key has been applied in ascending order and DESCENDING if the sort key has been applied in descending order. Returns NOT_ACTIVE if the sort key is not being applied.

See Also

ERecSortKey Class


GetReferenceLatitude Method

[image]

Endeca Presentation API
ERecSortKey..::..GetReferenceLatitude Method
ERecSortKey Class See Also Send Feedback
Gets the latitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual double GetReferenceLatitude()
Visual Basic
Public Overridable Function GetReferenceLatitude As Double
Visual C++
public:
virtual double GetReferenceLatitude()

Return Value

double - The latitude of the reference point. Positive values represent north latitude and negative values represent south latitude.

See Also

ERecSortKey Class


GetReferenceLongitude Method

[image]

Endeca Presentation API
ERecSortKey..::..GetReferenceLongitude Method
ERecSortKey Class See Also Send Feedback
Gets the longitude of the reference point for a geocode sort key. It is an error to call this method if GetType() != GEOCODE_SORT_KEY.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual double GetReferenceLongitude()
Visual Basic
Public Overridable Function GetReferenceLongitude As Double
Visual C++
public:
virtual double GetReferenceLongitude()

Return Value

double - The longitude of the reference point. Positive values represent east longitude and negative values represent west longitude.

See Also

ERecSortKey Class


IsActive Method

[image]

Endeca Presentation API
ERecSortKey..::..IsActive Method
ERecSortKey Class See Also Send Feedback
Returns whether the key is active. Returns whether this sort key is being applied.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsActive()
Visual Basic
Public Overridable Function IsActive As Boolean
Visual C++
public:
virtual bool IsActive()

Return Value

true if the key is being applied to records, and false if it is not.

See Also

ERecSortKey Class


SetGeocode Method

[image]

Endeca Presentation API
ERecSortKey..::..SetGeocode Method
ERecSortKey Class See Also Send Feedback
Sets the coordinates of the reference point if this is a geocode sort key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetGeocode(
    double lat,
    double lon
)
Visual Basic
Public Overridable Sub SetGeocode ( _
    lat As Double, _
    lon As Double _
)
Visual C++
public:
virtual void SetGeocode(
    double lat,
    double lon
)

Parameters

lat
Type: System..::..Double
The latitude to set for the reference point.
lon
Type: System..::..Double
The longitude to set for the reference point.

See Also

ERecSortKey Class


SetOrder Method

[image]

Endeca Presentation API
ERecSortKey..::..SetOrder Method
ERecSortKey Class See Also Send Feedback
Sets whether or not the sort on this key will be ascending.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetOrder(
    bool isAscending
)
Visual Basic
Public Overridable Sub SetOrder ( _
    isAscending As Boolean _
)
Visual C++
public:
virtual void SetOrder(
    bool isAscending
)

Parameters

isAscending
Type: System..::..Boolean
Boolean value to determine if the sort on this key will be ascending.

See Also

ERecSortKey Class


ERecSortKey Properties

[image] [image]

Endeca Presentation API
ERecSortKey Properties
ERecSortKey Class See Also Send Feedback

The ERecSortKey type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the name of this sort key.
Public property | Type | Gets the type of the sort key.

See Also

ERecSortKey Class


Name Property

[image]

Endeca Presentation API
ERecSortKey..::..Name Property
ERecSortKey Class See Also Send Feedback
Gets the name of this sort key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; }
Visual Basic
Public Overridable ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get ();
}

Field Value

Name of this sort key or null if it is not specified.

See Also

ERecSortKey Class


Type Property

[image]

Endeca Presentation API
ERecSortKey..::..Type Property
ERecSortKey Class See Also Send Feedback
Gets the type of the sort key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As Integer
    Get
Visual C++
public:
virtual property int Type {
    int get ();
}

Field Value

The sort key type.

See Also

ERecSortKey Class


ERecSortKeyList Class

[image]

Endeca Presentation API
ERecSortKeyList Class
Members See Also Send Feedback
Collection of record sort keys exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ERecSortKeyList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class ERecSortKeyList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ERecSortKeyList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ERecSortKeyList

See Also

ERecSortKeyList Members


ERecSortKeyList Members

[image] [image]

Endeca Presentation API
ERecSortKeyList Members
ERecSortKeyList Class Constructors Methods Properties See Also Send Feedback

The ERecSortKeyList type exposes the following members.

Constructors

 | Name | Description
Public method | ERecSortKeyList | Initializes a new instance of the ERecSortKeyList class

Methods

 | Name | Description
Public method | Add | Inserts the specified element at the specified position in this list.
Public method | Clear | Removes all the elements from the ERecSortKeyList.
Public method | Contains | Determines whether an element is in the ERecSortKeyList.
Public method | CopyTo | Copies the entire ERecSortKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSortKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the ERecSortKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecSortKeyList or in a portion of it.
Public method | Insert | Inserts an element into the ERecSortKeyList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the ERecSortKeyList.
Public method | RemoveAt | Removes the element at the specified index of the ERecSortKeyList.
Public method | Set | Replaces the element at the specified position in this list with the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecSortKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSortKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSortKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSortKeyList is synchronized (thread-safe).
Public property | Item | Gets and sets the ERecSortKey at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSortKeyList Class


ERecSortKeyList Constructor

[image]

Endeca Presentation API
ERecSortKeyList Constructor
ERecSortKeyList Class See Also Send Feedback
Initializes a new instance of the ERecSortKeyList class

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ERecSortKeyList()
Visual Basic
Public Sub New
Visual C++
public:
ERecSortKeyList()

See Also

ERecSortKeyList Class


ERecSortKeyList Methods

[image] [image]

Endeca Presentation API
ERecSortKeyList Methods
ERecSortKeyList Class See Also Send Feedback

The ERecSortKeyList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts the specified element at the specified position in this list.
Public method | Clear | Removes all the elements from the ERecSortKeyList.
Public method | Contains | Determines whether an element is in the ERecSortKeyList.
Public method | CopyTo | Copies the entire ERecSortKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire ERecSortKeyList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKey | Gets the ERecSortKey with the name name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the ERecSortKeyList or in a portion of it.
Public method | Insert | Inserts an element into the ERecSortKeyList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the ERecSortKeyList.
Public method | RemoveAt | Removes the element at the specified index of the ERecSortKeyList.
Public method | Set | Replaces the element at the specified position in this list with the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ERecSortKeyList Class


Add Method

[image]

Endeca Presentation API
ERecSortKeyList..::..Add Method
ERecSortKeyList Class See Also Send Feedback
Inserts the specified element at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to add.
elementAt
Type: System..::..Object
The element to be inserted.

Remarks

Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..ArgumentException | elementAt already exists in the list.

See Also

ERecSortKeyList Class


Clear Method

[image]

Endeca Presentation API
ERecSortKeyList..::..Clear Method
ERecSortKeyList Class See Also Send Feedback
Removes all the elements from the ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecSortKeyList is read-only. -or- The ERecSortKeyList has a fixed-size.

See Also

ERecSortKeyList Class


Contains Method

[image]

Endeca Presentation API
ERecSortKeyList..::..Contains Method
ERecSortKeyList Class See Also Send Feedback
Determines whether an element is in the ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecSortKeyList.

Return Value

true if item is found in the ERecSortKeyList.

Implements

IList..::..Contains(Object)

See Also

ERecSortKeyList Class


CopyTo Method

[image]

Endeca Presentation API
ERecSortKeyList..::..CopyTo Method
ERecSortKeyList Class See Also Send Feedback
Copies the entire ERecSortKeyList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ERecSortKeyList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source ERecSortKeyList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source ERecSortKeyList be cast automatically to the type of the destination array.

See Also

ERecSortKeyList Class


GetEnumerator Method

[image]

Endeca Presentation API
ERecSortKeyList..::..GetEnumerator Method
ERecSortKeyList Class See Also Send Feedback
Returns an enumerator for the entire ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire ERecSortKeyList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

ERecSortKeyList Class


GetKey Method

[image]

Endeca Presentation API
ERecSortKeyList..::..GetKey Method
ERecSortKeyList Class See Also Send Feedback
Gets the ERecSortKey with the name name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSortKey GetKey(
    string name
)
Visual Basic
Public Overridable Function GetKey ( _
    name As String _
) As ERecSortKey
Visual C++
public:
virtual ERecSortKey^ GetKey(
    String^ name
)

Parameters

name
Type: System..::..String
THe name of the ERecSortKey to get.

Return Value

Returns the ERecSortKey with name name. Returns null if key with specified name could not be found.

See Also

ERecSortKeyList Class


IndexOf Method

[image]

Endeca Presentation API
ERecSortKeyList..::..IndexOf Method
ERecSortKeyList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the ERecSortKeyList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the ERecSortKeyList.

Return Value

The zero-based index of the first occurrence of item within the entire ERecSortKeyList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

ERecSortKeyList Class


Insert Method

[image]

Endeca Presentation API
ERecSortKeyList..::..Insert Method
ERecSortKeyList Class See Also Send Feedback
Inserts an element into the ERecSortKeyList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The ERecSortKeyList is read-only. -or- The ERecSortKeyList has a fixed-size.

See Also

ERecSortKeyList Class


Remove Method

[image] [image]

Endeca Presentation API
ERecSortKeyList..::..Remove Method
ERecSortKeyList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the ERecSortKeyList.

See Also

ERecSortKeyList Class
ERecSortKeyList Members


Remove Method (Int32)

[image]

Endeca Presentation API
ERecSortKeyList..::..Remove Method (Int32)
ERecSortKeyList Class See Also Send Feedback
Removes the element at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Return Value

The element previously at position index.

Remarks

Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

Exceptions

Exception | Condition
System..::..IndexOutOfRangeException | index is out of range.

See Also

ERecSortKeyList Class
Remove Overload


Remove Method (Object)

[image]

Endeca Presentation API
ERecSortKeyList..::..Remove Method (Object)
ERecSortKeyList Class See Also Send Feedback
Removes the first occurence of a specified object from the ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from ERecSortKeyList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The ERecSortKeyList is read-only. -or- The ERecSortKeyList has a fixed-size.

See Also

ERecSortKeyList Class
Remove Overload


RemoveAt Method

[image]

Endeca Presentation API
ERecSortKeyList..::..RemoveAt Method
ERecSortKeyList Class See Also Send Feedback
Removes the element at the specified index of the ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The ERecSortKeyList is read-only. -or- The ERecSortKeyList has a fixed-size.

See Also

ERecSortKeyList Class


Set Method

[image]

Endeca Presentation API
ERecSortKeyList..::..Set Method
ERecSortKeyList Class See Also Send Feedback
Replaces the element at the specified position in this list with the specified element.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Set(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Function Set ( _
    index As Integer, _
    elementAt As Object _
) As Object
Visual C++
public:
virtual Object^ Set(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to set.
elementAt
Type: System..::..Object
The element to be set.

Return Value

Returns the element that was previously at index.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecSortKeyList Class


ERecSortKeyList Properties

[image] [image]

Endeca Presentation API
ERecSortKeyList Properties
ERecSortKeyList Class See Also Send Feedback

The ERecSortKeyList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the ERecSortKeyList.
Public property | IsFixedSize | Gets a value indicating whether the ERecSortKeyList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the ERecSortKeyList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ERecSortKeyList is synchronized (thread-safe).
Public property | Item | Gets and sets the ERecSortKey at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

ERecSortKeyList Class


Count Property

[image]

Endeca Presentation API
ERecSortKeyList..::..Count Property
ERecSortKeyList Class See Also Send Feedback
Gets the number of elements actually contained in the ERecSortKeyList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the ERecSortKeyList.

Implements

ICollection..::..Count

See Also

ERecSortKeyList Class


IsFixedSize Property

[image]

Endeca Presentation API
ERecSortKeyList..::..IsFixedSize Property
ERecSortKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecSortKeyList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the ERecSortKeyList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

ERecSortKeyList Class


IsReadOnly Property

[image]

Endeca Presentation API
ERecSortKeyList..::..IsReadOnly Property
ERecSortKeyList Class See Also Send Feedback
Gets a value indicating whether the ERecSortKeyList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the ERecSortKeyList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

ERecSortKeyList Class


IsSynchronized Property

[image]

Endeca Presentation API
ERecSortKeyList..::..IsSynchronized Property
ERecSortKeyList Class See Also Send Feedback
Gets a value indicating whether access to the ERecSortKeyList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the ERecSortKeyList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

ERecSortKeyList Class


Item Property

[image]

Endeca Presentation API
ERecSortKeyList..::..Item Property
ERecSortKeyList Class See Also Send Feedback
Gets and sets the ERecSortKey at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The ERecSortKey at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

ERecSortKeyList Class


SyncRoot Property

[image]

Endeca Presentation API
ERecSortKeyList..::..SyncRoot Property
ERecSortKeyList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the ERecSortKeyList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

ERecSortKeyList Class


ESearchAutoSuggestion Class

[image]

Endeca Presentation API
ESearchAutoSuggestion Class
Members See Also Send Feedback
ESearchAutoSuggestion represents a single alternate spelling suggestion made by the Endeca MDEX Engine when a record search is performed.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ESearchAutoSuggestion
Visual Basic
Public Class ESearchAutoSuggestion
Visual C++
public ref class ESearchAutoSuggestion

Remarks

A list of ESearchAutoSuggestionb> objects can be obtained by using the AutoSuggestions get property.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ESearchAutoSuggestion

See Also

ESearchAutoSuggestion Members


ESearchAutoSuggestion Members

[image] [image]

Endeca Presentation API
ESearchAutoSuggestion Members
ESearchAutoSuggestion Class Methods Properties See Also Send Feedback

The ESearchAutoSuggestion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDidSuggestionIncludeAutomaticPhrasing | Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.
Public method | GetDidSuggestionIncludeSpellingCorrection | Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDidSuggestionIncludeAutomaticPhrasing | Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.
Public method | SetDidSuggestionIncludeSpellingCorrection | Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IncludedAutomaticPhrasing | Gets and sets whether this suggestion includes terms that were auto-phrased.
Public property | IncludedSpellingCorrection | Gets and sets whether this suggestion includes terms that were spell-corrected.
Public property | Terms | Returns the terms for the spelling suggestion.

See Also

ESearchAutoSuggestion Class


ESearchAutoSuggestion Methods

[image] [image]

Endeca Presentation API
ESearchAutoSuggestion Methods
ESearchAutoSuggestion Class See Also Send Feedback

The ESearchAutoSuggestion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDidSuggestionIncludeAutomaticPhrasing | Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.
Public method | GetDidSuggestionIncludeSpellingCorrection | Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDidSuggestionIncludeAutomaticPhrasing | Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.
Public method | SetDidSuggestionIncludeSpellingCorrection | Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ESearchAutoSuggestion Class


GetDidSuggestionIncludeAutomaticPhrasing Method

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..GetDidSuggestionIncludeAutomaticPhrasing Method
ESearchAutoSuggestion Class See Also Send Feedback
Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetDidSuggestionIncludeAutomaticPhrasing()
Visual Basic
Public Function GetDidSuggestionIncludeAutomaticPhrasing As Boolean
Visual C++
public:
bool GetDidSuggestionIncludeAutomaticPhrasing()

Field Value

true if the terms were auto-phrased, or false otherwise.

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.ESearchAutoSuggestion.GetDidSuggestionIncludeAutomaticPhrasing"]

Remarks

This method is useful if the application developer wants to know what features engaged in the MDEX Engine when generating a suggestion.

See Also

ESearchAutoSuggestion Class


GetDidSuggestionIncludeSpellingCorrection Method

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..GetDidSuggestionIncludeSpellingCorrection Method
ESearchAutoSuggestion Class See Also Send Feedback
Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetDidSuggestionIncludeSpellingCorrection()
Visual Basic
Public Function GetDidSuggestionIncludeSpellingCorrection As Boolean
Visual C++
public:
bool GetDidSuggestionIncludeSpellingCorrection()

Field Value

true if the terms were spell-corrected, or false otherwise.

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.ESearchAutoSuggestion.GetDidSuggestionIncludeSpellingCorrection"]

Remarks

This method is useful if the application developer wants to know what features engaged in the MDEX Engine when generating a suggestion.

See Also

ESearchAutoSuggestion Class


SetDidSuggestionIncludeAutomaticPhrasing Method

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..SetDidSuggestionIncludeAutomaticPhrasing Method
ESearchAutoSuggestion Class See Also Send Feedback
Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void SetDidSuggestionIncludeAutomaticPhrasing(
    bool _includedAutophrase
)
Visual Basic
Public Sub SetDidSuggestionIncludeAutomaticPhrasing ( _
    _includedAutophrase As Boolean _
)
Visual C++
public:
void SetDidSuggestionIncludeAutomaticPhrasing(
    bool _includedAutophrase
)

Parameters

_includedAutophrase
Type: System..::..Boolean
true if the terms were auto-phrased, or false otherwise.

See Also

ESearchAutoSuggestion Class


SetDidSuggestionIncludeSpellingCorrection Method

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..SetDidSuggestionIncludeSpellingCorrection Method
ESearchAutoSuggestion Class See Also Send Feedback
Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void SetDidSuggestionIncludeSpellingCorrection(
    bool _includedSpelling
)
Visual Basic
Public Sub SetDidSuggestionIncludeSpellingCorrection ( _
    _includedSpelling As Boolean _
)
Visual C++
public:
void SetDidSuggestionIncludeSpellingCorrection(
    bool _includedSpelling
)

Parameters

_includedSpelling
Type: System..::..Boolean
true if the terms were spell-corrected, or false otherwise.

See Also

ESearchAutoSuggestion Class


ESearchAutoSuggestion Properties

[image] [image]

Endeca Presentation API
ESearchAutoSuggestion Properties
ESearchAutoSuggestion Class See Also Send Feedback

The ESearchAutoSuggestion type exposes the following members.

Properties

 | Name | Description
Public property | IncludedAutomaticPhrasing | Gets and sets whether this suggestion includes terms that were auto-phrased.
Public property | IncludedSpellingCorrection | Gets and sets whether this suggestion includes terms that were spell-corrected.
Public property | Terms | Returns the terms for the spelling suggestion.

See Also

ESearchAutoSuggestion Class


IncludedAutomaticPhrasing Property

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..IncludedAutomaticPhrasing Property
ESearchAutoSuggestion Class See Also Send Feedback
Gets and sets whether this suggestion includes terms that were auto-phrased.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IncludedAutomaticPhrasing { get; set; }
Visual Basic
Public Overridable Property IncludedAutomaticPhrasing As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IncludedAutomaticPhrasing {
    bool get ();
    void set (bool value);
}

Field Value

true if the terms were auto-phrased, or false otherwise.

See Also

ESearchAutoSuggestion Class


IncludedSpellingCorrection Property

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..IncludedSpellingCorrection Property
ESearchAutoSuggestion Class See Also Send Feedback
Gets and sets whether this suggestion includes terms that were spell-corrected.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IncludedSpellingCorrection { get; set; }
Visual Basic
Public Overridable Property IncludedSpellingCorrection As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IncludedSpellingCorrection {
    bool get ();
    void set (bool value);
}

Field Value

true if the terms were spell-corrected, or false otherwise.

See Also

ESearchAutoSuggestion Class


Terms Property

[image]

Endeca Presentation API
ESearchAutoSuggestion..::..Terms Property
ESearchAutoSuggestion Class See Also Send Feedback
Returns the terms for the spelling suggestion.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As String
    Get
Visual C++
public:
virtual property String^ Terms {
    String^ get ();
}

Field Value

The terms for the spelling suggestion.

See Also

ESearchAutoSuggestion Class


ESearchDYMSuggestion Class

[image]

Endeca Presentation API
ESearchDYMSuggestion Class
Members See Also Send Feedback
ESearchDYMSuggestion represents a single alternate spelling suggestion made by the Endeca MDEX Engine when a text search is performed.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ESearchDYMSuggestion
Visual Basic
Public Class ESearchDYMSuggestion
Visual C++
public ref class ESearchDYMSuggestion

Remarks

A list of ESearchDYMSuggestionb> objects can be obtained by using the DYMSuggestions get property.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ESearchDYMSuggestion

See Also

ESearchDYMSuggestion Members


ESearchDYMSuggestion Members

[image] [image]

Endeca Presentation API
ESearchDYMSuggestion Members
ESearchDYMSuggestion Class Methods Properties See Also Send Feedback

The ESearchDYMSuggestion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDidSuggestionIncludeAutomaticPhrasing | Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.
Public method | GetDidSuggestionIncludeSpellingCorrection | Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDidSuggestionIncludeAutomaticPhrasing | Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.
Public method | SetDidSuggestionIncludeSpellingCorrection | Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IncludedAutomaticPhrasing | Gets and sets whether this suggestion includes terms that were auto-phrased.
Public property | IncludedSpellingCorrection | Gets and sets whether this suggestion includes terms that were spell-corrected.
Public property | NumMatchingResults | Returns the number of results that will match if this suggestion is used in a search.
Public property | Terms | Returns the terms for the spelling suggestion

See Also

ESearchDYMSuggestion Class


ESearchDYMSuggestion Methods

[image] [image]

Endeca Presentation API
ESearchDYMSuggestion Methods
ESearchDYMSuggestion Class See Also Send Feedback

The ESearchDYMSuggestion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDidSuggestionIncludeAutomaticPhrasing | Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.
Public method | GetDidSuggestionIncludeSpellingCorrection | Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDidSuggestionIncludeAutomaticPhrasing | Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.
Public method | SetDidSuggestionIncludeSpellingCorrection | Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ESearchDYMSuggestion Class


GetDidSuggestionIncludeAutomaticPhrasing Method

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..GetDidSuggestionIncludeAutomaticPhrasing Method
ESearchDYMSuggestion Class See Also Send Feedback
Determines whether this suggestion includes one or more contiguous subsequences of terms that were phrased by the Automatic Phrasing feature of the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetDidSuggestionIncludeAutomaticPhrasing()
Visual Basic
Public Function GetDidSuggestionIncludeAutomaticPhrasing As Boolean
Visual C++
public:
bool GetDidSuggestionIncludeAutomaticPhrasing()

Field Value

true if the terms were auto-phrased, or false otherwise.

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.ESearchDYMSuggestion.GetDidSuggestionIncludeAutomaticPhrasing"]

Remarks

This method is useful if the application developer wants to know what features engaged in the MDEX Engine when generating a suggestion.

See Also

ESearchDYMSuggestion Class


GetDidSuggestionIncludeSpellingCorrection Method

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..GetDidSuggestionIncludeSpellingCorrection Method
ESearchDYMSuggestion Class See Also Send Feedback
Determines whether this suggestion includes one or more terms that were spell-corrected by the Spelling Correction feature of the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetDidSuggestionIncludeSpellingCorrection()
Visual Basic
Public Function GetDidSuggestionIncludeSpellingCorrection As Boolean
Visual C++
public:
bool GetDidSuggestionIncludeSpellingCorrection()

Field Value

true if the terms were spell-corrected, or false otherwise.

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.ESearchDYMSuggestion.GetDidSuggestionIncludeSpellingCorrection"]

Remarks

This method is useful if the application developer wants to know what features engaged in the MDEX Engine when generating a suggestion.

See Also

ESearchDYMSuggestion Class


SetDidSuggestionIncludeAutomaticPhrasing Method

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..SetDidSuggestionIncludeAutomaticPhrasing Method
ESearchDYMSuggestion Class See Also Send Feedback
Sets a Boolean value as to whether this suggestion includes terms that were auto-phrased.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void SetDidSuggestionIncludeAutomaticPhrasing(
    bool _includedAutophrase
)
Visual Basic
Public Sub SetDidSuggestionIncludeAutomaticPhrasing ( _
    _includedAutophrase As Boolean _
)
Visual C++
public:
void SetDidSuggestionIncludeAutomaticPhrasing(
    bool _includedAutophrase
)

Parameters

_includedAutophrase
Type: System..::..Boolean
true if the terms were auto-phrased, or false otherwise.

See Also

ESearchDYMSuggestion Class


SetDidSuggestionIncludeSpellingCorrection Method

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..SetDidSuggestionIncludeSpellingCorrection Method
ESearchDYMSuggestion Class See Also Send Feedback
Sets a Boolean value as to whether this suggestion includes terms that were spell-corrected.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void SetDidSuggestionIncludeSpellingCorrection(
    bool _includedSpelling
)
Visual Basic
Public Sub SetDidSuggestionIncludeSpellingCorrection ( _
    _includedSpelling As Boolean _
)
Visual C++
public:
void SetDidSuggestionIncludeSpellingCorrection(
    bool _includedSpelling
)

Parameters

_includedSpelling
Type: System..::..Boolean
true if the terms were spell-corrected, or false otherwise.

See Also

ESearchDYMSuggestion Class


ESearchDYMSuggestion Properties

[image] [image]

Endeca Presentation API
ESearchDYMSuggestion Properties
ESearchDYMSuggestion Class See Also Send Feedback

The ESearchDYMSuggestion type exposes the following members.

Properties

 | Name | Description
Public property | IncludedAutomaticPhrasing | Gets and sets whether this suggestion includes terms that were auto-phrased.
Public property | IncludedSpellingCorrection | Gets and sets whether this suggestion includes terms that were spell-corrected.
Public property | NumMatchingResults | Returns the number of results that will match if this suggestion is used in a search.
Public property | Terms | Returns the terms for the spelling suggestion

See Also

ESearchDYMSuggestion Class


IncludedAutomaticPhrasing Property

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..IncludedAutomaticPhrasing Property
ESearchDYMSuggestion Class See Also Send Feedback
Gets and sets whether this suggestion includes terms that were auto-phrased.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IncludedAutomaticPhrasing { get; set; }
Visual Basic
Public Overridable Property IncludedAutomaticPhrasing As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IncludedAutomaticPhrasing {
    bool get ();
    void set (bool value);
}

Field Value

true if the terms were auto-phrased, or false otherwise.

See Also

ESearchDYMSuggestion Class


IncludedSpellingCorrection Property

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..IncludedSpellingCorrection Property
ESearchDYMSuggestion Class See Also Send Feedback
Gets and sets whether this suggestion includes terms that were spell-corrected.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IncludedSpellingCorrection { get; set; }
Visual Basic
Public Overridable Property IncludedSpellingCorrection As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IncludedSpellingCorrection {
    bool get ();
    void set (bool value);
}

Field Value

true if the terms were spell-corrected, or false otherwise.

See Also

ESearchDYMSuggestion Class


NumMatchingResults Property

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..NumMatchingResults Property
ESearchDYMSuggestion Class See Also Send Feedback
Returns the number of results that will match if this suggestion is used in a search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NumMatchingResults { get; }
Visual Basic
Public Overridable ReadOnly Property NumMatchingResults As Long
    Get
Visual C++
public:
virtual property long long NumMatchingResults {
    long long get ();
}

Field Value

The number of results that will match when using this suggestion.

See Also

ESearchDYMSuggestion Class


Terms Property

[image]

Endeca Presentation API
ESearchDYMSuggestion..::..Terms Property
ESearchDYMSuggestion Class See Also Send Feedback
Returns the terms for the spelling suggestion

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As String
    Get
Visual C++
public:
virtual property String^ Terms {
    String^ get ();
}

Field Value

The terms for the spelling suggestion

See Also

ESearchDYMSuggestion Class


ESearchReport Class

[image]

Endeca Presentation API
ESearchReport Class
Members See Also Send Feedback
ESearchReport objects contain detailed information about record searches.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ESearchReport
Visual Basic
Public Class ESearchReport
Visual C++
public ref class ESearchReport

Remarks

Use ESearchReports to obtain an IDictionary of ESearchReport objects.

A single ESearchReport object contains information about a single search key. If a query is submitted to the Endeca MDEX Engine with multiple keys, ESearchReports will return an IDictionary that contains an ESearchReport for each search key that was submitted.

For example, in this query:

CopyC#
N=0&Ntk=Name|Flavors&Ntt=merlot|fuity
the resulting IDictionary will have two entries: one for the Name search key and one for the Flavors search key.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ESearchReport

See Also

ESearchReport Members


ESearchReport Members

[image] [image]

Endeca Presentation API
ESearchReport Members
ESearchReport Class Methods Fields Properties See Also Send Feedback

The ESearchReport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isValid | Determines if the search was a valid search.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MODE_ALL | Match all user search terms (i.e., perform a conjunctive search). This is the default mode.
MODE_ALL_ANY | Match all user search terms if possible, otherwise match at least one.
MODE_ALL_PARTIAL | Match all user search terms if possible, otherwise match some.
MODE_ANY | Match at least one user search term.
MODE_BOOLEAN | Match using a Boolean query.
MODE_PARTIAL | Match some user search terms.
MODE_PARTIAL_MAX | Match a maximal subset of user search terms.
MODE_UNKNOWN | The mode is unknown.

Properties

 | Name | Description
Public property | AutoSuggestions | Returns the list of automatic spelling corrections and/or alternative phrasing suggestions made by the Endeca MDEX Engine.
Public property | DYMSuggestions | Returns the list of "Did You Mean" suggestions made by the MDEX Engine
Public property | ErrorMessage | Returns the MDEX Engine's error message if the search was not valid.
Public property | Key | Gets the name of the Endeca Dimension or Property key used in the search.
Public property | MatchedMode | Returns the matched search mode that was selected by the MDEX Engine.
Public property | NumMatchedTerms | Returns the number of search terms that were sucessfully matched when the search was performed.
Public property | NumMatchingResults | Returns the number of records that matched the search.
Public property | SearchMode | Gets the requested search mode used in the search.
Public property | Terms | Gets the terms specified in the search.
Public property | TruncatedTerms | Returns a set of search terms after truncation.
Public property | WordInterps | Returns the word interpretations for the record search.

See Also

ESearchReport Class


ESearchReport Fields

[image] [image]

Endeca Presentation API
ESearchReport Fields
ESearchReport Class See Also Send Feedback

The ESearchReport type exposes the following members.

Fields

Name | Description
MODE_ALL | Match all user search terms (i.e., perform a conjunctive search). This is the default mode.
MODE_ALL_ANY | Match all user search terms if possible, otherwise match at least one.
MODE_ALL_PARTIAL | Match all user search terms if possible, otherwise match some.
MODE_ANY | Match at least one user search term.
MODE_BOOLEAN | Match using a Boolean query.
MODE_PARTIAL | Match some user search terms.
MODE_PARTIAL_MAX | Match a maximal subset of user search terms.
MODE_UNKNOWN | The mode is unknown.

See Also

ESearchReport Class


MODE_ALL Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_ALL Field
ESearchReport Class See Also Send Feedback
Match all user search terms (i.e., perform a conjunctive search). This is the default mode.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_ALL
Visual Basic
Public Shared ReadOnly MODE_ALL As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_ALL

See Also

ESearchReport Class


MODE_ALL_ANY Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_ALL_ANY Field
ESearchReport Class See Also Send Feedback
Match all user search terms if possible, otherwise match at least one.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_ALL_ANY
Visual Basic
Public Shared ReadOnly MODE_ALL_ANY As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_ALL_ANY

See Also

ESearchReport Class


MODE_ALL_PARTIAL Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_ALL_PARTIAL Field
ESearchReport Class See Also Send Feedback
Match all user search terms if possible, otherwise match some.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_ALL_PARTIAL
Visual Basic
Public Shared ReadOnly MODE_ALL_PARTIAL As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_ALL_PARTIAL

See Also

ESearchReport Class


MODE_ANY Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_ANY Field
ESearchReport Class See Also Send Feedback
Match at least one user search term.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_ANY
Visual Basic
Public Shared ReadOnly MODE_ANY As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_ANY

See Also

ESearchReport Class


MODE_BOOLEAN Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_BOOLEAN Field
ESearchReport Class See Also Send Feedback
Match using a Boolean query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_BOOLEAN
Visual Basic
Public Shared ReadOnly MODE_BOOLEAN As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_BOOLEAN

See Also

ESearchReport Class


MODE_PARTIAL Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_PARTIAL Field
ESearchReport Class See Also Send Feedback
Match some user search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_PARTIAL
Visual Basic
Public Shared ReadOnly MODE_PARTIAL As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_PARTIAL

See Also

ESearchReport Class


MODE_PARTIAL_MAX Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_PARTIAL_MAX Field
ESearchReport Class See Also Send Feedback
Match a maximal subset of user search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_PARTIAL_MAX
Visual Basic
Public Shared ReadOnly MODE_PARTIAL_MAX As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_PARTIAL_MAX

See Also

ESearchReport Class


MODE_UNKNOWN Field

[image]

Endeca Presentation API
ESearchReport..::..MODE_UNKNOWN Field
ESearchReport Class See Also Send Feedback
The mode is unknown.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ESearchReport..::..Mode MODE_UNKNOWN
Visual Basic
Public Shared ReadOnly MODE_UNKNOWN As ESearchReport..::..Mode
Visual C++
public:
static initonly ESearchReport..::..Mode^ MODE_UNKNOWN

See Also

ESearchReport Class


ESearchReport Methods

[image] [image]

Endeca Presentation API
ESearchReport Methods
ESearchReport Class See Also Send Feedback

The ESearchReport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | isValid | Determines if the search was a valid search.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ESearchReport Class


isValid Method

[image]

Endeca Presentation API
ESearchReport..::..isValid Method
ESearchReport Class See Also Send Feedback
Determines if the search was a valid search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool isValid()
Visual Basic
Public Overridable Function isValid As Boolean
Visual C++
public:
virtual bool isValid()

Field Value

true if the search was a valid search, false otherwise

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.ESearchReport.isValid"]

Remarks

If false is returned, check the value of ErrorMessage for a description of the error.

See Also

ESearchReport Class


ESearchReport Properties

[image] [image]

Endeca Presentation API
ESearchReport Properties
ESearchReport Class See Also Send Feedback

The ESearchReport type exposes the following members.

Properties

 | Name | Description
Public property | AutoSuggestions | Returns the list of automatic spelling corrections and/or alternative phrasing suggestions made by the Endeca MDEX Engine.
Public property | DYMSuggestions | Returns the list of "Did You Mean" suggestions made by the MDEX Engine
Public property | ErrorMessage | Returns the MDEX Engine's error message if the search was not valid.
Public property | Key | Gets the name of the Endeca Dimension or Property key used in the search.
Public property | MatchedMode | Returns the matched search mode that was selected by the MDEX Engine.
Public property | NumMatchedTerms | Returns the number of search terms that were sucessfully matched when the search was performed.
Public property | NumMatchingResults | Returns the number of records that matched the search.
Public property | SearchMode | Gets the requested search mode used in the search.
Public property | Terms | Gets the terms specified in the search.
Public property | TruncatedTerms | Returns a set of search terms after truncation.
Public property | WordInterps | Returns the word interpretations for the record search.

See Also

ESearchReport Class


AutoSuggestions Property

[image]

Endeca Presentation API
ESearchReport..::..AutoSuggestions Property
ESearchReport Class See Also Send Feedback
Returns the list of automatic spelling corrections and/or alternative phrasing suggestions made by the Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IList AutoSuggestions { get; }
Visual Basic
Public Overridable ReadOnly Property AutoSuggestions As IList
    Get
Visual C++
public:
virtual property IList^ AutoSuggestions {
    IList^ get ();
}

Field Value

A list of ESearchAutoSuggestion objects, each of which contains a single spelling or phrased suggestion. If there are no suggestions, the list will be empty.

Remarks

Alternative phrasing suggestions are used by the MDEX Engine as the query to compute the set of matching documents returned instead of the user's original search query. Alternative phrasing suggestions can be returned under one of the following scenarios:

  • The MDEX Engine's Automatic Spelling Correction feature is enabled with the Dgraph --spl command line flag.
  • Alternative phrasing suggestions are requested using the NavERecSearchComputeAlternativePhrasings setter property AND the NavERecSearchRewriteQueryWithAnAlternativePhrasing setter property is used to request that the MDEX Engine rewrite the query using one of the alternatives it has computed.
  • Both of the previous two conditions are met. In this case, the alternative phrasing suggestions returned will incorporate both Spelling Correction and Automatic Phrasing.

An example of having both Spelling Correction and Automatic Phrasing is if a user's query of:

CopyC#
QUERY[New Yorkk restaurants]
is rewritten to an alternative phrasing suggestion of:
CopyC#
QUERY["New York" restaurants]
 Here the term "Yorkk" was spell-corrected to "York" and the resulting terms "New" and "York" were suggested to be phrased by the Endeca MDEX Engine as "New York". Only those suggestions that, when issued as queries, would return one or more records (before any navigation filters are applied) will be returned.

See Also

ESearchReport Class


DYMSuggestions Property

[image]

Endeca Presentation API
ESearchReport..::..DYMSuggestions Property
ESearchReport Class See Also Send Feedback
Returns the list of "Did You Mean" suggestions made by the MDEX Engine

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IList DYMSuggestions { get; }
Visual Basic
Public Overridable ReadOnly Property DYMSuggestions As IList
    Get
Visual C++
public:
virtual property IList^ DYMSuggestions {
    IList^ get ();
}

Field Value

A list of ESearchDYMSuggestion objects. If there are no suggestions, the list will be empty.

Remarks

"Did You Mean" suggestions can be returned under the following scenarios:

  • The MDEX Engine's DYM feature is enabled with the Dgraph --dym command line flag.
  • Alternative phrasing suggestions are requested using the NavERecSearchComputeAlternativePhrasings setter property.
  • Both of the previous two conditions are met. In this case, the DYM suggestions returned will incorporate both Spelling Correction and Automatic Phrasing.

An example of having both Spelling Correction and Automatic Phrasing is if a user's query of:

CopyC#
QUERY[New Yorkk restaurants]
is rewritten to an alternative phrasing suggestion of:
CopyC#
QUERY["New York" restaurants]
 Here the term "Yorkk" was spell-corrected to "York" and the resulting terms "New" and "York" were suggested to be phrased by the Endeca MDEX Engine as "New York". Only those suggestions that, when issued as queries, would return one or more records (before any navigation filters are applied) will be returned.

See Also

ESearchReport Class


ErrorMessage Property

[image]

Endeca Presentation API
ESearchReport..::..ErrorMessage Property
ESearchReport Class See Also Send Feedback
Returns the MDEX Engine's error message if the search was not valid.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ErrorMessage { get; }
Visual Basic
Public Overridable ReadOnly Property ErrorMessage As String
    Get
Visual C++
public:
virtual property String^ ErrorMessage {
    String^ get ();
}

Field Value

A string representing the error message, or null if there is no error.

See Also

ESearchReport Class


Key Property

[image]

Endeca Presentation API
ESearchReport..::..Key Property
ESearchReport Class See Also Send Feedback
Gets the name of the Endeca Dimension or Property key used in the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Field Value

The name of the search key, or null if no key has been specified.

Remarks

Corresponds to the Ntk parameter of a UrlENEQuery.

See Also

ESearchReport Class


MatchedMode Property

[image]

Endeca Presentation API
ESearchReport..::..MatchedMode Property
ESearchReport Class See Also Send Feedback
Returns the matched search mode that was selected by the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ESearchReport..::..Mode MatchedMode { get; }
Visual Basic
Public Overridable ReadOnly Property MatchedMode As ESearchReport..::..Mode
    Get
Visual C++
public:
virtual property ESearchReport..::..Mode^ MatchedMode {
    ESearchReport..::..Mode^ get ();
}

Field Value

The match mode selected by the MDEX Engine.

Remarks

MatchedMode is different from SearchMode in that MatchedMode returns the match mode that was actually selected by the MDEX Engine, as opposed to the match mode that was requested in the query.

For example, assume that this query was issued to the MDEX Engine:

CopyC#
N=0&Ntk=all&Ntt=merlot+blackberry&Ntx=mode+matchallany

The query is searching for the terms merlot and blackberry and is requesting the match mode of MODE_ALL_ANY. This search mode will first attempt to perform a search that matches all of the terms; failing that, it will then perform a search that matches any of the terms. Assuming there are no occurrences of blackberry, the resulting match mode will be MODE_ANY.

See Also

ESearchReport Class


NumMatchedTerms Property

[image]

Endeca Presentation API
ESearchReport..::..NumMatchedTerms Property
ESearchReport Class See Also Send Feedback
Returns the number of search terms that were sucessfully matched when the search was performed.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NumMatchedTerms { get; }
Visual Basic
Public Overridable ReadOnly Property NumMatchedTerms As Long
    Get
Visual C++
public:
virtual property long long NumMatchedTerms {
    long long get ();
}

Field Value

The number of terms that matched.

Remarks

Note that the number of matched terms may be different than the number of terms returned from Terms if the search mode was MODE_ALL.

See Also

ESearchReport Class


NumMatchingResults Property

[image]

Endeca Presentation API
ESearchReport..::..NumMatchingResults Property
ESearchReport Class See Also Send Feedback
Returns the number of records that matched the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long NumMatchingResults { get; }
Visual Basic
Public Overridable ReadOnly Property NumMatchingResults As Long
    Get
Visual C++
public:
virtual property long long NumMatchingResults {
    long long get ();
}

Field Value

The number of records that matched the search.

Remarks

Corresponds to the TotalNumERecs property.

See Also

ESearchReport Class


SearchMode Property

[image]

Endeca Presentation API
ESearchReport..::..SearchMode Property
ESearchReport Class See Also Send Feedback
Gets the requested search mode used in the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ESearchReport..::..Mode SearchMode { get; }
Visual Basic
Public Overridable ReadOnly Property SearchMode As ESearchReport..::..Mode
    Get
Visual C++
public:
virtual property ESearchReport..::..Mode^ SearchMode {
    ESearchReport..::..Mode^ get ();
}

Field Value

The search mode that was requested when the search was performed. Defaults to MODE_ALL.

Remarks

Corresponds to the Ntx parameter of a UrlENEQuery.

See Also

ESearchReport Class


Terms Property

[image]

Endeca Presentation API
ESearchReport..::..Terms Property
ESearchReport Class See Also Send Feedback
Gets the terms specified in the search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Terms { get; }
Visual Basic
Public Overridable ReadOnly Property Terms As String
    Get
Visual C++
public:
virtual property String^ Terms {
    String^ get ();
}

Field Value

The search terms, or null if none is returned.

Remarks

Corresponds to the Ntt parameter of a UrlENEQuery.

See Also

ESearchReport Class


TruncatedTerms Property

[image]

Endeca Presentation API
ESearchReport..::..TruncatedTerms Property
ESearchReport Class See Also Send Feedback
Returns a set of search terms after truncation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string TruncatedTerms { get; }
Visual Basic
Public Overridable ReadOnly Property TruncatedTerms As String
    Get
Visual C++
public:
virtual property String^ TruncatedTerms {
    String^ get ();
}

Field Value

A string representing the truncated search terms, or null if no truncation was performed.

Remarks

If the number of search terms is too large, the MDEX Engine will truncate the query for performance reasons. TruncatedTerms returns the new set of search terms after the MDEX Engine has peformed the truncation. If no truncation was performed, returns null.

See Also

ESearchReport Class


WordInterps Property

[image]

Endeca Presentation API
ESearchReport..::..WordInterps Property
ESearchReport Class See Also Send Feedback
Returns the word interpretations for the record search.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap WordInterps { get; }
Visual Basic
Public Overridable ReadOnly Property WordInterps As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ WordInterps {
    PropertyMap^ get ();
}

Field Value

A PropertyMap representing the set of work interpretations.

Remarks

A word interpretation is the treatment of one or more query terms as some other terms during search processing. For example, assume the index contains the following thesaurus entry:
CopyC#
cab > cabernet

If a search is performed for the term cab and there is a match for cabernet, a single word interpretation will be returned with the key cab and a value of cabernet.

In the Automatic Phrasing feature, for each contiguous subsequence of query terms that was treated as a quoted phrase during search processing, a word interpretation will be returned with the original query terms as the key and the query terms in double quotes as the value.

Note that the MDEX Engine's --wordinterp flag must be used to obtain any results from WordInterps.

See Also

ESearchReport Class


ESearchReport.Mode Class

[image]

Endeca Presentation API
ESearchReport..::..Mode Class
ESearchReport Class Members See Also Send Feedback
Enumeration of Endeca search modes.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public sealed class Mode
Visual Basic
Public NotInheritable Class Mode
Visual C++
public ref class Mode sealed

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ESearchReport..::..Mode

See Also

ESearchReport..::..Mode Members


ESearchReport.Mode Members

[image] [image]

Endeca Presentation API
ESearchReport..::..Mode Members
ESearchReport..::..Mode Class Constructors Methods See Also Send Feedback

ESearchReport objects contain detailed information about record searches.

The ESearchReport..::..Mode type exposes the following members.

Constructors

 | Name | Description
Public method | ESearchReport..::..Mode | Initializes a new instance of the ESearchReport..::..Mode class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ESearchReport..::..Mode Class


ESearchReport.Mode Constructor

[image]

Endeca Presentation API
ESearchReport..::..Mode Constructor
ESearchReport..::..Mode Class See Also Send Feedback
Initializes a new instance of the ESearchReport..::..Mode class

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Mode()
Visual Basic
Public Sub New
Visual C++
public:
Mode()

See Also

ESearchReport..::..Mode Class


ESearchReport.Mode Methods

[image] [image]

Endeca Presentation API
ESearchReport..::..Mode Methods
ESearchReport..::..Mode Class See Also Send Feedback

The ESearchReport..::..Mode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ESearchReport..::..Mode Class


ETInstrumentor Class

[image]

Endeca Presentation API
ETInstrumentor Class
Members See Also Send Feedback
Class that instruments HTML pages for use with the Web-based tools package.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ETInstrumentor
Visual Basic
Public Class ETInstrumentor
Visual C++
public ref class ETInstrumentor

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ETInstrumentor

See Also

ETInstrumentor Members


ETInstrumentor Members

[image] [image]

Endeca Presentation API
ETInstrumentor Members
ETInstrumentor Class Constructors Methods See Also Send Feedback

The ETInstrumentor type exposes the following members.

Constructors

 | Name | Description
Public method | ETInstrumentor | Constructs a new ETInstrumentor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HtmlInstrumentNavigation | Instrument an HTML navigation page with hidden forms that act as hooks to work with the Web tools package.
Public method | HtmlInstrumentRecord | Instruments an HTML record page with hidden forms that act as hooks to work with the Web tools package.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ETInstrumentor Class


ETInstrumentor Constructor

[image]

Endeca Presentation API
ETInstrumentor Constructor
ETInstrumentor Class See Also Send Feedback
Constructs a new ETInstrumentor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ETInstrumentor()
Visual Basic
Public Sub New
Visual C++
public:
ETInstrumentor()

See Also

ETInstrumentor Class


ETInstrumentor Methods

[image] [image]

Endeca Presentation API
ETInstrumentor Methods
ETInstrumentor Class See Also Send Feedback

The ETInstrumentor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HtmlInstrumentNavigation | Instrument an HTML navigation page with hidden forms that act as hooks to work with the Web tools package.
Public method | HtmlInstrumentRecord | Instruments an HTML record page with hidden forms that act as hooks to work with the Web tools package.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ETInstrumentor Class


HtmlInstrumentNavigation Method

[image]

Endeca Presentation API
ETInstrumentor..::..HtmlInstrumentNavigation Method
ETInstrumentor Class See Also Send Feedback
Instrument an HTML navigation page with hidden forms that act as hooks to work with the Web tools package.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string HtmlInstrumentNavigation(
    Navigation n
)
Visual Basic
Public Function HtmlInstrumentNavigation ( _
    n As Navigation _
) As String
Visual C++
public:
String^ HtmlInstrumentNavigation(
    Navigation^ n
)

Parameters

n
Type: Endeca.Navigation..::..Navigation
Navigation object that represents a navigation page.

Return Value

HTML source that specifies a single hidden form.

See Also

ETInstrumentor Class


HtmlInstrumentRecord Method

[image]

Endeca Presentation API
ETInstrumentor..::..HtmlInstrumentRecord Method
ETInstrumentor Class See Also Send Feedback
Instruments an HTML record page with hidden forms that act as hooks to work with the Web tools package.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string HtmlInstrumentRecord(
    ERec e,
    string displayNameProperty,
    string recordSpecProperty
)
Visual Basic
Public Function HtmlInstrumentRecord ( _
    e As ERec, _
    displayNameProperty As String, _
    recordSpecProperty As String _
) As String
Visual C++
public:
String^ HtmlInstrumentRecord(
    ERec^ e,
    String^ displayNameProperty,
    String^ recordSpecProperty
)

Parameters

e
Type: Endeca.Navigation..::..ERec
The record that represents the page to be instrumented
displayNameProperty
Type: System..::..String
The name of the property that should be used for the title of the record.
recordSpecProperty
Type: System..::..String
The name of the property that uniquely identifies the record.

Return Value

HTML source that specifies a single hidden form.

See Also

ETInstrumentor Class


FieldList Class

[image]

Endeca Presentation API
FieldList Class
Members See Also Send Feedback
An IList of Endeca property or dimension names that will be used to specify which values will be returned for each record in the result set of a navigation query. The Selection setter property is used to set the FieldList for the query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FieldList : IList, ICollection,
    IEnumerable
Visual Basic
Public Class FieldList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class FieldList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..FieldList

See Also

FieldList Members


FieldList Members

[image] [image]

Endeca Presentation API
FieldList Members
FieldList Class Constructors Methods Properties See Also Send Feedback

The FieldList type exposes the following members.

Constructors

 | Name | Description
Public method | FieldList | Default constructor that creates an empty list.

Methods

 | Name | Description
Public method | Add | Add an item to the FieldList.
Public method | AddField(String) | Add a field to the FieldList by name.
Public method | AddField(Dimension) | Add a dimension field to the FieldList.
Public method | AddField(Property) | Add a property field to the FieldList.
Public method | Clear | Clear the FieldList.
Public method | Contains | Determines whether an element is in the FieldList.
Public method | CopyTo | Copies the entire FieldList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire FieldList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the FieldList or in a portion of it.
Public method | Insert | Insert an item into the FieldList.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove an item from the FieldList.
Public method | RemoveAt | Remove an indexed item from the FieldList.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the FieldList.
Public property | IsFixedSize | Gets a value indicating whether the FieldList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the FieldList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the FieldList is synchronized (thread-safe).
Public property | Item | Gets/Sets the field string at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

FieldList Class


FieldList Constructor

[image]

Endeca Presentation API
FieldList Constructor
FieldList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FieldList()
Visual Basic
Public Sub New
Visual C++
public:
FieldList()

See Also

FieldList Class


FieldList Methods

[image] [image]

Endeca Presentation API
FieldList Methods
FieldList Class See Also Send Feedback

The FieldList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an item to the FieldList.
Public method | AddField(String) | Add a field to the FieldList by name.
Public method | AddField(Dimension) | Add a dimension field to the FieldList.
Public method | AddField(Property) | Add a property field to the FieldList.
Public method | Clear | Clear the FieldList.
Public method | Contains | Determines whether an element is in the FieldList.
Public method | CopyTo | Copies the entire FieldList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire FieldList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the FieldList or in a portion of it.
Public method | Insert | Insert an item into the FieldList.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Remove an item from the FieldList.
Public method | RemoveAt | Remove an indexed item from the FieldList.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldList Class


Add Method

[image]

Endeca Presentation API
FieldList..::..Add Method
FieldList Class See Also Send Feedback
Add an item to the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the FieldList.

Return Value

Index of added field.

Implements

IList..::..Add(Object)

See Also

FieldList Class


AddField Method

[image] [image]

Endeca Presentation API
FieldList..::..AddField Method
FieldList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddField(String) | Add a field to the FieldList by name.
Public method | AddField(Dimension) | Add a dimension field to the FieldList.
Public method | AddField(Property) | Add a property field to the FieldList.

See Also

FieldList Class
FieldList Members


AddField Method (String)

[image]

Endeca Presentation API
FieldList..::..AddField Method (String)
FieldList Class See Also Send Feedback
Add a field to the FieldList by name.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int AddField(
    string f
)
Visual Basic
Public Overridable Function AddField ( _
    f As String _
) As Integer
Visual C++
public:
virtual int AddField(
    String^ f
)

Parameters

f
Type: System..::..String
The String to be added to the end of the FieldList.

Return Value

Index of added field.

See Also

FieldList Class
AddField Overload


AddField Method (Dimension)

[image]

Endeca Presentation API
FieldList..::..AddField Method (Dimension)
FieldList Class See Also Send Feedback
Add a dimension field to the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int AddField(
    Dimension d
)
Visual Basic
Public Overridable Function AddField ( _
    d As Dimension _
) As Integer
Visual C++
public:
virtual int AddField(
    Dimension^ d
)

Parameters

d
Type: Endeca.Navigation..::..Dimension
The Dimension to be added to the end of the FieldList.

Return Value

Index of added field.

See Also

FieldList Class
AddField Overload


AddField Method (Property)

[image]

Endeca Presentation API
FieldList..::..AddField Method (Property)
FieldList Class See Also Send Feedback
Add a property field to the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int AddField(
    Property p
)
Visual Basic
Public Overridable Function AddField ( _
    p As Property _
) As Integer
Visual C++
public:
virtual int AddField(
    Property^ p
)

Parameters

p
Type: Endeca.Navigation..::..Property
The Property to be added to the end of the FieldList.

Return Value

Index of added field.

See Also

FieldList Class
AddField Overload


Clear Method

[image]

Endeca Presentation API
FieldList..::..Clear Method
FieldList Class See Also Send Feedback
Clear the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

See Also

FieldList Class


Contains Method

[image]

Endeca Presentation API
FieldList..::..Contains Method
FieldList Class See Also Send Feedback
Determines whether an element is in the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the FieldList.

Return Value

true if item is found in the FieldList.

Implements

IList..::..Contains(Object)

See Also

FieldList Class


CopyTo Method

[image]

Endeca Presentation API
FieldList..::..CopyTo Method
FieldList Class See Also Send Feedback
Copies the entire FieldList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from FieldList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source FieldList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source FieldList be cast automatically to the type of the destination array.

See Also

FieldList Class


GetEnumerator Method

[image]

Endeca Presentation API
FieldList..::..GetEnumerator Method
FieldList Class See Also Send Feedback
Returns an enumerator for the entire FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire FieldList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

FieldList Class


IndexOf Method

[image]

Endeca Presentation API
FieldList..::..IndexOf Method
FieldList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the FieldList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the FieldList.

Return Value

The zero-based index of the first occurrence of item within the entire FieldList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

FieldList Class


Insert Method

[image]

Endeca Presentation API
FieldList..::..Insert Method
FieldList Class See Also Send Feedback
Insert an item into the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

See Also

FieldList Class


Remove Method

[image]

Endeca Presentation API
FieldList..::..Remove Method
FieldList Class See Also Send Feedback
Remove an item from the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from FieldList.

Implements

IList..::..Remove(Object)

See Also

FieldList Class


RemoveAt Method

[image]

Endeca Presentation API
FieldList..::..RemoveAt Method
FieldList Class See Also Send Feedback
Remove an indexed item from the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

FieldList Class


FieldList Properties

[image] [image]

Endeca Presentation API
FieldList Properties
FieldList Class See Also Send Feedback

The FieldList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the FieldList.
Public property | IsFixedSize | Gets a value indicating whether the FieldList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the FieldList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the FieldList is synchronized (thread-safe).
Public property | Item | Gets/Sets the field string at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

FieldList Class


Count Property

[image]

Endeca Presentation API
FieldList..::..Count Property
FieldList Class See Also Send Feedback
Gets the number of elements actually contained in the FieldList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the FieldList.

Implements

ICollection..::..Count

See Also

FieldList Class


IsFixedSize Property

[image]

Endeca Presentation API
FieldList..::..IsFixedSize Property
FieldList Class See Also Send Feedback
Gets a value indicating whether the FieldList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the FieldList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

FieldList Class


IsReadOnly Property

[image]

Endeca Presentation API
FieldList..::..IsReadOnly Property
FieldList Class See Also Send Feedback
Gets a value indicating whether the FieldList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the FieldList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

FieldList Class


IsSynchronized Property

[image]

Endeca Presentation API
FieldList..::..IsSynchronized Property
FieldList Class See Also Send Feedback
Gets a value indicating whether access to the FieldList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the FieldList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

FieldList Class


Item Property

[image]

Endeca Presentation API
FieldList..::..Item Property
FieldList Class See Also Send Feedback
Gets/Sets the field string at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimGroup at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

FieldList Class


SyncRoot Property

[image]

Endeca Presentation API
FieldList..::..SyncRoot Property
FieldList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the FieldList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

FieldList Class


GlobalDimSearchRefinementConfig Class

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig Class
Members See Also Send Feedback
Class representing a global refinement config for dimension search. The options currently available in this class are the ability to turn counts on or off, the ability to specify the number of results to return, and the ability to specify whether the synonyms should be returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class GlobalDimSearchRefinementConfig
Visual Basic
Public Class GlobalDimSearchRefinementConfig
Visual C++
public ref class GlobalDimSearchRefinementConfig

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..GlobalDimSearchRefinementConfig

See Also

GlobalDimSearchRefinementConfig Members


GlobalDimSearchRefinementConfig Members

[image] [image]

Endeca Presentation API
GlobalDimSearchRefinementConfig Members
GlobalDimSearchRefinementConfig Class Constructors Methods Properties See Also Send Feedback

The GlobalDimSearchRefinementConfig type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalDimSearchRefinementConfig | No argument default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of GlobalDimSearchRefinementConfig that can later be inserted into a URL.

Properties

 | Name | Description
Public property | IncludeInert | Accessor which gets/sets whether innert dimension values will be returned for all dimensions There is no per-dimension setting
Public property | MaxDepth | Accessor which gets/sets the maximum depth of dimension values that will be returned for all dimensions. There is no per-dimension setting
Public property | NumResults | Accessor which gets/sets the number of results to be returned per dimension for all dimensions. The per-dimension setting overrides the global setting for that dimension.
Public property | ShowCounts | Accessor which gets/sets whether the global config will show counts. The per-dimension setting overrides the global setting for that dimension.
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned for all dimensions. The per-dimension setting overrides the global setting for that dimension.

See Also

GlobalDimSearchRefinementConfig Class


GlobalDimSearchRefinementConfig Constructor

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig Constructor
GlobalDimSearchRefinementConfig Class See Also Send Feedback
No argument default constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GlobalDimSearchRefinementConfig()
Visual Basic
Public Sub New
Visual C++
public:
GlobalDimSearchRefinementConfig()

See Also

GlobalDimSearchRefinementConfig Class


GlobalDimSearchRefinementConfig Methods

[image] [image]

Endeca Presentation API
GlobalDimSearchRefinementConfig Methods
GlobalDimSearchRefinementConfig Class See Also Send Feedback

The GlobalDimSearchRefinementConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of GlobalDimSearchRefinementConfig that can later be inserted into a URL.

See Also

GlobalDimSearchRefinementConfig Class


ToString Method

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..ToString Method
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Returns a string representation of GlobalDimSearchRefinementConfig that can later be inserted into a URL.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.GlobalDimSearchRefinementConfig.ToString"]

See Also

GlobalDimSearchRefinementConfig Class


GlobalDimSearchRefinementConfig Properties

[image] [image]

Endeca Presentation API
GlobalDimSearchRefinementConfig Properties
GlobalDimSearchRefinementConfig Class See Also Send Feedback

The GlobalDimSearchRefinementConfig type exposes the following members.

Properties

 | Name | Description
Public property | IncludeInert | Accessor which gets/sets whether innert dimension values will be returned for all dimensions There is no per-dimension setting
Public property | MaxDepth | Accessor which gets/sets the maximum depth of dimension values that will be returned for all dimensions. There is no per-dimension setting
Public property | NumResults | Accessor which gets/sets the number of results to be returned per dimension for all dimensions. The per-dimension setting overrides the global setting for that dimension.
Public property | ShowCounts | Accessor which gets/sets whether the global config will show counts. The per-dimension setting overrides the global setting for that dimension.
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned for all dimensions. The per-dimension setting overrides the global setting for that dimension.

See Also

GlobalDimSearchRefinementConfig Class


IncludeInert Property

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..IncludeInert Property
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets whether innert dimension values will be returned for all dimensions There is no per-dimension setting

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalBoolean IncludeInert { get; set; }
Visual Basic
Public Property IncludeInert As OptionalBoolean
    Get
    Set
Visual C++
public:
property OptionalBoolean^ IncludeInert {
    OptionalBoolean^ get ();
    void set (OptionalBoolean^ value);
}

Field Value

An
CopyC#
OptionalBoolean
 that specifies whether innert values will be returned.
CopyC#
TRUE
 indicates that innert values will be returned.
CopyC#
FALSE
 indicates that innert values will not be returned. If the
CopyC#
OptionalBoolean
 is empty, then the default value is
CopyC#
FALSE
.

See Also

GlobalDimSearchRefinementConfig Class


MaxDepth Property

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..MaxDepth Property
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets the maximum depth of dimension values that will be returned for all dimensions. There is no per-dimension setting

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalInt MaxDepth { get; set; }
Visual Basic
Public Property MaxDepth As OptionalInt
    Get
    Set
Visual C++
public:
property OptionalInt^ MaxDepth {
    OptionalInt^ get ();
    void set (OptionalInt^ value);
}

Field Value

An
CopyC#
OptionalInt
 that specified the depth of dimensions that will be returned. If the
CopyC#
OptionalBoolean
 is empty, then all elligable dimension values are returned.

See Also

GlobalDimSearchRefinementConfig Class


NumResults Property

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..NumResults Property
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets the number of results to be returned per dimension for all dimensions. The per-dimension setting overrides the global setting for that dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalInt NumResults { get; set; }
Visual Basic
Public Property NumResults As OptionalInt
    Get
    Set
Visual C++
public:
property OptionalInt^ NumResults {
    OptionalInt^ get ();
    void set (OptionalInt^ value);
}

Field Value

An
CopyC#
OptionalInt
 that specified the number of results to be returned per dimension for all dimensions. If the
CopyC#
OptionalBoolean
 is empty, then, by default, all results are returned.

See Also

GlobalDimSearchRefinementConfig Class


ShowCounts Property

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..ShowCounts Property
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets whether the global config will show counts. The per-dimension setting overrides the global setting for that dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalBoolean ShowCounts { get; set; }
Visual Basic
Public Property ShowCounts As OptionalBoolean
    Get
    Set
Visual C++
public:
property OptionalBoolean^ ShowCounts {
    OptionalBoolean^ get ();
    void set (OptionalBoolean^ value);
}

Field Value

An
CopyC#
OptionalBoolean
 that specifies whether the dimension value will show counts.
CopyC#
TRUE
 indicates the dimension value will display counts and
CopyC#
FALSE
 indicates the dimension value will not. If the
CopyC#
OptionalBoolean
 is empty, then the default value is
CopyC#
FALSE
.

See Also

GlobalDimSearchRefinementConfig Class


Synonyms Property

[image]

Endeca Presentation API
GlobalDimSearchRefinementConfig..::..Synonyms Property
GlobalDimSearchRefinementConfig Class See Also Send Feedback
Accessor which gets/sets whether the synonyms will be returned for all dimensions. The per-dimension setting overrides the global setting for that dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalBoolean Synonyms { get; set; }
Visual Basic
Public Property Synonyms As OptionalBoolean
    Get
    Set
Visual C++
public:
property OptionalBoolean^ Synonyms {
    OptionalBoolean^ get ();
    void set (OptionalBoolean^ value);
}

Field Value

An
CopyC#
OptionalBoolean
 that specifies whether the synonyms will be returned.
CopyC#
TRUE
 indicates that the synonyms will be returned and
CopyC#
FALSE
 indicates that the synonyms will not be returned. If the
CopyC#
OptionalBoolean
 is empty, then the default value is
CopyC#
FALSE
.

See Also

GlobalDimSearchRefinementConfig Class


HttpENEConnection Class

[image]

Endeca Presentation API
HttpENEConnection Class
Members Example See Also Send Feedback
Provides a connection to an Endeca MDEX Engine over HTTP. Also provides a mechanism for issuing queries to the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class HttpENEConnection : IENEConnection
Visual Basic
<SerializableAttribute> _
Public Class HttpENEConnection _
    Implements IENEConnection
Visual C++
[SerializableAttribute]
public ref class HttpENEConnection : IENEConnection

Remarks

The HttpENEConnection is currently the only implementation of the IENEConnection interface.

This connection is a repository for hostname and port configuration parameters for HTTP connections to an Endeca MDEX Engine. The connection does not open a persistant connection to the MDEX Engine. The instantiation of this connection does not initiate an HTTP socket connection. Instead each issuance of the Query(ENEQuery) method opens a HTTP socket connection(s), makes the requests, and closes the connection(s).

Examples

An example usage of the HttpENEConnection in C# and ASP.NET:
CopyC#
IENEConnection nec = new HttpENEConnection("engine.endeca.com", 5001);
ENEQuery usq = new UrlENEQuery(Page.Request.Url.Query);
ENEQueryResults qr = nec.Query(usq);

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..HttpENEConnection
Endeca.Navigation..::..AuthHttpENEConnection

See Also

HttpENEConnection Members


HttpENEConnection Members

[image] [image]

Endeca Presentation API
HttpENEConnection Members
HttpENEConnection Class Constructors Methods Properties See Also Send Feedback

The HttpENEConnection type exposes the following members.

Constructors

 | Name | Description
Public method | HttpENEConnection()()()() | Default empty constructor.
Public method | HttpENEConnection(String, Int32) | Constructor for connection to an Endeca MDEX Engine over HTTP.
Public method | HttpENEConnection(String, String) | Constructor for connection to an Endeca MDEX Engine over HTTP.

Methods

 | Name | Description
Public method | AddHttpHeader | Add an HTTP header to the query request
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository
Public method | EnableSSL(X509Certificate) | Enables ssl
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Issues a query against the MDEX Engine.
Public method | SetPort | Sets the port of the MDEX Engine.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Hostname | Get and sets the hostname of the MDEX Engine.
Public property | MaxUrl | Get and set the maximum URL length
Public property | Port | Gets and sets the port of the MDEX Engine.

See Also

HttpENEConnection Class


HttpENEConnection Constructor

[image] [image]

Endeca Presentation API
HttpENEConnection Constructor
HttpENEConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HttpENEConnection()()()() | Default empty constructor.
Public method | HttpENEConnection(String, Int32) | Constructor for connection to an Endeca MDEX Engine over HTTP.
Public method | HttpENEConnection(String, String) | Constructor for connection to an Endeca MDEX Engine over HTTP.

See Also

HttpENEConnection Class
HttpENEConnection Members


HttpENEConnection Constructor

[image]

Endeca Presentation API
HttpENEConnection Constructor
HttpENEConnection Class See Also Send Feedback
Default empty constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public HttpENEConnection()
Visual Basic
Public Sub New
Visual C++
public:
HttpENEConnection()

Remarks

Hostname and port need to be set before Query(ENEQuery) is called, else a ENEQueryException will be thrown.

See Also

HttpENEConnection Class
HttpENEConnection Overload


HttpENEConnection Constructor (String, Int32)

[image]

Endeca Presentation API
HttpENEConnection Constructor (String, Int32)
HttpENEConnection Class See Also Send Feedback
Constructor for connection to an Endeca MDEX Engine over HTTP.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public HttpENEConnection(
    string hostname,
    int port
)
Visual Basic
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
HttpENEConnection(
    String^ hostname,
    int port
)

Parameters

hostname
Type: System..::..String
Hostname or IP address of the MDEX Engine. Example: 127.0.0.1 or engine.endeca.com.
port
Type: System..::..Int32
Port of the MDEX Engine. Example: 5001.

See Also

HttpENEConnection Class
HttpENEConnection Overload


HttpENEConnection Constructor (String, String)

[image]

Endeca Presentation API
HttpENEConnection Constructor (String, String)
HttpENEConnection Class See Also Send Feedback
Constructor for connection to an Endeca MDEX Engine over HTTP.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public HttpENEConnection(
    string hostname,
    string port
)
Visual Basic
Public Sub New ( _
    hostname As String, _
    port As String _
)
Visual C++
public:
HttpENEConnection(
    String^ hostname,
    String^ port
)

Parameters

hostname
Type: System..::..String
Hostname or IP address of the MDEX Engine. Example: 127.0.0.1 or engine.endeca.com.
port
Type: System..::..String
Hostname or IP address of the MDEX Engine. Port of the MDEX Engine. Example: 5001.

See Also

HttpENEConnection Class
HttpENEConnection Overload


HttpENEConnection Methods

[image] [image]

Endeca Presentation API
HttpENEConnection Methods
HttpENEConnection Class See Also Send Feedback

The HttpENEConnection type exposes the following members.

Methods

 | Name | Description
Public method | AddHttpHeader | Add an HTTP header to the query request
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository
Public method | EnableSSL(X509Certificate) | Enables ssl
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Query | Issues a query against the MDEX Engine.
Public method | SetPort | Sets the port of the MDEX Engine.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpENEConnection Class


AddHttpHeader Method

[image]

Endeca Presentation API
HttpENEConnection..::..AddHttpHeader Method
HttpENEConnection Class See Also Send Feedback
Add an HTTP header to the query request

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddHttpHeader(
    string name,
    string value
)
Visual Basic
Public Overridable Sub AddHttpHeader ( _
    name As String, _
    value As String _
)
Visual C++
public:
virtual void AddHttpHeader(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name of the HTTP header to add. The value of the HTTP header to add.
value
Type: System..::..String

See Also

HttpENEConnection Class


EnableSSL Method

[image] [image]

Endeca Presentation API
HttpENEConnection..::..EnableSSL Method
HttpENEConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EnableSSL()()()() | Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository
Public method | EnableSSL(X509Certificate) | Enables ssl

See Also

HttpENEConnection Class
HttpENEConnection Members


EnableSSL Method

[image]

Endeca Presentation API
HttpENEConnection..::..EnableSSL Method
HttpENEConnection Class See Also Send Feedback
Enables ssl. Will attempt to use the first personal certificate it finds issued by "Endeca Technologies, Inc." stored in Local Machine's peronsal certificate repository

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void EnableSSL()
Visual Basic
Public Sub EnableSSL
Visual C++
public:
void EnableSSL()

See Also

HttpENEConnection Class
EnableSSL Overload


EnableSSL Method (X509Certificate)

[image]

Endeca Presentation API
HttpENEConnection..::..EnableSSL Method (X509Certificate)
HttpENEConnection Class See Also Send Feedback
Enables ssl

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void EnableSSL(
    X509Certificate clientCertificate
)
Visual Basic
Public Sub EnableSSL ( _
    clientCertificate As X509Certificate _
)
Visual C++
public:
void EnableSSL(
    X509Certificate^ clientCertificate
)

Parameters

clientCertificate
Type: System.Security.Cryptography.X509Certificates..::..X509Certificate
Which private certificate to use

See Also

HttpENEConnection Class
EnableSSL Overload


Query Method

[image]

Endeca Presentation API
HttpENEConnection..::..Query Method
HttpENEConnection Class See Also Send Feedback
Issues a query against the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ENEQueryResults Query(
    ENEQuery neq
)
Visual Basic
Public Overridable Function Query ( _
    neq As ENEQuery _
) As ENEQueryResults
Visual C++
public:
virtual ENEQueryResults^ Query(
    ENEQuery^ neq
)

Parameters

neq
Type: Endeca.Navigation..::..ENEQuery
The query object containing the navigation, record etc. type requests to the MDEX Engine

Return Value

Returns a ENEQueryResults object which contains the resultant objects returned by the MDEX Engine in response to the query neq.

Implements

IENEConnection..::..Query(ENEQuery)

Exceptions

Exception | Condition
Endeca.Navigation..::..ENEQueryException | If there is a problem making the query. Possible subclasses of ENEQueryException that could be thrown are ENEConnectionException, EmptyENEQueryException, PartialENEQueryException, ENEException, VersionMismatchException, and so on.

See Also

HttpENEConnection Class


SetPort Method

[image]

Endeca Presentation API
HttpENEConnection..::..SetPort Method
HttpENEConnection Class See Also Send Feedback
Sets the port of the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetPort(
    string port
)
Visual Basic
Public Overridable Sub SetPort ( _
    port As String _
)
Visual C++
public:
virtual void SetPort(
    String^ port
)

Parameters

port
Type: System..::..String
Port of the MDEX Engine.

See Also

HttpENEConnection Class


HttpENEConnection Properties

[image] [image]

Endeca Presentation API
HttpENEConnection Properties
HttpENEConnection Class See Also Send Feedback

The HttpENEConnection type exposes the following members.

Properties

 | Name | Description
Public property | Hostname | Get and sets the hostname of the MDEX Engine.
Public property | MaxUrl | Get and set the maximum URL length
Public property | Port | Gets and sets the port of the MDEX Engine.

See Also

HttpENEConnection Class


Hostname Property

[image]

Endeca Presentation API
HttpENEConnection..::..Hostname Property
HttpENEConnection Class See Also Send Feedback
Get and sets the hostname of the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Hostname { get; set; }
Visual Basic
Public Overridable Property Hostname As String
    Get
    Set
Visual C++
public:
virtual property String^ Hostname {
    String^ get ();
    void set (String^ value);
}

Field Value

The hostname of the MDEX Engine. null if hostname has not been set.

See Also

HttpENEConnection Class


MaxUrl Property

[image]

Endeca Presentation API
HttpENEConnection..::..MaxUrl Property
HttpENEConnection Class See Also Send Feedback
Get and set the maximum URL length

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int MaxUrl { get; set; }
Visual Basic
Public Overridable Property MaxUrl As Integer
    Get
    Set
Visual C++
public:
virtual property int MaxUrl {
    int get ();
    void set (int value);
}

Field Value

Get and set the maximum URL length for which use of an HTTP GET operation is allowed. If a longer URL is needed, an HTTP POST operation will be used instead. If set to 0, POST will always be used. If set to -1, either GET or POST may be used at the discretion of the API. The default is -1.

See Also

HttpENEConnection Class


Port Property

[image]

Endeca Presentation API
HttpENEConnection..::..Port Property
HttpENEConnection Class See Also Send Feedback
Gets and sets the port of the MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Port { get; set; }
Visual Basic
Public Overridable Property Port As Integer
    Get
    Set
Visual C++
public:
virtual property int Port {
    int get ();
    void set (int value);
}

Field Value

The port of the MDEX Engine. 0 if port has not been set.

See Also

HttpENEConnection Class


IENEConnection Interface

[image]

Endeca Presentation API
IENEConnection Interface
Members See Also Send Feedback
A connection with an Endeca MDEX Engine. With a connection, queries can be issued to the MDEX Engine and ENEQueryResults are returned.

The only current type of connection offered is the HttpENEConnection.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IENEConnection
Visual Basic
Public Interface IENEConnection
Visual C++
public interface class IENEConnection

See Also

IENEConnection Members


IENEConnection Members

[image] [image]

Endeca Presentation API
IENEConnection Members
IENEConnection Interface Methods See Also Send Feedback

The IENEConnection type exposes the following members.

Methods

 | Name | Description
Public method | Query | Makes a query against an Endeca MDEX Engine.

See Also

IENEConnection Interface


IENEConnection Methods

[image] [image]

Endeca Presentation API
IENEConnection Methods
IENEConnection Interface See Also Send Feedback

The IENEConnection type exposes the following members.

Methods

 | Name | Description
Public method | Query | Makes a query against an Endeca MDEX Engine.

See Also

IENEConnection Interface


Query Method

[image]

Endeca Presentation API
IENEConnection..::..Query Method
IENEConnection Interface See Also Send Feedback
Makes a query against an Endeca MDEX Engine.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
ENEQueryResults Query(
    ENEQuery q
)
Visual Basic
Function Query ( _
    q As ENEQuery _
) As ENEQueryResults
Visual C++
ENEQueryResults^ Query(
    ENEQuery^ q
)

Parameters

q
Type: Endeca.Navigation..::..ENEQuery
Query to make.

Return Value

Results of the query.

Remarks

The query results.

Exceptions

Exception | Condition
Endeca.Navigation..::..ENEQueryException | If an Endeca MDEX Engine query fails.

See Also

IENEConnection Interface


InternalException Class

[image]

Endeca Presentation API
InternalException Class
Members See Also Send Feedback
Exception signalling that an internal error has occured in the system. Internal errors often signal an unexpected error in the execution of the system.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class InternalException : SystemException
Visual Basic
Public Class InternalException _
    Inherits SystemException
Visual C++
public ref class InternalException : public SystemException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
Endeca.Navigation..::..InternalException

See Also

InternalException Members


InternalException Members

[image] [image]

Endeca Presentation API
InternalException Members
InternalException Class Methods Properties See Also Send Feedback

The InternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintStackTrace | Prints the stack trace to the standard error stream.
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class


InternalException Methods

[image] [image]

Endeca Presentation API
InternalException Methods
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrintStackTrace | Prints the stack trace to the standard error stream.
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InternalException Class


PrintStackTrace Method

[image]

Endeca Presentation API
InternalException..::..PrintStackTrace Method
InternalException Class See Also Send Feedback
Prints the stack trace to the standard error stream.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void PrintStackTrace()
Visual Basic
Public Sub PrintStackTrace
Visual C++
public:
void PrintStackTrace()

See Also

InternalException Class


InternalException Properties

[image] [image]

Endeca Presentation API
InternalException Properties
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class


IPropertyContainer Interface

[image]

Endeca Presentation API
IPropertyContainer Interface
Members See Also Send Feedback
Interface for an object that has properties and has those properties exposed as a PropertyMap. The purpose for this interface is to allow common code to be used in the extraction of any object that supports this interface, for example building tag libraries around property containers.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IPropertyContainer
Visual Basic
Public Interface IPropertyContainer
Visual C++
public interface class IPropertyContainer

See Also

IPropertyContainer Members


IPropertyContainer Members

[image] [image]

Endeca Presentation API
IPropertyContainer Members
IPropertyContainer Interface Properties See Also Send Feedback

The IPropertyContainer type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gets the properties for this container.

See Also

IPropertyContainer Interface


IPropertyContainer Properties

[image] [image]

Endeca Presentation API
IPropertyContainer Properties
IPropertyContainer Interface See Also Send Feedback

The IPropertyContainer type exposes the following members.

Properties

 | Name | Description
Public property | Properties | Gets the properties for this container.

See Also

IPropertyContainer Interface


Properties Property

[image]

Endeca Presentation API
IPropertyContainer..::..Properties Property
IPropertyContainer Interface See Also Send Feedback
Gets the properties for this container.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
PropertyMap Properties { get; }
Visual Basic
ReadOnly Property Properties As PropertyMap
    Get
Visual C++
property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

Properties of this container.

Remarks

Returns an empty property map if there are no properties defined for this container.

See Also

IPropertyContainer Interface


KeyProperties Class

[image]

Endeca Presentation API
KeyProperties Class
Members See Also Send Feedback
Class providing access to a collection of properties associated with a given Endeca Dimension or Property key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class KeyProperties
Visual Basic
Public Class KeyProperties
Visual C++
public ref class KeyProperties

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..KeyProperties

See Also

KeyProperties Members


KeyProperties Members

[image] [image]

Endeca Presentation API
KeyProperties Members
KeyProperties Class Constructors Methods Properties See Also Send Feedback

The KeyProperties type exposes the following members.

Constructors

 | Name | Description
Public method | KeyProperties | Constructor for a KeyProperties.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the name of this Endeca Dimension or Property key.
Public property | Properties | Gets the properties for this Endeca Dimension or Property key.

See Also

KeyProperties Class


KeyProperties Constructor

[image]

Endeca Presentation API
KeyProperties Constructor
KeyProperties Class See Also Send Feedback
Constructor for a KeyProperties.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public KeyProperties(
    string keyName
)
Visual Basic
Public Sub New ( _
    keyName As String _
)
Visual C++
public:
KeyProperties(
    String^ keyName
)

Parameters

keyName
Type: System..::..String
Name of an Endeca Dimension or Property.

See Also

KeyProperties Class


KeyProperties Methods

[image] [image]

Endeca Presentation API
KeyProperties Methods
KeyProperties Class See Also Send Feedback

The KeyProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyProperties Class


KeyProperties Properties

[image] [image]

Endeca Presentation API
KeyProperties Properties
KeyProperties Class See Also Send Feedback

The KeyProperties type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the name of this Endeca Dimension or Property key.
Public property | Properties | Gets the properties for this Endeca Dimension or Property key.

See Also

KeyProperties Class


Key Property

[image]

Endeca Presentation API
KeyProperties..::..Key Property
KeyProperties Class See Also Send Feedback
Gets the name of this Endeca Dimension or Property key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Field Value

Name of this key.

See Also

KeyProperties Class


Properties Property

[image]

Endeca Presentation API
KeyProperties..::..Properties Property
KeyProperties Class See Also Send Feedback
Gets the properties for this Endeca Dimension or Property key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap Properties { get; }
Visual Basic
Public Overridable ReadOnly Property Properties As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

A PropertyMap containing the properties for this key.

See Also

KeyProperties Class


Navigation Class

[image]

Endeca Presentation API
Navigation Class
Members See Also Send Feedback
Top-level object returned from an Endeca MDEX Engine. The Navigation object serves as a container for several components (such as navigation descriptors, record set, etc.) that together compose a navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Navigation
Visual Basic
Public Class Navigation
Visual C++
public ref class Navigation

Remarks

A Navigation object is defined by the set of dimension values that were used to query the MDEX Engine to obtain the Navigation object. Those values are in the context of a Navigation object defined as descriptors, the values that describe the navigation query.

In addition, several other objects compose to make a dimension. The records which are the records that meet the query descriptor criteria. The aggregated records which are the same records but rolled up by a certain criteria. The various keys which describe options and operations available on the records. The refinements which are the navigational options that are available to refine the query.

The refinements and the descriptors are broken up by their individual dimensions. There is a third set of dimensions called the integrated dimensions which are the union of the refinement and descriptor dimensions. Lastly all three sets of dimensions are available consolidated by their dimensions groups via the RefinementDimGroups, DescriptorDimGroups, and IntegratedDimGroups properties.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..Navigation

See Also

Navigation Members


Navigation Members

[image] [image]

Endeca Presentation API
Navigation Members
Navigation Class Methods Properties See Also Send Feedback

The Navigation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveSortKeys | Gets the active sort keys applicable for this navigation.
Public method | GetAnalyticsStatementResult | Returns the AnalyticsStatementResult for the named query. If results for the named analytics query does not exist, null is returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AggrERecs | Gets the aggregated records associated with this navigation query, which come from the original records consolidated by a rollup key.
Public property | AggrERecsOffset | Gets the offset of the first aggregated record in the aggregated record list with respect to the total number of aggregated records in the dataset that match this navigation query.
Public property | AnalyticsQueryError | Gets or sets the error message, if any, associated with the evaluation of the analytics portion of the query results. This method reports any errors that span multiple statements; it does NOT report errors relating to an individual statement.
Public property | AnalyticsStatementNames | Gets the set of statement names included in the analytics results associated with this Navigation.
Public property | BulkAggrERecEnumerator | Gets an Enumerator that provides access to the bulk aggregated records associated with this navigation query.
Public property | BulkERecEnumerator | Gets an Enumerator that provides access to the bulk records associated with this navigation query.
Public property | CompleteDimensions | Gets the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.
Public property | CompleteDimGroups | Gets the dimension groups of the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.
Public property | DescriptorDimensions | Gets the dimensions for the descriptors for this navigation.
Public property | DescriptorDimGroups | Gets the dimension groups of the dimensions for the descriptors for this navigation.
Public property | ERecCompoundSearchKeys | Gets the text search group keys applicable for this navigation.
Public property | ERecs | Gets the records associated with this navigation query.
Public property | ERecSearchKeys | Gets the text search keys applicable for this navigation.
Public property | ERecsOffset | Gets the offset of the first record in the endeca record list with respect to the total number of records in the dataset that match this navigation query.
Public property | ESearchReports | Gets the IDictionary of ESearchReports for this navigation query result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.
Public property | ESearchReportsComplete | Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports
Public property | IntegratedDimensions | Gets the dimensions integrated from the refinement dimensions and the descriptor dimensions.
Public property | IntegratedDimGroups | Gets the dimension groups of the dimensions integrated from the refinement and descriptor dimensions.
Public property | KeyProperties | Gets or Sets the key properties request for the navigation query.
Public property | RangeFilters | Gets the range filters applied to this navigation query result.
Public property | RefinementDimensions | Gets the dimensions of that still have refinements available with respect to this query.
Public property | RefinementDimGroups | Gets the dimension groups of the dimensions that still have refinements available with respect to this navigation query.
Public property | RollupKeys | Gets the rollup keys applicable for this navigation.
Public property | SortKeys | Gets the sort keys applicable for this navigation.
Public property | Supplements | Gets the supplements to this navigation query result.
Public property | TotalNumAggrERecs | Gets the total number of aggregated records matching navigation query.
Public property | TotalNumERecs | Gets the total number of records matching navigation query.

See Also

Navigation Class


Navigation Methods

[image] [image]

Endeca Presentation API
Navigation Methods
Navigation Class See Also Send Feedback

The Navigation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveSortKeys | Gets the active sort keys applicable for this navigation.
Public method | GetAnalyticsStatementResult | Returns the AnalyticsStatementResult for the named query. If results for the named analytics query does not exist, null is returned.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Navigation Class


GetActiveSortKeys Method

[image]

Endeca Presentation API
Navigation..::..GetActiveSortKeys Method
Navigation Class See Also Send Feedback
Gets the active sort keys applicable for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSortKeyList GetActiveSortKeys()
Visual Basic
Public Overridable Function GetActiveSortKeys As ERecSortKeyList
Visual C++
public:
virtual ERecSortKeyList^ GetActiveSortKeys()

Return Value

Active sort keys for this navigation. Even if there are no active sort keys, a valid, empty ERecSortKeyList will be returned.

See Also

Navigation Class


GetAnalyticsStatementResult Method

[image]

Endeca Presentation API
Navigation..::..GetAnalyticsStatementResult Method
Navigation Class See Also Send Feedback
Returns the AnalyticsStatementResult for the named query. If results for the named analytics query does not exist, null is returned.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsStatementResult GetAnalyticsStatementResult(
    string name
)
Visual Basic
Public Function GetAnalyticsStatementResult ( _
    name As String _
) As AnalyticsStatementResult
Visual C++
public:
AnalyticsStatementResult^ GetAnalyticsStatementResult(
    String^ name
)

Parameters

name
Type: System..::..String
The named query.

Return Value

The AnalyticsStatementResult for the named query.

See Also

Navigation Class


Navigation Properties

[image] [image]

Endeca Presentation API
Navigation Properties
Navigation Class See Also Send Feedback

The Navigation type exposes the following members.

Properties

 | Name | Description
Public property | AggrERecs | Gets the aggregated records associated with this navigation query, which come from the original records consolidated by a rollup key.
Public property | AggrERecsOffset | Gets the offset of the first aggregated record in the aggregated record list with respect to the total number of aggregated records in the dataset that match this navigation query.
Public property | AnalyticsQueryError | Gets or sets the error message, if any, associated with the evaluation of the analytics portion of the query results. This method reports any errors that span multiple statements; it does NOT report errors relating to an individual statement.
Public property | AnalyticsStatementNames | Gets the set of statement names included in the analytics results associated with this Navigation.
Public property | BulkAggrERecEnumerator | Gets an Enumerator that provides access to the bulk aggregated records associated with this navigation query.
Public property | BulkERecEnumerator | Gets an Enumerator that provides access to the bulk records associated with this navigation query.
Public property | CompleteDimensions | Gets the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.
Public property | CompleteDimGroups | Gets the dimension groups of the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.
Public property | DescriptorDimensions | Gets the dimensions for the descriptors for this navigation.
Public property | DescriptorDimGroups | Gets the dimension groups of the dimensions for the descriptors for this navigation.
Public property | ERecCompoundSearchKeys | Gets the text search group keys applicable for this navigation.
Public property | ERecs | Gets the records associated with this navigation query.
Public property | ERecSearchKeys | Gets the text search keys applicable for this navigation.
Public property | ERecsOffset | Gets the offset of the first record in the endeca record list with respect to the total number of records in the dataset that match this navigation query.
Public property | ESearchReports | Gets the IDictionary of ESearchReports for this navigation query result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.
Public property | ESearchReportsComplete | Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports
Public property | IntegratedDimensions | Gets the dimensions integrated from the refinement dimensions and the descriptor dimensions.
Public property | IntegratedDimGroups | Gets the dimension groups of the dimensions integrated from the refinement and descriptor dimensions.
Public property | KeyProperties | Gets or Sets the key properties request for the navigation query.
Public property | RangeFilters | Gets the range filters applied to this navigation query result.
Public property | RefinementDimensions | Gets the dimensions of that still have refinements available with respect to this query.
Public property | RefinementDimGroups | Gets the dimension groups of the dimensions that still have refinements available with respect to this navigation query.
Public property | RollupKeys | Gets the rollup keys applicable for this navigation.
Public property | SortKeys | Gets the sort keys applicable for this navigation.
Public property | Supplements | Gets the supplements to this navigation query result.
Public property | TotalNumAggrERecs | Gets the total number of aggregated records matching navigation query.
Public property | TotalNumERecs | Gets the total number of records matching navigation query.

See Also

Navigation Class


AggrERecs Property

[image]

Endeca Presentation API
Navigation..::..AggrERecs Property
Navigation Class See Also Send Feedback
Gets the aggregated records associated with this navigation query, which come from the original records consolidated by a rollup key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual AggrERecList AggrERecs { get; }
Visual Basic
Public Overridable ReadOnly Property AggrERecs As AggrERecList
    Get
Visual C++
public:
virtual property AggrERecList^ AggrERecs {
    AggrERecList^ get ();
}

Field Value

The aggregated records of this navigation query. If no aggregated records are available an emtpy AggrERecList is returned.

See Also

Navigation Class


AggrERecsOffset Property

[image]

Endeca Presentation API
Navigation..::..AggrERecsOffset Property
Navigation Class See Also Send Feedback
Gets the offset of the first aggregated record in the aggregated record list with respect to the total number of aggregated records in the dataset that match this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long AggrERecsOffset { get; }
Visual Basic
Public Overridable ReadOnly Property AggrERecsOffset As Long
    Get
Visual C++
public:
virtual property long long AggrERecsOffset {
    long long get ();
}

Field Value

Offset of the first aggregated record in the endeca record list with respect to the aggregated records in the navigation query result. Also returns 0 if no aggregated records are in result.

See Also

Navigation Class


AnalyticsQueryError Property

[image]

Endeca Presentation API
Navigation..::..AnalyticsQueryError Property
Navigation Class See Also Send Feedback
Gets or sets the error message, if any, associated with the evaluation of the analytics portion of the query results. This method reports any errors that span multiple statements; it does NOT report errors relating to an individual statement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string AnalyticsQueryError { get; set; }
Visual Basic
Public Overridable Property AnalyticsQueryError As String
    Get
    Set
Visual C++
public:
virtual property String^ AnalyticsQueryError {
    String^ get ();
    void set (String^ value);
}

Field Value

The error message.

Return Value

The error message, or null if no error was encountered.

See Also

Navigation Class


AnalyticsStatementNames Property

[image]

Endeca Presentation API
Navigation..::..AnalyticsStatementNames Property
Navigation Class See Also Send Feedback
Gets the set of statement names included in the analytics results associated with this Navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IList AnalyticsStatementNames { get; }
Visual Basic
Public ReadOnly Property AnalyticsStatementNames As IList
    Get
Visual C++
public:
property IList^ AnalyticsStatementNames {
    IList^ get ();
}

Field Value

A list containing the names of analytics results associated with this Navigation, in alphabetical order. If no analytics results are available, an empty list is returned.

See Also

Navigation Class


BulkAggrERecEnumerator Property

[image]

Endeca Presentation API
Navigation..::..BulkAggrERecEnumerator Property
Navigation Class See Also Send Feedback
Gets an Enumerator that provides access to the bulk aggregated records associated with this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecEnumerator BulkAggrERecEnumerator { get; }
Visual Basic
Public Overridable ReadOnly Property BulkAggrERecEnumerator As ERecEnumerator
    Get
Visual C++
public:
virtual property ERecEnumerator^ BulkAggrERecEnumerator {
    ERecEnumerator^ get ();
}

Field Value

An ERecEnumerator providing access to the bulk aggregated records associated with this navigation query.

See Also

Navigation Class


BulkERecEnumerator Property

[image]

Endeca Presentation API
Navigation..::..BulkERecEnumerator Property
Navigation Class See Also Send Feedback
Gets an Enumerator that provides access to the bulk records associated with this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecEnumerator BulkERecEnumerator { get; }
Visual Basic
Public Overridable ReadOnly Property BulkERecEnumerator As ERecEnumerator
    Get
Visual C++
public:
virtual property ERecEnumerator^ BulkERecEnumerator {
    ERecEnumerator^ get ();
}

Field Value

An ERecEnumerator providing access to the bulk records associated with this navigation query.

See Also

Navigation Class


CompleteDimensions Property

[image]

Endeca Presentation API
Navigation..::..CompleteDimensions Property
Navigation Class See Also Send Feedback
Gets the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionList CompleteDimensions { get; }
Visual Basic
Public Overridable ReadOnly Property CompleteDimensions As DimensionList
    Get
Visual C++
public:
virtual property DimensionList^ CompleteDimensions {
    DimensionList^ get ();
}

Field Value

A DimensionList that is the union of the descriptor, refinement, and implicit dimensions.

Remarks

Complete dimensions are the dimensions that either have descriptors, still have refinement values relative to the navigation query, or only contain implicits. The integrated dimensions are in dimension order specified by the MDEX Engine.

See Also

Navigation Class


CompleteDimGroups Property

[image]

Endeca Presentation API
Navigation..::..CompleteDimGroups Property
Navigation Class See Also Send Feedback
Gets the dimension groups of the complete dimensions integrated from the refinement dimensions, the descriptor dimensions, and those that are completely implicit.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimGroupList CompleteDimGroups { get; }
Visual Basic
Public Overridable ReadOnly Property CompleteDimGroups As DimGroupList
    Get
Visual C++
public:
virtual property DimGroupList^ CompleteDimGroups {
    DimGroupList^ get ();
}

Field Value

The dimension groups (a DimGroupList) of the dimensions unioned from the descriptor, refinement, and implicit dimensions.

Remarks

This is analgous to CompleteDimensions except that the dimensions are consolidated by DimGroup. That is, complete dimensions are the dimensions that either have descriptors, still have refinement values relative to the navigation query, or only contain implicits. The integrated dimensions are in dimension order specified by the MDEX Engine.

See Also

Navigation Class


DescriptorDimensions Property

[image]

Endeca Presentation API
Navigation..::..DescriptorDimensions Property
Navigation Class See Also Send Feedback
Gets the dimensions for the descriptors for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionList DescriptorDimensions { get; }
Visual Basic
Public Overridable ReadOnly Property DescriptorDimensions As DimensionList
    Get
Visual C++
public:
virtual property DimensionList^ DescriptorDimensions {
    DimensionList^ get ();
}

Field Value

The dimensions of the descriptors of this navigation query.

Remarks

The descriptors are the set of dimension values that formulate the query that limit the record results of this navigation query. If there are no descriptors, an empty dimension list will be returned. Unlike all other dimension collections presented by the navigation, this collection is NOT in dimension order. Instead this collection IS presented in descriptor order specified by the navigation descriptors of the query, which in turn is most likely generated from SelectRefinement(Navigation, DimVal) which places the descriptors in selection order, that is the order with which the user made their selections.

See Also

Navigation Class


DescriptorDimGroups Property

[image]

Endeca Presentation API
Navigation..::..DescriptorDimGroups Property
Navigation Class See Also Send Feedback
Gets the dimension groups of the dimensions for the descriptors for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimGroupList DescriptorDimGroups { get; }
Visual Basic
Public Overridable ReadOnly Property DescriptorDimGroups As DimGroupList
    Get
Visual C++
public:
virtual property DimGroupList^ DescriptorDimGroups {
    DimGroupList^ get ();
}

Field Value

The dimension groups of the dimensions of the descriptors.

Remarks

Similar to DescriptorDimensions except that the dimensions are grouped by their dimension groups. Returns an empty DimGroupList if there are no descriptors. Unlike the descriptor dimensions, these dim groups are presented in MDEX Engine determined dimension order as opposed to the query specified descriptor order.

See Also

Navigation Class


ERecCompoundSearchKeys Property

[image]

Endeca Presentation API
Navigation..::..ERecCompoundSearchKeys Property
Navigation Class See Also Send Feedback
Gets the text search group keys applicable for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecCompoundSearchKeyList ERecCompoundSearchKeys { get; }
Visual Basic
Public Overridable ReadOnly Property ERecCompoundSearchKeys As ERecCompoundSearchKeyList
    Get
Visual C++
public:
virtual property ERecCompoundSearchKeyList^ ERecCompoundSearchKeys {
    ERecCompoundSearchKeyList^ get ();
}

Field Value

Text search group keys of this navigation. Even if there are no rollup group keys, a valid ERecCompoundSearchKeyList will be returned.

Remarks

Method will always return a ERecCompoundSearchKeyList, but the list may be empty if no text search group keys are present.

See Also

Navigation Class


ERecs Property

[image]

Endeca Presentation API
Navigation..::..ERecs Property
Navigation Class See Also Send Feedback
Gets the records associated with this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecList ERecs { get; set; }
Visual Basic
Public Overridable Property ERecs As ERecList
    Get
    Set
Visual C++
public:
virtual property ERecList^ ERecs {
    ERecList^ get ();
    void set (ERecList^ value);
}

Field Value

The records of this navigation query. If no records have are part of the navigation an empty ERecList is still returned.

See Also

Navigation Class


ERecSearchKeys Property

[image]

Endeca Presentation API
Navigation..::..ERecSearchKeys Property
Navigation Class See Also Send Feedback
Gets the text search keys applicable for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSearchKeyList ERecSearchKeys { get; }
Visual Basic
Public Overridable ReadOnly Property ERecSearchKeys As ERecSearchKeyList
    Get
Visual C++
public:
virtual property ERecSearchKeyList^ ERecSearchKeys {
    ERecSearchKeyList^ get ();
}

Field Value

Text search keys of this navigation. Even if there are no rollup keys, a valid ERecSearchKeyList will be returned.

Remarks

Method will always return a ERecSearchKeyList, but the list may be empty if no text search keys are present.

See Also

Navigation Class


ERecsOffset Property

[image]

Endeca Presentation API
Navigation..::..ERecsOffset Property
Navigation Class See Also Send Feedback
Gets the offset of the first record in the endeca record list with respect to the total number of records in the dataset that match this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long ERecsOffset { get; }
Visual Basic
Public Overridable ReadOnly Property ERecsOffset As Long
    Get
Visual C++
public:
virtual property long long ERecsOffset {
    long long get ();
}

Field Value

Offset of the first record in the endeca record list with respect to the records in the navigation query result. Also returns 0 if no records are in result.

See Also

Navigation Class


ESearchReports Property

[image]

Endeca Presentation API
Navigation..::..ESearchReports Property
Navigation Class See Also Send Feedback
Gets the IDictionary of ESearchReports for this navigation query result. Returns an empty set if there are no ESearchReports This functionality is deprecated and instead developers should use ESearchReportsComplete.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionary ESearchReports { get; }
Visual Basic
Public Overridable ReadOnly Property ESearchReports As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ ESearchReports {
    IDictionary^ get ();
}

Field Value

An IDictionary of ESearchReport, keyed by the search term.

See Also

Navigation Class


ESearchReportsComplete Property

[image]

Endeca Presentation API
Navigation..::..ESearchReportsComplete Property
Navigation Class See Also Send Feedback
Gets the IDictionary of IList of ESearchReportfor this navigation query result. Returns an empty set if there are no ESearchReports

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionary ESearchReportsComplete { get; }
Visual Basic
Public Overridable ReadOnly Property ESearchReportsComplete As IDictionary
    Get
Visual C++
public:
virtual property IDictionary^ ESearchReportsComplete {
    IDictionary^ get ();
}

Field Value

An IDictionary of IList of ESearchReport, keyed by the search term.

See Also

Navigation Class


IntegratedDimensions Property

[image]

Endeca Presentation API
Navigation..::..IntegratedDimensions Property
Navigation Class See Also Send Feedback
Gets the dimensions integrated from the refinement dimensions and the descriptor dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionList IntegratedDimensions { get; }
Visual Basic
Public Overridable ReadOnly Property IntegratedDimensions As DimensionList
    Get
Visual C++
public:
virtual property DimensionList^ IntegratedDimensions {
    DimensionList^ get ();
}

Field Value

The union of the descriptor and refinement dimensions.

Remarks

Integrated dimensions are the dimensions that either have descriptors or still have refinement values relative to the navigation query. Returns an empty set if there are neither refinement nor descriptor dimensions. The integrated dimensions are in dimension order specified by the MDEX Engine.

See Also

Navigation Class


IntegratedDimGroups Property

[image]

Endeca Presentation API
Navigation..::..IntegratedDimGroups Property
Navigation Class See Also Send Feedback
Gets the dimension groups of the dimensions integrated from the refinement and descriptor dimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimGroupList IntegratedDimGroups { get; }
Visual Basic
Public Overridable ReadOnly Property IntegratedDimGroups As DimGroupList
    Get
Visual C++
public:
virtual property DimGroupList^ IntegratedDimGroups {
    DimGroupList^ get ();
}

Field Value

The descriptor groups of the dimensions unioned from the descriptor and refinement dimensions.

Remarks

This is analgous to IntegratedDimensions except that the dimensions are consolidated by DimGroup. Returns an empty set if there are neither refinement nor descriptor dimensions. The dimension groups are in dimension group order determined by the MDEX Engine where the dimension group with the highest ranking dimension is placed first and so on.

See Also

Navigation Class


KeyProperties Property

[image]

Endeca Presentation API
Navigation..::..KeyProperties Property
Navigation Class See Also Send Feedback
Gets or Sets the key properties request for the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionary KeyProperties { get; set; }
Visual Basic
Public Overridable Property KeyProperties As IDictionary
    Get
    Set
Visual C++
public:
virtual property IDictionary^ KeyProperties {
    IDictionary^ get ();
    void set (IDictionary^ value);
}

Field Value

The key properties

See Also

Navigation Class


RangeFilters Property

[image]

Endeca Presentation API
Navigation..::..RangeFilters Property
Navigation Class See Also Send Feedback
Gets the range filters applied to this navigation query result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RangeFilterList RangeFilters { get; }
Visual Basic
Public Overridable ReadOnly Property RangeFilters As RangeFilterList
    Get
Visual C++
public:
virtual property RangeFilterList^ RangeFilters {
    RangeFilterList^ get ();
}

Field Value

RangeFilters applied on this navigation object. A valid RangeFilterList will always be returned.

Remarks

Method will always return a RangeFilterList, but the list may be empty if no range filters were applied.

See Also

Navigation Class


RefinementDimensions Property

[image]

Endeca Presentation API
Navigation..::..RefinementDimensions Property
Navigation Class See Also Send Feedback
Gets the dimensions of that still have refinements available with respect to this query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimensionList RefinementDimensions { get; }
Visual Basic
Public Overridable ReadOnly Property RefinementDimensions As DimensionList
    Get
Visual C++
public:
virtual property DimensionList^ RefinementDimensions {
    DimensionList^ get ();
}

Field Value

The dimension groups of the dimensions that still have refinements available.

Remarks

The dimensions contained by the list each have refinement options available that refine the record set do at least one record. Returns an empty DimensionList if there are no more refinements available for this navigation query. The dimensions are in MDEX Engine determined dimension order.

See Also

Navigation Class


RefinementDimGroups Property

[image]

Endeca Presentation API
Navigation..::..RefinementDimGroups Property
Navigation Class See Also Send Feedback
Gets the dimension groups of the dimensions that still have refinements available with respect to this navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimGroupList RefinementDimGroups { get; }
Visual Basic
Public Overridable ReadOnly Property RefinementDimGroups As DimGroupList
    Get
Visual C++
public:
virtual property DimGroupList^ RefinementDimGroups {
    DimGroupList^ get ();
}

Field Value

The dimension groups of the dimensions that still have refinements available.

Remarks

This list is analgous to RefinementDimensions except that they are grouped by their dimension groups. Returns an empty DimGroupList if there are no more refinements available. The dimension groups are in MDEX Engine determined order where the group with the highest ranking dimension is persented first and so on.

See Also

Navigation Class


RollupKeys Property

[image]

Endeca Presentation API
Navigation..::..RollupKeys Property
Navigation Class See Also Send Feedback
Gets the rollup keys applicable for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecRollupKeyList RollupKeys { get; }
Visual Basic
Public Overridable ReadOnly Property RollupKeys As ERecRollupKeyList
    Get
Visual C++
public:
virtual property ERecRollupKeyList^ RollupKeys {
    ERecRollupKeyList^ get ();
}

Field Value

Rollup keys of this navigation. Even if there are no rollup keys, a valid ERecRollupKeyList will be returned.

Remarks

Method will always return a ERecRollupKeyList, but the list may be empty if no rollup keys are present.

See Also

Navigation Class


SortKeys Property

[image]

Endeca Presentation API
Navigation..::..SortKeys Property
Navigation Class See Also Send Feedback
Gets the sort keys applicable for this navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecSortKeyList SortKeys { get; }
Visual Basic
Public Overridable ReadOnly Property SortKeys As ERecSortKeyList
    Get
Visual C++
public:
virtual property ERecSortKeyList^ SortKeys {
    ERecSortKeyList^ get ();
}

Field Value

Sort keys of this navigation. Even if there are no sort keys, a valid ERecSortKeyList will be returned.

Remarks

Method will always return a ERecSortKeyList, but the list may be empty if no sort keys are present.

See Also

Navigation Class


Supplements Property

[image]

Endeca Presentation API
Navigation..::..Supplements Property
Navigation Class See Also Send Feedback
Gets the supplements to this navigation query result.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual SupplementList Supplements { get; }
Visual Basic
Public Overridable ReadOnly Property Supplements As SupplementList
    Get
Visual C++
public:
virtual property SupplementList^ Supplements {
    SupplementList^ get ();
}

Field Value

A SupplementList containing the supplements of this navigation.

Remarks

Returns an empty set if there are no supplements.

See Also

Navigation Class


TotalNumAggrERecs Property

[image]

Endeca Presentation API
Navigation..::..TotalNumAggrERecs Property
Navigation Class See Also Send Feedback
Gets the total number of aggregated records matching navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long TotalNumAggrERecs { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumAggrERecs As Long
    Get
Visual C++
public:
virtual property long long TotalNumAggrERecs {
    long long get ();
}

Field Value

Total number of aggregated records in this navigation query.

Remarks

While a navigation may contain aggregated records often a navigation object does not contain all the aggregated records in the navigation.

See Also

Navigation Class


TotalNumERecs Property

[image]

Endeca Presentation API
Navigation..::..TotalNumERecs Property
Navigation Class See Also Send Feedback
Gets the total number of records matching navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long TotalNumERecs { get; }
Visual Basic
Public Overridable ReadOnly Property TotalNumERecs As Long
    Get
Visual C++
public:
virtual property long long TotalNumERecs {
    long long get ();
}

Field Value

Total number of records in this navigation query.

Remarks

While a navigation may contain records often a navigation object does not contain all the records in the navigation.

See Also

Navigation Class


NavigationRefsList Class

[image]

Endeca Presentation API
NavigationRefsList Class
Members See Also Send Feedback
List of navigation refinement values exposed as an IList. Each element of the list is a DimValList referencing a navigation state.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class NavigationRefsList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class NavigationRefsList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class NavigationRefsList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..NavigationRefsList

See Also

NavigationRefsList Members


NavigationRefsList Members

[image] [image]

Endeca Presentation API
NavigationRefsList Members
NavigationRefsList Class Methods Properties See Also Send Feedback

The NavigationRefsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the NavigationRefsList.
Public method | CopyTo | Copies the entire NavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire NavigationRefsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the NavigationRefsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the NavigationRefsList.
Public property | IsFixedSize | Gets a value indicating whether the NavigationRefsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the NavigationRefsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the NavigationRefsList is synchronized (thread-safe).
Public property | Item | Gets the DimValList at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

NavigationRefsList Class


NavigationRefsList Methods

[image] [image]

Endeca Presentation API
NavigationRefsList Methods
NavigationRefsList Class See Also Send Feedback

The NavigationRefsList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether an element is in the NavigationRefsList.
Public method | CopyTo | Copies the entire NavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire NavigationRefsList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the NavigationRefsList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NavigationRefsList Class


Add Method

[image]

Endeca Presentation API
NavigationRefsList..::..Add Method
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the NavigationRefsList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


Clear Method

[image]

Endeca Presentation API
NavigationRefsList..::..Clear Method
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


Contains Method

[image]

Endeca Presentation API
NavigationRefsList..::..Contains Method
NavigationRefsList Class See Also Send Feedback
Determines whether an element is in the NavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the NavigationRefsList.

Return Value

true if item is found in the NavigationRefsList.

Implements

IList..::..Contains(Object)

See Also

NavigationRefsList Class


CopyTo Method

[image]

Endeca Presentation API
NavigationRefsList..::..CopyTo Method
NavigationRefsList Class See Also Send Feedback
Copies the entire NavigationRefsList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from NavigationRefsList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source NavigationRefsList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source NavigationRefsList be cast automatically to the type of the destination array.

See Also

NavigationRefsList Class


GetEnumerator Method

[image]

Endeca Presentation API
NavigationRefsList..::..GetEnumerator Method
NavigationRefsList Class See Also Send Feedback
Returns an enumerator for the entire NavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire NavigationRefsList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

NavigationRefsList Class


IndexOf Method

[image]

Endeca Presentation API
NavigationRefsList..::..IndexOf Method
NavigationRefsList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the NavigationRefsList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the NavigationRefsList.

Return Value

The zero-based index of the first occurrence of item within the entire NavigationRefsList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

NavigationRefsList Class


Insert Method

[image]

Endeca Presentation API
NavigationRefsList..::..Insert Method
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


Remove Method

[image]

Endeca Presentation API
NavigationRefsList..::..Remove Method
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from NavigationRefsList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


RemoveAt Method

[image]

Endeca Presentation API
NavigationRefsList..::..RemoveAt Method
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


NavigationRefsList Properties

[image] [image]

Endeca Presentation API
NavigationRefsList Properties
NavigationRefsList Class See Also Send Feedback

The NavigationRefsList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the NavigationRefsList.
Public property | IsFixedSize | Gets a value indicating whether the NavigationRefsList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the NavigationRefsList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the NavigationRefsList is synchronized (thread-safe).
Public property | Item | Gets the DimValList at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

NavigationRefsList Class


Count Property

[image]

Endeca Presentation API
NavigationRefsList..::..Count Property
NavigationRefsList Class See Also Send Feedback
Gets the number of elements actually contained in the NavigationRefsList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the NavigationRefsList.

Implements

ICollection..::..Count

See Also

NavigationRefsList Class


IsFixedSize Property

[image]

Endeca Presentation API
NavigationRefsList..::..IsFixedSize Property
NavigationRefsList Class See Also Send Feedback
Gets a value indicating whether the NavigationRefsList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the NavigationRefsList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

NavigationRefsList Class


IsReadOnly Property

[image]

Endeca Presentation API
NavigationRefsList..::..IsReadOnly Property
NavigationRefsList Class See Also Send Feedback
Gets a value indicating whether the NavigationRefsList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the NavigationRefsList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

NavigationRefsList Class


IsSynchronized Property

[image]

Endeca Presentation API
NavigationRefsList..::..IsSynchronized Property
NavigationRefsList Class See Also Send Feedback
Gets a value indicating whether access to the NavigationRefsList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the NavigationRefsList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

NavigationRefsList Class


Item Property

[image]

Endeca Presentation API
NavigationRefsList..::..Item Property
NavigationRefsList Class See Also Send Feedback
Gets the DimValList at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The DimValList at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

NavigationRefsList Class


SyncRoot Property

[image]

Endeca Presentation API
NavigationRefsList..::..SyncRoot Property
NavigationRefsList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the NavigationRefsList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

NavigationRefsList Class


OptionalBoolean Class

[image]

Endeca Presentation API
OptionalBoolean Class
Members See Also Send Feedback
Class representing an
CopyC#
bool
 or an unset value. Unlike an
CopyC#
bool
, an
CopyC#
OptionalBool
 may be empty.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class OptionalBoolean
Visual Basic
Public Class OptionalBoolean
Visual C++
public ref class OptionalBoolean

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..OptionalBoolean

See Also

OptionalBoolean Members


OptionalBoolean Members

[image] [image]

Endeca Presentation API
OptionalBoolean Members
OptionalBoolean Class Constructors Methods Properties See Also Send Feedback

The OptionalBoolean type exposes the following members.

Constructors

Name Description
Public method OptionalBoolean()()()()
Default constructor that creates and empty
CopyC#
OptionalBool
 object.
Public method OptionalBoolean(Boolean)
Constructor specifying an
CopyC#
bool

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property BooleanValue
Accessor that gets the
CopyC#
bool
 of this
CopyC#
OptionalBool
. set is not supported.
Public property Empty
Accessor that gets whether this
CopyC#
OptionalBool
 is empty. Set operation is not supported.

See Also

OptionalBoolean Class


OptionalBoolean Constructor

[image] [image]

Endeca Presentation API
OptionalBoolean Constructor
OptionalBoolean Class See Also Send Feedback

Overload List

Name Description
Public method OptionalBoolean()()()()
Default constructor that creates and empty
CopyC#
OptionalBool
 object.
Public method OptionalBoolean(Boolean)
Constructor specifying an
CopyC#
bool

See Also

OptionalBoolean Class
OptionalBoolean Members


OptionalBoolean Constructor

[image]

Endeca Presentation API
OptionalBoolean Constructor
OptionalBoolean Class See Also Send Feedback
Default constructor that creates and empty
CopyC#
OptionalBool
 object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalBoolean()
Visual Basic
Public Sub New
Visual C++
public:
OptionalBoolean()

See Also

OptionalBoolean Class
OptionalBoolean Overload


OptionalBoolean Constructor (Boolean)

[image]

Endeca Presentation API
OptionalBoolean Constructor (Boolean)
OptionalBoolean Class See Also Send Feedback
Constructor specifying an
CopyC#
bool

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalBoolean(
    bool val
)
Visual Basic
Public Sub New ( _
    val As Boolean _
)
Visual C++
public:
OptionalBoolean(
    bool val
)

Parameters

val
Type: System..::..Boolean
The value of the
CopyC#
bool
 held in the
CopyC#
OptionalBool
.

See Also

OptionalBoolean Class
OptionalBoolean Overload


OptionalBoolean Methods

[image] [image]

Endeca Presentation API
OptionalBoolean Methods
OptionalBoolean Class See Also Send Feedback

The OptionalBoolean type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionalBoolean Class


OptionalBoolean Properties

[image] [image]

Endeca Presentation API
OptionalBoolean Properties
OptionalBoolean Class See Also Send Feedback

The OptionalBoolean type exposes the following members.

Properties

Name Description
Public property BooleanValue
Accessor that gets the
CopyC#
bool
 of this
CopyC#
OptionalBool
. set is not supported.
Public property Empty
Accessor that gets whether this
CopyC#
OptionalBool
 is empty. Set operation is not supported.

See Also

OptionalBoolean Class


BooleanValue Property

[image]

Endeca Presentation API
OptionalBoolean..::..BooleanValue Property
OptionalBoolean Class See Also Send Feedback
Accessor that gets the
CopyC#
bool
 of this
CopyC#
OptionalBool
. set is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool BooleanValue { get; set; }
Visual Basic
Public Overridable Property BooleanValue As Boolean
    Get
    Set
Visual C++
public:
virtual property bool BooleanValue {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
System..::..NullReferenceException | If trying to get the content of an empty bool.
System..::..NotSupportedException | If trying to use the set functionality. Set is unsupported.

See Also

OptionalBoolean Class


Empty Property

[image]

Endeca Presentation API
OptionalBoolean..::..Empty Property
OptionalBoolean Class See Also Send Feedback
Accessor that gets whether this
CopyC#
OptionalBool
 is empty. Set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Empty { get; set; }
Visual Basic
Public Overridable Property Empty As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Empty {
    bool get ();
    void set (bool value);
}

Return Value

True if this
CopyC#
OptionalBool
 is empty, false otherwise.

Exceptions

Exception | Condition
System..::..NotSupportedException | If trying to use the set functionality. Set is unsupported.

See Also

OptionalBoolean Class


OptionalInt Class

[image]

Endeca Presentation API
OptionalInt Class
Members See Also Send Feedback
Class representing an
CopyC#
int
 or an unset value. Unlike an
CopyC#
int
, an
CopyC#
OptionalInt
 may be empty.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class OptionalInt
Visual Basic
Public Class OptionalInt
Visual C++
public ref class OptionalInt

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..OptionalInt

See Also

OptionalInt Members


OptionalInt Members

[image] [image]

Endeca Presentation API
OptionalInt Members
OptionalInt Class Constructors Methods Properties See Also Send Feedback

The OptionalInt type exposes the following members.

Constructors

Name Description
Public method OptionalInt()()()()
Default constructor that creates and empty
CopyC#
OptionalInt
 object.
Public method OptionalInt(Int32)
Constructor specifying an
CopyC#
int

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property Empty
Accessor that gets whether this
CopyC#
OptionalInt
 is empty. Set operation is not supported.
Public property IntValue
Accessor that gets the
CopyC#
int
 of this
CopyC#
OptionalInt
. set is not supported.

See Also

OptionalInt Class


OptionalInt Constructor

[image] [image]

Endeca Presentation API
OptionalInt Constructor
OptionalInt Class See Also Send Feedback

Overload List

Name Description
Public method OptionalInt()()()()
Default constructor that creates and empty
CopyC#
OptionalInt
 object.
Public method OptionalInt(Int32)
Constructor specifying an
CopyC#
int

See Also

OptionalInt Class
OptionalInt Members


OptionalInt Constructor

[image]

Endeca Presentation API
OptionalInt Constructor
OptionalInt Class See Also Send Feedback
Default constructor that creates and empty
CopyC#
OptionalInt
 object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalInt()
Visual Basic
Public Sub New
Visual C++
public:
OptionalInt()

See Also

OptionalInt Class
OptionalInt Overload


OptionalInt Constructor (Int32)

[image]

Endeca Presentation API
OptionalInt Constructor (Int32)
OptionalInt Class See Also Send Feedback
Constructor specifying an
CopyC#
int

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OptionalInt(
    int val
)
Visual Basic
Public Sub New ( _
    val As Integer _
)
Visual C++
public:
OptionalInt(
    int val
)

Parameters

val
Type: System..::..Int32
The value of the
CopyC#
int
 held in the
CopyC#
OptionalInt
.

See Also

OptionalInt Class
OptionalInt Overload


OptionalInt Methods

[image] [image]

Endeca Presentation API
OptionalInt Methods
OptionalInt Class See Also Send Feedback

The OptionalInt type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionalInt Class


OptionalInt Properties

[image] [image]

Endeca Presentation API
OptionalInt Properties
OptionalInt Class See Also Send Feedback

The OptionalInt type exposes the following members.

Properties

Name Description
Public property Empty
Accessor that gets whether this
CopyC#
OptionalInt
 is empty. Set operation is not supported.
Public property IntValue
Accessor that gets the
CopyC#
int
 of this
CopyC#
OptionalInt
. set is not supported.

See Also

OptionalInt Class


Empty Property

[image]

Endeca Presentation API
OptionalInt..::..Empty Property
OptionalInt Class See Also Send Feedback
Accessor that gets whether this
CopyC#
OptionalInt
 is empty. Set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Empty { get; set; }
Visual Basic
Public Overridable Property Empty As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Empty {
    bool get ();
    void set (bool value);
}

Return Value

True if this
CopyC#
OptionalInt
 is empty, false otherwise.

Exceptions

Exception | Condition
System..::..NotSupportedException | If trying to use the set functionality. Set is unsupported.

See Also

OptionalInt Class


IntValue Property

[image]

Endeca Presentation API
OptionalInt..::..IntValue Property
OptionalInt Class See Also Send Feedback
Accessor that gets the
CopyC#
int
 of this
CopyC#
OptionalInt
. set is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IntValue { get; set; }
Visual Basic
Public Overridable Property IntValue As Integer
    Get
    Set
Visual C++
public:
virtual property int IntValue {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::..NullReferenceException | If trying to get the content of an empty int.
System..::..NotSupportedException | If trying to use the set functionality. Set is unsupported.

See Also

OptionalInt Class


PartialENEQueryException Class

[image]

Endeca Presentation API
PartialENEQueryException Class
Members See Also Send Feedback
Exception that is triggered if there is a query that does not completely express a query with all necessary parameter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class PartialENEQueryException : ENEQueryException
Visual Basic
Public Class PartialENEQueryException _
    Inherits ENEQueryException
Visual C++
public ref class PartialENEQueryException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..PartialENEQueryException

See Also

PartialENEQueryException Members


PartialENEQueryException Members

[image] [image]

Endeca Presentation API
PartialENEQueryException Members
PartialENEQueryException Class Methods Properties See Also Send Feedback

The PartialENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PartialENEQueryException Class


PartialENEQueryException Methods

[image] [image]

Endeca Presentation API
PartialENEQueryException Methods
PartialENEQueryException Class See Also Send Feedback

The PartialENEQueryException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PartialENEQueryException Class


PartialENEQueryException Properties

[image] [image]

Endeca Presentation API
PartialENEQueryException Properties
PartialENEQueryException Class See Also Send Feedback

The PartialENEQueryException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PartialENEQueryException Class


Property Class

[image]

Endeca Presentation API
Property Class
Members See Also Send Feedback
Class representing an Endeca name/value property pair.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Property : IComparable
Visual Basic
Public Class Property _
    Implements IComparable
Visual C++
public ref class Property : IComparable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..Property

See Also

Property Members


Property Members

[image] [image]

Endeca Presentation API
Property Members
Property Class Methods Properties See Also Send Feedback

The Property type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares this object to o.
Public method | Equals | Compares the specified object with this for equality. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Generates the hash code for this object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Key | Gets the name of the property.
Public property | Value | Gets the value of the property.

See Also

Property Class


Property Methods

[image] [image]

Endeca Presentation API
Property Methods
Property Class See Also Send Feedback

The Property type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares this object to o.
Public method | Equals | Compares the specified object with this for equality. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Generates the hash code for this object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Property Class


CompareTo Method

[image]

Endeca Presentation API
Property..::..CompareTo Method
Property Class See Also Send Feedback
Compares this object to o.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int CompareTo(
    Object o
)
Visual Basic
Public Overridable Function CompareTo ( _
    o As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ o
)

Parameters

o
Type: System..::..Object
An object for comparison.

Return Value

Negative int if this is less than o, 0 if they are equal, and a positive int if this is greater than o.

Implements

IComparable..::..CompareTo(Object)

Remarks

Casts o as Property and returns a negative int if this is less than o, zero if they are the same, and a positive int if this is greater than o.

Exceptions

Exception | Condition
System..::..InvalidCastException | o can't be cast as a Property.

See Also

Property Class


Equals Method

[image]

Endeca Presentation API
Property..::..Equals Method
Property Class See Also Send Feedback
Compares the specified object with this for equality.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::..Object
An object to compare for quality.

Return Value

true if the object can be cast as a Property and has the same key and value and false if not.

See Also

Property Class


GetHashCode Method

[image]

Endeca Presentation API
Property..::..GetHashCode Method
Property Class See Also Send Feedback
Generates the hash code for this object.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code for this Property.

See Also

Property Class


Property Properties

[image] [image]

Endeca Presentation API
Property Properties
Property Class See Also Send Feedback

The Property type exposes the following members.

Properties

 | Name | Description
Public property | Key | Gets the name of the property.
Public property | Value | Gets the value of the property.

See Also

Property Class


Key Property

[image]

Endeca Presentation API
Property..::..Key Property
Property Class See Also Send Feedback
Gets the name of the property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As Object
    Get
Visual C++
public:
virtual property Object^ Key {
    Object^ get ();
}

Field Value

Key of the property.

Remarks

Returned object is of type String.

See Also

Property Class


Value Property

[image]

Endeca Presentation API
Property..::..Value Property
Property Class See Also Send Feedback
Gets the value of the property.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Value { get; }
Visual Basic
Public Overridable ReadOnly Property Value As Object
    Get
Visual C++
public:
virtual property Object^ Value {
    Object^ get ();
}

Field Value

Value of the property.

Remarks

Returned object is of type String.

See Also

Property Class


PropertyMap Class

[image]

Endeca Presentation API
PropertyMap Class
Members See Also Send Feedback
Class providing access to a collection of properties.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class PropertyMap : IDictionary,
    ICollection, IEnumerable
Visual Basic
Public Class PropertyMap _
    Implements IDictionary, ICollection, IEnumerable
Visual C++
public ref class PropertyMap : IDictionary,
    ICollection, IEnumerable

Remarks

PropertyMap offers methods to provide multi map behavior via GetValues(String) since a property set can include many values with the same key.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..PropertyMap

See Also

PropertyMap Members


PropertyMap Members

[image] [image]

Endeca Presentation API
PropertyMap Members
PropertyMap Class Methods Properties See Also Send Feedback

The PropertyMap type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether the PropertyMap contains an element with the specified key.
Public method | CopyTo | Copies the entire PropertyMap to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator for the PropertyMap.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Gets the values associated with this key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the PropertyMap.
Public property | EntrySet | Gets the set of all properties in this PropertyMap.
Public property | IsFixedSize | Gets a value indicating whether the PropertyMap has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the PropertyMap is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the PropertyMap is synchronized (thread-safe).
Public property | Item | Gets an element with the specified key. The set operation is not supported.
Public property | Keys | Gets an ICollection containing the keys of this PropertyMap.
Public property | SyncRoot | This operation is not supported.
Public property | Values | Gets an ICollection containing the values of this PropertyMap.

See Also

PropertyMap Class


PropertyMap Methods

[image] [image]

Endeca Presentation API
PropertyMap Methods
PropertyMap Class See Also Send Feedback

The PropertyMap type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether the PropertyMap contains an element with the specified key.
Public method | CopyTo | Copies the entire PropertyMap to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IDictionaryEnumerator for the PropertyMap.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Gets the values associated with this key.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyMap Class


Add Method

[image]

Endeca Presentation API
PropertyMap..::..Add Method
PropertyMap Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    Object key,
    Object value
)
Visual Basic
Public Overridable Sub Add ( _
    key As Object, _
    value As Object _
)
Visual C++
public:
virtual void Add(
    Object^ key,
    Object^ value
)

Parameters

key
Type: System..::..Object
The Object to use at the key of the element to add.
value
Type: System..::..Object
The Object to use at the value of the element to add.

Implements

IDictionary..::..Add(Object, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

PropertyMap Class


Clear Method

[image]

Endeca Presentation API
PropertyMap..::..Clear Method
PropertyMap Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IDictionary..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

PropertyMap Class


Contains Method

[image]

Endeca Presentation API
PropertyMap..::..Contains Method
PropertyMap Class See Also Send Feedback
Determines whether the PropertyMap contains an element with the specified key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object key
)
Visual Basic
Public Overridable Function Contains ( _
    key As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ key
)

Parameters

key
Type: System..::..Object
They key to locate in the PropertyMap.

Return Value

true if the PropertyMap contains an element with they key; otherwise, false.

Implements

IDictionary..::..Contains(Object)

See Also

PropertyMap Class


CopyTo Method

[image]

Endeca Presentation API
PropertyMap..::..CopyTo Method
PropertyMap Class See Also Send Feedback
Copies the entire PropertyMap to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the DictionaryEntry objects copied from PropertyMap. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source PropertyMap is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source PropertyMap be cast automatically to the type of the destination array.

See Also

PropertyMap Class


GetEnumerator Method

[image]

Endeca Presentation API
PropertyMap..::..GetEnumerator Method
PropertyMap Class See Also Send Feedback
Returns an IDictionaryEnumerator for the PropertyMap.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IDictionaryEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IDictionaryEnumerator
Visual C++
public:
virtual IDictionaryEnumerator^ GetEnumerator()

Return Value

An IDictionaryEnumerator for the PropertyMap.

Implements

IDictionary..::..GetEnumerator()()()()

See Also

PropertyMap Class


GetValues Method

[image]

Endeca Presentation API
PropertyMap..::..GetValues Method
PropertyMap Class See Also Send Feedback
Gets the values associated with this key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ArrayList GetValues(
    string key
)
Visual Basic
Public Overridable Function GetValues ( _
    key As String _
) As ArrayList
Visual C++
public:
virtual ArrayList^ GetValues(
    String^ key
)

Parameters

key
Type: System..::..String
Key used to get associated values.

Return Value

All the values associated with the key. Returns null when no values are associated with key.

See Also

PropertyMap Class


Remove Method

[image]

Endeca Presentation API
PropertyMap..::..Remove Method
PropertyMap Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object key
)
Visual Basic
Public Overridable Sub Remove ( _
    key As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ key
)

Parameters

key
Type: System..::..Object
The key of the element to remove.

Implements

IDictionary..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

PropertyMap Class


PropertyMap Properties

[image] [image]

Endeca Presentation API
PropertyMap Properties
PropertyMap Class See Also Send Feedback

The PropertyMap type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the PropertyMap.
Public property | EntrySet | Gets the set of all properties in this PropertyMap.
Public property | IsFixedSize | Gets a value indicating whether the PropertyMap has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the PropertyMap is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the PropertyMap is synchronized (thread-safe).
Public property | Item | Gets an element with the specified key. The set operation is not supported.
Public property | Keys | Gets an ICollection containing the keys of this PropertyMap.
Public property | SyncRoot | This operation is not supported.
Public property | Values | Gets an ICollection containing the values of this PropertyMap.

See Also

PropertyMap Class


Count Property

[image]

Endeca Presentation API
PropertyMap..::..Count Property
PropertyMap Class See Also Send Feedback
Gets the number of elements actually contained in the PropertyMap.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the PropertyMap.

Implements

ICollection..::..Count

See Also

PropertyMap Class


EntrySet Property

[image]

Endeca Presentation API
PropertyMap..::..EntrySet Property
PropertyMap Class See Also Send Feedback
Gets the set of all properties in this PropertyMap.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IList EntrySet { get; }
Visual Basic
Public Overridable ReadOnly Property EntrySet As IList
    Get
Visual C++
public:
virtual property IList^ EntrySet {
    IList^ get ();
}

Field Value

The set of all properties.

See Also

PropertyMap Class


IsFixedSize Property

[image]

Endeca Presentation API
PropertyMap..::..IsFixedSize Property
PropertyMap Class See Also Send Feedback
Gets a value indicating whether the PropertyMap has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the PropertyMap is a fixed size; otherwise, false. The default is true.

Implements

IDictionary..::..IsFixedSize

See Also

PropertyMap Class


IsReadOnly Property

[image]

Endeca Presentation API
PropertyMap..::..IsReadOnly Property
PropertyMap Class See Also Send Feedback
Gets a value indicating whether the PropertyMap is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the PropertyMap is read-only; otherwise, false. The default is true.

Implements

IDictionary..::..IsReadOnly

See Also

PropertyMap Class


IsSynchronized Property

[image]

Endeca Presentation API
PropertyMap..::..IsSynchronized Property
PropertyMap Class See Also Send Feedback
Gets a value indicating whether access to the PropertyMap is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the PropertyMap is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

PropertyMap Class


Item Property

[image]

Endeca Presentation API
PropertyMap..::..Item Property
PropertyMap Class See Also Send Feedback
Gets an element with the specified key. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    Object key
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    key As Object _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}

Parameters

key
Type: System..::..Object
The key of the element to get.

Field Value

An element with the specified key.

Implements

IDictionary..::..Item[([( Object])])

Remarks

If key has multiple values, only one value is returned. The returned object is of type String.

Exceptions

Exception | Condition
System..::..ArgumentNullException | key is a null reference.
System..::..NotSupportedException | Always for set operation.

See Also

PropertyMap Class


Keys Property

[image]

Endeca Presentation API
PropertyMap..::..Keys Property
PropertyMap Class See Also Send Feedback
Gets an ICollection containing the keys of this PropertyMap.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ICollection Keys { get; }
Visual Basic
Public Overridable ReadOnly Property Keys As ICollection
    Get
Visual C++
public:
virtual property ICollection^ Keys {
    ICollection^ get ();
}

Field Value

An ICollection containing the keys of this PropertyMap.

Implements

IDictionary..::..Keys

See Also

PropertyMap Class


SyncRoot Property

[image]

Endeca Presentation API
PropertyMap..::..SyncRoot Property
PropertyMap Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the PropertyMap.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

PropertyMap Class


Values Property

[image]

Endeca Presentation API
PropertyMap..::..Values Property
PropertyMap Class See Also Send Feedback
Gets an ICollection containing the values of this PropertyMap.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ICollection Values { get; }
Visual Basic
Public Overridable ReadOnly Property Values As ICollection
    Get
Visual C++
public:
virtual property ICollection^ Values {
    ICollection^ get ();
}

Field Value

An ICollection containing the values of this PropertyMap.

Implements

IDictionary..::..Values

See Also

PropertyMap Class


RangeFilter Class

[image]

Endeca Presentation API
RangeFilter Class
Members See Also Send Feedback
Class representing a range filter on a navigation record set.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class RangeFilter
Visual Basic
Public Class RangeFilter
Visual C++
public ref class RangeFilter

Remarks

A filter is composed of a record property name and a set of conditions that have to be true in order for a record to pass through the filter.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RangeFilter

See Also

RangeFilter Members


RangeFilter Members

[image] [image]

Endeca Presentation API
RangeFilter Members
RangeFilter Class Constructors Methods See Also Send Feedback

The RangeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RangeFilter | Constructor creating a filter.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of the filter. (Overrides Object..::..ToString()()()().)

See Also

RangeFilter Class


RangeFilter Constructor

[image]

Endeca Presentation API
RangeFilter Constructor
RangeFilter Class See Also Send Feedback
Constructor creating a filter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public RangeFilter(
    string filter
)
Visual Basic
Public Sub New ( _
    filter As String _
)
Visual C++
public:
RangeFilter(
    String^ filter
)

Parameters

filter
Type: System..::..String
Range filter statement.

Remarks

A filter consists of a numeric property ( float or int ), and a filter statement that consists of operators LT, LTEQ, GT, GTEQ, or BTWN followed by one or two constants. BTWN is treated as a bounded range, as it is treated inclusive. Examples:
CopyC#
"Price|LT 10.88"
"create_date|BTWN 20020131 20020214"
"modified|GTEQ 2002"
 Range filter statement format:
CopyC#
<b>'<property name>|<filter statement>'</b>
CopyC#
<filter statement> = '[<unbounded range>|<bounded range>]'
<unbounded range> = '[LT|LTEQ|GT|GTEQ] <constant>'
<bounded range> = 'BTWN <constant> <constant>'
<property name> = name of a numerical record property.
<constant> = numerical constant that defines the range bounds.

See Also

RangeFilter Class


RangeFilter Methods

[image] [image]

Endeca Presentation API
RangeFilter Methods
RangeFilter Class See Also Send Feedback

The RangeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of the filter. (Overrides Object..::..ToString()()()().)

See Also

RangeFilter Class


ToString Method

[image]

Endeca Presentation API
RangeFilter..::..ToString Method
RangeFilter Class See Also Send Feedback
Returns the string representation of the filter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the filter.

See Also

RangeFilter Class


RangeFilterList Class

[image]

Endeca Presentation API
RangeFilterList Class
Members See Also Send Feedback
Class that encapsulates a collection of range filters (RangeFilter objects).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class RangeFilterList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class RangeFilterList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class RangeFilterList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RangeFilterList

See Also

RangeFilterList Members


RangeFilterList Members

[image] [image]

Endeca Presentation API
RangeFilterList Members
RangeFilterList Class Constructors Methods Properties See Also Send Feedback

The RangeFilterList type exposes the following members.

Constructors

 | Name | Description
Public method | RangeFilterList | Default constructor that creates an empty list.

Methods

 | Name | Description
Public method | Add | Inserts the specified element at the specified position in this list.
Public method | Clear | Removes all the elements from the RangeFilterList.
Public method | Contains | Determines whether an element is in the RangeFilterList.
Public method | CopyTo | Copies the entire RangeFilterList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire RangeFilterList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the RangeFilterList or in a portion of it.
Public method | Insert | Inserts an element into the RangeFilterList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the RangeFilterList.
Public method | RemoveAt | Removes the element at the specified index of the RangeFilterList.
Public method | Set | Replaces the element at the specified position in this list with the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the RangeFilterList.
Public property | IsFixedSize | Gets a value indicating whether the RangeFilterList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the RangeFilterList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the RangeFilterList is synchronized (thread-safe).
Public property | Item | Gets and sets the RangeFilter at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

RangeFilterList Class


RangeFilterList Constructor

[image]

Endeca Presentation API
RangeFilterList Constructor
RangeFilterList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public RangeFilterList()
Visual Basic
Public Sub New
Visual C++
public:
RangeFilterList()

See Also

RangeFilterList Class


RangeFilterList Methods

[image] [image]

Endeca Presentation API
RangeFilterList Methods
RangeFilterList Class See Also Send Feedback

The RangeFilterList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Inserts the specified element at the specified position in this list.
Public method | Clear | Removes all the elements from the RangeFilterList.
Public method | Contains | Determines whether an element is in the RangeFilterList.
Public method | CopyTo | Copies the entire RangeFilterList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire RangeFilterList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the RangeFilterList or in a portion of it.
Public method | Insert | Inserts an element into the RangeFilterList at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the RangeFilterList.
Public method | RemoveAt | Removes the element at the specified index of the RangeFilterList.
Public method | Set | Replaces the element at the specified position in this list with the specified element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RangeFilterList Class


Add Method

[image]

Endeca Presentation API
RangeFilterList..::..Add Method
RangeFilterList Class See Also Send Feedback
Inserts the specified element at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to add.
elementAt
Type: System..::..Object
The element to be inserted.

Remarks

Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

RangeFilterList Class


Clear Method

[image]

Endeca Presentation API
RangeFilterList..::..Clear Method
RangeFilterList Class See Also Send Feedback
Removes all the elements from the RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The RangeFilterList is read-only. -or- The RangeFilterList has a fixed-size.

See Also

RangeFilterList Class


Contains Method

[image]

Endeca Presentation API
RangeFilterList..::..Contains Method
RangeFilterList Class See Also Send Feedback
Determines whether an element is in the RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the RangeFilterList.

Return Value

true if item is found in the RangeFilterList.

Implements

IList..::..Contains(Object)

See Also

RangeFilterList Class


CopyTo Method

[image]

Endeca Presentation API
RangeFilterList..::..CopyTo Method
RangeFilterList Class See Also Send Feedback
Copies the entire RangeFilterList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from RangeFilterList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source RangeFilterList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source RangeFilterList be cast automatically to the type of the destination array.

See Also

RangeFilterList Class


GetEnumerator Method

[image]

Endeca Presentation API
RangeFilterList..::..GetEnumerator Method
RangeFilterList Class See Also Send Feedback
Returns an enumerator for the entire RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire RangeFilterList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

RangeFilterList Class


IndexOf Method

[image]

Endeca Presentation API
RangeFilterList..::..IndexOf Method
RangeFilterList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the RangeFilterList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the RangeFilterList.

Return Value

The zero-based index of the first occurrence of item within the entire RangeFilterList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

RangeFilterList Class


Insert Method

[image]

Endeca Presentation API
RangeFilterList..::..Insert Method
RangeFilterList Class See Also Send Feedback
Inserts an element into the RangeFilterList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The RangeFilterList is read-only. -or- The RangeFilterList has a fixed-size.

See Also

RangeFilterList Class


Remove Method

[image] [image]

Endeca Presentation API
RangeFilterList..::..Remove Method
RangeFilterList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(Int32) | Removes the element at the specified position in this list.
Public method | Remove(Object) | Removes the first occurence of a specified object from the RangeFilterList.

See Also

RangeFilterList Class
RangeFilterList Members


Remove Method (Int32)

[image]

Endeca Presentation API
RangeFilterList..::..Remove Method (Int32)
RangeFilterList Class See Also Send Feedback
Removes the element at the specified position in this list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Return Value

The element previously at position index.

Remarks

Shifts any subsequent elements to the left (subtracts one from their indices). Returns the element that was removed from the list.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

RangeFilterList Class
Remove Overload


Remove Method (Object)

[image]

Endeca Presentation API
RangeFilterList..::..Remove Method (Object)
RangeFilterList Class See Also Send Feedback
Removes the first occurence of a specified object from the RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from RangeFilterList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The RangeFilterList is read-only. -or- The RangeFilterList has a fixed-size.

See Also

RangeFilterList Class
Remove Overload


RemoveAt Method

[image]

Endeca Presentation API
RangeFilterList..::..RemoveAt Method
RangeFilterList Class See Also Send Feedback
Removes the element at the specified index of the RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The RangeFilterList is read-only. -or- The RangeFilterList has a fixed-size.

See Also

RangeFilterList Class


Set Method

[image]

Endeca Presentation API
RangeFilterList..::..Set Method
RangeFilterList Class See Also Send Feedback
Replaces the element at the specified position in this list with the specified element.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Set(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Function Set ( _
    index As Integer, _
    elementAt As Object _
) As Object
Visual C++
public:
virtual Object^ Set(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to set.
elementAt
Type: System..::..Object
The element to be set.

Return Value

The element previously at index.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

RangeFilterList Class


RangeFilterList Properties

[image] [image]

Endeca Presentation API
RangeFilterList Properties
RangeFilterList Class See Also Send Feedback

The RangeFilterList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the RangeFilterList.
Public property | IsFixedSize | Gets a value indicating whether the RangeFilterList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the RangeFilterList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the RangeFilterList is synchronized (thread-safe).
Public property | Item | Gets and sets the RangeFilter at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

RangeFilterList Class


Count Property

[image]

Endeca Presentation API
RangeFilterList..::..Count Property
RangeFilterList Class See Also Send Feedback
Gets the number of elements actually contained in the RangeFilterList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the RangeFilterList.

Implements

ICollection..::..Count

See Also

RangeFilterList Class


IsFixedSize Property

[image]

Endeca Presentation API
RangeFilterList..::..IsFixedSize Property
RangeFilterList Class See Also Send Feedback
Gets a value indicating whether the RangeFilterList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the RangeFilterList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

RangeFilterList Class


IsReadOnly Property

[image]

Endeca Presentation API
RangeFilterList..::..IsReadOnly Property
RangeFilterList Class See Also Send Feedback
Gets a value indicating whether the RangeFilterList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the RangeFilterList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

RangeFilterList Class


IsSynchronized Property

[image]

Endeca Presentation API
RangeFilterList..::..IsSynchronized Property
RangeFilterList Class See Also Send Feedback
Gets a value indicating whether access to the RangeFilterList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the RangeFilterList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

RangeFilterList Class


Item Property

[image]

Endeca Presentation API
RangeFilterList..::..Item Property
RangeFilterList Class See Also Send Feedback
Gets and sets the RangeFilter at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The RangeFilter at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

RangeFilterList Class


SyncRoot Property

[image]

Endeca Presentation API
RangeFilterList..::..SyncRoot Property
RangeFilterList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the RangeFilterList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

RangeFilterList Class


RefinementConfig Class

[image]

Endeca Presentation API
RefinementConfig Class
Members See Also Send Feedback
Class representing a dynamic refinement config for a dimension value. This will determine how refinements are computed under this dimension value. Use of a dynamic refinement config will suppress generation of a "More..." child dimension value. You can determine whether there are more refinements than the ones shown by looking at the "DGraph.More" property on the refinements' parent dimension value. Any of the settings in this class can be set explicitly or defaulted to use the corresponding dimension's settings in developer studio.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class RefinementConfig : RefinementConfigBase
Visual Basic
Public Class RefinementConfig _
    Inherits RefinementConfigBase
Visual C++
public ref class RefinementConfig : public RefinementConfigBase

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RefinementConfigBase
Endeca.Navigation..::..RefinementConfig

See Also

RefinementConfig Members


RefinementConfig Members

[image] [image]

Endeca Presentation API
RefinementConfig Members
RefinementConfig Class Constructors Methods Properties See Also Send Feedback

The RefinementConfig type exposes the following members.

Constructors

Name Description
Public method RefinementConfig
Default constructor where the
CopyC#
dimValId
 sets the dimension value this dynamic refinement config is associated with.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId | (Inherited from RefinementConfigBase.)
Protected method | parseShowCounts | (Inherited from RefinementConfigBase.)
Protected method | parseSynonyms | (Inherited from RefinementConfigBase.)
Public method | ToString | Returns the string representation of the dynamic refinement config.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config. (Inherited from RefinementConfigBase.)
Public property | DynamicRanking | Accessor which gets and sets whether the dimension value has Dynamic Ranking enabled, disabled or defaults to the settings in Developer Studio.
Public property | DynamicRankOrder | Accessor which gets and sets whether the dimension value is sorted statically (ordered by refinement sort order), dynamically (ordered by refinement count). If set to use default then the dimension value will be sorted statically or dynamically depending on the dimension's setting in Developer Studio. This is only used if the dimension value has Dynamic Ranking enabled.
Public property | DynamicRefinementCount | Accessor which gets and sets the maximum number of dimension values (refinements) to return to the user. This is only used if the dimension value has Dynamic Ranking enabled.
Public property | Exposed | Accessor that gets and sets whether to expose the dimension value.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)

See Also

RefinementConfig Class


RefinementConfig Constructor

[image]

Endeca Presentation API
RefinementConfig Constructor
RefinementConfig Class See Also Send Feedback
Default constructor where the
CopyC#
dimValId
 sets the dimension value this dynamic refinement config is associated with.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public RefinementConfig(
    long dimValId
)
Visual Basic
Public Sub New ( _
    dimValId As Long _
)
Visual C++
public:
RefinementConfig(
    long long dimValId
)

Parameters

dimValId
Type: System..::..Int64
Specifies which dimension value this dynamic refinement config is associated with.

See Also

RefinementConfig Class


RefinementConfig Methods

[image] [image]

Endeca Presentation API
RefinementConfig Methods
RefinementConfig Class See Also Send Feedback

The RefinementConfig type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId | (Inherited from RefinementConfigBase.)
Protected method | parseShowCounts | (Inherited from RefinementConfigBase.)
Protected method | parseSynonyms | (Inherited from RefinementConfigBase.)
Public method | ToString | Returns the string representation of the dynamic refinement config.

See Also

RefinementConfig Class


ToString Method

[image]

Endeca Presentation API
RefinementConfig..::..ToString Method
RefinementConfig Class See Also Send Feedback
Returns the string representation of the dynamic refinement config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

The string representation of the dynamic refinement config.

See Also

RefinementConfig Class


RefinementConfig Properties

[image] [image]

Endeca Presentation API
RefinementConfig Properties
RefinementConfig Class See Also Send Feedback

The RefinementConfig type exposes the following members.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config. (Inherited from RefinementConfigBase.)
Public property | DynamicRanking | Accessor which gets and sets whether the dimension value has Dynamic Ranking enabled, disabled or defaults to the settings in Developer Studio.
Public property | DynamicRankOrder | Accessor which gets and sets whether the dimension value is sorted statically (ordered by refinement sort order), dynamically (ordered by refinement count). If set to use default then the dimension value will be sorted statically or dynamically depending on the dimension's setting in Developer Studio. This is only used if the dimension value has Dynamic Ranking enabled.
Public property | DynamicRefinementCount | Accessor which gets and sets the maximum number of dimension values (refinements) to return to the user. This is only used if the dimension value has Dynamic Ranking enabled.
Public property | Exposed | Accessor that gets and sets whether to expose the dimension value.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension. (Inherited from RefinementConfigBase.)

See Also

RefinementConfig Class


DynamicRanking Property

[image]

Endeca Presentation API
RefinementConfig..::..DynamicRanking Property
RefinementConfig Class See Also Send Feedback
Accessor which gets and sets whether the dimension value has Dynamic Ranking enabled, disabled or defaults to the settings in Developer Studio.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RefinementConfig..::..DynamicRankingState DynamicRanking { get; set; }
Visual Basic
Public Overridable Property DynamicRanking As RefinementConfig..::..DynamicRankingState
    Get
    Set
Visual C++
public:
virtual property RefinementConfig..::..DynamicRankingState DynamicRanking {
    RefinementConfig..::..DynamicRankingState get ();
    void set (RefinementConfig..::..DynamicRankingState value);
}

Field Value

A
CopyC#
DynamicRankingState
 enum value: ENABLED, DISABLED or DEFAULT which uses the settings from Dev Studio.

See Also

RefinementConfig Class


DynamicRankOrder Property

[image]

Endeca Presentation API
RefinementConfig..::..DynamicRankOrder Property
RefinementConfig Class See Also Send Feedback
Accessor which gets and sets whether the dimension value is sorted statically (ordered by refinement sort order), dynamically (ordered by refinement count). If set to use default then the dimension value will be sorted statically or dynamically depending on the dimension's setting in Developer Studio. This is only used if the dimension value has Dynamic Ranking enabled.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual RefinementConfig..::..DynamicRankOrderState DynamicRankOrder { get; set; }
Visual Basic
Public Overridable Property DynamicRankOrder As RefinementConfig..::..DynamicRankOrderState
    Get
    Set
Visual C++
public:
virtual property RefinementConfig..::..DynamicRankOrderState DynamicRankOrder {
    RefinementConfig..::..DynamicRankOrderState get ();
    void set (RefinementConfig..::..DynamicRankOrderState value);
}

Field Value

A
CopyC#
DynamicRankOrderState
 enum value: STATIC, DYNAMIC or DEFAULT which uses the settings from Dev Studio.

See Also

RefinementConfig Class


DynamicRefinementCount Property

[image]

Endeca Presentation API
RefinementConfig..::..DynamicRefinementCount Property
RefinementConfig Class See Also Send Feedback
Accessor which gets and sets the maximum number of dimension values (refinements) to return to the user. This is only used if the dimension value has Dynamic Ranking enabled.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual OptionalInt DynamicRefinementCount { get; set; }
Visual Basic
Public Overridable Property DynamicRefinementCount As OptionalInt
    Get
    Set
Visual C++
public:
virtual property OptionalInt^ DynamicRefinementCount {
    OptionalInt^ get ();
    void set (OptionalInt^ value);
}

Field Value

An
CopyC#
OptionalInt
 specifying the maximum number of dimension values to return. An empty
CopyC#
OptionalInt
 indicates to use the settings in Developer Studio. Defaults to an empty
CopyC#
OptionalInt
.

See Also

RefinementConfig Class


Exposed Property

[image]

Endeca Presentation API
RefinementConfig..::..Exposed Property
RefinementConfig Class See Also Send Feedback
Accessor that gets and sets whether to expose the dimension value.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Exposed { get; set; }
Visual Basic
Public Overridable Property Exposed As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Exposed {
    bool get ();
    void set (bool value);
}

Field Value

CopyC#
bool
 which is
CopyC#
TRUE
(dimension value is exposed) or
CopyC#
FALSE
 (dimension value is not exposed). Defaults to
CopyC#
TRUE
.

See Also

RefinementConfig Class


RefinementConfig.DynamicRankingState Enumeration

[image]

Endeca Presentation API
RefinementConfig..::..DynamicRankingState Enumeration
RefinementConfig Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public enum DynamicRankingState
Visual Basic
Public Enumeration DynamicRankingState
Visual C++
public enum class DynamicRankingState

Members

Member name | Description
DEFAULT |
DISABLED |
ENABLED |

See Also


RefinementConfig.DynamicRankOrderState Enumeration

[image]

Endeca Presentation API
RefinementConfig..::..DynamicRankOrderState Enumeration
RefinementConfig Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public enum DynamicRankOrderState
Visual Basic
Public Enumeration DynamicRankOrderState
Visual C++
public enum class DynamicRankOrderState

Members

Member name | Description
DEFAULT |
STATIC |
DYNAMIC |

See Also


RefinementConfigBase Class

[image]

Endeca Presentation API
RefinementConfigBase Class
Members See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class RefinementConfigBase
Visual Basic
Public Class RefinementConfigBase
Visual C++
public ref class RefinementConfigBase

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RefinementConfigBase
Endeca.Navigation..::..DimSearchRefinementConfig
Endeca.Navigation..::..RefinementConfig

See Also

RefinementConfigBase Members


RefinementConfigBase Members

[image] [image]

Endeca Presentation API
RefinementConfigBase Members
RefinementConfigBase Class Constructors Methods Properties See Also Send Feedback

The RefinementConfigBase type exposes the following members.

Constructors

Name Description
Public method RefinementConfigBase
Default constructor where the
CopyC#
dimValId
 specifies the dimension value this config is associated with.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId |
Protected method | parseShowCounts |
Protected method | parseSynonyms |
Public method | ToString | Returns the string representation of the config base.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension.
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension.

See Also

RefinementConfigBase Class


RefinementConfigBase Constructor

[image]

Endeca Presentation API
RefinementConfigBase Constructor
RefinementConfigBase Class See Also Send Feedback
Default constructor where the
CopyC#
dimValId
 specifies the dimension value this config is associated with.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public RefinementConfigBase(
    long dimValId
)
Visual Basic
Public Sub New ( _
    dimValId As Long _
)
Visual C++
public:
RefinementConfigBase(
    long long dimValId
)

Parameters

dimValId
Type: System..::..Int64
Specifies which dimension value this config is associated with.

See Also

RefinementConfigBase Class


RefinementConfigBase Methods

[image] [image]

Endeca Presentation API
RefinementConfigBase Methods
RefinementConfigBase Class See Also Send Feedback

The RefinementConfigBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | parseDimValId |
Protected method | parseShowCounts |
Protected method | parseSynonyms |
Public method | ToString | Returns the string representation of the config base.

See Also

RefinementConfigBase Class


parseDimValId Method

[image]

Endeca Presentation API
RefinementConfigBase..::..parseDimValId Method
RefinementConfigBase Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void parseDimValId(
    string val
)
Visual Basic
Protected Sub parseDimValId ( _
    val As String _
)
Visual C++
protected:
void parseDimValId(
    String^ val
)

Parameters

val
Type: System..::..String

See Also

RefinementConfigBase Class


parseShowCounts Method

[image]

Endeca Presentation API
RefinementConfigBase..::..parseShowCounts Method
RefinementConfigBase Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void parseShowCounts(
    string val
)
Visual Basic
Protected Sub parseShowCounts ( _
    val As String _
)
Visual C++
protected:
void parseShowCounts(
    String^ val
)

Parameters

val
Type: System..::..String

See Also

RefinementConfigBase Class


parseSynonyms Method

[image]

Endeca Presentation API
RefinementConfigBase..::..parseSynonyms Method
RefinementConfigBase Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void parseSynonyms(
    string val
)
Visual Basic
Protected Sub parseSynonyms ( _
    val As String _
)
Visual C++
protected:
void parseSynonyms(
    String^ val
)

Parameters

val
Type: System..::..String

See Also

RefinementConfigBase Class


ToString Method

[image]

Endeca Presentation API
RefinementConfigBase..::..ToString Method
RefinementConfigBase Class See Also Send Feedback
Returns the string representation of the config base.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

The string representation of the config base.

See Also

RefinementConfigBase Class


RefinementConfigBase Properties

[image] [image]

Endeca Presentation API
RefinementConfigBase Properties
RefinementConfigBase Class See Also Send Feedback

The RefinementConfigBase type exposes the following members.

Properties

 | Name | Description
Public property | DimensionValueId | Accessor which gets the Dimension value ID associated with this refinement config.
Public property | ShowCounts | Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension.
Public property | Synonyms | Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension.

See Also

RefinementConfigBase Class


DimensionValueId Property

[image]

Endeca Presentation API
RefinementConfigBase..::..DimensionValueId Property
RefinementConfigBase Class See Also Send Feedback
Accessor which gets the Dimension value ID associated with this refinement config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimensionValueId { get; set; }
Visual Basic
Public Overridable Property DimensionValueId As Long
    Get
    Set
Visual C++
public:
virtual property long long DimensionValueId {
    long long get ();
    void set (long long value);
}

Field Value

A
CopyC#
long
 number, strictly greater than 0.

Exceptions

Exception | Condition
System..::..NotSupportedException | Set is unsupported

See Also

RefinementConfigBase Class


ShowCounts Property

[image]

Endeca Presentation API
RefinementConfigBase..::..ShowCounts Property
RefinementConfigBase Class See Also Send Feedback
Accessor which gets/sets whether the config will show counts. This setting overrides the global setting for the dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual OptionalBoolean ShowCounts { get; set; }
Visual Basic
Public Overridable Property ShowCounts As OptionalBoolean
    Get
    Set
Visual C++
public:
virtual property OptionalBoolean^ ShowCounts {
    OptionalBoolean^ get ();
    void set (OptionalBoolean^ value);
}

Field Value

An
CopyC#
OptionalBoolean
 that specified whether the dimension value will show counts.
CopyC#
TRUE
 indicates the dimension value will display counts and
CopyC#
FALSE
 indicates the dimension value will not. If the
CopyC#
OptionalBoolean
 is empty, then the default value is
CopyC#
FALSE
.

See Also

RefinementConfigBase Class


Synonyms Property

[image]

Endeca Presentation API
RefinementConfigBase..::..Synonyms Property
RefinementConfigBase Class See Also Send Feedback
Accessor which gets/sets whether the synonyms will be returned. This setting overrides the global setting for the dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual OptionalBoolean Synonyms { get; set; }
Visual Basic
Public Overridable Property Synonyms As OptionalBoolean
    Get
    Set
Visual C++
public:
virtual property OptionalBoolean^ Synonyms {
    OptionalBoolean^ get ();
    void set (OptionalBoolean^ value);
}

Field Value

An
CopyC#
OptionalBoolean
 that specified whether the synonyms for the dimension value will be returned.
CopyC#
TRUE
 indicates that the synonyms will be returned and
CopyC#
FALSE
 indicates that the synonyms will not be returned. If the
CopyC#
OptionalBoolean
 is empty, then the default value is
CopyC#
FALSE
.

See Also

RefinementConfigBase Class


RefinementConfigList Class

[image]

Endeca Presentation API
RefinementConfigList Class
Members See Also Send Feedback
Class that encapsulates a collection of dynamic refinement config (RefinementConfig) objects.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class RefinementConfigList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class RefinementConfigList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class RefinementConfigList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..RefinementConfigList

See Also

RefinementConfigList Members


RefinementConfigList Members

[image] [image]

Endeca Presentation API
RefinementConfigList Members
RefinementConfigList Class Constructors Methods Properties See Also Send Feedback

The RefinementConfigList type exposes the following members.

Constructors

 | Name | Description
Public method | RefinementConfigList | Default constructor that creates an empty list.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
RefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the RefinementConfigList.
Public method Contains
Determines whether an element is in the RefinementConfigList.
Public method CopyTo
Copies the entire RefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire RefinementConfigList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the RefinementConfigList or in a portion of it.
Public method Insert
Inserts an element into the RefinementConfigList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the RefinementConfigList.
Public method RemoveAt
Removes the element at the specified index of the RefinementConfigList.
Public method ToString
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the RefinementConfigList.
Public property | IsFixedSize | Gets a value indicating whether the RefinementConfigList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the RefinementConfigList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the RefinementConfigList is synchronized (thread-safe).
Public property | Item | Gets and sets the RefinementConfig at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

RefinementConfigList Class


RefinementConfigList Constructor

[image]

Endeca Presentation API
RefinementConfigList Constructor
RefinementConfigList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public RefinementConfigList()
Visual Basic
Public Sub New
Visual C++
public:
RefinementConfigList()

See Also

RefinementConfigList Class


RefinementConfigList Methods

[image] [image]

Endeca Presentation API
RefinementConfigList Methods
RefinementConfigList Class See Also Send Feedback

The RefinementConfigList type exposes the following members.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
RefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the RefinementConfigList.
Public method Contains
Determines whether an element is in the RefinementConfigList.
Public method CopyTo
Copies the entire RefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire RefinementConfigList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the RefinementConfigList or in a portion of it.
Public method Insert
Inserts an element into the RefinementConfigList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the RefinementConfigList.
Public method RemoveAt
Removes the element at the specified index of the RefinementConfigList.
Public method ToString
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

See Also

RefinementConfigList Class


Add Method

[image]

Endeca Presentation API
RefinementConfigList..::..Add Method
RefinementConfigList Class See Also Send Feedback
Inserts the specified
CopyC#
RefinementConfig
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The offset of the element
elementAt
Type: System..::..Object
The element to be inserted.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If index is out of range.

See Also

RefinementConfigList Class


Clear Method

[image]

Endeca Presentation API
RefinementConfigList..::..Clear Method
RefinementConfigList Class See Also Send Feedback
Removes all the elements from the RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The RefinementConfigList is read-only. -or- The RefinementConfigList has a fixed-size.

See Also

RefinementConfigList Class


Contains Method

[image]

Endeca Presentation API
RefinementConfigList..::..Contains Method
RefinementConfigList Class See Also Send Feedback
Determines whether an element is in the RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the RefinementConfigList.

Return Value

true if item is found in the RefinementConfigList.

Implements

IList..::..Contains(Object)

See Also

RefinementConfigList Class


CopyTo Method

[image]

Endeca Presentation API
RefinementConfigList..::..CopyTo Method
RefinementConfigList Class See Also Send Feedback
Copies the entire RefinementConfigList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from RefinementConfigList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source RefinementConfigList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source RefinementConfigList be cast automatically to the type of the destination array.

See Also

RefinementConfigList Class


GetEnumerator Method

[image]

Endeca Presentation API
RefinementConfigList..::..GetEnumerator Method
RefinementConfigList Class See Also Send Feedback
Returns an enumerator for the entire RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire RefinementConfigList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

RefinementConfigList Class


IndexOf Method

[image]

Endeca Presentation API
RefinementConfigList..::..IndexOf Method
RefinementConfigList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the RefinementConfigList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the RefinementConfigList.

Return Value

The zero-based index of the first occurrence of item within the entire RefinementConfigList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

RefinementConfigList Class


Insert Method

[image]

Endeca Presentation API
RefinementConfigList..::..Insert Method
RefinementConfigList Class See Also Send Feedback
Inserts an element into the RefinementConfigList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The RefinementConfigList is read-only. -or- The RefinementConfigList has a fixed-size.

See Also

RefinementConfigList Class


Remove Method

[image]

Endeca Presentation API
RefinementConfigList..::..Remove Method
RefinementConfigList Class See Also Send Feedback
Removes the first occurence of a specified object from the RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from RefinementConfigList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The RefinementConfigList is read-only. -or- The RefinementConfigList has a fixed-size.

See Also

RefinementConfigList Class


RemoveAt Method

[image]

Endeca Presentation API
RefinementConfigList..::..RemoveAt Method
RefinementConfigList Class See Also Send Feedback
Removes the element at the specified index of the RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The RefinementConfigList is read-only. -or- The RefinementConfigList has a fixed-size.

See Also

RefinementConfigList Class


ToString Method

[image]

Endeca Presentation API
RefinementConfigList..::..ToString Method
RefinementConfigList Class See Also Send Feedback
Takes the individual refinement configs in the list and turns them into a string representation that can later be inserted into a URL.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.RefinementConfigList.ToString"]

See Also

RefinementConfigList Class


RefinementConfigList Properties

[image] [image]

Endeca Presentation API
RefinementConfigList Properties
RefinementConfigList Class See Also Send Feedback

The RefinementConfigList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the RefinementConfigList.
Public property | IsFixedSize | Gets a value indicating whether the RefinementConfigList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the RefinementConfigList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the RefinementConfigList is synchronized (thread-safe).
Public property | Item | Gets and sets the RefinementConfig at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

RefinementConfigList Class


Count Property

[image]

Endeca Presentation API
RefinementConfigList..::..Count Property
RefinementConfigList Class See Also Send Feedback
Gets the number of elements actually contained in the RefinementConfigList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the RefinementConfigList.

Implements

ICollection..::..Count

See Also

RefinementConfigList Class


IsFixedSize Property

[image]

Endeca Presentation API
RefinementConfigList..::..IsFixedSize Property
RefinementConfigList Class See Also Send Feedback
Gets a value indicating whether the RefinementConfigList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the RefinementConfigList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

RefinementConfigList Class


IsReadOnly Property

[image]

Endeca Presentation API
RefinementConfigList..::..IsReadOnly Property
RefinementConfigList Class See Also Send Feedback
Gets a value indicating whether the RefinementConfigList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the RefinementConfigList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

RefinementConfigList Class


IsSynchronized Property

[image]

Endeca Presentation API
RefinementConfigList..::..IsSynchronized Property
RefinementConfigList Class See Also Send Feedback
Gets a value indicating whether access to the RefinementConfigList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the RefinementConfigList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

RefinementConfigList Class


Item Property

[image]

Endeca Presentation API
RefinementConfigList..::..Item Property
RefinementConfigList Class See Also Send Feedback
Gets and sets the RefinementConfig at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The RefinementConfig at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

RefinementConfigList Class


SyncRoot Property

[image]

Endeca Presentation API
RefinementConfigList..::..SyncRoot Property
RefinementConfigList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the RefinementConfigList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

RefinementConfigList Class


StratifiedDimVal Class

[image]

Endeca Presentation API
StratifiedDimVal Class
Members See Also Send Feedback
Class representing the assignment of a dimension value to a specific stratum for sorting. Dimension values are sorted by their assigned strata and then by whatever the refinement sorting method for the dimension is (via static ranking, dynamic ranking, dynamic refinement configs, etc). Dimension values not explicitly assigned a strata are assigned the strata 0.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class StratifiedDimVal
Visual Basic
Public Class StratifiedDimVal
Visual C++
public ref class StratifiedDimVal

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..StratifiedDimVal

See Also

StratifiedDimVal Members


StratifiedDimVal Members

[image] [image]

Endeca Presentation API
StratifiedDimVal Members
StratifiedDimVal Class Constructors Methods Properties See Also Send Feedback

The StratifiedDimVal type exposes the following members.

Constructors

 | Name | Description
Public method | StratifiedDimVal | Initializes a new instance of the StratifiedDimVal class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | parse |
Public method | ToString | Returns the string representation of the stratified dim val

Properties

 | Name | Description
Public property | DimValId | Gets the dimension value ID.
Public property | Stratum | Gets the stratum.

See Also

StratifiedDimVal Class


StratifiedDimVal Constructor

[image]

Endeca Presentation API
StratifiedDimVal Constructor
StratifiedDimVal Class See Also Send Feedback
Initializes a new instance of the StratifiedDimVal class

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public StratifiedDimVal(
    int stratum_,
    long dimValId_
)
Visual Basic
Public Sub New ( _
    stratum_ As Integer, _
    dimValId_ As Long _
)
Visual C++
public:
StratifiedDimVal(
    int stratum_,
    long long dimValId_
)

Parameters

stratum_
Type: System..::..Int32
dimValId_
Type: System..::..Int64

See Also

StratifiedDimVal Class


StratifiedDimVal Methods

[image] [image]

Endeca Presentation API
StratifiedDimVal Methods
StratifiedDimVal Class See Also Send Feedback

The StratifiedDimVal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | parse |
Public method | ToString | Returns the string representation of the stratified dim val

See Also

StratifiedDimVal Class


parse Method

[image]

Endeca Presentation API
StratifiedDimVal..::..parse Method
StratifiedDimVal Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static StratifiedDimVal parse(
    string val
)
Visual Basic
Public Shared Function parse ( _
    val As String _
) As StratifiedDimVal
Visual C++
public:
static StratifiedDimVal^ parse(
    String^ val
)

Parameters

val
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.StratifiedDimVal.parse(System.String)"]

See Also

StratifiedDimVal Class


ToString Method

[image]

Endeca Presentation API
StratifiedDimVal..::..ToString Method
StratifiedDimVal Class See Also Send Feedback
Returns the string representation of the stratified dim val

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

Returns the string representation of the stratified dim val.

See Also

StratifiedDimVal Class


StratifiedDimVal Properties

[image] [image]

Endeca Presentation API
StratifiedDimVal Properties
StratifiedDimVal Class See Also Send Feedback

The StratifiedDimVal type exposes the following members.

Properties

 | Name | Description
Public property | DimValId | Gets the dimension value ID.
Public property | Stratum | Gets the stratum.

See Also

StratifiedDimVal Class


DimValId Property

[image]

Endeca Presentation API
StratifiedDimVal..::..DimValId Property
StratifiedDimVal Class See Also Send Feedback
Gets the dimension value ID.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual long DimValId { get; set; }
Visual Basic
Public Overridable Property DimValId As Long
    Get
    Set
Visual C++
public:
virtual property long long DimValId {
    long long get ();
    void set (long long value);
}

Field Value

ID of the dimension value to be stratified.

See Also

StratifiedDimVal Class


Stratum Property

[image]

Endeca Presentation API
StratifiedDimVal..::..Stratum Property
StratifiedDimVal Class See Also Send Feedback
Gets the stratum.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Stratum { get; set; }
Visual Basic
Public Overridable Property Stratum As Integer
    Get
    Set
Visual C++
public:
virtual property int Stratum {
    int get ();
    void set (int value);
}

Field Value

Stratum for the dimension value.

See Also

StratifiedDimVal Class


StratifiedDimValList Class

[image]

Endeca Presentation API
StratifiedDimValList Class
Members See Also Send Feedback
Class that encapsulates a collection of stratified dimension values (StratifiedDimVal) objects.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class StratifiedDimValList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class StratifiedDimValList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class StratifiedDimValList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..StratifiedDimValList

See Also

StratifiedDimValList Members


StratifiedDimValList Members

[image] [image]

Endeca Presentation API
StratifiedDimValList Members
StratifiedDimValList Class Constructors Methods Properties See Also Send Feedback

The StratifiedDimValList type exposes the following members.

Constructors

 | Name | Description
Public method | StratifiedDimValList | Default constructor that creates an empty list.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
StratifiedDimVal
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the StratifiedDimValList.
Public method Contains
Determines whether an element is in the StratifiedDimValList.
Public method CopyTo
Copies the entire StratifiedDimValList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire StratifiedDimValList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the StratifiedDimValList or in a portion of it.
Public method Insert
Inserts an element into the StratifiedDimValList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the StratifiedDimValList.
Public method RemoveAt
Removes the element at the specified index of the StratifiedDimValList.
Public method ToString
Returns the string representation of the list of stratified dimension values.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the StratifiedDimValList.
Public property | IsFixedSize | Gets a value indicating whether the StratifiedDimValList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the StratifiedDimValList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the StratifiedDimValList is synchronized (thread-safe).
Public property | Item | Gets and sets the StratifiedDimVal at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

StratifiedDimValList Class


StratifiedDimValList Constructor

[image]

Endeca Presentation API
StratifiedDimValList Constructor
StratifiedDimValList Class See Also Send Feedback
Default constructor that creates an empty list.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public StratifiedDimValList()
Visual Basic
Public Sub New
Visual C++
public:
StratifiedDimValList()

See Also

StratifiedDimValList Class


StratifiedDimValList Methods

[image] [image]

Endeca Presentation API
StratifiedDimValList Methods
StratifiedDimValList Class See Also Send Feedback

The StratifiedDimValList type exposes the following members.

Methods

Name Description
Public method Add
Inserts the specified
CopyC#
StratifiedDimVal
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).
Public method Clear
Removes all the elements from the StratifiedDimValList.
Public method Contains
Determines whether an element is in the StratifiedDimValList.
Public method CopyTo
Copies the entire StratifiedDimValList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator for the entire StratifiedDimValList.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method IndexOf
Returns the zero-based index of the first occurrence of a value in the StratifiedDimValList or in a portion of it.
Public method Insert
Inserts an element into the StratifiedDimValList at the specified index.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Remove
Removes the first occurence of a specified object from the StratifiedDimValList.
Public method RemoveAt
Removes the element at the specified index of the StratifiedDimValList.
Public method ToString
Returns the string representation of the list of stratified dimension values.

See Also

StratifiedDimValList Class


Add Method

[image]

Endeca Presentation API
StratifiedDimValList..::..Add Method
StratifiedDimValList Class See Also Send Feedback
Inserts the specified
CopyC#
StratifiedDimVal
 at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Add(
    int index,
    Object elementAt
)
Visual Basic
Public Overridable Sub Add ( _
    index As Integer, _
    elementAt As Object _
)
Visual C++
public:
virtual void Add(
    int index,
    Object^ elementAt
)

Parameters

index
Type: System..::..Int32
The offset of the element
elementAt
Type: System..::..Object
The element to be inserted.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | If index is out of range.

See Also

StratifiedDimValList Class


Clear Method

[image]

Endeca Presentation API
StratifiedDimValList..::..Clear Method
StratifiedDimValList Class See Also Send Feedback
Removes all the elements from the StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | The StratifiedDimValList is read-only. -or- The StratifiedDimValList has a fixed-size.

See Also

StratifiedDimValList Class


Contains Method

[image]

Endeca Presentation API
StratifiedDimValList..::..Contains Method
StratifiedDimValList Class See Also Send Feedback
Determines whether an element is in the StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the StratifiedDimValList.

Return Value

true if item is found in the StratifiedDimValList.

Implements

IList..::..Contains(Object)

See Also

StratifiedDimValList Class


CopyTo Method

[image]

Endeca Presentation API
StratifiedDimValList..::..CopyTo Method
StratifiedDimValList Class See Also Send Feedback
Copies the entire StratifiedDimValList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from StratifiedDimValList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source StratifiedDimValList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source StratifiedDimValList be cast automatically to the type of the destination array.

See Also

StratifiedDimValList Class


GetEnumerator Method

[image]

Endeca Presentation API
StratifiedDimValList..::..GetEnumerator Method
StratifiedDimValList Class See Also Send Feedback
Returns an enumerator for the entire StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire StratifiedDimValList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

StratifiedDimValList Class


IndexOf Method

[image]

Endeca Presentation API
StratifiedDimValList..::..IndexOf Method
StratifiedDimValList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the StratifiedDimValList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the StratifiedDimValList.

Return Value

The zero-based index of the first occurrence of item within the entire StratifiedDimValList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

StratifiedDimValList Class


Insert Method

[image]

Endeca Presentation API
StratifiedDimValList..::..Insert Method
StratifiedDimValList Class See Also Send Feedback
Inserts an element into the StratifiedDimValList at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The StratifiedDimValList is read-only. -or- The StratifiedDimValList has a fixed-size.

See Also

StratifiedDimValList Class


Remove Method

[image]

Endeca Presentation API
StratifiedDimValList..::..Remove Method
StratifiedDimValList Class See Also Send Feedback
Removes the first occurence of a specified object from the StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from StratifiedDimValList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | The StratifiedDimValList is read-only. -or- The StratifiedDimValList has a fixed-size.

See Also

StratifiedDimValList Class


RemoveAt Method

[image]

Endeca Presentation API
StratifiedDimValList..::..RemoveAt Method
StratifiedDimValList Class See Also Send Feedback
Removes the element at the specified index of the StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | The StratifiedDimValList is read-only. -or- The StratifiedDimValList has a fixed-size.

See Also

StratifiedDimValList Class


ToString Method

[image]

Endeca Presentation API
StratifiedDimValList..::..ToString Method
StratifiedDimValList Class See Also Send Feedback
Returns the string representation of the list of stratified dimension values.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToString()
Visual Basic
Public Overridable Function ToString As String
Visual C++
public:
virtual String^ ToString()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.StratifiedDimValList.ToString"]

See Also

StratifiedDimValList Class


StratifiedDimValList Properties

[image] [image]

Endeca Presentation API
StratifiedDimValList Properties
StratifiedDimValList Class See Also Send Feedback

The StratifiedDimValList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the StratifiedDimValList.
Public property | IsFixedSize | Gets a value indicating whether the StratifiedDimValList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the StratifiedDimValList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the StratifiedDimValList is synchronized (thread-safe).
Public property | Item | Gets and sets the StratifiedDimVal at the specified index.
Public property | SyncRoot | This operation is not supported.

See Also

StratifiedDimValList Class


Count Property

[image]

Endeca Presentation API
StratifiedDimValList..::..Count Property
StratifiedDimValList Class See Also Send Feedback
Gets the number of elements actually contained in the StratifiedDimValList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the StratifiedDimValList.

Implements

ICollection..::..Count

See Also

StratifiedDimValList Class


IsFixedSize Property

[image]

Endeca Presentation API
StratifiedDimValList..::..IsFixedSize Property
StratifiedDimValList Class See Also Send Feedback
Gets a value indicating whether the StratifiedDimValList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the StratifiedDimValList is a fixed size; otherwise, false. The default is false.

Implements

IList..::..IsFixedSize

See Also

StratifiedDimValList Class


IsReadOnly Property

[image]

Endeca Presentation API
StratifiedDimValList..::..IsReadOnly Property
StratifiedDimValList Class See Also Send Feedback
Gets a value indicating whether the StratifiedDimValList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the StratifiedDimValList is read-only; otherwise, false. The default is false.

Implements

IList..::..IsReadOnly

See Also

StratifiedDimValList Class


IsSynchronized Property

[image]

Endeca Presentation API
StratifiedDimValList..::..IsSynchronized Property
StratifiedDimValList Class See Also Send Feedback
Gets a value indicating whether access to the StratifiedDimValList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the StratifiedDimValList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

StratifiedDimValList Class


Item Property

[image]

Endeca Presentation API
StratifiedDimValList..::..Item Property
StratifiedDimValList Class See Also Send Feedback
Gets and sets the StratifiedDimVal at the specified index.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The StratifiedDimVal at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.

See Also

StratifiedDimValList Class


SyncRoot Property

[image]

Endeca Presentation API
StratifiedDimValList..::..SyncRoot Property
StratifiedDimValList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the StratifiedDimValList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

StratifiedDimValList Class


Supplement Class

[image]

Endeca Presentation API
Supplement Class
Members See Also Send Feedback
Class representing supplemental information and data for a navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Supplement : IPropertyContainer
Visual Basic
Public Class Supplement _
    Implements IPropertyContainer
Visual C++
public ref class Supplement : IPropertyContainer

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..Supplement

See Also

Supplement Members


Supplement Members

[image] [image]

Endeca Presentation API
Supplement Members
Supplement Class Methods Properties See Also Send Feedback

The Supplement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ERecs | Gets the Endeca records of this Supplement.
Public property | NavigationRefs | Gets the navigation state queries referenced by this Supplement.
Public property | Properties | Gets the properties of this Supplement.

See Also

Supplement Class


Supplement Methods

[image] [image]

Endeca Presentation API
Supplement Methods
Supplement Class See Also Send Feedback

The Supplement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Supplement Class


Supplement Properties

[image] [image]

Endeca Presentation API
Supplement Properties
Supplement Class See Also Send Feedback

The Supplement type exposes the following members.

Properties

 | Name | Description
Public property | ERecs | Gets the Endeca records of this Supplement.
Public property | NavigationRefs | Gets the navigation state queries referenced by this Supplement.
Public property | Properties | Gets the properties of this Supplement.

See Also

Supplement Class


ERecs Property

[image]

Endeca Presentation API
Supplement..::..ERecs Property
Supplement Class See Also Send Feedback
Gets the Endeca records of this Supplement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ERecList ERecs { get; }
Visual Basic
Public Overridable ReadOnly Property ERecs As ERecList
    Get
Visual C++
public:
virtual property ERecList^ ERecs {
    ERecList^ get ();
}

Field Value

Endeca records (encapsulated in an ERecList) of this supplement.

Remarks

Returns an empty record list if there are no records assocaited with this supplement.

See Also

Supplement Class


NavigationRefs Property

[image]

Endeca Presentation API
Supplement..::..NavigationRefs Property
Supplement Class See Also Send Feedback
Gets the navigation state queries referenced by this Supplement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual NavigationRefsList NavigationRefs { get; }
Visual Basic
Public Overridable ReadOnly Property NavigationRefs As NavigationRefsList
    Get
Visual C++
public:
virtual property NavigationRefsList^ NavigationRefs {
    NavigationRefsList^ get ();
}

Field Value

Navigation references of this supplement.

Remarks

Returns an empty value list list if there are no navigation state references.

See Also

Supplement Class


Properties Property

[image]

Endeca Presentation API
Supplement..::..Properties Property
Supplement Class See Also Send Feedback
Gets the properties of this Supplement.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual PropertyMap Properties { get; }
Visual Basic
Public Overridable ReadOnly Property Properties As PropertyMap
    Get
Visual C++
public:
virtual property PropertyMap^ Properties {
    PropertyMap^ get ();
}

Field Value

Properties of this supplement.

Implements

IPropertyContainer..::..Properties

Remarks

Returns an empty set of properties if there are no properties associated with this supplement.

See Also

Supplement Class


SupplementList Class

[image]

Endeca Presentation API
SupplementList Class
Members See Also Send Feedback
List of supplements (Supplement objects) exposed as an IList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class SupplementList : IList,
    ICollection, IEnumerable
Visual Basic
Public Class SupplementList _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class SupplementList : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..SupplementList

See Also

SupplementList Members


SupplementList Members

[image] [image]

Endeca Presentation API
SupplementList Members
SupplementList Class Methods Properties See Also Send Feedback

The SupplementList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether a supplement is in the SupplementList.
Public method | CopyTo | Copies the entire SupplementList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire SupplementList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the SupplementList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the SupplementList.
Public property | IsFixedSize | Gets a value indicating whether the SupplementList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the SupplementList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the SupplementList is synchronized (thread-safe).
Public property | Item | Gets the Supplement at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

SupplementList Class


SupplementList Methods

[image] [image]

Endeca Presentation API
SupplementList Methods
SupplementList Class See Also Send Feedback

The SupplementList type exposes the following members.

Methods

 | Name | Description
Public method | Add | This operation is not supported.
Public method | Clear | This operation is not supported.
Public method | Contains | Determines whether a supplement is in the SupplementList.
Public method | CopyTo | Copies the entire SupplementList to a compatible one-dimensional Array, starting at the specified index of the target array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator for the entire SupplementList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of a value in the SupplementList or in a portion of it.
Public method | Insert | This operation is not supported.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | This operation is not supported.
Public method | RemoveAt | This operation is not supported.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupplementList Class


Add Method

[image]

Endeca Presentation API
SupplementList..::..Add Method
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Add(
    Object item
)
Visual Basic
Public Overridable Function Add ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int Add(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to be added to the end of the SupplementList.

Return Value

Nothing.

Implements

IList..::..Add(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


Clear Method

[image]

Endeca Presentation API
SupplementList..::..Clear Method
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

IList..::..Clear()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


Contains Method

[image]

Endeca Presentation API
SupplementList..::..Contains Method
SupplementList Class See Also Send Feedback
Determines whether a supplement is in the SupplementList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Contains(
    Object item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Supplement to locate in the SupplementList.

Return Value

true if item is found in the SupplementList.

Implements

IList..::..Contains(Object)

See Also

SupplementList Class


CopyTo Method

[image]

Endeca Presentation API
SupplementList..::..CopyTo Method
SupplementList Class See Also Send Feedback
Copies the entire SupplementList to a compatible one-dimensional Array, starting at the specified index of the target array.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int arrayIndex
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from SupplementList. The Array must have zero-based indexing.
arrayIndex
Type: System..::..Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

Remarks

The specified array must be of a compatible type.

This method uses Copy(Array, Array, Int32) to copy the elements.

Exceptions

Exception | Condition
System..::..ArgumentNullException | array is a null reference.
System..::..ArgumentOutOfRangeException | arrayIndex is less than zero.
System..::..ArgumentException | array is multidimensional. -or- arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source SupplementList is greater than the available space from arrayIndex to the end of the destination array.
System..::..InvalidCastException | The type of the source SupplementList be cast automatically to the type of the destination array.

See Also

SupplementList Class


GetEnumerator Method

[image]

Endeca Presentation API
SupplementList..::..GetEnumerator Method
SupplementList Class See Also Send Feedback
Returns an enumerator for the entire SupplementList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

An IEnumerator for the entire SupplementList

Implements

IEnumerable..::..GetEnumerator()()()()

Remarks

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

See Also

SupplementList Class


IndexOf Method

[image]

Endeca Presentation API
SupplementList..::..IndexOf Method
SupplementList Class See Also Send Feedback
Returns the zero-based index of the first occurrence of a value in the SupplementList or in a portion of it.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int IndexOf(
    Object item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to locate in the SupplementList.

Return Value

The zero-based index of the first occurrence of item within the entire SupplementList, if found; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

SupplementList Class


Insert Method

[image]

Endeca Presentation API
SupplementList..::..Insert Method
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Insert(
    int index,
    Object item
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    item As Object _
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ item
)

Parameters

index
Type: System..::..Int32
The zero-based index at which item should be inserted.
item
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


Remove Method

[image]

Endeca Presentation API
SupplementList..::..Remove Method
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void Remove(
    Object item
)
Visual Basic
Public Overridable Sub Remove ( _
    item As Object _
)
Visual C++
public:
virtual void Remove(
    Object^ item
)

Parameters

item
Type: System..::..Object
The Object to remove from SupplementList.

Implements

IList..::..Remove(Object)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


RemoveAt Method

[image]

Endeca Presentation API
SupplementList..::..RemoveAt Method
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the element to remove.

Implements

IList..::..RemoveAt(Int32)

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


SupplementList Properties

[image] [image]

Endeca Presentation API
SupplementList Properties
SupplementList Class See Also Send Feedback

The SupplementList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the SupplementList.
Public property | IsFixedSize | Gets a value indicating whether the SupplementList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the SupplementList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the SupplementList is synchronized (thread-safe).
Public property | Item | Gets the Supplement at the specified index. The set operation is not supported.
Public property | SyncRoot | This operation is not supported.

See Also

SupplementList Class


Count Property

[image]

Endeca Presentation API
SupplementList..::..Count Property
SupplementList Class See Also Send Feedback
Gets the number of elements actually contained in the SupplementList.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

Field Value

The number of elements actually contained in the SupplementList.

Implements

ICollection..::..Count

See Also

SupplementList Class


IsFixedSize Property

[image]

Endeca Presentation API
SupplementList..::..IsFixedSize Property
SupplementList Class See Also Send Feedback
Gets a value indicating whether the SupplementList has a fixed size.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
virtual property bool IsFixedSize {
    bool get ();
}

Field Value

true if the SupplementList is a fixed size; otherwise, false. The default is true.

Implements

IList..::..IsFixedSize

See Also

SupplementList Class


IsReadOnly Property

[image]

Endeca Presentation API
SupplementList..::..IsReadOnly Property
SupplementList Class See Also Send Feedback
Gets a value indicating whether the SupplementList is read-only.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

true if the SupplementList is read-only; otherwise, false. The default is true.

Implements

IList..::..IsReadOnly

See Also

SupplementList Class


IsSynchronized Property

[image]

Endeca Presentation API
SupplementList..::..IsSynchronized Property
SupplementList Class See Also Send Feedback
Gets a value indicating whether access to the SupplementList is synchronized (thread-safe).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
virtual property bool IsSynchronized {
    bool get ();
}

Field Value

true if access to the SupplementList is synchronized (thread-safe); otherwise, false. The default is false.

Implements

ICollection..::..IsSynchronized

See Also

SupplementList Class


Item Property

[image]

Endeca Presentation API
SupplementList..::..Item Property
SupplementList Class See Also Send Feedback
Gets the Supplement at the specified index. The set operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get.

Field Value

The Supplement at the specified index.

Implements

IList..::..Item[([( Int32])])

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | index is out of range.
System..::..NotSupportedException | Always for set operation.

See Also

SupplementList Class


SyncRoot Property

[image]

Endeca Presentation API
SupplementList..::..SyncRoot Property
SupplementList Class See Also Send Feedback
This operation is not supported.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get ();
}

Field Value

An object that can be used to synchronize access to the SupplementList.

Implements

ICollection..::..SyncRoot

Exceptions

Exception | Condition
System..::..NotSupportedException | Always.

See Also

SupplementList Class


UrlENEQuery Class

[image]

Endeca Presentation API
UrlENEQuery Class
Members Example See Also Send Feedback
An object used for formulating queries to an Endeca MDEX Engine through the use of an input URL.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[SerializableAttribute]
public class UrlENEQuery : ENEQuery
Visual Basic
<SerializableAttribute> _
Public Class UrlENEQuery _
    Inherits ENEQuery
Visual C++
[SerializableAttribute]
public ref class UrlENEQuery : public ENEQuery

Remarks

A direct subclass of ENEQuery, UrlENEQuery allows an application to pass in an request URL's query string and autopopulate the query fields to automatically query the MDEX Engine objects specified in the URL. Like the ENEQuery superclass, a UrlENEQuery can express a request for a navigation, a record, a value search, and/or a value set search.

Navigation Query

Parameter Name | Parameter Value Format | ENEQuery Method
N | Either 0 (zero) for a root navigation request, or one or more dimension value IDs. | NavDescriptors
Nao | A number indicating the starting index of an aggregated record list. | NavAggrERecsOffset
Ne | Either 0 indicating no refinement values are returned for any dimensions, or one or more dimension value IDs indicating which dimension navigation refinements will be exposed. | NavExposedRefinements
Nf Sets a range filter with one of these formats:
CopyC#
<i>key</i>|LT+<i>number</i><br /><i>key</i>|LTEQ+<i>number</i><br /><i>key</i>|GT+<i>number</i><br /><i>key</i>|GTEQ+<i>number</i><br /><i>key</i>|BTWN+<i>num1</i>+<i>num2</i><br /><i>key</i>|GCLT+<i>lat</i>,<i>lon</i>+<i>number</i><br /><i>key</i>|GCGT+<i>lat</i>,<i>lon</i>+<i>number</i><br /><i>key</i>|GCBTWN+<i>lat</i>,<i>lon</i>+<i>num1</i>+<i>num2</i>
         NavRangeFilters
Nk | Specify none to request that no key properties be returned. | NavNumAggrERecs
No | A number indicating the starting index of a record list. | NavERecsOffset
Np | Either 0 (no records are returned with each aggregated record), 1 (only a single representative record is returned with each aggregate record), or 2 (all records are returned with each aggregated record). | NavERecsPerAggrERec
Nr | The record filter for the navigation query. | NavRecordFilter
Nrc The dynamic refinement configs for the navigation query. Each dynamic refinement config is delimited by the pipe character and must have the
CopyC#
id
 setting. Settings for a dynamic refinement config are: id: The dimension value id. Valid values are integers strictly greater than 0. exposed: Whether to expose the dimension value's refinement. Valid values are true which indicates exposed and false which indicates unexposed. Defaults to exposed. showcounts: Whether to show counts for the dimension value's refinements. Valid values are true which indicates counts are shown and false which indicates counts are not shown. dynrank: Whether the dimension value has Dynamic Ranking enabled. Valid values are enableddisabled and
CopyC#
default
 which uses the setting from Developer Studio. dyncount: The maximum number of dimension values to return. Valid values are integers >=0 or
CopyC#
default
 which uses the setting from Developer Studio. dynorder: Dynamic Ranking sort order. Valid values are
CopyC#
static
,
CopyC#
dynamic
 or
CopyC#
default
 which uses the setting from Developer Studio. synonyms: Whether to show synonyms for the dimension value's refinements. Valid values are true which indicates synonyms are shown and false which indicates synonyms are not shown. Omission of a setting or specifying the value
CopyC#
default
 results in using the setting in Developer Studio. 		N=0&Nrc=id+134711+exposed+true+dynrank+enabled+dyncount+default+dynorder+dynamic+showcounts+true|id+132830+dyncount+7+synonyms+true NavRefinementConfigs
Nrs | The structure expression for the navigation query. | NavRecordFilter
Ns | One or more sort keys (properties or dimensions) for a Navigation object's record list. Optionally, each sort key can specify a sort order of 0 (ascending sort, the default) or 1 (descending sort). | SetNavActiveSortKeys(ERecSortKeyList)
Ntk | One or more search keys (properties or dimensions), each delimited by the pipe character. | NavERecSearches
Ntpc | 1 (to turn on the computed alternative phrasings feature for a record search) or 0 (to turn it off). 0 is the default. | NavERecSearchComputeAlternativePhrasings
Ntpr | 1 (to use a computed alternative phrasing for a record search) or 0 (to use the end user's original query). 0 is the default. | NavERecSearchRewriteQueryWithAnAlternativePhrasing
Ntt | One or more terms for a record search. Each term is delimited by a plus sign, and each set of terms is delimited by the pipe character. | NavERecSearches
Nx | Options for navigation queries (other than options for record search, which are handled by Ntx). | NavOpts
Ntx | One or more sets of options for record search in the navigation query. These options include search mode, relevance ranking, and the snip and nosnip operators. Each set of options is delimited by the pipe character. | NavERecSearches
Nty | 1 (to turn on the "Did You Mean" feature for a record search) or 0 (to turn it off). 0 is the default. | NavERecSearchDidYouMean
NrkThe search key for relevance ranking record searchNavRelRankERecRank | NrtOne or more terms for relevance ranking record search. Each term is delimited by a plus sign. NavRelRankERecRank | NrrThe relevance ranking strategy to use with relevance ranking record search. NavRelRankERecRank | NrmThe match mode to use with relevance ranking record search. NavRelRankERecRank
Nu | A property or dimension to be used as a rollup key for aggregated records. | NavRollupKey

Record Query

Parameter Name | Parameter Value Format | ENEQuery Method
R | One or more Endeca record IDs. | ERecs

Aggregated Record Query

Parameter Name | Parameter Value Format | ENEQuery Method
A | The record specification of the Endeca aggregated record. | AggrERecSpec
Af | One or more aggregated record navigation range filters. See the Nf parameter for the format. | AggrERecNavRangeFilters
An | One or more dimension value IDs. | AggrERecNavDescriptors
Ar | The record filter for the aggregated record navigation query. | AggrERecNavRecordFilter
Ars | The structure expression for the aggregated record query. | AggrERecStructureExpr
Au | A property or dimension to be used as a rollup key for aggregated records. | AggrERecRollupKey
As | A sort specification to be used to order representative records | AggrERecActiveSortKeys

Dimension Search Query

Parameter Name | Parameter Value Format | ENEQuery Method
D | The dimension search query terms. | DimSearchTerms
Df | One or more dimension search range filters. See the Nf parameter for the format. | DimSearchNavRangeFilters
Di | One or more IDs of dimensions to search against. | DimSearchDimensions
Dk | 0 means means default dimension value ranking is used to order dimension search results, while 1 means relevance ranking is used. | DimSearchRankResults
Dn | One or more dimension value IDs. | DimSearchNavDescriptors
Do | A number indicating the offset with which the dimension search will begin returning results per dimension. | DimSearchResultsOffset
Dp | The number of dimension value matches to return per dimension. | DimSearchNumDimValues
Dr | The record filter for the dimension search navigation query. | DimSearchNavRecordFilter
Drc | The dynamic refinement configs for the dimension search query. Each dynamic refinement config is delimited by the pipe character If the dynamic refinement config has the the id setting then it's paramaters aply to just that dimension. If the dynamic refinement config does not have the id setting then it's paramaters are global. Settings for a dynamic refinement config are: id: The dimension value id. Valid values are integers strictly greater than 0. showcounts: Whether to show counts for the dimension value's refinements. Valid values are true which indicates counts are shown and false which indicates counts are not shown. numresults: The maximum number of dimension values to return. Valid values are integers >=0. synonyms: Whether to show synonyms for the dimension value's refinements. Valid values are true which indicates synonyms are shown and false which indicates synonyms are not shown. maxdepth: The maximum depth of dimensions to return. Valid values are integers >= 0. This setting can only be global. includeinert: Whether to return dimension values which are inert. Valid values are true which indicates inert dimensions are shown and false which indicates inert dimensions are hidden. Defaults to false. This setting can only be global. | D=1*&Drc=maxdepth+1+includeinert+true|id+134711+showcounts+true+synonyms+true|id+132830+numresults+5 | DimSearchRefinementConfigs
Drs | The structure expression for the dimension search navigation query. | DimSearchNavRecordFilter
Du | A property or dimension to be used as a rollup key for aggregated counts. | D=Merlot&Drc=id+1000+showcounts+true&Du=P_Winery | DimSearchRollupKey
Dx | The options for the dimension search operation. | DimSearchOpts

Examples

The set methods of this query class are not meant to be usually called through a direct method call. For example a UrlENEQuery could formulate a request for a navigation and a value search from the URL:
CopyC#
controller.aspx?N=0&D=cadillac
 This example would express a query to the MDEX Engine for the root navigation as well as a value search for a value named "cadillac".

UrlENEQuery can be instantiated in a couple of ways in a ASP.NET and C# usage. For example:

CopyC#
IENEConnection nec = new HttpENEConnection("engine.endeca.com", 5001);
ENEQuery usq = new UrlENEQuery(Page.Request.Url.Query);
QueryResults = nec.Query(usq);

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..ENEQuery
Endeca.Navigation..::..UrlENEQuery

See Also

UrlENEQuery Members


UrlENEQuery Members

[image] [image]

Endeca Presentation API
UrlENEQuery Members
UrlENEQuery Class Constructors Methods Fields Properties See Also Send Feedback

The UrlENEQuery type exposes the following members.

Constructors

 | Name | Description
Public method | UrlENEQuery()()()() | No argument constructor.
Public method | UrlENEQuery(String) | Obsolete. Obsolete. Use the constructor that takes an encoding instead.
Public method | UrlENEQuery(String, String) | Constructor where the queryString gets parsed into the individual query fields.

Methods

 | Name | Description
Public method | AddSelection | Adds the field named fieldName to the set of fields that should be returned for each record in the result set. (Inherited from ENEQuery.)
Public method | ContainsAggrERecQuery | Returns if this query includes a aggregated record query. (Inherited from ENEQuery.)
Public method | ContainsDimSearchQuery | Returns if this query includes a dimension search query. (Inherited from ENEQuery.)
Public method | ContainsERecQuery | Returns if this query includes a record query. (Inherited from ENEQuery.)
Public method | ContainsERecsQuery | Returns if this query includes a query for records. (Inherited from ENEQuery.)
Public method | ContainsNavQuery | Returns whether the query includes a navigation query. (Inherited from ENEQuery.)
Public method | ContainsQuery | Returns whether the query is querying for any of a navigation, record, dimension search, or a value set search. (Inherited from ENEQuery.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNavActiveSortKeys | Get the list of sort keys with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetNavSortKey | Obsolete. Gets the sort key with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetNavSortOrder | Obsolete. Gets the sort order with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetA | Sets the aggregated record for the query. AggrERec.
Public method | SetAf | Sets the aggregated record navigation range filters. AggrERecNavRangeFilters.
Public method | SetAn | Sets the aggregated record navigation values for the query. AggrERecNavDescriptors.
Public method | SetAr | Sets the aggregated record navigation record filter. AggrERecNavRecordFilter.
Public method | SetArs | Sets the aggregated record structure expression. AggrERecStructureExpr.
Public method | SetAs | Sets the sort key for the record list of the aggregated record query.
Public method | SetAu | Sets the aggregated record rollup key with which the aggregated record is derived. AggrERecRollupKey.
Public method | SetD | Sets the string dimension search query terms. DimSearchTerms.
Public method | SetDf | Sets the dimension search navigation range filters. DimSearchNavRangeFilters.
Public method | SetDi | Sets the dimension(s) with which to dimension search in. DimSearchDimensions.
Public method | SetDk | Sets the dimension search behavior to order results. DimSearchRankResults.
Public method | SetDn | Sets the navigation restriction for the dimension search. DimSearchNavDescriptors
Public method | SetDo | Sets the dimension search results offset. DimSearchResultsOffset.
Public method | SetDp | Obsolete. Sets the number of results to return per dimension. DimSearchNumDimValues
Public method | SetDr | Sets the dimension search navigation record filter. DimSearchNavRangeFilters.
Public method | SetDrc | Sets the list of refinement configs for the dimension search query. refinement configs are delimited by '|'.
Public method | SetDrs | Sets the dimension search navigation structure expression. DimSearchNavRecordStructureExpr.
Public method | SetDu | Sets the rollup key for the dimension search query. DimSearchRollupKey.
Public method | SetDx | Sets the dimension search options. DimSearchOpts.
Public method | SetN | Sets the navigation field of the query. NavDescriptors
Public method | SetNa | Sets an analytics query. AnalyticsQuery
Public method | SetNao | Sets the navigation aggregated record list offset. NavAggrERecsOffset
Public method | SetNavActiveSortKeys | Set the list of sort keys with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNavSortKey | Obsolete. Sets the sort key with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNavSortOrder | Obsolete. Sets the sort order with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNdr | Sets the Disabled Refinements config for the navigation query.
Public method | SetNe | Sets the exposed navigation refinements. NavExposedRefinements
Public method | SetNf | Sets the range filters for the navigation query. NavRangeFilters.
Public method | SetNk | Sets the key properties request for the navigation query. NavKeyProperties
Public method | SetNmpt |
Public method | SetNmrf |
Public method | SetNo | Sets the navigation record list offset. NavERecsOffset
Public method | SetNp | Sets the number of records per aggregated record. NavERecsPerAggrERec
Public method | SetNr | Sets the record filter for the navigation query. NavRecordFilter.
Public method | SetNrc | Sets the list of dynamic refinement configs for the navigation query. Dynamic refinement configs are delimited by '|'.
Public method | SetNrcs | Sets the list of stratified dim vals used by this navigation query. Stratified dim vals are delimited by ';' and are in the form [strata],[dimvalid].
Public method | SetNrk | Sets the key of the record search of the navigation query using a specified relevance ranking strategy.
Public method | SetNrm | Sets the relevance ranking match mode for the record search of the navigation query.
Public method | SetNrr | Sets the relevance ranking strategy for the record search of the navigation query.
Public method | SetNrs | Sets the structure expression for the navigation query. NavRecordStructureExpr.
Public method | SetNrt | Sets the terms of the record search of the navigation query using a specified relevance ranking strategy.
Public method | SetNs | Sets the sort key for the record list of the navigation.
Public method | SetNso | Sets the sort order for the record list of the navigation.
Public method | SetNtk | Sets the keys of the record search of the navigation query.
Public method | SetNtpc | Sets whether the compute-autophrase record search functionality is on in the query. NavERecSearchComputeAlternativePhrasings
Public method | SetNtpr | Sets whether the rewrite-autophrase record search functionality is on in the query. NavERecSearchRewriteQueryWithAnAlternativePhrasing
Public method | SetNtt | Sets the terms of the record search of the navigation query.
Public method | SetNtx | Sets the options for the record search of the navigation query.
Public method | SetNty | Sets whether the did you mean record search functionality is on in the query. NavERecSearchDidYouMean
Public method | SetNu | Sets the rollup key for the navigation query. NavRollupKey
Public method | SetNx | Sets the navigation query options. NavOpts.
Public method | SetR | Sets the records for query. ERecs.
 | ToQueryString | Takes a ENEQuery and serializes the object into URL query string format.
Public method | ToString()()()() | Returns a string representation of this query.
Public method | ToString(String) | Returns a string representation of this query, using the given character encoding.

Fields

Name | Description
AGGR_EREC_NAV_DESCRIPTORS_PARAM | Parameter name for aggregated record descriptors.
AGGR_EREC_NAV_RANGE_FILTERS_PARAM | Parameter name for aggregated record navigation range filters.
AGGR_EREC_NAV_RECORD_FILTER_PARAM | Parameter name for aggregated record navigation record filter.
AGGR_EREC_PARAM | Parameter name for aggregated records.
AGGR_EREC_ROLLUP_KEY_PARAM | Parameter name for aggregated record rollup keys.
AGGR_EREC_SORT_KEY_PARAM | Parameter name for aggregated record sort keys.
AGGR_EREC_STRUCTURE_EXPR_PARAM | Parameter name for aggregated record structure expression.
ANALYTICS_PARAM | Parameter name for Analytics query
DIM_SEARCH_DIMENSIONS_PARAM | Parameter name for dimension search dimension.
DIM_SEARCH_NAV_DESCRIPTORS_PARAM | Parameter name for dimension search navigation descriptors.
DIM_SEARCH_NAV_RANGE_FILTERS_PARAM | Parameter name for dimension search navigation range filters.
DIM_SEARCH_NAV_RECORD_FILTER_PARAM | Parameter name for dimension search navigation record filter.
DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM | Parameter name for dimension search navigation structure expression.
DIM_SEARCH_NUM_DIM_VALUES_PARAM | Parameter name for number of dimension values to return.
DIM_SEARCH_OPTS_PARAM | Parameter name for dimension search options.
DIM_SEARCH_RANK_RESULTS_PARAM | Parameter name for ranking dimension search results.
DIM_SEARCH_REFINEMENT_CONFIGS_PARAM | Parameter name for dimension search refinement configs.
DIM_SEARCH_RESULTS_OFFSET_PARAM | Parameter name for dimension search results offset.
DIM_SEARCH_ROLLUP_KEY_PARAM | Parameter name for dimension search rollup key.
DIM_SEARCH_TERMS_PARAM | Parameter name for dimension search terms.
ERECS_PARAM | Parameter name for records.
NAV_AGGR_ERECS_OFFSET_PARAM | Parameter name for navigation aggregated record list offset.
NAV_DESCRIPTORS_PARAM | Parameter name for navigation values.
NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM | Parameter name for disabled refinements config.
NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM | Parameter name for navigation record search compute-autophrase.
NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM | Parameter name for navigation record search did you mean.
NAV_EREC_SEARCH_KEYS_PARAM | Parameter name for navigation record search keys.
NAV_EREC_SEARCH_OPTS_PARAM | Parameter name for navigation record search option sets.
NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM | Parameter name for navigation record search rewrite-autophrase.
NAV_EREC_SEARCH_TERMS_PARAM | Parameter name for navigation record search term sets.
NAV_ERECS_OFFSET_PARAM | Parameter name for navigation record list offset.
NAV_ERECS_PER_AGGR_EREC_PARAM | Parameter name for navigation number of records per aggregated record.
NAV_KEY_PROPERTIES_PARAM | Parameter name for navigation key properties.
NAV_MERCH_PREVIEW_TIME_PARAM | Parameter name for navigation preview time.
NAV_MERCH_RULE_FILTER_PARAM | ParameterName for Merch rule filter
NAV_OPTS_PARAM | Parameter name for navigation query options (other than options for record search, which are handled by Ntx).
NAV_RANGE_FILTERS_PARAM | Parameter name for navigation range filters.
NAV_RECORD_FILTER_PARAM | Parameter name for navigation record filters.
NAV_RECORD_STRUCTURE_EXPR_PARAM | Parameter name for navigation structure expressions.
NAV_REFINEMENT_CONFIGS_PARAM | Parameter name for navigation refinement configs.
NAV_RELRANK_EREC_RANK_KEY_PARAM | Parameter name for navigation relevance ranking record search key.
NAV_RELRANK_EREC_RANK_MATCH_PARAM | Parameter name for navigation relevance ranking match mode
NAV_RELRANK_EREC_RANK_STRATEGY_PARAM | Parameter name for navigation relevance ranking record search strategy
NAV_RELRANK_EREC_RANK_TERMS_PARAM | Parameter name for navigation relevance ranking record search terms.
NAV_RELRANK_EREC_SEARCH_KEY_PARAM | Parameter name for navigation relevance ranking record search key.
NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM | Parameter name for navigation relevance ranking record search strategy
NAV_RELRANK_EREC_SEARCH_TERMS_PARAM | Parameter name for navigation relevance ranking record search terms.
NAV_ROLLUP_KEY_PARAM | Parameter name for navigation rollup key.
NAV_SORT_KEY_PARAM | Parameter name for navigation sort key.
NAV_SORT_ORDER_PARAM | Parameter name for navigation sort order.
NAV_SPECIFIC_REFINEMENTS_PARAM | Parameter name for navigation exposed refinements.
NAV_STRATIFIED_DIM_VALS_PARAM | Parameter name for navigation stratified dim vals.
QUERY_ID_PARAM | Parameter name for Request Id
SESSION_ID_PARAM | Parameter name for Session Id

Properties

Name Description
Public property AggrERec Obsolete.
Gets or sets the Id of the aggregated record to be queried for.
(Inherited from ENEQuery.)
Public property AggrERecActiveSortKeys
Get the list of sort keys with which the aggregated records representative records will be sorted.
(Inherited from ENEQuery.)
Public property AggrERecNavDescriptors
Gets or sets the navigation values which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecNavRangeFilters
Gets or sets the navigation range filters which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecNavRecordFilter
Gets or sets the record filter which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecRollupKey
Gets or sets the rollup key the aggregated record is composed by.
(Inherited from ENEQuery.)
Public property AggrERecSpec
Gets or sets the specification of the aggregated record to be queried for.
(Inherited from ENEQuery.)
Public property AggrERecStructureExpr
Gets or sets the structure expression used to filter members of the aggregated record.
(Inherited from ENEQuery.)
Public property AnalyticsQuery
Gets and sets the AnalyticsQuery instance that represents the Analytics query that will be sent to the MDEX Engine. On set, if the query is malformed, it will not be set on the HttpENEConnection and a SyntaxException is thrown. An AnalyticsQuery instance can be built programmatically or by calling the parseQuery(String) method.
(Inherited from ENEQuery.)
Public property DimSearchCompound
Gets and sets whether dimension search will include compound results.
(Inherited from ENEQuery.)
Public property DimSearchDimension
Gets and sets the dimension which which the dimension search can search from.
(Inherited from ENEQuery.)
Public property DimSearchDimensions
Gets and sets the dimensions which which the dimension search can search from.
(Inherited from ENEQuery.)
Public property DimSearchNavDescriptors
Gets and sets the navigation values that describe a navigation state that restrict the number of values that can be searched from.
(Inherited from ENEQuery.)
Public property DimSearchNavRangeFilters
Gets and sets the navigation range filters that restrict the dimension search.
(Inherited from ENEQuery.)
Public property DimSearchNavRecordFilter
Gets and sets the record filter that will restrict the dimension search results.
(Inherited from ENEQuery.)
Public property DimSearchNavRecordStructureExpr
Gets and sets the structure expression that will restrict the dimension search results.
(Inherited from ENEQuery.)
Public property DimSearchNumDimValues Obsolete.
Gets and sets the number of values returned from each dimension for value search.
(Inherited from ENEQuery.)
Public property DimSearchOpts
Gets and sets the option set that dimension search will use.
(Inherited from ENEQuery.)
Public property DimSearchRankResults
Gets and sets how the dimension search will order its results.
(Inherited from ENEQuery.)
Public property DimSearchRefinementConfigs
Gets and sets the list of refinement configs to be used by the MDEX Engine for dimension search
(Inherited from ENEQuery.)
Public property DimSearchResultsOffset
Gets and sets the offset with which the dimension search will begin returning results per dimension.
(Inherited from ENEQuery.)
Public property DimSearchRollupKey
Gets and sets the rollup key which the records of the dimension search query should use to create aggregated counts. By setting a rollupKey with this method, aggregated counts are returned as the value for the
CopyC#
Dgraph.AggrBins
 key of the
CopyC#
DimVal
 object's
CopyC#
PropertyMap
.
(Inherited from ENEQuery.)
Public property DimSearchTerms
Gets and sets the search terms the dimension search will use.
(Inherited from ENEQuery.)
Public property ERec
Sets the Id of the record to be queried for.
(Inherited from ENEQuery.)
Public property ERecs
Gets or sets the Ids of the records to be queried for.
(Inherited from ENEQuery.)
Public property LanguageId
Gets and sets the ISO639 language code to be used for this query. The language id is sent to the MDEX Engine when the query is executed, and specifies the language of any text portion of the query. For example: search terms.
(Inherited from ENEQuery.)
Public property NavAggrERecsOffset
Gets and sets the offset into the navigation aggregated record list for navigation query.
(Inherited from ENEQuery.)
Public property NavAllRefinements
Gets and sets the query such that the navigation query will return with all the refinements possible for all dimensions.
(Inherited from ENEQuery.)
Public property NavDescriptors
Gets and sets the navigation descriptor IDs describing the navigation object to be queried for.
(Inherited from ENEQuery.)
Public property NavDisabledRefinementsConfig
Gets and sets the disabled refinements config.
(Inherited from ENEQuery.)
Public property NavERecSearchComputeAlternativePhrasings
Gets and sets if the fulltext search should turn on the compute-autophrase feature.
(Inherited from ENEQuery.)
Public property NavERecSearchDidYouMean
Gets and sets if the fulltext search should turn on the did you mean feature.
(Inherited from ENEQuery.)
Public property NavERecSearches
Gets and sets the navigation record searches to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavERecSearchRewriteQueryWithAnAlternativePhrasing
Gets and sets if the fulltext search should turn on the rewrite-autophrase feature.
(Inherited from ENEQuery.)
Public property NavERecsOffset
Gets and sets the offset into the navigation record list for navigation query.
(Inherited from ENEQuery.)
Public property NavERecsPerAggrERec
Gets and sets the max number of records to be returned in each aggregated record.
(Inherited from ENEQuery.)
Public property NavExposedRefinements
Gets and sets the set of refinements that should be exposed / returned with the navigation query.
(Inherited from ENEQuery.)
Public property NavKeyProperties
Get and sets the number of key properties to be returned.
(Inherited from ENEQuery.)
Public property NavMerchPreviewTime
Gets and sets the merch preview time on this navigation query.
(Inherited from ENEQuery.)
Public property NavMerchRuleFilter
Gets and sets the merch rule filter on this navigation query.
(Inherited from ENEQuery.)
Public property NavNumAggrERecs
Gets and sets the max number of aggregated records returned for the navigation query.
(Inherited from ENEQuery.)
Public property NavNumBulkAggrERecs
Gets and sets the max number of aggregated records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all aggregated records for the navigation query will be returned.
(Inherited from ENEQuery.)
Public property NavNumBulkERecs
Gets and sets the max number of records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all records for the navigation query will be returned.
(Inherited from ENEQuery.)
Public property NavNumERecs
Get and sets the max number of records returned for the navigation query.
(Inherited from ENEQuery.)
Public property NavOpts
Gets and sets the option set that navigation queries will use.
(Inherited from ENEQuery.)
Public property NavRangeFilters
Gets and sets the navigation range filters on this navigation query.
(Inherited from ENEQuery.)
Public property NavRecordFilter
Gets and sets the record filters on this navigation query.
(Inherited from ENEQuery.)
Public property NavRecordStructureExpr
Gets and sets the structure expression on this navigation query.
(Inherited from ENEQuery.)
Public property NavRefinementConfigs
Gets and sets the list of dynamic refinement configs to be used by the MDEX Engine.
(Inherited from ENEQuery.)
Public property NavRelRankERecRank
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavRelRankERecSearch Obsolete.
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavRollupKey
Gets and sets the rollup key with which the records of the navigation query should be rolled up with to create aggregated records.
(Inherited from ENEQuery.)
Public property NavStratifiedDimVals
Gets and sets the list stratified dim vals for use during refinement ranking by the MDEX engine.
(Inherited from ENEQuery.)
Public property Profiles
Gets and sets the set of profiles that describe the application end user.
(Inherited from ENEQuery.)
Public property QueryInfo
Gets and sets the ENEQueryInfo object.
(Inherited from ENEQuery.)
Public property Selection
Gets and sets the select list for the query.
(Inherited from ENEQuery.)

See Also

UrlENEQuery Class


UrlENEQuery Constructor

[image] [image]

Endeca Presentation API
UrlENEQuery Constructor
UrlENEQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UrlENEQuery()()()() | No argument constructor.
Public method | UrlENEQuery(String) | Obsolete. Obsolete. Use the constructor that takes an encoding instead.
Public method | UrlENEQuery(String, String) | Constructor where the queryString gets parsed into the individual query fields.

See Also

UrlENEQuery Class
UrlENEQuery Members


UrlENEQuery Constructor

[image]

Endeca Presentation API
UrlENEQuery Constructor
UrlENEQuery Class See Also Send Feedback
No argument constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public UrlENEQuery()
Visual Basic
Public Sub New
Visual C++
public:
UrlENEQuery()

Remarks

Individual setter methods must be called else query will result in EmptyENEQueryException.

See Also

UrlENEQuery Class
UrlENEQuery Overload


UrlENEQuery Constructor (String)

[image]

Endeca Presentation API
UrlENEQuery Constructor (String)
UrlENEQuery Class See Also Send Feedback
Obsolete. Use the constructor that takes an encoding instead.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")]
public UrlENEQuery(
    string queryString
)
Visual Basic
<ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")> _
Public Sub New ( _
    queryString As String _
)
Visual C++
[ObsoleteAttribute(L"This constructor is obsolete; use the version that takes an encoding instead")]
public:
UrlENEQuery(
    String^ queryString
)

Parameters

queryString
Type: System..::..String
Query string form URL to be parsed into invididual query options. The URL is assumed to be encoded in "windows-1252".

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If there were any errors in parsing queryString.

See Also

UrlENEQuery Class
UrlENEQuery Overload


UrlENEQuery Constructor (String, String)

[image]

Endeca Presentation API
UrlENEQuery Constructor (String, String)
UrlENEQuery Class See Also Send Feedback
Constructor where the queryString gets parsed into the individual query fields.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public UrlENEQuery(
    string queryString,
    string encoding
)
Visual Basic
Public Sub New ( _
    queryString As String, _
    encoding As String _
)
Visual C++
public:
UrlENEQuery(
    String^ queryString,
    String^ encoding
)

Parameters

queryString
Type: System..::..String
Query string form URL to be parsed into invididual query options.
encoding
Type: System..::..String
The character set encoding of the URL. Typically "windows-1252" or "UTF-8".

Remarks

The common use for this constructor is to pass in QueryString as is, i.e. arguments remain x-www-form-urlencoded, and this constructor parses out the arguments it is interested in.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If there were any errors in parsing queryString.

See Also

UrlENEQuery Class
UrlENEQuery Overload


UrlENEQuery Fields

[image] [image]

Endeca Presentation API
UrlENEQuery Fields
UrlENEQuery Class See Also Send Feedback

The UrlENEQuery type exposes the following members.

Fields

Name | Description
AGGR_EREC_NAV_DESCRIPTORS_PARAM | Parameter name for aggregated record descriptors.
AGGR_EREC_NAV_RANGE_FILTERS_PARAM | Parameter name for aggregated record navigation range filters.
AGGR_EREC_NAV_RECORD_FILTER_PARAM | Parameter name for aggregated record navigation record filter.
AGGR_EREC_PARAM | Parameter name for aggregated records.
AGGR_EREC_ROLLUP_KEY_PARAM | Parameter name for aggregated record rollup keys.
AGGR_EREC_SORT_KEY_PARAM | Parameter name for aggregated record sort keys.
AGGR_EREC_STRUCTURE_EXPR_PARAM | Parameter name for aggregated record structure expression.
ANALYTICS_PARAM | Parameter name for Analytics query
DIM_SEARCH_DIMENSIONS_PARAM | Parameter name for dimension search dimension.
DIM_SEARCH_NAV_DESCRIPTORS_PARAM | Parameter name for dimension search navigation descriptors.
DIM_SEARCH_NAV_RANGE_FILTERS_PARAM | Parameter name for dimension search navigation range filters.
DIM_SEARCH_NAV_RECORD_FILTER_PARAM | Parameter name for dimension search navigation record filter.
DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM | Parameter name for dimension search navigation structure expression.
DIM_SEARCH_NUM_DIM_VALUES_PARAM | Parameter name for number of dimension values to return.
DIM_SEARCH_OPTS_PARAM | Parameter name for dimension search options.
DIM_SEARCH_RANK_RESULTS_PARAM | Parameter name for ranking dimension search results.
DIM_SEARCH_REFINEMENT_CONFIGS_PARAM | Parameter name for dimension search refinement configs.
DIM_SEARCH_RESULTS_OFFSET_PARAM | Parameter name for dimension search results offset.
DIM_SEARCH_ROLLUP_KEY_PARAM | Parameter name for dimension search rollup key.
DIM_SEARCH_TERMS_PARAM | Parameter name for dimension search terms.
ERECS_PARAM | Parameter name for records.
NAV_AGGR_ERECS_OFFSET_PARAM | Parameter name for navigation aggregated record list offset.
NAV_DESCRIPTORS_PARAM | Parameter name for navigation values.
NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM | Parameter name for disabled refinements config.
NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM | Parameter name for navigation record search compute-autophrase.
NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM | Parameter name for navigation record search did you mean.
NAV_EREC_SEARCH_KEYS_PARAM | Parameter name for navigation record search keys.
NAV_EREC_SEARCH_OPTS_PARAM | Parameter name for navigation record search option sets.
NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM | Parameter name for navigation record search rewrite-autophrase.
NAV_EREC_SEARCH_TERMS_PARAM | Parameter name for navigation record search term sets.
NAV_ERECS_OFFSET_PARAM | Parameter name for navigation record list offset.
NAV_ERECS_PER_AGGR_EREC_PARAM | Parameter name for navigation number of records per aggregated record.
NAV_KEY_PROPERTIES_PARAM | Parameter name for navigation key properties.
NAV_MERCH_PREVIEW_TIME_PARAM | Parameter name for navigation preview time.
NAV_MERCH_RULE_FILTER_PARAM | ParameterName for Merch rule filter
NAV_OPTS_PARAM | Parameter name for navigation query options (other than options for record search, which are handled by Ntx).
NAV_RANGE_FILTERS_PARAM | Parameter name for navigation range filters.
NAV_RECORD_FILTER_PARAM | Parameter name for navigation record filters.
NAV_RECORD_STRUCTURE_EXPR_PARAM | Parameter name for navigation structure expressions.
NAV_REFINEMENT_CONFIGS_PARAM | Parameter name for navigation refinement configs.
NAV_RELRANK_EREC_RANK_KEY_PARAM | Parameter name for navigation relevance ranking record search key.
NAV_RELRANK_EREC_RANK_MATCH_PARAM | Parameter name for navigation relevance ranking match mode
NAV_RELRANK_EREC_RANK_STRATEGY_PARAM | Parameter name for navigation relevance ranking record search strategy
NAV_RELRANK_EREC_RANK_TERMS_PARAM | Parameter name for navigation relevance ranking record search terms.
NAV_RELRANK_EREC_SEARCH_KEY_PARAM | Parameter name for navigation relevance ranking record search key.
NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM | Parameter name for navigation relevance ranking record search strategy
NAV_RELRANK_EREC_SEARCH_TERMS_PARAM | Parameter name for navigation relevance ranking record search terms.
NAV_ROLLUP_KEY_PARAM | Parameter name for navigation rollup key.
NAV_SORT_KEY_PARAM | Parameter name for navigation sort key.
NAV_SORT_ORDER_PARAM | Parameter name for navigation sort order.
NAV_SPECIFIC_REFINEMENTS_PARAM | Parameter name for navigation exposed refinements.
NAV_STRATIFIED_DIM_VALS_PARAM | Parameter name for navigation stratified dim vals.
QUERY_ID_PARAM | Parameter name for Request Id
SESSION_ID_PARAM | Parameter name for Session Id

See Also

UrlENEQuery Class


AGGR_EREC_NAV_DESCRIPTORS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_NAV_DESCRIPTORS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record descriptors.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_NAV_DESCRIPTORS_PARAM
Visual Basic
Public Const AGGR_EREC_NAV_DESCRIPTORS_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_NAV_DESCRIPTORS_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_NAV_RANGE_FILTERS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_NAV_RANGE_FILTERS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record navigation range filters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_NAV_RANGE_FILTERS_PARAM
Visual Basic
Public Const AGGR_EREC_NAV_RANGE_FILTERS_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_NAV_RANGE_FILTERS_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_NAV_RECORD_FILTER_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_NAV_RECORD_FILTER_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record navigation record filter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_NAV_RECORD_FILTER_PARAM
Visual Basic
Public Const AGGR_EREC_NAV_RECORD_FILTER_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_NAV_RECORD_FILTER_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_PARAM
Visual Basic
Public Const AGGR_EREC_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_ROLLUP_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_ROLLUP_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record rollup keys.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_ROLLUP_KEY_PARAM
Visual Basic
Public Const AGGR_EREC_ROLLUP_KEY_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_ROLLUP_KEY_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_SORT_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_SORT_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record sort keys.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_SORT_KEY_PARAM
Visual Basic
Public Const AGGR_EREC_SORT_KEY_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_SORT_KEY_PARAM

See Also

UrlENEQuery Class


AGGR_EREC_STRUCTURE_EXPR_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..AGGR_EREC_STRUCTURE_EXPR_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for aggregated record structure expression.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string AGGR_EREC_STRUCTURE_EXPR_PARAM
Visual Basic
Public Const AGGR_EREC_STRUCTURE_EXPR_PARAM As String
Visual C++
public:
literal String^ AGGR_EREC_STRUCTURE_EXPR_PARAM

See Also

UrlENEQuery Class


ANALYTICS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..ANALYTICS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for Analytics query

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string ANALYTICS_PARAM
Visual Basic
Public Const ANALYTICS_PARAM As String
Visual C++
public:
literal String^ ANALYTICS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_DIMENSIONS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_DIMENSIONS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search dimension.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_DIMENSIONS_PARAM
Visual Basic
Public Const DIM_SEARCH_DIMENSIONS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_DIMENSIONS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_NAV_DESCRIPTORS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_NAV_DESCRIPTORS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search navigation descriptors.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_NAV_DESCRIPTORS_PARAM
Visual Basic
Public Const DIM_SEARCH_NAV_DESCRIPTORS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_NAV_DESCRIPTORS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_NAV_RANGE_FILTERS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_NAV_RANGE_FILTERS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search navigation range filters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_NAV_RANGE_FILTERS_PARAM
Visual Basic
Public Const DIM_SEARCH_NAV_RANGE_FILTERS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_NAV_RANGE_FILTERS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_NAV_RECORD_FILTER_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_NAV_RECORD_FILTER_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search navigation record filter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_NAV_RECORD_FILTER_PARAM
Visual Basic
Public Const DIM_SEARCH_NAV_RECORD_FILTER_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_NAV_RECORD_FILTER_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search navigation structure expression.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM
Visual Basic
Public Const DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_NAV_RECORD_STRUCTURE_EXPR_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_NUM_DIM_VALUES_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_NUM_DIM_VALUES_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for number of dimension values to return.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_NUM_DIM_VALUES_PARAM
Visual Basic
Public Const DIM_SEARCH_NUM_DIM_VALUES_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_NUM_DIM_VALUES_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_OPTS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_OPTS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search options.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_OPTS_PARAM
Visual Basic
Public Const DIM_SEARCH_OPTS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_OPTS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_RANK_RESULTS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_RANK_RESULTS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for ranking dimension search results.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_RANK_RESULTS_PARAM
Visual Basic
Public Const DIM_SEARCH_RANK_RESULTS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_RANK_RESULTS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_REFINEMENT_CONFIGS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_REFINEMENT_CONFIGS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search refinement configs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_REFINEMENT_CONFIGS_PARAM
Visual Basic
Public Const DIM_SEARCH_REFINEMENT_CONFIGS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_REFINEMENT_CONFIGS_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_RESULTS_OFFSET_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_RESULTS_OFFSET_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search results offset.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_RESULTS_OFFSET_PARAM
Visual Basic
Public Const DIM_SEARCH_RESULTS_OFFSET_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_RESULTS_OFFSET_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_ROLLUP_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_ROLLUP_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search rollup key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_ROLLUP_KEY_PARAM
Visual Basic
Public Const DIM_SEARCH_ROLLUP_KEY_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_ROLLUP_KEY_PARAM

See Also

UrlENEQuery Class


DIM_SEARCH_TERMS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..DIM_SEARCH_TERMS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for dimension search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string DIM_SEARCH_TERMS_PARAM
Visual Basic
Public Const DIM_SEARCH_TERMS_PARAM As String
Visual C++
public:
literal String^ DIM_SEARCH_TERMS_PARAM

See Also

UrlENEQuery Class


ERECS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..ERECS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for records.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string ERECS_PARAM
Visual Basic
Public Const ERECS_PARAM As String
Visual C++
public:
literal String^ ERECS_PARAM

See Also

UrlENEQuery Class


NAV_AGGR_ERECS_OFFSET_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_AGGR_ERECS_OFFSET_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation aggregated record list offset.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_AGGR_ERECS_OFFSET_PARAM
Visual Basic
Public Const NAV_AGGR_ERECS_OFFSET_PARAM As String
Visual C++
public:
literal String^ NAV_AGGR_ERECS_OFFSET_PARAM

See Also

UrlENEQuery Class


NAV_DESCRIPTORS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_DESCRIPTORS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation values.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_DESCRIPTORS_PARAM
Visual Basic
Public Const NAV_DESCRIPTORS_PARAM As String
Visual C++
public:
literal String^ NAV_DESCRIPTORS_PARAM

See Also

UrlENEQuery Class


NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for disabled refinements config.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM
Visual Basic
Public Const NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM As String
Visual C++
public:
literal String^ NAV_DISABLED_REFINEMENTS_CONFIGS_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search compute-autophrase.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_COMPUTE_ALTERNATIVE_PHRASINGS_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search did you mean.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_DID_YOU_MEAN_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_KEYS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_KEYS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search keys.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_KEYS_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_KEYS_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_KEYS_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_OPTS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_OPTS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search option sets.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_OPTS_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_OPTS_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_OPTS_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search rewrite-autophrase.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_REWRITE_WITH_AN_ALTERNATIVE_PHRASING_PARAM

See Also

UrlENEQuery Class


NAV_EREC_SEARCH_TERMS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_EREC_SEARCH_TERMS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record search term sets.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_EREC_SEARCH_TERMS_PARAM
Visual Basic
Public Const NAV_EREC_SEARCH_TERMS_PARAM As String
Visual C++
public:
literal String^ NAV_EREC_SEARCH_TERMS_PARAM

See Also

UrlENEQuery Class


NAV_ERECS_OFFSET_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_ERECS_OFFSET_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record list offset.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_ERECS_OFFSET_PARAM
Visual Basic
Public Const NAV_ERECS_OFFSET_PARAM As String
Visual C++
public:
literal String^ NAV_ERECS_OFFSET_PARAM

See Also

UrlENEQuery Class


NAV_ERECS_PER_AGGR_EREC_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_ERECS_PER_AGGR_EREC_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation number of records per aggregated record.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_ERECS_PER_AGGR_EREC_PARAM
Visual Basic
Public Const NAV_ERECS_PER_AGGR_EREC_PARAM As String
Visual C++
public:
literal String^ NAV_ERECS_PER_AGGR_EREC_PARAM

See Also

UrlENEQuery Class


NAV_KEY_PROPERTIES_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_KEY_PROPERTIES_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation key properties.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_KEY_PROPERTIES_PARAM
Visual Basic
Public Const NAV_KEY_PROPERTIES_PARAM As String
Visual C++
public:
literal String^ NAV_KEY_PROPERTIES_PARAM

See Also

UrlENEQuery Class


NAV_MERCH_PREVIEW_TIME_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_MERCH_PREVIEW_TIME_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation preview time.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_MERCH_PREVIEW_TIME_PARAM
Visual Basic
Public Const NAV_MERCH_PREVIEW_TIME_PARAM As String
Visual C++
public:
literal String^ NAV_MERCH_PREVIEW_TIME_PARAM

See Also

UrlENEQuery Class


NAV_MERCH_RULE_FILTER_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_MERCH_RULE_FILTER_PARAM Field
UrlENEQuery Class See Also Send Feedback
ParameterName for Merch rule filter

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_MERCH_RULE_FILTER_PARAM
Visual Basic
Public Const NAV_MERCH_RULE_FILTER_PARAM As String
Visual C++
public:
literal String^ NAV_MERCH_RULE_FILTER_PARAM

See Also

UrlENEQuery Class


NAV_OPTS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_OPTS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation query options (other than options for record search, which are handled by Ntx).

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_OPTS_PARAM
Visual Basic
Public Const NAV_OPTS_PARAM As String
Visual C++
public:
literal String^ NAV_OPTS_PARAM

See Also

UrlENEQuery Class


NAV_RANGE_FILTERS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RANGE_FILTERS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation range filters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RANGE_FILTERS_PARAM
Visual Basic
Public Const NAV_RANGE_FILTERS_PARAM As String
Visual C++
public:
literal String^ NAV_RANGE_FILTERS_PARAM

See Also

UrlENEQuery Class


NAV_RECORD_FILTER_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RECORD_FILTER_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation record filters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RECORD_FILTER_PARAM
Visual Basic
Public Const NAV_RECORD_FILTER_PARAM As String
Visual C++
public:
literal String^ NAV_RECORD_FILTER_PARAM

See Also

UrlENEQuery Class


NAV_RECORD_STRUCTURE_EXPR_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RECORD_STRUCTURE_EXPR_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation structure expressions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RECORD_STRUCTURE_EXPR_PARAM
Visual Basic
Public Const NAV_RECORD_STRUCTURE_EXPR_PARAM As String
Visual C++
public:
literal String^ NAV_RECORD_STRUCTURE_EXPR_PARAM

See Also

UrlENEQuery Class


NAV_REFINEMENT_CONFIGS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_REFINEMENT_CONFIGS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation refinement configs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_REFINEMENT_CONFIGS_PARAM
Visual Basic
Public Const NAV_REFINEMENT_CONFIGS_PARAM As String
Visual C++
public:
literal String^ NAV_REFINEMENT_CONFIGS_PARAM

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_RANK_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_RANK_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_RANK_KEY_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_RANK_KEY_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_RANK_KEY_PARAM

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_RANK_MATCH_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_RANK_MATCH_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking match mode

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_RANK_MATCH_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_RANK_MATCH_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_RANK_MATCH_PARAM

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_RANK_STRATEGY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_RANK_STRATEGY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search strategy

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_RANK_STRATEGY_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_RANK_STRATEGY_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_RANK_STRATEGY_PARAM

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_RANK_TERMS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_RANK_TERMS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_RANK_TERMS_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_RANK_TERMS_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_RANK_TERMS_PARAM

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_SEARCH_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_SEARCH_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_SEARCH_KEY_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_SEARCH_KEY_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_SEARCH_KEY_PARAM

Remarks

Deprecated: Later versions of the Endeca API may not support this constant.

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search strategy

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_SEARCH_STRATEGY_PARAM

Remarks

Deprecated: Later versions of the Endeca API may not support this constant.

See Also

UrlENEQuery Class


NAV_RELRANK_EREC_SEARCH_TERMS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_RELRANK_EREC_SEARCH_TERMS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation relevance ranking record search terms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_RELRANK_EREC_SEARCH_TERMS_PARAM
Visual Basic
Public Const NAV_RELRANK_EREC_SEARCH_TERMS_PARAM As String
Visual C++
public:
literal String^ NAV_RELRANK_EREC_SEARCH_TERMS_PARAM

Remarks

Deprecated: Later versions of the Endeca API may not support this constant.

See Also

UrlENEQuery Class


NAV_ROLLUP_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_ROLLUP_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation rollup key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_ROLLUP_KEY_PARAM
Visual Basic
Public Const NAV_ROLLUP_KEY_PARAM As String
Visual C++
public:
literal String^ NAV_ROLLUP_KEY_PARAM

See Also

UrlENEQuery Class


NAV_SORT_KEY_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_SORT_KEY_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation sort key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_SORT_KEY_PARAM
Visual Basic
Public Const NAV_SORT_KEY_PARAM As String
Visual C++
public:
literal String^ NAV_SORT_KEY_PARAM

See Also

UrlENEQuery Class


NAV_SORT_ORDER_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_SORT_ORDER_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation sort order.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_SORT_ORDER_PARAM
Visual Basic
Public Const NAV_SORT_ORDER_PARAM As String
Visual C++
public:
literal String^ NAV_SORT_ORDER_PARAM

See Also

UrlENEQuery Class


NAV_SPECIFIC_REFINEMENTS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_SPECIFIC_REFINEMENTS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation exposed refinements.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_SPECIFIC_REFINEMENTS_PARAM
Visual Basic
Public Const NAV_SPECIFIC_REFINEMENTS_PARAM As String
Visual C++
public:
literal String^ NAV_SPECIFIC_REFINEMENTS_PARAM

See Also

UrlENEQuery Class


NAV_STRATIFIED_DIM_VALS_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..NAV_STRATIFIED_DIM_VALS_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for navigation stratified dim vals.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string NAV_STRATIFIED_DIM_VALS_PARAM
Visual Basic
Public Const NAV_STRATIFIED_DIM_VALS_PARAM As String
Visual C++
public:
literal String^ NAV_STRATIFIED_DIM_VALS_PARAM

See Also

UrlENEQuery Class


QUERY_ID_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..QUERY_ID_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for Request Id

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string QUERY_ID_PARAM
Visual Basic
Public Const QUERY_ID_PARAM As String
Visual C++
public:
literal String^ QUERY_ID_PARAM

Remarks

Deprecated: Later versions of the Endeca API may not support this constant.

See Also

UrlENEQuery Class


SESSION_ID_PARAM Field

[image]

Endeca Presentation API
UrlENEQuery..::..SESSION_ID_PARAM Field
UrlENEQuery Class See Also Send Feedback
Parameter name for Session Id

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const string SESSION_ID_PARAM
Visual Basic
Public Const SESSION_ID_PARAM As String
Visual C++
public:
literal String^ SESSION_ID_PARAM

Remarks

Deprecated: Later versions of the Endeca API may not support this constant.

See Also

UrlENEQuery Class


UrlENEQuery Methods

[image] [image]

Endeca Presentation API
UrlENEQuery Methods
UrlENEQuery Class See Also Send Feedback

The UrlENEQuery type exposes the following members.

Methods

 | Name | Description
Public method | AddSelection | Adds the field named fieldName to the set of fields that should be returned for each record in the result set. (Inherited from ENEQuery.)
Public method | ContainsAggrERecQuery | Returns if this query includes a aggregated record query. (Inherited from ENEQuery.)
Public method | ContainsDimSearchQuery | Returns if this query includes a dimension search query. (Inherited from ENEQuery.)
Public method | ContainsERecQuery | Returns if this query includes a record query. (Inherited from ENEQuery.)
Public method | ContainsERecsQuery | Returns if this query includes a query for records. (Inherited from ENEQuery.)
Public method | ContainsNavQuery | Returns whether the query includes a navigation query. (Inherited from ENEQuery.)
Public method | ContainsQuery | Returns whether the query is querying for any of a navigation, record, dimension search, or a value set search. (Inherited from ENEQuery.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNavActiveSortKeys | Get the list of sort keys with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetNavSortKey | Obsolete. Gets the sort key with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetNavSortOrder | Obsolete. Gets the sort order with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetA | Sets the aggregated record for the query. AggrERec.
Public method | SetAf | Sets the aggregated record navigation range filters. AggrERecNavRangeFilters.
Public method | SetAn | Sets the aggregated record navigation values for the query. AggrERecNavDescriptors.
Public method | SetAr | Sets the aggregated record navigation record filter. AggrERecNavRecordFilter.
Public method | SetArs | Sets the aggregated record structure expression. AggrERecStructureExpr.
Public method | SetAs | Sets the sort key for the record list of the aggregated record query.
Public method | SetAu | Sets the aggregated record rollup key with which the aggregated record is derived. AggrERecRollupKey.
Public method | SetD | Sets the string dimension search query terms. DimSearchTerms.
Public method | SetDf | Sets the dimension search navigation range filters. DimSearchNavRangeFilters.
Public method | SetDi | Sets the dimension(s) with which to dimension search in. DimSearchDimensions.
Public method | SetDk | Sets the dimension search behavior to order results. DimSearchRankResults.
Public method | SetDn | Sets the navigation restriction for the dimension search. DimSearchNavDescriptors
Public method | SetDo | Sets the dimension search results offset. DimSearchResultsOffset.
Public method | SetDp | Obsolete. Sets the number of results to return per dimension. DimSearchNumDimValues
Public method | SetDr | Sets the dimension search navigation record filter. DimSearchNavRangeFilters.
Public method | SetDrc | Sets the list of refinement configs for the dimension search query. refinement configs are delimited by '|'.
Public method | SetDrs | Sets the dimension search navigation structure expression. DimSearchNavRecordStructureExpr.
Public method | SetDu | Sets the rollup key for the dimension search query. DimSearchRollupKey.
Public method | SetDx | Sets the dimension search options. DimSearchOpts.
Public method | SetN | Sets the navigation field of the query. NavDescriptors
Public method | SetNa | Sets an analytics query. AnalyticsQuery
Public method | SetNao | Sets the navigation aggregated record list offset. NavAggrERecsOffset
Public method | SetNavActiveSortKeys | Set the list of sort keys with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNavSortKey | Obsolete. Sets the sort key with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNavSortOrder | Obsolete. Sets the sort order with which the navigation query's records will be sorted. (Inherited from ENEQuery.)
Public method | SetNdr | Sets the Disabled Refinements config for the navigation query.
Public method | SetNe | Sets the exposed navigation refinements. NavExposedRefinements
Public method | SetNf | Sets the range filters for the navigation query. NavRangeFilters.
Public method | SetNk | Sets the key properties request for the navigation query. NavKeyProperties
Public method | SetNmpt |
Public method | SetNmrf |
Public method | SetNo | Sets the navigation record list offset. NavERecsOffset
Public method | SetNp | Sets the number of records per aggregated record. NavERecsPerAggrERec
Public method | SetNr | Sets the record filter for the navigation query. NavRecordFilter.
Public method | SetNrc | Sets the list of dynamic refinement configs for the navigation query. Dynamic refinement configs are delimited by '|'.
Public method | SetNrcs | Sets the list of stratified dim vals used by this navigation query. Stratified dim vals are delimited by ';' and are in the form [strata],[dimvalid].
Public method | SetNrk | Sets the key of the record search of the navigation query using a specified relevance ranking strategy.
Public method | SetNrm | Sets the relevance ranking match mode for the record search of the navigation query.
Public method | SetNrr | Sets the relevance ranking strategy for the record search of the navigation query.
Public method | SetNrs | Sets the structure expression for the navigation query. NavRecordStructureExpr.
Public method | SetNrt | Sets the terms of the record search of the navigation query using a specified relevance ranking strategy.
Public method | SetNs | Sets the sort key for the record list of the navigation.
Public method | SetNso | Sets the sort order for the record list of the navigation.
Public method | SetNtk | Sets the keys of the record search of the navigation query.
Public method | SetNtpc | Sets whether the compute-autophrase record search functionality is on in the query. NavERecSearchComputeAlternativePhrasings
Public method | SetNtpr | Sets whether the rewrite-autophrase record search functionality is on in the query. NavERecSearchRewriteQueryWithAnAlternativePhrasing
Public method | SetNtt | Sets the terms of the record search of the navigation query.
Public method | SetNtx | Sets the options for the record search of the navigation query.
Public method | SetNty | Sets whether the did you mean record search functionality is on in the query. NavERecSearchDidYouMean
Public method | SetNu | Sets the rollup key for the navigation query. NavRollupKey
Public method | SetNx | Sets the navigation query options. NavOpts.
Public method | SetR | Sets the records for query. ERecs.
 | ToQueryString | Takes a ENEQuery and serializes the object into URL query string format.
Public method | ToString()()()() | Returns a string representation of this query.
Public method | ToString(String) | Returns a string representation of this query, using the given character encoding.

See Also

UrlENEQuery Class


SetA Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetA Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record for the query. AggrERec.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetA(
    string a
)
Visual Basic
Public Overridable Sub SetA ( _
    a As String _
)
Visual C++
public:
virtual void SetA(
    String^ a
)

Parameters

a
Type: System..::..String
Where a is an aggregated ERecord specification.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If the aggregated record Id is unable to be parsed.

See Also

UrlENEQuery Class


SetAf Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetAf Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record navigation range filters. AggrERecNavRangeFilters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetAf(
    string filter
)
Visual Basic
Public Overridable Sub SetAf ( _
    filter As String _
)
Visual C++
public:
virtual void SetAf(
    String^ filter
)

Parameters

filter
Type: System..::..String
The navigation range filters for aggregated record query.

Remarks

Multiple filters are specified by '|' delimiting each filter as described in the ENEQuery method.

See Also

UrlENEQuery Class


SetAn Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetAn Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record navigation values for the query. AggrERecNavDescriptors.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetAn(
    string an
)
Visual Basic
Public Overridable Sub SetAn ( _
    an As String _
)
Visual C++
public:
virtual void SetAn(
    String^ an
)

Parameters

an
Type: System..::..String
Values with which to retrieve the aggregated records in relation to.

See Also

UrlENEQuery Class


SetAr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetAr Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record navigation record filter. AggrERecNavRecordFilter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetAr(
    string filter
)
Visual Basic
Public Overridable Sub SetAr ( _
    filter As String _
)
Visual C++
public:
virtual void SetAr(
    String^ filter
)

Parameters

filter
Type: System..::..String
The record filter for the aggregated record query.

See Also

UrlENEQuery Class


SetArs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetArs Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record structure expression. AggrERecStructureExpr.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetArs(
    string expr
)
Visual Basic
Public Overridable Sub SetArs ( _
    expr As String _
)
Visual C++
public:
virtual void SetArs(
    String^ expr
)

Parameters

expr
Type: System..::..String
The structure expression for the aggregated record query.

See Also

UrlENEQuery Class


SetAs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetAs Method
UrlENEQuery Class See Also Send Feedback
Sets the sort key for the record list of the aggregated record query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetAs(
    string keys
)
Visual Basic
Public Overridable Sub SetAs ( _
    keys As String _
)
Visual C++
public:
virtual void SetAs(
    String^ keys
)

Parameters

keys
Type: System..::..String
Sort key

See Also

UrlENEQuery Class


SetAu Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetAu Method
UrlENEQuery Class See Also Send Feedback
Sets the aggregated record rollup key with which the aggregated record is derived. AggrERecRollupKey.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetAu(
    string au
)
Visual Basic
Public Overridable Sub SetAu ( _
    au As String _
)
Visual C++
public:
virtual void SetAu(
    String^ au
)

Parameters

au
Type: System..::..String
Rollup key with which the aggregated record is derived.

See Also

UrlENEQuery Class


SetD Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetD Method
UrlENEQuery Class See Also Send Feedback
Sets the string dimension search query terms. DimSearchTerms.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetD(
    string d
)
Visual Basic
Public Overridable Sub SetD ( _
    d As String _
)
Visual C++
public:
virtual void SetD(
    String^ d
)

Parameters

d
Type: System..::..String
Dimension search query terms.

See Also

UrlENEQuery Class


SetDf Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDf Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search navigation range filters. DimSearchNavRangeFilters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDf(
    string filter
)
Visual Basic
Public Overridable Sub SetDf ( _
    filter As String _
)
Visual C++
public:
virtual void SetDf(
    String^ filter
)

Parameters

filter
Type: System..::..String
The navigation range filters for dimension search query.

Remarks

Multiple filters are specified by '|' delimiting each filter as described in the ENEQuery method.

See Also

UrlENEQuery Class


SetDi Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDi Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension(s) with which to dimension search in. DimSearchDimensions.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDi(
    string d
)
Visual Basic
Public Overridable Sub SetDi ( _
    d As String _
)
Visual C++
public:
virtual void SetDi(
    String^ d
)

Parameters

d
Type: System..::..String
Where d is list of dimensions to search within.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the the dimension Id(s).

See Also

UrlENEQuery Class


SetDk Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDk Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search behavior to order results. DimSearchRankResults.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDk(
    string r
)
Visual Basic
Public Overridable Sub SetDk ( _
    r As String _
)
Visual C++
public:
virtual void SetDk(
    String^ r
)

Parameters

r
Type: System..::..String
Either 0 (the default) to use the default dimension value ranking to order dimension search results or 1 to use relevance ranking.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse how the dimension search results should be ordered.

See Also

UrlENEQuery Class


SetDn Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDn Method
UrlENEQuery Class See Also Send Feedback
Sets the navigation restriction for the dimension search. DimSearchNavDescriptors

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDn(
    string n
)
Visual Basic
Public Overridable Sub SetDn ( _
    n As String _
)
Visual C++
public:
virtual void SetDn(
    String^ n
)

Parameters

n
Type: System..::..String
Where n is ' ' delimited string of dimension value Ids.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the navigation restrictions.

See Also

UrlENEQuery Class


SetDo Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDo Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search results offset. DimSearchResultsOffset.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDo(
    string o
)
Visual Basic
Public Overridable Sub SetDo ( _
    o As String _
)
Visual C++
public:
virtual void SetDo(
    String^ o
)

Parameters

o
Type: System..::..String
Where o is the offset into the results.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the offset.

See Also

UrlENEQuery Class


SetDp Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDp Method
UrlENEQuery Class See Also Send Feedback
Sets the number of results to return per dimension. DimSearchNumDimValues

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use setDrc(string) instead.")]
public virtual void SetDp(
    string num
)
Visual Basic
<ObsoleteAttribute("This method may not be supported in future versions of the MDEX Engine API. Use setDrc(string) instead.")> _
Public Overridable Sub SetDp ( _
    num As String _
)
Visual C++
[ObsoleteAttribute(L"This method may not be supported in future versions of the MDEX Engine API. Use setDrc(string) instead.")]
public:
virtual void SetDp(
    String^ num
)

Parameters

num
Type: System..::..String
Sets the number of values per dimension.

Remarks

Deprecated: This method may not be supported in future versions of the MDEX Engine API. Use setDrc(string) instead.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the number of results per dimension.

See Also

UrlENEQuery Class


SetDr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDr Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search navigation record filter. DimSearchNavRangeFilters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDr(
    string filter
)
Visual Basic
Public Overridable Sub SetDr ( _
    filter As String _
)
Visual C++
public:
virtual void SetDr(
    String^ filter
)

Parameters

filter
Type: System..::..String
The record filter for the dimension search query.

See Also

UrlENEQuery Class


SetDrc Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDrc Method
UrlENEQuery Class See Also Send Feedback
Sets the list of refinement configs for the dimension search query. refinement configs are delimited by '|'.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDrc(
    string configs
)
Visual Basic
Public Overridable Sub SetDrc ( _
    configs As String _
)
Visual C++
public:
virtual void SetDrc(
    String^ configs
)

Parameters

configs
Type: System..::..String
A urldecoded '|' delimited sequence of refinement configs.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse or pair up key+value pairs.

See Also

UrlENEQuery Class


SetDrs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDrs Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search navigation structure expression. DimSearchNavRecordStructureExpr.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDrs(
    string expr
)
Visual Basic
Public Overridable Sub SetDrs ( _
    expr As String _
)
Visual C++
public:
virtual void SetDrs(
    String^ expr
)

Parameters

expr
Type: System..::..String
The structure expression for the dimension search query.

See Also

UrlENEQuery Class


SetDu Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDu Method
UrlENEQuery Class See Also Send Feedback
Sets the rollup key for the dimension search query. DimSearchRollupKey.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDu(
    string key
)
Visual Basic
Public Overridable Sub SetDu ( _
    key As String _
)
Visual C++
public:
virtual void SetDu(
    String^ key
)

Parameters

key
Type: System..::..String

See Also

UrlENEQuery Class


SetDx Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetDx Method
UrlENEQuery Class See Also Send Feedback
Sets the dimension search options. DimSearchOpts.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDx(
    string opts
)
Visual Basic
Public Overridable Sub SetDx ( _
    opts As String _
)
Visual C++
public:
virtual void SetDx(
    String^ opts
)

Parameters

opts
Type: System..::..String
The options for the dimension search operation.

See Also

UrlENEQuery Class


SetN Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetN Method
UrlENEQuery Class See Also Send Feedback
Sets the navigation field of the query. NavDescriptors

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetN(
    string n
)
Visual Basic
Public Overridable Sub SetN ( _
    n As String _
)
Visual C++
public:
virtual void SetN(
    String^ n
)

Parameters

n
Type: System..::..String
Dimension value Ids delimtted by ' '.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If the navigation values are not able to be parsed.

See Also

UrlENEQuery Class


SetNa Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNa Method
UrlENEQuery Class See Also Send Feedback
Sets an analytics query. AnalyticsQuery

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNa(
    string query
)
Visual Basic
Public Overridable Sub SetNa ( _
    query As String _
)
Visual C++
public:
virtual void SetNa(
    String^ query
)

Parameters

query
Type: System..::..String
The analytics query.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the query is malformed.

See Also

UrlENEQuery Class


SetNao Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNao Method
UrlENEQuery Class See Also Send Feedback
Sets the navigation aggregated record list offset. NavAggrERecsOffset

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNao(
    string o
)
Visual Basic
Public Overridable Sub SetNao ( _
    o As String _
)
Visual C++
public:
virtual void SetNao(
    String^ o
)

Parameters

o
Type: System..::..String
The offset into the record list.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If the aggregated offset parameter is not able to be parsed.

See Also

UrlENEQuery Class


SetNdr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNdr Method
UrlENEQuery Class See Also Send Feedback
Sets the Disabled Refinements config for the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNdr(
    string configs
)
Visual Basic
Public Overridable Sub SetNdr ( _
    configs As String _
)
Visual C++
public:
virtual void SetNdr(
    String^ configs
)

Parameters

configs
Type: System..::..String

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing disabled-refinements configuration.

See Also

UrlENEQuery Class


SetNe Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNe Method
UrlENEQuery Class See Also Send Feedback
Sets the exposed navigation refinements. NavExposedRefinements

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNe(
    string e
)
Visual Basic
Public Overridable Sub SetNe ( _
    e As String _
)
Visual C++
public:
virtual void SetNe(
    String^ e
)

Parameters

e
Type: System..::..String
Where e is ' ' delimited string of dimension value ids.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If there is an error in parsing the exposed refinements.

See Also

UrlENEQuery Class


SetNf Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNf Method
UrlENEQuery Class See Also Send Feedback
Sets the range filters for the navigation query. NavRangeFilters.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNf(
    string filter
)
Visual Basic
Public Overridable Sub SetNf ( _
    filter As String _
)
Visual C++
public:
virtual void SetNf(
    String^ filter
)

Parameters

filter
Type: System..::..String
The range filters for navigation query.

Remarks

Multiple filters are specified by '|' delimiting each filter as described in the ENEQuery method.

See Also

UrlENEQuery Class


SetNk Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNk Method
UrlENEQuery Class See Also Send Feedback
Sets the key properties request for the navigation query. NavKeyProperties

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNk(
    string o
)
Visual Basic
Public Overridable Sub SetNk ( _
    o As String _
)
Visual C++
public:
virtual void SetNk(
    String^ o
)

Parameters

o
Type: System..::..String
The key properties request (all or none) for the navigation query.

See Also

UrlENEQuery Class


SetNmpt Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNmpt Method
UrlENEQuery Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNmpt(
    string previewTime
)
Visual Basic
Public Overridable Sub SetNmpt ( _
    previewTime As String _
)
Visual C++
public:
virtual void SetNmpt(
    String^ previewTime
)

Parameters

previewTime
Type: System..::..String

See Also

UrlENEQuery Class


SetNmrf Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNmrf Method
UrlENEQuery Class See Also Send Feedback

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNmrf(
    string filter
)
Visual Basic
Public Overridable Sub SetNmrf ( _
    filter As String _
)
Visual C++
public:
virtual void SetNmrf(
    String^ filter
)

Parameters

filter
Type: System..::..String

See Also

UrlENEQuery Class


SetNo Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNo Method
UrlENEQuery Class See Also Send Feedback
Sets the navigation record list offset. NavERecsOffset

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNo(
    string o
)
Visual Basic
Public Overridable Sub SetNo ( _
    o As String _
)
Visual C++
public:
virtual void SetNo(
    String^ o
)

Parameters

o
Type: System..::..String
The offset into the record list.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If the offset parameter is not able to be parsed.

See Also

UrlENEQuery Class


SetNp Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNp Method
UrlENEQuery Class See Also Send Feedback
Sets the number of records per aggregated record. NavERecsPerAggrERec

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNp(
    string num
)
Visual Basic
Public Overridable Sub SetNp ( _
    num As String _
)
Visual C++
public:
virtual void SetNp(
    String^ num
)

Parameters

num
Type: System..::..String
Where num is one of the values: ALL_ERECS_PER_AGGR, ONE_EREC_PER_AGGR, or ZERO_ERECS_PER_AGGR

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the number of records per aggregated record.

See Also

UrlENEQuery Class


SetNr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNr Method
UrlENEQuery Class See Also Send Feedback
Sets the record filter for the navigation query. NavRecordFilter.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNr(
    string filter
)
Visual Basic
Public Overridable Sub SetNr ( _
    filter As String _
)
Visual C++
public:
virtual void SetNr(
    String^ filter
)

Parameters

filter
Type: System..::..String
The record filter for navigation query.

See Also

UrlENEQuery Class


SetNrc Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrc Method
UrlENEQuery Class See Also Send Feedback
Sets the list of dynamic refinement configs for the navigation query. Dynamic refinement configs are delimited by '|'.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrc(
    string configs
)
Visual Basic
Public Overridable Sub SetNrc ( _
    configs As String _
)
Visual C++
public:
virtual void SetNrc(
    String^ configs
)

Parameters

configs
Type: System..::..String
A urldecoded '|' delimited sequence of refinement configs.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse or pair up key+value pairs.

See Also

UrlENEQuery Class


SetNrcs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrcs Method
UrlENEQuery Class See Also Send Feedback
Sets the list of stratified dim vals used by this navigation query. Stratified dim vals are delimited by ';' and are in the form [strata],[dimvalid].

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrcs(
    string configs
)
Visual Basic
Public Overridable Sub SetNrcs ( _
    configs As String _
)
Visual C++
public:
virtual void SetNrcs(
    String^ configs
)

Parameters

configs
Type: System..::..String
A urldecoded ';' delimited sequence of stratified dim vals.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If problem parsing the pairs

See Also

UrlENEQuery Class


SetNrk Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrk Method
UrlENEQuery Class See Also Send Feedback
Sets the key of the record search of the navigation query using a specified relevance ranking strategy.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrk(
    string key
)
Visual Basic
Public Overridable Sub SetNrk ( _
    key As String _
)
Visual C++
public:
virtual void SetNrk(
    String^ key
)

Parameters

key
Type: System..::..String
The url decoded key to be used for relevance ranking.
CopyC#
key
 should not contain any '|' characters.

Remarks

The Nrk parameter MUST be used with the Nrt parameter indicating the search term and the Nrr parameter indicating the relevance ranking strategy to be used.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search terms.

See Also

UrlENEQuery Class


SetNrm Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrm Method
UrlENEQuery Class See Also Send Feedback
Sets the relevance ranking match mode for the record search of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrm(
    string relRankMatchMode
)
Visual Basic
Public Overridable Sub SetNrm ( _
    relRankMatchMode As String _
)
Visual C++
public:
virtual void SetNrm(
    String^ relRankMatchMode
)

Parameters

relRankMatchMode
Type: System..::..String

Remarks

The Nrm parameter may be used with the Nrt, Nrk and Nrr parameters. If it is not used then the match mode will default to MatchAny.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search keys.

See Also

UrlENEQuery Class


SetNrr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrr Method
UrlENEQuery Class See Also Send Feedback
Sets the relevance ranking strategy for the record search of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrr(
    string relRankStrategy
)
Visual Basic
Public Overridable Sub SetNrr ( _
    relRankStrategy As String _
)
Visual C++
public:
virtual void SetNrr(
    String^ relRankStrategy
)

Parameters

relRankStrategy
Type: System..::..String
The urldecoded relevance ranking strategy to be used.
CopyC#
relRankStrategy
 should not contain any '|' characters.

Remarks

The Nrr parameter MUST be used with the Nrt and Nrk parameters.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search keys.

See Also

UrlENEQuery Class


SetNrs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrs Method
UrlENEQuery Class See Also Send Feedback
Sets the structure expression for the navigation query. NavRecordStructureExpr.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrs(
    string expr
)
Visual Basic
Public Overridable Sub SetNrs ( _
    expr As String _
)
Visual C++
public:
virtual void SetNrs(
    String^ expr
)

Parameters

expr
Type: System..::..String
The structure expression for navigation query.

See Also

UrlENEQuery Class


SetNrt Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNrt Method
UrlENEQuery Class See Also Send Feedback
Sets the terms of the record search of the navigation query using a specified relevance ranking strategy.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNrt(
    string terms
)
Visual Basic
Public Overridable Sub SetNrt ( _
    terms As String _
)
Visual C++
public:
virtual void SetNrt(
    String^ terms
)

Parameters

terms
Type: System..::..String
A urldecoded record search term set.
CopyC#
terms
 should not contain any '|' characters.

Remarks

The Nrt parameter MUST be used with the Nrk parameter indicating which key of the records to search and the Nrr parameter indicating the relevance ranking strategy to be used.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search keys.

See Also

UrlENEQuery Class


SetNs Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNs Method
UrlENEQuery Class See Also Send Feedback
Sets the sort key for the record list of the navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNs(
    string keys
)
Visual Basic
Public Overridable Sub SetNs ( _
    keys As String _
)
Visual C++
public:
virtual void SetNs(
    String^ keys
)

Parameters

keys
Type: System..::..String
Sort key of the navigation.

See Also

UrlENEQuery Class


SetNso Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNso Method
UrlENEQuery Class See Also Send Feedback
Sets the sort order for the record list of the navigation.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNso(
    string key
)
Visual Basic
Public Overridable Sub SetNso ( _
    key As String _
)
Visual C++
public:
virtual void SetNso(
    String^ key
)

Parameters

key
Type: System..::..String
Sort order of the navigation where order is one of: NAV_SORT_ASCENDING, or NAV_SORT_DESCENDING.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If unable to parse the sort order.

See Also

UrlENEQuery Class


SetNtk Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNtk Method
UrlENEQuery Class See Also Send Feedback
Sets the keys of the record search of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNtk(
    string keys
)
Visual Basic
Public Overridable Sub SetNtk ( _
    keys As String _
)
Visual C++
public:
virtual void SetNtk(
    String^ keys
)

Parameters

keys
Type: System..::..String
A urldecoded '|' delimited sequence of record search keys.

Remarks

The keys are delimited by '|'. The Ntt parameter MUST be used with the Ntt parameter indicating the search terms for each key. In addition Ntt should have the same number of term sets as Ntk has keys.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search terms.

See Also

UrlENEQuery Class


SetNtpc Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNtpc Method
UrlENEQuery Class See Also Send Feedback
Sets whether the compute-autophrase record search functionality is on in the query. NavERecSearchComputeAlternativePhrasings

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNtpc(
    string autophrase
)
Visual Basic
Public Overridable Sub SetNtpc ( _
    autophrase As String _
)
Visual C++
public:
virtual void SetNtpc(
    String^ autophrase
)

Parameters

autophrase
Type: System..::..String

See Also

UrlENEQuery Class


SetNtpr Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNtpr Method
UrlENEQuery Class See Also Send Feedback
Sets whether the rewrite-autophrase record search functionality is on in the query. NavERecSearchRewriteQueryWithAnAlternativePhrasing

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNtpr(
    string autophrasedwim
)
Visual Basic
Public Overridable Sub SetNtpr ( _
    autophrasedwim As String _
)
Visual C++
public:
virtual void SetNtpr(
    String^ autophrasedwim
)

Parameters

autophrasedwim
Type: System..::..String

See Also

UrlENEQuery Class


SetNtt Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNtt Method
UrlENEQuery Class See Also Send Feedback
Sets the terms of the record search of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNtt(
    string termSets
)
Visual Basic
Public Overridable Sub SetNtt ( _
    termSets As String _
)
Visual C++
public:
virtual void SetNtt(
    String^ termSets
)

Parameters

termSets
Type: System..::..String
A urldecoded '|' delimited sequence of record search term sets.

Remarks

Each set of terms are delimited by '|'. The Ntt parameter MUST be used with the Ntk parameter indicating which keys of the records to search. In addition Ntt should have the same number of term sets as Ntk has keys.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search keys.

See Also

UrlENEQuery Class


SetNtx Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNtx Method
UrlENEQuery Class See Also Send Feedback
Sets the options for the record search of the navigation query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNtx(
    string termSets
)
Visual Basic
Public Overridable Sub SetNtx ( _
    termSets As String _
)
Visual C++
public:
virtual void SetNtx(
    String^ termSets
)

Parameters

termSets
Type: System..::..String
A urldecoded '|' delimited sequence of record search option sets.

Remarks

Each set of options is delimited by '|'. The Ntx parameter MUST be used with the Ntt and Ntk parameters, and should have the same number of values as these parameters.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | Thrown if problem parsing or pairing up with search keys.

See Also

UrlENEQuery Class


SetNty Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNty Method
UrlENEQuery Class See Also Send Feedback
Sets whether the did you mean record search functionality is on in the query. NavERecSearchDidYouMean

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNty(
    string dym
)
Visual Basic
Public Overridable Sub SetNty ( _
    dym As String _
)
Visual C++
public:
virtual void SetNty(
    String^ dym
)

Parameters

dym
Type: System..::..String
0 for off. 1 for on.

See Also

UrlENEQuery Class


SetNu Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNu Method
UrlENEQuery Class See Also Send Feedback
Sets the rollup key for the navigation query. NavRollupKey

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNu(
    string key
)
Visual Basic
Public Overridable Sub SetNu ( _
    key As String _
)
Visual C++
public:
virtual void SetNu(
    String^ key
)

Parameters

key
Type: System..::..String
Rollup the navigation with this key.

See Also

UrlENEQuery Class


SetNx Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetNx Method
UrlENEQuery Class See Also Send Feedback
Sets the navigation query options. NavOpts.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetNx(
    string opts
)
Visual Basic
Public Overridable Sub SetNx ( _
    opts As String _
)
Visual C++
public:
virtual void SetNx(
    String^ opts
)

Parameters

opts
Type: System..::..String
The options for the navigation query (other than options for record search, which are handled by Ntx).

See Also

UrlENEQuery Class


SetR Method

[image]

Endeca Presentation API
UrlENEQuery..::..SetR Method
UrlENEQuery Class See Also Send Feedback
Sets the records for query. ERecs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetR(
    string r
)
Visual Basic
Public Overridable Sub SetR ( _
    r As String _
)
Visual C++
public:
virtual void SetR(
    String^ r
)

Parameters

r
Type: System..::..String
Record Ids delimitted by ' '.

Exceptions

Exception | Condition
Endeca.Navigation..::..UrlENEQueryParseException | If the record Ids are not able to be parsed.

See Also

UrlENEQuery Class


ToQueryString Method

[image]

Endeca Presentation API
UrlENEQuery..::..ToQueryString Method
UrlENEQuery Class See Also Send Feedback
Takes a ENEQuery and serializes the object into URL query string format.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static string ToQueryString(
    ENEQuery neq,
    string encoding
)
Visual Basic
Public Shared Function ToQueryString ( _
    neq As ENEQuery, _
    encoding As String _
) As String
Visual C++
public:
static String^ ToQueryString(
    ENEQuery^ neq,
    String^ encoding
)

Parameters

neq
Type: Endeca.Navigation..::..ENEQuery
ENEQuery to be serialized into URL query string format.
encoding
Type: System..::..String
The URL encoding (for example, "latin-1" or "unicode").

Return Value

A URL query string form of the neq.

Remarks

Parameters are x-www-form-urlencoded.

See Also

UrlENEQuery Class


ToString Method

[image] [image]

Endeca Presentation API
UrlENEQuery..::..ToString Method
UrlENEQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string representation of this query.
Public method | ToString(String) | Returns a string representation of this query, using the given character encoding.

See Also

UrlENEQuery Class
UrlENEQuery Members


ToString Method

[image]

Endeca Presentation API
UrlENEQuery..::..ToString Method
UrlENEQuery Class See Also Send Feedback
Returns a string representation of this query.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToString()
Visual Basic
Public Function ToString As String
Visual C++
public:
String^ ToString()

Return Value

A URL query string representation.

Remarks

The output format is of URL query string format. The same format as the input to the one argument constructor.

See Also

UrlENEQuery Class
ToString Overload


ToString Method (String)

[image]

Endeca Presentation API
UrlENEQuery..::..ToString Method (String)
UrlENEQuery Class See Also Send Feedback
Returns a string representation of this query, using the given character encoding.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToString(
    string encoding
)
Visual Basic
Public Function ToString ( _
    encoding As String _
) As String
Visual C++
public:
String^ ToString(
    String^ encoding
)

Parameters

encoding
Type: System..::..String
The URL encoding (for example, "latin-1" or "unicode").

Return Value

A URL query string representation.

Remarks

The output format is of URL query string format. The same format as the input to the one argument constructor.

See Also

UrlENEQuery Class
ToString Overload


UrlENEQuery Properties

[image] [image]

Endeca Presentation API
UrlENEQuery Properties
UrlENEQuery Class See Also Send Feedback

The UrlENEQuery type exposes the following members.

Properties

Name Description
Public property AggrERec Obsolete.
Gets or sets the Id of the aggregated record to be queried for.
(Inherited from ENEQuery.)
Public property AggrERecActiveSortKeys
Get the list of sort keys with which the aggregated records representative records will be sorted.
(Inherited from ENEQuery.)
Public property AggrERecNavDescriptors
Gets or sets the navigation values which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecNavRangeFilters
Gets or sets the navigation range filters which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecNavRecordFilter
Gets or sets the record filter which the aggregated record will be composed in relation to.
(Inherited from ENEQuery.)
Public property AggrERecRollupKey
Gets or sets the rollup key the aggregated record is composed by.
(Inherited from ENEQuery.)
Public property AggrERecSpec
Gets or sets the specification of the aggregated record to be queried for.
(Inherited from ENEQuery.)
Public property AggrERecStructureExpr
Gets or sets the structure expression used to filter members of the aggregated record.
(Inherited from ENEQuery.)
Public property AnalyticsQuery
Gets and sets the AnalyticsQuery instance that represents the Analytics query that will be sent to the MDEX Engine. On set, if the query is malformed, it will not be set on the HttpENEConnection and a SyntaxException is thrown. An AnalyticsQuery instance can be built programmatically or by calling the parseQuery(String) method.
(Inherited from ENEQuery.)
Public property DimSearchCompound
Gets and sets whether dimension search will include compound results.
(Inherited from ENEQuery.)
Public property DimSearchDimension
Gets and sets the dimension which which the dimension search can search from.
(Inherited from ENEQuery.)
Public property DimSearchDimensions
Gets and sets the dimensions which which the dimension search can search from.
(Inherited from ENEQuery.)
Public property DimSearchNavDescriptors
Gets and sets the navigation values that describe a navigation state that restrict the number of values that can be searched from.
(Inherited from ENEQuery.)
Public property DimSearchNavRangeFilters
Gets and sets the navigation range filters that restrict the dimension search.
(Inherited from ENEQuery.)
Public property DimSearchNavRecordFilter
Gets and sets the record filter that will restrict the dimension search results.
(Inherited from ENEQuery.)
Public property DimSearchNavRecordStructureExpr
Gets and sets the structure expression that will restrict the dimension search results.
(Inherited from ENEQuery.)
Public property DimSearchNumDimValues Obsolete.
Gets and sets the number of values returned from each dimension for value search.
(Inherited from ENEQuery.)
Public property DimSearchOpts
Gets and sets the option set that dimension search will use.
(Inherited from ENEQuery.)
Public property DimSearchRankResults
Gets and sets how the dimension search will order its results.
(Inherited from ENEQuery.)
Public property DimSearchRefinementConfigs
Gets and sets the list of refinement configs to be used by the MDEX Engine for dimension search
(Inherited from ENEQuery.)
Public property DimSearchResultsOffset
Gets and sets the offset with which the dimension search will begin returning results per dimension.
(Inherited from ENEQuery.)
Public property DimSearchRollupKey
Gets and sets the rollup key which the records of the dimension search query should use to create aggregated counts. By setting a rollupKey with this method, aggregated counts are returned as the value for the
CopyC#
Dgraph.AggrBins
 key of the
CopyC#
DimVal
 object's
CopyC#
PropertyMap
.
(Inherited from ENEQuery.)
Public property DimSearchTerms
Gets and sets the search terms the dimension search will use.
(Inherited from ENEQuery.)
Public property ERec
Sets the Id of the record to be queried for.
(Inherited from ENEQuery.)
Public property ERecs
Gets or sets the Ids of the records to be queried for.
(Inherited from ENEQuery.)
Public property LanguageId
Gets and sets the ISO639 language code to be used for this query. The language id is sent to the MDEX Engine when the query is executed, and specifies the language of any text portion of the query. For example: search terms.
(Inherited from ENEQuery.)
Public property NavAggrERecsOffset
Gets and sets the offset into the navigation aggregated record list for navigation query.
(Inherited from ENEQuery.)
Public property NavAllRefinements
Gets and sets the query such that the navigation query will return with all the refinements possible for all dimensions.
(Inherited from ENEQuery.)
Public property NavDescriptors
Gets and sets the navigation descriptor IDs describing the navigation object to be queried for.
(Inherited from ENEQuery.)
Public property NavDisabledRefinementsConfig
Gets and sets the disabled refinements config.
(Inherited from ENEQuery.)
Public property NavERecSearchComputeAlternativePhrasings
Gets and sets if the fulltext search should turn on the compute-autophrase feature.
(Inherited from ENEQuery.)
Public property NavERecSearchDidYouMean
Gets and sets if the fulltext search should turn on the did you mean feature.
(Inherited from ENEQuery.)
Public property NavERecSearches
Gets and sets the navigation record searches to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavERecSearchRewriteQueryWithAnAlternativePhrasing
Gets and sets if the fulltext search should turn on the rewrite-autophrase feature.
(Inherited from ENEQuery.)
Public property NavERecsOffset
Gets and sets the offset into the navigation record list for navigation query.
(Inherited from ENEQuery.)
Public property NavERecsPerAggrERec
Gets and sets the max number of records to be returned in each aggregated record.
(Inherited from ENEQuery.)
Public property NavExposedRefinements
Gets and sets the set of refinements that should be exposed / returned with the navigation query.
(Inherited from ENEQuery.)
Public property NavKeyProperties
Get and sets the number of key properties to be returned.
(Inherited from ENEQuery.)
Public property NavMerchPreviewTime
Gets and sets the merch preview time on this navigation query.
(Inherited from ENEQuery.)
Public property NavMerchRuleFilter
Gets and sets the merch rule filter on this navigation query.
(Inherited from ENEQuery.)
Public property NavNumAggrERecs
Gets and sets the max number of aggregated records returned for the navigation query.
(Inherited from ENEQuery.)
Public property NavNumBulkAggrERecs
Gets and sets the max number of aggregated records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all aggregated records for the navigation query will be returned.
(Inherited from ENEQuery.)
Public property NavNumBulkERecs
Gets and sets the max number of records returned in bulk format for the navigation query. If MAX_BULK_ERECS_AVAILABLE is passed to this method, then all records for the navigation query will be returned.
(Inherited from ENEQuery.)
Public property NavNumERecs
Get and sets the max number of records returned for the navigation query.
(Inherited from ENEQuery.)
Public property NavOpts
Gets and sets the option set that navigation queries will use.
(Inherited from ENEQuery.)
Public property NavRangeFilters
Gets and sets the navigation range filters on this navigation query.
(Inherited from ENEQuery.)
Public property NavRecordFilter
Gets and sets the record filters on this navigation query.
(Inherited from ENEQuery.)
Public property NavRecordStructureExpr
Gets and sets the structure expression on this navigation query.
(Inherited from ENEQuery.)
Public property NavRefinementConfigs
Gets and sets the list of dynamic refinement configs to be used by the MDEX Engine.
(Inherited from ENEQuery.)
Public property NavRelRankERecRank
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavRelRankERecSearch Obsolete.
Gets and sets the navigation relevance ranking record search to perform on the records of the navigation query.
(Inherited from ENEQuery.)
Public property NavRollupKey
Gets and sets the rollup key with which the records of the navigation query should be rolled up with to create aggregated records.
(Inherited from ENEQuery.)
Public property NavStratifiedDimVals
Gets and sets the list stratified dim vals for use during refinement ranking by the MDEX engine.
(Inherited from ENEQuery.)
Public property Profiles
Gets and sets the set of profiles that describe the application end user.
(Inherited from ENEQuery.)
Public property QueryInfo
Gets and sets the ENEQueryInfo object.
(Inherited from ENEQuery.)
Public property Selection
Gets and sets the select list for the query.
(Inherited from ENEQuery.)

See Also

UrlENEQuery Class


UrlENEQueryParseException Class

[image]

Endeca Presentation API
UrlENEQueryParseException Class
Members See Also Send Feedback
Exception representing an error while parsing a URL for a UrlENEQuery.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class UrlENEQueryParseException : ENEQueryException
Visual Basic
Public Class UrlENEQueryParseException _
    Inherits ENEQueryException
Visual C++
public ref class UrlENEQueryParseException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..UrlENEQueryParseException

See Also

UrlENEQueryParseException Members


UrlENEQueryParseException Members

[image] [image]

Endeca Presentation API
UrlENEQueryParseException Members
UrlENEQueryParseException Class Methods Properties See Also Send Feedback

The UrlENEQueryParseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UrlENEQueryParseException Class


UrlENEQueryParseException Methods

[image] [image]

Endeca Presentation API
UrlENEQueryParseException Methods
UrlENEQueryParseException Class See Also Send Feedback

The UrlENEQueryParseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UrlENEQueryParseException Class


UrlENEQueryParseException Properties

[image] [image]

Endeca Presentation API
UrlENEQueryParseException Properties
UrlENEQueryParseException Class See Also Send Feedback

The UrlENEQueryParseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UrlENEQueryParseException Class


UrlGen Class

[image]

Endeca Presentation API
UrlGen Class
Members See Also Send Feedback
A generic toolkit for manipulating and generating URL query strings.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class UrlGen
Visual Basic
Public Class UrlGen
Visual C++
public ref class UrlGen

Remarks

The intended use of UrlGen was for the management of state and query parameters when dealing with UrlENEQuery objects.

UrlGen takes either a query string in a constructor as the base query to work with or none which indicates that it begins with an empty base. The ToString()()()() method called immediately after the constructor will return the original input URL or none if none was specified.

The remove params and add parameters are evaluated in order. That is removes placed after an add may delete the parameter you just added.

This toolkit attempts to preserve whatever input URL parameters are input to the system as long as they follow the structure of an & delimited, x-www-form-urlencoded parameter value pairs. In the case of multiple parameters with the same name, the multiple pairs will be preserved on output, however, a remove, or add with the same name will remove or overwrite the all of the keys with that name. An append on the other hand will preserve the previous prameter. Append adds parameters without knowledge of the previous.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation..::..UrlGen

See Also

UrlGen Members


UrlGen Members

[image] [image]

Endeca Presentation API
UrlGen Members
UrlGen Class Constructors Methods See Also Send Feedback

The UrlGen type exposes the following members.

Constructors

 | Name | Description
Public method | UrlGen()()()() | Obsolete. Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.
Public method | UrlGen(String) | Obsolete. Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.
Public method | UrlGen(String, String) | Constructor where the start URL will be the one specified in this constructor.

Methods

 | Name | Description
Public method | AddParam | Manipulates the resultant URL by adding this key value pair.
Public method | AddParams | Bulk add of param pairs.
Public method | AppendParam | Manipulates the resultant url by adding this key value pair.
Public method | AppendParams | Bulk append of param pairs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParam | Removes any key value parameter from the to be outputted URL with the parameter name key.
Public method | RemoveParams | Removes any key value parameter with the keys specified in the collection.
Public method | ToString | The output method on this class. (Overrides Object..::..ToString()()()().)

See Also

UrlGen Class


UrlGen Constructor

[image] [image]

Endeca Presentation API
UrlGen Constructor
UrlGen Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UrlGen()()()() | Obsolete. Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.
Public method | UrlGen(String) | Obsolete. Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.
Public method | UrlGen(String, String) | Constructor where the start URL will be the one specified in this constructor.

See Also

UrlGen Class
UrlGen Members


UrlGen Constructor

[image]

Endeca Presentation API
UrlGen Constructor
UrlGen Class See Also Send Feedback
Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")]
public UrlGen()
Visual Basic
<ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")> _
Public Sub New
Visual C++
[ObsoleteAttribute(L"This constructor is obsolete; use the version that takes an encoding instead")]
public:
UrlGen()

See Also

UrlGen Class
UrlGen Overload


UrlGen Constructor (String)

[image]

Endeca Presentation API
UrlGen Constructor (String)
UrlGen Class See Also Send Feedback
Obsolete. Use the constructor that takes an encoding instead. This version defaults to using the "windows-1252" encoding.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
[ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")]
public UrlGen(
    string queryString
)
Visual Basic
<ObsoleteAttribute("This constructor is obsolete; use the version that takes an encoding instead")> _
Public Sub New ( _
    queryString As String _
)
Visual C++
[ObsoleteAttribute(L"This constructor is obsolete; use the version that takes an encoding instead")]
public:
UrlGen(
    String^ queryString
)

Parameters

queryString
Type: System..::..String
The base query string with which this class manipulates.

Remarks

This URL is the base with which this UrlGen manipulates. startUrl's form is of URL query string. That is everything of a URL after the '?' mark and of the form where the query is made up of key value pairs delimited by '&' and each pair delimited by '=' and the keys and values are x-www-form-urlencoded.

See Also

UrlGen Class
UrlGen Overload


UrlGen Constructor (String, String)

[image]

Endeca Presentation API
UrlGen Constructor (String, String)
UrlGen Class See Also Send Feedback
Constructor where the start URL will be the one specified in this constructor.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public UrlGen(
    string queryString,
    string encoding
)
Visual Basic
Public Sub New ( _
    queryString As String, _
    encoding As String _
)
Visual C++
public:
UrlGen(
    String^ queryString,
    String^ encoding
)

Parameters

queryString
Type: System..::..String
The base query string with which this class manipulates.
encoding
Type: System..::..String
The encoding to use for the URL. Typically "windows-1252" or "UTF-8".

Remarks

This URL is the base with which this UrlGen manipulates. startUrl's form is of URL query string. That is everything of a URL after the '?' mark and of the form where the query is made up of key value pairs delimited by '&' and each pair delimited by '=' and the keys and values are x-www-form-urlencoded.

See Also

UrlGen Class
UrlGen Overload


UrlGen Methods

[image] [image]

Endeca Presentation API
UrlGen Methods
UrlGen Class See Also Send Feedback

The UrlGen type exposes the following members.

Methods

 | Name | Description
Public method | AddParam | Manipulates the resultant URL by adding this key value pair.
Public method | AddParams | Bulk add of param pairs.
Public method | AppendParam | Manipulates the resultant url by adding this key value pair.
Public method | AppendParams | Bulk append of param pairs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveParam | Removes any key value parameter from the to be outputted URL with the parameter name key.
Public method | RemoveParams | Removes any key value parameter with the keys specified in the collection.
Public method | ToString | The output method on this class. (Overrides Object..::..ToString()()()().)

See Also

UrlGen Class


AddParam Method

[image]

Endeca Presentation API
UrlGen..::..AddParam Method
UrlGen Class See Also Send Feedback
Manipulates the resultant URL by adding this key value pair.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddParam(
    string key,
    string val
)
Visual Basic
Public Overridable Sub AddParam ( _
    key As String, _
    val As String _
)
Visual C++
public:
virtual void AddParam(
    String^ key,
    String^ val
)

Parameters

key
Type: System..::..String
Key name of the pair to be added.
val
Type: System..::..String
Value to be added to the output URL where the value is decoded.

Remarks

This method will overwrite ANY of the original parameters with the same key and any other parameter that got added by this same method previously with the same key. In addition, it is assumed that val is decoded and will encode the value as x-www-form-urlencoded on output. Values that are null or equal to "" will be skipped so that this method can be blindly called without having to check if the value is present.

See Also

UrlGen Class


AddParams Method

[image]

Endeca Presentation API
UrlGen..::..AddParams Method
UrlGen Class See Also Send Feedback
Bulk add of param pairs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AddParams(
    ICollection c
)
Visual Basic
Public Overridable Sub AddParams ( _
    c As ICollection _
)
Visual C++
public:
virtual void AddParams(
    ICollection^ c
)

Parameters

c
Type: System.Collections..::..ICollection
Collection of key value pairs.

Remarks

Each member of the collection must be of the form (String) <key>=<value> where the value is in x-www-form-urlencoded form. The semantics of these are the same as individual calls to AddParam(String, String) except that the values are encoded.

See Also

UrlGen Class


AppendParam Method

[image]

Endeca Presentation API
UrlGen..::..AppendParam Method
UrlGen Class See Also Send Feedback
Manipulates the resultant url by adding this key value pair.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AppendParam(
    string key,
    string val
)
Visual Basic
Public Overridable Sub AppendParam ( _
    key As String, _
    val As String _
)
Visual C++
public:
virtual void AppendParam(
    String^ key,
    String^ val
)

Parameters

key
Type: System..::..String
Key name of the pair to be added.
val
Type: System..::..String
Value to be added to the output url where the value is decoded.

Remarks

This method will NOT overwrite any of the original parameters with the same key or any other parameter that got added by this same method previously with the same key. In addition, it is assumed that is decoded and will encode the value as x-www-form-urlencoded on output. Values that are null or equal to "" will be skipped so that this method can be blindly called without having to check if the value is present.

See Also

UrlGen Class


AppendParams Method

[image]

Endeca Presentation API
UrlGen..::..AppendParams Method
UrlGen Class See Also Send Feedback
Bulk append of param pairs.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void AppendParams(
    ICollection c
)
Visual Basic
Public Overridable Sub AppendParams ( _
    c As ICollection _
)
Visual C++
public:
virtual void AppendParams(
    ICollection^ c
)

Parameters

c
Type: System.Collections..::..ICollection
Collection of key value pairs.

Remarks

Each member of the collection must be of the form (String) <key>=<value> where the value is in x-www-form-urlencoded form. The semantics of these are the same as individual calls to AppendParam(String, String) except that the values are encoded.

See Also

UrlGen Class


RemoveParam Method

[image]

Endeca Presentation API
UrlGen..::..RemoveParam Method
UrlGen Class See Also Send Feedback
Removes any key value parameter from the to be outputted URL with the parameter name key.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveParam(
    string key
)
Visual Basic
Public Overridable Sub RemoveParam ( _
    key As String _
)
Visual C++
public:
virtual void RemoveParam(
    String^ key
)

Parameters

key
Type: System..::..String
Parameter pair(s) to remove with the specified parameter name.

Remarks

This removes any parameter created preceeding this call either from the initial query string specified in the constructor or any parameter added from an AddParam(String, String) call. In the case of multiple parameters with the same name, this remove will remove all pairs with the same name. As expected, calling remove on a UrlGen with a empty constructor will not do anything as there will be no parameters to remove.

See Also

UrlGen Class


RemoveParams Method

[image]

Endeca Presentation API
UrlGen..::..RemoveParams Method
UrlGen Class See Also Send Feedback
Removes any key value parameter with the keys specified in the collection.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void RemoveParams(
    ICollection c
)
Visual Basic
Public Overridable Sub RemoveParams ( _
    c As ICollection _
)
Visual C++
public:
virtual void RemoveParams(
    ICollection^ c
)

Parameters

c
Type: System.Collections..::..ICollection
Collection of keys specifying parameter pairs to remove.

Remarks

Same semantics as the RemoveParam(String) call except that it is batch applied with c. Each element of collection c must be able to be casted as a String and be non null.

See Also

UrlGen Class


ToString Method

[image]

Endeca Presentation API
UrlGen..::..ToString Method
UrlGen Class See Also Send Feedback
The output method on this class.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The URL query string output of this class, where key value pairs are delimited by '&' and the pairs themselvs are delimited by '=' and the values are x-www-form-urlencoded.

Remarks

This method will output a query string format of the input URL and subsequent add and remove calls. A call to this method does not invalidate the class but merely generates a snapshot output.

See Also

UrlGen Class


VersionMismatchException Class

[image]

Endeca Presentation API
VersionMismatchException Class
Members See Also Send Feedback
Exception signalling the mismatch of two incompatible modules in the system while processing the query. Most often this exception is used to signal a mismatch between the IENEConnection and the Endeca MDEX Engine itself.

Namespace: Endeca.Navigation
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class VersionMismatchException : ENEQueryException
Visual Basic
Public Class VersionMismatchException _
    Inherits ENEQueryException
Visual C++
public ref class VersionMismatchException : public ENEQueryException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation..::..ENEQueryException
Endeca.Navigation..::..VersionMismatchException

See Also

VersionMismatchException Members


VersionMismatchException Members

[image] [image]

Endeca Presentation API
VersionMismatchException Members
VersionMismatchException Class Methods Properties See Also Send Feedback

The VersionMismatchException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class


VersionMismatchException Methods

[image] [image]

Endeca Presentation API
VersionMismatchException Methods
VersionMismatchException Class See Also Send Feedback

The VersionMismatchException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class


VersionMismatchException Properties

[image] [image]

Endeca Presentation API
VersionMismatchException Properties
VersionMismatchException Class See Also Send Feedback

The VersionMismatchException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class


Endeca.Navigation.AccessControl Namespace

[image]

Endeca Presentation API
Endeca.Navigation.AccessControl Namespace
Send Feedback

Classes

 | Class | Description
Public class | FailedLoginException |
Public class | LoginException |
Public class | LoginManager |
Public class | PasswordRequest | A simple password credential requestor. This may be used with the LoginManager string array constructor.
Public class | SimpleCredentialRequest | The base class of credential requests that are settable with a String value. All credential requests that are to be used from the LoginManager string array constructor should extend this class.
Public class | StaticCredentialRequestHandler | A simple request handler that uses a username and password.
Public class | UnsupportedCredentialException |
Public class | UsernameRequest |

Interfaces

 | Interface | Description
Public interface | IAuthCredentialRequest | Base interface for authentication information requests.
Public interface | IAuthCredentialRequestHandler | Interface implemented by clients of the ILoginManager interface to provide authentication credentials.
Public interface | IENEUser | Interface of the user object.
Public interface | ILoginManager |
Public interface | ILoginModule | LoginModule Interface - implemented by authentication and authorization providers.


FailedLoginException Class

[image]

Endeca Presentation API
FailedLoginException Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FailedLoginException : ApplicationException
Visual Basic
Public Class FailedLoginException _
    Inherits ApplicationException
Visual C++
public ref class FailedLoginException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Endeca.Navigation.AccessControl..::..FailedLoginException

See Also

FailedLoginException Members
Endeca.Navigation.AccessControl Namespace


FailedLoginException Members

[image] [image]

Endeca Presentation API
FailedLoginException Members
FailedLoginException Class Constructors Methods Properties See Also Send Feedback

The FailedLoginException type exposes the following members.

Constructors

 | Name | Description
Public method | FailedLoginException | Initializes a new instance of the FailedLoginException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FailedLoginException Class
Endeca.Navigation.AccessControl Namespace


FailedLoginException Constructor

[image]

Endeca Presentation API
FailedLoginException Constructor
FailedLoginException Class See Also Send Feedback
Initializes a new instance of the FailedLoginException class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FailedLoginException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
FailedLoginException(
    String^ msg
)

Parameters

msg
Type: System..::..String

See Also

FailedLoginException Class
Endeca.Navigation.AccessControl Namespace


FailedLoginException Methods

[image] [image]

Endeca Presentation API
FailedLoginException Methods
FailedLoginException Class See Also Send Feedback

The FailedLoginException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FailedLoginException Class
Endeca.Navigation.AccessControl Namespace


FailedLoginException Properties

[image] [image]

Endeca Presentation API
FailedLoginException Properties
FailedLoginException Class See Also Send Feedback

The FailedLoginException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FailedLoginException Class
Endeca.Navigation.AccessControl Namespace


IAuthCredentialRequest Interface

[image]

Endeca Presentation API
IAuthCredentialRequest Interface
See Also Send Feedback
Base interface for authentication information requests.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IAuthCredentialRequest
Visual Basic
Public Interface IAuthCredentialRequest
Visual C++
public interface class IAuthCredentialRequest

See Also

Endeca.Navigation.AccessControl Namespace


IAuthCredentialRequestHandler Interface

[image]

Endeca Presentation API
IAuthCredentialRequestHandler Interface
Members See Also Send Feedback
Interface implemented by clients of the ILoginManager interface to provide authentication credentials.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IAuthCredentialRequestHandler
Visual Basic
Public Interface IAuthCredentialRequestHandler
Visual C++
public interface class IAuthCredentialRequestHandler

See Also

IAuthCredentialRequestHandler Members
Endeca.Navigation.AccessControl Namespace


IAuthCredentialRequestHandler Members

[image] [image]

Endeca Presentation API
IAuthCredentialRequestHandler Members
IAuthCredentialRequestHandler Interface Methods See Also Send Feedback

The IAuthCredentialRequestHandler type exposes the following members.

Methods

 | Name | Description
Public method | ServiceRequests |

See Also

IAuthCredentialRequestHandler Interface
Endeca.Navigation.AccessControl Namespace


IAuthCredentialRequestHandler Methods

[image] [image]

Endeca Presentation API
IAuthCredentialRequestHandler Methods
IAuthCredentialRequestHandler Interface See Also Send Feedback

The IAuthCredentialRequestHandler type exposes the following members.

Methods

 | Name | Description
Public method | ServiceRequests |

See Also

IAuthCredentialRequestHandler Interface
Endeca.Navigation.AccessControl Namespace


ServiceRequests Method

[image]

Endeca Presentation API
IAuthCredentialRequestHandler..::..ServiceRequests Method
IAuthCredentialRequestHandler Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void ServiceRequests(
    IAuthCredentialRequest[] reqs
)
Visual Basic
Sub ServiceRequests ( _
    reqs As IAuthCredentialRequest() _
)
Visual C++
void ServiceRequests(
    array<IAuthCredentialRequest^>^ reqs
)

Parameters

reqs
Type: array< Endeca.Navigation.AccessControl..::..IAuthCredentialRequest >[]()[][]

See Also

IAuthCredentialRequestHandler Interface
Endeca.Navigation.AccessControl Namespace


IENEUser Interface

[image]

Endeca Presentation API
IENEUser Interface
Members See Also Send Feedback
Interface of the user object.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IENEUser
Visual Basic
Public Interface IENEUser
Visual C++
public interface class IENEUser

See Also

IENEUser Members
Endeca.Navigation.AccessControl Namespace


IENEUser Members

[image] [image]

Endeca Presentation API
IENEUser Members
IENEUser Interface Methods Properties See Also Send Feedback

The IENEUser type exposes the following members.

Methods

 | Name | Description
Public method | AddGroup |
Public method | RemoveGroup |

Properties

 | Name | Description
Public property | GroupCount |
Public property | Item |

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


IENEUser Methods

[image] [image]

Endeca Presentation API
IENEUser Methods
IENEUser Interface See Also Send Feedback

The IENEUser type exposes the following members.

Methods

 | Name | Description
Public method | AddGroup |
Public method | RemoveGroup |

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


AddGroup Method

[image]

Endeca Presentation API
IENEUser..::..AddGroup Method
IENEUser Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void AddGroup(
    string group
)
Visual Basic
Sub AddGroup ( _
    group As String _
)
Visual C++
void AddGroup(
    String^ group
)

Parameters

group
Type: System..::..String

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


RemoveGroup Method

[image]

Endeca Presentation API
IENEUser..::..RemoveGroup Method
IENEUser Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void RemoveGroup(
    string group
)
Visual Basic
Sub RemoveGroup ( _
    group As String _
)
Visual C++
void RemoveGroup(
    String^ group
)

Parameters

group
Type: System..::..String

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


IENEUser Properties

[image] [image]

Endeca Presentation API
IENEUser Properties
IENEUser Interface See Also Send Feedback

The IENEUser type exposes the following members.

Properties

 | Name | Description
Public property | GroupCount |
Public property | Item |

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


GroupCount Property

[image]

Endeca Presentation API
IENEUser..::..GroupCount Property
IENEUser Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
int GroupCount { get; }
Visual Basic
ReadOnly Property GroupCount As Integer
    Get
Visual C++
property int GroupCount {
    int get ();
}

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


Item Property

[image]

Endeca Presentation API
IENEUser..::..Item Property
IENEUser Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
string this[
    int index
] { get; }
Visual Basic
ReadOnly Default Property Item ( _
    index As Integer _
) As String
    Get
Visual C++
property String^ default[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

IENEUser Interface
Endeca.Navigation.AccessControl Namespace


ILoginManager Interface

[image]

Endeca Presentation API
ILoginManager Interface
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface ILoginManager
Visual Basic
Public Interface ILoginManager
Visual C++
public interface class ILoginManager

See Also

ILoginManager Members
Endeca.Navigation.AccessControl Namespace


ILoginManager Members

[image] [image]

Endeca Presentation API
ILoginManager Members
ILoginManager Interface Methods Properties See Also Send Feedback

The ILoginManager type exposes the following members.

Methods

 | Name | Description
Public method | Login |
Public method | LoginCallback |
Public method | Logout |

Properties

 | Name | Description
Public property | User |

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


ILoginManager Methods

[image] [image]

Endeca Presentation API
ILoginManager Methods
ILoginManager Interface See Also Send Feedback

The ILoginManager type exposes the following members.

Methods

 | Name | Description
Public method | Login |
Public method | LoginCallback |
Public method | Logout |

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


Login Method

[image]

Endeca Presentation API
ILoginManager..::..Login Method
ILoginManager Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
bool Login(
    string[] credTypes,
    string[] creds
)
Visual Basic
Function Login ( _
    credTypes As String(), _
    creds As String() _
) As Boolean
Visual C++
bool Login(
    array<String^>^ credTypes,
    array<String^>^ creds
)

Parameters

credTypes
Type: array< System..::..String >[]()[][]
creds
Type: array< System..::..String >[]()[][]

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.ILoginManager.Login(System.String[],System.String[])"]

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


LoginCallback Method

[image]

Endeca Presentation API
ILoginManager..::..LoginCallback Method
ILoginManager Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
bool LoginCallback(
    IAuthCredentialRequestHandler manager
)
Visual Basic
Function LoginCallback ( _
    manager As IAuthCredentialRequestHandler _
) As Boolean
Visual C++
bool LoginCallback(
    IAuthCredentialRequestHandler^ manager
)

Parameters

manager
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.ILoginManager.LoginCallback(Endeca.Navigation.AccessControl.IAuthCredentialRequestHandler)"]

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


Logout Method

[image]

Endeca Presentation API
ILoginManager..::..Logout Method
ILoginManager Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Logout()
Visual Basic
Sub Logout
Visual C++
void Logout()

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


ILoginManager Properties

[image] [image]

Endeca Presentation API
ILoginManager Properties
ILoginManager Interface See Also Send Feedback

The ILoginManager type exposes the following members.

Properties

 | Name | Description
Public property | User |

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


User Property

[image]

Endeca Presentation API
ILoginManager..::..User Property
ILoginManager Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
IENEUser User { get; }
Visual Basic
ReadOnly Property User As IENEUser
    Get
Visual C++
property IENEUser^ User {
    IENEUser^ get ();
}

See Also

ILoginManager Interface
Endeca.Navigation.AccessControl Namespace


ILoginModule Interface

[image]

Endeca Presentation API
ILoginModule Interface
Members See Also Send Feedback
LoginModule Interface - implemented by authentication and authorization providers.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface ILoginModule
Visual Basic
Public Interface ILoginModule
Visual C++
public interface class ILoginModule

See Also

ILoginModule Members
Endeca.Navigation.AccessControl Namespace


ILoginModule Members

[image] [image]

Endeca Presentation API
ILoginModule Members
ILoginModule Interface Methods See Also Send Feedback

The ILoginModule type exposes the following members.

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Init | Initialize the module.
Public method | Login | Perform initial authentication. Save authorization information until Commit or Abort.
Public method | Logout |

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


ILoginModule Methods

[image] [image]

Endeca Presentation API
ILoginModule Methods
ILoginModule Interface See Also Send Feedback

The ILoginModule type exposes the following members.

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Init | Initialize the module.
Public method | Login | Perform initial authentication. Save authorization information until Commit or Abort.
Public method | Logout |

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


Abort Method

[image]

Endeca Presentation API
ILoginModule..::..Abort Method
ILoginModule Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Abort()
Visual Basic
Sub Abort
Visual C++
void Abort()

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


Commit Method

[image]

Endeca Presentation API
ILoginModule..::..Commit Method
ILoginModule Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Commit(
    IENEUser user
)
Visual Basic
Sub Commit ( _
    user As IENEUser _
)
Visual C++
void Commit(
    IENEUser^ user
)

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


Init Method

[image]

Endeca Presentation API
ILoginModule..::..Init Method
ILoginModule Interface See Also Send Feedback
Initialize the module.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Init(
    IAuthCredentialRequestHandler handler,
    StringDictionary options
)
Visual Basic
Sub Init ( _
    handler As IAuthCredentialRequestHandler, _
    options As StringDictionary _
)
Visual C++
void Init(
    IAuthCredentialRequestHandler^ handler,
    StringDictionary^ options
)

Parameters

handler
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler
options
Type: System.Collections.Specialized..::..StringDictionary

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


Login Method

[image]

Endeca Presentation API
ILoginModule..::..Login Method
ILoginModule Interface See Also Send Feedback
Perform initial authentication. Save authorization information until Commit or Abort.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Login()
Visual Basic
Sub Login
Visual C++
void Login()

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


Logout Method

[image]

Endeca Presentation API
ILoginModule..::..Logout Method
ILoginModule Interface See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Logout(
    IENEUser user
)
Visual Basic
Sub Logout ( _
    user As IENEUser _
)
Visual C++
void Logout(
    IENEUser^ user
)

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

See Also

ILoginModule Interface
Endeca.Navigation.AccessControl Namespace


LoginException Class

[image]

Endeca Presentation API
LoginException Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class LoginException : ApplicationException
Visual Basic
Public Class LoginException _
    Inherits ApplicationException
Visual C++
public ref class LoginException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Endeca.Navigation.AccessControl..::..LoginException

See Also

LoginException Members
Endeca.Navigation.AccessControl Namespace


LoginException Members

[image] [image]

Endeca Presentation API
LoginException Members
LoginException Class Constructors Methods Properties See Also Send Feedback

The LoginException type exposes the following members.

Constructors

 | Name | Description
Public method | LoginException | Initializes a new instance of the LoginException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LoginException Class
Endeca.Navigation.AccessControl Namespace


LoginException Constructor

[image]

Endeca Presentation API
LoginException Constructor
LoginException Class See Also Send Feedback
Initializes a new instance of the LoginException class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public LoginException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
LoginException(
    String^ msg
)

Parameters

msg
Type: System..::..String

See Also

LoginException Class
Endeca.Navigation.AccessControl Namespace


LoginException Methods

[image] [image]

Endeca Presentation API
LoginException Methods
LoginException Class See Also Send Feedback

The LoginException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LoginException Class
Endeca.Navigation.AccessControl Namespace


LoginException Properties

[image] [image]

Endeca Presentation API
LoginException Properties
LoginException Class See Also Send Feedback

The LoginException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LoginException Class
Endeca.Navigation.AccessControl Namespace


LoginManager Class

[image]

Endeca Presentation API
LoginManager Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class LoginManager : ILoginManager
Visual Basic
Public Class LoginManager _
    Implements ILoginManager
Visual C++
public ref class LoginManager : ILoginManager

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl..::..LoginManager

See Also

LoginManager Members
Endeca.Navigation.AccessControl Namespace


LoginManager Members

[image] [image]

Endeca Presentation API
LoginManager Members
LoginManager Class Constructors Methods Properties See Also Send Feedback

The LoginManager type exposes the following members.

Constructors

 | Name | Description
Public method | LoginManager | Initializes a new instance of the LoginManager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Login |
Public method | LoginCallback |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | User |

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


LoginManager Constructor

[image]

Endeca Presentation API
LoginManager Constructor
LoginManager Class See Also Send Feedback
Initializes a new instance of the LoginManager class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public LoginManager()
Visual Basic
Public Sub New
Visual C++
public:
LoginManager()

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


LoginManager Methods

[image] [image]

Endeca Presentation API
LoginManager Methods
LoginManager Class See Also Send Feedback

The LoginManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Login |
Public method | LoginCallback |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


Login Method

[image]

Endeca Presentation API
LoginManager..::..Login Method
LoginManager Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool Login(
    string[] credTypes,
    string[] creds
)
Visual Basic
Public Function Login ( _
    credTypes As String(), _
    creds As String() _
) As Boolean
Visual C++
public:
virtual bool Login(
    array<String^>^ credTypes,
    array<String^>^ creds
) sealed

Parameters

credTypes
Type: array< System..::..String >[]()[][]
creds
Type: array< System..::..String >[]()[][]

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.LoginManager.Login(System.String[],System.String[])"]

Implements

ILoginManager..::..Login(array<String>[]()[][], array<String>[]()[][])

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


LoginCallback Method

[image]

Endeca Presentation API
LoginManager..::..LoginCallback Method
LoginManager Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool LoginCallback(
    IAuthCredentialRequestHandler handler
)
Visual Basic
Public Function LoginCallback ( _
    handler As IAuthCredentialRequestHandler _
) As Boolean
Visual C++
public:
virtual bool LoginCallback(
    IAuthCredentialRequestHandler^ handler
) sealed

Parameters

handler
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.LoginManager.LoginCallback(Endeca.Navigation.AccessControl.IAuthCredentialRequestHandler)"]

Implements

ILoginManager..::..LoginCallback(IAuthCredentialRequestHandler)

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


Logout Method

[image]

Endeca Presentation API
LoginManager..::..Logout Method
LoginManager Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Logout()
Visual Basic
Public Sub Logout
Visual C++
public:
virtual void Logout() sealed

Implements

ILoginManager..::..Logout()()()()

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


LoginManager Properties

[image] [image]

Endeca Presentation API
LoginManager Properties
LoginManager Class See Also Send Feedback

The LoginManager type exposes the following members.

Properties

 | Name | Description
Public property | User |

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


User Property

[image]

Endeca Presentation API
LoginManager..::..User Property
LoginManager Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IENEUser User { get; set; }
Visual Basic
Public Property User As IENEUser
    Get
    Set
Visual C++
public:
virtual property IENEUser^ User {
    IENEUser^ get () sealed;
    void set (IENEUser^ value) sealed;
}

Implements

ILoginManager..::..User

See Also

LoginManager Class
Endeca.Navigation.AccessControl Namespace


PasswordRequest Class

[image]

Endeca Presentation API
PasswordRequest Class
Members See Also Send Feedback
A simple password credential requestor. This may be used with the LoginManager string array constructor.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class PasswordRequest : SimpleCredentialRequest
Visual Basic
Public Class PasswordRequest _
    Inherits SimpleCredentialRequest
Visual C++
public ref class PasswordRequest : public SimpleCredentialRequest

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl..::..SimpleCredentialRequest
Endeca.Navigation.AccessControl..::..PasswordRequest

See Also

PasswordRequest Members
Endeca.Navigation.AccessControl Namespace


PasswordRequest Members

[image] [image]

Endeca Presentation API
PasswordRequest Members
PasswordRequest Class Constructors Methods Fields Properties See Also Send Feedback

The PasswordRequest type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordRequest | Default contructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from SimpleCredentialRequest.)

Fields

 | Name | Description
Protected field | credential | (Inherited from SimpleCredentialRequest.)

Properties

 | Name | Description
Public property | Password |
Public property | Value | (Inherited from SimpleCredentialRequest.)

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


PasswordRequest Constructor

[image]

Endeca Presentation API
PasswordRequest Constructor
PasswordRequest Class See Also Send Feedback
Default contructor.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public PasswordRequest()
Visual Basic
Public Sub New
Visual C++
public:
PasswordRequest()

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


PasswordRequest Fields

[image] [image]

Endeca Presentation API
PasswordRequest Fields
PasswordRequest Class See Also Send Feedback

The PasswordRequest type exposes the following members.

Fields

 | Name | Description
Protected field | credential | (Inherited from SimpleCredentialRequest.)

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


PasswordRequest Methods

[image] [image]

Endeca Presentation API
PasswordRequest Methods
PasswordRequest Class See Also Send Feedback

The PasswordRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from SimpleCredentialRequest.)

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


PasswordRequest Properties

[image] [image]

Endeca Presentation API
PasswordRequest Properties
PasswordRequest Class See Also Send Feedback

The PasswordRequest type exposes the following members.

Properties

 | Name | Description
Public property | Password |
Public property | Value | (Inherited from SimpleCredentialRequest.)

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


Password Property

[image]

Endeca Presentation API
PasswordRequest..::..Password Property
PasswordRequest Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

PasswordRequest Class
Endeca.Navigation.AccessControl Namespace


SimpleCredentialRequest Class

[image]

Endeca Presentation API
SimpleCredentialRequest Class
Members See Also Send Feedback
The base class of credential requests that are settable with a String value. All credential requests that are to be used from the LoginManager string array constructor should extend this class.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public abstract class SimpleCredentialRequest : IAuthCredentialRequest
Visual Basic
Public MustInherit Class SimpleCredentialRequest _
    Implements IAuthCredentialRequest
Visual C++
public ref class SimpleCredentialRequest abstract : IAuthCredentialRequest

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl..::..SimpleCredentialRequest
Endeca.Navigation.AccessControl..::..PasswordRequest
Endeca.Navigation.AccessControl..::..UsernameRequest

See Also

SimpleCredentialRequest Members
Endeca.Navigation.AccessControl Namespace


SimpleCredentialRequest Members

[image] [image]

Endeca Presentation API
SimpleCredentialRequest Members
SimpleCredentialRequest Class Methods Fields Properties See Also Send Feedback

The SimpleCredentialRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Protected field | credential |

Properties

 | Name | Description
Public property | Value |

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


SimpleCredentialRequest Fields

[image] [image]

Endeca Presentation API
SimpleCredentialRequest Fields
SimpleCredentialRequest Class See Also Send Feedback

The SimpleCredentialRequest type exposes the following members.

Fields

 | Name | Description
Protected field | credential |

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


credential Field

[image]

Endeca Presentation API
SimpleCredentialRequest..::..credential Field
SimpleCredentialRequest Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected string credential
Visual Basic
Protected credential As String
Visual C++
protected:
String^ credential

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


SimpleCredentialRequest Methods

[image] [image]

Endeca Presentation API
SimpleCredentialRequest Methods
SimpleCredentialRequest Class See Also Send Feedback

The SimpleCredentialRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


ToString Method

[image]

Endeca Presentation API
SimpleCredentialRequest..::..ToString Method
SimpleCredentialRequest Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.SimpleCredentialRequest.ToString"]

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


SimpleCredentialRequest Properties

[image] [image]

Endeca Presentation API
SimpleCredentialRequest Properties
SimpleCredentialRequest Class See Also Send Feedback

The SimpleCredentialRequest type exposes the following members.

Properties

 | Name | Description
Public property | Value |

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


Value Property

[image]

Endeca Presentation API
SimpleCredentialRequest..::..Value Property
SimpleCredentialRequest Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Value { get; set; }
Visual Basic
Public Overridable Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

SimpleCredentialRequest Class
Endeca.Navigation.AccessControl Namespace


StaticCredentialRequestHandler Class

[image]

Endeca Presentation API
StaticCredentialRequestHandler Class
Members See Also Send Feedback
A simple request handler that uses a username and password.

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class StaticCredentialRequestHandler : IAuthCredentialRequestHandler
Visual Basic
Public Class StaticCredentialRequestHandler _
    Implements IAuthCredentialRequestHandler
Visual C++
public ref class StaticCredentialRequestHandler : IAuthCredentialRequestHandler

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl..::..StaticCredentialRequestHandler

See Also

StaticCredentialRequestHandler Members
Endeca.Navigation.AccessControl Namespace


StaticCredentialRequestHandler Members

[image] [image]

Endeca Presentation API
StaticCredentialRequestHandler Members
StaticCredentialRequestHandler Class Constructors Methods See Also Send Feedback

The StaticCredentialRequestHandler type exposes the following members.

Constructors

 | Name | Description
Public method | StaticCredentialRequestHandler | Initializes a new instance of the StaticCredentialRequestHandler class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ServiceRequests |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StaticCredentialRequestHandler Class
Endeca.Navigation.AccessControl Namespace


StaticCredentialRequestHandler Constructor

[image]

Endeca Presentation API
StaticCredentialRequestHandler Constructor
StaticCredentialRequestHandler Class See Also Send Feedback
Initializes a new instance of the StaticCredentialRequestHandler class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public StaticCredentialRequestHandler(
    string user,
    string pass
)
Visual Basic
Public Sub New ( _
    user As String, _
    pass As String _
)
Visual C++
public:
StaticCredentialRequestHandler(
    String^ user,
    String^ pass
)

Parameters

user
Type: System..::..String
pass
Type: System..::..String

See Also

StaticCredentialRequestHandler Class
Endeca.Navigation.AccessControl Namespace


StaticCredentialRequestHandler Methods

[image] [image]

Endeca Presentation API
StaticCredentialRequestHandler Methods
StaticCredentialRequestHandler Class See Also Send Feedback

The StaticCredentialRequestHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ServiceRequests |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StaticCredentialRequestHandler Class
Endeca.Navigation.AccessControl Namespace


ServiceRequests Method

[image]

Endeca Presentation API
StaticCredentialRequestHandler..::..ServiceRequests Method
StaticCredentialRequestHandler Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void ServiceRequests(
    IAuthCredentialRequest[] reqs
)
Visual Basic
Public Sub ServiceRequests ( _
    reqs As IAuthCredentialRequest() _
)
Visual C++
public:
virtual void ServiceRequests(
    array<IAuthCredentialRequest^>^ reqs
) sealed

Parameters

reqs
Type: array< Endeca.Navigation.AccessControl..::..IAuthCredentialRequest >[]()[][]

Implements

IAuthCredentialRequestHandler..::..ServiceRequests(array<IAuthCredentialRequest>[]()[][])

See Also

StaticCredentialRequestHandler Class
Endeca.Navigation.AccessControl Namespace


UnsupportedCredentialException Class

[image]

Endeca Presentation API
UnsupportedCredentialException Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class UnsupportedCredentialException : ApplicationException
Visual Basic
Public Class UnsupportedCredentialException _
    Inherits ApplicationException
Visual C++
public ref class UnsupportedCredentialException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..ApplicationException
Endeca.Navigation.AccessControl..::..UnsupportedCredentialException

See Also

UnsupportedCredentialException Members
Endeca.Navigation.AccessControl Namespace


UnsupportedCredentialException Members

[image] [image]

Endeca Presentation API
UnsupportedCredentialException Members
UnsupportedCredentialException Class Constructors Methods Properties See Also Send Feedback

The UnsupportedCredentialException type exposes the following members.

Constructors

 | Name | Description
Public method | UnsupportedCredentialException | Initializes a new instance of the UnsupportedCredentialException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedCredentialException Class
Endeca.Navigation.AccessControl Namespace


UnsupportedCredentialException Constructor

[image]

Endeca Presentation API
UnsupportedCredentialException Constructor
UnsupportedCredentialException Class See Also Send Feedback
Initializes a new instance of the UnsupportedCredentialException class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public UnsupportedCredentialException(
    string msg
)
Visual Basic
Public Sub New ( _
    msg As String _
)
Visual C++
public:
UnsupportedCredentialException(
    String^ msg
)

Parameters

msg
Type: System..::..String

See Also

UnsupportedCredentialException Class
Endeca.Navigation.AccessControl Namespace


UnsupportedCredentialException Methods

[image] [image]

Endeca Presentation API
UnsupportedCredentialException Methods
UnsupportedCredentialException Class See Also Send Feedback

The UnsupportedCredentialException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UnsupportedCredentialException Class
Endeca.Navigation.AccessControl Namespace


UnsupportedCredentialException Properties

[image] [image]

Endeca Presentation API
UnsupportedCredentialException Properties
UnsupportedCredentialException Class See Also Send Feedback

The UnsupportedCredentialException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedCredentialException Class
Endeca.Navigation.AccessControl Namespace


UsernameRequest Class

[image]

Endeca Presentation API
UsernameRequest Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class UsernameRequest : SimpleCredentialRequest
Visual Basic
Public Class UsernameRequest _
    Inherits SimpleCredentialRequest
Visual C++
public ref class UsernameRequest : public SimpleCredentialRequest

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl..::..SimpleCredentialRequest
Endeca.Navigation.AccessControl..::..UsernameRequest

See Also

UsernameRequest Members
Endeca.Navigation.AccessControl Namespace


UsernameRequest Members

[image] [image]

Endeca Presentation API
UsernameRequest Members
UsernameRequest Class Constructors Methods Fields Properties See Also Send Feedback

The UsernameRequest type exposes the following members.

Constructors

 | Name | Description
Public method | UsernameRequest | Initializes a new instance of the UsernameRequest class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from SimpleCredentialRequest.)

Fields

 | Name | Description
Protected field | credential | (Inherited from SimpleCredentialRequest.)

Properties

 | Name | Description
Public property | Username |
Public property | Value | (Inherited from SimpleCredentialRequest.)

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


UsernameRequest Constructor

[image]

Endeca Presentation API
UsernameRequest Constructor
UsernameRequest Class See Also Send Feedback
Initializes a new instance of the UsernameRequest class

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public UsernameRequest()
Visual Basic
Public Sub New
Visual C++
public:
UsernameRequest()

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


UsernameRequest Fields

[image] [image]

Endeca Presentation API
UsernameRequest Fields
UsernameRequest Class See Also Send Feedback

The UsernameRequest type exposes the following members.

Fields

 | Name | Description
Protected field | credential | (Inherited from SimpleCredentialRequest.)

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


UsernameRequest Methods

[image] [image]

Endeca Presentation API
UsernameRequest Methods
UsernameRequest Class See Also Send Feedback

The UsernameRequest type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Inherited from SimpleCredentialRequest.)

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


UsernameRequest Properties

[image] [image]

Endeca Presentation API
UsernameRequest Properties
UsernameRequest Class See Also Send Feedback

The UsernameRequest type exposes the following members.

Properties

 | Name | Description
Public property | Username |
Public property | Value | (Inherited from SimpleCredentialRequest.)

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


Username Property

[image]

Endeca Presentation API
UsernameRequest..::..Username Property
UsernameRequest Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

See Also

UsernameRequest Class
Endeca.Navigation.AccessControl Namespace


Endeca.Navigation.AccessControl.FileLoginModule Namespace

[image]

Endeca Presentation API
Endeca.Navigation.AccessControl.FileLoginModule Namespace
Send Feedback

Classes

 | Class | Description
Public class | FileLoginModule |


FileLoginModule Class

[image]

Endeca Presentation API
FileLoginModule Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FileLoginModule : ILoginModule
Visual Basic
Public Class FileLoginModule _
    Implements ILoginModule
Visual C++
public ref class FileLoginModule : ILoginModule

Remarks

Deprecated: This class may not be available in future versions of the Presentation API.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl.FileLoginModule..::..FileLoginModule

See Also

FileLoginModule Members
Endeca.Navigation.AccessControl.FileLoginModule Namespace


FileLoginModule Members

[image] [image]

Endeca Presentation API
FileLoginModule Members
FileLoginModule Class Constructors Methods See Also Send Feedback

The FileLoginModule type exposes the following members.

Constructors

 | Name | Description
Public method | FileLoginModule | Initializes a new instance of the FileLoginModule class

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption |
Public method | GetOptionBool |
Public method | GetOptionNoError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Login |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


FileLoginModule Constructor

[image]

Endeca Presentation API
FileLoginModule Constructor
FileLoginModule Class See Also Send Feedback
Initializes a new instance of the FileLoginModule class

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FileLoginModule()
Visual Basic
Public Sub New
Visual C++
public:
FileLoginModule()

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


FileLoginModule Methods

[image] [image]

Endeca Presentation API
FileLoginModule Methods
FileLoginModule Class See Also Send Feedback

The FileLoginModule type exposes the following members.

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption |
Public method | GetOptionBool |
Public method | GetOptionNoError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Login |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Abort Method

[image]

Endeca Presentation API
FileLoginModule..::..Abort Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Abort()
Visual Basic
Public Sub Abort
Visual C++
public:
virtual void Abort() sealed

Implements

ILoginModule..::..Abort()()()()

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Commit Method

[image]

Endeca Presentation API
FileLoginModule..::..Commit Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Commit(
    IENEUser user
)
Visual Basic
Public Sub Commit ( _
    user As IENEUser _
)
Visual C++
public:
virtual void Commit(
    IENEUser^ user
) sealed

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

Implements

ILoginModule..::..Commit(IENEUser)

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


GetOption Method

[image]

Endeca Presentation API
FileLoginModule..::..GetOption Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string GetOption(
    string name
)
Visual Basic
Public Function GetOption ( _
    name As String _
) As String
Visual C++
public:
String^ GetOption(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.FileLoginModule.FileLoginModule.GetOption(System.String)"]

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


GetOptionBool Method

[image]

Endeca Presentation API
FileLoginModule..::..GetOptionBool Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetOptionBool(
    string name
)
Visual Basic
Public Function GetOptionBool ( _
    name As String _
) As Boolean
Visual C++
public:
bool GetOptionBool(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.FileLoginModule.FileLoginModule.GetOptionBool(System.String)"]

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


GetOptionNoError Method

[image]

Endeca Presentation API
FileLoginModule..::..GetOptionNoError Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string GetOptionNoError(
    string name
)
Visual Basic
Public Function GetOptionNoError ( _
    name As String _
) As String
Visual C++
public:
String^ GetOptionNoError(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.FileLoginModule.FileLoginModule.GetOptionNoError(System.String)"]

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Init Method

[image]

Endeca Presentation API
FileLoginModule..::..Init Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Init(
    IAuthCredentialRequestHandler handler,
    StringDictionary options
)
Visual Basic
Public Sub Init ( _
    handler As IAuthCredentialRequestHandler, _
    options As StringDictionary _
)
Visual C++
public:
virtual void Init(
    IAuthCredentialRequestHandler^ handler,
    StringDictionary^ options
) sealed

Parameters

handler
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler
options
Type: System.Collections.Specialized..::..StringDictionary

Implements

ILoginModule..::..Init(IAuthCredentialRequestHandler, StringDictionary)

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Login Method

[image]

Endeca Presentation API
FileLoginModule..::..Login Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Login()
Visual Basic
Public Sub Login
Visual C++
public:
virtual void Login() sealed

Implements

ILoginModule..::..Login()()()()

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Logout Method

[image]

Endeca Presentation API
FileLoginModule..::..Logout Method
FileLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.FileLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Logout(
    IENEUser user
)
Visual Basic
Public Sub Logout ( _
    user As IENEUser _
)
Visual C++
public:
virtual void Logout(
    IENEUser^ user
) sealed

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

Implements

ILoginModule..::..Logout(IENEUser)

See Also

FileLoginModule Class
Endeca.Navigation.AccessControl.FileLoginModule Namespace


Endeca.Navigation.AccessControl.LDAPLoginModule Namespace

[image]

Endeca Presentation API
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace
Send Feedback

Classes

 | Class | Description
Public class | LDAPLoginModule |


LDAPLoginModule Class

[image]

Endeca Presentation API
LDAPLoginModule Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class LDAPLoginModule : ILoginModule
Visual Basic
Public Class LDAPLoginModule _
    Implements ILoginModule
Visual C++
public ref class LDAPLoginModule : ILoginModule

Remarks

Deprecated: This class may not be available in future versions of the Presentation API.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.AccessControl.LDAPLoginModule..::..LDAPLoginModule

See Also

LDAPLoginModule Members
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


LDAPLoginModule Members

[image] [image]

Endeca Presentation API
LDAPLoginModule Members
LDAPLoginModule Class Constructors Methods See Also Send Feedback

The LDAPLoginModule type exposes the following members.

Constructors

 | Name | Description
Public method | LDAPLoginModule | Initializes a new instance of the LDAPLoginModule class

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption |
Public method | GetOptionBool |
Public method | GetOptionNoError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Login |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


LDAPLoginModule Constructor

[image]

Endeca Presentation API
LDAPLoginModule Constructor
LDAPLoginModule Class See Also Send Feedback
Initializes a new instance of the LDAPLoginModule class

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public LDAPLoginModule()
Visual Basic
Public Sub New
Visual C++
public:
LDAPLoginModule()

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


LDAPLoginModule Methods

[image] [image]

Endeca Presentation API
LDAPLoginModule Methods
LDAPLoginModule Class See Also Send Feedback

The LDAPLoginModule type exposes the following members.

Methods

 | Name | Description
Public method | Abort |
Public method | Commit |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOption |
Public method | GetOptionBool |
Public method | GetOptionNoError |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Public method | Login |
Public method | Logout |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Abort Method

[image]

Endeca Presentation API
LDAPLoginModule..::..Abort Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Abort()
Visual Basic
Public Sub Abort
Visual C++
public:
virtual void Abort() sealed

Implements

ILoginModule..::..Abort()()()()

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Commit Method

[image]

Endeca Presentation API
LDAPLoginModule..::..Commit Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Commit(
    IENEUser user
)
Visual Basic
Public Sub Commit ( _
    user As IENEUser _
)
Visual C++
public:
virtual void Commit(
    IENEUser^ user
) sealed

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

Implements

ILoginModule..::..Commit(IENEUser)

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


GetOption Method

[image]

Endeca Presentation API
LDAPLoginModule..::..GetOption Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string GetOption(
    string name
)
Visual Basic
Public Function GetOption ( _
    name As String _
) As String
Visual C++
public:
String^ GetOption(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.LDAPLoginModule.LDAPLoginModule.GetOption(System.String)"]

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


GetOptionBool Method

[image]

Endeca Presentation API
LDAPLoginModule..::..GetOptionBool Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public bool GetOptionBool(
    string name
)
Visual Basic
Public Function GetOptionBool ( _
    name As String _
) As Boolean
Visual C++
public:
bool GetOptionBool(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.LDAPLoginModule.LDAPLoginModule.GetOptionBool(System.String)"]

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


GetOptionNoError Method

[image]

Endeca Presentation API
LDAPLoginModule..::..GetOptionNoError Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string GetOptionNoError(
    string name
)
Visual Basic
Public Function GetOptionNoError ( _
    name As String _
) As String
Visual C++
public:
String^ GetOptionNoError(
    String^ name
)

Parameters

name
Type: System..::..String

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.AccessControl.LDAPLoginModule.LDAPLoginModule.GetOptionNoError(System.String)"]

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Init Method

[image]

Endeca Presentation API
LDAPLoginModule..::..Init Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Init(
    IAuthCredentialRequestHandler handler,
    StringDictionary options
)
Visual Basic
Public Sub Init ( _
    handler As IAuthCredentialRequestHandler, _
    options As StringDictionary _
)
Visual C++
public:
virtual void Init(
    IAuthCredentialRequestHandler^ handler,
    StringDictionary^ options
) sealed

Parameters

handler
Type: Endeca.Navigation.AccessControl..::..IAuthCredentialRequestHandler
options
Type: System.Collections.Specialized..::..StringDictionary

Implements

ILoginModule..::..Init(IAuthCredentialRequestHandler, StringDictionary)

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Login Method

[image]

Endeca Presentation API
LDAPLoginModule..::..Login Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Login()
Visual Basic
Public Sub Login
Visual C++
public:
virtual void Login() sealed

Implements

ILoginModule..::..Login()()()()

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Logout Method

[image]

Endeca Presentation API
LDAPLoginModule..::..Logout Method
LDAPLoginModule Class See Also Send Feedback

Namespace: Endeca.Navigation.AccessControl.LDAPLoginModule
Assembly: Endeca.Navigation.AccessControl (in Endeca.Navigation.AccessControl.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Logout(
    IENEUser user
)
Visual Basic
Public Sub Logout ( _
    user As IENEUser _
)
Visual C++
public:
virtual void Logout(
    IENEUser^ user
) sealed

Parameters

user
Type: Endeca.Navigation.AccessControl..::..IENEUser

Implements

ILoginModule..::..Logout(IENEUser)

See Also

LDAPLoginModule Class
Endeca.Navigation.AccessControl.LDAPLoginModule Namespace


Endeca.Navigation.Analytics Namespace

[image]

Endeca Presentation API
Endeca.Navigation.Analytics Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticsLexer |
Public class | AnalyticsParser |
Public class | AnalyticsParserTokenTypes |
Public class | AnalyticsQuery | An AnalyticsQuery is an ordered list of Statement objects.
Public class | CoalesceList | CoalesceList instances represent a list of expressions used to return the the first non-null value in the list. These coalesce expressions are objects of type IExpr.
Public class | ExprAggregate | Instances of the ExprAggregate class represent aggregate functions over the members of the associated aggregated record.
Public class | ExprAggregate..::..ExprAggregateOp | Enumeration of Endeca aggregate functions.
Public class | ExprBinary | An ExprBinary is a type of IExpr that represents a binary scalar expression. These expressions provide a full range of mathematical functions, such as addition and subtraction operators.
Public class | ExprBinary..::..ExprBinaryOp | Enumeration of Endeca mathematical operators.
Public class | ExprCoalesce | ExprCoalesce instances represent a coalesce expression holding multiple keys. The keys can be evaluated over the associated records, and the first non-null value is computed for each record.
Public class | ExprConstant | Instances of ExprConstant represent constants.
Public class | ExprFunction | ExprFunction instances represent unary scalar function expressions.
Public class | ExprFunction..::..ExprFunctionOp | Enumeration of Endeca unary scalar functions.
Public class | ExprKey | Instances of ExprKey represent record field names. The fields are Endeca properties or dimensions.
Public class | ExprLookup | ExprLookup instances represent an access to a derived property of a record in a foreign table.
Public class | FilterAnd | A FilterAnd is a IFilter implementing a Boolean n-way AND operation.
Public class | FilterCompare | A FilterCompare is a type of IFilter that performs a value comparison.
Public class | FilterCompare..::..FilterCompareOp | Enumeration of Endeca comparison operators.
Public class | FilterIn | A FilterIn is an IFilter that checks membership of a given set of values in a table. The membership is checked with a set of lookup expressions in a LookupList that is set in the FilterIn.
Public class | FilterNot | A FilterNot is an IFilter implementing a Boolean NOT operation. The filter evaluates to true for a given record if its child filter evaluates to false for that record.
Public class | FilterOr | A FilterOr is an IFilter implementing a Boolean n-way OR operation.
Public class | GroupBy | A GroupBy defines a single dimension of record grouping for a containing Statement operation.
Public class | GroupByList | A GroupByList is a list of GroupBy instances.
Public class | LookupList | LookupList instances represent a list of expressions used to uniquely identify a record in a table (foreign or local). These lookup expressions are objects of type IExpr.
Public class | OrderBy | An OrderBy defines an ordering on a set of records, based on the natural ordering of the specified field.
Public class | OrderByList | An OrderByList is a list of OrderBy instances.
Public class | Select | A Select operation represents the assignment of a named derived value to a record produced as the result of a Statement.
Public class | SelectList | A SelectList is a list of Select expressions.
Public class | Statement | A Statement represents a pass over a set of input records (those of the FROM table) to generate a set of output records.
Public class | SyntaxException | Analytics Syntax Exception representing an error due to a malformed query.
Public class | TestAnalyticsParser |

Interfaces

 | Interface | Description
Public interface | IExpr | IExpr is the interface for various types of composable Select derived property expressions.
Public interface | IFilter | IFilter is the interface for various types of composable record filter operators.
Public interface | IObjectList | IObjectList is an interface for handling a collection of objects.
Public interface | IQueryNode | IQueryNode is the interface for all parts of an Endeca Analytics query.


AnalyticsLexer Class

[image]

Endeca Presentation API
AnalyticsLexer Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AnalyticsLexer : CharScanner,
    TokenStream
Visual Basic
Public Class AnalyticsLexer _
    Inherits CharScanner _
    Implements TokenStream
Visual C++
public ref class AnalyticsLexer : public CharScanner,
    TokenStream

Inheritance Hierarchy

System..::..Object
CharScanner
Endeca.Navigation.Analytics..::..AnalyticsLexer

See Also

AnalyticsLexer Members
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Members

[image] [image]

Endeca Presentation API
AnalyticsLexer Members
AnalyticsLexer Class Constructors Methods Fields See Also Send Feedback

The AnalyticsLexer type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsLexer(InputBuffer) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(LexerSharedInputState) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(Stream) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(TextReader) | Initializes a new instance of the AnalyticsLexer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | mCLOSE_BRACKET |
Public method | mCLOSE_BRACKET_PERIOD |
Public method | mCLOSE_PAREN |
Public method | mCOLON |
Public method | mCOMMA |
Protected method | mDIGIT |
Public method | mDIV |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | mEQUAL |
Protected method | mEXPONENT |
Protected method | mFLOAT_SUFFIX |
Public method | mGREATER_THAN |
Public method | mGREATER_THAN_OR_EQUAL |
Public method | mIDENTIFIER |
Protected method | mIDENTIFIER_CHAR |
Protected method | mIDENTIFIER_ESCAPE_SEQ |
Protected method | mIDENTIFIER_START_CHAR |
Public method | mLESS_THAN |
Public method | mLESS_THAN_OR_EQUAL |
Public method | mMINUS |
Public method | mMULT |
Public method | mNOT_EQUAL |
Public method | mOPEN_BRACKET |
Public method | mOPEN_PAREN |
Public method | mPLUS |
Public method | mPOS_INT |
Protected method | mQUOTED_IDENTIFIER |
Protected method | mQUOTED_IDENTIFIER_CHAR |
Protected method | mREGULAR_IDENTIFIER |
Public method | mSEMI |
Public method | mSTRING_LITERAL |
Protected method | mSTRING_LITERAL_CHAR |
Protected method | mSTRING_LITERAL_ESCAPE_SEQ |
Public method | mWS |
Public method | nextToken | (Overrides CharScannernextToken()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
tokenSet_0_ |
tokenSet_1_ |
tokenSet_2_ |
tokenSet_3_ |
tokenSet_4_ |
tokenSet_5_ |
tokenSet_6_ |
tokenSet_7_ |
tokenSet_8_ |
WS |

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Constructor

[image] [image]

Endeca Presentation API
AnalyticsLexer Constructor
AnalyticsLexer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalyticsLexer(InputBuffer) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(LexerSharedInputState) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(Stream) | Initializes a new instance of the AnalyticsLexer class
Public method | AnalyticsLexer(TextReader) | Initializes a new instance of the AnalyticsLexer class

See Also

AnalyticsLexer Class
AnalyticsLexer Members
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Constructor ()

[image]

Endeca Presentation API
AnalyticsLexer Constructor ()
AnalyticsLexer Class See Also Send Feedback
Initializes a new instance of the AnalyticsLexer class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsLexer(
    InputBuffer ib
)
Visual Basic
Public Sub New ( _
    ib As InputBuffer _
)
Visual C++
public:
AnalyticsLexer(
    InputBuffer^ ib
)

Parameters

ib
Type: InputBuffer

See Also

AnalyticsLexer Class
AnalyticsLexer Overload
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Constructor ()

[image]

Endeca Presentation API
AnalyticsLexer Constructor ()
AnalyticsLexer Class See Also Send Feedback
Initializes a new instance of the AnalyticsLexer class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsLexer(
    LexerSharedInputState state
)
Visual Basic
Public Sub New ( _
    state As LexerSharedInputState _
)
Visual C++
public:
AnalyticsLexer(
    LexerSharedInputState^ state
)

Parameters

state
Type: LexerSharedInputState

See Also

AnalyticsLexer Class
AnalyticsLexer Overload
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Constructor (Stream)

[image]

Endeca Presentation API
AnalyticsLexer Constructor (Stream)
AnalyticsLexer Class See Also Send Feedback
Initializes a new instance of the AnalyticsLexer class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsLexer(
    Stream ins
)
Visual Basic
Public Sub New ( _
    ins As Stream _
)
Visual C++
public:
AnalyticsLexer(
    Stream^ ins
)

Parameters

ins
Type: System.IO..::..Stream

See Also

AnalyticsLexer Class
AnalyticsLexer Overload
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Constructor (TextReader)

[image]

Endeca Presentation API
AnalyticsLexer Constructor (TextReader)
AnalyticsLexer Class See Also Send Feedback
Initializes a new instance of the AnalyticsLexer class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsLexer(
    TextReader r
)
Visual Basic
Public Sub New ( _
    r As TextReader _
)
Visual C++
public:
AnalyticsLexer(
    TextReader^ r
)

Parameters

r
Type: System.IO..::..TextReader

See Also

AnalyticsLexer Class
AnalyticsLexer Overload
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Fields

[image] [image]

Endeca Presentation API
AnalyticsLexer Fields
AnalyticsLexer Class See Also Send Feedback

The AnalyticsLexer type exposes the following members.

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
tokenSet_0_ |
tokenSet_1_ |
tokenSet_2_ |
tokenSet_3_ |
tokenSet_4_ |
tokenSet_5_ |
tokenSet_6_ |
tokenSet_7_ |
tokenSet_8_ |
WS |

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET Field

[image]

Endeca Presentation API
AnalyticsLexer..::..CLOSE_BRACKET Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET
Visual Basic
Public Const CLOSE_BRACKET As Integer
Visual C++
public:
literal int CLOSE_BRACKET

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET_PERIOD Field

[image]

Endeca Presentation API
AnalyticsLexer..::..CLOSE_BRACKET_PERIOD Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET_PERIOD
Visual Basic
Public Const CLOSE_BRACKET_PERIOD As Integer
Visual C++
public:
literal int CLOSE_BRACKET_PERIOD

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


CLOSE_PAREN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..CLOSE_PAREN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_PAREN
Visual Basic
Public Const CLOSE_PAREN As Integer
Visual C++
public:
literal int CLOSE_PAREN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


COLON Field

[image]

Endeca Presentation API
AnalyticsLexer..::..COLON Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COLON
Visual Basic
Public Const COLON As Integer
Visual C++
public:
literal int COLON

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


COMMA Field

[image]

Endeca Presentation API
AnalyticsLexer..::..COMMA Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COMMA
Visual Basic
Public Const COMMA As Integer
Visual C++
public:
literal int COMMA

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


DIGIT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..DIGIT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIGIT
Visual Basic
Public Const DIGIT As Integer
Visual C++
public:
literal int DIGIT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


DIV Field

[image]

Endeca Presentation API
AnalyticsLexer..::..DIV Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIV
Visual Basic
Public Const DIV As Integer
Visual C++
public:
literal int DIV

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


EOF Field

[image]

Endeca Presentation API
AnalyticsLexer..::..EOF Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EOF
Visual Basic
Public Const EOF As Integer
Visual C++
public:
literal int EOF

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


EQUAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..EQUAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EQUAL
Visual Basic
Public Const EQUAL As Integer
Visual C++
public:
literal int EQUAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


EXPONENT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..EXPONENT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EXPONENT
Visual Basic
Public Const EXPONENT As Integer
Visual C++
public:
literal int EXPONENT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


FLOAT_SUFFIX Field

[image]

Endeca Presentation API
AnalyticsLexer..::..FLOAT_SUFFIX Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int FLOAT_SUFFIX
Visual Basic
Public Const FLOAT_SUFFIX As Integer
Visual C++
public:
literal int FLOAT_SUFFIX

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..GREATER_THAN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN
Visual Basic
Public Const GREATER_THAN As Integer
Visual C++
public:
literal int GREATER_THAN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..GREATER_THAN_OR_EQUAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN_OR_EQUAL
Visual Basic
Public Const GREATER_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int GREATER_THAN_OR_EQUAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..IDENTIFIER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER
Visual Basic
Public Const IDENTIFIER As Integer
Visual C++
public:
literal int IDENTIFIER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..IDENTIFIER_CHAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_CHAR
Visual Basic
Public Const IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_CHAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..IDENTIFIER_ESCAPE_SEQ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_ESCAPE_SEQ
Visual Basic
Public Const IDENTIFIER_ESCAPE_SEQ As Integer
Visual C++
public:
literal int IDENTIFIER_ESCAPE_SEQ

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_START_CHAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..IDENTIFIER_START_CHAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_START_CHAR
Visual Basic
Public Const IDENTIFIER_START_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_START_CHAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LESS_THAN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LESS_THAN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN
Visual Basic
Public Const LESS_THAN As Integer
Visual C++
public:
literal int LESS_THAN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LESS_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LESS_THAN_OR_EQUAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN_OR_EQUAL
Visual Basic
Public Const LESS_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int LESS_THAN_OR_EQUAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_ABS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_ABS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ABS
Visual Basic
Public Const LITERAL_ABS As Integer
Visual C++
public:
literal int LITERAL_ABS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_AND Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_AND Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AND
Visual Basic
Public Const LITERAL_AND As Integer
Visual C++
public:
literal int LITERAL_AND

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_ARB Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_ARB Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ARB
Visual Basic
Public Const LITERAL_ARB As Integer
Visual C++
public:
literal int LITERAL_ARB

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_AS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_AS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AS
Visual Basic
Public Const LITERAL_AS As Integer
Visual C++
public:
literal int LITERAL_AS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_ASC Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_ASC Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ASC
Visual Basic
Public Const LITERAL_ASC As Integer
Visual C++
public:
literal int LITERAL_ASC

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_AVG Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_AVG Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AVG
Visual Basic
Public Const LITERAL_AVG As Integer
Visual C++
public:
literal int LITERAL_AVG

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_BY Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_BY Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_BY
Visual Basic
Public Const LITERAL_BY As Integer
Visual C++
public:
literal int LITERAL_BY

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_CEIL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_CEIL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_CEIL
Visual Basic
Public Const LITERAL_CEIL As Integer
Visual C++
public:
literal int LITERAL_CEIL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_COALESCE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_COALESCE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COALESCE
Visual Basic
Public Const LITERAL_COALESCE As Integer
Visual C++
public:
literal int LITERAL_COALESCE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_COS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_COS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COS
Visual Basic
Public Const LITERAL_COS As Integer
Visual C++
public:
literal int LITERAL_COS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_COUNT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNT
Visual Basic
Public Const LITERAL_COUNT As Integer
Visual C++
public:
literal int LITERAL_COUNT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNTDISTINCT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_COUNTDISTINCT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNTDISTINCT
Visual Basic
Public Const LITERAL_COUNTDISTINCT As Integer
Visual C++
public:
literal int LITERAL_COUNTDISTINCT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DATE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DATE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DATE
Visual Basic
Public Const LITERAL_DATE As Integer
Visual C++
public:
literal int LITERAL_DATE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_MONTH Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DAY_OF_MONTH Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_MONTH
Visual Basic
Public Const LITERAL_DAY_OF_MONTH As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_MONTH

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_WEEK Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DAY_OF_WEEK Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_WEEK
Visual Basic
Public Const LITERAL_DAY_OF_WEEK As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_WEEK

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_YEAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DAY_OF_YEAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_YEAR
Visual Basic
Public Const LITERAL_DAY_OF_YEAR As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_YEAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DEFINE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DEFINE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DEFINE
Visual Basic
Public Const LITERAL_DEFINE As Integer
Visual C++
public:
literal int LITERAL_DEFINE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DESC Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DESC Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DESC
Visual Basic
Public Const LITERAL_DESC As Integer
Visual C++
public:
literal int LITERAL_DESC

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_DVAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_DVAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DVAL
Visual Basic
Public Const LITERAL_DVAL As Integer
Visual C++
public:
literal int LITERAL_DVAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXP Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_EXP Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXP
Visual Basic
Public Const LITERAL_EXP As Integer
Visual C++
public:
literal int LITERAL_EXP

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXTRACT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_EXTRACT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXTRACT
Visual Basic
Public Const LITERAL_EXTRACT As Integer
Visual C++
public:
literal int LITERAL_EXTRACT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_FLOOR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_FLOOR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FLOOR
Visual Basic
Public Const LITERAL_FLOOR As Integer
Visual C++
public:
literal int LITERAL_FLOOR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_FROM Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_FROM Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FROM
Visual Basic
Public Const LITERAL_FROM As Integer
Visual C++
public:
literal int LITERAL_FROM

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_GROUP Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_GROUP Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_GROUP
Visual Basic
Public Const LITERAL_GROUP As Integer
Visual C++
public:
literal int LITERAL_GROUP

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_HAVING Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_HAVING Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HAVING
Visual Basic
Public Const LITERAL_HAVING As Integer
Visual C++
public:
literal int LITERAL_HAVING

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_HOUR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_HOUR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HOUR
Visual Basic
Public Const LITERAL_HOUR As Integer
Visual C++
public:
literal int LITERAL_HOUR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_IN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_IN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IN
Visual Basic
Public Const LITERAL_IN As Integer
Visual C++
public:
literal int LITERAL_IN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_IS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_IS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IS
Visual Basic
Public Const LITERAL_IS As Integer
Visual C++
public:
literal int LITERAL_IS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_LAG Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_LAG Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LAG
Visual Basic
Public Const LITERAL_LAG As Integer
Visual C++
public:
literal int LITERAL_LAG

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_LEAD Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_LEAD Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LEAD
Visual Basic
Public Const LITERAL_LEAD As Integer
Visual C++
public:
literal int LITERAL_LEAD

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_LN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_LN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LN
Visual Basic
Public Const LITERAL_LN As Integer
Visual C++
public:
literal int LITERAL_LN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_LOG Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_LOG Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LOG
Visual Basic
Public Const LITERAL_LOG As Integer
Visual C++
public:
literal int LITERAL_LOG

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MAX Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MAX Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MAX
Visual Basic
Public Const LITERAL_MAX As Integer
Visual C++
public:
literal int LITERAL_MAX

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MEDIAN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MEDIAN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MEDIAN
Visual Basic
Public Const LITERAL_MEDIAN As Integer
Visual C++
public:
literal int LITERAL_MEDIAN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MIN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MIN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MIN
Visual Basic
Public Const LITERAL_MIN As Integer
Visual C++
public:
literal int LITERAL_MIN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MINUTE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MINUTE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MINUTE
Visual Basic
Public Const LITERAL_MINUTE As Integer
Visual C++
public:
literal int LITERAL_MINUTE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MOD Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MOD Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MOD
Visual Basic
Public Const LITERAL_MOD As Integer
Visual C++
public:
literal int LITERAL_MOD

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_MONTH Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_MONTH Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MONTH
Visual Basic
Public Const LITERAL_MONTH As Integer
Visual C++
public:
literal int LITERAL_MONTH

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_NOT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_NOT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NOT
Visual Basic
Public Const LITERAL_NOT As Integer
Visual C++
public:
literal int LITERAL_NOT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_NULL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_NULL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NULL
Visual Basic
Public Const LITERAL_NULL As Integer
Visual C++
public:
literal int LITERAL_NULL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_OR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_OR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_OR
Visual Basic
Public Const LITERAL_OR As Integer
Visual C++
public:
literal int LITERAL_OR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_ORDER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_ORDER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ORDER
Visual Basic
Public Const LITERAL_ORDER As Integer
Visual C++
public:
literal int LITERAL_ORDER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_PAGE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_PAGE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_PAGE
Visual Basic
Public Const LITERAL_PAGE As Integer
Visual C++
public:
literal int LITERAL_PAGE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_POWER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_POWER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_POWER
Visual Basic
Public Const LITERAL_POWER As Integer
Visual C++
public:
literal int LITERAL_POWER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_QUARTER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_QUARTER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_QUARTER
Visual Basic
Public Const LITERAL_QUARTER As Integer
Visual C++
public:
literal int LITERAL_QUARTER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_RETURN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_RETURN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_RETURN
Visual Basic
Public Const LITERAL_RETURN As Integer
Visual C++
public:
literal int LITERAL_RETURN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_ROUND Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_ROUND Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ROUND
Visual Basic
Public Const LITERAL_ROUND As Integer
Visual C++
public:
literal int LITERAL_ROUND

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SECOND Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SECOND Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SECOND
Visual Basic
Public Const LITERAL_SECOND As Integer
Visual C++
public:
literal int LITERAL_SECOND

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SELECT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SELECT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SELECT
Visual Basic
Public Const LITERAL_SELECT As Integer
Visual C++
public:
literal int LITERAL_SELECT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIGN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SIGN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIGN
Visual Basic
Public Const LITERAL_SIGN As Integer
Visual C++
public:
literal int LITERAL_SIGN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SIN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIN
Visual Basic
Public Const LITERAL_SIN As Integer
Visual C++
public:
literal int LITERAL_SIN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SQRT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SQRT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SQRT
Visual Basic
Public Const LITERAL_SQRT As Integer
Visual C++
public:
literal int LITERAL_SQRT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_STDDEV Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_STDDEV Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_STDDEV
Visual Basic
Public Const LITERAL_STDDEV As Integer
Visual C++
public:
literal int LITERAL_STDDEV

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_SUM Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_SUM Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SUM
Visual Basic
Public Const LITERAL_SUM As Integer
Visual C++
public:
literal int LITERAL_SUM

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_TAN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_TAN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TAN
Visual Basic
Public Const LITERAL_TAN As Integer
Visual C++
public:
literal int LITERAL_TAN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_TO_DURATION Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_TO_DURATION Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TO_DURATION
Visual Basic
Public Const LITERAL_TO_DURATION As Integer
Visual C++
public:
literal int LITERAL_TO_DURATION

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_TRUNC Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_TRUNC Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TRUNC
Visual Basic
Public Const LITERAL_TRUNC As Integer
Visual C++
public:
literal int LITERAL_TRUNC

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_VARIANCE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_VARIANCE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_VARIANCE
Visual Basic
Public Const LITERAL_VARIANCE As Integer
Visual C++
public:
literal int LITERAL_VARIANCE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_WEEK Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_WEEK Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WEEK
Visual Basic
Public Const LITERAL_WEEK As Integer
Visual C++
public:
literal int LITERAL_WEEK

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_WHERE Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_WHERE Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WHERE
Visual Basic
Public Const LITERAL_WHERE As Integer
Visual C++
public:
literal int LITERAL_WHERE

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


LITERAL_YEAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..LITERAL_YEAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_YEAR
Visual Basic
Public Const LITERAL_YEAR As Integer
Visual C++
public:
literal int LITERAL_YEAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


MINUS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..MINUS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MINUS
Visual Basic
Public Const MINUS As Integer
Visual C++
public:
literal int MINUS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


MULT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..MULT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MULT
Visual Basic
Public Const MULT As Integer
Visual C++
public:
literal int MULT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


NOT_EQUAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..NOT_EQUAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NOT_EQUAL
Visual Basic
Public Const NOT_EQUAL As Integer
Visual C++
public:
literal int NOT_EQUAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


NULL_TREE_LOOKAHEAD Field

[image]

Endeca Presentation API
AnalyticsLexer..::..NULL_TREE_LOOKAHEAD Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NULL_TREE_LOOKAHEAD
Visual Basic
Public Const NULL_TREE_LOOKAHEAD As Integer
Visual C++
public:
literal int NULL_TREE_LOOKAHEAD

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


OPEN_BRACKET Field

[image]

Endeca Presentation API
AnalyticsLexer..::..OPEN_BRACKET Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_BRACKET
Visual Basic
Public Const OPEN_BRACKET As Integer
Visual C++
public:
literal int OPEN_BRACKET

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


OPEN_PAREN Field

[image]

Endeca Presentation API
AnalyticsLexer..::..OPEN_PAREN Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_PAREN
Visual Basic
Public Const OPEN_PAREN As Integer
Visual C++
public:
literal int OPEN_PAREN

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


PLUS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..PLUS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int PLUS
Visual Basic
Public Const PLUS As Integer
Visual C++
public:
literal int PLUS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


POS_FLOAT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..POS_FLOAT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_FLOAT
Visual Basic
Public Const POS_FLOAT As Integer
Visual C++
public:
literal int POS_FLOAT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


POS_INT Field

[image]

Endeca Presentation API
AnalyticsLexer..::..POS_INT Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_INT
Visual Basic
Public Const POS_INT As Integer
Visual C++
public:
literal int POS_INT

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..QUOTED_IDENTIFIER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER
Visual Basic
Public Const QUOTED_IDENTIFIER As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..QUOTED_IDENTIFIER_CHAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER_CHAR
Visual Basic
Public Const QUOTED_IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER_CHAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


REGULAR_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsLexer..::..REGULAR_IDENTIFIER Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int REGULAR_IDENTIFIER
Visual Basic
Public Const REGULAR_IDENTIFIER As Integer
Visual C++
public:
literal int REGULAR_IDENTIFIER

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


SEMI Field

[image]

Endeca Presentation API
AnalyticsLexer..::..SEMI Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int SEMI
Visual Basic
Public Const SEMI As Integer
Visual C++
public:
literal int SEMI

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL Field

[image]

Endeca Presentation API
AnalyticsLexer..::..STRING_LITERAL Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL
Visual Basic
Public Const STRING_LITERAL As Integer
Visual C++
public:
literal int STRING_LITERAL

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_CHAR Field

[image]

Endeca Presentation API
AnalyticsLexer..::..STRING_LITERAL_CHAR Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_CHAR
Visual Basic
Public Const STRING_LITERAL_CHAR As Integer
Visual C++
public:
literal int STRING_LITERAL_CHAR

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..STRING_LITERAL_ESCAPE_SEQ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_ESCAPE_SEQ
Visual Basic
Public Const STRING_LITERAL_ESCAPE_SEQ As Integer
Visual C++
public:
literal int STRING_LITERAL_ESCAPE_SEQ

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_0_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_0_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_0_
Visual Basic
Public Shared ReadOnly tokenSet_0_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_0_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_1_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_1_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_1_
Visual Basic
Public Shared ReadOnly tokenSet_1_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_1_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_2_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_2_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_2_
Visual Basic
Public Shared ReadOnly tokenSet_2_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_2_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_3_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_3_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_3_
Visual Basic
Public Shared ReadOnly tokenSet_3_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_3_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_4_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_4_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_4_
Visual Basic
Public Shared ReadOnly tokenSet_4_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_4_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_5_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_5_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_5_
Visual Basic
Public Shared ReadOnly tokenSet_5_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_5_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_6_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_6_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_6_
Visual Basic
Public Shared ReadOnly tokenSet_6_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_6_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_7_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_7_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_7_
Visual Basic
Public Shared ReadOnly tokenSet_7_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_7_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


tokenSet_8_ Field

[image]

Endeca Presentation API
AnalyticsLexer..::..tokenSet_8_ Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_8_
Visual Basic
Public Shared ReadOnly tokenSet_8_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_8_

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


WS Field

[image]

Endeca Presentation API
AnalyticsLexer..::..WS Field
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int WS
Visual Basic
Public Const WS As Integer
Visual C++
public:
literal int WS

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


AnalyticsLexer Methods

[image] [image]

Endeca Presentation API
AnalyticsLexer Methods
AnalyticsLexer Class See Also Send Feedback

The AnalyticsLexer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | mCLOSE_BRACKET |
Public method | mCLOSE_BRACKET_PERIOD |
Public method | mCLOSE_PAREN |
Public method | mCOLON |
Public method | mCOMMA |
Protected method | mDIGIT |
Public method | mDIV |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | mEQUAL |
Protected method | mEXPONENT |
Protected method | mFLOAT_SUFFIX |
Public method | mGREATER_THAN |
Public method | mGREATER_THAN_OR_EQUAL |
Public method | mIDENTIFIER |
Protected method | mIDENTIFIER_CHAR |
Protected method | mIDENTIFIER_ESCAPE_SEQ |
Protected method | mIDENTIFIER_START_CHAR |
Public method | mLESS_THAN |
Public method | mLESS_THAN_OR_EQUAL |
Public method | mMINUS |
Public method | mMULT |
Public method | mNOT_EQUAL |
Public method | mOPEN_BRACKET |
Public method | mOPEN_PAREN |
Public method | mPLUS |
Public method | mPOS_INT |
Protected method | mQUOTED_IDENTIFIER |
Protected method | mQUOTED_IDENTIFIER_CHAR |
Protected method | mREGULAR_IDENTIFIER |
Public method | mSEMI |
Public method | mSTRING_LITERAL |
Protected method | mSTRING_LITERAL_CHAR |
Protected method | mSTRING_LITERAL_ESCAPE_SEQ |
Public method | mWS |
Public method | nextToken | (Overrides CharScannernextToken()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mCLOSE_BRACKET Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mCLOSE_BRACKET Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mCLOSE_BRACKET(
    bool _createToken
)
Visual Basic
Public Sub mCLOSE_BRACKET ( _
    _createToken As Boolean _
)
Visual C++
public:
void mCLOSE_BRACKET(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mCLOSE_BRACKET_PERIOD Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mCLOSE_BRACKET_PERIOD Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mCLOSE_BRACKET_PERIOD(
    bool _createToken
)
Visual Basic
Public Sub mCLOSE_BRACKET_PERIOD ( _
    _createToken As Boolean _
)
Visual C++
public:
void mCLOSE_BRACKET_PERIOD(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mCLOSE_PAREN Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mCLOSE_PAREN Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mCLOSE_PAREN(
    bool _createToken
)
Visual Basic
Public Sub mCLOSE_PAREN ( _
    _createToken As Boolean _
)
Visual C++
public:
void mCLOSE_PAREN(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mCOLON Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mCOLON Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mCOLON(
    bool _createToken
)
Visual Basic
Public Sub mCOLON ( _
    _createToken As Boolean _
)
Visual C++
public:
void mCOLON(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mCOMMA Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mCOMMA Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mCOMMA(
    bool _createToken
)
Visual Basic
Public Sub mCOMMA ( _
    _createToken As Boolean _
)
Visual C++
public:
void mCOMMA(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mDIGIT Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mDIGIT Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mDIGIT(
    bool _createToken
)
Visual Basic
Protected Sub mDIGIT ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mDIGIT(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mDIV Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mDIV Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mDIV(
    bool _createToken
)
Visual Basic
Public Sub mDIV ( _
    _createToken As Boolean _
)
Visual C++
public:
void mDIV(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mEQUAL Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mEQUAL Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mEQUAL(
    bool _createToken
)
Visual Basic
Public Sub mEQUAL ( _
    _createToken As Boolean _
)
Visual C++
public:
void mEQUAL(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mEXPONENT Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mEXPONENT Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mEXPONENT(
    bool _createToken
)
Visual Basic
Protected Sub mEXPONENT ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mEXPONENT(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mFLOAT_SUFFIX Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mFLOAT_SUFFIX Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mFLOAT_SUFFIX(
    bool _createToken
)
Visual Basic
Protected Sub mFLOAT_SUFFIX ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mFLOAT_SUFFIX(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mGREATER_THAN Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mGREATER_THAN Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mGREATER_THAN(
    bool _createToken
)
Visual Basic
Public Sub mGREATER_THAN ( _
    _createToken As Boolean _
)
Visual C++
public:
void mGREATER_THAN(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mGREATER_THAN_OR_EQUAL Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mGREATER_THAN_OR_EQUAL Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mGREATER_THAN_OR_EQUAL(
    bool _createToken
)
Visual Basic
Public Sub mGREATER_THAN_OR_EQUAL ( _
    _createToken As Boolean _
)
Visual C++
public:
void mGREATER_THAN_OR_EQUAL(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mIDENTIFIER Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mIDENTIFIER Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mIDENTIFIER(
    bool _createToken
)
Visual Basic
Public Sub mIDENTIFIER ( _
    _createToken As Boolean _
)
Visual C++
public:
void mIDENTIFIER(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mIDENTIFIER_CHAR Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mIDENTIFIER_CHAR Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mIDENTIFIER_CHAR(
    bool _createToken
)
Visual Basic
Protected Sub mIDENTIFIER_CHAR ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mIDENTIFIER_CHAR(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mIDENTIFIER_ESCAPE_SEQ Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mIDENTIFIER_ESCAPE_SEQ Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mIDENTIFIER_ESCAPE_SEQ(
    bool _createToken
)
Visual Basic
Protected Sub mIDENTIFIER_ESCAPE_SEQ ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mIDENTIFIER_ESCAPE_SEQ(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mIDENTIFIER_START_CHAR Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mIDENTIFIER_START_CHAR Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mIDENTIFIER_START_CHAR(
    bool _createToken
)
Visual Basic
Protected Sub mIDENTIFIER_START_CHAR ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mIDENTIFIER_START_CHAR(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mLESS_THAN Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mLESS_THAN Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mLESS_THAN(
    bool _createToken
)
Visual Basic
Public Sub mLESS_THAN ( _
    _createToken As Boolean _
)
Visual C++
public:
void mLESS_THAN(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mLESS_THAN_OR_EQUAL Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mLESS_THAN_OR_EQUAL Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mLESS_THAN_OR_EQUAL(
    bool _createToken
)
Visual Basic
Public Sub mLESS_THAN_OR_EQUAL ( _
    _createToken As Boolean _
)
Visual C++
public:
void mLESS_THAN_OR_EQUAL(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mMINUS Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mMINUS Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mMINUS(
    bool _createToken
)
Visual Basic
Public Sub mMINUS ( _
    _createToken As Boolean _
)
Visual C++
public:
void mMINUS(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mMULT Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mMULT Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mMULT(
    bool _createToken
)
Visual Basic
Public Sub mMULT ( _
    _createToken As Boolean _
)
Visual C++
public:
void mMULT(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mNOT_EQUAL Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mNOT_EQUAL Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mNOT_EQUAL(
    bool _createToken
)
Visual Basic
Public Sub mNOT_EQUAL ( _
    _createToken As Boolean _
)
Visual C++
public:
void mNOT_EQUAL(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mOPEN_BRACKET Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mOPEN_BRACKET Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mOPEN_BRACKET(
    bool _createToken
)
Visual Basic
Public Sub mOPEN_BRACKET ( _
    _createToken As Boolean _
)
Visual C++
public:
void mOPEN_BRACKET(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mOPEN_PAREN Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mOPEN_PAREN Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mOPEN_PAREN(
    bool _createToken
)
Visual Basic
Public Sub mOPEN_PAREN ( _
    _createToken As Boolean _
)
Visual C++
public:
void mOPEN_PAREN(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mPLUS Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mPLUS Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mPLUS(
    bool _createToken
)
Visual Basic
Public Sub mPLUS ( _
    _createToken As Boolean _
)
Visual C++
public:
void mPLUS(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mPOS_INT Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mPOS_INT Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mPOS_INT(
    bool _createToken
)
Visual Basic
Public Sub mPOS_INT ( _
    _createToken As Boolean _
)
Visual C++
public:
void mPOS_INT(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mQUOTED_IDENTIFIER Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mQUOTED_IDENTIFIER Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mQUOTED_IDENTIFIER(
    bool _createToken
)
Visual Basic
Protected Sub mQUOTED_IDENTIFIER ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mQUOTED_IDENTIFIER(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mQUOTED_IDENTIFIER_CHAR Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mQUOTED_IDENTIFIER_CHAR Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mQUOTED_IDENTIFIER_CHAR(
    bool _createToken
)
Visual Basic
Protected Sub mQUOTED_IDENTIFIER_CHAR ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mQUOTED_IDENTIFIER_CHAR(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mREGULAR_IDENTIFIER Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mREGULAR_IDENTIFIER Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mREGULAR_IDENTIFIER(
    bool _createToken
)
Visual Basic
Protected Sub mREGULAR_IDENTIFIER ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mREGULAR_IDENTIFIER(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mSEMI Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mSEMI Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mSEMI(
    bool _createToken
)
Visual Basic
Public Sub mSEMI ( _
    _createToken As Boolean _
)
Visual C++
public:
void mSEMI(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mSTRING_LITERAL Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mSTRING_LITERAL Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mSTRING_LITERAL(
    bool _createToken
)
Visual Basic
Public Sub mSTRING_LITERAL ( _
    _createToken As Boolean _
)
Visual C++
public:
void mSTRING_LITERAL(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mSTRING_LITERAL_CHAR Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mSTRING_LITERAL_CHAR Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mSTRING_LITERAL_CHAR(
    bool _createToken
)
Visual Basic
Protected Sub mSTRING_LITERAL_CHAR ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mSTRING_LITERAL_CHAR(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mSTRING_LITERAL_ESCAPE_SEQ Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mSTRING_LITERAL_ESCAPE_SEQ Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void mSTRING_LITERAL_ESCAPE_SEQ(
    bool _createToken
)
Visual Basic
Protected Sub mSTRING_LITERAL_ESCAPE_SEQ ( _
    _createToken As Boolean _
)
Visual C++
protected:
void mSTRING_LITERAL_ESCAPE_SEQ(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


mWS Method

[image]

Endeca Presentation API
AnalyticsLexer..::..mWS Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void mWS(
    bool _createToken
)
Visual Basic
Public Sub mWS ( _
    _createToken As Boolean _
)
Visual C++
public:
void mWS(
    bool _createToken
)

Parameters

_createToken
Type: System..::..Boolean

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


nextToken Method

[image]

Endeca Presentation API
AnalyticsLexer..::..nextToken Method
AnalyticsLexer Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override IToken nextToken()
Visual Basic
Public Overrides Function nextToken As IToken
Visual C++
public:
virtual IToken^ nextToken() override

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsLexer.nextToken"]

See Also

AnalyticsLexer Class
Endeca.Navigation.Analytics Namespace


AnalyticsParser Class

[image]

Endeca Presentation API
AnalyticsParser Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AnalyticsParser : LLkParser
Visual Basic
Public Class AnalyticsParser _
    Inherits LLkParser
Visual C++
public ref class AnalyticsParser : public LLkParser

Inheritance Hierarchy

System..::..Object
Parser
LLkParser
Endeca.Navigation.Analytics..::..AnalyticsParser

See Also

AnalyticsParser Members
Endeca.Navigation.Analytics Namespace


AnalyticsParser Members

[image] [image]

Endeca Presentation API
AnalyticsParser Members
AnalyticsParser Class Constructors Methods Fields See Also Send Feedback

The AnalyticsParser type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsParser(ParserSharedInputState) | Initializes a new instance of the AnalyticsParser class
Public method | AnalyticsParser(TokenBuffer) | Initializes a new instance of the AnalyticsParser class
Public method | AnalyticsParser(TokenStream) | Initializes a new instance of the AnalyticsParser class
Protected method | AnalyticsParser(TokenBuffer, Int32) | Initializes a new instance of the AnalyticsParser class
Protected method | AnalyticsParser(TokenStream, Int32) | Initializes a new instance of the AnalyticsParser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseAnalyticsQuery |
Public method | parseCoalesceList |
Public method | parseComparison |
Public method | parseDateTimeConst |
Public method | parseDValComparison |
Public method | parseExpr |
Public method | parseExprAggregate |
Public method | parseExprBinaryFactor |
Public method | parseExprBinaryTerm |
Public method | parseExprCoalesce |
Public method | parseExprFunction |
Public method | parseExprLookup |
Public method | parseFilter |
Public method | parseFilterBooleanFactor |
Public method | parseFilterBooleanTerm |
Public method | parseFloat |
Public method | parseGroupBy |
Public method | parseGroupByList |
Public method | parseInt |
Public method | parseLiteral |
Public method | parseLookupList |
Public method | parseNullComparison |
Public method | parseNumber |
Public method | parseOrderBy |
Public method | parseOrderByList |
Public method | parseSelect |
Public method | parseSelectList |
Public method | parseStatement |
 | Test |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
tokenNames_ |
tokenSet_0_ |
tokenSet_1_ |
WS |

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor

[image] [image]

Endeca Presentation API
AnalyticsParser Constructor
AnalyticsParser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalyticsParser(ParserSharedInputState) | Initializes a new instance of the AnalyticsParser class
Public method | AnalyticsParser(TokenBuffer) | Initializes a new instance of the AnalyticsParser class
Public method | AnalyticsParser(TokenStream) | Initializes a new instance of the AnalyticsParser class
Protected method | AnalyticsParser(TokenBuffer, Int32) | Initializes a new instance of the AnalyticsParser class
Protected method | AnalyticsParser(TokenStream, Int32) | Initializes a new instance of the AnalyticsParser class

See Also

AnalyticsParser Class
AnalyticsParser Members
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor ()

[image]

Endeca Presentation API
AnalyticsParser Constructor ()
AnalyticsParser Class See Also Send Feedback
Initializes a new instance of the AnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsParser(
    ParserSharedInputState state
)
Visual Basic
Public Sub New ( _
    state As ParserSharedInputState _
)
Visual C++
public:
AnalyticsParser(
    ParserSharedInputState^ state
)

Parameters

state
Type: ParserSharedInputState

See Also

AnalyticsParser Class
AnalyticsParser Overload
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor ()

[image]

Endeca Presentation API
AnalyticsParser Constructor ()
AnalyticsParser Class See Also Send Feedback
Initializes a new instance of the AnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsParser(
    TokenBuffer tokenBuf
)
Visual Basic
Public Sub New ( _
    tokenBuf As TokenBuffer _
)
Visual C++
public:
AnalyticsParser(
    TokenBuffer^ tokenBuf
)

Parameters

tokenBuf
Type: TokenBuffer

See Also

AnalyticsParser Class
AnalyticsParser Overload
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor ()

[image]

Endeca Presentation API
AnalyticsParser Constructor ()
AnalyticsParser Class See Also Send Feedback
Initializes a new instance of the AnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsParser(
    TokenStream lexer
)
Visual Basic
Public Sub New ( _
    lexer As TokenStream _
)
Visual C++
public:
AnalyticsParser(
    TokenStream^ lexer
)

Parameters

lexer
Type: TokenStream

See Also

AnalyticsParser Class
AnalyticsParser Overload
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor (, Int32)

[image]

Endeca Presentation API
AnalyticsParser Constructor (, Int32)
AnalyticsParser Class See Also Send Feedback
Initializes a new instance of the AnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected AnalyticsParser(
    TokenBuffer tokenBuf,
    int k
)
Visual Basic
Protected Sub New ( _
    tokenBuf As TokenBuffer, _
    k As Integer _
)
Visual C++
protected:
AnalyticsParser(
    TokenBuffer^ tokenBuf,
    int k
)

Parameters

tokenBuf
Type: TokenBuffer
k
Type: System..::..Int32

See Also

AnalyticsParser Class
AnalyticsParser Overload
Endeca.Navigation.Analytics Namespace


AnalyticsParser Constructor (, Int32)

[image]

Endeca Presentation API
AnalyticsParser Constructor (, Int32)
AnalyticsParser Class See Also Send Feedback
Initializes a new instance of the AnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected AnalyticsParser(
    TokenStream lexer,
    int k
)
Visual Basic
Protected Sub New ( _
    lexer As TokenStream, _
    k As Integer _
)
Visual C++
protected:
AnalyticsParser(
    TokenStream^ lexer,
    int k
)

Parameters

lexer
Type: TokenStream
k
Type: System..::..Int32

See Also

AnalyticsParser Class
AnalyticsParser Overload
Endeca.Navigation.Analytics Namespace


AnalyticsParser Fields

[image] [image]

Endeca Presentation API
AnalyticsParser Fields
AnalyticsParser Class See Also Send Feedback

The AnalyticsParser type exposes the following members.

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
tokenNames_ |
tokenSet_0_ |
tokenSet_1_ |
WS |

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET Field

[image]

Endeca Presentation API
AnalyticsParser..::..CLOSE_BRACKET Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET
Visual Basic
Public Const CLOSE_BRACKET As Integer
Visual C++
public:
literal int CLOSE_BRACKET

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET_PERIOD Field

[image]

Endeca Presentation API
AnalyticsParser..::..CLOSE_BRACKET_PERIOD Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET_PERIOD
Visual Basic
Public Const CLOSE_BRACKET_PERIOD As Integer
Visual C++
public:
literal int CLOSE_BRACKET_PERIOD

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


CLOSE_PAREN Field

[image]

Endeca Presentation API
AnalyticsParser..::..CLOSE_PAREN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_PAREN
Visual Basic
Public Const CLOSE_PAREN As Integer
Visual C++
public:
literal int CLOSE_PAREN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


COLON Field

[image]

Endeca Presentation API
AnalyticsParser..::..COLON Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COLON
Visual Basic
Public Const COLON As Integer
Visual C++
public:
literal int COLON

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


COMMA Field

[image]

Endeca Presentation API
AnalyticsParser..::..COMMA Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COMMA
Visual Basic
Public Const COMMA As Integer
Visual C++
public:
literal int COMMA

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


DIGIT Field

[image]

Endeca Presentation API
AnalyticsParser..::..DIGIT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIGIT
Visual Basic
Public Const DIGIT As Integer
Visual C++
public:
literal int DIGIT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


DIV Field

[image]

Endeca Presentation API
AnalyticsParser..::..DIV Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIV
Visual Basic
Public Const DIV As Integer
Visual C++
public:
literal int DIV

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


EOF Field

[image]

Endeca Presentation API
AnalyticsParser..::..EOF Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EOF
Visual Basic
Public Const EOF As Integer
Visual C++
public:
literal int EOF

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


EQUAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..EQUAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EQUAL
Visual Basic
Public Const EQUAL As Integer
Visual C++
public:
literal int EQUAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


EXPONENT Field

[image]

Endeca Presentation API
AnalyticsParser..::..EXPONENT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EXPONENT
Visual Basic
Public Const EXPONENT As Integer
Visual C++
public:
literal int EXPONENT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


FLOAT_SUFFIX Field

[image]

Endeca Presentation API
AnalyticsParser..::..FLOAT_SUFFIX Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int FLOAT_SUFFIX
Visual Basic
Public Const FLOAT_SUFFIX As Integer
Visual C++
public:
literal int FLOAT_SUFFIX

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN Field

[image]

Endeca Presentation API
AnalyticsParser..::..GREATER_THAN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN
Visual Basic
Public Const GREATER_THAN As Integer
Visual C++
public:
literal int GREATER_THAN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..GREATER_THAN_OR_EQUAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN_OR_EQUAL
Visual Basic
Public Const GREATER_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int GREATER_THAN_OR_EQUAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParser..::..IDENTIFIER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER
Visual Basic
Public Const IDENTIFIER As Integer
Visual C++
public:
literal int IDENTIFIER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..IDENTIFIER_CHAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_CHAR
Visual Basic
Public Const IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_CHAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsParser..::..IDENTIFIER_ESCAPE_SEQ Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_ESCAPE_SEQ
Visual Basic
Public Const IDENTIFIER_ESCAPE_SEQ As Integer
Visual C++
public:
literal int IDENTIFIER_ESCAPE_SEQ

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_START_CHAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..IDENTIFIER_START_CHAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_START_CHAR
Visual Basic
Public Const IDENTIFIER_START_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_START_CHAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LESS_THAN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LESS_THAN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN
Visual Basic
Public Const LESS_THAN As Integer
Visual C++
public:
literal int LESS_THAN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LESS_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..LESS_THAN_OR_EQUAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN_OR_EQUAL
Visual Basic
Public Const LESS_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int LESS_THAN_OR_EQUAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_ABS Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_ABS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ABS
Visual Basic
Public Const LITERAL_ABS As Integer
Visual C++
public:
literal int LITERAL_ABS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_AND Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_AND Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AND
Visual Basic
Public Const LITERAL_AND As Integer
Visual C++
public:
literal int LITERAL_AND

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_ARB Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_ARB Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ARB
Visual Basic
Public Const LITERAL_ARB As Integer
Visual C++
public:
literal int LITERAL_ARB

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_AS Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_AS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AS
Visual Basic
Public Const LITERAL_AS As Integer
Visual C++
public:
literal int LITERAL_AS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_ASC Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_ASC Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ASC
Visual Basic
Public Const LITERAL_ASC As Integer
Visual C++
public:
literal int LITERAL_ASC

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_AVG Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_AVG Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AVG
Visual Basic
Public Const LITERAL_AVG As Integer
Visual C++
public:
literal int LITERAL_AVG

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_BY Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_BY Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_BY
Visual Basic
Public Const LITERAL_BY As Integer
Visual C++
public:
literal int LITERAL_BY

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_CEIL Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_CEIL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_CEIL
Visual Basic
Public Const LITERAL_CEIL As Integer
Visual C++
public:
literal int LITERAL_CEIL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_COALESCE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_COALESCE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COALESCE
Visual Basic
Public Const LITERAL_COALESCE As Integer
Visual C++
public:
literal int LITERAL_COALESCE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_COS Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_COS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COS
Visual Basic
Public Const LITERAL_COS As Integer
Visual C++
public:
literal int LITERAL_COS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_COUNT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNT
Visual Basic
Public Const LITERAL_COUNT As Integer
Visual C++
public:
literal int LITERAL_COUNT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNTDISTINCT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_COUNTDISTINCT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNTDISTINCT
Visual Basic
Public Const LITERAL_COUNTDISTINCT As Integer
Visual C++
public:
literal int LITERAL_COUNTDISTINCT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DATE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DATE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DATE
Visual Basic
Public Const LITERAL_DATE As Integer
Visual C++
public:
literal int LITERAL_DATE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_MONTH Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DAY_OF_MONTH Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_MONTH
Visual Basic
Public Const LITERAL_DAY_OF_MONTH As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_MONTH

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_WEEK Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DAY_OF_WEEK Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_WEEK
Visual Basic
Public Const LITERAL_DAY_OF_WEEK As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_WEEK

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_YEAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DAY_OF_YEAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_YEAR
Visual Basic
Public Const LITERAL_DAY_OF_YEAR As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_YEAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DEFINE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DEFINE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DEFINE
Visual Basic
Public Const LITERAL_DEFINE As Integer
Visual C++
public:
literal int LITERAL_DEFINE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DESC Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DESC Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DESC
Visual Basic
Public Const LITERAL_DESC As Integer
Visual C++
public:
literal int LITERAL_DESC

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_DVAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_DVAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DVAL
Visual Basic
Public Const LITERAL_DVAL As Integer
Visual C++
public:
literal int LITERAL_DVAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXP Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_EXP Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXP
Visual Basic
Public Const LITERAL_EXP As Integer
Visual C++
public:
literal int LITERAL_EXP

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXTRACT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_EXTRACT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXTRACT
Visual Basic
Public Const LITERAL_EXTRACT As Integer
Visual C++
public:
literal int LITERAL_EXTRACT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_FLOOR Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_FLOOR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FLOOR
Visual Basic
Public Const LITERAL_FLOOR As Integer
Visual C++
public:
literal int LITERAL_FLOOR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_FROM Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_FROM Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FROM
Visual Basic
Public Const LITERAL_FROM As Integer
Visual C++
public:
literal int LITERAL_FROM

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_GROUP Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_GROUP Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_GROUP
Visual Basic
Public Const LITERAL_GROUP As Integer
Visual C++
public:
literal int LITERAL_GROUP

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_HAVING Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_HAVING Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HAVING
Visual Basic
Public Const LITERAL_HAVING As Integer
Visual C++
public:
literal int LITERAL_HAVING

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_HOUR Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_HOUR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HOUR
Visual Basic
Public Const LITERAL_HOUR As Integer
Visual C++
public:
literal int LITERAL_HOUR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_IN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_IN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IN
Visual Basic
Public Const LITERAL_IN As Integer
Visual C++
public:
literal int LITERAL_IN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_IS Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_IS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IS
Visual Basic
Public Const LITERAL_IS As Integer
Visual C++
public:
literal int LITERAL_IS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_LAG Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_LAG Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LAG
Visual Basic
Public Const LITERAL_LAG As Integer
Visual C++
public:
literal int LITERAL_LAG

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_LEAD Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_LEAD Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LEAD
Visual Basic
Public Const LITERAL_LEAD As Integer
Visual C++
public:
literal int LITERAL_LEAD

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_LN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_LN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LN
Visual Basic
Public Const LITERAL_LN As Integer
Visual C++
public:
literal int LITERAL_LN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_LOG Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_LOG Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LOG
Visual Basic
Public Const LITERAL_LOG As Integer
Visual C++
public:
literal int LITERAL_LOG

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MAX Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MAX Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MAX
Visual Basic
Public Const LITERAL_MAX As Integer
Visual C++
public:
literal int LITERAL_MAX

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MEDIAN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MEDIAN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MEDIAN
Visual Basic
Public Const LITERAL_MEDIAN As Integer
Visual C++
public:
literal int LITERAL_MEDIAN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MIN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MIN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MIN
Visual Basic
Public Const LITERAL_MIN As Integer
Visual C++
public:
literal int LITERAL_MIN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MINUTE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MINUTE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MINUTE
Visual Basic
Public Const LITERAL_MINUTE As Integer
Visual C++
public:
literal int LITERAL_MINUTE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MOD Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MOD Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MOD
Visual Basic
Public Const LITERAL_MOD As Integer
Visual C++
public:
literal int LITERAL_MOD

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_MONTH Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_MONTH Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MONTH
Visual Basic
Public Const LITERAL_MONTH As Integer
Visual C++
public:
literal int LITERAL_MONTH

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_NOT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_NOT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NOT
Visual Basic
Public Const LITERAL_NOT As Integer
Visual C++
public:
literal int LITERAL_NOT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_NULL Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_NULL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NULL
Visual Basic
Public Const LITERAL_NULL As Integer
Visual C++
public:
literal int LITERAL_NULL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_OR Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_OR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_OR
Visual Basic
Public Const LITERAL_OR As Integer
Visual C++
public:
literal int LITERAL_OR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_ORDER Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_ORDER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ORDER
Visual Basic
Public Const LITERAL_ORDER As Integer
Visual C++
public:
literal int LITERAL_ORDER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_PAGE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_PAGE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_PAGE
Visual Basic
Public Const LITERAL_PAGE As Integer
Visual C++
public:
literal int LITERAL_PAGE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_POWER Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_POWER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_POWER
Visual Basic
Public Const LITERAL_POWER As Integer
Visual C++
public:
literal int LITERAL_POWER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_QUARTER Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_QUARTER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_QUARTER
Visual Basic
Public Const LITERAL_QUARTER As Integer
Visual C++
public:
literal int LITERAL_QUARTER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_RETURN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_RETURN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_RETURN
Visual Basic
Public Const LITERAL_RETURN As Integer
Visual C++
public:
literal int LITERAL_RETURN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_ROUND Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_ROUND Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ROUND
Visual Basic
Public Const LITERAL_ROUND As Integer
Visual C++
public:
literal int LITERAL_ROUND

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SECOND Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SECOND Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SECOND
Visual Basic
Public Const LITERAL_SECOND As Integer
Visual C++
public:
literal int LITERAL_SECOND

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SELECT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SELECT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SELECT
Visual Basic
Public Const LITERAL_SELECT As Integer
Visual C++
public:
literal int LITERAL_SELECT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIGN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SIGN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIGN
Visual Basic
Public Const LITERAL_SIGN As Integer
Visual C++
public:
literal int LITERAL_SIGN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SIN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIN
Visual Basic
Public Const LITERAL_SIN As Integer
Visual C++
public:
literal int LITERAL_SIN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SQRT Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SQRT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SQRT
Visual Basic
Public Const LITERAL_SQRT As Integer
Visual C++
public:
literal int LITERAL_SQRT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_STDDEV Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_STDDEV Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_STDDEV
Visual Basic
Public Const LITERAL_STDDEV As Integer
Visual C++
public:
literal int LITERAL_STDDEV

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_SUM Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_SUM Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SUM
Visual Basic
Public Const LITERAL_SUM As Integer
Visual C++
public:
literal int LITERAL_SUM

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_TAN Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_TAN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TAN
Visual Basic
Public Const LITERAL_TAN As Integer
Visual C++
public:
literal int LITERAL_TAN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_TO_DURATION Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_TO_DURATION Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TO_DURATION
Visual Basic
Public Const LITERAL_TO_DURATION As Integer
Visual C++
public:
literal int LITERAL_TO_DURATION

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_TRUNC Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_TRUNC Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TRUNC
Visual Basic
Public Const LITERAL_TRUNC As Integer
Visual C++
public:
literal int LITERAL_TRUNC

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_VARIANCE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_VARIANCE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_VARIANCE
Visual Basic
Public Const LITERAL_VARIANCE As Integer
Visual C++
public:
literal int LITERAL_VARIANCE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_WEEK Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_WEEK Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WEEK
Visual Basic
Public Const LITERAL_WEEK As Integer
Visual C++
public:
literal int LITERAL_WEEK

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_WHERE Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_WHERE Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WHERE
Visual Basic
Public Const LITERAL_WHERE As Integer
Visual C++
public:
literal int LITERAL_WHERE

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


LITERAL_YEAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..LITERAL_YEAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_YEAR
Visual Basic
Public Const LITERAL_YEAR As Integer
Visual C++
public:
literal int LITERAL_YEAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


MINUS Field

[image]

Endeca Presentation API
AnalyticsParser..::..MINUS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MINUS
Visual Basic
Public Const MINUS As Integer
Visual C++
public:
literal int MINUS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


MULT Field

[image]

Endeca Presentation API
AnalyticsParser..::..MULT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MULT
Visual Basic
Public Const MULT As Integer
Visual C++
public:
literal int MULT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


NOT_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..NOT_EQUAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NOT_EQUAL
Visual Basic
Public Const NOT_EQUAL As Integer
Visual C++
public:
literal int NOT_EQUAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


NULL_TREE_LOOKAHEAD Field

[image]

Endeca Presentation API
AnalyticsParser..::..NULL_TREE_LOOKAHEAD Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NULL_TREE_LOOKAHEAD
Visual Basic
Public Const NULL_TREE_LOOKAHEAD As Integer
Visual C++
public:
literal int NULL_TREE_LOOKAHEAD

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


OPEN_BRACKET Field

[image]

Endeca Presentation API
AnalyticsParser..::..OPEN_BRACKET Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_BRACKET
Visual Basic
Public Const OPEN_BRACKET As Integer
Visual C++
public:
literal int OPEN_BRACKET

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


OPEN_PAREN Field

[image]

Endeca Presentation API
AnalyticsParser..::..OPEN_PAREN Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_PAREN
Visual Basic
Public Const OPEN_PAREN As Integer
Visual C++
public:
literal int OPEN_PAREN

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


PLUS Field

[image]

Endeca Presentation API
AnalyticsParser..::..PLUS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int PLUS
Visual Basic
Public Const PLUS As Integer
Visual C++
public:
literal int PLUS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


POS_FLOAT Field

[image]

Endeca Presentation API
AnalyticsParser..::..POS_FLOAT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_FLOAT
Visual Basic
Public Const POS_FLOAT As Integer
Visual C++
public:
literal int POS_FLOAT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


POS_INT Field

[image]

Endeca Presentation API
AnalyticsParser..::..POS_INT Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_INT
Visual Basic
Public Const POS_INT As Integer
Visual C++
public:
literal int POS_INT

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParser..::..QUOTED_IDENTIFIER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER
Visual Basic
Public Const QUOTED_IDENTIFIER As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..QUOTED_IDENTIFIER_CHAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER_CHAR
Visual Basic
Public Const QUOTED_IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER_CHAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


REGULAR_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParser..::..REGULAR_IDENTIFIER Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int REGULAR_IDENTIFIER
Visual Basic
Public Const REGULAR_IDENTIFIER As Integer
Visual C++
public:
literal int REGULAR_IDENTIFIER

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


SEMI Field

[image]

Endeca Presentation API
AnalyticsParser..::..SEMI Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int SEMI
Visual Basic
Public Const SEMI As Integer
Visual C++
public:
literal int SEMI

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL Field

[image]

Endeca Presentation API
AnalyticsParser..::..STRING_LITERAL Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL
Visual Basic
Public Const STRING_LITERAL As Integer
Visual C++
public:
literal int STRING_LITERAL

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_CHAR Field

[image]

Endeca Presentation API
AnalyticsParser..::..STRING_LITERAL_CHAR Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_CHAR
Visual Basic
Public Const STRING_LITERAL_CHAR As Integer
Visual C++
public:
literal int STRING_LITERAL_CHAR

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsParser..::..STRING_LITERAL_ESCAPE_SEQ Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_ESCAPE_SEQ
Visual Basic
Public Const STRING_LITERAL_ESCAPE_SEQ As Integer
Visual C++
public:
literal int STRING_LITERAL_ESCAPE_SEQ

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


tokenNames_ Field

[image]

Endeca Presentation API
AnalyticsParser..::..tokenNames_ Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly string[] tokenNames_
Visual Basic
Public Shared ReadOnly tokenNames_ As String()
Visual C++
public:
static initonly array<String^>^ tokenNames_

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


tokenSet_0_ Field

[image]

Endeca Presentation API
AnalyticsParser..::..tokenSet_0_ Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_0_
Visual Basic
Public Shared ReadOnly tokenSet_0_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_0_

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


tokenSet_1_ Field

[image]

Endeca Presentation API
AnalyticsParser..::..tokenSet_1_ Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly BitSet tokenSet_1_
Visual Basic
Public Shared ReadOnly tokenSet_1_ As BitSet
Visual C++
public:
static initonly BitSet^ tokenSet_1_

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


WS Field

[image]

Endeca Presentation API
AnalyticsParser..::..WS Field
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int WS
Visual Basic
Public Const WS As Integer
Visual C++
public:
literal int WS

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


AnalyticsParser Methods

[image] [image]

Endeca Presentation API
AnalyticsParser Methods
AnalyticsParser Class See Also Send Feedback

The AnalyticsParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | initialize |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | parseAnalyticsQuery |
Public method | parseCoalesceList |
Public method | parseComparison |
Public method | parseDateTimeConst |
Public method | parseDValComparison |
Public method | parseExpr |
Public method | parseExprAggregate |
Public method | parseExprBinaryFactor |
Public method | parseExprBinaryTerm |
Public method | parseExprCoalesce |
Public method | parseExprFunction |
Public method | parseExprLookup |
Public method | parseFilter |
Public method | parseFilterBooleanFactor |
Public method | parseFilterBooleanTerm |
Public method | parseFloat |
Public method | parseGroupBy |
Public method | parseGroupByList |
Public method | parseInt |
Public method | parseLiteral |
Public method | parseLookupList |
Public method | parseNullComparison |
Public method | parseNumber |
Public method | parseOrderBy |
Public method | parseOrderByList |
Public method | parseSelect |
Public method | parseSelectList |
Public method | parseStatement |
 | Test |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


initialize Method

[image]

Endeca Presentation API
AnalyticsParser..::..initialize Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
protected void initialize()
Visual Basic
Protected Sub initialize
Visual C++
protected:
void initialize()

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseAnalyticsQuery Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseAnalyticsQuery Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsQuery parseAnalyticsQuery()
Visual Basic
Public Function parseAnalyticsQuery As AnalyticsQuery
Visual C++
public:
AnalyticsQuery^ parseAnalyticsQuery()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseAnalyticsQuery"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseCoalesceList Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseCoalesceList Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public CoalesceList parseCoalesceList()
Visual Basic
Public Function parseCoalesceList As CoalesceList
Visual C++
public:
CoalesceList^ parseCoalesceList()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseCoalesceList"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseComparison Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseComparison Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseComparison()
Visual Basic
Public Function parseComparison As IFilter
Visual C++
public:
IFilter^ parseComparison()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseComparison"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseDateTimeConst Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseDateTimeConst Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int parseDateTimeConst()
Visual Basic
Public Function parseDateTimeConst As Integer
Visual C++
public:
int parseDateTimeConst()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseDateTimeConst"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseDValComparison Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseDValComparison Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseDValComparison()
Visual Basic
Public Function parseDValComparison As IFilter
Visual C++
public:
IFilter^ parseDValComparison()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseDValComparison"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExpr Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExpr Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExpr()
Visual Basic
Public Function parseExpr As IExpr
Visual C++
public:
IExpr^ parseExpr()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExpr"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprAggregate Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprAggregate Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprAggregate parseExprAggregate()
Visual Basic
Public Function parseExprAggregate As ExprAggregate
Visual C++
public:
ExprAggregate^ parseExprAggregate()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprAggregate"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprBinaryFactor Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprBinaryFactor Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExprBinaryFactor()
Visual Basic
Public Function parseExprBinaryFactor As IExpr
Visual C++
public:
IExpr^ parseExprBinaryFactor()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprBinaryFactor"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprBinaryTerm Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprBinaryTerm Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExprBinaryTerm()
Visual Basic
Public Function parseExprBinaryTerm As IExpr
Visual C++
public:
IExpr^ parseExprBinaryTerm()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprBinaryTerm"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprCoalesce Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprCoalesce Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExprCoalesce()
Visual Basic
Public Function parseExprCoalesce As IExpr
Visual C++
public:
IExpr^ parseExprCoalesce()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprCoalesce"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprFunction Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprFunction Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExprFunction()
Visual Basic
Public Function parseExprFunction As IExpr
Visual C++
public:
IExpr^ parseExprFunction()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprFunction"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseExprLookup Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseExprLookup Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IExpr parseExprLookup()
Visual Basic
Public Function parseExprLookup As IExpr
Visual C++
public:
IExpr^ parseExprLookup()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseExprLookup"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseFilter Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseFilter Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseFilter()
Visual Basic
Public Function parseFilter As IFilter
Visual C++
public:
IFilter^ parseFilter()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseFilter"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseFilterBooleanFactor Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseFilterBooleanFactor Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseFilterBooleanFactor()
Visual Basic
Public Function parseFilterBooleanFactor As IFilter
Visual C++
public:
IFilter^ parseFilterBooleanFactor()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseFilterBooleanFactor"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseFilterBooleanTerm Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseFilterBooleanTerm Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseFilterBooleanTerm()
Visual Basic
Public Function parseFilterBooleanTerm As IFilter
Visual C++
public:
IFilter^ parseFilterBooleanTerm()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseFilterBooleanTerm"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseFloat Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseFloat Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string parseFloat()
Visual Basic
Public Function parseFloat As String
Visual C++
public:
String^ parseFloat()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseFloat"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseGroupBy Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseGroupBy Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GroupBy parseGroupBy()
Visual Basic
Public Function parseGroupBy As GroupBy
Visual C++
public:
GroupBy^ parseGroupBy()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseGroupBy"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseGroupByList Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseGroupByList Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GroupByList parseGroupByList()
Visual Basic
Public Function parseGroupByList As GroupByList
Visual C++
public:
GroupByList^ parseGroupByList()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseGroupByList"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseInt Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseInt Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string parseInt()
Visual Basic
Public Function parseInt As String
Visual C++
public:
String^ parseInt()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseInt"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseLiteral Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseLiteral Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string parseLiteral()
Visual Basic
Public Function parseLiteral As String
Visual C++
public:
String^ parseLiteral()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseLiteral"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseLookupList Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseLookupList Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public LookupList parseLookupList()
Visual Basic
Public Function parseLookupList As LookupList
Visual C++
public:
LookupList^ parseLookupList()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseLookupList"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseNullComparison Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseNullComparison Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public IFilter parseNullComparison()
Visual Basic
Public Function parseNullComparison As IFilter
Visual C++
public:
IFilter^ parseNullComparison()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseNullComparison"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseNumber Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseNumber Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string parseNumber()
Visual Basic
Public Function parseNumber As String
Visual C++
public:
String^ parseNumber()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseNumber"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseOrderBy Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseOrderBy Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OrderBy parseOrderBy()
Visual Basic
Public Function parseOrderBy As OrderBy
Visual C++
public:
OrderBy^ parseOrderBy()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseOrderBy"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseOrderByList Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseOrderByList Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OrderByList parseOrderByList()
Visual Basic
Public Function parseOrderByList As OrderByList
Visual C++
public:
OrderByList^ parseOrderByList()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseOrderByList"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseSelect Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseSelect Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Select parseSelect()
Visual Basic
Public Function parseSelect As Select
Visual C++
public:
Select^ parseSelect()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseSelect"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseSelectList Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseSelectList Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public SelectList parseSelectList()
Visual Basic
Public Function parseSelectList As SelectList
Visual C++
public:
SelectList^ parseSelectList()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseSelectList"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


parseStatement Method

[image]

Endeca Presentation API
AnalyticsParser..::..parseStatement Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Statement parseStatement()
Visual Basic
Public Function parseStatement As Statement
Visual C++
public:
Statement^ parseStatement()

Return Value

[Missing <returns> documentation for "M:Endeca.Navigation.Analytics.AnalyticsParser.parseStatement"]

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


Test Method

[image]

Endeca Presentation API
AnalyticsParser..::..Test Method
AnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static void Test(
    Stream input
)
Visual Basic
Public Shared Sub Test ( _
    input As Stream _
)
Visual C++
public:
static void Test(
    Stream^ input
)

Parameters

input
Type: System.IO..::..Stream

See Also

AnalyticsParser Class
Endeca.Navigation.Analytics Namespace


AnalyticsParserTokenTypes Class

[image]

Endeca Presentation API
AnalyticsParserTokenTypes Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AnalyticsParserTokenTypes
Visual Basic
Public Class AnalyticsParserTokenTypes
Visual C++
public ref class AnalyticsParserTokenTypes

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..AnalyticsParserTokenTypes

See Also

AnalyticsParserTokenTypes Members
Endeca.Navigation.Analytics Namespace


AnalyticsParserTokenTypes Members

[image] [image]

Endeca Presentation API
AnalyticsParserTokenTypes Members
AnalyticsParserTokenTypes Class Constructors Methods Fields See Also Send Feedback

The AnalyticsParserTokenTypes type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsParserTokenTypes | Initializes a new instance of the AnalyticsParserTokenTypes class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
WS |

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


AnalyticsParserTokenTypes Constructor

[image]

Endeca Presentation API
AnalyticsParserTokenTypes Constructor
AnalyticsParserTokenTypes Class See Also Send Feedback
Initializes a new instance of the AnalyticsParserTokenTypes class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsParserTokenTypes()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsParserTokenTypes()

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


AnalyticsParserTokenTypes Fields

[image] [image]

Endeca Presentation API
AnalyticsParserTokenTypes Fields
AnalyticsParserTokenTypes Class See Also Send Feedback

The AnalyticsParserTokenTypes type exposes the following members.

Fields

Name | Description
CLOSE_BRACKET |
CLOSE_BRACKET_PERIOD |
CLOSE_PAREN |
COLON |
COMMA |
DIGIT |
DIV |
EOF |
EQUAL |
EXPONENT |
FLOAT_SUFFIX |
GREATER_THAN |
GREATER_THAN_OR_EQUAL |
IDENTIFIER |
IDENTIFIER_CHAR |
IDENTIFIER_ESCAPE_SEQ |
IDENTIFIER_START_CHAR |
LESS_THAN |
LESS_THAN_OR_EQUAL |
LITERAL_ABS |
LITERAL_AND |
LITERAL_ARB |
LITERAL_AS |
LITERAL_ASC |
LITERAL_AVG |
LITERAL_BY |
LITERAL_CEIL |
LITERAL_COALESCE |
LITERAL_COS |
LITERAL_COUNT |
LITERAL_COUNTDISTINCT |
LITERAL_DATE |
LITERAL_DAY_OF_MONTH |
LITERAL_DAY_OF_WEEK |
LITERAL_DAY_OF_YEAR |
LITERAL_DEFINE |
LITERAL_DESC |
LITERAL_DVAL |
LITERAL_EXP |
LITERAL_EXTRACT |
LITERAL_FLOOR |
LITERAL_FROM |
LITERAL_GROUP |
LITERAL_HAVING |
LITERAL_HOUR |
LITERAL_IN |
LITERAL_IS |
LITERAL_LAG |
LITERAL_LEAD |
LITERAL_LN |
LITERAL_LOG |
LITERAL_MAX |
LITERAL_MEDIAN |
LITERAL_MIN |
LITERAL_MINUTE |
LITERAL_MOD |
LITERAL_MONTH |
LITERAL_NOT |
LITERAL_NULL |
LITERAL_OR |
LITERAL_ORDER |
LITERAL_PAGE |
LITERAL_POWER |
LITERAL_QUARTER |
LITERAL_RETURN |
LITERAL_ROUND |
LITERAL_SECOND |
LITERAL_SELECT |
LITERAL_SIGN |
LITERAL_SIN |
LITERAL_SQRT |
LITERAL_STDDEV |
LITERAL_SUM |
LITERAL_TAN |
LITERAL_TO_DURATION |
LITERAL_TRUNC |
LITERAL_VARIANCE |
LITERAL_WEEK |
LITERAL_WHERE |
LITERAL_YEAR |
MINUS |
MULT |
NOT_EQUAL |
NULL_TREE_LOOKAHEAD |
OPEN_BRACKET |
OPEN_PAREN |
PLUS |
POS_FLOAT |
POS_INT |
QUOTED_IDENTIFIER |
QUOTED_IDENTIFIER_CHAR |
REGULAR_IDENTIFIER |
SEMI |
STRING_LITERAL |
STRING_LITERAL_CHAR |
STRING_LITERAL_ESCAPE_SEQ |
WS |

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..CLOSE_BRACKET Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET
Visual Basic
Public Const CLOSE_BRACKET As Integer
Visual C++
public:
literal int CLOSE_BRACKET

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


CLOSE_BRACKET_PERIOD Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..CLOSE_BRACKET_PERIOD Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_BRACKET_PERIOD
Visual Basic
Public Const CLOSE_BRACKET_PERIOD As Integer
Visual C++
public:
literal int CLOSE_BRACKET_PERIOD

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


CLOSE_PAREN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..CLOSE_PAREN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int CLOSE_PAREN
Visual Basic
Public Const CLOSE_PAREN As Integer
Visual C++
public:
literal int CLOSE_PAREN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


COLON Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..COLON Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COLON
Visual Basic
Public Const COLON As Integer
Visual C++
public:
literal int COLON

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


COMMA Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..COMMA Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int COMMA
Visual Basic
Public Const COMMA As Integer
Visual C++
public:
literal int COMMA

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


DIGIT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..DIGIT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIGIT
Visual Basic
Public Const DIGIT As Integer
Visual C++
public:
literal int DIGIT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


DIV Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..DIV Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DIV
Visual Basic
Public Const DIV As Integer
Visual C++
public:
literal int DIV

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


EOF Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..EOF Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EOF
Visual Basic
Public Const EOF As Integer
Visual C++
public:
literal int EOF

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


EQUAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..EQUAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EQUAL
Visual Basic
Public Const EQUAL As Integer
Visual C++
public:
literal int EQUAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


EXPONENT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..EXPONENT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int EXPONENT
Visual Basic
Public Const EXPONENT As Integer
Visual C++
public:
literal int EXPONENT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


FLOAT_SUFFIX Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..FLOAT_SUFFIX Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int FLOAT_SUFFIX
Visual Basic
Public Const FLOAT_SUFFIX As Integer
Visual C++
public:
literal int FLOAT_SUFFIX

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..GREATER_THAN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN
Visual Basic
Public Const GREATER_THAN As Integer
Visual C++
public:
literal int GREATER_THAN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


GREATER_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..GREATER_THAN_OR_EQUAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int GREATER_THAN_OR_EQUAL
Visual Basic
Public Const GREATER_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int GREATER_THAN_OR_EQUAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..IDENTIFIER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER
Visual Basic
Public Const IDENTIFIER As Integer
Visual C++
public:
literal int IDENTIFIER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..IDENTIFIER_CHAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_CHAR
Visual Basic
Public Const IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_CHAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..IDENTIFIER_ESCAPE_SEQ Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_ESCAPE_SEQ
Visual Basic
Public Const IDENTIFIER_ESCAPE_SEQ As Integer
Visual C++
public:
literal int IDENTIFIER_ESCAPE_SEQ

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


IDENTIFIER_START_CHAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..IDENTIFIER_START_CHAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int IDENTIFIER_START_CHAR
Visual Basic
Public Const IDENTIFIER_START_CHAR As Integer
Visual C++
public:
literal int IDENTIFIER_START_CHAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LESS_THAN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LESS_THAN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN
Visual Basic
Public Const LESS_THAN As Integer
Visual C++
public:
literal int LESS_THAN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LESS_THAN_OR_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LESS_THAN_OR_EQUAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LESS_THAN_OR_EQUAL
Visual Basic
Public Const LESS_THAN_OR_EQUAL As Integer
Visual C++
public:
literal int LESS_THAN_OR_EQUAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_ABS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_ABS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ABS
Visual Basic
Public Const LITERAL_ABS As Integer
Visual C++
public:
literal int LITERAL_ABS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_AND Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_AND Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AND
Visual Basic
Public Const LITERAL_AND As Integer
Visual C++
public:
literal int LITERAL_AND

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_ARB Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_ARB Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ARB
Visual Basic
Public Const LITERAL_ARB As Integer
Visual C++
public:
literal int LITERAL_ARB

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_AS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_AS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AS
Visual Basic
Public Const LITERAL_AS As Integer
Visual C++
public:
literal int LITERAL_AS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_ASC Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_ASC Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ASC
Visual Basic
Public Const LITERAL_ASC As Integer
Visual C++
public:
literal int LITERAL_ASC

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_AVG Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_AVG Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_AVG
Visual Basic
Public Const LITERAL_AVG As Integer
Visual C++
public:
literal int LITERAL_AVG

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_BY Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_BY Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_BY
Visual Basic
Public Const LITERAL_BY As Integer
Visual C++
public:
literal int LITERAL_BY

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_CEIL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_CEIL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_CEIL
Visual Basic
Public Const LITERAL_CEIL As Integer
Visual C++
public:
literal int LITERAL_CEIL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_COALESCE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_COALESCE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COALESCE
Visual Basic
Public Const LITERAL_COALESCE As Integer
Visual C++
public:
literal int LITERAL_COALESCE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_COS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_COS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COS
Visual Basic
Public Const LITERAL_COS As Integer
Visual C++
public:
literal int LITERAL_COS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_COUNT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNT
Visual Basic
Public Const LITERAL_COUNT As Integer
Visual C++
public:
literal int LITERAL_COUNT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_COUNTDISTINCT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_COUNTDISTINCT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_COUNTDISTINCT
Visual Basic
Public Const LITERAL_COUNTDISTINCT As Integer
Visual C++
public:
literal int LITERAL_COUNTDISTINCT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DATE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DATE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DATE
Visual Basic
Public Const LITERAL_DATE As Integer
Visual C++
public:
literal int LITERAL_DATE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_MONTH Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DAY_OF_MONTH Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_MONTH
Visual Basic
Public Const LITERAL_DAY_OF_MONTH As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_MONTH

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_WEEK Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DAY_OF_WEEK Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_WEEK
Visual Basic
Public Const LITERAL_DAY_OF_WEEK As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_WEEK

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DAY_OF_YEAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DAY_OF_YEAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DAY_OF_YEAR
Visual Basic
Public Const LITERAL_DAY_OF_YEAR As Integer
Visual C++
public:
literal int LITERAL_DAY_OF_YEAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DEFINE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DEFINE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DEFINE
Visual Basic
Public Const LITERAL_DEFINE As Integer
Visual C++
public:
literal int LITERAL_DEFINE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DESC Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DESC Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DESC
Visual Basic
Public Const LITERAL_DESC As Integer
Visual C++
public:
literal int LITERAL_DESC

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_DVAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_DVAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_DVAL
Visual Basic
Public Const LITERAL_DVAL As Integer
Visual C++
public:
literal int LITERAL_DVAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXP Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_EXP Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXP
Visual Basic
Public Const LITERAL_EXP As Integer
Visual C++
public:
literal int LITERAL_EXP

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_EXTRACT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_EXTRACT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_EXTRACT
Visual Basic
Public Const LITERAL_EXTRACT As Integer
Visual C++
public:
literal int LITERAL_EXTRACT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_FLOOR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_FLOOR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FLOOR
Visual Basic
Public Const LITERAL_FLOOR As Integer
Visual C++
public:
literal int LITERAL_FLOOR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_FROM Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_FROM Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_FROM
Visual Basic
Public Const LITERAL_FROM As Integer
Visual C++
public:
literal int LITERAL_FROM

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_GROUP Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_GROUP Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_GROUP
Visual Basic
Public Const LITERAL_GROUP As Integer
Visual C++
public:
literal int LITERAL_GROUP

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_HAVING Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_HAVING Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HAVING
Visual Basic
Public Const LITERAL_HAVING As Integer
Visual C++
public:
literal int LITERAL_HAVING

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_HOUR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_HOUR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_HOUR
Visual Basic
Public Const LITERAL_HOUR As Integer
Visual C++
public:
literal int LITERAL_HOUR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_IN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_IN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IN
Visual Basic
Public Const LITERAL_IN As Integer
Visual C++
public:
literal int LITERAL_IN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_IS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_IS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_IS
Visual Basic
Public Const LITERAL_IS As Integer
Visual C++
public:
literal int LITERAL_IS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_LAG Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_LAG Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LAG
Visual Basic
Public Const LITERAL_LAG As Integer
Visual C++
public:
literal int LITERAL_LAG

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_LEAD Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_LEAD Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LEAD
Visual Basic
Public Const LITERAL_LEAD As Integer
Visual C++
public:
literal int LITERAL_LEAD

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_LN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_LN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LN
Visual Basic
Public Const LITERAL_LN As Integer
Visual C++
public:
literal int LITERAL_LN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_LOG Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_LOG Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_LOG
Visual Basic
Public Const LITERAL_LOG As Integer
Visual C++
public:
literal int LITERAL_LOG

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MAX Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MAX Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MAX
Visual Basic
Public Const LITERAL_MAX As Integer
Visual C++
public:
literal int LITERAL_MAX

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MEDIAN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MEDIAN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MEDIAN
Visual Basic
Public Const LITERAL_MEDIAN As Integer
Visual C++
public:
literal int LITERAL_MEDIAN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MIN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MIN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MIN
Visual Basic
Public Const LITERAL_MIN As Integer
Visual C++
public:
literal int LITERAL_MIN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MINUTE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MINUTE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MINUTE
Visual Basic
Public Const LITERAL_MINUTE As Integer
Visual C++
public:
literal int LITERAL_MINUTE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MOD Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MOD Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MOD
Visual Basic
Public Const LITERAL_MOD As Integer
Visual C++
public:
literal int LITERAL_MOD

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_MONTH Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_MONTH Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_MONTH
Visual Basic
Public Const LITERAL_MONTH As Integer
Visual C++
public:
literal int LITERAL_MONTH

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_NOT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_NOT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NOT
Visual Basic
Public Const LITERAL_NOT As Integer
Visual C++
public:
literal int LITERAL_NOT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_NULL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_NULL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_NULL
Visual Basic
Public Const LITERAL_NULL As Integer
Visual C++
public:
literal int LITERAL_NULL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_OR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_OR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_OR
Visual Basic
Public Const LITERAL_OR As Integer
Visual C++
public:
literal int LITERAL_OR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_ORDER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_ORDER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ORDER
Visual Basic
Public Const LITERAL_ORDER As Integer
Visual C++
public:
literal int LITERAL_ORDER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_PAGE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_PAGE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_PAGE
Visual Basic
Public Const LITERAL_PAGE As Integer
Visual C++
public:
literal int LITERAL_PAGE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_POWER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_POWER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_POWER
Visual Basic
Public Const LITERAL_POWER As Integer
Visual C++
public:
literal int LITERAL_POWER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_QUARTER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_QUARTER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_QUARTER
Visual Basic
Public Const LITERAL_QUARTER As Integer
Visual C++
public:
literal int LITERAL_QUARTER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_RETURN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_RETURN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_RETURN
Visual Basic
Public Const LITERAL_RETURN As Integer
Visual C++
public:
literal int LITERAL_RETURN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_ROUND Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_ROUND Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_ROUND
Visual Basic
Public Const LITERAL_ROUND As Integer
Visual C++
public:
literal int LITERAL_ROUND

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SECOND Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SECOND Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SECOND
Visual Basic
Public Const LITERAL_SECOND As Integer
Visual C++
public:
literal int LITERAL_SECOND

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SELECT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SELECT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SELECT
Visual Basic
Public Const LITERAL_SELECT As Integer
Visual C++
public:
literal int LITERAL_SELECT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIGN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SIGN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIGN
Visual Basic
Public Const LITERAL_SIGN As Integer
Visual C++
public:
literal int LITERAL_SIGN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SIN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SIN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SIN
Visual Basic
Public Const LITERAL_SIN As Integer
Visual C++
public:
literal int LITERAL_SIN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SQRT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SQRT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SQRT
Visual Basic
Public Const LITERAL_SQRT As Integer
Visual C++
public:
literal int LITERAL_SQRT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_STDDEV Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_STDDEV Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_STDDEV
Visual Basic
Public Const LITERAL_STDDEV As Integer
Visual C++
public:
literal int LITERAL_STDDEV

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_SUM Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_SUM Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_SUM
Visual Basic
Public Const LITERAL_SUM As Integer
Visual C++
public:
literal int LITERAL_SUM

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_TAN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_TAN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TAN
Visual Basic
Public Const LITERAL_TAN As Integer
Visual C++
public:
literal int LITERAL_TAN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_TO_DURATION Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_TO_DURATION Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TO_DURATION
Visual Basic
Public Const LITERAL_TO_DURATION As Integer
Visual C++
public:
literal int LITERAL_TO_DURATION

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_TRUNC Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_TRUNC Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_TRUNC
Visual Basic
Public Const LITERAL_TRUNC As Integer
Visual C++
public:
literal int LITERAL_TRUNC

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_VARIANCE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_VARIANCE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_VARIANCE
Visual Basic
Public Const LITERAL_VARIANCE As Integer
Visual C++
public:
literal int LITERAL_VARIANCE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_WEEK Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_WEEK Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WEEK
Visual Basic
Public Const LITERAL_WEEK As Integer
Visual C++
public:
literal int LITERAL_WEEK

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_WHERE Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_WHERE Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_WHERE
Visual Basic
Public Const LITERAL_WHERE As Integer
Visual C++
public:
literal int LITERAL_WHERE

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


LITERAL_YEAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..LITERAL_YEAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int LITERAL_YEAR
Visual Basic
Public Const LITERAL_YEAR As Integer
Visual C++
public:
literal int LITERAL_YEAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


MINUS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..MINUS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MINUS
Visual Basic
Public Const MINUS As Integer
Visual C++
public:
literal int MINUS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


MULT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..MULT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MULT
Visual Basic
Public Const MULT As Integer
Visual C++
public:
literal int MULT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


NOT_EQUAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..NOT_EQUAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NOT_EQUAL
Visual Basic
Public Const NOT_EQUAL As Integer
Visual C++
public:
literal int NOT_EQUAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


NULL_TREE_LOOKAHEAD Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..NULL_TREE_LOOKAHEAD Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int NULL_TREE_LOOKAHEAD
Visual Basic
Public Const NULL_TREE_LOOKAHEAD As Integer
Visual C++
public:
literal int NULL_TREE_LOOKAHEAD

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


OPEN_BRACKET Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..OPEN_BRACKET Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_BRACKET
Visual Basic
Public Const OPEN_BRACKET As Integer
Visual C++
public:
literal int OPEN_BRACKET

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


OPEN_PAREN Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..OPEN_PAREN Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int OPEN_PAREN
Visual Basic
Public Const OPEN_PAREN As Integer
Visual C++
public:
literal int OPEN_PAREN

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


PLUS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..PLUS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int PLUS
Visual Basic
Public Const PLUS As Integer
Visual C++
public:
literal int PLUS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


POS_FLOAT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..POS_FLOAT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_FLOAT
Visual Basic
Public Const POS_FLOAT As Integer
Visual C++
public:
literal int POS_FLOAT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


POS_INT Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..POS_INT Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int POS_INT
Visual Basic
Public Const POS_INT As Integer
Visual C++
public:
literal int POS_INT

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..QUOTED_IDENTIFIER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER
Visual Basic
Public Const QUOTED_IDENTIFIER As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


QUOTED_IDENTIFIER_CHAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..QUOTED_IDENTIFIER_CHAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUOTED_IDENTIFIER_CHAR
Visual Basic
Public Const QUOTED_IDENTIFIER_CHAR As Integer
Visual C++
public:
literal int QUOTED_IDENTIFIER_CHAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


REGULAR_IDENTIFIER Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..REGULAR_IDENTIFIER Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int REGULAR_IDENTIFIER
Visual Basic
Public Const REGULAR_IDENTIFIER As Integer
Visual C++
public:
literal int REGULAR_IDENTIFIER

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


SEMI Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..SEMI Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int SEMI
Visual Basic
Public Const SEMI As Integer
Visual C++
public:
literal int SEMI

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..STRING_LITERAL Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL
Visual Basic
Public Const STRING_LITERAL As Integer
Visual C++
public:
literal int STRING_LITERAL

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_CHAR Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..STRING_LITERAL_CHAR Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_CHAR
Visual Basic
Public Const STRING_LITERAL_CHAR As Integer
Visual C++
public:
literal int STRING_LITERAL_CHAR

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


STRING_LITERAL_ESCAPE_SEQ Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..STRING_LITERAL_ESCAPE_SEQ Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int STRING_LITERAL_ESCAPE_SEQ
Visual Basic
Public Const STRING_LITERAL_ESCAPE_SEQ As Integer
Visual C++
public:
literal int STRING_LITERAL_ESCAPE_SEQ

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


WS Field

[image]

Endeca Presentation API
AnalyticsParserTokenTypes..::..WS Field
AnalyticsParserTokenTypes Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int WS
Visual Basic
Public Const WS As Integer
Visual C++
public:
literal int WS

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


AnalyticsParserTokenTypes Methods

[image] [image]

Endeca Presentation API
AnalyticsParserTokenTypes Methods
AnalyticsParserTokenTypes Class See Also Send Feedback

The AnalyticsParserTokenTypes type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticsParserTokenTypes Class
Endeca.Navigation.Analytics Namespace


AnalyticsQuery Class

[image]

Endeca Presentation API
AnalyticsQuery Class
Members See Also Send Feedback
An AnalyticsQuery is an ordered list of Statement objects.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class AnalyticsQuery : IObjectList,
    IQueryNode
Visual Basic
Public Class AnalyticsQuery _
    Implements IObjectList, IQueryNode
Visual C++
public ref class AnalyticsQuery : IObjectList,
    IQueryNode

Remarks

After creation, the AnalyticsQuery object is set in an ENEQuery object via the AnalyticsQuery setter property.

When the query is executed on the MDEX Engine, each Statement transforms an input set of records into a resulting stream of aggregated records. Each Statement operates on the record set produced by some previous Statement, or on the records in the Navigation State, or on all the records in the MDEX Engine. Note that each Statement in the AnalyticsQuery must have a unique name.

Users can construct an AnalyticsQuery with either the programmatic interface or a text-based syntax. Much of the text-based syntax is based on a subset of the SQL language. Use the parseQuery(String) parser method to create an AnalyticsQuery from the String representation of the query. For example, if str is a String that has been initialized to a valid query, then the statement:

CopyC#
AnalyticsQuery analytics = AnalyticsQuery.parseQuery(str);
creates an AnalyticsQuery when the str query is parsed.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..AnalyticsQuery

See Also

AnalyticsQuery Members
Endeca.Navigation.Analytics Namespace


AnalyticsQuery Members

[image] [image]

Endeca Presentation API
AnalyticsQuery Members
AnalyticsQuery Class Constructors Methods See Also Send Feedback

The AnalyticsQuery type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticsQuery | Constructs a new, empty AnalyticsQuery.

Methods

 | Name | Description
Public method | Add | Appends a Statement object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a Statement from the AnalyticsQuery.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | parseQuery | Parses a String form of a Statement query and returns an instance of an AnalyticsQuery if the query is well-formed.
Public method | Remove | Removes a Statement object from the AnalyticsQuery.
Public method | Size | Returns the number of Statement objects in this AnalyticsQuery.
Public method | ToString | Returns the string form of the syntax tree rooted at this AnalyticsQuery. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this AnalyticsQuery.
Public method | ValidateSyntax | Validates the syntax of this AnalyticsQuery.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


AnalyticsQuery Constructor

[image]

Endeca Presentation API
AnalyticsQuery Constructor
AnalyticsQuery Class See Also Send Feedback
Constructs a new, empty AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public AnalyticsQuery()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticsQuery()

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


AnalyticsQuery Methods

[image] [image]

Endeca Presentation API
AnalyticsQuery Methods
AnalyticsQuery Class See Also Send Feedback

The AnalyticsQuery type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a Statement object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a Statement from the AnalyticsQuery.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | parseQuery | Parses a String form of a Statement query and returns an instance of an AnalyticsQuery if the query is well-formed.
Public method | Remove | Removes a Statement object from the AnalyticsQuery.
Public method | Size | Returns the number of Statement objects in this AnalyticsQuery.
Public method | ToString | Returns the string form of the syntax tree rooted at this AnalyticsQuery. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this AnalyticsQuery.
Public method | ValidateSyntax | Validates the syntax of this AnalyticsQuery.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
AnalyticsQuery..::..Add Method
AnalyticsQuery Class See Also Send Feedback
Appends a Statement object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The Statement object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not a Statement object.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
AnalyticsQuery..::..Get Method
AnalyticsQuery Class See Also Send Feedback
Gets a Statement from the AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired Statement object.

Return Value

The Statement object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


parseQuery Method

[image]

Endeca Presentation API
AnalyticsQuery..::..parseQuery Method
AnalyticsQuery Class See Also Send Feedback
Parses a String form of a Statement query and returns an instance of an AnalyticsQuery if the query is well-formed.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static AnalyticsQuery parseQuery(
    string query
)
Visual Basic
Public Shared Function parseQuery ( _
    query As String _
) As AnalyticsQuery
Visual C++
public:
static AnalyticsQuery^ parseQuery(
    String^ query
)

Parameters

query
Type: System..::..String
A Statement query in a String text-based syntax.

Return Value

An AnalyticsQuery object

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the query is malformed or null or is malformed.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
AnalyticsQuery..::..Remove Method
AnalyticsQuery Class See Also Send Feedback
Removes a Statement object from the AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the Statement object to be removed.

Return Value

The removed Statement object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
AnalyticsQuery..::..Size Method
AnalyticsQuery Class See Also Send Feedback
Returns the number of Statement objects in this AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of Statement objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
AnalyticsQuery..::..ToString Method
AnalyticsQuery Class See Also Send Feedback
Returns the string form of the syntax tree rooted at this AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this AnalyticsQuery. Semicolons will delimit multiple Statement objects.

Implements

IQueryNode..::..ToString()()()()

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
AnalyticsQuery..::..ToWire Method
AnalyticsQuery Class See Also Send Feedback
Returns the wire form of this AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this AnalyticsQuery.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
AnalyticsQuery..::..ValidateSyntax Method
AnalyticsQuery Class See Also Send Feedback
Validates the syntax of this AnalyticsQuery.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

The AnalyticsQuery is valid if it contains at least one Statement, and all its Statement objects are themselves valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | if the AnalyticsQuery does not contain at least one Statement.

See Also

AnalyticsQuery Class
Endeca.Navigation.Analytics Namespace


CoalesceList Class

[image]

Endeca Presentation API
CoalesceList Class
Members See Also Send Feedback
CoalesceList instances represent a list of expressions used to return the the first non-null value in the list. These coalesce expressions are objects of type IExpr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class CoalesceList : IObjectList,
    IQueryNode
Visual Basic
Public Class CoalesceList _
    Implements IObjectList, IQueryNode
Visual C++
public ref class CoalesceList : IObjectList,
    IQueryNode

Remarks

Coalesce expressions provide the ability to evalute records for multiple values and return the first non-null value encountered, in the order specified. The CoalesceList saves the expressions in the form of a list, in the same order as specified in the query.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..CoalesceList

See Also

CoalesceList Members
Endeca.Navigation.Analytics Namespace


CoalesceList Members

[image] [image]

Endeca Presentation API
CoalesceList Members
CoalesceList Class Constructors Methods See Also Send Feedback

The CoalesceList type exposes the following members.

Constructors

 | Name | Description
Public method | CoalesceList | Constructs a new, empty CoalesceList.

Methods

 | Name | Description
Public method | Add | Appends a coalesce expression to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the coalesce expression (an IExpr object) from the CoalesceList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a coalesce expression (an IExpr object) from the CoalesceList.
Public method | Size | Returns the number of coalesce expressions in this CoalesceList.
Public method | ToString | Returns the string form of this CoalesceList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this CoalesceList.
Public method | ValidateSyntax | Validates the syntax of this CoalesceList.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


CoalesceList Constructor

[image]

Endeca Presentation API
CoalesceList Constructor
CoalesceList Class See Also Send Feedback
Constructs a new, empty CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public CoalesceList()
Visual Basic
Public Sub New
Visual C++
public:
CoalesceList()

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


CoalesceList Methods

[image] [image]

Endeca Presentation API
CoalesceList Methods
CoalesceList Class See Also Send Feedback

The CoalesceList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a coalesce expression to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the coalesce expression (an IExpr object) from the CoalesceList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a coalesce expression (an IExpr object) from the CoalesceList.
Public method | Size | Returns the number of coalesce expressions in this CoalesceList.
Public method | ToString | Returns the string form of this CoalesceList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this CoalesceList.
Public method | ValidateSyntax | Validates the syntax of this CoalesceList.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
CoalesceList..::..Add Method
CoalesceList Class See Also Send Feedback
Appends a coalesce expression to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The coalesce expression (an IExpr object) to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
CoalesceList..::..Get Method
CoalesceList Class See Also Send Feedback
Gets the coalesce expression (an IExpr object) from the CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired coalesce expression. The required index corresponds to the order in which the original query was entered.

Return Value

The IExpr object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
CoalesceList..::..Remove Method
CoalesceList Class See Also Send Feedback
Removes a coalesce expression (an IExpr object) from the CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the IExpr object to be removed.

Return Value

The removed IExpr object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
CoalesceList..::..Size Method
CoalesceList Class See Also Send Feedback
Returns the number of coalesce expressions in this CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of coalesce expressions (IExpr objects) in the collection.

Implements

IObjectList..::..Size()()()()

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
CoalesceList..::..ToString Method
CoalesceList Class See Also Send Feedback
Returns the string form of this CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this CoalesceList.

Implements

IQueryNode..::..ToString()()()()

Remarks

The CoalesceList format is:
CopyC#
<i>expression1</i>, <i>expression2</i>...
 where expression is the string form of the expression.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
CoalesceList..::..ToWire Method
CoalesceList Class See Also Send Feedback
Returns the wire form of this CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this CoalesceList.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
CoalesceList..::..ValidateSyntax Method
CoalesceList Class See Also Send Feedback
Validates the syntax of this CoalesceList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A CoalesceList is valid if all of its expressions are themselves valid. Note that a CoalesceList with no elements is syntactically valid.

See Also

CoalesceList Class
Endeca.Navigation.Analytics Namespace


ExprAggregate Class

[image]

Endeca Presentation API
ExprAggregate Class
Members See Also Send Feedback
Instances of the ExprAggregate class represent aggregate functions over the members of the associated aggregated record.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprAggregate : IExpr,
    IQueryNode
Visual Basic
Public Class ExprAggregate _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprAggregate : IExpr,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprAggregate

See Also

ExprAggregate Members
Endeca.Navigation.Analytics Namespace


ExprAggregate Members

[image] [image]

Endeca Presentation API
ExprAggregate Members
ExprAggregate Class Constructors Methods Fields Properties See Also Send Feedback

The ExprAggregate type exposes the following members.

Constructors

 | Name | Description
Public method | ExprAggregate | Creates a new ExprAggregate, which will compute an aggregate function over the evaluation of the subexpression expr on the members of the aggregated record.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprAggregate. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprAggregate.
Public method | ValidateSyntax | Validates the syntax of this ExprAggregate.

Fields

Name | Description
ARB | Arbitrary function.
AVG | Average function.
COUNT | Count function.
COUNTDISTINCT | Count Distinct function.
MAX | Maximum function.
MEDIAN | Median function.
MIN | Minimum function.
STDDEV | Standard Deviation function.
SUM | Sum function.
VARIANCE | Variance function.

Properties

 | Name | Description
Public property | Filter | Gets and sets the filter associated with this expression.
Public property | Function | Gets and sets the aggregate function for this ExprAggregate.
Public property | IExpr | Gets and sets the subexpression for this ExprAggregate. The aggregate function will be evaluated on this subexpression.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ExprAggregate Constructor

[image]

Endeca Presentation API
ExprAggregate Constructor
ExprAggregate Class See Also Send Feedback
Creates a new ExprAggregate, which will compute an aggregate function over the evaluation of the subexpression expr on the members of the aggregated record.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprAggregate(
    ExprAggregate..::..ExprAggregateOp function,
    IExpr expr
)
Visual Basic
Public Sub New ( _
    function As ExprAggregate..::..ExprAggregateOp, _
    expr As IExpr _
)
Visual C++
public:
ExprAggregate(
    ExprAggregate..::..ExprAggregateOp^ function,
    IExpr^ expr
)

Parameters

function
Type: Endeca.Navigation.Analytics..::..ExprAggregate..::..ExprAggregateOp
An aggregate function of type ExprAggregate..::..ExprAggregateOp. See the Function property for a list of the function names.
expr
Type: Endeca.Navigation.Analytics..::..IExpr
An object of type IExpr that will be the subexpression for this ExprAggregate.

Remarks

ExprAggregate nodes may not be nested. That is, neither the specified subexpression expr nor any of its descendant subexpressions may be instances of ExprAggregate; otherwise, the resulting expression is semantically invalid (note that this will not be caught by the ValidateSyntax()()()() method).

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ExprAggregate Fields

[image] [image]

Endeca Presentation API
ExprAggregate Fields
ExprAggregate Class See Also Send Feedback

The ExprAggregate type exposes the following members.

Fields

Name | Description
ARB | Arbitrary function.
AVG | Average function.
COUNT | Count function.
COUNTDISTINCT | Count Distinct function.
MAX | Maximum function.
MEDIAN | Median function.
MIN | Minimum function.
STDDEV | Standard Deviation function.
SUM | Sum function.
VARIANCE | Variance function.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ARB Field

[image]

Endeca Presentation API
ExprAggregate..::..ARB Field
ExprAggregate Class See Also Send Feedback
Arbitrary function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp ARB
Visual Basic
Public Shared ReadOnly ARB As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ ARB

Remarks

Selects an arbitrary but consistent value from the set of values in a field.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


AVG Field

[image]

Endeca Presentation API
ExprAggregate..::..AVG Field
ExprAggregate Class See Also Send Feedback
Average function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp AVG
Visual Basic
Public Shared ReadOnly AVG As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ AVG

Remarks

Computes the average (arithmetic mean) of all input values.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


COUNT Field

[image]

Endeca Presentation API
ExprAggregate..::..COUNT Field
ExprAggregate Class See Also Send Feedback
Count function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp COUNT
Visual Basic
Public Shared ReadOnly COUNT As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ COUNT

Remarks

Counts the values in a field.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


COUNTDISTINCT Field

[image]

Endeca Presentation API
ExprAggregate..::..COUNTDISTINCT Field
ExprAggregate Class See Also Send Feedback
Count Distinct function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp COUNTDISTINCT
Visual Basic
Public Shared ReadOnly COUNTDISTINCT As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ COUNTDISTINCT

Remarks

Counts the distinct values in a field, with no repetition.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


MAX Field

[image]

Endeca Presentation API
ExprAggregate..::..MAX Field
ExprAggregate Class See Also Send Feedback
Maximum function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp MAX
Visual Basic
Public Shared ReadOnly MAX As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ MAX

Remarks

Computes the maximum value of the subexpression across all input values.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


MEDIAN Field

[image]

Endeca Presentation API
ExprAggregate..::..MEDIAN Field
ExprAggregate Class See Also Send Feedback
Median function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp MEDIAN
Visual Basic
Public Shared ReadOnly MEDIAN As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ MEDIAN

Remarks

Finds the median value for a field.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


MIN Field

[image]

Endeca Presentation API
ExprAggregate..::..MIN Field
ExprAggregate Class See Also Send Feedback
Minimum function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp MIN
Visual Basic
Public Shared ReadOnly MIN As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ MIN

Remarks

Computes the minimum value of the subexpression across all input values.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


STDDEV Field

[image]

Endeca Presentation API
ExprAggregate..::..STDDEV Field
ExprAggregate Class See Also Send Feedback
Standard Deviation function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp STDDEV
Visual Basic
Public Shared ReadOnly STDDEV As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ STDDEV

Remarks

Computes the standard deviation for a field.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


SUM Field

[image]

Endeca Presentation API
ExprAggregate..::..SUM Field
ExprAggregate Class See Also Send Feedback
Sum function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp SUM
Visual Basic
Public Shared ReadOnly SUM As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ SUM

Remarks

Computes the sum of the subexpression across all input values.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


VARIANCE Field

[image]

Endeca Presentation API
ExprAggregate..::..VARIANCE Field
ExprAggregate Class See Also Send Feedback
Variance function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprAggregate..::..ExprAggregateOp VARIANCE
Visual Basic
Public Shared ReadOnly VARIANCE As ExprAggregate..::..ExprAggregateOp
Visual C++
public:
static initonly ExprAggregate..::..ExprAggregateOp^ VARIANCE

Remarks

Computes the variance for a field. The variance is the square of the standard deviation.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ExprAggregate Methods

[image] [image]

Endeca Presentation API
ExprAggregate Methods
ExprAggregate Class See Also Send Feedback

The ExprAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprAggregate. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprAggregate.
Public method | ValidateSyntax | Validates the syntax of this ExprAggregate.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprAggregate..::..ToString Method
ExprAggregate Class See Also Send Feedback
Returns the string form of this ExprAggregate.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprAggregate.

Implements

IQueryNode..::..ToString()()()()

Remarks

The ExprAggregate format is:
CopyC#
FUNCTION(<i>subexpression</i>)
 where FUNCTION is an aggregate function name.

The format for an ExprAggregate with a filter is:

CopyC#
FUNCTION(<i>subexpression</i>) WHERE <i>filter</i>
where filter is the filter added by the Filter setting property.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprAggregate..::..ToWire Method
ExprAggregate Class See Also Send Feedback
Returns the wire form of this ExprAggregate.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this ExprAggregate.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprAggregate..::..ValidateSyntax Method
ExprAggregate Class See Also Send Feedback
Validates the syntax of this ExprAggregate.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprAggregate is valid if the function is not null and the subexpression is non-null and itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ExprAggregate Properties

[image] [image]

Endeca Presentation API
ExprAggregate Properties
ExprAggregate Class See Also Send Feedback

The ExprAggregate type exposes the following members.

Properties

 | Name | Description
Public property | Filter | Gets and sets the filter associated with this expression.
Public property | Function | Gets and sets the aggregate function for this ExprAggregate.
Public property | IExpr | Gets and sets the subexpression for this ExprAggregate. The aggregate function will be evaluated on this subexpression.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


Filter Property

[image]

Endeca Presentation API
ExprAggregate..::..Filter Property
ExprAggregate Class See Also Send Feedback
Gets and sets the filter associated with this expression.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IFilter Filter { get; set; }
Visual Basic
Public Overridable Property Filter As IFilter
    Get
    Set
Visual C++
public:
virtual property IFilter^ Filter {
    IFilter^ get ();
    void set (IFilter^ value);
}

Field Value

The filter (of type IFilter) associated with this expression.

Remarks

For the getter version, only records in the associated aggregate that satisfy the returned filter contribute to the derived value represented by this expression.

For the setter version, adding a filter to this expression causes only records that satisfy the filter to be taken into account by this aggregate.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


Function Property

[image]

Endeca Presentation API
ExprAggregate..::..Function Property
ExprAggregate Class See Also Send Feedback
Gets and sets the aggregate function for this ExprAggregate.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ExprAggregate..::..ExprAggregateOp Function { get; set; }
Visual Basic
Public Overridable Property Function As ExprAggregate..::..ExprAggregateOp
    Get
    Set
Visual C++
public:
virtual property ExprAggregate..::..ExprAggregateOp^ Function {
    ExprAggregate..::..ExprAggregateOp^ get ();
    void set (ExprAggregate..::..ExprAggregateOp^ value);
}

Field Value

An aggregate function of type ExprAggregate..::..ExprAggregateOp.

Remarks

The aggregate functions are: ExprAggregate.ARB, ExprAggregate.AVG, ExprAggregate.COUNT, ExprAggregate.COUNTDISTINCT, ExprFunction.EXTRACT, ExprAggregate.MAX, ExprAggregate.MEDIAN, ExprAggregate.MIN, ExprAggregate.STDDEV, ExprAggregate.ROUND, ExprFunction.SIGN, ExprFunction.SUM, and ExprAggregate.VARIANCE.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


IExpr Property

[image]

Endeca Presentation API
ExprAggregate..::..IExpr Property
ExprAggregate Class See Also Send Feedback
Gets and sets the subexpression for this ExprAggregate. The aggregate function will be evaluated on this subexpression.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IExpr IExpr { get; set; }
Visual Basic
Public Overridable Property IExpr As IExpr
    Get
    Set
Visual C++
public:
virtual property IExpr^ IExpr {
    IExpr^ get ();
    void set (IExpr^ value);
}

Field Value

An object of type IExpr that is the subexpression for this ExprAggregate.

See Also

ExprAggregate Class
Endeca.Navigation.Analytics Namespace


ExprAggregate.ExprAggregateOp Class

[image]

Endeca Presentation API
ExprAggregate..::..ExprAggregateOp Class
ExprAggregate Class Members See Also Send Feedback
Enumeration of Endeca aggregate functions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprAggregateOp
Visual Basic
Public Class ExprAggregateOp
Visual C++
public ref class ExprAggregateOp

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprAggregate..::..ExprAggregateOp

See Also

ExprAggregate..::..ExprAggregateOp Members
Endeca.Navigation.Analytics Namespace


ExprAggregate.ExprAggregateOp Members

[image] [image]

Endeca Presentation API
ExprAggregate..::..ExprAggregateOp Members
ExprAggregate..::..ExprAggregateOp Class Methods See Also Send Feedback

Instances of the ExprAggregate class represent aggregate functions over the members of the associated aggregated record.

The ExprAggregate..::..ExprAggregateOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the aggregate function. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the aggregate function.

See Also

ExprAggregate..::..ExprAggregateOp Class
Endeca.Navigation.Analytics Namespace


ExprAggregate.ExprAggregateOp Methods

[image] [image]

Endeca Presentation API
ExprAggregate..::..ExprAggregateOp Methods
ExprAggregate..::..ExprAggregateOp Class See Also Send Feedback

The ExprAggregate..::..ExprAggregateOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the aggregate function. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the aggregate function.

See Also

ExprAggregate..::..ExprAggregateOp Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprAggregate..::..ExprAggregateOp..::..ToString Method
ExprAggregate..::..ExprAggregateOp Class See Also Send Feedback
Returns the string form of the aggregate function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of the aggregate function.

See Also

ExprAggregate..::..ExprAggregateOp Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprAggregate..::..ExprAggregateOp..::..ToWire Method
ExprAggregate..::..ExprAggregateOp Class See Also Send Feedback
Returns the wire form of the aggregate function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of the aggregate function.

See Also

ExprAggregate..::..ExprAggregateOp Class
Endeca.Navigation.Analytics Namespace


ExprBinary Class

[image]

Endeca Presentation API
ExprBinary Class
Members Example See Also Send Feedback
An ExprBinary is a type of IExpr that represents a binary scalar expression. These expressions provide a full range of mathematical functions, such as addition and subtraction operators.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprBinary : IExpr, IQueryNode
Visual Basic
Public Class ExprBinary _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprBinary : IExpr,
    IQueryNode

Examples

This code subtracts one from an integer property named Year:
CopyC#
LookupList lookup = new LookupList();
lookup.add(new ExprBinary(ExprBinary.MINUS, new ExprKey("Year"), new ExprConstant("1")));
 In the example, the ExprBinary object is set in a LookupList object.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprBinary

See Also

ExprBinary Members
Endeca.Navigation.Analytics Namespace


ExprBinary Members

[image] [image]

Endeca Presentation API
ExprBinary Members
ExprBinary Class Constructors Methods Fields Properties See Also Send Feedback

The ExprBinary type exposes the following members.

Constructors

 | Name | Description
Public method | ExprBinary | The ExprBinary will compute the specified specified function on the specified lhs and rhs parameters.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprBinary. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprBinary.
Public method | ValidateSyntax | Validates the syntax of this ExprBinary.

Fields

Name | Description
DIVIDE | Division operator.
LOG | Logarithm operator.
MINUS | Subtraction operator.
MOD | Modulo (remainder) operator.
MULTIPLY | Multiplication operator.
PLUS | Addition operator.
POWER | Exponentiation operator.
ROUND | Round operator.
TRUNC | Truncation operator.

Properties

 | Name | Description
Public property | Function | Gets and sets the the mathematical function for this ExprBinary.
Public property | Lhs | Gets and sets the left-hand side of this binary expression.
Public property | Rhs | Gets and sets the right-hand side of this binary expression.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ExprBinary Constructor

[image]

Endeca Presentation API
ExprBinary Constructor
ExprBinary Class See Also Send Feedback
The ExprBinary will compute the specified specified function on the specified lhs and rhs parameters.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprBinary(
    ExprBinary..::..ExprBinaryOp function,
    IExpr lhs,
    IExpr rhs
)
Visual Basic
Public Sub New ( _
    function As ExprBinary..::..ExprBinaryOp, _
    lhs As IExpr, _
    rhs As IExpr _
)
Visual C++
public:
ExprBinary(
    ExprBinary..::..ExprBinaryOp^ function,
    IExpr^ lhs,
    IExpr^ rhs
)

Parameters

function
Type: Endeca.Navigation.Analytics..::..ExprBinary..::..ExprBinaryOp
A mathematical function (of type ExprBinary..::..ExprBinaryOp) that specifies the type of operation to be made. See the Function property for a list of the function names.
lhs
Type: Endeca.Navigation.Analytics..::..IExpr
An object of type IExpr that will be the left-hand side of this binary expression.
rhs
Type: Endeca.Navigation.Analytics..::..IExpr
An object of type IExpr that will be the right-hand side of this binary expression.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ExprBinary Fields

[image] [image]

Endeca Presentation API
ExprBinary Fields
ExprBinary Class See Also Send Feedback

The ExprBinary type exposes the following members.

Fields

Name | Description
DIVIDE | Division operator.
LOG | Logarithm operator.
MINUS | Subtraction operator.
MOD | Modulo (remainder) operator.
MULTIPLY | Multiplication operator.
PLUS | Addition operator.
POWER | Exponentiation operator.
ROUND | Round operator.
TRUNC | Truncation operator.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


DIVIDE Field

[image]

Endeca Presentation API
ExprBinary..::..DIVIDE Field
ExprBinary Class See Also Send Feedback
Division operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp DIVIDE
Visual Basic
Public Shared ReadOnly DIVIDE As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ DIVIDE

Remarks

Divides the left-hand side of the expression by the value in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


LOG Field

[image]

Endeca Presentation API
ExprBinary..::..LOG Field
ExprBinary Class See Also Send Feedback
Logarithm operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp LOG
Visual Basic
Public Shared ReadOnly LOG As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ LOG

Remarks

Returns the logarithm of the right-hand side, where the value in the left-hand side is the base.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


MINUS Field

[image]

Endeca Presentation API
ExprBinary..::..MINUS Field
ExprBinary Class See Also Send Feedback
Subtraction operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp MINUS
Visual Basic
Public Shared ReadOnly MINUS As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ MINUS

Remarks

Subtracts the right-hand side of the expression from the left-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


MOD Field

[image]

Endeca Presentation API
ExprBinary..::..MOD Field
ExprBinary Class See Also Send Feedback
Modulo (remainder) operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp MOD
Visual Basic
Public Shared ReadOnly MOD As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ MOD

Remarks

Returns the remainder of the division of the left-hand side by the value in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


MULTIPLY Field

[image]

Endeca Presentation API
ExprBinary..::..MULTIPLY Field
ExprBinary Class See Also Send Feedback
Multiplication operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp MULTIPLY
Visual Basic
Public Shared ReadOnly MULTIPLY As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ MULTIPLY

Remarks

Multiplies the left-hand side of the expression by the value in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


PLUS Field

[image]

Endeca Presentation API
ExprBinary..::..PLUS Field
ExprBinary Class See Also Send Feedback
Addition operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp PLUS
Visual Basic
Public Shared ReadOnly PLUS As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ PLUS

Remarks

Adds the right-hand and left-hand sides of the expression.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


POWER Field

[image]

Endeca Presentation API
ExprBinary..::..POWER Field
ExprBinary Class See Also Send Feedback
Exponentiation operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp POWER
Visual Basic
Public Shared ReadOnly POWER As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ POWER

Remarks

Returns the value of the left-hand side raised to the power of the value in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ROUND Field

[image]

Endeca Presentation API
ExprBinary..::..ROUND Field
ExprBinary Class See Also Send Feedback
Round operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp ROUND
Visual Basic
Public Shared ReadOnly ROUND As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ ROUND

Remarks

Rounds the number in the left-hand side to the number of decimal places specified by the integer in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


TRUNC Field

[image]

Endeca Presentation API
ExprBinary..::..TRUNC Field
ExprBinary Class See Also Send Feedback
Truncation operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprBinary..::..ExprBinaryOp TRUNC
Visual Basic
Public Shared ReadOnly TRUNC As ExprBinary..::..ExprBinaryOp
Visual C++
public:
static initonly ExprBinary..::..ExprBinaryOp^ TRUNC

Remarks

Truncates the number in the left-hand side to the number of decimal places specified by the integer in the right-hand side.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ExprBinary Methods

[image] [image]

Endeca Presentation API
ExprBinary Methods
ExprBinary Class See Also Send Feedback

The ExprBinary type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprBinary. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprBinary.
Public method | ValidateSyntax | Validates the syntax of this ExprBinary.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprBinary..::..ToString Method
ExprBinary Class See Also Send Feedback
Returns the string form of this ExprBinary.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprBinary.

Implements

IQueryNode..::..ToString()()()()

Remarks

The format for the DIVIDE, MINUS, MULTIPLY, and PLUS operators is:
CopyC#
"<i>lhs-expression</i><i>sign</i><i>rhs-expression</i>"
 where sign is / (for DIVIDE), - (for MINUS), * (for MULTIPY), or + (for PLUS).

The format for the other operators is:

CopyC#
"<i>op</i>(<i>lhs-expression</i>, <i>rhs-expression</i>)"
where op is LOG, MOD, POWER, BROUND, or BTRUNC.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprBinary..::..ToWire Method
ExprBinary Class See Also Send Feedback
Returns the wire form of this ExprBinary.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprBinary.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprBinary..::..ValidateSyntax Method
ExprBinary Class See Also Send Feedback
Validates the syntax of this ExprBinary.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprBinary is valid if both the right-hand side and left-hand side subexpressions are non-null and valid, and the function is not null.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ExprBinary Properties

[image] [image]

Endeca Presentation API
ExprBinary Properties
ExprBinary Class See Also Send Feedback

The ExprBinary type exposes the following members.

Properties

 | Name | Description
Public property | Function | Gets and sets the the mathematical function for this ExprBinary.
Public property | Lhs | Gets and sets the left-hand side of this binary expression.
Public property | Rhs | Gets and sets the right-hand side of this binary expression.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


Function Property

[image]

Endeca Presentation API
ExprBinary..::..Function Property
ExprBinary Class See Also Send Feedback
Gets and sets the the mathematical function for this ExprBinary.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ExprBinary..::..ExprBinaryOp Function { get; set; }
Visual Basic
Public Overridable Property Function As ExprBinary..::..ExprBinaryOp
    Get
    Set
Visual C++
public:
virtual property ExprBinary..::..ExprBinaryOp^ Function {
    ExprBinary..::..ExprBinaryOp^ get ();
    void set (ExprBinary..::..ExprBinaryOp^ value);
}

Field Value

An object of type ExprBinary..::..ExprBinaryOp that is the function for this ExprBinary.

Remarks

The mathematical functions are: ExprBinary.DIVIDE, ExprBinary.LOG, ExprBinary.MINUS, ExprBinary.MOD, ExprBinary.MULTIPLY, ExprBinary.PLUS, ExprBinary.POWER, ExprBinary.ROUND, and ExprBinary.TRUNC.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


Lhs Property

[image]

Endeca Presentation API
ExprBinary..::..Lhs Property
ExprBinary Class See Also Send Feedback
Gets and sets the left-hand side of this binary expression.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IExpr Lhs { get; set; }
Visual Basic
Public Overridable Property Lhs As IExpr
    Get
    Set
Visual C++
public:
virtual property IExpr^ Lhs {
    IExpr^ get ();
    void set (IExpr^ value);
}

Field Value

An object of type IExpr that is the left-hand side for this ExprBinary.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


Rhs Property

[image]

Endeca Presentation API
ExprBinary..::..Rhs Property
ExprBinary Class See Also Send Feedback
Gets and sets the right-hand side of this binary expression.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IExpr Rhs { get; set; }
Visual Basic
Public Overridable Property Rhs As IExpr
    Get
    Set
Visual C++
public:
virtual property IExpr^ Rhs {
    IExpr^ get ();
    void set (IExpr^ value);
}

Field Value

An object of type IExpr that is the right-hand side for this ExprBinary.

See Also

ExprBinary Class
Endeca.Navigation.Analytics Namespace


ExprBinary.ExprBinaryOp Class

[image]

Endeca Presentation API
ExprBinary..::..ExprBinaryOp Class
ExprBinary Class Members See Also Send Feedback
Enumeration of Endeca mathematical operators.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprBinaryOp
Visual Basic
Public Class ExprBinaryOp
Visual C++
public ref class ExprBinaryOp

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprBinary..::..ExprBinaryOp

See Also

ExprBinary..::..ExprBinaryOp Members
Endeca.Navigation.Analytics Namespace


ExprBinary.ExprBinaryOp Members

[image] [image]

Endeca Presentation API
ExprBinary..::..ExprBinaryOp Members
ExprBinary..::..ExprBinaryOp Class Methods See Also Send Feedback

An ExprBinary is a type of IExpr that represents a binary scalar expression. These expressions provide a full range of mathematical functions, such as addition and subtraction operators.

The ExprBinary..::..ExprBinaryOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the mathematical operator. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the mathematical operator.

See Also

ExprBinary..::..ExprBinaryOp Class
Endeca.Navigation.Analytics Namespace


ExprBinary.ExprBinaryOp Methods

[image] [image]

Endeca Presentation API
ExprBinary..::..ExprBinaryOp Methods
ExprBinary..::..ExprBinaryOp Class See Also Send Feedback

The ExprBinary..::..ExprBinaryOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the mathematical operator. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the mathematical operator.

See Also

ExprBinary..::..ExprBinaryOp Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprBinary..::..ExprBinaryOp..::..ToString Method
ExprBinary..::..ExprBinaryOp Class See Also Send Feedback
Returns the string form of the mathematical operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of the mathematical operator.

See Also

ExprBinary..::..ExprBinaryOp Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprBinary..::..ExprBinaryOp..::..ToWire Method
ExprBinary..::..ExprBinaryOp Class See Also Send Feedback
Returns the wire form of the mathematical operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of the mathematical operator.

See Also

ExprBinary..::..ExprBinaryOp Class
Endeca.Navigation.Analytics Namespace


ExprCoalesce Class

[image]

Endeca Presentation API
ExprCoalesce Class
Members See Also Send Feedback
ExprCoalesce instances represent a coalesce expression holding multiple keys. The keys can be evaluated over the associated records, and the first non-null value is computed for each record.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprCoalesce : IExpr,
    IQueryNode
Visual Basic
Public Class ExprCoalesce _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprCoalesce : IExpr,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprCoalesce

See Also

ExprCoalesce Members
Endeca.Navigation.Analytics Namespace


ExprCoalesce Members

[image] [image]

Endeca Presentation API
ExprCoalesce Members
ExprCoalesce Class Constructors Methods Properties See Also Send Feedback

The ExprCoalesce type exposes the following members.

Constructors

 | Name | Description
Public method | ExprCoalesce | Constructs a new ExprCoalesce.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprCoalesce. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprCoalesce.
Public method | ValidateSyntax | Validates the syntax of this ExprCoalesce.

Properties

 | Name | Description
Public property | CoalesceList | Gets and sets the CoalesceList for this ExprCoalesce.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ExprCoalesce Constructor

[image]

Endeca Presentation API
ExprCoalesce Constructor
ExprCoalesce Class See Also Send Feedback
Constructs a new ExprCoalesce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprCoalesce(
    CoalesceList cList
)
Visual Basic
Public Sub New ( _
    cList As CoalesceList _
)
Visual C++
public:
ExprCoalesce(
    CoalesceList^ cList
)

Parameters

cList
Type: Endeca.Navigation.Analytics..::..CoalesceList
A CoalesceList object that has been populated with expressions (IExpr objects). The CoalesceList represents a list of expressions to be evaluted on each record to find the first non-null expression for the record. The list must hold expressions in the same order as entered in the query.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ExprCoalesce Methods

[image] [image]

Endeca Presentation API
ExprCoalesce Methods
ExprCoalesce Class See Also Send Feedback

The ExprCoalesce type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprCoalesce. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprCoalesce.
Public method | ValidateSyntax | Validates the syntax of this ExprCoalesce.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprCoalesce..::..ToString Method
ExprCoalesce Class See Also Send Feedback
Returns the string form of this ExprCoalesce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprCoalesce.

Implements

IQueryNode..::..ToString()()()()

Remarks

The ExprCoalesce format is:
CopyC#
COALESCE(<i>expression1</i>, <i>expression2</i>...)
 where each expression is a coalesce expression in the CoalesceList.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprCoalesce..::..ToWire Method
ExprCoalesce Class See Also Send Feedback
Returns the wire form of this ExprCoalesce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprCoalesce.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprCoalesce..::..ValidateSyntax Method
ExprCoalesce Class See Also Send Feedback
Validates the syntax of this ExprCoalesce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprCoalesce is valid if the CoalesceList is not null and is valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ExprCoalesce Properties

[image] [image]

Endeca Presentation API
ExprCoalesce Properties
ExprCoalesce Class See Also Send Feedback

The ExprCoalesce type exposes the following members.

Properties

 | Name | Description
Public property | CoalesceList | Gets and sets the CoalesceList for this ExprCoalesce.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


CoalesceList Property

[image]

Endeca Presentation API
ExprCoalesce..::..CoalesceList Property
ExprCoalesce Class See Also Send Feedback
Gets and sets the CoalesceList for this ExprCoalesce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual CoalesceList CoalesceList { get; set; }
Visual Basic
Public Overridable Property CoalesceList As CoalesceList
    Get
    Set
Visual C++
public:
virtual property CoalesceList^ CoalesceList {
    CoalesceList^ get ();
    void set (CoalesceList^ value);
}

Field Value

A CoalesceList object that has been populated with expressions (IExpr objects). The CoalesceList represents a list of expressions that can be evaluated for each record to return the first non-null value for that record.

See Also

ExprCoalesce Class
Endeca.Navigation.Analytics Namespace


ExprConstant Class

[image]

Endeca Presentation API
ExprConstant Class
Members See Also Send Feedback
Instances of ExprConstant represent constants.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprConstant : IExpr,
    IQueryNode
Visual Basic
Public Class ExprConstant _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprConstant : IExpr,
    IQueryNode

Remarks

Constants are used in expressions, such as the "2" in "x + 2". Both string and numeric constants are treated identically.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprConstant

See Also

ExprConstant Members
Endeca.Navigation.Analytics Namespace


ExprConstant Members

[image] [image]

Endeca Presentation API
ExprConstant Members
ExprConstant Class Constructors Methods Properties See Also Send Feedback

The ExprConstant type exposes the following members.

Constructors

 | Name | Description
Public method | ExprConstant | Creates a new ExprConstant expression node representing the specified constant val.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprConstant. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprConstant.
Public method | ValidateSyntax | Validates the syntax of this ExprConstant.

Properties

 | Name | Description
Public property | Value | Gets and sets the constant value for this ExprConstant.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ExprConstant Constructor

[image]

Endeca Presentation API
ExprConstant Constructor
ExprConstant Class See Also Send Feedback
Creates a new ExprConstant expression node representing the specified constant val.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprConstant(
    string val
)
Visual Basic
Public Sub New ( _
    val As String _
)
Visual C++
public:
ExprConstant(
    String^ val
)

Parameters

val
Type: System..::..String
The constant to be used in an expression.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ExprConstant Methods

[image] [image]

Endeca Presentation API
ExprConstant Methods
ExprConstant Class See Also Send Feedback

The ExprConstant type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprConstant. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprConstant.
Public method | ValidateSyntax | Validates the syntax of this ExprConstant.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprConstant..::..ToString Method
ExprConstant Class See Also Send Feedback
Returns the string form of this ExprConstant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprConstant.

Implements

IQueryNode..::..ToString()()()()

Remarks

ExprConstant uses a format that is illustrated by these three examples:
CopyC#
'john'
'3'
'56.903'

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprConstant..::..ToWire Method
ExprConstant Class See Also Send Feedback
Returns the wire form of this ExprConstant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprConstant.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprConstant..::..ValidateSyntax Method
ExprConstant Class See Also Send Feedback
Validates the syntax of this ExprConstant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprConstant is valid if the String representing the value is non-null and non-empty. Note that the String should represent a numeric value, but this is not enforced during validation.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ExprConstant Properties

[image] [image]

Endeca Presentation API
ExprConstant Properties
ExprConstant Class See Also Send Feedback

The ExprConstant type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets and sets the constant value for this ExprConstant.

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


Value Property

[image]

Endeca Presentation API
ExprConstant..::..Value Property
ExprConstant Class See Also Send Feedback
Gets and sets the constant value for this ExprConstant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Value { get; set; }
Visual Basic
Public Overridable Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The constant to be used in an expression

See Also

ExprConstant Class
Endeca.Navigation.Analytics Namespace


ExprFunction Class

[image]

Endeca Presentation API
ExprFunction Class
Members See Also Send Feedback
ExprFunction instances represent unary scalar function expressions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprFunction : IExpr,
    IQueryNode
Visual Basic
Public Class ExprFunction _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprFunction : IExpr,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprFunction

See Also

ExprFunction Members
Endeca.Navigation.Analytics Namespace


ExprFunction Members

[image] [image]

Endeca Presentation API
ExprFunction Members
ExprFunction Class Constructors Methods Fields Properties See Also Send Feedback

The ExprFunction type exposes the following members.

Constructors

 | Name | Description
Public method | ExprFunction | Creates a new ExprFunction of the specified subexpression subExpr.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprFunction. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprFunction.
Public method | ValidateSyntax | Validates the syntax of this ExprFunction.

Fields

Name | Description
ABS | Absolute value function.
CEIL | Ceiling function.
COS | Cosine function.
DATE | Date constant.
DAY_OF_MONTH | Day-of-month constant.
DAY_OF_WEEK | Day-of-week constant.
DAY_OF_YEAR | Day-of-year constant.
EXP | Exponential function.
EXTRACT | Date Extraction function.
FLOOR | Floor function.
HOUR | Hour constant.
LAG | Lag function.
LEAD | Lead function.
LN | Natural logarithm function.
MINUTE | Minute constant.
MONTH | Month constant.
QUARTER | Quarter year constant.
ROUND | Round function.
SECOND | Second constant.
SIGN | Sign function.
SIN | Sine function.
SQRT | Square root function.
TAN | Tangent function.
TO_DURATION | Duration function.
TRUNC | Date Truncation function.
WEEK | Week constant.
YEAR | Year constant.

Properties

 | Name | Description
Public property | Function | Gets and sets the function for this ExprFunction.
Public property | IExpr | Gets and sets the subexpression for this ExprFunction.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ExprFunction Constructor

[image]

Endeca Presentation API
ExprFunction Constructor
ExprFunction Class See Also Send Feedback
Creates a new ExprFunction of the specified subexpression subExpr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprFunction(
    ExprFunction..::..ExprFunctionOp func,
    IExpr subExpr,
    int decPlaces
)
Visual Basic
Public Sub New ( _
    func As ExprFunction..::..ExprFunctionOp, _
    subExpr As IExpr, _
    decPlaces As Integer _
)
Visual C++
public:
ExprFunction(
    ExprFunction..::..ExprFunctionOp^ func,
    IExpr^ subExpr,
    int decPlaces
)

Parameters

func
Type: Endeca.Navigation.Analytics..::..ExprFunction..::..ExprFunctionOp
A function of type ExprFunction..::..ExprFunctionOp that specifies the type of operation to be made.
subExpr
Type: Endeca.Navigation.Analytics..::..IExpr
An object of type IExpr that will be the subexpression for this ExprFunction.

If func is LAG or LEAD, then subExpr must be an ExprKey.

decPlaces
Type: System..::..Int32
An integer to be used only with the EXTRACT, LAG, LEAD, ROUND, and TRUNC functions.

For ROUND and TRUNC, positive numbers round to the equivalent number of decimal places; negative numbers round to the equivalent place to the left of the decimal place.

For TRUNC (when subExpr is a date/time) and EXTRACT, decPlaces is a constant such as HOUR or YEAR.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ExprFunction Fields

[image] [image]

Endeca Presentation API
ExprFunction Fields
ExprFunction Class See Also Send Feedback

The ExprFunction type exposes the following members.

Fields

Name | Description
ABS | Absolute value function.
CEIL | Ceiling function.
COS | Cosine function.
DATE | Date constant.
DAY_OF_MONTH | Day-of-month constant.
DAY_OF_WEEK | Day-of-week constant.
DAY_OF_YEAR | Day-of-year constant.
EXP | Exponential function.
EXTRACT | Date Extraction function.
FLOOR | Floor function.
HOUR | Hour constant.
LAG | Lag function.
LEAD | Lead function.
LN | Natural logarithm function.
MINUTE | Minute constant.
MONTH | Month constant.
QUARTER | Quarter year constant.
ROUND | Round function.
SECOND | Second constant.
SIGN | Sign function.
SIN | Sine function.
SQRT | Square root function.
TAN | Tangent function.
TO_DURATION | Duration function.
TRUNC | Date Truncation function.
WEEK | Week constant.
YEAR | Year constant.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ABS Field

[image]

Endeca Presentation API
ExprFunction..::..ABS Field
ExprFunction Class See Also Send Feedback
Absolute value function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp ABS
Visual Basic
Public Shared ReadOnly ABS As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ ABS

Remarks

Returns the absolute value of a number.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


CEIL Field

[image]

Endeca Presentation API
ExprFunction..::..CEIL Field
ExprFunction Class See Also Send Feedback
Ceiling function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp CEIL
Visual Basic
Public Shared ReadOnly CEIL As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ CEIL

Remarks

Returns the smallest integer that is greater than or equal to a given numeric expression.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


COS Field

[image]

Endeca Presentation API
ExprFunction..::..COS Field
ExprFunction Class See Also Send Feedback
Cosine function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp COS
Visual Basic
Public Shared ReadOnly COS As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ COS

Remarks

Returns the cosine, in radians, of an angle.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


DATE Field

[image]

Endeca Presentation API
ExprFunction..::..DATE Field
ExprFunction Class See Also Send Feedback
Date constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DATE
Visual Basic
Public Const DATE As Integer
Visual C++
public:
literal int DATE

Remarks

Used to designate the date as a day in the month, as the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


DAY_OF_MONTH Field

[image]

Endeca Presentation API
ExprFunction..::..DAY_OF_MONTH Field
ExprFunction Class See Also Send Feedback
Day-of-month constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DAY_OF_MONTH
Visual Basic
Public Const DAY_OF_MONTH As Integer
Visual C++
public:
literal int DAY_OF_MONTH

Remarks

Used to designate that a day of the month be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


DAY_OF_WEEK Field

[image]

Endeca Presentation API
ExprFunction..::..DAY_OF_WEEK Field
ExprFunction Class See Also Send Feedback
Day-of-week constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DAY_OF_WEEK
Visual Basic
Public Const DAY_OF_WEEK As Integer
Visual C++
public:
literal int DAY_OF_WEEK

Remarks

Used to designate that a day in the week be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


DAY_OF_YEAR Field

[image]

Endeca Presentation API
ExprFunction..::..DAY_OF_YEAR Field
ExprFunction Class See Also Send Feedback
Day-of-year constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int DAY_OF_YEAR
Visual Basic
Public Const DAY_OF_YEAR As Integer
Visual C++
public:
literal int DAY_OF_YEAR

Remarks

Used to designate that a day of the year be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


EXP Field

[image]

Endeca Presentation API
ExprFunction..::..EXP Field
ExprFunction Class See Also Send Feedback
Exponential function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp EXP
Visual Basic
Public Shared ReadOnly EXP As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ EXP

Remarks

Returns the log exponential (base e) value of a given numeric expression.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


EXTRACT Field

[image]

Endeca Presentation API
ExprFunction..::..EXTRACT Field
ExprFunction Class See Also Send Feedback
Date Extraction function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp EXTRACT
Visual Basic
Public Shared ReadOnly EXTRACT As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ EXTRACT

Remarks

Extracts a portion of a DateTime property value, such as the day of the week or month of the year. The portion to be extracted is specified with an integer in the decPlaces parameter of the ExprFunction constructor.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


FLOOR Field

[image]

Endeca Presentation API
ExprFunction..::..FLOOR Field
ExprFunction Class See Also Send Feedback
Floor function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp FLOOR
Visual Basic
Public Shared ReadOnly FLOOR As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ FLOOR

Remarks

Returns the largest integer less than or equal to a given numeric expression.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


HOUR Field

[image]

Endeca Presentation API
ExprFunction..::..HOUR Field
ExprFunction Class See Also Send Feedback
Hour constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int HOUR
Visual Basic
Public Const HOUR As Integer
Visual C++
public:
literal int HOUR

Remarks

Used to designate that an hour be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


LAG Field

[image]

Endeca Presentation API
ExprFunction..::..LAG Field
ExprFunction Class See Also Send Feedback
Lag function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp LAG
Visual Basic
Public Shared ReadOnly LAG As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ LAG

Remarks

Returns a value in a row a specified number of rows from a current row. LAG provides access to a row at a given offset prior to the current position. The offset is specified with the decPlaces parameter of the ExprFunction constructor.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


LEAD Field

[image]

Endeca Presentation API
ExprFunction..::..LEAD Field
ExprFunction Class See Also Send Feedback
Lead function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp LEAD
Visual Basic
Public Shared ReadOnly LEAD As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ LEAD

Remarks

Returns a value in a row a specified number of rows from a current row. LEAD provides access to a row at a given offset after the current position. The offset is specified with the decPlaces parameter of the ExprFunction constructor.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


LN Field

[image]

Endeca Presentation API
ExprFunction..::..LN Field
ExprFunction Class See Also Send Feedback
Natural logarithm function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp LN
Visual Basic
Public Shared ReadOnly LN As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ LN

Remarks

Returns the logarithm of its single argument, the base of which is e.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


MINUTE Field

[image]

Endeca Presentation API
ExprFunction..::..MINUTE Field
ExprFunction Class See Also Send Feedback
Minute constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MINUTE
Visual Basic
Public Const MINUTE As Integer
Visual C++
public:
literal int MINUTE

Remarks

Used to designate that a minute be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


MONTH Field

[image]

Endeca Presentation API
ExprFunction..::..MONTH Field
ExprFunction Class See Also Send Feedback
Month constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int MONTH
Visual Basic
Public Const MONTH As Integer
Visual C++
public:
literal int MONTH

Remarks

Used to designate that a month be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


QUARTER Field

[image]

Endeca Presentation API
ExprFunction..::..QUARTER Field
ExprFunction Class See Also Send Feedback
Quarter year constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int QUARTER
Visual Basic
Public Const QUARTER As Integer
Visual C++
public:
literal int QUARTER

Remarks

Used to designate that a quarter in a year be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ROUND Field

[image]

Endeca Presentation API
ExprFunction..::..ROUND Field
ExprFunction Class See Also Send Feedback
Round function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp ROUND
Visual Basic
Public Shared ReadOnly ROUND As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ ROUND

Remarks

Rounds a number to the nearest integer.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


SECOND Field

[image]

Endeca Presentation API
ExprFunction..::..SECOND Field
ExprFunction Class See Also Send Feedback
Second constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int SECOND
Visual Basic
Public Const SECOND As Integer
Visual C++
public:
literal int SECOND

Remarks

Used to designate that a second be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


SIGN Field

[image]

Endeca Presentation API
ExprFunction..::..SIGN Field
ExprFunction Class See Also Send Feedback
Sign function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp SIGN
Visual Basic
Public Shared ReadOnly SIGN As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ SIGN

Remarks

Returns the sign of a given numeric expression. SIGN returns -1 (if the expression is less than zero), 0 (if the expression is zero), or 1 (if the expression is greater than zero).

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


SIN Field

[image]

Endeca Presentation API
ExprFunction..::..SIN Field
ExprFunction Class See Also Send Feedback
Sine function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp SIN
Visual Basic
Public Shared ReadOnly SIN As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ SIN

Remarks

Returns the sine, in radians, of an angle.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


SQRT Field

[image]

Endeca Presentation API
ExprFunction..::..SQRT Field
ExprFunction Class See Also Send Feedback
Square root function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp SQRT
Visual Basic
Public Shared ReadOnly SQRT As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ SQRT

Remarks

Returns the square root of a given numeric expression.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


TAN Field

[image]

Endeca Presentation API
ExprFunction..::..TAN Field
ExprFunction Class See Also Send Feedback
Tangent function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp TAN
Visual Basic
Public Shared ReadOnly TAN As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ TAN

Remarks

Returns the tangent, in radians, of an angle.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


TO_DURATION Field

[image]

Endeca Presentation API
ExprFunction..::..TO_DURATION Field
ExprFunction Class See Also Send Feedback
Duration function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp TO_DURATION
Visual Basic
Public Shared ReadOnly TO_DURATION As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ TO_DURATION

Remarks

Casts an integer into a number of milliseconds, so that it can be used as a duration.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


TRUNC Field

[image]

Endeca Presentation API
ExprFunction..::..TRUNC Field
ExprFunction Class See Also Send Feedback
Date Truncation function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly ExprFunction..::..ExprFunctionOp TRUNC
Visual Basic
Public Shared ReadOnly TRUNC As ExprFunction..::..ExprFunctionOp
Visual C++
public:
static initonly ExprFunction..::..ExprFunctionOp^ TRUNC

Remarks

Rounds the value of a DateTime property down to a coarser granularity. The granularity is specified with an integer in the decPlaces parameter of the ExprFunction constructor.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


WEEK Field

[image]

Endeca Presentation API
ExprFunction..::..WEEK Field
ExprFunction Class See Also Send Feedback
Week constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int WEEK
Visual Basic
Public Const WEEK As Integer
Visual C++
public:
literal int WEEK

Remarks

Used to designate that a week be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


YEAR Field

[image]

Endeca Presentation API
ExprFunction..::..YEAR Field
ExprFunction Class See Also Send Feedback
Year constant.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public const int YEAR
Visual Basic
Public Const YEAR As Integer
Visual C++
public:
literal int YEAR

Remarks

Used to designate that a year be the value for the EXTRACT and TRUNC functions.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ExprFunction Methods

[image] [image]

Endeca Presentation API
ExprFunction Methods
ExprFunction Class See Also Send Feedback

The ExprFunction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprFunction. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprFunction.
Public method | ValidateSyntax | Validates the syntax of this ExprFunction.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprFunction..::..ToString Method
ExprFunction Class See Also Send Feedback
Returns the string form of this ExprFunction.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprFunction.

Implements

IQueryNode..::..ToString()()()()

Remarks

The format for the EXTRACT, LAG, LEAD, ROUND, and TRUNC functions is:
CopyC#
FUNCTION(<i>subexpression</i>), <i>decPlaces</i>
 where FUNCTION is a function name.

The format for the other functions omits the decPlaces setting.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprFunction..::..ToWire Method
ExprFunction Class See Also Send Feedback
Returns the wire form of this ExprFunction.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprFunction.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprFunction..::..ValidateSyntax Method
ExprFunction Class See Also Send Feedback
Validates the syntax of this ExprFunction.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprFunction is valid if the function is not null and the subexpression is non-null and itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ExprFunction Properties

[image] [image]

Endeca Presentation API
ExprFunction Properties
ExprFunction Class See Also Send Feedback

The ExprFunction type exposes the following members.

Properties

 | Name | Description
Public property | Function | Gets and sets the function for this ExprFunction.
Public property | IExpr | Gets and sets the subexpression for this ExprFunction.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


Function Property

[image]

Endeca Presentation API
ExprFunction..::..Function Property
ExprFunction Class See Also Send Feedback
Gets and sets the function for this ExprFunction.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ExprFunction..::..ExprFunctionOp Function { get; set; }
Visual Basic
Public Overridable Property Function As ExprFunction..::..ExprFunctionOp
    Get
    Set
Visual C++
public:
virtual property ExprFunction..::..ExprFunctionOp^ Function {
    ExprFunction..::..ExprFunctionOp^ get ();
    void set (ExprFunction..::..ExprFunctionOp^ value);
}

Field Value

A function of type ExprFunction..::..ExprFunctionOp.

Remarks

The functions are: ExprFunction.ABS, ExprFunction.CEIL, ExprFunction.COS, ExprFunction.EXP, ExprFunction.EXTRACT, ExprFunction.FLOOR, ExprFunction.LAG, ExprFunction.LEAD, ExprFunction.LN, ExprFunction.ROUND, ExprFunction.SIGN, ExprFunction.SIN, ExprFunction.SQRT, ExprFunction.TAN, ExprFunction.TO_DURATION, and ExprFunction.TRUNC.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


IExpr Property

[image]

Endeca Presentation API
ExprFunction..::..IExpr Property
ExprFunction Class See Also Send Feedback
Gets and sets the subexpression for this ExprFunction.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IExpr IExpr { get; set; }
Visual Basic
Public Overridable Property IExpr As IExpr
    Get
    Set
Visual C++
public:
virtual property IExpr^ IExpr {
    IExpr^ get ();
    void set (IExpr^ value);
}

Field Value

An object of type IExpr that is the subexpression for this ExprFunction.

See Also

ExprFunction Class
Endeca.Navigation.Analytics Namespace


ExprFunction.ExprFunctionOp Class

[image]

Endeca Presentation API
ExprFunction..::..ExprFunctionOp Class
ExprFunction Class Members See Also Send Feedback
Enumeration of Endeca unary scalar functions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprFunctionOp
Visual Basic
Public Class ExprFunctionOp
Visual C++
public ref class ExprFunctionOp

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprFunction..::..ExprFunctionOp

See Also

ExprFunction..::..ExprFunctionOp Members
Endeca.Navigation.Analytics Namespace


ExprFunction.ExprFunctionOp Members

[image] [image]

Endeca Presentation API
ExprFunction..::..ExprFunctionOp Members
ExprFunction..::..ExprFunctionOp Class Methods See Also Send Feedback

ExprFunction instances represent unary scalar function expressions.

The ExprFunction..::..ExprFunctionOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the unary scalar function. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the unary scalar function.

See Also

ExprFunction..::..ExprFunctionOp Class
Endeca.Navigation.Analytics Namespace


ExprFunction.ExprFunctionOp Methods

[image] [image]

Endeca Presentation API
ExprFunction..::..ExprFunctionOp Methods
ExprFunction..::..ExprFunctionOp Class See Also Send Feedback

The ExprFunction..::..ExprFunctionOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the unary scalar function. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the unary scalar function.

See Also

ExprFunction..::..ExprFunctionOp Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprFunction..::..ExprFunctionOp..::..ToString Method
ExprFunction..::..ExprFunctionOp Class See Also Send Feedback
Returns the string form of the unary scalar function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of the function.

See Also

ExprFunction..::..ExprFunctionOp Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprFunction..::..ExprFunctionOp..::..ToWire Method
ExprFunction..::..ExprFunctionOp Class See Also Send Feedback
Returns the wire form of the unary scalar function.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of the function.

See Also

ExprFunction..::..ExprFunctionOp Class
Endeca.Navigation.Analytics Namespace


ExprKey Class

[image]

Endeca Presentation API
ExprKey Class
Members See Also Send Feedback
Instances of ExprKey represent record field names. The fields are Endeca properties or dimensions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprKey : IExpr, IQueryNode
Visual Basic
Public Class ExprKey _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprKey : IExpr,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprKey

See Also

ExprKey Members
Endeca.Navigation.Analytics Namespace


ExprKey Members

[image] [image]

Endeca Presentation API
ExprKey Members
ExprKey Class Constructors Methods Properties See Also Send Feedback

The ExprKey type exposes the following members.

Constructors

 | Name | Description
Public method | ExprKey | Creates a new ExprKey expression node representing the specified record field name.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprKey. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprKey.
Public method | ValidateSyntax | Validates the syntax of this ExprKey.

Properties

 | Name | Description
Public property | Value | Gets and sets the value for this ExprKey.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ExprKey Constructor

[image]

Endeca Presentation API
ExprKey Constructor
ExprKey Class See Also Send Feedback
Creates a new ExprKey expression node representing the specified record field name.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprKey(
    string val
)
Visual Basic
Public Sub New ( _
    val As String _
)
Visual C++
public:
ExprKey(
    String^ val
)

Parameters

val
Type: System..::..String
The name of an Endeca property or dimension.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ExprKey Methods

[image] [image]

Endeca Presentation API
ExprKey Methods
ExprKey Class See Also Send Feedback

The ExprKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprKey. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprKey.
Public method | ValidateSyntax | Validates the syntax of this ExprKey.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprKey..::..ToString Method
ExprKey Class See Also Send Feedback
Returns the string form of this ExprKey.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprKey.

Implements

IQueryNode..::..ToString()()()()

Remarks

The ExprKey format is the value of the val parameter of the constructor, such as "price" or "revenue ($)".

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprKey..::..ToWire Method
ExprKey Class See Also Send Feedback
Returns the wire form of this ExprKey.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprKey.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprKey..::..ValidateSyntax Method
ExprKey Class See Also Send Feedback
Validates the syntax of this ExprKey.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprKey is valid if its value (the val parameter of the constructor) is non-null and non-empty.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ExprKey Properties

[image] [image]

Endeca Presentation API
ExprKey Properties
ExprKey Class See Also Send Feedback

The ExprKey type exposes the following members.

Properties

 | Name | Description
Public property | Value | Gets and sets the value for this ExprKey.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


Value Property

[image]

Endeca Presentation API
ExprKey..::..Value Property
ExprKey Class See Also Send Feedback
Gets and sets the value for this ExprKey.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Value { get; set; }
Visual Basic
Public Overridable Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of an Endeca property or dimension.

See Also

ExprKey Class
Endeca.Navigation.Analytics Namespace


ExprLookup Class

[image]

Endeca Presentation API
ExprLookup Class
Members See Also Send Feedback
ExprLookup instances represent an access to a derived property of a record in a foreign table.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class ExprLookup : IExpr, IQueryNode
Visual Basic
Public Class ExprLookup _
    Implements IExpr, IQueryNode
Visual C++
public ref class ExprLookup : IExpr,
    IQueryNode

Remarks

MyTable[{expr1}, {expr2}].field is semantically correct if MyTable is GROUPed by the same number of fields as the number of expressions within brackets "[...]", and field is a derived property defined on MyTable. Brackets with no expression list within represent access to a table that is GROUPed to a single record.

Note that because the implicit tables NavStateRecords and AllBaseRecords are not GROUPED, it is not possible to do a lookup on these tables.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..ExprLookup

See Also

ExprLookup Members
Endeca.Navigation.Analytics Namespace


ExprLookup Members

[image] [image]

Endeca Presentation API
ExprLookup Members
ExprLookup Class Constructors Methods Properties See Also Send Feedback

The ExprLookup type exposes the following members.

Constructors

 | Name | Description
Public method | ExprLookup | Constructs a new ExprLookup.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprLookup. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprLookup.
Public method | ValidateSyntax | Validates the syntax of this ExprLookup.

Properties

 | Name | Description
Public property | FieldName | Gets and sets the the field name for this ExprLookup.
Public property | LookupList | Gets and sets the LookupList for this ExprLookup.
Public property | TableName | Gets and sets the table name for this ExprLookup.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ExprLookup Constructor

[image]

Endeca Presentation API
ExprLookup Constructor
ExprLookup Class See Also Send Feedback
Constructs a new ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public ExprLookup(
    string tableName,
    string fieldName,
    LookupList lList
)
Visual Basic
Public Sub New ( _
    tableName As String, _
    fieldName As String, _
    lList As LookupList _
)
Visual C++
public:
ExprLookup(
    String^ tableName,
    String^ fieldName,
    LookupList^ lList
)

Parameters

tableName
Type: System..::..String
The name of the table. Note that the table names NavStateRecords and AllBaseRecords are reserved and therefore cannot be specified.
fieldName
Type: System..::..String
A derived property of the table specified by tableName.
lList
Type: Endeca.Navigation.Analytics..::..LookupList
A LookupList object that has been populated with lookup expressions (IExpr objects). The LookupList represents a list of expressions that evaluate to a list of values that uniquely identify a record in the table.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ExprLookup Methods

[image] [image]

Endeca Presentation API
ExprLookup Methods
ExprLookup Class See Also Send Feedback

The ExprLookup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this ExprLookup. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this ExprLookup.
Public method | ValidateSyntax | Validates the syntax of this ExprLookup.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
ExprLookup..::..ToString Method
ExprLookup Class See Also Send Feedback
Returns the string form of this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this ExprLookup.

Implements

IQueryNode..::..ToString()()()()

Remarks

The ExprLookup format is:
CopyC#
<i>tableName</i>[<i>expression1</i>, <i>expression2</i>...].<i>fieldName</i>
 where each expression is a lookup expression in the LookupList.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
ExprLookup..::..ToWire Method
ExprLookup Class See Also Send Feedback
Returns the wire form of this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public string ToWire()
Visual Basic
Public Function ToWire As String
Visual C++
public:
virtual String^ ToWire() sealed

Return Value

The wire form of this ExprLookup.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
ExprLookup..::..ValidateSyntax Method
ExprLookup Class See Also Send Feedback
Validates the syntax of this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An ExprLookup is valid if the table name and field name are non-null and non-empty. The LookupList itself must also be valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


ExprLookup Properties

[image] [image]

Endeca Presentation API
ExprLookup Properties
ExprLookup Class See Also Send Feedback

The ExprLookup type exposes the following members.

Properties

 | Name | Description
Public property | FieldName | Gets and sets the the field name for this ExprLookup.
Public property | LookupList | Gets and sets the LookupList for this ExprLookup.
Public property | TableName | Gets and sets the table name for this ExprLookup.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


FieldName Property

[image]

Endeca Presentation API
ExprLookup..::..FieldName Property
ExprLookup Class See Also Send Feedback
Gets and sets the the field name for this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FieldName { get; set; }
Visual Basic
Public Overridable Property FieldName As String
    Get
    Set
Visual C++
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

A derived property of the table specified for this ExprLookup.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


LookupList Property

[image]

Endeca Presentation API
ExprLookup..::..LookupList Property
ExprLookup Class See Also Send Feedback
Gets and sets the LookupList for this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual LookupList LookupList { get; set; }
Visual Basic
Public Overridable Property LookupList As LookupList
    Get
    Set
Visual C++
public:
virtual property LookupList^ LookupList {
    LookupList^ get ();
    void set (LookupList^ value);
}

Field Value

A LookupList object that has been populated with lookup expressions (IExpr objects). The LookupList represents a list of expressions that evaluate to a list of values that uniquely identify a record in the table.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


TableName Property

[image]

Endeca Presentation API
ExprLookup..::..TableName Property
ExprLookup Class See Also Send Feedback
Gets and sets the table name for this ExprLookup.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string TableName { get; set; }
Visual Basic
Public Overridable Property TableName As String
    Get
    Set
Visual C++
public:
virtual property String^ TableName {
    String^ get ();
    void set (String^ value);
}

Field Value

The table name of this ExprLookup. Note that for the setter, the table names NavStateRecords and AllBaseRecords are reserved and therefore cannot be specified.

See Also

ExprLookup Class
Endeca.Navigation.Analytics Namespace


FilterAnd Class

[image]

Endeca Presentation API
FilterAnd Class
Members See Also Send Feedback
A FilterAnd is a IFilter implementing a Boolean n-way AND operation.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterAnd : IObjectList, IFilter,
    IQueryNode
Visual Basic
Public Class FilterAnd _
    Implements IObjectList, IFilter, IQueryNode
Visual C++
public ref class FilterAnd : IObjectList,
    IFilter, IQueryNode

Remarks

The filter evaluates to true for a given record if all of its child Filters evaluate to true for that record. This type of filter provides an IObjectList interface, where the List elements represent child IFilter operations.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterAnd

See Also

FilterAnd Members
Endeca.Navigation.Analytics Namespace


FilterAnd Members

[image] [image]

Endeca Presentation API
FilterAnd Members
FilterAnd Class Constructors Methods See Also Send Feedback

The FilterAnd type exposes the following members.

Constructors

 | Name | Description
Public method | FilterAnd | Creates a new FilterAnd with no children.

Methods

 | Name | Description
Public method | Add | Appends an IFilter object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an IFilter object from the FilterAnd.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an IFilter object from the FilterAnd.
Public method | Size | Returns the number of IFilter objects in this FilterAnd.
Public method | ToString | Returns the string form of this FilterAnd. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterAnd.
Public method | ValidateSyntax | Validates the syntax of this FilterAnd.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


FilterAnd Constructor

[image]

Endeca Presentation API
FilterAnd Constructor
FilterAnd Class See Also Send Feedback
Creates a new FilterAnd with no children.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FilterAnd()
Visual Basic
Public Sub New
Visual C++
public:
FilterAnd()

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


FilterAnd Methods

[image] [image]

Endeca Presentation API
FilterAnd Methods
FilterAnd Class See Also Send Feedback

The FilterAnd type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends an IFilter object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an IFilter object from the FilterAnd.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an IFilter object from the FilterAnd.
Public method | Size | Returns the number of IFilter objects in this FilterAnd.
Public method | ToString | Returns the string form of this FilterAnd. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterAnd.
Public method | ValidateSyntax | Validates the syntax of this FilterAnd.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
FilterAnd..::..Add Method
FilterAnd Class See Also Send Feedback
Appends an IFilter object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The IFilter object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not an IFilter object.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
FilterAnd..::..Get Method
FilterAnd Class See Also Send Feedback
Gets an IFilter object from the FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index offset of the desired IFilter object.

Return Value

The IFilter object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
FilterAnd..::..Remove Method
FilterAnd Class See Also Send Feedback
Removes an IFilter object from the FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the IFilter object to be removed.

Return Value

The removed IFilter object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
FilterAnd..::..Size Method
FilterAnd Class See Also Send Feedback
Returns the number of IFilter objects in this FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of IFilter objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterAnd..::..ToString Method
FilterAnd Class See Also Send Feedback
Returns the string form of this FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string format of this FilterAnd.

Implements

IQueryNode..::..ToString()()()()

Remarks

The FilterAnd format is:
CopyC#
(<i>filter1</i> AND <i>filter2</i> ...)
 where each filter is the string form of an IFilter.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterAnd..::..ToWire Method
FilterAnd Class See Also Send Feedback
Returns the wire form of this FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this FilterAnd.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
FilterAnd..::..ValidateSyntax Method
FilterAnd Class See Also Send Feedback
Validates the syntax of this FilterAnd.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A FilterAnd is valid if the number of sub-filters (IFilter elements) is greater than zero and each sub-filter is itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the FilterAnd does not contain at least one sub-filter.

See Also

FilterAnd Class
Endeca.Navigation.Analytics Namespace


FilterCompare Class

[image]

Endeca Presentation API
FilterCompare Class
Members Example See Also Send Feedback
A FilterCompare is a type of IFilter that performs a value comparison.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterCompare : IFilter,
    IQueryNode
Visual Basic
Public Class FilterCompare _
    Implements IFilter, IQueryNode
Visual C++
public ref class FilterCompare : IFilter,
    IQueryNode

Remarks

After being created, the FilterCompare object is then set in a Statement object with the HavingFilter or WhereFilter methods.

A FilterCompare can also be used to determine if the value of an Endeca property or dimension is null or non-null.

Examples

A typical use of this class is to compare the value of an Endeca property or dimension to a specified literal value. This can be considered as a programmatic equivalent of the SQL HAVING and WHERE clauses. For example, this text-based syntax snippet:
CopyC#
RETURN Reps AS
WHERE Region = 'West'
 can be expressed programmatically as:
CopyC#
Statement reps = new Statement();
reps.Name = "Reps";
FilterCompare whFilter = new FilterCompare("Region", FilterCompare.EQ, "West");
reps.WhereFilter = whFilter;

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterCompare

See Also

FilterCompare Members
Endeca.Navigation.Analytics Namespace


FilterCompare Members

[image] [image]

Endeca Presentation API
FilterCompare Members
FilterCompare Class Constructors Methods Fields Properties See Also Send Feedback

The FilterCompare type exposes the following members.

Constructors

 | Name | Description
Public method | FilterCompare | Creates a new FilterCompare object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterCompare. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterCompare.
Public method | ValidateSyntax | Validates the syntax of this FilterCompare.

Fields

Name | Description
DVAL | DVAL operator.
EQ | EQUAL TO operator.
GT | GREATER THAN operator.
GTE | GREATER THAN OR EQUAL TO operator.
IS_NOT_NULL | NON-NULL operator.
IS_NULL | NULL operator.
LT | LESS THAN operator.
LTE | LESS THAN OR EQUAL TO operator.
NEQ | NOT EQUAL TO operator.

Properties

 | Name | Description
Public property | FieldName | Gets and sets the fieldName for this FilterCompare.
Public property | Function | Gets and sets the comparison function for this FilterCompare.
Public property | Value | Gets and sets the value for this FilterCompare.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FilterCompare Constructor

[image]

Endeca Presentation API
FilterCompare Constructor
FilterCompare Class See Also Send Feedback
Creates a new FilterCompare object.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FilterCompare(
    string fieldName,
    FilterCompare..::..FilterCompareOp function,
    string val
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    function As FilterCompare..::..FilterCompareOp, _
    val As String _
)
Visual C++
public:
FilterCompare(
    String^ fieldName,
    FilterCompare..::..FilterCompareOp^ function,
    String^ val
)

Parameters

fieldName
Type: System..::..String
The name of an Endeca property or dimension. The value of fieldName will be compared to the literal value of val. Note that this value is ignored for the DVAL function.
function
Type: Endeca.Navigation.Analytics..::..FilterCompare..::..FilterCompareOp
A comparison function of type FilterCompare..::..FilterCompareOp. See the Function property for a list of the comparison function names.
val
Type: System..::..String
A literal value to be compared to the value of fieldName. For the FilterCompare.DVAL function, this value specifies the ID of a dimension value.

Note that this value is ignored for the FilterCompare.IS_NULL and FilterCompare.IS_NOT_NULL functions.

Remarks

The FilterCompare compares the value for the Endeca property or dimension fieldName to the value specified by val using the function specified by function.

The filter evaluates to true for a given record if the specified comparison function evaluates to true when applied to the value for fieldName from the record (lhs) and the specified val (rhs). For example, if fieldName is "Price" and the record has a Price of 1.00, and the function is FilterCompare.LT and val is 2.00, then the filter would evaluate to true.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FilterCompare Fields

[image] [image]

Endeca Presentation API
FilterCompare Fields
FilterCompare Class See Also Send Feedback

The FilterCompare type exposes the following members.

Fields

Name | Description
DVAL | DVAL operator.
EQ | EQUAL TO operator.
GT | GREATER THAN operator.
GTE | GREATER THAN OR EQUAL TO operator.
IS_NOT_NULL | NON-NULL operator.
IS_NULL | NULL operator.
LT | LESS THAN operator.
LTE | LESS THAN OR EQUAL TO operator.
NEQ | NOT EQUAL TO operator.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


DVAL Field

[image]

Endeca Presentation API
FilterCompare..::..DVAL Field
FilterCompare Class See Also Send Feedback
DVAL operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp DVAL
Visual Basic
Public Shared ReadOnly DVAL As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ DVAL

Remarks

Used to filter records by a dimension value with an ID specified by the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


EQ Field

[image]

Endeca Presentation API
FilterCompare..::..EQ Field
FilterCompare Class See Also Send Feedback
EQUAL TO operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp EQ
Visual Basic
Public Shared ReadOnly EQ As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ EQ

Remarks

Determines if the value of fieldName is equal to the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


GT Field

[image]

Endeca Presentation API
FilterCompare..::..GT Field
FilterCompare Class See Also Send Feedback
GREATER THAN operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp GT
Visual Basic
Public Shared ReadOnly GT As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ GT

Remarks

Determines if the value of fieldName is greater than the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


GTE Field

[image]

Endeca Presentation API
FilterCompare..::..GTE Field
FilterCompare Class See Also Send Feedback
GREATER THAN OR EQUAL TO operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp GTE
Visual Basic
Public Shared ReadOnly GTE As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ GTE

Remarks

Determines if the value of fieldName is less than the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


IS_NOT_NULL Field

[image]

Endeca Presentation API
FilterCompare..::..IS_NOT_NULL Field
FilterCompare Class See Also Send Feedback
NON-NULL operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp IS_NOT_NULL
Visual Basic
Public Shared ReadOnly IS_NOT_NULL As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ IS_NOT_NULL

Remarks

Determines if the fieldName is null. The val parameter is ignored.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


IS_NULL Field

[image]

Endeca Presentation API
FilterCompare..::..IS_NULL Field
FilterCompare Class See Also Send Feedback
NULL operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp IS_NULL
Visual Basic
Public Shared ReadOnly IS_NULL As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ IS_NULL

Remarks

Determines if the fieldName is null. The val parameter is ignored.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


LT Field

[image]

Endeca Presentation API
FilterCompare..::..LT Field
FilterCompare Class See Also Send Feedback
LESS THAN operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp LT
Visual Basic
Public Shared ReadOnly LT As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ LT

Remarks

Determines if the value of fieldName is less than the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


LTE Field

[image]

Endeca Presentation API
FilterCompare..::..LTE Field
FilterCompare Class See Also Send Feedback
LESS THAN OR EQUAL TO operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp LTE
Visual Basic
Public Shared ReadOnly LTE As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ LTE

Remarks

Determines if the value of fieldName is less than or equal to the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


NEQ Field

[image]

Endeca Presentation API
FilterCompare..::..NEQ Field
FilterCompare Class See Also Send Feedback
NOT EQUAL TO operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static readonly FilterCompare..::..FilterCompareOp NEQ
Visual Basic
Public Shared ReadOnly NEQ As FilterCompare..::..FilterCompareOp
Visual C++
public:
static initonly FilterCompare..::..FilterCompareOp^ NEQ

Remarks

Determines if the value of fieldName is not equal to the value of the val parameter.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FilterCompare Methods

[image] [image]

Endeca Presentation API
FilterCompare Methods
FilterCompare Class See Also Send Feedback

The FilterCompare type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterCompare. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterCompare.
Public method | ValidateSyntax | Validates the syntax of this FilterCompare.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterCompare..::..ToString Method
FilterCompare Class See Also Send Feedback
Returns the string form of this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this FilterCompare.

Implements

IQueryNode..::..ToString()()()()

Remarks

The FilterCompare format is:
CopyC#
("<i>fieldName</i>" "<i>compare-function</i>" '<i>compare-value</i>')
 Note that compare-value is not returned for the FilterCompare.IS_NULL and FilterCompare.IS_NOT_NULL functions.

For the FilterCompare.DVAL function, the format is:

CopyC#
(DVAL("<i>value</i>")
For example:
CopyC#
("SalesTotal" "FilterCompare.GT" '10000')
 is returned if the property name is "SalesTotal" and a GREATER THAN comparison is being made to the value of 10000.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterCompare..::..ToWire Method
FilterCompare Class See Also Send Feedback
Returns the wire form of this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this FilterCompare.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
FilterCompare..::..ValidateSyntax Method
FilterCompare Class See Also Send Feedback
Validates the syntax of this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A FilterCompare is valid if the function is non-null and the fieldName and val are non-null and non-empty.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FilterCompare Properties

[image] [image]

Endeca Presentation API
FilterCompare Properties
FilterCompare Class See Also Send Feedback

The FilterCompare type exposes the following members.

Properties

 | Name | Description
Public property | FieldName | Gets and sets the fieldName for this FilterCompare.
Public property | Function | Gets and sets the comparison function for this FilterCompare.
Public property | Value | Gets and sets the value for this FilterCompare.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FieldName Property

[image]

Endeca Presentation API
FilterCompare..::..FieldName Property
FilterCompare Class See Also Send Feedback
Gets and sets the fieldName for this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FieldName { get; set; }
Visual Basic
Public Overridable Property FieldName As String
    Get
    Set
Visual C++
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of an Endeca property or dimension that is the fieldName setting for this FilterCompare.

The value of this field will either be tested for a null value or will be compared to the val parameter. Note that this value is ignored for the DVAL function.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


Function Property

[image]

Endeca Presentation API
FilterCompare..::..Function Property
FilterCompare Class See Also Send Feedback
Gets and sets the comparison function for this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual FilterCompare..::..FilterCompareOp Function { get; set; }
Visual Basic
Public Overridable Property Function As FilterCompare..::..FilterCompareOp
    Get
    Set
Visual C++
public:
virtual property FilterCompare..::..FilterCompareOp^ Function {
    FilterCompare..::..FilterCompareOp^ get ();
    void set (FilterCompare..::..FilterCompareOp^ value);
}

Field Value

The comparison function (of type FilterCompare..::..FilterCompareOp) for this FilterCompare. An example is FilterCompare.LT for the LESS THAN operator.

Remarks

The comparison functions are: FilterCompare.EQ, FilterCompare.NEQ, FilterCompare.LT, FilterCompare.LTE, FilterCompare.GT, FilterCompare.GTE, FilterCompare.IS_NULL, FilterCompare.IS_NOT_NULL, and FilterCompare.DVAL.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


Value Property

[image]

Endeca Presentation API
FilterCompare..::..Value Property
FilterCompare Class See Also Send Feedback
Gets and sets the value for this FilterCompare.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Value { get; set; }
Visual Basic
Public Overridable Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}

Field Value

The value to be compared.

Remarks

The value will be compared to the value of the fieldName, using the specified comparison function. For the DVAL function, value specifies the ID of the dimension value that will be used to filter records.

Note that this value is ignored for the IS_NULL and IS_NOT_NULL functions.

See Also

FilterCompare Class
Endeca.Navigation.Analytics Namespace


FilterCompare.FilterCompareOp Class

[image]

Endeca Presentation API
FilterCompare..::..FilterCompareOp Class
FilterCompare Class Members See Also Send Feedback
Enumeration of Endeca comparison operators.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterCompareOp
Visual Basic
Public Class FilterCompareOp
Visual C++
public ref class FilterCompareOp

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterCompare..::..FilterCompareOp

See Also

FilterCompare..::..FilterCompareOp Members
Endeca.Navigation.Analytics Namespace


FilterCompare.FilterCompareOp Members

[image] [image]

Endeca Presentation API
FilterCompare..::..FilterCompareOp Members
FilterCompare..::..FilterCompareOp Class Methods See Also Send Feedback

A FilterCompare is a type of IFilter that performs a value comparison.

The FilterCompare..::..FilterCompareOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the comparison operator. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the comparison operator.

See Also

FilterCompare..::..FilterCompareOp Class
Endeca.Navigation.Analytics Namespace


FilterCompare.FilterCompareOp Methods

[image] [image]

Endeca Presentation API
FilterCompare..::..FilterCompareOp Methods
FilterCompare..::..FilterCompareOp Class See Also Send Feedback

The FilterCompare..::..FilterCompareOp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of the comparison operator. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of the comparison operator.

See Also

FilterCompare..::..FilterCompareOp Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterCompare..::..FilterCompareOp..::..ToString Method
FilterCompare..::..FilterCompareOp Class See Also Send Feedback
Returns the string form of the comparison operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of the comparison operator.

See Also

FilterCompare..::..FilterCompareOp Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterCompare..::..FilterCompareOp..::..ToWire Method
FilterCompare..::..FilterCompareOp Class See Also Send Feedback
Returns the wire form of the comparison operator.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of the comparison operator.

See Also

FilterCompare..::..FilterCompareOp Class
Endeca.Navigation.Analytics Namespace


FilterIn Class

[image]

Endeca Presentation API
FilterIn Class
Members See Also Send Feedback
A FilterIn is an IFilter that checks membership of a given set of values in a table. The membership is checked with a set of lookup expressions in a LookupList that is set in the FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterIn : IFilter, IQueryNode
Visual Basic
Public Class FilterIn _
    Implements IFilter, IQueryNode
Visual C++
public ref class FilterIn : IFilter,
    IQueryNode

Remarks

This filter:
CopyC#
"[<i>expression1</i>, <i>expression2</i>] IN MyTable"
 is semantically correct if MyTable is GROUPED by the same number of fields as the number of expressions within brackets "[...]". In this way, the contents of the brackets uniquely identify a record in MyTable. Brackets with no expression list within represent access to a table that is GROUPed to a single record.

Because the implicit tables NavStateRecords and AllBaseRecords are not GROUPED, it is not possible to do a lookup on these tables.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterIn

See Also

FilterIn Members
Endeca.Navigation.Analytics Namespace


FilterIn Members

[image] [image]

Endeca Presentation API
FilterIn Members
FilterIn Class Constructors Methods Properties See Also Send Feedback

The FilterIn type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIn | Constructs a new FilterIn.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterIn. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterIn.
Public method | ValidateSyntax | Validates the syntax of this FilterIn.

Properties

 | Name | Description
Public property | LookupList | Gets and sets the LookupList for this FilterIn.
Public property | TableName | Gets and sets the table name for this FilterIn.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


FilterIn Constructor

[image]

Endeca Presentation API
FilterIn Constructor
FilterIn Class See Also Send Feedback
Constructs a new FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FilterIn(
    string tableName,
    LookupList lList
)
Visual Basic
Public Sub New ( _
    tableName As String, _
    lList As LookupList _
)
Visual C++
public:
FilterIn(
    String^ tableName,
    LookupList^ lList
)

Parameters

tableName
Type: System..::..String
The name of the table. Note that the table names NavStateRecords and AllBaseRecords are reserved and therefore cannot be specified.
lList
Type: Endeca.Navigation.Analytics..::..LookupList
A LookupList object that has been populated with lookup expressions (IExpr objects). The LookupList represents a list of expressions that evaluate to a list of values that uniquely identify a record in the table.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


FilterIn Methods

[image] [image]

Endeca Presentation API
FilterIn Methods
FilterIn Class See Also Send Feedback

The FilterIn type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterIn. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterIn.
Public method | ValidateSyntax | Validates the syntax of this FilterIn.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterIn..::..ToString Method
FilterIn Class See Also Send Feedback
Returns the string form of this FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this FilterIn.

Implements

IQueryNode..::..ToString()()()()

Remarks

The FilterIn format is:
CopyC#
[<i>expression1</i>, <i>expression2</i>...] IN <i>table-name</i>
 where each expression is a lookup expression in the LookupList.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterIn..::..ToWire Method
FilterIn Class See Also Send Feedback
Returns the wire form of this FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this FilterIn.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
FilterIn..::..ValidateSyntax Method
FilterIn Class See Also Send Feedback
Validates the syntax of this FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A FilterIn is valid if the table name is non-null and non-empty ahd the LookupList is itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


FilterIn Properties

[image] [image]

Endeca Presentation API
FilterIn Properties
FilterIn Class See Also Send Feedback

The FilterIn type exposes the following members.

Properties

 | Name | Description
Public property | LookupList | Gets and sets the LookupList for this FilterIn.
Public property | TableName | Gets and sets the table name for this FilterIn.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


LookupList Property

[image]

Endeca Presentation API
FilterIn..::..LookupList Property
FilterIn Class See Also Send Feedback
Gets and sets the LookupList for this FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual LookupList LookupList { get; set; }
Visual Basic
Public Overridable Property LookupList As LookupList
    Get
    Set
Visual C++
public:
virtual property LookupList^ LookupList {
    LookupList^ get ();
    void set (LookupList^ value);
}

Field Value

A LookupList object that has been populated with lookup expressions (IExpr objects). The LookupList represents a list of expressions that evaluate to a list of values that uniquely identify a record in the table.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


TableName Property

[image]

Endeca Presentation API
FilterIn..::..TableName Property
FilterIn Class See Also Send Feedback
Gets and sets the table name for this FilterIn.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string TableName { get; set; }
Visual Basic
Public Overridable Property TableName As String
    Get
    Set
Visual C++
public:
virtual property String^ TableName {
    String^ get ();
    void set (String^ value);
}

Field Value

The table name of this FilterIn. Note that for the setter, the table names NavStateRecords and AllBaseRecords are reserved and therefore cannot be specified.

See Also

FilterIn Class
Endeca.Navigation.Analytics Namespace


FilterNot Class

[image]

Endeca Presentation API
FilterNot Class
Members See Also Send Feedback
A FilterNot is an IFilter implementing a Boolean NOT operation. The filter evaluates to true for a given record if its child filter evaluates to false for that record.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterNot : IFilter, IQueryNode
Visual Basic
Public Class FilterNot _
    Implements IFilter, IQueryNode
Visual C++
public ref class FilterNot : IFilter,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterNot

See Also

FilterNot Members
Endeca.Navigation.Analytics Namespace


FilterNot Members

[image] [image]

Endeca Presentation API
FilterNot Members
FilterNot Class Constructors Methods Properties See Also Send Feedback

The FilterNot type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNot | Creates a new FilterNot.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterNot. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterNot.
Public method | ValidateSyntax | Validates the syntax of this FilterNot.

Properties

 | Name | Description
Public property | Filter | Gets and sets the filter sub-expression for this FilterNot.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


FilterNot Constructor

[image]

Endeca Presentation API
FilterNot Constructor
FilterNot Class See Also Send Feedback
Creates a new FilterNot.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FilterNot(
    IFilter filter
)
Visual Basic
Public Sub New ( _
    filter As IFilter _
)
Visual C++
public:
FilterNot(
    IFilter^ filter
)

Parameters

filter
Type: Endeca.Navigation.Analytics..::..IFilter
The filter sub-expression (of type IFilter) for this FilterNot.

Remarks

The FilterNot represents the negation of the filter sub-expression filter.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


FilterNot Methods

[image] [image]

Endeca Presentation API
FilterNot Methods
FilterNot Class See Also Send Feedback

The FilterNot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this FilterNot. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterNot.
Public method | ValidateSyntax | Validates the syntax of this FilterNot.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterNot..::..ToString Method
FilterNot Class Example See Also Send Feedback
Returns the string form of this FilterNot.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this FilterNot.

Implements

IQueryNode..::..ToString()()()()

Remarks

The FilterNot format is:
CopyC#
NOT(<i>subfilter</i>)
 where subfilter is the filter sub-expression.

Examples

This string:
CopyC#
NOT("SalesTotal" "FilterCompare.GT" "10000")
 is returned if a NOT operation is performed on the result of the GREATER THAN comparison.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterNot..::..ToWire Method
FilterNot Class See Also Send Feedback
Returns the wire form of this FilterNot.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this FilterNot.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
FilterNot..::..ValidateSyntax Method
FilterNot Class See Also Send Feedback
Validates the syntax of this FilterNot.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A FilterNot is valid if it contains a a sub-filter and that sub-filter is itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


FilterNot Properties

[image] [image]

Endeca Presentation API
FilterNot Properties
FilterNot Class See Also Send Feedback

The FilterNot type exposes the following members.

Properties

 | Name | Description
Public property | Filter | Gets and sets the filter sub-expression for this FilterNot.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


Filter Property

[image]

Endeca Presentation API
FilterNot..::..Filter Property
FilterNot Class See Also Send Feedback
Gets and sets the filter sub-expression for this FilterNot.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IFilter Filter { get; set; }
Visual Basic
Public Overridable Property Filter As IFilter
    Get
    Set
Visual C++
public:
virtual property IFilter^ Filter {
    IFilter^ get ();
    void set (IFilter^ value);
}

Field Value

The filter sub-expression (of type IFilter) for this FilterNot.

See Also

FilterNot Class
Endeca.Navigation.Analytics Namespace


FilterOr Class

[image]

Endeca Presentation API
FilterOr Class
Members See Also Send Feedback
A FilterOr is an IFilter implementing a Boolean n-way OR operation.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class FilterOr : IObjectList, IFilter,
    IQueryNode
Visual Basic
Public Class FilterOr _
    Implements IObjectList, IFilter, IQueryNode
Visual C++
public ref class FilterOr : IObjectList,
    IFilter, IQueryNode

Remarks

The filter evaluates to true for a given record if any of its child Filters evaluate to true for that record.

This type of filter provides a List (IObjectList) interface, where the List elements represent child IFilter operations.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..FilterOr

See Also

FilterOr Members
Endeca.Navigation.Analytics Namespace


FilterOr Members

[image] [image]

Endeca Presentation API
FilterOr Members
FilterOr Class Constructors Methods See Also Send Feedback

The FilterOr type exposes the following members.

Constructors

 | Name | Description
Public method | FilterOr | Creates a new FilterOr with no children (no IFilter sub-filters).

Methods

 | Name | Description
Public method | Add | Appends an IFilter object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an IFilter object from the FilterOr.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an IFilter object from the FilterOr.
Public method | Size | Returns the number of IFilter objects in this FilterOr.
Public method | ToString | Returns the string form of this FilterOr. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterOr.
Public method | ValidateSyntax | Validates the syntax of this FilterOr.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


FilterOr Constructor

[image]

Endeca Presentation API
FilterOr Constructor
FilterOr Class See Also Send Feedback
Creates a new FilterOr with no children (no IFilter sub-filters).

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public FilterOr()
Visual Basic
Public Sub New
Visual C++
public:
FilterOr()

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


FilterOr Methods

[image] [image]

Endeca Presentation API
FilterOr Methods
FilterOr Class See Also Send Feedback

The FilterOr type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends an IFilter object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an IFilter object from the FilterOr.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an IFilter object from the FilterOr.
Public method | Size | Returns the number of IFilter objects in this FilterOr.
Public method | ToString | Returns the string form of this FilterOr. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this FilterOr.
Public method | ValidateSyntax | Validates the syntax of this FilterOr.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
FilterOr..::..Add Method
FilterOr Class See Also Send Feedback
Appends an IFilter object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The IFilter object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not an IFilter object.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
FilterOr..::..Get Method
FilterOr Class See Also Send Feedback
Gets an IFilter object from the FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index offset of the desired IFilter object.

Return Value

The IFilter object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
FilterOr..::..Remove Method
FilterOr Class See Also Send Feedback
Removes an IFilter object from the FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the IFilter object to be removed.

Return Value

The removed IFilter object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
FilterOr..::..Size Method
FilterOr Class See Also Send Feedback
Returns the number of IFilter objects in this FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of IFilter objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
FilterOr..::..ToString Method
FilterOr Class See Also Send Feedback
Returns the string form of this FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string format of this FilterOr.

Implements

IQueryNode..::..ToString()()()()

Remarks

The FilterOr format is:
CopyC#
(<i>filter1</i> OR <i>filter2</i> ...)
 where each filter is the string form of an IFilter.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
FilterOr..::..ToWire Method
FilterOr Class See Also Send Feedback
Returns the wire form of this FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this FilterOr.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
FilterOr..::..ValidateSyntax Method
FilterOr Class See Also Send Feedback
Validates the syntax of this FilterOr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A FilterOr is valid if the number of sub-filters (IFilter elements) is greater than zero and each sub-filter is itself valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the FilterAnd does not contain at least one sub-filter.

See Also

FilterOr Class
Endeca.Navigation.Analytics Namespace


GroupBy Class

[image]

Endeca Presentation API
GroupBy Class
Members See Also Send Feedback
A GroupBy defines a single dimension of record grouping for a containing Statement operation.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class GroupBy : IQueryNode
Visual Basic
Public Class GroupBy _
    Implements IQueryNode
Visual C++
public ref class GroupBy : IQueryNode

Remarks

Basically, a GroupBy represents an Endeca property or dimension by which records will be grouped. Input records for the containing Statement operation are grouped together by common assignment from the GroupBy property or dimension. GroupBy instances are encapsulated in a GroupByList, which in turn is set in the Statement object.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..GroupBy

See Also

GroupBy Members
Endeca.Navigation.Analytics Namespace


GroupBy Members

[image] [image]

Endeca Presentation API
GroupBy Members
GroupBy Class Constructors Methods Properties See Also Send Feedback

The GroupBy type exposes the following members.

Constructors

 | Name | Description
Public method | GroupBy(String) | Constructs a new GroupBy.
Public method | GroupBy(String, Int32) | Constructs a new GroupBy, which will request aggregation of records into groups based on the Endeca property or dimension named groupingKey.

Methods

 | Name | Description
Public method | Equals | Indicates whether this GroupBy has an equivalence to a reference GroupBy specified by obj. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hashcode of the object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this GroupBy. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this GroupBy.
Public method | ValidateSyntax | Validates the syntax of this GroupBy.

Properties

 | Name | Description
Public property | Depth | Gets and sets the dimension depth for the aggregates defined by this GroupBy.
Public property | FieldName | Gets and sets the name of the grouping property or dimension for this GroupBy.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


GroupBy Constructor

[image] [image]

Endeca Presentation API
GroupBy Constructor
GroupBy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GroupBy(String) | Constructs a new GroupBy.
Public method | GroupBy(String, Int32) | Constructs a new GroupBy, which will request aggregation of records into groups based on the Endeca property or dimension named groupingKey.

See Also

GroupBy Class
GroupBy Members
Endeca.Navigation.Analytics Namespace


GroupBy Constructor (String)

[image]

Endeca Presentation API
GroupBy Constructor (String)
GroupBy Class Example See Also Send Feedback
Constructs a new GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GroupBy(
    string groupingKey
)
Visual Basic
Public Sub New ( _
    groupingKey As String _
)
Visual C++
public:
GroupBy(
    String^ groupingKey
)

Parameters

groupingKey
Type: System..::..String
The name of the Endeca property or dimension by which the records will be aggregated.

Remarks

This one-parameter constructor will request aggregation of records into groups based on the Endeca property or dimension named groupingKey.

Examples

This code:
CopyC#
GroupByList g = new GroupByList();
GroupBy grByYr = new GroupBy("Year");
g.add(grBy);
 performs a leaf-level grouping of records based on the Endeca dimension named Year.

See Also

GroupBy Class
GroupBy Overload
Endeca.Navigation.Analytics Namespace


GroupBy Constructor (String, Int32)

[image]

Endeca Presentation API
GroupBy Constructor (String, Int32)
GroupBy Class Example See Also Send Feedback
Constructs a new GroupBy, which will request aggregation of records into groups based on the Endeca property or dimension named groupingKey.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GroupBy(
    string groupingKey,
    int depth
)
Visual Basic
Public Sub New ( _
    groupingKey As String, _
    depth As Integer _
)
Visual C++
public:
GroupBy(
    String^ groupingKey,
    int depth
)

Parameters

groupingKey
Type: System..::..String
The name of the Endeca property or dimension by which the records will be aggregated.
depth
Type: System..::..Int32
The level of a dimension hierarchy at which the grouping will be performed.

Remarks

This two-parameter constructor will request aggregation of records into groups based on the Endeca property or dimension named groupingKey. For dimensions, the grouping will depend on the value's ancestor at depth from the root of the dimension's hierarchy.

Note that a depth of zero does not indicate grouping at the root of the hierarchy, but rather it denotes that depth will not be taken into account at all, so grouping will be performed based on the values encountered.

Examples

If a dimension named Region contains a hierarchy of Country, State, and City, and the grouping was desired at the State level (one level below the root of the dimension hierarchy), the constructor code would be:
CopyC#
GroupByList g = new GroupByList();
GroupBy grByReg = new GroupBy("Region",1);
g.add(grByReg);

See Also

GroupBy Class
GroupBy Overload
Endeca.Navigation.Analytics Namespace


GroupBy Methods

[image] [image]

Endeca Presentation API
GroupBy Methods
GroupBy Class See Also Send Feedback

The GroupBy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this GroupBy has an equivalence to a reference GroupBy specified by obj. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hashcode of the object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this GroupBy. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this GroupBy.
Public method | ValidateSyntax | Validates the syntax of this GroupBy.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


Equals Method

[image]

Endeca Presentation API
GroupBy..::..Equals Method
GroupBy Class See Also Send Feedback
Indicates whether this GroupBy has an equivalence to a reference GroupBy specified by obj.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The reference GroupBy with which to compare.

Return Value

true if this GroupBy is the same as obj; false otherwise.

Remarks

Note that the the depth settings of the two GroupBy objects are not compared.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


GetHashCode Method

[image]

Endeca Presentation API
GroupBy..::..GetHashCode Method
GroupBy Class See Also Send Feedback
Returns the hashcode of the object.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hashcode.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
GroupBy..::..ToString Method
GroupBy Class Example See Also Send Feedback
Returns the string form of this GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this GroupBy.

Implements

IQueryNode..::..ToString()()()()

Remarks

The GroupBy format is:
CopyC#
"<i>grouping-key-name</i>"
 if no depth has been set.

The format:

CopyC#
"<i>grouping-key-name</i>:<i>depth</i>"
is used if depth has been specified.

Examples

The string:
CopyC#
Region:2
 is returned if the grouping key is a dimension named Region with a grouping level of 2 (that is, two levels below the root of the dimension hierarchy).

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
GroupBy..::..ToWire Method
GroupBy Class See Also Send Feedback
Returns the wire form of this GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this GroupBy.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
GroupBy..::..ValidateSyntax Method
GroupBy Class See Also Send Feedback
Validates the syntax of this GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A GroupBy is valid if the grouping key name is non-null and non-empty, and the depth is non-negative.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


GroupBy Properties

[image] [image]

Endeca Presentation API
GroupBy Properties
GroupBy Class See Also Send Feedback

The GroupBy type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Gets and sets the dimension depth for the aggregates defined by this GroupBy.
Public property | FieldName | Gets and sets the name of the grouping property or dimension for this GroupBy.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


Depth Property

[image]

Endeca Presentation API
GroupBy..::..Depth Property
GroupBy Class See Also Send Feedback
Gets and sets the dimension depth for the aggregates defined by this GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int Depth { get; set; }
Visual Basic
Public Overridable Property Depth As Integer
    Get
    Set
Visual C++
public:
virtual property int Depth {
    int get ();
    void set (int value);
}

Field Value

An integer representing the level of a dimension hierarchy at which the grouping is performed.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


FieldName Property

[image]

Endeca Presentation API
GroupBy..::..FieldName Property
GroupBy Class See Also Send Feedback
Gets and sets the name of the grouping property or dimension for this GroupBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FieldName { get; set; }
Visual Basic
Public Overridable Property FieldName As String
    Get
    Set
Visual C++
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the Endeca property or dimension by which the records will be grouped.

See Also

GroupBy Class
Endeca.Navigation.Analytics Namespace


GroupByList Class

[image]

Endeca Presentation API
GroupByList Class
Members See Also Send Feedback
A GroupByList is a list of GroupBy instances.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class GroupByList : IObjectList,
    IQueryNode
Visual Basic
Public Class GroupByList _
    Implements IObjectList, IQueryNode
Visual C++
public ref class GroupByList : IObjectList,
    IQueryNode

Remarks

Each GroupBy instance in the GroupByList represents a single dimension of record grouping. Additionally, the GroupByList may be tagged with a method for computing subtotal aggregates, which are basically aggregates grouped by subsets of the GroupBy dimensions.

If an empty GroupByList is attached to a Statement, this indicates that the input records will be GROUPed to a single record.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..GroupByList

See Also

GroupByList Members
Endeca.Navigation.Analytics Namespace


GroupByList Members

[image] [image]

Endeca Presentation API
GroupByList Members
GroupByList Class Constructors Methods See Also Send Feedback

The GroupByList type exposes the following members.

Constructors

 | Name | Description
Public method | GroupByList | Constructs a new, empty GroupByList.

Methods

 | Name | Description
Public method | Add | Appends a GroupBy object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a GroupBy object from the GroupByList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a GroupBy object from the GroupByList.
Public method | Size | Returns the number of GroupBy objects in this GroupByList.
Public method | ToString | Returns the string form of this GroupByList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this GroupByList.
Public method | ValidateSyntax | Validates the syntax of this GroupByList.

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


GroupByList Constructor

[image]

Endeca Presentation API
GroupByList Constructor
GroupByList Class See Also Send Feedback
Constructs a new, empty GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public GroupByList()
Visual Basic
Public Sub New
Visual C++
public:
GroupByList()

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


GroupByList Methods

[image] [image]

Endeca Presentation API
GroupByList Methods
GroupByList Class See Also Send Feedback

The GroupByList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a GroupBy object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a GroupBy object from the GroupByList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a GroupBy object from the GroupByList.
Public method | Size | Returns the number of GroupBy objects in this GroupByList.
Public method | ToString | Returns the string form of this GroupByList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this GroupByList.
Public method | ValidateSyntax | Validates the syntax of this GroupByList.

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
GroupByList..::..Add Method
GroupByList Class See Also Send Feedback
Appends a GroupBy object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The GroupBy object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not a GroupBy object.

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
GroupByList..::..Get Method
GroupByList Class See Also Send Feedback
Gets a GroupBy object from the GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired GroupBy object.

Return Value

The GroupBy object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
GroupByList..::..Remove Method
GroupByList Class See Also Send Feedback
Removes a GroupBy object from the GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the GroupBy object to be removed.

Return Value

The removed GroupBy object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
GroupByList..::..Size Method
GroupByList Class See Also Send Feedback
Returns the number of GroupBy objects in this GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of GroupBy objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
GroupByList..::..ToString Method
GroupByList Class Example See Also Send Feedback
Returns the string form of this GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this GroupByList.

Implements

IQueryNode..::..ToString()()()()

Remarks

The GroupByList format for an empty GroupByList is:
CopyC#
GROUP
 An empty GroupByList indicates a GROUP operation that will result in a single result record.

The format:

CopyC#
GROUP BY <i>grouping-key-name1</i>, ...
is used if the GroupByList has one or more GroupBy objects.

Examples

The string:
CopyC#
GROUP BY Region, Year
 is returned if the aggregated records are grouped by the Region and Year combination.

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
GroupByList..::..ToWire Method
GroupByList Class See Also Send Feedback
Returns the wire form of this GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this GroupByList.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
GroupByList..::..ValidateSyntax Method
GroupByList Class See Also Send Feedback
Validates the syntax of this GroupByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A GroupByList is valid if any GroupBy element it contains is itself valid. An empty GroupByList is valid because it represents grouping to a single record (bucket).

See Also

GroupByList Class
Endeca.Navigation.Analytics Namespace


IExpr Interface

[image]

Endeca Presentation API
IExpr Interface
Members See Also Send Feedback
IExpr is the interface for various types of composable Select derived property expressions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IExpr : IQueryNode
Visual Basic
Public Interface IExpr _
    Inherits IQueryNode
Visual C++
public interface class IExpr : IQueryNode

See Also

IExpr Members
Endeca.Navigation.Analytics Namespace


IExpr Members

[image] [image]

Endeca Presentation API
IExpr Members
IExpr Interface Methods See Also Send Feedback

The IExpr type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node. (Inherited from IQueryNode.)
Public method | ToWire | Returns the wire form of this query node. (Inherited from IQueryNode.)
Public method | ValidateSyntax | Validates the syntax of this query node. (Inherited from IQueryNode.)

See Also

IExpr Interface
Endeca.Navigation.Analytics Namespace


IExpr Methods

[image] [image]

Endeca Presentation API
IExpr Methods
IExpr Interface See Also Send Feedback

The IExpr type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node. (Inherited from IQueryNode.)
Public method | ToWire | Returns the wire form of this query node. (Inherited from IQueryNode.)
Public method | ValidateSyntax | Validates the syntax of this query node. (Inherited from IQueryNode.)

See Also

IExpr Interface
Endeca.Navigation.Analytics Namespace


IFilter Interface

[image]

Endeca Presentation API
IFilter Interface
Members See Also Send Feedback
IFilter is the interface for various types of composable record filter operators.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IFilter : IQueryNode
Visual Basic
Public Interface IFilter _
    Inherits IQueryNode
Visual C++
public interface class IFilter : IQueryNode

See Also

IFilter Members
Endeca.Navigation.Analytics Namespace


IFilter Members

[image] [image]

Endeca Presentation API
IFilter Members
IFilter Interface Methods See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node. (Inherited from IQueryNode.)
Public method | ToWire | Returns the wire form of this query node. (Inherited from IQueryNode.)
Public method | ValidateSyntax | Validates the syntax of this query node. (Inherited from IQueryNode.)

See Also

IFilter Interface
Endeca.Navigation.Analytics Namespace


IFilter Methods

[image] [image]

Endeca Presentation API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node. (Inherited from IQueryNode.)
Public method | ToWire | Returns the wire form of this query node. (Inherited from IQueryNode.)
Public method | ValidateSyntax | Validates the syntax of this query node. (Inherited from IQueryNode.)

See Also

IFilter Interface
Endeca.Navigation.Analytics Namespace


IObjectList Interface

[image]

Endeca Presentation API
IObjectList Interface
Members See Also Send Feedback
IObjectList is an interface for handling a collection of objects.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IObjectList
Visual Basic
Public Interface IObjectList
Visual C++
public interface class IObjectList

See Also

IObjectList Members
Endeca.Navigation.Analytics Namespace


IObjectList Members

[image] [image]

Endeca Presentation API
IObjectList Members
IObjectList Interface Methods See Also Send Feedback

The IObjectList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends an object to the end of the collection
Public method | Get | Returns the object at index
Public method | Remove | Get the object at index and remove it from the list
Public method | Size | Returns the size of this collection

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


IObjectList Methods

[image] [image]

Endeca Presentation API
IObjectList Methods
IObjectList Interface See Also Send Feedback

The IObjectList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends an object to the end of the collection
Public method | Get | Returns the object at index
Public method | Remove | Get the object at index and remove it from the list
Public method | Size | Returns the size of this collection

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
IObjectList..::..Add Method
IObjectList Interface See Also Send Feedback
Appends an object to the end of the collection

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void Add(
    Object obj
)
Visual Basic
Sub Add ( _
    obj As Object _
)
Visual C++
void Add(
    Object^ obj
)

Parameters

obj
Type: System..::..Object
The object to be added

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
IObjectList..::..Get Method
IObjectList Interface See Also Send Feedback
Returns the object at index

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
Object Get(
    int index
)
Visual Basic
Function Get ( _
    index As Integer _
) As Object
Visual C++
Object^ Get(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the object

Return Value

The object

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
IObjectList..::..Remove Method
IObjectList Interface See Also Send Feedback
Get the object at index and remove it from the list

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
Object Remove(
    int index
)
Visual Basic
Function Remove ( _
    index As Integer _
) As Object
Visual C++
Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the object

Return Value

The removed object

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
IObjectList..::..Size Method
IObjectList Interface See Also Send Feedback
Returns the size of this collection

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
int Size()
Visual Basic
Function Size As Integer
Visual C++
int Size()

Return Value

The size

See Also

IObjectList Interface
Endeca.Navigation.Analytics Namespace


IQueryNode Interface

[image]

Endeca Presentation API
IQueryNode Interface
Members See Also Send Feedback
IQueryNode is the interface for all parts of an Endeca Analytics query.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface IQueryNode
Visual Basic
Public Interface IQueryNode
Visual C++
public interface class IQueryNode

See Also

IQueryNode Members
Endeca.Navigation.Analytics Namespace


IQueryNode Members

[image] [image]

Endeca Presentation API
IQueryNode Members
IQueryNode Interface Methods See Also Send Feedback

The IQueryNode type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node.
Public method | ToWire | Returns the wire form of this query node.
Public method | ValidateSyntax | Validates the syntax of this query node.

See Also

IQueryNode Interface
Endeca.Navigation.Analytics Namespace


IQueryNode Methods

[image] [image]

Endeca Presentation API
IQueryNode Methods
IQueryNode Interface See Also Send Feedback

The IQueryNode type exposes the following members.

Methods

 | Name | Description
Public method | ToString | Returns the String form of this query node.
Public method | ToWire | Returns the wire form of this query node.
Public method | ValidateSyntax | Validates the syntax of this query node.

See Also

IQueryNode Interface
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
IQueryNode..::..ToString Method
IQueryNode Interface See Also Send Feedback
Returns the String form of this query node.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
string ToString()
Visual Basic
Function ToString As String
Visual C++
String^ ToString()

Return Value

The String form of this query node.

See Also

IQueryNode Interface
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
IQueryNode..::..ToWire Method
IQueryNode Interface See Also Send Feedback
Returns the wire form of this query node.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
string ToWire()
Visual Basic
Function ToWire As String
Visual C++
String^ ToWire()

Return Value

The wire form of this query node.

See Also

IQueryNode Interface
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
IQueryNode..::..ValidateSyntax Method
IQueryNode Interface See Also Send Feedback
Validates the syntax of this query node.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
void ValidateSyntax()
Visual Basic
Sub ValidateSyntax
Visual C++
void ValidateSyntax()

See Also

IQueryNode Interface
Endeca.Navigation.Analytics Namespace


LookupList Class

[image]

Endeca Presentation API
LookupList Class
Members See Also Send Feedback
LookupList instances represent a list of expressions used to uniquely identify a record in a table (foreign or local). These lookup expressions are objects of type IExpr.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class LookupList : IObjectList, IQueryNode
Visual Basic
Public Class LookupList _
    Implements IObjectList, IQueryNode
Visual C++
public ref class LookupList : IObjectList,
    IQueryNode

Remarks

Lookup expressions provide the ability to refer to values in record sets that have been previously computed. Lookups can only refer to record sets that were grouped and the LookupList must match the GroupBy fields of the lookup record set.

A lookup expression maps a record in the current statement’s record set to a record in the lookup record set. A LookupList should therefore contain the same number of expressions as the size of the GroupByList of the table it is used to key into.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..LookupList

See Also

LookupList Members
Endeca.Navigation.Analytics Namespace


LookupList Members

[image] [image]

Endeca Presentation API
LookupList Members
LookupList Class Constructors Methods See Also Send Feedback

The LookupList type exposes the following members.

Constructors

 | Name | Description
Public method | LookupList | Constructs a new, empty LookupList.

Methods

 | Name | Description
Public method | Add | Appends a lookup expression to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the lookup expression (an IExpr object) from the LookupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a lookup expression (an IExpr object) from the LookupList.
Public method | Size | Returns the number of lookup expressions in this LookupList.
Public method | ToString | Returns the string form of this LookupList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this LookupList.
Public method | ValidateSyntax | Validates the syntax of this LookupList.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


LookupList Constructor

[image]

Endeca Presentation API
LookupList Constructor
LookupList Class See Also Send Feedback
Constructs a new, empty LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public LookupList()
Visual Basic
Public Sub New
Visual C++
public:
LookupList()

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


LookupList Methods

[image] [image]

Endeca Presentation API
LookupList Methods
LookupList Class See Also Send Feedback

The LookupList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a lookup expression to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the lookup expression (an IExpr object) from the LookupList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a lookup expression (an IExpr object) from the LookupList.
Public method | Size | Returns the number of lookup expressions in this LookupList.
Public method | ToString | Returns the string form of this LookupList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this LookupList.
Public method | ValidateSyntax | Validates the syntax of this LookupList.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
LookupList..::..Add Method
LookupList Class See Also Send Feedback
Appends a lookup expression to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The lookup expression (an IExpr object) to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
LookupList..::..Get Method
LookupList Class See Also Send Feedback
Gets the lookup expression (an IExpr object) from the LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired lookup expression.

Return Value

The IExpr object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
LookupList..::..Remove Method
LookupList Class See Also Send Feedback
Removes a lookup expression (an IExpr object) from the LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the IExpr object to be removed.

Return Value

The removed IExpr object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
LookupList..::..Size Method
LookupList Class See Also Send Feedback
Returns the number of lookup expressions in this LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of lookup expressions (IExpr objects) in the collection.

Implements

IObjectList..::..Size()()()()

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
LookupList..::..ToString Method
LookupList Class See Also Send Feedback
Returns the string form of this LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this LookupList.

Implements

IQueryNode..::..ToString()()()()

Remarks

The LookupList format is:
CopyC#
<i>expression1</i>, <i>expression2</i>...
 where expression is the string form of the lookup expression.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
LookupList..::..ToWire Method
LookupList Class See Also Send Feedback
Returns the wire form of this LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this LookupList.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
LookupList..::..ValidateSyntax Method
LookupList Class See Also Send Feedback
Validates the syntax of this LookupList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A LookupList is valid if all of its expressions are themselves valid. Note that a LookupList with no elements is syntactically valid.

See Also

LookupList Class
Endeca.Navigation.Analytics Namespace


OrderBy Class

[image]

Endeca Presentation API
OrderBy Class
Members See Also Send Feedback
An OrderBy defines an ordering on a set of records, based on the natural ordering of the specified field.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class OrderBy : IQueryNode
Visual Basic
Public Class OrderBy _
    Implements IQueryNode
Visual C++
public ref class OrderBy : IQueryNode

Remarks

An OrderBy allows records to be ordered by any of their property, dimension, or derived values, by ascending or descending sort, in any combination. OrderBy instances are encapsulated in an OrderByList, which in turn is set in the Statement.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..OrderBy

See Also

OrderBy Members
Endeca.Navigation.Analytics Namespace


OrderBy Members

[image] [image]

Endeca Presentation API
OrderBy Members
OrderBy Class Constructors Methods Properties See Also Send Feedback

The OrderBy type exposes the following members.

Constructors

 | Name | Description
Public method | OrderBy | Creates a new OrderBy.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this OrderBy. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this OrderBy.
Public method | ValidateSyntax | Validates the syntax of this OrderBy.

Properties

 | Name | Description
Public property | Ascending | Gets and sets the sort direction of this OrderBy.
Public property | FieldName | Gets and sets the name of the sorting property or dimension for this OrderBy.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


OrderBy Constructor

[image]

Endeca Presentation API
OrderBy Constructor
OrderBy Class Example See Also Send Feedback
Creates a new OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OrderBy(
    string fieldName,
    bool isAscending
)
Visual Basic
Public Sub New ( _
    fieldName As String, _
    isAscending As Boolean _
)
Visual C++
public:
OrderBy(
    String^ fieldName,
    bool isAscending
)

Parameters

fieldName
Type: System..::..String
The name of the Endeca property or dimension by which the records will be ordered.
isAscending
Type: System..::..Boolean
true for an ascending sort or false for a descending sort.

Remarks

The new OrderBy specifies a sort on an Endeca property or dimension indicated by fieldName in a sort direction specified by isAscending.

Examples

This sample:
CopyC#
OrderByList o = new OrderByList();
o.add(new OrderBy("Total", false));
 specifies an ordering based on the Total property with a descending sort of the records.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


OrderBy Methods

[image] [image]

Endeca Presentation API
OrderBy Methods
OrderBy Class See Also Send Feedback

The OrderBy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this OrderBy. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this OrderBy.
Public method | ValidateSyntax | Validates the syntax of this OrderBy.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
OrderBy..::..ToString Method
OrderBy Class Example See Also Send Feedback
Returns the string form of this OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this OrderBy.

Implements

IQueryNode..::..ToString()()()()

Remarks

For an ascending sort, the OrderBy format is:
CopyC#
<i>key-sort-name</i> ASC
 For a descending sort, the format is:
CopyC#
<i>key-sort-name</i> DESC
 where key-sort-name is the Endeca property or dimension by which the records will be sorted.

Examples

This string:
CopyC#
YearSales ASC
 is returned if the sorting key is a property named YearSales and an ascending sort direction has been set.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
OrderBy..::..ToWire Method
OrderBy Class See Also Send Feedback
Returns the wire form of this OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this OrderBy.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
OrderBy..::..ValidateSyntax Method
OrderBy Class See Also Send Feedback
Validates the syntax of this OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An OrderBy is valid if the key sorting name is non-null and non-empty.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


OrderBy Properties

[image] [image]

Endeca Presentation API
OrderBy Properties
OrderBy Class See Also Send Feedback

The OrderBy type exposes the following members.

Properties

 | Name | Description
Public property | Ascending | Gets and sets the sort direction of this OrderBy.
Public property | FieldName | Gets and sets the name of the sorting property or dimension for this OrderBy.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


Ascending Property

[image]

Endeca Presentation API
OrderBy..::..Ascending Property
OrderBy Class See Also Send Feedback
Gets and sets the sort direction of this OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Ascending { get; set; }
Visual Basic
Public Overridable Property Ascending As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Ascending {
    bool get ();
    void set (bool value);
}

Field Value

true for an ascending sort or false for a descending sort.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


FieldName Property

[image]

Endeca Presentation API
OrderBy..::..FieldName Property
OrderBy Class See Also Send Feedback
Gets and sets the name of the sorting property or dimension for this OrderBy.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FieldName { get; set; }
Visual Basic
Public Overridable Property FieldName As String
    Get
    Set
Visual C++
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the Endeca property or dimension by which the records will be ordered.

See Also

OrderBy Class
Endeca.Navigation.Analytics Namespace


OrderByList Class

[image]

Endeca Presentation API
OrderByList Class
Members See Also Send Feedback
An OrderByList is a list of OrderBy instances.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class OrderByList : IObjectList,
    IQueryNode
Visual Basic
Public Class OrderByList _
    Implements IObjectList, IQueryNode
Visual C++
public ref class OrderByList : IObjectList,
    IQueryNode

Remarks

Unlike a GroupByList, an OrderByList may not be empty, because an empty list does not imply a repeatable order.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..OrderByList

See Also

OrderByList Members
Endeca.Navigation.Analytics Namespace


OrderByList Members

[image] [image]

Endeca Presentation API
OrderByList Members
OrderByList Class Constructors Methods See Also Send Feedback

The OrderByList type exposes the following members.

Constructors

 | Name | Description
Public method | OrderByList | Constructs a new, empty OrderByList

Methods

 | Name | Description
Public method | Add | Appends an OrderBy object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an OrderBy object from the OrderByList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an OrderBy object from the OrderByList.
Public method | Size | Returns the number of OrderBy objects in this OrderByList.
Public method | ToString | Returns the string form of this OrderByList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this OrderByList.
Public method | ValidateSyntax | Validates the syntax of this OrderByList.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


OrderByList Constructor

[image]

Endeca Presentation API
OrderByList Constructor
OrderByList Class See Also Send Feedback
Constructs a new, empty OrderByList

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public OrderByList()
Visual Basic
Public Sub New
Visual C++
public:
OrderByList()

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


OrderByList Methods

[image] [image]

Endeca Presentation API
OrderByList Methods
OrderByList Class See Also Send Feedback

The OrderByList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends an OrderBy object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets an OrderBy object from the OrderByList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an OrderBy object from the OrderByList.
Public method | Size | Returns the number of OrderBy objects in this OrderByList.
Public method | ToString | Returns the string form of this OrderByList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this OrderByList.
Public method | ValidateSyntax | Validates the syntax of this OrderByList.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
OrderByList..::..Add Method
OrderByList Class See Also Send Feedback
Appends an OrderBy object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The OrderBy object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not an OrderBy object.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
OrderByList..::..Get Method
OrderByList Class See Also Send Feedback
Gets an OrderBy object from the OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired OrderBy object.

Return Value

The OrderBy object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
OrderByList..::..Remove Method
OrderByList Class See Also Send Feedback
Removes an OrderBy object from the OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the OrderBy object to be removed.

Return Value

The removed OrderBy object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
OrderByList..::..Size Method
OrderByList Class See Also Send Feedback
Returns the number of OrderBy objects in this OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of OrderBy objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
OrderByList..::..ToString Method
OrderByList Class Example See Also Send Feedback
Returns the string form of this OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this OrderByList.

Implements

IQueryNode..::..ToString()()()()

Remarks

The OrderByList format is:
CopyC#
ORDER BY <i>key-sort-name1</i><i>sortdir</i>, <i>key-sort-name2</i><i>sortdir</i> ...
 where sortdir is either ASC or DESC.

Examples

The string:
CopyC#
ORDER BY Total DESC
 is returned if the sorting key is a property named Total and a descending sort direction has been set.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
OrderByList..::..ToWire Method
OrderByList Class See Also Send Feedback
Returns the wire form of this OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this OrderByList.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
OrderByList..::..ValidateSyntax Method
OrderByList Class See Also Send Feedback
Validates the syntax of this OrderByList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

An OrderByList is valid if it is non-empty (must contain at least one OrderBy element) and all its OrderBy elements are themselves valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the OrderByList does not contain at least one OrderBy.

See Also

OrderByList Class
Endeca.Navigation.Analytics Namespace


Select Class

[image]

Endeca Presentation API
Select Class
Members See Also Send Feedback
A Select operation represents the assignment of a named derived value to a record produced as the result of a Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Select : IQueryNode
Visual Basic
Public Class Select _
    Implements IQueryNode
Visual C++
public ref class Select : IQueryNode

Remarks

The definition of the derived value is given by an expression.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..Select

See Also

Select Members
Endeca.Navigation.Analytics Namespace


Select Members

[image] [image]

Endeca Presentation API
Select Members
Select Class Constructors Methods Properties See Also Send Feedback

The Select type exposes the following members.

Constructors

 | Name | Description
Public method | Select | Constructs a new Select.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this Select. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this Select.
Public method | ValidateSyntax | Validates the syntax of this Select.

Properties

 | Name | Description
Public property | Expr | Gets and sets the derived property expression for this Select.
Public property | FieldName | Gets and sets the name of the derived property that this Select should produce.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


Select Constructor

[image]

Endeca Presentation API
Select Constructor
Select Class See Also Send Feedback
Constructs a new Select.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Select(
    string field,
    IExpr expr
)
Visual Basic
Public Sub New ( _
    field As String, _
    expr As IExpr _
)
Visual C++
public:
Select(
    String^ field,
    IExpr^ expr
)

Parameters

field
Type: System..::..String
The name of the derived property that this Select should produce.
expr
Type: Endeca.Navigation.Analytics..::..IExpr
The derived property expression as an object of type IExpr.

Remarks

The new Select will associate the result of expr with the derived property named field.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


Select Methods

[image] [image]

Endeca Presentation API
Select Methods
Select Class See Also Send Feedback

The Select type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string form of this Select. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this Select.
Public method | ValidateSyntax | Validates the syntax of this Select.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
Select..::..ToString Method
Select Class Example See Also Send Feedback
Returns the string form of this Select.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this Select.

Implements

IQueryNode..::..ToString()()()()

Remarks

The Select format is:
CopyC#
<i>expression</i> AS <i>derived-prop-name</i>
 where expression is the string form of an IExpr expression and derived-prop-name is the name of the derived property that will be produced.

Examples

This string:
CopyC#
AVG(Amount) / MAX(Amount) AS AvgOverMax
 is returned if the derived property name is AvgOverMax and the expression assigns the ratio of the average Amount value to the maximum "Amount" value.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
Select..::..ToWire Method
Select Class See Also Send Feedback
Returns the wire form of this Select.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this Select.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
Select..::..ValidateSyntax Method
Select Class See Also Send Feedback
Validates the syntax of this Select.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A Select is valid if the derived property name is non-null and non-empty and the expression is valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


Select Properties

[image] [image]

Endeca Presentation API
Select Properties
Select Class See Also Send Feedback

The Select type exposes the following members.

Properties

 | Name | Description
Public property | Expr | Gets and sets the derived property expression for this Select.
Public property | FieldName | Gets and sets the name of the derived property that this Select should produce.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


Expr Property

[image]

Endeca Presentation API
Select..::..Expr Property
Select Class See Also Send Feedback
Gets and sets the derived property expression for this Select.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IExpr Expr { get; set; }
Visual Basic
Public Overridable Property Expr As IExpr
    Get
    Set
Visual C++
public:
virtual property IExpr^ Expr {
    IExpr^ get ();
    void set (IExpr^ value);
}

Field Value

The derived property expression as an object of type IExpr.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


FieldName Property

[image]

Endeca Presentation API
Select..::..FieldName Property
Select Class See Also Send Feedback
Gets and sets the name of the derived property that this Select should produce.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FieldName { get; set; }
Visual Basic
Public Overridable Property FieldName As String
    Get
    Set
Visual C++
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the derived property that this Select should produce.

See Also

Select Class
Endeca.Navigation.Analytics Namespace


SelectList Class

[image]

Endeca Presentation API
SelectList Class
Members See Also Send Feedback
A SelectList is a list of Select expressions.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class SelectList : IObjectList, IQueryNode
Visual Basic
Public Class SelectList _
    Implements IObjectList, IQueryNode
Visual C++
public ref class SelectList : IObjectList,
    IQueryNode

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..SelectList

See Also

SelectList Members
Endeca.Navigation.Analytics Namespace


SelectList Members

[image] [image]

Endeca Presentation API
SelectList Members
SelectList Class Constructors Methods See Also Send Feedback

The SelectList type exposes the following members.

Constructors

 | Name | Description
Public method | SelectList | Constructs a new, empty SelectList.

Methods

 | Name | Description
Public method | Add | Appends a Select object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a Select expression from the SelectList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a Select object from the SelectList.
Public method | Size | Returns the number of Select expressions in this SelectList.
Public method | ToString | Returns the string form of this SelectList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this SelectList.
Public method | ValidateSyntax | Validates the syntax of this SelectList.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


SelectList Constructor

[image]

Endeca Presentation API
SelectList Constructor
SelectList Class See Also Send Feedback
Constructs a new, empty SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public SelectList()
Visual Basic
Public Sub New
Visual C++
public:
SelectList()

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


SelectList Methods

[image] [image]

Endeca Presentation API
SelectList Methods
SelectList Class See Also Send Feedback

The SelectList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Appends a Select object to the end of the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets a Select expression from the SelectList.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes a Select object from the SelectList.
Public method | Size | Returns the number of Select expressions in this SelectList.
Public method | ToString | Returns the string form of this SelectList. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this SelectList.
Public method | ValidateSyntax | Validates the syntax of this SelectList.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


Add Method

[image]

Endeca Presentation API
SelectList..::..Add Method
SelectList Class See Also Send Feedback
Appends a Select object to the end of the collection.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public void Add(
    Object obj
)
Visual Basic
Public Sub Add ( _
    obj As Object _
)
Visual C++
public:
virtual void Add(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
The Select object to be added.

Implements

IObjectList..::..Add(Object)

Exceptions

Exception | Condition
System..::..ArgumentNullException | If obj is a null reference.
System..::..ArgumentException | If obj is not a Select object.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


Get Method

[image]

Endeca Presentation API
SelectList..::..Get Method
SelectList Class See Also Send Feedback
Gets a Select expression from the SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Object Get(
    int index
)
Visual Basic
Public Function Get ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Get(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the desired Select object.

Return Value

The Select object at position index.

Implements

IObjectList..::..Get(Int32)

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


Remove Method

[image]

Endeca Presentation API
SelectList..::..Remove Method
SelectList Class See Also Send Feedback
Removes a Select object from the SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Object Remove(
    int index
)
Visual Basic
Public Overridable Function Remove ( _
    index As Integer _
) As Object
Visual C++
public:
virtual Object^ Remove(
    int index
)

Parameters

index
Type: System..::..Int32
The index offset of the Select object to be removed.

Return Value

The removed Select object that was previously at position index.

Implements

IObjectList..::..Remove(Int32)

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


Size Method

[image]

Endeca Presentation API
SelectList..::..Size Method
SelectList Class See Also Send Feedback
Returns the number of Select expressions in this SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public int Size()
Visual Basic
Public Function Size As Integer
Visual C++
public:
virtual int Size() sealed

Return Value

The number of Select objects in the collection.

Implements

IObjectList..::..Size()()()()

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
SelectList..::..ToString Method
SelectList Class Example See Also Send Feedback
Returns the string form of this SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this SelectList.

Implements

IQueryNode..::..ToString()()()()

Remarks

The SelectList format is:
CopyC#
SELECT <i>expression1</i> AS <i>derived-prop-name1</i>, <i>expression2</i> AS <i>derived-prop-name2</i>...
 where expression is the string form of an IExpr expression and derived-prop-name is the name of the derived property that will be produced.

Examples

The string:
CopyC#
SELECT COUNT(TransId) AS NumTrans
 is returned if the derived property name is NumTrans and the expression uses the COUNT function to compute the number of transactions by the TransId field.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
SelectList..::..ToWire Method
SelectList Class See Also Send Feedback
Returns the wire form of this SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this SelectList.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
SelectList..::..ValidateSyntax Method
SelectList Class See Also Send Feedback
Validates the syntax of this SelectList.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A SelectList is valid if it is non-empty and all its Select elements are themselves valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the SelectList is empty.

See Also

SelectList Class
Endeca.Navigation.Analytics Namespace


Statement Class

[image]

Endeca Presentation API
Statement Class
Members See Also Send Feedback
A Statement represents a pass over a set of input records (those of the FROM table) to generate a set of output records.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Statement : IQueryNode
Visual Basic
Public Class Statement _
    Implements IQueryNode
Visual C++
public ref class Statement : IQueryNode

Remarks

Input records and output records may be filtered; output records are populated with derived values, and with values by which the records are GROUPed. The output record set may be sorted and paged.

A Statement has the form:

  • RETURN {table-name} AS // required: RETURN or DEFINE: see Shown
  • SELECT // required
  • {expr1} AS {field1}, // required: at least one assignment.
  • {expr2} AS {field2},
  • ...
  • WHERE {filter} // optional
  • FROM {table-name} // optional
  • GROUP // optional: or GROUP BY {field}, {field},...
  • HAVING {filter} // optional
  • ORDER BY {field},{field}... // optional
  • PAGE({start}, {end}) // optional

NavStateRecords and AllBaseRecords are reserved table names. NavStateRecords is the default if the FROM clause is omitted.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..Statement

See Also

Statement Members
Endeca.Navigation.Analytics Namespace


Statement Members

[image] [image]

Endeca Presentation API
Statement Members
Statement Class Constructors Methods Properties See Also Send Feedback

The Statement type exposes the following members.

Constructors

 | Name | Description
Public method | Statement | Constructs a new, empty Statement.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetReturnRows | Sets the rows to return for this Statement.
Public method | ToString | Returns the string form of this Statement. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this Statement.
Public method | ValidateSyntax | Validates the syntax of this Statement.

Properties

 | Name | Description
Public property | FirstPage | Gets the first row-number requested.
Public property | FromStatementName | Gets and sets the name of the FROM Statement.
Public property | GroupByList | Gets and sets the GroupByList for this Statement.
Public property | HavingFilter | Gets and sets the HAVING clause for this Statement.
Public property | Name | Gets and sets the name of the current Statement.
Public property | OrderByList | Gets and sets the OrderByList for this Statement.
Public property | Paged | Tests whether this Statement is paged.
Public property | PagesRequested | Gets the number of pages requested.
Public property | SelectList | Gets and sets the list of Select expressions for this Statement.
Public property | Shown | Gets and sets whether the Statement is a Return or Define Statement.
Public property | WhereFilter | Gets and sets the WHERE clause for this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Statement Constructor

[image]

Endeca Presentation API
Statement Constructor
Statement Class See Also Send Feedback
Constructs a new, empty Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Statement()
Visual Basic
Public Sub New
Visual C++
public:
Statement()

Remarks

An empty Statement will act as a simple pass-through of records.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Statement Methods

[image] [image]

Endeca Presentation API
Statement Methods
Statement Class See Also Send Feedback

The Statement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetReturnRows | Sets the rows to return for this Statement.
Public method | ToString | Returns the string form of this Statement. (Overrides Object..::..ToString()()()().)
Public method | ToWire | Returns the wire form of this Statement.
Public method | ValidateSyntax | Validates the syntax of this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


SetReturnRows Method

[image]

Endeca Presentation API
Statement..::..SetReturnRows Method
Statement Class See Also Send Feedback
Sets the rows to return for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetReturnRows(
    int first,
    int num
)
Visual Basic
Public Overridable Sub SetReturnRows ( _
    first As Integer, _
    num As Integer _
)
Visual C++
public:
virtual void SetReturnRows(
    int first,
    int num
)

Parameters

first
Type: System..::..Int32
The starting row.
num
Type: System..::..Int32
The number of rows to return.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


ToString Method

[image]

Endeca Presentation API
Statement..::..ToString Method
Statement Class See Also Send Feedback
Returns the string form of this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string form of this Statement.

Implements

IQueryNode..::..ToString()()()()

Remarks

See the class comments for the form of the Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


ToWire Method

[image]

Endeca Presentation API
Statement..::..ToWire Method
Statement Class See Also Send Feedback
Returns the wire form of this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string ToWire()
Visual Basic
Public Overridable Function ToWire As String
Visual C++
public:
virtual String^ ToWire()

Return Value

The wire form of this Statement.

Implements

IQueryNode..::..ToWire()()()()

Remarks

This method is not intended for public use because the wire format is subject to change.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


ValidateSyntax Method

[image]

Endeca Presentation API
Statement..::..ValidateSyntax Method
Statement Class See Also Send Feedback
Validates the syntax of this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void ValidateSyntax()
Visual Basic
Public Overridable Sub ValidateSyntax
Visual C++
public:
virtual void ValidateSyntax()

Implements

IQueryNode..::..ValidateSyntax()()()()

Remarks

A Statement is valid if (1) the table-name is non-null and non-empty, (2) the SelectList is non-null and valid, and (3) if any of GroupByList, OrderByList, whereFilter, and havingFilter are non-null, they must be valid.

Exceptions

Exception | Condition
Endeca.Navigation.Analytics..::..SyntaxException | If the syntax requirements are not met.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Statement Properties

[image] [image]

Endeca Presentation API
Statement Properties
Statement Class See Also Send Feedback

The Statement type exposes the following members.

Properties

 | Name | Description
Public property | FirstPage | Gets the first row-number requested.
Public property | FromStatementName | Gets and sets the name of the FROM Statement.
Public property | GroupByList | Gets and sets the GroupByList for this Statement.
Public property | HavingFilter | Gets and sets the HAVING clause for this Statement.
Public property | Name | Gets and sets the name of the current Statement.
Public property | OrderByList | Gets and sets the OrderByList for this Statement.
Public property | Paged | Tests whether this Statement is paged.
Public property | PagesRequested | Gets the number of pages requested.
Public property | SelectList | Gets and sets the list of Select expressions for this Statement.
Public property | Shown | Gets and sets whether the Statement is a Return or Define Statement.
Public property | WhereFilter | Gets and sets the WHERE clause for this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


FirstPage Property

[image]

Endeca Presentation API
Statement..::..FirstPage Property
Statement Class See Also Send Feedback
Gets the first row-number requested.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int FirstPage { get; }
Visual Basic
Public Overridable ReadOnly Property FirstPage As Integer
    Get
Visual C++
public:
virtual property int FirstPage {
    int get ();
}

Field Value

If the Statement is paged, returns an integer representing the first row-number requested. If the Statement is not paged, 0 is returned.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


FromStatementName Property

[image]

Endeca Presentation API
Statement..::..FromStatementName Property
Statement Class See Also Send Feedback
Gets and sets the name of the FROM Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string FromStatementName { get; set; }
Visual Basic
Public Overridable Property FromStatementName As String
    Get
    Set
Visual C++
public:
virtual property String^ FromStatementName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the FROM Statement. Note that the name may be null; when the Statement is computed, a missing FROM clause is interpreted as FROM NavStateRecords.

Remarks

The FROM statement is the statement whose records are the input for this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


GroupByList Property

[image]

Endeca Presentation API
Statement..::..GroupByList Property
Statement Class See Also Send Feedback
Gets and sets the GroupByList for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual GroupByList GroupByList { get; set; }
Visual Basic
Public Overridable Property GroupByList As GroupByList
    Get
    Set
Visual C++
public:
virtual property GroupByList^ GroupByList {
    GroupByList^ get ();
    void set (GroupByList^ value);
}

Field Value

The GroupByList for this Statement.

Remarks

The GroupByList determines the way that input records are grouped into result aggregated records.

Basically, each GroupBy in the specified GroupByList represents a grouping property or dimension, and input records are assigned to a resulting aggregate based on their values for these properties and dimensions. Note that if an empty GroupByList is attached to a Statement, it indicates that the input records will be GROUPed to a single record.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


HavingFilter Property

[image]

Endeca Presentation API
Statement..::..HavingFilter Property
Statement Class See Also Send Feedback
Gets and sets the HAVING clause for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IFilter HavingFilter { get; set; }
Visual Basic
Public Overridable Property HavingFilter As IFilter
    Get
    Set
Visual C++
public:
virtual property IFilter^ HavingFilter {
    IFilter^ get ();
    void set (IFilter^ value);
}

Field Value

An IFilter containing the HAVING clause for this Statement.

Remarks

A HAVING clause acts as a filter on output aggregated records. In other words, it specifies a post-filter for this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Name Property

[image]

Endeca Presentation API
Statement..::..Name Property
Statement Class See Also Send Feedback
Gets and sets the name of the current Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the current Statement. If no name has been set, the getting version returns null.

Remarks

The name of the Statement must be non-null for the Statement to be syntactically valid.

Once the query is sent to the MDEX Engine and a response is returned, the Statement name must be used as the parameter to the GetAnalyticsStatementResult(String) method to obtain an AnalyticsStatementResult containing the records associated with the Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


OrderByList Property

[image]

Endeca Presentation API
Statement..::..OrderByList Property
Statement Class See Also Send Feedback
Gets and sets the OrderByList for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual OrderByList OrderByList { get; set; }
Visual Basic
Public Overridable Property OrderByList As OrderByList
    Get
    Set
Visual C++
public:
virtual property OrderByList^ OrderByList {
    OrderByList^ get ();
    void set (OrderByList^ value);
}

Field Value

The OrderByList for this Statement. Note that the OrderByList cannot be empty.

Remarks

The list of OrderBy specifications for the Statement determines the order in which result aggregated records will be returned, and determines the ranks of result aggregated records used by paging controls associated with GroupBy specifications.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Paged Property

[image]

Endeca Presentation API
Statement..::..Paged Property
Statement Class See Also Send Feedback
Tests whether this Statement is paged.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Paged { get; }
Visual Basic
Public Overridable ReadOnly Property Paged As Boolean
    Get
Visual C++
public:
virtual property bool Paged {
    bool get ();
}

Field Value

true if this Statement is paged, false otherwise.

Remarks

A Statement is paged if the application only wants a subset of the records that the Statement computes.

By default, the paged setting is false. Calling the SetReturnRows(Int32, Int32) method sets paged to true.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


PagesRequested Property

[image]

Endeca Presentation API
Statement..::..PagesRequested Property
Statement Class See Also Send Feedback
Gets the number of pages requested.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int PagesRequested { get; }
Visual Basic
Public Overridable ReadOnly Property PagesRequested As Integer
    Get
Visual C++
public:
virtual property int PagesRequested {
    int get ();
}

Field Value

If the Statement is paged, returns an integer representing the number of rows requested. Returns 0 if the Statement is not paged.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


SelectList Property

[image]

Endeca Presentation API
Statement..::..SelectList Property
Statement Class See Also Send Feedback
Gets and sets the list of Select expressions for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual SelectList SelectList { get; set; }
Visual Basic
Public Overridable Property SelectList As SelectList
    Get
    Set
Visual C++
public:
virtual property SelectList^ SelectList {
    SelectList^ get ();
    void set (SelectList^ value);
}

Field Value

A SelectList containing the Select expressions for this Statement.

Remarks

Each Select associates a derived value with each result aggregated record produced by this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


Shown Property

[image]

Endeca Presentation API
Statement..::..Shown Property
Statement Class See Also Send Feedback
Gets and sets whether the Statement is a Return or Define Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual bool Shown { get; set; }
Visual Basic
Public Overridable Property Shown As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Shown {
    bool get ();
    void set (bool value);
}

Field Value

true if the current Statement is a Return statement (indicates that the application wants to see its result records), or false if it is a Define statement (indicates that it is only used as an intermediate calculation).

Remarks

Return means that the results should be returned to the client, while Define means that it will only be used to compute other results.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


WhereFilter Property

[image]

Endeca Presentation API
Statement..::..WhereFilter Property
Statement Class See Also Send Feedback
Gets and sets the WHERE clause for this Statement.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual IFilter WhereFilter { get; set; }
Visual Basic
Public Overridable Property WhereFilter As IFilter
    Get
    Set
Visual C++
public:
virtual property IFilter^ WhereFilter {
    IFilter^ get ();
    void set (IFilter^ value);
}

Field Value

An IFilter containing the WHERE clause for this Statement.

Remarks

The WHERE clause acts as a filter on input records that will be grouped into result aggregates. In other words, it specifies a pre-filter for this Statement.

See Also

Statement Class
Endeca.Navigation.Analytics Namespace


SyntaxException Class

[image]

Endeca Presentation API
SyntaxException Class
Members See Also Send Feedback
Analytics Syntax Exception representing an error due to a malformed query.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class SyntaxException : Exception
Visual Basic
Public Class SyntaxException _
    Inherits Exception
Visual C++
public ref class SyntaxException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Endeca.Navigation.Analytics..::..SyntaxException

See Also

SyntaxException Members
Endeca.Navigation.Analytics Namespace


SyntaxException Members

[image] [image]

Endeca Presentation API
SyntaxException Members
SyntaxException Class Constructors Methods Properties See Also Send Feedback

The SyntaxException type exposes the following members.

Constructors

 | Name | Description
Public method | SyntaxException()()()() | Construct a new, default syntax exception with no message.
Public method | SyntaxException(String) | Construct a new syntax exception with the specified message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyntaxException Class
Endeca.Navigation.Analytics Namespace


SyntaxException Constructor

[image] [image]

Endeca Presentation API
SyntaxException Constructor
SyntaxException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SyntaxException()()()() | Construct a new, default syntax exception with no message.
Public method | SyntaxException(String) | Construct a new syntax exception with the specified message.

See Also

SyntaxException Class
SyntaxException Members
Endeca.Navigation.Analytics Namespace


SyntaxException Constructor

[image]

Endeca Presentation API
SyntaxException Constructor
SyntaxException Class See Also Send Feedback
Construct a new, default syntax exception with no message.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public SyntaxException()
Visual Basic
Public Sub New
Visual C++
public:
SyntaxException()

See Also

SyntaxException Class
SyntaxException Overload
Endeca.Navigation.Analytics Namespace


SyntaxException Constructor (String)

[image]

Endeca Presentation API
SyntaxException Constructor (String)
SyntaxException Class See Also Send Feedback
Construct a new syntax exception with the specified message.

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public SyntaxException(
    string s
)
Visual Basic
Public Sub New ( _
    s As String _
)
Visual C++
public:
SyntaxException(
    String^ s
)

Parameters

s
Type: System..::..String
The message string

See Also

SyntaxException Class
SyntaxException Overload
Endeca.Navigation.Analytics Namespace


SyntaxException Methods

[image] [image]

Endeca Presentation API
SyntaxException Methods
SyntaxException Class See Also Send Feedback

The SyntaxException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SyntaxException Class
Endeca.Navigation.Analytics Namespace


SyntaxException Properties

[image] [image]

Endeca Presentation API
SyntaxException Properties
SyntaxException Class See Also Send Feedback

The SyntaxException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SyntaxException Class
Endeca.Navigation.Analytics Namespace


TestAnalyticsParser Class

[image]

Endeca Presentation API
TestAnalyticsParser Class
Members See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class TestAnalyticsParser
Visual Basic
Public Class TestAnalyticsParser
Visual C++
public ref class TestAnalyticsParser

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Analytics..::..TestAnalyticsParser

See Also

TestAnalyticsParser Members
Endeca.Navigation.Analytics Namespace


TestAnalyticsParser Members

[image] [image]

Endeca Presentation API
TestAnalyticsParser Members
TestAnalyticsParser Class Constructors Methods See Also Send Feedback

The TestAnalyticsParser type exposes the following members.

Constructors

 | Name | Description
Public method | TestAnalyticsParser | Initializes a new instance of the TestAnalyticsParser class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestAnalyticsParser Class
Endeca.Navigation.Analytics Namespace


TestAnalyticsParser Constructor

[image]

Endeca Presentation API
TestAnalyticsParser Constructor
TestAnalyticsParser Class See Also Send Feedback
Initializes a new instance of the TestAnalyticsParser class

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public TestAnalyticsParser()
Visual Basic
Public Sub New
Visual C++
public:
TestAnalyticsParser()

See Also

TestAnalyticsParser Class
Endeca.Navigation.Analytics Namespace


TestAnalyticsParser Methods

[image] [image]

Endeca Presentation API
TestAnalyticsParser Methods
TestAnalyticsParser Class See Also Send Feedback

The TestAnalyticsParser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Main |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestAnalyticsParser Class
Endeca.Navigation.Analytics Namespace


Main Method

[image]

Endeca Presentation API
TestAnalyticsParser..::..Main Method
TestAnalyticsParser Class See Also Send Feedback

Namespace: Endeca.Navigation.Analytics
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public static void Main(
    string[] args
)
Visual Basic
Public Shared Sub Main ( _
    args As String() _
)
Visual C++
public:
static void Main(
    array<String^>^ args
)

Parameters

args
Type: array< System..::..String >[]()[][]

See Also

TestAnalyticsParser Class
Endeca.Navigation.Analytics Namespace


Endeca.Navigation.Charting Namespace

[image]

Endeca Presentation API
Endeca.Navigation.Charting Namespace
Send Feedback

Classes

 | Class | Description
Public class | Cell | Represents a value in a Grid.
Public class | CordaChartBuilder | A helper class to build Corda PopChart charts from Endeca data. It builds the Corda PCXML string that can be used to create the chart.
Public class | Grid | This class represents a grid (or multidimensional array) that is built from Endeca analytics data. The data is stored in a way that is convenient for building graphs, charts, or tables.
Public class | Label | Label represents a Grid label that came from either a dimension value or a property value.

Interfaces

 | Interface | Description
Public interface | Drilldown | This callback interface tells CordaChartBuilder the URLs to use for drilldown.


Cell Class

[image]

Endeca Presentation API
Cell Class
Members See Also Send Feedback
Represents a value in a Grid.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Cell
Visual Basic
Public Class Cell
Visual C++
public ref class Cell

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Charting..::..Cell

See Also

Cell Members
Endeca.Navigation.Charting Namespace


Cell Members

[image] [image]

Endeca Presentation API
Cell Members
Cell Class Methods Properties See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabel | Returns the specified label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a user-readable string representation of the value. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Labels | Returns the labels.
Public property | Value | Returns the value.

See Also

Cell Class
Endeca.Navigation.Charting Namespace


Cell Methods

[image] [image]

Endeca Presentation API
Cell Methods
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabel | Returns the specified label.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a user-readable string representation of the value. (Overrides Object..::..ToString()()()().)

See Also

Cell Class
Endeca.Navigation.Charting Namespace


GetLabel Method

[image]

Endeca Presentation API
Cell..::..GetLabel Method
Cell Class See Also Send Feedback
Returns the specified label.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Label GetLabel(
    int axis
)
Visual Basic
Public Overridable Function GetLabel ( _
    axis As Integer _
) As Label
Visual C++
public:
virtual Label^ GetLabel(
    int axis
)

Parameters

axis
Type: System..::..Int32
The axis that references the label.

Return Value

The specified label (a Label object).

See Also

Cell Class
Endeca.Navigation.Charting Namespace


ToString Method

[image]

Endeca Presentation API
Cell..::..ToString Method
Cell Class See Also Send Feedback
Returns a user-readable string representation of the value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The value as a String.

Remarks

This method is equivalent to the Value property.

See Also

Cell Class
Endeca.Navigation.Charting Namespace


Cell Properties

[image] [image]

Endeca Presentation API
Cell Properties
Cell Class See Also Send Feedback

The Cell type exposes the following members.

Properties

 | Name | Description
Public property | Labels | Returns the labels.
Public property | Value | Returns the value.

See Also

Cell Class
Endeca.Navigation.Charting Namespace


Labels Property

[image]

Endeca Presentation API
Cell..::..Labels Property
Cell Class See Also Send Feedback
Returns the labels.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ArrayList Labels { get; }
Visual Basic
Public Overridable ReadOnly Property Labels As ArrayList
    Get
Visual C++
public:
virtual property ArrayList^ Labels {
    ArrayList^ get ();
}

Field Value

A list containg grid labels (Label objects).

See Also

Cell Class
Endeca.Navigation.Charting Namespace


Value Property

[image]

Endeca Presentation API
Cell..::..Value Property
Cell Class See Also Send Feedback
Returns the value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Value { get; }
Visual Basic
Public Overridable ReadOnly Property Value As String
    Get
Visual C++
public:
virtual property String^ Value {
    String^ get ();
}

Field Value

The value as a String.

See Also

Cell Class
Endeca.Navigation.Charting Namespace


CordaChartBuilder Class

[image]

Endeca Presentation API
CordaChartBuilder Class
Members See Also Send Feedback
A helper class to build Corda PopChart charts from Endeca data. It builds the Corda PCXML string that can be used to create the chart.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class CordaChartBuilder
Visual Basic
Public Class CordaChartBuilder
Visual C++
public ref class CordaChartBuilder

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Charting..::..CordaChartBuilder

See Also

CordaChartBuilder Members
Endeca.Navigation.Charting Namespace


CordaChartBuilder Members

[image] [image]

Endeca Presentation API
CordaChartBuilder Members
CordaChartBuilder Class Constructors Methods Properties See Also Send Feedback

The CordaChartBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | CordaChartBuilder | Constructs a new CordaChartBuilder with the given name and data.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDrilldown | Enables drilldown for this chart.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PCXML | Returns the PCXML for the chart.

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


CordaChartBuilder Constructor

[image]

Endeca Presentation API
CordaChartBuilder Constructor
CordaChartBuilder Class See Also Send Feedback
Constructs a new CordaChartBuilder with the given name and data.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public CordaChartBuilder(
    string graphName,
    Grid grid
)
Visual Basic
Public Sub New ( _
    graphName As String, _
    grid As Grid _
)
Visual C++
public:
CordaChartBuilder(
    String^ graphName,
    Grid^ grid
)

Parameters

graphName
Type: System..::..String
The name of the graph object. Usually the name will be "graph".
grid
Type: Endeca.Navigation.Charting..::..Grid
The data to display (a Grid object). The Grid may have either one axis (for a standard 2-D chart) or 2 axes (for a 3-D cross-tab chart).

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


CordaChartBuilder Methods

[image] [image]

Endeca Presentation API
CordaChartBuilder Methods
CordaChartBuilder Class See Also Send Feedback

The CordaChartBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDrilldown | Enables drilldown for this chart.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


SetDrilldown Method

[image]

Endeca Presentation API
CordaChartBuilder..::..SetDrilldown Method
CordaChartBuilder Class See Also Send Feedback
Enables drilldown for this chart.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SetDrilldown(
    Drilldown drilldown,
    HttpRequest request
)
Visual Basic
Public Overridable Sub SetDrilldown ( _
    drilldown As Drilldown, _
    request As HttpRequest _
)
Visual C++
public:
virtual void SetDrilldown(
    Drilldown^ drilldown,
    HttpRequest^ request
)

Parameters

drilldown
Type: Endeca.Navigation.Charting..::..Drilldown
The Drilldown object which will return the URL to use when a value and/or label are clicked on.
request
Type: System.Web..::..HttpRequest
The current HTTP request, for use in building the new URL.

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


CordaChartBuilder Properties

[image] [image]

Endeca Presentation API
CordaChartBuilder Properties
CordaChartBuilder Class See Also Send Feedback

The CordaChartBuilder type exposes the following members.

Properties

 | Name | Description
Public property | PCXML | Returns the PCXML for the chart.

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


PCXML Property

[image]

Endeca Presentation API
CordaChartBuilder..::..PCXML Property
CordaChartBuilder Class See Also Send Feedback
Returns the PCXML for the chart.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string PCXML { get; }
Visual Basic
Public Overridable ReadOnly Property PCXML As String
    Get
Visual C++
public:
virtual property String^ PCXML {
    String^ get ();
}

Field Value

The PCXML.

See Also

CordaChartBuilder Class
Endeca.Navigation.Charting Namespace


Drilldown Interface

[image]

Endeca Presentation API
Drilldown Interface
Members See Also Send Feedback
This callback interface tells CordaChartBuilder the URLs to use for drilldown.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public interface Drilldown
Visual Basic
Public Interface Drilldown
Visual C++
public interface class Drilldown

See Also

Drilldown Members
Endeca.Navigation.Charting Namespace


Drilldown Members

[image] [image]

Endeca Presentation API
Drilldown Members
Drilldown Interface Methods See Also Send Feedback

The Drilldown type exposes the following members.

Methods

 | Name | Description
Public method | GetLabelURL | Returns the drilldown URL for the specified label.
Public method | GetValueURL | Returns the drilldown URL for this value.

See Also

Drilldown Interface
Endeca.Navigation.Charting Namespace


Drilldown Methods

[image] [image]

Endeca Presentation API
Drilldown Methods
Drilldown Interface See Also Send Feedback

The Drilldown type exposes the following members.

Methods

 | Name | Description
Public method | GetLabelURL | Returns the drilldown URL for the specified label.
Public method | GetValueURL | Returns the drilldown URL for this value.

See Also

Drilldown Interface
Endeca.Navigation.Charting Namespace


GetLabelURL Method

[image]

Endeca Presentation API
Drilldown..::..GetLabelURL Method
Drilldown Interface See Also Send Feedback
Returns the drilldown URL for the specified label.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
string GetLabelURL(
    Label label,
    HttpRequest request
)
Visual Basic
Function GetLabelURL ( _
    label As Label, _
    request As HttpRequest _
) As String
Visual C++
String^ GetLabelURL(
    Label^ label,
    HttpRequest^ request
)

Parameters

label
Type: Endeca.Navigation.Charting..::..Label
The label (a Label object).
request
Type: System.Web..::..HttpRequest
The current request, for help in formulating the URL.

Return Value

The drilldown URL for the label. Returns null to disable drilldown for this label.

See Also

Drilldown Interface
Endeca.Navigation.Charting Namespace


GetValueURL Method

[image]

Endeca Presentation API
Drilldown..::..GetValueURL Method
Drilldown Interface See Also Send Feedback
Returns the drilldown URL for this value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
string GetValueURL(
    Cell val,
    HttpRequest request
)
Visual Basic
Function GetValueURL ( _
    val As Cell, _
    request As HttpRequest _
) As String
Visual C++
String^ GetValueURL(
    Cell^ val,
    HttpRequest^ request
)

Parameters

val
Type: Endeca.Navigation.Charting..::..Cell
The value (a Cell object).
request
Type: System.Web..::..HttpRequest
The current request, for help in formulating the URL.

Return Value

The drilldown URL for the value. Returns null to disable drilldown for this label.

See Also

Drilldown Interface
Endeca.Navigation.Charting Namespace


Grid Class

[image]

Endeca Presentation API
Grid Class
Members See Also Send Feedback
This class represents a grid (or multidimensional array) that is built from Endeca analytics data. The data is stored in a way that is convenient for building graphs, charts, or tables.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Grid
Visual Basic
Public Class Grid
Visual C++
public ref class Grid

Remarks

A Grid returns values based on one or more "axes". For example, suppose you have cross-tab data in the following form:
CopyC#
{ Name: Smith,   Quarter: 1Q06,    Sales: 3000 }
{ Name: Smith,   Quarter: 2Q06,    Sales: 4200 }
{ Name: Smith,   Quarter: 3Q06,    Sales: 4500 }
{ Name: Jones,   Quarter: 1Q06,    Sales: 1200 }
{ Name: Jones,   Quarter: 2Q06,    Sales: 1600 }
 In this case, you create a Grid with 2 axisNames ("Name" and "Quarter") and with a valueName "Sales". The items in each axis (e.g., "Smith" and "3Q06") are called Labels, and are typically used as labels for the axes of a graph or table.

These Labels are also used to look up each value to display using the getValue method. In the example above, getValue for the Labels "Smith" and "3Q06" would return "4500".

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Charting..::..Grid

See Also

Grid Members
Endeca.Navigation.Charting Namespace


Grid Members

[image] [image]

Endeca Presentation API
Grid Members
Grid Class Constructors Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Constructors

 | Name | Description
Public method | Grid(IEnumerator, String, IList) | Constructs a Grid from the specified Endeca analytics data.
Public method | Grid(IEnumerator, String, String) | Convenience constructor for a one-axis Grid. Same as passing in an IList containing the string.
Public method | Grid(IEnumerator, String, String, String) | Convenience constructor for a two-axis Grid. Same as passing in an IList containing the two strings.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabels | Returns the List of Labels for the specified axis.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(IList) | Returns the value at the location indicated by the labels.
Public method | GetValue(Label) | Convenience method. Same as passing in a IList containing the Label.
Public method | GetValue(Label, Label) | Convenience method. Same as passing in an IList containing the two Labels.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SortLabels | Sorts the labels in the specified axis by the specified comparator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NumAxes | Returns the number of axes (i.e., the number of labels) in the Grid.

See Also

Grid Class
Endeca.Navigation.Charting Namespace


Grid Constructor

[image] [image]

Endeca Presentation API
Grid Constructor
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Grid(IEnumerator, String, IList) | Constructs a Grid from the specified Endeca analytics data.
Public method | Grid(IEnumerator, String, String) | Convenience constructor for a one-axis Grid. Same as passing in an IList containing the string.
Public method | Grid(IEnumerator, String, String, String) | Convenience constructor for a two-axis Grid. Same as passing in an IList containing the two strings.

See Also

Grid Class
Grid Members
Endeca.Navigation.Charting Namespace


Grid Constructor (IEnumerator, String, IList)

[image]

Endeca Presentation API
Grid Constructor (IEnumerator, String, IList)
Grid Class See Also Send Feedback
Constructs a Grid from the specified Endeca analytics data.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Grid(
    IEnumerator analytics,
    string valueName,
    IList axisNames
)
Visual Basic
Public Sub New ( _
    analytics As IEnumerator, _
    valueName As String, _
    axisNames As IList _
)
Visual C++
public:
Grid(
    IEnumerator^ analytics,
    String^ valueName,
    IList^ axisNames
)

Parameters

analytics
Type: System.Collections..::..IEnumerator
The analytics results to use.
valueName
Type: System..::..String
The name of the property or dimension that holds the value to chart.
axisNames
Type: System.Collections..::..IList
A list of the names of the properties or dimensions that hold the labels of each axis of the grid.

Exceptions

Exception | Condition
System..::..ArgumentException | If any argument is null.

See Also

Grid Class
Grid Overload
Endeca.Navigation.Charting Namespace


Grid Constructor (IEnumerator, String, String)

[image]

Endeca Presentation API
Grid Constructor (IEnumerator, String, String)
Grid Class See Also Send Feedback
Convenience constructor for a one-axis Grid. Same as passing in an IList containing the string.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Grid(
    IEnumerator analytics,
    string valueName,
    string axis
)
Visual Basic
Public Sub New ( _
    analytics As IEnumerator, _
    valueName As String, _
    axis As String _
)
Visual C++
public:
Grid(
    IEnumerator^ analytics,
    String^ valueName,
    String^ axis
)

Parameters

analytics
Type: System.Collections..::..IEnumerator
The analytics results to use.
valueName
Type: System..::..String
The name of the property or dimension that holds the value to chart.
axis
Type: System..::..String
The names of the properties or dimensions that hold the labels of the axis of the grid.

See Also

Grid Class
Grid Overload
Endeca.Navigation.Charting Namespace


Grid Constructor (IEnumerator, String, String, String)

[image]

Endeca Presentation API
Grid Constructor (IEnumerator, String, String, String)
Grid Class See Also Send Feedback
Convenience constructor for a two-axis Grid. Same as passing in an IList containing the two strings.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public Grid(
    IEnumerator analytics,
    string valueName,
    string axisOne,
    string axisTwo
)
Visual Basic
Public Sub New ( _
    analytics As IEnumerator, _
    valueName As String, _
    axisOne As String, _
    axisTwo As String _
)
Visual C++
public:
Grid(
    IEnumerator^ analytics,
    String^ valueName,
    String^ axisOne,
    String^ axisTwo
)

Parameters

analytics
Type: System.Collections..::..IEnumerator
The analytics results to use.
valueName
Type: System..::..String
The name of the property or dimension that holds the value to chart.
axisOne
Type: System..::..String
The names of the properties or dimensions that hold the labels of the first axis of the grid.
axisTwo
Type: System..::..String
The names of the properties or dimensions that hold the labels of the second axis of the grid.

See Also

Grid Class
Grid Overload
Endeca.Navigation.Charting Namespace


Grid Methods

[image] [image]

Endeca Presentation API
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabels | Returns the List of Labels for the specified axis.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(IList) | Returns the value at the location indicated by the labels.
Public method | GetValue(Label) | Convenience method. Same as passing in a IList containing the Label.
Public method | GetValue(Label, Label) | Convenience method. Same as passing in an IList containing the two Labels.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SortLabels | Sorts the labels in the specified axis by the specified comparator.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Grid Class
Endeca.Navigation.Charting Namespace


GetLabels Method

[image]

Endeca Presentation API
Grid..::..GetLabels Method
Grid Class See Also Send Feedback
Returns the List of Labels for the specified axis.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual ArrayList GetLabels(
    int axis
)
Visual Basic
Public Overridable Function GetLabels ( _
    axis As Integer _
) As ArrayList
Visual C++
public:
virtual ArrayList^ GetLabels(
    int axis
)

Parameters

axis
Type: System..::..Int32
The axis whose labels are to returned.

Return Value

A List of Label objects for the specified axis.

See Also

Grid Class
Endeca.Navigation.Charting Namespace


GetValue Method

[image] [image]

Endeca Presentation API
Grid..::..GetValue Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(IList) | Returns the value at the location indicated by the labels.
Public method | GetValue(Label) | Convenience method. Same as passing in a IList containing the Label.
Public method | GetValue(Label, Label) | Convenience method. Same as passing in an IList containing the two Labels.

See Also

Grid Class
Grid Members
Endeca.Navigation.Charting Namespace


GetValue Method (IList)

[image]

Endeca Presentation API
Grid..::..GetValue Method (IList)
Grid Class See Also Send Feedback
Returns the value at the location indicated by the labels.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Cell GetValue(
    IList labels
)
Visual Basic
Public Overridable Function GetValue ( _
    labels As IList _
) As Cell
Visual C++
public:
virtual Cell^ GetValue(
    IList^ labels
)

Parameters

labels
Type: System.Collections..::..IList
A List of Label objects.

Return Value

The value as a Cell object.

See Also

Grid Class
GetValue Overload
Endeca.Navigation.Charting Namespace


GetValue Method (Label)

[image]

Endeca Presentation API
Grid..::..GetValue Method (Label)
Grid Class See Also Send Feedback
Convenience method. Same as passing in a IList containing the Label.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Cell GetValue(
    Label label
)
Visual Basic
Public Overridable Function GetValue ( _
    label As Label _
) As Cell
Visual C++
public:
virtual Cell^ GetValue(
    Label^ label
)

Parameters

label
Type: Endeca.Navigation.Charting..::..Label
A Label object.

Return Value

The value as a Cell object.

See Also

Grid Class
GetValue Overload
Endeca.Navigation.Charting Namespace


GetValue Method (Label, Label)

[image]

Endeca Presentation API
Grid..::..GetValue Method (Label, Label)
Grid Class See Also Send Feedback
Convenience method. Same as passing in an IList containing the two Labels.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual Cell GetValue(
    Label labelOne,
    Label labelTwo
)
Visual Basic
Public Overridable Function GetValue ( _
    labelOne As Label, _
    labelTwo As Label _
) As Cell
Visual C++
public:
virtual Cell^ GetValue(
    Label^ labelOne,
    Label^ labelTwo
)

Parameters

labelOne
Type: Endeca.Navigation.Charting..::..Label
The first Label object.
labelTwo
Type: Endeca.Navigation.Charting..::..Label
The second Label object.

Return Value

The value as a Cell object.

See Also

Grid Class
GetValue Overload
Endeca.Navigation.Charting Namespace


SortLabels Method

[image]

Endeca Presentation API
Grid..::..SortLabels Method
Grid Class See Also Send Feedback
Sorts the labels in the specified axis by the specified comparator.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual void SortLabels(
    int axis,
    IComparer comparer
)
Visual Basic
Public Overridable Sub SortLabels ( _
    axis As Integer, _
    comparer As IComparer _
)
Visual C++
public:
virtual void SortLabels(
    int axis,
    IComparer^ comparer
)

Parameters

axis
Type: System..::..Int32
The axis to be sorted.
comparer
Type: System.Collections..::..IComparer
The Comparator that will compare the Label objects.

Remarks

The next caller to the GetLabels(Int32) method will receive the labels in sorted order.

See Also

Grid Class
Endeca.Navigation.Charting Namespace


Grid Properties

[image] [image]

Endeca Presentation API
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | NumAxes | Returns the number of axes (i.e., the number of labels) in the Grid.

See Also

Grid Class
Endeca.Navigation.Charting Namespace


NumAxes Property

[image]

Endeca Presentation API
Grid..::..NumAxes Property
Grid Class See Also Send Feedback
Returns the number of axes (i.e., the number of labels) in the Grid.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual int NumAxes { get; }
Visual Basic
Public Overridable ReadOnly Property NumAxes As Integer
    Get
Visual C++
public:
virtual property int NumAxes {
    int get ();
}

Field Value

The number of axes in the Grid.

Remarks

This does not count the values as an axis. This value is equal to the number of label-lists available from GetLabels(Int32).

See Also

Grid Class
Endeca.Navigation.Charting Namespace


Label Class

[image]

Endeca Presentation API
Label Class
Members See Also Send Feedback
Label represents a Grid label that came from either a dimension value or a property value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public class Label
Visual Basic
Public Class Label
Visual C++
public ref class Label

Remarks

Calling ToString()()()() will return the label's text, suitable for presenting as a label on an axis of a chart or table. If this is a dimension value, calling DimVal will return the dimension value (DimVal, which may be useful for navigation.

Inheritance Hierarchy

System..::..Object
Endeca.Navigation.Charting..::..Label

See Also

Label Members
Endeca.Navigation.Charting Namespace


Label Members

[image] [image]

Endeca Presentation API
Label Members
Label Class Methods Properties See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this Label has an equivalence to another Label. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a unique hash code for this Label. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns either the property value or the name of the dimension value. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DimVal | Returns the dimension value.
Public property | Property | Returns the property value.

See Also

Label Class
Endeca.Navigation.Charting Namespace


Label Methods

[image] [image]

Endeca Presentation API
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this Label has an equivalence to another Label. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a unique hash code for this Label. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns either the property value or the name of the dimension value. (Overrides Object..::..ToString()()()().)

See Also

Label Class
Endeca.Navigation.Charting Namespace


Equals Method

[image]

Endeca Presentation API
Label..::..Equals Method
Label Class See Also Send Feedback
Indicates whether this Label has an equivalence to another Label.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The reference Label with which to compare.

Return Value

true if this Label is the same as obj; false otherwise.

See Also

Label Class
Endeca.Navigation.Charting Namespace


GetHashCode Method

[image]

Endeca Presentation API
Label..::..GetHashCode Method
Label Class See Also Send Feedback
Returns a unique hash code for this Label.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code value.

See Also

Label Class
Endeca.Navigation.Charting Namespace


ToString Method

[image]

Endeca Presentation API
Label..::..ToString Method
Label Class See Also Send Feedback
Returns either the property value or the name of the dimension value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The property value, if this is a property. Otherwise returns the name of the dimension.

See Also

Label Class
Endeca.Navigation.Charting Namespace


Label Properties

[image] [image]

Endeca Presentation API
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | DimVal | Returns the dimension value.
Public property | Property | Returns the property value.

See Also

Label Class
Endeca.Navigation.Charting Namespace


DimVal Property

[image]

Endeca Presentation API
Label..::..DimVal Property
Label Class See Also Send Feedback
Returns the dimension value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual DimVal DimVal { get; }
Visual Basic
Public Overridable ReadOnly Property DimVal As DimVal
    Get
Visual C++
public:
virtual property DimVal^ DimVal {
    DimVal^ get ();
}

Field Value

The dimension value (a DimVal object), if this is a dimension. Otherwise returns null.

See Also

Label Class
Endeca.Navigation.Charting Namespace


Property Property

[image]

Endeca Presentation API
Label..::..Property Property
Label Class See Also Send Feedback
Returns the property value.

Namespace: Endeca.Navigation.Charting
Assembly: Endeca.Navigation (in Endeca.Navigation.dll) Version: 6.4.0.0 (6.5.1.8358)

Syntax

C#
public virtual string Property { get; }
Visual Basic
Public Overridable ReadOnly Property Property As String
    Get
Visual C++
public:
virtual property String^ Property {
    String^ get ();
}

Field Value

The property value, if this is a property. Otherwise returns null.

See Also

Label Class
Endeca.Navigation.Charting Namespace