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Preface

Oracle Resources
Table 1: Oracle resources
For help with... Contact...
Support http://www.oracle.com/support

(www.oracle.com/support)

Training https://education.oracle.com
(https://education.oracle.com)

Documentation • Oracle Help Center:
(http://www.oracle.com/goto/FSStorage/docs)

• From Oracle FS System Manager (GUI):
Help > Documentation

• From Oracle FS System HTTP access:
(http://system-name-ip/documentation.php
where system-name-ip is the name or the public
IP address of your system)

Documentation
feedback

http://www.oracle.com/goto/docfeedback
(http://www.oracle.com/goto/docfeedback)

Contact Oracle http://www.oracle.com/us/corporate/contact/index.html
(http://www.oracle.com/us/corporate/contact/
index.html)

Related Documentation
Familiarize yourself with the following related documents:

• Oracle Flash Storage System Glossary

• Oracle Flash Storage System CLI Reference

• Oracle FS1-2 Flash Storage System Release Notes
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CHAPTER 1

Welcome to Oracle FS System Administration

Oracle FS System Manager
Oracle FS System Manager (GUI), pictured below, allows you to deploy, to
provision, to manage, and to maintain an Oracle FS System.

Figure 1: Oracle FS System Manager

The GUI eliminates the complexity of provisioning tiered storage. For example,
you can select the appropriate application storage profile to provision and to
tune the storage easily by preselecting the appropriate QoS parameters.

Using the storage attributes that you provide through the GUI, the system
implements predictive application performance characteristics before it
physically provisions the storage. This feature puts you in control of resource
allocation.

The Pilot runs the management interface for the Oracle FS System. The GUI,
along with the other software that is implemented in the Oracle FS System,
enables policy-based provisioning that has the following features:

19



• QoS Plus, which automatically places parts of a SAN LUN onto
appropriate storage tiers with the goal of balancing the needs of the
business with the management of system resources

• Fault management, which automatically moves system resources to a
partner component to accommodate component failure or replacement
while maintaining data availability

• Guided Maintenance, which guides you through every step of replacing a
hardware component, including the recabling of the component

Note: If you prefer a command line interface for configuring and monitoring the
Oracle FS System, you can use the Oracle FS CLI (FSCLI) to manage the system.

Related Links
Controller Management
Creating Auto-Tiered LUNs
Hardware Management
Oracle FS System CLI
QoS Plus Overview

Accessing Oracle FS System Applications
You can access and download the Oracle FS System applications using the Pilot
web client. Applications include Oracle FS System Manager (GUI), Oracle
MaxMan, Oracle FS CLI (FSCLI), and various other utilities. In addition, the Pilot
web client provides both information about the status of the Oracle FS System
and links to technical documentation.

A username and password are not required to access the web pages that contain
the Management Software, Utilities, and Documentation sections. A username
and password are required to access the Alerts & Events and Information &
Status sections.

The following table summarizes the type of content that is available from the
Pilot web pages.

Welcome to Oracle FS System Administration
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Table 2: Software and system information
Category Description

Oracle FS System
Applications

Provides links to the installation files for Oracle FS System
Manager (GUI) and the Oracle MaxMan applications.

These applications are available in the following formats:

• Windows Installer: Provides the download link for
the Windows installer in MSI format.

• JAR and Run Scripts: Provides the download links
to the self‑contained JAR (Java archive) file and
scripts in ZIP and TAR archive formats.

Technical
Documentation

Provides links to the Oracle FS System technical
documentation in PDF format.

Utilities Provides links to the following downloads:

• Oracle FS CLI
• Oracle FS Virtual Disk Service Provider
• Oracle FS Volume Shadow Copy Service Provider
• The management information base (MIB) text file

for the Oracle Small Network Management
Protocol (SNMP).

• Oracle FS System Statistics Tools

Recent System Alerts
and Events

Provides a list of system alerts that require administrator
action and a list of the last 20 system events.

System Information
and Status

Provides a summary of the Oracle FS System information and
status.

Note: The web page configuration provided by the web server on the Pilot is
simple HTML. You can download this content to a mobile device, which allows
you to check for system alerts and the system status.

Related Links
Download the Oracle FS System Application
Install Oracle FS System Software (MSI)
Install Oracle FS System Software (JAR)

Client Application Download Formats
The client application packages are available in a variety of formats for both
Microsoft Windows and Linux operating systems. For archived file formats, you

Welcome to Oracle FS System Administration
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must decompress the files to your workstation before you can begin the
installation.

Select from the following file formats:

MSI
Specifies a Microsoft Windows installer file. Use this file type to start the
software installation in automatic mode.

ZIP
Specifies a compressed archive file. Use this file type to decompress the
files into a workstation folder for manual installation.

TAR
Specifies a non‑compressed tape file archive method. Use this file type to
extract the files into a workstation folder for manual installation.

TGZ
Specifies a compressed tape file archive method. Use this file type to
decompress and extract the files into a workstation folder for manual
installation.

TXT
Specifies a text file that can be used in any operating system environment.
This file type is not compressed and usually contains other information,
such as configuration details.

Related Links
Download the Oracle FS System Application
Install Oracle FS System Software (MSI)
Install Oracle FS System Software (JAR)

Download the Oracle FS System Application
The software for Oracle FS System Manager (GUI) is available on the Pilot, which
is accessed from a web browser.

1 Start a web browser on your workstation.
2 In the address field, specify your Oracle FS System.

Valid address options:

• The IP address of the Pilot

• The name of the Oracle FS System, if DNS name resolution is
available

3 Click Management Software.
4 Select the link for the software that you want to download.
5 Save the file to your client workstation.

In the next steps you will do one of the following:
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• Start the installation, if you selected an automatic installation file format

• Decompress the archived files, if you selected an archive file format

Related Links
Install Oracle FS System Software (MSI)
Install Oracle FS System Software (JAR)

Install Oracle FS System Software (MSI)
After you download the Windows installer for Oracle FS System Manager (GUI)
or Oracle MaxMan, install the files onto the workstation by running the
Microsoft Windows installation package.

Note: Verify that you are permitted to run an automatic installation.

1 Locate the client software file on the workstation.

For an automatic installation on Microsoft Windows platforms, the file
extension is .msi.

*_x64.msi For 64‑bit hardware
*_x86.msi For 32‑bit hardware

2 Double‑click the file to begin the installation.

3 Follow the instructions for the installation.

When the installation is complete, the following objects are created:

Oracle FS System
Manager

A shortcut on the Windows desktop that permits you
to run Oracle FS System Manager.

Oracle MaxMan A shortcut on the Windows desktop that permits you
to run Oracle MaxMan.

c:\Program Files
\Oracle Corporation

A directory that stores all of the files that are
necessary to run Oracle FS System Manager and
Oracle MaxMan.

Related Links
Install Oracle FS System Software (JAR)

Install Oracle FS System Software (JAR)
After you download the Oracle FS System application archive, extract the files to
a workstation before using the software. The archive contains a self‑contained
JAR (Java archive) file and the scripts needed to run Oracle FS System Manager
(GUI) and Oracle MaxMan applications.

1 Locate the client software archive file on the workstation.

2 Extract the contents of the archive file to a directory of your choosing on
the client host where you expect to be using the software.

Welcome to Oracle FS System Administration
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• For ZIP files, use a ZIP utility to extract the files.

• For TAR or TGZ files, use TAR or a similar utility to extract the files.

3 (Optional) Add the directory where you extracted the contents of the
archive files to your PATH environment variable.
This allows you to run the executable from any directory on your system.

Linux or Unix Edit your login shell to add the directory to your PATH
statement.

Windows Edit the PATH variable by navigating to My Computer >
Properties > Advanced > Environment Variables.

The extraction step creates the following objects for Oracle FS System Manager:

jar The folder containing the jar files for
Oracle FS System Manager

runOracleFSSystemManager.bat (Windows only) The client batch file to
run Oracle FS System Manager

runOracleFSSystemManager.sh The client shell file to run Oracle FS
System Manager

runOracleFSSystemManager.command (Mac OS only) The client shell file to
run Oracle FS System Manager

The extraction step creates the following objects for Oracle MaxMan:

jar The folder containing the jar files for Oracle
MaxMan

runOracleFSMaxMan.bat (Windows only) The client batch file to run Oracle
MaxMan

runOracleFSMaxMan.sh The client shell file to run Oracle MaxMan

runOracleMaxMan.command (Mac OS only) The client shell file to run Oracle
MaxMan

Related Links
Download the Oracle FS System Application
Install Oracle FS System Software (MSI)

Accessing the Oracle FS System
After you have installed Oracle FS System Manager (GUI) software package on a
client workstation, you can run the application to access an Oracle FS System.

Unless the default values have been changed during installation, use the
following values the first time that you use the Primary administrator account to
log in to the GUI:
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Table 3: Default login values
Field Default value
Pilot IP address 10.0.0.2

Login Name administrator

Password pillar

If the default value has been changed for the Pilot, use one of the following
options in the Oracle FS name field:

• If the Pilot IP address has been changed to a customer‑specific address, use
that address.

• If you configured the IP address to a DNS host name, you can use that host
name to log into the Oracle FS System.

The login name does not change.

The password does not change. However, after you login with the default
password, you will be prompted to enter a new password.

Passwords must adhere to the following security policy:

• Must be eight characters to 16 characters in length

• Cannot contain dictionary words

• Cannot be any of the last 50 passwords

Note: The system retains recent passwords for one year.

• Must contain at least one uppercase letter, one lowercase letter, one
numeric character, and one special character

The following list summarizes the tasks that you should perform immediately
after you change the password and log in to the system:

• Document the password and keep the password secure.

• Ensure that the Primary Administrator also obtains this password.

• Set up and test an email address for the Primary Administrator.

• Create one additional Administrator 1 account with a valid email address.
Use the additional Administrator 1 or appropriate level accounts for
routine system administration rather than the Primary administrator
account.

If you exceed the maximum number of administrator login attempts, your
account will disable. Use a Administrator 1 account, if one exists, to reset the
password. Primary system administrators and administrators who are assigned
to the Administrator 1 role can change the password of any administrator
account without knowing the previous password. A Support administrator
cannot reset the Primary system administrator password.
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At any given time, the following number of administrator sessions can be active:

• Five active sessions for each administrator account

• 25 total at any given time

Note: The default time-out period is 20 minutes. When a session is inactive for
more than the time-out period, the system terminates that session, and prompts
you to log in again.

Related Links
Change Administrator Passwords
Modify Security Settings

Providing a Password
In order to protect your security, Oracle enforces strict rules for choosing
passwords for access to Oracle FS System Manager (GUI).

Passwords must adhere to the following security policy:

• Must be eight characters to 16 characters in length

• Cannot contain dictionary words

• Cannot be any of the last 50 passwords

Note: The system retains recent passwords for one year.

• Must contain at least one uppercase letter, one lowercase letter, one
numeric character, and one special character

If you forget the Primary system administrator password, you can reset it using
one of the following methods:

• Use a Administrator 1 account, if one exists, to reset the password. Primary
system administrators and administrators who are assigned to the
Administrator 1 role can change the password of any administrator
account without knowing the previous password. A Support administrator
cannot reset the Primary system administrator password.

• Click Forgot password on the Login screen and follow the instructions in
the Forgot Password dialog. You must have an email address associated
with your account. The system sends a password reset token to the email
address associated with your account. If you receive an email with a
password reset token and you did not request a password reset token,
notify your system administrator.

If you need your Primary system administrator password reset, you can reset it
using one of the following methods:

• Use a Administrator 1 account, if one exists, to reset the password. Primary
system administrators and administrators who are assigned to the
Administrator 1 role can change the password of any administrator
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account without knowing the previous password. A Support administrator
cannot reset the Primary system administrator password.

• Click Reset password on the Login screen and follow the instructions in
the Reset Password dialog. You must have either your old password or
your password token to reset your password. If you do not have your
password token, click Forgot password on the Login screen and follow the
instructions in the Forgot Password dialog.

Related Links
Log In to Oracle FS System Manager

Log In to Oracle FS System Manager
Logging in to Oracle FS System Manager (GUI) gives you access to the Oracle FS
System so that you can perform administrative tasks, such as provisioning and
tuning storage.

Prerequisites: • The GUI software package has been installed on your client
workstation.

• The TCP port 26012 on the Oracle FS System is open and
not blocked.

1 Start the GUI application.

• For the Windows executable, double-click one of the following:

• The Oracle FS System Manager.exe file located at C:
\Program Files\Oracle Corporation\

• The Oracle FS System Manager (GUI) shortcut on the
Windows desktop

• For the Windows archive, run the runOracleFSSystemManager.bat
batch script.

• For Linux and Unix, run the runOracleFSSystemManager.sh shell
script.

• For Mac OS, run the runOracleFSSystemManager.command shell
script.

The login screen appears. If you have an existing installation of the GUI,
you might be prompted to update the install to match the software version
of the Oracle FS System.
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Figure 2: Oracle FS System Manager Login screen

2 For Oracle FS name, specify the Oracle FS System to which you want to
connect.
Valid values:

• IP address of the Pilot

• Oracle FS System name as configured in your site naming services
for the Pilot

3 For Login name, enter your login name.
4 For Password, enter your password.
5 Click Login.

The GUI opens to the System Information overview page, or the last page
you visited when you last logged off.

Related Links
Accessing Oracle FS System Applications
Download the Oracle FS System Application

Status Bar Description
Oracle FS System Manager (GUI) displays information about the operation of the
Oracle FS System in the status bar at the bottom of each overview window.

Figure 3: Oracle FS System Manager status bar

Legend 1  System status 6  Account that is currently logged in

2  Hardware status 7  Number of accounts that are currently logged in

3  System alert 8  Displays all accounts that are currently logged in
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4  Last system alert 9  Progress of current background task

5  System name 10  Displays all background tasks

The following table describes each status bar component.

Table 4: Status bar details
Status bar component Description
System status Displays the overall system status. A status of

Normal (green) requires no action. If, however, the
status is Warning (yellow) or Critical (red), click the
icon to view the System Summary page to identify
the cause of the status.

Hardware status Displays the overall system status of the hardware
components. A status of Normal (uncolored)
requires no action. If, however, the status is
Warning (yellow) or Critical (red), click the icon to
view the Hardware overview page so the cause of
the status can be identified.

System alert To open the System Alerts overview page and to
respond to any events that require intervention,
click this icon. The icon displays only when an
active system alert is present on the Oracle FS
System.

Last system alert If an alert exists, displays the date and time of the
last system alert. This information lets you know,
especially when multiple events exist, whether a
new system alert has been generated. The date and
time displays when an active system alert is
present on the Oracle FS System.

System name If a system name has been configured, displays the
system name. If no system name has been
configured, displays the serial number.

Account that is currently logged
in

Displays the name of the account that is currently
logged in to the system.

Number of accounts that are
currently logged in

Displays the number of accounts currently logged
in to the system.

Displays all accounts that are
currently logged in

Click this icon to open the Current User Session
dialog and to view details of the accounts that are
currently logged in to the system.

Progress of current background
tasks

Displays the progress of the currently running
tasks.

Displays all background tasks Click this icon to open the Background Processes
dialog.
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Related Links
View Currently Logged-in Accounts

Configure Automatic Screen Updates
You can disable automatic screen refresh if your Oracle FS System takes a long
time to refresh the screen contents.

If you have a very large system configuration or a large configuration that
experiences heavy activity, the system might take a few minutes to refresh the
screen contents. This delay might interrupt normal operations on the system. You
can disable the automatic screen refresh and manually update the screen
contents, as necessary.

1 Navigate to Tools > Configure Automatic Screen Updates.

2 Select the option to either enable or disable automatic screen updates.

Tip: To refresh the screen when the automatic updates is disabled, press
Ctrl-Alt-R on your keyboard.

View Currently Logged-in Accounts
You can view the details of the accounts that are logged into the system to see
information such as login name, role, full name, login time, and IP address.

Prerequisite: You must be logged into the Oracle FS System.

You should view a list of accounts logged into the system to decide whether you
need to contact the account owners before you shut down or restart the system.

1 From the Status Bar, click Users.
The Users dialog appears.

2 Review the accounts that are logged into the Oracle FS System.

3 Click Close when you are finished reviewing the list.

Log Out of Oracle FS System Manager
When you have completed your administrative tasks, log out of Oracle FS
System Manager (GUI) to prevent unauthorized users from gaining access to the
Oracle FS System from your workstation.

To log out, navigate to one of the following menu items:

Oracle FS >
Connect to

Allows you to choose another Oracle FS System to log in to.
You are disconnected from the current system and
prompted to log in to the new Oracle FS System.

Oracle FS > Log
off

Disconnects from the current Oracle FS System, allowing
you to log in to another system.

Oracle FS > Exit Disconnects from the current Oracle FS System and closes
the GUI application.
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Licensing the Optional Premium Features
All embedded software and all data services for the Oracle FS System are
enabled at the factory and included in the purchase price, including Oracle
MaxRep for NAS - Terabyte Perpetual. You can purchase additional Oracle
MaxRep premium features.

The following optional premium features are available on the Oracle MaxRep
Replication Engine:

• Oracle MaxRep Asynchronous Replication

• Oracle MaxRep Asynchronous Replication with Application Protection

• Oracle MaxRep Synchronous Replication

• Oracle MaxRep Synchronous Replication with Application Protection

Oracle FS System CLI
The Oracle FS CLI is the command line interface for configuring, operating, and
monitoring an Oracle FS System. The Oracle FS CLI provides the same
capabilities as Oracle FS System Manager (GUI), allowing configuration and
management of the Oracle FS System performed from the command line or
through custom scripts.

The following features are available with Oracle FS CLI:

• Runs as a command‑line interface

• Communicates from the host system to the Oracle FS System Pilot

• Uses familiar conventions for parameters and options, and provides
reasonable default values where possible

• Checks for required sets of parameters and displays error messages if the
required values are missing

• Supports automation through custom scripts using common scripting
languages

• Provides help for each of its commands and subcommands

Welcome to Oracle FS System Administration
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CHAPTER 2

Manage Global Settings

Global Settings Configuration
The first time you log into the Oracle FS System you should perform several
configuration tasks.

The following list summarizes the tasks that help you to configure the system‑
wide settings:

• Set and synchronize the Oracle FS System time with external time servers.

• Define the networking properties, which includes the following tasks:

• Define and configure the IP addressing and the IP characteristics of
the management ports.

• Define an email server in your network that can receive Oracle FS
System alerts and can forward them to administrator email accounts,
for example, to be used to recover account credentials.

• Enable Call‑Home, a feature that notifies Oracle about issues in the
system. The Call‑Home feature of Oracle FS System Manager (GUI)
is integrated with Oracle Auto Service Request (ASR).

• Set system‑wide iSCSI settings if your configuration requires that all
iSCSI connections use the Challenge Handshake Authentication
Protocol (CHAP), access control, or both. If access control is defined
for each initiator, you do not need to configure iSCSI at the system
level.

• Create additional Storage Profiles, if needed.

• Define session time‑out periods and failed login attempts.

• Create additional administrator accounts, especially an account assigned
the Administrator 1 role.

• Define SNMP host settings.

The success of other configuration tasks depends on the system‑wide settings.
For example, if you do not configure the email server, the system cannot send
alerts or the information needed to reset an administrator password.
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Related Links
System Time Synchronization
Network Interfaces
System Notifications
Settings for ASR (Call-Home)
iSCSI Settings
Controller Ports
Storage Profiles
Modifying Security Settings
Administrator Account Management
SNMP Trap Host Management

System Time Synchronization
You can set the properties of the system time to synchronize the Oracle FS
System clock time with a Network Time Protocol (NTP) server or you can set the
date and time manually.

To set the Oracle FS System time, use one of the following options:

Use
External
Time Source

Synchronizes the system time with an external NTP server.

Important: Do not attempt to use a Windows system as an NTP
server unless that system has a third‑party NTP service such as
Meissner installed. Alternatively, use a Linux‑ or Unix‑compatible
NTP server and sync both the Oracle FS System server and the
Windows Time Service to that server. For more information about
configuring time services, refer to Appendix H: Configuring Time
Services for a Heterogeneous UNIX and Windows Environment (http://
technet.microsoft.com/en‑us/library/bb463171.aspx).

Note: If the primary NTP server is not available, the Oracle FS
System consults the secondary servers in round-robin fashion
until a connection is made.

Use Internal
Hardware
Clock

Allows you to set the system time manually. This option is not
valid when Oracle FS SecureWORMfs filesystems exist on the
system. Oracle FS SecureWORMfs requires an NTP server, as does
CIFS authentication as well as many NFS environments.

Related Links
Modify the Oracle FS System Time

Modify the Oracle FS System Time
Configure the Oracle FS System time so that event timestamps and logging
timestamps are accurate and so that time-dependent applications work properly.

1 Navigate to System > Global Settings > System Time.
2 Select Actions > Modify.

Manage Global Settings
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3 Select an option for configuring the system time.

4 Depending on which option you select, enter the NTP server details or
choose the system time using the date and time dialog.

Important: If either option you choose changes the time to be prior to the
current time, the Pilot restarts to implement the new time.

5 Click OK.

After approximately 15 minutes, navigate to System > Alerts and Events and
ensure that there are no Oracle FS System alerts and events indicating that the
NTP sync has failed.

Related Links
Modify System Time Dialog
System Time Synchronization

Network Interfaces
Configure the Oracle FS System management network interfaces to ensure
proper communication with devices on the customer network.

Configuring the system network affects the following types of communication:

• Management traffic between the Pilot and other devices on the customer
network

• The sending of the alerts, notifications of system events, and password
recovery information to an email server

The management interface provides connectivity between the customer
management network and the Oracle FS System Pilot. You can choose from the
following methods to assign the IP addresses to the management interface on the
Pilot:

• Dynamic Host Configuration Protocol (DHCP), which assigns a public IP
address dynamically when the Pilot starts. This address only applies to the
public IP address of the Oracle FS System. DHCP is not supported for the
individual Pilot CU addresses.

• Static IP address, which assigns a permanent, public IP address to the
Oracle FS System, and assigns unique IP addresses to each of the Pilots. If
the management client cannot access the public IP address, the client can
access one of the unique IP addresses of the active Pilot.

The primary and secondary DNS servers provide the name resolution for the
following Oracle FS System features:

• Call‑Home

• Email

• Password recovery

Manage Global Settings
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The Call‑Home feature, when enabled, allows the Oracle FS System to send to
the Oracle Call‑Home server (callhome.support.pillardata.com) the following
types of information:

• System log bundles (for use by Oracle Customer Support)

• System status

• System configuration information

• System statistics

• Internal system logs

• System event notifications (for use by Oracle Auto Service Request (ASR))

• System status

• System configuration information

To send the Call‑Home information, the Pilot uses a DNS server to resolve the
names of the recipients.

You can define a primary DNS server and a secondary DNS server. The system
uses the primary DNS server to resolve host names into IP addresses. If the
primary server cannot be reached, the system uses the secondary DNS server.

Related Links
Configure the Management Interface
Configure DNS Settings

Configure the Management Interface
Configuring the management interface might involve, for example, specifying
the static or dynamic IP addressing method for the Pilot.

You need to choose one of the following options when selecting how you want
the Oracle FS System to assign IP addresses:

Enable DHCP Use if your system assigns IP addresses automatically using a
Dynamic Host Configuration Protocol (DHCP).

Static IP Address Use to manually configure the IP addresses. Enter the values
into the appropriate fields.

Important: When providing static IP addresses for the management interface, be
sure that you enter the correct addresses and that the addresses are reachable
over the management network. Otherwise, you and management clients will not
be able to access the Oracle FS System. If you enter unreachable addresses or
have forgotten the addresses, contact Oracle Customer Support to get an
encrypted file that can be used to reset the IP addresses to the factory default
settings.

1 Navigate to System > Global Settings > Networking.

2 Select Actions > Modify.
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3 From the Interfaces tab, select how you want the Oracle FS System to
assign IP addresses.

4 (Optional) Select the Transmit Setting.

Note: When your Ethernet network contains an auto‑negotiation feature,
leave this option at the default setting, Auto.

5 Click OK.

Related Links
Modify Network Settings, Interfaces Tab

Configure DNS Settings
DNS servers are used by the Pilot to resolve the address of the Oracle Auto
Service Request (ASR) server and to locate mail servers for sending password
recovery instructions.

You can set the primary and secondary DNS server to resolve host names to IP
addresses, for example. Also, the DNS settings allow the Oracle FS System to
send Call‑Home information, password recovery instructions, and event
notifications to designated email recipients.

1 Navigate to System > Global Settings > Networking.

2 Select Actions > Modify.

3 From the Interfaces tab, enter the Primary DNS Server IP address.

4 Enter the Secondary DNS Server IP address.

5 Click OK.

Related Links
Modify Network Settings, Interfaces Tab

System Notifications
Setting up system notifications allows you to define recipients for the event
notifications and the system alerts, and to define the Call‑Home settings that
integrate with Oracle Auto Service Request (ASR).

The Oracle FS System provides various methods of setting up system
notifications, including the following options:

Event
Notifications

Simple Mail Transfer Protocol (SMTP) email messages that
notify recipients of specified system events. System events
include informational events, warning events, and critical events
such as the creation of a logical volume or the occurrence of a
hardware problem or software problem. Event notifications are
optional and, when enabled, supplement normal event logging
and Call‑Home notification.
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System Alerts System Alerts are the notifications that the Oracle FS System
generates to identify conditions that warrant investigation and
action.
System Alerts include the following examples:

• Notifications about resources that are not fully
operational, indicating a need for maintenance.

• Notifications about insufficient storage, indicating a need
for a reallocation of resources, a cleanup of resources, or
possibly the purchase of additional storage. This kind of
information is important when an administrator has
implemented thin provisioning for one or more logical
volumes.

Password
Recovery

The notifications that the Oracle FS System generates to send
users a password token which allows them to reset forgotten
passwords. An email server must be set up and the user must
have a valid email address associated with the user account.

Call‑Home A feature of an Oracle FS System that, when enabled, allows the
system to send the system status information, the appropriate
logs, and the system configuration information to Oracle
Customer Support. If the Auto Service Request (ASR) feature is
enabled, Call‑Home also notifies Oracle Customer Support
about critical issues that exist in the Oracle FS System.

You must define an email server to receive the alerts and the event notifications
and to send the email messages to designated recipients.

The Oracle FS System supports the Simple Network Management Protocol
(SNMP) protocol for monitoring the configuration of various system
components.

Related Links
Managing Event Notifications
Managing System Alerts
Auto Service Requests
Settings for ASR (Call-Home)
Configure Email Notification Settings

Auto Service Requests
Oracle Auto Service Request (ASR) is a feature of Oracle hardware warranty and
Oracle Premier Support for Systems. The ASR feature automatically generates a
service request for specific Oracle FS System software and hardware events. This
automated feature securely expedites system diagnostics, prioritizes your service
requests, and dispatches parts, if needed.

The ASR feature performs the following activities automatically:
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• Generates a service request (SR) when needed

• Handles service requests according to priority

• Dispatches parts when needed

• Attaches Call‑Home logs and log bundles to the SR

My Oracle Support (MOS) allows you, or a customer user administrator (CUA),
to associate your Oracle FS System with a customer support identifier (CSI),
which indicates that your system is licensed for Oracle Customer Support. The
CSI information includes the Oracle FS System serial number, organization, and
the level of support. The CUA is typically a technical representative from your
organization.

The ASR feature relies on the Call‑Home feature of the Oracle FS System to
communicate system events to MOS. After you configure and activate the ASR in
MOS, your system is ready to notify Oracle Customer Support of certain system
events.

For additional ASR support information, refer to Oracle Auto Service Request
(http://www.oracle.com/us/support/auto‑service‑request/index.html) on the
Oracle Support website.

Related Links
Settings for ASR (Call-Home)

Configure Email Notification Settings
Configuring email notifications allows selected individuals to receive the
messages that are generated by the Oracle FS System.

1 Navigate to System > Global Settings > Networking.
2 Select Actions > Modify.
3 Click the Notification tab.
4 (Optional) To be notified by email of each Call‑Home event, select Enable

Email Notification.
5 (Optional) Enter the configuration settings for the email server.
6 Click OK.

Related Links
Modify Network Settings, Notification Tab

Settings for ASR (Call-Home)
Call‑Home is a feature that, when enabled, works with the Auto Service Request
(ASR) feature to send all notifications and associated logs about specific
Oracle FS System events to My Oracle Support (MOS). Configure the Call‑Home
settings correctly to ensure that the MOS system properly manages the events.

Note: No customer data is sent in a Call‑Home transmission.
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The Oracle FS System sends log bundles that contain information about the
system event. The log bundles assist Oracle Customer Support to diagnose the
system event. The collection of the log bundles is initiated by one of the
following methods:

Manual The administrator has requested a log bundle collection.
You can manually send the logs to MOS and associate the
logs with an existing SR number.

Event-triggered When a system event occurs, the Oracle FS System triggers
the following activities:

• Collects log bundles that contain information about
the event

• Uploads the logs to MOS

If necessary, MOS creates an SR for the system event and
then dispatches replacement parts, if appropriate.

Periodic The system sends a notification as scheduled in Oracle FS
System Manager (GUI) configuration.
After the ASR feature is activated, MOS expects to receive
an event, known as a heartbeat, each day from the Oracle FS
System. The daily heartbeat keeps the ASR feature in an
active state. The following options ensure that MOS receives
daily and weekly heartbeat event notifications:

• Standard periodic Call‑Home
• Larger periodic Call‑Home

For both options, do not change the option schedules.
If the daily heartbeats are not received, MOS creates an SR
indicating that the periodic heartbeat is overdue. MOS then
dispatches the SR to Oracle Customer Support for
resolution.

The Oracle FS System maintains a directory of log collections, each of which
represents an event or a manual log bundle. You can select a log bundle file, a
range of log bundle files, or a group of log bundle files to download or transmit
to MOS. The name of each log bundle indicates the reason, date, and time (GMT)
that the bundle was created, as well as the reason, date, and time the previous
bundle was created.

Oracle Customer Support might request that you send multiple log bundles to
MOS. When you create a manual log bundle, you can add an SR number in the
Notes field. MOS then automatically associates that log bundle with your active
SR.

You can send the log bundles to a local server, if necessary. However, sending log
bundles to the local server disables all ASR functionality.
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Related Links
Managing Event Logs
System Log Bundles

Configure Call-Home for ASR
Configure the Call‑Home options to ensure that the Oracle FS System sends
specific event notifications to My Oracle Support (MOS). MOS then receives
these notifications and, if necessary, initiates a service request (SR).

Prerequisites • If the Oracle FS System is configured for Call‑Home
options and Auto Service Request (ASR), and the
connection to the Call‑Home server is direct, without
a proxy, then all firewalls must allow all three Pilot IP
addresses to make outbound connections on TCP Port
443 to the Call‑Home server at Oracle.

• If the Oracle FS System is configured for Call‑Home
options and ASR, but is configured to use a proxy,
then the proxy must be configured to accept
connections from all three Pilot IP addresses and
allow them to connect from the proxy to the Oracle
Call‑Home server on port 443.

• Any firewalls between the Pilots and the proxy must
allow the TCP port configured for the Pilot to the
proxy connections to pass through firewalls for all
three Pilot IP addresses.

You also configure Call‑Home options that keep the ASR feature active. MOS
expects to receive an event, known as a heartbeat, each day from the Oracle FS
System. This heartbeat is controlled by the Enable standard periodic Call-Home
option.

1 Navigate to System > Global Settings > Networking.

2 Select Actions > Modify.

3 Click the Notification tab.

4 Select the Enable event triggered Call-Home option.

5 Select the Enable standard periodic Call-Home option.

Note: Accept the default daily periodic interval. The ASR feature expects a
daily Call‑Home notification.

6 Select the Enable larger periodic Call-Home option.
Accept the default weekly periodic interval.

7 Verify that the Use Oracle Server option is selected.

8 Accept the default settings for the Use Oracle Server option.

Note: Do not alter the server name of the HTTP Server address.
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Note: If your environment does not use a proxy, you must configure at
least one DNS server. Ensure that the DNS server resolves to the host name
of the Oracle server: callhome.support.pillardata.com.

9 (Optional) Select Use Proxy and enter the proxy server address, port
number, and protocol type as provided by your proxy administrator.

Note: Ensure that the proxy server, if used, resolves the host name of the
Oracle server: callhome.support.pillardata.com.

10 Select Enable large file transfers.

Note: This option ensures that Oracle Customer Support receives the
detailed logs that are created for an event.

11 Accept the default value for the Number of recent events to send in
header option.

Note: An Oracle Customer Support professional might request that you
change this value for a specific purpose.

12 Click OK.

You can test the Call‑Home settings from the Networking overview page of the
System tab.

Related Links
Modify Network Settings, Notification Tab
Configure the Management Interface
Settings for ASR (Call-Home)
Configure Call-Home for ASR
Activate ASR (Test Call-Home)
Upload the Call-Home Matrix

Activate ASR (Test Call-Home)
After you have configured Call‑Home for the Auto Service Request (ASR)
feature, send an ASR activation request to My Oracle Support (MOS).

Prerequisites: • Call‑Home is configured to access the ASR functions
in MOS.

• Event triggering and periodic triggering for
Call‑Home are enabled and, the parameters are set to
the default settings.

• Administrator privileges exist to the ASR asset that is
registered in MOS.

1 Navigate to System > Global Settings > Networking.

2 To send the ASR activation request, select Actions > Test Call‑Home.

3 Confirm that you want to send test Call‑Home information, and click OK.
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The Call‑Home test is an ASR activation request in MOS. MOS should
receive your request in a few minutes, but no longer than 60 minutes.

Note: You can repeat the activation request again, as necessary.

You or the customer user administrator (CUA) performs the following steps to
verify that the ASR activation request was successful.

4 Verify the receipt of an email from MOS with instructions to complete the
ASR activation process.
For information that describes how to complete the activation process,
login to My Oracle Support (https://support.oracle.com/). Search for the
article titled “How to complete Auto Service Request (ASR) asset activation
using My Oracle Support.”

5 Log in to MOS and verify that the ASR asset status shows “pending”.
An “inactive” state means that MOS has not received your activation
request.

If you did not receive an email from MOS, or if the ASR asset in MOS is
“inactive”, then perform the detailed ASR activation (Call‑Home)
troubleshooting.

Note: Do not contact Oracle Customer Support until you have completed the
troubleshooting checks.

Related Links
Networking Overview Page

ASR Activation (Call-Home) Troubleshooting
You might need to troubleshoot the Oracle Auto Service Request (ASR) activation
request when you have not received an email from My Oracle Support (MOS) in
response to an activation request.

You can check the following resources to troubleshoot where the ASR activation
request communications might be failing.

Call-Home
Succeeded

A Call‑Home Succeeded Event Log message means that the
Oracle FS System has successfully sent the Call‑Home event
or activation request.
If you see the Call‑Home Succeeded Event Log message,
check the following items:

• Receipt of an email notification from MOS within 60
minutes

• ASR asset in MOS has a “pending” status

If either of these checks fail, and your system has a proxy
configured, then check the proxy logs to determine if the
connection to the Oracle server was successful. If the proxy
logged an error, correct the proxy settings in your network
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or correct the Oracle FS System proxy configuration. Verify
your updates by running the ASR activation request again.

Call-Home
Failed

A Call‑Home Failed event creates a System Alert and an
Event Log records the system fault.
View the properties of the event. If you received the error
EventParameters.Callhome.error.
1:HTTPS_UNKNOWN_HOST, then Call‑Home failed to locate a
server.
Verify the following criteria:

• The Oracle FS System can contact the configured DNS
servers.

• The DNS servers can resolve the host name of the
Oracle server, callhome.support.pillardata.com.

If another error message is present, save the event message
by using the Copy to Clipboard option from the Event
Properties dialog. Contact Oracle Customer Support, if
further assistance is required.

Related Links
Settings for ASR (Call-Home)
Activate ASR (Test Call-Home)
Display the Event Properties
Manage the System Alerts

Upload the Call-Home Matrix
Upload a custom Call‑Home matrix to update the list of events that trigger a
Call‑Home event, or to update the logs that are collected for the event.

Prerequisites: • You must be logged in as a Support administrator to
access a Call‑Home matrix.

• You must obtain an updated Call‑Home matrix from
Oracle Customer Support.

Important: A software update overwrites the Call‑Home matrix. You might either
need to upload the custom matrix after a software update or to obtain a new
matrix after the software update. Contact Oracle Customer Support for
information about the impact that the new Call‑Home matrix might have on your
system.

1 Navigate to System > Global Settings > Networking.
2 Select Actions > Upload Call‑Home Matrix.
3 From the Upload Call‑Home Matrix dialog, click the browse button […] to

proceed.
4 Navigate to and select the Call‑Home matrix file that you received from

Oracle Customer Support.
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5 Click Open.

6 From the Upload Call‑Home Matrix dialog, click OK to upload the matrix
file.

Verify your Call‑Home settings after uploading any custom matrix file.

Related Links
Networking Overview Page

iSCSI Settings
If you have any iSCSI hosts that are configured to use Challenge Handshake
Authentication Protocol (CHAP), access control, or both, you must also set up
system‑wide iSCSI settings on the Oracle FS System. Configuring the iSCSI
settings defines the authentication methods and the access controls on the
Oracle FS System that the SAN hosts must match to gain access to the system.

If you have CHAP and access control configured for each initiator, you do not
need to configure iSCSI globally.

The Internet Storage Name Service (iSNS) facilitates the discovery, the
management, and the configuration of iSCSI devices on a TCP/IP network. iSNS
provides intelligent storage discovery and intelligent management services that
are comparable to those services that are found in Fibre Channel networks. iSNS
allows a normal IP network to function in a manner that is similar to that of a
storage area network.

For the iSNS feature to work properly, configure all iSCSI ports on the Oracle FS
System to have access to the same primary iSNS server. This rule is necessary so
that all of the iSCSI ports get the same result when querying the iSNS database
for the set of initiators that are members of the discovery domain set that is
associated with the Oracle FS System.

Important: If an iSCSI port has no access or loses access to the iSNS server, the
Oracle FS System reports the iSNS error events but continues to operate
normally. For iSNS access control to function correctly, at least one iSCSI port on
the Oracle FS System must have access to the iSNS server during a system restart;
otherwise, all iSCSI logins are rejected.

Related Links
Configure iSCSI System Settings

Configure iSCSI System Settings
You can set the system‑wide iSCSI authentication settings for the iSCSI initiator
ports, which would apply to all iSCSI hosts.

1 Navigate to System > Global Settings > Networking.

2 Select Actions > Modify.
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3 From the iSCSI tab, enter values to configure the initiator ports.
4 Click OK.

Related Links
Modify Network Settings, iSCSI Tab
iSCSI Settings

Modify iSCSI Port Settings
You can change the default values of the iSCSI port settings. For example, you
might need to change the maximum transmission unit (MTU) of a port in one of
the Controllers.

The default action that the Oracle FS System uses for all iSCSI ports is to interpret
the IP address, the subnet mask, and the gateway address using Dynamic Host
Configuration Protocol (DHCP). If you want to assign these values manually,
modify each port with the values that you want to use.

1 Navigate to System > Global Settings > Controller Ports.
2 From the Controller Ports overview page, select either a slot or a port that

you want to modify.
3 Select Actions > Modify Port Settings.
4 Make any necessary changes.
5 Click OK.

Related Links
Modify Controller Port Settings Dialog
Modify a Host: Reconfigure iSCSI Access Settings
iSCSI Settings

Controller Ports
Oracle FS System Manager (GUI) allows you to update the protocol properties of
a Controller for Ethernet, Fibre Channel, or iSCSI.

You can modify the following aspects of the Controller ports:

• The protocol that is used

• Whether link aggregation is enabled

• The management priority value used in link negotiation and identification
for the aggregated ports

You can change port provisioning except for the following caveats:

• Cannot change the port provisioning for Ethernet ports or for SAS ports.

• Can only toggle the port provisioning between FC and iSCSI. If you do
change the port provisioning, you must replace the small form factor (SFP)
to match the provisioning.
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• All HBA ports must be provisioned identically. For example, Port 0 cannot
be FC and Port 1 be iSCSI.

The system allows you to change port provisioning while the system is running.
The system applies the port provisioning to both nodes in a Controller pair.

Important: Do not change port provisioning unless you are prepared for all
clients to temporarily lose access. Changing port provisioning restarts the
controller pair. This is a system restart.

Related Links
Managing SAN Host Entries
View a Summary of all the Controller Ports
View the Port Details for all the Controllers
View the Port Details for a Controller
View the Settings for a Controller Port
Manage Port Provisioning for a Controller

View a Summary of all the Controller Ports
The Controller Ports overview page displays the topology properties of the
network ports for each of the Oracle FS System Controllers.

From the Controller Ports overview page, you have the option to view and to
modify the properties of selected Controllers and selected ports.

1 Navigate to System > Global Settings > Controller Ports.

2 Verify that the summary information is what you expect.

Related Links
Controller Ports Overview Page
View the Port Details for all the Controllers
View the Port Details for a Controller
View the Settings for a Controller Port
Manage Port Provisioning for a Controller

View the Port Details for all the Controllers
You can use Oracle FS System Manager (GUI) to view the port details for the
Controllers in one screen. Also, you can view separately the various protocols
that the Controller supports.

1 Navigate to System > Global Settings > Controller Ports.

2 Select Actions > View Port Settings.
The View Controller Port Settings dialog appears, displaying all of the port
details for all of the Controllers.

3 Click the appropriate tab to view the Controller port settings.
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4 Verify that the summary information is what you expect.

5 Click Close.

Related Links
View Controller Port Settings, Ethernet Tab
View a Summary of all the Controller Ports
View the Port Details for a Controller
View the Settings for a Controller Port
Manage Port Provisioning for a Controller

View the Port Details for a Controller
You can use Oracle FS System Manager (GUI) to view the port details for the
Controllers in one screen. Also, you can view separately the various protocols
that the Controller supports.

1 Navigate to System > Global Settings > Controller Ports.

2 Select a Controller.

3 Select Actions > View Port Settings.
The View Controller Port Settings dialog appears displaying each of the
port types on a different tab.

4 Click the appropriate tab to view the details of the Controller port.

5 Verify the summary information is what you expect.

6 Click Close.

Related Links
View Controller Port Settings, Ethernet Tab
View a Summary of all the Controller Ports
View the Port Details for all the Controllers
View the Settings for a Controller Port
Manage Port Provisioning for a Controller

View the Settings for a Controller Port
The Controller Ports overview page displays the topology properties of the
network ports for each of the Oracle FS System Controllers.

1 Navigate to System > Global Settings > Controller Ports.

2 Select a Controller port.

3 Select Actions > View Port Settings.

4 Verify that the summary information is what you expect.

5 Click Close.
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Related Links
View Controller Port Settings, Ethernet Tab
View a Summary of all the Controller Ports
View the Port Details for all the Controllers
View the Port Details for a Controller
Manage Port Provisioning for a Controller

Manage Port Provisioning for a Controller
You can change the port protocol at the Controller level. You can also specify
whether the Ethernet ports are to be aggregated into a single link and the
aggregation priority.

The system allows you to change port provisioning while the system is running.
The system applies the port provisioning to both nodes in a Controller pair.

Important: Do not change port provisioning unless you are prepared for all
clients to temporarily lose access. Changing port provisioning restarts the
controller pair. This is a system restart.

If you select the entire Controller, you can change the protocol supported by a
slot. If the protocol is Ethernet, you can aggregate the ports into a single link.

If you select a Controller slot, you can change the protocol that the slot supports
(affects all of the ports in that slot). If the slot supports Ethernet, you can change
whether the all of the ports in the slot are to be aggregated.

If you select a particular port, you can change the protocol that the port supports.
If the port supports Ethernet, you can change whether the all of the ports in the
slot are to be aggregated.

1 Navigate to System > Global Settings > Controller Ports.

2 Select a Controller.

3 Select Actions > Manage Port Provisioning.

4 Select a Controller Slot Number and change the protocol properties as
needed.

5 Click OK.
Any necessary changes are mirrored to the peer controller, and the system
restarts.

Related Links
Manage Port Provisioning Dialog
View a Summary of all the Controller Ports
View the Port Details for all the Controllers
View the Port Details for a Controller
View the Settings for a Controller Port
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Storage Profiles

When configuring a logical volume, you can select a collection of predefined
properties to apply to that volume. This collection of properties is called a Storage
Profile.

When using a specific Storage Profile, you can select a profile that you have
previously created and saved, one of the pre‑configured profiles, or create a new
profile.

After a volume is created using a Storage Profile, removing the profile does not
affect the performance characteristics of that volume.

The following properties define a Storage Profile:

RAID level Identifies the storage mechanism that is used to enhance the
ability of the system to recover data from the loss of one or more
drives.

Read ahead Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the amount of
additional data, if any, that the system places into the Controller
cache.

Priority Identifies the priority that the system gives to various
operational aspects of a logical volume, such as the Controller
processing queue. The processing‑queue priority defines the
percentage of the Controller CPU cycles that are dedicated to the
volume. Identifies as well where the data is striped on rotating
drives.

Stripe width Identifies the number of drive groups over which the data is
written.

Writes Identifies the write‑caching rules to use for the profile.

Preferred
Storage
Classes

Identifies the type of physical media on which the data is stored.

Related Links
Managing Storage Profiles
Storage Tiers and Storage Profiles

Storage Tiers and Storage Profiles
For all of the predefined Storage Profiles, the most preferred Storage Class and
the RAID level always correspond to a valid storage tier.

For any Storage Domain, eight different types of storage tiers are possible for
holding auto‑tiered LUNs. The following table summarizes the possible storage
tiers in a Storage Domain:
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Table 5: Possible storage tiers in a Storage Domain
 Storage tier

Storage class Tier 1 Tier 2
Capacity HDD RAID 6 RAID 10

Capacity SSD RAID 5 RAID 10

Performance HDD RAID 5 RAID 10

Performance SSD RAID 5 RAID 10

In any given Storage Domain, however, only some of those tiers are present.

When creating or modifying an auto‑tiered LUN, if you use a Storage Profile to
define the QoS characteristics of the LUN, the system determines the starting
storage tier for the LUN by evaluating the desired Storage Classes and the RAID
level using the following process:

• First, from the desired Storage Classes, the system selects the best Storage
Class that is present in the Storage Domain.

• If none of the desired Storage Classes are present, the system returns an
error.

Note: This condition can only occur for custom storage profiles.

• Using that Storage Class, the system changes the RAID level from RAID 5
to RAID 6 or from RAID 6 to RAID 5, depending on whether the change is
necessary to match one of the tiers.

Managing Storage Profiles
You can use a Storage Profile to configure the Quality of Service (QoS) properties
automatically when you create a logical volume.

A Storage Profile is defined as follows: A set of QoS attributes that can be used to
configure a logical volume. Oracle provides a collection of Storage Profiles that
are optimized for specific uses within an application context. Administrators can
select one of the available profiles, create a new profile, or modify an existing
profile.

The Performance Benchmark Storage Profile is designed for performance testing
purposes only. This Storage Profile is not recommended for most applications
because it uses the system resources in a way that negatively impacts other
applications and interferes with the functioning of other volumes in the Storage
Domain. After creating a volume that uses the Performance Benchmark Storage
Profile, delete the Performance Benchmark volume before you configure normal
volumes for applications.
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Related Links
Create a Storage Profile
Duplicate a Storage Profile
View Storage Profiles
Delete a Storage Profile

Create a Storage Profile

You can create a Storage Profile that defines a collection of Quality of Service
(QoS) properties that differ in some way to the Storage Profiles that have been
predefined in the system.

Important: When creating a Storage Profile, you should be familiar with the
interactions among the attributes and the potential effects on system
performance.

Oracle‑supplied profiles are displayed with a type of System. Custom profiles are
displayed with a type of Custom.

1 Navigate to System > Global Settings > Storage Profiles.

2 Select Actions > Create Storage Profile.

3 Set the QoS properties as needed.
For the name of the Standard Profile, enter an appropriate value. For all
other properties, select the desired value from the drop‑down list.

4 Click OK.
After saving a profile, you cannot make changes to it. You can only delete
the profile.

Related Links
Create Storage Profile Dialog
Duplicate a Storage Profile
View Storage Profiles
Delete a Storage Profile

Duplicate a Storage Profile

You can create a new Storage Profile by duplicating an existing profile.

Duplicating a profile copies the properties of the original profile to a new profile.
You can then customize the new profile by changing any of the existing
properties.

1 Navigate to System > Global Settings > Storage Profiles.

2 Select the Storage Profile you want to duplicate.

3 Select Actions > Duplicate Storage Profile.

4 Change the existing QoS properties as needed.
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For the name of the Standard Profile, enter an appropriate value. For all
other properties, select the desired value from the drop‑down list.

5 Click OK.

Related Links
Duplicate Storage Profile Dialog
Create a Storage Profile
View Storage Profiles
Delete a Storage Profile

View Storage Profiles
Before using a Storage Profile to create a logical volume, you can display the
Quality of Service (QoS) properties of the profile to determine whether those
properties are appropriate for your needs.

Oracle FS System Manager (GUI) lists two types of Storage Profiles:

Custom A custom profile that was created by a storage administrator.
System An Oracle‑provided profile.

1 Navigate to System > Global Settings > Storage Profiles.
The system displays a complete list of QoS properties for all available
profiles.

2 To view a specific storage profile setting, choose a profile and then select
Actions > View Storage Profile.

3 Verify that the property information is what you expect.

4 Click Close.

Related Links
View Storage Profile Dialog
Create a Storage Profile
Duplicate a Storage Profile
Delete a Storage Profile

Delete a Storage Profile

When a custom Storage Profile is no longer needed, you can remove it from the
system. You cannot delete Oracle‑supplied profiles (type of System).

1 Navigate to System > Global Settings > Storage Profiles.

2 Select the custom Storage Profile that you want to delete.

3 Select Actions > Delete Storage Profile.
The Delete Storage Profile dialog appears.

4 Click OK.
The custom Storage Profile is deleted from the system.
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Note: Volumes that were created using the profile are not affected when
the storage profile is deleted. The volumes created using the profile
continue to function normally.

Related Links
Create a Storage Profile
Duplicate a Storage Profile
View Storage Profiles

Modifying Security Settings
You can update the account security properties and the login welcome message
using the security settings in Oracle FS System Manager.

You can change the following global security settings for system administrator
accounts:

• Set the number of consecutive failed login attempts that the Oracle FS
System allows. When the threshold is exceeded, the system disables the
account and writes an entry in the event log. Only a Primary Administrator
or an Administrator 1 can re‑enable the account. After the account is re‑
enabled, the system resets the counter upon a successful login. The failed
login attempts value must be between 1 and 20.

• Set the session time-out so that the Oracle FS System terminates a session
after a given period of inactivity. The session time-out value must be
between 1 and 999 minutes (the default is 20 minutes).

Related Links
Modify Security Settings
Modify the Login Screen Message

Modify Security Settings
Configure the Oracle FS System security by limiting the number of failed login
attempts and by setting a time limit for inactive login sessions.

1 Navigate to System > Global Settings > Security.

2 Select Actions > Modify.

3 Enter the values in the failed login attempts field and the session time‑out
field.
The value for the number of failed login attempts must be between 1 and
20 (the default is 10 minutes). The session time‑out value must be between
1 and 999 minutes (the default is 20 minutes).

4 Click OK.

Related Links
Modify Security Settings Dialog
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Modify the Login Screen Message
You can add a customized message to the Oracle FS System Manager login
screen. For example, you might want to announce that system maintenance or
system downtime will be occurring at a specific time to notify administrators to
log out before that time.

1 Navigate to System > Global Settings > Security.

2 Select Actions > Modify.

3 Enter a login screen message.
You can enter up to 256 Unicode characters. The login message appears on
the login screen when an administrator first starts Oracle FS System
Manager.

4 Click OK.

Related Links
Modify Security Settings Dialog

Administrator Account Management
Administrators have specific privileges on the Oracle FS System that are based
on their assigned role for their account.

You can create multiple accounts in an Oracle FS System. More accounts are
useful, for example, if you want to delegate responsibilities. For example, you
might choose to create the following accounts:

• At least one additional administration account. In this way, a designated
person can assume responsibility while the Primary system administrator
is unavailable. Assign the Administrator 1 role to this account.

Tip: Do not use the Primary Administrator (the account named
“administrator” that comes installed with the software) account for day-to-
day operations. Instead, set up an Administrator 1 account when you
install the system. One reason is that besides the Primary system
administrator, only an Administrator 1 can modify an account password
(including that of the Primary system administrator) without knowing the
previous password.

• One or more administration accounts with read‑only privileges. In this
way, managers can monitor the system but they cannot change
configuration details. Assign these accounts to the Monitor role.

If you delegate administrative tasks, you can have the other administrators:

• Modify account attributes. For example, change the password or disable
the account other than the Primary system administrator account.

• Change the security settings of accounts.

• Delete obsolete accounts.
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At times, you might need to modify the attributes of other accounts. A Primary
system administrator and users who are assigned to the Administrator 1 role can
modify their own account or the accounts of another administrator.

Some changes take effect immediately. For example, a login session is terminated
when you disable or delete the login account.

Other changes affect the account the next time an individual or a client logs in.
For example, when you modify a password for an account or modify the global
session time‑out value, those changes take affect the next time a session is
started.

Related Links
Creating Administrator Accounts
Modifying Administrator Accounts
Administrator Account Types
Create an Administrator Account
Display Administrator Account Details
Delete an Administrator Account

Administrator Account Types
Administrator accounts have certain privileges, which depend on the role of the
account.

To administer an Oracle Flash Storage System, you must log in using an
administrator account. Every account performs a specific role that defines system
privileges.

Table 6: Administrator privileges by role
Administrator role Privileges
Primary
Administrator

Performs all configuration, management, and monitoring tasks,
including the ability to modify all other accounts. This account
cannot be deleted or disabled.

Administrator 1 Performs all configuration, management, and monitoring tasks
except for running the Drive Enclosure console.

Administrator 2 Performs all tasks except for the following caveats:

• Cannot create and manage File Servers and
administrator accounts

• Cannot modify software configurations or hardware
configurations

• Cannot shut down the system
• Cannot run the Drive Enclosure console

Monitor Displays system information only; cannot modify the
configuration. Can modify their own account attributes.
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Table 6: Administrator privileges by role (continued)
Administrator role Privileges
Oracle Support Performs limited customer service‑only functions; cannot

modify the configuration. This account cannot be deleted or
disabled.

Note: Only the Oracle Customer Support personnel can use this
account.

For the complete list of command options that this role is
authorized to perform, see the PARAMETERS section in a
specific Oracle FS CLI command.

Support Performs limited customer service‑only functions; cannot
modify the configuration.

For the complete list of command options that this role is
authorized to perform, see the PARAMETERS section in a
specific Oracle FS CLI command.

Related Links
Creating Administrator Accounts
Modifying Administrator Accounts
Create an Administrator Account
Modify an Administrator Account

Creating Administrator Accounts
You can create new administrator accounts, each with different roles that are
authorized to perform different functions. For example, you can create a Monitor
account that has the authority to perform read‑only management tasks and the
ability to modify only their own account attributes.

You can create multiple accounts in an Oracle FS System. More accounts are
useful, for example, if you want to delegate responsibilities. For example, you
might choose to create the following accounts:

• At least one additional administration account. In this way, a designated
person can assume responsibility while the Primary system administrator
is unavailable. Assign the Administrator 1 role to this account.

Tip: Do not use the Primary Administrator (the account named
“administrator” that comes installed with the software) account for day-to-
day operations. Instead, set up an Administrator 1 account when you
install the system. One reason is that besides the Primary system
administrator, only an Administrator 1 can modify an account password
(including that of the Primary system administrator) without knowing the
previous password.
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• One or more administration accounts with read‑only privileges. In this
way, managers can monitor the system but they cannot change
configuration details. Assign these accounts to the Monitor role.

Note: If you do not enter an email address for an administrator account,
administrators cannot reset their own passwords using the Reset password
feature in Oracle FS System Manager.

You can create a maximum of 128 administration accounts. Only 25 user‑created
account sessions can be logged in at any given time. Only five accounts are
permitted to be logged in at the same time. A Primary system administrator can
forcefully log in to free up an account session if necessary.

Related Links
Modifying Administrator Accounts
Administrator Account Types
Create an Administrator Account
Modify an Administrator Account
Delete an Administrator Account

Create an Administrator Account
You can create new administrator accounts to allow users to perform various
tasks on the Oracle FS System.

1 From Oracle FS System Manager (GUI), navigate to System > Global
Settings > Administrator Accounts.

2 Select Actions > Create.

3 Enter the name of the account in the Login Name field.

4 Select a role from the Role list.

Note: Refer to the Administrator Account Description that is provided on
the dialog for a full description of each role.

5 Enter the remaining information about the account owner.
Required information:

• Full Name
• Email Address
• Phone Number
• Password
• Confirm Password

Note: If you do not enter an email address for an administrator account,
administrators cannot reset their own passwords using the Reset
password feature in Oracle FS System Manager.

6 (Optional) To disable the account, select the Disable Account option.
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Use the Disable Account option when you want to create accounts that
you want to enable at a later time.

7 Click OK.

Related Links
Create Administrator Account Dialog
Administrator Account Management
Administrator Account Types
Delete an Administrator Account

Modifying Administrator Accounts
You can change the properties of select administrator accounts. For example, you
might want to change the role of an administrator account to give the
administrator more or fewer system privileges.

If you delegate administrative tasks, you can have the other administrators:

• Modify account attributes. For example, change the password or disable
the account other than the Primary system administrator account.

• Change the security settings of accounts.

• Delete obsolete accounts.

At times, you might need to modify the attributes of other accounts. A Primary
system administrator and users who are assigned to the Administrator 1 role can
modify their own account or the accounts of another administrator.

Some changes take effect immediately. For example, a login session is terminated
when you disable or delete the login account.

Other changes affect the account the next time an individual or a client logs in.
For example, when you modify a password for an account or modify the global
session time‑out value, those changes take affect the next time a session is
started.

Related Links
Modify an Administrator Account
Change Administrator Passwords
Reset the Primary System Administrator Password

Modify an Administrator Account

You can modify the administrator account details, disable the account, or change
the user password.

1 Navigate to System > Global Settings > Administrator Accounts.
2 Select an account name from the list of login names.
3 Select Actions > Modify.
4 Enter values for the attributes that you want to modify.
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Note: You cannot disable the Primary system administrator account or the
Oracle Support account.

5 Click OK.

Related Links
Modify Administrator Account Dialog
Modifying Administrator Accounts
Change Administrator Passwords
Reset the Primary System Administrator Password

Change Administrator Passwords

You can change the administrator password as necessary when, for example, an
administrator forgets the password.

Passwords must adhere to the following security policy:

• Must be eight characters to 16 characters in length

• Cannot contain dictionary words

• Cannot be any of the last 50 passwords

Note: The system retains recent passwords for one year.

• Must contain at least one uppercase letter, one lowercase letter, one
numeric character, and one special character

1 Navigate to System > Global Settings > Administrator Accounts.
2 Select a login name from the Administrator Accounts list.
3 Select Actions > Modify.
4 Enter the new password in both the Password and Confirm Password

fields.
5 Click OK.

Related Links
Modify Administrator Account Dialog
Modifying Administrator Accounts
Modify an Administrator Account
Reset the Primary System Administrator Password

Reset the Primary System Administrator Password

If you forget the Primary system administrator password, an Administrator 1 can
reset it.

If you need your Primary system administrator password reset, you can reset it
using one of the following methods:

• Use a Administrator 1 account, if one exists, to reset the password. Primary
system administrators and administrators who are assigned to the
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Administrator 1 role can change the password of any administrator
account without knowing the previous password. A Support administrator
cannot reset the Primary system administrator password.

• Click Reset password on the Login screen and follow the instructions in
the Reset Password dialog. You must have either your old password or
your password token to reset your password. If you do not have your
password token, click Forgot password on the Login screen and follow the
instructions in the Forgot Password dialog.

If you are an Administrator 1, use the following steps to reset the password.

1 Navigate to System > Global Settings > Administrator Accounts.
2 Select an account name from the list of login names.
3 Select Actions > Modify.
4 Enter the new password in both the Password and Confirm Password

fields.
5 Click OK.

Related Links
Modify Administrator Account Dialog
Modifying Administrator Accounts
Modify an Administrator Account
Change Administrator Passwords

Display Administrator Account Details
You can display details about all login accounts or about a specific login account.
You can also review the accounts that are disabled or have incomplete contact
information.

1 Navigate to System > Global Settings > Administrator Accounts.
2 Select the account you want to view, and then select Actions > View.
3 Review the displayed information to ensure that the account details are

what you expect.
4 Click OK.

Related Links
View Administrator Account Dialog

Delete an Administrator Account
You might want to delete a login account when, for example, someone who has
an account leaves the company.

1 Navigate to System > Global Settings > Administrator Accounts.
2 Select an account name from the Administrator Accounts list to that you

want to remove.
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3 Select Actions > Delete.
The system displays the Delete Account dialog.

4 Click OK.

Related Links
Creating Administrator Accounts
Modifying Administrator Accounts
Create an Administrator Account
Modify an Administrator Account

SNMP Trap Host Management
If you use Simple Network Management Protocol (SNMP) applications to
monitor network devices, you can define SNMP trap hosts to receive Oracle FS
System traps. Any workstation that has an SNMP-based management
application installed on it can be a trap host.

Oracle Flash Storage Systems support SNMP version 2c. SET operations from
SNMP management applications are not supported.

A management information base (MIB) table is a plain text file that provides the
details on all system objects for which Oracle provides management information.
To use the MIB file, you first download the file from the Utilities page of the Pilot
management interface, and then import the file in to the SNMP management
application.

Note: You can define event notifications as an alternative to SNMP.

Related Links
Download the MIB From the Pilot

System Objects That Can Be Monitored
The management information base (MIB) is self-documenting and lists the
Oracle FS System resources that you can monitor. You can download the text-
based MIB from the Utilities page of the Pilot management interface or using
Oracle FS System Manager (GUI).

Some of the Oracle FS System resources that a system administrator can monitor
are listed below. Some of this information can be used, for example, to graph or
otherwise track the trend lines of certain resources, such as that for storage space
and its utilization and for I/O operations for each second (IOPS) over certain time
periods.

System Alerts
System Alerts are the notifications that the Oracle FS System generates to identify
conditions that warrant investigation and action.

System Alerts include the following examples:
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• Notifications about resources that are not fully operational, indicating a
need for maintenance.

• Notifications about insufficient storage, indicating a need for a reallocation
of resources, a cleanup of resources, or possibly the purchase of additional
storage. This kind of information is important when an administrator has
implemented thin provisioning for one or more logical volumes.

Call‑Home or Manual Log Collection
Querying these resources, the administrator can check the following information:

• The time of collection

• The availability status

• The type of information that is contained in the logs

Running Tasks
Some tasks that are running in the background are normal management jobs
such as scheduled clone replications or scheduled upgrades, or are the result of
some administrative action. Other tasks, however, might indicate a condition in
the Oracle FS System that is worth investigating, such as any of the following
conditions:

• Pilot restarts

• System restarts

• Topology rediscovery

This category is also useful for seeing when a planned task has completed or
might need recovery, such as when replicating a very large logical volume.

Scheduled Tasks
Querying this resource allows the administrator to determine which tasks are
scheduled and when they are scheduled. Knowing this information can be useful
in determining whether some traps or events can be expected.

Software Versions
Capturing software versions is useful in a large data center. To determine which
Oracle FS System requires updates or to discover whether a software update is
complete, you must access each system individually. Those multiple accesses can
be combined into a single task by using an SNMP management utility to perform
the queries.

Storage Usage
Monitoring short term trends and long term trends in capacity usage helps the
system administrator avoid getting System Alerts warnings, for example, that
Clone LUNs are being deleted to free up capacity. Because you can over‑allocate
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logical volumes when using the thin provisioning feature, such volumes need to
be monitored and can require additional physical storage.

System Configuration
Use a central SNMP resource to view the configuration and the status of the
resources of multiple systems, including:

• LUNs

• Interfaces

• Clones

• LUN mapping and masking

Traps
Traps are equivalent to email-based administrator alerts and provide another
means of alerting system administrators to unfavorable storage conditions,
which might result in a system alert.

Related Links
Download the MIB From the Pilot

Create SNMP Hosts
You can configure any workstation as a Simple Network Management Protocol
(SNMP) host. When you set up an SNMP host, you can also set the threshold of
the monitored event that will trigger a trap message to the SNMP host.

If you want to configure the SNMP server to monitor but not receive trap
messages, clear the Receive Traps option.

1 Navigate to System > Global Settings > SNMP.

2 Select Actions > Create.

3 Enter a Name for the SNMP host.

4 Enter the values in the Host IP field and the Community String field to
specify where the traps are directed.
The community string must contain at least six characters.

5 (Optional) Select the Receive traps option to enable the Trap Port Number
field.

6 (Optional) Enter the Trap Port Number.

Valid values:

• For SNMP queries, use port 161

• For SNMP traps, use port 162

7 (Optional) Select the Severity threshold from the list of possible filters:
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Informational Requires no action for events that are information
only.

Warning Requires no immediate action for minor conditions
that you can address at your convenience.

Critical Requires prompt action to prevent system failures or
offline conditions.

8 Click OK.

Related Links
Create SNMP Host Dialog
Modify SNMP Hosts
Delete SNMP Hosts
View SNMP Hosts

Modify SNMP Hosts
You can modify the hosts that receive Simple Network Management Protocol
(SNMP) traps. You might, for example, need to modify the IP address of the trap
host if you install your SNMP‑based management application on a different
workstation.

1 Navigate to System > Global Settings > SNMP.

2 From the SNMP Hosts overview page, select an SNMP host.

3 Select Actions > Modify.

4 Enter values for the attributes that you want to modify.

5 Click OK.

Related Links
Modify SNMP Host Dialog
Create SNMP Hosts
Delete SNMP Hosts
View SNMP Hosts

Delete SNMP Hosts
You can delete a host from the Simple Network Management Protocol (SNMP)
configuration. For example, you might want to delete a host after you uninstall
an SNMP‑based management application from that host.

1 Navigate to System > Global Settings > SNMP.

2 From the SNMP Hosts overview page, select an SNMP host to delete.

3 Select Actions > Delete.

4 Click OK.
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Related Links
Create SNMP Hosts
Modify SNMP Hosts
View SNMP Hosts

View SNMP Hosts
You can review a list of Small Network Management Protocol (SNMP) hosts that
are configured on the Oracle FS System. For example, you might want to know
the community string that a host uses for receiving traps.

1 Navigate to System > Global Settings > SNMP.

2 Review the list of SNMP trap hosts and ensure that the SNMP host details
are what you expect.

3 To view details about a specific host, select a host from the list and select
Actions > View.

4 Verify that the SNMP information is what you expect.

5 Click Close.

Related Links
View SNMP Host Dialog
Create SNMP Hosts
Modify SNMP Hosts
Delete SNMP Hosts

Download the MIB
The management information base (MIB) table that supports the Simple Network
Management Protocol (SNMP) table lists the Oracle FS System resources that you
can monitor. The file is available on the Pilot, but you can download it using
Oracle FS System Manager (GUI).

1 Navigate to System > Global Settings > SNMP.

2 From the SNMP Hosts overview page, select an SNMP host.

3 Select Actions > Download Oracle FS System MIB.

4 From the Download Oracle FS System MIB dialog, click the browse button
[…] to proceed.

5 Navigate to the desired target download path and specify a filename.

6 Click OK.

Download the MIB From the Pilot
The management information base (MIB) table that supports the Simple Network
Management Protocol (SNMP) table lists the Oracle FS System resources that you

Manage Global Settings

65



can monitor. The file is available on the Pilot, which can be accessed from a web
browser.

1 Start a web browser from your workstation.

2 Specify the public IP address of the Pilot or the name of the Oracle FS
System as the address to open.

3 Click Utility Software.

4 Click Download Oracle FS System SNMP MIB.

5 From the web browser, save the file to your client workstation.
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CHAPTER 3

Manage Storage Groups

Display Capacity Usage
You can display the capacity usage of all Storage Domains by Storage Class and
compare that usage to the total system capacity and to the assigned capacity
limits of the Oracle FS System.

1 Navigate to System > Dashboard.
The Dashboard shows the storage capacity for each Storage Domain in the
system.

2 Review the displayed capacity usage for each Storage Domain.

Figure 4: Usage summary

Note: Drive manufacturers often report drive capacities in decimal units
(powers of 10). An Oracle FS System reports the capacity of physical
storage and the size of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Related Links
Dashboard Overview Page

Volume Groups
A volume group is an administrative system object that is used to organize
logical volumes and, possibly, other volume groups. Volume groups can span
Storage Domains. A volume group can contain logical storage objects, such as
other volume groups, filesystems, LUNs, and Clone LUNs.
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Volume groups have the following properties:

• Each volume group must have a unique name. No two volumes groups in
an Oracle FS System can have the same name.

• The total number of volume groups is limited to 5000.

• The system allows up to 10 volume groups nested in a parent volume
group.

• Volume groups allow you to group logical storage objects that reside in
different Storage Domains.

• When deleting a volume group any nested objects, such as child volume
groups, LUNs, or filesystems, will be deleted also.

You can use volume groups to organize the storage objects that parallel your
organizational structure. For example, you might want to group all of your LUNs
and filesystems that are located in the United States in one volume group, and
the LUNs for the European sites in another volume group.

If you do not create nested volume groups, create all volumes within the default
volume group to create a broad, shallow hierarchy.

Figure 5: Default volume group example

Create nested volume group by creating a parent volume group, and then assign
logical volumes or other volume groups to the parent volume group.
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Figure 6: Nested volume groups

Related Links
Display Volume Group Details
Create Volume Groups

Display Volume Group Details
You can view the hierarchal relationship of the volume groups and the assigned
logical volumes.

1 Navigate to SAN > Volume Groups.
2 Review the characteristics of all of the available volume groups.

If necessary, you can reorganize and rename these groups.

Related Links
Volume Groups Overview Page
Volume Groups
Create Volume Groups
Delete a Volume Group
Rename a Volume Group

Create Volume Groups
Create volume groups when you want to organize logical volumes into
organizational units.

1 Navigate to SAN > Volume Groups.
2 Select Actions > Manage Volume Groups.
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3 Click Create.
The system creates a row for the volume group.

4 Enter the Volume Name for the volume group.

5 (Optional) From the Parent Volume Group Name list, select the volume
group that you want to be the parent.

6 (Optional) To immediately delete the selected row, click Remove.

7 Click OK.

Related Links
Create Volume Group Dialog
Volume Groups
Add Volumes to a Volume Group
Add Volume Groups to a Volume Group

Add Volumes to a Volume Group
You can add logical volumes to an existing volume group as your system
environment changes.

As you assign LUNs, filesystems, and possibly other volume groups to a selected
volume group, Oracle FS System Manager (GUI) provides you with a preview of
your selected change in the Volume Groups overview page.

1 Navigate to SAN > Volume Groups.

2 Select Actions > Manage Volume Groups.

3 From the Volumes tab, select the LUN or filesystem to add to the volume
group.

4 From the Volume Group list, select the volume group in which you want
to place the LUN or filesystem.

You can repeat Step 3 and Step 4 to add more volumes to the volume group.

5 Click OK.

Related Links
Manage Volume Groups, Volumes Tab
Create Volume Groups
Add Volume Groups to a Volume Group

Add Volume Groups to a Volume Group
You can add volume groups to an existing volume group as your system
environment changes.

As you assign the volume group to the volume group, Oracle FS System
Manager (GUI) provides you with a preview of your selected change in the
Volume Groups overview page.

Manage Storage Groups

70



1 Navigate to SAN > Volume Groups.

2 Select Actions > Manage Volume Groups.

3 From the Volume Groups tab, select the volume group to modify.

4 Click Modify.

5 From the Parent Volume Group Name list, select the volume group that
you want to be the parent.

6 Click OK.

7 Click OK.

Related Links
Manage Volume Groups, Volume Groups Tab
Create Volume Groups
Add Volumes to a Volume Group

Rename a Volume Group
If needed, you can modify the name of a volume group as the organization of
your volume group changes.

1 Navigate to SAN > Volume Groups.

2 Select Actions > Manage Volume Groups.

3 From the Volume Groups tab, select the volume group that you want to
rename.

4 Click Modify.

5 In Volume Name enter the new name for the volume group.

6 Click OK.

Related Links
Manage Volume Groups, Volume Groups Tab
Volume Groups
Delete a Volume Group
Display Volume Group Details

Delete a Volume Group
You can delete a volume group after you have reassigned all of its logical
volumes to different volume groups.

1 Navigate to SAN > Volume Groups.

2 Select Actions > Manage Volume Groups.

3 From the Volume Groups tab, select a volume group to delete.
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Note: If the volume group contains any objects, move or delete those
objects before you delete the volume group.

4 Click Delete.

Related Links
Manage Volume Groups, Volume Groups Tab
Volume Groups
Display Volume Group Details

Move a Volume to a Different Volume Group
If needed, you can modify the association of your volumes to your volume
groups. For example, after you create a volume group you can move one or more
logical volumes from an existing volume group to the new volume group.

As you assign LUNs, filesystems, and possibly other volume groups to a selected
volume group, Oracle FS System Manager (GUI) provides you with a preview of
your selected change in the Volume Groups overview page.

1 Navigate to SAN > Volume Groups.
2 Select Actions > Manage Volume Groups.
3 From the Volumes tab, select a LUN or filesystem to move.
4 Select a Volume Group entry to modify the hierarchical structure where

your volume is a child of the selected parent.

Tip: To move the volume outside of all custom volume groups, select
<none>.

5 Click OK.

Related Links
Manage Volume Groups, Volumes Tab
Add Volumes to a Volume Group
Create Volume Groups

Move a Volume Group to a Different Volume Group
If needed, you can reorganize your volume groups. For example, you can remove
the child volumes from a parent volume group.

As you assign LUNs, filesystems, and possibly other volume groups to a selected
volume group, Oracle FS System Manager (GUI) provides you with a preview of
your selected change in the Volume Groups overview page.

1 Navigate to SAN > Volume Groups.
2 Select Actions > Manage Volume Groups.
3 From the Volume Groups tab, select the volume group that you want to

move.
4 Click Modify.
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5 From the Parent Volume Group Name list, select the volume group that
you want to be the parent.

Tip: To move the volume group outside of all custom volume groups, select
<none>.

6 Click OK.

7 Click OK.

Related Links
Manage Volume Groups, Volume Groups Tab
Create Volume Groups
Add Volumes to a Volume Group

Storage Domains
Storage Domains give you the flexibility to store your data into logical groups
that meet your storage requirements. Examples of such groups can include
geographical location, or departmental function within your organization. You
can also group your data by access frequency, or group your data by levels of
confidentiality.

A Storage Domain is a virtual storage pool that consists of an assortment of drive
groups. Each drive group contains drives of a particular Storage Class and of a
particular capacity. The properties of the drive groups that comprise a Storage
Domain can differ from one another. A Storage Domain can contain up to 1024
drive groups.

An administrator can allocate a particular drive group to a specific administrator‑
defined Storage Domain. When no administrator‑defined domains exist, all of
the drive groups reside in the default Storage Domain.

Volume groups allow you to logically organize your data based on the data
content or geographical location. Storage domains allow you organize your
content based on physical properties of the storage pool, such as Storage Class or
auto‑tiering capabilities.

Storage Domain Examples
Storage Domains enable storage administrators to assign logical volumes to
specific Storage Domains. Such assignments can be made to reduce contention
among volumes, to implement different levels of security for those volumes, or
both. When more storage capacity is required, the administrator can add drive
groups to the Storage Domain.

Storage administrators typically use Storage Domains for the following reasons:

User group
separation

In this scenario, storage administrators can isolate
application data to specific drive groups on a department
basis (for internal cloud environments) or on a customer
basis (in external cloud environments). This isolation
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eliminates interapplication contention for I/O services and
provides charge‑back capabilities.

Protocol
separation

In this scenario, storage administrators can place
application data on separate drive groups that are based on
protocol and connectivity. This separation eliminates any
chance of interapplication contention for I/O services. For
example, an administrator could create a NAS domain, a
SAN iSCSI domain, and a SAN FC domain.

Application I/O
isolation

Storage administrators can create Storage Domains for use
in specific applications and tiers of storage to eliminate
unwanted drive group contention. For example, an
administrator can place the Oracle DB indexes in a
dedicated, SSD‑based Storage Domain to isolate all other
work from the indexes. The data table space and other
components can be in a different Storage Domain.

Data security Storage administrators can place logical volumes that
contain sensitive data on a particular Storage Domain. If the
data must be destroyed, the drives within those drive
groups can be destroyed without the administrator having
to be concerned with preserving less sensitive data. Placing
those volumes in their own Storage Domain ensures that
those volumes do not share drive groups with less sensitive
material.

Drive group
or hardware
retirement

As drives age, the probability of failure increases. Storage
Domains can efficiently move data to newer drive groups
that have larger capacities.

Auto‑tiering Storage administrators can place all auto‑tiered LUNs in a
Storage Domain that is dedicated to the QoS Plus feature.
The administrator can adjust the properties of the QoS Plus
feature until the optimum configuration is found. The
optimum configuration can then be used on other Storage
Domains in the system.

Related Links
Volume Groups
Managing Storage Domains
Storage Domain Objects Illustrated
Create a Storage Domain

Storage Domain Compaction
The Oracle FS System compacts fragmented storage capacity, which is caused by
deleted auto‑tiered LUNs, and makes the capacity available for use.

The system allocates storage capacity for QoS Plus. During normal operations,
storage capacity can become fragmented when capacity is freed from deleted
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auto‑tiered LUNs, but that freed capacity is not made available. Fragmented
capacity makes inefficient use of the available storage capacity.

As needed, the system compacts the storage capacity in the drive groups that
comprise of the Storage Domain. You can manually compact the Storage Domain
to make the fragmented storage capacity available for use. During compact
operations, any QoS Plus data migration is suspended. Compacting the Storage
Domain cannot occur when there is insufficient storage capacity in the drive
group.

Related Links
Storage Domains
Compact a Storage Domain

Storage Domain Integrity Check
The Oracle FS System continuously monitors and verifies the integrity of the data
that is stored or changed on the Storage Domain. For auto‑tiered LUNs, the
system runs the integrity check to verify that the LUN data and the LUN address
locations, which describes where the data resides, are not lost or corrupted.

In the event that the system detects a problem with the auto‑tier address location,
the system sends a Volumes Have Lost Mappings system alert. Lost mappings
is a condition in which data on the auto‑tiered LUNs might not be accessible or
available. The integrity check on the Storage Domain begins immediately after
the discovery of the lost mappings. This check cannot be cancelled by the
administrator. The integrity check can take several minutes to several hours to
complete. The actual time depends on the number of LUNs and the amount of
data that the system checks.

During the integrity check, the system verifies that the locations to the auto‑tier
data is correctly reported. If the Storage Domain has the Tier Reallocation option
disabled, then the integrity check does not apply.

The system also automatically runs the integrity check in the following
circumstances:

• After a restart operation resulting from the system not shutting down
cleanly.

• After a Controller failover.

• After a warmstart, if the administrator does not respond to a Lost Data
system alert.

• After a warmstart, if the system did not complete its data mappings or data
migrations.

• After detecting a media error on a metadata volume. The media error can
also result in Volumes Have Lost Mappings but the system does not wait
for your response before proceeding with the integrity check.
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You can initiate an integrity check on the Storage Domain at any time, or as
instructed by Oracle Customer Support. If you initiate the integrity check while
the system is already performing the check, the system ignores your request.

Related Links
Storage Domains
Check the Integrity of a Storage Domain

Storage Domain Objects Illustrated
Storage organization can be illustrated using a diagram that includes various
components of the Storage Domain, drive groups, volume groups, and logical
volumes.

Storage Domain Management
Storage administrators can perform regular management actions for any logical
volume residing in a Storage Domain, including:

• Create logical volumes within a domain.

• Create volume copies within the same or different domain.

• Create clones of logical volumes contained in a domain.

• Move logical volumes to a different volume group or a different Storage
Domain.

• Delete logical volumes from a domain.

Note: All allocation for a logical volume is confined to the drive groups within a
Storage Domain.

Storage Domain Illustration
The following figure illustrates two Storage Domains and six logical volumes
that are distributed across those domains. This illustration also shows the
relationships among those Storage Domains and other storage objects.

Manage Storage Groups

76



Figure 7: Storage Domains and other storage objects

Legend 1 Drive groups 6  Volume group

2  Storage Domains 7  Single-tier SAN LUN

3 Capacity HDD drive group 8 Auto-tier SAN LUNs

4  Performance HDD drive group 9  Filesystem data tiers

5  Performance SSD drive groups

In the illustration, a volume group (annotation 6) contains three logical volumes
(annotations 7 and 8), which spans two Storage Domains (annotation 2). A
volume group can contain logical storage objects, such as other volume groups,
filesystems, LUNs, and Clone LUNs.

You can have a drive group that is not assigned to any Storage Domain. This
unassigned state is usually temporary. While in this state, the capacity of the
drive group is not included as free or available capacity. The causes of an
unassigned state for a drive group include:

• Drives have been added to a Drive Enclosure.

• A drive group was removed from a Storage Domain.

Related Links
Storage Domains
Volume Groups
Moving Volumes
Create a Storage Domain
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Managing Storage Domains
Occasionally, a storage administrator must perform certain management actions
on a Storage Domain.

When an Oracle FS System starts up for the first time after installation, that
system has one Storage Domain that contains all of the drive groups that are
available in the system. That domain is referred to as the default Storage Domain.
You can create additional Storage Domains by removing one or more of those
drive groups from the default domain and adding them to new Storage
Domains.

When you create a Storage Domain, ensure that sufficient storage capacity exists.
You can add capacity to the Storage Domain in the following ways:

• Remove drive groups from the default Storage Domain and add those
drive groups to the Storage Domain.

• Add more drives to an existing Drive Enclosure.

• Add more Drive Enclosures.

You can create a Storage Domain without drive groups. Such a Storage Domain
contains no storage capacity and therefore cannot be assigned to a logical
volume.

Managing your Storage Domains involves the following activities:

• Creating, modifying, and deleting the Storage Domains

• Adding drive groups to the Storage Domain

• Removing drive groups from the Storage Domain

• Compacting and verifying the Storage Domains

• Generating an auto‑tier effectiveness report

• Viewing the auto‑tier storage capacity

The Oracle FS System provides some advanced options for controlling the QoS
Plus feature, which is called Auto‑tier in the GUI. Use caution when performing
any of the following activities:

• Disabling the tier reallocation feature

• Disabling the collection of tier reallocation statistics

• Optimizing auto‑tier performance

• Allocating the auto‑tier storage capacity
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Related Links
Capacities
Data Migration
Effectiveness of QoS Plus
Provisioning Storage Domains
Create a Storage Domain
Optimize Auto‑Tier Scans
Compact a Storage Domain
Delete a Storage Domain

Provisioning Storage Domains
When logical volumes already exist on a Storage Domain, provisioning the
Storage Domain by adding or removing drive groups can cause data migration.
Data migration can occur when a drive group that contains a volume is moved to
another Storage Domain.

The system notifies you that attempting to perform any of the following actions
causes data migration:

• When moving an existing volume to another Storage Domain, the target
Storage Domain must have sufficient capacity for the volume. If sufficient
capacity exists, the system migrates the volume data.

• When moving a drive group from one Storage Domain to another, you
must allow the system to migrate all of the volumes off of the source drive
group. Then, the drive group can be added to the target Storage Domain.

• If the drive group contains volumes, when you remove the drive group
from the source Storage Domain, then the system migrates the volumes
from the drive group to another drive group in the Storage Domain.
Ensure that sufficient free capacity exists on the Storage Domain to move
the volumes from one drive group to another.

• When reassigning a drive group that contains part or all of a volume, the
existing Storage Domain that contains that drive group must have
sufficient free capacity in other drive groups. This free capacity
accommodates the loss of the drive group that is being moved to another
Storage Domain. When the drive group is moved, the system migrates the
volume data onto the remaining drive groups.

• When you add a drive group to the Storage Domain, you have the option
to rebalance the existing volumes in the Storage Domain. Enable rebalance
is the default, which maximizes the performance of the existing volumes
that might not have sufficient capacity in the drive groups.

Important: The Storage Domain must have sufficient free capacity on the target
Storage Domain to hold the entire volume that is being migrated. For a drive
group, both the source and target drive groups must have sufficient storage
capacity to hold the data that is being migrated.
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The system also provides you the following information:

• A list of the volumes (and their associated repositories) that will require
data migration

• A message indicating whether enough capacity exists to move those
volumes into the selected Storage Domain

• A message indicating whether enough capacity exists for the remaining
volumes to reside in an existing Storage Domain

Related Links
Moving Volumes
Storage Domains
Drive Groups
Create a Storage Domain

Create a Storage Domain
Storage Domains allow you to assign logical volumes to a specific collection of
drive groups. For example, Storage Domains allow administrators to partition
storage for specific users or departments in a public or private cloud storage
environment.

Assigning volumes to specific Storage Domains can reduce I/O contention among
volumes.

1 Navigate to System > Storage Domains.
2 Select Actions > Create Storage Domain.
3 Enter the name of the Storage Domain.
4 (Optional) Select the Background Process Priority that the system uses to

respond to migrating data.
Possible choices:

• System Chooses
• Minimize Impact
• Maximize Speed

5 (Optional) Select the tier reallocation options.
Possible choices:

• Enable Tier Reallocation
• Enable Tier Reallocation Statistics Collection

6 (Optional) Optimize the Auto‑Tier Scan Options.

Possible choices:

• Performance-Optimizing Scan Cycle
• Number of n‑hour Scan Cycles

Note: Select the lock icon to unlock and lock the fields.
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The system calculates the Cost‑Optimizing Scan Cycle value.
7 (Optional) In the Allowable Storage Capacity for Auto‑Tiered LUNs field,

enter the percentage of the storage capacity to allocate for each available
Storage Class that is listed.

8 Click OK.

The Storage Domain now appears in the list of domains.

After you create a Storage Domain, add one or more drive groups to the domain
so you can assign logical volumes in the domain. The number of drive groups
that you add to a Storage Domain and the Storage Classes available in those
drive groups directly affect the performance of the volume that is on that
domain.

Related Links
Create Storage Domain Dialog
Storage Domains
Managing Storage Domains
Moving Volumes
Delete a Storage Domain

Rename a Storage Domain
Sometimes you might want to change the name of a Storage Domain to a more
meaningful name.

Changing the name of a Storage Domain does not affect the data or other
configurations of the domain.

1 Navigate to System > Storage Domains.
2 Select the Storage Domain to update.
3 Select Actions > Modify Storage Domain.
4 Update the Name of the Storage Domain.
5 Click OK.

Related Links
Modify Storage Domain Dialog
Create a Storage Domain
View the Properties of a Storage Domain

Update the Background Process Priority
You might need to adjust the background process priority for the Storage
Domain because your system is not migrating data efficiently. For example, you
can lower the migration priority to provide more resources for user data
operations.

1 Navigate to System > Storage Domains.
2 Select the Storage Domain to update.
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3 Select Actions > Modify Storage Domain.

4 Select the Background Process Priority that the system uses to respond to
migrating data.
Possible choices:

• System Chooses
• Minimize Impact
• Maximize Speed

5 Click OK.

Related Links
Modify Storage Domain Dialog
Managing Storage Domains
Optimize Auto‑Tier Scans

View the Properties of a Storage Domain
You can view the properties of a Storage Domain, such as the capacity for each
Storage Class, the settings for the background activity, and properties for
auto‑tier (QoS Plus).

You can view the following properties of a Storage Domain from the View
Storage Domain dialog:

• Storage capacities by Storage Class

• Priority of background processes

• Tier reallocation and the collection of statistics

• Scan cycling for QoS Plus

• Limits to the QoS Plus storage capacity

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to view.

3 Select Actions > View Storage Domain.

4 Review the displayed information.

5 Click Close.

Related Links
View Storage Domain Dialog
Limit the Storage Capacity for QoS Plus
Update Tier Reallocation Options
Optimize Auto‑Tier Scans
Update the Background Process Priority
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Limit the Storage Capacity for QoS Plus
When premium storage capacity is limited, you can specify that the Storage
Domain use only a specified percentage of the capacity for the QoS Plus feature.

Note: Reducing the amount of QoS Plus storage capacity below the amount of
capacity that is currently being used causes the system to migrate data to
available Storage Classes only if the storage capacity is available. You might need
to free some storage capacity before the system can use the desired allocated
percentage of your storage capacity.

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to update.

3 Select Actions > Modify Storage Domain.

4 In the Allowable Storage Capacity for Auto‑Tiered LUNs field, enter the
percentage of the storage capacity to allocate for each available Storage
Class that is listed.

5 Click OK.

Related Links
Modify Storage Domain Dialog
View Storage Allocation Details
Optimize Auto‑Tier Scans

Update Tier Reallocation Options
You can temporarily disable one or both of the following aspects of storage tier
reallocation: the migration of data and the collection of statistics. For example,
disabling the migration of data allows you to suspend data tier reallocation for
all of the auto-tiered LUNs in the Storage Domain.

Important: Disabling the tier reallocation options affects data migration for all of
the LUNs that are assigned to the selected Storage Domain. Use caution before
disabling these features.

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to update.

3 Select Actions > Modify Storage Domain.

4 (Optional) Deselect the Enable Tier Reallocation option.

5 (Optional) Deselect the Enable Tier Reallocation Statistics Collection
option.

6 Click OK.

To resume normal tier reallocation operations, remember to enable the tier
reallocation and statistics options.
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Related Links
Modify Storage Domain Dialog
Data Migration
View Storage Allocation Details
Optimize Auto‑Tier Scans

Optimize Auto‑Tier Scans
For the selected Storage Domain, you might need to optimize the frequency with
which the Oracle FS System scans the data access patterns of the auto‑tiered
LUNs.

The Oracle FS System scans the data access patterns of the auto‑tier LUNs to
determine the best time to place data in the Storage Classes within the Storage
Domain. You can optimize the auto‑tier scans by lengthening or shortening the
time between scans. A shorter time span increases the number of scans and
results in frequent data migration. A longer time span might represent the actual
data access patterns of your system.

Important: Adjusting the auto‑tier scans might affect the efficiency of the QoS
Plus feature. Use caution before adjusting the scan options.

For example, setting the Number of n‑hour Scan Cycles too low can move data
that is accessed frequently over a long time period to be moved to a lower
performance drive.

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to update.

3 Select Actions > Modify Storage Domain.

4 Select the lock icon ( ) to unlock the Auto‑Tier Scan Options.

5 (Optional) In the Performance-Optimizing Scan Cycle field, enter the
frequency value.

6 (Optional) In the Number of n‑hour Scan Cycles field, enter the cycles
value.
The system calculates the Cost‑Optimizing Scan Cycle value.

7 Click OK.

Reset the auto‑tier scan options to the default values when the custom settings
are no longer needed.

Related Links
Modify Storage Domain Dialog
Data Migration
Effectiveness of QoS Plus
View Storage Allocation Details
Managing Storage Domains
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Compact a Storage Domain
You might want to compact the storage tier capacity that is unavailable in the
Storage Domain. After the compacting is complete, the system has free capacity
that is available for use.

The Oracle FS System compacts the QoS Plus storage capacity on a regular basis.
However, you can manually compact the Storage Domain as needed. For
example, you might want to compact the Storage Domain after you have deleted
a number of auto‑tier LUNs and need to quickly release any unavailable storage
capacity.

1 Navigate to System > Storage Domains.
2 Select the Storage Domain to update.
3 Select Actions > Compact Storage Domain.

The Storage Domain status changes to Background Activity.
4 Click OK.
5 Click OK.

When the compact process is complete, the Storage Domain status changes to
Normal. You can monitor the compaction process by selecting Tasks from the
status bar. The free storage capacity should increase after you have compacted
the unavailable storage capacity.

If the compacting process is taking too long, or if the process impacts system
performance, you can cancel the process by selecting Actions > Cancel Compact
Storage Domain.

Related Links
Storage Domains Overview Page
Reclaiming Capacity
Storage Domains
Storage Domain Compaction
Managing Storage Domains

Check the Integrity of a Storage Domain
You can check the integrity of a Storage Domain when you suspect that the
auto‑tier data might be lost or corrupted. You might also be requested by Oracle
Customer Support to run an integrity check.

Note: The Oracle FS System automatically runs the integrity check when the
system has encountered a Volumes Have Lost Mappings system alert.

1 Navigate to System > Storage Domains.
2 Select the Storage Domain on which to run the integrity check.
3 Select Actions > Verify Storage Domain.

The Storage Domain status changes to Background Activity.
4 Click OK.

Manage Storage Groups

85



When the integrity check is complete, the Storage Domain status changes to
Normal. You can monitor the process by clicking Tasks on the status bar.

If the verification process that you initiated is taking too long, or if the process
impacts system performance, you can cancel the process by selecting Actions >
Cancel Verify Storage Domain.

Note: Cancelling the verification process does not affect the system or data.

Related Links
Storage Domains Overview Page
Storage Domain Integrity Check
Storage Domains
Managing Storage Domains

View Storage Allocation Details
You might want to view the allocated storage capacity in a Storage Domain,
which includes both capacities by RAID type and immobile storage capacity. If
the capacities are nearly full, you might consider increasing the storage capacity
in the Storage Domain.

If you notice that both RAID 10 and immobile capacities are nearly full, consider
one or all of the following actions:

• Increase the high performance storage capacity in your Storage Domain for
auto‑tiered LUNs.

• Increase the percentage storage capacity limit that is set for auto‑tier LUNs.

• Reduce immobile capacity by allowing the system to use low cost storage
capacity for auto‑tier LUNs.

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to view.

3 Select Actions > View Storage Allocation Details.

4 Review the displayed information.

5 Click Close.

Related Links
Storage Domains Overview Page
Managing Storage Domains
Storage Domains
Limit the Storage Capacity for QoS Plus

Delete a Storage Domain
When you no longer need a Storage Domain, you can delete it.
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Prerequisites • The Storage Domain that you want to delete must not
contain any logical volumes. If the Storage Domain
contains any logical volumes, delete those volumes or
move those volumes to another Storage Domain.

• The Storage Domain that you want to delete must not
have any drive groups assigned to the domain. If any
drive groups are assigned to the Storage Domain,
perform the following actions:

• If any of the drive groups contain any logical
volumes, delete those volumes or move them to
another Storage Domain.

• Remove the drive groups from the Storage
Domain.

1 Navigate to System > Storage Domains.

2 Select the Storage Domain to delete.

3 Select Actions > Delete Storage Domain.

4 Click OK.
One of the following occurs:

• If the operation is successful, the Storage Domain is removed from
the system.

• If the operation is unsuccessful, the system does not remove the
Storage Domain and displays an appropriate error dialog:

• The Storage Domain contains one or more logical volumes.

• The Storage Domain has one or more drive groups assigned to
it.

If the operation is unsuccessful, move any volumes residing on the
Storage Domain to another Storage Domain, if appropriate. Then
remove the drive groups.

Related Links
Storage Domains Overview Page
Managing Storage Domains
Create a Storage Domain

Moving Volumes
Sometimes you might want to move a logical volume from one Storage Domain
to another Storage Domain to improve the performance of that volume.

For example, if a Storage Domain is being used to support an Oracle DB
application, you might want to move the database indexes into a
higher‑performance Storage Domain that is separate from the Storage Domain in
which the database tables are located.
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When you move a volume to a different Storage Domain, the system prompts
you to select another Storage Domain for the volume. If sufficient free capacity
exists to migrate the data to the other domain, the move request succeeds;
otherwise, the system returns an error. The system successfully moves the
volume when the following conditions are met:

• Sufficient free storage capacity exists in the target Storage Domain.

• For QoS Plus volumes, the target Storage Domain contains lower Storage
Classes.

When the system migrates a volume with a populated clone repository to
another Storage Domain, the system does not migrate the repository to the other
Storage Domain. Instead, the clones remain in the original Storage Domain.

If the clone repository is empty, the system creates a repository in the other
Storage Domain after the migration is complete.

Related Links
Storage Domains
Move a Volume to Another Storage Domain

Move a Volume to Another Storage Domain
Move a logical volume to another Storage Domain, for example, when you want
to remove the drive group on which the volume resides. You also might want to
move a volume to a Storage Domain that is dedicated for a specific purpose, such
as storing database indexes.

Prerequisite A target Storage Domain with sufficient free capacity to
accept the logical volume. The target Storage Domain can
contain the same or different Storage Class.

Note: Moving logical volumes and removing the drive groups from the Storage
Domain are performed as separate actions.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to move.

3 Select Actions > Modify.

4 In the Storage Domain list, select the Storage Domain to which you want to
move the LUN.

5 (Optional) Select a Storage Class from the available list for the target
Storage Domain.

6 Click OK.
One of the following occurs:

• If the operation is successful, the system begins a background task to
migrate the volume to the new Storage Domain. Also, the system
releases and reconditions the storage in the previous domain.
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• If the operation is unsuccessful, the system does not migrate the
volume but instead displays an appropriate error dialog:

• The target Storage Domain has insufficient free capacity of the
selected Storage Class. To resolve, remove unneeded volumes
that consume capacity on the drive groups of that Storage
Class. You can also add drive groups or add more storage
capacity to the drive group.

• The target Storage Domain does not contain enough storage
capacity. To resolve, add to the target Storage Domain one or
more drive groups of the desired Storage Class.

Related Links
Modify SAN LUN, Quality of Service Tab, Auto Tier
Modify SAN LUN, Quality of Service Tab, Single Tier
SAN LUNs Overview Page
Moving Volumes

Drive Groups
A drive group is a logical object that manages a collection of drives of the same
Storage Class, all of which are from the same Drive Enclosure. The maximum
number of drive groups in the Oracle FS System is 1024.

A drive group belongs to a single Storage Domain. A drive group can also be
unassigned, which means that the group can be assigned to any Storage Domain.

Managing the drive groups involves the following activities:

• Assigning the primary drive group to another drive group in the system

• Removing drive groups from a Storage Domain

• Adding drive groups to a Storage Domain

• Viewing the status of the drives in a drive group

• Viewing the RAID status across all of the volumes that occupy the drive
groups

Related Links
Configure Drive Group Real-Time Statistics
Assigning Drive Groups
View the Properties of a Drive Group
Make a Drive Group the Primary Drive Group

Drive Group Data Protection
The Oracle FS System copies data away from a drive that is predicted to fail.

The data of a logical volume is striped across the drives in several drive groups.
The data from several volumes can even be located on the same drive group. The
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data from all of these volumes is protected by one or more levels of RAID.
Because of this striping, a given drive can contain data from multiple volumes.
As a result, a particular drive might be supporting several levels of RAID.

When one of the drives within a drive group fails or is about to fail, the system
assigns an appropriate status to the data blocks that are located on the affected
drive. The status of one data block might differ from the status of another data
block, even though both data blocks reside on the same drive. If the statuses
differ, the difference in the statuses results from the RAID level of those data
blocks being different.

Within a given drive group, the system treats all of the data blocks that are
protected by the same RAID level as a group. The system groups them by RAID
level for reporting purposes.

Related Links
Data Integrity on the Drives
High Availability
Priority Level and Performance
Drive Groups
View the Properties of a Drive Group

List Drive Groups in a Storage Domain
You might want to know the state of each drive group and the state of the drives
in those drive groups.

The Storage Domains overview page lists all of the drive groups, by Storage
Domain.

1 Navigate to System > Storage Domains.

2 Review the displayed information.

3 Click OK.

Related Links
Storage Domains Overview Page
Drive Groups
Assigning Drive Groups
Storage Domains
View the Properties of a Drive Group

View the Properties of a Drive Group
You can view the properties of a drive group and its included drives to
determine, for example, whether a particular drive might need to be replaced.

You can view the drive group properties, such as whether a drive group is
primary. Use the Modify Drive Group action to view drive details and status.
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1 Navigate to System > Storage Domains.

2 Select the drive group that want to view.

3 Select Actions > Modify Drive Group.

4 From the list of Replaceable Units, select a drive in the drive group.

5 Review the drive properties on the right side of the dialog.

6 Click OK.

Related Links
Modify Drive Group Dialog
Storage Domains Overview Page
Drive Groups

Primary Drive Group Description
The primary drive group is the drive group in an Oracle FS System that contains
the system-wide Persistence volume. The Persistence volume is the internal name
of the volume that contains the system configuration database. The system
contains one primary drive group.

If only one drive group exists, the drive group is the primary drive group. If the
system contains more than one drive group, the system selects one of the drive
groups to be primary.

You can change the primary drive group at any time. The Oracle FS System
places the primary drive group on the lowest Storage Class in the system. If you
add Drive Enclosures to the system that are a lower Storage Class than the
existing classes, the system automatically migrates the primary drive group to
the new lowest Storage Class. The system then migrates the system configuration
database that is contained in the Persistence volume to the newly assigned
primary drive group.

Note: Assign the primary drive group to a lower Storage Class, such as Capacity
hard disk drive (HDD).

If a nonprimary drive group becomes the primary drive group, the system
migrates the system data to the new primary drive group. The administrator
cannot cancel this special data migration.

For a new Oracle FS System, or after a system reset, the following sequence
occurs:

• The system starts with no system configuration database.

• When powered up, the system discovers all of the Drive Enclosures and
creates drive groups to contain the discovered drives.

• The system assigns one of the drive groups as the primary drive group.
The default primary drive group contains drives with the lowest Storage
Class in the system, such as Capacity Disk.
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• The system assigns all of the remaining drive groups that it created to a
default Storage Domain.

• The system then writes the initial configuration to the Persistence volume
in the primary drive group.

If more Drive Enclosures are added to the system, and those Drive Enclosures
contain a lower Storage Class, the system automatically designates one of the
drive groups in the new Drive Enclosure as primary. The system then migrates
the system configuration database contained in the Persistence volume to that
new, primary drive group.

Related Links
Assigning Drive Groups
Make a Drive Group the Primary Drive Group

Make a Drive Group the Primary Drive Group
You can make another drive group the primary when, for example, you plan to
replace drives in the existing primary drive group.

The primary drive group is identified by the  icon.

Note: Assign the primary drive group to a lower Storage Class, such as Capacity
hard disk drive (HDD).

1 Navigate to System > Storage Domains.

2 Select the drive group that you want to become the primary drive group.

3 Select Actions > Modify Drive Group.

4 Select the Make this drive group the primary drive group option.

5 Click OK.

The system runs a background process to move the system configuration
database to the new primary drive group. When the background process
completes, the system moves the primary drive group icon to the new primary
drive group.

Related Links
Modify Drive Group Dialog
Drive Groups
Primary Drive Group Description

Assigning Drive Groups
Sometimes you might need to assign an existing drive group to another Storage
Domain.

You can add multiple drive groups to a Storage Domain at one time. Wait for any
background processes to complete before assigning existing drive groups to a
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Storage Domain. You can view the background processes from the Tasks button
on the status bar.

Reassigning drive groups from one Storage Domain to another is a two step
process:

Step one Remove the drive groups from the first Storage Domain.
You can remove multiple drive groups from a Storage
Domain at one time, but you can only remove drive groups
from one Storage Domain at a time. When this step
completes, the drive groups are designated as unassigned.

Note: The system allows you to perform one operation to
remove drive groups from a Storage Domain (or add drive
groups to a Storage Domain). The add or remove operation
can include multiple drive groups.

Removing the drive groups requires that the Oracle FS
System migrate the data to the other drive groups in the
Storage Domain. If sufficient storage capacity does not exist
on the other drive groups, then the drive group removal
fails.
Migrating drive group data from the drive groups can take
many hours to complete, and the system migrates only one
drive group at a time. To conserve system resources, plan
your drive group removals carefully. You can specify the
resource priority that the system uses to migrate your data.
The following priorities are available to complete your
request:

System Chooses (Default) Specifies that the system
balances the resources that are needed
for background data movement with
the resources that are needed to
service the incoming client I/O.

Minimize Impact Specifies that the system restricts the
amount of system resources that are
given to the background data
movement operation. This option
minimizes the impact on client I/O.
Recommended for highly‑loaded
Storage Domains.

Maximize Speed Specifies that the system grants
resource priority to the background
data movement operation. This option
reduces the amount of system
resources that are available for client
I/O. Recommended for lightly‑loaded
Storage Domains.

Manage Storage Groups

93



Step two Assign the unassigned drive groups to the second Storage
Domain.

Related Links
Drive Groups
List Drive Groups in a Storage Domain
Remove Drive Groups From a Storage Domain
Add Drive Groups to a Storage Domain

Remove Drive Groups From a Storage Domain
Remove drive groups from a Storage Domain when you need to remove drive
groups of a particular Storage Class. You might also need to remove the drive
groups to assign the drive groups to another Storage Domain.

Prerequisite Sufficient Storage Domain capacity to receive the data that
is migrating from the removed drive group.

When you remove a drive group from the Storage Domain, the system migrates
any volume data to the remaining drive groups in the Storage Domain, if
sufficient free capacity exists on the remaining drive groups. This migration can
take several hours to complete. Plan to remove the drive groups when the system
is idle or when the system has minimal I/O activity.

1 Navigate to System > Storage Domains.

2 Select all of the drive groups that you want to remove from the Storage
Domain.

3 Select Actions > Remove from Storage Domain.

4 Select the Migration Priority for the drive group removal.

5 Click OK.

6 (Optional) Click Tasks from the status bar to view the detailed status of the
task that is removing the drive group.

The system places the drive groups that were successfully removed into an
unassigned category. You can now add the unassigned drive groups to another
Storage Domain.

Related Links
Remove from Storage Domain Dialog
Storage Domains Overview Page
Assigning Drive Groups

Add Drive Groups to a Storage Domain
Add drive groups when you need to add particular Storage Classes to a Storage
Domain. You might also need to add the drive groups to a Storage Domain to
increase storage capacity.
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Prerequisite Drive groups with an unassigned status.

1 Navigate to System > Storage Domains.

2 Select all of the drive groups that you want to add to a Storage Domain.

3 Select Actions > Add to Storage Domain.

4 Select the Storage Domain to which you want the drive group to be
assigned.

5 (Optional) To distribute data from the other drive groups in the Storage
Domain to the drive groups that you are adding, select the Rebalance
volume data option.

6 Confirm that the drive groups that you selected are listed in the Drive
groups to be included list.

7 (Optional) Select the Include check box for any Additional Drive Groups
to Include in the Storage Domain.

8 Click OK.
The system begins assigning the drive groups to the selected Storage
Domain.

9 (Optional) Click Tasks from the status bar to view the detailed status of the
task that is adding the drive groups.

Related Links
Add to Storage Domain Dialog
Storage Domains Overview Page
Assigning Drive Groups

Manage Storage Groups

95



CHAPTER 4

About QoS and Provisioning

QoS Policies
Quality of Service (QoS), in general, defines a set of attributes for a logical
volume that affects how the volume utilizes storage and the priority that the
Oracle FS System gives to the I/O requests that target the volume.

When creating a logical volume, the administrator can select for the volume
regular QoS features or enhanced QoS features (which are collectively referred to
as QoS Plus):

• The administrator creates a regular QoS volume by selecting the Single
tier option in the GUI. Such a volume is sometimes referred to as a single-
tiered volume.

• The administrator creates a QoS Plus volume by selecting the Auto-tier
option in the GUI. Such a volume is sometimes referred to as an auto-tiered
volume.

When defining a logical volume, an administrator can set the QoS policies for the
following properties of the volume:

Storage Class The preferred type of storage media on which to place the
user data initially. For QoS Plus volumes, the Storage Class
and the RAID level of a volume determine the initial
placement of the data.
Subsequently, the data usage statistics determine whether
the data is migrated to another storage tier. Infrequently
used data is moved to more cost‑effective but lower‑
performance storage, while frequently used data is moved
to a storage tier that has better performance characteristics.

Priority A relative attribute that the system uses to set the
importance and the treatment of logical volumes. A volume
with a higher priority than another volume receives
precedence in the handling of access requests. A higher
priority also allows a larger share of typically finite
resources, such as the storage tiers and the system cache.
Because the priority setting is relative, setting priorities to all
low values or to all high values has the same effect, which
nullifies the opportunity to distinguish between the service
levels of volumes.
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RAID level The type of data protection and the degree of data
protection from drive failures. The type of protection
influences the performance characteristics of the volume.
The degree of protection determines the number of failures
that can occur in a RAID group before having to restore the
data from a backup of some kind.

Read‑ahead policy The degree to which the storage system anticipates
continuing read requests beyond an outstanding request.
Correct anticipation greatly improves performance, while
incorrect anticipation can waste system resources. By
specifying a read‑ahead policy, the administrator can
provide an effective hint to the system to get the desired
results of reading additional data blocks.

The RAID level and the read‑ahead policy comprise the advanced view of the
QoS properties for a volume. The RAID level and the read‑ahead policy can be
defined indirectly through the basic view of QoS. The basic view consists of the
following properties:

• The level of redundancy (single or double)

• The predominant access method (random, sequential, or a mix of the two
access methods)

• The predominant type of I/O request (read, write, or a mix of the two
request types)

You can access the basic view of QoS by selecting a custom Storage Profile for the
volume.

Related Links
Access Bias
Defining QoS Properties
I/O Bias
Priority Level and Performance
QoS Plus Overview
Redundancy and Data Protection
Storage Class Description

Defining QoS Properties
In addition to the Storage Class and the priority level for a logical volume, you
must also define two other Quality of Service (QoS) properties for the volume:
the RAID level and the read‑ahead policy. The Oracle FS System provides two
approaches to defining the RAID level and the read‑ahead policy.

Note: When you create a LUN, the system automatically sets the RAID level and
the read-ahead policy. You can override those default properties from the Create
SAN LUN dialog by selecting Custom in the Storage Profile field.
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You can customize the settings for the RAID level and for the read‑ahead policy
by using one of the following approaches:

Basic
approach

Using the basic approach, you indirectly specify the RAID level
and the read-ahead policy for the volume. Using this approach,
you specify the data redundancy, the I/O bias, and the access bias
of a logical volume. These QoS properties are referred to as the
basic QoS properties of the volume.

Advanced
approach

Using the advanced approach, you directly specify the RAID level
and the read-ahead policy for a logical volume. These QoS
properties are referred to as the advanced QoS properties of the
volume.

Note: In Oracle FS System Manager (GUI), when customizing the QoS properties
of a logical volume, you can set the basic QoS properties of the volume and then
map them to the advanced QoS properties. You cannot, however, set the
advanced QoS properties and then map them to the basic QoS properties.

The following table summarizes how the basic QoS properties map to the
advanced QoS properties of a volume.

Table 7: Mapping QoS properties
Initial Storage
Class

Initial
redundancy

Basic QoS properties Advanced QoS properties

Initial typical
access

Initial I/O
bias

Initial RAID
level

Initial read-
ahead

Capacity
disk

Double Sequential Read RAID 6 Aggressive

All others All
others

RAID 6 Normal

All other
Storage
Classes

Single Sequential Read RAID 5 Aggressive

Random Write RAID 10
(mirrored)

Normal

All others All
others

RAID 5 Normal

Related Links
Managing SAN LUNs
Access Bias
I/O Bias
Priority Level and Performance
Redundancy and Data Protection
Storage Class Description

Storage Class Description
The Storage Class QoS property allows you to specify the preferred storage
media to use for a logical volume.
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A Storage Class is a specific categorization of SAS physical storage, each category
having distinct characteristics with regard to capacity and to data access
performance. Available Storage Classes:

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

A Storage Class relates to storage objects in the following ways:

• A newly created LUN that is using regular QoS (a single-tiered LUN) is
associated with one Storage Class.

• A newly created LUN that is using QoS Plus (an auto‑tiered LUN) is
associated initially with one Storage Class. At a later time, an auto‑tiered
LUN migrates fully or partially onto the most cost‑effective and the most
performance‑effective Storage Classes according to the use patterns and to
the QoS priority level of the LUN.

• A newly created, single data tier filesystem is associated with one Storage
Class.

• A newly created filesystem that has multiple data tiers can be associated
with multiple Storage Classes. In this case, each data tier is based on a
different class. Furthermore, the administrator or the file owner can
migrate a file that resides in a multiple‑tier filesystem from one Storage
Class to another Storage Class.

• Oracle FS System Manager (GUI) shows the capacity that is available for
each Storage Domain. For a given Storage Domain, the GUI displays the
capacity by Storage Class and by drive group.

Related Links
Priority Level and Performance
QoS Plus Overview
Redundancy and Data Protection
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Priority Level and Performance
The priority level of a logical volume determines the characteristics of the system
response to the incoming I/O requests against the volume. In general, the higher
the priority level that is associated with a volume, the faster the system can
respond to an access request.

Available priority levels:

Premium Indicates the highest priority for responding to requests in the
processing queue.

High Indicates the next highest priority for responding to requests in the
processing queue.

Medium Indicates an intermediate priority for responding to requests in the
processing queue.

Low Indicates the next to lowest priority for responding to requests in the
processing queue.

Archive Indicates the lowest priority for responding to requests in the
processing queue.

The time that the Oracle FS System takes to respond to an incoming I/O request
depends on the factors that are listed in the following sections.

Queue Priority
The SAN interface of a Controller has one processing queue for each of the five
QoS priority levels. The SAN interface places each incoming I/O request for a
LUN into the processing queue that corresponds to the QoS priority that is
associated with the LUN.

If the SAN interface of a Controller is overcommitted, the Oracle FS System
allocates the processing resources of the Controller to each queue according to
the priority of the queue. The Premium queue gets the largest allocation of
processing resources. The other priority queues get proportionally smaller
allocations of resources, depending on the priority level of the queue.

Data Migration
For logical volumes that use QoS Plus, the Oracle FS System adjusts the QoS bias
that the system uses when determining whether and when to migrate the user
data across the storage tiers. This adjustment causes the higher priority volumes
to be given a greater opportunity to occupy the higher performance Storage
Classes.

For example, if two data blocks have the same access statistics but one block has
a higher QoS Priority setting, the block having the higher Priority migrates
sooner than the block having the lower Priority.
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Thin Provisioning
For a logical volume that uses QoS Plus and is thinly provisioned, the Oracle FS
System selects the initial Storage Class that the system uses for infilling based on
the Storage Class and the RAID level that the administrator selected for the
volume.

Striping
For LUNs using regular QoS (single‑tiered LUNs), if a sufficient number of drive
groups exist in the Storage Domain that hosts a logical volume, the Oracle FS
System places a higher priority volume on a greater number of drive groups than
the system does for a lower priority volume. Placing a high priority volume on
more drive groups enhances the performance of the volume.

For example, for a logical volume that has a priority level of Premium or High,
the system stripes the volume across four drive groups. If, however, that volume
has a priority level of Low or Archive, the system stripes the volume across only
two drive groups.

For LUNs that are using QoS Plus (auto-tiered LUNs), the system creates
appropriate storage tiers on which to place the auto-tiered LUNs before creating
the LUNs. Because storage tiers span all of the drive groups within a Storage
Domain, auto-tiered LUNs can utilize all of those drive groups, independent of
priority level.

Related Links
Data Migration
Growing Thin Volumes
QoS Plus Overview
Redundancy and Data Protection
Thin Provisioning

Redundancy and Data Protection
The redundancy level of a logical volume determines the number of copies of the
parity bits that the Oracle FS System creates for the volume. The number of
copies of the parity bits determines the level of protection for the volume data if a
drive that contains any data for the volume fails.

Important: Contact Oracle Customer Support for assistance with sizing your
system and with creating your logical volumes.

The redundancy Quality of Service (QoS) property provides the following
choices for parity:

Single Stores the original user data plus one set of parity bits to help in the
recovery of lost data. Access to the data is preserved even after the
failure of one drive. Single parity is implemented using RAID 5
technology and is the default redundancy level for the Storage Classes
that specify the performance-type media.
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Double Stores the original user data plus two sets of parity bits to help in the
recovery of lost data. Access to the data is preserved even after the
simultaneous failure of two drives. Double parity is implemented using
RAID 6 technology and is the default redundancy level for the Storage
Classes that specify the capacity-type media.

A drive group is a logical object that manages a collection of drives of the same
Storage Class, all of which are from the same Drive Enclosure. The number of
drives in the drive group depends on the drive type. A drive group containing
hard disk drives (HDDs) consists of 12 drives. A drive group containing solid
state drives (SSDs) consists of six drives.

The following list shows the number of drive groups across which the Oracle FS
System allocates capacity for a logical volume that is using regular QoS (a single-
tiered volume). The number of drive groups depends only on the priority level
that you have chosen for the volume:

• Premium: 4 drive groups

• High: 4 drive groups

• Medium: 3 drive groups

• Low: 2 drive groups

• Archive: 2 drive groups

Note: For solid-state drives (SSDs), the system uses all of the assigned SSDs in the
Storage Domain when striping a volume, regardless of the priority level chosen
for the volume.

The number of drive groups that the Oracle FS System uses to stripe a single-
tiered volume can, at times, be fewer than what is shown in the above list. The
system might use fewer drive groups because, for example, many of the drive
groups in the Storage Domain are nearing full capacity or are at full capacity.
When either situation exists, the system might allocate more than one stripe for a
new volume in the same drive group, degrading the overall performance for that
volume.

When performance is degraded because the striping for the volume is across
fewer drive groups than would normally be used, you can re-establish high
performance for the volume by including additional drive groups in the Storage
Domain.

Adding drive groups allows the Oracle FS System to rebalance the allocations so
that the volume utilizes the proper number of drive groups. The rebalancing is
achieved by the system moving the extra stripes from the drive group to the
newly added drive group.

Related Links
Priority Level and Performance
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Access Bias
Requests for I/O operations on a logical volume can be biased toward sequential
access, random access, or a balanced mix of the two types of access. You can use
the bias of these requests (in conjunction with the I/O bias property) to help
optimize the performance of the volume.

As a Quality of Service (QoS) property, the access bias indicates to the system the
expected pattern that is typically used to access the data in a volume:

Sequential Indicates that the read requests and the write requests operate on
the data mostly by accessing the records one after the other in a
physical order.

Random Indicates that the read requests and the write requests operate on
the data mostly by accessing the records in an arbitrary order.

Mixed Indicates that the read requests and the write requests operate on
the data sometimes in sequential order and sometimes in random
order.

Note: Access bias specifies an optimization bias. Access bias is not a requirement
that all data operations conform to the specified access method.

Related Links
I/O Bias

I/O Bias
Requests for I/O operations on a logical volume can be biased toward read
operations, write operations, or a balanced mix of the two types of operation.
You can use the bias of the type of I/O operation (in conjunction with the access
bias property) to help optimize the performance of a logical volume.

As a Quality of Service (QoS) property, the I/O bias indicates to the system the
type of I/O operation that is the most common or is the most expected for a
particular volume:

Read Indicates that most of the access requests are for read operations.

Write Indicates that most of the access requests are for write operations.

Mixed Indicates that the number of access requests are similar for read
operations and for write operations.

Important: If you choose Random as the access bias and Write as the I/O Bias,
and if you choose single redundancy for data protection, the Oracle FS System
creates the logical volume using RAID 10 (mirrored data). This RAID level
enhances the write performance but uses twice the capacity.

For write requests, the system stores all of the user data and all of the system
metadata in mirrored copies of the journal. One copy is maintained in the regular
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cache on the owning Controller. The mirror copy is maintained in one of the
following locations:

• The memory of the partner Controller that is backed by an energy storage
module (ESM). All host write operations are copied to the ESM-backed,
non-volatile cache in the partner Controller. This type of operation is often
refered to as a write back cache.

• The virtual LUN (VLUN) that is reserved on the physical storage for the
logical volume, if the partner Controller is unavailable for the write
operation. Write operations to this copy are equivalent to write-through
cache.

Write operations from the journal to permanent physical storage are equivalent
to write‑through cache. The system flushes the user data and the corresponding
metadata as a unit to the physical storage.

Related Links
Access Bias
Faster Random-Write Operations

Faster Random-Write Operations
You can enhance the performance of random-write operations on a logical
volume under certain circumstances.

Using the QoS-based management tools that are provided in Oracle FS System
Manager (GUI), you can improve the overall performance of random-write
intensive applications by taking advantage of RAID 10 data protection, which
replaces four I/O operations with a parallel mirrored-write operation.

The system utilizes this RAID level when you set the optimization settings for a
logical volume to random access with a write I/O bias. In this case, the system
allocates space on a RAID 10 array on which the system performs parallel
mirrored‑write operations (two writes).

In addition, because the data resides on two independent drives, RAID 10 allows
the Oracle FS System to optimize read operations. In this case, the system can
select the least busy of the two drives when performing the read operation.

Related Links
Access Bias
I/O Bias

QoS Plus Overview
Enhanced QoS, called QoS Plus, automatically adapts the location of data blocks
to optimize the storage efficiencies, to yield a higher performance, and to lower
the cost of storage. The QoS Plus features result in an optimal cost/IOP and the
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cost/TB over time by means of specific usage characteristics and specific QoS
levels.

Note: Volumes that have a large number of access requests that are skewed to a
relatively small portion of the user data benefit the most from the features of QoS
Plus.

When configuring QoS Plus for a LUN (by selecting the Auto-tier option), the
administrator configures the initial settings for the LUN and then lets the system
manage the placement of the data from that point forward. Besides initially
creating the auto‑tiered LUN, an administrator needs to adjust little else, if
anything, after the LUN is created.

Related Links
Storage Performance Statistical Data Overview
Data Migration
Affect of Statistics on Data Migration

Storage Tiers
A storage tier is a collection of blocks of contiguous storage, all of which have the
same RAID level. This collection is spread across one or more drive groups
within a given Storage Domain. Storage tiers are used by administrators and by
the Oracle FS System to provision logical volumes.

When an administrator initially creates a LUN, the administrator defines a
number of QoS properties for the volume, including the initial Storage Class for
the volume. If the LUN uses QoS Plus, the Oracle FS System creates two storage
tiers in the Storage Domain that the administrator selects for the volume:

• For capacity HDDs, the system creates a RAID 6 storage tier, which
implements double redundancy, and a RAID 10 storage tier, which
implements mirroring.

• For all other drives, the system creates a RAID 5 storage tier, which
implements single redundancy, and a RAID 10 storage tier as well.

Note: The RAID level of the storage tiers depends on the Storage Class that is
selected for the LUN.

The storage tier on which the system places the LUN depends on the Storage
Class and on the redundancy level (single parity, double parity, or mirroring)
that the administrator selects for the volume.

Note: For filesystems, an Oracle FS System uses two types of storage tiers: data
tiers and metadata tiers. A filesystem data tier contains user data. A filesystem
metadata tier contains system-level data that describe the filesystem and the user
data that it contains.
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Related Links
Redundancy and Data Protection
Storage Class Description

Data Migration
Data migration that results from the QoS Plus feature occurs when the system,
after an analysis of the historical usage information for the block of data,
determines that another Storage Class or RAID level can better service that block
of data.

When optimizing for system performance, QoS Plus moves frequently accessed
data blocks of a LUN to a faster, more expensive Storage Class, such as high-
performance solid-state drives (SSDs). Conversely, when optimizing for cost, QoS
Plus moves infrequently accessed data blocks to a slower, less expensive Storage
Class, such as high-capacity hard disk drives (HDDs).

Note: When data migration occurs, the Oracle FS System gives the higher priority
volumes a greater opportunity to occupy the higher performance Storage
Classes. To migrate the data, the system initiates a task that runs as a background
process.

You can limit data migration to use only designated Storage Classes. When you
create a LUN using QoS Plus, you can specify the Storage Classes to include for
data migration and to exclude for data migration. QoS Plus moves infrequently
accessed data to a lower performance Storage Class, such as Capacity Disk.

Excluding less expensive Storage Classes and including high performance
Storage Classes causes immobile storage capacity. Immobile data occurs when the
system cannot migrate the data to a lower Storage Class. Data that cannot
migrate to a lower Storage Class is considered immobile and the storage capacity
that this data occupies is immobile. Data migration is efficient when 100% of the
system capacity is available.

Note: If the preferred Storage Class is full, data might be placed temporarily in a
non-preferred Storage Class.

Provide sufficient storage for data migration and allow the system to use all of
that storage capacity. Oracle FS System Manager (GUI) provides a graph that
shows all of your allocated storage capacities and immobile storage capacities
from the Storage Domain page.

Related Links
Affect of Statistics on Data Migration
Priority Level and Performance
QoS Plus Controls
Redundancy and Data Protection
Storage Class Description

About QoS and Provisioning

106



Affect of Statistics on Data Migration
The Oracle FS System collects an extensive set of statistics that cover many
aspects of the performance of the overall system, including data usage.

The Oracle FS System monitors and analyzes the data activity statistics of the
LUN to determine if the initial properties make the best use of the available
storage resources. If, for example, the system determines that data within a LUN
has not been accessed for several days, the system moves 640 KB blocks of data
from the LUN to high-capacity, low-cost drives that are suitable for archival
purposes. If the volume experiences a high amount of data activity, the Oracle FS
System migrates the LUN data to higher-performance drives.

For a LUN that is using QoS Plus, the Oracle FS System gathers and stores
statistics about the access requests as I/O is performed on the LUN. At specific
times, which can be set by the administrator for a Storage Domain, the system
analyzes those statistics. From this analysis, if the system determines that certain
data within the auto‑tiered LUN can benefit by placing the data on a different
storage tier, the system migrates that data to the storage tier that best matches the
use of the data.

Related Links
QoS Plus Controls
QoS Plus Overview

QoS Plus Controls
The QoS Plus feature consumes resources that might affect overall system
performance. You can control certain aspects of this feature to mitigate some of
those effects.

The Oracle FS System monitors the I/O activity to determine the best time to
migrate the data to another storage tier. When the system activity is low, tier
migration efforts increase. Conversely, when the system load is heavy, tier
migration efforts decrease, but do not cease.

Scanning
Oracle FS System Manager (GUI) provides various options that together
optimize your storage utilization costs and the overall performance of the I/O
operations. The options affect when QoS Plus scans your data and when QoS
Plus moves the data among the available Storage Classes.

To match your application activity, you can provide delays to the scan frequency
that is used by QoS Plus.

Tier Reallocation
You can disable the data migration feature at both the Storage Domain and LUN
levels. Disabling data migration at the Storage Domain prevents data migration
for all LUNs that are assigned to that Storage Domain. You can prevent data
migration for a single LUN by deselecting the Tier Reallocation option in the

About QoS and Provisioning

107



Additional Options dialog. The options for disabling data migration at the
Storage Domain and LUN levels are independent. For example, if you make a
data migration change to the Storage Domain, that change does not affect the
settings for the LUN.

Capacity Limits
By default, QoS Plus uses all of the available storage capacity in a Storage
Domain. For each Storage Class in a given Storage Domain, you can specify the
percentage of storage capacity that the Oracle FS System can use for QoS Plus
LUNs. Specifying a percentage of the capacity that can be used for QoS Plus is
most useful for the Storage Classes that are relatively expensive.

You can allocate, for example, 80% of your performance HDD capacity for
auto‑tiered LUNs, which then leaves 20% of that capacity for LUNs using regular
QoS and for filesystems.

Note: Reducing the amount of QoS Plus storage capacity below the amount of
capacity that is currently being used causes the system to migrate data to
available Storage Classes only if the storage capacity is available. You might need
to free some storage capacity before the system can use the desired allocated
percentage of your storage capacity.

Related Links
Limit the Storage Capacity for QoS Plus
Update Tier Reallocation Options
Optimize Auto‑Tier Scans
Data Migration
Affect of Statistics on Data Migration
Storage Tiers

Effectiveness of QoS Plus
Distribution charts and effectiveness reports provide detailed information about
the efficiency of the QoS Plus feature that is applied to a set of auto‑tiered LUNs.
The QoS Plus feature optimizes the placement of data blocks to yield higher
system performance and to lower the cost of storage.

Effectiveness Graphics for QoS Plus
The View Auto Tier Graphs dialog displays all of the auto‑tiered LUNs in the
Storage Domain. You can select up to 10 of the LUNs from which to view the
effectiveness graphics. When you click Update Graphs, the following graphs
display:

Data Transferred By
Number of Accesses

Indicates a histogram of the different regions of all of
the LUNs in the Storage Domain by the frequency of
I/O access.The histogram bar height represents the
amount of data transferred. The y‑axis is not labeled.
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Tier Structure By Storage
Class and Priority

Indicates a graph of the Storage Class and the
capacity of the LUN regions for the selected
auto‑tiered LUNs. The chart also shows a number
that represents the QoS priority for the auto‑tiered
LUN. A table at the bottom of the chart provides the
list of selected LUNs. The table is also a legend for
the LUNs that are represented on the graph.

The two graphs allow you to observe the placement of the data blocks and
determine the effectiveness of the QoS Plus feature that is applied to the selected
auto‑tiered LUNs.

Figure 8: Data Transferred By Number of Accesses histogram

Legend 1 I/O activity of the LUN region that
occupies the Performance SSD

4 I/O activity of the LUN region that
occupies the Capacity HDD

2 I/O activity of the LUN region that
occupies the Capacity SSD

5 LUN region

3 I/O activity of the LUN region that
occupies the Performance HDD

The histogram represents the I/O distribution and the data transfer activity for all
of the auto‑tiered LUNs in the Storage Domain. The system counts the number of
I/O accesses that was necessary to transfer data to and from the auto‑tiered
LUNs. The information is then plotted on the graph from the lowest I/O activity
to the highest. The system categorizes different regions of a LUN by the
frequency of access and by Storage Class. The graph shows the amount of data
transferred to each of these categories.

QoS Plus is most effective if the regions of the LUN that receive most of the I/O
are in the best Storage Class. The graph shows that the storage is used effectively
when the regions of the LUN that receive the most number of accesses are also in
the most efficient Storage Class that is available, which is the Performance solid‑
state drives (SSDs). If the regions of the LUN with the most number of accesses
are not in SSD, the performance could be improved by adding Performance SSD
capacity to the Storage Domain.
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Figure 9: Tier Structure by Storage Class and QoS Priority graph

Legend 1 Allocated capacity of the LUN 5 Relative LUN storage capacity that
occupies the Capacity HDD

2 Relative LUN storage capacity that
occupies the Performance SSD

6 Tooltip

3 Relative LUN storage capacity that
occupies the Capacity SSD

7 QoS Priority value:

    1 = Premium

    2 = High

    3 = Medium

    4 = Low

    5 = Archive

4 Relative LUN storage capacity that
occupies the Performance HDD

8 LUN Row number that
corresponds to the list of LUNs
below the graph

The above figure shows how the QoS Plus feature distributes data in the selected
auto‑tiered LUNs. Each bar of the graph represents 100% of the allocated
capacity of the LUN and provides the following information about the LUNs:

• The Storage Class of each region within the LUN

• The storage capacity of each region

• A value that represents the QoS priority of the LUN

The graph information helps you determine if your LUNs are placed in the
optimum Storage Class and assigned the appropriate QoS priority. Ideally, you
want your LUNs with heavy I/O loads and larger capacity requirements assigned
to the premium Storage Class and using the highest QoS priority level.
Conversely, you want the LUNs with low I/O loads assigned to the low-cost
Storage Class using a low QoS priority level.
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Effectiveness Reports for QoS Plus
The Generate Auto‑Tier Effectiveness Report dialog allows you to view the
Auto‑Tier Effectiveness report. The report summarizes the results of the analysis
that the QoS Plus feature has performed on the auto‑tiered LUNs in the Storage
Domain.

The report contains the following information about each auto‑tiered LUN:

Constrained
skew

Indicates the degree of uniformity of the data distribution and
the I/O activity across all of the Storage Classes that are
available to the auto‑tiered LUN. The report provides a value
between 0 and 1. Use the information in the following table as a
guide in interpreting the constrained-skew value.

Table 8: Constrained skew
Approximate
constrained skew
value

Description

Is close to 1.0 Indicates that the I/O activity and that the
LUN data are unevenly distributed across all
of the available Storage Classes.

The LUN contains a small amount of data,
which resides on high-cost Performance
SSDs, that are receiving all of the I/O activity.
The same LUN also contains a majority
amount of data that resides on low-cost
storage, such as Capacity drives, that is never
accessed.

QoS Plus can benefit the LUN.

Is close to 0 Indicates that the I/O activity and data are
evenly distributed across all of the available
Storage Classes.

QoS Plus can provide little benefit for the
LUN.

Average IOPS Indicates the number of IOPS that are averaged over the
previous auto‑tier scan cycle.

Peak IOPS Indicates the number of IOPS for a two‑minute time frame
where the IOPS were the greatest during the previous auto‑tier
scan cycle.
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Related Links
Example to Determine the Effect of Adding an Application
Example to Determine Performance During Peak Usage
Storage Performance Statistical Data Overview
Generate Auto-Tier Effectiveness Report
View the Auto-Tier Graphs

View the Auto-Tier Graphs
After your system has processed your data for a period of time, you might want
to view how the QoS Plus feature distributes the data in your auto‑tiered LUNs.
Two graphs display information that helps you decide whether to add
Performance solid‑state drive (SSDs).

1 Navigate to System > Storage Domains.
2 Select the Storage Domain to view.
3 Select Actions > View Auto-Tier Graphs.
4 Select up to 10 auto‑tiered LUNs.
5 To display the graphs, click Update Graphs.

The dialog displays the following graphs:

• Data Transferred By Number of Accesses

• Tier Structure By Storage Class and Priority
6 Use the arrow buttons to adjust the size of the chart window.
7 To update the chart with current information or with other LUNs, repeat

Step 4 and Step 5.
8 Click Close.

Related Links
View Auto-Tier Graphs Dialog
Effectiveness of QoS Plus

Generate Auto‑Tier Effectiveness Report
Installing more storage capacity to the Oracle FS System can affect the values that
are used in the Auto‑Tier Effectiveness Report. You can update the storage cost
values that represents your system, if necessary. You can view the report
immediately, or you can download the report in one of many common formats.

1 Navigate to System > Storage Domains.
2 Select the Storage Domain to report.
3 Select Actions > Generate Auto‑tier Effectiveness Report.
4 (Optional) Update a value in the Storage Costs table.

To update a value, double-click the cell.
5 Generate the report.
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Available options:

• To create and view the report immediately, click Generate and View
Report.

• To create and view the report at a later time, click OK.

To view your effectiveness report later, navigate to System > Reporting &
Statistics > Generated Reports and select the effectiveness report. You can then
download the report in one of many common formats.

Related Links
Storage Domains Overview Page
Generate Auto-Tier Effectiveness Report Dialog
Effectiveness of QoS Plus

Capacities
Depending on the context, the term capacity can refer to logical space or to actual,
physical space.

Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Logical
capacity

The space that you request that the system set aside for a logical
volume. In Oracle FS System Manager (GUI), logical capacities are
used in the following contexts:

addressable The size limit that you established for the volume. The
addressable capacity is sometimes referred to as the
maximum size of a volume. Addressable capacity
includes the space that is needed for the repository
when you specify clone-based data protection for the
volume.

allocated The amount of space that the system has set aside for
a specific volume.

used The amount of the allocated space in a filesystem that
contains user data.

Note: Logical capacities do not include the overhead that is needed
for implementing RAID protection (parity data and mirroring).

Physical
capacity

The actual space that the system assigns to the volume or has
available for assignment. Values that the system reports for physical
capacities refer to the actual space on the physical media.
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The value that is reported for the physical capacity of a volume is
greater than the value that is reported for the logical capacity of the
volume. The physical capacity of a volume is greater because of the
overhead that is used to implement the volume. For example, the
physical capacity takes into account the space that is needed for the
clones of the volume and for RAID protection.

Related Links
Growing Thin Volumes
Overhead for Capacity Allocation

Free Capacity and Volume Creation
A minimum amount of free space in the selected Storage Domain is required to
create a logical volume.

When you create a new volume, the actual amount of physical capacity that is
consumed from the free space in the Storage Domain includes the capacity that is
needed to accommodate the system overhead that is associated with the volume,
such as the capacity that is required for RAID protection.

A request to create a logical volume can fail because of one of the following
reasons:

• Insufficient capacity remains in the Storage Class or Storage Domain that
you specified for the volume.

• The system needed to round your request to a larger value, and the
rounded value is greater than the available capacity.

Related Links
Capacities
Overhead for Capacity Allocation
Reclaiming Capacity

Overhead for Capacity Allocation
Your plans for the provisioning of logical volumes must take into account the
extra capacity that the Oracle FS System allocates to accommodate various needs.
Together, these extra capacities comprise what is called system overhead.

Oracle FS System Manager (GUI) reports the physical capacities for the Storage
Domains, for the drive groups, and for the logical volumes that exist in an
Oracle FS System.

Overhead for RAID Protection
To account for the data protection overhead, the Oracle FS System increases the
requested capacity by a certain amount when creating a volume. The amount of
additional capacity depends on the RAID level of the volume that is being
created and on the initial Storage Class that is selected for the volume:
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• RAID 5, solid state drive (SSD): 20%

• RAID 5, hard disk drive (HDD): 10%

Note: In the GUI, the physical capacity and the logical capacity for RAID 5
HDDs appears to be 20% because the system includes the spare space in
the overhead calculation.

• RAID 6, capacity HDD: 20%

• RAID 10, all Storage Classes: 100%

For example, assume that you request 250 GB of capacity for a new volume. If
you select single redundancy on any HDD Storage Class, the system uses a
RAID 5 geometry for the new volume and allocates an additional 10% (25 GB) of
capacity. If, however, you select double redundancy on capacity HDDs, the
system uses a RAID 6 geometry for the new volume and allocates an additional
20% (50 GB) of capacity.

Note: These overhead percentages are approximate and can vary somewhat for
different reasons.

The capacity that a volume consumes and the capacity that the system reports for
the volume both include the overhead for RAID protection.

Overhead for Infill Reserve
For each Storage Domain that contains hard disk drives (HDDs), the Oracle FS
System reserves 50 GB of physical capacity as a reserve that can be used, if
needed, for infilling thin volumes. This reserve is available to all SAN LUNs that
are located partly or wholly on those HDDs.

Note: The system includes the infill reserve capacity in the free physical
capacities that are reported for the Storage Domains and for the drive groups.

The Oracle FS System reserves this infill reserve capacity to help prevent an
inadvertent exhaustion of the physical capacity when thinly provisioned
volumes grow. When a thinly provisioned volume needs to grow, the system
uses this reserve capacity when all of the regular HDD capacity in the Storage
Domain has been allocated.

Related Links
Capacities
Growing Thin Volumes
Redundancy and Data Protection
Storage Class Description

Thin Provisioning
Traditionally, when a system allocates storage for a logical volume, the allocation
is dedicated to that volume. This dedication prevents other volumes from
accessing this storage, even when the amount that is allocated is never used by
the owning volume.
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Thin provisioning allows you to leverage this unused storage. To leverage
unused storage, perform the following actions:

• Allocate capacity based on future needs.

• Draw from a common pool of storage as the allocated capacity is
consumed.

Thin provisioning on an Oracle FS System allows you to create a logical volume
of any size without committing the requested capacity at the time that you create
the volume. Each volume appears to have all of the storage that the volume
needs for ongoing operations. The difference is that the physical capacity is not
actually locked to a particular volume.

All logical volumes in an Oracle FS System have two properties that are related
to the logical capacity of the volumes. Also, whether a logical volume is thinly
provisioned depends on the relationship between the initial values of those two
capacities.

Capacity
Addressable logical capacity

The maximum amount of storage to which the
logical volume can grow. Because of the rounding
that the system performs internally, the value of
this property can be up to 2 GB less than the value
for the allocated logical capacity.

Allocated
Allocated logical capacity

The amount of storage that the system dedicates
to the logical volume. The allocated logical
capacity can be any value up to and including the
addressable logical capacity. When you create a
SAN LUN, you specify this value, which becomes
the initial capacity that the system allocates to the
LUN.

Tip: If you do not want thin provisioning for the
LUN, set the allocated logical capacity equal to
the addressable logical capacity.

In contrast, when you create a NAS filesystem, the
allocated logical capacity property is not
available. For filesystems, the Oracle FS System
creates the filesystem without allocating any
initial capacity for the data tiers. Instead, when
the filesystem needs additional capacity, the
system automatically allocates the capacity at that
time.

Note: The action of the Oracle FS System
automatically allocating additional capacity to a
thinly provisioned logical volumeis called infill.
This additional capacity might not be contiguous
with the previous allocations.
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Related Links
Capacities
Growing Thin Volumes

Provisioning Thin Volumes

The capacity that is reserved for thin provisioning, which is a part of the system
overhead, is accounted for in the available capacity that Oracle FS System
Manager (GUI) reports. Because the system has already accounted for this
reserve capacity, what the GUI reports as available capacity is fully available for
the provisioning of logical volumes.

For SAN LUNs, the degree to which a LUN is thinly provisioned depends on the
nature of the host applications that access the LUN. If only specific portions of a
LUN are ever accessed by applications, the thinness of that volume remains the
same. As applications attempt to access increasingly diverse areas of the LUN,
however, the Oracle FS System allocates additional physical space for the LUN,
causing the thinness of the volume to decrease.

Some applications access most or all of the addressable space for a volume. In
these cases, the volume transitions from being thinly provisioned to being fully
provisioned while the application executes. An example of such an application is
the mkfs utility, which creates a filesystem on a partition. As the mkfs utility
formats the filesystem, most or all of the partition is written by the utility, causing
the underlying volume on the Oracle FS System to become fully provisioned. In
these cases, creating the underlying volume using thin provisioning has little
value.

The Microsoft Windows operating system reserves a substantial amount of
metadata for a filesystem that has been formatted as a New Technology File
System (NTFS) volume. The layout of this metadata causes an early allocation of
thinly provisioned space. The primary NTFS metadata consists of the following
objects:

• The boot record, which is written to both the beginning and the end of the
volume

• The master file table (MFT), which is written to both the beginning of the
volume and the middle of the volume

To prevent the MFT from becoming fragmented, Windows reserves a buffer
around the MFT. The size of this buffer can be configured to be 12.5%, 25%,
37.5%, or 50% of the drive space. Windows does not create new files in this buffer
region until the unused space is consumed. Each time the remainder of the drive
space becomes full, the buffer size is halved. This strategy provides new space
for additional write operations.

Oracle does not recommend creating a thinly provisioned LUN that consumes
more than 90% of the maximum capacity on the first infill, especially when using
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NTFS. NTFS writes throughout the LUN, causing allocations that do not match
the amount of data that is written.

A heavily used NTFS filesystem running without much free capacity eventually
uses up all of the capacity unless the filesystem is defragmented periodically.
NTFS favors writing into newly allocated space instead of reusing previously
written space. NTFS works with thin provisioning initially but can quickly use
up more allocation than the amount of data that the filesystem shows as used.

Because thin provisioning uses Controller resources and affects performance, a
good use of thin provisioning is for a LUN that has the following characteristics:

• The initial allocation is equal to the amount of existing data, plus 10%. This
value becomes the allocated logical capacity.

• The addressable logical capacity is as large as you expect that the LUN will
ever need.

For example, given 420 GB of file data, the administrator should configure the
allocated logical capacity of the LUN to be approximately 470 GB and the
addressable logical capacity to be approximately 1 TB.

Note: How much capacity NTFS uses depends on many factors, including the
amount of data involved in the write operations, where the write operations are
performed, and other factors such as the type of storage used in the storage pool.

On Linux platforms, EXT2 and EXT3 filesystems write metadata over the entire
range of logical block addresses (LBAs) of the LUN. The drive is organized into
block groups and metadata exists at the beginning of each block group. This
configuration typically causes the entire LUN to be provisioned when the
administrator creates a filesystem. This full provisioning occurs because the
metadata write is below the minimum allocation unit that is used by the
Oracle FS Systems. This condition causes the system to expand every allocation
extent to the maximum size.

In summary, the success of utilizing thin provisioning depends on the filesystem
or the application using the LUN.

Related Links
Thin Provisioning

Growing Thin Volumes

When a thinly provisioned volume needs additional capacity, the Oracle FS
System automatically allocates the capacity at that point in time, which grows (or
infills) the thin volume.

Note: The additional capacity that is allocated, however, might not be contiguous
with the previous allocations.
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Growth Increments
When the Oracle FS System infills a logical volume, the system divides the
allocation into slices that are called growth increments. The system uses as many of
the slices as are needed to fulfill the allocation.

For LUNs using regular QoS (single-tiered LUNs), the size of a growth increment
is between 1 GB and 2 GB. For example, if the volume is 2 TB, the system uses a
number of increments between 1024 and 2048 for the allocation. The exact
number depends on the results of an algorithm that utilizes the following storage
properties of the single-tiered volume:

• The Storage Class of the drive groups on which the volume is placed

• The RAID level of the volume

• The number of drive groups across which the volume is striped, which is
controlled by the Priority QoS property

Note: For LUNs using QoS Plus (auto-tiered LUNs), the size of a growth
increment is 640 KB.

Growing LUNs
SAN LUNs reside in a single Storage Domain and utilize the capacity that is
provided by the Storage Classes that you specify for the LUNs. For a thinly
provisioned LUN, the following rules also apply:

• The growth of a single‑tiered LUN using regular QoS is confined to the
drive groups that support the Storage Class that is assigned to the LUN.

• The growth of an auto-tiered LUN can grow by utilizing the capacity in
any of the storage tiers, independent of Storage Class.

Growing Filesystems
Filesystems reside in NAS-based storage tiers that are called data tiers, which
hold user data, and metadata tiers, which hold filesystem metadata. Data tiers and
metadata tiers are dedicated to a specific filesystem.

The growth of a NAS storage tier that supports a thinly provisioned filesystem is
restricted by the following rules:

• The growth of the tier is confined to the drive groups that support the
Storage Class that is assigned to the tier.

• The growth of the tier is confined within the boundaries of the Storage
Domain in which the tier resides.

Related Links
Priority Level and Performance
Redundancy and Data Protection
Storage Class Description
Storage Tiers
Thin Provisioning
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Reclaiming Capacity
When you delete a logical volume, the Oracle FS System reconditions the space
(by writing a predefined bit pattern) before reclaiming the space for reuse. As the
previously allocated capacity frees up, the capacity becomes available for
allocation.

When you delete a large volume, the operation can take awhile for all of the
capacity to be reclaimed. Because of the additional time that is needed to
recondition the drives holding the volume data, the amount of physically
allocated capacity plus the amount of physically free capacity in the owning
drive groups might not equal the total physical capacity in those drive groups.
Therefore, while the deleted capacity is being reconditioned, Oracle FS System
Manager (GUI) displays the amount of physical capacity that remains to be
reconditioned as “preparing.”

Related Links
Compact a Storage Domain
Capacities

About QoS and Provisioning

120



CHAPTER 5

Manage SAN Volumes

Managing SAN LUNs
A LUN is defined as the following: A logical volume that is defined over a
collection of drive groups and is addressed using SCSI protocol in a SAN. An
administrator defines the QoS attributes of the LUN.

Use Oracle FS System Manager (GUI) to perform the following actions:

• Create a single‑tier or auto‑tiered LUN.

• Modify the properties of a LUN.

• Map a LUN to specific SAN host entries or multiple host entries.

• Move a LUN from one Storage Domain to another.

• Enable and disable the data path to a LUN.

• Provide clone and copy operations on a LUN for various purposes,
including data protection.

You assign the storage resources and QoS attributes when you create the LUN.
As needs change, you can later modify the QoS attributes of the LUN, the storage
capacity that is assigned to the LUN, or both. You can designate the LUN as
auto‑tier. With an auto‑tiered LUN, the system continuously monitors its I/O and
gathers statistics for analysis. From this analysis, data is placed on the tier that
best matches its use.

Note: When you create a LUN, the system automatically sets the tiering level of
the LUN to single tier. If you want to allow for automatic data migration to
higher data tiers, change the LUN to an auto-tiered LUN. If you create an auto-
tiered LUN when the system contains only one Storage Class, no data migration
occurs until other Storage Classes are added to the system.

The Oracle FS System creates two storage tiers for each Storage Class that is
present in the Storage Domain. Depending on the type of Storage Class, the
system assigns a RAID level for each tier. The administrator views the properties
of the storage tier by accessing the QoS properties and Storage Class. The
following table defines the RAID levels by Storage Class.
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Table 9: RAID level by storage class and storage tier
 Storage tier

Storage class Tier 1 Tier 2
Capacity HDD RAID 6 RAID 10

Capacity SSD RAID 5 RAID 10

Performance HDD RAID 5 RAID 10

Performance SSD RAID 5 RAID 10

You can use the Oracle FS System Manager (GUI) to disable the data path to the
LUN. Disabling the data path makes the LUN inaccessible to the SAN host.

To provide data protection for a LUN, you can clone the volume. You can
manually clone or copy a LUN. You can also create a schedule so that the system
automatically creates cloned LUNs at times that you define.

Related Links
Data Migration
LUN Statistics and Trending Overview
QoS Policies
Storage Class Description
Storage Tiers
Creating Auto-Tiered LUNs
Single‑Tier QoS for LUNs
Mapping LUNs and SAN Host Entries
Disable the Data Path of a LUN

Creating Auto-Tiered LUNs
When you create an auto‑tiered LUN, you select the initial properties for QoS
and Storage Class, and you provide the capacity requirements for the LUN. By
default, the system has access to all of the available Storage Classes for data
migration.

An auto‑tiered LUN is a LUN that uses the auto‑tier (QoS Plus) feature. This
feature uses the configured Storage Class within the Storage Domain to
optimally store the data and to make the best use of the available storage types
and capacities. Even though the system sets the LUN initially to single tier, you
can select the auto‑tier option, if desired.

As data is stored and retrieved in the LUN, the Oracle FS System migrates that
portion of the data to the appropriate Storage Classes. This process is called data
migration. Data migration that results from the QoS Plus feature occurs when the
system, after an analysis of the historical usage information for the block of data,
determines that another Storage Class or RAID level can better service that block
of data.
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Auto‑tiered LUNs can access all of the configured Storage Classes in the Storage
Domain. When you create an auto‑tiered LUN, you are presented with a
graphical representation of the Storage Domain capacities and the storage
allocation by Storage Class. The graphs provide an overview of the potential
storage usage for the LUN so that you can plan your storage requirements
appropriately.

Administrators can create Storage Domains in the system. When the system
contains more than one Storage Domain, the Storage Domain field displays on
the GUI screen. Otherwise this field is not present in the GUI and the system
assigns the LUN to the default Storage Domain.

The Oracle FS System calculates whether enough storage resources are available
to create a new logical volume. Oracle FS System Manager (GUI) provides
graphs that represent the Storage Domain capacity requirements for the volume
and a second graph that represents the storage capacity by storage class. The
system updates the graphs as you adjust the QoS values for Storage Class and
redundancy.

Note: The capacity values displayed in the usage graphs represent the sizes of the
largest volume that you can create in a particular Storage Class, given one of two
performance configurations.

The Create LUN dialog contains three tabs for entering the QoS information and
mapping the LUN to a host entry.

Quality of Service (Required) The Quality of Service tab allows you to define
the QoS attributes for a LUN, assign your LUN to a volume
group and a Storage Domain. You can also create a volume
group from this tab and view the Storage Domain
properties.

Note: If no custom Storage Domains have been defined, the
Storage Domain option does not appear on the tab.

Enter the LUN volume name, and then select a Storage
Profile that contains predefined QoS attributes. If necessary,
choose the custom QoS attributes. The system contains two
levels of QoS settings: Basic and Advanced.
The QoS settings that you enter for your LUN help the
system determine the initial placement of the data. When
enough statistics and usage history is collected about the
data, the system determines whether to move some of the
data to a different storage tier.
When you create an auto‑tiered LUN and request a nonzero
amount of capacity to be allocated, the Oracle FS System
takes a few minutes to reserve that capacity. Until the
capacity allocation process completes, the system reports
the allocated capacity as zero (0). After the allocation
process completes, the system reports the amount of
allocated capacity that you originally requested.
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Mapping (Optional) The Mapping tab allows you to specify which
SAN host entries can access the LUN.
You can map the LUN using one of the following methods:

• Map the LUN to a SAN host entry using a specific
LUN number.

• Map all SAN host entries to access the LUN using the
same LUN number. This method is not
recommended.

Data Protection (Optional) The Data Protection tab allows you to allocate
the storage capacity for the Clone LUNs repository. You can
apply unique QoS properties to the Clone LUN repository
and assign the maximum storage capacity for the repository.
You can also create a clone schedule to perform data
protection at regular intervals.

Related Links
Free Capacity and Volume Creation
QoS Plus Overview
Storage Domains
Storage Profiles
Volume Groups
Modifying Auto-Tiered LUNs
Mapping LUNs and SAN Host Entries
Create Auto-Tiered LUN: Define Quality of Service
Create Auto-Tier LUN: Define Data Protection

Create Auto-Tiered LUN: Define Quality of Service

Define the Quality of Service (QoS) attributes to allocate the storage resources
that are necessary to create the auto‑tiered LUN.

1 Navigate to SAN > Storage > LUNs.

2 Select Actions > Create.

3 Click Auto Tier.

4 (Optional) From the Storage Domain list, select the Storage Domain that
you want to assign to the LUN.
If necessary, click the browse button, […] to display a list of available
Storage Domains.

Note: The Storage Domain list displays only when administrator‑defined
Storage Domains exist. If no administrator‑defined Storage Domains exist
or you do not assign the LUN to a specific Storage Domain, then the
system assigns the LUN to the default Storage Domain.

5 Enter a name in the LUN Name field.
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6 (Optional) From the Volume Group list, select the volume group that you
want the LUN to belong.

Note: If necessary, click the browse button, […] to create a volume group.

7 To use the QoS properties of an existing Storage Profile, select the Use
Storage Profile field, and then select the desired profile from the list.

Selecting a Storage Profile sets the remaining QoS property fields to
read‑only and displays the Advanced QoS settings that are associated with
the Storage Profile.

8 Select the Initial Storage Class where you want to store the LUN.
Possible classes:

• Capacity Disk
• Capacity SSD
• Performance Disk
• Performance SSD

9 (Optional) Select the Basic link.

The indirect QoS properties display. Available selections:

• Initial Typical Access
• Initial I/O Bias
• Initial Redundancy

10 (Optional) From the Initial Typical Access list, select the common access
method for this LUN.
Available access methods:

• Sequential
• Random
• Mixed

11 (Optional) From the Initial I/O Bias list, select the typical read‑write ratio
for this LUN.
Available biases:

• Read
• Write
• Mixed

12 (Optional) Select the Advanced link.

The direct QoS properties display. Available selections:

• Initial RAID Level
• Initial Read Ahead
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Important: Selecting Advanced QoS properties clears the Basic QoS
selections.

13 (Optional) From the Initial RAID Level list, select the RAID level to
associate with this LUN.
Possible RAID levels:

• Single Parity
• Double Parity
• Mirrored

14 (Optional) From the Initial Read Ahead list, select the read‑ahead polity to
apply to this LUN.
Valid policies:

• Normal
• Aggressive
• Conservative

15 (Optional) From the Priority Level field, select the desired option for the
LUN.
Valid choices:

• Premium
• High
• Medium
• Low
• Archive

16 (Optional) From the Migration/Copy Priority list, select the priority to
define how the system performs background copies.
Valid choices:

• System Chooses
• Minimize Impact
• Maximize Speed

17 (Optional) Click the Additional Options button.
The Additional Options dialog appears.

18 (Optional) From the Additional Options dialog, select the desired Storage
Classes that you want the auto‑tier LUN to use.

19 (Optional) To enable auto‑tiering, select the Tier Reallocation Enabled
check box.

20 Click Close.
21 In the Allocated and Addressable fields, specify the logical capacities for

this volume.
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Note: Use the storage capacity usage graphs to determine the impact on
the storage requirements for the LUN.

22 To create the LUN now, click OK.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.

• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Related Links
Create SAN LUN, Quality of Service Tab, Auto‑tier
QoS Plus Overview
Managing SAN LUNs
Mapping LUNs and SAN Host Entries
Create Auto-Tier LUN: Define Data Protection

Create Auto-Tier LUN: Define Data Protection

You can allocate clone capacity for an auto‑tier LUN and create a schedule to
perform clone operations on a regular basis. The Data Protection page also
allows you to either use custom QoS settings for your clones or use the LUN
settings.

After the clone is created, you can change the priority level and other properties
of the clone. When creating a Clone LUN, make sure that enough repository
space exists for the clone. The system stores in the clone repository only the
changes that are made to the source volume or to the clone.

1 Navigate to SAN > Storage > LUNs.

2 Select Actions > Create.

3 Click Auto Tier.

4 Click the Data Protection tab.

5 To allow the system to create Clone LUNs, select the Enable Clones check
box.
Selecting this option enables the remaining options on the page.

6 In the Maximum Capacity field, enter a value for the Capacity for Clone
Storage. The system sets a default of 110% of the LUN storage capacity.
Selecting a value of 100% provides enough capacity to avoid strict control
over the storage capacity without using up unnecessary capacity.
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CAUTION: Allocate sufficient repository or clone storage capacity to
minimize the chances of running out of this space (which could lead to
data inconsistency or loss). To set sufficient capacity, use a value equal to
the source volume capacity multiplied by the number of replicas
multiplied by the maximum rate of change. For example, for a 100 GB
volume that is projected to have 20 active replicas at a time and no more
than a 20% rate of change, use a value of 400 GB for the storage capacity.

7 (Optional) Select the Match Repository QoS to LUN QoS check box.
Selecting the Match Repository QoS to LUN QoS option applies the LUN
QoS properties to the clones and disables the Clone Storage QoS fields.

8 (Optional) From the Storage Domain list, select the Storage Domain that
you want to assign the LUN.

9 Select the Initial Storage Class where you want to store the LUN.
Possible classes:

• Capacity Disk
• Capacity SSD
• Performance Disk
• Performance SSD

10 (Optional) Select the Basic link.

The indirect QoS properties display. Available selections:

• Initial Typical Access
• Initial I/O Bias
• Initial Redundancy

11 (Optional) From the Initial Typical Access list, select the common access
method for this LUN.
Available access methods:

• Sequential
• Random
• Mixed

12 (Optional) From the Initial I/O Bias list, select the typical read‑write ratio
for this LUN.
Available biases:

• Read
• Write
• Mixed

13 (Optional) Select the Advanced link.

The direct QoS properties display. Available selections:
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• Initial RAID Level

Important: Selecting Advanced QoS properties clears the Basic QoS
selections.

14 (Optional) From the Initial RAID Level list, select the RAID level to
associate with this LUN.
Possible RAID levels:

• Single Parity
• Double Parity
• Mirrored

15 (Optional) From the Priority Level field, select the desired option for the
LUN.
Valid choices:

• Premium
• High
• Medium
• Low
• Archive

16 (Optional) Click the Additional Options button.
The Additional Options dialog appears.

17 (Optional) From the Additional Options dialog, select the desired Storage
Classes that you want the auto‑tier LUN to use.

18 Click Close.

19 (Optional) To create a Clone LUN data protection schedule, click Create.
See the procedure for creating Clone LUNs on a scheduled basis.

20 (Optional) Click OK.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.

• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Manage SAN Volumes

129



Related Links
Create SAN LUN, Data Protection Tab, Auto Tier
Managing SAN LUNs
Mapping LUNs and SAN Host Entries
Create Auto-Tiered LUN: Define Quality of Service

Modifying Auto-Tiered LUNs
You might need to modify the current Quality of Service (QoS) attributes for an
auto‑tiered LUN. Modifications include increasing the capacity and allocating
space for Clone LUNs. You can also modify the mapping of a LUN as well as
change the Controller to which the LUN is assigned. If necessary, you can also
convert the auto‑tiered LUN to single‑tier.

Note: When you change the Storage Class of a logical volume, the volume is
migrated to the new Storage Class. Any existing clones of that volume are not
migrated to the new Storage Class.

You modify a LUN by entering the QoS attributes on the Oracle FS System
Manager screen. The Modify LUN screen contains three tabs for entering QoS
information and mapping the LUN to a host entry.

Quality of Service (Required) The Quality of Service tab allows you to change
the assigned volume group or Storage Domain. You can
also create a group if one does not exist. This tab also allows
you to customize QoS attributes, including selecting a
storage profile, storage class, redundancy, and other
properties, depending on the selected parameters. You can
also set the capacity limits for the LUN and view the effects
that the selected QoS attributes would have on the storage
class and overall system storage capacities.

Mapping (Optional) The Mapping tab allows you to specify which
SAN host entries can access the LUN.
You can map the LUN using one of the following methods:

• Map the LUN to a SAN host entry using a specific
LUN number.

• Map all SAN host entries to access the LUN using the
same LUN number. This method is not
recommended.

Data Protection (Optional) The Data Protection tab allows you to allocate
the storage capacity for the Clone LUNs repository. You can
apply unique QoS properties to the Clone LUN repository
and increase, but not decrease, the maximum clone capacity
of your clone. You can also create a clone schedule to
perform data protection at regular intervals.
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Related Links
QoS Plus Overview
Modify Auto-Tiered LUN: Define Quality of Service
Modify Auto-Tiered LUN: Change to Single-Tier QoS
Modify Auto-Tiered LUN: Define Data Protection

Modify Auto-Tiered LUN: Define Quality of Service

You might need to modify the current QoS attributes for an auto‑tiered LUN.
Modifications include increasing the capacity or allocate space for Clone LUNs.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 From the Quality of Service tab, modify the necessary QoS attributes.

5 To save your changes to the LUN, click OK.

Related Links
Modify SAN LUN, Quality of Service Tab, Auto Tier
QoS Plus Overview
Modifying Auto-Tiered LUNs

Modify Auto-Tiered LUN: Change to Single-Tier QoS

You might want to change an auto‑tiered LUN to single‑tier LUN when you want
to use fixed QoS resources and Storage Classes.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 Click the Quality of Service tab.

5 Click Single Tier.

6 Update the QoS properties, as necessary.

7 To save your changes to the LUN, click OK.

The Tier Reallocation column of the LUNs overview page changes states from an
auto‑tier state, such as Enabled, to a dash (‑ ‑). This state change indicates that
the LUN is now single-tier.

Related Links
Modify SAN LUN, Quality of Service Tab, Single Tier
Modifying Auto-Tiered LUNs
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Modify Auto-Tiered LUN: Define Data Protection

You can modify the allocated clone capacity and QoS properties for your
auto‑tiered LUN and manage the data protection schedules.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 Click the Data Protection tab.

5 Update the fields, as necessary.

6 (Optional) To create a Clone LUN data protection schedule, click Create.
See the procedure for creating Clone LUNs on a scheduled basis.

7 (Optional) To update an existing data protection schedule, select the
schedule from the Clone Schedules list and then click Modify.
See the procedure for modifying the schedule for details.

8 (Optional) To remove an existing data protection schedule, select the
schedule from the Clone Schedules list and then click Delete.

Note: You are not prompted to confirm the removal of the data protection
schedule.

9 To save your changes to the LUN, click OK.

Related Links
Modify SAN LUN, Data Protection Tab, Auto Tier
Create a LUN Data Protection Schedule
Modifying Auto-Tiered LUNs

Single‑Tier QoS for LUNs
Single‑tier LUNs have QoS properties that specify the Storage Class and other
performance parameters for storing data on the LUN on the Oracle FS System.

The QoS properties of a single‑tier LUN remains unchanged until the
administrator changes these properties. An auto‑tier LUN monitors the data
activity and automatically adjusts the QoS properties based on system
performance and data activity. For some applications, you might not want the
Oracle FS System to make changes to your QoS properties. In this case a
single‑tier is preferred.

Consider creating a single‑tier LUN when the following reasons apply:

• Your application requires low latency for all I/O. A single‑tier allows you to
specify the Storage Class, such as a Performance SSD. Specifying the
Storage Class ensures that the system uses this class regardless of the
access frequency by your application.
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• Your application is accessed frequently but has no particular performance
requirement. A single‑tier allows you to isolate your long-term data to a
high‑capacity drive, which has regular performance characteristics.

• You are migrating an application from an existing system to the Oracle FS
System and the existing system has LUNs configured for specific
performance requirement of your applications.

If needed, you can change the tier type to auto‑tier after you create the LUN.

Related Links
QoS Policies
Managing SAN LUNs
Creating Single‑Tier LUNs
Modifying Single‑Tier LUNs

Creating Single‑Tier LUNs

The Oracle FS System creates LUNs in a single storage tier, which consists of
Quality of Service (QoS) properties and Storage Classes.

When you create a LUN, the Oracle FS System calculates whether there is
enough storage resources available to create a new logical volume. The Oracle FS
System Manager (GUI) provides graphs that represent the storage capacity
requirements for the volume and a second graph that represents the overall
system capacity requirements. The system updates the graphs as you adjust the
QoS values for Storage Class and redundancy.

Note: The capacity values displayed in the usage graphs represent the sizes of the
largest volume that you can create in a particular Storage Class, given one of two
performance configurations.

Administrators can create Storage Domains in the system. When the system
contains more than one Storage Domain, the Storage Domain field displays on
the GUI screen. Otherwise this field is not present in the GUI and the system
assigns the LUN to the default Storage Domain.

You can also assign a LUN to a volume group. If a volume group is not available,
you can create one on the screen. administrative system object that is used to
organize logical volumes and, possibly, other volume groups. Volume groups can
span Storage Domains.

The Create LUN dialog contains three tabs for entering the QoS information and
mapping the LUN to a host entry.

Quality of Service (Required) The Quality of Service tab allows you to define
the QoS attributes for a LUN, assign your LUN to a volume
group and a Storage Domain. You can also create a volume
group from this tab and view the Storage Domain
properties.
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Note: If no custom Storage Domains have been defined, the
Storage Domain option does not appear on the tab.

Enter the LUN volume name, and then select a Storage
Profile that contains predefined QoS attributes. If necessary,
choose the custom QoS attributes. The system contains two
levels of QoS settings: Basic and Advanced.

Mapping (Optional) The Mapping tab allows you to specify which
SAN host entries can access the LUN.
You can map the LUN using one of the following methods:

• Map the LUN to a SAN host entry using a specific
LUN number.

• Map all SAN host entries to access the LUN using the
same LUN number. This method is not
recommended.

Data Protection (Optional) The Data Protection tab allows you to allocate
the storage capacity for the Clone LUNs repository. You can
apply unique QoS properties to the Clone LUN repository
and assign the maximum storage capacity for the repository.
You can also create a clone schedule to perform data
protection at regular intervals.

Related Links
Free Capacity and Volume Creation
Storage Domains
Storage Profiles
Volume Groups
Single‑Tier QoS for LUNs
Mapping LUNs and SAN Host Entries
Create Single-Tier LUN: Define Quality of Service
Create Single-Tier LUN: Define Data Protection

Create Single‑Tier LUN: Define Quality of Service

Define the Quality of Service (QoS) attributes to allocate the storage resources
that are necessary to create the Single‑Tier LUN.

Oracle FS System Manager (GUI) provides a list of Storage Profiles that contain
QoS attributes. When you select a Storage Profile, the system automatically fills
in the QoS fields with the values defined for the Storage Profile. Selecting a
Storage Profile disables the custom QoS settings. To define custom QoS settings,
you can create your own Storage Profile. A custom Storage Profile can then be
selected from the Storage Profile list.

Storage Domains enable storage administrators to assign logical volumes to
specific Storage Domains. Such assignments can be made to reduce contention
among volumes, to implement different levels of security for those volumes, or
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both. When more storage capacity is required, the administrator can add drive
groups to the Storage Domain.

Volume groups allow you to group logical volumes into one administrative unit.
You can then treat this volume group as a single, large volume.

1 Navigate to SAN > Storage > LUNs.
2 Select Actions > Create.
3 Click Single Tier.
4 (Optional) From the Storage Domain list, select the Storage Domain that

you want to assign to the LUN.
If necessary, click the browse button, […] to display a list of available
Storage Domains.

Note: The Storage Domain list displays only when administrator‑defined
Storage Domains exist. If no administrator‑defined Storage Domains exist
or you do not assign the LUN to a specific Storage Domain, then the
system assigns the LUN to the default Storage Domain.

5 Enter a name in the LUN Name field.
6 (Optional) From the Volume Group list, select the volume group that you

want the LUN to belong.

Note: If necessary, click the browse button, […] to create a volume group.
7 To use the QoS properties of an existing Storage Profile, select the Use

Storage Profile field, and then select the desired profile from the list.

Selecting a Storage Profile sets the remaining QoS property fields to
read‑only and displays the Advanced QoS settings that are associated with
the Storage Profile.

8 Select the Storage Class where you want to store the LUN.
Possible classes:

• Capacity Disk
• Capacity SSD
• Performance Disk
• Performance SSD

9 (Optional) Select the Basic link.

The indirect QoS properties display. Available selections:

• Typical Access
• I/O Bias
• Redundancy

10 (Optional) From the Typical Access list, select the common access method
for this LUN.
Available access methods:

Manage SAN Volumes

135



• Sequential
• Random
• Mixed

11 (Optional) From the I/O Bias list, select the typical read‑write ratio for this
LUN.
Available biases:

• Read
• Write
• Mixed

12 (Optional) From the Redundancy list, select the number of parity bits to
copy for this LUN.
Available redundancies:

• Single
• Double

13 (Optional) Select the Advanced link.

The direct QoS properties display. Available selections:

• RAID Level
• Read Ahead

Important: Selecting Advanced QoS properties clears the Basic QoS
selections.

14 (Optional) From the RAID Level list, select the RAID level to associate
with this LUN.
Possible RAID levels:

• Single Parity
• Double Parity
• Mirrored

15 (Optional) From the Read Ahead list, select the read‑ahead policy to apply
to this LUN.
Valid policies:

• Normal
• Aggressive
• Conservative

16 (Optional) From the Priority Level field, select the desired option for the
LUN.
Valid choices:
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• Premium
• High
• Medium
• Low
• Archive

17 (Optional) From the Migration/Copy Priority list, select the priority to
define how the system performs background copies.
Valid choices:

• System Chooses
• Minimize Impact
• Maximize Speed

18 In the Allocated and Addressable fields, specify the logical capacities for
this volume.

Note: Use the storage capacity usage graphs to determine the impact on
the storage requirements for the LUN.

19 To create the LUN now, click OK.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.

• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Related Links
Create SAN LUN, Quality of Service Tab, Single Tier
Managing SAN LUNs
Mapping LUNs and SAN Host Entries
Create Single-Tier LUN: Define Data Protection

Create Single‑Tier LUN: Define Data Protection

You can allocate clone capacity for a single-tier LUN and create a schedule
Clone LUN to perform clone operations on a regular basis. The Data Protection
page also allows you to use custom QoS settings for your clones or use the LUN
settings.

After the clone is created, you can change the priority level and other properties
of the clone. When creating a Clone LUN, make sure that enough repository
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space exists for the clone. The system stores in the clone repository only the
changes that are made to the source volume or to the clone.

1 Navigate to SAN > Storage > LUNs.
2 Select Actions > Create.
3 Click Single Tier.
4 Click the Data Protection tab.
5 To allow the system to create Clone LUNs, select the Enable Clones check

box.
Selecting this option enables the remaining options on the page.

6 In the Maximum Capacity field, enter a value for the Capacity for Clone
Storage. The system sets a default of 110% of the LUN storage capacity.
Selecting a value of 100% provides enough capacity to avoid strict control
over the storage capacity without using up unnecessary capacity.

CAUTION: Allocate sufficient repository or clone storage capacity to
minimize the chances of running out of this space (which could lead to
data inconsistency or loss). To set sufficient capacity, use a value equal to
the source volume capacity multiplied by the number of replicas
multiplied by the maximum rate of change. For example, for a 100 GB
volume that is projected to have 20 active replicas at a time and no more
than a 20% rate of change, use a value of 400 GB for the storage capacity.

7 (Optional) Select the Match Repository QoS to LUN QoS check box.
Selecting the Match Repository QoS to LUN QoS option applies the LUN
QoS properties to the clones and disables the Clone Storage QoS fields.

8 (Optional) From the Storage Domain list, select the Storage Domain that
you want to assign the LUN.

9 Select the Storage Class where you want to store the LUN.
Possible classes:

• Capacity Disk
• Capacity SSD
• Performance Disk
• Performance SSD

10 (Optional) Select the Basic link.

The indirect QoS properties display. Available selections:

• Typical Access
• I/O Bias
• Redundancy

11 (Optional) From the Typical Access list, select the common access method
for this LUN.
Available access methods:
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• Sequential
• Random
• Mixed

12 (Optional) From the I/O Bias list, select the typical read‑write ratio for this
LUN.
Available biases:

• Read
• Write
• Mixed

13 (Optional) From the Redundancy list, select the number of parity bits to
copy for this LUN.
Available redundancies:

• Single
• Double

14 (Optional) Select the Advanced link.

The direct QoS properties display. Available selections:

• RAID Level
• Read Ahead

Important: Selecting Advanced QoS properties clears the Basic QoS
selections.

15 (Optional) From the RAID Level list, select the RAID level to associate
with this LUN.
Possible RAID levels:

• Single Parity
• Double Parity
• Mirrored

16 (Optional) From the Priority Level field, select the desired option for the
LUN.
Valid choices:

• Premium
• High
• Medium
• Low
• Archive

17 (Optional) To create a Clone LUN data protection schedule, click Create.
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See the procedure for creating Clone LUNs on a scheduled basis.

18 (Optional) Click OK.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.

• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Related Links
Create SAN LUN, Data Protection Tab, Single Tier
Managing SAN LUNs
Mapping LUNs and SAN Host Entries
Create Single-Tier LUN: Define Quality of Service

Modifying Single‑Tier LUNs

You might need to modify the current Quality of Service (QoS) attributes for a
Single‑Tier LUN, such as increase the capacity or allocate space for Clone LUNs.
You can also modify the mapping of a LUN as well as change the Controller to
which the LUN is assigned.

Note: When you change the Storage Class of a logical volume, the volume is
migrated to the new Storage Class. Any existing clones of that volume are not
migrated to the new Storage Class.

You modify a LUN by entering the QoS attributes on the Oracle FS System
Manager screen. The Modify LUN screen contains three tabs for entering QoS
information and mapping the LUN to a host entry.

Quality of Service (Required) The Quality of Service tab allows you to change
the assigned volume group or Storage Domain. You can
also create a group if one does not exist. This tab also allows
you to customize QoS attributes, including selecting a
storage profile, storage class, redundancy, and other
properties, depending on the selected parameters. You can
also set the capacity limits for the LUN and view the effects
that the selected QoS attributes would have on the storage
class and overall system storage capacities.

Mapping (Optional) The Mapping tab allows you to specify which
SAN host entries can access the LUN.
You can map the LUN using one of the following methods:
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• Map the LUN to a SAN host entry using a specific
LUN number.

• Map all SAN host entries to access the LUN using the
same LUN number. This method is not
recommended.

Data Protection (Optional) The Data Protection tab allows you to allocate
the storage capacity for the Clone LUNs repository. You can
apply unique QoS properties to the Clone LUN repository
and increase, but not decrease, the maximum clone capacity
of your clone. You can also create a clone schedule to
perform data protection at regular intervals.

Related Links
Modify Single‑Tier LUN: Quality of Service
Modify Single‑Tier LUN: Change to Auto-Tiered LUN
Modify Single‑Tier LUN: Data Protection

Modify Single‑Tier LUN: Quality of Service

You might need to modify the current QoS attributes for a LUN, such as increase
the capacity or allocate space for Clone LUNs.

1 Navigate to SAN > Storage > LUNs.
2 Select the LUN that you want to modify.
3 Select Actions > Modify.
4 From the Quality of Service tab, modify the necessary QoS attributes.
5 To save your changes to the LUN, click OK.

Related Links
Modify SAN LUN, Quality of Service Tab, Single Tier
Modifying Single‑Tier LUNs

Modify Single‑Tier LUN: Change to Auto-Tiered LUN

You might want to change a single‑tier LUN to an auto‑tiered LUN when you
want to make efficient use of the Oracle FS System resources.

1 Navigate to SAN > Storage > LUNs.
2 Select the LUN that you want to modify.
3 Select Actions > Modify.
4 Click the Quality of Service tab.
5 Click Auto Tier.
6 (Optional) Click the Additional Options button.

The Additional Options dialog appears.
7 (Optional) From the Additional Options dialog, select the desired Storage

Classes that you want the auto‑tier LUN to use.
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8 (Optional) To enable auto‑tiering, select the Tier Reallocation Enabled
check box.

9 Click Close.

10 Update the QoS properties, as necessary.

11 To save your changes to the LUN, click OK.

The Tier Reallocation column of the LUNs overview page changes states from a
dash (‑ ‑) to some other state, such as Enabled. This state change indicates that
the LUN is now auto‑tier.

Related Links
Modify SAN LUN, Quality of Service Tab, Auto Tier
Modifying Single‑Tier LUNs

Modify Single‑Tier LUN: Data Protection

You can modify the allocated clone capacity and QoS properties for your
single‑tier LUN. You can also manage the data protection schedules.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 Click the Data Protection tab.

5 Update the fields, as necessary.

6 (Optional) To create a Clone LUN data protection schedule, click Create.
See the procedure for creating Clone LUNs on a scheduled basis.

7 (Optional) To update an existing data protection schedule, select the
schedule from the Clone Schedules list and then click Modify.
See the procedure for modifying the schedule for details.

8 (Optional) To remove an existing data protection schedule, select the
schedule from the Clone Schedules list and then click Delete.

Note: You are not prompted to confirm the removal of the data protection
schedule.

9 To save your changes to the LUN, click OK.

Related Links
Modify SAN LUN, Data Protection Tab, Single Tier
Modifying Single‑Tier LUNs

Display LUN Details
You can display details about a selected LUN.

The LUN details include:
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• Single‑tier LUN or auto‑tier LUN

• Quality of Service (QoS) attributes

• Allocated storage capacity

• Volume group and Storage Domain associations

• SAN host entry mapping details and Controller port masking assignments

• Clone capacity and cloning schedules

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN you want to view.

3 Select Actions > View.

4 Select any of the tabbed pages to view the LUN properties.

5 Click Close.

Related Links
View SAN LUN, Data Protection Tab, Single Tier
View SAN LUN, Mapping Tab
View SAN LUN, Quality of Service Tab, Single Tier
Controller Ports
QoS Policies
Storage Domains
Volume Groups
Modifying Auto-Tiered LUNs
Modifying Single‑Tier LUNs
Mapping LUNs and SAN Host Entries

Disable the Data Path of a LUN
You might want to remove the ability of a SAN host to access a LUN or
Clone LUN.

Disabling the data path to the logical volume prevents I/O operations on the
volume. However, mappings to the SAN host entries are retained.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to disable from the data path.

3 Select Actions > Disable Data Path.
A confirmation dialog displays.

4 To disable the data path for the LUN, click OK.

On the LUN overview page, the Host Access status of the volume changes to
Inactive. You must enable the LUN to start I/O and make the LUN accessible on
the network
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Related Links
SAN LUNs Overview Page
Managing SAN LUNs
Enable the Data Path of a LUN

Enable the Data Path of a LUN
Enabling the data path to a LUN restores the communication between the
mapped SAN host and the volume. When the data path to a LUN has been
disabled, you can provide the ability of a SAN host to access that LUN using the
host mappings already established.

The LUN overview page identifies the Host Access status of a disabled LUN as
Inactive.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to enable.

3 Select Actions > Enable Data Path.

4 To enable the data path, click OK.

On the LUN overview page, the Host Access status of the volume changes from
Inactive to the original status.

Related Links
SAN LUNs Overview Page
Managing SAN LUNs
Disable the Data Path of a LUN

Relocating LUNs
You can relocate a LUN from its assigned Controller to another Controller.

If you relocate a LUN from one Controller to another, the system reconfigures the
volume at the new location while attempting to maintain the integrity of the
data.

CAUTION: If a client attempts to modify that LUN while the LUN is being
relocated, the client loses its connection and data becomes corrupted or lost.
Before you relocate a LUN to another Controller, clients unmount the LUN to
ensure data integrity during the move.

Keep LUN copies on the same Controller as the source LUN until the
background copy has completed. You can monitor the status of this task from the
Task window.

Important: If the LUN is a member of a SAN replication pair, isolate the pair
before relocating the LUN to a different Controller. For more information, see the
Oracle MaxRep for SAN User’s Guide.
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Related Links
Data Replicas and System Capacity
Managing SAN LUNs
Change the LUN Location on a Controller

Change the LUN Location on a Controller
You can relocate a LUN from one Controller to another.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 Click the Mapping tab.
The current Controller assignment is displayed in the Current Controller
field.

5 From the Assigned Controller list, select the desired Controller.

6 To save your changes, click OK.

Related Links
Modify SAN LUN, Mapping Tab
Relocating LUNs

Delete a LUN
When a LUN is longer needed, you can delete it.

Note: When you delete a LUN, any clones that are in process or completed are
also deleted.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to delete.

3 Select Actions > Delete.
The system displays the Delete LUN dialog. The Delete LUN dialog lists
the LUN and the affected clones that the system identifies for deletion.

Note: The system displays the option, Delete LUNs and existing host
mappings when the LUN you are deleting contains host mappings.
Deleting a LUN with host mappings causes each of those hosts to lose
access to the LUN and clones.

4 To acknowledge that you want to delete the LUN, along with any clones
and host mappings, select the option Delete LUNs and existing host
mappings.

5 Click OK.
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Related Links
Delete LUN
Creating Auto-Tiered LUNs
Creating Single‑Tier LUNs

Mapping LUNs and SAN Host Entries
After creating your LUNs, map them to the SAN host entry so that the volumes
can be used by the Oracle FS System.

Mapping allows you to specify which SAN host entries can access the LUN.
Mapping your LUN to a host entry makes the LUN available to the Oracle FS
System.

You can map the LUN using one of the following methods:

• Map the LUN to a SAN host entry using a specific LUN number.

• Map all SAN host entries to access the LUN using the same LUN number.
This method is not recommended.

Related Links
Create LUN: Define Mapping by Selected Host Entries
Create LUN: Define Mapping by LUN Number
Modify LUN: Define Mapping by Selected Host Entries
Modify LUN: Define Mapping by LUN Number

Create LUN: Define Mapping by Selected Host Entries
Mapping your LUN makes the LUN available to the host entry. You can specify
that your LUN map to a specific host entry and LUN number.

1 Navigate to SAN > Storage > LUNs.
2 Select Actions > Create.
3 Click the Mapping tab.
4 Select the Access Protocol that permits access to the LUN.

Valid options:

• Fibre Channel (FC)
• iSCSI

5 Select the option Only selected hosts (via maps).
The system displays the Hosts mapping table.

6 From the LUN Controller Assignment controls, allow the Oracle FS System
to assign the Controller, by leaving the Assigned Controller option set to
the default, which is <auto assign>.

7 Click Create.
8 From the Create LUN Map dialog, define the mapping for the LUN, then

click OK or click OK and Continue.
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Valid options:

• LUN Name
• Host Name
• LUN Number

Tip: If network clients are running on Windows 2000 or 2003 platforms,
and you want those clients to be able to access the LUN, do not select LUN
number 255.

Note: Clicking OK and Continue allows you to map more hosts to this
LUN. Clicking OK creates the LUN mapping and closes the dialog.

9 (Optional) From the Ports Masked for this LUN table, select Yes for each
Controller port that you want to mask.
When you mask a port, the LUN cannot be accessed from the specified
ports.

Note: If you use Oracle FS System LUN masking or switch zoning and do
not use LUN assignment, you could create a situation in which a LUN is
not exposed on the ports through which you want the clients to be able to
access the LUN. To avoid this situation, assign the LUN to the Controller
on which you have the mapping set.

10 Click OK.

If the host entry that you want to allow access to the LUN is not displayed in the
list, add the host entry by associating the host initiator to the host entry.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.

• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Related Links
Create LUN Map Dialog
Create SAN LUN, Mapping Tab
Mapping LUNs and SAN Host Entries
Creating Auto-Tiered LUNs
Creating Single‑Tier LUNs
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Create LUN: Define Mapping by LUN Number
Mapping a LUN makes the LUN available to the host. You can specify that the
LUN map to a specific LUN number that any SAN host entry can use.

You might want all SAN host entries to be able to access a LUN using the same
unique LUN number. This approach requires that you not map any host to this
LUN.

1 Navigate to SAN > Storage > LUNs.

2 Select Actions > Create.

3 Click the Mapping tab.

4 Select the Access Protocol that permits access to the LUN.
Valid options:

• Fibre Channel (FC)
• iSCSI

5 Select the option All hosts may access the LUN using LUN number.

6 Select a LUN number from the drop-down list to assign to the LUN.

Tip: If network clients are running on Windows 2000 or 2003 platforms,
and you want those clients to be able to access the LUN, do not select LUN
number 255.

7 From the LUN Controller Assignment controls, allow the Oracle FS System
to assign the Controller, by leaving the Assigned Controller option set to
the default, which is <auto assign>.

8 (Optional) From the Ports Masked for this LUN table, select Yes for each
Controller port that you want to mask.
When you mask a port, the LUN cannot be accessed from the specified
ports.

Note: If you use Oracle FS System LUN masking or switch zoning and do
not use LUN assignment, you could create a situation in which a LUN is
not exposed on the ports through which you want the clients to be able to
access the LUN. To avoid this situation, assign the LUN to the Controller
on which you have the mapping set.

9 Click OK.

Clicking OK creates the LUN using the default settings on the remaining tabs.
You can perform the tasks associated with the other tabs to fine‑tune the
remaining LUN properties. The default properties include:

• The LUN is assigned to the default Volume Group and the default Storage
Domain.

• The LUN is mapped to the same host entry as the most recent LUN
mapping.
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• The system does not create repository capacity for Clone LUNs.

• The system does not create schedules for automatic Clone LUNs.

Related Links
Create LUN Map Dialog
Mapping LUNs and SAN Host Entries
Creating Auto-Tiered LUNs
Creating Single‑Tier LUNs

Modify LUN: Define Mapping by Selected Host Entries
You might need to modify the LUN mapping properties of a host entry when the
host is offline (for example, for maintenance).

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.

4 From the Mapping tab, select the host mapping to modify, and then click
Modify.

5 From the Modify LUN Number dialog, select a new LUN to map for this
LUN, then click OK.

Tip: If network clients are running on Windows 2000 or 2003 platforms,
and you want those clients to be able to access the LUN, do not select LUN
number 255.

6 To save your changes, click OK.

If the host entry that you want to allow access to the LUN is not displayed in the
list, add the host entry by associating the host initiator to the host entry.

Related Links
Modify LUN Number Dialog
Modify SAN LUN, Mapping Tab
Mapping LUNs and SAN Host Entries
Modifying Auto-Tiered LUNs
Modifying Single‑Tier LUNs

Modify LUN: Define Mapping by LUN Number
You might want to modify the LUN number that all SAN host entries use to
access the LUN.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to modify.

3 Select Actions > Modify.
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4 From the Mapping tab, select a LUN number from the drop-down list to
assign to the LUN.

Tip: If network clients are running on Windows 2000 or 2003 platforms,
and you want those clients to be able to access the LUN, do not select LUN
number 255.

5 To save your changes, click OK.

Related Links
Modify SAN LUN, Mapping Tab
Mapping LUNs and SAN Host Entries
Modifying Auto-Tiered LUNs
Modifying Single‑Tier LUNs

Oracle FS VDS Provider
The Oracle FS Virtual Disk Service Provider (VDS Provider) software provides a
plug-in that allows administrators to manage LUNs on the Oracle FS System. The
software is available from the Pilot management interface.

The Oracle FS System Pilot management interface provides links that allow you
to download and install the Oracle FS Virtual Disk Service Provider software.
During the installation process, you can register a single Oracle FS System. After
installation, you can register more systems.

Note: Verify the VDS software installation before registering any systems.

Related Links
Managing SAN LUNs
Download and Install the VDS Provider
Verify the VDS Provider Installation
Register an Oracle FS System with the VDS Provider

Download and Install the VDS Provider
The Pilot management interface provides links to download the Oracle FS Virtual
Disk Service Provider software. The software is available for both 32‑ and 64‑bit
systems.

Prerequisites • An Oracle FS System configured with FC protocol.
• You need the following information to register the

Oracle FS System with the Oracle FS Virtual Disk
Service Provider software:

• System serial number
• Login account: username
• Login account: password
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The software installer allows the configuration of an Oracle FS System.
Additional systems can be configured from a command‑line tool, called
registerAxiom.

1 Start a web browser.

2 Specify the IP address of the Pilot or the name of the Oracle FS System as
the address to open.

3 Click the Utility Software tab.

4 Download the VDS software and save the file to your server.
Select the software version that is appropriate for your system architecture.

• Download Oracle FS VDS Provider ‑ 32 bit
• Download Oracle FS VDS Provider ‑ 64 bit

5 Locate the file on your server and double‑click the file to begin the
installation.

6 Follow the instructions to install the software on the server.

Note: You are prompted for the Oracle FS System serial number, user
name, and password during the installation.

7 To close the installation wizard, click Close from the Installation Complete
page.

8 Restart the Windows server.

Next, verify that the software is installed correctly.

Related Links
Oracle FS VDS Provider
Verify the VDS Provider Installation

Verify the VDS Provider Installation
After you install the Oracle FS Virtual Disk Service Provider software, verify the
installation. After you have verified the installation, you can register more
Oracle FS Systems.

Prerequisite Installed Oracle FS Virtual Disk Service Provider software.

Use the Windows diskRAID program to verify that the Oracle FS Virtual Disk
Service Provider software is installed on your workstation.

1 Navigate to Start > run from your workstation.

2 From the Open field, type diskraid.

3 Click OK.
You are prompted to confirm access to your workstation.

4 To continue, click Yes.
A new console window opens with the prompt DISKRAID>.
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5 From the command prompt, type list providers.
Verify that the VDS provider name is listed. If VDS provider name is not
listed, install the software again, or contact your system administrator.

6 To close the DISKRAID command window, type exit.

Related Links
Oracle FS VDS Provider
Download and Install the VDS Provider

Register an Oracle FS System with the VDS Provider
After you install the Oracle FS Virtual Disk Service Provider software, you can
register additional Oracle FS Systems with the software.

Prerequisite • Installed Oracle FS Virtual Disk Service Provider
plug-in

• You need the following information to register each
Oracle FS System with the Oracle FS Virtual Disk
Service Provider plug-in:

• System serial number
• Login account: user name
• Login account: password

The Oracle FS Virtual Disk Service Provider installs a utility that adds and
removes Windows registry entries for the Oracle FS System.

1 Start a command prompt from your workstation.

2 Change the directory to the bin folder of the VDS provider installation.

3 (Optional) To view a list of acceptable usage options, type registerAxiom.

4 To register a Oracle FS System, type registerAxiom sample-serial user-name
user-password.

Note: Enter the required information in the order listed.

5 (Optional) To remove the registered Oracle FS System, type
registerAxiom sample-serial.

Related Links
Oracle FS VDS Provider
Download and Install the VDS Provider
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CHAPTER 6

Manage SAN Host Entries

SAN Host Entries
A SAN host entry is a record in Oracle FS System Manager (GUI) that represents
a group of one or more initiators. An initiator is the World Wide Name (WWN) of
an FC HBA port or the name of an iSCSI initiator. You create host entries
manually using the GUI, or automatically using Oracle FS Path Manager (FSPM).

Note: The GUI uses the term host to refer to SAN host entries. Also, the term SAN
host refers to any computer that is connected to the Oracle FS System by way of a
Storage Area Network.

The Oracle FS System can contain the following types of SAN host entries:

Unassociated host The Oracle FS System automatically creates unassociated
SAN host entries when an initiator is discovered on the
SAN. The name of the initiator and the unassociated SAN
host entry are the same.

Associated host A host entry that an administrator associates with one or
more host initiators. Use the Associate Hosts option to
manually associate the initiators as associated hosts. After
associating the initiators to the host, the associated host is a
host entry, referred to in the GUI as a host.

FSPM host
A host that FSPM associates with one or more host initiators
after logging in to the Pilot. FSPM manages the association
of the initiators on the FSPM host to the FSPM host name.
The FSPM host entry contains the following information:

• The name of the FSPM host, which is the SAN host
that runs FSPM

• The list of initiators, which includes the FC ports in
the host system, and, if iSCSI is configured, the names
of the iSCSI initiators

If the Oracle FS System has LUNs, you can map them to any type of host entry.
Mapping the LUNs makes them visible to all of the initiators that the host entry
owns.

You can move initiators into associated host entries as necessary. When you move
an initiator from an unassociated host to an associated host, the system adds the
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unassociated initiator to the host entry and deletes the unassociated host entry.
The system moves the mapped LUNs to the host entry and retains the LUN
mappings.

For example, you want to move a LUN (mapped to LUN number 3) to a host that
contains a LUN (mapped to LUN number 5). After the move, the associated host
contains both LUNs, each mapped to its respective LUN number. If the new and
existing LUN numbers are the same, the Oracle FS System assigns a new LUN
number to the newly mapped LUN.

Moving initiators from one associated host entry to another requires the
following actions:

• Remove the initiator from the first host entry.

• Associate the initiator to the new host entry.

The LUN mappings from the original host entry are not applied to the new host
entry. If, after moving the initiator, there are no more initiators that are associated
with the original host entry, then the Oracle FS System removes that entry.

When you delete a SAN host entry, the Oracle FS System creates an unassociated
host for each initiator that is connected to the system. When deleting a host, you
have the following options:

• Keep all of the LUN mappings that belong to the deleted host with each
new unassociated host. Keeping the LUN mappings allows you to map a
LUN to another host.

• Delete all of the LUN mappings that belong to the deleted host.

Related Links
Managing SAN Host Entries
FSPM on SAN Hosts

FSPM on SAN Hosts
Oracle FS Path Manager (FSPM) monitors the initiator ports on the SAN host and
the data paths between the SAN host and the Oracle FS System.

For many operating systems, FSPM performs the following key functions:

• Enables the use of multiple paths between HBA ports on the host and
Controller ports

• Balances the load across HBA channels and Controller ports

• Monitors path failure and transfers traffic to different paths if a failure
occurs

• Maps LUNs to host volumes

• Reports the status of host drivers and paths in Oracle FS System Manager
(GUI)

Manage SAN Host Entries

154



• Collects logs to include in Call‑Home files when SAN hosts are selected

• Automates the recognition and configuration of the FSPM host in the GUI

A host system accesses LUNs through a SCSI-over-FC driver or an iSCSI driver.
These drivers are provided with the operating system or by the HBA
manufacturer.

Related Links
Controller Ports
Managing Event Logs
Mapping LUNs and SAN Host Entries
FSPM Hosts Management

FSPM Hosts Management
Oracle FS Path Manager (FSPM) runs on a SAN host to create FSPM hosts and
monitor data paths on the Oracle FS System.

When FSPM logs in to the Pilot, FSPM provides the name of the SAN host and
the list of host initiators. If necessary, the Oracle FS System creates any FSPM
hosts that are not found on the system and assigns the available initiators to the
FSPM host.

FSPM is operating normally when the following conditions apply:

• FSPM successfully logs in to the Pilot.

• The Pilot has registered the host initiators as an FSPM host.

• An active TCP connection exists between the Pilot and FSPM daemon.

The FSPM host entry contains the following information:

• The name of the FSPM host, which is the SAN host that runs FSPM

• The list of initiators, which includes the FC ports in the host system, and, if
iSCSI is configured, the names of the iSCSI initiators

When you need to change the name of the FSPM host entry, change the name of
the SAN host that is running FSPM.

CAUTION: If you improperly change the name of the FSPM host, you could lose
access to your data.

FSPM that is running on the SAN host provides information to the Oracle FS
System on a continuous basis. For example, FSPM reports for each LUN the
number of optimized and non‑optimized paths that are currently usable at the
host.

You can perform the following actions using FSPM:

• Monitor the multiple data paths to the Oracle FS System Controllers.

• Verify the connection status of each initiator on the host.
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• Balance the load traffic among the multiple paths.

FSPM sends a list of SAN host initiators to the Pilot. If any of the SAN host
initiators are not currently associated with the FSPM host entry, then they are
added to it. As a result, all the LUN mappings that are associated with the FSPM
host entry are applied to the new initiators.

Deleting FSPM host entries releases the initiators that are members of that FSPM
host. However, a new FSPM host is created the next time that FSPM logs in to the
Pilot.

For more information about FSPM, refer to the Oracle FS Path Manager Installation
Guide and to the Oracle FS Path Manager Release Notes for the appropriate SAN
host platform.

Related Links
SAN Host Entries
Rename an FSPM Host

Rename an FSPM Host
You can rename the Oracle FS Path Manager (FSPM) host by deleting the old host
entry and renaming the SAN host that is running FSPM. FSPM creates a new
host entry with the new SAN host name.

The FSPM host name contains the name of the SAN host that is running FSPM.
To change the name of the FSPM host, delete the FSPM host and then rename the
SAN host. FSPM creates a new FSPM host when you restart FSPM. Correctly
renaming the FSPM host ensures that the Oracle FS System maintains the
internal record of the FSPM host.

1 Stop FSPM.
For instructions, refer to Oracle FS Path Manager Installation Guide.

2 To view the list of SAN host entries, including the FSPM host, from
Oracle FS System Manager (GUI), navigate to SAN > Storage > Hosts.

3 Verify that at least one initiator is connected to the FSPM host.

4 Select the FSPM host that you want to delete.

5 Select Actions > Delete Host.
The system displays the FSPM host and any LUN mappings.

6 Verify that the Delete mappings and initiators? option is not selected.
Because you did not select the Delete mappings and initiators? option, the
Oracle FS System retains any mappings to the host initiators. FSPM uses
these initiators when the system creates the FSPM host using the new SAN
host name.

7 To delete the FSPM host, click OK.

8 Rename the SAN host on which you have installed the FSPM software.
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The process for renaming the SAN host varies depending on the host
operating system. Check the documentation for your host operating
system.

9 Restart FSPM.
For instructions, refer to Oracle FS Path Manager Installation Guide.

FSPM logs in to the Pilot and reports the new SAN host name. Then, the
Oracle FS System creates an FSPM host entry with the new SAN host name. The
FSPM host contains the host initiators and any LUN mappings.

Related Links
Hosts Overview Page
FSPM Hosts Management
Rename an Associated Host Entry

Managing SAN Host Entries
Use Oracle FS System Manager (GUI) to manage SAN host entries. If you have
installed the Oracle FS Path Manager (FSPM), FSPM creates FSPM host entries
for you.

The configuration of the Controller and SAN hosts includes the following tasks:

• Configure the FC ports or iSCSI ports in the Controller for network access.
When these ports are configured, a successful connection can be made
from the initiator ports on the SAN host to the target ports on the
Controller.

• Provide an alias for the SAN host initiator ports. An alias makes the ports
easier to identify.

• Configure authentication between the iSCSI Controller ports and the hosts.

• Enable the HP‑UX compatibility option that allows the system to use the
HP-UX addressing scheme for LUNs.

• Configure the FSPM load balancing settings on some operating systems.

• Map a LUN to a selected host entry. Mapping is the mechanism that
enables the SAN host to identify and access the LUN.

• Optionally mask a Controller port so that the LUN cannot be accessed
through that port.

• Associate the host entry to a host group, which is a named, logical
collection of hosts.

When you delete a host entry, by default the Oracle FS System retains the
mappings to the initiators of that deleted entry. These retained mappings allow
you to transfer the mappings to another host entry. You can optionally remove
these mappings when deleting a host entry. When you delete a host entry, the
Oracle FS System creates new unassociated host entries for any initiators that are
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discovered by the system. You might need to refresh the screen (Ctrl-Alt-R) to
view the new initiators.

You can group hosts together using host groups. A host group is a named, logical
collection of one or more host entries. Host groups are a convenient way to
associate many SAN host entries into a single, manageable object. Host groups
are compatible with associated hosts and FSPM hosts.

Related Links
Mapping LUNs and SAN Host Entries
Configure iSCSI System Settings
Manage Port Provisioning for a Controller

Create an Associated Host Entry
When you do not have Oracle FS Path Manager (FSPM) installed on the SAN
host system, you create associated host entries by associating one or more
initiators to a named host entry.

Associate initiators to a host when the Host overview page lists that host in one
of the following manners:

• Unknown state

• By a world wide name (WWN) for FC initiators

• By an iSCSI initiator name

1 Navigate to SAN > Storage > Hosts.
2 Select Actions > Associate Hosts.

The Associate Hosts dialog appears.
3 Specify the name of the host in the Host Name field.
4 Select the initiators from the Create Association list.

Valid methods:

• Select the initiators from the discovered WWN or iSCSI name list.

• Enter a WWN or iSCSI name of an initiator on the SAN network.
5 To associate the initiators to the host entry, click Add.

The selected initiator moves to the Associations table.
6 Continue adding initiators to the Associations table, as necessary.
7 (Optional) To enable the Challenge Handshake Authentication Protocol

(CHAP), select Enable Authentication.
8 (Optional) Enter the CHAP iSCSI Host Specific Settings.

Required authentication credentials:

• CHAP Name

• CHAP Secret

• Retype CHAP Secret
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9 (Optional) To grant access to the Oracle FS System from iSCSI login
attempts, select the Grant Access to Oracle FS option.

10 (Optional) To remove an entry from the Associations table, select the item
and then click Remove.

11 Click OK.

The Host overview page displays the host entry name with the desired
associated initiators.

Related Links
Associate Hosts Dialog
Hosts Overview Page
SAN Host Entries

Rename an Associated Host Entry
You can rename an associated host entry without affecting associated mappings.

You cannot rename FSPM host entries and unassociated host entries directly. For
these host entry types, the Host Name field is not enabled.

• If you want to rename an unassociated host entry, create an associated host
entry with the desired name.

• If you want to rename an FSPM host entry, you must rename the FSPM
host.

1 Navigate to SAN > Storage > Hosts.
2 Select the associated host that you want to rename.
3 Select Actions > Modify Host.
4 From the Host Name field, enter a new name for the host.
5 Click OK.

Related Links
Hosts Overview Page
Modify Host, Ports Tab

Delete a Host Entry
Delete the host entry when you want to disassociate the initiators from the entry.

The Oracle FS System retains your LUN mappings to the initiators of your
deleted host entry. You can remove the mappings, as necessary.

1 Navigate to SAN > Storage > Hosts.
2 Select a host from the list to delete.
3 Select Actions > Delete Host.

The system displays the Delete Host dialog.
4 (Optional) Select the Delete mappings and initiators? option.
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By selecting the Delete mappings and initiators? option, the system
removes any LUN mappings and from the associated initiators, and does
not immediately create unassociated host entries for the initiators. In this
case, the system creates unassociated host entries for any of the discovered
initiators on the SAN.

5 Click OK.

If necessary, refresh the screen to view the unmapped host initiators by clicking
the refresh icon ( ).

Related Links
Hosts Overview Page
Managing SAN Host Entries

View SAN Host Entry Settings
You can view the SAN host entry status and associated initiators. If Oracle FS
Path Manager (FSPM) is installed, you can also view details about load balance
and communication status.

1 Navigate to SAN > Storage > Hosts.
2 Select a host from the list to view.
3 Select Actions > View Host.
4 Select any of the tabbed pages to view the host settings.
5 Click Close.

Related Links
Hosts Overview Page
View Host, Advanced Tab
View Host, iSCSI Access Tab
View Host, Oracle FS Path Manager Tab
View Host, Ports Tab
Managing SAN Host Entries

Modifying SAN Host Entries
You can modify information about a host including adding an alias name for a
host HBA port, enabling the iSCSI host Challenge Handshake Authentication
Protocol (CHAP) authentication, and setting the HP‑UX compatibility option.

You can change the FSPM settings of the FSPM host entries only when FSPM is
installed and communicating with the Oracle FS System.

Also, if you have hosts that are running the HP‑UX Operating System, enable the
HP‑UX compatibility you can option for these hosts. When this option is enabled,
the system presents LUN numbers using the HP‑UX addressing scheme,
allowing up to 4095 LUNs. When enabled, the host cannot have a visible LUN
using ID 0.
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Modify the host by using the following tabbed pages as necessary:

Ports Allows you to create or modify an HBA port alias and view FC
and iSCSI port information.

Oracle FS Path
Manager

Allows you to view the installed FSPM version and path
manager settings. From this page, you can modify the load
balancing settings and view the number of optimized and non‑
optimized data paths.

iSCSI Access If you select a host with an iSCSI connection, you can manage
the CHAP authorization and grant access to the Oracle FS
System.

Advanced If the SAN host is running the HP‑UX operating system, you
can set the HP‑UX compatibility mode option from this page.

Related Links
FSPM on SAN Hosts
Modify a Host: Assign a Port Alias
Modify a Host: FSPM Load Balancing
Modify a Host: Reconfigure iSCSI Access Settings
Modify a Host: Reconfigure Advanced Settings

Modify a Host: Assign a Port Alias

Assign an alias to an HBA port to make the host and the port easier to identify.

1 Navigate to SAN > Storage > Hosts.

2 Select a host from the list to modify.

3 Select Actions > Modify Host.

4 From the Ports tab, select a port from the list.

5 Enter an Alias name for the port you wish to modify.

6 Click OK.

Related Links
Modify Host, Ports Tab
Modifying SAN Host Entries

Modify a Host: FSPM Load Balancing

You can change the load balancing method that Oracle FS Path Manager (FSPM)
uses to access LUNs.

1 Navigate to SAN > Storage > Hosts.

2 Select a host from the list to modify.

3 Select Actions > Modify Host.
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4 From the Oracle FS Path Manager tab, select a LUN, then select an option
from the Load Balancing list.
Available methods:

• Static

• Round Robin

Note: Some operating systems do not allow you to update this option.

5 Click OK.

Related Links
Modify Host, Oracle FS Path Manager Tab
Modifying SAN Host Entries

Modify a Host: Reconfigure iSCSI Access Settings

If you want to allow iSCSI initiator access to the Oracle FS System, enable the
Challenge Handshake Authentication Protocol (CHAP) option and grant access
to the system.

1 Navigate to SAN > Storage > Hosts.

2 Select a host from the list to modify.

3 Select Actions > Modify Host.

4 From the iSCSI Access tab, select Enable Authentication to allow CHAP
authentication credentials.

5 Enter the necessary CHAP credentials in the fields provided.

6 (Optional) To allow iSCSI initiator login attempts to the Oracle FS System,
select Grant Access to Oracle FS option.

7 Click OK.

Related Links
Modify Host, iSCSI Access Tab
Modifying SAN Host Entries

Modify a Host: Reconfigure Advanced Settings

If you have hosts that are running the HP‑UX Operating System, enable the
HP‑UX compatibility option. When the HP‑UX compatibility option is enabled,
the system presents the LUN numbers by using the HP-UX addressing scheme.

The LUN numbers by using the HP-UX addressing scheme allows you to access
up to 4095 LUNs.

Note: When enabled, the HP-UX host cannot have a visible LUN using ID 0.

1 Navigate to SAN > Storage > Hosts.

2 Select a host from the list to modify.
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3 Select Actions > Modify Host.

4 Select the Advanced tab.

5 To enable HP‑UX LUN addressing scheme, select the HP‑UX
Compatibility Mode option.

6 Click OK.

Related Links
Modify Host, Advanced Tab
Modifying SAN Host Entries

Initiator-to-Controller Connectivity
Oracle FS System Manager (GUI) provides the connectivity status of each
Controller ports and host initiator. After you have mapped LUNs to the hosts,
you can view the connectivity status of every data path in the system.

The inter‑connectivity among the Controllers and host initiators creates highly
redundant data paths. This redundancy ensures that data reliably transfers
among the host, the Controller, and the mapped LUNs. The Oracle FS System
provides connectivity status among the various data paths. Such states might
indicate that an FC switch is offline.

You can view the connectivity status from the Initiator‑to‑Controller
Connectivity menu items that are available from various locations in the GUI.
Depending on the object that you have selected, the GUI shows the state of the
initiator that is assigned to the host entry, host initiator, or LUN. The following
table summarizes the connectivity information among the Controllers ports,
LUNs, hosts, and initiators.

Table 10: Initiators‑to‑Controller connectivity information in the GUI
GUI page source Selected object Connectivity information

Hosts overview Host Displays connectivity between all
Controller ports and all host initiators that
are assigned to the host entries.

Hosts overview Host initiator Displays connectivity between all
Controller ports and selected host initiator.

LUN‑to‑Hosts overview LUN The page provides connectivity status
between the LUN and host. The page also,
displays connectivity between the host
initiators and all Controller ports.

Hosts‑to‑LUNs
overview

Host The page provides connectivity status
between the host and LUN. The page also,
displays connectivity between the host
initiators and all Controller ports.
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Related Links
Controller Ports
Mapping LUNs and SAN Host Entries
SAN Host Entries
Managing SAN Host Entries

Host Groups
You can easily manage the mapping of a LUN to hosts by assigning the host
entries to a specific group. This group is a named, logical collection of hosts.

Your system might contain the following hosts:

• Hosts that Oracle FS Path Manager (FSPM) registered, called FSPM host
entries

• Hosts that an administrator created by associating various initiators, called
associated host entries

You can create more hosts by either using the FSPM service or manually creating
host entries. Creating host groups is useful if you have SAN host clusters, each of
which contains many SAN hosts and each SAN host contains a few initiators.

If this SAN host cluster is not defined in the GUI as a host group, when you want
to map a LUN to the cluster, map each host to the LUN one at a time.
Furthermore, if you must move a SAN host to a different cluster, manually
update each LUN mapping, also one at a time.

A more efficient method, however, is to define the cluster as a host group and
then assign the hosts to the host group. When you later move a host from one
host group to another, all the initiators that are associated with that host inherit
the LUN mappings associated with that host group.

Note: The Pilot automatically manages the deletion of the old mappings and the
creation of the new initiator mappings.

Host groups have the following properties:

• A host can belong to only one host group.

• You can map unlimited hosts to a host group.

• A host group can have zero or more mappings.

• You can map a LUN to either a host or a host group.

• If a host group has mappings, then all hosts in the host group have all of
the mappings of the host group, but any given host may also have other
mappings. No mappings may conflict with other mappings.

• When assigning a host with mappings to a host group without mappings,
you are prompted to migrate mappings on the host to the host group.
Migrating these mappings make them available to all hosts in the group,
not just the single host.
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For example, consider the following host group (cluster) configuration:

Host group Alpha LUN1 is mapped to this host group as LUN number 0.

Host A Initiators A1 and A2 are mapped to LUN1. The
LUN number is 0.

Host B Initiators B1 and B2 are mapped to LUN1. The
LUN number is 0.

Host group
Omega

LUN2 is mapped to this host group as LUN number 0.

Host C Initiators C1 and C2 are mapped to LUN2. The
LUN number is 0.

If you move Host B from host group Alpha to host group Omega, the LUN
mappings for Host B are automatically adjusted, as shown below:

Host group Alpha LUN1 is mapped to this host group as LUN number 0.

Host A Initiators A1 and A2 are mapped to LUN1. The
LUN number is 0.

Host group
Omega

LUN2 is mapped to this host group as LUN number 0.

Host B Initiators B1 and B2 are mapped to LUN2. The
LUN number is 0.

Host C Initiators C1 and C2 are mapped to LUN2. The
LUN number is 0.

Related Links
Managing Host Groups
Create a Host Group

Managing Host Groups

Managing host groups involves understanding the host mappings to the hosts
groups and host access to the LUNs.

To use the host group feature, first create the host group, then assign your hosts
to the group. After the host group is created and the hosts are assigned to the
group, you can map your LUNs to the host group. A host that is assigned to a
host group is still available for mapping by way of the host or the host group to
which the host is assigned.

When deleting a host group, remove the host members first. Ideally, you would
delete an empty host group that contains no host memberships. Emptying a host
group involves moving each host to another group or removing the host from the
group. This action might affect the current host‑to‑LUN mapping. After moving
a mapped host to another host group, you will receive a confirmation to
unassociate the host from the host group.
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The system displays the confirmation to unassociate a host from a host group
when there are LUNs mapped to a group. You can decide how you want the
system to process the residual mappings. You are presented with two options:

Retain Host
Mappings

Allows you to copy all mappings for the deleted host group
to the hosts that belong to the group. The hosts that
belonged to the deleted host group retains access to any
LUNs to which they had access while a member of their
host group.

Delete Mappings Allows you to remove all mappings for the deleted host
group. The hosts that belonged to the deleted host group
lose access to any LUNs to which they had access while a
member of the host group. Choosing this option causes the
message No Mappings to appear in the LUNs overview page
if the LUN is not assigned to a host or host group. The
Delete Mappings option does not affect any LUNs that are
mapped to the host (and not to the host group).

Related Links
Host Groups
Create a Host Group
Delete a Host Group

Create a Host Group

You can create a host group that allows you to associate host entries into logical
organizational units.

1 Navigate to SAN > Storage > Hosts.

2 Select Actions > Manage SAN Host Groups.
The system displays the Manage SAN Host Groups dialog.

3 Click Create.

4 Enter a name for the host group.

5 (Optional) From the Hosts tab, assign the host entries to an available host
group.

6 Click OK.

The system organizes the host entries into the new host group.

Related Links
Manage SAN Host Groups, Groups Tab
Host Groups
Managing Host Groups
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Modify a Host Group

You can modify a host group by changing its name, removing SAN host entries,
or by assigning SAN host entries to the group.

You can modify a host group in the following ways:

• Update the host group name

• Assign a host to a host group

• Remove a host entry from a host group

1 Navigate to SAN > Storage > Hosts.
2 Select Actions > Manage SAN Host Groups.

The system displays the Manage SAN Host Groups dialog.
3 To change the host group name, select a host group and update the name

from the Group tab.
4 To reassign a host to a new host group, select a host and choose a new host

group from the Host Group list from the Hosts tab.
5 To remove a host entry from a host group, select the Hosts tab, and then

select a host and select [--] from the Host Group list.

Note: Specify how the LUN mappings are processed for the mapped hosts.
6 Click OK.

Related Links
Manage SAN Host Groups, Groups Tab
Host Groups
Create a Host Group
Delete a Host Group

Delete a Host Group

Delete a host group when the group is no longer needed.

When possible, delete a host group that contains no host entries. If you delete a
host group that contains host entries, the system prompts you for more action on
how to map the entries.

1 Navigate to SAN > Storage > Hosts.
2 Select Actions > Manage SAN Host Groups.

The system displays the Manage SAN Host Groups dialog.
3 From the Manage SAN Host Groups, Groups tab, select a host group from

the available list.
4 Click Delete.

The host group is removed from the list.
5 Click OK.

If the host group was empty when you deleted it, the system deletes the
host group from the system. However, if the host group contains mapped
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host entries, more information is required about how to map the LUNs
that were mapped to the host entry that you deleted from the host group.

6 (Optional) From the Confirm SAN Host Group Unassociation of Hosts
dialog, specify how to process the LUN mappings for the mapped host
entries.
Valid options:

• Retain Host Mappings

• Delete Mappings

7 Click OK.

Review the Host Access status from the LUNs overview page for the affected
LUNs. Verify that the host mapping are correct.

Related Links
Manage SAN Host Groups, Groups Tab
Host Groups
Create a Host Group
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CHAPTER 7

Manage Data Protection

Data Replicas and System Capacity
You can create online data replicas in different ways. Each method consumes the
capacity in the storage array differently.

Oracle FS System Manager (GUI) displays the relationship of the Clone LUNs
and associated parent LUNs in a hierarchal relationship called a replica tree. A
replica tree can also include clones of clones.

The Oracle FS System ensures that all of the logical volumes that are associated
with a particular replica tree reside on the same Controller.

Note: This discussion of replica trees on a Controller does not apply to replicated
objects created by the Oracle MaxRep for SAN.

If you change the home Controller of any of these logical volumes, the system
changes the home Controller for all of them. The system updates the home
Controller on the following objects:

• Clone LUNs

• Volume copies

Volume copies and logical volumes that are being migrated because of QoS
changes continue to reside in the original replica tree until the data operations
are complete. After the volume copy or the migration completes, the volume is
removed from the original replica tree and becomes the root of a new replica
tree.

After you start a volume copy operation or the system starts a data migration
operation, if you rehome any object that is in the replica tree, the method for
rehoming the Controller differs by replica type. If the system has not yet
detached the copy from its source volume, the system rehomes the copy. If,
however, the system has already detached the copy, the copy is no longer in the
original replica tree; therefore the copy is not rehomed.

The following table summarizes the replica types and capacity usage.
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Table 11: Capacity usage by online data replicas
Replica type Description Capacity usage
Clone LUN Creates a readable and writable point-in-

time snapshot of a LUN that only stores
the delta between the source LUN and the
clone. The Clone relies on the source LUN
for unmodified LUN data.

Consumes system space
allocated for clones.
Only changes to the
source or clone are
stored.

volume copy Creates a block-level, full-image, read-
write copy of a logical volume. QoS
attributes for a volume copy can differ
from the QoS attributes of the original.

Consumes free space
from system capacity
that is equal to the
current size of the
volume.

The online data replicas have the following characteristics:

• The replicas require no prior configuration (other than initial QoS
allocation).

• The system creates the replicas as an explicit one‑time operation.

• The system creates the replicas on the same Oracle FS System as the source
volume.

• The system creates independent replicas from the source volumes. When
data changes in the source volume, those changes are not reflected in the
replica.

Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Related Links
Create an Immediate Clone LUN
Copy a LUN

Copying and Cloning LUNs
You can make a copy of a LUN or create a point‑in‑time clone of a LUN. When
creating a copy, you copy all of the LUN data to the new LUN. You also have the
option to copy the LUN properties to a new LUN without copying the source
data.

Create a Clone LUN when you want to create an exact image of the original
LUN. A Clone LUN is a point‑in‑time, read‑write copy of a LUN that you can
immediately use. A Clone LUN retains the same QoS parameters as the source
LUN and consumes storage capacity from the Clone LUN storage space created
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for the source LUN. A Clone LUN only stores the differences between the source
LUN and the clone. The Clone LUN uses the source LUN for most data. A
Clone LUN is available immediately after creation. Clone LUNs provide a
convenient method to branch from the source data without the need to do a full
block‑level copy.

Another reason to create a clone or a copy is to preserve a point-in-time view of
the data. If you create a clone for this purpose, you can later restore the data to
the source LUN.

Copy a LUN when you need a new LUN with the same starting data as an
existing LUN.

Before creating a Clone LUN or a copy of a LUN, ensure that changes to the
source LUN are minimized. For best results, pause the host applications that
access the LUN, or use host software, such as Oracle FS Volume Shadow Copy
Service Provider (VSS), before creating the Clone LUN. When the system
displays the replica in the Oracle FS System Manager (GUI), you can resume
writing to the LUN.

Unlike a clone, the new blocks for the copy might be on a different drive group
or on a drive group of a different Storage Class. For example, a volume copy of a
LUN that uses a high performance Storage Class, such as a Performance solid-
state drive, premium priority LUN may be created in a low performance
Capacity drive.

You can also create a LUN that has the QoS and storage capacity settings of an
existing LUN. Creating a LUN in this manner copies the properties of the LUN
without copying the associated data. After you create a LUN with the desired
properties, you can use the LUN as a template for creating new LUNs.

Related Links
Data Replicas and System Capacity
Managing Clone LUNs
Copy a LUN
Create a LUN Like an Existing LUN

Copy a LUN
You can copy an existing LUN and give the new LUN different QoS properties.
Copying a LUN allows system resources to be maximized for the task at hand.

For example, if you have a volume copy that is used for reporting purposes, you
might want to assign to the copy a lower performance Storage Class and a higher
read‑centric access pattern than you would assign to the source volume.

You can also copy a Clone LUN. The copy then is independent of the source LUN
from which the clone was created. You might want to copy a Clone LUN when
you do not want to recover any changes to the source LUN.

1 Navigate to SAN > Storage > LUNs.
2 Select a LUN from the list that you want to copy.
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3 Select Actions > Copy LUN.

4 Enter a new, unique name for the LUN.

5 Update the QoS parameters and remaining fields, selecting the tabs as
necessary.

6 Click OK.

Related Links
Copy SAN LUN, Data Protection Tab, Auto Tier
Copy SAN LUN, Data Protection Tab, Single Tier
Copy SAN LUN, Mapping Tab
Copy SAN LUN, Quality of Service Tab, Auto Tier
Copy SAN LUN, Quality of Service Tab, Single Tier
Capacities
QoS Policies
Data Replicas and System Capacity
Copying and Cloning LUNs

Create a LUN Like an Existing LUN
You can create a LUN using the QoS properties of an existing LUN as a template.
Creating a LUN from a template does not copy any data to the new LUN.

Creating a LUN from an existing LUN copies the QoS properties from the
existing LUN to the new LUN. The following properties are not copied to the
new LUN:

• LUN host mappings

Map your new LUN to a host entry.

• Clone LUN schedules

If you want to create automated Clone LUNs, create a data protection
schedule for the LUN.

1 Navigate to SAN > Storage > LUNs.

2 Select a LUN from the list that contains the QoS properties that you want
to copy.

3 Select Actions > Create LUN like selected.
The system displays the Create SAN LUN dialog with a unique LUN
name.

4 (Optional) Enter a new, unique name for the LUN.

Note: The system creates a new LUN name that is based on the name of the
source LUN.

5 Make any necessary changes to the LUN properties.

6 (Optional) Select the Mapping tab and map the LUN to a host entry.
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7 (Optional) Select the Data Protection tab and create a data protection
schedule.

8 Click OK.

Related Links
Create SAN LUN, Data Protection Tab, Auto Tier
Create SAN LUN, Data Protection Tab, Single Tier
Create SAN LUN, Mapping Tab
Create SAN LUN, Quality of Service Tab, Auto‑tier
Create SAN LUN, Quality of Service Tab, Single Tier
QoS Policies
Copying and Cloning LUNs
Copy a LUN

Managing Clone LUNs
Clone LUNs are writable snapshot images of a LUN using partial-block snapshot
technology. This technology allows the Oracle FS System to use the modified
information in the clone and the unmodified information from the source LUN.
You can create clones of clones. You can create a Clone LUN at any time.

A Clone LUN is defined as: A point‑in‑time, read‑write, partial‑block snapshot of
a LUN that can be accessed immediately.

Before creating a Clone LUN, ensure that changes to the source LUN are
minimized. For best results, pause the host applications that access the LUN, or
use host software, such as Oracle FS Volume Shadow Copy Service Provider
(VSS), before creating the Clone LUN. When the system displays the replica in
the Oracle FS System Manager (GUI), you can resume writing to the LUN.

Important: Make sure that the clone repository does not fill up, consuming the
maximum amount of space allocated. Monitor the amount of space available and
modify the volume to allocate more clone capacity, as needed. If a clone requires
more space from the repository, but space is not available, the clone is taken
offline and a System Alert is generated.

Deleting a LUN or Clone LUN, affects the associated clones:

• Deleting a LUN also deletes any clones of the LUN.

• Deleting a Clone LUN retains any clones of the Clone LUN.

Related Links
Oracle FS VSS Provider Plug-In
Delete a Clone LUN
Create an Immediate Clone LUN
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Create an Immediate Clone LUN
You can create Clone LUNs from an existing LUN or from a Clone LUN.

After the clone is created, you can change the priority level and other properties
of the clone. When creating a Clone LUN, make sure that enough repository
space exists for the clone. The system stores in the clone repository only the
changes that are made to the source volume or to the clone.

1 Navigate to SAN > Storage > LUNs.

2 Select the LUN that you want to clone.

3 Select Actions > Clone.

4 Enter a new, unique name for the Clone LUN.

5 (Optional) Make any necessary changes to the QoS properties.

6 (Optional) Select the Mapping tab and map the Clone LUN to a host entry.

7 (Optional) Select the Data Protection tab and create a data protection
schedule.

8 Click OK.

The name of the new Clone LUN appears on the LUN overview page.

Related Links
Create SAN Clone LUN, Mapping Tab
Create SAN Clone LUN, Quality of Service Tab
Data Replicas and System Capacity
Managing Clone LUNs
Create a Clone LUN Schedule

Delete a Clone LUN
You can delete a single Clone LUN when the clone is no longer needed.

When you delete a Clone LUN, only the target clone is deleted. When the target
clone is the parent or source for other clones, the child clones are not deleted.
Instead, the child clones become children of the next higher parent in the
hierarchy.

1 Navigate to SAN > Storage > LUNs.

2 Select the Clone LUN that you want to delete.

3 Select Actions > Delete.

Note: The system displays the Delete LUN dialog. This dialog indicates
that, if this clone is a parent or source of Clone LUNs, those Clone LUNs
are not deleted.

Manage Data Protection

174



4 To acknowledge that you want to delete the LUN, along with any clones
and host mappings, select the option Delete LUNs and existing host
mappings.

5 Click OK.
If the deleted Clone LUN has child clones, the child clones move up one
level in the hierarchy of clones.

Related Links
Delete LUN
Managing Clone LUNs
Delete All Clone LUNs

Delete All Clone LUNs
When a collection of Clone LUNs that are derived from a common source LUN
are no longer needed, you can delete the entire collection.

When you delete a collection of clones that have a common parent LUN, the
system determines the most efficient and quickest order of deletion.

1 Navigate to SAN > Storage > LUNs.

2 Select the parent LUN of all of the Clone LUNs that you want to delete.

3 Select Actions > Delete Clones.
The system displays the Delete Clone LUNs dialog want a list of all the
clones to delete.

4 To acknowledge that you want to delete the LUN, along with any clones
and host mappings, select the option Delete LUNs and existing host
mappings.

5 Click OK.

Related Links
Managing Clone LUNs
Delete a Clone LUN

Display Clone LUN Details
You can view specific information about a Clone LUN, such as the host
mappings for the clone.

The details of a Clone LUN includes information about the following properties:

• QoS attributes

• Allocated storage capacity

• Volume group and Storage Domain memberships

• SAN host mapping details and Controller port masking assignments

• Clone capacity and cloning schedules
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1 Navigate to SAN > Storage > LUNs.

2 Select the Clone LUN that you want to view.

3 Select Actions > View.

4 Select any of the tabbed pages to view the LUN properties.

5 Click Close.

Related Links
View SAN LUN, Data Protection Tab, Auto Tier
View SAN LUN, Data Protection Tab, Single Tier
View SAN LUN, Mapping Tab
View SAN LUN, Quality of Service Tab, Auto Tier
View SAN LUN, Quality of Service Tab, Single Tier
Create an Immediate Clone LUN

Restore a LUN from a Clone LUN
You can restore a LUN to its state when the Clone LUN was created.

Restoring a LUN from a Clone LUN results in returning the LUN to the exact
point‑in‑time image of the clone, plus any changes made to the clone. This
method quickly restores the data online, especially when compared to copying
the entire data set back from a tape backup. Furthermore, restoring from the
clone allows access to the data while the restore is in progress.

You might want to restore a Clone LUN if the following scenarios apply:

• Some undesirable changes to the data were made.

• An external client application or virus corrupted the LUN.

1 Navigate to SAN > Storage > LUNs.

2 Select the Clone LUN that you want to restore.

Note: The restoration process resets the creation date of the LUN to that of
the selected Clone LUN.

3 Select Actions > Restore from Clone.

4 Click OK.

The system restores the LUN, during which time system performance might be
slightly degraded. The system starts a task in the background to perform the
restore operation. When the background task completes, the system writes an
event to the event log and removes the “In Progress” status from the LUN
overview page.

Related Links
Data Replicas and System Capacity
Display Clone LUN Details
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Data Protection Schedules
A data protection schedule defines the following parameters:

• The time units in which the data protection event occurs, such as hourly,
daily, or weekly.

• The time intervals at which a replica is created, such as every hour, every
two hours, and so on.

• If you perform a data protection job only one time, use the Run Once
option when you create or modify your job schedule. After the system runs
this job, the system deletes the schedule. Check the event log for the
completion status of your job.

You can modify an existing data protection schedule or delete a schedule when
the schedule is no longer needed.

Related Links
Data Replicas and System Capacity
Managing Clone LUNs
Create a Clone LUN Schedule

Create a Clone LUN Schedule
When you create a LUN, you can also create a schedule that instructs the system
to clone your LUN at regular intervals.

Note: A schedule should be synchronized with the host applications that access
the logical volume so that all data I/O is quieted before the replication operation
starts.

1 Navigate to SAN > Storage > LUNs.
2 Select Actions > Create LUN.
3 From the Data Protection tab, select the Enable Clones option.
4 To display the Create Job Schedule dialog, click Create.
5 Enter a Schedule Name.
6 (Optional) Select Enabled if you want the schedule to start protecting your

data at the scheduled time.
If you do not enable the schedule now, you can do so later by modifying
the schedule.

7 From the Select a Volume to Protect table, select a LUN from which to
create the Clone LUN.

Note: Select a volume that has allocated capacity for clones.
8 Click the expansion button to the right of Start Time to select the day and

time for your schedule to start.
9 Use the controls in the Modify Date/Time dialog to select the date and

time.
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10 To close the Modify Date/Time dialog, click OK.
11 Select a frequency for the schedule.

Valid frequencies:

• Run Once

• Hourly

• Daily

• Weekly
12 Select a recurrence value for the schedule.

If you chose a frequency of Weekly, select the day of the week that you
would like the schedule to run.

13 Click OK.
The schedule is listed on the Clone Schedules table and the Clone
Schedules overview page.

Related Links
Create Job Schedule Dialog
Data Replicas and System Capacity
Managing Clone LUNs

Create a LUN Data Protection Schedule
You can create a data protection schedule that in turn creates a clone of a
protected volume (LUN or Clone LUN) at regular intervals.

1 Navigate to SAN > Data Protection > Clone Schedules.
2 Select Actions > Create.
3 Enter a name for the data protection schedule.
4 (Optional) Select a Volume Group in which to create the Clone LUNs.
5 (Optional) Select Enabled if you want the schedule to start protecting your

data at the scheduled time.
If you do not enable the schedule now, you can do so later by modifying
the schedule.

6 From the Select a Volume to Protect table, select a LUN from which to
create the Clone LUN.

Note: Select a volume that has allocated capacity for clones.
7 Click the expansion button to the right of Start Time to select the day and

time for your schedule to start.
8 Use the controls in the Modify Date/Time dialog to select the date and

time.
9 To close the Modify Date/Time dialog, click OK.
10 Select a frequency for the schedule.
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Valid frequencies:

• Run Once

• Hourly

• Daily

• Weekly

11 Select a recurrence value for the schedule.
If you chose a frequency of Weekly, select the day of the week that you
would like the schedule to run.

12 Click OK.
The schedule is listed on the Clone Schedules overview page.

Related Links
Create Data Protection Schedule Dialog
Data Replicas and System Capacity
Managing Clone LUNs

Modify a LUN Data Protection Schedule
You can modify characteristics of a data protection schedule, such as its
frequency to reduce the number of clones.

1 Navigate to SAN > Data Protection > Clone Schedules.

2 From the available list, select a data protection schedule that you want to
update.

3 Select Actions > Modify.

4 (Optional) Enter a new name for the data protection schedule.

5 (Optional) Select a Volume Group in which to create the Clone LUNs.

6 (Optional) Select Enabled if you want the schedule to start protecting your
data at the scheduled time.

7 (Optional) Update the Start Time and for Recurrence for the data
protection schedule.

8 Click OK.

Related Links
Modify Data Protection Schedule Dialog
Create a LUN Data Protection Schedule
Delete a LUN Data Protection Schedule
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Delete a LUN Data Protection Schedule
You can delete a data protection schedule when data protection requirements
change. After deleting the schedule, no automatic data protection occurs on the
affected LUN.

1 Navigate to SAN > Data Protection > Clone Schedules.
2 From the available list, select a data protection schedule that you want to

delete.
3 Select Actions > Delete.
4 Click OK.

Related Links
Clone Schedules Overview Page
Create a LUN Data Protection Schedule
Modify a LUN Data Protection Schedule

View a LUN Data Protection Schedule
You can display the details of a data protection schedule. For example, you can
view the volume group that is associated with the Clone LUNs, or you can
review the schedule details.

1 Navigate to SAN > Data Protection > Clone Schedules.
2 From the available list, select a data protection schedule that you want to

display.
3 Select Actions > View.
4 Review the displayed information to ensure that the data protection

schedule details are what you expect.
5 Click Close.

Related Links
View Data Protection Schedule Dialog
Create a LUN Data Protection Schedule
Modify a LUN Data Protection Schedule

Oracle FS VSS Provider Plug-In
The Microsoft Volume Shadow Copy Service (VSS) works with your hardware to
write data to the volumes on the Oracle FS System while backing up those
volumes. The Pilot web client provides links for the VSS hardware provider
software.

The Oracle FS Volume Shadow Copy Service Provider is a VSS hardware
provider that makes volume shadow copies of VSS-enabled applications that use
Oracle FS System LUNs without interrupting normal operations.

VSS enables data protection and management services through a standard set of
configuration and monitoring capabilities. These capabilities include creating
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and manipulating backups without shutting down applications or essential
services. During a restore operation, VSS shuts down or pauses applications as
needed to enable the restore operation.

For more information about VSS, refer to the following documentation:

• The Volume Shadow Copy Service Technical Reference (http://
technet.microsoft.com/en‑us/library/cc738819(WS.10).aspx) provided by
Microsoft.

• The Microsoft Developers Network (MSDN) article The VSS Model
(Windows) (http://msdn.microsoft.com/en‑us/library/aa384625.aspx).

Refer to your VSS‑enabled backup application documentation for instructions on
configuring and using VSS with your backup application.

Related Links
Managing Clone LUNs
Download and Install the VSS Software

Download and Install the VSS Software
The Pilot web client provides links to download the Oracle FS Volume Shadow
Copy Service Provider (VSS) software and install the software on your SAN host.
The software is available for both 32‑ and 64‑bit systems.

Prerequisites • The SAN host must have TCP/IP connectivity, over
Ethernet, to the Pilot.

• For the VSS Provider to create volume shadow copies,
the SAN host must have Fibre Channel connectivity
to the Controller.

• During the installation, you need to provide the
system serial number, user name, and password.

The software installer allows the configuration of an Oracle FS System.
Additional systems can be configured from a command‑line tool, called
registerAxiom.

1 Start a web browser.

2 Specify the IP address of the Pilot or the name of the Oracle FS System as
the address to open.

3 Click the Utility Software tab.

4 Download the VSS software and save the file to your server.
Select the software version that is appropriate for your system architecture.

• Download Oracle FS Volume Shadow Copy Service
Provider ‑ 32 bit

• Download Oracle FS Volume Shadow Copy Service
Provider ‑ 64 bit
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5 Locate the file on your server and double‑click the file to begin the
installation.

6 Follow the instructions to install the software on the server.

Note: You are prompted for the Oracle FS System serial number, user
name, and password during the installation.

7 To close the installation wizard, click Close from the Installation Complete
page.

8 Restart the Windows server.

Next, verify that the software is installed correctly.

Related Links
Oracle FS VSS Provider Plug-In
Verify the Oracle FS VSS Provider Installation

Verify the Oracle FS VSS Provider Installation
After you install the Oracle FS Volume Shadow Copy Service Provider (VSS)
software, verify the installation so that you can register more Oracle FS Systems.

Prerequisite Installed VSS software.

Verify the software installation from the command prompt on your server.

1 From your Windows server, navigate to Start > Run.

2 From the Open field, enter cmd.

3 Verify installation by running the following command.

C:\vssadmin List Providers

This command returns the name of the VSS provider, for example:
Provider name: 'Oracle FS VSS HW Provider'

If the VSS Provider returns the provider name, Oracle FS VSS HW Provider,
then the installation was successful and your server can use the VSS
provider to create shadow copies.

Related Links
Oracle FS VSS Provider Plug-In
Download and Install the VSS Software
Register Additional Systems with VSS

Register Additional Systems with VSS
As your system configurations change, you can register more Oracle FS Systems
with the Oracle FS Volume Shadow Copy Service Provider (VSS).

Prerequisites Installed VSS software.
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You need the following information to register each
Oracle FS System with the VSS software:

• System serial number
• Login account: user name
• Login account: password

The VSS software adds and removes Windows registry entries for the Oracle FS
System.

The VSS installer allows you to configure a single Oracle FS System. To configure
more systems or remove systems, use the registerAxiom command‑line tool:

1 From your Windows server, navigate to Start > Run.

2 From the Open field, enter cmd.

3 (Optional) To view a list of acceptable usage options, enter
registerAxiom.

4 To register an Oracle FS System, enter registerAxiom sample-serial-number
user-name user-password.

Note: Enter the required information in the order listed.

5 (Optional) To remove a registered Oracle FS System, enter registerAxiom
sample-serial-number.

Related Links
Oracle FS VSS Provider Plug-In
Verify the Oracle FS VSS Provider Installation
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CHAPTER 8

Manage Software Components

Display Software and Firmware Versions
Before performing an update of the Oracle FS System software and firmware,
check the current version of the system software and firmware to ensure that you
stage the correct package.

The following modules include version information:

• Drive firmware and Enclosure (EBOD) Firmware in the Drive Enclosures

• Application software and operating system in the Pilots

• Controller software and Controller BIOS

Note: For administrator accounts that have the Support or the Oracle Support
role, the system displays complete packaging information, including the
compatibility matrix for the software and firmware. For all other administrator
accounts, the system displays only the release number of the software and
firmware.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Verify that the current version of the installed system software and
firmware to ensure that you stage the correct package.
You should stage a newer version of the software than the software that is
installed.

Related Links
Software and Firmware Overview Page
View the Upgrade Paths to the Staged Package
View the Upgrade Paths From the Installed Package

Download Software and Firmware Updates
Download the latest software and firmware updates from My Oracle Support
(MOS) to ensure that your Oracle FS System is up to date. You can download
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general availability releases, as well as patches specific to your system, from
MOS.

Prerequisites: • Ensure that you are registered on MOS.
• For restricted patches, contact Oracle Customer Support to

request the password.
• Have available the serial number for the Oracle FS System

for which you want the software or firmware update.
• Have available the patch number for the Oracle FS System

for which you want the software or firmware update.

1 Using your registered username and password, log in to My Oracle Support
(https://support.oracle.com).
For more information about all the features and functionality of MOS,
including information about patches and updates, see My Oracle Support
Documentation (http://docs.oracle.com/cd/E25290_01/index.htm).

2 In the menu bar, select Patches and Updates.
3 In the Patch Search pane, choose one of the following search methods:

Number/Name or Bug
Number (Simple)

Search for the patch name, the patch number, or
the platform.

Product or Family
(Advanced)

Search for the product, the release, and the
platform, as well as other criteria.

Note: The product you want to search for is Oracle
FS1-2 Flash Storage System.

Recommended Patch
Advisor

Search for recommended patches for products,
releases, and platforms.

4 Complete all the fields necessary to perform your search.
5 Click Search.
6 On the Patch Search window, review all patch information.

Check the file size of the download and ensure that your workstation has
sufficient space for the download.

7 Click the row of the patch that you want to download, and then click Read
Me.

Important: Always review the Read Me file before downloading the patch
or update to ensure that you are downloading the correct version.

8 To download the software and firmware package, click Download.
The system displays a dialog box that identifies the software package to be
downloaded. A single patch or software update can contain multiple files.

Tip: If your browser window displays an information bar that states that
the download is blocked, click the appropriate options to allow the
download to proceed.

Manage Software Components

185

https://support.oracle.com
http://docs.oracle.com/cd/E25290_01/index.htm
http://docs.oracle.com/cd/E25290_01/index.htm


9 On the File Download screen, click Show Digest Details to display the
SHA‑1 and MD5 checksums for each of the ZIP files.

10 To begin the download, click the filename of the selected file.

11 To save the software package on your workstation, click Save.
After you successfully download the software update package, close the
original dialog box.

12 Using the Digest Information from the Patch Download screen, verify the
integrity of the downloaded files before proceeding.

13 Extract the ZIP files.

Important: You cannot stage the ZIP file. You must stage the RPM Package
Manager (.rpm) file.

Upload (stage) the extracted software or firmware RPM Package Manager (.rpm)
file to the Oracle FS System.

Related Links
Upload the Software and Firmware Package

Upload the Software and Firmware Package
After downloading a software and firmware update package from My Oracle
Support (MOS), and extracting the RPM files from the ZIP archive, you can stage
(upload) the RPM files on the Pilot to prepare the system for the software and
firmware update. You can perform the update immediately or schedule the
update for a later time.

Prerequisite: Place the update package on a workstation or client located on the
same network as the Pilot or on a workstation located on a
network that has a LAN connection speed to the Pilot of at least
100 Mb/s. The workstation must support either Oracle FS System
Manager or Oracle FS CLI.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 From the Software and Firmware page, click Upload Software Package.

3 From the Upload Software Package dialog, click the browse button […].

4 In the Upload Software Package dialog, navigate to the software package
you downloaded, highlight it, and click Open.

5 Click OK.
The software package is placed onto the Pilot. When the upload is
complete, the update package displays in the Staged Software and
Firmware panel.
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Tip: Click Tasks on the Software and Firmware screen to view the staging
progress in Oracle FS System Manager. The staging task only appears on
the screen after the RPM file has been uploaded.

After staging is complete, verify that the software or firmware module and the
version number of a software or firmware module match what you intended to
upload.

Related Links
Software and Firmware Overview Page

Updating the Software and Firmware
An update operation installs a new version of software or firmware onto an
Oracle FS System. You can manually update the software or the firmware using
Oracle FS System Manager (GUI).

You must download the software and firmware updates from My Oracle Support
(MOS) to your local host, stage the software and firmware updates on the Pilot to
prepare the system for the update, ensure that there are no system alerts and that
all statuses are normal in the GUI, and then update the software and firmware.

An update affects one or more of the following components:

• Drive Enclosure

• Drive firmware

Note: Drive firmware is listed by drive type (for example, Hitachi
300Gb HDD or SanDisk 1600GB SSD). Updating the drive firmware
requires a system restart.

• Enclosure Firmware

Note: Enclosure Firmware is listed by type and version (for example,
Enclosure Firmware Xrtx Ebod 7044319).

• Pilot

• Pilot Software

• Pilot OS

• Controller

• Oracle FS1-2 Controller Software

• Controller BIOS

Note: Controller BIOS is listed by model number (for example, M3
Controller BIOS). Updating the Controllers requires a system restart.

Note: A software update always includes the Pilot Software and the Oracle FS1-2
Controller Software. The Pilot Software and the Oracle FS1-2 Controller Software
must be installed at the same time and their versions must match.
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Related Links
Software and Firmware Update Prerequisites
Software Update Options
Download Software and Firmware Updates
Upload the Software and Firmware Package
Upload Storage Class Mapping File

View the Upgrade Paths to the Staged Package
You can review a history of the software and firmware packages that have been
staged on your Oracle FS System to see which upgrades are available, as well as
whether an upgrade causes Pilot or data disruption.

Note: For administrator accounts that have the Support or the Oracle Support
role, the system displays complete packaging information, including the
compatibility matrix for the software and firmware. For all other administrator
accounts, the system displays only the release number of the software and
firmware.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Select Actions > View Upgrade Paths to Staged Package.
The Upgrade Paths to Staged Package dialog displays the packages that
have been staged to the Pilot.

3 Verify that the information is what you expect.
If the list shows more than one upgrade version, install the earliest
software version first, followed by the subsequent versions.

Related Links
Software and Firmware Overview Page

View the Upgrade Paths From the Installed Package
You can review a history of the software and firmware packages that are installed
on your Oracle FS System. Knowing which software and firmware packages that
are installed on your Oracle FS System helps you decide which upgrades are
needed.

Note: For administrator accounts that have the Support or the Oracle Support
role, the system displays complete packaging information, including the
compatibility matrix for the software and firmware. For all other administrator
accounts, the system displays only the release number of the software and
firmware.

1 Navigate to Support > Software and Firmware.
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The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Select Actions > View Upgrade Paths from Installed Package.
The Upgrade Paths from Installed Package dialog displays the upgrade
path information.

Related Links
Software and Firmware Overview Page

Types of Software Updates
Both standard (non-disruptive) software updates and disruptive software
updates can be performed to the Oracle FS System. You need to understand the
different update types before you perform an update.

Standard (non-disruptive) software updates do not require a restart of the entire
system. Disruptive software updates require a restart of the entire system.

Note: In addition to software updates that you perform, the system performs
automatic updates to hardware components using firmware already stored in the
system.
For example, when replacement hardware is installed and the replacement
hardware is at a lower firmware version than the current system version, the
firmware in the new hardware is automatically updated. Automatic updates also
occur during a system, Controller, or Drive Enclosure restart where a system
software update contains non‑critical hardware firmware updates and the update
has been purposely ignored by the system during non‑disruptive updates due to
the additional time needed for installation.
Drive firmware updates are never installed on a system restart unless an
administrator specifies that the drive firmware is to be updated.

As system software updates are installed, only one type of update can be
performed at a time. You can either update the system software or update the
drive firmware but not both at the same time. For drive firmware updates, install
all updates unless instructed not to install all updates by Oracle Customer
Support.

Related Links
Standard Software Updates
Disruptive Software Updates

Standard Software Updates

You should be aware of which software updates are standard before you perform
them. The Oracle FS System implements standard software updates by installing
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both the Oracle FS1-2 Controller Software and the Pilot Software, and if
applicable, the Pilot OS.

Standard updates interrupt data access for a few seconds. However, the software
can be updated without restarting the entire system and user applications do not
lose access to the Oracle FS System storage arrays during the software update.

The Pilot does shut down and restart. When the Pilot shuts down, the connection
between the Oracle FS System and Oracle FS System Manager (GUI) is
disconnected. A message stating that the connection has been lost displays,
followed by the login panel from which you can log back in. If the update is still
in progress after you log back in, navigate to the Status Summary screen to view
the status of the Pilots, Controllers, and Drive Enclosures.

Tip: To check the overall status of the system, go to the System Information
screen. If the status is BOOT_STATE_PILOT, the update is still in progress.

Related Links
Disruptive Software Updates

Disruptive Software Updates

You should be aware of which software updates are disruptive before you
perform them. Oracle FS Systems implement disruptive software updates by
restarting the entire system to bring up the new software. User applications lose
access to the Oracle FS System storage arrays during a disruptive software
update.

Examples of disruptive updates include drive updates and Controller BIOS
component updates. You choose to perform a disruptive update by selecting
Restart and update software or Shutdown Controller.

Note: If the upgrade package includes enclosure firmware updates, and you do
not select Restart and update software or Shutdown Controller, the update
proceeds without restarting the system. The enclosure firmware updates are not
applied until the next system restart. If you do select Restart and update
software or Shutdown Controller, the system installs the enclosure firmware on
the resulting system startup.

You need to perform disruptive updates under the following conditions:

• The system is not reporting a Normal state

• Pinned data is found within the system

• The compatibility matrix validation needs to be overridden to complete the
installation

• System alerts are active

• A previous software update failed
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• The new Controller BIOS version is an newer version than the current
version installed on the system

• Another task fails to complete within 10 minutes of starting the update

Related Links
Standard Software Updates

Software Update Options

You can choose to ignore certain system conditions in order to perform an
update.

You might choose to ignore certain system conditions in the following
circumstances:

• System conditions are preventing you from performing an upgrade

• To recover from a failed upgrade

• To perform an upgrade to recover from a system condition

• To install an older release that the one that is installed

Whether you are performing a standard software update or a disruptive software
update, you can choose to ignore system conditions, to force a controller
shutdown, and to override a previously failed software update. Select any of the
following overrides:

Ignore
compatibility

Ignoring the compatibility matrix validation should be
performed only if all other attempts to correct system
configuration have failed and you have been instructed by the
release notes, a My Oracle Support Knowledge article, or
Oracle Customer Support to ignore the validation.

Shutdown the
Controller

Disrupts data access and forces a system restart. The
Controllers shut down and then restart with the new software
installed. Only use this option if you have been instructed to
do so by the release notes, a My Oracle Support Knowledge
article, or Oracle Customer Support.

Ignore hardware
status (except
Pilots)

Used to upgrade a system with a minor issue, such as a single
failed drive. If the issue is in a Controller, do not use the
option unless instructed to do so by Oracle Customer Support
or the release notes.

Ignore system
alerts

An upgrade of any type will be blocked if there are any
system alerts unless this option is selected. System alerts for
issues that do not affect the operation of the system do not
affect the ability to perform a standard update, for example, a
failed email, a failed Call‑Home, a failed FTP server, or task
failure due to an invalid requested configuration change.
For system alerts indicating topology issues or hardware
conditions, contact Oracle Customer Support or resolve the
condition before attempting a standard update.
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Important: Always check the details of all the system alerts
before using this option.

Ignore current
requests

Used to cancel Pilot software tasks in progress, such as log
collection or Call‑Home. For any task that is modifying
storage, host access, or system software, do not use this option
without advice from Oracle Customer Support. The system
waits for up to 10 minutes for running tasks to complete. If
non-upgrade tasks do not complete within 10 minutes, the
upgrade fails with a Failed To Drain Operation Pool error unless
this option is selected.

Override
previously
failed software
updates

Used to retry a software update after the issue involved in the
prior failed attempt is corrected. Using this option does not
cause a disruptive update. Do not use this option more than
once for any software update without advice from Oracle
Customer Support.

Related Links
Update the Oracle FS System Software
Cancel a Scheduled Software Update

Software and Firmware Update Prerequisites
Ensure that all prerequisites are met before performing any software and
firmware update so that your software and firmware update is successful.

Important: Always read the Release Notes for any patch or update for a complete
list of upgrade requirements and prerequisites.

Prerequisites:

• For minor updates (for example, R6.1 to R6.2) and patch release updates
(for example, R6.1.1 to R6.1.2), perform the following actions:

• On the Software and Firmware page, verify the currently installed
release to ensure that you staged the correct package. Your staged
release should be more recent than your installed release.

• On the System Alerts page, check for system alerts and resolve all
issues by performing the recommended actions. Contact Oracle
Customer Support if you require assistance.

• On the Status Summary page, ensure that all Oracle FS System
Manager statuses are Normal.

• On the Tasks page, check for tasks that are pending. If you have tasks
that are pending, the system waits for the existing tasks to complete
before running the update.

• For a major update (for example, R6.x to R7), read the release notes and
complete any of the following necessary tasks:
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• Ensure that all prerequisites are met for any minor and patch release
updates.

• Halt all data path I/O.

• Open a service request with Oracle Customer Support to ensure that
a system audit is not required.

• For a Pilot BIOS update, ensure that you have a USB keyboard and VGA
monitor, as well as the login credentials for the Pilot root password and
the Oracle Integrated Lights Out Manager (ILOM) root password. See
Oracle FS1-2 Flash Storage System Field Service Guide for more information.

Related Links
Update the Oracle FS System Software
Cancel a Scheduled Software Update

Update the Oracle FS System Software
After staging a software package on the Pilot, you can update the system
software. You can perform the update immediately or schedule the update for a
later time.

Note: Perform the update operation as the Primary administrator and in an
Administrator 1 role.

Important: When logged into the system as a support administrator, you can
select individual components to update from the software module package. You
can also select Always Install, Install if newer version, or Do not install.
Contact Oracle Customer Support before installing individual software
components.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Select Actions > Update Software.
3 (Optional) Select the individual software module you want to update,

using the Install Action column at the top of the screen.

Valid options are:

• Do not install

• Install if newer version

• Always Install

Important: Only update individual software modules under the direction of
Oracle Customer Support.

4 Unless explicitly directed to select Restart and update software (disrupts
data access) by the Read Me file, Release Notes, or Oracle Customer
Support, select the option Update software without restarting system.
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5 (Optional) Select any of the other options available in the Software Update
Options pane.

Note: A software update validation errors message appears on the bottom
of this page if you select an option that cannot be performed. You must
clear any software update validation errors before proceeding. Some
options will cause data access disruptions. Be sure to read each option
carefully.

6 (Optional) To schedule your software update for a later time, click the
Schedule tab and enter the time on which the system should perform the
operation. You can schedule updates to occur within 72 hours.

7 Click OK.
8 Click Yes.

If you selected any of the upgrade options, you need to accept the
agreements for all those options.

Related Links
Update Software
Restart the Oracle FS System

Schedule the Software Update
You can schedule software updates to occur at a specified time. For example, you
can schedule an update to occur during off‑peak hours when there is less I/O
activity.

Prerequisites: • Software updates uploaded and ready to install.
• Logged in to Oracle FS System Manager (GUI) using

the Administrator role.

You can schedule updates to occur within 72 hours.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Select Actions > Update Software.
3 (Optional) Select the individual software module that you want to update.

The default action is Install if newer version.

Valid options are:

• Do not install

• Install if newer version

• Always Install

Important: Only update individual software modules under the direction of
Oracle Customer Support.
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4 To enable a software update schedule for a later time, click the Schedule
software update to occur at a later time option.

5 Click the ellipsis control (...) and enter the date and time on which the
system should perform the operation. You can schedule updates to occur
within 72 hours.

6 Click OK.
After clicking OK, the Software and Firmware page displays the scheduled
software update.

Important: At the scheduled time of the update, the system status must be
normal with no system alerts. If the system status is not normal or the
system has alerts, the scheduled update fails.

You can click Cancel Scheduled Update at any time to cancel the scheduled
software update.

Related Links
Cancel a Scheduled Software Update

Cancel a Scheduled Software Update
You can cancel a scheduled software update, for example, if you need to
reschedule the update for an earlier or later time.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Click Cancel Scheduled Update.
If a scheduled software update is active, a notice appears on the page.

3 Confirm that you want to cancel the update and click OK.
The system deletes the scheduled task and removes the software update
notice from the Software and Firmware page.

Related Links
Software and Firmware Overview Page

Update the Drive Firmware
Update the drive firmware so that the drive performs at an optimum level as
specified by the manufacturer.

1 Navigate to Support > Software and Firmware.
The summary page displays the software and firmware packages currently
installed on the Drive Enclosures, Drives, Pilots, and Controllers, as well as
any staged software and firmware packages.

2 Confirm that the correct firmware version is staged on the Oracle FS
System.
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3 Select Actions > Update Drive Firmware.

4 To choose the firmware that you want to update, select the Install
checkbox in the Pending Drive Firmware Updates pane.

5 When you are ready to update the drive firmware and disrupt data access
to the system, click OK.

The system updates the firmware of the drives that match the criteria specified in
the firmware package. One drive is taken offline and the firmware updated. Then
the drive is placed online and the RAID information updated. The process
repeats for each drive. When the update completes, the Oracle FS System
restarts. During restart, the system updates any drives that contain outdated
firmware.

If the update fails, the update for the rest of the drives is cancelled, and the
Oracle FS System displays a system alert. To resolve the issue, you can either try
the update process again or replace the affected drive. If the problem continues,
contact Oracle Customer Support.

Related Links
Update Drive Firmware Dialog
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CHAPTER 9

Manage Hardware Components

Pilot Management
The Pilot is a hardware component that provides system management services,
system restart services, Call‑Home services, administrative access, and
maintenance access. Administrators can connect to the Pilot nodes over the
Ethernet using Oracle FS System Manager (GUI) or Oracle FS CLI.

You manage the Pilot by performing the following tasks:

• Troubleshooting network connectivity to the Pilot

• Identifying, troubleshooting, and repairing a Pilot
hardware

• Ensuring that network access is configured to necessary external
applications

• Ensuring that Call‑Home and Auto Service Request (ASR) is configured
and enabled

Pilot management also includes ensuring that certain network ports needed by
either the client applications or the Pilot are open.

Related Links
View the Properties of the Pilots
View the Network Connectivity of a Pilot
Identify a Pilot
Repair a Pilot

Pilot Overview
The Pilot is an out-of-band management controller that directs and manages all
system activity.

Each Oracle FS System has one active Pilot and one standby Pilot.

The Pilot provides access to the following:

• All management functions for the Oracle FS System

• System monitoring, alerts, log collection, and automatic log transmission

• Management for restarting, replacing, updating, and recovering Controller
and Drive Enclosure resources
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The following figure shows the front of the Pilot.

Figure 10: Pilot

View the Properties of the Pilots
You can view the properties of the Pilots on your Oracle FS System. For example,
you might want to know the status and OS version of both the standby and the
active Pilot node.

Ensure that one Pilot is in active mode and the other Pilot in standby mode, and
that the displayed OS versions and server versions for both Pilots are the same.

1 Navigate to System > Hardware > Pilots.

2 Verify that the information is what you expect.
If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.

Related Links
Pilot Overview Page

View the Network Connectivity of a Pilot
You can view the network connectivity of a Pilot to determine which network
interfaces are connected, as well as the status of the network interfaces for the
management of the system and for the servicing of the system.

1 Navigate to System > Hardware > Pilots.

2 Select a Pilot.

3 Select Actions > View Pilot.

4 Verify that the information is what you expect.
If you see a status other than Connected and Consistent, view the details of
that hardware component to diagnose and to resolve the issue. If you
encounter an issue that you cannot resolve, contact Oracle Customer
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Support. If the Consistency of Status shows Intermittent for any interface,
check both ends of the cable to make sure they are securely inserted.

5 Click Close.

Related Links
View Pilot Dialog
Configure the Management Interface
Pilot Management
View the Properties of the Pilots
Identify a Pilot
Repair a Pilot

Identify a Pilot
You can identify a specific Pilot. The system uses flashing LEDs to identify
hardware components. In a crowded data center, the flashing LEDs allow you to
locate the Pilot on which you want to perform maintenance.

1 Navigate to System > Hardware > Pilots.

2 Select a Pilot.

3 Select Actions > Identify Pilot.
The Identify dialog is displayed.

4 Follow the instructions provided by Guided Maintenance to identify the
hardware component.

5 Click Finish.

Related Links
Pilot Management
View the Properties of the Pilots
View the Network Connectivity of a Pilot
Repair a Pilot

Repair a Pilot
Guided Maintenance enables you to replace components on either your active or
your standby Pilot nodes.

1 Contact Oracle Customer Support prior to replacing a Pilot component.
Oracle Customer Support identifies the failed component on the Pilot for
you.

2 Navigate to System > Hardware > Pilots.

3 Select the Pilot you want to repair.

4 Select Actions > Repair Pilot.
Guided Maintenance displays the list of Pilot components.

Manage Hardware Components

199



5 Based on the information from your Oracle Customer Support
representative, select the correct component from the list.

6 Click Next.
Guided Maintenance sends a request to flash the white locate LED on the
Pilot to help you identify the Pilot in the data center.

7 Click Next.

Guided Maintenance displays a link to Pilot Repair Procedures.

8 Click the Pilot Repair Procedures link to open and print the procedures.

9 Click Next.

• If you are replacing a component located on the active Pilot, Guided
Maintenance brings the active Pilot offline and fails over to the
standby Pilot. After the active Pilot is offline, the GUI closes. You can
safely disconnect the power cords and data cables. When the failover
is complete, you can log back into the GUI.

• If you are replacing a component located on the standby Pilot,
Guided Maintenance brings the standby Pilot offline. After the
standby Pilot is offline, you can safely disconnect the power cords
and data cables. When servicing the standby Pilot, failover is not
required.

• If you are replacing a power supply or a fan module, you are not
required to bring the Pilot offline. The power supplies and fan
modules are hot‑serviceable.

Note: You can replace one power supply without bringing the Pilot
offline, as long as the second power supply remains online and
operational.

Related Links
Pilot Management
View the Properties of the Pilots
View the Network Connectivity of a Pilot
Identify a Pilot

Management Network Ports
If there are any firewalls located between the Pilot and the source or destination
of a service, the ports must be open for that service to function.

The following table lists all of the software ports that are used by the Pilot for
communicating with other components within the Oracle FS System and with
services running on the network.
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Table 12: Pilot TCP ports
Port
number

Application Description

22 SSH Used by Oracle Customer Support. This port is
disabled by default and may be opened only in rare
situations if required during a service call. In those
cases, Oracle Customer Support will notify the will
be notified that this port needs to be opened.

25 Simple Mail
Transfer Protocol
(SMTP)

Used by the Pilot for email notifications that are sent
by the Oracle FS System and for account password
recovery. This port is only used for outbound
communication to a configured mail server.

53 DNS Used by the Oracle FS System for name resolution of
other servers and services in the environment, for
example, to resolve the name of an external mail
server as needed for email notifications.

80 HTTP Used by the Oracle FS System for status monitoring
and the download from the Pilot of documentation
and various applications, such as Oracle FS System
Manager (GUI).

123 Network Time
Protocol (NTP)

Used by the Oracle FS System to synchronize the
system time with an external time service provider.

161 Simple Network
Management
Protocol (SNMP)

Used by a host SNMP Management Server to monitor
the Oracle FS System.

162 SNMP traps Used by the Oracle FS System to transmit SNMP
traps to an external management application or by
UPS devices to send notifications to an Oracle FS
System. For example, used by compliant UPS devices
to warn the Oracle FS System that the UPS device is
running on battery power.

443 HTTPS Used by the HTTPS Call‑Home option on the Pilot.
This port must be open on all three Pilot ports to the
Oracle Call‑Home server.

Also used by HTTPS for checking status and alerts,
using a web browser.

8083 Oracle FS CLI
interface

Used by the Oracle FS System for the Oracle FS CLI
interface and for application integration.
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Table 12: Pilot TCP ports (continued)
Port
number

Application Description

8085 REST interface Used by the Oracle FS System for application
integration with a REST-based management
application. This port is disabled by default.

10000 Network Data
Management
Protocol (NDMP)

Used by the Pilot to provide backup and restore
access to all file systems on the Oracle FS System.
This port must be open between the three IP
addresses of the Pilots and the Backup Management
Server.

26012 Oracle FS System
Manager

Used by Oracle FS System Manager (GUI) and
Oracle FS Path Manager (FSPM) to communicate
with the Oracle FS System.

Controller Management
A Controller is one of the nodes in an active-active pair of nodes, each of which
provides access to user data and mirrors the cached data and the state of the
partner node. When a Controller fails or when a Controller is taken offline
through Guided Maintenance, the Oracle FS System uses failover and failback to
return the Oracle FS System to a normal state. Failover transfers all of the
resources of the offline node to the node that remains online. Failback transfers
those resources back to the node that was offline when the node comes back
online.

Managing Controllers consists of the following tasks:

• Viewing the overall status of all Controllers, as well as the details of
specific Controllers

• Modifying comments, chassis IDs, and the service types of each Controller

• Identifying Controllers

• Replacing failed components

• Monitoring Controller failover and failback

Related Links
Controller Diagnostics and Command Testing
SAN Controller Protocols Statistics and Trending Overview
Controller Commands

Controller Overview
Controllers provide I/O access to the customer LAN or SAN and provide an
internal SAS interface that is used to interconnect all Drive Enclosures and other
Controllers. The Oracle FS System supports two storage Controllers.
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The following figure shows an Oracle FS System Controller.

Figure 11: Oracle FS System Controller

View the Status of the Controllers
Viewing the status of the Controllers can help you to respond quickly to
problems that can occur on a Controller.

1 Navigate to System > Hardware > Controllers.
The Controllers overview page displays the status summary of each
Controller, the chassis, the comment, the service type, the failover
Controller , temperature, and a summary of the FRUs and CRUs.

2 Verify that the information is what you expect.
If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.

Related Links
Controllers Overview Page

View the Details of a Controller
You can view the details of any Controller. For example, you might want to view
the status of each field replaceable unit (FRU) and customer replaceable unit
(CRU) to determine whether Guided Maintenance is needed to replace a
component. You can also view the status of the I/O ports.

The Controller details include the following information:

• Controller identifier, memory size, and model

• Replaceable unit part number, serial number, location, and specifications

1 Navigate to System > Hardware > Controllers.
The Controllers overview page displays the status summary of each
Controller, the chassis, the comment, the service type, the failover
Controller , temperature, and a summary of the FRUs and CRUs.

2 Select a Controller.
3 Select Actions > View.
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4 Verify that the information is what you expect.
If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.

5 Click Close.

Related Links
View Controller, Components Tab
View Controller, I/O Ports Tab
Controller Ports

Modify the Controller Comment
The Controller comment is the descriptive text that is assigned to a Controller.
You can change or assign unique, meaningful comments to help you more easily
locate specific Controller components. The Controller comment can contain up to
255 alphanumeric characters.

1 Navigate to System > Hardware > Controllers.
The Controllers overview page displays the status summary of each
Controller, the chassis, the comment, the service type, the failover
Controller , temperature, and a summary of the FRUs and CRUs.

2 Select a Controller.

3 Select Actions > Modify.

4 In the Comment field, enter a string of text that associates a comment with
the Controller.
You can enter up to 255 alphanumeric characters.

5 Click OK.

Related Links
Modify Controller, Components Tab

Modify a Chassis ID
The chassis ID is the Controller Name as displayed in the Controllers summary.
Chassis IDs are unique, numeric identifiers that are displayed on the Controllers
and the Drive Enclosures. You can use Oracle FS System Manager (GUI) to
modify the chassis IDs.

1 Navigate to System > Hardware > Controllers.
The Controllers overview page displays the status summary of each
Controller, the chassis, the comment, the service type, the failover
Controller , temperature, and a summary of the FRUs and CRUs.

2 Select a Controller.

3 Select Actions > Modify Chassis ID.
The Modify Chassis ID dialog is displayed.
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4 From the Desired ID list, select a new Chassis ID number.

5 Click OK.

Related Links
Modify Chassis ID Dialog
Pilot Management

Identify a Controller
You can identify a specific Controller. The system uses flashing LEDs to identify
hardware components. In a crowded data center, the flashing LEDs allow you to
locate the Controller on which you want to perform maintenance.

1 Navigate to System > Hardware > Controllers.
The Controllers overview page displays the status summary of each
Controller, the chassis, the comment, the service type, the failover
Controller , temperature, and a summary of the FRUs and CRUs.

2 Select a Controller.

3 Select Actions > Identify.
The Identify dialog is displayed.

4 Select one of the identification options.

5 Click Next.

6 Follow the instructions provided by Guided Maintenance to identify the
hardware component.

7 Click Finish.

Related Links
Pilot Management

Drive Enclosure Management
You can expand the storage pool that is available to an Oracle FS System to
accommodate increased storage demands by adding additional Drive
Enclosures. Additionally, moving drive groups from one Storage Domain to
another can help balance the capacity provisioning across domains.

Managing Drive Enclosures consists of the following tasks:

• Viewing the overall status of all Drive Enclosures, as well as the details of
specific Drive Enclosures

• Modifying comments and chassis IDs

• Identifying Drive Enclosures

• Replacing failed components
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Related Links
Drive Groups
Storage Domains
Run the Drive Enclosure Commands
Upload Storage Class Mapping File

Drive Enclosure Overview
Drive Enclosures are used as back-end storage for the Oracle Flash Storage
System. The Oracle FS System can be configured for as many as 30 Drive
Enclosures. The two types of Drive Enclosure are the DE2-24P Drive Enclosure
and the DE2-24C Drive Enclosure. Both Drive Enclosure types can co-exist in the
same system.

Drive Enclosure are high‑availability, serial‑attached SCSI (SAS‑2) storage
enclosures. The DE2‑24P Drive Enclosure has a 2U chassis that supports 24 small
form factor (SFF), 2.5-inch (6.35-cm) hard disk drives (HDDs). The DE2-24P Drive
Enclosure also supports configurations with seven, 13, or 19 solid state drives
(SSDs). The DE2‑24C Drive Enclosure has a 4U chassis that supports 24 large
form factor (LFF), 3.5-inch (8.89-cm) HDDs.

The following figures show the front of the DE2‑24P Drive Enclosure and the
DE2-24C Drive Enclosure.

Figure 12: DE2-24P Drive Enclosure (front view)
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Figure 13: DE2-24C Drive Enclosure (front view)

Both types of Drive Enclosures have the following physical configuration:

• Two hot-serviceable I/O modules with two interface slots that comply with
the Storage Bridge Bay (SBB) standard

• Two hot-serviceable 580W power cooling modules with dual load-sharing
power supplies and integrated fans

• 19-inch rack‑compatible enclosure

• Front access to all drives

• Back access to the I/O modules and the power cooling modules

• LEDs with status information for the I/O modules, the drives, and the
power cooling modules

The following figures show the back of the DE2‑24P Drive Enclosure and the
DE2-24C Drive Enclosure.
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Figure 14: DE2-24P Drive Enclosure (back view)

Figure 15: DE2-24C Drive Enclosure (back view)

Related Links
High Availability
HDD Failure and Recovery
SSD Failure and Recovery

High Availability

High availability centers around RAID levels, redundancy, pre-emptive copy,
dynamic spares, dedicated spares, and copyback. With high availability, the
Oracle FS System can respond gracefully to an unexpected hardware or software
failure that has the potential for service disruption. Furthermore, this feature
keeps customer data highly accessible even during hardware replacements.
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The Oracle FS System includes the following high‑availability features:

Single
Parity

Stores the original user data plus one set of parity bits to help in
the recovery of lost data. Access to the data is preserved even after
the failure of one drive. Single parity is implemented using RAID 5
technology and is the default redundancy level for the Storage
Classes that specify the performance-type media.

Double
Parity

Stores the original user data plus two sets of parity bits to help in
the recovery of lost data. Access to the data is preserved even after
the simultaneous failure of two drives. Double parity is
implemented using RAID 6 technology and is the default
redundancy level for the Storage Classes that specify the capacity-
type media.

Mirroring A RAID level in which the Oracle FS System maintains an exact
duplicate of a logical volume at a different location. No parity data
is used. Mirroring protects against the loss of at least one drive
and possibly more drives with an improvement of the
performance of random write operations. Mirrored RAID is
implemented using RAID 10 technology.

Oracle Pre-
Emptive
Copy

A feature of the Oracle FS System firmware that copies the data on
a drive that has been predicted to fail to a spare drive before the
suspect drive fails and is subsequently taken offline for
replacement. This feature avoids performance degradation and
potential exposure to data loss when the drive does fail.

Dynamic
Spare

Unallocated strips on high-capacity hard disk drives (HDDs) in a
given drive group. This spare capacity is striped across all of the
HDDs in the drive group. Dynamic spares are used to support the
RAID 5 protection level and the RAID 10 protection level.
Dynamic spares cannot cross drive group boundaries.

Spare Drive An unused solid state drive (SSD) that can support the rebuilding
of a drive group by means of copy-away operations. Drive
Enclosures and drive groups do not contain an SSD that is
dedicated only to this purpose. If, however, an unused SSD exists
in a Drive Enclosure and if an SSD in that Drive Enclosure fails or
is removed, the system uses that unused drive to rebuild the drive
that failed or was removed.
Furthermore, if no unused SSD exists, the system can use its parity
data to continue functioning with a lost SSD.

Copyback Copyback is the process of moving data from an active spare strip,
for HDDs, or from a dedicated spare drive, for SSDs, to a newly
replaced drive.

Related Links
Priority Level and Performance
Redundancy and Data Protection
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SSD Failure and Recovery

If a solid state drive (SSD) fails, the Oracle FS System uses RAID 5 (single parity)
and the RAID 10 (mirroring), along with the dedicated spare drives, to recover
lost data.

SSD arrays are configured with a dedicated spare drive. If the Oracle FS System
detects a failing SSD, the system performs an Oracle Pre-emptive Copy, which
copies the data from the failing SSD to the spare drive. An Oracle Pre-emptive
Copy protects the system from performance degradation and potential data loss
when an SSD fails. A spare drive can have different performance or data
retention characteristics.

After the failing SSD is replaced, the system performs a copyback operation. The
copyback operation copies the data from the spare drive to the replacement SSD.
The copyback operation restores the SSD array to its original capabilitieswith a
normal rebuild to spare and copyback from spare.

Note: You can view the remaining life expectancy (in months) and pro-actively
replace the drive using Guided Maintenance in Oracle FS System Manager (GUI).

Related Links
Redundancy and Data Protection

HDD Failure and Recovery

If a hard disk drive (HDD) fails, the Oracle FS System uses the parity and the
mirroring features of RAID technology, along with the dynamic spares, to ensure
that data is not lost.

HDD arrays are configured with dynamic spares. In a RAID configuration, an
HDD failure triggers a rebuild operation. During a rebuild operation, the
reconstructed data is built on the spare HDD that is within the rebuilt stripe.
When the failed HDD is replaced, the data held in the spare HDD is copied back
to the replacement HDD.

Related Links
Redundancy and Data Protection

View the Status of the Drive Enclosures
Viewing the status of the Drive Enclosures helps you to identify and to respond
to problems that can occur on a Drive Enclosure.

1 Navigate to System > Hardware > Drive Enclosures.

2 Verify that the information is what you expect.
If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.
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Related Links
Drive Enclosures Overview Page

View the Details of a Drive Enclosure
Viewing the details of a Drive Enclosure helps you to identify and to respond to
problems that can occur on each field replaceable unit (FRU) and customer
replaceable unit (CRU), as well as on the I/O ports within the Drive Enclosure.

The Drive Enclosure details include the following information:

• The properties of the Drive Enclosure

• A list of all the FRUs and CRUs

• A list of all the I/O ports and the I/O port properties

1 Navigate to System > Hardware > Drive Enclosures.
2 Select a Drive Enclosure.
3 Select Actions > View.
4 Verify that the information is what you expect.

If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.

5 Click Close.

If you see a status other than Normal for any of the FRUs or CRUs, you might
need to replace that component. Select a FRU or CRU to replace it.

Related Links
View Drive Enclosure, Components Tab
View Drive Enclosure, I/O Ports Tab
Drive Enclosure Management
View the Details of a Drive Enclosure

Modify the Drive Enclosure Comment
The Drive Enclosure comment is the descriptive text that is assigned to a Drive
Enclosure. You can change or assign unique, meaningful comments to help you
more easily locate specific Drive Enclosure components. The Drive Enclosure
comment can be up to 255 alphanumeric characters.

1 Navigate to System > Hardware > Drive Enclosures.
2 Select a Drive Enclosure.
3 Select Actions > Modify.
4 In the Comment field, enter a string of text that describes the Drive

Enclosure.
You can enter up to 255 alphanumeric characters.

5 Click OK.
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Related Links
Modify Drive Enclosure, Components Tab

Identify a Drive Enclosure
You can identify a specific Drive Enclosure. The system uses flashing LEDs to
identify hardware components. In a crowded data center, the flashing LEDs
allow you to locate the Drive Enclosure on which you want to perform
maintenance.

1 Navigate to System > Hardware > Drive Enclosures.

2 Select a Drive Enclosure.

3 Select Actions > Identify.
The Identify dialog is displayed.

4 Select one of the identification options.

5 Click Next.

6 Follow the instructions provided by Guided Maintenance to identify the
hardware component.

7 Click Finish.

Related Links
Drive Enclosure Management
Modify the Drive Enclosure Comment
Modify a Chassis ID

Modify a Chassis ID
The Chassis ID is the Drive Enclosure Name as displayed in Drive Enclosures
summary. Chassis IDs are unique, numeric identifiers that are displayed on the
Controllers and the Drive Enclosures. You can use Oracle FS System Manager
(GUI) to modify the chassis IDs.

1 Navigate to System > Hardware > Drive Enclosures.

2 Select a Drive Enclosure.

3 Select Actions > Modify Chassis ID.
The Modify Chassis ID dialog is displayed.

4 From the Desired ID list, select a new Chassis ID number.

5 Click OK.

Related Links
Modify Chassis ID Dialog
Drive Enclosure Management
Modify the Drive Enclosure Comment
Identify a Drive Enclosure

Manage Hardware Components

212



Data Integrity on the Drives
The SCSI Protection Information field is a mechanism to prevent silent data
corruption. SCSI Protection Information ensures that any data that is successfully
read by a host from an Oracle FS System is the intended data, and that the data is
the same as when it was last written by a host. This integrity check is only
internal to the Oracle FS System.

The RAID firmware in the Oracle FS System formats all of the drives in the
storage arrays to a sector size of 520 bytes. As SAN data is received from the host,
eight bytes of integrity metadata is generated for every 512 bytes of host data.
The integrity metadata is appended to the host data to form the internal 520‑byte
sector. When data is transferred back to the host, the eight bytes of metadata is
stripped off and used to check that the 512 bytes of host data is correct. If the
check fails, a read error is reported to the host.

The eight bytes of metadata includes a Cyclic Redundancy Check (CRC) of the
host data and a Reference Tag that identifies the offset of the sector within the
host LUN or file. These two pieces of information allow the firmware to check
that the data being transferred belongs to the location that the host requested and
that the data is the same as it was when last written.

Reference Tag checking is one part of the normal data integrity processing that is
performed by the RAID firmware. However, if a client application reads a large
number of sectors that have never been written, the client application might
experience degraded performance when reading these sectors. Such client
applications can include:

• Sector level backup applications

• Replication applications

If unusual performance issues exist for such client applications, you can disable
Reference Tag checking on any given LUN to see if you can improve the
performance of those applications. If Reference Tag checking is disabled, the
Oracle FS System continues to validate CRCs for these sectors but bypasses the
Reference Tag checking.

Related Links
Drive Enclosure Management

Hardware Management
Even if you do not manage the hardware in the Oracle FS System yourself, it is
important that you understand some details about hardware management in the
Oracle FS System.

Hardware management consists of drive replacement, component replacement,
and system expansion. Both drive replacement and component replacement can
be performed using Guided Maintenance in the GUI. Guided Maintenance in the
GUI is the preferred method of hardware replacement. System expansion is not a
performed using Guided Maintenance in the GUI.
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Related Links
Drive Enclosure Management

Hardware Replacement
Your Support Services contract provides guidelines to replace field replaceable
units (FRUs) and customer replaceable units (CRUs) in your Oracle FS System.

Based on the terms of your contract, you can perform the following actions:

• Replace the FRU or CRU yourself.

• Place a service request so that a service technician comes to your site to
replace the FRU.

Tip: You can enable Auto Service Request (ASR) in My Oracle Support
(MOS) to automatically create a service request for you.

Important: Replacement of a FRU or a CRU requires that you use Guided
Maintenance in Oracle FS System Manager (GUI) or the Oracle FS CLI to
perform the following actions:

• Prepare the system for the FRU or the CRU replacement.

• Integrate the new FRU or the new CRU into the system.

Note: Guided Maintenance in the GUI provides a step-by-step graphical
representation of the hardware replacement process. Guided Maintenance
in the GUI is the preferred method of hardware replacement.
Consult the appropriate Oracle FS System Service Guide for details.

Check the power supply fan filters annually for accumulated dust. If needed,
vacuum the power supplies, even if no component replacement or repair is
required. This type of maintenance does not require Guided Maintenance.

Related Links
Replace a Component

Drive Replacement
Drive replacement is a procedure performed using Guided Maintenance. The
replacement drive can be a new drive or a drive previously used in a Drive
Enclosure.

Important: The Oracle FS System accepts only Oracle-supplied drives. The
capacity and the type of a replacement drive must be same as the other drives in
the Drive Enclosure.

The Oracle FS System considers all drives as foreign drives until you accept the
drives into the Drive Enclosure. If data exists on the drive you are inserting, all
the data is lost when the drive is accepted.

You start the drive replacement process using Guided Maintenance. Guided
Maintenance prepares the system and the Drive Enclosure for the drive
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replacement. After you have inserted a replacement drive into a Drive Enclosure,
continue using Guided Maintenance to complete the process.

Replace a Component
To maintain or to restore reliability to an Oracle FS System, you sometimes need
to replace a component.

Oracle supports only Oracle-supplied components in an Oracle FS System.

Guided Maintenance in Oracle FS System Manager (GUI) provides you a step-
by-step graphical representation of the hardware replacement process. Guided
Maintenance in the GUI is the preferred method of hardware replacement.

CAUTION: Hardware that does not conform to Oracle specifications or is not an
Oracle-supplied component might compromise data integrity and voids the
warranty of the Oracle FS System.

1 Navigate to System > Hardware and then select Controllers or Drive
Enclosures.

2 In the overview page, click the Controller or Drive Enclosure that contains
the component that you want to replace.

3 Select Actions > View.

4 On the Components tab in the View dialog, select the component that you
want to replace and click Replace Component.

5 Follow the instructions provided by Guided Maintenance to repair the
component.
Refer as well to the appropriate Oracle FS System Service Guide for detailed
instructions.

6 Click Finish.

Related Links
View Controller, Components Tab
View Drive Enclosure, Components Tab

System Expansion
To accommodate increased storage demands and to expand the storage pool
available to the Oracle FS System, you can add Drive Enclosures to the system.
You can combine additional DE2-24P Drive Enclosures and DE2-24C Drive
Enclosures in the same system.

Before adding a Drive Enclosure, make sure that the system has the latest
software version installed:

• In Oracle FS System Manager (GUI), log in with a support administrator
account and select Support > Software and Firmware.

• In Oracle FS CLI, run the software_update ‑list ‑installed command.
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Additionally, determine whether sufficient space exists in the rack for the new
Drive Enclosures. The PDUs installed in the rack must have enough free circuits.
If the PDUs cannot accommodate more Drive Enclosures or if the rack lacks
space for more Drive Enclosures, then you must set up additional racks.

Note: Adding Drive Enclosures can be disruptive to the system in the following
circumstances:

• The existing PDU arrangements are insufficient to fulfill power
requirements. The system must be powered off to add PDUs to the existing
PDU arrangement.

Note: If the system uses Oracle‑supplied racks with PDUs designed for the
system, you rarely need additional PDUs to fulfill power requirements. It
might be necessary to enable the second half of an Oracle PDU in order to
utilize additional power receptacles. Enabling the second half of an Oracle
PDU is not disruptive to the system.

• The current layout of the hardware in the racks requires changes to
accommodate the length limits for cables that are used for Controller-to-
Drive Enclosure connections and Drive Enclosure-to-Drive Enclosure
connections.

Based on the configuration of Drive Enclosure strings, adding Drive Enclosures
to the system requires one of the following scenarios:

• Distribute the new Drive Enclosures across the existing Drive Enclosure
strings that contain less than five Drive Enclosures. Adding to an existing
Drive Enclosure string is non-disruptive to the system.

When adding Drive Enclosures to an existing Drive Enclosure string,
attach the new Drive Enclosure to the last Drive Enclosure on the string.

• Create a new Drive Enclosure string. You can add up to five Drive
Enclosures to a new string. A new Drive Enclosure string requires an
available SAS HBA port.

Related Links
Display Software and Firmware Versions

UPS Devices
UPS devices provide backup power to the Oracle FS System in the event of a
power failure. The system monitors the UPS activities and reports the health of
the device.

Typically, enterprise class products like the Oracle FS System do not use a UPS
and rely on generator backed power supply in the data centers. However, if you
use a UPS, it must be based on the maximum wattage requirements of the sum
total of all the Oracle FS System components. The UPS, if used, should conform
to the APC PowerNet MIB specifications so that it can send SNMP traps to the
Oracle FS System to indicate that it is operating in battery mode or in normal
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mode and that the Oracle FS System should be configured to receive the traps.
For more information about managing APC products that can be monitored and
configured with SNMP, see the Schneider Electric MIB Reference Guide (http://
www.apcmedia.com/salestools/JGAY‑83UPH9/JGAY‑83UPH9_R0_EN.pdf). In
short, a UPS system must be based on the maximum wattage requirements of the
sum total of all the Oracle FS System components. Up to four devices can be
monitored by the system. The information gathered from the UPS includes:

• Communication status

• Power source

• Battery status

In the event of a power failure, the UPS device switches from AC to battery
power, and then sends an SNMP Trap message to the Oracle FS System
indicating that the UPS is on battery power. The Oracle FS System then switches
to a conservative operating state, where all data writes are to the storage arrays
to protect data should the UPS battery drain before normal power can be
restored. This conservative state is exited when the UPS device sends an SNMP
Trap message to the Oracle FS System indicating that the UPS is not on battery
and returns the Oracle FS System to normal cached operation.

Related Links
Create a UPS Device
View a UPS Device
Modify a UPS Device
Delete a UPS Device

Create a UPS Device
You can create a connection to a UPS device that is connected to the Oracle FS
System to allow you to see the battery status, the communication status, and the
properties of the UPS. Up to four UPS devices can be configured for the system.

1 Navigate to System > Hardware > UPSs.

2 Select Actions > Create UPS.
Do not use the community strings "public" or "private" if the UPS device
allows configuration of more secure strings.

3 Enter the information in the fields that are provided.

4 Click OK.

Related Links
Create UPS Dialog
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View a UPS Device
You can review the properties, the battery status, and the communication status
of a UPS device that is connected to the Oracle FS System.

1 Navigate to System > Hardware > UPSs.
2 Select a UPS.
3 Select Actions > View UPS.

The View UPS dialog appears.
4 Verify that the information is what you expect.

If you see a status other than Normal, view the details of that hardware
component to diagnose and to resolve the issue. If you encounter an issue
that you cannot resolve, contact Oracle Customer Support.

5 Click Close.

Related Links
View UPS Dialog

Modify a UPS Device
You can modify the properties of a UPS device. For example, you can update the
name of the UPS device or change the name of the community string that is used
to receive traps that monitor the device activities.

1 Navigate to System > Hardware > UPSs.
2 Select a UPS.
3 Select Actions > Modify UPS.

Do not use the community strings "public" or "private" if the UPS device
allows configuration of more secure strings.

4 Update the properties for the UPS connection.
5 Click OK.

Related Links
Modify UPS Dialog

Delete a UPS Device
If a UPS device is removed from the Oracle FS System, you can no longer
monitor the device activities. Because you can no longer monitor the device
activities, you should remove the connection from Oracle FS System Manager
(GUI).

1 Navigate to System > Hardware > UPSs.
2 Select a UPS.
3 Select Actions > Delete UPS.

The Confirm Delete dialog appears.
4 Click OK.
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Related Links
UPSs Overview Page
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CHAPTER 10

Manage Alerts and Events

View a Summary of the System Status
Oracle FS System Manager (GUI) provides a summary of all the hardware
components in the system and a list of the events, alerts, and notifications that
have occurred.

The System Summary page allows you to quickly access the hardware status
pages and view the number of system alerts and system events.

Tip: You can also obtain a brief set of the same information by pointing your
browser to the IP address or name of the Oracle FS System. The web server on
the Oracle FS System is a convenient facility when you want to download this
information to a mobile device.

1 Navigate to System > Alerts and Events > Status Summary.

2 Verify that the hardware status and event information are what you expect.

3 (Optional) If you detect a situation that needs to be addressed, you can
click on the item in question.
The system displays the appropriate page where you can view more
details about the situation.

Related Links
Status Summary Overview Page
Managing System Alerts
Managing Event Logs
Managing Event Notifications

Managing System Alerts
Some configuration events in an Oracle FS System require administrator
intervention to resolve the underlying issue.

The system notifies you of a system alert by displaying a flashing exclamation‑
point icon ( ) on Oracle FS System Manager (GUI) status bar. When this flashing
icon is displayed, the GMT time of the most recent alert is displayed to the right
of the icon. When you click the icon, the GUI displays the System Alerts page
that includes the following information:

• The name of system alert.
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• Information about the alert and the time that it occurred. Some of the alerts
include recommended actions.

• The date and time that the alert occurred.

To resolve the issue, perform the recommended action.

Related Links
System Notifications
Display the System Alerts
Manage the System Alerts
Delete a System Alert

Display the System Alerts
If the Oracle FS System has any system alerts, you can view details about the
alerts and perform any required action. You can sort the available list of system
alerts by category. You can also manage the system alerts from this page.

1 Navigate to System > Alerts and Events > System Alerts.

2 Review the system alert list to ensure that the information is what you
expect.

If the alert is resolved, the system deletes the alert from the list. If the alert
persists, the alert remains on the System Alerts page.

Related Links
System Alerts Overview Page
Managing System Alerts
Manage the System Alerts
Delete a System Alert

Manage the System Alerts
You can view the details of a system alert that is generated by the Oracle FS
System. You can also copy the alert information to your workstation clipboard.

1 Navigate to System > Alerts and Events > System Alerts.

2 Select an alert from the list.

3 To display details about the alert, select Actions > Manage.

Tip: You can also double‑click the alert.

4 Read the information about the system alert.

5 (Optional) Click Copy to Clipboard to save the alert information to your
workstation clipboard.

6 Click OK.

If you copied the alert information to your workstation clipboard, then you can
use this information in an email, for example.
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Related Links
System Alerts Overview Page
Managing System Alerts
Delete a System Alert

Delete a System Alert
You can delete a single alert or multiple alerts that are generated by the Oracle FS
System. However, before deleting the alert, ensure that you first address the
source of the alert.

1 Navigate to System > Alerts and Events > System Alerts.

2 Select one or more alerts from the list.

3 Select Actions > Delete.

4 Click OK.

Related Links
System Alerts Overview Page
Display the System Alerts
Manage the System Alerts

Clearing Pinned Data
Pinned data can occur when issues arise regarding the Drive Enclosure storage
array. In such a case, data that is to be written to that array remains in the flash‑
backed memory of the Controller.

Each LUN maintains a sequential record of committed transactions (a set of
modified blocks) that are guaranteed to be written to the underlying drive group
storage. The Oracle FS System maintains one cache for each LUN. In the
background, the system asynchronously flushes each cache to permanent
storage. These records are managed within what are called write cache.

The system maintains two copies of the cache in flash‑backed memory. The
primary copy exists on the same Controller node on which the LUN resides. The
secondary copy (a mirror) exists in the flash‑backed memory in the partner node
to allow recovery in the event of a failure of the home Controller.

Pinned data is modified data that the system cannot flush from memory to
physical storage due to a system failure or a power failure. The Oracle FS System
protects this in‑memory data until the system can flush the data to physical
storage. To resolve any pinned data, you can perform the following actions:

• Fix the issue, which would then let the system flush the pinned data.

• Discard the pinned data.

An administrator‑initiated shutdown request fails if any user data is still cached
and has not yet been written to physical storage. Pinned data causes the
shutdown to fail. If the Controllers cannot communicate with the Drive
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Enclosures to flush the cached data, the Oracle FS System retains, or pins, the
data in cache.

If you receive a system alert about pinned data when you initiate a shutdown
request, navigate to System > Hardware > Drive Enclosures to review the details
about the Drive Enclosures. Resolve any hardware issues that might exist.
Hardware issues can prevent communication between Controllers and Drive
Enclosures and can prevent the system from flushing the cached data to storage.

Related Links
Controller Management
Drive Enclosure Overview
Managing System Alerts
Display the System Alerts

Managing Event Logs
Event logs display the events of the Oracle FS System. Events include
management actions such as the creation or deletion of LUNs and any problems
encountered by the Oracle FS System, such as hardware issues or other problems
detected in the Controller or Oracle FS System Manager (GUI). You can set filters
for severity and category types.

When you encounter an issue that you cannot resolve, you can bundle a
collection of the logs and send the bundle to your Call‑Home server. From there,
Oracle Customer Support can analyze the logs to help you resolve the issue.

Possible event severities:

Informational Requires no action for events that are information only.

Warning Requires no immediate action for minor conditions that you
can address at your convenience.

Critical Requires prompt action to prevent system failures or offline
conditions.

Possible event categories:

Security Events to notify of a security problem, such as an
unauthorized request.

Audit Events that track what users are doing, such as the
operations that they performed.

System Events to notify of system problems, such as a missing
Drive Enclosure or Controller.
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Related Links
Create a Log Bundle
View a Summary of the System Status
Display the Event Log Entries
Delete the Event Logs

Display the Event Log Entries
Review the event log to monitor events that have occurred in the Oracle FS
System. If too many events display on the screen, you can filter the list of events.

1 Navigate to System > Alerts and Events > Event Log.

2 Review the event log details to ensure that the information is what you
expect.

3 (Optional) Click the Events per page list to select the maximum number of
events to display on each page.

4 (Optional) Click the page number on the upper right side of the page to
navigate quickly to a desired page.

5 (Optional) Select Actions > Set Event Log Filter to specify the types of
events to display in the list.

6 (Optional) Click the Refresh icon ( ) on the upper right side of the page to
update the list.

Related Links
Event Log Overview Page
Set Event Log Filter Dialog
Managing Event Logs
Display the Event Log Entries
Delete the Event Logs

Display the Event Properties
You can review the event properties from the Oracle FS System and copy the
properties to the clipboard. Copying the event properties permits you to capture
the event details and send them to Oracle Customer Support, for example.

1 Navigate to System > Alerts and Events > Event Log.

2 Select an event from the list.

3 Select Actions > Event Properties.

Tip: You can also double‑click the event.

4 (Optional) To copy the event properties to the clipboard, click Copy to
Clipboard.

5 Click Close.
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You can now paste the contents of the event property information in an email
and send the information to Oracle Customer Support, if requested.

Related Links
Events Properties Dialog
Display the Event Log Entries
Delete the Event Logs
Filter Event Log Entries

Filter Event Log Entries
You might want to view only certain types of entries in the event log. Filter the
events to limit the type of events that appear.

1 Navigate to System > Alerts and Events > Event Log.
2 Select Actions > Set Event Log Filter.
3 Set the filter type.

Valid types:

• Event Categories: Select all that apply.

• Event Severities: Select all that apply.

• Event Date Range: Select the Display Events that occur in a date
range option, and then select the Beginning date and Ending date.

4 (Optional) To reset the dialog to its default state, click Reset to Defaults.
5 Click OK.
6 (Optional) Click the Refresh icon ( ) on the upper right side of the page to

update the list.

The Event Log overview page displays the (filtered) label at the top of the list,
indicating that the events match your filtered criteria.

Related Links
Set Event Log Filter Dialog
Managing Event Logs
Display the Event Log Entries
Delete the Event Logs

Delete the Event Logs
If the number of events becomes too large, you can remove all of the events in
one operation.

Prerequisite: Logged in to Oracle FS System Manager (GUI) using the
Oracle Support role or the Support role.

Important: Deleting the event logs removes all of the logs from the system,
including logs that are not shown because a filter is in effect.
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1 Navigate to System > Alerts and Events > Event Log.

2 Select Actions > Delete Event Logs.

3 Click OK.

Related Links
Event Log Overview Page
Managing Event Logs
Display the Event Log Entries
Display the Event Properties

Managing Event Notifications
Create event notifications so that certain individuals can be notified when
specific Oracle FS System events occur. You can display the details of an event
and make changes as needed. You can also test notifications to make sure that the
specified email addresses are correct.

Event notifications are Simple Mail Transfer Protocol (SMTP) email messages
that notify recipients of specified system events. System events include
informational events, warning events, and critical events such as the creation of a
logical volume or the occurrence of a hardware problem or software problem.
Event notifications are optional and, when enabled, supplement normal event
logging and Call‑Home notification.

You must designate one or more email recipients to receive event notifications.
You must have a configured and functioning email server to send the
notifications.

Note: The email server is also used to notify recipients of any Call‑Home
notifications.

Related Links
System Notifications
Display Event Notifications
Create an Event Notification
Delete an Event Notification

Display Event Notifications
You can view a list of existing event notifications and determine if any changes
are needed. Use the Event Notification overview page to create, modify, delete,
or view the event notifications.

1 Navigate to System > Alerts and Events > Event Notification.

2 Review the event notification details to ensure that the information is what
you expect.
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Related Links
Event Notification Overview Page
Managing Event Notifications
Display the Event Notification Details
Create an Event Notification
Modify an Event Notification
Delete an Event Notification

Create an Event Notification
Create event notifications so that the system can generate email when specific
events occur in the Oracle FS System. You can specify the types of system events
that trigger alerts, as well as designate the recipients who receive the notices.

If you do not set up notices, you can still monitor system events using the event
log. Call‑Home notifications are independent of email notifications and will be
sent to Oracle Customer Support about issues in the Oracle FS System.

1 Navigate to System > Alerts and Events > Event Notification.

2 Select Actions > Create.

3 Enter a name for the event notification.

4 Enter a description for the event notification.

5 To enable the notification, select Enable Event Notification.

6 Review the list of events.

Tip: To sort the list by severity, click By severity, then category. To sort the
list by category, click By category, then severity.

Tip: To expand or collapse the list of events, click the expand ( ) or collapse
( ) symbols.

7 From the Monitored Events list, select the events that you want to trigger
the notification.

8 To add one or more event notification recipients, click Add.

For example, to be notified of any login failures, in the Events Not
Monitored column navigate to the Informational > Audit list. Select Login
Failed, and then click the right-facing arrow to move the item to the
Monitored Events column.

Tip: To add an entire event type, select the severity or category name and
move that event type to the Monitored Events column.

For example, to monitor all Critical events, select Critical and move the
event type to the Monitored Events column.

9 Enter the email address of each notification recipient.

10 (Optional) Click Test Email to make sure that the alert is sent to the correct
email addresses and that the SMTP server is properly configured.
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Note: Allow at least 10 minutes between email tests.

11 (Optional) To remove an email address from the list, select the address and
click Remove.

12 Click OK.

Related Links
Create Event Notification Dialog
Configure Email Notification Settings
Managing Event Notifications
Display the Event Notification Details
Modify an Event Notification
Delete an Event Notification

Display the Event Notification Details
You can view the details of an event notification and determine if any changes
are needed.

1 Navigate to System > Alerts and Events > Event Notification.

2 Select the name of the event notification you want to view.

3 Select Actions > View.

4 Review the event notification details to ensure that the information is what
you expect.

5 Click Close.

If any changes to an event notification are needed, you can modify the
notification entry.

Related Links
View Event Notification Dialog
Managing Event Notifications
Display the Event Notification Details
Modify an Event Notification
Delete an Event Notification

Modify an Event Notification
You can modify the properties of an event notification. For example, for a given
notification, you can change the events that are monitored or the email address to
which the notification is sent.

1 Navigate to System > Alerts and Events > Event Notification.

2 Select the name of the event notification that you want to modify.

3 Select Actions > Modify.

4 (Optional) Enter a new name for the event notification.
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5 (Optional) Enter a new description for the event notification.

6 (Optional) Update the Event Notification Recipient Email Addresses list.
Possible choices:

• To add an email recipient, click Add.

• To remove an email recipient, click Remove.

7 (Optional) Select new event categories or severities to monitor.

8 Click OK.

Related Links
Modify Event Notification Dialog
Configure Email Notification Settings
Managing Event Notifications
Create an Event Notification
Delete an Event Notification

Delete an Event Notification
You can delete an existing event notification. For example, you might want to
delete an event notification if someone leaves the company and you no longer
want event notifications to be sent to an inactive email account.

1 Navigate to System > Alerts and Events > Event Notification.

2 Select the event notification that you want to delete.

3 Select Actions > Delete.

4 Click OK.

Related Links
Event Notification Overview Page
Managing Event Notifications
Display Event Notifications
Create an Event Notification
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CHAPTER 11

Perform Diagnostic Operations

Oracle FS System Diagnostics
Someone from the Oracle Customer Support might request that you run one or
more of the support tools and send the diagnostic output to Oracle.

The Oracle FS System is fault tolerant. The system detects anomalies and
automatically fails over to a partner component to maintain data availability. No
intervention is required, unless a technician is needed to replace a hardware
component.

Even fault‑tolerant systems with a long mean time between failure (MTBF) rate
cannot avoid component failure forever. If a component failure results in system
instability, support tools are available to diagnose and to fix the issue.

To support the Oracle FS System, you can perform any of the following actions:

• Collect system information and download the system log bundle from the
Pilot to a local host or send the bundle to the Call‑Home server

• Diagnose Controller hardware and software issues

• Run Controller commands

• Access the Drive Enclosure console to check and diagnose drive groups

• Shut down and restart the Oracle FS System

• Set halt points that pause the system startup process

• Reset the system to its factory configuration

Related Links
Create a Log Bundle
Run Controller Diagnostics
Run Controller Command
View the Drive Enclosure Console
Shut Down the Oracle FS System
Restart the Oracle FS System
Manage System Halt Points
Reset the Oracle FS System
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System Log Bundles
To help diagnose a situation that might exist, Oracle Customer Support might
request that you collect into a single bundle certain logs and other diagnostic
information. Then you can send the bundle to My Oracle Support (MOS) for
analysis.

System information can be collected from the following sources and placed into
the system log bundle:

• Pilot hardware component

• Controller hardware components

• Drive Enclosure hardware components

• Hosts

• Statistics

• Replication appliances

• System configuration

When you create a system log bundle, you can indicate the extent of information
coverage for each of the above selected sources. You can specify that all logs are
to be included, or just the more recent logs. For the recent logs, you can specify
the number of hours back in time for which information is to be collected.

You can also include in the log bundle the statistics and the existing
configuration of the Oracle FS System. All log bundles contain the time and date
at which the bundle was collected.

If you have an open service request (SR) and know the SR number, you can use
that number in the log notes and send the bundle to the Call‑Home server. The
SR number must be the first entry in the Notes field, followed by any other notes
for that bundle. The log bundles that you send to Call‑Home will then be
associated with that SR number with Oracle Customer Support.

You can send the log bundle directly to the Oracle server, or you can download
the bundle and then attach that bundle to an existing SR in MOS. In either case,
the logs are transferred securely using encryption.

Note: Downloaded log bundles cannot be sent directly to the Oracle server.

Related Links
Create a Log Bundle
Send Logs to the Call-Home Server

View UI Client Logs
You can display a folder of client logs that contain a history of the Oracle FS
System Manager (GUI) activities that have been performed on the Oracle FS
System.

1 Navigate to Support > System Logs.

Perform Diagnostic Operations

231



2 Select Actions > View UI Client Logs.

Tip: You can use Alt-Ctrl-L to view all of the logs and Alt-Ctrl-Z to create a
zip archive containing all of the logs.

Depending on your operating system, one of the following actions occurs:

• Windows: The system opens Windows Explorer and displays the
location of the client logs.

• Linux: The system changes the directory to the location of the client
logs.

Use a text editor or reader to view the contents of any of the client logs.

Related Links
System Logs Overview Page
System Log Bundles

Create a Log Bundle
Oracle Customer Support might request that you create a log bundle and send
the bundle to Oracle for analysis. You can specify that the log bundle be
associated with an existing service request (SR).

1 Navigate to Support > System Logs.

2 Select Actions > Create.
The Create Log Bundle dialog is displayed with all of the components
selected for data collection.

3 Click Select All.

Note: Oracle Customer Support might request that you select specific
components.

4 (Optional) To send the log files to the Oracle server, select the Send to
Call‑Home server option.

5 (Optional) To specify a collection period of the last hours or last days,
select Most Recent Logs.

6 (Optional) Enter the desired value, and then select the units in Hours or
Days.

7 (Optional) To select a collection period from the last log collection to the
present, select All Logs Since Last Log Collection.

8 (Optional) To collect logs from the SAN hosts that are running Oracle FS
Path Manager (FSPM), click Select Host and then select the hosts from the
list.

Note: The SAN host must have FSPM installed and the host is in a
communicating state.

When you are finished selecting the hosts, click OK.
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9 (Optional) To download the log bundle to your workstation, select the
Download to option, and then specify the file path for the log bundle.

10 (Optional) Enter a short description for the log collection in the Notes field.

For example, you can enter a service request (SR) number.

Note: If you use an SR number, it must be the first entry followed by any
other notes about the log bundle.

11 To create the log bundle, click OK.

The system begins collecting the data logs and displays the log bundle in
the System Logs overview page. If you selected the Send to Call‑Home
server option, then the log bundle is sent directly to the Oracle server.

From the System Logs overview page, you can download the log bundle to your
workstation or, if you are logged in using a Support role, you can send the log
bundle to the Oracle server.

Related Links
Create Log Bundle Dialog
Configure Call-Home for ASR
System Log Bundles
Settings for ASR (Call-Home)
Send Logs to the Call-Home Server
Download Log Bundles
Delete Log Bundles

Collect Statistics
The Oracle FS System generates performance statistics for logical volumes and
for SAN protocols. The statistics also include capacity usage and system health
information. Oracle Customer Support might request that you collect the system
performance statistics and transmit the data to Oracle for analysis.

The downloaded statistics can be reviewed using the Oracle FS System Statistics
Tool. For more information, review the Oracle Flash Storage System Statistics Tools
User’s Guide.

1 Navigate to Support > System Logs.
2 Select Actions > Create.

The Create Log Bundle dialog is displayed with all of the components
selected for data collection.

3 Click Deselect All.
4 From the Component or Item table, select the Statistics option.
5 (Optional) To specify a collection period of the last hours or last days,

select Most Recent Logs.
6 (Optional) Enter the desired value, and then select the units in Hours or

Days.
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7 (Optional) To select a collection period from the last log collection to the
present, select All Logs Since Last Log Collection.

8 (Optional) To collect logs from the SAN hosts that are running Oracle FS
Path Manager (FSPM), click Select Host and then select the hosts from the
list.

Note: The SAN host must have FSPM installed and the host is in a
communicating state.

When you are finished selecting the hosts, click OK.

9 (Optional) Enter a short description for the log collection in the Notes field.

For example, you can enter a service request (SR) number.

Note: If you use an SR number, it must be the first entry followed by any
other notes about the log bundle.

10 (Optional) To download the log bundle to your workstation, select the
Download to option, and then specify the file path for the log bundle.

11 Click OK.

To delete a log, you must be logged in with support login privileges.

Related Links
Create Log Bundle Dialog
Storage Performance Statistical Data Overview
Storage Performance Statistical Data Overview
Delete Log Bundles

Download Log Bundles
When an Oracle FS System system event occurs, the system records the incident
information in system logs. These logs are useful when troubleshooting.

A log bundle contains a number of system logs and is formatted as a TAR file,
which you can download to your workstation. Oracle Customer Support might
request that you collect the logs and send them to Oracle for analysis.

1 Navigate to Support > System Logs.

2 Select a log bundle to download from the System Logs list.

3 Select Actions > Send to > Download.

4 To select the file location on your workstation, click the browse button [...].

5 Click OK.

Send the log bundles to Oracle Customer Support, if requested.

You can also attach the log bundle to an existing service request (SR). Access the
SR in My Oracle Support (MOS) and upload the logs.
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Related Links
System Logs Overview Page
System Log Bundles
Send Logs to the Call-Home Server

Send Logs to the Call-Home Server
If a significant Oracle FS System event occurs, the system writes logs that contain
information about the incident. Support administrators and administrators with
Support role privileges can manually send the system log bundles to the Oracle
server.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Oracle Support role or the Support role.

Logs are generated by the system when a significant event occurs, or manually
created by the administrator. Oracle Customer Support might request that you
create a log bundle and send the bundle to Oracle for analysis. If you want to
automatically send the logs to the Call‑Home server, select the Send to
Call‑Home server option when you create the log bundle.

1 Navigate to Support > System Logs.

2 From the System Logs list, select a log bundle to send to the Call‑Home
server.

3 Select Actions > Send to > Call-Home Server.

4 Click OK.

If Oracle Customer Support requested the log bundle, confirm that the file was
received.

Related Links
System Logs Overview Page
Configure Call-Home for ASR
System Log Bundles
Settings for ASR (Call-Home)
Download Log Bundles

Clear the System Logs
If you are instructed by Oracle Customer Support, you can delete all of the
Controller logs and log bundles from the Oracle FS System.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Oracle Support role or the Support role.

Clearing the system logs removes log collections and Controller logs. To remove
an individual log bundle, use the Delete Log Bundles option.
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Important: Deleting the system logs permanently removes all record of the past
system behavior.

1 Navigate to Support > System Logs.

2 Select Actions > Clear Logs.

3 Select the types of logs to delete.
Valid choices:

• Controller Logs
• Log Collections

4 Click OK.

Related Links
Create Log Bundle Dialog
System Log Bundles
Delete Log Bundles

Delete Log Bundles
If you are instructed by Oracle Customer Support, you can remove some or all of
the log bundles that have been created by the system and by the administrators
of the Oracle FS System.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Oracle Support role or the Support role.

Important: Deleted log bundles cannot be recovered.

1 Navigate to Support > System Logs.

2 Select one or more of the log bundles from the System Logs list.

Tip: Use the Ctrl or Shift keys to select and deselect multiple log bundles.

3 Select Actions > Delete.

4 Click OK.

Related Links
System Log Bundles
Create a Log Bundle

Data Consistency
The data consistency test verifies the integrity of the RAID parity data, not the
integrity of user-created data.

You might want to run the data consistency test after replacing a drive in a Drive
Enclosure. Also, Oracle Customer Support might request that you run a data
consistency test for diagnostic purposes.
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Running the data consistency test impacts Oracle FS System performance. You
have two options to choose from when performing this test:

• High priority: The verification check could affect I/O performance by up to
30%. The high‑priority option yields faster results, but has a greater impact
on system performance.

• Low priority: The verification check could affect I/O performance by up to
10%. The low‑priority option is recommended if you want to check the
Drive Enclosure after replacing a drive.

Data consistency failures are typically isolated to the drive or drive group error
handling. The Oracle FS System compensates for some of the errors that are
encountered during the tests. However, if an error persists that cannot be fixed,
the system displays Fail on the Data Consistency overview page. In this case,
collect the Oracle FS System data logs and contact Oracle Customer Support.

Related Links
Data Integrity on the Drives
Verify the Data Consistency of a Drive Group

Verify the Data Consistency of a Drive Group
You can verify the integrity of the RAID parity data that is maintained by the
Oracle FS System software by running the data consistency test on a selected
drive group. The Oracle FS System writes and maintains the parity data on
various drives within a certain drive group. After replacing a drive in one of
those drive groups, you might want to confirm that the parity data is consistent
on that drive group.

1 Navigate to Support > Data Consistency.

2 Select a drive group that you want to verify.

3 Select Actions > Data Consistency.

4 From the Verify Data Consistency dialog, specify how much I/O time to
give to this operation.
Valid choices:

• High Priority
• Low Priority

For example, if you specify High Priority, this operation could impact
Drive Enclosure performance by up to 30%.

5 To start the data verification, click OK.

After data verification completes, the results appear on the Data Consistency
page. Use the refresh button ( ) to update the page, if necessary. The system
displays the date and time of the most recent integrity test results.
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Related Links
Data Consistency Overview Page
Data Consistency

Controller Diagnostics and Command Testing
Administrators can use two features of the Oracle FS System Manager (GUI) to
help characterize and isolate the source of Controller issues. These issues can be
related to Controller hardware or software, or can be related to the connections
between the Controller and the public data network.

The Controller diagnostics feature performs a suite of diagnostic tests on the
hardware components and the software modules in a Controller. The hardware
that is tested includes, for example, the motherboard, the network interface
cards, the fans, and the power supplies that are contained within the Controller.

Note: During startup, the Oracle FS System always performs diagnostics on the
Controller nodes.

The diagnostic tests on the hardware and software return detailed information to
help a support administrator to characterize and to isolate specific faults in the
system. With this information, the support administrator can more easily
determine which field replaceable unit (FRU) needs to be replaced.

Important: Close all of the applications that are using the Controller before
running diagnostics, then disconnect the Controller from the public data
network.

While the diagnostic tests are being run, the status of the Controller appears as
Failed Over. When the tests are complete, the status changes to Normal.

To run diagnostics on a Controller, the system disables the write cache in the
target Controller, moves all the resources of the Controller to its partner
Controller, and takes the target Controller offline. All of the LUNs that are
assigned to the Controller are put into Conservative mode. During the diagnostic
period, the performance of the partner Controller is diminished because all I/O is
performed directly to disk.

Related Links
Controller Management
Run Controller Diagnostics
Run Controller Command

Run Controller Diagnostics
Oracle Customer Support might request that you run diagnostics on a selected
Controller to test its hardware components. The results of these tests can help
you take the appropriate steps to ensure data integrity and to reduce downtime.
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Prerequisites • Logged in to Oracle FS System Manager (GUI) using
the Oracle Support role or the Support role.

• All of the clients that are connected to the target
Controller are idle. Alternatively, ensure that the
zoning and client configuration are set up to handle
the condition of the Controller going offline with all
data access moved to the partner Controller.

You can run hardware diagnostics in response to various conditions such as
certain hardware faults, the crossing of critical statistics thresholds, and certain
generated events. The goal of these diagnostics is to isolate the cause of that
condition. After a hardware diagnostic is invoked, it performs a particular test
and returns a Pass status or a Fail status. For a Fail status, the diagnostic test
returns detailed information about the failure.

CAUTION: Do not initiate diagnostics on a Controller that is currently serving
data. If you do, data loss could occur.

During the diagnostic period, the performance of the partner Controller is
diminished because all I/O is performed directly to disk.

1 Navigate to System > Hardware > Controllers.
2 Select Actions > Run Diagnostics.
3 Select the Controller on which you want to run diagnostics.
4 Read the warning on the Controller Diagnostics dialog box, then click

Next.
After the diagnostics is completed, the Success dialog appears.

5 To display the diagnostics test results, click Next.
6 Review the results of the diagnostics test.
7 To close the diagnostics dialog, click Finished.

Related Links
Controllers Overview Page
Controller Diagnostics and Command Testing
View Controller Diagnostics

View Controller Diagnostics
Administrators who are logged in with one of the support roles can review the
results of the latest Controller diagnostics.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Oracle Support role or the Support role.

1 Navigate to System > Hardware > Controllers.
2 Select Actions > View Diagnostics.
3 Select the Controller for which you want to view the diagnostic results.

Perform Diagnostic Operations

239



4 To display the diagnostics test results, click Next.

5 Review the results of the diagnostics test.

6 To close the diagnostics dialog, click Finished.

Related Links
Controller Diagnostics and Command Testing
Run Controller Diagnostics

Controller Commands
You can run commands on a Controller to obtain internal information about the
Controller, such as a failed component or a list of failed field replaceable units
(FRUs) or to diagnose other issues.

You can also use the Controller statistics tool that by navigating to System >
Reporting & Statistics > CPU Statistics.

Note: Use the prefix command ipmifm when entering commands in the
Controller command line.
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Table 13: Controller commands
Command Syntax Description

fmadm ipmifm fmadm faulty [‑afgiprsv]

‑a Displays all faults. By default,
the fmadm faulty command
only lists output for resources
that are currently present and
not working correctly.
If you specify the -a option, all
resource information cached by
the Fault Manager (FM) is listed,
including faults that have been
automatically corrected or when
no recovery action is needed.
The listing includes information
for resources that might no
longer be present in the system.

‑f Displays all field replaceable
units (FRUs).

‑g Groups faults that have the same
FRU, class, and fault message.

‑i Displays the persistent cache
identifier for each resource in the
Fault Manager.

‑p Pipes output and adds a page
break between each fault
message.

‑r Displays the Fault Management
Resource with their Identifier
(FMRI) and the fault
management state.

‑s Displays a single‑line summary
of each fault event.

‑v Displays the full output of the
fault.

Allows administrators and service
personnel to view and to modify the
system configuration parameters that
are maintained by the Solaris FM.

FM receives telemetry information
relating to the problems that are
detected by the system software,
diagnoses these problems, and initiates
proactive self-healing activities such as
disabling faulty components.

Example:

The following example displays a
single line fault summary and groups
the faults by FRU:
ipmifm fmadm faulty ‑ags

Related Links
Controller Management
Controller Diagnostics and Command Testing
Run Controller Diagnostics
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Run Controller Command
You might need to view information about a particular Controller. For example,
you can obtain the fault management (FM) status of a Controller. The FM status
provides details about a failed component.

1 Navigate to Support > System Trouble.

2 Select Actions > Run Controller Command.

3 Select a Controller from the list.

4 Enter the command in the Command Line field.

5 Enter any necessary variables in the Environment Variables field.
Enter the variables in the form of variablename=value, where variablename is
the environment variable and value is the text passed to the operating
system that is running in the Controller.

6 Click Execute.
The Command Output displays the results that are returned by the
command that was executed.

Related Links
Run Controller Command Dialog
Controller Diagnostics and Command Testing
Controller Commands

Drive Enclosure Console
When checking or diagnosing drive group issues, a support administrator or a
primary administrator can access the Drive Enclosure console. You can use the
console to view RAID command output from the Oracle FS System. You can also
run RAID commands to a particular Drive Enclosure and view the responses
from those commands.

WARNING: When troubleshooting, do not power‑cycle a Drive Enclosure.
Power‑cycling a Drive Enclosure impacts the primary and secondary data paths
in the Drive Enclosure and puts user data at risk.

Run the Drive Enclosure console commands under the direction of Oracle
Customer Support. The support representative will supply the support
administrator with the necessary commands to run in the console.

RAID output is generated by the Oracle FS System and written to the Drive
Enclosure console. You can copy the output and, if requested, send that output to
Oracle Customer Support.

When you use the Drive Enclosure console to access a Drive Enclosure, the
output being generated by that Drive Enclosure appears in the console.
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Figure 16: Drive Enclosure console

Note: The Drive Enclosure console can be used by only one login session at a
time. When launching the console, the support administrator has the option of
forcing other sessions to disconnect.

During a debug session, you have the option of capturing all generated output at
any time, and copying that output to the clipboard or saving the output to a file.
The name of the saved file contains the World Wide Name (WWN) of the Drive
Enclosure and a timestamp, which can help in a review of the debug session.

When a fault, a failure, or a sub-optimum condition occurs within a Drive
Enclosure, the recovery of that Drive Enclosure might require access to a number
of RAID commands that can be run from the Drive Enclosure console. The Drive
Enclosure console provides access to those commands.

CAUTION: Use Drive Enclosure console commands for recovery purposes or
diagnostic purposes only, as instructed by Oracle Customer Support. These
command are used to gather information or to clear conditions that cannot
otherwise be accomplished. To avoid data loss, do not execute Drive Enclosure
console commands without assistance from Oracle Customer Support.

Oracle Customer Support will provide you with the commands that you can run.
These commands allows you to view, test, or debug the drives in the Drive
Enclosure in some way.
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Related Links
Drive Enclosure Management
View the Drive Enclosure Console

View the Drive Enclosure Console
After you replace a drive in the Drive Enclosure, you can view the RAID output
in the Drive Enclosure console.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Administrator role, the Oracle Support role, or the Support
role.

RAID output is generated by the Oracle FS System and written to the Drive
Enclosure console. You can copy the output and, if requested, send that output to
Oracle Customer Support.

1 Navigate to System > Hardware > Drive Enclosures.

2 Select Actions > View Drive Enclosure Console.
The Drive Enclosure Console dialog appears and an informational warning
is displayed.

3 Click Next.

4 Select the Drive Enclosure that you want monitor.

5 Select the I/O Module that you want to monitor.

6 (Optional) To ensure that no other Drive Enclosure console session is
running on the Oracle FS System, select the Disconnect other users from
the Drive Enclosure console option.

7 Click Next.
Oracle FS System writes output from the Drive Enclosure to the console.

8 (Optional) To pause the display, click Scroll Lock.
To restart the display, click Scroll Lock again.

9 (Optional) Capture all of the output from the console.
Valid choices:

• Copy to Clipboard
• Save Log to File

10 To terminate the Drive Enclosure console session, click Finish.

If you selected the option Save Log to File, you might be asked to send the log
file to Oracle Customer Support, or to attach the file to a service request in My
Oracle Support (MOS).

Related Links
Drive Enclosure Console
Run the Drive Enclosure Commands
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Run the Drive Enclosure Commands
You can run RAID code commands that control the Drive Enclosure. For
example, you might need to run the commands to help in the recovery from a
drive group error or a Drive Enclosure error.

CAUTION: Use Drive Enclosure console commands for recovery purposes or
diagnostic purposes only, as instructed by Oracle Customer Support. These
command are used to gather information or to clear conditions that cannot
otherwise be accomplished. To avoid data loss, do not execute Drive Enclosure
console commands without assistance from Oracle Customer Support.

Important: The Drive Enclosure continuously writes output to the console. When
you run a Drive Enclosure command, always capture the output before and after
running the command.

Prerequisite Logged in to Oracle FS System Manager (GUI) using the
Administrator role, the Oracle Support role, or the Support
role.

1 Navigate to System > Hardware > Drive Enclosures.

2 Select Actions > View Drive Enclosure Console.
The Drive Enclosure Console dialog appears and an informational warning
is displayed.

3 Click Next.

4 Select the Drive Enclosure that you want monitor.

5 Select the I/O Module that you want to monitor.

6 (Optional) To ensure that no other Drive Enclosure console session is
running on the Oracle FS System, select the Disconnect other users from
the Drive Enclosure console option.

7 Click Next.
Oracle FS System writes output from the Drive Enclosure to the console.

8 If instructed by Oracle Customer Support, enter a Drive Enclosure
command, and then click Send.

The Oracle FS System runs the command and displays the results in the
console.

9 (Optional) Capture all of the output from the console.
Valid choices:

• Copy to Clipboard
• Save Log to File

10 To terminate the Drive Enclosure console session, click Finish.
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Related Links
Drive Enclosure Management
Drive Enclosure Console
View the Drive Enclosure Console

Shut Down the Oracle FS System
Use the shut down option to systematically shut down all of the software that is
running on the Oracle FS System. After the software is shut down, you can safely
power off the hardware.

The Oracle FS System is composed of many hardware components and software
processes that have dependencies on other components and processes. To ensure
that all dependencies are satisfied and that the Oracle FS System is shut down in
an orderly fashion, use the Shut Down option.

While the system is in a shutdown state, the Oracle FS System Manager (GUI) is
still running and accessible. The only actions that you can perform from the GUI
are to display system status, collect logs, and restart the Oracle FS System.

1 From Oracle FS System Manager (GUI), select Oracle FS > Shut Down.

The system displays the Confirm Shut Down dialog.

Important: Shutting down stops all software processes and closes the data path.
While the system is shut down, users cannot access data.

2 Read the information on the Confirm Shut Down dialog.

3 To shut down the system, click OK.

The system status icon changes to a yellow triangle with the message: Prepare for
Shutdown. The system continues to shut down all of the software processes,
however the GUI remains running. After the software is shutdown, the System
Information page displays, Shutdown.

When you are ready to restart the system, use the Oracle FS > Restart action.

If the shutdown fails, the system displays a System Alert indicating the
shutdown failure. That System Alert presents an option to force the system
shutdown.

CAUTION: Use of the force shutdown action will cause data loss.

The option to force a system shutdown should only be used when it is absolutely
necessary. For example, shut down the system when you need to power off the
facility.

Related Links
System Startup
Restart the Oracle FS System
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Restart the Oracle FS System
Restarting the Oracle FS System reinitializes all software components.
Reinitializing the software is necessary, for example, when preparing for a
disruptive software update process.

CAUTION: Data loss is possible if client I/O is active when the system restarts.

If the system is currently in an Online state, you might want to send a message to
the system users that a system restart is about to begin. Stopping all user I/O 15
minutes before you restart a running system minimizes the risk of data loss. This
time ensures that the flash backed memory is written to the storage arrays before
the restart begins. You cannot schedule a system restart.

When you restart a running system, it begins a shutdown operation, which takes
all data paths offline, writes all cached data to the storage arrays, and quiets the
software modules. The system then begins the startup process. During this phase
of the restart operation, the startup process verifies the system configuration and
attempts to bring the system online.

Note: When restarting the system after the system has been shut down, the
system initiates the startup process. This process verifies the system
configuration and attempts to bring the system online.

1 Select Oracle FS > Restart.

The system displays the restart confirmation dialog.

2 Read the information on the confirmation dialog, and then click OK.

The system starts up and, when the startup process completes, the System
Information page (System > System Information) displays Status: Normal.

If the Pilot cannot safely shut down the system to begin the restart process,
a second dialog is displayed. Read the message, then do one of the
following:

• To close the dialog so you can resolve the problem, click Cancel.
• To ignore the problem and continue with the system restart, click

Force Restart.

CAUTION: Data loss is possible. Be certain you want to force a restart
operation.

Related Links
System Startup
Shut Down the Oracle FS System

System Startup
The Oracle FS System starts up when the system is powered on, when the system
undergoes a disruptive software update, or when a system administrator
explicitly requests a restart.
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Controlled by the Pilot management software, the startup process proceeds in an
orderly way.

Note: When a system is starting up, the data paths are not available until the
Controllers have completed the startup process.

During a system startup, the management software on the Pilot obtains
heartbeats from the Controllers and verifies the configuration of the Oracle FS
System

When the Oracle FS System starts, all Controller nodes progress through two
stages. The first stage is controlled by the Controller BIOS that resides on the
Controller. The second stage is controlled by Pilot software and the
Configuration Manager (CM) software component on the Controller.

Related Links
Shut Down the Oracle FS System
Restart the Oracle FS System

System Halt Points
By enabling system halt points, you can more easily diagnose those situations in
which you cannot get a Controller to start successfully because of some hardware
or software condition.

CAUTION: Use system halt points for troubleshooting purposes only. System halt
points are used to gather information or to clear conditions that cannot otherwise
be accomplished. Never set or clear halt points without assistance from Oracle
Customer Support. Only the Primary administrator and the Support
administrator can manage system halt points.

When the Oracle FS System starts, all Controller nodes progress through two
stages. The first stage is controlled by the Controller BIOS that resides on the
Controller. The second stage is controlled by Pilot software and the
Configuration Manager (CM) software component on the Controller.

First Startup Stage
A Controller node starts by executing page code that resides in its Controller
BIOS. You can watch the Controller LEDs to monitor the progress of this stage.
(Refer to the Oracle FS1-2 Flash Storage System Installation Guide for an explanation
of these LED startup codes.)

During the first stage, the page code in the Controller BIOS performs many
actions, including the following sequence:

• First, the page code runs a set of power-on tests.

• Next, the code begins monitoring flash backed memory.
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• Then, the code initializes the private management interface (PMI) on the
Controller.

• Finally, the code passes control to pxeboot, which downloads the Controller
software from the Pilot.

If this stage succeeds, the second stage begins, in which the Controller software
components are initialized.

Second Startup Stage
In this second stage, the Pilot performs several checks on each Controller node
and, if all is well, puts the node into an Initialization state. When the initialization
of the software components finishes, the Pilot then, by sending commands in a
defined sequence, brings the Controller software components to a Normal state.

Both the Oracle FS System Manager (GUI) and the Oracle FS CLI products
identify the names of these Controller software components with a prefix of
PDS_COMP_. This prefix is followed by the initials for the component. For
example, CM identifies the Configuration Manager. Support administrators can
selectively control the execution of these software components by enabling and
disabling halt points on those software components.

If the Support administrator has previously enabled a halt point on one of these
software components, the Controller boot process is halted at the specified halt
point. The halt points are unique for each component.

When the startup process stops, the Support administrator can take various
diagnostic actions, such as dumping a log file or reading an internal table.

After completing those actions, the Support administrator can instruct the
startup process to continue. At this point, the Pilot now sends commands to each
Controller to resume the startup process from the point at which it was halted. If
there are multiple halt points, the system starts up to the next halt point

Related Links
System Startup
Manage System Halt Points
Continue System Startup

Manage System Halt Points
You can enable halt points for diagnostic purposes. Halt points pause the startup
sequence of the Oracle FS System at the specified component step, allowing you
to perform various diagnostics tasks.

CAUTION: Use system halt points for troubleshooting purposes only. System halt
points are used to gather information or to clear conditions that cannot otherwise
be accomplished. Never set or clear halt points without assistance from Oracle
Customer Support. Only the Primary administrator and the Support
administrator can manage system halt points.
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1 Navigate to Support > System Halt Points.
2 Select Actions > Manage Halt Points.

The system displays a list of available halt points. The system displays a
check mark in the Paused on Halt Point column where the startup
sequence has halted.

3 (Optional) Select the Active box for each the step where you want the
system to halt.

Note: You can enable up to eight halt points on your system.

4 (Optional) To remove all active halt points in the list, click Clear.
Clearing all active halt points enables the system, when you instruct it to
continue, to resume the startup process without any additional system
halts.

5 If you selected one or more halt points, click OK.

The selected halt points display in the System Halt Points overview page.

After the system restarts, the system pauses at the designated halt point. The
System Halt Points overview page displays a check mark in the Paused on Halt
Point column where the system has paused. You can perform diagnostic tasks
such as collecting logs, reviewing the contents of system tables, and so forth.
After you complete these tasks, you can direct the system to continue the startup
process.

Related Links
Manage Halt Points Dialog
System Halt Points
Continue System Startup

Continue System Startup
After using system halt points to stop the Oracle FS System startup sequence at a
specified component step, you can easily resume system startup.

Important: Use system halt points for troubleshooting purposes only. System halt
points are used to gather information or to clear conditions that cannot otherwise
be accomplished. Never set or clear halt points without assistance from Oracle
Customer Support. Only the Primary administrator and the Support
administrator can manage system halt points.

1 Navigate to Support > System Halt Points.
The system displays a list of selected halt points. The currently halted step
is indicated in the Paused on Halt Point column.

2 Select the halt point from the list.
3 To continue the startup sequence, select Actions > Continue.

The system continues the startup process and proceeds to the next halt
point, if any.
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4 Click OK.

5 Repeat Step 3 and Step 4 until the system has processed all of the halt
points.

Related Links
System Halt Points Overview Page
System Halt Points
Manage System Halt Points

Reset the Oracle FS System
In extremely rare circumstances, you might need to reset your system serial
number and system configuration.

Prerequisite A special system reset file that is associated with the system
serial number from Oracle Customer Support.

WARNING: Because this action deletes all user data along with the system
configuration, the system prompts you to confirm the system reset operation. Be
absolutely sure you want to reset your system, because all data in your system will
be lost.

The system reset file performs the following actions:

• Deletes all data stored on the Oracle FS System

• Resets the configuration to an initial state

1 Navigate to Support > System Trouble.

2 Select Actions > Reset System.
The Reset System dialog box is displayed.

3 Read the WARNING text and, when you are ready, click the browse button
(...) to proceed.

4 Navigate to and select the system reset file that you received from Oracle
Customer Support.

5 Click OK.

6 When prompted to confirm the deletion of all data and the system
configuration, click OK to reset your system.

The Oracle FS System restarts and the user data is no longer available. Set the
Controller service type as the system restarts. The startup process will not
continue until you set the service type. When the startup is complete, the system
is returned to an initial state.
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Related Links
Reset System Dialog
System Startup
Oracle FS System Diagnostics
Restart the Oracle FS System
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CHAPTER 12

Manage Reports

Generated Reports Overview
Generated reports provide listings of configuration details, storage and
performance information, and statistical information about your system that you
can download to your client from the Oracle FS System.

You can generate a report immediately at the Generated Reports page, or you can
schedule a report to be generated at a specified time at the Scheduled Reports
page.

You can generate the following types of reports:

SAN Hosts Provides detailed configuration information on the host
servers and configured components currently included in
your storage area network (SAN). The data includes the SAN
Host operating system, Fibre Channel Initiator, Fibre Channel
ports, load balancing settings, LUNs, and other information
describing the SAN Hosts.

Storage
Performance

Provides performance information about the LUNs on the
Oracle FS System at the time the report was generated. The
performance data includes: read operations per second, write
operations per second, and total read and write operations
per second; read MB per second, write MB per second, and
total read and write MB per second for each LUN.
Additional storage performance data, including real-time
statistics, is available for each LUN from the SAN > Statistics
and Trending > LUNs feature.

Storage Use Provides capacity information on the storage currently
available on the Oracle FS System. The data includes the total,
allocated, free, and preparing capacity for all available
storage. The data for total, allocated, free, and preparing
capacity is also presented per storage class.

Storage Use per
Volume

Provides capacity information for each logical volume on the
Oracle FS System. The data includes the allocated, maximum,
and used capacity per volume.

System
Configuration

Provides detailed information on the configuration and
current status of the Oracle FS System and all of its
components, such as serial numbers, firmware versions, ports,
and status, for the Pilot, Controllers, and Drive Enclosures.
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Note: You might want to generate and archive the System
Configuration report as the report provides a record of your
system configuration at the time the report was generated. A
record of system changes would be useful for system
planning and customer support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers, and Drive
Enclosures information included in the detailed System
Configuration report. The data includes the current status of
the components listed above and system information.

You can download reports in the following formats:

Table 14: Report download formats
Format Usage
CSV Comma‑separated values. Import into any spreadsheet or database.

Excel Import (XSL) directly into Microsoft Excel or compatible spreadsheet
applications.

HTML Display in a browser.

PDF Printer‑friendly online document.

XML XML, tagged document.

Related Links
Generate a Report
Download a Report
Delete a Report

Generate a Report
You can generate predefined reports to view statistical information about the
Oracle FS System.

An example where you can use generated reports is to generate and save a
performance report and then generate and save a storage use report. This
combination of reports provides information on trends to manage system storage
capacity upgrades.

1 From the System tab, click Reporting & Statistics  > Generated Reports.

2 Select Actions > Generate.

3 From the Type drop-down menu in the Generate Report dialog, select a
report.

4 Click OK.

When the report is complete, the Generated Reports page displays the name of
the report, the time the report was created, and the size of the report.
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To see the contents of the report, select the name of the report in the Generated
Reports Overview page and download it in your preferred format. You cannot
view the report from the Generated Reports Overview page.

Related Links
Generate Report Dialog
Download a Report
Delete a Report

Download a Report
You can download generated reports to your client workstation in a variety of
formats.

Only reports listed on the Generated Reports page can be downloaded.

Download reports to see their contents.

1 From the System tab, navigate to Reporting and Statistics  > Generated
Reports.

2 Select the name of the report you want to download on the Generated
Reports page.

3 Select Actions  > Download.
4 Choose a file format from the Format drop-down menu in the Download

Report dialog.

Valid formats:

• CSV (comma-separated values)
• Excel
• HTML
• PDF
• XML

5 Click the browse button (...) and choose the desired destination for the
report.

6 Enter a filename in the File Name field, and click Save.
The path, filename, and extension appear in the Target Download Path
field in the Download Report dialog.

7 Click OK.

The report is downloaded in the specified format to the target location.

You must have the appropriate viewer to view the downloaded report. For
example, Adobe Reader is required to view PDF reports.

Related Links
Download Report Dialog
Delete a Report
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Delete a Report
You can delete any generated report listed in the Generated Reports page.
Deleting a report removes the report from the Oracle FS System.

Delete a report to make room for additional reports, or to remove older reports
that are no longer needed.

1 From the System tab, navigate to Reporting and Statistics  > Generated
Reports.

2 Select the name of the report you want to delete.

3 Select Actions > Delete from the menu.

4 Click OK.

Scheduled Reports Overview
You can schedule a report to be generated at a time and frequency that you
specify.

You can use reporting schedules to generate different types of reports whenever
you need them. The Oracle FS System generates these scheduled reports at the
desired time and lists them on the Generated Reports page for you to download
in the format of your choice.

All schedules for generating reports are listed on the Reporting Schedules page.
You can create new reporting schedules, and view, modify, or delete existing
schedules, from the Reporting Schedules page.

You can create a reporting schedule and enable the schedule to start generating
reports immediately at the specified start time. Or, if you prefer, you can store the
schedule on the Reporting Schedules page and enable the schedule later. You can
also disable a schedule temporarily (if, for example, you want to keep it from
interfering with scheduled maintenance) and then enable the schedule again.
Deleting a schedule removes the schedule from the system, but disabling a
schedule leaves the schedule available for enabling later on.

Scheduled reports continue to be generated until you disable or delete the
reporting schedule.

Here are some examples of reports you can schedule; the frequency you schedule
these reports depends upon your storage environment:

• Storage Performance report scheduled to run weekly to provide a
performance summary over a period of time. You can archive these reports
to create a historical storage performance record.

• Storage Use report scheduled to run every four weeks to monitor free
capacity in a static environment where you are not adding or deleting
LUNs often. In a more dynamic environment where you are adding or
deleting LUNs often, you can schedule the Storage Use report to run more
frequently, such as daily or weekly.
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• Storage Performance and Storage Use reports scheduled to run at the same
time and frequency if you want to compare storage performance with
capacity.

Related Links
Create a Reporting Schedule
View a Reporting Schedule
Modify a Reporting Schedule
Delete a Reporting Schedule
Create a Reporting Schedule
View a Reporting Schedule
Modify a Reporting Schedule
Delete a Reporting Schedule

Create a Reporting Schedule
You can schedule a report to be generated at a time and frequency that you
specify.

To generate a particular report on a regular basis, create a schedule for
generating that report on the Reporting Schedules page.

1 From the System tab, navigate to Reporting and Statistics  > Reporting
Schedules.

2 Select Actions > Create.

3 Enter a name for your schedule in the Schedule Name field.
If you do not provide a name, the system uses the default name untitled.

Note: The name you enter is for your use in identifying the schedule listed
in the Reporting Schedules. For example, if you want to run a weekly
report on storage use, you enter weeklystorageuse as the schedule name
to help locate that report. When a report is generated, the system
automatically creates a name for the report. The name the system creates is
based on the report type, (for example StorageUse_1374861600286), not the
name you assigned to the report schedule. The report name is displayed in
the Generated Reports name column.

4 Select the type of report you want to generate from the Report Type menu.
Choose one of:

• SAN Hosts
• Storage Performance
• Storage Use
• Storage Use per Volume
• System Configuration
• System Configuration Summary
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5 (Optional) Select Enabled if you would like your schedule to start as soon
as the schedule is created.
If you do not enable your schedule now, you can do so at a later time by
modifying the schedule.

6 Click the expansion button to the right of Start Time to select the day and
time for your schedule to start.

7 Use the controls in the Modify Date/Time dialog to select the date and
time.

8 Select a frequency for your schedule:

• Run Once
• Hourly
• Daily
• Weekly

9 Select a recurrence value for your schedule.

If the schedule frequency is Weekly, specify to generate the report every
one, two, three, or four weeks, and on which day of the week to generate
the report. Select multiple days to generate the report on more than one
day during each week.

10 Click OK.

Your schedule is listed on the Reporting Schedules page. If you enabled the
schedule, the scheduled report is listed on the Generated Reports page when the
report is generated.

Related Links
Create Reporting Schedule Dialog
View a Reporting Schedule
Modify a Reporting Schedule
Delete a Reporting Schedule

View a Reporting Schedule
View a reporting schedule to see the name, report type, enabled status, start time,
frequency, and recurrence of the reporting schedule.

View reporting schedules from the Reporting Schedules page.

1 From the System tab, navigate to Reporting and Statistics  > Reporting
Schedules.

2 Select the name of the reporting schedule you want to view.

3 Select Actions > View.

The View Reporting Schedule dialog lists the parameters of the selected
schedule.
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Related Links
View Reporting Schedule Dialog
Modify a Reporting Schedule
Delete a Reporting Schedule

Modify a Reporting Schedule
Modify a reporting schedule to change the name, report type, enabled status,
start time, frequency, or recurrence of the reporting schedule.

1 From the System tab, navigate to Reporting and Statistics  > Generated
Reports.

2 Select Actions > Modify.

3 (Optional) Enter a new name for the reporting schedule in the Schedule
Name field.

Note: The name you enter is for your use in identifying the schedule listed
in the Reporting Schedules. For example, if you want to run a weekly
report on storage use, you enter weeklystorageuse as the schedule name
to help locate that report. When a report is generated, the system
automatically creates a name for the report. The name the system creates is
based on the report type, (for example. StorageUse_1374861600286 ), not
the name you assigned to the report schedule. The report name is
displayed in the Generated Reports name column.

4 (Optional) Select a new type of report to generate from the Report Types
menu.

5 (Optional) Click the expansion button to the right of Start Time to select a
new start date and time.

6 (Optional) Select a new frequency.

7 (Optional) Select a new Recurrence value.

If the schedule frequency is Weekly, specify to generate the report every
one, two, three, or four weeks, and on which day of the week to generate
the report. Select multiple days to generate the report on more than one
day during each week.

8 Click OK to save your modifications.

Your modified schedule is listed on the Reporting Schedules page. If you enabled
the schedule, the scheduled report is listed on the Generated Reports page when
the report is generated.

Related Links
Modify Reporting Schedule Dialog
Delete a Reporting Schedule
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Delete a Reporting Schedule
Delete a reporting schedule when you no longer need to generate a report of this
type on a regular basis.

1 From the System tab, navigate to Reporting and Statistics  > Reporting
Schedules.

2 Select the name of the reporting schedule you want to delete on the
Reporting Schedules page.

3 Select Actions > Delete.

4 Click OK in the Confirm Delete Reporting Schedule dialog.

This removes the schedule name from the Reporting Schedules page, and no
further reports are generated from this schedule. Reports that were generated
from this schedule remain on the Generated Reports page until you delete them.
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CHAPTER 13

Manage Statistics and Trending

Storage Performance Statistical Data Overview
Statistical data is collected to help compare storage management objectives with
storage performance. The statistical data is also used to supplement
troubleshooting storage performance issues.

The Oracle FS System collects statistical data that enables you to perform the
following tasks:

• Monitor system performance

• Review performance details by port, storage object, protocol, and Control
Unit

• Analyze performance details to improve overall metrics

Performance data is available for the following functions:

• Drive Group

• CPU

• SAN LUNs

• SAN Controller Protocols

Statistical data is displayed as either performance or real-time data. The data is
updated as follows:

Performance data Performance data is refreshed every two minutes. An
example of performance data is the data displayed under
SAN > Statistics and Trending > LUNs, overview page.

Real-time data Real-time data is refreshed every second. An example of real-
time data is the LUN Real Time Statistics graph.

Note: Data is refreshed automatically if the Configure Automatic Screen
Updates is set to the default value, Enable Automatic Screen Updates. If this is
disabled, you need to use the keyboard combination of Ctrl-Alt-R to manually
refresh the data. To change the settings, navigate to Tools > Configure Automatic
Screen Updates.

You can also access the following statistical data:

Historical data Historical data is available from a minimum of the previous
one hour to a period you specify in hours or days. For further
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information on collecting and analyzing historical data, refer to
the Oracle Flash Storage System Statistics Tools User’s Guide.

Predefined
report data

Statistical data is also available through predefined reports such
as Storage Performance. These reports are available under
System > Reporting & Statistics > Generated Reports.

Related Links
Effectiveness of QoS Plus

Storage Performance Statistical Data Terminology
Before reviewing performance data, review the key terminology used to describe
storage performance as these terms form the base for understanding
performance statistics.

These terms are used frequently to describe storage performance:

Input/Output
per second

Measurement of the number of input and output operations
completed per second. Input/Output per second (IOPS) is
usually shown as read, write, and total IOPS.

Latency When reading and writing data, latency is defined as the time
it takes for a read operation or write operation to complete.
Factors that contribute to latency include the amount of time to
read data and write data from a disk, and the amount of time
required to transfer the data over a storage link.

Queue Depth Queue depth, sometimes referred to as I/O queue depth, is the
number of I/O requests (pending or outstanding I/Os) waiting
to be completed.

Response Time Response time is the average time, in milliseconds, to complete
an I/O operation.

Throughput Throughput is measured as the amount of data, in megabtyes
per second, that is processed by the Oracle FS System.
Throughput is also expressed in IOPS when measuring
sequential data. Whether expressed as megabtyes per second
or as IOPS, throughput represents bandwidth.

Drive Group Statistics Overview
Access drive group statistics for real-time statistics that can be used to review
performance.

When reviewing drive group statistics, consider the following information:

• The statistics include all drives contained within the drive group.

• The media type affects latency. For example, latency is higher for HDD and
lower for SSD.

When reviewing drive group statistics, take note of the media type in the drive
group as different media types have different performance characteristics. To
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determine the media type for a drive group, navigate to System > Hardware >
Drive Groups and review the information under the Media Type column.

Note: Drive Group Statistics are only available as real-time statistics from the
Drive Group Real Time Statistics graph which is accessed from System >
Reporting & Statistics > Drive Group Statistics > Actions > Drive Group Real
Time Statistics.

The available statistics that are displayed from the Drive Group Real Time
Statistics include:

Drive
Group

Displays statistics for the selected drive group.
Valid statistics:

Read IOPS Indicates the average number of read operations
per second per drive group.

Write IOPS Indicates the average number of write operations
per second per drive group.

Total IOPS Indicates the average number of read operations
and write operations per second per drive group.

Read bytes per
second

Indicates the rate at which the system has
transferred bytes from a drive group during read
operations.

Write bytes per
second

Indicates the rate at which the system has
transferred bytes to a drive group during write
operations.

Total bytes per
second

Indicates the total number of bytes for read and
write activity per drive group.

Read latency Indicates the average time to complete a read
operation per drive group.

Write latency Indicates the average time to complete a write
operation per drive group.

Total latency Indicates the average time to complete read
operations and write operations at the frequency
the operations occurred per drive group.

Read block size Indicates the average read block size per drive
group.

Write block size Indicates the average write block size per drive
group.

Total block size Indicates the average block size per drive group.
Read queue
depth

Indicates the number of read operations waiting to
be completed for the drive group.

Write queue
depth

Indicates the number of write operations waiting
to be completed for the drive group.
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Total queue
depth

Indicates the number of read operations and write
operations waiting to be completed for the drive
group.

Related Links
Configure Drive Group Real-Time Statistics

Configure Drive Group Real-Time Statistics
You create a real-time statistics graph to display drive group statistics.

Prerequisite: • Review the list of statistics that is available for the drive
groups.

Statistics for drive groups are available in real-time and are updated every
second.

1 To access real-time statistics for a drive group, navigate to System >
Reporting and Statistics > Drive Group Statistics.

2 Select the drive group.

3 Select Actions > Drive Group Real Time Statistics.

4 Click Add Graph, select a statistic, and click OK.
If you want to display another statistic, select Add Graph, select a statistic,
and click OK. A graph for that statistic is added to the Drive Group Real
Time Statistics below the first graph.
You could also select another drive group and display a real-time statistic
graph for that drive group. With both real-time graphs displayed, you can
compare statistics between the drive groups.

5 To delete a graph, click Remove Graph

Related Links
Display Multiple Real-Time Statistics Graphs

Controller CPU Statistics Overview
Statistics are available for the selected Controller, which include percent time in
kernel and total percent time busy. These statistics are used to identify system
behaviors or variances in performance.

The two real-time statistics available are:

Percent Time in
Kernel

Percentage of CPU utilization that occurred while executing
commands at the system level. The scale is 0 to 100 percent.

Total Percent Time
Busy

Percentage of time the CPU was busy on the Controller.
The scale is 0 to 100 percent.
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The measurements are used to identify trends in Controller usage. These
statistics can be requested by Oracle Customer Support to help resolve potential
system load issues, identity system capacity issues, or identify application issues.

Related Links
Configure Controller CPU Real-Time Statistics
Display Multiple Real-Time Statistics Graphs

Configure Controller CPU Real-Time Statistics
You can display statistics, which are percent time in kernel and total percent time
busy, for a selected Controller CPU. The statistics and are used to identify
performance issues in the system.

The CPU statistics are used to identify trends in Controller CPU usage.

1 To generate statistics about a Controller CPU, navigate to System >
Reporting and Statistics > CPU Statistics.

2 Select a Controller.

3 Select Actions > Controller CPU Real Time Statistics.
When you select a real-time statistic, default statistics are automatically
graphed and displayed. You can add or remove statistics as needed.

For Controller CPU real-time statistics, the default statistics graphed and
displayed are percent time in kernel and total percent time busy.

4 Select Add Graph, then select either Percent Time in Kernel or Total
Percent Time Busy.

5 Click OK.
After you select and display one statistic, you can select the other statistic
to be displayed as a separate graph within the same panel. For example,
you could select Percent Time in Kernel and display that graph and then
choose Total Percent Time Busy and also display that graph in the same
panel. With both graphs displayed, you can view the statistics at the same
time.

6 To delete a graph, click Remove Graph.

A graph displays the data for the statistic that you selected. The displayed data is
updated every second.

Related Links
Display Multiple Real-Time Statistics Graphs
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LUN Statistics and Trending Overview
The Oracle FS System collects statistics that provide information about storage
network status and performance of the LUNs on the system.

LUN statistics are displayed in a table that is updated every two minutes, a
detailed view that is updated every two minutes, or a real time statistics graph
that is updated every second.

From the LUNs view, statistics are arranged by LUN name in the LUN statistics
table. The statistics can be sorted by column by clicking on the column header.

Related Links
Detailed LUN Statistics Descriptions
LUN Statistics Descriptions
LUN Real-Time Statistics Graphs Description
View LUN Statistics
Configure a Real-Time LUN Statistics Graph
View Detailed LUN Statistics
Display Multiple Real-Time Statistics Graphs

LUN Statistics Descriptions
LUN statistics provide an overview of all LUNs present on your Oracle FS
System.

You can review information and statistical data for each LUN. The data is
refreshed every two minutes. You can manually refresh the data by pressing
(entering) the keyboard combination of Ctrl > Alt > R.

Name Identifies the name that is assigned to a LUN for
administrative purposes.

Physical Allotted
Capacity

Identifies the capacity, in gigabytes (GB), that is reserved
for the LUN.

Priority Level Identifies the priority level assigned to the specified LUN.
Valid levels:

• Archive
• Low
• Medium
• High
• Premium

IOPS Indicates the average read and write operations per
second.

Throughput Indicates the data transfer rate in MB/s for read and write
operations.
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I/O Latency Indicates the average time, in milliseconds, to complete the
read operations or write operations.

I/O Size Indicates the average size of the read operations and write
operations.

Collection Period Displays the start and the end time at which information
was last collected from the Oracle FS System.

You can use this information to monitor the LUNs in your Oracle FS System or
compare LUN performance and capacity for planning improvements to your
system.

View LUN Statistics
You can view information and statistical data about all LUNs configured on the
Oracle FS System on the LUN Statistics and Trending Overview page.

Prerequisite: • One or more LUNs must be present on your Oracle FS
System to create a LUN real-time statistics graph.

1 Navigate to SAN > Statistics and Trending > LUNs.
All LUNs are presented in the table.

2 (Optional) Click a column heading to sort the list by the contents of that
column to view the information in a different order.

The displayed data is refreshed every two minutes.

Related Links
LUNs Overview Page

Detailed LUN Statistics Descriptions
Detailed statistics for each LUN is available from the LUNs page.

The following statistical data is refreshed every two minutes.

Name Identifies the name of the selected LUN.

Oracle FS System Performance
Specifies throughput and IOPS data divided by the CPU cycles needed to process
those I/O requests from the LUN. The difference between Oracle FS System
Performance and System Load is thatOracle FS System Performance includes
the CPU cycles needed to perform read operations or write operations.

Read Throughput Indicates the data transfer rate for read operations.

Write Throughput Indicates the data transfer rate for write operations.

Total Throughput Indicates the data transfer rate for read operations and
write operations.
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Read IOPS Indicates the average number of read operations per
second.

Write IOPS Indicates the average number of write operations per
second.

Total IOPS Indicates the total read and writes operations per second.

System Load
Specifies throughput and IOPS data if the system devoted all resources to
process those I/O requests from the LUN. The difference between System Load
and Oracle FS System Performance is that the System Load does not include the
CPU cycles needed to perform read operations or write operations.

Read Throughput Indicates what the data transfer rate for data inputs, which
are read operations, of the specified LUN would be if the
system devoted all of the CPU resources to the LUN.

Write Throughput Indicates the data transfer rate for data outputs, which are
write operations, of the specified LUN would be if the
system devoted all of the CPU resources to the LUN.

Total Throughput Indicates the average data transfer rate for data read
operations and write operations of the specified LUN
would be if the system devoted all of the CPU resources to
the LUN.

Read IOPS Indicates the average number of read operations per second
for read operations would be if the system devoted all of the
CPU resources to the LUN.

Write IOPS Indicates the average number of write operations per
second for write operations would be if the system devoted
all of the CPU resources to the LUN.

Total IOPS Indicates the combined read and write operations per
second would be if the system devoted all of the CPU
resources to the LUN.

I/O Latency
Specifies the average time to complete a read or write operation (in milliseconds)
and the average operation size (in KB).

Read Response
Time

Identifies the average time to perform a read operation in
the last sample period.

Write Response
Time

Identifies the average time to perform a write operation in
the last sample period.

Response Time Identifies the average time to perform a read or write
operation in the last sample period.
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Read Operation
Size

Identifies the average size of a read operation in the last
sample period.

Write Operation
Size

Identifies the average size of a write operation in the last
sample period.

General
Specifies the I/O activity of the cache usage.

Cache Flushes per
Second

Indicates the rate per second for which cache lines were
flushed (written) to disk in the last sample period.

Cache Hit Ratio Indicates the percentage of read operations that were
completed from the read cache, which is also called cache
hits, in the last sample period.

Read-Ahead IOPS Indicates the average read operations per second from read-
ahead fetching in the last sample period.  Read-ahead
fetching utilizes read access behavior in the sample period
to determine read-ahead IOPS.

Non-Optimized
IOPS

Indicates the total read operations and write operations per
second that passed through non‑optimized data paths in the
last sample period. Optimized paths are preferred over
 non‑optimized paths for performance. Non‑optimized
paths occur when there is no path management software
used to manage data paths, the path management software
is not configured correctly, or an optimized path is not
available.
Path management software and applications provide load
balancing and path management for improved performance

View Detailed LUN Statistics
You can view statistical information about all LUNs configured on the Oracle FS
System on the LUN Statistics and Trending Overview page.

Prerequisite: • One or more LUNs must be present on your Oracle FS
System to create a LUN real-time statistics graph.

1 Navigate to SAN > Statistics and Trending > LUNs.
All LUNs are listed in the LUN Statistics and Trending table.

2 Select a LUN from the list.

3 Navigate to Actions > View Details to view detailed information about the
selected LUN.

The displayed statistics are refreshed every two minutes.

Related Links
View LUN Statistics Detail
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LUN Real-Time Statistics Graphs Description
Real-time statistics collected from LUNs can be used to produce graphs that
include performance data. Examples of performance data include read
operations, write operations, latency, and queue depth.

The following real-time statistics are available for a LUN:

Read IOPS Indicates the average number of read operations per
second.

Write IOPS Indicates the average number of write operations per
second.

Read bytes per
second

Indicates the rate at which the system has transferred bytes
from a drive during read operations.

Write bytes per
second

Indicates the rate at which the system has transferred bytes
to a drive during write operations.

Read latency Indicates the average time to complete a read operation.
Write latency Indicates the average time to complete a write operation.
Read block size Displays the average amount of data read that are red in a

read operation.
Write block size Displays the average amount of data that are written in a

write operation.
Total block size Displays the average amount of data that are transferred in

a read or write operation.
Read queue depth Displays the number of read operations that are waiting to

be fulfilled, on average.
Write queue depth Displays the number of write operations that are awaiting

to be processed, on average.
Total bytes per
second

Displays the total bytes transmitted per second, on
average.

Total IOPS Indicates the total number of read and write operations per
second.

Total latency Indicates the average time to complete operations.
Total queue depth Displays the total number of I/O operations that are

queued for processing, on average.

Configure a Real-Time LUN Statistics Graph
LUN real-time statistics graphs provide a graphical view of the statistics
available for the LUNs on your Oracle FS System.

To display a LUN real-time statistics graph, you need to select a LUN, and then
select one or more statistics to display in the graph.

Prerequisite: • One or more LUNs must be present on your Oracle FS
System to create a LUN real-time statistics graph.
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1 Navigate to SAN > Statistics and Trending > LUNs.

2 Select a LUN.

3 Select Actions > LUN Real Time Statistics.
When you select a real-time statistic, default statistics are automatically
graphed and displayed. You can add or remove statistics as needed.

For LUN real-time statistics, the default statistics graphed and displayed
are total latency and total I/O per second.

4 Click Add Graph, select a statistic, and click OK.
If you want to display another statistic, click Add Graph, select a statistic,
and click OK. A graph for that statistic is added to the LUN Real Time
Statistics below the first graph.
You could also select another LUN, and display a real-time statistic graph
for that LUN. With both real-time graphs displayed, you could compare
statistics between the LUNs.

5 To delete a graph, click Remove Graph.

The displayed statistical data is updated every second.

Related Links
Display Multiple Real-Time Statistics Graphs

SAN Controller Protocols Statistics and Trending Overview
The Oracle FS System collects statistics that can keep you informed about the
storage network status and performance of the Controllers on the system.

SAN Controller statistics and details can be displayed for reference in static
tables or displayed dynamically in a real-time statistics graph.

Statistics are arranged by Controller name in the SAN Controller Protocol
Statistics table.

Related Links
SAN Controller Statistics Descriptions
Detailed SAN Controller Protocol Statistics Descriptions
SAN Controller Real-Time Statistics Graph Description
View SAN Controller Protocols
View Detailed SAN Controller Protocols Statistics
Configure a Real-Time Statistics Graph for a SAN Controller

SAN Controller Statistics Descriptions
SAN Controller protocol statistics provide an overview of the Controller ports on
your Oracle FS System.

You can review the status of the following:

Manage Statistics and Trending

271



Name Identifies the name of the selected Controller.

Port Type Identifies the Controller port protocol type, FC, or iSCSI.

Slot Number Identifies the Controller PCI slot assignment.
Port Number Identifies the port numbers which are 0 or 1.

Negotiated Speed Displays the transmission speed in Gbps/second for the
port. The transmission speed is negotiated between the
HBA or FC switch and the Controller.

Throughput (per
Second)

Identifies the throughput in MB/second.

Read Identifies the read throughput in MB/second.

Write Identifies the write throughput in MB/second.

I/O Latency Identifies the time in milliseconds to read or write data.
Displays the following:

Read Identifies the time to read data in
milliseconds.

Write Identifies the time to write data in
milliseconds

Combined Identifies the combined amount of time to
read and write data in milliseconds.

I/O Size Identifies the average size of the read and write operations.

Commands
Received (per
Second)

Displays the number of read and write commands received
on the Oracle FS System each second over the last sampling
period.

Channel Errors
Since Activated

Displays the cumulative number of channel errors that have
occurred since the Controller was activated.

Collection Period Identifies the start and end times at which information was
last collected from the Oracle FS System. Data is collected
for a two-minute period and the data is refreshed every two
minutes.

You can view more detailed information about Controllers by viewing details for
a selected Controller. Detailed information is available for Fibre Channel (FC) or
iSCSI Controllers, depending on the type of Controller selected.

You can use this statistical information to monitor the Controllers or to compare
Controller characteristics for planning improvements to your system.

View SAN Controller Protocols
You can view statistical information about all Controllers on the Oracle FS
System at the SAN Controller Protocols page.
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1 From the SAN tab, navigate to Statistics and Trending > SAN > Controller
Protocols.
All Controllers are listed in the SAN Controller Protocol Statistics and
Trending table.

2 Click the Name column heading to sort the list of Controllers.

Related Links
Controller Protocol Statistics Overview Page

Detailed SAN Controller Protocol Statistics Descriptions
Provides detailed statistics about Fibre Channel (FC) or iSCSI ports on a
Controller.

The detailed information includes descriptions of both FC and iSCSI ports on a
Controller. Content that is specific to either an FC or iSCSI port is noted in the
description.

Name Identifies the name of the Controller.

Slot Identifies the HBA location (slots 1, 4, and 5) on the Controller.

Port Number Identifies the HBA port numbers on the Controller.

Port Type Identifies the HBA port type.

General Information

Read Throughput Identifies the data transfer rate for data inputs (reads).

Write Throughput Identifies the data transfer rate for data outputs (writes).

Total Throughput Identifies the average combined input and output data
transfer rates (reads and writes).

Total IOPS Identifies the total number of I/O operations per second.

Performance

Max Read
Throughput

Identifies the maximum input data transfer rate (reads).

Max Write
Throughput

Identifies the maximum output data transfer rate (writes).

Max Total
Throughput

Identifies the maximum combined input and output data
transfer rate (reads and writes).
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Max Read IOPS Identifies the maximum number of input (read) I/O
operations per second.

Max Write IOPS Identifies the maximum number of output (write) I/O
operations per second.

Max Total IOPS Identifies the maximum total number of input and output
(read and write) I/O operations per second.

SCSI Task Management Operations

Abort Task Indicates the number of abort task commands processed on
the selected port.

Abort Task Set Indicates the number of abort task set commands processed
on the selected port.
A task set is a group of tasks.

Clear ACA Indicates the number of Clear ACA (Auto Contingent
Allegiance) commands processed on the selected port.

Clear Task Set Indicates the number of clear task set commands processed
on the selected port.

Logical Unit Reset Indicates the number of reset logical unit commands
processed on the selected port.

Target Reset Indicates the number of target reset commands processed
on the selected port.

I/O Latency
Specifies the average time to complete a read or write operation (in milliseconds)
and the average operation size (in KB).

Read Response
Time

Identifies the average time to perform a read operation in
the last sample period.

Write Response
Time

Identifies the average time to perform a write operation in
the last sample period.

Response Time Identifies the average time to perform a read or write
operation in the last sample period.

Read Operation
Size

Identifies the average size of a read operation in the last
sample period.

Write Operation
Size

Identifies the average size of a write operation in the last
sample period.
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FC Only

Channel Errors

Total Channel
Errors

Indicates the total number of channel errors associated with
this port.

Command
Timeout Errors

Indicates the number of command timeout errors that have
occurred on the channel associated with this port.

DMA Errors Indicates the number of Direct Memory Access (DMA)
errors that have occurred on the channel associated with
this port.

Invalid RXID
Errors

Indicates the number of invalid responder exchange
identifier (RXID) errors that have occurred on the channel
associated with this port.

Loop Init Errors Indicates the number of loop initialization errors that have
occurred on the channel associated with this port.

Overrun Errors Indicates the number of overrun errors that have occurred
on the channel associated with this port.

PCI Errors Indicates the number of Peripheral Component Interconnect
(PCI) errors that have occurred on the channel associated
with this port.

Port Unavailable
Errors

Indicates the number of port unavailable errors that have
occurred on the channel associated with this port.

Reselection
Timeout Errors

Indicates the number of reselection timeout errors that have
occurred on the channel associated with this port.

Bad Frame Errors Indicates the number of frames dropped from first‑in or
first‑out buffer that have occurred on the channel associated
with this port.

System Errors Indicates the number of system errors that have occurred on
the channel associated with this port.

Unacknowledged
Host Event Errors

Indicates the number of unacknowledged host event errors
that have occurred on the channel associated with this port.

Underrun Errors Indicates the number of underrun errors that have occurred
on the channel associated with this port.

Transfer Errors Indicates the number of data transfer errors that have
occurred on the channel associated with this port.
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iSCSI Only

iSCSI Port Errors

Underrun Errors Indicates the number of underrun errors during the
collection period.

Overrun Errors Indicates the number of overrun errors during the collection
period.

Command
Timeout Errors

Indicates the number of command timeout errors during
the collection period.

DMA Errors Indicates the number of Direct Memory Access (DMA)
errors during the collection period.

Transport Errors Indicates the number of transport errors during the
collection period.

Device
Unavailable Errors

Indicates the number of device unavailable errors during
the collection period.

Data Digest Errors Indicates the number of data digest errors during the
collection period.

Header Digest
Errors

Indicates the number of header digest errors during the
collection period.

Invalid Snack
Errors

Indicates the number of invalid SNACK (selective negative
acknowledgment) errors during the collection period.

Unsolicited Data
Errors

Indicates the number of unsolicited data errors, which are
SCSI writes which include data but immediate data is
disabled because the total data string would exceed the
burst length, during the collection period.

Unexpected Data
SN Errors

Indicates the number of unexpected data storage network
(SN) errors caused from data sequence number in the
Protocl Data Unit (PDU) during the collection period.

Initiator Task Tag
Errors

Indicates the number of initiator task tag errors during the
collection period.

System Errors Indicates the number of system errors during the collection
period.

MAC CRC Errors Indicates the number of Media Access Control Cyclic
Redundancy Check (MAC CRC) errors during the collection
period.

MAC Encoding
Errors

Indicates the number of MAC encoding errors during the
collection period.
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iSNS Errors Indicates the number of Internet storage name service
(iSNS) errors during the collection period.

Command PDUs
Rejected

Indicates the number of command Protocol Data Unit
(PDUs) rejected during the collection period.

Connection
Failures

Indicates the number of connection failures during the
collection period.

Session Login
Failures

Indicates the number of session login failures during the
collection period.

FW Dump Errors Indicates the number of firmware (FW) dump errors during
the collection period.

iSCSI Port Requests

Reinitialize
Requests

Indicates the number of re-initialization requests during the
collection period.

Target Cold Reset
Requests

Indicates the number of cold target reset requests during
the collection period. A target cold reset cancels all pending
operations.

Task Reassign
Requests

Indicates the number of task reassign requests during the
collection period. A task reassign creates a new allegiance
connection for the task.

ISNS Messages Indicates the number of Internet Storage Name Service
(iSNS) messages during the collection period.

iSCSI Port Events

Link Up Events Indicates the number of link up events during the collection
period.

Link Down Events Indicates the number of link down events during the
collection period.

IP Address
Change Events

Indicates the number of IP address change events during
the collection period.

Duplicate IP
Address Events

Indicates the number of duplicate IP address events during
the collection period.

View Detailed SAN Controller Protocols Statistics
You can view statistical information about all Controllers configured on the
Oracle FS System on the SAN Controller Protocols page.
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1 From the SAN tab, navigate to Statistics and Trending > SAN > Controller
Protocols.
All Controllers are listed in the SAN Controller Protocol Statistics and
Trending table.

2 Click the Name column heading to sort the list of Controllers.

3 Select a Controller from the list.

4 To view detailed information about the selected Controller, select
Actions > View Details.

Related Links
View Details Dialog (Fibre Channel)
View Details Dialog (iSCSI)

SAN Controller Real-Time Statistics Graph Description
You can create charts of statistics collected from the Controller ports in your
Oracle FS System to show trends in the data.

Statistics collected from Controller ports that can be used to produce trending
charts include:

• The total amounts and rates of data read and written through a specified
Controller port

• Statistics specific to the Fibre Channel (FC) or iSCSI protocol

The statistics that can be displayed include IOPS and bytes read and written:

Read IOPS Indicates the number of read I/O operations per second.
Write IOPS Indicates the number of write I/O operations per second.
Total IOPS Indicates the total number of read and write IOPS.
Read bytes per
second

Indicates the rate at which the system has transferred
bytes from a drive during read operations.

Write bytes per
second

Indicates the rate at which the system has transferred
bytes to a drive during write operations.

Total bytes per
second

Displays the total number of bytes for read and write
operations.

Configure a Real-Time Statistics Graph for a SAN Controller
A real-time statistics graph for a SAN Controller provides a graphical view of the
statistics available for the Controllers on your Oracle FS System.

Prerequisite: • One or more Controllers must be accessible on your
Oracle FS System to create a real-time statistics graph.

1 Navigate toSAN > Statistics and Trending > Controller Protocol.

2 Select a Controller.
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3 Select either Actions > FC Port Real Time Statistics or iSCSI Port Real
Time Statistics
When you select a real-time statistic, default statistics are automatically
graphed and displayed. You can add or remove statistics as needed.

For FC port real-time statistics, the default statistic graphed and displayed
is total I/O per second.

For iSCSI port real-time statistics, the default statistic graphed and
displayed is total I/O per second.

4 Click Add Graph, select a statistic, and click OK to display the graph. If
you want to display another statistic, click Add Graph, select a statistic,
and click OK.
A graph for that statistic is added to the FC Port Real Time Statistics or
iSCSI Port Real Time Statistics below the first graph.

The displayed statistical data is updated every second.

Related Links
Display Multiple Real-Time Statistics Graphs

Example to Determine Performance During Peak Usage
The following example describes a process to measure Oracle FS System
performance to determine if performance objectives are met in peak usage
periods.

In this example, the administrator wants to determine if performance objectives
are met during a peak usage period by reviewing latency and IOPS on key
LUNs. The administrator needs to:

• measure system performance in real-time during a peak period when user
activity is high.

• validate the performance of key LUNs used during the peak period.

The administrator needs to collect the following data in real-time:

• Latency on the selected LUNs that are most active during the peak period

• IOPS on the selected LUNs that are most active during the peak period

• Percentage CPU is busy on the Controller

• IOPS on the Fibre Channel ports

• Latency on all drive groups

Determine Performance During Peak Time
These are suggested steps to determine Oracle FS System performance using the
Oracle FS System Manager (GUI) during a peak usage period to capture
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statistics. The statistics are used to determine the overall health of the system and
of specific LUNs.

Prerequisite: • Knowledge of LUNs and drive groups including host-to-
LUN mapping.

1 To determine latency for a selected LUN, navigate to SAN > Statistics and
Trending > LUNs and select the LUN. You can choose one of these
methods to view the data:

1 You can view the I/O latency data from the LUNs Overview page.

2 For additional I/O latency data from the LUNs Overview page, select
a LUN and then select Actions > View Details for more information.

3 If you want to view the I/O latency in a real-time graph, select
Actions > LUN Real Time Statistics. From the LUN Real Time
Statistics, click Add Graph, select Total Latency, and click OK.

2 To determine the IOPS for a selected LUN, navigate to SAN > Statistics
and Trending > LUNs and select the LUN.

1 You can view the IOPS data from the LUNs page.

2 You can select Actions > View Details to display more details.

3 If you want to view the IOPS in a real time graph, select Actions >
LUN Real Time Statistics From the LUN Real Time Statistics, click
Add Graph, select Total IO Per Second, and click OK.

3 To determine the percentage the CPU is busy on the Controller, navigate to
System > Reporting and Statistics > CPU Statistics.

1 Select the Controller.

2 Select Actions > Controller CPU Real Time Statistics.

3 Click Add Graph and select Total Percent Time Busy.

4 Click OK.

4 To determine the IOPS for FC ports, navigate to SAN > Statistics and
Trending > Controller Protocols and select the Controller.

1 Select Actions > View Details to display IOPS data.

2 If you want to view the IOPS in a real time graph, select Actions >
FC Port Real Time Statistics.

3 From the FC Port Real Time Statistics, click Add Graph, select Total
IO Per Second, and click OK.

5 To determine the latency of a drive group, navigate to System > Reporting
and Statistics > Drive Group Statistics.

1 Select the Controller.

2 Select Actions > Drive Group Real Time Statistics.
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3 Click Add Graph, select Total Latency.

4 Click OK.

By checking latency and IOPS on the key LUNs, you can determine if
performance meets performance objectives. If these values appear to be
problematic, the other values already charted provide you with information on
where to begin to identify the cause. The FC port information can provide insight
into FC throughput. Latencies on LUNs or drive groups should not exceed a
limit established by the administrator’s guidelines. Based on experience, you can
identify LUN values that are high or low.

Related Links
CPU Statistics Overview Page
Drive Group Statistics Overview Page
View Details Dialog (Fibre Channel)
View Details Dialog (iSCSI)
View LUN Statistics Detail
Display Multiple Real-Time Statistics Graphs

Example to Determine the Effect of Adding an Application
This is an example of how to measure Oracle FS System performance to
determine if adding an application to the system impacts application
performance of other applications.

Before adding an application and after adding an application to a new LUN or
existing LUNs, performance data, specifically latency and IOPS, is collected. The
data is collected to create a baseline to determine if adding an application
impacts performance or causes contention with other applications.

By checking latency and IOPS on existing LUNs, you can determine if data
performance is acceptable on the LUNs after adding an application to a new
LUN or existing LUNs. If the data performance is not acceptable, you might need
to install the application on another LUN or you might need to move the LUN to
another Storage Domain.

Determine if Adding an Application Impacts Performance
These steps provide an example of how to measure Oracle FS System
performance using the Oracle FS System Manager (GUI) to determine if adding
an application impacts performance.

Prerequisites: • Name of the LUNs where the application is installed.
• Storage Domain for the application LUN or LUNs and

existing LUNs.

The process begins when you capture real-time statistics for the existing LUNs in
the Storage Domain before the application is installed and after the application is
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installed. If new a LUN or LUNs were created for the application, you would
capture real-time statistics for the LUN or LUNs after the application is installed.

Note: This example assumes that the applications on the LUNs are generating the
same amount of data before and after installation of the new application.

These steps describe the process for capturing total latency and total IOPS. You
would capture this data before you added the application and after you added
the application. If a new LUN or LUNs were added for the application, you
would capture the data for that LUN or LUNs after the application was installed.

1 To determine the Storage Domain for the LUNs, navigate to SAN >
Storage > LUNs. The Storage Domain is listed under the column Groups.

2 To determine latency for a LUN, navigate to SAN > Statistics and
Trending > LUNs and select the LUN.

• You can view the I/O latency data from the LUNs page.

• You can select Actions > View Details to display more details.

• If you want to view the I/O latency in a real-time graph, select
Actions > LUN Real Time Statistics.

• From LUN Real Time Statistics, click Add Graph, select Total
Latency, and click OK.

3 To determine the IOPS for a LUN, navigate to SAN > Statistics and
Trending > LUNs and select the LUN.

• You can view the IOPS data from the LUNs page.

• You can select Actions > View Details to display more details.

• If you want to view the IOPS in a real- time graph, select Actions >
LUN Real Time Statistics.

• From LUN Real Time Statistics, click Add Graph, select Total IO
Per Second, and click OK.

From the same LUN, you could first open the graph for Total Latency and
then for Total IO Per Second so that both graphs appear within the same
pane to compare statistics. You could also do this for other LUNs if you
want to compare statistics for multiple LUNs at one time.

By checking latency, and IOPS, on the LUNs, the administrator determines if the
performance changed and is acceptable after adding the application.

Related Links
View LUN Statistics Detail
Display Multiple Real-Time Statistics Graphs
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Display Multiple Real-Time Statistics Graphs
Display multiple real-time statistics graphs in one panel to view or compare
multiple statistics.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics

3 For example, choose LUN Real Time Statistics, click Add Graph, select
Read Queue Depth, and click OK.

4 After Read Queue Depth is displayed, click Add Graph, select Write
Queue Depth and click OK.

5 After Read Queue Depth is displayed, click Add Graph, select Total
Queue Depth and click OK.

Graphs for all three statistics are displayed in the same panel, and are refreshed
every second. This process applies to all real time statistics graphs.

Note: You can delete a graph by clicking Remove Graph in order to view
different statistics.

Customize the Appearance of a Real-Time Statistic Graph
You can customize the appearance of any real-time statistic graph using the
Properties function that is accessed from the graph.

Create a real-time statistics graph and then customize the labels, fonts, color, and
plot line appearance displayed in the graph using graph’s controls from the
Properties function.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
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• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics

3 Select a statistic and then click Draw Graph.
4 Click inside the graph, and then click the right mouse button to modify the

graph.
A menu is displayed with choices for modifying the graph.

5 Select Properties.
The Chart Properties dialog is displayed.

6 Select Title, Plot, or Other to change labels, fonts, color, and plot line
appearance used in the graph.

7 Click OK to save your changes.
The changes are saved during the time the graph is displayed. Once you
close the graph, the changes to the graph are discarded.

Customize the View of a Real-Time Statistics Graph
You can customize the view of a real-time statistics graph by zooming in and
zooming out to view details in the graph.

Create a real-time statistics graph and then modify the graph using controls
available with the graph.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics
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3 Click Add Graph, select a statistic, and click OK.

4 Click inside the graph, and then click the right mouse button to modify the
graph.
A menu is displayed with choices for modifying the graph.

5 Click Zoom In or Zoom Out to expand or shrink the data displayed in the
graph.
You can use the Auto Range to reset the graph.

Save a Real-Time Statistics Graph
You can save a real‑time statistics graph as a Portable Network Graphic (PNG)
file. The file you save is snapshot of the graphic displayed on your workstation
and reflects what you see; no additional data is included in the graphic.

You can copy, save, or print a real‑time statistics graph as a file when the graph is
displayed in the Real Time Statistic Graph dialog. For example, if you are
reviewing CPU Statistics, a graph for either Percent Time in Kernel or Total Time
Busy is displayed in the Controller CPU Real Time Statistics dialog. You can
copy, save, or print that graph as a PNG file.

Copied, saved, or printed graphs provide a snapshot of the statistics shown at
one point in time.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics

3 Click Add Graph, select a statistic, and click OK.

4 Click inside the graph, and then click the right mouse button to modify the
graph.
A menu is displayed with choices for modifying the graph.

5 Click Save as ... .

6 Navigate to a location on your local workstation where you want to save
the graph.

Manage Statistics and Trending

285



7 Enter a filename for the graph. For example, the statistic was percent real‑
time kernel from the Controller CPU Real Time Statistics graph. You
could use the filename, percentrealtimekernel.

8 Click OK.

The graph is saved as a PNG file with a file extension of png.

Copy a Real-Time Statistics Graph
Copy a real‑time statistics graph as a Portable Network Graphic (PNG) file to
import the file directly into another program such as word processing
application.

You can copy, save, or print a real‑time statistics graph as a file when the graph is
displayed in the Real Time Statistic Graph dialog. For example, if you are
reviewing CPU Statistics, a graph for either Percent Time in Kernel or Total Time
Busy is displayed in the Controller CPU Real Time Statistics dialog. You can
copy, save, or print that graph as a PNG file.

Copied, saved, or printed graphs provide a snapshot of the statistics shown at
one point in time.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics

3 Click Add Graph, select a statistic, and click OK.

4 Click inside the graph, and then click the right mouse button to modify the
graph.
A menu is displayed with choices for modifying the graph.

5 Click Copy and import the PNG file into the application, such as a word
processing application.

The image file of the chart is inserted into the application.
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Print a Real-Time Statistics Graph
Print real-time statistics graphs to provide a graphical snapshot of the trends
shown at one point in time in the chart.

You can copy, save, or print a real‑time statistics graph as a file when the graph is
displayed in the Real Time Statistic Graph dialog. For example, if you are
reviewing CPU Statistics, a graph for either Percent Time in Kernel or Total Time
Busy is displayed in the Controller CPU Real Time Statistics dialog. You can
copy, save, or print that graph as a PNG file.

Copied, saved, or printed graphs provide a snapshot of the statistics shown at
one point in time.

1 Choose a function where real-time statistic graphs are available:

• System > Reporting and Statistics > Drive Group Statistics
• System > Reporting and Statistics > CPU Statistics
• SAN > Statistics and Trending > LUNs
• SAN > Statistics and Trending > Controller Protocols

2 Select one of the following actions to access the real-time graph function:

• Actions > Controller CPU Real Time Statistics
• Actions > Drive Group Real Time Statistics
• Actions > LUN Real Time Statistics
• Actions > FC Port Real Time Statistics
• Actions > iSCSI Port Real Time Statistics

3 Click Add Graph, select a statistic, and click OK.

4 Click inside the graph, and then click the right mouse button to modify the
graph.
A menu is displayed with choices for modifying the graph.

5 Select Print and then follow your operating system print instructions.

The system sends a print image of the real-time statistics graphic to the printer
you selected.
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APPENDIX A

Oracle FS System Limits

Operating Limits for an Oracle FS System
The following table lists the numbers of objects that can be configured for an
Oracle FS System.

Table 15: System limits
Object Quantity range

repositories1 Maximum: 1024

Storage Domains Minimum: 1

Maximum: 64 per Oracle FS System

virtual LUNs
(VLUNs)

Maximums:2

• 8192 per Controller
• 8192 per Oracle FS System

VLUN block
snapshots, full
(copies)

Maximum: 12 full snapshots per VLUN

VLUN block
snapshots, partial
(clones)

Maximum: 1024 partial snapshots of a single source volume
active at a time

volume groups Minimum: 1

Maximum: 5000 total

volume size Minimum:

• 1 GB and 50% of maximum capacity
• Minimum growth increment: 1 GB

Maximum: System capacity

1 A repository is a VLUN and is associated with a logical volume. A repository holds metadata for
the clones of that volume. A volume has at most one repository VLUN.

2 Recommended maximums are 4096 per Controller and 4096 per system.

288



The following table lists the numbers of objects that are related to a Drive
Enclosure that can be configured for an Oracle FS System.

Table 16: Drive Enclosure configuration limits
Object Quantity range

Drive Enclosures
(DE)

Minimum: 1

Maximums:

• Per Oracle FS System: 30
• Per Storage Domain: 30
• Per SAS HBA: 10
• Per DE string: 5

drive groups Minimum: 1

Maximums:

• Per Oracle FS System: 1024
• Per Storage Domain: 1024

drives Per DE • HDDs: 24 drives of the same type (in
groups of 12)

• Performance SSDs: 13 drives of the
same type (in groups of 6, plus 1 as a
hot spare)

• Capacity SSDs: 19 drives of the same
type (in groups of 6, plus 1 as a hot
spare)

Per drive
group

• HDDs: 12
• SSDs: 6

System Limits for SAN Objects
The following table lists the numbers of SAN‑related objects that can be
configured for an Oracle FS System.
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Table 17: SAN operating limits
Object Quantity range

LUN-to-host
mappings

Maximum: 33,554,432 per Oracle FS System

SAN host
connections (active)

Maximum:

• 512 active connections per SAN CU port

• 3072 per SAN CU (with 6 ports)

• 6144 per Oracle FS System (with 12 ports)

SAN LUNs Maximum3:

• 4096 visible for any given SAN Controller

• 4096 visible across all SAN Controllers in a given system

• 4096 visible per SAN host

SAN LUN size Minimum:

• 1 GB and 50% of maximum capacity
• Minimum growth increment: 1 GB

Maximum: System capacity

The following table lists the numbers of SAN‑related objects that can be
configured for an Oracle FS Path Manager (FSPM) host. See the appropriate
Oracle FS Path Manager Installation Guide for a complete list of operating limits.

Table 18: FSPM operating limits
Object Quantity range

system connections Maximum: 8

Note: The connections can be to any combination of Oracle FS
Systems and Pillar Axiom systems.

LUN data paths Maximum: 32 to each LUN

HBA ports Maximum: 32

3 A visible (active) SAN LUN requires one virtual LUN (VLUN) for user data and one VLUN for
metadata. A clone of a SAN LUN requires one VLUN for the metadata and one VLUN for the
data repository. If the clone is active, a third VLUN is required, making a total of five VLUNs for
the SAN LUN and its clone.
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APPENDIX B

System Tab Reference Pages

Add to Storage Domain Dialog
Navigation: System > Storage Domains > Actions > Add to Storage Domain

Adds an unassigned drive group to a Storage Domain.

Before a drive group can be used, the drive group must be assigned (added) to a
Storage Domain.

Note: For the most effective rebalancing and use of system resources, include as
many drive groups as possible in a single request.

Storage Domain Specifies the assigned Storage Domain for the selected drive
groups.

Rebalance
Volume Data

Specifies that the system balances the existing volumes
across the drive groups when you add drive groups to the
Storage Domain. When enabled, the system distributes the
data of the existing volumes to all of the drive groups in the
Storage Domain. Not selecting the option retains the data
distribution across the existing drive groups in the Storage
Domain.

Drive Groups to
be Included

Displays the drive groups that are to be associated with the
Storage Domain.

Additional
Drive Groups to
Include

Displays additional drive groups that are not associated with
a Storage Domain. You can also add those drive groups to
the Storage Domain. Select the drive groups you want to
include.

Note: If there is only one drive group, this list of additional
drive groups to include is not displayed.

Related Links
Assigning Drive Groups
Add Drive Groups to a Storage Domain

Administrator Accounts Overview Page
Navigation: System > Global Settings > Administrator Accounts
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Displays the user name, ID or Fully Qualified Name (FQN), role, full name,
email address, phone number, and whether each account is enabled.

This page provides options to create, modify, delete, and view administrator
accounts.

Up to 10 active administrator sessions can be defined. Of these 10 sessions, one is
reserved for the Primary Administrator role and another one for the
Administrator 1 role.

Login Name Lists administrator login, or user names. Click a name to review
or modify the administrator account.

Role Identifies the role that is assigned to the administrator account. A
role defines which permissions are granted to the administrator.

• Primary Administrator
• Administrator 1
• Administrator 2
• Monitor
• Support
• Oracle support

Disabled Identifies whether the administrator account is disabled.

No Indicates that the account is active.
Administrators whose accounts are
enabled can log in to the Oracle FS System.

Yes Indicates that the account is inactive.
Administrators whose accounts are
disabled cannot log in.

Full Name Identifies the first and last name associated with the
administrator account.

Email
Address

Identifies the email address of the recipient. The email server to
which the Oracle FS System sends alerts must be able to receive
messages at this address. The system does not validate this
address.

Phone
Number

Identifies the phone number associated with the administrator
account. The Oracle FS System does not verify the validity of this
entry.

Related Links
Administrator Account Management

Alerts and Events Overview
Navigation: System > Alerts and Events
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Displays links for managing system alerts and events and for reviewing the
system status and the hardware details.

Status Summary Displays the overall system status allowing you, for
example, to discover the status of individual hardware
components.

System Alerts Manages the system alerts allowing you, for example, to
know when to allocate additional capacity to a volume.

Event Log Manages the event logs and the event filters.

Event Notification Manages the types of events to be monitored and the email
addresses of the notification recipients.

Related Links
System Notifications

Controllers Overview Page
Navigation: System > Hardware > Controllers

Displays the properties of the Controllers that are a part of the Oracle FS System.

Options available from this page allow you to run diagnostics, locate Controllers
on the Oracle FS System, and view Controller details.

Name Lists the names of hardware components. Click a name to
display details about that hardware component.

Comment Displays descriptive text that is associated with a
Controller. A comment can include up to 256 characters.

Service Type Lists whether the Controller

Failover Controller Identifies the Controller that is used if the other
Controller fails in the pair.

Status Displays the current status of the Controller. A status of
Normal requires no action.

Temperature Displays the temperature status of the Controller.

Chassis Displays the current status of the Controller chassis.

Motherboard Displays the current status of the Controller motherboard
assembly.

Power Supply Displays the current status of the Controller power
supply.

Fans Displays the current status of the Controller fans.

Energy Storage
Modules

Displays the current status of the Controller energy
storage modules.
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HBA Module Displays the status of installed Host Bus Adapter (HBA)
on the Controller. This includes HBAs that connect to
host servers and HBAs that connect to Drive Enclosures.

Related Links
Controller Management
View the Status of the Controllers

Controller Ports Overview Page
Navigation: System > Global Settings > Controller Ports

Lists the topology properties of the network ports for each of the Oracle FS
System Controllers. An administrator can manage the properties of a Controller
from this page.

Name Identifies the information about the Controller. The column
includes the following information:

• Controller name
• Adapter slot number
• Adapter port number

Status Identifies the HBA connection status.
Valid states:

• Normal
• Connected
• Not connected

Port Type Indicates the type of HBA.
Valid types:

• Ethernet
• Fibre Channel (FC)
• Internet SCSI (Small Computer System Interface) (iSCSI)
• Serial Attached SCSI (SAS)

Address Identifies the unique address of the Oracle FS System Controller
port on the network.

Network
Link

Negotiated Link
Speed

Indicates the port transmission speed in
Gigabits each second.

Medium Type Identifies the types of small form‑factor
pluggable (SFP) transceiver interface
devices used for data path traffic between
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the customer network switches and the
Controllers.
Valid SFP interface types:

• Copper
• Optical
• Long Wave Optical
• Short Wave Optical

Related Links
Controller Ports
View a Summary of all the Controller Ports

CPU Statistics Overview Page
Navigation: System > Reporting and Statistics > CPU Statistics

Provides access to details about statistics that are available for the
selectedController CPU. No statistics are displayed on this page; statistics are
only available by selecting ActionsCPU Statistics.

Valid choices:

Controller Identifies the selected Controller.

To generate statistics about a Controller CPU, select a Controller and then select
Actions > Controller CPU Real Time Statistics. Click Add Graph and select a
statistic (you can review the following list for details).

The two choices are:

Percent Time in
Kernel

Percentage of CPU utilization that occurred while executing
commands at the system level. The scale is 0 to 100 percent.

Total Percent Time
Busy

Percentage of time the CPU was busy on theController. The
scale is 0 to 100 percent.

Theses measurement can be used to identify trends in Controller CPU usage that
can cause performance issues. For example, if the Total Percent Time Busy for
the CPU exceeds 90%, there can be I/O bottleneck at the Controller. These
statistics are generally requested by Oracle Customer Support to help resolve
potential system load issues, identity system capacity issues, or application
issues.

Related Links
Controller CPU Statistics Overview
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Create Administrator Account Dialog
Navigation: System > Global Settings > Administrator Accounts > Actions >
Create

Creates new administrator accounts.

Login
Name

Identifies the login name assigned to the administrator account.
This field is limited to 20 characters.

Role Identifies the authorized privileges for an administrator account.
Different roles are authorized to perform different functions:

Administrator
1

The administrator role for a login account that
provides the authority to perform all
administrative tasks and all configuration tasks
except for certain tasks that are reserved for
the support roles.

Administrator
2

The administrator role for a login account that
provides the authority to perform most
administrative and configuration tasks. A login
account assigned to this role cannot, however,
perform the following tasks:

• Manage the administrator accounts and
other global system settings such as
those settings for networking, the
Controller ports, system security, and the
system time.

• Perform software upgrades or use
Guided Maintenance to replace
hardware components.

• Shut down the Oracle FS System system.

Monitor An administrator role for login accounts that
provides the authority for those accounts to
perform read‑only management tasks and to
modify their own account properties.

Support A unique login account solely for support
representatives. This login account is not
authorized to modify or delete data resources,
system alerts, or administrator accounts.

Important: Use this account only if you are
familiar with it or instructed by Oracle
Customer Support.

For the following predefined roles, you cannot assign
administrators to them and you cannot delete them:
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Primary system
administrator

A login account that has the same
privileges as the Administrator 1
role.

Primary support
administrator

A login account that has the same
privileges as the Monitor role, as well
as privileges to perform
support‑related tasks.

Full Name Identifies the first and last name associated with the administrator
account.

Email
Address

Identifies the email address associated with the administrator
account. The email username can have up to 64 characters and the
email domain can have up to 255 characters. The email server to
which the Oracle FS System sends alerts must be able to receive
messages at this address. The system does not validate this
address.

Note: An IP address cannot be entered as the email domain.

Phone
Number

Identifies the phone number associated with the administrator
account. The Oracle FS System does not verify the validity of this
entry.

Password Identifies the password of the administrator account. Enter the
password; follow the password rules displayed on the dialog.

Confirm
Password

Confirms that the password was entered correctly.

Password
Duration

Select a duration between 1 to 180 days to determine when the
password expires. Refer to your company’s policy on password
expiration to determine the duration you should set.

Disable
Account

Indicates whether the administrative account is disabled. The
Oracle FS System maintains disabled accounts but does not allow
them to log in. A disabled account can be enabled later by
modifying it. This setting takes effect immediately. If the
administrator is logged in when you disable the account, the
system logs out the administrator immediately.

Note: You cannot disable the Primary system administrator
account.

Related Links
Create an Administrator Account

Create Event Notification Dialog
Navigation: System > Alerts and Events > Event Notification > Actions > Create
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Creates event notices when specified events occur.

When an event is triggered, the Oracle FS System sends a notification to the
designated email recipients.

Name Identifies the name of the event notification.

Description Describes the event notification.

Enable Event
Notification

Indicates whether event notification is enabled. Select this
option to activate the notification when the event occurs on
the Oracle FS System.

Event
Notification
Recipient Email
Addresses

Identifies the email addresses of the recipients who are to
receive event notifications. The email server to which the
Oracle FS System sends notifications must be able to send
messages to the email addresses.

Add Allows you to add email recipients to the event notification.

Test Email Sends a message to the specified email addresses to test the
recipient email addresses. Recipients receive a message that
is titled “[Oracle‑QoS] Test email” in their email in‑boxes.

Note: Allow at least 10 minutes between email tests.

Remove Deletes the selected email address from the list.

Monitored Events
By severity,
then category

Sorts the list of events by severity with a list of event categories.
The severity categories include:

Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent system
failures or offline conditions.

By category,
then severity

Sorts the list of events by categories with a list of event severity.
The categories include:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.
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System Events to notify of system problems, such
as a missing Drive Enclosure or
Controller.

Events Not
Monitored

Provides the list of events not set to be monitored. The
Oracle FS System does not trigger a notification when an event
listed occurs. From the list, you can specify the events to be
monitored. You can sort the list by severity or category.

Monitored
Events

Provides the list of events that you specified to be monitored.
The Oracle FS System triggers a notification each time an event
that you specified occurs. The email addresses specified in the
Event Notification Recipient Email Addresses field receive the
event notifications. You can sort the list by severity or category.

Related Links
Create an Event Notification

Create Reporting Schedule Dialog
Navigation: System > Reporting and Statistics > Reporting Schedules > Actions >
Create

Creates new schedules for generating reports.

Schedule
Name

Enter a name for the schedule. The name is displayed in the
Name column on the Reporting Schedules page. If you do not
specify a name, the system uses the default name of untitled.

Note: The name you enter is for your use in identifying the
schedule listed in the Reporting Schedules.
For example, if you want to run a weekly report on storage use,
you might enter weeklystorageuse as the schedule name to help
you locate that report. When a report is generated, the system
automatically creates a name for the report, itself. The name the
system creates is based on the report type, such as
StorageUse_1374861600286 not the name you assigned to the
report schedule. The report name is displayed in the Generated
Reports name column.

Report Type SAN Hosts Provides detailed configuration information
on the host servers and configured
components currently included in your
storage area network (SAN). The data
includes the SAN Host operating system,
Fibre Channel Initiator, Fibre Channel ports,
load balancing settings, LUNs, and other
information describing the SAN Hosts.

Storage
Performance

Provides performance information about the
LUNs on the Oracle FS System at the time the
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report was generated. The performance data
includes: read operations per second, write
operations per second, and total read and
write operations per second; read MB per
second, write MB per second, and total read
and write MB per second for each LUN.
Additional storage performance data,
including real-time statistics, is available for
each LUN from the SAN > Statistics and
Trending > LUNs feature.

Storage Use Provides capacity information on the storage
currently available on the Oracle FS System.
The data includes the total, allocated, free,
and preparing capacity for all available
storage. The data for total, allocated, free, and
preparing capacity is also presented per
storage class.

Storage Use per
Volume

Provides capacity information for each logical
volume on the Oracle FS System. The data
includes the allocated, maximum, and used
capacity per volume.

System
Configuration

Provides detailed information on the
configuration and current status of the
Oracle FS System and all of its components,
such as serial numbers, firmware versions,
ports, and status, for the Pilot, Controllers,
and Drive Enclosures.

Note: You might want to generate and archive
the System Configuration report as the report
provides a record of your system
configuration at the time the report was
generated. A record of system changes would
be useful for system planning and customer
support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers,
and Drive Enclosures information included in
the detailed System Configuration report. The
data includes the current status of the
components listed above and system
information.

Enabled Specifies whether the scheduled report is active or inactive. To
make a scheduled report active, check the Enable checkbox. If
you do not want the scheduled report to be active, do not check
the Enable checkbox. The scheduled report is still listed under
Reporting Schedule but reports are not generated.

Start Time Specifies the date and time to begin generating reports.
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Schedule
Frequency

Specifies the frequency at which the schedule generates reports.
Frequencies include:

• Run Once
• Hourly
• Daily
• Weekly

Recurrence Specifies how many hours, days, or weeks to wait before
generating this scheduled report again. You can also specify a
specific day on which you want the report to be generated.

Related Links
Create a Reporting Schedule

Create SNMP Host Dialog
Navigation: System > Global Settings > SNMP > Actions > Create

Creates Simple Network Management Protocol (SNMP) trap hosts.

Name Identifies the name for the SNMP host.

Host IP Identifies the IP address or domain name of a client that
receives the Oracle FS System SNMP information.

Community
string

Identifies the community string for use when the Oracle FS
System sends an event trap to the SNMP host.

Note: When an administrator does not specify a community
string for read-only access, SNMP servers and clients
typically use public.

Receive traps Indicates that the SNMP host receives event traps sent to it.

Trap Port
Number

Identifies the SNMP host port number to use for sending an
event trap.

Severity
threshold

Identifies the severity threshold for events that the system
sends to the SNMP host by event traps.
Severity levels:

• Informational
• Warning
• Critical

Related Links
Create SNMP Hosts
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Create Storage Domain Dialog
Navigation: System > Storage Domains > Actions > Create Storage Domains

Creates and configures properties for a new Storage Domain.

Name Specifies the name of this Storage Domain. This name must be
unique within the Oracle FS System.
Storage Domain names can consist of up to 82 UTF-8 printable
characters. The name cannot include the following characters:

• / (forward slash)
• \ (backward slash)
• . (dot)
• .. (dot dot)
• tab

Background
Process
Priority

System
Chooses

(Default) Specifies that the system balances the
resources that are needed for background data
movement with the resources that are needed
to service the incoming client I/O.

Minimize
Impact

Specifies that the system restricts the amount of
system resources that are given to the
background data movement operation. This
option minimizes the impact on client I/O.
Recommended for highly‑loaded Storage
Domains.

Maximize
Speed

Specifies that the system grants resource
priority to the background data movement
operation. This option reduces the amount of
system resources that are available for client
I/O. Recommended for lightly‑loaded Storage
Domains.

Enable Tier
Reallocation

Specifies that any tiered data that resides in this Storage
Domain has data progression enabled. Individual objects might
have tier reallocation disabled. Enabling tier reallocation at the
Storage Domain level does not override any objects that have
tier reallocation disabled. The default value is enabled.

Enable Tier
Reallocation
Statistics
Collection

Collects data usage patterns for the Storage Domain internally
to analyze and determine the optimum storage classes for the
data. The default value is enabled. It is recommended you do
not change this setting unless you need to test different profiles.
Disable this setting if you are modifying your storage profile for
testing purposes and did not want to collect statistics during
the test. You do not want to collect tier reallocation statistics
during the test as this might distort future tier reallocation.
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After you complete testing, enable tier reallocation statistics
collection.

Note: Enabling or disabling the tier reallocation statistics
collection has no effect on statistics you can view for CPU, drive
groups, Filesystems, or LUNs. (Those are a different set of
statistics.)

Auto‑Tier Scan Options (Advanced)
Optimizes the auto‑tier algorithm for moving data to different Storage Classes.
You can specify the interval for when auto‑tier moves frequently accessed data
blocks and infrequently accessed data blocks to match your application activity.

Note: To unlock the auto‑tier scan options, select the lock icon. Selecting the lock
icon again resets the values to the state when the fields were unlocked.

Performance-
Optimizing
Scan Cycle

Specifies the frequency, in hours, that auto‑tier scans to move
frequently accessed data blocks to a high performance Storage
Class.
For example, a value of 32 means that every 32 hours auto‑tier
scans the system to move frequently accessed data blocks to a
high performance Storage Class.
Updates to this field affect the label of the Number of n‑hour
Scan Cycles field. For example, a value of 32 changes the label
for the Number of n‑hour Scan Cycles to Number of 32‑hour
Scan Cycles.
Enter a value from 1 through 168.

Number of
n‑hour Scan
Cycles

Specifies the frequency that auto‑tier runs the
performance‑optimizing scan cycles before auto‑tier runs the
cost‑optimizing scan cycle. The value entered in the Number
of n‑hour Scan Cycles field is multiplied by the value entered
in the Performance-Optimizing Scan Cycle field to obtain the
value set in the Cost-Optimizing Scan Cycle field.
For example, a value of 5 means that every fifth time that
auto‑tier runs the performance‑optimizing scan cycle, auto‑tier
then runs the cost‑optimizing scan cycle to move infrequently
accessed data to a less expensive storage class.
Enter a value from 2 through 31.

Cost-
Optimizing
Scan Cycle

(Read‑only) Displays the frequency, in hours, that auto‑tier
scans to move infrequently accessed data blocks to a less
expensive Storage Class.
The value displayed in this field is calculated as the product of
the value you entered in the Performance-Optimizing Scan
Cycle field and the value you entered in the Number of n-
hour Scan Cycles field.
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For example, to set auto‑tier to move infrequently accessed
data blocks to a less expensive Storage Class every 200 hours,
enter the following values:

• Performance Optimizing Scan Cycle: 25
• Number of 25‑hour Scan Cycles: 8

The system displays 200 in the Cost-Optimizing Scan Cycle
field. In this example, the values that you enter instruct
auto‑tier to run the performance‑optimizing scan every 25
hours. Then, during every eighth scan cycle (or every 200
hours), auto‑tier runs a cost‑optimizing scan to move
infrequently accessed data blocks to a less expensive Storage
Class.

Allowable Storage Capacity for Auto‑Tiered LUNs
Indicates the maximum percentage of storage capacity to dedicate to auto-tier
reallocation for each Storage Class of the Storage Domain. Enter a percentage for
each available Storage Class.

The default value is 100%.

Related Links
Create a Storage Domain

Create Storage Profile Dialog
Navigation: System > Global Settings > Storage Profiles > Actions > Create
Storage Profile

Adds a new Storage Profile with custom QoS. The Storage Profile can then be
selected when managing a logical volume.

Name Identifies the name of the Storage Profile. The name
includes, in some instances, the name of the application that
is associated with the profile.
Storage Profile names can consist of up to 128 UTF‑8
characters.

Enter Basic QoS
Settings

Opens the Enter Basic QoS Settings dialog where you can
enter the following basic QoS parameters. The system
converts the basic setting selections to the following
advanced QoS settings:

• RAID Level
• Read Ahead

Typical
Access

Identifies the most common method of
data access. Valid biases:
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Sequential Indicates that the read
requests and the write
requests operate on the
data mostly by accessing
the records one after the
other in a physical order.

Random Indicates that the read
requests and the write
requests operate on the
data mostly by accessing
the records in an arbitrary
order.

Mixed Indicates that the read
requests and the write
requests operate on the
data sometimes in
sequential order and
sometimes in random
order.

I/O Bias Identifies the typical read‑write ratio. Valid
I/O biases:

Read Indicates that most of the access
requests are for read
operations.

Write Indicates that most of the access
requests are for write
operations.

Mixed Indicates that the number of
access requests are similar for
read operations and for write
operations.

Redundancy Identifies the number of copies of the
parity bits that the Oracle FS System
creates for the volume.
Valid redundancy levels:

Single Stores the original user data
plus one set of parity bits to
help in the recovery of lost
data. Access to the data is
preserved even after the
failure of one drive. Single
parity is implemented using
RAID 5 technology and is the
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default redundancy level for
the Storage Classes that
specify the performance-type
media.

Double Stores the original user data
plus two sets of parity bits to
help in the recovery of lost
data. Access to the data is
preserved even after the
simultaneous failure of two
drives. Double parity is
implemented using RAID 6
technology and is the default
redundancy level for the
Storage Classes that specify
the capacity-type media.

RAID Level Identifies the storage mechanism that is used to enhance the
ability of the system to recover data from the loss of one or
more drives.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the loss of
one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the loss of
one or two drives with a slight cost to
write performance. Double parity is
implemented as a variant of the
RAID 6 storage technology.

Mirrored Indicates that no parity bits exist for
the volume. Instead, the system writes
the data in two different locations.
This RAID level protects against the
loss of at least one drive and possibly
more drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.
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Read Ahead Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places into
the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the data
mostly in a random manner or
in a mixed sequential and
random manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the data
mostly in a sequential manner
and that the workload is biased
toward read operations.

Conservative Indicates that the input
requests and the output
requests are mostly sequential
and that the workload is biased
toward write operations.

Priority Identifies the priority that the system gives to various
operational aspects of a logical volume, such as the
Controller processing queue. The processing‑queue priority
defines the percentage of the Controller CPU cycles that are
dedicated to the volume. Identifies as well where the data is
striped on rotating drives. Valid priority levels:

Premium Indicates the highest priority for responding to
requests in the processing queue.

High Indicates the next highest priority for
responding to requests in the processing
queue.

Medium Indicates an intermediate priority for
responding to requests in the processing
queue.

Low Indicates the next to lowest priority for
responding to requests in the processing
queue.

Archive Indicates the lowest priority for responding to
requests in the processing queue.

Advanced
Provides access to the QoS properties that might affect system performance.
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Note: This option is recommended for expert administrators who understand the
full range of QoS properties.

Writes Identifies the write‑caching rules to use for the profile.
Valid options:

Write-through Writes data to the Controller cache and to
the storage arrays before the write request
completes. This rule ensures that the data
is safely written to the storage before the
write request returns to the application.
Write‑through caching performs more
slowly than does write‑back caching
because the data is being written to the
storage arrays as well as to the cache.

Write-back caching Writes data to the Controller cache, and
the write request returns immediately
without waiting for the write‑to‑disk to
complete. During idle cycles, the system
writes the data from the cache to the
storage arrays. Write‑back caching
performs faster than does write‑through
because the data only needs to be written
to the cache before the write request
returns.

Important: If the system goes down
unexpectedly, the data in the cache that
has not been written to the storage arrays
could be lost.

During the shutdown process, the system
writes all cached data to the storage
arrays.

Default Indicates that the Oracle FS System selects
the appropriate write‑caching rule based
on the selected QoS settings.

Stripe
Width

Identifies the number of drive groups over which the data is written.
For custom Storage Profiles, you can select a stripe width from the list
of predefined values. You can also enter a value from 1 to 64.
Predefined stripe widths values:

1 Indicates a stripe width of 1 drive group.

2 Indicates a stripe width of 2 drive groups.

3 Indicates a stripe width of 3 drive groups.

4 Indicates a stripe width of 4 drive groups.
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6 Indicates a stripe width of 6 drive groups.

8 Indicates a stripe width of 8 drive groups.

64 Indicates a stripe width of 64 drive groups.

All Indicates that the logical volume is striped across all of
the available drive groups.

auto‑select Indicates that the Oracle FS System determines the stripe
width based on the Priority option that you selected.

Note: We recommend that you use the auto‑select
option.

When you choose auto‑select the system uses the
following stripe widths for the Priority that you
selected. However, the GUI displays auto‑select not the
actual stripe width that the system determines.

• Archive priority: The system uses a stripe width of
2 drive groups.

• Low priority: The system uses a stripe width of 2
drive groups.

• Medium priority: The system uses a stripe width
of 3 drive groups.

• High priority: The system uses a stripe width of 4
drive groups.

• Premium priority: The system uses a stripe width
of 4 drive groups.

Preferred Storage Classes
Allows you to specify the Storage Class media on which the logical volume
resides and the preferred order that the Oracle FS System uses the media.

Preferred
Order

Indicates the preferred order in which the Oracle FS System uses
the available Storage Classes.
For example, if you are creating a profile for archiving database
records, choose a Storage Class with large capacity as your first
choice. For profiles that manage large data volumes, select a
Storage Class that is optimized for read and write operations.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
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performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Related Links
Create a Storage Profile

Create UPS Dialog
Navigation: System > Hardware > UPSs > Actions > Create UPS

Creates and adds an uninterruptible power supply (UPS) device to the Oracle FS
System using a simple network management protocol (SNMP).

Name Identifies the name of the UPS device. UPS names must be
unique across the Oracle FS System and must be 256 or fewer
UTF‑8 characters.

IP Address Identifies the IP address that is assigned to the external UPS
device.

SNMP
Community

The UPS device sends information to the Oracle FS System
such as battery low.
Identifies a community for which a specific trap host should
receive traps that the Oracle FS System generates. You can
specify different community strings for each trap host so that
multiple administrators can receive specific types of SNMP
traps. The default community string is public (lower case). It is
recommend you change the default community string.

Note: This community string entered here must match the
community string configured on the UPS device.
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Related Links
Create a UPS Device

Dashboard Overview Page
Navigation: System > Dashboard

Displays the recent system alerts and event notifications for the Oracle FS
System. The dashboard also provides bar graphs that represents the capacity for
each Storage Class within the Storage Domains.

Recent Alerts and Events
Lists the recent system alerts and event notifications for the Oracle FS System.

Severity Displays the 10 most recent alerts and error notifications for the
Oracle FS System. The dashboard lists the system alerts first,
followed by the severe event notifications. Select an item to
display the details about the alert or event.
Possible severity levels:

Critical Requires prompt action to prevent system
failures or offline conditions.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Description Displays the information about the system alert or event
notification.

Creation Date Indicates the date and time when the system alert or event
notification occurred.

Storage Domains
Displays graphically the storage classes, and their capacities, for each Storage
Domain of the Oracle FS System.

Valid media types:

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
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the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

For each storage class, the dashboard graphically displays the Storage Domain
physical capacities. The graph uses colored bars of different thicknesses to
indicate the capacity status of each storage class. Hover the mouse pointer over
each graph to display the capacity type.

Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Possible physical storage capacities:

Free Space Displays the amount of capacity that is available for
allocation in the indicated Storage Class.

Used Capacity Displays the amount of capacity that is consumed by data
and system overhead.

Total Capacity Displays the total amount of raw capacity provided by the
drive groups that are defined within the indicated Storage
Class.

Allocated Space Displays the amount of capacity that has been assigned and
designated to all storage classes residing on the indicated
Storage Class.

Preparing
Capacity

Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Class.

Allocated to
Logical
Maximum

Displays the maximum capacity to which the Storage Class
can grow.

The dashboard provides a refresh button ( ) in the upper‑right corner of the
page that allows you update the contents of the page.
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Delete Drive Group Dialog
Navigation: System > Storage Domains > Actions > Delete Drive Group or
System > Hardware > Actions > Delete Drive Group

Removes the selected drive group.

OK Removes the selected drive group. You can only select a drive group
that is not associated with a Storage Domain. If the operation is
successful, the drive group record is removed from the list of drive
groups and data is migrated to other drive groups. If the operation is
unsuccessful, the system does not remove the drive group and displays
an appropriate error dialog:

Cancel Cancel the operation and close the dialog box.

Delete Storage Domain Dialog
Navigation: System > Storage Domains > Actions > Delete Storage Domain

Removes the selected Storage Domain.

OK Removes the selected Storage Domain. If the operation is successful,
the Storage Domain is removed from the list of Storage Domains. If the
operation is unsuccessful, the system does not remove the Storage
Domain and displays an appropriate error dialog:

• The Storage Domain contains one or more logical volumes.
• The Storage Domain has one or more drive groups that are

assigned to the Storage Domain.
• If the operation is unsuccessful, move the drive groups or logical

volumes on the Storage Domain to another Storage Domain.

Cancel Cancel the operation and close the dialog box.

Related Links
Delete a Storage Domain

Download Report Dialog
Navigation: System > Reporting and Statistics > Generated Reports > Actions >
Download

Specifies the file format to use when downloading a generated report, as well as
the location to save the file on the client.

Format Indicates the file format for the generated report.
Available formats:
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• CSV (comma-separated values)
• Excel
• HTML
• PDF
• XML

Target
Download Path

Indicates the filename and path for where to save the
downloaded file.

Related Links
Download a Report

Drive Enclosures Overview Page
Navigation: System > Hardware > Drive Enclosures

Lists the Drive Enclosures that are installed on the Oracle FS System.

Displays the current status of the hardware components. A status of Normal
requires no action.

Name Identifies the name of the Drive Enclosure including the
chassis ID, which is displayed on the front of the Drive
Enclosure.

Comment Displays the user‑defined comment that helps identify
the Drive Enclosure.

Overall Displays the summary status of the Drive Enclosure.

Temperature Displays the status of the Drive Enclosure temperature.

Chassis Displays the status of the Drive Enclosure chassis.

I/O Modules Displays the status of the I/O Modules within the Drive
Enclosure.

Power Cooling
Modules

Displays the status of the power cooling modules within
the Drive Enclosure.

Drives Displays the status of the drives within the Drive
Enclosure.

Related Links
View the Status of the Drive Enclosures

Drive Groups Overview Page
Navigation: System > Hardware > Drive Groups
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Lists the properties of each drive group that is defined on an Oracle FS System.

Drive
Group
Number

Displays the number that uniquely identifies the drive group.

Note: The primary drive group in a Storage Domain is indicated
by this icon . The primary drive group contains system
configuration information.

Drive
Group
Status

Indicates the operating condition of the drive group.
Status conditions include:

Normal The drives are accessible and no action is
required.

Degraded
Warning

A drive has failed but this is not yet critical.
This applies only to double parity.

Degraded
Critical

Two or more drives have failed. The loss of one
more drive causes a failure.

Failed Multiple drives have failed. The drives are
offline and data may be lost.

Media Type Specifies the category of physical media that comprises the drive
group.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that
are optimized for the performance of capacity
and for read operations. The write performance
for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of
capacity.
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Enclosure
Chassis ID

Displays the numeric identifier of the Drive Enclosure. The
Enclosure Chassis ID is located and displayed on the front of the
Drive Enclosure. The numeric values range from 01 to 99; the
hexadecimal values from A0 to FF.

Storage
Domain

Displays the Storage Domain to which the drive group is
assigned.

Physical Capacity
Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Allocated Displays the amount of capacity that has been assigned and
designated to all logical volumes residing on the indicated
Storage Domain.

Free Displays the amount of capacity that is available for
allocation in the indicated Storage Class.

Preparing Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Class.

Total Capacity Displays the total amount of raw capacity provided by the
drive groups that are defined within the indicated Storage
Class.

Physical
Distribution

Provides a graphical representation of the capacity that is
used compared to the maximum that is allocated

Drive Group Statistics Overview Page
Navigation: System > Reporting and Statistics > Drive Group Statistics

Provides access to details about drive group statistics including performance. No
statistics are displayed on this page; statistics are only available by selecting
ActionsDrive Group Real Time Statistics.

To generate statistics about a drive group, select a drive group, then select
Actions > Drive Group Real Time Statistics. Click Add Graph and select a
statistic (you can review the following list for details).

The available statistics that are displayed are:

Drive
Group

Displays statistics for the selected drive group.
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Valid statistics:

Read IOPS Indicates the average number of read operations
per second per drive group.

Write IOPS Indicates the average number of write operations
per second per drive group.

Total IOPS Indicates the average number of read operations
and write operations per second per drive group.

Read bytes per
second

Indicates the rate at which the system has
transferred bytes from a drive group during read
operations.

Write bytes per
second

Indicates the rate at which the system has
transferred bytes to a drive group during write
operations.

Total bytes per
second

Indicates the total number of bytes for read and
write activity per drive group.

Read latency Indicates the average time to complete a read
operation per drive group.

Write latency Indicates the average time to complete a write
operation per drive group.

Total latency Indicates the average time to complete read
operations and write operations at the frequency
the operations occurred per drive group.

Read block size Indicates the average read block size per drive
group.

Write block size Indicates the average write block size per drive
group.

Total block size Indicates the average block size per drive group.
Read queue
depth

Indicates the number of read operations waiting to
be completed for the drive group.

Write queue
depth

Indicates the number of write operations waiting
to be completed for the drive group.

Total queue
depth

Indicates the number of read operations and write
operations waiting to be completed for the drive
group.

Related Links
Drive Group Statistics Overview

Duplicate Storage Profile Dialog
Navigation: System > Global Settings > Storage Profiles > Actions > Duplicate
Storage Profile
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Copies an existing Storage Profile.

Name Identifies the name of the Storage Profile. The name includes, in
some instances, the name of the application that is associated with
the profile.
Storage Profile names can consist of up to 128 UTF‑8 characters.

Enter
Basic
QoS
Settings

Opens the Enter Basic QoS Settings dialog where you can enter the
following basic QoS parameters. The system converts the basic
setting selections to the following advanced QoS settings:

• RAID Level
• Read Ahead

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and
the write requests operate on the
data mostly by accessing the
records one after the other in a
physical order.

Random Indicates that the read requests and
the write requests operate on the
data mostly by accessing the
records in an arbitrary order.

Mixed Indicates that the read requests and
the write requests operate on the
data sometimes in sequential order
and sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O
biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access
requests are similar for read operations
and for write operations.

Redundancy Identifies the number of copies of the parity bits
that the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one
set of parity bits to help in the recovery

System Tab Reference Pages

318



of lost data. Access to the data is
preserved even after the failure of one
drive. Single parity is implemented
using RAID 5 technology and is the
default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two
sets of parity bits to help in the
recovery of lost data. Access to the data
is preserved even after the
simultaneous failure of two drives.
Double parity is implemented using
RAID 6 technology and is the default
redundancy level for the Storage
Classes that specify the capacity-type
media.

RAID
Level

Identifies the storage mechanism that is used to enhance the ability of
the system to recover data from the loss of one or more drives.
Possible RAID levels:

Single parity Indicates that, in addition to the actual data,
one set of parity bits exists for the logical
volume. This parity level protects against the
loss of one drive. Single parity is implemented
as a variant of the RAID 5 storage technology.

Double parity Indicates that, in addition to the actual data,
two sets of parity bits exist for the logical
volume. This parity level protects against the
loss of one or two drives with a slight cost to
write performance. Double parity is
implemented as a variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist for the
volume. Instead, the system writes the data in
two different locations. This RAID level
protects against the loss of at least one drive
and possibly more drives with an improvement
of the performance of random write operations.
Mirrored RAID is implemented as a variant of
the RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for sequential
read operations. The policy determines the amount of additional
data, if any, that the system places into the Controller cache. Valid
policies:
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Normal Indicates that the input requests and the
output requests are accessing the data
mostly in a random manner or in a
mixed sequential and random manner.

Aggressive Indicates that the input requests and the
output requests are accessing the data
mostly in a sequential manner and that
the workload is biased toward read
operations.

Conservative Indicates that the input requests and the
output requests are mostly sequential
and that the workload is biased toward
write operations.

Priority Identifies the priority that the system gives to various operational
aspects of a logical volume, such as the Controller processing queue.
The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume. Identifies as
well where the data is striped on rotating drives. Valid priority levels:

Premium Indicates the highest priority for responding to requests
in the processing queue.

High Indicates the next highest priority for responding to
requests in the processing queue.

Medium Indicates an intermediate priority for responding to
requests in the processing queue.

Low Indicates the next to lowest priority for responding to
requests in the processing queue.

Archive Indicates the lowest priority for responding to requests
in the processing queue.

Advanced
Provides access to the QoS properties that might affect system performance.

Note: This option is recommended for expert administrators who understand the
full range of QoS properties.

Writes Identifies the write‑caching rules to use for the profile.
Valid options:

Write-through Writes data to the Controller cache and to
the storage arrays before the write request
completes. This rule ensures that the data
is safely written to the storage before the
write request returns to the application.
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Write‑through caching performs more
slowly than does write‑back caching
because the data is being written to the
storage arrays as well as to the cache.

Write-back caching Writes data to the Controller cache, and
the write request returns immediately
without waiting for the write‑to‑disk to
complete. During idle cycles, the system
writes the data from the cache to the
storage arrays. Write‑back caching
performs faster than does write‑through
because the data only needs to be written
to the cache before the write request
returns.

Important: If the system goes down
unexpectedly, the data in the cache that
has not been written to the storage arrays
could be lost.

During the shutdown process, the system
writes all cached data to the storage
arrays.

Default Indicates that the Oracle FS System selects
the appropriate write‑caching rule based
on the selected QoS settings.

Stripe
Width

Identifies the number of drive groups over which the data is written.
For custom Storage Profiles, you can select a stripe width from the list
of predefined values. You can also enter a value from 1 to 64.
Predefined stripe widths values:

1 Indicates a stripe width of 1 drive group.

2 Indicates a stripe width of 2 drive groups.

3 Indicates a stripe width of 3 drive groups.

4 Indicates a stripe width of 4 drive groups.

6 Indicates a stripe width of 6 drive groups.

8 Indicates a stripe width of 8 drive groups.

64 Indicates a stripe width of 64 drive groups.

All Indicates that the logical volume is striped across all of
the available drive groups.

auto‑select Indicates that the Oracle FS System determines the stripe
width based on the Priority option that you selected.
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Note: We recommend that you use the auto‑select
option.

When you choose auto‑select the system uses the
following stripe widths for the Priority that you
selected. However, the GUI displays auto‑select not the
actual stripe width that the system determines.

• Archive priority: The system uses a stripe width of
2 drive groups.

• Low priority: The system uses a stripe width of 2
drive groups.

• Medium priority: The system uses a stripe width
of 3 drive groups.

• High priority: The system uses a stripe width of 4
drive groups.

• Premium priority: The system uses a stripe width
of 4 drive groups.

Preferred Storage Classes
Allows you to specify the Storage Class media on which the logical volume
resides and the preferred order that the Oracle FS System uses the media.

Preferred
Order

Indicates the preferred order in which the Oracle FS System uses
the available Storage Classes.
For example, if you are creating a profile for archiving database
records, choose a Storage Class with large capacity as your first
choice. For profiles that manage large data volumes, select a
Storage Class that is optimized for read and write operations.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
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sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Related Links
Duplicate a Storage Profile

Event Log Overview Page
Navigation: System > Alerts and Events  > Event Log

Displays the event logs that are associated with the Oracle FS System.

You can set a filter to display specific types of events if the list is too long.

Event Displays the name of the event in the Oracle FS System event
log.

Severity Displays the severity level of entries in the Oracle FS System
event log. Possible severity levels:

Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent
system failures or offline conditions.

Category Identifies the type of event. Valid values:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.

System Events to notify of system problems,
such as a missing Drive Enclosure or
Controller.

Time
Occurred

Identifies the time at which the event was sent to the
designated recipients.
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Affected Item Provides the specific object name affected by the Event Type.
For example, if the Event reads Drive Enclosure Firmware
Invalid, then the Affected Item column lists the Drive
Enclosure name that caused the event to occur. Such details
provide more information for troubleshooting purposes.

User Identifies the name of the user logged in at the time the event
occurred.

Description Displays the event description text.

Related Links
Display the Event Log Entries

Event Notification Overview Page
Navigation: System > Alerts and Events > Event Notification

Displays the list of event notifications created for the Oracle FS System.

This page provides options to manage event notifications.

Name Lists the name of event notification. Click a name to review,
modify, or delete the notification settings.

Enabled Indicates whether the event notification is enabled.

• Checked: The event notification is actively collecting
event information.

• Unchecked: The event notification is inactive and not
collecting event information.

Time Last Sent Identifies the time at which the event was sent to the
designated recipients.

Number of Events Indicates the number of events collected by the notification.

Number of
Recipients

Indicates the number of email recipients subscribed to the
event notification.

Description Displays the description of the event notification.

Related Links
Display Event Notifications

Events Properties Dialog
Navigation: System > Alerts and Events > Event Log > Actions > Event Properties
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Views detailed information for a selected event.

Copy to
Clipboard

Copies the contents of the event properties to your clipboard.
For example, click Copy to Clipboard to copy the event
properties to the clipboard. You can then paste the information
into an email and send the email to a system administrator.

Event Displays the name of the event in the Oracle FS System event
log.

Category Identifies the type of event. Valid values:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.

System Events to notify of system problems,
such as a missing Drive Enclosure or
Controller.

Time Occurred Identifies the time at which the event was sent to the
designated recipients.

User Identifies the name of the user logged in at the time the event
occurred.

Affected Item Provides the specific object name affected by the Event Type.
For example, if the Event reads Drive Enclosure Firmware
Invalid, then the Affected Item column lists the Drive
Enclosure name that caused the event to occur. Such details
provide more information for troubleshooting purposes.

Description Displays the event description text. The Description also
provides more information that Oracle Customer Support can
use to help resolve the event.

Related Links
Display the Event Properties

Generate Auto-Tier Effectiveness Report Dialog
Navigation: System > Storage Domains > Actions > Generate Auto-Tier
Effectiveness Report
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Modifies the storage costs, per GB and I/O per second (IOPS), that are used to
report the effectiveness of the QoS Plus feature.

Storage Costs
Provides the initial storage cost for each GB and for each IOPS of the Oracle FS
System. Enter the actual costs for each Storage Class in your system.

Performance
SSD

Cost per GB Specifies the cost for each GB for the
Performance solid‑state drives (SSDs)
that are in the system.

Cost per IOPS Specifies the cost for each IOPS for the
Performance SSDs that are in the
system.

Capacity SSD Cost per GB Specifies the cost for each GB for the
Capacity SSDs that are in the system.

Cost per IOPS Specifies the cost for each IOPS for the
Capacity SSDs that are in the system.

Performance
HDD

Cost per GB Specifies the cost for each GB for the
Performance hard disk drives (HDDs)
that are in the system.

Cost per IOPS Specifies the cost for each IOPS for the
Performance HDDs that are in the
system.

Capacity HDD Cost per GB Specifies the cost for each GB for the
Capacity HDDs that are in the system.

Cost per IOPS Specifies the cost for each IOPS for the
Capacity HDDs that are in the system.

Generate and View Report
Creates the Auto‑Tier Effectiveness Report and displays the report in a dialog for
review. The report is stored in the Generated Reports page under System >
Reporting & Statistics.

OK
Creates the Auto‑Tier Effectiveness Report in the Generated Reports page under
System > Reporting & Statistics.

Related Links
Generate Auto-Tier Effectiveness Report
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Generate Report Dialog
Navigation: System > Reporting and Statistics > Generated Reports > Actions >
Generate

Generates reports based on pre‑defined report types for the Oracle FS System.

Based on the report type you select, the system generates a real‑time report
containing information about SAN hosts, storage performance and use, or
system configuration. The report provides a snapshot of the information
available at the moment you generate the report.

Type Specifies the type of report to be generated:

SAN Hosts Provides detailed configuration information on the
host servers and configured components currently
included in your storage area network (SAN). The
data includes the SAN Host operating system, Fibre
Channel Initiator, Fibre Channel ports, load
balancing settings, LUNs, and other information
describing the SAN Hosts.

Storage
Performance

Provides performance information about the LUNs
on the Oracle FS System at the time the report was
generated. The performance data includes: read
operations per second, write operations per second,
and total read and write operations per second; read
MB per second, write MB per second, and total read
and write MB per second for each LUN.
Additional storage performance data, including real-
time statistics, is available for each LUN from the
SAN > Statistics and Trending > LUNs feature.

Storage Use Provides capacity information on the storage
currently available on the Oracle FS System. The data
includes the total, allocated, free, and preparing
capacity for all available storage. The data for total,
allocated, free, and preparing capacity is also
presented per storage class.

Storage Use per
Volume

Provides capacity information for each logical
volume on the Oracle FS System. The data includes
the allocated, maximum, and used capacity per
volume.

System
Configuration

Provides detailed information on the configuration
and current status of the Oracle FS System and all of
its components, such as serial numbers, firmware
versions, ports, and status, for the Pilot, Controllers,
and Drive Enclosures.

Note: You might want to generate and archive the
System Configuration report as the report provides a
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record of your system configuration at the time the
report was generated. A record of system changes
would be useful for system planning and customer
support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers, and
Drive Enclosures information included in the
detailed System Configuration report. The data
includes the current status of the components listed
above and system information.

Related Links
Generate a Report

Generated Reports Overview Page
Navigation: System > Reporting and Statistics > Generated Reports

Manages generated reports. From this page, you can create, delete, and modify
reports.

All reports, whether manually generated or generated by a reporting schedule,
are stored on the Oracle FS System and listed on this page. The Generated
Reports page lists the names, creation dates, and sizes of all currently available
generated reports. Use the Generated Reports list to select reports for
downloading in the format of your choice or to delete selected reports.

Name Displays the name of the generated report.

Created Displays the date and time that the report was created.

Size Indicates the size of the raw report file in kilobytes (KB) or megabytes
(MB).

Note: The size of the downloaded report will vary depending on the
chosen format.

Global Settings Overview Page
Navigation: System > Global Settings

Displays links that allow you to select and modify system‑wide settings for the
Oracle FS System.

After you select a category of settings, you can review or modify the collection of
settings for that category.

Networking Review or modify various characteristics of the customer
network, including for example:

• The Oracle FS System management interface
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• Call‑Home configuration
• iSCSI connectivity

Controller Ports View the Controller and port topology. Controller port
provisioning is also available from this page.

Storage Profiles View and manage the Oracle FS System Storage Profiles.

Note: Modifying or creating Storage Profiles is
recommended for expert users.

Security Manage account security settings including number of
failed login attempts allowed and session time‑out period.

Administrator
Accounts

Create and manage the administrator accounts that are
configured on the Oracle FS System.

SNMP Manage and configure the Simple Network Management
Protocol (SNMP) trap hosts.

System Time Set and synchronize the time across all Oracle FS System
components.

Hardware Overview Page
Navigation: System > Hardware

Displays links to pages that allow you to select options to display hardware
components installed on the Oracle FS System. After you select a type, you can
select and review the status and current configuration of a specific hardware
component.

Lists hardware components by type. Click a component identifier to display
details about the component.

Pilots Allows you to review the Pilot status and properties.

Controllers Allows you to review the Controller status and properties.

Drive Enclosures Allows you to review the Drive Enclosure status and
properties.

Drive Groups Allows you to review the drive group status and
properties.

UPS Allows you to review the uninterruptible power supply
(UPS) status and properties.

Component
Status Overview

Displays the overall health status of the following
hardware components. Click the graphic to display details
about the component.

• Pilots
• Controllers
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• Drive Enclosures

Manage Port Provisioning Dialog
Navigation: System > Global Settings > Controller Ports > Actions > Manage Port
Provisioning

Updates the Controller protocol used by the Oracle FS System.

Controller Identifies the name of the Controller.

Slot Number Identifies the Controller HBA slot number.

Manufacturer Identifies the HBA maker.

Model Identifies the HBA model number.

Number of Ports Identifies the number of ports that are available on the HBA.

Protocol Identifies the HBA protocol.
Valid protocols:

• Ethernet
• FC
• iSCSI
• SAS

Link Aggregation
Specifies the link aggregation properties for the Ethernet HBA port.

Aggregate
HBA Ports

This property is valid for Ethernet protocols only.
Specifies whether link aggregation is enabled on the HBA
port. Link aggregation allows theOracle FS System to group
pairs of Ethernet ports and treat the group as though the
physical links were one logical link. By default, link
aggregation is disabled. When enabled, link aggregation
allows the system and customer-supplied Ethernet switch to
negotiate link aggregation priority.

Management
Priority

This property is valid for Ethernet protocols only.
Specifies the link aggregation management priority. A higher
number indicates that the Ethernet switch has the priority to
manage link aggregation; a smaller number indicates that the
Oracle FS System is likely to assume this role.

Related Links
Manage Port Provisioning for a Controller

System Tab Reference Pages

330



Modify Administrator Account Dialog
Navigation: System > Global Settings > Administrator Accounts > Actions >
Modify

Changes the properties of a specific administrator account.

Login
Name

Identifies the login name assigned to the administrator account.
This field is limited to 20 characters.

Role Identifies the authorized privileges for an administrator account.
Different roles are authorized to perform different functions:

Administrator
1

The administrator role for a login account that
provides the authority to perform all
administrative tasks and all configuration tasks
except for certain tasks that are reserved for
the support roles.

Administrator
2

The administrator role for a login account that
provides the authority to perform most
administrative and configuration tasks. A login
account assigned to this role cannot, however,
perform the following tasks:

• Manage the administrator accounts and
other global system settings such as
those settings for networking, the
Controller ports, system security, and the
system time.

• Perform software upgrades or use
Guided Maintenance to replace
hardware components.

• Shut down the Oracle FS System system.

Monitor An administrator role for login accounts that
provides the authority for those accounts to
perform read‑only management tasks and to
modify their own account properties.

Support A unique login account solely for support
representatives. This login account is not
authorized to modify or delete data resources,
system alerts, or administrator accounts.

Important: Use this account only if you are
familiar with it or instructed by Oracle
Customer Support.

For the following predefined roles, you cannot assign
administrators to them and you cannot delete them:

System Tab Reference Pages

331



Primary system
administrator

A login account that has the same
privileges as the Administrator 1
role.

Primary support
administrator

A login account that has the same
privileges as the Monitor role, as well
as privileges to perform
support‑related tasks.

Note: You cannot change the role on predefined administrator
accounts such as the primary administrator; the Role drop-down
box is disabled.

Full Name Identifies the first and last name associated with the administrator
account.

Email
Address

Identifies the email address associated with the administrator
account. The email username can have up to 64 characters and the
email domain can have up to 255 characters. The email server to
which the Oracle FS System sends alerts must be able to receive
messages at this address. The system does not validate this
address.

Note: An IP address cannot be entered as the email domain.

Phone
Number

Identifies the phone number associated with the administrator
account. The Oracle FS System does not verify the validity of this
entry.

Password Identifies the password of the administrator account. Enter the
password; follow the password rules displayed on the dialog.

Password
Duration

Select a duration between 1 to 180 days to determine when the
password expires. Refer to your company’s policy on password
expiration to determine the duration you should set.

Confirm
Password

Confirms that the password was entered correctly.

Disable
Account

Indicates whether the administrative account is disabled. The
Oracle FS System maintains disabled accounts but does not allow
them to log in. A disabled account can be enabled later by
modifying it. This setting takes effect immediately. If the
administrator is logged in when you disable the account, the
system logs out the administrator immediately.

Note: You cannot disable the Primary system administrator
account.

Related Links
Modify an Administrator Account
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Modify Asset Information Dialog
Navigation: System > System Information > Actions > Modify

Updates the Oracle FS System asset and contact information.

Name Indicates the name that is assigned to the Oracle FS System.
The system name also appears in the status bar.

Description Indicates the short description of the Oracle FS System. We
recommend that you keep the description to less than 80
characters.

Location Indicates the physical location of the Oracle FS System.

Contact Name Lists the individual, or group of individuals, responsible for
the Oracle FS System.

Contact Phone Indicates the phone number of the individual or group of
individuals responsible for the system.

Asset Number Indicates the corporate asset number that is assigned to the
Oracle FS System.

Modify Chassis ID Dialog
Navigation: System > Hardware > Controllers > Actions > Modify Chassis ID

Updates the chassis ID number of the Controller. The chassis number appears on
the front of the Controller.

Current
ID

Identifies the current chassis ID.

Desired
ID

Select a chassis ID number from the pull‑down list. You can choose
from 1 to 99 or A0 to FF in hexadecimal. If you choose a chassis ID
that is already in use, you can swap the numbers. For example, if
you want to change chassis ID 15 to chassis ID 10 and chassis ID 10
is already assigned, you will be prompted to confirm you want to
swap the chassis ID numbers. Chassis ID 15 becomes chassis ID 10
and chassis ID 10 becomes chassis ID 15.

Related Links
Modify a Chassis ID

Modify Controller, Components Tab
Navigation: System > Hardware > Controllers > Actions > Modify > Components

Displays the status of the selected Controller and the components.

If there is a hardware failure, select the component and click Replace
Component. Oracle FS System Manager (GUI) starts Guided Maintenance.
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Guided Maintenance presents you with a sequence of dialogs that guides you
through the process of replacing a component.

Note: For more information about Guided Maintenance, refer to Oracle FS1-2
Flash Storage System Field Service Guide.

Comment Allows you to enter descriptive text that is associated with a
Controller. A comment can include up to 256 characters.

Identifier Displays the World Wide Number (WWN) associated with a
Controller.

Memory Displays the amount of random access memory (RAM)
provided by the DIMMs configured in the Controller.

Model Displays the model number of the Controller.

Replaceable
Unit

Lists the Controller components that are replaceable through
Guided Maintenance. Select a component, and then click
Replace Component to start Guided Maintenance.

Note: For fan replacement, the Replaceable Unit list displays
the names of each fan. Each power supply contains one fan,
and each fan module contains two fans. If a fan fails in a power
supply, replace the power supply. If a fan fails in a fan module,
replace the fan module. The following list identifies the names
of the fans and the corresponding customer replaceable unit
(CRU).

If the following fan fails Replace the following CRU
Fan 0 Power supply 0
Fan 1 Power supply 1
Fans 2, 3 Fan module 0
Fans 4, 5 Fan module 1
Fans 6, 7 Fan module 2
Fans 8, 9 Fan module 3
Fans 10, 11 Fan module 4

Status Displays the current status of a hardware component. A status
of Normal requires no action.

Related Links
Modify the Controller Comment

Modify Controller, I/O Ports Tab
Navigation: System > Hardware > Controllers > Actions > Modify > I/O Ports

System Tab Reference Pages

334



Displays the I/O ports of the selected Controller.

Slot Location of the HBA installed on the Controller
Port HBA port number.
Connection
Type

Identifies the types of network ports for data path traffic
between the customer network switches and the Controllers:

Copper Identifies copper interfaces.

Long Wave Optical Identifies longwave optical small form‑
factor pluggable (SFP) transceiver
interfaces.

Short Wave
Optical

Identifies shortwave optical SFP
transceiver interfaces.

Unknown Indicates that the connection type cannot
be determined.

Status Identifies the connection state between the HBA port and
Controller.
Possible states:

Connected Indicates that the HBA port on the host is
connected to the port on the Controller.
In most operating systems, host ports log in to
the Controller ports immediately after the two
are physically connected and enabled and
remain logged in until the physical connection
is broken. So, Connected effectively means that
there is an enabled physical connection between
the ports.

Not
Connected

Indicates that the HBA port on the host is not
connected to the port on the Controller.

Note: On HP‑UX platforms, however, some HBA device drivers
use a different approach. These drivers log out of the
connection when there is no traffic to send. The HP‑UX initiator
often logs out when the initiator does not discover any
accessible LUNs attached to the target port. For these reasons,
an HP‑UX HBA port often shows as Not Connected even
though there is an enabled physical connection between the
ports.

Bandwidth Displays the data rate of the port interface.

SFP Status Displays the status of the SFP transceiver.

• Bypassed
• Bypassed-No SFP
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• Bypassed-Incorrect Speed
• Bypassed-Read Error
• Bypassed-Incorrect Type
• Bypassed-Lost Sync

If the interface module itself should fail, the SFP status shows
Hardware Failure.

SFP Vendor Displays the vendor's part number for the SFP. If that
information is not available, the system displays Unknown.

SFP Part
Number

Displays the vendor's part number for the SFP. If that
information is not available, the field is blank or displays
Unknown.

SFP Revision Displays the part revision number for the SFP. If that
information is not available, the field is blank or displays
Unknown.

Modify Controller Port Settings Dialog
Navigation: System > Global Settings > Controller Ports > Actions > Modify Port
Settings

Updates the Controller iSCSI port properties. An administrator can also view
iSCSI port properties from this dialog.

Port Information
Controller Name Identifies the name of the Controller.

Slot Number Identifies the Controller HBA slot number.

Port Identifies the HBA port number.

Slot Identifies the Controller HBA slot number.

Status Identifies the HBA connection status.
Valid states:

• Connected
• Not connected
• Offline

Type Indicates the type of HBA.
Valid types:

• Ethernet
• Fibre Channel (FC)
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• Internet SCSI (Small Computer System Interface)
(iSCSI)

• Serial Attached SCSI (SAS)

Negotiated Speed Indicates the port transmission speed in Gigabits each
second.

Maximum Speed Indicates the maximum speed of the port.

Port Information
MAC Address Identifies the unique identifier of the HBA port.

Portal Group Tag Identifies the iSCSI target portal group tag that is assigned
to the port.

Link Up Indicates the iSCSI port link up status.
Valid states:

• No
• Yes

iSNS Client Status Indicates the iSNS client status for the iSCSI port.
Valid states:

• Access lost
• Established
• In progress
• Unknown

MTU Bytes
Minimum

Indicates the minimum number of bytes supported by the
maximum transmission unit (MTU).

MTU Bytes
Maximum

Indicates the maximum number of bytes supported by the
maximum transmission unit (MTU).

iSCSI Settings
IP
Assignment

Specifies the configuration method that the Oracle FS System
uses to obtain the IP address of the HBA port.
Valid methods:

DHCP Specifies whether a DHCP server
automatically assigns the IP addresses to
network clients. This setting makes the
Oracle FS System known to the DHCP
software. For this option, use a Microsoft
DHCP server that is configured by the
Microsoft iSNS Server installer to return
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the server IP address using DHCP option
43 (vendor‑specific) or DHCP option 83
(iSNS).

Static Specifies whether a permanent IP
address is assigned to the Pilot in an
Oracle FS System. Choose this option if
you do not use DHCP.

Netmask Specifies the netmask for the primary IP address that is
permanently assigned to the management interface of the
Oracle FS System.

Gateway Specifies the gateway IP address that is permanently assigned
to the management interface of the Oracle FS System.

TCP Port Specifies the Transmission Control Protocol (TCP) port number
that is configured on the iSCSI port.

VLAN
Enabled

Signifies whether a virtual LAN (VLAN) has been defined for
the iSCSI network.

VLAN ID Specifies the group portal tag number.

MTU Specifies the maximum transmission unit (MTU) value in bytes
for the Controller node.
The frame size (MTU) does not include the Ethernet header
portion of the packet. If your network switch has trouble with
the MTU size, you can set the switch to a larger value or lower
the MTU size to correct the problem.
If your network supports extended Ethernet (jumbo) frames,
enter an integer greater than 1500 and less than 9001. Make
sure that this Oracle FS System MTU size matches the network
MTU size. If the MTU sizes are mismatched, performance
might be severely degraded.

SFP Information
Status Identifies the small form‑factor pluggable (SFP) device port

status.
Valid SFP device states:

• Enabled 1 Gb
• Enabled 2 Gb
• Enabled 4 Gb
• Enabled 8 Gb
• Enabled 10 Gb
• Enabled 16 Gb
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• No SFP
• Incorrect Speed
• Read Error
• Incorrect Type
• Loss of Sync
• Other

Connection
Type

Identifies the types of SFP transceiver interface devices used
for data path traffic between the customer network switches
and the Controllers.
Valid SFP interface types:

• Copper
• Optical
• Long Wave Optical
• Short Wave Optical

Vendor Identifies the SFP device manufacturer.

Part Number Identifies the SFP device part number.

Revision Identifies the SFP device revision number.

Modify Controller Service Type Dialog
Navigation: System > Hardware > Controllers > Actions > Modify Controller
Service Type

Modifies the Service Type of a selected Controller.

Desired
Service
Type

The Service Type defines how much memory is optimized for I/O
performance to support either SAN or NAS by reallocating cache
resource. The cache allocations are approximate.

Note: Both Controllers must be set to the same Service Type.

Note: The service type can be selected based on the type of HBA
installed. For example, if you are using the Ethernet port on the
system, you would choose NAS Only. If you only have an FC HBA
installed, you would use SAN Only.

Available Service Types:

SAN Only Allocates 100 percent of cache allocated to
SAN.

NAS Only Allocates 100 percent of cache allocated to
NAS.
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Biased to SAN Allocates 70 percent of cache allocated to
SAN, and 30 percent of cache allocated to
NAS.

Biased to NAS Allocates 70 percent of cache allocated to
NAS, and 30 percent of cache allocated to
SAN.

Data Access Disruption Required
Shutdown Controllers shut down to enable hardware to be removed and

added as necessary. When the Controllers are powered on, the
Desired Service Type is applied.

Restart Controllers are restarted but no hardware can be removed or
added.

Modify Drive Enclosure, Components Tab
Navigation: System > Hardware > Drive Enclosures > Actions > Modify >
Components

Modifies the Comment field of the selected Drive Enclosure.

You can view the status of the selected Drive Enclosure and its components
including chassis, drives, I/O modules, and power cooling module. You can also
control the option for automatic Drive Enclosure operations.

If there is a hardware failure, select the failed component and then click Replace
Component. The Oracle FS System Manager starts the Guided Maintenance,
which begins a process of resolving the hardware failure.

Note: For more information on Guided Maintenance, refer to the Oracle FS1-2
Flash Storage System Customer Service Guide.

Comment Specifies the new name that is assigned to the Drive Enclosure.
Use a unique, meaningful name to help you easily locate specific
components. The Oracle FS System maps the assigned name to
the component’s serial number and updates the map if you
modify the component name.
By default, the Drive Enclosures are assigned names such as
Enclosure 01. This string is a logical Drive Enclosure name
and does not necessarily reflect the physical location of the
Drive Enclosure. You can use the Comment field to provide
descriptive information such as the rack location where the
Oracle FS System is located. For example, you could enter, Rack
07.

Model Indicates the model number of the Drive Enclosure in which the
drive resides.
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Serial
Number

Indicates the serial number of the selected Drive Enclosure.

Drive
Enclosure ID

Indicates the unique identifier (the World Wide Name) of the
selected Drive Enclosure.

Perform
Automatic
Drive
Enclosure
Operations

Indicates whether data protection operations, such as copyback,
copy-away, and rebuild run in the background, as necessary.
Deselect this option as instructed by Oracle Customer Support.
You might also need to deselect this option as instructed in a My
Oracle Support (MOS) Knowledge Article that is specific to your
issue.

Replaceable
Unit

Indicates the Drive Enclosure components that are replaceable.

Status
(Chassis)

Provides the operational state of the Drive Enclosure chassis.
Oracle FS System Manager (GUI) displays a status icon followed
by the chassis state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal chassis status:

Normal The chassis is operating normally.

 (Warning) The following operational states are associated
with a warning chassis status:

Unknown The system is unable to read the
chassis state.

Status
(Drives)

Provides the operational state of the drive in the drive group.
Oracle FS System Manager (GUI) displays a status icon followed
by the drive state.
Possible states, by status icon:

(Normal)
The following operational states are associated
with a normal drive status:

Normal The drive is a member of the drive
group.

Not Used The drive is operating normally,
but is not a member of a drive
group.

(Warning)
The following operational states are associated
with a warning drive status:

Booting The drive is starting up.
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Copy Away
Source

The system has detected a
failure on the drive and is
currently copying the data
to a target drive. The drive
state changes to Failed
when copying is complete.

Copy Away
Target

The system has detected a
failure on another drive and
is currently copying the data
to this target drive.

Copyback An active spare drive is
copying data to this drive.

Degraded
Connectivity

The connection to the drive
is limited to only a single
Controller.

Foreign The drive is not a member
of this drive group. Accept
this drive using the
associated System Alert to
make the drive a member of
the drive group.

Missing The drive is not found in the
Drive Enclosure.

Rebuilding The drive is a target of a
rebuild operation for a drive
group.

Recovered The drive has failure history,
but is now online and is not
a member of a drive group.

Recovered In
Use

The drive has failure history.
The drive is now online and
is a member of a drive
group.

Shutdown The system is in shutdown
mode and cannot access the
drive.

Unknown The system is unable to read
the drive state.

(Critical)
The following operational states are associated
with a critical drive status:

Critical The drive has experienced a failure.
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Restore The drive is currently being
restored.

Status (I/O
modules)

Provides the operational state of the I/O module in the drive
group. Oracle FS System Manager (GUI) displays a status icon
followed by the I/O module state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal I/O module status:

Normal The I/O module is operating
normally.

(Warning)
The following operational states are associated
with a warning I/O module status:

Offline The I/O module is offline.

Missing The I/O module is not found in
the Drive Enclosure.

Unknown The system is unable to read the
I/O module state.

 (Critical) The following operational states are associated
with a critical I/O module status:

Critical The I/O module has experienced a
failure.

Status
(Power
Cooling
Module)

Provides the operational state of the Drive Enclosure power
cooling module. Oracle FS System Manager (GUI) displays a
status icon followed by the power cooling module state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal power cooling module status:

Normal The power cooling module is
operating normally.

(Warning)
The following operational states are associated
with a warning power cooling module status:

Offline The system reports that the
power cooling module is failed
or is disabled.

System Tab Reference Pages

343



Missing The power cooling module is
not found in the Drive
Enclosure.

Warning The power cooling module is
functioning but shows signs of
failure.

Unknown The system is unable to read the
power cooling module state.

 (Critical) The following operational states are associated
with a critical power cooling module status:

Critical The power cooling module has
experienced a failure.

Replace
Component

Starts Guided Maintenance that steps you through the
component replacement process.

The system displays details about the selected replaceable component.

Chassis
information

Provides detailed information about the selected chassis.

Number Indicates the number that uniquely identifies
the chassis within the Drive Enclosure.

Status Indicates the operational state of the
component.

Part Number Indicates the manufacturer part number of the
component.

Serial Number Indicates the serial number of the component.

Drive
information

Provides detailed information about the selected drive.

Status Indicates the operational state of the drive.

Model Indicates the manufacturers model number of
the drive.

Serial
Number

Indicates the serial number of the drive.

Firmware
Number

Indicates the firmware version number of the
drive.

Drive Slot
Number

Indicates the Drive Enclosure slot number
where the drive is installed.

Storage
Class

Specifies the category of physical media that
comprises the drive group.
Valid media types:
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Performance
SSD

Specifies that the data is
stored on solid state drives
(SSDs) that are optimized for
the performance of balanced
read and write operations.

Capacity
SSD

Specifies that the data is
stored on SSDs that are
optimized for the
performance of capacity and
for read operations. The
write performance for this
Storage Class is sacrificed
somewhat to achieve the
optimizations for read
performance and for
capacity.

Performance
Disk

Specifies that the data is
stored on high‑speed hard
disk drives (HDDs). This
Storage Class sacrifices some
capacity to reduce the access
time and the latency of the
read operations and of the
write operations.

Capacity
Disk

Specifies that the data is
stored on high‑capacity,
rotating HDDs. This Storage
Class optimizes capacity at
some sacrifice of speed. For a
storage system that does not
include tape storage as an
option, this Storage Class
always provides the lowest
cost for each GB of capacity.

Drive
Enclosure

Indicates the unique identifier of the Drive
Enclosure.

Drive
Capacity

Indicates the storage capacity of the drive.

Remaining
Life
Expectancy

(SSD only) Indicates the remaining months in
the life of the drive.

I/O Module
information

Provides detailed information about the selected I/O module.

Number Indicates the number that uniquely identifies
the I/O module within the Drive Enclosure.
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Status Indicates the operational state of the I/O
module.

Part Number Indicates the manufacturer part number of
the I/O module.

Serial Number Indicates the serial number of the I/O
module.

Firmware
Number

Indicates the firmware version number of the
I/O module.

Power
Cooling
Module
information

Provides detailed information about the selected Power Cooling
Module.

Status Indicates the operational state of the Power
Cooling Module.

Model Indicates the manufacturer model number of
the Power Cooling Module.

Serial Number Indicates the serial number of the Power
Cooling Module.

Number of
Fans

Indicates the number of cooling fans in the
Power Cooling Module.

Number of
Failed Fans

Indicates the number of failed cooling fans in
the Power Cooling Module.

Related Links
Modify the Drive Enclosure Comment

Modify Drive Enclosure, I/O Ports Tab
Navigation: System > Hardware > Drive Enclosures > Actions > Modify  > I/O
Ports

Displays the status of the Serial Attached SCIS (SAS) interfaces of the selected
Drive Enclosures. No changes can be made from this panel.

Port Lists the PHYs that are associated with the I/O module port.

Phy State Indicates the state of the PHY connection. A wide port has two
or more of the PHY states indicate Link Up. A narrow port has
only one PHY state is Link Up.
Possible states:

Link Up Indicates that the PHY connection is
functioning properly.
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Link Down Indicates that the PHY connection is
disconnected.

Disabled Indicates that the PHY connection is disabled.

Reset Indicates that the system is resetting the PHY
connection.

Negotiated
Speed

Indicates the port transmission speed in Gigabits each second.

Maximum
Speed

Indicates the maximum speed of the port.

Modify Drive Group Dialog
Navigation:

• System > Storage Domains > Actions > Modify Drive Group

• System > Hardware > Drive Groups > Actions > Modify

Displays information about drives within a drive group. You can also set a drive
group as the primary drive group.

Replaceable Units
Replaceable
Unit

Displays the drives available in a drive group. The details about
a selected drive are displayed on the right-hand side of the
dialog.

Status
(Drives)

Provides the operational state of the drive in the drive group.
Oracle FS System Manager (GUI) displays a status icon followed
by the drive state.
Possible states, by status icon:

(Normal)
The following operational states are associated
with a normal drive status:

Normal The drive is a member of the drive
group.

Not Used The drive is operating normally,
but is not a member of a drive
group.

(Warning)
The following operational states are associated
with a warning drive status:

Booting The drive is starting up.

Copy Away
Source

The system has detected a
failure on the drive and is
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currently copying the data
to a target drive. The drive
state changes to Failed
when copying is complete.

Copy Away
Target

The system has detected a
failure on another drive and
is currently copying the data
to this target drive.

Copyback An active spare drive is
copying data to this drive.

Degraded
Connectivity

The connection to the drive
is limited to only a single
Controller.

Foreign The drive is not a member of
this drive group. Accept this
drive using the associated
System Alert to make the
drive a member of the drive
group.

Missing The drive is not found in the
Drive Enclosure.

Rebuilding The drive is a target of a
rebuild operation for a drive
group.

Recovered The drive has failure history,
but is now online and is not
a member of a drive group.

Recovered In
Use

The drive has failure history.
The drive is now online and
is a member of a drive
group.

Shutdown The system is in shutdown
mode and cannot access the
drive.

Unknown The system is unable to read
the drive state.

(Critical)
The following operational states are associated
with a critical drive status:

Critical The drive has experienced a failure.

System Tab Reference Pages

348



Restore The drive is currently being
restored.

Drive
information

Provides detailed information about the selected drive.

Status Indicates the operational state of the drive.

Model Indicates the manufacturers model number of
the drive.

Serial
Number

Indicates the serial number of the drive.

Firmware
Number

Indicates the firmware version number of the
drive.

Drive Slot
Number

Indicates the Drive Enclosure slot number
where the drive is installed.

Storage
Class

Specifies the category of physical media that
comprises the drive group.
Valid media types:

Performance
SSD

Specifies that the data is
stored on solid state drives
(SSDs) that are optimized for
the performance of balanced
read and write operations.

Capacity
SSD

Specifies that the data is
stored on SSDs that are
optimized for the
performance of capacity and
for read operations. The
write performance for this
Storage Class is sacrificed
somewhat to achieve the
optimizations for read
performance and for
capacity.

Performance
Disk

Specifies that the data is
stored on high‑speed hard
disk drives (HDDs). This
Storage Class sacrifices some
capacity to reduce the access
time and the latency of the
read operations and of the
write operations.

Capacity
Disk

Specifies that the data is
stored on high‑capacity,
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rotating HDDs. This Storage
Class optimizes capacity at
some sacrifice of speed. For a
storage system that does not
include tape storage as an
option, this Storage Class
always provides the lowest
cost for each GB of capacity.

Drive
Enclosure

Indicates the unique identifier of the Drive
Enclosure.

Drive
Capacity

Indicates the storage capacity of the drive.

Remaining
Life
Expectancy

(SSD only) Indicates the remaining months in
the life of the drive.

Make this
drive group
the primary
drive group

Make the drive group the primary drive group within the Drive
Enclosure. The primary drive group contains system
configuration data.

RAID Levels and Status
RAID
Level

Indicates the types of RAID data protection that is provided by the
selected drive group.
Each entry in the table represents a particular set of minimum
allocation units (MAUs) in the drive group. Each of the MAUs in a
given set has the same level of RAID protection, forming a RAID
protection segment for the drive group.
If a drive goes offline, the event affects all of the MAUs in the
protection segment in the same way. Therefore, the reported status for
a given RAID level applies to the entire protection segment.

Single
Parity

Indicates that each of the MAUs in the RAID protection
segment uses one set of parity bits to protect against the
loss of one drive in the drive group. Single parity is
implemented as a variant of the RAID 5 storage
technology.

Double
Parity

Indicates that each of the MAUs in the RAID protection
segment uses two sets of parity bits to protect against
the loss of one or two drives in the drive group. Double
parity is implemented as a variant of the RAID 6
storage technology.

Mirrored Indicates that each of the MAUs in the RAID protection
segment is written across two drives in the drive group.
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Mirrored RAID is implemented as a variant of the
RAID 10 storage technology.

RAID
Status

Possible states:

Normal Indicates that the drive group is accessible and no
action is required.

Degraded
Warning

Indicates that the drive has failed in the drive group,
but the drive group is still accessible. Replace the
failed drive. If the drive group is the primary drive
group, then replace the drive immediately. The
primary drive group contains system overhead,
including all system configuration data.

Degraded
Critical

Indicates that two or more of the drives have failed.
The drive group can become inaccessible unless you
replace the drives.

Failed Indicates that multiple drives have failed. The drive
group is not accessible. Replace the failed drives.
After the failed drives are replaced, the drive group
becomes accessible.

Unknown Indicates that the drive status information is not
available to display.

Related Links
Make a Drive Group the Primary Drive Group

Modify Chassis ID Dialog
Navigation: System > Drive Enclosures > Actions > Modify Chassis ID

Updates the chassis ID number of the Drive Enclosure. The chassis ID appears on
the Drive Enclosure.

Current ID Identifies the current chassis ID.
Desired ID Lists the available chassis ID numbers. You can select from 01 to 99

or A0 to FF in hexadecimal. If you select a chassis ID that is
already in use, the system issues a message to indicate that the
selected chassis ID is already in use. You can choose swap the two
chassis ID numbers or cancel the operation.

Related Links
Modify a Chassis ID

Modify Event Notification Dialog
Navigation: System > Alerts and Events > Event Notification > Actions > Modify
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Changes the selected event notification.

When an event is triggered, the Oracle FS System sends a notification to the
designated recipients. You can change which notifications are monitored as well
who receives the notification.

Name Identifies the name of the event notification.

Description Describes the event notification.

Enable Event
Notification

Indicates whether event notification is enabled. Select this
option to activate the notification when the event occurs on
the Oracle FS System.

Event
Notification
Recipient Email
Addresses

Identifies the email addresses of the recipients who are to
receive event notifications. The email server to which the
Oracle FS System sends notifications must be able to send
messages to the email addresses.

Add Allows you to add email recipients to the event notification.

Test Email Sends a message to the specified email addresses to test the
recipient email addresses. Recipients receive a message that
is titled “[Oracle‑QoS] Test email” in their email in‑boxes.

Note: Allow at least 10 minutes between email tests.

Remove Deletes the selected email address from the list.

Monitored Events
By severity,
then category

Sorts the list of events by severity with a list of event categories.
The severity categories include:

Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent system
failures or offline conditions.

By category,
then severity

Sorts the list of events by categories with a list of event severity.
The categories include:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.
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System Events to notify of system problems, such
as a missing Drive Enclosure or
Controller.

Events Not
Monitored

Provides the list of events not set to be monitored. The
Oracle FS System does not trigger a notification when an event
listed occurs. From the list, you can specify the events to be
monitored. You can sort the list by severity or category.

Monitored
Events

Provides the list of events that you specified to be monitored.
The Oracle FS System triggers a notification each time an event
that you specified occurs. The email addresses specified in the
Event Notification Recipient Email Addresses field receive the
event notifications. You can sort the list by severity or category.

Related Links
Modify an Event Notification

Modify Network Settings, Interfaces Tab
Navigation: System > Global Settings > Networking > Actions > Modify >
Interfaces

Updates the network and data-path interfaces for the Oracle FS System.

Management Interface
Enable
DHCP

Indicates whether you have a Dynamic Host Configuration
Protocol (DHCP) server that automatically assigns IP addresses
to network clients. This setting makes the Oracle FS System
known to the DHCP software.

Static IP
Address

Identifies whether to assign a permanent IP address to the
Oracle FS System Pilot. Choose this option if you do not use
DHCP.

Note: Selecting this option enables the Public Interface fields.

Transmit
Setting

Important: Use care when setting the transmit speed and duplex
mode. If your external network does not support the
management interface setting, a loss of access to the Pilot could
result. If access is lost, contact Oracle Customer Support for
assistance.

Select from the drop-down list the speed and duplex mode that
you want the Pilot management interface to use.

Note: Auto negotiate is the default transmit setting. We
recommend the default setting for all but special circumstances.

Valid speeds:
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• Auto
• Half 10 Mbps
• Full 10 Mbps
• Half 100 Mbps
• Full 100 Mbps
• Half 1000 Mbps
• Full 1000 Mbps
• Full 10 Gbps

Speed Displays the actual speed and duplex mode that the
management interface uses.

Public
Interface
(when Static
IP Address is
selected)

Specifies the IP address that is permanently assigned to the
public interface to the Pilot.

Pilot 1/Pilot 2 Specifics the IP addresses that are permanently assigned to the
Pilot nodes. You can use these static IP addresses as an alternate
method to access the active Pilot node.

Netmask Specifies the subnet mask for the public IP address that is
permanently assigned to the Oracle FS System.

Gateway Specifies the public IP address of the gateway server in the
subnet of which the Oracle FS System is a member.

DNS Settings
Primary DNS
Server

Specifies the Domain Name Server (DNS) that is used to
resolve IP addresses.

Secondary DNS
Server

Specifies the IP address of the secondary DNS server in
the network if the primary DNS server cannot be reached.

Static Routes
Manages TCP/IP traffic to non‑local network routes for a File Server.

Routes are used to send network traffic to specific IP addresses or to specific
subnets. Typically, a File Server uses the gateway attribute of the virtual interface
(VIF) to route outgoing traffic.

By default, the routing table is empty. If you define one or more static routes for a
File Server, you can define up to 32 routes.

Destination Identifies the route destination network or host.

Netmask Identifies the subnet mask for the destination route IP address.
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Gateway Identifies the IP address that is assigned to the gateway host. The
gateway IP address is used to route messages from this network
to other networks.

Order Identifies the routing position in the table.

Add Route Adds a TCP/IP route for access by all File Servers.

Remove Route Removes one or more TCP/IP routes.

Related Links
Configure the Management Interface

Modify Network Settings, iSCSI Tab
Navigation: System > Global Settings > Networking > Actions > Modify > iSCSI

Updates system‑wide iSCSI settings if you have iSCSI hosts configured to use
Challenge Handshake Authentication Protocol (CHAP), Access Control, Internet
Storage Name Service (iSNS), or a combination of these parameters.

The iSCSI settings configures the authentication and access controls on the
Oracle FS System, which the host must match to gain access. If you have CHAP
and Access Control configured for each initiator, you do not need to configure
iSCSI globally.

Connectivity and Communication
iSCSI
Device
Name

Identifies the name of the iSCSI initiator for the SAN host. An
initiator encapsulates SCSI commands and data requests within
iSCSI packets and transfers the packets across the IP network.

iSCSI
Device
Alias

Identifies an easily understood, alternative name for the iSCSI
device. By default, the device alias is constructed using the Oracle FS
System model plus the system serial number using the following
format:

• Oracle FS System <model‑number> SSN:<serial‑number>

Enable
Header
Digest

When an iSCSI initiator logs in to the Oracle FS System, the initiator
negotiates the parameters for the iSCSI session. If the initiator does
not give the system a choice regarding the use of iSCSI header
digests, the system complies with what the initiator wants. If the
initiator gives the system a choice and if Enable Header Digest is
enabled, the system chooses to use header digests, regardless of the
preference identified by the initiator.

Note: When selected, this parameter provides more error checking
for the header portion of the iSCSI packet.
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Enable
Data
Digest

When an iSCSI initiator logs in to the Oracle FS System, the initiator
negotiates the parameters for the iSCSI session. If the initiator does
not give the system a choice regarding the use of iSCSI data digests,
the system complies with what the initiator wants. If the initiator
gives the system a choice and if Enable Data Digest is enabled, the
system will choose to use data digests, regardless of the preference
identified by the initiator.

Note: When selected, this parameter provides additional error
checking for the data portion of the iSCSI packet.

iSNS Server Registration
Enable iSNS
Server
Registration

Choosing this option allows Oracle FS System iSCSI targets
to be registered in the iSNS server.
For discovery of the iSNS server IP address, specify either
DHCP or static addressing:

Static This option requires the following information:

Server Indicates the server IP address.

TCP port Indicates the TCP port that the
Oracle FS System uses to register with
the iSNS server.

Security
Access Control Specifies the access control method for iSCSI initiators.

Valid options:

None Specifies that the Oracle FS System
permits all iSCSI initiators to login.

Oracle FS Specifies that the Oracle FS System
rejects iSCSI login attempts from
initiators that have not explicitly been
granted permission by the user
through the Oracle FS System
Manager interface.

Authentication Identifies the authentication of the host (initiator) during
login. Valid options:

All Initiators Specifies that CHAP authentication is
required for all iSCSI connections to
the Oracle FS System, regardless of
what is configured for each host.

Per Initiator Specifies that CHAP authentication is
required only for those iSCSI
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connections for which it is configured
for each host.

Note: If the initiator on the SAN host
has been configured to require CHAP
authentication, login fails unless the
Oracle FS System is configured to
authenticate to All Initiators or
authentication is set to Per Initiator
and the Enable Bi‑Directional CHAP
option is selected. In either case,
specify the CHAP Secret for the
initiator.

Authentication
Server

Specifies whether the Oracle FS System or a Radius server
performs the authentication.

Oracle FS Indicates that the Oracle FS System
performs the authentication.

Radius Indicates that a RADIUS server
performs the authentication.

Note: When this option is selected, the
system ignores any CHAP name or
secret that is configured for a host in
the Oracle FS System Manager.

Enable Bi-
Directional
CHAP

Enables the CHAP protocol to be used for requests for data
(from the iSCSI initiator) and responses to requests (from
the iSCSI target). If bi-directional CHAP support is disabled
for the Oracle FS System, disable bi-directional CHAP for
all initiators; otherwise the initiator login fails.

CHAP Secret Identifies the encrypted CHAP authentication password
(secret) used in the exchange of user names and secrets
between two iSCSI devices. Both devices must support
Point‑to‑Point Protocol (PPP) authentication.

Note: The Oracle FS System supports up to 100 UTF-8 non-
integer characters. However, when connecting to Windows
servers, limit the secret to a value between 12 and 16
characters in length.

Retype CHAP
Secret

Re-enter the encrypted CHAP authentication password
used.

Primary Radius
Server and
Secondary
Radius Server

Identifies the details for connecting to the primary and
secondary Radius servers. This information is required
when the Authentication Server is set to Radius.

IP Address Specifies the IP address of the Radius
server.

System Tab Reference Pages

357



UDP Port Specifies the UDP port of the Radius
server to which the Radius server is
listening.

Radius Secret Specifies the secret used to access the
Radius server.

Retype Radius
Secret

Specifies the retyped secret used to
access the primary Radius server.

Related Links
Configure iSCSI System Settings

Modify Network Settings, Notification Tab
Navigation: System > Global Settings > Networking > Actions > Modify >
Notification

Updates the email server that receives email and Call‑Home notifications from
the Oracle FS System and sends the email messages to the designated recipients.

Email Notifications
Specifies the email server details necessary to send notification from the
Oracle FS System.

Enable Email
Notifications

Identifies whether email is enabled.

• Enable email if you intend to define alerts to send
email notifications.

• Disable email if you do not want to send email
notifications from the Oracle FS System.

SMTP Server IP
Address

Identifies the Simple Mail Transfer Protocol (SMTP) server
to use for sending any emails. Valid options:

• IP: The IP address for the SNMP server
• DNS: The Domain Name Service (DNS) for the SNMP

server

SMTP Server
Port

Specifies the port to which the SMTP server listens for
incoming email.

Email Domain Specifies the sending domain identifier other than the
Oracle FS System.

Email Flood
Prevention

Identifies the time interval in which the system is permitted
to send two subsequent emails when an event occurs on the
Oracle FS System. The smaller the number, the more
frequent the system sends event notification emails. The
default time is 300 seconds (5 minutes).

System Tab Reference Pages

358



Call-Home Triggering
Allows you to specify when events logs and messages are sent to the Call‑Home
server.

Enable
event
triggered
Call-Home

Enables Call‑Home support, which enables the Oracle FS System
to send status messages to the designated server.

Enable
standard
periodic
Call-Home

Enables the periodic sending of the Oracle FS System event logs
to the Call‑Home server.

Start Date Indicates the time and date when to begin
the periodic transfers.

Interval Indicates the unit of occurrence at which
the system performs the scheduled
transfer. Valid options:

Daily Performs the
scheduled task on a
daily basis.

Weekly Performs the
scheduled task on a
weekly basis.

Monthly Performs the
scheduled task on a
monthly basis.

Recurrence Indicates the number of intervals to wait
before starting the next scheduled
Call‑Home operation. Enter or select a
value from 1 to 100.
The default interval is weekly.

Enable
larger
periodic
Call-Home

Enables large files to be sent to the Call‑Home server so that trace
logs and performance statistics are automatically included in the
Call‑Home logs.

Start Date Indicates the time and date when to begin
the periodic transfers.

Interval Indicates the unit of occurrence at which
the system performs the scheduled
transfer. Valid options:

Daily Performs the
scheduled task on a
daily basis.
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Weekly Performs the
scheduled task on a
weekly basis.

Monthly Performs the
scheduled task on a
monthly basis.

Recurrence Indicates the number of intervals to wait
before starting the next scheduled
Call‑Home operation. Enter or select a
value from 1 to 100.
The default interval is weekly.

Call-Home Configuration
Specifies the Call‑Home server settings. You can configure an Oracle server or a
local server to receive the event logs and messages.

Use Oracle
Server

Specifies that Call‑Home logs and messages should be sent to
Oracle.

Server
Address

Identifies the IP address or the domain name of
the Call‑Home server,
callhome.support.pillardata.com. Valid options:

• IP: The IP address for the SNMP server
• DNS: The Domain Name Service (DNS)

for the SNMP server

Connect
via SCP

Specifies the use of secure copy (SCP) with
1024‑bit encryption and secure keys to transfer
files directly over the Internet to Oracle
Customer Support.

Connect
via
HTTPS

Sends files either directly to the Oracle server
through a secure Internet connection or to a
proxy server.

Use Proxy Sends Call‑Home logs through a proxy server
for security purposes or when the Oracle FS
System does not have direct access to the
Internet.

Proxy
Server
Address

Identifies the DNS server name or IP address of
the proxy server.

Proxy
Server
Port

Identifies the port that the proxy server uses to
send the Call‑Home log files.
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Protocol Identifies the type of protocol that Call‑Home
uses to access the proxy server. Valid options:

HTTP
SOCKS4
SOCKS5
Unknown

Use Local
Server

Specifies that Call‑Home status messages should be sent to a
local server by providing the IP address or domain name of
the local server.

SCP Server Specifies the use of secure copy (SCP)
with 1024‑bit encryption and secure
keys to transfer files directly over the
Internet to Oracle Customer Support.

Remote Directory Identifies the full directory path on the
target server in which to store the
Call‑Home log files.

Password
Authentication

Specifies that authentication is required to access the local
server. Use login credentials or a customer‑supplied
certificate to authenticate access to the local server.

Username Specifies the name of the user.

Password Specifies the password associated with
the username.

Enable large file
transfers

Identifies whether trace logs and performance statistics are
included in Call‑Home data transfers. The size of the log file
is not limited and can become large.

• Enable this option to allow large files so that trace logs
and performance statistics are automatically included
in the messages that are sent to Oracle Customer
Support.

• Disable this option to exclude trace logs and
performance statistics from the Call‑Home messages
that are sent to Oracle Customer Support. You can
collect, download, and transmit the trace logs
separately if they are needed.

Number of
recent events to
send in header

Specifies the maximum number of system events to include
in the Call‑Home status messages. The number of system
events should be greater than or equal to zero.

Related Links
Configure Email Notification Settings
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Modify Reporting Schedule Dialog
Navigation: System > Reporting and Statistics > Reporting Schedules > Actions >
Modify

Changes the properties of the selected reporting schedule.

Schedule
Name

Enter a name for the schedule. The name is displayed in the
Name column on the Reporting Schedules page. If you do not
specify a name, the system uses the default name of untitled.

Note: The name you enter is for your use in identifying the
schedule listed in the Reporting Schedules.
For example, if you want to run a weekly report on storage use,
you might enter weeklystorageuse as the schedule name to
help you locate that report. When a report is generated, the
system automatically creates a name for the report, itself. The
name the system creates is based on the report type, such as
StorageUse_1374861600286 not the name you assigned to the
report schedule. The report name is displayed in the Generated
Reports name column.

Report Type SAN Hosts Provides detailed configuration information
on the host servers and configured
components currently included in your
storage area network (SAN). The data
includes the SAN Host operating system,
Fibre Channel Initiator, Fibre Channel ports,
load balancing settings, LUNs, and other
information describing the SAN Hosts.

Storage
Performance

Provides performance information about the
LUNs on the Oracle FS System at the time the
report was generated. The performance data
includes: read operations per second, write
operations per second, and total read and
write operations per second; read MB per
second, write MB per second, and total read
and write MB per second for each LUN.
Additional storage performance data,
including real-time statistics, is available for
each LUN from the SAN > Statistics and
Trending > LUNs feature.

Storage Use Provides capacity information on the storage
currently available on the Oracle FS System.
The data includes the total, allocated, free,
and preparing capacity for all available
storage. The data for total, allocated, free, and
preparing capacity is also presented per
storage class.
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Storage Use per
Volume

Provides capacity information for each logical
volume on the Oracle FS System. The data
includes the allocated, maximum, and used
capacity per volume.

System
Configuration

Provides detailed information on the
configuration and current status of the
Oracle FS System and all of its components,
such as serial numbers, firmware versions,
ports, and status, for the Pilot, Controllers,
and Drive Enclosures.

Note: You might want to generate and archive
the System Configuration report as the report
provides a record of your system
configuration at the time the report was
generated. A record of system changes would
be useful for system planning and customer
support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers,
and Drive Enclosures information included in
the detailed System Configuration report. The
data includes the current status of the
components listed above and system
information.

Enabled Specifies whether the scheduled report is active or inactive. To
make a scheduled report active, check the Enable checkbox. If
you do not want the scheduled report to be active, do not check
the Enable checkbox. The scheduled report is still listed under
Reporting Schedule but reports are not generated.

Start Time Specifies the date and time to begin generating reports.

Schedule
Frequency

Specifies the frequency at which the schedule generates reports.
Frequencies include:

• Run Once
• Hourly
• Daily
• Weekly

Recurrence Specifies how many hours, days, or weeks to wait before
generating this scheduled report again. You can also specify a
specific day on which you want the report to be generated.

Related Links
Modify a Reporting Schedule
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Modify Security Settings Dialog
Navigation: System > Global Settings > Security > Actions > Modify

Updates the account security properties and the login welcome message.

Account Security
Consecutive
failed login
attempts allowed

Identifies the number of times that an administrator can
attempt, and fail, to log in to the Oracle FS System. When
the number of failed login attempts exceeds this limit, the
system locks out the account. Only the Primary system
administrator and administrators having the role of
Administrator 1 can unlock the account.

Session timeout
period (in
minutes) for all
administrators

Identifies an inactivity time limit, after which an
administrator session is terminated. Sessions in progress
continue to use the previous value and are not affected by
changes that you make. Sessions that start after you change
the value use the modified session time‑out value.
The default for the session time-out is 999 minutes.
After an administrator logs in, if the administrator is
inactive for a length of time equal to the session time-out
period, the Oracle FS System automatically logs the
account out of the system.
The session time-out period applies only to property
dialogs and popup windows in the Oracle FS System
Manager. The session time-out period does not apply to the
main window because of activity that occurs to verify the
system status and health.

Login Screen Message
Specifies a message that is displayed when system administrators log in to the
Oracle FS System. You can enter up to 256 Unicode characters.

Related Links
Modify Security Settings

Modify SNMP Host Dialog
Navigation: System > Global Settings > SNMP > Actions > Modify

Changes the properties of the Simple Network Management Protocol (SNMP)
trap hosts.

Name Identifies the name for the SNMP host.

Host IP Identifies the IP address or domain name of a client that
receives the Oracle FS System SNMP information.
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Community
String

Identifies the community string for use when the Oracle FS
System sends an event trap to the SNMP host.

Note: When an administrator does not specify a community
string for read-only access, SNMP servers and clients
typically use public.

Receive traps Indicates that the SNMP host receives event traps sent to it.

Trap Port
Number

Identifies the SNMP host port number to use for sending an
event trap.

Severity
Threshold

Identifies the severity threshold for events that the system
sends to the SNMP host by event traps.
Severity levels:

• Informational
• Warning
• Critical

Related Links
Modify SNMP Hosts

Modify Storage Domain Dialog
Navigation: System > Storage Domains > Actions > Modify Storage Domain

Modifies the properties of the selected Storage Domain.

Storage Domain Capacity by Storage Class
Displays graphically the storage classes, and their capacities, for the selected
Storage Domain.

Valid media types:

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.
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Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

For each storage class, the system graphically displays the Storage Domain
physical capacities. The graph uses colored bars of different thicknesses to
indicate the capacity status of each storage class. Hover the mouse pointer over
each graph to display the capacity type.

Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Possible physical storage capacities:

Free Space Displays the amount of capacity that is available for
allocation in the indicated Storage Class.

Used Capacity Displays the amount of capacity that is consumed by data
and system overhead.

Total Capacity Displays the total amount of raw capacity provided by the
drive groups that are defined within the indicated Storage
Class.

Allocated Space Displays the amount of capacity that has been assigned and
designated to all storage classes residing on the indicated
Storage Class.

Preparing
Capacity

Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Class.

Allocated to
Logical
Maximum

Displays the maximum capacity to which the Storage Class
can grow.

Name Specifies the name of this Storage Domain. This name must be
unique within the Oracle FS System.
Storage Domain names can consist of up to 82 UTF-8 printable
characters. The name cannot include the following characters:

• / (forward slash)
• \ (backward slash)
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• . (dot)
• .. (dot dot)
• tab

Background
Process
Priority

System
Chooses

(Default) Specifies that the system balances the
resources that are needed for background data
movement with the resources that are needed
to service the incoming client I/O.

Minimize
Impact

Specifies that the system restricts the amount of
system resources that are given to the
background data movement operation. This
option minimizes the impact on client I/O.
Recommended for highly‑loaded Storage
Domains.

Maximize
Speed

Specifies that the system grants resource
priority to the background data movement
operation. This option reduces the amount of
system resources that are available for client
I/O. Recommended for lightly‑loaded Storage
Domains.

Enable Tier
Reallocation

Specifies that any tiered data that resides in this Storage
Domain has data progression enabled. Individual objects might
have tier reallocation disabled. Enabling tier reallocation at the
Storage Domain level does not override any objects that have
tier reallocation disabled. The default value is enabled.

Enable Tier
Reallocation
Statistics
Collection

Collects data usage patterns for the Storage Domain internally
to analyze and determine the optimum storage classes for the
data. The default value is enabled. It is recommended you do
not change this setting unless you need to test different profiles.
Disable this setting if you are modifying your storage profile for
testing purposes and did not want to collect statistics during
the test. You do not want to collect tier reallocation statistics
during the test as this might distort future tier reallocation.
After you complete testing, enable tier reallocation statistics
collection.

Note: Enabling or disabling the tier reallocation statistics
collection has no effect on statistics you can view for CPU, drive
groups, Filesystems, or LUNs. (Those are a different set of
statistics.)

Auto‑Tier Scan Options (Advanced)
Optimizes the auto‑tier algorithm for moving data to different Storage Classes.
You can specify the interval for when auto‑tier moves frequently accessed data
blocks and infrequently accessed data blocks to match your application activity.
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Note: To unlock the auto‑tier scan options, select the lock icon. Selecting the lock
icon again resets the values to the state when the fields were unlocked.

Performance-
Optimizing
Scan Cycle

Specifies the frequency, in hours, that auto‑tier scans to move
frequently accessed data blocks to a high performance Storage
Class.
For example, a value of 32 means that every 32 hours auto‑tier
scans the system to move frequently accessed data blocks to a
high performance Storage Class.
Updates to this field affect the label of the Number of n‑hour
Scan Cycles field. For example, a value of 32 changes the label
for the Number of n‑hour Scan Cycles to Number of 32‑hour
Scan Cycles.
Enter a value from 1 through 168.

Number of
n‑hour Scan
Cycles

Specifies the frequency that auto‑tier runs the
performance‑optimizing scan cycles before auto‑tier runs the
cost‑optimizing scan cycle. The value entered in the Number
of n‑hour Scan Cycles field is multiplied by the value entered
in the Performance-Optimizing Scan Cycle field to obtain the
value set in the Cost-Optimizing Scan Cycle field.
For example, a value of 5 means that every fifth time that
auto‑tier runs the performance‑optimizing scan cycle, auto‑tier
then runs the cost‑optimizing scan cycle to move infrequently
accessed data to a less expensive storage class.
Enter a value from 2 through 31.

Cost-
Optimizing
Scan Cycle

(Read‑only) Displays the frequency, in hours, that auto‑tier
scans to move infrequently accessed data blocks to a less
expensive Storage Class.
The value displayed in this field is calculated as the product of
the value you entered in the Performance-Optimizing Scan
Cycle field and the value you entered in the Number of n-
hour Scan Cycles field.
For example, to set auto‑tier to move infrequently accessed
data blocks to a less expensive Storage Class every 200 hours,
enter the following values:

• Performance Optimizing Scan Cycle: 25
• Number of 25‑hour Scan Cycles: 8

The system displays 200 in the Cost-Optimizing Scan Cycle
field. In this example, the values that you enter instruct
auto‑tier to run the performance‑optimizing scan every 25
hours. Then, during every eighth scan cycle (or every 200
hours), auto‑tier runs a cost‑optimizing scan to move
infrequently accessed data blocks to a less expensive Storage
Class.
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Allowable Storage Capacity for Auto‑Tiered LUNs
Indicates the maximum percentage of storage capacity to dedicate to auto-tier
reallocation for each Storage Class of the Storage Domain. Enter a percentage for
each available Storage Class.

The default value is 100%.

Related Links
Limit the Storage Capacity for QoS Plus
Optimize Auto‑Tier Scans
Rename a Storage Domain
Update the Background Process Priority
Update Tier Reallocation Options

Modify System Time Dialog
Navigation: System > Global Settings > System Time > Actions > Modify

Changes the properties of the system time to synchronize the Oracle FS System
clock time with a Network Time Protocol (NTP) server or to set the date and time
manually.

Use External
Time Source

Identifies that the Oracle FS System synchronizes its clocks with
Network Time Protocol (NTP) servers. You can specify a
primary NTP server and up to two alternate NTP servers with
which the system synchronizes its clocks. Enter the IP addresses
assigned to the primary NTP server and up to two alternate NTP
servers into the following fields:

• NTP Server 1
• NTP Server 2
• NTP Server 3

If the primary NTP server is unavailable, the system polls the
alternate NTP servers in a round-robin fashion until the
Oracle FS System connects to an available NTP server. Enter IP
addresses or DNS names for up to two alternate NTP servers.

Use Internal
Hardware
Clock

Identifies that the Oracle FS System synchronizes its clocks with
a date and time that you set manually. Oracle FS System clocks
are synchronized with each other, and their time may differ from
other clocks in your network.

Date/Time Presents a wizard that allows you to set the Oracle FS System
date and time. The time that you set is converted internally to
the Coordinated Universal Time (abbreviated UTC) format.

Related Links
Modify the Oracle FS System Time
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Modify UPS Dialog
Navigation: System > Hardware > UPSs > Actions > Modify UPS

Changes the properties of a selected uninterruptible power supply (UPS) device.
For example, you can assign the UPS device to an alternate simple network
management protocol (SNMP) community string.

Name Identifies the name of the UPS device. UPS names must be
unique across the Oracle FS System and must be 256 or fewer
UTF‑8 characters.

IP Address Identifies the IP address that is assigned to the external UPS
device.

SNMP
Community

Identifies a community for which a specific trap host should
receive traps that the Oracle FS System generates. You can
specify different community strings for each trap host so that
multiple administrators can receive specific types of SNMP
traps. The default community string is public (lower case). It is
recommend you change the default community string.

Note: This community string entered here must match the
community string configured on the UPS device.

Current Status
Provides read‑only details and status about the UPS device.

Model Identifies the model number of the UPS device.

Firmware Revision Identifies the firmware version that is installed on the
UPS device.

Serial Number Identifies the serial number of the UPS device.

Power Source Identifies the source of the UPS power. Valid sources:

• AC (alternating current)
• Battery
• Unknown

Battery Status Identifies the status of the UPS batteries. Valid values:

• Normal
• Warning
• Critical
• Unknown

Communication
Status

Identifies the communication status between the UPS
device and the Oracle FS System system. Valid values:
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• OK
• Failed

Related Links
Modify a UPS Device

Networking Overview Page
Navigation: System > Global Settings > Networking

Lists the networking properties for the Oracle FS System.

Management Interface
DHCP
Enabled

Specifies whether the Dynamic Host Configuration Protocol
(DHCP) is enabled.

IP Address Identifies the public or the shared IP address that is assigned to
the Pilot. This IP address is what the administrator uses to
access the Oracle FS System over the management interface.

Subnet Mask Assigns the subnetwork mask for the public IP address that is
permanently assigned to the Pilot.

Gateway Assigns the IP address of the gateway network node in the
subnetwork of which the Oracle FS System (the Pilot) is a
member.

MAC
Address

Identifies the unique network identifier of the active Pilot node.
When a Pilot node fails, the passive node becomes the active
node. The MAC address changes to the unique network
identifier of the formerly passive node

Speed Identifies the actual port speed and duplex mode at which the
management interface is running.

DNS Settings
Primary DNS
Server

Identifies the IP address of the primary Domain Name
Server (DNS) that is used to resolve the IP addresses.

Secondary DNS
Server

Identifies the IP address of the secondary DNS server that
should be used if the primary DNS server cannot be
reached.

Notification
Email Enabled Identifies whether email is enabled to notify recipients

of system events.
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Email Server IP Identifies the IP address of the Simple Mail Transfer
Protocol (SMTP) server that receives system event
notifications.

Email Server Port Identifies the port that the SMTP server listens to for
incoming email requests.

Email Flood
Preventions

(Optional) Specifies the interval, in seconds, that the
Oracle FS System waits before sending event
notification emails to the administrator for the same
event.

Event Triggered Indicates whether event-triggered Call‑Home is
enabled.

Standard Periodic Indicates whether standard Call‑Home messages are
scheduled and enabled.

Larger Periodic Indicates whether larger Call‑Home messages are
scheduled and enabled.

Large Files Indicates whether large files are sent to the Call‑Home
server.

Call‑Home Matrix
Version

Indicates the revision level of the Call‑Home matrix.

iSCSI Connectivity and Communication
Device
Name

Identifies the name of the iSCSI initiator for the SAN host. An
initiator encapsulates SCSI commands and data requests within
iSCSI packets and transfers the packets across the IP network.

Device
Alias

Identifies an easily understood, alternative name for the iSCSI
device. By default, the device alias is constructed using the
Oracle FS System model plus the system serial number using the
following format:

• Oracle FS System <model‑number> SSN:<serial‑number>

Header
Digest

Identifies that the system is using iSCSI header digests.

Data
Digest

Identifies that the system is using iSCSI data digests.

iSNS Settings
iSNS Server
Registration

Identifies whether the Oracle FS System iSCSI targets
are registered in the iSNS server.
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iSCSI Security
Access
Control

Specifies that the Oracle FS System rejects iSCSI login attempts
from initiators that have not explicitly been granted permission
by the user through the Oracle FS System Manager interface or
Oracle FS CLI.

Authentication Identifies the authentication of the host (initiator) during login.

Authentication Server Indicates the server name used to authenticate the
iSCSI requests.

Bi-directional
CHAP Enabled

Identifies the status of the CHAP protocol for data
requests (from the iSCSI initiator) and request responses
(from the iSCSI target).

Pilot Overview Page
Navigation: System > Hardware > Pilots

Displays the status of the Pilots that are installed on the Oracle FS System.

Pilot Identifies the Pilot which is labeled either 1 or 2.

Status Displays the current status of the Pilot. A status of Normal
requires no action.

Mode Displays the current operational mode of the Pilot. Valid options:

Active Indicates which Pilot performs all configuration tasks
that administrators request.

Standby Indicates which Pilot acts as a secondary device and
does nothing unless the active Pilot fails over to this
standby Pilot.

OS Version Identifies the operating system version of the Pilot.

Server
Version

Identifies the software version installed on the Oracle FS System.

Serial
Number

Identifies the serial number that is assigned to the Pilot.

Note: The serial number for the Oracle FS System, which is a
different serial number than the Pilot serial number, is displayed
in the System Information panel.

Related Links
View the Properties of the Pilots

Remove from Storage Domain Dialog
Navigation: System > Storage Domains > Actions > Remove from Storage Domain
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Removes the selected drive group from a Storage Domain.

After a drive group is removed from a Storage Domain, the drive group is
displayed as unassigned. If you want to move a drive group from one Storage
Domain to another, remove the drive group from the Storage Domain and then
add the drive group to a different Storage Domain.

Note: Removing drive groups from Storage Domains can take many hours and
the system only processes one removal at a time. Therefore, it is recommended
that you select all drive groups you need to remove and remove the drive groups
in a single operation.

Migration
Policy

System
Chooses

(Default) Specifies that the system balances the
resources that are needed for background data
movement with the resources that are needed to
service the incoming client I/O.

Minimize
Impact

Specifies that the system restricts the amount of
system resources that are given to the background
data movement operation. This option minimizes
the impact on client I/O. Recommended for
highly‑loaded Storage Domains.

Maximize
Speed

Specifies that the system grants resource priority
to the background data movement operation. This
option reduces the amount of system resources
that are available for client I/O. Recommended for
lightly‑loaded Storage Domains.

Related Links
Remove Drive Groups From a Storage Domain

Reporting Schedules Overview Page
Navigation: System > Reporting and Statistics > Reporting Schedules

Manages reporting schedules. From this page you can create, delete, and modify
schedules.

Name Displays the user defined name of the schedule.

Report
Type

SAN Hosts Provides detailed configuration information
on the host servers and configured
components currently included in your
storage area network (SAN). The data
includes the SAN Host operating system,
Fibre Channel Initiator, Fibre Channel ports,
load balancing settings, LUNs, and other
information describing the SAN Hosts.

Storage
Performance

Provides performance information about the
LUNs on the Oracle FS System at the time the
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report was generated. The performance data
includes: read operations per second, write
operations per second, and total read and
write operations per second; read MB per
second, write MB per second, and total read
and write MB per second for each LUN.
Additional storage performance data,
including real-time statistics, is available for
each LUN from the SAN > Statistics and
Trending > LUNs feature.

Storage Use Provides capacity information on the storage
currently available on the Oracle FS System.
The data includes the total, allocated, free, and
preparing capacity for all available storage.
The data for total, allocated, free, and
preparing capacity is also presented per
storage class.

Storage Use per
Volume

Provides capacity information for each logical
volume on the Oracle FS System. The data
includes the allocated, maximum, and used
capacity per volume.

System
Configuration

Provides detailed information on the
configuration and current status of the
Oracle FS System and all of its components,
such as serial numbers, firmware versions,
ports, and status, for the Pilot, Controllers,
and Drive Enclosures.

Note: You might want to generate and archive
the System Configuration report as the report
provides a record of your system
configuration at the time the report was
generated. A record of system changes would
be useful for system planning and customer
support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers,
and Drive Enclosures information included in
the detailed System Configuration report. The
data includes the current status of the
components listed above and system
information.

Start Time Specifies the date and time to begin generating reports.

Frequency Specifies the frequency at which the schedule generates reports.
Frequencies include:
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• Run Once
• Hourly
• Daily
• Weekly

Enabled Specifies whether the scheduled report is active or inactive.
You can activate or deactivate a reporting schedule on the Modify
Reporting Schedule dialog. If you want to stop the report from
being generated, you can modify the report schedule to make the
report inactive by unchecking the Enable checkbox. If a schedule
is inactive, you can modify the schedule to make the report active
by checking the Enable checkbox.

Reporting and Statistics Overview Page
Navigation: System > Reporting and Statistics

Displays links to the Reporting Schedules Overview page and the Generated
Reports Overview page.

You can schedule a report to be generated at a specific time. You can also
generate real‑time reports.

The Oracle FS System collects the following information and makes the
information available in reports:

• Statistical information about SAN hosts

• Storage and performance information

• System configuration information

Scheduled
Reports

Opens the Reporting Schedules overview page. From this
page, you can view reports that are scheduled, modify
scheduled reports, and schedule a report to be generated at a
specific time.

Generated
Reports

Opens the Generated Reports overview page. From this page,
you can view reports, generate a real-time report, and
download reports to a location that you choose.

Drive Group
Statistics

Opens the Drive Group Statistics overview page. From this
page, you can generate and download drive group statistics to
a location that you choose.

CPU Statistics Opens the CPU Statistics overview page. From this page, you
can generate and download Controller CPU statistics to a
location that you choose.

Security Overview Page
Navigation: System > Global Settings > Security
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Lists the security configuration for administrator accounts. An administrator can
manage the security properties from this page.

Account Security
Consecutive
failed login
attempts allowed

Identifies the number of times that an administrator can
attempt, and fail, to log in to the Oracle FS System. When
the number of failed login attempts exceeds this limit, the
system locks out the account. Only the Primary system
administrator and administrators having the role of
Administrator 1 can unlock the account.

Session timeout
period (in
minutes) for all
administrators

Identifies an inactivity time limit, after which an
administrator session is terminated. Sessions in progress
continue to use the previous value and are not affected by
changes that you make. Sessions that start after you change
the value use the modified session time‑out value.
The default for the session time-out is 999 minutes.
After an administrator logs in, if the administrator is
inactive for a length of time equal to the session time-out
period, the Oracle FS System automatically logs the
account out of the system.
The session time-out period applies only to property
dialogs and popup windows in the Oracle FS System
Manager. The session time-out period does not apply to the
main window because of activity that occurs to verify the
system status and health.

Login Screen Message
Specifies a message that is displayed when system administrators log in to the
Oracle FS System. You can enter up to 256 Unicode characters.

Set Event Log Filter Dialog
Navigation: System > Alerts and Events > Event Log > Actions > Set Event Log
Filter

Creates and modifies the event filters that are configured on the Oracle FS
System system.

Event
Categories

Identifies a list of event categories. Choose from:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.
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System Events to notify of system problems, such
as a missing Drive Enclosure or
Controller.

Event
Severities

Identifies a list of event types. Choose from:

Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent system
failures or offline conditions.

Event Date
Range

Indicates whether to filter events by occurrence date.

Display Events
that occur in a
date range

Select this option to activate the Beginning
date and Ending date options. To filter the
events by type and by severity level only,
then clear this option.

Beginning date Specifies the date so that events that
occurred on or after this date, and that
match the selected filters, are displayed.

Ending date Specifies the date so that events that
occurred on or before this date, and that
match the selected filters, are displayed.

Reset to
Defaults

Resets the page to default values. Select this option to enable all
of the Event Severities and Event Categories and to clear any set
date range.

Related Links
Filter Event Log Entries

SNMP Hosts Overview Page
Navigation: System > Global Settings > SNMP

Displays whether any hosts were created to support the Simple Network
Management Protocol (SNMP) software feature.

This page provides options to modify the SNMP host settings and delete SNMP
hosts.

Name Identifies the name for the SNMP host.

Authorized Host
IP

Identifies the IP address or domain name of a client that
receives the Oracle FS System SNMP information.
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Community
String

Identifies the community string for use when the Oracle FS
System sends an event trap to the SNMP host.

Note: When an administrator does not specify a community
string for read-only access, SNMP servers and clients
typically use public.

Receives Traps Indicates that the SNMP host receives event traps sent to it.

Related Links
View SNMP Hosts

Status Summary Overview Page
Navigation: System > Alerts and Status > Status Summary

Displays the status and health of the Pilots, Controllers, and Drive Enclosures
that are installed on the Oracle FS System.

If a Replication Engine (Oracle MaxRep for SAN or Oracle MaxRep for NAS) is
configured for the Oracle FS System, information is also displayed about the
Replication Engine.

If a uninterruptible power supply (UPS) is configured for the Oracle FS System,
information is also displayed about the UPS.

Pilots
The Pilots table lists the following information:

Pilot Displays the operational status of the Pilot.

Mode Displays the current operational mode of the Pilot.

Active Indicates which server currently functions as the active Pilot
and performs all requested configuration tasks.

Standby Indicates which server currently functions as the standby
Pilot and only performs configuration tasks during a
failover.

Status Displays the status of a Pilot.

 (Normal) A Normal status requires no action.

 (Warning) A Warning status requires action.

 (Critical) A Critical status requires action.

Note: To obtain more information about the component status, select the
component.
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Controllers
The Controllers table lists the following information:

Controller
Name

Lists the names of hardware components.

Service Type Lists the type of Controller.

Status Identifies the status of the Controller.

 (Normal) A Normal status requires no action.

 (Warning) A Warning status requires action.

 (Critical) A Critical status requires action.

Note: To obtain more information about the component status, select the
component.

Replication Engines
Service Status Identifies the health of the processes running on the Replication

Engine.

Agent Status Identifies the communication status of the Oracle MaxRep for
SAN agents registered with the Oracle FS System.

Name Identifies the name of the Replication Engine.

IP Address Identifies the IP address of the Replication Engine or high
availability Replication Engine cluster.

UPSs
The uninterruptible power supply (UPS) table lists the following information:

Name Identifies the name assigned to the external UPS device.

Power Source Identifies the source of the UPS power. Valid sources:

• AC (alternating current)
• Battery
• Unknown

Battery Status Identifies the status of the UPS batteries. Valid values:

• Normal
• Warning
• Critical
• Unknown
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Drive Enclosures
The Drive Enclosures table lists the following information:

Drive Enclosure
Name

Lists the names of hardware components.

Status  (Normal) A Normal status requires no action.

 (Warning) A Warning status requires action.

 (Critical) A Critical status requires action.

Note: To obtain more information about the component status, select the
component.

Event Log
The Event Log table lists the following information:

Severity Displays the severity level of entries in the Oracle FS System
event log. Possible severity levels:

Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent system
failures or offline conditions.

Number of
Events

The number of events that have occurred on the Oracle FS
System.

Event Notification
The Event Notification table lists the following information:

Number of Recipients Indicates the total number of email recipients.

Disabled Email
Subscriptions

Indicates the number of event notifications that
are currently disabled.

Enabled Email Subscriptions Indicates the number of event notifications that
are currently enabled.

Number of Monitored
system Events

Indicates the number of monitored events.

Refresh
Updates the page with current data.
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Storage Domains Overview Page
Navigation: System > Storage Domains

Lists the properties of each Storage Domain that is defined on this Oracle FS
System.

Name Specifies the name of the Storage Domain and the names of the
drive groups that are assigned to the domain.

Note: The primary drive group in a Storage Domain is indicated
by this icon . The primary drive group contains system
configuration information.

Storage
Domain
Status

Provides the operating condition of the Storage Domain.
Status conditions include:

Normal Indicates that no action is required.

Background
Activity

Indicates that a process is running which
effects the Storage Domain. For example, if
you started a Compact Storage Domain
process, the Storage Domain status would
change from Normal to Background
Activity.

Drive Group
Status

Indicates the operating condition of the drive group.
Status conditions include:

Normal The drives are accessible and no action is
required.

Degraded
Warning

A drive has failed but this is not yet critical.
This applies only to double parity.

Degraded
Critical

Two or more drives have failed. The loss of
one more drive causes a failure.

Failed Multiple drives have failed. The drives are
offline and data may be lost.

Tier
Reallocation

Identifies the tier reallocation status of the Storage Domain.
When tier reallocation is enabled, the Oracle FS System
dedicates resources and uses statistical data and QoS priority
property to migrate data from one storage tier to another.
Valid states:

Enabled Indicates that the tier reallocation is active on
the Storage Domain. Enabled makes possible
the migration of high-usage data to higher
performing storage tiers in this Storage
Domain.
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Disabled Indicates that tier reallocation is not active on
the Storage Domain. Disabled does not allow
the migration of high-usage data to higher
performing storage tiers in this Storage
Domain.

Statistics
Collection
Disabled

Indicates that statistical data used by the
Oracle FS System to migrate the data is not
collected. Oracle recommends not using this
option as the statistical data is required for
the tier reallocation process.

Tier
reallocation
disabled

Indicates that the tier reallocation is not
active. The statistics collection is active.

Media Type Specifies the category of physical media that comprises the
drive group.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that
are optimized for the performance of capacity
and for read operations. The write
performance for this Storage Class is
sacrificed somewhat to achieve the
optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations
and of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include
tape storage as an option, this Storage Class
always provides the lowest cost for each GB
of capacity.

Enclosure
Chassis ID

Displays the numeric identifier of the Drive Enclosure. The
Enclosure Chassis ID is located and displayed on the front of
the Drive Enclosure. The numeric values range from 01 to 99;
the hexadecimal values from A0 to FF.
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Physical Capacity
Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Allocated Displays the amount of capacity that has been assigned and
designated to all logical volumes residing on the indicated
Storage Domain.

Free Displays the amount of capacity that is available for
allocation in the indicated Storage Domain.

Preparing Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Domain.

Total Capacity Displays the total amount of raw capacity provided by the
Drive Enclosures that are defined within the indicated
Storage Domain.

Physical
Distribution

Provides a graphical representation of the capacity that is
used compared to the maximum that is allocated

Storage Profiles Overview Page
Navigation: System > Global Settings > Storage Profiles

Lists the Quality of Service (QoS) settings for all of the available Storage Profiles
on the system. Administrators can manage custom profiles from this page.

Type Identifies the type of the Storage Profile.
Valid profile types:

Custom Indicates a Storage Profile that consists of
administrator‑defined QoS settings.

Note: Custom profiles cannot be modified.
Also, if a logical volume uses a custom
profile, that profile cannot be deleted.

System Indicates a Storage Profile that ships with the
Oracle FS System.

Note: System profiles cannot be modified or
deleted.
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Name Identifies the name of the Storage Profile. The name includes, in
some instances, the name of the application that is associated with
the profile.

RAID
Level

Identifies the storage mechanism that is used to enhance the ability
of the system to recover data from the loss of one or more drives.
Possible RAID levels:

Single parity Indicates that, in addition to the actual data,
one set of parity bits exists for the logical
volume. This parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the RAID 5
storage technology.

Double parity Indicates that, in addition to the actual data,
two sets of parity bits exist for the logical
volume. This parity level protects against the
loss of one or two drives with a slight cost to
write performance. Double parity is
implemented as a variant of the RAID 6
storage technology.

Mirrored Indicates that no parity bits exist for the
volume. Instead, the system writes the data in
two different locations. This RAID level
protects against the loss of at least one drive
and possibly more drives with an
improvement of the performance of random
write operations. Mirrored RAID is
implemented as a variant of the RAID 10
storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for sequential
read operations. The policy determines the amount of additional
data, if any, that the system places into the Controller cache. Valid
policies:

Normal Indicates that the input requests and
the output requests are accessing the
data mostly in a random manner or in
a mixed sequential and random
manner.

Aggressive Indicates that the input requests and
the output requests are accessing the
data mostly in a sequential manner
and that the workload is biased
toward read operations.

Conservative Indicates that the input requests and
the output requests are mostly
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sequential and that the workload is
biased toward write operations.

Priority Identifies the priority that the system gives to various operational
aspects of a logical volume, such as the Controller processing
queue. The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume. Identifies
as well where the data is striped on rotating drives. Valid priority
levels:

Premium Indicates the highest priority for responding to
requests in the processing queue.

High Indicates the next highest priority for responding to
requests in the processing queue.

Medium Indicates an intermediate priority for responding to
requests in the processing queue.

Low Indicates the next to lowest priority for responding to
requests in the processing queue.

Archive Indicates the lowest priority for responding to requests
in the processing queue.

Stripe
Width

Identifies the number of drive groups over which the data is
written.
Possible values:

1 through 64 Indicates the specified stripe width.

all Indicates that the logical volume is striped across
all of the available drive groups.

auto‑select Indicates that the Oracle FS System determines the
stripe width based on the Priority option that you
selected.

Writes Identifies the write‑caching rules to use for the profile.
Valid options:

Write-through Writes data to the Controller cache and
to the storage arrays before the write
request completes. This rule ensures
that the data is safely written to the
storage before the write request
returns to the application. Write‑
through caching performs more slowly
than does write‑back caching because
the data is being written to the storage
arrays as well as to the cache.
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Write-back caching Writes data to the Controller cache,
and the write request returns
immediately without waiting for the
write‑to‑disk to complete. During idle
cycles, the system writes the data from
the cache to the storage arrays. Write‑
back caching performs faster than does
write‑through because the data only
needs to be written to the cache before
the write request returns.

Important: If the system goes down
unexpectedly, the data in the cache
that has not been written to the storage
arrays could be lost.

During the shutdown process, the
system writes all cached data to the
storage arrays.

Default Indicates that the Oracle FS System
selects the appropriate write‑caching
rule based on the selected QoS
settings.

Preferred
Storage

Indicates the preferred order in which the Oracle FS System uses
the available Storage Classes.

System Alerts Overview Page
Navigation: System > Alerts and Events > System Alerts

Displays links that allow you to manage alerts that are generated when specific
events occur.

You can copy the system alert information to your workstation clipboard or
remove the alert as necessary.

Alert Identifies item that caused the system alert.

Time Occurred Indicates the date and time the system alert occurred.

Affected Items Identifies the name of the system object that caused the system
alert.

Description Provides a brief description of the system alert.

Related Links
Display the System Alerts
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System Information Page
Navigation: System > System Information

Displays the Oracle FS System information, including the name, administrator
contact information, and software version. The page also provides an overview
of the Controller configuration and the Storage Classes of the available Drive
Groups.

The administrator controls the following fields on this page:

• Name

• Description

• Location

• Contact Name

• Contact Phone

• Asset Number

Name Identifies the name that is assigned to the Oracle FS System.
The system name also appears in the status bar.

Description Displays the system description as defined by the system
administrator.

Model Displays the model number of Oracle FS System.

Status Displays the overall health status of the Oracle FS System.

Controllers Displays the number and service type of Controllers that are
installed in the system.
The Controller service types include:

• SAN Only
• NAS Only
• SAN and NAS with SAN bias
• SAN and NAS with NAS bias

Drive Groups Displays the available Storage Classes that are installed in
the system and the number of drives in each Storage Class.

Manufacturer Displays the manufacturer of the Oracle FS System.

Location Displays the system location as defined by the system
administrator.

Contact Name Displays the primary contact person as defined by the
system administrator.

Contact Phone Displays the phone number of the primary contact person as
defined by the system administrator.
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Asset Number Displays the system asset number as defined by the system
administrator.

Serial Number Identifies the system serial number (SSN) that Oracle
assigned to the system.

IP Address Identifies the public IP address of the Oracle FS System
management interface. This interface provides access to the
Oracle FS System Manager. The administrator provides this
IP address in the Interfaces tab of the Global Settings >
Networking page.

MAC Address Identifies the Media Access Control (MAC) address of the
currently active Pilot node.

Software Version Identifies the release level of the software and firmware
modules that manage the entire Oracle FS System.

System Time Overview Page
Navigation: System > Global Settings > System Time

Displays the system time and any Network Time Protocol (NTP) servers with
which the system clock is synchronized.

System Time Identifies the current Oracle FS System date, time, and time
zone.

NTP Servers Identifies whether the Oracle FS System synchronizes its clocks
with:

• Network Time Protocol (NTP) servers
• A manual time setting that you specify from the internal

hardware clock

UPSs Overview Page
Navigation: System > Hardware > UPSs

Displays the current status of the uninterruptible power supply (UPS) battery
and power.

The Oracle FS System retrieves information from each device using Simple
Network Management Protocol (SNMP) over the Pilot Ethernet connection to
monitor and report status. This page provides options to create and manage the
UPS devices connected to the Oracle FS System.

Name Identifies the name assigned to the external UPS device.

IP Address Identifies the IP address that is assigned to the external UPS
device.
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Model Identifies the model number of the UPS device.

Power Source Identifies the source of the UPS power. Valid sources:

• AC (alternating current)
• Battery
• Unknown

Battery Status Identifies the status of the UPS batteries. Valid values:

• Normal
• Warning
• Critical
• Unknown

View Administrator Account Dialog
Navigation: System > Global Settings > Administrator Accounts > Actions > View

Displays details about the selected account from the Administrator Accounts
list.

Login
Name

Identifies the login name assigned to the administrator account.
This field is limited to 20 characters.

Role Identifies the authorized privileges for an administrator account.
Different roles are authorized to perform different functions:

Administrator
1

The administrator role for a login account that
provides the authority to perform all
administrative tasks and all configuration tasks
except for certain tasks that are reserved for the
support roles.

Administrator
2

The administrator role for a login account that
provides the authority to perform most
administrative and configuration tasks. A login
account assigned to this role cannot, however,
perform the following tasks:

• Manage the administrator accounts and
other global system settings such as those
settings for networking, the Controller
ports, system security, and the system
time.

• Perform software upgrades or use Guided
Maintenance to replace hardware
components.

• Shut down the Oracle FS System system.
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Monitor An administrator role for login accounts that
provides the authority for those accounts to
perform read‑only management tasks and to
modify their own account properties.

Support A unique login account solely for support
representatives. This login account is not
authorized to modify or delete data resources,
system alerts, or administrator accounts.

Important: Use this account only if you are
familiar with it or instructed by Oracle
Customer Support.

For the following predefined roles, you cannot assign
administrators to them and you cannot delete them:

Primary system
administrator

A login account that has the same
privileges as the Administrator 1 role.

Primary support
administrator

A login account that has the same
privileges as the Monitor role, as well
as privileges to perform
support‑related tasks.

Full
Name

Identifies the first and last name associated with the administrator
account.

Email
Address

Identifies the email address associated with the administrator
account. The email username can have up to 64 characters and the
email domain can have up to 255 characters. The email server to
which the Oracle FS System sends alerts must be able to receive
messages at this address. The system does not validate this address.

Note: An IP address cannot be entered as the email domain.

Phone
Number

Identifies the phone number associated with the administrator
account. The Oracle FS System does not verify the validity of this
entry.

Disabled Indicates whether the administrative account is disabled. The
Oracle FS System maintains disabled accounts but does not allow
them to log in. A disabled account can be enabled later by
modifying it. This setting takes effect immediately. If the
administrator is logged in when you disable the account, the
system logs out the administrator immediately.

Note: You cannot disable the Primary system administrator
account.

Related Links
Display Administrator Account Details

System Tab Reference Pages

391



View Auto-Tier Graphs Dialog
Navigation: System > Storage Domains > Actions > View Auto-Tier Graphs

Displays graphically the effectiveness of the QoS Plus feature for a collection of
auto‑tiered LUNs.

Provides details about a collection of auto‑tiered LUNs in a Storage Domain. You
can select up to 10 LUNs to analyze.

Name Identifies the name that is assigned to the LUN.

LUID Identifies the unique identifier of the LUN.

Priority Level Identifies the assigned priority level of the volume at the time
that it was created.

Premium Indicates the highest priority for responding to
requests in the processing queue.

High Indicates the next highest priority for
responding to requests in the processing queue.

Medium Indicates an intermediate priority for
responding to requests in the processing queue.

Low Indicates the next to lowest priority for
responding to requests in the processing queue.

Archive Indicates the lowest priority for responding to
requests in the processing queue.

Capacity Disk
Capacity

Identifies the amount of capacity that is allocated to the auto‑
tiered LUNs that reside on RAID 6 and RAID 10 storage
tiers.

Performance
Disk Capacity

Identifies the amount of capacity that is allocated to the auto‑
tiered LUNs that reside on RAID 5 and RAID 10 storage
tiers.

Capacity SSD
Capacity

Identifies the amount of capacity that is allocated to the auto‑
tiered LUNs that reside on RAID 5 and RAID 10 storage
tiers.

Performance
SSD Capacity

Identifies the amount of capacity that is allocated to the auto‑
tiered LUNs that reside on RAID 5 and RAID 10 storage
tiers.

Displays two graphs: a graph that depicts the number of data migration
calculations that the system performed and another graph that summarizes the
capacities by Storage Class.

Update
Graphs

Creates the following graphs that are based on the data from the
selected auto‑tiered LUNs. Click Update Graphs to refresh the
contents of the graphs.
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Data Transferred By
Number of Accesses

Indicates a histogram of the different
regions of all of the LUNs in the Storage
Domain by the frequency of I/O
access.The histogram bar height
represents the amount of data
transferred. The y‑axis is not labeled.

Tier Structure By
Storage Class and
Priority

Indicates a graph of the Storage Class
and the capacity of the LUN regions for
the selected auto‑tiered LUNs. The chart
also shows a number that represents the
QoS priority for the auto‑tiered LUN. A
table at the bottom of the chart provides
the list of selected LUNs. The table is
also a legend for the LUNs that are
represented on the graph.

Related Links
View the Auto-Tier Graphs

View Controller, Components Tab
Navigation: System > Hardware > Controllers > Actions > View > Components

Displays the status of the selected Controller and the components.

If there is a hardware failure, select the component and click Replace
Component. Oracle FS System Manager (GUI) starts Guided Maintenance.
Guided Maintenance presents you with a sequence of dialogs that guides you
through the process of replacing a component.

Note: For more information about Guided Maintenance, refer to Oracle FS1-2
Flash Storage System Field Service Guide.

Comment Displays descriptive text that is associated with a Controller. A
comment can include up to 256 characters.

Identifier Displays the World Wide Number (WWN) associated with a
Controller.

Memory Displays the amount of random access memory (RAM)
provided by the DIMMs configured in the Controller.

Model Displays the model number of the Controller.

Replaceable
Unit

Lists the Controller components that are replaceable through
Guided Maintenance. Select a component, and then click
Replace Component to start Guided Maintenance.

Note: For fan replacement, the Replaceable Unit list displays
the names of each fan. Each power supply contains one fan,
and each fan module contains two fans. If a fan fails in a power
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supply, replace the power supply. If a fan fails in a fan module,
replace the fan module. The following list identifies the names
of the fans and the corresponding customer replaceable unit
(CRU).

If the following fan fails Replace the following CRU
Fan 0 Power supply 0
Fan 1 Power supply 1
Fans 2, 3 Fan module 0
Fans 4, 5 Fan module 1
Fans 6, 7 Fan module 2
Fans 8, 9 Fan module 3
Fans 10, 11 Fan module 4

Status Displays the current status of a hardware component. A status
of Normal requires no action.

Related Links
View the Details of a Controller

View Controller, I/O Ports Tab
Navigation: System > Hardware > Controllers > Actions > View > I/O Ports

Displays I/O port information for the selected Controller.

Slot Location of the HBA installed on the Controller
Port HBA port number.
Connection
Type

Identifies the types of network ports for data path traffic
between the customer network switches and the Controllers:

Copper Identifies copper interfaces.

Long Wave Optical Identifies longwave optical small form‑
factor pluggable (SFP) transceiver
interfaces.

Short Wave
Optical

Identifies shortwave optical SFP
transceiver interfaces.

Unknown Indicates that the connection type cannot
be determined.

Status Identifies the connection state between the HBA port and
Controller.
Possible states:
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Connected Indicates that the HBA port on the host is
connected to the port on the Controller.
In most operating systems, host ports log in to
the Controller ports immediately after the two
are physically connected and enabled and
remain logged in until the physical connection
is broken. So, Connected effectively means that
there is an enabled physical connection between
the ports.

Not
Connected

Indicates that the HBA port on the host is not
connected to the port on the Controller.

Note: On HP‑UX platforms, however, some HBA device drivers
use a different approach. These drivers log out of the
connection when there is no traffic to send. The HP‑UX initiator
often logs out when the initiator does not discover any
accessible LUNs attached to the target port. For these reasons,
an HP‑UX HBA port often shows as Not Connected even
though there is an enabled physical connection between the
ports.

Bandwidth Displays the data rate of the port interface.

SFP Status Displays the status of the SFP transceiver.

• Bypassed
• Bypassed-No SFP
• Bypassed-Incorrect Speed
• Bypassed-Read Error
• Bypassed-Incorrect Type
• Bypassed-Lost Sync

If the interface module itself should fail, the SFP status shows
Hardware Failure.

SFP Vendor Displays the vendor's part number for the SFP. If that
information is not available, the system displays Unknown.

SFP Part
Number

Displays the vendor's part number for the SFP. If that
information is not available, the field is blank or displays
Unknown.

SFP Revision Displays the part revision number for the SFP. If that
information is not available, the field is blank or displays
Unknown.

Related Links
View the Details of a Controller
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View Controller Port Settings, Ethernet Tab
Navigation: System > Global Settings > Controller Ports > Actions > View Port
Settings > Ethernet

Displays the Controller Ethernet port properties.

Port Information
Controller Name Identifies the name of the Controller.

Slot Number Identifies the Controller HBA slot number.

Port Number Identifies the HBA port number.

Status Identifies the HBA connection status.
Valid states:

• Connected
• Not connected
• Offline

Type Indicates the type of HBA.
Valid types:

• Ethernet
• Fibre Channel (FC)
• Internet SCSI (Small Computer System Interface)

(iSCSI)
• Serial Attached SCSI (SAS)

Negotiated Speed Indicates the port transmission speed in Gigabits each
second.

Maximum Speed Indicates the maximum speed of the port.

Ethernet Information
MAC Address Identifies the unique identifier of the HBA port.

MTU Bytes
Maximum

Indicates the maximum number of bytes supported by
the maximum transmission unit (MTU).

MTU Bytes
Minimum

Indicates the minimum number of bytes supported by
the maximum transmission unit (MTU).

SFP Information
Status Identifies the small form‑factor pluggable (SFP) device port

status.
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Valid SFP device states:

• Enabled 1 Gb
• Enabled 2 Gb
• Enabled 4 Gb
• Enabled 8 Gb
• Enabled 10 Gb
• Enabled 16 Gb
• No SFP
• Incorrect Speed
• Read Error
• Incorrect Type
• Loss of Sync
• Other

Connection
Type

Identifies the types of SFP transceiver interface devices used
for data path traffic between the customer network switches
and the Controllers.
Valid SFP interface types:

• Copper
• Optical
• Long Wave Optical
• Short Wave Optical

Vendor Identifies the SFP device manufacturer.

Part Number Identifies the SFP device part number.

Revision Identifies the SFP device revision number.

Related Links
View the Port Details for a Controller

View Controller Port Settings, Fibre Channel Tab
Navigation: System > Global Settings > Controller Ports > Actions > View Port
Settings > Fibre Channel

Displays the Controller Fibre Channel port properties.

Port Information
Controller Name Identifies the name of the Controller.

Slot Identifies the Controller HBA slot number.
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Port Identifies the HBA port number.

Status Identifies the HBA connection status.
Valid states:

• Connected
• Not connected
• Offline

Type Indicates the type of HBA.
Valid types:

• Ethernet
• Fibre Channel (FC)
• Internet SCSI (Small Computer System Interface)

(iSCSI)
• Serial Attached SCSI (SAS)

Negotiated Speed Indicates the port transmission speed in Gigabits each
second.

Maximum Speed Indicates the maximum speed of the port.

Fibre Channel Information
Address Identifies the unique address of the Oracle FS System Controller port

on the network.

Topology Identifies the FC transport topology in use by the ports in the
network interface module (NIM) to connect to the storage area
network (SAN) employed by the customer.
Valid types:

Fabric Indicates that the port is an N_Port in a
switched fabric (FC‑SW).

Loop Indicates that the port is an NL_Port in an
arbitrated loop (FC‑AL).

Point‑to‑Point Indicates that the port is an N_Port that is
connected to another N_Port, back to back
(FC‑P2P).

Public Loop Indicates that the port is an NL_Port that is
connected to a loop in which one port in the
loop is an FL_Port in the fabric (FC‑FLA).

Note: The topology used by the Backend SAS
Interconnect between the Controllers and the
Drive Enclosure is private and not reported.
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SFP Information
Status Identifies the small form‑factor pluggable (SFP) device port

status.
Valid SFP device states:

• Enabled 1 Gb
• Enabled 2 Gb
• Enabled 4 Gb
• Enabled 8 Gb
• Enabled 10 Gb
• Enabled 16 Gb
• No SFP
• Incorrect Speed
• Read Error
• Incorrect Type
• Loss of Sync
• Other

Connection
Type

Identifies the types of SFP transceiver interface devices used
for data path traffic between the customer network switches
and the Controllers.
Valid SFP interface types:

• Copper
• Optical
• Long Wave Optical
• Short Wave Optical

Vendor Identifies the SFP device manufacturer.

Part Number Identifies the SFP device part number.

Revision Identifies the SFP device revision number.

Related Links
View the Port Details for a Controller

View Controller Port Settings, iSCSI Tab
Navigation: System > Global Settings > Controller Ports > Actions > View Port
Settings > iSCSI
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Displays the Controller iSCSI port properties.

Port Information
Controller Name Identifies the name of the Controller.

Slot Identifies the Controller HBA slot number.

Port Identifies the HBA port number.

Status Identifies the HBA connection status.
Valid states:

• Connected
• Not connected
• Offline

Type Indicates the type of HBA.

Negotiated Speed Indicates the port transmission speed in Gigabits each
second.

Maximum Speed Indicates the maximum speed of the port.

iSCSI Information
MAC Address Identifies the unique identifier of the HBA port.

Portal Group Tag Identifies the iSCSI target portal group tag that is assigned
to the port.

Link Up Indicates the iSCSI port link up status.
Valid states:

• No
• Yes

iSNS Client Status Indicates the iSNS client status for the iSCSI port.
Valid states:

• Access lost
• Established
• In progress
• Unknown

MTU Bytes
Minimum

Indicates the minimum number of bytes supported by the
maximum transmission unit (MTU).

MTU Bytes
Maximum

Indicates the maximum number of bytes supported by the
maximum transmission unit (MTU).
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iSCSI Settings
IP Address
Assignment

Identifies the configuration method that the Oracle FS
System uses to obtain the IP address of the HBA port.
Valid methods:

DHCP Indicates that the DHCP server
automatically assigns the IP
addresses to network clients.

Static Indicates that a permanent IP address
is assigned to the network client.

IP Address Identifies the IP address that is assigned to the Oracle FS
System.

Netmask Identifies the netmask that is assigned to the Oracle FS
System.

Gateway Identifies the gateway IP address that is assigned to the
Oracle FS System.

TCP Port Identifies the Transmission Control Protocol (TCP) port
number that is configured on the iSCSI port.

VLAN Enabled Signifies whether a virtual LAN (VLAN) has been defined
for the iSCSI network.

VLAN ID Identifies the group portal tag number.

MTU Identifies the maximum transmission unit (MTU) value for
the Controller node.

SFP Information
Status Identifies the small form‑factor pluggable (SFP) device port

status.
Valid SFP device states:

• Enabled 1 Gb
• Enabled 2 Gb
• Enabled 4 Gb
• Enabled 8 Gb
• Enabled 10 Gb
• Enabled 16 Gb
• No SFP
• Incorrect Speed
• Read Error
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• Incorrect Type
• Loss of Sync
• Other

Connection
Type

Identifies the types of SFP transceiver interface devices used
for data path traffic between the customer network switches
and the Controllers.
Valid SFP interface types:

• Copper
• Optical
• Long Wave Optical
• Short Wave Optical

Vendor Identifies the SFP device manufacturer.

Part Number Identifies the SFP device part number.

Revision Identifies the SFP device revision number.

Related Links
View the Port Details for a Controller

View Controller Port Settings, SAS Tab
Navigation: System > Global Settings > Controller Ports > Actions > View Port
Settings > SAS

Displays the Controller SAS port properties.

Port Information
Controller Name Identifies the name of the Controller.

Slot Identifies the Controller HBA slot number.

Port Identifies the HBA port number.

Status Identifies the HBA connection status.
Valid states:

• Connected
• Not connected
• Offline

Type Indicates the type of HBA.

Negotiated Speed Indicates the port transmission speed in Gigabits each
second.
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Maximum Speed Indicates the maximum speed of the port.

WWN Identifies the world‑wide name (WWN) of the Controller
port.

Related Links
View the Port Details for a Controller

View Drive Enclosure, Components Tab
Navigation: System > Hardware > Drive Enclosures > Actions > View >
Components

Displays status of the selected Drive Enclosure, and its components including
chassis, drives, I/O modules, and power control modules.

Comment Identifies a descriptive name that is assigned to a hardware
component.

Model Indicates the model number of the Drive Enclosure in which the
drive resides.

Serial
Number

Indicates the serial number of the selected Drive Enclosure.

Drive
Enclosure ID

Indicates the unique identifier (the World Wide Name) of the
selected Drive Enclosure.

Perform
Automatic
Drive
Enclosure
Operations

Indicates whether data protection operations, such as copyback,
copy-away, and rebuild run in the background, as necessary.
This option is deselected under the direction of Oracle Customer
Support or as directed in a My Oracle Support (MOS)
Knowledge Article.

Replaceable
Unit

Indicates the Drive Enclosure components that are replaceable.

Status
(Chassis)

Provides the operational state of the Drive Enclosure chassis.
Oracle FS System Manager (GUI) displays a status icon followed
by the chassis state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal chassis status:

Normal The chassis is operating normally.

 (Warning) The following operational states are associated
with a warning chassis status:

Unknown The system is unable to read
the chassis state.
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Status
(Drives)

Provides the operational state of the drive in the drive group.
Oracle FS System Manager (GUI) displays a status icon followed
by the drive state.
Possible states, by status icon:

(Normal)
The following operational states are associated
with a normal drive status:

Normal The drive is a member of the
drive group.

Not Used The drive is operating normally,
but is not a member of a drive
group.

(Warning)
The following operational states are associated
with a warning drive status:

Booting The drive is starting up.

Copy Away
Source

The system has detected a
failure on the drive and is
currently copying the data
to a target drive. The drive
state changes to Failed
when copying is complete.

Copy Away
Target

The system has detected a
failure on another drive and
is currently copying the
data to this target drive.

Copyback An active spare drive is
copying data to this drive.

Degraded
Connectivity

The connection to the drive
is limited to only a single
Controller.

Foreign The drive is not a member
of this drive group. Accept
this drive using the
associated System Alert to
make the drive a member of
the drive group.

Missing The drive is not found in the
Drive Enclosure.

Rebuilding The drive is a target of a
rebuild operation for a drive
group.
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Recovered The drive has failure
history, but is now online
and is not a member of a
drive group.

Recovered In
Use

The drive has failure
history. The drive is now
online and is a member of a
drive group.

Shutdown The system is in shutdown
mode and cannot access the
drive.

Unknown The system is unable to read
the drive state.

(Critical)
The following operational states are associated
with a critical drive status:

Critical The drive has experienced a failure.

Restore The drive is currently being
restored.

Status (I/O
modules)

Provides the operational state of the I/O module in the drive
group. Oracle FS System Manager (GUI) displays a status icon
followed by the I/O module state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal I/O module status:

Normal The I/O module is operating
normally.

(Warning)
The following operational states are associated
with a warning I/O module status:

Offline The I/O module is offline.

Missing The I/O module is not found in
the Drive Enclosure.

Unknown The system is unable to read the
I/O module state.

 (Critical) The following operational states are associated
with a critical I/O module status:

Critical The I/O module has experienced a
failure.
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Status
(Power
Cooling
Module)

Provides the operational state of the Drive Enclosure power
cooling module. Oracle FS System Manager (GUI) displays a
status icon followed by the power cooling module state.
Possible states, by status icon:

 (Normal) The following operational states are associated
with a normal power cooling module status:

Normal The power cooling module is
operating normally.

(Warning)
The following operational states are associated
with a warning power cooling module status:

Offline The system reports that the
power cooling module is failed
or is disabled.

Missing The power cooling module is
not found in the Drive
Enclosure.

Warning The power cooling module is
functioning but shows signs of
failure.

Unknown The system is unable to read the
power cooling module state.

 (Critical) The following operational states are associated
with a critical power cooling module status:

Critical The power cooling module has
experienced a failure.

The system displays details about the selected replaceable component.

Chassis
information

Provides detailed information about the selected chassis.

Number Indicates the number that uniquely identifies
the chassis within the Drive Enclosure.

Status Indicates the operational state of the
component.

Part Number Indicates the manufacturer part number of the
component.

Serial Number Indicates the serial number of the component.

Drive
information

Provides detailed information about the selected drive.

Status Indicates the operational state of the drive.
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Model Indicates the manufacturers model number of
the drive.

Serial
Number

Indicates the serial number of the drive.

Firmware
Number

Indicates the firmware version number of the
drive.

Drive Slot
Number

Indicates the Drive Enclosure slot number
where the drive is installed.

Storage
Class

Specifies the category of physical media that
comprises the drive group.
Valid media types:

Performance
SSD

Specifies that the data is
stored on solid state drives
(SSDs) that are optimized for
the performance of balanced
read and write operations.

Capacity
SSD

Specifies that the data is
stored on SSDs that are
optimized for the
performance of capacity and
for read operations. The
write performance for this
Storage Class is sacrificed
somewhat to achieve the
optimizations for read
performance and for
capacity.

Performance
Disk

Specifies that the data is
stored on high‑speed hard
disk drives (HDDs). This
Storage Class sacrifices some
capacity to reduce the access
time and the latency of the
read operations and of the
write operations.

Capacity
Disk

Specifies that the data is
stored on high‑capacity,
rotating HDDs. This Storage
Class optimizes capacity at
some sacrifice of speed. For a
storage system that does not
include tape storage as an
option, this Storage Class
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always provides the lowest
cost for each GB of capacity.

Drive
Enclosure

Indicates the unique identifier of the Drive
Enclosure.

Drive
Capacity

Indicates the storage capacity of the drive.

Remaining
Life
Expectancy

(SSD only) Indicates the remaining months in
the life of the drive.

I/O Module
information

Provides detailed information about the selected I/O module.

Number Indicates the number that uniquely identifies
the I/O module within the Drive Enclosure.

Status Indicates the operational state of the I/O
module.

Part Number Indicates the manufacturer part number of
the I/O module.

Serial Number Indicates the serial number of the I/O
module.

Firmware
Number

Indicates the firmware version number of the
I/O module.

Power
Cooling
Module
information

Provides detailed information about the selected Power Cooling
Module.

Status Indicates the operational state of the Power
Cooling Module.

Model Indicates the manufacturer model number of
the Power Cooling Module.

Serial Number Indicates the serial number of the Power
Cooling Module.

Number of
Fans

Indicates the number of cooling fans in the
Power Cooling Module.

Number of
Failed Fans

Indicates the number of failed cooling fans in
the Power Cooling Module.

Related Links
View the Details of a Drive Enclosure

View Drive Enclosure, I/O Ports Tab
Navigation: System > Hardware > Drive Enclosures > Actions > View  > I/O Ports
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Displays the status of I/O ports of the Serial Attached SCSI (SAS) of the selected
Drive Enclosure.

Port Lists the PHYs that are associated with the I/O module port.

Phy State Indicates the state of the PHY connection. A wide port has two
or more of the PHY states indicate Link Up. A narrow port has
only one PHY state is Link Up.
Possible states:

Link Up Indicates that the PHY connection is
functioning properly.

Link Down Indicates that the PHY connection is
disconnected.

Disabled Indicates that the PHY connection is disabled.

Reset Indicates that the system is resetting the PHY
connection.

Negotiated
Speed

Indicates the port transmission speed in Gigabits each second.

Maximum
Speed

Indicates the maximum speed of the port.

Related Links
View the Details of a Drive Enclosure

View Drive Group Dialog
Navigation:

• System > Storage Domains > Actions > View Drive Group

• System > Hardware > Drive Groups > Actions > View

Displays information about the drive group.

Replaceable Unit
Replaceable
Unit

Displays the drives available in a drive group. The details about
a selected drive are displayed on the right-hand side of the
dialog.

Status
(Drives)

Provides the operational state of the drive in the drive group.
Oracle FS System Manager (GUI) displays a status icon
followed by the drive state.
Possible states, by status icon:

(Normal)
The following operational states are associated
with a normal drive status:
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Normal The drive is a member of the
drive group.

Not Used The drive is operating normally,
but is not a member of a drive
group.

(Warning)
The following operational states are associated
with a warning drive status:

Booting The drive is starting up.

Copy Away
Source

The system has detected a
failure on the drive and is
currently copying the data
to a target drive. The drive
state changes to Failed
when copying is complete.

Copy Away
Target

The system has detected a
failure on another drive and
is currently copying the
data to this target drive.

Copyback An active spare drive is
copying data to this drive.

Degraded
Connectivity

The connection to the drive
is limited to only a single
Controller.

Foreign The drive is not a member
of this drive group. Accept
this drive using the
associated System Alert to
make the drive a member of
the drive group.

Missing The drive is not found in
the Drive Enclosure.

Rebuilding The drive is a target of a
rebuild operation for a
drive group.

Recovered The drive has failure
history, but is now online
and is not a member of a
drive group.

Recovered In
Use

The drive has failure
history. The drive is now
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online and is a member of a
drive group.

Shutdown The system is in shutdown
mode and cannot access the
drive.

Unknown The system is unable to
read the drive state.

(Critical)
The following operational states are associated
with a critical drive status:

Critical The drive has experienced a failure.

Restore The drive is currently being
restored.

Make this
drive group
the primary
drive group

Make the drive group the primary drive group within the Drive
Enclosure. The primary drive group contains system
configuration data.

RAID Levels and Status
RAID
Level

Indicates the types of RAID data protection that is provided by the
selected drive group.
Each entry in the table represents a particular set of minimum
allocation units (MAUs) in the drive group. Each of the MAUs in a
given set has the same level of RAID protection, forming a RAID
protection segment for the drive group.
If a drive goes offline, the event affects all of the MAUs in the
protection segment in the same way. Therefore, the reported status for
a given RAID level applies to the entire protection segment.

Single
Parity

Indicates that each of the MAUs in the RAID protection
segment uses one set of parity bits to protect against the
loss of one drive in the drive group. Single parity is
implemented as a variant of the RAID 5 storage
technology.

Double
Parity

Indicates that each of the MAUs in the RAID protection
segment uses two sets of parity bits to protect against
the loss of one or two drives in the drive group. Double
parity is implemented as a variant of the RAID 6
storage technology.

Mirrored Indicates that each of the MAUs in the RAID protection
segment is written across two drives in the drive group.
Mirrored RAID is implemented as a variant of the
RAID 10 storage technology.
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RAID
Status

Possible states:

Normal Indicates that the drive group is accessible and no
action is required.

Degraded
Warning

Indicates that the drive has failed in the drive group,
but the drive group is still accessible. Replace the
failed drive. If the drive group is the primary drive
group, then replace the drive immediately. The
primary drive group contains system overhead,
including all system configuration data.

Degraded
Critical

Indicates that two or more of the drives have failed.
The drive group can become inaccessible unless you
replace the drives.

Failed Indicates that multiple drives have failed. The drive
group is not accessible. Replace the failed drives.
After the failed drives are replaced, the drive group
becomes accessible.

Unknown Indicates that the drive status information is not
available to display.

View Event Notification Dialog
Navigation: System > Alerts and Events > Event Notification > Actions > View

Displays event notices.

When an event is triggered, the Oracle FS System sends a notification to the
designated email recipients.

Name Displays the user‑defined name of the event notification.

Description Displays the user‑defined description of the event
notification.

Enable Event
Notification

Displays whether the event notification is enabled. When
checked, this option activates the notification when the
event occurs on the Oracle FS System.

Event Notification
Recipient Email
Addresses

Displays the email addresses of the recipients who are to
receive event notifications. The email server to which the
Oracle FS System sends notifications must be able to send
messages to these email addresses.

Monitored Events
By severity,
then category

Sorts the list of events by severity with a list of event
categories. The severity categories include:
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Informational Requires no action for events that are
information only.

Warning Requires no immediate action for minor
conditions that you can address at your
convenience.

Critical Requires prompt action to prevent
system failures or offline conditions.

By category,
then severity

Sorts the list of events by categories with a list of event severity.
The categories include:

Security Events to notify of a security problem,
such as an unauthorized request.

Audit Events that track what users are doing,
such as the operations that they
performed.

System Events to notify of system problems,
such as a missing Drive Enclosure or
Controller.

Events Not
Monitored

Displays the list of events not set to be monitored. The
Oracle FS System does not trigger a notification when an event
listed occurs.

Monitored
Events

Displays the list of events that you specified to be monitored.
The Oracle FS System triggers a notification each time an event
that you specified occurs. The email addresses specified in the
Event Notification Recipient Email Addresses field receive
the event notifications.

Related Links
Display the Event Notification Details

View Pilot Dialog
Navigation: System > Hardware > Pilots > Actions > View Pilot

Displays the status of the selected Pilot management controller that is installed
on the Oracle FS System.

Control Unit
Number

Identifies the node of the Pilot, which is either 1 or 2.

Operation Mode Displays the current operational mode of the Pilot.
Possible modes:
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Active Indicates which Pilot performs all
configuration tasks that administrators
request.

Standby Indicates which Pilot acts as a
secondary (passive) device and if the
active Pilot fails over to this standby
Pilot. The passive Pilot monitors the
health of the active Pilot and
Controller but is not active in
managing the data resources of the
Oracle FS System.

Unknown Indicates that the Pilot operational
state could not be determined.

Status Displays the current operational state of the Pilot.
Possible states:

Normal Indicates that the Pilot is operating
normally.

Warning Indicates that the Pilot has a minor
error that requires attention at your
earliest convenience.

Critical Indicates that the Pilot has a major
error that requires prompt action.

Booting Indicates that the Pilot is starting up.

Upgrading Indicates that the Pilot firmware is
being updated.

Shutdown Indicates that the Pilot is shutting
down.

Configuration
Server Status

Indicates the state of the configuration server that runs from
the active Pilot.

Pilot Network Connectivity
Provides the port status of the following network interfaces for the Pilot.

Ethernet 0 Indicates the connectivity status of the PilottoPilot interface
connection.
Possible states:

Connected Indicates that the port connection is
normal and no administrator action is
required.

Not Connected Indicates that the port cannot connect.
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Unknown Connection state cannot be determined.

Ethernet 1 Indicates the connectivity status of the PilottoController
interface connection.
Possible states:

Connected Indicates that the port connection is
normal and no administrator action is
required.

Not Connected Indicates that the port cannot connect.

Unknown Connection state cannot be determined.

Management Indicates the connectivity status of the external management
network.
Possible states:

Connected Indicates that the port connection is
normal and no administrator action is
required.

Not Connected Indicates that the port cannot connect.

Unknown Connection state cannot be determined.

Serial Indicates the connectivity status of the internal Pilot‑to‑Pilot
communication.
Possible states:

Connected Indicates that the port connection is
normal and no administrator action is
required.

Not Connected Indicates that the port cannot connect.

Unknown Connection state cannot be determined.

Service Port Indicates the connectivity status of the service port, which is
reserved for Oracle use.
Possible states:

Connected Indicates that the port connection is
normal and no administrator action is
required.

Not Connected Indicates that the port cannot connect.

Unknown Connection state cannot be determined.

Consistency of
Status

Identifies the connection reliability of the network interfaces.
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Possible states:

Consistent Indicates that the connection is reliable.

Inconsistent Indicates that the connection is not reliable.
You will need to perform troubleshooting to
resolve the problem. Inconsistent status might
not be caused by network issues, particularly
on the Ethernet and the Serial ports.

Related Links
View the Network Connectivity of a Pilot

View Reporting Schedule Dialog
Navigation: System > Reporting and Statistics > Reporting Schedules > Actions >
View Schedule

Displays details about the selected reporting schedule.

Schedule
Name

Displays the user defined name of the schedule.

Report Type SAN Hosts Provides detailed configuration information
on the host servers and configured
components currently included in your
storage area network (SAN). The data
includes the SAN Host operating system,
Fibre Channel Initiator, Fibre Channel ports,
load balancing settings, LUNs, and other
information describing the SAN Hosts.

Storage
Performance

Provides performance information about the
LUNs on the Oracle FS System at the time the
report was generated. The performance data
includes: read operations per second, write
operations per second, and total read and
write operations per second; read MB per
second, write MB per second, and total read
and write MB per second for each LUN.
Additional storage performance data,
including real-time statistics, is available for
each LUN from the SAN > Statistics and
Trending > LUNs feature.

Storage Use Provides capacity information on the storage
currently available on the Oracle FS System.
The data includes the total, allocated, free,
and preparing capacity for all available
storage. The data for total, allocated, free,
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and preparing capacity is also presented per
storage class.

Storage Use per
Volume

Provides capacity information for each
logical volume on the Oracle FS System. The
data includes the allocated, maximum, and
used capacity per volume.

System
Configuration

Provides detailed information on the
configuration and current status of the
Oracle FS System and all of its components,
such as serial numbers, firmware versions,
ports, and status, for the Pilot, Controllers,
and Drive Enclosures.

Note: You might want to generate and
archive the System Configuration report as the
report provides a record of your system
configuration at the time the report was
generated. A record of system changes would
be useful for system planning and customer
support.

System
Configuration
Summary

Provides a summary of the Pilot, Controllers,
and Drive Enclosures information included
in the detailed System Configuration report.
The data includes the current status of the
components listed above and system
information.

Enabled Specifies whether the scheduled report is active or inactive. To
make a scheduled report active, check the Enable checkbox. If
you do not want the scheduled report to be active, do not check
the Enable checkbox. The scheduled report is still listed under
Reporting Schedule but reports are not generated.

Start Time Specifies the date and time to begin generating reports.

Schedule
Frequency

Specifies the frequency at which the schedule generates reports.
Frequencies include:

• Run Once
• Hourly
• Daily
• Weekly

Recurrence Specifies how many hours, days, or weeks to wait before
generating this scheduled report again. You can also specify a
specific day on which you want the report to be generated.

Related Links
View a Reporting Schedule
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View SNMP Host Dialog
Navigation: System > Global Settings > SNMP > Actions > View SNMP Host

Displays information about the selected Simple Network Management Protocol
(SNMP) trap hosts.

Name Identifies the name for the SNMP host.

Host IP Identifies the IP address or domain name of a client that
receives the Oracle FS System SNMP information.

Community
string

Identifies the community string for use when the Oracle FS
System sends an event trap to the SNMP host.

Note: When an administrator does not specify a community
string for read-only access, SNMP servers and clients
typically use public.

Receive traps Indicates that the SNMP host receives event traps sent to it.

Severity
threshold

Identifies the severity threshold for events that the system
sends to the SNMP host by event traps.
Severity levels:

• Informational
• Warning
• Critical

Related Links
View SNMP Hosts

View Storage Allocation Details Dialog
Navigation: System > Storage Domains > Actions > View Storage Allocation
Details

Displays, by Storage Class, the storage capacities for all of the single tier LUNs
and auto‑tier LUNs in the selected Storage Domain.

For each available Storage Class, the system displays a graph for the following
storage capacities.

Single Tier Indicates the allocated storage capacity for single tier LUNs.

Auto Tier Indicates the allocated storage capacity for auto‑tier LUNs. The
solid portion of the graph identifies the allocated capacity that is
using to RAID 5 or RAID 6. The shaded portion of the graph
identifies the allocated capacity that is using to RAID 10.

Note: RAID 6 is only available on a Capacity HDD Storage Class.
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Immobile Indicates that the storage capacity cannot move to a lower cost,
lower performance Storage Class. You can reduce immobile
capacity by including low performance Storage Classes in the
LUNs.
The solid portion of the graph identifies the allocated capacity that
is using to RAID 5 or RAID 6. The shaded portion of the graph
identifies the allocated capacity that is using to RAID 10.

Note: RAID 6 is only available on a Capacity HDD Storage Class.

Free Displays the amount of capacity that is available for allocation in
the indicated Storage Domain.

Unused Displays the amount of capacity that is allocated for, but not used
by auto‑tiered LUNs. The unused free capacity can only be used
for auto‑tiered LUNs. Compact the Storage Domain to release the
unused space for non‑auto‑tiered LUNs.

Preparing Displays the amount of capacity that is being initialized. This value
typically results from a volume having been deleted. This value
decreases over time while the value for free space correspondingly
increases for the indicated Storage Domain.

Related Links
View Storage Allocation Details

View Storage Domain Dialog
Navigation: System > Storage Domains > Actions > View Storage Domain

Displays information about the selected Storage Domain.

Storage Domain Capacity by Storage Class
Displays graphically the storage classes, and their capacities, for the selected
Storage Domain.

Valid media types:

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
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the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

For each storage class, the system graphically displays the Storage Domain
physical capacities. The graph uses colored bars of different thicknesses to
indicate the capacity status of each storage class. Hover the mouse pointer over
each graph to display the capacity type.

Note: Drive manufacturers often report drive capacities in decimal units (powers
of 10). An Oracle FS System reports the capacity of physical storage and the size
of logical volumes in binary units (powers of two):

1 MB = 10242 (1,048,576) bytes
1 GB = 10243 (1,073,741,824) bytes
1 TB = 10244 (1,099,511,627,776) bytes

Possible physical storage capacities:

Free Space Displays the amount of capacity that is available for
allocation in the indicated Storage Class.

Used Capacity Displays the amount of capacity that is consumed by data
and system overhead.

Total Capacity Displays the total amount of raw capacity provided by the
drive groups that are defined within the indicated Storage
Class.

Allocated Space Displays the amount of capacity that has been assigned and
designated to all storage classes residing on the indicated
Storage Class.

Preparing
Capacity

Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Class.

Allocated to
Logical
Maximum

Displays the maximum capacity to which the Storage Class
can grow.

Name Specifies the name of this Storage Domain. This name must be
unique within the Oracle FS System.

Background
Process
Priority

System
Chooses

(Default) Specifies that the system balances the
resources that are needed for background data
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movement with the resources that are needed
to service the incoming client I/O.

Minimize
Impact

Specifies that the system restricts the amount of
system resources that are given to the
background data movement operation. This
option minimizes the impact on client I/O.
Recommended for highly‑loaded Storage
Domains.

Maximize
Speed

Specifies that the system grants resource
priority to the background data movement
operation. This option reduces the amount of
system resources that are available for client
I/O. Recommended for lightly‑loaded Storage
Domains.

Enable Tier
Reallocation

Specifies that any tiered data that resides in this Storage
Domain has data progression enabled. Individual objects might
have tier reallocation disabled. Enabling tier reallocation at the
Storage Domain level does not override any objects that have
tier reallocation disabled. The default value is enabled.

Enable Tier
Reallocation
Statistics
Collection

Collects data usage patterns for the Storage Domain internally
to analyze and determine the optimum storage classes for the
data. The default value is enabled. It is recommended you do
not change this setting unless you need to test different profiles.
Disable this setting if you are modifying your storage profile
for testing purposes and did not want to collect statistics
during the test. You do not want to collect tier reallocation
statistics during the test as this might distort future tier
reallocation. After you complete testing, enable tier reallocation
statistics collection.

Note: Enabling or disabling the tier reallocation statistics
collection has no effect on statistics you can view for CPU,
drive groups, Filesystems, or LUNs. (Those are a different set
of statistics.)

Auto‑Tier Scan Options (Advanced)
Optimizes the auto‑tier algorithm for moving data to different Storage Classes.
You can specify the interval for when auto‑tier moves frequently accessed data
blocks and infrequently accessed data blocks to match your application activity.

Performance-
Optimizing
Scan Cycle

Specifies the frequency, in hours, that auto‑tier scans to move
frequently accessed data blocks to a high performance Storage
Class.
For example, a value of 32 means that every 32 hours auto‑tier
scans the system to move frequently accessed data blocks to a
high performance Storage Class.
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Updates to this field affect the label of the Number of n‑hour
Scan Cycles field. For example, a value of 32 changes the label
for the Number of n‑hour Scan Cycles to Number of 32‑hour
Scan Cycles.

Number of
24‑hour Scan
Cycles

Specifies the frequency that auto‑tier runs the
performance‑optimizing scan cycles before auto‑tier runs the
cost‑optimizing scan cycle. The value entered in the Number
of n‑hour Scan Cycles field is multiplied by the value entered
in the Performance-Optimizing Scan Cycle field to obtain the
value set in the Cost-Optimizing Scan Cycle field.
For example, a value of 5 means that every fifth time that
auto‑tier runs the performance‑optimizing scan cycle,
auto‑tier then runs the cost‑optimizing scan cycle to move
infrequently accessed data to a less expensive storage class.

Cost-
Optimizing
Scan Cycle

(Read‑only) Displays the frequency, in hours, that auto‑tier
scans to move infrequently accessed data blocks to a less
expensive Storage Class.
The value displayed in this field is calculated as the product of
the value you entered in the Performance-Optimizing Scan
Cycle field and the value you entered in the Number of n-
hour Scan Cycles field.

Allowable Storage Capacity for Auto‑Tiered LUNs
Indicates the maximum percentage of storage capacity to dedicate to auto-tier
reallocation for each Storage Class of the Storage Domain.

Related Links
View the Properties of a Storage Domain

View Storage Domains Dialog
Navigation:

NAS > Storage > Filesystems > Actions > Create Filesystem > View Storage
Domains
SAN > Storage > LUNs > Actions > Create LUN > View Storage Domains

Displays properties of the available Storage Domains and associated drive
groups.

Name Specifies the name of the Storage Domain and lists the Drive
Enclosures and drive groups that are assigned to the domain.

Status Displays the status of the Storage Domains and of the drive
groups that are associated with those Storage Domains. Normal
means that no action is required.

System Tab Reference Pages

422



Normal Indicates that the drive group is accessible and
no action is required.

Degraded
Warning

Indicates that the drive has failed in the drive
group, but the drive group is still accessible.
Replace the failed drive. If the drive group is
the primary drive group, then replace the drive
immediately. The primary drive group contains
system overhead, including all system
configuration data.

Degraded
Critical

Indicates that two or more of the drives have
failed. The drive group can become inaccessible
unless you replace the drives.

Failed Indicates that multiple drives have failed. The
drive group is not accessible. Replace the failed
drives. After the failed drives are replaced, the
drive group becomes accessible.

Unknown Indicates that the drive status information is not
available to display.

Tier
Reallocation

Identifies the tier reallocation status of the Storage Domain.
When tier reallocation is enabled, the Oracle FS System
dedicates resources and uses statistical data and QoS priority
property to migrate data from one storage tier to another.
Valid states:

Enabled Indicates that the tier reallocation is active on
the Storage Domain. Enabled makes possible
the migration of high-usage data to higher
performing storage tiers in this Storage
Domain.

Disabled Indicates that tier reallocation is not active on
the Storage Domain. Disabled does not allow
the migration of high-usage data to higher
performing storage tiers in this Storage
Domain.

Statistics
Collection
Disabled

Indicates that statistical data used by the
Oracle FS System to migrate the data is not
collected. Oracle recommends not using this
option as the statistical data is required for
the tier reallocation process.

Tier
reallocation
disabled

Indicates that the tier reallocation is not
active. The statistics collection is active.

Media Type Specifies the category of physical media that comprises the drive
group.
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Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that
are optimized for the performance of capacity
and for read operations. The write
performance for this Storage Class is
sacrificed somewhat to achieve the
optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations
and of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include
tape storage as an option, this Storage Class
always provides the lowest cost for each GB
of capacity.

Enclosure
Chassis ID

Displays the numeric identifier of the Drive Enclosure. The
Enclosure Chassis ID is located and displayed on the front of
the Drive Enclosure. The numeric values range from 01 to 99;
the hexadecimal values from A0 to FF.

Physical Capacity
Allocated Displays the amount of capacity that has been assigned and

designated to all logical volumes residing on the indicated
Storage Domain.

Free Displays the amount of capacity that is available for
allocation in the indicated Storage Domain.

Unavailable Displays the amount of capacity that is being initialized. This
value typically results from a volume having been deleted.
This value decreases over time while the value for free space
correspondingly increases for the indicated Storage Domain.

Total Capacity Displays the total amount of raw capacity provided by the
Drive Enclosures that are defined within the indicated
Storage Domain.
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Physical
Distribution

Provides a graphical representation of the capacity that is
used compared to the maximum that is allocated.

Related Links
Create Auto-Tiered LUN: Define Quality of Service
Create Single-Tier LUN: Define Quality of Service

View Storage Profile Dialog
Navigation: System > Global Settings > Storage Profiles > Actions > View Storage
Profile

Displays the properties of a Storage Profile.

Name Identifies the name of the Storage Profile. The name includes, in some
instances, the name of the application that is associated with the
profile.

RAID
Level

Identifies the storage mechanism that is used to enhance the ability of
the system to recover data from the loss of one or more drives.
Possible RAID levels:

Single parity Indicates that, in addition to the actual data,
one set of parity bits exists for the logical
volume. This parity level protects against the
loss of one drive. Single parity is implemented
as a variant of the RAID 5 storage technology.

Double parity Indicates that, in addition to the actual data,
two sets of parity bits exist for the logical
volume. This parity level protects against the
loss of one or two drives with a slight cost to
write performance. Double parity is
implemented as a variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist for the
volume. Instead, the system writes the data in
two different locations. This RAID level
protects against the loss of at least one drive
and possibly more drives with an improvement
of the performance of random write operations.
Mirrored RAID is implemented as a variant of
the RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for sequential
read operations. The policy determines the amount of additional
data, if any, that the system places into the Controller cache. Valid
policies:
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Normal Indicates that the input requests and the
output requests are accessing the data
mostly in a random manner or in a
mixed sequential and random manner.

Aggressive Indicates that the input requests and the
output requests are accessing the data
mostly in a sequential manner and that
the workload is biased toward read
operations.

Conservative Indicates that the input requests and the
output requests are mostly sequential
and that the workload is biased toward
write operations.

Priority Identifies the priority that the system gives to various operational
aspects of a logical volume, such as the Controller processing queue.
The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume. Identifies as
well where the data is striped on rotating drives. Valid priority levels:

Premium Indicates the highest priority for responding to requests
in the processing queue.

High Indicates the next highest priority for responding to
requests in the processing queue.

Medium Indicates an intermediate priority for responding to
requests in the processing queue.

Low Indicates the next to lowest priority for responding to
requests in the processing queue.

Archive Indicates the lowest priority for responding to requests
in the processing queue.

Advanced
Displays addition QoS properties of the Storage Profile.

Writes Identifies the write‑caching rules to use for the profile.
Valid options:

Write-through Writes data to the Controller cache and to
the storage arrays before the write request
completes. This rule ensures that the data
is safely written to the storage before the
write request returns to the application.
Write‑through caching performs more
slowly than does write‑back caching
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because the data is being written to the
storage arrays as well as to the cache.

Write-back caching Writes data to the Controller cache, and
the write request returns immediately
without waiting for the write‑to‑disk to
complete. During idle cycles, the system
writes the data from the cache to the
storage arrays. Write‑back caching
performs faster than does write‑through
because the data only needs to be written
to the cache before the write request
returns.

Important: If the system goes down
unexpectedly, the data in the cache that
has not been written to the storage arrays
could be lost.

During the shutdown process, the system
writes all cached data to the storage
arrays.

Default Indicates that the Oracle FS System selects
the appropriate write‑caching rule based
on the selected QoS settings.

Stripe
Width

Identifies the number of drive groups over which the data is written.
Possible values:

1 through 64 Indicates the specified stripe width.

all Indicates that the logical volume is striped across all
of the available drive groups.

auto‑select Indicates that the Oracle FS System determines the
stripe width based on the Priority option that you
selected.

Preferred Storage Classes
Displays the Storage Class media on which the logical volume resides and the
preferred order that the Oracle FS System uses the media.

Preferred
Order

Indicates the preferred order in which the Oracle FS System uses
the available Storage Classes.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:
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Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Related Links
View Storage Profiles

View UPS Dialog
Navigation: System > Hardware > UPSs > Actions > View UPS

Displays properties of a selected uninterruptible power supply (UPS) device.

Name Identifies the name of the UPS device. UPS names must be
unique across the Oracle FS System and must be 256 or fewer
UTF‑8 characters.

IP Address Identifies the IP address that is assigned to the external UPS
device.

SNMP
Community

Identifies a community for which a specific trap host should
receive traps that the Oracle FS System generates. You can
specify different community strings for each trap host so that
multiple administrators can receive specific types of SNMP
traps. The default community string is public (lower case). It is
recommend you change the default community string.

Note: This community string entered here must match the
community string configured on the UPS device.
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Current Status
Provides read‑only details and status about the UPS device. You cannot modify
this information.

Model Identifies the model number of the UPS device.

Firmware Revision Identifies the firmware version that is installed on the
UPS device.

Serial Number Identifies the serial number of the UPS device.

Power Source Identifies the source of the UPS power. Valid sources:

• AC (alternating current)
• Battery
• Unknown

Battery Status Identifies the status of the UPS batteries. Valid values:

• Normal
• Warning
• Critical
• Unknown

Communication
Status

Identifies the communication status between the UPS
device and the Oracle FS System system. Valid values:

• OK
• Failed

Related Links
View a UPS Device
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APPENDIX C

SAN Tab Reference Pages

Additional Options Dialog
Navigation: SAN > Storage > LUNs > Actions > ... > Quality of Service >
Auto‑tier > Additional Options

Lets you select which Storage Classes to use for tier migration. You can also
specify whether tier migration is enabled for the auto‑tiered LUN.

Storage Classes for Auto‑Tiering
Use All
Classes

Specifies that the auto‑tiering feature uses all of the Storage
Classes that are available on the Oracle FS System.

Note: Oracle recommends using the default value of Use All
Classes.

Use only the
following

Specifies that the auto‑tiered LUN uses only the selected
Storage Classes. Deselecting a Storage Class from the list
excludes that Storage Class and its capacity from tier
migration.
Excluding less expensive Storage Classes and including high
performance Storage Classes causes immobile storage capacity.
Immobile data occurs when the system cannot migrate the
data to a lower Storage Class. Data that cannot migrate to a
lower Storage Class is considered immobile and the storage
capacity that this data occupies is immobile. Immobile capacity
can significantly restrict the efficiency of tier migration.

Note: A Storage Class that contains the text “(not present)”,
indicates that the particular class is not available in the Storage
Domain. However, when the storage becomes available then
the tier migration process uses that Storage Class.

Tier
Reallocation
Enabled

Specifies whether to apply storage tier migration to the LUN.
Selecting the Tier Reallocation Enabled option does not
override the disabled Tier Reallocation setting in the Storage
Domain.
When enabled, the system moves data from one storage tier to
another storage tier to achieve the best overall performance
and lowest overall cost. For the tier migration process to work,
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select the Tier Reallocation Enabled option and enable the
same option in the Storage Domain.

Related Links
Managing SAN LUNs
Create Auto-Tiered LUN: Define Quality of Service
Modify Auto-Tiered LUN: Define Quality of Service

Associate Hosts Dialog
Navigation: SAN > Storage > Hosts > Actions > Associate Hosts

Enables the Oracle FS System to recognize Fibre Channel (FC) or iSCSI SAN
hosts that do not have Oracle FS Path Manager installed.

Host Name Identifies the SAN host that accesses LUNs or Clone LUNs
configured on the Oracle FS System.

Create Association
Specifies the name of the SAN initiator that is used for the SAN host association.

Valid options:

Specify WWN Specifies the Fibre Channel port world‑wide name
(WWN) that the Oracle FS System has not discovered.

Select iSCSI device
name

Specifies the iSCSI initiator name that the Oracle FS
System has not discovered.

Select from
discovered WWNs

Specifies the list Fibre Channel port WWNs that the
Oracle FS System discovered on the network.

Select from
discovered iSCSI
Names

Specifies the list of iSCSI initiator names that the
Oracle FS System discovered on the network.

iSCSI Host Specific Settings
Enable
Authentication

Indicates whether the Challenge Handshake
Authentication Protocol (CHAP) protocol for iSCSI
sessions between the SAN host and the Oracle FS System
is enabled.

Note: Depending on the global settings, the CHAP name
property and the CHAP secret property might not be
required. Those properties are not required, for example,
when authentication is performed through a RADIUS
server.

CHAP Name Identifies the name of the iSCSI initiator that is to be used
during authentication.
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CHAP Secret Identifies the encrypted CHAP authentication password
(secret) to be used in the exchange of user names and
secrets between two devices. Both devices must support
Point‑to‑Point (PPP) authentication.

Note: The Oracle FS System supports up to 100 UTF‑8
non‑integer characters. However, when connecting to
Windows servers, you must limit the secret to a value from
12 to 16 characters in length.

Retype CHAP
Secret

Confirms the encrypted CHAP authentication password.

Grant Access to
Oracle FS

Specifies whether the Oracle FS System must reject iSCSI
login attempts from initiators that have not explicitly been
granted permission by the user through the Oracle FS
System Manager interface or through the Oracle FS System
Command Line Interface (CLI).

Associations
Type Identifies the type of initiator that is associated with the

SAN host entry.

HBA Alias Identifies an alternative friendly name that is assigned to the
host port.

Device / HBA
Port Name

Identifies the name of the device or initiator that is
associated with the SAN host entry.

Controls
Remove Deletes the selected objects.

Related Links
Create an Associated Host Entry

Controller Protocol Statistics Overview Page
Navigation: SAN > Statistics and Trending > Controller Protocols

Displays statistics for storage area network (SAN) protocols. The SAN protocols
are either Fibre Channel (FC) or Internet Small Computer System Interface
(iSCSI)

Name Identifies the name of the selected Controller.

Port Type Identifies the Controller port protocol type, FC, or iSCSI.

Slot Number Identifies the Controller PCI slot assignment.
Port Number Identifies the port numbers which are 0 or 1.

SAN Tab Reference Pages

432



Negotiated Speed Displays the transmission speed in Gbps/second for the
port. The transmission speed is negotiated between the
HBA or FC switch and the Controller.

Throughput (per
Second)

Identifies the throughput in MB/second.

Read Identifies the read throughput in MB/second.

Write Identifies the write throughput in MB/second.

I/O Latency Identifies the time in milliseconds to read or write data.
Displays the following:

Read Identifies the time to read data in
milliseconds.

Write Identifies the time to write data in
milliseconds

Combined Identifies the combined amount of time to
read and write data in milliseconds.

I/O Size Identifies the average size of the read and write operations.

Commands
Received (per
Second)

Displays the number of read and write commands received
on the Oracle FS System each second over the last sampling
period.

Channel Errors
Since Activated

Displays the cumulative number of channel errors that have
occurred since the Controller was activated.

Collection Period Identifies the start and end times at which information was
last collected from the Oracle FS System. Data is collected
for a two-minute period and the data is refreshed every two
minutes.

To generate real-time statistics about an FC or iSCSI port, select the port, then
select Actions > FC Port Real Time Statistics or iSCSI Port Real Time Statistics.
Click Add Graph and select a statistic (you can review the following list for
details.

The statistics displayed include:

Read IOPS Indicates the number of read I/O operations per second.
Write IOPS Indicates the number of write I/O operations per second.
Total IOPS Indicates the total number of read and write IOPS.
Read bytes per
second

Indicates the rate at which the system has transferred
bytes from a drive during read operations.

Write bytes per
second

Indicates the rate at which the system has transferred
bytes to a drive during write operations.

Total bytes per
second

Displays the total number of bytes for read and write
operations.
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Related Links
View SAN Controller Protocols

Copy SAN LUN, Data Protection Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > Copy > Data Protection > Auto
Tier

Adds data protection schedules to LUN copies. You can also manage data
replication schedules from this page.

Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clone Storage
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
the Addressable Logical Capacity value that you provided in
the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Current
Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs.
The value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that
you provided in the Quality of Service tab.
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Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Initial
Storage
Class

Specifies the initial category of physical media on which the logical
volume resides. For auto‑tiered LUNs, the Oracle FS System
determines the actual Storage Class that matches the data usage
statistics on the volume to get the most optimal performance.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve the
optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

SAN Tab Reference Pages

435



Initial
Typical
Access

Identifies the most common method of data access. Valid
biases:

Sequential Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records one after the other
in a physical order.

Random Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records in an arbitrary
order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

Initial I/
O Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests are for
read operations.

Write Indicates that most of the access requests are for
write operations.

Mixed Indicates that the number of access requests are
similar for read operations and for write
operations.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

Initial
RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
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exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.
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Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.

Additional
Options

Displays a dialog that allows you to select Auto Tier
Storage Class options.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
QoS Policies
Copy a LUN

Copy SAN LUN, Data Protection Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Copy > Data Protection > Single
Tier
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Adds data protection schedules to LUN copies. You can also manage data
replication schedules from this page.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity by Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clone Storage
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on the
Addressable Logical Capacity value that you provided in the
Quality of Service tab.

Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
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addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs. The
value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that you
provided in the Quality of Service tab.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone QoS Storage
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.
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Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
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data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the system
writes the data in two different
locations. This RAID level protects
against the loss of at least one
drive and possibly more drives
with an improvement of the

SAN Tab Reference Pages

442



performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:
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• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
Copy a LUN

Copy SAN LUN, Mapping Tab
Navigation: SAN > Storage > LUNs > Actions > Copy > Mapping

Creates the LUN‑to‑host mapping settings for a logical volume.

Access
Protocol

Specifies the protocols that are allowed for accessing the
logical volume.
Valid options:

Fibre Channel
(FC)

Specifies that hosts can use the FC
protocol to access this LUN.

Tip: The system always uses FC paths at
a preference over iSCSI paths. Also, load
balancing is not mixed between these
two protocols.

iSCSI Specifies that hosts can use the iSCSI
protocol to access this LUN.

Only selected
hosts (via
maps)

Specifies that only designated SAN hosts can access this LUN
using a specific, possibly different, LUN number on each of
those hosts. If the LUN is mapped, the LUN number must be
unique to the mapped SAN host.
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All hosts may
access this
LUN using
LUN Number

Specifies all SAN hosts accessing this LUN use the same LUN
number. Select this option to activate the LUN number
selection drop-down list.

LUN Controller Assignment
The LUN Controller Assignment option allows you to home the LUN copy on a
Controller other than the Controller on which the source LUN is homed. The
default is to home the copy on the same Controller as the source LUN.

Current
Controller

Identifies the current Controller on which the LUN is homed.

Note: For new source LUNs, this field is not available; instead,
use the Assigned Controller option.

Assigned
Controller

Identifies the Controller to which the system should assign
the LUN. Choose an available Controller node from the list.

Ports Masked for this LUN
Displays the physical Controller ports to exclude (mask) so they cannot access
the LUN.

Masked Indicates whether the port for the LUN is masked.

Protocol Identifies the type of access protocol, FC or iSCSI.

Controller Identifies the name of the Controller.

Slot Identifies the slot number of the Controller HBA.

Port Identifies the Controller port number.

Controller Port
Address

Identifies the unique identifier of each Controller network
port. For FC networks, this identifier is the World Wide
Name (WWN). For iSCSI networks, this identifier is the
Media Access Control (MAC) address.

LUN Mapping
Manages the LUN‑to‑Host mapping assignments.

Note: The LUN mapping table only displays when you select the Only selected
hosts (via maps) option.

You can map a LUN or Clone LUN to either a single host or a host group.

Hosts
Mapped to
this LUN

Name Identifies the SAN host that accesses LUNs
configured on the Oracle FS System. If the
Oracle FS Path Manager is not installed, the
system displays the WWN of the FC HBA or the
IP address of the iSCSI device.
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Map via
LUN
Number

Identifies the number to assign to the LUN for the
associated SAN host. This number must be
unique for that particular host. It need not to be
unique across all hosts.

Create Opens the dialog that allows you to create the LUN-to-host
mapping based on your selections for host name and assign the
LUN number that the host uses.

Modify Opens the dialog that allows you to change the LUN mapped to
the associated host.

Remove Removes the LUN mapping for the selected SAN host.

Related Links
Copy a LUN

Copy SAN LUN, Quality of Service Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > Copy > Quality of Service > Auto
Tier

Copies an existing logical volume.

Selected Storage Class Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Allocation By Storage Class and RAID Level
Indicates graphically the actual physical capacity of the auto‑tiered LUN plus the
capacity that is required for RAID Level parity. The graph contains stacked bars
that represent the sum of the Storage Class physical capacity and the RAID Level
parity. A legend at the bottom of the graphic provides detailed information about
each bar.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN
Name

Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
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• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Storage
Class

Specifies the initial category of physical media on which the
logical volume resides. For auto‑tiered LUNs, the Oracle FS
System determines the actual Storage Class that matches the data
usage statistics on the volume to get the most optimal
performance.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
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selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
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data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
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amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.
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Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Additional
Options

Displays a dialog that allows you to select Auto Tier Storage
Class options. The dialog also provides options for selecting
tier reallocation, which allows data migration to the
appropriate storage class based on data usage.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
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Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.
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Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
QoS Policies
Copy a LUN

Copy SAN LUN, Quality of Service Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Copy > Quality of Service > Single
Tier

Copies an existing logical volume.

Selected Storage Class Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity By Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.
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Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
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For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the number of copies of the parity bits that
the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
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and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is

SAN Tab Reference Pages

456



implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.
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Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
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Tag
Checking

Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.
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Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
Copy a LUN

Create Job Schedule Dialog
Navigation: SAN > Storage > LUNs > Actions > ... > Data Protection > Create

Creates a volume replication job schedule.

Note: A schedule should be synchronized with the host applications that access
the logical volume so that all data I/O is quieted before the replication operation
starts.

Schedule
Name

Identifies the unique name of a scheduled operation, which is an
action that the Oracle FS System performs at the specified time or
at regular intervals.

Volume
Group

Allows you to assign the clone volume to an existing volume
group.

Enabled Indicates whether the schedule is enabled.

• Enable the schedule so that the operation is performed at
the specified time.

• Disable the schedule so that operations are not performed.
This option allows you to define a schedule before the
source volume has been made available to users.

Start Time Identifies the date and time at which the Oracle FS System starts a
scheduled operation.
Valid options:

Run Once Indicates that the schedule runs
immediately and only one time.

Hourly Indicates that the schedule runs every hour.
Daily Indicates that the schedule runs every day.
Weekly Indicates that the schedule runs every week.

Recurrence Identifies how often the system should perform the scheduled
operation. Valid values vary based on the recurrence interval and
frequency of the schedule.
Valid values are listed in the following table.
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Table 19: Schedule recurrence intervals
Recurrence interval Valid values
Hourly 1 through 24

Daily 1 through 7

Weekly 1 though 4

Related Links
Create a Clone LUN Schedule

Create Data Protection Schedule Dialog
Navigation: SAN > Data Protection > Clone Schedules > Actions > Create

Creates a data replication schedule on a selected logical volume.

Schedule Name Identifies the unique name of a scheduled operation, which is
an action that the Oracle FS System performs at the specified
time or at regular intervals.

Volume Group
for Created
Clones

Allows you to assign the clone volume to an existing volume
group.

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not
performed as scheduled.

Select a Volume to Protect
Volume to Replicate Identifies the name of the logical volume from

which the scheduled clone is created.

Number of Existing
Clones

Identifies the number of child Clone LUNs
associated with the existing LUN.

Used Capacity Allocated
for Clones

Displays the amount of space allocated for
Clone LUNs.

Maximum Capacity
Allocated for Clones

Displays the maximum space allocated for
Clone LUNs.

Schedule
Start Time Identifies the date and time that the schedule begins.
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Schedule
Frequency

Identifies the frequency at which the schedule runs.
Frequencies include:

• Run Once
• Hourly
• Daily
• Weekly

Recurrence Identifies how often the system should perform the
scheduled operation. Valid values vary based on the
recurrence interval and frequency of the schedule.

Related Links
Create a LUN Data Protection Schedule

Create LUN Map Dialog
Navigation: SAN > Storage > LUNs > Actions > ... > Mapping > Create

Establishes the LUN connections to a specified host.

LUN Name Identifies the name of the LUN or Clone LUN on the Oracle FS
System.

Host Name Identifies the SAN host that accesses LUNs or Clone LUNs
configured on the Oracle FS System.
You can map a LUN or Clone LUN to either a single host or a
host group.

LUN Number Specifies the LUN number to which the logical volume is
assigned.

Related Links
Create LUN: Define Mapping by Selected Host Entries
Modify LUN: Define Mapping by Selected Host Entries

Create SAN Clone LUN, Mapping Tab
Navigation: SAN > Storage > LUNs > Actions > Clone > Mapping

Creates the LUN‑to‑host mapping settings for a Clone LUN.

Access
Protocol

Specifies the protocols that are allowed for accessing the
logical volume.
Valid options:

Fibre Channel
(FC)

Specifies that hosts can use the FC
protocol to access this LUN.
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Tip: The system always uses FC paths at
a preference over iSCSI paths. Also, load
balancing is not mixed between these
two protocols.

iSCSI Specifies that hosts can use the iSCSI
protocol to access this LUN.

Only selected
hosts (via
maps)

Specifies that only designated SAN hosts can access this LUN
using a specific, possibly different, LUN number on each of
those hosts. If the LUN is mapped, the LUN number must be
unique to the mapped SAN host.

All hosts may
access this
LUN using
LUN Number

Specifies all SAN hosts accessing this LUN use the same LUN
number. Select this option to activate the LUN number
selection drop-down list.

LUN Controller Assignment
Current
Controller

Identifies the current Controller on which the LUN is homed.

Note: For new source LUNs, this field is not available; instead,
use the Assigned Controller option.

Assigned
Controller

Identifies the Controller to which the system should assign
the LUN. Choose an available Controller node from the list.

Ports Masked for this LUN
Displays the physical Controller ports to exclude (mask) so they cannot access
the LUN.

Masked Indicates whether the port for the LUN is masked.

Protocol Identifies the type of access protocol, FC or iSCSI.

Controller Identifies the name of the Controller.

Slot Identifies the slot number of the Controller HBA.

Port Identifies the Controller port number.

Controller Port
Address

Identifies the unique identifier of each Controller network
port. For FC networks, this identifier is the World Wide
Name (WWN). For iSCSI networks, this identifier is the
Media Access Control (MAC) address.

LUN Mapping
Manages the LUN‑to‑Host mapping assignments.

Note: The LUN mapping table only displays when you select the Only selected
hosts (via maps) option.
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You can map a LUN or Clone LUN to either a single host or a host group.

Hosts
Mapped to
this LUN

Name Identifies the SAN host that accesses LUNs
configured on the Oracle FS System. If the
Oracle FS Path Manager is not installed, the
system displays the WWN of the FC HBA or the
IP address of the iSCSI device.

Map via
LUN
Number

Identifies the number to assign to the LUN for the
associated SAN host. This number must be
unique for that particular host. It need not to be
unique across all hosts.

Create Opens the dialog that allows you to create the LUN-to-host
mapping based on your selections for host name and assign the
LUN number that the host uses.

Modify Opens the dialog that allows you to change the LUN mapped to
the associated host.

Remove Removes the LUN mapping for the selected SAN host.

Related Links
Create an Immediate Clone LUN

Create SAN Clone LUN, Quality of Service Tab
Navigation: SAN > Storage > LUNs > Actions > Clone > Quality of Service

Creates a Clone LUN from an existing LUN.

Clone Storage for Source Volume LUN
Displays the allocated and growth potential for the Clone LUN within the source
LUN repository. The graph uses colored bars to indicate the capacity status of the
logical volume you are creating.

LUN
Name

Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Storage
Class

(Read only)
Specifies the category of physical media on which the logical volume
resides.
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Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic
(Read
only)

Allows you to specify indirectly the parity level of the data and the
read-ahead policy for the data. You specify those properties indirectly
by selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level
of redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and
the write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and
the write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and
the write requests operate on the data
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sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access
requests are similar for read operations
and for write operations.

Redundancy Identifies the number of copies of the parity bits that
the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one set
of parity bits to help in the recovery of
lost data. Access to the data is preserved
even after the failure of one drive. Single
parity is implemented using RAID 5
technology and is the default redundancy
level for the Storage Classes that specify
the performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of
lost data. Access to the data is preserved
even after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the
default redundancy level for the Storage
Classes that specify the capacity-type
media.

Advanced
(Read
only)

Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume.
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This parity level protects against
the loss of one drive. Single
parity is implemented as a
variant of the RAID 5 storage
technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity
bits exist for the logical volume.
This parity level protects against
the loss of one or two drives with
a slight cost to write
performance. Double parity is
implemented as a variant of the
RAID 6 storage technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of
at least one drive and possibly
more drives with an
improvement of the performance
of random write operations.
Mirrored RAID is implemented
as a variant of the RAID 10
storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a
sequential manner and
that the workload is
biased toward read
operations.
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Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased
toward write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

(Read only)
Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.
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Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
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previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Related Links
Create an Immediate Clone LUN

Create SAN LUN, Mapping Tab
Navigation: SAN > Storage > LUNs > Actions > Create > Mapping

Creates the LUN‑to‑host mapping settings for a LUN.

Access
Protocol

Specifies the protocols that are allowed for accessing the
logical volume.
Valid options:

Fibre Channel
(FC)

Specifies that hosts can use the FC
protocol to access this LUN.

Tip: The system always uses FC paths at
a preference over iSCSI paths. Also, load
balancing is not mixed between these
two protocols.

iSCSI Specifies that hosts can use the iSCSI
protocol to access this LUN.

Only selected
hosts (via
maps)

Specifies that only designated SAN hosts can access this LUN
using a specific, possibly different, LUN number on each of
those hosts. If the LUN is mapped, the LUN number must be
unique to the mapped SAN host.

All hosts may
access this
LUN using
LUN Number

Specifies all SAN hosts accessing this LUN use the same LUN
number. Select this option to activate the LUN number
selection drop-down list.
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LUN Controller Assignment
The LUN Controller Assignment option allows you to home the LUN copy on a
Controller other than the Controller on which the source LUN is homed. The
default is to home the copy on the same Controller as the source LUN.

Current
Controller

Identifies the current Controller on which the LUN is homed.

Note: For new source LUNs, this field is not available; instead,
use the Assigned Controller option.

Assigned
Controller

Identifies the Controller to which the system should assign the
LUN. Choose an available Controller node from the list.

Auto-assign Assigns your LUN to an available
Controller. This option allows the Pilot to
move resources to the other Controller node
in the event of a failover and maximizes
performance by balancing the system load
with existing logical volumes. You can
modify this field after the LUN has been
created.

Note: If you select this option, you cannot
set up port masking and port mapping until
after the LUN is created.

Controller Name Select a Controller node from the drop-
down list. Use this option when you want
to access the data from a particular port
(port masking).

Ports Masked for this LUN
Displays the physical Controller ports to exclude (mask) so they cannot access
the LUN.

Masked Indicates whether the port for the LUN is masked.

Protocol Identifies the type of access protocol, FC or iSCSI.

Controller Identifies the name of the Controller.

Slot Identifies the slot number of the Controller HBA.

Port Identifies the Controller port number.

Controller Port
Address

Identifies the unique identifier of each Controller network
port. For FC networks, this identifier is the World Wide
Name (WWN). For iSCSI networks, this identifier is the
Media Access Control (MAC) address.

LUN Mapping
Manages the LUN‑to‑Host mapping assignments.
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Note: The LUN mapping table only displays when you select the Only selected
hosts (via maps) option.

You can map a LUN or Clone LUN to either a single host or a host group.

Hosts
Mapped to
this LUN

Name Identifies the SAN host that accesses LUNs
configured on the Oracle FS System. If the
Oracle FS Path Manager is not installed, the
system displays the WWN of the FC HBA or the
IP address of the iSCSI device.

Map via
LUN
Number

Identifies the number to assign to the LUN for the
associated SAN host. This number must be
unique for that particular host. It need not to be
unique across all hosts.

Create Opens the dialog that allows you to create the LUN-to-host
mapping based on your selections for host name and assign the
LUN number that the host uses.

Modify Opens the dialog that allows you to change the LUN mapped to
the associated host.

Remove Removes the LUN mapping for the selected SAN host.

Related Links
Create LUN: Define Mapping by Selected Host Entries

Create SAN LUN, Data Protection Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Create > Data Protection > Single
Tier

Adds data protection schedules for creating Clone LUNs.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity by Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.
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Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clones
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
the Addressable Logical Capacity value that you provided in
the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Current
Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs.
The value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that
you provided in the Quality of Service tab.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.
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Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
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mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.
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RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the system
writes the data in two different
locations. This RAID level protects
against the loss of at least one
drive and possibly more drives
with an improvement of the
performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
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the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.
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Related Links
Create Single-Tier LUN: Define Data Protection
Modify Single‑Tier LUN: Data Protection

Create SAN LUN, Data Protection Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > Create > Data Protection > Auto
Tier

Adds data protection schedules for creating Clone LUNs.

Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clones
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
the Addressable Logical Capacity value that you provided in
the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Current
Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs.
The value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that
you provided in the Quality of Service tab.
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Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

Initial
Storage
Class

Specifies the initial category of physical media on which the logical
volume resides. For auto‑tiered LUNs, the Oracle FS System
determines the actual Storage Class that matches the data usage
statistics on the volume to get the most optimal performance.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.
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Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Initial
Typical
Access

Identifies the most common method of data access. Valid
biases:

Sequential Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records one after the other
in a physical order.

Random Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records in an arbitrary
order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

Initial I/
O Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests are for
read operations.

Write Indicates that most of the access requests are for
write operations.

Mixed Indicates that the number of access requests are
similar for read operations and for write
operations.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

Initial
RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
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implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.
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Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.

Additional
Options

Displays a dialog that allows you to select Auto Tier
Storage Class options.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.
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Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
QoS Policies
Create Auto-Tier LUN: Define Data Protection
Modify Auto-Tiered LUN: Define Data Protection

Create SAN LUN, Quality of Service Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Create > Quality of Service >
Single Tier

Creates and configures the capacity and performance settings for a single tier
LUN.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.
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Capacity By Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.
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[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.
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Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the number of copies of the parity bits that
the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
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Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.
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Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.
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Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
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previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
Create Single-Tier LUN: Define Quality of Service

Create SAN LUN, Quality of Service Tab, Auto‑tier
Navigation: SAN > Storage > LUNs > Actions > Create > Quality of Service > Auto
Tier

Creates and configures the capacity and performance settings for an auto‑tier
LUN.

Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

SAN Tab Reference Pages

490



Allocation By Storage Class and RAID Level
Indicates graphically the estimated physical capacity that is required for the
following settings:

• Allocated Logical Capacity
• Initial RAID Level

The actual values display after the auto‑tiered LUN is created.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN
Name

Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Note: The RAID level that the system uses might be different that
the RAID level that is specified by the Storage Profile. The
difference, if any, depends on the RAID levels that are available in
the selected Storage Domain.

Initial
Storage
Class

Specifies the initial category of physical media on which the logical
volume resides. For auto‑tiered LUNs, the Oracle FS System
determines the actual Storage Class that matches the data usage
statistics on the volume to get the most optimal performance.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
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performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:
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Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

Initial
RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.
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Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.
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Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
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have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Additional
Options

Displays a dialog that allows you to select Auto Tier Storage
Class options. The dialog also provides options for selecting
tier reallocation, which allows data migration to the
appropriate storage class based on data usage.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
previously written by the host. There is no other effect on the
LUN.
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Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
Managing SAN LUNs
QoS Policies
Storage Tiers and Storage Profiles
Create Auto-Tiered LUN: Define Quality of Service

Create Volume Group Dialog
Navigation:

NAS > Storage > Filesystems > Actions > Create Filesystem > Quality of
Service > Volume Group ... > Volume Groups > Create
SAN > Storage > LUNs > Actions > Create LUN > Quality of Service > Volume
Group ... > Volume Groups > Create

Adds an organizational unit that can group a collection of logical volumes on the
Oracle FS System.

Volume Name Identifies the name of the volume group. Valid volume group
names consist of letters and numerals and can be up to 14
characters in length. Each volume group name must be unique
within its parent volume group.
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Parent
Volume
Group Name

Identifies the name of the top‑level node in a nested volume
group relationship.

Related Links
Create Auto-Tiered LUN: Define Quality of Service
Create Single-Tier LUN: Define Quality of Service

Delete LUN
Navigation: SAN > Storage > LUNs > Actions > Delete

Confirms the removal of a selected LUN.

Important: If the LUN is a member of a SAN replication pair, delete the Oracle
MaxRep protection plan before deleting the LUN. For more information, see the
Oracle MaxRep for SAN User’s Guide.

Volumes to
Delete

Identifies the LUN, and any Clone LUNs, to remove from the
Oracle FS System.

CAUTION: Data loss might occur. Carefully review the list
before deleting the LUNs.

Related Links
Delete a LUN

Host to LUN Mapping Overview Page
Navigation: SAN > Storage > Host‑LUN Mapping

Displays the mapping properties between the SAN hosts and the Oracle FS
System LUNs with which the hosts are associated. This page also displays the
status of the connections between these hosts and the associated Controller ports.

Host to LUN Map
HBA Port/Device Displays the following for each host mapping:

• SAN LUN or Clone LUN name
• Host name or WWN
• Host group name

Controller-
Initiator
Connectivity

Identifies the connection status between the Controller
and initiator port. The status might indicate masked
Controller ports or disabled protocols.
Valid states:

SAN Tab Reference Pages

498



• Connected
• Connected, Masked
• Connected, Masked, Protocol Disabled
• Connected, Partially Masked
• Connected, Partially Masked, Some Protocols

Disabled
• Connected, Protocol Disabled
• Connected, Some Protocols Disabled
• Not Connected

Mapped Via LUN
Number

Identifies the LUN number used for the SAN host
mapping.

LUN Name on
Host

Identifies the name used by the SAN host to identify the
LUN, if known.

Initiator-To-Controller Connectivity Dialog
Navigation: SAN > Storage > Hosts > Actions > Initiator-to-Controller
Connectivity

Displays information about connectivity between host initiators and Controller
ports.

Name Identifies the information about the Controller. The column
includes the following information:

• Controller name
• Adapter slot number
• Adapter port number

Port Type Displays the Controller port type.
Valid types:

• iSCSI
• FC

Address Identifies the unique address of the Oracle FS System Controller
port on the network.

Host Name Displays the host name and a column for each initiator port in the
host. The contents of each column show the state of connectivity
between that host initiator port and each Controller port.

Related Links
Initiator-to-Controller Connectivity
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LUN to Host Mapping Overview Page
Navigation: SAN > Storage > LUN‑Host Mapping

Displays the mapping properties between the Oracle FS System LUNs and the
SAN hosts. This page also displays the status of the connections between the
SAN hosts and the associated Controller ports.

LUN to Host Map
Name Displays the following for each host mapping:

• SAN LUN or Clone LUN name
• Host name or WWN
• Host group name

Controller-
Initiator
Connectivity

Identifies the connection status between the Controller and
initiator port. The status might indicate masked Controller
ports or disabled protocols.
Valid states:

• Connected
• Connected, Masked
• Connected, Masked, Protocol Disabled
• Connected, Partially Masked
• Connected, Partially Masked, Some Protocols

Disabled
• Connected, Protocol Disabled
• Connected, Some Protocols Disabled
• Not Connected

Mapped via LUN
Number

Identifies the LUN number used for the SAN host
mapping.

LUN Name on
Host

Identifies the name used by the SAN host to identify the
LUN, if known.

LUNs Overview Page
Navigation: SAN > Statistics and Trending > LUNs

Displays performance statistics for LUNs.

Name Identifies the name that is assigned to a LUN for
administrative purposes.

Physical Allocated
Capacity

Identifies the capacity, in gigabytes (GB), that is reserved
for the LUN.

SAN Tab Reference Pages

500



Priority Level Identifies the priority level assigned to the specified LUN.
Valid levels:

• Archive
• Low
• Medium
• High
• Premium

IOPS Indicates the average read and write operations per
second.

Throughput Indicates the data transfer rate in MB/s for read and write
operations.

I/O Latency Indicates the average time, in milliseconds, to complete
the read operations or write operations.

I/O Size Indicates the average size of the read operations and write
operations.

Collection Period Displays the start and the end time at which information
was last collected from the Oracle FS System.

To generate real-time statistics for a LUN, select a LUN, then select Actions >
LUN Real Time Statistics. Click Add Graph and select a statistic (you can
review the following list for details).

The statistics displayed include:

Read IOPS Indicates the average number of read operations per
second.

Write IOPS Indicates the average number of write operations per
second.

Read bytes per
second

Indicates the rate at which the system has transferred bytes
from a drive during read operations.

Write bytes per
second

Indicates the rate at which the system has transferred bytes
to a drive during write operations.

Read latency Indicates the average time to complete a read operation.
Write latency Indicates the average time to complete a write operation.
Read block size Displays the average amount of data read that are red in a

read operation.
Write block size Displays the average amount of data that are written in a

write operation.
Total block size Displays the average amount of data that are transferred in

a read or write operation.
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Read queue depth Displays the number of read operations that are waiting to
be fulfilled, on average.

Write queue depth Displays the number of write operations that are awaiting
to be processed, on average.

Total bytes per
second

Displays the total bytes transmitted per second, on
average.

Total IOPS Indicates the total number of read and write operations per
second.

Total latency Indicates the average time to complete operations.
Total queue depth Displays the total number of I/O operations that are

queued for processing, on average.

Related Links
View LUN Statistics

Manage SAN Host Groups, Groups Tab
Navigation: SAN > Stroage > Hosts > Actions > Manage SAN Host Groups >
Groups

Creates and modifies Storage Area Network (SAN) host groups. You can assign
any SAN host to a host group.

A host group is a named collection of SAN hosts that the system manages as a
group, which simplifies the task of associating hosts to LUNs.

Name Indicates the name of the host group.

Create Creates a new row in the table from which you can type the host group
name.

Delete Deletes the selected host group.

Related Links
Create a Host Group
Modify a Host Group

Manage SAN Host Groups, Hosts Tab
Navigation: SAN > Storage > Hosts > Actions > Manage SAN Host Groups > Hosts

Assigns registered Storage Area Network (SAN) hosts to a host group.

Note: Register at least one host to the Oracle FS System before assigning that host
to your host group.

A host group is a named collection of SAN hosts that the system manages as a
group, which simplifies the task of associating hosts to LUNs.
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Name Indicates the name of the SAN host that is available for host
group assignment.

Host Group Indicates the name of the host group to which the host is
assigned.

Related Links
Create a Host Group
Modify a Host Group

Manage Volume Groups Dialog
Navigation:

NAS > Storage > Filesystems > Actions > Create Filesystem > Quality of
Service > Volume Group ... > Volume Groups
SAN > Storage > LUNs > Actions > Create LUN > Quality of Service > Volume
Group ... > Volume Group ... > Volume Groups

Manages the organizational units that group the collections of logical volumes on
the Oracle FS System, including the nesting of volume groups.

Volume
Group

Identifies the name of the volume group. Valid volume group
names consist of letters and numerals and can be up to 14
characters in length. Each volume group name must be unique
within its parent volume group.

Parent
Volume
Group
Name

Identifies the name of the top‑level node in a nested volume
group relationship.

Logical
Capacity
(GB)

Provides an overview of the logical capacity usage and the
logical capacity requirements of the volume group.

Used Indicates the amount of allocated
capacity that is consumed.

• For LUNs, this amount is the
same as the allocated amount.

• For filesystems, this amount is
the allocated capacity that
contains user data.

Allocated Identifies the total amount of
storage capacity that is reserved for
this volume or this volume group.

Distribution Displays a graphical comparison of
the allocated capacity that this
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volume uses to the unused allocated
capacity.

Create Opens a dialog that allows you to add a volume group.

Modify Opens a dialog that allows you to modify the properties of a
volume group.

Delete Removes the selected volume group.

Related Links
Create Auto-Tiered LUN: Define Quality of Service
Create Single-Tier LUN: Define Quality of Service
Modify Auto-Tiered LUN: Define Quality of Service
Modify Single‑Tier LUN: Quality of Service

Manage Volume Groups, Volume Groups Tab
Navigation:

NAS > Volume Groups > Actions > Manage Volume Groups > Volume Groups
SAN > Volume Groups > Actions > Manage Volume Groups > Volume Groups

Manages the organizational units that group the collections of logical volumes on
the Oracle FS System, including the nesting of volume groups.

Volume
Group

Identifies the name of the volume group. Valid volume group
names consist of letters and numerals and can be up to 14
characters in length. Each volume group name must be unique
within its parent volume group.

Parent
Volume
Group Name

Identifies the name of the top‑level node in a nested volume
group relationship.

Logical
Capacity
(GB)

Provides an overview of the logical capacity usage and the
logical capacity requirements of the volume group.

Used Indicates the amount of allocated
capacity that is consumed.

• For LUNs, this amount is the
same as the allocated amount.

• For filesystems, this amount
is the allocated capacity that
contains user data.

Allocated Identifies the total amount of
storage capacity that is reserved for
this volume or this volume group.
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Distribution Displays a graphical comparison of
the allocated capacity that this
volume uses to the unused allocated
capacity.

Create Opens a row for creating a volume group.

Modify Opens a dialog that allows you to modify the properties of a
volume group.

Delete Removes the selected volume group.

Related Links
Create Auto-Tiered LUN: Define Quality of Service
Create Single-Tier LUN: Define Quality of Service
Modify Auto-Tiered LUN: Define Quality of Service
Modify Single‑Tier LUN: Quality of Service

Manage Volume Groups, Volumes Tab
Navigation:

NAS > Volume Groups > Actions > Manage Volume Groups > Volumes
SAN > Volume Groups > Actions > Manage Volume Groups > Volumes

Reassigns the logical volumes on the Oracle FS System to different volume
groups.

Volume
Name

Identifies the names of the configured logical volumes.

Volume
Group

Identifies the name of the volume group in which the logical volume
resides. This field can be used to reassign the volume to another
group.

Logical
Capacity
(GB)

Provides an overview of the logical capacity usage and the logical
capacity requirements of the volume group.

Used Indicates the amount of allocated capacity that
is consumed.

• For LUNs, this amount is the same as
the allocated amount.

• For filesystems, this amount is the
allocated capacity that contains user
data.

Allocated Identifies the total amount of storage capacity
that is reserved for this volume or this volume
group.
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Maximum Identifies the sum of the addressable capacity
for the logical volume and its clone repository.

RAID Level Single parity Indicates that, in
addition to the actual
data, one set of parity
bits exists for the logical
volume. This parity
level protects against
the loss of one drive.
Single parity is
implemented as a
variant of the RAID 5
storage technology.

Double parity Indicates that, in
addition to the actual
data, two sets of parity
bits exist for the logical
volume. This parity
level protects against
the loss of one or two
drives with a slight cost
to write performance.
Double parity is
implemented as a
variant of the RAID 6
storage technology.

Mirrored Indicates that no parity
bits exist for the
volume. Instead, the
system writes the data
in two different
locations. This RAID
level protects against
the loss of at least one
drive and possibly
more drives with an
improvement of the
performance of random
write operations.
Mirrored RAID is
implemented as a
variant of the RAID 10
storage technology.

Physical
Capacity
(GB)

Provides an overview of the physical capacity usage and the
physical capacity requirements of all the volumes on the system.
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Volume Overhead Identifies the physical and logical
storage capacity that is required to
meet the logical volume Quality of
Service (QoS) settings.

Used Identifies the current capacity that the
volume consumes.

Allocated Specifies the amount of raw capacity in
gigabytes (GB) that the system has
assigned and designated to this logical
volume.

Maximum Identifies the maximum capacity for the
volume group. The maximum capacity
of the logical volumes and nested
volume groups that are associated with
the volume group cannot exceed this
value. A value of 0 (zero) identifies that
the volume group is configured with
unlimited capacity. You can increase the
maximum capacity of the associated
logical volumes and the nested volume
groups without constraints.

Priority
Level

Filesystems Identifies the priority that the system gives to
various operational aspects of a logical volume, such
as the Controller processing queue. The processing‑
queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the
volume. Identifies as well where the data is striped
on rotating drives. Valid priority levels:

Premium Indicates the highest priority for
responding to requests in the
processing queue.

High Indicates the next highest priority for
responding to requests in the
processing queue.

Medium Indicates an intermediate priority for
responding to requests in the
processing queue.

Low Indicates the next to lowest priority for
responding to requests in the
processing queue.

Archive Indicates the lowest priority for
responding to requests in the
processing queue.
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LUNs Identifies the priority that the system gives to
various operational aspects of a logical volume.
These operational aspects include the Controller
processing queue, the SAN interface requests, and
the migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the
percentage of the Controller CPU cycles that are
dedicated to the volume.

Premium Indicates the highest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
highest priority when the system
migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
next highest priority when the system
migrates the data to the higher-
performing storage tiers.

Medium Indicates an intermediate priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive an
intermediate priority when the system
migrates the data to the higher-
performing storage tiers.

Low Indicates the next to lowest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
next to lowest priority when the
system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
lowest priority when the system
migrates the data to the higher-
performing storage tiers.

Related Links
Move a Volume to a Different Volume Group
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Modify Data Protection Schedule Dialog
Navigation: SAN > Data Protection > Clone Schedules  > Actions > Modify

Updates the properties of an existing data protection schedule. You can also
enable or disable the schedule from this page.

Schedule
Name

Identifies the name of the schedule.

Volume
Group for
Created
Clones

Allows you to assign the clone volume to an existing volume
group.

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not
performed as scheduled. Disable the
schedule, for example, when the source
volume (LUN or Clone LUN) has not been
made available to users.

Protected
Volume

Identifies the name of the logical volume from which the
scheduled clone is created.

Schedule Identifies the date and time that the schedule begins.
Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Recurrence Specifies how many hours, days, or weeks to wait before
generating this scheduled operation again.
Valid values are listed in the following table.

Table 20: Schedule recurrence intervals
Recurrence interval Valid values
Hourly 1 through 24

Daily 1 through 7

Weekly 1 though 4
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Related Links
Modify a LUN Data Protection Schedule

Modify Host, Advanced Tab
Navigation: SAN > Stroage > Hosts > Actions > Modify Host > Advanced

Enables HP-UX Compatibility mode to a host in a Storage Area Network (SAN).

HP-UX
Compatibility
Mode

Use this option when the SAN host is running the HP-UX
operating system. When compatibility mode option is
enabled, the system uses an alternative method to present
LUNs on the SAN host. This alternative method is
compatible with HP-UX. When this option is enabled, you
might not have a LUN visible to the host as LUN number 0.
HP-UX compatibility mode enables the full range of LUN
numbers (other than 0) to be used with HP-UX operating
systems. You can verify the current host mappings from the
Flash Storage Path Manager tab.

Related Links
Modify a Host: Reconfigure Advanced Settings

Modify Host, Oracle FS Path Manager Tab
Navigation: SAN > Storage > Hosts > Actions > Modify Host > Oracle FS Path
Manager

Modifies the configuration settings for Oracle FS Path Manager (FSPM).

You can configure the load balancing settings of LUNs. You can also view the
optimized (fastest paths) available to a LUN.

Host Information
Host Name Identifies the name of the SAN host that has access to the

Oracle FS System.

Management IP
Address

Identifies the IP address of the SAN host. The system uses
this address to exchange management requests and
responses with the FSPM that is installed on the host. If
FSPM is not installed, this field displays N/A.

Operating System Identifies the operating system that is associated with the
SAN host, when Oracle FS Path Manager is installed on
that host; otherwise, this field displays N/A.

Oracle FS Path
Manager Version

Identifies the version of the FSPM that is installed and
running on the SAN host.
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Path Manager Settings
LUN Name Identifies the name of the LUN or Clone LUN on the

Oracle FS System.

Name on Host Identifies the name used by the SAN host to identify the
LUN.

Load Balancing Identifies the type of load balancing that the storage area
network (SAN) hosts performs to access Oracle FS System
LUNs.

Note: If the Load Balancing option is not selectable, then
the version of FSPM does not allow load balancing on the
host.

Valid types:

Static Indicates load balancing
across multiple paths to the
configured LUNs.
The software selects the best
available path, and all
commands are sent over that
path until the path is no
longer operational, in which
case the failed path fails over
to another appropriate path.

Round Robin Indicates load balancing
across multiple paths to the
configured LUNs.
The system sends the
commands one by one using
the best available paths,
which ensures that LUN
commands are evenly
distributed over any path that
is available to access the
LUNs.

Optimized Paths Identifies the number of optimized (fastest path available)
access paths to the LUN.

Non‑Optimized
Paths

Identifies the number of non‑optimized access paths to the
LUN.

Related Links
Modify a Host: FSPM Load Balancing
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Modify Host, iSCSI Access Tab
Navigation: SAN > Storage > Hosts > Actions > Modify Host > iSCSI Access

Modifies the iSCSI access settings for iSCSI connections from a Storage Area
Network (SAN) host.

If you configure iSCSI on a host port and want that port to be able to connect to
the Oracle FS System, you must also configure iSCSI for that port on the
Oracle FS System.

Note: iSCSI settings are only available if the host is configured to use iSCSI.

iSCSI Host Specific Settings
Enable
Authentication

Indicates whether the Challenge Handshake
Authentication Protocol (CHAP) protocol for iSCSI
sessions between the SAN host and the Oracle FS System
is enabled.

Note: Depending on the global settings, the CHAP name
property and the CHAP secret property might not be
required. Those properties are not required, for example,
when authentication is performed through a RADIUS
server.

Chap Name Identifies the name of the iSCSI initiator that is to be used
during authentication.

CHAP Secret Identifies the encrypted CHAP authentication password
(secret) to be used in the exchange of user names and
secrets between two devices. Both devices must support
Point‑to‑Point (PPP) authentication.

Note: The Oracle FS System supports up to 100 UTF‑8
non‑integer characters. However, when connecting to
Windows servers, you must limit the secret to a value from
12 to 16 characters in length.

Retype CHAP
Secret

Confirms the encrypted CHAP authentication password.

Grant Access to
Oracle FS

Specifies whether the Oracle FS System must reject iSCSI
login attempts from initiators that have not explicitly been
granted permission by the user through the Oracle FS
System Manager interface or through the Oracle FS System
Command Line Interface (CLI).

Related Links
Modify a Host: Reconfigure iSCSI Access Settings

Modify Host, Ports Tab
Navigation: SAN > Storage > Hosts > Actions > Modify Host > Ports
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Modifies the host driver information of the storage area network (SAN).

If you are configuring iSCSI on the host port, also configure iSCSI on the
Oracle FS System.

Depending upon the host configuration, the port information is shown as FC or
iSCSI.

Host Name Identifies the name of the SAN host entry.

FC Port Information
Alias Identifies the HBA alternative, friendly, name for the port,

which can be set to any useful value.

Note: Select this field to make necessary changes.

Port Identifies the WWN assigned to an FC HBA port.

Speed Indicates the speed, in Gb/s, of the connection between the
SAN host and the device to which the host is directly
connected. That device is typically a network switch or
possibly the Controller.

Note: The actual data transfer rate between the SAN host
and the Controller can be less than the reported speed. It
can be less because the data transfer rate is governed by the
slowest link on the path between the host and the
Controller.

Manufacturer Identifies the manufacturer of a hardware component.

HBA Model Identifies the model number of a hardware component.

Driver Version Identifies version of the HBA driver.

Firmware Version Identifies the HBA firmware version.

iSCSI Port Information
Alias Identifies an alternative friendly name that is assigned to the

host port.

Note: Select the field to make necessary changes.

iSCSI Device
Name

Identifies the name of the iSCSI initiator for the SAN host. An
initiator encapsulates SCSI commands and data requests
within iSCSI packets and transfers the packets across the IP
network.

IP Addresses Identifies the IP address of the host iSCSI port.

Related Links
Modify a Host: Assign a Port Alias
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Modify Job Schedule Dialog
Navigation: SAN > Storage > LUNs > Actions > ... > Data Protection > Modify

Updates a data replication schedule.

Schedule
Name

Identifies the unique name of a scheduled operation, which is
an action that the Oracle FS System performs at the specified
time or at regular intervals.

Data
Protection
Type

Identifies the type of data protection, such as clone, that is
used in the schedule.

Volume Group Allows you to assign the clone volume to an existing volume
group.

Enabled Indicates whether the schedule is enabled.

• Enable the schedule so that the operation is performed
at the specified time.

• Disable the schedule so that operations are not
performed. This option allows you to define a schedule
before the source volume has been made available to
users.

Start Time Identifies the date and time at which the Oracle FS System
starts a scheduled operation.

Recurrence Identifies how often the system should perform the scheduled
operation. Valid values vary based on the recurrence interval
and frequency of the schedule.

Related Links
Modify Auto-Tiered LUN: Define Data Protection
Modify Single‑Tier LUN: Data Protection

Modify LUN Number Dialog
Navigation: SAN > Storage > LUNs > Actions > Create > Mapping > Modify

Updates the assigned LUN number that is assigned to host.

LUN Number Identifies the number to assign to the LUN for the associated
host.

Related Links
Modify LUN: Define Mapping by LUN Number
Modify LUN: Define Mapping by Selected Host Entries
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Modify SAN LUN, Data Protection Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Modify > Data Protection > Single
Tier

Updates the storage capacity of a logical volume. You can also manage data
replication schedules from this page.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity by Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clone Storage
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
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the Addressable Logical Capacity value that you provided in
the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Current
Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs.
The value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that
you provided in the Quality of Service tab.

Number of
Clones

Identifies the number of clones that have been created for this
LUN and its clones.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
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the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.
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Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
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Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the system
writes the data in two different
locations. This RAID level protects
against the loss of at least one
drive and possibly more drives
with an improvement of the
performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.
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Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
Modify Single‑Tier LUN: Data Protection

Modify SAN LUN, Data Protection Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > Modify > Data Protection > Auto
Tier

Updates the storage capacity of a logical volume. You can also manage data
replication schedules from this page.

Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.
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Enable
Clones

Specifies whether to enable the Capacity for Clones options.
Selecting this option also enables the Specify Clone QoS options.

Capacity for Clones
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
the Addressable Logical Capacity value that you provided in
the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Current
Available
Capacity

Identifies the amount of current storage capacity allocated for
clones of this LUN.

Estimated
Maximum
Capacity

Specifies the estimated storage space to allocate for
Clone LUNs. The value of this field changes as the Maximum
Capacity percentage changes and as the Capacity value
changes that you provided in the Quality of Service tab.

Estimated
Available
Capacity

Identifies the estimated available capacity for Clone LUNs.
The value of this field changes as the Maximum Capacity
percentage changes and as the Capacity value changes that
you provided in the Quality of Service tab.

Number of
Clones

Identifies the number of clones that have been created for this
LUN and its clones.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Domain

Specifies the name of the storage domain associated with the LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

Initial
Storage
Class

Specifies the initial category of physical media on which the logical
volume resides. For auto‑tiered LUNs, the Oracle FS System
determines the actual Storage Class that matches the data usage
statistics on the volume to get the most optimal performance.
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Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Initial
Typical
Access

Identifies the most common method of data access. Valid
biases:

Sequential Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records one after the other
in a physical order.

Random Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records in an arbitrary
order.

Mixed Indicates that the read requests and the
write requests operate on the data
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sometimes in sequential order and
sometimes in random order.

Initial I/
O Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests are for
read operations.

Write Indicates that most of the access requests are for
write operations.

Mixed Indicates that the number of access requests are
similar for read operations and for write
operations.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

Initial
RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
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drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Additional
Options

Displays a dialog that allows you to select Auto Tier
Storage Class options.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
QoS Policies
Modify Auto-Tiered LUN: Define Data Protection

Modify SAN LUN, Mapping Tab
Navigation: SAN > Storage > LUNs > Actions > Modify > Mapping
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Updates the LUN‑to‑host mapping settings for a logical volume.

Access Protocol Specifies the protocols that are allowed for accessing the
logical volume.

Only selected
hosts (via maps)

Specifies that only designated SAN hosts can access this
LUN using a specific, possibly different, LUN number on
each of those hosts. If the LUN is mapped, the LUN
number must be unique to the mapped SAN host.

All hosts may
access this LUN
using LUN
Number

Specifies all SAN hosts accessing this LUN use the same
LUN number. Select this option to activate the LUN
number selection drop-down list.

LUN Controller Assignment
Current
Controller

Identifies the current Controller on which the LUN is homed.

Note: For new source LUNs, this field is not available; instead,
use the Assigned Controller option.

Assigned
Controller

Identifies the Controller to which the system should assign
the LUN. Choose an available Controller node from the list.

Ports Masked for this LUN
Displays the physical Controller ports to exclude (mask) so they cannot access
the LUN.

Masked Indicates whether the port for the LUN is masked.

Protocol Identifies the type of access protocol, FC or iSCSI.

Controller Identifies the name of the Controller.

Slot Identifies the slot number of the Controller HBA.

Port Identifies the Controller port number.

Controller Port
Address

Identifies the unique identifier of each Controller network
port. For FC networks, this identifier is the World Wide
Name (WWN). For iSCSI networks, this identifier is the
Media Access Control (MAC) address.

LUN Mapping
Manages the LUN‑to‑Host mapping assignments.

Note: The LUN mapping table only displays when you select the Only selected
hosts (via maps) option.

You can map a LUN or Clone LUN to either a single host or a host group.
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Hosts
Mapped to
this LUN

Name Identifies the SAN host that accesses LUNs
configured on the Oracle FS System. If the
Oracle FS Path Manager is not installed, the
system displays the WWN of the FC HBA or the
IP address of the iSCSI device.

Map via
LUN
Number

Identifies the number to assign to the LUN for the
associated SAN host. This number must be
unique for that particular host. It need not to be
unique across all hosts.

Create Opens the dialog that allows you to create the LUN-to-host
mapping based on your selections for host name and assign the
LUN number that the host uses.

Modify Opens the dialog that allows you to change the LUN mapped to
the associated host.

Remove Removes the LUN mapping for the selected SAN host.

Related Links
Modify LUN: Define Mapping by LUN Number
Modify LUN: Define Mapping by Selected Host Entries

Modify SAN LUN, Quality of Service Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > Modify > Quality of Service >
Single Tier

Updates an existing logical volume.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity By Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
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achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.
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Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.
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Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the number of copies of the parity bits that
the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the

SAN Tab Reference Pages

529



loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.
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Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.
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Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
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because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
Modify Single‑Tier LUN: Quality of Service

Modify SAN LUN, Quality of Service Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > Modify > Quality of Service >
Auto Tier

Updates an existing logical volume.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Allocation By Storage Class and RAID Level
Indicates graphically the actual physical capacity of the auto‑tiered LUN plus the
capacity that is required for RAID Level parity. The graph contains stacked bars
that represent the sum of the Storage Class physical capacity and the RAID Level
parity. A legend at the bottom of the graphic provides detailed information about
each bar.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

SAN Tab Reference Pages

533



View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties. Selecting this option disables the remaining QoS
properties on the page.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Initial
Storage
Class

Specifies the initial category of physical media on which the
logical volume resides. For auto‑tiered LUNs, the Oracle FS
System determines the actual Storage Class that matches the data
usage statistics on the volume to get the most optimal
performance.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
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For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Initial
Typical
Access

Identifies the most common method of data access. Valid
biases:

Sequential Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records one after the other
in a physical order.

Random Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records in an arbitrary
order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

Initial I/
O Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests are for
read operations.

Write Indicates that most of the access requests are for
write operations.

Mixed Indicates that the number of access requests are
similar for read operations and for write
operations.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

Initial
RAID
Level

Identifies the initial RAID level associated with the
Storage Profile. The Oracle FS System determines the
actual RAID Level that matches the data usage statistics
on the volume to get the most optimal performance.
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Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as
a variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Initial
Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.
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Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.
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Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume can
grow. For a clone, this field identifies how much addressable
space is available. Capacity must be greater than or equal to the
allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference
Tag
Checking

Disables a portion of the internal data integrity checks for the
LUN. Selecting this option disables checking whether any given
block of data has the same identity, known as the Logical Block
Address (LBA), as that which was written by the host. Data CRC
integrity checking is not affected.
If you select the Disable Reference Tag Checking option, then
the Use as a Boot LUN option has no effect.
If necessary, when the LUN is being initialized or is being
prepared by a host or an application, temporarily select the
following options:

• Use as a Boot LUN
• Disable Reference Tag Checking

When the host or application is finished, then deselect these
options.
If your host or application has interoperability problems with the
Oracle FS System, then you can use the Disable Reference Tag
Checking option to temporarily work around the issue.

Note: For information that describes when to select the Disable
Reference Tag Checking option, login to My Oracle Support
(https://support.oracle.com/). Search for the article titled “When
To Use “Use as Boot LUN” and “Disable Reference Tag
Checking” Options For FS1‑2 LUNs.”

Use as a
Boot LUN

Modifies the default error response returned to the host or
application when a block of data is read that has not been
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previously written by the host. There is no other effect on the
LUN.
Select this option if you have hosts and application that read data
blocks that they have not written as part of a validation process,
such as preparing the LUN for system boot.
Reading a data block before it is written causes the reference tag
check to fail, which returns an error to the host. After receiving
this error, the host retries the operation, and inhibits the reference
tag check. The Use as a Boot LUN option does not modify the
reference tag check. This option only changes the error response
because some hosts and applications modify the retry timing
depending on the error that is returned. Always try both settings
of the Use as a Boot LUN option before using the Disable
Reference Tag Checking option.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and maximum)
for this logical volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for clones
of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and maximum)
for this logical volume.

Related Links
QoS Policies
Modify Auto-Tiered LUN: Define Quality of Service

Modify Volume Group Dialog
Navigation:

NAS > Storage > Filesystems > Actions > Create Filesystem > Quality of
Service > Volume Group ... > Volume Groups > Modify
SAN > Storage > LUNs > Actions > Create LUN > Quality of Service > Volume
Group ... > Volume Groups > Modify

Changes the properties of an organizational unit that groups a collection of
logical volumes on the Oracle FS System.

Volume Name Identifies the name of the volume group. Valid volume group
names consist of letters and numerals and can be up to 14
characters in length. Each volume group name must be unique
within its parent volume group.
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Parent
Volume
Group Name

Identifies the name of the top‑level node in a nested volume
group relationship.

Related Links
Modify Auto-Tiered LUN: Define Quality of Service
Modify Single‑Tier LUN: Quality of Service

Replication Engines Overview Page
Navigation: SAN > Data Protection > Replication Engines

Displays the status of the available Oracle MaxRep for SAN Replication Engines
registered with the Oracle FS System. You can manage the Replication Engine
from this page.

Service Status Identifies the health of the processes running on the
Replication Engine.
Valid states:

• Normal
• Warning
• Unknown

Agent Status Identifies the communication status of the Oracle MaxRep
for SAN agents registered with the Oracle FS System.
Valid states:

• All Communicating
• Warning
• Unknown

Name Identifies the name of the Replication Engine.

IP Address Identifies the IP address of the Replication Engine or high
availability Replication Engine cluster.

Version Identifies the Oracle MaxRep for SAN software version that
is running on the Replication Engine.

Clone Schedules Overview Page
Navigation: SAN > Data Protection > Clone Schedules
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Displays a summary of the data protection schedules. You can also create and
manage the data protection schedules.

Name Identifies the name of a schedule. Select a schedule name and
use the Actions menu to review or modify the schedule
settings.

Start Time Identifies the time and date on which the Oracle FS System
started a schedule recurrence.

Frequency Identifies the interval at which the Oracle FS System starts a
recurrent schedule.

Protected
Volume

Identifies the name of the logical volume from which a
Clone LUN was created.

Enabled Identifies whether the data protection schedule is enabled.

Yes Indicates that the schedule is actively cloning the
protected volumes.

No Indicates that the schedule is not cloning the protected
volumes.

Data Protection Overview
Navigation:SAN > Data Protection

Displays links to pages that allow you to manage the data protection schedules
and access connected Oracle FS System Replication Engines.

Clone Schedules Allows you to view the list of available data protection
schedules.

Replication Engines Allows you to view a list of available Replication
Engines.

Hosts Overview Page
Navigation: SAN > Storage > Hosts

Manages properties of the storage area network (SAN) hosts defined on an
Oracle FS System.

Actions from this page allow you to manage the host on the system.

Host Name Identifies the name of the SAN host entry.

Controller-
initiator
Connectivity

Identifies the connection status between the Controller and
initiator port. The status might indicate masked Controller
ports or disabled protocols.
Valid states:
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• Connected
• Connected, Masked
• Connected, Masked, Protocol Disabled
• Connected, Partially Masked
• Connected, Partially Masked, Some Protocols

Disabled
• Connected, Protocol Disabled
• Connected, Some Protocols Disabled
• Not Connected

Number of LUNs
Mapped

Identifies the number of LUNs that are mapped to that
particular SAN host either because of specific mapping or
because the LUN is available to all SAN hosts.

Oracle FS Path Manager
Identifies certain global characteristics associated with the Oracle FS Path
Manager (FSPM).

Status Identifies whether FSPM is communicating, or if it is not registered.
Valid states:

Communicating Indicates that the host control path is logged
into the Pilot. Communicating status is
required for the FSPM control path to report
path status, configure load balancing, and
use the Oracle FS System to collect FSPM
diagnostic logs.

Not
Communicating

The FSPM host control path has previously
logged in to the Pilot, but it is not currently
logged in.

Not Registered A control path from an FSPM host with this
name has never logged in to the Pilot.

Version Identifies the version of the FSPM that is installed and running on
the SAN host.

Host IP
Address

Identifies the IP address of the SAN host. The system uses this
address to exchange management requests and responses with the
FSPM that is installed on the host. If FSPM is not installed, this field
displays N/A.

HBA
HBA Alias Name Identifies an alternative friendly name that is assigned to the

host port.
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SAN LUNs Overview Page
Navigation: SAN > Storage > LUNs

Displays various properties of the logical volumes that are configured on the
Oracle FS System. Actions on this page allow you to manage those volumes as
well as to create an immediate Clone LUN.

Name Identifies the name that is assigned to the LUN.

Status Identifies the status of each LUN.
Valid states:

Online Indicates that the volume is fully
accessible.

Offline Indicates that the volume is not accessible.

Conservative Indicates that the write‑back cache of the
volume is disabled, which reduces system
performance. A Conservative state might
indicate a hardware problem.

Prepared Indicates that the storage resources for the
volume are reserved for the clone, but the
clone is not committed to the storage
device.

Read Only Indicates that the volume is in write
protect mode and is set to read‑only.

Unknown Indicates that not enough information is
obtained from the volume to report its
status.

Background
Activity

Indicates the LUN creation and deletion status.
Valid states:

• Idle
• In‑Progress

Tier
Reallocation

Identifies the tier reallocation status of the Storage Domain.
When tier reallocation is enabled, the Oracle FS System
dedicates resources and uses statistical data and QoS priority
property to migrate data from one storage tier to another.
Valid states:

Enabled Indicates that tier reallocation is active on the
logical volume.

Disabled Indicates that tier reallocation is not active on
the logical volume.
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Storage
Domain
Disabled

Indicates that tier reallocation is disabled on
the Storage Domain and therefore disabled on
the LUN.

Host Access Identifies the SAN host mapping status associated with the
LUN.
Valid states:

Mapped Indicates that the LUN is mapped to one or
more SAN hosts.

No Mappings Indicates that the LUN is not mapped to a
SAN host.

Inactive Indicates that the data path of the LUN is
disabled, which makes the LUN inaccessible
on the network.

All Indicates that the LUN is accessible by all of
the hosts on the network.

Protocol
Access

Identifies the access protocol used to map the LUN to the
Controller.
Protocols include:

• FC only
• iSCSI only
• No Access
• All

Groups Displays the volume group or storage domain to which the
logical volumes belong.

Volume Group Lists the name of the volume group where
the logical volume is located.

Storage Domain Specifies the name of the Storage Domain.

Logical
Capacity
(GB)

Displays the storage requirements for the logical volumes.

Allocated Identifies the total amount of storage
capacity that is reserved for this volume.

Addressable Identifies the capacity limit to which the
volume can grow.

Logical
Distribution

Displays a graphical comparison of the
allocated capacity that this volume uses to
the allocated capacity that is unused.

QoS Displays the RAID and priority levels.
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RAID
Level

Identifies the storage mechanism that is used to
enhance the ability of the system to recover data
from the loss of one or more drives. Possible RAID
levels:

Single
Parity

Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the loss
of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double
Parity

Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the loss
of one or two drives with a slight
cost to write performance. Double
parity is implemented as a variant of
the RAID 6 storage technology.

Mirrored Indicates that no parity bits exist for
the volume. Instead, the system
writes the data in two different
locations. This RAID level protects
against the loss of at least one drive
and possibly more drives with an
improvement of the performance of
random write operations. Mirrored
RAID is implemented as a variant of
the RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to
various operational aspects of a logical volume.
These operational aspects include the Controller
processing queue, the SAN interface requests, and
the migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the
percentage of the Controller CPU cycles that are
dedicated to the volume.

Valid priority levels:

Premium Indicates the highest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
highest priority when the system
migrates the data to the higher-
performing storage tiers.
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High Indicates the next highest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
next highest priority when the
system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive an
intermediate priority when the
system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority
for responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
next to lowest priority when the
system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for
responding to requests in the
processing queue. For auto-tiered
LUNs, busy LUN extents receive the
lowest priority when the system
migrates the data to the higher-
performing storage tiers.

Clone
Capacity
(GB)

Displays the physical storage usage for the Clone LUNs.

Logical
Maximum

Identifies the amount of storage that was
requested for the clone repository.

Physical Used Identifies the amount of clone capacity
that is allocated to the volume for clone
data. The amount of capacity includes the
overhead that is needed to create the
logical volume. The overhead is parity for
data protection.

Physical
Allocated

Identifies the total amount of clone
capacity that the system reserved for the
logical volume. The amount of capacity
includes the overhead that is needed to
create the logical volume.

Physical
Maximum

Identifies the maximum clone capacity
allowed. For clones. This field identifies
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how much space is available for clone
data.

Total
Physical
Capacity
(GB)

Displays the total physical storage capacity for the logical
volumes and Clone LUNs.

LUN Overhead Identifies the physical and logical
storage capacity that is required to
meet the LUN Quality of Service
(QoS) settings.

Allocated Specifies the amount of raw
capacity in gigabytes (GB) that the
system has assigned and
designated to this logical volume.

Maximum Identifies the sum of the
addressable capacity for the logical
volume and its clone repository.

Physical Distribution Displays a graphical comparison of
the capacity that is used to the
maximum capacity that is allocated.

Global LUN Number Identifies the globally unique identifier of the LUN.

LUID Identifies the unique identifier of the LUN.

Statistics and Trending Overview Page
Navigation: SAN > Statistics and Trending

Displays links to pages that provide access to statistics on LUNs and Controller
protocols.

LUNs Opens the LUNs statistics page. You can view details on LUN
statistics as well as real time statistics.

Controller
Protocols

Opens the Controller Protocol statistics page. You can view
details on FC and iSCSI port statistics as well as real time
statistics for those ports.

SAN Storage Overview Page
Navigation: SAN > Storage

Displays links that allow you to create and manage logical volumes and storage
area network (SAN) hosts that are configured on the Oracle FS System.

LUNs Allows the administrator to create, view, and modify a logical
volume within a SAN. Administrators assign storage resources
and Quality of Service (QoS) attributes to each LUN.
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Hosts Allows the administrator to manage the SAN hosts, including
creating host groups, renaming hosts, and, if Oracle FS Path
Manager is not installed, associating hosts with an HBA.

Hosts to
LUN Map

Provides a topology overview of the hosts and associated
mapped LUNs.

LUN to Host
Map

Provides a topology overview of the LUNs and associated
mapped hosts.

View Data Protection Schedule Dialog
Navigation: SAN > Data Protection > Clone Schedules > Actions > View

Displays the data protection schedule properties.

Schedule Name Identifies the name of the scheduled job.

Volume Group
for Created
Clones

Identifies the volume group to which the clone is assigned.

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled
operation performs at the specified
time.

Disabled Indicates that the operation is not
performed as scheduled. Disable the
schedule, for example, when the
source volume (LUN or Clone LUN)
has not been made available to users.

Protected Volume Identifies the name of the logical volume from which the
scheduled clone is created.

Schedule Identifies the schedule of the data protection.

Recurrence Identifies the interval by which the scheduled job occurs.

Related Links
View a LUN Data Protection Schedule

View LUN Statistics Detail
Navigation: SAN > Statistics and Trending > LUNs > Actions > View Details

Displays detailed information about the LUN you selected from the LUNs page.

If the dialog is kept open, the displayed information is refreshed, every two
minutes.
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Name Identifies the name of the selected LUN.

Oracle FS System Performance
Read Throughput Indicates the data transfer rate for read operations.

Write Throughput Indicates the data transfer rate for write operations.

Total Throughput Indicates the data transfer rate for read operations and
write operations.

Read IOPS Indicates the average number of read operations per
second.

Write IOPS Indicates the average number of write operations per
second.

Total IOPS Indicates the total read and writes operations per second.

System Load
Specifies the performance of the LUN while processing I/O requests.

Read Throughput Indicates what the data transfer rate for data inputs, which
are read operations, of the specified LUN would be if the
system devoted all of the CPU resources to the LUN.

Write Throughput Indicates the data transfer rate for data outputs, which are
write operations, of the specified LUN would be if the
system devoted all of the CPU resources to the LUN.

Total Throughput Indicates the average data transfer rate for data read
operations and write operations of the specified LUN
would be if the system devoted all of the CPU resources to
the LUN.

Read IOPS Indicates the average number of read operations per second
for read operations would be if the system devoted all of the
CPU resources to the LUN.

Write IOPS Indicates the average number of write operations per
second for write operations would be if the system devoted
all of the CPU resources to the LUN.

Total IOPS Indicates the combined read and write operations per
second would be if the system devoted all of the CPU
resources to the LUN.

I/O Latency
Specifies the average time to complete a read or write operation (in milliseconds)
and the average operation size (in KB).
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Read Response
Time

Identifies the average time to perform a read operation in
the last sample period.

Write Response
Time

Identifies the average time to perform a write operation in
the last sample period.

Response Time Identifies the average time to perform a read or write
operation in the last sample period.

Read Operation
Size

Identifies the average size of a read operation in the last
sample period.

Write Operation
Size

Identifies the average size of a write operation in the last
sample period.

General
Specifies the I/O activity of the cache usage.

Cache Flushes per
Second

Indicates the rate per second for which cache lines were
flushed (written) to disk in the last sample period.

Cache Hit Ratio Indicates the percentage of read operations that were
completed from the read cache, which is also called cache
hits, in the last sample period.

Read-Ahead IOPS Indicates the average read operations per second from read-
ahead fetching in the last sample period.  Read-ahead
fetching utilizes read access behavior in the sample period
to determine read-ahead IOPS.

Non-Optimized
IOPS

Indicates the total read operations and write operations per
second that passed through non‑optimized data paths in the
last sample period. Optimized paths are preferred over
 non‑optimized paths for performance. Non‑optimized
paths occur when there is no path management software
used to manage data paths, the path management software
is not configured correctly, or an optimized path is not
available.
Path management software and applications provide load
balancing and path management for improved performance

Related Links
View Detailed LUN Statistics

View Details Dialog (Fibre Channel)
Navigation: SAN > Statistics and Trending > Controller Protocols > Actions >
View Details
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Displays information about the Fibre Channel (FC) port you have selected on the
Controller Statistics page.

The View Details panel displays data shown in the Controller Protocol Statistics
page as well as additional information. The information displayed is refreshed, if
the panel is kept open, every two minutes as this is the collection period time.

Name Identifies the name of the Controller.

Slot Identifies the HBA location (slots 1, 4, and 5) on the Controller.

Port Number Identifies the HBA port numbers on the Controller.

Port Type Identifies the HBA port type.

General Information

Read Throughput Identifies the data transfer rate for data inputs (reads).

Write Throughput Identifies the data transfer rate for data outputs (writes).

Total Throughput Identifies the average combined input and output data
transfer rates (reads and writes).

Total IOPS Identifies the total number of I/O operations per second.

Performance

Max Read
Throughput

Identifies the maximum input data transfer rate (reads).

Max Write
Throughput

Identifies the maximum output data transfer rate (writes).

Max Total
Throughput

Identifies the maximum combined input and output data
transfer rate (reads and writes).

Max Read IOPS Identifies the maximum number of input (read) I/O
operations per second.

Max Write IOPS Identifies the maximum number of output (write) I/O
operations per second.

Max Total IOPS Identifies the maximum total number of input and output
(read and write) I/O operations per second.

SCSI Task Management Operations
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Abort Task Indicates the number of abort task commands processed on
the selected port.

Abort Task Set Indicates the number of abort task set commands processed
on the selected port.
A task set is a group of tasks.

Clear ACA Indicates the number of Clear ACA (Auto Contingent
Allegiance) commands processed on the selected port.

Clear Task Set Indicates the number of clear task set commands processed
on the selected port.

Logical Unit Reset Indicates the number of reset logical unit commands
processed on the selected port.

Target Reset Indicates the number of target reset commands processed
on the selected port.

I/O Latency
Specifies the average time to complete a read or write operation (in milliseconds)
and the average operation size (in KB).

Read Response
Time

Identifies the average time to perform a read operation in
the last sample period.

Write Response
Time

Identifies the average time to perform a write operation in
the last sample period.

Response Time Identifies the average time to perform a read or write
operation in the last sample period.

Read Operation
Size

Identifies the average size of a read operation in the last
sample period.

Write Operation
Size

Identifies the average size of a write operation in the last
sample period.

Channel Errors

Total Channel
Errors

Indicates the total number of channel errors associated with
this port.

Command
Timeout Errors

Indicates the number of command timeout errors that have
occurred on the channel associated with this port.

DMA Errors Indicates the number of Direct Memory Access (DMA)
errors that have occurred on the channel associated with
this port.
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Invalid RXID
Errors

Indicates the number of invalid responder exchange
identifier (RXID) errors that have occurred on the channel
associated with this port.

Loop Init Errors Indicates the number of loop initialization errors that have
occurred on the channel associated with this port.

Overrun Errors Indicates the number of overrun errors that have occurred
on the channel associated with this port.

PCI Errors Indicates the number of Peripheral Component Interconnect
(PCI) errors that have occurred on the channel associated
with this port.

Port Unavailable
Errors

Indicates the number of port unavailable errors that have
occurred on the channel associated with this port.

Reselection
Timeout Errors

Indicates the number of reselection timeout errors that have
occurred on the channel associated with this port.

Bad Frame Errors Indicates the number of frames dropped from first‑in or
first‑out buffer that have occurred on the channel associated
with this port.

System Errors Indicates the number of system errors that have occurred on
the channel associated with this port.

Unacknowledged
Host Event Errors

Indicates the number of unacknowledged host event errors
that have occurred on the channel associated with this port.

Underrun Errors Indicates the number of underrun errors that have occurred
on the channel associated with this port.

Transfer Errors Indicates the number of data transfer errors that have
occurred on the channel associated with this port.

Loop Activity

LIPs Indicates the number of loop initialization primitive (LIP)
sequences which are used to initialize or reset attached
ports to a known state.

Loop Ups Indicates the number of loop ports that are up and
available.

Loop Downs Indicates the number of loop ports that are down and not
available.

Related Links
View Detailed SAN Controller Protocols Statistics
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View Details Dialog (iSCSI)
Navigation: SAN > Statistics and Trending > Controller Protocols > Actions >
View Details

Displays information about the iSCSI port you selected on them Controller
Protocol Statistics page.

The View Details panel displays data shown in the Controller Protocol Statistics
page and other information. If the panel is kept open, the information displayed
is refreshed every two minute.

Name Identifies the name of the Controller.

Slot Identifies the HBA location (slots 1, 4, and 5) on the Controller.

Port Number Identifies the HBA port numbers on the Controller.

Port Type Identifies the HBA port type.

General Information
Read Throughput Identifies the data transfer rate for data inputs (reads).

Write Throughput Identifies the data transfer rate for data outputs (writes).

Total Throughput Identifies the average combined input and output data
transfer rates (reads and writes).

Performance
Max Read
Throughput

Identifies the maximum input data transfer rate (reads).

Max Write
Throughput

Identifies the maximum output data transfer rate (writes).

Max Total
Throughput

Identifies the maximum combined input and output data
transfer rate (reads and writes).

Max Read IOPS Identifies the maximum number of input (read) I/O
operations per second.

Max Write IOPS Identifies the maximum number of output (write) I/O
operations per second.

Max Total IOPS Identifies the maximum total number of input and output
(read and write) I/O operations per second.

SCSI Task Management Operations
Abort Task Indicates the number of abort task commands processed on

the selected port.
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Abort Task Set Indicates the number of abort task set commands processed
on the selected port.
A task set is a group of tasks.

Clear ACA Indicates the number of Clear ACA (Auto Contingent
Allegiance) commands processed on the selected port.

Clear Task Set Indicates the number of clear task set commands processed
on the selected port.

Logical Unit Reset Indicates the number of reset logical unit commands
processed on the selected port.

Target Reset Indicates the number of target reset commands processed
on the selected port.

I/O Latency
Specifies the average time to complete a read or write operation (in milliseconds)
and the average operation size (in KB).

Read Response
Time

Identifies the average time to perform a read operation in
the last sample period.

Write Response
Time

Identifies the average time to perform a write operation in
the last sample period.

Response Time Identifies the average time to perform a read or write
operation in the last sample period.

Read Operation
Size

Identifies the average size of a read operation in the last
sample period.

Write Operation
Size

Identifies the average size of a write operation in the last
sample period.

iSCSI Port Errors
Underrun Errors Indicates the number of underrun errors during the

collection period.

Overrun Errors Indicates the number of overrun errors during the collection
period.

Command
Timeout Errors

Indicates the number of command timeout errors during
the collection period.

DMA Errors Indicates the number of Direct Memory Access (DMA)
errors during the collection period.

Transport Errors Indicates the number of transport errors during the
collection period.
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Device
Unavailable Errors

Indicates the number of device unavailable errors during
the collection period.

Data Digest Errors Indicates the number of data digest errors during the
collection period.

Header Digest
Errors

Indicates the number of header digest errors during the
collection period.

Invalid Snack
Errors

Indicates the number of invalid SNACK (selective negative
acknowledgment) errors during the collection period.

Unsolicited Data
Errors

Indicates the number of unsolicited data errors, which are
SCSI writes which include data but immediate data is
disabled because the total data string would exceed the
burst length, during the collection period.

Unexpected Data
SN Errors

Indicates the number of unexpected data storage network
(SN) errors caused from data sequence number in the
Protocl Data Unit (PDU) during the collection period.

Initiator Task Tag
Errors

Indicates the number of initiator task tag errors during the
collection period.

System Errors Indicates the number of system errors during the collection
period.

MAC CRC Errors Indicates the number of Media Access Control Cyclic
Redundancy Check (MAC CRC) errors during the collection
period.

MAC Encoding
Errors

Indicates the number of MAC encoding errors during the
collection period.

iSNS Errors Indicates the number of Internet storage name service
(iSNS) errors during the collection period.

Command PDUs
Rejected

Indicates the number of command Protocol Data Unit
(PDUs) rejected during the collection period.

Connection
Failures

Indicates the number of connection failures during the
collection period.

Session Login
Failures

Indicates the number of session login failures during the
collection period.

FW Dump Errors Indicates the number of firmware (FW) dump errors during
the collection period.

iSCSI Port Requests
Reinitialize
Requests

Indicates the number of re-initialization requests during the
collection period.
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Target Cold Reset
Requests

Indicates the number of cold target reset requests during
the collection period. A target cold reset cancels all pending
operations.

Task Reassign
Requests

Indicates the number of task reassign requests during the
collection period. A task reassign creates a new allegiance
connection for the task.

ISNS Messages Indicates the number of Internet Storage Name Service
(iSNS) messages during the collection period.

iSCSI Port Events
Link Up Events Indicates the number of link up events during the collection

period.

Link Down Events Indicates the number of link down events during the
collection period.

IP Address
Change Events

Indicates the number of IP address change events during
the collection period.

Duplicate IP
Address Events

Indicates the number of duplicate IP address events during
the collection period.

Related Links
View Detailed SAN Controller Protocols Statistics

View Host, Advanced Tab
Navigation: SAN > Storage > Hosts > Actions > View Host > Advanced

Displays the HP compatibility option setting for the selected Storage Area
Network (SAN) host.

HP-UX
Compatibility
Mode

Use this option when the SAN host is running the HP-UX
operating system. When compatibility mode option is
enabled, the system uses an alternative method to present
LUNs on the SAN host. This alternative method is
compatible with HP-UX. When this option is enabled, you
might not have a LUN visible to the host as LUN number 0.
HP-UX compatibility mode enables the full range of LUN
numbers (other than 0) to be used with HP-UX operating
systems. You can verify the current host mappings from the
Flash Storage Path Manager tab.

Related Links
View SAN Host Entry Settings
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View Host, Oracle FS Path Manager Tab
Navigation: SAN > Storage > Hosts > Actions > View Host > Oracle FS Path
Manager

Displays configuration information about Oracle FS Path Manager that is
running on the host.

Host Information
Host Name Identifies the name of the SAN host entry.

Management IP
Address

Identifies the IP address of the SAN host. The system uses
this address to exchange management requests and
responses with the FSPM that is installed on the host. If
FSPM is not installed, this field displays N/A.

Operating System Identifies the operating system that is associated with the
SAN host, when Oracle FS Path Manager is installed on
that host; otherwise, this field displays N/A.

Oracle FS Path
Manager Version

Identifies the version of the FSPM that is installed and
running on the SAN host.

Oracle FS Path Manager Settings
LUN Name Identifies the name of the LUN or Clone LUN on the Oracle FS

System.

Name on Host Identifies the name used by the SAN host to identify the
LUN.

Load Balancing Identifies the type of load balancing that the storage area
network (SAN) hosts performs to access Oracle FS System
LUNs.

Note: If the Load Balancing option is not selectable, then
the version of FSPM does not allow load balancing on the
host.

Valid types:

Static Indicates load balancing
across multiple paths to the
configured LUNs.
The software selects the best
available path, and all
commands are sent over that
path until the path is no
longer operational, in which
case the failed path fails over
to another appropriate path.
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Round Robin Indicates load balancing
across multiple paths to the
configured LUNs.
The system sends the
commands one by one using
the best available paths,
which ensures that LUN
commands are evenly
distributed over any path
that is available to access the
LUNs.

Number of
Optimized Paths

Identifies the number of optimized (fastest path available)
access paths to the LUN.

Number of
Non‑Optimized
Paths

Identifies the number of non‑optimized access paths to
the LUN.

Related Links
View SAN Host Entry Settings

View Host, iSCSI Access Tab
Navigation: SAN > Storage > Hosts > Actions > View Host > iSCSI Access

Displays iSCSI information for the Storage Area Network (SAN) host.

Note: iSCSI settings are not available for a SAN host using Fibre Channel
protocol.

iSCSI Host Specific Settings
Enable
Authentication

Indicates whether the Challenge Handshake
Authentication Protocol (CHAP) protocol for iSCSI
sessions between the SAN host and the Oracle FS System
is enabled.

Note: Depending on the global settings, the CHAP name
property and the CHAP secret property might not be
required. Those properties are not required, for example,
when authentication is performed through a RADIUS
server.

Chap Name Identifies the name of the iSCSI initiator that is to be used
during authentication.

CHAP Secret Identifies the encrypted CHAP authentication password
(secret) to be used in the exchange of user names and
secrets between two devices. Both devices must support
Point‑to‑Point (PPP) authentication.

SAN Tab Reference Pages

559



Retype CHAP
Secret

No information is available for this field.

Grant Access to
Oracle FS

Specifies whether the Oracle FS System must reject iSCSI
login attempts from initiators that have not explicitly been
granted permission by the user through the Oracle FS
System Manager interface or through the Oracle FS
System Command Line Interface (CLI).

Related Links
View SAN Host Entry Settings

View Host, Ports Tab
Navigation: SAN > Stroage > Hosts > Actions > View Host > Ports

Displays port information about a selected host.

Host Name Identifies the name of the SAN host entry.

FC Port Information
Alias Identifies an alternative friendly name that is assigned to

the host port.

Port Identifies the WWN assigned to a Fibre Channel HBA port.

Speed Indicates the speed, in Gb/s, of the connection between the
SAN host and the device to which the host is directly
connected. That device is typically a network switch or
possibly the Controller.

Note: The actual data transfer rate between the SAN host
and the Controller can be less than the reported speed. It
can be less because the data transfer rate is governed by the
slowest link on the path between the host and the
Controller.

Manufacturer Identifies the manufacturer of a hardware component.

HBA Model Identifies the model number of a hardware component.

Driver Version Identifies version of the HBA driver.

Firmware Version Identifies the HBA firmware version.

iSCSI Port Information
Alias Identifies an alternative friendly name that is assigned to the

host port.

iSCSI Device
Name

Identifies the name of the iSCSI initiator for the SAN host.
An initiator encapsulates SCSI commands and data requests
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within iSCSI packets and transfers the packets across the IP
network.

IP Addresses Identifies the IP address of the host iSCSI port.

Related Links
View SAN Host Entry Settings

View SAN LUN, Data Protection Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > View > Data Protection > Single
Tier

Displays the data replication schedules of a logical volume.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity by Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Enable Clones Indicates whether the Capacity for Clones option is set.
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Capacity for Clone Storage
Maximum
capacity

Specifies the percentage of storage space to allocate for
Clone LUNs.

Note: Changes to this field updates the Maximum and
Available Capacity values. The capacity values are based on
the Addressable Logical Capacity value that you provided
in the Quality of Service tab.

Current
Maximum
Capacity

Identifies the maximum capacity to which the logical
volume can grow. For a clone, this field identifies how
much addressable space is available. Capacity must be
greater than or equal to the allocated logical capacity.

Current Available
Capacity

Identifies the amount of current storage capacity allocated
for clones of this LUN.

Number of
Clones (of this
clone)

Identifies the number of clones that have been created for
this LUN.

Number of
Clones (total)

Identifies the number of clones that have been created for
this LUN and its clones.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Specifies the enhanced QoS settings to apply to the clone storage that are created
by the data protection schedule, or manually created by the administrator.

Storage
Class

Specifies the category of physical media on which the logical volume
resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve the
optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed hard
disk drives (HDDs). This Storage Class sacrifices
some capacity to reduce the access time and the
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latency of the read operations and of the write
operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:
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Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the system
writes the data in two different
locations. This RAID level protects
against the loss of at least one
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drive and possibly more drives
with an improvement of the
performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the highest priority when the
system migrates the data to the higher-performing
storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next highest priority when
the system migrates the data to the higher-performing
storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive an intermediate priority when
the system migrates the data to the higher-performing
storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered LUNs,
busy LUN extents receive the next to lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Archive Indicates the lowest priority for responding to requests
in the processing queue. For auto-tiered LUNs, busy
LUN extents receive the lowest priority when the system
migrates the data to the higher-performing storage tiers.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.
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Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
Display Clone LUN Details

View SAN LUN, Data Protection Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > View > Data Protection > Auto
Tier

Displays the data replication schedules of a logical volume.

Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Enable Clones Indicates whether the Capacity for Clones option is set.

Capacity for Clones
Maximum capacity Specifies the percentage of storage space to allocate for

Clone LUNs.

Current Maximum
Capacity

Identifies the maximum capacity to which the logical
volume can grow. For a clone, this field identifies how
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much addressable space is available. Capacity must be
greater than or equal to the allocated logical capacity.

Current Available
Capacity

Identifies the amount of current storage capacity
allocated for clones of this LUN.

Number of Clones
(of this clone)

Identifies the number of clones that have been created for
this LUN.

Number of Clones
(total)

Identifies the number of clones that have been created for
this LUN and its clones.

Match Repository QoS
to LUN QoS

Specifies whether to apply the clone storage QoS
properties using a Data Protection schedule, or
manually applied by the administrator.

Clone Storage QoS
Indicates the QoS settings that are applied to the logical volume.

Initial
Storage
Class

Indicates the category of physical media on which the logical volume
resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and for
read operations. The write performance for this
Storage Class is sacrificed somewhat to achieve
the optimizations for read performance and for
capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access time
and the latency of the read operations and of the
write operations.

Capacity Disk Specifies that the data is stored on high‑capacity,
rotating HDDs. This Storage Class optimizes
capacity at some sacrifice of speed. For a storage
system that does not include tape storage as an
option, this Storage Class always provides the
lowest cost for each GB of capacity.

Basic Initial
Typical
Access

Identifies the most common method of data access. Valid
biases:
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Sequential Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records one after the other
in a physical order.

Random Indicates that the read requests and the
write requests operate on the data mostly
by accessing the records in an arbitrary
order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

Initial I/
O Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests are for
read operations.

Write Indicates that most of the access requests are for
write operations.

Mixed Indicates that the number of access requests are
similar for read operations and for write
operations.

Advanced Initial
RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as
a variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
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system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Clone Schedules
Lists the data protection schedules that are associated with the logical volume.

Name Identifies the name of the schedule.

Start Time Identifies the date and time that the schedule begins.

Frequency Identifies the frequency at which the schedule runs. Frequencies
include:

• Run Once
• Hourly
• Daily
• Weekly

Enabled Identifies whether the schedule is enabled.

Enabled Indicates that the scheduled operation
performs at the specified time.

Disabled Indicates that the operation is not performed
as scheduled. Disable the schedule, for
example, when the source volume (LUN or
Clone LUN) has not been made available to
users.

Create Displays a dialog to create a scheduled operation.

Modify Displays a dialog to modify an existing schedule.

Delete Removes an existing schedule.

Related Links
Display Clone LUN Details

View SAN LUN, Mapping Tab
Navigation: SAN > Storage > LUNs > Actions > View > Mapping
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Displays the LUN‑to‑host mapping settings for a logical volume.

Access Protocol Specifies the protocols that are allowed for accessing the
logical volume.

Only selected
hosts (via maps)

Specifies that only designated SAN hosts can access this
LUN using a specific, possibly different, LUN number on
each of those hosts. If the LUN is mapped, the LUN
number must be unique to the mapped SAN host.

All hosts may
access this LUN
using LUN
Number

Specifies all SAN hosts accessing this LUN use the same
LUN number. Select this option to activate the LUN
number selection drop-down list.

LUN Controller Assignment
Current
Controller

Identifies the current Controller on which the LUN is homed.

Note: For new source LUNs, this field is not available; instead,
use the Assigned Controller option.

Assigned
Controller

Identifies the Controller to which the system should assign
the LUN. Choose an available Controller node from the list.

Ports Masked for this LUN
Displays the physical Controller ports to exclude (mask) so they cannot access
the LUN.

Masked Indicates whether the port for the LUN is masked.

Protocol Identifies the type of access protocol, FC or iSCSI.

Controller Identifies the name of the Controller.

Slot Identifies the slot number of the Controller HBA.

Port Identifies the Controller port number.

Controller Port
Address

Identifies the unique identifier of each Controller network
port. For FC networks, this identifier is the World Wide
Name (WWN). For iSCSI networks, this identifier is the
Media Access Control (MAC) address.

LUN Mapping
Manages the LUN‑to‑Host mapping assignments.

Note: The LUN mapping table only displays when you select the Only selected
hosts (via maps) option.

You can map a LUN or Clone LUN to either a single host or a host group.
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Hosts
Mapped to
this LUN

Name Identifies the SAN host that accesses LUNs
configured on the Oracle FS System. If the
Oracle FS Path Manager is not installed, the
system displays the WWN of the FC HBA or the
IP address of the iSCSI device.

Map via
LUN
Number

Identifies the number to assign to the LUN for the
associated SAN host. This number must be
unique for that particular host. It need not to be
unique across all hosts.

Create Opens the dialog that allows you to create the LUN-to-host
mapping based on your selections for host name and assign the
LUN number that the host uses.

Modify Opens the dialog that allows you to change the LUN mapped to
the associated host.

Remove Removes the LUN mapping for the selected SAN host.

Related Links
Display LUN Details

View SAN LUN, Quality of Service Tab, Single Tier
Navigation: SAN > Storage > LUNs > Actions > View > Quality of Service > Single
Tier

Displays the QoS properties of a selected logical volume.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.

Capacity By Storage Class
Identifies the type of physical media on which the data is stored. Valid media
types (listed from the highest performance priority to the lowest performance
priority):

Performance
SSD

Specifies that the data is stored on solid state drives (SSDs) that
are optimized for the performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are optimized for
the performance of capacity and for read operations. The write
performance for this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance and for
capacity.
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Performance
Disk

Specifies that the data is stored on high‑speed hard disk drives
(HDDs). This Storage Class sacrifices some capacity to reduce
the access time and the latency of the read operations and of
the write operations.

Capacity Disk Specifies that the data is stored on high‑capacity, rotating
HDDs. This Storage Class optimizes capacity at some sacrifice
of speed. For a storage system that does not include tape
storage as an option, this Storage Class always provides the
lowest cost for each GB of capacity.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Uses
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
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this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.

Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of
capacity.

Basic Allows you to specify indirectly the parity level of the data and the read-
ahead policy for the data. You specify those properties indirectly by
selecting how the data is typically accessed and the level of data
protection that is desired.

Note: After you select how the data is typically accessed and the level of
redundancy for the data, the system displays the parity level and the
read-ahead policy for the volume that supports your selections.

Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

I/O Bias Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.
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Mixed Indicates that the number of access requests
are similar for read operations and for write
operations.

Redundancy Identifies the number of copies of the parity bits that
the Oracle FS System creates for the volume.
Valid redundancy levels:

Single Stores the original user data plus one set of
parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the default
redundancy level for the Storage Classes
that specify the capacity-type media.

Advanced Allows you to specify directly the parity level of the data and the
read-ahead policy for the data.

Important: Use of this option clears the selections, if any, that were
made in the Basic option.

RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
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Double parity is implemented as a
variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of at
least one drive and possibly more
drives with an improvement of
the performance of random write
operations. Mirrored RAID is
implemented as a variant of the
RAID 10 storage technology.

Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.
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Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.
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Capacity Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference Tag
Checking

Indicates that a portion of the internal data integrity checks is
disabled for the LUN. If set, the Use as a Boot LUN option has
no effect.

Use as a Boot
LUN

Indicates the status returned from the LUN is modified for
unwritten data blocks. Setting this option affects the host or
application retry timing.

Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute
selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and
maximum) for this logical
volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for
clones of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and
maximum) for this logical
volume.

Related Links
Display LUN Details

View SAN LUN, Quality of Service Tab, Auto Tier
Navigation: SAN > Storage > LUNs > Actions > View > Quality of Service > Auto
Tier

Displays the QoS properties of a selected logical volume.

Selected Storage Domain Capacity
Displays the storage capacity of the selected storage class and Storage Domain
that is available for the logical volume. The graph uses colored bars of different
thicknesses to indicate the capacity status of the logical volume you are creating
as well as the overall system capacity.
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Allocation By Storage Class and RAID Level
Indicates graphically the actual physical capacity of the auto‑tiered LUN plus the
capacity that is required for RAID Level parity. The graph contains stacked bars
that represent the sum of the Storage Class physical capacity and the RAID Level
parity. A legend at the bottom of the graphic provides detailed information about
each bar.

Storage
Domain

Specifies the name of the storage domain associated with the
LUN.

Note: All Storage Domain options appear when the Oracle FS
System contains custom Storage Domains.

View
Storage
Domains

Displays a dialog that lists the available Storage Domains.

LUN Name Identifies the name that is assigned to a LUN for administrative
purposes. LUN names must meet the following requirements:

• Must be unique across the Oracle FS System
• Must be 82 or fewer UTF characters
• Must be 255 or fewer ASCII characters

Volume
Group

Allows you to assign the LUN to a volume group.

[...] Opens the Manage Volume Groups dialog,
which allows you to create a volume group.

Use
Storage
Profile

Specifies whether the logical volume uses a custom set of QoS
properties.

[...] Opens the View Storage Profiles dialog,
which allows you to review the profile
details.

Initial
Storage
Class

Specifies the category of physical media on which the logical
volume resides.
Valid media types:

Performance
SSD

Specifies that the data is stored on solid state
drives (SSDs) that are optimized for the
performance of balanced read and write
operations.

Capacity SSD Specifies that the data is stored on SSDs that are
optimized for the performance of capacity and
for read operations. The write performance for
this Storage Class is sacrificed somewhat to
achieve the optimizations for read performance
and for capacity.
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Performance
Disk

Specifies that the data is stored on high‑speed
hard disk drives (HDDs). This Storage Class
sacrifices some capacity to reduce the access
time and the latency of the read operations and
of the write operations.

Capacity Disk Specifies that the data is stored on high‑
capacity, rotating HDDs. This Storage Class
optimizes capacity at some sacrifice of speed.
For a storage system that does not include tape
storage as an option, this Storage Class always
provides the lowest cost for each GB of
capacity.

Basic Initial Typical
Access

Identifies the most common method of data access.
Valid biases:

Sequential Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records one
after the other in a physical order.

Random Indicates that the read requests and the
write requests operate on the data
mostly by accessing the records in an
arbitrary order.

Mixed Indicates that the read requests and the
write requests operate on the data
sometimes in sequential order and
sometimes in random order.

Initial I/O
Bias

Identifies the typical read‑write ratio. Valid I/O biases:

Read Indicates that most of the access requests
are for read operations.

Write Indicates that most of the access requests
are for write operations.

Mixed Indicates that the number of access requests
are similar for read operations and for
write operations.

Initial
Redundancy

Identifies the RAID level associated with the Storage
Profile.
Valid redundancy levels:

Single Stores the original user data plus one set
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
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after the failure of one drive. Single parity
is implemented using RAID 5 technology
and is the default redundancy level for the
Storage Classes that specify the
performance-type media.

Double Stores the original user data plus two sets
of parity bits to help in the recovery of lost
data. Access to the data is preserved even
after the simultaneous failure of two
drives. Double parity is implemented
using RAID 6 technology and is the
default redundancy level for the Storage
Classes that specify the capacity-type
media.

Advanced Initial
RAID
Level

Identifies the RAID level associated with the Storage
Profile.
Possible RAID levels:

Single parity Indicates that, in addition to the
actual data, one set of parity bits
exists for the logical volume. This
parity level protects against the
loss of one drive. Single parity is
implemented as a variant of the
RAID 5 storage technology.

Double parity Indicates that, in addition to the
actual data, two sets of parity bits
exist for the logical volume. This
parity level protects against the
loss of one or two drives with a
slight cost to write performance.
Double parity is implemented as
a variant of the RAID 6 storage
technology.

Mirrored Indicates that no parity bits exist
for the volume. Instead, the
system writes the data in two
different locations. This RAID
level protects against the loss of
at least one drive and possibly
more drives with an
improvement of the performance
of random write operations.
Mirrored RAID is implemented
as a variant of the RAID 10
storage technology.

SAN Tab Reference Pages

580



Initial
Read
Ahead

Identifies the read‑ahead policy that the system uses for
sequential read operations. The policy determines the
amount of additional data, if any, that the system places
into the Controller cache. Valid policies:

Normal Indicates that the input
requests and the output
requests are accessing the
data mostly in a random
manner or in a mixed
sequential and random
manner.

Aggressive Indicates that the input
requests and the output
requests are accessing the
data mostly in a sequential
manner and that the
workload is biased toward
read operations.

Conservative Indicates that the input
requests and the output
requests are mostly
sequential and that the
workload is biased toward
write operations.

Priority
Level

Identifies the priority that the system gives to various operational
aspects of a logical volume. These operational aspects include the
Controller processing queue, the SAN interface requests, and the
migration of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the percentage of the
Controller CPU cycles that are dedicated to the volume.

Premium Indicates the highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the highest priority
when the system migrates the data to the higher-
performing storage tiers.

High Indicates the next highest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next highest
priority when the system migrates the data to the
higher-performing storage tiers.

Medium Indicates an intermediate priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive an intermediate
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priority when the system migrates the data to the
higher-performing storage tiers.

Low Indicates the next to lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the next to lowest
priority when the system migrates the data to the
higher-performing storage tiers.

Archive Indicates the lowest priority for responding to
requests in the processing queue. For auto-tiered
LUNs, busy LUN extents receive the lowest priority
when the system migrates the data to the higher-
performing storage tiers.

Migration/
Copy
Priority

Identifies the strategy the system should use to control the impact
on performance when background tasks need to copy or move
data from one location in the storage pool to another.

Note: When the system is idle or lightly loaded, the background
task maximizes the amount of work done regardless of the option
selected.

Valid priorities:

System Chooses Balances the background copy with the
incoming client I/O. This option is the
default.

Minimize Impact Restricts the amount of work performed on
a loaded system. This option is intended to
have a minimal impact on client I/O
throughput at the expense of longer copy
times.

Maximum Speed Prioritizes the background copy at the
expense of client I/O throughput.

Capacity Identifies the maximum capacity to which the logical volume
can grow. For a clone, this field identifies how much
addressable space is available. Capacity must be greater than
or equal to the allocated logical capacity.

Allocated
Logical
Capacity

Identifies the amount of capacity that is reserved for the logical
volume. The reserve capacity must be less than or equal to the
maximum capacity.

Disable
Reference Tag
Checking

Indicates that a portion of the internal data integrity checks is
disabled for the LUN. If set, the Use as a Boot LUN option has
no effect.

Use as a Boot
LUN

Indicates the status returned from the LUN is modified for
unwritten data blocks. Setting this option affects the host or
application retry timing.
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Capacity
Estimates

Provides an estimate of the physical storage capacity
requirements, which are based on your QoS attribute
selections.

Estimated Physical
Capacity

Identifies the estimated physical
capacity (allocated and
maximum) for this logical
volume.

Estimated Clone
Capacity

Identifies the estimated capacity
(allocated and maximum) for
clones of this logical volume.

Estimated Total
Capacity

Identifies the estimated total
capacity (allocated and
maximum) for this logical
volume.

Related Links
Display LUN Details

Volume Groups Overview Page
Navigation:

NAS > Volume Groups
SAN > Volume Groups

Manages the volume groups and the logical volumes that are configured on the
Oracle FS System.

From this page you can create, modify, view, and delete volume groups and
logical volumes. You can copy and clone the logical volumes. You can also
change the QoS settings of any volume from standard to enhanced.

Note: A dash in a field signifies that the property does not apply to the volume.

Name Lists the names of the logical volumes and the names of the volume
groups that are configured on this Oracle FS System. If a logical volume
belongs to a volume group, the volume is listed beneath that group.

Status Identifies the accessibility of the logical volume.

filesystems Valid states:

Online Indicates that the filesystem is fully
accessible and functional.

Busy Indicates that the filesystem is fully
functional but no external access is
currently allowed.
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Degraded
Writes

Indicates that the filesystem is
functional but, instead of writing the
data to the Controller journal, the
system is writing the data directly to
disk. As a result, the performance of
the filesystem is degraded.

Read-Only Indicates that the Controller journal
has been pinned or that the journal has
been lost.

Partial
Online

Indicates that the filesystem is
functional but one or more of the data
tiers is offline.

Offline Indicates that the filesystem is not
accessible.

LUNs Valid states:

Online Indicates that the volume is fully
accessible.

Offline Indicates that the volume is not
accessible.

Conservative Indicates that the write‑back cache
of the volume is disabled, which
reduces system performance. A
Conservative state might indicate
a hardware problem.

Prepared Indicates that the storage
resources for the volume are
reserved for the clone, but the
clone is not committed to the
storage device.

Read Only Indicates that the volume is in
write protect mode and is set to
read‑only.

Unknown Indicates that not enough
information is obtained from the
volume to report its status.

Logical Capacity (GB)
Provides an overview of the logical capacity usage and the logical capacity
requirements of the volume group.

Used Indicates the amount of allocated capacity that is consumed.
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• For LUNs, this amount is the same as the allocated
amount.

• For filesystems, this amount is the allocated capacity
that contains user data.

Allocated Identifies the total amount of storage capacity that is reserved
for this volume or this volume group.

Addressable Identifies the capacity limit to which the volume can grow.

Distribution Displays a graphical comparison of the allocated capacity that
this volume uses to the unused allocated capacity.

Logical
Maximum

Identifies the sum of the addressable capacity for the logical
volume and its clone repository.

Capacity (GB) for Clone LUNs
Provides an overview of the physical capacity usage and the physical capacity
requirements of any Clone LUNs that might exist in the volume group.

Physical Used Identifies the amount of clone capacity that is
allocated to the volume for clone data. The amount of
capacity includes the overhead that is needed to
create the logical volume. The overhead is parity for
data protection.

Physical Allocated Identifies the total amount of clone capacity that the
system reserved for the logical volume. The amount
of capacity includes the overhead that is needed to
create the logical volume.

Physical Maximum Identifies the maximum clone capacity allowed. For
clones. This field identifies how much space is
available for clone data.

 

RAID
Level

Single parity Indicates that, in addition to the actual data, one
set of parity bits exists for the logical volume.
This parity level protects against the loss of one
drive. Single parity is implemented as a variant
of the RAID 5 storage technology.

Double parity Indicates that, in addition to the actual data,
two sets of parity bits exist for the logical
volume. This parity level protects against the
loss of one or two drives with a slight cost to
write performance. Double parity is
implemented as a variant of the RAID 6 storage
technology.
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Mirrored Indicates that no parity bits exist for the
volume. Instead, the system writes the data in
two different locations. This RAID level protects
against the loss of at least one drive and
possibly more drives with an improvement of
the performance of random write operations.
Mirrored RAID is implemented as a variant of
the RAID 10 storage technology.

Note: For LUNs, the system displays the RAID levels that are in use
by each LUN. For filesystems, the system displays the RAID levels
that are in use by the filesystem storage tiers.

Priority
Level

Filesystems Identifies the priority that the system gives to various
operational aspects of a logical volume, such as the
Controller processing queue. The processing‑queue
priority defines the percentage of the Controller CPU
cycles that are dedicated to the volume. Identifies as
well where the data is striped on rotating drives. Valid
priority levels:

Premium Indicates the highest priority for
responding to requests in the processing
queue.

High Indicates the next highest priority for
responding to requests in the processing
queue.

Medium Indicates an intermediate priority for
responding to requests in the processing
queue.

Low Indicates the next to lowest priority for
responding to requests in the processing
queue.

Archive Indicates the lowest priority for
responding to requests in the processing
queue.

LUNs Identifies the priority that the system gives to various
operational aspects of a logical volume. These
operational aspects include the Controller processing
queue, the SAN interface requests, and the migration
of the auto-tiered LUN extents.

Note: The processing‑queue priority defines the
percentage of the Controller CPU cycles that are
dedicated to the volume.

Premium Indicates the highest priority for
responding to requests in the processing
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queue. For auto-tiered LUNs, busy LUN
extents receive the highest priority
when the system migrates the data to
the higher-performing storage tiers.

High Indicates the next highest priority for
responding to requests in the processing
queue. For auto-tiered LUNs, busy LUN
extents receive the next highest priority
when the system migrates the data to
the higher-performing storage tiers.

Medium Indicates an intermediate priority for
responding to requests in the processing
queue. For auto-tiered LUNs, busy LUN
extents receive an intermediate priority
when the system migrates the data to
the higher-performing storage tiers.

Low Indicates the next to lowest priority for
responding to requests in the processing
queue. For auto-tiered LUNs, busy LUN
extents receive the next to lowest
priority when the system migrates the
data to the higher-performing storage
tiers.

Archive Indicates the lowest priority for
responding to requests in the processing
queue. For auto-tiered LUNs, busy LUN
extents receive the lowest priority when
the system migrates the data to the
higher-performing storage tiers.

Related Links
Display Volume Group Details
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APPENDIX D

Support Tab Reference Pages

Clear Log Dialog
Navigation: Support > System Logs > Actions > Clear Logs

Clears (deletes) all existing collected log bundles from the Oracle FS System. This
does not clear logs which are not contained in a log bundle.

Note: Clearing (deleting) system logs requires support administrator login
privileges. Contact Oracle Customer Support before proceeding.

Controller Logs Select this option if you want to clear (delete) only Controller
logs. This leaves logs, like event log, intact.

Log Collections Select this option to clear (delete) all logs displayed in the
System Logs view.

.

Related Links
Clear the System Logs

Create Log Bundle Dialog
Navigation: Support > System Logs > Actions > Create

Defines the hardware components and system events to include in the log files.

You can define the collection period, select SAN hosts to gather information
from, and choose if logs are sent to a Call‑Home server or downloaded to a
workstation. You can also associate the log file with a server request (SR).

Component or
Item

Provides a list of available components and system events for
data collection.

Collect Indicates whether the object is
selected for data collection

Name Indicates the name of the object
for data collection.

Select buttons Specifies all or a group of system components.
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Select All Sets all object events in the list to Yes.
This selection provides a record of all
events on the system.

Deselect All Resets the available object events in the
list to No so that no logs are collected.

Collection
Period

Controls the extent of information coverage for each selected
source.

Most Recent Logs Indicates the age of the collected
data logs. For example, a setting
of four hours means that the logs
are less than four hours old. (Four
hours is the default value. You can
also specify days instead of
hours.)

All Logs Since Last Log
Collection

Indicates that the data collection
logs are continually updated.

SAN Host Log
Selection

Allows you to select the SAN host for log collection:

This feature is only available if the SAN host is running
Oracle FS Path Manager and the SAN hosts are logged in at the
time of collection.

Number of hosts
selected for log
collection

Indicates the number of hosts selected
for log collection.

Select Hosts Opens a dialog that allows you to select
recognized SAN hosts on the system for
log collection.

Collect Indicates whether the host
is selected for data
collection.

SAN host Indicates the name of the
SAN host for data
collection

Notes Provides user‑defined information about the system logs
collection. This information appears in the Notes column. The
notes information appears in the Notes column of the System
Logs overview page for easily identification. This information
is also included in the header of the log bundle for
identification.
The Notes field is also used to associate the log bundles with
an open service request (SR). The SR number must be the first
entry in the field. Add any other notes that are related to the
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log bundles after the SR number. Select the Send to Call-Home
server option when using the SR number.

Send to Call-
Home server

Collects the log and then transmits the log to the configured
Call‑Home server.

Download to Creates the log bundle and then downloads that log bundle to
a user specified directory on the workstation.

Related Links
Create a Log Bundle

Data Consistency Overview Page
Navigation: Support > Data Consistency

Displays the data consistency check results for the Oracle FS System Drive Group
or allows you to create tasks to verify data consistency. Data consistency refers to
the integrity of the parity data and not the user-created data.

Note: The data consistency check requires significant system resources and is
usually performed at the direction of Oracle Customer Support.

You can perform the data consistency check by selecting a Drive Group and then
select Actions > Verify Data Consistency.

When you select Verify Data Consistency, you can choose whether to run the
check at low priority or high priority. At low priority, there is a 10 percent
potential system impact to the system and at high priority, there is a 30 percent
potential to impact system performance. If you select low priority, the check
talkes longer to complete but with less potential system impact. If you do not see
the results displayed after a period of time, refresh the page to display the
results.

After you start a data consistency check, you cannot cancel the process. Also, the
process might be shown as completed in the Tasks panel, the process can
continue to run in the background until actual completion.

If the data consistency check fails, you may see the Status change to degraded. If
you see a status of degraded, with or without a data consistency check, contact
Oracle Customer Support.

Drive Group Identifies the name of the Drive Group.
Status Identifies the state of the Drive Group. Valid states:

Normal Requires no action
Warning Requires no immediate action for minor

conditions.
Critical Requires prompt action to prevent system

failures or offline conditions
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Unknown Additional information is required.

Date of Result Specifies the date and time when the data consistency test
was completed.

Consistency
Result

Specifies the result of the data consistency test. Valid results:

• Pass
• Fail

Errors Found Identifies the number of consistency test errors.

Errors Fixed Identifies the number of errors corrected during the test.

Manage Halt Points Dialog
Navigation: Support > System Halt Points > Manage Halt Points

Manages the system halt points that are available on the Oracle FS System. A halt
point set for a software component causes the system to pause the startup
sequence at a step associated with that component to enable troubleshooting and
diagnostics.

CAUTION: Use system halt points for troubleshooting purposes only. System halt
points are used to gather information or to clear conditions that cannot otherwise
be accomplished. Never set or clear halt points without assistance from Oracle
Customer Support. Only the Primary administrator and the Support
administrator can manage system halt points.

Active Indicates whether the startup process is to halt at the
indicated step for this software component.

Order Identifies where in the startup sequence the software
component step is to be executed.

Paused on Halt
Point

Indicates the step at which the startup sequence is halted.

Component
Name

Identifies the name of the software component that is
associated with the system halt point. The system lists the
components in the normal startup sequence.

Step Identifies the name of the software component step where
the halt point is to occur. The system lists the steps in the
normal startup sequence.

Clear Deselects all of the selected halt points that appear in the
Paused on Halt Point field.

Related Links
Manage System Halt Points
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Reset System Dialog
Navigation: Support > System Trouble > Actions > Reset System

Resets the system configuration as directed by Oracle Customer Support. Do not
use this feature unless directed by Oracle Customer Support. Resetting the
system changes the system serial number which can cause issues with service
entitlement.

Requires an encrypted file provided by Oracle Customer Support for
configuration information.

CAUTION: Because this action deletes all user data along with the system
configuration, the system prompts you to confirm the operation. Be absolutely
sure you want to take this action. All data in the system is lost. After you select
OK, this action cannot be canceled or undone.

Resetting the system configuration, performs the following actions:

• Deletes all data stored on the Oracle FS System.

• Resets the configuration to an initial state.

• Resets the system serial number.

Reset File[...] Select the filename and folder location for the encrypted file
provided by Oracle Customer Support.

Related Links
Reset the Oracle FS System

Software and Firmware Overview Page
Navigation: Support > Software and Firmware

Displays the software and firmware packages currently installed on the Drive
Enclosures, Controllers, and Pilots.

Other information includes listing of all software and firmware packages staged
for an upgrade and whether a given software module applies to current
hardware installed n the system.

Software Update Scheduled
Note: The Software Update Scheduled information appears only if there is an
active software update scheduled. The Scheduled Software Update allows you to
update the software at a later time.

Task Name Identifies the type of scheduled task: Software
Update.

Scheduled Start Time Indicates the date and time of the schedule software
update.
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Cancel Scheduled
Update

Allows you to remove the scheduled software
update.

Installed Software
Package Version Identifies the version number of the currently installed

software package. The package version is the version of the
Red Hat Package Manger (RPM) package already installed.

Compatibility
Matrix Version

Identifies the package version of the currently installed
compatibility matrix. The matrix version is usually the same
as the package version unless you have staged a higher
revision package.

Module Identifies the name of a software or firmware module that is
installed on the Oracle FS System.

Table 21: Software module types
Name Description
Pilot OS Operating system for the Pilot.

Pilot Software Software that runs on the Pilot, such as
the GUI interface and web server,
online help, and Simple Network
Management Protocol (SNMP).

Controller BIOS Programmable ROM (PROM), which
includes BIOS and netboot code, for
the Controllers.

Controller Software Software that manages the Controllers.

Drive Enclosures
Firmware

Firmware for Drive Enclosures.

Version Identifies the version number of a software module. A value
of unsupported indicates there is a problem with the
individual software module. Contact Oracle Customer
Support for assistance.

Applies to
Current
Hardware
(Support roles
only)

Indicates that the affected hardware component uses the
software module.

Note: The Applies to Current Hardware column is
displayed only for user accounts set up with support role
privileges.
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Staged Software
Package
Version

Identifies the version number of the currently installed
software package. The package version is the version of the
Red Hat Package Manger (RPM) package already installed.

Can Upgrade
to Staged
Version

Indicates that an upgrade path is available based on the
installed software module version and the staged software
package.

Upload
Software
Package

Permits you to select and upload a software update package.
Software packages are downloaded from My Oracle Support
(support.oracle.com). Contact Oracle Customer Support if
assistance is needed.

Related Links
Display Software and Firmware Versions

System Halt Points Overview Page
Navigation: Support > System Halt Points

Displays the system halt points, if any, that have been enabled on the Oracle FS
System and allows you to set or clear a halt point.

The system halt points are used for diagnostics and typically requested by Oracle
Customer Support to aid in isolating problems. In most instances, you should not
create a system halt point unless instructed by Oracle Customer Support.

Order Identifies where in the startup sequence the software
component step is to be executed.

Paused on Halt
Point

Indicates the step at which the startup sequence is halted.

Component
Name

Identifies the name of the software component that is
associated with the system halt point. The system lists the
components in the normal startup sequence.

Step Identifies the name of the software component step where
the halt point is to occur. The system lists the steps in the
normal startup sequence.

System Logs Overview Page
Navigation: Support > System Logs

Displays collected system information available on an Oracle FS System. You can
view logs as well as create new logs from this page.

You can manage logs from this page, including sending logs to a Call‑Home
server, downloading logs to a user‑defined location, deleting logs, and clearing
logs.
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File Name Lists the name of the log file bundle containing the collected
system information. (The logs are compressed in the tar format.)

Note: The log name includes two time stamps. In this example,
A990033ZIO-130714104814-130718095816-
PCP_EVT_FOUND_PILOT_CORE_FILE-e-02-02.tar, the two
timestamps indicate:

1 The first field, 130714104814 is the time stamp of the
previous log bundle created before the most recent log
bundle was created. For example, if the last log file was
created on July 14, 2013, at 10:48:14 am, that information is
added to the first part of the log file bundle name.

2 The second field, 130718095816, is the time stamp of the log
file that was created. For example, if a log file was created on
July 18, 2013, at 9:58:16 am; the time and date is shown as
130718095816 in the log file name.

Time
Collected

Identifies the time and date at which the download bundle was
collected from the Oracle FS System.

Collection
Type

Indicates the method by which the system logs are collected:

Manual Indicates user initiated system logs.

Event Generated Indicates event triggered system logs where
the triggering event is also in the name of the
log bundle. .

Periodic Indicates periodic or schedule driven
Call‑Home system or test logs. The periodic
method is used to produce a small log that
contains the entire system configuration and
last 100 events.

Content Identifies the types of system information that have been collected
and are included in the current download bundle.

Size Identifies the size of the download bundle.

Notes Provides user‑defined information about the system logs
collection. This information is transferred in the header of the log
bundle and may be used to identify the reason for this collection.
For example, the user‑defined information could include the
Service Request number for tracking purposes.

System Trouble Overview Page
Navigation: Support > System Trouble

Reviews the status and health of the Controllers that are installed on the
Oracle FS System. The Actions menu options allow you to test the connectivity
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between the Oracle FS System and the customer network as well as reset the
system to an initial state.

Controller
Name

Identifies the name of the Controllers selected for test
connectivity.

Comment Displays descriptive text that is associated with a Controller. A
comment can include up to 256 characters.

Service Type Identifies the service type of Controller attached to Oracle FS
System. The service type is displayed as SAN Only, Biased to
SAN, NAS Only, or Biased to NAS for each Controller.

Failover
Controller

Identifies the Controller that is used to provide services when
the other Controller in the pair fails.

Status Displays the status of the Controller.

Normal Requires no action
Warning Requires no immediate action for

minor conditions.
Critical Requires prompt action to prevent

system failures or offline
conditions

Unknown Additional information is
required.

Run Controller Command Dialog
Navigation: Support > System Trouble > Actions > Run Controller Command

Runs commands on a selected Controller.

Controller Identifies the Controller that you want to run the
commands.

Command Line Identifies the command to perform on the specified
Controller.

fmadm

Note: Use the prefix command ipmifm when entering
commands in the Controller command line.

Environment
Variables

Identifies the space‑delimited pairs of environment
variables and values to use while executing the command.

Execute Runs the specified command.

Command Output Displays the results of the command that was run to
resolve a connectivity issue. The command output cannot
be saved to a file.
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Related Links
Run Controller Command

Update Drive Firmware Dialog
Navigation: Support > Software and Firmware > Actions > Update Drive
Firmware

Installs the firmware for all of the selected drive types in the Oracle FS System.

Pending Drive Firmware Updates
Provides information about the drives that match the specifications for the
firmware update.

Install? Indicates whether the Oracle FS System updates the firmware
for the selected item.

Drive Type Indicates the following information about the drive:

• Manufacturer name
• Storage capacity
• Media type: HDD or SSD

The system updates the firmware for all of the drives that
match the selected drive types.

Current
Firmware
Version

Identifies the version number of the drive firmware.

Pending
Firmware
Version

Identifies the version number of the drive firmware staged for
update.

Related Links
Update the Drive Firmware

Update Software
Navigation: Support > Software and Firmware > Actions > Update Software

Manages the software and firmware updates on the Oracle FS System. Enables
you to create an update schedule or immediately update, and also allows you to
select the upgrade options and system overrides.

The update process affects all software modules and firmware on the Oracle FS
System. To specify which updates are installed on individual components, login
as support administrator.

Important: When logged into the system as a support administrator, you can
select individual components to update from the software module package. You
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can also select Always Install, Install if newer version, or Do not install.
Contact Oracle Customer Support before installing individual software
components.

Install
Action

Identifies the action to perform on the selected module during
the software update. The support administrator role allows you
to select individual software packages to install.

Note: When you selectively update the software modules, the
Oracle FS System cannot determine the current software module
version and displays unsupported as the installed software
version.

The choices include:

Do not install Select this option to keep the existing
module version.

Install if newer
version

Select this option to upgrade the existing
module only if the update is a later version.
This is the default action and the only
action available to administrators. This
action does not require you to be logged in
as a support administrator.

Always Install Select this option always install the
selected module.

Note: The Always Install option may cause
an upgrade or downgrade to the currently
installed module version. You may also use
this feature to install a module that does
not apply to your current hardware. For
example, to prepare for new hardware to
be installed.

Module Identifies the name of a module that is in the staged package.
Installed
Version

Identifies the version number of a software module. A value of
unsupported indicates there is a problem with the individual
software module. Contact Oracle Customer Support for
assistance.

Staged
Version

Identifies the version number of the staged software module.
Staged software is a newer version of the software that can be
installed.

Update
Software
without
restarting

Updates the software on the Oracle FS System. The update is
performed without a system restart and I/O data access is not
disrupted unless Oracle Customer Support instructs you to
choose the Shutdown Controller software update option. This
the default setting for most updates. Based on the type of
updated, the system recommends which update option to use. If
this option is selected by the system, use this option.
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Note: You may need to change this value to the Restart and
update software (disrupts data access) if requested to do so by
Oracle Customer Support based on your system configuration.

Restart and
update
software
(disrupts
data access)

Updates the software on the Oracle FS System. The update
performs a shutdown which disrupts I/O data access and the
restarts the system to install the update. Based on the type of
update, the system recommends which update option to use. If
the option is selected by the system, use this option.

Software Update Options

Note: Only select any of the following options if instructed to by Oracle
Customer Support or if the Oracle FS1-2 Flash Storage System Release Notes
describes specific options or recovery from standard conditions.

The following options provide additional control of the software update. These
options apply to all software modules that are ready for update.

CAUTION: Turning on some of these options disrupts data access.

Ignore
compatibility (not
recommended)

During the update process, the Oracle FS System verifies
that the version of the staged module is compatible with
existing hardware and software. Select this option to
override a failed compatibility check. This option does not
automatically change a non‑disruptive upgrade to a
disruptive upgrade.

Shutdown
Controller

Select this option to force the software update to shutdown
all Controller software components for the upgrade. This
option affects data access and requires you to select Restart
and update software (disrupts data access).

Ignore hardware
status (except for
Pilots)

Select this option to force the software update regardless of
the state of the system hardware. This option can affect data
access, depending on the specific hardware and state of the
Controller or Drive Enclosure hardware.
If the Controller has issues, do not use this option without
first contacting Oracle Customer Support to determine
whether the Shutdown Controller option should also be
used.

Ignore system
alerts

Select this option to proceed with the software upgrade and
ignore any system alerts. An upgrade of any type is blocked
if there are any system alerts unless this option is turned on.
This option may or may not affect data access, depending
on the specific system alert.

Ignore current
requests

Select this option to proceed with the software upgrade
regardless of pending system requests. This option allows
you to begin the upgrade even if there are blocking tasks
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running which are visible in the Tasks list. (A blocking task
is a task that normally would be completed before a system
restart.)
If a task is running that is modifying storage, host access, or
system software, contact Oracle Customer Support before
turning on this option. This option may or may not affect
data access, depending on the specific task.

Override failed
software update

Select this option to overwrite a previous, failed software
update. Once an upgrade fails, that status is kept, and you
can only clear it by selecting this option and having a
successful upgrade. Do not use this option unless instructed
to by Oracle Customer Support or described in the
Oracle FS1-2 Flash Storage System Release Notes.

Schedule Software Update
Adds scheduling capabilities to the software update.

Schedule
software
update to
occur at a later
time

Enables you to select the upgrade and options and schedule it
for a later time. Lists any existing scheduled updates with the
options listed.

Note: The Schedule software update to occur at a later time
option is only available to users logged in with administrator
role; users logged in with support role cannot access this
feature.

Time to
Perform
Software
Update

Note: This option is displayed whether or not there is a
scheduled update. If there is an existing schedule, then that
schedule is displayed.

Identifies the time at which the Oracle FS System starts a
scheduled software update.

Note: The pop‑up calendar that is used to set the software
update schedule is limited to the next 72‑hours. Note that not
all of the drop-down lists and other features of this calendar
are functional. This behavior is normal.

Software Update Validation Errors

The Software Update Validation Errors appears if the options you selected cause
a conflict with existing software or hardware. If there are no conflicts, the
Software Update Validation Errors is not displayed.

Information is provided why the update is not allowed but for guidance on how
to resolve the issue, contact Oracle Customer Support or review the Oracle FS1-2
Flash Storage System Release Notes
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Note: If there is an issue with a software update and the issues results in a
validation error, the scheduled upgrade is blocked, and a system alert is also
created.

Related Links
Update the Oracle FS System Software

Upgrade Paths From Installed Package Dialog
Navigation: Support > Software and Firmware > Actions > View Upgrade Paths
from Installed Package

Displays the software updates that are installed. The information also indicates if
the upgrades will cause Pilot or data disruption. If you want to upgrade a
software update, you review this panel to verify which upgrades are installed.

Package Version Indicates the version of the software package which is
installed and the upgrade paths supported for this installed
package.

Pilot Disruption
Required

Indicates if the upgrade may disrupt activities on the Pilot.
If just restarting the Pilot, this would not affect data access
unless the data disruption flag is also set.

Data Disruption
Required

Indicates if the upgrade may disrupt data path. The field
will display one of:

• Yes: Indicates that the upgrade interrupts data access
and the upgrade should be performed during a
maintenance period.

• No: Indicates that the software upgrade does not
disrupt data access.

Pilot Software Lists the version number.
Pilot OS Lists the version number.
Controller
Software

Indicates the supported software package to which you can
upgrade.

Controller BIOs Indicates the supported software package to which you can
upgrade.

Drive Enclosure
Firmware

Indicates the supported software package to which you can
upgrade.

Related Links
View the Upgrade Paths From the Installed Package
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Upgrade Paths to Staged Package Dialog
Navigation: Support > Software and Firmware > Actions > View Upgrade Paths to
Staged Package

Displays staged software which is the last version of software you staged. The
version could be lower or the version could be a non‑software firmware only
package. When you upload a software package, if the upload and the internal
staging of the software by the system was successful, that version is listed here.
That version is ready to be installed on the system from the Update Software
panel. The information also indicates if the upgrade causes Pilot or data
disruption.

Package Version Indicates the version of the staged package and the upgrade
paths to that package. This might not include the current
installed package. Also the version of the staged package
might not be available for installation if the compatibility
matrix does not allow the upgrade due to hardware
incompatibility.

Pilot Disruption
Required

Indicates if the upgrade may disrupt activities on the Pilot. If
just restarting the Pilot, this would not affect data access
unless the data disruption flag is also set.

Data Disruption
Required

Indicates if the upgrade may disrupt data path. The field will
display one of:

• Yes: Indicates that the upgrade interrupts data access
and the upgrade should be performed during a
maintenance period.

• No: Indicates that the software upgrade does not
disrupt data access.

Pilot Software Lists the version number.
Pilot OS Lists the version number.
Controller
Software

Indicates the supported software package to which you can
upgrade.

Controller BIOs Indicates the supported software package to which you can
upgrade.

Drive Enclosure
Firmware

Indicates the supported software package to which you can
upgrade.

Related Links
View the Upgrade Paths to the Staged Package
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set halt points 249
view Controller diagnostic results 239

on Controllers 238
Oracle Auto Service Request (ASR) activation 42
proxy server failure 42

display
account summaries 60
alerts 221
auto-tiered LUN details 142
capacity usage 67
clone LUN details 175
Controller diagnostic results 239
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Controller ports 46, 47
data protection details 180
details

of a Controller 203
of a Drive Enclosure 211

Drive Enclosure console output 244
drive group properties 90
drive groups 90
event logs 224
event notification details 228
event notifications 226
event properties 224
immobile capacities 86
logged-in accounts 30
Pilot connectivity 198
properties

of a Pilot 198
of UPS devices 218

RAID capacities 86
RAID output 244
reporting schedules 258
SAN host entry settings 160
single-tier LUN details 142
status

of a Drive Enclosure 210
of all Controllers 203

Storage Domain properties 82
Storage Domain storage allocation 86
Storage Profiles 52
system alerts 221
UI client logs 231
volume group details 69

DNS, see Domain Name Servers (DNS)
documentation

feedback 18
Domain Name Server (DNS)

purpose 34
Domain Name Servers (DNS)

how to
configure IP addresses 36

download
client software 22
generated reports 255
log bundles 234
Oracle FS System firmware updates 184
Oracle FS System MIB table 65
Oracle FS System software patches 184
Oracle FS System software updates 184
reports 255
VDS Provider 150
VSS Provider 181

Drive Enclosure commands
how to

run commands 245
view output 244

Drive Enclosure comments
how to

modify the comment field 211
Drive Enclosure console

description 242
how to

run Drive Enclosure commands 245
view output 244

Drive Enclosures
description 215
drive replacement 214
error recovery 242
expand system storage 215
how to

identify 212
run Drive Enclosure commands 245
view console output 244
view details 211
view status 210

managing 205
number of drives 289
physical configuration 206
quantity range 289
RAID commands 242
types of

DE2-24C Drive Enclosure 206
DE2-24P Drive Enclosure 206

drive firmware
how to

download the packages 184
update the staged firmware 195

drive group
statistics 262
view real-time statistics 264

drive groups
adding Drive Enclosures 91
assigning to Storage Domains 92
data protection 89
definition 102
how to

add to Storage Domains 94
assign as primary 92
create primary 92
display within Storage Domains 90
remove from Storage Domain 94
view primary state 90
view properties 90
view RAID level 90
view RAID status 90

managing activities 89
migration priorities 93
move persistence volume 91
nonprimary becomes primary 91
number of drives 289
optimum number for striping a volume 102
primary drive group description 91
quantity range 289
RAID level groups 90
RAID levels 89
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RAID protection 89
reassigning overview 93
reassigning to a different Storage Domain 92
removing from Storage Domains 92
Storage Domains, relationship to 89
system configuration migration 91
unassigned Storage Domain status 77
warning states 90

drives
capacity reported 113
determine RAID level of storage tiers 105
Drive Enclosures

HDDs 206
large form factor (LFF) 206
small form factor drives (SFF) 206
SSDs 206

drive replacement 214
foreign 214
HDDs have reserve capacity for infilling 115
how to

view capacity 90
view Drive Enclosure details 90
view firmware 90
view remaining life 90
view status 90
view Storage Class 90

preparing capacities 120
priority striping on HDDs 100
protecting data against drive failure 101
quantities in a system 289
rebuilding 208
reconditioning after deleting a volume 120
Storage Class types 99

duplicate
Storage Profiles 51

E
education programs 18
email notifications

how to
configure 38

event logs
description 223
how to

delete entries 225
test the Call-Home feature 41

event notifications
description 226
how to

configure email server 38
create 227
delete 229
display 226
display details 228
modify 228

types of 36

events
as MIB objects 61–63
how to

copy properties 224
delete logs 225
display logs 224
display properties 224
filter log entries 225

managing 220

F
features, premium options 31
feedback, documentation 18
field replaceable units, see FRUs
filesystems

about capacity attributes 113
capacity overhead 114
growing thin volumes 119
insufficient space to create 114
thinly provisioned 116

filter
event log entries 225

firewall
TCP ports 200

firmware updates
description 187
how to

download firmware packages 184
firmware, drive

how to
update the staged firmware 195

foreign drives 214
formats, download

application packages 21
free capacities

insufficient 114
reclaimed 120

FRUs
how to

replace 215
replacement 214

FSPM, see Oracle FS Path Manager (FSPM)

G
generated reports

delete 256
download 255
file formats 255
how to

create 254
schedule 257

global settings
configure

Domain Name Servers (DNS) 36
initial setup 32
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system-wide parameters 32
growth increments

definition 119
size, for auto-tiered LUNs 119
size, for single-tiered LUNs 119

GUI application
client software location 23
how to

download 22
install using MSI 23
install using the command line 23
log in 27
log out 30

status bar 28
GUI pages

Add to Storage Domain Dialog 291
Additional Options dialog 430
Administrator Accounts overview 291
Alerts and Events Overview Page 292
Associate Hosts 431, 432
Clear Log 588
Clone Schedules Overview page 540
Controller Ports overview 294
Controllers overview 293
Copy SAN LUN

Auto Tier, Data Protection tab 434, 435, 438
Auto Tier, Quality of Service tab 446
Mapping tab 444, 445
Single Tier, Data Protection tab 438–440, 443
Single Tier, Quality of Service tab 453

Create Administrator Account Dialog 296
Create Data Protection Schedule dialog 461
Create Event Notification 297, 298
Create Job Schedule 460
Create Log Bundle 588
Create LUN Map dialog 462
Create Reporting Schedules dialog 299
Create SAN Clone LUN

Mapping tab 462, 463
Quality of Service tab 464

Create SAN LUN
Auto Tier, Data Protection 478, 479, 483
Auto Tier, Quality of Service tab 490, 491
Mapping tab 470, 471
Single Tier, Data Protection 472–474, 477
Single Tier, Quality of Service tab 483, 484

Create SNMP Host Dialog 301
Create Storage Domain Dialog 302–304
Create Storage Profile Dialog 304, 307, 309
Create Uninterruptible Power Supplies dialog 310
Create UPS dialog 310
Create Volume Group 497
Dashboard overview 311
Data Consistency overview 590
Delete Drive Group Dialog 313
Delete LUN 498
Delete Storage Domain Dialog 313

Download Report 313
Drive Enclosures Overview 314
Drive Group Statistics dialog 316
Drive Groups Overview 314, 316
Duplicate Storage Profile Dialog 317, 320, 322
Event Log overview 323
Events overview page 324
Events Properties dialog 324
Generate Auto‑Tier Effectiveness Report 325, 326
Generate Report Dialog 327
Generated Reports Overview 328
Global Settings Overview 328
Hardware overview page 329
Host to LUN Mapping overview 498
Initiator‑to‑Controller Connectivity 499
LUN Statistics and Trending page 500
LUN to Host Mapping overview 500
Manage Halt Points dialog 591
Manage Port Provisioning Dialog 330
Manage SAN Host Groups

Groups 502
Hosts 502

Manage Storage Profiles overview page 384
Manage Volume Groups

Volume Groups 504
Volumes 505

Modify Administrator Account 331
Modify Asset Information 333
Modify Controller

Components 333
I/O Ports 334

Modify Controller Port Settings Dialog 336–338
Modify Controller Service Type 339, 340
Modify Data Protection Schedule dialog 509
Modify Drive Enclosure

Components 333, 340, 351
I/O Ports 346

Modify Drive Group Dialog 347, 350
Modify Event Notification 351, 352
Modify Host

Advanced 510
iSCSI Access 512
Oracle FS Path Manager 510, 511
Ports 512, 513

Modify Job Schedule dialog 514
Modify LUN Number dialog 514
Modify Network Settings

Interfaces 353, 354
iSCSI 355, 356
Notification 358–360

Modify Reporting Schedule dialog 362
Modify SAN LUN

Auto Tier, Data Protection tab 520, 521, 524
Auto Tier, Quality of Service tab 533
Mapping tab 524, 525
Single Tier, Data Protection tab 515, 516, 520
Single Tier, Quality of Service tab 526
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Modify Security Settings 364
Modify SNMP Host 364
Modify Storage Domain Dialog 365, 367, 369
Modify System Time 369
Modify Uninterruptible Power Supplies dialog 370
Modify UPS dialog 370
Modify Volume Group 539
Networking Overview 371–373
Pilot overview 373
Pilot View dialog 413, 414
Remove from Storage Domain Dialog 373
Replication Engines Overview page 540
Reporting and Statistics Overview Page 376
Reporting Schedules Overview 374
Reset System 592
Run Controller Command dialog 596
SAN Data Protection Overview page 541
SAN Hosts overview 541, 542
SAN LUNs Overview page 543
SAN Protocol Statistics Overview page 432
SAN Statistics 547
SAN Storage Overview page 547
Security Settings overview 376, 377
Set Event Log Filter 377
SNMP Hosts overview 378
Software and Firmware page 592–594
Storage Domains Overview 382, 384
System Alerts overview 387
System Halt Points Overview 594
System Information 388
System Logs overview 594
System Status overview 379–381
System Time Overview 389
System Trouble overview 595
Update Drive Firmware dialog 597
Update Software 597, 599, 600
View Administrator Account 390
View Auto-Tier Graphs 392
View Controller

Components 393
I/O Ports 394

View Controller Port Settings
Ethernet 396
Fibre Channel 397–399
iSCSI 399–401
SAS 402

View CPU Statistics 295
View Data Protection Schedule dialog 548
View Details Dialog (Fibre Channel) 550–553
View Details Dialog (iSCSI) 554–557
View Details Dialog (LUNs) 548–550
View Drive Enclosure

Components 403
I/O Ports 408

View Drive Group Dialog 409, 411
View Event Notification 412
View Host

Advanced 557
iSCSI Access 559
Oracle FS Path Manager 558
Ports 560

View Reporting Schedule dialog 416
View SAN LUN

Auto Tier, Data Protection tab 566, 567, 569
Auto Tier, Quality of Service tab 577, 578
Mapping tab 569, 570
Single Tier, Data Protection tab 561, 562, 565
Single Tier, Quality of Service tab 571

View SNMP Host 418
View Storage Capacity Allocation Details dialog 
418
View Storage Domain Dialog 419, 421, 422
View Storage Domains dialog 422, 424
View Storage Profile Dialog 425–427
View Uninterruptible Power Supplies dialog 428,
429
View UPS dialog 428, 429
Volume Groups Overview 583–585

H
halt points, system

description 248, 249
how to

clear 249
continue startup 250
manage 249

use of 249
hard disk drives (HDDs)

failure 210
recovery 210
see also drives

hardware components
how to

replace 215
replacement 214
types of Drive Enclosures

DE2-24C 206
DE2-24P 206

hardware management
overview 213

hardware updates
prerequisites 192

HBA alias
how to

add 161
HDDs, see hard disk drives (HDDs)
high availability

copyback 208
description 208
double parity 208
dynamic spare 208
mirroring 208
single parity 208
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spare drive 208
homing logical volumes 169
host entries, SAN

deleting 154
description 153
description for mapping 146
grouping 164
how to

create 158
delete 159
display details 160
display FSPM driver details 160
group 166
map to LUNs 146, 148
modify groups 167
modify LUN mapping 149
modify mapping 149
rename 159

management 157
modifying 160

host groups
description 164
how to

add SAN host entries 167
create 166
delete 167
modify 167
rename 167

managing 165
hosts, associated

definition 153
deleting 154
grouping 164
how to

create host-to-initiator association 158
rename 159

LUN mappings 154
moving 154

hosts, FSPM
host record description 153

hosts, SAN
connectivity status 163
how to

add HBA alias 161
create host entries 158
delete host entries 159
enable CHAP authentication 162
install VSS Provider 181
modify HP-UX compatibility mode 162
modify iSCSI Access Settings 162

initiator status 163
management 157
maximum connections 290
Oracle FS Path Manager (FSPM) 154

hosts, unassociated
definition 153
LUN mappings 153

moving 153
HP-UX compatibility mode

how to
enable 162

I
I/O bias QoS property

description 103
plus access bias maps to advanced QoS 98

identify
Controllers 205
Drive Enclosures 212
Pilots 199

immobile capacities
definition 106, 430
how to

display 86
infill provisioning

decreases unused capacity 117
definition 116
reserve capacity 115

Initiator-to-Controller connectivity
description 163

install
Oracle MaxMan

using the command line 23
the GUI application

using MSI 23
using the command line 23

VDS Provider 150
VSS Provider 181

installed software
how to

view upgrade paths 188
interfaces, management

how to
configure 35

IP addresses
Domain Name Servers (DNS) 36
how to

configure SNMP trap hosts 63
configure the iSCSI ports 45
configure the Pilot IP addresses 35

management interface (Pilot) 34
Pilot 28

ipmifm fmadm Controller command
for SAN Controllers 241

iSCSI Access Settings
how to

modify 162
iSCSI protocol

how to
configure system settings 44
modify port settings 45

iSCSI settings 44
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J
jar folder

explained 24
jobs, scheduled

how to
cancel software updates 195

journals, Controller 103

L
large form factor (LFF) drives, see drives
licensing optional premium features 31
limits

clone repositories, maximum number 288
clones, maximum number 288
copies, maximum number 288
Drive Enclosures, quantity range 289
drive groups, quantity range 289
LUN-to-host mappings 290
number of drives 289
SAN host connections, maximum 290
SAN LUN size 290
SAN LUNs, maximum 290
Storage Domains, quantity range 288
VLUNs, quantity range 288
volume groups, quantity range 288
volume size, range 288

list
Controller diagnostic results 239
details

of a Controller 203
of a Drive Enclosure 211

Drive Enclosure console output 244
drive group properties 90
immobile capacities 86
properties

of a Pilot 198
of UPS devices 218

RAID capacities 86
RAID output 244
status

of a Drive Enclosure 210
of all Controllers 203

Storage Domain properties 82
Storage Domain storage allocation 86
UI client logs 231

load balancing
how to

modify Oracle FS Path Manager (FSPM) settings 
161

log bundles
associate with service requests 39
description 231
how to

create 232
download 234

send to Call-Home server 235
send to Customer Support 232

send to Call-Home 231
uses for 39

log in
default values 24

log out 30
logged-in accounts

how to
view 30

logical capacities
description 113

login screen message
how to

modify 54
logs

collections, as MIB objects 62
how to

clear 235
copy event properties 224
delete 235, 236
delete events 225
display event properties 224
display events 224
filter (events) 225

LUN mapping
for a specific host entry 146
for all hosts 148

LUNs
about capacity attributes 113
about managing 121
capacity overhead 114
configure real‑time LUN statistics graph 270
description for mapping 146
detailed statistics 267–269
growing thin volumes 119
homing 169
how to

copy 171
create from existing LUN 172
display data protection details 180
map to a specific host entry 146
map to all hosts 148
modify mapping 149
move to another Storage Domain 88
move to another volume group 72
prevent access through a port 147, 148
restore from a Clone LUN 176

insufficient space to create 114
limits

host mappings, maximum 290
maximum quantity 290
size 290

statistics description 266
thinly provisioned 116
view detailed statistics 269
view real-time statistics 270
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view statistics 267
write cache 222
see also auto-tiered LUNs and single-tier LUNs

M
manage

Controller port provisioning 48
Controllers 202
Drive Enclosures 205
Pilots 197

management interfaces
how to

configure 35
IP addresses 34

mapping
a LUN to a specific host entry 146
a LUN to all hosts 148

masks, port
how to

prevent LUN access 147, 148
MIB table, Oracle FS System

description 61
how to

download from the GUI 65
download from the Pilot 65

objects 61–63
migration, data

affected by priority level of the volume 100
data usage statistics 107
disabling 107
effects created by Storage Domain creation 79
optimize for cost 107
optimize for performance 107

mirroring, data
for random-write operations 104

mobile devices
how to

download system status 220
modify

account security settings 53
administrator account 58
administrator accounts 54
auto-tiered LUNs

convert to single-tier LUNs 131
reported allocated capacities 123

chassis ID
of Controllers 204
of Drive Enclosures 212

comment field
for Controllers 204
for Drive Enclosures 211

data protection
auto-tiered LUNs 132
single-tier LUNs 142

data protection schedule 179
email configuration 38

event notifications 228
iSCSI port settings 45
login screen message 54
LUN mapping 149
Oracle FS Path Manager (FSPM)

load balancing 161
properties

for UPS devices 218
Quality of Service

auto-tiered LUNs 131
single-tier LUNs 141

reporting schedules 259
SAN host port settings 161
SAN host settings

HP-UX compatibility mode 162
iSCSI Access Settings 162

single-tier LUNs
convert to auto-tiered LUNs 141

SNMP hosts 64
software update schedule 194
Storage Domain background process priority 81
tier reallocation options 83
volume group name 71

monitoring system components 37
MOS, see My Oracle Support (MOS)
move

volume groups to another volume group 72
volumes to another volume group 72

MSI
file type explained 22

multiple
administrator accounts 54

My Oracle Support (MOS)
Auto Service Requests (ASR) feature 38

N
network

configure
administrator account 54

network interfaces
about connectivity 34

Network Time Protocol (NTP)
how to

configure 33
networks

open ports in the firewall 200
ports used by the Pilot 200

notifications, event
description 226
how to

configure email server 38
create 227
delete 229
modify 228

types of 36
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online help 18
options, premium features 31
Oracle documentation 18
Oracle FS CLI

description 31
Oracle FS Path Manager (FSPM)

definition 153
deleting FSPM host entries 156
FSPM host record description 153
hosts

grouping 164
how to

delete host groups 167
display driver details 160
group 166
modify groups 167
modify load balancing settings 161
rename host 156

limits
number of data paths 290
number of HBA ports 290
number of system connections 290

monitoring hosts 155
moving initiators description 156
on SAN hosts 154
overview description 155
possible actions 155
renaming FSPM hosts 155

Oracle FS System Manager
description 19
description of status bar 29
how to

log in 27
log out 30
run 27

Windows shortcut 23
Oracle FS Systems

about accessing 24
capacity usage by replica type 169
client software packages

description 20
configure Auto Service Request (ASR) feature 37
Controllers

overview 202
Drive Enclosures, quantity range 289
drive groups, quantity range 289
firewall TCP ports 200
firmware updates 187
how to

delete event logs 225
display event logs 224
display event properties 224
display software versions 184
display status 220
download patches 184

download software updates 184
identify Controllers 205
identify Drive Enclosures 212
identify Pilots 199
install 23
reset the serial number 251
reset the system configuration 251
restart 247
set halt points 249
shut down 246
stage software updates 186
update the software 193

log bundles 231
managing

Controllers 202
Drive Enclosures 205
Pilots 197

monitoring system components 37
notifications 36
Oracle FS System MIB table 36
Pilots, overview 197
software updates 187
startup 247
status bar 28

Oracle FS Virtual Disk Service (VDS) Provider
description 150
how to

download 150
register 152
verify 151

Oracle FS Volume Shadow Copy Service (VSS)
description 180
how to

download and install 181
register 182
verify 182

Oracle Help Center (OHC) 18
Oracle MaxMan application

client software description 20
how to

install using the MSI 23
Windows shortcut 23

Oracle Pre-Emptive Copy 208
over‑committed, see thinly provisioned volumes
overhead, volume 114, 115

P
parity data

how to
verify 237

passwords
choosing 26
how to

change 26
recover from forgotten password 26, 59

recovery 36
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reset tokens 26
rules 26
token

forgotten passwords 26
resetting passwords 26

passwords, administrator
how to

change 58, 59
recover from forgotten password 25
reset 59

passwords
reset tokens 59
token

forgotten passwords 59
resetting passwords 59

patches
how to

download patches 184
performance

how to
collect statistics 233

Storage Profiles
comparisons 49

performance data 261
Persistence volume

description 91
physical capacities

description 113
Pilot

default IP 25
how to

download the Oracle FS System MIB 43
upload custom Call‑Home matrix 43
upload software updates 186

IP address 28
Pilot BIOS updates

prerequisites 192
Pilots

firewall ports 200
how to

identify 199
repair 199
view network connectivity 198
view properties 198

managing 197
overview 197

pinned data
about clearing 222

port masks
how to

prevent LUN access 147, 148
ports

open in the firewall 200
primary drive groups

how to
create 92

priority QoS property

definition 96
effects

on I/O processing 100
on performance 100, 101
on striping across drive groups 102

privileges
administrator accounts 54

product support 18
progression, data, see data migration
provisioning

Controller ports 48

Q
QoS Plus feature

how to
limit storage capacity 83

Quality of Service (QoS)
rehoming logical volumes 169

Quality of Service (QoS) feature
access bias 103
basic and advanced views 97
defining QoS, two methods 97
description 96
I/O bias property 103
mapping from basic to advanced 98
priority property

effects on performance 100, 101
QoS Plus feature

Auto-tier option 105
constrained skew 111
controls 107, 108
data migration illustrated 106
definition 96
description 104
effect on data migration 100
effectiveness report 108, 111
histogram chart 108, 111
limiting capacity 108

redundancy property 101
regular and enhanced 96
Storage Class property 98
volume properties 96

queue priority, processing
definition 100

R
RAID capacities

how to
display 86

RAID levels
for Storage Profiles 49
of drive groups 89

RAID output
how to

view 244
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RAID protection
capacity overhead 114
for storage tiers 105

random‑write QoS setting
enhanced performance 104

real-time data 261
reboots

Oracle FS Systems 247
redundancy QoS property

description 101
refresh screen content 30
register

VDS Provider 152
VSS Provider 182

relocating
auto-tiered LUNs 144
single-tier LUNs 144

remove
a Storage Profile 52
auto-tiered LUNs 145
Clone LUN replicas 174, 175
data protection schedules 180
log bundles 236
single-tier LUNs 145
Storage Domains 86
system logs 235
volume groups 71

rename
Storage Domains 81

repair
a Pilot 199

replace
a CRU 215
a FRU 215

replicas
capacity usage 169
data synchronization differences 170
trees 169

reporting schedules
delete 260
display 258
modify 259
view 258

reports
create 253
delete 256
download 255
generate 253
generated 253
how to

generate 254
generate QoS Plus effectiveness 112
update storage cost values 112

schedule 256, 257
scheduled 256

repositories, clone
maximum number 288

requisite reading 18
reset

system configuration 251
system serial number 251

restarts
Oracle FS Systems 247

restore
from a Clone LUN 176

runOracleFSMaxMan.bat
explained 24

runOracleFSMaxMan.sh
explained 24

runOracleFSSystemManager.bat
explained 24

runOracleFSSystemManager.command 24
runOracleFSSystemManager.sh

explained 24
runOracleMaxMan.command 24

S
sales information 18
SAN host entries

deleting 154
description 153
description for mapping 146
grouping 164
how to

create 158
delete 159
display details 160
display FSPM driver details 160
group 166
map to LUNs 146, 148
modify groups 167
modify LUN mapping 149
modify mapping 149
rename 159

management 157
modifying 160

SAN hosts
connectivity status 163
how to

add HBA alias 161
create host entries 158
delete host entries 159
enable CHAP authentication 162
install VSS Provider 181
modify HP-UX compatibility mode 162
modify iSCSI Access Settings 162

initiator status 163
management 157
monitoring Oracle FS Path Manager (FSPM) 155
Oracle FS Path Manager (FSPM) 154

SAN storage parameters
how to

delete host entries 159
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display SAN host entry settings 160
modify HP-UX compatibility mode 162
modify iSCSI Access Settings 162

scheduled reports 256
scheduled software updates

how to
cancel 195

scheduled tasks (MIB object) 62
screen updates

how to
disable 30
enable 30
manually refresh 30

security settings, account
about modifying 53
account management 54
administrator accounts 54
how to

configure 53
service requests

associate with log bundles 39
automatic 37
how to

attach log bundles 232
used with Call-Home 231
see also Auto Service Request (ASR) feature

session
terminate 54

severities, event 223
shadow copy, volume, see Oracle FS Volume Shadow
Copy Service (VSS)
shut down

Oracle FS System 246
single-tier LUNs

description for creating 133
description for modifying 140
how to

convert from auto-tiered LUNs 131
convert to auto-tiered LUNs 141
define data protection 137
define Quality of Service 134
delete 145
disable data path 143
display 142
enable data path 144
modify data protection 142
modify Quality of Service 141
move to a new Controller 145
provide access to 144
remove access to 143

Quality of Service description 132
reasons for creating 132
relocating, description 144
see also LUNs

single-tiering
definition 96

size

volume capacity range 288
small form factor (SFF) drives, see drives
snapshots

clones, maximum number 288
copies, maximum number 288

SNMP agent
about trap host management 61
how to

create hosts 63
delete hosts 64
download the MIB table from the GUI 65
download the MIB table from the Pilot 65
modify hosts 64
view hosts 65

Oracle FS System resources 61–63
Software modules

update options 599
validation errors 600

Software update
options 599
validation errors 600

software updates
description 187
disruptive 190
how to

cancel scheduled updates 195
display Oracle FS System software versions 184
download software packages 184
schedule 194
stage update packages 186
update the system 193
view upgrade paths 188

non-disruptive 189
options 191
prerequisites 192
standard 189
types of 189

software, client
available packages 20
description 20

software, Oracle FS System
versions as MIB objects 62

solid state drives (SSDs)
failure 210
recovery 210
see also drives

SSDs, see solid state drives (SSDs)
staged software

how to
view upgrade paths 188

startup, Controller
BIOS code actions 248
halt points, use of 249
stages 248

statistics
channel errors 275, 552
configure real‑time LUN statistics graph 270
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configure SAN Controller real‑time statistics 278
Controller CPU 264
copy real-time statistics graph 286
create Controller CPU real-time graph 265
create drive group real-time graph 264
customize real-time statistics graph appearance 283
customize real-time statistics graph view 284
definitions 262
detailed LUN statistics 267–269
detailed SAN Controller statistics 273–277
determine if application impacts performance 281
determine performance during peak time 279
display multiple real-time statistics graphs 283
drive group 262, 264
example of determining performance 279
example of effect of adding application 281
Fibre Channel 273–275, 551–553
general information 273, 551
historical data definition 261
I/O latency 274, 552
iSCIS 277
iSCSI 276, 277
loop activity 553
LUNs statistics description 266
performance 273, 551
performance data definition 261
performance data types 261
port and type

Fibre Channel 273–275, 551–553
port errors 276
port events 277
port request 277
print a real-time statistics graph 287
real‑time data definition 261
report data definition 261
SAN Controller description 271
SAN Controller real-time statistics graph
description 278
SAN Controller statistics description 271
save a real-time statistics graph 285
SCSI Task Management Operations 274, 551
terminology 262
update frequency 261
view detailed LUN statistics 269
view LUN real-time statistics 270
view LUN statistics 267
view SAN Controller detailed statistics 277
view SAN Controller Protocols 272

statistics, data usage
effect on data migration 107

statistics, performance
how to

collect 233
status bar

component descriptions 29
components 28

status, system

summary 220
Storage Class QoS property

affects where infilling occurs 101
data migration limitations 106
definition 96
description 99
determines RAID level of storage tiers 105
QoS Plus capacity limits 108

Storage Domains
adding capacity 78
advanced options 78
allocated capacity for QoS Plus 108
capacity overhead 115
compact storage capacity 74
defragmentation 74
description 73
Drive Enclosures, quantity range 289
drive groups, relationship to 89
effect created by

creating a domain when volumes exist 79
moving a volume to another domain 87
reassigning a drive group to another domain 92

how to
add drive groups 94
adjust auto-tier scans 84
check consistency 85
check integrity 85
compact 85
create 80
defragment 85
delete 86
disable tier reallocation 83
disable tier reallocation statistics collection 83
display drive groups 90
display immobile capacity 86
display RAID capacity 86
enable tier reallocation 83
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generate QoS Plus effectiveness report 112
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maximize background process speed 81
minimize background process impact 81
move a logical volume 88
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remove drive groups 94
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update background process priority 81
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view properties 82
view QoS Plus optimization scan settings 82
view storage allocation 86
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view storage capacity limits 82
view tier reallocation setting 82
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illustrated 76
infill reserve for HDDs 115
integrity check 75
management 76
management features 78
managing 78
number of drive groups 289
number of drive groups affect striping 101
QoS Plus features 78
quantity range 288
RAID level of storage tiers 105
relationship to volume groups 77
turning off tier reallocation 107
unassigned drive groups 77
usage scenarios 73
verification 75
without drive groups 78

storage enclosures, see Drive Enclosures
storage organization

illustrated 76
storage parameters, SAN

how to
delete host entries 159
display SAN host entry settings 160
modify FSPM settings 161
modify HP-UX compatibility mode 162
modify iSCSI Access Settings 162

Storage Profiles
description 49, 50
how to

create 51
delete 52
duplicate 51
view 52

RAID levels, available 49
storage tiers

available RAID levels 105
description 121

storage usage (MIB object) 62
striping, volume

affected by priority level of the volume 101
All SSDs in Storage Domain are used 102
optimum number of drive groups 102
rebalancing the QoS 102

Support portal 18
support tools

description 230
synchronization, data

difference among replica types 170
system alerts

how to
copy to clipboard 221
display 221
manage 221

lost mappings 75
managing 220
provided by MIB objects 61

volumes have lost mappings 75
system expansion

adding Drive Enclosures 215
system halt points

description 248, 249
how to

clear 249
continue startup 250
manage 249

use of 249
system logs

bundles 231
description 223
how to

clear 235
delete 235

system network
configuration 34

system resets
startup sequence 91

system serial numbers
how to

reset 251
system startup

with halt points 249
system status

how to
view 220

system, Oracle FS
capacity usage by replica type 169
configuration (as an MIB object) 63
description of status bar 29
how to

configure time 33
monitoring system components 37
notifications 36

T
TAR

file type explained 22
tasks, system

as an MIB object 62
background tasks (MIB object) 62

TCP ports
open in firewall 200

terminate
session 54

test
Call-Home feature 41

TGZ
file type explained 22

thin provisioning
infill affected by priority level of the volume 101

thinly provisioned volumes
definition 116
infilling 118, 119
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on Linux 118
on Microsoft Windows NTFS 117

tier reallocation
effect of deselecting 107
see also data migration.

tools, support
description 230

training programs 18
traps (MIB object) 63
troubleshoot, see diagnostics
TXT

file type explained 22

U
unassociated hosts

definition 153
LUN mappings 153
moving 153
see also SAN host entries

update
auto-tiered LUNs

convert to single-tier LUNs 131
chassis ID,

of Controller 204
of Drive Enclosure 212

comment field
for Controllers 204
for Drive Enclosures 211

data protection
auto-tiered LUNs 132
single-tier LUNs 142

data protection schedule 179
event notifications 228
LUN mapping 149
properties

for UPS devices 218
Quality of Service

auto-tiered LUNs 131
single-tier LUNs 141

single-tier LUNs
convert to auto-tiered LUNs 141

software update schedule 194
Storage Domain background process priority 81
tier reallocation options 83
volume group name 71

upload
Call-Home matrix 43

UPS devices
conservative mode 216
description 216
how to

create UPS entries 217
delete UPS entries 218
modify UPS entries 218
view UPS entries 218

utilities software

how to
download 22

V
VDS, see Oracle FS Virtual Disk Service (VDS) Provider
verify

data consistency 237
VDS Provider 151
VSS Provider 182

view
account summaries 60
alerts 221
auto-tiered LUN details 142
auto-tiered LUNs

reported allocated capacities 123
auto‑tiering effectiveness graphs 112
capacity usage 67
clone LUN details 175
Controller diagnostic results 239
Controller ports 46, 47
data protection details 180
details

of a Controller 203
of a Drive Enclosure 211

Drive Enclosure console output 244
drive group properties 90
drive groups 90
event logs 224
event notification details 228
event properties 224
immobile capacities 86
logged-in accounts 30
Pilot connectivity 198
properties

of a Pilot 198
of UPS devices 218

RAID capacities 86
RAID output 244
reporting schedules 258
SAN host entry settings 160
single-tier LUN details 142
status

of a Drive Enclosure 210
of all Controllers 203

Storage Domain properties 82
Storage Domain storage allocation 86
Storage Profiles 52
system alerts 221
UI client logs 231
volume group details 69

Virtual Disk Service (VDS) Provider, see Oracle FS
Virtual Disk Service (VDS) Provider
virtual LUNs (VLUNs)

maximum number of clone repositories 288
maximum number of volume clones 288
maximum number of volume copies 288
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quantity range for total VLUNs 288
volume copies

capacity usage 170
rehoming logical volumes 169

volume groups
description 67
how to

add logical volumes 70
add LUNs 70
add volume groups 70
assign as parent 72
create 69
delete 71
display details 69
filesystems 70
move to another volume group 72
rename 71

quantity range 288
relationship to Storage Domains 77

volume shadow copy, see Oracle FS Volume Shadow
Copy Service (VSS)
volumes have lost mappings

system alert 75
VSS Provider, see Oracle FS Volume Shadow Copy
Service (VSS)

W
Windows installer

how to
install the GUI application 23

write cache
LUN 222

write caching 103

Z
ZIP

file type explained 22
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