A Working With Multiple Tools Release Foundations

As a best practice, you should always set up multiple tools release foundations, including a test environment for applying fixes to JD Edwards EnterpriseOne tools releases. This helps ensure that a stable environment exists before you promote fixes to your production environment. You can also use this same principle and procedure to set up multiple foundations of major tools releases, such as Tools Release 9.1 and Tools Release 9.2.

The procedures described in this document enable customers to target specific environments when they install a tools release. For example, customers can keep the production environment running on the existing foundation and apply the new tools release to all other environments. This configuration enables them to perform tests on the new foundation code without impacting the production environment. When they complete the testing, they can then apply the new tools release to production.

By completing the tasks below, you can configure your JD Edwards EnterpriseOne systems to handle many foundations on a single enterprise server. These tasks require that you reconfigure pathcodes and jde.ini files to set up multiple foundations, but once the initial tasks are completed, the new configuration requires very little maintenance.

Before you begin the installation, consider these factors:

  • The multiple foundation setup uses one security server process per port.

  • If you have multiple Enterprise Servers at different tools release levels, make sure each of them is pointing to the correct security data sources.

  • If you have multiple foundations or multiple Enterprise Servers at different tools release levels, a dual maintenance of users and passwords is required.

  • Before beginning installation of the Tools Release 9.2, check the associated readme.txt file for late-breaking information and requirements.

This appendix consists of the following tasks:

A.1 Understanding Multiple Foundation Code on the Enterprise Server

To install multiple foundations, you must first install and configure new system code on the Enterprise Server. This section includes these topics:

Note:

If your JD Edwards EnterpriseOne configuration includes multiple servers running JD Edwards EnterpriseOne host code (for example, additional application servers or data servers), then you will need to apply the procedures for installing multiple foundations to each server. For this type of configuration to work successfully:
  • Make sure that the port settings for the [JDENET] section in the jde.ini match between all servers running the same foundation.

  • Ensure the new services are running on all servers.

  • Run PORTTEST successfully on all servers for all foundation releases that you have installed.

A.1.1 Working With Tools Releases on the Enterprise Server

Refer to the JD Edwards EnterpriseOne Tools Server Manager Guide as described in the section of this guide entitled: Section 1.3, "Understanding Server Manager and This Guide".

This section discusses these topics:

A.1.1.1 Creating a New User and Group

The section discusses how to create a new UNIX user and group, which varies by platform.

A.1.1.1.1 Creating Users and Groups on Solaris Platforms

This section discusses how to create users and groups on a Solaris Enterprise Server.

  • Personnel

    System administrator

  • Logon status

    On the Solaris Enterprise Server, logged on as root.

  • Prerequisites

    None

  • Concurrent Tasks

    None

Use the following procedure to create a new UNIX administrator user and group on a Solaris Enterprise Server.

  1. Log on to the UNIX Enterprise Server as root (super user). You can log on directly from a UNIX workstation or use telnet from the Microsoft Windows Deployment Server.

    • Solaris

      Run the admintool program and from the Browse menu, select Groups.

    • Solaris

      From the Edit menu, select Add. Enter the following value in the Group Name field:

      pssprelease_number

      where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

      pssp1

  2. Click OK to display a list of groups.

  3. Verify that the pssprelease_number group is listed.

    • Solaris

      From the Browse menu, select Users.

  4. Select to Add users by following this procedure:

    • Solaris

      From the Edit menu, select Add.

  5. Complete these fields:

    • Login Name

      Enter the value:

      pssprelease_number

      where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

      pssp1

    • Home Directory

      Enter the value:

      /home/pssprelease_number

      where home is the name of the home directory of the JD Edwards EnterpriseOne user you just created. The system may fill this field automatically.

    • Primary Group

      Enter the same value as you entered for the Login Name field. For example:

      pssprelease_number

      where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

      pssp1

    • Start-up Program

      Applicable to HP9000 only

      Enter this value:

      /usr/bin/ksh

      Alternatively, you can select from a list of available shells.

    • Login Shell

      Applicable to Solaris only

      Enter this value:

      /usr/bin/ksh

      Alternatively, you can select from a list of available shells.

  6. Click OK.

  7. Specify password.

    • Solaris

      Select Normal Password from the drop down menu, enter a password, verify the password, and click OK.

  8. Click OK.

    • Solaris

      Exit the admintool.

A.1.1.1.2 Creating Users and Groups on RS/6000 Platforms

This section discusses how to create users and groups on a RS/6000 Enterprise Server.

  • Personnel

    System administrator

  • Logon status

    On the RS/6000 Enterprise Server, logged on as root.

  • Prerequisites

    None

  • Concurrent Tasks

    None

Use the following procedure to create a new UNIX user and group on an RS/6000 Enterprise Server.

  1. Log on to the RS/6000 as root (super user), or use telnet from the Microsoft Windows deployment server.

  2. Run the smit program.

  3. Select Security and Users.

  4. Select Group and Add a Group.

  5. Add a group called:

    pssprelease_number

    where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

    pssp1

    Use the default values for the remaining fields.

  6. To return to the Security menu, press F3 three times.

  7. Select Users and Add a User and complete these fields:

    • User Name

      Enter the value:

      pssprelease_number

      where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

      pssp1

    • Primary Group

      Enter the value:

      /home/pssprelease_number

      where home is the name of the home directory of the JD Edwards EnterpriseOne user you just created. The system may fill this field automatically.

    • Primary Group

      Enter the same value as you entered for the Login Name field. For example:

      pssprelease_number

      where release_number is the Service Pack base release being installed. For example, for Service Pack 1 you would enter:

      pssp1

    • Home Directory

      Enter the value:

      /home/pssprelease_number

      where home is the name of the home directory of the JD Edwards EnterpriseOne user you just created. The system may fill this field automatically.

    • Initial Program

      Enter this value:

      /bin/ksh

  8. Press Enter to accept the values.

  9. To exit, press F3.

  10. To assign a password for pssprelease_number, enter this command:

    passwd pssprelease_number

A.1.1.1.3 Copying .oneworld and .profile from an Existing User to a New User
  1. Go to the home directory of an existing UNIX user. For example, your user might be psft900.

  2. Using this command, copy the .oneworld file to the home directory of the new user that you created in Creating a New User and Group:

    cp .oneworld .profile /home/user

    where user is the name of the new user you created in Creating a New User and Group.

A.1.1.2 Creating a New Host Code Directory

This section discusses how to create a host code directory on UNIX operating systems.

  1. On the UNIX-based Enterprise Server, navigate to the directory where the JD Edwards EnterpriseOne host code is installed. For example:

    mount_point/JDEdwards/

  2. Create a new directory for the service pack you want to test. For example, your directory name might be E910SPTEST or E920_DVJDPY.

    mkdir host_code_dir

    where host_code_dir is the name of the new host code directory.

    The new directory will be used to store both the new service pack and the path codes that will access the service pack.

A.1.1.2.1 Granting Ownership and Authority

Enter these commands to grant ownership and authority to the directory you created in Creating a New User and Group:

chmod 777 host_code_dir

chown user host_code_dir

chgrp group host_code_dir

A.1.1.2.2 Editing the .oneworld File

This section discusses how to change the .oneworld file.

  1. Navigate to the home directory of the new user created above.

  2. Edit the .oneworld file to update the EVRHOME path with the new host code directory. For example:

    export EVRHOME=/mount_point/JDEdwards/host_code_dir

  3. If no .oneworld script exists check the .profile file for a call to the enterpriseone.sh script. Edit the enterpriseone.sh file to update the EVRHOME path with the new host code directory. For example:

    export EVRHOME=/mount_point/JDEdwards/host_code_dir

A.1.1.2.3 Moving the Path Codes to the New Directory
  1. From the mount_point/JDEdwards/E920 directory, determine the path codes that you want to access the new Tools Release. Move the selected path codes into the newly created directory using this command:

    mv path_code /mount_point/JDEdwards/host_code_dir

    where path_code is the path code selected to be moved where a valid value for path code might be PD920.

    For example, if you wanted to test the new Tools Release with all environments except Production (PROD, PD), move the Development (DEV,DV), Pristine (PRST920, PS) and Prototype (CRP, PY) path codes.

    Do not copy the path codes. Instead you should always move them. You should not associate more than one Tools Release or Service Pack with an environment at the same time.

  2. Enter the following commands to grant ownership and authority to the path codes you moved:

    chmod 775 /mount_point/JDEdwards/host_code_dir/path_code

    chown user /mount_point/JDEdwards/host_code_dir/path_code

    chgrp group /mount_point/JDEdwards/host_code_dir/path_code

A.1.1.2.4 Creating Remaining Directories

This section discusses creating the remaining directories necessary to complete the install.

  1. Logon to the Enterprise server as the new user created above.

  2. Navigate to the new directory created above. For example:

    /mount_point/JDEdwards/host_code_dir

    In the new directory, create the following subdirectories with these exact case-sensitive names:

    • ini

    • packages

    • PrintQueue

A.1.1.2.5 Copying the jde.ini to the New Directory
  1. Navigate to this directory:

    /mount_point/JDEdwards/e920/ini

  2. Use the following command to copy the jde.ini to the host code directory:

    cp JDE.INI /mount_point/JDEdwards/host_code_dir/ini

  3. Enter the following command to change the permissions of the file:

    chmod 666 /mount_point/JDEdwards/host_code_dir/ini/JDE.INI

A.1.1.3 Editing the jde.ini File

This section discusses how to make modifications to the jde.ini file that is located on a UNIX Enterprise Server.

  1. On the Enterprise Server, navigate to the /ini directory under the new host code directory. The file is typically located in this directory:

    /mount_point/JDEdwards/host_code_dir/ini

  2. Edit the jde.ini file to change the paths in each of the entries below to point to the new host code directory:

    Note:

    Replace host_code_dir in the entries below with the name of the new host code directory.
    [DEBUG]
    DebugFile=mount_point/JDEdwards/host_code_dir/log/jdedebug.log
    JobFile=mount_point/JDEdwards/host_code_dir/log/jde.log
    JDETSFile=mount_point/JDEdwards/host_code_dir/log/JDETS.log
    
    [INSTALL]
    B9=mount_point/JDEdwards/host_code_dir
    
    [BSFN BUILD]
    BuildArea=mount_point/JDEdwards/host_code_dir/packages
    
  3. Locate the [JDENET] section and find the port settings for serviceNameList and serviceNameConnect. For each entry, add 100 to the number. For example, if the settings are both 6013, change them to 6113.

    [JDENET]
    serviceNameList=6113
    serviceNameConnect=6113
    
  4. In the [JDEIPC] section, add 1000 to the startIPCKeyValue entry. For example:

    [JDEIPC]
    startIPCKeyValue=7000
    

    Note:

    If the startIPCKeyValue value is commented out, delete the comment mark to enable the setting.
  5. In the [SECURITY] section, either clear security or edit DefaultEnvironment to reference a valid environment that accesses the new service pack.

  6. Replace all references to the production environment (for example, PD920) with a valid environment that will access the new service pack (for example, PY920).

A.1.2 Registering an Existing Enterprise Server with Server Manager

Any Enterprise Server running Tools Release 8.97 and greater should be registered with Server Manager. For details, refer to the section entitled: "Register or Create a JD Edwards Enterprise Server as a New Managed Instance" in the JD Edwards EnterpriseOne Tools Server Manager Guide.

A.1.3 Understanding PORTTEST

To ensure that the new tools release is properly installed on the Enterprise Server, complete the following task to run PORTTEST on all environments accessing the new tools release.

Note:

If Security Server is on, then JD Edwards EnterpriseOne services must be running before PORTTEST can be run.

This section contains the following topics:

A.1.3.1 Running the PORTTEST

This section discusses the procedure to run the PORTTEST command on a UNIX Enterprise server.

  1. Log on the Enterprise Server as the new user that you created in Creating a New User and Group.

  2. Enter these commands:

    cd mount_point/JDEdwards/host_code_dir/system/bin32

    PORTTEST userid password environment

    where userid is a valid Release 9.2 user, password is the password for that user, and environment is the environment you are verifying. These parameters are case-sensitive.

  3. Repeat the PORTTEST command for each environment accessing the new service pack.

A.1.3.2 Starting the Services

This section discusses how to manage Services on a UNIX Enterprise Server.

  1. Navigate to the drive and directory that contains the JD Edwards EnterpriseOne host code. For example:

    cd /mount_point/JDEdwards/host_code_dir/system/bin32

  2. Enter the following command:

./RunOneWorld.sh

A.2 Understanding Multiple Foundation Code on the Deployment Server

This chapter discusses:

A.2.1 Installing Multiple Tools Releases on the Deployment Server

  1. Sign on to the Deployment server using the JDE user ID.

  2. Make sure that all JD Edwards EnterpriseOne processes (for example, Solution Explorer) are not running.

  3. On the Deployment server, navigate to this directory:

    z:\JDEdwards\E920

    where z: is the drive on which the JD Edwards EnterpriseOne host code is installed.

  4. In the E920 directory, create a directory called

    System_TR_Original

    where TR_Original is the release number of the tools release currently installed. For example, System_920.

  5. From the \JDEdwards\E920 directory, copy (not move) the following directories to the new System directory (System_TR_Original) that was just created. This will serve as backup or rollback location for the previous release.

    System

    SystemComp

    OneWorld Client Install

    Caution:

    Ensure you do not move these directories; they are required in both locations. This is because the installer needs to save a copy of the jdbj.ini and jas.ini files so you can relocate them in the new system directory.

    Note:

    If you get a warning message, it indicates files are locked. You need to ensure that JD Edwards EnterpriseOne or any other application is not running and causing a lock on any file.
  6. Install a Management Agent on the Deployment Server. This should be the Tools Release 9.2 version of the Microsoft Windows version of the JD Edwards EnterpriseOne Management Agent.

    Refer to this chapter in the Server Manager Guide:

    Install a Management Agent

    Note:

    The installer for the Management Agent requires a 32-bit JRE. You can use the same JRE that you used to install the Deployment Server using the OUI installer.
  7. Register the Deployment Server to the Server Manage Console.

    Refer to this chapter in the Server Manager Guide:

    Register a JD Edwards Deployment Server as a New Managed Instance

  8. Obtain and deploy the Tools Release software component for the Deployment Server.

    Refer to this chapter in the Server Manager Guide:

    Managed Software Components

    Note:

    Changing Tools Releases on the Deployment Server. When you use Server Manager to install the Software Component for a Tools Release prior to 9.2 on a Deployment Server, these two directories (which are the entire contents of the Tools Release portion of the Deployment Server) are backed up in a .jar file:
    • \System

    • \OneWorld Client Install

    Therefore, when you use Server Manager to change a Tools Release prior to 9.2 on the Deployment Server, only those directories are restored.

    For Tools Release 9.2 and greater, the Server Manager install of the Tools Release performs differently because the contents are already stored in a .jar file where they can be extracted.

    In all cases, whenever Server Manager installs or changes a Tools Release, additional special files such as certain .ini and .html files are backed up.

    To fully preserve a Deployment Server, you should manually perform a full backup of the machine.

  9. In the E920 directory, create another new directory called System_TR_New where TR_New is the release number of the tools release being installed. For example, System_91_A1.

  10. Move the newly installed System, SystemComp, and OneWorld Client Install files and directories into the new directory:

    \JDEdwards\E920\System_TR_New

    For example, \JDEdwards\E920\System_91_A1.

  11. Restore the original directories by copying the System, SystemComp, and OneWorld Client Install directories from System_TR_original to the base installation directory x:\JDEdwards\E920.

  12. Locate the jde.ini in this location:

    \JDEdwards\E920\System_TR_New\OneWorld Client Install\Misc

  13. Modify the above-located jde.ini to change the port to that on which you wish to run the multiple foundation. For example, valid ports might be 6014, 6015, 6016, 6017, etc.

A.2.2 Adding a New Machine Record for the New Tools Release

  1. On the Deployment Server, log on to the deployment environment.

  2. From the Fast Path menu, run P9654A.

  3. On Work with Locations and Machines, click Find and expand the location tree.

  4. Click Enterprise Servers and then click Add.

  5. On Enterprise Server Revisions, complete the following fields:

    Field Description
    Machine Name Enter the name of your existing primary Enterprise Server.
    Description Enter a description for the machine.
    Release Enter E920.
    Host Type Click the visual assist button and select the type of Enterprise Server.
    Port Number This should match the port number previously set in the new tools release

    jde.ini

    Database Type Click the visual assist button and select the type of database being used on the Enterprise Server.
    Installation Path Enter the installation directory path in which Release 9.2 is installed on the Enterprise Server.

  6. Click OK.

    Note:

    For Oracle databases, the program prompts for a connect string. Enter or verify the connect string and click OK.
  7. On Work with Locations and Machines, click Find and expand the tree.

  8. Expand the Enterprise Server, click the newly added machine and click Select.

  9. On Enterprise Server Revisions, click the Environments form exit.

  10. On Machine Environments Revision, add the environments which you want to access with the new tools release. You can add the environments either by typing their names into the grid or by selecting them using the visual assist.

  11. Click OK twice to return to Work with Locations and Machines.

A.2.3 Modifying the Existing Machine Record to Remove Environments

  1. On the Deployment Server, log on to the deployment environment.

  2. From the fast path menu, run P9654A.

  3. On Work with Locations and Machines, click Find and expand the location tree.

  4. Expand Enterprise Servers, click the initial Enterprise Server machine record and click Select.

  5. On Enterprise Server Revisions form, click the Environments form exit.

  6. Delete all the environments that you added in the previous section.

    This should leave you with only those environments that you have defined to access the production tools release (for example, PD920).

  7. Click OK twice.

A.3 Working with Packages for Multiple Foundations

Deploying the new tools release is easily done using the Package Build application by using a non-default foundation. Use these steps to create and include a new foundation for the multi-foundation tools release.

  1. Sign on to the Deployment Server using the JDE user ID.

  2. Sign on to EnterpriseOne using the JDE user ID into the Deployment (DEPXXX) environment.

  3. Launch the Package Assembly application from menu GH9083.

  4. Go to Form/Foundation and click the Add button on the Foundation Component Selection Screen

    This image is described in surrounding text.
  5. On Foundation Item Revisions, click the OK button to save the Foundation Item Revision information.

  6. Click the Find button to display the new Foundation item list.

  7. On the Package Component Revision, click the Add button to add an update package.

    Complete these fields:

    • Name

    • Description

    • Path Code

  8. Click the Next button.

    This image is described in surrounding text.
  9. On the Package Component Revisions, enter a valid value for the Parent Package and select the Foundation icon.

  10. On Foundation Item Revisions, select the Find button.

  11. Select the Multi-foundation for the Update Package by clicking the first column of the selected row.

    Note:

    Ensure that the check mark displays in the first column of the selected row record.
  12. Click the Close button.

  13. Click the End button to complete the Package Assembly process.

  14. Click the Row > Active/Inactive icon.

  15. Click the Define Build button and continue through the subsequent screens.

    This image is described in surrounding text.
  16. On Package Build Revisions, select the Compression Options tab and select your compression options.

  17. Proceed to submit the build and deploy the package.

A.4 Working with the Development Client

Use the procedure in this section to set up your Development Client.

  1. On the GH9083 menu, launch the Package Build application.

  2. Create an update package by selecting Package Assembly and then Add.

    This image is described in surrounding text.
  3. On Work With Features, select Add.

    This image is described in surrounding text.
  4. On Feature Based Deployment Director, click Next.

    This image is described in surrounding text.
  5. On Feature Information, complete these fields:

    Field Description
    Feature Type Enter a valid value for this feature type.
    Description Enter a description for the feature.
    Feature Installation Options Select your feature installation options by checking the appropriate check boxes.
    Components Verify this check box is selected:

    Additional Install Processes


  6. Click Next.

    This image is described in surrounding text.
  7. On Package Assembly, Additional Install Processes, complete these fields:

    • Feature

      Enter a meaningful name for the feature. For example, if you are using WebLogic:

      WEBDEVWLS

      If you are using WAS, an example would be

      WEBDEVWAS

      You can specify any name for the feature.

    • Feature Type

      Enter the value 1.

    • Description

      Enter a description. For example:

      Web Development Objects (WLSH4A) for WLS

      or

      Web Development Objects (WASH4A) for WebSphere

      You can specify any name for the description.

    • Required

      Ensure this option is selected.

    • Additional Install Processes

      Ensure this option is selected.

  8. Click Save.

  9. Click Next.

  10. Continue with the rest of the package assembly; there is no need to select any objects.

  11. Define the package and, when prompted, make sure to select:

    Build Feature Inf

  12. Submit the package, which creates the new feature .inf for Web Development.

    The newly created feature .inf file is located in the package.inf directory.

    Note:

    For any subsequent package builds for the non-default foundation for which you want to include webdev feature, you can use the package that you created with this procedure.

A.5 Editing the Development Client jde.ini File

Note:

If you are using SnapShot, you do not need to manually edit the jde.ini file to manage multiple clients for multiple foundations, as described in this procedure.

This section describes editing the jde.ini file for a Development Client.

In order for the Release 9.2 clients to access the new tools release, you must edit the jde.ini file on each client to point to the new directory.

Complete the following task on all Release 9.2 clients that have path codes that will access the new tools release.

Note:

You will be unable to access multiple tools releases with a single client. To access multiple tools releases, you will need to install a different client for each tools release. This will require using the SnapShot application to save each client before installing the next one.
  1. On the Release 9.2 workstation, open Microsoft Windows Explorer, and navigate to your Microsoft Windows directory. For example:

    cd c:\WINDOWS

  2. Open the jde.ini file.

  3. Locate the [JDENET] section, and edit the port settings for serviceNameListen and serviceNameConnect. Change these entries to match those of the server jde.ini file for the new tools release.

[JDENET]
serviceNameList=portNumber
serviceNameConnect=portNumber

where portNumber is the same port number you entered in the jde.ini file on the Enterprise Server.

A.6 Setting up the Multiple jde.ini Files on the Deployment Server

You may need to set up multiple jde.ini files on the Deployment Server to address the requirement for the Development Client to access different pathcodes and ports for different application releases of JD Edwards EnterpriseOne. For details, refer to the appendix of this guide entitled: Appendix C, "Data by Pathcode".