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Copyright and disclaimer
Copyright © 2015, 2016, Oracle and/or its affiliates. All rights reserved.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of
their respective owners. UNIX is a registered trademark of The Open Group.

This software and related documentation are provided under a license agreement containing restrictions on
use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your
license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license,
transmit, distribute, exhibit, perform, publish or display any part, in any form, or by any means. Reverse
engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is
prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If
you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on
behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software,
any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are
"commercial computer software" pursuant to the applicable Federal Acquisition Regulation and agency-
specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the
programs, including any operating system, integrated software, any programs installed on the hardware,
and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No
other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management applications. It
is not developed or intended for use in any inherently dangerous applications, including applications that may
create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall
be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe
use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software
or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products and
services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim
all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and
its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of
third-party content, products, or services.
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Preface
Oracle Big Data Discovery is a set of end-to-end visual analytic capabilities that leverage the power of Hadoop
to transform raw data into business insight in minutes, without the need to learn complex products or rely only
on highly skilled resources.

About this guide
This guide describes how to download, deploy, verify, and validate the Enterprise Manager Plug-in for Big
Data Discovery. The plug-in extends Oracle Enterprise Manager Cloud Control to add support for monitoring,
diagnosing, and managing Oracle Big Data Discovery.

Audience
This guide is intended for administrators who are using Enterprise Manager Cloud Control to monitor and
manage an Oracle Big Data Discovery environment.

Conventions
The following conventions are used in this document.

Typographic conventions

The following table describes the typographic conventions used in this document.

Typeface Meaning

User Interface Elements This formatting is used for graphical user interface elements such as
pages, dialog boxes, buttons, and fields.

Code Sample This formatting is used for sample code segments within a paragraph.

Variable This formatting is used for variable values.

For variables within a code sample, the formatting is Variable.

File Path This formatting is used for file names and paths.

Symbol conventions

The following table describes symbol conventions used in this document.
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Symbol Description Example Meaning

> The right angle bracket, File > New > Project From the File menu,
or greater-than sign, choose New, then from
indicates menu item the New submenu,
selections in a graphic choose Project.
user interface.

Path variable conventions

This table describes the path variable conventions used in this document.

Path variable Meaning

$ORACLE_HOME Indicates the absolute path to your Oracle Middleware home directory,
where BDD and WebLogic Server are installed.

$BDD_HOME Indicates the absolute path to your Oracle Big Data Discovery home
directory, $ORACLE_HOME/BDD-<version>.

$DOMAIN_HOME Indicates the absolute path to your WebLogic domain home directory. For
example, if your domain is named bdd-<version>_domain, then
$DOMAIN_HOME is $ORACLE_HOME/user_projects/domains/bdd-
<version>_domain.

$DGRAPH_HOME Indicates the absolute path to your Dgraph home directory,
$BDD_HOME/dgraph.

Contacting Oracle Customer Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support.
This includes important information regarding Oracle software, implementation questions, product and solution
help, as well as overall news and updates from Oracle.

You can contact Oracle Customer Support through Oracle's Support portal, My Oracle Support at
https://support.oracle.com.
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Chapter 1

Overview

This section covers the steps for installing, upgrading, or uninstalling the Enterprise Manager Plug-in for Big
Data Discovery.

Description

Supported Versions

Prerequisites

Downloading the Plug-in

Configuring a Remote Management Agent

Deploying the Plug-in

Adding Big Data Discovery targets

Verifying and Validating the Plug-in

Upgrading the Plug-in

Undeploying the Plug-in

Documentation Accessibility

Description
The Enterprise Manager Plug-in for Big Data Discovery extends Oracle Enterprise Manager Cloud Control to
add support for monitoring, diagnosing, and managing Oracle Big Data Discovery and its components.

By deploying the plug-in within your Cloud Control environment, you gain the following management features:

• Monitor the availability and performance of Big Data Discovery components.

• Perform administrative operations such as starting and stopping Dgraph nodes.

• View logging information for each Big Data Discovery component including Dgraph request logs.

• Perform trend analysis on collected performance information.

• Gain access to rich out-of-box reports.

When the plug-in is deployed, its version displays as 13.1.1.1.0 on the View>Plug-ins >Only Deployed
filtered listing of deployed plug-ins.
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Supported Versions
This plug-in supports the following versions of Oracle products:

• Enterprise Manager Cloud Control 13c Release 1 (or higher).

• Oracle Big Data Discovery 1.1.0 or higher.

Prerequisites
The following prerequisites must be met before you can deploy the plug-in:

• Oracle Big Data Discovery 1.1.0 or higher is installed.

• The following components of Oracle Enterprise Manager Cloud Control 13c Release 1 or higher are
installed:

- Oracle Management Service with Oracle Management Repository

- Oracle Management Agent for Linux

• For remote Agent monitoring, a remote Agent must be properly configured. See Configuring a Remote
Management Agent on page 8.

• Set user privileges for the Job System of Enterprise Manager. For the procedure, refer to "Setting
Credentials for the Job System to Work with Enterprise Manager" in the Database Installation Guide for
Microsoft Windows (E24186-04).

This guide is listed in the Installing and Upgrading section of the Oracle Database Documentation Library
at: http://www.oracle.com/pls/db112/homepage.

Upgrading from Version 12.1.0.2.0

If you have Version 12.1.0.2.0 of the Enterprise Manager Plug-in for Big Data Discovery, you must first
upgrade your Enterprise Manager Cloud Control to Version 13c Release 1 (or higher) before you can install
Version 13c Release 1 of the plug-in.

After the upgrade, all BDD targets discovered in the EM 12c plugin should also exist in the new EM 13c plug-
in and be workable. So there is no need to deploy the new BDD plug-in and discover those BDD targets
again.

Downloading the Plug-in
You can download plug-ins in online or offline mode. Online mode refers to an environment where you have
Internet connectivity and can download the plug-in directly through Enterprise Manager from My Oracle
Support. Offline mode refers to an environment where you do not have Internet connectivity, or where the
plug-in is not available from My Oracle Support.

See the Managing Plug-ins chapter in the Oracle Enterprise Manager Cloud Control Administrator's Guide for
details on downloading the plug-in in either mode:
http://docs.oracle.com/cd/E63000_01/EMADM/plugin_mngr.htm#CJGBEAHJ

Oracle® Enterprise Manager Plug-In for Big Data Discovery: Version 13c Release 1 • May 2016
Installation Guide

http://docs.oracle.com/cd/E63000_01/EMADM/plugin_mngr.htm#CJGBEAHJ


Overview 8

Configuring a Remote Management Agent
Enterprise Manager uses remote agents as a communication mechanism to monitor and manage host
machines. You must install and configure a remote agent on any host machine running Big Data Discovery
nodes. Enterprise Manager can then monitor the host, discover any Big Data Discovery targets running on the
host, and manage the targets.

To configure a remote agent:

1. Log in to Enterprise Manager Cloud Control.

2. Select Setup>Add Target>Add Targets Manually.

3. Select Add Host Targets and click Add Host...

4. On the Add Host Targets: Host and Platform page, click + Add and do the following:

(a) In Host field, specify the fully qualified name of the host where you want to install the remote
agent.

(b) From the Platform list, select the appropriate platform.

For example, this is typically Linux x86-64.

(c) Specify as many target hosts as necessary.

(d) Click Next.

5. On the Add Host Targets: Installation Details page, do the following:

(a) In Installation Base Directory field, specify the path to install the remote agent into.

For example, the typical installation path is /localdisk/basedir.

(b) The Instance Directory name is populated by default based on the Installation Base Directory
value. You should not have to change this value.

(c) In Named Credential field, click the + icon.

6. In the Create new Named Credential dialog, specify the following:

(a) In UserName, specify the user who has privileges to log into the host where you want to install
the remote agent.

(b) In Password and Confirm Password, specify the corresponding password for the user.

(c) In Run Privilege, select Sudo.

(d) In Run as, specify root.

(e) Click OK.

The user you specify must have write privileges to create an installation directory on the host.

7. In the Privileged Delegation Setting, add -S to the list of command line arguments.

For example:

/usr/bin/sudo -S -u %RUNAS% %COMMAND%

Installation Guide

8. At the top of the Add Host Targets: Installation Details page, click Next.
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9. On the Add Host Targets: Review page, confirm the information and click Deploy Agent.

It may take a few moments to install the remote agent on the host. If you specified multiple target
hosts in step 4, Enterprise Manager deploys an agent to each host.

10. Click Done.

Deploying the Plug-in
You can deploy the plug-in to an Oracle Management Service instance using the Enterprise Manager Cloud
Control console, or using the EM Command Line Interface (EMCLI).

The console and the command line interface let you deploy one plug-in at a time or multiple plug-ins.

For instructions on deploying the plug-in, see the "Managing Plug-ins" chapter in the Oracle Enterprise
Manager Cloud Control Administrator's Guide:
http://docs.oracle.com/cd/E63000_01/EMADM/plugin_mngr.htm#CHDBGHFE

Adding Big Data Discovery targets
After deploying the plug-in, follow the steps below to manually discover Big Data Discovery targets and add
the targets to Enterprise Manager for central monitoring and management. Also, as part of this procedure, you
promote the targets after they have been discovered.

Remember that discovering Big Data Discovery targets identifies the components on their host machines.
Promoting the targets adds them to Enterprise Manager for central monitoring and management.

To discover targets:

1. Log in to Enterprise Manager Cloud Control.

2. Click Setup>Add Target>Add Targets Manually.

3. Select Add Targets Using Guided Process.

4. From the Target Types list, choose Oracle Big Data Discovery and click Add Using Guided
Process.

5. On the Add Oracle Big Data Discovery Targets: Select Hosts page, click + Add to display a list of
hosts.

6. On the Search and Select: Host page, select one or more host names where Big Data Discovery is
installed and click Select.

7. Specify a path to the installation for Big Data Installation Home.

For example, a typical default value is /localdisk/Oracle/Middleware/BDD1.1.1.

8. Set preferred credentials for a host:

(a) Select a host name from the table.

(b) Click Set Credential and Selected Host.

Note that the Test Connection button on the lets the system validate if the provided credentials
are correct.

(c) Specify UserName and Password values to access a host.

Oracle® Enterprise Manager Plug-In for Big Data Discovery: Version 13c Release 1 • May 2016
Installation Guide

http://docs.oracle.com/cd/E63000_01/EMADM/plugin_mngr.htm#CHDBGHFE


Overview 10

(d) Click OK.

9. Click Next.

10. On the Add Oracle Big Data Discovery Targets: Select Targets page, choose a specific cluster
from Cluster Name.

11. Select one or more targets within that cluster to promote.

12. For any Studio targets on this page, specify the WebLogic username and password under WebLogic
Authentication.

13. If a Studio target is installed with one-way or two-way SSL model, the Guided Process page
automatically enables or disables the related SSL fields. Depending on how SSL is enabled for Studio,
do one of the following so that Enterprise Manager can access the secured targets:

• If Studio is configured in one-way SSL mode, provide the Trust Keystore file name and path, type
and passphrase for Studio targets only in the SSL Trust Keystore Authentication field.

• If Studio is configured in two-way SSL mode, provide the corresponding keystore file names and
paths, types and passphrases for Studio targets in both the SSL Trust Keystore Authentication
and the SLL Keystore Authentication fields.

These SSL fields have the same meaning as their WebLogic counterparts.

Note: Enabling SSL for Studio activates default demo keystores in Weblogic, which you
should replace with your own certificates after deployment.

For additional information on the plug-in requirements for a securely deployed Studio, see the section
on Enterprise Manager plug-in in the Oracle Big Data Discovery Administrator's Guide.

14. Click Next.

15. On the Add Oracle Big Data Discovery Targets: Review page, click Submit.

You can confirm that Enterprise Manager is managing the targets by selecting Targets>All Targets
and expanding the Target Type>Middleware folder. You'll see the Target Name (the Big Data
Discovery hosts) and the Target Type (the Big Data Discovery components).

Verifying and Validating the Plug-in
After waiting a few minutes for the plug-in to start collecting data, follow the steps below to verify and validate
that Enterprise Manager is properly monitoring the plug-in target.

To verify and validate the plug-in:

1. Click Targets, then All Targets.

2. On the All Targets page, expand Target Type>Middleware and select an Oracle Big Data Discovery
Cluster.

The target home page displays.
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Upgrading the Plug-in
The Self Update feature allows you to expand Enterprise Manager's capabilities by updating Enterprise
Manager components whenever new or updated features become available. Updated plug-ins are made
available via the Enterprise Manager Store, an external site that is periodically checked by Enterprise Manager
Cloud Control to obtain information about updates ready for download.

See the Updating Cloud Control chapter in the Oracle Enterprise Manager Cloud Control Administrator's
Guide for steps to update the plug-in:
http://docs.oracle.com/cd/E63000_01/EMADM/self_update.htm#CHDCGJBJ

Undeploying the Plug-in
See the Managing Plug-ins chapter in the Oracle Enterprise Manager Cloud Control Administrator's Guide for
steps to undeploy the plug-in:

http://docs.oracle.com/cd/E63000_01/EMADM/plugin_mngr.htm#CHDFDJAB

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website:

http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.
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