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Preface 
 
 
 

EDAConnect Installation Guide Overview 
 
 

This manual provides step-by-step instructions for installing EDAConnect Library-
Sync and EDAConnect Designer. The manual is organized into the following 
chapters: 
 

• Chapter 1: EDAConnect Overview — Describes EDAConnect 
components and the system architecture of a typical EDAConnect 
installation 

• Chapter 2: LibSync Installation Requirements — Lists specific hardware 
and software requirements for EDAConnect LibSync installation. 

•  Chapter 3: LibSync Installation Procedure — Provides LibSync-specific 
instructions for installation and testing. 

 
 

Font Conventions 
 
 

In this guide, the following font conventions are used: 
 

• Links, buttons, menus, and icons that are clicked appear in Bold Face Type. 

• Items to select in drop-down menus or navigator trees are bold with “→” between 
entries. 

• Window and field names are in Initial Capitals. 

• Cross references to sections and other chapters appear as underlined text. 

• References to other Perception Software documentation appear in italicized text. 

• Information to be provided or entered by the user appear in <italicized text> between 
angle brackets. 

 

 
 

Perception Software Technical Support 
 
 

If you encounter installation issues and you require technical support assistance, you 
may contact us by logging to your customer account at www.perceptionsoftware.com 
and clicking the Submit Issue button in the navigation panel. Or, to speak to a 
Customer Support representative directly, dial: 888-828-1444 x118. 
 

 

 

 

 

 



 

 
 

EDAConnect Overview 
 
 
 

Introduction 
 
 

EDAConnect is an application framework that supports multiple ECAD/EDA tool to 
PLM system connectivity. EDAConnect consists of the following components: 
 

• An application framework providing core functionality 

• Plug-ins that extend the framework for specific engineering to PLM tasks 

• ECAD drivers that provide connectivity to specific ECAD tools 
 
There are two plug-ins for EDAConnect: LibSync and Designer. These are described below. 
 

 

LibSync 
 
 

EDAConnect LibSync is an application consisting of the EDAConnect application 
framework and the LibSync plug-ins. LibSync extracts critical PLM attributes and makes 
them available to EDA tools. This application is typically installed and run by the 
librarians within the engineering organization. 
 
LibSync is a desktop application (client-side only) that connects to the PLM infrastructure 
and manages a separate database to which the EDA tools connect. This database is 
referred to as the local EDA database. Since the EDA tools can connect to a database 
populated with attribute data, LibSync requires no additional software for the engineering 
community. This data is kept current by LibSync through a synchronization schedule 
configured by the librarian. 
 
 

Installation Architecture 

 
 

The following diagram shows the system architecture for a typical EDAConnect 
installation. Each component of this architecture is described below. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 



  
   

  

 

 

 

 
 
 

  

 

   
 

  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

PLM System 
 
 

EDAConnect Designer and LibSync are client applications to the PLM infrastructure. 
Designer and LibSync communicate with the PLM system through the PLM system’s 
API. Designer uses EDA-specific drivers to extract BOM information from ECAD 
projects and allows the user to compare that information against a previously existing 
BOM and to publish new BOMs and Engineering Change Orders to the PLM system. 
LibSync reads part attribute data such as lifecycle phase, lead time, and RoHS 
compliance and stores that information in the Local EDA Database which can then be 
read both EDA tools. 
 

 
 

Local EDA Database 
 
 

The local EDA database stores the extracted attributes from the PLM system by 
EDAConnect LibSync which manages the table structure in the database to be 
consistent with what ECAD tools require. The connection to the local database is 
made via the ODBC standard. The database is not required to be physically local to 
the EDA environment, but generally must be on a high performance LAN. 
 

 
 

Librarian Workstation 
 
 

The librarian workstation is the machine utilized by the librarian. The librarian 
workstation is required to have an EDAConnect LibSync application installed for both 
configuring and executing the automated library synchronization. This application allows 
the librarian to configure the list of items and attributes that are written to the local EDA 
database. 



 

 

 
 

EDA Tool Environment 
 
 

EDAConnect Designer is installed on the workstations in the EDA tool environment which 
consists of the EDA tool workstations and associated software. Designer uses EDA-
specific drivers to extract BOM information and design files from ECAD projects. The 
user may then use Designer to check-in design files to the PLM system, compare BOM 
information against a previously existing BOM in the PLM system, and to publish new 
BOMs and Engineering Change Orders as required. 
 
LibSync reads part attribute data such as lifecycle phase, lead time, and RoHS 
compliance and stores that information in the local EDA database. A subset of EDA 
tools (generally, schematic capture) can then access to the local EDA database to 
facilitate part selection. 
 
 

EDAConnect LibSync Logs 

 
 

EDAConnect applications create the following logs:  

• Configuration Details Log 

• Eclipse Error Log 

• Perception Log 

 

Configuration Details Log 

 
 

The Configuration Log has the following characteristics: 
 

• Logs detailed information regarding Eclipse and Java settings including: 

o System Properties 

o Plug-in Registry 

o User Preferences 

  



• Is accessible through Help→About EDAConnect…→Configuration 

Details 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Eclipse Error Log 
 
 

The Eclipse Error Log has the following characteristics: 
 

• Logs Eclipse framework errors and untrapped application exceptions 

• Is accessible through Help→About EDAConnect…→Configuration Details→View 
Error Log 

 
NOTE: Typically, this information is not required when reporting 
a problem and can be ignored. 

 

Perception Log 
 
 

The Perception log has the following characteristics: 
 

• Logs Java transactions, error messages, and all trapped exceptions 

• Logs all Console messages and library synchronization information �

 Log pathname is: 

<install_path>\EDAConnect-LibSync\logs\perception.log 
 
  

NOTE: The perception.log logging level for LibSync scripts can 
be set via the scripts.logging.level property in the config.ini 
file. 



 

LibSync Installation Requirements 

 
 
 
 

PLM Platform Requirements 

 
 
 

Hardware Requirements 
 
 

EDAConnect LibSync is designed to support the Agile infrastructure. Additional 
hardware is not required to support EDAConnect LibSync. 
 

 

PLM System Requirements 
 

Specific licensing requirements are determined by the PLM version being utilized 
and the purchased EDAConnect PLM driver. 
 
EDAConnect LibSync version 3.4.0 supports Agile 9.3.x – 9.3.4 
 

 

 
 

ECAD Server Platform Requirements 
 

Hardware Requirements 
 
 

The minimum hardware requirements for EDAConnect LibSync are: 
 

• RAM: 512MB 

• Free Disk: 100MB 
 

 
 

Workstation OS Requirements 
• RedHat Linux (RHEL) 6.6  - 64bit 

• Windows Server 2008  -  64bit 
 

 

  



Supported ECAD Tools 
 
 

ECAD tool support is dependent on the ECAD tools that support a Part Selection 
database.The following table lists the tools supported. 
 

 

Supported ECAD Tools 

Orcad Capture CIS 

Mentor DxDatabook 

Altium Database Library 

Concept PTF File  

 

 
 

Local Database Requirements 
  
EDAConnect LibSync populates a database to which the EDA tools connect. This 
database may be any of the following: 
 

• Microsoft Access 2003 with Mircosoft ODBC Driver 4.00.6304.00 

• MySQL 5.0 with MySQL ODBC Driver 3.51.12.00 

• Oracle 10g with Oracle ODBC Driver 10.02.00.01 
  
Other versions of these databases and ODBC connectors should be valid, but EDAC 
is only validated against those listed. There are known incompatibilities using the 
Oracle ODBC driver with Oracle 8i. 
 

 

 
 

International Character Sets 
 
 

The use of international character sets is not fully supported in LibSync. For example, 
non-English characters in PLM class names results in local database table names 
containing non-English characters which may cause synchronization to fail. 
 

 

 
 

JRE Requirements 
 
 

Libsync requires access to a Java Runtime Environment. Libsync supports both JRE 1.6 and 

1.7. Both are available within the download file. The version you should install is based on the 

version of Agile PLM you are integrating with.  



 

Librarian Workstation Requirements 
 
 

To support background synchronization, the librarian must configure a workstation that is 

available 24x7. This machine need not be a standalone dedicated server; however, if this 

machine is not operational and connected to the network, then library synchronization will not 

occur. The workstation must meet the minimum EDAConnect hardware requirements. 

 

 

CAD Library Connector Installation  
 

Software Distribution Structure 

 
 

EDAConnect Libsync is server based application that is configured by an administrator and is 

run as a service. 

EDAConnect Libsync software is available from the Oracle Software Delivery Cloud. 

You can enter the keyword  CAD Library      to location the product. 

 

 

Select the appropriate Platform and you will be presented with your Products for download. 

Click Continue to see the Available Releases for the ECAD Connector. Check all download 

files checkboxes and click Continue. 

Once you have agreed to the license terms you will be presented with the File Download form, 

download all zip files. 

The Agile CAD Library Connector zip file will contain the following files:  

Platform Zip Filename Description 
Windows  libsync-3.4-windows.zip Installation package for Libsync 
Windows  agilexplorer-3.4-win64.zip Installation package for Agile Explorer 



Windows agilexplorer-3.4-win64.zip.md5 Checksum for Agile Explorer zip file 
Linux libsync-3.4-linux.zip Installation package for Libsync 
Linux agilexplorer-3.4-linux64.zip Installation package for Agile Explorer 
Linux agilexplorer-3.4-linux64.zip.md5 Checksum for Agile Explorer zip file 

 

Installation Instructions 
 

Agile Explorer 
Once you have the agilexplorer*zip file available use the following on-line documentation for 

installation instructions, http://support.perceptionsoftware.com/entries/79052905-System-

Installation.  

Libsync 
 

► To assemble an installation folder for EDAConnect LibSync 

1. Create an installation folder for your EDAConnect Software, e.g. c:\Perception. 
2. Extract the contents of the libsync-3.4-<platform>.zip file to your EDAConnect 

installation folder. This should create an EDAConnect-Libsync folder (e.g. 
C:\Perception\EDAConnect-Libsync) 

3. If you are using Agile 9.3.3 or 9.3.4 extract the contents of EDAConnect-
Dashboard\jre_zips\jre7u51.zip to your EDAConnect-Dashboard folder. This should 
create an EDAConnect-Libsync/jre folder. After this is completed you can delete the 
EDAConnect-Dashboard\jre_zips folder. 

4. If you are using Agile 9.3.0, 9.3.1 or 9.3.2 extract the contents of EDAConnect-
Dashboard\jre_zips\jre6u26.zip to your EDAConnect-Dashboard folder. This should 
create an EDAConnect-Libsync/jre folder. After this is completed you can delete the 
EDAConnect-Dashboard\jre_zips folder. 

5. If you are running on Linux extract the contents of the appropriate EDAConnect-
Libsync\linux_versions\ linux.gtk*.zip file into your EDAConnect-Libsync folder. 

6. If you are integrating with ConceptHDL copy the file 
com.perception.drivers.database.ptf_1.6.0.201503060809.jar from the EDAConnect-
Libsync\storage_driver_jars folder to EDAConnect-Libsync\product\plugins. 

7. If you are integrating with Orcad CIS, DxDatabook or Altium Database Libraries copy 
the file com.perception.drivers.database.odbc_1.8.0.201503060809.jar from the 
EDAConnect-Libsync\storage_driver_jars folder to EDAConnect-
Libsync\product\plugins. 
 

 

 
 

► Launching LibSync  
 

Navigate to: 

 

<install_path>\Perception\EDAConnect-LibSync\install 
 



NOTE: If you are setting up automated library synchronization, it is required that the 

machine executing the synchronization be available and online during the scheduled 

synchronization slots. 

 
 

Configuring EDAConnect LibSync 
 
 
 

Configuring Java Heap Size 
 
 

LibSync is pre-configured to use a Java maximum heap size of 512 MB. Depending on the 

size of the part classes being synchronized, you may encounter Java “Out of memory” errors. 

Should this occur, you may increase the maximum heap size by editing the MAX_HEAP_SIZE 

parameter in: 
 

<install_path>\EDAConnect-LibSync\EDAConnect-LibSync.bat 

 
 

Configuring LibSync Properties (config.ini) 
 
 

The following table describes specific properties that should be configured during the 

installation of LibSync. These properties are located in: 

<install_path>\ EDAConnect-LibSync\product\configuration\config.ini 

 
 

 

LibSync Configuration File (config.ini) Properties 

Property Name Description Example Values 

PLM Server Host Parameters 
 

plm.hosts 

 

 

Specifies PLM server URLs used 
to populate the PLM Server Host 
drop-down list in the PLM 
Connection dialog. 

 

 

plm.hosts= 
http://agileprod.mycompany.com, 
http://agiletest.mycompany.com 

 

 

 

 

 

 

 

 

 
 

LibSync Configuration File (config.ini) Properties 

Property Name Description Example Values 

PLM Processing Parameters 



 

plm.itemnumber.attribute 

 

 

Identifies the PLM item number 
property name used by the PTF 
driver. 

 
Default = Title Block.Number 

 

 

plm.itemnumber.attribute = 
Item Number 

 

 

rows.per.query 

 

 

Specifies the number of PLM rows 
to process at a time. 

 
Default = 1000 

 

 

rows.per.query = 2000 

 

EDA Local Database and PTF File Parameters 
 

database.date.format 

 

 

Specifies the default date format to 
display when converting date data 
types to string during ODBC or 
PTF synchronization. 

 
Default = MM/dd/yyyy 

 

See the Date Format Table below 
for more information. 

 

 

database.date.format = MM-dd-yy 

 

 

database.money.precision 

 

 

Specifies the default number of 
decimal places to display when 
converting money data types to 
string during ODBC or PTF 
synchronization. 

 
Default = -1 (no formatting) 

 

 

database.money.precision = 2 

 

 

database.numeric.precision 

 

 

Specifies the default number of 
decimal places to display when 
converting numeric data types to 
string during ODBC or PTF 
synchronization. 

 
Default = -1 (no formatting) 

 

 

database.numeric.precision = 1 

 

 

odbc.source.date.format 

 

 

Specifies the date format to use to 
parse PLM date fields. 

See the Date Format Table below 
for more information. 

 

odbc.source.date.format = 
yyyy-MM-dd HH:mm:ss 

 

 

string.column.length 

 

 

Default field size for strings in the 
LibSync mapping file for the local 
EDA database. 

 

Default = 32 

 

 

string.column.length = 64 

 

 
 

 

 

 

 

 

 

 

 
 



LibSync Configuration File (config.ini) Properties 

Property Name Description Example Values 

EDA Local Database and PTF File Parameters 
 

uom.logging 

 

 

Specifies whether unit of measure 
logging is enabled (on) or disabled 
(off). 

 

Default = off 

 

 

uom.logging = on 

 

 

 

 
 

LibSync Configuration File (config.ini) Properties 

Property Name Description Example Values 

Scripting Parameters 

scripts.logging.level 

 

Specifies the logging level for scripts. 
Multiple levels may be specified using 
a comma-delimited list. 

 

scripts.logging.level = err,out 

 

scripts.properties.file 

 

Specifies the pathname to the 
scripts.properties configuration file used 
by various scripts. 

Backslashes must be doubled: 
c:\\Perception\\... 

scripts.properties.file = 
c:\\Perception\\scripts\\scripts.properties 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Value Logs 

err System.err (default) 

 

out 

 

System.out, 
edaconnectConsole.writeMessage 

debug edaconnectLogger.logError 



 

 

 

Date Format Table 

Letter   Date or Time Component Example Values 

G Era designator AD 

y Year 1996; 96 

M Month in year July; Jul; 07 

w Week in year 27 

W Week in month 2 

D Day in year 189 

d Day in month 10 

F Day of week in month 2 

E Day in week Tuesday; Tue 

a am/pm marker PM 

H Hour in day (0-23) 0 

k Hour in day (1-24) 24 

K Hour in am/pm (0-11) 0 

h Hour in am/pm (1-12) 12 

m Minute in hour 30 

s Second in minute 55 

S Millisecond 978 

z Time zone Pacific Standard Time; PST; GMT-08:00 

Z Time zone -800 

 

 
 

Setting the PLM Connection Preferences 
 
 
 

► To set PLM connection preferences for LibSync 

 

1. Select Window→Preferences from the Window menu on LibSync’s taskbar. 

2. Select Library Synchronization from the Preferences navigation tree. The 

Library Synchronization dialog box is displayed. 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Select the “PLM Server Host.” 
 

A. Choose the desired PLM server URL from the “PLM Server Host” drop-
down menu. If the desired server URL is not included in the list, enter 
the URL manually. 

 
NOTE: The PLM system administrator will need to supply the 
exact URL, but it is typically of the form: 
http://plmserver.domain/VirtualDirectory. 

 
If the URL does not use HTTPS protocol, proceed to step 4. If 
the URL does use HTTPS protocol, it will be necessary to add 
the PLM server’s CA certificate key to LibSync’s JRE trusted 
keystore in order to access the PLM server. 

 

 

B. Save the PLM server’s root CA certificate key to the local disk: 

• Open the PLM URL with IE 6 or IE 7. 

• Click View→Security Report or the lock icon on the status 

bar or address bar to display the Security Report. 



  
   

[s t ]  

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

• Click View certificates. 

• Click the Certification Path tab and select the root certificate by double-
clicking on it. 

• Select the Details tab and click on the Copy to File… button. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

• In the Certificate Export Wizard “Welcome” dialog, click the Next button. 

• In the “Export File Format” dialog, select “DER encoded binary” and click the 

Next button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

• In the “File to Export” dialog, specify a known location on the local 
disk such as: 

<install_path>\EDAConnect-LibSync\userware\<my_certificate.cer> 
 

and click the Next button. 
 

• In the “Completing the Certificate Export Wizard” dialog, click the 
Finish button. 

 
• Click the OK buttons to close the windows associated with certificate export. 

 
 

C. Register the certificate key with LibSync’s JRE:  

• In Windows, open a command window. 

• Navigate to the bin directory for LibSync’s JRE: 
 

cd <install_path>\EDAConnect-LibSync\jre\bin 
 
 

• Use the following command to register the certificate key: 
 

keytool -import -v -file <install_path>\EDAConnect-
LibSync\userware\<my_certificate.cer> -keystore 
<install_path>\EDAConnect-LibSync\jre\lib\security\cacerts 

-storepass changeit 
 
 

4. Enter the appropriate “User Name” and “Password” for the PLM server. 



 
NOTE: The password is encrypted for security. 

 
5. If your PLM system requires additional parameters such as port number 

assignments, enter the information in the “Additional Parameters” field. 
 

6. Check the Auto Login checkbox to enable auto-login. Uncheck the Auto 
Login checkbox to disable auto-login. 

 

7. You may omit the “Log File Name” since LibSync automatically logs all 
transaction and exception information to the perception.log file.  

8. Enter the parts type in the “Parts Type” field. 
 

NOTE: “Parts Type” specifies the PLM objects that may be 
utilized for attribute mapping. A typical value for this field is 
“Items/Parts” or “Parts Class”. If you are uncertain 
regarding the appropriate value to enter for “Parts Type”, 
please ask the PLM administrator. 

 
 

Configuring the Local Database Instance 
 
 

Based on mappings defined by the librarian, EDAConnect LibSync synchronizes PLM 

mastered metadata with the ECAD tools. This is accomplished by populating a simple 

database from which the ECAD tools read. EDAConnect will fully manage this database, 

creating new tables and adding new rows and columns as required. Due to this cache 

database, ECAD tools receive high performance access to accurate PLM metadata. 

  

NOTE: LibSync purges old data from this database during synchronization. Therefore, 

this database should be regarded as read-only. 

 

Recommendations 
 
 

When setting up EDAConnect LibSync, it is important to plan the location and type of database 

required. EDAConnect supports the ODBC standard. This allows EDAConnect to 

communicate with many standard database technologies without the need to modify the 

application. 

 
 

Database Technology 
 
The choice of database technology depends on the following factors: 

• Size of the ECAD Library (number of unique part numbers and attributes) 

• Physical location and number of designers 

• Network access speed 

• Number of users 

 

 



 

Size of the ECAD Library 
 
The size of the library determines how much data is managed by the database. Each unique 

part number basically adds a row into the database, while each unique attribute adds a column. 

Generally speaking, the number of unique part numbers that engineers may choose from is 

determined by the PLM system and the ECAD library, and generally is not changeable. There 

is flexibility in selecting the number of attributes that are of high value to engineering. 

A part library with 5,000 - 10,000 unique part numbers and 5 - 10 attributes is small and may 

be suitable for a simple database such as Microsoft Access. Larger part libraries really should 

consider a full RDBMS instance such as MySQL or Oracle. It is strongly recommended that 

one use the qualified ODBC driver for the chosen database application (see Local Database 

Requirements on page 14). 

 
 

Physical Location 
 
The location of the database generally impacts the performance of choosing new parts or 

executing schematic verifications. The performance is greatly affected by the IT infrastructure. 

It is advisable that the attribute cache reside within the confines of the LAN, ideally at the same 

physical site as the designers. The most important criterion generally is the response time the 

designers experience while selecting parts. The synchronization of the library is done offline 

and thus does not impact the day-to-day activities of the design engineer. 

 
 

Network Access Speed 
 
The amount of data utilized for the day-to-day efforts of the engineers is not very high. Hence, 

network throughput is not a critical issue; however, network latency is. Each part requires a 

roundtrip communication with the database server. A high latency network will make such 

roundtrips slow. This is especially true when doing full sheet part verification in the ECAD tool. 

Generally speaking, most LAN implementations are of sufficient performance, and any issues 

are likely to arise in WAN situations or in remote sites with VPN-type access. 

 
 

Number of Users 
 
The number of users may dictate the database technology, but the frequency of access by 

each user is critical. In a large design group with a large ECAD library, it is possible that 

several users are searching for parts concurrently, while a number of other users are executing 

full schematic verifications. This causes a high number of concurrent database transactions. 

Technologies such as Microsoft Access are not designed to handle this, and should be 

upgraded to a full RDBMS. A small design team of say 5 engineers will have much lower 

concurrent access to the database, in which case Microsoft Access would suffice. 

 

 

 

 
 



Configuring Microsoft Access 
 
 

The Local EDA Database must be set up on a networked server and a Data Source Name 

(DSN) must be set up for each computer that is to communicate with the database. Please see 

Appendix A – Configuring an ODBC Database on page 37 for the procedure to create a new 

database and set up a Data Source Name. Also, see the documentation for your database 

application and ODBC driver for more specific configuration information. 

The following section describes how to set up a simple Microsoft Access database. It assumes 

Microsoft Access is available on a shared workstation. These instructions assume MS Access 

2003, but the procedure is similar for other versions. 

 

 
 

Testing the LibSync Environment 
 
Use the following procedure to verify that EDAConnect LibSync has correct access to PLM and 

to the local database. This procedure assumes that: 

• Java Runtime is installed and operational. 

• EDAConnect Application is installed and available to current workstation. 

• Agile is running with appropriate SDK or API runtime licenses available. 

• You have a valid Agile account and permissions. 

• ODBC database is available. 

 
 

► To test proper connectivity 
 

1. Launch EDAConnect-LibSync. 
 

2. Set up Library Synchronization preferences: 
 

A. Select Window→Preferences…→Library Synchronization. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

A. Choose the desired PLM server URL from the “PLM Server Host” drop-down 

menu. If the desired server URL is not included in the list, enter the URL manually. 

B. Enter the appropriate “User Name” and “Password” for the PLM server. 

C. Check the “Auto Login” checkbox to have LibSync automatically login to PLM on 

start up. 

D. Enter the full pathname for a LibSync log file in the “Log File Name” field. E. Set 

“Parts Type” to Items/Parts or another value as appropriate. 

F. Click Apply and then click OK. The dialog will close.  

3. Create a test mapping file: 

A. In the main application window, select File→New→Mapping File.  

B. Enter a filename “c:\test” and click the Finish button. 

 

 
 



4. Set up the PLM Connection: 

A. Enter your <PLM server>, <username> and <password> in the appropriate fields 

in the PLM Connection group box. 

 

 

 

 

 

 

 

 

 

 

 

B. Click the Test Connection button in the PLM Connection group box. 

The Console window should display a “PLM connection successful” message. 

 

5. Set up the Database Connection: 

A. Enter the DSN name for the Local EDA Database or the pathname to the PTF 

Update Template in the “Connection String” field. 

B. If you opted to password protect the DSN, enter your database credentials. 

 

 

 

 

 

 

 
 

C. Click the Test Connection button in the Database Connection group box. 

The Console window should display a “Database connection successful” 

message. 

If both the PLM Connection and Database Connection tests reported a 

successful, connection you have validated a successful installation of 

EDAConnect LibSync. 

NOTE: If you desire e-mail notification when synchronization has been 

completed, you must edit the SMTP connection information under the 

ODBC settings. This will require valid SMPT server and connection 

information. 

 

 

 

 

 

 

 
 



Troubleshooting the LibSync Environment 
 
 

If either the PLM connection test or the database connection test fails, then troubleshoot the 

connection using the steps below: 

 

 

► To troubleshoot PLM connection issues  

• Verify network connectivity. 

• Verify PLM Server Host URL including protocol, host name and path. 

• Verify your PLM server is accessible from this workstation by logging into the PLM web 

portal. 

• Verify your PLM credentials (username/password) are correctly entered. � Verify that 

you have a valid SDK runtime license. 

 
 

► To troubleshoot database connection issues 
 

• Verify the MDB file exists by opening the file in Microsoft Access. 

• Verify your database credentials (username/password) are correctly entered.  

• Verify that no one else has the database opened exclusively. 
 

 
 

Installing LibSync as a Windows Service 
 
 

LibSync provides a command line interface for synchronization. Once a LibSync installation is 

configured and working, it may be desirable to install the LibSync as a service if ODBC or PTF 

synchronizations are to be performed on a regular schedule. That way, if the LibSync server is 

rebooted, then LibSync will restart automatically. 

 

 
► To install LibSync as a Windows Service 

1. Set up the config_service.ini file: 

A. Navigate to the LibSync configuration directory: 

<install_path>\EDAConnect-

LibSync\product\configuration 

B. Open config_service.ini in a text editor. 
 

C. Set the desired values for the following 

properties: i. libsync.home 

ii. libsync.psm_files 
 

iii. libsync.default_logfile 
 
 
 



NOTE: Each time the config_service.ini file or a template 
file referenced by the config_service.ini is edited, the 
LibSync CLI tool service will need to be stopped and 
restarted via Windows Services in order for the new 
settings to take effect. 

 
 

2. Install the LibSync CLI tool service: 
 

A. Navigate to the LibSync installation directory: 

<install_path>\EDAConnect-LibSync 

B. Double-click on LibSyncServiceInstall.bat to install the LibSync service.  

C. Launch Windows Services to configure the LibSync service: 

Start→Settings→Control Panel→Administrative Tools→Services 
 

D. Locate EDAConnect-LibSync Service in the Services listing and double-
click on the service name to open the EDAConnect-LibSync Service 
Properties dialog. 

 

E. Set “Startup type” to “Automatic” and click the OK button. 
 

F. Right-click on EDAConnect-LibSync Service and select Start to Start the 
service. 

 
NOTE: The DSN referenced by the LibSync mapping file 
must be a system level DSN in order to work with the 
LibSync service. 

 
NOTE: Once the service is started, a libsyncservice.log file is 
created in the EDAConnect-LibSync\product directory. 

 
 

When installing a new version of LibSync, it may be desirable to use a different 

pathname for the installation so as not to overwrite the existing installation. This not only 

provides the ability to easily revert back to the prior version, if necessary, but also 

makes it easy to transfer the config.ini fle from the old installation to the new installation. 

For example, the installation paths might be:

Old Installation: New 

Installation: 

c:\Perception\EDAConnect-LibSync-140 

c:\Percpetion\EDAConnect-LibSync-142 

 

 



 

 

► To change the pathname for LibSync service 

1. In Windows, open a command window on the LibSync server. 2. Enter the 

following commands: 

sc stop LibSyncService 

sc config LibSyncService binPath=”<install_path>\product\ LibSyncService.exe” 

sc start LibSyncService 

To remove the LibSync service altogether, use the following procedure. 

 

 

► To delete LibSync as a Windows Service 
 

1. In Windows, open a command window on the LibSync server. 2. Enter the 

following commands: 

sc stop LibSyncService sc delete LibSyncService 

 
 
 
 

Appendix A – Configuring an ODBC 
Database 

 
 
 

This procedure describes how to set up an ODBC database and configure the Data Source 

Name (DSN). The DSN tells Windows how to communicate with a database. A DSN must be 

set up for every computer that is to communicate with a given database. This includes the 

librarian’s and the designer’s workstations. 

NOTE: Microsoft Access is used as the example database. However, the procedure is 

similar for other database applications. 

 
 

► To configure an ODBC database 

1. Set up a DSN (Data Source Name) 

A. In Windows, go to Start→Settings→Control Panel to launch the 

Control Panel  

B. Select Administrative Tools. 

 

 

 

 

 

 
 



2. Select Data Sources (ODBC). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The ODBC Data Source Administrator dialog box is displayed. 

 
 

3. Select the Drivers tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

The Drivers tab lists any ODBC Data Sources already present on your system. You 

may refer to any one of these by name in the Database Connection table on the 

General tab of a PSM file. 

NOTE: Be careful to select the correct name or you may corrupt an existing 

database. 

 

 

 
 



4. Verify the driver you need is installed and is the correct version level per the 

following table: 

 

 ODBC Driver Requirements 

Database ODBC Driver 

Microsoft Access 2003 Mircosoft ODBC Driver 4.00.6304.00 

MySQL 5.0 MySQL ODBC Driver 3.51.12.00 

Oracle 10g Oracle ODBC Driver 10.02.00.01 

SQL Server 2005 SQL_Server Driver 6.00.6000.16386 

 

 
 

NOTE: Other versions of these databases and ODBC connectors 
should be valid, but EDAConnect is only validated against those 
listed. There are known incompatibilities using the Oracle ODBC 
driver with Oracle 8i. 

 
 

5. If the required ODBC driver is not present, you will need to install it. 

NOTE: Consult your database user documentation to find out where to obtain the 

ODBC driver and how to install it. 

6. Create a new Data Source: 

A. If LibSync is not configured as a service, select the User DSN. Otherwise, select 

the System DSN tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

B. Click the Add button to create a new Data Source. 
 



C. Select the appropriate Data Source (in this example, Microsoft Access) and click 

the Finish button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

The ODBC Setup dialog box is displayed. 

NOTE: The ODBC Setup dialog is different for each database type. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

NOTE: You may encounter problems with data types if you're using an Oracle Data 

Source and Oracle’s NLS_LANG variable is not set properly. NLS_LANG should be 

set to: 

 

 

 
 



AMERICAN_AMERICA.WE8MSWIN1252 

or whatever is appropriate for your system. Please refer to your Oracle 

documentation for more information. 

D. Enter the “Data Source Name” and “Description”. 

Use this name in the “Connection String” field in the Database Connection group 

box on the General tab of the PSM file. 

Click the Select button to select and existing Access database. Otherwise, go to 

step F. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

• Select an existing Access database and click the OK button. 

• Go to step G. 

 

NOTE: This file should be accessible on your network by others. 
 
 

E. Click the Create button to create a new database. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

• Enter the “Database Name” for the new database. 



• Select the location for the new database and click the OK button. 

 
 

NOTE: This file should be accessible on your network by others. 

 
 

F. Click the OK button to close the ODBC Setup dialog box. 

G. Click the OK button to close the ODBC Data Source Administrator dialog box. H. 

Close the Administrative Tools dialog box. 

 

For MySQL, the ODBC Setup dialog looks like this: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

NOTE: MySQL uses authentication, so you’ll need to 
enter the login credentials here. Also, be sure that Pad 
Char to Full Length on the Advanced→Flags 2 tab is 
unchecked. 

 

 
 

  



For Oracle, the ODBC Setup dialog looks like this: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


