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前言

Oracle 的 StorageTek SL8500 模块化磁带库系统是一个企业存储解决方案，可提供完全自动化的盒式磁带存储和检索。

本指南假定您熟悉 SL8500 磁带库模块和组件。有关介绍性信息和规划信息，请参见《SL8500 概述和规划指南》，网址：

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html


文档可访问性

有关 Oracle 对可访问性的承诺，请访问 Oracle Accessibility Program 网站 http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc。


获得 Oracle 支持

购买了支持服务的 Oracle 客户可通过 My Oracle Support 获得电子支持。有关信息，请访问 http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info；如果您听力受损，请访问 http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs。








1 安装 StorageTek Library Console

Oracle 的 StorageTek Library Console (SLC) 是用于配置、监视和管理 SL8500 磁带库的 GUI 应用程序。




	
注:

盒式磁带上的客户数据对 SLC 或磁带库是绝对不可用的。磁带机的外部数据接口与磁带库基础结构是分离的。







	
选择 SLC 版本


	
下载 SLC 介质包


	
安装单机版 SLC


	
安装 Web 版 SLC






选择 SLC 版本

除非另行说明，否则可以使用以下 SLC 版本中的任一种执行本文档中的过程。

	
单机版－SLC 从具有到磁带库的网络连接的任何系统远程运行。


	
Web 版－SLC 安装在服务器上，允许各个客户机使用浏览器访问 SLC。


	
本地操作面板－SLC 预先安装在磁带库上，这样磁带库操作员就可以在磁带库上直接使用大多数 SLC 功能。









下载 SLC 介质包

介质包包括 Web 版 SLC 服务器、Web 版 SLC 客户机和单机版 SLC。

	
访问 Oracle Software Delivery Cloud：

http://edelivery.oracle.com


	
单击 Sign In/Register。


	
阅读条款和限制。指明您接受这些条款和限制。


	
搜索 SLC，然后选择 Oracle StorageTek Library Console。单击 Select Platform。


	
选择 GENERIC (All Platforms)，然后单击 Select。


	
确认 "Selected Products" 下列出了 Oracle StorageTek Library Console，然后单击 Continue。


	
单击 Select Alternate Release。选择一个 SLC 版本，然后单击 Continue。


	
阅读条款和限制。指明您接受这些条款和限制，然后单击 Continue。


	
保存 zip 文件。将介质包解压缩到所需位置。









安装单机版 SLC

	
在更新之前卸载 SLC 的所有以前版本。


	
下载并提取单机版 SLC 介质包（请参见下载 SLC 介质包）。


	
选择操作系统适用的 SLC 安装程序文件（请参阅介质包自述文件）。


	
查看信息。单击 Next。


	
指定 SLC 的安装位置。单击 Next。


	
指定创建 SLC 快捷方式图标的位置。单击 Next。




	
注:

在 Solaris 上，无法选择默认的根目录。Oracle 建议使用 /u-sr/bin 或类似的位置。








	
验证信息是否正确。单击 Install。


	
单击 Done。





支持的平台

	
Solaris 10 SPARC、Solaris 10 x86


	
Windows Server 2008 SP2 64 位、Windows 2012 Enterprise Server


	
Windows 7 SP1 64 位、Windows 8 64 位、Windows 8.1 64 位


	
Oracle Unbreakable Linux 5 (2.6.18) 32 位


	
SUSE Enterprise Linux 10.2 (2.6.16) 32 位








安全注意事项

SLC 通过 SSL 与主磁带库接口 (primary library interface, PLI) 相连接，SSL 提供磁带库和 SLC 会话之间的安全通信路径。这可防止未经授权的网络用户监视磁带库活动。








安装 Web 版 SLC

仅需在服务器上安装 Web 版 SLC 更新。可以在 Web 版 SLC 服务器运行期间对其进行更新。安装更新之后，客户机启动该应用程序时，这些更新就会自动下载。

	
下载并解压缩 Web 版 SLC 服务器 (.war) 文件（请参见下载 SLC 介质包）。


	
在服务器上部署文件（请参阅介质包自述文件）。






最低浏览器要求

	
Internet Explorer 8（Windows 7：64 位）


	
Firefox 17.0.2 ESR（Windows 7：64 位）








安全注意事项

Web 版 SLC 具有数字签名，用于保证该软件是由 Oracle Corporation 发布并且自创建以来未被改变或损坏。作为 Java Web Start 进程，Web 版 SLC 包含由 Java 2 平台提供的安全功能。




	
重要提示:

您负责实施所有相应的其他安全系统，包括防火墙和用户访问权限。

















2 登录 SLC




	
注:

在进行 RE 故障转移之后，使用新的活动磁带库控制器（先前的备用控制器）的 IP 地址或 DNS 别名进行登录。







	
安装磁带库后首次登录


	
登录到单机版 SLC


	
登录到 Web 版 SLC


	
登录到本地操作面板


	
更改用户密码






安装磁带库后首次登录

	
使用 admin 用户 ID，通过 Oracle 提供的激活密码的前八个字符登录到 SLC。


	
更改 admin 密码：

	
选择 Tools > User Mgmt


	
完成密码字段。


	
单击 Modify。












登录到单机版 SLC

	
要在系统上启动 SLC，请执行以下任一操作：

	
双击 SLC 桌面图标。


	
选择 Start > RunSLConsole 或 Launch > RunSLConsole。





	
输入登录信息。单击 Log on。









登录到 Web 版 SLC

要使用浏览器登录，请从 http://www.mozilla.com 下载 Mozilla Firefox。在 Solaris 平台上，还可以使用命令行登录到 Web 版 SLC。

	
获取 SLC 服务器的 DNS 别名或 IP 地址。


	
选择登录方式：

	
命令行－仅在 Solaris 上可用。在终端窗口中，输入：

javaws http://server_ID:port_ID/opel/slc.jnlp


	
浏览器－在 Windows 或 Solaris 上都可用。在客户机系统上的浏览器中，转至 SLC Web Start 应用程序：

http://server_ID:port_ID/opel




其中：

	
server_ID－SLC 服务器的 IP 地址或 DNS 别名。


	
port_ID－SLC 应用程序的端口 ID，通常是 8080。


	
opel－服务器上 Web 版 SLC 应用程序的名称（上下文根目录）。





	
单击 Launch Now。


	
指定要对 slc.jnlp 文件采取的操作。选择以下两个选项之一：

	
Open with Java Web Start Launcher，以直接启动 SLC。


	
Save to Disk，以将 slc.jnlp 文件保存到客户机中并在以后登录 SLC。





	
如果是首次运行 Web 版 SLC，请完成数字签名警告对话框（验证发布者并单击 Run）。


	
输入 SLC 登录信息。单击 Log on。









登录到本地操作面板

一次只有一个用户可以登录本地操作面板。

	
如果屏幕显示空白，则触碰屏幕的任何位置可激活 login 屏幕。


	
输入登录信息。


	
单击 Log on。









更改用户密码

每个站点都有一组固定的用户 ID：admin（客户管理员）、service（Oracle 技术支持代表）和 oem（第三方现场服务技术人员）。为每个用户 ID 分配了一组权限，这些权限确定用户可以访问 SLC 内的哪些实用程序。 

	
使用要修改的帐户登录到 SLC。


	
选择 Tools > User Mgmt


	
填写以下字段：Current Password、New Password 和 Retype Password。


	
单击 Modify。











3 激活可选功能

硬件激活文件可启用可选的磁带库功能，如容量升级和分区。您必须为购买的每个功能安装一个硬件激活文件。

	
下载新的硬件激活文件


	
安装新的硬件激活文件


	
显示当前的硬件激活文件


	
删除硬件激活文件


	
在具有早于 FRS_7.00 的固件的磁带库上启用功能






下载新的硬件激活文件

仅针对具有固件 FRS_7.00 或更高版本的磁带库使用该过程。对于具有较低固件级别的磁带库，请参见在具有早于 FRS_7.00 的固件的磁带库上启用功能。

	
访问 Oracle Software Delivery Cloud：

http://edelivery.oracle.com


	
单击 Sign In/Register。


	
阅读条款和限制。指明您接受这些条款和限制。


	
搜索 SL8500，然后选择硬件激活文件。单击 Select Platform。


	
选择 GENERIC (All Platforms)，然后单击 Select。


	
确认 "Selected Products" 下列出了正确的硬件激活文件，然后单击 Continue。


	
选择可用的发行版。单击 Continue。


	
阅读条款和限制。指明您接受这些条款和限制，然后单击 Continue。


	
保存 zip 文件，然后将其提取到所需位置。









安装新的硬件激活文件




	
注:

自固件 FRS_8.31 和 SLC 6.25 之后，一个分区硬件激活文件可以激活整个复合磁带库中的分区。







	
使用 SLC 登录到目标磁带库。


	
选择 Tools > Hardware Activation。


	
单击 Install Hardware Activation Keys 选项卡。


	
通过浏览找到硬件激活文件。


	
查看硬件激活文件详细信息。单击 Install。


	
验证是否已成功安装激活文件（请参见显示当前的硬件激活文件）。




	
注:

您可能还需要执行其他任务才能使用新功能（请参见配置容量和对磁带库进行分区）。
















显示当前的硬件激活文件




	
注:

要显示所有硬件激活活动的日志，请使用 "Reports" 实用程序（请参见使用 Reports 实用程序查看磁带库和设备报告）。







	
登录到目标磁带库。

自固件 FRS_8.31 和 SLC 6.25 之后，复合磁带库的所有硬件激活文件都显示在一个屏幕中。您可以登录到复合磁带库中的任何磁带库。


	
选择 Tools > Hardware Activation


	
单击 Current Hardware Activation Keys 选项卡。









删除硬件激活文件

只有在极少数情况下才需要删除硬件激活文件，此删除操作会影响磁带库的运行。磁带库上安装有多余的硬件激活文件不会导致任何问题（例如，容量激活文件超出磁带库的物理容量）。

	
使用 SLC 登录到目标磁带库。


	
选择 Tools > Hardware Activation。


	
单击 Delete Hardware Activation Files 选项卡。


	
选择要删除的激活文件。


	
验证是否已选择正确的激活文件，然后单击 Delete。




	
注:

删除文件后您可能还需要执行其他任务（请参见删除分区）。
















在具有早于 FRS_7.00 的固件的磁带库上启用功能

对于具有早于 FRS_7.00 的固件的 SL8500 磁带库，请与 Oracle 技术支持联系以启用可选功能。对于固件 FRS_7.00 或更高版本，请使用下载新的硬件激活文件中介绍的过程。








4 配置容量 




	
注:

磁带库控制器自动分配已分区磁带库中的容量。只能在未分区磁带库中配置容量。








	
在单个磁带库中应用默认容量配置


	
在单个磁带库中创建定制容量配置


	
在复合磁带库中创建定制容量配置


	
解决由容量更改导致的孤立磁带问题


	
定制容量激活的准则


	
修改容量配置之后对 HLI 主机的影响






在单个磁带库中应用默认容量配置

对于具有单个主机且未分区的单个磁带库，磁带库可以在您安装硬件激活文件后自动激活容量。

从固件 FRS_8.31 开始，默认配置从磁带机周围组件激活容量，直到容量许可证用完。

	
为了防止发生冲突，请在配置磁带库之前与其他磁带库用户进行协商。


	
在单机版或 Web 版 SLC 中，选择 Tools > Select Active Cells。


	
单击 Design By Library 选项卡。


	
单击 Apply Default Capacity。




	
注:

应用默认容量会从介质验证池中移除所有磁带机。要重新添加磁带机，请参见定义介质验证池。











	
注意:

如果出现警告，请不要提交更改。单击 Details >>，然后对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。








	
重新配置磁带库主机应用程序以识别更改（请参见主机软件文档）。









在单个磁带库中创建定制容量配置




	
注:

可以单击 Refresh 放弃未确定的更改并存储上次保存的配置。必须应用配置才能将其保存至磁带库控制器。







	
为了防止发生冲突，请在配置磁带库之前与其他磁带库用户进行协商。


	
在单机版或 Web 版 SLC 中，选择 Tools > Select Active Cells > Design By Library 选项卡。


	
从下拉列表中选择磁带库区域。然后，单击 Add（选择要激活的区域）或 Remove（取消激活区域）。


	
完成配置后，单击 Apply User Design。




	
注意:

如果出现警告，请不要提交更改。单击 Details >>，然后对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。








	
重新配置磁带库主机应用程序以识别更改（请参见主机软件文档）。





单个磁带库的容量图标


	SLC 图标	说明

	[image: 白色矩形表示非活动单元。]（白色矩形）
	非活动－尚未许可使用的插槽

	[image: 带三角形的白色矩形表示活动单元。]（带三角形的白色矩形）
	活动－已许可使用的插槽

	[image: 紫色矩形表示已选择的单元。]（紫色矩形）
	已选择－已指定要激活或取消激活的插槽

	[image: 暗红色矩形表示无需激活。]（暗红色矩形）
	无需激活－资源默认处于活动状态











在复合磁带库中创建定制容量配置




	
注:

可以单击 Refresh 放弃未确定的更改并存储上次保存的配置。必须应用配置才能将其保存至磁带库控制器。







	
为了防止发生冲突，请在配置磁带库之前与其他磁带库用户进行协商。


	
在单机版或 Web 版 SLC 中，选择 Tools > Active Cells。




	
注:

单击 Reset Capacity 会移除介质验证池中的当前容量配置和所有磁带机，因此您需要创建新的定制容量设计。








	
选择磁带库区域（您可以单击 "Rail" 或 "Library" 按钮，或者单击单个区域）。然后，单击 Add（激活）或 Delete（取消激活）。

红色部分表示激活的容量。白色部分表示非活动容量。最小容量激活增量是四分之一滑轨，最高可达每个磁带库 16 个区域。


	
完成配置后，单击 Apply User Design。




	
注意:

如果出现警告，请不要提交更改。单击 Details >>，然后对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。








	
重新配置磁带库主机以识别更改（请参见主机软件文档）。





复合磁带库的容量图标


	SLC 图标	说明

	[image: 纯白色矩形表示非活动单元。]（白色矩形）
	未分配－尚未许可使用的滑轨区域

	[image: 纯红色矩形表示活动单元。]（红色矩形）
	已分配－已许可使用的滑轨区域。

	[image: 带边框的矩形表示已选择的单元。]（黑色边框）
	已选择－已指定要激活或取消激活的区域








图 4-1 复合磁带库容量激活示例

[image: 周围的文本说明了 图 4-1 。]



图例： 

	
选择整个磁带库


	
选择半个滑轨


	
活动的半个滑轨（红色表示已分配容量）


	
非活动的四分之一滑轨（白色表示未分配容量）


	
已选择的非活动四分之一滑轨（由黑色粗边框表示）









解决由容量更改导致的孤立磁带问题

更改磁带库的活动容量可能会导致孤立磁带错误。当主机不能访问某个磁带时，该磁带便成为孤立磁带。

要解决孤立磁带，可以：

	
生成孤立磁带的报告（请参见生成活动容量报告）


	
审计磁带库（请参见审计磁带库）


	
对磁带执行恢复移动（请参见移动磁带（恢复移动））




有关分区磁带库，请参见解决由分区更改导致的孤立磁带问题。






定制容量激活的准则

	
以可能的最大块（滑轨、磁带库侧面或磁带库挡板）选择存储资源。避免选择单个磁带机和存储阵列。


	
要使磁带机的访问效果最佳，请同时激活磁带库内部和外部磁带库挡板并激活磁带机附近的存储插槽。


	
当快速导入和导出磁带更为重要时，激活磁带存取口 (Cartridge Access Port, CAP) 附近的存储插槽。


	
避免取消激活包含磁带的插槽或者手动将磁带移至非活动插槽。否则会创建孤立磁带。









修改容量配置之后对 HLI 主机的影响

修改容量配置之后通过主机软件启动审计。

激活容量之后，受影响的磁带库将临时脱机，然后将重新联机。脱机时，磁带库停止接受新传入的主机作业，但会完成已接受的作业。不必断开再重新连接 HLI 主机。

磁带库控制器会向所有主机发送异步消息，以便通知它们磁带库配置已更改。ACSLS 主机必须执行未分区磁带库审计以将新的容量包含在内。在执行审计时，主机可以继续处理作业。








5 对磁带库进行分区

磁带库分区将保留磁带库资源（磁带机、插槽和批量 CAP），以供指定的主机独占使用。分区是使用硬件激活文件启用的可选功能（请参见激活可选功能）。

在向分区分配插槽时，磁带库控制器会自动激活这些插槽。请确保有足够的购买容量供分区设计使用。分区可以是非连续的。




	
注:

旋转 CAP 是共享的磁带库资源，因此您无法将它们分配给某个分区（请参见在分区的磁带库中共享 CAP）。







	
使用 SLC 对磁带库进行分区


	
在分区的磁带库中共享 CAP


	
解决由分区更改导致的孤立磁带问题


	
分区时最大限度地提高磁带库性能






使用 SLC 对磁带库进行分区




	
注:

在使用 Commit 选项卡应用更改之后，才会发生分区更改。要放弃未提交的更改，请单击 Refresh。







	
添加分区 ID


	
更改分区的名称


	
删除分区


	
在单个磁带库的分区中分配资源


	
在复合磁带库的分区中分配资源


	
提交分区更改






添加分区 ID

	
停止所有主机操作。


	
选择 Tools > Partitions > Summary (Step 2) 选项卡。


	
在 "Partition Allocation Summary" 区域中单击 Add Partition。


	
从下拉列表中选择一个分区 ID 并输入分区名称。分区 ID 无需连续。


	
单击 OK。


	
对于单个磁带库，继续执行在单个磁带库的分区中分配资源。

对于复合磁带库，继续执行在复合磁带库的分区中分配资源。









删除分区

删除某个分区后，会将为该分区分配的所有资源标记为可用，删除该分区的所有主机连接，并删除分区 ID。

	
将有效的数据磁带移出将要删除的分区（请参见移动磁带（恢复移动））。


	
停止所有主机操作。


	
选择 Tools > Partitions > Summary (Step 2) 选项卡。


	
在 "Partition Allocation Summary" 表中，选择要删除的相应分区。


	
单击 Delete Partition。


	
对于单个磁带库，单击 Design by Library (Step 3) 选项卡。然后，单击 Verify。




	
注意:

如果出现警告，则单击 Details >> 并对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。然后重新验证设计。







对于复合磁带库，将自动执行验证。


	
如果未显示警告，请继续执行提交分区更改。









更改分区的名称

	
选择 Tools > Partitions > Summary (Step 2) 选项卡。


	
在 "Partition Allocation Summary" 表中，选择要修改的相应分区。


	
单击 Modify Partition。


	
输入分区名称。单击 OK。


	
继续执行提交分区更改。









在单个磁带库的分区中分配资源

	
选择 Tools > Partitions > Design by Library (Step 3) 选项卡。


	
从下拉列表中选择一个分区 ID。


	
使用下拉列表选择磁带库区域。单击 Add（分配）或 Remove（取消分配）。




	
注:

您可以将批量 CAP 分配给分区。批量 CAP 是每个滑轨末端上更大的矩形。S 表示共享 CAP。








	
要完善分区，请从第二个下拉列表中选择 Remove Array 或 Add Array。然后单击要修改的磁带机、阵列或批量 CAP。


	
为每个分区 ID 重复步骤 2-4。




	
注:

要将一个分区中的某个资源重新分配至另一个分区，必须在重新分配该资源之前将其从初始分区中删除。









	
在完成分区设计后，单击 Verify。




	
注意:

如果出现警告，则单击 Details >> 并对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。然后重新验证设计。








	
如果未显示警告，请继续执行提交分区更改。





适用于单个磁带库分区的规范

	
最多八个分区。


	
最小插槽增量为一个阵列。


	
最小磁带机增量为一个磁带机。









在复合磁带库的分区中分配资源

	
选择 Tools > Partitions > Design (Step 3) 选项卡。


	
从左上角的选项中选择分区（如果没有分区，请参见添加分区 ID）。


	
选择磁带库的资源。您可以单击 "Rail" 或 "Library" 按钮，或者单击单个区域。




	
注:

您可以将批量 CAP 分配给分区。批量 CAP 是每个滑轨末端上更大的矩形。S 表示共享 CAP。








	
单击 Add（分配）或者 Delete（取消分配）。


	
为每个分区重复步骤 2-5。




	
注:

要将一个分区中的某个资源重新分配至另一个分区，必须在重新分配该资源之前将其从初始分区中删除。









	
继续执行提交分区更改。





适用于复合磁带库分区的规范

	
总共最多 16 个分区，每个磁带库最多八个分区。


	
最小插槽增量为四分之一滑轨（例如磁带库右侧滑轨 1 的内部挡板）


	
最小磁带机增量为一个磁带机。


	
分区边界可以跨直通端口 (pass-thru port, PTP)。









提交分区更改

在完成这些过程之前，分区配置不会发生更改。

	
为了防止配置冲突，应在提交分区更改之前使磁带库对其他用户不可用并停止所有主机操作。


	
选择 Commit (Step 4) 选项卡。


	
单击 Apply。




	
注意:

如果出现警告，请不要提交更改。单击 Details >>。然后，对孤立磁带执行恢复移动（请参见移动磁带（恢复移动））。








	
更新所有受影响的主机应用程序以识别更改（请参见主机软件文档）。








SLC 分区图标的含义


表 5-1 磁带库分区图标

	图标
	说明

	
[image: 纯白色矩形表示非活动单元。]（白色矩形）


	
可用－滑轨的区域尚未分配给分区



	
[image: 彩色矩形]（彩色矩形）


	
已分配－滑轨的区域已分配给分区



	
[image: 带 S 的矩形]（带 S 的白色矩形）

	
共享的批量 CAP


	
仅复合磁带库分区

[image: 带边框的矩形表示已选择的单元。]（黑色粗边框）


	
已选择－已选择要修改的区域。单击 "Add" 会将该区域分配给分区。单击 "Delete" 将使该区域可供其他分区使用。









图 5-1 复合磁带库分区示例

[image: 周围的文本说明了 图 5-1 。]



图例： 

	
选择整个磁带库


	
选择半个滑轨


	
已将半个滑轨分配给红色分区


	
可用的四分之一滑轨


	
已选择四分之一滑轨（由黑色粗边框表示）











在分区的磁带库中共享 CAP

在分区的磁带库中，主机间可以共享 CAP。每个主机可以在需要时保留 CAP，然后在不再需要时释放该 CAP。如果 CAP 为空、已关闭、已锁定且尚未被其他分区保留，主机可以保留该 CAP。在分区的磁带库中禁用 CAP 自动装入模式，因为它会干扰保留系统（请参见自动装入模式）。

如果分区未释放 CAP 保留，并且您无法终止 ACSLS 或 ELS 中的装入或弹出命令，则磁带库管理员必须覆盖保留（请参见覆盖分区的 CAP 保留）。






解决由分区更改导致的孤立磁带问题

在分区磁带库中，孤立磁带位于未分配给原始主机的插槽中。当更改分区大小、删除分区或将磁带移到未分配给分区的插槽或磁带机时，就可能出现孤立磁带。

在分区的磁带库中，孤立磁带可能导致数据丢失。分区中存在孤立磁带的主机可能会将该磁带视为临时卷并覆盖数据。

SLC 会在发现孤立磁带时发出警告。要解决孤立磁带问题，请执行以下操作：

	
生成孤立磁带的报告（请参见生成活动容量报告）


	
审计磁带库（请参见审计磁带库）


	
对磁带执行恢复移动（请参见移动磁带（恢复移动））









分区时最大限度地提高磁带库性能

	
以可能的最大块（滑轨、磁带库侧面或磁带库挡板）对存储插槽进行分区。以完整的磁带库滑轨进行分区以最大程度地减少升降装置的使用。在复合磁带库中，使一个分区包含在一个磁带库中以最大程度地减少 PTP 的使用。


	
为了最好地访问磁带机，请将内部和外部磁带库挡板一起激活。


	
避免对单个磁带机和存储插槽阵列进行分区。仅在需要优化已经以较大的块概括性地定义的容量时，才选择和取消选择个别资源。


	
为了更快地装入和弹出，请将靠近 CAP 的存储插槽分区在一起。为了更快地访问存储的数据，请将靠近磁带机的存储插槽分区在一起。











6 操作 CAP

磁带存取口 (cartridge access port, CAP) 用于装入或者弹出磁带。有两种 CAP 类型：批量 CAP 和旋转 CAP。有关 CAP 类型的概述，请参见《SL8500 概述和规划指南》。

	
使用 CAP 装入磁带


	
使用 CAP 弹出磁带


	
锁定/解锁 CAP


	
覆盖分区的 CAP 保留


	
修改批量 CAP 消息


	
启用和禁用批量 CAP


	
CAP 模式


	
CAP 使用准则





另请参见

	
在分区的磁带库中共享 CAP






使用 CAP 装入磁带

CAP 磁带盒是可移除的。您可以按任意顺序将磁带放置到任何磁带盒插槽中，使轮毂装置面朝下，磁带标签面朝您。




	
注意:

当您装入磁带时，CAP 磁带盒必须树立。装入磁带时将 CAP 磁带盒平放可能会因磁带无法正确对齐而导致机械手错误。










	
注意:

为了避免设备损坏，请勿强制打开或关闭 CAP。切勿装入无标签的磁带或将磁带倒置。







	
在主机启动装入操作（请参见主机软件文档）。


	
解锁指示灯亮起时，按 CAP 按钮。


	
将磁带放置到 CAP 中，使轮毂装置面朝下，条形码面朝您。


	
如果使用批量 CAP，请关闭 CAP 门并按 CAP 按钮。

如果使用旋转 CAP，请按 CAP 按钮以关闭 CAP。

磁带库会将磁带从 CAP 移动到存储插槽，记录磁带位置，并将该位置发送到主机。CAP 为空后，磁带库会将 CAP 返回至其默认状态。





如何使用 CAP 最大限度地提高磁带库性能

	
将需要经常装入和弹出的磁带放到邻近 CAP 磁带盒的位置。


	
装入与磁带所在滑轨相邻的磁带盒。


	
为便于确定哪些磁带去往哪个滑轨，请将标签置于 CAP 外部以指示磁带盒的磁带类型。


	
使用与具有兼容磁带机的滑轨相邻的 CAP 磁带盒装入磁带。









使用 CAP 弹出磁带




	
注意:

为了避免设备损坏，请勿强制打开或关闭 CAP。







	
在主机启动弹出操作（请参见主机软件文档）。


	
解锁指示灯亮起时，按 CAP 按钮。

CAP 门将打开。


	
将所有磁带从 CAP 中移除。


	
如果使用批量 CAP，请关闭 CAP 门并按 CAP 按钮。

如果使用旋转 CAP，请按 CAP 按钮以关闭 CAP。


	
机械手将继续向 CAP 填入，直到将您指定的所有磁带导出。重复步骤 2 至步骤 4。

磁带库弹出所有磁带后，机械手将审计 CAP 以验证其是否为空（在导出操作期间机械手不读取磁带标签）。然后，磁带库从磁带库控制器数据库和主机数据库中清除磁带的位置。CAP 会恢复到其默认状态。









锁定/解锁 CAP

通常由主机软件解锁或锁定 CAP。然而，如果您无法通过主机解锁 CAP，则可以使用以下过程。解锁的 CAP 会被磁带库保留，直到锁定之后才可供所有主机使用。




	
注:

如果主机保留了 CAP，则其必须释放 CAP 保留，之后您才能解锁 CAP。







	
尝试使用主机软件解锁 CAP。


	
如果您无法通过主机解锁 CAP，请在 SLC 中选择 Tools > Diagnostics。


	
展开 CAP 文件夹。选择要修改的 CAP。


	
单击 Access 选项卡。


	
在 "Locked" 下拉列表中选择：

	
False 可解锁。


	
True 可锁定。





	
单击 Apply。









覆盖分区的 CAP 保留

如果分区未释放 CAP 保留，并且您无法终止主机上的装入或弹出命令，请使用此过程覆盖 CAP 保留。




	
注:

必须遵循此过程中的所有步骤，否则 CAP 可能会对所有分区不可用。







	
在 SLC 中，选择 Tools > Diagnostics。


	
展开 CAP 文件夹，然后选择要覆盖的 CAP。


	
单击 Unreserve 选项卡。记下 CAP 的分区 ID。


	
单击 Apply 覆盖保留。


	
如果 CAP 已锁定，则将其解锁（请参见锁定/解锁 CAP）。


	
打开 CAP。移除所有磁带。


	
关闭 CAP。磁带库将验证 CAP 是否为空。CAP 状态变为 "unreserved"，这将使 CAP 对所有分区都可用。


	
确定您是否应将磁带重新装入磁带库。确保将磁带装入正确的分区。









修改批量 CAP 消息

SLC 可以基于装入或弹出期间从 ACSLS 或 ELS 发送的消息编号显示 CAP 通知消息。该消息在 CAP 解锁后显示在 "Systems Details" 的 CAP 状态页面上（请参见查看设备状态和属性）。

[image: 周围的文本说明了 cap_message.png。]

您必须在 SLC 中配置消息（请参见下文），并将消息编号连同来自主机的装入或弹出请求一起发送（请参见主机软件文档）。


创建新批量 CAP 消息

	
在 SLC 中，选择 Tools > Configuration。


	
单击 Cap Usage Messages 选项卡。


	
单击 Add。


	
输入消息编号（介于 4 和 99 之间）。


	
输入消息（最多 80 个字符）。单击 OK。




	
注:

超过 18 个字符的消息在 CAP 状态页面中将被截断。然而，从状态页面中，您可以单击消息以在弹出窗口中查看完整消息。








	
单击 Apply。





修改或删除现有批量 CAP 消息




	
注:

您无法修改或删除前四个消息。








	
在 SLC 中，选择 Tools > Configuration。


	
单击 Cap Usage Messages 选项卡。


	
从列表中选择消息，然后单击 Modify 或 Delete。


	
单击 Apply。









启用和禁用批量 CAP

磁带库不会使用禁用的批量 CAP 来装入或弹出磁带。例如，如果您无法方便地操作顶部 CAP，则应禁用滑轨 1 上的 CAP。

	
在 SLC 中，选择 Tools > Configuration。


	
单击 Enable/Disable CAP 选项卡。


	
为 CAP 选择 "Disable" 或 "Enable"。


	
单击 Apply。









CAP 模式


自动装入模式

仅未分区的 HLI 磁带库支持 CAP 自动装入模式（请参见主机软件文档以启用自动装入）。

利用 CAP 自动装入模式，磁带库操作员可以打开 CAP 并在不发出显式装入请求的情况下启动装入操作。处于自动装入模式的 CAP 将保持解锁状态，并且不要求主机保留。


手动模式

手动模式是最安全的 CAP 操作方法。处于手动模式时，系统将默认锁定 CAP，并且其 LED 指示灯熄灭。要使用手动 CAP 启动装入或弹出操作，您必须输入显式装入或弹出请求，然后再按下小键盘上的 CAP Open。






CAP 使用准则

	
插入磁带时方向要正确（轮毂装置面朝下，标签面朝您）。装入磁带时您可以跳过 CAP 中的插槽。


	
在将磁带放入 CAP 中之前验证所有磁带均具有正确的标签。切勿装入无标签的磁带。


	
要更有效地装入磁带，请在发出装入命令之前先装入 CAP 磁带盒。


	
如果执行作业只需要一个 CAP，请勿使用多个 CAP。打开多个 CAP 会增加审计时间。


	
如果与 CAP 相邻的机械手不工作，则无法访问此 CAP（或此部分的旋转 CAP）。











7 配置磁带机

	
配置磁带机清洗


	
配置磁带机托盘序列号


	
通过调整磁带机放置最大限度地提高磁带库性能






配置磁带机清洗

磁带库磁带机需要使用清洗磁带定期进行清洗，以防止读/写错误。从 SL8500 固件 FRS_7.00 和 SLC 5.50 开始，必须由主机应用程序（如 ACSLS 或 ELS）管理磁带机清洗。

但是，从 SL8500 固件 FRS_8.31 和 SLC 6.25 起，磁带库将自动清洗介质验证磁带机。因此，使用介质验证的磁带库必须在保留的系统插槽中具有清洗磁带。您可以使用 SLC 装入介质验证清洗磁带（请参见导入或导出诊断磁带或清洗磁带）。此外，您可以使用 CLI 管理清洗磁带（请参见附录 B 命令行界面参考的 cleaning 部分）。



配置主机管理的磁带机清洗

	
在 SLC 中，选择 Tools > Configuration。为磁带库和所有分区禁用自动清洗。单击 Apply。（自动清洗功能默认情况下处于禁用状态）。




	
注:

自 SL8500 固件版本 FRS_7.00 和 SLC 版本 5.50 起，无法通过 SLC 启用/禁用自动清洗功能。只有磁带库管理员可以通过 CLI 进行此操作。








	
从主机启用自动清洗。

	
对于 ELS，请参见《ELS System Programmer's Guide》以启用清洗功能。


	
对于 ACSLS，自动清洗功能默认情况下处于启用状态。请参见《ACSLS Administrator's Guide》。





	
使用 ACSLS 或 ELS 命令将清洗磁带装入磁带库中。




	
注:

请勿使用 SLC 的 Import/Export 页面为主机管理的清洗装入清洗磁带。








	
使用 ACSLS 或 ELS 监视清洗磁带和磁带机的状态。


	
使用 ACSLS 或 ELS 命令将清洗磁带从磁带库中弹出。不能使用 SLC 的 Import/Export 页面来弹出主机管理的清洗磁带。











配置磁带机托盘序列号

	
选择 Tools > Configuration。


	
单击 Drive Tray S/N 选项卡。


	
单击 Refresh 以显示当前数据。


	
要编辑单个磁带机托盘序列号，请执行以下操作：

	
双击 "Drive Tray S/N" 字段。


	
输入磁带机托盘序列号。继续执行步骤 6。





	
要一次编辑多个磁带机托盘序列号，可以编辑逗号分隔值 (comma-separated value, csv) 文件：

	
单击 Export，然后将文件保存到所需的位置。


	
打开该文件，只对磁带机托盘序列号进行编辑。请勿更改其他值。保存更改。


	
在 SLC 中，单击 Import。找到刚才更新的 .csv 文件，然后单击 Open。





	
单击 Apply，然后单击 Yes。









通过调整磁带机放置最大限度地提高磁带库性能

	
为了减少升降装置和直通活动，请在每个滑轨上放置多个磁带机类型。


	
将同一滑轨上的磁带机和兼容磁带组合在一起。


	
对于挂载速率十分高的应用，不要在一个滑轨上放置十六个磁带机。这会导致需等待很长时间才能使用机械手。对于挂载速率很高的应用，可能需要将多个滑轨上的磁带机聚集在一起。


	
在冗余的机械手磁带库中，先在最外面的列 (± 2) 中安装磁带机。这样两个机械手便可以同时访问磁带机。











8 管理磁带

	
移动磁带（恢复移动）


	
定位磁带


	
查看磁带信息


	
导入或导出诊断磁带或清洗磁带


	
磁带类型


	
处理磁带


	
通过调整磁带放置最大限度地提高磁带库性能





另请参见：

	
使用 CAP 装入磁带


	
使用 CAP 弹出磁带


	
解决由分区更改导致的孤立磁带问题


	
解决由容量更改导致的孤立磁带问题






移动磁带（恢复移动）

使用 SLC 移动磁带仅会更新磁带在磁带库控制器数据库中的位置。必须通过主机软件执行审计以更新主机数据库，从而防止挂载失败。

要查看磁带库中所有磁带的表，请参见查看磁带信息。




	
注意:

要避免数据丢失，在分区磁带库中移动磁带时应谨慎操作。意外地将磁带从一个分区移到另一个分区将使磁带孤立，并且新分区可能将覆盖现有数据。








	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 RcvrMove 选项卡。


	
选择源位置模式：

	
对于 VOLID，输入要移动的磁带的 vol-id。


	
对于 Location，选择磁带的当前位置（CAP、Slot、Drive、Reserved Slots）。





	
选择目标位置类型（CAP、Storage Slots、Drive 和 Reserved Slots）并选择目标地址。




	
注:

仅当源为 CAP 或保留的插槽时才选择 "Drive"。
不要将数据磁带移动到保留的插槽中。保留的插槽应仅包含诊断磁带或清洗磁带。










	
单击 Start。


	
从主机软件启动磁带库审计以更新主机数据库（请参见磁带管理软件文档）。









定位磁带

可以按卷 ID、内部磁带库地址或 HLI 地址搜索磁带。

要查看磁带库中所有磁带的表，请参见查看磁带信息。



按卷 ID 定位磁带

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 Search 选项卡。


	
选择 VOLID。


	
输入卷 ID（使用 * 作为通配符）。


	
从 "Requester" 下拉列表中，选择搜索结果的格式：

	
default 以磁带库内部地址格式显示。


	
hli0 或 hli1 以 HLI-PRC 地址格式显示。





	
选择磁带类型。


	
单击 Search。









按地址定位磁带

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 Search 选项卡。


	
选择 Location。


	
从下拉列表中选择搜索标准，然后输入地址（通配符无效）。


	
从 "Requester" 下拉列表中，选择在 "Location" 字段中输入的地址类型。


	
单击 Search。


	
单击 . . . 以查看有关磁带的详细信息。











查看磁带信息

	
在 SLC 中，选择 Tools > Reports。


	
展开导航树中的 Status Summary 文件夹。


	
选择 Cartridge Table。





另请参见

	
使用 Reports 实用程序查看磁带库和设备报告









导入或导出诊断磁带或清洗磁带




	
注意:

磁带库会将已使用的清洗磁带视为新磁带。为了避免设备损坏，请勿重新导入已使用的清洗磁带。








磁带库将诊断磁带和清洗磁带存储在保留的系统插槽中。主机磁带库应用程序无法访问这些磁带。磁带库一次只能执行一个诊断磁带或清洗磁带的导入或导出操作。在整个操作过程中，磁带库控制器都会保留 CAP。

在导入之前，验证所有磁带是否都具有正确的标签。诊断磁带必须具有 DG 作为八个字符卷 ID 的前两个字符。清洗磁带必须具有 CLN 作为前三个字符。



导入诊断磁带或清洗磁带




	
注:

从 SL8500 固件 FRS_7.00 和 SLC 5.50 开始，必须由主机应用程序（如 ACSLS 或 ELS）管理磁带机清洗。对于主机管理的清洗，请勿使用以下过程。而应使用主机软件装入清洗磁带。







	
验证磁带库是否具有足够的空系统插槽。机械手恢复和磁带库初始化要求磁带库的每个侧面上有一个空系统插槽。


	
验证 CAP 是否为空、未被主机保留、已关闭且已锁定（请参见查看设备状态和属性）。


	
在 SLC 中，选择 Tools > Diagnostics。


	
展开设备树中的 CAP 文件夹。选择要使用的 CAP。


	
单击 Import/Export 选项卡。


	
在 "Operation" 部分中，选择 Import Cleaning/Diagnostic cartridges。


	
在 "Select favored rail for import" 列表中，选择首选的存储滑轨或 No affinity。




	
注:

磁带库会将诊断磁带和清洗磁带装入所选滑轨上的系统插槽内（如果有可用空间）。否则，磁带库会在所有系统插槽之间分配磁带。









	
单击 Start。


	
将磁带装入 CAP（请参见使用 CAP 装入磁带）。









导出诊断磁带或清洗磁带

	
验证磁带库是否具有足够的空系统插槽。机械手恢复和磁带库初始化要求磁带库的每个侧面上有一个空系统插槽。


	
验证 CAP 是否为空、未被主机保留、已关闭且已锁定（请参见查看设备状态和属性）。


	
在 SLC 中，选择 Tools > Diagnostics。


	
展开设备树中的 CAP 文件夹。选择要使用的 CAP。


	
单击 Import/Export 选项卡。


	
选择导出操作的类型。


	
单击 Start。


	
当显示卸载通知时，卸载 CAP（请参见使用 CAP 弹出磁带）。











磁带类型

	
数据磁带－存储客户数据


	
诊断磁带－供服务代表用来对磁带机运行读/写测试（请参见导入或导出诊断磁带或清洗磁带）


	
清洗磁带－清洗磁带路径和磁带机的读取/写入磁头（请参见配置磁带机清洗）






磁带标签

有关介质标签标准的信息，请参见 OTN 上的《Barcode Label Technical Brief》。所有磁带库磁带都必须有可读的外部标签。机械手遇到不可读的标签时，将报告错误。

不支持无标签的磁带。磁带库将通过 CAP 导出找到的所有无标签磁带。无标签磁带或未知类型的磁带不会挂载到磁带机。








处理磁带




	
注意:

如果磁带处理不当，可能会发生数据丢失或磁带库组件受损的情况。








	
保持磁带清洁并在每次使用之前检查其是否损坏。


	
绝不打开卡盒。


	
不要在无卡盒的情况下处理磁带。


	
不要将磁带或卡盒直接暴露在阳光下、潮湿环境或磁场中。






检查磁带

在任何情况下，在将磁带插入磁带机或磁带库之前，请始终对其进行检查。有缺陷的或脏的磁带可能会损坏磁带机。绝不使用损坏的磁带。查看是否存在以下情况：

	
污垢或碎屑


	
外壳破裂


	
写保护开关损坏


	
磁带中有液体


	
标签粘贴不牢固，或者超出了磁带边缘









清洁卡盒表面

使用不起毛的布擦除卡盒上的所有灰尘、污垢和水分。使用 Oracle StorageTek 磁带清洁擦巾清洁卡盒。这些擦巾浸有异丙醇。不要让任何溶液触及磁带或进入卡盒内部。




	
注意:

可能会损坏卡盒。不要使用丙酮、三氯乙烷、甲苯、二甲苯、苯、酮、丁酮、二氯甲烷、氯乙烷、酯、乙酸乙酯或类似的化学品来清除标签或清洁卡盒。












存放磁带

将磁带存放在清洁的环境中。在准备好使用磁带之前，不要将磁带从其保护包装中拿出。使用撕扯线（而不是尖锐工具）拆除包装。在使用磁带之前，请确保磁带在其工作环境中至少放置了 24 小时。








通过调整磁带放置最大限度地提高磁带库性能

	
将同一滑轨上的磁带和兼容磁带机组合在一起。将磁带挂载到位于同一滑轨上的磁带机并限制磁带必须移动的距离。最大程度地减少磁带库中滑轨之间的升降装置操作以及磁带库之间的直通操作。


	
确保每个滑轨具有足够的空插槽、数据磁带数量、擦写磁带数量和磁带机数量，可以支持峰值用量。


	
将非活动磁带移出磁带库。将不常使用的磁带移至离磁带机较远的位置，并将较为常用的磁带移至离磁带机较近的位置。


	
装入与磁带所在滑轨相邻的磁带盒。


	
使用磁带库内容管理器 (Library Content Manager, LCM) 自动管理 z/OS 客户的可用插槽。


	
使用主机管理软件（ACSLS 和 HSC）所提供的浮动选项。


	
将需要经常装入和弹出的磁带放到邻近 CAP 的滑轨上。在具有旋转 CAP 的磁带库中，将非活动磁带放到顶部滑轨上。














9 验证介质

要使用介质验证 (media validation, MV) 功能验证 T10000 磁带的完整性，必须定义 T10000C 或 D 磁带机池。该池不被视为分区，也不包含磁带，主机无法访问该池中的磁带机。




	
注:

磁带库会自动清洗 MV 磁带机，而不管磁带库的自动清洗状态为何。Oracle 服务代表应确保磁带库中有清洗磁带。







	
介质验证要求


	
定义介质验证池


	
启动或恢复介质验证


	
停止验证


	
在修改 MV 池之后更新主机信息






介质验证要求

	
最低 SL8500 固件 FRS_8.31 和 SLC FRS_6.25


	
指定的 T10000C 或 T10000D 磁带机池（TTI 5.40 级或更高）


	
高内存 HBT 卡


	
最低 STA 2.0 以自动执行介质验证（可选）









定义介质验证池




	
注:

主机无法访问介质验证池中的磁带机。








	
对于复合磁带库，您可以登录到复合磁带库中的任何磁带库以修改 MV 池。确认复合磁带库中的所有磁带库均联机。


	
确认主机未使用您要添加到池的磁带机。


	
在 SLC 中，选择 Tools > Media Validation。单击 Slot Selection 选项卡。


	
单击 Refresh 以显示最新配置。


	
将最多 10 个磁带机放置在池中。突出显示磁带机插槽，然后单击 Add 或 Remove。




	
注:

将磁带机添加到 MV 池中时，磁带库（或受影响的分区）将脱机。








	
单击 Apply。


	
如果使用分区磁带库，则将已从池中移除的所有磁带机插槽重新分配给某个分区（请参见对磁带库进行分区）。


	
重新配置主机应用程序（请参见在修改 MV 池之后更新主机信息）。





介质验证磁带机池图标


	SLC 磁带机图标	含义

	[image: 磁带机插槽为空图标。]	磁带机插槽为空

	[image: 托架中的磁带机无效图标。]	插槽包含无效的磁带机类型或磁带机类型正确但处于无效状态

	[image: 托架中具有对于介质验证有效的磁带机图标。]	磁带机类型（T10000C 或 T10000D）正确并处于有效状态
	[image: 分区数图标。]	磁带机插槽的分区数

	[image: 磁带机位于介质验证池中图标。]	磁带机插槽位于介质验证池中











启动或恢复介质验证

每个 SLC 会话，一次只能验证一个磁带。要自动执行该过程，请使用 StorageTek Tape Analytics 2.0 或更高版本（请参阅 STA 文档）。

	
登录到磁带库。对于复合磁带库，登录到包含要用于验证的磁带机的磁带库。


	
在 SLC 中，选择 Tools > Media Validation。单击 Media Validation 选项卡。


	
选择一个磁带机。如果没有列出任何磁带机，请参见定义介质验证池。




	
注:

如果无法选择某个磁带机，则该磁带机可能类型错误或处于无效的状态。









	
从列表中选择一个磁带或在磁带标签字段中输入一个 VOLSER。


	
选择验证类型（有关说明，请参见验证类型）。




	
注:

选择 Complete Resume 或 Complete Plus Resume 以从上次停止位置恢复完整的验证。








	
单击 Start。如果磁带装入成功，则会开始验证。

验证完成后，磁带返回到其源位置。如果源位置丢失，磁带库则将磁带移至系统插槽以进行主机恢复。





验证类型


	验证类型
	说明
	开始位置
	每个磁带的近似持续时间

	Basic Verify	挂载并卸载，以确定 MIR 是否不可读或不同步	不适用
	2 分钟
	Standard Verify	读取：
－1000 个记录，从磁带的开头开始

－包含 EOD 的包装，然后读取 EOD

－顶部和底部带上的最外层包装，以验证边缘

	磁带开头
	最多 30 分钟
	Rebuild MIR	以磁带速度读取数据
	MIR 中的无效位置	T10000C－5 个小时
T10000D－9 小时


	Complete BOT	以磁带速度读取数据
	磁带开头
	T10000C－6 个小时
T10000D－最多 9 小时


	Complete Plus BOT脚注 1 	检查数据完整性验证 CRC，以确定它是否存在	磁带开头
	T10000C－压缩率低于 2.5:1 时 6 小时。
T10000D－压缩率低于 3:1 时 9 小时








脚注 1 需要解压缩和 Oracle Key Manager。






停止验证

如果主机请求当前正在验证的磁带，验证将停止。还可以使用 SLC 停止验证。

	
以启动验证的用户身份登录。


	
在 SLC 中，选择 Tools > Media Validation。


	
选择 Media Validation 选项卡。


	
单击 Stop。

一旦验证停止，磁带将返回到其源位置。如果源位置丢失，磁带库则将磁带移至系统插槽以进行主机恢复。









在修改 MV 池之后更新主机信息

	
对于 ACSLS，必须在修改 MV 池之后启动重新配置。使用 config drives <panel_id> 实用程序。有关更多信息，请参见《ACSLS Administrator's Guide》。


	
对于 ELS，在修改 MV 池之后无需任何操作。ELS 主机自动进行重新配置。





修改 MV 池对 HLI 主机的影响

将磁带机添加到 MV 池中之后，磁带库（或受影响的分区）将脱机。受影响的主机会依次从磁带库收到 "Configuration Changed"、"LSM Ready" 和 "Not Ready" 消息。ELS 会自动从其配置中删除已移动到 MV 池中的磁带机。ACSLS 会自动将已移动到 MV 池中的磁带机更新为脱机状态，但 ACSLS 要求启动重新配置。

在从 MV 池中移除磁带机之后，磁带库和分区仍保持联机。对于未分区的磁带库，磁带机插槽立即可供主机使用。ELS 主机开始重新配置，但 ACSLS 主机要求启动重新配置。对于分区磁带库，必须将已从 MV 池中移除的磁带机插槽分配给某个分区（请参见对磁带库进行分区）。








10 审计磁带库

审计验证磁带位置并更新磁带库数据库，该数据库包含卷 ID、当前位置以及每个磁带的验证状态。

在检修门关闭或磁带库初始化之后，磁带库自动执行审计。




	
注:

从 SLC 启动审计仅更新磁带库数据库。要更新主机数据库，必须从主机启动审计。







	
对整个磁带库执行物理审计


	
对某个单元范围执行物理审计


	
对某个单元范围执行验证审计


	
审计指示器的含义





另请参见

	
查看磁带信息






对整个磁带库执行物理审计




	
注:

物理审计一旦开始就不能停止。








对于整个磁带库审计，机械手将访问所有插槽（存储、CAP、磁带机、保留），更新磁带数据库，并将磁带位置的 "verified" 状态更改为 true。

请勿在峰值活动期间运行此审计（请参见下文中的对整个磁带库执行审计的影响）。对于每个磁带插槽，审计需要大约 0.5 秒的时间。

	
在 SLC 中，选择 Tools > Diagnostics。


	
选择设备树中的 Library。


	
单击 Audit 选项卡。


	
对于整个磁带库，选择 Yes（对于物理审计和验证审计，选择 No）。


	
单击 Audit。





对整个磁带库执行审计的影响

虽然整个磁带库审计是后台进程，并且不会中断磁带库操作，但它需要共享机械手资源。您可能会发现，在审计完成之前，执行磁带库操作所需的时间比平时略长。在处理需要尚未审计位置的相关信息的请求时可能有一点延迟，因为磁带库在处理请求之前将审计该位置。






对某个单元范围执行物理审计




	
注:

物理审计一旦开始就不能停止。








	
在 SLC 中，选择 Tools > Diagnostics。


	
选择设备树中的 Library。


	
单击 Audit 选项卡。


	
对于物理审计，选择 Yes（对于整个磁带库和验证审计，选择 No）。


	
从下拉列表中，为审计的开始位置和结束位置选择内部地址。


	
单击 Audit。









对某个单元范围执行验证审计

验证审计将验证磁带数据库中特定磁带位置或特定位置范围的状态。如果某个磁带地址的验证状态为 false，则将针对该位置执行物理审计，并更新磁带数据库。

	
在 SLC 中，选择 Tools > Diagnostics。


	
选择设备树中的 Library。


	
单击 Audit 选项卡。


	
对于验证审计，选择 Yes（对于整个磁带库和物理审计，选择 No）。


	
从下拉列表中，为审计的开始位置和结束位置选择内部地址。


	
单击 Audit。









审计指示器的含义

为了指示正在进行审计，SLC 会显示一个旋转指示器，并显示消息 "Audit in progress"。如果看到此指示器，请不要打开磁带库检修门。否则将导致重新启动审计。

只有在自动启动审计（磁带库检修门被打开又关闭，磁带库打开电源或重新引导）时，才会显示审计指示器。如果通过 SLC 或主机启动审计，则不会显示该指示器。








11 查看磁带库和设备信息

SLC 仅显示已保存至磁带库控制器数据库中的最新磁带库和设备信息。单击 Refresh 可使用最新的配置数据更新 SLC。

	
查看磁带库运行状态


	
查看磁带库属性和配置


	
查看设备状态和属性


	
查看本地操作面板类型


	
SLC 中磁带库和设备状态指示器的含义





另请参见

	
生成报告和日志


	
查看磁带信息






查看磁带库运行状态

	
在 SLC 中，选择 Tools > System Detail。选择设备树中的 Library。


	
单击 Status 选项卡。


	
选择次级选项卡：

	
General－显示磁带库的当前运行状态。只要发生主机活动、后台操作或操作员活动，就会更新这些值。可以使用该选项卡使磁带库联机或脱机（请参见使磁带库脱机和使磁带库联机）。


	
Complex－显示复合磁带库的当前运行状态。


	
Status Module－显示磁带库状态警报。仅当在磁带库中有活动服务时，才可以使用此功能。另请参见清除磁带库状态警报。


	
HLI－显示磁带库上所有 HLI 接口端口的当前状态。这些信息包括本地 TCP/IP 套接字、本地 IP、连接状态、端口状态以及连接后发送和接收的信息。


	
Internal Networks－显示端口状态。












查看磁带库属性和配置

	
在 SLC 中，选择 Tools > System Detail。选择设备树中的 Library。


	
单击 Properties 选项卡。


	
选择次级选项卡：

	
General－显示磁带库的物理、机械、逻辑和网络配置。


	
Complex－显示复合磁带库的 IP 地址信息。


	
Library Controller－显示磁带库控制器的详细信息，包括序列号和固件版本。


	
Drive Controller－显示磁带机控制器的详细信息，包括序列号和当前固件版本。












查看设备状态和属性

可以查看有关 CAP、磁带机、机械手、冗余电子设备、电源和安全门的信息。还可以使用 SLC Reports 实用程序查看设备信息（请参见使用 Reports 实用程序查看磁带库和设备报告）。

	
在 SLC 中，选择 Tools > System Detail。


	
在设备树中选择设备文件夹。


	
有关状态和属性的信息，请展开设备文件夹。选择一个设备。


	
选择一个选项卡。根据所选择的设备，参阅下面相应的信息。




	
注:

对于批量 CAP 磁带库，选择 CAP 文件夹并单击 Status，以便一次查看所有 CAP 及批量 CAP 装入/弹出消息（请参见修改批量 CAP 消息）。











设备的 "Status" 和 "Properties" 选项卡

	
Status 选项卡－显示设备的当前运行状态


	
Properties 选项卡－显示设备配置信息，包括序列号和当前固件级别





磁带机选项卡

仅磁带机具有以下系统详细信息选项卡。

	
"Display" 选项卡－显示网络数据、T10000 和 T9840D 磁带机的虚拟操作面板 (Virtual Operator Panel, VOP) 以及磁带机 LED 指示灯状态


	
"Drive Tray" 选项卡－显示磁带机托盘的当前状态





	磁带机状态
	含义

	Empty	磁带机上没有挂载磁带。

	Unloaded	磁带已准备好进行卸载。

	Ready	已装入磁带。

	NotCommunicating	控制器卡无法与磁带机通信。

	rewindUnload	磁带机正忙于重绕和卸载。








冗余电子设备卡状态

"A" 指示左边的卡插槽，"B" 指示右边的卡插槽（从磁带库后面往前看）。

	
hbca：磁带库控制器，A（左侧）插槽


	
hbcb：磁带库控制器，B（右侧）插槽


	
hbta：磁带机控制器，A（左侧）插槽


	
hbtb：磁带机控制器，B（右侧）插槽




	

	卡状态
	含义

	Duplex: Software ready, switch possible	活动磁带库控制器正常运行。

	Not installed	未在磁带库中安装卡。

	Ok	活动或备用磁带机控制器卡正常运行。

	Pre-standby: software not ready	备用磁带库控制器卡正在装入备用代码，不能用于自动故障转移或手动切换。

	Standby: software ready	备用磁带库控制器卡正常运行，可用于自动故障转移或手动切换。














查看本地操作面板类型

	
在 SLC 中，选择 Tools > Diagnostics。


	
选择设备树中的 Library，然后单击 OpPanel 选项卡。

类型在屏幕底部列出。W 指示基于 Windows，DL 或 OL 指示基于 Linux。









SLC 中磁带库和设备状态指示器的含义


	SLC 图标	含义

	[image: 带白色对勾标记的绿色圆圈。]
	正常

	[image: 带惊叹号的黄色警告三角]
	警告

	[image: 红色停止标志。]
	错误








设备的运行状态

"System Details and the Diagnostics" 实用程序的设备树显示设备运行状态。

	
正常－磁带库设备正常运行


	
警告－设备已脱机或在降级状态下运行


	
错误－设备发生故障





通信状态

所有 SLC 屏幕的左下角均显示通信状态，通信状态指示 SLC 和磁带库控制器之间的通信状态。

	
正常－SLC 与磁带库控制器正常通信


	
警告－服务器响应时间超过 10 秒


	
错误－服务器响应时间超过 30 秒




在与磁带库控制器中断通信 30–60 秒后，心跳监视器变为灰色，再转为红色，并显示以下消息：


Heartbeat message not received from the library controller.


从 SLC 注销，然后再次登录以恢复通信。


磁带库的运行状态

所有 SLC 屏幕的右下角均显示磁带库运行状态。

	
正常－所有磁带库设备均正常运行


	
警告－一台或多台磁带库设备已脱机或在降级状态下运行


	
错误－一台或多台磁带库发生故障

修复设备错误之后，磁带库运行状态指示器将变为 "Warning"。在将磁带库脱机之前，指示器不会变为 "Normal"。如果某个设备或状态警报状况存在多个问题，则运行状态指示器显示最严重的状况。











12 生成报告和日志

	
使用 Reports 实用程序查看磁带库和设备报告


	
生成活动容量报告


	
生成分区报告（仅单个磁带库）


	
为 Oracle 技术支持生成诊断文件


	
监视磁带库事件





另请参见

	
查看磁带库和设备信息


	
查看磁带信息






使用 Reports 实用程序查看磁带库和设备报告

所有报告输出都是静态展示报告生成时的信息。单击右上角的 Update 可刷新信息。




	
注:

在同一个工作站上运行多个 SLC 实例可能导致报告上的数据不一致。建议一次只由一个用户生成 SLC 报告。







	
在 SLC 中，选择 Tools > Reports。


	
在导航树中，展开报告文件夹。选择一个报告。

您可以从 Partitions 实用程序或 Active Capacity 实用程序访问其他报告。您可以使用 System Details 实用程序查看单个设备的信息。


表 12-1 SLC 报告

	文件夹
	报告
	说明

	
Statistics

	
Drive Events

	
显示磁带机事件和错误。此报告最多可显示 70 个条目。


	
Drive Media Events

	
显示磁带机发生的磁带错误事件。此报告最多可显示 500 个条目。


	
General Events

	
显示磁带库运行事件摘要。



	
Media Events

	
显示磁带错误。此报告最多可显示 2000 个条目。


	
Log

	
EventLog

	
根据严重程度显示事件日志（请参见 Severity）。


	
Status Summary

	
Cartridge Table

	
列出磁带位置、介质类型、标签和状态信息。



	
Device Reserve Table

	
列出升降装置、机械手和 PTP 保留信息。


	
Drive Table

	
列出磁带机位置、类型和序列号信息。



	
CAP Summary

	
列出 CAP 的位置。


	
Cartridge Summary

	
列出磁带库中所有磁带的位置、介质类型和标签信息。



	
Drive Summary

	
列出磁带机位置、类型、序列号、代码信息和设备详细信息。



	
Library Information

	
列出磁带库物理配置、代码版本和磁带库的状态。



	
Robot Summary

	
列出机械手地址和状态。



	
Status Detail

	
CAP/Drive/Robot Details

	
列出标识信息、代码版本和设备状态。



	
Library Details

	
列出磁带库物理配置、代码版本和磁带库的状态。



	
Versions

	
Hardware Versions

	
列出控制器卡、CAP、机械手和 PTP 的 FRU 序列号。


	
Software Versions

	
列出控制器卡、CAP、升降装置、机械手和 PTP 的代码版本。


	
Audit Log

	
Feature Audit Log

	
列出磁带库生命周期中的所有功能激活活动。要仅查看当前硬件激活文件，请参见显示当前的硬件激活文件。



	
CAP Usage Messages

	
Messages

	
列出 CAP 使用情况消息。要定义消息，请参见修改批量 CAP 消息















生成活动容量报告

	
在 SLC 中，选择 Tools > Select Active Cells > View Reports 选项卡。


	
选择报告：

	
Cartridge and Cell Media Summary－显示活动容量区域中介质的插槽地址和卷序列号 (volser)


	
Orphaned Cartridge Report－显示一个包含所有孤立磁带的详细列表












生成分区报告（仅单个磁带库）

	
在 SLC 中，选择 Tools > Partitions > Reports 选项卡。


	
从菜单中选择一种报告类型：

	
Cartridge Cell and Media Summary－显示每个分区中介质的插槽地址和卷序列号 (volser)


	
Orphaned Cartridge Report－显示孤立磁带的插槽地址和卷序列号 (volser)


	
Partition Summary－显示分配到每个分区的资源


	
Partition Details－显示特定分区 ID 的详细信息












为 Oracle 技术支持生成诊断文件

Oracle 技术支持代表可能要求您捕获并传输管理信息库 (Management Information Base, MIB) 或日志快照文件。



生成磁带库 SNMP MIB 文件

	
在 SLC 中，选择 Tools > Diagnostics。


	
单击导航树中的 Library 文件夹。


	
单击 Transfer File 选项卡。


	
选择 SNMP MIB。单击 Transfer File。


	
使用 .txt 后缀保存文件。


	
将文件通过电子邮件发送给 Oracle 技术支持代表。









生成磁带库日志快照文件

必须在日志生成后 15 分钟内保存日志。该文件已加密。

	
在 SLC 中，选择 Tools > Diagnostics。


	
单击导航树中的 Library 文件夹。


	
单击 Transfer File 选项卡。


	
选择 Log Snapshot。


	
选择 All Devices 或 Selected Device。如果选择 "Selected Device"，则选择相应设备。


	
单击 Generate Log Snapshot On Library。


	
单击 Yes，然后单击 OK。


	
单击 Transfer Log Snapshot To Your Computer。


	
使用自动生成的名称保存文件。


	
将文件通过电子邮件发送给 Oracle 技术支持代表。











监视磁带库事件

磁带库控制器会持续监视磁带库操作并记录所有事件。使用 SLC 的 Monitors 实用程序，可以打开事件监视器以显示事件数据或将其假脱机到文件中。事件监视器是根源分析的有用工具。

	
事件监视器类型


	
启动事件监视器


	
将事件监视器数据保存到文件中


	
显示结果代码定义






启动事件监视器

	
在 SLC 中，选择 Tools > Monitors。


	
展开导航树中的 Permanent Monitors 文件夹。


	
单击一个事件监视器类型（请参见事件监视器类型）。单击 Open。


	
使用 Monitor 菜单暂停、恢复、永久停止或清除事件监视器。使用 "Spool File" 菜单将事件监视器保存到文件中（请参见将事件监视器数据保存到文件中）。







	
注:

要在一个屏幕中排列多个事件监视器，请使用右上角的 Window 菜单。












将事件监视器数据保存到文件中

可能需要将该文件发送至 Oracle 技术支持代表以帮助诊断问题。

	
打开事件监视器（请参见启动事件监视器）。


	
在事件监视器窗口中，选择 Spool File > Start Spooling。


	
浏览到所需目录，输入文件名，然后单击 Save。


	
要停止假脱机，请选择 Monitor > Stop Spooling。









显示结果代码定义

结果代码标识磁带库事件类型（结果代码与磁带库 EventId 相同）。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 Search 选项卡。


	
在 "Search Type" 列表中，选择 Result Code。


	
要搜索特定的结果代码，请输入完整的代码（通配符或部分代码无效）。

要列出所有结果代码，请选择 List All。


	
单击 Search。









事件监视器类型

有四种事件监视器类型：All、Error Warn Info、Error and Warnings 和 Errors。每种监视器类型根据事件的严重程度记录事件。例如，Errors 监视器仅记录错误事件（有关事件类型的说明，请参见 Severity）。

事件监视器中记录的每个事件包含以下信息：

	Time
	
标识事件发生的时间。


	Device ID
	
标识与事件对应的设备的磁带库地址。


	User
	
标识生成事件的用户。对于 HLI 或 SCSI 主机活动，这是 "root"。


	I / F
	
标识请求者的接口类型。接口可以是 hli、scsi 或 default（对于 SLC 或 CLI 请求）。


	Activity
	
标识发出的命令，如 "load drive"。


	Request Identifier
	
标识所有主机接口请求。帮助跟踪每个主机请求产生的日志活动的序列。


	
	Severity
	
标识事件的重要性。某些事件数据是非易失性的，即该数据在系统关开机循环期间仍会存在。

Error－非易失性数据，指示可阻止请求（主机或诊断）成功完成的故障。

Warning－非易失性数据，指示未停止磁带库完成请求（主机或诊断）的功能的故障。警告可标识性能损失或可能指示将来不可恢复的错误的情况。

Information－易失性数据，指示常规设备或磁带库信息（如设备状态、添加的设备、注册的侦听器、更新的托盘序列号等）。该信息对于建立警告或错误事件的活动历史记录很重要。

Trace－易失性数据，指示诊断活动跟踪。


	Result Code
	
标识磁带库事件类型（结果代码与磁带库 EventId 相同）。要使用 SLC 搜索 Result Code 的含义，请参见显示结果代码定义或参阅磁带库固件代码软件包中包含的 SL8500_FRSxxx_JavaErrorCodes.html 文件。


	Result Text
	
提供有关请求或事件的结果的信息。













13 更改联机/脱机状态和重新引导

	
使磁带库脱机


	
使磁带库联机


	
使设备脱机


	
使设备联机


	
重新引导磁带库


	
重新引导本地操作面板


	
重新引导升降装置


	
重新引导机械手






使磁带库脱机




	
注:

在使用 SLC 之前，始终尝试使用 ACSLS 或 ELS 软件使磁带库脱机。







	
使所有磁带库磁带机脱机（请参见使设备脱机）。


	
在 SLC 中，选择 Tools > System Detail。


	
选择设备树中的 Library。


	
单击 Status 选项卡，然后单击 General 选项卡。


	
在 "Transition Request" 字段中，单击 Take offline。


	
单击 Apply。磁带库进入脱机状态之前，系统将完成所有未完成的磁带库作业。


	
等待脱机确认消息。如果磁带库未脱机，则检查磁带库的状态（请参见查看磁带库运行状态）。





何时将磁带库置于脱机状态：

	
关闭磁带库电源之前


	
打开磁带库检修门之前


	
磁带库不工作并且需要维修时









使磁带库联机




	
注:

在使用 SLC 之前，始终尝试使用 ACSLS 或 ELS 软件使磁带库联机。







	
在 SLC 中，选择 Tools > System Detail。


	
单击设备树中的 Library。


	
单击 Status 选项卡，然后单击 General 选项卡。


	
在 "Transition Request" 字段中，单击 Bring online。


	
单击 Apply。


	
如果适用，使磁带库在 ACSLS 和 ELS 主机上联机（请参见主机软件文档）。









使设备脱机




	
注:

在使用 SLC 之前，始终尝试使用 ACSLS 或 ELS 磁带管理软件使设备脱机。







	
在 SLC 中，选择 Tools > System Detail。


	
展开设备文件夹（CAP、机械手或磁带机）。选择要修改的设备。


	
单击 Status 选项卡。


	
在 "Transition Request" 列表中，选择 Take offline。在使设备脱机之前，系统会完成设备所有未完成的作业

机械手脱机时，它将移到滑轨的末端，磁带库无法使用它。如果磁带库正在使用冗余机械手功能，则第二个机械手将接手所有请求。


	
单击 Apply。









使设备联机




	
注:

处于错误状态的脱机磁带库设备无法联机。必须先更正错误状态。








	
在 SLC 中，选择 Tools > System Detail。


	
展开 CAP 文件夹。选择要修改的 CAP。


	
单击 Status 选项卡。


	
在 "Transition Request" 列表中，选择 "Bring Online"。


	
单击 Apply。









重新引导磁带库

重新引导磁带库需要从闪存中重新装入固件并重新启动磁带库控制器。

	
在 SLC 中，选择 Tools > Diagnostics。


	
单击导航树中的 Library 文件夹。


	
单击 Reboot。


	
其他所有用户必须注销。单击 OK。


	
如果磁带库联机，单击 OK 使磁带库脱机。


	
单击 OK 重新引导磁带库。


	
单击 OK 终止此 SLC 会话。请在磁带库完全初始化后再重新登录到 SLC。









重新引导本地操作面板

如果本地操作面板挂起或帮助内容不可见，则可能需要重新引导本地操作面板。可以在本地操作面板或从远程 SLC 会话重新引导。

	
在 SLC 中，选择 Tools > Diagnostics。


	
选择设备树中的 Library，然后单击 OpPanel 选项卡。


	
单击 Reboot Operator Panel 按钮。


	
如果从本地操作面板重新引导，则屏幕将变为空白。当操作面板重新联机时，重新引导完成。

如果从远程 SLC 会话重新引导，则 "Reboot Complete" 指示本地操作面板重新引导已完成。









重新引导升降装置

	
选择 Tools > Diagnostics。


	
展开 Elevator 文件夹，然后选择升降装置。


	
单击 Reboot。


	
单击 OK 以重新引导升降装置。









重新引导机械手

	
选择 Tools > Diagnostics。


	
展开 Robot 文件夹，然后选择机械手。


	
单击 Reboot。


	
单击 OK 以重新引导机械手。











14 故障排除

	
基本故障排除


	
运行磁带库自检


	
运行设备自检


	
诊断机械手问题


	
确定控制器卡的状态


	
清除磁带库状态警报


	
使用 SLC 启动手动 RE 切换


	
校准触摸屏


	
排除主机连接问题





另请参见

	
更改联机/脱机状态和重新引导


	
为 Oracle 技术支持生成诊断文件


	
监视磁带库事件


	
维修磁带库






基本故障排除

在运行诊断测试或与 Oracle 技术支持联系之前，请查看以下故障排除提示。

	“需要维修”（琥珀色）LED 指示灯持续亮起
	
使用 SLC 检查磁带库以及连接的设备（磁带机、CAP 和机械手）的运行状况。请参见查看磁带库和设备信息。

要执行运行状况检查，请执行以下操作：

	
登录到 SLC。


	
访问 "System Detail" 模块，Tools > System Detail。


	
在导航树中检查以下指示器："Device Healthy" 或 "Device Error"




其他检查：

	
检查 "Status"（例如，联机/脱机）选项卡和 "Statistics"（例如，正常运行时间、停机时间、错误和警告）选项卡，以了解有关磁带库和设备运行状况的更多信息。


	
确保磁带已在其存储插槽中完全就位并且朝向正确。


	
对照 X 表检查是否存在任何外部物品或碎片，并将其移除（如果有）。





	“CAP 打开”LED 指示灯亮起并闪烁
	
打开 CAP 并确保磁带正确安放。关闭 CAP。


	SLC 不显示修改过的数据，即信息保持不变
	
检查 SLC 心跳图标。


	“机械手故障”或“磁带库故障”琥珀色 LED 指示灯持续亮起
	
	
检查 SLC 是否显示了任何错误消息。写下报告的错误消息。


	
打开前门。观察并记下磁带、机械手和磁带机的状态。


	
确保磁带已在其存储插槽中完全就位并且朝向正确。


	
确保已拆除包装材料。


	
检查磁带库基底是否存在任何物品或碎屑。如果存在，请将其清除。


	
检查磁带机的状态。


	
关闭前门。


	
在磁带机托盘背面推拉，确保磁带机已完全就位并向前锁定。如果托盘可以移动，则表明需要对其重新定位和锁定。





	客户机无法与磁带库或磁带机通信
	
确保电缆已安全连接到磁带库背面、磁带机和客户机上的相应连接器。


	磁带库无法与磁带机通信，SLC 上的磁带机状态显示 "Not communicating"
	
确保电缆已安全连接到磁带库背面、磁带机和客户机上的相应连接器。


	磁带机清洗或清洗消息重复或过多
	
	
将清洗磁带更换为新的清洗磁带。


	
运行磁带库自检，并注意是否报告了磁带机的错误。


	
运行任何基于客户机的磁带机诊断测试。












运行磁带库自检

使用磁带库自检帮助诊断问题。磁带库自检可以是非中断性的（磁带返回至其原始位置），也可以是中断性的（磁带可能放置在新位置）。




	
注:

执行中断性自检之前，磁带库必须脱机（请参见 使磁带库脱机）。







	
确保磁带库中有合适的磁带机诊断磁带（请参见导入或导出诊断磁带或清洗磁带）。


	
在 SLC 中，选择 Tools > Diagnostics，然后单击 Library 文件夹。


	
单击 SelfTest 选项卡。


	
在 "Mode" 列表中，选择自检类型：

	
Non-Disruptive－测试中使用的所有磁带均将返回到其原始位置


	
Disruptive－磁带可能会返回到新位置。磁带库必须与所有主机脱机，才能运行此自检。





	
单击 Run。测试完成时会显示测试结果。


	
对于中断性测试，将磁带库联机后可恢复正常操作。





自检期间磁带库检查的内容：

	
验证磁带库控制器、磁带机、升降装置以及机械手之间的通信路径。


	
执行获取和放置操作以检查机械手、升降装置和 CAP 的运行状况。其中包括从保留的系统插槽到随机的空存储插槽或 CAP 插槽的获取和放置操作。


	
执行全面的磁带库审计。


	
针对磁带库中安装的所有磁带机，执行诊断磁带的挂载和卸载。除非系统插槽中有诊断磁带，否则不会开始自检。如果系统找到了兼容的诊断磁带，则将针对每种磁带机类型重复自检。如果系统未找到用于某种磁带机类型的诊断磁带，则将跳过该磁带机的挂载/卸载操作。









运行设备自检

使用设备自检帮助诊断问题。可以对 CAP、机械手或磁带机执行自检。




	
注:

对批量 CAP 运行自检需要手动打开和关闭 CAP 门。








对所有 CAP 运行自检（仅限批量 CAP）

	
在 SLC 中，选择 Tools >Diagnostics，然后选择 CAP 文件夹。


	
在 "Mode" 列表中，选择 Non-Disruptive（中断性自检需要使磁带库与所有主机脱机）。


	
单击 Run。


	
根据指示打开并关闭 CAP 门。测试完成后会显示一条消息。





针对单个设备运行自检

	
在 SLC 中，选择 Tools >Diagnostics。


	
展开设备树中的设备文件夹（CAP、机械手、磁带机、PTP 或升降装置）。选择设备。




	
注:

要执行机械手自检，磁带库中必须有诊断磁带可用（请参见导入或导出诊断磁带或清洗磁带）。









	
在 "Mode" 列表中，选择 Non-Disruptive。


	
单击 Run。测试完成后会显示一条消息。









诊断机械手问题

诊断移动可以通过发出一系列“获取”和“放置”操作来帮助监视或诊断机械手问题。系统根据设置的最小和最大目标和池地址范围选择诊断移动的机械手。如果地址范围需要，可选择多个机械手。

成功的诊断移动不会重新排列磁带库中的磁带，系统会将磁带返回到其原始位置。但是，有些诊断移动失败可能会导致将盒式磁带留在新位置中。



定义诊断移动




	
注:

诊断移动要求共享机械手资源。活动高峰期间不应运行诊断移动。







可以设置多个诊断移动例程并同时运行这些例程，只要每个诊断移动的目标范围和池范围不重叠即可。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 DiagMove 选项卡，然后单击 Manage 选项卡。


	
在 "Defined Sequence" 部分中，单击 Add。


	
定义目标地址范围（用于“获取”操作的区域）。

	
选择插槽类型。


	
选择范围的开始位置和结束位置。





	
单击 Next。


	
定义源地址范围（用于在目标地址不包含磁带或无可用的空插槽时提供磁带或空插槽的区域）。

	
选择插槽类型。


	
选择开始位置和结束位置。





	
单击 Next。


	
为移动命名并指定移动数（介于 1 和 5000 之间）。


	
选择访问顺序和移动类型，并启用/禁用移动前的兼容性检查（有关详细信息，请参见下文）。


	
单击 Finish。新的诊断序列列在 "Defined Sequences" 部分中。请参见启动诊断移动。





诊断移动要定义以下项目：

	
Target Address Range－定义用于在诊断移动中执行“获取”操作的区域。有效的目标地址类型为存储插槽、CAP、磁带机和存储插槽、系统插槽或全部。




	
注:

目标地址范围中的所有资源都会保留。但是，只有当前机械手为获取/放置操作而访问的位置对主机不可用。








	
Pool Address Range－定义用于在目标地址不包含磁带或无空插槽可用时提供磁带或空插槽的区域。池和目标地址可以重叠。


	
Access Order－确定机械手在目标地址范围内执行“获取”操作的方式。有两个选项：

	
Sequential－机械手从目标地址范围中的第一个位置开始执行获取操作。机械手会继续按顺序访问该范围内的位置，直到完成请求的移动次数为止。


	
Random－机械手随机选择目标地址范围中的某个位置来获取磁带。机械手还可以多次访问目标地址范围内的同一地址获取磁带；但是，如果指定了足够的移动请求次数，则可保证机械手访问所有插槽。随机访问例程会在完成请求的移动次数之后结束。












启动诊断移动




	
注:

可以同时运行多个移动，只要用于移动的目标地址范围和池地址范围不重叠即可。








在开始诊断移动之前，必须定义移动（请参见定义诊断移动）。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 DiagMove 选项卡，然后单击 Manage 选项卡。


	
在 "Defined Sequences" 部分中，选择一个诊断移动。单击 Open。


	
选择 File > Start Sequence。








保存诊断移动

可以将定义的诊断移动保存到文件中，并使用该文件恢复已从磁带库中删除的移动或将其复制到其他磁带库。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 DiagMove 选项卡，然后单击 Manage 选项卡。


	
在 "Defined Sequence" 部分中，选择诊断移动，然后单击 SLC 屏幕顶部的 Save。








监视和控制打开的诊断移动

要启动诊断移动，请参见启动诊断移动。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 DiagMove 选项卡，然后单击 Monitor 选项卡。


	
每个监视器窗口均指示相应移动的状态：


	状态指示器
	有效值

	Spooling Status－指示是否正将移动输出保存到文件	True、False
	State－移动的执行状态	Running、pausing、paused、stopping、stopped
	Health－移动的运行状态	OK、warning、error
	Completed moves－已完成的移动数	数量







	
使用每个 Monitor 窗口中的 File 菜单可启动/停止/暂停序列、清除输出窗口或者启动/停止假脱机。











确定控制器卡的状态

控制器卡状态由卡上的 LED 指示灯进行指示并显示在 SLC 中（请参见查看设备状态和属性）。可以使用卡的状态解决磁带库的问题。

这些 LED 指示灯及其含义在两种卡类型（HBC 和 HBT）上是一样的。


	控制器卡 LED 指示灯	定义

	活动－绿色
	卡正在作为活动控制器运行并运行活动代码。

	备用－琥珀色
	卡正在作为备用控制器运行并运行备用代码。

	故障－红色
	卡遇到严重错误。

	弹出正常－蓝色
	技术支持代表可以安全地启动卡弹出。










清除磁带库状态警报

只能清除标记为 "Clearable" 的警报，并且只能在磁带库上有活动服务时清除。

清除警报只是将其从 Status Module 显示中删除，并没有从根源上解决问题。如果没有其他设备或状态警报，磁带库运行状态指示器将恢复 "Normal"。如果警报是定期更新引起的，则会在下一个更新周期重新出现。

	
在 SLC 中，选择 Tools > System Detail，并单击 Library 文件夹。


	
单击 Status 选项卡，然后单击 Status Module 选项卡。


	
在 "Clear Alert Number" 列表上，选择要清除的警报编号，然后单击 Apply。









使用 SLC 启动手动 RE 切换




	
注:

您还可以使用主机软件或 CLI 启动手动 RE 切换（请参见启动手动故障转移的方法）。







此过程在本地操作面板上不可用。

	
验证卡的设备状态是否指示 "switch is possible"（请参见查看设备状态和属性）。


	
在 SLC 中，选择 Tools > Diagnostics。


	
选择 Redundant Electronics 文件夹


	
单击 Apply 开始切换过程。如果备用磁带库和磁带机控制器卡有问题，则无法继续切换。


	
如果没有错误，请单击 Yes。


	
单击 OK 注销 SLC。


	
等待切换完成，然后重新登录到磁带库。必须指定新活动控制器的 IP 地址或 DNS 别名。









校准触摸屏

出厂之前会校准触摸屏。如果触摸屏未校准，则可以重新校准或重置触摸屏。校准触摸屏的方法具体取决于类型和版本（请参见查看本地操作面板类型）。

	
如果附带的是基于 Linux 的本地操作面板（DL 或 OL），则可以按照以下过程自行重新校准或将其重置为出厂设置。


	
如果附带的是基于 Windows 的本地操作面板 (W)，请与您的 Oracle 技术支持代表联系。






重新校准本地操作面板

	
如需精确校准，应确保触摸屏上没有碎屑。


	
登录到本地操作面板。选择 Tools > Calibrate。


	
单击 Calibrate。


	
将显示一系列目标。用手指或手写笔轻按每个目标的中心。


	
要保存新设置，请执行以下操作：

	
点按 Click Me 按钮。

如果按钮不下陷，则表明触摸屏未正确校准。放弃新设置（请参见步骤 6）。


	
单击 OK 以保存新设置。





	
要放弃新设置，请执行以下操作：

	
不点按 Click Me 按钮，让计时器过期。


	
返回步骤 3 并重新校准。




如果第二次校准不成功，本地操作面板将自动重新引导，恢复以前保存的校准。









将本地操作面板重置为出厂设置

	
登录到本地操作面板。


	
在 SLC 中，选择 Tools > Calibrate。


	
单击 Reset Calibration。本地操作面板将重新引导。











排除主机连接问题

	
使用探测器（一种用于跟踪磁带库网络通信的设备或程序）。


	
在连接到磁带库的交换机或路由器上显示端口统计信息。搜索任何错误。


	
通过磁带库管理软件运行跟踪以显示主机到磁带库的数据包和传输。


	
确认两台单独的主机没有争相管理同一个磁带库或分区。要查看当前主机连接，请参见查看磁带库运行状态。单击 HLI 选项卡。











15 维修磁带库

	
关闭磁带库


	
打开磁带库


	
在不关闭维修安全门的情况下进入磁带库


	
使用紧急情况机械手停止开关


	
手动挂载或卸载磁带


	
操作维修安全门





另请参见

	
故障排除






关闭磁带库




	
注意:

如果在关闭磁带库时未执行以下过程，则可能会面临设备损坏、磁带损坏或数据丢失的风险。








	
确保所有磁带库请求都已完成。


	
使磁带库和磁带机脱机。


	
通过使用 SLC 验证磁带机状态确保磁带机为空（请参见使用 Reports 实用程序查看磁带库和设备报告）。


	
打开磁带库后门。


	
在右下角找到配电设备 (power distribution unit, PDU)，然后将电源开关设置到 OFF 位置 (0)。如果磁带库有 2N 电源配置，请同时关闭两个 PDU。

有关 PDU 的更多信息，请参见《SL8500 概述和规划指南》。









打开磁带库

	
验证前检修门是否已关闭并锁上。




	
注:

如果您不想打开机械手、CAP 和升降装置，请让前检修门保持打开状态。








	
将电源开关设置到 ON 位置。

如果磁带库有 2N 电源配置，请同时打开两个 PDU。









在不关闭维修安全门的情况下进入磁带库




	
注:

如果打开检修门但不关闭安全门，所有磁带库操作都将停止。磁带库重新联机时，将执行完全审计。另请参见操作维修安全门。








	
遵循所有安全防范措施（请参见进入磁带库时的安全防范措施）。


	
使磁带库脱机（请参见使磁带库脱机）。


	
开锁并打开前检修门。将检修门锁定在打开状态并携带好钥匙


	
如有必要，将机械手移开，从底部滑轨开始。避免损坏机械手的机械或电子组件。机械手应自由移动。如果移动受限，不要对机械手施力。


	
在退出磁带库之前，确认磁带库中没有松动的项或人员。


	
关闭并闩上检修门。


	
锁上门并携带好钥匙。


	
使磁带库联机（请参见使磁带库联机）。






进入磁带库时的安全防范措施




	
警告:

为了防止检修门意外关闭，请将检修门锁定在打开状态并携带好钥匙。










	
确认磁带库已脱机。如果您怀疑机械手已联机，请不要进入磁带库或移动任何机械手。


	
不要试图覆盖磁带库中的任何电气安全设备或机械安全设备。


	
通知附近区域中的人员，您即将进入磁带库。


	
找到门的机械释放装置（检修门内侧的黄色手柄）。如果您在磁带库中时门关闭，则推动机械释放装置以开锁并打开门。


	
当位于磁带库内时，始终保持两扇前检修门处于打开状态。


	
了解磁带库的身体接触限制。小心不要使身体撞到阵列或使衣服挂住阵列（通道仅宽 0.4 米 [18 英寸]）。











使用紧急情况机械手停止开关

紧急情况机械手停止 (emergency robotics stop, EMS) 开关可断开机械手的所有供电。

万一在有人锁在磁带库中的情况下开始启动系统，则在机械手开始移动之前，灯光会闪烁 30 秒。这样将为磁带库外面的人员留出足够的时间来推动紧急情况机械手停止开关。


图 15-1 紧急情况机械手停止开关

[image: 周围的文本说明了 图 15-1 。]



	
紧急情况机械手停止 (Emergency Robotic Stop, ERS) 开关









手动挂载或卸载磁带

在手动挂载磁带之前，请参阅磁带机文档。




	
注意:

双手不要接触磁带机的机械和电子组件。








	
记录磁带库管理软件提供的卷 ID、磁带位置和磁带机插槽。


	
找到磁带机（使用 Reports 实用程序查看磁带库和设备报告）。


	
找到磁带（定位磁带）。


	
调整磁带的方向，使轮毂装置面朝下，并使 vol-id 标签朝向您。


	
将磁带推入磁带机。不要对磁带施力。如果在插入磁带时感觉到一些阻挡，请验证针对磁带机而言所插入的磁带类型是否正确。


	
要卸载磁带机，请按磁带机正面的 UNLOAD 开关。

如果磁带不弹出，请参阅磁带机文档。









操作维修安全门

您可以使用 SLC 监视安全门的状态（请参见查看设备状态和属性）。

安全门是一个滑动屏障，可临时关闭前门和升降装置组件背面之间的左侧或右侧区域。服务代表可以使用维护钥匙激活维修安全门。关上安全门时，服务代表可以打开前门，以便无需使磁带库脱机即可检修有故障的机械手。

如果关上了安全门，则磁带库可以继续处理主机请求。磁带库将针对靠近安全门或位于安全门后面的插槽的所有挂载请求排入队列，直到服务代表完成维修。关闭并锁上检修门后，维修安全门便会移至磁带库的中心。然后，机械手恢复其所有功能。


访问左侧维护区

在激活安全门之前，服务代表应使用 SLC 使左升降装置和左批量 CAP 脱机。在完成维护活动后，服务代表应使左升降装置和批量 CAP 重新联机。


访问右侧维护区

在激活安全门之前，服务代表应使用 SLC 使右升降装置以及旋转 CAP 或右批量 CAP 脱机。在完成维护活动后，服务代表应使 CAP 和右升降装置联机。








A 磁带库功能的软件和硬件要求


介质验证

	
高内存 HBT 卡

	
如果使用 RE，则两个 HBT 卡都应该为高内存卡





	
最低 FRS_8.31 和 SLC FRS_6.25


	
另请参见：介质验证要求





分区

	
最低 FRS_7.01 和 SLC 5.50（适用于单个磁带库分区）


	
最低 FRS_8.31 和 SLC 6.25（适用于复合磁带库分区）

	
ACSLS 8.3、HSC 6.2：PTF L1H16SG (VM)；ELS 7.0：PTF L1H15SI (MVS)；ELS 7.1：PTF L1H16SJ；ELS 7.2：集成








冗余电子设备

	
最低 FRS_6.00 和 SLC 版本 4.65


	
另请参见：冗余电子设备要求





启用 ADI 模式

	
高内存 HBT

	
如果使用 RE，则两个 HBT 卡都必须为高内存卡





	
最低 FRS_8.36





将富磁带机数据发送至 STA

	
运行 TTI 5.40+ 的 T10000 磁带机需要高内存 HBT 才能将所有数据发送至 STA。如果没有高内存 HBT，则磁带机可以正常运行，但是 STA 只能接收基本数据。









B 命令行界面参考

本附录介绍管理员用户可以使用的命令行界面 (Command Line Interface, CLI) 命令。由于 CLI 以固件为基础，因此可能并非所有命令都适用于您的磁带库。

管理员可访问的 CLI 命令包括：

	
audit


	
capCommand


	
cleaning


	
config


	
date


	
drive


	
hwActivation


	
mediaValidation


	
network


	
partition


	
reControl


	
snmp


	
ssh


	
time


	
traceRoute


	
version


	
whereAmi






audit

此命令对整个磁带库或部分磁带库执行物理审计。

	audit
	
显示 audit 命令的帮助，与 "help audit" 相同。


	audit *
	
启动整个磁带库的物理审计。此命令立即返回且不显示任何结果。

示例:


SL8500> audit *
   requestId
   requestId 9
   Done
   Failure Count 0
   Success Count 1
COMPLETED


	audit <device address> <address>
	
执行单个地址的物理审计并显示结果。

	
<device address>－指定要使用的机械手，格式为：磁带库、滑轨、列、侧面、行。


	
<address>－指定要审计的插槽位置，格式为：磁带库、滑轨、列、侧面、行。




示例:


SL8500> audit 1,4,0,1,0 1,4,-45,1,1
   requestId
   requestId 9
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
   Done
   Failure Count 0
   Success Count 1
COMPLETED


	audit <device address> <start address> <end address>
	
执行一系列地址的物理审计并显示结果。

	
<device address>－指定要使用的机械手，格式为：磁带库、滑轨、列、侧面、行。


	
<start address> <end address>－指定要审计的开始和结束插槽位置，格式为：磁带库、滑轨、列、侧面、行。开始和结束地址之间只有行是变量。




示例:


SL8500> audit 1,4,0,1,0 1,4,-45,1,1 1,4,-45,1,2
   requestId
   requestId 10
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
 
   Attributes Media Label EN34410R
   Object     Location    1,4,-45,1,2
   ...
   Done
   Failure Count 0
   Success Count 5
COMPLETED


	audit multiRowScan {enable | disable | print} <device address>
	
启用或禁用能够缩短审计时间的多行扫描审计功能。

	
print－打印多行扫描审计状态。


	
<device address>－指定要使用的机械手，格式为：磁带库、滑轨、列、侧面、行。




示例:


SL8500> audit multiRowScan print 1,1,0,1,0
   requestId
   requestId 8401
   Attributes Multi Row Scan enabled
   Object     Robot          1,1,0,1,0
   Done
   Failure Count 0
   Success Count 1
COMPLETED









capCommand

此命令用于管理 CAP。

	capCommand
	
显示 capCommand 命令的帮助，与 "help capCommand" 相同。


	capCommand <enable|disable> <device_address>
	
在滑轨上启用或禁用 CAP（仅适用于批量 CAP）。某些情况可能会阻止 CAP 被禁用，例如由主机保留。

	
<device address>－指定要释放的 CAP，格式为：磁带库、滑轨、列、侧面、行。





	capCommand forceUnreserve <device address>
	
强制释放 CAP。如果 CAP 中有磁带，保留将更改为 "default"。如果 CAP 中没有磁带，保留将更改为 "none"。

	
<device address>－指定要释放的 CAP，格式为：磁带库、滑轨、列、侧面、行。





	capCommand {lock | unlock} <device address>
	
锁定或解锁设备地址所指定的 CAP。

	
<device address>－指定要锁定/解锁的 CAP，格式为：磁带库、滑轨、列、侧面、行。












cleaning

这一系列命令显示并控制与磁带库内的清洗和诊断磁带相关的功能。只有具有介质验证功能的客户才能使用这些命令。

	cleaning
	
显示 cleaning 命令的帮助，与 "help cleaning" 相同。


	cleaning list cleaning
	
列出系统插槽中的所有清洗磁带。

示例：


SL8500> cleaning list cleaning
   requestId
   requestId 9001
   Attributes Expired  false
      Label            CLN0080U
      Location         1,1,-52,1,13
      Max Usage Count  100
      Media Type       9840_Cleaning
      Status           ok
      Usage Count      0
Object Cartridge       cleaning


	cleaning import <cap device address> [ to { 1 | 2 | 3 | 4 | * } ]
	
将清洗和诊断磁带导入到系统插槽。一次只能执行一个导入/导出操作。对于 SL8500 磁带库，必须至少有 9 个空系统插槽才能进行导入。

	
<cap device address>－指定要用于导入操作的 CAP，格式为：磁带库、滑轨、列、侧面、行。


	
to { 1 | 2 | 3 | 4 | * }－指定可能的情况下磁带要导入到的滑轨（可选）




示例：


SL8500> cleaning import 1,2,55,1,0 to 1
   requestId
   requestId 10101
   Message CAP open(ing). Place cartridges to import in CAP, then close CAP.Use CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 0
COMPLETED


	cleaning export <cap device address> cleaning select { 1 | 2 | 3 | 4 | expired }
	
导出选定的清洗磁带。一次只能执行一个导入/导出操作。

	
<cap device address>－指定要用于导出操作的 CAP，格式为：磁带库、滑轨、列、侧面、行。


	
select { 1 | 2 | 3 | 4 | expired }－指定从中导出清洗磁带的滑轨编号。




示例：


SL8500> cleaning export 1,2,55,2,0 cleaning select expired
   requestId
   requestId 9601
   Address      1.4.-52.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED


	cleaning export <cap device address> <cartridge address>
	
将特定的清洗或诊断磁带导出到指定 cap。一次只能执行一个导入/导出操作。

	
<cap device address>－指定要用于导出操作的 CAP，格式为：磁带库、滑轨、列、侧面、行。


	
<cartridge address>－指定要导出的磁带的位置，格式为：磁带库、滑轨、列、侧面、行。指定的磁带必须位于系统插槽中，而且必须是清洗磁带或诊断磁带。




示例:


SL8500> cleaning export 1,2,55,2,0 1,4,-52,1,12
   requestId
   requestId 9601
   Address      1.4.-52.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED


	cleaning threshold list
	
显示清洗磁带类型及其警告阈值的列表。每个清洗磁带类型都有 4 个属性：

	
Index－"cleaning threshold set" 命令所使用的清洗磁带类型


	
Media type－所用清洗磁带的类型


	
Maximum usage count－磁带制造商推荐的最大使用次数


	
Warning threshold value－用户定义的阈值，用于确定清洗磁带的使用计数一旦达到此阈值何时为其设置警告状况。




示例:


SL8500> cleaning threshold list
   requestId
   requestId 15001
   Attributes
   Object     Index               1
              Media Type          SgtUltrium1_Cleaning
              Recommend Max Usage 100
              Warning Threshold   0
   Attributes
   Object     Index               3
              Media Type          T10000_Cleaning
              Recommend Max Usage 50
              Warning Threshold   0


	cleaning threshold set <warning threshold value> <list index number>
	
为特定的清洗磁带类型设置警告阈值。

	
<warning threshold value>－可以是 1000 及以内的任何正整数。值为 0 表示无警告阈值。


	
<list index number>－在 "cleaning threshold list" 命令的列表中，索引编号指定的清洗磁带类型。




示例：


SL8500> cleaning threshold set 55 11
   requestId
   requestId 15101
   Attributes
   Object      Success true
   Done
COMPLETED


	cleaning driveWarning set { on | off }
	
将磁带机清洗警告标志设置为 on 或 off。

	
on－如果磁带机需要清洗，则将其运行状况设置为警告


	
off－即使磁带机需要清洗，其运行状况也不会受到影响












config

此命令将显示当前的物理磁带库配置或设置磁带库配置参数。

	config
	
显示 config 命令的帮助，与 "help config" 相同。


	config complexId set {1 - 127}
	
仅针对在其中执行了该命令的磁带库设置 SDP 所使用的 complexId。如果复合磁带库中存在多个磁带库，则必须为其中的每个磁带库单独设置 complexId。


	config complexId set {1 - 127} <library address>
	
为远程磁带库所使用的 SDP 设置 complexId。如果复合磁带库中存在多个磁带库，则必须为其中的每个磁带库单独设置 complexId。

	
<library address>－指定磁带库，格式为：磁带库、滑轨、列、侧面、行。例如：2, 0, 0, 0, 0。





	config complexId clear
	
清除磁带库的 complexId 编号。此命令将重新启动网络堆栈并导致 SDP ILC IP 地址停止响应。


	config complexId clear <library address>
	
清除远程磁带库的 complexId 编号。此命令将重新启动网络堆栈并导致 SDP ILC IP 地址停止响应。

	
<library address>－指定磁带库，格式为：磁带库、滑轨、列、侧面、行。例如：2, 0, 0, 0, 0。





	config complexId print
	
显示在其中执行了该命令的磁带库的当前 complexId。


	config ilc print
	
显示 ilc 状态。


	config ilc {enable | disable}
	
启用或禁用磁带库间通信 (Inter-Library Communications, ILC) LAN。如果已请求禁用，则必须首先使用 "accessState offline <device address>" 命令使磁带库脱机。


	config libraryId print
	
显示此磁带库的当前磁带库标识符。


	config libraryId set {1 - 32}
	
设置 libraryId，值从 1 到 32。磁带库必须脱机才能使用此命令。


	config print
	
显示当前的物理磁带库配置。


	config serviceInfo print
	
显示磁带库服务信息。


	config serviceInfo set
	
设置服务信息：contact 'contactName' phone 'phoneNumber' streetAddr 'streetAddress' city 'city' state 'state' country 'country' zip 'zipCode' description 'description data'。

目前，最大字符串长度为 31 个字符。每个字符串都必须由 ' '（单引号）分隔，以便能够使用空格和其他字符。

示例：


SL8500> config serviceInfo set city 'Denver' contact 'Andy' country 'USA' description 'Manager' phone '303 222-4444' state 'C0' streetAddr '1 tape drive' zip '80027'

requestId
requestId 1512402
Device serviceInfo
Success true
Done
Failure Count 0
Success Count 1
COMPLETED









date

此命令以格林尼治标准时间 (Greenwich Mean Time, GMT) 设置磁带库日期。

	date
	
显示 date 命令的帮助，与 "help date" 相同。


	date print
	
显示当前的系统日期。


	date <MM> / <DD> / <YYYY>
	
设置系统日期。在复合磁带库中，libraryId = 1 的磁带库为主磁带库。更改主磁带库上的日期。

	
<MM>－月（两位数）


	
<DD>－日（两位数）


	
<YYYY>－年（四位数）












drive

此命令显示磁带机的相关信息或执行 adiEnable、fastLoad、power 和 rewindUnload 等磁带机实用程序。

	drive
	
显示 drive 命令的帮助，与 "help drive" 相同。


	drive adiEnable {on | off | print}
	
打开、关闭或者打印 ADI 磁带机搜索状况。一旦启用，所有后续添加的磁带机都将尝试 ADI 磁带机搜索。要为磁带库中具有 ADI 功能的所有磁带机启用 ADI，必须重新引导磁带库。


	drive fastLoad {on | off | print}
	
打开、关闭或者打印 fastLoad 功能的状况。FastLoad 会更改磁带机挂载（move 命令）的行为。fastLoad 开启时，机械手并不等待 PUT 完全装入到磁带机，而是立即进行下一操作。此外，还会更改 rewindUnload 命令的行为，不等待磁带机卸载而是立即返回。fastLoad 的状态适用于所有磁带机。




	
注:

此命令仅影响发出它的同一 CLI 会话中所发出的命令。








	drive print { <drive address> | * }
	
显示磁带机摘要信息：位置、状态、状况、类型、固件版本、接口类型、使用中、序列号、状态（联机/脱机）、状况（正常、警告或错误）和磁带机供应商。

	
<drive address>－指定磁带库中的磁带机，格式为：磁带库、滑轨、列、侧面、行。


	
*－显示磁带库中所有磁带机的磁带机信息





	drive search {on | off} <drive address>
	
导致磁带机托盘上的绿色 LED 指示灯闪烁。闪烁将一直持续，直到发出 search off 命令。用于在磁带库中找到磁带机。

	
<drive address>－指定磁带库中的磁带机，格式为：磁带库、滑轨、列、侧面、行。












hwActivation

购买硬件激活许可后，此命令可激活某些磁带库功能。




	
注:

禁用 openVolser、dualRobot、分区设置或冗余电子设备时，必须重新引导磁带库。







	hwActivation
	
显示 hwActivation 命令的帮助，与 "help hwActivation" 相同。


	hwActivation addLicenseFile
	
添加许可文件。许可文件必须命名为 SL8500_license_config.dsf。全路径名为 /usr/local/SL8500_license_config.dsf。


	hwActivation deleteFile <index>
	
删除指定的已安装功能文件。

	
<index>－指定要删除的文件编号，如磁带库控制器 hwActivation 模块数据库中所指定。请参见 "hwActivation listFiles"。





	hwActivation listFiles
	
列出磁带库控制器 hwActivation 模块数据库中已安装功能的文件。


	hwActivation print
	
列出磁带库控制器 hwActivation 模块数据库中所有已启用的功能。









mediaValidation

此命令管理介质验证功能。

	mediaValidation
	
显示 mediaValidation 命令的帮助，与 "help mediaValidation" 相同


	mediaValidation print { all | poolOnly } { * | @ }
	
显示介质验证池的磁带机位置。

	
all－列出所有磁带机插槽


	
poolOnly－仅列出介质验证池中的磁带机插槽


	
*－仅显示目标磁带库的信息


	
@－显示整个复合磁带库的信息





	mediaValidation reservation clear <drive address>
	
清除指定磁带机的介质验证保留。

	
<drive address>－指定磁带库中的磁带机，格式为：磁带库、滑轨、列、侧面、行。





	mediaValidation stopValidation <drive address>
	
停止目前正在进行的验证。磁带返回到源存储插槽。

	
<drive address>－指定磁带库中的磁带机，格式为：磁带库、滑轨、列、侧面、行。












network

此命令用于配置和显示控制器卡的网络配置。有关其他信息，请参见 OTN 上的《SL8500 主机连接指南》。

	network clone [Port 2B IP address] [Port 2A IP address]
	
用于冗余电子设备配置。将所有端口、路由和 IP 策略配置复制到 B 侧 HBC。IP 地址替换为针对 B 侧的命令中指定的 IP 地址。如果未指定任何端口 IP 地址，则不在 B 侧设置它们。


	network config print
	
显示为 network 命令所设置的目录磁带库侧面（A 或 B）。


	network config side {a | b}
	
设置网络命令的目标磁带库侧面。


	network config clear
	
清除网络配置。此命令停止网络连接。重新配置需要访问 HBC 卡上的串行端口。


	network export
	
导出磁带库网络配置文件 (.lnc) 并生成网络配置脚本 (.scr)。仅在之前未设置任何网络配置的情况下使用。


	network gateway <IP address>
	
设置外部网络默认网关。


	network gateway clear
	
清除外部网络默认网关。


	network import
	
导入磁带库网络配置文件 (.lnc)。


	network ip <IP address>
	
设置 2B 端口的 IP 地址。


	network ip address add <IP address> dev {2A | 2B}
	
设置特定端口的 IP 地址。


	network ip address del <IP address> dev {2A | 2B}
	
删除端口的 IP 地址。


	network ip address show [dev {2A | 2B}]
	
显示特定端口或两个端口（如果未指定 dev）的当前地址信息。


	network ip link set dev {2A | 2B} {up | down}
	
设置端口的运行状况，从而控制端口能否发送和接收以太网通信流量。

	
up－将端口设置为联机


	
down－将端口设置为脱机





	network ip policy {enable | disable} dev {2A | 2B}
	
对设备 2A 或 2B 启用或禁用策略路由。


	network ip policy status
	
显示设备 2A 和 2B 的策略路由状况。


	network ip policy route {add | del} <IP address> dev {2A | 2B}
	
为设备 2A 或 2B 的策略添加或删除静态路由。


	network ip policy route {add | del} <IP address> via <Gateway IP address> dev {2A | 2B}
	
为设备 2A 或 2B 的策略添加或删除通过网关的静态路由。


	network ip policy route show [ dev {2A | 2B} ]
	
显示设备 2A 或 2B 的策略路由信息。


	network ip route add default via <IP address>
	
设置默认网关路由 IP 地址。


	network ip route delete default
	
删除默认网关路由 IP 地址。


	network ip route {add | del} <IP address [/netmask] > dev {1A | 1B | 2A | 2B}
	
为指定主机添加或删除静态 IP（Internet Protocol，Internet 协议）路由地址。此命令还使用户可以为特定端口设置网络掩码。

示例:


SL8500>network ip route add 129.80.81.59/24 dev 1B
COMPLETED


	network ip route {add | del} <IP address [/netmask] > via <Gateway IP address>
	
添加或删除到目标网络 IP 网关地址的静态路由。


	network ip route show [dev {2A | 2B}]
	
显示当前的路由表信息或特定端口的路由表信息。


	network name <host name string>
	
设置主机名。


	network netmask <netmask>
	
以 xxx.xxx.xxx.xxx 形式设置外部网络的网络掩码。


	network print
	
显示外部以太网端口（2A 和 2B）的当前网络配置。









partition

此命令显示当前状况或禁用分区功能。

	partition
	
显示 partition 命令的帮助，与 "help partition" 相同。


	partition autoClean set { * | <Partition Id> }
	
设置指定分区内的自动清洗（0，适用于未分区的磁带库）。


	partition attribute status { * | <Partition Id> }
	
显示单个指定分区或所有分区的状态属性。


	partition disable
	
在磁带库中禁用分区。


	partition getCapacity
	
显示磁带库或任何已定义分区的容量值。


	partition status
	
显示当前分区状态。


	partition setCapacity { <Partition Id> , <Capacity> }
	
设置指定分区的容量。命令中未列出的现有分区的容量将设置为零。

示例：


SL8500> partition setCapacity 1,200 2,50 3,600
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED


	partition setNonPartitionedHLI
	
将分区设置为 hli0。如果有任何磁带机存在于介质验证池中，则必须事先将其删除。如果在复合磁带库中，则会将所有磁带库都设置为 hli0。


	partition set state {online | offline} <Partition Id>
	
设置指定分区的当前状态 (offline/online)。









reControl

此命令控制/切换冗余电子设备并检索磁带库控制器冗余电子设备状态。

	reControl
	
显示 reControl 命令的帮助，与 "help reControl" 相同。


	reControl status [ <library address> | * ]
	
检索冗余电子设备状况。

	
<library address>－指定磁带库，格式为：磁带库、滑轨、列、侧面、行。例如：2, 0, 0, 0, 0。


	
*－检索复合磁带库中所有磁带库的状况












snmp

此命令配置简单网络管理协议 (Simple Network Management Protocol, SNMP)。有关更多信息，请参见 OTN 上的 SNMP 参考指南。






ssh

此命令控制驻留在 HBC 上的 ssh 守护进程/服务器的配置。这是 SLC 和其他各种应用程序连接到磁带库控制器所使用的协议实用程序。

	ssh print
	
打印当前的 ssh 守护进程协议设置。


	ssh set version1and2
	
将 ssh 守护进程协议限制设置为 v1 和 v2。（此为默认设置）。ssh 服务器会重新启动。


	ssh set version2
	
将 ssh 守护进程协议限制仅设置为 v2。









time

此命令以军用时间表示法设置磁带库日期。

	time
	
显示 time 命令的帮助，与 "help time" 相同。


	time print
	
显示当前的系统时间。


	time <HH> : <MM>
	
设置系统时间。在一分钟之内完成解析。在复合磁带库中，libraryId = 1 的磁带库为主磁带库。更改主磁带库上的时间。

	
<HH>－小时（两位数）


	
<MM>－分钟（两位数）





	time <HH> : <MM> : <SS>
	
设置系统时间。在一秒钟之内完成解析。在复合磁带库中，libraryId = 1 的磁带库为主磁带库。更改主磁带库上的时间。

	
<HH>－小时（两位数）


	
<MM>－分钟（两位数）


	
<SS>－秒（两位数）












traceRoute

此命令跟踪到指定 IP 地址的网络路由。

	traceRoute <IP Address>
	
执行到指定 IP 地址的 traceRoute。









version

此命令显示客户版本以及适用于所请求设备的软件的版本。

	version print [ <device address> | *]
	
显示某个设备或所有设备的代码的软件版本。

	
<device address>－指定磁带库中的设备，格式为：磁带库、滑轨、列、侧面、行。












whereAmi

此命令显示与正在执行的冗余电子设备命令相关的磁带库和卡的相关系统及逻辑卡信息。

	whereAmi
	
显示在何处发出该命令的相关信息。

示例：


SL8500> whereAmI
   Host Name: gulibtst02b
   Port 2B IP Address: 172.20.151.24
   Library Type: SL8500
   HBC side: B
   Active side: B
COMPLETED











C 磁带库寻址参考




	
注:

除非另行指定，否则左侧和右侧指的是从 CAP 一侧（正面）查看磁带库时的情况。







	
使用 SLC 在 HLI 和磁带库格式之间转换插槽地址


	
寻址方案对比


	
了解寻址中使用结构元素


	
内部磁带库寻址方案


	
HLI-PRC 寻址方案


	
磁带机的物理硬件编号


	
保留的内部 IP 地址






使用 SLC 在 HLI 和磁带库格式之间转换插槽地址

您可以使用 SLC 在内部磁带库地址（磁带库、滑轨、列、侧面、行）与 ACSLS 和 ELS 使用的 HLI 地址（LSM, 面板, 行, 列）之间转换。

	
在 SLC 中，选择 Tools > Diagnostics。选择设备树中的 Library。


	
单击 Search 选项卡。


	
选择 Location。


	
从下拉列表中选择搜索标准，然后输入地址（通配符无效）。


	
从 "Requester" 下拉列表中，选择 hli0（如果您输入了 HLI 地址）或者选择 default（如果您输入了内部磁带库地址）。


	
单击 Search。


	
如果您输入了 HLI 地址，则内部磁带库地址将显示在搜索结果的 "Address" 列中。如果您输入了内部磁带库地址，请单击 . . . 以查看 HLI 地址。









寻址方案对比

	
内部磁带库寻址方案（磁带库、滑轨、列、侧面、行）－由固件和内部通信使用，表示磁带库中的所有设备和位置。

	
从 1 开始，并使用负数。


	
列指示磁带库中的水平位置


	
外部挡板行编号为 1 至 13，内部挡板编号为 1 至 14。





	
HLI-PRC 寻址方案（LSM, 面板, 行, 列）－由 HLI 客户机（例如 ACSLS 和 ELS）使用，表示磁带库位置和组件。

	
从 0 开始，并且只能使用正数。


	
列指示磁带库的左侧或右侧


	
外部挡板行编号为 0 至 12，内部挡板编号为 13 至 26。





	
磁带机的物理硬件编号－标识 HBC 卡分配的磁带机插槽位置。





图 C-1 内部磁带库与 HLI-PRC 寻址（磁带库顶部视图）

[image: 周围的文本说明了 图 C-1 。]







了解寻址中使用结构元素


挡板

	
磁带库的每一侧（左/右）都有一个内部挡板和一个外部挡板。





标准阵列

	
内部挡板上具有 14 插槽的阵列


	
外部挡板上具有 13 插槽的阵列





特殊阵列

	
直通端口上面具有 8 插槽的阵列


	
维修安全门的止动托架下具有 8 插槽的阵列


	
升降装置和直通端口上具有 4 插槽的阵列


	
每个滑轨的末端具有 3 插槽的阵列


	
批量 CAP 磁带盒具有 12 插槽的阵列





滑轨 (LSM)

每个磁带库有四个机械手滑轨。对于 HLI 寻址，每个滑轨都被视为一个磁带库存储模块 (library storage module, LSM)。


列（面板）

列（相当于 HLI-PRC 寻址中的面板）指的是磁带库中某个组件的水平位置（与电子表格中的列类似）。特殊列包括：

	
角部，因为没有内部挡板


	
直通端口，因为由于 PTP，顶部的六个插槽无法访问


	
直通端口面板，因为顶部磁带插槽（在端口下方）已保留为冗余的机械手放置插槽（每个滑轨两个，每侧各一个）









内部磁带库寻址方案

	
内部磁带库寻址概述


	
磁带机内部磁带库寻址


	
旋转 CAP 内部寻址


	
PTP 内部寻址


	
升降装置内部寻址


	
机械手内部寻址






内部磁带库寻址概述

内部磁带库寻址使用磁带库、滑轨、列、侧面、行（L,R,C,S,W）指定位置。

	
磁带库－磁带库在复合磁带库中的编号（对于单个磁带库，始终为 1）


	
滑轨－自上而下从 1 到 4 编号的机械手滑轨。


	
列－设备或插槽的水平位置。列编号从磁带机托架的中心开始，在您朝磁带库正面移动时向右移动增量为 +1，向左移动增量为 -1：

	
+1 紧邻磁带机托架中心的右侧。


	
-1 紧邻磁带机托架中心的左侧。


	
包含盒式磁带的第一列分别为 +3 和 -3。





	
侧面－指示内部挡板和外部挡板、左或右机械手，或者左或右旋转 CAP。

	
外部挡板 =1，内部挡板 =2


	
左机械手 =1，右机械手 =2（在非冗余机械手中，侧面始终为 1）


	
右旋转 CAP =1，左旋转 CAP =2（对于批量 CAP，侧面始终为 1）





	
行－设备或插槽的垂直位置。行自上 (1) 而下（外侧挡板至 13，内部挡板至 14）连续编号。




组件（如 CAP、升降装置、PTP 和机械手）具有唯一的寻址规则：

	
行值等于 0，表示地址代表设备，而非设备中的插槽。


	
侧面值可能与内部挡板和外部挡板没有直接的关联。


	
升降装置和 CAP 的列值取决于磁带库中存储扩展模块的数量。









磁带机内部磁带库寻址

磁带机始终具有介于 -2 和 2 之间的列值、侧面值 1，以及介于 1 和 4 之间的行值。


图 C-2 磁带机内部磁带库寻址（从磁带库正面看）

[image: 周围的文本说明了 图 C-2 。]







旋转 CAP 内部寻址

	
滑轨和行：

	
在为设备编号时，滑轨值为 2，行值为 0。


	
在为特定插槽编号时，滑轨代表与 CAP 磁带盒相邻的滑轨（值可能为 2-4），行是 CAP 磁带盒中的插槽（值可能为 1-13）。





	
列：列值等于客户可访问列的数量加 3。在没有 SEM 的磁带库中，有 11 个客户可访问列，因此 CAP 列值为 14。


	
侧面：

	
右 CAP = 侧面值为 1


	
左 CAP = 侧面值为 2







示例

对于固件地址 1, 3, 22, 2, 10：磁带库值为 1。滑轨是从上面数的第三个 (3)。磁带库包含一个 SEM（19 个客户可访问列加 3 = 22）。CAP 位于左侧 (2)。插槽在 CAP 磁带盒中是第 10 个。





批量 CAP 内部寻址


图 C-3 批量 CAP 插槽阵列

[image: 周围的文本说明了 图 C-3 。]



图例 

	
批量 CAP 阵列（每个阵列 12 个插槽）


	
三个组阵列


	
保留的系统单元


	
维修安全门




批量 CAP 寻址：

	
滑轨：与 CAP 相邻的滑轨的编号 (1 - 4)。


	
行：为设备编号时，行值为 0。对特定插槽进行编号时，行值为 CAP 磁带盒中的插槽 (1 - 12)。


	
列：CAP 磁带盒占用磁带库中的最后三列。如果磁带库具有一个 SEM，则有 19 个客户可访问列。因此，CAP 磁带盒占用列 20、21 和 22。


	
侧面：值始终为 1。




示例

对于固件地址 1, 3, 22, 2, 10：磁带库值为 1。滑轨是从上面数的第三个 (3)。磁带库包含一个 SEM（19 个客户可访问列，因此列 22 是最外层的列）。CAP 位于左侧 (2)。插槽在 CAP 磁带盒中是第 10 个。






PTP 内部寻址

	
滑轨：值（1 至 4）代表与 PTP 相邻的滑轨。


	
列：右 PTP = 列值 +6，左 PTP = 列值 -6。


	
侧面：侧面值始终为 1，因为 PTP 在外部挡板上。


	
行：

	
在为设备编号时，行为 0。


	
在为特定插槽编号时，行为 PTP 中的插槽（1 或 2）。







示例

对于固件地址 1, 2, -6, 1, 0：磁带库值为 1。PTP 是从上面数的第二个滑轨 (2)。它位于左侧（列 -6）的外部挡板（侧面 1）上，并且此地址代表设备 (0)。






升降装置内部寻址

	
滑轨：值始终为 0，因为升降装置不对应于特定滑轨。


	
列：客户可访问列的数量加 2。在没有 SEM 的磁带库中，有 11 个客户可访问列，因此升降装置列值为 13。


	
侧面：值始终为 2，因为升降装置在内部挡板上。


	
行：

	
在为设备编号时，行为 0。


	
在为特定插槽编号时，行为升降装置中的插槽 (1-4)。







示例

对于固件地址 1, 0, 21, 2, 4：磁带库值为 1。升降装置跨所有滑轨 (0)。磁带库包含一个 SEM（19 个客户可访问列加 2 = 21）。升降装置位于内部挡板（侧面 2）上，并且此地址代表升降装置中第四个插槽。






机械手内部寻址

	
滑轨：值（1 到 4）代表机械手所在的滑轨。


	
列：值始终为 0。


	
侧面：

	
如果每个滑轨只有一个机械手，则该值始终为 1。


	
对于冗余机械手，左机械手 = 1，右机械手 = 2。





	
行：

	
在为设备编号时，行为 0。


	
在为特定插槽编号时，行为插槽值 (1)。







示例

对于固件地址 1, 1, 0, 2, 0：磁带库值为 1。机械手位于顶部的滑轨上 (1)。机械手跨所有列 (0)。它是冗余机械手系统中的右机械手 (2)，并且此地址代表设备 (0)。








HLI-PRC 寻址方案

	
HLI-PRC 寻址方案概述


	
复合磁带库 HLI 编号


	
磁带机 HLI-PRC 寻址






HLI-PRC 寻址方案概述

HLI-PRC 寻址从 0 开始，仅使用正数并且具有四个参数：LSM、面板、行和列。

	
LSM：每个滑轨都被视为一个独立的磁带库存储模块 (library storage module, LSM)。LSM 的编号为 0 到 3（从上至下）。

复合磁带库中的磁带库由 LSM 标识（请参见复合磁带库 HLI 编号）。


	
面板：指示磁带库中的水平位置。面板横跨整个磁带库，包含每个 LSM 的两个侧面（左侧和右侧）以及两个挡板（内部挡板和外部挡板）。面板 0 = CAP。面板 1 = 磁带机。面板 2 至 n = 存储插槽。


表 C-1 各种磁带库配置的面板编号

	配置
	面板编号

	
基本磁带库


	
RIM

	
CIM

	
	
	
	
	

	
	
2 - 7

	
8 - 10

	
	
	
	
	

	
一个扩展模块


	
RIM

	
SEM

	
CIM

	
	
	
	

	
	
2 - 7

	
8 - 15

	
16 - 18

	
	
	
	

	
两个扩展模块


	
RIM

	
SEM

	
SEM

	
CIM

	
	
	

	
	
2 - 7

	
8 -15

	
16 - 23

	
24 - 26

	
	
	

	
五个扩展模块


	
RIM

	
SEM

	
SEM

	
SEM

	
SEM

	
SEM

	
CIM


	
	
2 - 7

	
8 -15

	
16 - 23

	
24 - 31

	
32 - 39

	
40 - 47

	
48 - 50








	
行：盒式磁带的垂直位置，从上至下连续编号。外部挡板 = 0 至 12。内部挡板 = 13 至 26。


	
列：指示磁带库的左侧或右侧（从正面看）。左 = 0。右 = 1。









复合磁带库 HLI 编号

复合磁带库中每增加一个磁带库，LSM 编号便会相继增加。LSM 编号按以下模式增加（最多可具有十个磁带库）：

	
磁带库 1：LSM 0 到 3


	
磁带库 2：LSM 4 到 7


	
磁带库 3：LSM 8 到 11




向复合磁带库添加其他磁带库时，应从右向左添加磁带库（从磁带库的 CAP 侧看）。从左向右扩展将导致为 LSM 重新编号，这样需要重新配置主机。


图 C-4 直通端口规划示例

[image: 周围的文本说明了 图 C-4 。]



	
推荐的方法，即将磁带库添加到左侧，这样 LSM 编号会相继增加。


	
中断性方法，需要重新配置 LSM 编号。


	
新磁带库


	
连接现有磁带库的直通端口









磁带机 HLI-PRC 寻址

对于磁带机，面板值始终等于 1，列值始终等于 0，并且行值介于 0 到 15 之间。


图 C-5 磁带机 HLI-PRC 寻址（从磁带库正面看）

[image: 周围的文本说明了 图 C-5 。]









磁带机的物理硬件编号

HBC 卡分配介于 1 到 64 之间的物理硬件编号。


图 C-6 磁带机的物理硬件编号（从磁带库背面看）

[image: 周围的文本说明了 图 C-6 。]




图 C-7 磁带机编号方法对比（从磁带库正面看）

[image: 周围的文本说明了 图 C-7 。]







保留的内部 IP 地址


	IP 地址	说明

	10.0.0.0./24	内部设备网络。

	10.0.11.0/24	ILC 网络。基于磁带库标识符的主机 IP 地址。
	10.x+2.11.0/24 或
10.(1...253) + 2.11.0/24

	SDP 交接点。X = 复合磁带库标识符 (1...253)。
	10.0.4.0/24	滑轨 0 设备网络。
	10.0.3.0/24	滑轨 1 设备网络。
	10.0.2.0/24	滑轨 2 设备网络。
	10.0.1.0/24	滑轨 3 设备网络。












D 冗余电子设备概述 

可选的冗余电子设备 (redundant electronics, RE) 功能为磁带库控制器提供故障转移保护。如果磁带库控制器或磁带机控制器发生错误，则操作将切换至备用控制器。在卡装配架的同侧安装的磁带库控制器和磁带机控制器始终作为一对切换。

RE 允许 Oracle 技术支持代表在磁带库联机状态下更换发生故障的卡，并将固件升级过程中的中断降低到最小程度。




	
注:

对 HBCR 的任何引用也会引用 HBC。







	
冗余电子设备要求


	
冗余电子设备配置示例


	
在故障转移期间发生的事件


	
阻止 RE 切换的因素


	
启动自动故障转移的因素


	
启动手动故障转移的方法


	
使用 RE 时的固件升级





另请参见：

	
使用 SLC 启动手动 RE 切换






冗余电子设备要求

	
两个磁带库控制器卡 (HBCR)


	
两个磁带机控制器卡 (HBT)




	
注:

要启用 ADI 模式，两个卡必须都是高内存 HBT。
如果使用介质验证，则 Oracle 建议两个卡都是高内存 HBT 卡。










	
SL8500 固件版本最低为 FRS_6.00，SLC 版本最低为 4.65


	
使用 CLI 启用的硬件激活文件









冗余电子设备配置示例

每个磁带库控制器卡都需要具有唯一的 IP 地址。对于双 TCP/IP，每个卡需要两个唯一的 IP 地址：一个用于主端口 2B，一个用于辅助端口 2A。因此，具有 RE 和双 TCP/IP 的磁带库需要四个唯一的 IP 地址。

在每个控制器卡上，端口 2B 和 2A 必须位于不同的广播域上。不过，活动卡上的 2B 端口和备用卡上的 2B 端口可以位于同一广播域上。2A 端口也是如此。


图 D-1 冗余电子设备配置示例

[image: 周围的文本说明了 图 D-1 。]



另请参见：双 TCP/IP 概述和多 TCP/IP 概述。






在故障转移期间发生的事件

进行控制器卡故障转移时，活动磁带库控制器将尝试完成所有正在进行的作业，并将磁带数据库复制到备用控制器卡。如果无法复制数据库（通常仅在突发故障时发生），则必须在故障转移后执行审计（请参见审计磁带库）。磁带库将所有中转磁带返回其起始插槽。磁带库将无法返回至起始插槽的所有磁带置于系统插槽中，以进行主机恢复（请参见主机软件文档）。

在所有正在进行的作业完成或超时之后，卡将切换角色。备用控制器将变为活动控制器，先前的活动控制器将变为备用控制器。如果以前活动的控制器无法打开备用软件，该控制器将进入故障状态。


故障转移对用户的影响

	
磁带管理软件（Symantec 或 Virtual Storage Manager）的用户不会看到中断。


	
HLI 主机应用程序会将故障转移过程期间的请求排入队列，以在故障转移切换之后完成。对于 ACSLS，仅挂载和卸载请求受到影响（请参见主机软件文档）。


	
SLC 和 CLI 连接将终止。必须使用新活动磁带库控制器（以前的备用控制器）的 IP 地址或 DNS 别名重新建立与磁带库的连接。









阻止 RE 切换的因素

	
备用磁带库或磁带机控制器处于故障或弹出状态。


	
备用代码未在备用磁带库或磁带机控制器卡上运行。


	
正在进行固件下载或卡初始化。









启动自动故障转移的因素

自动故障转移可以由活动或备用磁带库控制器启动。

在以下情况下，活动磁带库控制器将启动自动故障转移：

	
其对应磁带机控制器卡未安装或者未进行通信。


	
它检测到灾难性的内部软件错误。




如果活动控制器未正常运行，备用磁带库控制器将启动自动故障转移。






启动手动故障转移的方法

在启动手动切换之前，您应确认备用磁带库和磁带机控制器运行正常。可以通过以下工具启动手动切换：

	
主机磁带管理（ACSLS 或 ELS）－可以从活动或备用磁带库控制器启动故障转移。备用磁带库控制器仅接受 set host path group 和 force switchover HLI 请求。


	
SLC－只能从活动磁带库控制器启动故障转移（请参见使用 SLC 启动手动 RE 切换）。


	
CLI－Oracle 技术支持代表可以从活动或备用磁带库控制器启动故障转移。




在以下情况下可能需要进行手动切换：在备用卡初始安装后，固件升级后，或定期检查故障转移是否正常工作。不能手动切换磁带库控制器但不切换磁带机控制器 — 这两个控制器始终作为一对进行切换。






使用 RE 时的固件升级

对于 RE 磁带库，固件升级对磁带库操作的中断可降低到最小程度。磁带库在活动和备用控制器卡上以及所有设备上同时装入和解压缩新代码。然后磁带库激活代码并重新启动控制器和大多数设备。在大多数情况下，磁带库会绕过机械手初始化。

在磁带库重新引导之前，装入、解压缩和激活代码不会中断磁带库操作。在重新引导进行期间（大约需要 10 分钟），主机应用程序（ACSLS 和 ELS）将所有挂载和卸载请求排入队列。在重新引导完成之后，将排队的请求提交到磁带库控制器中。

有关固件下载和激活的信息，请参见升级磁带库固件。








E 双 TCP/IP 概述

双 TCP/IP 使用 HBC/HBCR 卡的主端口 2B 和辅助端口 2A 在主机与磁带库之间提供两个连接。如果主要主机连接断开，则磁带库自动使用辅助连接。

	
双 TCP/IP 的最低要求


	
使用共享网络


	
配置双 TCP/IP


	
双 TCP/IP 配置示例





另请参见

	
冗余电子设备概述


	
ACSLS 或 ELS 文档






双 TCP/IP 的最低要求

	
包含 PUT0701 的 ACSLS 7.1（适用于 Solaris 或 AIX）。Oracle 建议 ACSLS 8.1 或更高版本。


	
包含以下 PTF 的 NCS 6.2：SOS620 L1H168G、SMS620 L1H168F（适用于 HSC/MVS/VM）和 MSP PTF LF620DL（适用于 MSP）。


	
必须将所有交换机或路由器端口配置为自动协商。SL8500 端口默认配置为自动协商并支持 10/100 Mbps 速度。


	
硬件激活文件（请参见第 3 章 激活可选功能）









使用共享网络




	
注:

Oracle 建议使用专用网络，以实现最大吞吐量、最小资源争用和更高的安全性。







如果必须使用共享网络：

	
直接将磁带库连接到可过滤掉非定向（广播）通信的交换机或路由器。


	
将磁带库置于其自己的子网中。这可以防止磁带库收到广播消息。


	
使用受管交换机或路由器来：

	
设置端口上的优先级，以便为主机和磁带库提供较高的优先级。


	
在主机和磁带库之间提供专用带宽。


	
在主机与磁带库之间创建一个虚拟局域网 (virtual local area network, VLAN)。





	
使用虚拟专用网络 (virtual private network, VPN) 将主机到磁带库的通信与其他干扰（例如无关广播）隔离开来。





共享网络上的网络广播问题

发送到所有网络节点的广播会定向至磁带库。磁带库无法在它接收这些不相关的广播时有效处理请求。因此，主机与磁带库之间的连接可能会断开。

繁重的网络通信还可能会使 HBC/HBCR 卡上的以太网控制器超载。因此，控制器会不断重置。


共享网络上发生 ARP 洪流

SL8500 的处理器可能会被地址解析协议 (address resolution protocol, ARP) 广播洪流所淹没。应在交换机或路由器后面连接连接磁带库。






配置双 TCP/IP




	
注:

在配置双 TCP/IP 之前，从管理员处或使用相应的 network ip 命令收集有关网络、路由和 IP 地址的信息。







	
针对双 TCP/IP 配置磁带库


	
针对双 TCP/IP 配置 ACSLS 主机


	
针对双 TCP/IP 配置 ELS 主机






针对双 TCP/IP 配置磁带库

使用 route 命令管理路由表。定义主机 2A 和 2B 端口的路由。

	
使用 CLI，使两个端口都脱机：


SL8500> network ip link set dev 2A down
SL8500> network ip link set dev 2B down


	
为两个端口添加新的 IP 地址和子网掩码：


SL8500> network ip address add IP_address/netmask dev 2A
SL8500> network ip address add IP_address/netmask dev 2B


	
要使更改生效，请将两个端口联机：


SL8500> network ip link set dev 2A up
SL8500> network ip link set dev 2B up


	
为每个端口输入网络路由配置：

	
对于多个主机，为每个主机添加 IP 地址和网络掩码：


SL8500> network ip route add IP_address/netmask dev 2A
SL8500> network ip route add IP_address/netmask dev 2B


	
对于单个主机，无需网络掩码值：


SL8500> network ip policy route add host_IP_address dev 2A
SL8500> network ip policy route add host_IP_address via gateway_IP_address dev 2A
SL8500> network ip policy enable 2A |2B
SL8500> network ip policy status





	
验证配置。


SL8500> network ip address show
SL8500> network ip route show
SL8500> network ip policy route show dev 2A |2B


	
检查日期和时间是否准确。


SL8500> time
time print
time HH: MM
time HH:MM:SS


	
对配置进行测试以确保通过两个端口都可以访问磁带库。









针对双 TCP/IP 配置 ACSLS 主机

对于 ACSLS 服务器，应使用 acsss_config 命令或动态配置 config 实用程序在两个单独的子网上配置两个网络接口。使用 route 命令在 ACSLS 服务器上定义这两个路由。另一个物理连接提高了可靠性。

	
根据 ACSLS 文档更新 ACSLS 服务器的路由表。如果 ACSLS 服务器上只有单个网络接口，则主机上不需要特殊路由。


	
在 ACSLS 服务器上通过 UNIX 命令提示符，使用动态配置命令添加与 SL8500 的端口连接。

	
确保 ACS 到 ACSLS 之间的连接处于联机或诊断模式。


	
使用 config port acs_id 添加端口。


	
如果尚未联机，使 ACS 联机以连接到 ACSLS。





	
要删除或者以不同的端口替换现有 IP 地址，请执行以下操作：

	
发出 kill.acsss（对于 7.3 和更低版本）或 acsss disable（对于 8.0 和更高版本）命令来关闭 ACSLS。


	
发出 acsss_config 命令来配置新端口。


	
发出 rc.acsss（对于 7.3 和更低版本）或 acsss enable（对于 8.0 和更高版本）命令使 ACSLS 重新联机







有关更多信息，请参见《ACSLS Administrator’s Guide》。






针对双 TCP/IP 配置 ELS 主机

	
根据 ELS 文档更新 IBM 大型机的路由表。如果 IBM 大型机上只有单个网络接口，则主机上不需要特殊路由。


	
在 IBM 大型机控制台或 PARMLIB，使用 LMUPATH 控制语句定义网络 LMU 连接。


	
指定另一个 LMUADDR 参数来定义双 TCP/IP。ELS 自动确定连接是双 TCP/IP 还是双 LMU。


	
使 ACS 脱机，发出 LMUPDEF命令，并使 ACS 重新联机以获取修订后的包括第二个连接的 LMUPATH 语句。




有关更多信息，请参见 ELS 文档。








双 TCP/IP 配置示例

	
ACSLS 双 TCP/IP 和共享子网示例


	
通过公共网络的 ACSLS 双 TCP/IP 示例


	
ACSLS 高可用性双 TCP/IP 示例


	
有关 RE 和双 TCP/IP 的示例，另请参见冗余电子设备配置示例。






ACSLS 双 TCP/IP 和共享子网示例

在本例中，ACSLS 服务器和磁带库共享两个独立的子网。SL8500 使用与 ACSLS 服务器上的网络接口的一对一关系。子网 192.168.0/23 上的网络接口卡连接到端口 2B，子网 192.168.1/23 上的网络接口卡连接到端口 2A。


路由

使用 UNIX route 命令强制实施关系。有关更多信息，请参见《ACSLS Administrator's Guide》。


图 E-1 ACSLS 双 TCP/IP 和共享子网

[image: ACSLS 双 TCP/IP 和共享子网]









通过公共网络的 ACSLS 双 TCP/IP 示例

在本例中，ACSLS 服务器包含位于两个不同子网上的两个网络接口。两个接口都通过一个公共网络，并且在连接到 SL8500 磁带库之前进入两个不同的子网。此配置使用与第一个示例中相同的命令。


图 E-2 ACSLS 双 TCP/IP

[image: 通过公共网络的 ACSLS 双 TCP/IP]







ACSLS 高可用性双 TCP/IP 示例

以下示例是需要双 TCP/IP 的 ACSLS 高可用性 (High Availability, HA) 环境。HA 环境的目的是采用两台 ACSLS 服务器，一台处于活动状态，一台处于备用状态。在此配置中，两台 ACSLS 服务器将六个网络接口（每台上三个）连接到两个不同的子网。第三个子网通过公共网络连接了两台 ACSLS 服务器。

有关 ACSLS HA 和双 TCP/IP 的更多信息，请参见《ACSLS Administrator's Guide》。


路由

在使用 ACSLS HA 时，您应该通过两个不同的子网隔离 SL8500 网络接口。两个不同的 ACSLS 服务器使用不同的网络接口；因此，应将定制路由条目同时添加到两个 ACSLS HA 服务器。将两台服务器的 IP 地址添加到 SL8500 配置。





路由表

将定制条目添加到 ACSLS 服务器上的路由表；不过，在重新引导 ACSLS 服务器之后，所有定制路由表条目都将丢失。要维护定制路由表条目，可以创建脚本来添加定制路由。将脚本放置在 rc 目录结构中以便在引导时自动执行。

有关更多信息，请参阅《ACSLS Administrator's Guide》。


图 E-3 ACSLS 高可用性双 TCP/IP

[image: 采用双 TCP/IP 的 ACSLS HA]








ELS/HSC 和双 TCP/IP 示例

以下示例显示了使用双 TCP/IP 的大型机系统的首选配置。大型机包含位于两个不同子网上的两个网络接口。各个连接穿过一个公用网络，然后在到达 SL8500 磁带库之前连接到两个不同的子网。

有关更多信息，请参阅 ELS 文档。


图 E-4 ELS/HSC 双 TCP/IP

[image: ELS/HSC 双 TCP/IP]











F 多 TCP/IP 概述

多 TCP/IP 允许主机连接到复合磁带库中的多个磁带库。如果连接到复合磁带库中的一个磁带库失败，则主机仍可以通过复合磁带库中的其他磁带库通信。ACSLS 主机最多支持 15 个连接，ELS 主机最多支持 32 个连接。

	
多 TCP/IP 最低要求


	
配置建议


	
多 TCP/IP 配置示例





另请参见：

	
双 TCP/IP 概述


	
冗余电子设备概述


	
ACSLS 和 ELS 文档






多 TCP/IP 最低要求

	
复合磁带库


	
SL8500 固件版本 FRS_3.97 和 SLC 版本 3.38


	
具有 PUT0701 的 ACSLS 7.1 或 7.1.1（HA 2.0 还需要 PTF 6514766）。需要 ACSLS 8.1 或更高版本才能支持 15 个磁带库连接。


	
具有 PTF L1H168H 的 ELS 版本 7.0，或者具有 PTF L1H168I 的 ELS 版本 7.1


	
硬件激活文件（请参见第 3 章 激活可选功能）









配置建议

	
始终使用多个子网以实现冗余。


	
对于复合磁带库中 ACSLS 服务器与每个 SL8500 之间的单个连接，则不需要路由表。


	
对于采用双和多 TCP/IP 的磁带库，请使用 CLI 为端口 2A 配置路由。确保端口 2A 和 2B 位于单独的广播域上。


	
对于 ELS，使用 LMUPATH 控制语句定义多个 LMUADDR 参数。这些参数是多 TCP/IP 连接的 IP 地址。

在下面的示例中，主机连接到四个 SL8500 磁带库。


LMUPATH ACS(00)LMUADDR(123.456.789.012,123.456.789,
013,123.456.789.014,123.456.789.015)









多 TCP/IP 配置示例


图 F-1 与复合磁带库的多 TCP/IP 连接

[image: 周围的文本说明了 图 F-1 。]




图 F-2 与复合磁带库的双 TCP/IP 和多 TCP/IP 连接

[image: 周围的文本说明了 图 F-2 。]



有关更多信息，请参见双 TCP/IP 概述。








G 升级磁带库固件

请与 Oracle 技术支持联系以升级固件。只应由 Oracle 服务代表安装新的磁带库固件。




	
注:

不能在本地操作面板上执行代码下载和激活。








磁带库固件不包含磁带机代码升级（请参见特定于磁带机的文档）。

	
将代码下载到磁带库控制器


	
在磁带库控制器上激活代码






将代码下载到磁带库控制器

	
在以下位置找到固件升级软件包（.jar 文件）：

http://edelivery.oracle.com


	
将代码下载到系统中。


	
登录 SLC。

如果要升级 SL8500 复合磁带库，可以连接到复合磁带库中的任何磁带库。升级内容会同时通过单个 SLC 会话下载到复合磁带库中的所有磁带库。


	
选择 Tools > Diagnostics，然后选择设备树中的 Library。


	
单击 Load Code 选项卡。


	
找到固件软件包。


	
验证内容和文件名。单击 Load。

下载过程最多可能需要 10 分钟。


	
验证是否已成功解压缩软件包（失败的标签显示 0）。









在磁带库控制器上激活代码

只应由 Oracle 服务代表安装新的磁带库固件。请与 Oracle 技术支持联系以获取帮助。




	
注:

要激活代码，必须重新引导磁带库。相应地安排激活时间。








	
下载并解压缩代码（请参见将代码下载到磁带库控制器）。


	
在 SLC 中，选择 Tools > Diagnostics，然后在设备树中选择 Library。


	
单击 Activate Code 选项卡。


	
在 "Target" 列表中，选择要激活的代码软件包（本例中为 SL8500 Code）。


	
在 "Available Versions" 部分，选择要激活的代码版本。单击 Activate。




	
注意:

内部文件可能受损。请不要在激活代码时重新引导磁带库中的任何设备，也不要对磁带库执行任何操作。









	
激活过程完成后，单击 OK 重新引导磁带库。


	
单击 OK 终止 SLC 会话。磁带库初始化完成之后，可以重新登录到 SLC。











H 控制污染物

本附录阐述了如何控制污染物。


环境污染物

控制机房内的污染级别极其重要，因为空气颗粒物可使磁带库、磁带机和磁带介质受损。在大多数情况下，肉眼看不见小于十微米的大多数粒子，但是这些粒子损坏性最强。因此，工作环境必须符合以下要求：

	
ISO 14644-1 Class 8 环境。


	
空气颗粒物的总质量必须每立方米小于或等于 200 微克。


	
ANSI/ISA 71.04-1985 规定的严重级别 G1。




Oracle 当前要求使用 1999 年批准的 ISO 14644-1 标准，但是如果 ISO 管理机构批准了任何 ISO 14644-1 更新标准，Oracle 将要求使用这些标准。ISO 14644-1 标准主要着重于颗粒物的数量和大小以及正确的度量方法，但是不处理颗粒物的总质量。因此，还需要总质量限制，因为机房或数据中心可能满足 ISO 14644-1 规范，但是由于机房中存在特定类型的颗粒物，仍可能会损坏设备。此外，ANSI/ISA 71.04-1985 规范处理气态污染物，因为空气中一些化学物质更有害。以上所有三种要求与其他主要磁带存储供应商设定的要求一致。





必需的空气质量级别

粒子、气体和其他污染物可能会影响计算机硬件的持续运行。其影响可能包括从间歇性干扰到实际的组件故障。机房必须设计为可以进行较高程度的清洁。空气浮尘、气体和烟雾必须维持在定义的限制内，从而帮助最大程度地降低对硬件的潜在影响。

空气颗粒物级别必须维持在 ISO 14644-1 Class 8 环境的限制之内。此标准根据空气颗粒物浓度定义清洁区域的空气质量等级。此标准的粒子数量级小于办公环境中标准空气的粒子数量级。十微米或更小的粒子对于大多数的数据处理硬件都有害，因为它们往往大量存在，很容易避开许多敏感组件的内部空气过滤系统。计算机硬件暴露在大量这种亚微粒子中时，可能会导致部件移动、敏感接触以及组件腐蚀，从而危及系统可靠性。

某些气体的浓度过高也会加速腐蚀并导致电子元件故障。由于硬件的敏感性，以及机房环境通常是几乎完全循环的，要特别注意机房中的气态污染物。由于气流模式的循环特性，机房中的任何污染物威胁都会加重。在通风良好的场所中可能不需要考虑的暴露级别在循环空气的机房中会对硬件造成反复攻击。防止机房环境暴露给外部影响物的隔离措施也会增加机房中未处理的任何不利影响物。

对电子元件特别危险的气体包括氯化合物、氨及其衍生物、硫氧化物以及汽油烃。缺少适当的硬件暴露限制时，必须使用健康暴露限制。

下面各节将详细讲述维持 ISO 14644-1 Class 8 环境的一些最佳做法，不过下面是必须符合的一些基本事项：

	
不允许带食物或饮料进入该区域。


	
禁止在数据中心清洁区域存放硬纸板、木材或包装材料。


	
确定单独区域用来将新设备从包装箱中取出。


	
必须首先隔离敏感设备以及该设备专门针对的任何空气，然后才能在数据中心内进行施工或钻孔。施工将生成较高程度的颗粒物，会超过局部区域的 ISO 14644-1 Class 8 标准。干砌墙和石膏对存储设备尤其有害。








污染物属性和源

机房中的污染物可能有许多形式，可能来自许多源。机房中的机械过程会产生危险的污染物或搅动已落定污染物。粒子必须满足两个基本标准才被视为污染物：

	
它必须具有可能会导致损坏硬件的物理属性。


	
它必须能够迁移到它可能导致物理损坏的区域。




可能污染物与实际污染物之间的唯一区别是时间和位置。颗粒物质最可能迁移到其具有空气传播性质时会进行损坏的区域。由于这个缘故，在确定机房环境的质量时空气颗粒物浓度是一个非常有用的度量标准。根据局部情况，1,000 微米大的粒子会变为具有空气传播性质，但是它们的有效寿命非常短，而且可以被大多数过滤设备阻止。亚微颗粒物对于敏感计算机硬件更为危险，因为它们可以保持空气传播性质更长的时间，而且更易于绕开过滤器。


操作员活动

计算机空间内人的活动可能是一个干净机房内的最大污染源。正常活动会掉出组织碎片，例如头皮屑、头发或者衣服上的纤维。开关抽屉或硬件面板或者任何金属相对金属的活动都会产生金属屑。只是走过地面也会搅动已落定的污染物，使其在空气中飞扬并且可能造成危害。





硬件移动

安装或重新配置硬件会涉及大量底层地板活动，已落定污染物非常容易受到搅动，致使它们扩散到空气中，随着空气流动对机房硬件造成危害。这在底层地板未密封时尤其危险。未密封的混凝土会将细微尘粒散布到气流中并且容易受到盐霜（通过蒸发或液体静压力带到地板表面的矿物盐）影响。





室外空气

来自受控环境外部未充分过滤的空气会带入无数污染物。气流会带动管道系统中的过滤后污染物，这些污染物将被带入硬件环境。这在向下流动的空调系统中尤其重要，在这样的系统中底层地板空隙用作送风管道。如果结构地板被污染，或者混凝土板未密封，细颗粒物质（例如混凝土灰尘或盐霜）会被直接带入机房的硬件中。





存储的物品

存储和处理不使用的硬件或用品也会是一个污染源。移动或处理起皱的纸箱或木质底盘时会散布纤维。存储的物品不仅是污染源；在机房受控区域中处理这些物品会搅动机房中已有的已落定污染物。





外部影响物

在负压环境中，相邻办公区域或建筑外部的污染物可以通过门缝或墙上的渗透区渗入机房环境。农产品加工过程通常会涉及氨和磷酸盐，在制造区域会产生很多化学品。如果数据中心设施附近存在此类行业，可能需要进行化学过滤。根据情况，还应该评估汽车排放物、来自当地采石场或砖石制造设施的灰尘或者海雾的潜在影响。





清洁活动

不适当的清洁活动也会使环境恶化。常规或“办公”清洁活动中使用的许多化学品会损坏敏感的计算机设备。应该避免使用清洁过程和设备一节中列出的具有潜在危险的化学品。这些产品排放的气体或者产品与硬件组件直接接触会导致故障。建筑物空气处理设备中使用的某些杀菌处理剂也不适用于机房，因为它们含有可危害组件的化学物质或者不适用于再循环通风系统的气流。使用拖把或未充分过滤的真空吸尘器也会导致污染。

有必要采取措施来防止空气污染物（例如金属粒子、大气尘埃、溶剂蒸汽、腐蚀性气体、烟灰、机载光纤或盐分）进入机房环境或者在该环境中生成。如果缺少硬件暴露限制，则应该使用 OSHA、NIOSH 或 ACGIH 的适用人体暴露限制。







污染物影响

空气颗粒物与电子设备之间的破坏性反应可以多种方式进行。干扰的方式取决于危机事故的时间和位置、污染物的物理属性以及放置组件的环境。


物理干扰

如果硬粒子的抗拉强度比组件材料的抗拉强度大至少 10%，则该粒子会通过磨削操作或嵌入来去除组件表面的材料。软粒子不会损坏组件表面，但是会聚集成斑块，干扰正常运行。如果这些粒子是粘性的，它们会聚集其他颗粒物质。如果非常小的粒子聚集在粘性表面上，或者由于静电电荷积聚而凝聚，甚至这些粒子也会产生影响。





腐蚀失效

由于粒子的固有成分或者由于粒子吸收水汽和气态污染物而导致的腐蚀失效或接触中断也会导致故障。污染物的化学成分非常重要。例如，盐分从空气中吸收水蒸汽（核化）后大小会增加。如果敏感位置存在矿物盐沉积，并且环境非常潮湿，这些盐分的大小会增大从而对装置产生物理干扰，或者会形成盐溶液而导致损害。





短路

在电路板或其他组件上积聚粒子会产生传导通路。许多类型的颗粒物本来不是传导性的，但是它们在高水分环境中可以吸收大量水分。导电粒子导致的问题涉及间歇故障到对组件的实际损害和运转故障。





热故障

过滤设备的过早堵塞将导致气流受限，从而可能引起内部过热和磁头碰撞。硬件组件上累积的厚尘埃层还会形成可能导致热相关故障的绝缘层。







室内条件

数据中心受控区域内的所有表面都应该维持较高清洁水平。所有表面都应该由受过培训的专业人员定期进行清洁，如清洁过程和设备一节中所述。应该特别注意硬件下面的区域以及活动地板网格。硬件进气口附近的污染物更容易被传送到它们会产生损害的区域。启开地板砖来到达底层地板时会使活动地板网格上累积的颗粒物在空气中飞扬。

向下流动的空调系统中的底层地板空隙会起到送风箱的作用。该区域受到空调加压，然后调节后的空气将通过通风地板进入硬件空间。因此，从空调传送到硬件的所有空气必须首先经过底层地板空隙。送风箱中的不良状况会对硬件区域产生很大影响。

数据中心中的底层地板空隙通常仅被视为走线和走管的便利位置。一定要记住这也是一个管道，并且假地板下面必须保持高度清洁。污染源可能包括腐化的建筑材料、操作员活动或来自受控区域外部的渗透。通常将形成颗粒物沉积，其中电缆或其他底层地板物品形成气坝，使颗粒物落定和沉积。移动这些物品时，颗粒物将重新卷入送风气流，从而被带入硬件中。

损坏的或未进行适当保护的建筑材料通常是底层地板污染源。未经保护的混凝土、砖石块、灰泥或石膏壁板将随着时间流逝而腐化，向空气中散布细颗粒物。过滤后空调表面或底层地板物品的腐蚀也会成为问题。必须定期对底层地板空隙进行彻底而适当的净化，以处理这些污染物。在任何净化过程中都只能使用配备了高效颗粒空气 (High Efficiency Particulate Air, HEPA) 过滤的真空吸尘器。未充分过滤的真空吸尘器无法阻止细微粒子，这些粒子将会以很高的速度传过装置并在空气中飞扬。

未密封的混凝土、砖石或其他相似材料会持续恶化。在施工期间通常使用的密封剂和硬化剂常常设计为保护地板以承受繁重的交通，或者对地板进行准备以应用地板材料，不是针对送风箱的内部表面。虽然定期净化将帮助处理松散颗粒物，但表面仍会随着时间而恶化，或者因为底层地板活动会导致磨损。理想情况下，在施工时将适当地对所有底层地板表面进行密封。如果不是这样，将需要采取特殊预防措施来处理联机机房中的表面。

在封装过程中仅使用适当材料和方法极其重要。不适当的密封剂或过程实际上会恶化它们本来要改善的条件，影响硬件操作和可靠性。在联机机房中封装送风箱时应该采取以下预防措施：

	
人工应用密封剂。在联机数据中心完全不适合应用喷洒技术。喷洒过程强迫密封剂在供应气流中变为具有空气传播性质，更可能会将电缆封装到地板中。


	
使用有色密封剂。通过着色可以在应用时看到密封剂，从而确保完全密封，而且着色可以帮助标识将随着时间而被损坏或暴露的区域。


	
它必须具有较高灵活性和较低多孔性，以便有效地覆盖主题区域的不规则结构，并且最大程度地降低水分移动和水损。


	
密封剂不得释放任何有害污染物气体。行业中常用的许多密封剂都是高度氨化的，或者包含可能对硬件有害的其他化学物质。这种气体排放不太可能导致直接的、灾难性故障，但是这些化学物质通常将促进触点、磁头或其他组件的腐蚀。




有效封装联机机房中的底层地板是一项非常敏感和困难的任务，但是如果使用适当过程和材料则可以安全执行该任务。避免将吊顶空隙用作建筑通风系统的开放送风或回风管道。该区域通常非常脏并且难于清理。通常结构表面涂有纤维防火层，吊顶板和绝缘层也会向外散布。甚至在过滤之前，这也是会对机房中的环境条件产生不利影响的无用暴露。吊顶空隙不要变为受压状态也是非常重要的，因为这将强迫脏空气进入机房。底层地板和和吊顶空隙中具有渗透区的柱状物和电缆槽会导致吊顶空隙增压。





暴露点

应该处理数据中心中的所有潜在暴露点，从而最大程度降低来自受控区域外部的潜在影响。机房的正压将有助于限制污染物渗入，但是最大程度降低机房周围的任何缺口也非常重要。为确保正确维持环境，应该考虑以下各项：

	
所有门都应该与其门框紧贴。


	
可以使用密封垫和废屑来处理所有缝隙。


	
在可能会意外触发自动门的区域应该避免使用自动门。另一种控制方式是在远处放置门触发器，从而推车的人可以轻松开门。在高度敏感区域或者数据中心暴露于不良条件的区域，可能需要设计和安装人员活板门。使用其间存在缓冲区的两组门可以帮助限制直接暴露给外部条件。


	
密封数据中心与邻近区域之间的所有渗透区。


	
避免与未实施严格控制的邻近区域共用机房吊顶或底层地板压力通风系统。








过滤

过滤是处理受控环境中的空气颗粒物的一种有效方式。一定要充分过滤用于数据中心的所有空气处理设备，以确保在机房内维持适当的条件。室内过程冷却是一种建议的控制机房环境的方法。室内处理散热器对室内空气进行再循环。来自硬件区域的空气将通过这些装置进行过滤和冷却，然后进入底层地板压力通风系统。压力通风系统将受压，迫使调节过的空气进入机房，通过多孔砖，然后返回空调进行重新调节。与典型机房空气处理设备相关的气流形式和设计比典型舒适冷却空调具有更高的空气变化率，所以与办公环境相比，空气过滤频率要高得多。正确进行过滤可以捕获大量颗粒物。室内安装的过滤器、再循环空调应该具有 40% 的最低效率（大气尘点效率，ASHRAE 标准 52.1）。应该安装低级预过滤器来帮助延长更昂贵的主要过滤器的寿命。

进入机房受控区域的所有空气（因为通风或正压）应首先通过高效过滤设施。理想情况下，来自建筑外部来源的空气应使用效率为 99.97%（DOP效率 MILSTD-282）或更高的高效颗粒空气 (High Efficiency Particulate Air, HEPA) 过滤设施进行过滤。昂贵的高效过滤器应使用更频繁更换的多层预过滤器进行保护。低级预过滤器（20% ASHRAE 大气尘点效率）应该是主要防线。下一过滤器组应该包含效率在 60% 和 80% ASHRAE 大气尘点效率之间的折叠过滤器或袋式过滤器。


表 H-1 过滤百分比

	ASHRAE 52-76 尘点效率百分比	3.0 微米	1.0 微米	0.3 微米
	
25-30%

	
80%

	
20%

	
<5%


	
60-65%

	
93%

	
50%

	
20%


	
80-85%

	
99%

	
90%

	
50%


	
90%

	
>99%

	
92%

	
60%


	
DOP 95%

	
N/A

	
>99%

	
95%








低效过滤器在去除空气中的亚微颗粒物时几乎完全无效。此外，使用的过滤器大小适合空气处理设备也非常重要。过滤器面板周围的缝隙使空气在通过空调时可以绕过过滤器。应使用适当材料（不锈钢面板或定制过滤器组件）填充所有缝隙或开口。





正压和通风

将需要设计从机房系统外部引入空气以便满足正压和通风要求。相对于未实施严格控制的周围区域，数据中心应设计为处于正压状态。更敏感区域的正压是对通过机房周边任何小缺口的污染物渗入进行控制的一种有效方式。正压系统设计为对数据处理中心内的门口和其他访问点应用向外空气力量，从而最大程度地降低机房的污染物渗入。仅应向受控环境引入很少量的空气。在具有多个机房的数据中心，最敏感区域应该受到高度加压。但是，极其重要的是用于对机房正向加压的空气不要对机房中的环境条件产生不利影响。从机房外部引入的所有空气都需要进行充分过滤和调节，以确保其处于可接受参数范围内。这些参数可以比机房的目标条件宽松，因为引入的空气应该是很少量的。应基于引入的空气量以及对数据中心环境的可能影响精确确定可接受的限制。

因为大多数数据中心都使用封闭的再循环空调系统，所以需要引入很少量的空气来满足机房成员的通风要求。数据中心区域内通常人口密度非常低；因而通风所需的空气非常少。在大多数情况下，实现正压所需的空气很可能会超过满足机房成员所需的空气。通常，小于 5% 的外部补充空气量应该足够了（ASHRAE 手册：应用，第 17 章）。对于每个成员或工作站，15 CFM 的外部空气量应该足以满足机房的通风需要。






清洁过程和设备

即使设计完美的数据中心也需要持续进行维护。设计方面有缺陷的数据中心可能需要大量工作才能将环境维持在所需的限制内。硬件性能是导致数据中心需要高度清洁的一个重要因素。

操作员认知是另一个考虑因素。维持相当高水平的清洁将提升数据中心中成员对特殊要求和限制的认知程度。数据中心成员或访客将十分重视受控环境，从而更可能采取正确措施。任何维持相当高水平的清洁度且整洁、有条理的环境也将会博得机房成员和访客的敬重。当潜在客户参观机房时，他们会将机房的整体外观视为对卓越和质量的整体承诺的一个反映。有效的清洁计划必须包含专门设计的短期和长期措施。这些措施汇总如下：


表 H-2 数据中心的清洁计划

	频率
	任务

	
每日行动


	
清理垃圾



	
周行动


	
活动地板维护（真空吸尘器和湿拖把）



	
季度行动


	
硬件净化

机房表面净化



	
半年行动


	
底层地板空隙净化

空调净化（根据需要）










每日任务

此工作说明重点关注机房中每天丢弃的垃圾的清理。此外，在打印室或者进行大量操作员活动的房间中需要每天进行地板吸尘。






每周任务

此工作说明重点关注活动地板系统的维护。在一周内，活动地板会由于灰尘累积和瑕疵而变脏。应对整个活动地板进行吸尘和湿擦。数据中心使用的所有真空吸尘器（用于任何目的）都应该配备高效颗粒空气 (High Efficiency Particulate Air, HEPA) 过滤。未充分过滤的设备无法阻止更小的粒子，而仅是搅动这些粒子，从而恶化了它们本来要改善的环境。拖把头和灰尘擦相应设计为非散布形式也是非常重要的。

数据中心内使用的清洁剂不能对硬件造成威胁。可能会损坏硬件的清洁剂包括具有以下特点的产品：

	
氨化的


	
基于氯的


	
基于磷酸盐的


	
具有丰富漂白剂


	
基于石化的


	
地板除蜡剂或修补剂。




使用建议的浓度也非常重要，因为即使是适当的药剂，处于不适当的浓度时也可能会产生损害。清洁剂在整个项目中应维持在良好状况，应避免过度应用。





季度任务

季度工作说明涉及更加详细而全面的净化计划，并且仅应由经验丰富的机房污染控制专业人员来执行。根据活动级别和存在的污染，这些措施应该每年执行三到四次。机房所有表面都应该彻底净化，包括橱柜、壁架、机框、架子和支撑设备。高处的壁架和照明设备以及通常可进入的区域应该根据需要进行处理或吸尘。垂直表面（包括窗户、玻璃隔板、门等）应进行彻底处理。在表面净化过程中应使用浸渍了粒子吸附材料的特殊灰尘布料。不要使用一般抹布或纤维布料来执行这些活动。在这些活动过程中不要使用任何化学品、蜡类或溶剂。

应该从所有外部硬件表面（包括水平表面和垂直表面）去除已落定的污染物。还应该处理装置的进气口和出气口格栅。不要擦拭装置的控制表面，因为可以通过使用轻微压缩的空气净化这些区域。清理键盘和人身安全控件时还应该特别小心。应该使用特殊处理的灰尘擦来处理所有硬件表面。应该使用光学清洁剂和防静电布料来处理显示器。不应该在计算机硬件上使用静电释放 (Electro-Static Discharge, ESD) 耗散化学品，因为这些药剂对于大多数敏感硬件都有腐蚀和损害。计算机硬件已充分设计为允许静电耗散，所以不需要任何进一步处理。彻底净化所有硬件和机房表面后，应该对活动地板进行 HEPA 吸尘和湿擦，如“周行动”中所详述。





两年任务

根据压力通风系统表面的状况和污染物累积程度，应每 18 个月到 24 个月对底层地板空隙进行一次净化。在一年内，底层地板空隙经历大量活动，而这些活动会造成新的污染物累积。虽然上述每周地板清洁活动将极大减少底层地板灰尘累积，但是一定数量的表面灰尘将迁移到底层地板空隙中。将底层地板维持在较高清洁程度这一点非常重要，因为此区域用作硬件的送风箱。最好在短期内执行底层地板净化处理，以减少交叉污染。执行此操作的人员应该进行充分培训来评估电缆连接和优先级。应针对可能的电缆处理和移动，对底层地板空隙的每个暴露区域单独进行检查和评估。在移动电缆之前，应检查和充分使用所有捻接和插接连接。执行所有底层地板活动时必须正确考虑空气分布和地板负荷。尝试维护活动地板完整性和适当的湿度条件时，应仔细管理从地板系统去除的地板砖数量。大多数情况下，每个工程队在任何时候打开活动地板都不能超过 24 平方英尺（六块砖）。还应该彻底净化活动地板的支撑网格系统，首先用真空吸尘器吸走松散碎屑，然后用湿海绵擦拭累积的残渣。橡胶垫（如果存在）以及组成网格系统的金属框也应从网格机件中取下并使用湿海绵进行清洁。应该记录和报告地板空隙内的任何异常状况，例如受损的地板悬挂物、地板砖、电缆和表面。







活动和过程

数据中心隔离是维护正常状况的一个不可或缺的因素。应避免在数据中心进行所有不必要的活动，并且仅限于必要人员可以进入数据中心。应限制轮班等定期活动，并且走动应限于远离硬件，从而避免意外接触。机房中工作的所有人员，包括临时员工和保洁人员，都应该进行关于硬件的最基本敏感性的培训，从而避免不必要的暴露。数据中心的受控区域应该与产生污染的活动彻底隔离。理想情况下，机械或人工活动较多的打印室、检查分类室、指挥中心或其他区域不应该直接接触到数据中心。这些区域的来往道路不应需要从主要数据中心区域经过。








词汇表


2N

一项可选的电源配置，提供交流电和直流电冗余。每四个磁带机一个电源，每个机械手一个电源。此配置需要另一个交流电源以支持其他系统 PDU。所有四个附件机架均会通电。另请参见 N+1。





ADI

自动化磁带机接口 (Automation drive interface)。支持用于 StorageTek Tape Analytics 的富数据。





access door（检修门）

CIM 任一侧的门，维修人员可以通过此门进入磁带库。





active slot（活动插槽）

可用于磁带存储的存储插槽。





active capacity（活动容量）

已授权磁带库用于存储的存储插槽数。这不能超过 installed capacity（安装的容量）或 purchased capacity（购买的容量）。与 allocated capacity（已分配容量）相同。





allocated capacity（已分配容量）

活动插槽的数目。已分配容量不能超过硬件激活文件定义的 purchased capacity（购买的容量）。与 active capacity（活动容量）相同。另请参见 unallocated capacity（未分配容量）。





audit（审计）

磁带库所有区域中磁带位置的清单，包括存储区和保留区中的插槽。在以下情况下执行审计：

	
磁带库在接通电源时初始化。


	
在未激活维修安全门的情况下打开和关闭一个或两个检修门之后。


	
可通过 SLC 创建物理审计请求。




另请参见 host audit（主机审计）、physical audit（物理审计）、verified audit（验证审计）和 virtual audit（虚拟审计）。





away library（远位磁带库）

从正面看位于 home library（主磁带库）左侧的 SL8500 磁带库。远位磁带库不向直通端口供电，或对其进行控制或恢复。





CAP

请参见 cartridge access port, CAP（磁带存取口）。





CLI

Command line interface（命令行界面）。





capacity（容量）

磁带库的存储容量。另请参见 active capacity（活动容量）和 installed capacity（安装的容量）。





cartridge（盒式磁带）

容纳磁带的容器，可以挂载到磁带机以读取或写入数据。磁带库使用数据磁带、诊断磁带和清洗磁带。





cartridge access port, CAP（磁带存取口）

内置到磁带库门板上的端口，用于导入或导出磁带。





cartridge array（磁带阵列）

一个塑料架，用于容纳多个未使用的磁带。SL8500 磁带库的内部挡板由 14 插槽的阵列组成，外部挡板由 13 插槽的阵列组成。





cleaning cartridge（清洗磁带）

一种盒式磁带，用于清洗磁带机中的磁带路径。清洗磁带是特定于磁带机的，在使用有限的次数后应更换。





customer interface module, CIM（客户接口模块）

SL8500 磁带库的正面模块，包含触摸屏操作面板并使维修人员可以接触到磁带库和维修托架。





DEM

请参见 drive and electronics module, DEM（磁带机和电子模块）。





dWWN

请参见 dynamic WWN（动态 WWN）。





data cartridge（数据磁带）

用于存储数据的磁带。





diagnostic cartridge（诊断磁带）

用于磁带机的诊断例程的磁带。





drive and electronics module, DEM（磁带机和电子模块）

SL8500 磁带库中的模块，用于容纳电子设备控制模块、配电设备 (power distribution unit, PDU)、电源、附件机架和设备，以及磁带库的磁带机。该模块位于磁带库的背面。





drive array（磁带机阵列）

安装在磁带机和电子模块中的用于挂载磁带机托盘组件的金属架。磁带机和电子模块最多可以容纳四个阵列组件，而每个阵列最多可以容纳 16 个磁带机托盘组件。





drive bay（磁带机托架）

磁带机阵列的一部分，可容纳一个磁带机托盘。





drive bay address（磁带机托架地址）

一个两位数的整数 (01–64)，代表插入磁带机托盘组件的物理位置。





drive tray（磁带机托盘）

用于将磁带机接入磁带库的金属机箱、电缆、电子卡和磁带机组合。磁带机托盘包含磁带机控制器卡（HBD 或 LOD）。





Dual TCP/IP（双 TCP/IP）

提供主机软件（ACSLS 或 HSC）与磁带库控制器之间的两个独立主机连接。





dynamic WWN（动态 WWN）

启用后，dWWN 会将名称指定给磁带库磁带机插槽，而不是指定给设备。更换磁带机时，新的磁带机将采用所更换磁带机的名称，因此无需重新配置系统。dWWN 会将名称指定给单个磁带机插槽，而不是指定给设备。





ECM

请参见 electronics control module, ECM（电子设备控制模块）。





ELS

请参见 Enterprise Library Software。





ERS

请参见 emergency robotics stop switch, ERS（紧急情况机械手停止开关）。





eject（弹出）

请参见 export（导出）。





electronics control module, ECM（电子设备控制模块）

包含 HBK 卡、HBC/HBCR 卡和 HBT 卡的模块。ECM 处理来自主机系统组件的命令，它对磁带库组件的活动进行协调，并监视来自传感器和交换机的状态输入。





elevator（升降装置）

垂直传输磁带的设备。SL8500 磁带库具有两个升降装置，可在磁带库的滑轨之间移动磁带。





emergency robotics stop switch, ERS（紧急情况机械手停止开关）

位于 CIM 小键盘上的开关，可以断开机械手的所有供电。





enter（装入）

请参见 import（导入）。





Enterprise Library Software

为大型客户机自动执行磁带操作的软件产品。





export（导出）

磁带库将磁带放置在 CAP 插槽中，以便操作员可以从磁带库中移除磁带。与 eject（弹出）相同。





FRU

Field replaceable unit（现场可更换单元）。





failover（故障转移）

在主路径出现故障时移至辅助或冗余路径的操作。





front controller module（正面控制器模块）

该模块用于容纳升降装置、CAP、转盘和安全屏障的控制器。





front facade（正面）

CIM 的外面部分，介于检修门之间，包含小键盘和本地操作面板。





get（获取）

一种机械手从插槽或磁带机中获取磁带的活动。





HLI/PRC

主机磁带库接口/面板行列 (Host Library Interface/Panel Row Column)





home library（主磁带库）

为 pass-thru port, PTP（直通端口）装置提供电源、信号和控制线的磁带库。从正面看，此磁带库位于复合磁带库的右侧。





host audit（主机审计）

更新主机数据库中磁带 vol-id 以及位置的过程。此审计由一个主机命令启动。





hot swap（热交换）

在系统电源仍处于打开状态且系统继续操作时移除和更换系统组件。





hot-pluggable（可热插拔）

此功能可以使 Oracle 服务代表在保持系统加电的情况下更换系统组件。还允许在不中断子系统使用的情况下继续执行硬件维护操作和硬件升级。与 hot swap（热交换）相对。





import（导入）

将磁带放入磁带存取口以便磁带库可以将其插入存储插槽的过程。





inactive slot（非活动插槽）

已显式取消激活因而无法用于磁带存储的存储插槽。





installed capacity（安装的容量）

磁带库中实际存在的存储插槽数。





interlock switch（互锁开关）

此开关可在打开前门时断开磁带库装置（不包括磁带机）的电源。





keypad（小键盘）

位于 CIM 上的界面。小键盘包含 CAP 开/关按钮、安全门锁和 ERS 按钮。





LCM

请参见 Library Content Manager, LCM（磁带库内容管理器）。





LTO

请参见 linear tape open format, LTO（线性磁带开放格式）。





library complex（复合磁带库）

通过 pass-thru port, PTP（直通端口）彼此相连的两个或多个 SL8500 磁带库。





library controller, LC（磁带库控制器）

磁带库中的 HBC/HBCR 卡，用于控制操作面板的操作并与操作面板进行通信。





Library Content Manager, LCM（磁带库内容管理器）

此软件提供对大型机自动化磁带环境的内容管理。可与主机软件组件、虚拟存储管理器以及磁带管理系统一起使用。





library operator panel（磁带库操作面板）

请参见 touch screen operator control panel（触摸屏操作控制面板）。





library storage module, LSM（磁带库存储模块）

通过直通端口连接至复合磁带库中的其他 LSM 的磁带库组件。功能与 SL8500 滑轨相同。





linear tape open format, LTO（线性磁带开放格式）

所创建的一组磁带数据格式标准，用于实现不同 LTO Ultrium 磁带机供应商之间的数据交换。这些标准允许共享数据磁带。





magazine（磁带盒）

一种用于容纳磁带的可移除阵列，位于磁带存取口 (cartridge access port, CAP) 中。





Multi TCP/IP（多 TCP/IP）

使用 TCP/IP 连接至多个磁带库，以在主机软件（ACSLS 或 HSC）和 SL8500 library complex（复合磁带库）之间提供冗余通信路径。





MIR

介质信息区域 (Media Information Region, MIR)。指示用户数据在物理介质上的位置的一种地图或目录。此功能允许磁带机优化对用户数据的访问，从而节省大量数据访问时间。加密磁带上的 MIR 数据不进行加密。





N+1

标准电源配置，通过向直流电网添加额外的直流电源来提供直流电源冗余。每两个机械手一个电源外加一个冗余电源，每八个磁带机一个电源外加一个冗余电源。有两个 PDU：一个系统 PDU，一个 N+1 PDU。仅附件机架 2 和 4 会通电。另请参见 2N。





online replacement（联机更换）

在磁带库仍在运行时更换或维修模块。维修人员可能需要在移除或更换模块之前关闭模块的电源。





operator panel（操作面板）

请参见 touch screen operator control panel（触摸屏操作控制面板）。





orphaned cartridge（孤立磁带）

分区磁带库中位于未分配插槽或磁带机（即，未分配给任何已定义分区的插槽或磁带机）中的磁带。在分区边界发生变化、删除分区或手动将磁带移至未分配或不可访问的插槽时，磁带可能会成为孤立磁带。





PDU

请参见 power distribution unit, PDU（配电设备）。





PLI

请参见 primary library interface, PLI（主磁带库接口）。





PTP

请参见 pass-thru port, PTP（直通端口）。





pass-thru port, PTP（直通端口）

一种机电设备，可在同一复合磁带库中的两个相邻磁带库存储模块之间传递磁带。library complex（复合磁带库）是通过直通端口相连的一系列磁带库。因为有四个滑轨，所以 SL8500 磁带库通过四个 PTP 连接在一起。另请参见 home library（主磁带库）和 away library（远位磁带库）。





physical audit（物理审计）

机械手执行以下操作时会发生物理审计：

	
扫描磁带库中的磁带位置


	
验证卷


	
更新磁带库控制卡清单


	
将磁带位置的状态设置为 true








physical capacity（物理容量）

磁带库中的存储插槽数。比较对象 active capacity（活动容量）。





power distribution unit, PDU（配电设备）

用于将交流电源线从一个入口分布到多个电源插座的设备。多个 PDU 可提供更高可用性，因为如果一个 PDU 或其备用电流源（如果 PDU 使用独立的交流源）断开电源，电源会继续工作。





primary library interface, PLI（主磁带库接口）

操作面板和磁带库控制器之间的通信路径。





purchased capacity（购买的容量）

已获得激活授权的存储插槽总数。该值由硬件激活文件定义。另请参见 allocated capacity（已分配容量）和 active capacity（活动容量）。





put（放置）

一种机械手将磁带放入插槽或磁带机的活动。





RE

请参见 redundant electronics, RE（冗余电子设备）。





RIM

请参见 robotics interface module, RIM（机械手接口模块）。





rail（滑轨）

(1) 上端机械手磁轨组件部分，用于提供机械手的电源和通信。(2) 可通过滑轨访问所有磁带插槽和磁带机。





redundant electronics, RE（冗余电子设备）

此功能在企业磁带库中提供故障转移保护。RE 使用两组磁带库控制器卡。在任意给定的时间，其中一组处于活动状态，而另一组处于备用状态。活动磁带库控制器可以故障转移到备用磁带库控制器，以响应来自 ACSLS 或 SLC 的命令。磁带库可以在出现磁带库卡故障时启动自动故障转移。





robot（机械手）

一种沿着磁轨水平移动的装置，用于在磁带库的各个位置之间运送盒式磁带。





robotics interface module, RIM（机械手接口模块）

包含弯曲滑轨和 pass-thru port, PTP（直通端口）组件的模块。





selected slot（选定的插槽）

当前无法用于磁带存储但在增加激活的容量时将由磁带库控制器自动激活的存储插槽。





service area（维修区域）

客户接口模块检修门与安全屏障之间的区域。在维修区域中，可以存储冗余或不工作的机械手以供维修，并可维修或更换其他装置。





service safety door（维修安全门）

可以降低和升高的马达驱动式屏障。此门用于将正面接口部件的维修区域与磁带库的其余部分隔开。通过 SSD，维修人员可以在打开和关闭正面检修门时安全维修或更换磁带库装置，而不会影响大多数磁带库操作。





slot（插槽）

磁带库中磁带的存储位置。





TTI

请参见 tape transport interface, TTI（磁带传输接口）。





tape drive（磁带机）

一种电机设备，用于移动磁带，包含将数据写入磁带和从磁带读取数据的装置。





tape storage area（磁带存储区域）

磁带库中存储磁带的区域。





tape transport interface, TTI（磁带传输接口）

用于控制和监视磁带移动的接口。





touch screen operator control panel（触摸屏操作控制面板）

带有触摸屏接口和面板挂载计算机的平板显示屏幕。此功能附加到磁带库的正面。





track（磁轨）

机械手移动的水平路径。





unallocated capacity（未分配容量）

可用于容量激活的存储插槽数。此值等于 purchased capacity（购买的容量）减去 allocated capacity（已分配容量）。





vol-id

指定给磁带的卷 ID。与 VOLSER 相同。





VOLSER

卷序列号。与 vol-id 相同。





VSM

请参见 virtual storage manager, VSM（虚拟存储管理器）。





VTCS

请参见 virtual tape control system, VTCS（虚拟磁带控制系统）。





VTD

请参见 virtual tape drive, VTD（虚拟磁带机）。





VTSS

请参见 virtual tape storage subsystem, VTSS（虚拟磁带存储子系统）。





verified audit（验证审计）

验证审计是从 SLC 调用的，并实际验证特定磁带插槽或特定范围插槽的状态。





virtual audit（虚拟审计）

虚拟审计是从 SLC 调用的，且仅在控制台屏幕（本地或远程皆可）中显示磁带清单。





virtual storage manager, VSM（虚拟存储管理器）

一种存储解决方案，可虚拟化虚拟磁带存储子系统缓冲区中的卷和传输，从而提高介质和传输的使用率。





virtual tape control system, VTCS（虚拟磁带控制系统）

主要的主机代码，用于控制有关 VTSS、VTV、RTD 和 MVC 的活动和信息。





virtual tape drive, VTD（虚拟磁带机）

用于模拟 VTSS 中的物理传输，类似于 MVS 的物理磁带传输。写入到 VTD 中的数据实际上被写入到 DASD 中。VTSS 包含 64 个 VTD，可以对 VTV 进行虚拟挂载。





virtual tape storage subsystem, VTSS（虚拟磁带存储子系统）

包含虚拟卷 (Virtual Volume, VTV) 和虚拟磁带机 (Virtual Drive, VTD) 的 DASD 缓冲区。VTSS 是一个 STK RAID 6 硬件设备，其中包含启用了传送装置仿真的微代码。RAID 设备可以从磁盘读取“磁带”数据或将“磁带”数据写入到磁盘中，也可以从 RTD 读取数据或将数据写入到 RTD 中。





virtual tape volume, VTV（虚拟磁带卷）

在操作系统中显示为实际磁带卷的 DASD 缓冲区部分。数据将写入到 VTV 或从 VTV 读取，而 VTV 可以迁移到实际磁带或从实际磁带重新调用。





WWN

请参见 World Wide Name（全局名称）。





World Wide Name（全局名称）

用于唯一标识各个设备和供应商的 64 位地址，与以太网接口的 MAC 地址类似。光纤通道网络上的每个端口都必须有自己的 WWN。WWN 不只是物理硬件地址。它还充当 SAN 节点的逻辑地址。如果任一相连的硬件发生更改，SAN 配置也会更改。如果设备出现故障或被更换，节点的 WWN 会发生更改，从而强制对 SAN 进行重新配置。每个磁带机托架都保留有三个全局名称：节点、端口 A 和端口 B。
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