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Oracle® Fusion Middleware Oracle Access Management管理者ガイド
11g リリース2 (11.1.2.3) for All Platforms
E61950-08
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E.3 管理者のロックアウト

問題

管理者がOracle Access Managementコンソールへ正常にログインできない。次のメッセージが表示されます。

Manually Change Identity Store Settings at OPSS Level and configure the IDMDOmainAgent.

原因

Access Managerでは、IAM Suiteアプリケーション・ドメインの認証情報すなわちOAM管理コンソール・ポリシーに基づき、Oracle Access Managementコンソールを保護します。このポリシーは、フォーム・チャレンジ・メソッドおよびLDAP認証モジュールを使用する単一の認証スキーム(OAMAdminコンソール・スキーム)に基づいています。LDAP認証モジュールは、システム・ストアとして指定されたユーザー・アイデンティティ・ストアをポイントしている必要があります。

たとえば、開発モードを設定して、(すべての管理者、ユーザーおよびその中で定義されるグループが)Oracle Internet Directoryを使用できるようにすれば、LDAP認証モジュールはこのユーザー・アイデンティティ・ストアをポイントし、システム・ストアとして指定することになります。

解決策

  1. ユーザー・アイデンティティを、指定されたシステム・ストアと埋込みLDAPストアの両方に挿入します。

  2. Oracle Access Managementコンソールにログインします。

  3. 「ネイティブ認証モジュールの管理」の説明に従い、指定されたシステム・ストアにより使用されるLDAP認証モジュールを構成して、適切なユーザー・アイデンティティ・ストアをポイントするようにします。