Contents

Getting Started ........................................................................................................... 25
Information for First Time Users .............................................................................. 25
Configuring Your System for Unifier ....................................................................... 25
Supported Browsers and Settings ............................................................................. 26
User name and Password ........................................................................................... 27
Sign In to and Sign Out of Unifier ............................................................................ 28
Security Warnings ...................................................................................................... 29
Signing In to Self-Service Portal .............................................................................. 29
File Viewer Option .................................................................................................... 30
Navigating in Unifier ................................................................................................. 30
  Unifier User Interface (UI) Content and Internationalization ............................ 30
  User Home Page ...................................................................................................... 31
  Navigator .................................................................................................................. 31
  Tabs and Navigation Bar .......................................................................................... 32
  Modes of Operation .................................................................................................. 33
  Breadcrumbs (locator links) ..................................................................................... 33
  Bookmarks ................................................................................................................ 34
User Preferences ......................................................................................................... 34
  Viewing Your Contact Information ......................................................................... 36
  Changing Your Password ......................................................................................... 36
  Changing the Time Zone or Date Format ............................................................... 38
  Changing Number and Currency Formats ............................................................ 39
  Changing Language ................................................................................................ 40
  Choosing a Viewer Option and Setting Viewer Exceptions .................................. 40
  Selecting Email Subscription Options .................................................................... 42
  Changing Unifier Default Landing Page ............................................................... 45
  Choosing a Proxy User ............................................................................................. 46
  Additional Support ................................................................................................... 48

Unifier Administration Mode .......................................................................................... 50
Company Administration ............................................................................................. 53
Sponsor Company versus Partner/Member Company .............................................. 55
Administrators ........................................................................................................... 57
Permission Based Security .......................................................................................... 59
Access Administration Mode ...................................................................................... 61
About dashboards in Unifier ....................................................................................... 63
Self-Service Portal ....................................................................................................... 65
Managing Public Searches ......................................................................................... 67
  Setting Public Search Permissions ......................................................................... 67
Managing Public Searches ................................................................. 67
Setting up Data Structure Setup Node .................................................. 69
Working with system and configurable Modules ................................... 71
  View available System and Configurable modules ............................. 71
  Add custom attributes to the Project/Shell Sponsorship module .......... 71
Working with Data Definitions ............................................................. 73
  About data definition properties ...................................................... 73
  Data definitions from uDesigner ..................................................... 74
  View Basic data definitions .......................................................... 74
  Add a Basic data definition .......................................................... 75
  View Cost Code data definitions ................................................... 76
  Add a Cost Code Definition .......................................................... 76
Adding and Managing Data Sets .......................................................... 77
  Add data set values to a pull-down menu or radio button ................. 77
  Add data set values to a multi-select Input data definition ............... 79
  Import data set values .............................................................. 79
  Modify or remove data set values ............................................... 81
  Reorder data set values .............................................................. 82
  Row numbering follows a relative numerical progression ................. 82
Working with Data Elements ............................................................... 83
  Access data elements ............................................................... 84
  Export data elements ............................................................... 84
  View data element usage ........................................................... 84
Configuring Dynamic Data Sets .......................................................... 85
  How to set up a dynamic data set ............................................... 85
  Access dynamic data sets ......................................................... 86
  View dynamic data set properties ............................................... 86
  Define the value set and behavior set values ............................... 87
  Import dynamic data set values .................................................. 88
  Delete a dynamic data set combination ....................................... 89
  Edit a dynamic data set combination ........................................... 89
  View dynamic data set usage ..................................................... 90
Creating Data Views ........................................................................... 91
  Grant Permissions for Data View Creation .................................... 92
  Create and Publish Data Views and Metadata ............................... 92
  View data (query results) and metadata (columns) in the view .......... 94
  Export data (query results) ......................................................... 95
  View Data View Usage in Reports and Data Cubes ....................... 96
  Edit data views ......................................................................... 96
Creating Data Cubes ........................................................................... 97
  Defining a Data Cube ............................................................... 97
  Selecting data sources .............................................................. 99
<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage user login information (Security tab)</td>
<td>141</td>
</tr>
<tr>
<td>Manage a user’s group membership (Groups tab)</td>
<td>142</td>
</tr>
<tr>
<td>Edit user permissions (Permissions tab)</td>
<td>143</td>
</tr>
<tr>
<td>View user’s project, program, and shell membership (Project/Program/Shell tabs)</td>
<td>143</td>
</tr>
<tr>
<td>Designate a proxy user (Proxy tab)</td>
<td>143</td>
</tr>
<tr>
<td>Send email to a company user</td>
<td>145</td>
</tr>
<tr>
<td>Unlock a locked user account</td>
<td>146</td>
</tr>
<tr>
<td>Change the status of multiple company users</td>
<td>146</td>
</tr>
<tr>
<td>View or print user audit log</td>
<td>146</td>
</tr>
<tr>
<td>Adding and Managing Partner Company Users</td>
<td>147</td>
</tr>
<tr>
<td>Add a partner company user</td>
<td>147</td>
</tr>
<tr>
<td>Manage partner company user status, groups and permissions</td>
<td>148</td>
</tr>
<tr>
<td>Change the status of multiple partner users</td>
<td>149</td>
</tr>
<tr>
<td>Adding and Managing Groups</td>
<td>150</td>
</tr>
<tr>
<td>Create a new group</td>
<td>150</td>
</tr>
<tr>
<td>Add users to a group (Members tab)</td>
<td>151</td>
</tr>
<tr>
<td>Edit group permissions (Permissions tab)</td>
<td>151</td>
</tr>
<tr>
<td>Managing users in bulk</td>
<td>152</td>
</tr>
<tr>
<td>Change user group assignments or add new users in bulk</td>
<td>152</td>
</tr>
<tr>
<td>Change user status in bulk</td>
<td>153</td>
</tr>
<tr>
<td>Update multiple company or partner users</td>
<td>154</td>
</tr>
<tr>
<td>Creating and Managing User Preference Templates</td>
<td>154</td>
</tr>
<tr>
<td>Create a User Preferences Template</td>
<td>155</td>
</tr>
<tr>
<td>Update Users with the User Preferences Template</td>
<td>155</td>
</tr>
<tr>
<td>View update users history</td>
<td>156</td>
</tr>
<tr>
<td>Cancel a user update request</td>
<td>156</td>
</tr>
<tr>
<td>Creating an Approved Email List for Project and Shell Mailboxes</td>
<td>157</td>
</tr>
<tr>
<td>Import and Export Email Addresses</td>
<td>158</td>
</tr>
<tr>
<td>Managing permissions and access control</td>
<td>159</td>
</tr>
<tr>
<td>Permission tab versus Access Control</td>
<td>159</td>
</tr>
<tr>
<td>Access Control</td>
<td>159</td>
</tr>
<tr>
<td>Permissions tab</td>
<td>160</td>
</tr>
<tr>
<td>Edit user or group permissions using Access Control</td>
<td>160</td>
</tr>
<tr>
<td>Create or edit a permission template</td>
<td>161</td>
</tr>
<tr>
<td>Generate and print an Access Information report</td>
<td>162</td>
</tr>
<tr>
<td>Working with the License Manager</td>
<td>163</td>
</tr>
<tr>
<td>View License Manager terms and usage</td>
<td>163</td>
</tr>
<tr>
<td>Set up License Manager scheduled runs and notifications</td>
<td>164</td>
</tr>
<tr>
<td>Print license manager information</td>
<td>165</td>
</tr>
<tr>
<td>View or print the License Manager audit log</td>
<td>165</td>
</tr>
<tr>
<td>Running System Usage Reports</td>
<td>166</td>
</tr>
</tbody>
</table>
Run a System Usage Report ................................................................. 166
System Usage Report Types ................................................................. 168
Adding & Managing Partner Companies .................................................. 179
  Add a partner company ........................................................................ 179
  Remove a partner company ................................................................ 179
  View partner company profile ............................................................. 180
Configure Project Numbering, Cost Codes, and Status .............................. 181
  Create and manage project categories (organize projects) ..................... 181
Setting up Multiple Company Calendars ................................................. 185
  Setting Multiple Calendar Permissions ................................................. 185
  Creating Multiple Calendars ................................................................. 186
  Modify, delete, or mark a calendar as default ...................................... 187
Manage Support and e-Learning contact information (Contact tab) ............ 189
Manage company password policy (Security tab) ....................................... 191
Manage company addresses (Address tab) ............................................... 193
Access Company Details ......................................................................... 195
Production Bundles ................................................................................ 197
  Accessing Production Bundles Node .................................................... 198
  Production Bundles Log ....................................................................... 198
  Creating Production Bundles ................................................................. 200
  Additional Setup Options ...................................................................... 202
  Importing Production Bundles ............................................................... 209
Custom Dashboards ................................................................................ 211
  Creating Company or Shell Custom Dashboards ..................................... 211
Granting Custom Dashboard Permissions ................................................... 211
  Configuring a Company Custom Dashboard ........................................... 212
  Modify the General Properties of a Company Dashboard ...................... 212
  Define queries for Company Dashboard data cubes ............................... 213
  Specify cache details ............................................................................. 214
  Grant Company Dashboard View permission ....................................... 215
  Configuring a Shell Dashboard ............................................................... 215
  Modify the General Properties of a Shell Custom Dashboard ................. 215
  Define queries for shell dashboard data cubes ...................................... 216
  Modifying a custom dashboard .............................................................. 217
    Delete a custom dashboard ................................................................ 217
    Find a custom dashboard .................................................................. 218
    Download XML data associated with a custom dashboard .................. 218
    Refresh the Company Dashboard cache .............................................. 219
Project Administration ............................................................................. 221
Creating and Managing Projects ............................................................. 221
  How to create and setup a project ......................................................... 221
  Creating a Project Template ................................................................. 222
Access project templates .......................................................... 222
Create a project template ....................................................... 222
Create a project template by copying a template or project ........ 223
Set up modules in the project template ................................. 224
Manage Project Templates ..................................................... 226
Defining Project (and Project Template) Properties ................. 226
Define general project properties (General tab) ....................... 226
Define project location (Location tab) ................................. 228
Add project currencies (Standards tab) ................................. 229
Add a project image (Standards tab) ............................. 230
Distribute an External Email Address for the Project (Standards Tab) ... 230
Set up project progress tracking (Progress tab) ...................... 232
Add links to other project-related web pages (Links tab) .......... 233
Select a project custom attribute (Custom tab) ....................... 234
Create a project calendar (Calendar tab) ............................... 234

Creating a Project ................................................................ 235
Grant permission to administer projects or project templates .... 235
Create a project by copying a template or project .......... 235
Create a new project manually ........................................... 236
Add Cost Sheet ................................................................ 237
Manage Projects ................................................................. 237
Activate or deactivate a project ......................................... 238

Updating Projects ................................................................. 238
General procedure for updating project information .......... 239
Update users .................................................................... 239
Update groups ................................................................... 240
Update business processes and BP setups ......................... 241
Update user-defined reports ............................................. 242
Update access control ....................................................... 243
Update cost sheet columns in a project ............................. 244
Cost Column Project Update Rules ..................................... 245
Update Schedule of Values (SOV) Structure ......................... 246
Update commitment funding structure .............................. 247
Update cash flow curve properties and permissions .......... 247
Update project cost or fund rules ................................... 249
Update gates setups ......................................................... 250
View update history ......................................................... 251
Cancel a project update request ....................................... 251

Managing Member Companies ........................................... 251
Add a member company to a project ................................ 252
View member company profile ........................................ 252
Remove a member company from a project ....................... 252
Managing Project Users and Groups ................................................................. 253
  Add a user to a project ................................................................................ 253
  View or edit a project user’s profile .............................................................. 254
  Create and Manage Project Groups .............................................................. 255
  Grant project user permissions through Project Access Control .......... 256
  Generate and print access information report ............................................ 256

Setting Up Automatic Status Update ............................................................ 256

Setting Up Gates ............................................................................................ 257
  Example of a gates setup and conditions .................................................... 258
  Define the project phase list ........................................................................ 258
  Create a gates setup ...................................................................................... 259
  Add project phases to the gates setup (Settings tab) ...................................... 259
  Configure Gates conditions ........................................................................... 260
  Configure gate elements ............................................................................... 261
  Change the order of project phases ............................................................... 262
  Define gates runs schedule (Schedule tab) .. ........................................... 262
  Activate or deactivate a gates setup ............................................................. 262
  Set user permissions for gates ..................................................................... 263

Create an automatic project status update setup ............................................. 263
  Choose the order of non-active statuses (Settings tab) .................................. 264
  Define status change query and trigger conditions (Settings tab) .................. 264
  Define project status update schedule (Schedule tab) .................................. 265
  Activate or deactivate an auto-update status setup ......................................... 265
  Set permissions for automatic update of project status .................................. 266

Program Administration .................................................................................. 267
  Creating and Managing Programs ............................................................... 267
  Creating a Program ....................................................................................... 267
  Defining Program Properties ...................................................................... 268
    Define Program General Properties (General tab) ........................................ 268
    Add or Remove Projects or Shells From a Program (Projects tab) ............... 268
    Set Up Program Progress Tracking (Progress tab) ...................................... 269
    Add Links to Other Program-Related Web Pages (Links tab) ...................... 270

Program User Administration ........................................................................ 270
  Add Users or Groups to a Program ............................................................... 270
  Grant Program Permissions (Access Control) .............................................. 271

Importing and Deploying a Design ................................................................. 273

Exporting a Design .......................................................................................... 277

Shells Administration ....................................................................................... 279
  Dedicated Mailbox for the Shell ................................................................... 279
  User Permissions and Navigation ............................................................... 280
  Setting up Shells ......................................................................................... 280

Importing Shells .............................................................................................. 280
Migration limitations ............................................................ 337
Migration considerations ........................................................ 338
Migration mapping of project data elements to shell data elements .... 338
Migrate projects to shells ....................................................... 339
Export the migration template ................................................ 340
Modify the exported csv template ............................................ 340
Initiate migration of standard projects to WBS shells ...................... 341
View migration history .......................................................... 341
Test for WBS shell creation .................................................... 342
Internationalization and CSV Files .......................................................... 343
Internationalization and Web Services ..................................................... 347
Web Services and Internationalization........................................ 347
Number formatting of data ..................................................... 347
Get Web Services ................................................................ 347
Internationalization (Email Notifications) .................................................. 348
Internationalization (Support for Tools) .................................................... 348
Internationalization (BI Publisher Custom Reports). ......................... 349
Internationalization (Dashboards) .................................................. 350
Internationalization (Help Files) .................................................... 350
Internationalization (Spell Check) .................................................... 350
Internationalization (Date and Time Zone Formats) ...................... 351
Internationalization (Audit Log) .................................................... 351
Setting Up Business Processes ........................................................ 353
Master Logs ..................................................................................... 353
Advanced Logs and Standard Logs ........................................... 354
Importing Business Processes (BPs). .............................................. 355
Configuring Business Processes (BPs) .............................................. 355
Create Custom-Designed BP Print Layout (Custom Print tab) .......... 356
Configure and Activate a BP ....................................................... 361
Configure a BP workflow (Workflow tab) ..................................... 363
Create a custom XML template in MS Word ................................ 364
Business Processes Production Bundle Configuration ..................... 366
General Procedures for Setting up Business Processes .................. 366
Loading a Business Process ....................................................... 367
Setting Up a Non-Workflow Business Process ............................. 368
Basic non-workflow set up in General tab and Settings tab .......... 368
Selecting BIP Custom Print (Format > Custom) .......................... 370
Set up email notification for a non-workflow BP ......................... 370
Set up auto-creation for a non-workflow BP or planning item ....... 372
Set up record and line item copy options .................................. 376
Single-record business processes ............................................. 377
Setting Up a Workflow Business Process ..................................... 378
Contents

Basic workflow set up in General tab ................................................................. 378
Selecting BIP Custom Print (Format > Custom) .................................................. 379
Designate additional editors for Business Process records ............................ 380
Set up email notification for a workflow BP ...................................................... 380
Set up auto-creation for a workflow BP .............................................................. 382
Workflow setup in General and Setting tabs ..................................................... 385
Define the business process workflow .................................................................. 386
Overall workflow settings .................................................................................. 386
Settings for standard workflow steps ................................................................ 387
About Completion Policies, Resolving Actions, and Their Statuses .................... 395
Settings for conditional routing steps ................................................................. 396
Settings for auto-create steps ............................................................................ 397
Settings for sub-workflows ............................................................................... 397
Creating and Adding Business Process Help Files ........................................... 398
About Auto-creating a Business Process record or Planning Item Based on conditions or frequency ................................................................. 399
Grouping line items into single records ............................................................ 401
Bypassing the I Step ......................................................................................... 402
Auto-Creation Protocol for Bypassing the I Step ............................................. 402
Rules for Checking Conditions for Auto-Creation ......................................... 403
Rule 1 ........................................................................................................ 403
Rule 2 ........................................................................................................ 403
Rule 3 ........................................................................................................ 403
Setting up auto-creation of cash flow curves from contracts ....................... 404
Copying Workflow Setups from Other Schemas ............................................. 405
At the Company Level, Copy a Setup from Another Setup in the Same BP ........ 407
Copy a Setup from One Project/Shell Template to Another ............................ 408
Copy a Setup from a Project/Shell to a Template ........................................... 409
Importing Workflow Setups From One Company to Another Company In the Same Environment ................................................................. 410
Importing Workflow Setups from One Environment to Another .................... 412
Import a Setup From One Company to Another Company ............................ 413
Import a Setup for a BP to a Project/Shell Template for the Same BP in Another Environment ................................................................. 414
Setting up a blanket purchase order summary template ............................... 415
Setting up an RFB business process ................................................................. 416
Verify the RFB Has Been Designed Correctly ................................................. 417
Set Up a Bid Management Account in Primavera Unifier ................................. 417
Set Up the RFB in Unifier .............................................................................. 417
Business Process Permission Settings ............................................................... 418
Business Process Functionality in Unifier ........................................................ 418
Query-based Tab in Business Processes ............................................................ 420
Setting Up Updates for Business Process Records ................................................. 423
  Company Workspace and Business Process Updates ........................................ 423
  Company Workspace and Preventive Maintenance Type BP ...................... 424
  Project/Shell and Business Process Updates .............................................. 427
  Project/Shells and Preventive Maintenance Type BP ............................ 428
Setting Up the Asset Manager ............................................................................ 429
  Importing Asset Classes ........................................................................... 431
  Configuring the Asset Manager ................................................................. 431
  Asset Manager Production Bundle Configuration ........................................ 432
  Grant asset class template permissions ................................................... 432
  Creating and Managing Asset Templates .................................................... 432
  Create an asset template ......................................................................... 432
  Create a new template from an existing template or asset ....................... 433
  Creating a Depreciation Schedule ............................................................... 434
  Straight line method ............................................................................... 435
  Without Salvage ..................................................................................... 435
  With Salvage ......................................................................................... 435
  Example ................................................................................................. 435
  Double decline method ............................................................................ 436
  Example ................................................................................................. 436
  Sum of year digits .................................................................................. 436
  Manual .................................................................................................... 437
  Example ................................................................................................. 437
  Set up a depreciation schedule ............................................................... 437
  Verify the depreciation data source list .................................................... 439
Setting up and Managing Asset Sheets ........................................................... 440
  Create an asset sheet column ................................................................. 440
  Add a column for business process data ............................................... 442
  Add a column for project cost data ....................................................... 442
  Add a formula column ............................................................................ 442
  Create an asset summary sheet column .................................................. 444
  Edit asset details from the asset sheet ..................................................... 444
Managing Asset Sheet Properties ................................................................. 444
  Map asset sheet columns to company account codes ............................ 446
  Associating Projects with Asset Classes .................................................. 447
Setting Up Code-Based and Records-Based Configurable Manager .......... 449
  Setting Permissions to Import Configurable Managers ......................... 449
  Importing Code and Records-Based Configurable Managers ................ 450
  Setting Permissions to Import Classes ...................................................... 450
  Importing Classes for Code and Records-based Configurable Managers ... 450
  Configure configurable manager classes ............................................... 450
  Run an error check on a class .................................................................. 451
Configure a Data Picker for the manager .......................................................... 451
Setting Template Administration Permissions ............................................. 453
Creating Class Template Sheets .................................................................. 453
  Create a class template ........................................................................ 453
  Add columns to sheet templates .......................................................... 454
  Copy sheets under project or shell templates ....................................... 455
  Manage sheet properties ...................................................................... 456
Setting User Permissions for Code and Records-Based Managers .............. 456
Setting Up the Cost Manager ..................................................................... 457
Cost Manager Overview ........................................................................... 457
  Cost Sheets ...................................................................................... 457
  Funding Manager ............................................................................. 458
  Cash Flow .......................................................................................... 458
  Earned Value ..................................................................................... 459
  Schedule of Values ............................................................................. 459
  Generic Cost Manager ......................................................................... 459
  About Cost Managers and Unifier functional areas ......................... 459
Cost Managers and Unifier Functional Areas ............................................. 460
About Currencies and Exchange Rates ...................................................... 460
  Managing currencies and exchange rates .......................................... 465
  Importing and Exporting Exchange Rates ........................................ 467
Setting up Cost Sheets ............................................................................... 469
  How to set up the cost manager (cost sheets) .................................... 469
  Importing the Cost Attribute Form ...................................................... 470
  Configuring Cost Manager Permissions ............................................. 470
  Creating and Setting up Cost Templates ............................................. 470
  Create a new cost sheet template ...................................................... 471
  Define cost sheet default view (General tab) ....................................... 471
  Define cost code structure (Structure tab) .......................................... 472
  Define cost sheet options (Options tab) ............................................. 474
  Edit cost sheet template structure or properties ............................... 475
  Open the cost sheet template ........................................................... 476
  Adding Cost Columns ........................................................................ 476
  About cost sheet columns ................................................................. 476
  Add a cost column ............................................................................ 476
  Project or shell cost column data sources ......................................... 479
  Create a formula in a cost column ...................................................... 480
  Example Formula ............................................................................... 481
  Adding Cost Rows (WBS Codes) ......................................................... 481
  About the WBS details window ............................................................ 482
  Create a summary row ...................................................................... 483
  Import cost rows (WBS codes) ........................................................... 483
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating Worksheet Templates</td>
<td>484</td>
</tr>
<tr>
<td>Create a new worksheet template</td>
<td>484</td>
</tr>
<tr>
<td>Open the worksheet template</td>
<td>485</td>
</tr>
<tr>
<td>Create a worksheet column</td>
<td>485</td>
</tr>
<tr>
<td>Create a worksheet in a project or shell</td>
<td>485</td>
</tr>
<tr>
<td>Delete a worksheet</td>
<td>486</td>
</tr>
<tr>
<td>Managing Cost Templates</td>
<td>486</td>
</tr>
<tr>
<td>View or edit cost template properties</td>
<td>486</td>
</tr>
<tr>
<td>Delete a template</td>
<td>486</td>
</tr>
<tr>
<td>Edit a cost column</td>
<td>487</td>
</tr>
<tr>
<td>Move a column</td>
<td>487</td>
</tr>
<tr>
<td>Delete a column</td>
<td>487</td>
</tr>
<tr>
<td>Hide cost sheet columns</td>
<td>487</td>
</tr>
<tr>
<td>Edit a cost row</td>
<td>488</td>
</tr>
<tr>
<td>View or edit WBS details</td>
<td>488</td>
</tr>
<tr>
<td>Creating a Project or Shell Cost Sheet</td>
<td>489</td>
</tr>
<tr>
<td>Add cost sheet columns and rows</td>
<td>490</td>
</tr>
<tr>
<td>Add column view or edit restrictions</td>
<td>490</td>
</tr>
<tr>
<td>Cost sheet column permission matrix</td>
<td>491</td>
</tr>
<tr>
<td>Effects of column restrictions on viewing a worksheet</td>
<td>492</td>
</tr>
<tr>
<td>Add WBS breakdown</td>
<td>492</td>
</tr>
<tr>
<td>Add notes and attachments to a WBS code</td>
<td>493</td>
</tr>
<tr>
<td>Modify cost sheet default view</td>
<td>493</td>
</tr>
<tr>
<td>Setting up a Program Cost Sheet</td>
<td>494</td>
</tr>
<tr>
<td>Access the program cost sheet has</td>
<td>494</td>
</tr>
<tr>
<td>Add Program Cost Sheet Columns</td>
<td>495</td>
</tr>
<tr>
<td>Program cost sheet data sources</td>
<td>495</td>
</tr>
<tr>
<td>Create and manage program cost groups</td>
<td>496</td>
</tr>
<tr>
<td>Setting up the Company Cost Sheet</td>
<td>497</td>
</tr>
<tr>
<td>Create a company cost sheet</td>
<td>497</td>
</tr>
<tr>
<td>Modify company cost sheet default view</td>
<td>497</td>
</tr>
<tr>
<td>Add Company Cost Sheet Columns</td>
<td>497</td>
</tr>
<tr>
<td>Company Cost Sheet Data Sources</td>
<td>498</td>
</tr>
<tr>
<td>Map cost sheet column to an account code</td>
<td>499</td>
</tr>
<tr>
<td>Setting up a Company Accounts Sheet</td>
<td>500</td>
</tr>
<tr>
<td>How to set up a company accounts sheet</td>
<td>500</td>
</tr>
<tr>
<td>Import Company Account Code Attributes Form</td>
<td>501</td>
</tr>
<tr>
<td>Create a company accounts sheet</td>
<td>501</td>
</tr>
<tr>
<td>Add a column to an accounts sheet</td>
<td>502</td>
</tr>
<tr>
<td>Adding and Managing Accounts Sheet Rows</td>
<td>503</td>
</tr>
<tr>
<td>Add rows to the accounts sheet</td>
<td>503</td>
</tr>
<tr>
<td>Delete accounts sheet rows</td>
<td>503</td>
</tr>
</tbody>
</table>
Contents

Import account sheet rows ................................................................. 504
Activate an account code ................................................................. 504
Modify accounts sheet default view ................................................. 504

Setting up the Funding Manager .................................................. 505
How to set up the Funding Manager ............................................. 505
Importing Fund Attribute Form ..................................................... 507
Creating a Company Funding Sheet ............................................. 508
Add columns to the company funding sheet .................................... 508
Add rows (Funds) to the company funding sheet ............................... 512
Creating a Project or Shell Funding Sheet Template ...................... 514
Add a column to the funding template (or project/shell funding sheet) 514
Add a funding column to project or shell cost sheet ....................... 517
Add rows to the funding template (or project/shell funding sheet) ....... 518
Creating a Project/Shell Funding Sheet ................................ 519
Add columns to the project/shell funding sheet .............................. 519
Add project or shell funds (rows) .................................................... 520
Define Fund Assignment Options for Project/Shell Funding ............... 520
Set up funding assignment options .............................................. 520
Set fund assignment status and order ............................................ 523
Set fund assignment order at the WBS level ................................. 523
Set fund assignment order at SOV level ........................................ 524
Creating Commitment Funding Sheet Templates ............................ 526
Add and Manage commitment funding sheet columns ...................... 526
Define Fund Assignment Options for Commitment Funding .......... 530
Define commitment fund assignment rules ................................ 530
Define commitment fund assignment details ................................ 531

Setting Up Schedule of Values (SOV) ............................................. 532
How to Set Up SOV .................................................................... 533
Creating an SOV Template ......................................................... 534
Add SOV Columns ..................................................................... 535

Setting Up Cash Flow .................................................................. 537
How to Set Up Cash Flow ............................................................. 539
Grant Yourself Permissions to Configure Cash Flow ....................... 540
Create a Cash Flow Distribution Profile ....................................... 540
Delete a Distribution Profile ......................................................... 541
Edit a Distribution Profile ............................................................. 542
Creating Cash Flow Data Sources ............................................... 542
Delete a Cash Flow Data Source .................................................... 543
Edit a Cash Flow Data Source ....................................................... 544
Distributing Cost Data ................................................................. 544
Cash Flow Curve Templates ......................................................... 546
Create a Template for a Cash Flow Curve ................................. 547
Create Roll-up Templates ...................................................... 549
Granting Cash Flow User Mode Permissions ............................... 551
Setting up the Rules Engine .......................................................... 552
About Rules ........................................................................ 552
About control sources and levels .............................................. 552
Control Source ..................................................................... 553
Rule Levels ........................................................................ 553
Access a rule or rule template ................................................. 554
Creating Rules and Rules Templates .......................................... 554
Create a rule template.......................................................... 554
Create a project or shell rule .................................................. 557
Create a company rule .......................................................... 558
Validating and Activating Rules ................................................ 558
Validate a rule ................................................................... 558
Activate or Inactivate a rule ................................................... 559
Manage Rules ..................................................................... 559
Setting up a Generic Cost Manager .............................................. 560
Setting Generic Cost Manager Permissions ............................... 561
Import Generic Cost Manager .................................................. 561
Import Generic Cost Manager Attribute form ................................ 561
Creating a Cost Sheet Template for a Generic Manager ............... 561
Create a Generic Cost Sheet template ....................................... 561
Structure a Generic Cost Sheet template .................................... 562
Setting Generic Cost Sheet Template Permissions ........................ 564
Creating a Generic Cost Sheet ................................................. 564
Setting up the Commitment Summary Template ............................ 564
Create a Commitment Summary Sheet Template ......................... 564
Create a Commitment Summary Sheet ....................................... 566
Update a Commitment Summary Sheet from a template ............... 566
Setting Up the Document Manager .............................................. 567
Document and Folder Properties ............................................... 567
Permissions ........................................................................ 568
Categories ........................................................................ 568
Importing Document Manager Attribute Forms ........................... 568
Setting Document Manager Administration and User Permissions ........ 569
Working with Folder Structure Templates .................................... 569
Lock and unlock the first-level folder structure ............................. 571
Setting Up the Planning Manager .............................................. 573
Importing a Planning Type ........................................................ 573
Granting Yourself Permissions ............................................... 573
Creating a Default Structure for the Planning Sheet ......................... 574
Add a column based on a formula calculation ............................... 575
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a column based on a database query ............................................. 577</td>
</tr>
<tr>
<td>Create a planning column group .............................................................. 578</td>
</tr>
<tr>
<td>Edit Planning Sheet Properties ............................................................... 579</td>
</tr>
<tr>
<td>Configuring the planning type ................................................................. 579</td>
</tr>
<tr>
<td>Planning Manager Production Bundle Configuration ................................ 580</td>
</tr>
<tr>
<td>Granting planning setup permissions ....................................................... 580</td>
</tr>
<tr>
<td>Loading the Planning Manager ................................................................. 581</td>
</tr>
<tr>
<td>Granting User Permissions ...................................................................... 581</td>
</tr>
<tr>
<td>Master Log for the Planning Manager ..................................................... 582</td>
</tr>
<tr>
<td>Setting Up the Portfolio Manager ............................................................ 583</td>
</tr>
<tr>
<td>Import a Portfolio .................................................................................... 584</td>
</tr>
<tr>
<td>Grant Yourself Permissions .................................................................... 584</td>
</tr>
<tr>
<td>Create Period Structures ....................................................................... 585</td>
</tr>
<tr>
<td>Configure the Portfolio Manager ............................................................ 586</td>
</tr>
<tr>
<td>Portfolio Manager Production Bundle Configuration .................................. 590</td>
</tr>
<tr>
<td>Delete Columns From a Sheet .................................................................. 591</td>
</tr>
<tr>
<td>Grant User Permissions ........................................................................... 591</td>
</tr>
<tr>
<td>Setting Up the Resource Manager ............................................................ 593</td>
</tr>
<tr>
<td>Set Up Resource Manager ....................................................................... 593</td>
</tr>
<tr>
<td>Configure the Resource Manager at the company level ......................... 594</td>
</tr>
<tr>
<td>Resource Manager Production Bundle Configuration .................................. 595</td>
</tr>
<tr>
<td>Creating Roles and Resources ................................................................. 595</td>
</tr>
<tr>
<td>Create a role ........................................................................................... 595</td>
</tr>
<tr>
<td>Add a billable rate to a role (Rates tab) .................................................. 596</td>
</tr>
<tr>
<td>Add resources to a role (Resources tab) ................................................... 596</td>
</tr>
<tr>
<td>Import roles ............................................................................................. 596</td>
</tr>
<tr>
<td>Create a resource .................................................................................... 597</td>
</tr>
<tr>
<td>Add a role to a resource (Roles tab) ........................................................ 597</td>
</tr>
<tr>
<td>Add a skill set to a resource (Skills tab) .................................................. 598</td>
</tr>
<tr>
<td>View and manage resource booking details (Calendar tab) ..................... 598</td>
</tr>
<tr>
<td>View resource project/Shell booking information (Projects/Shells tab) ...... 598</td>
</tr>
<tr>
<td>Import resources ..................................................................................... 599</td>
</tr>
<tr>
<td>Update resource information by importing ............................................. 599</td>
</tr>
<tr>
<td>Setting up the Resource Manager in Projects or Shells ............................ 599</td>
</tr>
<tr>
<td>Set up the Resource Manager in a project/shell ....................................... 599</td>
</tr>
<tr>
<td>Set up the Resource Manager in a project or Shell template ..................... 601</td>
</tr>
<tr>
<td>About Resource Manager sheets ............................................................. 602</td>
</tr>
<tr>
<td>Setting Up the Schedule Manager ............................................................ 603</td>
</tr>
<tr>
<td>Additional Options for Setting Up the Schedule Manager ....................... 603</td>
</tr>
<tr>
<td>Importing an Activity Attribute Form ...................................................... 604</td>
</tr>
<tr>
<td>Create Schedule Sheet Templates ............................................................. 604</td>
</tr>
<tr>
<td>Grant Schedule Manager and Custom Calendar Permissions to Users .......... 605</td>
</tr>
</tbody>
</table>
Refresh Schedule Sheet Data ................................................................. 605
Updating Schedule Sheet Properties from Templates ............................... 606
  What you can do with schedule sheet update: .................................. 606
Update Schedule Sheet Activities from Templates ..................................... 608
  What you can do with linked templates: ......................................... 608
  What you cannot do with linked templates: ................................... 608
Enable and Disable Schedule Sheet Linking ........................................... 609
Link a Template to a Project or Shell Schedule Sheet ............................ 609
Update Linked Schedule Sheets from Project or Shell Templates .......... 609
Unlink a Template From a Project or Shell Schedule ............................. 610
View Linked Schedule Sheets ............................................................. 610
Importing Schedule Files .......................................................................... 610
  Primavera considerations: ............................................................. 611
  Microsoft Project considerations: .................................................. 611
Define data mapping ........................................................................... 612
Import CSV, XML, or MPP files to create or modify schedule sheet activities ................................................................. 615
  WBS code options for Primavera XML and Microsoft Project XML ....... 616
Primavera XML and Microsoft Project XML WBS Code interpretation .... 617
Updating User Information in Schedule Sheet Properties Using Bulk Processing ................................................................. 617
Creating Activity Sheet Templates .......................................................... 618
Scope Management Setup ........................................................................ 620
  Setting up Scope Management for Activities ................................... 621
About activity-level editing .................................................................... 621
  Set up activity-level editing ............................................................. 623
Space Manager ........................................................................................ 625
  About the uCAD Plug-In ................................................................. 627
  Space Manager Prerequisites .......................................................... 627
Importing and Configuring Levels and Space Types .................................. 627
Configuring Levels and Space Types ...................................................... 628
  Configuring a Level or Space Type .................................................. 628
  Configuring Fill Colors and Text for Space Types ............................. 629
Space Manager Production Bundle Configuration .................................... 630
Creating Level Sheet Templates .............................................................. 630
Creating a Stack Plan Template ............................................................... 631
Setting Permissions for the Space Manager ............................................. 633
Query Tabs in Spaces ............................................................................. 633
Setting Up User-Defined Reports (UDRs) ................................................ 637
  Creating and Setting Up a UDR Template ....................................... 637
    UDR Data Types ........................................................................... 637
    Accessing UDR Templates .......................................................... 641
Creating a UDR Template .............................................................. 642
Tagging a UDR Template for Production ....................................... 644
General tab (all reports) .............................................................. 644
Data Elements tab (tabular report) .............................................. 645
Data Elements tab (cross tab report) .......................................... 646
Data Elements tab (summary report) .......................................... 647
Data Elements tab (alert report) .................................................. 648
Data elements ........................................................................... 649
Query tab (all reports) ............................................................... 649
Layout tab (all reports) .............................................................. 650
Layout tab (Page Setup setting) .................................................. 650
Layout tab (Title Page, Header, Footer, Summary Page settings) .... 650
Layout tab (Cross Tab setting) .................................................... 651
Layout tab (Group By setting) ..................................................... 652
Projects tab (program-level reports, all types) ......................... 652
Projects/Shells tab (program-level and company-level reports, all types) 652
Shells tab (shell-level reports, all types) .................................... 653
Permission tab (all reports) ......................................................... 653
Schedule tab (all reports) ........................................................... 654
Add and manage data elements (columns) to the report .............. 655
Manage report column (data element) properties ....................... 657
Set auto range .......................................................................... 658
Grant report edit or run permissions to other users ...................... 658
Define report queries (query condition) ..................................... 659
Set up title page, header, footer and summary page .................... 660
Schedule report runs ................................................................. 661
Report Run Times .................................................................... 662
Generate reports with incremental data between scheduled runs ..... 662
Enable a report for web services integration ............................... 662
Creating User-Defined Project, Shell, Program, and Company Reports 665

Access user-defined reports ...................................................... 665
Create a UDR from a report template ......................................... 665
Editing or Deleting User-Defined Reports ................................. 666
Importing User-Defined Reports into Project or Shell Templates 666
Translating Custom Strings (Internationalization) ....................... 669

Internationalization Node Properties ....................................... 669
Displaying Custom Strings and System Strings ......................... 671
Administration Mode ............................................................... 672
Assigning Permissions .............................................................. 673
Translating Methods .................................................................. 673
Internationalizing Unifier Environments (Staging and Production) 675

Unifier Mobile Application for iOS.................................................. 676
## Unifier Administration Guide

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unifier and Third-Party Applications</td>
<td>677</td>
</tr>
<tr>
<td>Unifier and Primavera Analytics</td>
<td>679</td>
</tr>
<tr>
<td>Analytics Node</td>
<td>681</td>
</tr>
<tr>
<td>Analytics Log Properties</td>
<td>681</td>
</tr>
<tr>
<td>Analytics Log (Business Process) Setup</td>
<td>682</td>
</tr>
<tr>
<td>Analytics Log (Cash Flow) Setup</td>
<td>687</td>
</tr>
<tr>
<td>Analytics Log (Cost Sheet) Setup</td>
<td>688</td>
</tr>
<tr>
<td>Analytics Log (P6 Summary Sheets)</td>
<td>691</td>
</tr>
<tr>
<td>Analytics Log (Shells)</td>
<td>692</td>
</tr>
<tr>
<td>Analytics Log (Space Manager)</td>
<td>695</td>
</tr>
<tr>
<td>Data Mapping - Space Types Tab</td>
<td>696</td>
</tr>
<tr>
<td>Data Mapping - Level Tab</td>
<td>698</td>
</tr>
<tr>
<td>Analytics Log (Vendors)</td>
<td>701</td>
</tr>
<tr>
<td>Access Control Changes for Analytics Node in User Mode Access</td>
<td>703</td>
</tr>
<tr>
<td>Granting Permissions for Analytics</td>
<td>703</td>
</tr>
<tr>
<td>Accessing the Unifier Analytics Dashboard in OBI</td>
<td>704</td>
</tr>
<tr>
<td>Accessing Unifier from OBI server</td>
<td>704</td>
</tr>
<tr>
<td>Action Links (from OBI to Unifier)</td>
<td>705</td>
</tr>
<tr>
<td>Accessing Analytics from Unifier</td>
<td>706</td>
</tr>
<tr>
<td>Publishing Unifier Data to Analytics</td>
<td>706</td>
</tr>
<tr>
<td>Unifier Configurator and OBI Server</td>
<td>707</td>
</tr>
<tr>
<td>Analytics Block</td>
<td>707</td>
</tr>
<tr>
<td>Analytics Block and Shell Templates</td>
<td>708</td>
</tr>
<tr>
<td>Unifier and Primavera P6</td>
<td>709</td>
</tr>
<tr>
<td>P6 Data Sources node</td>
<td>710</td>
</tr>
<tr>
<td>P6 Activity Data</td>
<td>713</td>
</tr>
<tr>
<td>P6 Activity Picker Query Configuration</td>
<td>713</td>
</tr>
<tr>
<td>P6 Data and Cash Flow Templates</td>
<td>715</td>
</tr>
<tr>
<td>Unifier and Primavera Gateway</td>
<td>716</td>
</tr>
<tr>
<td>Gateway node in Unifier</td>
<td>720</td>
</tr>
<tr>
<td>Business Objects node in Unifier</td>
<td>721</td>
</tr>
<tr>
<td>Configuring Permissions for Business Objects</td>
<td>724</td>
</tr>
<tr>
<td>Unifier Provider, Unifier, and Gateway</td>
<td>725</td>
</tr>
<tr>
<td>Project/Shell</td>
<td>726</td>
</tr>
<tr>
<td>Project/Shell Data Dictionary</td>
<td>726</td>
</tr>
<tr>
<td>Project/Shell Business Flow</td>
<td>727</td>
</tr>
<tr>
<td>Project/Shell Synchronization</td>
<td>728</td>
</tr>
<tr>
<td>Project/Shell End-to-End Solution</td>
<td>728</td>
</tr>
<tr>
<td>Business Processes</td>
<td>730</td>
</tr>
<tr>
<td>Business Processes Data Dictionary</td>
<td>731</td>
</tr>
<tr>
<td>Summary Payment Application (SPA) SOV type BPs</td>
<td>741</td>
</tr>
<tr>
<td>Unifier Provider BP Objects and Gateway Objects</td>
<td>743</td>
</tr>
</tbody>
</table>
Getting Started

If you are using Primavera Unifier for the first time, review this section which will help you get acquainted with Unifier and its navigation.

In This Section

Information for First Time Users ................................................................. 25
Configuring Your System for Unifier .......................................................... 25
Supported Browsers and Settings ............................................................... 26
User name and Password ........................................................................... 27
Sign In to and Sign Out of Unifier .............................................................. 28
Security Warnings ..................................................................................... 29
Signing In to Self-Service Portal ............................................................... 29
File Viewer Option ..................................................................................... 30
Navigating in Unifier .................................................................................. 30
User Preferences ....................................................................................... 34

Information for First Time Users

You need to have Administrator privileges, on the local machine, before you can configure your computer for use with Primavera Unifier and install certain plug-ins. Always review this information with your IT department.

Before using Unifier with Internet Explorer (IE), ensure that the security settings for the Internet zone is set as Medium or Medium-High.

Configuring Your System for Unifier

Ensure that the necessary browser settings (within the supported browsers) are configured for the computers that access Unifier. For the full list of system requirements and versions go to:

1) Primavera Unifier Online Documentation Library
2) Select to view the library for the current release
3) Select Installation and Upgrading
4) Click Supported Technologies and Tested Configurations spreadsheet
5) Open the following and review the contents:
   1. Supported Technologies page
   2. Unifier Tested Configurations spreadsheet
Supported Browsers and Settings

You can use Primavera Unifier with the following supported browsers:

- Microsoft Edge
- Microsoft Internet Explorer
- Mozilla Firefox
- Google Chrome
- Apple Safari

**Notes:**
- For the full list of system requirements, supported software, and versions, refer to the *Tested Configurations* document.

**Microsoft Edge**

Refer to Microsoft Edge Help to see the details on language settings and how to set up the options explained here.

**Microsoft Internet Explorer (IE)**

Refer to Microsoft Internet Explorer Help to see the details on language settings and how to set up the options explained here.

To configure the IE browser for Unifier ensure that the security settings for the Internet zone is set as **Medium** or **Medium-High**. If your internet settings are customized, contact your IT for more information. When finished, sign out of Unifier and close the browser completely in order for the new settings to take effect.

For plug-ins, follow these steps:

**Note:** Depending on your IE setup, these instructions may vary.

1) Click **Tools** and then **Internet Options**.
2) Select the **Security** tab and select the **Custom Level**.
3) Scroll down to **Scripting of Java applets**.
4) Ensure that the **Enable** radio button is checked.
5) Click **OK** to save your preference.

**Mozilla Firefox**

Refer to Mozilla Firefox Help to see the details on language settings. If your internet settings are customized, contact your IT for more information. When finished, sign out of Unifier and close the browser completely in order for the new settings to take effect.

For plug-ins, follow these steps:

1) Open the **Firefox** browser, or restart it if it is already running.
2) From the Firefox Menu Bar, select **Tools**, then click **Add-ons**.
3) In the Add-ons Manager window, select **Plugins**.
4) Click to select the Java (TM) Platform plug-in (Windows), or the Java Applet Plug-in (Mac OS X).
5) Ensure that the option "**Ask to Activate**" or "**Always Activate**" is selected. For older versions of Firefox, click **Enable**. Note that if the button displays Disable, Java is already enabled.

**Google Chrome**

Refer to Google Chrome Help to see the details on language settings. If your internet settings are customized, contact your IT for more information. When finished, sign out of Unifier and close the browser completely in order for the new settings to take effect.

**Note:** AutoVue viewing is not supported in Google Chrome.

**Apple Safari**

Refer to Safari Help to see the details on how to set up the options explained here.

To use Apple Safari you must set Java to Run in Unsafe Mode, in browser preferences. Go to **Preferences**, under Security select **Java**, then select **Run in Unsafe Mode**, and click **OK**.

For plug-ins, follow these steps:
1) Click on **Safari** and select **Preferences**.
2) Select the **Security** option.
3) Select **Allow Plug-ins**, then click on **Manage Website Settings**.
4) Click on the Java item, select one of the options: Ask, Allow, or Allow Always (from the drop-down list **When visiting other websites**).
5) Click **Done** and close the **Safari Preferences** window.

**User name and Password**

Before you can sign in to Primavera Unifier, you must have a user account, which will provide you with a Login Username and a Password that you can use to sign in to the Primavera Unifier system. Your Primavera Unifier Company Administrator(s) should be able to create your user account and provide you with your Login Username and Password.
Note: If Oracle Primavera Customer Support Team is administering the setup and user administration for your company, you will receive your Login Username and Password directly from them.

Forgot Password

You can reset your own password if you forget it. In order to do this, you must first set up one or more secret questions in Primavera Unifier. It is recommended that you set up these secret questions so you can reset your own password. If you have not set up secret questions, contact Customer Support to reset your password.

To reset your password if you forget it:
1) In the Primavera Unifier Sign In window, click **Forgot Password?**
2) Enter your user name and email address, and click **OK**.
3) Answer your Secret Question(s) and click **Submit**. You will receive an email notification containing your reset password. Use the new password to sign in to Primavera Unifier.

To add secret questions to use when resetting your password:
1) Sign in to Primavera Unifier, then click the **Preferences** link in the upper right portion of the Primavera Unifier window.
2) Click the **Security** tab.
3) Under Password Recovery Secret Questions, select a question and enter the answer. You can add up to three Secret Questions.

Sign In to and Sign Out of Unifier

To access the Primavera Unifier Sign In window follow these steps:

Notes:
- The Sign In page appears based on the supported browser language. If the browser is not supported, the Sign In page appears in English.
- After signing in to Unifier, the Unifier language will be based on the Language selected in the User Preferences. See **User Preferences** (on page 34) section for details.

1) Open your browser and enter the web address that your site administrator has provided for you.
2) Enter your user name: `coadmin`
3) Enter the password that was set for you during the Unifier installation.
4) Click **Sign In** to open the application.

Note: To sign out of the Primavera Unifier, click **Sign Out** from the upper right-corner of the Unifier window.

If you have trouble signing in, check to ensure that:
- The Caps Lock function is not on (user names and passwords are case-sensitive).
You entered the correct user name and password.

If you still have trouble signing in, contact your Company Administrator or Oracle Customer Support.

After signing in for the first time, you may wish, or be required, to change your password. See the Changing Your Password (on page 36) section for details.

---

**Note:** Save your work often. If you are inactive in Unifier for longer than the time-out limit (one hour), the system will sign you out automatically, and any unsaved work will be lost.

---

### Security Warnings

The first time you perform certain functions in Primavera Unifier, security warnings may appear from third party software confirming the use of Java plug-ins from these business partners.

Follow the instructions below to prevent the warnings from recurring every time that you use the functionality in Primavera Unifier that requires these certificates.

#### Preventing a Security Warning from Recurring

A first time user may receive a security warning. When prompted by your browser to acknowledge a security warning in Unifier, you may select your browser option to ignore future warnings. The setting to ignore warnings varies by browser.

---

### Signing In to Self-Service Portal

Certain business processes can be enabled for access through the Self-Service Portal. The actions users can take through the Self-Service Portal are:

- Create a business process
- Modify a business process
- Add or remove business process attachments
- Add General Comments to a business process

To sign into the Self-Service Portal Landing Page:

1) In your web browser, enter the URL you use to access Primavera Unifier, followed by /portal. For example: https://your-web-address.com/portal

2) Enter your Self-Service Portal user name and password, choose your company from the pull-down (if applicable), and click the **Sign In**. The Landing Page opens.

To create and submit a new record:

1) Select a business process to work with from the log in the left Navigator.
2) Click the **New** button.
3) Fill out the business process form.
4) Click **Submit**.

To open or edit an existing record:
Unifier Administration Guide

1) Navigate to the business process in the left Navigator. The business process log opens in the right pane, listing all available records that you have permission to view.
2) Select the record from the log and click Open (or double-click the record from the log.) The record opens in the view-only mode.
3) To edit the details, click the Edit button.
4) Make necessary edits to the form.
5) Click Submit to submit the edited record.

Note: You must have been given the proper permissions to create, view, or edit portal-enabled records.

File Viewer Option

The following topics discuss the basic user preferences settings that should be configured before using Primavera Unifier for the first time.

For more information regarding all User Preference settings, see Unifier Help or Unifier User Guide.

File Viewer Option (Select Default Viewer)

Primavera Unifier provides two methods of viewing files:
- Native
- Unifier Viewer

Unifier Viewer is the default option. The Viewer lets you view and markup documents. The markups are saved as markups without changing the original file. Native Viewer allows you to view most file formats in the application in which you created or regularly view them. In other words, if you view a .doc file in Native, Microsoft Word will open and display the .doc file.

Navigating in Unifier

When you sign in to Unifier, you will be returned to the location (Tab, Mode, Module) where you last signed out to:
- Review all of your projects or shells, tasks, or messages.
- Quickly view your active tasks or new uMails.
- View system-wide project or shell or shell announcements.
- Access Primavera Unifier functions using the Navigator.

To return to the Home page, click the Home tab or Home icon if the tab is not available.

Unifier User Interface (UI) Content and Internationalization

The contents that appear in the Unifier application UI (also known as System Strings) cannot be modified by the Users. The System Strings are available in different languages, per user preferences.
Example
Sign In and Terms and Condition pages, Menus, Alerts, and Errors

In contrast, the content of the material created by the Users (also known as Custom Strings) can be translated into different languages. Refer to the Translating Custom Strings (Internationalization) section of the Unifier Administration Guide, for details.

Example
Business Process (BP) name, Data Element (DE) label, pull-down values, radio button, text in lines, navigation log names, and multi select values

Notes:
- The user input data (data entry) in Business Processes (BPs), attribute forms of various Managers, and other similar elements, when entered at runtime, cannot be translated.
- User’s data entry must be saved “as-is” and include support for single and multi-byte characters UCS Transformation Format—8-bit (UTF-8).

User Home Page

When you are on the Unifier Home page, you can:
- See the login information: The last login date and time that you signed in.
- See the name of the user who has signed in.
- Access username menu, Help, and Sign Out options.
- Access Preferences from the username menu.
- Change password and access proxy login settings (Proxy For) from the username menu, without opening the Preferences window.
- Access Unifier Help, Unifier Library, Contact Support, Download Plugins, and About Unifier from the Help menu.
- Review all of your projects or shells, tasks, or messages.
- See which projects have active tasks or new uMails.
- View system-wide project or shell or shell announcements.
- Access Primavera Unifier functions using the Navigator.

Navigator

The primary means of accessing Unifier features within a project or a shell is through the Navigator, located in the left pane of the Unifier window.

The Navigator is similar to a folder system, much like a network drive. Each feature is stored in its own "node," similar to a folder. Each node is controlled by permissions. If you do not see a feature in the Navigator, contact your project or shell Administrator or Company Administrator to verify that you have been assigned the proper access permissions.
Note: Company Administrators can configure the User Mode Navigator to better suit business needs, for example, creating additional nodes to store business process records, renaming some of the nodes mentioned below, and so on. Your Navigator may differ, but the basic functionality will be the same.

Use the Expand All or Collapse All icons, in the Navigator pane, to expand or collapse the nodes.

**Tabs and Navigation Bar**

**Tabs**

Unifier uses tab-based navigation. You can use tabs to navigate to frequently used locations: Home, Company Workspace, individual projects, programs, and single- or multiple-instance shells.

Unifier allows you to create, and use, unlimited number of tabs, rearrange your tabs locations on the screen, close all tabs (except one). You can arrange tabs (including the Home tab) by dragging.

To create a new tab, click the plus (+) sign next to the existing tab on your screen and use dragging to arrange tabs, including the Home tab.

**Note:** When tabs no longer fit on the page, Unifier provides scrolling option and drop-down list to assist you with accessing all your tabs.

You can also create multiple tabs representing the same location to quickly navigate to, or in, different areas within that location.

Tabs maintain their states if you switch tabs. For example, if you are working in Schedule Manager (User mode) and decide to switch to another tab and switch back, the system preserves your setting, Schedule Manager (User mode). Similarly, when you sign out of Unifier and sign in again, you return to the tab that you were working with, before you signed out, with your settings preserved.

**Note:** First-time Unifier users see only the Home tab. Returning users see all the tabs that were displayed in the previous Unifier version.

*(For on-premises users only)* Unifier displays the Executive Dashboard tab only if you have access to a company dashboard. The Executive Dashboard tab is different from the other tabs.

The following lists the Executive Dashboard tab features:

- Fixed height and width
- Displays a chart
- Always remains as the first tab, so it cannot be reordered like other tabs
- Is not included in the scroll area, so it remains in place to the left of the scroll controls
Navigation Bar

The navigation bar in Unifier consists of bookmarks, navigation field, and breadcrumbs (locator links).

- **Bookmarks**
  See *Bookmarks*.
- **Navigation field**
  To enter the name, number, or path of the location you want to go to. The navigation field provides an alternative way to navigate to the frequently used locations.
- **Breadcrumbs (locator links)**
  See *Breadcrumbs (locator links)*.

Modes of Operation

Primavera Unifier has two modes of operation.

- **User Mode**: Users spend most of their time in this mode. The User Mode allows you perform the day-to-day activities, collaborate through business processes and uMail, maintain, for example, the Cost Manager, Schedule Manager, and Document Manager, and run reports.
- **Administration Mode**: Company administrators work in this mode to set up, for example, company, program, and project or shell properties, user permissions, templates for major Unifier features, data structures, and configure and set up business process forms and workflows.

You can switch between modes using the Navigator. The option is located at the top of the Navigator. You can click on **User** or **Admin** options to access the User or Administration modes.

**Note**: Access to Unifier functionality is granted through permissions. The ability to utilize a specific function in Unifier depends on permissions settings.

Breadcrumbs (locator links)

Breadcrumbs or locator links represent the path to the current location and always include Home (Home icon) as well as your current location.

- Click on a breadcrumb name.
- Click the drop-down arrow of a breadcrumb to reveal the direct children or sub-shells of that location.
- Click the Home icon to go to the Home landing page; click its drop-down arrow to display key locations.

**Note**: Even if you do not have permission to access a shell, the shell name appears in the breadcrumb trail.
**Bookmarks**

The function of bookmarks in Unifier is similar to the bookmarks that you create in a web browser to help you access a web page more quickly, or navigate to frequently used locations.

**Note:** Unifier does not validate bookmark names, so ensure that you do not add duplicate or confusing bookmark names.

You can add bookmarks to Unifier User Mode functions where you frequently work.

**Note:** You cannot add bookmarks in Administration Mode.

To add bookmarks:

1) Go to the tab/node that you want to bookmark.
2) From the top right-hand corner, click the **Star** icon to open the Bookmarks window. The name of the tab/node appears in the Name field. You can modify the name for your bookmark, if you wish.
3) Click **Add** to create a bookmark.
4) Close the Bookmark window by clicking outside the Bookmark window.

**Note:** Accessing a tab/node through a bookmark is based on your user permissions.

To use bookmarks, from the top right-hand corner, click the **Star** icon to open the Bookmarks window.

Provided that you have permission to access that module, clicking on a bookmark opens the shell or project. Breadcrumbs to your current location appear in the upper left-corner of the Unifier window.

**Note:** If you do not have permission to access a module that you designate as the default, Unifier displays the Home page.

To delete a bookmark, open the bookmark window, scroll on the bookmark that you want to delete, click the star symbol on the left-hand side of the Bookmark name, and click **Delete**.

To move a bookmark up or down, open the bookmark window, scroll on the bookmark that you want to move, click the star symbol on the left-hand side of the Bookmark name, and click **Move Up** or **Move Down**.

To rename a bookmark, select the bookmark, and change the bookmark name in the Name field.

**Note:** If you do not wish to designate a bookmark as the default module shown to you at sign in, ensure that none of the bookmarks are selected before you close the Bookmarks window.

**User Preferences**

To access the User Preferences window:
1) From the top right-corner of your window, click your **User Name** to open a contextual menu. The menu offers a limited set of choices that are available in the current state.

2) Click **Preferences** to open the User Preferences window. The User Preferences window opens on the General tab.

The User Preferences window contains the following tabs:

- General
- Security
- Options
- Region Format
- Proxy

The following describes each tab.

**General tab**

Use the General tab to view company contact information.

**Security tab**

Use the Security tab to:

- View password policy
- Manage password reset and recovery
- Manage secret questions.

---

**Note**: If your company is using Oracle Identity Management (OIM) to add users to your company, you must use OIM to manage your password. For information on changing your password, see the documentation included with OIM.

---

**Options tab**

Use the Options tab to manage Company settings such as:

- File viewer (Default Viewer)
- File viewer exception (Viewer Exceptions)
- Login view (Default Login View)
- Email settings (Email Subscription)

**Region Format tab**

Use the Region Format tab to manage settings such as:

- Language
- Time Zone
- Date Format
Proxy tab

Use the Proxy tab to:

- Prevent assigning proxies (Do not allow Proxies)
- Add multiple proxies (Users who can act as my Proxy)
- See the history of proxy login (Proxy Login History)
- See the list of users who can act as your proxy (Users who can act as my Proxy)
- See the list of users who you act as their proxy (Users I can act as their Proxy)

**Note:** You can select/designate more than one proxy user.

The topics that follow describe available User Preference configuration settings for each tab, in details.

### Viewing Your Contact Information

Use the User Preference **General** tab to view your company contact information such as the contact’s: Title, Email, Work Phone number, Mobile Phone number, Pager number, Fax number, and Address (City, State/Province, Zip/Postal Code, and Country/Region).

**Note:** The Company Administrator manages user profiles, including the contact information. Contact your Company Administrator if you want to update your information.

### Changing Your Password

Use the User Preference **Security** tab to manage password reset, password recovery, selection of secret questions, and view password policy.

**Notes:**

- If your company is using Oracle Identity Management (OIM) to add users to your company, you must use OIM to manage your password. For information on changing your password, see the documentation included with OIM.
- You cannot recover/reset your password if you do not set up password recovery secret questions and corresponding answers.
- For better security, change your password at regular intervals. Your Company Administrator may require you to change it at set times.

You can change your password in two ways:

- Using the **Security** tab of the User Preferences window (for first-time users)
Using the **Change Password** option (for returning users)

To change your password using the **Security** tab of the User Preferences window follow these steps:

1) Go to the User Preference **Security** tab.
2) Click **View Password Policy**, review the policy (see the **Password/Login Policy** section at the end of this section for details), and close the window.
3) Enter your current password and new password in the Current Password and Password fields.
4) Confirm your new password by entering the new password in the Confirm Password field.
5) Under Password Recovery Secret Questions section of the Security tab, select a question and enter the answer. You can designate up to three secret questions.
6) Click **Apply** and click **OK** to close the User Preferences window.

To change your password using the Security tab of the Change Password option follow these steps:

1) From the top right-corner of your window, click your **User Name** to open a contextual menu.
2) Click **Change Password** to open the Change Password window.
3) Enter your current password and new password in the Current Password and Password fields.
4) Confirm your new password by entering the new password in the Confirm Password field.
5) Click **Save** completing changing of your password.

You can recover your password from the Sign In Page.

To recover your password:

1) Go to the Sign In page.
2) Click **Forgot Password?** link to open the Reset Password window.
3) Enter your user name and email in the User Name and Email fields.
4) Click **Submit** to show the Secret Question.

**Note:** If you did not set up the Password Recovery Secret Questions, or if your Unifier account is Inactive or On-Hold, you will receive an error message instructing you to contact Oracle Customer Support.

5) Enter the answer to your secret question field and click **Submit**. A system-generated email containing a temporary password will be sent to you automatically.
6) Click **OK** in the Alert window.
7) Go to your email inbox and open the system-generated email titled "Unifier Password Reset Notification" and follow the instructions.

**Password/Login Policy**

- **Minimum overall characters:** Minimum number of characters that a password must contain; default is one (1).
- **Maximum overall characters:** Minimum number of characters that a password must contain.
- **Minimum numeric characters:** Password must contain a minimum amount of numbers.
- **Minimum alphabetic characters:** Password must contain a minimum amount of letters.
- **Minimum special characters:** Special characters are [{~@#$%^&*()-_=+;:"',<.>/?}].
Password cannot be same as Username: Users cannot use their user name as a password.
Password cannot be the same as the user’s First or Last Name: Users cannot use their first or last name as a password.
Password cannot be same as last password(s): A newly changed password must be different from the previously used passwords.
Password expiration day(s): If a password expires, users are prompted to change it when they next sign in.
Inform user before expiration day(s): Upon signing in, users are warned that their passwords are about to expire, and are given the opportunity to change the password.
Maximum sign in attempts: If a user does not successfully sign in after this number of attempts, the account is locked.
Suspend inactive user after day(s): Sets the number of days of inactivity before a user account is locked.

Changing the Time Zone or Date Format

The following settings are maintained in the Region Format tab of your User Preferences.
The Time Zone setting affects the date stamp that appears on the actions that you perform in Unifier, such as saving or uploading files, running user-defined reports, and due dates of tasks assigned to you. The date stamp is effective as of 12:00 AM in your time zone.

Example
If your time zone is Eastern Standard Time, and your task is due August 1, then at 12:00 AM August 1 your task is due — even if it is only 9:00 PM July 31 in Pacific Standard Time.

Note: The Time Zone setting is based on the Coordinated Universal Time (UTC).

To set the time zone:
1) Go to the User Preference Region Format tab.
2) Click the Time Zone drop-down list and select a time zone based on your locale.
3) When finished, click Apply and then OK.
The Date Format determines how date fields appear to you in Unifier.

To set the date format:
1) Go to the User Preference Region Format tab.
2) Click the Date Format drop-down list and select a date format.
3) When finished, click Apply and then OK.
Unifier supports the following additional date formats:

Note: The time format for all dates is: HH:MM AM.

- MM/DD/YYYY
- DD/MM/YYYY
- MM/DD/YY
DD/MM/YY
MM-DD-YYYY
DD-MM-YYYY
MM-DD-YY
DD-MM-YY
DD.MM.YYYY
YYYY-MM-DD
MMM/DD/YYYY
DD/MMM/YYYY
YYYY/MMM/DD
M/D/YYYY
M/D/YY
D/M/YYYY
D/M/YY
YY/M/D
YYYY/M/D
YY/MM/DD
YYYY/MM/DD

Changing Number and Currency Formats

The following settings are maintained in the Region Format tab of your User Preferences.

The Number and Currency Formats section of the Region Format tab of your User Preferences allows you to:

- Select Preferred Region from a list. This is the region that you want.
- Set the Decimal Symbol for your currency from a list.
- Set Digit Grouping from a list.
- Set Positive Currency Format from a list.
- Set Negative Currency Format from a list.
- Set Negative Number Format from a list.

When finished, click Apply and then OK.

The Number and Currency Formats section of the Region Format tab also provides examples for the following:

- Currency
- Decimal Number
- Integer Number

The examples show the arrangement of the numbers (the way the numbers are displayed) in the forms when a particular formatting option has been selected.

For decimal numeric data, the precision is governed by the "Decimal Places" set in the Data Element properties.
**Unifier Administration Guide**

**Note:** When the Company Administrator creates a User for the first time, when selecting a language, the values of the number formats are populated accordingly and displayed in the **Region Format** tab of the User Preferences. The number formatting options are not displayed in the User Properties window. The number formatting options are displayed in the User Preferences. If the Company Administrator changes the language value in the User Properties window, the **Region Format** tab of the User Preferences shows the same languages as in User Properties window and the number formatting options remain the same.

---

**Changing Language**

The following settings are maintained in the **Region Format** tab of your User Preferences.

To set the language:

1) Go to the User Preference **Region Format** tab.
2) Click the **Language** drop-down list and select your language.
3) When finished, click **Apply** and then **OK**.

The following languages are supported:

- Chinese (Simplified)
- Chinese (Traditional)
- Dutch
- English
- French
- German
- Italian
- Japanese
- Korean
- Portuguese (Brazil)
- Russian
- Spanish

---

**Choosing a Viewer Option and Setting Viewer Exceptions**

The following settings are maintained in the **Options** tab of your User Preferences.

**Viewer Option**

**Note:** Before you choose a file viewer option, you must have an active AutoVue license and AutoVue installed and configured on your server.
The file viewer option determines how Unifier displays files (such as documents or drawings) that are attached to business processes or stored in the Document Manager and opened from within Unifier.

You can choose a default viewer, which will be used to open most file types in Unifier. You can also specify exceptions to this; for example, you may choose Unifier Viewer as the default viewer, which will be used to open most file types, but then choose to open a few file types such as drawing files and image files using the native software applications that reside on the user's desktop machine.

To select a file viewer option:

1) Go to the User Preference Options tab.
2) Click the Default Viewer drop-down list and select one of the following viewer options:
   - Native
   - Unifier Viewer
3) When finished, click Apply and then OK.

The following describes each of the default file viewer options in details:

**Native**

To open documents in their native software applications (for example, Microsoft® Word documents are opened in Microsoft Word). In order to be able to use this option to view files, you must have the native software application installed on your computer.

*Note:* The native software application does not display the document graphical markups, but Unifier displays the document graphical markups automatically, using the AutoVue viewer.

**Unifier Viewer**

To open documents in AutoVue viewer, which can display virtually any type of file.

*Note:* If you select Unifier Viewer, the document opens in read-only view, but it supports adding graphical markups and text comments (for example, in attachments to business process and other records, or in files in the Document Manager).

**Viewer Exceptions**

The Viewer Exceptions section of the Options tab allows you to specify exceptions to the default viewer of your choice.

**Example**

If you selected “Unifier Viewer” as your file viewer and want “Native” to show a particular extension and not the “Unifier Viewer,” enter the extension in the “Always Use Native:” field.

If you selected “Native” as your file viewer and want “Unifier” to show a particular extension and not your Native software, enter the extension in the “Always Use Unifier:” field.

**Notes:**
Selecting Email Subscription Options

The following settings are maintained in the Options tab of your User Preferences.

Email Subscription

The email subscription option enables each user to control the number, type, and frequency of Unifier-related email notifications received. Users can subscribe to, or opt-out of, receiving email notifications for events within Unifier.

Send notifications in single daily digest

Select this option if you want to receive your email notifications in a consolidated email, once a day (single daily digest), instead of receiving the notification emails individually and per event. Deselect this option to receive email notifications individually and per event.

Before you begin selecting email subscription options

Permission

To receive an email notification for a module and/or event, you must have view permission for that module and/or event. This view permission is set in Administration mode.

Note: If you do not have view permission, your email notifications settings do not override the original permissions (set by your Company Administrator), and you only get email notifications for modules and/or events that you have permission to view.

Document Manager notifications

In addition to module-level view permission, you must also have at least view permission on the specific documents or folders that would generate the event email. These permissions are set by Company Administrator and from within the Document Manager. In addition, the owner of the folder has the option of not generating email notifications for specific events.

External email accounts

If you are using an email address from a generic email account such as Yahoo, Hotmail, and so forth, your spam filter may filter out these notifications. Refer to your email provider regarding how to allow these notifications to reach your inbox.

To receive email notification for a module or event

1) Go to the User Preference Options tab.
2) Select your choices from the scrolling window. See the following table for details.

To opt-out of receiving email notification for a module or event, simply deselect the items from the scrolling window.
To subscribe to or opt-out of email notifications

1) Go to the User Preference Options tab.
2) From Email Subscription field, select the modules and events for which you want to receive email notifications. If you do not select a module or event, you do not receive email notifications related to the unselected module or event. The following table for details.
3) The events apply to the following modules:
   - Workflow business processes
   - Non-workflow business processes
   - Document Manager - Project/Shell
   - Document Manager - Company
   - uMail
   - User Defined Reports
   - Alerts
   - Gates
   - Project/Shell
4) To opt out of receiving email notifications regarding specific Unifier events, deselect the checkbox for the notification.
5) To receive Unifier email notifications in one email summary per day, click the Send notification in single daily digest checkbox. The summary email will be sent if one or more events trigger an email notification.
6) When finished, click Apply and OK.

Notes:
- For permission-based emails, email notification is usually sent the first time permission has been granted and not when permissions are modified, unless otherwise noted.
- Document Manager email notifications are only sent if users have at least view permission on the affected item, and if the item owner enables email notification.

Modules and Events Options

This section describes the events within each module.

Workflow Business Processes

These events pertain to business processes. To receive notification, you must have at least view permission for the business process (BP). You can opt to receive email notification when:

Personal tasks

You are part of the assignees list when a BP is sent (this becomes a task for you).

Decline tasks

A task is declined by one or more of the assignees that you have added to a BP that you sent.

Overdue personal tasks
An assigned task is past the due date.

*Messages*

Someone cc's you on a BP.

*Discussion group comments*

A discussion group participant adds and saves comments within the discussion group. You will receive notification if you are the owner of the discussion group.

*Record Workflow Complete*

The record Workflow is complete and the Workflow end step has been reached; this is applicable on any Workflow BP where user is selected as part of the "Notify users on workflow completion" setup under the BP Setup > Setting tab.

*Record Modification*

A certain step occurs in a workflow (if your Administrator has enabled workflow actions for the workflow step) that needs action. Actions are shown as hyperlinks in the email.

*Non-Workflow Business Processes*

These events pertain to non-workflow business processes. To receive notification, you must have at least view permission for the business process (BP). You can opt to receive email notification when:

*Record Creation*

A new record is created.

*Record Modification*

A record or line item is modified, a line item is added or deleted, comments or attachments are added, attachments are removed.

**Document Manager - Project/Shell and Document Manager - Company**

*Note:* With this module in particular, a user modifying multiple documents or folders, or folders with many subfolders, can potentially trigger a large amount of email. You can prevent receiving too many notifications by choosing the digest notification (one email) option, or limit the events for which you want to receive notification.

Users with view permission (set in the Document Manager) on the applicable document, folder, or shortcut target receive notification when the following occurs:

*Document upload*

A new document is uploaded into the folder.

*Transfer ownership*

File or folder ownership is transferred. The new owner is notified.

*Move*

A document, folder, or shortcut is moved from one location or folder to another.
Delete
A document, folder, or shortcut is deleted.

Document revise
A document is revised.

Folder rename
A folder is renamed.

uMail

Personal uMail
Users receive email notification when a new uMail is received.

User Defined Reports (UDRs)
Users receive email notification when:

New report granted
The user is granted at least run permission to a user-defined report by another user.

Results from scheduled reports
When a scheduled report has been generated and the results are available; requires run permission be granted for the report.

Alerts

Each alert
Users can receive notification when an alert is generated.

Gates

Change Phase Notification
User receives notification when a phase is changed.

Auto-email PDF Gates run
User receives a PDF copy of an automated gates run.

Project/Shell

Successful Creation
Program Manager, Project Manager, or Project Administrator receives notification of the successful creation of a Project/Shell. This notification occurs if the Project/Shell is created manually, through Web Services, using a CSV file, or through auto-creation.

Changing Unifier Default Landing Page

Note: This section applies to on-premise users, only.

The following settings are maintained in the Options tab of your User Preferences.
When you sign in to Unifier and the application opens, by default you see the Home tab view as the landing page. You can change the landing page view to a custom dashboard of your choice at Company-level, only.

You can choose from the configured custom Company-level dashboards by selecting a dashboard from the Available Dashboards drop-down list in the dashboard view.

To change the landing page view to a custom dashboard:
1) Go to the User Preference Options tab.
2) Select Use Custom Dashboard as default login view, next to the Default Login View field.
3) Click Apply and OK.

Choosing a Proxy User

The following settings are maintained in the Proxy tab of your User Preferences option.

You can be a proxy for multiple people, and you can designate more than one user as your proxy. Proxy users can be granted permission to access another user’s account to complete tasks and perform other functions on that person’s behalf. When another person signs in as your proxy user, that person will have access to all of the records and functions that you do.

When you designate another user as your proxy, the user will have access to all of:
- The records that you have generated
- The functions that you perform

When you designate another user as your proxy, the user will not be able to change your Preference settings and the Audit logs reflect the actions taken by a proxy user as "on behalf of" the original user.

You can limit the period in which the proxy user will have access to your account by specifying a start and end date or leave their access active indefinitely.

Proxy users who are active (Status: Active) receive email notification of tasks to perform as proxy. This applies during the time specified time period, using the Start Date/Time and End Date/Time.

---

**Note:** If the proxy user must receive task notifications immediately, ask the proxy user to ensure that the Send notifications in a single daily digest checkbox is not selected. See Selecting Email Subscription Options (on page 42) on the User Preferences Options tab.

Use the Proxy tab to:
- Prevent assigning proxies (Do not allow Proxies)
  **Note:** This option is available for the Administrator (Admin mode), only.
- Add multiple proxies (Users who can act as my Proxy)
- See the history of proxy login (Proxy Login History)
- See the list of users who can act as your proxy (Users who can act as my Proxy)
- See the list of users who you act as their proxy (Users I can act as their Proxy)
**Do not allow Proxies**

Only Site/Company Administrators, Company users, and Partner users are permitted to select the **Do not allow Proxies** option.

**Note:** This option is read-only in the user's User Preferences window.

Users are able to add proxy users in their User Preferences window only if the Site/Company Administrator has not checked the **Do not allow Proxies** option in the Proxy tab of Edit User window.

**Users who can act as my Proxy**

This section of the Proxy tab lists the users who can act as your proxy and allows you to add, adjust the settings, remove proxies, and view the proxy login history.

If you have access to more than one Company and want to assign a proxy for yourself in those companies, you need to go into each Company and set the proxy user (Company > your user name > Preferences > Proxy).

**Note:** You can select/designate more than one proxy user.

**Add**

If the **Do not allow Proxies** option is selected by your Site/Company Administrators, then this option is not available for you to use.

If the **Do not allow Proxies** option is not selected by your Site/Company Administrators, then you can use this option to grant proxy access to other users. To add a proxy, click **Add** and follow the prompts.

**Note:** Your Company Administrator can assign other users to act as proxies to your account. If you are unable to do so.

**Settings**

If the **Do not allow Proxies** option is selected by your Site/Company Administrators, then this option is not available for you to use.

If the **Do not allow Proxies** option is not selected by your Site/Company Administrators, then you can use this option to select an existing proxy and change the user settings of your proxy, such as start and end date/time. To change the user settings of your proxy, click **Settings** and follow the prompts.

The system sets the values in the time-related fields base on the user's preferred data and time formats.

If you do not specify a start or end date, the proxy user can access your account immediately and their access privileges will not expire.

You can select **Active** to activate your proxy's access. To disable your proxy's access, select **Inactive**.

**Remove**
You can use this option to remove a selected proxy. To remove a user as your proxy, click to select the proxy from the list and click **Remove**.

**Proxy Login History**

Use this option to view the following information about your proxies:

- Name
- Login Date
- Logout Date

The last login information appears on top.

**Users I can act as their Proxy**

If the Site/Company Administrator has designated you as a proxy for another user, your user name is listed under Users I can act as their Proxy field.

---

**Note:** As a proxy of a user, you have all the permissions that have been granted to that user except that you cannot change the user's original Preference settings even if the user has Administration permissions.

---

To log in as someone else’s proxy user:

1. From the top right-corner of your window, click your **User Name** to open a contextual menu.
2. Click the **Proxy For** link to see a list of the users who designated you as their proxy.
3. Click to select the user name.
4. Select the user account to which you want to log in as a proxy.
5. Click **Proxy Login**. The Unifier Home Page opens, and you are immediately acting on behalf of the user.

To log out as a proxy user:

Click the **Sign Out** link at the upper right portion of the Unifier window. Your Proxy session will end, but you will still be signed in to Unifier under your own user name.

**Additional Support**

The following is a list of additional support that are available in Unifier:

- Unifier Help
- Unifier Library
- Contact Support
- Download Plugins
- About Unifier

---

**Note:** The Contact Support and Download Plugins options both open a single window, Support. The only difference is as follows:
- Contact Support opens the **Contact** tab of the Support window by default
- Download Plugins opens the **Download** tab of the Support window by default
Unifier Help
Click Help from the upper right-hand section of the Unifier window to open a contextual menu and click Unifier Help to open the Unifier and uDesigner Help.

Unifier Library
Click Help from the upper right-hand section of the Unifier window to open a contextual menu and click Unifier Library to open the Primavera Unifier Documentation Library.

Contact Support
Click Help from the upper right-hand section of the Unifier window to open a contextual menu and click Contact Support to open the Support window.

The Support window has two tabs:
- Contact, which opens by default
- Download

In the Contact tab, Contact Information section, you can see the name, phone, and contact instructions of someone at your company that you can contact when you need help with Primavera Unifier. For assistance, try this person, first.

**Note:** This information is available only if your company administrator has provided internal support contact information.

In the Contact tab, eLearning section, you see the location (Access), name of the contact (Contact), and any instructions that you might need in order to access the eLearning materials.

**Note:** Your company may elect to provide access to the eLearning suite, where you can access interactive Primavera Unifier learning materials. Alternatively, your company may have its own customized support or training materials that can be accessed on an internal site/location. If your company administrator provides this contact information, it will be listed at the bottom of the window.

In the Download tab, Download section, you can see a list of the following application and plug-ins available to download, with installation instructions.

- Unifier uCAD Plug-in

Each application and plug-in has two options:
- Download
- Installation instructions

Follow the links within each option to proceed.

Download Plugins
Click Help from the upper right-hand section of the Unifier window to open a contextual menu and click Download Plugins to open the Support window.

The Support window has two tabs:
Unifier Administration Guide

- Contact
- Download, which opens by default

In the Download tab, Download section, you can see a list of the following application and plug-ins available to download, with installation instructions.

- Unifier uCAD Plug-in

Each application and plug-in has two options:

- Download
- Installation instructions

Follow the links within each option to proceed.

In the Contact tab, Contact Information section, you can see the name, phone, and contact instructions of someone at your company that you can contact when you need help with Primavera Unifier. For assistance, try this person, first.

**Note:** This information is available only if your company administrator has provided internal support contact information.

In the Contact tab, eLearning section, you see the location (Access), name of the contact (Contact), and any instructions that you might need in order to access the eLearning materials.

**Note:** Your company may elect to provide access to the eLearning suite, where you can access interactive Primavera Unifier learning materials. Alternatively, your company may have its own customized support or training materials that can be accessed on an internal site/location. If your company administrator provides this contact information, it will be listed at the bottom of the window.

**About Unifier**

Click **Help** from the upper right-hand section of the Unifier window to open a contextual menu and click **About Unifier** to access version number, copyright information, and software agreement details for the Oracle Primavera Unifier.

**Unifier Administration Mode**

Unifier has two modes of operation:

- **Administration Mode** (or, Admin Mode): Used for all administrative tasks within Unifier to set up and configure features and modules. Access to Admin Mode functions is usually limited to a few users within a company.
- **User Mode**: Used to enter and access information, and perform tasks within Unifier. Most Unifier users will do their work in User Mode.
Access to Unifier functionality is granted through Permissions. The ability to utilize a specific function in Unifier depends on Permissions settings (accessed in Admin Mode).
Company Administration

Company Administrators generally administer sponsor company functions. This includes:

- Managing company details such as contact information
- Adding and managing users and groups
- Setting up and managing data structure
- Configuring the user mode navigator

Company Administrators also manage the list of active partner companies (derived from the list of approved partners maintained by the Site Administrator), and partner company user permissions to sponsor company features.

Sponsor Company

A sponsor company is a company that commissions projects. Projects are created in Unifier under that company as Projects or Shells. A sponsor company may have many partners.

Partner Company

A partner company is a consultant, contractor or vendor company that is associated with a sponsor company. A partner company may work on some or all of the projects or shells that the sponsor company commissions.

To access company administration functions in Unifier, go to the Company Workspace tab and switch to Administration Mode to open the company landing page.
Sponsor Company versus Partner/Member Company

A Sponsor Company commissions projects or shells. Projects and shells are created in Unifier under the Sponsor Company. Projects and shells are ‘a collaboration space’ allowing users to collaborate and coordinate during the execution of a project or shell.

A Partner Company is a consultant, contractor or vendor company associated with a Sponsor Company. A Partner company may work with the Sponsor Company on all or only some the Sponsor Company’s projects or shells. A Sponsor Company may have one, many, or no partners.

When a partner company participates in a project or shell, they become a Member Company in that project or shell, and the users added to the project or shell become Member Company Users. Project and shell access is limited to those Unifier users (of the sponsor company or member companies) who are chosen for a project or shell.
Administrators

There are different levels of Administrators in Unifier. Unifier permissions are completely configurable for each company. The information below is based on defaults and typical use. Unifier Administrators include:

- Site (or System) Administrator
- Company Administrator
- Project/Shell Administrator

Site (or System) Administrator

Site Administrators are responsible for the end-to-end administration of the Unifier. Oracle Primavera’s technical team performs the System Administrator function for Oracle Primavera-hosted customers. System Administrators normally:

- Create Sponsor and Partner Companies
- Load Modules and certain System Reports
- Add Users to Partner/Member Companies
- Manage the License Manager
- Perform basic system administration tasks, including unlocking locked user accounts
- Can also perform Company, Project and Shell Administrators' functions, as requested

Note: To have Partner/Member Companies added, or users added to Partner/Member companies, contact Oracle Support (http://support.oracle.com/), or your local support.

Company Administrator

Company Administrators can perform all Unifier tasks other than system administration. The Company Administrator group is automatically created when a company is created in Unifier. This group has pre-set permissions, which can be changed as needed (for example, as new business processes or modules are added, or if the company administrator will be assisting in other modules such as project or shell administration). Company Administrators typically (depending on permissions):

- Modify Company Properties
- Manage Company-level Users and Groups and grant Permissions
- Manage Partner Company status and users
- Create Cross-Project or Cross-Shell Reports
- Create and Maintain Data Definitions and Data Elements
- Activate Business Process schemas and define record numbering scheme
- Define the company exchange rate and currencies
- Create Programs, Projects, and Shells; manage Project Organization (categories) and Shell Organization (types)
- Set up Templates

Project/Shell Administrator
Project or Shell Administrators manage project-level or shell-level administration tasks, and may also administer programs for projects. A project or shell administrator will add existing Unifier users to projects and/or project/shell groups, restrict access within specific projects, set up the project or shell cost/funding/SOV/schedule sheets, and set up business processes. Project or Shell Administrators typically:

- Administer projects or shells they are a member of
- Add Project or Shell Users, create Groups and grant Permissions
- Create and modify the Cost Sheet
- Create Business Process Setups and define workflows
- May also manage programs as a Program Administrator (for projects only)
Permission Based Security

Unifier offers a flexible yet powerful permission-based security system, as opposed to role-based security. Role-based security by definition limits the user to a fixed set of functions or tasks. With permission-based security, access to all modules, functions and tasks in Unifier is controlled by granting each user any combination of permissions. These permissions consist of the ability to access specific Unifier tasks, and to perform specific actions within those tasks, such as create, modify, and view.

For ease of use, permissions can be set for both individuals and for groups of users. You can even copy permissions from one user to another, and then make modifications.

A user may belong to any (or all) of the administration groups and perform functions as a company, program, or project or shell administrator. Company Administrators generally have program and project or shell permissions, and may or may not work within the specific projects or shells. You may want a project, shell, or program administrator to have the ability to perform some company administrator functions, such as creating a project or shell. Creating different types of user permission templates will help you to more easily grant access to different staff members, whether they are administrative staff, engineers or architects, managers, vendors or subcontractors, IT personnel, etc.

Use default permissions as a guideline, but your users’ actual permission settings will depend on your organizations needs.
Access Administration Mode

All users, User or Administrator, start out in User Mode when first signed in to Unifier. You access the Administration mode through the left Navigator.

To access Administration mode

Select the Administration Mode from the Navigator to open the Administration Home Page.

The Company Home Page displays the following information:

- **Contact Name**: click on the link to view contact details for the company contact.
- **Home Page URL**: links to the company's Web site, which opens in another browser window (this optional link is defined by the Company Administrator).
- **Help URL**: links to an internal source of supporting information, such as a company intranet site (this optional link is defined by the Company Administrator).
- **Company Addresses**: the right side of the window displays a list of all addresses that have been entered in the system for the company, such as the main office, billing and shipping address, etc.
- **Partner Companies**: any consultants, contractors or vendors that are associated with projects or shells that the Sponsor Company commissions.

**Note**: As you access different modules on the Navigator, the Navigator remains available on the left of the screen, while the content frame on the right changes.

Initially, the Administration Mode navigation menu is collapsed. To expand or collapse any of Unifier menus click on the plus sign to the left of a module name.
About dashboards in Unifier

In Unifier, the following types of dashboards are available.

**My Dashboard** (end user-defined dashboard): By default, all shells have a dashboard that the end user can configure if they have configure permissions. The dashboard is the user’s personal dashboard, with their personally configured view of shell data. My Dashboard can be configured by end users in User Mode using the Edit Dashboard window, but is often configured for each user by the Administrator. Users can select this type of dashboard to view from the View Dashboard drop-down list on each shell. This dashboard is recommended if the user wants a personalized dashboard to view data that they specifically need to see regarding the shell.

**Shell dashboards:** These dashboards allow users to view information specific to the shell for which the dashboard was created. This differs from My Dashboard in that it is a shell view of the shell for all users to use. My Dashboard is a personalized view for a specific user, therefore displaying only the information that the user wants to see. The shell instance dashboard is a general view of specific shell data, and is not specific to any one user view of data. Administrators can create multiple shell instance dashboards per shell instance. Users can select this type of dashboard to view from the View Dashboard drop-down list on each shell. These dashboards are maintained at the shell level and are available to any user to view (but not edit) provided the user has permissions.

**Custom Dashboard.** This is a dashboard someone created externally using a dashboard creation software that generates SWF (Small Web Format) files. An Administrator can upload a SWF file into the Custom Dashboard for use within Unifier. Users cannot modify these dashboards. You can use this dashboard as your default dashboard.
Self-Service Portal

The Self-Service Portal enables users to sign in and work with specifically-enabled business processes. For example, Oracle Primavera customers use Unifier for corrective work order management. These work requests are usually generated from project participants who do not use Unifier. These participants can use the Self-Service Portal, which allows request submittals through a web-based tool. Users can use the Self-Service Portal to submit requests and to view the status of these requests, and to collaborate on submitted requests.

In uDesigner, you can enable certain business processes to be accessed through the Self-Service Portal. The business processes that you can enable to be accessed through the Self-Service Portal must have the following characteristics:

- Simple
- Company level
- Non-workflow
- Multi-record

The actions users can take through the Self-Service Portal are:

- Create a business process
- Modify a business process
- Add or remove business process attachments
- Add General Comments to a business process

Before you begin, design the Landing Page in terms of the text and graphics that you want it to contain. Then:

**Step 1:** Set Landing Page permission.

**Step 2:** Configure and activate the Landing Page.

**Step 3:** Specify users that receive portal-specific notifications. See *Setting Up a Non-Workflow Business Process* (on page 368) for details.

### Setting Up a Self-Service Portal Landing Page

**Note:** You must have Configure permission to be able to configure a Portal Landing page.

To set Landing Page permissions:

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode Access > Configuration > All > Landing Page.**
4) Set the permission as needed: **Configure:** Administrators can configure Self-Service Portal Landing Pages.
Configuring and Activating a Portal Landing page

If you have the Configure permission for the Self-Service Portal Landing Page, you can use an HTML editor to set up a Landing Page. After you configure and activate the Portal Landing Page, users signing in to the Self-Service Portal will see this landing page. You can configure one Landing Page, and activate this page for use.

**Note:** If no Landing Page is configured, a user sign in to the Self-Service Portal will see the Unifier Announcement page.

To configure and activate a Portal Landing page:

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Configuration > Landing Page** in the left Navigator.
3) Click **New**.
4) Enter the **Setup Name** of the Landing Page, and an optional **Description** of the page. The default initial status of the page is **Inactive**. You can change this status after you complete the page.
5) Click the **Layout** tab.
6) Use the **HTML** editor to add text, and perform other editing functions.
7) Click the **Insert Image** button (second button from the right in the toolbar) to insert an image into your Landing Page. Browse for the image, and click **OK**, and **Close** after the upload is complete.
8) Click **OK**.

To activate a Portal Landing page:

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Configuration > Landing Page** in the left Navigator.
3) Select the Landing Page in the log.
4) Choose **Status > Active**. You can inactivate the Landing Page by choosing **Status > Inactive**. When a Landing Page is inactive, the user who signs in the Self-Service Portal sees the Unifier Announcement page. If no active Landing Page is set up, the portal user sees a default Landing Page.
Managing Public Searches

A public search is any set of criteria a user has specified to search a log for specific records and has saved for future use as a search. Users can specify search criteria, give the criteria a name, and save it. The search then becomes available on their Tasks and business process log pages under the Filtered By button. In addition, users can make searches available to other users by making them public. Administrators with "Manage Public Searches" permissions can delete, change status, and transfer ownership of public searches created by any user.

In This Section

Setting Public Search Permissions..............................................................................67
Managing Public Searches..........................................................................................67

Setting Public Search Permissions

To set public search permissions:

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select Administration Mode Access > Data Structure Setup > Public Searches > <searches>.
4) Set the permissions as needed:
   - Manage Public Searches: Administrators can delete, change status, and transfer ownership of public searches.

Managing Public Searches

Administrators can delete, change status, and transfer ownership of public searches.

To delete public searches

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > Public Searches in the left Navigator. The Public Searches log opens. This log lists only searches that have the status of "public."
3) Select a public search.
4) Click Delete. The search is deleted from all Filtered by lists on Tasks logs and business process logs, and is no longer available to any users to use for searches.

To change the status of a public search

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > Public Searches in the left Navigator. The Public Searches log opens.
3) Select a public search.
4) Choose or Status > Private.
Note: When you change the status of a public search to private, it no longer appears on the Public Searches log.

To transfer the ownership of a public search
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > Public Searches in the left Navigator. The Public Searches log opens.
3) Select a public search.
4) Click Transfer Ownership.
5) Select a user to whom you want to transfer ownership and click OK.
Setting up Data Structure Setup Node

This section explains how to set up the information in the Data Structure Setup node. These include:

**System Modules**

Unifier functionality is loaded into the system through various Modules. Only the Site Administrator can load new modules.

**Application Modules**

Unifier Applications are deployed into the system through the Application Modules node.

**Data Cube Definitions**

A data cube definition is a query tool you can use to extract data and display it on a block of a configurable dashboard.

**Data Definitions**

Data definitions describe how data is entered into Unifier and stored. The definition consists of the data type (whether it is an alphabetical string or a number), the data size (in number of characters for strings), and the input method (from a text box, pull-down menu, radio button, or check box).

---

Notes:

- Users can translate custom defined strings into various supported languages. The Internationalization module (under the Configuration node in the left Navigator) contains a list of custom strings developed by the user, which provides the necessary details for translators.
- The numeric fields support international number formats (standards).
- Unifier displays all available currencies and their respective symbols.

You must create data definitions before you specify the data elements for forms. For information on creating new data definitions, refer to the *Unifier uDesigner User Guide*. The data definitions dictate how the data element will enter and store the information in Unifier. A data definition can belong to one of the following categories:

- **Basic**: Predefined or user-defined Data Definitions that contain all Data Definitions except the Cost Code definitions.
- **Cost Codes**: Displays the type of cost code (fields that define the structure of the Cost Codes) specified in uDesigner for the project. The type available for Projects (Standard) is WBS.
- **Data Picker**: Data pickers work with master business process logs, shells, and configurable managers that function across a shell hierarchy. The purpose of a data picker is to make it easier for users to choose records:
  - From a master business process log
  - From a class in a configurable manager that operates across shells
  - For auto-creation across shells
A data picker usually displays an extra navigation structure that makes it easier for users to choose records to work with. In operation, a data picker navigates to a specific business process, shell, or configurable manager and then extracts the records to display on the list by using a query the Unifier Administrator sets up.

**Data Elements**
Data elements combine a “Data Definitions” with a field label to become what users see on the forms in Unifier. The fields on the forms the users see are filled by data elements. A data element can be a text box, where the user types in information; a pull-down menu of choices (also known as a picker), such as dates or names; radio buttons, where the user must select one of the options presented; or a check box, where the user has the option of choosing something or not. Data elements are the name and form label only—the element is essentially an empty “shell” that will not contain values until they are specified in Unifier. For information on creating new data elements, refer the *uDesigner User Guide*.

**Data Indexes**
Allows the creation of user-defined database indexes that speed up the performance of large data sets. The database index name is constructed by a fixed prefix, UUU, plus internal row_id, followed by _ and a user-defined suffix and description.

**Data Views**
Provides a view of Unifier data obtained via SQL query. It allows access to all Unifier database tables in a company registry (registry dependency ensures data security). Data Views enable administrators to design and deploy custom reports (program- and shell-level), create user-defined reports (UDRs), and utilize data as a source for Data Cube Definitions (used to display live, or cached data in a custom company or shell dashboards).

**Dynamic Data Sets**
A dynamic data set is comprised of a “set” of data elements that includes a master data element and dependent data elements, which can be pull-down menus or radio buttons. You set up the elements and behavior of the set.

**Public Searches**
A public search is any set of criteria that was specified to search a log for specific records.

**Reports**
The System and Logs report modules are loaded by the Site Administrator.

**Statuses**
Statuses are created in the Data Structure Setup node and indicate the position of an asset, line item, record, and tag at any point in the business process, such as “approved,” “pending,” or “closed.” The status is what drives the workflow from one step to the next.

- **Assets Statuses**: An asset status controls which assets are displayed on an Asset class sheet, instead of impacting the disposition of a business process or line item like other statuses.
- **Line Item Statuses**: A line item status is part of the form that moves through the workflow, but it is not a visible part of a workflow.
**Record Statuses:** At each transaction, the Unifier user must apply a status to the record. Each business process produces at least one, and sometimes many, transaction records during its workflow.

**Tags:** Are used to mark business processes for Staging or Production before creating design bundles and deployment. A business process must have a complete status in order to export, tag or deploy.

**ER Views**

Provides a tabular view of Data Elements and Data Definitions used in modules.

**In This Section**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with system and configurable Modules</td>
<td>71</td>
</tr>
<tr>
<td>Working with Data Definitions</td>
<td>73</td>
</tr>
<tr>
<td>Adding and Managing Data Sets</td>
<td>77</td>
</tr>
<tr>
<td>Working with Data Elements</td>
<td>83</td>
</tr>
<tr>
<td>Configuring Dynamic Data Sets</td>
<td>85</td>
</tr>
</tbody>
</table>

**Working with system and configurable Modules**

Unifier functionality is loaded into the system through various modules. For example, the Cost Manager and Schedule Manager are system modules that provide cost and scheduling functionality. Also, your system might contain various configurable modules created in uDesigner. Only the Site Administrator can load new modules.

Some modules can be customized with "custom attributes," which are customized data fields, described later in this section.

**View available System and Configurable modules**

**To view the System Modules log**

1) Go to the **Company Workspace** tab and switch to **Administration Mode**.
2) Click **Data Structure Setup > System Modules** in the left Navigator. The modules log opens, showing all the modules and Unifier functions that have been loaded into your environment.

**Add custom attributes to the Project/Shell Sponsorship module**

Custom Attributes are customized data fields that can be created and added to the Project/Shell Sponsorship module. For example, you can use Custom Attributes to:

- Add a Region designation to a Project (accessed in the **Custom** tab of the Project or Shell window)
- Add a Division or Building designation to a Project/Shell User or Group (accessed in the **Custom** tab of the User or Group window in project user administration)

You can modify, delete, or change the order of custom attributes, as long as they have not yet been deployed. Once deployed, custom attributes cannot be deleted; form labels and the list order can be modified as needed.
To add custom attributes to the Project/Shell Sponsorship module

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > System Modules in the left Navigator. The Modules log opens.
3) Click Project/Shell Sponsorship in the left Navigator and click Open. The Custom Attributes window opens.
4) Click the Project, Shell, Project/Shell User or Project/Shell Group tab.
5) Click Add. The New Custom Attribute window opens. Complete the window fields as described in the table below.
6) Click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute Name</td>
<td>Enter a name for the custom attribute, with no spaces (an underscore _ can be used). The Attribute Name appears on the Basic Data Definitions Log but does not appear on the form.</td>
</tr>
<tr>
<td>Data Definition Source</td>
<td>Select a Data Definition from the drop-down list.</td>
</tr>
<tr>
<td>Form Label</td>
<td>Enter the label that will be displayed on the form.</td>
</tr>
<tr>
<td>Number of Lines</td>
<td>This field appears for multi-line text fields. Enter the number of lines to display and make available to users to enter text. This affects the display of the text field only (for example, entering &quot;4&quot; will allow the first four lines of text to display). Additional lines of text may still be added, depending on the character size of the field, and can be accessed with a scroll bar on the text field.</td>
</tr>
<tr>
<td>Append a Line Separator</td>
<td>Select the checkbox if you want to create a separator line on the form as each Custom Attribute is added.</td>
</tr>
</tbody>
</table>

To modify or delete custom attributes
From the Custom Attribute window, select the data definition and click the Modify button to make changes, or Remove to delete.

To change the list order
In the Custom Attribute window, select an attribute and click Move Up or Move Down.

To preview custom attributes
Click the Preview button from the Custom Attribute window.

To deploy the custom attributes
From the Custom Attribute window, select the data definition and click the Deploy button. The data definition will be available for use within Unifier.

Note: Once a data definition is deployed, it cannot be deleted or renamed.
Working with Data Definitions

Data definitions define the data type and input type of a data element. Data elements are created from data definitions.

There are two types of Data Definitions: Basic and Cost Codes data definitions.

- **Basic**: allow a company to provide values for certain types of data fields where a list of available choices is desired, for example, *Project Phase*, or to make data entry fields reportable
- **Cost Codes**: structure used for WBS Codes on the cost sheet and cost business processes

**Note**: Data definitions are defined under the Data structure node in Unifier.

About data definition properties

Data definitions can be of the following Data Types:

- **String**: Any alphanumeric character or special character like * or 
- **Integer**: A non-decimal number. Can be used for pull-down menu, radio button or checkbox fields
- **Date**: For date fields
- **Float**: This is applicable to currency amounts only
- **Input**: This determines how data is entered or displayed in the field

<table>
<thead>
<tr>
<th>This input method</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check box</td>
<td>Provides an option that the user can select (&quot;check&quot;) or not. &quot;Not checked&quot; is the default value.</td>
</tr>
<tr>
<td>Multi-line text area</td>
<td>Use this element for multiple text lines for entries up to 4000 characters long, such as descriptions or remarks.</td>
</tr>
<tr>
<td>Multi-select Input</td>
<td>Allows the user to make multiple selections from a list.</td>
</tr>
<tr>
<td>Picker</td>
<td>Allows users to choose from lists of items. Unifier and uDesigner are shipped with a number of predefined pickers. Pickers are system-defined in uDesigner, and cannot be created in Unifier. A Picker can be added to a uDesigner BP and allows users to cross reference another Unifier record. Pickers include BP Picker, BPO Picker, User Picker, Company Picker, Line Item Picker, SOV Picker, Fund Picker, Asset Picker, Project Picker, Shell Picker, and more.</td>
</tr>
<tr>
<td>Pull-down menu</td>
<td>Provides a list of items the user can choose from but cannot change (e.g., a date picker).</td>
</tr>
<tr>
<td>Radio buttons</td>
<td>Use where two values are possible and one must be selected.</td>
</tr>
</tbody>
</table>
Text box

A text box is usually used for smaller text (1 to 64 characters), but could be longer.

Dynamic Data Set

A dynamic data set allows one data element on the form to control both values and behavior of other data elements on the same form. (In this example, choosing Yes in the Single Project field activated the Project Picker field below it.)

Data definitions from uDesigner

The Data Definitions provide the structure for fields used on forms created in uDesigner. In uDesigner, the Data Elements are created to build fields to put on the forms. The Data Elements use the Data Definitions in uDesigner as the structure for the data.

The Data Definitions used are added to the list of Basic Data Definitions and the data values are added to the Data Definitions in Basic Data Definitions.

Note: All Basic or Cost Code Data Definitions must be created in uDesigner. This enables the user to distinguish between Data Definitions created in uDesigner, and the Data Definitions created in Unifier. Refer to the Unifier uDesigner User Guide for a full description of creating Data Definitions and Data Elements in uDesigner.

View Basic data definitions

Basic Data Definitions enable Unifier to provide fields, such as Phase, in which a company can enter their own data values. This enables companies to customize the values presented in some fields in Unifier.

Several data definitions are predefined in Unifier. Basic Data Definitions are found in the Basic Data Definitions log.

Note: New data definitions must be deployed before use. Data definitions that have not been deployed will show Not deployed in the Status column.

To access Basic Data Definitions

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > Data Definitions > Basic in the left Navigator. The Basic Data Definitions log opens. The system-generated data definitions are listed as Company or System in the Category field.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Descriptive name for the data definition. This is the database name, and accepts alphanumeric characters, spaces, - (dash) and _ (underline).</td>
</tr>
</tbody>
</table>
### Add a Basic data definition

The following procedures describe how to add a new Basic data definition to Unifier.

#### To create a basic data definition

1. Click the **Company Workspace** tab and switch to **Administration Mode**.
2. In the left Navigator, click **Data Structure Setup > Data Definitions > Basic**.
3. Click the **New** button. The **Create New Data Definition** window opens.
4. In the **Name** field, enter a unique name for the data definition.
   - The name can include alphanumeric characters, spaces, dashes, and underlines.
   - The name is case-sensitive.
   - The name cannot begin the name with a prefix reserved by Oracle Primavera: SYS, UU, or Picker.
5) In the **Data Type** field, specify whether the definition will be a string or integer data type. When you specify the data type, Unifier displays an additional field, **Input Type**.

6) In the **Input Type** field, select the method the user will use to enter the data.
7) Click **Apply** to open the data set tab, or **Ok** to close the Create New Data Definition window.

**View Cost Code data definitions**

Cost Code Data Definitions are used in the Cost Manager to build the identifier for a row of cost data. Your company may refer to these as Account Codes, Cost Codes or WBS Codes. For example, these could link costs on a project or shell to the General Ledger for Finance.

WBS Codes can be built with one to a maximum of 10 cost code segments. Each segment is defined by a different data definition, so a five-segment WBS Code would require five cost code data definitions.

Cost Code values may be entered one at a time or imported from a CSV file.

**To access Cost Code Data Definitions**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Definitions > Cost Codes** in the left Navigator. The **Cost Code Data Definitions** log opens.

**Add a Cost Code Definition**

- **To create a cost code data definition**
  1) Click the **Company Workspace** tab and switch to Administration Mode.
  2) In the left Navigator, click **Data Structure Setup > Data Definitions > Cost Codes**.
  3) Click the **New** button. The **Create New Data Definition** window opens.
  4) Enter a unique name for the cost code. The Category field is read only.
  5) Enter a Label for the cost code.
  6) Select an input type: either Text Box or Pull-down Menu.
  7) Click **Ok**.
Adding and Managing Data Sets

Data Set Values are applicable to data definitions that provide the user with a set of values from which to choose, for example, pull-down menus, radio buttons, and multi-select types. Some data definitions have been supplied with data set values; others must be entered. Data Set values can be added, removed or changed.

Some examples of Data Definitions for which data sets must be defined:
- Project/Shell Type, Project/Shell Site and Project/Shell Phase
- Discipline (for example, Architectural or Engineering; appears on some business process forms)
- Unit of Measure (appears for Line Item entry)
- Spend Category (for certain Cost-type business processes)

Add data set values to a pull-down menu or radio button

You can add or import data set values for data definitions that require data sets. These values are used to populate the available choices on pull-down menu fields, radio buttons, or checkboxes on a form or attribute form.

A couple of things to take note of:
- You cannot set a default cost code value.
- If the data definition is an integer type, and will be used in a formula, the value will be used in the formula, not the label. For integer data definitions, use care when assigning the value.
- Avoid semicolons and commas in data set values, as this can cause problems in the selection list.

To add data set values to a Data Definition (all except Multi-select Input)
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup>Data Definitions>Basic or Cost Codes in the left Navigator.
3) Select a data definition and click Open. The Modify Data Definition window opens.
4) Click the **Data Set** tab.

5) Click **Add**. An editable row appears on the window. You can press the **Tab** key to move from one field to the next, or click inside a field.

6) Enter a **Value**. This value is the data that is stored in the database. This value will appear on the form if you do not enter a label.

7) Enter an optional **Label**. This is what is presented to the user as a pull-down menu or radio button option. This can be different from the value.

8) In the **Status** field, enter **Active** or **Inactive**. The default is **Active**. If you want the value to remain on the data set but not show up for users at runtime, you can inactivate it, rather than remove it.

9) You can select the **Default** checkbox for one of the values on the data set list. This will display in the field at runtime. Selecting a default value is optional.

10) To add another row, click **Add**.

   - To insert a data set value in the middle of the list, select a value and click **Add**. The new row will be added above your selection.
   - To add a new value to the bottom of the list, be sure a row is not selected, and click **Add**. (Or, press the **Tab** key and tab through the fields of the last row, until the **Add** button is highlighted.)

11) If you want the data set list to be non-editable, then select the **Non-Modifiable** checkbox. Select this if you do want other users to be able to alter the list. Use caution before selecting **Non-Modifiable**. Once you select this you will be able to rearrange the order and select a different default value but you will not be able to modify or remove values from the data set. If this option is selected by a user with create permissions, other users cannot modify the data set value list. If it is selected by a user with modify permissions, the option cannot be deselected again, except by a user with create permissions.

12) Click **Apply** to save your entries, or **OK** to save and exit.
Add data set values to a multi-select Input data definition

Multi-select input type data definitions allow users at runtime to select more than one value to enter into the field at runtime. In the field, the values the user selected are separated with the Separator displayed on the General tab of the Data Definition window (such as a comma).

Note: Do not use an apostrophe (‘) in the data for a multi-select input type data definition. This can result in blank data in the selector. You cannot set a default value for this input type.

To add data set values to a Multi-select Input data definition

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup>Data Definitions>Basic in the left Navigator. The Modify Data Definition window opens.
3) Click the Data Set tab.
4) Click Add. An editable row appears on the window. You can press the Tab key to move from one field to the next, or click inside a field.
5) Enter a Value (128 character limit). This value will appear on the form. Values can contain spaces, but cannot contain the separate value (displayed on the General tab, for example, comma).
6) In the Status field, enter Active or Inactive. The default is Active. If you want the value to remain on the data set but not show up for users at runtime, you can Inactivate it, rather than remove it.
7) To add another row, click Add. (Or press the Tab key and tab through the fields of the last row, until the Add button is selected.)
8) If you want the data set list to be non-editable, then select the Non-Modifiable checkbox. Select this if you do want other users to be able to alter the list. Use caution before selecting Non-Modifiable. Once you select this you will be able to rearrange the order and select a different default value but you will not be able to modify or remove values from the data set.
   If this option is selected by a user with create permissions, other users cannot modify the data set value list. If it is selected by a user with modify permissions, the option cannot be deselected again, except by a user with create permissions.
9) Click Apply to save your entries, or OK to save and exit.

Import data set values

If you have a large number of data set values to enter (for example, if you want to populate a State pull-down menu with all 50 U.S. states), you can use a CSV file to import the values. This can be done for any data definition that uses a Data Set.

Importing data set values consists of the following:

Step 1: Export the CSV template file
   a. Open the Data Definition and click the Data Set tab.
   b. Click the Export button.
c. Save the file to your local drive. The file will contain any values that have already been entered for the data set.

Step 2: Complete the CSV file

a. Open the CSV template file.

<table>
<thead>
<tr>
<th></th>
<th>A6</th>
<th></th>
<th></th>
<th>GP</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AT</td>
<td>Assembly/Test Building</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>AU</td>
<td>Auditorium (Stand Alone)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>CA</td>
<td>Cafeteria (Stand Alone)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>CN</td>
<td>Conference Center (Stand Alone)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>DC</td>
<td>Data Center (Stand Alone)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>GP</td>
<td>General Purpose Building/Options</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>PK</td>
<td>Parking Structure</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>PW</td>
<td>Product Warehouse (Finished Goods)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>PB</td>
<td>Projects Building - Fab Support Building</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>RC</td>
<td>Recreation and Fitness Center (Stand Alone)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>WC</td>
<td>Warehouse - General (Shipping and Receiving)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Note there are no column headers in the template. Start at the top left corner of the file. The first column of the CSV file is the Value and the second column is the Label.

b. Delete any existing values. There cannot be duplicate values in a data set.

c. For each row, enter the Value and the Label. Include only two columns, and do not include a header row in the file. Do not add a status column; the status will be Active by default upon import.

d. Save the CSV file.

Step 3: Import the CSV file

a. Click the Import button.

b. Browse to the completed CSV file and click OK.

   New rows are appended to any existing entries. Unifier performs validation of the import file to ensure that valid CSV format is used. Duplicate entries are not allowed. After importing, you can rearrange the order of the rows if necessary.

c. If you see an error message after importing, proceed to Step 4 below.

Step 4: View the import validation error file (if applicable)

a. If an error occurs during import and you are presented with an error message, click Yes. You can then choose Open to open the file or Save to save the file to your local machine before opening.

b. Open the error file, which is a CSV file. Error messages are listed next to the row in which the error occurred (for example, if you have a duplicate row).

c. You can use fix the errors in this file (for example, remove duplicate rows) and re-import it after fixing the listed errors. Be sure to remove all extraneous text, including the error messages, before importing.
Modify or remove data set values

You can edit or remove values in data set lists. When you modify an existing data set, the new values will become available when new records are created that use the field (for example, create a new business processes).

To edit a data set value
1) Open a Data Definition and click the Data Set tab.
2) Double-click the value or label to modify. The field becomes editable. Edit the field as needed and click OK.

To activate or deactivate a data set value
1) Open a Data Definition and click the Data Set tab.
2) Click the Status pull-down menu and choose Active to activate, or Inactive to deactivate. Click OK.

Inactive values do not appear on the list at runtime.

Active and Inactive data set values

To remove a data set value from the data definition drop-down list
1) Open a Data Definition and click the Data Set tab.
2) Do one of the following:
   - To permanently remove a value, select it from the list and click Remove.
To remove the value from the data definition drop-down selection list that the user is presented with, but retain it in the data set value list, click **Inactive**.

3) Click **OK**.

### Reorder data set values

You can rearrange the order of data set lists. When you modify an existing data set, the new values will become available when new records are created that use the field (for example, create a new business processes).

#### To rearrange the order of the data set value list

Once you have added the data set values, you can rearrange the order of their appearance on drop-down lists, multi-select input fields, and radio buttons. You can do this in two ways:

- Using the **Move Up** and **Move Down** keys
- Changing the order of the rows by editing the **Row** column

#### To rearrange the order using the Move Up/Move Down keys

1) Open the **Status Definition** window and click the **Data Set** tab.
2) On the **Data Set** tab, highlight the data element and click the **Move Up** or **Move Down** key until the element is in the order you want.
3) Click **OK**.

#### To rearrange the order by Editing the Row column:

1) Open the **Status Definition** window and click the **Data Set** tab.
2) On the **Data Set** tab, highlight (or double-click) the row number of the element you want to reorder.
3) Enter the new row number the element should occupy.
4) Repeat step 2 for any other data elements you want to reorder.
5) Click the **Update Order** button; click **OK** to save the change and close the window.

### Row numbering follows a relative numerical progression

Row numbers on the list start at 1. When you change the order of the rows, you can enter just about any number; even positive, negative, and duplicate numbers. uDesigner will re-sort the rows by honoring the relative order of the numbers you enter.

If you enter:

- A negative number (e.g., -100): The row will move to the top, becoming row 1. If you enter two negative numbers, the "most negative" number becomes row 1, and the "next negative" number becomes row 2.
- Zero (0): The row will move to the top, becoming row 1 (or the row following any negative number you entered).
- A number greater than the existing number of rows (e.g., 100 when there are only 50 rows): The row will move to the end, becoming row 50. If you enter two numbers greater than the existing number of rows (e.g., 100 and 101), the sort will honor the order of the numbers. In this example, 100 and 101 will become rows 49 and 50.
Unifier Administration Mode

- A duplicate number (i.e., the same number for two or more different rows): The duplicate-numbered rows will become adjacent rows (in no specific order).

Example of row numbers before sorting:

Edited row numbers:

Row numbers after sorting:

**Working with Data Elements**

A data element is a data field on a business process. Data Elements are defined by Data Definitions. The data element properties are defined by the Data Definitions.
You can use a Data Definition to define the properties of more than one data element. Data Elements are defined under the Data structure node as well as the Attribute forms in Unifier.

You can export a CSV file listing specific data elements.

You can also view the usage of each data element, that is, the list of specific business processes where the data element is used.

**Access data elements**

**To access the Data Elements log**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Elements** in the left Navigator. The **Data Elements** log opens.

   The log lists the data elements used for your company. For each data element, the log displays the Data Definition on which it is based, and the Form Label, which is how the data element appears on a form.

**Export data elements**

You can create a CSV file containing the current list of data elements. This can be useful if you need to create different combinations of data set values for Dynamic Data Sets, taking from different sources of data definition data set values.

**To export data elements**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Elements** in the left Navigator. The **Data Elements** log opens.
3) From the **Data Elements** log, click the **Export** button. You may Open the file to preview it or Save it to your local drive.
4) Name the file and click **Save**.

**View data element usage**

The Usage button in the Data Elements allows you to view the business processes or attribute forms that the data element is being used.

**To view data element usage**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Elements** in the left Navigator. The **Data Elements** log opens.
3) From the **Data Elements** log, select a data element and click **Usage**. The Usage window displays the forms that use the data element.
Configuring Dynamic Data Sets

This flexible uDesigner option can be used on business processes and attributes forms. It allows one data element on the form to control both values and behavior of other data elements on the same form.

A dynamic data set is comprised of a "set" of data elements that includes a master data element and dependent data elements, which can be pull-down menus or radio buttons. The values that are available to users at runtime for the dependent fields are dependent on the selection the user makes for the master data element field. A dynamic data set can be used on business processes and attributes forms, and allows one data element on the form to control both values and behavior of other data elements on the same form.

For example, you can define a dynamic data set that includes a Country, State, City, Postal Code and Zip Code data elements that function as pull-down menus on a form. The Country field is a master data element. The set can be configured so that, at runtime, the user must select a value for Country, which dynamically controls the values that are available to be chosen for State. The user then selects a State, which drives the choices available for City.

Field behavior (such as required, or read-only) can also be controlled by the dynamic data set. For example, a dynamic data set might include data elements for Country, Zip Code and Postal Code. At runtime, depending on the selected value for the Country, the Zip code field may get become enabled and a required field, while the Postal Code field becomes disabled.

How to set up a dynamic data set

Dynamic data sets are imported automatically when you import a business process or attribute form that has the dynamic data set on it.

Setting up a dynamic data set consists of the following:

1) **Prepare elements and data set values.** View dynamic data set properties to identify elements of the dynamic data set:

   - Master Data Element, which drives the behavior of the set.
   - Value Set, which lists the data elements whose values will be controlled by the master element (for example, if the master element is Country, then the value set might include a pull-down data element State, the values of which will change depending on the country chosen.
   - Behavior Set, listing elements whose behavior is controlled by the master element (for example, a field that becomes Required or Disabled depending on the value chosen for the master element (for example, the Country chosen might dictate whether the Postal Code or Zip Code field is enabled for the user).

Verify that data definition data sets are populated. The data elements that can be part of a dynamic data set can be pull-down menus or radio buttons. The values for the selections are maintained in the Data Set tab of the data definition properties. Be sure that the individual data definitions have valid data sets. (For example, if you have a State pull-down data element, the data set corresponding to the data definition for the State field must be populated with the state options you wish to make available to users.)
2) **Define the Value Set and Behavior Set.** The value set consists of the fields whose values will be controlled by the master data element selection at runtime. The Master data element is the first element on the list. You will define the values that display at runtime.

The behavior set contains the fields whose behavior (Required, Disabled) will be controlled by the master data element selection at runtime. You will define the behavior of the fields at runtime.

---

**Access dynamic data sets**

Dynamic data sets are imported into Unifier when a business process or attribute form on which they appear are imported.

**To access dynamic data sets**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Data Structure Setup>Dynamic Data Sets** in the left Navigator. The Dynamic Data Sets log opens.

---

**View dynamic data set properties**

The dynamic data set properties and data elements are designed in uDesigner. The properties window identifies:

- Master Data Element, which drives the behavior of the set.
- Value Set, which lists the data elements whose values will be controlled by the master element (for example, if the master element is Country, then the value set might include a pull-down data element State, the values of which will change depending on the country chosen).
- Behavior Set, listing elements whose behavior is controlled by the master element (for example, a field that becomes Required or Disabled depending on the value chosen for the master element (for example, the Country chosen might dictate whether the Postal Code or Zip Code field is enabled for the user)).

**To view dynamic data set properties**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup>Dynamic Data Sets** in the left Navigator. The Dynamic Data Sets log opens.

3) Select the dynamic data set to edit and click **Properties**. The Properties window opens. The Properties window is view-only.

4) The **General** tab displays the general information about the dynamic data set:
   - **Name and Description**
   - **Master Data Element**: the data element that serves as the master data element for the set
   - **Data Definition**: the data definition corresponding to the master data element. The data definition will be a pull-down menu or radio buttons. The values available for the master data element are entered in the Data Set tab for the data definition.
   - **Form Label**: the form label of the master data element

5) Click the **Value Set** tab. This tab displays the data elements of the value set, which are the fields whose values will be controlled by the master data element selection at runtime. The Master data element is the first element on the list. Values of each data element are based on the data set values defined under base Data Definition.

6) Click the **Behavior Set** tab. This tab displays the data elements of the behavior set, whose behavior (Required, Disabled) will be controlled by the master data element selection at runtime.

---

**Define the value set and behavior set values**

You can add values to dynamic data sets manually one a time, or by importing multiple values from a CSV file. The following describes adding dynamic data set values manually.

Fields defined with a Value Set have values limited by the master data element. For example, a Country master data element can control the values that display for a State field.

**To define the value set and behavior set combination**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Data Structure Setup>Dynamic Data Sets** in the left Navigator. The Dynamic Data Sets log opens.

3) Select the dynamic data set and click **Open**. The dynamic data set log opens for the selected set.
4) Click **New**. The Add/Edit <set name> window opens.

![Add/Edit window](image)

5) Complete the window. The fields on the window will depend on how the dynamic data set was designed. It may include a value set, a behavior set, or both:

- **Value Set**: These are the data elements that will be controlled by master data element selection at runtime. The Master data element is the first element on the list.

  Click the drop-down list and select a value for each data element. The drop-down list values are based on the data set values defined under the base data definition.

  In the example in the following figure, the value set is Country and State. At runtime on the form, when the user selects a Country, the State field will populate with the states that are associated with that country. These value sets determine the combinations of Country-State that display.

- **Behavior Set**: The behavior of these data elements (Required, Disabled) will be controlled by the master data element selection at runtime.

  Click the drop-down and select **Required** (Field displays a *) or **Disabled** (field is read-only). If you leave the selection blank (or "Select" on the drop-down), there will be no change in behavior for the element.

  In the example in the following figure, the behavior set is Mail Stop and Zip Code. In this case, at runtime, depending on the Country chosen, either Mail Stop or Zip Code will become a required field, or will be disabled.

6) To add another Value Set and Behavior Set combination, click **Add**, which will save the combination you just entered and allow you to add another.

7) When you are done adding combinations, click **OK**. The set displays on the dynamic data set log.

---

**Import dynamic data set values**

Importing dynamic data set values consists of:

**Step 1: Export the CSV template file**

a) Click the **Export** button.

b) Save the file to your local drive.
Step 2: Complete the CSV file

a) Open the CSV template file.
b) Enter values for each column as applicable:
   - **Value set**: The columns correspond to the date elements that make up the value set. The values you enter here must match values in the data set for the data definition.
   - **Behavior set**: The behavior set column is labeled with a (B). Valid values are Required (makes the data element a required field), Disabled (the data element is read-only), or you can leave it blank.

c) Save the CSV file.

Step 3: Import the CSV file

a) Click the **Import** button.
b) Browse to the completed CSV file and click **OK**.
c) To download a CSV file containing status details of the import, click **Yes** at the prompt.

   The rows that you completed in the CSV file are appended to existing entries. Duplicate entries are allowed.

### Delete a dynamic data set combination

You can delete a dynamic data set combination (value set and behavior set). This removes the combination from use with the dynamic data set.

**To delete a dynamic data set combination**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup>Dynamic Data Sets** in the left Navigator. The Dynamic Data Sets log opens.
3) Select the dynamic data set and click **Open**. The dynamic data set log opens for the selected set.
4) Select an entry and click **Delete**. Click **Yes** to confirm.

### Edit a dynamic data set combination

When you edit a dynamic data set, any changes you make will not reflect in forms. The data element must be deleted from the form and added again in uDesigner, and the form re-imported.

**To edit a dynamic data set**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup>Dynamic Data Sets** in the left Navigator. The Dynamic Data Sets log opens.
3) Select the dynamic data set and click **Open**. The dynamic data set log opens for the selected set.
4) Select an entry and click **Open**, or double-click to open.
5) Make modifications to Value Set or Behavior Set as necessary and save.
View dynamic data set usage
You can view the forms on which a dynamic data set is used.

To view dynamic data set usage
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data Sets log opens.
3) Select a dynamic data set and click the Usage button in the toolbar. The Usage window opens, listing the forms on which the dynamic data set is used.
Creating Data Views

Company Administrators can create data views from data base queries to use as data sources for project/shell-level user-defined reports and shell dashboards. Data views must contain project_id in the SQL query for the data view to show up in a project or shell-level UDR data type list.

**Note:** Data views published prior to the Primavera Unifier 9.5 release must be republished (i.e., set to draft status and then reset to published status) before they show up in the UDR data type list.

Before you begin: Define your reporting requirements first. Collaboration between business users and technical development teams helps identify the data you need to collect and how to present that data so report recipients will have an easy-to-read, useful report.

**Step 1: Set permissions for data view creation.** See *Grant Permissions for Data View Creation* (on page 92).

**Step 2: Create data views.** See *Create and Publish Data Views and Metadata* (on page 92).

- Data views must be published (as indicated by the Publish Date) before you can use them as data sources in UDRs, data cubes, or custom reports.
- Test your data view SQL queries in the Unifier Staging environment before deploying them in the Production environment because only by testing can you be sure the query is valid and returns the desired data.

  **Note:** See the *Internationalizing Unifier Environments (Staging and Production)* section for translation information.

**Step 3: View data and metadata.** See *View data (query results) and metadata (columns) in the view* (on page 94).

**Step 4: Export data.** See *Export data (query results)* (on page 95).

**Note:** Data Views are included any time a:

- Custom Report, which is using Data Views, has been bundled for a Production environment.
- Data Cube, which is using Data Views, has been bundled for a Production environment.
- User-Defined Report (UDR), which is using Data Views, has been bundled for a Production environment.
In This Section

Grant Permissions for Data View Creation .............................................................. 92
Create and Publish Data Views and Metadata ........................................................ 92
View data (query results) and metadata (columns) in the view ................................ 94
Export data (query results) ...................................................................................... 95
View Data View Usage in Reports and Data Cubes ................................................ 96
Edit data views ........................................................................................................ 96

Grant Permissions for Data View Creation

To grant permission for data view creation

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select Administration Mode Access > Data Structure Setup > Data Views. The Permission Settings window opens. Here you can add, modify, or remove permission settings.
4) Click the Add button. Another window called Permission Settings opens.
5) Click the Add Users/Groups button. The Users/Groups window opens.
6) Select the intended users and/or groups and click the Add button
7) Click the OK button to return to the Permission Settings window.
8) Select the users or groups in Select Users/Groups, located in the upper portion of the window, and select the appropriate level of access for the user or group in Permissions Settings, located in the lower portion of the window.
   View: allows users and groups to see the data view settings
   Create/Modify, allows users and groups to define or change data view settings. This setting includes View permission.
9) Click the OK button.
10) Click the Apply button to save changes and keep the window open, or the OK button to save changes and close the window.

Create and Publish Data Views and Metadata

After you create a data view, you must publish it to be able to use it in user-defined reports, data cubes, or custom reports. There are two things to know about using data views in user-defined reports:

- Data views must contain project_id in the SQL query for the data view to show up in a project or shell-level UDR data type list
- Data views published prior to the Primavera Unifier 9.5 release, must be republished (i.e., set to draft status and then reset to published status) before they show up in the UDR data type list
Depending on the data elements you choose, you might need to publish the metadata associated with the data view. For example, if the selected data element has a data definition type of pull-down Menu, you will have to publish the metadata to see the actual label of the pull-down rather than the value. In the case where a data element is defined as Actual Value? based on a Yes/No data element, with 0= No and 1=Yes, if Actual Value? is used in the data view, then you need to publish the metadata of Actual Value? to get the Yes or No value rather than 0 or 1.

**To create Data Views**
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Data Structure Setup > Data Views in the left Navigator. The User-Defined Data Views log opens.
3) Click New. The User-defined View window opens.
4) The Prefix is auto-populated with the company short name. Enter the name of the Data View, the label, an optional description, and the SQL query for the Data View. For further details on how to create SQL queries used in the creation and management of Data Views, please consult the Oracle Consulting Services team.
5) Click OK.

**To publish Data Views**
1) Go to Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Data Structure Setup > Data Views. The User-Defined Data Views log opens.
3) Select an unpublished Data View.
4) Click the Status button.
5) Select Published.
6) Click OK.

**To publish metadata**
You can associate metadata with its Unifier data set for both labels and values. Data views tend to contain technical shorthand from system and SQL abbreviations. While clear to the technical person who wrote the data view, report consumers will appreciate seeing the same field labels and field value selections they see in their business processes and managers.

For example, in your data view you might include the data element "year_pd," which represents a pull down menu with selections for different years assigned to its data set. In your user-defined report, you might want to see the label "Year" instead of "year_pd;" and you might want to query on meaningful values, such as 1999, 2001, 2002, etc., instead of the numeric values of the data definition, 1,2,3, etc.

1) In the User-Defined Data Views log, select a published Data View.
2) Click the Metadata button.
3) Double-click in the **Definition** field for each data element and select the data definition for the selected element. The data definitions available for selection are filtered by the data elements used.

4) Double-click the **Label** field for each element you want to use in the UDR. Rename it to whatever you want to see in the report.

5) Click **Publish Metadata**.

---

### View data (query results) and metadata (columns) in the view

The **Data** button will return the query results of the view (essentially, a preview of the report results, without any user entered parameters).

The **Metadata** button will return all of the columns in the view. The Metadata button will return the definition of the columns: names, type and labels of the columns used in the view. For example:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>INTEGER</td>
<td></td>
</tr>
<tr>
<td>company_id</td>
<td>COMPANY_ID</td>
<td>INTEGER</td>
</tr>
<tr>
<td>rootid</td>
<td>ROOTID</td>
<td></td>
</tr>
<tr>
<td>shellmodel</td>
<td>SHELLMODEL</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>shellnumber</td>
<td>SHELLNUMBER</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>shellname</td>
<td>SHELLNAME</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>shellphase</td>
<td>SHELLPHASE</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>createdate</td>
<td>CREATEDATE</td>
<td>TIMESTAMP</td>
</tr>
<tr>
<td>isemplate</td>
<td>ISEMPLATE</td>
<td>BIT</td>
</tr>
<tr>
<td>shellimage</td>
<td>SHELLIMAGE</td>
<td>INTEGER</td>
</tr>
<tr>
<td>previousstatus</td>
<td>PREVIOUSSTATUS</td>
<td>INTEGER</td>
</tr>
<tr>
<td>address_code</td>
<td>ADDRESS_CODE</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>latitude</td>
<td>LATITUDE</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>longitude</td>
<td>LONGITUDE</td>
<td>VARCHAR</td>
</tr>
<tr>
<td>shelllocation</td>
<td>SHELLLOCATION</td>
<td>VARCHAR</td>
</tr>
</tbody>
</table>

---

**To view query results**

1) In Administration Mode, go to the **Company Workspace** tab and click **Company > Data Structure Setup > Data Views** in the left Navigator. The User-Defined Data Views log opens.

2) Select a view in the User-Defined Data Views log.

3) Click the **Data** button. The results window will display the query results.

**To view columns**

1) Select a view in the User-Defined Data Views log.

2) Click the **Metadata** button. The results window will return all of the columns in the view.
If the Data View is in Draft status, then the meta data that you see will be based on the last Published data. If the Data View has not been published before, then no data is displayed.

You can delete a Data View that was included in the Production bundle, indirectly.

**Note:** Although deletion of a Data View is possible, if a Data View has been used in a tagged UDR, Custom BIP report, or Data Cube for Production bundle, then the bundle creation will fail because of the missing data views.

### Export data (query results)

The results of the data query can be exported as CSV or SQL files.

**To export data as CSV**

1) Select a view in the User-Defined Data Views log and click the **Data** button. The results window will display the query results.

2) Click the **Export As CSV** button.

3) At the prompt, you can choose to Open or Save the resulting CSV file to your local drive.

The CSV file will contain the data that is displayed on the results log window. By default, the first 100 lines will be displayed. You can click the Display drop-down (in the upper right corner of the results log window) and choose 200 to display the first 200 lines. When you click Export As CSV, the CSV file will contain the 100 (or 200) lines displayed in the window.

Only the 100 or 200 rows will be exported at a time. You cannot export the entire result of the view (for example, if there are more than 200 rows) in one click. You must export in groups of 200 rows at the maximum and then manually combine the exported results.

**To export data as SQL**

1) Select a view in the User-Defined Data Views log and click the **Data** button. The results window will display the query results.

2) Click the **Export As SQL** button.

3) At the prompt, you can choose to **Open** or **Save** the resulting SQL file to your local drive.

   This will export your SQL script to create the table required for the data view and the data itself.

**Notes on Working with the Oracle Database**

- Only the 100 or 200 rows will be exported at a time. You cannot export the entire result of the view (for example, if there are more than 200 rows) in one click. You must export in groups of 200 rows at the maximum and then manually combine the exported results.

- Note that SQL export files have the .sql extension and work best with the Oracle database as the field types used in the creation of the data view are of Oracle type (for example, VARCHAR). If the exported SQL file is to be used in a database other than Oracle, you must manually modify that file to replace the field types with the types that work with the non-Oracle database.
Unifier uses a field type called TIMESTAMP for all date or time fields, so you must modify the session date format to match the timestamp used in Unifier. For example, you can run the following statement for an Oracle database: ALTER SESSION SET NLS_DATE_FORMAT = 'YYYY-MM-DD HH24:MI:SS';

- If you are building multiple data views based on other data views, changes a data view in the lower hierarchy (example adding a new data element) will necessitate the dependent views to be refreshed by changing them to Draft and then republish the data views to incorporate the changes. For example, if Dataview 2 is based on Dataview 1, and you add a new field to Dataview 1 and then republish it. You must then change Dataview 2 to Draft and then republish it so that it will contain the change you made in Dataview 1.

- Additional cleaning of the data (in case of export to SQL file) might be needed if there are (' apostrophes in the values of some fields, or if there are ampersands (&). This will result in inconsistent values between the results in Unifier and the result in the local database after import.

### View Data View Usage in Reports and Data Cubes

**To view reports and data cubes in which a Data View is used**

1. Select a view in the User-Defined Data Views log.
2. Click the **Usage** button. The Usage window opens, listing the reports and data cubes in which the data view is used.

### Edit data views

Data views must be in draft mode to edit.

**To edit data views**

1. In Administration Mode, go to the **Company Workspace** tab and click **Data Structure Setup > Data Views** in the left Navigator. The user defined Data Views log opens.
2. Select a data view in the User-Defined Data Views log.
3. Click **Status** and select **Draft**.
4. Click the **Open** button to access the SQL statement.
5. Edit the SQL statement and click **Apply** or **OK** to save changes.
6. Highlight the data view and click **Status**.
7. Select **Publish** to make the data view available for use in user defined reports, data cubes, and custom reports.
Creating Data Cubes

Data cubes comprise data that you can use to render a variety of charts (bar, area, column, line, and table) in a custom dashboard (either at company-level or shell-level), or in a custom data block of a shell dashboard. In this way you can visually compare aspects of your data set.

Data cubes are either company level or shell level. The data source for data cubes can be from a business process or a manager attribute form, or from a data base query. Unifier does not limit the number of data cubes you can create.

Creating a data cube requires that you:

- **Granting permissions for Data Cube** (on page 101) to create a data cube
- **Defining a Data Cube** (on page 97) a new data cube, which includes
  - Selecting the data source for the data cube
  - Completing the data cube properties
- Publishing the data cube
- **Granting permissions for Data Cube** (on page 101) so they can view the data cube composition in Data Cube Definitions

In This Section

- Defining a Data Cube .............................................................................................. 97
- Selecting data sources ............................................................................................  99
- Adding data elements ............................................................................................ 100
- Defining queries ..................................................................................................... 100
- Granting permissions for Data Cube ...................................................................... 101
- Publishing Data Cube ............................................................................................ 101

Defining a Data Cube

To define a data cube

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Cube Definitions** in the left Navigator. The Data Cubes log window opens.
3) Click either **New > Shell Data Cube** or **New > Company Data Cube**. The Create Data Cube window opens.
4) Select **Data Type** or **Data View**.
   - A data type comprises business process and manager attribute forms
   - A data view comprises results from a data base query

*Note*: When creating data cubes, data views are only seen when you select Data View as the source. This is different from UDR creation when data views are listed with data types.

5) Click **OK**. The Data Cube window opens.
6) Complete the General tab.
   - **Name**: enter a unique name for the data cube
   - **Description**: this field is optional
   - **Data Type**: this read-only field is automatically completed with the data type selection
   - **Type**: this read-only field is automatically completed with the level selection

7) Click the **Data Source** tab. On this tab you can add the data sources you want to include in the data cube, for example, a business process, workflow, or shell.

8) Click the **Add** button. The Data Sources window opens listing all available data sources for this data cube.

9) Select at least one data source. You cannot move to the next tab or save the data cube without a data source selection. You can add as many data sources as are available.

10) Click the **Data Elements** tab.

11) Select at least one data element. You cannot save the data cube without a data element selection. You can add as many data elements as are available.

   The selected data elements are arranged in the Data Elements pane in a grid; the table below describes the columns.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source</td>
<td>The data element data source.</td>
</tr>
<tr>
<td>Label</td>
<td>The data element label. You can modify this label.</td>
</tr>
<tr>
<td>Name</td>
<td>The data element name.</td>
</tr>
<tr>
<td>Type</td>
<td>The data element type.</td>
</tr>
<tr>
<td>Group</td>
<td>Click to define whether the data element can be used as a Grouping element when the data cube is used.</td>
</tr>
<tr>
<td>Summary</td>
<td>Click to define whether the data element can be used as a Summary type.</td>
</tr>
</tbody>
</table>

   On this pane you have the option to add functions. To do so, click **Add Functions**. Select a function type: Formula, Date Difference, Date Add, Date Function.
   - For **Formula** click **Create**. Create a formula and click **OK**. The data source available for the formula are based on the data sources you selected in the Data Sources tab.
   - For **Date Difference** enter a column heading name, specify the dates, and whether to show partial days. Click **OK**.
   - For **Date Add** enter a column heading name, specify the date and the add function. Click **OK**.
   - For **Date Function** enter a column heading name and specify the date. Click **OK**.

   To modify a data element, select the data element and click the **Modify** button.
   To remove a data element, select the data element and click the **Remove** button.
   Use the **Move Up** or **Move Down** buttons to reorder the listed data elements.

12. Click the Query tab if you want to add one or more queries to the data cube. See **Define report queries (query condition)** (on page 659).
Data Cubes and Production Bundles

Data Cubes are used for creating Shell dashboards. Data Cubes defined in the Staging environment can be bundled and transferred to the Production environment.

**Note:** Design Bundle is included as a part of Production Bundle.

You can pick and choose which Data Cubes to transfer by using the Tag option in the Data Cubes log window.

The Data Cubes log window contains the following columns:

- Name
- Description
- Type
- Source
- Last Modified
- Published Date
- Last Published By
- Tag
- Last Bundled Date

The Tag option (the Tag drop-down from the toolbar) allows you to tag a Data Cube for Production. The following provides additional information about the Tag option:

- To tag a Data Cube, select the item and click the Tag option. There are two sub-options available: Production and Clear.
- The Clear option also allows you to remove an existing tag. If you clear a tag for a Data Cube, that Data Cube will not be included in the Design Bundle.

**Note:** The Data Views associated with the Data Cubes are included in the Design Bundle.

- You can tag deployed Data Cubes, only.
- Once you tag Data Cubes for Production, the Data Cubes will be included in the Design Bundle.
- You can delete a tagged Data Cube that was included in the Production bundle.
- When the Design Bundle is being created, the system will check to ensure that the record that has been tagged is in Publish status, or not. If the record that has been tagged is not in Publish status, then an error message is displayed at the time of creating the export bundle.
- Data Views are included any time a Data Cube, which is using Data Views, has been bundled for a Production environment.

The Last Bundled Date column displays the date when the Data Cube was last included in the Production bundle. When a Production Bundle, which includes Data Cubes, is created successfully, the system will stamp the Data Cubes with the Last Bundle Date.

### Selecting data sources

To select data sources for data cubes:

---

Unifier Administration Mode
1) Click the **Data Sources** tab. This tab lists the available data sources for the data cube.
2) Click **Add** to add a data source. The Data Sources window opens.
3) Select one data source or multiple data sources and click **OK**.
4) To remove a data source, select a data source and click the **Remove** button.
5) Next, define data elements in the Data Elements tab, as described in the following procedure.

## Adding data elements

### To add data elements for data cubes

1) Click the **Data Elements** tab where you will see the fields listed in the table below these directions.
2) Click **Add Elements**.
3) Select one data element or multiple data elements and click **OK**.
4) Click **Add Functions**. Select a function type:
   - **Formula**: Click **Create a formula** and click **OK**. The data source available for the formula are based on the data sources you selected in the Data Sources tab **Date Difference**: Enter a column heading name, specify the dates, and whether to show partial days. Click **OK**.
   - **Date Add**: Enter a column heading name, specify the date and the add function. Click **OK**.
   - **Date Function**: Enter a column heading name and specify the date. Click **OK**.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source</td>
<td>The data element data source.</td>
</tr>
<tr>
<td>Label</td>
<td>The data element label. You can modify this label.</td>
</tr>
<tr>
<td>Name</td>
<td>The data element name.</td>
</tr>
<tr>
<td>Type</td>
<td>The data element type.</td>
</tr>
<tr>
<td>Group</td>
<td>Click to define whether the data element can be used as a <strong>Grouping</strong> element when the data cube is used.</td>
</tr>
<tr>
<td>Summary</td>
<td>Click to define whether the data element can be used as a <strong>Summary</strong> type.</td>
</tr>
</tbody>
</table>

### Additional actions you can take

- Modify a data element by selecting the data element and clicking the **Modify** button.
- Remove a data element by selecting the data element and clicking the **Remove** button.
- Reorder the listed data element by using the **Move Up** or **Move Down** buttons.

### Defining queries

#### To define queries for data cubes

1) Click the **Queries** tab.
2) Build a query. See *Define report queries (query condition)* (on page 659) for details on creating queries.
3) When you have finished working with the Data Cube window tabs, click **OK**.

### Granting permissions for Data Cube

**To grant permission for data cube creation, modification, or viewing**

1) Go to the **Company Workspace** tab and switch to **Admin mode**.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode Access > Data Structure Setup > Data Cube Definitions**. The Permission Settings window opens. Here you can add, modify, or remove permission settings.
4) Click the **Add** button. Another window called Permission Settings opens.
5) Click the **Add Users/Groups** button. The Users/Groups window opens.
6) Select the intended users and/or groups and click the Add button
7) Click the **OK** button to return to the Permission Settings window.
8) Select the users or groups in Select Users/Groups, located in the upper portion of the window, and select the appropriate level of access for the user or group in Permissions Settings, located in the lower portion of the window.
   - **Create/Modify**: You must have Create/View permission to create or define or change data cubes. This setting includes View permission.
   - **View**: You can use this setting to allow users and groups to see the data cubes.
9) Click the **OK** button.
10) Click the **Apply** button to save changes and keep the window open, or the **OK** button to save changes and close the window.

### Publishing Data Cube

You must publish data cubes to make them available for use in the configurable dashboard.

**To publish data cubes**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Data Structure Setup > Data Cube Definitions** in the left Navigator. The Data Cubes log window opens.
3) Select a data cube and click the **Publish** button.

**Note**: You can modify a published data cube, but you must republish it to make the changes available to users.
Configuring and Publishing BI Publisher Custom Prints and Reports

The following sections explain how to configure custom prints and custom reports in the BI Publisher (Oracle Business Intelligence (BI) Publisher or BIP).

To publish custom prints and custom reports:

1) Prepare the custom print or custom report
2) Click Status
3) Select Publish

In This Section

Custom Prints and Reports Overview ................................................................. 103
Custom Prints and Reports Windows Log......................................................... 104
BI Publisher Report Levels ............................................................................. 109
Sample XML Data for Custom Prints and Reports ........................................... 110
Creating BI Publisher Custom Print ................................................................. 111
Publishing BI Publisher Custom Print ............................................................... 114
Creating BI Publisher Custom Report .............................................................. 115
Publishing BI Publisher Custom Report ........................................................... 121
Uploading Template for Custom Report Configuration (Template File tab) ...... 122
Modifying Existing Custom Report Configuration .......................................... 123
Setting Permissions for Custom Reports ......................................................... 124

Custom Prints and Reports Overview

To access Custom Prints and Reports sub-node: Open Unifier > Company Workspace > Admin mode > Configuration > Custom Prints and Reports.

Note: To run custom reports, access Reports node: Open Unifier > Company Workspace > User mode > Reports. Data views are required for creating custom reports.

The New option of the Custom Prints and Reports log window (or File > New) allows you to create the following:

- **Custom Print with Internal Data Model**
  Create a new BI Publisher Custom Print template based on an internal data model (standard data model), which is generated and maintained internally by Unifier.

- **Custom Print with External Data Model**
External data models can be created outside of the Unifier system. They can include links to multiple tables and pull data from multiple Business Processes. These data models can be used to create custom print templates. You can create a Custom Print template based on an external data model. The concept of creating a Custom Print template based on an external data model is similar to the concept of creating a Custom Print template based on an internal data model, except that when you create a a Custom Print template based on an external data model:

The Data model type in the General tab will be seen as External. The Sample Data tab will not be seen.

**Note:** When BI Publisher Custom Print templates are created using external data model, Unifier does not generate any additional data models for use in the print template.

**Report with Internal Data Model**

Create a new BI Publisher Custom Report based on the standard data model, which is generated and maintained internally by Unifier. When you save the BI Publisher Custom Report, Unifier saves changes applied to the following in the data model:

- Data views
- Data links
- Query parameters
- Additional parameters

**Report with External Data Model**

Create a new BI Publisher Custom Report to upload the custom data model file created using BI Publisher. Unifier will not maintain the data model file. You can generate sample data for external model based report provided that the external model based report is published at least once. You have to externally modify the .XDM file either manually or by using the BI Publisher data model editor. Then re-upload the report.

**Creating Data Model (.XDM) File**

To create a new .XDM file, you can either:

a. Create the .XDM file from a local BI Publisher server, or
b. Copy any existing .XDM file, from an existing report, and create a new .XDM file.

**Note:** To create an .XDM file that works with Unifier, you need to make changes in the .XDM file, accordingly.

**Custom Prints and Reports Windows Log**

**Access Control and Log**

The following applies to all Custom Prints and reports (Internal Reports and External Reports).
Users do not need separate set of permissions to access the External Reports in the Custom Prints and Reports log. Users who have permissions to the **Custom Prints and Reports** node are able to view the External Reports in Admin mode.

In User mode, since the External Reports appear as a list, the permission settings are the same as those for Internal Custom Reports (View).

**Log**

The Custom Prints and Reports windows log (Custom Prints and Reports - Current View: All) displays the following information:

- **Name**
  Name of Print template or name of Report.
  For External Reports: This field displays the name of the report populated from the BI Publisher server.
  For Custom Print: The name of the print template, as entered in Unifier.
  For Internal Reports: The name of the report as entered in Unifier.
  The maximum character length in Unifier is 255. After 255, the characters will be truncated.

- **Description**
  Description of Print template or description of Report.
  For External Reports: This field displays the description of the report populated from the BI Publisher server.
  For Custom Print: The description of the print template, as entered in Unifier.
  For Internal Reports: The description of the report, as entered in Unifier.

- **Type**
  Custom Print
  External Reports: The reports that are created in the BI Publisher server, and are displayed here, will have a Type: External Reports.
  Internal Reports: The reports that are created in Unifier will have a Type: Internal Reports.

- **Location**
  Location of the report in the BI Publisher server relative to the path specified in the Unifier Configurator.
  For the External Reports, the path is relative to the property value for the BIP External Report Folder.
  For the Internal Reports, the path is relative to the property value for the BIP Report Folder.
  This column displays the path of the report in the BI Publisher server. The location plays an important role when there are two reports with the same name.

- **Data Model Type**
  Internal or External for both Print and Report.

- **Key**
  System-generated unique ID.
  For External Reports: The key starts with "uuu_ext"
  For Print or Internal Report: The key starts with "uuu_"
Report Level
The value is blank for Print and for both Internal andExternal reports, it shows Project, Program, or Application (for Internal Reports, only).

Status
Displays whether the report is in one of the following conditions:
Invalid (only applicable for the External Reports)
Draft
Publish

Publish Date
Date the record was last published, or synchronized, in the BI Publisher server and Unifier. This field will be blank when status is changed to Draft/Invalid.
For External Reports: The date when the report is synchronized in Unifier (from BI Publisher server to Unifier).
For Custom Print: The date that the print template was published to the BI Publisher server.
For Internal Reports: The date the reports was published to the BI Publisher server.

Last Modified By
Name of the user who last synchronized the record.

Tag
For Custom Print: Blank. Tagging can be done for reports and Custom Prints.
For Internal Reports: If tagged for Production, then the value is "Production." If not tagged for Production, then the value is blank.
For External Reports: Blank
The following provides additional information about the Tag (the Tag drop-down list on the toolbar) option:
Both Custom Prints and Custom Reports can be tagged as Production, regardless of the record Status (Published or Draft). You can remove a tag by using the Clear option. If you remove a tag, the Custom Prints, or Custom Reports, will not be included in the Production Bundle.
You can tag Program-level and Project-level Custom Reports.
The Application and Program modules cannot be included in the Production Bundle.
The Application-level Custom Reports cannot be tagged and included in the Production Bundle.
The Program-level Custom Reports can be tagged and included in the Production Bundle.
If a template file, which has been defined in the Custom Reports, is missing in the Unifier server, the name of the template will show in the Custom Report but at run-time (when a user wants to use the Custom Report), the system will generate an error message.
The Custom Reports name and level must match in both source environment and destination environment.
You can tag the internal Custom Reports, only.
Tagged Custom Prints and Custom Reports are included in the Production Bundle.
You can delete a tagged Custom Print that was included in the Production Bundle.
When the Production Bundle is being created, the system will check to ensure that the record that has been tagged is in Publish status, or not. If the record that has been tagged is not in Publish status, then an error message is displayed at the time of creating the export bundle.

The Data Views associated with the Custom Reports are included in the Production Bundle.

If the Custom Print has been used in the setup of a tagged BP, the Custom Print needs to be tagged.

**Last Bundled Date**

The date when the Custom Report, or Custom Print, was last included in the Production bundle. This column displays the date that the tagged Custom Prints, or Custom Reports, had been included in the Production Bundle. Upon successful creation of the Production Bundle, the system stamps the Custom Report, or Custom Print, with the Last Bundle Date.

For Custom Print: Stamped with the last date of Export Bundle Creation.

For Internal Reports: Stamped with the last date of Export Bundle Creation.

For External Reports: Blank

**Find**

The Find option, on the toolbar, allows you to search for a particular record in Custom Prints and Reports log. The options for finding a report are:

- Name
- Type
- Location
- Data Model Type
- Last Modified By

**Synchronize External Reports**

The Synchronize External Reports option, on the toolbar, enables you to synchronize data between the BI Publisher server and Unifier.

This option allows you, the Administrator, to update Unifier with the reports created in the BI Publisher server. When you click Synchronize External Reports, the system connects to BI Publisher server to retrieve reports through Web Services.

You can set the level of the report (Report Level) in the Synchronize External Reports window that opens after you click Synchronize External Reports.

Once the synchronization is complete, you can set the permissions, per Report Level, in Unifier. During the runtime, all changes to the report design, such as data model, layout, translation files, and so forth, will be applied.

The following rules apply when you synchronize external reports:

- The Synchronize External Reports window displays all the new reports that exist in the BI Publisher server.
- Reports that exist in both BI Publisher server and Unifier (same reports in terms of count, name, and location), do not appear in the Synchronize External Reports window.
When you click Synchronize External Reports, the system synchronizes all reports. You cannot select a particular report to be imported into Unifier.

If you have imported a report to Unifier and the report no longer exists in the BIP server, then when you click Synchronize External Reports the status of the report will be "Invalid" and you cannot see the report at runtime.

If you change the name of a report in BI Publisher server, the system treats the report as a new report after synchronization.

The system sets the original report, in Unifier, as "Invalid" and you cannot see the report at runtime.

If you change the location of a report in BI Publisher server, the system treats the report as a new report, after synchronization.

The Synchronize External Reports window displays the report and the report new location, after import.

The system sets the original report, in Unifier, as "Invalid" and you cannot see the report at runtime.

If multiple reports, with same names exist in BI Publisher server, after synchronization, all reports will be imported into Unifier.

After the reports are synchronized, the system updates the descriptions of the reports. There will be a small delay for this operation.

Synchronize External Reports window

The Report Name is a read-only field and lists the names in alphabetical order.

The Location is a read-only field and lists the location of the report in the BI Publisher server.

The Report Level is drop-down field and contains two values to select from: Project and Program. The default value is Project, and you can modify the Report Level at the time of import, only. Once you import the report, you cannot modify the Report Level. If you select an incorrect Report Level, then the system sets the status of that report as "Invalid." You can select Synchronized External Reports option and set the Report Level in the Edit Report Level window.

The Description field provides a description for the BI Publisher Report on the BI Publisher server.

About Status

The values for this column are:

- Draft
- Published
- Invalid

About the status option "Invalid"

Toolbar option: Status > Invalid.

The "Invalid" status is applicable to External Reports, only. This status does not apply, and is not available, for Internal Reports and Custom Print records.

The system assigns the "Invalid" status if a report that has been previously imported to Unifier is no longer in the BI Publisher server.

You can delete an External Report that has the status "Invalid" from the log.
If the user had the permission to view an External Report at runtime, and the status is now set as "Invalid," then the user cannot view the External Report at runtime.

**Toolbar options for External Reports in Custom Prints and Reports log**

**New**
The External Reports are created in the BI Publisher server. The New option enables the user to create Internal Reports and Custom Print templates.

**Open**
The user uses the Open option to open an External Report.

**Copy**
This option is disabled if you select a record in the Custom Print, or Reports, logs that is an External Report type.

**Delete**
For External Reports: The user can use this option to delete External Reports that have "Invalid" status. This option is disabled if the selected External Report is in "Published" status.

For Internal Reports: The user can use this option to delete an Internal Report that has never been Published.

For Custom Prints: The user can use this option to delete a Custom Print that is in "Draft" or "Published" status.

**Status**
The status for all imported External Reports is "Published."

**Synchronize External Reports**
This option allows the user to synchronize data between the BI Publisher server and Unifier.

---

**BI Publisher Report Levels**

There are two major levels for BI Publisher report.

- Project level which means the report is running in Project/Shell context.
- Program level which means the report is running in Program context.

For a Project or Program report, respectively, ensure that the following predefined Unifier parameters are applied on the "Where" clause as conditions in the query of the Data Set related to the Main view:

- :uuu_p_context_project_id
- :uuu_p_context_program_id

The following are examples of the parameters used in a "Where" clause:

- project_id = nvl(:uuu_p_context_project_id,project_id)
- program_id = nvl(:uuu_p_context_program_id,program_id)
The following sections explain each option in details.

**Sample XML Data for Custom Prints and Reports**

In case of a Custom Print, the sample data contains data elements that will be used in the layout files to capture information about a business process.

Some data elements are specific to the business process selected as they map to the standard and custom elements included in the business process forms.

There are some data elements present in the sample data for all the business process since they apply to all. These data elements provide information such as record attachments, attachment comments, line item attachments, workflow steps, and so forth.

The following is a list of data elements and their descriptions:

- `<li_attachments>`
  The sub-elements under this provide information about line item attachments for the business process when the business process has line items

- `<lic_attachments>`
  The element is a child of `<la_comments>` and its sub-elements provide information about attachments linked to the comment of line-item attachment

- `<li_ca>`
  The element is a sub-element that provides information about cost allocation line item element for Summary Payment Application of SOV type BP

- `<la_comments>`
  This element is a child of `<li_attachments>` and it's sub-elements provide information on the comments associated with the line-item attachment

- `<standard_elements>`
  The sub-elements of this group element provide information about company name, project name, project number etc

- `<general_comments>`
  The sub-elements of this group element provides information about general comments on the business process

- `<gc_attachments>`
  The element is a child of `<general_comments>` and its sub-elements provide information about attachments linked to the general comment

- `<record_attachments>`
  The sub-elements under this provide information about record attachments for the business process

- `<ra_comments>`
  This element is a child of `<record_attachments>` and it's sub-elements provide information on the comments associated with the record attachments

- `<rac_attachments>`
  The element is a child of `<ra_comments>` and it's sub-elements provide information about attachments linked to the comment of record attachment
For a workflow business process there are additional elements which provide information about the workflow process and its details

- `<workflow_steps>`
  The sub-element of this element provide information about the workflow steps associated with the business process. Details like step name, step assignees

- `<task_assignees>`
  The sub-element of this element provide information about task and assignee details. Information like Task name, Task Status, Assigned From, Assigned To and more

- `<workflow_progress>`
  The sub-elements of this element provide information about status of the workflow

- `<group_assignment_notes>`
  The sub-elements of this element provide information about the notes sent when a task is assigned to the group in the workflow process

### Creating BI Publisher Custom Print

To create a new BI Publisher custom print configuration:

1) Open Unifier
2) Go to Company Workspace
3) Switch to Admin mode
4) Click Configuration to open the node
5) Click Custom Prints and Reports
6) From the log window (Custom Prints and Reports - Current View: All) click **New**
7) Select one of the following options to open the Custom Print window:
   - **Custom Print with Internal Data Model**, or
   - **Custom Print with External Data Model**

   **Note:** To view a BI Publisher custom print template, select the template and click Open.

See the "Custom Prints and Reports Overview" section for details.

### Custom Print Window (General tab)

In the **General** tab, you can define the general custom print information.

1) Enter and select values in the following fields:

   **Note:** Required fields are marked with an asterisk (*), or a star.

   - **Name**
     Enter a unique name for the custom print, up to 50 characters (use alphanumeric characters, non-ASCII characters, or spaces).
   - **Description**
(Optional) Enter a brief description about the custom print up to 250 characters (use non-ASCII characters)

- **Data Source**
  Select one of the values from the drop-down list. The list contains all the design objects that support custom print, such as BP names, Space attribute names, CM attribute names, and so forth.

- **Data Model Type**
  This is pre-populated read-only field, based on the selected custom print type. The values can either be Internal or External, based on the option selected at the time of creating the custom print.

2) Click **Apply** to continue.

When you click Apply, Unifier processes the information that you have provided and prepares the custom print for publication. As a result of this process, two additional tabs are added to the **Custom Print** window that require your input:

- **Template File tab**
  The Template File tab allows you to upload:
  - Multiple templates for the custom print (RTF, PDF, Excel, eText)
  - Data model (.XDM) file (for print with external data model)

- **Sample Data tab**
  The Sample Data tab allows you to generate the sample XML, which you can use to create layouts for the custom print. In the case of an external data model-based report, the report must have been published to the BI Publisher server at least once before the sample XML data can be generated.

See the following topics for details:

- **Custom Print Window (Template File tab)**
- **Custom Print Window (Sample Data tab)**

---

**Custom Print Window (Template File tab)**

The Template File tab contains information about the print layout, along with the corresponding templates and XLIFF translations.

**Add**

Use Add to upload the print layout and the translated XLIFF files. The XLIFF files are used for translation purposes. When you click Add, the "Add template and Files" window opens.

The "Add template and Files" window has two sections:

- **Template**
- **Translated XLIFF files for the Template**

**Note:** Required fields are marked with an asterisk (*), or a star.
**Template**

The Template section contains the following fields:

- **Template Name**: Enter a unique name for the template (use non-ASCII characters).
- **Template Type**: From the drop-down list, select a template type: RTF, PDF, Excel, or eText.
  
  A Template Type can be changed as long as the template is in Creation stage. Once created, the Template Type cannot be modified, and the custom print designer must create a new template (of the desired type) and remove the one that is no longer required.
- **Layout File**: Browse to find and upload the layout files, based on the template type.

**Translated XLIFF files for the Template**

If you want to internationalize the product, then the translated XLIFF files can be uploaded, for the corresponding languages, in the Translated XLIFF filed for template section.

Click **Apply** when finished.

When you open an existing Custom Print, the Template File tab lists all available templates. The first template is always marked as Default, but you can change the default template.

**Modify**

Use **Modify** to modify the existing print template and XLIFF files. You must select an existing file before you can proceed. When you click **Modify**, the "Modify Template and Files" window opens.

The "Modify Template and Files" window has two sections:

- **Template**
- **Translated XLIFF files for the Template**

  **Note**: Required fields are marked with an asterisk (*), or a star.

**Template**

The Template section contains the following fields:

- **Template Name**: The unique name for the template.
- **Template Type**: This is a pre-populated read-only field, based on the selected Template Type.
  
  A Template Type can be changed as long as the template is in Creation stage. Once created, the Template Type cannot be modified, and the custom print designer must create a new template (of the desired type) and remove the one that is no longer required.
- **Layout File**: Browse to find and upload the layout files, based on the template type. The original custom print file is displayed.

**Notes:**

- You can modify a BI Publisher Custom Print template only if the status is set as "Draft."
- You cannot modify a Data Source of a Custom Print template after the Custom Print template has been created.
- You can modify the contents of the Description field at any time.
Translated XLIFF files for the Template

If you want to internationalize the product, then the translated XLIFF files can be uploaded, for the corresponding languages, in the Translated XLIFF filed for template section.

Click **Apply** when finished.

Remove

To remove a Custom Print template, click to select the template, and click **Remove**.

**Note:** To delete a Custom Print template, you can select the Custom Print template from the log and click Delete. You can delete a Custom Print template regardless of the Custom Print template status.

Download

The Download option allows you to download the template and the corresponding translated XLIFF files. You must select an existing file before your can proceed.

When you click Download, a zip file is generated. The zip file name format must be:

```
Template_<Numeric part of report key>_<File Type>.zip
```

**Example**

```
Template_483_PDF.zip
```

You can copy a Custom Print template to use as a base for a new Custom Print template.

**Note:** After copying a Custom Print template, the term, "Copy of" appears at the beginning of the name of the new Custom Print template.

Custom Print Window (Sample Data tab)

You can use the Custom Print window Sample Data tab to download sample data for designing the custom print template file. You can use the XML data to design the print template file in the BI Publisher.

The XML tags in the sample data are displayed for all the fields that are relevant to the selected data source. The XML tags are grouped according to the XML elements or data sets. The data sets displayed in the Sample Data tab are driven by the data source type. For a Workflow BP, the various elements are the upper forms, line items, workflow details, comments, and so forth.

1) In the Sample Data tab click **Generate**.
2) When finished, click **Download**.
3) Click **Apply**.
4) Click **OK**.

Publishing BI Publisher Custom Print

You must publish the BI Publisher Custom Prints in the BI Publisher Server.
To publish a BI Publisher Custom Print:

1) Prepare the custom print.
2) Click **Status**.
   - The status of a BI Publisher Custom Print template is either set as Draft, or the status is set as Published. For either case, in order to print the BI Publisher Custom Print template, you must select Publish.
   - You can delete a Custom Print template regardless of the Custom Print template status.
3) Select **Publish**.
   - After you publish, the system performs validation and if there are no errors the system publishes the Custom Print template and assigns the new Published Date in the log.

**Notes:**
- If you remove the data elements from the design of the data source that has been used in the BI Publisher Custom Print template, then you must republish the Custom Print template to the BI Publisher server.
- If you add new data elements, or if you change (or add) other elements of a design, such as Upper Form and Detail Form, and these changes or additions can be seen in the Custom Print template output, then you must update the Custom Print template.
- You can update the Custom Print template layout by regenerating the sample data.

---

### Creating BI Publisher Custom Report

To create a new BI Publisher *custom report* configuration:

1) Open **Unifier**
2) Go to **Company Workspace**
3) Switch to **Admin** mode
4) Click **Configuration** to open the node
5) Click **Custom Prints and Reports**
6) From the log window (Custom Prints and Reports - Current View: All) click **New**
7) Select one of the following options to open the Custom Report window:
   - Report with Internal Data Model, or
   - Report with External Data Model

See the "Custom Prints and Reports Overview" section for details.

---

### Custom Report Window (General tab)

In the **General** tab, you can define the general custom report information.

1) Enter and select values in the following fields:
Note: Required fields are marked with an asterisk (*), or a star.

- **Name**
Enter a unique name for the custom report, up to 50 characters (use alphanumeric characters or spaces).

- **Description**
(Optional) Enter a brief description about the custom report.

- **Data Model Type**
This is a pre-populated read-only field, based on the selected custom report type. The values can either be Internal or External, based on the option selected at the time of creating the custom report.

- **Report Level**
A drop-down list that allows you to select *Project* for a project-level custom report, *Program* for a program-level custom report, or *Application* for an application-level custom report.

- **Main View**
A drop-down list that allows you to select a data view to use as the main view of the custom report. The items in the drop-down list are populated with the data views that have been published.

  Note: When you are selecting a Main View, ensure that you select a view that has the level-appropriate ID, as a column, in the view definition. For example, if you are selecting a Main View for a Program (report level), the view must have "program_id", as a column, in the view definition.

2) Click **Apply** to continue.

When you click Apply, Unifier processes the information that you have provided and prepares the custom report for publication. As a result of this process, two additional tabs are added to the Custom Report window that require your input:

- **Template File tab**
The Template File tab allows you to upload:
  - Multiple templates for the custom report (RTF, PDF, Excel, eText)
  - Data model (.XDM) file (for report with external data model)

- **Sample Data tab**
The Sample Data tab allows you to generate the sample XML data which you can use to create layouts for the custom report.

See the following topics for details:

- **Custom Print Window (Template File tab)**
- **Custom Report Window (Sample Data tab)**

### Custom Report Window (Views tab)

On the Views tab, you can:

- Set the views used as data sets (Views used as data sets)
Determine data links (Data links)

To set additional views, used as data sets, follow these steps:

1) On the Custom Reports window, click the Views tab.
2) In the "Views used as data sets" section click Add to add a new row to the Views list.
3) In the "View Name" column, from the drop-down list, select a view. The drop-down list displays the available published data views.
   In the "View Type" column, double-click the entry to make the cell editable, and select a view type from the drop-down list. You can select one view as the main view, only. The other views are sub-report views.
4) In the "Data Set Name" column, double-click the cell to make it editable, and enter the name of the data set to which this view should belong.
5) In the "Data Set" Tag column, double-click the cell to make it editable, and enter the tag for the data set.
6) To add another view, repeat steps 1 to 5.

You can enter any number of data views for a custom report and group them into data sets.

Once you have specified the data views and grouped them into data sets, you can link one data set to another in order to extract related information from multiple sources.

For translation-related information about Oracle Business Intelligence Publisher (BI Publisher or BIP) Reports, see the Internationalization (BI Publisher Custom Reports) section.

Note: For External Data Model based reports, you cannot add or remove views.

You can create only one link level; that is, you can create one "sub-link." You cannot create another link under a sub-link.

To determine data links, follow these steps:

1) In the Data links section of the window, click Add to open the Add Link window.
2) In the Source Data Set field, select the name of the data set you want to link to another set. The selection list shows the data sets you created in the upper section of the Views tab.
3) In the Source Element Name field, select the name of the field on the source data set that you want to map to the target data set.
   The element data type must match the data type of the target element; for example, you must match an integer to an integer, a string to a string.
4) In the Target Data Set field, select the name of the data set the source data set should link to.
5) In the Target Element field, select the name of the field on the target set that the source element field should map to.
6) To add another link, click the Add button and repeat steps 2 to 5, or click OK to save the links the exit the Add Link window.
7) Click Apply, and click OK to exit the Custom Report window.
**Custom Report Window (Query tab)**

On this tab, you can add query parameters to the configuration. The query parameters are created on the columns of the main view, selected for the Custom Report. At runtime, these parameters appear in the Search Parameters block.

**To add query parameters to the custom report**

1) On the Custom Reports window, click the **Query** tab.
2) Click the **Add** button. The Add Query window opens. Complete the window:
   - **Element Name:** Click the drop-down list and choose from the elements (all columns from the main view).
     - **Label:** Enter a label to use for the Element Name. This label appears to the user at runtime.
     - **Operator:** Select the appropriate operator to use for the query. The operators will depend on the data type of the element chosen.
     - **Source Type:** This is the source of the value. Choose one of the following:
       - **Data Definition:** Allows you to choose a data definition. The following field becomes available:
         - **Select Definition:** Select from the drop-down list. The list displays data definitions defined in the company that apply to the type of element chosen. (For example, if you choose a pull-down or radio button, the data set values defined for the data definition will be displayed to the user at runtime.) This allows you to use existing data definition values, rather than entering them manually (see Ad Hoc below).
   - **View:** Allows you to compare columns in your current view against another view chosen here. The following fields become available:
     - **Select View:** Lists all published data views. Choose the view to compare.
     - **Value Column:** Lists the columns for view chosen in Select View. This is the column that will be compared.
     - **Label Column:** What you choose here will be displayed to the user at runtime.
     - **Context Sensitive:** If this checkbox is selected, the results will automatically apply the filter for project_id at runtime (results will be for the current project only).
   - **Ad Hoc:** Allows user to select values in User Mode from selection list. If you choose this option, you must specify the list of values here. This is similar to defining a data definition data set.
     - Click the **Add** button. The Ad Hoc window opens.
     - Click **Add**. A new row is added.
     - Enter a **Value** and **Label**.
3) You can modify the query parameters by doing the following:
   - Delete a row by selecting it and clicking **Remove**.
   - Modify parameter by selecting a row and clicking **Modify**.
   - Change the order of the query parameters (as they appear in User Mode), by selecting a row and clicking **Move Up** or **Move Down**.
4) When done, click **Apply** to save changes. You can click **OK** to save and exit, or click another tab to continue to define the configuration.
Custom Report Window (Parameters tab)

If the report designer has defined a formula using parameters with the same name that was used in the Parameters tab, then it will be displayed on the report at runtime. In User Mode, these parameters appear in the Additional Parameters block.

To add additional parameters to the custom report:

1) On the Custom Reports window, click the Parameters tab.
2) Click Add to add a new row. Enter the following information.
   - **Name**: Double-click in the field to make it editable. The Name entered here must match the parameter name used in the BIP report. The behavior and default values for the parameters specified here can be applied automatically to the report at run time.
   - **Editable**: If this checkbox is selected, the field will be editable in User Mode. If not, the field is read-only.
   - **Hidden**: If selected, the field will be hidden in User Mode. The report may still use the parameter at runtime, depending on the design.
   - **Label**: Defines the label of the parameter field in User Mode.
   - **Default**: You can enter a default value that will be used in User Mode.
3) To delete a row, select it and click Remove.
4) Click Apply to save changes. You can click OK to save and exit, or click another tab to continue to define the configuration.

Predefined BI Publisher Parameter Examples

The name for a Parameter is mapped to a BIP parameter based on the format:

`:uuu_p_{Parameter Name}`

**Note**: Ensure the length of `{Parameter Name}` is less than 24 characters.

Any parameters created on the Parameters tab also need to be appropriately added into the Parameters tag in the .XDM file.

Predefined Unifier Parameters

Predefined parameters are reserved for Unifier to pass the runtime values to BI Publisher runtime context.

Here is example from a XDM file.

```xml
<parameters xmlns="http://xmlns.oracle.com/oxp/xmlp">
  ...
  <parameter name="uuu_p_context_project_id" dataType="xsd:string" rowPlacement="7">
    <input label="context project id" size="10"/>
  </parameter>
  <parameter name="uuu_p_context_program_id" dataType="xsd:string" rowPlacement="8">
```

The following is an example for how to use the predefined BI Publisher Parameters to display an image in the Report layout:

1) Create Form fields in the .rtf.
2) In the HelpText of the form field, define variable matching the parameter names used in the image URL.

3) Right-click the dummy image and select Size (and its AltText), then enter the following content:

```
url: {concat($uuu_p_urlF,'companyRegistry=',$uuu_p_companyRegistryF,'
&sessionId=',$uuu_p_sessionIdF,'&id=',PROJECTIMAGE)}
```

Note: The uuu_p_* are the predefined parameters in the data model. They are also the variable names defined in the RTF form fields. The PROJECTIMAGE is the element for image file ID from Unifier.

In the HelpText of the form field enter:

```
<?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>
```

### Custom Report Window (Template File tab)

The Template File tab allows you to upload:

- Multiple templates for the custom report (RTF, PDF, Excel, eText)
- Data model (.XDM) file (for report with external data model)

Use this tab to add, modify, remove, or download files. Click **Apply** when finished.

### Custom Report Window (Sample Data tab)

The Sample Data tab allows you to generate the sample XML data, which you can use to create layouts for the custom report. In the case of an external data model-based report, the report must have been published to the BI Publisher server at least once before the sample XML data can be generated.

Note: Depending on the Report Level that you have selected in the General tab, the fields and selections in this tab changes.

1) In the Sample Data tab select a sample, determine the number of rows that you want to see, and click **Generate**.
2) When finished, click **Download**.
3) Click **Apply**
4) Click **OK**

### Publishing BI Publisher Custom Report

To publish a BI Publisher Custom Report:

1) Prepare the custom report
2) Click **Status**
3) Select **Publish**
Uploading Template for Custom Report Configuration (Template File tab)

On this tab, you can specify the format in which you want the report data to appear. You can upload your Oracle BI Publisher report designs on this tab.

For Oracle BI Publisher reports, you can use this tab for two purposes:

- To assign an existing template file to the custom report
- To download sample XML data to use with the Microsoft Word BI Publisher plug-in to create a new template

To upload and assign an existing template for the report

1) On the Custom Reports window, click the Report File tab.

   **Note:** You may need to complete the General tab first and click Apply before this tab appears.

For uploading a template for both type of reports - Internal and External data model type reports

1) Open the custom report window.
2) Click the Report File tab.
3) Enter the Template Name.
4) Select the Template Type.
5) Mark whether this template is the Default template. You must select a default template.
6) Browse to upload the Template File.
7) After clicking Apply or OK, you can click Download and download the uploaded template for reuse.

For uploading a template for External data model type report

1) In the Report file tab click the Add/Modify button.
2) Click the Browse button, navigate to the .XDM file you want to use for the data model, and click the Upload button.
   
   Unifier uploads the data model for the report to the BI server.
3) (Optional) To modify the data model, you can download it to your local drive by clicking the Download button.
4) Click OK.

For uploading a template for External data model type custom report

You need to upload the Data Model file (.XDM) from the Custom Print Template File tab, using the following parameters:

- uuu_p_project_id
  Project ID
- uuu_p_context_company_id
  Company ID
- uuu_p_process_id
  Workflow process ID
Unifier Administration Mode

- **uuu_p_source_id**
  Business process record ID
- **uuu_p_object_type**
  Business process id as in uDesigner
- **uuu_p_hide_task_details**
  To hide the task status if the user does not have permission. The value of 0 is passed if the user does not have permission to view the task statuses
- **uuu_p_hidden_comments**
  To view the hidden comments, if the user has the permission. The value of 1 is passed if the user has the permission to view hidden comments

These parameters are used to pass information from the Unifier runtime to the BI Publisher server (integration at runtime).

**To download sample XML data for designing new templates**

This part of the Sample Data tab is for downloading sample data to use in designing a new report template file. You can download data from a specific project.

1. (Optional) In the **Sample Project** field, select the project or shell data you want to generate. If you do not specify a sample project or shell, Unifier will use data from the main view that was specified on the Views tab.
2. In the **Number of rows to return** field, specify the number of rows of data you want to use for designing the template.
3. Click the **Generate** button. This button is disabled in case of external data model report until the report has been published at least once.

   Unifier generates a random sample of the XML from the Sample Project, or the main view of data.

4. Click **OK**.

   You can then use this XML data in BI Publisher to design the template file.

**Modifying Existing Custom Report Configuration**

Any changes to the Data view, Data Set, Query and Parameters are not applied to the XDM file by Unifier. Users need to apply those changes manually to the XDM file.

**Data View**

If a data view is changed, it may require a modification in the XDM file. For instance, if a new column is added and it is required in the layout of the report, then the column must be added into the query in the data set in the XDM file.

**Main View for Data set**

If a main view is changed for the data set, it requires a modification in the XDM file to reflect the change in the From clause of the query of the main data set.
Query Parameter

The Element name for a Query is mapped to a BI Publisher parameter based on the format:

:uuu_p_{Element Name}

**Note:** Ensure the length of `{Element Name}` is less than 24 characters.

Any query parameters created on the elements of the main view on the query tab also need to be appropriately mapped in the Where clause of the main view query in the XDM. Refer to Adding or Modifying Unifier report parameters section of the Unifier Reporting using BI Publisher 11g document.

To modify an existing custom report configuration:

1) Go to the Company Workspace tab and switch to Administration mode.
2) Click **Configuration > Custom Prints and Reports** in the left Navigator to open the log.
3) Select a custom report and click **Open** to open the custom report window.

**Note:** The custom report must be in Draft status for modification.

4) Modify the fields as necessary. All fields except the "Report Level" can be modified, as long as the custom report has not yet been published. Once the report has been published, the "Report Name" files also becomes un-editable.

### Setting Permissions for Custom Reports

To set permissions for Custom Reports:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Access Control** in the left Navigator. In the Access Control log window, there are two modules: Administration Mode Access and User Mode Access.
   - If the reports are at the Program level, in the right pane, select **User Mode Access > Programs > Reports > Custom > <report name>**.
   - If the reports are at the Project level, in the right pane, select **User Mode Access > Shells/Projects (Standard) > Reports > Custom > <Report Name>**
3) Select the access for the appropriate user.
4) Click **OK**.

**Note:** A user with the "configure" permission to the Custom Report node, can configure custom print templates. There are no separate permissions for performing actions on the custom print templates.
Configuring the User Mode Navigator

The configurable User Mode Navigator feature allows you to modify the appearance and organization of the modules and business processes that are available in the left hand Navigator for all company users. This allows you to group Unifier modules, logs and business processes to suit your company’s business needs.

This functionality is limited to the collaborative portions of the user mode navigator: Company Workspace, Programs, Shells and Projects.

Note: This configuration will affect the User Mode navigation for all users in your company. We strongly recommend that you fully test your configurations in uStage before configuring in your production environment.

As always, access to any module or business process is strictly controlled by permission settings. The configurable navigator feature does not override permission settings in any way; it simply allows you to customize the look and organization of navigator modules that a user has permissions to access. Any changes you make to the User Mode navigation tree will be reflected in the Access Control view. If a user has permission to access at least one leaf node under a grouping node, then the Grouping Node will appear in the user’s view of the navigator. If the user does not have permission to any leaf nodes under a grouping node, then the grouping node will not appear in the user’s Navigator.

Within the configurable navigator, you can create new grouping nodes, rename existing ones, reorder items within the nodes, and even remove unused modules from the Navigator, providing increased flexibility to organize and view Unifier modules and business processes. The configured view will appear for all users.

Note the following terminology used with this feature:

- **Grouping Node**: This is a container "parent" node. Clicking a Grouping Node in the left hand Navigator simply expands the node to display any child nodes below it; the child nodes can be leaf nodes, or another grouping node. (Example: Project Logs, Cost Manager). Grouping nodes are easy to identify: they have a (+) next to them in the navigation tree.

- **Actionable Grouping Node**: This type of grouping node not only expands to display child nodes underneath it, but also refreshes the right pane and displays an associated log or page. (Example: Projects node, which not only expands to display project nodes in the Navigator, but also opens the Project home page).

- **Leaf Node**: This is a child node that cannot become a grouping node; the last node in the navigation "tree," where no further branching can take place. Clicking a child node refreshes the right hand Unifier pane to display the associated module or log. (Example: Cost Sheet within the Cost Manager, or individual business process logs under Project Logs).

The configurable navigator allows you to:

- Configure navigation trees for Project, Shell, Program and Company Workspace areas of the user mode navigator; settings do not take effect in your users’ navigators until you deploy them
Create new grouping nodes
Rename new and existing grouping nodes
Change the icons associated with the nodes
Move nodes up and down the navigation tree, or from one grouping node to another
Remove unused modules from the navigator without deleting the modules themselves
Move business process logs or other modules between new or existing Grouping Nodes
Store three versions of the navigator: last saved version, last deployed version, and the system default version, and allows you to restore the navigator to any of these versions at any time

**Note:** Since the configurable navigator is a separate setup, new business processes will not automatically appear in the log chosen during configuration, even after setup. They will appear in the right pane of the User Configurable Navigator window. You must manually place the business process into the correct node in the left pane to make it available to users.

### In This Section

- Create a new user mode navigator configuration ................................................... 126
- Create a new grouping node .................................................................................. 127
- Rename a grouping node ...................................................................................... 128
- Change the icon of a grouping node ...................................................................... 129
- Move nodes within the navigator ............................................................................ 129
- Remove unused modules from the navigator .......................................................... 131
- Delete a grouping node .......................................................................................... 133
- Deploying a navigator configuration ....................................................................... 133
- Delete a navigator configuration ............................................................................. 133
- Restore the navigator to previous or default configuration ..................................... 134

### Create a new user mode navigator configuration

You can create one configuration for user mode Project, Shell, Program or Company Workspace.

**To create a new project, program or company workspace navigator configuration**

1. Go to the Company Workspace tab and switch to Admin mode.
2. In the left Navigator, click **Configuration>User Mode Navigator**. The User Mode Navigator log opens. The log lists any previously created configurations.
3. Click **New** and choose one of the following:
   - **Home**: configures the navigation node for Master Logs

   **Note:** You cannot hide the Tasks, Messages, Drafts, and uMail nodes under the Home tab.
- **Company Workspace**: configures the navigation nodes within the Company Workspace portion of the User Mode navigator
- **Program**: configures the program level navigation
- **Project/Shell**: configures the project/shell level navigation

The Create New Navigator window opens. The left portion of the window displays the navigation as it would appear for users. In the example below, the default navigation is displayed, since a new configuration has not been deployed.

The right pane of the window displays available modules or business process logs that can be added to the navigation on the left.

4) Configure the new navigator configuration as described below.

5) To save the configuration, click **OK**.

The configuration will be displayed in the log. There can be one configuration each for Project, Shell, Program or Company Workspace. After saving, you must deploy the configuration for it to take effect. See **Deploying a navigator configuration** (on page 133).

You can configure the new project, program or company workspace navigation. After deploying, the configuration will appear in the user mode navigator for all users in your company.

Use the toolbar to configure the navigation:

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create new grouping node</td>
</tr>
<tr>
<td>Rename</td>
<td>Rename selected grouping node</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expand all grouping nodes to reveal their leaf nodes</td>
</tr>
<tr>
<td>Move Up</td>
<td>Move selected grouping nodes or leaf nodes up</td>
</tr>
<tr>
<td>Move Down</td>
<td>Move selected grouping nodes or leaf nodes down</td>
</tr>
<tr>
<td>Cut</td>
<td>Cut nodes from one grouping node to another</td>
</tr>
<tr>
<td>Paste</td>
<td>Paste nodes from one grouping node to another</td>
</tr>
<tr>
<td>Restore</td>
<td>Restore to original system configuration or last deployed version</td>
</tr>
<tr>
<td>Change Icon</td>
<td>Change the icon of the selected node</td>
</tr>
</tbody>
</table>

**To expand all navigator nodes**

In the navigator window, click the **Expand All** button. This expands all grouping nodes and allows you to view all of the nodes currently present in the navigation. You can contract a grouping node to hide the leaf nodes by clicking the (-) next to the grouping node name.

**Create a new grouping node**

You can create a grouping node to use to organize modules or business process logs.

**To create a new grouping node**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, click **Configuration>User Mode Navigator**. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the left Navigator, select a valid parent node. This can be the root node (Company Workspace, Program, Shell, or Project), or any other grouping node in the navigator tree (for example, Cost Manager or Project Logs).
4) Click **New**. The newly created node is created under the selected node. The default name is New Grouping Node, and uses the default icon of a file folder. Grouping nodes can be renamed, moved and given a new icon.

![Image of Unifier Administration Guide](image)

**Rename a grouping node**

You can rename any new or existing grouping node in the navigator, with the exception of the root node (Project, Shell, Program or Company Workspace). You cannot rename leaf nodes.

**To rename a grouping node**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) In the left Navigator, click **Configuration>User Mode Navigator**. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the navigator window, double-click the grouping node, or select the node and click the **Rename** button. The field becomes editable.
4) Enter a new name for the field, up to 32 characters. Grouping nodes under same parent node cannot have same name.

![Image of Unifier Administration Guide](image)
Change the icon of a grouping node

You can change the icon of any grouping node except the root node (Projects, Shells, Programs, Company Workspace).

To change the icon of a grouping node
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the navigator window, select the grouping node and click the Change Icon button. The available icons are displayed.
4) Click the new icon. The icon immediately appears on the selected grouping node.

Move nodes within the navigator

You can move any grouping node or leaf node up or down the navigator, either within the original grouping node, or from one grouping node to another. There are three ways to move nodes within the navigator:

- Move a node up and down the navigation tree within its parent grouping node
- Move a node from one grouping node to another

See the following procedures for more details.

To move a node up or down the navigator
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the navigator window, select the node to move.
4) Click the **Move Up** or **Move Down** button to move the node up or down within the parent grouping node. If you move a grouping node, all child nodes move with it.

To move a leaf node from one grouping node to another

1) In the navigator window, select the node to move.
2) Click the > button to move the node to the right pane. Continue with each node that you want to move.
   
   Only leaf nodes will be moved. If you select a grouping node, only the leaf nodes underneath it will move to the right pane. The grouping node itself will be deleted.
3) In the left pane, select the destination grouping node into which you want to move the leaf nodes.
4) In the right pane, select the leaf node to move and click the < button. The leaf node moves to the grouping node on the left. Repeat as needed with any other leaf nodes to move.
**Note:** If you leave a leaf node in the right pane and deploy the configuration, that module or business process will not appear on the user mode navigator for users.

---

**To move a node from one grouping node to another by cut and paste**

1) In the navigator window, select the node to move. You can select a grouping node or leaf node.
2) Click the **Cut** button. (The selected node will not yet be removed).
3) In the left pane, select the destination grouping node in which to move the selection.
4) Click the **Paste** button. The node will be moved the new location. If you have selected a grouping node, the grouping node and all leaf nodes will be moved.

---

**Remove unused modules from the navigator**

If there are Unifier modules that your company never uses, and that cannot be hidden by use of permission settings (for example, the uMail module), you can remove them from the User Mode Navigator. The modules themselves will not be deleted, and can be restored to the Navigator at any time.

**To remove a module from the User Mode Navigator**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) In the left Navigator, click **Configuration>User Mode Navigator**. The User Mode Navigator log opens. The log lists any previously created configurations.

3) In the navigator window, select the node to remove.

4) Click the > button to move the node to the right pane. Continue with each node that you want to remove.

   Only leaf nodes will be moved. If you select a grouping node, only the leaf nodes underneath it will move to the right pane. The grouping node itself will be deleted.

5) Save and deploy the configuration. The nodes that remain in the right pane will not appear in the user mode navigator.

   In the above example, the uMail module nodes are moved to the right pane, which remove them from the user mode navigator for all users. Note that the original uMail grouping node has been deleted.
Delete a grouping node

Any grouping node can be deleted. Leaf nodes cannot be deleted; however, you can remove them from the user mode navigator that appears to all users. See Remove unused modules from the navigator on page 131.

To delete a grouping node

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the left pane of the navigator window, select a grouping node.
4) Click the > button. The grouping node is deleted. If the grouping node contains leaf nodes, the leaf nodes are moved to the right pane, and the grouping node is deleted.

Deploying a navigator configuration

Once you have created a navigator configuration, it must be deployed for changes to take effect in the user mode. Once you deploy the navigation, the view will be displayed to all users.

To deploy a new navigator

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the User Mode Navigator log, select the configuration to deploy.
4) Click the Deploy button. When the navigation configuration is deployed, a confirmation window opens. Click OK.
   The navigator change takes effect immediately for all users.

Delete a navigator configuration

If you delete a configuration from the User Mode Navigator log, the system defaults for the applicable portion of the User Mode Navigator (Project, Shell, Program or Company Workspace) will be restored back to the system defaults automatically.

To delete a configuration and restore the navigator to system defaults

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator log opens. The log lists any previously created configurations.
3) In the User Mode Navigator log, select the configuration to delete.
4) Click the Delete button. At the confirmation window, click Yes. The user mode navigator will be restored to system defaults immediately.
You can restore the navigator configuration to a previously saved version, the last deployed version, or to original system default at any time. You must still deploy the restored navigator in order for it to take effect.

**To restore the navigator to a previous or default version**

In the configurable navigator window, click the **Restore** button and choose one of the following options:

- **Last Saved**: Restores the navigation tree to the last saved version, regardless of deployment
- **Last Deployment**: Restores the navigator to the version that was last deployed (not applicable for new configurations that have not yet been deployed)
- **System Default**: Restores the navigator to the original system defaults
User and Group Administration

This section covers adding and managing sponsor company and partner company users, user groups, and permission settings and access control.

In This Section

Importing User Attribute Form ................................................................. 135
Adding and Managing Company Users ...................................................... 135
Adding and Managing Partner Company Users ......................................... 147
Adding and Managing Groups .................................................................. 150
Managing users in bulk ........................................................................... 152
Creating and Managing User Preference Templates ............................... 154
Creating an Approved Email List for Project and Shell Mailboxes ............ 157
Managing permissions and access control ............................................... 159
Working with the License Manager ......................................................... 163
Running System Usage Reports ............................................................... 166

Importing User Attribute Form

For company user administration, Unifier displays a default log, General tab (used when creating a user with the Company or Partner detail form), and User/Group picker, unless you design and import your own user administration attribute form.

In uDesigner, you can add additional data elements to the User Attribute form, configure Company User and Partner User logs, add additional attributes to the View User Profile form, and a User/Group picker. The additional data elements appear as user properties on the General tab for Company and Partner users, as well as on the user View Profile form. For example, the additional user properties can include a user’s department and location, or other details.

All designs, including user attribute forms, are designed in uDesigner and deployed to Unifier. See the instructions in the topic Importing and Deploying a Design (on page 273).

Adding and Managing Company Users

Company Administrators can add new users to the sponsor company. Each new user creates a new user record. These are known as company users. Company users can be entered manually one at a time, or multiple user records can be imported into Unifier from a CSV file.

Note: The Internationalization and CSV Files section contains information about translating CSV files.

To ensure compliance with company standards and restrict access, Oracle recommends that the responsibility for user administration (at the company level) be delegated to one person, or a small group of people.
**Note**: If you are using Oracle Identity Management (OIM) to add users to your company, some of the instructions that follow do not apply. OIM creates the user's login name, first and last names, and email account. OIM does not honor user attribute forms or user preference templates. Users manage their own passwords with OIM. OIM will honor the permissions and proxy users you specify in Unifier. You can use a CSV file to bulk update user information (see *Managing users in bulk* (on page 152)), except for passwords. The Template Name columns is mandatory field in order to update user information, successfully.

**To access the Company Users log**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **User Administration > Company Users** in the left Navigator. To open an existing user record, select a user from the log and click **Open**.

**Note**: If a **User Attribute** form has been imported, the columns that appear in the Users Log can vary. If designed in uDesigner, the log can include navigation in the left pane. This navigation allows you to filter the display of users listed in the log. If you decide that you want a standard log to display, you can remove the navigation from the log in uDesigner. Also, the search criteria in the Find window and sort order can also vary depending on what was added to the User log design in the **User Attribute** form.

**Add a New Company User**

This section describes how to manually add a new user record to your company. For information about importing multiple user records from a CSV file, see the following section.

If you have created a **User Preference template** (in **Standards & Libraries > User Preference Templates**), the active template will automatically be used to generate the new user’s user preferences. If there is no active template present, then the system default settings will be used for the user preferences.

The following information is for adding users from Unifier.

**Notes**:

- If you access Unifier through Oracle Identity Management (OIM), you cannot add a new user.
- You can import a CSV file, but if the CSV file has a new user, the user will not be added.
- Users manage their own passwords with OIM.
- OIM does not honor user attribute forms and does not use user preference templates. Users will be able to edit the user attributes and the preferences in Unifier.
- OIM has its own password policy which supersedes other policies.
To add a new company user

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Company Users in the left Navigator.
3) Click New from the toolbar to open the Edit User window and complete the form.
4) The Edit User window opens.
5) Complete the fields of the General tab as discussed in the following table.
6) Click the Security tab. You must also add a login user name before saving the record. See Manage user login information (Security tab) (on page 141) for details.
7) At this point, you can activate the user, save the record, or complete the rest of the tabs:
   - Permissions: You can configure individual permission settings for the user in this tab. See Edit user permissions (Permissions tab) (on page 143) for details. Alternatively, you can assign the user to a group (the user will automatically inherit group permissions), or assign permission through Access Control.
   - Projects: This tab lists the projects to which the user has been added and is view-only. See View user’s project, program, and shell membership (Project/Program/Shell tabs) (on page 143).
   - Shells: This tab lists the shells to which the user has been added and is view-only. See View user’s project, program, and shell membership (Project/Program/Shell tabs) (on page 143).
   - Programs: This tab lists the programs to which the user has been added and is view-only. See View user’s project, program, and shell membership (Project/Program/Shell tabs) (on page 143).
   - Proxy: You can add or view the user’s proxy users in this tab. See Designate a proxy user (Proxy tab) (on page 143).
8) Click Apply to save changes, or OK to save and exit the window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name, Last Name</td>
<td>Enter the first and last name of the user. These are required fields.</td>
</tr>
<tr>
<td>Title</td>
<td>Enter an optional company title for the user.</td>
</tr>
<tr>
<td>Email</td>
<td>Enter the user’s email address, which will be used to send system notifications to the user, and will display in the user’s contact information. This is a required field.</td>
</tr>
<tr>
<td>Work Phone</td>
<td>Enter the user’s work telephone number.</td>
</tr>
<tr>
<td>Mobile Phone</td>
<td>Enter the user’s mobile telephone number.</td>
</tr>
<tr>
<td>Home Phone</td>
<td>Enter the user’s home telephone number.</td>
</tr>
<tr>
<td>Pager</td>
<td>Enter the user’s page number.</td>
</tr>
<tr>
<td>Fax</td>
<td>Enter the user’s fax number.</td>
</tr>
<tr>
<td>Address</td>
<td>Click the Select button to add a company address to the user profile (From Edit Company, Address Tab)</td>
</tr>
</tbody>
</table>
Time Zone | Choose the default time zone for the user. This can be changed in the User Preferences window.
---|---
Language | Select a language from the drop-down list.
Date Format | This setting controls the display of dates on reports, business process forms, etc. This can be changed in the User Preferences window.

| Status | New users are Active by default. Status can be Active, Inactive or On-hold. Neither Inactive nor On-Hold users can sign in to Unifier:
|---|---|
| **Active**: User is listed in Project or Shell Directory, in User/Group Picker, User can sign in and participate in project or shell.
| **Inactive**: User’s name does not appear anywhere for selection on any project-or shell-related functions or User Picker. User cannot sign in but they can be given permissions and added to groups.
| **On-hold**: User can be added to a project or shell and assigned as a participant in a business process workflow but cannot sign in. Normally used to pre-assign users to a new project or shell before activating it.

**Active** and **On Hold** users will be counted against your user license terms; **Inactive** users will not.

---

**Import company users (add users or update users)**

If you have a large number of users to add or update, you may want to import the records, so you do not have to manually open and update each user record. You can import multiple users with a CSV file by doing the following:

- Export a copy of the CSV file structure.
- Populate the CSV file with user information.
- Import the CSV file into Unifier.

**Note**: If you are using Oracle Identity Management (OIM) to add users to your company, you cannot import users via CSV file. You can, however, update user information via CSV, except for the user’s password.

Once the OIM is enabled, the following features will be disabled in Unifier:

- Manual User Creation
- CSV Import User

**Note**: The CSV Import User feature continues to support the User Update function but not the Create User function.

- Editing the username and password in the user admin
Unifier Administration Mode

- Web Service (Create User)

To export a copy of the CSV file structure
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **User Administration > Company Users** in the left Navigator.
3) Click the **File** menu and choose **Export > Export Structure**. A confirmation window opens. Do one of the following:
   - Click **Open** to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   - Click **Save** to save the file to your local drive. Enter a name for the file and click **Save**.

To export existing users for update
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **User Administration > Company Users** in the left Navigator.
3) Choose **File > Export > All**, or select users in the log and choose **File > Export > Selection**. A confirmation window opens. Do one of the following:
   - Click **Open** to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   - Click **Save** to save the file to your local drive. Enter a name for the file and click **Save**.

To populate the CSV file with user information
1) Open Microsoft® Excel (or other program compatible with CSV format), and open the CSV file you just saved.
2) Enter or modify user information in the spreadsheet. The fields are discussed in the following table. Note the following:
   - Do not delete or change the order of the columns; this will make the file invalid.
   - Valid information must be entered into columns corresponding to required fields. An asterisk in the column header indicates required fields. (Expand the columns to see the asterisks if necessary.)
   - For non-text-entry fields (Time Zone, Date Format, Address), enter the corresponding code. Valid codes are found in the **Unifier Reference Guide**.
   - Non-required fields (column heading does not have an asterisk) are optional. You may enter information or leave these fields blank.
   - User names can have the characters A-Z a-z 0-9 but not a space or a special character @, dash or underscore. User names cannot be more than 64 characters long.
3) Save in CSV format.

<table>
<thead>
<tr>
<th>In this column:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name*</td>
<td>Enter user’s first name.</td>
</tr>
<tr>
<td>Last Name*</td>
<td>Enter user’s last name.</td>
</tr>
<tr>
<td>Title</td>
<td>Enter user’s company title</td>
</tr>
<tr>
<td>Email*</td>
<td>Enter user’s email address</td>
</tr>
</tbody>
</table>
### Work Phone
Enter user's work phone number

### Mobile Phone
Enter user's cell phone number

### Home Phone
Enter user's home phone number

### Pager
Enter user's pager number

### Fax
Enter user's fax number

### Login Username*
Enter a unique username that the user will use to log into Primavera Unifier

### Password
Enter a password that will allow the user to log in for the first time. The user can change the password after signing in to Unifier.

### Time Zone*
Enter the code for the Time Zone (refer to the Unifier Reference Guide for the list of codes). This is a required field, even if you are entering a User Preferences Template Name (if the time zone specified in the template is different from this cell, the template selection will take precedence).

### Date Format*
Enter the code for the Date Format (refer to the Unifier Reference Guide for the list of codes). This is a required field, even if you are entering a User Preferences Template Name (if the date format specified in the template is different from this cell, the template selection will take precedence).

### Address
Enter the code for the company address to use with this user. (Refer to the Unifier Reference Guide for the list of codes)

### Template Name
If you have created User Preferences Templates, enter the name of the template to use for this user.

### Status*
Enter a status code for this user: Active=1, On-Hold=2, Inactive=0

* = mandatory column

**To import the CSV file into Unifier**

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **User Administration > Users** in the left Navigator.
3. Choose New > Import to import the completed CSV file.
4. Click **Browse** and navigate to where you saved the file.
5. Click **OK** to import. New users are created and existing users are updated.
6. Open the User record and setup the Groups, Permissions, Projects/Shells, Programs, and Proxy tabs as needed.

   If any rows contain errors, no rows are imported. Error messages are listed in the CSV file.
To fix import errors
If you receive the Confirmation message:

Import could not be completed. Do you want to download a file with errors shown?

1) Click Yes to open the CSV file.
2) Fix the rows that contain errors.
3) Re-import the file.

Export user records
You can export a CSV file with current user information.

To export a CSV file containing all user records
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Company Users in the left Navigator.
3) Click the File menu and choose Export > All. A confirmation window opens. Do one of the following:
   - Click Open to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   - Click Save to save the file to your local drive. Enter a name for the file and click Save.

To export a CSV file containing selected user records
1) In the Company Users log, select one or more users to export (press the Ctrl or Shift keys to select multiple users).
2) Click the File menu and choose Export > Selection. A confirmation window opens. Do one of the following:
   - Click Open to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   - Click Save to save the file to your local drive. Enter a name for the file and click Save.

Manage user login information (Security tab)
Before you activate a new user, you must enter a Login Username. To allow the user to sign in to the system, you must also add an initial password. You can also change the user’s password here, for example if the user has forgotten their password.

Users can change their password later in the User Preferences window.

Note: If you are using Oracle Identity Management (OIM) to add users to your company, the instructions that follow do not apply. OIM creates the user’s login name, first and last names, and email account. Users manage their own passwords with OIM. OIM does not honor user attribute forms.

To add or manage user login information
1) In the User Administration log, select a user and click Open. The Edit User window opens.
2) Click the **Security** tab.

3) Complete the fields as shown in the following table.

4) Click **Apply** to save changes, or **OK** to save and exit.

<table>
<thead>
<tr>
<th><strong>In this field:</strong></th>
<th><strong>Do this:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Login Username</td>
<td>Enter the Users Sign In ID (required). This value can be changed by the System or Company Administrator but not by the User.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the value the user will use as their Sign In ID. Passwords must match the company Security/Password policy, if one is in force.</td>
</tr>
<tr>
<td>Confirm Password</td>
<td>Confirm password by re-entering.</td>
</tr>
</tbody>
</table>
| View Password Policy | Click this link to verify the password is conforming to your company’s Security/Password policy (Edit Company window, Security tab). A password that does not comply will generate a warning message.  

**Note:** If you are using OIM to provision your company users, the password policy specified here will be superseded by the password policy in OIM.

---

**Note:** The Security tab is not available if Unifier is integrated with SSO (LDAP, OAM).

---

**Manage a user’s group membership (Groups tab)**

You can manage a user’s group membership from the Groups tab of the Edit User window. This tab displays all the groups the user is a member of, and allows you to quickly add or remove groups. The default groups are Company Administrators, Project Administrators, Shell Administrators, and Support. For information about adding or managing groups, see **Adding and Managing Groups** (on page 150).

**Note:** If you are using OIM to add users to your company, you will still have to use these instructions to add users to groups.

**To add a user to a group**

1) In the User Administration log, select a user and click **Open**. The Edit User window opens.

2) Select the **Groups** tab.

3) Click **Add**. The User/Group Picker opens.

4) Select the **Group** and click **Add**. The group will appear in the Selected Groups window. Click **OK** to save.
To remove a user from a group
On the Groups tab, select a group and click Remove.

Edit user permissions (Permissions tab)
This procedure allows you to grant or remove specific user permissions. This is useful if a user needs special permissions that are not likely to be repeated with other users, or is not part of a group. You can also specify permissions for groups (if you add the user to the group, the user will automatically inherit all group permissions, or control permissions through Access Control.

To edit a user's permission settings
1) In the User Administration log, select a user and click Open. The Edit User window opens.
2) Select the Permissions tab.
3) Click a plus sign to expand the choices. Scroll up or down as needed.
4) Select the Permission module in which to grant permissions. Choose the Permission level in the bottom window. Permissions are described in the Unifier Reference Guide.
5) Click OK to save.

To copy permissions from a template
1) In the Permissions tab, click the Copy Permissions button.
2) Select the template and click OK. All permissions settings in the user record will be overwritten and replaced with the permission settings from the template.

View user's project, program, and shell membership (Project/Program/Shell tabs)
Users can be added to projects, programs, and shells giving them access to participate in them. You can view a user's project membership in the Projects/Shells tab, and program membership in the Program tab.

To view a user's project membership
1) In the User Administration log, select a user and click Open. The Edit User window opens.
2) Select the Projects tab. This tab displays the list of programs of which the user is a member. Users cannot be added or removed from Programs here.

To view a user's program membership
1) In the User Administration log, select a user and click Open. The Edit User window opens.
2) Select the Programs tab. This tab displays the list of programs of which the user is a member. Users cannot be added or removed from Programs here.

Designate a proxy user (Proxy tab)
A Site/Company Administrator can designate a user to be a proxy user for another user.
- Proxy users can be granted permission to access another user's account and perform various functions on that person's behalf if that person is unavailable, such as on vacation.
Proxy users who are active (Status: Active) receive email notification of tasks to perform as proxy. This applies during the time specified time period, using the Start Date/Time and End Date/Time.

Proxy users have access to all of the records, settings and functions of the original user. A proxy user signed in to another’s account cannot change Preference settings. The Audit logs reflect the actions taken by a proxy user as "on behalf of" the original user.

**Note:** If the specified proxy user has Send notifications in a single daily digest selected on the Options tab of their User Preferences, it will impact when they receive notification of the task they must perform as proxy. Ensure that the Send notifications in a single daily digest checkbox is deselected for the proxy user if that user must receive the task notifications immediately.

To designate a proxy user follow these steps:

**Note:** The following applies to Company Users, Partner Users, and Groups.

1) Launch **Unifier > Company Workspace > Admin mode > User Administration > Company Users.**
2) Select a user from the Users log and click open to open the **Edit User** window
3) Click **Proxy** tab.
4) Set the options per following descriptions.

**Do not allow Proxies**

The Site/Company Administrators, Company users, and Partner users) are permitted to select the **Do not allow Proxies** option.

**Note:** This option is read-only in the user's User Preferences window.

Users are able to add proxy users in their User Preferences window only if the Site/Company Administrator has not checked the **Do not allow Proxies** option in the Proxy tab of Edit User window.

**Users who can act as my Proxy**

This section of the Proxy tab lists the users who can act as proxy and allows you to add, adjust the settings, remove proxies, and view the proxy login history.

**Note:** You can select/designate more than one proxy user.

**Add**

The Company Administrator can assign other users to act as proxies to your account. if you are unable to do so.

To add a proxy:

1) Click **Add** to open the **Proxy User Settings** window.
2) Click **Select** to open the **Users/Group Picker** window.
3) Select users, click **Add**, and then click **OK** to go back to the **Proxy User Settings** window.
4) Enter the Start Date/Time and End Date/Time values.
5) Select the **Status (Active)** and click **OK**.

**Settings**

Use this option to select an existing proxy and change the user settings of the proxy, such as start and end date/time. To change the user settings of the proxy, click **Settings** and follow the prompts.

The system sets the values in the time-related fields base on the user's preferred data and time formats.

---

**Note:** If you do not specify a start or end date, the proxy user can access your account immediately and their access privileges will not expire.

You can select **Active** to activate proxy's access. To disable proxy's access, select **Inactive**.

**Remove**

You can use this option to remove a selected proxy. To remove a user as a proxy, click to select the proxy from the list and click **Remove**.

**Proxy Login History**

Use this option to view the following information about the proxies:

- Name
- Login Date
- Logout Date

The last login information appears on top.

---

**Note:** The **Sign Out** link at the upper right portion of the Unifier window allows a proxy's session to end.

---

**Send email to a company user**

This is available for company users only, and is not available for partner company users.

**To send an email to a company user**

1) Navigate to the Company Users log.
2) Select one or more names in the log, then click **Send email** on the button bar. Your email client window opens, where you can then send an email to the user(s) you selected.
Unlock a locked user account

A user account can be locked if the user exceeds the maximum logon attempts, or if the user has not signed in after a specified number of days. These password criteria are configured on the Security tab of the Edit Company window.

Users who are locked out of Unifier will receive a message stating the condition that needs to be corrected.

*Note:* If you are using Oracle Identity Management (OIM) to provision the users in your company, you must use OIM to unlock a user account. For information, see the documentation that accompanies the OIM product.

**To unlock a locked user account**

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **User Administration > Company Users** or **User Administration > Partner Users** in the left Navigator.
3. Select the user from the log.
4. Click **Open**, and click the **Security** tab. When a user’s account is locked, the Unlock account checkbox appears selected. This checkbox is provided only if the user’s account is locked. Otherwise, it does not appear on the user’s Security tab.
5. Deselect the **Unlock account** checkbox.
6. Click **Apply** to save or **OK** to save and exit.

Change the status of multiple company users

If you want to change the status of multiple users at the same time you can select the users from the log and change the status for all of those users. This eliminates the need for you to open each user record to modify the user status.

The **License Manager** controls the number of active users within a system. If the new users will exceed your license terms, you will receive an error message.

**To change the status of multiple company users**

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **User Administration > Company Users** in the left Navigator.
3. Select the users whose status you want to change.
4. Choose **Status** and one of the available statuses (Active, Inactive, On-Hold).

View or print user audit log

To view the Audit Log for a user record:

1. Select a user from the Users log.
2. Click the **View** menu and choose **Audit Log**. The Audit Log window opens, listing each event associated with the user.
3) From the Audit Log window, you can double-click a listed event to view the audit record detail, which details the action taken. The details also include for reference the current time zone of the user viewing the audit log.

To print the audit log:
1) From the Audit Log window, click the **Print** button. A PDF file of the audit log is created.
2) Do one of the following:
   - Click **Open** to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save, or print the file.
   - Click **Save**. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose **File > Print** to print.

### Adding and Managing Partner Company Users

Adding a partner company user enables you to grant them access to your company Unifier features in the company workspace, programs, projects, or shells. You can manage their status, group membership, and permissions.

**Add a partner company user**

Partner company user details are managed by the Site Administrator or the company administrator for the partner company. As the company administrator for the your company, you can add partner company users to your own company at the company, program, project, or shell level, and control their status and permissions within your company.

Partner company users can be added to projects or shells, even if the users do not show up on this list. If a partner company user is added to a project or shell, the user will be added to the Partner Company Users log automatically.

**Note**: The License Manager controls the number of active partner company users within a system. If the new users will exceed your license terms, you will receive an error message.

**Note**: By default, new users will have a status of **Active**. You can change the status or other user detail information selecting the user from the list and clicking **Open**.

**To access the Partner Users log**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **User Administration > Partner Users** in the left Navigator. To open an existing user record, select a user from the log and click **Open**.
Note: If a User Attribute form has been imported, the columns that appear in the Users Log can vary. If designed in uDesigner, the log can include navigation in the left pane. This navigation allows you to filter the display of users listed in the log. If you decide that you want a standard log to display, you can remove the navigation from the log in uDesigner. Also, the search criteria in the Find window and sort order can also vary depending on what was added to the User log design in the User Attribute form.

To add a partner company user
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Partner Users in the left Navigator.
3) Click New. The User/Group Picker opens.

Note: If a User Administration design has been imported, the content of the User/Group Picker (in User view) can vary. The Find window and sort order can also vary depending on the optional design created in uDesigner.

4) Click the List Names from drop-down list at the top of the picker window and choose the company from which to add the new project or shell user.
   This drop-down lists your sponsor company plus any Partner Companies. You can click the Partner Companies node under your company to view the list of available partner companies.
5) Select one or more users to add. You can press the Shift or Ctrl keys to select multiple users at once.
6) Click the Add button. You can continue to select and add names to the Selected Users portion of the picker window.
7) Click OK to add the users to the Partner Users log.

Manage partner company user status, groups and permissions
User details such as contact information are managed for individual users by the company administrator for the partner company.

Note: Partner company users can be granted Company Administrator permissions if you add them to the Company Administrators group. See Manage a user's group membership (Groups tab) (on page 142) for details on adding users to groups.

You can manage the following information for partner company users:

Status: You can change the partner company user to Active, Inactive, or On-Hold.
   - Active users are eligible to participate in company or project- or shell-level activities to which they have permissions.
   - On-Hold users appear on user pickers, and can be added to business process set ups, project or shell user lists. However, the user cannot log onto the system until they are activated.
In inactive users will not appear in user pickers. If you inactivate partner company users, they will automatically become inactive throughout the system, including in any projects or shells to which they belong. After inactivating, if you then change the status back Active, their status in projects or shells will not automatically change back to Active; you will need to reactivate them at the project or shell level.

Groups: You can add a partner company user to a company or project- or shell-level group as needed.

Permissions: You control permission access for partner company users within your company.

To edit a partner company user’s details
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration>Partner Users in the left Navigator. The Users log opens.
3) Select a partner company user and click Open. The Partner Company Edit User window opens.

  **Note:** If a User Administration design has been imported, the data elements that appear in the General tab of the User Properties can vary.

4) Do any of the following:
   - To change the status of the partner company user, click the General tab and change the Status field.
   - To manage a partner company user’s group membership, click the Groups tab. Click Add or Remove.
   - To manage a partner company user’s permissions, click the Permissions tab. Grant permissions to the user as needed. (In addition, when using Access Control, both partner company users and sponsor company users can be added to a module.)
5) Click OK to save and exit.

Change the status of multiple partner users
If you want to change the status of multiple users at the same time you can select the users from the log and change the status for all of those users. This eliminates the need for you to open each user record to modify the user status.

  **Note:** The License Manager controls the number of active users within a system. If the new users will exceed your license terms, you will receive an error message.

To change the status of multiple partner users
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Partner Users in the left Navigator.
3) Select the users whose status you want to change.
4) Choose Status and one of the available statuses (Active, Inactive, On-Hold).
Adding and Managing Groups

Company-level user groups can be used to group users who will be using the same functionality in Primavera Unifier and assigned the same Permissions. Anytime a new person comes onto the project or shell you can assign them to the appropriate groups and their permissions will be set automatically.

There are three default groups created for new companies: Company Administrators, Project Administrators, and Support. You can edit group information and permissions as necessary, and create new groups as needed.

For example, you may want to create a "Finance Admin" group and give them permission to create and modify Cost Sheet Templates. Another "Finance User" group may have permission to access and work with project- and shell-level cost sheets, but not the templates. These users may require access to only those modules and reports dealing with finances, but not other areas of the company, project or shell.

To access user groups
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Groups in the left Navigator.

Create a new group

The following discusses how to create a new group.

To create a new group
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration > Groups in the left Navigator. The Groups log opens.
3) Click the New button. The Groups window opens.
4) Complete the General tab as outlined in the following table.
5) At this point you can also complete the other two tabs:
   - Add user to the groups in the Members tab.
   - Add group permissions in the Permissions tab.
6) Click OK to add the new Group.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Name</td>
<td>Enter a name for the group.</td>
</tr>
<tr>
<td>Group Manager</td>
<td>Click Select and select the person responsible for administering the group. This person automatically becomes a member of the Group.</td>
</tr>
<tr>
<td>Group Description</td>
<td>Enter a description, such as the group’s function or permission level.</td>
</tr>
</tbody>
</table>
Add users to a group (Members tab)

This section discusses how to add and manage a group’s membership. You can add company users or partner company users to a group. You can also manage a user’s group membership in the Groups tab of the Edit User window of both company and partner users.

To add a user to a group
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration>Groups in the left Navigator. The Groups log opens.
3) Select a group and click Open. The Groups window opens.
4) Click the Members tab, and click Add. The User/Group Picker opens. The User/Group Picker displays all Active or On-Hold users from the sponsor company and all Partner Companies. The company affiliation is noted in the Company column on the picker.

Note: If a User Administration design has been imported, the content of the User/Group picker (in User view) can vary. The Find window and sort order can also vary depending on the optional design created in uDesigner.

5) Select the user(s) to add to the group. (Press the Ctrl or Shift keys to select more than one user name.)
6) Click Add. Users will appear in the Selected Users box.
7) Click OK, then click OK to close the Groups window.

To remove a user from a group
From the Groups window, Members tab, select the user on the list and click Remove.

Edit group permissions (Permissions tab)

The permissions assigned here will be applied to all members of the group. Users within the group inherit permissions from the group. If a user is in more than one group, then the highest level of permissions granted in any group for a module will prevail.

Note: Permissions are described in the Unifier Reference Guide.

To assign permissions
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration>Groups in the left Navigator. The Groups log opens.
3) Select a group and click Open. The Groups window opens.
4) Click the Permissions tab.
5) You may click on the plus sign next to a module to expand the options. Scroll up or down, as needed.
6) Select a module in the upper portion of the window. Choose the Permission level for that module in the lower portion.
7) Click OK to save.
To copy permissions from a template
1) In the Permissions tab, click the Copy Permissions button.
2) Select the template and click OK. All permissions settings in the user record will be overwritten and replaced with the permission settings from the template.

Managing users in bulk

You can use bulk processing to manage users across a large number of projects or shells. Bulk processing means that you can perform the same action on a large number of user records without having to navigate to each record and perform the same action repeatedly. You can perform this bulk processing at the shell or project level. Bulk user management is performed using CSV file export and import. Importing user group assignments and importing users uses the existing Add Users permissions on a project or shell.

**Note:** For cases where users have the same first and last name, the combination of first name, last name, company, and email address is used to uniquely identify a user. The email address is required on all imported rows.

You can use bulk processing to:
- Add or remove user group assignments
- Add new users

**Note:** If you are using Oracle Identity Management (OIM) to add users to your company, you cannot use CSV files to add users. OIM creates the user's login name, first and last names, and email account. Users manage their own passwords with OIM. OIM does not honor user attribute forms. For information, see the documentation that accompanies the OIM product.

- Change the status of existing users
- Update multiple users in the User logs for Company or Partner users

Change user group assignments or add new users in bulk

To add or remove user group assignments in bulk
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Company Sponsored Projects > All or Company Sponsored Shells > shell log (for the shells that you have configured).
3) Select projects or shells from the log.
4) Choose File > Export > Export User Group Assignments > All Projects/Shells or File > Export > Export User Group Assignments > Selected Projects/Shells. This will export the current user group assignments for all or the selected projects or shells to a CSV file. The exported file contains all users and group assignments for the selected projects or shells. Empty project groups are exported as well. Users that are not assigned to groups are not exported.
5) All columns are required, except the Action column. The Action column determines if a user is added to a group, removed from a group, or if no action occurs for a user’s group assignment. Enter Remove to remove a user from a group; enter Add to add a user to a group. Users are automatically added in the Active status. If you leave the Action column blank for a user, no action occurs for that user’s group assignment.

**Note:** The words Remove and Add must be initial capitalized.

To change a group assignment for a user, remove the user from one group and then add them to another.

6) You can also add new users at this point by adding new lines to the sheet and entering the data for the new users. On import, these new users are added to the project or shell with Active status. When you add new users, you must enter data into all columns except for Action, which is optional. New partner company users are added to Partner Company Users as well as to the project or shell.

7) Save the CSV sheet when you are finished modifying the user group assignments or adding new users.

8) Navigate back to the log and choose File > Import > Import User Group Assignments.

9) Upload the modified CSV file and click OK.

The import process will load all rows that have no errors. The import can issue exceptions if:
- A user is not a valid user in Unifier
- The user/company combination is not valid
- The group is not valid in the project/shell
- The Partner user license is exceeded
- Action specified is invalid
- Insufficient permissions exist to add users or add and remove group assignments

**Change user status in bulk**

To change user status in bulk:

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Company Sponsored Projects > All or CompanySponsored Shells > shell log (for the shells that you have configured).

3) Select projects or shells from the log.

4) Choose File > Export > Export Users. This will export the current users for the selected projects or shells to a CSV file.

5) In the Status column of the CSV file, change the status of the user as needed. Valid status designations are:
   - Active
   - Inactive
   - On-Hold

   Also, you can add new users. Be sure to provide valid values in all columns.

6) Save the CSV sheet when you are finished modifying the user statuses.

7) Navigate back to the log and choose File > Import > Import Users.
The import process will change the status of existing users and add new users as specified in the CSV sheet. Users can be added from companies listed under the Member Companies node at the project/shell level.

The import process will load all rows that have no errors. The import can issue exceptions if:

- A user is not a valid user in Unifier
- The user/company combination is not valid
- The group is not valid in the project/shell
- The Partner user license is exceeded
- Insufficient permissions exist to change the user status or add a user

8) Upload the modified CSV file and click **OK**.

### Update multiple company or partner users

Bulk edit of Company or Partner users relies on fields defined in Integration and is available only if the User Attribute form has been imported. For Partner users, the only additional attributes that are available for bulk edit are those that were added by importing the User Attribute form.

**Note:** Bulk update of status is available through the Status button in the Users log toolbar.

### To update multiple users in the Users log

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **User Administration > Company Users or User Administration > Partner Users** in the left Navigator.
3) From the log, select users to modify.
4) Choose **Edit > Bulk Edit**.
5) Modify the Bulk Edit form as needed.
6) Select the **Update** checkbox for the fields you want to update. The checkbox is automatically selected when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.
7) Click **Update**. This launches the bulk update of the selected records.

The Bulk Actions Status window displays after you click Update. This window allows you to monitor the progress of the bulk update. Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.

### Creating and Managing User Preference Templates

User Preference templates can be used to configure the default user preference settings for new users. It can also be used to update existing users' user preferences by "pushing" the preference options. In this way, you can establish a standard for your users' preference settings.

**Note:** If you are using Oracle Identity Management (OIM) to enter users into your company, preference templates will be ignored.
**Create a User Preferences Template**

You can create any number of user preferences templates.

To create a new User Preferences Template:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Standards and Libraries** and then **User Preference Templates** in the left Navigator. The Preference Templates log opens.
3) Click **New**. The User Preferences Template window opens.
4) On the **General** tab, enter a name for the template. Each template must have a unique name. Enter an optional description.
5) For **Status**, choose **Active** or **Inactive**. You can create any number of templates, but only one can be active at a time.
   The Active template will be used as the default user preference settings when adding new company users. The other templates can be used to update ("push") preference settings to existing users.
6) Click the **Preference** tab. The Preferences tab appears exactly like the Options tab of a user’s User Preference window. Complete the fields in the window as described earlier in the **User Preferences** (on page 34) section of this guide.
7) Click **Apply** to save changes, or **OK** to save and close the window.

**Update Users with the User Preferences Template**

You can create multiple user preference templates. The Active template will be used as the default template when creating new users. The other templates can be used to update ("push") preference settings to existing users.

The Update Users process runs in the background. Depending on the number of records and projects or shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

To apply the user preferences template to selected users

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Standards and Libraries > User Preference Templates** in the left Navigator. The Preference Templates log opens.
3) Select any template in the log.
4) Click the **Update Users** button and choose **Users**. The User Picker opens. The picker lists Company Users.
5) Select the users to update and click **Add**. Click **OK** to close the picker window.
6) Select preferences to update. Only selected options are updated. Email subscription choices are not selectable; they are determined by the template.
7) Click **OK**.
8) Click **Yes** to confirm. The user preferences of the selected user(s) will be updated with the template settings.
To apply the user preferences template to all users
1) In the Preference Templates log, select a template.
2) Click the Update Users button and choose All Users. This includes Company Users. Users are identified by their unique User ID.
3) Select preferences to update. Only selected options are updated. Email subscription choices are not selectable; they are determined by the template.
4) Click OK.
5) Click Yes to confirm.

View update users history
You can view details about previous Update User runs.

To view Update Users History
1) Go to the Company Workspace tab and switch to Admin mode.
3) Click the Update Users button and choose History. The Update Users: History window opens. It lists the following:
   - Requestor: User who initiated the update process
   - Users: Either user selected or all users
   - Submit date: When the update request was submitted
   - Start date: When the update process started
   - End date: When the update process ended
   - Status: Status of the request
4) Select an instance from the list and click Open (or double-click to open). The History Details window opens, displaying which users were updated by the request.

Cancel a user update request
You can cancel an update request that has not yet started, that is, the status is not In Process or Finished.

To cancel a user update request
1) Go to the Company Workspace tab and switch to Admin mode.
3) Click the Update Projects or Update Shells button and choose History. The Update Projects or Shells: History window opens.
4) Select an update that has not yet started.
5) Click Cancel Request.
Creating an Approved Email List for Project and Shell Mailboxes

External emails are important communications that need to be included in projects and shells. Such emails can come from project or shell members who send emails from outside Unifier, or from external users who do not use Unifier. These email communications (and any attachments) can be collected in a central repository, called a Mailbox, so that users can use them in managing and documenting the project or shell. Once such emails reside in the project’s or shell’s Mailbox, users can forward them to appropriate members, flag them for review, and reply to them. In addition, these external emails can be linked to business process records.

**Note:** Any email address used by any company or partner user will be considered "approved" and automatically added to this list.

When Unifier is installed on your system, a dedicated email address for your company is specified, and whenever a project or shell is created, it is given a unique identifier. Unifier combines your company email address and project/shell identifier to create a dedicated "mailbox" as the communications repository for the project or shell.

To prevent spam and virus attacks from infiltrating your system via external emails, you will need to create a list of approved email addresses that will be accepted by the project or shell Mailbox.

**Note:** Unifier will accept up to 1,000 emails from any single address per day. Any emails beyond 1,000 will be ignored as spam.

### To create an approved email list

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Standards & Libraries > Approved Email List** in the left Navigator.
3. Click the **New** button. The Add/Edit Approved Emails window opens.
4. In the **Email** field, enter the email address you want to add to the approved list.
5. (Optional) In the **First Name** and **Last Name** fields, enter the name of the user.
6. If you want to add another email address, click **Apply**; otherwise, click **OK** to close the window.

### To edit an email address

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **Standards & Libraries > Approved Email List** in the left Navigator.
3. In the log of email addresses, double-click the address. The **Add/Edit Approved Emails** opens.
4. Edit the information and click **OK**.

### To delete an email address

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **Standards & Libraries > Approved Email List** in the left Navigator.
3. In the log of email addresses, select the address you want to delete and click the **Delete** button.
To find a specific email address

1) On the Approved Email List log, click the Find button. A Find window opens.
   The Find window shows fields from the list, which you can use to narrow the list of items you see on the list. These fields show an operator, such as "contains" or "equals," which you can use to specify more precisely which items you want to search for.

2) Click the operator beside the field and choose the operator you want to use on the field, such as "equals," "does not contain," or "is empty".

3) Enter the value the field should contain.
   You can enter a partial name or address.

4) Click Search (or press Enter).
   Unifier will display the address(es) or name(s) that match the criteria you entered. It will also identify the criteria by which you have searched the list in the "Current View: filtered by" line above the list. If you choose to, you can cancel the find action by clicking [Cancel Filter]. Unifier will restore the list to its unfiltered state.

Import and Export Email Addresses

If the user and email address information is stored in another software application, such as Microsoft Excel, you can import the information from the software application into the Approved Email List. You can also export the information from the Approved Email List to another software application, if necessary.

To import and export email addresses, you first need to create a template structure to use for both the import and export actions.

Note: If you choose the Export > All option, you do not need to create a template structure.

To create a template structure

1) On the Approved Email List log, click the Export button and choose Structure.
2) At the File Download prompt, click Open. Unifier opens a CSV file showing columns for the email address, first name, and last name of the user.
3) Save the CSV file. This CSV file becomes the vehicle for importing and exporting Approved Email List data.

To import approved email addresses

1) On the Approved Email List log, click the Import button. The File Upload window opens.
2) Use the Browse button to navigate to the CSV file you want to import.
3) Click OK to upload the file into the Approved Email List.

To export all approved email addresses

On the Approved Email List log, click the Export button and choose All. Unifier will export all the email addresses on the approved list to the CSV file and open the file. You can edit the file and import it back into Unifier, or save the file for later updates.
To export specific approved email addresses
1) On the Approved Email List log, select the addresses you want to export.
2) Click the Export button and choose Selected.
   Unifier will export the email addresses you selected to the CSV file and open the file. You can edit the file and import it back into Unifier, or save the file for later updates.

Managing permissions and access control

Permissions can be set at the company level, program level, or project and shell level. This section discusses managing company level permissions.

Company level permissions can be set on company, program, shell, and project level functions. Changes to program and project or shell level permission settings made here will take affect for new programs and projects or shells to which users will be assigned. These settings can be overridden by adjusting specific permissions at the program or project or shell.

About Permissions

- Permissions are granted to users, or groups, to allow them access to Unifier features. Specific permission settings are described in the Unifier Reference Guide.
- A user can be granted permissions individually, or can inherit them from the groups to which the user belongs.
- If a user is in more than one group, then the highest level of permissions granted in any group for a module will prevail.
- Users can be granted individual permissions in addition to group permissions. If user-level and group-level permissions are different for a module, the highest level will be granted to the user.
- If you grant permissions to project or shell level User Mode features from the company-level Permissions tab, the new permission settings will take effect on future projects or shells the user is assigned to, but not on current projects or shells. To grant permissions to a user for a current project, be sure to change the permissions from the project or shell level user record.
- Permissions in a project or shell template from which the project or shell is created override Company level permissions.

Permission tab versus Access Control

There are two ways to control permissions and access to Unifier features and records: Access Control and the Permissions tab. Both of these will allow you to manage permissions. See below to help you decide which to use.

Access Control

Access Control displays the permissions granted to all users and groups per module. It allows you to quickly see which users and groups have access to each module and at what permission setting.

You can add, remove or adjust permissions for multiple users or groups at once, rather than editing the properties for each user or group individually. For example, if you need to grant access permissions to a newly setup business process, or want to verify that all team members have access to a new feature, it may be easier to do this in Access Control rather than opening each individual group or user record.
You can also generate and print an Access Information table summarizing permission settings.

**Permissions tab**

You can manage individual user or group permissions in the Permissions tab, which is part of the Properties window for the user or group record. Use the Permissions tab to quickly view or adjust permission settings for a particular user or group.

The Permissions tab also enables access to permission templates. You can copy a permission template to quickly set up the permissions for a new user or group; you can also save an existing user or group’s permission settings as a new template for later use.

See *Edit user permissions (Permissions tab)* (on page 143) or *Edit group permissions (Permissions tab)* (on page 151).

**Edit user or group permissions using Access Control**

**To adjust permission settings using Access Control**

1) Do one of the following:

   - To open company level access control, go to the **Company Workspace** tab and switch to Admin mode. Click **Access Control** in the left Navigator. The Access Control window opens in the right pane of the Unifier window. The window displays a copy of the Navigator.
   - To open access control for a program, go to the Company Workspace tab and switch to Admin mode. Click **Access Control** in the left Navigator. The Access Control window opens in the right pane of the Unifier window. The window displays a copy of the Navigator.
   - To open access control for a project, open the project and click **Access Control** in the left Navigator. The Access Control window opens in the right pane of the Unifier window. The window displays a copy of the Navigator.
   - To open access control for a shell, open the shell and click **Access Control** in the left Navigator. The Access Control window opens in the right pane of the Unifier window. The window displays a copy of the Navigator.

2) Select a module in the Access Control window. The Module Permission Settings window opens. It lists the user(s) and group(s) which currently have access to the selected module and their permission settings.

   You can **Add**, **Modify**, or **Remove** users or groups, and grant permission levels. See the following procedures.

**To add user and group access to a module**

1) From the Module Permission Settings window, click **Add**. The Permission/Access Control window opens.

2) Click **Add Users/Groups**. The **User/Group Picker** opens.

3) Select users and/or groups from the list, click **Add** to add them to the Selected Users/Groups list, and click **OK**.

4) In the **Permission Settings** window, select the level of permissions you want to assign to the Users/Groups. Click **OK**.
To remove a user/group and their related module permissions

In the Module Permission Settings window, select the checkbox next to the user or group and then click the Remove button.

To modify permission settings

In the Module Permission Settings window, select the checkbox next to the user or group and then click the Modify button. Make changes to permission settings as needed and click OK.

Create or edit a permission template

Permission templates are sets of permissions that can be applied to users or groups of users as a whole. This is often an easier alternative to setting individual access permissions, especially when setting up groups and working with large project or shell teams. You can apply the template to a user or group to set basic permissions, then modify the permissions for individuals or groups if needed.

Note that any project or shell level permission granted at the company level and then applied to a specific user or group of users is inherited at project or shell creation time. The user permissions can then be modified at the project or shell level if further modifications are necessary.

To create a new permission template

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Permission Templates in the left Navigator. The Permission Templates log opens.
3) Click the New button. The Edit Permission Template window opens.
4) Add a name and description of the template in the General tab.
5) Click the Permissions tab. This window is the same as the Permissions tab for an individual user or group record.
6) Configure the permissions settings and click OK.

To edit a permission template

1) Select the template from the Permission Template log and click the Open button. The Edit Permission Template window opens.
2) You can edit the name or description in the General tab.
3) Click the Permissions tab and adjust permission settings as needed.
4) Click OK.

To create a new permission template from existing permission settings

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click User Administration>Groups in the left Navigator.
3) Select a group and click Open.
4) Click the Permissions tab.
5) Click the Save as Template button. Enter a template name and click OK.
Generate and print an Access Information report

You can generate and print an Access Information summary report of user and group permission settings. The report will display all user and group permissions.

To generate the Access Information report
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) Click the Access Information button. The Access Information window opens. It may take several moments to generate the report.

To print the Access Information report
1) Generate the Access Information report. When the report is complete, the Print button becomes available on the toolbar.
2) Click the Print button. Select the printer and click OK.
Working with the License Manager

The License Manager controls the number of active named users (that is, the number of unique sign in usernames) that are allowed in the system, based on agreed license terms. This applies to both sponsor company users, and any partner company users. The license manager terms — number of allowed users — are maintained by the Site Administrator, and cannot be edited by the Company Administrator.

The Company Administrator can access the license manager to view the current named users and user record limits, view usage charts, and print usage reports. The License Manager can also be set up to automatically notify the company administrator (or other designated user) when the number of named users is approaching the limit. The License Manager can also allow for an "overage" — a certain number of users that are over the limit, as determined by the terms of the license agreement.

And "active named user" refers to any user in the system with a status of "Active" or "On hold." Users with a status of "Inactive" are not counted against the license terms. Any number of inactive users can be added or imported. The license manager counts users with status of Active or On-Hold.

View License Manager terms and usage

The License Manager console provides easy access for viewing license terms and usage.

To view the License Manager console

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click License Manager in the left Navigator. The License Manager console opens in the right pane.

   The License Manager displays the following:
   - **License Terms**: Displays the number of Active Named Users — that is, any user with a specific user name and password — in the sponsor company and all partner companies. ("Active" refers to users with a status of Active or On-Hold.) It also displays any Overage limits, which allow companies to exceed their active named user limits by an agreed upon amount.
   - **Current Usage**: Displays the current number of Active Named Users (users with status Active or On Hold for your company and partner companies, and whether the Overage is being used. Usage refers to user records only, regardless of whether the users are currently signed in, or not. (Current Usage also displays the "as of" date and time of the last update.)
   - **License Utilization Charts**: Displays Active Named User and Overage terms and usage in chart form.

To view the License Terms window

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click License Manager in the left Navigator. The License Manager console displays in the right pane.
3) Click the Open button. The License Terms window opens. This window is read-only for company administrators, and is editable by Site Administrators only.
The General tab displays your company’s current license terms. This tab is read-only, and managed by the Site Administrator.

The Notification tab allows you to schedule regular usage checks, and configure thresholds for notifying you when you are getting close to license term limits.

If you exceed license limits while adding or importing users

- While adding company or partner company users, if license limits have been reached, a warning message will appear. You may receive this warning message if:
  - The license limit for active named users has been reached, but not the overage limits. Any new users will be counted against the overage limits.
  - The license limits for both active named users and overage have been reached. You will be able to add new user records, but will not be able to activate them without adjusting your current license limits, or deactivating other users.
  - If you are adding partner company users to the company workspace or a project or shell, you can add the users, but will not be able to activate them.
  - If you are importing users (via XML or CSV), and the license limits are reached, any user records that would exceed the limit will not be created, and you will receive an error message informing you of the number of user records that could not be created.
  - In addition, if your license limits have been reached, you will not be able to activate any currently inactive users.

Set up License Manager scheduled runs and notifications

You can set up the License Manager to notify you when the number of active users in your company or partner companies is approaching the established license limits.

**Note:** Notifications will only be sent if a scheduled run is set up and enabled. Notifications will only be sent to users or groups who have been given explicit Modify or Notify Permissions.

To set up notification and threshold limits

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click License Manager in the left Navigator. The License Manager console appears in the right pane.
3) Click the Open button. The License Terms window opens.
4) Click the Notifications tab. Complete the fields as described in the following table and click OK.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable</td>
<td>Select this checkbox to enable notifications regarding License Term</td>
</tr>
</tbody>
</table>
### Notifications

Thresholds. These email notifications will be sent to users or groups who explicitly have Modify or Notify permissions. Notifications are sent only after scheduled runs.

### Notification Thresholds: Active Named Users

Enter the threshold values for active named users in your company and partner company. For example, if you want to be notified when the number of active named users in the system reaches 80% of your license terms, then enter 80 in this field.

**Note:** The threshold value calculates against the number of allowed active users in the license terms, and does not count overage amounts. Once the threshold limit has been reached, users will continue to receive notifications during every scheduled run.

### Scheduled Runs Frequency

You must schedule usage runs in order to generate notifications. These runs check for currently active named users in your company and partner company. You will receive notification of these runs only if threshold values have been reached. Choose frequency:

- **Weekly:** select the day of the week.
- **Monthly:** select the day of the month.

---

**Print license manager information**

You can print a copy of the current license manager console view.

**To print license manager terms and usage**

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **License Manager** in the left Navigator. The License Manager displays in the right pane.
3. Click the **Print Preview** button. The information appears in a printable HTML format in a separate browser window.
4. Click the **Print** icon in the upper right corner of the preview window. Select your printer and click **Print**.

**View or print the License Manager audit log**

The audit log captures changes made to license terms. You can view the audit log, print a copy, or save a PDF copy of the audit log to your local drive.

**To view a license manager audit log**

1. From the License Manager log, click the **View** menu and choose **Audit Log**. The Audit Log window opens.
2. From the Audit Log window, you can double-click a listed event to view the audit record detail, which includes for reference the current time zone of the user viewing the audit log.

**To print the audit log**

1. From the Audit Log window, click the **Print** button. A PDF file is created.
2) Do one of the following:
   ▶ Click **Open** to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save, or print the file.
   ▶ Click **Save**. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose **File > Print** to print.

### Running System Usage Reports

You can track current system usage using the predefined system usage reports. These reports provide an accurate and efficient way to track and manage licenses and system usage. Usage reports can be run based on company workspace or individual projects or shells, and can track both sponsor company users and partner company users.

The available reports are:

- Usage Detail By Company
- Usage Summary By Company
- Usage Detail By Project/Shell
- Usage Summary By Project/Shell
- Usage Detail By Company Workspace
- Usage Summary By Company Workspace
- Usage Detail By User
- Usage Summary By User
- User Account Details
- User Account Summary
- User Session Detail
- Last Login
- Current Login
- Proxy Login

The reports are described in the following sections.

### Run a System Usage Report

The following is the general procedure for running a system usage report. The availability for the reports is based on permissions.

**To run a system usage report**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **System Reports** in the left Navigator.
3) Select a report from the log and click **Open** (or double-click the selected report). The query window for the report opens. The query window will differ depending on the report selected.
4) Use the table below to complete the Query fields. You can leave the fields blank to return all records without filtering.
5) Choose a report format. The User Account Details include Programs as a source, and allows you to choose a program name for the report. The options are:
   - **HTML**: Displays the report in the standard format in a browser window. You may print a copy of the report from the browser window. (Click the File menu and select Print or Print Preview.)
   - **CSV**: Formats the report in an exportable CSV format, usually in Microsoft Excel, or other software application you have setup for this format. You will be prompted to save the file or open it.
   - **Excel**: The report displays in Microsoft Excel format in the browser window. You can save an Excel formatted copy of the report or print from the window. (Click the File menu and select Save As or Print.)
   - **PDF**: Opens Adobe Acrobat Reader and displays the report in PDF format. You can save a copy of the report and/or print it from the PDF window. (Click the File menu and select Save or Print.)
   - **XML**: Generates the output in XML format. Before the results are generated, a confirmation window will open, giving you the option to save the XML file to your local machine (click Save), or display the results in a popup browser window (click Open).

6) Click **Run** to run the report. The report results are generated in the format you chose.

<table>
<thead>
<tr>
<th>For this query parameter:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Owner Company</strong></td>
<td>(The field displays the owner company.)</td>
</tr>
</tbody>
</table>
| **Source**               | Select one of the following options to see where users’ time was spent:  
                           | All: All areas of the system  
                           | Company Workspace  
                           | Project: If you select Project, the Project picker is activated.  
                           | Shell: If you select Shell, the Shell picker is activated.  
                           | Other: Other areas of the system that are not part of a project or shell or the company workspace, such as the Asset Manager, Administration Mode, program features, user home page, etc. |
| **Project/Shell**        | If you chose Project/Shell or All as the source, the Project/Shell picker is activated. Click Select to select a specific project. If you do not select a project or shell, the default is all projects or shells. |
| **Partner Company**      | Click Select to select a specific partner, or leave blank to include all partner companies (in addition to the owner company results). |
| **Date Range From**      | Click the calendar icon to enter a start date for the report. If you leave it blank, then the report will start at the company activation date. |
For this query parameter:  | Do this:       
--- | --- 
Date Range To | Click the calendar icon to enter a start date for the report. If you leave it blank, then the report will include results up to the current date. 

System Usage Report Types

The following describes details for running the predefined system usage reports.

Usage Detail By Company

This report allows you to view usage times across a company and all of its partner users grouped by Company /Partner name. This report uses the login time to track usage, and shows usage per day (not per session).

The report results are sorted as follows:

- Company name in alphabetical order.
- For each company, the list of user names: first name, last name
- For each user, lists the source alphabetically
- When source = Project, then project names are listed alphabetically

Report Query Parameters:

- Owner Company: Read-only
- Source: All, Company Workspace, Project/ Shell or Other
- Project/Shell: Select a Project/Shell or leave blank
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name</td>
<td>The name of the company for which the report is being generated. Depending on filter condition, this report can be generated for a particular company or all.</td>
</tr>
<tr>
<td>User Name</td>
<td>The user names that are involved either in Projects or Shells or directly at Company Level.</td>
</tr>
<tr>
<td>User ID</td>
<td>The user ids that are involved either in Projects or Shells or directly at Company Level</td>
</tr>
<tr>
<td>Source</td>
<td>Company Workspace, Project, Shell, or Other</td>
</tr>
<tr>
<td>Name</td>
<td>The names of projects or shells that have users assigned to it either from Company or Partner levels. If user does not participate in any Projects or Shells the Project or Shell Name and number columns is empty.</td>
</tr>
<tr>
<td><strong>This column:</strong></td>
<td><strong>Shows:</strong></td>
</tr>
<tr>
<td>-----------------</td>
<td>------------</td>
</tr>
<tr>
<td>Number</td>
<td>The number that corresponds to the Project or Shell Name</td>
</tr>
<tr>
<td>Date</td>
<td>Date when user signed in to Unifier</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Time taken by User in minutes between sign in and sign out</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Time taken by User in hours between sign in and sign out</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td>Total time taken by all users per company login level and per Company Partner level</td>
</tr>
<tr>
<td><strong>Grand Total</strong></td>
<td>Total time taken by all users at a company level as well as Company Partner level</td>
</tr>
</tbody>
</table>

**Usage Summary By Company**

This report allows you to view summarized usage times across the sponsor company and partner companies. These are usage times logged by users, once they sign in to Unifier, independent of whether they are working for their own company or other companies. The report results are sorted alphabetically by company name.

Report Query Parameters:
- Source: All, Company Workspace, Project/Shell or Other
- Project: Select a project or leave blank for all projects
- Shell: Select a shell or leave blank for all shells
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th><strong>This column:</strong></th>
<th><strong>Shows:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name</td>
<td>The company name. Depending on filter condition, this report can be generated for a particular company or all companies.</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Total Time taken by all Company Users in minutes at &quot;Source&quot; level between sign in and sign out in the specified date ranges</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Total Time taken by all Company Users in hours at &quot;Source&quot; level between sign in and sign out in the specified date ranges</td>
</tr>
</tbody>
</table>

**Usage Detail By Project/Shell**

The Usage Detail By Project/Shell report shows usage details per project or shells across a company and its partners grouped by project or shell name. Results are sorted by:
- Project/Shell names alphabetically for all projects belonging to user company
For each project or shell, lists users belonging to owner company first followed by partner company sorted alphabetically
Within a company, users are sorted alphabetically by first name, last name

Report Query Parameters:
- Source: defaults to Project/Shell
- Project/Shell: Select a Project/Shell or leave blank
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The names of projects or shells that have users assigned to it either from Company or Partner levels.</td>
</tr>
<tr>
<td>Number</td>
<td>The corresponding Project or Shell Numbers.</td>
</tr>
<tr>
<td>Company Name</td>
<td>Name of the owner company. Depending on filter condition, this report can be generated for a particular Sponsoring company. If no users from current company are assigned to the Project, the row will start with Partner name.</td>
</tr>
<tr>
<td>User Name</td>
<td>The user names that are involved in Projects/Shells</td>
</tr>
<tr>
<td>User ID</td>
<td>The user ids that are involved either in Projects/Shells</td>
</tr>
<tr>
<td>Date</td>
<td>Date when user signed in to Unifier</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Time taken by User in minutes between sign in and sign out working on that Project/Shell</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Time taken by User in hours between sign in and sign out working on that Project/Shell</td>
</tr>
<tr>
<td>Total</td>
<td>Total time taken by sponsor company or partner company users for a given project or shell</td>
</tr>
<tr>
<td>Grand Total</td>
<td>Total time taken by sponsor company or partner company users across Projects/Shells.</td>
</tr>
</tbody>
</table>

**Usage Summary By Project/Shell**

This report displays summarized usage times per project or shell across a company and partner users grouped by project name.

Report Query Parameters:
- Source: defaults to Project/Shell
- Project/Shell: Select a Project/Shell or leave blank
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To
This column: | Shows:
---|---
Name | The names of projects or shells that have users assigned to it either from Company or Partner levels
Number | The corresponding Project/Shell Numbers
Company Name | Either the Sponsoring Company Name or Partner Company Name. Distribution across Owner Company and Partner users in a given Project
Usage (Min) | Total Time taken by all Users in minutes between sign in and sign out per Project/Shell
Usage (Hrs) | Total Time taken by all Users in hours between sign in and sign out per Project/Shell
Total | Total time taken by users at a company level as well as Company Partner level for across all company projects or shells

**Usage Detail By Company Workspace**

This report displays usage times for company and partner users working in the owner company’s Company Workspace.

**Report Query Parameters:**
- Source: defaults to Company Workspace
- Project/Shell: Not applicable
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

This column: | Shows:
---|---
Company Name | The company name. Depending on filter condition this report can be generated for a particular Sponsoring company. If no users from current company are assigned to work in the Company Workspace the row will start with Partner name.
User Name | The user names that are involved at Company Level
User ID | The user ids that are involved either at Company Level
Date | Date when user signed in to Unifier
Usage (Min) | Time taken by User in minutes between sign in and sign out working at the Company Workspace
Usage (Hrs) | Time taken by User in hours between sign in and sign out working at the Company Workspace
This column: Shows:

<table>
<thead>
<tr>
<th>Total</th>
<th>Total time taken by users at a company level as well as Company Partner level at Company level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grand Total</td>
<td>Total time taken by users at a company level as well as Company Partner level across Company and its Partners.</td>
</tr>
</tbody>
</table>

**Usage Summary By Company Workspace**

This report summarizes usage times for company and partner users working in the owner company's Company Workspace.

Report Query Parameters:
- Source: defaults to Company Workspace
- Project/Shell: Not applicable
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company</td>
<td>Name of the Sponsoring Company or Partner</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Total Time taken by all Users in minutes between sign in and sign out in Company Workspace per Company/Partner</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Total Time taken by all Users in hours between sign in and sign out in Company Workspace per Company/Partner</td>
</tr>
<tr>
<td>Total</td>
<td>Total time taken by users at a owner company level as well as Company Partner level in the Owner Company Workspace</td>
</tr>
</tbody>
</table>

**Usage Detail By User**

This report details usage across a company and all of its partner users grouped by user name. The results sort by user’s first name and last name independent of whether user belongs to the owner company or a partner company.

Report Query Parameters:
- Source: All, Company Workspace, Project/Shell or Other
- Project/Shell: Select a Project/Shell or leave blank
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To
Unifier Administration Mode

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>The user names that are involved either in Projects or directly at Company Level</td>
</tr>
<tr>
<td>User ID</td>
<td>The user ids that are involved either in Projects or directly at Company Level</td>
</tr>
<tr>
<td>Company Name</td>
<td>Company Name of the User</td>
</tr>
<tr>
<td>Source</td>
<td>Either Company Workspace/Project/ Other</td>
</tr>
<tr>
<td>Name</td>
<td>The names of projects or shells that have users assigned to it either from Company or Partner levels. This column is empty if Source is Company Workspace or Other.</td>
</tr>
<tr>
<td>Number</td>
<td>The corresponding Project/Shell Numbers. This column is empty if Source is Company Workspace or Other.</td>
</tr>
<tr>
<td>Date</td>
<td>Date when user signed in to Unifier</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Time taken by User in minutes between sign in and sign out</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Time taken by User in hours between sign in and sign out</td>
</tr>
<tr>
<td>Total</td>
<td>Total time taken by a particular user at a company level as well as Company Partner level across Source criteria</td>
</tr>
<tr>
<td>Grand Total</td>
<td>Total time taken by all users at a co. level as well as Company Partner level across Source criteria</td>
</tr>
</tbody>
</table>

**Usage Summary By User**

This report displays summarized usage times per user. The report is sorted alphabetically by user first name, last name.

Report Query Parameters:

- Source: All, Company Workspace, Project/Shell or Other
- Project/Shell: Select a Project/Shell or leave blank for all projects or shells
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>All user names for sponsor company and partner companies</td>
</tr>
<tr>
<td>User ID</td>
<td>The corresponding User IDs</td>
</tr>
<tr>
<td>Company Name</td>
<td>Each user’s company</td>
</tr>
<tr>
<td>This column:</td>
<td>Shows:</td>
</tr>
<tr>
<td>-------------</td>
<td>--------</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Total Time taken by a user in minutes between sign in and sign out summed up in the date ranges</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Total Time taken by a User in hours between sign in and sign out summed up in the date ranges</td>
</tr>
</tbody>
</table>

**User Account Details**

This report displays account status details across a company and partners grouped first by Company User Names and then Partner User Names.

**Report Query Parameters:**
- Source: All, Company Workspace, Programs or Projects/Shells
- Source Name: Active if Programs or Projects/Shells is the source. Click Select and select the Program or Project/Shell name from the list.
- Partner Company: Select a partner or leave blank for all partners

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name</td>
<td>The Sponsor Company Name, followed by the Partner Names</td>
</tr>
<tr>
<td>User Name</td>
<td>All user Names from a company and partner users assigned to Sponsoring Company Projects</td>
</tr>
<tr>
<td>User ID</td>
<td>The corresponding User IDs</td>
</tr>
<tr>
<td>Source</td>
<td>The Project/Shell Name the user is a part of</td>
</tr>
<tr>
<td>Source Name</td>
<td>The name of the project or shell</td>
</tr>
<tr>
<td>Date Added</td>
<td>The date that this user was added to the company. This column is empty for Partner users</td>
</tr>
<tr>
<td>User Status</td>
<td>The Status of the User at the project or shell level whether (Active/Inactive)</td>
</tr>
<tr>
<td>Status Effective Date</td>
<td>The date the Status of the user changed at the project Level.</td>
</tr>
</tbody>
</table>

**User Account Summary**

This report summarizes account status details across a company and partners grouped first by Company User Names and then Partner User Names.

**Report Query Parameters:**
- Partner Company: Select a partner or leave blank for all partners
Unifier Administration Mode

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name</td>
<td>The Sponsoring Company or Partner</td>
</tr>
<tr>
<td>Company Short Name</td>
<td>The short name for the Company</td>
</tr>
<tr>
<td>Total Users</td>
<td>Total number of users at Owner Company/Partner working on Owner Company Workspace or Owner Company Projects</td>
</tr>
<tr>
<td>Current Active Users</td>
<td>Total number of active users at Owner Company/Partner working on Owner Company Workspace or Owner Company Projects</td>
</tr>
<tr>
<td>Current Inactive Users</td>
<td>Total number of inactive users at Owner Company/Partner working on Owner Company Workspace or Owner Company Projects</td>
</tr>
<tr>
<td>Current On Hold Users</td>
<td>Total number of inactive users at Owner Company/Partner working on Owner Company Workspace or Owner Company Projects</td>
</tr>
</tbody>
</table>

**User Session Detail**

This report displays user sign in session details.

Report Query Parameters:

- Owner Company
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>All user Names from an Owner Company</td>
</tr>
<tr>
<td>User ID</td>
<td>The corresponding User IDs</td>
</tr>
<tr>
<td>Company Name</td>
<td>The Sponsoring Company or Partner</td>
</tr>
<tr>
<td>Login Date</td>
<td>Date user signed in to Unifier</td>
</tr>
<tr>
<td>Logout Date</td>
<td>Date user signed out. (Dates will displayed in Server Time zone)</td>
</tr>
<tr>
<td>Session End Type</td>
<td>Timeout or Logout</td>
</tr>
<tr>
<td>Usage (Min)</td>
<td>Usage between sign in and sign out in minutes</td>
</tr>
<tr>
<td>Usage (Hrs)</td>
<td>Usage between sign in and sign out in Hours</td>
</tr>
</tbody>
</table>
This column | Shows:
--- | ---
Total | Total time taken

**Last Login**

This report displays last sign in details for a user. It lists the users that have signed in, not all user accounts. If a user has never signed in to Unifier, that user will not be listed on the Last Login Report.

Report Query Parameters:
- Partner Company: Select a partner or leave blank for all partners

<table>
<thead>
<tr>
<th>This column</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>All user Names from an Owner Company</td>
</tr>
<tr>
<td>User ID</td>
<td>The corresponding User IDs</td>
</tr>
<tr>
<td>Company Name</td>
<td>The Sponsoring Company or Partner</td>
</tr>
<tr>
<td>User Status</td>
<td>The status of the user</td>
</tr>
<tr>
<td>Last Login Date</td>
<td>Date when Company User last signed in. For a partner user, this date should be the last date the user signed in to Partner Company Workspace.</td>
</tr>
<tr>
<td>Days Since Last Login</td>
<td>Number of days since the user last signed in. Calculated as difference between last sign in date and the date on which the report is run.</td>
</tr>
</tbody>
</table>

**Current Login**

The Current Login Report displays currently logged in users.

Report Query Parameters:
- Source: All, Company Workspace, Programs or Projects
- Source Name: Active if Programs or Projects is the source. Click Select and select the program or Project name from the list.
- Partner Company: Select a partner or leave blank for all partners

<table>
<thead>
<tr>
<th>This column</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company</td>
<td>Sponsor company</td>
</tr>
<tr>
<td>User Name</td>
<td>All user names from an Owner Company</td>
</tr>
<tr>
<td>User ID</td>
<td>The corresponding User IDs</td>
</tr>
<tr>
<td>Source</td>
<td>The source</td>
</tr>
</tbody>
</table>
### Unifier Administration Mode

#### This column:
<table>
<thead>
<tr>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Name</td>
</tr>
<tr>
<td>Source Number</td>
</tr>
<tr>
<td>Login Time</td>
</tr>
<tr>
<td>Remote Address</td>
</tr>
</tbody>
</table>

### Proxy Login

This report displays user sign in proxy details.

Report Query Parameters:
- Partner Company: Select a partner or leave blank for all partners
- Date Range From
- Date Range To

<table>
<thead>
<tr>
<th>This column:</th>
<th>Shows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Name</td>
<td>The Proxy first name</td>
</tr>
<tr>
<td>Last Name</td>
<td>The Proxy last name</td>
</tr>
<tr>
<td>Login User Name</td>
<td>The user who logged in</td>
</tr>
<tr>
<td>Company Short Name</td>
<td>The Company name of the Proxy user</td>
</tr>
<tr>
<td>Proxy User Name</td>
<td>Then name of the Proxy</td>
</tr>
<tr>
<td>Login Date</td>
<td>The date the user logged in</td>
</tr>
</tbody>
</table>
Adding & Managing Partner Companies

A sponsor company may work with one or many partner companies (for example, subcontractors, vendors, etc.) to work on projects, shells, or company level activities. Company Administrators can manage partner companies and users. The Site administrator will first add the potential partner company to the list of available companies, from which you can select the companies to activate. Partner company users can be granted access to specific company level and project-level or shell-level features.

**Note**: Contact your Site Administrator to add a company to the list of available companies.

To access partner companies

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click the Partner Companies node in the left Navigator. The Partner Companies log opens. The log will display any current partner companies.

Add a partner company

Adding a partner company to the list allows you to work with partner company users within Unifier.

**To add a partner company**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Partner Companies in the left Navigator. The Partner Companies log opens.
3) Click the Add button. The Add Partner Companies window opens, listing available potential partner companies. (This list is maintained by the Site Administrator.)
4) To search for a particular company, click the Find button. The Find box opens at the top of the window. Click the Search By drop down and choose Company Name or Contact Name. Enter the search criteria in the Search for field and click the Search button.
5) Select one or more companies from the list and click the Add button.
6) When the confirmation window opens, click Yes. The company is added to the log. Users from the company are now available to be added to company, project, or shell functions.

Remove a partner company

If you no longer want users in a partner company to participate in your company, project, or shell Unifier areas, you can remove the company from the list. If you remove a partner company:
The partner company users that have been added as users either under your company (Partner Users node) or in any projects or shells will be inactivated automatically.

If the partner company being removed has previously been added to a project or shell as a project or shell "member company," the company will remain in the Member Company log for the project or shell, but users will be inactivated.

These inactivated users cannot be reactivated unless the partner company is added back to Partner Companies node.

To remove a partner company
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Partner Companies in the left Navigator. The Partner Companies log opens.
3) Select a partner company from the list and click Remove.
4) At the confirmation window, click Yes.

View partner company profile

Partner company details are managed by the company administrator for the company, or the Site Administrator. You can view the details.

To view the company profile of a partner company
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Partner Companies in the left Navigator. The Partner Companies log opens.
3) Select a partner company from the list and click Open (or double-click). The Company Profile window opens. The information in this window is read-only, and is maintained by the partner company’s administrator.
4) Click the General tab to view general information, or the Address tab to view address and other contact information for the company.
Configure Project Numbering, Cost Codes, and Status

To configure project numbering, cost codes, and status:

1) Go to the Company Workspace tab and click Configuration > Shell Manager in the left Navigator.

2) Select Projects (Standard) and click the Open button. The Configuration - Projects (Standard) window opens.

3) Complete the General tab as described in the table below.

4) Click Apply to save your changes, or OK to save and exit the window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable automatic numbering</td>
<td>Select to allow automatic numbering of projects based on the specified Format and Start values. You can deselect this checkbox to disable automatic numbering. This checkbox is selected by default.</td>
</tr>
<tr>
<td>Format/Start</td>
<td>Specify the format and starting number for projects if automatic numbering is enabled. Format determines the format of the numbering schema. Start determines the starting number of the numeric schema. By default, Format is blank and Start is 0001. The numbering schema format cannot be changed after a user creates projects using the originally specified format.</td>
</tr>
<tr>
<td>Cost Codes: WBS/Generic</td>
<td>Displays the type of cost code specified in uDesigner for the project. The type available for Projects (Standard) is WBS.</td>
</tr>
<tr>
<td>Status</td>
<td>Status can be Active or Inactive. Users cannot access projects with the status Inactive. The default is Inactive.</td>
</tr>
</tbody>
</table>

In This Section

Create and manage project categories (organize projects)................................. 181

You may create project categories to help organize multiple projects. Project categories have no effect in User Mode and are invisible. Users who are assigned to a project, regardless of the category, will see the project listed in their Projects log.

Once a project has been created under one category, it cannot be moved to another. New projects may be created under the new categories. Once you create a category, you cannot edit or delete it, but you can deactivate it to prevent it from being displayed in the Navigator.
**Tip:** Project Administration permissions can be set based on category. For example, you might create a category called Large Construction Projects, another called Small Construction Projects, and another called Maintenance and Facilities. You can grant project administration permissions to one set of project administrators for the All category, to another group for the construction categories, and to a third group to handle project administration of the maintenance/facilities projects. Once you create a category, you cannot edit or delete it, but you can deactivate it to prevent it from being displayed in the Navigator. Remember to grant permissions to yourself or others to view the new categories and to create/edit projects in the category.

**To create a project category**
1) Go to the **Company Workspace** tab and switch to User mode.
2) In the left Navigator, click **Configuration > Shell Manager**.
3) Select **Projects (Standard)** and click the **Open** button. The Configuration - Projects (Standard) window opens.
4) In the **Organize** tab, click **Add**. The Add Project Category window opens.
5) Type a **name** for the new category. The status for the newly-added category is **Active**:
   - **Active**: projects can be created in the category, which appears in the Navigator
   - **Inactive**: the category will not appear in the Navigator until it is activated
6) Click **OK** to add the category.
7) After all categories have been added, click **OK** to save and exit the Configuration - Projects (Standard) window.

**To rename a project category**
1) In the Configuration - Projects (Standard) window, select a category.
2) Edit the project category **Name** and click **OK**.
3) Click **OK** to close the Configuration - Projects (Standard) window.

**To activate/deactivate a project category**
1) Open the Configuration - Projects (Standard) window and do one of the following:
   - To deactivate an active category, deselect the **Activate** checkbox. Deactivating a category will cause it to not be displayed under Company Sponsored Projects, but this does not affect any projects organized within it. Any projects in a deactivated category are still accessible to administrators under **Administration Mode > Projects**, and to users in User Mode.
   - To activate an inactive category, select the category and select the **Activate** checkbox.
2) Click **OK** to close the Configuration - Projects (Standard) window.

**To grant permission to access the new project category**
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click **User Administration>Users** (to grant permissions to individual users) or **User Administration>Groups** (to grant permissions to a group.)
3) Select a **User** or **Group** from the log and click **Open**.
4) Click the **Permissions** tab.
5) In the upper portion of the window, click **Company Sponsored Projects** (in Administration Access). The bottom portion of the window lists the available categories (default is "All").
6) Select the new categories to which you want the user to have administration access, and click **OK**. The user may already have access to All which allows them to administer (create or edit) projects in the All category.

**Note:** Having "Administer All" permission does not automatically grant administration access to other custom categories. This permission setting allows the user access to the project category only, and does not set specific permissions regarding project administration.

**To access the categories**

New categories appear under the Company Sponsored Projects node in Administration Mode. You may need to refresh the page (reopen the company record, or press the F5 key) before you can see the new categories.
Setting up Multiple Company Calendars

Unifier supports multiple calendars, enabling you to create a library of calendars that can be selected for use at the Company or project/shell levels. The multiple calendars enable you to have calendars to support varying work schedules (depending on locality) and to account for holidays and other non-working days. For example, some countries in the Middle East have weekends that are other than Saturday and Sunday. Unless otherwise specified, the default calendar for a project or shell is the Company calendar that is designated as the default calendar. The calendar selected affects project or shell durations and due dates.

The calendars can be used in project/shell templates, and are automatically applied when the template is updated. Also, users can create activity calendars to use in schedule sheets, specific activities in schedule sheets. Calendars also affect business process task due dates, workflow due dates, and formula calculations.

Step 1: Set permissions for multiple calendars. Grant permissions to allow the configuration of Company-level multiple calendars. See Setting Multiple Calendar Permissions (on page 185).

Step 2: Create and manage calendars (create, copy, modify, delete, set as default). See Creating Multiple Calendars (on page 186) and Modify, delete, or mark a calendar as default (on page 187).

In This Section

Setting Multiple Calendar Permissions ............................................................. 185
Creating Multiple Calendars ........................................................................... 186
Modify, delete, or mark a calendar as default ................................................. 187

Setting Multiple Calendar Permissions

You must have permissions granted to be able to create, modify, or view the calendars.

To set multiple calendar permissions
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click the Access Control node.
3) On the right pane, select Administration Mode Access > Standards & Libraries > Calendars.
4) Set the permissions as needed:
   - Create: Users can create, modify, view, delete, mark as default. These calendars are known as Standard Calendars.
   - Modify: Users can modify and view Standard Calendars.
   - View: Users can view existing Standard Calendars.
Creating Multiple Calendars

You can create Standard Calendars for use in Unifier at the Company level, project/shell level, activity, and business processes. There is a default Company Calendar available in Unifier. This calendar is marked as the default calendar, but you can change the default calendar to the Standard Calendar you create.

You can also copy an existing calendar and modify it to create a new calendar.

You must have Create permission to be able to create Standard Calendars.

To create Standard Calendars

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window opens.
3) Click New. The Calendar Properties window opens.
4) Enter the calendar name and an optional description.
5) Specify the working and non-working days for the calendar you are creating. Browse to the month and year using the pull-down menus at the top of the calendar. Saturdays and Sundays are set as non-working days by default. Do one of the following:
   - To set a particular date as a non-working day (for example, a holiday), click the date on the calendar and select Non Working. The date will appear grayed out, and will not be used in date calculations.
   - To set a non-working day as a working day, click a grayed cell and select Working.
   - To set a particular day of the week (for example, every Saturday) as a non-working day, click the day at the top of the calendar (for example "Sat"), then click Non Working. All Saturdays in the calendar will be changed to non-working days (gray).
   - To set a particular day of the week as a working day, click the day at the top of the calendar, then click Working.
   - If you only want to set the day of the week in a particular month as working or non-working days, select each day individually and click Working or Non Working.

   **Note:** If you have marked the day of the week as a non-working day throughout the calendar by selecting the day at the top of the calendar (for example "Sat"), then you will not be able to mark individual days (that is, individual Saturdays in this example) as working days. To be able to include both working and non-working instances of a day of the week on the calendar, you must select them individually.

6) Click OK.

To copy existing calendars

1) Go to the Company Workspace tab and click Standards & Libraries > Calendars in the left Navigator. The Calendars log window opens.
2) Select a calendar in the log.
3) Click Copy. The Calendar Properties window opens with the calendar description and calendars days specified.
4) Enter the calendar name and change the optional description as needed.
5) Modify the working and non-working days that are specific to the new calendar you are creating. Select the calendar day and click the Working or Non Working radio buttons as needed.
6) Click OK.

Modify, delete, or mark a calendar as default

You can modify or delete calendars, and mark a calendar as the default.

You can modify Standard Calendars if you have Modify permission. You can delete Standard Calendars if you have Create permission. If a calendar is in use projects/shells, schedule sheets, or schedule sheet activities, you are asked to replace the calendar you delete with another calendar.

You can also specify a default Standard Calendar if you have Create permission. Unless otherwise specified, the default calendar for a project or shell is the Company calendar that is designated as the default calendar. The calendar selected affects project or shell durations and due dates.

To modify a calendar
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window opens.
3) Click Open. The Calendar Properties window opens.
4) Modify the calendar name and change the optional description as needed.
5) Modify the working and non-working days that are specific to the new calendar you are creating. Select the calendar day and click the Working or Non Working radio buttons as needed.
6) Click OK.

To delete a calendar
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window opens.
3) Select one or more calendars in the log.
4) Click Delete. If a calendar is not in use, it is deleted. If a calendar is in use, the Select a Calendar to replace window displays. Select an alternate calendar and click OK.

Note: You cannot delete calendars that are used by view-only projects or shells.

To specify a default calendar
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window opens.
3) Select a calendar in the log.
4) Click Default.
Manage Support and e-Learning contact information (Contact tab)

In the Contact tab of the Edit Company window, you can provide your users with an email address and/or phone number of your internal support staff. This information will be displayed in error messages users may encounter if their accounts become locked, on the Support window Contact tab, and at the bottom of email notifications. The information included for email notification can contain a hyperlink to your local support. For information about translating Email Notifications, see the *Internationalization (Email Notifications)* section.

In addition, if your company is part of the eLearning suite of interactive tutorials, you can provide access information to your users in this tab. This space can also be used for any location (such as an internal website) where you have provided Unifier training materials.

To manage user support contact information

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the right pane, click the Open button. The Edit Company window opens.
3) Open the Edit Company window and click the Contact tab.
4) Under Support Contact Info and eLearning Access, you can add or modify the contact information as needed. See the following table for details.
5) Click Apply to save changes, or OK to save and exit the Edit Company window.

<table>
<thead>
<tr>
<th>To complete this section:</th>
<th>Enter this information:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Support Contact Info</td>
<td>Email: Email address for company internal support. Phone: Phone number for company internal support. Instructions: Information that appears in the Support window Contact tab, as well as the Email and Phone from above. This provides information to your users on how the use the support information. Email Notifications: Information that appears at the bottom of email notifications. This field supports simple html formatting, and can include a hyperlink. For example: <code>&lt;p&gt;For YourCompany support, contact &lt;a href=&quot;mailto:support@yourcompany.com&quot;&gt;support@yourcompany.com&lt;/a&gt; or 1-800-555-1212. &lt;/p&gt;</code> which will display in the bottom of record email notifications as: For YourCompany support, contact support@yourcompany or 1-800-555-1212.</td>
</tr>
<tr>
<td>eLearning Access</td>
<td>URL: Enter the URL for eLearning access. It is best to include the entire address. Label: This is the label for the URL above. The label can display the actual URL, or you can a different label. This will</td>
</tr>
</tbody>
</table>
| appear as a hyperlink to users.  
| Contact email: Enter an email address that you would like users to use if they need to contact someone. Enter a valid email format, e.g., elearn@yourcompany.com.  
| Instructions: You can enter instructions or other information such as a contact phone number. This field does not support html formatting.  |
Manage company password policy (Security tab)

Sponsor company administrators can specify password security policies in the Security tab of the Edit Company window. By default, the minimum password requirement is set at one (1) character, meaning that the user is required to create a password with a minimum of one character. If a value is not entered in a field, the option is ignored.

**Note:** These settings apply to Sponsor/Owner company users only. They will not apply to Partner Company users, where the default settings apply.

**Note:** If your company is using Oracle Identity Management (OIM) to provision your company users, the password policy specified on this tab will not be used. OIM has its own password policy which will supersede the policy on this Security tab.

To manage user password criteria

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the right pane, click the Open button. The Edit Company window opens.
3) Open the Edit Company window and click the Security tab.

4) Select the password criteria that you want to configure, then enter the value in the text box. See the following table for details on each option.

5) Click Apply to save changes, or OK to save and exit the Edit Company window.

<table>
<thead>
<tr>
<th>Select this option:</th>
<th>To specify:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum overall character(s)</td>
<td>Minimum number of characters that a password must contain; default is one (1)</td>
</tr>
<tr>
<td>Maximum overall character(s)</td>
<td>Maximum number of characters that a password must contain</td>
</tr>
<tr>
<td>Minimum numeric character(s)</td>
<td>Password must contain a minimum amount of numbers</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Minimum alphabetic character(s)</td>
<td>Password must contain a minimum amount of letters</td>
</tr>
<tr>
<td>Minimum special character(s)</td>
<td>Special characters are <code>!@#$%^&amp;*()-_=+;:'&quot;,&lt;.&gt;/?]</code></td>
</tr>
<tr>
<td>Password cannot be same as user name</td>
<td>Users cannot use their user name as their password</td>
</tr>
<tr>
<td>Password cannot be same as first or last name</td>
<td>Users cannot use their name as their password</td>
</tr>
<tr>
<td>Password cannot be same as last</td>
<td>A newly changed password must be different from previously used ones (indicated the number here)</td>
</tr>
<tr>
<td>Password expiration</td>
<td>If password expires, users will be prompted to change it when attempting to log on</td>
</tr>
<tr>
<td>Inform user before expiration</td>
<td>Upon signing in, users are warned that their passwords are about to expire and given the option of changing it</td>
</tr>
<tr>
<td>Maximum login attempts</td>
<td>If user does not successfully log on after this number of attempts, the account will become locked</td>
</tr>
<tr>
<td>Suspend inactive user after</td>
<td>Sets the number of days of inactivity before a user’s account is locked</td>
</tr>
</tbody>
</table>
Manage company addresses (Address tab)

At a minimum, a Headquarters address must be entered in the Edit Company window. The Headquarters address will be the default company address. The default address displays on the Company Home Page, and is used to generate an online company location map. You can add up to six additional company addresses.

To manage company addresses
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the right pane, click the Open button. The Edit Company window opens.
3) Click the Address tab.
4) Complete all fields marked as mandatory (red asterisk *). To enter additional addresses, click Address Type and choose another address to enter. See the table below for details.
5) Click Apply to save changes, or OK to save and close the Edit Company window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address Type</td>
<td>Click the field and select from the drop-down list. At a minimum, an address for Headquarters is required, which is used as the default company address in Unifier. You can enter up to seven company addresses (for example, billing).</td>
</tr>
<tr>
<td>Attention</td>
<td>Click the Select button and select a user from the picker.</td>
</tr>
<tr>
<td>Address and phone fields</td>
<td>These are text fields. No validation will be performed on these fields. All fields with a red asterisk are required. Select the Country/Region from the drop-down list.</td>
</tr>
</tbody>
</table>
Access Company Details

Company detail information is managed in the Edit Company window.

To access the Edit Company window
1) Go to the Company Workspace tab and switch to Administration Mode.
2) In the right pane, click the Open button. The Edit Company window opens.

The Edit Company window has the following tabs:
- **General**: In this tab, you can manage several company features. See the table below for details. The fields with red asterisks are required.
- **Address**: You can enter up to seven company addresses. There must be at least one address entered for the company headquarters.
- **Security**: In this tab, you can manage the password policy that your users must follow when signed in to Unifier.
  
  **Note**: If your company is using Oracle Identity Management (OIM) to provision your company users, the password policy specified on this tab will not be used. OIM has its own password policy which will supersede the policy on this tab.
- **Contact**: Maintains support contact and e-Learning access information for your users. The information entered here appears in the Support window (Contact tab). To access the Support window, click Help, from the upper right-corner of the Unifier window, and select Contact Support from the menu.

To complete the General tab

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a company name, up to 64 characters. It can include alphanumeric</td>
</tr>
<tr>
<td></td>
<td>characters, spaces and punctuation.</td>
</tr>
<tr>
<td>Short Name</td>
<td>Enter a one-word short name, up to eight characters. The Short Name is a</td>
</tr>
<tr>
<td></td>
<td>unique, one-word abbreviated form of your company name, and is used</td>
</tr>
<tr>
<td></td>
<td>throughout Unifier in place of the company name. (For example, uDesigner-</td>
</tr>
<tr>
<td></td>
<td>created business processes and on logs that identify partner companies.)</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a company description. This is displayed on the Administration Mode</td>
</tr>
<tr>
<td></td>
<td>home page. This can be especially useful for identifying partner</td>
</tr>
<tr>
<td></td>
<td>companies, such as subcontractors or vendors.</td>
</tr>
<tr>
<td>Contact Name</td>
<td>Click Select, then select a user from the User/Group picker. This name</td>
</tr>
<tr>
<td></td>
<td>is displayed on the Company Home Page in Administration and User Modes.</td>
</tr>
<tr>
<td></td>
<td>The list is generated from the list of active users in the Company Users</td>
</tr>
<tr>
<td><strong>Help URL</strong></td>
<td>Enter an additional URL that points to internal documentation regarding company policies or practices, an intranet site, or other internal information that you choose. This is displayed on the Company Home Page as a hyperlink.</td>
</tr>
<tr>
<td><strong>Company Logo</strong></td>
<td>Customize Unifier by uploading your company logo. To upload a logo, click the Add button and choose the logo from the file menu. The image must be in <code>jpg</code>, <code>jpeg</code>, <code>gif</code>, or <code>png</code> format. To remove an existing logo, click the Remove button. The logo area supports a maximum size of 145 x 40px, images that are larger will be proportionally scaled until the image fits within the maximum size. Images that are smaller than the maximum will be centered in the logo area and will not be scaled.</td>
</tr>
<tr>
<td><strong>Status</strong></td>
<td>Company status is controlled by the Site Administrator.</td>
</tr>
<tr>
<td><strong>Authentication Key/Re-Enter Authentication Key</strong></td>
<td>Enter a unique key used when data is integrated with Unifier from external systems via Web Services. This is not the same as the uDesigner Authentication Key. The current key is stored in an encrypted format and can be changed as needed. If a key has already been assigned to the company, it will not be displayed in the field; the field will appear blank. Re-enter the key in the following field to confirm it.</td>
</tr>
<tr>
<td><strong>Bid Access URL</strong></td>
<td>Used with Request for Bid (RFB) feature. This is the URL that will be used by bidders to access bids (system-assigned). <strong>Note:</strong> When the bidder is notified of a new bid record for the first time, Unifier sends out an email notification with the same login credentials that the bidder has used. To prevent access disruption, Oracle recommends that the bidder first reset password through OIM, and then sign in to Unifier using the newly set password.</td>
</tr>
<tr>
<td><strong>Bid Management Account</strong></td>
<td>Enter the account name of the user who will be managing the bids that your company receives. This is the account that will contain the bidder’s preferences you specify when you create the bid management account. See the instructions under &quot;Set Up a Bid Management Account in Primavera Unifier&quot; in the Primavera Unifier Administration Help.</td>
</tr>
<tr>
<td><strong>Owner</strong></td>
<td>This checkbox allows a company to sponsor projects or shells, and is controlled by the Site Administrator. The checkbox will not be selected if the company is a partner company that is not authorized to sponsor projects or shells.</td>
</tr>
</tbody>
</table>
Production Bundles

About Bundles

There are two types of bundles in Unifier:

- **Design Bundle**
  You can use the Design Bundle to transfer your designs between the Staging environments. This includes the designs defined in the uDesigner node, only.

- **Production Bundle**
  You can use the Production Bundle to transfer your designs, related configuration, and setup information between Staging, pre-Production, and Production environments.
  The Production Bundle enables the test-complete designs, and setups, to be transferred from Staging environment to the Production environment. The Production Bundle includes:
    - The design bundle and all the other optional bundles that you select at the time of export.
  Upon successful creation of the Production bundle, and after the Production bundle has been published, the system stamps the last published date and applies changes to design and setup.

The **Design Bundles** node (Company Workspace > Admin mode > uDesigner > Design Bundles) allows you to create the Staging Design Bundles. From the toolbar of the Design Bundles log you can select the following options:

- **Import**
- **Export Staging Bundle**
  Use this option to export your design.
- **Error Check Staging Bundle**
  Use this option to check for errors.
- **Download**
- **Delete**
  Use this option to delete the bundles that you no longer need.
- **Find**
  Use this option to search for a specific bundle in the log.

The Tag option (in the Designer toolbar), allow you to tag a design for Staging environment or Production environment. You can use the Clear option to remove an existing tag. Refer to the `Unifier uDesigner User Guide` (Design Bundle) for details.

The **Production Bundles** node (Company Workspace > Admin mode > Production Bundles) allows you to create Production bundles.

All existing Production Bundles are listed in the Production Bundles log. The bundles are stamped with Published By and Published Date, User name, and the date that the bundle was created. See the following "Production Bundles Log" topic for more details.
Note: Once the Status of a form is "Complete," and you have completed testing the form in the Primavera Unifier Staging environment, you can bundle your design, or multiple designs, for importing into the Primavera Unifier Production environment.

Changing Bundle Content in the Production Environment

The components included in the bundle will either create new components in Production or will update the existing ones. You can change the content of the bundle in the Production environment, manually. All the updates will apply at the time of import, based on the names or IDs that are unique for each component.

In This Section

Accessing Production Bundles Node ................................................................. 198
Production Bundles Log ...................................................................................... 198
Creating Production Bundles ............................................................................ 200
Additional Setup Options .................................................................................. 202
Importing Production Bundles .......................................................................... 209

Accessing Production Bundles Node

Access to the Production Bundles node is controlled by permissions. Granting permissions to the Production Bundles node is similar to granting permissions to the Design Bundles node, under uDesigner.

To grant permissions to the Production Bundles node, go to Access Control and select Production Bundles (Company Workspace > Admin mode > Access Control > Production Bundles).

Selecting Enable (from the Permission Settings:) allows you to grant permissions to both Users and groups. Users are able too view the contents of this node.

Production Bundles Log

The Production Bundles log contains the following toolbar options:

Note: The toolbar options can be accessed by the menu toolbar, also.

- New
- Import
- User Mapping
- Bundle Content
- Download
  Use this option to download the bundle .zip file. You can download an export bundle, save the file on your computer local-drive, and later use the file to import it into a different environment.
- Delete
  Use this option to delete the bundles that you no longer need.
Find
Publish

Note: The Publish option allows you to perform the final step in the Production Bundle creation. This option allows you to select a bundle and Publish it. After successful Publish, this bundle can be imported into a Production environment.

The Production Bundles log contains the following columns:
- Date
- Type
- File Name
- Version
- Description
- Status
- User Name
- Published Date
- Published By

User Mapping

Many Unifier modules have user information as a part of setup information. When you create an Export Production bundle, the user information is included in the bundle; however, when you export, the user information will not be created in the Production and the import process will fail. To prevent this, you can map the Staging environment users to a user in the Production environment. As a result, you must map the user after you create the bundle. Use the User Mapping window to set up the user mapping and follow these steps:

Select the bundle before launching the User Mapping window.

Note: The list of users displayed are based on the bundle content and the users in one bundle might be different in the other bundle.

Proceed with mapping base on the Login User Name.

Notes:
- The names that you enter in the Destination Login Name field (Production) must exist in the destination environment. The system does not check the names at the time of export, and you must validate the user names at the time of import.
- If no user exists by that name, the import will fail.
- The Login User Name is a text field and the system will validate the character length against the existing character length limit for the field.
The user mapping that you set at this point applies to the particular bundle that you are working with, so after you click OK in the User Mapping window, the user mapping setup will be a part of the bundle, and you can see the user mapping information in the Bundle Content window, for successful bundles.

- The user mapping option will not be available (disabled) if you publish a bundle to Production.
- You cannot map a two-source user to the same destination user.

Generating Design Bundle Report
You can generate a PDF report in order to view the Design Bundle contents in a report format.

Audit Log
After you import a Production bundle, all included modules that support auditing will continue to do so. The following lists the specifics:

- Auditing is done post import and in the destination environment.
- New attributes are not added to the Audit log.
- The Date displayed is the Import Bundle Date.
- The User Name is the user who last imported the Production Bundle.

Creating Production Bundles
The Production Bundle includes all dependency and reference checks at the time of export.

For designs that have several setups and configurations, for example Business Processes, you can:

- Include the setups and configurations in your design (in the Staging environment)
- Create a bundle zip file
- Import the bundle zip file to the Production environment for use

When creating a new Production Bundle in the Staging environment, you have the option to include the following configurations, and other setups, in the bundle and transfer the bundle to the Production environment:

- Design Bundle Content
  - uDesigner Designs
  - Custom Reports
  - Data Cubes

Go to Production Bundles node and click New from the log (Company Workspace > Admin mode > Production Bundles > New). The New option can be used in the Staging environment or the pre-Production environment.

Notes:
You can use a Production bundle that has been published in the Production environment. If you want to conduct tests (pre-Production or Staging environment), then you can use a non-published Production bundle.

If you have multi-server environment (Staging, pre-Production, and Production), the pre-Production bundle enables you to take the designs and setups to the pre-Production environment.

The pre-Production bundle has the same contents as the Production bundle.

A pre-Production server must have the Staging server setup, in the Unifier Configurator.

In the Create New Bundle window, enter a name and description in the File Name and Description fields. Select the desired Additional Setup Options and click OK when finished. See the following "Additional Setup Options" topic for details.

- Data Structure (including Data Definitions, Dynamic Data Sets, Cost Codes)
- Configuration Only
- Shell Templates
- Company Workspace
- Single Instance Shells

**Note:** Configuration Setup for Shells and Business Processes designs will be included for Shell Templates, Company Workspace, and Single Instance Shells options.

When you click OK, the system triggers a job which will create the Production bundle. Validations will be performed to check for various dependencies and completeness of the Production bundle.

- Creates the file in the log.
- Checks all dependencies and references at the time of the bundle.
- Displays one of the following under the Status column:
  - In Progress: If the job is still in progress.
  - Failed: If the job has failed.
  - Error: If the job has completed, but the generated .zip file contains errors.

**Note:** If the .zip file contains errors, you cannot publish the bundle for Production, and the Download option is disabled.

- Success: If the job has completed, and the generated .zip file does not contain errors. If the status displays Success, the .zip file can be used in Staging environment or pre-Production environment.

Creating a bundle does not publish the designs, and setups, to Production; therefore, you can make modifications to the designs, and setups. Upon a successful creation of the bundle, the system stamps the Last Bundled Date. The Last Bundled Date contains the time stamp.
When an export bundle is created, the count for each component will be seen based on the current “Tag” status for each item. So the count might vary between Version 1 and Version 2 of export bundles.

**Additional Setup Options**

The Design Bundle forms the basis for Design Setup Bundle creation, and the contents of the Design Bundle, as explained in the Design Bundle section of the Unifier uDesigner User Guide, are included in the bundle.

When you select additional setup options from Additional Setup Options section of the Create New Bundle window, all the components associated with the options that you have selected will be included in the bundle. As a result, you cannot pick and choose the individual components of the options that you have selected.

**Example**

If you select Shell Templates option, then all the items mentioned in the Shell Template bundle will be included. So, if there are any changes to the BP setup in a Shell Template, and this needs to be included in the bundle, then the option of Shell Templates, and related configuration, is selected.

If a component is tagged, unless the additional option associated with the component is checked, the component cannot be exported.

**Example**

You may tag a Shell Template called Buildings TP-1, if you do not select the Shell Templates option from Additional Setup Options section of the Create New Bundle window, then you cannot export the template Buildings TP-1.

The following is a list of the options available under Additional Setup Options section of the Create New Bundle window:

- Data Structure, including Data Definitions, Dynamic Data Sets, and Cost Codes
- Configuration Only
- Shell Templates
- Company Workspace
- Single Instance Shells

**Note:** Configuration Setup for Shells and Business Processes designs will be included for Shell Template, Company Workspace, and Single Instance Shells options.

The following explains each of the options available under Additional Setup Options section in detail:

**Data Structure, including Data Definitions, Dynamic Data Sets, and Cost Codes**

Data Definition (DD) and Dynamic Data Sets (DDS) are determined by the designs in the Design Bundle. Since the Cost Codes are not related to any design, then all Cost Codes defined at the Company-level are included in the Design Bundle. This is the list of the contents that are included in the Design Bundle from this category:
Data Definitions for Data Elements
- Default values (values for all Data Definitions, data type "String, Integer, and Float")
- Value/Label datasets, where applicable (values from Integer and String pull-downs, Radio Buttons, Multi-Select and they include values and corresponding labels, Status for each value, and default values)
- Dynamic Data Sets (DDS)
  DDS setup information (Master Data Element, Behavior Set and Value Set)

**Note:** Although the design bundles include the DDS added to the forms in the designs, the configuration of the DDS is not included.

Cost Codes
- All Cost Codes defined under Data Structure Setup and "Used=Yes".

**Important Note:** While creating your Production Bundle, if you select the option of Data Structure (which includes Data Definitions, Dynamic Data Sets, and Cost Codes) and import, the data set information existing in your Production Bundle replaces the data set information in the destination server, completely.

Configuration Only
Select this option when you want to transfer the configuration setup for all of the designs that are included in the Design Bundle between the environments (Staging, pre-Production, and Production). This is a list of the contents that are included in the Design Bundle from this category:

- Business Processes
  - General tab Setup information
  - Workflow tab Setup information
  - Custom Print tab Setup information
  - Query tab
  See the Business Processes Production Bundle Configuration section in this guide.

- Asset Manager
  - General tab Setup information
  - Custom Print tab Setup information
  See the Asset Manager Production Bundle Configuration section in this guide.

- Planning Manager
  - General tab Setup information
  - Custom Print tab Setup information
  - Default Structure information
  See the Planning Manager Production Bundle Configuration section in this guide.

- Portfolio Manager
  - General tab Setup information
  - Query tab Setup information
See the Portfolio Manager Production Bundle Configuration section in this guide.

- Resource Manager
  - General tab Setup information
See the Resource Manager Production Bundle Configuration section in this guide.

- Shell Manager
  - General tab Setup information
  - Organize tab Setup information
See the Shell Manager Production Bundle Configuration section in this guide.

- Space Manager
  - General tab Setup information
  - Custom Print tab Setup information
  - Options tab Setup information
See the Space Manager Production Bundle Configuration section in this guide.

Shell Templates

- Shell Templates
  - Tagged Shell Template
  - Associated configuration

- Business Processes Setup for Single Shell Instances and Multiple Shell Instances
  - Overall BP Setup
  - Workflow Setup
  - User Attribute form (if there are any filtering for Additional assignees)
  - Configuration Bundle
    - Configuration setup for designs that are included in the Template and are part of the Design Bundle, only.

- User-Defined Reports (UDRs)
  - All UDRs tagged in the selected Shell Template
  - Data View
    - Data View associated with the UDR.

- Single Record Business Process (BP)
  - The record instance existing in the Template, if the Design Bundle includes Single Record BP.

- Users and Groups
  - Users and Groups setup for Business Process (BP) setup, Reports, and Single Record BP.

- Access Control
  - Administration mode and User mode permissions for all the nodes in the Shell Template, including:
    - All Design objects permissions such as Business Processes (BPs), Managers, and so forth.
    - System-provided modules.
The following explains the Shell Templates option in detail.

Select the **Shell Templates** option for bundling and transferring the contents of Shell Templates across environments. The system includes the following configurations in the Design Bundle from this category:

- **All Shell Templates tagged for Production**
  
  **Note:** The number within the parenthesis informs you about the total count of Shell Templates that have been tagged for Production.

- **Content of the Shell Template**
- **Configuration of selected Shells and Business Processes (BPs)**

You can bundle the Shell Templates that exist in the Staging environment and transfer your bundle to the Production environment. Your bundle will include the Shell details data (data from all tabs in the Shell setup). In addition:

- The currency, defined in the Currency tab, is included as a part of the bundle. If the selected currency does not exist, then the system creates one in the destination environment. The currency attributes such as Code, Name, Symbol, and so forth cannot be updated by means of bundle import. The Currency tab content is update upon every import. If the exchange rates defined for currencies in the tagged source Shell Template do not exist in the destination environment, then the system creates a new exchange rate record for that currency and that exchange rate will be set to Active, and:
  - The Effective is set to the Bundle Import Date.
  - The Peg rate is brought over from the source environment.
  - The Float rate is brought over from the source environment, if the rate does not exist in the destination environment.

- The calendar, from the Calendar tab, is included as a part of the bundle. If the selected calendar does not exist, then the system creates one in the destination environment.

- All multi-instance Shell Templates have the Tag and Last Bundled Date options. Once you tag a Shell record, the record will be included in the Shell Template bundle and upon successful creation of the bundle, the system stamps the Shell Template with the Last Bundled Date. You can remove a tag (Clear) to exclude the record.

  **Note:** The log of the Shell is user-defined. The columns and the Tag option are not available in the Shell Instances.

- The following Shell details in the form will be exported and imported in the destination environment upon every import:
  - Text fields, Pull downs (Integer and String), Radio buttons, check boxes, Integer, Decimal and Currency Amounts and Dates.

  **Note:** Any picker that refers to some other design object like BP pickers, data pickers, and so forth will not be included.

- The contents of the Organize tab (Shell configuration), which defines the Shell hierarchy, will be included. This includes the defined sub-Shells.
Notes:

- Shells cannot be created if they do not activate them in the Configuration module.
- The export bundle operation will fail if:
  - The design of the tagged Shell is not included in the Design Bundle.
  - The Shell design version that is included in the Design Bundle does not match the deployed Shell design version.

Business Processes

- A Shell Template can have several Business Processes in the Staging environment. Only those Business Processes that have been tagged for Production, in uDesigner, can be included in the Production Bundle.
- The configuration bundle can contain Workflows that have been setup (activated in Configuration module). If there are multiple Workflow setups in a Business Process, then all the setups are included in the bundle, regardless of the status.
- Business Processes, and other design objects, in a template depend on their setups in the Configuration module. Only the configuration setups of the Business Processes, and the Shell that the Business Process resides in, are included in the template can be a part of the bundle.
- In Workflow setups, where additional filtering on assignees exist for steps, the published design for user attribute form in the Design Bundle must include the deployed design.

User-Defined Reports (UDRs)

- You can transfer User-Defined Reports (UDRs) that have been tagged in a Shell Template (Company Workspace > Admin mode > Templates > Shells) from Staging environment to Production environment. The data source for the reports can be a uDesigner design, a Data View, or a system-provided source.
- Use the Tag option of the User-Defined Reports log in a Shell Template (Company Workspace > Admin mode > Templates > Shells > Shell > Reports > User-Defined) to tag a report for Production. The Last Bundled Date displays the date that the Production Export bundle was included in the report.

Single Record Business Process (BP)

The data from the Single Record BP gets exported from the source environment and then gets imported into the destination environment. This includes: Text fields, Pull downs (Integer and String), Radio buttons, check boxes, Integer, Decimal and Currency Amounts and Dates.

The following data/items are not included in the Design Bundle:

- Any picker that refers to some other design object like BP pickers or data pickers
- Attachments, linked records, and general comments

Groups and Users

- Only users and groups who are relevant to the contents of the Design Bundle are included:
  - All users and groups setup in the Business Process and Workflow.
  - All users and groups included in the tagged User-Defined Reports.
  - All users and groups included in the Shell Template > Access Control pertaining to the Business Process.
Unifier Administration Mode

- All users and groups included in the Shell Template > Access Control for tagged User-Defined Reports.
- All users and groups included in the Shell Template > Access Control for tagged Custom BIP Reports.
- All users and groups included in the Shell Template > Access Control (Admin mode) > Templates > Shells ><Tagged Shell type>

Access Control

- For both Admin and User modes: The permissions for the Design objects.
  
  Example
  
  If an Action Items BP has been tagged in uDesigner (and has been included in the bundle), then the Setup Permissions for the Action Items are included in the Design Bundle.

The following are the Design objects that are included in the Design Bundle:

- Projects (Standards)/Shell Properties, Member Companies, User Administration, Dashboards, and Gates
- For User mode, the following system-provided modules are included in the Design Bundle:
  - Non-navigational Nodes, uMail, Mailbox, Information, Gates
- Design objects that are not included in the Design Bundle:
  - System-provided modules: Planning Manger and Resource Manager
  - For User mode: Generic Cost Manager, Cost Manager, Document Manager, and Resource Manager

Notes:

- If you tag a Custom BIP Report for Production, but you do not tag the Shell Template, the report will be included in the Design Bundle; however, the Access Control permissions will not be set for the report, and you will not be able to see the report under the Custom Reports, in Admin mode.
- The permissions for Data Cubes that exist in the Data Cubes module (User mode > Non-navigation Nodes > Data Cubes) will be included in the Shell Template bundle; however, the permissions for the tagged Data Cubes are bundled, only.

Company Workspace

Select this option in order to transfer the content of the Company Workspace from one environment to another. For more information, see the following details:

- Business Processes Setup for Single Shell Instances and Multiple Shell Instances
  - Overall BP Setup
  - Workflow Setup
  - User Attribute form (if there are any filtering for Additional assignees)
  - Configuration Bundle
    Configuration setup for designs that are included in the Template and are part of the Design Bundle, only.
User-Defined Reports (UDRs)
- All UDRs tagged in the User mode
- Data View
  Data View associated with the UDR.

Users and Groups
- Users and Groups setup for Business Process (BP) setup and Reports.

Access Control
  Administration mode permissions for designs included in the Design Bundle and setup, in Company Workspace.

The following explains the Company Workspace option in details.

The Business Processes that are included in the Design Bundle can be at Company level, and setups for the designs, in the Design Bundle, will be included as a part of the Company Workspace bundle.

The system includes the following configurations in the Design Bundle from this category:
- User-Defined Reports (UDRs)
- Single Record Business Process
- Groups and Users
- Access Control
- Permissions (Admin mode)

Single Instance Shells
Select this option in order to transfer the content of Single Instance Shells from one environment to another. This is a list of the contents that are included in the Design Bundle from this category:
- All Single Instance Shells tagged for Production

  Note: The number within the parenthesis informs you about the total count of Single Instance Shells that have been tagged for Production.

For more information, see the following details:
- Configuration of the design setup
- Business Processes Setup for Single Shell Instances and Multiple Shell Instances
  - Overall BP Setup
  - Workflow Setup
  - User Attribute form (if there are any filtering for Additional assignees)
  - Configuration Bundle
    Configuration setup for designs setup in the Shell Instance and included in the Design Bundle, only.

User-Defined Reports (UDRs)
- All UDRs tagged in the User mode of Shell Instance
- Data View
  Data View associated with the UDR.
Unifier Administration Mode

- Single Record Business Process
- Users and Groups
  - Users and Groups setup for Business Process (BP) setup and Reports.
- Access Control
  - Administration mode permissions for designs included in the Design Bundle and existing in the Shell Instance setup.
- Permissions (Admin mode)
- System Modules
  - Project (Standards), Shell Properties, and Member Companies are not included.

For more information, see the Bundling Single Instance Shells in this guide.

**Importing Production Bundles**

You can import the bundles from the source environment into the destination environment by way of Import. The import bundle process is similar to the export bundle process. The following explains the details:

- An import is done when you click **Import** on the log.
- The zip file that is being imported must be valid for the Production environment.

  **Note:** In the Staging environment the Production Bundle that contained the zip file must have been successfully Published.

- The File Status field shows the status of the import process.
- The Bundle Content details window displays the content of the imported bundle.
- The Bundle Content Errors window or Warning window displays the errors or warnings specific to the import process.
Custom Dashboards

Custom dashboards present data in a graphical format. Using data mined from data views and data cubes, you can create custom dashboards that provide an accurate and dynamic view of company and project performance indicators. You can have multiple custom dashboards in Unifier.

**Note:** Before you begin creating a company or shell custom dashboard, ensure your company has enabled custom dashboards. Consult with your site administrator for details.

**In This Section**

Creating Company or Shell Custom Dashboards ................................................... 211
Granting Custom Dashboard Permissions ............................................................. 211
Configuring a Shell Dashboard .............................................................................. 215
Modifying a custom dashboard .............................................................................. 217

**Creating Company or Shell Custom Dashboards**

You cannot create **Company** or **Shell** SWF-based (small web format) custom dashboards.

**Note:** Existing custom dashboards can be modified.

The SWF file should be configured to point to a data cube in Unifier. You can only use **Company Data Cubes** with **Company Dashboards** and **Shell Data Cubes** with **Shell Dashboards** (See the "Data Cubes" topic).

When you create the SWF file, be sure to include a URL that includes the custom dashboard name. This will ensure there is a link between the SWF file and the custom dashboard’s data cubes, and that the custom dashboard data will refresh when the data changes.

Users can print the custom dashboard if the print capability is resident in the imported SWF file used to display the dashboard.

**Granting Custom Dashboard Permissions**

Ensure you have permission to create company and shell dashboards. These two types of dashboards use the same Module Permission Settings for Company Dashboard and Shell Dashboard.

- **To grant Custom Dashboard permissions**
  1) Navigate to the **Company Workspace** tab and switch to Administration Mode.
  2) In the left Navigator, select the **Access Control** node. The Access Control log opens and lists all available functions in Unifier.

4) Click the Add button. Another Permission Settings for: Workspace window opens.

   In the Select Users/Groups pane:
   a. Click the Add Users/Groups button. The User/Group Picker window opens.
   b. Select users and/or groups and click the Add button. The user or group name appears in the Selected Users/Group pane.
   c. Click the OK button.

   In the Permission Settings: pane, located in the bottom section of the window, select the desired permissions. The permissions cascade, in other words, if you have a permission, you have all the permissions below that selection.

   - **Create:** Users can create a Custom Dashboard; they can use the custom dashboard toolbar buttons New, Open, Delete, Find, Permissions, Download XML, Refresh Cache.
   - **Modify:** Users can modify Custom Dashboard properties and edit the dashboard; they can use the custom dashboard toolbar buttons Open, Delete, Find, Permissions, Download XML, Refresh Cache.
   - **Modify Permissions:** Users can assign permissions but cannot edit properties unless they have the Modify permission. They can use the custom dashboard toolbar buttons Open, Find, Permissions, and Download XML.
   - **View:** Users can view existing custom dashboards. They can use the custom dashboard toolbar buttons Open, Find, and Download XML.

5) Click the OK button.

---

**Configuring a Company Custom Dashboard**

Configuring a Company Dashboard entails modifying the dashboard properties and assigning permission for users.

The Company Dashboard properties include:

- A **General** tab, where you can name the dashboard and upload the SWF file
- A **Query** tab, where you can add multiple queries, select the data cube, and define grouping, summary, output, and reporting options
- A **Cache** tab, where you can enable the XML caching option (instead of using real-time data)

**Modify the General Properties of a Company Dashboard**

You cannot define the general properties of Company Dashboard.

**Note:** Existing custom dashboards can be modified.

To modify the General properties of a Company dashboard, do the following:

1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the **Custom Dashboard** node. The Custom Dashboard log window opens.

3) In the **General** tab complete the fields as shown in the table below.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the dashboard.</td>
</tr>
<tr>
<td>Title</td>
<td>Enter a title. The title appears in the list of available custom dashboards that a user can view.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description</td>
</tr>
<tr>
<td>SWF File</td>
<td>Browse for the SWF (Small Web Format) file to use with the dashboard.</td>
</tr>
<tr>
<td>Type</td>
<td>Unifier displays the dashboard type as a read-only field.</td>
</tr>
</tbody>
</table>

Next, select data sources in the **Query** tab, as described in the following procedure.

**Define queries for Company Dashboard data cubes**

- **To define queries for data cubes**
  1) Click the **Query** tab.
  2) Click **Add**. The Query window opens. Complete the fields in the **Query** window as described in the table below.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the name of the query.</td>
</tr>
<tr>
<td>Data Cube</td>
<td>Choose a data cube to use as a data source for the custom dashboard.</td>
</tr>
<tr>
<td></td>
<td>▶ For a company-level custom dashboard, the data cube must be defined as <strong>Company Data Cube</strong>.</td>
</tr>
<tr>
<td></td>
<td>▶ For a shell-level custom dashboard, the data cube must be defined as <strong>Shell Data Cube</strong>.</td>
</tr>
<tr>
<td>Source Grouped By</td>
<td>Choose a column from Data Cube definition by which to group data. This drop-down list lists those data elements that are marked Group By in Data Cube definition. Changing the value under this drop-down should always reset values under Report On and Summary Type.</td>
</tr>
<tr>
<td>Output Type</td>
<td>Choose the output type, which determines the output after grouping data based on Source Grouped By column. Following are the options</td>
</tr>
<tr>
<td></td>
<td>▶ Record Count</td>
</tr>
</tbody>
</table>
Summary Value

Report On
Choose a column defined in the data cube from among those designated as Summary.

Summary Type
This drop-down shows a list of possible summary types. Values shown under this drop-down are based on the type of Report On data element:
- For Numeric type of data element: Summary, Min, Max, Average
- For Date type of data element: Min/Max

Next, specify cache details in the Cache tab, as described in the following procedure.

Specify cache details
This tab is only available on a company-level dashboard. You must enable the cache before data can be cached. Enabling the cache allows you to schedule the refresh of dashboard data at a preset frequency. With every successful run, the XML data file associated with the dashboard is refreshed.

Note: The Enable Cache option controls the Refresh Cache ability on the log. If Cache is not Enabled, Refresh Cache will not work.

The XML data is created only during a scheduled run or when the refresh cache option is selected. If Enable Cache is disabled, the XML is deleted. Until the scheduler refreshes the cache, or a manual refresh of the cache is not done, XML is not created. If Cache is not enabled in the custom dashboard properties, the dashboard query will result in real-time XML data.

To enable the cache and specify refresh and recurrence
Click the Cache tab. Complete the cache fields as described in the table below.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Cache</td>
<td>Mark this check box if you want to use the caching function. This selection enables the other options on the form.</td>
</tr>
<tr>
<td>Cache Refresh Frequency</td>
<td>Select cache refresh frequency.</td>
</tr>
<tr>
<td></td>
<td>- Daily.</td>
</tr>
<tr>
<td></td>
<td>- Weekly, end of day. Select which day of the week you want the cache to refresh.</td>
</tr>
<tr>
<td></td>
<td>- Monthly. Select which day of the month for the cache to refresh.</td>
</tr>
<tr>
<td></td>
<td>- Yearly.</td>
</tr>
</tbody>
</table>
Range of Recurrence
- Start on. Select a date to begin the refreshing the cache. This is a required field.
- No end date.
- End by. Select a date to end refreshing the cache.

Grant Company Dashboard View permission

To grant Company Dashboard View permission
1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the Custom Dashboard node. The Custom Dashboard log window opens.

   Note: Although the log lists both Company and Shell custom dashboards, you cannot grant Shell custom dashboard View permission in this log. Shell custom dashboard view permission is set at the individual shell level; that is, if you have access to a shell you will see its dashboard.

3) Select a Company dashboard from the log and click the Permission button. The Edit Permission window opens.
4) Click the Add button. The User/Group Picker window opens.
5) Select the users and or groups to add and click the Add button. The selected users or groups populate the Selected User/Groups pane.
6) Click the OK button to close the User/Group Picker.
7) In the User/group Name pane select the user or group and in the Permissions pane select View.
8) Click the User/Group Picker button to save the selection.

Configuring a Shell Dashboard

Configuring a Shell Dashboard entails modifying the dashboard properties, which include:
- A General tab, where you can name the dashboard and upload the SWF file
- A Query tab, where you can add multiple queries, select the data cube, and define grouping, summary, output, and reporting options

Caching is not available for the shell dashboard.
If you are a member of a shell, you can see its dashboard.

Modify the General Properties of a Shell Custom Dashboard
You cannot define the general properties of Shell Dashboard.
Unifier Administration Guide

**Note**: Existing custom dashboards can be modified.

To modify the General properties of a Shell custom dashboard, do the following:

1) Navigate to the **Company Workspace** tab and switch to Administration Mode.

2) Navigate to the **Company Workspace** tab and switch to Administration Mode.

3) **Select** the **Custom Dashboard** node. The Custom Dashboard log window opens.

4) In the **General** tab complete the fields as shown in the table below.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the dashboard.</td>
</tr>
<tr>
<td>Title</td>
<td>Enter a title. The title appears in the list of available custom dashboards that a user can view.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description</td>
</tr>
<tr>
<td>SWF File</td>
<td>Browse for the SWF (Small Web Format) file to use with the dashboard.</td>
</tr>
<tr>
<td>Type</td>
<td>Unifier displays the dashboard type as a read-only field.</td>
</tr>
</tbody>
</table>

Next, select data sources in the **Query** tab.

**Define queries for shell dashboard data cubes**

► **To define queries for shell dashboard data cubes**

1) Click the **Query** tab.

2) Click **Add**. The Query window opens. Complete the fields on the **Query** tab.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the name of the query.</td>
</tr>
<tr>
<td>Data Cube</td>
<td>Choose a data cube to use as a data source for the custom dashboard.</td>
</tr>
<tr>
<td>Data Cube</td>
<td>For a company-level custom dashboard, the data cube must be defined as <strong>Company Data Cube</strong>.</td>
</tr>
<tr>
<td>Data Cube</td>
<td>For a shell-level custom dashboard, the data cube must be defined as <strong>Shell Data Cube</strong>.</td>
</tr>
<tr>
<td>Show Data From</td>
<td>Determine the level from which the data cube should pull information.</td>
</tr>
<tr>
<td></td>
<td>Current Shell Only</td>
</tr>
</tbody>
</table>
### Modifying a custom dashboard

With the exception of refreshing a company dashboard cache, modification procedures pertain to both Company and Shell dashboards.

> **To modify a custom dashboard**
> 1) Navigate to the **Company Workspace** tab and switch to Administration Mode.
> 2) **Select** the **Custom Dashboard** node. The Custom Dashboard log window opens.
> 3) Select a company dashboard.
> 4) Click the **Open** button.
> 5) Modify the dashboard as needed and click **OK**.

See these dashboard modification topics:

- Delete a custom dashboard
- Find a custom dashboard
- Download XML Company or Shell dashboard data
- Refresh the Company Dashboard cache

---

### Source Grouped By

Choose a column from Data Cube definition by which to group data. This drop-down list lists those data elements that are marked Group By in Data Cube definition. Changing the value under this drop-down should always reset values under Report On and Summary Type.

<table>
<thead>
<tr>
<th>Source Grouped By</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sub-Shells Only</td>
<td></td>
</tr>
<tr>
<td>Current Shells and Sub-Shells</td>
<td></td>
</tr>
</tbody>
</table>

### Output Type

Choose the output type, which determines the output after grouping data based on Source Grouped By column. Following are the options:

- Record Count
- Summary Value

### Report On

Choose a column defined in the data cube from among those designated as Summary.

### Summary Type

This drop-down shows a list of possible summary types. Values shown under this drop-down are based on the type of Report On data element:

- For Numeric type of data element: Summary, Min, Max, Average
- For Date type of data element: Min/Max
Delete a custom dashboard

Only users with Create/Modify permissions can delete a custom dashboard. TheDelete procedure pertains to both Company and Shell Dashboards.

To delete a custom dashboard
1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the Custom Dashboard node. The Custom Dashboard log window opens.
3) Select a company dashboard.
4) Click the Delete button.
5) You will receive a confirmation message. Click OK.

Find a custom dashboard

This procedure is germane to both Company and Shell Dashboards.

To find a custom dashboard
1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the Custom Dashboard node. The Custom Dashboard log window opens.
3) Click the Find button.
4) You can search for custom dashboards using Name or Type.
5) Enter the search criteria and click Search (or press Enter).

Primavera Unifier displays all the dashboards that met the search criteria you entered.

Download XML data associated with a custom dashboard

You can download the data associated with the custom Company or Shell Dashboard.

Note: For Company Dashboard, if you enabled the cache when you defined the dashboard properties, then Unifier will download the last stored XML data.

To download XML data associated with a custom dashboard
1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the Custom Dashboard node. The Custom Dashboard log window opens.
3) Select a company dashboard.
4) Click the Download XML button.
5) Save the XML file.
Refresh the Company Dashboard cache

To refresh the company dashboard cache

The Refresh Cache option is available only for Company Dashboards that have the cache enabled. If you attempt to refresh the cache and the cache is not enabled, you will receive the message: *Cannot refresh the cache. Cache is currently disabled on this dashboard.*

1) Navigate to the Company Workspace tab and switch to Administration Mode.
2) Select the **Custom Dashboard node**. The Custom Dashboard log window opens.
3) Select a company dashboard.
4) Click the **Refresh Cache** button that is located on the tool bar.
Project Administration

The following topics describe tasks related with Project Administration.

In This Section

Creating and Managing Projects ................................................................. 221
Creating a Project ....................................................................................... 235
Updating Projects ....................................................................................... 238
Managing Member Companies ................................................................. 251
Managing Project Users and Groups ......................................................... 253
Setting Up Automatic Status Update ......................................................... 256
Setting Up Gates ....................................................................................... 257
Create an automatic project status update setup ........................................ 263
Choose the order of non-active statuses (Settings tab) ............................... 264
Define status change query and trigger conditions (Settings tab) ............. 264
Define project status update schedule (Schedule tab) .............................. 265
Activate or deactivate an auto-update status setup .................................... 265
Set permissions for automatic update of project status ............................. 266

Creating and Managing Projects

Projects can be created from scratch one at a time, or can be created by copying a project template. It is recommended that you create one or more project templates first, then create new projects based on them. Advantages to using a template include ease of individual project setup, consistency between projects, and the ability to update project information easily (for example, if you add a new user, introduce a new business process, or edit a cost sheet column) by allowing you to make an addition or modification directly to the template and then "push" it to existing projects.

Note: You can migrate standard projects to WBS shells. See Migrating standard projects to WBS shells (on page 337).

How to create and setup a project

Be sure you have the proper permission setting to administer projects. If your company has chosen to "organize projects" (that is, create projects under different project categories), be sure these categories have been set up. Categories can also include asset classes.

Step 1: Create a Project Template. Most major functionality that is available in a project can be set up in a project template. You can set up as few or as many individual features as you like within a template.

Step 2: Create a new Project. This can be done manually, or by copying a project template.

Step 3: Set up permissions. Grant permissions to access and work with the new project to project team members. Refer to the Unifier Reference Guide for project permission settings.
Step 4: Setup up gates. This is an optional step. The gates feature allows you set up acceptance criteria to use to track and control project phases.

Step 5: Manage projects. This includes updating projects to "push" updated information, set ups, etc., to existing projects. The projects do not need to have been created originally from the template.

The following sections discuss creating and managing projects and project templates.

Creating a Project Template

Project and project template categories are maintained by the company administrator. Asset classes are added as project category nodes when they are created. One category ("All") is listed by default. You can create project templates under the All category, or other project categories or asset classes as needed. These categories do not appear to users in User Mode; they are a way to organize projects or link asset classes to projects.

Access project templates

To access project templates
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) in the left Navigator.
3) Expand the Projects (Standard) node. Like projects, project templates can be grouped by categories or by asset classes.
4) Click one of the category or asset nodes. The Project Templates log opens. The log lists any project templates that have been created under the category.

Create a project template

The following procedure describes how to create a project template. The procedure is similar to creating a new project.

To create a new project template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects in the left Navigator.
3) Expand the Projects (Standard) area to display the categories. The default is All. The project category that you define here will determine the category to which subsequent projects will be assigned. The project category cannot be changed.
   Use caution when defining a template in a project category. You cannot "re-categorize" a project or project template once it is created and saved.
4) Click one of the category or asset nodes. The Project Templates log opens. The log lists any project templates that have been created under the category.
5) Click the New button. The Template window opens. The Template window is equivalent to the Project window; the same properties and tabs are filled out for a project template as for a new project.
6) Complete the Template window. This window will be used for the project Properties when creating projects:
Unifier Administration Mode

- **General tab:** Define properties. See *Define general project properties (General tab)* (on page 226).
- **Location tab:** Define the project location. See *Define project location (Location tab)* (on page 228) and *Add a project image (Standards tab)* (on page 230).
- **Standards tab:** See *Add project currencies (Standards tab)* (on page 229).
- **Progress tab:** See *Set up project progress tracking (Progress tab)* (on page 232).
- **Links tab:** See *Add links to other project-related web pages (Links tab)* (on page 233).
- **Custom tab:** See *Select a project custom attribute (Custom tab)* (on page 234).

These tabs are the same for both project templates and projects.

7) Click **Apply** to save changes as you enter information, and **OK** when you are ready to save information and exit the Template window.

Create a project template by copying a template or project

You can create a Project Template by copying from an existing Project template or an existing Project.

**Note:** You can choose to copy any existing Custom Calendars from the template or from an existing project.

To create a project template by copying an existing project or project template

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates > Project (Standard)** in the left Navigator, then select a project category. The default is **All**. Use caution when defining a project category. You cannot "re-categorize" a project or project template once it is created and saved.
3) From the **File** menu, choose **New >Copy From**. The Template Project Cloning window opens.
4) From the **Copy From** drop-down list, select one of the following:
   - **Template:** The log displays the list of existing project templates
   - **Project:** The log displays the list of available company-sponsored projects
5) Select a listed template or project name.
6) In the Select Modules pane, select the modules to include in the new template.
7) Click **OK**. The Template window opens, displaying the project template properties. Most properties are copied from the original project or template into the Template properties window, with the following exceptions:
   - **Project Number:** On the General tab, enter a Project Number
   - **Project Currency:** On the Standards tab, specify the Project Currency
   - **Project Image:** On the Standards tab, specify the Project Image (optional)
8) Click **OK**. Click **Yes** to confirm.
Caution: Use caution when selecting which modules to copy. When you create an empty project template by copying from an existing project or template, you will be copying existing setups already created in the selected modules. (For example, if you select Cost Sheet, you will copy not only the project cost sheet, but any existing work packages and worksheets as well; since cost sheets and work packages cannot be deleted once created, you will not be able to delete these from the new template.)

Set up modules in the project template

Setting up modules is optional. For example, you can configure a Cost Sheet in your project template. When you create a new project using this template, you will have the option of copying this Cost Sheet into the new project.

Project Templates have the same fields as a new Project.

Note: Some fields are not filled in or not copied over when you copy from a template because they are not relevant until a project is created, like Project Start Date and Project Image.

Member Companies

You can select project member companies from your company’s list of partner companies. See Managing Member Companies (on page 251).

Access Control

Enables setting up default permission settings for users and groups. See Grant project user permissions through Project Access Control (on page 256).

Users and Groups

As with projects, you must add at least one user to the project template before you can activate it. Users and groups added to a project template are always copied by default from the template to the project created from it. See Managing Project Users and Groups (on page 253).

If your groups are going to be similar across all of your projects, you can define them once in the template rather than creating them in each project. It is not recommended that you put Users into the Project Template unless you know that those users will be on every project. The one exception is that a Project Administrator is required to be named in the template. Users cannot be deleted once they are in the Template, although Users can be deactivated.

Projects Templates can include the following modules:

Business Process Setup

Business Process setups created in the template can be copied over to projects.

Rules

You can define project level cost or funding rules.

Project Information

You can define the business process that will be used in the Project Information: General node.

Gates Setup
You can include a gates setup in your project template. See Setting Up Gates (on page 257).

Cost Manager
You can define any or all of the following in a template:

- **Cost Sheet** (includes Worksheets and Work Packages)
  
  You can create a cost sheet for the project template. This is similar to creating a cost sheet for a project. And like projects, you can also include worksheets and work packages.

- **Funding Sheets**
  
  You can create a project fund sheet, and commitment funding sheet structure.

- **Schedule of values (SOV)** (Structures for General Spends, Payment Applications, and/or Summary Payment Applications)
  
  - For General Spends SOV, the SOV structure is copied from an SOV template in the Templates log.
  
  - For Payment Applications SOV and Summary Payment Applications SOV, the structure is copied from the line item grid structure of the Payment Application Business Process. This means that you must first complete the Business Process (BP) setup for the Payment Application BP before you can create the structure.

- **Cash Flow Curves**
  
  You can create Cash Flow Curves.

  **Note:** Since only one Cost Sheet, Funding Sheet, SOV structure (of each type) and commitment funding structure can exist in a project, make these choices carefully. Once you create these items in the project template, you can modify them, but will not be able to delete or replace them.

Document Manager, Project Documents
You can create a folder structure for the document manager that can be used across projects. These can be created from Folder Structure Templates, or folders can be added manually. Unlike Folder Structure Templates, you can also assign users (if they are in the project template) folder-level permissions, and can import folders and folder properties.

Resource Manager
You can create the setup and resource sheets in the template.

Schedule Sheet
A Schedule Template will be used to create the Schedule Sheet. Like the Cost Sheet, once this is created, it cannot be deleted.

User-defined Reports: You can create one or more user-defined report templates, which will be used for project user-defined reports. You can import user-defined reports into project templates from project templates in other companies and Unifier environments. See Importing User-Defined Reports into Project or Shell Templates (on page 666).

To set up modules in the project template
1) Open the project template.
2) Click a module and add the applicable information. This information can be carried over to new projects created from the template.

**Manage Project Templates**

Once the Project Template properties have been defined, you can setup any or all of the available modules. These will be copied to projects that have been setup using the template.

*Note:* You do not have to setup modules here. If you do not setup a module in the Project Template, the modules will not be setup in the projects. You can setup the projects manually after project creation, or by using individual templates, for example, cost sheet templates.

You have the option to edit project properties and modules and update existing projects with the new data. See *Updating Projects* (on page 238) for more information.

**To open the project template**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates>Project (Standard)** in the left Navigator.
3) Select a project category (default is **All**). The **Project Templates** log opens.
4) Select a project template from the log and click **Open**.
5) The project template home page opens. The navigator expands to display the modules that can be configured in the project template. Select a module to edit or set up.

**To edit project template properties**

1) From the project template home page, click the **Open** button. The Template window opens.
2) Click the tabs to view or edit project template properties.

---

**Defining Project (and Project Template) Properties**

This section describes the Properties window for projects and project templates.

**Define general project properties (General tab)**

**To define project locations for a project or project template**

1) Open the **General** tab of the Project or Template window.
2) Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Number</td>
<td>For Templates, you might enter a phrase such as Enter project number here or information for your Project Administrator regarding how to assign a project number, as each project created from the template will have its own number. When creating a new project, if the Site Administrator enabled automatic project numbering during new company setup, this field will be pre-populated each time a new project is created.</td>
</tr>
<tr>
<td>Setup Date</td>
<td>Populates automatically with the current date when the project or template is saved.</td>
</tr>
</tbody>
</table>
### Project Name
Enter a project name. For templates, you might enter a generic name or instructions such as Enter Project Name here.

### Description
Explain the purpose or intended uses of the project or template (especially if you have multiple templates).

### Administrator
Click Select to open the User/Group picker and select a Project Administrator. For templates, the user will automatically become part of the Project Administrator group for any project created from the template. (Additional administrators can be selected.)

### Construction Type
Choose New Construction or Retrofit/Remodel.

### Project Status
You can activate the project template immediately, or place it On-Hold or make it View-Only and activate later. A template that is On-Hold, View-Only, or Inactive cannot be used to create a project. It is good practice to leave a project or template On-Hold until you have completed the setup. Project Administrators/Users with "modify project status" rights are the only ones who can change the status.

The project administrator will receive email notification when the status of a project changes. The change of project status could occur due to a manual change, bulk update, through Web Services or a CSV file, or through automatic update.

Status definitions for projects are:

- **Active**: Active, in-progress project. All project actions in User and Administration Mode are available.
- **On-Hold**: The initial shell status. On-hold shells appear on the shells log. Shell administration functionality is available to shell administrators for setup and maintenance for users with permissions to perform that function. Users cannot create records in a shell that is On-Hold. If a user attempts to access a shell that is On-Hold, the system displays an alert message stating that the shell is On-Hold.
- **View-Only**: For end users, View-Only projects can be viewed, printed, exported, and included in reports. They cannot be modified. When a shell is View-Only, the status overrides (but does not modify) access control permissions, granting only View permissions. The project reverts to the access control permissions when the project is made Active. View-Only projects can be added to and removed from programs, and can roll up to programs, UDRs, and dashboards. Business process records cannot be auto-created in View-Only projects. Data from View-Only projects does not roll up to Company-level account codes or cost sheets. Data will roll up from View-Only projects to programs, the Planning Manager, and the Asset Manager. No updates can occur to View-Only projects through Integration, Unifier Mobile, or through reverse auto-population. View-Only projects cannot be updated through templates. Consolidate line item functionality is disabled for View-Only projects. View-Only projects have only view, export, and print permissions.
available. Tasks and Drafts are not available for View-Only projects. Messages are available, but users cannot add general comments. uMail is available for viewing, but users cannot send, edit or delete messages for View-Only projects. When a project becomes View-only, all scheduled jobs associated with it are canceled. When the status of the project changes back to Active, you must restart any scheduled jobs. Administrators can perform all actions on View-Only projects.

- **Inactive**: Used to suspend project usage. Inactive projects are visible from the Administration Mode under Sponsored Project log only, but not visible under the Projects node (i.e., only Sponsor Company can access the project), or in User Mode logs and selections. Only System and Project Administrators (users with Modify Status rights) can reactivate the project. Late tasks in an inactive project may still show up in users’ tasks logs. Though they can access the task, no transactions can be performed in the inactive project.

<table>
<thead>
<tr>
<th>Auto-update Status Setup</th>
<th>The selections on the drop-down list are defined automatic status update setups. These setups are defined at the Company level for use in specific projects. See <strong>Setting Up Automatic Status Update</strong> (on page 256) for details. If you decide not to use the automatic status update, you can deactivate it by deseleting a setup (by literally selecting the word “Select”).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Type</td>
<td>The selections on the drop-down list are defined in the data set of the Project Type data definition. The default is None. Contact your Company Administrator if you need additional Project Types defined.</td>
</tr>
</tbody>
</table>

**Define project location (Location tab)**

You can define up to four addresses (Project, Billing, Shipping, and Billing & Shipping) for a project or project template. For each project or project template, you must enter at least one address: the Project Address. The Project Address will be used to generate an online location map accessed in the Project Home Page in User Mode.

The following is applicable when creating a project template or new project:

**To define project locations for a project or project template**

1) Open the **Location** tab of the Project or Template window.
2) Complete the Location tab as shown in the following table.
3) Click **Apply** to save changes, or **OK** to save and exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address Type</td>
<td>Select one of the address types listed (you must complete the Project Address fields).</td>
</tr>
<tr>
<td>Address 2</td>
<td>Enter the main street address Note: If the Project Template will be used for different project locations,</td>
</tr>
</tbody>
</table>
you can enter generic notations for the Project Administrator, such as Enter project address here.

<table>
<thead>
<tr>
<th>Address 3</th>
<th>Address 4</th>
<th>Generally for P.O. Box numbers, suite numbers, etc.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address 3</td>
<td>Address 4</td>
<td>Generally for P.O. Box numbers, suite numbers, etc.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Country</th>
<th>Choose the from the drop-down list.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site</td>
<td>Choose a site from the drop-down list. The selections are generated from the Project Site data definition. The default is None.</td>
</tr>
</tbody>
</table>

**Add project currencies (Standards tab)**

On the Standards tab, you can specify a currency or currencies that will be used on the project. The currency you specify here will be used throughout the project, for example for cost business processes, the cost sheet, etc. You must define at least one currency. If the project is international, you can define multiple currencies in which to display data, although only one can be the default project currency.

**Note:** The list of available currencies is maintained in Standards & Libraries > Exchange Rate.

To define project currency for a project or project template

1) Open the Standards tab of the Project or Template window.
2) In the Currencies section of the window, click the Add button. The Edit Exchange Rate window opens.

**Note:** The Base Currency shown at the top of the Edit Exchange Rate window is the Base Currency set up for your company. For example, if yours is a U.S. company, the Base Currency will likely be United States Dollar (USD). If your company does business internationally, you may make other currencies available for project use.

3) Use the information in the table below to add a currency.
4) Click OK to save and exit the Edit Exchange Rate window.
5) In the Standards tab, select a Project Currency from the drop-down list. This will be used as the default project currency. Once you have selected a project currency and saved the template or project, it cannot be changed. The selections are generated from the Currencies list you defined.
6) Click Apply to save changes, or OK to save and exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency Name</td>
<td>Select the currency you want to use for the cost functions in this project. If the currency you selected is other than the company Base Currency, then complete the following fields.</td>
</tr>
</tbody>
</table>
Unifier Administration Guide

<table>
<thead>
<tr>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter an exchange rate to use for conversion calculations. From the drop-down list select one of the following:</td>
</tr>
<tr>
<td>➢ If <strong>Float</strong> is selected, the rate is updated automatically from the <strong>Company Currency Table</strong> ([Standards &amp; Libraries &gt; Exchange Rate]).</td>
</tr>
<tr>
<td>➢ A <strong>Peg</strong> rate locks in the company rate on the day the rate is set. (Only a Project Administrator can manually modify the <strong>Peg</strong> rate to a value other than the company peg rate.).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Hedge?</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the <strong>Hedge</strong> selection is Yes, then the Hedge rate is used for conversion calculations. Otherwise, the <strong>Float</strong> rate will be used.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>If an amount is entered for the <strong>Rate</strong>, then the hedge rate is used until the amount specified is reached (by spends) and then the system will revert back to the normal rate.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>If <strong>Float</strong> is specified, Unifier will retrieve the rate, based on today’s date and time. If <strong>Peg</strong> rate is specified, the field will be editable.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Optional) Add any comments that might be necessary to explain the default currency.</td>
</tr>
</tbody>
</table>

### Add a project image (Standards tab)

You can add a representative image of the project that will display on the project home page for users.

For templates, it is not necessary to select a project image because it will not be copied to a project created from the template. However, you can include one to provide an example to users creating projects.

For best results, the recommended image size is 500 pixels wide by 300 pixels high. Image files should be in jpeg or gif format.

#### To define a project image

1. Open the **Standards** tab of the Project or Template window.
2. In the **Project Image** field, click the **Browse** button.
3. Browse to the location of the image file, select the file and click **OK**.
4. Click **Apply** to save changes, or **OK** to save and exit.

### Distribute an External Email Address for the Project (Standards Tab)

External emails are important communications that need to be included in projects. Such emails can come from project members or from external users who do not use Unifier. These email communications (and any attachments) can be collected in a central repository, called the **Project/ShellMailbox**, so that project members can use them in managing and documenting the project. Once such emails reside in the project’s mailbox, project users can view them, forward them to appropriate members, flag them for review, and reply to them. In addition, these external emails can be linked to business process records.
When Unifier is installed on your system, a dedicated email address for your company is specified, and whenever you create a project, Unifier assigns it a unique identifier. Unifier combines this email address and project identifier to create the Project Mailbox. This email address appears on the Standards tab, and from the Standards tab, you can send the email address for the Project Mailbox to all project participants, both within and outside of Unifier.

Notes:
- External emails that have been blind carbon-copied (Bcc) are not collected by the mailbox.
- To prevent spam and virus attacks, you will need to create a list of approved email addresses that will be accepted by the project. See Creating an Approved Email List for Project and Shell Mailboxes (on page 157).

To distribute the external email address
1) Click the Send Email button. An email message window opens.
2) In the To field, enter the email addresses of all participants in the project.
   You can also send the address of the dedicated mailbox to external users by adding their email addresses in the External Cc field.
3) Click the Send button.

Distribute the email address from the landing page
In addition to the Standard tab, you can distribute the email address from the project’s landing page. Remember to add the new recipient to the approved email list for this mailbox (Creating an Approved Email List for Project and Shell Mailboxes (on page 157)).

To notify project users whenever the project mailbox receives an external email

![Image of Unifier interface with project details](image-url)

Click this link to distribute the email address for the project’s Mailbox to other users.
1) In the **Send Notification To** field, click the **Select** button. The User Picker opens.
2) Select the users you want to notify and click **OK**.

### Set up project progress tracking (Progress tab)

The Progress tab of the Project window helps you track the progress of your project. You can manage milestones and project phase from this window. This information is displayed on the Progress pane of the Project landing page. This means a project administrator can quickly view the current status of a project and make modifications as necessary. Project Phase can affect other modules such as triggering when certain workflows or documents become available.

The Progress tab can be linked to the Project Schedule Sheet. By setting up the Project properties to integrate with the Schedule Manager, changes in the schedule manager will automatically change the progress indicator in the project or program Progress tab. (The Schedule Manager is referenced.)

The Project Phase can be set manually, or can be maintained manually (see **Setting Up Gates** (on page 257).)

### To set up project progress tracking

1) Open the **Progress** tab of the Project or Template window.
2) Complete the tab as described in the following table.
3) Click **Apply** to save changes, or **Ok** to save and exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start Date</strong></td>
<td>Choose one of the options:</td>
</tr>
<tr>
<td></td>
<td>Manual: Manually enter the project start date by clicking the calendar icon.</td>
</tr>
<tr>
<td></td>
<td>From Schedule Manager: Click the selection list and choose a data column from the list (for example, Project Start Date). The Project Schedule Sheet must be created and setup before selections become available.</td>
</tr>
<tr>
<td><strong>Planned Completion</strong></td>
<td>Choose one of the options:</td>
</tr>
<tr>
<td></td>
<td>Manual: Manually enter the project start date by clicking the calendar icon.</td>
</tr>
<tr>
<td></td>
<td>From Schedule Manager: Click the selection list and choose a data column from the list (for example, Project Due Date). The Project Schedule Sheet must be created and setup before selections become available.</td>
</tr>
<tr>
<td><strong>Revised Completion</strong></td>
<td>Choose one of the options:</td>
</tr>
<tr>
<td></td>
<td>Manual: Manually enter the project start date by clicking the calendar icon.</td>
</tr>
<tr>
<td></td>
<td>From Schedule Manager: Click the selection list and choose a data column from the list The Project Schedule Sheet must be created and setup before selections become available.</td>
</tr>
</tbody>
</table>
### Add links to other project-related web pages (Links tab)

Project Links will appear on the Project Home Page. Links entered here in the Project Template will be copied over to the Project.

Project Links will appear on the Project Home Page. They can be used to provide links for users to useful websites, your company’s website, an intranet, etc. Links entered here in the Project Template will be copied over to the Project.

**To add a project link**

1. Open the **Links** tab of the Project or Template window.
2. Enter the name and URL for any number of links you want to appear on the project home page. The name will display as an interactive link on the project home page. When users click on the link, a new browser window opens to the URL.
   
   For example, to provide a direct link to the government Occupational Health and Safety website, you might enter OSHA as the name, and http://www.osha.gov as the URL.
3. Click **Add Row** to add additional URL links on the project home page.
4. Click **Apply** to save.

<table>
<thead>
<tr>
<th><strong>Design Complete</strong></th>
<th>This indicates the percentage of the design phase that has been completed. Enter a value.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Construction Complete</strong></td>
<td>This is the percentage of the construction phase that has been completed. Enter a value.</td>
</tr>
<tr>
<td><strong>Notes</strong></td>
<td>Project notes can be anything that the Project Administrator feels is relevant to share with other Project Administrators. This note is not displayed on the Summary or Project Home Page.</td>
</tr>
<tr>
<td><strong>Status</strong></td>
<td>Chose from one of the three statuses.</td>
</tr>
</tbody>
</table>
| **Project Phase** | If you are manually managing project phases, you can choose from this list for template and projects.  

**Note:** If you are using Gates, this list may not be applicable.

Project Phase is a system-defined Data Definition that is pre-filled when the company is created. You can update this list by navigating to Data Structure Setup > Data Definitions > General and add new values to the Data Set list.

**Note:** Project Phase is associated with Files and Folders in the Document Manager. Files and Folders can be given a Phase Property. Then, the only Folders and Files that will show in the DM are those folders without a Phase Property or one that matches what is set in Project Setup. |
Select a project custom attribute (Custom tab)

Projects can have Custom Attributes associated with them. Custom Attributes are created as company-defined Data Definitions. In the case of Projects and Project Templates, they can be used to provide further data not defined elsewhere. In the example below, Regions were defined as a custom attribute.

If no custom attributes have been defined, the tab will be blank.

To select a custom attribute
1) Open the Custom tab of the Project or Template window.
2) Select the value from the pull-down menu. Click OK.

Create a project calendar (Calendar tab)

Each project can have its own calendar. The project calendar that you specify can be used to override the Company calendar, or you can use the Company calendar for the project. If there is no project calendar, or a project calendar is not in use, the Company-level Standard Calendar marked as the default calendar is the calendar that is used by the project. Project calendars can be based on Standard Calendars created at the Company level, or Custom Calendars created for the specific project. The project calendar you create applies only to the project for which you create that calendar. The calendar selected affects project durations and due dates.

For example, companies can have multiple projects in different countries that have different working and non-working days. These working and non-working days must be considered when determining such time-driven factors as business process workflow due dates and activity dates in schedule sheets.

Note: Unless otherwise specified, the default calendar for a project is the Company calendar that is marked as default at the Company level.

To create a project calendar
1) Open the Calendar tab of the Project or Template window. The calendar you create in this tab is known as the Project/Shell Calendar.
2) You can select a Company-level Standard Calendar, or use a Custom Calendar for your project. The calendar that you select displays in the Calendar tab.
   - To use a Standard Calendar as the project calendar, click the Standard Calendar radio button and select a calendar from the drop-down list.
   - To use a Custom Calendar as the project calendar, click the Custom Calendar radio button and click Copy. You can copy a previously-created Standard Calendar and use it as the project calendar.
3) You can modify the displayed calendar. You can specify the working and non-working days for the calendar. Browse to the month and year using the pull-down menus at the top of the calendar. Saturdays and Sundays are set as non-working days by default. Do one of the following:
   - To set a particular date as a non-working day (for example, a holiday), click the date on the calendar and select Non Working. The date will appear grayed out, and will not be used in date calculations.
   - To set a non-working day as a working day, click a grayed cell and select Working.
To set a particular day of the week (for example, every Saturday) as a non-working day, click the day at the top of the calendar (for example "Sat"), then click Non Working. All Saturdays in the calendar will be changed to non-working days (gray).

To set a particular day of the week as a working day, click the day at the top of the calendar, then click Working.

If you only want to set the day of the week in a particular month as working or non-working days, select each day individually and click Working or Non Working.

**Note:** If you have marked the day of the week as a non-working day throughout the calendar by selecting the day at the top of the calendar (for example "Sat"), then you will not be able to mark individual days (that is, individual Saturdays in this example) as working days. To be able to include both working and non-working instances of a day of the week on the calendar, you must select them individually.

4) Click OK. When you click OK, the calendar displayed in the Calendar tab is the project calendar.

---

### Creating a Project

The follow discusses creating a project by copying from a project template, by copying from another existing project, or creating manually.

---

#### Grant permission to administer projects or project templates

In order for a Project Administrator to be able to create and setup a Project, the administrator must have the permission setting to "Administer All" (or "Administer Project Category") at the Company Sponsored Projects, Project Properties level.

**To grant permissions to Project Administrator User or Group**

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click User Administration > Company Users or Partner Users (to grant permissions to individual users) or Groups (to grant permission to a project administration group).
3) Scroll to Company Sponsored Projects (Standard) and select.
4) Select the user or group and click Open. Click the Permissions tab.
5) Select Administer All (for non-categorized projects), and/or Administer Project Category.

---

#### Create a project by copying a template or project

You can create projects using the project templates you created. You can also create projects by copying from existing projects.

You can verify the project properties, make changes as necessary, update status, or activate as necessary.
Tip: Because you can only have one cost sheet per project (and once a Cost Sheet is created for a project, it cannot be deleted or replaced), you might consider creating a Cost Template in the Templates log and copy into the project separately.

Note: As Project Administrator, you can receive email notification of the successful creation of a shell instance, for shells that are created manually, through Web Services or a CSV file upload, or through auto-creation. This notification can be set up in email notifications in uDesigner. Also, you can set your User Preferences to control whether you receive these notifications.

To create a project from a project template or existing project
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Projects in the left Navigator.
3) If your company is using project categories, click a project category in which to create the new project. If you don't wish to categorize the project, or if no categories have been setup, click All. Note that not all administrators will have access to all project categories.
4) From the File menu, click New > Copy From. The Project Cloning window opens.
5) Click the Copy From drop-down list and choose Project to copy an existing project, or Template to copy a project template.
6) Select a project or template from the list and click OK. To search for a specific project or template on the list, click the Filter By field and select Name or Number. In the Filter For field, enter all or part of the name or number to search for and click Search.
7) In the Select Modules pane, select the modules to include in the new project. Users and Groups are selected by default and copied along with the project properties.

Note: If the Schedule Sheet option is selected, the curves relating to the schedule sheet will be copied to the new project. If the Schedule Sheet is NOT selected, the curves relating to the schedule sheet will be created but the name of the schedule sheet selected on the properties window will be empty.

8) Click OK. The Project window opens, displaying the project properties.
Most properties are copied from the original template with the following exceptions:
   ▶ Project Number: On the General tab, enter a Project Number
   ▶ Project Currency: On the Standards tab, specify the Project Currency
   ▶ Project Image: On the Standards tab, specify the Project Image (optional)
9) When the window is complete, click OK.
10) Click Yes to confirm and create the new project.

Create a new project manually
To manually create a new project:
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Projects in the left Navigator.
3) Click a project category in which to create the new project. If you don't wish to categorize the project, or if no categories have been setup, click All. Note that not all administrators will have access to all project categories.

4) Click the New button. The Project window opens.

5) Complete the information on each of the tabs.

The tabs contain the same fields as the template window.

Some notes on the tabs:

- **General** tab: Note Project Status: you may set the project status to Active to make it available to users immediately, or leave it as Inactive until you have completed setting up the new project. This will prevent users from signing in to their company and attempting to access the project before it is ready.

- **Location** tab: Be sure to enter the complete Project Address and any other project related addresses.

- **Progress** tab: Enter the project schedule start date, planned completion date, status and project phase.

  You can manage a project's progress on a continuing basis by reviewing the project properties you define here. For instance, at any time you can enter a revised completion date, enter the percent complete for a design and/or construction project, monitor the project status, or change the project phase to ensure information contained in the Document Manager is current and available to the project team at the right time.

  The information that you enter here is also viewable from the Progress pane of the Project landing page. This means a project administrator can quickly view the current status of a project and make modifications as necessary.

6) Click OK to save your changes and exit the Project window.

### Add Cost Sheet

The option "Enable P6 sources" is not available in a Cost Sheet created in a Standard Project or Standard Project Template.

The cost sheet that has the option "Enable P6 sources" selected is not included when you want to create a new Cost Sheet by copying a cost sheet.

The template that has the option "Enable P6 sources" selected is not included when you want to create a new Cost Sheet using: New > Cost Sheet > Copy from Template.

### Manage Projects

You can verify the Project properties, make changes as necessary, update status, or activate as necessary. It is recommended that you keep the company progress information up to date to reflect the ongoing status and progress of the project.

You can also modify project information in a Project Template and then update one or more existing projects by "pushing" the information from the template to the projects (see **Updating Projects** (on page 238)).

To open a project

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Projects** in the left Navigator. Select a project name from the project log and click **Open**. The Project home page opens.

**To edit an existing project**
1) Open the project's home page and switch to Admin mode.
2) Click the **Open** button. The Project window opens.
3) Modify the project information as necessary on the tabs. You can modify any of the project properties any time during the project duration, except for the project currency. Once a project is set up, the project currency is locked.
4) Click **OK** to save your changes and exit the **Project** window.

**Note:** The tabs contain the same fields as the Template window.

**Activate or deactivate a project**

**To activate/deactivate a project**
1) Open the Project Home Page and switch to Admin mode.
2) Click the **Open** button. The Project window opens.
3) In the **General** tab, set the status to Active, Inactive, or On-hold.
   - **On-hold**: The initial project status. On-Hold projects are listed on the projects log, but you cannot work with them.
   - **Active**: Active, in-progress project. All project actions in User and Administration Mode are available.
   - **Inactive**: Inactivate projects to suspend project usage. Inactive projects are visible from the Administration Mode under Sponsored Project log only, but not visible under the Projects node (i.e., only Sponsor Company can access the project), or in User Mode logs and selections. Only System and Project Administrators (users with Modify Status rights) can reactivate the project.

**Note:** "Late" tasks in an inactive project may still show up in users’ task logs. Though they can access the task, no transactions can be performed in the inactive project.

**Updating Projects**

The Update Projects function allows you to quickly add or modify information into a project template, and then apply that template to existing projects. This will "push" the new information to the projects that you specify. By allowing data to be entered or modified once, this function helps to reduce set up time and ensure cross-project uniformity.

The Update Projects function is available for select modules in Project Templates. The following information can be pushed:

- **Users**: users, group membership, permissions
- **Groups**: group names, permissions
Unifier Administration Mode

- **Business Processes and BP Setups**: Business processes, setups
- **User-defined Reports**: Reports, report permissions
- **Access Control**: Modules, users, groups, permissions
- **Cost Sheet**: Cost sheet columns, column access and restrictions
- **SOV**: General and Payment Applications structure
- **Commitment Funding**: Commitment funding sheet structure
- **Cash Flow**: Curve properties and permissions
- **Rules**: Project cost or fund rules
- **Gates Setups**: Active or inactive setups
- **Schedule Sheet Properties**: Title, description, Master Schedule, status, auto-control, project start date, and error notification.

Each project module that can be updated from the template has an Update Project button in the toolbar.

This functionality makes it easy to update information across multiple projects. For example, if you add new users, or group of users, to the company and need to add them to multiple projects, you can add them to a project template, then use the Update Projects functionality to add the users to multiple projects.

Projects with a status of Active or On-Hold can be updated with this functionality. Inactive or View-Only projects cannot. Users with Create permission for the project template modules can do this operation.

**Note**: You update project information one module at a time. Any Active or On-hold projects can be updated in this way.

### General procedure for updating project information

In general, the Update Project feature works like this:

**Step 1.** Open a Project Template.

**Step 2.** Navigate to one of the modules listed above. Add or edit data.

**Step 3.** Click the **Update Project** button. Select which information within the module to update, and which of your active or on-hold projects to "push" the information to. New information will be added to the selected projects. Edited information will overwrite existing data.

You can also cancel a project update before it reaches the In Process status.

Detailed instructions for updating specific types of project information is found in the following sections.

### Update users

You can add new users to multiple projects at once by adding them to a project template in the User Administration > Users module. When adding new users to a project, you can assign individual permissions directly to a new user, or add the user to a group to apply group permissions.
The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

### Some notes about updating users
- Users are identified by their unique User ID.
- Any Active, Inactive or On-hold users can be pushed.
- If the user does not already exist in the project, the user will be added to the project with the permission settings and group membership.
- If the user already exists in the project, the user information is updated (replaced) with the user information as entered in the project template. This includes permission settings and group membership.
- If a group that the user was added to doesn’t already exist in the project, the group will be added, and the user will be added to the group. Group permissions are not updated; this is done by updating groups.
- If the group already exists, the user will be added to it. Group properties and permissions will not be affected.

### To add or update users using Update Project
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) > All in the left Navigator. Open the project template to update.
3) In the Project Template, go to the User Administration > Users log.
4) Add a user to the project template, or select a user to edit. Define user parameters and assign permissions.
5) Select one or more users in the Users log.
6) Click the Update Projects button and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.
     An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
7) Click **Yes** if you want to proceed with the update, or **No** to cancel.

### Update groups
You can add new users to projects individually or by adding them to groups, and then adding the groups to the projects. You can assign the user individual permissions, or add the user to a group and apply group permissions.
The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating groups:

- Groups are identified by their unique Group Name.
- All group properties, including permission settings, will be added or updated in the projects that you selected.
- If the group does not already exist, the group will be created with the permission settings. Group membership (user list) will not be updated in the project.
- If a group of that name exists, the properties and permissions of that group will be replaced with the new group, but not the list of users.
- Users will not automatically be added to the group; they need to be added by updating users (group membership).

**To add or edit user groups using Update Project**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates>Projects (Standard) > All** in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to the **User Administration>Groups** log.
4) Add a group to the project template, or select group to edit. Define group parameters and assign group permissions.
5) Select one or more groups from the Groups log.
6) Click **Update Projects** and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects.
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.

   An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
7) Click **Yes** if you want to proceed with the update, or **No** to cancel.

**Update business processes and BP setups**

You can add and update new business processes, or add additional business process setups to existing business processes.

The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.
Notes:

About updating business processes and setups:

- **BP Setup** is identified by the unique combination of BP Name, Setup Name and Workflow Name.
- If the BP Name does not exist, it will be added to project with the BP Setup and permissions.
- If the BP exists, but the BP Setup does not, it will be added to the BP.
- If the BP and BP Setup exist, the Setup will be replaced with the new one.
- Users and Groups that are part of a BP setup as assignees are added/updated, but not permissions. If a group is created, it will be empty. Users must be added to the group separately through user administration.
- BP-related permissions are added/updated (for example, discussion groups).

To add or update business process setups using Update Project

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates>Projects (Standard) >All** in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to the **Setup >Business Process** log.
4) Add any new business processes, if applicable. (The BP must already have been imported into Unifier and configured at the company level.)
5) To add or edit business process setups, select the BP to update in the Business Processes log. Click **Open**. The BP Setup log opens.
6) Create a new setup or modify an existing setup. You may create as many setups as you wish to make available in the project(s).
7) Select one or more setups from the BP Setup log.
8) Click **Update Projects** and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.

    An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
9) Click **Yes** if you want to proceed with the update, or **No** to cancel.

Update user-defined reports

You can add and update user-defined reports.
The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Some notes about updating reports

- Reports are identified by the combination of Name and Data Type.
- If the report name and data type does not exist, the new one will be added. Users/Groups will be added/updated, and permissions will be created for the report. The administrator updating the project becomes the report owner.
- If a report exists with the same name and data type, it will be replaced with the new one. This includes updating the report, users/groups are created or updated, and permissions are created or updated for the report. The original report owner remains the same.

To add or update user-defined reports using Update Project

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) > All in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to the Reports > User-Defined Reports log.
4) Add a UDR to the project template, or select UDR to edit. Define properties.
5) Select one or more reports from the User-Defined Reports log.
6) Click Update Projects and choose one of the following:
   - Projects: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - All Projects: updates all active and on-hold projects.
   - History: allows you to view the update history from past updates or cancel a request before the update begins.
     An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
7) Click Yes if you want to proceed with the update, or No to cancel.

Update access control

You can edit access control parameters and update across projects.

Notes:

- Modules are identified by name.
- If the module exists in the project, the module is updated, users/groups are created or updated, and permissions are updated for the module.
- If the module does not exist, the module is added to the project. Users/groups are created and permissions are created for that module.

**To update access control using Update Project**

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Templates>Projects (Standard)** in the left Navigator. Open the project template to update.
3. In the Project Template, navigate to **Access Control** and assign user or group permissions to the modules as needed.
4. Click the **Update Projects** button. The Update Projects window opens, displaying the list of modules for which the access control settings can be updated.
5. Select the module(s) that you wish to update, click **Update Projects** and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.

An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.

6. Click **Yes** if you want to proceed with the update, or **No** to cancel.

**Update cost sheet columns in a project**

Cost sheet columns can be updated using this functionality.

The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating cost sheet columns:

- A column is identified by a unique data source.
- If the project cost sheet does not exist in the project, the column is not added.
- If the project cost sheet is present but the column does not exist, the column definition is created, and the column is added. Column restrictions are added. Users/Groups are created or updated.
For formula columns, be sure to first push the columns or data sources that make up the formula (if they don’t already exist in the cost sheet), then push the formula column.

Any new column that is created will use the column to its immediate left as the reference point for positioning. When a column is added to the cost sheet via an update, this means: If the column to the left of the column that is being pushed exists in both the template and cost sheet, the column will be positioned in the cost sheet according to its position in the template. If the column to the left of the column being pushed exists in the template but does not exist in the cost sheet, then the column will be added to the end (far right) in the cost sheet.

Cost Column Project Update Rules

If a project cost sheet column of the same name exists, it will be replaced according to the following matrix.

<table>
<thead>
<tr>
<th>If this template (source):</th>
<th>Is used for this project (destination):</th>
<th>The template will:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Date Source</td>
<td>Column exists</td>
<td>Update the column</td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with the same definition</td>
</tr>
<tr>
<td>Logical Data source</td>
<td>Logical Data source Column Exists</td>
<td>Update and replace the formula</td>
</tr>
<tr>
<td>(Formula entry)</td>
<td>(Formula entry)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logical Data source column exists</td>
<td>Not update the column or formula</td>
</tr>
<tr>
<td></td>
<td>(Manual entry)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with same definition</td>
</tr>
<tr>
<td>Logical Data source</td>
<td>Logical Data source Column Exists</td>
<td>Update the column</td>
</tr>
<tr>
<td>(Manual entry)</td>
<td>(Manual entry)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logical Data source Column Exists</td>
<td>Update the column and change it to manual entry</td>
</tr>
<tr>
<td></td>
<td>(Formula entry)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with same definition</td>
</tr>
</tbody>
</table>

To add or update cost sheet columns using Update Project

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) > All in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to Cost Manager > Cost Sheet. Create or open the Project Cost Sheet.
4) From the cost sheet, click Columns to open the Columns log. Add or edit cost sheet columns as needed.
5) From the **Columns Log** window, select the column to push. Only one column can be updated at a time.

6) Click **Update Projects** and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects.
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.

   An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.

7) Click **Yes** if you want to proceed with the update, or **No** to cancel.

**Update Schedule of Values (SOV) Structure**

You can update the SOV structure for General Spends, Payment Applications, or Summary Payment Applications.

The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**
- Update Project can be used to create or update the SOV structure. If the structure already exists, it will be updated. If not, it will be created (restrictions apply for payment applications; see below).
- When creating or updating the structure of the Payment Applications SOV or Summary Payment Applications, the Payment Application business process must be set up in the target project first. If the business process has an active setup, then Update Project will create or update the structure.

**To update SOV structure using Update Project**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Templates > Projects (Standard) > All** in the left Navigator. Open the project template to update.

3) In the Project Template, navigate to **Cost Manager > Schedule of Values**. Select one of the options: **General Spends/Payment Applications/Summary Payment Applications**.

4) Click **Update Projects** and choose one of the following:
   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects.
Unifier Administration Mode

- **History**: allows you to view the update history from past updates or cancel a request before the update begins.
  
  An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.

5) Click **Yes** if you want to proceed with the update, or **No** to cancel.

---

**Update commitment funding structure**

You can update the structure used to create commitment funding sheets.

The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating the commitment funding sheet structure:

- Update Project can be used to create or update the commitment funding structure in the project. If the structure already exists, it will be updated. If not, it will be created.
- Updating the structure in a project will not affect commitment funding sheets that already exist. New sheets will reflect the updated structure.

---

**To update commitment funding structure using Update Project**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Templates > Projects (Standard) > All** in the left Navigator. Open the project template to update.

3) In the Project Template, navigate to **Cost Manager > Funding > Commitment Funding Sheet**.

4) Click **Update Projects** and choose one of the following:

   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects.
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.

   An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.

5) Click **Yes** if you want to proceed with the update, or **No** to cancel.

---

**Update cash flow curve properties and permissions**

You can push cash flow detail curve properties and permissions from a project template to a project.
The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:

About updating cash flow curve properties:

- Both detail curve properties and permissions are pushed from the template to the project.
- Cash flow detail curves are identified by name.
- If a detail curve with the same name exists in the project, it will be replaced. All properties, including detail level and time scale, and permission settings will be updated.
- If a detail curve with the same name does not exist in the project, a new one will be created.
- Users and groups will be added if they do not exist. If a group is created, it will be empty.
- In order to push a curve, the destination project must have a cost sheet.
- Commitment detail level curves will not be pushed.
- A Summary WBS curve cannot be pushed to a project where the cost sheet is flat.
- After a successful update, the updated destination curves will be refreshed.

To update cash flow properties and permissions using Update Project

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) > All in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to Cost Manager > Cash Flow.
4) Add a cash flow curve to the project template, or select one to edit. Define properties and permissions.
5) Select a curve from the Cash Flow log.
6) Click Update Projects and choose one of the following:
   - Projects: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - All Projects: updates all projects.
   - History: allows you to view the update history from past updates or cancel a request before the update begins.
   An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
7) Click Yes if you want to proceed with the update, or No to cancel.
Update project cost or fund rules

Project cost or fund rules can be updated using this functionality.

The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:

About updating rules:

- Both active and inactive rules can be pushed.
- Rules are identified by the combination of rule name and the source.
- If the rule does not exist, it will be added.
- If a rule already exists with the same name and source, that rule will be updated. This includes the status: for example, if the rule being pushed is active, and the rule in the project is inactive, the system will update the existing rule and activate it.
- It is possible to have more than one rule with the same name and source in a project/shell or template. If two or more rules already exist with the same name and source as the rule being pushed, the update will not occur and will give an error.
- When the update process begins, the system will first attempt to validate each rule (equivalent to clicking the Validate button). This will occur whether the rule is active or inactive in the template. If the rule is validated successfully, the system will proceed with the update.
- If the rule fails validation, the rule will not be pushed. The attempt will be captured in the History.

To update rules using Update Project

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Projects (Standard) > All in the left Navigator. Open the project template to update.
3) In the Project Template, navigate to Cost Manager > Rules.
4) Select one or more rules from the log.
5) Click Update Projects and choose one of the following:
   - Projects: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - All Projects: updates all projects.
   - History: allows you to view the update history from past updates or cancel a request before the update begins.

An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.
6) Click **Yes** if you want to proceed with the update, or **No** to cancel.

### Update gates setups

You can update projects with Active or Inactive Gates setups. The Update Project process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating Gates setups:

- The Gates setup update will completely overwrite any existing Gates setup, or will be added if it did not previously exist.
- Previously scheduled Gates runs are overwritten by the new Gates setup. If the pushed setup is Active new scheduled Gates runs are scheduled according to the schedule in the new setup.
- Both Inactive and Active Gates setups can be pushed in the update.
- After update the Gates setup reflects the status of the template.
- After the update, the Current Phase in the Gates setup is reset to the First Phase.
- After the update, Gates projects will not execute the scheduled refresh if the project is On-Hold. Gates scheduling will resume automatically when the project becomes Active.
- If you have permission to create Gates setups, you can update Gates setups using Update Project, even if you do not have permission to access the individual projects.
- Users and groups specified in the Email Notification field are added if they do not exist.
- Newly-created groups are empty.

### To update Gates setups using Update Project

1) Go to the **Company Workspace** tab and switch to admin mode.

2) Click **Templates > Projects (Standard)** in the left Navigator. Open the project template to update.

3) In the project template, click **Setup and select Gates**.

4) Select a Gates setup.

5) Click **Update Projects** and choose one of the following:

   - **Projects**: allows you to choose which project(s) to update. You can use Find to search for specific projects to select from the complete list of projects. You can select as many projects as you want to update. The Page and Display fields display on the Project Update window, but are disabled in this case.
   - **All Projects**: updates all active and on-hold projects.
   - **History**: allows you to view the update history from past updates or cancel a request before the update begins.
An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a project is updated, this action cannot be undone.

6) Click Yes if you want to proceed with the update, or No to cancel.

### View update history
You can view details about previously updated project modules.

#### To view Update Project History
1) In the Project Template, navigate to the module to view the update history.
2) Click the **Update Projects** button and choose **History**. The Update Projects: History window opens. It lists any previous incidents of using Update Projects.
3) Select an instance from the list and click **Open**. The History Details window opens, detailing the module information that was updated. History Details displays:
   - **Requestor**: User who initiated the update process
   - **Projects**: Either user-selected or all projects
   - **Submitted date**: When the update request was submitted
   - **Start date**: When the update process started
   - **End date**: When the update process ended

### Cancel a project update request
You can cancel an update request that has not yet started; that is, any request that does not have a status of In Process or Finished.

#### To cancel a project update request
1) In the Project Template, navigate to the module in which you want to cancel the update request.
2) Click the **Update Projects** button and choose **History**. The Update Projects: History window opens.
3) Select an update that has not yet started.
4) Click **Cancel Request**.

### Managing Member Companies
If your company has set up Partner Companies, those companies can become eligible to be added to projects. When added to a project, these companies become Member Companies, and their users can participate in projects with any permission level you set for them.

**Note**: The list of eligible partner companies is maintained in the Partner Companies log. In Administration Mode, navigate to **Company > Partner Companies** to view the list.
Add a member company to a project

Active partner company users (users with a unique Unifier user name, and status of Active or On Hold) can be added to projects and assigned permissions, just like sponsor company users. See Add a user to a project (on page 253) for more information.

To add a member company to a project

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Projects > [project] > Member Company in the left Navigator. The Member Companies log opens.
3) Click the Add button. The Add Member Companies window opens. This window lists the available partner companies that can be added to the project as a member company. You can click the Find button to search for a particular company by Company Name or Contact Name.
4) Select one or more companies from the list and click the Add Member button.
5) At the confirmation window, click Yes. The company is added to the Member Companies log.

View member company profile

To view a member company profile

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Projects > [project] > Member Company in the left Navigator. The Member Companies log opens.
3) Select a company from the list and click Open. The Company Profile window for the company opens. This is a view-only window. This information is maintained by the partner company’s administrator.
4) Click the General tab to view general information, and the Address tab to view contact information.

Remove a member company from a project

You can remove a member company from the project’s Member Companies list. When a member company is removed from a project, users belonging to the member company will be automatically inactivated for that project.

To remove a member company

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Projects > [project] > Member Company in the left Navigator. The Member Companies log opens.
3) Select the company and click the Remove button.
4) At the confirmation window, click OK. This will remove the selected company from the list and inactivate any users who have been added to the project.
Managing Project Users and Groups

This section discusses adding groups and users to projects, managing project groups, and managing project permission levels.

You can use bulk processing to update users in projects. See *Managing users in bulk* (on page 152) for details.

**Add a user to a project**

After you have created a project, you will need to add users to the list of approved project users. Project users can be from your own sponsor company, or from approved member companies.

When adding users from your company to the project:

- To add users from your own (sponsor) company, the user must be either *Active* or *On-Hold* at the company level. When added, the user will automatically be *Active* for the project.
- Users who are *Inactive* at the company level cannot be added to a project.

When adding users from a partner company to the project:

- In order to add a user from a partner company, the company must first be added to the Member Companies list for the project. The user must be either *Active* or *On-Hold* at the company level for their own company. When added, the user will automatically be *Active* for the project.
- The user does not necessarily need to be listed in the Partner Users log at the company level in order to be added to a company. If the user is listed in the Partner Users log, the user must be *Active* or *On-Hold*. If the user is not already in the Partner Users log, they will be automatically added to the list of Partner Users with a status of *Active*.

**To add users to a project**

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **Company SponsoredProjects > [project] > User Administration > Users** in the left Navigator. The Users log opens. The log lists all users that are already part of the project.
3. Click **New**. The User/Group Picker opens.
4. Click the **List Names from** drop-down list at the top of the picker window and choose the company from which to add the new project user.
   - This drop-down lists your sponsor company plus any member companies that have been added to the project. You can click the **Member Companies** node under the project to view the list of available member companies.
5. Select one or more users to add to the project. You can press the Shift or Ctrl keys to select multiple users at once.
6) Click the **Add** button. You can continue to select and add names to the Selected Users portion of the picker window.

7) Click **OK** to add the users to the project. The new users are listed in the Users log.

**Note:** By default, new users will have a status of **Active**. You can change the status or other user detail information selecting the user from the list and clicking **Open**.

---

**To add a user to a project template**

Open the project template and navigate to **User Administration>Users**. Follow the steps above to add a sponsor company or member company user to the template.

---

**View or edit a project user’s profile**

You can edit a project user’s details. These procedures apply to sponsor company users and member company users.

**To view or edit a project user profile**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Company Sponsored Projects > [project] > User Administration > Users** in the left Navigator. The Users log opens.

3) Select a user from the list and click **Open**. The Edit Project User window opens. The window has the following tabs: General, Groups, Permissions and Custom.

4) In the **General** tab, review the contact information for the user as it will appear in the Project Directory. By default, the project address (as defined in the project details) displays as the contact address. You can edit this information as necessary.

   You can also modify the user's project status:

   - **Active**: User is listed in Project Directory, in User/Group Picker, User can log in and participate in the project. New users are Active by default.
   - **Inactive**: If you deactivate a project user, the user’s name will not appear anywhere for selection on any project-related functions. The user will not be able to access the project. Inactivating a user at the project level does not affect their status on other projects.
   - **On-Hold**: User can be added to a project, or assigned as a participant in a business process workflow but cannot sign in.

5) Select the **Show user on the Project Directory** option if you want the user's information to be viewable in the Project Directory.

6) In the **Groups** tab, you can add or remove the project users to a project-level group the same way that you add company users to company groups. Click the Add button to add a group to the user’s list, or select a group and click Remove to remove the user from the group.

7) In the **Permissions** tab, you can assign project-related permissions to the user, by module and mode. For more information about assigning permissions, see Company User Administration. Permissions are described in the **Unifier Reference Guide**.

8) In the **Custom** tab, you can view available custom attributes that may have been added to the user form.
Create and Manage Project Groups

Groups are a way to collect Users together so that adding new team members to the project and assigning permissions can be done quickly and efficiently. For example, groups can be members of the same project team, and/or they can be users who share the same access privileges. At the company level, groups can span projects. At the project level, all members of a group are members of a given project. Different members of a project may have different access to Unifier functionality, depending on their role on the project.

For example, a Finance person might require access to cost modules and reports dealing with finances, but not RFIs or Transmittals and their associated reports. An Executive might require access to Summary financial information, and not the cost BPs.

As users are added to a Group, they will inherit the Group’s permissions. If they are in more than one group, then the highest level of permissions granted in any group for a module will prevail. Permissions are described in the *Unifier Reference Guide*.

When adding users to the group, you can choose eligible users from the sponsor company and any partner company users. The company short name will be listed in the User Picker window next to each user.

Company level groups cannot be copied into a project.

To create a new group

1) Go to the Company workspace tab and switch to Admin mode.
2) Click **Company Sponsored Projects > [project] > User Administration>Groups** in the left Navigator. The Groups log opens.
3) Click **New**. The Groups window opens.
4) Complete the **General** tab:
   a. Group Name: Enter a name for the group
   b. Manager: Click Select and select a user from the User Picker window. This is the person who will be responsible for administering the group.
   c. Description: Enter an optional description for the group.
5) Click the **Members** tab. This is where you add and manage group membership.
   a. Click **Add**.
   b. From the User/Group Picker, select the users to add to the group and click **Add**.
   c. Click **OK**.
6) Click the **Permissions** tab. In this tab, you manage group permission settings. If a user is a member of the group, the user will inherit all group permissions.
   a. Granting permissions to the group is similar to granting permissions to individual users.
   b. Choose the project-related permissions for the group that will apply to all members assigned to this group. Choose permissions by module and mode.
7) In the **Custom** tab, you can view available custom attributes that may have been added to the group form.

To edit group information

1) Go to the Company workspace tab and switch to Admin mode.
2) Click **Company Sponsored Projects > [project] > User Administration>Groups** in the left Navigator. The Groups log opens.

3) Select a group and click **Open**, or double-click the selected group. The Groups window opens.

4) Make changes as necessary and click **OK**.

---

**Grant project user permissions through Project Access Control**

Once you have created a project, assign permissions to the people who need to access the project. You can use Access Control to grant multiple Users or Groups permission simultaneously, rather than editing the properties for each User or Group individually.

**To view or change a project’s access control**

Click **Access Control** in the Navigator. Unifier displays a copy of the Navigator menu in the right pane of the window. In this right pane, you may click on different modules of the Navigator menu to set permissions for those functions.

---

**Generate and print access information report**

You can generate and print an Access Information summary of user and group access (permission settings). The report will display all user and group permissions.

**To generate the Access Information report**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Company Sponsored Projects > [project] > Access Control** in the Navigator.

3) Click the **Access Information** button. The Access Information window opens. It may take several moments to generate the report.

**To print the Access Information report**

1) Generate the **Access Information** report.

2) Click the **Print** button. (When the report is complete, the **Print** button becomes available.)

---

**Setting Up Automatic Status Update**

At the Company level, you can define the setup of the automatic update of project statuses of active projects based on triggering conditions which are defined using various data sources as parameters. For example:

- A selected activity on the schedule sheet is in the Completed status
- A single-record business process record is set to a specified status
- A business process workflow reaches a specified status

Depending on the setup and the conditions that are set, the status of the project can change from Active to a non-active status (On-Hold, View-Only, or Inactive). You can define multiple setups for each project. After you define these setups, they can be used on project or shell instances, or on templates to enable the automatic update of project status.
The data sources that you use in the triggering conditions can be either from project or shell level, or from the Company level. This data sources can be business processes, sheets or attribute forms. You can define the frequency at which Unifier evaluates the conditions to see if a particular active project should change its status, and can define a list of users or groups to be notified when the project status is changed. The highest frequency is daily.

This automatic update of project status can be useful for users that have a large number of projects and want many of these projects to change their status based on certain triggering conditions, and thus the users do not have to search for and modify these projects manually. For example, you can define a setup at the Company level that contains a triggering condition that changes of the status of an active project On-Hold if the project funds consumption exceeds the funds appropriated for that project. This allows the project manager to review the project and take appropriate action. If, in this case, the project manager is able to get additional funding for the project, the Administrator can change the project status back to Active to restart the project activities.

**Note:** Automatic project status update can change the status of a project from Active to an inactive status. If you want the inactive project to status to revert to Active, you must activate the project manually.

**Step 1:** Create setups - general information.

**Step 2:** Verify the order of project statuses.

**Step 3:** Define project status triggering conditions.

**Step 4:** Define the schedule for automatic update of project status.

**Step 5:** Activate the automatic update of project status.

**Step 6:** Define permissions.

### Setting Up Gates

**Before you begin:** Verify the list of project phases resides in the Project Phase data definition pull-down data set. This is the same list that is used when selecting a project phase manually in the project properties window. You can add or modify the default list as needed. This list makes the phases available for any project or project template; for each project or template, you select which of the phases to use. Create any business processes that you plan to use to drive gates conditions and phase completion.

**Step 1:** Define Project Phases. For each project or template, you define the list of project phases to include in the setup, choosing from the entire list in the Project Phase data set.

**Step 2:** Define Gate Conditions. For each phase, define one or more gates conditions. A gate condition is a combination data element and trigger condition that enable transition to the next phase.

**Step 3:** Schedule Gates runs. The gates runs run the validation of gate conditions. You can schedule runs automatically. This is optional.

**Step 4:** Activate the gates setup.

**Step 5:** Define permissions.
Note: If you create a new project by copying a project template or an existing project, any existing gates setup in the source project is copied into the new project, including the gates status. The gates phases are restarted at the first phase in the new project, and the scheduled gates run is activated.

Example of a gates setup and conditions

You will be setting up phases in gates to represent the actual phases of a project. For the project to advance from one phase to another, certain conditions must be met. This example will discuss phases, conditions, and using business processes in the context of the conditions to advance a project from one phase to another.

For example, phases for Project Zero could be:

- Preliminary
- Investigation
- Definition
- Measurement
- Analysis
- Execute
- Control

Previously, you have set up two business processes to use in the conditions for your gates setup. These are:

- **Schedule**: A single record business process that is updated manually by a project manager by checking checkboxes for the various phases such as Definition Phase Complete? or Measurement Phase Complete?
- **Funding**: A workflow business process that is automatically updated through the steps of the workflow.

As the project manager checks the checkboxes in the phases as represented in the Schedule business process, the gates runs keep checking the statuses of the checkboxes. As they are checked off, the project advances to the next phase.

The exception to this procedure is the transition from the Analysis phase to the Execute phase. Additional approval is needed for funding in order for the project to advance from Analysis to Execute. The Funding business process is included in the conditions for the Analysis phase. This business process must have the status Construction Approved and have a value of greater than zero for the Analysis phase to be exited and the Execute phase entered for the project.

Define the project phase list

**To view the project phase list**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure Setup > Data Definitions** in the left Navigator.
3) Select **Basic**.
4) Select the Project Phase data definition and click Open. The Modify Data Definitions window opens.
5) Click the Data Set tab. The active phases on this list will be available for project phase setup.
6) Modify the list as needed. Any changes you make here will be reflected in new gates setups. Current setups will not be affected.

Create a gates setup
You can create a gates setup in project templates, and in individual projects. There can be one setup per project.

To create a new gates setup
1) Go to the Company Workspace tab and switch to Admin mode.
2) Do one of the following:
   - To create the setup in a project template, click Templates > Projects (Standard) in the left Navigator. Open the project template.
   - To create the setup in a project, click Company Sponsored Projects in the left Navigator. Open the project.
4) Click New. The gate setup is created automatically. Double-click the setup, or select from the list and click Open. The Gates Setup window opens. There are three tabs: General, Settings, Schedule.
5) In the General tab, enter a Setup Name, which displays in the log, and an optional Description. At this point, Status is Inactive by default.
6) In the Settings tab, define project phases and gates conditions. For details, see Add project phases to the gates setup (Settings tab) (on page 259) and Configure gate elements (on page 261).
7) In the Schedule tab, you can schedule regular gates. See Define gates runs schedule (Schedule tab) (on page 262).

Add project phases to the gates setup (Settings tab)
Select which of the phases to use in the project or template from the available project phase list. You can reorder them as necessary for the project or template.

To add project phases to the new gates setup
1) Open the Gates Setup window and click the Settings tab.
2) In the Phases pane, click the Add button. The Select Phases window opens, displaying the list of available project phases.
3) Select one or more project phases to add to the list. To select multiple phases, hold down the CTRL or SHIFT keys while selecting.
4) Click OK. The phases appear in the Phases list.
   The order in which the phases appear on the list is the order in which they will be followed in the project. The first phase on the list will be the first phase of the project.
Configure Gates conditions

To access the gate configuration view:

Select a project phase. The gate configure view opens in the right pane. See the following table for more information about the gate configuration view.

The **Phase Gate Configuration** section in the navigator lists the Project Phases for the current Project. The visual order of the Phases depends on the Order specified in the General tab.

The **Gates Conditions Elements** section allows you to define condition criteria per element. Gate Elements will be selected from all Unifier data sources and modules available in a particular project (for the Sponsoring company).

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start Date</strong></td>
<td>The Start date for a particular Phase can be manually set or auto populated from a Schedule Sheet by linking it to a particular activity or milestone (activity with zero duration and marked as milestone) where it will update dynamically based on the start date associated with this activity. If there are multiple Start dates, choose the Start date used to set Gantt Charts in Schedule Manager. The start date must fall within Project date ranges. Note: You cannot choose dates from schedule sheets in the Schedule Manager for generic shells, because the Schedule Manager is not available in generic shells.</td>
</tr>
<tr>
<td><strong>Planned Completion</strong></td>
<td>Can be manually set or auto populated from a Schedule Sheet by linking it to a particular activity or milestone (activity with zero duration and marked as milestone) where it will update dynamically based on the start date associated with this activity. If there are multiple End dates, choose the End date used to set Gantt Charts in Schedule Manager. Note: You cannot choose dates from schedule sheets in the Schedule Manager for generic shells, because the Schedule Manager is not available in generic shells. Note: Dates are for reporting only. Phases cannot be date driven.</td>
</tr>
<tr>
<td><strong>Advance to Next Project Phase...</strong></td>
<td>This checkbox enables automatic phase advancement. Select the checkbox if you want the project to move automatically to the next phase once all Gate Elements for a particular Phase have been checked.</td>
</tr>
<tr>
<td><strong>Notify users on Phase Completion</strong></td>
<td>Allows you to define users who receive phase completion notification. You can configure the body text in the notification (similar to the BP Setup on the End Step, where you can specify the message text content.</td>
</tr>
<tr>
<td><strong>Reevaluate conditions on every Gates run</strong></td>
<td>When selected, this checkbox specifies that processing always starts at the First phase during a scheduled Gates Run/Refresh. You might have to scroll down to see this checkbox.</td>
</tr>
</tbody>
</table>
If the checkbox is unchecked for a phase:
- If the phase is currently incomplete, incomplete conditions are evaluated and completed conditions are skipped
- If the phase is currently complete, phase processing is skipped
- If the checkbox is checked in a phase:
  - Every condition in that phase is reevaluated. Including conditions that were met
  - All conditions (except conditions that were marked as "ignore" manually) are marked as incomplete at the beginning of every Gates run and refresh.

Saved Gates run (PDF) from prior runs persist. Processing will stop at a Phase where first un-met condition is encountered. By default this checkbox is deselected.

---

**Configure gate elements**

**To add a Gate Condition Element**

1) In the Gates Setup window, gate configuration view, select a project phase and click **Add**. The Data Type window opens.
2) Select a **Data Type** from the drop-down.
3) Click **OK**. The Edit Gate Condition window opens.
4) Complete the **General** tab: Enter a Name for the Gate Element. This can be the name of the data element or any descriptive name. This appears on the Gate Conditions Elements list. You can add an optional Description.
5) Click **Apply** to save changes, or **OK** to save changes and exit the window.

**To define query and trigger conditions**

1) In the Edit Gate Condition window, click the **Query** tab.
2) Under Query Conditions, click **Add**. The Query Condition window opens.
3) Complete the **Query** tab:
   - **Data Element**: Click the Select button. The Data Element Picker opens. The list is generated from the data type you chose in the General tab. If the data element is a picker, pull-down or radio button, the Value field will display the values entered in the data set tab of for the data definition associated with the data element. For a full list of data elements and data types, refer to the *Unifier Reference Guide*.
   - **Label**: The label defaults to the data element name. You can enter a different label.
   - **Condition**: Define Gate Condition Element Condition. The condition options vary dynamically depending on the selected Data Element. The screen shots below list out the various options for different Data Element types. Examples include equals, does not equal.
Values: Specify value. The Values field varies dynamically depending on the selected Data Element and Condition. (For example, if the element is a text box, the condition might be Contains, and value might be one or more letters to search for. If the element is a pull-down or other data definition with a data set, you will select a value from the data set.)

**Change the order of project phases**

**To change the order of the phases in a gates setup**

Select a phase and click the Move Up or Move Down button.

**Define gates runs schedule (Schedule tab)**

You can define a gates run schedule in the Gates Setup window, Schedule tab. This run evaluates gates conditions, and marks completed conditions as Complete. The update process can also be invoked manually in user mode. The scheduler engine is a background process.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Scheduled Gates Runs</td>
<td>Select this checkbox to enable scheduled updating of Gate Elements. Deselecting this checkbox will disable the scheduler, and any scheduled future runs will be canceled immediately. The scheduled gates runs are disabled in the last phase provided all conditions are met, and the Enable Scheduled Gates Runs checkbox is automatically deselected.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Choose Frequency of the Scheduled Gates Runs (Daily, weekly, monthly, quarterly, yearly)</td>
</tr>
<tr>
<td>Range of Recurrence</td>
<td>You can specify a date on which the Gate Runs will end, or no end date.</td>
</tr>
<tr>
<td>Auto-email as PDF Attachment to Gates creator</td>
<td>Select this checkbox to enable automatic emailing of the scheduled run results as a PDF attachment. The report displays the current status of each project phase and gate condition.</td>
</tr>
</tbody>
</table>

**Activate or deactivate a gates setup**

Activating a gates setup will enable the scheduled gates runs. After activation, if you need to edit the gates set up, you will need to deactivate it first.

You can make edits while the setup is inactive, including: adding or removing phases; reordering phases; add, modify or remove conditions within a phase.

Some notes about activating/deactivating gates setup:
Reactivating an active project: If you temporarily deactivate a project that is in process, and then reactivate it, the gates check will start over at the first phase. This is because the setup needs to check all phases for new phase additions or new gate conditions that may have been added. You can manually update the project phases by clicking the Refresh button for gates in User Mode. This will evaluate all phases starting from the first phase, even if the phase has been marked Complete, and mark the first phase as the current phase. Note: be aware this may trigger email notifications regarding gates advancement, as set up in the Settings tab (where the users who are notified are defined), and those users’ email subscription settings (User Preferences).

While a gates set up is inactive: No scheduled gates run will be done. To manually advance phases in User Mode Gates for the project, the gates setup must be active.

View-Only and Inactive projects: If a project has View-Only or Inactive status, the gates setup is inactivated, and you must manually reactivate the setup.

Set user permissions for gates

To grant User Mode Gates permissions:

In Access Control or Permissions window, navigate to User Mode > Shells/Projects (Standard) > Gates. The permissions are:

- **Change Phase**: Allows the user to change gates phases.
- **Modify and Refresh**: Allows the use to modify gates and refresh gates.
- **Refresh**: Allows the user to refresh gates.
- **View**: Allows the user to view gates.

Create an automatic project status update setup

Multiple setups can be defined at the company level and then used to configure individual projects.

**To create a new project status update setup**

1) Go to the Company Workspace tab and switch to Admin mode.


3) Click New. The Auto-update Status Setup window opens. There are three tabs: General, Settings, Schedule.

4) In the General tab, enter a Setup Name, which displays in the log, and an optional Description.

5) In the Settings tab, define the order of the non-active statuses and the status change query and trigger conditions. For details, see *Choose the order of non-active statuses (Settings tab)* (on page 264) and *Define status change query and trigger conditions (Settings tab)* (on page 264).

6) In the Schedule tab, you can schedule the shell status update. See *Define project status update schedule (Schedule tab)* (on page 265).

7) Once you have defined the setup, you must activate it to be able to apply it to a project. See *Activate or deactivate an auto-update status setup* (on page 265).

**Note**: You must deactivate a setup to be able to modify it.
Choose the order of non-active statuses (Settings tab)

By default the order of the listed statuses is On-Hold, View-Only, and Inactive. These are listed on the left side of the Settings tab in the Status pane. You can change the order using the Move Up or Move Down buttons. You can change the order of the non-active statuses. The order of the statuses is significant because the triggering conditions for the statuses are evaluated in the order in which they are listed on this tab, with the verification of the triggering conditions occurring for each condition listed in turn.

For example, if the conditions for the first listed status are not met, then the conditions for the next listed status are evaluated. If the conditions for that status are not met, then the triggering conditions for the third status conditions are evaluated. As soon as the first match occurs, Unifier will automatically change the project status and does not perform further evaluation.

To reorder non-active project statuses
1) Open the Auto-update Status Setup window and click the Settings tab.
2) In the Status pane, select the status you want to move.
3) Click the Move Up or Move Down button to reposition the selected status.
4) Click Apply to save changes, or OK to save changes and exit the window.

Define status change query and trigger conditions (Settings tab)

The Conditions Elements section allows you to define condition criteria per element. Elements can be selected from all Unifier data sources and modules available at the Company level.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notify users and groups on Status change</td>
<td>Allows you to define the users and groups who will receive status change notification.</td>
</tr>
<tr>
<td>Email content</td>
<td>Enter the content of the email you want to send to notified users and groups. This content appears in the Additional Information section of the email.</td>
</tr>
</tbody>
</table>

To define query and trigger conditions
1) Under Conditions Elements, click Add.
2) Select a Data Type, and click OK. The Query Condition window opens.
3) Complete the General tab by entering a name for the query and a brief description. The Data type and Element is auto-populated from the selection you make on the Query tab.
4) Click the Query tab.
5) Click Add.
6) Complete the Query tab:
   - Data Element: Click the Select button. The Data Element Picker opens. The list is generated from the data type you chose in the General tab. If the data element is a picker, pull-down or radio button, the Value field will display the values entered in the data set tab of for the data definition associated with the data element. For a full list of data elements and data types, Refer to the Unifier Reference Guide.
Unifier Administration Mode

- **Label**: The label defaults to the data element name. You can enter a different label.
- **Condition**: Define Gate Condition Element Condition. The condition options vary dynamically depending on the selected Data Element. The screen shots below list out the various options for different Data Element types. Examples include equals, does not equal.
- **Values**: Specify value. The Values field varies dynamically depending on the selected Data Element and Condition. (For example, if the element is a text box, the condition might be Contains, and value might be one or more letters to search for. If the element is a pull-down or other data definition with a data set, you will select a value from the data set.)

7) Select the trigger conditions.
8) Click **OK**.

### Define project status update schedule (Schedule tab)

You can define a schedule to check the conditions for the automatic update in the Auto-update Status Setup window, Schedule tab.

The maximum frequency that Unifier will verify whether triggering conditions are met is daily. If you have a need for greater frequency of verification, you must monitor the project with the project manager and then change the project status manually as needed. For example, if the triggering condition verification is performed in the morning, and the project funds are being spend during the course of the day, the project could exceed its budget before the condition verification occurs the next morning, and the project status is automatically changed.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Scheduled Runs</td>
<td>Select this checkbox to enable scheduled evaluating of the automatic update status. Deselecting this checkbox will disable the scheduler, and any scheduled future runs will be canceled immediately. The scheduled evaluation is disabled for the last status in the list, provided all conditions are met, and the Enable Scheduled Runs checkbox is automatically deselected.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Choose Frequency of the Scheduled Runs (Daily, weekly, monthly, quarterly, yearly)</td>
</tr>
<tr>
<td>Range of Recurrence</td>
<td>You can specify a date on which the Scheduled Runs will end, or no end date.</td>
</tr>
</tbody>
</table>

### Activate or deactivate an auto-update status setup

You must activate a setup in order to be able to apply it to a project.

**Note**: You must deactivate a setup to be able to modify it.
To activate or deactivate a project status update setup
1) To activate or deactivate a new setup to use in projects, go to the Company Workspace tab and switch to Admin mode.
3) Select a setup in the log.
4) Click the **Status** button. You can choose **Active** or **Inactive**.

Set permissions for automatic update of project status

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode Access > Company Workspace > Auto-update Status Setup**. The permissions are:
   - **Create**: Allows the creation of new auto-update status setups, edit existing auto-update status setups and activate or deactivate auto-update status setups.
   - **Modify**: Allows the edit existing auto-update status setups and activate or deactivate auto-update status setups. This permission excludes the ability to create a new auto-update status setup.
   - **View**: Allows viewing of existing auto-update status setups.
Program Administration

The following section describes how to create and manage programs.

In This Section

Creating and Managing Programs ................................................................. 267
Creating a Program .......................................................................................... 267
Defining Program Properties ............................................................................ 268
Program User Administration ........................................................................... 270

Creating and Managing Programs

Programs are a way to group like projects or WBS shells together (or projects and shells in combination). Programs allow consolidation of financial, schedule and status data across projects or shells. They are created at the company level in Admin mode. An administrator typically grants permissions to other project or shell team members who will modify an existing program and generate specific project or shell data. For example, a project or shell team member may modify a program to produce high-level forecasting data or to generate program reports based on a project's cost, schedule, and status data.

Although the Company Administrator creates the program, rights are typically granted to project or shell members who will then modify the existing program and generate specific project or shell data.

For example, a project or shell team member may modify a program to produce high-level forecasting data or to generate program reports based on the project cost, schedule and status data for one project or shell or across several projects or shells.

Creating a Program

To create a new Program:

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Programs in the left Navigator.
3) Click New on the button bar. The Program window opens.
4) Complete the tabs. This defines the program properties:
   - **General**: Define general properties
   - **Shell/Projects**: Add projects and shell to the program
   - **Progress**: Track progress of the program
   - **Links**: Add your own web page links, which appear on the Program home page
   
   See the following section for details.
5) Click Apply to save changes, or OK to save and exit the window.
Defining Program Properties

You can define program properties when you first create a program, or open an existing program.

Define Program General Properties (General tab)

To access program properties:

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Programs** in the leftNavigator.
3) Select a program from the log and click **Open**. The program properties landing page opens.
4) Click **Open** to open the Program window.
5) Use the information in the following table to complete the General tab.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program Number</td>
<td>Enter a number for the program.</td>
</tr>
<tr>
<td>Setup Date</td>
<td>This field is populated with the program creation date.</td>
</tr>
<tr>
<td>Program Name</td>
<td>Enter a name for the program.</td>
</tr>
<tr>
<td>Description</td>
<td>(Optional) Enter a description of the program or projects or shells within it.</td>
</tr>
<tr>
<td>Administrator</td>
<td>Click <strong>Select</strong> and select an administrator from the list. Each program must have an administrator.</td>
</tr>
<tr>
<td>Image</td>
<td>(Optional) You can click <strong>Browse</strong> and select an image file. This image will appear on the Program Home Page.</td>
</tr>
<tr>
<td>Program Category</td>
<td>If a program category data definition has been setup, you can select it here.</td>
</tr>
<tr>
<td>Status</td>
<td>Select a status.</td>
</tr>
</tbody>
</table>

Add or Remove Projects or Shells From a Program (Projects tab)

You can add any Active or On Hold project to a program. Inactive projects are not eligible.

To add a Projects/Shells to a program

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Programs** in the left Navigator.
3) Select a program from the log and click **Open**. The program properties landing page opens.
4) Click **Open** to open the Program window.
5) Click the **Projects/Shells** tab.
6) Click **New**.
7) Select one or more projects or shells and click the Add Project/Shell button. To select multiple projects or shells, hold down the Ctrl or Shift key while selecting.

8) In the Program window, click Apply to save, or OK to save and exit.

To remove a Projects/Shells:
On the Projects/Shells tab, select the project or shell and click Remove.

**Set Up Program Progress Tracking (Progress tab)**

You can enter a start date and planned completion dates for a program by manually entering the dates, or by linking the program to the project or shell schedule sheet. To use the Schedule Manager options, a schedule sheet must be defined in your project or shell. As changes are made in the Schedule Manager, they will automatically change the progress indicator in the Progress tab.

Progress indicators linked to the schedule are:

- Start Date
- Planned Completion
- Revised Completion

To track the progress of a program manually:

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Programs in the left Navigator.
3) Select a program from the log and click Open. The program properties landing page opens.
4) Click Open to open the Program window.
5) Click the Progress tab.
6) Complete the fields. See the following table for details.
7) Click Apply to save the changes, or OK to save and exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Start Date    | Choose one of the options:  
Manual: Manually enter the project or shell start date by clicking the calendar icon.  
From Schedule Manager: Click the selection list and choose a data column from the list (for example, Program Start Date). The Program Schedule Sheet must be created and setup before selections become available. |
| Planned Completion | Choose one of the options:  
Manual: Manually enter the project or shell start date by clicking the calendar icon.  
From Schedule Manager: Click the selection list and choose a data column from the list (for example, Program Due Date). The Program Schedule Sheet must be created and setup before selections become available. |
Choose one of the options:

- **Manual**: Manually enter the project or shell start date by clicking the calendar icon.
- **From Schedule Manager**: Click the selection list and choose a data column from the list. The Program Schedule Sheet must be created and setup before selections become available.

**Notes**

Program notes can be anything that the Administrator feels is relevant to share with other Project or Shell Administrators. This note is not displayed on the Summary or Home Page.

---

### Add Links to Other Program-Related Web Pages (Links tab)

Links are displayed on the Program home page.

**To add a link**

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Programs** in the left Navigator.
3. Select a program from the log and click **Open**. The program properties landing page opens.
4. Click **Open** to open the Program window.
5. Click the **Links** tab.
6. Enter a name for the link and the link’s URL.
7. To add more links, click the **Add Row** button and repeat step 5.
8. When you are finished, click **OK**.

### Program User Administration

The **User Administration** node appears below the new program name in the Navigator once it is created and activated.

As projects or shells are added to programs, the users and groups are not automatically added to the program. By default, the Program Administrator chosen during the program setup is added as a program user. The Program Administrator group is automatically added as a default group, and the program administrator is added to the group by default. You can add additional users and groups to the Program and set permission levels.

### Add Users or Groups to a Program

To add users or groups to a program via the Company Workspace:

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click the **User Administration** node for your program in the left Navigator.
3. Click **Users** to add users, or **Groups** to add groups to the program.
Unifier Administration Mode

**Note:** If a User Attribute form has been imported, the program user log will reflect the design of any designed Partner Log included in that form. See *Importing User Attribute Form* (on page 135) for details.

4) Click **New** on the button bar. The standard User/Group Picker window opens.

5) Select a **Company** from the **List Names from:** list box and Users or Groups from the **Show By:** list box.

6) Select the users/groups to include in the Program and click **Add**. You can also create a new group by highlighting the Groups node and selecting **File > New** or the **New** button.

7) When you are done adding users and groups, click **OK** to return to the Users or Groups log.

---

**Grant Program Permissions (Access Control)**

Granting program permissions entails granting users access to the modules in the program, such as the Schedule Manager or cost sheets.

**To grant user/group permissions to the program**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Access Control** in the left Navigator.

3) On the right pane, select **User Mode Access > Programs > [module]**. The Permission Settings window opens.

4) Click the **Add** button. The User/Group Picker opens.

5) In the picker, specify a user or group and select the Permission Settings.

6) Click **OK**, then click **OK** in the Permission Settings window.
Importing and Deploying a Design

uDesigner Overview

uDesigner is a functional module of Unifier and is enabled automatically when Unifier is installed. The uDesigner module is used to create:

- Business Process (BP)
- Managers (Asset - Cost - Document - Planning - Portfolio - Resource - Schedule - Space - Shell)
- Configurable Modules
- Attribute Forms (Users, Shells, Document Manager, Cost)

You can use the uDesigner module to create, configure, setup, and test all designs in the Unifier Staging environment, and after you test the designs, you can import the designs to another environment, such as Unifier Production, by way of design bundles.

Notes:

- You can select the Unifier environment in the Unifier Configurator. Unifier Staging environment is a Unifier server deployed without selecting the "Production" configuration checkbox in the Configurator.
- Staging is a testing environment that replicates the Unifier Production environment. It must be set up just like production. An object (for example a BP) can be deployed multiple times in the Staging environment.
- Users with permission have access to uDesigner (Staging or Production). In Staging environment, all uDesigner functionalities are available, but in Production environment the uDesigner functionalities are limited.
- See the Internationalizing Unifier Environments (Staging and Production) section for translation information.

When deploying your designs using Design Bundles, it is important to note the version numbers:

- A deployed version indicates that the design has been tested in the Staging environment.
- A published version indicates that the design has been imported, or the design has been imported into the Production environment for the first time.

Design bundles can include designs for business processes as well as managers.

During design bundle creation, uDesigner goes through all the logs (both business process and manager logs) and compares the last published version of each design with the deployed version number. If the deployed version number is greater than the published version number, uDesigner collects the design for the bundle.

When you import a design bundle (the Import function in the Design Bundle node), Unifier runs an error check on all the designs in the bundle. This error check ensures that:

- Business processes that are referenced in the tested business process have been imported.
Business process pickers are referenced correctly.
A workflow is defined for workflow business processes.
When a link auto-creates a business process, the auto-created business process has been imported.
All edit and view forms that appear in the workflow steps are included.
Trigger elements are defined in conditional steps.
Statuses, including terminal statuses, are properly defined.
Formula fields are properly defined.
Auto-populated fields are properly defined, and referenced processes are present.
Form validation rules are correctly defined.

**Note:** When you bundled the designs in the uDesigner Staging area, you should have saved the zip file containing the design bundle on your desktop or local system.

To import and deploy a design:

1) Go to the **Company Workspace** tab and switch to **Administration Mode**.
2) Click **uDesigner > Design Bundles** (in the left Navigator) to open the Design Bundles log.
3) Click **Import** to open the Import window.
4) Provide a brief description, click **Browse**, select the file that you want to import, and click **OK**. The file name appears in the Design Bundles log. The import is complete.

**Note:** Exported Production Bundles can only be imported into Unifier Production environment.

Unifier imports the design bundle and sends the designs to the **Configuration** node in the left Navigator. The designs are will appear in the **Configuration** node in their respective logs: for example, business processes will be in the Business Process log, and shells will be in the Shell Manager log. Once you have imported the design, you must configure it. For instructions on configuring the component, see **Configuring Business Processes (BPs)** (on page 355) or the setup topic for the appropriate manager:

- **Configuring Shells** (on page 281)
- **Configuring the Asset Manager** (on page 431)
- **Configure configurable manager classes** (on page 450)
- **Creating a Default Structure for the Planning Sheet** (on page 574) and **Configuring the planning type** (on page 579)
- **Configure the Portfolio Manager** (on page 586) and **Create Period Structures** (on page 585) for the Portfolio Manager
- **Configure the Resource Manager at the company level** (on page 594) and **Setting up the Resource Manager in Projects or Shells** (on page 599)
- **Setting up the Schedule Manager** (on page 603)
- **Cost Manager Setup** (see "**Setting Up the Cost Manager**" on page 457)
**Check for errors**

If you prefer, you can error check the designs before you import and deploy a design bundle. To error check a design bundle before importing:

1) In the left Navigator, click **uDesigner > Design Bundles**.
2) Click the **Error Check Staging Bundle** button on the tool bar and choose **Import**.
   
   uDesigner performs an error check on the designs in the design bundle. If it finds any errors, an error window opens describing the errors.

**Re-Deploy a design**

If you find that a design was not imported correctly, you can re-deploy the individual design. To re-deploy a design:

1) In the left Navigator, click:
   - **uDesigner > Business Processes** to re-deploy a Business Process design
   - **uDesigner > [manager name]** to re-deploy a manager design

2) In the log on the right, select the design you want to re-deploy.
3) Click **Deploy** in the toolbar.
   
   Unifier deploys the design and sends it to the **Configuration** node in the left Navigator.
Exporting a Design

Once the designs are completed and tested by the user in the Staging environment, the user can transfer the designs into the production environment by way of design bundles; however, the user must first create the design bundles in the Staging environment, export them to a local directory, and then transfer them into the production environment.

**Note**: See the *Internationalizing Unifier Environments (Staging and Production)* section for translation information.

To export designs to another environment:

1) Go to the **Company Workspace** tab and switch to **Administration Mode**.
2) Click **uDesigner > Design Bundles** in the left Navigator. The Design Bundles log opens.
3) Click the **Export Staging Bundle** button to open the Publish window.
4) In the File Name field, enter the file name that you want to export, provide a brief description, and click **OK**. The file name appears in the Design Bundles log. This is a .zip file.
5) Select your file, click **Download**, and save the file in a desired location. The designs are now ready to be exported to the production environment.
Shells Administration

You can use a Shell to organize the information about projects, or facilities, in one place. A Shell includes functions and features that are necessary for managing the information about projects, or facilities, within that Shell. A Shell does not require to function like a Project.

In This Section

Dedicated Mailbox for the Shell ................................................................. 279
User Permissions and Navigation .............................................................. 280
Setting up Shells ..................................................................................... 280
Setting Up the Automatic Update of Shell Status ...................................... 323
How to set Up Gates ............................................................................... 327
Editing Multiple Shells at once with Bulk Edit ......................................... 333
About Shell Dashboards .......................................................................... 334
Migrating standard projects to WBS shells .............................................. 337
Internationalization and CSV Files .......................................................... 343
Internationalization and Web Services ...................................................... 347
Internationalization (Email Notifications) .................................................. 348
Internationalization (Support for Tools) .................................................... 348
Internationalization (BI Publisher Custom Reports) .................................. 349
Internationalization (Dashboards) ............................................................. 350
Internationalization (Help Files) ............................................................... 350
Internationalization (Spell Check) ............................................................ 350
Internationalization (Date and Time Zone Formats) ............................... 351
Internationalization (Audit Log) ............................................................... 351

Dedicated Mailbox for the Shell

External emails are important communications that need to be included in shells. Such emails can come from project team members or from external users who do not use Unifier. These email communications (and any attachments) can be collected in a central repository for the shell, called a Mailbox. Once such emails reside in the shell’s Mailbox, users can view them, forward them to appropriate members, flag them for review, and reply to them. In addition, these external emails can be linked to business process records.

**Note:** External emails that have been blind carbon-copied (Bcc) are not collected by the Mailbox.

When Unifier is installed on your system, a dedicated email address for your company is specified, and whenever a shell is created, Unifier assigns it a unique identifier. Unifier combines this email address and shell identifier to create the shell’s Mailbox.
Note: To prevent spam and virus attacks, you will need to create a list of approved email addresses that will be accepted by the shell. See *Creating an Approved Email List for Project and Shell Mailboxes* (on page 157) for more information.

When you create a shell, you can notify all shell participants, both within and outside of Unifier, of the shell's email address. See *Create a new shell manually* (on page 293).

### User Permissions and Navigation

Navigation from the Landing Page to a specific place in the sub-shell hierarchy requires permissions. Permissions can be:

- Granted on an instance-by-instance basis
- Pushed through shell templates
- Users can be managed through groups or added individually to instances

### Setting up Shells

**Before you begin:** Shells types must be designed in uDesigner.

**Step 1:** Import shell types. Import into Unifier the shells that were designed in uDesigner.

**Step 2:** Set permissions to configure the shells in the Shell Manager.

**Step 3:** Configure imported shells in the Shell Manager.

**Step 4:** Set permissions to administer shell templates, which you can use to create shells for projects.

**Step 5:** Create shell templates.

**Step 6:** Set permissions to add or modify shells.

**Step 7:** Create new shells for user projects.

Note: You will set permissions at several points during shell setup, in order to be able to access, or to grant access to, various aspects of working with the shell.

### Importing Shells

All designs, including shell designs, are designed in uDesigner and deployed to Unifier. See the instructions in the topic *Importing and Deploying a Design* (on page 273).

Note: Importing Forms that Contain Data Pickers: Data pickers point to a data source for the records they display. If that data source—the BP, shell, space, planning item, or manager class—to which the picker is pointing is not already in Unifier, you will receive a warning. The business process will not operate correctly until the data source is imported.
Setting Permissions to Configure Shell Types in the Shell Manager

To set permissions to configure shell types in the Shell Manager:

1) In Administration mode, go to the Company Workspace tab and click Access Control in the left Navigator.
2) On the right pane, select Administration Mode Access > Configuration > All > Shell Manager.
3) See Edit user or group permissions using Access Control (on page 160).
4) Click OK.

Configuring Shells

Configuring a shell consists of activating it and organizing it into a hierarchy.

Note: Before you configure shells it is worthwhile to plan the shell hierarchy with your users and uDesigner user. The instance, and cost settings affect how you will use the shell and its relationship to other shells. Planning will help you achieve the result that will meet your business needs.

To configure the shell types in the Shell Manager

1) Go to the Company Workspace tab and switch to Administration Mode.
2) Click Configuration > Shell Manager in the left Navigator.
3) Select a shell type and click the Open button. The Configuration <shell name> window opens.
4) Complete the General tab as described in the first table below.
5) Click the Organize tab. On this tab you can specify the sub-shell types that are allowed under a shell type.
   This tab is where you establish the shell hierarchy, by selecting allowed sub-shells. For example, assume you have configured a shell called Region, which has the sub-shell types Properties and Buildings. Also, Properties has Buildings as a sub-shell. Unifier performs validation during shell configuration, and manages the relationships among the shells that you configure. The second table below shows the relationships among the shells described above. Click the Add button to add sub-shell types from the list of imported shells. You can add sub-shell types to the sub-shell type you are currently configuring. Click Add and select the sub-shell types to add. Select the types to add, and click OK. You can only add shells that have the Active status.
6) Select the Active checkbox for the sub-shell types you want to activate. You can deactivate sub-shell types that you do not want users to use for sub-shell instance creation. You can deactivate sub-shell type even if sub-shell instances have been created with that type.
   Note: You can remove a sub-shell type from the list by clicking Remove, as long as an instance of the sub-shell type is not created under the shell.
7) Click Apply to save changes as you enter information, and OK when you are ready to save information and exit the Configuration window.
8) Complete the configuration steps for each shell type.
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable automatic numbering</td>
<td>Select to allow automatic numbering of projects based on the specified Format and Start values. You can deselect this checkbox to disable automatic numbering. This checkbox is selected by default.</td>
</tr>
<tr>
<td>Format/Start</td>
<td>Specify the format and starting number for projects if automatic numbering is enabled. Format determines the format of the numbering schema. Start determines the starting number of the numeric schema. By default, Format is blank and Start is 0001. The numbering schema format cannot be changed after a user creates shell instances using the originally specified format.</td>
</tr>
<tr>
<td>Cost Codes: WBS/Generic</td>
<td>Displays the type of cost code specified in uDesigner for the shell type.</td>
</tr>
<tr>
<td>Status</td>
<td>Status can be Active or Inactive. Users cannot access shells types with the status Inactive. The default is Inactive. If a shell type is Inactive, users cannot create shell instances of that type.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Shells-</th>
<th>Parent</th>
<th>Child</th>
<th>Grandchild</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sub-shells that are allowed</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Parent</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Child</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Grandchild</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

Shell Manager Production Bundle Configuration

The following configurations can be included in the Shell Manager Production Bundle:

- General setup
  - All the fields included in the General Configuration (General tab).
- Organize setup
  - All the fields included in the Organize tab.

Notes:

- The sub-Shells defined in the Shell hierarchy are also included in the Production Bundle.
The sub-Shells defined in the Organize tab are included in the Design Bundle if all the defined Shells are tagged (as Production) in uDesigner.

You can export the sub-Shells when all sub-Shells are tagged (as Production) in uDesigner, only.

For more information, see the Production Bundles (on page 197) section in this guide.

Setting Permissions to Administer Shell Templates

Setting Shell Template administration access:
1) Go to the Company Workspace tab and switch to Administration Mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select Administration Mode Access > Templates > Shells [shell node].
4) See Edit user or group permissions using Access Control (on page 160).
5) Click OK.

Creating a Shell Template

From the Shells node under Templates, you can access the shell type templates that are created. One node is created under Shells for each shell type that is imported and that has an active configuration status.

Note: Single-instance shells are not listed under Templates > Shells as there can only be one instance created for those shell types, and there is no need of a template.

To access shell templates
1) Go to the Company Workspace tab and switch to Administration Mode.
2) Click Templates > Shells in the left Navigator.
3) Expand the Shells node. Any shell templates are grouped by shell types. Note that one node is created for each shell type imported.
4) Click one of the shell type nodes. The Shell Templates log opens. The log lists any shell templates that have been created for that shell type.

Create a shell template

The following procedure describes how to create a shell template.

To create a new shell template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
   Expand the Shells to display the shell types.
3) Click one of the shell type nodes. The <shell> Templates log opens. The log lists any shell templates that have been created under that particular shell type.
4) Click the **New** button. The <shell> template Details window opens.

5) The General tab you see will depend on the Shell Attributes form that was imported. In the General tab, complete the fields as described in the table below:

6) In the Currency tab, click the **Add** button. The Edit Exchange Rate window opens.

   **Note:** The Base Currency shown at the top of the Edit Exchange Rate is the Base Currency set up for your company. For example, if yours is a U.S. company, the Base Currency will likely be United States Dollar (USD). If your company does business internationally, you may make other currencies available for shell use.

   a. Complete the Edit Exchange Rate window:
      - Click the **Select** button.
      - Select a currency from the list and click **OK**. The available currencies are defined at the time your company was set up. (The currency list is maintained in Standards & Libraries > Exchange Rate.) Contact your Company Administrator if you need additional currencies.

   b. If the currency you selected is other than the company Base Currency, then complete the following:
      - **Rate:** enter an exchange rate to use for conversion calculations. From the drop-down list select one of the following:
        - If **Float** is selected, the rate comes from the company active exchange rate set (Standards & Libraries > Exchange Rate).
        - A **Peg rate** is locked at the rate set. (Only an administrator can change the Peg rate, or Peg to Float or Hedge).
        - If the **Hedge** selection is **Yes**, then the **Hedge rate** is used. Otherwise, the Float rate will be used. If an amount is entered for the Rate, then the hedge rate is used until the amount specified is reached (by spends) and then the system will revert back to the active exchange rate.
      - Click **OK** to save and exit the Edit Exchange Rate window.

   c. Select a **Default Currency** from the drop-down list. This will be used as the default shell currency. Once you have selected a shell currency and saved the template or shell, it cannot be changed. The selections are generated from the Currencies list you defined.

      **Note:** You cannot modify this default currency after you save the changes to the template Detail window.

7) In the **Options** tab, you can upload an image file. This image is displayed on landing page of the shell in both Administrator and User Modes. Click **Browse** to browse for the image file and then click the **Add** button. Also, you can select the phase of the shell on this tab. The phases available are based on the Phase data definition.

8) Complete the **Links** tab to add links to the shell. These links are displayed on the shell landing page in User Mode. Use links to provide users with access to useful websites, your company’s website, an intranet, or other destinations. Click Add Row and enter the name and URL for the links you want to add to the landing page.
9) In the Calendar tab, create a shell calendar. Each shell can have its own calendar. The shell calendar that you specify can be used to override the Company calendar, or you can use the Company calendar for the shell. If there is no shell calendar, or a shell calendar is not in use, the Company-level Standard Calendar marked as the default calendar is the calendar that is used by the shell. Shell calendars can be based on Standard Calendars created at the Company level, or Custom Calendars created for the specific shell. The shell calendar you create applies only to the shell for which you create that calendar. The calendar selected affects shell durations and due dates. For example, companies can have multiple projects in different countries that have different working and non-working days. These working and non-working days must be considered when determining such time-driven factors as business process workflow due dates and activity dates in schedule sheets.

**Note:** Unless otherwise specified, the default calendar for a shell is the Company calendar that is marked as default at the Company level.

a. Open the Calendar tab of the shell or Template window. The calendar you create in this tab is known as the Project/Shell Calendar.

b. You can select a Company-level Standard Calendar, or use a Custom Calendar for your shell. The calendar that you select displays in the Calendar tab.

   - To use a Standard Calendar as the shell calendar, click the Standard Calendar radio button and select a calendar from the drop-down list.
   - To use a Custom Calendar as the shell calendar, click the Custom Calendar radio button and click Copy. You can copy a previously-created Standard Calendar and use it as the project calendar.

c. You can modify the displayed calendar. You can specify the working and non-working days for the calendar. Browse to the month and year using the pull-down menus at the top of the calendar. Saturdays and Sundays are set as non-working days by default. Do one of the following:

   - To set a particular date as a non-working day (for example, a holiday), click the date on the calendar and select **Non Working**. The date will appear grayed out, and will not be used in date calculations.
   - To set a non-working day as a working day, click a grayed cell and select **Working**.
   - To set a particular day of the week (for example, every Saturday) as a non-working day, click the day at the top of the calendar (for example “Sat”), then click **Non Working**. All Saturdays in the calendar will be changed to non-working days (gray).
   - To set a particular day of the week as a working day, click the day at the top of the calendar, then click **Working**.
   - If you only want to set the day of the week in a particular month as working or non-working days, select each day individually and click **Working** or **Non Working**.

**Note:** If you have marked the day of the week as a non-working day throughout the calendar by selecting the day at the top of the calendar (for example “Sat”), then you will not be able to mark individual days (that is, individual Saturdays in this example) as working days. To be able to include both working and non-working instances of a day of the week on the calendar, you must select them individually.
d. Click **OK**. When you click OK, the calendar displayed in the Calendar tab is the shell calendar.

10) Click **Apply** to save changes as you enter information, and **OK** when you are ready to save information and exit the window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Enter a description of the shell type template.</td>
</tr>
<tr>
<td>Administrator</td>
<td>Select an administrator for the template.</td>
</tr>
<tr>
<td>Location</td>
<td>Disabled for template creation.</td>
</tr>
</tbody>
</table>

You can activate the shell immediately, or place it On-hold and activate later. A template that is On-hold or Inactive cannot be used to create a shell. It is good practice to leave a shell or template On-hold until you have completed the setup. Shell Administrators/Users with "modify shell status" rights are the only ones who can change the status.

The Shell Administrator will receive email notification when the status of a shell changes. The change of shell status could occur due to a manual change, bulk update, through Web Services or a CSV file, or through automatic update.

Status definitions for **shells** are:

- **Active**: Active, in-progress shell. All shell actions in User and Administration Mode are available.
- **On-hold**: The initial shell status. On-hold shells appear on the shells log. Shell administration functionality is available to shell administrators for setup and maintenance for users with permissions to perform that function. Users cannot create records in a shell that is On-Hold. If a user attempts to access a shell that is On-Hold, the system displays an alert message stating that the shell is On-Hold.
- **View-Only**: For end users, View-Only shells can be viewed, printed, exported, and included in reports. They cannot be modified. When a shell is View-Only, the status overrides (but does not modify) access control permissions, granting only View permissions. The shell reverts to the access control permissions when the shell is made Active. View-Only shells can be added to and removed from programs, and can roll up to programs, UDRs, and dashboards. Business process records cannot be auto-created in View-Only shells. Data from View-Only shells rolls up to Generic Cost Manager cost sheets if all of the shells in the hierarchy are generic. Data also rolls up to the program level cost sheet, if all of the shells in the hierarchy are WBS type and are included in the program setup, and Schedule Manager information rolls up to the program-level Schedule Sheet. Data rolls up to dashboards...
on a View-Only shell from child shells in the hierarchy, and rolls up to a parent shell from a View-Only shell. No updates can occur to View-Only projects through Integration, Mobile, or through reverse auto-population. View-Only shells cannot be updated through templates. Consolidate line item functionality is disabled for View-Only shells. Users can navigate through the shell hierarchy using View-Only shell instances. View-Only shells have only view, export, and print permissions available. Tasks and Drafts are not available for View-Only shells. Messages are available, but users cannot add general comments. uMail is available for viewing, but users cannot send, edit or delete messages for View-Only shells. When a shell becomes View-only, all scheduled jobs associated with it are canceled. When the status of the shell changes back to Active, you must restart any scheduled jobs. Administrators can perform all actions on View-Only shells.

- **Inactive**: Used to suspend shell usage. Inactive shells are visible from the Administration Mode under Sponsored Shell log only, but not visible under the Shells node (i.e., only Sponsor Company can access the shell), or in User Mode logs and selections. Only System and Shell Administrators (users with Modify Status rights) can reactivate the shell.

Note: "Late" tasks in an inactive shell may still show up in users’ tasks logs. Though they can access the task, no transactions can be performed in the inactive shell.

| **Auto-update Status Setup** | The selections on the drop-down list are defined automatic status update setups. These setups are defined at the Company level for use in specific shells. See *Setting Up the Automatic Update of Shell Status* (on page 323) for details. If you decide not to use the automatic status update, you can deactivate it by deselecting a setup (by literally selecting the word “Select”). |
| **Shell Number** | Unique number that identifies the shell. |
| **GeoCoding** | Details for mapping. This field appears if geocoding was set up in uDesigner for the shell. |

**Shell template modules and managers**

In shell templates you can prepare modules and managers to make standardized templates, which ensure project uniformity and greatly reduce the potential for errors. You can have different templates for different project models. For example, you can have one template for "cookie-cutter" projects that do not change, and you can have another template for projects that might incur substantial changes. Unifier will copy any prep-work when you use the template to create a new shell, a process called cloning. Manager and module availability can differ depending upon WBS or generic code specification in uDesigner. See *Create a shell by copying a template or shell* (on page 297).
Managers and modules available in all shell templates (both WBS and generic codes)

- **Member Companies**: In order to make partner companies that you added at the company level available in your projects, you add them in Member Companies. Member companies added to a shell template automatically copy to a shell during cloning. See *Managing Member Companies* (on page 298).

- **Access Control**: For modules and managers included in a shell template, you can assign user-mode permissions. Permissions set in a template will automatically copy to a shell during cloning. Keep in mind, records created in user mode may require permission assignment in user mode. See *Managing permissions and access control* (on page 159).

- **User Administration**: Users and groups added to a template are copied by default from the template to a new shell during cloning. See *User and Group Administration* (on page 135).
  - Users—Users added to a template automatically copy to the shell during cloning. Users added to shell templates cannot be deleted, only inactivated.
  - Groups—Groups added to a template, and any users added to these groups, automatically copy to the shell during cloning.

- **Setup**:
  - **Business Process**—You have the option to copy all, or none, of the business processes and their setups that were added to a template. See *General Procedures for Setting up Business Processes* (on page 366). If you added a single-record business process to a template, and created a record, that record with all of its data will be copied during cloning. See *Single-record business processes* (on page 377).
  - **Dashboards**—You can define dashboards in a template and opt to include them when you clone a new shell from the template. See *Creating a shell dashboard in a template* (on page 335).
  - **Gates**—Gates provide a means of automating when a project moves to the next phase. You can define gates in a template and opt to include them when you clone a new shell from the template. See *How to set Up Gates* (on page 327).
  - **Planning Manager**—This is where you can plan for new projects, and create proposals and forecasts for projects already running in Unifier.
  - **Resource Manager**—This is where you can set up and manage personnel resources in a company, project, or shell.

- **Information**: This is where single-record business processes exist. When you clone a template, any single-record business processes are copied as well. See *Single-record business processes* (on page 377).

- **Configurable Modules > Configurable Managers (CM1 through CM25)**: Configurable Managers are designed in uDesigner, and have flexible coding structures to allow data collection and analysis.

- **Document Manager**: You can create a folder structure for the Document Manager that can be used across shells. These can be created from Folder Structure Templates, or folders can be added manually. Unlike Folder Structure Templates, you can also assign users folder-level permissions (if they are in the shell template), and can import folders and folder properties.
Reports: You can create one or more user-defined report templates, which will be used for shell-level user-defined reports. You can import user-defined reports into shell templates from shell templates in other companies and Unifier environments, for example, from uStage to production. See Importing User-Defined Reports into Project or Shell Templates (on page 666).

Selections available in only Generic code shell templates

- Configurable Modules > Generic Cost Manager (CM0): The Generic Cost Manager captures cost-related transactions in a Generic Shell. These can include costs like rent, lease payments, or landscape care that are based on time scales such as monthly, quarterly or yearly. Each generic shell can have one Generic Cost Manager.

- Cost Manager > Commitment Summaries: In the same way the schedule of values summarizes all cost information related to a particular commitment business process, the commitment summary tracks commitment record information. See Setting up the Commitment Summary Template (on page 564).

Selections available only in WBS code shell templates

Cost Manager

- Cash Flow
  Cash flow is the distribution of cost over time - in project management terms, it is the movement of cash into or out of a project measured during a specific time period.

- Cost Sheet
  The cost sheet provides detailed accounting of the project's budget and costs. You can create one cost sheet per template or shell. See Setting up Cost Sheets (on page 469). Tip! Set up the standard cost sheet template and copy it into the shell template.

- Earned Value
  The earned value module provides quantitative tracking information about project or shell status using earned value analysis. You can only set User Mode permissions in a template.

- Funding
  The Funding Manager helps you to keep track of where project funding comes from and how it is being spent. You can create one funding sheet per template or shell. See Setting up the Funding Manager (on page 505).

- Schedule of values (SOV)
  The SOV sheet summarizes all cost information related to a particular commitment business process. This is where you define structures for General Spends, Payment Applications, or Summary Payment Applications.

  You can define a General Spends SOV structure by copying from an SOV template in the Templates log.

  For Payment Application SOV and Summary Payment Application SOV, the structure is copied from the line item grid structure of the Payment Application Business Process. This means that you must first complete the Business Process (BP) setup for the Payment Application BP before you can create the structure. See Setting Up Schedule of Values (SOV) (on page 532).

Rules
You can define shell-level cost or funding rules. See *Creating Rules and Rules Templates* (on page 554)

**Schedule Manager**

- **Schedule Sheet**
  A schedule template will be used to create the schedule sheet. Like the cost sheet, once this is created, it cannot be deleted.

- **Custom Calendars**
  Primavera Unifier allows you to create Custom Calendars to be used by the Schedule Manager.

**Shell Templates**

If the Data Element (DE) "uuu_int_schedule_type" is not included in the attribute form, then:

- The template that has the option "Enable P6 sources" selected is not included when you want to create a new Cost Sheet using: New > Cost Sheet > Copy from Template.
- The cost sheet that has the option "Enable P6 sources" selected is not included when you want to create a new Cost Sheet by copying a cost sheet from a Shell instance.

If the DE "uuu_int_schedule_type" is included in the attribute form, then:

When you add a Cost Sheet to the template (using a standalone template or by Copy from other Shell instances), you can select a "Tree" structure cost sheet, only.

**Notes:**

- You can select any Cost Sheet irrespective of whether the option "Enable P6 Sources" is selected or not.
- Once you create a Cost Sheet, the option "Enable P6 Sources" is available for edit.
- Once you add columns to the Cost Sheet using "P6 Data Sources" you cannot deselect the property.
- If you remove the columns using P6 Data Sources, you can deselect the "Enable P6 Sources" option.

The value for the DE "uuu_int_schedule_type" remains blank because the DE is read-only.

**Create a shell template by copying a template or shell**

You can create a Shell Template by copying from an existing shell template or an existing shell.

**To create a shell template by copying an existing shell or shell template**

1. Go to the Company Workspace tab and switch to Admin mode.
2. Click **Templates > Shells** in the left Navigator, then select a shell type.
3. Select the shell type template you want to copy.
4. Click **Copy** button. The Template <shell type name> Cloning window opens.
5. From the **Copy From** drop-down list, select one of the following:
   - **Template**: The log displays the list of shell templates created under the current shell type.
<shell type name>: The log displays the list of available shell instances. You can select one to use for template creation.

6) Select a listed template or shell name.

7) In the Select Modules pane, select the modules to include in the new template. The modules available depend on the cost code type of the shell or shell template (WBS or Generic). See Shell Cloning window selections (on page 291) for the lists of available modules by cost code type.

8) Click OK. The template Detail window opens, displaying the shell template properties. Most properties are copied from the original shell or template into the template Detail window, with the following exceptions:
   - **Number**: On the General tab, enter a Number for the shell template. If automatic numbering is specified, this field is read-only.
   - **Currency**: On the Currency tab, specify the Shell Currency
   - **Image**: On the Options tab, specify the Shell Image (optional)

   The status is set to On-Hold.

9) Click OK. Click Yes to confirm.

Shell Cloning window selections

In a shell log, when you click the Copy button, the cloning window lists optional calendar, module, manager, sheet, and structure selections. You must select an item to include it in the new shell. See Create a shell by copying a template or shell (on page 297).

Cloning window selections for all shell templates and shells (both WBS and generic codes)

- **User/Groups**: This is not an optional selection; users and groups in a template or shell are always included by default. See User and Group Administration (on page 135)

- **BP Setup**: You have the option to copy all, or none, of the business processes and their setups that are in the template or shell. See General Procedures for Setting up Business Processes (on page 366).

Templates do not allow record creation of multiple-record business processes, but they do allow record creation of single-record business processes under the Information>General node. If you added a single-record business process into the template or shell, and created a record, that record with all of its data is cloned when you select this option. See Single-record business processes (on page 377).

- **Configurable Modules > Configurable Managers (CM1 through CM25)**: Configurable Managers are designed in uDesigner, and have flexible coding structures to data collection and analysis. Each manager appears in the module selection pane by its unique name.

- **Custom Calendars**: Custom calendars provide a means to address variations in work schedules, holidays, and other non-working days. You can add custom calendars to a shell detail form on the Calendar tab. See Creating Multiple Calendars (on page 186).

- **Dashboard Setup**: Shells and templates may have multiple dashboards, each governed by unique permission settings. See Creating a shell dashboard in a template (on page 335).

- **Document Folder Structure**: Folder templates help standardize document organization in the Document Manager.
Gates Setup: Gates provide a means of automating when a project moves to the next phase. See *How to set Up Gates* (on page 327).

Resource Manager: Manage personnel resources using the Resource Manager.

User Defined Reports: You can create multiple user-defined report templates and include them in the new shell during cloning.

Cloning window selections for only Generic code shell templates and shells

- **Commitment Summaries**: In the same way the schedule of values summarizes all cost information related to a particular commitment business process, the commitment summary tracks commitment record information. See *Setting up the Commitment Summary Template* (on page 564).

- **Generic Cost Manager (CM0)**: The Generic Cost Manager captures cost-related transactions for a generic shell. Each generic shell can have one Generic Cost Manager.

Cloning window selections only for WBS code shell templates and shells

- **Cash Flow**: Cash flow is the distribution of cost over time—in project management terms, it is the movement of cash into or out of a project measured during a specific time period.

- **Commitment Funding Sheet**: A funding sheet tracks project funding—where it comes from and how it is being spent. You can create one funding sheet per template or shell. See *Setting up the Funding Manager* (on page 505).

- **Cost Sheet**: The cost sheet provides detailed tracking of the project’s budget and costs. You can create one cost sheet per template or shell. See *Setting up Cost Sheets* (on page 469).

- **Schedule of Values**: The schedule of values summarizes all cost information related to a particular commitment business process. See *Setting Up Schedule of Values (SOV)* (on page 532).

- **Rules**: Project cost or funding rules impose conditions on project transactions per rule queries. See *Creating Rules and Rules Templates* (on page 554).

- **Schedule Sheet**: Schedule sheets track project activities and milestones. You can have multiple schedule sheets in a project. Once created, they cannot be deleted.

Manage Shell Templates

**To open the shell template**

1) Go to the Company Workspace tab and switch to Admin mode.

2) Click **Templates > Shells** in the left Navigator.

3) Select a shell type. The shell templates log opens.

4) Select a shell template from the log and click **Open**.

**To edit shell template properties**

1) From the shell template home page, click the **Open** button. The template Detail window opens.

2) Click the tabs to view or edit shell template properties.

**Setting Permissions to Create or Modify Shell Instances**

To set shell instance access:
1) In Administration mode, go to the **Company Workspace** tab and click **Access Control** in the left Navigator.

2) On the right pane, select **Administration Mode Access > Company Sponsored /Shells> [shell node]**.

3) See **Edit user or group permissions using Access Control** (on page 160), select these permissions depending on what access need to be granted:
   - **Create**: Allows the creation of new shell instances
   - **Modify Status**: Allows the modification of the status of shell instances
   - **Modify Properties**: Allows the modification of shell instance properties
   - **Configure User Dashboard**: Allows the configuration of the shell dashboard in User Mode. This is the dashboard listed as My Dashboard in the View Dashboard drop-down list that displays for the end user in a shell instance.

4) Click **OK**.

---

### Creating a Shell

There are multiple ways to create a shell.

- Manually, from scratch
- Copying from a shell template
- Copying from an existing shell
- Importing via a CSV file
- Using a shell creation business process

When you create a shell from a shell template or by copying another shell, any shell dashboard that exists in the source template, Unifier copies the dashboard into the destination shell.

**Create a new shell manually**

**To manually create a new shell**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Company Sponsored Shells** in the left Navigator.
3) Select a shell type.

   **Note**: Ensure that you test shells in uStage before creating them in Unifier.

4) Click the **New** button. The <shell> template Details window opens.
5) On the **General** tab, complete the fields as described in the first table below. The fields in the table here are only the required fields. The shell that was designed for your company may include other fields.
6) On the **Currency** tab, click the **Add** button to add a default currency for the shell type template.

   **Note**: You cannot modify this default currency after you save the changes to the template Detail window.

7) Use the information in the second table below to add a currency.
8) Click the **Options** tab.
9) Use the information in the third table below to complete the **Options** tab.
10) Complete the Links tab to add links to the shell. These links are displayed on the shell landing page in User Mode. Use links to provide users with access to useful websites, your company’s website, an intranet, or other destinations.
   a. Click Add Row and enter the name and URL for the links you want to add to the landing page.
11) Click **Apply** to save changes as you enter information, and **OK** when you are ready to save information and exit the window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
<td>Enter a description of the shell type template.</td>
</tr>
<tr>
<td><strong>Administrator</strong></td>
<td>Select an administrator for the template.</td>
</tr>
</tbody>
</table>
| **Location** | The Location picker allows you to change the location of a shell, and is accessible when you set up a shell or modify the shell details. See **Location picker behavior** (on page 296) for details. Use the Location Picker to select where the shell instance will reside. In the Location picker:  
   - Find searches the current level  
   - Open shows the next level of shells  
   - Select completes the action  
   - Location Picker will allow breadcrumbs to display through the hierarchy  
   - Work systematically from the top of the hierarchy to the bottom  
   - There must be an instance of a single shell to connect to  
   You can use the Location picker to reorganize the shell hierarchy. The shell can move across tabs, or laterally along the hierarchy. When you move a shell instance, all of the shell data moves with the shell. If an auto-populated business process moves with the shell instance, then the auto-populated data moves with the business process. Data for the business process will be collected from the new shell location. In addition, if a child shell has been designed with linked elements, field values on the shell’s attribute form or single-record BPs will be automatically updated to reflect changes when the shell is moved. |
| **Status** | You can activate the shell immediately, or place it On-hold and activate later. A template that is On-hold or Inactive cannot be used to create a shell. It is good practice to leave a shell or template On-hold until you have completed the setup. Shell Administrators/Users with "modify shell status" rights are the only ones who can change the status. Status definitions for **shells** are:  
   - **On-hold**: The initial shell status. On-hold shells appear on the shells log. Shell administration functionality is available to shell administrators for setup and maintenance for users with permissions to perform that function. Users cannot create records |
in a shell that is On-Hold. If a user attempts to access a shell that is On-Hold, the system displays an alert message stating that the shell is On-Hold.

- **Active**: Active, in-progress shell. All shell actions in User and Administration Mode are available.
- **Inactive**: Used to suspend shell usage. Inactive shells are visible from the Administration Mode under Sponsored Shell log only, but not visible under the Shells node (i.e., only Sponsor Company can access the shell), or in User Mode logs and selections. Only System and Shell Administrators (users with Modify Status rights) can reactivate the shell.

Note: "Late" tasks in an inactive shell may still show up in users' tasks logs. Though they can access the task, no transactions can be performed in the inactive shell.

<table>
<thead>
<tr>
<th>Shell Number</th>
<th>Unique number that identifies the shell.</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeoCoding</td>
<td>Details for mapping. This field appears if geocoding was set up in uDesigner for the shell.</td>
</tr>
<tr>
<td>Currency Name</td>
<td>Select the currency you want to use for the cost functions in this project. If the currency you selected is other than the company Base Currency, then complete the following fields.</td>
</tr>
<tr>
<td>Rate</td>
<td>Enter an exchange rate to use for conversion calculations. From the drop-down list select one of the following: If <strong>Float</strong> is selected, the rate is updated automatically from the company currency table (Standards &amp; Libraries &gt; Exchange Rate). A <strong>Peg rate</strong> is locked at the company rate on the day the rate is set. (Only a Project Administrator can manually modify the Peg rate to a value other than the company peg rate.).</td>
</tr>
<tr>
<td>Hedge?</td>
<td>If the Hedge selection is <strong>Yes</strong>, then the Hedge rate is used for conversion calculations. Otherwise, the Float rate will be used.</td>
</tr>
<tr>
<td>Rate</td>
<td>If an amount is entered for the Rate, then the hedge rate is used until the amount specified is reached (by spends) and then the system will revert back to the normal rate.</td>
</tr>
<tr>
<td>Amount</td>
<td>If <strong>Float</strong> is specified, Primavera Unifier will retrieve the rate, based on today’s date and time. If <strong>Peg Rate</strong> is specified, the field will be editable.</td>
</tr>
<tr>
<td>Comments</td>
<td>(Optional) Add any comments that might be necessary to explain the default currency.</td>
</tr>
<tr>
<td>Image</td>
<td>(Optional) Upload an image file. This image is displayed on landing page of the shell in both Administrator and User Modes. Click <strong>Browse</strong> to browse for the image file and then click the <strong>Add</strong> button.</td>
</tr>
</tbody>
</table>
### Unifier Administration Guide

<table>
<thead>
<tr>
<th><strong>Phase</strong></th>
<th>(Optional) Select the phase of the shell on this tab. The phases available are based on the Phase data definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Shell Email</strong></td>
<td>The <strong>Email Address</strong> field shows the dedicated email &quot;mailbox&quot; that is automatically created for the shell. (For information on this mailbox, see <strong>Dedicated Mailbox for the Shell</strong> (on page 279).) You can distribute this shell email address to all users, both within and outside of Primavera Unifier, who will participate in the shell. To do so: Click the <strong>Send Email</strong> button. An email message window opens. In the <strong>To</strong> field, enter the email addresses of all participants in the shell. You can also send the address of the dedicated mailbox to external users by adding their email addresses in the <strong>External Cc</strong> field. Click the <strong>Send</strong> button. Note: You can also create a link on the shell dashboard that users can use to distribute this email address to shell users.</td>
</tr>
<tr>
<td><strong>Email Address</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Shell Email Send Notification To</strong></td>
<td>Use this field to send notification to users in the shell whenever the shell mailbox receives an external email. To do so: Click the <strong>Select</strong> button. The User Picker opens. Select the users you want to notify and click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>

### Location picker behavior

The Location Picker opens when you click the **Location Select** button. This is an example of a Location picker:

![Location Picker](image)

In this example there are two single instance shells, Facility Management and Project Management. You can use this Location picker to select a shell instance. The multiple instance shells are listed under the single shell instances that are represented as tabs. You can select a tab on which the shell is listed on the organization configuration.
When this picker is opened first it displays the instance of single shell. In this example it is showing All Facilities. If Project Management tab is clicked then you should see the single instance shell created under that tab. You can now select this instance by highlighting it and clicking the Select button. If you want to drill down to another shell instance which is created under this single shell instance, you can navigate to it by selecting the single instance shell and double clicking or selecting a shell and clicking the Open button.

**Create a shell by copying a template or shell**

You can create shells using the shell templates you created. You can also create shells by copying from existing shells. You can verify the shell properties, make changes as necessary, update status, or activate as necessary.

---

**Note:** As Shell Administrator, you can receive email notification of the successful creation of a shell. This notification can be set up in email notifications in uDesigner. Also, you can set your User Preferences to control whether you receive these notifications.

---

Creating a shell from a shell template or another shell, copies shell dashboards in the source template or shell to the destination shell. You can choose to copy any existing Custom Calendars from the template or from an existing shell.

**To create a shell from a shell template or existing shell**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells in the left Navigator.
3) Select a shell name.
4) Click the Copy button. The Shell Cloning window opens.
5) Click the Copy From drop-down list and choose Shell to copy an existing shell, or Template to copy a shell template.
6) Select a shell or template from the list and click OK.

To search for a specific shell or template in the list, click the Filter By field and select **Name** or **Number**. In the Filter For field, enter all or part of the name or number to search for and click Search.

7) In the Select Modules pane, select the modules to include in the new shell. Users and Groups are selected by default and copied along with the shell properties. See *Shell Cloning window selections* (on page 291) for a discussion of the modules available for selection in the type of shell you are cloning.

---

**Note:** When you copy a shell or template, you also copy existing setups in the modules you selected. If you select BP Setup when you copy a template, you will copy any existing business process setups, including those for any single-record business processes (SRBPs). SRBP setups and record data are copied along with everything else.

8) Click OK. The Shell Details window opens, displaying the shell properties.

Most properties are copied from the original template with the following exceptions:

- **Number:** On the General tab, enter a Shell Number
Currency: On the Currency tab, specify the Shell Currency

Image: On the Options tab, specify the Shell Image (optional)

9) When you finish completing the shell details, click OK. Click Yes to confirm and create the new shell.

Managing Member Companies

If your company has set up Partner Companies, those companies can become eligible to be added to shells. When added to a shell, these companies become Member Companies, and their users can participate in shells with any permission level you set for them.

Note: The list of eligible partner companies is maintained in the Partner Companies log. In Administration Mode, navigate to Company>Partner Companies to view the list.

Add a member company to a shell

Active partner company users (users with a unique Unifier user name, and status of Active or On Hold) can be added to shells and assigned permissions, just like sponsor company users.

To add a member company to a shell

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells > <shell name> > <project name> > Member Companies in the left Navigator. The Member Companies log opens.
3) Click the Add button. The Add Member Companies window opens. This window lists the available partner companies that can be added to the shell as a member company.
   You can click the Find button to search for a particular company by Company Name or Contact Name.
4) Select one or more companies from the list and click the Add button.
5) At the confirmation window, click Yes. The company is added to the Member Companies log.

View member company profile

To view a member company profile

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells > [shell] > [shell instance] > Member Companies in the left Navigator. The Member Companies log opens.
3) Select a company from the list and click Open. The Company Profile window for the company opens. This is a view-only window. This information is maintained by the partner company’s administrator.
4) Click the General tab to view general information, and the Address tab to view contact information.

Remove a member company from a shell

You can remove a member company from the shell’s Member Companies list. When a member company is removed from a shell, users belonging to the member company will be automatically inactivated for that shell.
To remove a member company
1) Select the company and click the Remove button.
2) At the confirmation window, click OK. This will remove the selected company from the list and inactivate any users who have been added to the shell.

Managing Shell Users and Groups
This section discusses adding groups and users to shells, managing shell groups, and managing shell permission levels.

Add a user to a shell
After you have created a shell, you will need to add users to the list of approved shell users. Shell users can be from your own sponsor company, or from approved member companies.

When adding users from your company to the shell:
- To add users from your own (sponsor) company, the user must be either Active or On-Hold at the company level. When added, the user will automatically be Active for the shell.
- Users who are inactive at the company level cannot be added to a shell.

When adding users from a partner company to the shell:
- In order to add a user from a partner company, the company must first be added to the Member Companies list for the shell. The user must be either Active or On-Hold at the company level. When added, the user will automatically be Active for the shell.
- The user does not necessarily need to be listed in the Partner Users log at the company level in order to be added to a company. If the user is listed in the Partner Users log, the user must be Active or On-Hold. If the user is not already in the Partner Users log, they will be automatically added to the list of Partner Users with a status of Active.

To add users to a shell
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells > [shell name] > [project name] > User Administration > Users in the left Navigator. The Users log opens. The log lists all users that are already part of the shell.
3) Click New. The User/Group Picker opens.

   Note: If a User Attribute form has been imported, the shell user log will reflect the design of any designed Partner Log included in that form. See Importing User Attribute Form (on page 135) for details.

4) Click the List Names from drop-down list at the top of the picker window and choose the company from which to add the new shell user.
This drop-down lists your sponsor company plus any member companies that have been added to the shell. You can click the Member Companies node under the shell to view the list of available member companies.
Unifier Administration Guide

**Note:** By default, new users will have a status of *Active*. You can change the status or other user detail information selecting the user from the list and clicking *Open*.

5) Select one or more users to add to the shell. You can press the *Shift* or *Ctrl* keys to select multiple users at once.

6) Click the *Add* button. You can continue to select and add names to the *Selected Users* portion of the picker window.

7) Click *OK* to add the users to the shell. The new users are listed in the Users log.

**To add a user to a shell template**

Open the shell template and navigate to *User Administration > Users*. Follow the steps above to add a sponsor company or member company user to the template.

**View or edit a shell user’s profile**

You can edit a shell user’s details. These procedures apply to sponsor company users and member company users.

**To view or edit a shell user profile**

1) Go to the *Company Workspace* tab and switch to Admin mode.

2) Click *Company Sponsored Shells > [shell instance] > User Administration > Users* in the left Navigator. The Users log opens.

3) Select a user from the list and click *Open*. The Edit Shell User window opens. The window has the following tabs: General, Groups, Permissions and Custom.

**Note:** If a User Administration design has been imported from uDesigner by your Administrator, the content of this profile can vary.

4) In the *General* tab, review the contact information for the user as it will appear in the Shell Directory. By default, the shell address (as defined in the shell details) displays as the contact address. You can edit this information as necessary.

You can also modify the user's shell status:

- **Active:** User is listed in Shell Directory, in User/Group Picker, User can log in and participate in the shell. New users are Active by default.

- **Inactive:** If you deactivate a shell user, the user’s name will not appear anywhere for selection on any shell-related functions. The user will not be able to access the shell. Inactivating a user at the shell level does not affect their status on other shells.

- **On-Hold:** User can be added to a shell, or assigned as a participant in a business process workflow but cannot log in.

5) Select the *Show user on the Shell Directory* option, if you want the user's information to be viewable in the Shell Directory.

6) In the *Groups* tab, you can add or remove the shell users to a shell-level group the same way that you add company users to company groups. Click the *Add* button to add a group to the user’s list, or select a group and click Remove to remove the user from the group.
7) In the **Permissions** tab, you can assign shell-related permissions to the user, by module and mode.

8) In the **Custom** tab, you can view available custom attributes that may have been added to the user form.

**Create and Manage Shell Groups**

Groups are a way to aggregate Users together so that adding new team members to the shell and assigning permissions can be done quickly and efficiently. For example, groups can be members of the same shell team, and/or they can be users who share the same access privileges. At the company level, groups can span shells. At the shell level, all members of a group are members of a given shell. Different members of a shell may have different access to Unifier functionality, depending on their role on the shell.

For example, a Finance person might require access to cost modules and reports dealing with finances, but not RFIs or Transmittals and their associated reports. An Executive might require access to Summary financial information, and not the cost BPs.

As users are added to a Group, they will inherit the Group’s permissions. If they are in more than one group, then the highest level of permissions granted in any group for a module will prevail.

When adding users to the group, you can choose eligible users from the sponsor company and any partner company users. The company short name will be listed in the User Picker window next to each user.

Company level groups cannot be copied into a shell.

**To create a new group**

1) Open the shell and switch to Admin mode.

2) Click **Company Sponsored Shells > [shell] > [shell instance] > User Administration > Groups** in the left Navigator. The Groups log opens.

3) Click **New**. The Groups window opens.

4) Complete the **General** tab:
   - **Group Name**: Enter a name for the group
   - **Manager**: Click Select and select a user from the User Picker window. This is the person who will be responsible for administering the group.
   - **Description**: Enter an optional description for the group.

5) Click the **Members** tab. This is where you add and manage group membership.
   a. Click **Add**.
   b. From the User/Group Picker, select the users to add to the group and click **Add**.
   c. Click **Ok**.

6) Click the **Permissions** tab. In this tab, you manage group permission settings. If a user is a member of the group, the user will inherit all group permissions.

   Granting permissions to the group is similar to granting permissions to individual users.
   Choose the shell-related permissions for the group that will apply to all members assigned to this group. Choose permissions by module and mode.

7) In the **Custom** tab, you can view available custom attributes that may have been added to the group form.
To edit group information
1) Open the shell and switch to Admin mode.
2) Click Company Sponsored Shells > [shell] > [shell instance] > User Administration > Groups in the left Navigator. The Groups log opens.
3) Select a group and click Open, or double-click the selected group. The Groups window opens.
4) Make changes as necessary and click Ok.

Grant shell user permissions through Shell Access Control
Once you have created a shell, assign permissions to the people who need to access the shell. You can use Access Control to grant multiple Users or Groups permission simultaneously, rather than editing the properties for each User or Group individually.

To view or change a shell’s access control
Do either of the following:
- Open the shell and switch to Admin mode. Click Access Control in the Navigator.
- Go to the Company Workspace tab and switch to Admin mode. Click Company-Sponsored Shells > [shell type] > [shell] in the left Navigator. Then click Access Control in the Navigator.

Unifier displays a copy of the Navigator menu in the right pane of the window. In this right pane, you may click on different modules of the Navigator menu to set permissions for those functions.

Generate and print access information report
You can generate and print an Access Information summary of user and group access (permission settings). The report will display all user and group permissions.

To generate the Access Information report
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells > [shell] > [shellinstance] > Access Control in the Navigator.
3) Click the Access Information button. The Access Information window opens. It may take several moments to generate the report.

To print the Access Information report
1) Generate the Access Information report.
2) Click the Print button. (When the report is complete, the Print button becomes available.)

Create new shells using an imported CSV file
An Integration interface must be created for shell creation to work via CSV file.

To create new shells using an imported CSV file
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells in the left Navigator.
3) Select a shell type.
4) In the shell log, click Export Template.
5) Complete the shell creation template CSV file. Some hints:
   - The shell location must have a leading /. Be sure to use the true shell name as entered in the Shell Manager configuration.
   - Shell statuses are Active or Inactive. Use initial capitalization.
   - Administrators must be valid users. You might enter the user’s full name (for example, Henry James) or the system user name (for example, hjames) depending on the configuration.
   - If using currency override, be sure the currency is active in Exchange rates and the CSV file contains a valid currency code.

6) In the shell log, click **Import**.
7) Select the modules to include in the shell.
8) Select the template from the listed templates and click **OK**.
9) Browse for the CSV file.
10) Click **OK**.

**Reasons for a Shell Creation business process CSV failing to import**

1) Any incorrect rows will cause the CSV upload to fail and an error message will display the incorrect row number.
2) Incorrect shell location used (this has to be set up before importing a CSV.)
3) Invalid shell name or number.
4) The location on the imported CSV file is not a valid parent location.
5) The sub-shell of the type that you are importing was not configured under the parent location specified.
6) Currency override used an invalid currency code or the currency was not active in Exchange rates.

**Note:** If shell creation fails, the user who attempted to import the CSV will get an email notification of the import failure.

**Create shells with the shell creation business process**

Before you begin, review these conditions for successful Shell creation from the Shell creation business process:

- Shell creation business process must be designed and deployed in uDesigner and configured and set up in Unifier.
- Shell template must be created
- Shell hierarchies must be correctly configured in Shell Manager
- Shell number must be unique
- Shell override currency, if it is to be used, must be active in Exchange Rates

The shell creation business process can synchronously auto-create a multiple-instance WBS or generic shell anywhere in or across a shell hierarchy. The business process uses a shell location picker to assign where the shell will reside in the hierarchy, and a shell picker to select a template. This means shell organization must be correctly configured in the Shell Manager and the shell template must be created.
The shell creation business processes designer can define the business process as company level or shell level. The designer may use workflow to support review and approval processes, or elect to design the business process without workflow. At run time, Unifier passes select information captured in the business process form to the newly created shell, thus avoiding redundant data entry. Reaching terminal status, as defined in uDesigner, triggers the synchronous shell creation process. If there is a planning item picker on the shell creation business process record or line item Unifier will link the planning item to the new shell.

Notification

Unifier will send an email notification upon successful shell auto-creation, provided notification is set up in business process setup, Unifier has a valid email address for anyone selected to receive notification, and those selected subscribe to email notification in user preferences. If auto-creation fails, Unifier will immediately send an alert to those selected to receive notification.

There are two types of shell creation business processes: simple and line item.

- **Simple-type**
  - The simple-type shell creation business process creates one shell per record. Reaching a terminal record status, as defined in uDesigner, triggers the synchronous shell auto-creation process. The business process designer has the option to either define workflow or not. In uDesigner the designer can define integration; in Unifier you can obtain the business process import template from the business process log.
  - It is important to note that the CSV import template must be correctly completed or Unifier will reject the CSV file in its entirety and not create any shells. When Unifier rejects a CSV file it creates an error file that tells you which line item is in error and why it is in error. To ensure a successful upload of the shell creation business process CSV file, retain the column headings in the same order as exported, and complete all required fields.

- **Line Item-type**
  - The line item-type shell creation business process creates a shell for each line item. Use the upper form to create the parent shell and each line item to create a child shell. Auto-creation happens when:
    - Record terminal status is reached, as defined in uDesigner
    - Line item status is met, as defined in uDesigner
    - A line item passes validation
  - At run time, when Unifier processes a line item-type shell creation business process record, it will create a new shell from each line item that passes validation. For example, if there are 10 line items in the shell creation record, but only five pass validation, Unifier will create five shells. Shell creation line items can be consolidated, provided consolidation is configured in uDesigner.

Managing Shells

You can verify the shell properties, make changes as necessary, update status, or activate as necessary. It is recommended that you keep the company progress information up to date to reflect the ongoing status and progress of the shell.
You can also modify shell information in a shell type template and then update one or more existing shells by "pushing" the information from the template to the shells (see Updating Shells (on page 307)).

To open a shell
Click the tab for the shell. Select a shell name from the shell log and click Open. The shell landing page opens.

To edit an existing shell
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells in the left Navigator; select the shell instance, and then click the Details button. The shell window opens.
3) Modify the shell information as necessary. You can modify any of the shell properties any time during the shell duration, except for the shell currency. Once a shell is set up, the shell currency is locked.

The Location picker allows you to change the location of a shell, and is accessible when you set up a shell or modify the shell details. See Location picker behavior (on page 296) for details.
Use the Location Picker to select where the shell instance will reside. In the Location picker:
- Find searches the current level
- Open shows the next level of shells
- Select completes the action
- Location Picker will display breadcrumbs through the hierarchy
- Work systematically from the top of the hierarchy to the bottom
- There must be an instance of a single shell to connect to

Note: You can use the Location picker to reorganize the shell hierarchy. The shell can move across tabs, or laterally along the hierarchy. When you move a shell instance, all of the shell data moves with the shell. If an auto-populated business process moves with the shell instance, then the auto-populated data moves with the business process. Data for the business process will be collected from the new shell location. In addition, if a child shell attribute form or a single-record BP in a child shell has been designed with linked elements, the child shell attribute data and BP data will be automatically changed to reflect the new parent shell’s current attribute values.

4) Click OK to save your changes and exit the Shell window.

To deactivate an existing shell
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells in the left Navigator; select the shell instance, and then click the Details button. The shell window opens.
3) On the General tab, select Inactive.
Note: If you deactivate a single instance shell (a shell that displays in Unifier as a tab) you cannot access that shell again to activate it. The tab will persist, but not be accessible.

4) Click **OK** to save your changes and exit the **Shell** window.

**Bundling Single Instance Shells**

You can bundle Single Instance Shells that exist in the Staging environment in order to transfer the bundle to the Production environment.

The bundle that you create will include:

- The shell details data (data from all tabs in the shell).
- The currency defined in the Currency tab and if the selected currency does not exist in the destination environment, the system will create it.

**Note:** The Currency attributes such as Code, Name, Symbol, and so forth are not updated when you import the bundle, and after you create the shell, the Currency tab content will not be updated upon subsequent imports.

- The calendar from the Calendar tab and if the selected calendar does not exist in the destination environment, the system will create it.

The following Shell details are included in the Single Instance Shell:

**Note:** The following Shell details are exported and imported to the destination environment on the first import, only. No subsequent updates of Shell details data can be performed in the destination environment.

- Shell data that exists in the form for the following fields: Shell Name, Shell Number, Administrator, and Shell Status.

The Shell log window is a user-defined log, and the user-defined columns appear next to the system-defined columns. Use the Tag option (in the log window) to tag a Single Instance Shell for Production. Once tagged, the shell will be included in the Single Instance Shell bundle.

When you create a Single Instance Shell bundle successfully, the system stamps the Shell with the Last Bundled Date.

Shells cannot be created if they are not activated in the Configuration module, so the configuration of the Shell will be included in the Shell bundle at the time of transfer between environments.

**Note:** The contents of the Organize tab, which defines the Shell hierarchy, will be included.
Updating Shells

The Update Shells function allows you to quickly add or modify information into a shell template, and then apply that template to existing shells. This will "push" the new information to the shells that you specify. By allowing data to be entered or modified once, this function helps to reduce set up time and ensure cross-shell uniformity.

The Update Shells function is available for select modules in shell type templates. The modules that you can update are listed below.

- **Users**: users, group membership, permissions
- **Groups**: group names, permissions
- **Business Processes and BP Setups**: Business processes, setups
- **User-defined Reports**: Reports, report permissions
- **Access Control**: modules, users, groups, permissions
- **Cost Sheet**: Cost sheet columns, column access and restrictions
- **SOV**: General and Payment Applications structures
- **Commitment Funding**: Commitment funding sheet structure
- **Cash Flow**: Properties and permissions
- **Rules**: Cost or fund rules
- **Schedule Sheet Properties**: title, description, Master Schedule, status, auto-control, project start date, and error notification. *Updating Schedule Sheet Properties from Templates* (on page 606)
- **Gates**: Active or Inactive setups
- **Shell Instance Dashboards**: dashboards created at the shell level, and are available for users to view (but not edit) with granted permissions

Each of these modules has an Update function where you can use Find to isolate the shells you want to update. The find window contains data elements from the Find form (designed in uDesigner). This makes targeting shells with specific information possible. For example, if you add new users, to the company, and need to add them to many shells, but not every shell, you can add them to a shell template and use the Update Shells functional to add the users to only those shells that require them.

Shells with a status of Active or On-Hold can be updated with this functionality. Inactive or View-Only shells cannot. Users with create permission for the shell type template modules can do this operation.

**Note**: You update shell information one module at a time. Any Active or On-hold shells can be updated in this way.

General procedure for updating shell formation (on page 308)

*Update users* (on page 308)

*Update groups* (on page 309)

*Update business processes and BP setups* (on page 310)

*Update user-defined reports* (on page 311)
General procedure for updating shell formation

In general, the Update Shells feature works like this:

Step 1. In Administration Mode, open a shell type template.

Step 2. Navigate to one of the modules listed above. Add or edit data.

Step 3. Click the Update Shells button. Select which information within the module to update, and which of your active or on-hold shells to "push" the information to. New information will be added to the selected shells. Edited information will overwrite existing data.

You can also cancel a shell update before it reaches the In Process status.

Detailed instructions for updating specific types of shell information is found in the following sections.

Update users

You can add new users to multiple shells at once by adding them to a shell template in the User Administration > Users module. When adding new users to a shell, you can assign individual permissions directly to a new user, or add the user to a group to apply group permissions.

The Update Shells process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Some notes about updating users

- Users are identified by their unique User ID.
- Any Active, Inactive or On-hold users can be pushed.
- If the user does not already exist in the shell, the user will be added to the shell with the permission settings and group membership.
- If the user already exists in the shell, the user information is updated (replaced) with the user information as entered in the shell template. This includes permission settings and group membership.
Unifier Administration Mode

- If a group that the user was added to doesn’t already exist in the shell, the group will be added, and the user will be added to the group. Group permissions are not updated; this is done by updating groups.
- If the group already exists, the user will be added to it. Group properties and permissions will not be affected.

To add or update users using Update Shells
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the shell type template to update.
4) In the shell type template, navigate to the User Administration > Users log.
5) Add a user to the shell type template, or select a user to edit. Define user parameters and assign permissions.
6) Select one or more users in the Users log.
7) Click the Update Shells button and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
   - **History**: You can view the update history from past updates or cancel a request before the update begins.
     - An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.
8) Click Yes if you want to proceed with the update, or No to cancel.

Update groups

You can add new users to shells individually or by adding them to groups, and then adding the groups to the shells. You can assign the user individual permissions, or add the user to a group and apply group permissions.

The Update process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:
About updating groups:
- Groups are identified by their unique Group Name.
- All group properties, including permission settings, will be added or updated in the shells that you selected.
- If the group does not already exist, the group will be created with the permission settings. Group membership (user list) will not be updated in the shell.
- If a group of that name exists, the properties and permissions of that group will be replaced with the new group, but not the list of users.
- Users are not automatically added to the group; they need to be added by updating users (group membership).

To add or edit user groups using Update Shells
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the shell template to update.
4) In the shell type template, navigate to the User Administration > Groups log.
5) Select one or more groups from the Groups log.
6) Click Update Shells and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
   - **History**: You can view the update history from past updates or cancel a request before the update begins.

   An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

7) Click Yes if you want to proceed with the update, or No to cancel.

Update business processes and BP setups
You can add and update new business processes, or add additional business process setups to existing business processes.

The Update Shell process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:
About updating business processes and setups:
- BP Setup is identified by the unique combination of BP Name, Setup Name and Workflow Name.
- If the BP Name does not exist, it will be added to project with the BP Setup and permissions.
- If the BP exists, but the BP Setup does not, it will be added to the BP.
- If the BP and BP Setup exist, the Setup will be replaced with the new one.
Users and Groups that are part of a BP setup as assignees are added/updated, but not permissions. If a group is created, it will be empty. Users must be added to the group separately through user administration.

BP-related permissions are added/updated (for example, discussion groups).

To add or update business process setups using Update Shells
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the shell type template to update.
4) In the shell type template, navigate to Setup > Business Processes.
5) Add any new business processes, if applicable. (The BP must already have been imported into Unifier and configured at the company level.)
6) To add or edit business process setups, select the BP to update in the Business Processes log. Click Open. The BP Setup log opens.
7) Create a new setup or modify an existing setup. You may create as many setups as you wish to make available in the shell(s).
8) Select one or more setups from the BP Setup log.
9) Click Update Shells and choose one of the following:
   - Shells: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - All Shells: You can use this option to update all shells of that shell type.
   - History: You can view the update history from past updates or cancel a request before the update begins.
     An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.
10) Click Yes if you want to proceed with the update, or No to cancel.

Update user-defined reports
You can add and update user-defined reports.

The Update Shell process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Some notes about updating reports
- Reports are identified by the unique combination of Name and Data Type. Report names do not have to be unique.
- If the report name and data type does not exist, the new one will be added. Users/Groups will be added/updated, and permissions will be created for the report. The administrator updating the shell becomes the report owner.
- If a report exists with the same name and data type, it will be replaced with the new one. This includes updating the report, users/groups are created or updated, and permissions are created or updated for the report. The original report owner remains the same.

To add or update user-defined reports using Update Shells
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells** in the left Navigator.
3) Open the shell template to update.
4) In the shell type template, navigate to the **Reports > User-Defined Reports** log.
5) Add a UDR to the shell type template, or select UDR to edit. Define properties.
6) Select one or more reports from the User-Defined Reports log.
7) Click **Update Shells** and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
   - **History**: You can view the update history from past updates or cancel a request before the update begins.
     An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.
8) Click **Yes** if you want to proceed with the update, or **No** to cancel.

**Update access control**
You can edit access control parameters and update across shells.

The Update Shell process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**
- Modules are identified by name.
- If the module exists in the shell, the module is updated, users/groups are created or updated, and permissions are updated for the module.
- If the module does not exist, the module is added to the shell. Users/groups are created and permissions are created for that module.
To update access control using Update Shells

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the shell template to update.
4) In the shell-type template, navigate to Access Control and assign user or group permissions to the modules as needed.
5) Click the Update Shells button. The Update Shells window opens, displaying the list of modules for which the access control settings can be updated.
6) Select the module(s) that you wish to update.
7) Click Update Shells and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
   - **History**: You can view the update history from past updates or cancel a request before the update begins.

   An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.
8) Click Yes if you want to proceed with the update, or No to cancel.

Update cost sheet columns in a shell

Cost sheet columns can be updated in WBS code-based shells.

The Update Shell process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About cost sheet columns:

- A column is identified by a unique data source.
- If the cost sheet does not exist in the shell, the column is not added.
- If the shell cost sheet is present but the column does not exist, the column definition is created, and the column is added. Column restrictions are added. Users/Groups are created or updated.
- For formula columns, be sure to first push the columns or data sources that make up the formula (if they don’t already exist in the cost sheet), then push the formula column.
Any new column that is created will use the column to its immediate left as the reference point for positioning. When a column is added to the cost sheet via an update, this means: If the column to the left of the column that is being pushed exists in both the template and cost sheet, the column will be positioned in the cost sheet according to its position in the template. If the column to the left of the column being pushed exists in the template but does not exist in the cost sheet, then the column will be added to the end (far right) in the cost sheet.

Cost Column Shell Update Rules

If a cost sheet column of the same name exists, it will be replaced according to the following matrix.

<table>
<thead>
<tr>
<th>If this template (source):</th>
<th>Is used for this shell (destination):</th>
<th>The template will:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Date Source</td>
<td>Column exists</td>
<td>Update the column</td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with the same definition</td>
</tr>
<tr>
<td>Logical Data source (Formula entry)</td>
<td>Logical Data source Column Exists (Formula entry)</td>
<td>Update and replace the formula</td>
</tr>
<tr>
<td></td>
<td>Logical Data source column exists (Manual entry)</td>
<td>Not update the column or formula</td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with same definition</td>
</tr>
<tr>
<td>Logical Data source (Manual entry)</td>
<td>Logical Data source Column Exists (Manual entry)</td>
<td>Update the column</td>
</tr>
<tr>
<td></td>
<td>Logical Data source Column Exists (Formula entry)</td>
<td>Update the column and change it to manual entry</td>
</tr>
<tr>
<td></td>
<td>Column does not exist</td>
<td>Create column with same definition</td>
</tr>
</tbody>
</table>

To add or update cost sheet columns using Update Shells

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the template to update.
4) In the shell type template, navigate to Cost Manager > Cost Sheet. Create or open the Shell Cost Sheet.
5) From the cost sheet, click Columns to open the Columns log. Add or edit cost sheet columns as needed.
6) From the Columns Log window, select the column to push. Only one column can be updated at a time.
7) Click **Update Shells** and choose one of the following:

- **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.

- **All Shells**: You can use this option to update all shells of that shell type.

- **History**: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

8) Click **Yes** if you want to proceed with the update, or **No** to cancel.

**Update schedule of values structure**

You can update the SOV structure for general spends or payment applications in WBS code-based shells.

The Update Shell process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating the schedule of values structure:

- Update Shell can be used to create or update the SOV structure. If the structure already exists, it will be updated. If not, it will be created (restrictions apply for payment applications; see below).

- When creating or updating the structure of Payment Applications SOV and Summary Payment Applications SOV, the Payment Application Business Process must be set up in the target shell first. If the business process has an active setup, then Update Shell will create or update the structure.

**To update SOV structure using Update Shells**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Templates > Shell** in the left Navigator.

3) Open the shell template to update.

4) In the Shell Template, navigate to **Cost Manager > Schedule of Values**. Select one of these options: **General Spends/Payment Applications/Summary Payment Applications**.

5) Click **Update Shells** and choose one of the following:

- **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.

- **All Shells**: You can use this option to update all shells of that shell type.
History: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

6) Click Yes if you want to proceed with the update, or No to cancel.

Update commitment funding structure

You can update the structure used to create commitment funding sheets in WBS code-based shells.

The Update Shells process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:

About updating the commitment funding sheet structure:

- Update Project can be used to create or update the commitment funding structure in the project. If the structure already exists, it will be updated. If not, it will be created.
- Updating the structure in a project will not affect commitment funding sheets that already exist. New sheets will reflect the updated structure.

To update commitment funding structure using Update Shell

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shell in the left Navigator.
3) Open the shell template to update.
4) In the shell template, navigate to Cost Manager > Funding > Commitment Funding Sheet.
5) Click Update Shells and choose one of the following:
   - Shells: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - All Shells: You can use this option to update all shells of that shell type.
   - History: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

6) Click Yes if you want to proceed with the update, or No to cancel.

Update cash flow properties and permissions

You can push cash flow detail curve properties and permissions from a shell template to a shell. This is available for WBS-code based shells and templates.
The Update Shell process runs in the background. Depending on the number of records and projects you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating cash flow curve properties:

- Both detail curve properties and permissions are pushed from the template to the project.
- Cash flow detail curves are identified by name.
- If a detail curve with the same name exists in the project, it will be replaced. All properties, including detail level and time scale, and permission settings will be updated.
- If a detail curve with the same name does not exist in the project, a new one will be created.
- Users and groups will be added if they do not exist. If a group is created, it will be empty.
- In order to push a curve, the destination project must have a cost sheet.
- Commitment detail level curves will not be pushed.
- A Summary WBS curve cannot be pushed to a project where the cost sheet is flat.
- After a successful update, the updated destination curves will be refreshed.

To update cash flow curve properties and permissions using Update Shell

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shell** in the left Navigator.
3) Open the shell template to update.
4) In the shell template, navigate to **Cost Manager > Cash Flow**.
5) Add a cash flow curve to the shell template, or select one to edit. Define properties.
6) Select a curve from the Cash Flow log.
7) Click **Update Shells** and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
   - **History**: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.
8) An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a shell is updated, this action cannot be undone. Click Yes if you want to proceed with the update, or No to cancel.

**Update cost or fund rules**

Cost and fund rules can be updated in WBS code-based shells.

The Update Shells process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

**Notes:**

About updating rules:

- Both active and inactive rules can be pushed.
- Rules are identified by the combination of rule name and the source.
- If the rule does not exist, it will be added.
- If a rule already exists with the same name and source, that rule will be updated. This includes the status: for example, if the rule being pushed is active, and the rule in the shell is inactive, the system will update the existing rule and activate it.
- It is possible to have more than one rule with the same name and source in a project/shell or template. If two or more rules already exist with the same name and source as the rule being pushed, the update will not occur and will give an error.
- When the update process begins, the system will first attempt to validate each rule (equivalent to clicking the Validate button). This will occur whether the rule is active or inactive in the template. If the rule is validated successfully, the system will proceed with the update.
- If the rule fails validation, the rule will not be pushed. The attempt will be captured in the History.

**To update rules using Update Shells**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shell in the left Navigator.
3) Open the shell template to update.
4) In the Shell Template, navigate to Cost Manager > Rules.
5) Select one or more rules from the log.
6) Click Update Shells and choose one of the following:
   - **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
   - **All Shells**: You can use this option to update all shells of that shell type.
History: You can view the update history from past updates or cancel a request before the update begins. An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

7) Click Yes if you want to proceed with the update, or No to cancel.

Update Gates setups

You can update shells with Active or Inactive Gates setups. The Update Shells process runs in the background. Depending on the number of records and shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Notes:

About updating Gates setups:

- The Gates setup update will completely overwrite any existing Gates setup, or will be added if it did not previously exist.
- Previously scheduled Gates runs are overwritten by the new Gates setup. If the pushed setup is Active new scheduled Gates runs are scheduled according to the schedule in the new setup.
- Both Inactive and Active Gates setups can be pushed in the update.
- After update the Gates setup reflects the status of the template.
- After the update, the Current Phase in the Gates setup is reset to the First Phase.
- After the update, Gates shells will not execute the scheduled refresh if the shell is On-Hold. Gates scheduling will resume automatically when the shell becomes Active.
- If you have permission to create Gates setups, you can update Gates setups using Update Shell, even if you do not have permission to access the individual shells.
- Users and groups specified in the Email Notification field are added if they do not exist.
- Newly-created groups are empty.

To update Gates setups using Update Shell

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > [shell type] > [shell instance] in the left Navigator.
3) In the shell template, click Setup and select Gates.
4) Select a Gates setup.

- Shells: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
- All Shells: You can use this option to update all shells of that shell type.
History: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

5) Click Yes if you want to proceed with the update, or No to cancel.

Update shell instance dashboards

You can add new dashboards to shell instances, for users to view. You can assign the user View permission to the shell instance dashboards.

The Update process runs in the background. Depending on the number of shells you are updating, it can take a considerable amount of time to complete. The process is complete when the End Date column in the Update History window shows the complete date.

Some notes about updating shell instance dashboards

- If granted View permission, users can view shell instance dashboards, but cannot modify them.
- If a user added to shell instance dashboard permissions, and that user does not exist in the shell, that user is added to the shell upon update.
- If a user has created My Dashboard in User Mode for a shell, that dashboard is not overwritten by Update Shells.

To add or update shell instance dashboards using Update

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells > [shell type] > [shell instance] > Setup > Dashboards in the left Navigator. The Dashboards log window opens.
3) Select one or more shell instance dashboards from the Dashboards log.
4) Click UpdateShells and choose one of the following:

- **Shells**: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.
- **All Shells**: You can use this option to update all shells of that shell type.
- **History**: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

5) Click Yes if you want to proceed with the update, or No to cancel.

Update generic cost sheet columns and rows

You may have a large number of codes that are used within the Generic Cost Manager. In addition you may have a large number of shells in your implementation. To update codes and columns in your generic cost manager sheets with a minimal effort, you can push columns in a project or shell template generic cost sheet from the Columns Log to cost sheets.
Notes:

About updating shell instance dashboards:

- A cost sheet must already exist in the destination shell. Pushing a column from a template will not create a cost sheet that can receive the column.
- You can push one column at a time.
- If a source column is a single data source, then the destination column will be created with that single data source if it does not already exist. (Column A or B in example below)
- If a source column is a formula with only single data sources, then pushing the source column will create that column in the destination cost sheet, if it does not already exist. (Column C in example below)
- If a source column is a formula with columns included in the formula, as long as all constituent columns contain single data sources, the source column can be pushed; for any columns that do not exist in the destination cost sheet, the formula will be changed to a single data source in the formula. (Column D in example below)
- If a source column is a formula with constituent columns that include logical data sources, the logical data source must exist in the destination cost sheet. The formula for the logical data source may be different in the destination cost sheet. Any column that contains a single data source will follow the rule above. (Column F in example below)

<table>
<thead>
<tr>
<th>Column</th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>Original Commitment</td>
<td>Change Orders</td>
<td>Pending Commitments</td>
<td>Total Commitments</td>
<td>Trends</td>
<td>Forecast</td>
</tr>
<tr>
<td>Data Source</td>
<td>Purchase_Order (Approved)</td>
<td>Change_Orders (Approved)</td>
<td>CMO11</td>
<td>CMO12</td>
<td>Trends/Open</td>
<td>CM013</td>
</tr>
<tr>
<td>Formula</td>
<td>Purchase_Order (Pending) + Change_Orders (Pending)</td>
<td>Original Commitment + Change_Orders (Pending)</td>
<td>Total Commitments + Trends</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To add or update generic cost sheet columns from a template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells** in the left Navigator.
3) Open the shell-type template to update.
4) In the shell template, navigate to **Configurable Modules > Generic Cost Manager**.
5) Select the **Generic Cost Manager Sheet** template and click the **Structure** button.
6) In the Generic Cost Manager Sheet log, select the cost sheet template and then click the **Columns** button. The Columns Log window opens.
7) Select a cost sheet column.
8) Click **Update Shells** and choose one of the following:
Shells: You can use this option to select one or more shells to update. When the update window opens, it lists all shells in the project. You can use Find to isolate the shells you want to update. The find window contains data elements from the Find form that was designed in uDesigner. When you have isolated the shells to update, click the Update button and select either Selected Shell(s) or All Filtered Shells.

All Shells: You can use this option to update all shells of that shell type.

History: You can view the update history from past updates or cancel a request before the update begins.

An Alert window opens letting you know that you are about to push changes to the selected shells; there is no undo for the update.

9) Click Yes if you want to proceed with the update, or No to cancel.

To update generic cost sheet rows from a template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Shells in the left Navigator.
3) Open the shell template you want to update.
4) In the template, navigate to Configurable Modules > Generic Cost Manager.
5) Select the template and click the Structure button.
6) Select a row or rows to push to the project/shell level generic cost sheet. You can select multiple rows by holding down the Shift or Ctrl keys as you click on the rows.

Unifier will update leaf-level rows, but not summary rows.

7) Click Update Shells and choose one of the following:
   - Shells: allows you to choose which shell(s) to update. You can use Find to search for specific shells to select from the complete list of shells. You can select as many shells as you want to update. The Page and Display fields display on the Shell Update window, but are disabled in this case.
   - All Shells: updates all active and on-hold shells
   - History: allows you to view the update history from past updates or cancel a request before the update begins.

An Alert window opens, detailing the information that will be updated. Read the message carefully, as once a shell is updated, this action cannot be undone.

8) Click Yes if you want to proceed with the update, or No to cancel.

View update history
You can view details about previously updated shell modules.

To view Update Shell History
1) In the shell type template, navigate to the module to view the update history.
2) Click the Update Shells button and choose History. The Update Shells: History window opens. It lists any previous incidents of using Update Shells.
3) Select an instance from the list and click Open. The History Details window opens, detailing the module information that was updated. History Details displays:
   - Requestor: User who initiated the update process
Shells: Either user-selected or all shells

Submitted date: When the update request was submitted

Start date: When the update process started

End date: When the update process ended

**Cancel a shell update request**

You can cancel an update request that has not yet started; that is, any request that does not have a status of **In Process** or **Finished**.

**To cancel a shell update request**

1) In the shell type template, navigate to the module in which you want to cancel the update request.

2) Click the **Update Shells** button and choose **History**. The Update Shells: History window opens.

3) Select an update that has not yet started.

4) Click **Cancel Request**.

---

**Setting Up the Automatic Update of Shell Status**

At the Company level, you can define the setup of the automatic update of project statuses of active projects based on triggering conditions which are defined using various data sources as parameters. For example:

- A selected activity on the schedule sheet is in the Completed status
- A single-record business process record is set to a specified status
- A business process workflow reaches a specified status

Depending on the setup and the conditions that are set, the status of the shell can change from Active to a non-active status (On-Hold, View-Only, or Inactive). You can define multiple setups for each shell. After you define these setups, they can be used on shell instances, or on templates to enable the automatic update of shell status.

The data sources that you use in the triggering conditions can be either from shell level or from the Company level. This data sources can be business processes, sheets or attribute forms. You can define the frequency at which Unifier evaluates the conditions to see if a particular active shell should change its status, and can define a list of users or groups to be notified when the shell status is changed. The highest frequency is daily.

This automatic update of shell status can be useful for users that have a large number of shells and want many of these shells to change their status based on certain triggering conditions, and thus the users do not have to search for and modify these shells manually. For example, you can define a setup at the Company level that contains a triggering condition that changes the status of an active shell On-Hold if the shell funds consumption exceeds the funds appropriated for that shell. This allows the shell manager to review the shell and take appropriate action. If, in this case, the shell manager is able to get additional funding for the shell, the Administrator can change the shell status back to Active to restart the shell activities.
**Note:** Automatic shell status update can change the status of a shell from Active to an inactive status. If you want the inactive shell to status to revert to Active, you must activate the shell manually.

**Step 1:** Create setups - general information.

**Step 2:** Verify the order of shell statuses.

**Step 3:** Define shell status triggering conditions.

**Step 4:** Define the schedule for automatic update of shell status.

**Step 5:** Activate the automatic update of shell status.

**Step 6:** Define permissions.

### Create an automatic shell status update setup

Multiple setups can be defined at the company level and then used to configure individual shells.

**Note:** You must have imported a shell attribute form that contains the uuu_au_setup_picker data element to be able to setup the automatic update of shell status.

### To create a new shell status update setup

1) Go to the **Company Workspace** tab and switch to Admin mode.


3) Click **New**. The Auto-update Status Setup window opens. There are three tabs: General, Settings, Schedule.

4) In the **General** tab, enter a Setup Name, which displays in the log, and an optional Description.

5) In the **Settings** tab, define the order of the non-active statuses and the status change query and trigger conditions. For details, see *Choose the order of non-active statuses (Settings tab)* (on page 325) and *Define status change query and trigger conditions (Settings tab)* (on page 325).

6) In the **Schedule** tab, you can schedule the shell status update. See *Define shell status update schedule (Schedule tab)* (on page 326).

7) Once you have defined the setup, you must activate it to be able to apply it to a shell. See *Activate or deactivate an auto-update status setup* (on page 326).

**Note:** You must deactivate a setup to be able to modify it.
Choose the order of non-active statuses (Settings tab)

By default the order of the listed statuses is On-Hold, View-Only, and Inactive. These are listed on the left side of the Settings tab in the Status pane. You can change the order using the Move Up or Move Down buttons. You can change the order of the non-active statuses. The order of the statuses is significant because the triggering conditions for the statuses are evaluated in the order in which they are listed on this tab, with the verification of the triggering conditions occurring for each condition listed in turn.

For example, if the conditions for the first listed status are not met, then the conditions for the next listed status are evaluated. If the conditions for that status are not met, then the triggering conditions for the third status conditions are evaluated. As soon as the first match occurs, Unifier will automatically change the shell status and does not perform further evaluation.

To reorder non-active shell statuses

1) Open the Auto-update Status Setup window and click the Settings tab.
2) In the Status pane, select the status you want to move.
3) Click the Move Up or Move Down button to reposition the selected status.
4) Click Apply to save changes, or OK to save changes and exit the window.

Define status change query and trigger conditions (Settings tab)

The Conditions Elements section allows you to define condition criteria per element. Elements can be selected from all Unifier data sources and modules available at the Company level.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notify users and groups on Status change</td>
<td>Allows you to define the users and groups who will receive status change notification.</td>
</tr>
<tr>
<td>Email content</td>
<td>Enter the content of the email you want to send to notified users and groups. This content appears in the Additional Information section of the email.</td>
</tr>
</tbody>
</table>

To define query and trigger conditions

1) Under Conditions Elements, click Add.
2) Select a Data Type, and click OK. The Query Condition window opens.
3) Complete the General tab by entering a name for the query and a brief description. The Data type and Element is auto-populated from the selection you make on the Query tab.
4) Click the Query tab.
5) Click Add.
6) Complete the Query tab:
Data Element: Click the Select button. The Data Element Picker opens. The list is generated from the data type you chose in the General tab. If the data element is a picker, pull-down or radio button, the Value field will display the values entered in the data set tab of the data definition associated with the data element. For a full list of data elements and data types, refer to the Unifier Reference Guide.

Label: The label defaults to the data element name. You can enter a different label.

Condition: Define Gate Condition Element Condition. The condition options vary dynamically depending on the selected Data Element. The screen shots below list out the various options for different Data Element types. Examples include equals, does not equal.

Values: Specify value. The Values field varies dynamically depending on the selected Data Element and Condition. (For example, if the element is a text box, the condition might be Contains, and value might be one or more letters to search for. If the element is a pull-down or other data definition with a data set, you will select a value from the data set.)

7) Select the trigger conditions.
8) Click OK.

Define shell status update schedule (Schedule tab)
You can define a schedule to check the conditions for the automatic update in the Auto-update Status Setup window, Schedule tab.

The maximum frequency that Unifier will verify whether triggering conditions are met is daily. If you have a need for greater frequency of verification, you must monitor the shell with the shell manager and then change the shell status manually as needed. For example, if the triggering condition verification is performed in the morning, and the shell funds are being spend during the course of the day, the shell could exceed its budget before the condition verification occurs the next morning, and the shell status is automatically changed.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Scheduled Runs</td>
<td>Select this checkbox to enable scheduled evaluating of the automatic update status. Deselecting this checkbox will disable the scheduler, and any scheduled future runs will be canceled immediately. The scheduled evaluation is disabled for the last status in the list, provided all conditions are met, and the Enable Scheduled Runs checkbox is automatically deselected.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Choose Frequency of the Scheduled Runs (Daily, weekly, monthly, quarterly, yearly)</td>
</tr>
<tr>
<td>Range of Recurrence</td>
<td>You can specify a date on which the Scheduled Runs will end, or no end date.</td>
</tr>
</tbody>
</table>

Activate or deactivate an auto-update status setup
You must activate a setup in order to be able to apply it to a shell.
Note: You must deactivate a setup to be able to modify it.

To activate or deactivate a shell status update setup

1) To activate or deactivate a new setup to use in shells, go to the Company Workspace tab and switch to Admin mode.
3) Select a setup in the log.
4) Click the Status button. You can choose Active or Inactive.

Set permissions for automatic update of shell status

To set permissions for automatic status update:

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select Administration Mode Access > Company Workspace > Auto-update Status Setup. The permissions are:
   - Create: Allows the creation of new auto-update status setups, edit existing auto-update status setups and activate or deactivate auto-update status setups.
   - Modify: Allows the edit existing auto-update status setups and activate or deactivate auto-update status setups. This permission excludes the ability to create a new auto-update status setup.
   - View: Allows viewing of existing auto-update status setups.

How to set Up Gates

Before you begin: Verify the list of phases resides in the Phase data definition pull-down data set. This is the same list that is used when selecting a phase manually in the shell properties window. You can add or modify the default list as needed. This list makes the phases available for any shell instance or shell type template; for each shell or template, you select which of the phases to use. Create any business processes that you plan to use to drive gates conditions and phase completion.

Step 1: Define Phases. For each shell instance or shell type template, you define the list of phases to include in the setup, choosing from the entire list in the Phase data set.

Step 2: Define Gate Conditions. For each phase, define one or more gates conditions. A gate condition is a combination data element and trigger condition that enable transition to the next phase.

Step 3: Schedule Gates runs. The gates run the validation of gate conditions. You can schedule runs automatically. This is optional.

Step 4: Activate the Gates setup.
Step 5: Define permissions.
Note: If you create a new shell by copying a shell template or an existing shell, any existing gates setup in the source shell is copied into the new shell, including the gates status. The gates phases are restarted at the first phase in the new shell, and the scheduled gates run is activated.

**Example of a gates setup and conditions**

You will be setting up phases in gates to represent the actual phases of a shell. For the shell to advance from one phase to another, certain conditions must be met. This example will discuss phases, conditions, and using business processes in the context of the conditions to advance a shell from one phase to another.

For example, phases for shell Zero could be:

- Preliminary
- Investigation
- Definition
- Measurement
- Analysis
- Execute
- Control

Previously, you have set up two business processes to use in the conditions for your gates setup. These are:

- **Schedule**: A single record business process that is updated manually by a shell manager by checking checkboxes for the various phases such as Definition Phase Complete? or Measurement Phase Complete?
- **Funding**: A workflow business process that is automatically updated thorough the steps of the workflow.

As the shell manager checks the checkboxes in the phases as represented in the Schedule business process, the gates runs keep checking the statuses of the checkboxes. As they are checked off, the project advances to the next phase.

The exception to this procedure is the transition from the Analysis phase to the Execute phase. Additional approval is needed for funding in order for the project to advance from Analysis to Execute. The Funding business process is included in the conditions for the Analysis phase. This business process must have the status Construction Approved and have a value of greater than zero for the Analysis phase to be exited and the Execute phase entered for the project.

**Define the phase list**

**To view the phase list**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Data Structure > Data Definitions** in the left Navigator.
3) Click **Basic**.
4) Select the Phase data definition and click **Open**. The Modify Data Definitions window opens.
5) Click the **Data Set** tab. The active phases on this list will be available for phase setup.

6) Modify the list as needed. Any changes you make here will be reflected in new gates set ups. Current setups will not be affected.

---

**Create a gates setup**

You can create a gates setup in shell templates, and in individual shells. There can be one setup per shell instance.

**To create a new gates setup**

1) Do one of the following:
   - To create the setup in a shell type template, go to the Company Workspace tab and switch to Admin mode. Click **Templates > Shells** in the left Navigator. Open the shell template.
   - To create the setup in a shell instance, go to the Company Workspace tab and switch to Admin mode. Click **Company Sponsored Shells** in the left Navigator. Open the shell instance.

2) Choose **Setup > Gates**. The Gates Setup log opens.

3) Click **New**. The gate setup is created automatically. Double-click the setup, or select from the list and click **Open**. The Gates Setup window opens. There are three tabs: General, Settings, Schedule.

4) In the **General** tab, enter a Setup Name, which displays in the log, and an optional Description. At this point, Status is Inactive by default.

5) In the **Settings** tab, define phases and gates conditions.

6) In the **Schedule** tab, you can schedule regular gates.

---

**Add phases to the gates setup (Settings tab)**

Select which of the phases to use in the shell or shell template from the available phase list. You can reorder them as necessary for the shell instance or shell type template.

**To add phases to the new gates setup**

1) Open the Gates Setup window and click the **Settings** tab.

2) In the **Phases** pane, click the **Add** button. The Select Phases window opens, displaying the list of available phases.

3) Select one or more phases to add to the list. To select multiple phases, hold down the **CTRL** or **SHIFT** keys while selecting.

4) Click **OK**. The phases appear in the Phases list.
   
   The order in which the phases appear on the list is the order they will be followed in the shell. The first phase on the list will be the first phase of the shell.

---

**Access gate configuration view**

**To access the gate configuration view**

Select a phase. The gate configure view opens in the right pane. See the following table for more information about the gate configuration view.
The **Phase Gate Configuration** section in the navigator lists the Phases for the current shell. The visual order of the Phases depends on the Order specified in the General tab.

The **Gates Conditions Elements** section allows you to define condition criteria per element. Gate Elements will be selected from all Unifier data sources and modules available in a particular shell (for the Sponsoring company).

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start Date</strong></td>
<td>The Start date for a particular Phase can be manually set or auto populated from a Schedule Sheet by linking it to a particular activity or milestone (activity with zero duration and marked as milestone) where it will update dynamically based on the start date associated with this activity. If there are multiple Start dates, choose the Start date used to set Gantt Charts in Schedule Manager. The start date must fall within Shell date ranges.</td>
</tr>
<tr>
<td><strong>Planned Completion</strong></td>
<td>Can be manually set or auto populated from a Schedule Sheet by linking it to a particular activity or milestone (activity with zero duration and marked as milestone) where it will update dynamically based on the start date associated with this activity. If there are multiple End dates, choose the End date used to set Gantt Charts in Schedule Manager. <strong>Note</strong>: Dates are for reporting only. Phases cannot be date driven.</td>
</tr>
<tr>
<td><strong>Advance to Next Phase...</strong></td>
<td>This checkbox enables automatic phase advancement. Select the checkbox if you want the shell to move automatically to the next phase once all Gate Elements for a particular Phase have been checked.</td>
</tr>
<tr>
<td><strong>Notify users on Phase Completion</strong></td>
<td>Allows you to define users who receive phase completion notification. You can configure the body text in the notification (similar to the business process Setup on the End Step, where you can specify the message text content.</td>
</tr>
</tbody>
</table>
| **Reevaluate conditions on every Gates run** | When selected, this checkbox specifies that processing always starts at the First phase during a scheduled Gates Run/Refresh. You might have to scroll down to see this checkbox. If the checkbox is not selected for a phase:  
  - If the phase is currently incomplete, incomplete conditions are evaluated and completed conditions are skipped  
  - If the phase is currently complete, phase processing is skipped  
  If the checkbox is selected in a phase:  
  - Every condition in that phase is reevaluated. Including conditions that were met  
  - All conditions (except conditions that were marked as "ignore" manually) are marked as incomplete at the beginning of every Gates run and refresh.  
Saved Gates run (PDF) from prior runs persist. Processing will stop at a Phase where first un-met condition is encountered. By default this... |
Configure gate elements

To add a Gate Condition Element
1) In the Gates Setup window, gate configuration view, select a phase and click Add. The Data Type window opens.
2) Select a Data Type from the drop down menu.
3) Click OK. The Edit Gate Condition window opens.
4) Complete the General tab: Enter a Name for the Gate Element. This can be the name of the data element or any descriptive name. This appears on the Gate Conditions Elements list. You can add an optional Description.
5) Click Apply to save changes, or OK to save changes and exit the window.

To define query and trigger conditions
1) In the Edit Gate Condition window, click the Query tab.
2) Under Query Conditions, click Add. The Query Condition window opens.
3) Complete the Query tab:
   - Data Element: Click the Select button. The Data Element Picker opens. The list is generated from the data type you chose in the General tab. If the data element is a picker, pull-down or radio button, the Value field will display the values entered in the data set tab of for the data definition associated with the data element. For a full list of data elements and data types, refer to the Unifier Reference Guide.
   - Label: The label defaults to the data element name. You can enter a different label.
   - Condition: Define Gate Condition Element Condition. The condition options vary dynamically depending on the selected Data Element. The screen shots below list out the various options for different Data Element types. Examples include equals, does not equal.
   - Values: Specify value. The Values field varies dynamically depending on the selected Data Element and Condition. (For example, if the element is a text box, the condition might be Contains, and value might be one or more letters to search for. If the element is a pull-down or other data definition with a data set, you will select a value from the data set.)

Change the order of phases

To change the order of the phases in a gates setup
Select a phase and click the Move Up or Move Down button.

Define gates runs schedule (Schedule tab)
You can define a gates run schedule in the Gates Setup window, Schedule tab. This run evaluates gates conditions, and marks completed conditions as Complete. The update process can also be invoked manually in user mode. The scheduler engine is a background process.
In this field: | Do this:
---|---
Enable Scheduled Gates Runs | Select this checkbox to enable scheduled updating of Gate Elements. Deselecting this checkbox will disable the scheduler, and any scheduled future runs will be canceled immediately. The scheduled gates runs are disabled in the last phase provided all conditions are met, and the Enable Scheduled Gates Runs checkbox is automatically deselected.

Frequency | Choose Frequency of the Scheduled Gates Runs (Daily, weekly, monthly, quarterly, yearly)

Range of Recurrence | You can specify a date on which the Gate Runs will end, or no end date.

Auto-email as PDF Attachment to Gates creator | Select this checkbox to enable automatic emailing of the scheduled run results as a PDF attachment. The report displays the current status of each phase and gate condition.

### Activate or deactivate a gates setup

Activating a gates setup will enable the scheduled gates runs. After activation, if you need to edit the gates set up, you will need to deactivate it first.

You can make edits while the setup is inactive, including: adding or removing phases; reordering phases; add, modify or remove conditions within a phase.

Some notes about activating/deactivating gates setup:

- Reactivating an active shell: If you temporarily deactivate a shell that is in process, and then reactivate it, the gates check will start over at the first phase. This is because the setup needs to check all phases for new phase additions or new gate conditions that may have been added. You can manually update the phases by clicking the Refresh button for gates in User Mode. This will evaluate all phases starting from the first phase, even if the phase has been marked Complete, and mark the first phase as the current phase. Be aware this may trigger email notifications regarding gates advancement, as set up in the Settings tab (where the users who are notified are defined), and those users’ email subscription settings (User Preferences).

- While a gates set up is Inactive: No scheduled gates run will be done. To manually advance phases in User Mode Gates for the shell, the gates setup must be active.

- View-Only and Inactive shells: If a shell has the View-Only or Inactive status, the gates setup is inactivated, and you must manually reactivate the setup.

### Set user permissions for gates

To grant User Mode Gates permissions:

In Access Control or Permissions window, navigate to **User Mode > Shells/Projects (Standard) > Gates**. The permissions are:
Change Phase: Allows the user to change gates phases.
Modify and Refresh: Allows the user to modify gates and refresh gates.
Refresh: Allows the user to refresh gates.
View: Allows the user to view gates.

Editing Multiple Shells at once with Bulk Edit

If you have a large number of shells that need similar edits, you can use bulk edit to update all of them at once. You can update a maximum of 200 records using bulk shell edit. The bulk edit must be defined in uDesigner, and you must have the Allow Bulk Edit permission set on the shells in order to use the bulk edit.

The bulk edit function works only on fields from the action form (upper form) for the current step. It cannot be used to edit the following:

- Auto-populated fields
- Fields in a dynamic data set
- Read-only fields
- Fields from line items
- System-generated fields, such as record number, status, or due date

Notes:
- An Integration interface must be created for Bulk Edit to work with Shells.
- You can use bulk processing to update users in shells. See Managing users in bulk (on page 152) for details.

To edit shells using bulk edit

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells in the left Navigator.
3) Select one or more shells, or perform a Find to search for a group of shells to work with. You can select the shells from the shell log or the Find log.
4) Choose Edit > Update > Bulk Edit. The Bulk Edit window displays. The fields displayed in this window depend what was specified in uDesigner for the shell.
   The Bulk Edit form includes all editable fields for the shell. All system-generated elements and formula columns are automatically recalculated during the bulk edit for each record.
5) Modify the Bulk Edit form as needed.
6) Select the Update checkbox for the fields you want to update. The checkbox is automatically selected when you type into or modify a field. You can deselect it if you do not want to modify the field at this time.
7) Click Update. This launches the bulk update of the selected records.
   The Bulk Actions Status window opens after you click Update. This window allows you to monitor the progress of the bulk update.
8) Click OK after all records have processed. Click Cancel if you want to cancel the bulk update in progress.
About Shell Dashboards

Shell dashboards display project data in an at-a-glance format. You can control the dashboard appearance and content and make it specific to the shell with which you are working; however, shell dashboards cannot pull data from across shell hierarchies. For example, consider two anchor shells, which are seen as tabs, one is labeled "Capital Projects," and one is labeled "Facilities." The Capital Projects dashboard can display data from all levels of the Capital Projects hierarchy; however, it cannot display Facilities data because Facilities is the root of a separate, independent hierarchy.

Two types of dashboards are available in project shells:

**My Dashboard:** All shells have a personal dashboard that a user can define if he or she has Setup permission. A user can configure My Dashboard in User Mode using the Edit Dashboard window. Users can select My Dashboard from the View Dashboard drop-down list on each shell.

**Shell dashboards:** Shell dashboards allow users to view shell and subordinate shell data. This differs from My Dashboard in that a user cannot share his or her personalized dashboard. Administrators can create multiple shell dashboards per shell and push them via templates. Users can select this type of dashboard to view from the View Dashboard drop-down list on each shell. These dashboards are maintained at the shell level and are available to any user to view (but not edit) provided the user has permissions.

Each shell dashboard has at least one tab and can have up to five tabs. The default tab name is Summary, which you can change. The default shell dashboard layout contains these four blocks:

- **Image:** Displays the image your company administrator uploaded for the shell.
- **Items Requiring Your Attention:** Contains items that are generally listed on the Unifier Home page, such as tasks and messages.
- **Details:** Lists shell details, including shell number, shell name, administrator, and other details.
- **Links:** List of links configured for the shell by your company administrator.

On each tab, you can select a different layout to which you can add blocks of these types:

- **Standard:** Use this selection to view project data from, for example, business process, manager, users, and active tasks.
- **Portlet:** Use this selection to view an external URL, such as a web cam, or a frequently visited website.
- **Drilldown:** Use this selection to slice and dice project-shell data.
- **Custom:** Use this selection to view data from the current shell, subordinate shells, or both (cannot cross hierarchies).

**Setting shell instance dashboard permissions**

To set shell instance dashboard permissions:

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode Access > Permissions for Shells / Projects (Standard) > Setup > Dashboards**.
4) Set the permissions as needed:
   - Setup: Administrators can create a shell instance dashboard.

Creating a shell dashboard in a template

You can create new dashboards in shell templates and push them to shells. See *Update shell instance dashboards* (on page 320) for details.

You can edit a dashboard in an established project shell. For details, refer to the *Unifier User Guide*.

**To create a dashboard in a shell template**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell name] > [project shell template] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Click **New**. The Dashboard Properties window opens.
4) Enter the dashboard name and an optional description. The dashboard name must be unique within the shell.
5) Click **OK**. The dashboard is listed in the log.
6) Select the dashboard in the log and click **Open**. The default view of the shell dashboard opens.
7) Choose **Edit > Dashboard**. The Edit Dashboard window opens.

   **Note**: You might not see data in parts of the dashboard if you do not have specific permissions to access data cubes.

Copy a shell dashboard

You can create new shell dashboards by copying and modifying existing dashboards. Copying a shell dashboard does not copy the permissions associated with the dashboard, but will copy all other dashboard information.

**To copy a shell dashboard**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [shell name] > [project shell name] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Select a shell dashboard.
4) Click **Copy**.
5) Enter the name of the new dashboard and an optional description.
6) Click **OK**. The dashboard is listed in the log.
7) Select the dashboard in the log and click **Open**. The shell dashboard opens.
8) Choose **Edit > Dashboard**. The Edit Dashboard window opens.
9) Modify the new dashboard as needed and **OK**.
Modify shell instance dashboard properties

To modify shell instance dashboard properties:
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [shell type] > [shell instance] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Select a shell instance dashboard.
4) Click **Properties**.
5) Modify the dashboard name or description as needed.
6) Click **OK**.

Delete a shell instance dashboard

To delete a shell instance dashboard
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [shell type] > [shell instance] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Select a shell instance dashboard.
4) Click **Delete**.

Find a shell instance dashboard

To find a shell instance dashboard
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [shell type] > [shell instance] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Click **Find**.
4) Enter the search criteria and click **Search** (or press Enter). Unifier displays all the dashboards that met the search criteria you entered.

Set user or group permission for a shell instance dashboard

To set user or group permission for a shell instance dashboard:
1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Company Sponsored Shells > [shell type] > [shell instance] > Setup > Dashboards** in the left Navigator. The Dashboards log window opens.
3) Select a shell instance dashboard.
4) Click **Permissions**.
5) Add users or groups as needed. Select the **View** permission.
6) Click **Apply** to save or **OK** to save and exit.
Migrating standard projects to WBS shells

You can migrate one or multiple standard projects to WBS shell types that you specify. After migration, the new WBS shell is created in the shell hierarchy in the location you specify, and the standard project is no longer listed in the project log in Unifier. All of the data that existed under the standard project can then be accessed from the newly-created WBS shell.

**Note:** When you migrate a standard project to a WBS shell, you cannot undo the migration and return the shell to the standard project form. The migration cannot be reversed, so be sure that you want to perform the project-to-shell migration.

After you migrate standard projects to WBS shells, you can use the features that shells offer, such as:

- Hierarchical distribution, visualization and navigation of capital projects when organized under shell hierarchies based on business needs
- Configurable dashboards
- Roll up of cost data across the shell hierarchy

**Migration limitations**

The following are some migration limitations for you to consider:

- The shell type must be a WBS shell. You cannot migrate standard projects to generic shells, only to WBS shells.
- Shell name is limited to 128 characters, and shell description is limited to 250 characters. However, standard project name is limited to 250 characters, and the project description is limited to 2000 characters. In order for the migration from project to WBS shell to be successful, you must modify the project name and description to be within the limits for these fields that exist for the shells (128 characters for a shell name, and 250 characters for a shell description).
- The standard project name cannot contain any special characters, such as: `\/:*"<>|`
- You cannot migrate a standard project to a single instance (top level) shell. You can only migrate to multiple-instance shells.
- Even if the destination WBS shell type has auto-numbering setup, the migration cannot incorporate the new shell into the shell auto-numbering, but instead copies the project number while creating shell. The new shell is identified by the project number of the original project.
- You will have to set up a new configurable shell dashboard for the new shell that is created by the migration. Any existing project summary set up does not migrate to the new shell.
- If any business processes, planning items, assets, and configurable managers in the original project use project pickers, then you will have to recreate the link between these objects and the new shell.
- Migration from a standard project to a WBS shell cannot be reversed. Once the migration is complete, the standard project is converted to a WBS shell, and the information from that project resides in the newly-created WBS shell.
Migration considerations

Before you migrate:

- Be sure that you have Integration defined for the WBS shells you plan to use for migration.
- Examine the shell hierarchy of your WBS shells and determine the location for the new migrated shells. You can migrate several projects at once into a shell type, creating a new shell instance under that shell type for each migrated project.
- Examine the set ups for the original projects and also for the destination shells, and think about the mapping from the project to the shell. You might have to add data elements on the project side or the shell side to ensure that the data you need is migrated correctly and completely. For example, the shell name is limited to 128 characters, and shell description is limited to 250 characters. However, standard project name is limited to 250 characters, and the project description is limited to 2000 characters. In order for the migration from project to WBS shell to be successful, you must modify the project name and description to be within the limits for these fields that exist for the shells (128 characters for a shell name, and 250 characters for a shell description).
- As a best practice, do not migrate projects that have the Active status. Modify the projects as needed to get them as finished as possible and then put them in the Inactive status before migration. Make your project as complete as you can before you migrate it to a WBS shell.
- Test your migration in your uStage testing environment before implementing it in your production environment to ensure that the migration is successful and yields the desired result.
- You can use user-defined reports to gather data regarding which projects to migrate and the location they should occupy in the shell hierarchy.
- Understand that migration cannot be undone; when you migrate a project to a WBS shell, you cannot go back to that project. The project is converted completely to a WBS shell when the migration completes successfully.

Migration mapping of project data elements to shell data elements

The following table shows the automatic mapping of original project data elements to destination WBS shell data elements. These data elements define the fields shown on the project or shell setup window tabs. This mapping occurs automatically during the migration. When a standard project is migrated to a WBS shell, the project’s data element values are automatically populated in the equivalent shell data element as listed in the table:

<table>
<thead>
<tr>
<th>Standard project data element</th>
<th>WBS shell data element</th>
<th>Comments on action during migration</th>
</tr>
</thead>
<tbody>
<tr>
<td>General tab of WBS shell</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Project Number</td>
<td>Shell Number</td>
<td>One-to-one mapping occurs.</td>
</tr>
<tr>
<td>Project Name</td>
<td>Shell Name</td>
<td>One-to-one mapping occurs.</td>
</tr>
<tr>
<td>Description</td>
<td>Description</td>
<td>One-to-one mapping occurs.</td>
</tr>
<tr>
<td>Administrator</td>
<td>Administrator</td>
<td>One-to-one mapping occurs.</td>
</tr>
<tr>
<td>Project Status</td>
<td>Shell Status</td>
<td>One-to-one mapping occurs.</td>
</tr>
</tbody>
</table>
Unifier Administration Mode

### Currency tab of WBS shell
- **Currency Name**: Currency Name
  - One-to-one mapping occurs for all defined currencies.
- **Rate**: Rate
  - One-to-one mapping occurs for all defined currencies.
- **Type**: Type
  - One-to-one mapping occurs for all defined currencies.
- **Hedge Rate**: Hedge Rate
  - One-to-one mapping occurs for all defined currencies.
- **Hedge Amount**: Hedge Amount
  - One-to-one mapping occurs for all defined currencies.
- **Default Currency**: Default Currency
  - One-to-one mapping occurs.

### Options tab of WBS shell
- **Project Image**: Image
  - One-to-one mapping occurs.
- **Project Phase**: Phase
  - One-to-one mapping occurs.

### Links tab of WBS shell
- **Name**: Name
  - One-to-one mapping occurs for all defined links.
- **URL**: URL
  - One-to-one mapping occurs for all defined links.

---

## Migrate projects to shells

**Before you begin**: See the considerations and mapping discussed in Creating a Business Process record from a template.

**Step 1: Export the migration template.** Export the CSV template. This template will vary depending on the data elements included in the configuration of a particular shell type. This template contains the fields and format that the system needs to migrate the standard projects to WBS shells. See *Export the migration template* (on page 340).

**Step 2: Modify the exported CSV template.** Be sure that you have the correct project information ready to enter into the template. After you convert a standard project into a WBS shell, you cannot reverse the conversion. See *Modify the exported csv template* (on page 340).

**Step 3: Initiate migration.** Import the completed CSV file. See *Initiate migration of standard projects to WBS shells* (on page 341)
Step 4: View migration history. See View migration history (on page 341).

Step 5: Test for shell creation. See Test for WBS shell creation (on page 342).

You export the template, then modify it and import it. You will export the template from a selected WBS shell, and then import the modified template back into the same WBS shell to complete the migration.

Export the migration template

To export the migration template

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Company Sponsored Shells > <WBS shell type>.

   Note: The shell type must be for a WBS shell. You cannot migrate standard projects to generic shells, only to WBS shells. You cannot migrate a standard project to a single instance (top level) shell, only multiple-instance shells.

3) In the shell type log, choose Export Template > Project Migration Template.
4) Download the template to the desired location. The template you download will be specific to the shell type of the log from which you exported the template.

Modify the exported csv template

Be sure that you have the correct project information ready to enter into the template. After you convert a standard project into a WBS shell, you cannot reverse the conversion.

   Note: You can use user-defined reports to gather data regarding which projects to migrate and where they should be in the shell hierarchy.

To modify the template

1) Open and edit the CSV template, per the template content, and the description of the template content in this section. It is recommended that you migrate projects that are not in the Active status. The content of the migration template will vary depending on the shell type into which you choose to migrate.

The exported template is organized in three sections:

   › Instructions: This section at the top of the template explains how to fill in the template to initiate the migration. Do not modify this text.
   
   › Mapping: This section maps the available standard project attributes with the user-defined WBS shell attributes. Use this section to create mapping for data elements that you have added in addition to the data elements listed in the table in Migration mapping of project data elements to shell data elements (on page 338). The Mapping section lists all the project attributes which are not automatically mapped. If you use custom project attributes, these attributes be listed and mapped in this section. The project data elements are static; you add the shell data elements to complete the mapping. The values in this section are overwritten by any literal values that you add in the Project section.
Project: This section lists the Project Number and Location, and the use-defined WBS shell attributes as column headings. Project Number and Location are mandatory; the other columns are not, and are based on the attributes listed in the Mapping section. This list does not include the automatically-mapped shell attributes such as Shell Name or Shell Number. Add a row for each project you want to migrate, and enter the Project Number and the Location. The location should be delimited with /. For example: /Capital/Project/Buildings/Tool Sheds. Add the literal values that are to be changed during the migration.

**Note:** Projects are identified by the Project Number for migration. Be sure that you enter the correct project numbers for standard projects you want to migrate to WBS shells.

2) Save the template CSV file.

### Initiate migration of standard projects to WBS shells

You can migrate several projects at once into a shell type, creating a new shell instance under that shell type for each migrated project. Before you initiate the migration, ensure that you have the Create permission on the destination shell type, in order to create the shell instances from the migrated projects. You exported the template from a selected WBS shell, and then import the modified template back into the same WBS shell to complete the migration.

**Note:** You cannot undo the migration of standard projects to WBS shells after the migration completes successfully. Verify that you have completed the CSV migration template correctly, especially in terms of the Project Number.

### To initiate migration

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [WBS shell type]** in the left Navigator.
3) In the shell type log, choose Import > Migrate Projects into Shells.
4) Browse for the CSV file and click **OK**.

This imports the migration template and performs validations on the data. The migration is a background process. Each project listed in the CSV file is migrated into a WBS shell based on the mapping and values provided in the CSV. Project migration is either successful or not successful. Validation is performed before migration, and if there are any errors, a project is not migrated. Errors can include incorrect mapping or invalid format of the project rows (including changing column order or adding or removing columns).

### View migration history

You can view the status of each submitted migration by using the Migration History.

### To view migration history

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Sponsored Shells > [WBS shell type]** in the left Navigator.
3) In the shell type log, choose Import > Migration History.
Each submitted migration is listed in Migration History with one of these statuses:

- **Not Started**: The migration process has not started.
- **In Progress**: The migration process is in progress.
- **Completed Successfully**: The migration of all standard projects completed, and the corresponding WBS shells have been created.
- **Completed with Errors**: The migration of standard projects has completed, however, there were some errors that prevented the migration of some of the projects to WBS shells.

Potential migration errors:

- Location entered is invalid. This error can occur if the location does not exist or is inactive in the shell hierarchy.
- Cannot create an instance of the shell type under the location entered; does not exist in the shell hierarchy.
- Project number could happen to be the same as the number of an existing shell in the hierarchy. Shell numbers must be unique.
- String values are entered incorrectly. Enter the labels for string values.
- The standard project name is limited to 250 characters, and the project description is limited to 2000 characters. In order for the migration from project to WBS shell to be successful, you must modify the project name and description to be within the limits for these fields that exist for the shells (128 characters for a shell name, and 250 characters for a shell description). Any error can result if the project name or project description are longer than the character limits for the shell name and shell description.

4) If any of the projects did not migrate due to errors, you can view the CSV with the rows that have errors by clicking the Completed with Errors status hyperlink.

This link allows you to download the CSV containing any errors. This file is in the same format as the submitted CSV, with all mapping information retained. However, in the Project section, only the rows which have errors in them are shown with an additional column added containing error comments. You can use this CSV file to review the errors and then re-import the file after you correct the errors.

5) Click **Close** to close the Project Migration History window.

**Test for WBS shell creation**

Ensure that your new WBS shell is created correctly and contains the attributes that you expect:

- The shell instance should be accessible in Administrator and User Mode (for Unifier and Unifier Mobile) under the parent shell it was migrated to.
- Users should be able to navigate to the business process and other manager data under the new WBS shell.
- Shell creation will trigger email notification.
- User/groups membership should remain same as on the original standard project.
- All the auto-population, reverse auto-population, linked elements, and other settings should work as they did on the original standard project.
Internationalization and CSV Files

Importing and exporting data in Unifier can be done by using a Comma-Separated Values (CSV) data file or a CSV template file.

This section explains how the availability of different languages (Internationalization) impact the various CSV files created, used, imported, or exported.

**Note:** Number formatting is not supported for Symbols that are based on a right-to-left language such as official languages of Afghanistan or Hebrew.

**Generic CSV files**

Language preferences are detected from the User Preferences settings, for both CSV data files and CSV template in:
- All column headers
- All informational text

If importing a CSV file fails, the import error file displays the system generated error messages in the preferred language.

If importing a CSV file fails because of form validation errors, then the custom error message displays the message in the preferred language.

**Notes:**
- If translation is not available for a custom error message, then the source string is displayed.
- Before importing a CSV file, always check the User Preferences settings to see the allowed format and number formatting.
- When importing, or exporting, a CSV file, the date format follows the User Preferences date format settings.

**CSV files and sheets (importing or exporting column details)**

**Exporting a CSV file, with or without and import:**
- When you export a CSV data file from the sheet, the numeric fields display according to your User Preferences settings, the number format options settings.
- In Unifier functionalities that allow export and import of data through a CSV file, the currency symbol and digit grouping symbol are not displayed.
- In Unifier functionalities that allow only exporting of data but not importing data through a CSV file, the currency symbol and the digit grouping symbol are displayed.
- In Unifier functionalities that allow only exporting of data but not importing data through a CSV file, the negative numbers display according to your User Preferences settings.
- Decimal symbol display according to your User Preferences settings.
- In Unifier functionalities, which allow exporting and importing of data through a CSV, the negative numbers, if any, displays as: `<Number, Decimal Symbol, Number>` (Example: -100000,99 – The decimal symbol is comma)
If there are any date fields, then the dates are formatted based on your User Preferences settings.

Importing a CSV data file

- If importing a CSV data file (Example: Importing Column details), the column data appears according to your User Preferences settings.
- You do not need to enter the Currency symbol manually because the symbol is included in the header. Entering the Currency symbol manually generates an error message.
- When importing a CSV file is complete, the number formatting displays according to your User Preferences settings.
- When importing a CSV file is complete, the date formatting displays according to your User Preferences settings.

List of impacted sheets and modules

- Cost Sheet
- Funding Sheet
- CM sheet
- Generic Cost Sheet
- Planning Sheet
- Summary Fund Sheet
- Summary Budget
- WBS Details
- Column Details
- Data Definitions (DDs) export

List of modules impacted by exporting, only

In Unifier functionalities that allow only exporting of data but not importing data through a CSV file, the column headers and the Data Element (DE) labels display according to your User Preferences settings. The following shows a list of modules impacted by exporting, only:

- Basic data definitions under Data Structure Setup
- Cost Codes under Data Structure Setup
- Data Elements under Data Structure Setup
- Data Picker under Data Structure Setup

CSV templates

- When exporting a CSV template, the column headers display according to your User Preferences settings. The following provides additional information:
- If you enter data for any text type DE, the data is not translated. Example: "Vendor Specialty" is a text type DE. If the User enters "Electrical Appliances" as the data, then the entry is not translated according to the User Preferences settings.
- You must not include currency and digit grouping symbols when you enter data because the information is captured as a part of header information and according to your User Preferences settings. If you enter currency and digit grouping symbols when you enter data, you receive an error message.
- Ensure that you enter the negative number format with a minus sign at the beginning of the number: Example: -10000,99 (minus 10000 comma 99). The decimal symbol is a comma)
If you enter a value in the date field, or in line items, through CSV, the values display according to your User Preferences settings.

**Notes:**
- All error messages, system, custom, or form validation, display according to your User Preferences settings.
- The file name of an exported file will not be translated automatically.

The following lists the impacted modules:
- CSV Import for all Business Processes for record creation
- CSV Import for Asset Manager Objects for record creation
- CSV Import under CM – Code and Record based manager for record creation
- CSV Import under Planning Manager for record creation
- CSV Import under Portfolio Manager for record creation
- CSV Import under Shell Manager for record creation
- CSV Import under Space Manager for record creation
- CSV Import under User Administration for record creation
- Line Item import for Line Item creation

**Additional information about exporting and importing CSV files**

When importing and exporting of a CSV file is conducted by Users with two different language settings, for example French and German, the data entered into an exported file must match the original language set.

**Example**

The CSV template Export has been done in French and the template is being used by a German User. If the German User enters data without changing the column structure and Import the file, the Import action will fail and an error message will appear in German, indicating the error.
Internationalization and Web Services

About Web Services

New records can be created and line items added using Integration through Web Services. Also, the Unifier Schedule Manager integrates with Primavera scheduling software by way of Web Services.

**Note:** Integration through Web Services must be coordinated with an Oracle Primavera representative.

As Project Administrator, you can receive email notification of the successful creation of a shell instance, for shells that are created manually, through Web Services or a CSV file upload, or through auto-creation. This notification can be set up in email notifications in uDesigner. Also, you can set your User Preferences to control whether you receive these notifications.

Refer to the *Unifier Reference Guide* for data elements you can use with Web Services.

Web Services and Internationalization

The output data generated by Web Services is always in the source language.

**Note:** If a record (Example: Business Process) is created by using Web Services and the Data Definition (DD) label includes a non-ASCII string, then the record creation will fail.

Number formatting of data

When you enter numeric data in XML, you can use the decimal point (period) and negative sign (dash), only.

Examples

- XML Tag: `<Committed_Amount>100.99</Committed_Amount>`
- XML Tag: `<Credited_Amount>-1423.99</Credited_Amount>`

Get Web Services

You can use the Get Web Services call methods to get various attributes of Shell, WBS, and the list of Business Process records, Shells, and User defined data.

When a Get call is executed, all the input content in the response XML will be in the language of the source strings.

Number formatting does not apply to the numeric data and the decimal point is a period. The negative numbers are displayed with the minus sign before the numeric data, for example, -12345.99.

**Note:** Number formatting is not supported for Symbols that are based on a right-to-left language such as official languages of Afghanistan or Hebrew.
Internationalization (Email Notifications)

When Unifier generates an email notification, the language used for that email is based on the recipient's User Preferences.

Email notifications for scheduled User-Defined Reports (UDRs), Gates, and so forth, have two components:
- Text
- Attachments

If a Business Process (BP) email notification contains an attachment with the record information, then the Custom Strings and number formatting in the attachment is according to the User Preferences.

If a scheduled UDR is sent as a part of an email attachment, the language in the PDF attachment is according to the User Preferences of the UDR owner; however, the email text content is according to the recipient's User Preferences.

When a UDR is generated manually and saved by a User, the language in the PDF attachment is according to the User Preferences of the User who generated, or ran, the UDR.

If a scheduled job such as Project Gates, where the "Auto-email as PDF attachment to users and groups" option is selected, the language in the PDF attachment is according to the User Preferences of the creator of the job (Project Gates creator).

When a manual refresh of the Gates is requested, the language in the PDF attachment is according to the User Preferences of the User who requested the refresh.

Internationalization (Support for Tools)

When used within Unifier, the following tools support internationalization:
- Oracle Map, Autovue Server, Flex replacement (O charts)

  Note: The Unifier Plug-ins do not support internationalization.

Oracle Map viewer supports internationalization for Tier 1 languages. Refer to the Oracle Map Viewer User Guide for more details.

The language displayed in the map, and the following subsequent areas, is according to the language selected in the User Preferences of the User:
- View map for BP records from log
- Shell Landing Page
- Map Picker in Log Find
- Map Picker in Bulk Edit
- View Map when invoked from the BP record
**Note:** eLocation services, which is used for geocoding, does not support internationalization. As a result, the map labels are displayed in English. If a User enters a label in a different language, then the Find feature does not provide the desired results.

---

**Internationalization (BI Publisher Custom Reports)**

The Oracle Business Intelligence Publisher (BI Publisher or BIP) Reports support internationalization as follows:

**Custom Report (Report File tab) window**

If there are no templates available for the report, the Custom Report window (Report File tab) displays according to the default settings.

To upload the translated XLIFF files and report layout, click **Add** to open the Add Template and Files window, enter data in the required fields, and click **OK**.

**Notes:**

- The non-RTF templates do not support internationalization.
- You can change the template type when the template is in Creation stage, only. Once you create a template, you cannot change the template type. Use the report designer to create a new template with the desired template type and remove the template that is no longer needed.

In the Custom Report window (Report File tab), the only editable column is the Default column, which allows you to set the default template by selecting (check-box) the corresponding template.

**Note:** The system sets the first template, or XLIFF file, that you upload as the default template.

Use **Modify** in the Custom Report window (Report File tab) to modify an existing template. Once you click Modify, the Modify Template and Files window opens which allows you to modify the template and the translated XLIFF file for that template. When finished, click **OK**.

Use **Download** in the Custom Report window (Report File tab) to download a template and the corresponding translated XLIFF file, in a zip file.

**External Data Model BI Publisher Reports**

If you want to download the data model of a template, select the template and click **Download** in the Custom Report window (Report File tab). When the download is complete for an External BIP report, the data model is included.
Non-RTF type template

BIP supports RTF templates and XLIFF files. If the report designer selects a non-RTF type template, the Browse option in the Modify Template and Files window (Translated XLIFF files for the Template section) will be disabled.

Custom Report (Query tab) window

Queries based on Data Definition (DD) support internationalization and number formatting associated with internationalization according to the User Preferences settings.

Queries based on Data Views do not support internationalization and formatting because raw data is being used.

Queries based on Ad-Hoc support internationalization and number formatting associated with internationalization according to the User Preferences settings.

Internationalization (Dashboards)

Shell Dashboards

The Shell Dashboards support Internationalization and number formatting for System Strings as well as Custom Strings according to the User Preferences settings.

Custom Dashboards

Custom Dashboards have two components:

- Data cube
- SWF file

The SWF file uses the data cube and the labels are created when the user selects the Download XML option from the Custom Dashboard log and downloads the generated XML. The language used in the generated XML is based on the User Preferences settings for both System Strings and Custom Strings.

Note: If you change the language, you need to recreate the SWF (Small Web Format) file in order to generate a translated XML. If there are no caching of data in the Dashboard, the translation takes place, but if there caching of data in the Dashboard, then there will be no translation.

Internationalization (Help Files)

Unifier Help files do not support Internationalization and are not translated.

Note: You can translate the Help files, using a third party translator, and display the files based on the your User Preferences settings. This includes uploading a single PDF with multiple language help information.

Internationalization (Spell Check)

The Spell Check feature does not support Internationalization.
Note: If the language selected in your User Preferences is not English, the Spell Check option will not be available.

### Internationalization (Date and Time Zone Formats)

#### Date formats
The following additional date formats support Internationalization:

- MM/DD/YYYY
- DD/MM/YYYY
- MM/DD/YY
- DD/MM/YY
- MM-DD-YYYY
- DD-MM-YYYY
- MM-DD-YY
- DD-MM-YY
- DD.MM.YYYY
- YYYY-MM-DD
- MMM/DD/YYYY
- DD/MMM/YYYY
- YYYY/MMM/DD
- M/D/YYYY
- M/D/YY
- D/M/YYYY
- D/M/YY
- YY/M/D
- YYYY/M/D
- YY/MM/DD
- YYYY/MM/DD
- YYYY/MM/DD

#### Time Zone formats
The Time Zone setting is based on the Coordinated Universal Time (UTC) and support Internationalization.

Note: The time format for all dates is: HH:MM AM.

### Internationalization (Audit Log)

Within the Audit log, the following columns support Internationalization according to the User Preferences:

- Event
- Description
Field

For Event, Description, and Field columns, System Strings are and Custom Strings can be translated.
Setting Up Business Processes

Information is entered and stored in Unifier using electronic business process forms and routed via configurable workflows. Business processes -- and their workflows, logs, and even search parameters -- can be created and designed in uDesigner. They are then imported into Unifier, configured for use, and set up for use in specific projects, shells or the company workspace.

Setting up business processes for use in Unifier consists of the following steps:

**Step 1:** Import and deploy business processes from uDesigner.

**Step 2:** Configure the BPs. This configuration enables the BP to be set up for use. It consists of establishing the record number sequence, determining which BP log the records will be stored in, and activating workflows.

**Step 3:** Set up the BPs. After configuring, BPs must be set up for use at the company level or in individual projects or shells. For workflow BPs, you can create multiple setups that allow you to use the same BP form with any number of customized workflows.

**Step 4:** Grant permissions. After setting up and activating a business process, you must grant User Mode permission to all users (including yourself) who will need to view records or participate in a workflow.

*Note:* Not all BPs work in all areas of Unifier. *Business Process Functionality in Unifier* (on page 418) for a table listing all available business processes and the functional areas in Unifier in which they are available for use.

---

**In This Section**

- Master Logs .......................................................... 353
- Advanced Logs and Standard Logs .................................. 354
- Importing Business Processes (BPs) ........................................ 355
- Configuring Business Processes (BPs) .............................. 355
- Business Processes Production Bundle Configuration ........ 366
- General Procedures for Setting up Business Processes ............... 366
- Business Process Permission Settings .................................. 418
- Business Process Functionality in Unifier .......................... 418
- Query-based Tab in Business Processes ........................... 420

---

**Master Logs**

Master Logs are located under the Home tab in Unifier. Master Logs allow users to access all or a subset of records of the same type, in a single log that spans multiple shells or projects. Master Logs list all business process types at the shell/project level in separate nodes for each type. This includes workflow, non-workflow, and multiple record business processes. Company-level and single-record business processes are not listed in Master Logs.
Master Logs are available for all business process logs; however, they are not visible to users unless they have permission to view the log.

For example, your company might have a shell hierarchy of buildings. A dispatcher who is responsible for translating service requests into work orders could use a Master Log to create and edit work order records for any building shell from a single, "master" log, rather than drilling into each building shell to access the records.

Master Logs can also be filtered to display only certain records. For example, a regional Lease Manager might need to access all of the active leases in the system that have lease amounts greater than $50,000 per year. Using the filter feature, the lease manager could display these leases in the Master Log, thereby making his/her work easier.

In order for users to view and work with a Master Log, you must grant permissions to it.

**Setting Master Logs Permissions**

You must give explicit permission(s) to users access the Master Logs node. You can grant permissions for users to access all business processes in the Master Log, or to individual business process types. To view business process records, users must also:

- Be an active member in the project, shell, or sub-shell
- Have access to at least one business process in the Master Logs node

All shell/project business processes in the system (except inactive and single-record BPs) are listed alphabetically in their corresponding Master Logs.

**To set Master Logs permissions**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **User Mode Access > Home > Master Log > <business process>**.
4) Set the permissions as needed:

   - **View**: Users can view all business process records across all projects and all records in the shell hierarchy (subject to their highest level of shell membership in the hierarchy) independent of whether or not they are assignees on or have permissions to view and manage individual records within a particular Shell or Project. These users can also view saved searches.
   - **Allow Bulk Edit**: Users can select one or more records within a Master Log and perform Bulk Edit on business process records. Selected records can potentially span across multiple shells. Users having this permission automatically have View permissions.

---

**Advanced Logs and Standard Logs**

For Business Processes, Shells, the Space Manager, and code-and-record-based managers, you can design either a Standard log, or an Advanced log that will work with the Business Process Master Logs and Data Pickers. An Advanced Log creates an extra navigation structure that makes it easier for the user to choose records to work with.

The "Business Process Log" option is pre-selected according the definition of Advanced Log, or "Standard" Log in uDesigner.
Users can manually change the view of the Business Process log from Standard to Advanced. The "Business Process Log" option is pre-selected according the definition of Advanced Log, or "Standard" Log in uDesigner.

- If you select the "Business Process Log" option that in Admin mode as "Standard," then in User mode:
  The Master Log for that Business Process displays the Advanced Log and all other Business Process logs render the Standard Log.
- If you select the "Business Process Log" option that in Admin mode as "Advanced," then in User mode:
  The Master Log for that Business Process displays the Advanced Log. In addition, all other Business Process logs render the Advanced Log.

### Importing Business Processes (BPs)

All designs, including Business Processes, are designed in uDesigner and deployed to Unifier. See the instructions in the topic [Importing and Deploying a Design](on page 273).

### Configuring Business Processes (BPs)

Business process configuration allows you to configure and activate the company-level information for each business process you will use. After business processes are deployed from uDesigner, they are available for use. Configuring allows activation of the business process and specific workflow schema that can be used in projects, shells, or the company level.

The "Enable for Mobile Application" checkbox must be selected for BPs that you want to be used in the Unifier Mobile App.

Configuration consists of:

- Activating or deactivating a BP (deactivating an active BP will also deactivate all of its setups)
- Determining which BP log the BP records will be stored in (e.g., project logs, shell logs, company logs, Data Manager, etc.)
- Establishing the BP record numbering sequence
- For workflow BPs, activating the workflows that will be allowed for use with the BP
- Creating a custom-designed print layout that can be used to print BP records

**Note:** Configuration of the Data Picker and Data Elements (and when applicable: Unique and Auto Sequence settings) must be done in uDesigner.

### Accessing Business Process configuration log

1) Go to the **Company Workspace** tab and switch to **Admin** mode.

2) Click **Configuration > Business Process** in the left Navigator. The Configuration - Business Processes log opens. The log lists the Business Processes that have been imported into Primavera Unifier.
The newly imported Business Processes are inactive by default and are activated during configuration. The ID column shows the short code used to identify the Business Process, as defined in uDesigner. During configuration, you can choose to include this identifier as part of the record number (for example, if a BP has an ID of uaici, individual record numbers created for the BP might be uaici-0001, uaici-0002, etc.).

**Create Custom-Designed BP Print Layout (Custom Print tab)**

In the Business Process Configuration window, the Custom Print tab allows you to customize the layout of a document, using either MS Word® (leveraging the XML style design) or PDF format (using Adobe® LiveCycle® Design View.)

You can use the custom print templates to print one record at a time. The document shows all the values of the record that are available. This feature is similar to Print Preview for HTML or PDF. The only difference is that you can custom design the format for the selected record.

Unifier automatically generates the XML schema, which is used to define the custom layout in Word or in LiveCycle. For a given business process, you can export the schema and use it to develop your own customized template. You then save the template and upload it to Unifier.

<table>
<thead>
<tr>
<th>With This button:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export Schema</td>
<td>Creates a custom print template using the PDF or Word option.</td>
</tr>
<tr>
<td>Download</td>
<td>Select a template and click Download to use a prepared custom template.</td>
</tr>
<tr>
<td>Upload, Rename, or Remove</td>
<td>Add, change, or remove the custom template. Select the template from the list and click the relevant button.</td>
</tr>
</tbody>
</table>

**Rename an existing template**

In the Custom Print window, you can make changes to the names of existing templates.

1) Select the template from the list and click **Rename**.
2) In the Rename window, make the changes in the **Title** field.

**Note:** If the template you chose was a MS Word template, there will be an additional field, Export As. This allows you to export the template as a different name.

3) Click **OK**.

**Preparing to build a custom print PDF template**

Prior to starting, make sure Adobe LiveCycle Designer has been downloaded to your computer.

1) In the Business Process Configuration log, open the desired business process form.
2) Click the **Custom Print** tab.
3) Click the **Export Schema** drop-down and select **Schema for PDF**. A pop-up window appears.
4) Save the XSD schema file to a location.
5) Open Adobe LiveCycle and click **File > New Blank document**.
6) Click **File > New Data Connection**.
7) Name the new connection and select **XML Schema**.
8) Click **Next**.
9) In the **Select XML Schema File** field, click the browse button and find the XML Schema file you just saved.
10) In the **Options** section, select **Embed XML Schema**.
11) Click **Finish**. The XSD tags appear in the Data View tab on the left pane of LiveCycle.

**Note**: The tag naming scheme is a combination of LiveCycle and Unifier names. The first word before the underscore is LiveCycle’s term, for example, "task," "form," and "lineitem." Everything after the first underscore is a Unifier data element. For a full list of the Unifier data elements definitions (XSD tags), see "XSD tags used in creating a PDF template" below.

**Building the template**

From the XSD tag list in the Data View tab on the left pane of LiveCycle and drag and drop your tags onto the template. For Attachments, Comments, Tabs and Workflow tags, special care needs to be made to ensure that the tags do not overlap in the printed output.

1) Select an Attachment, Comment, Tab or Workflow tag and drag and drop it onto the template, for example, "Attachments." The XSD tags display as a group inside a frame ("subform") with four small squares at each corner of the frame. The subform frame rests inside a frame called "top form."

2) Right-click on the subform’s frame corner and choose **Palette > Objects**. The Object tab opens on the right side of the LiveCycle window.

3) In the **Content** field, select **Flowed**.

4) Right-click on the top form’s frame corner and choose **Palette > Objects**.

5) In the **Content** field of the Object tab, select **Positioned**.
6) To add current workflow steps to the template, use the Task_Details tags.

7) When finished, click **File > Save**.

**Uploading the template into Unifier**

1) In Unifier Custom Print window, click **Upload**.

2) Navigate to the saved LiveCycle template and upload it. The name of the template appears in the Custom Print screen.

   The user can now print the business process record using the PDF template option (File > Print Preview > Custom.) The printed output will look similar to this:

**XSD tags used in creating a PDF template**

Below is a list of all the default XSD tags imported from Unifier into LiveCycle. Comments and attachments are recursive and repeatable. For example, an upper form can have comments with attachments. Line items can have attachments and comments to the attachments recursively.

<table>
<thead>
<tr>
<th>Type of tag Name Description</th>
<th>Type of tag Name Description</th>
<th>Type of tag Name Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard</td>
<td>▶ Shell_Logo - shell</td>
<td>▶ Applicable to all types of BP records</td>
</tr>
<tr>
<td>Element</td>
<td>or project logo / image</td>
<td></td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------------------</td>
<td></td>
</tr>
<tr>
<td>Use these tags to have project/shell information as part of the printed output</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Task_Details</strong></td>
<td><strong>Assigned_To</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>CC</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Sent_For</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Task_Due_Date</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Task_Status</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Task_Note</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Sub_Workflow</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Sub_Workflow_Due_Date</strong></td>
<td></td>
</tr>
<tr>
<td>Tags appear in the task section of a BP record</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Use these tags to print out the current step of the workflow</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Applicable to all types of BP records</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Upper_Forms</strong></td>
<td><strong>&lt;upper form1 name&gt;</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- name of the upper form, Example: contract view form</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>&lt;Elements from form1&gt;</strong> - elements within upper form</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>&lt;upper form2 name&gt;</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- name of the upper form, Example: contract action form</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>&lt;Elements from form2&gt;</strong> - elements within the upper form</td>
<td></td>
</tr>
<tr>
<td>Tags for all the upper forms available for a BP. Example: view form, action form etc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Applicable to all types of BP records</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Tabs</strong></td>
<td><strong>&lt;tab1 name&gt;</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- name of the tab</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Line_Items</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- line item tag that encloses all the elements within the line item</td>
<td></td>
</tr>
<tr>
<td></td>
<td>* element1 - the data *element name</td>
<td></td>
</tr>
<tr>
<td>Use these tags to include the information in the line item tabs in the printed output. The printed output will show the name of the line item tab name with the line items under it.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elements of each tab are listed under the corresponding tab.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Applicable to all BP types except: Simple and Document type (Without Folder)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To create a customized XML template in Word
1) In the Business Process Configuration log, open the desired business process form.
2) Click the **Custom Print** tab.
3) Click the Export Schema drop-down and select Schema for Word 2003. The File Download window opens prompting you to save the file. Click Save.
4) Open a new Microsoft Word document.
5) Import the XSD file into Word by selecting Tools > Templates and Add-ins.
6) Click the XML Schema tab and click Add Schema.
7) Navigate to the bp_schema.xsd file and click Open.
   In the Schema Settings window, type a unique name for the schema in the URI and Alias field (for example, "Submittal"). The name you enter for the alias appears in the list of available schemas in the Templates and Add-ins window.

   **Note:** Do not select the Schema validate options checkbox.
8) Click OK. An MS Word document opens with a list of available Unifier BP tags under "XML Structure" on the right side of the window.
9) To add XML tags to the Word document, enter text (e.g., xxx_project_name to print Project Name) and click the project_name tag that is available as part of the XML structure.

   **Note:** For custom print to work properly, do not add XML tags to the header and footer.

   The text will be surrounded with project_name tag. You can follow this process for any element.
10) To print line item information, first select the text for all the line item elements and select the appropriate XML tags. Then select all the elements that are part of the line items and click the_bp_lineitems tag.
   By doing this you are enclosing all line item elements within the_bp_lineitems XML tag. At runtime, Unifier will know that the elements that are part of_bp_lineitems should be printed for each line item of the BP. Elements that are part of the upper form are prefixed with "form_", and detail form elements are prefixed with "lineitem_".
11) Turn off the XML tags before saving.
12) Click File > Save As. Name the document, and select XML format for the save option. The document must be saved in XML format. Now you are ready to upload the completed document through the Business Process Configuration window.
13) In the Business Process Configuration window, on the Custom Print tab, click Upload. The File Upload window opens.
14) Browse and select the Word file you created. You can enter document title, rev. no., and issue date.
15) Click OK to save and close the window.

**Configure and Activate a BP**

The following procedure describes how to configure and activate a business process. If the business process form contains a data picker, you will also have to configure the data picker.

**To configure and activate a business process**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Configuration > Business Process in the left Navigator. The Configuration - Business Processes log opens, displaying the BPs that have been imported into your company.

3) Select a business process and click Open > General. The Configuration window for the business process opens.

4) Complete the General tab according to the table below Step 9.
   In this tab, you can specify the log in which the BP records will appear, the numbering sequence for the records, the status, and record termination restrictions. The tab also shows whether the BP is company, project, or shell level.

5) Click the Workflow tab (applicable for workflow BPs only). Business processes may have multiple workflows that have been defined in uDesigner. Use this tab to activate one or more workflows that have been imported with the BP. Non-workflow BPs will not appear in this tab.

6) Click the Custom Print tab. This tab is optional. It allows you to customize the BP layout of a Word document. See Create Custom-Designed BP Print Layout (Custom Print tab) (on page 356)

7) When you have completed the configuration information, you can make the BP available for setup and use by changing the status to active in the General tab.

8) When the window is complete, click OK.

Fields on the General tab:

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>Displays whether the BP is company, project, or shell level, as determined in uDesigner.</td>
</tr>
<tr>
<td>Default Location</td>
<td>Choose where the BP records will be stored. Some BP types will default to a log and cannot be changed. Note: If you are using the user configurable Navigator, you may not see the BP in the User Mode log immediately, even after granting permissions. You need to manually move the BP into the correct User Mode node.</td>
</tr>
</tbody>
</table>
| Sequence Policy      | This determines how the record numbers for each BP record are sequenced. The record number is displayed on the form and in the Business Process log.  
  Company Based: Record numbering starts with this number on the first record of the first project or shell and is sequential on each record after that, no matter what project a BP record is created in.  
  Project/Shell Based: Record numbering starts over in each new project or shell, and is sequential within the project or shell. |
| Sequence Format      | The prefix and starting number that will be used for BP record numbers.  
  Use Base Commit's Record Number: This is for identifying workflow Change Commits (Line Items with WBS Code Cost BPs) at the project or shell level. For this type of change commit, you can use the base commit's record number as part of the prefix for the change commit's record number. This will clearly identify the base |
commit to which the change commit refers. It will also provide sequential numbering for the change commits so that users can see how many change orders have been initiated for the base commit. To specify this addition to the prefix number, you need to include a separator, such as a period, and a starting number for the change commits. The maximum number of characters for the starting number is 8. For the total format, including the base commit's record number and the sequential numbers, the maximum number of characters is 20.

For example, a base commit record might be numbered PO-00123456. For a change commit record that refers to this base commit, the change commit record number could be PO-00123456, followed by a separator (such as - ) and a number for the change commit. The sequence format for change commits attached to this base commit could be numbered:

PO-00123456-001
PO-00123456-002
PO-00123456-003

Note: This numbering sequence will be frozen once it is used for a change commit in a project or shell. Any change to this numbering sequence will only affect change commits created in a new project or shell.

Record Creator

This option gives administrators more control over who can edit or terminate a BP record once it is created.

Do not allow to terminate record. If selected, once a BP record has been created, the owner or creator cannot terminate it. If not selected, after a BP record has been created, the owner or creator of the record can terminate it.

Caution: Any user with terminate workflow permission for the BP, regardless of BP record ownership, will be able to terminate a record for that BP, regardless of whether this option is selected.

Allow to modify record. If selected, the creator or owner of the record will be able to modify the record at any time, whether or not s/he is the assignee on a step.

Status

Active enables the BP to be set up and used to create BP records. Inactive prevents set up or use of the BP.

Configure a BP workflow (Workflow tab)

Workflow business processes may have one or more workflows, which, along with the BP settings, control how BP records flow through the steps of the creation, response, review, and approval process. Workflows are designed in uDesigner and included with the BP. You must activate the workflows that you plan to set up and use.
To configure and activate a workflow
1) In the Business Process Configuration window, click the Workflow tab.
2) To activate a workflow, select the workflow and click Activate.
3) Alternatively, you can select a workflow and click Modify. The Workflow Configuration window opens.
   ▶ In the General tab, you can edit the name or description if necessary.
   ▶ You can change the status to active in this tab.
   ▶ To view the steps of the workflow, click the Step tab.
   ▶ Click OK to exit the Workflow Configuration window.
4) If you have edited or added a workflow to an existing business process and re-imported, you may need to add the new workflow. Click Add to add newly defined workflows, if any exist.
5) Click Apply to save your changes, and OK to exit the Business Process Configuration window.

Create a custom XML template in MS Word
In the Business Process Configuration window, the Custom Print tab allows you to customize the layout of a document, using either MS Word® (leveraging the XML style design) or PDF format (using Adobe® LiveCycle® Design View.)

You can use the custom print templates to print one record at a time. The document shows all the values of the record that are available. This feature is similar to Print Preview for HTML or PDF. The only difference is that you can custom design the format for the selected record.

Unifier automatically generates the XML schema, which is used to define the custom layout in Word or in LiveCycle. For a given business process, you can export the schema and use it to develop your own customized template. You then save the template and upload it to Unifier.

To create a custom XML template in MS Word
1) In the Business Process Configuration log, open the desired business process form.
2) Click the Custom Print tab.
4) Click Save.
5) Open a new Microsoft Word document.
6) Import the XSD file into Word by selecting Tools > Templates and Add-ins.
7) Click the XML Schema tab and click Add Schema.
8) Navigate to the bp_schema.xsd file and click Open.
9) In the Schema Settings window, type a unique name for the schema in the URI and Alias field (for example, "Submittal").
   The name you enter for the alias appears in the list of available schemas in the Templates and Add-ins window.
10) Click OK. An MS Word document opens with a list of available Unifier BP tags under "XML Structure" on the right side of the window.

11) To add XML tags to the Word document, enter text (e.g., xxx_project_name to print Project Name) and click the project_name tag that is available as part of the XML structure.

**Note:** For custom print to work properly, do not add XML tags to the header and footer.

The text will be surrounded with project_name tag. You can follow this process for any element.

12) To print line item information, select the text for all the line item elements and select the appropriate XML tags. Then select all the elements that are part of the line items and click the _bp_lineitems tag.

By doing this you are enclosing all line item elements within the _bp_lineitems XML tag. At runtime, Unifier will know that the elements that are part of _bp_lineitems should be printed for each line item of the business process. Elements that are part of the upper form are prefixed with "form_", and detail form elements are prefixed with "lineitem_".

13) Turn off the XML tags before saving.
14) Click **File > Save As**. Name the document, and select **XML format** for the save option. The document must be saved in XML format. Now you are ready to upload the completed document through the Business Process Configuration window.

15) In the Business Process Configuration window, on the Custom Print tab, click **Upload**. The File Upload window opens.

16) Browse and select the Word file you created. You can enter the document title, rev. no., and issue date.

17) Click **OK** to save and close the window.

**Business Processes Production Bundle Configuration**

The following configurations can be included in the Business Processes Production Bundle:

- **General setup**
  - All the fields included in the General Configuration (General tab).
- **Custom Print**
  - Word and PDF templates, if any.
- **BIP Custom Print**
  - All the BIP Custom Print in the Custom Prints and Reports.
- **Workflows**
  - All configured Workflows.
- **Query**
  - All queries that have been configured based on data elements.

For more information, see the *Production Bundles* (on page 197) section in this guide.

**General Procedures for Setting up Business Processes**

Business processes must be set up before use. The general procedures apply to company-level and project-or shell-level business processes, with some differences.

**Workflow BPs:** Workflow business processes can have one or more BP setups, which define the workflow setup options. These include configuring the workflow and each step. These options control step behaviors as the BP moves through the steps of the workflow. Each step can have an associated duration and the workflow (consisting of all the steps) can have an overall duration, which facilitates project or shell data flow-through and tracking. BP setup is the process of choosing a configuration, assigning users or groups to each step, configuring the actions they can take on that step, and setting the durations.

You may want to create multiple workflows per BP to accommodate different ways for the workflow to operate. For example, you can configure an RFI workflow with or without a coordinator. You may or may not have a need for both workflows on your project or shell.

**Non-workflow BPs:** For non-workflow BPs, one setup is allowed. Setup includes adding the list of users who can create a new non-workflow BP.

**Set up of auto-creation of BPs or line items:** Both workflow and non-workflow BPs support auto-creation. Auto-creation can be based on a:
Condition that is met
- Date that passes
- Condition and a date
- Frequency (at periodic intervals, for example)
- Condition and frequency

You can auto-create BPs or line items from the upper form or the detail form, using creator elements. See Set up auto-creation for a non-workflow BP or planning item (on page 372) for non-workflow auto-creation setup and Set up auto-creation for a workflow BP (on page 382) for workflow auto-creation.

**Auto-creation of BPs based on workflow steps**: You can specify that some workflow BPs include steps during the workflow that enable the auto-creation of BPs from an S-Step. Define the business process workflow (on page 386) for details.

**Special setups**: There are special setup procedures for blanket purchase order BPs and Request for Bid (RFB) BPs. There is an additional option for auto-creation of a commitment-level cash flow curve in setups for base commit business processes.

### Loading a Business Process

Loading the business process is part of setting it up. In this step, you will be loading the configured business process into the area where it should reside—the Company Workspace, a shell, or a standard project. This step filters the business processes by company, shell, or project level, thereby narrowing the number of BPs so that the users do not have to sift through your company’s entire list of BPs.

When you load a business process, you also load the permission infrastructure and the ability to grant permissions for this BP.

**To load a business process**

1. Go to the Company Workspace tab and switch to Admin mode.
   - To load a BP into the Company Workspace, click Company Workspace > Business Process Setup in the left Navigator.
   - To load a BP into a shell, click Company Sponsored Shells > [shell type] > [shell] > Setup > Business Process in the left Navigator.
   - To load a BP into a standard project, click Company Sponsored Projects > All > [project] > Setup > Business Process in the left Navigator.
   - To load a BP into the templates for a project, click Templates > Projects (Standard) > All > [template]. Then select Setup > Business Process in the left Navigator.
   - To load a BP into the templates for a shell, click Templates > Shells > in the left Navigator. Then choose the [shell type] > [template]. Then select Setup > Business Process in the left Navigator.
2. Click New. The New Business Processes window opens, showing the business processes that are available for loading.
3. Select the business process you want to load and click OK. Unifier displays the business process in the right pane.
Setting Up a Non-Workflow Business Process

This procedure is applicable to project, shell, and company level non-workflow business processes. Be sure you have added the business process to the log first.

Basic non-workflow set up in General tab and Settings tab

To set up a non-workflow business process - General Tab

1) Open the project or shell, or (for a company-level business process) go to the Company Workspace tab, and switch to Admin mode.
2) Navigate to the Business Processes log.
3) Select the non-workflow BP and click Open. The Setup log opens on the General tab.
5) Complete the tabs as described below and click OK.
6) Click Yes to activate the BP and make it available to users, or click No to keep the BP inactive until a later date.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Name</td>
<td>Enter a unique name (required field).</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description. This is optional, but recommended.</td>
</tr>
<tr>
<td>Help File</td>
<td>Allows you to add a custom PDF help file.</td>
</tr>
<tr>
<td>Default Record Status</td>
<td>Use this field in setting up the creation of non-workflow business processes. The status you enter here will be used as the beginning status for a record created using any method—manual, integration, or auto-creation of any type.</td>
</tr>
<tr>
<td>Send error notification to:</td>
<td>Specify the user to receive error notifications.</td>
</tr>
<tr>
<td>Save Record Information to Document Manager</td>
<td>Select this check box if the records produced by this business process should be automatically saved in the Document Manager. If you select this option, Unifier will send a copy of the business process' records, along with their comments and attachments, to a specified folder* in the Document Manager. The owner of the published record will be the assignee of the business process that published it. If the record already exists in the folder, the record will be published as a revision. If the path to the folder is invalid for any reason, the record will be sent to the Unpublished Documents node. Depending on how you set up the business process, it can be automatically published to the Document Manager whenever an email notification is sent regarding the status of the business process.</td>
</tr>
</tbody>
</table>

* This folder is identified on the business process with this data element uuu_dm_record_info_path. For information about this element, refer to the Unifier Reference Guide.
### Default Record format for Notification and Document Manager

This option has two purposes:

- If you want notification sent to users whenever a business process record is created or modified, use this option to specify the format in which you want the notification to be sent.
- If you have checked the **Save Record Information to Document Manager** check box, use this option to specify the format in which the business process records should be saved.

### Cash Flow: Default Template

This option only appears in WBS code-based Base Commit business processes. It allows you to enable the auto-creation of a commitment-level cash flow curve at runtime for the business process record. The curve is based on the selected commitment-level cash flow template, and is created when the record is completed.

Click **Add** and choose a template.

For more information, see *Setting up auto-creation of cash flow curves from contracts* (on page 404).

### Settings tab

Add the creator and editor on the **Settings** tab:

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creator(s)</td>
<td>Click <strong>Select</strong> to choose the creators of the BP, those users who may create a new BP record from this setup.</td>
</tr>
<tr>
<td>Editor(s)</td>
<td>Optionally, click <strong>Select</strong> to choose users and/or groups who can edit the business process without being granted explicit record-level permission. This allows users other than the assignee to edit the business process record. The Editors field can include users and groups that are also entered under Creator(s). The Editors can be added on these BP types:</td>
</tr>
<tr>
<td></td>
<td>‣ Line Item</td>
</tr>
<tr>
<td></td>
<td>‣ Cost (all types, including Lease and Line Item with Multiple Codes)</td>
</tr>
<tr>
<td></td>
<td>‣ Document</td>
</tr>
<tr>
<td></td>
<td>‣ Simple</td>
</tr>
<tr>
<td></td>
<td>‣ RFB</td>
</tr>
<tr>
<td></td>
<td>‣ Text</td>
</tr>
</tbody>
</table>

Users or groups that you add as Editors can open and edit any record that they can see listed in the business process log, per their view access permission. Access permissions are **View User Records**, **View Company Records**, or **View All Records**. The user who is designated as an Editor must have at least one of these permissions to be able to view the record in the log to access it to edit.
Allow Quick Calendar Entry

Click Select and choose the users and/or groups who will be allowed to use the quick entry feature to reserve the object of this business process, or to edit or delete it from the calendar.

Note: This option will appear only on those business processes that have been calendar-enabled by design.

Selecting BIP Custom Print (Format > Custom)

The following is a list of conditions applicable to BIP Custom Print.

- Only Published BIP Custom print templates can be selected while setting up the Business Process; however, if you make any changes to the Published template and do not re-publish it to BI server, the selected template will continue to remain in the Business Process (BP) setup option. Any record information sent as email attachments will contain data from the last published version existing in the BI server.
- If the BP setup has been done in a Project/Shell template, then when you update the setup information onto instances of Projects/Shells, the setup gets pushed.
- If you delete the BIP Custom Print template selected in the BP Setup window, then the system removes the deleted BIP Custom Print template from the BP setup.
- If the system does not generate the print output, for example due to server issues, then the email attachment, which contains the record information, generates an error message.
- Custom Print template included in the BP setup can be exported in the Production Bundle. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell template will also be included. If the Custom Print Template is not tagged, then the bundle export will result in an error.

Note: If the BIP Custom Print output could not be generated because of connection issues to BIP Server or inconsistencies in between Custom Print on Unifier and BIP Server, then notification emails for Business Process modification will have an "error.html" document (as an attachment) instead of a record information document. If the record information is Published to Document Manager, then a 0 KB document will be published to the Document Manager.

Set up email notification for a non-workflow BP

Use the Notification tab to set up automatic email notifications to users and groups whenever a non-workflow business process is created or modified, either manually, or via auto-creation, reverse auto-population, CSV, or integration.

Note: If the business process has been designed to allow users to include additional users or groups in the email, the email notification will be sent to them as well.

1) Use the information in the table below to complete the Notification tab.
2) Click **Apply** to save your changes and **OK** to exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send notifications to</td>
<td>Click <strong>Select</strong> and choose those users or groups that should be notified whenever a non-workflow business process is created or modified.</td>
</tr>
<tr>
<td>Notify creator on record modification</td>
<td>By default, this check box is checked. If you do not want the BP creator to be notified when the business process is modified, de-select this check box.</td>
</tr>
<tr>
<td>Notification triggering events</td>
<td>The fields you select here will tell Unifier when to notify the users or groups.</td>
</tr>
<tr>
<td>Create Record</td>
<td>Select this check box if notification should go out whenever a record is created.</td>
</tr>
<tr>
<td>Edit Upper Form</td>
<td>Select this check box if notification should go out whenever the upper form of a record is edited.</td>
</tr>
<tr>
<td>Add/Edit/Delete Line Items</td>
<td>Select this check box if notification should go out whenever a line item is added to the record, edited, or deleted from the record.</td>
</tr>
<tr>
<td>Add General Comments</td>
<td>Select this check box if notification should go out whenever comments are added to a record.</td>
</tr>
<tr>
<td>Add/Remove Attachments</td>
<td>Select this check box if notification should go out whenever attachments are added to or removed from a record.</td>
</tr>
<tr>
<td>Attachments</td>
<td>The fields you select here will tell Unifier how to add attachments to the record.</td>
</tr>
<tr>
<td>Include both record and line item attachments</td>
<td>Select this check box if the notification should include both the record and the line item attachments.</td>
</tr>
<tr>
<td>Include record information as attachment</td>
<td>Select this check box if the notification should include the record information as an attachment.</td>
</tr>
<tr>
<td>Override default format</td>
<td>If you have specified a default record format on the General tab, you can use this check box to override the default format. For example, you can use the General tab to specify that the default record format for both email notifications and records saved in the Document Manager be in PDF format. If necessary, you could then use the Override default format check box to override the format and choose Custom for the notification only.</td>
</tr>
<tr>
<td>Format PDF/Custom</td>
<td>Select the form.</td>
</tr>
</tbody>
</table>
The attachments are PDF or a custom format. BI Publisher (BIP) Custom Prints are available to be selected for the Notification format. For custom format, select the print format defined for the business process.

**Set up auto-creation for a non-workflow BP or planning item**

On the Auto-Creation tab, you can set up the auto-creation of another record or line item for the business process you are setting up. You can also set up the auto-creation for other business processes that will be spawned by this business process.

For information about auto-creating business processes, see *About Auto-creating a Business Process record or Planning Item Based on conditions or frequency* (on page 399).

**To set up auto-creation of a non-workflow business process or planning item**

1) Click the **Autocreation** tab.

2) Under **Settings for auto creation of** [name of the business process, planning item, or line item you are setting up], in the **Creator** field, click the **Select** button and choose the name of the auto-creator.
3) Under the section **Settings for auto-creation of other business process records or line items**, select the BP creator element under the upper or detail form.

![Unifier Administration Mode](image)

This line identifies the business process or line item the creator element you selected will create.

4) (Not an option for line item creation.) In the **Assignee/Creator** field, click the **Select** button and choose the name of the user or group who should assume ownership of the auto-created record.

5) Ignore the **Duration** field.

6) To create the conditions that will trigger the auto-creation, select the **Enable condition based auto creation** check box and continue as follows:

   **Note:** If you leave this check box un-checked, the BP, planning item, or line item will be available for manual creation only.

   a. To add a trigger condition, click the **Add** button. The Add Condition window opens.

   b. On the **General** tab, enter a name for the trigger and a description.
c. Click the **Query** tab.

The Query tab is where you will define the conditions the data must meet before Unifier will auto-create the new business process record or line item.

In the upper section of the window, you can specify that a field on the business process form:

- Must meet a certain criteria or value
- Must meet a certain value based on a formula using the numeric fields on the form

Click the Add button to specify a condition for a field on the business process form. Click the Add Formula button to create a formula that the value of the field must meet. Use the information under About Queries to complete the query.

In the lower section of the window, you can specify a date condition that will trigger the auto-creation. Use the information under About Queries to complete the query.

**Notes:**

Date condition triggers are not available for line item auto-creation.

**About Date Triggers:**
If you want to create a continual date trigger condition, make sure you use the Date Trigger Condition section of the window to create it. Although you can also create a date trigger using a formula in the upper section of the window, Unifier will process the triggers differently.

- The conditions you specify in the upper section of the window will be processed only once, when the user clicks the Finish Editing button on the form. However, the date conditions you specify in the DateTrigger Condition section will be processed daily.

- This behavior is important to consider when you are creating a date condition that occurs in the future. A date trigger specified under the Date Trigger Condition section will be processed daily, and will, therefore, "catch" the trigger condition when the future date occurs.

d. Click OK.

7) If you want the auto-created record or line item to include attachments from the original (source) record, select the Include Attachments check box.

**Note:** This step is not applicable for Document type business processes.

If you select this option:
- Any record-level attachments made to the source record will appear at the record level of the destination record.
- Any attachments made to the line items of the source record will appear at the line item level of the destination record.

8) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation normally creates, select the Bypass initiation step during auto creation checkbox.

If you select this option, the auto-created BP or planning item will skip the initiation step and will appear in the user’s Tasks Log and BP Log or Planning Item Log with the status that was specified on the General tab of the business process setup window. For more information, see About Auto-creating a Business Process record or Planning Item Based on conditions or frequency (on page 399).

9) If you want to copy any records that are linked to the original record, select the Copy Linked Records check box.

10) (Not an option for line item creation.) If you are creating a record from a detail form, you can group line items into a single record. To do so, select the Enable grouping of line items when autocreating records from line item tabs check box.

In the Group By field, click Select and select the data element (or elements) you want to group by. If the values in these data elements match for any of the line items, Unifier will auto-create a single record for them. For more information, see Grouping line items into single records (on page 401).

**Note:** If you leave the Group By field blank, Unifier will auto-create a single record containing all the line items on the source record.

11) Click Apply to save your changes, or OK to save and exit the window.
Set up record and line item copy options

Use this feature to set up copy options for users when they copy a record with line items and references.

The options you specify here will give the Unifier user the ability to copy specific (rather than all) line items, as well as the ability to include attachments and linked records, and retain or remove references to auto-created records.

To set up these options, you must create a condition the data element must meet in order for the line item to be included for these copy options.

For example, you could create a set of options specifying that all line items with a status of "open" be copied, and their attachments be included in the copy. Using this example, you could set up a weekly meeting minutes business process that automatically generates action item business processes for each task that arises from the meeting. Using these copy options, you could roll over action items that are still open to the next week’s meeting minutes.

At runtime, the options you set up here will be given to users to choose from when they copy records.

Note: These options are not available for Payment Applications.

To set up copy options

1) Open the business process for which you want to set up the copy options.
2) Click the Record Copy tab. The Record Copy Setup window opens.
3) Click the Add button. The Copy Condition Setup window opens.
4) In the Name field, enter a name for this copy setup. The name should be unique, and can be up to 250 characters long.
   This is the name that will appear on the list of copy options the Unifier user will see when they copy a record or line item.
5) (Optional) In the Description field, enter a description of what this setup does.
   Tip: It’s a good idea to include a precise description of what the copy options are for the setup. This description will appear on the list of copy options the Unifier user will see when they copy the record, and a good description will tell them exactly what will be copied. You can enter up to 4000 characters.
6) Under the Condition area of the window, click the Add button. The Query Condition window opens.
7) In the Data Element field, select the of the field on the line item form that you want to use to identify which line items can be copied.
8) In the Condition field, select the operator Unifier should use to test the data element you selected.
   A condition is a state or restriction the value in the data element (field) must meet. A condition of the value might be that it must be equal to a certain number (maybe 10) or that it must contain a certain string of letters (such as "due date of").
If the data element meets the condition you specify, Unifier will include this line item on the list the user can choose from. (For more information on conditions and queries, see About Queries.)

9) Click **OK**.

10) On the **Copy Condition Setup** window, specify these additional copy options as shown in the table below.

11) Click **OK**.

<table>
<thead>
<tr>
<th>Select this checkbox:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Attachments</td>
<td>Include attachments in the copy operation.</td>
</tr>
<tr>
<td>Copy Linked Records</td>
<td>Include any linked records in the copy operation.</td>
</tr>
<tr>
<td>Retain reference to auto-created business process records on record upper form</td>
<td>Keep the references to business processes that were auto-created from the upper form.</td>
</tr>
<tr>
<td>Retain reference to auto-created business process records on line items across all tabs</td>
<td>Keep the references to business processes that were auto-created from the line item (detail) form. This applies to all line items from all tabs.</td>
</tr>
</tbody>
</table>

**Single-record business processes**

Single-record business processes store information that you use repeatedly in your projects. Think of them as file cabinets where you keep things like: industry standards; federal, state, and local regulations and statutes; policies; and FAQs. You can have multiple single-record business processes in a project, each with its own information focus. From these single-records you can auto-populate fields in business processes, including constant values.

To facilitate single-sourcing of your data, create the single-record business process in the project or shell template prior to creating your project from the template. When you clone a project or shell template, you have the option to select BP Setup, which not only copies all business process setups, but all single-record business process records and their data.

Data copied from single record business processes includes:
Attachments to records and line items, if applicable
- All data pickers (Business Process, Configurable Managers, Shell Manager, User Attributes)
- Any other pickers except business process pickers
- Linked elements
- Permissions associated with the single-record business process

Copying a single record business process does not include:
- Business process pickers
- Linked records
- Linked mail
- General comments

You can also use CSV or web services to clone a shell or project template that contains the single record business process.

**To create a single-record business process**

**Before you begin:**
- Ensure you have Setup permission for the business process. See *Edit user or group permissions using Access Control* (on page 160)
- Follow the directions to set up a non-workflow business process. See *Basic non-workflow set up in General tab and Settings tab* (on page 368)

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates in the left Navigator.
3) In the left Navigator, click Projects (Standard) > [project] or Shells > [shell] and on the right pane, open the template in which the single-record business process resides.
4) In the left Navigator, click Information > General.
5) On the right pane, open the single-record business process record and complete all required fields.
6) Click Save or Finish Editing, as appropriate. Both actions save the record, but Save leaves the record in Edit mode, and Finish Editing leaves the record in a read-only state.

**Caution:** If you click Finish Editing and the record is in a terminal status you will not be able to edit that record again.

7) Assign record permissions as appropriate.

**Setting Up a Workflow Business Process**

These procedures are applicable to project, shell and company-level workflow business processes.

**Basic workflow set up in General tab**

To set up a workflow business process
1) From the Business Processes log, select a BP and click Open. The Setup log opens.
2) Click New. The Select Workflow window opens.
3) Click the Workflow selection list and click OK. The Business Process Setup window opens.

   Note: You may configure a setup for multiple workflows by repeating this procedure for each workflow available for the business process.

4) Complete the General tab (see the table below).

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Name</td>
<td>Enter a unique name (required field).</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description of the setup.</td>
</tr>
<tr>
<td>Help File</td>
<td>Allows you to add a custom PDF help file.</td>
</tr>
<tr>
<td>Auto Creation Workflow</td>
<td>The workflow to use for the auto-created BP. <em>Workflow setup in General and Setting tabs</em> (on page 385).</td>
</tr>
<tr>
<td>Auto Creator</td>
<td>Select the name to use as the creator of any auto-created records of this BP.</td>
</tr>
<tr>
<td>Auto Action</td>
<td>Select the step to use as the first step in the workflow of auto-created records.</td>
</tr>
<tr>
<td>Send error notification to</td>
<td>Specify the user to receive error notifications.</td>
</tr>
<tr>
<td>Default Record format for Notification and Document Manager</td>
<td>This option has two purposes:</td>
</tr>
<tr>
<td></td>
<td>▶ If you want notification sent to users whenever a business process record is created or modified, use this option to specify the format in which you want the notification to be sent.</td>
</tr>
<tr>
<td></td>
<td>▶ If you have checked the Save Record Information to Document Manager check box, use this option to specify the format in which the business process records should be saved.</td>
</tr>
</tbody>
</table>

**Selecting BIP Custom Print (Format > Custom)**

The following is a list of conditions applicable to BIP Custom Print.

- Only Published BIP Custom print templates can be selected while setting up the Business Process; however, if you make any changes to the Published template and do not re-publish it to BI server, the selected template will continue to remain in the Business Process (BP) setup option. Any record information sent as email attachments will contain data from the last published version existing in the BI server.
- If the BP setup has been done in a Project/Shell template, then when you update the setup information onto instances of Projects/Shells, the setup gets pushed.
- If you delete the BIP Custom Print template selected in the BP Setup window, then the system removes the deleted BIP Custom Print template from the BP setup.
If the system does not generate the print output, for example due to server issues, then the email attachment, which contains the record information, generates an error message.

Custom Print template included in the BP setup can be exported in the Production Bundle. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell template will also be included. If the Custom Print Template is not tagged, then the bundle export will result in an error.

**Note:** If the BIP Custom Print output could not be generated because of connection issues to BIP Server or inconsistencies in between Custom Print on Unifier and BIP Server, then notification emails for Business Process modification will have an "error.html" document (as an attachment) instead of a record information document. If the record information is Published to Document Manager, then a 0 KB document will be published to the Document Manager.

---

**Designate additional editors for Business Process records**

Normally, the editors of any record must be an assignee on the step of the workflow. However, there are times when a record may need editing by someone other than the step assignees. For example, the owner of a purchase order record should be able to attach revised documents to the PO at the end step of the workflow. Or, an engineer who has sent a task to an architect realizes that some drawings are missing from the record. The engineer should be able to attach the documents to the record, even though the task assignee is now the architect.

The Settings tab is where you can designate non-assignee editors for business process records. (These editors must have permission to at least view the record.) Editors designated on this tab can open records and modify the upper or line item content of the record. Changes made by these editors are recorded in the audit log. Whereas step assignees will see the form that is attached to a step, the record editors you designate on this tab will see a specific form for editing. This form must be specified in uDesigner when the business process is created.

**Note:** The editors you specify on this tab are record-level editors. You can designate additional editors at the step level when you set up the workflow. See **Define the business process workflow** (on page 386)

---

**To designate additional editors for records.**

1) Click the **Settings** tab.

2) In the **Record Editor(s)** field, click the **Select** button and choose the users or groups who should have editing privileges on this record.

3) Click **Apply** to save these settings.

---

**Set up email notification for a workflow BP**

Use the **Notification** tab to set up automatic email notifications to users and groups whenever a non-workflow business process is created or modified, either manually, or via auto-creation, reverse auto-population, CSV, or integration.
**Note:** If the business process has been designed to allow users to include additional users or groups in the email, the email notification will be sent to them as well.

1) Use the information in the table below to complete the Notification tab.
2) Click **Apply** to save your changes and **OK** to exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send notifications to</td>
<td>Click Select and choose those users or groups that should be notified whenever a non-workflow business process is created or modified.</td>
</tr>
<tr>
<td>Notify creator on record modification</td>
<td>By default, this check box is checked. If you do not want the BP creator to be notified when the business process is modified, de-select this check box.</td>
</tr>
<tr>
<td>Notify Assignee of Record Modification</td>
<td>Select this check box if you want the assignee(s) on a step to be notified whenever the business process record is edited.</td>
</tr>
<tr>
<td>Notify Cc on Record Modification</td>
<td>Select this check box if you want the users who have been Cc’d on a step to be notified whenever the business process record is edited.</td>
</tr>
<tr>
<td>Notification triggering events</td>
<td>The fields you select here will tell Unifier when to notify the users or groups.</td>
</tr>
<tr>
<td>Edit Upper Form</td>
<td>Select this check box if notification should go out whenever the upper form of a record is edited.</td>
</tr>
<tr>
<td>Add/Edit/Delete Line Items</td>
<td>Select this check box if notification should go out whenever a line item is added to the record, edited, or deleted from the record.</td>
</tr>
<tr>
<td>Add General Comments</td>
<td>Select this check box if notification should go out whenever comments are added to a record.</td>
</tr>
<tr>
<td>Add/Remove Attachments</td>
<td>Select this check box if notification should go out whenever attachments are added to or removed from a record.</td>
</tr>
<tr>
<td>Attachments</td>
<td>The fields you select here will tell Unifier how to add attachments to the record.</td>
</tr>
<tr>
<td>Include both record and line item</td>
<td>Select this check box if the notification should include both the record and the line item attachments.</td>
</tr>
<tr>
<td>Include record information as</td>
<td>Select this check box if the notification should include the record information as an attachment.</td>
</tr>
</tbody>
</table>
Set up auto-creation for a workflow BP

On the Auto-Creation tab, you can set up this business process to automatically create another record or line item for this business process. You can also set up this business process to automatically create other business processes, planning items, or line items if the form includes a creator element.

For information about auto-creating business processes or planning items, see About Auto-creating a Business Process record or Planning Item Based on conditions or frequency (on page 399).

To set up auto-creation of a workflow business process

1) Click the Autocreation tab.

2) Under Settings for auto creation of [name of the business process, planning item, or line item you are setting up], complete the following fields as shown in the table below (at the end of this topic).

3) Under the section Settings for auto-creation of other business process records or line items, select the creator element under the upper or detail form.

This line identifies the business process or line item the creator element you selected will create.
4) (Not an option for line item creation.) In the **Assignee/Creator** field, click the **Select** button and choose the name of the user or group who should assume ownership of the auto-created record.

5) (Not an option for line item creation.) In the **Duration** field, specify the duration of the workflow for the auto-created record.

6) If you want the auto-created record to include attachments from the original (source) record, select the **Include Attachments** check box.

   If you select this option:
   - Any record-level attachments made to the source record will appear at the record level of the destination record.
   - Any attachments made to the line items of the source record will appear at the line item level of the destination record.

   **Note:** This step is not applicable for Document type business processes.

7) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation normally creates, select the **Bypass initiation step during auto creation.**

   If you select this option, the auto-created BP will skip the initiation step and will appear in the user’s BP log at the appropriate step in the workflow. (For more information, see *About Auto-creating a Business Process record or Planning Item Based on conditions or frequency* (on page 399).)

8) If you want to copy any records that are linked to the original record, select the **Copy Linked Records** check box.

9) (Not an option for line item creation.) If you want to group line items into a single record, select the **Enable grouping of line items when autocreating records from line item tabs** check box.

   In the **Group By** field, click Select and select the data element (or elements) you want to group by. If the values in these data elements match for any of the line items, Unifier will auto-create a single record for them. For more information, see *Grouping line items into single records* (on page 401).

   **Note:** If you leave the **Group By** field blank, Unifier will auto-create a single record containing all the line items on the source record.

10) To create the conditions that will trigger the auto-creation, select the **Enable condition based auto creation** check box and continue as follows:

   **Note:** If you leave this check box un-checked, the BP, planning item, or line item will be available for manual creation only.

   a. To add a trigger condition, click the **Add** button. The Add Condition window opens.
   b. On the **General** tab, enter a name for the trigger and a description.
c. Click the **Query** tab.

The Query tab is where you will define the conditions the data must meet before Unifier will auto-create the new business process record.

In the upper section of the window, you can specify that a field on the business process form:

- Must meet a certain criteria or value
- Must meet a certain value based on a formula using the numeric fields on the form

Click the Add button to specify a condition for a field on the business process form. Click the Add Formula button to create a formula that the value of the field must meet. Use the information under About Queries to complete the query.

In the lower section of the window, you can specify a date condition that will trigger the auto-creation. Use the information under About Queries to complete the query.

**Notes:**

Date condition triggers are not available for line item auto-creation.

About Date Triggers:
If you want to create a continual date trigger condition, make sure you use the Date Trigger Condition section of the window to create it. Although you can also create a date trigger using a formula in the upper section of the window, Unifier will process the triggers differently.

The conditions you specify in the upper section of the window will be processed only once, when the user clicks the Send button on the form to send the form to the next step in the workflow. However, the date conditions you specify in the Date Trigger Condition section will be processed daily.

This behavior is important to consider when you are creating a date condition that occurs in the future. A date trigger specified under the Date Trigger Condition section will be processed daily, and will, therefore, "catch" the trigger condition when the future date occurs.

d. Click OK.

11) Click **Apply** to save your changes, or OK to save and exit the window.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup</td>
<td>Specify the workflow setup that the auto-created business process or planning item should use.</td>
</tr>
<tr>
<td>Creator</td>
<td>Click the Select button and choose the name of the person or group who should assume ownership of the auto-created record.</td>
</tr>
<tr>
<td>Action</td>
<td>Specify the step in the workflow that should be used as the first step in the workflow of the auto-created BP or planning item records.</td>
</tr>
</tbody>
</table>

**Workflow setup in General and Setting tabs**

This section explains how to set up workflows. Workflow setups can be time-consuming. Unifier offers other options of copying or importing workflow setups. To use these options, see *Copying Workflow Setups from Other Schemas* (on page 405) or *Importing Workflow Setups from One Environment to Another* (on page 412).

1) In Administration mode:
   - To set up a workflow in a company level business process, click the Company Workspace tab and, in the Navigator, go to Company Workspace > Business Process Setup.
   - To set up a workflow in a project/shell level business process, click the project or shell tab and, in the Navigator, go to Setup > Business Process.

2) On the right pane, double-click the business process you want to set up.

3) In the Navigator, click **Workflow Setup** and on the right pane, double-click the name of the workflow you want to set up.

   The Workflow Setup window opens.

4) Complete the **General** tab for the workflow. See the table below.
5) Click the **Settings** tab to configure the workflow. **Define the business process workflow** (on page 386).

6) When the setup is complete, return to the General tab and click the **Error Check** button. This validates the setup, including checking that all steps have assignees. An error window opens identifying any errors that will prevent the setup from being activated.

7) If there are no errors, click **OK** in the Setup window. You will be prompted to activate the BP. Click **Yes** to activate the BP and make it available to users, or click **No** to keep the BP inactive until a later date.

### Define the business process workflow

In the Settings tab of the Business Process Setup window, you can configure the workflow details. The workflow step settings are arranged in a tree structure, showing all of the steps. From here you can set up the overall workflow setup, individual step setting, steps that lead to conditional routing, links with auto-creation of business process, and sub-workflow settings. These procedures are applicable to project- and company-level workflow business processes.

#### Overall workflow settings

The following describes the settings for the overall workflow. Select the top option in the left navigation pane to access these settings. Click the scroll bar on the right to scroll down the window and view all fields.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Workflow Duration</td>
<td>When <strong>Yes</strong> is selected, records created with this instance will be marked as late when the defined amount of time passes.</td>
</tr>
<tr>
<td>Workflow Duration</td>
<td>You can optionally set the duration of the workflow.</td>
</tr>
<tr>
<td>Override Workflow Due Date</td>
<td>User can override the due date for the workflow. Be sure to select Yes for this option if you are using Scope Management and have selected Enforce Activity Finish Date for the</td>
</tr>
</tbody>
</table>
Record Due Date for the activity business process. Setting up Scope Management for Activities (on page 621).

| Project Phase (Project-level BPs only) | Setup is valid only during the specified project phase. This is not applicable for company level BPs. |
| Notify users or groups on workflow completion | Selected users or groups will be notified once the workflow is complete. |

**Settings for standard workflow steps**

This setup is for standard workflow steps. The Settings tab displays the steps that are available for the selected BP, and therefore will vary depending upon how the BP has been designed in uDesigner. Not all selections discussed below will be available for all workflow steps. In addition, depending on the BP design, not all fields will be editable. The following is an example of a creation step. Click the scroll bar on the right to scroll down the window and view all fields.

Select a workflow step to access these settings.

**About Create and End Steps**

The Create and End steps in a workflow have unique characteristics you should be aware of during the design and set up of the workflow.

<table>
<thead>
<tr>
<th>In uDesigner</th>
<th>In Unifier Administration</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can rename the Create step to something else if you want. You can place only outgoing links on the Create step. You can attach only action forms to the Create step. You cannot send a link back to the Create step. If the workflow requires that a form be sent back to the creator (Create step), add a separate &quot;back step&quot; or &quot;revision step&quot; that will send the form back to the creator.</td>
<td>You cannot &quot;Cc&quot; users on the Create step. A workflow cannot send a link back to the Create step. If the workflow requires that a form be sent back to the creator (Create step), the workflow design should include a separate &quot;back step&quot; or &quot;revision step&quot; that will send the form back to the creator. If your workflow includes such a &quot;back step,&quot; specify <strong>match step &lt;Creation&gt;</strong> for the Assignees on that step.</td>
</tr>
</tbody>
</table>
For the End step

You cannot rename the End step.
You can place only incoming links on the End step.
You can attach either an action form or a view form to the End step.

You can "Cc" users on the End step.
You can send the form to the editors who have been assigned to the form.
You can add comments to a business process at the End step, and also at any status in a workflow, including "terminated."

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Step Name</strong></td>
<td>You can click the link to view a graphical representation of the workflow, with the current step highlighted. Be aware that workflows can often be very large. If you are viewing a large workflow, you can enlarge the canvas screen to make it easier to see all the steps to the workflow progression. To enlarge the canvas, you can drag the window sides until the workflow fits in the window, or you can quickly maximize the canvas. To maximize the canvas, click the icon in the upper-right corner of the window. To restore the canvas window to its normal size, click the Restore icon.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description to help identify the workflow.</td>
</tr>
<tr>
<td>Duration</td>
<td>Choose the time length for this step.</td>
</tr>
<tr>
<td>Override Task Due Date</td>
<td>Allows user to override due date for an individual task.</td>
</tr>
<tr>
<td>Allow Decline Step Task</td>
<td>Click Yes if you want the assignees to have the ability to decline an action on an assigned task.</td>
</tr>
<tr>
<td>Enable Step for Integration</td>
<td>Click the radio button if you want this step to be available for integration with an external system, such as Web Services. If you make the step available for integration, the user can use the external system to view a read-only copy of the BP at that step. Note: If you select this option, the Completion Policy field (see below) will be set to &quot;Single,&quot; and the Assignment Policy field for the following step must be set to &quot;Preassigned.&quot;</td>
</tr>
<tr>
<td>Assignment Policy</td>
<td>For <strong>User Select</strong> (default), the individual who creates a record (such as an invoice) from this workflow instance can choose the users to assign to this task from the list of assignees for this step. For <strong>Preassigned</strong>, every user on the assignee list is automatically assigned to the step when the record is created.</td>
</tr>
</tbody>
</table>
In this field: | Do this:
--- | ---
Assignees | Select the users to assign to this step. These users will receive task notifications, instructing them to take action at this step. When you click the **Select** button, you can choose one or more options:

**User Picker:** Unifier displays the User/Group Picker window. Choose one or more users or groups to add as assignees.

**Dynamic:** Choose a step in the workflow from the Select Step pop-up window. The assignees from that step become the assignees used on this step. You cannot choose Dynamic when adding assignees to the first step (Creation) in the workflow.

You can constrain the list of assignees for this step by selecting the Additional conditions to filter assignees check box. To constrain the list of assignees, you need to create a query to filter the assignees using criteria you specify. To do this, click the Define button and specify a field comparison. For information on creating this type of query, see About Queries.

Allow Cc | Allows assignees to add cc users who will receive a view-only copy of the BP record. Choose one of the options:

**No:** Does not allow sending copies to other users.

**Yes:** Click **Select** to create the list of users or groups from whom the BP users can choose to Cc. (This option also activates the Allow Add Cc functionality.)

**Preassigned:** Click **Select** to choose the users who will be automatically cc’d. No other users can be copied.

**Preassigned and Allow Add Cc:** Click **Select** to choose the users who will be automatically cc’d. The Allow Add Cc option is set to Yes.

Note: You cannot allow Ccs on the Create step.

Allow Add Assignees | Allows assignees to add additional assignees in addition to those defined in the Assignees field to the current step. Assignees can add the additional assignees **before accepting the task**. This is done by clicking the **Edit** menu and choosing **Add Assignees to Current Step**.

For example, user A has been sent a BP for review. User A wishes to add user B as an assignee to the review step as well. Before clicking Accept Task, user A chooses **Edit > Add Assignees to Current Step** and adds user B. User B is notified (depending on email preferences) of the new task. Both user A and user B can accept the task and participate in the review step of the workflow.

Note: You cannot add assignees on the Create step.
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Allow Add Cc | This option has two functions:  
1. When the Allow Cc field is set to Preassigned and Allow Add Cc, this option is set to Yes automatically. It enables BP users at runtime to copy additional users on a BP step that already has a preassigned cc user. This is done on the action form of the BP during the regular workflow step by selecting the Cc button. Click **Select** and choose the users/ or groups that can be copied.  
2. This option becomes available (choose Yes or No) if Allow Cc is set to Yes. Similar to Allow Add Assignees, this option allows assignees to send a copy of the current step of the BP to additional users in addition to those defined in the Add Cc field. Assignees can add the additional cc users before accepting the task. This is done by clicking the **Edit** menu and choosing **Copy Users to Current Step**.  
For example, user A has been sent a BP for review. User A wishes to add user B as an assignee to the review step as well. Before clicking Accept Task, user A chooses Edit > Add Assignees to Current Step and adds user B. User B is notified (depending on email preferences) of the new task. User A can accept the task and participate in the review step of the workflow. User B can review the view-only copy.  
Note: You cannot add Ccs on the Create step. |
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step Editors</td>
<td>Optionally, you can define one or more editors per each defined step in the business process workflow setup. Editors are users who can edit the business process without being granted explicit record-level permission or as assignees of the step. This allows users other than the assignee to edit the business process record. If you are an Editor on a business process step, you can open and edit any record on the step. Editors can be added on these BP types: Line Item Cost (all types, including Lease and Line Item with Multiple Codes) Document Simple RFB Text The Editor functionality has these attributes: The user who is designated as an editor must have a minimum of View User Records to the BP log in question. All edits are done through the BP Log. Editors cannot edit a workflow record until the task assignee accepts the task, and saves the draft. Editors cannot be defined on the creation step of a business process. Editors can be defined on the end step. Editors can be defined on a workflow step only if the Completion Policy is Single. (Unifier will generate an error if Completion Policy is set to All Majority or Consensus.) Editor on a task receive notification each time a draft is created. If multiple editors and the assignee are editing the business process record draft, the data saved by the last update will overwrite all previous updates. Edits performed on the End step of a workflow business process affect the record directly, as no draft exists. Edits that occur on the end step are captured in the audit listing the editor who performed the edit. Edits performed by record editors appear in the Audit log. Note: You cannot assign editors on the Create step.</td>
</tr>
<tr>
<td>Discussion Group</td>
<td>Specify assignees for discussion groups on the BP. Note: You cannot assign discussion groups on the Create step.</td>
</tr>
<tr>
<td>In this field</td>
<td>Do this:</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Step Revisiting</td>
<td>If a step is rejected and sent back for clarification or editing, this option determines to whom the BP can be sent back (which assignees will be available for selection):</td>
</tr>
<tr>
<td></td>
<td><strong>Include only previous action takers:</strong> Only the assignee users who were selected when the workflow moved into that step originally are eligible to be reselected.</td>
</tr>
<tr>
<td></td>
<td><strong>Include all step assignees:</strong> All assignee users are eligible to be selected.</td>
</tr>
<tr>
<td></td>
<td>Note: You cannot specify step revisiting on the Create step.</td>
</tr>
<tr>
<td>Completion Policy</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td><strong>Single:</strong> If any assignee completes the task, no matter which action is taken, the record moves forward to the next step.</td>
</tr>
<tr>
<td></td>
<td><strong>All-Majority:</strong> All assignees are required to respond. If there is no clear majority, Unifier uses the resolving action to determine what path through the workflow to take.</td>
</tr>
<tr>
<td></td>
<td><strong>All-Consensus:</strong> All assignees are required to respond. If there is no consensus (all must agree on the action), Unifier uses the resolving action to determine what path through the workflow to take.</td>
</tr>
<tr>
<td></td>
<td>Note: You cannot assign a completion policy on the Create step.</td>
</tr>
<tr>
<td>Resolving Action</td>
<td>This moves the step to either a following step, a previous step, or a conditional step that essentially &quot;re-addresses&quot; the task. This step must be completed before the workflow can continue. The assignees on this resolving action step can include the original task assignees and can also include new assignees.</td>
</tr>
<tr>
<td></td>
<td>Note: You cannot assign a resolving action on the Create step.</td>
</tr>
<tr>
<td>Overdue Policy</td>
<td>You can choose to send late notifications to all assignees if the step passes its duration.</td>
</tr>
<tr>
<td></td>
<td>Note: You cannot assign an overdue policy on the Create step.</td>
</tr>
</tbody>
</table>
## Commenting

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| **Commenting** | You may select either of these options regarding commenting. These refer to the general comments on BP forms, as well as comments regarding individual file attachments on document-type BPs.  
**Allow hiding of comments**: Allows users to hide comments. The comments will remain as part of the record, and administrators and others with permissions can view the comments, which are not visible to others without the view permission.  
**Allow deletion of comments**: Allows users with permission to delete comments previously added to the BP record.  
**Allow cc users to add general comments**: Allows users copied on a step to add general comments without accepting the task. Not available on the end step.  
**Notes**:  
- You cannot include comments on the Create step.  
- Task assignees can also add general comments without accepting the task if they have been given the **Add General Comments** permission on the business process. With this permission, they can add a general comment to any BP record they can view (workflow or non-workflow), regardless of the workflow step (including the End step), and regardless of the assignee or Cc settings. For more information on this permission, refer to the Permissions chapter in the *Unifier Reference Guide*. |

## Email Response: Enable response via email

| **Email Response: Enable response via email** | By default, this checkbox is unchecked. When enabled, this allows users who receive email that is sent out when a workflow reaches the current step to respond and take actions in Unifier via email. The checkbox appears on all workflow steps other than the creation step. The email that the user receives includes hyperlinks to workflow actions.  
When you are taking an action in a Workflow by way of email, if you include attachments, the attachments can be seen under the General Comments section of the BP record.  
**Notes**:  
- You cannot enable email response on the Create step.  
- To enable the attachment of files to email responses to workflow actions, this option must be selected as well as the Add Attachments option on the Options tab in the Action Form design in uDesigner. |

---

---
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Email Attachments: Include both record and line item attachments Include record information as attachment | Select to specify the content and format of email attachments. You can include business process record and line item attachments, as well as business process record information. Also, you can override the attachment format set in the General tab if necessary.  
**Note:** You cannot enable email attachments on the Create step. |
| Override default format | If you have specified a default record format on the General tab, you can use this check box to override the default format. For example, you can use the General tab to specify that the default record format for both email notifications and records saved in the Document Manager be in PDF format. If necessary, you could then use the Override default format check box to override the format and choose Custom for the notification only.  
**Note:** Hidden comments on a particular step in the Workflow and permission settings applied to certain data in the UI are retained in the custom print output. |
| Email Content | You can add additional information that will be sent out as part of task notification.  
**Note:** You cannot add additional information on the Create step. |
| Cash Flow Default Template | This option only appears in WBS code-based Base Commit business processes. It allows you to enable the auto-creation of a commitment-level cash flow curve at runtime for the business process record. The curve is based on the selected commitment-level cash flow template, and is created upon being sent from the step. Click Add and choose a template. For more information, see *Setting up auto-creation of cash flow curves from contracts* (on page 404). |
| Additional Information Save Record information to Document Manager | Select this check box if the record information (including BP comments and attachments) should be automatically saved at this step in the Document Manager. |
About Completion Policies, Resolving Actions, and Their Statuses

As administrator, you will set a completion policy on each step in a workflow. This policy determines when the step is complete and where the step proceeds from there. A step can be complete under the following conditions:

- Any single user can accept a task and complete it, and the record will move forward to the next step. This is called a single completion policy.
- All assignees to the task have responded to it and a majority has agreed on the action that moves the record forward to the next step. This is called an all-majority completion policy. If there is no clear majority on the action, Unifier will use a resolving action to determine how the record moves forward.
- All assignees to the task have responded to it and all assignees have agreed on the action that moves the record forward to the next step. This is called an all-consensus policy. If there is no consensus on the action, Unifier will use a resolving action to determine how the record moves forward.

A resolving action moves the step to either a following step, a previous step, or a conditional step that essentially "re-addresses" the task. This step must be completed before the workflow can continue. The assignees on this resolving action step can include the original task assignees and can also include new assignees.

The statuses you see on this window are internal to Unifier and are used only to display the status of the workflow step relative to the completion policy. These statuses are:

- **Not Started**: The assignee has not accepted the task.
- **In Progress**: The assignee has accepted the task.
- **Locked**: This status is used when the step has a single completion policy and one of the assignees accepted the task. This status denotes those assignees who were also assigned to the task, but because of the single completion policy, the task was locked and these assignees no longer have access to it.
- **View Only**: This status indicates that this user was cc’d on the task, but is not expected to take action on the task.
- **Completed**: This status is given to an assignee’s action if the task was finished and needed no resolving action. At any step, a task can have only one status of "Completed."
- **Closed**: This status is given to an assignee’s action if the task was finished, but triggered a resolving action. The task will either return to a previous step, move forward to a next step, or divert to a conditional step, which will resolve the condition and move the task forward in the workflow. The step the action moves to for resolution will show a status of "Not Started." The number of times the task shows a "Closed" status indicates the number of times the step has been revisited.

To illustrate:

Settings for conditional routing steps

Conditional routing steps are child nodes of the steps that lead to the condition routing. Auto-routing steps are shown with a diamond in front. Set up routing conditions on these steps.

Remember that the next step in the business process workflow will be dependent upon the value entered on the BP for the data element. When you are finished setting up this conditional routing step, the Settings tab will show two steps that represent the two options for the step that follows this auto-routing step. You define both of them, but the BP will follow just one of them based on the trigger.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition Name</td>
<td>Name of the condition. Can be configured for each setup.</td>
</tr>
<tr>
<td>Resolving Condition</td>
<td>Select this checkbox if this routing action goes to a step that is meant to resolve the condition.</td>
</tr>
<tr>
<td>Operator</td>
<td><strong>AND:</strong> All the conditions that are defined should be satisfied to satisfy a condition.</td>
</tr>
<tr>
<td></td>
<td><strong>OR:</strong> At least one of the conditions should be satisfied to satisfy a condition.</td>
</tr>
<tr>
<td>Trigger</td>
<td>Elements that are selected as part of design. Value of these elements will be resolved to route workflow. Can be one or more elements depending</td>
</tr>
</tbody>
</table>
**Unifier Administration Mode**

| Elements | upon design. |

**Settings for auto-create steps**

Some steps include the ability to auto-create other records, depending on the status of the previous step. It is displayed as a child node from which the link is drawn out. For document-type BPs, the auto-creation of BP records will also copy attachments from the original record.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Auto-create records | Choose one of the following:  
  **As per workflow design:** Auto-create BPs that were configured as part of the design in uDesigner.  
  **Based on user selection during execution:** During execution, user will be given a list of BPs that are selected under workflow design in uDesigner. User can choose which BP record should be auto-created.  
  **Process list:** Select a list of BPs for which the system will auto-create records during execution. |

**Settings for sub-workflows**

A sub-workflow is a mini workflow within a main workflow and is part of the uDesigner workflow design. It is a grouping of one or more steps. A sub-workflow node will be child node of the main workflow and a sibling of other steps and sub-workflow nodes.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sub-workflow Name</td>
<td>You can click the link to view the graphic of the sub-workflow.</td>
</tr>
<tr>
<td>Description</td>
<td>Capture more information about the sub-workflow.</td>
</tr>
<tr>
<td>Enable Sub-workflow duration</td>
<td>Similar to the main workflow. A duration can be set for the group of steps.</td>
</tr>
<tr>
<td>Overall Sub-workflow duration</td>
<td>Similar to the main workflow. Overall duration for the group of steps.</td>
</tr>
<tr>
<td>Override Sub-workflow due date</td>
<td>Similar to main workflow. User can override sub-workflow due date during execution.</td>
</tr>
</tbody>
</table>
Creating and Adding Business Process Help Files

Oracle provides standard business processes. You can access the help files associated with these business processes from the Unifier Help menu. To download the help files and save them locally, do the following:

1) Go to Primavera Unifier Online Documentation Library.
2) Select to view the library for the current release.
3) Select Help System.
4) Click Unifier Help.
5) Click Downloadable Unifier Help and, follow the prompts, and save the contents of help.zip locally.
6) Open the help folder.
7) Copy bp_help.zip and paste it locally.

You can also develop your customized business process and create your own help files.

**Note:** The help files must be in Adobe Acrobat PDF format.

You can add the help file to new or existing business process setups. If you add the help file after individual business process records have already been created, the help file will not be available to the existing records; however, it will be available immediately from the business process log or in any new business process that is created after the help file has been added.

**Note:** Custom business process help files can be added to project-level or company-level BPs.

To create a custom business process help file

1) Be sure that you have installed on your system Adobe Acrobat or other software application that includes a plug-in allowing the ability to create a PDF file.

2) In Microsoft Word or a similar software application, write the business process instructions that you wish to be made available to other business process users. Save the business process help file, but do not close it.

3) With your business process help file still open, do one of the following to create a PDF file. This will depend on how your system is set up.

   - **Print to PDF file:** Click the File menu and choose Print. From the Printer drop-down list, select Adobe PDF as the printer, and click OK. Name the PDF file and click OK.
   - **Save as PDF file:** Click the File menu and choose Save as PDF. Name the PDF file and click OK.

   The PDF file will be generated, and can be viewed using Adobe Acrobat Reader.

To add a custom business process help file to a new or existing business process setup

1) In Administration Mode:

   - For a business process at the company level, go to the Company Workspace tab and click Company Workspace > Business Process Setup.
Unifier Administration Mode

For a business process in a project or shell, open the project or shell and, in the Navigator, click **Setup > Business Process**.

**Note:** Even though the help file is added to an individual setup window, it is automatically added to all setups for that business process. The help file will be available immediately to all users with access to the business process log in User Mode, and will be available to any individual business process record created after adding the help file.

1. Select the business process from the log and click **Open**. The Setup log for the business process opens.
2. Click **New** to create a new setup, or select an existing setup from the log and click **Open**. The Business Process Setup window opens.
3. In the **General** tab, click the **Help File Add** button. The File Upload window opens.
4. Click **Browse** and navigate to the help file that you want to add. The help file must be an Adobe Acrobat PDF file. Click **OK** to attach the file and close the File Upload window.
5. When you have completed the Business Process Setup window, click **OK**.

**To access the business process Help link**

1. In User Mode, navigate to the business process log.
2. Click the **Help** menu, then click the business process name, which appears at the bottom of the **Help** menu. If a business process help file has been added to the business process form setup, the PDF file will open.
3. You can also access the file from business process form. Open a business process record, click the **Help** menu, and click on the business process name.

**About Auto-creating a Business Process record or Planning Item Based on conditions or frequency**

Using uDesigner, users can design a form that automatically creates a new business process (BP), line item, or planning item from a source form to a destination (auto-created) form after certain criteria are met. Users who have modify ownership permissions in the source record can enable auto-creation. You can override conditional auto-creation and immediately invoke the auto-creation manually if needed.

This type of auto-creation automatically generates a new record based on:

- A condition, such as a dollar amount
- A frequency, such as a daily or weekly time frame

**Note:** Line items cannot be created with a frequency trigger.

- Both a condition and a frequency

When a business process or line item reaches the trigger(s), the form will automatically create a new record or line item. This type of auto-creation uses a BP Creator, Planning Item Creator, or BP Line Item Creator data element on the upper and/or detail form to generate the new business process(es), line items, or planning item(s).

You can use auto-created business processes to manage repeated events, such as:
Line items of lease business process generating payment request business process records: A lease business process with a pre-generated payment schedule can use this functionality to generate payment request records at appropriate preset days in advance of the payment due date to be routed for approvals.

Preventive maintenance business process line items generating work orders business process records: A preventive maintenance type business process (Preventive Maintenance Book) can be set up to create work orders for assets at periodic intervals depending on the service needs of the asset.

For example, if you wanted to use auto-creation to create a work order business process to order maintenance on a vehicle, you would first create a preventative maintenance business process (the source business process) and have your administrator set up the auto-creation of a work order for vehicle maintenance business process (the destination business process) to order the work on the vehicle.

In this example, the uDesigner user set up which business process is the source business process and which is the destination business process. The company administrator specifies the conditions and defaults for the auto-creation. End users can set up the periodic auto-creation, based on their needs.

Create action items from meeting minutes: Create and assign tasks to different people creating a fully automated flow for routing of action items from meeting minutes.

Create a planning item: Create a planning item when an initiative business process has been approved. The planning item could then be fleshed out with details, such as budgets, locations, personnel.

Add a new line item to an existing record: You can add a line item to an existing business process. For example, a submittal registry record could contain line items that auto-create separate submittal business process forms for each contractor on a project. In the course of work, you might realize that the original submittal registry record is missing a submittal for an architectural drawing. You could submit a new submittal business process form that would add the missing architectural drawing submittal to the original registry record.

For Line Item Creation:

Users cannot create a line item on a record that is at a terminal or terminated status.

For line items created on a non-workflow cost type business process, the cost amount(s) will roll up to the Cost Sheet.

For line items created on workflow cost type business process, the cost amount(s) will NOT roll up to the Cost Sheet.

After a new workflow record is created, Unifier sends it to the assignees as an initiation task (I Step) that appears on the user's Tasks log and the business process log to which the record belongs. If a new record is sent as an initiation task, the user must accept the task to manually launch the record.

Note: Regardless of the number of assignees or creators, only one user may accept the I-Step task.

After a new non-workflow record is created, Unifier sends it to the designated creators as an initiation task (I Step) that appears on the user's Tasks log and the business process log to which the record belongs. The user must accept the task to view the record.
Grouping line items into single records

Unifier auto-creates new business process records using a BP Creator element. If this element is on the upper form of the business process, it will auto-create a single record. If the BP Creator element is on the detail or line item form, it will auto-create a record for every line item on the source record. For example, if source tab A has a BP Creator element and 10 line items, and source tab B has the same BP Creator element and 7 line items, 17 new records will be auto-created.

Sometimes, however, creating a record for every line item is cumbersome. You can end up with 17 records that differ in only one aspect, such as a color. For cases like this, you can group line items for auto-creation in order to create fewer generated records. In a simple example for a lumber yard order, you might have doors made of wood or steel, both in colors of white and red. You could group the line items according the material (wood or steel) and color (red or white) to create fewer work order records.

<table>
<thead>
<tr>
<th>SKU</th>
<th>Qty</th>
<th>Material</th>
<th>Color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>102</td>
<td>11</td>
<td>Wood</td>
<td>White</td>
<td>Pending</td>
</tr>
<tr>
<td>103</td>
<td>1</td>
<td>Steel</td>
<td>Silver</td>
<td>Pending</td>
</tr>
<tr>
<td>104</td>
<td>12</td>
<td>Steel</td>
<td>Silver</td>
<td>Pending</td>
</tr>
<tr>
<td>105</td>
<td>2</td>
<td>Wood</td>
<td>Red</td>
<td>Pending</td>
</tr>
<tr>
<td>106</td>
<td>9</td>
<td>Wood</td>
<td>White</td>
<td>Pending</td>
</tr>
<tr>
<td>107</td>
<td>3</td>
<td>Wood</td>
<td>Brown</td>
<td>Pending</td>
</tr>
</tbody>
</table>

By grouping line items by material and color, the auto-creation would generate four Work Order business processes instead of six.

<table>
<thead>
<tr>
<th>SKU</th>
<th>Qty</th>
<th>Material</th>
<th>Color</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>105</td>
<td>2</td>
<td>Wood</td>
<td>Red</td>
<td>Pending</td>
</tr>
<tr>
<td>102</td>
<td>11</td>
<td>Wood</td>
<td>White</td>
<td>Pending</td>
</tr>
<tr>
<td>106</td>
<td>9</td>
<td>Wood</td>
<td>White</td>
<td>Pending</td>
</tr>
</tbody>
</table>

Notes:

- If the auto-created business process is set up to include line item attachments, the attachments will be appended to the upper form of the destination business process if it is not a line item type.
- If the auto-creation uses a date trigger, Unifier will ignore this grouping feature.
Unifier will not group line items if

- The steps in the workflow are of different duration
- The task assignees are different
- The locations (such as shells) are different

See also Set up auto-creation for a non-workflow BP or planning item (on page 372) and Set up auto-creation for a workflow BP (on page 382).

Bypassing the I Step

During business process setup you can set up an auto-created workflow BP to skip the Initiation step and send the record directly into the workflow, where it normally arrives at the first step after the Create step (or the first step in a conditional routing). For a workflow BP, you can specify the schema, the step in the workflow that the record should use as its first step, the workflow duration, and the name of the person or group who will be the owner of the auto-created record. When the record is created, data will roll up to the manager sheets at the appropriate status; however, if Unifier encounters errors or invalid data, the record will remain at the Create step, and roll-ups will not occur until the user resolves the errors.

For a non-workflow BP, you can set up an auto-created record to skip the Initiation step. In this case, the non-workflow BP will be created and will appear in the BP log in either an "edit" or "finish edit" mode. If it appears in an "edit" mode, the user will have to open the record and add or correct information on the form. If it appears in a "finish edit" mode, the record is considered complete, and data will roll up to manager sheets.

Auto-Creation Protocol for Bypassing the I Step

Auto-creation uses details specified in the BP Creator element to create the record. If these details are not present in the BP Creator element, the auto-creation feature will use the following protocol to attempt to create the record.

<table>
<thead>
<tr>
<th>For a Non-Workflow BP</th>
<th>For a Workflow BP</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Checks for owner specification:</strong></td>
<td><strong>Checks for owner specification:</strong></td>
</tr>
<tr>
<td>Checks the source BP setup</td>
<td>Checks the source BP setup</td>
</tr>
<tr>
<td>Checks the destination BP setup</td>
<td>Checks the destination BP setup</td>
</tr>
<tr>
<td>If no owner can be identified, sends an error notification to those specified in source BP</td>
<td>If no owner can be identified, sends an error notification to those specified in source BP.</td>
</tr>
<tr>
<td><strong>Checks for status:</strong></td>
<td><strong>Checks for a workflow schema:</strong></td>
</tr>
<tr>
<td>Checks the destination BP setup</td>
<td>Checks the destination BP setup</td>
</tr>
<tr>
<td>If no status found, creates the record and puts it into &quot;edit&quot; mode for user to correct.</td>
<td>If no schema is specified, the record will be sent as an I Step to the user’s Tasks log and the BP log to which the record belongs. The user must accept the task to manually launch the record.</td>
</tr>
<tr>
<td><strong>Checks for an action specification</strong></td>
<td></td>
</tr>
</tbody>
</table>
Checks the destination BP setup
If no action is specified, the record will be sent as an I
Step to the user’s Tasks log and the BP log to which
the record belongs. The user must accept the task to
manually launch the record.

Rules for Checking Conditions for Auto-Creation
There are rules that govern when Unifier scheduler checks the conditions for auto-creation, and
then if the conditions are met, auto-creates the BP.

Rule 1
The Company Administrator selected the Enable Auto creation checkbox for BP Creator when the
auto-creation was set up in Unifier.

If the Enable Auto creation checkbox is checked, it implies system based auto-creation, and the
BP Creator Select button is not displayed in User Mode.

For non-workflow BPs: The condition check occurs on Finish Edit. If condition met, creates
record and shows the link for the auto-created BP. If no condition is specified auto-creates records
and shows the link for the auto-created BP.

For workflow BPs: The condition check occurs on Send. If end step reached and Action Form is
used on End Step, the condition check occurs on Save instead of Send. If condition met, creates
record and shows the link for the auto-created BP. If no condition specified blindly creates records
and shows the link for the auto-created BP.

If the Enable Auto creation checkbox is not checked, it implies manual creation.

For non-workflow BPs: The condition check does not occur on Finish Edit.

For workflow BPs: The condition check does not occur on Send.

BP Creator- Select button shown in User Mode so that the user can create the business process
manually. If clicked, creates BP record without checking any condition, and creates record and
shows the link.

Rule 2
Date Trigger Condition check: Are checks on the specified Date Data Element. Setting this up
implies that condition checks are done on a date instead of Finish Edit/Send in case of Non
workflow and Workflow respectively provided a link does not already exist next to BP creator
element. If a link already exists, it will not create any new records for that BP Creator element in
the chosen line item of the record.

Rule 3
Trigger Condition check based on frequency (Periodic): Are checks on frequency for BP
Creator elements with Enable Auto creator checked. If specified, these are the only time condition
checks are done. This overrides any other checks for date. This is the only method to create
multiple records even if a link already exists and a record has already been creator for this BP
Creator element. The link created using this will always point to last auto-created record.
Setting up auto-creation of cash flow curves from contracts

An additional cash flow option is available on the setup window for WBS code-based base commit business processes. This option enables the automatic creation of a commitment cash flow curve for each base commit record in a project or shell. In order to do this, you simply designate a commitment-level cash flow template to use for the auto-created curve.

For workflow business processes, this option is available in the Workflow Setup window Settings tab for every step other than the Create step. At runtime, when the record is sent from that step, the cash flow curve auto-creation is triggered and the curve is created in the Cash Flow log for the project or shell.

For non-workflow business processes, this option is available in the Business Process Setup window on the General tab. At runtime, the cash flow curve auto-creation will be triggered when the Finish Edit button is clicked on the BP record.

The following procedures describe enabling the auto-create cash flow option. See Setting Up a Non-Workflow Business Process (on page 368) and Setting Up a Workflow Business Process (on page 378) for more details on setting up business processes.

Note: This option is available for base commit business processes only; that is, cost-type business processes with sub-type of “Line Items with WBS Code,” and classification of “Base Commit.” For all other types of business processes, this option will not display. The cash flow curves that are auto-created are based on commitment detail level curve templates (either company-level, or curves created in project or shell templates).

To enable auto-creation of commitment-level cash flow curves in non-workflow base commit BP records

1) Navigate to the Business Process Setup window for the base commit business process.
   a. Open the project/shell (or project/shell template) and switch to Admin mode.
   b. In the left Navigator, click Setup>Business Process. Double-click the base commit business process from the log.
   c. Double-click the business process again to open the Business Process Setup window.
2) On the General tab, locate the Cash Flow Template field.
3) Click Add. The Cash Flow Templates window opens. It lists all commitment detail-level cash flow templates created in the Company Workspace (In Standards & Libraries > Cash Flow >Templates) or in project or shell templates (in the Cash Flow node).
4) Choose a template and click Select.
   Note: Entering a template in this field enables the cash flow auto-create feature. To disable this feature, click the Remove button to remove the cash flow template from the field.
5) Click OK to save and exit the Business Process Setup window.
At runtime, a commitment cash flow curve will be created in the project or shell when the base commit record is complete -- that is, the user clicks the Finish Editing button on the record. The data used for the cash flow curve will be taken from the line item values on the record at the time the record is sent.

**To enable auto-creation of commitment-level cash flow curves in workflow base commit BP records**

1) Navigate to the Business Process Setup window for the base commit business process.
   a. Open the project/shell (or project/shell template) and switch to Admin mode.
   b. In the left Navigator, open Setup>Business Process. Double-click the base commit business process from the log.
   c. Click Workflow Setup, then double-click a setup name (or create a new BP setup) to open the Workflow Setup window.
2) Click the **Settings** tab.
3) Select any step other than the Create step. Scroll down the Step Configuration options and locate the Cash Flow: Default Template field.
4) Click **Add**. The Cash Flow Templates window opens. It lists all commitment detail-level cash flow templates created in the Company Workspace (in Standards & Libraries>Cash Flow>Templates) or in project or shell templates (in the Cash Flow node).
5) Choose a template and click **Select**.

**Note**: Entering a template in this field enables the cash flow auto-create feature. To disable this feature, click the Remove button to remove the cash flow template from the field.

6) Click **OK** to save and exit the Workflow Setup window.
   At runtime, a commitment cash flow curve will be created in the project or shell when the base commit record is sent from the selected step. The data used for the cash flow curve will be taken from the line item values on the record at the time the record is sent. If record line item values are edited during the course of the workflow, then the curve values will update the next time the curve is refreshed.

**Note**: This option is not available in the Create step. If you designate a cash flow template in more than one workflow step, the cash flow curve will be created at the first step in which this option is enabled; the auto-creation will be ignored in any subsequent steps, because only one cash flow curve can be created per base commit record.

**Copying Workflow Setups from Other Schemas**

Some workflows can encompass many steps, as well as conditional routing and sub-workflows. Most of your time as administrator can be spent setting up the workflow schemas in your company. To make setting up workflow schemas easier and faster, Unifier provides you the option of copying existing setups from other workflow schemas.
For example, if you have set up a large schema for an approval process that includes separate workflows for different provisos, you can copy the setup of one schema to another workflow, and make incidental changes where necessary, rather than set up the entire workflow schema again. Or, if you have a complex schema for setting up a project or shell, you can copy that schema to set up a different project or shell in your same Unifier environment.

<table>
<thead>
<tr>
<th>You can copy a setup from here:</th>
<th>To here:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A business process in the Company Workspace</td>
<td>The same business process in the same Company Workspace</td>
</tr>
<tr>
<td></td>
<td>If any users or groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A project template for a business process</td>
<td>Another project template for the same business process</td>
</tr>
<tr>
<td></td>
<td>If any users or groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A business process in a project</td>
<td>A project template for the same business process</td>
</tr>
<tr>
<td></td>
<td>If any users or groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A shell template for a business process</td>
<td>Another shell template (of any shell type) for the same business process</td>
</tr>
<tr>
<td></td>
<td>If any users or groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A business process in a shell</td>
<td>A shell template (of any shell type) for the same business process</td>
</tr>
<tr>
<td></td>
<td>If any users or groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
</tbody>
</table>

**Business Processes Must Match**

In all cases, the business process name, type, sub-type, classification, studio owner, and version number must match or the copy function will fail.

**About the version number**

The number in the Version column of the business process log shows the uDesigner version number. This number represents the number of times the design has been changed from Draft mode to Complete.

The uDesigner module automatically increments the version number whenever a design is returned to Draft mode. When the draft is changed to Complete, it shows that number. This version of the design in uDesigner may or may not be the version that is active in Unifier.
The version number that appears on this log in Unifier shows the last deployed version that was imported. This number may not match the version number uDesigner, but it is the last active version of the design in Unifier. The version number of the BP you are copying from must match the version number of the BP you are copying into.

**At the Company Level, Copy a Setup from Another Setup in the Same BP**

In this copy action, you copy a setup to another setup in the same business process in the same company workspace.

**To copy a workflow setup**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Workspace > Business Process Setup** in the left Navigator.
3) On the right pane, double-click the business process to open it.
4) In the Navigator, click **Workflow Setup**, and in the right pane, select the setup you want to copy.
5) Click the **Copy** button. The Workflow Setup window opens.
6) On the **General** tab, enter a name and description for the new setup and make the status **Active** or **Inactive** as necessary.
7) Click **Apply**.
8) Click the **Settings** tab. The **Settings** tab opens, showing the workflow of the setup you copied.
   On this tab, you can make any changes you want to the setup you copied to accommodate the new setup.
9) To save the new setup, click **OK**.
   If you made the setup **Active**, Unifier will perform an error check on the new setup and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.
Copy a Setup from One Project/Shell Template to Another

In this copy action, you copy a setup from a business process in one project/shell template to the same business process in another project/shell template.

To copy a setup from one project/shell template to another
1) Go to the Company Workspace tab and switch to Admin mode.
2) Do one of the following:
   - To copy a setup into a BP in a standard project template, click Templates > Projects (Standard) > All in the left Navigator. In the right pane, double-click the project that contains the BP you want to copy the setup into.
   - To copy a setup into a BP in a shell template, click Templates > Shells > [shell type] in the left Navigator. In the right pane, double-click the shell that contains the BP you want to copy the setup into.
3) In the Navigator, click Setup > Business Process.
4) In the right pane, double-click the name of the business process into which you want to copy the setup.
5) In the Navigator, click Workflow Setup.
6) Click the Copy From button and choose Templates. A copy window opens, listing all the workflow templates for that BP that exist in all the projects and shells in your environment.
7) Select the template you want to copy and click Copy. The Workflow Setup window opens.
8) On the General tab, enter a name and description for the new setup and make the status Active or Inactive as necessary.
9) Click Apply.
10) Click the Settings tab. The Settings tab opens, showing the workflow of the schema you copied.
    On this tab, you can make any changes you want to the setup you copied to accommodate the new setup.
11) To save the new setup, click OK.
    Unifier adds the template to the workflow setup log. If you made the setup Active, Unifier will perform an error check on the new setup and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.
Copy a Setup from a Project/Shell to a Template

In this copy action, you copy a workflow setup from a business process in a project or shell and make it a template in the BP you copy the setup into.

To copy a setup from a project/shell to a template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Do one of the following:
   - To copy a setup into a BP in a standard project template, click Templates > Projects (Standard) > All in the left Navigator. In the right pane, double-click the project that contains the BP you want to copy the setup into.
   - To copy a setup into a BP in a shell template, click Templates > Shells > [shell type] in the left Navigator. In the right pane, double-click the shell that contains the BP you want to copy into.
3) In the Navigator, click Setup > Business Process.
4) In the right pane, double-click the name of the business process into which you want to copy the setup.
5) In the Navigator, click Workflow Setup. The right pane lists the workflow setups that currently exist for this business process.
6) Click the Copy From button and choose Project/Shell.
   A copy window opens, listing all the workflow setups for that BP that exist in all the projects and shells in your environment.
7) Select the setup you want to copy and click Copy. The Workflow Setup window opens.
8) On the General tab, enter a name and description for the new setup and make the status Active or Inactive as necessary.
9) Click Apply.
10) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you copied.
    On this tab, you can make any changes you want to the setup you copied to accommodate the new setup.
11) To save the new setup, click OK.
   Unifier makes a template of the setup you copied and adds the template to the workflow setup log. If you made the setup Active, Unifier will perform an error check on the new schema and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.
Importing Workflow Setups From One Company to Another Company In the Same Environment

Unifier provides you the option of copying existing workflow setups into other workflows in your company (Copying Workflow Setups from Other Schemas on page 405).

In addition to that option, you can import workflow setups from one company to another company in your environment, such as from one company in uStage to another company in the same uStage environment. This import option is critically useful if your company is undergoing a significant reorganization or redesign, and the current designs in your Unifier environment are no longer sufficient.

You can import a setup from here: | To here:
---|---
A business process in a Company Workspace | The same business process in another Company Workspace
If any groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.

A project template for a business process | A project template for the same business process in another company
If any groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.

A shell template for a business process | A shell template (of the same shell type) for the same business process in another company
If any groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.

Business Processes Must Match

In all cases, the business process name, type, sub-type, classification, studio owner, and version number must match or the copy function will fail.

About the version number

The number in the Version column of the business process log shows the uDesigner version number. This number represents the number of times the design has been changed from Draft mode to Complete. The uDesigner module automatically increments the version number whenever a design is returned to Draft mode. When the draft is changed to Complete, it shows that number. This version of the design in uDesigner may or may not be the version that is active in Unifier. The version number that appears on this log in uDesigner shows the last design version that was imported. This number may not match the version number in uDesigner, but it is the last active version of the design in uDesigner. The version number of the BP you are copying from must match the version number of the BP you are copying into.
To import a workflow setup from one company to another company

1) In Administration mode, go to the Company Workspace tab and click **Company Workspace > Business Process Setup** in the left Navigator.

2) Open the business process you want to import the setup into.

3) In the Navigator, click **Workflow Setup**, and click the **Import** button. The Unifier sign in window opens.
   This is where you sign in to the company from which you want to import a workflow setup.

4) Enter the following information:
   - **Company Short Name**: This is the identifier for the company that you are signing in to.
   - **Authentication Key**: This is the key of the company that you are signing in to. This key was set up at the time the company was configured. It is like a password that provides import access to the BPs of the company you want to import from.
   - **Unifier URL**: (Optional) This is the web address of the Unifier server you want to sign in to. If you leave this field blank, Unifier will assume you are importing within the same environment.

   **Note**: The Unifier at this URL must be the same version number as the Unifier you are working in. The import function does not work across companies with different versions of Unifier.

5) Click **OK**.
   The import window opens, listing the matching workflow setups (active and inactive) that currently reside in the company you have signed in to for the business process you selected under the Company Workspace node.

6) Select the workflow setup(s) you want to import and click the **Import** button.
   Unifier imports the workflow setup(s) using the following guidelines:
   - If a setup does not currently exist in the destination company, the import will happen immediately and Unifier will mark the new setup **Inactive**.
   - If a setup already exists, Unifier will verify that you want to replace the existing setup with the one you are importing. If you import the setup, Unifier will replace the existing setup and mark the new setup **Inactive**.

7) Click the **Close Window** button.

8) In the right pane, double-click the setup you imported. The Workflow Setup window opens.

9) On the **General** tab, enter a name and description for the new setup and make the status **Active** or **Inactive** as necessary.

10) Click **Apply**, then click the **Settings** tab. The Settings tab opens, showing the workflow of the setup you copied.
   On this tab, you can make any changes you want to the setup you imported to accommodate the new setup.

11) To save the new setup, click **OK**.
   Unifier adds the setup you imported to the workflow setup log. If you made the setup **Active**, Unifier will perform an error check on the new setup and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.
Importing Workflow Setups from One Environment to Another

Unifier provides you the option of importing existing workflow setups from one company to another in the same environment (see Importing Workflow Setups From One Company to Another Company In the Same Environment (on page 410)).

In addition to that option, you can also import workflow setups from one environment to another, such as from uStage to your Unifier environment.

**Note:** To support the import function, the versions of the environments must match. For example, you cannot import a setup from one version of uStage to a different version of Unifier.

<table>
<thead>
<tr>
<th>You can import a setup from here:</th>
<th>To here:</th>
</tr>
</thead>
<tbody>
<tr>
<td>A business process in a Company Workspace</td>
<td>The same business process in another Company Workspace</td>
</tr>
<tr>
<td></td>
<td>If any groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A project template for a business process</td>
<td>A project template for the same business process in another environment</td>
</tr>
<tr>
<td></td>
<td>If any groups are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
<tr>
<td>A shell template for a business process</td>
<td>A shell template (of the same shell type) for the same business process in another environment</td>
</tr>
<tr>
<td></td>
<td>If any are defined in the setup, they will be copied over if they do not already exist; matching will be done on the name.</td>
</tr>
</tbody>
</table>

**Business Processes Must Match**

In all cases, the business process name, type, sub-type, classification, studio owner, and version number must match or the copy function will fail.

**About the version number**

The number in the Version column of the business process log shows the uDesigner version number. This number represents the number of times the design has been changed from Draft mode to Complete. The uDesigner module automatically increments the version number whenever a design is returned to Draft mode. When the draft is changed to Complete, it shows that number. This version of the design in uDesigner may or may not be the version that is active in Unifier. The version number that appears on this log in uDesigner shows the last design version that was imported. This number may not match the version number in uDesigner, but it is the last active version of the design in uDesigner. The version number of the BP you are copying from must match the version number of the BP you are copying into.
Import a Setup From One Company to Another Company

In this import action, you import a setup from one company to a setup in the same business process in another company.

To import a workflow setup from one company to another company

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Company Workspace > Business Process Setup** in the left Navigator.
3) Open the business process you want to import the setup into.
4) In the Navigator, click **Workflow Setup**, and click the **Import** button. The Unifier sign in window opens.
   This is where you sign in to the environment from which you want to import a workflow setup.
5) Enter the following information:
   - **Company Short Name**: This is the identifier for the company that you are signing in to.
   - **Authentication Key**: This is the key of the company that you are signing in to. This key was set up at the time the company was configured. It is like a password that provides import access to the BPs of the company you want to import from.
   - **Primavera Unifier URL**: This is the web address of the Unifier server you want to sign in to.

   **Note**: The Unifier at this URL must be the same version number as the Unifier you are working in. The import function does not work across environments with different versions of Unifier.
6) Click **OK**.
   The import window opens, listing the workflow setups that currently reside in the environment you have signed in for the business process you selected under the Company Workspace node.
7) Select the workflow setup(s) you want to import and click the **Import** button.
   Unifier imports the workflow setup(s) using the following guidelines:
   - If a setup does not currently exist in the destination environment, the import will happen immediately and Unifier will mark the new setup **Inactive**.
   - If a setup already exists, Unifier will verify that you want to replace the existing setup with the one you are importing. If you import the setup, Unifier will replace the existing setup and mark the new setup **Inactive**.
8) Click the **Close Window** button.
9) In the right pane, double-click the setup you imported. The Workflow Setup window opens.
10) On the **General** tab, enter a name and description for the new setup and make the status **Active** or **Inactive** as necessary.
11) Click **Apply**, then click the **Settings** tab. The Settings tab opens, showing the workflow of the setup you copied.
    On this tab, you can make any changes you want to the setup you imported to accommodate the new setup.
12) To save the new setup, click **OK**.
Unifier adds the setup you imported to the workflow setup log. If you made the setup Active, Unifier will perform an error check on the new setup and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.

**Import a Setup for a BP to a Project/Shell Template for the Same BP in Another Environment**

When importing to a shell template, the source and destination shells must be of the same type.

**To import a BP setup to a project/shell template in another environment**

1. Go to the Company Workspace tab and switch to Admin mode.
2. Do one of the following:
   - To import a setup into a BP in a standard project template, click **Templates > Projects (Standard) > All** in the left Navigator. In the right pane, double-click the project template that contains the BP you want to import the setup into.
   - To import a setup into a BP in a shell template click **Templates > Shells > [shell type]** in the left Navigator. In the right pane, double-click the shell template that contains the BP you want to import the setup into.
3. In the Navigator, click **Setup > Business Process**.
4. In the right pane, double-click the name of the business process you want to import the setup into.
5. In the Navigator, click **Workflow Setup**. The right pane lists the workflow setups that currently exist for this business process.
6. Click **Import** to open the sign in window.
   - This is where you sign in to the environment from which you want to import a workflow setup.
7. Enter the following information:
   - **Company Short Name**: This is the identifier for the company that you are signing in to.
   - **Authentication Key**: This is the key of the company that you are signing in to. This key was set up at the time the company was configured. It is like a password that provides import access to the BPs of the company you want to import from.
   - **Primavera Unifier URL**: This is the web address of the Unifier server you want to sign in to.

   **Note**: The Unifier at this URL must be the same version number as the Unifier you are working in. The import function does not work across environments with different versions of Unifier.

8. Click **OK**.
   - The import window opens, listing all the workflow setups for that BP that exist in all the projects (if you chose a project template) or shells (if you chose a shell template) in the environment you signed in to.
9. Select the setup you want to import and click **Import**, then click **Close Window**.
10. In the right pane, double-click the setup you imported. The Workflow Setup window opens.
11. On the **General** tab, enter a name and description for the new setup and make the status **Active** or **Inactive** as necessary.
12. Click **Apply**.
13) Click the **Settings** tab. The Settings tab opens, showing the workflow of the setup you imported.

   On this tab, you can make any changes you want to the setup you imported to accommodate the new setup.

14) To save the new setup, click **OK**.

   Unifier adds the setup you imported to the workflow setup log. If you made the setup **Active**, Unifier will perform an error check on the new setup and notify you of any errors it encounters; otherwise, the error check will not occur until the setup is activated.

---

**Setting up a blanket purchase order summary template**

If you have set up a company-level blanket purchase order (a uDesigner created, company-level cost subtype commit BP), you must then set up a summary template to enable validation against individual commit BPs that reference the blanket PO.

**To set up the summary template for a blanket PO**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) In the left Navigator, click **Company Workspace > Business Process Setup**. The business process log opens.

3) In the log, double-click the name of the blanket PO business process. A setup log opens.

4) On the log, select the business process and click the **Summary Template** button.

5) You may add additional columns as needed. Click **Columns**, then click **New**. Complete the Column Properties. The data source choices for columns include:

   - **Single source**: All active cost BPs for your company (and their statuses), regardless of project. You determine which statuses you want to appear on the sheet. If you import and set up cost BPs that might reference the blanket PO, be sure to add them to the summary sheet template to track them against the total.

   - **Logical source**: Total commits and remaining balance. These should be set up as formulas, where total commits is the sum of the commits that you added as columns, and the remaining balance is the difference between the original amount and total commits.
To enable validation, include a total commits column to keep track of commit BPs that reference the blanket PO, and a remaining balance column to ensure that you do not exceed the original amount.

Setting up an RFB business process

A Request for Bid (RFB) business process allows companies to invite bids from multiple vendors. The Request for Bid process requires the following components to operate in Primavera Unifier:

- **Master Vendor BP**: A simple or line-item type company level BP listing available vendors who can be invited to bid. A company can have only one master vendor BP.
- **Requestor form**: This is the BP form the Primavera Unifier user uses to distribute bid requests from vendors.
- **Bidder form**: This is the BP form the vendors use to submit their bids.
- **A workflow for the requestor form**: This workflow or workflows can be used to approve the RFB before inviting bids, to distribute the RFB, and to approve the final bid award.
- **(Optional) A bid comparison sheet**: This is a sheet designed specifically for your company for the purpose of comparing the bids you receive from vendors. (If your company has not designed one, Primavera Unifier provides a default sheet you can use.)
Verify the RFB Has Been Designed Correctly

In uDesigner User mode:

1) Verify that the correct vendor list is linked to the RFB.
   a. Open your vendor master business process properties and click the Options tab.
   b. Make sure the field **Use this process as RFB master vendor list** is checked. This option links the vendor list to your RFB.

2) Make sure the correct vendor list has been specified as the RFB’s reference process.
   a. Open the RFB and click **Reference Processes** in the Navigator.
   b. Verify that the RFB references the correct vendor BP.

Set Up a Bid Management Account in Primavera Unifier

To enable the vendors to sign in to Primavera Unifier and submit bids, you need to create a "bidder" account. In the preferences you set up for this account, you need to specify certain settings to make the bidding process possible. You will enter this bidder’s account in your company’s preferences.

**Tip:** Do not link the bid management account to an actual user in your company. Create this account strictly for the bidding process so that you can set up the account preferences specifically for bidding. If you set up a special "bid management" user account, you can prevent users from inadvertently changing the settings.

1) To set up this "bidder" account, add the bidder as a user. See **User and Group Administration** (on page 135).
2) Sign in to Primavera Unifier as the user with the bidder account.
3) From the top right-corner of your window, click your **User Name** to open a contextual menu.
4) Click the **Preferences** link. The User Preferences window opens.
5) Click the **Options** tab.
6) Set the **Time Zone** field to match that of the bid requestor’s (either your company’s time zone, or the zone from which the bid invitation is sent).
   If your bidders are in a different time zone from yours, this will protect them from mistakenly submitting bids after the bidding process is closed.

Set Up the RFB in Unifier

To set up the RFB (in Administration Mode):

1) Follow the standard procedures to import (**Importing Business Processes (BPs)** (on page 355)), configure (**Configuring Business Processes (BPs)** (on page 355)), and set up (see **General Procedures for Setting up Business Processes** (on page 366)) the RFB.
2) Define a link for the bidders to use to submit bids:
   a. Go to the **Company Workspace** tab and switch to **Admin** mode.
   b. In the left Navigator, click your company name. The company landing page opens.
   c. Click the **Open** button. The Edit Company properties window opens.
   d. Click the **General** tab.
e. In the **Bid Access URL** field, finish the URL address (usually with the name of your company).

   This is the link that will appear on the bid invitation you send to the bidder. The bidder will use this link to sign in to Unifier and submit a bid.

f. In the **Bid Management Account** field, enter the account name of the user who will be managing the bids that your company receives.

   This is the account that contains the bidder’s preferences you created using the instructions under *Set Up a Bid Management Account in Primavera Unifier* (on page 417).

**Business Process Permission Settings**

Refer to the *Unifier Reference Guide* for permission settings.

**Business Process Functionality in Unifier**

Not all BPs work with all functional areas of Primavera Unifier. This table lists the available BPs and the areas in which the BP works.

<table>
<thead>
<tr>
<th>Type</th>
<th>Subtype</th>
<th>Classification</th>
<th>Project (Standard)</th>
<th>Shell (WBS)</th>
<th>Shell (Generic)</th>
<th>Company</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost</td>
<td>Commit at Company level</td>
<td>-</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>Generic</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>Transfer</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>Base Commit</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>Change Commit</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>General Spends</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with WBS code</td>
<td>Payment Applications</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with fund code</td>
<td>Generic</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with fund code</td>
<td>Transfer</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with both fund and WBS code</td>
<td>Generic</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with both fund and WBS code</td>
<td>Transfer</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>--------------------------------------</td>
<td>----------</td>
<td>---</td>
<td>---</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with company account code</td>
<td>Generic</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with company account code</td>
<td>Transfer</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with asset code</td>
<td>-</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>Generic</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>Transfer</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>Base Commit</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>Change Commit</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>General Spends</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Line item with multiple codes</td>
<td>Lease</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line item</td>
<td>-</td>
<td>-</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Line item</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>RFB</td>
<td>-</td>
<td>-</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Simple</td>
<td>-</td>
<td>-</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Simple</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Document</td>
<td>With folder structure</td>
<td>No detail form</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Document</td>
<td>With folder structure</td>
<td>With detail form</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Document</td>
<td>Without folder structure</td>
<td>No detail form</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Document</td>
<td>Without folder structure</td>
<td>With detail form</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
The Query tab allows access to all Business Processes/Space/Level records, related to a Business Process, by way of Query-based Tab (QBT). For example, if you need to see all approved Spaces related to your BP, you can use the QBT to query/fetch those records. Once a Query-based Tab (QBT) is successfully created and deployed using uDesigner, the Query Tabs appear in the Unifier required BP, in User mode.

As a pre-process to defining the Query Tab in the BP, you need to use a Reference picker in one of the upper forms of the BP/Space/Level from where you want to create the Query Tab. For defining a Query Tab, click on the Query Tabs link in uDesigner, click New, and select a BP/Space/Level. The system allows you to create a maximum of 8 tabs in uDesigner, including the QBT.

To define a Query Tab, go to uDesigner:
1) Click **Query Tabs**.
2) Click **New**.
3) Select a BP.

The Query Items sub-node under the Business Process node (uDesigner > Admin mode > Business Processes > [BP]) allows you to include references to other BPs/Spaces/Levels in a form of a Query-based tab.

Within a selected BP, the Query Items sub-node provides the following two links:
- Query Tabs
- Summary Elements

**Query Tabs**

Once a Query-based Tab (QBT) is successfully created and deployed using uDesigner, the BP Query Tabs appear in the Unifier required BP, in User mode. You can use the Query Tabs sub-node to define and maintain the various Query Tabs that are defined within the BP.

**General Tab**

In the General tab, you can enter the name, description, and reference picker for the required QBT.
In case, you have already included the Reference picker in the Upper form of the BP, the Reference picker appears in the drop-down list of the Reference picker. In this case, the Name field is populated with the name of the BP, but you can change the name of the QBT, if necessary. The name and reference pickers are mandatory fields on the General Tab, so you cannot create a QBT if you have not included the Reference picker on the Upper form of the BP.

**Query Tab**

The Query Tab of the QBT is used to create a query to filter the results, displayed within the QBT, based on any particular condition.

To access the Query Tab, go to Item Logs sub-node, open the QBT that was created, and switch to the **Query** tab.

---

**Note:** It is not mandatory to have a query, so in case no queries are defined all records display in the QBT, in User mode.

---

You can define multiple queries within the Query tab.

The Query Tabs log page allows you to:

- See all the Query Tabs
- Create a new QBT (New).
- Open an existing QBT to review or change content (Open).
- Delete an existing QBT (Delete).

**Summary Elements**

You can use the Summary Elements on the Upper form of the BP to show the data that is being exchanged. You can use the following types of the Summary Elements in QBT:

- Average
- Count
- Total
- Maximum
- Minimum

You can define multiple Summary Elements. To create Summary Elements, go to uDesigner > your BP [BP] > Summary Elements and use the QBT to create your Summary Elements. After defining the Summary Elements, click **OK** to save. The Summary Element log page allows you to:

- See all the Summary Elements.
- Create a new Summary Element (New).
- Open an existing Summary Element to review or change content (Open).
- Delete an existing Summary Element (Delete).

Once you create the Summary Elements, you can include them in the Upper form of your BP [BP].
Setting Up Updates for Business Process Records

Business Processes (BPs) can be associated with specific Project or Shell (Project/Shell-level BP), or they can be applicable for the entire Company (Company-level BP) and not to be specific to a Project/Shell. The Administrator (Project/Shell or Company) determines which forms are to be used and how the workflows operate.

To set up a BP record to receive updates in a Company or Project/Shell, do one of the following:

For a Company, switch to the Admin mode > Company Workspace > Business Process Updates

For a Project/Shell, switch to the Admin mode > Company Sponsored Shells > Business Process Updates

In This Section

Company Workspace and Business Process Updates ............................................. 423
Project/Shell and Business Process Updates ......................................................... 427

Company Workspace and Business Process Updates

To update a Business Process (BP) in the Company Workspace, go to Company, switch to the Admin mode > Company Workspace > Business Process Updates.

Business Process Updates Log in Company Workspace

The Business Process Updates log in Company Workspace allows you to set up updates from a template to a record, at the Company level. The log consists of the following:

Menu

- File
- Edit
- View
- Help

Toolbar

- New
- Cancel Request
- Open
- Find
- View Details

Note: These options can be accessed through the Business Process Updates log window menu options.

Columns
The functions of the elements in the Business Process Updates log are explained in the proceeding sections.

**Company Workspace and Preventive Maintenance Type BP**

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create Work Order BP records for assets at periodic intervals according to the service needs of the asset.

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive Maintenance Book) in order to view all the Work Order BP records for that Preventive Maintenance type BP (Preventive Maintenance Book).

The Business Process Updates log in Company Workspace allows you to set up updates from a PM Book Template to a PM Book record, at the Company level.

The following explains the following toolbar options:

**Note**: These options can be accessed through the Business Process Updates log window menu options.

- **New**
- **Cancel Request**
- **Open**
- **Find**
- **View Details**

The **New** option enables you to create new update requests from the PM Book Template type, and the log displays all the PM Book Template updates that exist at the Company level.

The drop-down list of the **New** option lists all the BPs of PM Book Template type that have been set up in the Company Workspace. If a BP is not Active, or it does not have Active setups, then the system does not include the BP in this list.

**Note**: If there are no BPs that have Active setups, the **New** option will be disabled.

When you select a BP from the New option list, the BP record selection window opens which enables you to select the source PM Book Template record for the update.
The BP record selection window contains the log elements/options that have been set in the Business Process Configuration.

The toolbar of the BP record selection window has the same option as the Data Picker window. The **Cancel Request** option enables you to cancel a scheduled update. You can only cancel a request that has not started (i.e., you can cancel a record that is not stamped with a Start Date.). You can cancel multiple requests. After you cancel an update request, the system changes the:

- Status of the request to: Not Started
- Schedule option to: None

The **Open** option enables you to view the request details; however, depending on the status of a record, this option may not be available, as explained here:

- If the Status of a record is "Completed/In Progress/Error/Failed," then the log window has a Close option. In this case, you can only view the update request details.
- If the Status of a record is "Not Started/Not Scheduled," then the update setup window opens.

The **Find** option enables you to search for a particular request in the log, using the following search parameters:

- **Name**
- **Source Business Process**
- **Source Business Process Record**
- **Status**

**Note:** The logical operators are the same as in any String or Pull Down field.

The **View Details** option enables you to view the details of an update request. When you click this option, the system opens a report in PDF format that outlines the details of all of the PM Book records that were updated successfully and those that were not.

**PM Book Record Update Window**

After you select the source PM Book Template record for the update, the **PM Book Record Update** window opens which contains multiple tabs. These tabs are based on the PM Book Template design and are not query-based tabs.

**Note:** Depending on the design of the Asset Business Process in uDesigner, you may see other tabs (Detail Form tabs) in the PM Book Record Update window. For example, you can see Time Schedules tab, Gauge Meter Schedules tab, and so forth.

The following describes each tab in details:

- **General tab**
  The General tab is fixed and has the following fields:
  - **Name** (required)
  - **Description** (optional)
Source Business Process (read-only): The value in this field is the name of the PM Book Template Business Process.

Source Business Process Record (read-only): The value in this field is the number of the PM Book Template record that is the source of the update.

Schedule (block): This block has two fields (date and time picker) impacting the schedule of the update (Date and None). The date that you select must be greater than the current date and time.

Main Form tab
The Main Form tab is fixed. The fields in this tab enables you to update the Upper Form field values of the PM Book record from the Upper Form field values of the PM Book Template record.

The Data Elements in the Main Form tab are based on the Data Elements that exist in the PM Book Template.

By default, all Data Elements are selected. Use the check box next to Data Element to select or deselect all other Data Elements.

The order of the fields are based on the Upper Form design.

Use the View Record Details option to open a read-only copy of a record. This is to assist the user with reviewing the existing values of the PM Book Template record.

Detail Form tabs (Other tabs)

The Update PM Book Records window displays tabs based on the design of the Detail Form (uDesigner > Business Processes > PM Book Templates > Design Form). For example, if the Detail Form contains Time Schedules and Gauge Meter Schedules, then the Update PM Book Records window displays the Time Schedules tab, Gauge Meter Schedules tab, in addition to the fixed tabs (General tab and Main Form tab).

The Detail Form tabs enables you to select the Line Items that need to be updated in the auto-created PM Book records, from the PM Book Template.

The following elements are available in each Detail Form tab:

Line Items

From this block, you can specify the Line Items that you want to get updated in the PM Book records, from the PM Book Template. The Line Items block displays all Line Items that exist in the selected template record and includes the following information about each Line Item:

Line No.

The line number of the Line Item in the PM Book Template. The line number in the PM Book record may not have a one-to-one connection with the line number existing in the BP Book Template.

Short Description

Line Item Details

Each Line Item has a View, hyperlink, option that enables you to view the Line Item details, in View only mode.

Data Elements - <name> tab

This section displays the list of applicable Data Elements. Use the Data Element check box to select/deselect all elements. The Line Items listed here exist in the auto-created PM Book record.
When an Asset auto-creates a PM Book record, the Line Items, and contents, are copied over from the PM Book Template record associated with the Asset. The system associates a unique "guid" for each of the Line Items in the PM Book record and maintains a reference to the Line Items in the parent PM Book Template record. Since such a reference exists, the Line Item in the parent PM Book template record is changed, and the corresponding Line Item in the destination PM Book record is updated by means of this Push update.

New line items can only be added to the Time based tab. If new Line Items are added to the PM Book Template record, you need to conduct a push to add the new Line Items to the PM Book record, as new Line Items. The Data Elements of the PM Book records are updated as part of this push.

If the Line Items do not exist in the auto-created PM Book records, then the system creates the Line Items. The new Line Item creation, in the PM Book records, follow the Line Item auto-creation logic, and the new Line Item creation does not refer to the Data Elements section of the tabs, at the time of update. The tab mapping that has been set in the design of the Asset BP forms the basis for copying over the field values in the PM Book records.

### Project/Shell and Business Process Updates

To update a Business Process (BP) in the Project/Shell, go to Project/Shell, switch to the Admin mode > Company Sponsored Shells > Business Process Updates.

### Business Process Updates Log in Project/Shell

The Business Process Updates log in Project/Shell allows you to set up updates from a template to a record, at the Project/Shell level. The log consists of the following:

#### Menu
- File
- Edit
- View
- Help

#### Toolbar
- New
- Cancel Request
- Open
- Find
- View Details

**Note:** These options can be accessed through the Business Process Updates log window menu options.

#### Columns
- Name
- Source Business Process
- Source Business Process Record
The functions of the elements in the Business Process Updates log are explained in the proceeding sections.

### Project/Shells and Preventive Maintenance Type BP

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create Work Order BP records for assets at periodic intervals according to the service needs of the asset.

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive Maintenance Book) in order to view all the Work Order BP records for that Preventive Maintenance type BP (Preventive Maintenance Book).

The Business Process Updates log in **Project/Shell** allows you to set up updates from a PM Book Template to a PM Book record, at the **Project/Shell** level.

See the *Company Workspace and Preventive Maintenance Type BP* (on page 424) section for details.
Setting Up the Asset Manager

About the Asset Manager

The Asset Manager module is part of the company workspace. It is used to manage assets and depreciation. This manager allows users to track assets and depreciation on their associated asset sheets. It allows users to enter company assets, set up depreciation schedules for them, and classify them into categories to make managing them more efficient. Ultimately, users can gather these assets onto a sheet to track asset depreciation in monthly, quarterly, or yearly increments.

The Asset Manager uses four depreciation methods: straight line, double decline, sum of year digits, and manual depreciation. For each method, asset depreciation is calculated for the entire life of the asset over a specified period. For example, if an asset is depreciating over two years and you specify a monthly depreciation increment, then the asset’s value is recalculated each month for two years from the date of acquisition.

The Asset Manager allows you to:

- Create, organize, and manage company assets
- Define an unlimited number of asset classes, and design an asset attribute form per asset class
- Create assets: manual, templates, or import
- Apply multiple asset depreciation methods: straight line, double decline, sum of years digits, manual
- Track an asset’s total cost of ownership (roll up maintenance-related costs from projects or company-level BPs to specific company account codes)

The Asset Manager does not directly use business processes; rather, it uses attribute forms to create asset classes and detail forms to create the assets themselves. In Unifier, an asset class maps assets to company account codes, tracks asset costs and depreciation, and keeps the company account sheet updated with current asset values. In addition, the manager uses reference processes to extract the asset’s acquisition cost from a company-level BP.

In User Mode, the Asset Management node lists the names of every class. These nodes are where users create and modify new assets, set up their depreciation schedules, and refresh assets to recalculate their values and update the asset class sheet and the company account sheet.

Asset Sheets: You can track assets and depreciation on asset sheets. There is one asset sheet per class, listing details about each asset in that class, plus an asset summary sheet, which helps you track all of your assets in one place.

Asset Classes: Assets are grouped in classes (for example, buildings, equipment, etc.). The detail forms that are used to enter asset information can be configured in uDesigner, per class. For example, you can design and use different forms for entering information about your company’s building assets and equipment assets. Each asset exists as a unique record.
**Asset Codes:** Asset codes are generated automatically when assets are created. The asset code will be built using different data elements defined on the asset form as segments. At runtime, the asset code is built automatically based on the data element values selected. A tree structure is automatically built to access these assets based on the asset codes. Assets with the same segment values will be grouped together to form a hierarchy.

**Note:** User permissions are granted per asset class or sheet. If you cannot view any part of the Asset Manager to which you require access, contact your company administrator.

---

**Setting up the Asset Manager**

Asset class forms must be designed in uDesigner. An asset class is a way to group assets of a similar type together. Examples of asset classes are buildings, vehicles, computer equipment, etc. Asset class forms are used to create new assets within each asset class, with a different form for different classes. The classes, forms, and corresponding logs are designed in uDesigner.

**Step 1:** Design the asset classes and forms in uDesigner and deploy them into Unifier.

**Step 2:** Configure and activate each class. This enables assets and asset sheets to be created for the class. It also enables projects to be associated with assets by creating asset categories for project creation.

**Step 3:** Grant template administration permissions.

**Step 4:** Create asset templates. These can be used to create assets under an asset class in User Mode.

**Step 5:** Set up a depreciation schedule in an asset template or in individual company assets.

**Step 6:** Create assets under asset classes in User Mode. You can create assets manually or by copying a template. If you did not set up the depreciation schedule in a template, you can do it per asset (Step 5).

**Step 7:** Set up the asset sheets. Asset sheets are maintained in User Mode.

---

**In This Section**

- Importing Asset Classes ................................................................. 431
- Configuring the Asset Manager ...................................................... 431
- Asset Manager Production Bundle Configuration .......................... 432
- Grant asset class template permissions ....................................... 432
- Creating and Managing Asset Templates ...................................... 432
- Creating a Depreciation Schedule ................................................. 434
- Setting up and Managing Asset Sheets ........................................ 440
- Managing Asset Sheet Properties ............................................... 444
- Map asset sheet columns to company account codes .................. 446
- Associating Projects with Asset Classes ..................................... 447
Importing Asset Classes

All designs, including asset classes, are designed in uDesigner and deployed to Unifier. See the instructions in the topic *Importing and Deploying a Design* (on page 273).

Configuring the Asset Manager

Once an asset class has been imported, it must be configured and activated to create assets. Asset classes are listed in the Asset Manager configuration log automatically after importing, with a default status of inactive.

**To configure an asset class**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) In the left Navigator, click **Configuration > Asset Manager**. The Asset Manager log opens. Any asset classes that have been designed in uDesigner will be listed in the log.

3) Select an asset class record from the log window and click **Open**. The asset class window opens.

4) Complete the **General** tab as described in the following table.

5) In the **Custom Print** tab, utilizing MS Word’s XML schema, you can create a customized printed output. This is similar to creating custom-designed BP print layout as explained in the Create Custom-Designed BP Print Layout (Custom Print tab) section.

6) To make the asset class active, click **Active** for the status. This will enable assets and asset sheets to be created in User Mode. The asset class is also available to use as a project category.

7) Click **OK**.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequence Format</td>
<td>Define the sequence used to create record numbers for new assets created for this class in User Mode. This is similar to business process numbering. Each time a new asset is created under this asset class, this sequence format will be used. Note: A sequence format change will not take affect once an asset is created under an asset class.</td>
</tr>
<tr>
<td>Help File</td>
<td>You can upload a PDF file as a help file for the Asset Manager. This file will be available from the asset class log window and individual asset record.</td>
</tr>
<tr>
<td>Auto Creator</td>
<td>Specify the auto-creator.</td>
</tr>
<tr>
<td>Status</td>
<td>Active or Inactive. Activating the configuration will make the class available in User Mode and Administration Mode to create assets, asset sheets, and asset templates. It also makes the asset class available as a project category in which to create projects that are associated with the assets.</td>
</tr>
</tbody>
</table>
Asset Manager Production Bundle Configuration

The following configurations can be included in the Asset Manager Production Bundle:

- General setup (in General tab)
  - All the fields included in the General Configuration (General tab).
- Custom Print
  - Word and PDF templates, if any.
- BIP Custom Print
  - All the BIP Custom Print in the Custom Prints and Reports.

For more information, see the *Production Bundles* (on page 197) section in this guide.

Grant asset class template permissions

Once you have activated an asset class configuration, you can create asset class templates that can be used to quickly create assets within the class.

When you activate a new asset class in the configuration window, you must grant permission (to yourself, another administrator, or a group such as company administrators) to administer asset class templates and create assets in user mode.

Creating and Managing Asset Templates

You can create one or more asset class templates that can be used to create assets within the class.

To access asset class templates

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Assets** in the left Navigator and select the asset class for which you want to create a template. The templates log for the class opens. The log lists any templates that have been created for the asset class.

   The columns that appear on the log will depend on the asset class design. The design controls the appearance of the asset form, the log, and which fields you can search on using the Find button. This is true for templates as well as assets created in User Mode.

To search for an asset template

In the asset template log, click the **Find** button. You can search for the template based on fields available on the asset form used for the template. These fields will vary depending upon the design for your company.

Create an asset template

The following describes how to create a new asset template manually.
To manually create an asset template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, select the asset class under **Templates > Assets**. The templates log for the class displays.
3) Click the **New** button. The Create New asset form opens.
   This form is similar to a non-workflow business process form. The form has two sections:
   - **General**: In the upper portion of the form, enter all the details about the asset. The fields on this form depend on the asset class attribute form design.
   - **Standard** tab: You can choose to define the depreciation schedule in a template. *Creating a Depreciation Schedule* (on page 434). Setting up the depreciation schedule is optional and can be defined in User Mode for each asset. Before you can set up a depreciation schedule, you must first save the form.
4) Click **Save** to save changes to the upper form, or **Finish Editing** to save and close the form.

Create a new template from an existing template or asset

You can create a template by copying an existing asset or a template from the same class.

To copy an existing template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Assets** in the left Navigator and select the asset class for which you want to create a template. The templates log for the class opens.
3) Select an asset class template from the log and click **Copy > Template**. The form opens with the information from the original template.
4) Make changes as needed and click **Finish Editing** to save the new template.

To copy an asset

1) Select **Copy > Asset**. The Copy from Asset window opens. Assets from the same class are displayed in this list.
2) Select an asset and click **Copy** to create a template. You can click **Find** to search for an asset by name.

To edit an asset template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Assets** in the left Navigator and select the asset class under which the template resides. The templates log for the class opens.
3) Select the template and click the **Open** button. The asset class form opens.
   **Note**: If you previously clicked the **Finish Editing** button for the form, you can make it editable again by clicking the **Edit** button at the top of the form.
4) To edit the depreciation schedule, click the **Depreciation Setup** button.
To delete an asset template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Assets** in the left Navigator and select the asset class under which the template resides. The templates log for the class opens.
3) Select the template and click the **Delete** button. Click **Yes** to confirm.

Creating a Depreciation Schedule

Each asset can be depreciated based on the depreciation definition associated with it. Depreciation of an asset will be based on acquisition cost, acquisition date, salvage value, etc. The Asset Manager will perform these calculations for each asset and update the asset form. These calculations can be shown on the asset class sheet and asset summary sheet, and can be optionally rolled up to the company accounts sheet.

**Note:** Before you can create a depreciation schedule for an asset, you must populate the data set for the SYS Depreciation Name data definition. To do this, use the instructions under *Adding and Managing Data Sets* (on page 77).

Depreciation calculation for an asset will be based on the selected method. The following methods are available:

- Straight line method
- Double decline method
- Sum of year digits
- Manual

Regardless of which method is used, depreciation for an asset will be calculated from the specified asset acquisition date to the end of the depreciation period.

These are the input parameters to calculate depreciation:

- Acquisition date
- Acquisition cost
- Salvage value
- Depreciation period
- Factor% (only for double decline method)
- Timescale units

Depreciation output values:

<table>
<thead>
<tr>
<th>Output Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Net book value</td>
<td>Book value of an asset as of a particular period</td>
</tr>
<tr>
<td>Cumulative depreciation</td>
<td>Accumulated depreciation cost of an asset over a period of time</td>
</tr>
<tr>
<td>Current period depreciation</td>
<td>Depreciation cost of an asset for a particular period</td>
</tr>
</tbody>
</table>
**Straight line method**

This method is the simplest of all depreciation methods. Depreciation for each time period (timescale units) will be calculated by dividing acquisition cost by depreciation period. If asset has salvage value, it should be considered while calculating depreciation.

**Without Salvage**

<table>
<thead>
<tr>
<th>Timescale Units</th>
<th>Formula to Calculate Depreciation per Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly</td>
<td>Acquisition Cost / (Depreciation Period * 12)</td>
</tr>
<tr>
<td>Quarterly</td>
<td>Acquisition Cost / (Depreciation Period * 4)</td>
</tr>
<tr>
<td>Yearly</td>
<td>Acquisition Cost / (Depreciation Period * 1)</td>
</tr>
</tbody>
</table>

**With Salvage**

<table>
<thead>
<tr>
<th>Timescale Units</th>
<th>Formula to Calculate Depreciation per Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monthly</td>
<td>(Acquisition Cost – Salvage Value) / (Depreciation Period * 12)</td>
</tr>
<tr>
<td>Quarterly</td>
<td>(Acquisition Cost – Salvage Value) / (Depreciation Period * 4)</td>
</tr>
<tr>
<td>Yearly</td>
<td>(Acquisition Cost – Salvage Value) / (Depreciation Period * 1)</td>
</tr>
</tbody>
</table>

Net Book Value = Starting Book Value – Current Period Depreciation

Starting Book Value = Net Book Value of Previous Period

Starting Book Value of First Period = Acquisition Cost

**Example**

An asset with an original cost of $3,000 is depreciated yearly over three years beginning January 1, 2006, using the straight line method with no salvage value.

- Depreciation beginning January 1, 2006 means that the acquisition date is 12/31/2006. This can be the purchase date of an asset or when the asset was put into service.
- The asset form is updated with current period depreciation, net book value, and cumulative depreciation periodically based on timescale units. If the timescale units are years, these data elements on the asset detail form should be updated every year with the calculated values displayed on the depreciation sheet. In this example, the asset detail form will be updated every January.

The depreciation table would look like this:

<table>
<thead>
<tr>
<th>Period</th>
<th>Starting Book Value</th>
<th>Current Period Depreciation</th>
<th>Net Book Value</th>
<th>Cumulative Depreciation</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/31/2006</td>
<td>3000 (Acquisition)</td>
<td>1000</td>
<td>2000 (3000-2000)</td>
<td>1000</td>
</tr>
</tbody>
</table>
### Double decline method

This method allows depreciation of an asset at an accelerated pace. The following formula is used while calculating depreciation per period.

\[
\text{Current Period Depreciation} = \text{Net Book Value of Previous Period} \times \text{Factor} \times \left(\frac{1}{n}\right)
\]

Net Book Value = Starting Book Value – Current Period Depreciation

Starting Book Value = Net Book Value of Previous Period

- Starting Book Value of First Period = Acquisition Cost
- Factor = Value entered while defining the depreciation definition (enter a percentage value, usually 200% or 150%)
- \(n\) = Number of depreciation periods

Salvage value is not considered while calculating depreciation for each period. But the acquisition cost – accumulated depreciation value should not go below the salvage value. For any depreciation period, if the acquisition cost – accumulated depreciation value goes below the salvage value, the depreciation for that period should be reduced so that the total value of the asset does not go below the salvage value.

**Example**

An asset value is $140,000. It will be depreciated over five years, and the factor entered is 200%. The depreciation rate for this method is 200% \(\times\) \(\frac{1}{5}\) = 40%.

The first period calculation is 140,000 \(\times\) 40% = 56,000.

### Sum of year digits

The following formula is used for this method:

\[
\text{Current Period Depreciation} = (\text{Cost} - \text{Salvage Value}) \times [\text{Factor}]
\]

The calculation factor depends upon the depreciation period and will change for each period based on the following formula, where \(n\) is the number of depreciation periods:

- Fraction for first year = \(\frac{n}{1+2+3+4+5+\ldots+n}\)
- Fraction for second year = \(\frac{(n-1)}{1+2+3+\ldots+n}\)
- Fraction for third year = \(\frac{(n-2)}{1+2+3+\ldots+n}\)
Manual

With the manual method, you enter the current depreciation value for each period on the depreciation sheet. The net book value and cumulative depreciation are calculated automatically based on the depreciation value. Depreciation is calculated for each time period and displayed on the depreciation sheet. Once the depreciation calculation sheet is updated, the asset detail form is updated.

Example

An asset with an original cost of $3,000 is depreciated yearly over three years beginning January 1, 2006. The salvage value is $500.

The initial depreciation sheet shows the following:

<table>
<thead>
<tr>
<th>Period</th>
<th>Current Period Depreciation</th>
<th>Net Book Value</th>
<th>Cumulative Depreciation</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/31/2006</td>
<td>0</td>
<td>3000</td>
<td>0</td>
</tr>
<tr>
<td>12/31/2007</td>
<td>0</td>
<td>3000</td>
<td>0</td>
</tr>
<tr>
<td>12/31/2008</td>
<td>0</td>
<td>3000</td>
<td>0</td>
</tr>
</tbody>
</table>

Net book value and cumulative depreciation are calculated, read-only fields.

Enter the depreciation amounts for each period. The net book value and cumulative depreciation are calculated as follows:

<table>
<thead>
<tr>
<th>Period</th>
<th>Current Period Depreciation</th>
<th>Net Book Value</th>
<th>Cumulative Depreciation</th>
</tr>
</thead>
<tbody>
<tr>
<td>12/31/2006</td>
<td>500</td>
<td>2500</td>
<td>500</td>
</tr>
<tr>
<td>12/31/2007</td>
<td>1000</td>
<td>1500</td>
<td>1500</td>
</tr>
<tr>
<td>12/31/2008</td>
<td>1000</td>
<td>500</td>
<td>2500</td>
</tr>
</tbody>
</table>

Set up a depreciation schedule

You can set up the depreciation of an asset template after the general information has been completed, and you have clicked the Save or Finish Editing button. This is optional in a template.

Depreciation schedule columns are predefined. Columns are populated based on the depreciation calculation. Below is a sample depreciation schedule.
To set up depreciation

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Asset Manager in the left Navigator and select the asset class. The asset log for the class opens.
3) Click the Open button. The asset class form opens.
   If you previously clicked the Finish Editing button for the form, you can make it editable again by clicking the Edit button at the top of the form.
4) Click the Depreciation Setup button. The Depreciation Setup window opens.
5) Add a row by clicking the Add Row button.
6) Complete the information for the depreciation setup as described in the table below.
7) Click OK to save and exit the window.
8) When the asset template is complete, click Finish Editing.
**In this field:** | **Do this:**
---|---
Default | Choose one of the depreciation methods to use as a default for the assets that are created based on this template. This is optional.
Name (required) | Select from the drop-down list. The list is managed in the depreciation data source data definition.
Depreciation Method (required) | This drop-down lists the following depreciation methods:
- Straight line method
- Double decline method
- Sum of years digits
- Manual
Timescale Units (required) | This value determines the frequency of asset depreciation:
- **Months:** Asset will be depreciated every month
- **Quarters:** Depreciate asset quarterly
- **Years:** Depreciate asset yearly
Factor% | This is required for the double decline depreciation method. It is the value entered while defining the depreciation definition. Enter a percentage value, usually 200% or 150%.

**Verify the depreciation data source list**

The list of available depreciation data sources is managed in the depreciation data source data definition data set. Below is a sample depreciation data source list.
Setting up and Managing Asset Sheets

Asset sheets are created automatically when asset classes are imported and activated. Asset sheets are listed in the Asset Sheet log window in the User Mode Asset Manager. There is one sheet per asset class, plus an asset summary sheet that summarizes all asset sheets. Assets are added to asset sheets as rows automatically, listed by the segmented asset code. In the asset summary sheet, the rows are the asset classes.

The asset summary sheet displays information of all asset sheets. It displays total values from individual asset class sheets. The asset summary sheet is created automatically once the first asset class is imported. Asset classes imported into Unifier are automatically added as rows.

Columns can be added to asset sheets. Some examples of columns include:

- To capture data from the asset form.
- Business processes—Company-level BPs with line items with asset code subtype are available; only the Amount field is available.
- Project cost columns—Most columns from project cost sheets are available; only the Amount field is available. This is available when projects are created under asset categories.
- Manual entry or formula columns

Users with create permission on asset class sheets will be allowed to create and define columns.

Create an asset sheet column

Columns can be added to asset sheets. These columns can be used to capture data from the asset form, business processes, or manually entered data on the sheet. Users with create permission on asset class sheets are allowed to create and define columns.

To create a new asset sheet column

1) In the asset sheet, click the Columns button in the menu bar. The Asset Sheet Columns Log opens.

2) In the menu bar click New. The Column Properties window opens. Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The Name field is populated with the data source value selected.</td>
</tr>
<tr>
<td>Datasource</td>
<td>Select a data source. The drop-down list lists the data elements found on the asset class form. This list also shows data elements based on SYS Numeric Logical Datasource, Sys Date Logical Datasource, Sys Business Process Datasource, and Sys Project Cost Datasource data definitions. Data sources of type SYS Numeric Logical Datasource, SYS Date Logical Datasource, Sys Business Process Datasource, and Sys Project Cost Datasource can only be used once. Examples include: Business processes: Company-level BPs with line items with</td>
</tr>
</tbody>
</table>
### Entry Method
Choose one of the following data-entry methods to use for the column. The available choices vary depending on the data source selected. Options include:
- **Manual entry:** User enters data directly into the cell, or data is rolled up from another source, such as the asset form.
- **Formula:** Options are Numeric, Date Difference, and Date Add.
- **Data Type:** This option is applicable if the data source is SYS Business Process, a business process or information from the project cost sheet. After selecting the data type, click **Define** to choose the data element or define a formula based on the data element.

### Date Format
Specify how you want the column data to appear. This is applicable to numeric columns. Options are:
- **Show as Percentage:** Data entered in a column will display in percentage format. For example, if a user enters 0.25, it will display as 25%.
- **Decimal Places:** Select the number of decimal places to display.
- **Use 1000 Separator (,):** Data entered is formatted with a separator; for example, 1,000, not 1000.
- **Negative Number Format:** Select how negative values will be displayed on the sheet: with a negative sign or in parentheses.

### Display Mode
Select **Hide** to make the column invisible to users, or **Show** to display it.

### Total
This controls what displays in the bottom summary row for each column:
- **Blank:** Summary row will remain blank.
- **Sum of All Rows:** Displays the sum total of all row values for this column.
- **User Formula Definition:** Formula entered in the Formula field will apply to the summary row.

### Column Position After
Select a column from the list. This determines the position of the column on the sheet.

---

**To copy a column**

1. In the Column log, select a column and click **Copy**. The Column Properties window opens.
2. Make changes as necessary for the new column. You must change at least the data source.
Add a column for business process data

You can add a column that captures data from a selected business process. The business process must be company level of type line items with asset code.

You can roll up data directly from the business process or create a formula for the column based on the data.

To add a column for business process data
1) Open the Asset Sheet to which you want to add a column.
2) Click the Column button, located in the sheet tool bar.
3) In the Column Properties window, choose a data source of type Sys Business Process.
   This allows you to link the column to a company-level business process of type line items with asset code.
4) For the entry method, choose Data Type and click the Define button. The Define Data Type window opens. The window is similar to a formula window.
5) Click the Select button and select a business process from the list. The list includes only company-level BPs with the line items with asset code subtype. Only the Amount field is available. You can optionally use the field to define a formula.
6) Click OK. Save the column definition.

Add a column for project cost data

You can add a column that captures data from a project cost sheet, allowing you to link assets with project cost data. You can roll up data directly from the project cost sheet or create a formula for the column based on the data.

To add a project cost data column
1) Create a new column.
2) In the Column Properties window, choose a data source of type SYS Project Cost.
3) For the entry method, choose Data Type and click the Define button. The Define Data Type window opens. The window is similar to a formula window.
4) Click the Select button and select from the list. The list includes data sources that are available while defining a project cost sheet, such as an assigned budget, revised budget, all cost business processes, and project cost 1 to project cost 25. Only the Amount field is available. Data from the project will be rolled up to an asset class sheet in the base currency. You can optionally use the field to define a formula.
5) Click OK. Save the column definition.

Add a formula column

You can add a formula column to the sheet for data sources that are based on either the data definitions SYS Numeric Logical Datasource or SYS Date Logical Datasource.

You can define formulas for the following types:

- **Numeric**: This option is available if the data source is SYS Numeric Logical.
Data Difference: This option is available if the data source is SYS Numeric Logical. It is used for formulas that calculate the difference between two dates.

Date Add: This option is available if the data source is SYS Date Logical. It can be used to add values to a date to calculate a new date.

To create a numeric formula
1) In the column Properties window, choose Formula and select Numeric.
2) Click Create. The Create Formula window for numeric formulas opens.
3) Select either Item or Sheet from the data type drop-down list. Item lists data elements that are defined on the form. Sheet lists columns that are already defined on sheet.
4) Build a formula by doing the following:
   - To include a data source in the formula, select the data source from the list and click Select.
   - Click a mathematical modifier (plus, minus, and so on) and numbers on the keypad.
5) When the formula is complete, click OK.

To create a date difference formula
1) In the column Properties window, choose Formula and choose Data Difference. Click Create. The Date Difference window opens.
2) For Earlier Date and Later Date, click Select. Select a data element. The list includes date type data elements from the form or existing date type columns on the sheet.
3) Choose one of the following:
   - Calculations based on Calendar Days: The calculation is based on calendar days and does not take company non-working days into account.
   - Calculations based on Work Days: The calculation is based on the company calendar working and non-working days.
   - Show Partial Day
4) Click OK.

To create a date add formula
1) In the column Properties window, choose Formula and choose Data Add. Click Create. The Date Add window opens.
2) For the Date field, click Select and choose a data element from the list.
3) For the Add field, click Select and choose a data element from the list.
4) Choose one of the following:
   - Calculations based on Calendar Days: The calculation is based on calendar days and does not take company non-working days into account.
   - Calculations based on Work Days: The calculation is based on the company calendar working and non-working days.
5) Click OK.
**Create an asset summary sheet column**

You can add columns to the asset summary sheet to display information from individual asset sheets. Available data types are the columns on the asset summary sheet.

**Edit asset details from the asset sheet**

You can edit asset detail information directly from the asset sheet, without having to open the asset form.

- Modify data elements from the asset when defining columns.
- Data elements are editable from the asset class sheet.
- Changes made to elements from the sheet will be reflected on the asset detail form automatically.
- Data elements that are editable and not required are editable from the sheet.
- Conditions under which a data source is not editable from a sheet object include:
  - All pickers except the Date picker
  - Data elements that are of SYS Logical Datasource formulas
  - Data elements that are SYS Business Process Datasource and SYS Project Cost Datasource

**Managing Asset Sheet Properties**

The Properties window for the asset sheet maintains the name and display options. You can also track asset value by associating a column on an asset sheet with a company account code. The company accounts sheet must be defined and account codes created before you can perform this mapping.

**To open the asset summary sheet Properties window**

1) In the Asset Sheets log, select the asset summary sheet and click the **Properties** button.
2) Complete the **General** tab as described in the following table.
3) In the **Options** tab, asset sheet columns can be mapped to company account codes. The total value of the column will roll up to the company accounts sheet.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>This is the name of the asset sheet, which reflects the class name and is read only.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Display Mode</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td><strong>Tree:</strong> Lists the asset codes in a hierarchical manner based on the code segments and mimicking the tree structure in the Navigator.</td>
</tr>
<tr>
<td></td>
<td><strong>Flat:</strong> Lists the codes in a flat structure.</td>
</tr>
<tr>
<td>Include</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td><strong>All Assets:</strong> All asset records created in the class will be displayed on the sheet</td>
</tr>
</tbody>
</table>
Assets with statuses: Click Select and choose one or more statuses from the list. Only assets with one of the selected statuses will be displayed on the sheet.

Map asset sheet columns to company account codes

You can track asset value by associating a column on an asset sheet with a company account code. The company accounts sheet must be defined, and account codes must be created before you can perform this mapping.

Notes:
- You can map an asset sheet column to more than one account code. For example, Column A can be mapped to both Account Code X and Account Code Y. This means that the total will display for both account codes in that column. However, each account code can be mapped only once. Account Codes X and Y cannot be mapped to any other columns; that is, you cannot map two columns of an asset sheet to a single account code.
- If you remove a column from the asset sheet that is associated with an account code, the mapping will be lost.

Once mapping is done, data from the asset sheet is rolled up to the accounts sheet under the Assets data source, which can be used to define an accounts sheet column. Only the total value will be rolled up.

Whenever there is change to an asset sheet column, that column data (total value) will roll up to the accounts sheet based on the mapping.

Following are the triggering conditions under which data is rolled up to the accounts sheet:
- When a column is mapped to an accounts sheet after the Properties window of the asset sheet is saved.
- When a column mapping is changed or removed on the asset sheet properties window.
- When a column in the asset sheet gets updated due to changes in the asset or asset sheet.

Note: The process used to update the accounts sheet with mapped asset sheet data runs in the background. After mapping an asset column to the accounts sheet or updating the asset sheet data, the change may not be reflected in the accounts sheet immediately.

To map an asset sheet column to a company account code

1) In User mode, go to the Company Workspace tab and open the Asset Sheets log in the left Navigator, select an asset sheet, and click the Properties button. The Properties window opens.
2) Click the **Options** tab, then click the **Add** button. The Add Mapping window opens.

![Add Mapping window](image)

3) Use the table below to complete the fields in this window.

4) Click **OK**.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>The drop-down list lists all columns that are defined on the asset sheet. Select the column you want to map to the account sheet.</td>
</tr>
<tr>
<td>Account Code</td>
<td>Click <strong>Select</strong>. A picker window opens displaying active codes from the accounts sheet. Select a code and click <strong>Open</strong>.</td>
</tr>
<tr>
<td>Account Name</td>
<td>This field is populated with the name of the account code chosen in the previous field.</td>
</tr>
</tbody>
</table>

**To modify or remove mapping**

Select a row and click **Modify** to edit mapping, or **Remove** to remove mapping. You cannot map two columns of an asset sheet to a single account code.

**Associating Projects with Asset Classes**

You can associate one or more projects with an asset. This allows you to manage assets using projects with full project functionality (cost sheet, business processes, etc.).

The asset class is added to the list of available categories that can be used to organize projects. By default, the new asset class categories are inactive. You must activate them to use them.

**To associate a project to an asset class:**

- Activate the asset classes as project categories. This enables projects or project templates to be created under the asset category.
- Create a new project or project template under the asset. Creating a project under the new asset category allows you to associate a project with an asset. You cannot associate an existing project to an asset.

**To activate asset classes and use them as project categories**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, click Configuration > Shell Manager.
3) Select Projects (Standard) and click the Open > General button. The Configuration Projects (Standard) window opens.
4) Click the Organize tab.
5) Select the asset class on the list and click the Active button. The asset class can now be associated with a project.
6) Click OK. Click Yes to confirm.
7) Click OK to save and exit the Edit Company window.

**Note:** You must grant user permission to yourself or other users or groups to view the new category.

**To create a new project under an asset**
1) Go to the Company Workspace tab and switch to Admin mode.
2) Select the asset class category under one of the following in the left Navigator:
   - Templates > Projects (Standard)> project >Asset Manager > [asset class category]
   - Company Sponsored Projects > project >Asset Manager > [asset class category]
3) Create a new project or project template under the asset class category.
4) Complete the project or project template properties window.
   When created under an asset class, an Asset picker is preset on the General tab.
5) In the Asset field, click the Select button. The Assets window opens, listing the assets created under the asset class.
6) Select an asset from the list and click Open.
   Selecting an asset is not required for project templates, but is required when creating new projects. This selection cannot be edited. The asset is displayed in the Projects log.

**Note:** The Asset picker is not available on projects or templates that are not created under category nodes based on asset classes.
Setting Up Code-Based and Records-Based Configurable Manager

Configurable manager, as well as classes, forms, and corresponding logs are designed in uDesigner (Configurable Modules) and deployed to Unifier. You must also define the business processes that work with the configurable manager.

**Note:** Assign a specific name for the configurable manager in uDesigner. The generic term used in the instructions is configurable manager.

**Step 1:** Design code-based and records-based configurable manager in uDesigner (Configurable Modules).

**Step 2:** Setup the Business Process Data elements under the Options tab and deploy the manager. After the manager has been deployed, classes can be designed and deployed.

**Step 3** Set permissions.

**Step 4:** Configure the code and records-based manager.

**Step 5:** Set the template administration permissions.

**Step 6:** Create template sheets and add columns.

**Step 7:** Set permissions for the user.

---

**In This Section**

- Setting Permissions to Import Configurable Managers ................................................................. 449
- Importing Code and Records-Based Configurable Managers ......................................................... 450
- Setting Permissions to Import Classes ............................................................................................... 450
- Importing Classes for Code and Records-based Configurable Managers ........................................ 450
- Configure configurable manager classes .......................................................................................... 450
- Run an error check on a class ........................................................................................................... 451
- Configure a Data Picker for the manager ............................................................................................ 451
- Setting Template Administration Permissions .................................................................................... 453
- Creating Class Template Sheets ........................................................................................................ 453
- Setting User Permissions for Code and Records-Based Managers .................................................. 456

---

**Setting Permissions to Import Configurable Managers**

You must have modify permission under Access Control > Administration Mode Access > Data Structure Setup > Configurable Modules to import configurable managers. You can set view permissions to allow users to view configurable modules.
Importing Code and Records-Based Configurable Managers

All designs, including configurable managers, are designed in uDesigner and deployed to Unifier. See the instructions in the topic *Importing and Deploying a Design* (on page 273).

**Note**: Importing Forms that Contain Data Pickers: Data pickers point to a data source for the records they display. If that data source—the BP, shell, or manager class—to which the picker is pointing is not already in Unifier, you will receive a warning. The business process will not operate correctly until the data source is imported.

Setting Permissions to Import Classes

Classes must be deployed before you can set permissions. Set permissions based on existing permissions for the Company > uDesigner.

Importing Classes for Code and Records-based Configurable Managers

To import a class into Unifier production, see the instructions in the topic *Importing and Deploying a Design* (on page 273).

Configure configurable manager classes

Imported configurable manager classes are listed in the manager configuration log, with a default status of inactive.

**To configure a configurable manager class**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Configuration > [configurable manager]** in the left Navigator. The Configurable Manager log opens. The log lists the classes.
3) Select a class record from the log window and click **Open**. The Configuration window opens.
4) Complete the **General** tab as described in the table below.
5) On the **Custom Print** tab, using MS Word’s XML schema, you can create a customized printed output (similar to *Create Custom-Designed BP Print Layout (Custom Print tab)* (on page 356)).
6) To make the class active, click **Active**. This enables classes and sheets to be created in User Mode. The class is also available to use as a project category or shell type.
7) Click **OK**.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequence Format</td>
<td>Define the sequence of the record numbers for records created for this class in User Mode. This is similar to business process numbering.</td>
</tr>
</tbody>
</table>
Help File | You can upload a PDF file to use as a help file for the manager.
---|---
Auto Creator | Select the auto-creator.
Status | Activating the configuration makes the class available in User Mode and Administration Mode for creating records, sheets, and templates.

### Run an error check on a class

To error-check imported classes:

1. Go to the **Company Workspace** tab and switch to **Admin** mode.
2. Click **uDesigner > [configurable manager]** in the left Navigator to open the Configurable Manager log.
3. Select one or more classes in the log. To select multiple classes, press the **Ctrl** key or **Shift** key while selecting the classes.
4. Click the **Error Check** button. After validation, the error check window opens, listing any errors that were found.
5. To fix the errors, make the changes in uDesigner.

### Configure a Data Picker for the manager

If your code-and-record-based manager includes a data picker or a user data picker, it must be configured to examine and extract the records that should appear on the picker list. To do this, you need to create a database query. (For more information on data pickers, see the *Unifier uDesigner User Guide*. And for more information on queries, see Queries.

Once you have set up the query or queries for a data picker, and the picker is active in Unifier, the queries will be launched whenever:

- The user clicks the data picker field on a form
- The business process is auto-created
- A record is created or updated through integration (both CSV and Web Services)
- The data picker is updated via reverse-auto-population

For more information on data pickers, see "About Data Pickers" and "About User Data Pickers" in the *Unifier uDesigner User Guide*.

In addition to setting up queries to extract records for the picker, you can configure the picker to filter the records that the query returns so that only certain records appear on the picker. This is particularly convenient, for example, if the manager attribute form contains a user data picker that automatically assigns users to an object as it is created.

**To configure a data picker**

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Configuration > [manager name]** in the left Navigator. The Configuration log opens.
3. Select a record and click **Open > Data Picker**. The Data Picker Configuration window opens.
4) In the left pane, click the name of the data picker.

5) Create the query.
   The query will search the database and extract the records to display on the data picker. The query will filter the records returned from the database according to a condition or conditions you specify. The condition(s) will "test" a field on the form to see if it passes or fails the criteria. If the field passes the criteria, Unifier will include it on the data picker.
   a. Click the Add button. Unifier displays the Add Query Condition window.
   b. In the Data Element field, select the field on the business process that you want to test with the condition.
      For example, the condition might be that the status field on the shell must be "Active."
      The window expands to show an active Condition field and additional fields where you can specify the query criteria.
      
      **Note:** If any field in the query or queries is subsequently removed from the configurable manager attribute form, the entire query operation will be ignored. That is, if one query fails because a field was removed from the design, Unifier will ignore all the queries. If a field has been removed from a design, you must amend the query.
   c. In the Condition field, select the condition the value in the field must meet.
      The remaining fields on this window vary, depending on the data element and the condition you specified. For help in completing these fields, see About Queries.
   d. Repeat steps a through c to include additional query conditions.

6) (Optional) Filter the returned records.
   This filtering option appears on configurable manager attribute forms that contain user data pickers. This option will filter the list of groups or users that appear on the picker. Use the instructions in the table below to filter the returned records.

7) When you have finished, click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter list of Users/Groups based on Project/Shell Membership</td>
<td>Select this checkbox if you want to filter the list of users on the picker to show only those with project or shell membership. In operation, Unifier will auto-populate and reverse-auto-populate the data picker with all users or groups, regardless of this checkbox. However, at runtime, Unifier will filter the picker for the user if you select this checkbox. <strong>Note:</strong> If you select this option, the rest of the filtering options will be disabled.</td>
</tr>
<tr>
<td>Group Membership</td>
<td>Select the group from which you want to specify a user or users. The drop-down list shows all the groups that are at the company level.</td>
</tr>
<tr>
<td>Project/Shell Membership</td>
<td>If you want Unifier to add these users to the shell membership, select the Add user to Project/Shell checkbox. If you want to also add these users to the group under the shell, select the Add user</td>
</tr>
</tbody>
</table>
**Setting Template Administration Permissions**

After you have configured a configurable manager, you can create templates to use with the manager.

When you activate a new class, you must grant permission to yourself, another administrator, or a group such as company administrators to administer class templates and create classes in User Mode.

You must have administrator permission granted under Access Control > Administration Mode Access > Data Structure Setup > Configurable Modules to administer configurable managers.

**Creating Class Template Sheets**

You can create one or more class templates for each class for each configurable manager.

**Create a class template**

You can create a new class template manually or by copying an existing template that is the same class as the new template.

**To manually create a class template**

1) In Administration Mode, go to the **Company Workspace** tab and click **Templates > Configurable Modules** in the left Navigator.

2) In the Navigator, select the configurable manager. The templates log for the classes opens.

3) Click the **New** button. Select the class for which you want to create the new template. The Properties window opens. Complete the window as described in the following table and then click **OK**.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter the name of the sheet, which reflects the class name and is read only.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
</tbody>
</table>
| Display Mode  | Choose one of the following:  
- **Tree**: Lists the codes in a hierarchical manner based on the code segments, mimicking the tree structure in the Navigator.  
- **Flat**: Lists the codes in a flat structure. |
| Picker        | Choose one of the following to include:  
- **All Records**: All records created in the class are displayed on the as a member to the selected group checkbox

**Note**: To use this option, the user data picker must be on the upper form, not the detail form.
Records with statuses: Only records of the selected status are displayed on the sheet. Click Select and choose one or more statuses from the list.

To copy an existing template
1) To copy a template from the company level, select a class template from the log and click Copy > Template. The Properties window opens with the information from the original template.
2) To copy a template from the project or shell level, click Copy > Project or Copy > shell name.
3) Make changes as needed and click OK to save the new template.

To access configurable manager class templates
1) In Administration Mode, go to the Company Workspace tab and click Company > Templates > Configurable Modules.
2) In the Navigator, select the configurable manager. The templates log for the classes opens.

To search for a class template
In the class template log, click Find. You can search for the template based on the fields available on the form used for the template. These fields vary depending on the design.

Add columns to sheet templates
You can add columns to configurable manager sheet templates. You can use these columns to capture data from business processes or manually entered data. You can add columns to the template, but cannot add rows.

Users with create permission on class sheets are allowed to create and define columns.

To add a sheet column
1) Open the sheet.
2) Click Columns. The Columns Log opens.
3) Click New. The Column Properties window opens. Complete the window as described in the following table.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The Name field is populated with the data source value selected. You can change this name as desired. It is helpful, but not required, to use a unique name.</td>
</tr>
<tr>
<td>Datasource</td>
<td>Select a data source. You can use a data source only once; however, you can use the column in a formula. For example, if one data source is Commits (Approved), and another is Change Commits (Approved), you can add them together in a new column called Total Commits (Approved).</td>
</tr>
</tbody>
</table>
### Entry Method
Choose the data-entry method to use for the column. The choices available depend on the data source selected. The options include:

- **Manual entry**: Users can enter data directly into the cell, or data is rolled up from another source, such as the form.
- **Formula**: The options are *Numeric*, *Date Difference*, and *Date Add*. See [Add a formula column](on page 442) for details on adding formula columns.
- **Data Type**: Applicable if the data source is SYS Business Process, a business process, or information from the project cost sheet. After selecting the data type, click **Define** to choose the data element or define a formula based on the data element.

### Data Format
Specify how you want the data in numeric columns to appear.

- **Show as Percentage**: Data displays as a percentage. For example, if a user enters 0.25, it displays as 25%.
- **Decimal Places**: Select the number of decimal places to display.

**Note**: If the data element was defined in uDesigner with a specific decimal amount, it will override any decimal amount you specify here.

- **Use 1000 Separator (,)**: Data uses a separator for thousands. For example, 1,000 with a comma, not 1000.
- **Negative Number Format**: Select whether negative values are displayed with a negative sign or in parentheses.

### Display Mode
Select **Hide** to make the column invisible to users, or **Show** to display it.

### Total
Controls what displays in the bottom summary row for each column:

- **Blank**: The summary row remains blank.
- **Sum of All Rows**: Displays the sum total of all row values for this column.
- **Use Formula Definition**: Use the formula entered in the Formula field.

### Column Position After
Determines the position of the column on the sheet. Select a column from the list.

---

**To copy a column**

1) In the Column log, select a column and click **Copy**. The Column Properties window opens.
2) Make changes as necessary for the new column. You must change at least the data source.

---

**Copy sheets under project or shell templates**

You can copy one sheet for each project or shell template.

**To copy a sheet under a project or shell template**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, click **Templates > Projects > All** or **Company > Templates > Shells > [shell]**.

3) To copy a template from the company level, select a class template from the log and click **Copy > Template**. The Properties window opens with the information from the original template.

4) To copy a template from the project or shell level, click **Copy > Project** or **Copy > shell**.

5) Make changes as needed and click **OK** to save the new template.

---

**Manage sheet properties**

The Properties window for the sheet maintains the name and display options.

**To open the summary sheet Properties window**

In the Configurable Manager Sheets log, select the sheet and click the **Properties** button.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>This is the name of the sheet, which reflects the class name and is read-only.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Class</td>
<td>Read-only field that displays the class associated with the sheet.</td>
</tr>
</tbody>
</table>
| Display Mode  | Choose one of the following:  
|               | **Tree**: Lists the codes in a hierarchical manner based on the code segments, mimicking the tree structure in the Navigator.  
|               | **Flat**: Lists the codes in a flat structure. |
| Picker        | Choose one of the following to include:  
|               | **All Records**: All records created in the class are displayed on the sheet.  
|               | **Records with statuses**: Only records of the selected status are displayed on the sheet. Click **Select** and choose one or more statuses from the list. |

---

**Setting User Permissions for Code and Records-Based Managers**

For users to be able to work with the configurable manager class sheet, you must set user permissions for the class sheet under **Access Control > User Mode Access > Company Workspace > configurable manager name > Class Sheets**.
Unifier Cost Manager consists of several modules designed to help you track and manage cost in projects, shells, programs, and across the company. Setup of the cost manager modules includes the following.

**In This Section**

- Cost Manager Overview ........................................................................................ 457
- Cost Managers and Unifier Functional Areas ........................................................ 460
- About Currencies and Exchange Rates ...................................................................... 460
- Setting up Cost Sheets .......................................................................................... 469
- Setting up a Company Accounts Sheet ................................................................. 500
- Setting up the Funding Manager ........................................................................... 505
- Setting Up Schedule of Values (SOV) ................................................................. 532
- Setting Up Cash Flow ............................................................................................ 537
- Setting up the Rules Engine .................................................................................. 552
- Setting up a Generic Cost Manager ....................................................................... 560

**Cost Manager Overview**

The Cost Manager consists of the modules and features listed below.

**Cost Sheets**

**Project/Shell cost sheet:** The project or shell cost sheet is a detailed accounting of the project’s or shell’s budget and costs. It works much like a spreadsheet within Unifier that calculates and maintains the project or shell cost information stored in the project or shell. The project or shell cost sheet rows contain unique WBS codes (or cost codes), which can be used to link project or shell or program costs to the general ledger for finance. Cost information can be entered manually, pulled from work packages or worksheets, or rolled up automatically from business processes when transactions occur in Unifier.

**Program cost sheet:** Program cost sheets are created automatically once a project cost sheet has been created in at least one project within the program. The columns of the program cost sheet can be set up to allow cost sheet data to roll up automatically from individual project cost sheets. The program cost sheet will display cost data for all projects within the program that have a status of active or on hold. The currency used is the company base currency. Projects on the program cost sheet are sorted automatically by ascending project number. As new projects are added to the program, and cost sheets are created for them, the new projects will be automatically added to the program cost sheet.
**Company cost sheet:** The company administrator can create a company-level cost sheet to display cost data across project or shells. Projects or shells on the company cost sheet are added by default as project- or shell-level cost sheets are created. Only active and on-hold projects or shells should be rolled up to a company-level cost sheet. Projects and shells are listed in order by project or shell number in an ascending order. Data rolls up to the company cost sheet columns from individual project or shell cost sheet columns by data source. The data displayed on the program cost sheet is view only.

**Work packages:** In addition to a project or shell cost sheet, multiple work packages may also be defined. A work package is a group of cost sheet rows that is a subset of the project or shell cost sheet. Work packages provide insight into the budget without providing full access to the details of the project or shell cost sheet.

**Worksheets:** Cost worksheets can be created to support the project or shell cost sheet. They can be used as sub-cost sheets, enabling specific calculations or data entry in a separate sheet, which can then be rolled up into a defined project or shell cost sheet column. For example, a worksheet can be used to offload complex calculations, which can be rolled up into a single cost sheet column. Worksheets support manual data entry and formulas. Business processes do not roll up to worksheets. Permissions can be controlled for individual worksheets. Worksheets are not independently reportable; however, cost sheet columns that reference worksheets can be reported on.

**Funding Manager**

**Company funding sheets:** The company funding sheet tracks all sources of funding across all projects or shells and programs. You create only one sheet per company. Funding sources that are made available at project or shell sheet level are rolled up to the company sheet, which maintains the overall fund information. Once created, the company funding sheet can be edited, but not deleted. The company funding sheet must be created before creating individual project or shell funding sheets.

**Project/Shell funding sheets:** The project or shell funding sheet tracks how funding is being allocated and consumed at the project or shell level. Project or shell fund sheets work in conjunction with the company funding sheet. Allocating funding sources at project or shell level can be done manually or through a business process. A funding template and company funding sheet must be complete before you can create a project or shell funding sheet.

**Commitment funding sheets:** You can optionally set up commitment level funding, which allows you to allocate specific project/shell funds to individual base commit records. This works in conjunction with the SOV sheet to track base and change commit lines and balances.

**Cash Flow**

Unifier advanced Cash Flow module includes the ability to create multiple baseline, spends, forecast and custom curves and compare them on one cash flow worksheet. You can create data source, distribution profiles, and cash flow curve templates to simplify creation of cash flow in multiple projects and shells. Administrators can also set up base commit business processes to automatically create cash flow curves for the commitment record at a particular workflow step, (or for non-workflow BPs, when the record is complete).
Earned Value
The earned value module provides quantitative tracking information about project or shell status using earned value analysis. It provides specific numerical measurements for reviewing progress as the project or shell team advances through the work tasks allotted to the project or shell schedule. The module helps project or shell managers track whether projects or shells are on schedule and on budget. It provides accurate and consistent methods to estimate the percent of budget spent, percent of work done, and percent of time elapsed.

Schedule of Values
The schedule of values (SOV) module provides a way to assemble information from contract, change order and invoice/payment business processes into an SOV sheet, streamlining the process of invoicing for completed phases of a project or shell. SOV functionality is available with uDesigner-created cost BPs for which the Allow creation of Schedule of Values option is defined. The business processes can be designed to create an SOV sheet automatically upon reaching the designated step.

The following are the SOV sheets types:
- General Spends
- Payment Applications
- Summary Payment Applications

Generic Cost Manager
The Generic Cost Manager captures cost-related activities for a generic shell. These include costs like rent, lease payments, landscape care, building maintenance and repair, remodel of building interiors, and more.

With this manager, you can capture and view cost transaction information based on a timescale, such as quarterly or yearly. Each shell can have one Generic Cost Manager. The Generic Cost Manager uses specific generic cost business processes as a data source.

About Cost Managers and Unifier functional areas
The standard Cost Manager and the Generic Cost Manager work with different areas of Unifier. This table lists the areas and indicates which cost manager works with each area.

<table>
<thead>
<tr>
<th>Cost Manager</th>
<th>Company</th>
<th>Program</th>
<th>Project (Standard)</th>
<th>Shell (WBS)</th>
<th>Shell (Generic)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Manager (standard WBS)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Generic Cost Manager</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

The cost data from Project (Standard) and Shell (WBS) can both roll up to the Company level. The cost data from Shell (Generic) does not roll up to Company Level.
Cost Managers and Unifier Functional Areas

The standard Cost Manager and the Generic Cost Manager work with different areas of Unifier. This table lists the areas and indicates which cost manager works with each area.

<table>
<thead>
<tr>
<th>Cost Manager</th>
<th>Company</th>
<th>Program</th>
<th>Project (Standard)</th>
<th>Shell (WBS)</th>
<th>Shell (Generic)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Manager (standard WBS)</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Generic Cost Manager</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

The cost data from Project (Standard) and Shell (WBS) can both roll up to the Company level. The cost data from Shell (Generic) does not roll up to Company Level.

About Currencies and Exchange Rates

Unifier cost management system supports multiple currencies and exchange rates. The functions Unifier uses are exchange rates sets, effective dates, future exchange rates, base currency, project currency, transaction currency, project/shell currency options, and currency pickers. What follows are descriptions of each of these functions and how they are used in Unifier.

Currencies

Standards & Libraries > Currencies: This is where a Unifier Administrator can manually add new company currencies to suit the company business needs, in addition to the predefined list of currencies. You need to have appropriate permission to access the Currencies sub-node.

You can see the Currencies node in the Permission tab of the User properties: Company Workspace > Access Control > Administration Mode Access > Currencies.

A Unifier Administrator can setup both users and Groups permissions to the Currencies sub-node. There are three types of permissions allowed: Create, Modify, and View.

- A user that has the "Create" permission, can add, modify, and view currencies.
- A user that has the "Modify" permission, can modify and view currencies.
- A user that has the "View" permission, can view currencies.

The log for Currencies sub-node has the following elements:

Toolbar options
- New: to add new currencies
- Open: to view and modify existing currencies in the log
- Delete: to delete the currencies in the log
- Find: to search for a specific currency

Menu bar options
- File > New, Open
Log columns

- Currency Name: Displays the Currency Name
- Currency Code: Displays the Currency code for the country
- Currency Symbol: Displays the Currency symbol for the currency
- Description: Description for Currency

The Currencies log has a list of predefined currencies. When you click Currencies, a predefined list of currencies displays in alphabetical order. In addition:

- Currency code is displayed for all the existing currencies.
- If currency symbols exist, the currency symbols are populated under the Currency symbol column.
- Users who have permissions can modify the predefined currencies.
- Description lists all the countries that use that currency.

To add new currencies:

1) Click New to open the Currency Details Window
2) Enter the Currency Name, Currency Code, Currency Symbol, and Description
   - Currency Name is a required field. Currency Name is a text field (maximum of 250 characters)
   - Currency Code is a required field. Currency Code is a text field (maximum of 8 characters)
   - Currency Symbol is an optional text field (maximum of 8 characters)
     - Single characters such as . , ( ) are not allowed
     - Characters such as | " \ are not allowed
     - Patterns such as $ $ & $ \ are not allowed
     Note: You cannot type just a comma as a currency symbol. Also, the Pipe character (|) and back slash (\) are not allowed in the Currency Name, Code and Symbol fields.
   - Description is an optional text field (maximum of 500 characters)
3) Click OK to save
4) Validate the new currency by ensuring that the:
   - Currency Name is unique and does not exist in the predefined list.
   - Currency Code is unique and does not exist in the predefined list.
   - Number of characters entered in the text field does not exceed the limit.

To view the details of an existing currency, click the currency and select open from the Menu bar.

You can modify the Currency Name, Currency Symbol, and Description after you have created a currency and defined the currency Exchange Rates. You cannot modify the Currency Code, once a currency is created.

To delete a currency, select the currency and click Delete.
You cannot delete a currency that has been used to define exchange rates.

Currency selected as Base Currency, at the time of creating the company, cannot be deleted.

To search in Currencies, use Find in the Currencies log view. The search parameters are Currency Code and Currency Name. The logical operators for both parameters are the following:

- contains
- does not contain
- equals
- does not equal

The Audits log displays the additions and modifications applied to currencies. Audits log allows you to select a record to see the audit information. The top part of the Audit log window displays the currency name, for example, Audit Log for: Australian Dollar (AUD).

The Currency List window, which you can see when you are defining the exchange rates, displays a list of currencies that you have defined in the Currencies sub-node. Fields in the Currency List window are Currency Name, Currency Code, Currency Symbol, and Description. The Description field includes the country name and if there are multiple countries that share the same Currency Name, the country names are listed and separated by a comma, for example, for Currency Name, Euro (EUR), the Description field lists: Andorra, Belgium, France, and so forth, in alphabetic order.

**Note:** If the currency name is modified, then existing exchange rate CSV template fails. You must export the exchange rate template again for the new currency name. The existing Web Services calls for record creations and updates fails if the currency names are modified.

Similar to other custom string translations the currency names can be translated for internationalization.

**Exchange Rates**

**Standards & Libraries > Exchange Rates:** This is where you can add currencies and define their exchange rates against the base currency, which was defined during company creation. You can add currencies, manage currency exchange rates, and set currency effective dates as needed. Each line in the Exchange Rates log is considered a set.

**Note:** In addition to the predefined list of currencies, a Unifier Administrator can add new company currencies to suit the company business needs.

Currency conversions use the exchange rate defined in the active Exchange Rates set. Until you modify a currency rate, Unifier uses the last active rate for that currency.

You can take the following actions to manage currencies:

- Create a New Exchange Rates set. You can make the set active today, or you can set the effective date to a future date.
Modify an existing Exchange Rates set that has a future effective date. You can modify rates in a set until it reaches the effective date. You can change the effective date to as soon as tomorrow, but you cannot change the effective date to today.

Set an Effective date: On the chosen date, at 12:00 am system date and time -- in your time zone -- the effective date becomes active.

For example:
- Your time zone is Munich, Germany (UTC + 1)
- April 20 you add a future exchange rate and set the effective date as May 1
- May 1 at 12:00 am the currency rate takes effect in Munich’s time zone
- April 30 at 3:00 pm the currency rate takes effect in Los Angeles’ time zone

View Exchange Rates

According to the date, it displays:
- Currency Name
- Currency Symbol
- 1.0 Base Currency
- Effective Date

Future currency exchange rates

Future exchange rates allow you to plan ahead for currency fluctuations. Unifier uses the active exchange rate based on the effective date; however, cash flow curves show currency rate changes at the beginning of the first full month the rate is in effect.

In the Baseline details example that follows, you can see differences in values due to future exchange rate conversions.

- The transaction currency is INR.
- The project currency is EUR.
- The distribution is linear.
- The distributed values are 37,000 INR per time period.
- May and June rates take effect on the first of the month, respectively.
- A July future exchange rate takes effect in Unifier on 07/02/2012, so Unifier continues to display the value of the June rate in the cash flow.
The August rate shows up in the cash flow curve on 08/01/2012.

<table>
<thead>
<tr>
<th>Baseline details</th>
<th>Project Currency: Euro (EUR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>Name</td>
</tr>
<tr>
<td>BCGS-0002</td>
<td>GS Contracts 2</td>
</tr>
</tbody>
</table>

**Base currency**

The currency the company creator selected as the default currency during company creation. Upon creation, the base currency is fixed and cannot be changed. The base currency becomes the default currency for projects and shells; however, the default currency can be changed during project or shell creation. Company-level cost data roll-ups can draw from multiple projects and shells. Each of these projects or shells can have a different project currency.

**Project currency**

A Project Currency is the currency that was selected as the project or shell-level default currency during project or shell creation. This can be different from the Base Currency, and you must take the following steps before you save the new project or shell.

- **First:** Before creating the new project or shell, verify that the non-base currency exists in the Exchange Rate Set.
  - If it does not, you can add it.
  - If the exchange rate effective date is in the future you cannot add it to the project or shell currency set.
- **Second:** During project/shell creation, add the non-base currency to the project or shell.
- **Third:** During project/shell creation, select the non-base currency as the project or shell default currency.

Unifier calculates and stores costs in the project currency. Business process records created in a non-project currency, such as a transaction currency, use the exchange rate that was active at the time of record creation for currency conversion to project currency.

**Project/shell currency options**

When adding a currency to a project or a shell, you have the options to float, hedge, or peg the currency rate. These options establish how to handle fluctuations in that currency’s market rate.

- **Float** - A currency’s value fluctuates according to the foreign exchange market. Unifier updates currency exchange rates according to the effective date of the Exchange Rate set.


- **Hedge** - Intended to reduce future risk of currency fluctuations.
- **Peg** - The currency exchange rate is fixed. Pegging impedes project currency conversion in a project or a shell.

Role rates changes due to currency exchange rate changes only consider Float and disregard Hedged or Pegged rates.

**Transaction currency**

This is a currency that was added to the project or shell Currencies, and picked at run time using a currency picker on the commitment business process. Upon record creation, Unifier uses the current active currency exchange rate in the Exchange Rate table to convert a transaction currency to the project currency.

Cash flow curves display data in the transaction currency, if different from the project currency. At run time, users can switch between currency views, but they can only modify values in the transaction currency view.

**Currency picker**

Currency pickers are available only for the upper form of a cost-type commitment business processes such a contract or a change order. This means all line items will be in the record, or transaction, currency.

---

**Managing currencies and exchange rates**

The exchange rate set defines the currencies that are available for use within the system and their corresponding exchange rates, which are based on the company base currency. The exchange rate set that is currently active in the system will display a status of Active. All previous sets are retained, so you can view the currencies and rates that were active in the system in the past. Future currency rates are also listed in the log.

**To view the company base currency**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) In the left Navigator, click **Standards & Libraries > Exchange Rates**. The Exchange Rates log opens, displaying the following information:
   - **Effective Date**: This is the date the base currency and its associated exchange rates became active. If you have not yet created an exchange rate set, there will be one default listed in the log, created by the Site Administrator.
   - **Base Currency**: This is the base currency used by the company.
   - **Created By**: This field identifies the user who created or modified the exchange rate set.
   - **Status**: The status indicates which set is active. Only one exchange rate set can be active at a time. View currencies and exchange rates (exchange rate set).

**To view an exchange rate set**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, click **Standards & Libraries > Exchange Rates**. The Exchange Rates log opens.
3) Select a set from the list and click **Open** (or double-click the selection). The Edit Currency window opens, displaying the list of available currencies and their exchange rates.

**Add a currency to the exchange rates**

To add additional currencies you must create a new exchange rate set. Existing exchange rate sets can be modified until the effective date is reached and that set becomes active. Old sets are inactivated and saved for archival purposes. You can add as many sets as you like, as long as each set uses a unique effective date.

**To add a currency to the exchange rate set**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) In the left Navigator, click **Standards & Libraries > Exchange Rates**. The Exchange Rates log opens.
3) Click **New**. The Edit Currency window opens. The window displays all currencies that were added in previous exchange rates sets.
   - The Base Currency field is fixed.
   - In the Effective Date field you can select a future effective date for any exchange rate in the exchange rate set.
4) Click **Add**. The Edit Exchange Rate window opens.
   - In the Currency Name field select a currency from the currency list.
   - In the Rate field, enter the exchange rate multiplier to convert the new rate to the company base rate. For example, if the base currency is United States Dollar (USD), and you are adding Euro (EUR), then the exchange rate is the number of EUR in $1 USD; that could look like 0.76 = $1, so in this case you would enter .76.
5) Click the date icon in the Effective Date field, and select the date this exchange rate set becomes effective.
   - If you do not select an effective date, Unifier uses 12:00 am local time (tomorrow morning) as the effective date.
   - If the effective date is in the future, the current exchange rate set remains active until the effective date of the new exchange rate set.
   - The future exchange rate set remains editable until the effective date is reached.
   - Before you save the exchange rate set, you can remove a currency that you just added. Once the exchange rate set is saved you cannot remove that currency and Unifier will carry forward that currency in any new currency exchange rate sets.
6) Click **OK** to save the exchange rate set.

**To modify an exchange rate**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) In the left Navigator, click **Standards & Libraries > Exchange Rates**. The Exchange Rates log opens.
3) Click **New**. The Edit Currency window opens.
4) Select a currency from the list and click **Modify**. The Edit Exchange Rate window opens.
5) Enter the new rate and click **OK**.
6) Enter the Effective Date. The effective date defaults to 12:00 am local time tomorrow morning.
If you want the rate to take effect immediately, you can enter today’s date.
You can enter a future effective date, and the current exchange rate set remains active until the effective date.
7) Click OK to save and exit the Edit Currency window.

To copy an exchange rate set
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates log opens.
3) Select an exchange rate set.
4) Click the Copy button. The Edit Currency window opens.
   From here you can:
   ▶ Add additional currencies.
   ▶ Modify exchange rates.
   ▶ Set an effective date for the exchange rate set.
5) Click OK to save and exit the Edit Currency window.

Importing and Exporting Exchange Rates
You can create and update exchange rates through a CSV file. For example, you can import the exchange rates you are using in your enterprise resource planning (ERP) system into Unifier so that the rates match in both systems.

You can import exchange rates with a CSV file by doing the following:
▶ Export a copy of the CSV file structure.
▶ Populate the CSV file with currency rate information.
▶ Import the CSV file into Unifier.

To export a copy of the CSV file structure
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates log opens.
3) Choose File > Export. A confirmation window opens. You export the active exchange rates. Do one of the following:
   ▶ Click Open to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   ▶ Click Save to save the file to your local drive. Enter a name for the file and click Save.

To populate the CSV file with exchange rate information
1) Open Microsoft® Excel (or other program compatible with the CSV format), and open the exported CSV file.
2) Enter currency exchange rate information in the spreadsheet. The fields are discussed in the table below.
Notes:
- Do not delete or change the order of the columns.
- Successful import creates a currency exchange rate set with the Active status.
- Only the currency code is validated, but Unifier will add to the exchange rate set the values you specify in the CSV upload file.
- Only the absolute value for the exchange rate is considered. If you enter a negative value, the negative sign is dropped and only the value is considered.
- You can enter new rates, or update existing rates.
- Only the first five decimal values of the exchange rate are imported; if less than five decimal values are entered, zeros are added during the import to add up to five values.
- If you remove an exchange rate from the CSV file, the rate is retained in Unifier, and is not deleted.
- If there are errors in the CSV file Unifier will not import the CSV file.

3) Save in CSV format.

<table>
<thead>
<tr>
<th>In this column:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency Name</td>
<td>Enter the name of the currency. For example, United States Dollar. This currency name is not validated and is for reference only.</td>
</tr>
<tr>
<td>Currency Code</td>
<td>Enter a valid currency code. Only the Currency Code is required and validated.</td>
</tr>
<tr>
<td>1.0 Base Currency =</td>
<td>Enter the exchange rate for the currency. The number you enter rounds at ten decimal places. Enter numbers and decimal points only; do not enter special characters.</td>
</tr>
</tbody>
</table>

To import the CSV file into Unifier
1) **Go to the Company Workspace tab and switch to Admin mode.**
2) **In the left Navigator, click Standards & Libraries > Exchange Rates.** The Exchange Rates log opens
3) Choose **File> Import** to import the completed CSV file.
4) Click **Browse** and navigate to where you saved the file.
5) **Click OK** to import.

Only files with exchange rate information in the correct format will be imported. If the upload fails, the CSV file will contain an error message that explains why the upload failed. The user who imported the CSV file is listed in the Audit log as the User.
To fix import errors
1) Re-open the CSV file.
2) Delete rows that were successfully imported.
3) Fix the rows that were not imported correctly.
4) Re-import the file.

To export exchange rates to your desktop
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates log opens
3) Choose File > Export. A confirmation window opens. Do one of the following:
   - Click Open to open the file in Excel (or other editor that supports CSV files). You can save the file from here after previewing.
   - Click Save to save the file to your local drive. Enter a name for the file and click Save.

Setting up Cost Sheets

The following is provided as a reference for creating, setting up and managing the Cost Sheet portion of the Cost Manager.

How to set up the cost manager (cost sheets)

Before you begin: Ensure that currencies and exchange rates have been set up. Verify that all Cost Codes have been added or imported. Before you can create the Cost Template, you must create the necessary Cost Codes Data Definition(s) which will be used to build your WBS Codes.

WBS Cost Codes can be single or multi segment codes. See Importing and Exporting Exchange Rates (on page 467), Add a Basic data definition (on page 75).

Step 1: Design and deploy the cost attribute form. Once deployed, the cost attribute form becomes the WBS Details window in Unifier, used to create and manage WBS codes in the project or shell cost sheet. This is an optional step. If you do not create a cost attribute, a default form will be used to create WBS codes. (See Importing the Cost Attribute Form (on page 470).)

Step 2: Configure permissions. (Refer to the Unifier Reference Guide for cost manager permission settings.)

Step 3: Create a cost sheet template. You must create at least one cost template before you can create cost sheets. You can use the template to create project or shell cost sheets, or a cost sheet within a project or shell template. You can add columns to the template, which can be used to capture transaction data from cost business processes, create formulas, manage the budget, manually enter data, link to the funding manager, and much more. You can create the WBS codes in the template, which are the rows on the sheet. (You can also set up columns and rows on individual cost sheets, following the same procedures). (See Creating and Setting up Cost Templates (on page 470).)

Step 4: Create a project or shell cost sheet. You can create a cost sheet directly in the project or shell, or in a project or shell template (when you create project or shells from the template, you can include the cost sheet). (See Creating a Project or Shell Cost Sheet (on page 489).)
Step 5: Define the project or shell budget. After creating the project or shell cost sheet, you can distribute the budget. This is done in User Mode.

Optional steps:

- Create work packages. This is done in user mode.
- Create worksheets. Worksheets can be used as mini-cost sheets, linked to project or shell cost sheet columns. You create a worksheet template first. (See Creating Worksheet Templates (on page 484).)
- Create program and company cost sheets. This is optional. The program and company cost sheets are used to summarize project data. You can configure these sheets to display specific data by adding or removing desired columns. The rows correspond to each individual project cost sheet. The program cost sheet will summarize the cost sheet data for the project in the program. The company level cost sheet summarizes project data across the company. The company cost sheet can also be mapped to company level account codes, which can allow you to link project WBS codes with company level account codes. (See Setting up a Program Cost Sheet (on page 494), Setting up the Company Cost Sheet (on page 497).)
- Design and deploy cost business processes. Use these to enable transactions against the cost sheet.
- Set up a company accounts sheet. (See Setting up a Company Accounts Sheet (on page 500))
- Set up SOV. (See Setting Up Schedule of Values (SOV) (on page 532))
- Set up Funding. (See Setting up the Funding Manager (on page 505))
- Set up Rules. (See Setting up the Rules Engine (on page 552))

Importing the Cost Attribute Form

A cost attribute form (created in uDesigner) is used as the WBS Details window. The WBS Details window is used to create rows (WBS Codes) to project or shell cost sheets.

You can have only one Cost Attribute form per company, which will be used for WBS Details window across all projects or shells.

To import and deploy a cost attribute form into Unifier production, see the instructions in the topic Importing and Deploying a Design (on page 273).

Configuring Cost Manager Permissions

Refer to the Unifier Reference Guide for cost manager permission settings.

Creating and Setting up Cost Templates

Project or shell cost sheets are created by copying from a cost sheet template or from an existing project or shell cost sheet in another project or shell. Therefore, when you first set up the cost manager, you must start with at least one cost template that you can use to create a project or shell cost sheet (or cost sheet in a project or shell template).
Unifier Administration Mode

To access cost sheet templates

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates>Cost Sheets in the left Navigator. The Cost Templates log opens. This log is used to create cost sheet templates and worksheet templates.

Create a new cost sheet template

The following procedure describes how create a cost sheet template. This will be a "blank" template with no rows and two default columns. After creating the blank template, you can add columns and/or rows before creating a project or shell cost sheet from it.

To create a new cost sheet template

1) In Administration Mode, go to the Company Workspace tab and click Templates>Cost Sheets in the left Navigator. The Cost Templates log opens.
2) Click the New button and choose Cost Sheet. The Properties window opens.

The Properties window is the same for cost sheet templates and for project or shell cost sheets, and has three tabs:

- **General**: Defines general properties of the template:
  - Enter a unique Title, which is used to identify the template in the log and when creating a new project or shell cost sheet from the template. When you create a cost sheet from the template, the title will default to Project Cost Sheet and will not be editable.
  - Enter an optional Description for the template. This description will be copied to the Project Cost Sheet when you create one, and will not be editable.
  - You can select a Default View for the template. This can be edited in the Project Cost Sheet. For details, see Define cost sheet default view (General tab) (on page 471).

- **Structure**: Defines the structure of the WBS Codes (or Cost Codes) for use within the cost sheet. This remains editable in cost templates, but once it is set in a project or shell cost sheet, it cannot be changed as this tab defines the WBS Code structure for the project or shell. For details, see Define cost code structure (Structure tab) (on page 472).

- **Options**: Defines labels for the two default columns, and details on forecast handling. For details, see Define cost sheet options (Options tab) (on page 474).

Define cost sheet default view (General tab)

The cost sheet default view refers to how the cost sheet appears when it is first opened. There are two options regarding the cost sheet default view, described in the procedure below. These options control how the cost sheet opens for all users. Unlike other cost sheet properties, the default view settings can be modified in the Project Cost Sheet after it has been created in User Mode.

To define the cost sheet default view

1) Open the Properties window (select the template and click the Properties button from the log toolbar, or open the template and click File > Properties).
2) On the General tab, you may choose either or both of the Default View checkbox options:
Open in maximized view: when the cost sheet or template is opened, it will automatically open maximized, or full-screen

Open in split mode: when the cost sheet or template is opened, it will automatically open as split (same as clicking the Split button)

If these options are not selected, the cost sheet or template will open by default to a size slightly smaller than the Unifier screen, and not split.

Note: The cost sheet window can be resized by clicking the Minimize or Maximize/Restore buttons in the upper right corner of the window, or by dragging the edges of the window to the size that you need. When working with a cost sheet with many columns, it can be useful to split the window. You can click the Split button to scroll through the columns in the right half of the window, while maintaining a view of the WBS Code and WBS Item columns in the left half. To return the sheet to normal view, click the Split button again.

Define cost code structure (Structure tab)

In the Structure tab of the cost sheet or template Properties window, you define the structure of the cost codes used in the sheet. The cost codes that are built from this structure are used throughout the project or shell, for example, in cost type business processes for cost transactions.

This structure remains editable in cost templates, allowing you to make adjustments to the structure as needed. In project or shell cost sheets, once the structure has been defined, it cannot be edited.

To define the cost code structure

1) In the cost Properties windows, click the Structure tab.

2) Determine how many segments to use for cost codes. For example, your company may have a three-segment WBS code based on numerical values. You may have as little as one segment (each cost code is a single entity), or as many as 10.

3) In the Structure field at the top of the window, select Flat or Tree.

   - If you choose Flat, the cost sheet will display the WBS codes (rows) in a flat structure, with no indented rows. This is useful if you want to display all WBS codes at once.

   - If you choose Tree, you have the option of creating indented, nested rows, which can be collapsed into summary, or grouping, rows. This is useful if you will be creating a large amount of rows that can be grouped into categories.

   Summary rows act only as grouping rows for their indented child, or leaf, rows. Data cannot be entered directly into a summary row.

4) For Segment 1, click the pull-down menu and choose the first segment.

   The available segments correspond to the list of Cost Code Data Definitions found in Administration Mode in Company>Data Structure Setup>Data Definitions>Cost Codes.
5) Repeat the previous step for each additional segment you wish to add.

<table>
<thead>
<tr>
<th>In this Field</th>
<th>Do This:</th>
</tr>
</thead>
</table>
| **Structure**   | This defines the structure of the WBS Code rows and how they will appear on the cost template and sheets. Choose Flat or Tree:  
|                 |   - Flat: no indenting of rows  
|                 |   - Tree: allows indented, nested rows, and summary rows                                                                                                                                             |
| **Sort WBS**    | If you select the Sort WBS checkbox, the rows will be sorted in ascending order by WBS Code automatically when new cost codes are added (flat structure only)                                               |
| **Segments**    | This is where you build the WBS codes (or "account" codes) that will be used for the cost sheet rows. WBS codes may consist of one or multiple (up to 10)                                                      |
segments. Each segment consists of a separate cost code data definition, as defined in Administration Mode>Your Company>Data Definitions>Cost Codes. You must define at least one segment. Select one or more segments, up to 10, in the order (left to right) you want them to appear in the Cost Sheet rows.

| Preview       | You can click the Preview button to view the result. |

Define cost sheet options (Options tab)

In the cost sheet or template Properties window, Options tab, you can define the labels of the default cost sheet columns (WBS Code and WBS Item). You can also define forecast behavior for the sheet.

To define the cost column labels
1) In the cost Properties windows, click the Options tab.
2) Enter new labels for the WBS Code and/or WBS Item columns.
3) Click Apply to save changes, or OK to save and exit the window.

To define the cost forecast details and inclusion
1) In the cost Properties windows, click the Options tab.
2) Complete the forecast details fields as described in the following table.
3) Click Apply to save changes, or OK to save and exit the window.

| Labels | These determine how the WBS code columns will be labeled, according to your company’s conventions. (Note: If you will be importing cost sheet data, it is important that the column labels match those in the import files.)
|        | WBS Code: Enter the WBS Code title that your company uses. For example, Account Code, Cost Code or WBS Code.
|        | WBS Item: Enter the WBS label that your company uses. For example, WBS Item, Cost Item or Account Description.

| Forecast Details/Forecast Inclusion | Specify the configuration for managing the Forecast column of the Cost Sheet. User Line Items/Manual is the default configuration; the following are the configuration options:
|                                  | User Line Items and Manual: At any time, the cost sheet user can...
add, edit, or delete Line Items in the Cell Detail Window of the Project or Shell Cost Sheet for the Yet to Buy/Allowance For Change (YTB/AFC) column. The user has to manually choose which commits are included in the forecast. Options for choices are:

- Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast, then $100 is automatically deducted from YTB
- Manually adjust YTB/AFC
- Make no change to YTB/AFC

**User Line Items and Auto**: Do not use this combination. This scenario will automatically inflate the Forecast due to the manual adjustment of Yet To Buy (YTB).

**Transactions and Auto**: Note the following:

- Commits (for example Base Contract, Change Order, Purchase Requisition) are automatically updated with changes to the Forecast, depending on the formula.
- Adjustments are automatically included in the Forecast column upon approval as defined by the workflow.

**Transactions and Manual**: Line Items can be added to the Cell Detail window of the Project or Shell Cost Sheet. No deletions or modifications can occur on existing line items. The user has to manually choose which commits are included in the forecast. Options for choices are:

- Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast then $100 is automatically deducted from YTB
- Manually adjust YTB/AFC
- Make no change to YTB/AFC

**P6 Integration**

Enable P6 sources

This option allows you to enable the Cost Sheet Template in Unifier to acquire data from the P6 Summary Sheets. If you select this option, you must select Tree for the Cost Sheet Structure. The Data Format in Cost Sheet Template Column "Properties" window shows has the "Decimal" option

---

**Edit cost sheet template structure or properties**

You can edit the cost template properties, rows, and columns. You can also add default data to direct entry cells, which can be copied to cost sheets created from the template.

Cost Sheet Properties include Name, Description, Default View, Structure definition (Flat or Tree), WBS Code and WBS Item titles, and switches for Forecast Details/Forecast Inclusion functionality.
Open the cost sheet template

After completing the Properties window, the cost template is created and appears in the Cost Templates log. After creating the cost sheet template, you must open the sheet to add columns and rows.

To open the cost sheet template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Cost Sheets in the left Navigator. The Cost Templates log opens.
3) Select the template and click Open (or double-click the selected sheet). The Cost Sheet Template Setup window opens. This window is the same layout as a project or shell cost sheet.

Adding Cost Columns

These procedures apply to adding columns to a cost sheet at the project or shell, program or company level; to a cost sheet template; or to a worksheet.

About cost sheet columns

Cost columns specify the data sources (business process transactions, formulas, values entered manually, etc.) that will be displayed on the cost sheet. Default columns are WBS Code and WBS Item. Cost columns can be added to cost templates, to project- or shell-level, program-level and company-level cost sheets, and to worksheets.

Columns can be of the following types:

- **Business process transaction column**: Data is rolled up automatically from cost type business processes when the BP reaches the specified status.
- **Manual entry column**: Users can enter data directly to the sheet through line item or direct entries. Custom data sources can be applied to these columns to allow project or shell cost data to roll up to program or company cost sheets, and be reportable through user-defined reports.
- **Formula column**: The column values are calculated based on a formula that normally includes values from other columns. For example, if there are multiple cost type business processes affecting the sheet, you may want to have a column that shows the sum of all of them (“Total Commits”). Custom data sources can be applied to these columns to enable them to roll up to program or company cost sheets, and be reportable.
- **Fund column**: Provides additional functionality to work with the Funding sheet. For more information, see Add a funding column to project or shell cost sheet (on page 517).
- **SOV columns**: Provides additional functionality to work with Schedule of Value sheets.

Add a cost column

This general procedure can be used for adding columns is the same whether you are adding columns to a cost sheet (project or shell, program or company level), a cost sheet template, or a worksheet.

To add a column to a cost sheet template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates > Cost Sheets** in the left Navigator. The Cost Templates log opens.
3) Select the template and click **Open** (or double-click the selected template). The Cost Sheet Template Setup window opens. This window is the same layout as a project or shell cost sheet.
4) Click the **Columns** button. The Columns Log window opens.

This window lists any existing columns, other than the two default columns (**WBS Code** and **WBS Item**), which are not editable. If no new columns have been added, the log will be empty.

1) Click the **New** button. The Column Properties window opens.
2) Complete the fields in the **Column Properties** window as described below and click **OK**.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name you choose will appear as the column header on the Project or Shell Cost Sheet. If you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
<tr>
<td><strong>Datasource</strong></td>
<td>All columns must be associated with a data source. The data source that you choose will determine which of the following options are available. The types of Data sources available are:</td>
</tr>
<tr>
<td></td>
<td>‣ <strong>Single Sources</strong>: These values roll up from other sources. These include cost type business processes, some predefined cost columns.</td>
</tr>
<tr>
<td></td>
<td>‣ <strong>Logical Sources</strong>: Choose one to create Manual Entry or Formula columns.</td>
</tr>
<tr>
<td></td>
<td>‣ <strong>P6 Sources</strong>: To select the P6 Summary Sheet from which cost should roll up.</td>
</tr>
<tr>
<td><strong>Element</strong></td>
<td>If you select the &quot;Enable P6 sources&quot; option when defining your Cost Sheet options (Creating a new Cost Sheet Template, Options tab), the following occurs in the Column Properties window:</td>
</tr>
<tr>
<td></td>
<td>The Datasource drop-down list contains the Published P6 Data Sources that have been defined in Standards and Libraries, in P6 Sources. Once you select a P6 Source as a Datasource for a column, you must select an Element (Required). The Element drop-down list contains a fixed list of available options.</td>
</tr>
<tr>
<td></td>
<td>If you select any P6 Datasource or Element to define a column, then:</td>
</tr>
<tr>
<td></td>
<td>‣ <strong>Column Name</strong> defaults to the Element that you selected.</td>
</tr>
<tr>
<td></td>
<td>Example</td>
</tr>
<tr>
<td></td>
<td>You select DataSource or Element as Sanctioned Baseline or Planned Cost. The Column Name, then, appears as: Planned Cost.</td>
</tr>
<tr>
<td></td>
<td>‣ You can edit the Name and Data Format.</td>
</tr>
<tr>
<td><strong>Notes</strong>:</td>
<td>- For all &quot;Cost&quot; elements (Planned Cost, Actual Cost, etc.), the Data Format is pre-selected as &quot;Currency&quot;</td>
</tr>
</tbody>
</table>
- For all "Unit" elements (Planned Units, Actual Units, etc.), the Data Format is pre-selected as "Decimal"
  - All P6 Sources are available for Formula Creation (Format: <P6 Source>: <Element>).
  - You can edit the Display Mode
  - You can edit the Total

<table>
<thead>
<tr>
<th>Entry Method</th>
<th>This is applicable for logical data sources.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- <strong>Manual Entry, Direct entry into cell</strong>: Users enter values by clicking the cell and entering values directly into the cell.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Manual Entry, Line item content</strong>: Users enter values manually via a line-item entry window for each WBS Code (clicking the cell opens the cell details window.)</td>
</tr>
<tr>
<td></td>
<td>- <strong>Worksheet</strong>: From the drop-down lists, select the Name of the worksheet and the Column within it.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Formula</strong>: Values are calculated based on a specified formula entered for the column. Formulas can include the values of other columns. Click the Create button to create the formula.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data Format</th>
<th>Applicable for Manual Entry or Formula columns:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- <strong>Currency</strong>: Right-aligns column contents and includes a currency symbol, a thousands separator and two decimal places</td>
</tr>
<tr>
<td></td>
<td>- <strong>Percentage</strong>: Right-aligns the contents and includes a percentage symbol</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Display Mode</th>
<th>Refers to whether the column is displayed on the cost sheet.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- <strong>Show</strong>: This is the default choice. This indicates that column will display by default on the cost sheet to all users with at least &quot;view&quot; permission for the cost sheet.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Hide</strong>: Hidden columns are active but not displayed on the cost sheet. Hidden columns can be accessed by users with &quot;create&quot; permission on the cost sheet.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Total</th>
<th>Determines what will display in the &quot;Total&quot; (bottom) row for the column:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- <strong>Blank</strong>: The total of this column is not applicable and will not display on the cost sheet. Choose this column for percentage columns and other columns where it does not make sense to display the sum total.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Sum of All Rows</strong>: The sum total of the column values is displayed.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Use Formula Definition</strong>: For formula columns; the formula will be applied to the &quot;Total&quot; row in the same way it is applied to other rows in the column.</td>
</tr>
</tbody>
</table>

| Column Position After | The new column will be inserted after the column selected. |
## Project or shell cost column data sources

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Sources</td>
<td>Columns in which data is manually rolled up from business processes once the appropriate terminal status is reached. Can also include other specified sources.</td>
</tr>
<tr>
<td>Cost-type Business Processes</td>
<td>Included in the Single Sources list are all of Cost BPs that are available for your project or shell, and all of their terminal statuses.</td>
</tr>
<tr>
<td>AFC</td>
<td>No description provided.</td>
</tr>
<tr>
<td>Assigned Budget</td>
<td>This column goes hand-in-hand with budget distribution. It allows the user to create specific, detailed line-items for each WBS code in the budget. Each line item can be assigned individually.</td>
</tr>
<tr>
<td>Funded Records</td>
<td>This column shows records in which the WBS code is funded, that is, spend-type business process records that consume funds.</td>
</tr>
<tr>
<td>Unfunded Records</td>
<td>This corresponds to spend-type BP records that are not funded.</td>
</tr>
<tr>
<td>Prior Forecasts</td>
<td>No description provided.</td>
</tr>
<tr>
<td>Yet To Buy</td>
<td>Part of the commitment that still must be purchased. For example, a base contract is for 1000 items, and 500 have been bought. There are 500 items &quot;yet to buy.&quot; It is based on a currency amount. In Cost Sheet Properties, setting &quot;Auto&quot; &quot;Transaction&quot; options will track the yet to buy information.</td>
</tr>
<tr>
<td>Logical Sources</td>
<td>No description provided.</td>
</tr>
<tr>
<td>Budget Remaining Balance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Budget Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Commits</td>
<td>This is a place holder for a formula you create (include all commit columns; optional).</td>
</tr>
<tr>
<td>Forecasts</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Forecasts (Unaccepted)</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Forecasts Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>WBS Funding</td>
<td>Requires additional setting in Funding Sheet; see Setting up the Funding Manager (on page 505).</td>
</tr>
<tr>
<td>Manual Funding by WBS</td>
<td>Requires additional setting in Funding Sheet; see Setting up the Funding Manager (on page 505).</td>
</tr>
<tr>
<td>Revised Budget</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
</tbody>
</table>
Spends | This is a place holder for a formula you create (include all spend columns; optional).
---|---
Project or shell Cost 1-25 | These can be used to rollup manual and formula columns to company and program cost sheets. Each data source can be used for one column.

**Create a formula in a cost column**

This procedure addresses how to create a formula column for use on a cost sheet. (The general procedure also applies to cost sheet templates and work sheets.)

When creating a cost sheet column, selecting a logical data source allows you to build a formula in which you can include:

- Other columns from this cost sheet
- Single data sources, such as business processes in a certain status
- Total elements, such as the tallied value of a column
- Data elements from single-record, non-workflow business processes

If you are creating a formula for forecasts (unaccepted), data sources are limited to business processes flagged in uDesigner for cost sheet forecasting. For example, if base commits and change commits were enabled for cost sheet forecasting, you will see base commits (unaccepted) and change commits (unaccepted) as available data sources for use in the forecasts (unaccepted) formula. You will not see other data sources that were not flagged in uDesigner for this purpose.

When you build your formula, think about which data sources will generate the result you want in your cost sheet column. For example, if you want to see total commitments, you can add contracts (approved) and change orders (approved).

**Note**: Use care when selecting the Cost Column that you use to build your formula. You can possibly choose from Columns (columns in the sheet), Data Sources (values of business processes), Total Elements (totals from columns), or Data Elements (data elements on Information/General record(s), typically named Project Information). The source column that you use can affect the data values in your cost sheet. If you select an incorrect source, you can get a result you do not expect. Be sure that you know the source to use before you build your formula.

To create a formula

1) In the Column Properties window, choose **Formula**, then click the **Create** button. The Formula Creation window opens.
2) Enter the first value in the formula:
   - To enter **numerical values** into the formula, click the number keys on the on-screen keypad. (Include parentheses, % or decimal point as necessary.)
   - To add a **data source** or **column value** (existing columns on the sheet you are working on) into the formula, select it from the list in the left pane, then click the **Select** button.

As you build the formula, it appears in the Formula box in the upper right portion of the window.
3) Click on the appropriate operator: add, subtract, multiply, or divide.
4) Continue to alternate between choosing values and operators to add to the formula.

**Note:** Unifier applies the operators in the order of proper mathematical procedure: from left to right, with multiplication and division first, followed by addition and subtraction.

5) You may click **Undo** at any time to undo the last action. Click the **Clear All** button to clear the entire formula.
6) When the formula is complete, click **OK** to save your formula and return to the Column Properties window.

**Example Formula**

A user wants to create a "Yet To Buy" column that calculates 7% of the Assigned Budget column. To create this formula using the keypad in the Formula Creation window:

1) Click 7 then click the percent % key. The value is displayed as 7/100
2) Click the multiplier X
3) Select Assigned Budget from the Cost Column pane on the left, then click Select

The final formula looks like this: $\frac{7}{100} \times \text{Assigned Budget}$

---

**Adding Cost Rows (WBS Codes)**

The following procedures are applicable to Cost Templates and Cost Sheets.

Each cost sheet row corresponds to the unique WBS (or Cost) codes that link costs on a project or shell to the General Ledger for Finance. They may be added manually or imported from a CSV file.

WBS codes may consist of one or a maximum of 10 segments. Each segment is defined by a different data definition. For example, a five segment WBS Code would require five data definitions. Segments can be defined via a selection list or text entry.

If the cost sheet has been setup to automatically sort WBS codes, then all new rows will be sorted by ascending order.

You cannot create duplicate WBS Codes at the same row level on the sheet. If you choose a Flat structure for your cost sheet (no indented rows), then you will not be allowed to create duplicate WBS Codes. If you choose a Tree structure, you can use the same WBS Code as long as each instance is within a different grouping (or parent) row.

**To manually add rows to a cost sheet or cost template**

1) Open the Cost Template or Cost Sheet.
2) Click the **Rows** button. The Rows window opens.
3) Click **Add Row**. The WBS Details window opens.
4) Complete the **WBS Details** window as described in the following section.
5) Click **OK**.
**To insert a row between existing rows**

1) In the **Rows** window, select the checkbox next to the row after which you want to insert the new row.

2) Click **Add Row** and follow the procedure to add a new row. The new row will be added after the selected row.

**About the WBS details window**

Following is an overview of the fields and tabs in the WBS Details window.

The WBS Details window displays WBS properties. You can add notes or file attachments to the WBS code in this window. You can also specify WBS Breakdowns in this window, which are used in Schedule of Values (SOV) sheets.

The values that are available in the WBS code selection come from the Cost Codes data definitions. Navigate to **Administration Mode>Company>Data Structure Setup>Data Definitions>Cost Codes**. The log will show whether the code is a Text Box or Pulldown Menu. The codes listed in the log are those that are available to use when building the WBS Code segments.

This section discusses the default WBS Details window. If your company has designed a uDesigner-created Cost Attribute Form, the fields may differ. Fields with a red asterisk are mandatory.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>WBS Code</td>
<td>Click <strong>Select</strong> to choose the cost code segments for the WBS code. The Cost Code Selection window opens.</td>
</tr>
<tr>
<td>WBS Item</td>
<td>Enter a label that will display on the cost sheet next to the WBS Code, this can help other users to identify what the code represents.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description to describe the row.</td>
</tr>
</tbody>
</table>

**Notes:**

About the WBS Details window:

- The appearance of the Cost Code Selection window will depend on how your cost sheet was set up, which WBS Codes (cost codes) were used in the definition, and how each code was set up.
- If the WBS code segment has a **Select** button, then click the button and choose the segment values from the list.
- If the WBS code segment does not have a **Select** button, then type the value of the segment into the field.
Create a summary row

If you selected a Tree Structure format, you can indent rows. These indented rows can be used to capture cost transactions. The parent node acts as a summary row, summarizing the information present for each of the indented "child" rows. You cannot enter information directly into a summary row.

To create a summary row by indenting
1) In the Rows window, select the checkbox of the row(s) to indent under the summary row.
2) Click the Indent button. The row immediately above will become a summary row. All monetary values in the detail lines below a summary row will be rolled up to the summary row automatically.

To outdent a row
1) In the Rows window, select an indented row by clicking its checkbox.
2) Click the Outdent button. The row will no longer be part of the summary row.

Import cost rows (WBS codes)

You can create WBS Codes in a cost sheet by importing them from a CSV file. This procedure can also be used to copy the WBS codes from one cost sheet or template to another (the structure and code segments must be the same).

Step 1: Export the file template
a) Open the cost sheet or template, click the Export button and select WBS Details.
b) On the File Download window, click Save.
c) Enter a file name, browse to where you want to save the file, and click Save.

Step 2: Add the WBS code rows to the CSV file
a) Navigate to and open the CSV file (in Microsoft Excel or other compatible program).
   If the Cost Template already contains rows, they will be listed. If summary rows exist, the WBS column will display them with two tilde symbols (~~) separating the parent row from the child row.
   e.g.: 2000000 ~~210000, where 2000000 is the parent and 210000 is the child.
b) Enter information in the required fields and save the file.

   Note: Do not change or delete any of the listed WBS Codes that already exist in Unifier or you will get an error. Changes to the WBS Code must be done within Unifier.

   Required fields:
   • WBS Code: must be a match to a WBS Code in the Cost Sheet
   • WBS Item: must be a match to the WBS Item for the associated WBS Code in the Cost Sheet
   • Cost Type: Capital or Expense
   • Status: Active or Inactive

Step 3: Import the rows
a) In the cost sheet or template, click the **Import** button and select **WBS Details**.

b) In the Upload window, browse to and add the CSV file.

c) Click **OK**. After the import, your Cost Sheet will show the new rows.

**To copy WBS codes from one cost sheet or template to another**

1) In the source cost sheet or template, click **Export > WBS Details**. Save the CSV files. You can go in to the file and add additional codes if needed.

2) In the destination cost sheet or template, click **Import > WBS Details**. Browse to the CSV file and import.

---

**Note:** The structure of the two sheets must be the same: Both must be tree or flat structure. Verify the structures by opening the Properties window and clicking the Structure tab. Be sure you are using the same WBS code segments.

---

**Creating Worksheet Templates**

Worksheets are extensions of the cost sheet. They can be used as "sub-cost sheets," enabling specific calculations or data entry in a separate sheet, which can then be rolled up into a defined project or shell cost sheet column. For example, a worksheet can be used to off-load complex calculations, which can be rolled up into a single cost sheet column. The rows equal the WBS codes on the cost sheet. Worksheets can have multiple columns for data entry or formula calculations, but do not support data rolled up from business processes.

A cost sheet column can be associated with a worksheet as the data entry method. A worksheet column can also be associated with another worksheet, as long as there is not a circular reference. There can be multiple worksheets in a project or shell.

---

**Note:** A circular reference is referred to a reference in which the last field references the first field and creates a closed loop.

A worksheet template can be created in Administration Mode. Permissions can be controlled for individual worksheets. Worksheets are not independently reportable; however, cost sheet columns that reference worksheets can be reported on.

**Create a new worksheet template**

You can use this template to create worksheets for individual project or shell cost sheets, or for cost sheets in project or shell templates.

Worksheets are created similarly to cost sheets. The user who creates a worksheet will be the owner of the Worksheet. The owner can grant permissions to other users / groups in User Mode.

**To create a new worksheet template**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Templates > Cost Sheets** in the left Navigator. The Cost Templates log opens.

3) Click the **New** button and choose **Worksheet**. The Worksheet Properties window opens.

4) Complete the Worksheet Properties window:
Unifier Administration Mode

- **Title**: Enter a unique title to identify the worksheet or template. This is a required field.
- **Description**: Enter an optional description. This is especially useful if you plan to create multiple templates for use in different project or shells, or multiple worksheets for a project or shell.
- **Default View**: You may choose either or both of the Default View checkbox options:
  - **Open in maximized view**: when the worksheet or template is opened, it will automatically open maximized, or full-screen
  - **Open in split mode**: when the worksheet or template is opened, it will automatically open as split (same as clicking the Split button)

If these options are not selected, the worksheet or template will open by default to a size slightly smaller than the Unifier screen, and not split. The window can be resized by clicking the Minimize or Maximize/Restore buttons in the upper right corner of the window, or by dragging the edges of the window to the size that you need.

5) Click **OK** to save and exit the window. The worksheet template is listed in the log.

You can open the worksheet template and configure it by adding columns; the rows will be the WBS codes within the corresponding cost sheet.

Open the worksheet template

After creating the worksheet template, you must open the sheet to add columns.

**To open the worksheet template**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates>Cost Sheets** in the left Navigator.
3) Select the worksheet template and click **Open** (or double-click the selected sheet). The worksheet template window opens.

Create a worksheet column

Adding a column to a worksheet is similar to adding a column to the cost sheet. You can add manual entry (direct or line item) columns or formula columns. You can also add columns that reference other worksheets. This allows interaction between worksheets.

The available datasources are Project Worksheet Cost 1 through 50.

**To add a column**

1) Open the worksheet and click the **Columns** button. The Columns Log opens.
2) Click **New**. The Column Properties window opens.
3) Complete the Column Properties as usual for a column.
   - If you are creating a formula, the datasources that are available for the formula are limited to the other columns on the worksheet.
4) Complete the window and click **OK**.

Create a worksheet in a project or shell

You can create a new worksheet in the project or shell level Cost Manager by copying from a template or copying from a project or shell.
To create a new worksheet from a template
1) Click New and select Copy from Template. This option will allow you to create a worksheet by copying one from a company level template.
2) Select a worksheet template and click Copy.

To create a new worksheet from another project or shell
1) Click New and select Copy from Project or Shell. The Copy from Projects or Shells window opens. This window will list worksheets from all project or shells.
2) Select any Cost Sheet and click the Copy button to create a new Cost Sheet.

Delete a worksheet
User will not be allowed to delete a Worksheet if it is referred as a Column Entry method in Cost Sheet. Only owner of Worksheet will be allowed to delete Worksheet along with user with Create permission at module level.

To delete a worksheet
Select the worksheet in the log and click the Delete button.

Managing Cost Templates
You can edit the cost template properties, rows, columns, or add default data to rows. Edits to a template will be reflected in cost sheets that are created from it, but will not affect exiting cost sheets.

View or edit cost template properties
The Properties window of a cost template is fully editable. This allows you to make changes as necessary to use when creating subsequent cost sheets from the template.

Many of the properties that are editable in cost templates are not editable in Properties window of the cost sheet itself once it has been created in the project or shell or in a project or shell template.

To view or edit cost template properties
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Cost Sheets in the left Navigator. The Cost Templates log opens.
3) Select a cost template from the log and click the Properties button. The Properties window opens.
4) Make edits as necessary. Any edits that you make to a cost template will affect new project or shell cost sheets created from the template. Existing cost sheets will not be affected.
5) Click Apply to save changes, or OK to save and exit the window.

Delete a template
You can delete a cost template from the cost templates log. Cost sheets in project or shell templates or in project or shells cannot be deleted. Deleting a template will have no affect on cost sheets created from it.
To delete a template
From the Cost Templates log, select the template and click the **Delete** button.

**Edit a cost column**
You can edit the properties of a column, including the entry method, as long as this is applicable for the selected data source. Although it is possible to change the entry method for a column, use caution when doing so when data exists in the column. Information such as detailed line item entries could be lost. For example, if you change the data entry method from line item entry to direct entry, the value will appear in the cell, but all line item details will be lost.

**To edit a column**
1) From the Cost Templates log (or project or shell Cost Sheet log), select the template/sheet and click **Open**.
2) Click the **Columns** button. The Columns Log window opens, displaying the list of current columns.
3) Select a column from the Column log and click **Open**. The Column Properties window opens. Make changes as necessary.

**Move a column**
To move a column:
1) From the Columns log, select a column to move.
2) Click **Move Up (Left)** or **Move Down (Right)**. The order that the columns appear in the Log window is the order (from left to right) that they appear on the sheet.

**Delete a column**
If a column is being used in a formula in another column, you must remove the column from the formula before you can delete it. If the column contains a cell with line item data, you must first remove each line item before it can be deleted.

**To delete a column**
1) Select a column from the Columns Log and click **Open** to open the Column Properties window.
2) Click the **Delete** button. Click **Yes** to confirm.

**Hide cost sheet columns**
You can hide a cost sheet column. Hidden columns are not visible on the cost sheet, but otherwise function like other cost columns. For example, you might want to hide a column that is used in a formula column, but is unnecessary to display. Hidden columns can be viewed from the Columns Log by users with "create" permission on the cost sheet.

**To hide a cost sheet column**
1) Select a column from the Columns Log and click **Open** to open the Column Properties window.
2) For Display Mode, choose **Hide**.
3) Click **OK** to close the window. The Columns log will show the column as Hidden in the Display Mode column. Hidden columns do not display on the cost sheet, but are listed in the Columns log.
To unhide a hidden cost sheet column

1) Select the hidden column from the Columns Log and click Open to open the Column Properties window. Hidden columns are labeled as "Hidden" in the Display Mode column in the Columns Log.
2) For Display Mode, choose Unhide.
3) Click OK to close the window. The column will display on the cost sheet, to all users with at least View permissions, and who have not been given View restrictions.

Edit a cost row

You can edit rows in templates and cost sheets. However, in cost sheets, if you have already distributed and locked the budget, you must unlock it first before you can access the Rows window and edit rows.

To edit a row

1) From the cost template/sheet, click the Rows button. The Rows window opens, displaying the list of current rows.
2) From the Rows window you can Add a row, select a row and Delete it, Indent a row under a summary row, or Outdent a row, bringing it out from under a summary row.
3) For more information, see Adding Cost Rows (WBS Codes) (on page 481).

View or edit WBS details

The WBS Details window displays WBS properties. Notes and files can be attached to transactions via the WBS Details window. You can also specify WBS Breakdowns in the WBS Details window, which are used in SOV sheets.

Note: If you have locked the budget, you will need to unlock it first in order to access the Rows window or WBS Details window.

To view WBS Details

1) Open the Cost Sheet.
2) Do one of the following:
   - From the cost sheet, click the WBS Code to be edited, which appears as a link in the first column of the cost sheet row. The WBS Details window opens as a read-only window.
   - From the cost sheet, click the Rows button to open the Rows window, then click a WBS Code. The WBS Details opens in an editable view, provided you have edit permissions.

   The General tab displays information about the WBS Code. The Breakdown tab displays breakdown information.

To edit WBS Details

For more information about adding WBS Breakdown, see the following section.

1) From the Cost Sheet, click the Rows button. The Rows window opens.
2) Click the WBS Code to be edited, which appears as a link. The WBS Details window opens.
3) Make changes to the General Tab or Breakdown Tab as necessary.
4) Click **Apply** and **OK**.

---

**Creating a Project or Shell Cost Sheet**

The Cost Sheet is created by copying from a cost template or another project or shell cost sheet. Only one project or shell cost sheet may be defined per project or shell. You may define multiple work packages or work sheets.

If a worksheet is associated with the cost sheet or template (that is, if a cost sheet column definition refers to Worksheet as Data Entry method), the worksheet will also be copied.

**Note**: Once a cost sheet has been created, it cannot be deleted. Be sure the structure (tree or flat) of the template is what you want to use for the cost sheet. The structure is not editable for cost sheets. You can add, modify or delete columns and rows to the sheet as necessary.

**To create a cost sheet by copying a template**

1) Click **New** and select **Copy from Template**. This option will allow user to create a Cost Sheet by copying one from a company level template.
2) Select a template and click **Copy**.

**To create a cost sheet by copying from another project or shell**

1) Open the project or shell into which you want to copy the cost sheet and switch to User mode.
2) In the Navigator, click **Cost Manager > Cost Sheet**.
3) Click **New** and select **Copy from Project/Shell**. The Copy from Projects/Shells window opens. This window will list Cost Sheet from all projects or shells. Observe that only Cost Sheets should be displayed to user.
4) Select any Cost Sheet and click the **Copy** button to create a new Cost Sheet.
Add cost sheet columns and rows

Rows and columns are added to project or shell cost sheet the same way as they are to cost templates. See *Creating and Setting up Cost Templates* (on page 470).

Add column view or edit restrictions

The Restrictions setting allows you to restrict viewing or editing permissions for particular columns. This functionality allows you to restrict specific users or groups from viewing or editing columns that they would normally be able to access.

Column restrictions can be added to project or shell, program and company level cost sheet columns and work package columns, but not the cost template.

A user may have general view and/or edit permissions on the cost sheet, but can be restricted from viewing or editing cost information in specific columns within the cost sheet. Users or Groups with Create permissions can set these additional column restrictions from within the cost sheet in User Mode.

Column restrictions differ from "hidden columns" in that users with edit and/or view permissions for the entire cost sheet will by default have edit and/or view permissions for each column in the cost sheet, unless restricted from doing so. "Hidden" columns are not displayed on the cost sheet, regardless of the permissions of the user.

Restriction setup affects Budget Distribution and Assigned Budget. If Assigned Budget is available on the cost sheet, the following applies:

- No Restriction setup for a user: User can view and edit both Budget distribution and Assigned Budget
- Disallow Viewing checked for a user: User cannot view and edit both Budget distribution and Assigned Budget. Cannot import Summary Budget
- Disallow Viewing unchecked for a user: User can view Budget distribution and Assigned Budget. Cannot import Summary Budget.
- Disallow Editing checked for a user: User cannot view and modify Budget distribution and Assigned Budget. Cannot import Summary Budget.
- Disallow Editing unchecked for a user: User can view and modify Budget distribution and Assigned Budget. Can import Summary Budget.

Restrictions and permissions:

- Opening a worksheet directly from the log window is based on the worksheet permission defined for that worksheet.
- Accessing and viewing worksheet data from a Cost Sheet column is subject to column restrictions. Worksheet ownership (creator) and permissions work on top of Cost Sheet column restrictions.
- Be sure you have cost sheet "Create" permissions. Users with create permissions for the cost sheet will be allowed to access the Restrictions button.

To set cost sheet column restrictions

1) In User Mode, open the work package or project or shell, program or company level cost sheet.
2) Click the Columns button. The Columns Log opens.
3) Click the **Restrictions** button. The Edit Restrictions window opens.

4) Click the **Add** button. The User/Group Picker opens.
   The users or groups that are displayed in the picker are limited to those users and groups that have cost sheet permissions. For example, if you have given project or shell cost sheet permission to a single group, that group will display in the User/Group Picker window.

5) Select the user or group to edit restrictions and click **OK**. The Edit Restrictions window opens.

6) Select one or more user/group in the upper portion of the Edit Restrictions window (press the **Shift** or **Ctrl** keys to select more than one user or group). The permission settings for each cost sheet column are displayed in the lower portion of the window.

7) For each column, you may set the following restrictions:
   
   - **Disallow Editing**: if a user or group is not allowed to edit a column, then that user or group will not be allowed to add, modify, or delete data in any of the cells in the column.
   
   - **Disallow Viewing**: select this checkbox if you want to restrict the user/group from viewing a particular column.

8) Click **OK**.

**Cost sheet column permission matrix**

The following summarizes the relationship between user cost sheet permission settings in Administration mode with the additional column restrictions in User Mode.

**Column restrictions will not override View or Edit permissions for users with module-level Create permission.** If a user has Cost Sheet module Create permission (in permission settings), this overrides any User Mode column restrictions. This also means that if a user has a "Disallow Editing" or "Disallow Viewing" column restriction, and then is subsequently granted module-level Create permission for the cost sheet, that Create permission will override the column restriction and the user will be able to view/edit the column (even if the restriction is still selected in User Mode).

---

**Note:** These restrictions apply to work packages as well. If a user does not have view permission on a column, then that user will not be allowed to view the same column in a work package.

<table>
<thead>
<tr>
<th>With this Permission/Restriction Setting:</th>
<th>The User Can:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost Sheet Module</td>
<td>The User Can:</td>
</tr>
<tr>
<td>&quot;Disallow Editing&quot;</td>
<td>Edit column data</td>
</tr>
<tr>
<td>View</td>
<td>not selected</td>
</tr>
<tr>
<td>View</td>
<td>x</td>
</tr>
<tr>
<td>View</td>
<td>x</td>
</tr>
<tr>
<td>Modify</td>
<td>not selected</td>
</tr>
<tr>
<td>Modify</td>
<td>x</td>
</tr>
<tr>
<td>Modify</td>
<td>x</td>
</tr>
</tbody>
</table>
If a user or group is removed from module level permission but was previously configured in the Restrictions window to edit or view columns, then that user or group will not be removed from the restrictions list.

Edit Restriction is available only for manual entry column, for example: Manual datasource, Assigned Budget, YTB, Manual Funding at Project or Shell and WBS Level. For all other columns, Edit Restriction option is disabled, as the user cannot edit information.

**Effects of column restrictions on viewing a worksheet**

<table>
<thead>
<tr>
<th>Case</th>
<th>Can view/edit column data</th>
<th>Can view column data</th>
<th>Owner</th>
<th>Edit permission</th>
<th>View permission</th>
<th>Access in view mode</th>
<th>Access in edit mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>n/a</td>
<td>Yes</td>
</tr>
<tr>
<td>2</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>n/a</td>
<td>Yes</td>
</tr>
<tr>
<td>3</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>4</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>5</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>n/a</td>
<td>Yes</td>
</tr>
<tr>
<td>6</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>n/a</td>
<td>Yes</td>
</tr>
<tr>
<td>7</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>8</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>9</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

In cases 4 and 8, the user will see an error message that they cannot view the worksheet as they do not have view permissions for the worksheet. In case 9, they will not see any message, as they cannot see the column with worksheet as the data entry method.

**Add WBS breakdown**

Breakdowns are used in SOV sheets. Invoices can be created from SOVs that can include WBS breakdowns. The breakdowns are not accessible in any BP except Spends BPs, and are not associated with data definitions, and so are not reportable.

The breakdown applies to a single project or shell, and can be applied across projects or shells by adding WBS code rows and breakdowns to Cost templates, or creating cost sheets from previous project or shell cost sheets with breakdowns.
You may add as many breakdowns as you need. When you click OK, the system will perform a validation check. If the WBS code is already in use in a cost sheet transaction, the system will not allow the addition of a breakdown.

**Note:** If you have locked the budget, you will need to unlock it first to access the Rows window.

You can also add breakdowns directly to SOV sheet. This is done in User mode on the SOV sheet.

### To add a WBS Breakdown

1. From the Cost Sheet, click the **Rows** button. The Rows window opens.
2. Click the **WBS Code** to be edited, which appears as a link. The WBS Details window opens.
3. Make changes to the **General** tab or **Breakdown** tab as necessary.
4. Open the WBS Details window and click the **Breakdown** tab.

**Note:** The **Breakdown** tab becomes accessible after the row has been created. To see the **Breakdown** tab, you must first create the WBS Code and click **OK**.

5. Click the **Add** button.
6. Add a Breakdown **Name** and **Description** and click **OK**.

### Add notes and attachments to a WBS code

To add notes to a WBS code:

1. From the WBS Details window, click **Add Notes**.
2. Enter the note and click **OK**. The number of Notes attached to the record will display in the lower left corner of the window.
3. Click the **Number** link to view the notes.

To attach files to a WBS code:

From the WBS Details window, click **Attach** and select one of the following options:

- **My Computer**: To attach a file from your local system. When you attach files from your local system.
- **Primavera Unifier Folder**: To attach documents from the Document Manager. The window opens, displaying the Documents files and folders. Select the files and folders to attach and click **OK**. (Folders are not attached; the contents of selected folders are attached in a flat list. Documents with duplicate files names will not attach.) You must have at least view permission to the folders and files within the Document Manager in order to view and attach them.

### Modify cost sheet default view

The cost sheet default view refers to how the cost sheet appears when it is first opened. The cost sheet Properties window offers two options regarding the cost sheet default view, described in the procedure below. These options control how the cost sheet opens for all users.
To modify the cost sheet default view

1) In User Mode, open the cost sheet Properties window (click the Properties button from the log toolbar, or open the cost sheet and click File > Properties).

2) On the General tab, you may optionally choose either or both of the Default View checkbox options:
   - **Open in maximized view:** when the cost sheet is opened, it will automatically open maximized, or full-screen
   - **Open in split mode:** when the cost sheet is opened, it will automatically open as split (same as clicking the Split button)

   If these options are not selected, the cost sheet will open by default to a size slightly smaller than the Unifier screen, and not split.

Setting up a Program Cost Sheet

Program Cost Sheets are created automatically once a project cost sheet has been created for one of the project in the program. It includes all projects that are active an on-hold and that are included as part of program definition. Newly added projects will be displayed on Cost Sheet at appropriate location based on sorting order.

The Program Cost Sheet will display cost data for all projects (within the program) that have a status of Active or On-hold. The currency used is the company Base Currency.

Projects on the Program Cost Sheet are sorted automatically by ascending project number. As new projects are added to the program, and cost sheets are created for them, the new projects will be automatically added to the Program Cost Sheet.

You can add columns to correspond to and roll up project cost sheet data. Rows correspond to project cost sheets.

Access the program cost sheet

When you create a new Program, the Program Cost Sheet is created automatically, based on the cost sheets of the individual projects in the program. As project cost sheets are updated, the program cost sheet is updated automatically. You may add additional Cost Groups which incorporate program-related cost data.

To view a program cost sheet or cost group

1) Open the program.

2) From the Navigator, click **Cost Manager > Cost Sheet**. The log lists the Program Cost Sheet and any cost groups.
   - **Title:** The Program Cost Sheet name or the Cost Group name.
   - **Reference No.:** The Reference number assigned to the Cost Group at time of creation.
   - **Date Created:** The date the Cost Sheet or Cost Group was added to the Program.
   - **Creator:** The project team member that added the Program Cost Sheet or Cost Group to the Program.
   - **Type:** The type is either Program Cost Sheet or Cost Group.
   - **Status:** The current status of the Program Cost Sheet or Cost Group.

3) Select the Cost Sheet or Cost Group to view and click **Open**.
The Program Cost Sheet opens, listing each of the projects in the program. The Project Numbers are hyperlinks that open the associated project cost sheet. Depending on your permission levels, you can view the current project data that was used in the current Program.

4) To view a project cost sheet, click on the Project Number link. The Project Cost Sheet opens. Close the project cost sheet window when you are done viewing it.

5) Close the Program Cost Sheet when you are done making modifications.

Add Program Cost Sheet Columns

Cost sheet columns can be added to program cost sheets the way they are added to cost templates. Predefined data sources at project level will be rolled up to program level automatically.

Note: Column restrictions can be added to program cost sheet columns. See the Project Cost Sheet section. See Add column view or edit restrictions (on page 490).

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Sources</td>
<td>Data from single datasources Project Cost1 to Project Cost25 is rolled up from project-level cost sheets. Users can also view datasources based on business process data rollup from the project-level. Following are the available datasources:</td>
</tr>
<tr>
<td>Business Process (All statuses)</td>
<td>Included in the Single Sources list are all of Cost BPs that are available for your project, and all of their terminal statuses.</td>
</tr>
<tr>
<td>AFC</td>
<td>AFC</td>
</tr>
<tr>
<td>Funded Records</td>
<td>This column shows records in which the WBS code is funded, that is, spend-type business process records that consume funds.</td>
</tr>
<tr>
<td>Unfunded Records</td>
<td>This corresponds to spend-type BP records that are not funded.</td>
</tr>
<tr>
<td>Prior Forecasts</td>
<td></td>
</tr>
<tr>
<td>Yet To Buy</td>
<td></td>
</tr>
<tr>
<td>Project Cost 1 to Project Cost 25</td>
<td>Rollup from all projects</td>
</tr>
<tr>
<td>All Project Single Sources</td>
<td>All other data sources are similar to Project Cost Sheet.</td>
</tr>
<tr>
<td>Logical Sources</td>
<td></td>
</tr>
<tr>
<td>Program Budget Remaining Balance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Program Budget Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td>Program Commits</td>
<td>You can add all your BP commits here.</td>
</tr>
<tr>
<td>Program Forecasts</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Program Forecasts (Unaccepted)</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Program Forecasts Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Program Funding</td>
<td>You can roll up all project funding here</td>
</tr>
<tr>
<td>Program Spends</td>
<td>You can rollup spends BPs here.</td>
</tr>
<tr>
<td>Program WBS Funding</td>
<td>This requires additional setting in Funding Sheet; see Setting up the Funding Manager (on page 505).</td>
</tr>
<tr>
<td>Program Manual Funding by WBS</td>
<td></td>
</tr>
<tr>
<td>Program Cost 1-25</td>
<td></td>
</tr>
</tbody>
</table>

Create and manage program cost groups

To create a new program cost group
1) Open a program and click Cost Manager > Cost Sheet in the left Navigator. The Cost Manager log opens.
2) Click the New button. The Cost Group Properties window opens.
3) Enter the Properties information:
   ▶ Title: Enter a unique title for the cost group.
   ▶ Record No.: Enter a record number.
   ▶ Status: Choose to make the Cost Group Active or Inactive.
   ▶ Owner: Click Select and select an owner.
   ▶ Enter an optional Description and any Comments.
   ▶ You may click the Attach button to attach files to the Cost Group.
4) Click Apply and OK to save the Cost Group properties information. The new Cost Group appears in the Cost Summary log.
To set up the Cost Group
1) Select the Cost Group from the Program Cost Manager log.
2) Click Open. The Cost Group sheet opens.
   Depending on your permission levels, you can view the current project data that was used in
   the current Program, or you can Add and Delete columns and select new data sources to use
   in the Program.
3) Close the Program Cost Sheet when you are done making modifications, then navigate to the
   Summary node to view the new Program data.

Setting up the Company Cost Sheet
The company cost sheet can be setup to rollup project or shell cost data across all company
project or shells.

Create a company cost sheet
Company cost sheet will not be auto-created. The company administrator must create one. Cost
sheets are added by default.

To create a company cost sheet
1) In User Mode, navigate to Company > Cost Manager> Cost Sheet. The Cost Sheet log
   opens.
2) Click New. Once a cost sheet has been created it cannot be deleted.

Modify company cost sheet default view
The company cost sheet Properties window offers two options regarding how the cost sheet will
appear when it is first opened. These options control how the company cost sheet opens for all
users.

To modify the company cost sheet default view
1) Open the company cost sheet Properties window (click the Properties button from the log
   toolbar, or open the cost sheet and click File > Properties).
2) On the General tab, you may choose either or both of the Default View checkbox options:
   - Open in maximized view: when the sheet is opened, it will automatically open maximized,
     or full-screen
   - Open in split mode: when the sheet is opened, it will automatically open as split (same as
     clicking the Split button)
   If these options are not selected, the company cost sheet will open by default to a size slightly
   smaller than the Unifier screen, and not split.

Add Company Cost Sheet Columns
Cost sheet columns can be added to company cost sheets the way they are added to cost
templates. Predefined data sources at project or shell (WBS) level will roll up to company level
automatically.
Note: Column restrictions can be added to company cost sheet columns. See Add column view or edit restrictions (on page 490).

**Company Cost Sheet Data Sources**

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Sources</td>
<td>Data from single datasources <strong>Project Cost1</strong> to <strong>Project Cost25</strong> is rolled up from project-level cost sheets. Users can also view datasources based on business process data rollup from the project-level. Following are the available datasources:</td>
</tr>
<tr>
<td>Business Process (All statuses)</td>
<td>Included in the Single Sources list are all of Cost BPs that are available for your project, and all of their terminal statuses.</td>
</tr>
<tr>
<td>AFC</td>
<td>Allowance for Change. This is a contingency value.</td>
</tr>
<tr>
<td>Funded Records</td>
<td>This column shows records in which the WBS code is funded, that is, spend-type business process records that consume funds.</td>
</tr>
<tr>
<td>Unfunded Records</td>
<td>This corresponds to spend-type BP records that are not funded.</td>
</tr>
<tr>
<td>Prior Forecasts</td>
<td>Prior forecasts</td>
</tr>
<tr>
<td>Yet To Buy</td>
<td>This is a portion of a commit that you still need to buy. This can be automated for uDesigner BPs (commit BPs can track YTB), In Unifier Cost Properties, you need to set &quot;Auto&quot; &quot;Transaction&quot; options, which track YTB.</td>
</tr>
<tr>
<td>Project Cost 1 to Project Cost 25 Rollup from all projects</td>
<td>Rollup from all projects</td>
</tr>
<tr>
<td>All Project Single Sources</td>
<td>All other data sources are similar to Project Cost Sheet.</td>
</tr>
<tr>
<td>Logical Sources</td>
<td>These sources are formulas.</td>
</tr>
<tr>
<td>Company Budget Remaining Balance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Company Budget Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Company Commits</td>
<td>Can be used for company commit BPs</td>
</tr>
<tr>
<td>Company Forecasts</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Company Forecasts (Unaccepted)</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Company Forecasts Variance</td>
<td>This is a place holder for a formula you create (optional).</td>
</tr>
<tr>
<td>Company Funding</td>
<td>You can roll up all project funding here.</td>
</tr>
<tr>
<td>Company Spends</td>
<td>You can rollup spends BPs here.</td>
</tr>
</tbody>
</table>
Map cost sheet column to an account code

You can define mapping between a company cost sheet column and a company account code. This allows you to link an account code with project or shell cost data that is rolled up from a project or shell cost sheet into the cost sheet.

Notes:
- You can map a cost column to more than one account code. For example, Column A can be mapped to both Account Code X and Account Code Y. This means that the Total will display for both account codes in that column. However, each account code can be mapped only once (Account Codes X and Y cannot be mapped to any other columns).
- If you remove a column from the asset sheet that is associated with an account code, the mapping will be lost.

To map a cost sheet column to an account code

1) In User Mode, navigate to the company cost sheet.
2) Open the Properties window and click the Options tab.
3) Click Add. The Add Mapping window opens.
4) Complete the window:
   - Column Name: Company Cost Sheet Column drop-down will show list of all columns that are defined on the cost sheet.
   - Account Code: Click Select. A picker window opens displaying active codes from the accounts sheet. Select a code and click Open.
   - Account Name: This field is populated with the name of the account code chosen in the previous field, as defined in the accounts sheet.
5) Click OK to save the Add Mapping window.
6) Click Add to add additional mapping if necessary.
7) Click OK to save and exit the Properties window.

Once mapping is complete, data from the company cost sheet (which reflects data rolled up from project or shell cost sheets) will be rolled up to the Accounts Sheet under the Projects data source. Only the total value will be rolled up. If the Total value in the cost sheet column changes, the change is reflected on the accounts sheet.
**Unifier Administration Guide**

**Note**: The process used to update the accounts sheet with mapped cost sheet data runs in the background. After mapping a cost column to the accounts sheet, or updating the cost sheet data, the change may not reflect in the accounts sheet immediately.

**To modify mapping**
In the Properties window, Options tab, select a mapping and click Modify. You can make changes in the Add Mapping window.

**To remove mapping**
In the Properties window, Options tab, select a mapping and click Remove. This removes the mapping. Data will no longer roll up to the accounts sheet.

**Setting up a Company Accounts Sheet**

The company accounts sheet is used to track company level accounts information, such as assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using account codes instead of WBS codes.

Account codes are independent of WBS codes, but are similar in structure format. Company level business processes can be designed in uDesigner to roll up to the accounts sheet (line items are associated with account codes).

**How to set up a company accounts sheet**

**Before you begin**: A Company Account code attribute form must be deployed in uDesigner. This is used as the detail form for creating account codes (rows) on the accounts sheet. There is no default form available. The design also includes creating an account code picker, which can be used on BP forms used with the accounts sheet, and for mapping account codes to project or shell cost sheet columns.

**Step 1**: Deploy the company Account Code attribute form in uDesigner, similar to other design deployment in uDesigner.

**Step 2**: Grant Accounts Sheet permissions.

**Step 3**: Create a company level accounts sheet. There is one accounts sheet per company. There is no template for an accounts sheet. After creation, you add columns and rows. The columns can be formulas, they can roll up data from company cost (accounts) business processes, or they can roll up asset data, project or shell cost data, or resource data. Adding rows to the accounts sheet creates the account codes that are used. You need to activate the account codes after adding the rows.

**Optional steps**: To roll up transactions to the accounts sheet, you must create and set up company-level cost business processes (also known as an account type business process). These BPs use account codes rather than the WBS codes used in project or shell level cost BPs. These are discussed in the Business Process sections. Other options assume that you have configured and set up an Assets Sheet (for rolling up asset data).
Import Company Account Code Attributes Form

To import Company Account Code Attributes form, see the instructions in the topic Importing and Deploying a Design (on page 273).

Create a company accounts sheet

You can create a accounts sheet to create new company account codes and capture and view company level cost.

To create an accounts sheet

1) In User Mode, go to the Company Workspace tab and click Cost Manager > Accounts Sheet in the left Navigator. The Accounts Sheet log opens. You can have one accounts sheet per company.
2) Click New. The Properties window opens.
3) Complete the General tab.
   - **Title**: This will be displayed in the log
   - **Description**: Enter an optional description
   - **Display Mode**: Choose Flat or Tree. Account codes are segmented, similar to WBS Codes. You can switch between Flat or Tree at any time. The same data is displayed in Tree or Flat structure.
   - **Default View**: You may choose either or both of the Default View checkbox options:
     - **Open in maximized view**: when the sheet is opened, it will automatically open maximized, or full-screen
     - **Open in split mode**: when the sheet is opened, it will automatically open as split (same as clicking the Split button)

   If these options are not selected, the accounts sheet will open by default to a size slightly smaller than the Unifier screen, and not split. The window can be resized by clicking the Minimize or Maximize/Restore buttons in the upper right corner of the window, or by dragging the edges of the window to the size that you need.
4) Click OK. The new accounts sheet appears in the log.

To open the company accounts sheet

1) In User Mode, go to the Company Workspace tab and click Cost Manager > Accounts Sheet in the left Navigator.
2) Select the accounts sheet in the log and click Open, or double-click the sheet to open it. The Accounts Sheet opens. You can do the following:
   - Add rows (account codes) or columns
   - Resize the window as needed (click and drag the sides)
   - Split the screen vertically, which is useful for viewing columns or entering data while keeping the account codes in view (click the Split button)
Add a column to an accounts sheet

You can add as many columns as necessary to the accounts sheet. There are two default columns: Company Account Code and Company Account Name. You can add columns for formulas, for transaction data from company level cost business processes (account type), or to roll up data from project or shell cost sheets, asset sheets, or resource actuals.

To add a column

1) Open the accounts sheet.
2) Click the Columns button. The Columns log opens.
3) Click New. The Column Properties window opens.
4) Complete the columns log as described in the following table.
5) Click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name is populated with the data source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Click the drop-down and choose the data source for the column. Options include:</td>
</tr>
<tr>
<td></td>
<td>Single Sources:</td>
</tr>
<tr>
<td></td>
<td>▶ Company account type BPs, listed by name and status. These are company level cost BP's of subtype line items with accounts code or line items with asset code.</td>
</tr>
<tr>
<td></td>
<td>▶ Projects/Shells (WBS): Data is rolled up from project or shell cost sheets into the company cost sheet, based on the mapping of cost sheet columns and account code.</td>
</tr>
<tr>
<td></td>
<td>▶ Assets: Data is rolled up based on the mapping between asset sheet columns and account code.</td>
</tr>
<tr>
<td></td>
<td>▶ Resource Actuals: Data is rolled up from company level time sheet records.</td>
</tr>
<tr>
<td></td>
<td>Logical Sources:</td>
</tr>
<tr>
<td></td>
<td>▶ Accounts Code 1 through 25. You can use these to create a formula or manual entry column. These are reportable.</td>
</tr>
<tr>
<td>Entry Method</td>
<td>Select one of the options (options available are dependent on the data source; applicable when a Logical data source is selected):</td>
</tr>
<tr>
<td></td>
<td>▶ Manual: User enters data directly into an accounts sheet cell</td>
</tr>
<tr>
<td></td>
<td>▶ Formula: Can create a formula from other accounts sheet columns</td>
</tr>
<tr>
<td>Data Format</td>
<td>Choose Currency (base currency) or Percentage (%)</td>
</tr>
<tr>
<td>Display Mode</td>
<td>Show or Hide the column from user view</td>
</tr>
<tr>
<td>Column Position After</td>
<td>Select the column after which you want the current column to appear</td>
</tr>
</tbody>
</table>
To roll up project or shell cost sheet data to the accounts sheet
1) Be sure the project or shell cost sheet data rolls up to a company cost sheet column, using a data source Project/Shell Cost 1 through 25 for the cost sheet column.
2) Map the company cost column to an account code. (In the company cost sheet Properties window, Options tab. See *Map cost sheet column to an account code* (on page 499).)
3) Roll up the mapped company cost column data to the accounts sheet column, choosing *Projects/Shell* data source. The column will show the Total of the company cost column.

As project or shell level transactions take place, the company cost column will reflect the changes, which in turn will roll up to the accounts sheet.

To roll up project or shell asset sheet data
1) Map the asset sheet column to an account code. See *Setting Up the Asset Manager* (on page 429).
2) Roll up the mapped asset data to the accounts sheet column, choosing *Assets* data source. The column will show the Total of the asset column.

*Note:* The process used to update the accounts sheet with mapped cost or asset sheet data runs in the background. After mapping a cost or asset column to the accounts sheet, or updating the cost or asset sheet data, the change may not be reflected in the accounts sheet immediately.

### Adding and Managing Accounts Sheet Rows

Regardless of the order you add or import rows, they are automatically sorted alphanumerically by account code.

**Add rows to the accounts sheet**

You can add account codes to the accounts sheet manually or by importing.

**To add a row to the accounts sheet manually**
1) Open the Accounts Sheet.
2) Click the *Add Rows* button.
3) Complete the *Account Code Details* form. This is the attribute form will vary based on your company’s design. Account codes are built like WBS codes, from segments that can be text fields or pulldown menus.
4) Click *OK*.

**Delete accounts sheet rows**

You cannot delete a row if it contains line item or rolled-up data, or if the code is mapped to a cost or asset sheet column.

**To delete rows from the accounts sheet**
1) Open the accounts sheet.
2) If you are using a tree structure, click the plus (+) next to segment rows (shaded blue) to view account code rows.
3) Select a checkbox next to the account code to be deleted.
4) Click the **Delete Rows** button.
5) Click **Yes** to confirm.

**Import account sheet rows**

**Step 1: Export template**

a) Open the accounts sheet.
b) Click the **Export** button and choose **Account Codes**.
c) In the File Download window, click **Save**. Enter a file name, browse to where you want to save the file, and click **Save**.

**Step 2: Edit Template in Excel**

a) Open the CSV file you just exported.
b) If the accounts sheet already contains rows, they will be listed. Note the format and structure.
c) Delete any existing rows.
d) Enter new account codes into the columns and save the file.

**Step 3: Import the CSV file**

a) On the Account Sheet toolbar, click **Import** and choose **Account Codes**.
b) In the Upload window, browse to and add the CSV file.
c) Click **OK**. After the import, the accounts sheet will show the new rows. Rows are automatically alphabetically by account code (adjusts for tree or flat structure).

**Activate an account code**

If an account code is inactive it should still be displayed on accounts sheet but should not be available through an account code picker.

**To activate or deactivate an account code**

1) Open the Accounts Sheet.
2) Click the **Account Status** button. The Account Code Status window opens.
3) Select one or more account codes and click **Activate** or **Deactivate**.

**Modify accounts sheet default view**

The accounts sheet Properties window offers two options regarding how the sheet will appear when it is first opened. These options control how the sheet opens for all users.

**To modify the accounts sheet default view**

1) Open the accounts sheet Properties window (select the sheet and click the **Properties** button from the log toolbar, or open the sheet and click **File > Properties**).
2) On the **General** tab, you may choose either or both of the **Default View** checkbox options:
   - **Open in maximized view**: when the accounts sheet is opened, it will automatically open maximized, or full-screen
   - **Open in split mode**: when the sheet is opened, it will automatically open as split (same as clicking the **Split** button)
If these options are not selected, the accounts sheet will open by default to a size slightly smaller than the Unifier screen, and not split.

**Setting up the Funding Manager**

The Funding Manager helps you to keep track of where project or shell funding comes from and how it is being spent. The Funding Manager is available in standard projects and WBS shells. Use the Project or Shell Funding sheet to specify the appropriation and assignment of funds from each funding source. You can automate fund appropriation and assignment when used with cost business processes.

Sometimes, it may be necessary to allocate specific funds to use on a particular contract, and have a means to control consumption on the invoices created against that contract. This can be done through commitment-level funding. A commitment funding sheet is created for each base commit that has been designed for commitment funding. You allocate funds from the project or shell funding sheet to the commitment funding sheet. This sheet works in conjunction with the Schedule of Values (SOV) sheet to track base commit and change commit line items and balances.

**Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding Sheets**

The first step to setting up funding is to create and set up a company funding sheet, where individual funding sources are maintained.

For example, a corporation’s funding sources may include different types of corporate accounts. For municipal or educational facilities, funds may come from bond measures, grants, donations or other sources. All of these funding sources will be listed and tracked on the company funding sheet. As funds are consumed via business processes or manually in individual project or shells, this data is rolled up to the company funding sheet.

Project or shell funding sheets track how your company’s funding is being spent on each project or shell. It tracks individual transactions, which are rolled up to the company funding sheet. All project or shell funding sheets must be created based on a funding template.

If you are using commitment funding, you will start with a commitment funding template, which is used to create the commitment funding structure within a project or shell. As base commits (that are designed for commitment funding in uDesigner) are routed and approved, a commitment funding sheet is created, based on this structure, for each base commit record. This sheet works with the SOV sheet to track and control funding of each SOV line.

**How to set up the Funding Manager**

The following is an overview of the steps needed to set up funding for use in projects and shells, plus the steps needed to set up the optional commitment level funding. Details for each step are in the sections that follow, unless otherwise noted.

**Setting up company and project/shell funding**

**Before you begin.** The fund attribute form can be designed in uDesigner. This will be used as the Fund Details window when adding new funds to the company funding sheet, or viewing fund properties. If your company does not design a fund attribute form, a simple default form is used.
**Import and set up fund business processes.** You can use business processes for fund allocations, fund assignment (also known as consumption; enabled on spends type business processes), and fund credits (also enabled on spends business processes). This step can be done at any point in this general procedure. Be sure you know which funding business processes you will be using for the project or shell before defining funding rules on the project or shell funding sheet.

**Step 1: Import and deploy the fund attribute form.** Once imported, the fund attribute form becomes the Fund Details window in Unifier, used to create and manage fund codes in the company funding sheet. When designing the form, you can also design the fund picker, which is used to add funds to business processes and project/shell funding sheets, as well as "Find" on the picker. This is an optional step. If you do not create a fund attribute form, a default fund code form and fund picker will be used.

**Step 2: Create and set up the Company Funding Sheet (User Mode).** You define the funds in the company funding sheet, which can then be used for funding project or shells. Only one company-level funding may be created per company. All project or shell funding sheets refer to the company funding sheet.

**Step 3: Create and set up Project/Shell Funding Template (Administration Mode).** The funding template is used to create project or shell funding sheets.

**Step 4: Create and set up the Project/Shell Funding Sheet (User Mode).** The project or shell funding sheet is based on the funding template. (You can also define the project/shell funding sheet in a project or shell template.) The funding sources available for the project or shell are defined in the company funding sheet.

**Step 5: Define funding assignment rules.** Funding assignment rules can be defined in the project/shell funding sheet or the funding template (or both). You can also determine the order in which to consume funds if you will be using automatic fund assignment from business processes. (This step can be done any time after creating the funding template. If you define assignment rules in a template, they will be carried over to the sheets created from them.)

**Additional steps: Create funding rules in the rules engine.** You can create funding rules in the rules engine that can help you manage your funds and fund balances. The most common rule is to keep your company fund balances from becoming less than zero. Configure permissions. As you create funding sheets and set up funding business processes, remember to configure the permissions to go with them. Refer to the *Unifier Reference Guide* for funding permissions.

**Setting up commitment level funding**

Commitment level funding is optional. To set it up, first set up funding in the project or shell, then follow these additional steps.

Commitment funding works in conjunction with general spends and payment applications SOV sheets.

**Before you begin.** Be sure that the project/shell funding has been set up, with funds allocated and available on the project/shell funding sheet. Data sources are available for project/shell funding sheets (and company funding sheets) to track funding that is assigned for specific base commits. Also, be sure you have added the data source "Scheduled Value" to the SOV structure for the project or shell. Commitment funding uses the SOV to track base commit and change commit amounts, and uses the Scheduled Value column to track remaining balances.
Import and set up business processes for commitment funding. In addition to business processes that are used for project/shell funding, you can design business processes for use with commitment funding. In uDesigner, commitment funding is enabled on the base commit (and linked change commit); automatic generation of an SOV must also be enabled. Then, the ability to create (and later access) the commitment funding sheet can be enabled on the form. Be sure the spends business process that is linked to the base commit has been enabled to consume funding.

**Step 1: Create and set up Commitment Funding Template (Administration Mode).** This template is used to create a commitment funding structures in the project or shell, which in turn is used to create the individual commitment funding sheets for each base commit record. You can add columns to the template, but not rows.

**Step 2: Define funding assignment rules.** This is done in the Assignment tab of the Properties window. Assignment rules can be defined in the commitment funding template, structure or sheets. (This step can be done any time after creating the funding or commitment funding template. If you define assignment rules in a template, they will be carried over to the structure and sheets created from them.)

**Step 3: Create Commitment Funding Sheet Structure (User Mode).** Structures are created at the project level in user mode from a commitment funding template. When commitment funding sheets are created from base commit records, this default structure is used. You can also create a commitment funding structure in a project or shell template.

**Step 4: Create individual commitment funding sheets.** This is done automatically the first time you click the Funding button on a base commit business process form (this button becomes available on specific steps as designed in uDesigner). After creation, the commitment funding sheet is available for viewing or modification by clicking the Funding button on the base commit or associated change commits, or from the Commitment Funding log itself.

**Additional steps: Configure permissions.** Module permissions must be granted to the commitment funding template, to the commitment funding sheet in a project or shell template (if using), to commitment funding sheet in a project or shell (in order for the node to be visible). In addition, record level permission must be granted to individual commitment funding sheets. By default, the owner of the base commit will have permissions to the sheet. Additional users must be granted view or edit permissions. Refer to the Unifier Reference Guide for general funding permissions. Sheet permissions are granted User mode. **Additional assignment details.** After the commitment funding sheet and SOV sheet are created, additional funding assignment details can be defined on the Fund Assignment window (accessed from the SOV sheet or commitment funding sheet).

**Importing Fund Attribute Form**

The Fund Details form can be configured by creating a Fund Attribute form in uDesigner. With the import of this attribute form, you are also importing designs for the fund picker, which is used to add funds to business processes and project/shell funding sheets, as well as "Find" on the picker. If you do not create a fund attribute form, a default fund code form and fund picker will be used. Only one fund attribute form may be created and imported per company.

**Notes:**
• Use caution when modifying and re-importing an attribute form. For example, if you make changes to a data definition, such as Fund Category after it is being used in the funding sheet, the system may not see the new data definition and will produce an error.
• Oracle Primavera strongly recommends that you use uStage Environment to test out uDesigner business processes and attribute forms before deploying to Unifier.

To import a fund attribute form into Unifier production, see the instructions in the topic Importing and Deploying a Design (on page 273).

Creating a Company Funding Sheet

The Company Funding Sheet tracks all sources of funding across all projects or WBS shells. You create only one sheet per company. Funding sources that are made available at project or shell sheet level or commitment level are rolled up to the company sheet, which maintains the overall fund information.

Once created, the company funding sheet can be edited, but not deleted. The company funding sheet must be created before creating individual project or shell funding sheets.

To create the company funding sheet
1) In User Mode, go to the Company Workspace tab and click Cost Manager > Funding in the left Navigator. The Company Funding Log opens.
2) Click New. The Properties window opens.
3) Enter a Title and Description.
4) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested rows).
5) Click OK. The funding sheet is listed in the Company Funding log.

Add columns to the company funding sheet

The columns on the company funding sheet are used to track project/shell level funding, as well as commitment level funding if you are using it, and keep track of fund balances.

To add a column to the company funding sheet
1) From the Company Funding log, select the company funding sheet and click Open (or double-click on the company funding sheet). The Company Funding Sheet window opens.
2) Click the Columns button. The Column Log window opens.
3) Click New. The Column Properties window opens. Complete the Properties window as described in the following table.
4) Click **OK** to add the new column to the company funding sheet.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name you choose will appear as the column header. You may manually enter a column name, or, if you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
<tr>
<td><strong>Datasource</strong></td>
<td>All columns must be associated with a data source. The data source that you choose will determine which of the following options are available. The types of Data sources available are as follow.  &lt;ul&gt;   &lt;li&gt;&lt;strong&gt;Single Sources&lt;/strong&gt;: These values roll up from a single, defined source, such as a business process or a system defined source.&lt;/li&gt;   &lt;li&gt;&lt;strong&gt;Logical Sources&lt;/strong&gt;: These include user-defined Manual Entry or Formula columns.&lt;/li&gt;  &lt;/ul&gt;</td>
</tr>
</tbody>
</table>
Data sources that contain funding sources and consumption information; that is, Fund subtype of Cost business processes, which allocate funding, Spends business processes that consume funding, and Commit business processes that trigger commitment funding, if used.

- **Business Processes**: List of cost-type business processes that include funding data definitions.
- **Project/Shell Funding**: Sum of all funding sources at project or shell level for each project or shell, as rolled up from each individual project or shell funding sheet. The information that gets rolled up to this column is dependent on the project or shell funding sheet setup for each project or shell.
- **WBS Funding**: Sum of all funding sources at WBS level for each project or shell, rolled up from each individual project or shell funding sheet. The information that gets rolled up to this column is dependent on the project or shell funding sheet setup for each project or shell.
- **Manual Funding by project/shell**: Sum of all project or shell-level funds that are allocated at project or shell level manually.
- **Manual Funding by WBS**: Sum of all funds that are allocated at WBS level manually.
- **Commitment Funding**: Sum of all funds that are allocated at the commitment level (if used) for each project or shell.
- **Records Funded at Project/Shell Level**: Sum of all records that are funded at project or shell level. These are records that have already ended their workflow or hit terminal status.
- **Records Funded at WBS Level**: Sum of all records that are funded at WBS Level. These are records that have already ended their workflow or hit terminal status.
- **Records Funded at Commitment Level**: Sum of all records that are funded at the commitment level (spends BPs that are linked to base commits enabled for commitment funding). These are records that have already ended their workflow or hit terminal status.
- **Transient Records Funded at WBS Level**: Sum of all in-process records that are funded at WBS Level. These are records that are currently in process.
- **Transient Records Funded at Project Level**: Sum of all records that are funded at project or shell level. These are records that are currently in process.
- **Transient Records Funded at Commitment Level**: Sum of all in-process records that are funded at the commitment level.
- **Fund1 to Fund25**: Generic data sources that can be used for manual entry or formula columns to make the values.
| Logical Sources | Logical sources include the following data sources.  
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
|  | **Company Funding**: This is commonly the column to use to manually enter the starting amount for each fund.  
|  | **Company Fund1 to Fund25**: Generic data sources that can be used for manual entry or formula columns to make the values reportable.  
| Entry Method | The following options are applicable for logical data sources.  
| --- | --- |
|  | **Manual Entry**: Choose Direct Entry into Cell to allow entry directly into the cell, or Line Item Content to allow data entry through a line item window.  
|  | **Formula**: Values are calculated based on a specified formula entered for the column. Formulas can include the values of other columns. Click the Create button to create the formula.  
| Data Format | The following options are applicable for Manual Entry or Formula columns.  
| --- | --- |
|  | **Currency**: right-aligns column contents and includes a currency symbol, a thousands separator and two decimal places  
|  | **Percentage**: right-aligns the contents and includes a percentage symbol  
| Display Mode | The following options refer to whether the column is displayed on the sheet.  
| --- | --- |
|  | **Show**: Choose this option to allow users to view this column.  
|  | **Hide**: Hidden columns are active but not displayed and can be accessed by users with "create" permission on the funding sheet.  
| Total | These options determine what will appear in the "Total" (bottom) row for the column:  
| --- | --- |
|  | **Blank**: The total of this column is not applicable and will not appear on the sheet. Choose this column for percentage columns and other columns where it does not make sense to display the sum total.  
|  | **Sum of All Rows**: The sum total of the column values is displayed.  
|  | **Use Formula Definition**: For formula columns; the formula will be applied to the "Total" row in the same way it is applied to other rows in the column.  
| Column Position After | The new column will be inserted after the column selected.  

Note: As funding is consumed from individual funds, the new balance will not be reflected on the company funding sheet by default. You can track your fund balances by adding columns to roll up funding assignments from business process or by manual assignments from the project/shell funding sheets, and commitment funding sheets if used, then adding a formula column to keep track of the balance. You can also use the rules engine to create a rule to keep this balance from going less than zero (or another amount).

Add rows (Funds) to the company funding sheet

Each row of a Company Funding Sheet represents an individual source of funds. The funds defined here are used in individual project or shell funding sheets.

Note: Once fund assignments have been made against them on project or shell funding sheets, you will not be able to edit company funding sheet rows.

To add company funding sheet rows (funds)

1) From the Company Funding Sheet, click **Rows**.
2) Click **Add Row**. The Fund Details window opens. If you have imported a Fund Attribute form, this will be displayed as the Fund Details window.
3) Complete the Fund Details window.

   The table below describes the fields on the default Fund Details window. If your company has imported a Fund Attribute form, the fields you see may differ greatly.
4) Click **OK**. The fund appears as a row on the Funding Sheet in alphabetical order.

### To edit a row
1) From the Funding Sheet, click on the **Rows** button.
2) Click on a row title. The Fund Detail window opens.
3) Make changes and click **OK**.

### To delete a row
1) From the Funding Sheet, click on the **Rows** button.
2) Click the selection box next to the row or rows to be deleted.
3) Click the **Delete Rows** button. The selected rows will be deleted.
4) Click **Close** to close the window and refresh the Funding Sheet window.
Creating a Project or Shell Funding Sheet Template

Funding templates are created and setup in the Templates node, and are used to create individual project or shell funding sheets. They can also be used to create a funding sheet in a project or shell template.

Setting up the funding template consists of adding columns, which correspond to the data sources (e.g., business process transactions, formulas, values you enter manually, etc.) that you wish to track for each funding source. It can also include adding rows (funds).

You can specify fund assignment rules in the template or individual project/shell funding sheets. See Defining Fund Assignment Options for Project/Shell Funding (on page 520).

To create a new funding sheet template

1) In Administration mode, go to the Company Workspace tab and click Templates > Funding > Funding Sheet in the left Navigator.
2) Click the New button. The Properties window opens.
3) Enter a Title and Description.
4) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested rows).
5) Click OK. The template is listed in the log.

After creating the funding template, you can open the sheet and define columns and add funds (rows).

Add a column to the funding template (or project/shell funding sheet)

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets created in project or shell templates.

Funding columns specify the data sources (business process transactions, formulas, values entered manually, etc.) that will be displayed on the project or shell funding sheet. Default columns on funding sheet are Fund Code and Fund Name. If a Fund Attribute form has been imported, in which the label of Fund Code data element and Fund Name data element were modified, then the new labels will be displayed as column headers.

Note: Some project funding columns require assignment information at the project level and cannot be created in the template (for example, Consumed Funds, WBS Funding).

To add a funding column

1) Open the funding sheet or template:
2) Open the funding template and click the Columns button. The Column Log window opens, displaying the list of existing columns.
3) Click New. The Column Properties window opens.
4) Complete the Column Properties window as described in the table below.
5) Click **OK** to add the new column.

![Image of Column Properties window]

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name you choose will appear as the column header. You may manually enter a column name, or, if you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
</tbody>
</table>
| **Datasource**| All columns must be associated with a data source. The data source that you choose will determine which of the following options are available. The types of Data sources available are:  
**Single Sources**: These values roll up from other sources. These include cost type business processes, some pre-defined cost columns.  
**Logical Sources**: These include user-defined Manual Entry or Formula columns. |
| **Single Source**| Data sources that contain funding sources and consumption information; that is, Fund subtype of Cost business processes, which allocate funding, Spends business processes that consume funding, and Commit business processes that trigger commitment funding, if used.  
- **Business Processes**: List of cost-type business processes that include funding data definitions.  
- **Manual Funding by WBS**: Sum of all funds that are allocated at WBS level manually.  
- **Commitment Funding**: If commitment funding is used, this datasource tracks funds that are allocated across base commit |
and change commit business process records enabled for
commitment funding. Reflects sum of Funding Across All Funds
and Funding By Discrete Funds datasources on commitment
funding sheets. Click the link to view cell details.

- **Records Funded at Project/Shell Level**: Sum of all records
  that are funded at project or shell level. These are records that
  have already ended their workflow or hit terminal status.

- **Records Funded at WBS Level**: Sum of all records that are
  funded at WBS Level. These are records that have already
  ended their workflow or hit terminal status.

- **Records Funded at Commitment Level**: Sum of all records
  that are funded at the commitment level (spends BPs that are
  linked to base commits enabled for commitment funding). These
  are records that have already ended their workflow or hit
  terminal status.

- **Transient Records Funded at WBS Level**: Sum of all records
  that are funded at WBS Level. These are records that are
  currently in process.

- **Transient Records Funded at Project Level**: Sum of all
  records that are funded at project or shell level. These are
  records that are currently in process.

- **Transient Records Funded at Commitment Level**: Sum of all
  in-process records that are funded at the commitment level.

### Logical Sources

**Logical Sources include:**

- **Project/Shell Funding**: Sum of all funding sources at project or
  shell level. The information that gets rolled up to this data source
  is dependent on project or shell Funding Sheet setup for each
  project or shell.

- **WBS Funding**: Sum of all funding sources at WBS level. The
  information that gets rolled up to this data source is dependent
  on project or shell Funding Sheet setup for each project or shell.

- **Manual Funding by Project/Shell**: Sum of all funds that are
  allocated at project or shell level manually.

- **Fund1 to Fund25**: Generic data sources that can be used for
  manual entry columns to make the values reportable.

### Entry Method

This is applicable for logical data sources.

**Manual Entry**: Choose Direct Entry into Cell to allow entry directly
into the cell, or Line Item Content to allow data entry through a line
item window.

**Formula**: Values are calculated based on a specified formula
entered for the column. Formulas can include the values of other
columns. Click the Create button to create the formula.

### Data Format

Applicable for Manual Entry or Formula columns:

**Currency**: right-aligns column contents and includes a currency
symbol, a thousands separator and two decimal places
### Display Mode

<table>
<thead>
<tr>
<th>Percentage: right-aligns the contents and includes a percentage symbol</th>
</tr>
</thead>
</table>

### Total

<table>
<thead>
<tr>
<th>Determines what will display in the &quot;Total&quot; (bottom) row for the column:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Blank</strong>: The total of this column is not applicable and will not display on the cost sheet. Choose this column for percentage columns and other columns where it does not make sense to display the sum total.</td>
</tr>
<tr>
<td><strong>Sum of All Rows</strong>: The sum total of the column values is displayed.</td>
</tr>
<tr>
<td><strong>Use Formula Definition</strong>: For formula columns; the formula will be applied to the &quot;Total&quot; row in the same way it is applied to other rows in the column.</td>
</tr>
</tbody>
</table>

### Column Position After

| The new column will be inserted after the column selected |

---

**Add a funding column to project or shell cost sheet**

Cost sheets can show fund related information as part of Funding Manager solution. The following section discusses funding columns you can add to the project or shell cost sheet.

**To add a funding column to the Project/Shell Cost Sheet**

1. Open the **Cost Sheet** cost sheet and click the **Columns** button. The Column Log window opens.
2. Click **New**. The Column Properties window opens.
3. Complete the Properties window. For Data Source, choose from the following:
   - **Single sources**: Data sources that contain fund related information:
     - **Funded Records**: Sum of all Records that are funded at WBS Level.
     - **Unfunded Records**: Sum of all Records that are not funded at WBS Level.
     - **Manual Funding by WBS Level**: Sum of all funding sources that are allocated at WBS level manually.
   - **Logical sources**: Data sources that are available at project or shell level:
     - **WBS Funding**: Sum of all funding sources at WBS level. The information that gets rolled up to this data source is dependent on Project/Shell Funding Sheet setup for each project or shell.
**Unifier Administration Guide**

---

**Note**: You cannot select this data source unless a funding source is selected under "Processes Contributing Assignable Funds" for WBS level. This is located under Project Funding sheet > Properties > Assignment Tab.

4) Click **OK** to add the new funding column to the project or shell cost sheet.

**To edit a column**

1) From the Columns Log window, select a column and click **Open**. The Column Properties window opens.
2) Make edits as necessary and click **OK**.

**Note**: Changing entry methods. Although it is possible to change the entry methods for a column (for example, from "Line item content" to "Direct entry into cell"), use caution when doing so if you have already entered values in the column cells. For example, if you change from line item entry to direct cell entry, the Amount value shown in the cell will appear correctly, but will be an editable direct entry amount, and detailed line item information will be lost.

**To move a column**

From the Columns Log window, select a column to move, then click **Move Up (Left)** or **Move Down (Right)**. The order in which the columns appear in the Log window is the order (from left to right) that they appear on the sheet.

**To delete a column**

Select a column from the Columns Log and click **Open** to open the Column Properties window, and then click **Delete**. The column will be deleted.

**Note**: If the column is being used in a formula in another column, you must remove the column from the formula before you can delete it. If the column contains a cell with line item data, you must first remove each line item before it can be deleted.

**Add rows to the funding template (or project/shell funding sheet)**

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets created in project or shell templates.

Each row of a project or shell funding sheet represents an individual source of funds. The funds added here are funds that are active under the company funding sheet.

**Note**: Once fund assignments have been made against them, you will not be able to edit project or shell funding sheet rows. To view the status of a fund, click the **Fund Status** button on the tool bar.
To add rows (funds) to the funding template or project/shell funding sheet

1) Open the funding sheet or template.
2) Click **Rows**, and then click **Add Row**. The Fund Detail window opens. If you have imported a Fund Attribute form, a customized Fund Detail window will open.
3) Select a fund from the fund picker (or Fund Source field).
   You can search for a specific fund in the fund picker by clicking the Find button and opening the Find form. Enter search criteria and click Search. This limits the number of funds that are displayed to those that match the search criteria.
4) You can search for a specific fund in the fund picker:
   a. Click the Find button. The Find window opens. The window that opens will depend on the design in uDesigner.
      - If an attribute form is not defined, the default Find window will allow you to search by Fund Code or Fund Name.
      - If an attribute form is defined, the Find window can also be designed in uDesigner, and you may have additional fields to search by.
   b. Enter search criteria and click Search. This limits the number of funds that are displayed to those that match the search criteria.
5) Click **OK**. The fund appears as a row on the Funding Sheet. Funds are displayed in alphabetical order on funding sheet.
6) To view fund details click on a fund under fund code column. If you import a Fund Attribute form then you will see customized detail form instead of a generic fund detail form.

Creating a Project/Shell Funding Sheet

The Project/Shell Funding Sheet tracks how funding is being allocated and consumed at the project or shell level. Project or shell funding sheets work in conjunction with the company funding sheet. Allocating funding sources at project or shell level can be done manually, or through a business processes.

A Funding Template and Company Funding Sheet must be complete before you can create a project or shell Funding Sheet.

To create the project or shell funding sheet

1) In User Mode, open the project and click **Cost Manager>Funding** in the left Navigator. The Project/Shell Funding Log opens.
2) Click **New**. The Select Template window opens.
3) Select a template and click **OK**. Click **Yes** to confirm. The Project/Shell Funding Sheet displays in the log. You can use the funding sheet as it is or set it up to meet the needs of the project or shell.

Add columns to the project/shell funding sheet

Columns are added to a Project/Shell Funding Sheet in the same way as they are added to a Funding Template. See *Add a column to the funding template (or project/shell funding sheet)* (on page 514).
Add project or shell funds (rows)

Rows are added to a Project/Shell Funding Sheet in the same way as they are added to a funding template. Add rows to the funding template (or project/shell funding sheet) (on page 518)

To edit a row
1) From the Funding Sheet, click the Rows button.
2) Click a row title. The Fund Detail window opens.
3) Make changes and click OK.

To delete a row
1) From the Funding Sheet, click on the Rows button.
2) Click the selection box next to the row or rows to be deleted.
3) Click the Delete Rows button. The selected rows will be deleted.
4) Click Close to close the window and refresh the funding sheet window.

Defining Fund Assignment Options for Project/Shell Funding

The following options are available as part of assignment rules at project or shell level and WBS level. These can be defined in a funding template, or individual project/shell funding sheets.

Project and WBS Level: Specify the sources of funds for this project or shell, either manual or via fund appropriation business processes.

Assignment Levels and Rules: For each funding business process (and each status) that has been set up for the project or shell, you specify manual, Auto Order, or Auto Ratio:

For details, see the following procedures.

Set up funding assignment options

After you create a project or shell funding sheet, you can set up assignment options. This includes specifying whether manual assignment is allowed; defining the business processes that can be used to assign funds to project or shells or to specific WBS codes; and defining assignment levels.

Project Level and WBS Level: Specify how funds can be added for this project or shell. This can be Manual (appropriate funds manually from the company funding sheet, and/or through funding appropriation business processes that appropriate company funds for the project or shell.

You can define funding appropriations at the project level (not associated with specific WBS codes), and at the WBS level (funding is specified per WBS code). You can "mix and match" for each project, with some business processes using project level funding, and others WBS level. Manual fund appropriations can be done at both levels.

Assignment Levels and Rules: For each funding business process that has been set up for the project or shell, you specify manual, Auto Order, or Auto Ratio. You also choose to assign funds at the Project Level (funding is consumed based on the total of the spends business process, providing greater flexibility for fund assignment), or WBS Level (funding is consumed per line item of a spends business process, which provides greater control over how funds are spent on each item.)
Unifier Administration Mode

- **Manual**: Funds can be manually assigned. As spends business processes (e.g., invoices or payment applications) are routed and reach specified statuses, the amounts to be funded are collected under the Unassigned total on the funding sheet. Funds are assigned manually to these spends records.

- **Auto Order**: Funds are assigned automatically when a spends business process reaches a specified status. Funds are assigned based on the fund order, which is defined on the funding sheet by clicking the Fund Assignment Order button. When funds are consumed on one fund, then the next funding source is used for funding. Once all funds are consumed, remaining spends are collected under Unassigned.

- **Auto Ratio**: Funds are assigned automatically when a spends business process reaches a specified status. Funds are assigned based on the fund ratio, which is automatically calculated based on current fund levels. Once all funds are consumed, remaining spends are collected under Unassigned.

**Note**: Be sure you have imported and set up any business processes you will be using for fund appropriation and assignment in the project or shell before setting assignment rules

### To set up fund assignment rules
1. Open the project or shell funding sheet.
2. Select the template in the log and click the Properties button.
3. Click the Assignment tab.
4. Complete the window as described in the following table.
5. Click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Funding Assignment</td>
<td>Select the Funding Assignments sources. The sources can be at the WBS level, where funds are assigned to specific WBS codes, or project or shell level, which allows project or shell level funding without assigning funds to specific WBS codes.</td>
</tr>
<tr>
<td>Project/Shell Level</td>
<td>Click Add to add project or shell level sources. Options include: Manual: Allows manual entry of project or shell fund assignments on the sheet Business Processes: Any cost type business process that is created with sub-type Line Items with Fund Code and Classification as Generic.</td>
</tr>
<tr>
<td>WBS Level</td>
<td>Click Add to add WBS level sources. Options include: Manual: Allows manual entry of WBS level fund assignments on the sheet Business Processes: Any cost type business process that is created with sub-type Line Items with both WBS Code and Fund Code and Classification as Generic.</td>
</tr>
<tr>
<td>Assignment</td>
<td>Allows you to set fund assignment rule for each spend-type business</td>
</tr>
</tbody>
</table>
Levels: process that is configured in your project or shell. The assignment level will only show those spend type business processes that consume funds. This option is available while designing spend type business process in uDesigner.

<table>
<thead>
<tr>
<th>Assignment Rules</th>
<th>Click the drop-down list and select a project- or shell-level or WBS-level rule.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project/Shell Level:</strong></td>
<td>Manual (Assign by BP Record Total): All spends are collected as Unassigned. These spends should be assigned manually to one or more funds at project or shell record Level.</td>
</tr>
<tr>
<td></td>
<td>Manual (Assign by BP Line Item): All spends are collected as Unassigned. These spends should be assigned manually to one or more funds at the project or shell line item.</td>
</tr>
<tr>
<td></td>
<td>Auto Order (Assign by BP Record Total): Funding sources are arranged in a prescribed order, and spend are assigned in that order. The assignment order is defined under project or shell Funding Sheet → Fund Assignment Order → Fund Assignment Order Window.</td>
</tr>
<tr>
<td></td>
<td>Auto Order (Assign by BP Line Item): Funding sources are arranged in a prescribed order, and spend are assigned in that order at line item level. The assignment order is defined under project or shell Funding Sheet → Fund Assignment Order → Fund Assignment Order Window.</td>
</tr>
<tr>
<td></td>
<td>Auto Ratio (Assign by BP Record Total): Funding sources are proportionally consumed until fully depleted. The fund level itself automatically defines the ratio. Once the funds are consumed, remaining spends are collected as Unassigned.</td>
</tr>
<tr>
<td></td>
<td>Auto Ratio (Assign by BP Line Item): Funding sources are proportionally consumed until fully depleted at line item level. The fund level itself automatically defines the ratio. Once the funds are consumed, remaining spends are collected as Unassigned.</td>
</tr>
<tr>
<td><strong>WBS Level:</strong></td>
<td>Manual: All spends are collected as Unassigned, and are manually assigned to one or more funds at WBS level.</td>
</tr>
<tr>
<td></td>
<td>Auto Order: Funding sources assigned to that WBS are arranged in a prescribed order, and spends are assigned in that order. Once all funds are consumed, remaining spends are collected as Unassigned. Fund Assignment Order for WBS can be defined under Cost Sheet&gt;Fund Assignment Order&gt;Fund Assignment Order Window.</td>
</tr>
<tr>
<td></td>
<td>Auto Ratio: Funding sources assigned to that WBS are proportionally consumed until fully depleted. The fund level itself automatically defines the ratio. Once all funds are consumed, remaining spends are collected as Unassigned.</td>
</tr>
<tr>
<td><strong>SOV Auto Order:</strong></td>
<td>This option indicates that the assignment should be...</td>
</tr>
</tbody>
</table>
SOV level using Auto order option. The order assignment will be defined under SOV>Fund Assignment Window.

SOV Auto Ratio: This option indicates that the assignment should be at SOV level using Auto ratio option. The ratio will be defined under SOV>Fund Assignment Window.

Set fund assignment status and order
You can control whether a fund is available when assigning funds to spend by activating or deactivating the fund at the project or shell level. Fund assignment order is required if you decide to consume funds automatically. You can also view the Fund order. This will be the order that will be used while assigning funds with Auto Order option.

Funds can be automatically consumed at project or shell level by following fund order defined under Fund Assignment Order window on project or shell Funding Sheet.

To set the fund assignment status and assignment order
1) Open the project or shell Funding Sheet.
2) Click Fund Assignment Order button on the toolbar. The Fund Assignment Order window opens showing whether funds are active or inactive.
3) Select a fund in the table, and click Activate or Deactivate. Deactivating a fund prevents it from being available when assigning funds to spend.
4) If you want to change the assignment order, select a fund and click Move Up or Move Down.
5) Click Close to exit the window.

Set fund assignment order at the WBS level
The Unassigned (WBS Level) link on the Project/Shell Funding Sheet displays the total of funds at the WBS level. Funds can be automatically consumed at WBS level by following fund order defined for each WBS Code from the Fund Assignment Order window on the Project/Shell Cost Sheet.

To set fund assignment order at WBS Level
1) Open the Project/Shell Cost Sheet.
2) Click the **Fund Assignment Order** button on the toolbar. The Fund Assignment Order window opens.

3) Select a **WBS code** from the upper pane. A list of funds that are available for this WBS will be displayed on the bottom pane.

   The bottom pane will also display assignment status of funds. You can modify assignment status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with Inactive status will not be used as part of consumption process.

4) Select a fund and click **Move Up** or **Move Down** button to change fund order.

5) If you have defined **Breakdowns** for a WBS code, then select breakdown to view funds.

### Set fund assignment order at SOV level

Funds can be automatically consumed at the SOV level by following fund order or fund ratio defined for each WBS under Fund Assignment Order window on SOV Sheet. You have ability to defined order or ratio for each SOV.

**Note**: Fund assignment details can be set on the SOV sheet when you are doing project/shell level funding as well as commitment level funding. The following procedure discusses how to do SOV Auto Order at the project/shell level. If the base commit that created the SOV has been enabled for commitment funding, then fund assignment is done at the commitment level.

### To set fund assignment order at SOV Level: For WBS—SOV Auto Order

1) Open the SOV Sheet.

2) Click the **Fund Assignment** button on the toolbar. The Fund Assignment window opens.
You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that you choose for spend under the Project/Shell Funding Sheet > Properties > Assignment Tab.

3) Select a WBS code from the upper pane.

4) Select a fund from the list and click **OK**.

   The bottom pane will also display assignment status of funds. You can modify assignment status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with Inactive status will not be used as part of consumption process.

5) Select a fund and click **Move Up** or **Move Down** button to change fund order.

6) If you have defined **Breakdowns** for a WBS code, then select breakdown to view funds.

7) To add a fund, click the **Add** button. The Add Funds window lists the funds that are available for the selected WBS Code. Select a fund from the list and click **OK**.

**To set fund assignment order and Ratio at SOV Level: For WBS—SOV Auto Ratio**

1) Open the SOV Sheet.
2) Click the **Fund Assignment** button on the toolbar. The Fund Assignment Order window opens.

3) You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that you choose for spend under Project/Shell Funding Sheet > Properties > Assignment Tab.

4) Select a **WBS** code from the upper pane. A list of funds that are available for this WBS will be displayed on the bottom pane.
   
   The bottom pane will also display assignment status of funds. You can modify assignment status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with Inactive status will not be used as part of consumption process.

5) Select a fund and click **Move Up** or **Move Down** button to change fund order.

6) If you have defined **Breakdowns** for a WBS code, then select breakdown to view funds.

7) To add a fund, click the **Add** button. The Add Funds window lists the funds that are available for the selected WBS Code. Select a fund from the list and click **OK**.

8) Select a fund and enter a % value.

---

**Creating Commitment Funding Sheet Templates**

Commitment Funding Sheet templates are created and set up in the Templates node, and are used to create the commitment funding sheet structure in a project or shell (or in a project or shell template). This structure is then used when sheets are created for individual base commit records. Setting up the commitment funding template consists of adding columns, which correspond to the data sources (e.g., business process transactions, formulas, values you enter manually, etc.) that you wish to track for each funding source.

You can specify fund assignment rules in the template, structure or individual commitment funding sheets.

**To create a new commitment funding sheet template**

1) In Administration mode, go to the **Company Workspace** tab and click **Templates > Funding > Commitment Funding Sheet** in the left Navigator.

2) Click the **New** button. The Properties window opens.

3) Enter a **Title** and **Description**.

4) Click **OK**. The template is listed in the log.

After creating the funding template, you can open the sheet and define columns.

**Add and Manage commitment funding sheet columns**

These procedures are applicable to commitment funding sheet templates, commitment funding structures created in a project or shell, commitment funding sheet structures created in project or shell templates, or individual commitment funding sheets.

Funding columns specify the data sources (business process transactions, formulas, values entered manually, etc.) that will be displayed on commitment funding sheet.

**To add a column to a commitment funding template, structure or sheet**

1) Open the commitment funding sheet, template or structure.
2) Click the **Columns** button. The Column Log window opens, displaying the list of existing columns.

3) Click **New**. The Column Properties window opens.

4) Complete the Column Properties window as described in the following table.

5) Click **OK** to add the new column.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name you choose will appear as the column header. You may manually enter a column name, or, if you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
<tr>
<td>Datasource</td>
<td>All columns must be associated with a data source. <strong>Note:</strong> In these datasource definitions, the terms All Funds and Discrete Fund refer to the fund assignment options. These options determine how the SOV lines (and therefore, the commit lines) will be funded, either automatically or manually from the entire list of funds available to the commit, or by one specific fund. (See &quot;Define commitment fund assignment details (on page 531)). The data sources available for commitment funding sheets are:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Funding Across All Funds:</strong> Use this column to enter (or calculate) the amount of each fund to allocate for this base commit record. The rows on the sheet are the funds that will be used to fund the commit. The value entered here will be the fund amount available for all commit lines that have &quot;All Funds&quot; as assignment. This can be a manual entry column, or a formula that uses another manual entry column as the basis of the formula.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Funding By Discrete Fund:</strong> This column displays the sum total of all the line items of base and change commits that are funded by a specific (or &quot;discrete&quot;) fund. This value can be used to determine the fund balance during consumption.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Records Funded Across All Funds:</strong> Reflects the total of funds consumed from records that are funded based on All Funds, whether funding is done manually or automatically.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Records Funded By Discrete Fund:</strong> Displays the total of funds consumed from records that are funded based on a discrete fund, whether funding is done manually or automatically.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Fund Balance Across All Funds:</strong> This column tracks the fund balance across all funds. The formula used is (Funding Across All Funds) - (Records Funded By All Funds).</td>
</tr>
</tbody>
</table>
|               | - **Fund Balance By Discrete Fund:** This column tracks the fund balance by specific fund chosen in the Fund Assignment window. The formula used is (Funding By
<table>
<thead>
<tr>
<th>Entry Method</th>
<th>Choose one (the options that are available are dependent on the data source chosen):</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual Entry</td>
<td>Users enter values directly on the sheet.</td>
</tr>
<tr>
<td>Formula</td>
<td>Values are calculated using the entered formula. Formulas can include the values of other columns. Click the Create button to create the formula.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Display Mode</th>
<th>This controls the display of numeric column data.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show as percentage</td>
<td>Data is displayed as %</td>
</tr>
<tr>
<td>Decimal places</td>
<td>Choose 2 to 8</td>
</tr>
<tr>
<td>Use 1000 Separator</td>
<td>Select checkbox to include a comma separator</td>
</tr>
<tr>
<td>Negative Number Format</td>
<td>Choose parentheses or minus sign</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Total</th>
<th>Determines what will display in the “Total” (bottom) row for the column:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>The total of this column is not applicable and will not display on the cost sheet. Choose this column for percentage columns and other columns where it does not make sense to display the sum total.</td>
</tr>
<tr>
<td>Sum of All Rows</td>
<td>The sum total of the column values is displayed.</td>
</tr>
<tr>
<td>Use Formula Definition</td>
<td>For formula columns; the formula will be applied to the “Total” row in the same way it is applied to other rows in the column.</td>
</tr>
</tbody>
</table>

| Column Position After | The new column will be inserted after the column selected |

To create a formula column

1) In the Column Properties window, choose Formula as the Entry Method, then click the Create button. The Formula Creation window opens.

2) Enter the first value in the formula:
   - To enter numerical values into the formula, click the number keys on the on-screen keypad. (Include parentheses, % or decimal point as necessary.)
   - To add a column value into the formula, select it from the list in the left pane, then click the Select button (or double-click it). Options include:
Columns: These are columns that have been added to the sheet. The value in the corresponding row will be used in the formula.

Total Elements: These are the columns on the sheet that display a total (either the sum or formula definition, as defined in the Total option for that column). The value of the Total for that column will be used in the formula.

An additional default Total Element is also available: Commitment Total Funded By All Funds. It is the sum of all commit line items (base and change commits) that have the assignment option "All Funds" (as selected for each commit line on the Fund Assignment window).

As you build the formula, it appears in the Formula box in the upper right portion of the window.

3) Click on the appropriate operator: add, subtract, multiply, or divide.

4) Continue to alternate between choosing values and operators to add to the formula.

5) You may click Undo at any time to undo the last action. Click the Clear All button to clear the entire formula.

6) When the formula is complete, click OK to save your formula and return to the Column Properties window.

7) If you need to change the formula after creating it, click the Modify button (next to the Formula option). Clear the old formula first (click Undo or Clear All), then re-enter it.

To create a column by copying an existing column

1) In the Column log, select a column and click Copy. The Column Properties window opens.

2) Make changes as necessary for the new column. You must change at least the data source.

To edit a column

From the Columns Log window, select a column and click Open. The Column Properties window opens.

Make edits as necessary and click OK.

Note: Although it is possible to change the entry methods for a column, use caution when doing so. For example, if you change the entry method from Manual Entry to Formula, any existing values you have entered in that column will be replaced with the formula. Some column properties for some system data sources cannot be modified.

To move a column

From the Columns Log window, select a column to move, then click Move Up (Left) or Move Down (Right). The order in which the columns appear in the Log window is the order (from left to right) that they appear on the sheet.

To delete a column

Select a column from the Columns Log and click Delete. The column will be deleted.
Note: If the column is being used in a formula in another column, you must remove the column from the formula before you can delete it.

Defining Fund Assignment Options for Commitment Funding

Fund Assignment refers to how funds are to be consumed as spends type business processes (e.g., invoices and payment applications) come in against the base commit that is being funded.

The first step in defining the Assignment rules—whether funding is to be done manually or by auto ratio. The assignment levels and rules are defined on the Assignments tab in the Properties window of the commitment funding sheet. This step is mandatory in order to do commitment level funding.

The Assignment tab lists the spends business processes that are linked to base commits enabled for commitment level funding. For each listed business process, you define how fund assignment will be done when these spends records come in against the base commit (either manually, or automatically by fund ratio).

You can define these assignment rules on the commitment funding template. When you create a commitment funding structure in a project or shell, these assignment rules will be copied to it, and when you create new sheets from the structure, they will be copied to the sheets. If you need to, you can modify these rules on individual structures and sheets.

The next step is optional: define Fund Assignment details per SOV line; that is, define whether a specific fund must be used to fund a particular line on the commit. This allows you to provide details about fund assignment or consumption for each line on the base commit or any change commits. You access the Fund Assignment window by clicking the Fund Assignment button on the commitment funding sheet or SOV sheet associated with the base commit.

If you do not define any assignment options in this window, then All Funds is the default selection. This means that all funds that have been allocated to the base commit on the commitment funding sheet will be available for funding each line of the spends business process created against it (either manually or by auto ratio, as defined by the assignment rules).

Fund assignment on these lines is tracked by commitment funding sheet columns using data sources that for records or fund balance "across all funds." Add and Manage commitment funding sheet columns (on page 526).

Sometimes, you may need to specify that a specific fund be used to fund a specific WBS code or SOV line. For these lines, you can select a specific fund (or "discrete fund"). Fund assignment is then tracked by commitment funding sheet columns using data sources for records or fund balance "by discrete fund.")

For details, see the following procedures.

Define commitment fund assignment rules

The fund assignment rules define how assignment will be done on the spends business processes created against the base commit being funded: either manually or automatically by fund ratio.
Funding assignment levels and rules can be defined in the commitment funding template, structure, or individual sheets. It is easiest to set them once -- in the template -- and have them carried forward into the structures and sheets created from it. If necessary, these options can be modified later for individual structures and sheets. These rules must be defined on the commitment funding sheet in order to do commitment level funding.

**To set up commitment funding assignment rules**

1) Open the **Properties** window of the commitment funding template, structure or sheet. (From the File menu, choose Properties.)

2) Click the **Assignment** tab. The list displays all General Spends and Payment Application Business Processes that are linked to a Base Commits that has been enabled for commitment funding and have been designed to consume fund according to the design in uDesigner).

3) For each listed spends business process, click the Assignment Rule drop-down and select one of the following:

   - **Commitment Level - Manual**: Funds are manually assigned at runtime. As spends business processes are routed and reach specified status, the amounts to be funded are collected under the Unassigned total on the commitment funding sheet, similar to project/shell level manual funding. You can then select each line of the spends BP and assign funds at runtime. Consumed funds roll up to the commitment funding sheet and the project funding sheet.

   - **Commitment Level - Auto Ratio**: Funds are assigned automatically when the spends business process reaches a specified status. Funds are assigned based on the fund ratio, which is calculated based on the fund levels (using the value in the column of data source Funding Ratio Across All Funds on the commitment funding sheet), and is managed and tracked on the commitment funding sheet. If all funds are consumed, any remaining spends amounts are collected under Unassigned.

4) Click **OK**.

**Define commitment fund assignment details**

This is an optional step that allows you to provide details about fund assignment or consumption for each line on the base commit or any change commits. The commitment funding sheet works in conjunction with the SOV sheet in tracking the individual line items on the base commit and any change commits. Therefore, you can define details about fund assignment per SOV line. This is done on the Fund Assignment window.

By default, all funds that have been allocated to the base commit on the commitment funding sheet will be available for funding each line of the spends business process created against it (either manually or by auto ratio, as defined by the assignment rules).

However, if you need to specify that a specific fund must be used to fund a specific WBS code (or SOV line), you can specify a specific (or "discrete") fund to use.

You can do fund assignment one row at a time, or several rows at a time (bulk assignment). See the following procedures.

---

**Note**: If you do not define fund assignment options, the default will be All Funds for each SOV line.
To set fund assignment details (one row at a time)
1) Open the commitment funding sheet or the SOV sheet.
2) Click the **Fund Assignment** button on the toolbar. The fund assignment grid view displays each line that is present on the SOV sheet, including WBS breakdowns. (The Fund Assignment button is available on the commitment funding sheet once the SOV has been created for the base commit.)
3) In the Assignment column, click the drop-down and choose the assignment:
   - **All Funds**: This is the default option. This means that all funds allocated to the commitment funding sheet are available to fund the SOV line or breakdown. (This option must be used if you are doing assignment by auto-ratio.)
   - On the commitment funding sheet at runtime, funding consumption will roll up to the column using data source "Funding Across All Funds."
   - **<Fund Code-Fund Name>**: Each fund that has been allocated to the commitment funding sheet will display on the drop-down alphabetically. These are referred to as "discrete funds." You can choose to assign a specific fund to an SOV line or breakdown. This means that only that fund will be used to fund that line. (You can choose the same fund code for multiple lines.)
   - On the commitment funding sheet at runtime, funding consumption will roll up to the column using data source "Funding By Discrete Fund."

   **Note**: If an SOV line has a breakdown, then select an assignment for each breakdown, not the SOV line itself.

4) Click **Save** to save the sheet.

To set fund assignment on multiple rows on the SOV sheet (bulk assignment)
1) Open the commitment funding sheet or SOV sheet.
2) Click the **Fund Assignment** button on the toolbar. The fund assignment grid view displays each line that is present on the SOV sheet, and includes an Assignment column.
3) Select a row, or multiple rows by holding down the Shift key (to select a range of rows) or Ctrl key (to select rows throughout the sheet) while clicking the rows.
4) Click the **Bulk Assignment** button. The Bulk Assignment window opens.
5) Click the **Assignment** drop-down and choose the assignment. The values listed are the same as on the Fund Assignment window for the individual SOV lines.
6) Click the **Update** button.
7) Click **Save** on the Fund Assignment window to save your changes.

Setting Up Schedule of Values (SOV)
When a Base Commits Business Process (BP) is approved, it creates a Schedule of Values (SOV) sheet. The SOV sheet is the "working document" on which committed monies are entered. The committed monies shown on the SOV sheet are rolled up to the Company Cost Sheet.

**Note**: The Change Commits BPs continue to change or add costs to the SOV during the life of the Project/Shell.
Unifier Schedule of Values (SOV) functionality provides a way to assemble information from contract, change order, and invoice/payment BPs into a SOV sheet, streamlining the process of invoicing for completed phases of a Project/Shell.

SOV functionality is available for Cost type BPs in which the "Allow creation of Schedule of Values" option is defined, or selected, in the design properties. The BPs can be designed to create an SOV sheet automatically upon reaching the designated step.

You may define one SOV sheet per Commit BP, for example, a Purchase Order or a Contract. Rows are automatically populated based on the WBS/Cost/Accounts codes defined in the Commit BP.

Before you can create an SOV:
- Design Commit type BP in uDesigner and deploy.
- Configure and set up commit BP.
  - SOV functionality is available with commit BPs, for example a Purchase Order for which the Create SOV option is selected in uDesigner. For these BPs, the system automatically creates a SOV sheet upon reaching the designated step. There may be one SOV sheet per Commit Business Process. Rows are automatically populated based on the WBS/Account Codes defined in the Commit BP.
- Create and set up the Project/Shell Cost sheet.

### How to Set Up SOV

#### Before you begin

Base Commits and Change Commits Business Processes must be set up for the Project/Shell.

#### Step 1: Create and set up SOV template (General Spends only)

You can create a template in the Templates log in Administration Mode. If you are using General Spends SOV, the structure that will be used for the SOV sheets is created from the template.

**Note:** You can define a General Spends SOV structure by copying from an SOV template in the Templates log.

#### Step 2: Set up SOV Structure (User mode)

a) SOV Sheets are created, either manually or automatically, from Base Commits, based on the structure that is set up in Step 1.

b) For General Spends SOV, the SOV structure is copied from an SOV template.

c) For Payment Application SOV and Summary Payment Application SOV, the structure is copied from the line item grid structure of the Payment Application Business Process. This means that you must first complete the Business Process (BP) setup for the Payment Application BP before you can create the structure.

#### Step 3: Create SOV Sheets

You can create General Spends, Payment Applications, and Summary Payment Applications SOV structures in project templates.
Creating an SOV Template

An SOV Template needs to be created and set up before you can create a SOV sheet. SOV sheets are created using an SOV Template that defines the columns that will appear on the SOV sheet.

**Note:** All SOV sheets in a single Project/Shell will use the same template structure.

If an SOV Template does not exist when an SOV sheet is auto-created from a Cost type BP, one will be created automatically with the default columns WBS Code and WBS Item and Breakdown Data. You can edit this structure as needed, but the default columns are not editable.

**To create a new SOV Template**

1) In Administration Mode, go to the Company Workspace tab and click Templates > Shells > Projects > Cost Manager > Schedule of Values in the left Navigator.

2) Click the New button. The Properties window opens.

3) Enter a Name and Description in the General tab.

4) Click the Options tab.

   Use the Options tab to define the labels that will be used for the SOV column headings. The fields listed in the Labels block are the name of labels that are displayed as column headings on the SOV sheet. You may change the labels or accept them as is. It is recommended that you use the same labels as is used in the Cost Template and Cost sheets.

   The following explains how to set up the fields in the Properties window, Options tab:

   **Ref**
   
   Refers to a reference number for the entire commit. (Another example of a label for this column is "Order Number.")

   **WBS Code**
   
   This field is not editable.

   **WBS Item**
   
   This field is not editable.

   **Breakdown**
   
   The WBS Code Breakdown that you specify in the WBS Details window for that code.

   **Description**
   
   This label refers to the line item description when the SOV is in line item mode.

5) When finished, click Apply and then OK.

The Schedule of Values node, under Project/Shell templates, contains the following sub-nodes:

- General Spends
- Payment Applications
- Summary Payment Applications

The Summary Payment Applications sub-node lists the Business Processes (BPs) of the Summary Payment Applications SOV sheets that have been configured in the template.
You cannot define the structure if a Base Commits or Change Commits BP of Summary Payment Applications SOV sheet is not configured in the template.

You can define one Summary Payment Applications SOV type template for every Base Commits of Summary Payment Applications SOV type BP.

If the Summary Payment Applications SOV sheet is configured in the Project/Shell templates, then you can select columns from the Data Elements that are defined on the Detail form of the Summary Payment Applications SOV sheet, and the Base Commits.

Add SOV Columns

Columns determine what data is displayed on the SOV sheets. You can add, modify, delete, hide/unhide columns on the structure. Any modifications you make on the structure will be reflected on all SOV sheets for that project or shell. Columns can be added to the SOV Template or Structure. Each column represents a data source. At a minimum, include a column for Commits Remaining Balance to enable validation of Spends against the Commits.

**Note:** This information is applicable to adding or editing columns in an SOV template or structure.

To add an SOV column

1) Open the SOV template or structure.
2) Click the **Columns** button. The columns log opens.
   - The three default columns (**WBS Code**, **WBS Item**, and **Breakdown**), for the General Spends and Payment Applications, are not editable and do not appear in the log.
   - The default columns (Cost Code, Code Name, Cost Line Item Type, and Description), for the Summary Payment Applications, are also not editable and do not appear in the log.
3) Click **New**. The Column Properties window opens.

4) Complete the Column Properties window and click **OK**.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name you choose will appear as the column header. You may manually enter a column name, or, if you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
<tr>
<td><strong>Datasource</strong></td>
<td>All columns must be associated with a data source. The data source that you choose will determine which of the following options are available:</td>
</tr>
<tr>
<td><strong>Single Sources</strong></td>
<td>These values roll up from single defined sources, including business processes.</td>
</tr>
</tbody>
</table>
| **Logical Sources** | The options are:  
  - **None**: allows you to manually configure the column as a manual entry or formula column to suit your needs  
  - **Commits Remaining Balance**: Commits Remaining Balance is a column on the SOV Template/Structure. It reflects the amount of your commits minus the spends, according to a formula you |
### Unifier Administration Mode

**Scheduled Value**: This is a formula column can be used to keep track of the remaining SOV balance. (Example formula: Base Commit (Approved) + Change Commit (Approved) - General Spends Invoice (Approved))

Note: Be sure to add a **Scheduled Value** column to the SOV sheet if you will be doing commitment level funding.

#### Entry Method
- **Manual Entry**: Choose Direct Entry into Cell to allow entry directly into the cell, or Line Item Content to allow data entry through a line item window.
- **Formula**: Values are calculated based on a specified formula entered for the column. Formulas can include the values of other columns. Click the Create button to create the formula.

#### Data Format
Applicable for Manual Entry or Formula columns:
- **Currency**: right-aligns column contents and includes a currency symbol, a thousands separator and two decimal places
- **Percentage**: right-aligns the contents and includes a percentage symbol

#### Display Mode
- **Show**: The default choice. This indicates that column will display by default on the cost sheet to all users with at least "view" permission for the cost sheet.
- **Hide**: Hidden columns are active but not displayed on the cost sheet. Hidden columns can be accessed by users with "create" permission on the cost sheet.

#### Column Position After
The new column will be inserted after the column selected

#### Allow sub-breakdown with validation
If this option is selected, the sum of breakdown amounts is validated against the WBS summary amount. That is, the sum of the breakdowns cannot exceed the amount of the WBS code itself.

## Setting Up Cash Flow

Unifier Cash Flow module allows you generate and compare Baseline, Actuals (or "spends"), Portfolio, Forecast, Derived, and Custom curves in a project or WBS code-based shell. The curve detail levels include:

- **Cash Flow by Project/Shell**
  - You can track the costs associated with an entire Project/Shell over time.
- **Cash Flow by WBS**
The creation of a WBS detail curve is similar to cash flow by Project/Shell. Use this option if cash flow needs to be tracked at the WBS level as opposed to the Project/Shell level, by allowing you plot cash flow curves by specific WBS codes, or all codes, in the Project/Shell.

- **Cash Flow by Summary WBS**
  The creation of a Summary WBS detail curve is very similar to cash flow by WBS. Use this option if cash flow needs to be tracked by summary WBS codes. In order to select this option, the Project/Shell cost sheet must use a tree structure (and therefore has summary WBS codes) rather than a flat structure.

- **Cash Flow by Commitment**
  This option allows you to plot and analyze cash flow data for an entire commit record (including base commit, any change commits, and related invoices). You can choose a specific business process commitment record within the Project/Shell, such as a purchase order or contract, and track the cost information over time. Each commitment record can have one baseline curve.

Unifier displays Cash Flow curve detail level data in a Cash Flow Worksheet. The cash flow curve worksheet can display any number of Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, or Custom curves (based on the same detail level). Depending on curve set up you can manually enter manual, pull data automatically from other sources such as business processes, cost sheet columns and schedule manager dates (depending on the curve type), and compare multiple curves. Here is an example of a cash flow detail curve worksheet and curves.

At runtime, the user can view the cost distribution information by WBS code from a schedule sheet see Create a Cash flow curve from a Schedule Sheet.
To facilitate creation of cash flow curves and roll up of data to program and company cash flow worksheets, you can create the following in Administration Mode (Admin mode):

- **Data Sources**
  - You create data sources that can be used to create and identify cash flow curves, and roll up data to program and company worksheets. You will need to create data sources in order to create cash flow curves.
  - Data sources are created based on a Curve Type: Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, or Custom curves. Each curve type has its own logic to address different business requirements.

- **Distribution Profiles**
  - These are optional. Distribution profiles can be applied to cash flow curves to automatically distribute cost data across a specified time period. At runtime, you will have the option of manually distributing data in the cash flow worksheet, or automatically distributing the data using one of these profiles.

- **Company-level Templates**
  - These are also optional. You can create cash flow detail curve templates, which can be used to create new curves at runtime within a project and shell; and rollup curve templates, which you can use to create program curves to roll up cash flow data from projects or shells.

- **Project/Shell-level Templates**
  - You can create cash flow curves within a project template or a WBS-code based shell template. These can be used to create new curves in projects or shells; they can also be used to "push" out updates to existing curves. *Update cash flow curve properties and permissions* (on page 247).

### How to Set Up Cash Flow

Here is an overview of the steps required to set up the cash flow module.

**Note:** There are two Cash Flow modules: the module in effect prior to the 9.3 release is called Cash Flow (Basic); the module introduced in 9.3 and discussed here is named Cash Flow. Each module has its own user and administration mode permissions.

---

**Step 1:** Grant yourself permissions to configure the cash flow modules.

**Step 2:** Create custom cash flow data sources. These are used to create curves in projects and shells. You also define a color for each data source, which will display as the curve color on the cash flow graphs. See *Creating Cash Flow Data Sources* (on page 542)

**Step 3:** Create distribution profiles. These profiles can be used to distribute cost or any value over a period of time. (See *Distributing Cost Data* (on page 544).)
Step 4: Create cash flow templates. You can create any number of cash flow templates at the company level, or create cash flow curves within a project/shell template. Setting up cash flow templates is essentially the same as creating the curves manually in a project or shell (or a project/shell template), with some exceptions that are mentioned in the setup procedure details. You can use company-level and project/shell level templates to quickly create cash flow detail curves and rollup curves in projects and shells. See Create a template for a cash flow curve (on page 547).

Step 5: Create cash flow in a project or shell. You can create any number of cash flow curves in a project or shell. These can be detail level or rollup curves. You can create them manually, by copying an existing curve, or by copying a template, see Cash Flow in the Unifier User Guide.

Step 6: Create cash flow in a program or company. You can create rollup curves in programs and in the company workspace, and roll up cash flow data from projects and shells. See Create Roll-up Templates (on page 549) in the Unifier User Guide.

Step 7: Grant cash flow permissions to users.

Grant Yourself Permissions to Configure Cash Flow

You must grant permission to yourself, another administrator, or group such as Company Administrators, to configure cash flow modules.

To grant yourself configure permissions
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, select Administration Mode Access > Standards & Libraries > Cash Flow > Data Sources.
4) In the Module Permission Settings window, click the Add button. The Permission/Access Control window opens.
5) Click the Add Users/Groups button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give configuration permission and click the Add button. Then click OK.
   Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select Modify and View and click OK. Unifier adds the name(s) to the Permission Settings window.
8) Repeat these instructions to grant permission to cash flow Distribution Profiles and cash flow Templates. (Give these modules Create permission.)
9) Click OK.

Create a Cash Flow Distribution Profile

You can create new profiles manually or by copying an existing profile.

To create a distribution profile manually
1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click Standards & Libraries > Cash Flow > Distribution Profiles in the left Navigator. The Distribution Profiles log opens.
The default Distribution Profiles record displays in the log. All profiles are stored in this record.

3) Select Distribution Profiles in the log and click Open (or double-click Distribution Profiles). The Edit Distribution Profiles window opens. The left side of the window displays the list of the distribution profiles. The right side of the window displays a graphical representation of the profile and is used to define it.

4) Click the New button. This adds a new row to the Distribution Profiles list.

5) Enter a unique Name for the profile (up to 30 characters).

6) Be sure the Active checkbox is selected if you want it to be available for cash flow curves. If you deselect this checkbox, the profile will not be available for selection on curves.

7) Define the distribution profile on the graph by entering values in the Profile % slots.
   By default, when you create a new distribution profile, the graphical display will be a linear distribution. (5% is entered into each of the 20 slots: 5% x 20=100%.) You can modify this profile by entering a value for each slot for the Profile %. The graph will reflect the values that you enter.
   You can enter values with up to two decimal places per slot. Press the Tab key to move one slot to the next. The total of all the slots for the Profile % must add up to exactly 100%.

8) When the distribution profile is complete, click the Save button.

To create a distribution profile by copying an existing profile
1) In the Edit Distribution Profiles window, select a profile and click Copy. A new row is added, and the selected profile information is copied.
2) Enter a new Name for the copied profile. Make any changes to the profile values as needed and click Save.

Delete a Distribution Profile
You can delete distribution profiles as long as they are not currently being used in the system. If a distribution profile is being used, you can delete it as long as you replace it with another profile first. This is explained in the following procedure.

To delete a distribution profile
1) Open the Distribution Profile window.
2) Select one or more profiles from the list on the left. Press the Ctrl or Shift key to select multiple profiles.
3) Click the Delete button.
   ▸ If the profiles you selected are not currently being used by the system, a warning message opens. Confirm that you want to delete the profiles by clicking Yes.
   ▸ If you selected multiple profiles and one or more of them are being used by the system, an error message opens displaying the profiles currently in use.
   ▸ To delete a profile that is currently in use, go to Step 4.
     ▪ Close the error window.
     ▪ You can delete the profiles that are not in use by selecting them again from the Distribution Profiles window and clicking Delete.
4) If you select a single profile that is being used by the system, you will be prompted to replace the profile with another profile.
   - The Select a Distribution Profile window opens.
   - Click the Select button and select a new profile from the list.
   - Click OK. The profile being deleted is replaced with the profile selected in this window. When the curve using the profile is refreshed at runtime, the new profile will take effect.

**Edit a Distribution Profile**

You can edit a distribution profile. The change will take effect in curves that use the profile the next time the curve is refreshed.

**To edit a distribution profile**

1) Open the Distribution profile window.
2) On the left side of the window, select the distribution profile to edit.
   - You can edit the profile **Name**. If the profile is used by a curve, the name change will be reflected in the curve Properties.
   - You can select or deselect the **Active** checkbox. Active profiles are available for selection when choosing a default profile for auto distribution. Inactive profiles will not show up on the selection list. If you inactivate a profile and a curve is already using it, the curve will not be affected; it will still use the profile.
   - On the right side of the window, you can change the **Profile %** values. Change will be reflected in curves that use the profile when the curve is refreshed.
3) Click **Save** to save the changes. If the profile is being used by one or more curves, the profile change will take affect the next time the curves are refreshed.

**Creating Cash Flow Data Sources**

You can add multiple curves to a cash flow worksheet so you can view and compare curves side by side. These curves are based on the data sources you add here.

Each data source is used to identify one of the curves on a worksheet, and therefore can be used once per worksheet. You can however, reuse the data sources on different worksheets. You can create as many data sources as you need to create cash flow curves.

When you create a data source, you associate it with a Curve Type. Each curve type has a built-in logic when creating the curve using the data source. The curve types are:

- **Baseline**
  Choose this to create a Baseline curve. You can choose to manually enter the cost data, or automatically pull the data from a cost column, such as a Budget.

- **Forecast**
  Choose this to create a curve that helps forecast future cash flow based on actual spends records.

- **Actuals** *(Spends)*
  Choose this to plot spends data over time.

- **Portfolio Budget**
Choose original or shared option to create a Portfolio Budget curve.

- **Derived**
  Choose to create a Derived curve.

- **Custom**
  You can create Custom curves that you can use to enter data, or to compare against other curves. The setup is similar to the Baseline curves.

### To create a Cash Flow data source

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. In the left Navigator, click **Standards & Libraries > Cash Flow > Data Sources**. The Data Sources log opens. By default, there is one Data Sources record displayed in the log. All data sources are stored in this record.
3. Select Data Sources in the log and click **Open** (or double-click Data Sources). The Edit Data Source window opens.
4. Click the **Add** button. This adds a new row to the window.
5. Enter a **Name** for the data source. The name must be unique and not exceed 30 characters. Press the **Tab** key to move to the next field.
6. Select a **Curve Type** from the drop-down list: Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, or Custom curves.
   - You can make your selection by clicking the field and selecting from the list, pressing the first letter of your selection on the keyboard (e.g., press the B key to select Baseline), or you can use the arrow keys on your keyboard to browse the list and make your selection.
   - Press **Tab** to move to the next field.
7. Select a **Color**.
   - This color will be used on the cash flow graph at runtime when a curve is generated from the data source. There are 256 colors (including "0" for black) to choose from.
   - Like the Curve Type field, you can click the field and select from the list; press the arrow keys to browse the colors; or, if you know the number of the color that you want, you can type it directly then press Enter.
8. To rearrange the data sources, select on the list and click the **Move Up** or **Move Down** buttons. This is the order in which the data sources will be presented when a user creates a curve.
9. Click **OK** to save and exit the window.

### Delete a Cash Flow Data Source

You can remove a data source from the list only if it is not being used by any cash flow curves.

If a data source is in use and you want to delete it, you must first delete any curves using it (these are the curves defined in the cash flow Properties window, Curves tab).

### To delete a cash flow data source

1. Open the Edit Data Source window. (In Administration Mode, navigate to **Standards & Libraries > Cash Flow > Data Sources. Double-click Data Sources.**)
2. Select the data source to delete and click the **Remove** button. The row is deleted.
3) Click **OK** to save and exit the window.

### Edit a Cash Flow Data Source

You can edit the data source color, which changes the color of the curves using the data source. You can also change the row order, which changes the order that data sources appear on the selection list when creating a new curve.

**Notes:**

- Curve Type is not editable.
- The data source name can be changed, but use caution when doing so. If you rename a data source, the curves that use the data source will not recognize the new name, and the data will not be visible on the curves. If you change the name back to the original name, the data will appear again on the curves.

### To edit a cash flow data source

1) Open the Cash Flow Data Sources (Cashflow Datasources) window.
2) You can make changes as necessary, based on the information.
3) Click **OK** to save and exit the window.

### Distributing Cost Data

When you create a cash flow curve, Unifier distributes cost data using the distribution method defined in the cash flow curve properties. Distribution can be either manual, or automatic from a defined profile.

In User Mode, Unifier displays commitment curve cost data in the record transaction currency, but stores costs in project currency. Currency conversion uses the active exchange rate set.

- **Baseline curves use the exchange rate that was active at the time of record creation.**
- **Actuals curves use the exchange rate that was active at the time the money was paid.**
- **Forecast curves use the exchange rates in effect for each time period over the duration of the curve.**

If the transaction currency is different from the project currency, you can change the currency view between transaction and project currencies. You can only edit data in the transaction currency view. If there is a more recent value in the exchange rate table, refreshing the curve will refresh the cost data. You will not see the currency menu if the business process record was created in the project currency.
Manual distribution

When you select manual distribution in the curve properties, you manually enter the data for distribution in the curve details window at run time. Unifier preserves cost distribution and duration when you change the From Date (start date) of baseline, custom, and forecast curves (when there are no actuals) in project/shell, summary WBS, and WBS detail curves. In other words, if you change a cash flow curve to start on a different date then it originally did, Unifier shifts the curve along the timeline to reflect the new date and moves the cost data to retain the integrity of the curve. Unifier pegs the distribution of cost data to the From Date, rather than the end or To Date. Here is how this works when the From Date changes:

- If the modified curve is the same length as the original curve, the curve shifts along the timeline to reflect the new start date and all cost data remains in the curve.
- If the modified curve is longer than the original curve, the curve will shift along the timeline to reflect the new start date, but existing data is not redistributed to the additional time periods. Each time period retains its original value and additional columns have values of zero.
- If the modified curve is shorter than the original curve, then the curve will shift along the timeline to reflect the new start date, and existing data is truncated at the new end date.

Auto by default profile distribution

A distribution profile lets you predefine the way you want Unifier to distribute cost data in User Mode. You can add any number of profiles in the Edit Distribution Profiles window.

The left side of the window contains:

- A list of previously created distribution profiles. Initially this list is empty.
- The Active checkbox, which controls whether the profile is available for selection for a curve.

The right side of the window contains:

- Graph: The graph is a graphical representation of the profile % that you enter over the duration %.
- Duration %: These are the x-axis units of the graph. The x-axis starts at zero (0), with another 20 slots, equally distributed up to 100%.
- Profile %: Starts at 0, with 20 remaining slots to enter the profile distribution percent values. You will enter incremental values in these slots. The total value of the profile % must add up to 100%. You cannot enter negative numbers in these slots. The values you enter will determine the shape of the curve, and distribution of the data.

By default, when you create a new distribution profile, the graphical display will be a linear distribution (5% is entered in each of the 20 data slots).

Following are some distribution profile examples.

<table>
<thead>
<tr>
<th>Curve Example</th>
<th>Profile %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Linear</td>
<td>5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5</td>
</tr>
<tr>
<td>S-Curve</td>
<td>0.5 0.5 1.5 1.5 4 4 7.5 7.5 11.5 11.5 11.5 11.5 7.5 7.5 4 4 1.5 1.5 0.5 0.5</td>
</tr>
<tr>
<td>Back Loaded</td>
<td>3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5 3.5</td>
</tr>
<tr>
<td>Front Loaded</td>
<td>6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5 6.5</td>
</tr>
</tbody>
</table>
Cash Flow Curve Templates

You can create cash flow curve templates that can be used to create cash flow curves in projects and WBS-code based shells. If you are using programs or company-level cash flow, you can create roll-up curve templates. See *Create Roll-up Templates* (on page 549).

Template creation methods are manual or copying an existing one. After creating a template, you can set refresh frequency and activate or deactivate curves.

Creating and setting up a template is essentially the same as setting up the curves manually in a project or shell. The major difference is you cannot select individual records in the template; these must be chosen from within the projects or shells. See Cash flow curves in the *Unifier User Guide*.

The detail curve creates a worksheet in the project or shell that can include several curves. You can create detail curves and detail curve templates at the following detail levels:

- **Cash flow by project or shell**: You can track the costs associated with an entire project or shell over time.
- **Cash flow by WBS**: The creation of a WBS detail curve is similar to cash flow by project/shell. Use this option if cash flow needs to be tracked at the WBS level as opposed to the project or shell level, by allowing you plot cash flow curves by specific WBS codes, or all codes, in the project or shell.
- **Cash flow by Summary WBS**: The creation of a Summary WBS detail curve is very similar to cash flow by WBS. Use this option if cash flow needs to be tracked by summary WBS codes. In order to select this option, the project/shell cost sheet must use a tree structure -- and therefore has summary WBS codes -- rather than a flat structure.
- **Cash flow by commitment**: This option allows you to plot and analyze cash flow data for an entire commit record (including base commit, any change commits, and related invoices). You can choose the specific business process commitment record within the project/shell, such as a purchase order or contract, and track the cost information over time.

- **Note**: You can set up the automatic creation of a cash flow curve when a base commit record is created and completed or reaches a particular step. This is done in the BP Setup for the business process. See *Setting up auto-creation of cash flow curves from contracts* (on page 404)

To create a cash flow detail level curve in a template

1) Go to the Company Workspace tab and switch to Administration Mode.
2) In the left Navigator, do one of the following:
   - To create a template, click **Standards & Libraries > Cash Flow > Templates**. This is a template users can select at run time.
   - To create a detail curve in a project or shell template, click **Templates**. Open the project or shell template, then click **Cost Manager>Cash Flow** in the Navigator. This cash flow model can be copied during project or shell cloning.

   The Cash Flow log opens.
3) Click the **New** button. The Properties window opens.

   Directions for completing the cash flow curve properties are in the *Unifier User Guide*.  

---
Unifier Administration Mode

- **General tab**: Define the name, description, detail level, time scale and period close settings.
- **Curves tab**: Define individual curves (Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, and Custom curves) that will be part of the group of curves that make up the cash flow detail curve.
- **Filters tab**: Limit the cash flow data on your curve to a particular set of WBS codes or (if the cost sheet is tree structure) summary WBS codes. If you do not specify a filter, then all codes will be used for the data.
- **Options tab**: Define the format to use for the numbers displayed on the cash flow worksheet.
- **Schedule tab**: Enable automatic refresh of the cash flow curve, and set the refresh schedule.
- **Summary tab**: A Summary Cash Flow Curve displays selected cash flows from your project.

---

**Create a Template for a Cash Flow Curve**

This topic discusses cash flow templates that you can create in Standards and Libraries > Cash Flow > Templates. For instructions on how to create cash flow curves, refer to the *Unifier User Guide*.

**Cash Flow Curve templates**

You can create cash flow curve templates that can be used to create cash flow curves in projects and WBS-code based shells. If you are using programs or company-level cash flow, you can create rollup curve templates. See *Create Roll-up Templates* (on page 549).

Template creation methods are manual or copying an existing one. After creating a template, you can set refresh frequency and activate or deactivate curves. Creating and setting up a template is essentially the same as setting up the curves manually in a project or shell. The major difference is you cannot select individual records in the template; these must be chosen from within the projects or shells.

The detail curve creates a worksheet in the project or shell that can include several curves. You can create detail curve templates at the following detail levels:

- **Cash Flow by Project/Shell**
  Used to track the costs associated with an entire Project/Shell over time.

- **Cash flow by WBS**
  Used to track cash flow at the WBS level as opposed to the project or shell level. Allows you to plot cash flow curves by specific WBS codes, or all codes, in the project or shell.

- **Cash flow by Summary WBS**
  Used to track cash flow by summary WBS codes. In order to select this option, the project/shell cost sheet must use a tree structure -- and therefore has summary WBS codes -- rather than a flat structure.

- **Cash flow by Commitment**
Used to plot and analyze cash flow data for a base commit record (including base commit, any change commits, and related invoices). You can choose a specific business process commitment record within the project/shell, such as a purchase order or contract, and track the cost information over time. Each commitment record can have one baseline curve.

Note: You can set up the automatic creation of a cash flow curve when a base commit record is created and completed or reaches a particular step. This is done in the BP Setup for the business process.

To create a new cash flow detail level curve in a template

1) Do one of the following:
   - To create a template: In Administration mode, go to the **Company Workspace** tab and click **Standards & Libraries > Cash Flow > Templates** in the left navigator.
   - To create a detail curve in a project or shell template: In Administration mode, go to the **Company Workspace** tab and click **Templates** in the left Navigator. Open the project/shell template. Go to **Cost Manager > Cash Flow**. The Cash Flow log opens.

2) Click the **New** button. The Properties window opens. Refer to the **Unifier User Guide** for instructions on completing the Cash Flow Curve properties.
   - **General** tab: Define the name, description, detail level, time scale and period close settings.
   - **Curves** tab: Define individual curves (Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, and Custom curves) that will be part of the group of curves that make up the cash flow detail curve.
   - **Filters** tab: Limit the cash flow data on your curve to a particular set of WBS codes or (if the cost sheet is tree structure) summary WBS codes. If you do not specify a filter, then all codes will be used for the data.
   - **Options** tab: Define the format to use for the numbers displayed on the cash flow worksheet.
   - **Schedule** tab: Enable automatic refresh of the cash flow curve, and set the refresh schedule.
   - **Summary tab**: A Summary Cash Flow Curve displays selected cash flows from your project.

To add filters on a Cash Flow Curve template

1) Go to **Company Workspace > Admin mode > Templates > Project/Shells**.
2) Open your Project/Shell template > **Cost Manager > Cash Flow**.
3) Click **New** to configure your Cash Flow curve or open an existing Cash Flow curve.
4) Click **View** and select **Filter**.

Note: Alternatively, you can open the Filter window by way of clicking the filter icon on the upper right-hand corner of the Cashflow Worksheet window.

5) Select which curves to display. Deselect any curves you do not want to display.
6) In the **Save As** field box enter a name for the filter.
7) Click **OK** to close the window.
8) The name of the filter that you have saved appears on the upper right-hand corner of the Cashflow Worksheet window. This window contains a list of saved filters that have been saved.

   **Note:** The Default View option allows you to select which particular filter to display when you open a Cash Flow Worksheet.

9) You can click **Edit > select Manage Filters** to delete, set default view, change name, and change the description of your filter.

10) In the Cash Flow log window, ensure that your Cash Flow curve is selected and click Update Shells.

**Create Roll-up Templates**

Use roll-up curves in programs and in the company-level Cost Manager to roll up cash flow data from all the projects and shells in which cash flow is being used. You can create roll-up curve templates, and use these to create the roll-up curves.

**To create a new roll-up template**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) In the left Navigator, click **Standards & Libraries > Cash Flow > Templates**. The Cash Flow Standard Templates log opens.

3) Click **New > Rollup Curves**. The Properties window opens in the General tab.
4) Click the Options tab. On this tab you can define the format to use for the numbers displayed on the worksheet. This is similar to the Options tab on detail curves. See *Create a template for a cash flow curve* (on page 547) in the *Unifier User Guide*.

<table>
<thead>
<tr>
<th>In this Field:</th>
<th>Do This:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a unique name for the roll-up curve</td>
</tr>
</tbody>
</table>
## Unifier Administration Mode

### Description
Enter an optional description.

### Status
- **Active**: Data can be rolled up from project and shell cash flow curves.
- **Inactive**: Data is not rolled up to the curve.

### Data Sources
This list displays the data sources that have been defined in Standards & Libraries > Cash Flow > Data Sources. Select one or more of the listed data sources that you want to roll up from the project or shell cash flow curves to the roll-up curve. To quickly select all data sources, you can select the checkbox at the top of the list, next to Data Sources.

### Time Scale
Choose Month or Year, and the format. The roll-up curve will roll up data from curves that use the same time scale.

## Granting Cash Flow User Mode Permissions

Before others can access a cash flow curve that you created, they need user mode permission. This is different from permission granted in Administration Mode, which is for general access to the module. You grant user mode permission per detail curve in the project or shell.

**Note**: Granting cash flow User Mode permissions explained in this section is different from permission granted in Administration Mode, which is for general access to the module (Refer to the Unifier Administration Guide for details). You grant User Mode permission per detail curve in the Project/Shell.

### To give users permissions to work with a cash flow curve

1. Open the Project/Shell and click **Cost Manager > Cash Flow** in the left Navigator. The Cash Flow log opens.
2. Select a curve from the log and click **Permission** to open the Edit Permission window.
3. Click **Add** to open the User/Groups window. Select one or more users or groups to grant permission to, click **Add** and then click **OK**.
4. In the Edit Permission window, select one or more users or groups, and select the following permissions:
   - **Modify Permission**: Allows user to modify permissions to the curve. This also automatically selects **Edit Data**.
   - **Edit Data**: Allows user to enter or edit data for manual data entry curves.
   - **View**: By default, when you add a user or group to the window, they are granted **View permission**, which allows them to access and view the curves and data.
5. Click **Apply** and then click **OK**.
Setting up the Rules Engine

Rules constrain the sending of cost-type business process records, and affect making changes to Cost and Funding sheets. That is, they give some control over costs by helping you to enforce cost constraints. For example, you could create a rule that prevents invoices from exceeding a contract budget.

As the administrator, you can create rules and rule templates. Rules can be created at the project or shell level or company level. Rule templates can be created for project- or shell-level rules.

You will be using a formula to create a rule, much as you use formulas to create field values.

About Rules

A rule is triggered when a user attempts to "send" a business process record to the next step whose status activates the rule. For example, the rule may be designed to activate when a record gets to the Pending or Approved status. A rule can prevent the record from proceeding to the next step if doing so will violate the rule. Rules affect how users can work with:

- Funding sheets (at project or shell or company level)
- Project/Shell Cost sheets
- Schedule of Values

When you create a rule, you can designate specific groups or users who can override the rule exception.

When a rule violation occurs, Unifier displays a "Rule Exceptions" window.

If the user has override control, they can click Override to ignore the rule exception, or Cancel to accept the rule and remain on the step. If the user clicks Override, Unifier will ignore the rule exception and send information to the audit log about the override transaction.

Rule exceptions can be triggered by:

- Adding or copying a line item on the Cost Sheet
- Copying data from one column to another on the Cost Sheet
- Entering data directly into a cell on the Cost Sheet
- An email action that sends cost data to the sheet
- An integration transaction that sends cost data to the sheet
- I Step and S Step business process auto-creation
- A business process record that rolls up cost data to the sheet

Note: Unifier does not display a Rule Exception window if the rule validation is triggered from an email action, or integration. If the user has override control, Unifier will assume the user wants to override the rule exception and sends the override information to the audit log.

About control sources and levels

When you create a new rule, you choose the control source (that is, whether the rule will affect cost or fund transactions), and the rule level (what the rule will enforce).
Control Source

In projects or shells, you can create rules for cost (choose Project Cost as the control source) or funding (choose Project Fund as the source). At the company level, you can create rules for funding (the control source is Company Fund).

**Note:** "Commit" refers to a commit business process, such as a purchase order, and also would include change commit business processes if specified in the rule; additionally, the term "budget" can mean any cost sheet data source being validated against with the rule, which is usually, but not necessarily, budget-related.

Rule Levels

**Project Cost:** Rules with Project Cost as the source provide validation to business processes that affect project or shell cost sheets. Rule levels are:

- **Per WBS:** These rules provide control per WBS code across the project or shell budget. For example, if you have an assigned budget amount for specific WBS codes, you can create rules that check all commit business processes (and change commits if specified) to verify that those assigned budget amounts, per WBS code, are not exceeded. **Note:** If a business process record has several line items, even if only one of the line items will violate the rule, the entire record will be rejected.

- **Per Total for Entire Project:** This rule looks at the total, cumulative amount of commit business processes and verifies the total against the project or shell budget (or other parameter you choose). This type of rule can ensure that the project or shell budget is not exceeded, but does not verify specific WBS code or funding amounts.

- **Per Fund within each WBS:** Applicable if the project or shell includes funding at the WBS level. The rule will validate the amount being charged on the commit business process record for each WBS code against the assigned fund amount per WBS, as specified in the fund information on the cost sheet.

- **Per WBS within each Commit:** Related to SOV. For example, the rule can validate that the total amount of a purchase order and related change orders will not exceed a certain amount for a specific WBS code.

- **Per selected Summary WBS Codes:** Allows you to select one or more summary WBS codes on which to enforce the rule. This option is applicable when the cost sheet has a tree structure; cost sheets with flat structures do not have summary codes. You can choose to enforce the rule on each summary code individually, or on the total of the selected codes. Because you must select summary WBS codes from the cost sheet for this rule, this option is not available in rule templates; it is available for rules within project templates and shell templates, and within projects and shells.

- **Per selected WBS Codes:** Allows you to select one or more "leaf" level WBS codes (that is, codes that are not summary codes) on which to enforce the rule. You can choose to enforce the rule on each code individually, or on the total of the selected codes. This option is applicable for cost sheets with a tree or flat structure. Similar to the previous option, this is available in rules within project templates and shell templates, and within projects and shells, not in rule templates.
Project Fund: This control source option provides validation to business processes that affect project or shell funding sheets. Rule levels are:

- **Per Fund**: These rules provide control per fund per project or shell, similar to "Per WBS" above.
- **Per Total for Entire Project/Shell**: Provide control over entire funding amount for the project or shell, similar to cost rules.

Company Fund: Company level rules can be created for company funding sheets:

- **Per Fund**: These rules provide validation against the total amount of each fund, regardless of project or shell distribution.
- **Per Total of all funds**: Provides validation for the total of all funds available to the company.

Access a rule or rule template

**To access a rule or rule template**

Rules can be created and accessed in the following logs in Administration Mode:

- Company Workspace > Rules
- Company > Templates > Rules
- Project > Rules
- Project Template > Rules
- Shell > Rules
- Shell Template > Rules

**Creating Rules and Rules Templates**

All new rules are created in a similar way. You can create new rules and rules templates manually or by copying from another rule or template.

Rules can also be added to existing active and on-hold projects and shells by updating ("pushing") them from a project or shell template using Update Projects or Update Shells.

**Note**: In order to start using a rule after it has been created, it must be validated and activated. After creating rules, see Validating and Activating Rules (on page 558).

Create a rule template

You can create a rule template, or a rule within a project or shell template. By default, rule templates remain inactive; the Validate, Activate and Deactivate buttons on the toolbar are disabled. Rules within project and shell templates can be validated and activated.

You can create a new rule manually or by copying an existing rule. If you create a rule within a project or shell template, the rule can be "pushed" to existing projects or shells.

**To create a rule template**

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click one of the following:
Unifier Administration Mode

- Company Workspace > Rules
- Templates > Rules
- Templates > Projects (Standard) > [project] > [template] > Rules
- Templates > Shells > [shell] > [template] > Rules

**Note:** At the Template > Shells level, you can create rules only for WBS shells, not generic shells.

3) Click **New.** The Create a New Rule window opens.
4) Select the **Control Source** and **Rule Level**.

**Note:** For details on choosing the source and level, see *About control sources and levels* (on page 552).

5) Click **OK.** The Edit Rule window opens.
6) Use the information in the first table below to complete the fields on the General tab.
7) Click the **Rule** tab and complete the fields using the information in the second table below.
8) In project or shell templates, if you chose "Per selected WBS Summary Codes" or "Per selected WBS Codes" as the rule Level, then the WBS Codes tab appears in the Edit Rule window. See the following procedure for selecting WBS codes.
9) Click **OK** to save and close the Edit Rule window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the rule.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description of the rule.</td>
</tr>
<tr>
<td>Control Source</td>
<td>Unifier displays the control source you chose in this field.</td>
</tr>
<tr>
<td>Rule Level</td>
<td>Unifier displays the rule level you chose in this field.</td>
</tr>
<tr>
<td>Status</td>
<td>Unifier displays the current status of the rule.</td>
</tr>
<tr>
<td>Users/Groups who can override</td>
<td>(Optional; appears only at the project and shell templates level)</td>
</tr>
<tr>
<td></td>
<td>This option is available only for the following rule levels:</td>
</tr>
<tr>
<td></td>
<td>Per selected summary WBS codes</td>
</tr>
<tr>
<td></td>
<td>Per selected WBS codes</td>
</tr>
<tr>
<td></td>
<td>Click the Select button and from the picker that appears, select the</td>
</tr>
<tr>
<td></td>
<td>users or groups that will be allowed to override this rule at runtime.</td>
</tr>
<tr>
<td></td>
<td>If you select this option, the specified users/groups should be</td>
</tr>
<tr>
<td></td>
<td>able to override a rule failure condition during a workflow. Unifier</td>
</tr>
<tr>
<td></td>
<td>will display the name(s) of the overriding user(s) and any comments</td>
</tr>
<tr>
<td></td>
<td>in the Audit Log.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If you use this option, users/groups can override this rule,</td>
</tr>
<tr>
<td></td>
<td>even if the data is not valid. Also, the users/groups specified in</td>
</tr>
<tr>
<td></td>
<td>this option will be added to the project/shell if</td>
</tr>
</tbody>
</table>
they do not already exist there

| Notify Users/Groups when overridden | (Optional; appears only at the project and shell templates level) Click the Select button and from the picker that appears, select the users or groups that should be notified if this rule is overridden. |

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Limit Expression</strong></td>
<td>This defines the Upper Limit that the rule validates against and is static. For example, for cost rules, this might be the Assigned Budget, or can include the sum of several budget-related data sources on the cost sheet. Click the Formula button. The Formula Creation window opens. The data source list includes all available cost sheet data sources for cost-related rules, or funding sheets data sources for fund-related rules. This is the value on the left of the Condition. Pending positive values are not considered.</td>
</tr>
<tr>
<td><strong>Condition</strong></td>
<td>The option &quot;greater than or equal to&quot; is the only selection available. Rules always check that the &quot;Upper Limit&quot; (Limit Expression) is greater than or equal to the amount calculated by the Data Expression.</td>
</tr>
<tr>
<td><strong>Data Expression</strong></td>
<td>This is what is being validated. For example: Purchase Order (Pending) + Purchase Order (Approved) + Change Commit (Pending) + Change Commit (Approved) Click the Formula button. The Formula Creation window opens. The data source list includes all available cost sheet data sources for cost-related rules, or funding sheets data sources for fund-related rules. This is the value on the right of the Condition. Pending negative values are not considered.</td>
</tr>
<tr>
<td><strong>Show this message when condition is not met</strong></td>
<td>This field is required. Enter a message to display to users if the rule condition is not met.</td>
</tr>
</tbody>
</table>

**To select WBS codes or summary codes**

1) In the Edit Rule window, click the **WBS Codes** tab. (This tab is available if you chose "Per selected WBS Summary Codes" or "Per selected WBS Codes" as the rule Level.)

2) Click **Add**. The WBS Picker opens.
   - If you chose "Per selected WBS Summary Codes," the picker displays the summary WBS codes on the sheet. This is only applicable if the project/shell cost sheet uses a tree structure. Cost sheets with flat structures do not have summary WBS codes.
If you chose "Per selected WBS Codes," the picker displays the "leaf" WBS codes (individual, non-summary codes). This is applicable for both tree and flat cost sheets.

3) Select one or more codes from the picker and click Select.
To locate the WBS codes you need, you can click the Find button in the WBS Picker. For tree structure cost sheets, you can also click Expand or Collapse to help you navigate the code structure.
After you select the WBS codes, they are listed in the WBS Codes tab. You can add as many WBS codes as needed. At runtime, the rule will be applied only to the WBS codes selected.

Note: Summary WBS codes must all be at the same summary level (i.e., the same indent level).

4) For Validation, choose one of the following:
   - Validate total of selected rows: the system will calculate the sum of the selected WBS codes and then apply the rule to the total
   - Validate selected rows independently: the system will apply the rule to each selected WBS code individually

5) To remove a WBS code from the list, select it and click Remove.
6) Click OK to save and close the Edit Rule window.

Note: If you add a WBS code or summary code to this list and it is later removed from the cost sheet, the rule will not be affected. The code will still appear on the WBS Codes tab. At runtime, the rule engine will ignore the code that was removed from the cost sheet. Similarly, in a tree structure, if a summary code is changed to a leaf code (or vice versa) after adding it to the WBS Codes tab, at runtime, the rule engine will ignore the code that was changed and not create an error.

Create a project or shell rule
You can create a new rule in a project or shell manually or by copying a rule template or existing rule.

In addition to these procedures, rules can also be added to existing active and on-hold projects and shells by updating ("pushing") them from a project or shell template using Update Projects (Update project cost or fund rules (on page 249)) or Update Shells (Update cost or fund rules (on page 318)).

To create a new project or shell level rule
1) Open the project or shell and switch to Admin mode.
2) Click to Rules in the left Navigator.
3) Click New. Follow the procedure for creating a Rule Template.

To create a rule by copying a rule template
1) Open the project or shell and switch to Admin mode.
2) Click Rules in the left Navigator.
3) Click the Copy button and select Template. The Copy from Rule Template window opens.
4) Select a template from the list and click **Copy**. The Edit Rule window opens. You may make edits to the Edit Rule window if necessary. For example, by default, the Name will display as "Copy of (name of rule template)," which you may wish to change.

5) Click **OK**. The new project or shell rule will be added to the project or shell Rules log.

**To create a rule by copying an existing rule**

1) Open the project or shell and switch to Admin mode.
2) Click **Rules** in the left Navigator.
3) Select a Rule from the log.
4) Click the **Copy** button and select **Rule**. The Edit Rule window opens. You may make edits to the Edit Rule window if necessary. For example, by default, the Name will display as "Copy of (name of the copied rule)," which you may wish to change.
5) Click **OK**. The new project or shell rule will be added to the project or shell Rules log.

**Create a company rule**

At the company level, you can create rules for the company funding sheet. You can create rules that help you manage each fund, or the total of all funds.

**To create a company level rule**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Company Workspace > Rules**.
3) Click **New**. The Create a New Rule window opens.
4) Select the **Control Source**: Company Fund.
5) Select the **Rule Level**: Per Fund or Per Total of all funds.
6) Click **OK**. The Edit Rule window opens.
7) Complete the Edit Rule window as in the Rule Template procedure and click **OK**.

**Validating and Activating Rules**

Rules must be active before they can take effect. Before activating a rule, they must first be validated to make sure there are no conflicts associated with it. Rules within projects and shells as well as within project templates and shell templates can be validated and activated. Rule templates cannot be activated or validated.

**Validate a rule**

You can validate rules in projects or shells, and company level rules. You can also validate rules in project or shell templates to help ensure that they will work in the project or shell, even if you do not immediately activate them. Validation is not available in rule templates, because part of the validation process involves verifying that the cost or fund sheet is set up and any referenced business processes are active.

It is good practice to validate a rule before attempting to activate it. If you try to activate a rule directly, the system will first validate it anyway, but if there is a conflict, you will simply see an error and may not be able to assess what the issue is. By validating first, the system provides more information if the validation fails.
To validate a rule
1) Select a rule from the Rules log.
2) Click the Validate button on the toolbar. The Validation Results window opens.
   If the validation failed, the errors will be listed in the window. Edit the rule as necessary and revalidate.

Activate or Inactivate a rule
You can activate rules in projects or shells, and company level rules. You can also activate rules in project or shell templates. In this way, the rules in the projects or shells that are created from these templates will be active as soon as the project or shell is active.
You cannot activate a rule template.

To activate a rule
1) Select one or more rules in the Rules log. Be sure that the rules have passed validation.
2) Click the Activate button.

To deactivate a rule
1) Select one or more activate rules in the Rules log.
2) Click the Deactivate button.

Manage Rules
Rules can be accessed in the following logs in Administration Mode:

- Company Workspace > Rules
- Company > Templates > Rules
- Project > Rules
- Project Template > Rules
- Shell > Rules
- Shell Template > Rules

Rules can also be updated in active and on-hold projects and shells by updating ("pushing") the changes from a project or shell template using Update Projects Update project cost or fund rules (on page 249)) or Update Shells (Update cost or fund rules (on page 318)).

To edit a rule
1) Select the rule in the Rules log. If the rule is active, you must deactivate it before editing.
2) Click the Edit button. The Edit Rule window opens.
3) Make edits as necessary and click OK.

To delete a rule
Select a rule from the Rule Log window. Click Delete, then Yes when prompted to confirm.

To view a rule audit log
1) Select a rule from the Rules log.
2) Click the View menu and choose Audit Log. The Audit Log window opens, listing each event associated with the rule. The date and time stamp of each event reflect users’ current time zone as set in their User Preferences.

3) From the Audit Log window, you can double-click a listed event to view the audit record detail, which details the action taken. The details also include the user’s current time zone for reference.

To print the audit log
1) From the Audit Log window, click the Print button. A PDF file is created.
2) Do one of the following:
   - Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can view, save, or print the file.
   - Click Save. In the Save As window, navigate to the location in which you want to save the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print.

Setting up a Generic Cost Manager

You can define a Generic Cost Manager to capture cost-related activities for a Generic Shell. These include costs like:

- Rent
- Lease payments
- Landscape care
- Building maintenance and repair
- Remodel of building interiors

With this manager, you can capture and view cost transaction information based on a time scale, such as quarterly or yearly. Each shell can have one Generic Cost Manager.

The Generic Cost Manager uses specific Generic Cost business processes and business processes with the type Line Items with Multiple Codes as data sources.

Before you begin. The Generic Cost Manager and the Generic Cost Manager Attribute form must first be designed in uDesigner.

Step 1: Set the permissions for importing the Generic Cost Manager.

Step 2: Import the Generic Cost Manager.

Step 3: Import and deploy the Generic Cost Manager Attribute form.

Step 4: Set template permissions.

Step 5: Create the Generic Cost Sheet template at the company level.

Step 6: Create a Generic Cost Sheet.

Step 7: Work with Generic Cost BPs.

Step 8: Set up the Commitment Summary Template.
Note: The name of the Generic Cost Manager you will work with is determined by the name given to it in uDesigner. For documentation purposes, the manager is referred to as the Generic Cost Manager.

**Setting Generic Cost Manager Permissions**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Access Control** in the left Navigator.
3) In the right pane, select **Configurable Modules > Generic Cost Manager**.
   
   The permissions are:
   - **Modify**: Allows the use to import configurable modules from uDesigner
   - **View**: Allows the user to view configurable modules imported from uDesigner

**Import Generic Cost Manager**

To import an asset class into Unifier production, see the instructions in the topic *Importing and Deploying a Design* (on page 273).

**Import Generic Cost Manager Attribute form**

To import and deploy an attribute form into Unifier production, see the instructions in the topic *Importing and Deploying a Design* (on page 273).

**Creating a Cost Sheet Template for a Generic Manager**

You can create a Generic Cost Sheet template to use with the Generic Cost Manager.

**Create a Generic Cost Sheet template**

The name of the template is based on whatever name was given to the Generic Cost Manager. You create this template at the company level, and use it in shells that are of the type Generic.

**To create a Generic Cost Sheet template**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Templates> Configurable Modules > Generic Cost Manager** in the left Navigator.
3) Click **New** to create a new Generic Cost Sheet template. You can create multiple templates.
   
   The Properties window displays.
4) In the **General** tab, enter general information for the template:
   - a. Enter a unique **Title**, which is used to identify the template in the log, and when creating a new Generic Cost Sheet from the template.
   - b. Enter an optional **Description** for the template.
   - c. Choose a default display mode for the sheet.
     - If you choose **Flat**, the cost sheet will display the codes (rows) in a flat structure, with no indented rows. This is useful if you want to display all codes at once.
If you choose **Tree**, you have the option of creating indented, nested rows, which can be collapsed into summary, or grouping, rows. This is useful if you will be creating a large amount of rows that can be grouped into categories. You can check **Expand all codes** to expand the row structure by default.

d. Choose a **Default View**. The choices are:
   - Current Shell
   - Current Shell and Sub-shells
   - Sub-shells

5) In the **Segments** tab, define the segments of the cost codes that will be created on the sheet by choosing the **Segment Sources**. The segment sources are those that were defined in **uDesigner**. After you click **Apply**, you cannot add or remove any of the segments. If you want to use different segments, you must create a new template.

6) Click **Apply** to save changes, or **OK** to save and exit the window.

**Structure a Generic Cost Sheet template**

After you create the template, you can define the structure by adding rows and columns.

**To add rows to a Generic Cost Sheet template**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates> Configurable Modules > Generic Cost Manager** in the left Navigator.
3) Select a Generic Cost Template.
4) Click the **Structure** button. The Template Structure Setup window opens.
5) Click **Add Row**. The Generic Cost Code Details window opens.
6) To form cost codes (rows) click **Select** next to the **Cost Code** field.
7) Enter the cost code segments and click **OK**.
8) Optionally, enter a code name for the cost code.
9) Select a status (**Active** or **Inactive**).
10) Click **Add** to add the row and then continue to add rows, or click **OK** to exit.

**To add columns to a Generic Cost Sheet template**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click **Templates> Configurable Modules > Generic Cost Manager** in the left Navigator.
3) Select a Generic Cost Template.
4) Click the **Structure** button. The Template Structure Setup window displays.
5) Click **Columns**. The Cost Sheet Columns window opens.
6) Click the **New** button. The Column Properties window opens.
7) Complete the fields in the Column Properties window as described in the table below.
8) Click **OK** when you are done with the column properties.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a column name. The name you choose will appear as the column header on the sheet. If you leave the Name field blank, the selection you</td>
</tr>
</tbody>
</table>
Unifier Administration Mode

| **Datasource** | Choose a datasource. All columns must be associated with a data source. The data source that you choose will determine which of the following options are available. The types of Data sources available are:
|               | Single Datasource: These values roll up from business processes that have these attributes:
|               | Level: Project/Shell
|               | Type: Cost
|               | Sub-Type: Line Items with Multiple Codes
|               | Configurable Manager: <name of Generic Cost Manager>
|               | Logical Datasource: Generic Cost Manager (1-25). |
| **Entry Method** | Choose an entry method. This is applicable for logical data sources. Manual Entry, Direct entry into cell: Users enter values by clicking the cell and entering values directly into the cell. Formula: Values are calculated based on a specified formula entered for the column. Formulas can include the values of other columns. Click the Create button to create the formula. |
| **Data Format** | Choose a data format. Applicable for Manual Entry or Formula columns:
|               | Show as percentage: Display the data in percentages.
|               | Decimal Places: Number of decimal places to display.
|               | Use 1000 Separator (,): Use a comma as a separator.
|               | Negative Number Format: Specify the format for negative numbers. |
| **Display Mode** | Choose a display mode. Refers to whether the column is displayed on the cost sheet.
|               | Show: Default; indicates that column will display by default on the cost sheet to all users with at least "view" permission for the cost sheet.
|               | Hide: Hidden columns are active but not displayed on the cost sheet. Hidden columns can be accessed by users with "create" permission on the cost sheet.
|               | Total: Choose to designate the content of the Total row of the column. Default is Blank. You can choose Sum of All Rows or Use Formula Definition.
|               | Average: Display the average row of the column. |
| **Total** | Choose how the total is displayed. Determines what will display in the "Total" (bottom) row for the column:
|               | Blank: The total of this column is not applicable and will not display on the cost sheet. Choose this column for percentage columns and other columns where it does not make sense to display the sum total.
|               | Sum of All Rows: The sum total of the column values is displayed.
|               | Use Formula Definition: For formula columns; the formula will be applied to the "Total" row in the same way it is applied to other rows in the column. |
Setting Generic Cost Sheet Template Permissions

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, select Templates > Generic Cost Manager.
4) Select the Generic Cost Sheet template.

The permissions are:
- **Create**: Allows user to create a new Generic Cost Sheet template.
- **Modify Properties**: Allows the user to modify the template properties.
- **Modify**: Allows the use to modify an existing template.
- **View**: Allows the user to view templates.

Creating a Generic Cost Sheet

You create a Generic Cost Sheet in the same way you create a standard Cost Sheet. See *Create a company cost sheet* (on page 497) for details. Remember that the Generic Cost sheet can only be added to a generic shell, not to a project.

Setting up the Commitment Summary Template

When a Generic Cost BP of the Base Commit type reaches Terminal status, it will create a record in the Commitment Summary sheet, which tracks commits in the context of a shell. When subsequent Change Commits and General Spend Generic Cost BPs that are associated with the original Base Commit, BP will update the Base Commit record on the Commitment Summary sheet.

Create a Commitment Summary Sheet Template

To create a Commitment Summary sheet template

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Commitment Summaries in the left Navigator.
3) Click New to create a new Commitment Summary sheet template. You can create multiple templates.
4) In the General tab, enter a unique Name and an optional Description.
5) In the Options tab, enter the following column names: **Ref**, **Cost Code**, **Code Name**, **Breakdown**, and **Description**.
   Depending on design in uDesigner, some columns may not display in the Commitment Summary sheet.
6) Click OK.
To add columns to a Commitment Summary sheet template

1) In Administration Mode, go to the Company Workspace tab and click Templates > Commitment Summaries in the left Navigator.

2) Select a Commitment Summary sheet template.

3) Click the Columns button. The Columns Log window opens.

4) Click the New button. The Column Properties window opens.

5) Complete the fields in the Column Properties window as described in the table below.

6) Click OK when you are done with the column properties.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a column name. The name you choose will appear as the column header on the sheet. If you leave the Name field blank, the selection you make in the Datasource field will automatically populate the Name field.</td>
</tr>
</tbody>
</table>
| Datasource    | Choose a datasource for the column. The data source that you choose will determine which of the following options are available. The types of Datasources available are:  
  Single Datasource: These values roll up from business processes that have these attributes:  
    - Sub-Type: Line Items with Multiple Codes  
    - Classification: Base Commit, Change Commit, or General Spends  
  Logical Datasource:  
    - Commitment Cost 1 to Commitment Cost 25  
    - Commitment Remaining Balance  
| Entry Method  | This is applicable for logical data sources.  
  - Manual Entry, Direct entry into cell: Users enter values by clicking the cell and entering values directly into the cell.  
  - Formula: Values are calculated based on a specified formula entered for the column. Formulas can include the values of other columns. Click the Create button to create the formula.  
| Data Format   | Choose the data format:  
  - Currency: Formats data in a currency format with a comma (,) separator.  
  - Percentage: Formats data as a percentage (%).  
| Display Mode  | Choose a display mode. This refers to whether the column is displayed on the cost sheet.  
  - Show: Default; indicates that column will display by default on the cost sheet to all users with at least "view" permission for the cost sheet.  
  - Hide: Hidden columns are active but not displayed on the cost sheet. Hidden columns can be accessed by users with "create" permission on the cost sheet.  
| Column Position | Choose the column position. The new column will be inserted after the column selected. |
| Allow sub-breakdown with validation | Select to be able to manually enter values against breakdowns in lines created on the sheet through Base Commit and Change Commit. |

### Create a Commitment Summary Sheet

To create a Commitment Summary sheet:

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Templates > Shells > [Shell name] > Cost Manager > Commitment Summary** in the left Navigator. The Commitment Summary log opens.
3. Click the **Create Structure** button. The Select Template window opens.
4. Choose a template and click **OK**.
5. Click **Columns** to add columns.
6. Choose **File > Properties** to edit the sheet properties.
7. In the **General** tab, enter a unique **Name** and an optional **Description**.
8. In the **Options** tab, enter the following column names: **Ref**, **Cost Code**, **Code Name**, **Breakdown**, and **Description**.
   - Depending on the design in uDesigner, some columns may not display in the Commitment Summary sheet.
9. Click **OK**.

### Update a Commitment Summary Sheet from a template

To update a Commitment Summary sheet from a template:

1. Go to the **Company Workspace** tab and switch to Admin mode.
2. Click **Templates > Shells > [shell] > Cost Manager > Commitment Summary** in the left Navigator. The Commitment Summary log opens.
3. Modify the Commitment Summary
4. Click the **Update Shells** button. The Update Shells window opens.
5. Choose the shells to update and click **OK**.
Setting Up the Document Manager

A document attribute form and folder attribute form can be designed in uDesigner. These are used as the Properties window for documents and folders in the project-, shell-, and company-level Document Manager, which allows you to specify the fields that you want to associate with folders and documents (these are reportable).

**Step 1:** Import and deploy Document Manager attribute forms. This is an optional step. If you do not import these forms, default forms will be used for document and folder properties.

*Note:* Configuration of the Data Picker and Data Elements (and when applicable: Unique and Auto Sequence settings) must be done in uDesigner.

**Step 3:** Create a folder structure template. This can be used to create the folder structures in the Document Manager at the project, shell, and company level.

**Step 4:** Lock the folder structure. This is an optional step. This locks the first-level folder structure in User Mode, which prevents users from creating or editing first-level folders, allowing you to maintain a consistent structure across projects and shells and at the company level. Users can still add or edit subfolders. You can unlock the folder structure later for editing if necessary.

In This Section

- Document and Folder Properties ................................................................. 567
- Permissions ........................................................................................................ 568
- Categories ......................................................................................................... 568
- Importing Document Manager Attribute Forms ................................................. 568
- Setting Document Manager Administration and User Permissions .................. 569
- Working with Folder Structure Templates ....................................................... 569
- Lock and unlock the first-level folder structure .................................................. 571

Document and Folder Properties

Users have the ability to create attribute forms to customize the document properties and folder properties in the Document Manager, using the uDesigner. The data elements on the Properties window are fully reportable through user-defined reports.

The project documents, shell documents, and company documents log columns can also be customized through uDesigner, as well as the find function for searching on document and folders properties. You can import one document properties attribute form and one folder properties attribute form. Refer to the Unifier uDesigner User Guide for details about creating Document Manager attribute forms.
Permissions

The Document Manager permissions are set at the module level through the Permissions window or access control. Permissions for the Project-level, Shell-level, and Company-level Document Manager are set separately. When permission is granted to view the Project Documents, Shell Documents, or Company Documents node, this only grants the user the ability to access the module and potentially to view documents stored there. Users must also be granted specific permission to create, modify, or view specific documents and folders in User Mode. This can be done by the folder or document’s owner, or an administrator with full access permissions. Permissions at the folder or document level can be inherited from permission settings in the parent folder.

A user granted full access permissions will have access with full permissions to create, modify, or delete any folder or document, regardless of the permission setting at the folder or document level. In addition, a user who is the owner of a folder or document will have full access permissions on that folder or document. Any folder or document level permissions are ignored. However, if the owner transfers ownership to another user, the permission setting for the former owner will be determined by the folder or document level permission setting.

A user designated as the document administrator should have permission to create and maintain folder structure templates. Optionally, it is useful for the document administrator to have full access permissions granted for the Project Documents, Shell Documents, Company Documents, and Unpublished Documents nodes.

Categories

Categories are controlled by the data definition SYS Category. This is managed like other data definitions. Category values are added as the data set.

When entering document or folder properties in the Document Manager, a category can be defined by choosing from the values in the data set. Category information is reportable in user-defined reports.

Importing Document Manager Attribute Forms

You can customize the document and folder properties by creating DMS attribute forms in uDesigner. Ensure that you have checked for errors and changed the status to complete in uDesigner.

When deploying the attribute forms, the following will be updated with the customized interface designed in uDesigner:

- Project Documents log
- Shell Documents log
- Company Documents log
- Search by Properties Criteria

You can have only one document and folder attribute form per company, which will be used for the document and folder properties in the company-level Document Manager and across all projects and shells.
Unifier Administration Mode

To import and deploy a Document Manager attribute form into Unifier production, see the instructions in the topic *Importing and Deploying a Design* (on page 273).

### Setting Document Manager Administration and User Permissions

To grant auto-sequencing configuration permission:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode > Configuration > Document Manager**.
4) Select **Configure**.

To grant User Mode permissions:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select:
   - **User Mode > Company Workspace > Document Manager > Company Documents** or
   - **User Mode > [project or shell] > Document Manager**.
4) Select **Full Access**, **Create**, **Organize**, or **View**.

For Unpublished Documents, the permissions are **Publish**, **Download**, **Open**, **View**.

For Document type business process permission settings, refer to the *Unifier Reference Guide*.

### Working with Folder Structure Templates

You can standardize the setup of the Document Manager across your projects and shells and at the company level by creating folder structure templates. These allow you to create the folders and sub-folders that you can then import into the company Document Manager, or into any project and shell or project or shell template to organize your documents.

After importing, you can add, move, rename, or delete folders as needed. You can import a folder structure directly under the Project Document, Shell Document, or Company Documents node to create the main folder structure, or create specialized structures to import under existing folders to create sub-folders.

**Note:** By default, files attached to business processes are placed in the Unpublished Documents folder in the Document Manager. A Publish Path data element can be designed in business processes in uDesigner to specify the automatic publishing of documents to a specified path and override the default. For document-type business processes With Folder Structure, you can specify that a configured folder path be appended to the folder structure. This appended path is based on the path configured in the uuu_dm_publish_path data element on the business process form, and the selection of the Append Line Items Folder Structure to Auto Publish Path option, which is documented in the *Unifier uDesigner User Guide*; see Starting an Upper Form for details.
To create a folder structure template
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Folder Structures in the left Navigator.
3) Click the New button, or click the File menu and choose New > Create New Template. The Create Folder Template window opens.
4) Enter a name for the template.
5) Click Add. A sub-folder will be created in the Template Folder. The Template Folder corresponds to the folder into which you will import the folder structure in the Document Manager.
6) Continue to add folders.
   Select the parent folder before clicking Add. Clicking Add without selecting a folder will default to the last folder created.
7) To modify the folders, do any of the following:
   - Click + (plus sign) to the left of the folder to expand it and display the sub-folders.
   - Select a folder and click Remove to delete a folder.
   - Select a folder and click Rename to change the name.
   - Select a folder and click Move Up or Move Down to move it.
8) Click OK.

To create a folder structure from an existing project or shell
1) In Administration mode, go to the Company Workspace tab and click Templates > Folder Structures in the left Navigator.
2) Click New > Copy from Project or New > Copy from Shell. The Projects or Shells window opens.
3) Select a project or shell from the list and click Select Project or Select Shell. You can click Find to search for the project or shell. The Copy Folder Template window opens, displaying the entire folder structure of the project or shell you chose.
4) Give the new template a name. You can add, modify, delete, or move the listed folders as needed.
5) Click OK to save the template.
   The structure can be imported into the Document Manager. See Import a folder structure template.

To modify a folder structure template
1) In the Folder Structure Template log, select the folder structure template to modify and click the Open button. The View Folder Structure Template opens.
2) Click + (plus sign) to the left of a folder to expand it and display the sub-folders.
3) To modify folders, do any of the following:
   - Select a folder and click Remove to delete a folder.
   - Select a folder and click Rename to change the name.
   - Select a folder and click Move Up or Move Down to move it.
   - Click OK.
To delete a folder structure template

In the Folder Structure Template log, select the folder structure to delete and click the Delete button. Click Yes to confirm.

Lock and unlock the first-level folder structure

An administrator with full Document Manager permissions (full access or create permission on the Project Documents, Shell Documents, or Company Documents node) has the ability to lock or unlock the first-level folder structure. The first-level folder structure refers to the folders directly beneath the Project Documents, Shell Documents, or Company Documents node.

This allows an administrator to establish a standard first-level folder structure that cannot be modified. Users will not be able to add, modify, or delete the first-level folders, but can add sub-folders or documents. Permissions to lock first-level folders can be modified.

You can lock the folder structure at the Project Documents, Shell Documents, or Company Documents root folders.

To lock the first-level folder structure

1) In User Mode, do one of the following:
   - Open a project or shell and click Document Manager > Documents in the left Navigator. Be sure the Project or Shell Documents folder is selected.
   - Go to the Company Workspace tab and click Document Manager > Company Documents in the left Navigator. Be sure the Company Projects or Company Shells folder is selected.
2) Click Properties. The Folder Properties window opens.
3) Click the Options tab.
4) Select the checkbox Lock first level folder structure below Project Documents (or Company or Shell) at the bottom of the window. You may need to scroll down. Users with permissions will be able to add documents and sub-folders, but cannot add, modify, or delete the first-level folders.

   **Note:** This checkbox is only available in the Project, Shell, and Company Documents folder properties.

5) Click OK.

To unlock the first-level folder structure

Open the Folder Properties window, Options tab, and deselect the checkbox.
Setting Up the Planning Manager

Before you begin: Planning types are designed in uDesigner and deployed to Unifier. A planning type consists of planning item forms and planning sheet forms. Examples of planning types include Capital Planning, IT Planning, etc. The planning item forms are used to create new planning initiatives for that type, and the sheet forms are used to create the associated planning sheet. The types, forms, and corresponding logs are designed in uDesigner.

Step 1: Design Planning Type attribute in uDesigner and deploy to Unifier. This is similar to any other design deployment in uDesigner.

Step 2: Grant yourself permissions to create a default sheet structure and configure the planning type.

Step 3: Create a default structure for the planning sheets. This is a template that you will create to specify the default columns that should be on the planning sheets.

Step 4: Configure (activate) each planning type.

Step 5: Grant Planning Manager permissions to users. In User Mode, the permissions for planning items and sheets are Full Access, Create and View.

Once you have completed these steps, the Planning Manager is ready for use in Unifier (User mode).

In This Section

Importing a Planning Type................................................................. 573
Granting Yourself Permissions .......................................................... 573
Creating a Default Structure for the Planning Sheet ...................................... 574
Configuring the planning type ................................................................. 579
Planning Manager Production Bundle Configuration ..................................... 580
Granting planning setup permissions ......................................................... 580
Loading the Planning Manager ................................................................. 581
Granting User Permissions ..................................................................... 581
Master Log for the Planning Manager ......................................................... 582

Importing a Planning Type

To import and deploy a planning type into Unifier production, see the instructions in the topic Importing and Deploying a Design (on page 273).

Granting Yourself Permissions

When you import a new planning type, you must grant permission (to yourself, another administrator, or group such as Company Administrators) to configure the planning type and create a default structure for the planning sheets.
To grant configure permissions
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, select Administration Mode Access > Configuration > All > Planning Manager.
4) In the Module Permission Settings window, click the Add button. The Permission/Access Control window opens.
5) Click the Add Users/Groups button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give configuration permission and click the Add button. Click OK. Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select Configure and click OK. Unifier adds the name(s) to the Permission Settings window.
8) Click OK.

Creating a Default Structure for the Planning Sheet

Creating a sheet structure produces a template that users can use to create a planning sheet. You must create a default sheet structure before you can use the Planning Manager at the company level, or load the Planning Manager into a shell.

To create a planning sheet structure
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Configuration > Planning Manager in the left Navigator.
3) Select the planning item for which you want to create a structure.
4) Click the Default Structure button. The Planning Sheet Template window opens.
5) Add columns by clicking the Columns button. The Column Log opens.
6) Click New. The Column Properties window opens.
7) Use the information in the following table to complete the Column Properties window.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source</td>
<td>Select the field you want to appear on the sheet. (This list shows the fields (data elements) that were included on the Planning Item attribute form.) When you select the field, Unifier displays the field label in the Name field.</td>
</tr>
<tr>
<td>Entry Method</td>
<td>Specify:</td>
</tr>
<tr>
<td></td>
<td>‣ Manual Entry if the user must manually enter values into this field</td>
</tr>
<tr>
<td></td>
<td>‣ Formula if the field will be automatically calculated with a formula. (To create the formula, see Add a column based on a formula calculation (on page 575).)</td>
</tr>
<tr>
<td></td>
<td>‣ Query to retrieve data from the database that meets specific conditions and display it in this column. (To create the query, see Add a column based on a database query (on page</td>
</tr>
</tbody>
</table>
### Show as percentage

- **Decimal Places**: If you chose Formula or Query as the data entry method, use these options to specify how the value should be shown.

- **Use 1000 Separator(,)**: Note: If the data element was defined in uDesigner with a specific decimal amount, it will override any decimal amount you specify here.

### Display Mode

Use this option to hide or display this field on the sheet.

### Total

If you created a formula or query to calculate the values for this column, you can specify:

- **Blank**: to leave the total of this column blank. (Choose "blank" for percentage columns and other columns where it does not make sense to display a total.)
- **Sum of All Rows**: to display the sum total of all the column values.
- **Use Formula Definition**: to display the total; that is, the same formula will be applied to the total that was applied to all the values in this column.

### Average

If you created a formula or query to calculate the values for this column, you can specify:

- **Blank**: to leave the average of this column blank. (Choose "blank" for percentage columns and other columns where it does not make sense to display an average.)
- **Avg of All Rows**: to display the value as an average of all the rows’ values.

### Column Position After

Use this field to specify where the column should appear on the sheet.

---

**Add a column based on a formula calculation**

If you choose Formula as the data entry method, you can create a numeric, a "date add," or a "date difference" type of formula to automatically calculate the values for the fields in the column.

The numeric formula option is only available if the data source you specify has been built on the SYS Numeric Logical Datasource data definition.

A "data add" formula takes the value from a date field and adds the value of another field to it. This option is only available if the data source you specify has been built on the SYS Date Logical Datasource data definition.

A "date difference" formula takes the value from a date or date field and subtracts it from the value in another date or date field. This option is only available if the data source you specify has been built on the SYS Numeric Logical Datasource data definition.
To create a numeric formula for a column
1) In the **Data Source** field, choose the field that contains the value you want to include in this column.
2) In the **Entry Method** field, choose **Formula** and click the **Create** button. The Formula Creation window opens.
3) In the **Data Type** field, specify where the field comes from—a planning item, or the planning sheet. The Formula Creation window opens, showing a list of the fields from the data type you selected.
4) Create the formula using the field values in this data source, or field values and numeric operators, such as add, subtract, or multiply.
5) Click **OK**.

To create a "date add" formula for a column
1) In the **Data Source** field, choose the field on the sheet that should show the value you are calculating here.
2) In the **Entry Method** field, click **Formula**, then click the **Create** button. The Create Formula window opens.
3) In the **Date** field, select the field to which you want to add another value as follows.
   a. Click the **Select** button. The Date Element Picker window opens.
   b. In the **Data Type** field, specify where the date field you want to add to comes from—a planning item, or the planning sheet. Unifier displays a list of the fields on the planning item form, or the planning sheet.
   c. Select the field and click **OK**.
4) In the **Add** field, select the field that contains the value you want to add to the field.
5) Specify whether the calculation should be based on calendar days or work days.
6) Click **OK**. Unifier displays the formula on the Column Properties window.

To create a "date difference" formula for a column
1) In the **Data Source** field, choose the field on the sheet that should show the value you are calculating here.
2) In the **Entry Method** field, click **Formula** and select **Date Difference** from the list.
3) Click the **Create** button. The Date Difference window opens.
4) For the **Earlier** and **Later Dates**, you can use either the last date the Planning Sheet was updated, or you can choose another field from the sheet or a planning item to supply the date value.

5) In the **Calculation based on** field, specify whether the calculation should be based on calendar days or workdays.

6) If you want the value to include fractions of days, select the **Show Partial Days** check box.

7) Click **OK**.

---

### Add a column based on a database query

If you choose **Query** as the data entry method, use these instructions to add a column to the Planning Sheet that will contain values extracted from the database. These values will be retrieved from the database only if they meet the conditions you specify. (In operation, you will be extracting data from the database and testing it to determine whether or not it should be included in this column.)

The Query option is only available if the data source you specify has been built on one of the following data definitions:

- **SYS Numeric Datasource**
- **SYS Date Datasource**

#### To create a query

1) In the **Data Source** field, choose the field on the sheet that should show the value you retrieve from this query.

2) In the **Entry Method** field, choose **Query** and click the **Define** button. The Query Definition window opens.

3) In the **Data Type** field, select the functional area of Unifier the data should come from. This field is the first step in describing where the data resides in the database. For example, the data type could be a Cost BP, a fund allocation request, or a cash flow.

4) In the **Datasource** field, click the **Select** button. The Formula Creation window opens, showing a list of the fields from the data type you selected.

   You can drill down into the data type for other data sources if you wish by clicking the arrow beside this field and selecting other data source areas.
5) (Optional) Create a formula using the field values in this data source, or field values and numeric operators, such as add, subtract, or multiply. Click OK to return to the Query Definition window.

6) Specify the query condition as follows:
   a. Click Add. The Query Condition window opens.
   b. In the Data Element field, click Select to open the Data Element Picker.
   c. In the Data Source field, select the functional area of Unifier the data should come from. Unifier displays a list of the fields from the data source you selected.
   d. From the list, select the field that contains the value you want to place conditions on and click OK.
      ▪ If the value meets the condition you specify, it will be included in this column on the sheet.
      ▪ If the field you select is a date field, Unifier will display an additional field, Timescale Units, in which you will need to specify the option that matches the column definition. For example, if the column is a yearly budget, you would select Years. If the column is to show a quarterly value, you would select Quarters.
   e. In the Condition field, select the condition the value must meet to be included on the Planning Sheet, such as equals, or does not contain. For example, the value in the data element must equal 10, or the value in the data element must not equal (i.e., "is not") Yes.
   f. In the Values field, enter the value you want to test the condition on (or select the value from the list that appears when you click the Select button). The Select button may or may not appear, depending on the data element you choose. For example, for a data source of "Business Process/Status," you could choose a status from the list of statuses associated with that BP. This would limit the column data to business process records of that status.
   g. Click OK.

7) On the Query Definition window, click OK.

**Create a planning column group**

This allows you to group columns together and assign a group name, which is displayed on the planning sheet above the columns. Columns in a group must be contiguous.

**Note:** If you need to add a column to an existing group, first ungroup the existing columns, then create a new group to include the new column.

**To group planning sheet columns**

1) Select Columns. Columns must be contiguous, and cannot belong to more than one group.
2) Click Group Columns > Group. The Edit Column Groups window opens.
3) Name the group and click Ok. Group names must be unique. The Group Name will appear in the planning sheet log and also on the Planning Sheet above the columns.

**To add or remove columns to the group**

1) Ungroup the columns.
2) Select a new group of contiguous columns. Add or move columns as necessary.
3) Group the new columns.

**To change the group name**
1) Select any column in the group.
2) Click **Group Columns > Group**.
3) Enter a new Name and click **OK**.

**To ungroup columns**
Select grouped columns and click **Group Columns > Ungroup**. Ungroup will remove group name from all columns that are part of that group.

**Edit Planning Sheet Properties**
You can edit the properties in individual planning sheets or the default structure.

**To edit planning sheet properties**
1) Open the planning sheet or default structure.
2) Click **File > Properties**. The Properties window opens.
3) Complete the **General** tab: You can enter or change the **Name** of the sheet, and add an optional **Description**.
4) Click the **Options** tab:
   - **Sort by Column**: Choose the column to sort the planning item rows by. The default is Name (planning item name). As you add additional columns to the sheet, these columns will be available to select.
   - **Sort Order**: Choose Ascending or Descending; works in conjunction with Sort By Column.
   - **Update Planning Items**: When this checkbox is selected, it allows planning sheet users to manually edit planned item data. This helps to prevent conflicting data from multiple planning items.
      *This box can be checked on only one sheet per Planning Type. When this box is checked, the sheet is moved to the top of the log, and displayed in bold font, thereby acting as a master planning sheet.*
5) Click **OK**.

**Configuring the planning type**
Configuring a planning type makes it active in Unifier, gives it a numbering sequence for the records, and specifies an optional Help file and hard copy layout for printing.

**To configure a planning type**
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Configuration > Planning Manager** in the left Navigator. Each planning type will be listed here.
3) Select a planning item and click **Open** (or double-click). The Planning Configuration window opens.
4) Complete the **General** tab:
   - **Sequence Format**: This will define how planning item records will be numbered under this Planning type.
   - **Help File**: This will allow user to upload a PDF file as help file for Planning Item. This file should be available from Planning Item log window and individual planning item record.
   - **Status**: This defines if this planning type is active or not. If it is not active then it will not be visible under User Mode in Unifier even if a user has permission to access it.

5) Complete the **Custom Print** tab: You can create a custom printout of planning types. This is similar to creating a *Create Custom-Designed BP Print Layout (Custom Print tab)* (on page 356).

6) Click **OK**.

---

### Planning Manager Production Bundle Configuration

The following configurations can be included in the Planning Manager Production Bundle:

- **General setup**
  - All the fields included in the General Configuration (General tab)
- **Custom Print**
  - Word and PDF templates, if any.
- **BIP Custom Print**
  - All the BIP Custom Print in the Custom Prints and Reports.
- **Default structure**
  - The default structure of the Planning sheet.

For more information, see the *Production Bundles* (on page 197) section in this guide.

---

### Granting planning setup permissions

Once you have created a default sheet structure and activated the planning type, you need to grant yourself and other users setup permission to the Planning Manager.

**To grant setup permissions**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **AccessControl** in the left Navigator. In the right pane, navigate as follows:
   - For a Planning Manager at the company level, navigate to **User Mode Access > Company Workspace > Planning Manager**.
   - For a Planning Manager at the project of shell level, navigate to **Shells/Projects (Standard) > Setup > Planning Manager**.
3) In the Module Permission Settings window, click the **Add** button. The Permission/Access Control window opens.
4) Click the **Add Users/Groups** button. The User/Group Picker opens.
5) Select the user(s) to whom you want to give configuration permission and click the **Add** button. Then click **OK**.
Unifier adds the name(s) to the Permission/Access Control window.

6) Under Permission Settings, select Setup and click OK. Unifier adds the name(s) to the Permission Settings window.

7) Click OK.

### Loading the Planning Manager

Loading the Planning Manager is part of setting it up. In this step, you will be loading the manager into the area where it should reside—the Company Workspace, a shell, or a standard project. When you load the Planning Manager, you also load the permission infrastructure and the ability to grant permissions for the manager.

**To load the Planning Manager**

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, navigate to one of the following:
   - To load the Planning Manager into the Company Workspace, click Company Workspace > Planning Manager in the left Navigator.
   - To load the Planning Manager into a shell, open the shell or sub-shell into which you want to load the Planning Manager. Click Setup > Planning Manager in the left Navigator.

3) Click New. The New Business Processes window opens, showing the Planning Managers that are available for loading.

4) Select the planning manager you want to load and click OK. Unifier displays the manager in the right pane.

### Granting User Permissions

Once you have loaded the Planning Manager into the company workspace, or the shell, you need to grant user permissions to the Planning Manager.

**To grant user permissions**

1) Open the shell or sub-shell in which the Planning Manager resides. In Administration mode, click Access Control in the left Navigator.

2) In the right pane, under Administration Mode Access, click Access Control.

3) In the Module Permission Settings window, click the Add button. The Permission/Access Control window opens.

4) Click the Add Users/Groups button. The User/Group Picker opens.

5) Select the user(s) to whom you want to give permissions and click the Add button. Then click OK. Unifier adds the name(s) to the Permission/Access Control window.

6) Under Permission Settings, select the permissions you want to grant the user(s) and click OK. Unifier adds the name(s) to the Permission Settings window.

7) Click OK.

8) In the right pane, under User Mode Access, click Planning Manager.

9) For both the planning items and planning sheets, repeat steps step 3 through 6.
Master Log for the Planning Manager

Master Logs allow users to access all or a subset of records of the same type, in a single log that spans multiple shells or projects. Master Logs for planning items list all planning item types at the shell/project level in separate nodes for each type. Company-level planning items are not listed in Master Logs. Master Logs are located under the Home tab in Unifier.

Master Logs are available for all Planning Manager logs; however, they are not visible to users unless they have permission to view the log.

In order for users to view and work with a Master Log, you must grant permissions to it. You can grant permissions for users to access all planning items in the Master Log, or to individual planning items. To view planning items, users must also:

- Be an active member of the project, shell, or sub-shell
- Have access to at least one business process in the Master Logs node

To set Master Log permissions

1) Click the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select User Mode Access > Home > Master Log - Planning Items > [planning item].
4) Add the user(s) and set the permissions as needed:
   - **View**: Users can view all records across all projects and all records in the shell hierarchy (subject to their highest level of shell membership in the hierarchy) independent of whether or not they are assignees on or have permissions to view and manage individual records within a particular shell or project. These users can also view saved searches.
   - **Allow Bulk Edit**: Users can select one or more records within a Master Log and perform bulk edits on records. Selected records can potentially span across multiple shells. Users having this permission automatically have View permissions.
Setting Up the Portfolio Manager

The Portfolio Manager is where the budget forecast planners in your company can gather cost and schedule information on projects (both planned and in execution) and perform analyses on "what if" scenarios. These scenarios are used to propose an optimal mix of projects for a portfolio, based on available budget targets and the strategic goals of the company.

Portfolio planners can create a portfolio for a specific "planning horizon" (for example, from 2014 through 2020) and then create multiple scenarios in that portfolio. Each scenario can use forecast numbers and actuals, as well as schedule dates, for both planned and active projects in a specific shell type across a hierarchy in the company.

Budget forecast planners create these scenarios on sheets, one for each scenario. The scenario sheets can pull in the following data from any shell type in a hierarchy:

- Project information from the shell attribute form or single-record business process
- Project start and end dates from the shell attribute form or single-record business process
- Cash flow data (both forecasted and actual) from each project's Cost Manager

With this data, you can forecast costs over a specific time period (called a "period structure"). You can then manipulate scenarios by:

- Including or excluding projects
- Pushing start dates for planned projects into the future
- Modify project end dates to change the project's duration
- Proposing different cash flow distribution numbers by manually editing the cash flow columns
- Negotiating proposed budgets with project managers

**Note:** The numbers the planner proposes in a scenario will NOT affect a project's live data. The proposed numbers are stored only in the Portfolio Manager and will not affect live project data until a scenario has been approved by your company management.

Once these scenario analyses have been completed, the best (or several best) scenario(s) can be sent to the executive decision makers for approval.

Once a scenario has been approved, Unifier:

- Marks the approved scenario "shared" so that project managers can see the approved dates and numbers. The scenario is set to read-only mode and can no longer be modified or deleted.
- Updates each project's original budget numbers with the proposed numbers on the approved scenario.
- Updates each project's monthly or yearly cash flow numbers with the proposed numbers on the approved scenario.
- Updates the project start date (if it was changed) for any planned projects that will begin during the portfolio’s planning period.
- Locks the budget and cash flow numbers to prevent any further changes.
To set up the Portfolio Manager

Before you begin: A portfolio attribute (detail) form is designed in uDesigner and deployed to Unifier. This attribute form is what you and other users will use to create new portfolios in Unifier.

Step 1: Design the Portfolio Manager attribute form in uDesigner and deploy to Unifier. This is similar to any other design deployment in uDesigner.

Step 2: Grant yourself permissions to configure the portfolio and create period structures.

Step 3: Create period structures under the Standards & Libraries node. Primavera Unifier uses these period structures to calculate costs for the portfolio’s forecasted budget.

Step 4: Configure the portfolio.

Step 5: Grant Portfolio Manager permissions to users.

Once you have completed these steps, the Portfolio Manager is ready for use in Primavera Unifier’s User Mode.

In This Section

Import a Portfolio ................................................................. 584
Grant Yourself Permissions .................................................. 584
Create Period Structures ....................................................... 585
Configure the Portfolio Manager ........................................... 586
Portfolio Manager Production Bundle Configuration ............... 590
Delete Columns From a Sheet .............................................. 591
Grant User Permissions ........................................................ 591

Import a Portfolio

To import and deploy a portfolio manager into Unifier production, see the instructions in the topic Importing and Deploying a Design (on page 273).

Grant Yourself Permissions

When you import a new portfolio, you must grant permission (to yourself, another administrator, or group such as Company Administrators) to configure the portfolio and set up period structures in the Standards & Libraries.

To grant configure permissions

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, select Administration Mode Access > Configuration > All > Portfolio Manager.
4) In the Module Permission Settings window, click the Add button. The Permission/Access Control window opens.
5) Click the Add Users/Groups button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give configuration permission and click the Add button. Then click OK. Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select Configure and click OK. Unifier adds the name(s) to the Permission Settings window.
8) Click OK.

To grant permissions to create period structures
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, select Administration Mode Access > Standards & Libraries > Period Structure.
4) In the Module Permission Settings window, click the Add button. The Permission/Access Control window opens.
5) Click the Add Users/Groups button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give configuration permission and click the Add button. Then click OK. Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select Create and click OK. Unifier adds the name(s) to the Permission Settings window.
8) On the Permission Settings window, click OK.

Create Period Structures

Each portfolio needs a defined period of time in order to be able to calculate costs for the forecasted budget. (Currently, Unifier supports only yearly time periods.) Creating a period structure designates the time scale for the period, the format the period should appear in at runtime on the period picker, and whether or not the period is active (available for use at runtime).

Once you have created a period structure, it cannot be deleted. In addition, once a period is in use in a deployed Portfolio Manager, it cannot be modified or inactivated.

To create a period structure
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Standards & Libraries > Period Structure in the left Navigator.
3) Click New. The Period structure window opens.
4) Use the information in the table below to complete the fields in the Period Structure window.
5) Click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period Structure</td>
<td>Enter a name for the period structure.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter a description of this period. This is not mandatory, but is recommended.</td>
</tr>
</tbody>
</table>
### Configure the Portfolio Manager

Configuring a portfolio means configuring the scenarios that will be analyzed in a portfolio. By configuring a scenario, you create a "template" for the sheets that planners can use to create the scenarios for analyzing and forecasting capital budgets.

The template will contain:

- The planning options for the scenario sheet, such as the period structure and data linking options
- Project phases that identify a project as planned or in execution
- The data sources to be used for the analysis, such as project dates and cash flow sources.
- The query that will extract the project data that should be included in the portfolio
- The column layout that will appear on the scenario sheet

#### To configure a portfolio

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Configuration > Portfolio Manager** in the left Navigator. Each portfolio will be listed here.

3) Select a portfolio and click **Open** (or double-click). The Portfolio Configuration window opens.

4) Use the information in the first table below to complete the **General** tab.

5) Click **Apply**, then click the **Query** tab.

On the Query tab, you create a query that will search the database and extract the shell records to display on the scenario sheets in the portfolio. The query will filter the records returned from the database according to a condition or conditions you specify. The condition(s) will "test" a field or fields on the form to see if they pass or fail the criteria. If the fields pass the criteria, Unifier will make it available for the scenario sheets.

<table>
<thead>
<tr>
<th>Status</th>
<th>Specify whether this period is active (available for use) or inactive.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period Settings</td>
<td>Specify the time scale for this period.</td>
</tr>
<tr>
<td>Period:</td>
<td>Select the time period for the analysis. This list shows years, each beginning with a month in the year and ending at the end of the month preceding the beginning month.</td>
</tr>
<tr>
<td>Identify Period By:</td>
<td>Use this option to accommodate time periods that span across two years. For example, if your fiscal planning period is from July 2010 to June 2011, use this option to tell Unifier that the planning year is based on either a starting month of July or an ending month of June.</td>
</tr>
<tr>
<td>Format:</td>
<td>Specify the format the date should appear in:</td>
</tr>
<tr>
<td>For Year, YYYY or YY</td>
<td></td>
</tr>
</tbody>
</table>
The query that extracts the projects from the database is a dynamic process that occurs whenever users open a scenario sheet. The projects that appear on the sheet will fluctuate, depending on whether they still meet the criteria for inclusion. For example, a project that was previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project may be added to the sheet because it now meets the query criteria.

6) In the **Auto-add/auto-remove projects**... field, select the check box if you want Unifier to automatically add and remove projects to and from scenario sheets.

If you do not select this check box, Unifier will display these projects at the bottom of the scenario window in a separate grid, where users can manually select and add them to the scenario sheet.

**Note:** This setting does not work retroactively. If you change this setting at a later date, it will affect only those portfolio plans that are new.

7) Create the query.

The query will search the database and extract the shell records to display on the scenario sheet. The query will filter the records returned from the database according to a condition or conditions you specify. The condition(s) will "test" a field on the form to see if it passes or fails the criteria. If the field passes the criteria, Unifier will include it on the scenario sheet.

a. Click the **Add** button. Unifier displays the Add Query Condition window.

   In the **Data Element** field, select the field on the attribute form or single-record business process that you want to test with the condition.

   For example, the condition might be that the status field on the shell attribute form must be "Active."

   The window expands to show an active **Condition** field and additional fields where you can specify the query criteria.

b. In the **Condition** field, select the condition the value in the field must meet.

c. Click **OK**.

   The remaining fields on this window vary, depending on the data element and the condition you specified. For help in completing these fields, see About Queries.

**Note:** If any field in the query or queries is subsequently removed from the shell or single-record BP design, the entire query operation will be ignored. That is, if one query fails because a field was removed from the design, Unifier will ignore all the queries. If a field has been removed from a design, you must amend the query.

8) Repeat steps a through d to include additional query conditions.

9) Click **Apply**, then click the **Columns** tab.

10) Use the information in the second table below to complete the Columns tab.
### In this field: Do this:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Specify whether this portfolio is active (available for use) or inactive. When you activate a portfolio, Unifier loads it into all shells, but it will not be available to users until you grant user permissions to it. (See <em>Grant User Permissions</em> on page 591.)</td>
</tr>
<tr>
<td>Include Projects of Type</td>
<td>Specify the shell type that contains the project data that should be analyzed. The list will show all multiple-instance WBS shell types from any hierarchy, and data from all shells of this type will be used in the analysis.</td>
</tr>
<tr>
<td>Project attributes from</td>
<td>The portfolio will automatically include data from the portfolio attribute (detail) form; however, you can also include information from single-record business processes, if they are appropriate. If there is a single-record business process that contains information that you want to include in this portfolio, select the name of the record you want to include.</td>
</tr>
<tr>
<td>Period Structure</td>
<td>Specify the time period this portfolio should use. These period structures were created under the Standards &amp; Libraries node after the portfolio was imported. The option shows what the period is (yearly, quarterly, or monthly) and the format in which the period will appear on the Period Structure Picker at runtime.</td>
</tr>
</tbody>
</table>
| Projects are in planning when in the following phases | If you are including planned projects, you need to specify what phases of these projects you want to include in the analysis for this portfolio.  
- **Planning Phases** Select the planning phases whose data should be used in the portfolio analysis. You can select multiple phases. |
| Projects added to a scenario are initially linked or unlinked | As the administrator, you can specify that projects in a portfolio are linked or unlinked to project data when the user first opens the scenario sheet. Once the scenario sheet is open, the user can choose to link or unlink the projects as appropriate.  
- **Linked** This option links the project data to the project database and updates the data in the portfolio every time the user opens a scenario sheet.  
- **Unlinked** This option unlinks the project data from the database. Select this option if you do not want the project data dynamically updated. |
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Data Sources</td>
<td>Specify where the data should come from for the portfolio. In this option, you will be choosing the data elements that will provide the values for the scenario analyses.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Start Date</strong> Select the name of the field (data element) that contains the project start date. The elements you see on this list come from the project attribute form and any single-record business process you included.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Update project start date upon approval</strong> Select this check box if you want to update a planned project’s start date on the attribute form when a scenario is approved for the current budget. The approved scenario may contain an adjusted start date. If the start date is adjusted on the scenario, Unifier will change the date on the project/shell’s attribute form to reflect the new date. If the Schedule sheet properties are configured to drive the schedule start date from the project/shell attribute form, the form will then update the start date on the Schedule sheet.</td>
</tr>
<tr>
<td></td>
<td>- <strong>End Date</strong> Select the name of the field (data element) that contains the project end date. The elements you see on this list come from the project attribute form and any single-record business process you included.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Budget Source</strong> Select the budget source that should be used in the analysis. This budget source was defined under Standards &amp; Libraries &gt; Cash Flow.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Forecast Source</strong> Select the forecast source that should be used in the analysis. This forecast source was defined under Standards &amp; Libraries &gt; Cash Flow.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong></td>
</tr>
<tr>
<td></td>
<td>- Select the data source according to your business case.</td>
</tr>
<tr>
<td></td>
<td>- The curves of the selected data sources must have the same currency.</td>
</tr>
<tr>
<td>Scenario Columns</td>
<td>Specify what additional columns you want to appear on the scenario sheet. You can add the Project Phase Data Element (DE) to the Portfolio in order to see the latest value of Project Phase (Planning, Conceptual Design, Schematic Design, etc.) in the Portfolio as it changes (manually or via Gates) without having to take a manual step of saving a single record BP within a Shell. To add the Project Phase DE, go to the Configuration window, click Add, and from the Data Element drop-down list select Project Phase.</td>
</tr>
</tbody>
</table>

---

**Note:**

- Select the data source according to your business case.
- The curves of the selected data sources must have the same currency.
<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
</table>
| Default Sorting | Specify the default order in which the columns should appear.  
- **Initial Sort Column**: Use this to specify the column by which the scenario sheet is initially sorted when the user opens the sheet. The user can change the column sorting.  
- **Sort Order**: Specify whether the projects on the sheet should appear in ascending or descending alphanumeric order.  
- **Freeze column up to**: This option affects the scrolling behavior of the scenario sheet. Scenario sheets contain certain columns that must always appear on the sheet. As administrator, you can add more columns to the sheet. Of these columns you add, you must specify that 1 of those columns must remain fixed when the user scrolls the sheet horizontally. |
| Planning Horizon | Specify how many years should be included in this scenario. The default horizon is 10 years. This option designates the year columns that will appear on the scenario sheet.  
- **Number of years’ planning**: Select the number of years to be included in this scenario.  
- **Number of years planned in months**: Specify how many years the planner wants to plan by months. For example, the planner may want to plan by month for the first two years; thereafter, by year. |

**Portfolio Manager Production Bundle Configuration**

The following configurations can be included in the Portfolio Manager Design Bundle:

- **General setup**
  All the fields included in the General Configuration (General tab), including: Yearly Planning and Project Data Sources.

  - **Note**: You can tag the Portfolios to be included in the Production Bundle by way of: Configuration > Portfolio Manager > Portfolio Manager log window > Tag > Production

- **Query**
  All queries that have been configured based on data sources.

- **Columns structure**
The structure of the Column that has been defined in the Columns tab.

You can include the Portfolios that you want to include in your Production Bundle. To include a Portfolio:

1) Select the Portfolio from the log.
2) Click the Tag drop-down list and select Production. To remove a tag from a Portfolio, and exclude the Portfolio from the Production Bundle, use the Clear option.

**Notes:**
- You can tag a Portfolio that has been configured, only.
- Once you tag a Portfolio, the Portfolio will be included in the Production Bundle.
- You can tag multiple Portfolios.
- The Last Bundled Date (in Configuration - Portfolio Manager log window) displays the date that the Portfolio was bundled.
- For a successful inclusion of a Portfolio, the Shell and single-record Business Process must be a part of the Design Bundle.

For more information, see the Production Bundles (on page 197) section in this guide.

### Delete Columns From a Sheet

You can delete columns from a sheet from either the Portfolio Configuration window, or the Column Properties window.

**To delete columns from the Portfolio Configuration window**

1) Click the Columns tab.
2) In the Scenario Columns section of the configuration window, select the name of the column and click the Remove button.

**To delete columns from the Column Properties window**

1) Click the Columns tab.
2) In the Scenario Columns section of the configuration window, click the Modify button. The Column Properties window opens.
3) Click the Delete button to delete the column.

### Grant User Permissions

Once the Portfolio Manager is active in a shell, you need to grant user permissions to the Portfolio Manager.

**To grant user permissions**

1) Open the shell where the Portfolio Manager resides and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) In the right pane, under User Mode Access, click Portfolio Manager.
4) Click the portfolio. The Permission Settings window opens.
5) In the Permission Settings window, click the **Add** button. The User/Group Permissions window opens.
6) Click the **Add Users/Groups** button. The User/Group Picker opens.
7) Select the user(s) to whom you want to give permissions and click the **Add** button. Unifier adds the name(s) to the Permission/Access Control window.
8) Under **Permission Settings**, select the permissions you want to grant the user(s) and click **OK**. Unifier adds the name(s) to the Permission Settings window.
9) Click **OK**.
Setting Up the Resource Manager

The Resource Manager uses Resource Booking business processes and Timesheet business processes. The Resource Manager attribute form (used to create resources and roles) has to be deployed in uDesigner.

In addition, Resource Booking and Timesheet business processes can be used with the Resource Manager (however, Resource Booking BPs are not available in generic shells). The Resource Booking is used for booking resources on the Booking Summary Sheet. When the record is approved, the resource is considered to be hard-booked. While the record is pending, the resource booking is considered to be soft-booked. One Resource Booking business process can exist at the company, project, or shell level.

If a Resource Booking and a Timesheet business process have been designed and deployed in Unifier (to be used with the Resource Manager), then these business processes need configuration and setup.

The Timesheet business process can be designed to roll up hours and costs from the time sheet to cost sheets. Required fields are the Resource picker (to pick the resource) and Week of (date). In addition to a Role picker and rate/hours fields, the time sheet detail form can include an Activity picker (to link the time sheet to a schedule sheet activity), Account Code picker (to link to the company accounts sheet), and Project picker (to link to a project). Only one time sheet business process can exist at the company level. However, multiple workflow schemas are allowed.

Some of data elements and data definitions used with the Resource Manager need data set values. (See Adding and Managing Data Sets (on page 77).) Data definitions that will require data set values include:

- SYS Resc Calendar NW Day Type
- SYS Resource Proficiency
- SYS Resc Work Type
- SYS Resource Skill
- SYS Resource Interest

In This Section

Set Up Resource Manager ................................................................. 593
Configure the Resource Manager at the company level ..................... 594
Resource Manager Production Bundle Configuration .......................... 595
Creating Roles and Resources ............................................................ 595
Setting up the Resource Manager in Projects or Shells ....................... 599

Set Up Resource Manager


Before you begin: Resource Manager attribute form is designed in uDesigner and deployed to Unifier.
Step 1: Design Resource Manager attribute form in uDesigner and deploy to Unifier. This is similar to any other design deployment in uDesigner. See the instructions in the topic Importing and Deploying a Design (on page 273).

Step 2: Configure the Resource Manager at the company level.

Step 3: Create or import roles and resources at the company level.

Step 4: Set up the Resource Manager at the project level.

Step 5: Set permissions at company and project levels.

Step 6: Define the project-level resource allocation sheet under Project Templates (optional).

Step 7: Activate the Resource Manager to create the Resource Sheets at company and project levels (User Mode*):
- Allocations Summary
- Resource Allocation
- Booking Summary
- Actuals Summary
- Utilization Summary
- Bookings vs. Actuals
- Availability

Step 8: Set up the Resource Dashboard (User Mode*).

### Configure the Resource Manager at the company level

The Resource Manager can be configured at both the company level and the project or shell level.

**To configure the Resource Manager at the company level**

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Configuration > Resource Manager in the left Navigator. Resource Manager is listed in the log automatically.
3) Select Resource Manager and click Open.
4) Complete the Resource Manager General Configuration window as described in the following table and then click OK.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Code</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>Manual: Allows you to enter a resource code manually while defining resources. Validation is performed to ensure resource codes are unique.</td>
</tr>
<tr>
<td></td>
<td>Automatic: Automatic numbering generates unique resource codes using a sequence.</td>
</tr>
<tr>
<td></td>
<td>Sequence Format: For automatic numbering, enter an alpha-numeric prefix for the resource code (e.g., RES).</td>
</tr>
<tr>
<td></td>
<td>Start: Enter a number to start the sequence. Numbers are</td>
</tr>
</tbody>
</table>
Resource Sheet Defaults

These define default values for resource sheets. These values can be changed any time. Choose options for:

- **Timescale Unit:** Options are day, week, month. Defines the default granularity for the display on all resource sheets at the company and project level.
- **Date From:** Enter a default start date for the timeline display on all resource sheets at the company level. This default does not prevent entering transactions before this date. Actual start date of the timeline will be driven by the earliest applicable transaction date (for booking, assignment, allocation, etc.).
- **Date To:** The latest applicable transaction date.

Resource Booking

- **Allow over-booking of resources:** The resource booking process will be allowed to overbook a resource (beyond the resource’s daily capacity).
- **Maximum Over-booking Percent:** This field is enabled if the over-booking checkbox is selected. Enter any positive integer amount. If a value is not specified, there is no limit on over-booking.

This information can be edited at any time. Changes will be reflected on subsequent bookings.

Note: A resource can never be booked more than 24 hours on any day.

---

**Resource Manager Production Bundle Configuration**

The following configurations can be included in the Resource Manager Production Bundle:

- **General setup**
  
  All the fields included in the General Configuration (General tab)

For more information, see the *Production Bundles* (on page 197) section in this guide.

**Creating Roles and Resources**

You create roles and resources in Administration Mode in the company workspace. These can be used with the Resource Manager.

**Create a role**

**To create a role**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Resource Manager > Roles** in the left Navigator. The Roles log opens.
3) Click **New**. The Create Role window opens.
4) Complete the General tab.
5) Click **Active** when you are ready to activate the role and make it available to assign to a resource.
6) Click the **Rates** tab. This allows you associate billable rates to a role. See *Add a billable rate to a role (Rates tab)* (on page 596).
7) Click the **Resources** tab. This allows you to associate resources to a role. See *Add resources to a role (Resources tab)* (on page 596).

Resources can be associated with roles from this tab, and also from the Roles tab in the Resources Properties.
8) Click **OK**.

**Add a billable rate to a role (Rates tab)**

*To add a billable rate to a role*
1) In the Create Role window, click the **Rates** tab.
2) In the **Currency Name** field, click the **Select** button. Select the currency to use and click **OK**.
3) Click the **Add** button. The Role Rates window opens.
4) In the Roles window:
   - Define an effective date for the rate (click the calendar icon and select the date).
   - Enter a standard rate.
   - Enter an overtime rate.
5) Click **OK**.

**Add resources to a role (Resources tab)**

*To add resources to the role*
1) In the Create Role window, click the **Resources** tab.
2) Click **Add** and choose a resource from the Resource picker.
3) Click **OK**.

**Import roles**

Importing lets you add multiple new roles, or update attributes for existing roles.

*To import roles*
1) In the Roles log, click the **Export** button. Save the CSV file. The CSV file columns correspond to the attributes on the role attributes form (General tab).
2) Open the file and add roles as needed.
3) Click the **Import** button and browse to the CSV file you saved. Import the file.
Create a resource

To create a resource

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Resource Manager > Resources in the left Navigator. The Resources log opens.
3) Click New. The User Picker window opens, listing active and on-hold users from the sponsor company and active partner companies.
4) Select a user and click OK. The Create Resource window opens.
5) Complete the General tab. This tab may vary with the design of the resource attribute form you imported. Fields may include:
   - **Resource Code:** Automatically generated, manually entered, based on the configuration.
   - **Resource Name:** Enter a name to associate with the resource.
   - **Description:** Enter an optional description.
   - **Status:** The default is active.
   - **Resource Capacity (Hrs):** Enter the number of hours users can work in a day. Default value is 8.
   - **Sunday (Hrs.).....Saturday (Hrs.):** Depending on the design of the Resource Attribute form, these fields may or may not appear on the General tab. If they do, you can enter the number of hours the resource can work on each of these days. Unifier will use these values to calculate the resource’s Capacity per week.
   - **Default Capacity (Hrs):** Default value is 8. Number of hours a person can work in a day. This is overridden if the form was designed to include the Sunday through Saturday hours fields.
6) Click the Roles tab. This lets you choose a role to associate with the resource. See Add a role to a resource (Roles tab) (on page 597) for details.
7) Click the Skills tab. This allows you to associate one or more skills to a resource. See Add a skill set to a resource (Skills tab) (on page 598) for details.
8) Click the Calendar tab. The calendar displays bookings, vacation days, etc. for the resource. See View and manage resource booking details (Calendar tab) (on page 598) for details.
9) Click the Projects/Shells tab. The tab displays the projects/shells in which the resource is booked and booking specifics. See View resource project/Shell booking information (Projects/Shells tab) (on page 598) for details.
10) Click OK.

Add a role to a resource (Roles tab)

To add a role to a resource

1) In the Create Resource window, click the Roles tab.
2) Click Add, select a role from the Role picker and click Open. The role is added to the resource.

To remove a role from a resource

1) In the Create Resource/Resource Properties window, click the Roles tab.
2) Select the role and click Delete.
Add a skill set to a resource (Skills tab)

To add a skill set to a resource
1) In the Create Resource window, click the Skills tab.
2) Click Add. Select a skill name from the drop-down list (defined for the data definition).
3) Select the proficiency.
4) Select the interest.

To remove a skill from a resource
1) In the Create Resource/Resource Properties window, click the Skills tab.
2) Select the skill and click Delete.

View and manage resource booking details (Calendar tab)

You can view and manage booking dates, unavailable dates (non-project time, such as vacation days), and more. The range of dates and total booked hours for each project/shell gives the Resource Manager an idea of how long the project/shell engagement is for the resource. Hard-bookings and soft-bookings are displayed on the calendar.

To view and manage the resource booking calendar and details
1) In the Create Resource window, click the Calendar tab. The calendar displays bookings, vacation days, etc. for the resource.
2) You can click the Month tab or Week tab to change the calendar view. A maximum of five projects/shells can be shown for any day in the month view. If a resource is booked for more than five projects/shells in a day, you can view them all in the week view.
3) To view all projects/shells for any given day, select a day and click the Booking Details button.
   The Resource Booking Details window opens. The window displays the project/shell bookings for that resource on the selected date. For each project/shell, it shows project/shell number, project/shell name, booking status, dates when the booking starts and ends, total hours booked for the resource during this period on the project/shell, and total hours booked on the current date on the project/shell. The dates and hours shown include non-project time.
4) To make a resource unavailable for booking on a certain date, select the date and check the Unavailable checkbox. You can click the drop-down list and select an option.
   • The range of dates and total booked hours for each project gives the Resource Manager an idea of how long the project engagement is for the resource.
   • Hard-bookings and soft-bookings for the resource are displayed on the calendar.

View resource project/Shell booking information (Projects/Shells tab)

To view project/shell booking information for a resource:

In the Create Resource window, click the Projects/Shells tab. The tab displays the projects/shells in which the resource is booked and the following information:

• Earlier Booking Date: Earlier date on which a booking exists for the project/shell for the current resource.
Unifier Administration Mode

- Latest Booking Date: Latest date on which a booking exists for the project/shell for the current resource.
- Hard Booked Hrs.: Total hours resource is hard-booked on the project/shell.
- Soft Booked Hrs.: Total hours resource is soft-booked on the project/shell.

Import resources
Importing lets you add multiple new resources or update attributes for existing roles.

To import resources
Importing lets you add multiple new resources, or update attributes for existing roles.
1) In the Resources log, click the Export button. Save the CSV file. The CSV file columns correspond to the attributes on the resource attributes form (General tab).
2) Open the file and add roles as needed.
3) Click the Import button and browse to the CSV file you saved. Import the file.

Update resource information by importing
To update resources:
1) Click Export.
2) Complete the CSV file.
3) Import the file. The import will support updating attributes of existing resources. You cannot add new resources through importing. Below is an example of a CSV file.

Setting up the Resource Manager in Projects or Shells

You can set up the Resource Manager in an individual project or shell, or in a project/shell template. The Resource Manager is available to both WBS shells and generic shells; however, some Resource Manager features are limited in generic shells.

Set up the Resource Manager in a project/shell

Setting up the Resource Manager in a project or shell consists of choosing resource allocation options and resource sheet defaults.

Note: Once you complete and save the Resource Manager setup information in a project or shell, the resource sheets will be created based on the options you choose. Once saved, you will not be able to change the allocation options. (You can change the resource sheet defaults.)

To set up the Resource Manager in a project or shell
1) Go to Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click:
   - Company Sponsored Project > [project] > Setup > Resource Manager to set up the Resource Manager in a project.
Company Sponsored Shell > [shell] > Setup > Resource Manager to set up the Resource Manager in a shell.

3) In the right pane, select Resource Manager and click Open. The Configuration window opens. Complete the window as described in the following table.

4) Complete the window as described in the following table.

5) Click OK.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Based Allocation</td>
<td>Choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>Allocate via Resource Allocation Sheet at Company level: By default, allocations to this project will be done from the company level via the resource allocation sheet. Allocated roles will be pushed to the project. The project level resource allocation sheet will be disabled. Manual booking via the Booking Summary Sheet will be available, as well as booking edits.</td>
</tr>
<tr>
<td></td>
<td>Allocate via Resource Allocation Sheet at Project/Shell level: When this option is chosen, allocations to this project or shell will be done via the project/shell-level resource allocation sheet. Role allocations will be initiated (pulled) from the project/shell. This project/shell will not be available to allocate from the company level. Manual booking via the Booking Summary Sheet will be available, as well as booking edits.</td>
</tr>
<tr>
<td></td>
<td>No Allocation: Choose this option if the project/shell does not require role hours to be allocated. If you choose this option, the Allocation and Utilization Sheets will not be visible to the user, and Resource Booking BPs will not be available in the project/shell. Manual booking via the Booking Summary Sheet will be available, as well as booking edits. Note: This is the only option available to the Resource Manager in a generic shell.</td>
</tr>
</tbody>
</table>

| Resource Sheet Defaults       | These default values will apply to all resource sheets at the project level:                                                                                                                                 |
|                               | **Timescale Units:** Options are day, week, and month. These define the default granularity on all resource sheets at the company and project level. This value can be changed at any time. |
|                               | **Date From:** Enter a default start date for the timeline display on all resource sheets at the company level. This default does not prevent entering transactions before this date. Actual start date of the timeline will be driven by the earliest applicable transaction date (for booking, assignment, allocation, etc.). This value can be changed at any time. |
|                               | **Date To:** Enter an end date for the timeline display on all resource sheets at the company level. This default does not prevent entering transactions beyond this date. Actual end date of the timeline will be driven by the latest applicable transaction date (for booking, assignment, allocation, etc.). This value can be changed at any time. |

To edit the Resource Manager setup in a project or shell

1) Go to Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click:
To set up the Resource Manager in a project or shell template

In a project or shell template, you can set up the Resource Manager as you would within a project or shell. You can also set up a project/shell level resource allocation sheet if the Resource Manager configuration is set to allow allocations at the project/shell level.

**To set up the Resource Manager in a project template**

1. Go to the **Company Workspace** tab and switch to **Admin** mode.
2. Click **Templates** in the left Navigator.
   - For a project, click **Projects (Standard) > [project]**.
   - For a shell, click **Shells > [shell]**.
   Unifier displays the Template Log in the right pane.
3. Double-click the name of the template in which you want to set up the Resource Manager.
4. In the Navigator, click **Setup > Resource Manager**.
5. On the right pane, select **Resource Manager** and click **Open**. The Configuration window opens. Complete the window as described in the table in *Set up the Resource Manager in a project/shell* (on page 599).
6. Complete the window as described in the table in *Set up the Resource Manager in a project/shell* (on page 599).
7. Click **OK**.

**To set up a resource allocation sheet in a project/shell template**

1. Go to the **Company Workspace** tab and switch to **Admin** mode.
2. Click Templates in the left Navigator.
   - For a project, click **Projects (Standard) > [project]**.
   - For a shell, click **Shells > [shell]**.
   Unifier displays the Template Log in the right pane.
3. Double-click the name of the template in which you want to set up the allocation sheet.
4. In the Navigator, click **Resource Manager > Resource Sheets**.
Unifier automatically creates an allocation sheet when the Resource Manager is activated in the project/shell.

6) To add resource allocations to the template, click the Add button. The Resource Allocation window opens.

7) Complete the window:
   - **Role Name**: Click Select, choose a role, and click OK.
   - **Date From**: Click the calendar and choose the start date for the allocation.
   - **Date To**: Click the calendar and choose the end date for the allocation.
   - **Allocated Hours**: Unifier automatically calculates the allocated hours and displays them in this field. You can edit the hours, if necessary.

8) Click OK.

**About Resource Manager sheets**

Default Resource Manager sheets are created automatically in User Mode when the Resource Manager is activated.
Setting Up the Schedule Manager

Here is the overall process for setting up schedule sheets in projects or shells:

**Step 1**: Import and deploy the Activity Attribute form in uDesigner. If a configured schedule attribute form will be used, import it into Unifier. If a schedule attribute form has not been designed, Unifier will use a default attribute forms for the Schedule Manager and the activities.

*Note*: Configuration of the Data Picker and Data Elements (and when applicable: Unique and Auto Sequence settings) must be done in uDesigner.

**Step 2**: Set customer calendar permissions, if necessary.

**Step 3**: Create a schedule sheet template. There are two places where you can create schedule sheet templates: At the company-level, under Templates > Schedule Sheets; and in project/shell templates. The process for creating schedule sheets is similar in both types of templates.

*Note*: The advantage of creating schedule sheets in a project/shell is that when you clone a project/shell template, you can copy all schedule sheets in that template.

Once you have completed these steps, the Schedule Manager is ready for use in Unifier's User Mode.

In This Section

- Additional Options for Setting Up the Schedule Manager ........................................ 603
- Importing an Activity Attribute Form ....................................................................... 604
- Create Schedule Sheet Templates ........................................................................ 604
- Grant Schedule Manager and Custom Calendar Permissions to Users ................. 605
- Refresh Schedule Sheet Data ............................................................................... 605
- Updating Schedule Sheet Properties from Templates ........................................... 606
- Update Schedule Sheet Activities from Templates ................................................ 608
- Importing Schedule Files ....................................................................................... 610
- Scope Management Setup .................................................................................... 620
- About activity-level editing .................................................................................... 621

**Additional Options for Setting Up the Schedule Manager**

Configure a project/shell template schedule sheet as a **Master Schedule Sheet**. After cloning the project/shell, you can use the **Master Schedule Sheet** to create other schedule sheets in the project/shell that have the same sheet properties, including start and finish dates.

- Link schedule sheets in a project/shell template to project/shell schedule sheets.
- Configure data mapping to allow direct importing of external sources such as Microsoft Project or Primavera schedules.
- Create program level schedule sheets.
Note: Many of the tasks you might perform as Administrator can also be done at the Unifier user level. The tasks you can perform only at the Administrator level are completely described in this chapter. For those activities that overlap levels, Refer to the Unifier User Guide for detailed instructions.

**Importing an Activity Attribute Form**

The Schedule Manager needs attribute forms to define the activities for a project schedule, including its start and end dates.

When creating new activities on the schedule sheet, Unifier opens this form as the General tab of the Activity Properties form.

Note: If there is no attribute form for the Schedule Manager, Unifier will create a default schedule sheet with the following columns: ID, Activity name, Start date, Finish dates, and Duration.

The Resource Manager and the Schedule Manager can work together for resource management. If you have deployed the Resource Manager, Unifier uses the Resource Assignment Attribute form as the Resource tab of the Activity Properties form.

To import and deploy a schedule attribute form or a resource assignment attribute form into Unifier production, see the instructions in the topic *Importing and Deploying a Design* (on page 273).

**Create Schedule Sheet Templates**

There are three locations for schedule sheet templates in Unifier: in company Templates, in a project template, or in a shell template. Project and shell schedule sheet templates are copied into a new project or shell during cloning, provided you selected Schedule Sheets in the cloning window.

The creation steps are similar for any schedule sheet template; however, Activity Properties in the company-level template only allow you to set up the General and Dependencies tabs. In project or shell schedule sheet templates, you can set up all properties.

**To create a schedule sheet template**

1) Go to the **Company Workspace** tab and switch to Admin mode.
   - For a company-level template, in the left Navigator, click **Templates > Schedule Sheets**.
   - For a project template, in the left Navigator, click **Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets**.
   - For a shell template, in the left Navigator, click **Templates > Shells > [shell type] > [shelltemplate] > Schedule Manager > Schedule Sheets**.

2) To create the schedule sheet for the template, use the instructions on creating a schedule sheet in the Unifier User Guide, Create a project or shell cash flow sheet in Cash Flow.
Grant Schedule Manager and Custom Calendar Permissions to Users

Once the Schedule Manager is active in a shell, you need to grant user permissions to the manager and the custom calendars.

To grant user permissions to the Schedule Manager

1) Open the shell where the Schedule Manager resides and switch to Admin mode.
2) In the left Navigator, click **Access Control**.
3) In the right pane, under **User Mode Access**, click **Schedule Manager**. The Permission Settings window opens.
4) In the Permission Settings window, click the **Add** button. The User/Group Permissions window opens.
5) Click the **Add Users/Groups** button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give permissions and click the **Add** button. Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select the permissions you want to grant the user(s) and click **OK**. Unifier adds the name(s) to the Permission Settings window.
8) Click **OK**.

To grant user permissions to the custom calendars

1) Open the shell where the Schedule Manager resides and switch to Admin mode.
2) In the left Navigator, click **Access Control**.
3) In the right pane, under **User Mode Access**, click **Schedule Manager > Custom Calendar**. The Permission Settings window opens.
4) In the Permission Settings window, click the **Add** button. The User/Group Permissions window opens.
5) Click the **Add Users/Groups** button. The User/Group Picker opens.
6) Select the user(s) to whom you want to give permissions and click the **Add** button. Unifier adds the name(s) to the Permission/Access Control window.
7) Under Permission Settings, select the permissions you want to grant the user(s) and click **OK**. Unifier adds the name(s) to the Permission Settings window.
8) Click **OK**.

Refresh Schedule Sheet Data

A schedule sheet refresh updates cost data associated with the schedule sheet. During the refresh, Unifier recalculate dates, activity role rates, and costs if there were any changes to the schedule sheet, such as copying rows into the sheet. Alternatively, you can set up a schedule to automatically refresh the sheet data.

**Note:** A scheduled refresh can fail if (1) an activity has more than one WBS code, or (2) a cost sheet column to which a schedule sheet column is associated is deleted from the cost sheet.
To manually refresh schedule sheet templates
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates > Schedule Sheets in the left Navigator.
   Schedule sheet templates that require refreshing are shown on the Schedule Sheet log with a refresh icon:
   ![Refresh icon]
3) Select a template and click the Refresh button.

To set up a refresh schedule
1) Go to the Company Workspace tab and switch to Admin mode.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.
2) On the Schedule Sheets log, select one or more schedule sheet templates.
3) Choose Refresh > Set Frequency.
4) Select the Enable scheduled refresh checkbox.
5) Select the Frequency and the Range of Recurrence.
6) Click OK.

Updating Schedule Sheet Properties from Templates
If you create project or shells with a template, you can update schedule sheet properties in the projects and shells from schedule sheets in the template. Both the source and destination schedule sheets must have the same name.

What you can do with schedule sheet update:
- Change the schedule’s status (active/inactive)
- Change auto-control (on/off)
- Change auto-update options
- Change the scheduled refresh frequency
- Change the schedule’s calendar
- Change the schedule start date, unless there are activities already in progress or completed
- Change activity level access
- Change Gantt chart bar labels and dates

Note: Updates of linked schedule sheets do not occur to sheets in projects or shells that have Inactive or View-Only status.

Calendars and Linked Schedule Sheets
When a schedule sheet is initially linked, any calendar associated with that schedule sheet is copied over with the sheet. However, when there are any subsequent updates to the linked sheet from a template, the calendar is not again updated on the sheet.

To update schedule sheet properties from project or shell templates

1) Go to the **Company Workspace** tab and switch to Admin mode.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shelltype] > [shell template] > Schedule Manager > Schedule Sheets.

2) From the Schedule Sheets log, select the schedule sheet to push.
   - Both the source and destination schedule sheets must have the same name.

3) Click the Update button and choose:
   - Properties > [project] or All Projects
   - Properties > [shell] or All Shells
   - An Options window opens.

4) On the Options window, select the properties to update:
   - Description
   - Status
   - Auto-control: You can still manually initiate business processes. Unifier disregards predecessor/successor dependency relationships when you manually start an activity, even if auto-control is set to On in the schedule sheet properties.
   - Calendar
   - Schedule Start Date: You can only change the schedule start date if there are no activities in progress or completed. Changing the start date can prompt Unifier to recalculate and roll up resource amounts.
   - Notify users and/or group on errors
   - Enforce Group Permission
   - Auto update activity status based on Actual Start/Finish Date
   - Activity Progress requires an Actual Start date
   - Schedule Refresh Properties
   - Enforce Activity 100% Complete against Actual Finish date
   - Auto-Update % after entering Actual Finish Date

5) Click **OK**. You will receive a confirmation of the update. Click **OK**.

View schedule sheet properties update history

To view update history:

1) From the Schedule Sheets log, select the schedule sheet with the updates you want to see.
2) Click the Update button and select History. The Update Projects History or Update Shells History window opens. This window lists the update history for each submitted update.
3) Click the Close Window button when you are finished viewing the history.
Update Schedule Sheet Activities from Templates

If you create project or shells with a template, you can update schedule sheet properties in the projects and shells from schedule sheets in the template. *Updating Schedule Sheet Properties from Templates* (on page 606).

You can also update the activities on a schedule sheet by using a separate "linking" function in Unifier that links a schedule sheet to a template for the specific purpose of updating activities. This feature is also convenient if you have imported a schedule and want to push it to your projects or shells.

**Note:** Projects or shells that are in Inactive or View-Only status will not be updated.

What you can do with linked templates:

If you link a schedule sheet to a template in this way, you can use the template schedule sheet to push the following changes to sheet columns and activities:

- Imported CSV or MPP files to the destination sheet
- Added activities
- Changes to activity status
- Changes to column order
- Added new columns
- Removed column
- Hidden columns
- Column indents and outdents

What you cannot do with linked templates:

- Change schedule sheet properties, activity dates, WBS codes, or activity resources.
- Delete activities
- Modify activity name or code associations
- Modify Scope Management setup

Once you link a schedule sheet to a template in this way, users can change dates and other data on the sheet, but they cannot add activities, delete activities, or otherwise change the structure of a sheet. You can only change the structure of the sheet and activities by changing the template and pushing the changes to the project/shell sheets.

**Permissions**

You do not need to have permission on the destination schedule sheet in order to update the sheet via a project/shell template schedule sheet. You must have the Edit Structure and Data permission to set up linked schedule sheets.
Enable and Disable Schedule Sheet Linking

Before you can link project or shell schedule sheets to a template for updating, you must enable the template for linking.

To enable linking for a schedule sheet template
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates** in the left Navigator.
   - For a project template, in the left Navigator, click **Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets**.
   - For a shell template, in the left Navigator, click **Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets**.
3) On the Schedule Sheets log, select a **Schedule Sheet** template.
4) From the Edit menu, select **Sheet Linking > Enable**.

To disable linking for a schedule sheet template
1) On the Schedule Sheets log, select a **Schedule Sheet** template.
2) From the Edit menu, select **Sheet Linking > Disable**.
   Disabling Sheet Linking disconnects all project/shell schedule sheets from the linked template; the schedule sheets can no longer receive updates from the template.

Link a Template to a Project or Shell Schedule Sheet
1) On the Schedule Sheet log, select the schedule sheet template that you want to link.
   This template must have been enabled for linking. (See **Enable and Disable Schedule Sheet Linking**.)
2) Choose **View > Linked Schedule Sheets**.
   The Linked Schedule Sheets window opens, listing the schedule sheets that are currently linked to the template.
3) Click **Add**. The Add Schedule Sheets window opens.
   This window lists Active and On-Hold projects or shells and the corresponding active schedule sheets for those projects or shells.
4) Select one or more schedule sheets and click **Select**. You will receive a confirmation message that the data in the newly linked sheet will be modified when the update is completed using the link between the template and the sheet.
   When you link a schedule sheet to the template, Unifier:
   - Deletes the existing data on the project/shell schedule sheet, including all activities, columns and cell data
   - Retains the schedule sheet properties, including the Schedule Start Date
5) To link the sheets, click **OK**.
6) When you are finished adding linked sheets, click **Close Window**.

Update Linked Schedule Sheets from Project or Shell Templates
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates** in the left Navigator.
   - For a project template, in the left Navigator, click **Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets**.
   - For a shell template, in the left Navigator, click **Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets**.

3) On the Schedule Sheets log, select the Schedule Sheet template that should update the activities on the linked schedule sheets.

4) Click **Update > Linked Schedule Sheets**.
   Unifier will update the activities and columns on all the schedule sheets that are linked to the template. It will not, however, push changes to activity dates.

**Impact on Scope Management**
Scope Management setups that are updated through the use of linked schedule sheets allow updates to any activities that are not yet initiated. This includes business process name, responsible users, duration flag, completion conditions.

---

**Unlink a Template From a Project or Shell Schedule**

1) On the Schedule Sheet log, select the schedule sheet template that you want to unlink.
2) Choose **View > Linked Schedule Sheets**. The Linked Schedule Sheets window opens, listing the schedule sheets that are currently linked to the template.
3) Select the sheet you want to unlink and click Remove.
   Unifier will disconnect the schedule sheet from the template.
4) Repeat steps 2 and 3 for any other sheets you want to disconnect from the template.
5) When you are finished unlinking sheets, click **Close Window**.

**View Linked Schedule Sheets**
You can view a list of schedule sheets that have been linked to the template. These are the destination schedule sheets that Unifier updates when you push changes from the template.

**To view linked schedule sheets**
1) On the Schedule Sheet log, select the schedule sheet template.
2) Choose **View > Linked Schedule Sheets**. Schedule sheets that are available for updating from the linked schedule sheet template are listed in the Linked Schedule Sheets window. Master schedule sheets are listed as well as non-master sheets.
3) When you have finished viewing the linked sheets, click **Close Window**.

**Importing Schedule Files**
Unifier supports working with schedule files such as Primavera. Once you import these schedule files, your external data becomes available in Unifier. In Unifier, users have access to the Schedule Manager’s analytical tools. For example, they can forecast project costs, monitor project progress at the activity and resource levels, and track earned value with schedule data.
If users assign resources in non-Unifier software, Unifier will soft-book those resource assignments, provided you created a data set for those assignments (see *Add data set values to a pull-down menu or radio button* (on page 77)).

**Overall steps to import schedule files**

1) Save the schedule files.
   - For Primavera XML files
     a. Export the Primavera file to XML.
     b. Modify the XML file to use with web services, as described in the *Unifier Integration Interface Guide*.
     c. Select Import distribution data from external source (refer to the "Select the activity budget distribution profile" section in the Schedule Manager chapter of the *Unifier User Guide*).
   - For Microsoft Project files
     d. Save the files as MPP, or export the Microsoft Project file to CSV or XML. Use this file as a template.

2) Define data mapping.

3) Import the CSV or XML files to create or modify schedule sheet activities.

**Primavera considerations:**

- Unifier’s Schedule Manager integrates with Primavera’s scheduling software by way of Web Services.
- Unifier honors the Primavera Current Data Date entry when calculating earned value (BCWS, BCWP, ACWP, EAC).
- When importing Primavera XML files into Unifier, you must configure the number of WBS code segments, and you can specify a suffix mask.
- Consult the *Unifier Integration Interface Guide* for data elements you can use with Web Services.

**Microsoft Project considerations:**

Unifier uploads Microsoft Project directly into a schedule sheet.

- To use the Activity Calendar from Microsoft Project, first create a calendar in Unifier with the same name as the external calendar. (See .)
- To import Resource Assignments from Microsoft Project, first add the same MPP resource types to the SYS Resource Type data set in Unifier. We recommend using MPP standard resource types: Work, Material, and Cost. (See "Add a data definition (Basic and Cost Codes)" on page 95.)
- Configuring WBS code segments is not necessary for Microsoft Project. See *WBS code options for Primavera XML and Microsoft Project XML* (on page 616).
Define data mapping

Data mapping establishes a 1 to 1 association between fields in a Unifier schedule sheet and a schedule sheet, such as Primavera P6. The data map creates a CSV or XML file into which the data from the external schedule can be loaded. Once loaded with data values, these files can then be imported into a Unifier schedule.

You can create multiple data maps and select the data mapping you want to use when you import the schedule files to create or modify schedule sheet activities.

**Note**: You must create at least one mapping. Unifier will use this mapping as a default if there are no others.

Unifier supports multiple data formats: CSV, MPP, MPP XML, P6 XML. You must map any specific fields from an external source that you want to see in Unifier.

<table>
<thead>
<tr>
<th>Data format</th>
<th>Data mapping requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSV</td>
<td>Requires mapping; you can select the mapping when you upload the file.</td>
</tr>
<tr>
<td>MPP</td>
<td>Mapping is not required. Imported fields are limited to Start Date, Finish Date, and Duration. Do not select a default data mapping if you will be asking Unifier to consider an activity calendar.</td>
</tr>
<tr>
<td>Primavera XML</td>
<td>Requires default data mapping.</td>
</tr>
<tr>
<td>Microsoft Project SML</td>
<td>Requires mapping; you can select the mapping when you upload the file.</td>
</tr>
</tbody>
</table>

To define data mapping

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates** in the left Navigator.
   - For a project template, in the left Navigator, click **Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets**.
   - For a shell template, in the left Navigator, click **Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets**.
3) From the Schedule Sheets log, open the **Schedule Sheet** template you want to map.
4) Choose **File > Data Mapping**. The Data Mappings window opens. The Data Mappings window lists any mappings created for schedules such as Primavera P6 or Microsoft ® Project.
   - If a mapping on this list is marked as the default mapping, Unifier will use this mapping when the schedule is imported. If you do not mark a mapping as the default, Unifier will prompt the users to select a mapping whenever they import a schedule.
5) Click **Add**. The Data Mapping window opens.
6) On the General tab, enter the name and the description for the data mapping and click **Apply**.
7) Click the **Activity** tab.
Use this tab to create the structure of the CSV or XML file for the export and import operations. On this tab, you can map Unifier schedule sheet columns to external CSV headers and XML tags in order to import or export activity information.

a. Click the Add button. Another data mapping window opens.

b. Use the information in the first table below to complete the fields on this window.

8) (Optional) On the Resources tab, you can map resource information through XML integration. Enter the header in the XML element that corresponds to the column.

   Note: Mapping resources is mandatory only if you select Import Resource Assignments on the Options tab.

   a. Click the Add button. Another data mapping window opens.
   b. Select the column and enter the header in the XML element that corresponds to the column.

9) Click Apply on the Resources tab.

10) Click the Options tab. On this tab, you can configure XML options that are used by Unifier when importing data.

11) Use the information in the second table below to complete the fields on the Options tab.

12) Click OK.

<table>
<thead>
<tr>
<th>Data format</th>
<th>Data mapping requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Select the data elements you want to import. Minimum required fields for XML import are Activity ID, Activity Name, Start date, Finish date, and Duration.</td>
</tr>
<tr>
<td>CSV Header</td>
<td>Enter the CSV header from the external source.</td>
</tr>
<tr>
<td>XML Element</td>
<td>Enter the XML from the external source</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>XML Import</td>
<td>Define options for importing XML activity schedules into Unifier. Mapping options are the same for Primavera XML and Microsoft Project XML.</td>
</tr>
<tr>
<td>Options</td>
<td>You can either retain existing schedule information in Unifier, or overwrite it complete upon importing an external XML file.</td>
</tr>
<tr>
<td></td>
<td>▸ Merge into existing schedule. With this selection, you have a sub-option to Delete Activities removed from the source schedule.</td>
</tr>
<tr>
<td></td>
<td>▸ Overwrite existing schedule replaces the existing schedule.</td>
</tr>
<tr>
<td>Data Elements</td>
<td>Select the appropriate checkboxes if you want to import activities (rows), <strong>Activity Dependencies</strong>: Select this checkbox to retain activities from the XML source file. <strong>Activity Calendar</strong>: Select this checkbox to retain the activity calendar from the XML source file. If imported, the activity calendar will trigger the</td>
</tr>
</tbody>
</table>
recalculation of activity dates as needed, and will override any existing activity calendar association. If a calendar is not imported, the activity will use the existing calendar defined in the Schedule Sheet properties.

Note: There must be a calendar in Unifier with the same name as the calendar in the import file.

**Resource Assignments**: Select this checkbox to retain the resource assignments from the XML source file. If you want to import resources, define the resource types for the data definition SYS Resource Type. For Microsoft Project files, use standard resource types: Work, Material, and Cost. Upon import, these resource types will soft book.

**WBS Codes**: Select this checkbox to import WBS codes. See [WBS code options for Primavera XML and Microsoft Project XML](#) (on page 616).

**Number of Levels**: (for Primavera XML only) Specify the segments that should be considered in the Primavera XML file for the codes (from 1 to 9) and the WBS code suffix mask. See [WBS code options for Primavera XML and Microsoft Project XML](#) (on page 616) for details.

**Suffix Mask**: (for Primavera XML only) You can use a constant or a data element value in the Suffix Mask.

- To use a constant in the Suffix Mask, click the Constant radio button, and enter the suffix you want to have appended to the WBS code.
- To use the value from a data element in the Suffix Mask, click the Data Element radio button and select a data element.

---

**XML Export**

Define options for exporting through XML into another application

**Data Elements**

Select the appropriate checkboxes if you want to export activities (rows), and whether to include dependencies, resource assignments, and/or WBS codes.

---

**WBS Code Options for Primavera XML and Microsoft Project XML**

Unifier can recognize the WBS codes imported through XML files and match these codes to equivalent codes in a project/shell cost sheet. For Primavera XML files, you need to specify the **Number of Levels** and a **Suffix Mask**. (The codes in Microsoft Project XML files are automatically resolved by Unifier when the file is imported.)

The number of levels specifies the number of segments that should be included to build WBS codes based on data from the Primavera XML file. The number of segments considered starts from the top of the imported XML file. If you specify a number of segments and the data in the XML file has fewer segments than that number, then all segments are processed.

The **Suffix Mask** you enter is added to the WBS code elements that Integration derives from the XML file. The WBS code derived from the XML file with the mask is validated against the WBS codes (leaf level) created for the project/shell Cost Sheet.

While deriving the WBS codes from the XML file, Integration separates segments retrieved from the XML file with the cost code separator specified in uDesigner). When specifying the Suffix Mask, be sure to use the same cost code separator if the mask contains more than one segment.
Import CSV, XML, or MPP files to create or modify schedule sheet activities

Once you have saved the schedule files in an importable format (CSV, XML, or MPP) and defined the data mapping, you are ready to import the files into the Unifier schedule sheet template.

To import a CSV file
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates in the left Navigator.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.

From the Schedule Sheets log, open the Schedule Sheet template into which you want to import the schedule. The Schedule Sheet template opens.

1) Choose File > Import > From CSV.
   When you import the file, you can select the data mapping you want to use for the importing files. If a default mapping was created, you will not have to select a mapping. If not, Unifier will display a Select Data Mapping window. If this window opens, select the data mapping you want to use for this import and click OK.
   The File Upload window opens.
2) Browse to select the CSV file to upload.
3) Click OK.

To import XML and MPP files
1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates in the left Navigator.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.
3) From the Schedule Sheets log, open the Schedule Sheet template into which you want to import the schedule. The Schedule Sheet template opens.
4) Choose File > Import > From External Source.
   When you import the file, you can select the data mapping you want to use for the importing files; however, in some cases, MPP files do not require that you to select a data mapping.
   If a default mapping was created, you will not have to select a mapping. If not, Unifier will display a Select Data Mapping window. If this window opens, select the data mapping you want to use for this import and click OK.
   The File Upload window opens.
5) Use the table below to complete the fields in this window.
6) Click OK. The File Upload window opens.
7) Browse to select the file to upload.
8) Click OK.
<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPP</td>
<td>Data mapping is not required; leave the Data Mapping field empty.</td>
</tr>
<tr>
<td>MPP XML</td>
<td>Data mapping is required; select the mapping you want to use.</td>
</tr>
<tr>
<td>MPP activity calendar</td>
<td>Select Consider Activity Calendar. Note: This requires an existing calendar in Unifier with the same name. See <em>Creating Multiple Calendars</em> (on page 186) If an activity calendar is not imported and considered, the activity will use the existing calendar defined in the schedule sheet properties.</td>
</tr>
<tr>
<td>MPP Resource assignments</td>
<td>Data mapping is not required; leave the Data Mapping field empty. Note: This requires a data set for the SYS Resource Type data element. See <em>Add a Basic data definition</em> (on page 75). Use MPP standard resource types: Work, Material, and Cost. Upon import, Unifier will soft-book these resource types.</td>
</tr>
</tbody>
</table>

**WBS code options for Primavera XML and Microsoft Project XML**

Unifier can recognize the WBS codes imported through XML files and match these codes to equivalent codes in a project or shell cost sheet.

**To enter the WBS code options**

1) On the Data Mapping *Options* tab, select the *WBS Codes* checkbox.
2) Enter the *Number of Levels* (from a minimum of 1 to a maximum of 9). This specifies the number of segments that should be included to build WBS codes based on data from the Primavera XML file. The number of segments considered starts from the top of the imported XML file. If you specify a number of segments and the data in the XML file has fewer segments than that number, then all segments are processed.

*Note*: You must enter a number of levels if you select the WBS Codes checkbox. However, for Microsoft Project XML files this value is ignored. The WBS Codes are resolved automatically by using the WBS code element in the MS Project XML schema when the MS Project XML file is imported.

3) Optionally, (for Primavera XML only) enter the Suffix Mask you want to use for the WBS code mapping. The mask you enter is added to the WBS code elements that Integration derives from the XML file. The WBS code derived from the XML file with the mask is validated against the WBS codes (leaf level) created for the project or shell Cost Sheet.
While deriving the WBS codes from the XML file, Integration separates segments retrieved from the XML file with the pre-defined Cost Code Separator (previously defined under Data Definitions in uDesigner). When specifying the Suffix Mask, be sure to use the same Cost Code Separator if the mask contains more than one segment. You do not need to start the Suffix Mask with the Cost Code Separator. Unifier will add this separator to combine the WBS codes derived from the XML file and the Suffix Mask you enter.

You can use a constant suffix, or use the value of a data element as a suffix:

- To use a constant in the Suffix Mask, click the Constant radio button, and enter the suffix you want to have appended to the WBS code.
- To use a data element values in the Suffix Mask, click the Data Element radio button and select a data element.

4) Click OK.

**Primavera XML and Microsoft Project XML WBS Code interpretation**

The data Unifier derives from the Primavera XML file consists of WBS Code segments, and activity and resource data. Upon import, a tree of WBS code elements are combined to form a WBS Code. Each element is a segment of a WBS code. The Activity element is attached to last node of the WBS Code segment. Activity Resource Assignment information is considered.

This is an example of WBS code structure during import from an XML file:

<WBS 1>
  <WBS 11>
    <WBS 111>
    <Activity A>

In above example, actual WBS Code is <WBS 1>.<WBS 11>.<WBS 111>. Activity A contains a reference to its parent (<WBS 111>) WBS code segment. When processing the import of the XML data, Unifier first checks the Activity WBS code element and then builds the rest of the WBS code by moving up the WBS tree structure. In this example, Activity A has WBS 111 as a reference and Unifier use the structure to build the WBS code as WBS 1.WBS 11.WBS 111.

After this WBS code is built, a Suffix mask (for Primavera XML files) is added to the beginning and end of the derived WBS code to create a Unifier WBS code. When the Unifier WBS code is created, it is validated against the WBS code created in the project or shell Cost Sheet.

If an activity is moved from one WBS code to another WBS code, Unifier will move the activity during the XML file processing. If an activity or WBS code is deleted in the imported XML file, and the same activity exists in Unifier, Unifier will not delete that activity or WBS code.

**Updating User Information in Schedule Sheet Properties Using Bulk Processing**

You can use bulk processing to update user information in schedule sheet properties for a large number of sheets. This user data pertains to the groups or individual users who are notified of errors and also the groups who are given activity-level permissions. You can perform this bulk processing at the shell or project level.

**Note:** You can update 200 records at a time using bulk processing.
Change user group assignments or add new users in bulk

To add or remove user group assignments in bulk

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) In the left Navigator, click **Company Sponsored Projects** (for a project) or **Company Sponsored Shells** (for a shell).
3) In the log on the right pane, select project(s) or shell(s) you want to update.
4) Choose **File > Export > Export Schedule Sheet Properties**. This will export the current properties for all of the schedule sheets for the selected shells or projects to a CSV file.
5) Click **Open** to open the CSV file, or **Save** to save the file to your desktop.
6) Modify the sheet in the CSV file as needed.
   All column values are required, except for Notify Users and Notify Groups. Group and user names are separated by semi-colon (;).
7) Save the CSV file when you are finished modifying the user group assignments or adding new users.
8) Navigate back to the log and choose **File > Import > Import Schedule Sheet Properties**.
9) Upload the modified CSV file and click **OK**.
   You will receive an email notification when the update is finished.

Creating Activity Sheet Templates

Activity Sheets are used at the Program level to give program managers visibility into their activity data, and give them the ability to manage these activities across projects and shells. They are available in the Schedule Manager at the Program level.

Program managers can use an activity sheet to view, edit, and update a large amount of activity data across projects and shells. Activity codes are mapped to activities in the Activity Sheet, and the data for the Activity Sheet is gathered only from the projects’ Master Schedule Sheets. Project names form the rows of the activity sheet; the activity codes and other data from the master sheets form the columns and sub-columns of the sheet.

Users cannot create Activity Sheets; they are available only from templates that you create.

Create an Activity Sheet template

To create an Activity Sheet template

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Activity Sheets** in the left Navigator. The Activity Sheets template log opens.
3) Click **New**. The Activities Sheet properties window opens.
4) Use the information in the table below to complete the fields on the General tab.
5) Click **Apply**, then click the **Activity Codes** tab.
   On this tab, you add the rows of activities you want to see on the Activity Sheet. The rows in the sheets that are created from this template will list the projects and shells related to the activity codes you specify on this tab.
6) Click the **Add** button to add activity rows.
Unifier adds an empty row to the window.

7) In the **Activity Code** column, double-click the cell. The cell becomes editable.

8) Click the down arrow and select the activity for the row.

9) To change the order of the activity rows, select a row and use the **Move Up (Left)** or **Move Down (Right)** buttons to move the activity.

10) Click **Apply**, then click the **Data Elements** tab.

    On this tab, you specify the columns you want on the Activity Sheet.

11) Click the **Add** button to add a row for the field. Unifier adds an empty row to the window.

12) In the **Data Elements** column, double-click the cell. The cell becomes editable.

13) Click the down arrow and select the field you want to display as a column on the sheet.

**Note**: Activities can be affected by calendar selection, if there are multiple calendars implemented. You can include a Calendar column on the activity sheet, and this column will allow users to select a company level or a project/shell calendar per activity (custom calendars are not available). When activities are updated through the Activity Sheet, Unifier considers the calendar in use for the activity. The Start Dates, Finish Dates and Durations can be affected by the calendar used for an activity.

14) To change the order of the fields, select a row and use the **Move Up (Left)** or **Move Down (Right)** buttons to move the field.

15) Use the **Editable** checkbox to designate which data elements will be editable on the Activity Sheet.

    Only one of Start Date, Finish Date, or Duration elements in a group of elements can be made Editable (the other two elements of the group, if added, are not selectable).

    The following elements are always read-only, and cannot be marked as editable:

    - Actual Start/Finish/Duration
    - Auto-update Activity checkbox
    - Milestone checkbox
    - Activity Code
    - Activity Status
    - Baseline elements

16) If you want Unifier to automatically adjust the start and finish dates to reflect a negative lag, select the **Allow negative lag to accommodate specified Start/Finish Dates** checkbox.

    For example, lag could be adjusted to a negative value automatically to accommodate manual entries if an activity cannot be normally moved as a result of an existing dependency or lag. This could occur if:

    - The Finish Date on Activity 2 is updated to be pulled in by five days
    - The Start Date cannot move to be earlier due to predecessor Activity 1
    - In this case, you can make the lag negative by five days to allow the Start Date to move earlier and keep the duration constant

    In another example, the Finish Date on Activity 2 is moved up by five days.

    - The Start Date can be moved earlier only by two days due to predecessor Activity 1
In this case, we can make the lag negative by 3 days (-5+2=-3) to allow the Start Date to move earlier and keep the duration constant.

17) Click the **Move Up (Left)** or **Move Down (Right)** buttons to change the sorting order of the columns.

18) Click **OK**. The new Activity Sheet template is available in the log.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Enter a title for the template. This is used as the template identifier and must be unique. (up to 120 characters)</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description. (up to 400 characters)</td>
</tr>
<tr>
<td>Status</td>
<td>When you are ready to make the template active and available for use, click Active. The default is Active.</td>
</tr>
</tbody>
</table>

**Scope Management Setup**

Scope management is a framework that defines deliverables, responsible roles, actual assignees and their schedules, and drives coordinated production of these deliverables. Scope management initiates actions for producing deliverables based on the completion of dependencies. It routes them to responsible person/group, monitors their completion and updates deliverable statuses automatically. It manages different activities across schedules for different team members simultaneously.

**Note**: Scope Management is not available for launching non-workflow business processes.

This feature allows you to use existing Schedule Management functionality with added data elements to automate the management of a project’s scope and schedule with all associated activities, tasks, and deliverables. This feature provides project managers with the ability to manage each scope item’s task assignments, ownerships, and durations.

Project managers can use Scope Management as the solution to manage high volume, quick-turn around projects that have standardized scope and scheduled activities. Examples of projects that would benefit from the use of Scope Management functionality are retail construction projects such as bank branches or chain fast food restaurants. Unifier’s Scope Management capabilities are also useful for large capital projects with complex scope and schedules, and that have numerous dependent activities and milestones with associated tasks and deadlines.

Scope Management coordinates the creation of the defined deliverables using the schedules of the various assignees, and automatically moves tasks to the next assignee. Scope Management then routes tasks related to the deliverables to the next responsible assignee (person or group), monitors the state of the tasks, and updates deliverable status automatically. Actions for the creation of deliverables are based on fixed time durations and the completion of dependencies.
This functionality can be enabled on any schedule sheet, including a Master schedule sheet. Scope Management enables you to link BPs with schedule sheet task activities and route those BPs, with automatic update of status as they are routed and worked on. The BPs represent the work that needs to be done to complete the task. Also, you can override the automatic routing at any time and launch the activity-associated BPs manually. The BP-related task is deemed done when specified completion conditions are met.

**Setting up Scope Management for Activities**

After you create the project- or shell-level schedule sheet template at the company level, you can set up the following for each activity:

- Linked BP
- Responsible users or groups
- Due date
- Completion conditions

**To set up Scope Management for an activity**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates** in the left Navigator.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.
   The Schedule Sheets log opens.
3) Select the template from the log and click the **Open** button, or double-click the selected template. The schedule sheet template opens.
4) To set up scope management for the template, use the instructions in the **Unifier User Guide** on setting up scope management for activities.

**About activity-level editing**

At the project shell level, you can configure the Schedule Sheet so that specific cells can be edited only by designated groups of users. In a project, the project manager is usually responsible for the entire schedule, with various activity owners responsible for managing dates on specific project tasks. Enforcing activity-level editing controls the users and groups who can edit certain data, such as group-specific start and finish dates for activities.

**Notes:**

- You can set up the activity-level editing restrictions in a template, and the editing control configuration will be copied into any schedule sheet created from that template.
- Unifier will ignore any data imported through CSV or XML for restricted fields. If there is any failure in validation, Unifier will stop the import.
Activity-level editing allows the project manager and other activity owners to collaborate on a project and discuss the impact of changes to start and finish dates across the entire schedule. This collaboration allows the project manager or activity owners to enter new start and finish dates for activities without immediately affecting the start and finish dates for all activities. The editing restrictions prevent the proposed dates from affecting the entire schedule before the dates are approved or adjusted. Only those users with appropriate permissions can edit restricted dates.

**Note:** Updates that occur from Activity Sheets are also subject to activity-level editing restrictions if the restrictions are configured on the corresponding schedule sheet, as are updates from CSV import or Web Services Integration.

The following table shows an example of the impact on dates in a schedule sheet with activity-level editing configured, and with activities and group-specific date columns. In this example, the groups Const, IT, and ATM all have group-specific start dates and finish dates for activities:

<table>
<thead>
<tr>
<th>Activity owned by Const Group</th>
<th>Start Date</th>
<th>Finish Date</th>
<th>Const Start Date</th>
<th>Const Finish Date</th>
<th>IT Start Date</th>
<th>IT Finish Date</th>
<th>ATM Start Date</th>
<th>ATM Finish Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project manager can edit these dates</td>
<td>Const Group can edit these dates</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A less restrictive implementation of activity-level editing allows specific groups to edit all cells in selected rows. In this implementation, when project manager changes activity start or finish dates, those changes could affect other dates in the schedule, due to dependencies among the activities:

<table>
<thead>
<tr>
<th>Activity owned by Const Group</th>
<th>Start Date</th>
<th>Finish Date</th>
<th>Other data in the schedule sheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project manager can edit these rows</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Activity owned by IT Group</th>
<th>Start Date</th>
<th>Finish Date</th>
<th>Other data in the schedule sheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>IT Group can edit these rows</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Activity owned by ATM Group</th>
<th>Start Date</th>
<th>Finish Date</th>
<th>Other data in the schedule sheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATM Group can edit these rows</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Set up activity-level editing

Before you set up activity-level editing:

- Be sure the Activity Attribute form has been designed to include the Filtered Group data element and any group-specific start date and finish date data elements (see the "Schedule Manager Overview" in the Unifier uDesigner User Guide for more information).
- Be sure the Add the Filtered Group data element and any group-specific date data elements have been included as columns on the schedule sheet.
- Create the groups who should have permissions for activity-level editing. See User and Group Administration (on page 135). Be sure not to include the project manager in any of these groups (as the group manager, for example), as this will result in conflicting permissions if later you add any restrictions to the columns schedule sheet.
- Give these groups the View All Sheets permission for the Schedule Sheets for the project/shell. Do not grant Full Access permissions, as that will override any activity-level configuration to restrict editing.

To set up activity-level editing

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates in the left Navigator.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.
   The Schedule Sheets log opens.
3) On the Schedule Sheets log, select the schedule sheet and click the Permissions button on the toolbar. The Edit Permission window opens.
4) Add the group or groups for activity-level permissions and specify Edit Data in the Permissions section of the window.
5) Give the project manager Modify Permission.
6) Click OK.
7) Click the Properties button on the toolbar.
8) On the General tab, select the Permissions: Enforce Activity Level Permission by Group checkbox and select a Default Group from the drop-down list.
9) Open the schedule sheet (either in the template or in the project or shell).
10) Under the Filtered Group column, click the activity for which you want to specify editing.
11) From the drop-down list, select the group you want to have activity-level editing permission.

The group selection you make in the activity row controls the access for editing that activity. For example, if you select IT Group as the Filtered Group for an activity, then only users who are members of the IT Group can modify data for that activity (in that row).

**Note:** For a less restrictive, row-level implementation of activity-level editing, you can stop here and not perform the next step, which provides further restrictions to the cell level.
To set up more cell-level editing restrictions

In addition to activity-level editing permissions, and can use column restrictions to enforce that only certain groups can edit certain cells. For example, for project managers, you could restrict the group-specific date columns only. For the activity-owner groups, you could restrict access to all columns except for the group-specific date columns. For example, for the IT Group, you could restrict access to all columns except for IT Start Date and IT End Date.

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Templates in the left Navigator.
   - For a project template, in the left Navigator, click Templates > Projects (Standard) > [project] > [project template] > Schedule Manager > Schedule Sheets.
   - For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell template] > Schedule Manager > Schedule Sheets.
   The Schedule Sheets log opens.
3) Open the schedule sheet you want to restrict.
4) From the File menu, choose Restrictions. The Restrictions Setup window opens.
5) Under User/Group Name, add the user or group name whose access you want to restrict.
6) Under Activity Restriction Settings, choose the fields on the sheet that you want to restrict.
7) (Optional) Under Resource Assignment Restriction Settings, choose the resource-related fields on the sheet that you want to restrict.
Space Manager

In Unifier, the Space Manager is where you can perform the tasks of facilities management. The Space Manager integrates the AutoCAD® application to provide drawing and modeling capabilities for your architectural, layout, and design needs.

**Note:** The Space Manager is only available to shells; it cannot be used for standard projects.

Using the Space Manager, you can gather data about the levels in your facility (such as floors and parking lots) and the spaces that exist on each level (cubicles, offices, conference rooms, etc.). Each level is supported by an AutoCAD® drawing. You can enter individual spaces into Unifier, or directly onto an AutoCAD® drawing and classify them into categories (such as common areas, or usable space) to make managing them more efficient. Similar to the Asset Manager, categories (called types) of spaces can be designed in uDesigner, and you can then add records of individual spaces to these types and manage them on an electronic sheet.

The Space Manager is a means of organizing all the square footage in your facility to make monitoring, maintaining, and revising your facility more efficient. The Space Manager can be integrated with other managers or business processes to give you a broader view of your company’s physical capital and resources. For example, the Space Manager can be integrated with the Asset Manager to include the computers that reside in each cubicle on a level; or integrated with the Resource Manager to include the employees who occupy each space on a level.

In uDesigner, one attribute form is designed for a “level” type in your facility and multiple attribute forms for “spaces” types. With these attribute forms, you can create a hierarchy of levels and spaces within levels to store the facilities data you choose to collect.

**Notes:**
- In the Space Manager, think of a level as the “platform” on which spaces reside.
- Configuration of the Data Picker and Data Elements (and when applicable: Unique and Auto Sequence settings) must be done in uDesigner.

In Unifier, the **Sheets** node in the Space Manager stores the manager sheet on which all the levels in your facility are shown. Unifier automatically creates a level sheet for every level type that is created. On these sheets, you can import and export drawing files to and from AutoCAD®, and also import and export column data. From the level sheet, you can also automatically update individual level records with data added to the sheet, either manually or via a formula created for a column.

The **Stack Plans** node is where you can create stack plans to show the actual usage of the levels in the company’s building(s). You can choose the information (data elements or specific spaces) you want to see on the stack plan and update the plan periodically to keep abreast of changes in the levels’ space usage. For example, you might want to know the square footage used by each department on each floor (level); or how many square feet of a floor are vacant versus leased.
The **Levels** node lists all the levels that exist in your facility. Each level is supported by an AutoCAD® drawing. This node is where you can create new levels or update existing ones, download drawing files, add spaces to the level, attach a drawing to the level, and print the drawing. This is where you can create new levels or update existing ones, import data from CSV files, export templates to CSV.

The **Spaces** node shows a list of all the space types, and under the space type sub-node, all the spaces that exist in your facility. This is where you can create new spaces or update existing ones, import data from CSV files, export templates to CSV, and select spaces to view on the level drawing.

The Space Manager allows you to identify floors and each space by type and associate attributes to the particular spaces. For example, a multi-floor building could have many types of spaces, such as offices, cubicles, restrooms, conferences room, laboratories, and eating areas.

You manage spaces according to space type. Examples of space types are:

- Gross measured area, which is the entire square footage of a floor, from wall to wall
- Common area, such as hallways, lobbies, and entrances
- Usable space, such as cubicles, offices, and conference rooms
- Vertical penetration, which includes elevators, stairwells, and columns

The Space Manager is available within a shell. Each shell can have only one Space Manager. A building is at the shell level. An example hierarchical arrangement of objects in the Space Manager is as follows:

- Buildings (shell level)
  - Levels (Floors) of the building or other similar structures (in this case, Floor is an example of a level record)
    - Spaces in the building. These are the various spaces in the structure, such as storage rooms, offices, and other interior spaces (space records). Spaces is a fixed node designed in uDesigner.

The Space Manager includes a sheet to help you manage levels and spaces. The sheet will allow you to create formulas to calculate total leasable and rentable space for a facility or building.

**uCAD Plug-In**

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in application, which can be downloaded from Unifier. uCAD enables:

- Authoring of space objects in AutoCAD®
- Identifying spaces on a floor drawing and link them to Unifier space objects
- Associate a drawing file to a Unifier level record
- Transferring changes to level and space records between the Unifier Space Manager and AutoCAD®
In This Section

About the uCAD Plug-In ................................................................. 627
Space Manager Prerequisites .................................................... 627
Importing and Configuring Levels and Space Types .................. 627
Configuring Levels and Space Types ......................................... 628
Space Manager Production Bundle Configuration ..................... 630
Creating Level Sheet Templates ................................................. 630
Creating a Stack Plan Template ................................................... 631
Setting Permissions for the Space Manager ............................... 633
Query Tabs in Spaces .................................................................... 633

About the uCAD Plug-In

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in application, which can be downloaded from Unifier. uCAD enables:

- Authoring of space objects in AutoCAD®
- Identifying spaces on a floor drawing and link them to Unifier space objects
- Associate a drawing file to a Unifier level record
- Transferring changes to level and space records between the Unifier Space Manager and AutoCAD®

Space Manager Prerequisites

The following is a list of prerequisites:

- Generic or WBS shells configured
- Level and space attribute forms defined in uDesigner
- uCAD plug-in and AutoCAD® installed on your desktop (if you are going to use the Space Manager with the optional AutoCAD® integration)

The *Unifier uCAD Installation and User Guide* is also available from the Unifier Support window, on the Download tab. After you download the uCAD plug-in you can access uCAD from the Windows Start menu > Programs> uCAD. When you install the plug-in, the uClient Configurator is also installed. The *Unifier uClient Configurator Setup Guide* is available in the uClient Configurator Help menu. The *Unifier uCAD Installation and User Guide* is available in the uCAD Help menu.

- Auto Desk® Design Review
  
  This is required if the user wants to view the uploaded drawing files within the Space Manager window. It is a free download from http://usa.autodesk.com.

Importing and Configuring Levels and Space Types

Importing and configuring levels and spaces types for the Space Manager for use in Unifier consists of the following steps:

**Step 1: Import level and space types.** Levels and space types are created in uDesigner.
Step 2: Configure the level and spaces. This configuration enables these types to be set up.

Step 3: Setup Level Sheet Templates

Step 4: Create stack plan templates

Step 5: Set permissions. After setting up and configuring levels and spaces, you must set User Mode permission to all users who will need to work with these components of the Space Manager.

In order to create levels and space types in Unifier, the Space Manager module has to be loaded. Contact the Company or Site Administrator.

The Space Manager can have only one level type design but multiple space type designs. You have to first deploy the level design in uDesigner before deploying any Space type designs.

To import and deploy a level or space attribute form into Unifier production, see the instructions in the topic **Importing and Deploying a Design** (on page 273).

### Configuring Levels and Space Types

Level and Space configuration allows you to activate the level and space types for use in the Space Manager.

**To access the level and space configuration log**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Configuration > Space Manager** in the left Navigator. The Configuration – Space Manager log opens. The log lists the level and space types that were imported into Unifier. The newly imported level and space types are inactive by default and can be activated during configuration.

### Configuring a Level or Space Type

The following describes how to activate a level or space types.

**To configure a level or space type**

1) Go to the **Company Workspace** tab and switch to Admin mode.

2) Click **Configuration > Space Manager** in the left Navigator. The **Configuration-Space Manager** log opens, displaying the level and space types that have been imported into your company.

3) Select a level or space type and click **Open**. The Configuration window for the level or space type opens.

4) Complete the **General** tab. In this tab, you can add a custom Help file and change the status of the level or space type to Active.

5) Click the **Custom Print** tab. This tab is optional; it allows you to customize the layout of a PDF document leveraging the XML style design format.

6) Click **OK**.
Configuring Fill Colors and Text for Space Types

You can configure fill colors and text for uCAD drawings to support visual analysis of the drawings to facilitate space planning. For example, users might want to see a floor plan with each space type on that plan highlighted in a different color based on the department using that space.

**To configure fill colors and text for a space type**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Configuration > Space Manager** in the left Navigator. The **Configuration-Space Manager** log opens, displaying the level and space types that have been imported into your company.
3) Select a space type and click **Open**. The Configuration window for the space type opens.
4) For space types, click the **Options** tab. On this tab, you can enter information regarding spaces that enables users to color code spaces shown in uCAD. Users can also specify the display text that will appear on drawings.
5) Complete the CAD Drawing Options as described in the table below.
6) Click **OK**.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Color</td>
<td>Click <strong>Select</strong> to specify the AutoCAD (ACI) Color used by default when displaying spaces of this type. The system default is white (no color). You can select a color from the 255 color AutoCAD ACI color palette. This ACI color is converted to the corresponding HEX HTML color. The default color is used for space outlines.</td>
</tr>
<tr>
<td>Text Element Sort</td>
<td>Click <strong>Select</strong> to specify the sort order of the data elements whose text labels will be available to be shown as text on the uCAD drawing, as defined in uDesigner. You can use <strong>Add</strong> to select the data elements to display and select a data element and click <strong>Remove</strong> to delete data elements from the list of displayed data element text. Use the <strong>Move Up</strong> and <strong>Move Down</strong> buttons to re-order selected data elements. Also, you can re-order the data elements by editing the Row number, and clicking <strong>Update Order</strong> to refresh the window. Click OK to exit the Data Element window.</td>
</tr>
<tr>
<td>Fill Display Elements</td>
<td>Click <strong>Select</strong> to specific the drop-down list data elements (Input Type Pull-down Menu) that are available to be used for visual analysis on the uCAD drawing, and to specify a color for each value in the Data Set for that Pull-down Menu. Select a Data Element and select Enable Fill By. Select colors for the data element data set values. Click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>
Space Manager Production Bundle Configuration

The following configurations can be included in the Space Manager Production Bundle:

- **General setup**
  All the fields included in the General Configuration (General tab).

- **Custom Print**
  Word and PDF templates, if any.

- **BIP Custom Print**
  All the BIP Custom Print in the Custom Prints and Reports.

- **Space Attributes**
  The content of the Options tab for Space Attributes, including Default Color, Text Element Sort, and Fill Display Elements.

  **Note:** If you do not select the Data Structure setup option at the time of creating the export bundle, the Data Definition selected in the Fill Display Elements field will not contain the Value or Label datasets and only the colors can be seen.

For more information, see the *Production Bundles* (on page 197) section in this guide.

Creating Level Sheet Templates

**To open a level sheet**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell or shells] > Space Manager> Level Sheets** in the left Navigator. The Level Sheets log opens. There is one level sheet per shell.
3) Select the sheet in the log and click **Open**.

**To open the Level Sheet properties window**

In the Level Sheets log, select the sheet and click **Properties**.

**To create a template for a level sheet**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell or shells] > Space Manager> Level Sheets** in the left Navigator.
3) Click **New**. The Levels Sheet Properties window opens.
4) Enter an optional description. You cannot change the sheet title.
5) Choose whether to include all levels on the sheet or just levels with selected statuses.
6) Click **OK**.

**To add columns to a level sheet template**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell or shells] > Space Manager > Level Sheets** in the left Navigator.

3) Select the level sheet, and click **Open**.

4) Click **Columns**. The Columns Log window opens.

5) Click **New**. The Column Definition window opens.

6) In the **Datasource** drop-down list, select the data source to use. The list includes the data elements found on the level forms.

7) For **Entry Method**, choose how information is entered in the column. The choices depend on the data source selected.

8) For **Data Format**, select the format for numeric columns. The options are:
   - **Show as Percentage**: Displays data in percentage. For example, if 0.25 is entered, it displays as 25%.
   - **Decimal Places**: Select the number of decimal places to display.
     - **Note**: If the data element was defined in uDesigner with a specific number of decimal places, it will override any decimal places you specify here.
   - **Use 1000 Separator (,)**: Data is formatted using separators. For example, one thousand is displayed as 1,000 with a comma, not 1000.
   - **Negative Number Format**: Select how negative values are displayed: with a negative sign or in parentheses.

9) For **Display Mode**, select **Hide** to make the column invisible to users or **Show** to display it.

10) For **Total**, select what is shown in the bottom summary row for each column. The options are:
   - **Blank**: Summary row is blank.
   - **Sum of All Rows**: Displays the sum total of all row values for this column.
   - **User Formula Definition**: Displays the result of the formula entered in the Formula field.

11) For **Average**, select **Blank** or the average of all rows.

12) For **Column Position After**, select a column from the list to specify its position on the sheet.

13) Click **OK**.

### Creating a Stack Plan Template

A stack plan is a two-dimensional graphical display of facility or building data. Usually, these graphs display area calculations by different attributes (for example, rented, leased, vacant, occupied by a tenant). Stack plans allow users to view area information across all building levels or floors based on defined attributes. Stack plans display only space records. With permissions, users can create or modify a stack plan under a shell.

**To create a stack plan**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell] > Space Manager > Stack Plans** in the left Navigator.
3) Click **New**. The Properties window opens.
4) Complete the **General** tab as described in the first table below.
5) Click the **Options** tab and complete as shown in the second table below.
6) Click **Apply** to save changes, or **OK** to save and exit.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter the stack plan name.</td>
</tr>
<tr>
<td>Description</td>
<td>Enter an optional description.</td>
</tr>
<tr>
<td>Include:</td>
<td>Select to specify that all levels be included in the stack plan, or that only levels of selected status be included in the stack plan.</td>
</tr>
<tr>
<td>▶ All Levels</td>
<td></td>
</tr>
<tr>
<td>▶ Levels with statuses</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space Types</td>
<td>Select a space type.</td>
</tr>
<tr>
<td>Stack By:</td>
<td>Select whether to stack by selected space type or by a data element.</td>
</tr>
<tr>
<td>▶ Space Type</td>
<td></td>
</tr>
<tr>
<td>▶ Data Element</td>
<td></td>
</tr>
<tr>
<td>Stacking View</td>
<td>Select to specify standard stacking or 100% stacking.</td>
</tr>
<tr>
<td>Sort Floors By:</td>
<td>Select to sort floors by a selected data element from the Level Attribute form.</td>
</tr>
<tr>
<td>Show Legend</td>
<td>Select to display a legend for the stack chart.</td>
</tr>
<tr>
<td>Conditions</td>
<td>Add a condition to filter the number of space records included in the stack plan calculation. The stack plan calculation logic sums up the values from the uuu_area data element used on the space-type detail form.</td>
</tr>
</tbody>
</table>

**To modify stack plan properties**
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell] > Space Manager> Stack Plans.**
3) Select a stack plan and click **Properties.** The Properties window opens.
4) Modify the stack plan properties as needed.
5) Click **OK.**

**To update a stack plan across shells**
1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Templates > Shells > [shell ] > Space Manager> Stack Plans.**
3) Select a stack plan in the log.
4) Click **Update Shells.** You can choose to update the stack plan in selected shells, or all shells.
Setting Permissions for the Space Manager

You must set the user permissions for the various components of the Space Manager. The Space Manager components are:

- Sheets
- Stack Plans
- Levels
- Individual space types

To set the Space Manager components permissions

1) Go to the Company Workspace tab and switch to Admin mode.
2) Click Access Control in the left Navigator.
3) On the right pane, select User Mode Access > Space Manager. The permissions for each component are:
   - Sheets: Create, Modify, View
   - Levels: Create, Modify, View, Allow Bulk Edit
   - Spaces > All > <space types>: Create, Modify, View, Delete, Allow Bulk Edit
   - Stack Plans: Create, Modify, View

**Note:** Users with Modify permission can import drawing files into a level record.

Query Tabs in Spaces

The Query tab allows access to all BP records, related to Space, by way of Query-based Tab (QBT). For example, if you need to see all approved BPs related to your Space, you can use the QBT to query/fetch those records. Once a Query-based Tab (QBT) is successfully created and deployed using uDesigner, the BP Query Tabs appear in the Unifier required Space, in User mode.

As a pre-process to defining the Query Tab in the Space, you need to use the Space picker in one of the upper forms of the BP from where you want to create the Query Tab. For defining a Query Tab, click on the Query Tabs link in uDesigner, click New, and select a Business Process. The system allows you to create a maximum of 8 Query Based Tabs in uDesigner. To define a Query Tab, go to uDesigner:

1) Click **Query Tabs**.
2) Click **New**.
3) Select a BP.

**Note:** You can use the Space picker (uuu_phy_space_picker) for the Query Tabs in the Upper form of the Business Process (BP), where you want the Query Tab originate from.

All the functionalities that are available with Query Tabs for Business Processes (BPs) are also available for the Space Manager.
The Query Items sub-node under the Space Manager node (uDesigner > Admin mode > Space Manager > [Space]) allows you to include references to other BPs in a form of a Query-based tab. Within a selected Space, the Query Items sub-node provides the following two links:

- Query Tabs
- Summary Elements

**Query Tabs**

Once a Query-based Tab (QBT) is successfully created and deployed using uDesigner, the BP Query Tabs appear in the Unifier required Space, in User mode. You can use the Query Tabs sub-node to define and maintain the various Query Tabs that are defined within the Space. See "Opening Space Records" and "Creating a New Space Record" topics in the *Unifier User Guide* for more details.

**General Tab**

In the General tab, you can enter the name, description, and reference picker for the required QBT BP.

In case, you have already included the Space picker in the Upper form of the BP, the Space picker appears in the drop-down list of the reference picker. In this case, the Name field is populated with the name of the BP, but you can change the name of the QBT, if necessary. The name and reference pickers are mandatory fields on the General Tab, so you cannot create a QBT if you have not included the Space picker on the Upper form of the BP.

**Query Tab**

The Query Tab of the QBT is used to create a query to filter the results, displayed within the QBT, based on any particular condition.

*Note*: It is not mandatory to have a query, so in case no queries are defined all records display in the QBT, in User mode.

You can define multiple queries within the Query tab.

Once you complete adding values in both General and Query tabs, click **Save**. The Query Tabs log page allows you to:

- See all the Query Tabs
- Create a new QBT (New).
- Open an existing QBT to review or change content (Open).
- Delete an existing QBT (Delete).
- Rearrange the ordering of the QBTs that are displayed (Tab Order).

**Summary Elements**

You can use the Summary Elements on the Detail form of the Space to show the data that is being exchanged. You can use all existing types of Summary Elements (Average, Count, Total, Maximum, and Minimum) in the QBT.
You can define multiple Summary Elements. To create Summary Elements, go to uDesigner > your space [Space] > Summary Elements and use the Space QBT to create your Summary Elements. After defining the Summary Elements, click OK to save. The Summary Element log page allows you to:

- See all the Summary Elements.
- Create a new Summary Element (New).
- Open an existing Summary Element to review or change content (Open).
- Delete an existing Summary Element (Delete).

Once you create the Summary Elements, you can include them in the Detail form of your space [Space].
Setting Up User-Defined Reports (UDRs)

These are the recommended steps to set up the User-Defined Report (UDR) functionality:

**Step 1:** Create a UDR template.
**Step 2:** Create project or shell UDRs.
**Step 3:** Create a program UDR.
**Step 4:** Create a company UDR.

In This Section

Creating and Setting Up a UDR Template ................................................................. 637

Creating and Setting Up a UDR Template

Report templates allow you to create templates that a user can then copy from to create User-Defined Reports (UDRs). Report templates are based on specific data types and pre-defined data elements that differ depending on the data type.

Report templates define queries used to search the database for transaction or Project/Shell data and report layout.

You can create UDR templates for the following UDR report types:

- Tabular
- Cross Tab
- Summary
- Alert

UDR Data Types

The following table summarizes data types in user-defined reports. Data types also include project- or shell-level and company-level business processes, asset classes, planning items, and sheets.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Project UDR</th>
<th>Shell UDR</th>
<th>Program UDR</th>
<th>Company UDR</th>
<th>UDR Template</th>
<th>Use for Maintenance Management Only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accounts Sheet</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Active Task Information</td>
<td>x</td>
<td>x</td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------</td>
<td>-------</td>
<td>--------------------</td>
<td>-------------------</td>
<td>--------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Asset Summary Sheet</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Audit</td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commitment Summary</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Company Cash Flow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Company Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Company User Information</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost Sheet - WBS</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Cost Transactions -WBS</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Cost Transactions MC - WBS</td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Views</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Document Manager</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
</tr>
<tr>
<td>Document Manager—Company</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Equipment</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Funding</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Gates</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Inventory</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inventory On-hand Detail</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Item Master</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Job Plan</td>
<td>x</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Master PM Book</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Master PM Meter Schedule</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Master PM Time Schedule</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material Transaction</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Partner User Information</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PM Book</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PM Meter Schedule</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PM Time Schedule</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Program Cash flow</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Program Cost</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Program Schedule</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Booking</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager—All Actuals</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager—Allocated Roles</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager—Booked Resources</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager—Project Actuals</td>
<td></td>
<td></td>
<td>x</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager—Resources (Company)</td>
<td></td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource</td>
<td></td>
<td></td>
<td>x</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manager—Roles</td>
<td>Resource Manager—Sheets</td>
<td>Service Center</td>
<td>Service Request</td>
<td>Schedule of Values</td>
<td>Shell or Project Cash Flow</td>
<td>Shell or Project Cost</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------</td>
<td>----------------</td>
<td>-----------------</td>
<td>-------------------</td>
<td>-----------------------</td>
<td>------------------------</td>
</tr>
</tbody>
</table>
Accessing UDR Templates

To access **Project** UDR templates:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Templates > Projects (Standards) > All > [project template]**.
3) Select a project from the log.
4) From the left-hand Navigator click **Reports > User-Defined**.

To access **Shell** UDR templates:

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click **Templates > Shells > [shell type] > [shell template]**.
3) From the left-hand Navigator, click a shell to open the log, select a shell from the log, and click **Open**.
4) From the left-hand Navigator click **Reports > User-Defined**.

The User-Defined Reports log for the (Shell UDR templates) contains all the UDR templates that have been defined for a specific Company, and the log contains the following information:

- **Menu bar**
  - File
  - Edit
  - View
  - Help

- **Toolbar**
  - New
  - Copy
  - Open
  - Edit
  - Delete
  - Find
  - Save Results
  - Tag
  - Update Shells
  - Import

- **Columns**
  - Name
  - Description
  - Data Type
  - Report Type
  - Owner
  - Scheduled
The following table explains each of the column-headings:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>This icon indicates that reports created based on this template will be enabled for web services integration. The integration option is available only for project-level, shell-level, and company-level reports.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the report template.</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the template.</td>
</tr>
<tr>
<td>Data Type</td>
<td>The type of data on which the report is being run, for example, business processes, Cost Manager elements, project or shell information, workflow information, etc.</td>
</tr>
<tr>
<td>Report Type</td>
<td>Tabular, cross tab, summary, or alert.</td>
</tr>
<tr>
<td>Owner</td>
<td>The creator of a report is its owner.</td>
</tr>
<tr>
<td>Scheduled</td>
<td>Displays the scheduled frequency of a scheduled report.</td>
</tr>
<tr>
<td>Last Run Date</td>
<td>The date that the report was run last.</td>
</tr>
<tr>
<td>Tag</td>
<td>Displays whether a UDR template has been tagged for Production, or not (blank).</td>
</tr>
<tr>
<td>Last Bundled Date</td>
<td>Displays the date of the Production Export bundle that included this UDR template.</td>
</tr>
</tbody>
</table>

**Creating a UDR Template**

These procedures are applicable for UDR templates or for manually creating a new UDR in User mode.

**To create a UDR template**

1) Go to the **Company Workspace** tab and switch to **Admin** mode.
2) Click one of the following in the left Navigator:
   - **Templates > Reports**
   - **Templates > Project (Standard) > All > [project template] > Reports > User-Defined**
   - **Templates > Shells > [shell type] > [shell template] > Reports > User-Defined**
3) Click the **New** button. The Create a New Report window opens.
4) Fill in the fields using the information in the table below
5) Click **OK**. The Edit Report window opens. This window has multiple tabs for defining the report layout and content. The actual tabs that display will depend on the type of report you are creating. These tabs are:

- **General tab**: In this tab, you enter the report name, the title that displays on the report at runtime, and define general settings, such as enabling it for integration, and setting a default time zone to use where time stamps appear on the report.

- **Data Elements tab**: Allows you to specify the data elements on which to report, and which will appear as columns on the report at runtime. The Data Elements tab differs with each report type. In addition, the data elements that are available to be added to the report depend on the data type chosen during report creation. The data elements can include business process fields, columns in cost, funding, SOV, and schedule sheets, project data such as project name, status, user name, etc.

- **Query tab**: Defines query parameters to input at report runtime.

- **Layout tab**: Allows you to customize the layout and presentation of the report. If you do not define layout parameters, a default layout will be used. The Layout tab differs with each report type.

- **Projects/ Shells tab**: This tab appears only in program-level and company-level reports. It displays which projects or shells will be included in the report.

- **Shells tab**: This tab appears only in shell-level reports. It displays which shells can be included in the report.

- **Permission tab**: Enables the report owner to grant permission to other users to run or edit the report. This tab is available only in User Mode and not in the report template.

- **Schedule tab**: Allows the report owner to schedule and configure automatic report generation and optionally save or email the results.

6) Complete the tabs in the Edit Report window as described in the following sections and click **OK**.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data Type</strong></td>
<td>Select from the list. The Data Type list includes all available business processes (for example, base contracts), pre-defined data types (e.g., project users), modules (for example, Document Manager), data views in Published status (listed in alpha order, project/shell-level requires project_id in query), and may also include custom data types.</td>
</tr>
</tbody>
</table>
| **Element**   | If you chose a business process or a uDesigner BP-driven feature (such as funding, schedule of values, project information) as the data type, the Element drop-down list becomes available. Select one of the following options as available for your data type choice:  
  - **All Fields**: Makes all fields on the BP available for the report.  
  - **General (Header) Fields**: Only the BP header fields will be available, which provides a less detailed report.  
  - **Custom Defined**: This is automatically selected for |
### uDesigner

- Created BPs and related functions. This enables all the custom data element fields on the BPs to be available for the report.

| Report Type | Choose a report type. |

---

### Tagging a UDR Template for Production

You can transfer User-Defined Reports (UDRs) that have been tagged in a Shell Template from Staging environment to Production environment. The data source for the reports can be a uDesigner design, a Data View, or a system-provided source.

Use the Tag option of the User-Defined Reports log in a Shell Template to tag a report for Production.

- The Tag column displays whether a UDR template has been tagged for Production, or not (blank).
- The Last Bundled Date column displays the date that the Production Export bundle was included in the report.

To tag a UDR template for Production and include it in the bundle:

1) Click the UDR template.
2) Click Tag and click Production.

**Notes:** The system retains the tab values even after the creation of the Production Export bundle.

To remove a UDR template that has been tagged for Production and exclude it from the bundle:

1) Click the UDR template.
2) Click Tag and click Clear.

### General tab (all reports)

The General tab defines the report name, title, and description and displays the data type and report type (tabular, cross tab, summary, or alert). The General tab is the same for each report type. Below is a sample of the General tab.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Name</td>
<td>The name appears on the user-defined reports log.</td>
</tr>
<tr>
<td>Report Title</td>
<td>The title appears on the report itself. By default, the field is populated automatically with the report name and is editable.</td>
</tr>
<tr>
<td>Description</td>
<td>Description is optional.</td>
</tr>
<tr>
<td>Data Type, Element, and Report Type</td>
<td>Automatically populated from the options selected during the creation of the report.</td>
</tr>
</tbody>
</table>
Enable for Integration

Selecting this option flags the report as eligible for integration through web services (uLink). Contact Oracle Customer Support for more information about web services integration and uLink. This option is available for project-, shell-, and company-level reports only.

When the checkbox is selected, the integration icon appears in the UDR log next to the report name.

Note: Because web services uses the report name to identify reports, each report marked for integration must have a unique name. If there are two reports with the same name, only one of those reports can be marked for integration. This is true even if you cannot see the other report with the same name. For example, another user has created a report with the same name, for which you do not have view permission, and marked it for integration.

Default Time Zone

This option allows you to choose the default time zone that will be used where time stamps appear on the report (such as data/time data elements). There are two options:

- Click the pull-down and choose a specific time zone in which to display date/time information in the report at runtime. Use this option when you want all instances of the report to display results in a fixed time zone, for example, the project location.
- You can also choose to default to user’s time zone. When this option is chosen, users in different locations will see report results that reflect their own time zone.

Note: For scheduled reports, all users will get the same report results. If the user time zone option is chosen, then the report owner’s time zone is used.

Data Elements tab (tabular report)

Each column of a tabular report corresponds to a data element or function (formula, date, or date difference). You can add or modify the data elements or functions on this tab. The Data Elements tab differs with each report type. The data elements depend on the data type chosen during report creation (see below.) The data elements can include business process fields, columns in cost, funding, SOV, and schedule sheets, project data such as project name, status, user name, etc.

<table>
<thead>
<tr>
<th>This button:</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Functions</td>
<td>Click to open the Data Element Properties window. Allows you to create a formula, data difference, or date column in the report.</td>
</tr>
<tr>
<td>Add Elements</td>
<td>Click to open the Data Element Picker window. The data sources and elements that are available vary based on the data type that you chose when creating the report.</td>
</tr>
<tr>
<td>Modify</td>
<td>Modify data element properties.</td>
</tr>
</tbody>
</table>
Sort | Determines which column to sort report results by.
---|---
Remove | Select a listed data element and click to remove it.
Move Up (Left) | Select a data element and click to move the column to the left.
Move Down (Right) | Select a data element and click to move the column to the right.
Current width | This field displays the width of the report in pixels. The report width is determined by the number and column width of data elements that are added.
Maximum available width | The maximum width of the report is determined by the page size and orientation as selected in the Layout tab.

Data Elements tab (cross tab report)

Cross tab reports allow the display of data on two axes. For example, the report below is being set up to track amount per WBS code per phase, where the WBS codes are the rows, the phases are the column headings, and the body data is made up of the line item amount.

Cross tab reports enable users to run time-series reports defined by two data sources, for example, payments made per quarter per vendor.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Column</td>
<td>This determines the data element that will be used for each row.</td>
</tr>
<tr>
<td>Data Element</td>
<td>Click <strong>Select</strong> and choose the data element. The list will depend upon the data type chosen. The data type will be listed before the data element, separated with a slash (/). For example: Funding/Funding Type, where Funding is the data type chosen on the General tab, and Funding Type is the data element.</td>
</tr>
<tr>
<td>Heading</td>
<td>The heading will automatically populate with the data element that you choose, but you can edit this as necessary.</td>
</tr>
</tbody>
</table>
You can specify a column width for the 1st column, or leave it blank to use the default width (automatically adjusts depending on the number of body columns in the report).

This determines the series for which the data will be presented. The list is pre-defined and will depend on what was chosen for the 1st Column. Typically, these are system-defined data elements related to the 1st column choice, for example, status, creation date, etc.

Click Select. The Data Element Picker window opens. Click the Data Source list at the top of the window and select a data source. This determines which data elements will be available for the report. The choices will include the data type you chose in the General tab, as well as related data sources. Select a data element and click OK. Some data sources might not have data elements.

You may specify body column width or leave it blank to have it automatically adjusted.

This determines the data that will show up in the body of the report. The list is dependent on what is chosen for the other parameters, and is determined by what is logically reportable.

Select Show Total if you want column and row sum totals to be included in the report. Choose Left or Right alignment. Choose Ascending or Descending to determine the sorting order of the columns and rows.

Data Elements tab (summary report)
On this tab, you specify the data that will be reported and how it will be presented on the project summary page. In the example below, a cost sheet report is being set up to display the value of total commits against WBS code.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Column</td>
<td>This determines the data element that will be used for each of the rows. In the example above, this is WBS code. Click Select and choose the data element. The list will depend upon the data type chosen. The data type will be listed before the data element, separated with a slash (/). For example: Funding/Funding Type, where Funding is the data type chosen on the General tab, and Funding Type is the data element.</td>
</tr>
<tr>
<td>Heading</td>
<td>The will automatically populate with the data element that you choose, but you can edit this as necessary.</td>
</tr>
<tr>
<td>Width</td>
<td>You may specify a column width or leave it blank to use the default width.</td>
</tr>
</tbody>
</table>
If the data element is a date type, you can specify time parameters

- **By:** Choose the year, quarter, month, or day to display the data.
- **Format:** How the heading will display the date
- **From and To:** Establishes the date range to include in the report.

<table>
<thead>
<tr>
<th>2nd Column</th>
<th>This determines what information is being presented.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Count</td>
<td>Displays the total number of records. For example, for a report on a BP type, it will display the number of BP records.</td>
</tr>
<tr>
<td>Summary Value</td>
<td>Displays a value. In the above example, the value is the total value of the commits (Contracts + Change Orders) for each WBS code. To enter a formula, click the <strong>Formula</strong> button.</td>
</tr>
</tbody>
</table>
| Summary Type | Choose one of the following:  
- **Summary:** Provides a summary value.  
- **Average:** Displays the average value.  
- **Maximum:** Displays the maximum value.  
- **Minimum:** Displays the minimum value. |
| Heading | Type a heading for the 2nd column. |
| Width | You may specify a column width or leave it blank to use the default width. |

### Data Elements tab (alert report)

On this tab, you define the parameters that will trigger the alert that will be sent you. In the example below, the alert will be triggered for invoices that are greater than $1,000.

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alert Column</td>
<td>This determines what information is being presented.</td>
</tr>
<tr>
<td>Record Count</td>
<td>Displays the total number of records.</td>
</tr>
<tr>
<td>Summary Value</td>
<td>Displays a value. In the above example, the value is the total value of the commits (Contracts + Change Orders) for each WBS code. To enter a formula, click the <strong>Formula</strong> button.</td>
</tr>
</tbody>
</table>
| Summary Type | Choose one of the following:  
- **Summary:** Provides a summary value.  
- **Average:** Displays the average value.  
- **Maximum:** Displays the maximum value.  
- **Minimum:** Displays the minimum value. |
| Condition | Specify the condition that will trigger the alert. This can be used for record count or summary value. |
| Trigger Value | Enter the value of the record count or summary value that will trigger the alert. |
Indicator | Allows you to specify a flag icon (red, yellow, or green) in the alert to help you identify the level or type of alert. The flags have no meaning other than user-defined identification.

### Data elements

<table>
<thead>
<tr>
<th>Data Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query parameters</td>
<td>This data element will allow query parameters to be printed with the report result.</td>
</tr>
<tr>
<td>Project/Shell list</td>
<td>This data element will allow project or shell list information to be printed with the report result.</td>
</tr>
</tbody>
</table>

The display of numeric data elements can be formatted. The following formats are available:

- **Decimal place**: Number of decimals to display
- **User1000 separator**: Display of comma separator
- **Negative number format**: Minus sign or parenthesis; for example, -1234 or (1234)

### Query tab (all reports)

The Query tab defines query parameters to input at report runtime. For example, for a funding report, the query can be set to run the report only on specific company funds. You can define the funds or allow the user to specify them at runtime.

The data elements available for the query will depend on the report data type. Defining a query is optional. See *Define report queries (query condition)* (on page 659).

<table>
<thead>
<tr>
<th>This button:</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Allows you to add a query condition to the report.</td>
</tr>
<tr>
<td>Modify</td>
<td>Select a query condition and click to modify.</td>
</tr>
<tr>
<td>Remove</td>
<td>Select a query condition and click to delete it from the report.</td>
</tr>
<tr>
<td>Show results matching any condition (instead of all)</td>
<td>Select this to show report results matching one or more of the listed query conditions. If you do not select this option, the report results will include only those that match all listed query conditions.</td>
</tr>
</tbody>
</table>
Layout tab (all reports)
The Layout tab allows you to configure the layout and presentation of the report results. If you do not define layout parameters, the default settings will be used. The Layout tab is the same for all reports with the following exceptions: Cross tab reports and tabular reports each include an additional layout option specific to their report types (see Layout tab (Cross Tab setting) (on page 651) and Layout tab (Group By setting) (on page 652)).

Click on the Report Properties options on the left side of the window to define each layout.

Layout tab (Page Setup setting)
The Page Setup on the Layout tab allows you to configure the size and orientation of the report (see below.)

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Choose the paper size from the drop-down list (letter, legal, ledger, or A4).</td>
</tr>
<tr>
<td>Orientation</td>
<td>Report can be generated as portrait or landscape.</td>
</tr>
</tbody>
</table>

Layout tab (Title Page, Header, Footer, Summary Page settings)
The Title Page, Header, Footer and Summary Page options allow you to define general layout and presentation of the report results. If you do not define layout parameters, the default settings will be used. A number of standard and report-specific data elements are available to add to your report.

Tip: If you want users to be able to add a runtime note, include the data element Runtime Notes in the layout.

<table>
<thead>
<tr>
<th>Report Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Page</td>
<td>You can create an optional title page, which will be the first page of the report.</td>
</tr>
<tr>
<td>Header</td>
<td>You may enter a header for the report. This will display at the top of each page of the body of the report. The header will not display on the title page or the summary page.</td>
</tr>
<tr>
<td>Footer</td>
<td>The footer will display at the bottom of each page of the body of the report. The footer will not display on the title page or the summary page.</td>
</tr>
<tr>
<td>Summary Page</td>
<td>The summary page will display as the last page of the report.</td>
</tr>
</tbody>
</table>
For more information about setting up these report properties, see *Set up title page, header, footer and summary page* (on page 660)

<table>
<thead>
<tr>
<th>This button:</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Click the Add button to add additional rows of text to the title page, header, footer, or summary page.</td>
</tr>
<tr>
<td>Modify</td>
<td>Select a row and click Modify to edit it.</td>
</tr>
<tr>
<td>Remove</td>
<td>Select a row and click Remove to delete it.</td>
</tr>
<tr>
<td>Move Up or Move Down</td>
<td>Select a row and click Move Up or Move Down to change the order of the rows.</td>
</tr>
<tr>
<td>Current Height</td>
<td>Displays the total height of the text (sum of the pixels of all lines) in the header, footer, title page, and summary page.</td>
</tr>
<tr>
<td>Maximum Available Height</td>
<td>Displays the maximum height available, based on the paper size and orientation.</td>
</tr>
<tr>
<td>Show Border</td>
<td>Select if you want the text to be enclosed in a border.</td>
</tr>
</tbody>
</table>

**Layout tab (Cross Tab setting)**

For cross tab reports. The fields here are applicable for time stamp data element types in the first column and body columns, as selected in the Data Elements tab).

<table>
<thead>
<tr>
<th>In this field:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>By</td>
<td>Sets the time period for the report by year, quarter, month, or day.</td>
</tr>
<tr>
<td>Format</td>
<td>Select the format of the By field.</td>
</tr>
<tr>
<td>From and To</td>
<td>Specify the date range on which you want to report. You can select Auto Range instead.</td>
</tr>
<tr>
<td>From: Auto Range</td>
<td>The Auto Range feature automatically displays data in report results without specifying a date range. You can select Auto Range for either or both to and from dates. If the From Auto Range option is selected, all available data up until the specified end date will display in the report. For example, if you want to view all data up to 2005 but want to exclude 2006, you would click Auto Range From and select a To date of 2005.</td>
</tr>
<tr>
<td>To: Auto Range</td>
<td>If the To Auto Range option is selected, all available data from the specified start date until present will display in the report. For example, if you want to view data starting from 2004 to present, click Auto Range and select From Date of 2004.</td>
</tr>
</tbody>
</table>
Layout tab (Group By setting)

Tabular reports can include grouped data element results, for example, grouping BP record results by BP creator.

**Note:** For Unifier Mobile users, if the Group By option is set on reports (that is, group by user name), you cannot mark these reports as mobile. Reports marked as mobile cannot contain groupings of data results.

<table>
<thead>
<tr>
<th>This button:</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Click to add a group.</td>
</tr>
<tr>
<td>Modify</td>
<td>Select a group and click to modify the Group By properties.</td>
</tr>
<tr>
<td>Remove</td>
<td>Select the group and click to remove.</td>
</tr>
</tbody>
</table>

Projects tab (program-level reports, all types)

This tab appears only in program-level and company-level reports, and displays which projects will be included in the report (see below.) The Projects tab is set up the same way for each report type.

For program-level reports, the projects that are part of the program are listed in the Projects tab and are not editable.

Projects/Shells tab (program-level and company-level reports, all types)

This tab (see below) appears only in program-level and company-level reports, and displays which shells and projects will be included in the report.

For company-level reports, the Project/Shells tab displays all shells in the company. The report can automatically include all active and on-hold projects or shells in each report generated, or it can be edited to include a subset of project or shells and optionally allow users to modify the project or shell list during runtime.

<table>
<thead>
<tr>
<th>This button or option:</th>
<th>Does this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically add all active, view-only, and on-hold projects/shells</td>
<td>When this option is chosen, the generated report will automatically include all active, view-only, or on-hold projects and shells. Inactive projects and shells are not included in the generated report results.</td>
</tr>
<tr>
<td>Only data from selected projects/shells</td>
<td>This option allows you to select which projects/shells (with Active, On-Hold, or View-Only status) to include in the report. To add a project or shell, click the <strong>Add</strong> button. In the Select Project window, select the project/shell to add and click Add. To remove a project or shell from the report, select it from the</td>
</tr>
</tbody>
</table>
### Shells tab (shell-level reports, all types)

This tab appears only in shell-level reports, and displays which shells will be included in the report.

<table>
<thead>
<tr>
<th>This button or option:</th>
<th>Does this:</th>
</tr>
</thead>
</table>
| **Shells**             | The options in this field are:  
|                        | Current Shell and Sub-Shells  
|                        | Current Shell Only  
|                        | Sub-Shells Only  
|                        | User-Defined  
|                        | The User-Defined option allows you to choose from among the shells in which you are a member. |
| **Exclude Inactive Shells** | Allows you to exclude shells with the status Inactive. This is checked by default. |
| **Add**                | When you click Add, the Select shell window opens. Select the shells and click the Add button. This button is available only if you have selected the User-Defined option in the Shells field. |
| **Remove**             | Select a shell and click Remove to remove it from the report. This button is available only if you have selected the User-Defined option in the Shells field. |
| **Allow users to modify User-defined list during execution** | This checkbox is enabled if User-Defined is chosen. When this checkbox is selected, users will be able to change which shells from the available list to include in the generated report at runtime. |

### Permission tab (all reports)

In the Permission tab, you can grant permission to other users to run, edit, or modify the permissions of this report. This tab is available only in User Mode and not in the report template.
**Schedule tab (all reports)**

The Schedule tab enables report owners to create a schedule to automatically run user-defined reports and save the results as PDF or XML files, automatically save the report in the Document Manager, and to specify whether to email the report results to the report owner or to specified users and groups.

<table>
<thead>
<tr>
<th>In this field</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Scheduled Report Runs</td>
<td>Select this checkbox to enable scheduling of automatic report runs. Define the following parameters.</td>
</tr>
<tr>
<td>Output Format</td>
<td>Specify the format of the scheduled report results: PDF or XML.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Specify the frequency with which the report will be run:</td>
</tr>
<tr>
<td></td>
<td><strong>Daily</strong>: Runs once at the end of the day (23:59:59).</td>
</tr>
<tr>
<td></td>
<td><strong>Weekly</strong>: Specify the day on which the report will be generated, e.g., from previous week Saturday (00:00:00) to this week Friday (23:59:59).</td>
</tr>
<tr>
<td></td>
<td><strong>Monthly</strong>: Specify the date on which the report will be generated. If the scheduled date is past the last day of the month (e.g., the 31), the report will automatically be generated on the last day of that month. E.g., monthly (08/04/06) frequency should take last month (07/05/06 00:00:00) to this month (08/04/06 23:59:59).</td>
</tr>
<tr>
<td></td>
<td><strong>Quarterly</strong>: Generated at the end of each calendar quarter. E.g., data generated end of Q2 should be Q2 (04/01/06 00:00:00) to end of quarter Q2 (06/30/06 23:59:59). Q1 is Jan to March, Q2 is April to June, Q3 is July to Sept, Q4 is Oct to Dec.</td>
</tr>
<tr>
<td></td>
<td><strong>Yearly</strong>: Report is generated at the end of the calendar year. E.g., data generated end of 2006 should be 2006 01/01/06 00:00:00 to 2006 12/31/06 23:59:59.</td>
</tr>
<tr>
<td>Range of Recurrence</td>
<td>Choose the range of recurrence of the scheduled report:</td>
</tr>
<tr>
<td></td>
<td><strong>No end date</strong>: The report will be generated according to schedule indefinitely.</td>
</tr>
<tr>
<td></td>
<td><strong>End by</strong>: A date after which the scheduled report will not be generated.</td>
</tr>
<tr>
<td>Auto-email as attachment to report owner</td>
<td>Select to have a PDF or XML copy of the report emailed to the report owner after generation. You can select this option and Auto-email as attachments to users and groups at the same time.</td>
</tr>
<tr>
<td>Auto-email as attachments to</td>
<td>Select to have a PDF or XML copy of the report emailed</td>
</tr>
</tbody>
</table>
Add and manage data elements (columns) to the report

The following procedures describe how to add data elements to a user-defined report or template. These become the columns on the report at runtime, and determine what data will be displayed on the report.

To add data elements to the report
1) In the Edit Report window, click the Data Elements tab.
2) Click Add Elements. The Data Element Picker opens.
3) Choose one or more data elements from the list. (Press the Ctrl or Shift keys to select multiple data elements.)
4) Click OK.

Add formulas to data elements

If you want to display the results of calculations based on data elements available for the data type you chose, you can create a formula column on the report.

Note: Use caution when creating a formula with data elements. It is possible to create a formula where the denominator is zero, which can cause a data conflict error when the report is run.

To add a formula
1) In the Edit Report window, Data Elements tab, click the Add Functions buttons. The Data Element Properties window opens.
2) From the Data Element drop-down list, choose Formula. The Data Element Properties window expands.

3) Enter a column heading, which is displayed on the report.
   You may specify how the column is displayed by specifying the alignment, column width, decimal places, 1000 separator, and negative number format.

4) If you select Hide Column, the column will not be displayed on the report.

5) Selecting Summary will display the sum of the column values at the end of the column.

6) Click Formula to open the Formula Creator. Create the formula and click OK.

To add a date add column
1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data Element Properties window opens.

2) From the Data Element drop-down list, choose Date Add. The Data Element Properties window expands.

3) Enter a column heading, which is displayed on the report.
   You may specify how the column is displayed by specifying the width (in pixels) and alignment. If you select Hide Column, the column will not be displayed on the report.

4) For the Date field, click Select and choose the date data source.

5) For the Add field, select the numerical data source. This is the value that will be added to the date element to arrive at the final value to display in the report.

6) If you want the time to also display as well as the date, then select the Display Timestamp checkbox.

7) Click OK.

To add a date difference column
1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data Element Properties window opens.

2) From the Data Element drop-down list, choose Date Difference. The Data Element Properties window expands.

3) Enter a column heading, which is displayed on the report.
   You may specify how the column is displayed by specifying the width (in pixels) and alignment. If you select Hide Column, the column will not be displayed on the report.

4) Specify the earlier date and later date. Choose Today if you want to use the current day as one of the dates, or click Select to open the Data Element Picker. Select a data source from the drop-down list, then select a data element from the resulting list.

5) If you want to show results with partial days, then select the Show Partial Days checkbox.

   Note: Date Picker data elements (as opposed to Date Only pickers) include timestamps. When calculating the difference between these date and times, it is possible to get a result in partial days. If you select this checkbox, results will display two decimal places; if you do not select this checkbox, results will be in whole numbers.

6) Click OK. The calculation is Later Date - Earlier Date, in days.
Manage report column (data element) properties

You can refine the display of the report columns by modifying the data element properties. You can modify the column heading, width and alignment, as well as hide a column, or choose to display the timestamp for date pickers.

**To view or modify column properties**

1) In the Edit Report window, Data Elements tab, select the listed data element and click **Modify**.
2) You can modify the column heading, column width, and alignment for how you want it to appear in the report results.
3) Click **OK**.

**To hide data elements in the report output**

1) Select the listed data element and click **Modify**.
2) Select **Hide Column** if you do not want the column to appear on the report (for example, columns added as part of a formula calculation but do not need to be printed).
3) Click **OK**.

**To display the timestamp on date data elements**

1) Select the listed date picker data element and click **Modify**. For date picker elements that include timestamps, the Data Element Properties window displays an additional option: Display Timestamp. This option is not available for data elements based on date-only pickers, or other elements that do not capture timestamps.

   **Note:** The Schedule Manager ignores timestamps, therefore, date fields associated with the Schedule Manager will not display the time, even if this option is selected.

2) Select **Display Timestamp**. At runtime, the time displays next to the date.
3) Click **OK**.

**To remove a listed data element**

Select the data element to remove from the report and click **Remove**.

**To change the order of the data element columns**

Select a data element from the list. Click **Move Up (Left)** to move the element up the list to the left on the report), or **Move Down (Right)** to move it down to the right on the report.

**To choose the column by which to sort the report**

1) Click the **Sort** button.
2) In the **Column Heading** list box, select the data element column by which you want to sort the report findings. For example, choose Creator Name to sort by the creator of each record.
3) Click the right arrow button **>>** to move it to the Sort By field.
4) In the Sort Order list, choose **Ascending** or **Descending**. Click **OK**.
Set auto range
The auto range feature for cross tab report types automatically displays report data without having to specify a date range. During set up, you select the data types. Only time stamp types enable the option for configuring the date range and auto range.

For example, if 2005 to 2006 is specified as the date range but only values for 2005 have been entered, the report will only display data for 2005. If a date range is not specified, all data will be displayed in the generated report.

At runtime, users will have the option to select dates or auto range.

To enable the auto range option
1) From the Edit Report window, click the Data Elements tab.
2) Set time stamp data element (date) under First Column or Body Columns.
   If no timestamp data element is specified, all dates with data will be displayed when the report is generated.
3) Click Apply.

To set the auto range
1) Click the Layout tab, then click Cross Tab. There are two checkboxes for auto range.

   Note: Only report columns with data appear for non-time-stamp data types. If a data value is not entered, the column will not appear in a cross tab report. If you select the time stamp data type, report columns appear, even if data is not entered.

2) For From Date, click the Auto Range radio button.
   The date selection option will be grayed out. If From Date is selected and To Date is deselected, all data up until the specified end date will display in the report. For example, to view data up to 2005 but exclude 2006, click Auto Range and enter a To Date of 2005.
   Alternatively, to view data from 2004 to present, deselect Auto Range and enter a From Date of 2004.

3) For To Date, click the Auto Range radio button.
   The date selection option will be grayed out. If From Date is deselected, data entered from the specified start date until present will display in the report. For example, to view data starting from 2004 to the present, click Auto Range and enter a From Date of 2004.
   Alternatively, to view data up to 2005 but exclude 2006, deselect Auto Range and enter a To Date of 2005.
   If you select both options for the Auto Range From and To dates, only the data supplied for this period will appear in the report.

Grant report edit or run permissions to other users
If you are the creator or owner of a report, or if you are an administrator with full access permissions, you can grant permission to other users to access or run a report.
To grant report permission to other users
1) In User Mode, navigate to the user-defined report log. Select the UDR and click the Edit button. The Edit Report window opens.
2) Click the Permission tab.
3) Click the Add button. The User/Group Picker opens.
4) Select users or groups, click Add and OK.
5) Select the newly added user or group, and select the permissions to grant:
   - **Modify Permission**: Allows the user to modify other users’ permission settings for the report.
   - **Edit Report**: Allows user to edit report parameters.
   - **Run**: Enabled by default. Allows the user to run the report.
6) Click Apply to save your changes and then OK to exit the Edit Report window.

Define report queries (query condition)
You can define query parameters that users can input at report runtime. For example, for a funding report, the query can be set to run the report only on specific company funds that the user specifies at runtime. Defining a query is optional.

The data elements available for the query will depend on the report data type, and the condition options will be dependent upon the data element type chosen.

To define a query
1) From the Query tab, click Add. The Query Condition window opens.
2) Click the Select button to open the Data Element Picker. Choose a data source from the drop-down list, and then choose a data element from the list.

   **Note**: If you choose a date-type data element, the Use timestamp in query checkbox becomes available; if you select this option, the timestamp as well as the date will be taken into account in the query.

3) The Label field is populated based on the selection and can be modified.
4) Select a condition from the resulting list.
   For example, choose equals to generate reports that exactly meet certain conditions or since last scheduled report run to generate reports with incremental data between scheduled runs.
5) For Values, click the Select button and select one or more values for the condition (e.g., Pending or Approved).
   For maximum flexibility, choose a list of conditions but leave the value empty. This allows the user who runs the report to choose to use one or all of the queries to limit the data on which the report will be based.
6) If you want users to be able to modify these values when running the report, select **Allow users to modify value(s) during execution**. This option is checked by default and recommended to provide flexibility at report runtime.
7) Click OK.
Set up title page, header, footer and summary page

You can set up the report’s title page, header, footer, and summary page from the Layout tab. These are all set up in a similar way.

- The title page is printed as the first page of the report.
- The header is printed at the top of each of the results pages.
- The footer is printed at the bottom of each of the results pages.
- The summary page is printed at the end of the report, after the results.

To set up the title page, header, footer, and summary page

1) In the Edit Report window, click the Layout tab.
2) Under Report Properties, click Title Page, Header, Footer, or Summary Page.
3) Click Content and select from the list. The drop-down options are the same for left, center, or right columns.

- **Number of Projects/shells**: Displays the number of projects or shells within the phrase "This report contains data from n projects or shells."
- **Page**: Shows the page number for each page of the report.
- **Project/Shell List**: Provides a list of all of the projects or shells from which data is used for the report, in the format Project/Shell Number: Project/Shell Name. Can be used for reports on one or multiple projects or shells.
- **Project/Shell Name**: Displays the project or shell name when the report is for a single report. If multiple projects or shells are included in the report, the names will not be displayed (use Project/Shell List instead).
- **Project/Shell Number**: Displays the project or shell number when the report is for a single report. If multiple projects or shells are included in the report, the numbers will not be displayed (use Project/Shell List instead).
- **Query Parameters**: Displays the query parameters entered from the report.
- **Report Owner**: Displays the report owner.
- **Report Run By**: Displays the user who ran the report. If the report was generated by schedule, the name of the report owner will be displayed.
- **Report Title**: Displays the title of the report.
- **Run Date**: Displays the date on which the report was run. This date/time reflects server time, that is, the time zone in which the server running your Unifier environment is located; for most users, this will be Pacific Time (GMT -8). If you have any questions regarding server time for your environment, contact your Company Administrator.
- **Run Date and Time**: Displays the date and time on which the report was run. This date/time reflects server time.
- **Time Zone**: Displays the time zone that is applicable for the report, as chosen in the General tab of the Edit Report window (a default time zone or the user’s at runtime).
- **Runtime Notes**: Choosing this option does two things: provides a text box in which to enter notes that will appear on each report (for example, "Runtime Notes:") and activates a Runtime Notes text box in the Notes tab during runtime in which the user running the report can add notes that will appear on the current report only.
- **Text**: Provides a text box in which you may enter text to be displayed on the report.
4) Keep an eye on the fields in the bottom of the window:
   - **Current height (pixels):** Displays the total height of the text (sum of the pixels of all lines) in the header, footer, title page, or summary page.
   - **Maximum available height:** Total allowable height.
   - **Show Border:** Selecting this checkbox will display a four-sided border around the title page, header, footer, or summary page text.

   The following figures display the default layouts of the header, footer, and summary page options. These are customizable.

### Schedule report runs

Report owners can schedule automatic generation of user-defined reports. The report can be scheduled to run daily, weekly, monthly, quarterly, or yearly. Schedule report results will be saved and can be retrieved later, or can be optionally emailed.

Users with run permissions will be able to retrieve the generated reports. Report owners can schedule generation of the report.

#### To schedule report runs

1) Open the Edit Report window for the report and choose the **Schedule** tab.
2) Select the **Enable Scheduled Report Runs** checkbox.
3) Select the output format:
   - **PDF:** The results will be saved in a PDF file, which can be read using Adobe Acrobat Reader.
   - **XML:** The results will be saved in an XML file.
4) Specify the frequency with which the report will be run:
   - **Daily:** Report will be run daily.
   - **Weekly:** Specify the day on which the report will be generated.
   - **Monthly:** Specify the date on which the report will be generated. If the scheduled date is past the last day of the month (e.g., the 31st), the report will automatically be generated on the last day of that month.
   - **Quarterly:** Generated at the end of each calendar quarter.
   - **Yearly:** Report is generated at the end of the calendar year.
5) Specify the range of recurrence of the scheduled report:
   - **No end date:** The report will be generated according to schedule indefinitely.
   - **End by:** A date after which the scheduled report will not be generated.
6) Select **Auto-email as attachment to report owner** to have a copy of the report emailed as a PDF or XML file attachment, based on your output format selection.

   Or, select **Auto-email as attachment to users and groups** to have a copy of the report emailed as a PDF or XML file attachment, based on your output format selection. Click **Select**, specify the users and groups, and click **OK**. You can select this option and **Auto-email as attachments to report owner** at the same time.
Note: Be sure to specify Results from scheduled reports in your user preferences email management to receive the email and attachment.

7) Select the Saved Result Log checkbox to save the report in Unifier, where you can view it at your convenience.

8) Select the Document Manager checkbox to save the report in the Document Manager.
   In the Save as field, Unifier shows the name of the report; however, you can enter another name for the report if you want.
   In the Location field, click Select and choose the folder in the Document Manager in which the report should be saved. (You must have permissions to the folder.)

9) Click OK.

Report Run Times
Run time reflects server time, that is, the time zone in which the server running your Unifier environment is located; for most users, this will be Pacific Time (GMT -8). If you have any questions regarding server time for your environment, contact your Company Administrator.

- **Daily**: 23:59:59
- **Weekly**: E.g., from previous week Saturday (00:00:00) to this week Friday (23:59:59).
- **Monthly**: E.g., monthly (08/04/07) frequency should take last month (07/05/07 00:00:00) to this month (08/04/07 23:59:59)
- **Quarterly**: E.g., data generated end of Q2 should be Q2 (04/01/07 00:00:00) to end of quarter Q2 (06/30/07 23:59:59).
- **Yearly**: E.g., data generated end of 2007 should be 2007 01/01/07 00:00:00 to 2007 12/31/07 23:59:59.

Generate reports with incremental data between scheduled runs
You can generate reports that only include information added since the last scheduled run for the report.

To generate reports with incremental data for every scheduled run
1) Open the Edit Report window and choose the Query tab.
2) Click the Condition drop-down list and choose since last scheduled report run.
3) Click OK.

Enable a report for web services integration
You can flag project or shell and company user-defined reports as eligible for integration. This enables report results to be available for integration with other systems through web services and uLink. This option is not available for program-level reports. Contact Oracle Customer Support for information regarding XML integration via web services.

To enable a user-defined report for web services integration
1) Open the Edit Report window and choose the General tab.
2) Select the **Enable for Integration** checkbox and click **OK**. The integration icon will display in the UDR log next to the report.

**Report Names**: Because web services uses the report name to identify reports, each report marked for integration must have a unique name. For project- or shell-level reports, this applies to all UDRs within a specific project or shell. For company-level reports, it applies to all company-level UDRs. If there are two reports with the same name, only one of those reports can be marked for Integration. This is true even if you cannot see the other report with the same name. For example, another user has created a report with the same name, for which you do not have view permission, and marked it for integration.
Creating User-Defined Project, Shell, Program, and Company Reports

Before running a report, it must first be created and set up to define its parameters. The following procedures describe creating UDRs at the project or shell, program and company levels. This section will show you how to:

- Access project, shell, program, and company UDRs
- Create a UDR by copying a template
- Create a UDR by copying an existing report in the same log
- Create a UDR from scratch

In This Section

Access user-defined reports .............................................................. 665
Create a UDR from a report template .................................................... 665
Editing or Deleting User-Defined Reports ............................................. 666
Importing User-Defined Reports into Project or Shell Templates .............. 666

Access user-defined reports

User-defined reports are set up and run in User Mode. You can run project or shell, program, and company level UDRs.

To access project or shell user-defined reports

In User Mode, open a project or shell. Navigate to Reports > User-Defined. The User-Defined Reports log opens.

To access shell user-defined reports

In User Mode, open a shell. Navigate to Reports > User-Defined. The User-Defined Reports log opens.

To access program user-defined reports

In User Mode, open a program. Navigate to Reports > User-Defined. The User-Defined Reports log opens.

To access company user-defined reports

In User Mode, open the company. Navigate to Reports. The User-Defined Reports log opens.

Create a UDR from a report template

The following procedure explains how to create a UDR by copying an existing report template.

To create a user-defined report from a template

1) Navigate to the project, shell, program, or company User-Defined Reports log.
Unifier Administration Guide

2) Click the **Copy** button and choose **Template**. The Copy From Report Template window opens.

3) Select a template from the list and click the **Copy** button. The Edit Report window opens.

4) Review the parameters on each of the tabs and edit as necessary. See *Creating a UDR Template* (on page 642) for details on the tabs.

5) Click **Apply** to save changes, or **OK** to save changes and close the Edit Report window. The report is listed in the log.

**To create a user-defined report from an existing report**

1) Navigate to the project, shell, program, or company User-Defined Reports log.
2) Select a report from the log.
3) Click the **Copy** button and choose **Report**. The Edit Report window opens. The default name is "Copy of Template Name."
4) Follow the steps in the procedure *Creating a UDR Template* (on page 642).

**To create a user-defined report manually**

1) Navigate to the project, shell, program, or company User-Defined Reports log and click **New**.
2) Follow the instructions in the procedure *Creating a UDR Template* (on page 642).

### Editing or Deleting User-Defined Reports

You can edit most report parameters and assign report permissions to each report in User Mode. You can also view the list of projects or shells that will be included in program-level reports, and select the projects or shells to include in company-level reports.

This is applicable if you are the report owner, if you have edit permission, or if you are an administrator with full access permissions.

**To edit a user-defined report**

1) Navigate to the UDR log and select the report to edit.
2) Click the **Edit** button. The Edit Report window opens. Review or edit the parameters on the tabs. For more information about each of the tabs, see *Creating a UDR Template* (on page 642).
3) Click **Apply** to save changes, or **OK** to save changes and close the Edit Report window.

**To delete a user-defined report**

Select it from the log and click **Delete**.

### Importing User-Defined Reports into Project or Shell Templates

You can import user-defined reports into project templates from project templates in other Companies or other Unifier environments. Also, you can import user-defined reports into shell templates of the same shell type from other Companies or other Unifier environments. This enables you to reuse reports created in other companies or environments.
To import user-defined reports

1) Go to the Company Workspace tab and switch to Admin mode.
2) In the left Navigator, click:
   - Templates > Project (Standard) > All > [project] > Reports > User-Defined Reports
   - Templates > Shells > [shell type] > [shell] Reports > User-Defined Reports
3) Click the Import button. The Unifier Sign In window opens.
4) Enter the following information:
   - Company Short Name: this is the identifier used for your company, and was set up at the time of company configuration.
   - Authentication Key: this key is set up at the time the company was configured. Contact your site administrator for further information.
   - Primavera Unifier URL: the web address of the Primavera Unifier server.
   - Search For: use to narrow your search for the report you want to import.
5) Click OK. The Import Report Template from Unifier window opens, listing the user-defined reports.
6) Choose the report or reports and click the Import button. The UDR Import Error window opens, listing any import errors. These are some possible report import errors:
   - Source and destination report environments have different versions of Unifier
   - Report already exists in the destination if the report is enabled for Integration
   - Report data sources vary between the report source and destination
   If there are no errors, all reports are imported; if there are errors, none of the reports are imported until the errors are rectified.

   **Note**: If you are importing a user-defined report into a shell template, the report you import must be from a shell of the same type as the destination shell template.

7) When the import is complete, click OK.
8) Click Close to exit the Import Report Template from Unifier window. The reports are added to the User-Defined Reports log. When you import a user-defined report, you are listed the report owner.
Translating Custom Strings (Internationalization)

The content of the material created by the Users (also known as custom strings) can be translated into different languages.

Examples
- Business Process (BP) name, Data Element (DE) label, drop-down labels, radio button, navigation log names, and multi select values

**Note:** The user input data in Business Processes (BPs), attribute forms of various Managers, and other similar elements, when entered at runtime, cannot be translated.

The Internationalization node (a sub-node of Configuration node) contains the custom strings that the users have developed. The custom strings that are listed in the Internationalization Log window are set to provide the necessary details for translators.

In This Section

Internationalization Node Properties .............................................................. 669
Displaying Custom Strings and System Strings ............................................. 671
Assigning Permissions .................................................................................. 673
Translating Methods ...................................................................................... 673
Internationalizing Unifier Environments (Staging and Production) ............. 675

Internationalization Node Properties

To access the Internationalization node:

1) Sign in to **Unifier**.
2) Go to **Company Workspace**.
3) Switch to **Admin** mode.
4) Click **Configuration** node to expand.
5) Click **Internationalization** to open the Configuration - Internationalization Log window (Internationalization Log).

Within the Internationalization Log, you can:

- Determine which log item qualify for custom strings translation.
- Select to see 100 or 200 items per page.
  - Use the Display drop-down list on top right-hand side of the log window.
- Change the order of the items in the Source Type column.
- Change the sequence of the languages displayed in the log as explained in the following section.
- See the list of all Custom Strings available for translation.
To change the sequence of the languages displayed in the Internationalization Log:

1) From the Internationalization Log window toolbar, click Columns to open the Internationalization Log - Language Order window.
   Alternatively, you can click Edit from the menu bar and select Columns.
2) To select which languages must be displayed in the log list, select or deselect your options from the Show Language column.
3) To rearrange the order of languages displayed on each row in the log list, click to select the language, and click **Move Up** or click **Move Down**.
   Alternatively, you can double-click the number next to the language, edit the number, and click Update Order.
4) When finished, click **Update Order**, **Apply**, and **OK**.
5) Use **Refresh** to update the list in the Internationalization Log window. The following explains the refresh options:
   - **Strings**: Use this option to refresh the Internationalization log with the source strings belonging to a particular source type. The system prompts you to select the Source Type of the strings that need to be refreshed.
     When you select Strings, the Refresh Strings window opens, which allows you to select, or deselect the source types that you want the system to display. Click OK to save your changes, Cancel to terminate the change.
   - **All Strings**: Use this option to refresh the Internationalization log with all custom strings from all source types. This operation might take a few minutes.
     When you select All Strings, a Confirmation message window opens explaining the system status. Review the message and proceed as desired.
   - **History**: Use this option to see the history of refresh requests: Requestor, Source Type, Submit Date, End Date, and Status. You can view History details after the refresh is complete.

The following explains the function of each toolbar option in the Internationalization Log window:

- **Open**: This option allows you to open the translated custom string.
- **Export**: This option allows you to export strings for bulk translation.
- **Import**: This option allows you to import a file that is ready (translated) into Unifier, or log.
- **Delete**: This option allows you to delete translated custom strings.
  **Note**: You can delete a custom string only if it has not been used elsewhere.
- **Find**: This option allows you to filter out the custom strings that are available in the log.
  **Note**: When you select this option, you must select a source type and provide search operator for the string that you want to find.
- **Columns**: This option allows you to set the sequence of log columns.
- **Refresh**: This option allows you to refresh the items in the log with new or modified custom strings that qualify for custom translation.

The following explains the function of each menu option in the Internationalization Log window:

- **Note**: You can perform the functions of menu options using the toolbar.
- **File**: This option allows you to perform: Open, Export, Import, and Refresh
Displaying Custom Strings and System Strings

The following describes how Custom Strings and System Strings display in Administration mode and while defining Sheets and User Define Reports (UDRs).

The contents that appear in the Unifier application UI (also known as System Strings) cannot be modified by the Users. The System Strings are available in different languages, per user preferences.

Example
- Sign In and Terms and Condition pages, Menus, Alerts, and Errors

In contrast, the content of the material created by the Users (also known as Custom Strings) can be translated into different languages.

Example
- Business Process (BP) name, Data Element (DE) label, pull-down values, radio button, text in lines, navigation log names, and multi select values

System Strings are translated according to the user preferences, set in the User Preferences window.

Custom Strings are translated according to the specifications added to the source string, set in the XLIFF file.

When a combination of System and Custom strings are used (concatenation), for example, in a form, the System String portion is translated according to the user preferences, set in the User Preferences window, and the Custom String portion is translated according to the specifications added to the source string, set in the XLIFF file. As a result, it is possible to see an object having one field displayed in one language and another field displayed in another language.

In general, the translated Custom Strings cannot be displayed, or seen, while in the user is in Admin mode, except for:

- Translated Custom Strings for Attribute forms.
  Example
  If there is a Data Element (DE) called, "Building Name" in an Attribute form (Shell), and if the German translation of the DE exists, then the details page displays the German translation in Admin mode.

- Pages that are shared between the User mode and Admin mode.
  Example
  If translated Custom Strings are available, then the pages display the translated Custom Strings in Admin mode and are synchronized when switching to the User mode, as is the case with:
  - Code-based Configurable Manager- sheet templates
  - Record-based Configurable Manager - sheet templates
Administration Mode

Administration mode

When in the Administration mode, the contents that appear in the Unifier application UI (also known as System Strings) cannot be modified by the Users. The System Strings are available in different languages, per user preferences.

Example
Sign In and Terms and Condition pages, Menus, Alerts, and Errors

In contrast, the content of the material created by the Users (also known as Custom Strings) can be translated into different languages.

Example
Business Process (BP) name, Data Element (DE) label, pull-down values, radio button, text in lines, navigation log names, and multi select values

System Strings are translated according to the user preferences, set in the User Preferences window.

Custom Strings are translated according to the specifications added to the source string, set in the XLIFF file.

When a combination of System and Custom strings are used (concatenation), for example, in a form, the System String portion is translated according to the user preferences, set in the User Preferences window, and the Custom String portion is translated according to the specifications added to the source string, set in the XLIFF file. As a result, it is possible to see an object having one field displayed in one language and another field displayed in another language.

In general, the translated Custom Strings cannot be displayed, or seen, while in the user is in Admin mode, except for:

- Translated Custom Strings for Attribute forms.
  Example
  If there is a Data Element (DE) called, "Building Name" in an Attribute form (Shell), and if the German translation of the DE exists, then the details page displays the German translation in Admin mode.

- Pages that are shared between the User mode and Admin mode.
  Example
  If translated Custom Strings are available, then the pages display the translated Custom Strings in Admin mode and are synchronized when switching to the User mode, as is the case with:
  - Code-based Configurable Manager- sheet templates
  - Record-based Configurable Manager - sheet templates
  - Asset Class templates
Assigning Permissions

The Company Administrator assigns access permissions to the Internationalization node, and the permissions can be set for both Users and Groups.

To proceed with assigning permissions, go to Configuration node > Access Control (Admin mode), and select the Internationalization module to change the access settings. Alternatively, you can use the Permission tab of the User properties, also.

There are two types of permissions available for the Internationalization node:

- Configure
- View

Users who have Configure permission can translate the custom strings, and Users who have View permission can view the translated custom strings, only.

To assign View permission to a User, disable the following options in the Modify Translation String window:

1) Import, in the toolbar and menu.
2) Delete, in the toolbar and menu.
3) Columns, in the toolbar and menu.
4) When finished, click Apply and then OK.

Translating Methods

There are two methods available in Unifier for translating custom strings:

- User Interface
  Use this translation method when you add or modify a limited number of custom strings, only.
- Export/Import
  Use this translation method when you need to translate a large number of custom strings. This method is particularly useful to professional product-translator because the system provides a file format (.XLIFF) that streamlines the translation efforts (Export). After the translations are completed, the Company Administrator, or a User with appropriate permissions, can access the Internationalization node and import the translated file back into Unifier (Import). The translation is done for one language at a time.

To use the User Interface translation method

1) Go to the Internationalization node.
2) Select the custom string that you want to translate.
3) Click Open from the toolbar to open the Modify Translation String window. The Source Type and Source String fields are read only.
4) In the Note field enter a description explaining the context and usage of the custom string that you are about to translate.
5) Modify, or add to, the existing translations. You can enter multiple languages for the custom string.

6) When finished, click **Apply** and then **OK**.

### About Source Type and Source String

Each custom string is unique according to the custom string Source Type and Source String. The Source Type displays the Source String category. Data Structure, uDesigner, and Reports are some of the options under Source Type.

**Example**
A designer designs a Data Element (DE) with the label: Vendors. The Business Process is also name: Vendors. Since both the DE and BP constitute a design element, the Source Type is: uDesigner.

### Language codes

Use the following information to match the language settings:

- Chinese (Simplified): zh_CH
- Chinese (Traditional): zh_TW
- English: en
- French: fr
- German: de
- Italian: it
- Japanese: ja
- Korean: ko
- Portuguese (Brazil): pt_BR
- Russian: ru
- Spanish: es

### To use the Export/Import translation method

1) Go to the **Internationalization** node.
2) Select the custom string that you want to translate.
3) Click **Export** from the toolbar to open the Export Options window.
4) Select values for the following fields:
   - Source Language
     The current language of the custom string. (Example: English)
   - Target Language
     The language that the source custom string has to be translated into. You can select one language, only. (Example: German)
   - Source Type
     To allow you to filter the custom string for export base on a particular Source Type. The drop-down list contains values such as: Data Structure, Reports, etc. (Example: Business Process Setup)
   - Include Translated Strings
This is an optional parameter. By default, this option is selected.
- If selected, the custom strings (source strings) that are currently translated into the selected language will be exported, also.
- If deselected, only the custom strings (source strings) that are not translated into the selected language will be exported.

5) Click Export to open the File Download window. The file download operation follows the Unifier standard file download process.

The exported file is in ".XLIFF" format and the file name contains "Unifier" (Unifier+-+<Language Name>.XLIFF).

The number of characters allowed in the file name is based on Unifier standard. For supported version of the "XLIFF" file refer to the Primavera Unifier Tested Configurations in the Primavera Unifier Documentation Library.

The exported file contains the following information: ID, Source String, Target Language, and Note.

The Source String is the base for all translations, the Target Language is the language selected, and the Note is a placeholder, which stores notes for the translators. The source language attribute for the exported file originates from the Source language selection at the time of export.

6) Save the file in your local folder and open the file using a program such as Notepad or WordPad.

7) Open the saved XLIFF file, review the declaration information, and search for <source>. Example:

<source>Assets</source>

8) Enter a new line, include the target language information, and save the file. Example:

<target>Aktiva</target>

9) Change the value of "approved" to "yes." Example:

<trans-unit id="o8oRKk8ZYDv+BJodINqTIBpmz+fhygs3" approved="yes">
10) Proceed to import the file back to Unifier.

When the file is ready, use the Import option to bring the translated file back into Unifier.

1) Go to the Internationalization node.

2) Click Import from the toolbar to open the Unifier standard File Upload window.

3) Click Browse, and import the translated file (Unifier-,Language Name.XLIFF). Basic file replacement and override apply.

At this point, the translated custom strings map to the appropriate language settings and ready to be used.

---

**Note:** The Oracle Database column size must not exceed the storage size of 4000 bytes.

---

**Internationalizing Unifier Environments (Staging and Production)**

A translated custom string can be used in both Unifier Staging environment and in Unifier Production environment.
You can use the "XLIFF" file across the two environments using the export and import functions. 

**Workflow**

First, export the custom string (translated) using the Export option out of one environment. Then, using the Import option, import the exported custom string (translated) into the other environment.

---

**Notes:**

- The transfer of translated custom strings can be done one language at a time.
- If a custom string does not exist in the destination environment, then that custom string cannot be used; however, the custom string will be available in the Internationalization Log window.
- If you add a source string to your source type in the Staging environment, but this source string does not exist in the Production environment, upon exporting the XLIFF file to the Production environment, the source string will carry over.

---

**Unifier Mobile Application for iOS**

The Unifier Mobile Application for iOS is a mobile application built specifically for installation and use on mobile devices (smart phones). By using the Unifier Mobile Application iOS on your mobile device, you can:

- Act on the assigned tasks
- View the various tasks
- Create new business process records
- Work offline

**Note:** The Unifier Mobile Help for iOS, embedded in the application, assists you with using the application on your mobile device.
Unifier and Third-Party Applications

Unifier objects can be integrated with third-party applications by way of:

- **Web Services**
  Client and server applications that communicate over the World Wide Web’s (WWW) HyperText Transfer Protocol (HTTP) and provide a standard means for operation between software applications running on a variety of platforms and frameworks, using XML. For more information about Web Services integration, refer to the *Unifier Integration Interface Guide*.

- **Oracle Database Gateways**
  Addressing the needs of disparate data access and making it possible to integrate with any number of non-Oracle systems from an Oracle application. Oracle Database Gateways enable integration with data stores such as IBM DB2, Microsoft SQL Server, Excel and transaction managers like IBM CICS.

Unifier is integrated with the following enterprise applications via Primavera Gateway:

- **Oracle Primavera Analytics**
- **Oracle Primavera P6**
- **Oracle E-Business Suite** (also known as Applications/Apps or EB-Suite/EBS)
As shown below, once all the objects are created and linked to each other, data flows to Unifier (business flows/synchronizations) in this formation: Third-party/external application > Third-party/external Provider > Gateway > Unifier Provider > Unifier

**Unifier integration with other applications via Gateway**

**Provider must have a hard-coded (Java-code) link to the corresponding object in Gateway**

The following sections describe the process in details.

**In This Section**

- Unifier and Primavera Analytics ............................................................................. 679
- Unifier and Primavera P6 ...................................................................................... 709
- Unifier and Primavera Gateway ............................................................................. 716
- Unifier Provider, Unifier, and Gateway .................................................................. 725
Analytics provides an in-depth and comprehensive method for analyzing and evaluating:

- Project performance
- Project history
- Resource assignments
- Utilization
- Business processes
- Cash flows
- Cost sheets

For data exchange to happen between Unifier and Analytics, the Site/Company Administrator must load the Analytics module for the company.

The Company administrator can access the Analytics module by signing into Unifier and navigating to the System Modules node (Data Structure > Administration mode > System Modules).

Users can use the Analytics for data input and must have permission in order to be able to access the Analytics node. Permissions set in Unifier (Access Control) enable users to view the data in Oracle Business Intelligence (OBI) server. Users ability to access to OBI server is also set in Unifier.

**Analytics Subject Areas and Unifier Data**

Analytics subject areas use the following Unifier data:

- P6 Summary Sheets
- Shells
- Space Manager
- Vendors
- Business Process
  - Analytics uses this subject area to analyze cost and non-cost line items in business processes.
- Business Process History
  - Analytics uses this subject area to analyze weekly historical business process facts to better understand changes over time. Note that dimensional business process history is not supported.
- Cash Flow
  - Analytics uses this subject area to analyze WBS-level cash flows. You can map columns to predefined company-level cash flow curves. Five generic columns are included to support custom labels from Primavera Unifier. Any Cash Flow families will be designated in Primavera Unifier (based on Cash Flow 'Name' value).
- Cash Flow History
  - Analytics uses this subject area to analyze weekly historical cash flow facts to better understand changes over time. Note that dimensional cash flow history is not supported.
- Cost Sheet
Analytics uses this subject area to analyze cost sheets. You can map your data source to a predefined list of cost sheet columns. Ten generic columns are included to support custom labels from Primavera Unifier.

- **Cost Sheet History**
  Analytics uses this subject area to analyze weekly historical cost sheet facts to better understand changes over time.

  **Note:** Dimensional cost sheet history is not supported.

### Analytics and Dashboards

Each of the following dashboards has filter selections, or prompts, to help you narrow the results in the sections by the date, project, location, and so on. You can access the Analytics node in **Company Workspace > Administration** mode > **Analytics**.

- **Business Process**
  The Business Processes dashboard enables you to view business process data, including business process overview analyses, business process data by geographic location, and business process history analyses.

- **Cash Flow**
  The Cash Flow dashboard enables you to view cash flow data, including comparisons of actuals vs. forecast and forecast vs. baseline, cash flow data by geographic location, and cash flow history analyses.

- **Cost Sheet**
  The Cost Sheet dashboard enables you to view cost data, including a comparison of original and revised budget details, and cost history analyses.
In This Section

Analytics Node ...................................................................................................... 681
Analytics Log Properties ..................................................................................... 681
Analytics Log (Business Process) Setup .............................................................. 682
Analytics Log (Cash Flow) Setup ........................................................................... 687
Analytics Log (Cost Sheet) Setup ......................................................................... 688
Analytics Log (P6 Summary Sheets) ..................................................................... 691
Analytics Log (Shells) ........................................................................................... 692
Analytics Log (Space Manager) ............................................................................ 695
Analytics Log (Vendors) ....................................................................................... 701
Access Control Changes for Analytics Node in User Mode Access ....................... 703
Granting Permissions for Analytics ...................................................................... 703
Accessing the Unifier Analytics Dashboard in OBI ................................................ 704
Accessing Unifier from OBI server .......................................................................... 704
Action Links (from OBI to Unifier) ........................................................................ 705
Accessing Analytics from Unifier ........................................................................... 706
Publishing Unifier Data to Analytics ...................................................................... 706
Unifier Configurator and OBI Server ...................................................................... 707
Analytics Block ...................................................................................................... 707
Analytics Block and Shell Templates ...................................................................... 708

Analytics Node

The Analytics node is located under the Administration node, above the Custom Dashboard node. In Analytics node, you can select publication of Unifier data to Analytics server, map data, and set schedule for periodic publication of Unifier data into Analytics.

When you click the Analytics node, the log displays predefined set of Unifier modules such as:

- Business Processes
- Cash Flow
- Cost Sheet
- P6 Summary Sheets
- Shells
- Space Manager
- Vendors

Analytics Log Properties

The Analytics log has two columns which display the Name and the Last Modified Date of the records.

The Analytics log toolbar has the following options:

- Open
- Schedule
- Run History
The Open and Run History options can be accessed from the File menu. The Schedule option can accessed from the Edit menu.

**Analytics Log (Business Process) Setup**

You can set up Dashboards and Analyses, for Unifier Business Process, in Oracle Business Intelligence Enterprise (OBIE) analyses and select the Business Process data that you want to use for analyses.

When you open a Business Process in the Analytics node, you will see the Analytics - Business Process Setup window with the following tabs:

- Business Processes
- Data Mapping

**Business Processes tab**

*Select Business Processes for Analytics*

The Business Processes tab allows you to select the Business Process that you want to use in Analytics.

Use the Add or Remove buttons to add or remove the Business Processes for Analytics.

To add a new Business Process for use in Analytics:

1) Click **Add** to open the Select Business Processes for Analytics window that lists all the Company-level, Shell-level, and Project-level Business Processes, in alphabetical order.

   **Note:** This list includes Active and Inactive Business Processes.

2) Select one Business Process, or select as many as you need, and click **OK** to add the Business Process to the log.

   **Note:** After you added the Business Process, that Business Process will no longer be available in the Select Business Processes for Analytics list.

You can remove a Business Process that is published for Analytics. To remove a Business Process for use in Analytics, select the Business Process from the Select Business Processes for Analytics list and click **Remove**. You can delete multiple Business Processes from the list. You can add a removed Business Process for Analytics reporting. Click **Add** if you want to add a removed Business Process to the list.

If Company Administrator inactivates a Business Process that has been used for Analytics, then this Business Process continues to remain in the Business Processes tab. If you remove a Business Process from the Business Processes tab, data that exists in Analytics, for the removed Business process, remains as is; however, the new data will not be published.

**Data Mapping tab**

The Data Mapping tab allows you to map the predefined Analytic Business Process fields to a corresponding Unifier Data Element (DE) in the Business Process.

**Notes:**
The Data Mapping tab is available after you have added a Business Process, in the Business Processes tab, and clicked Apply or OK.

- The Data Mapping is done per DE and not per Business Process. All Business Processes added in the Business Processes list tab are included and you do not need to select a specific Business Process for mapping.
- The fields from both Upper and Detail forms can be mapped in the Data Mapping tab, and you can change mapping of the fields.
- The workflow data (Steps and tasks), related to any Workflow BP, is also sent to Analytics.

The Data Mapping tab displays the following information:

- Name
- Source
- Data Source
- User Defined Attributes
  - Name
  - Data Type
  - Source
  - Data Source
  - Label

**Note:** In addition to the system defined fields for Analytics, you can define additional custom fields for Analytics in the User Defined Attribute section.

**Name**

The Name column is pre-populated and displays the following names:

- Contract Type
- Reason
- Specification Section
- Vendor ID
- Quantity
- Spend Category
- Unit Cost
- Unit of Measure

The names above represent the fields used in OBI. These are read-only fields and you cannot modify them.

All the "Main Form" fields are listed first and are sorted alphabetically within the source.

All the "Line Item" fields are listed after the Main form fields and are sorted alphabetically within the source.

**Source**
The Source column displays the location of the Data Element (DE) seen in the Data Source. For Business Processes, the DEs can either be from the "Main Form" or the "Line Item."

**Data Source**

The Data Source column contains a consolidated list of all DEs for all of the selected Business Processes in the Business Processes tab. In addition:

- The list of values displayed upon clicking the Data Source drop-down will be those that have a matching data definition as the Name field. When you click the Data Source drop-down list contains a list of values that have a matching Data Definition (DD) as the Name field.
- The drop-down list, which requires the Upper form mapping, contains a consolidated list of all Upper form DEs. For example, if there are ten Upper forms from all the Business Processes, and each Upper form has 10 DEs, then the list of DEs displayed in the drop-down list will be a consolidated and unique list of DEs from all the Business Processes.
- The drop-down list, which requires the Detail form mapping, contains a consolidated list of all Detail form DEs. For example, if there are twenty Detail forms, and each Detail form has 10 DEs, then the list of DEs displayed in the drop-down list will be a consolidated and unique list of DEs from the Detail forms of all the Business Processes.
- The fields displayed in the Data Source drop-down list is a concatenation of DE Label and DE Name, and the DE Name is displayed within parenthesis. For example, `Department(contract_department)`

**User Defined Attributes**

The User Defined Attributes section of the Data Mapping tab lists the following columns:

- Name
- Data Type
- Source
- Data Source
- Label

The Label will be based on the selected DE label, but you can change it.

Use the Add, Modify, and Remove to add, modify, or remove user defined attributes.

To modify a user-defined attribute, click to select the attribute, click **Modify**, and modify the fields.

To remove a user-defined attribute, click to select the attribute, click **Remove**, and modify the fields.

To add a user-defined attribute, read the following information:

When you click **Add**, the Add User Defined Attribute window opens. This window allows you to select the following mandatory fields:

- Data Type
- Source
- Name
- Data Source
- Label

---

**Notes:**
A value for the mandatory Label field will be selected by the system.
- The Label field is populated based on the Data Element that you have selected from the Data Source drop-down list.
- The Label field is editable and required. You will receive an error message if you leave the Label field blank.
- If you notice that the value in the Label field has changed, it means that other fields have been updated at one point.
- Analytics displays the value, if the label is absent.
- Analytics displays the label, which has the Value/Label pair, in the case of Data Elements (DEs).

The Data Type that you select impacts the Name and the Data Source of the user-defined attribute. The **Data Type** field allows you to select the following attributes, only:

- **String** (default)
- **Date**
- **Numeric**

For example, if you select **String** as your Data Type, you can:

- Select from a predefined set of sources from Source drop-down list (Main Form or Line Item).
- Add up to 30 names (User Defined String Fields 1 - 30) as the Name.
- Select from a predefined set of data sources from Data Source drop-down list.
- The content of the Label filed will be selected by the system and according to your other selections.

**Analytics Dimension and Fact**

The Data Type that you select corresponds to the Analytics fields as follows:

- If the Data Type that you select is String/Date, then your selection corresponds to a Dimension object in Analytics.
- If the Data Type that you select is Numeric, then your selection corresponds to a Fact object in Analytics.

**Additional information**

- If the same DE exists in both Upper form and Detail form, then the DE is displayed for the Upper form fields, as well as the Line Item fields.
- If you map a DE for one field, you can map the same DE to another field. You can choose the DEs, per your Company business needs, when setting up the mapping.
- If you change the mapping of the fields, for the new records, then the next time the data is published to OBI, the values will be as per the updated fields. If you need to refresh, for all the records, then you need to click the checkbox option in the Schedule tab.
- If you delete a DE mapped to an Analytic field, then the Data Source field displays the DE name, only.
- If there are any un-mapped fields in the Data Mapping tab, the un-mapped fields appear in the DE list, based on the updated design.
If you delete a Business Process, and click Apply, then the Data Source field displays the DE name, only.

Unifier Analytics supports custom attributes for Business Processes for various Facts and Dimensions as described in the following table:

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Source</th>
<th>Allowed User Defined Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Main Form</td>
<td>60</td>
</tr>
<tr>
<td>String</td>
<td>Line Items</td>
<td>40</td>
</tr>
<tr>
<td>Date</td>
<td>Main Form</td>
<td>40</td>
</tr>
<tr>
<td>Date</td>
<td>Line Items</td>
<td>20</td>
</tr>
<tr>
<td>Numeric</td>
<td>Main Form</td>
<td>40</td>
</tr>
<tr>
<td>Numeric</td>
<td>Line Items</td>
<td>20</td>
</tr>
</tbody>
</table>

Summary Payment Application (SPA) SOV type BPs

You can perform data reporting in Analytics for Base Commit, Change Commit, and Payment Application Business Processes of SPA SOV type. The system sends the following Cost allocation Line Item details to Analytics:

- Cost Code
- Cost Name
- Short Description
- Quantity
- Unit Price
- Amount

If you need to transfer data from any field (at the Summary level) to Analytics, then you must map the field to a User Defined Field in Line Items of the Business Process. The system sends the mapped field to Analytics as a part of Cost allocation Line Item.

**Note:** Users can map any field that exist in the Detail form.

The values of the fields in the existing Cost allocation Line Items are retained for the fields that are common to both the Summary and Cost allocation Line Items. The following explains the details:

- **Cost Code**
  The value of the field in the Cost allocation Line Item is retained. The WBS Picker field does not exist in the Detail Form design.

- **Cost Name**
  The value of the field in the Cost allocation Line Item is retained. The bi_item field does not exist in the Detail Form design.

- **Short Description**
  The value of the field in the Cost allocation Line Item is retained.

- **Quantity**
The value of the field in the Cost allocation Line Item is retained.

- **Unit Price**
  The value of the field in the Cost allocation Line Item is retained. The Unit price is auto-populated from the value of the field in the Detail Form and is a read-only field in the Cost allocation Line Item. The value of the field in the Cost allocation Line Item will match the value of the field in the Detail Form.

- **Amount**
  The value of the field in the Cost allocation Line Item is retained.

---

**Analytics Log (Cash Flow) Setup**

You can set up Dashboards and Analyses, for Unifier Cash Flow data, in Oracle Business Intelligence Enterprise (OBIE) analyses and:

- Select the Cash Flow names that you want to use for analyses.
- Set up the data for the fields related to Cash Flow in the Cash Flow record.

When you open a Cash Flow record in the Analytics node, you will see the Cash Flow Setup window that contains the Cash Flow names defined in Shells. In this window, you can add a Cash Flow record and click Apply to see the Data Mapping tab.

In addition to the system-generated Cash Flow Curves, you can add additional user-defined Cash Flow Curves (total of 10). The User Defined Curves section, in Data Mapping tab of the Cash Flow Setup, displays the additional 5 Cash Flow Curves (User Defined Curves from 6 to 10).

**Cash Flow tab**

Use the Cash Flow tab to select the Cash Flow names that you want to use in Analytics. Once selected, you can use Add to add the name or Remove to remove a Cash Flow.

To add a new Cash Flow:

1) In the Analytics - Cash Flow Setup window, Cash Flow tab, click Add to open the Cash Flow window, Select Cash Flow for Analytics.

   **Note:** This list includes the available Cash Flow items, from all WBS Shells, all Detail Level WBS, and Summary WBS, in alphabetical order.

2) Select one Cash Flow, or select as many as you need, and click OK to add the Cash Flow to the log.

   **Note:** After you add a Cash Flow, that Cash Flow will no longer be available in the Select Cash Flow for Analytics list.

You can remove a Cash Flow item that is published for Analytics. To remove a Cash Flow item for use in Analytics, select the Cash Flow item from the Select Cash Flow item for Analytics list and click Remove. You can delete multiple Cash Flow items from the list. You can add a removed Cash Flow item for Analytics reporting. Click Add if you want to add a removed Cash Flow item to the list.
Data Mapping tab (Cash Flow)

The Data Mapping tab allows you to map the predefined Analytic Cash Flow fields to a corresponding Unifier Cash Flow Curve type.

**Note:** The Data Mapping tab is available after you have added a Cash Flow item, in the Cash Flow tab, and clicked Apply or OK.

The Data Mapping tab displays the following information:

- **Name**: Predefined and represents the fields used in OBI.
  - The names are grouped logically and sorted based on Initial Baseline, Current Baseline, Actuals, Forecast, and User Defined Curves (1 through 10).
  - The drop-down list for the Initial Baseline and Current Baseline includes the items that are based on the Baseline Cash Flow curve type, defined under the Cash Flow data sources (Cashflow Datasources window) in the Standard & Libraries.
  - The drop-down list for the Actuals includes the items that are based on the Spends curve type.
  - The drop-down list for the Forecast includes the items that are based on the Forecast curve type.
  - The drop-down list for the User Defined Curves (1 through 10) includes all the Cash Flow data sources. The items listed are based on the Cash Flow curve type and sorted in alphabetical order.
- **Data Source**: The Cash Flow data sources defined under the Cash Flow > Data Sources node of the Standards & Libraries.
  - The fields displayed in the Data Source drop-down list is a concatenation of the Cash Flow data source name and Cash Flow curve type.

The Analytic field name can be the same as the Data Source name. For example, you can map a User Defined Curve to data source named, "Initial Baseline."

The following is a list of fields that need mapping for Cash Flow:

- Initial Baseline
- Current Baseline
- Actuals (Spends)
- Forecast
- User Defined Curve 1
- ...
- User Defined Curve 10

**Note:** Cash Flow Derive curve is not supported.

Analytics Log (Cost Sheet) Setup

You can set up Dashboards and Analyses, for Unifier Cost Sheet data, in Oracle Business Intelligence Enterprise (OBIE) analyses and select the Cost Sheet column data that you want to use for analyses.
When you open a Cost Sheet record in the Analytics node, you see the Analytics - Cost Sheet Setup window with one tab:

Data Mapping

The Data Mapping tab is divided in two sections:

- System defined columns
- User Defined Columns

The system defined columns of the Data Mapping tab allows you to map the Cost sheet Analytic fields to a corresponding Cost Sheet Data Source defined in Unifier.

In addition to the system-generated Cost Sheet columns, you can add additional user-defined columns (total of 20). The User Defined Columns section, in Data Mapping tab of the Cost Sheet Setup, displays the additional 10 columns (User Defined Columns from 11 to 20).

The top section of the Data Mapping tab displays all the system defined fields in the following columns:

- Name
- Data Source

**Name**

Lists a series of predefined fields which correspond to the fields used in OBI.

---

**Note:** Since the fields under Name are grouped logically, the order displayed are according to the list of fields that need mapping for Cost Sheet.

---

This is a list of predefined fields:

- Estimate
- Original Budget
- Pending Budget Revisions
- Approved Budget Revisions
- Revised Budget
- Contracts
- Purchase Orders
- Original Commitments
- Forecast
- Pending Change Orders
- Pending PO Amendments
- Pending Commitment Changes
- Approved Change Orders
- Approved PO Amendments
- Approved Commitment Changes
- Revised Commitments
- Pending Payment Applications
- Pending Invoices
Unifier Administration Guide

- Pending Spends
- Approved Payment Applications
- Approved Invoices
- Approved Spends
- Actuals Received
- Journal Entries
- Risks & Issues
- Forecast Adjustments
- Budget Variance
- Remaining Budget
- Budget Percent
- Commitment Percent

**Data Source**

Lists the corresponding data source to each field that is listed in the Name column. The values are:

- Divided into two sources (Single Sources and the Logical Sources).
- Sorted in alphabetic order.
- Exist in the Cost Sheet for all WBS type Shells.

The bottom section of the Analytics - Cost Sheet Setup window includes the User Defined Columns presented in the following columns:

- Name
- Data Source
- Label

**Name**

This is a list of predefined columns:

- User Defined Column 1
- ...
- User Defined Column 20

The Analytic field name can be the same as the Data Source name. For example, you can map a User Defined Curve to data source named, "Initial Baseline."

**Data Source**

- The P6 data sources are included under the Single Sources, and the element is included within the parenthesis of the P6 Data Source. For example, Current Baseline (Planned Cost).
- In addition to the predefined list displayed, you can add up to 10 additional mappings for the Cost Sheet data sources.
- You can pick the same data source for multiple fields.

**Label**

- Labels are required for User Defined Columns. A red-color asterisk (*/star symbol) appears for the columns that have been mapped to a data source.
Unifier Administration Mode

**Note:** Asterisk (*/star symbol) does not appear for a column that has not been mapped to a data source.

- For existing mappings of user-defined Cost Sheet columns, the labels are populated based on the data source name.
- Labels support non-ISO characters (UTF-8 characters).
- If there are no labels, then the data source names will be sent to OBIEE.

**Note:** Custom String translation is not applied.

- When you select a data source for the first time, the label is populated based on the data source name. You can modify the label according to your business need.
- The maximum characters allowed in the label field is 50, same as the Cost Sheet Data Source Name.

**Note:** The system does not perform Label Uniqueness test.

---

**Analytics Log (P6 Summary Sheets)**

You can set up Dashboards and Analyses, for P6 Summary Sheets, in Oracle Business Intelligence Enterprise (OBIE) analyses and select the P6 Summary Sheets data that you want to use for analyses.

When you open P6 Summary Sheets in the Analytics node, you will see the Analytics – P6 Summary Sheets Setup window with the following tab: P6 Data Sources.

**P6 Data Sources tab**

The P6 Data Sources tab allows you to select the P6 Data Sources that you want to use in Analytics (P6 Data Sources for Analytics).

Use the Add or Remove buttons to add or remove the P6 Data Sources that you want to use in Analytics.

To add a P6 Data Sources for Analytics:

Click **Add** to open the Select P6 Data Sources for Analytics window and select a P6 data source for Analytics. The following data sources are available to select:

**Note:** The P6 Data Sources that need to send data to OBIEE are set up here.

- Current Schedule
- Customer Sign-Off Baseline
- Initial Planning Baseline
- Management Sign-Off Baseline
- New P6 Data Source for Analytics Testing
- P6 Testing datasource

These are all the published P6 data sources defined under Standards & Libraries.
When finished, click **Apply** and then **OK**.

You can select more than one data source. To select more than one data source, click one source, click **OK**, and click to add additional data sources.

**Note**: Once you add a data source, that data source will not be shown in the Select P6 Data Sources for Analytics window.

### Additional information

- You can use the P6 Summary Sheets that are included in the following types of Unifier WBS Shells for Analytics:
  - Duration
  - Resource loaded
  - Cost loaded

  **Note**: The P6 Summary Sheets for the above data sources will send data to Analytics.

- If fields overlap between the WBS Shells and the existing P6 Summary Sheets, then the system-defined fields in the P6 Summary Sheets will be used.
  
  Example:
  
  Planned Start and Planned Finish are mapped fields in Unifier WBS Shells; however, these fields will be replaced by the system-defined fields in the P6 Summary Sheets.

- Data analysis can be performed on P6-Unifier integrated data. Since there is no user interface (UI) component for the P6 Summary Sheets in Unifier, when Unifier sends data to OBIEE, the details of the P6 Summary Sheets of the selected P6 data source is sent to Analytics. In Analytics, views are created based on the details of the P6 Summary Sheets and the user can see the daily-level data.

### Analytics Log (Shells)

You can set up Dashboards and Analyses, for Unifier Shells, in Oracle Business Intelligence Enterprise (OBIE) analyses and select the Shell data that you want to use for analyses.

When you open a Shell in the Analytics node, you will see the Analytics - Shells Setup window with one tab:

- **Data Mapping**.

The Data Mapping tab is divided in two sections:

- System defined and User defined attributes
- **User Defined Columns**

The system defined columns of the Data Mapping tab allows you to map the Shells (called "Projects" in Analytics) Analytic fields to a corresponding Shell attribute Data Element (DE) defined in Unifier.

The top section of the Data Mapping tab displays all the system defined fields in the following columns:
Name

Lists a series of predefined, read-only fields, which represent the fields used in OBI.

- Shell Phase
- Anticipated Start
- Anticipated Finish
- Start
- Finish
- Forecast Start Date
- Forecast Finish Date
- Planned Start
- Planned Finish
- Scheduled Finish
- Current Budget
- Original Budget
- Proposed Budget
- Address 1
- Address 2
- City
- State
- State Code
- Country
- Country Code
- Postal code

Data Source

- Lists all of the Data Elements (DEs), in the Shell attributes, with matching Data Definitions (DDs).
- The DEs are listed in alphabetical order.
- The values listed in the drop-down list have a matching DD as in the Name field and includes a consolidated list of all the DEs across all Shell attribute forms. For example, when you select the "Project Start Date," the drop-down list will include all the date fields in all of the Shell attribute forms.

The bottom section of the Analytics - Shells Setup window includes the User Defined attributes/fields presented in the following columns:

- Name
- Data Type
- Data Source
- Label

Use the Add, Modify, and Remove to add, modify, or remove user defined attributes.
To modify a user-defined attribute, click to select the attribute, click **Modify**, and modify the fields.

To remove a user-defined attribute, click to select the attribute, click **Remove**, and modify the fields.

**Note:** If you remove a user-defined attribute, the DE name will remain in the list for future use.

To add a user-defined attribute, read the following information:

When you click **Add**, the Add User Defined Attribute window opens. This window allows you to select the following mandatory fields:

- Data Type
- Name
- Data Source
- Label

**Notes:**

- The Label field is populated based on the Data Element that you have selected from the Data Source drop-down list.
- The Label field is editable and required. You will receive an error message if you leave the Label field blank.
- If you notice that the value in the Label field has changed, it means that other fields have been updated at one point.

The Data Type that you select impacts the Name and the Data Source of the user-defined attribute. The **Data Type** field allows you to select the following attributes, only:

- String (default)
- Date
- Numeric

For example, if you select **String** as your Data Type, you can:

- Add up to 20 names (User Defined String Fields 1 - 20) as the Name.
- Select from a predefined set of data sources from Data Source drop-down list.
- The content of the Label field will be selected by the system and according to your other selections.

**Dimension and Fact**

The Data Type that you select corresponds to the Analytics fields as follows:

- If the Data Type that you select is String/Date, then your selection corresponds to a Dimension object in Analytics.
- If the Data Type that you select is Numeric, then your selection corresponds to a Fact object in Analytics.
**Analytics Log (Space Manager)**

You can set up Dashboards and Analyses, for Space Manager, in Oracle Business Intelligence Enterprise (OBIE) analyses and select the Space Manager data that you want to use for analyses.

When you open the **Space Manager** in the **Analytics** node, you will see the **Analytics - Space Manager Setup** window with one tab: **Space Types**.

The **Space Types** tab contains a list of space type names under the **Space Types for Analysis** section. You can add and remove a Space type using the **Add** and **Remove** buttons on this tab and below the **Space Types for Analysis** section. When finished, click **Apply** and **Ok** to complete the operation.

**Adding Space Types**

To add new Space Types click **Add** to open the **Select Space Types for Analytics** window. If available, a list of available Space Types that have been deployed in the Company appear in the window, in alphabetical order. The list contains all Active and Inactive Space Types. Click to select one, or more, Space Types and then click **OK** to add the selected Space Types to the Space Types log. Once added:

- The selected Space Types do not appear in the Select Space Types for Analytics window.
- The Data Mapping - Space Types tab appear.

Click **Apply** to complete the adding operation.

**Removing Space Types**

You can remove the Space Types that have been published for Analytics. To remove the Space Types, click to select one, or more, Space Types and click **Remove**. Once removed:

- The selected Space Types do not appear in the Select Space Types for Analytics window.

If you want to add removed Space Types, read the instructions in the Adding Space Types topic.

**Working with Space Types**

If you (Company Administrator) inactivate a space type, and the inactivated space type was used for Analytics, then the inactivated space type remains in the Space Types tab.

If a published space type is removed from the Space Types tab, the data that exists in Analytics (for the removed space type) remains as is.

**Note:** Added new data will not be published.

If an unpublished space type is removed from the Space Types tab, then no information related to the space type, and Level, is sent to Analytics.

The following sections explain the following tabs that appear after you add Space Types:

- Data Mapping - Space Types tab
- Data Mapping - Level tab
Data Mapping - Space Types Tab

The Data Mapping - Space Types tab appears after you add Space Types, and it enables you to add custom fields, from various Space Types, to use in Analytics. You can use this tab to map the Analytics field to the corresponding Space Types field. The Data Mapping - Space Types tab contains a list of user-defined attributes under the User Defined Attributes section. The User Defined Attributes section is a log that lists the following fields for each user-defined attributes:

- Name
- Data Type
- Data Source
- Label

All the fields mentioned above are read-only fields. You can add, modify, and remove user-defined attributes using the Add, Modify and Remove buttons on this tab.

Adding new user-defined fields

To add new user-defined fields, click Add to open the Add User Defined Attribute window and enter values in the following required fields:

- Data Type
- Name
- Data Source
- Label

About Data Type

The values for Data Type field are:

- String
- Date
- Numeric

When you select a Data Type, you set the value of the of the field as either a Dimension or a Fact. If you select the Data Type as String, or Timestamp, then the field will be a Dimension object in Analytics. If you select the Data Type as Numeric, then the field will be a Fact object in Analytics.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Analytics</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Dimension</td>
</tr>
<tr>
<td>Date</td>
<td>Dimension</td>
</tr>
<tr>
<td>Numeric</td>
<td>Fact</td>
</tr>
</tbody>
</table>

Adding new user-defined fields (custom fields) for Data Type: String

If you select the Data Type as String, then up to 20 String type Data Elements can be added from the Space Detail Form, as user-defined attributes.
To add new user-defined fields (custom fields) for **String** Data Type, click **Add** to open the **User Defined Attribute** window and enter values in the following required fields:

**Name**
The **Name** drop-down list contains values from "User Defined String Field 1" to "User Defined String Field 20." If a name has already been selected, then the name is not listed in the Name drop-down list.

For example, if the "Department" field has been added as a "User Defined String Field 1," then the Name drop-down list does not display "User Defined String Field 1." If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

**Data Source**
The **Data Source** drop-down list contains a list of Data Elements from the Space Detail Form.

If you select the Data Type as **String**, the Data Elements in the Data Source drop-down list are:

- Strings and Integer Pull Downs
- Integer and String Radio Buttons
- Check Boxes
- Test Data Elements

There are no Pickers listed/available. The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, **Project Type(prjt_type)**. If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

**Label**
The **Label** field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The maximum allowed length is similar to Data Element label. The system does not perform a label uniqueness verification.

**Adding new user-defined fields (custom fields) for Data Type: Date**

If you select the Data Type as **Date**, then up to 10 "Date" Data Elements can be added from the Space Detail Form, as user-defined attributes.

To add new user-defined fields (custom fields) for **Date** Data Type, click **Add** to open the **User Defined Attribute** window and enter values in the following required fields:

**Name**
The **Name** drop-down list contains values from "User Defined Date Field 1" to "User Defined Date Field 20." If a name has already been selected, then the name is not listed in the Name drop-down list. For example, if the "Project Commission Date" field has been added as a "User Defined Date Field 1," then the Name drop-down list does not display "User Defined Date Field 1." If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

**Data Source**
If you select the Data Type as **Date**, the Data Elements in the Data Source drop-down list are:

- Date
Date only Picker

The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, Project Archive Date(prjt_arc_date). If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

Label

The Label field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The system does not perform a label uniqueness verification.

Adding new user-defined fields (custom fields) for Data Type: Numeric

If you select the Data Type as Numeric, then up to 40 numeric data elements can be added from the Level Detail Form, as user-defined attributes.

To add new user-defined fields (custom fields) for Numeric Data Type, click Add to open the User Defined Attribute window and enter values in the following required fields:

Name

The Name drop-down list contains values from "User Defined Date Field 1" to "User Defined Date Field 40." If a name has already been selected, then the name is not listed in the Name drop-down list. For example, if the "Total Count" field has been added as a "User Defined Date Field 1," then the Name drop-down list does not display "User Defined Date Field 1." If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

Data Source

If you select the Data Type as Numeric, the Data Elements in the Data Source drop-down list are the Data Elements found on the Space Detail Forms and are:

- Integer
- Currency
- Decimal Amount

There are no Integer Pull Downs, Integer Radio Buttons, and Integer Check Boxes. The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, Contract Amount(con_amt). If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

Label

The Label field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The maximum allowed length is similar to Data Element label. The system does not perform a label uniqueness verification.

Data Mapping - Level Tab

The Data Mapping - Level tab appears after you add Space Types, and it enables you to add custom level/floor fields, from various Levels, to use in Analytics. You can use this tab to map the Analytics field to the corresponding Levels field.
The Data Mapping - Level tab contains a list of user-defined attributes under the User Defined Attributes section. The User Defined Attributes section is a log that lists the following fields for each user-defined attributes:

- Name
- Data Type
- Data Source
- Label

All the fields mentioned above are read-only fields. You can add, modify, and remove user-defined attributes using the Add, Modify and Remove buttons on this tab.

Adding new user-defined fields

To add new user-defined fields, click Add to open the Add User Defined Attribute window and enter values in the following required fields:

- Data Type
- Name
- Data Source
- Label

About Data Type

The values for Data Type field are:

- String
- Date
- Numeric

When you select a Data Type, you set the value of the field as either a Dimension or a Fact. If you select the Data Type as String, or Timestamp, then the field will be a Dimension object in Analytics. If you select the Data Type as Numeric, then the field will be a Fact object in Analytics.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Analytics</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Dimension</td>
</tr>
<tr>
<td>Date</td>
<td>Dimension</td>
</tr>
<tr>
<td>Numeric</td>
<td>Fact</td>
</tr>
</tbody>
</table>

Adding new user-defined fields (custom fields) for Data Type: String

If you select the Data Type as String, then up to 20 String type Data Elements can be added from the Level Detail Form, as user-defined attributes.

To add new user-defined fields (custom fields) for String Data Type, click Add to open the User Defined Attribute window and enter values in the following required fields:

Name
The **Name** drop-down list contains values from "User Defined String Field 1" to "User Defined String Field 15." If a name has already been selected, then the name is not listed in the Name drop-down list. For example, if the "Department" field has been added as a "User Defined String Field 1," then the Name drop-down list does not display "User Defined String Field 1." If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

**Data Source**

The **Data Source** drop-down list contains a list of Data Elements from the *Level Detail Form*. If you select the Data Type as **String**, the Data Elements in the Data Source drop-down list are:

- Strings and Integer Pull Downs
- Integer and String Radio Buttons
- Check Boxes
- Test Data Elements

There are no Pickers listed/available. The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, `Project Type (prjt_type)`. If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

**Label**

The **Label** field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The maximum allowed length is similar to Data Element label. The system does not perform a label uniqueness verification.

**Adding new user-defined fields (custom fields) for Data Type: Date**

If you select the Data Type as **Date**, then up to 10 "Date" Data Elements can be added from the *Level Detail Form*, as user-defined attributes.

To add new user-defined fields (custom fields) for **Date** Data Type, click **Add** to open the **User Defined Attribute** window and enter values in the following required fields:

**Name**

The **Name** drop-down list contains values from "User Defined Date Field 1" to "User Defined Date Field 10." If a name has already been selected, then the name is not listed in the Name drop-down list. For example, if the "Project Commission Date" field has been added as a "User Defined Date Field 1," then the Name drop-down list does not display "User Defined Date Field 1." If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

**Data Source**

The **Data Source** drop-down list contains a list of Data Elements from the *Level Detail Form*. If you select the Data Type as **Date**, the the Data Elements in the Data Source drop-down list are:

- Date
- Date only Picker
The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, Project Archive Date(prjt_arc_date). If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

**Label**

The **Label** field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The system does not perform a label uniqueness verification.

**Adding new user-defined fields (custom fields) for Data Type: Numeric**

If you select the Data Type as **Numeric**, then up to 30 numeric data elements can be added from the Space Detail Form, as user-defined attributes.

To add new user-defined fields (custom fields) for **Numeric** Data Type, click **Add** to open the User Defined Attribute window and enter values in the following required fields:

**Name**

The **Name** drop-down list contains values from “User Defined Date Field 1” to “User Defined Date Field 30.” If a name has already been selected, then the name is not listed in the Name drop-down list. For example, if the “# of Spaces” field has been added as a “User Defined Date Field 1,” then the Name drop-down list does not display “User Defined Date Field 1.” If a previously added field has been deleted, then that Name is displayed in the Name drop-down list.

**Data Source**

If you select the Data Type as **Numeric**, the the Data Elements in the Data Source drop-down list are the Data Elements found on the Level Detail Forms and are:

- Integer
- Currency
- Decimal Amount

There are no Integer Pull Downs, Integer Radio Buttons, and Integer Check Boxes. The Data Source field displays a series of interconnected Data Element names and Data Element labels in the following format: DE Label(DE name). For example, Contract Amount(con_amt). If a previously added Data Element is deleted from the Deployed design, then the Data Element name is displayed, only.

**Label**

The **Label** field is populated based on the Data Element that you select in the Data Source. You can modify the value of this field with non-ISO characters (UTF-8), in order to support internationalization, only. The maximum allowed length is similar to Data Element label. The system does not perform a label uniqueness verification.

**Analytics Log (Vendors)**

You can set up Dashboards and Analyses, for Unifier Vendors data, in Oracle Business Intelligence Enterprise (OBIE) analyses.
When you open a Vendors record in the Analytics node, you will see the Analytics - Vendors Setup window that contains the following tabs, after you add a Vendor record and click Apply:

- Vendors tab
- Data Mapping tab

**Vendors tab**

*Note:* You need to first select the Business Processes that you want to set as Vendor Business Processes for use in Analytics.

In the Vendors tab, click **Add** to open the Select a Business Process as Vendor for Analytics window. The list of Business Processes in this window is in alphabetic order.

*Note:* Only one Business Process can be marked as Vendor, so the Add option is disabled after your selection.

Select a Business Process (Company and Shell level - Active and Inactive), then click **OK**. You can select one Business Process, only.

You can remove a Vendor Business Process by selecting the item and clicking Remove.

Use the Vendors tab to select the Vendors names that you want to use in Analytics. Once selected, you can use Add to add the name or Remove to remove a Vendors.

You can remove a Vendor Business Process that is published for Analytics. To remove an item for use in Analytics, select the item from the list in the Select a Business Process as Vendor for Analytics window and click **Remove**. You can add a removed item for Analytics reporting. Click **Add** if you want to add a removed item to the list.

If the Company Administrator inactivates a Business Process marked as Vendor, and if the item is used for Analytics, then this Vendor Business Process remains in the Vendors tab.

If a Vendor is removed from the Vendors tab, data that exists in Analytics (for the removed Vendor Business Process) remains as is; however, the new data will not be published.

**Data Mapping tab**

The Data Mapping tab allows you to map the predefined Analytic Vendor related fields to a corresponding Unifier Data Element (DE) in the Business Process. As mentioned earlier, this tab is available after you have added a Business Process in the Vendors tab and clicked Apply or OK.

In the Data Mapping tab, the following columns, or fields, are present:

- Name
- Source
- Data Source

**Name**

Pre-populated and represents the fields used in OBI. These are read-only fields and you cannot modify them.

**Source**
Displays the location of the Data Element (DE) seen in the Data Source. The DEs for Vendor mapping are the Upper form DEs.

**Data Source**

Allows you to select from a list of all Upper form DEs, for the selected Vendor Business Process in the Vendors tab. The list is filtered based on the Data Definition (DD) match. You can change the mapping of the fields.

The following is a list of fields that need mapping for Vendors:
- Vendor ID
- Name
- Type

The fields displayed in the Data Source drop-down list is a concatenation of DE Label and DE Name, and the DE Name is displayed within parenthesis. For example, Department(contract_department)

**Rules for Data Mapping**

- If the Analytic field is of a String type, then all pull-downs (Integer and String), Radio Boxes (Integer and String), check boxes, and text DEs are displayed. No pickers will be seen.
- If the Analytic field is of a Pull-down type, then the list of DEs displayed in the Data Source drop-down list are filtered and only the DEs of Pull-down type are displayed. This list includes both Integer and String Pull-downs.
- If the Analytic field is of a Numeric type, then the list of values displayed is a consolidated list of all numeric data elements, which include DEs of type Integer Amount, Currency Amount, and Decimal Amount. No integer pull-downs or Radio boxes will be seen.

**Access Control Changes for Analytics Node in User Mode Access**

**User Mode Access > Company Workspace**

The root node "Non-navigational Nodes" (under Company Workspace section of the Access Control, contains the Analytics node, and the administrator can assign permissions to the root node "Non-navigational Nodes." The View option is the only permission option available for Analytics node.

When users have view permissions at Company Workspace level, the users can see the executive dashboard tab and the “Analytics” link, after opening the tab.

**User Mode Access > Shells/Projects (Standard)**

The Analytics node is available under the "Non-navigational Nodes." The administrator can assign permissions to both the users and groups.

**Granting Permissions for Analytics**

**To grant permission for Analytics**

1) Go to the **Company Workspace** tab and switch to Admin mode.
2) Click **Access Control** in the left Navigator.
3) On the right pane, select **Administration Mode Access > Analytics**. The Permission Settings window opens. Here you can add, modify, or remove permission settings.

4) Click **Add** to open another window called Permission Settings opens.

5) Click **Add Users/Groups**. The Users/Groups window opens.

6) Select the intended users and/or groups and click **Add**.

7) Click **OK** to return to the Permission Settings window.

8) Select the users or groups in Select Users/Groups, located in the upper portion of the window, and select the appropriate level of access for the user or group in Permissions Settings, located in the lower portion of the window.

   **View**: This option allows users and groups to open and view the contents in Analytics node. Users with View permission cannot make any changes.

   **Modify**: This option allows users and groups to configure and modify the data required for Analytics. This setting includes View permission. Users are also able to set schedule for publishing data, for various areas in Unifier, to the Oracle Business Intelligence (OBI) server.

9) Click **OK**.

Click **Apply** to save changes and keep the window open, or click **OK** to save changes and close the window.

### Accessing the Unifier Analytics Dashboard in OBI

Users can access the Unifier Analytics dashboard designed in Oracle Business Intelligence (OBI) platform by using the link provided in Unifier.

**With Single Sign On (SSO)**

When accessing the Unifier Analytics dashboard with **Single Sign On (SSO) enabled**, you navigate from Unifier to the OBI, directly.

If a user goes to the OBI landing page, the accessibility of the landing page, dashboards, analyses, and so forth are controlled by the settings for the user that is logged in OBI.

If a Shell analytics user cannot go to the corresponding dashboard, the system will take the user to the default landing page set in OBI.

**Without Single Sign On (SSO)**

To access the Unifier Analytics dashboard without **Single Sign On (SSO) enabled**, you need to login to the OBI server.

### Accessing Unifier from OBI server

You can access Unifier from OBI server by way of Action Links.

Action Links, within OBIEE 11g, are a way of providing easy and seamless navigation from an Analysis to other local content (such as other Analyses or Dashboards) or external content (such as websites). The Action Links in Analytics allows you to view the data in Unifier.
**Action Links (from OBI to Unifier)**

The following is a list of available Action Links:

- Link to Cost Sheet log
- Link to Cash Flow log
- Link to BP Record
- Link to Shell landing page

**With Single Sign On (SSO)**

When accessing from OBI server *with Single Sign On (SSO) enabled*, you must have appropriate permission to access a particular page, and pertinent navigation, in Unifier. For example, if you want to access a Cost Sheet using the Cost Sheet Action Link, you must have permission to access that particular Cost Sheet, for the selected project (Project Cost Sheet).

If you do not have permission to a Unifier page that is linked to an Action Link, then the system will take you to the default landing page.

**Without Single Sign On (SSO)**

To access the Unifier Analytics dashboard *without Single Sign On (SSO) enabled*, when using an Action Link, you need to login to the OBI server and enter your credentials.

If a Unifier session is already in progress and you click an Action Link, the system will take you to the Unifier page, directly.

Users must have appropriate permission to access a particular page, and pertinent navigation, in Unifier. For example, if you want to access a Cost Sheet using the Cost Sheet Action Link, you must have permission to access that particular Cost Sheet, for the selected project (Project Cost Sheet).

If you do not have permission to a Unifier page that is linked to an Action Link, then the system will take you to the default landing page.

**About Link to BP Record**

With Single Sign On (SSO) enabled, if you click the Link to BP Record (Action Link), you can lunch Unifier application and open the Business Process Record, provided that you have the appropriate permissions to the Business Process record. If you do not have the required permissions to the Business Process record, then the system will take you to the Business Process Log.

Without Single Sign On (SSO) enabled, if you click the Link to BP Record (Action Link), the system displays the Sign In page or Unifier landing page (depending on whether the session is expired or not). If you click the Link to BP Record (Action Link), you can lunch Unifier application and open the Business Process Record, provided that you have the appropriate permissions to the Business Process record. If you do not have the required permissions to the Business Process record, then the system will take you to the Business Process Log.
Accessing Analytics from Unifier

You can access Analytics from the following places in Unifier:

Company level Dashboards

The company level access is typically provided to executive level users who want to view the Analytics dashboards at a Company level. These users will be able to access data from all Shells.

Dashboards

You can access the executive Analytics Dashboards by clicking the Analytic Dashboards button. This button will be in place of the existing Custom Dashboard tab. Clicking the Analytic Dashboards button, on the top left-hand corner of the screen, allows you to open the Analytic Dashboards in OBIE.

The Analytic Dashboards button can be seen by users who have access to Company level Analytics (Company Workspace > Non Navigational Nodes: View access).

When a user has access to both Custom dashboards (Small Web Format (SWF) Dashboard) and Analytics, the existing Custom Dashboards tab remains as is; however, an additional button called “Analytics Dashboards…” will be seen in the Dashboards page.

When a user has access to Custom SWF Dashboards, only, there are no changes to the existing User Interface (UI).

When a user has no access to the Custom SWF Dashboards or Analytics, the Analytic Dashboards button will be hidden.

Shell-level Dashboards

The Shell members can configure Custom Shell dashboards.

In the Source Details section of the Edit Dashboard window, the Analytics option for the Block Type supports Analytics for Shell details.

Any user with the Edit Dashboard permissions can add the Analytics option for the Block Type.

Publishing Unifier Data to Analytics

You must send Unifier data to Analytics periodically. You can set the frequency of sending data to Analytics, by way of OBI, by using the Schedule option in the toolbar.

Note: If you need location-specific details for Spatial Data in Analytics, ensure that the values for Country and State Data Elements (DEs) are according to the ISO standards. These values can be pulldowns or plain text fields.

Schedule Setup

The frequency for the data publication can be Daily, Weekly or None. The default value is Daily.

You can set the frequency to Daily, Weekly, or None.

The default frequency is Daily.
If you select Weekly, the system sets the day to Sunday. You can change the day.

If you select None, there will be no periodic publication of Unifier data to Analytics.

You can set the time for the publication of data.

You must set the time format to 24-hour notation in the form hh:mm, for the publication of data. The Hour drop-down lists hours from 0 to 23 for hour and 0 to 59 for minute. The default option for time is set to 00:00. The system displays the server time zone after the minute.

You must select the checkbox for the Data Refresh option if you made changes to the DD value or labels. By default, the checkbox is unchecked.

You must select the checkbox for the Data Refresh option if you made changes to the data mapping fields. After the run is complete, the system resets the checkbox for the Data Refresh option and the checkbox will be unchecked.

**Mapping Linked Elements**

The linked elements can be mapped to Analytics fields. The values of linked elements from the source are rendered at run-time in the destination record. Periodic update of data to Analytics is done on an incremental basis. However, if there are any changes to the value of the linked elements in the source record, then you need to conduct a full refresh of data in order for Analytics to display these values. As a result, you must select the "Refresh All data" for this purpose.

**Run History**

Run History option allows you to see the status of the scheduled runs of the Unifier data publication to the Analytics server. When you select the Run History option, by clicking Run History on the toolbar, the Run History window opens and displays the following information:

- **Requestor**: Is always "System"
- **Submit Date**: The date entered by user
- **Start Data**: The date entered by user
- **End Date**: The date entered by user
- **Status**: The run status

You can view the Run History details by opening a record in the Run History log.

The history details window includes the Start Date, the End Date, a message.

- **Success message**: “Data was sent to Analytics, successfully.”
- **Failure message**: For example, “An error occurred and data was not sent to Analytics successfully. Contact System Administrator.” The system displays the actual error after the generic failure message.

**Unifier Configurator and OBI Server**

The Unifier Configurator has an additional option for users to enter the URL to the OBI server. Refer to the *Unifier Installation Guide (WebLogic)* for details.

**Analytics Block**

The following provides detailed information about the Analytics Block window:
Block Title: This field contains the title of the Analytics Block.
Name: This field contains the name (as a hyperlink) of the Analytics Block.
URL: This field contains the URL, entered by the user, and it must match the URL specified in the Configurator.

**Note:** The URL protocol, server path, and port must all match; otherwise, the validation fails.

**Example**
If the URL is: `http://slc44.us.oracle.com:7001/analytics`, then the Analytics URL must be: `http://slc44.us.oracle.com:7001/analytics`.

**Note:** The system does not validate the other URL parameters, for example, the Dashboard name.

When you post the Analytics Block, it appears in the Source Details log and provides the following information:
- Block Title: Title entered by the user.
- Source Name: Same as the name entered in the Name field.
- Block Type: Analytics
- Result Type: Blank
- Display Type: Blank

The Analytics Block is also displayed in the Shell landing page. In the Unifier Analytics pane, you can click Analytics Dashboards to go to the shell dashboard in the Analytics server.

If a user does not have permissions to access the Shell dashboards defined in OBIEE server, then the link is disabled and displays as plain text.

You can add Analytics block to “My Dashboards”. However, the link connecting Unifier to the Analytics server, from this "My Dashboards" is completely driven by the Access Control > Mode Access > Shells/Projects (Standard) > Non-Navigation Nodes > Analytics.

**Analytics Block and Shell Templates**
The Analytics Block that is defined in the Shell dashboard of the Shell templates can be pushed to Shell instances.
Unifier and Primavera P6

Unifier receives the integrated data, from P6, and uses the data for the following Cost modules:

- Cost Sheet
- Cash Flow
- Earned Value (EV)

As a part of integration, you can capture the "summarized" P6 data within the Cost modules and view the information in a columnar and comparative format, for example, Cost Sheet columns, Cash Flow Curves, and Earned Value Curves). In addition, the Reporting functionality within Unifier enables you to create "User-Defined" or "Custom" reports using the "summarized" P6 data.

Prerequisites for a Successful Integration

- Use WBS type Shells to use Unifier cost modules with data integrated from P6.
- Use the system Data Element `uuu_int_schedule_type` within the Integration -> Detail section of Shell attribute form definition.
- Create and Publish P6 Data Sources to pull P6 data into Cost Sheet.
- Create Shell instances corresponding to each P6 Schedule that needs to be integrated with Unifier by following these instructions:
  - Each Shell instance must have the same ‘Shell Number’ as the corresponding P6 Project ID.
  - To bring the P6 internal Project id to Unifier, you need to add the P6 Internal Project ID field (`uuu_int_internal_proj_id`) to the Attribute form and the Integration Detail form (Company Workspace > Admin mode > uDesigner > Shell Manager > Integration > Detail)
  - Create or use separate Shell Templates for Duration Based and Resource or Cost Loaded integrated Shells in Unifier because the Cost Sheet for Duration Based schedules will not contain columns rolling up from P6 Summary Sheets (when the other two types of schedules will have columns rolling up from P6 Summary Sheets)

- Include the following in the Role attribute form, if the integration will be Resource or Cost Loaded:
  - `uuu_role_imported_from_p6`
  - `uuu_role_type, uuu_role_id`
  - `uuu_role_uom`

  For correct cost calculations in Resource Loaded schedules, update all imported roles with Rate values.

- If you create Unifier Roles via integration, include the Roles above the Data Elements (DEs) in the integration detail section in uDesigner Role attribute design.

- For Resource Loaded or Cost Loaded schedules:
  - (Recommended) Do not change or update the ID of Roles created via integration manually because when you create Roles via integration the Role ID is used as the identifier by means of which the integration interface maps the P6 Resource to Unifier Role.

- If you want to integrate the CBS codes with P6, do the following:
  - Include `uuu_cost_imported_from_p6` and `uuu_int_hidden_from_p6` in the WBS attribute form
Define the default CBS segment values within Data Structure Setup -> Data Definitions -> Cost Codes

If you want to create Cost Codes for a Shell using the P6 WBS structure, ensure that the Cost Sheet structure in P6 is Tree.

Do not include Unifier Cost Code separators ("-", ".") in P6 WBS Codes if you are creating Cost Codes in Unifier using P6 data.

When working with P6 data sources or Cost Sheet columns:

- You can create or publish P6 data sources via integration and when the "Send Summary data" integration is used.
- You can add published P6 data sources, as columns, in Cost Sheet Templates, only.
- If you create P6 data sources via integration, and not manually, then you can add columns to Cost Sheet after the "Send Summary data to Unifier" is used, only.
- If you create P6 data sources manually, and not via integration, then create or publish P6 data sources by:
  - Creating or publishing one P6 Data Source called "Current Schedule." This datasource is used by the system to define the "Type" of all Master Summary sheets (Summary sheets which contain summary data from the main P6 project which is integrated with Unifier).
  - Creating or publishing all "Baseline Type" values defined within P6 Enterprise Data as P6 Data Sources in Unifier.
  - Once you created or published the P6 data sources, you can use the P6 data sources to create columns in the Cost Sheet Template and push the information to the Shell instances.

In This Section

P6 Data Sources node ........................................................................................... 710
P6 Activity Data ..................................................................................................... 713
P6 Activity Picker Query Configuration ............................................................... 713
P6 Data and Cash Flow Templates ........................................................................ 715

**P6 Data Sources node**

The P6 Data Sources node is located under the Standards &Libraries node. The P6 Data Sources node enables you to access the following information, based on your permissions:

- Data source
  - Captured from P6 Summary Sheets, for use in Cost Sheets or Cost Sheets Templates.
  - Examples of P6 Data Sources: Current Schedule Summary, Original Baseline Summary, Sanctioned Baseline Summary
- Dataset for the attribute "Type" for P6 Summary Sheets

**Note:** Unifier allow a maximum of 12 P6 Data Sources to be integrated, with "Current Schedule" as one of the 12 P6 Data Sources must be named.
P6 Data Sources Permissions
The P6 Data Sources node appears under the Standards &Libraries node, when in Administration mode. The following permissions are available for the P6 Data Sources:

- **Create**
  User with Create permission have full access to the P6 Data Sources node and is allowed to create new data sources, modify existing data sources, and delete and view all data sources. If a user has "Create" permission, the remaining two permissions is enabled automatically.

- **Delete/Modify**
  User with Delete/Modify permission will not be able to Create new data sources. If a user has "Delete/Modify" permission, the "View" permission is enabled automatically.

- **View**
  User having View Permission will not be able to Create, Modify or Delete, but will only be able to View the different data sources.

P6 Data Sources Log Window (Main menu)

**File**
- New: To create a new Data Source
- Copy: To copy a Data Source
- Open: To open a Data Source

**Note:** Data Sources must have unique names.

**Edit**
- Delete: To delete a P6 Data Source
  If the P6 Data Source has been published already, you cannot delete.
- Properties: To edit the Data Source properties

**Note:** You cannot edit the name of a Data Source.

**View**
- To find a Data Source.

**Help**
- To access online help and documents.

P6 Data Sources Log Window (Toolbar menu)

**New**
- To define a new P6 Data Source, using the New window.

**Open**
- To open a defined P6 Data Source.
Delete
To delete an existing Data Source, one record at a time.

Publish
To make the P6 Data Source available to be added as Cost Sheet columns. You can select and Publish more than one Data Source at a time.

Note: Once a Data source is published, it appears as a "single" Data Sources within a Cost Sheet or Cost Sheet Template that have the option of "Enable P6 Sources" selected in the properties. Unpublished Data Sources are not be available as Cost Sheet "Single" Data Sources.

Find
To find a Data Source

P6 Data Sources Properties Window

- **Name**
  Text (maximum 120 characters). This content of this field is from P6 and maps to the P6 Project Name.

- **Description**
  Editable field allowing you to enter a description (maximum 500 characters).
**P6 Activity Data**

If you are using both Unifier and P6, you can link the two applications using Primavera Gateway and send data from a P6 Schedule to Unifier Projects. You can "pick" activities and Auto-populate (AP) or Reverse Auto-populate (RAP) from the corresponding P6 project.

**Corresponding P6 Project**

The term “Corresponding P6 project” refers to that P6 project which has the:

- Same ID as Unifier Project
- or
- Same ID as captured in a system element in Unifier project attributes

**Maintaining Projects (Unifier and P6)**

Maintain projects between the two applications by ensuring that the:

- ID of the projects match in both applications
- or
- System Data Element (DE) (uuu_int_p6_project_id) is present on the Shell Attribute form, and the value is the same as the corresponding P6 project ID.

If only when one of the conditions above is met that the Gateway - Unifier Provider can determine which P6 project corresponds to which Unifier project.

**Note:** Integration with P6 application applies to Unifier WBS type Shell only. The integration does not apply to the Unifier Project (Standard).

---

**P6 Activity Picker Query Configuration**

You can query the P6 Activity Picker elements by using the fields associated with the P6 Activity Attribute form. To define query conditions for P6 Activity Picker elements, from the same place as Data Picker query conditions in Unifier, switch to the Admin mode: Configuration > Business Processes > File > Open > Data Picker.

In the Query Condition window, you can add query conditions under the Add Query Condition section:

- **Data Element**
  A drop-down list that contains all the elements (pre-defined or custom) from the P6 Activity Attribute form. You can use the Data Element to create any query to filter out P6 Schedule activities from the P6 Activity Picker.

- **Condition**
  To set conditions for the query.
You can use a Cash Flow Shell template (Shell instances and Shell templates) to select the Summary Sheets by selecting the associated P6 data sources. As a result, when you use a Cash Flow Shell template to push the Cash Flow settings, the system updates the Shell instance with the Cash Flow settings of the template.

**Note:** The following applies to both Distribution, Cost, and Schedule sections.

At runtime, the system uses the data from Summary Sheets, associated with the P6 data source, to render the Cash Flow curves.

**Distribution and Schedule**

In the Distribution or Schedule sections of the Cash Flow templates (with Detail level WBS), click **Select** from the Use data from P6 Sources option to open the Select Data sources window. This window displays all the data sources listed in the Standards & Libraries.

**Note:** The Data Type option (under the P6 Source selection option) is a required field, if you select Use data from P6 Sources option. Use the drop-down list in the Data Type field to see a list of all the data types available for the selected P6 data source.

Since the Schedule type will be blank, the Cash Flow template displays all the options available regardless of the Schedule type.

The P6 sources in Distribution, Cost (only for Actuals), and Schedule sections are always enabled in the Cash Flow templates.

The P6 Sources window (source selection) lists all the Published data sources, in alphabetical order. You can click on a source name to select that source. To find a source, go to Find, click the drop-down list, and follow the prompts. Depending on the type of the Cash Flow curve, this option is available only if you select the Distribution/Schedule/cost option as Use data/dates from P6 Sources.

The Data type options for the Baseline curves are:

- At Completion
- Planned

The Data type options for the Forecast curves are:

- At Completion
- Remaining

You can copy the Cash Flow curve properties that exist in a Shell template to the Cash Flow curves that exist in instances if:

- The Shell template push is done
- The Shell template is used to create new instances
Unifier and Primavera Gateway

Gateway allows data to be moved between two applications (at least one of them is a Primavera application) on schedule or on demand. It is a single integration hub where all the data integration happens with Primavera applications.

For a Unifier object to exchange data with an object in another application via Gateway, the object must be pre-defined within:

- Unifier Provider
- Gateway
- Third-party/external application Provider

Additionally, objects within each Provider must have a hard-coded (Java code) link to the corresponding object (with which it exchanges data) in Gateway.

Example

To expose Unifier Project object for integration with another application via Gateway, there must be:

- Project object defined in Unifier Provider
- Project object defined in Gateway
- Project object defined in Unifier Provider must be hard-coded (Java code) to link to Gateway Project object

Correspondingly, to exchange data with Unifier Project object, the third-party/external application Provider must have a Project object within it and that object must be hard coded (via java coding) to link to Gateway Project object.

Unifier Objects and Gateway

The following Unifier objects can be integrated with third-party applications via Gateway:

- **Projects/Shells**
  
  You can create and update Projects in Unifier using project data from an external application via Gateway. The exchange of information is bi-directional, from the third-party application to Unifier and from Unifier to the third-party application.

  **Note**: Integration with P6 application does not apply to the Unifier Project (Standard).

- **Business Processes**
  
  You can create and update Business Process records using data from external applications sent to Unifier via Gateway. The exchange of information is one-directional, from the third-party to Unifier.

- **Roles**
  
  You can create and update Unifier Roles using data sent over from Gateway. The exchange of information is one-directional, from the third-party to Unifier.
Unifier Administration Mode

**WBS Codes**
You can create WBS codes, within a Cost Sheet, using data sent over from Gateway. The exchange of information is one-directional, from the third-party to Unifier.

*Note:* Integration with P6 application applies to Unifier WBS Shell-type only.

**Gateway Objects that Support Unifier Objects**

<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BlanketPurchaseOrder</td>
<td>A company level purchase order, which enables agreements with vendors to provide services across multiple projects, released on a per-project/per-period basis with work authorizations against a previously determined maximum.</td>
</tr>
<tr>
<td>2</td>
<td>BlanketPurchaseOrderDetail</td>
<td>Line Items for Blanket Purchase Orders</td>
</tr>
<tr>
<td>3</td>
<td>Contract</td>
<td>Base Commit for EPC Activities (SOV = Payment Application)</td>
</tr>
<tr>
<td>4</td>
<td>ContractDetail</td>
<td>Line Items for Contracts</td>
</tr>
<tr>
<td>5</td>
<td>PurchaseOrder</td>
<td>To track money committed to be spent (General Spends type Base Commit)</td>
</tr>
<tr>
<td>6</td>
<td>PurchaseOrderDetail</td>
<td>Line Items for Purchase Orders</td>
</tr>
<tr>
<td>7</td>
<td>WorkRelease</td>
<td>Process that is connected to Blanket Purchase Order Business Process that is deployed at company level. This process can be used to write against the blanket purchase order</td>
</tr>
<tr>
<td>8</td>
<td>WorkReleaseDetail</td>
<td>Line Items for Work Releases</td>
</tr>
<tr>
<td>9</td>
<td>ChangeOrder</td>
<td>A formal commit change to the contract.</td>
</tr>
<tr>
<td>10</td>
<td>ChangeOrderDetail</td>
<td>Line Items for Change Orders</td>
</tr>
<tr>
<td>11</td>
<td>POAmendment</td>
<td>Approval process for purchase order changes.</td>
</tr>
<tr>
<td>12</td>
<td>POAmendmentDetail</td>
<td>Line Items for PO Amendments</td>
</tr>
<tr>
<td>13</td>
<td>Invoice</td>
<td>A general process for requesting and approving payments against commitments (invoice at the WBS or breakdown level, do not calculate retainage or stored materials)</td>
</tr>
<tr>
<td>14</td>
<td>InvoiceDetail</td>
<td>Line Items for Invoices</td>
</tr>
<tr>
<td>Item</td>
<td>Object Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>15</td>
<td>PaymentApplication</td>
<td>A process to track your payment information using a standard payment application method (for example, tracking retainage, stored materials, past payments, etc.)</td>
</tr>
<tr>
<td>16</td>
<td>PaymentApplication Detail</td>
<td>Line Items for Payment Applications</td>
</tr>
<tr>
<td>17</td>
<td>Estimate</td>
<td>Used to create multiple project estimates and identify the preferred scenario.</td>
</tr>
<tr>
<td>18</td>
<td>EstimateDetail</td>
<td>Line Items for Estimates</td>
</tr>
<tr>
<td>19</td>
<td>BudgetApproval</td>
<td>Used to approve project budget</td>
</tr>
<tr>
<td>20</td>
<td>BudgetApprovalDetail</td>
<td>Line Items for Budget Approval</td>
</tr>
<tr>
<td>21</td>
<td>BudgetChange</td>
<td>For requesting additional (or reduced) budget beyond the existing budget.</td>
</tr>
<tr>
<td>22</td>
<td>BudgetChangeDetail</td>
<td>Line Items for Budget Changes</td>
</tr>
<tr>
<td>23</td>
<td>BudgetTransfer</td>
<td>For transferring budget from one WBS code to another. Most typically used to release budget contingency to other cost items.</td>
</tr>
<tr>
<td>24</td>
<td>BudgetTransferDetail</td>
<td>Line Items for Budget Transfers</td>
</tr>
<tr>
<td>25</td>
<td>PotentialChangeOrder</td>
<td>Contractor initiated potential change order.</td>
</tr>
<tr>
<td>26</td>
<td>PotentialChangeOrderDetail</td>
<td>Line Items for Potential Change Orders</td>
</tr>
<tr>
<td>27</td>
<td>JournalEntry</td>
<td>A process for adjusting spends line items. Most commonly used to reassign costs to alternate cost centers or GL codes; Generic spend to transfer across cost codes</td>
</tr>
<tr>
<td>28</td>
<td>JournalEntryDetail</td>
<td>Line Items for Journal Entries</td>
</tr>
<tr>
<td>29</td>
<td>Payment</td>
<td>BP to hold Checks Processed Information from Financial System.</td>
</tr>
<tr>
<td>30</td>
<td>PaymentDetail</td>
<td>Line Items for Payments</td>
</tr>
<tr>
<td>31</td>
<td>RiskAndIssue</td>
<td>A log for documenting, tracking, and estimating impacts of open issues and risks; Log of items that may impact schedule/scope/cost</td>
</tr>
<tr>
<td>32</td>
<td>RiskAndIssueDetail</td>
<td>Line Items for Risks &amp; Issues</td>
</tr>
<tr>
<td>33</td>
<td>FundAppropriation</td>
<td>Fund accounts as assigned to projects</td>
</tr>
<tr>
<td>Item</td>
<td>Object Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>34</td>
<td>FundAppropriationDetail</td>
<td>Line Items for Fund Appropriations</td>
</tr>
<tr>
<td>35</td>
<td>ProjectInformation</td>
<td>Project attribute information</td>
</tr>
<tr>
<td>36</td>
<td>VendorEvaluation</td>
<td>Document vendor performance for consideration for future work (Simple)</td>
</tr>
<tr>
<td>37</td>
<td>Vendor</td>
<td>Company vendor directory</td>
</tr>
<tr>
<td>38</td>
<td>Vendor Detail</td>
<td>Line Items for Vendors</td>
</tr>
<tr>
<td>39</td>
<td>Timesheet</td>
<td>Used to capture Employee Timesheets (project / non-project hrs)</td>
</tr>
<tr>
<td>40</td>
<td>TimesheetDetail</td>
<td>Line Items for Timesheets</td>
</tr>
<tr>
<td>41</td>
<td>RequestforSubstitution</td>
<td>A change of identical material or equipment</td>
</tr>
<tr>
<td>42</td>
<td>RequestforSubstitutionDetail</td>
<td>Line Items for Request for Substitution</td>
</tr>
<tr>
<td>43</td>
<td>BudgetChangeOrder</td>
<td>A change to a budget that is typically created for a contractor that is based on changes to a contract between the contractor and owner.</td>
</tr>
<tr>
<td>44</td>
<td>BudgetChangeOrderDetail</td>
<td>Line Items for Budget Change Orders</td>
</tr>
<tr>
<td>45</td>
<td>BudgetItem</td>
<td>A budget that is typically created for a contractor that is based on a contract they have with an owner for a project.</td>
</tr>
<tr>
<td>46</td>
<td>BudgetItemDetail</td>
<td>Line Items for Budget Items</td>
</tr>
<tr>
<td>47</td>
<td>PaymentApplicationtoOwner</td>
<td>A payment application that is raised by a contractor to the owner in order for the contractor to receive payment.</td>
</tr>
<tr>
<td>48</td>
<td>PaymentApplicationtoOwnerDetail</td>
<td>Line Items for Payment Applications to Owner</td>
</tr>
<tr>
<td>49</td>
<td>PaymentFromOwner</td>
<td>A record of the actual payments a contractor will have received from the owner based on the payment application they presented to the owner.</td>
</tr>
<tr>
<td>50</td>
<td>PaymentFromOwnerDetail</td>
<td>Line Items for Payments From Owner</td>
</tr>
</tbody>
</table>
Gateway node in Unifier

To access the Gateway node go to Unifier WBS type Shell > Company Workspace > Admin mode > Gateway > Business Objects

The Gateway node provides the following information on the Gateway Integration landing page:

**API URL**
- This element captures the Gateway API URL that Unifier goes to in order to establish connection with Gateway.
- Data Definition: SYS Description Text 250

**User Name**
- This element contains the user’s name who logs into Gateway URL.
- Data Definition: SYS Long Name

**Unifier Deployment**

**P6 Integration Parameters**
- P6 Activity Sheet Synchronization
- Import Synchronization
- Export Synchronization

To see the Integration Settings, click Open from the toolbar. In the Integration Settings window, you can edit fields and run test.

**Integration Settings Window (Editable fields)**
- API URL
- User Name
- Password
  - Contains the password required to log into the Gateway URL.
  - Data Definition: Short Description Text
- Unifier Deployment
  - Allows you to enter the name of the Unifier Deployment, which needs to be accessed to exchange data with external applications
  - Data Definition: SYS Short Description Text 250
- Import Synchronization
  - Contains the name of the Gateway Synchronization, which will be used to Import Activity data from Unifier to P6
  - Using the Gateway URL and the Unifier Deployment details captured within the "Integration" tab of "Company Properties," this field lists all the "Import" synchronizations from the URL, which are applicable to the mentioned Unifier Deployment.
  - **Note:** For Unifier, this is an "Import" synchronization (to import data into Unifier). From P6 perspective, this is an "Export."
  - Editable Drop-down (size 250 chars)
- Export Synchronization
Unifier Administration Mode

- Contains the name of the Gateway Synchronization, which will be used to Export Activity data from P6 to Unifier
- Using the Gateway URL and the Unifier Deployment details captured within the ‘Integration’ tab of Company Properties, this field lists all the "Export" synchronizations from the URL which are applicable to the mentioned Unifier Deployment.
- **Note**: For Unifier, this is an "Export" synchronization (to export data from Unifier), from P6 perspective, this is an "Import."
- Editable Drop-down (size 250 chars)

**Integration Settings Window (Editable fields)**

Run a test to verify that the Gateway URL and other credentials are valid. To run a test to verify that the Gateway URL and other credentials are valid use the Test Connection button. If the system is unable to establish connection, you will receive an error message. If the system is able to establish connection, you will receive a confirmation message.

**Business Objects node in Unifier**

You can expand the Gateway node to see the Business Objects node (Company Workspace > Admin mode > Gateway > Business Objects). When you click the Business Objects node the Business Objects log window appears on the right-hand side.

**Business Objects log**

The Business Objects log window in Unifier provides the following information:

- List of Unifier objects that have been deployed from uDesigner. The Unifier objects are:
  - Projects/Shells (Attribute form)
  - Business Processes

  **Note**: The following types of BPs are not supported for integration: Project/Shell Creation BP - Resource BP - RFB BP - Text BP.

- Roles (Attribute form)

- WBS Codes (Unifier WBS Shell-type only)

- Detailed information about each Unifier object that has been deployed:
  - Name
  - Category
  - Type
  - Last Updated from uDesigner
  - Last Deployed to Gateway

- A mean to deploy a Unifier Business object that is ready to Gateway
  - Deploy to Gateway
In the Business Objects log window, the columns provide detailed information about each Unifier object that has been deployed.

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the Unifier object.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the Unifier object: Business Processes, Shell Manager, and so forth</td>
</tr>
<tr>
<td>Type</td>
<td>The type of the Unifier object: Activity Sheet Attributes (from P6 and not defined in uDesigner), Resource Attributes, Roles Attributes, Cost, Simple, Shell Type, Document, Line Item, and so forth.</td>
</tr>
<tr>
<td>Last Updated from uDesigner</td>
<td>The date when the Unifier object was last updated in uDesigner, which is the Unifier object &quot;Deploy&quot; date from uDesigner.</td>
</tr>
<tr>
<td>Last Deployed to Gateway</td>
<td>The date when the Unifier object was last deployed to Gateway.</td>
</tr>
</tbody>
</table>

In the Business Objects log window, the menu enables you to:

- Deploy a Unifier object to Gateway
  - Edit
- Find a Unifier object by applying filters
  - View
- Review the history of a Unifier object
  - View
- Access Unifier Help, documentation library, and productivity kit
  - Help

In the Business Objects log window, the toolbar enables you to:

- Deploy a Unifier object to Gateway
  - **Deploy to Gateway**
- Review the history of a Unifier object
  - **History**
- Find a Unifier object by applying filters
  - **Find**

**Deploy to Gateway**

If the "Integration" form of the following is set in uDesigner, you can use this option to deploy:

- Activity Sheet Attributes (as captured in Unifier > Unifier Provider > Gateway)
  
The deploy action only sends the values that you had manually entered in the Activity Attribute form to Gateway. The "Activity Sheet" object in Gateway contains all the pre-defined Activity Attributes fields by default.
Projects/Shells (Attribute form)
Business Processes
Roles (Attribute form)

WBS Codes (Unifier WBS Shell-type only)
The user can select multiple items and deploy the selected items to Gateway. When deployed to Gateway, the system appends the attributes of the objects in Unifier to the corresponding object in Unifier Provider. For the selected objects, the user can create the following and synchronize the data exchange:
- Data Mapping templates
- Business Process flows

History
The system logs all the deployed Unifier objects in History. The History option allows you to view the status of a deploy action, informing you whether the deployment was successful, or not, in addition to the following information:
- Requestor
  The name of the user who has deployed the record.
- Source
  If you select Unifier objects of same type and deploy, then the system provides all selected objects (including names of all objects which were chosen by you for deploy) in alphabetical order.
  If you select Unifier objects of multiple types and deploy, then the system provides separate history entries for each of the objects that are getting deployed to Gateway.
- Start Date
  The date when the deployment action started (Unifier started to prepare the xml file for Gateway).
- End Date
  The date when the deployment action ended.
- Status
  The status of deployment action (Finished, In Progress, Finished with Errors).

In the History window toolbar, you can:
- Open
  To open an item in the History log.
  - Similar to the Open option in other "History" windows in Unifier, this action opens the "History Details" window.
  - Similar to other places in Unifier, you can take this action on one selected row only.
- Find
  To allow you to search the History records. You can search on all columns (Requestor, Attribute Form, Submit Date, Start Date, End Date, Status).
Close Window
To close the History window.

History Details
- If you select a row in the History window and click Open, the History Details window opens. This window includes information about:
  - Business Processes
    The name of the attribute form that was deployed.
  - Gateway URL
    The Gateway API URL through which link to the 3rd party applications is established, as defined by the user within Unifier Company Properties > Integration tab.
  - Unifier Deployment Name
    The name of the Unifier Deployment as defined within the Unifier Company Properties > Integration tab.
  - Deploy action status details
    The details of the status of the deploy action, successful or not.

Find
The Find option allow you to search for records in all of the Business Objects window columns.

Configuring Permissions for Business Objects
To configure the permissions for Business Objects go to: Company Workspace > Admin mode > Access Control. The Access Control node includes the Gateway node.

To set permission for Gateway node:
- Configure
  If you check this permission, the user can update the "Integration Settings" at "Gateway Integration" landing page.
- Get / Set Activity Sheet Data
  If you check this permission, the user can do the following from the Shell log File menu (Unifier WBS type Shell):
  - Get Activity Sheet Data (from the Shell toolbar):
    - All Shells
    - Selected Shells
    - Filtered Shells
    - History
  - Send Activity Sheet Data (from the Shell toolbar):
    - All Shells
    - Selected Shells
    - Filtered Shells
    - History
Permission for "Get / Set Activity Sheet Data" from Shell log are configured in Unifier Admin Mode while permissions to take these action from within a Shell (User mode) are given at Unifier User mode level.

To set permission for Business Objects node:

Deploy
If you check this permission, you will enable the Deploy option, in the right-had pane of the Business Objects page.

You can grant permissions, for Business Objects, by way of the User Mode Access in Access Control node: Company Workspace > Admin mode > Access Control > User Mode Access > Shells / Projects (Standard) > Schedule Manager > Activity Sheet.

Note: You can move the Activity Sheet module under other nodes.

The following permissions are available for Activity Sheet:

- **Get Data**
  If you check this permission, the user can go in the Activity Sheet (Shell > User mode > Schedule Manager > Activity Sheet) and perform "Get Activity Sheet Data" or view "History."
  If you select the "Get Data" permission, the "View" permission will be selected automatically. In addition to the "Get Data" permission, the user needs the "View" permission in order to be able to have the "Get Activity Sheet Data" permission. You can grant "View" permission without granting the "Get Data" permission.

- **Send Data**
  If you check this permission, the user can go in the Activity Sheet (Shell > User mode > Schedule Manager > Activity Sheet) and perform "Send Data" or view "History."
  If you select the "Send Data" permission, the "View" permission will be selected automatically. In addition to the "Send Data" permission, the user needs the "View" permission in order to be able to have the "Send Activity Sheet Data" permission. You can grant "View" permission without granting the "Send Data" permission.

- **View**
  If you check this permission, the user can view Activity Sheet data (Shell > User mode > Schedule Manager > Activity Sheet) and perform "Open."

The permissions above are also available:

- When granting permissions through User Administration (Company Workspace > Admin mode > User Administration).
- Within a Shell Template or Shell Instance Access Controls.
- When granting permissions within a Shell Template or Shell Instance Access Control through User Administration.
- Where all nodes are listed in Unifier Navigator (User mode), when appropriate.

## Unifier Provider, Unifier, and Gateway

The following Unifier objects are available in Unifier Provider:

- **Project**
Includes attributes that support the creation of projects in Unifier by way of Gateway. The Project object in Unifier Provider includes the following information:

- Status
- Location
- Template Number

**Business Processes** (BPs)
Enables you to create/update different types of BPs such as Cost, Line Item, Document, and so forth, in Unifier. To correspond to the Gateway infrastructure, separate objects are available to capture the information in the BP Upper Form and Detail tab. To support the creation of BPs in Unifier, the Business Processes object in Unifier Provider includes the following information:

- Name
- Status
- Detail tab Name

**Roles**
Enables you to create/update Roles in Unifier (Resource Manager > Roles).

**Resources**
Enables you to create/update Roles in Unifier (Resource Manager > Roles). You can use the Resources object to identify whether a data from Unifier Provider can create a Role, or not.

**WBS Codes** (Unifier WBS Shell-type only)
- Enables you to use the CBS object in Unifier Provider to import/export the CBS code data from Unifier.
- Enables you to use the WBS object in Unifier Provider to import the CBS code data into Unifier.

The following provides more details.

**Project/Shell**
To create/update Project/Shell in Unifier you can use the following attributes:

- Data Dictionary
- Business Flow
- Synchronization
- End-to-end solution

The following sections provide more details.

**Project/Shell Data Dictionary**
The following table describes the Data Dictionary for Unifier Provider (Project/Shell):
### Attribute Name

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Description</th>
</tr>
</thead>
</table>
| Status         | To capture the status of Unifier project. Since Unifier projects must have one of following statuses, the user must define the data value mapping XML to map status of source project and to a project status value in Unifier.  
  > Active  
  > On-Hold  
  > View-Only  
  > Inactive |
| Location       | The location of the destination Unifier Project.  
  Example  
  All Regions > Sites > Properties |
| Template       | The "Number" of the template which must be used to create the new project in Unifier.  
  > Unifier Shell Template Numbers are enforced to be unique across all shell template types.  
  > Unifier determines the "Type" of the shell that must be created, using the template number. |

### Project/Shell Business Flow

When defining a Business Flow in Unifier Provider (Project/Shell), the destination application parameters for Unifier Provider, Project object, enable you to define the location (Location) and template (Template) as parameters. The attributes are specific to Unifier and eliminate the need for the source application to send the values for Unifier fields.

If the source application sends value for either of the parameters mentioned below via data mapping and you define the parameter value in the business flow, then the value sent by way of mapping takes precedence.

The following parameters are required for successful project creation in Unifier.

**Note:** Oracle recommends that you set these parameters as "Required" in the Business Flow definition.
<table>
<thead>
<tr>
<th>Object</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Location</td>
<td>This is a Text field. You must enter one location, only. Example All Regions &gt; Sites &gt; Properties If you enter multiple locations, Unifier Provider will not be able to resolve the location in Unifier and project creation will fail.</td>
<td>Use this parameter to identify the location (Location): Where the Unifier project must be created in Unifier. You can also add the location as &quot;Shell Attribute&quot; (uuu_location) when defining the &quot;Project&quot; object filters. If you define the location parameter as a shell attribute (uuu_location = &lt;xyz&gt;), and use the available drop-down field (Location) for the Project object, then project creation will fail. If you add a filter row by selecting the fields as Shell Attribute Form and provide a value of the Shell Location, for Project object, then project creation will fail.</td>
</tr>
<tr>
<td>Project Template Number</td>
<td>This is a Text field. You must enter one number, only. If you enter multiple numbers, Unifier Provider will not be able to resolve the template in Unifier and project creation will fail.</td>
<td>Use this parameter to identify the templates which must be used to create the new Project in Unifier.</td>
</tr>
</tbody>
</table>

**Project/Shell Synchronization**

Synchronization in Unifier Provider (Project/Shell) occurs when you set the parameters (Project Location and Project Template Number) as "Required" or "Optional" in the Business Flow definition.

**Project/Shell End-to-End Solution**

The following explains the end-to-end solution for Unifier Provider (Project/Shell). The configuration settings are for:

- Unifier
- Unifier Provider
To configure the creation of projects in Unifier via Gateway

**Note:** This is an optional step. You can skip deploying the objects from Unifier and add relevant fields in Gateway Data Mapping Templates directly, manually.

In Unifier, go to **Company Workspace > Admin mode > Gateway > Business Objects.**

Deploy the Shell Attribute Forms of the shells that you want to create in Unifier, via Gateway Integration.

All fields from the deployed Shell Attribute Forms appear as attributes of Project object in Unifier Provider Data Dictionary.

**To configure the creation of projects in Unifier Provider via Gateway**

You must:

- Create Data Mapping Templates
- Define Business Flow
- Define Synchronizations
- Synchronize

The following provides the details for each step:

**Create Data Mapping Templates**

Create Data Mapping Templates to map attributes of the Shell that needs to integrate with the third-party application. All attributes of the Unifier Data Dictionary Project object are available to be added to the Data Mapping Template.

**Note:** Ensure that you create one Data Mapping Template per Shell type.

If you do not want to deploy from Unifier and want to create the Data Mapping Templates in Gateway directly, then add each Shell Attribute Form Data Element that needs to receive data from the third-party application Project object, manually.

If you want to deploy from Unifier, after adding the Shell Attribute Form Data Element, then:

- If the manually added field is same as one of the fields that were deployed from Unifier, then there will be no adverse impact on the existing fields.
- If the manually added field does not exist as a Data Element in Unifier, then there will be no adverse impact on the existing fields.

The fields remain as they are when the third-party application sends values for the fields that were added to Unifier Provider and those values are not sent to Unifier.

**Define Business Flow**

Define Business Flow using the appropriate Data Mapping Template.

Create one Business Flow per Shell type in Unifier.

Add the appropriate source (Source) application parameters to filter the projects that you want to create in Unifier.
Add the values of relevant destination (Destination) application parameters (Location and Template).

Configure the Business Flow to be used for creating (Create) and updating (Update) the project in Unifier.

**Define Synchronizations**

Define Synchronizations by using the appropriate Business Flow.

Define the appropriate parameter values for data exchange.

Define the schedule frequency so that the synchronization does not have to be run manually for the project creation or update.

**Synchronization**

When a synchronization is run, Unifier Provider sends data to Unifier to:

- Create or update a Shell instance (as per Business Flow configuration).
- Populate the Data Element with the name of the application that is integrating with Unifier, if the destination Shell Attribute Form contains the "uuu_integrated_with" Data Element.

**Note:** The application name value is sent by Gateway. The name is not hard-coded by Unifier.

Gateway maintains a cross-reference table between objects of the two applications to monitor whether to create or update the records of an object. The cross-reference table has IDs of projects in Unifier and P6. If the cross-reference table has and entry for a Unifier project against a P6 project, then Gateway will update the Unifier project; otherwise, Gateway will create a Unifier project.

**Note:** If a project exists in Unifier and does not have an entry in the Gateway cross-reference table, then when Gateway proceeds to create a project in Unifier, to prevent creating a duplicate project in Unifier, Unifier converts the create request to update request and proceeds to update the existing project, instead of creating a new project.

**Business Processes**

To create/update Business Process records in Unifier you can use the following attributes:

- Data Dictionary
- Business Flow
- Synchronization
- End-to-end solution

The following sections provide more details.
## Business Processes Data Dictionary

### Data Dictionary (Unifier Provider Business Processes)

**Notes:**
- The remaining attributes are deployed from Unifier, as Data Elements, and will be added to relevant business processes, per business need.
- If available, the Object IDs in Gateway are noted in the corresponding field.
- The Parent Element ID is the tag in the Line Item which connects the Line Item with the parent record in which the Line Item has to exist in.
- Create separate templates for importing data into different BPs.

<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 1    | Company Costs | Unifier business processes that hold company level costs. When deployed from Unifier, the Upper forms of the Business Processes of the following category provide data for this object: Type = Cost  AND  Sub-type = Commit at Company Level  AND  Classification = <Null> OR Generic | ▶ Record Number (record_no)  
▶ Title (title)  
▶ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
▶ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
▶ Status (status)  
▶ Amount (amount) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 2    | Company Costs Detail | Detail tabs of Company Cost business processes. When deployed from Unifier, the Detail tabs of all business processes that are in Company Costs category provide data for this object. | ▸ Parent Record Number  
▸ Line No./LiNum in Unifier Provider and LineNo in Gateway Object field (S.No 3)  
▸ Tab Name (uuu_tab_id)  
▸ Short Description (short_desc)  
▸ Item Quantity (uuu_quantity)  
▸ Item Unit Cost (uuu_unit_price) in Unifier Provider and PricePerUnit in Gateway Object field (S.No 4)  
▸ Amount (amount) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 3    | Project Commits| Unifier Project level business processes related to money committed to be spent. When deployed from Unifier, the Upper forms of the business processes of the following category provide data for this object: Type = Cost AND Sub-type = Line Items with WBS Code OR Line Items with Multiple Codes AND Classification = Base Commit OR Change Commit | Record Number (record_no)  
Title (title)  
Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
Due date (due_date)  
Effective Date (uuu_effective_date)  
Transaction Currency (currencyid)  
Rate in Project Currency (currencyrate)  
Status (status)  
Description (description)  
Amount (amount)  
Publish Path (uuu_dm_publish_path)  
Reference BPO (ref_bpo)  
Contract/PO (refid) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Project Commits Detail</td>
<td>Detail tabs of the Project commits type business processes. When deployed from Unifier, the Detail tabs of all business processes that are in Project Commits category provide data for this object.</td>
<td>▸ Parent Record Number&lt;br&gt;▼ Line No./LiNum in Unifier Provider and LineNo in Gateway Object field (S.No 3)&lt;br&gt;▼ Tab Name (uuu_tab_id)&lt;br&gt;▼ Cost Code (bitemID)&lt;br&gt;▼ Short_Description (short_desc)&lt;br&gt;▼ Description (description)&lt;br&gt;▼ Work Package (wpid)&lt;br&gt;▼ Item Quantity (uuu_quantity)&lt;br&gt;▼ Item Unit Cost (uuu_unit_price) in Unifier Provider and PricePerUnit in Gateway Object field (S.No 4)&lt;br&gt;▼ Amount (amount)&lt;br&gt;▼ Reference BPO Lineitem (ref_bpo_lineitem)&lt;br&gt;▼ Reference (uuu_sovlinum)&lt;br&gt;▼ Parent Detail Id (ParentDetailId)</td>
</tr>
<tr>
<td>Item</td>
<td>Object Name</td>
<td>Description</td>
<td>Object Attributes</td>
</tr>
<tr>
<td>------</td>
<td>----------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| 5    | Project Invoices | Unifier invoice related Project level business processes. When deployed from Unifier, the Upper forms of the business processes of the following category provide data for this object: Type = Cost AND Sub-type = Line Items with WBS Code OR Line Items with Multiple Codes AND Classification = General Spends OR Payment Applications | ▶ Record Number (record_no)  
▶ Title (title)  
▶ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
▶ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
▶ Due date (due_date)  
▶ Effective Date (uuu_effective_date)  
▶ Contract/PO (refid)  
▶ Transaction Currency (currencyid)  
▶ Amount (amount)  
▶ Status (status)  
▶ Publish Path (uuu_dm_publish_path) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 6    | Project Invoices  | Detail tabs of the Project invoices type business processes. When deployed from Unifier, the Detail tabs of all business processes that are in Project Invoices category provide data for this object. | ▸ Parent Record Number  
    ▸ Line No./LiNum in Unifier Provider and LineNo in Gateway Object field (S.No 3)  
    ▸ Tab Name (uuu_tab_id)  
    ▸ Cost Code (bitemID)  
    ▸ Short_Description (short_desc)  
    ▸ Description (description)  
    ▸ Work Package (wpid)  
    ▸ Item Quantity (uuu_quantity)  
    ▸ Item Unit Cost (uuu_unit_price) in Unifier Provider and PricePerUnit in Gateway Object field (S.No 4)  
    ▸ Amount (amount)  
    ▸ Effective Date (uuu_effective_date)  
    ▸ Scheduled Value (scheduled_value)  
    ▸ Parent Detail Id (ParentDetailId) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 7    | Other Project Costs  | Unifier Project level business processes that captures costs other than commits or invoices. When deployed from Unifier, the Upper forms of the business processes of the following category provide data for this object: Type = Cost AND Sub-type = Line Items with WBS Code OR Line Items with Fund Code OR AND Classification = Generic OR Transfer OR | ▸ Record Number (record_no)  
▷ Title (title)  
▷ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
▷ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
▷ Status (status)  
▷ Amount (amount)  
▷ Publish Path (uuu_dm_publish_path) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
</table>
| 8    | Other Project Costs Detail | Detail tabs of the Other Project costs type business processes. When deployed from Unifier, the Detail tabs of all business processes that are in Other Project Costs category provide data for this object. |  Parent Record Number  
 Line No./LiNum in Unifier Provider and LineNo in Gateway Object field (S.No 3)  
 Tab Name (uuu_tab_id)  
 Cost Code (bitemID)  
 Fund Code (uuu_fund_code)  
 Short_Description (short_desc)  
 Description (description)  
 Item Quantity (uuu_quantity)  
 Item Unit Cost (uuu_unit_price) in Unifier Provider and PricePerUnit in Gateway Object field (S.No 4)  
 Amount (amount)  
 Effective Date (uuu_effective_date) |
| 9    | Project Simple  | Unifier project level Simple business processes. When deployed from Unifier, the Upper forms of the business processes of the following category provide data for this object: Type = Simple AND Level = Project/Shell |  Record Number (record_no)  
 Title (title)  
 Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
 Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
 Status (status)  
 Publish Path (uuu_dm_publish_path) |
<table>
<thead>
<tr>
<th>Item</th>
<th>Object Name</th>
<th>Description</th>
<th>Object Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Company Simple</td>
<td>Unifier company level Simple business processes. When deployed from Unifier,</td>
<td>▸ Record Number (record_no)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the Upper forms of the business processes of the following category provide</td>
<td>▸ Title (title)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>data for this object:</td>
<td>▸ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Type = Simple</td>
<td>field (S.No 2)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND</td>
<td>▸ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Level = Company</td>
<td>Object field (S.No 1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▸ Status (status)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▸ Due Date (due_date)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▸ Publish Path (uuu_dm_publish_path)</td>
</tr>
<tr>
<td>11</td>
<td>Company Line Item</td>
<td>Unifier company level Line Item type business processes. When deployed from</td>
<td>▸ Record Number (record_no)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the Upper forms of the business processes of the following category provide</td>
<td>▸ Title (title)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>data for this object:</td>
<td>▸ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Type = Line Item</td>
<td>field (S.No 2)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND</td>
<td>▸ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sub-Type = Any</td>
<td>Object field (S.No 1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>AND</td>
<td>▸ Status (status)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Level = Company</td>
<td>▸ Due Date (due_date)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▸ Publish Path (uuu_dm_publish_path)</td>
</tr>
<tr>
<td>Item</td>
<td>Object Name</td>
<td>Description</td>
<td>Object Attributes</td>
</tr>
<tr>
<td>------</td>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| 12   | Company Line Item Detail | Detail tabs of the company Line Item type business processes. When deployed from Unifier, the Detail tabs of all business processes that are in Company Line Item category provide data for this object. | ▶ Parent Record Number  
▶ Line No./LiNum in Unifier Provider and LineNo in Gateway Object field (S.No 3)  
▶ Tab Name (uuu_tab_id)  
▶ Short Description (short_desc) |
| 13   | Project Document    | Unifier Project level Document type business processes. When deployed from Unifier, the Upper forms of the business processes of the following category provide data for this object:  
Type = Document  
AND  
Sub-Type = Any  
AND  
Level = Project/Shell | ▶ Record Number (record_no)  
▶ Title (title)  
▶ Creator (uuu_creator_id) in Unifier Provider and CreateUserId in Gateway Object field (S.No 2)  
▶ Creation Date (uuu_creation_date) in Unifier Provider and CreateDate in Gateway Object field (S.No 1)  
▶ Short Description (short_desc)  
▶ Status (status)  
▶ Publish Path (uuu_dm_publish_path) |
Summary Payment Application (SPA) SOV type BPs

The creation and update of the Line Items in the Summary Payment Application (SPA) SOV type BPs requires three fields in Unifier Provider. These fields are designed to identify and separate the SPA SOV type BPs in Unifier Provider from the existing SPA SOV type BPs in Unifier.

Note: Line Item update is not supported for Project Invoice (Payment Applications) Type of BP's through Gateway Integration. As a result, every Update from Gateway to Unifier will result in the creation of a new Line Item.

Depending on which Line Item is referenced, the Line Items coming from Gateway follow a certain structure as described in the examples below:

**Base Commit Type BP Line Item**

Example

```xml
<bp_lineitems> <!--Summary Line -- >
<ElementId>Summary1</ElementId>
<ParentDetailId></ParentDetailId>
<short_desc>desc 1</short_desc>
</bp_lineitems>

<bp_lineitems> <!--Costed line -- >
<ElementId>costed line 1</ElementId>
<ParentDetailId>Summary1</ParentDetailId>
<short_desc>desc 1</short_desc>
</bp_lineitems>
```
**Note:** The *parentdetailid* connects the BP Line Item to its parent Summary Line Item in the SOV.

### Change Commit Type BP Line Item

#### Example

```xml
<_bp_lineitems> <!—Summary Line -- >
<ElementId>Summary1</ElementId>
<ParentDetailId></ParentDetailId>
<short_desc>desc 1</short_desc>
<uuu_sovlinum>1</uuu_sovlinum>
</_bp_lineitems>

<_bp_lineitems> <!—Costed line -- >
<ElementId>costed line 1</ElementId>
<ParentDetailId>Summary1</ParentDetailId>
<short_desc>desc 1</short_desc>
<uuu_sovlinum>1.1</uuu_sovlinum>
<bItemID>Code 1</bItemID>
</_bp_lineitems>
```

#### Notes:

- The *parentdetailid* connects the BP Line Item to its parent Summary Line Item in the SOV.
- The Data Element *uuu_sovlinum* is an optional field. If the value is received by Unifier for the same field, then Unifier will try to update an existing row; otherwise, the update will create a new Line Item in the SOV (based on the settings of the SOV).

### Invoice Type BP Line Item

#### Example

```xml
<_bp_lineitems> <!—Summary Line -- >
<ElementId>Summary1</ElementId>
<ParentDetailId></ParentDetailId>
<short_desc>desc 1</short_desc>
<bItemID></bItemID>
<_refnum>1</_refnum>
</_bp_lineitems>

<_bp_lineitems> <!—Costed line -- >
<ElementId>costed line 1</ElementId>
<ParentDetailId>Summary1</ParentDetailId>
```
Notes:

- The parentdetailid connects the BP Line Item to its parent Summary Line Item in the SOV.
- The refnum is for Unifier and is used when creating the structure within the SOV for the incoming Line Items and the Summary lines.

Unifier Provider BP Objects and Gateway Objects

To correspond to the Unifier Provider objects (explained in the preceding Data Dictionary section), Gateway will introduce new objects to support the various business processes.

You can use the mapping information in the following table to see how data is sent from Unifier to a third-party application and flows from object to object (Unifier Provider > Gateway).

<table>
<thead>
<tr>
<th>Item</th>
<th>Unifier Provider Object Name</th>
<th>Corresponding Gateway Object Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Company Costs</td>
<td>BlanketPurchaseOrder</td>
</tr>
<tr>
<td>2</td>
<td>Company Costs Detail</td>
<td>BlanketPurchaseOrderDetail</td>
</tr>
<tr>
<td>3</td>
<td>Project Commits</td>
<td>BudgetChangeOrder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetItem</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Contract</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PurchaseOrder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WorkRelease</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ChangeOrder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>POAmendment</td>
</tr>
<tr>
<td>4</td>
<td>Project Commits Detail</td>
<td>BudgetChangeOrderDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetItemDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ContractDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PurchaseOrderDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WorkReleaseDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ChangeOrderDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>POAmendmentDetail</td>
</tr>
<tr>
<td>5</td>
<td>Project Invoices</td>
<td>Invoice</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentApplication</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentApplicationtoOwner</td>
</tr>
<tr>
<td>Item</td>
<td>Unifier Provider Object Name</td>
<td>Corresponding Gateway Object Name</td>
</tr>
<tr>
<td>------</td>
<td>---------------------------------------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>6</td>
<td>Project Invoices Detail</td>
<td>InvoiceDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentApplicationDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentApplicationtoOwnerDetail</td>
</tr>
<tr>
<td>7</td>
<td>Other Project Costs</td>
<td>Estimate</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetApproval</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetChange</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetTransfer</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PotentialChangeOrder</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JournalEntry</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Payment</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentFromOwner</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RiskAndIssue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FundAppropriation</td>
</tr>
<tr>
<td>8</td>
<td>Other Project Costs Detail</td>
<td>EstimateDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetApprovalDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetChangeDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BudgetTransferDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PotentialChangeOrderDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JournalEntryDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PaymentFromOwnerDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RiskAndIssueDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FundAppropriationDetail</td>
</tr>
<tr>
<td>9</td>
<td>Project Simple</td>
<td>ProjectInformation</td>
</tr>
<tr>
<td>10</td>
<td>Company Simple</td>
<td>VendorEvaluation</td>
</tr>
<tr>
<td>11</td>
<td>Company Line Item</td>
<td>Vendor</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Timesheet</td>
</tr>
<tr>
<td>12</td>
<td>Company Line Item Detail</td>
<td>VendorDetail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TimesheetDetail</td>
</tr>
<tr>
<td>13</td>
<td>Project Document</td>
<td>RequestforSubstitution</td>
</tr>
<tr>
<td>14</td>
<td>Project Document Detail</td>
<td>RequestforSubstitutionDetail</td>
</tr>
</tbody>
</table>
Business Processes Business Flow

When defining a Business Flow in Unifier Provider (Business Processes), the destination application parameters for Unifier Provider, BP object, enable you to define which BP needs to receive data by way of the Business Flow configuration. The attributes are specific to Unifier and eliminate the need for the source application to send the values for Unifier fields.

Notes:

- To avoid duplicating records, create separate Business Flows (for two BPs of the same type) when importing data into Unifier.
- Do not use a single Business Flow in Gateway to import into two Company Costs type BPs. Instead, use different Business Flows for setting up the data flow.

If the source application sends value for either of the parameters mentioned below via data mapping and you define the parameter value in the business flow, then the value sent by way of mapping takes precedence.

The following parameters are required for successful project creation in Unifier.

<table>
<thead>
<tr>
<th>Object</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| Business Process Name | Text field          | Use this parameter to identify the Name of the business process that requires the data from the third-party application. The value that you enter in this parameter is used by Unifier Provider to identify which BP requires data. Example Creating Data Mapping Template  
  ▶ Unifier Provider object: Project Commits  
  ▶ Gateway object: Contracts  
  ▶ Third-party Application object: xyz |
|                   | If you enter more than one value, then the integration will fail. |                                                                                                                                          |

Example

Creating Data Mapping Template

- Unifier Provider object: Project Commits
- Gateway object: Contracts
- Third-party Application object: xyz
<table>
<thead>
<tr>
<th>Object</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business Process Detail</td>
<td>Text field</td>
<td>Use this parameter to identify the Detail tab of the business process that requires the data from the third-party application. The value that you enter in this parameter is used by Unifier Provider to identify which BP requires data.</td>
</tr>
<tr>
<td>Tab Name</td>
<td>If you enter more than one value, then the integration will fail.</td>
<td>Example</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Creating Data Mapping Template</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▶ Unifier Provider object: Project Commits Detail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▶ Gateway object: Contracts Detail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>▶ Third-party Application object: xyz</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note</strong>: The tab Name is also an attribute for all Line Item objects in Unifier Provider. If the third-party Application sends value for tab name by way of mapping, then the mapped value will override the parameter value defined in Business Flow.</td>
</tr>
</tbody>
</table>
Unifier Administration Mode

<table>
<thead>
<tr>
<th>Object</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Item Identifier</td>
<td>Text field</td>
<td><strong>Note</strong>: Oracle recommends that you use the Data Element name. If you enter more than one value, then the integration will fail.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This parameter is used by Unifier during an update of an existing Line Item (in Unifier), only. The value that you enter in the Data Element of this parameter is used by Unifier to identify which Line Item requires update. <strong>Note</strong>: Within this parameter text box, enter the name (not label) of the Data Element on the Detail tab that must be used as the identifier for Line Item update. Unifier Provider identifies the value entered in this text box as the DE name (not label).</td>
</tr>
</tbody>
</table>

Business Processes Synchronization

Synchronization in Unifier Provider (Business Processes) occurs when you set the parameters (Business Process Name, Status, and Detail Tab Name) as "Required" or "Optional" in the Business Flow definition.

Business Processes End-to-End Solution

The following explains the end-to-end solution for Unifier Provider (Business Processes). The configuration settings are for:

- Unifier
- Unifier Provider

To configure the creation of Business Processes in Unifier via Gateway

**Note**: This is an optional step. You can skip deploying the objects from Unifier and add relevant fields in Gateway Data Mapping Templates directly, manually.

Go to **Company Workspace > Admin mode > Gateway > Business Objects**.

Deploy the business process record that you want to create in Unifier, via Gateway Integration.

All Data Elements from the deployed business process record appear as attributes of Business Process object (Company Costs, Project Commits, Project Invoices, etc.) in Unifier Provider Data Dictionary.
To configure the creation of Business Processes in Unifier Provider via Gateway

You must:

- Create Data Mapping Templates
- Define Business Flow
- Define Synchronizations
- Synchronize

The following provides the details for each step:

**Create Data Mapping Templates**

Create Data Mapping Templates to map attributes of the BPs Upper Form data that needs to integrate with Gateway > Third-party application.

**Notes:**

Ensure that you create one Data Mapping Template per BP.

If the BP that needs to integrate has Detail tab, then create additional Data Mapping Template, one template per Detail tab, to ensure that the map the Detail Form elements to Gateway > Third-party application.

Once you deploy the BP from Unifier to Gateway, all the attributes of the Business Process object Unifier Provider (Company Costs, Project Commits, Project Invoices, etc.) will be available for you to add to the Data Mapping Template.

If you do not want to deploy from Unifier and want to create the Data Mapping Templates in Gateway directly, then you must add each BP Data Element that needs to receive data from a third-party application object in Gateway, manually (use the Add New Field in the Add Template window). After you add each BP Data Element in Gateway, you must deploy the BP from Unifier.

Note the following conditions:

- If the manually added field is the same as one of the fields that you deployed from Unifier, there will be no impact on the existing field. This is similar as if you deployed the manually added field from Unifier.
- If the manually added field does not exist as a Data Element in Unifier, there will be no impact on the existing field. When the third-party application sends value for this field to Unifier Provider, the value remains as is and it is not sent to Unifier.

**Define Business Flow**

Define Business Flow using the appropriate Data Mapping Template.

Create one Business Flow per BP Upper Form and one Business Flow per BP Detail tab in Unifier.

Add the appropriate source (Source) application parameters to filter the BP records that you want to extract for the third-party application and create in Unifier.

Add the values of the following relevant destination (Destination) application parameters in order for the BP Records/Line Items to be created in Unifier:

- Project ID
- Business Process Name
- Business Process Detail Tab Name
Configure the Business Flow to be used for creating (Create) and updating (Update) the BP Records/Line Items in Unifier.

Define Synchronizations
Define Synchronizations by using the appropriate Business Flow.
Define the appropriate parameter values for data exchange.
Define the schedule frequency so that the synchronization does not have to be run manually for the BP Records/Line Items creation or update.

Synchronize
When a synchronization is run, Unifier Provider sends data to Unifier to create or update BP Records/Line Items instance (as per Business Flow configuration).

Example
To create BP records of Base Commits type in Unifier:

1) In Unifier, deploy the Base Commits BP to map to Unifier Provider object (Project Commits).
2) Log in to Gateway instance and create the following two Data Mapping Templates:
   a. Using the Gateway object "Project Commits" to map the Base Commits BP "Upper Form" information to the third-party application.
   b. Using the Gateway object "Project Commits Detail" to map the Base Commits BP "Detail" tab information to the third-party application.
3) Using the appropriate Gateway objects, create the following two Business Flows:
   a. Using Gateway object "Purchase Orders" and selecting the corresponding Data Mapping Template that you created (sub-step "a" above).
   b. Using Gateway object "Purchase Orders Detail" and selecting the corresponding Data Mapping Template that you created (sub-step "b" above).
4) Add the appropriate source (Source App Parameters) to filter records from the source application and set the destination application parameters (Destination App Parameters) to:
   a. Business Process Name = Base Commit
   b. Business Process Detail Tab = <detail tab name>
5) Create two synchronizations:
   a. For Base Commit BP in Unifier
   b. For Base Commit Line Item in Unifier
6) Define the schedule frequency so that the synchronization does not have to be run manually for the BP Records/Line Items creation or update.

Roles
You can create a Role in Unifier by using both Role and Resource data from a third-party application. The Role object in Unifier Provider can be used to create and update Roles in Unifier. The following sections provide details about:

- Roles Data Dictionary
- Roles Business Flow
- Roles Business Flow (Destination App Parameters)
Roles Synchronization
Roles End-to-End Solution

Roles Data Dictionary
The Role object in Unifier Provider has the following default attributes which are the mandatory fields needed to create a Role object in Unifier:

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Role Name</td>
<td>The name of the Role object in Unifier.</td>
</tr>
<tr>
<td>Role Status</td>
<td>The Role status is either Active or Inactive.</td>
</tr>
<tr>
<td></td>
<td>- If the third-party application Role Status values do not match the Unifier Role Status values, then use Data Mapping values.</td>
</tr>
<tr>
<td></td>
<td>- If the third-party application does not send any values for this attribute, then Unifier creates a Role with a default status of &quot;Active.&quot;</td>
</tr>
<tr>
<td>Role Currency</td>
<td>The currency for the Role.</td>
</tr>
<tr>
<td></td>
<td>This attribute is mandatory/required for creating a Role object in Unifier.</td>
</tr>
<tr>
<td></td>
<td>If the third-party application does not send any values for this attribute, then Unifier creates a Role with a default currency of company base currency.</td>
</tr>
</tbody>
</table>

As a result of the Summary Sheet integration that creates Role in Unifier (by pulling data from P6 Schedule Summary data, the Role ID (uuu_role_id) is a mandatory/required field for creating a Role object in Unifier.

Creating a Role object in Unifier by pulling data from Gateway (Role/Resource object) does not require the Role ID (uuu_role_id) field for creating a Role object in Unifier.

Creating a Role object in Unifier via Gateway integration (by pulling data from Gateway Role/Resource object) require the values of the following fields, mentioned in the table above:

- Role Name
- Role Status
- Role Currency

Roles Business Flow
Role, or Resource, mapping in Unifier (from a third-party application) is achieved by way of the "Dynamic Object Mapping" field in Gateway.

The "Create Template" window in Gateway enables you to select "Provider 1" as a third-party application and "Provider 2" as Unifier.
In the section available for mapping objects, you can select "Resource" as the object in the third-party application and "Role" as the object in Unifier (Provider 2).

You can choose a criteria to bring the "Resource" data from the third-party application by selecting the "Use Criteria Step" checkbox. You can then proceed to the next step and add the required mappings.

**Roles Business Flow (Destination App Parameters)**

You can create the Roles object in Unifier from both Resources and Roles objects in Unifier Provider. As a result, when defining a Business Flow, you need to identify the parameters (Destination App Parameters) within Unifier Provider. The following explains the Roles Business Flow:

**Roles Synchronization**

You can create synchronization using the appropriate Business Flow.

**Roles End-to-End Solution**

Follow these steps to create Roles objects in Unifier, via Gateway integration:

1) From Unifier, deploy the Roles attribute form to Gateway.
   - This is an optional step. You can use this step to add additional Data Elements (required for Role creation or to receive values from the third-party application) to the Roles attribute form.
   - You can create the Role object in Unifier from Role, or Resource, object in Unifier Provider by using the destination parameter (see the Roles Business Flow (Destination App Parameters) above); however, when a Roles object is deployed from Unifier, it only provides attributes for the Role object in Unifier Provider, only.

2) Create Data Mapping Template.
   Unifier Provider "Role" object > Gateway "Role" object > Third-party Application "xyz" object

3) Create Business Flow.
   Use the Gateway "Role" object and Data Mapping Template.

4) Create Synchronization.
   Use the Business Flow.

5) Create Schedule.
   Enable the scheduled creation/update of roles.
WBS Codes
You can create and update the WBS Codes in Unifier Cost Sheet via Gateway integration with any third-party application.

For More Information

Where to Get Documentation
If you need help with an operation in Primavera Unifier, there are a number of resources to help you.

Note: The Company Administrators for Unifier Cloud must use the Primavera Unifier Cloud Service Administration Guide instead of all the other installation and configuration guides in the Primavera Unifier Documentation Library.

Online Help
If you have a question or need further assistance regarding a specific feature, review the online help.

Click the Help menu from any Primavera Unifier window, and choose:

- **Unifier Help**: This link goes to the Oracle Technical Network (OTN) Primavera Unifier Online Document Library. From here you can access:
  - Unifier Help
  - Unifier Administration Guide
  - Unifier User Guide
  - Unifier uDesigner User Guide
  - Unifier Reference Guide
  You must have Adobe Acrobat Reader installed (available free at www.adobe.com).

- **BP-specific Help**: If your company has provided customized Help files for individual business processes, you can access them through the business process log or the Help menu.

  Note: For the full list of system requirements, applications, and application version levels refer to the Primavera Unifier Tested Configurations in the Primavera Unifier Documentation Library.

Documentation
Complete documentation libraries for Primavera Unifier releases are available on the Oracle Technology Network (OTN) at:
http://www.oracle.com/technetwork/documentation/default-1870233.html
From this location you can either view libraries online or download them to have local copies. We recommend viewing them from OTN to ensure you always access the latest versions, including critical corrections and enhancements.

The documentation assumes a standard setup of the product, with full access rights to all features and functions.

**Help System Access**

Primavera Unifier is configured to access its help system directly on OTN. However, a downloadable version of the help system is also available on OTN if you need to download, deploy, and access a local copy.

**Documentation Accessibility**

For information about Oracle’s commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

**Access to Oracle Support**

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

**Where to Get Training**

To access comprehensive training for all Primavera products, go to: http://education.oracle.com

**Oracle Learning Library**

The Oracle Learning Library (OLL) provides online learning content covering Primavera products. Content includes whitepapers, videos, tutorials, articles, demos, step-by-step instructions to accomplish specific tasks, and self-paced interactive learning modules.

To access the learning library’s Primavera content, go to: http://www.oracle.com/oll/primavera

**Where to Get Support**

If you have a question about using Oracle products that you or your network administrator cannot resolve with information in the documentation or help, click http://support.oracle.com/. This page provides the latest information on contacting Oracle Global Customer Support, knowledge articles, and the support renewals process. For more information about working with Support, visit https://support.oracle.com/epmos/faces/DocumentDisplay?id=888813.2 to view **Support Tools & Tips**.
Using Primavera's Support Resource Centers

Primavera’s Support Resource Center provides links to important support and product information. Primavera's Product Information Centers (PICs) organize documents found on My Oracle Support (MOS), providing quick access to product and version specific information such as important knowledge documents, Release Value Propositions, and Oracle University training. PICs also offer documentation on Lifetime Management, from planning to installs, upgrades, and maintenance.

Visit https://support.oracle.com/epmos/faces/DocumentDisplay?id=1486951.1 to access links to all of the current PICs.

PICs also provide access to:

- **Communities**, which are moderated by Oracle providing a place for collaboration among industry peers to share best practices.
- **News** from our development and strategy groups.
- **Education** via a list of available Primavera product trainings through Oracle University. The Oracle Advisor Webcast program brings interactive expertise straight to the desktop using Oracle Web Conferencing technology. This capability brings you and Oracle experts together to access information about support services, products, technologies, best practices, and more.

Contacting Your Company Administrator

Click **Help** from the upper right-hand section of the Unifier window to open a contextual menu and click **Contact Support** to open the Support window.

In the Contact tab, Contact Information section, you can see the name, phone, and contact instructions of someone at your company that you can contact when you need help with Primavera Unifier. For assistance, try this person, first.

**Note:** This information is available only if your company administrator has provided internal support contact information.

In the Contact tab, eLearning section, you see the location (Access), name of the contact (Contact), and any instructions that you might need in order to access the eLearning materials.

**Note:** Your company may elect to provide access to the eLearning suite, where you can access interactive Primavera Unifier learning materials. Alternatively, your company may have its own customized support or training materials that can be accessed on an internal site/location. If your company administrator provides this contact information, it will be listed at the bottom of the window.

Creating a Service Request

Primavera Unifier integrates with different Oracle applications; when you create a Service Request, be sure to open the request with the proper Support team. To ensure you reach the proper Support team, enter the correct product information when you create the Service Request. Each product has its own support line.
Use the Primavera Unifier support line when you are having installation, configuration, connection, or application issues related to the Primavera Unifier.

Use one of the following support lines when you are having installation or configuration issues that do not relate to the Primavera Unifier.

- Oracle WebLogic Server
- Oracle Server
- Oracle Database Server
- Oracle AutoVue
- Oracle WebCenter Content
- Oracle Enterprise Manager
- Oracle Business Intelligence

**Keeping your Software Up to Date**

To ensure you have the latest versions of your products, be sure to download and install all available patch sets from http://support.oracle.com/.

**Finding Security-related Patches**

To get the latest information about Critical Patch Updates, visit http://www.oracle.com/technetwork/topics/security/alerts-086861.html.
Legal Notices

Oracle Primavera Unifier Administration Guide

Copyright © 1998, 2016, Oracle and/or its affiliates. All rights reserved. Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are “commercial computer software” pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate failsafe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products and services from third-parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.