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Preface

Agile PLM is a comprehensive enterprise PLM solution for managing your product 
value chain. 

Audience
This document is intended for administrators and users of the Agile PLM products.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support 
through My Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

Related Documents
Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle 
Technology Network (OTN) website 
http://www.oracle.com/technetwork/documentation/agile-085940.html contains 
the latest versions of the Agile PLM PDF files. You can view or download these 
manuals from the website, or you can ask your Agile administrator if there is an Agile 
PLM Documentation folder available on your network from which you can access the 
Agile PLM documentation (PDF) files. 

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.
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monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.

Convention Meaning
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1Introduction

This user guide provides detailed descriptions of all Agile Product Portfolio 
Management (PPM) features and explains how you can use PPM to record, monitor, 
and track progress of projects and programs.

Agile Product Portfolio Management Overview
Agile Product Portfolio Management is a web-based application that enables users to 
manage all aspects of a project or program. PPM is fully integrated with the complete 
Agile PLM suite of products to maintain a centralized view of project records and 
associated product information within the organization.

Executives use the PPM Dashboards to view portfolio data pertaining to all projects or 
programs. Portfolio data includes risks such as schedule slips, lack of resources, and 
project costs that directly contribute to the overall status of the project.

What's New in PPM 9.3.5
Agile PPM 9.3.5 introduces the following features and enhancements:

■ Gantt Chart improvements:

■ Multi-project Gantt - You can now open multiple projects in one Gantt session. 
For more information, see "Working with Multi-Project Gantt" on page 2-45.

■ Navigator - A new tool is available to allow you to easily add, remove, and 
lock/unlock projects in Gantt. For more information, see "Gantt Navigator" on 
page 2-48.

■ Filtering capability - Filter functionality is now available in Gantt. For more 
information, see "Filtering in Gantt" on page 2-44.

■ Privilege checking for editing in Gantt is now fully enforced. See "Privilege 
Checks in Gantt" on page 2-30 for more information.

■ In the Gantt Task Assignment view, the following changes have been made:

* Two read-only columns, Days Effort and Actual Hours, have been added 
to the Manage Resources table.

* A threshold line is displayed in the Resource Utilization chart to show the 
capacity of a resource/resource pool. It marks the 100% level. 

* Detailed Utilization is displayed per project in the tooltip.

* Calculation of Resource Utilization logic has changed.

For more information, see "Task Assignment" on page 2-32.
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■ Additional changes were made to improve the management of programs and 
resource balancing. These changes include:

* A view option in Comparative Gantt view that shows the variance 
between the latest loaded data from the server and real time data.

* New insertion behavior from inline editing to a pop-up window in File 
menu/toolbar. This behavior is more consistent with the context menu. 
These changes have been applied to all project data-related views, 
including Gantt, Task Assignments, Calendar, Critical Path, and 
Comparative Gantt views.

* The root project is now displayed in the tooltip of the assignment in 
Resource View.

* Added Root Parent column in the Resource Utilization View.

For documentation on the common features and enhancements introduced across 
Agile PLM in this release, see the Getting Started with Agile PLM guide.

Upgrade Considerations
During an upgrade from a previous version of PPM, data migration is necessary to 
ensure that the existing data complies with new or changed business rules.

To facilitate the data migration, a post upgrade utility is available. For information on 
using this utility, see the Agile PLM Database Upgrade Guide.

Note: The PPM post upgrade utility is not supported on WebSphere 
Application Server.

Workday settings can be configured in the aut.properties file before upgrade. For details 
of parameters to be defined, see the Agile PLM Database Upgrade Guide.

Configuration Notes
■ For Japanese and Chinese operating systems, an Agile PPM database instance can 

only be configured to use UTF-8 language encoding. Agile PPM sets the browser's 
character encoding to UTF-8, and it is not recommended to change the character 
encoding setting in the browser.

■ For information on all Agile PLM software specifications, including supported 
Java Runtime Environment, see the Agile PLM Capacity Planning Guide.

Related Documentation
Common Agile PLM functionality is not described in the PPM User Guide. The 
following manuals provide comprehensive information on all common Agile PLM 
features and administrative requirements.

■ Agile PLM Getting Started Guide

■ Agile PLM Administrator Guide

Features Summary
PPM provides visibility into all levels of project activity, and enables you to track and 
control all aspects of a project. You can use PPM features to do the following:
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■ Project Planning

■ Create projects based on existing project templates

■ Create a project

■ Create baselines for projects

■ Convert Microsoft® Project files to PPM projects to associate project 
information with related product records in Agile PLM

■ Import and export root-level information about the projects

■ Import project details from file formats such as XLS and CSV into PPM

■ Manage project schedules

■ Manage project milestones and gates

■ Resource Management

■ Assign projects and tasks to resources

■ Manage resource pools

■ Track time and effort spent on projects

■ Project Collaboration

■ Initiate and respond to project-related discussions

■ Post news and action items related to the project

■ View notifications on assignments and action items

■ Maintain a project dashboard

■ Project Tracking

■ View project summary to track overall status of a project

■ Track project costs

■ Monitor overall status of the project

■ Generate project reports for analysis

■ View notifications on assignments and action items

When to Use Web Client
Web Client is recommended for project team members who need to view information 
and add or edit data that is specific to the activities they own.

Use Web Client to:

■ View notifications and assignments

■ Manage assignments

■ Use timesheets

■ View a personalized dashboard

■ View project summary and status

■ Change workflow status

■ View reports

■ Manage subscriptions
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■ Manage content

■ Participate in discussions

Project participants use Web Client for all their activities.

When to Use Gantt Chart
Gantt chart is recommended for program and project managers, whose primary 
responsibility is to monitor and manage programs and projects.

Use Gantt chart to:

■ Assign and manage tasks and resources

■ Monitor resource utilization

■ Quickly add and edit activities, gates, and dependencies

■ View progress and modify project schedule

Project Management Objects
Project Management process involves management of schedules, tasks, statuses, 
discussions, documents, phases, gates, and resources.

At a minimum, a typical Agile PPM project consists of:

■ A root-level project

■ A series of child objects such as phases, programs, tasks, gates, or other projects.

The following table describes the various objects in the Agile PPM solution.

Icon Object Description

Project A Project is a unique set of related projects, phases, tasks, 
sub-programs, milestones, and gates that is driven by a time 
schedule with target start and end dates, and dependencies. A 
Project is the top-level object, but can also be a child of another 
project.

If the organizational practice uses Programs as the top-level object, 
to enable program creation in PPM, contact your site's Agile 
Administrator.

Program A Program is a unique set of related programs, phases, tasks, 
sub-programs, milestones and gates. Programs are driven by a 
time schedule. A Program can be the top-level object or a child 
object of another project or program.

Phase A Phase, sometimes called a stage, is a segment of a project.

Phases define the activities required to create a set of deliverables. 
When phases end, Project Managers may hold a phase exit or gate 
review to examine the completion status of each phase.

A Phase comprises activities such as tasks and gates. It derives the 
date and status information from the project elements.

Task A Task is a segment of work that one or more resources can 
complete over a period. Progress or status of a task rolls up to 
higher levels of the program. Phases, projects, programs, or other 
tasks can contain tasks.
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Programs, projects, phases, tasks and gates can be fully customized. For further 
information, see your site's Agile administrator.

Gate A gate marks a point in the project timeline that typically requires 
a review of a group of project tasks, activities, or deliverables.

Gate status is 'Closed' by default. Gate status can be set to 'Review' 
or 'Open' based on work performed in the project. The work 
performed is typically defined in the form of deliverables. If a gate 
is set to 'Review', the project can be on hold until it is opened. 
When a gate is 'opened', directly or after a review, project progress 
can resume.

Decision Gate: A decision gate is a special gate type used in 
phase-gate project methodologies. Decision gates mark a point in 
the project timeline when tactical and strategic decisions about a 
project need to be executed. Each phase of a project in a phase-gate 
model has a corresponding decision gate. Standard projects for 
New Product Development are typically five or six phases, each 
with a decision gate.

Stationary Gate: A stationary gate is a gate type used to restrict 
users from modifying critical dates on the project schedule. A gate 
is usually moved forward automatically if tasks preceding the gate 
are moved forward. If you define a gate as 'stationary', only users 
with explicit privileges to move the gate can move the preceding 
tasks forward. To learn how to define a stationary gate, see 
"Defining Stationary Gates" on page 3-4.

Note: A Gate cannot have any Activities/Gates/Milestones as its 
children, therefore a Gate cannot be imported into PPM if it has 
children.

Milestone Milestones are points in the project timeline that indicate the need 
for additional or secondary activities. Milestones can mark billing 
cycles, sub-project launch points, project metrics, or project team 
notifications. Milestones may or may not be dependent on 
deliverables.

Note: A Milestone cannot have any Activities/Gates/Milestones 
as its children, therefore a Milestone cannot be imported into PPM 
if it has children.

Deliverable A Deliverable represents a unit of work required for a project's 
success, usually fulfilled by generating a digital file. (Word 
processing documents, spreadsheet documents, PDFs, 
presentation documents, and so on.) Deliverables can also be Agile 
PLM objects and processes.

Deliverables are managed in the Content tab of a project and often 
used to control the status of tasks and gates.

 
Discussion Discussions are informal conversations specific to a project or 

program, found in the Discussions tab within the Collaboration 
tab of the project object. Discussions are frequently sub-classed 
into Risks and Issues sub-classes to capture and store all risks and 
issues related to projects.

News Information or announcements that need to be communicated to 
everyone who has access to the project object. News is a tab within 
the Collaboration tab of the project object.

Action Item Action items are created in the Collaboration tab of a project and 
used to track non-essential activities that do not impact the project 
timeline. Action items can be assigned at any level of the project 
hierarchy. Action items are tracked and available to users in the 
project's Summary page and the My Assignments page.

Icon Object Description
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Project Tree Structure
The following figure illustrates the various PPM objects in a project.

Figure 1–1 Project Tree Structure

Projects, programs, phases, tasks and gates can be customized. A 'Program' with 
multiple projects is 'Complete' only if all the projects within it are 'Complete'. Each of 
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these projects has its own set of phases and gates. The following figure illustrates 
'Projects' within a 'Program':

Figure 1–2 Projects within a Program

If your organization uses 'Programs' instead of 'Projects', contact your site's Agile 
Administrator to modify settings in Java Client.

An example of a project tree structure as seen in the navigation pane:
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Figure 1–3 Project Tree View in Navigator

PPM Process Flow
The following flowchart shows typical PPM processes and workflow participants.

Figure 1–4 PPM Process Flow
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Where to Find Information

Your role... Where to find information…

Project or Program 
Management Office

"Setting Up Project Management Processes" on page 3-1.

"Best Practices" on page A-1.

Project Manager "Creating and Managing Projects" on page 4-1.

"Working with Microsoft Project" on page 7-1.

"Import and Export" on page 9-1.

"Tracking Projects" on page 6-1.

Resource Pool Owner "Creating and Managing Projects" on page 4-1.

Task Owner, Resource "Participating in Projects" on page 5-1.

Administrator "Configuring Product Portfolio Management" on page 10-1.

Any PPM User "Understanding the Interface" on page 2-1.

"Best Practices" on page A-1.
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2Understanding the Interface

As a PPM user, you need to be familiar with the following:

■ Using PPM-specific tabs in the Dashboard

■ Working with PPM Notifications

■ Working with My Assignments

■ Working with Timesheets

■ Accessing project information

■ Using the Navigator

■ Working with Gantt Chart

Home Page
The Agile Home page provides access to Dashboard, Notifications, Workflow 
Routings, and My Assignments. You can configure the application to view timesheets. 
You can set the Home page to display one of these tab pages as your preferred start 
page. For more information, refer to the Getting Started with Agile PLM guide.

If you choose one of the dashboard tabs as your preferred start page, that dashboard 
tab page displays when you click the Home page icon in the top pane.

To view the Home page while you are working on a project page, click the Home icon.

Quick Links
Quick Links, at the top of the Home page, is a list of up to ten links that you use 
frequently. You can define and edit your own Quick Links list. Your Quick Links list 
can include predefined Agile PLM system links, saved searches in your Personal 
Searches folder, or bookmarks in your My Bookmarks folder.

Home Page Inbox Tabs
As information passes through the Agile system, users receive news of status changes, 
requests, and other notifications through email. Users with different roles and 
privileges receive different notifications. As soon as you log in to the Web Client, it is a 
good practice to view the information available for your perusal on the Home Page 
Inbox tabs.

■ Dashboard Tab -Enables you to view and manage information across all your 
projects. For more details on dashboard features, see "Dashboard" on page 2-2.
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■ Notifications Tab -Lists notifications that inform you of some action or process 
that has taken place, or requests that you can accept from the My Assignments tab. 
In addition, this tab lists the action items or activities for which you can accept or 
decline ownership from the My Assignments tab. It is a recommended practice to 
delete the notifications after you have read them.

■ Workflow Routings Tab -Lists the routable objects that require your review or 
action. Click the object number in the table to open a routable object.

■ My Assignments Tab -My Assignments Tab lists project leaf node objects or action 
items assigned to you which are not yet complete. You can accept or decline a 
request or ownership. Click the Quick View callout that appears when you 
position your mouse cursor over an object, to view the details of the object.

■ Timesheet Tab -Enables timesheet entry by assigned resources on a project. It 
enables you to track reported time data to ascertain resource utilization and 
related costs. This tab is visible only if enabled by your Agile administrator.

Dashboard
The Dashboard is a highly configurable set of views that enables users to track and 
manage the information available in the Agile PLM system.

You can create an unlimited number of dashboard tabs to categorize and display the 
content you want. Access to these tabs can be restricted through roles and privileges. 
The data that you want to view can be retrieved from different sources, and rendered 
in charts, tables, and other forms.

Dashboard tabs must be created and configured in Agile Java Client by an 
administrator. You can view and personalize the tabs that are made visible in Agile 
PLM Web Client for your use.

For details on configuring Dashboard views, see the Agile PLM Administrator Guide.

The dashboard enables PPM users to view and manage information across all projects. 
You can use the dashboard to obtain:

■ Executive-level view of key information for all your projects based on your roles 
and privileges

■ User-level information about your own activities and tasks

■ Resource utilization reports

All users can use the dashboard to access reports and view consolidated information. 
See also "Reports" on page 6-5.

Dashboard Tabs
The dashboard comprises:

■ Default Tabs that enable you to select the view: Executive, Projects, Resources, 
Financial, My Stuff, Optional Tab 1, and Optional Tab 2.

■ User-configured tabs that display customized information in tabular or chart 
formats, based on preferences set up by an administrator.

To view user-configured tabs, you must have the Dashboard Tab View privilege 
assigned to you, and this privilege must be applied to these tabs within the Agile Java 
Client.

■ Widgets within each tab that present information relevant to that view. For 
example, in the My Stuff tab, the widgets represent the current user's project 
activities: My Discussions, My Documents, My Action Items.
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■ The Dashboard Filter icon in every table enables you to filter data within the 
widgets to create customized views.

The information you can view in the Executive, Projects, and Financial tabs is from 
root projects for which you have the Read and Discover privilege.

If you are an Executive, you have global privileges. You can view all root-level projects 
that contain matching values for the dashboard category fields. By default, these fields 
are labeled Project Type, Region, Division, Customer, Launch Year, Product Line, 
Category 7 to Category 24, and Program. These are multi-select list fields that can be 
relabeled and configured within the Administration > General Info tab in the Agile 
Java Client.

For information on how to configure optional dashboard tabs, see the Agile PLM 
Administrator Guide.

Accessing Gantt from the Dashboard  

You can launch Gantt from Dashboard from the following tables:

■ Executive tab >Project Status and Financial

■ Project tab > Project Status

■ Financial tab >Financial

To launch Gantt, select one or more project rows, click the list drop-down arrow > 
Gantt Chart, and select the launch mode. Root projects related to the selected projects 
via the PLM Reference field are launched. See "Gantt Chart" on page 2-27 for more 
details about single and multi-project Gantt.

Configuring Dashboard Tab Widgets
The Dashboard Filter icon at the top of each widget enables you to filter the data in the 
widget to show only the information that is most relevant to you.

You can filter the dashboard category fields that display within each tab widget 
according to your business requirement.

For example, a functional manager who owns several resource pools might want to 
view only off-track tasks assigned to people in certain pools. An executive might set 
the dashboard to show all the projects, programs, issues, gates, financial summaries, 
and resources that apply to a division and region, or view a specified subset. Once the 
dashboard settings are entered, you only see information that satisfies the specified 
settings.

You can use the dashboard category fields to rapidly classify tasks and to slice data for 
reporting purposes. The default Dashboard category fields are Project Type, Region, 
Product Line, Division, Region, Launch year, Program, Category 7 to Category 24.

The values that you set at the root project level are applied down the hierarchy. For 
example, if you set a particular value for Division at the root project level, all the tasks 
within the hierarchy are also set to the same value. These fields are ideally used for 
Customer, Market and other attributes that are relevant at the top level of the project.

If a root project has a value set to "All," then, by design, it will appear in all views no 
matter what value is selected in the configuration view for that field.

Executive Tab
The Executive tab provides portfolio data for the executive who needs to monitor 
projects and see information rollups by type of project. It provides a cross-section of 
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information on projects where you can see the major risks in terms of schedule, 
resources, and cost.

The Executive tab contains data only if you have Executive role, or have Read 
privilege for root-level projects.

The widgets in the Executive tab are:

■ Project Status - Provides a graph of all active projects the user has configured to 
view, showing the overall status of each (that is, On Track, Needs Attention, Off 
Track). For each type of status displayed, the widget shows the percentage of 
projects with the specific status.

To display the number of projects that comprise a segment, place the mouse cursor 
over that segment of the chart.

To display the Projects tab with a particular segment of projects selected in all 
windows, click that segment.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed or 
Template, or projects that are archived or soft-deleted.

You can also open projects in Gantt from within the table view in Project Status.

■ Resource Pool Allocation - Displays a table showing the names of available 
resource pools and associated data, filtered by the settings in the dashboard filter.

The table displays the following information for each resource pool:

– Pool Name- The name of the resource pool.

– Overdue - The number of Off Track projects which have a resource pool or 
pool members assigned.

– Allocation - Displays a red square if the pool or any of its members are 
over-allocated for a project.

Pool members who do not have current assignments are not counted. Resources who 
are not assigned to any resource pool do not appear on the dashboard.

To view the Resource Pool Utilization Report, click the icon in the last column of the 
Resource Pool Allocation widget in the dashboard.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed or Template, or 
projects that are archived or soft-deleted.

■ Financial - Displays a table showing cost rollups for the root projects that you 
have access to view. The Financial tab in the Executive view also shows the same 
table that is presented in the Financial View. See "Financial Tab" on page 2-6.

Projects Tab
The Projects tab displays gate progress, status, and discussions specific to the projects 
for which you have access as the owner, resource, or team member. The various 
widgets in the Projects tab are:

■ Project Status - Displays all projects to which you have access (subject to the table 
filters). It includes the root project name, status, start date and end date.

To change the sort order, click a column heading.

To open a Project object, click its name. The icon adjacent to the project name 
indicates the status of the project, such as On Track or Needs Attention.
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■ Gate Status - Displays the gates for each active project, their status and scheduled 
due date. (The number required is derived from the number of deliverables listed 
on the Content tab plus the number of dependencies to the gate.)

To open a project or gate, click its name.

■ Project Discussions - Lists the open discussions, specific to the projects for which 
you have access rights. The Open Date denotes the date on which the discussion 
was initiated. Use the Priority drop-down list to filter the discussions by priority.

Resources Tab
The Resources tab provides resource pool owners and executives with information 
about the resources they manage. Pool managers can see the status of activities 
assigned to their resources, the priority issues related to their resources and the list of 
off-track activities assigned to their pools. They can also see the current resource loads 
across the enterprise.

The various widgets in the Resources tab are:

■ Resource Allocation - Shows each resource pool's projects and status, noting items 
that are in Pending, Assigned, or Overdue statuses. It also notes resources that are 
over-allocated.

A pending activity or gate is one that has been delegated to a resource pool, but 
has not yet been assigned to a user in that pool.

The number of overdue items is a count of all activities or gates that are past the 
due date, regardless of whether they are assigned to users.

To edit status for a resource pool (add or remove resources, or create a report), 
click its name.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed or 
Template, or projects that are archived or soft-deleted.

■ Open Discussions by Resource Pool - Shows the discussions for each resource 
pool. You can select priorities to display from the Priority list. Click the name of a 
project to open it. Once the project object is open you can go to its Discussions tab, 
and view associated issues. (For further information on the Discussions tab, see 
"Discussions Table" on page 4-29.

If there is a discussion thread, only the top level issue is displayed.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed or Template, 
or projects that are archived or soft-deleted.

■ Resource Pool Activity Status - Shows Off-Track items assigned to pool members 
of pools that you own, noting Scheduled due date, Project name, and Scheduled 
End date. To view and update off-track resource pool activities, click the Resource 
pool name.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed, or projects 
that are archived or soft-deleted.

■ Resource Pool Utilization - Shows a graph of resource pool utilization by project, 
enabling a pool manager to see where resources are allocated or over-allocated.

To view project name and percent utilization of resources, place the mouse pointer 
over each chart segment.
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To view team data, click the chart segment of interest. This opens the 
corresponding project object in the Team tab.

The data in this window does not include projects that are in the Completed or 
Canceled states, projects with a Project State field setting of Proposed, or projects 
that are archived or soft-deleted.

Financial Tab
The Financial tab shows charts of capital expense, labor cost, and fixed cost for each 
root project available. The Financial tab also shows the same table that is presented in 
the 'Financial' widget in the Executive tab.

To configure which reports appear in the Financial tab, use Tools and Settings > 
Administration > Dashboard Configuration.

To select the projects to be considered for each chart, use the Dashboard filter in the 
chart.

You can minimize, maximize, or close charts in the tab view. When a chart is closed, 
the Add Content list appears. Use this list to re-open any chart that you have closed.

My Stuff Tab
The My Stuff tab displays the Documents, Discussions, and Action Items assigned to 
the logged in user. The widgets in this tab are:

■ My Action Items - Displays all your Action Items by Status, Creator, and Due 
Date. The name of the project or discussion to which the Action Item is associated 
appears as a link in the Belongs To column. Click the link to view the associated 
object. To view the Action Item, click the corresponding link in the Subject 
column.

■ My Documents - Lists all the project-related documents that you own with the 
name of the Root Project, Project Name, Folder Number, and the File Name. To 
open a file, click the folder number and then click the Files tab. Alternatively, you 
can click the file name to view the document.

■ My Discussions - Lists all the discussions you have created for the selected set of 
projects, showing the Subject, Most Recent Message, and the Date for each. You 
can click the Subject link to view and reply to a discussion.

Optional Tabs
You can configure Optional Tab1 and Optional Tab2 to display reports based on your 
customized queries in each table. If you have the privilege to configure these tabs, a 
Configure button appears in the middle of each table in the Optional Tabs page.

The fields that are available for display are configured in Java Client by an 
administrator. For more information on configuring Optional tabs in Java Client, see 
the Agile PLM Administrator Guide.

PPM Notifications
Within Product Portfolio Management, default notifications are triggered and sent to 
appropriate recipients when you perform various actions on a project object. For 
example, a notification can inform you of schedule or status changes, an activity 
assigned to you, or a project that needs your approval, based on your role.

Event-based notifications can also be configured in Java Client according to your 
requirement. Such notifications can be triggered by event-based subscriptions.
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For detailed information on event-based notifications, configuring notifications, and 
creating custom notifications, see the Agile PLM Administrator Guide.

Note: Notifications are generated only when enabled in Java Client.

Default PPM notifications are related to any of the following:

■ Ownership, Assignment or Delegation

■ Schedule Change

■ Cost

■ Workflow

■ Discussions

■ Subscriptions

■ Setup

Cost Impact Notifications  
Notification Received By When...

Task Overbudget Notification Task Owner The cost of executing a task 
exceeds the budget allocation 
for it.

Actual Time exceeds 
Budgeted time to Object 
Owner Notification

Project owner Resource(s) allocated to a task 
have exceeded the budgeted 
time to complete the task.

Actual Time exceeds 
Budgeted time to Pool Owner 
Notification

Resource Pool Owner Resource(s) from the 
recipient's resource pool have 
exceeded the budgeted time to 
complete the allocated task.

Discussion-related Notifications  
Notification Received By When...

Discussion Action Item 
Assignment Notification

Discussion 
participant/program resource

An action item associated 
with a discussion is assigned 
to the recipient.

Discussion Create Notification Any user added to the Notify 
list during discussion creation.

A new discussion object is 
created successfully.

Discussion Send Discussion 
participant/program resource

A discussion is sent to the 
recipient.

Reply Create Notification Discussion participants A user replies to a message 
within a discussion thread.

Reply Update Notification Discussion participants A user updates a reply 
message within a discussion 
thread.
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Other Notifications  
Notification Received By When...

Relationship Promotion 
Failure Notification

Program Owner Automatic promotion of a 
project status fails for any 
reason, for example, the 
non-completion of a required 
field.

Relationship Notifications > 
Subscription Notification

Notification subscriber Field tags within a 
subscription notification is 
changed or updated.

Ownership, Assignment, or Delegation Notifications  

The following notifications are related to ownership, assignment, or delegation of a 
project object.

Notification Received By When...

Project Object Delegation 
Notification

Delegated user A Project activity is delegated 
to the recipient.

Action Item Assignment 
Notification

Assigned user An action item is assigned to 
the recipient.

Project Owner Assignment 
Notification

Project owner The recipient creates a project 
from a template or is assigned 
ownership of a project during 
project creation from a 
template.

Assignment of an activity to a 
resource.

Assigned user An activity is assigned to the 
recipient.

Accept activity assignment Project Owner The assigned resource accepts 
the activity assignment.

Reject activity assignment Project Owner The assigned resource rejects 
the activity assignment

Project Object Delegation 
Accept Notification

Project Owner A resource accepts an activity 
delegation.

Project Object Delegation 
Reject Notification

Project Owner A resource declines an activity 
delegation.

Notification for Project Object 
Delegation

Delegated user A project activity is delegated 
to the recipient and must be 
accepted or rejected from the 
My Assignments tab.

Notification for Activity 
Object Owner Change

New Activity Owner Ownership of an activity is 
changed on the General Info 
tab.

Pool Owner Project 
Delegation Notification

Resource Pool Owner An activity (with or without 
child activities) is delegated to 
a resource pool.

Notification for Activity 
Assignment to a Resource

Resource Pool Member An activity is assigned to the 
recipient.

Pool Owner Project 
Delegation Request

Resource Pool Owner A child activity of a template 
project is delegated to the 
recipient's resource pool and 
must be accepted or rejected 
from the My Assignments tab.
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Schedule Change Notifications  

Pool Owner Project 
Delegation Accept 
Notification

Project Owner A resource pool owner accepts 
an activity assignment.

Pool Owner Project 
Delegation Reject Notification

Project Owner A resource pool owner rejects 
an activity assignment.

Notification to Resource pool 
owner- Assignment of 
Activity

Resource Pool Owner An activity is assigned to a 
resource in the recipient's 
resource pool. For proposed 
projects, this can be controlled 
using a SmartRule.

Gate Action Item Assignment 
Notification

Assigned user An action item associated 
with a project gate is assigned 
to the recipient.

Gate Object Delegation Delegated user A project gate is delegated to 
the recipient.

Gate Object Delegation Accept 
Notification

Gate Owner A user accepts a gate object 
delegation.

Gate Object Delegation Reject 
Notification

Gate Owner A user rejects a gate object 
delegation.

Notification for Gate Object 
Delegation

Delegated user A program gate is delegated 
to the recipient and must be 
accepted or rejected from the 
My Assignments tab.

Notification for Gate Object 
Owner Change

New Gate Owner Ownership of a Gate is 
changed on the General Info 
tab.

Notification Received By When...

Parent Project Schedule 
Change Notification

Parent Program Owner The scheduled date of a 
parent activity is changed. 
Applies only when one or 
more baselines are created for 
the tree.

Predecessor Project Schedule 
Change Notification

Successor Program Owner The scheduled dates of a 
predecessor activity is 
changed, resulting in changes 
to the scheduled dates of the 
successor activity.

Microsoft Project Sync Change 
Notification

Program Owner Changes made to a PPM 
project from Microsoft Project 
are synchronized, resulting in 
schedule date changes. 
Applies only when one or 
more baselines are created for 
the tree.

Child Activity Reschedule 
Notification

Activity Owner The scheduled date of a child 
activity is changed because of 
changes to the scheduled date 
of the parent activity. Applies 
only when one or more 
baselines are created for the 
tree.

Notification Received By When...
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Setup-related Notifications  
Notification Received By When...

Project Creation Notification Project Creator Project creation is run as a 
background process and a 
new project is created 
successfully.

Activity Send Any user. An activity is sent to the 
recipient.

User Disabled Notification Resource Pool Owner A user who was assigned as a 
resource to an activity from 
the recipient's resource pool 
has been disabled by the 
system.

Workflow-related Notifications  

Notification to Activity 
Owner for Project Schedule 
Date Change due to addition 
of Predecessor

Activity Owner The Schedule Date of an 
activity has changed because 
it is now dependent upon a 
preceding activity.

Project Schedule Change 
Notification - addition of gate 
predecessor

Activity Owner The Schedule Date of an 
activity has changed because 
it is now dependent upon a 
preceding gate.

Notifications for Calendar 
Update

Activity or Gate Owners A calendar used in the project 
is updated, affecting the 
project schedule. 

Notification Received By When...

Project Status Promotion, 
Observers/Notifiers

Designated observers or users 
on the Notify list.

There is a change in activity 
status.

Project Status Promotion, 
Approvers

Designated approvers. There is a change in activity 
status that requires approval.

Approve Project, Notifiers All users on the Notify list for 
the activity.

The activity has been 
approved to move forward in 
the workflow.

Project Approve Activity, Add 
Approver

Designated approver. The recipient is added as an 
approver for a project or 
activity.

Project Approve Activity, Add 
Observer

Designated observer. The recipient is added as an 
observer for a project or 
activity.

Project Approve Activity, 
Remove Approver

Designated Project Approver The recipient is removed from 
the list of approvers for a 
project or activity.

Project Activity Comment Program Owner A user has added a comment 
to an activity.

Project Activity Promotion 
Failure, Reject

Program Owner A required approver rejects a 
project status promotion 
request.

Notification Received By When...
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Workflow Routings Tab
The Home page Workflow Routings tab lists routable objects that require your 
attention. For example, your Workflow Routings table may contain tasks that you can 
choose to accept.

The workflow routings are a combination of base classes and actions that define the 
kind of attention on the routed object. In PPM, the routable objects are Activities or 
Gates in the Project Class.

The workflow routings tab consists of routable objects that require your:

■ Approval

■ Acknowledgment

■ Acceptance or Rejection

■ Review

■ Action

This tab includes features that allow you to review your routing objects quickly and 
efficiently. For detailed information on Workflow Routing tab, see the Getting Started 
with Agile PLM guide.

My Assignments
The Home page My Assignments tab lists Activities and Action Items for which you 
are responsible. The My Assignments tab provides a set of tools that allow you to 
efficiently work with your assignments. You can sort the assignments table rows, or 
select one or more assignment rows in the table, and then perform an action on the 
selected assignments. For example, you can accept or decline a project activity 
assignment, or flag an assignment for easier tracking.

The Home page My Assignments tab table includes:

Project Activity Promotion, 
Approve

Program Owner A required approver approves 
a project status promotion 
request.

Gate Status Promotion 
Observers/Notifiers

Designated Gate Observers There is a change in gate 
status.

Gate Status Promotion; 
Approvers

Project /Gate Approvers There is a change in gate 
status that requires approval.

Project Approve Gate; Add 
Approver

Designated Gate Approver The recipient is added as an 
approver for a gate.

Project Approve Gate; Add 
Observer

Designated Gate Observer The recipient is added as an 
observer for a gate.

Project Approver Gate; 
Remove Approver

Designated Gate Approver The recipient is removed from 
the list of approvers for a gate.

Project Gate Comment Program Owner A user adds a comment to a 
project gate.

Project Gate Promotion 
Failure Reject

Program Owner A required approver rejects a 
gate status promotion request.

Project Gate Promotion; 
Approve

Program Owner A required approver approves 
a gate status promotion 
request.

Notification Received By When...
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■ Activity objects where:

■ The activity is In Process. The workflow status type is not Complete or 
Canceled.

■ The activity's Project State attribute is set to Active. Proposed or Template 
activities are not included.

■ You are the owner of the activity and the Delegated Owner field is blank. If 
you have delegated ownership, the Delegated Owner field contains the name 
of the delegated owner until the activity is accepted or declined.

■ You are the delegated owner of the activity.

■ You are a resource on the Team tab of the activity and your allocation is 
greater than 0%.

■ Action Items where:

■ The action item is assigned to you and it is not Complete or Canceled.

■ The action item is assigned to you and it has been accepted.

■ The action item is assigned to you and it has not been declined.

■ You are the creator of the action item and it has been declined by the assignee.

Project Assignments  

Projects that display in your My Assignments tab are:

■ Active root-level projects that have no child objects, for which you are the owner.

■ Leaf-level projects for which you are the owner.

■ Projects that you have delegated to a resource from the Actions> Delegate menu.

The project is displayed until the assigned resource accepts the action item. Once the 
resource accepts the action item, it disappears from your My Assignments list and you 
receive a notification in the Notifications tab.

My Assignments Table  

Your Agile administrator determines which columns appear in the My Assignments 
table. The displayed attributes can be enabled or disabled only through the Admin > 
System Settings > My Assignments node in Agile Java Client Administrator. You can, 
however, rearrange or filter the defined columns as you want, using the Personalize 
option. For detailed information on how to manage assignments, see the Getting 
Started with Agile PLM guide.

Creating Personalized Views  

The Personalize button enables you to create customized views of the content that is 
displayed in page tables. Once you create views, these are listed as options for your 
selection in the Views drop-down list. For details on using the Personalize options, see 
the Getting Started with Agile PLM guide.

Timesheet
The Timesheet feature helps Agile PPM customers address critical business needs, 
such as the accurate calculation of resource time and associated labor costs for a 
project. This feature helps authorized users to do the following:

■ Record the number of hours worked against each assigned task, on a daily or 
weekly basis.
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■ View and administer all timesheets recorded in the system.

■ Derive resource time data for reports and analysis.

Note: The timesheet reflects the working or non-working days as 
defined in the project or activity calendar in use. Non-working days 
set as exceptions and regular weekends are shown in gray. Users can 
enter time for all days regardless of whether they are defined as 
working or non-working days.

Timesheet entry and management is restricted by certain role, privilege, and 
SmartRule settings in Java Client. For details, see the Agile PLM Administrator Guide.

Timesheet Tab Tools

Tool Description

More >Print Prints the selected timesheets. Click More > 
Print to print the timesheet.

More >Timesheet Search Enables users with appropriate privileges to 
search and view all timesheets recorded in the 
system. Click More > Timesheet Search to 
search for time sheets. For more information, 
see "Searching for Timesheets" on page 4-20.

More > Fill-down Copy the value from a cell to the 
corresponding cells in all rows following the 
selection.

More > Fill-down (selected cells) Copy the value from a cell to all the selected 
cells. The value of the first cell in the selection 
is copied into all the selected cells.

More > Fill-up Copy the value from a cell to the 
corresponding cells in all rows preceding the 
selection.

More > Fill-up (selected cells) Copy the value from a cell to all the selected 
cells. The value of the last cell in the selection 
is copied into all the selected cells.

Views Enables you to select from a list of defined 
timesheet views. You can create views using 
the Personalize options.

Personalize Click Personalize to set the Table filters. You 
can configure the timesheet display to show 
selected attributes such as the associated 
activity's Name, Number (manually created or 
auto-generated activity number), Description, 
Parent, Parent Number, or Root Parent.

If you have privilege to view timesheets of 
other users, you can create a View to 
configure and view other users' time sheets.

This filter works the same as in My 
Assignments. For detailed information about 
using the filter, see the Getting Started with 
Agile PLM guide.
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Project Page
The project page opens when you click any project object. From this page, you can 
record and update information such as schedule, cost, status, resources, content, and 
discussions about the project.

From the project page, you can:

■ View details of a project - see "Viewing Project Details" on page 2-14.

■ View project summary - see "Viewing Project Summary" on page 2-15.

■ View the project as a Gantt Chart - see "Launching Gantt" on page 2-29.

■ Lock or unlock projects - see "Multiple Users Editing the Same Task" on page 4-5.

■ Change the status of a project-see "Changing Workflow Status" on page 5-4.

■ View the project tree - Click the Navigator button to show the project tree instead 
of the folder structure, in the left pane.

■ Perform various actions on a project - see "Actions Menu" on page 2-25.

■ Personalize table views - see "Creating Personalized Views" on page 2-12, and 
"Personalizing Views for Content" on page 3-11.

Viewing Project Details
The Details View is displayed by default if you click a project object that is at the 
lowest level in the hierarchy (no sub-activities). If you click an object that has 
sub-activities, it opens in the Summary view. The Summary view is not available for 
objects without sub-activities. While viewing a project, you can click the Details View 
or Summary buttons to toggle between the two views.

You can view and manage project-related objects from the following tabs or pages 
within the Details View.

Tab Tasks

General Info View and edit general information about the 
project, including activities, status, and other 
attributes configured in Administration. See 
"Viewing General Information" on page 2-19.

Schedule Manage the schedule of individual activities 
within the project, create baselines, and 
analyze the impact of changes. See "Managing 
Schedules" on page 4-21.

Dependencies Create and manage dependencies between 
various project-related activities. See "Creating 
and Editing Dependencies in Web Client" on 
page 4-23.

Team Manage resources for a project. See "Managing 
Resources" on page 4-10.

Content View and manage all project-related content, 
including deliverables. See "Managing 
Content" on page 3-7.

Workflow View workflows and sign off, and assign 
approvers, observers, and notifiers as 
necessary. 
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Viewing Project Summary
When you first open a project which has sub-activities the Summary view displays. (If 
the project you open does not have sub-activities, then the Details view appears.) The 
Summary view is a consolidated view of project information. Executives, task owners 
and project managers can use this page to quickly review current information, status, 
and health of a project. This view can comprise all parent-level objects (projects, 
phases, and tasks) that have child activities. This view is not available on leaf-level 
activities and gates.

The Summary page contains several 'widgets'. Each widget provides users with 
customized information and action buttons for a specific aspect of the project, as 
configured by an administrator. For example, a Project Gates widget may provide 
users visibility into the status of the project gates (milestones) for that project and 
deliverables associated with those gates. An Upcoming Activities and Action Items 
widget may list upcoming activities and provide an Add button that you can use to 
add an action item to be performed for an activity.

To configure the Summary view, you need appropriate privileges. For details on 
privileges and summary page configuration steps, see the Agile PLM Administrator 
Guide.

Collaboration Create or join project-related discussions, view 
action items, share news and information. See 
"Managing Discussions" on page 4-29.

Attachments View, edit, and manage attachments that are 
required for project execution. See "Working 
with Attachments" on page 2-24.

History View project history. See "Viewing History" on 
page 2-25..

Tab Tasks
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Figure 2–1 Project Summary Page

Summary Page Actions
You can perform the primary actions required on the project directly from the 
Summary view.

Most widgets contain links to the listed objects. You can use these links to navigate to 
the appropriate tab of the object and perform necessary actions. For example, in the 
Project Gates widget, you can click the name of the Gate to modify the details.

The contents of each widget and the actions that you can perform within each are 
explained in the table below.
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Widget Description Actions Available

Project Summary A quick overview of the 
project. Displays data for 
attributes associated to project 
activities, as configured by an 
administrator. Examples of 
the attributes are Name, 
Description, Status, Scheduled 
Start date, and Scheduled End 
date

Add image - Insert an image 
file from your local drive. 
Click Add Image to browse 
and select an image file from 
your local drive. The image 
file is automatically resized if 
it exceeds the allotted space 
and resolution.

Replace Image - Replace the 
current image file with 
another.

Image editing options are 
available only to root project 
managers, and only on the 
root project.

Edit - Edit the attribute values 
displayed within the widget. 
You must have Modify 
privilege to edit these values. 
For details, see the Agile PLM 
Administrator Guide.

Upcoming Activities and 
Action Items

Helps you keep track of 
immediate requirements. Lists 
project activities and action 
items that are either overdue, 
or will be due within a 
specified time frame. You can 
view leaf-level project objects 
(including gate sub-classes) 
that are in Not Started or In 
Progress states, and Open 
Action Items associated to the 
Activity being viewed and its 
child activities. Table columns 
are sortable; by default these 
are sorted by Due Date.

Add Action Item - Create a 
Action Item for the activity 
being viewed currently. Click 
Add Action Item to open a 
dialog where you can create 
the new action item.

Show -Filter the list using the 
options within the Show 
drop-down list to display 
upcoming action items and 
activities, or items that need 
your immediate attention. For 
example, you can use the My 
Activities and Action Items 
list item to filter the list by 
items for which you are the 
assigned owner. After 
selecting an option, you can 
additionally narrow down the 
results by entering a number 
in the due in - days field. The 
default value in this field is 7 
(days).
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Recent Discussions Displays a list of recent, open 
discussions that occurred 
within a specified time frame. 
When you click a row to select 
a discussion, the discussion 
thread displays in the bottom 
pane of the window as a 
preview.

Add - Create a discussion to 
be associated with the current 
Activity. Click Add to open 
the Add Discussion wizard 
and enter discussion details. 
You can select the list of users 
you want to include in the 
discussion and notify them.

Join - Join an existing 
discussion. Select the row of 
the discussion you want to 
join and click Join to join the 
discussion.

Reply - Reply to a discussion 
message. Click Reply on the 
right-hand side of the selected 
discussion row to open a 
dialog where you can enter 
your response. You can edit 
the subject of the message if 
you want. By default, the 
response will be sent to all 
users currently included in 
the discussion. You can edit 
the Notify List field in the 
dialog to change the list of 
users who will receive the 
response.

Project Gates Displays the list of Gates and 
their due dates.

If you have created multiple 
Gate subclasses to establish 
milestones, you can configure 
this widget to display the 
Gate subclasses you want to 
view. For details, see the Agile 
PLM Administrator Guide.

Quick Navigation - Click the 
name of a listed gate to 
navigate directly to the 
General Info tab view of that 
gate.

Important Content Displays a list of content 
objects that were added to the 
Important Content view from 
the Content tab. See "Working 
with Project Content" on 
page 4-7.

Quick Navigation - Click the 
content object name to 
navigate directly to that 
General Info tab for that 
object.

Project News Displays project-related news 
to keep team members and 
resources informed about 
project information.

Add - Click Add to open a 
dialog where you can create a 
news item related to the 
activity currently being 
viewed. You can add a subject 
and news text.

Remove - Select a news item 
and click Remove to remove it 
from the widget. You can 
multi-select items in the list to 
remove them.

Widget Description Actions Available
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To toggle between the summary view and a detailed view of the project, click 
Summary or Details View as appropriate.

Viewing General Information
The General Info tab contains Activity and Status information, and displays 
information for the fields listed in the table. Fields which contain information that is 
compiled or rolled up from other fields are not editable.To edit fields, click the Edit 
button. You can make changes in the editable fields, and click Save to save the 
changes, or click Cancel to exit without saving.

Team Contact Info. Displays the team members 
associated with the selected 
activity and provides contact 
information for those team 
members.

Click the name of the team 
member to navigate directly 
to the Team tab of the current 
activity.

Send Email - Send a 
notification to a team member 
whose name appears as an 
attribute within the widget. 
Click the Email icon next to 
the username to open a 
comments dialog box, where 
you can enter comments and 
then send these as a 
notification to the team 
member.

Field Contains...

Schedule Information that enables you to quickly track 
program progress. Displays the targeted start 
and finish dates. Also displays the total 
duration between the targeted start and finish 
dates.

The default Start time stamp is 08:00:00 A.M 
and default End time stamp is 05:00:00 P.M. 
However, you can manually edit the End time 
stamp, if required.

You cannot edit the Start time stamp to a value 
lesser than 08:00:00.If you create the project at 
07:00:00 A.M, the Start time stamp displays 
08:00:00A.M.

The value of the default time stamp is based 
on the value set for Working hours 
configuration in the configuration file 
(agile.properties) during Agile PLM installation.

Estimated Information that enables you to track when 
overdue items will be delivered.

Actual Actual varies from schedule if you are ahead 
of or behind targeted project dates.

Widget Description Actions Available
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Variance in Work Days Start Variance, Finish Variance, and Duration 
Variance are displayed for Estimated, and 
Actual dates, compared with Scheduled dates. 
Variances are displayed in either Work Days 
or Calendar Days, or both Work and Calendar 
days.

Your Agile administrator determines which 
information is displayed in the summary table 
on the General Info tab.

Number The Autonumber assigned to the project 
object.

Activities Type Displays whether the activity is a project, 
program, phase, or task.

Owner The project owner.

Name The name of the activity.

Description Text that describes the project. The maximum 
length is set by the Agile administrator.

Root Parent A link to the root parent object.

Parent A link to the parent object.

Project State Indicates the type: Active, Proposed, 
Template. Only an active project can undergo 
changes in workflow status.

Audit Score The audit score for the activity. See "Audit 
Values" on page 2-23.

Weight Weight assigned to the activity. 

Weighted Score A calculated score based on the audit score 
times the weight. 

Status Indicates the workflow status of the project.

Rollup Health Status Indicates whether the health status rollup is 
selected or not.

Cost Status Denotes the cost status for the activity. This 
value is a selected value for the leaf object and 
a rolled-up value for a parent object.

Resource Status Denotes the resource status for the activity. 
This value is a selected value for the leaf object 
and a rolled-up value for a parent object.

Quality Status Denotes the quality status for the activity. This 
value is a selected value for the leaf object and 
a rolled-up value for a parent object.

Lock User Name of the user who is currently using Gantt 
Chart or Microsoft® Project to modify the 
project. When a user launches either Gantt 
Chart or Microsoft Project, the activity is 
automatically locked to prevent any other user 
from editing the project in PPM.

Workflow Identifies the object's assigned workflow.

Schedule Status The schedule status of the activity.

Field Contains...
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Overall Status An overall status of the activity. This value is 
calculated based on either selected or rolled 
up-values for cost, resource, quality, and 
schedule. It denotes the worst of these status 
values (cost, resource, quality, and schedule).

Project Type Dashboard field. May be renamed during 
implementation.

Region Dashboard field. May be renamed during 
implementation.

Division Dashboard field. May be renamed during 
implementation.

Product Line Dashboard field. May be renamed during 
implementation.

Customer Dashboard field. May be renamed during 
implementation.

Launch Year Dashboard field. May be renamed during 
implementation.

Global Controls whether the project is available to all 
executives or not.

Actual Labor Cost The Labor cost incurred on the project as on 
date, based on the actual work done on the 
project.

Budgeted Labor Cost The intended Labor cost for the project.

Estimated Labor Cost to Completion The cost of Labor for the entire project which 
is calculated based on the change in Project 
cost or plan, as the project progresses.

Actual Fixed Cost The Fixed Cost incurred on the project as on 
date, based on the actual work done on the 
project.

Budgeted Fixed Cost The intended Fixed cost for the project.

Estimated Fixed Cost to Completion The fixed cost for the project which is 
calculated based on the change in the project 
costing or plan as the project progresses.

Actual Capital Expenses The capital expenses incurred on the project as 
on date.

Budgeted Capital Expenses The intended capital expense limit on the 
project.

Estimated Capital Expenses to Completion The estimated capital expenses for the project 
which varies based on any change in the fixed 
assets of the project.

Actual Time (In Days) Days Effort is calculated at the rate of 8 hours 
per day and displayed as Actual Time (In 
Days). Each day is calculated as a bucket of 8 
hours. For example, if actual hours worked is 
24, Actual Time (In Days) is calculated as 3 
days. If actual hours worked is 25, it is 
calculated as 4 days.

Budgeted Time (In Days) The preallocated time in days for a project to 
reach completion.

Field Contains...
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Estimated Time to Completion The approximate time that is required for the 
project to reach completion, by the progress in 
project.

Category fields Fields that are configured by the 
administrator. There are 25 Category fields. 
The last category field is assigned to the 
criteria called 'All Programs', by default. The 
user can create a project and link it to a 
specific program. This linking helps to 
consolidate information from multiple projects 
associated with the same program.

These Category fields are not available for 
Users and User Group objects.

Schedule Editor Indicates the source of schedule editing for 
this project: PPM or MSP (Microsoft® Project). 
This is automatically set to MSP when you 
launch a project into Microsoft Project. When 
set to MSP, the PPM project does not change 
dates and duration programmatically. This 
ensures that when the project is published in 
PPM from Microsoft® Project, the project 
dates are correct in PPM.

Actual Flex Cost A cost field that is configured by the 
administrator. Actual cost reflects the cost 
incurred on the project as on date.

Budgeted Flex Cost A cost field that is configured by the 
administrator. Budgeted cost reflects the 
intended cost for the project.

Estimated Flex Cost to Completion A cost field that is configured by the 
administrator. Estimated cost reflects the cost 
that keeps varying based on any change in the 
project cost or plan as the project progresses.

Critical Indicates whether the activity is on the critical 
path.

Total Actual Cost Sum of all the actual costs.

Total Budgeted Cost Sum of all the budgeted costs.

Total Estimated Cost to Completion Sum of all the estimated costs to completion.

Created from Template Name of the template from which this project 
is created.

PLM Reference Any object that you want to add as a reference 
to the project. This object also appears in the 
Content tab of the project.

Project Keywords Keywords that are associated to the project. 
You can configure the project summary page 
to display important content by these project 
keywords.

Functional Team(s) Lists any functional teams you have 
associated with the activity for workflow 
routings.

Integration details (Appears only if RMW is installed.)

Scale Factor Indicates the number by which the BOM 
quantity should be multiplied for commercial 
production.

Field Contains...
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To edit the information in the General Info tab:

1. Click Edit on the General Info tab of a project object.

2. Modify the editable fields.

3. Click Save.

Dates
Within Agile PPM, dates are displayed in your preferred date format, but there is no 
time zone conversion applied for dates such as Schedule Start Date, Schedule End 
Date, Actual Start Date, Actual End Date, Estimated Start Date and Estimated End 
Date.

Date values that you enter are stored in Greenwich Mean Time (GMT) and displayed 
without the time zone. For example, if you enter a date value of 10/10/2009, the 
system stores the date in the database as 10/10/2009 00:00:00 GMT.

Page Two, Page Three, Workflow, and History dates are displayed in user-preferred 
time zones.

Duration
Objects within a project can have different duration types such as:

■ Fixed duration - The object takes a defined period, for example, five days. For 
Fixed duration, the Days Effort is calculated as the Scheduled Duration times the 
sum of the % Allocation of all resources. You can also create a zero duration 
activity by selecting Fixed Duration and setting Zero as the Days Effort.

■ Effort driven - The Days Effort of the object is fixed, but the number of resources 
assigned affects the Scheduled Duration. For Effort Driven Duration Type, the 
Scheduled Duration is calculated as the Days Effort divided by the sum of % 
Allocation of all resources.

If a parent changes to a leaf node object (an activity with no children) then the 
Duration type changes from 'Calculated' to 'Fixed'. The Duration remains the same as 
it was when it was the parent. If the parent object had resources, Days Effort is 
calculated based on the percentage allocation of the Resource/Groups assigned to the 
Team tab. If there are no resources, the Days Effort is the same as the Scheduled 
Duration.

Audit Values
The General Info tab of activities contains the following audit values:

Operating Mode Defaults to Clinical Supply.

Integration Message Provides information about the integration, or 
reason for failure.

Integration Status Indicates whether the PPM object was 
successfully synced to RMW.

Internal ID ID of the synced object in the RMW database.

Calendar Calendar assigned to this activity. Calendars 
that are enabled by an administrator are 
visible for selection.

Field Contains...
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■ Audit Score - The value assigned to each object in a project by an auditor during 
an audit, based on performance indicators.

■ Weight - A value that reflects the importance of the individual object compared to 
other objects in the entire project.

■ Weighted Score - A value calculated by multiplying the values in the Weight and 
Audit Score fields.

Working with Attachments
Attachments to Agile business objects contain pertinent information about the object 
in addition to the information recorded on the object tabs. Examples of attachment 
files are:

■ Drawing files such as CAD drawings or scanned image files in viewable formats

■ Web-based information in the form of URLs

■ Project specifications and other documents

■ Non-viewable files, compressed files, and so on

Important: As a best practice, it is recommended that the 
attachments tab in Agile PPM activities and gates be disabled. Agile 
PPM provides a unique tab, the Content Tab, that you can use for all 
project content, including attachments.

For more information on working with attachments, refer the Getting Started with Agile 
PLM guide.

Collaborating on Project Activities
The Collaboration tab enables you to manage project-related discussions, action items 
that result from the discussions, and news items. You can also add and view these 
objects in the Project Summary page.

Figure 2–2 Collaboration Tab

The Collaboration tab has the following views:

■ Discussions - Enables you to initiate, join, reply to, or remove a discussion. The 
Notifications tab in your Home page displays all the discussions notified to you. 
For further information on managing discussions, see "Managing Discussions" on 
page 4-29.

■ Action Items - Enables you to manage the action items. You can add, remove, 
accept, or decline an action item. In addition, you can mark the action item 
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'Complete'. The Action Items which you add in this tab appear in the My 
Assignments tab of the assignee's Home page. You can view these action items in 
the Upcoming Activities and Action Items widget of the Project Summary page.

For further information on working with Action items, see "Viewing Action Items" on 
page 4-31.

■ News - Enables you to add and remove news or announcements specific to the 
project. You can also add and remove news items on the Project Summary page.

Viewing History
The History tab records all actions taken, such as editing the General Info tab or 
changing activities or team members.

If you do not have the appropriate read privileges, you cannot view the fields on the 
History tab. If you have questions about your privileges, see your Agile administrator.

Actions Menu
The Actions Menu consists of the following options in addition to the standard PLM 
menu commands such as Bookmark, Subscribe, Save As and Delete.

Menu Description

Gantt Chart Click Gantt Chart to view the Gantt Chart 
view of the project. For more information on 
working with Gantt, see "Gantt Chart" on 
page 2-27.

Delegate Click Delegate to delegate the project to a 
different owner. For more information on 
delegating ownership, see "Delegating 
Ownership" on page 4-18.

Substitute Resource Click Substitute Resource to replace a 
resource in the project team. For more 
information on substituting resources, see 
"Substituting Resources" on page 4-20.

Change Parent Click Change Parent to modify the root parent 
of the project.

Make This a Root Activity In the project or phase within a project, select 
Make this a root activity to start a new 
project. This change modifies the existing 
dependencies.

Compare Baselines Click Compare Baselines to view a 
comparison between two project baselines. For 
more information, see "Comparing Baselines" 
on page 4-28.

Microsoft® Project The entries in this menu enable you to launch 
the existing PPM project in Microsoft Project. 
In addition, you can save the existing PPM 
project as an XML file. For more information, 
see "Working with Microsoft Project" on 
page 7-1.

Complete Click Complete to modify the status of the 
project to 'Complete'.

Change to Canceled Click Change to Canceled to modify the status 
of the Project to 'Canceled'.
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Address Book Palette
To search for a user group:

1. Click to open the address book palette.

2. Choose s in the address book palette dropdown list.

3. Type the user group object search criteria that you want to use.

4. Click the Execute a Quick Search button.

5. In the palette search results table, double-click the user group row you want. You 
can also select one or more rows and drag them to the field that you are 
modifying.

6. Press the Escape key to close the address book palette.

To search for a user within a user group:

The Search within a User Group option becomes available when the number of user 
groups in the Agile PLM system exceeds 200.

1. Click to open the address book palette.

2. Choose Search within a user group in the address book palette dropdown list.

3. In the Select a user group to search within dialog, type the name of the user 
group you want, or click the Search button to search for a group.

4. When you have selected a user group, click OK.

Agile PLM adds the group name to the address book palette dropdown list. Agile 
PLM continues to add group names to the palette dropdown list until the number of 
groups equals twenty. As additional groups are added to the list, Agile PLM removes 
the oldest entries from the dropdown list. A maximum of twenty groups that you 
recently selected for the Search within a user group option remain on the dropdown 
list.

Alternatively, you can use the address book palette dropdown list to select one of the 
user groups that you have selected recently.

1. Type the user object search criteria that you want to use.

2. Click the Execute a Quick Search button. The search is restricted to the members 
of the selected group.

3. In the palette search results table, double-click the user group row you want. You 
can also select one or more rows and drag them to the field that you are 
modifying.

Accept Calendar Change Click Accept Calendar Change to manually 
accept changes to the calendar. You must have 
privileges to modify schedule dates and 
duration to perform this action. See also 
"Using Calendars" on page 4-22.

Reports and Analytics The entries in this menu enable you to obtain 
reports on Project Resource Utilization and 
Schedule. For more information, see "Reports" 
on page 6-5.

PPM Sync to RMW (appears if RMW is 
installed)

Click PPM Sync to RMW to update the RMW 
database with projects and work requests 
created in PPM.
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4. Press the Escape key to close the address book palette.

To search for users:

1. Click to open the address book palette.

2. Choose Users in the address book palette dropdown list.

3. Type the user object search criteria that you want to use.

4. Click the Execute a Quick Search button.

5. In the palette search results table, double-click the user group row you want. You 
can also select one or more rows and drag them to the field that you are 
modifying.

6. Press the Escape key to close the address book palette.

Gantt Chart
The Gantt chart feature is a powerful project management tool that helps project 
managers plan, administer, and track projects from start to finish. With Gantt, you can 
create a project and then plan the work breakdown structure for this project, which 
includes defining activities and tasks, creating dependencies between tasks, and 
performing resource management.

The Gantt Chart offers rich user-friendly features (such as Excel-like data editing) to 
manipulate and view data in graphical or tabular formats. Multiple view options 
enable you to focus on discrete project aspects, and right-click menus help you to 
quickly take actions on selected project objects.

The default Gantt view consists of a menu bar, standard toolbar, a tabular activity pane 
and a graphical activity pane. The tabular activity pane provides a hierarchical tree 
structure representation of all activities and the graphical pane provides a graphical 
representation of activities with color and iconic indicators.

Additional features are available in Gantt as a result of the multi-project Gantt feature. 
These features, as well as differences between single-project and multi-project Gantt, 
are documented in subsequent sub-sections.
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Figure 2–3 Gantt Chart

Prerequisites
Ensure that you have the appropriate privileges to perform project management 
activities within the Gantt Chart. You can create, modify, and delete activities in Gantt 
only if you have been assigned the privileges to do so. If you have questions about 
your assigned roles and privileges, contact your Agile administrator.

The Gantt chart uses Java Web Start technology and requires Java Runtime 
Environment (JRE) to be installed on your computer. If the recommended JRE does not 
exist on your system or if you have a lower version installed, you are prompted to 
install the latest JRE version. For information on the recommended JRE, see Agile PLM 
Capacity Planning Guide.

If certain firewalls prevent this automatic download, you can download and install the 
appropriate JRE version.

Modes of Operation
The Gantt chart operates in three modes:

■ Connected - Requested data is obtained directly from the server.

■ Disconnected - Requested data is obtained from the installation folder. If the server 
is not available, Gantt switches to this mode. Once the server becomes available, it 
switches back to Connected mode.

■ Offline - Requested data is retrieved from the installation folder. The server is 
assumed to be unavailable.



Note: The Gantt chart opens in the mode it was set to when you last 
worked on it. If the Gantt Chart was set to Offline mode in your last 
session, it opens in Offline mode when you next try to launch a project 
from Web Client. The requested project cannot be opened as the 
system assumes server unavailability. Instead, a new default project is 
launched. To open the project you wanted, change the mode from 
Offline to Connected, and then launch the project again from Web 
Client.
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Launching Gantt
You can launch Gantt Chart from the Dashboard or from a program/project.

To launch the Gantt Chart from the Projects tab of the Dashboard, select the project(s), 
click the list drop-down arrow > Gantt Chart and select your launch mode. See 
"Launch Options" for launch mode options. 

Alternatively, to launch the Gantt Chart from a project, open the project and select 
Details View > Gantt Chart.

If your project has sub-activities, you can also select Actions > Gantt Chart from the 
Summary view.

When you start the Gantt Chart, Java JAR files are downloaded into your computer's 
temporary files folder. Once these are loaded, the Gantt Chart appears.

You can also launch multiple related projects in Gantt. For information about 
launching multi-project Gantt, see "Working with Multi-Project Gantt" on page 2-45.

Launch Options
You can launch the Gantt Chart from Web Client using any of the following project 
lock options:

■ Full Lock Mode - Locks the current activity and all its lower-level activities, 
including dependent activities in other projects. Open in this mode to make 
overall schedule changes that should overwrite information in related projects.

■ Internal Lock Mode - Locks the current activity and all its lower-level activities 
within the project. Dependant activities in other projects remain unlocked and can 
be edited. Be aware that scheduling changes that you make may affect the 
schedule of dependent activities in other projects. Open in this mode to perform 
changes that are not related to schedule.

■ Read Only mode - Enables you to view but not edit data. Open in this mode to 
view or monitor projects without making changes.

If you launch Gantt in Full Lock Mode or Internal Lock Mode successfully from the 
Web Client, the loaded project(s) in Gantt will be locked accordingly. Note, however, 
that when you try to add additional projects using Navigator from within Gantt, the 
newly added projects are always Read Only by default, even if the current projects are 
all locked. You need to lock the newly added projects manually through Navigator. See 
"Gantt Navigator" on page 2-48 for more about the Navigator.

Launching Gantt Using Shortcuts
During Gantt download, you are prompted to confirm whether you want shortcuts to 
the Gantt application to be installed on your Desktop and Start menu. Click Yes to 
confirm. These shortcuts are especially useful when you want to work on Gantt offline.
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To launch Gantt from the Desktop, double-click the Gantt icon. To launch Gantt from 
the Start menu, choose Programs > Oracle | Agile PLM and select the Gantt 
application. Once you have saved a Gantt Chart Exchange (.gcx) file on your system, 
you can simply double-click the file to launch the Gantt Chart.

Privilege Checks in Gantt
The following privileges checks are enforced in Gantt:

■ Create

■ Delete

■ Modify

Only authorized changes for objects and object data are allowed.

The Modify privilege controls differ between Web Client and Gantt. See Chapter 10, 
"Configuring Product Portfolio Management" for more details.

Gantt Toolbar
Most actions on the Gantt Chart can be performed using the icons on the toolbar or 
corresponding keyboard shortcuts. When you place your mouse pointer over an icon, 
the shortcut key appears next to the name of the icon.

Function Shortcut Keys Description

Navigator Ctrl+Shift+N Opens Navigator tool.

Open Ctrl+O Opens Activities or Gates.

Save Ctrl+S Saves changed information in the Gantt.

Refresh from 
Server

Ctrl+L Overwrites current data with the latest data from 
the server. All unsaved changes are lost.

Cut Ctrl+X Cuts a selected cell value, activity or gate.

Copy Ctrl+C Copies a selected cell value, activity or gate.

Paste Ctrl+V Pastes the cut or copied cell value, activity or gate. 
If you copy a task that is in Completed status, the 
status changes to Pending when you paste it.

Activity Insert Inserts an activity below the selected activity, at the 
same indent level.

Gate Alt+G Inserts a gate below the selected activity, at the 
same indent level.

Delete Delete Deletes the selected item from the Gantt Chart.

To select an activity for deletion, highlight or select 
the whole row.

Create 
Dependency

Alt+C Adds a dependency.

Edit Dependency Alt+D Opens the Edit Dependency dialog for the selected 
dependency.

Go To Selected 
Task

Ctrl+G Brings the corresponding graphic into view.

Indent or Move 
Right

Alt+Shift+Right Indents an item, making a project element report to 
another item.

Moves the selected item or items to the right.
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Views in Gantt
Gantt supports the following views:

■ Gantt

■ Task Assignment

■ Calendar

■ Critical Path

■ Comparative Gantt

■ Resource

■ Resource Sheet

■ Resource Utilization

Gantt
The Gantt view is the default view. This view displays the project activities and 
schedules in a combination pane. One pane displays a tabular view of activities in a 
hierarchical tree structure. The other displays a graphical view of activities in a bar 
graph format.

In all project data-related views, the graphical view is displayed as follows:

■ The root (top) level of the loaded project is always be black (even it is not the real 
top level in the original project).

Outdent or Move 
Left

Alt+Shift+Left Outdents an item, so that a project element no 
longer reports to the higher-level element.

Moves the selected item or items to the left.

Move Up Alt+Shift+Up Moves an item up to change the order of the listed 
items at the same level. If project elements report to 
that item, these move along with it.

Move Down Alt+Shift+Down Moves an item down to change the order of the 
listed items at the same level. If project elements 
report to the item, these move along with it.

Expand All Ctrl+E Expands the Project tree structure to view all the 
activities within.

Collapse All Ctrl+Q Collapses the Project tree structure to hide all the 
activities in the tree.

Zoom In Ctrl+Plus 
(NumPad)

Enlarges the graphical pane view.

Zoom Out Ctrl+Minus Reduces the graphical pane view.

Zoom To Fit Ctrl+0 Changes the size of the graphical pane to show the 
entire project within the visible area.

Manage Resources Alt+F10 Enables you to select and manage resources for the 
selected activities.

Delegate Owner Alt+F12 Enables you to delegate the ownership of the 
selected activities.

Predefined Filter N/A Predefined filters to be used in Gantt.

Custom Filter Ctrl + Shift + F Custom filtering for filtering project data in Gantt. 

Function Shortcut Keys Description
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■ The leaf (bottom) level is always displayed in pink, unless it is the only level 
loaded in Gantt.

■ Other levels between the root and leaf levels are displayed in orange.

Task Assignment
The Task Assignment view is a combination view of the Gantt Chart in the top pane 
and the Manage Resources sheet and Resource Utilization chart in the bottom pane. 
When you select an activity in this Gantt view, resource information about the task 
appears in the Manage Resource view. You can simultaneously view the resource 
utilization of each resource in a graph format in the Resource Utilization pane.

For a resource, the utilization is equal to the summarized value of allocation 
percentage. For instance, if you assigned a resource to 2 tasks with 100% allocations on 
the same day, then the utilization of the resource is 200%.

For a resource pool, the utilization is the summarized value of allocation percentage 
divided by the resource amount. For instance, if you assign a resource pool to two 
tasks at the same day with 100% allocation, and the resource pool has 2 resources, then 
the utilization of this resource pool is 100% instead of 200% though the Allocation% 
may display 200%.

Resource utilization calculations in the Task Assignment and Resource Utilization 
views are provided as follows:

■ Allocations in active projects are calculated, whether the projects are loaded in 
Gantt or only on the server. Projects that are not loaded into Gantt are displayed in 
the sub-total in Others in the tooltip.

■ Allocations in Proposed Projects are only calculated when the projects are loaded 
into Gantt. Projects that are have not been loaded are not displayed in Others in 
the tooltip.

■ Allocations in Template Projects are never calculated even if the projects are 
loaded in Gantt.

See the "Resource Utilization" on page 2-34 for more information about this view.

Tip: You can access the Manage Resources table and Resource 
Utilization chart as a popup windows. Go to Tools > Manage 
Resources to open the Manage Resources window. Click the 
Utilization button in the upper right hand corner to open the Resource 
Utilization chart.

Calendar
The Calendar view enables you to create, edit, and review your project tasks in a 
calendar format. The Calendar view consists of two tabs, Month and Day. The Month 
tab displays a monthly view with all the days in the month. The Day tab displays a 
day view with all the hours in the day.

The Calendar view is helpful to view tasks that are scheduled on a particular day, 
week or month. It shows tasks schedules for a specific week or range of weeks. You 
can create a project by entering a task and the duration of a project using the calendar 
format.
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Critical Path
Critical path view helps you plan all activities that directly affect the completion date 
of a project. Critical Path is determined by identifying all the activities that have slack, 
below a pre-determined number of days.

Critical path activities act as the basis for creating a schedule and planning resource 
allocation. It helps you analyze where a remedial action is required to get a project 
back on track. Critical path can be viewed at activity and sub-activity level. The critical 
task is the current activity on the critical path.

If a schedule is on a critical path, the schedule bar on the graphical pane appears red.

Comparative Gantt
The Comparative Gantt view helps you compare the current project schedule against 
other views, including the following: 

■ Estimated - shows the difference between the current schedule and estimated 
schedule.

■ Actual - shows the difference between the current schedule and actual schedule.

■ Latest Loaded From Server - shows the difference between the current schedule 
and the latest loaded schedule from the serve.

■ Baselines - shows the variance between the current schedule and the selected 
baseline.

To view a comparison, select an option from the drop-down list in the main toolbar. 
All saved baselines are included in this list for selection. The default comparison value 
is Estimated. 

Note: The ability to view baselines is only available in single-project 
Gantt.

When this Latest Loaded from Server option is selected, the comparative view is 
between the current project schedule and the latest loaded schedule. This option is 
added to provide you with a view that can simulate some changes to the project 
schedule without really implementing the changes. Until you save your latest change 
or click Refresh from server, the data will not be updated.

In the graphical view:

■ The Current schedule of a parent displays in black.

■ The Current schedule of a child activity displays in orange.

■ The Current schedule of a leaf activity displays in pink.

■ The Estimated, Actual, or Latest schedule of the parent activity displays in white.

■ The Estimated, Actual, or Latest schedule of selected child activities displays in 
gray.

In the tabular view, you can view baseline schedule information (start and end dates) 
in columns alongside current schedule information.

Resource
The Resource view displays a list of all users for a particular project and their task 
allocation according to the schedule, in a calendar format. If you have assigned an 
allocation to a user, in this view, in the bar graph in the top pane you can view the 
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activity name, and its root parent information by hovering over the bar. The 
percentage of allocation is displayed in the bottom pane. You can also select the 
topmost row - All Users - to view a bar graph of all resources simultaneously.

In this view, you can also update task assignments to balance resource workload. For 
instance, if a user has been assigned two tasks in the same time period, causing 
overloading, one of the tasks can be postponed or reassigned. The Project Manager or 
Resource Pool Manager can move the task to another time period or to another user 
using a simple drag-and-drop action. The Gantt data is updated immediately, and 
synchronized to the server when saved.

Resource Sheet
The Resource Sheet enables you to view available resources and add selected resources 
to your project. The Resource Sheet contains a set of users who are associated with the 
activities within a project. Adding resources to a Resource Sheet reduces duplication 
and maintenance of resources. You can access the Resource Sheet from View > 
Resource Sheet.

The Resource Sheet view contains fields with relevant user information such as Title, 
Business Phone, Email, Status, Assigned from Pool, and so on. You can review, add, or 
edit information on each resource. You can quickly create a resource list for your 
project by adding the name of each resource and their related information. A resource 
can be an individual, a company or department, a piece of equipment, a room, or any 
other resource that you are using for your project.

Note: Simultaneous updates to the Resource Sheet by different users 
are not supported. Updates to the resource sheet are saved 
independently of Gantt chart updates.

If you load multiple projects in Gantt, all of the involved team members, that is all of 
the users listed in the projects’ Team tabs, are aggregated and displayed in Resource 
Sheet. Any of the users can be selected in the drop-down list in the Manage Resource 
table in the pop-up in the Task Assignment view of any of the loaded project’s 
activities.

Resource Utilization
The Resource Utilization view displays all the resources and the tasks assigned to each 
resource. It displays the tasks and task allocations from other projects in PPM as well. 
You can view the following information for each resource or resource group in this 
table:

■ Name

■ Pool Name

■ Root Parent

■ % Allocation

■ Schedule Start

■ Schedule End

The Resource Utilization logic functions the same in this view as it does in the Task 
Assignment View. See "Task Assignment" on page 2-32 for more.

To format columns in the report:
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1. Choose Format>Preferences.

2. Within the Preferences dialog that opens, in the Columns tab, select the columns 
you want to display.

3. Use the arrow buttons to move selected column names from the Available 
Columns list to the Selected Columns list.

4. To rearrange the order in which the columns display, move them up or down in 
the list using the up and down arrows.

5. To hide or show gridlines, select the appropriate check boxes for Horizontal and 
Vertical.

6. Click OK to apply your changes.

Customizing the Gantt Chart
The graphical and tabular display of data within the Gantt Chart can be customized 
based on your preferences. You can configure the display of columns, grids, bar labels, 
appearance, and styles using the options in the Format menu.

You can configure the columns to display Page One attributes - the options that are 
made available in these fields are configured in the Java Client General Info attribute 
settings.

Setting Preferences
You can customize column display and set other preferences such as preferred file 
download location, as described further.

To customize column display:

1. Choose Format > Preferences.

2. Within the Preferences dialog that opens, in the Columns tab, select the columns 
you want to display.

3. Use the arrow buttons to move selected column names from the Available 
columns list to the Frozen or Non-Frozen columns list as desired. The Non-Frozen 
column displays all the visible columns in the tabular activity pane.

4. Click OK.

To freeze, unfreeze, or hide one or more columns:

1. Within the tabular view pane, select the column or columns.

2. In the right-click menu, select Freeze Column, Unfreeze Column or Hide as 
appropriate.

Within the Columns tab of the Preferences dialog, you can use the and arrow buttons 
to sort the order of the displayed columns. Alternatively, you can click and drag a 
column in the tabular view pane to change its location.

To set preferences for offline mode:

1. Choose Format > Preferences.

2. Within the Preferences dialog, select the Advanced tab.

3. In the File Location field, browse and select the folder to which you want your 
files downloaded for offline access. The default location for file downloads is your 
My Documents folder.
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4. In the Project Name field, you can enter a default value for activity names. For 
example, if several of your projects start with the same name, say 'ABC Project 
V.1', 'ABC Project V.2', 'ABC Project V.3' and so on, you can enter 'ABC Project' in 
this field so that you only need to change the rest of the name.

5. Select other options as appropriate:

■ If you select Yes for the Download Page Two and Page Three field, this 
information gets downloaded when you are in Online mode, and can be saved 
for offline activity. If you select No, this information is loaded only if you 
choose to view the properties of a selected activity.

■ If you select Yes in the Display Locked Projects on Exit field, a dialog appears 
when you exit Gantt, where you can view the list of projects that are locked by 
you. You can then choose to unlock activities that other users may need to 
access.

6. Click OK to exit the Preferences dialog.

7. In the Format menu, click Save Settings to save your preferences. The next time 
you log in, these settings are maintained.

Appearance and Style
To customize the appearance of your Gantt Chart, choose Format > Appearance and 
choose a theme.

To change the graphical view style, choose Format > Styles and choose a style.

Bar Labels
You can select the text to be displayed on the bar graphs on the graphical view pane. 
The information is displayed in relation to the task, project or phase corresponding to 
the bar graph. Choose Format >Bar Labels and select labels.

Grids
You can also customize the display of grids and rows in your graphical view.

Once you have made changes to any of the format settings, select Format>Save 
Settings from the menu bar to save changes.

The Save Settings command does not save changes to the Grid.

View Bar
The View Bar is a pane that is displayed on the left of the Gantt Chart and enables you 
easy access to view the different type of Gantt views. The Gantt view types are 
displayed as icons and you can click the icon to display the view. The default setting 
for the View Bar is Enabled. To disable it for a particular session, click View and select 
View Bar.

A check mark next to the View Bar option indicates that the view bar is enabled.

Gantt Menu Options
This section details the various Gantt menu options for File.

The File menu in the Gantt Chart offers the following options:



Menu Command Action

New Creates a new root project with default project data.

This option is disabled in multi-project Gantt.

Open Opens a search window where you can locate and open projects from 
the server. You can search by Root Project, Root Template, Activities, 
Gates, or All Project. Available only in online mode. The search criteria 
you last used appears by default in the Find From field.

When you search by Activities or Gates, parametric search options 
become available if corresponding attributes have been enabled in Java 
Client. Click Options to view parametric search fields and specify 
criteria.

This option is disabled in multi-project Gantt.

Save Saves the project to the server. Saved data includes: Page One, Page 
Two, Page Three, Schedule, Dependencies, Team, and Resources..

Save As Saves the project to the server under a different name. Saved data 
includes: Page One, Page Two, Page Three, Schedule, Team, and 
Resource Sheet. Content (from the Content tab) is not saved.

This option is disabled in multi-project Gantt.

Navigator Opens Gantt Navigator tool. See"Gantt Navigator" on page 2-48. 

Open File Helps you search and locate a saved GCX (Gantt Chart Exchange) file 
on your hard drive. If you saved a folder location as a preference in the 
Advanced tab of the Format > Preferences dialog, this folder is opened. 
If the current project was opened using a GCX file stored in a particular 
folder, that folder is opened.

This option is disabled in multi-project Gantt.

Save File Saves the project to your hard drive. Saved data includes all activities, 
dependencies, resource sheet, activity states, and any modifications 
made after you last saved the project.

This option is disabled in multi-project Gantt.

Save As File Saves the project to your hard drive under a different name. Make sure 
you change the name of the root project so that you do not update an 
existing project on the server inadvertently.

This option is disabled in multi-project Gantt.

Refresh from Server Reloads the project with the latest data from the server. Use this feature 
to update resource information without having to close the project and 
open it again. Save your changes first, as all unsaved changes are 
overwritten. If you have configured any views, these are retained. If the 
project is newly created and not yet saved to the server, you are 
prompted to save the project.

Recent Files Displays a list of up to 10 files that were recently opened from the hard 
drive.

This option is disabled in multi-project Gantt.

Work Offline When selected, switches the Gantt to offline mode, regardless of server 
availability. To return to online mode, select this option again. 
Connection status is displayed at the bottom right corner of the 
window.

This option is disabled in multi-project Gantt.
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The Edit menu in the Gantt Chart offers the following options:
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Menu Command Action Notes

Undo Undo the action made in Gantt 
(the latest action only).

Cut Cut the selected record.

Copy Copy the selected record. The Copy menu option is 
available in all views, except the 
Resource Sheet and Resource 
Utilization views.

The Copy menu option is one of 
only three options available in 
the Resource view.

Paste Paste the copied record.

Fill > Down Fill down values among the 
selected rows from top to 
bottom.

Fill > Up Fill up values among the 
selected rows from bottom to 
top.

Find Open the Find window to find 
a target task.

The Resource view only has the 
Copy, Find and Find Selected 
Value options.

The Resource Sheet view only 
has the Find, Find Selected 
Value, and Delete options.

The Resource Utilization view 
only has the Find and Find 
Selected Value options.

Find Selected Value Find the next cell that is the 
same as the selected cell.

The Resource view only has the 
Copy, Find and Find Selected 
Value options.

The Resource Sheet view only 
has the Find, Find Selected 
Value, and Delete options.

The Resource Utilization view 
only has the Find and Find 
Selected Value options.

Go To Selected Task Locate the selected task in 
Gantt Bar.

Custom Filter Open Custom Filter.

Insert > Activity Insert a new activity.

Action cannot be performed on 
a root project.

Insert > Gate Insert a new gate.

Action cannot be performed on 
a root project.

Create Dependency Switch to dependency-creation 
mode.

Edit Dependency Edit the selected dependency.

Delete Delete the selected 
activity/gate/dependency.
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The View menu in the Gantt Chart offers the following options:

Move Activity > Indent Indent an activity/gate one 
level.

Action cannot be performed on 
a root project.

Move Activity > Outdent Outdent an activity/gate one 
level.

Action cannot be performed on 
a root project.

Move Activity > Move Up Move an activity/gate up one 
row.

Action cannot be performed on 
a root project.

Move Activity > Move 
Down

Move an activity/gate down 
one row.

Action cannot be performed on 
a root project.

Reschedule > Move 
Back/Forward

Open the Move Back/Forward 
window to reschedule the 
project.

Reschedule > Remove 
Slack

Remove all the slack in the 
project(s) and adjust project 
dates to give you a 'best fit' 
schedule.

Menu Command Action Notes

Gantt Switch to Gantt View.

Task Assignment View Switch to Task Assignment View.

Calendar Switch to Calendar View.

Critical Path Switch to Critical Path View.

Comparative View Switch to Comparative Gantt View.

Resource Switch to Resource View.

Resource Sheet Switch to Resource Sheet View.

Resource Utilization Switch to Resource Utilization 
View.

Expand All Expand all projects to leaf level. Not available in Resource Sheet 
view.

Collapse All Collapse all projects to root level. Not available in Resource Sheet 
view.

View Bar Hide/unhide View Bar in the left.

Zoom In Zoom in Gantt Bar. Not available in Resource Sheet 
view.

Zoom Out Zoom out Gantt Bar. Not available in Resource Sheet 
view.

Menu Command Action Notes
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The Format menu in the Gantt Chart offers the following options:

Zoom to Fit Zoom the Gantt Bar to fit the 
window size to display the whole 
project.

Not available in Resource Sheet 
view.

Menu Command Action Notes

Preference Open the preference window to 
configure displayed attributes, etc. 

The Resource Sheet view and 
Resource Utilization view only 
have the Preference and Save 
Settings Format menu options

. In the Resource Utilization 
view, the user can add the Root 
Parent column.

Grid > Show Vertical 
Grid

Control to show vertical grid or not.

Grid > Vertical Grid 
Color

Configure vertical grid color.

Grid > Show Weekends Control to show weekend color or 
not.

Grid > Weekend Color Configure weekend color.

Grid . Show Non 
Working Hours

Control to show non-working hours 
or not.

Grid > Show Non 
Working Hours Color

Configure non-working hours color.

Grid > Show 
Horizontal Grid

Control to show horizontal grid or 
not.

Grid > Horizontal Grid 
Color

Configure horizontal grid color.

Grid > Color Rows Control to show colorful rows or 
not.

Grid > Even Row Color Configure even row color.

Grid > Odd Row Color Configure odd row color.

Bar Labels > Name Show activity name of the 
activity/gate in the Gantt bar.

Bar Labels > Start Date Show scheduled start date of the 
activity in Gantt bar.

Bar Labels > End Date Show scheduled end date of the 
activity in Gantt bar.

Bar Labels > Status Show complete percentage of the 
activity/gate in the Gantt bar.

Bar Labels > % 
Complete

Show status of status of the 
activity/gate in the Gantt bar.

Bar Labels > None Show nothing in the Gantt bar.

Appearances > Metal Change the appearance to Metal.

Appearances > Nimbus Change the appearance to Nimbus.

Menu Command Action Notes
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The Tools menu in the Gantt Chart offers the following options:

Note: All options, unless otherwise noted, are unavailable in 
Resource-related views.

Menu Command Action Notes

Manage Resources Open the Manage Resources 
window.

Delegate Ownership Open the Delegation window.

Show Changes Open the comparison report in 
browser.

This option is disabled in 
multi-project Gantt.

Show in Browser Show the project in Web Client.

Unlock Projects Open the Unlock Projects window.

Add Resource Add a new resource to resource 
sheet

This is only available in the 
Resource Sheet view and it is 
the only Tools menu option 
available in this view.

The Help menu in the Gantt Chart offers the following options:

Appearances > 
CDE/Motif

Change the appearance to 
CDE/Motif.

Appearances > 
Windows

Change the appearance to 
Windows.

Appearances > 
Windows Classic

Change the appearance to Windows 
Classic.

Appearances > 
Kunststoff

Change the appearance to 
Kunststoff.

Appearances > Office Change the appearance to Office.

Styles > Agile Change the style to Agile.

Styles > Activity 
Completion

Change the style to Activity 
Completion.

Styles > Critical Path Change the style to Critical Path.

Styles > Custom Time 
Scale

Change the style to Custom Time 
Scale.

Styles > Level Coloring Change the style to Level Coloring.

Styles > Standard Change the style to Standard.

Save Settings Save all the format settings. The Resource Sheet view and 
Resource Utilization view only 
have the Preference and Save 
Settings Format menu options.

Menu Command Action Notes



Menu Command Action

Manual Open the Manual link.

About Show information about Gantt.
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The Context menu in the Gantt Chart offers the following options: 

Note: All options, unless otherwise noted, are unavailable in 
Resource-related views.

Menu Command Action Notes

Cut Activity See the Menu Options.

Copy Activity See the Menu Options.

Paste See the Menu Options.

Expand/Collapse See the Menu Options.

Fill Ups See the Menu Options.

Fill Down See the Menu Options.

Indent See the Menu Options.

Action cannot be performed on a root 
project.

Outdent See the Menu Options.

Action cannot be performed on a root 
project.

Move Up See the Menu Options.

Action cannot be performed on a root 
project.

Move Down See the Menu Options.

Action cannot be performed on a root 
project.

Insert Activity See the Menu Options.

Action cannot be performed on a root 
project.

Insert Gate See the Menu Options.

Action cannot be performed on a root 
project.

Delete See the Menu Options.

Manage Resources See the Menu Options.

Move Back/Forward See the Menu Options.

Go to Selected Task See the Menu Options.

Show in Browser See the Menu Options.

Properties Open the property window to 
view/edit P2/P3 attributes of the 
selected activity/gate
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Working Offline on Single-Project Gantt
In single-project Gantt, you can use the Gantt client as a standalone application on 
your computer and continue working on the Gantt Chart even when you are not 
logged into Agile PLM. This feature enables you to do the following:

■ Continue working on a project while traveling or during server downtime.

■ Create a preliminary draft of a project and make it available online only when you 
want other users to see it.

■ Email a saved project to others for opinions and updates.

The first time you launch a Gantt chart from Web Client, you are provided the option 
to save a shortcut to the Gantt chart on your desktop. Once you save the shortcut, you 
can use it to launch Gantt and work on it offline.

Unlocking Projects before Exiting
When you close the Gantt Chart after working on it in Offline or Disconnected mode, 
the projects that you opened from Gantt remain locked. To ensure that projects used by 
others are unlocked for their use, you are prompted to unlock projects before you exit. 
Within the Unlock Projects dialog that appears, select the projects that you want to 
unlock for the use of others and click OK.

Copy Copy the selected resource/resource 
pool.

This menu option is only 
available in the Resource 
View.

 The Resource View context 
menu has the following 
options: Copy, 
Expand/Collapse, Move 
Resource (Up/Down).

Expand/Collapse Expand/Collapse the selected 
resource pool.

This menu option is only 
available in the Resource 
View.

The Resource View context 
menu has the following 
options: Copy, 
Expand/Collapse, Move 
Resource (Up/Down).

Move Resource Up Move the selected resource up for one 
row.

This menu option is only 
available in the Resource 
View.

 The Resource View context 
menu has the following 
options: Copy, 
Expand/Collapse, Move 
Resource (Up/Down).

Move Resource Down Move the selected resource down for 
one row.

This menu option is only 
available in the Resource 
View.

 The Resource View context 
menu has the following 
options: Copy, 
Expand/Collapse, Move 
Resource (Up/Down).

Menu Command Action Notes
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Filtering in Gantt
You can use filter functionality to filter activities and gates by any visible attribute on 
the General Info tab. Filtering in Gantt is supported in the following views:

■ Gantt

■ Task Assignment

■ Calendar

■ Critical Path

■ Comparative Gantt

To apply a custom filter:

1. Click the Custom Filter button or click Edit > Custom Filter.

2. Click in the Attribute dropdown, select an attribute and click OK.

3. Select a value in the Match If field.

4. Enter a value in the Value field.

5. To enter additional criteria, click the Add button (Plus button) and repeat the steps 
above.

6. Click Apply to apply the changes. The custom filter window remains open. Note 
that no actions can be executed in the main Gantt window while the custom filter 
window is open.

Alternatively, click Exit to apply the filter and close the custom filter window.

Once the filter is applied, the project data in the Gantt table only displays the 
activities/gates that match the filter criteria. Additionally, the Custom Filter button is 
modified to indicate that a filter has been applied.

To unapply a custom filter:

1. Click the Custom Filter button or click Edit > Custom Filter.

2. Select all of the criteria that you want to remove.

3. Click Remove (Minus button).

4.  Click Exit or Apply.

Using Predefined Filters
There are five predefined filters you can use to filter tasks on all project data-related 
views. These filters are available to show risky activities and so on.The predefined 
filters are as follows:

■ Unassigned Resources - There are predefined three filters that allow you to narrow 
down tasks that have resource pools that are assigned, yet no individual is 
assigned. The three filters check for unassigned tasks within 30 days, 90 days, and 
180 days of the start date.

■ Allocation Overload - Any activity with utilization greater than 100%, that is an 
overloaded resource/resource pool, is displayed.

■ Resource Budget Overload - Any activity with over-budgeted (Actual Hours/8 > 
Days Efforts) resources is displayed.



Gantt Chart

Understanding the Interface 2-45

Toggling the View Between Gantt and Web Client
While you are working on the Gantt Chart, you can switch to the Web Client view if 
required. This option is available in all modes of the Gantt Chart and is highlighted 
only when at least one row from the project Tree is selected.

To switch to the Web Client view of the current project:

1. Select one or more activity rows in the Gantt chart.

2. In the Tools menu, or in the right-click menu, select Show In Browser. If you are 
not connected to the server, the Agile PLM login screen appears.

3. Log in to Agile. A new browser window opens for each activity row that you 
selected.

Printing a Gantt Chart
You can print any view of the Gantt Chart using the Print option in the File menu.

Within the Print window, or the Print Preview window, you can manually change 
Page Setup options if necessary. By default, the page margins are set to 0.5 inches, and 
the page orientation is set to Landscape.

Working with Multi-Project Gantt
You can load multiple objects into a single Gantt window. 

Launching Multiple-project Gantt
Multi-project Gantt can be launched in three main ways:

■ via PLM Reference attribute: If Gantt is launched from a root project, with one or 
more root projects in its PLM Reference attribute, when the user launches the root 
project, the PLM Reference project(s) are also loaded into Gantt. 

In this case, the following conditions are pre-requisites:

■ The activity that is launched must be at the root level.

■ There must be at least one root project in the current project’s PLM Reference 
field.

■ The current user must have sufficient privilege to view the PLM Reference 
projects:

■ via Dashboard: Select multiple projects in Dashboard and then launch Gantt from 
the Gantt menu.

■ via Navigator: Launch Gantt with a single project first and then add additional 
projects using the Gantt Navigator tool.

Note: Projects that are not authorized for the user are filtered out 
before projects are loaded into Multi-Project Gantt. 

In multi-project Gantt, by default, only root projects and their first child level are 
displayed. The user can expand/collapse the hierarchy manually.
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Figure 2–4 Multi-Project Gantt

As shown in Figure 2–4, "Multi-Project Gantt", the Gantt window title displays the 
session name, as well as the number of projects that are being displayed. The format is 
as follows: Session Name + X Projects in display + Template (Optional) + Gantt Lock 
Mode (Read Only/Internal Lock/Full Lock/Mixed). Specifically, the title display is 
formed according to the following:

■ Session Name:

– If launching from a program with PLM Reference projects, the session name is 
the program name by default.

– If launching from Dashboard by multiple selection, the session name is "New 
session" by default.

– If launching a single project first and then adding another project, the session 
name is the original project name.

– User can update the session name in Navigator.

■ X projects in display:

– Only displayed when more than 1 project is loaded in Gantt.

■ Template:

– Only displayed when all the loaded projects are Template state.

■ Lock Mode:

– When all loaded projects are Read Only, Read Only Mode is displayed.

– When all loaded projects are Internal Locked, Internal Lock Mode is 
displayed.

– When all loaded projects are Full Locked, Full Lock Mode is displayed.

– Otherwise, Mixed mode is displayed.

Root projects are differentiated in multi-project Gantt view by their distinct black 
colored bars and bolded name.
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Most Menu/View and toolbar options function as they do in single-project Gantt, 
except for the following exceptions:

■ In Comparative View, in the comparative option list, no baselines are listed. 
Baseline comparisons are only available for single-project Gantt.

■ In the multi-project Gantt File Menu, unlike in single-project Gantt, the following 
options are disabled:

– New

– Open

– Save As

– Open File

– Save File

– Save As File

– Recent Files

– Work Offline 

Launch Mode  

You can launch multiple-project Gantt view in Read Only, Internal Lock, and Lock 
modes. Read Only and Internal Lock launch modes in multiple-project Gantt function 
as they do in single-project Gantt, as described in "Launch Options" on page 29.

If the current user tries to launch Gantt in Full Lock Mode, however, if any of the 
selected projects is locked by another user, two options are given to the user:

■ Continue: 

– First, whichever projects can be fully locked, the system does a Full Lock.

– Second, whichever projects can be internally locked, the system uses Internal 
Lock on them.

– The rest of the projects are opened in Gantt in Read Only mode.

■  Cancel: Cancel this action.

Editing in Multi-Project Gantt
Privilege checks in multi-project Gantt are conducted the same as in single-project 
Gantt. Create, modify, and delete privilege checks are enforced when editing in Gantt. 
For more information, see "Privilege Checks in Gantt" on page 2-30 and "About 
Privileges in Gantt" on page 10-13.

Inter-dependencies in Multi-Project Gantt  

In multi-project Gantt, you can create dependencies between projects. Inter-project 
dependencies can only be created between internal locked projects. If a user wants to 
create a dependency against a full locked project, a pop-up message is triggered to 
inform the user that they need to switch the lock mode to internal lock first. The user 
can click Continue to open Navigator and decide if they want to unlock the full locked 
project and Internal Lock it again or cancel the dependency creation instead.

If both the predecessor project and successor project are loaded in Gantt, the 
inter-project dependency between them is displayed
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Gantt Navigator
The Gantt Navigator is a tool that allows the user to navigate Gantt by providing 
information about how many projects are included in the current Gantt session, and 
allowing the user to add, remove, and lock projects in that session.The Navigator can 
be launched by clicking File Menu > Navigator, clicking on the Navigator toolbar 
button, or by using the hot key Ctrl + Shift + N.

When you launch the Navigator tool, the outcome depends on whether or not the 
current activity is a root project. If the current activity is a root project, the Navigator 
window pops up and all the current root projects are displayed. If the current activity 
is not a root project, a pop-up message displays asking if the user wants to load its root 
first in order to launch the navigator. If there are any pending changes in the current 
activity, the user can: 

■ save the change and load the root

■ discard pending changes and load the root

■ return to Gantt without any change

Figure 2–5 Navigator window

The Navigator opens with the default session name, which is editable by the user 
within the Navigator window. Current root projects are loaded with the following 
attributes:

■ Lock Status

■ Name

■ Description

■ Status

■ Lock User

■ Owner

■ Schedule Start Date

■ Schedule End Date
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You can manipulate the current Gantt session by using the following buttons and field 
at the top of the Navigator window:

■ Session Name field - This is an editable field that allows you to change the default 
session name.

■ Add (plus) button and Remove (minus) button - See "Adding Projects or Deleting 
Projects From Gantt" on page 2-49 for more information.

■ Full Lock, Internal Lock, and Unlock buttons - See "Locking and Unlocking 
Projects in Navigator" on page 2-50 for more information.

There are three buttons at the bottom of the Navigator window, including:

■ Exit - Apply changes and exit Navigator.

■ Apply - Apply changes and stay in Navigator.

■ Cancel - Exit Navigator window.

Adding Projects or Deleting Projects From Gantt
You can add projects to Gantt from within the Navigator. You can search for root 
projects by all attributes that are available in Advanced Search. Discovery and Read 
privileges of the user are considered.

To add a project to Gantt from Navigator:

1. Within Navigator, click the Add (plus) button. The Search window appears.

2. Enter a keyword in the Value field in the Search window.

3. Click Find to execute the search. Search results appear in the bottom panel of the 
search window. 

4. Select the rows of projects to add. 

5. Click OK to add the projects, or Cancel to exit the search window. The selected 
root projects are added to the main Navigator window.

Note: If a project to be added has PLM Reference projects, the PLM 
Reference projects are also added to Navigator. A message indicating 
this is displayed in the bottom-left of the Navigator window. Hover 
over the message to view the tooltip which contains more information.

6. Click Apply to make changes effective in Gantt.

Note: When you add additional projects to the Gantt session using 
Navigator, the newly added projects are always Read Only by default, 
even if the current projects are all locked. You need to lock the newly 
added projects manually through Navigator.

To remove a project from Gantt using Navigator:

1. Select the project(s).

2. Click the Remove (minus) button above the table to remove the project(s).

3. Click Apply or Exit to put changes into effect.

Note the following conditional situations:
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■ If a user removes all but one project from multi-project Gantt, then Gantt begins to 
function as single-project Gantt.

■ If a user tries to remove all projects from Gantt, an error message is displayed in 
the bottom-left corner of the Navigator window. Hover over the message to view 
the tooltip which contains more information.

■ If a user tries to remove a project that has unsaved/pending changes, a popup 
window appears to notify the user.

Locking and Unlocking Projects in Navigator
Within the Navigator, you can use the lock/unlock buttons. The current status of a 
project’s locked/unlocked state is shown in the Lock Status column in Navigator.

Note: Unlike the Add/Remove functionality in Navigator that does 
not go into affect until the user applies them, all lock functionality in 
Navigator is applied once the lock or unlock button is clicked.

To lock or unlock a project within Navigator:

1. Select the project(s) that you want to unlock or lock.

2. Click the appropriate lock button to do a Full Lock, Internal Lock, or Unlock. 
Depending on the outcome, a success or failure message appears.

The following is the logic that is used when a user attempts to lock/unlock a project 
within Navigator:

■ Full Lock: The user selects one or more projects and clicks the button to lock 
projects:

–  If the selected projects are unlocked, the system tries to lock these projects:

* If this succeeds, a message is returned stating that Project XXX has been 
locked successfully.

* If this fails, a message is returned stating that Project XXX cannot be 
locked because it is locked by user XXX.

– If the selected projects are Internal Locked, the system tries to lock the 
dependent projects according to the external dependencies.

* If this succeeds, a message is returned stating that Project XXX has been 
locked successfully.

* If this fails, a message is returned stating that Project XXX cannot be 
locked because it is locked by user XXX.

■ Internal Lock: The user selects one or more projects and clicks the button to 
internal lock these projects:

–  If the selected projects are unlocked, the system tries to lock these projects:

* If this succeeds, a message is returned stating that Project XXX has been 
locked successfully.

* If this fails, a message is returned stating that Project XXX cannot be 
locked because it is locked by user XXX.

–  If the selected projects are Full Locked, the system tries to unlock the 
dependent projects according to the external dependencies.
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* If this succeeds, a message is returned stating that Project XXX has been 
unlocked successfully.

* If this fails, the error message is shown, along with the reason.

■ Unlock: The user selects one or multiple projects and clicks the button to unlock 
projects.

–  If the selected projects are Full Locked, the system tries to unlock the projects 
and their dependent projects according to the external dependencies.

* If this succeeds, a message is returned stating that Project XXX has been 
unlocked successfully.

* If this fails, the error message is shown, along with the reason.

–  If the selected projects are Internal Locked, the system tries to unlock these 
projects.

* If this succeeds, a message is returned stating that Project XXX has been 
unlocked successfully.

* If this fails, the error message is shown, along with the reason.
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3Setting Up Project Management Processes

This chapter describes how to set up processes necessary for the proper functioning of 
projects and programs, including the following:

■ Defining Calendars

■ Creating Project Templates

■ Adding Activities and Gates

■ Setting Ownership to Resource Pools

■ Managing Content

Defining Calendars
PPM provides the ability to create customized calendars to deliver better schedule 
accuracy. You can create country or region-specific calendars to ensure that national 
holidays and other non-working days are taken into consideration while scheduling 
tasks. To do this, you define which dates within a calendar year should be marked as 
working days by exception, or non-working days by exception. While scheduling or 
re-scheduling a project, the scheduling process skips non-working days and schedules 
project activity only on working days.

If a project has resources in three different locations, you can create a calendar for each 
location, specifying applicable working and non-working days. For example, you 
could create separate calendars for U.S.A, India, and China. Individual tasks within a 
project can be based on different calendars. 

The scheduling algorithm performs calendar checks for leaf-level activities, and this 
may affect start and end dates, and also duration. For example, when you move the 
schedule forward, a Schedule End Date could be moved further than you expect, to 
accommodate an exception defined in a leaf-level activity calendar.

Calendar checks are not performed at the parent level as dates are rolled up from 
leaf-level activities.

Use the Calendar menu under Tools and Settings in Web Client to create and 
configure calendars for your project. 

For more information, see "Configuring Calendars" on page 10-24 and "Using 
Calendars" on page 4-22.

Setting up a Project Structure
When creating a new project, the easiest way to build the structure is to start at the top 
and work down. Typically, for a structured project, you need:
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■ Parent project object

■ Child activity objects

■ Designated project "gates"

■ Pool of resources (project team members)

You can store project specifications and requirements documents with the parent 
project object, to make it easy for project members to locate them.

The general procedure is to create the root-level project first and then create the child 
objects.

Sequence of steps:

1. Create the root-level project object using the method described in "Creating a 
Project" on page 4-1. Be sure to specify Project as the object type.

2. Create the first child object. Go to the Schedule tab of the new Project object, and 
click Add. Create the first child object. All objects created from the Schedule tab 
are children of the current object.

3. Repeat the process to create additional child objects, as needed.

4. Open each child object and create its child objects, as needed.

5. Set Gates to delineate the completion of key project goals.

6. Set Milestones to define a target or trigger point for project metrics or 
communications.

7. Map existing dependencies between project objects.

Once you have the structure in place, you can use Actions > Save As to save it as a 
template for future projects.

You can also create project objects using the project Gantt Chart. For further 
information, see "Gantt Chart" on page 2-27.

Creating a Project Template
Project templates provide a framework to create projects with similar components. 
These components include tasks, resources, and deliverables that can be similar in 
construct across multiple projects. Use project templates as a base to modify project 
content and schedule as required for various projects.

To create a template:

1. Launch Agile Web Client.

2. Click the Create New drop-down menu.

3. Select Projects > New. The Create New dialog appears.

4. In the Create New dialog, from the Type list, select Project. Additional fields 
appear.

5. Enter the Name of the template.

6. Enter the Description of the template, if required.

7. From the Delegated Owner palette, select the delegated owner.

8. From the Project State list, select Template.

9. From the Calendar list, select a calendar. Working and non-working days specified 
in the chosen calendar are used in schedule calculation.
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10. Select a Duration Type.

11. From the Calendar palette, select a Schedule Start Date.

12. Enter the Schedule Duration in days. The Schedule End Date is an 
auto-populated value.

13. Click Save. The General Info tab of the new project appears. Fill in information on 
the various project tabs, as required.

Identifying the Template Used to Create a Project
If a project is created from a template, a link to the template is provided in the Created 
from Template field in the General Info tab of the project and its child activities. You 
can click this link to open the Template that was used to create the Project.

After creating a project from a template, if you add child activities to this project, the 
Created from Template field for these activities will be blank as these are not created 
from the template.

■ If you save an existing template as a Proposed or Active project, the Created from 
Template field shows the name of the original template.

■ If you save an existing template as another template, the field is left blank.

■ If you perform a Save As operation on any level lower than the root level, the field 
is left blank.

Adding Activities
You can add activities such as Project, Program, Phase, Task, Gate, or Milestone from 
Gantt Chart or Web Client.

Add Activities using Gantt Chart
You can add activities to a Project from the Gantt Chart using the Insert Activity 
options on the main toolbar or the right-click menu.

Alternately, you can use the quicker options listed below.

To add an activity in Gantt Chart:

1. Select the row under which you want to add an activity.

2. Press the Insert key on your keyboard. This inserts a new row below the row 
currently selected.

3. Type the name of the activity in the newly created blank row.

The activity created belongs to the Task subclass. To add an activity of a specific 
subclass, use the shortcut key Ctrl+Alt+A.

4. In the Activity dialog that opens, select a subclass for the activity.

5. Specify the Start Date and End Date. The Schedule Duration field will 
automatically display the number of days based on the start and end date. You can 
also specify the start date and enter the total number of days of your project in the 
Schedule Duration field; the end date is automatically calculated.

6. From the Calendar list, select a calendar. Working and non-working days specified 
in the chosen calendar are used in schedule calculation.

7. Click OK to add the activity.
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Add Activities 
You can add activities from the Schedule tab of a Project, Program, or Phase.

To add an activity using Web Client:

1. Click the Schedule Tab.

2. Click Add.

3. In the Create New dialog, from the Type list, select the Type of activity.

4. In the remaining fields which appear, type the mandatory information such as 
Name, Owner, Calendar, Schedule dates, and Duration Type as applicable.

5. Enter the optional fields, as required.

6. Click Save. The activities appear as a table in the Schedule Tab.

Adding Gates
A Gate is a zero duration activity which signifies completion of a major activity similar 
to a Milestone. A Gate can be added in the Gantt Chart or Web Client to enable checks 
or control, for completing tasks on schedule before a new task can start. A dependency 
should be created to achieve this. See "Creating and Editing Dependencies in Gantt" on 
page 4-24.

To add a Gate in Gantt Chart:

1. Select an activity on the tabular view pane.

2. From the right-click menu, click Insert Gate. Or, simply click the Gate icon on the 
tool bar. You can also use the shortcut key Alt+G.

3. In the dialog that opens, enter a name for the gate and specify the End Date.

4. Click OK to add the gate.

To add a Gate in Web Client:

1. Navigate to the activity in which you want to add a gate.

2. Click the Schedule tab.

3. Click Add.

4. In the Create New dialog, from the Type list, select Gate. The remaining fields 
appear.

5. Enter the Name of the gate.

6. Enter the Description of the gate, if required.

7. Use the address book palette to select a Delegated Owner, if you want to delegate 
the ownership of the gate.

8. From the Calendar list, select a calendar. Working and non-working days specified 
in the chosen calendar are used in schedule calculation.

9. Choose the Schedule End Date for the gate.

10. Click Save. The details of the gate appear in the Schedule tab as a row of data.

Defining Stationary Gates
To have better control over the project schedule, you can mark some gates as 
Stationary Gates. If you define a gate as 'stationary', only users with explicit privileges 
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to move the gate can move the preceding tasks forward. For details on configuring this 
privilege, see "Configuring Stationary Gates" on page 10-16.

To define a stationary gate:

1. Open the gate object.

2. On the General Info tab, click Edit.

3. Scroll down to the bottom of the page to locate the attribute Enable Stationary 
Gate.

4. The default option is No. Change this to Yes.

The gate is marked as a stationary gate and only users with appropriate privileges can 
move the preceding tasks forward.

Adding Milestones
A Milestone is a zero effort activity identical to a Gate, which marks the completion of 
a set of activities including gates. Usually, milestones are not directly dependent on 
deliverables. Milestones can contribute to dependencies in projects where more than 
one sub-projects are involved and the milestone of one project drives the progress of 
another.

To add a Milestone in Web Client:

1. Navigate to the activity in which you want to add a milestone.

2. Click the Schedule tab.

3. Click Add.

4. In the Create New dialog, from the Type list, select Milestone. The remaining 
fields appear.

5. Enter the Name of the milestone.

6. Enter the Description of the milestone, if required.

7. Use the address book palette to select a Delegated Owner, if you want to delegate 
the ownership of the milestone.

8. From the Calendar list, select a calendar. Working and non-working days specified 
in the chosen calendar are used in schedule calculation.

9. Choose the Schedule End Date for the milestone.

10. Click Save. The details of the milestone appear in the Schedule tab as a row of 
data.

Editing Data
You can perform the following data-editing actions within the Gantt Chart:

■ Copy and Paste from Excel - You can copy and paste a project directly from an 
Excel sheet into the Gantt tabular pane. Data in the Excel sheet should be in the 
field format shown below.

Sub-class Name Schedule Start Schedule End

<Activity Type> <Program Name> <date format 
according to User 
Preference in Agile>

<date format according 
to User Preference in 
Agile>
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The data to be copied and pasted should contain the activity Type such as Program, 
Phase, Task or Gate, the project name and the start and end dates of the project. (For 
Gates, the Start Date is considered as the End Date in Agile). These fields are 
mandatory. Ensure you do not select the header row when copying from Excel.

■ Copy and Paste Activities -You can copy and paste single or multiple activities in 
the tabular view.

■ To copy, select the activity or activities, and click Copy in the right-click menu, 
or click the Copy icon on the toolbar.

■ To paste, place your cursor on the destination row and select Paste in the 
Right-click menu, or click the Paste icon on the toolbar.

When you copy an activity to create one, the following information is copied over: 
Cover Page, Page Two and Page Three attributes, schedule dates and resource 
assignments. If the activity has any dependencies defined, or content associated with 
it, these are not copied.

■ Copy and Paste Content - Content must be pasted in a relevant destination. For 
example, you cannot copy a text field into a date format field.

■ Fill-up / Fill-down - You can replicate content such as activity names or dates on 
the tabular view. This action copies the text of the selected cell to adjoining cells 
you select.

To fill-up or fill-down, place your cursor on the corner of the selected cell. The 
cursor changes into cross-hair shape. Drag the cross-hair cursor up or down, to 
replicate the same text in the cells above or below.

Note: You cannot fill dates up or down if there is a dependency 
attached to the activity, and the fill action results in the Successor date 
falling before the Predecessor date.

■ View Program Information - You can view an activity's general information, Page 
One, and Page Two details from the Gantt Chart.

To view project information, right-click a project activity and select Properties.

The Web Client offers the following options to edit data in the tables:

■ Copy

■ Paste

■ Fill-up

■ Fill-down

These options are available in the More menu of the Team, Content and Attachment 
tabs of a project.

For more information, see the Getting Started with Agile PLM User Guide.

Deleting Project Elements
You need appropriate privileges to delete the project elements. An owner may delete a 
Phase, Task, Deliverable, or Gate. When deleted, Discussions and File Folders are 
removed only from the project, not from the system. They are retained as standalone 
objects in Agile. When you delete a project element from the Recycle Bin, the system 
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deletes it from the database. For more information on deleting Agile objects, see 
Getting Started with Agile PLM User Guide.

To delete a project element:

1. Select the row of the object you want to remove.

2. Click the Remove button. The Reason palette appears.

3. In the Reason Codes list, select a Reason Code.

4. In the Comments field, enter comments as appropriate. This option becomes 
available only if the corresponding SmartRule - Enable Comments for Deleting, 
Archiving & Delegating - is enabled in Java Client. For details, see the Agile PLM 
Administrator Guide.

5. Click OK.

The Reason Code and Comments fields are optional. This information is recorded in 
the History tab of the object. When you delete a child object, the reason for deletion 
appears in the History tab of the parent object.

Alternatively, you can also use the Actions > Delete menu command to delete a 
selected project element.

Setting Ownership to Resource Pools
Organizations have projects spanning across departments and hence efficient resource 
management for these projects require an owner for the Resource Pool. A user group 
that is associated to a resource pool is owned by the user that created the user group, 
by default. However, you can modify the ownership of a given resource pool.

To set ownership to a Resource Pool:

1. Navigate to Tools and Settings > Address Book > User Groups.

2. In the table, click the Name of the user group that is a Resource Pool. The user 
group page appears.

3. In the General Info tab, click Edit.

4. From the Owner palette, select the owner of the resource pool.

5. Click Save.

If the User Group that you select is not a resource pool already:

1. In the General Info tab, select Yes in the resource pool list.

2. From the Owner palette, select the owner of the resource pool.

3. Click Save.

Managing Content
In PPM, 'content' refers to deliverables associated with the project. A deliverable can 
be any project or project object that has a lifecycle phase or a workflow assigned to it, 
or any file added as an attachment in the Content tab. Examples of content are 
programs, projects, phases, templates, files or URLs, or objects referenced from other 
applications.

The Content tab is not simply a list of deliverables, but a rule-based control system for 
project management. Any content can have a rule associated with it. Rules can be set 
to prevent tasks from starting or completing unless certain deliverables have reached 
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specific states or status. The template will allow you to build out complex control 
mechanisms that alert users, automate many project processes, and prevent 
inappropriate tasks from starting or completing out of sequence or without the right 
information. The following picture outlines what the content tab can contain, what 
rules can be applied and if the content itself can have attachments or content:

Figure 3–1 ’Content’ in PPM

Important: As a best practice, it is recommended that the 
attachments tab in Agile PPM activities and gates be disabled. Agile 
PPM provides a unique tab, the Content Tab, that must be used for all 
project content, including attachments, for projects.

Discussions, Users, and User groups are the only objects that cannot be added as 
deliverables.

This section describes content objects and key functions such as adding new content, 
marking content as 'Mandatory', and working with the Content tab.

Adding Content
You can add activities and gates as deliverables on other activities and gates. You can 
also set rules to ensure the completion of one activity before another. For example, to 
ensure the completion of an activity before a gate is opened, you can add that activity 
as a deliverable for the gate to open. You can even restrict one gate from opening 
before another gate is opened, by adding the prior gate as a deliverable to the 
subsequent gate.

For more information on defining rules, see "Defining Rules for Content" on page 3-12.

When adding Projects as deliverables to other projects, they can be Proposed or 
Active.
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Templates can also be deliverables. For a project that has its own copies of 
deliverables, a template can be a deliverable on tasks.

■ You cannot add an object that causes a circular relationship as a deliverable. For 
example, you cannot mandate that Task1 is a deliverable for Task2 to reach 
completion, and Task2 is a deliverable for Task1 to reach completion.

■ To add an object, you must have Create privilege for that object, and Modify 
privilege on the attribute for that object.

To add content to an activity:

1. Navigate to the activity to which you want to add content.

2. Click the Content Tab.

3. Click Add > By Search to search and select an object to add. Or click Add > By 
Create to create an object.

4. Complete the required information in the appropriate fields.

5. Click Add.

The added content appears in the Content Tab.

You can use the combination of Ctrl + I keys to view the Create to Add icon and the 
Search field.

To add content to an activity using custom search:

1. Use the Search icon or use Ctrl+Shift+Q keys and specify the search criteria.

2. Click Navigator on the Search Results pane. The search results appear on the left 
navigation pane.

3. Navigate to the Content tab of the activity to which you want to add content.

4. Drag and drop the objects you want to add, from the Navigation pane into the 
Content tab.

You can also drag an object from the Recently Visited list on the left pane and add it to 
an activity.

If the content you want to add is already part of another project, you can copy the 
content from another project (Use More >Copy) and paste (Use More > Paste) it into 
the current project. You can also add Files and URLs as content to an activity.

If you are adding a revision-controlled object, you can double-click the Revision field 
to choose the revision.

To add reference objects:

1. In the Content tab, click Add > Reference Objects.

2. In the Search dialog that opens, select a category and search for the object you 
want to add. (You can click the name of the object to view it in the corresponding 
application.)

3. Double-click the row to add the reference object.

Objects that can be referenced are configured in Java Client, under Admin> System 
Settings > Reference Objects Management. Reference object categories need to be 
defined as subclasses under the Reference Objects class. For more details on 
configuring reference objects, see the Agile PLM Administrator Guide.

To add files:

1. Click Add > Files in the Content Tab.
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2. In the File Upload Selector dialog, browse for and select the files that you want to 
upload.

3. Select upload options as appropriate.

4. Click Upload. The selected files appear in the Content table.

You can add up to five files in a File Folder.

1. If you want to add all the selected files to the same File Folder, select Add all files 
to a single file folder check box.

2. Click Add. The selected files display in the Content tab.

To add URLs:

1. Click Add > URLs in the Content tab. The Add URL dialog box appears.

2. Type the URL of the web page you want to add as content.

Note: Do not delete the prefix http:// in the URL fields.

3. To view the web page before adding it, click Preview.

4. Enter the Description for the URL, if required.

5. To store all the added URLs in a single File Folder, select Add all URLs to a single 
file folder.

6. Click Add. The selected URLs display in the Content tab.

Adding Revision-controlled Objects
If you are adding a revision-controlled object to the Content tab, you can double-click 
the Revision field to choose a particular revision or all revisions. Multiple revisions are 
allowed for the same object, in separate rows. When any revision-controlled object is 
revised, all related objects are tagged as "impacted".

You can configure Revision attributes (Impacted, Revision, Track Impact, and 
Change) for a class or subclass in Java Client Administrator. For details on how to 
enable or disable attributes in Java Client, see the Agile PLM Administrator Guide.

Note: The Revision field cannot be edited if the task is in Completed 
or Canceled status.

Setting Mandatory Content
The Content tab of the activity has project deliverables such as Change Orders, 
Problem Reports, Items, Documents, Digital Files, activities, gates or URLs. One or 
more of these deliverables may be required due to regulatory mandates (from agencies 
such as the FDA), certifications (such as ISO), or approvals (such as Underwriters 
Laboratory), and cannot be overlooked or deleted by the project managers.

For example, a product may require an Underwriters Laboratory listing before moving 
into production, and this document is a deliverable for the task assigned to deliver it. 
You can mark this content as 'Mandatory', to ensure that this deliverable and its 
related task cannot be deleted by the project manager. Only an Agile PPM 
administrator or user with the appropriate privileges can delete this task from the 
project tree.



Note: This action is restricted to users who have the 
Activities.Content.MandatoryApplied To property on the Modify 
privilege mask. For more information, see "Modify Privilege Mask 
Applied To Properties that Control Specific User Actions" on 
page 10-9.
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To set mandatory content:

1. Navigate to the activity that has the requisite content.

2. Click the Content Tab.

3. Click the row that displays the content to be mandated.

4. Double-click the corresponding cell in the Mandatory column.

5. In the list, select Yes. Click any other cell to save the modified value.

You can set rules on the contents of any activity to ensure a check on the availability of 
the Project artifacts. For more information, see "Defining Rules for Content" on 
page 3-12.

Setting Up AutoNumbering
AutoNumbers are the unique identifiers for PPM objects. The AutoNumbers of 
deliverables are dependent on the AutoNumber preset for each type of deliverable. In 
PPM, the Web Client does not allow you to modify the AutoNumbers.

For more information on AutoNumbers, see "Duplicating Deliverables from a Project 
Template" on page 3-13. For information on setting up AutoNumbering in Agile PLM, 
refer the Agile PLM Administrator Guide.

Personalizing Views for Content
The Personalize menu in the Content Tab enables you to set your preferences for the 
content table.

The following personalization settings are possible for the content table:

■ Sort: Sort the displayed data by three different attributes in ascending or 
descending order.

■ Filter: Filter the displayed data by one or more column-specific search strings.

■ Format: Choose the fields or columns to be displayed on the table.

■ Properties: Display the details specific to the current View selected in the Views 
list.

For detailed information on personalizing table views, refer to the Getting Started with 
Agile PLM Guide.

In the Content tab of any activity, you can personalize views based on the keywords of 
the root project.

To choose keywords:

1. In the root project, click the General Info tab.

2. Click Edit.

3. In the Status Information section, select the keywords applicable to the project 
from the Project Keywords palette.
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If you do not see the keyword of your choice, add it to the Keyword list in Java 
Client.

4. Click Save.

Your keywords appear in the Views list, in the Content Tab of the root Project. In 
addition, the keywords appear in the More > Add Keyword menu.

To personalize views based on Keyword:

1. Navigate to the content table that you want to personalize.

2. Select a content row.

3. Click More > Add Keyword.

4. Select a Keyword appropriate to the selected content.

5. In the Views list, select the Keyword. The content table lists only those content 
objects that contain the selected keyword.

In the contents table, the Keyword column of the content row displays the keyword 
associated with the content.

Defining Rules for Content
You can set Relationship Rules on content to ensure dependency criteria. Consider an 
example scenario, where one of the activities in your project must be 'Complete' before 
another begins. This change of status contributes to the dependency in the scenario. 
Relationship rules define the relationship between the status of the content and 
activity, and the nature of the action triggered when the rule is satisfied.

To set relationship rules for the content in an activity:

1. Navigate to the activity that has the requisite content.

2. Click the Content tab.

3. To select a content row, click the row handler on the row.

4. Click Edit Rule.

5. In the Relationship Rule palette, select the content status from the list.

Example: Document 1 is Review

6. Select the corresponding Activity status that you want to set.

Example: Set Activity to Complete

7. Click Save.

In the Relationship Rule palette, to remove a Relationship Rule, click Remove. To 
return to the Content tab, click Cancel.

You can also add Rules for Content, using the Quick View dialog of the added content.

To add a rule using Quick View dialog:

1. Place the mouse cursor on the Name of the content.

2. Click the Quick View call out to view the details of the content in a Quick View 
dialog.

3. Click Add Rule link in the dialog to set a relationship rule.

4. In the Relationship Rule palette, select the Content Status from the list.

Example: If Document 1 is Review
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5. Select the corresponding Activity status that you want to set.

Example: Set Activity to Complete

6. Click Save.

Duplicating Deliverables from a Project Template
There are certain considerations you need to remember when you create a project from 
a Template as described in "Creating a Project" on page 4-1. These are provided here 
for your reference.

■ While creating a Project from a Template, you can opt to duplicate or clone the 
Content objects from the template project. Select the Content check box in the 
Optional tab section of Create new > Project > From Template> Create New 
dialog.

■ If the Content check box is selected, copies are created for all deliverables in the 
template. The project and all its child activities will reference the newly created 
copies and not the original deliverables in the template. For example, a content 
object such as a Marketing Requirements Document that was available in the 
template is duplicated in the new project, with the file attached from the template.

■ If the Content check box is not selected, there are no copies of deliverables created, 
and no links are provided to any deliverables on the template.

■ If the Content object does not have a Rule, only the link is copied and this link 
will point to the same object as in the template. For example, a Content object such 
as a Standard Operating Procedure (SOP) document, where it is not necessary to 
create an object, and only a link to the controlled document is necessary.

■ In the template, if a task's workflow rule criteria has already been met, the content 
is copied over to the new project but not the rule.

For example - A task in the template has the following rule - When Complete, Set 
Active Gate to In Review. If the Active Gate is Open or Canceled, it is already past 
the In Review Status in the workflow progression, so the rule is not copied over.

■ In general, copies are not created for all objects that do not have a Save as 
functionality. All deliverable objects for which copies cannot be automatically 
created are listed in the error log window.

AutoNumbers
■ If multiple AutoNumbers exist on a content object and the system does not know 

which one to use, content is not created and an error is reported.

■ Within the template, ensure that an AutoNumber is set for each deliverable. 
Deliverable AutoNumbers for the created project are automatically selected based 
on the AutoNumber chosen for the original deliverable in the template.

■ The AutoNumbers attribute is not filled in Proposed or Active type projects. If 
such projects are saved as templates, you need to fill in the AutoNumber attribute 
in the template again.

■ Copies are not created for deliverables where the AutoNumber field is left blank. 
Templates use the AutoNumber attribute of a particular content to determine the 
name of the deliverable to be created.

■ For all classes, if the same object is a deliverable for multiple activities and gates in 
the template, the copy of the object is created for the first activity / gate for which 



Managing Content

3-14 Product Portfolio Management User Guide

it is a deliverable, and a link to this copy is provided for all other subsequent 
activities or gates for which the same object is a deliverable.

For example, let's say that a document DOC00341 is a deliverable that is referenced 
twice in a template, on Task1 and Task2. When a project is created from this template, 
a new copy of the original deliverable in the template is created - DOC00982 for Task. 
This document will be a deliverable for Task2 as well, following the same pattern as in 
the template that the project is created from.

Required Fields
■ All required fields are copied from the original deliverable to the newly created 

copy.

Tabs
■ For all subclasses, Cover Page, Page Two, Page Three and Attachments tabs are 

copied.

For example, if an assembly is a deliverable on one of the tasks, the only tabs that are 
copied are Page One, Page Two, Page Three and Attachments. The BOM tab is not 
copied over.

Activities and Gates
■ When internal activities and gates in the template are used as deliverables, 

corresponding copies are created in the newly created project tree and referenced 
as deliverables in the other activities and gates as defined in the template.

■ When activities and gates within a template or source project are added as 
deliverables to later activities and gates in the template, the deliverables on a 
project created from the template will also reference corresponding activities on 
the newly created project.

For example, if Task1 is a deliverable of Task2 in the template, then for any project that 
is created from the template, Task1 in the project will be a deliverable of Task2 in the 
project. This is one approach of implementing hard exit on gates, that is, ensuring 
certain activities are completed or certain gates are opened before another specific 
activity is completed or gate is opened.

Root Projects
■ Only the root projects of Template type are allowed as deliverables for activities 

and gates within a template.

■ If an external root template is a deliverable on a task of a template, a new project 
deliverable is created as a copy of the original template deliverable. This copy of 
the original project deliverable has the project tree structure in place, but no 
deliverables. When creating copies of external root templates, only General Info, 
Page Two, Page Three, Attachments, Dependencies and Schedule tabs are copied.

Team and Content tabs are not copied.

External root templates, if used as deliverables multiple times, are cloned only once, 
similar to internal activities and gates.

Templates
■ If the user chooses to create a proposed project from a template, all templates that 

are deliverables of this template are created as proposed projects that are 
deliverables of the newly created proposed project. (The same applies if you 
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choose to create an Active project from a template. For the copies, only the name 
of the root project is changed; the names of the activities and gates remain the 
same. The activities and gates numbers, however, are system-generated and 
unique.

■ Copies of external activity deliverables that are not root templates are not created 
because non-root activities cannot exist by themselves. In this case, the 
deliverables on the project created from the template will reference the original 
deliverables on the template for such objects.
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4Creating and Managing Projects

Creating and managing projects in PPM involves using Web Client or Gantt to:

■ Create, edit, activate, and baseline a project

■ Work with project content

■ Assign resources and allocate activities

■ Establish dependencies and reschedule activities

■ Initiate and respond to discussions

Creating a Project
You can create a project using Web Client or Gantt.

Using Gantt Chart
You can create an Active or Proposed project from the File menu or an existing 
template in Gantt.

To create a project using the File menu in Gantt:

1. Launch Gantt Chart. See "Launching Gantt" on page 2-29.

2. Click File > New. The New Project window opens with the standard duration of 
one day.

3. To rename the project, double-click the name of the project.

4. Click File > Save. The project is Active by default.

Right-click the project name in Gantt and click Properties to modify the various 
properties of the project.

To quickly create a project using data from a spreadsheet:

1. Ensure that the data in the spreadsheet is in the following format:

Activity Type Name Schedule Start Date Schedule End Date

<type of activity> <name of activity> <start date in 
mm/dd/yy format>

<end date in mm/dd/yy 
format>

Dates should be in the mm/dd/yy format.

2. Copy the required rows from the spreadsheet.

3. Launch Gantt Chart. 
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4. Click File > New.

5. Select the default row that appears and paste the rows you copied (Press CTRL+V 
or right-click and select Paste). Errors, if any, are reported at the bottom of the 
window.

6. The project is copied over. Click File > Save.

To create a project from an existing template in Gantt Chart:

1. Click File > Open to view the Activity window.

2. In the Find From list, select Root Templates.

3. If you know the name of the template, enter the Name, or click Find.

4. Click a row to select the template.

5. Click OK to view the new project based on the selected template.

6. Click File > Save as File to save the project on the disk.

7. In the Save as File Options dialog, enter the Name and Description for the new 
project.

8. Select Active or Proposed from the Project State List.

9. Click OK and select the destination folder for the new project.

The new project does not have the Page Two and Page Three attributes copied from 
the template. The content from the Attachments and Content tabs are not copied 
when you save a new project from a template using Gantt.

Using Web Client
You can create a project from Web Client using the following:

■ The Create New menu

■ The Save As menu

■ An existing project template

In the Web Client, the Create New menu enables you to create a project.

To create a project using the Create menu:

1. Launch Agile Web Client.

2. Click the Create New drop-down menu.

3. Select Projects > New.

4. In the Create New dialog, select Project from the Type list.

5. Enter the Name of the project.

6. Enter the Description for the project, if required.

7. From the DelegatedOwner list, select the new owner for the project. The default 
owner of the project is the logged-in user.

8. Select Proposed in the Project State List. You can change the status to Active when 
you are ready to roll out the project. Your selection here can have implications on 
the AutoNumber attributes of the new project. For more details, see "Duplicating 
Deliverables from a Project Template" on page 3-13.

9. In the Schedule section:
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■ From the Calendar list, select a calendar. Working and non-working days 
specified in the chosen calendar are used in schedule calculation.

■ Select Duration Type, Schedule Start Date, and Schedule End Date. The 
Schedule Duration is automatically calculated as the difference between the 
start and end dates.

10. Click Save.

Note: If Recipe & Material Workspace (RMW) is installed, you are 
presented the option to create an RMW Project or RMW 
WorkRequest. In the Type list, these options appear instead of 
Project. All other steps remain the same.

The Actions > Save As menu enables you to save an existing template as an 'Active' or 
'Proposed' project. The default type of the project is Active.

To create a project using the Save As menu:

1. Navigate to the Template or Program which you want to save as a new project.

2. Click the Actions > Save As menu.

3. In the Save As dialog, enter the Name of the project.

4. Enter the Description for the project, if required.

5. Select Proposed in the Project State list. You can change the status to Active when 
you are ready to roll out the project. Your selection here can have implications on 
the AutoNumber attributes of the new project. For more details, see "Duplicating 
Deliverables from a Project Template" on page 3-13.

6. Select the optional components of the project or template whose contents you 
want to copy to the new project.

7. If your template or project has a lot of content to be copied, select the Run As a 
Background Process check box. You can then continue working on other projects 
while the new project is being created. A notification is sent to you when the 
process completes. You can open the project directly from the notification link.

8. To mark this project as the baseline version, select the Kick-off Baseline check 
box.

9. Click Save.

You can create a project from an existing template to avoid entering all project-related 
information afresh.

To create a project object from an existing template:

1. Launch Agile Web Client.

2. Click the Create New drop-down menu.

3. Select Projects > From Template.

4. In the Create New dialog, from the Templates palette, select Template. The 
remaining fields appear.

5. Enter the Name of the project.

6. Enter the Description for the project.
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7. From the Owner list, select the new owner for the project. The default owner of 
any activity in the project is the owner specified for that activity in the template.

8. If you want this user to own all the child project-objects, select the Apply as owner 
for this level and below check box.

9. Select the Start Date or End Date option. Use the Calendar palette to select the 
Schedule date.

10. Select Proposed in the Project State list. You can change the status to Active when 
you are ready to roll out the project. Your selection here can have implications on 
the AutoNumber attributes of the new project. 

11. Select the optional components of the template whose contents you want to copy 
to the new project.

12. If your template has a lot of content to be copied, select the Run As a Background 
Process check box. You can then continue working on other projects while the new 
project is being created. You receive a notification when the process completes. 
You can open the project directly from the notification link.

13. To mark this project as the baseline version, select the Kick-off Baseline.

14. Click Save.

When you create a project from a template, the dependencies and content relationship 
rules in the template are replicated in the new project. For details, see "Dependencies 
Between Templates and Active Projects" on page 4-26.

Editing a Project
You can edit the information in the project page tabs such as General Info, Schedule, 
Team, Dependency, Content and Collaboration. In multiuser environments, 
sometimes, more than one user edits the same task in a project. In addition, concurrent 
users may need to edit multiple tasks in the same project tree.

Editing Project Objects Concurrently
The Agile PPM solution is designed to manage large projects with hundreds of 
activities and numerous team members. It is possible for multiple users to edit the 
following:

■ Multiple tasks in the same project tree structure at the same time.

■ The same task at the same time.

Editing Multiple Tasks in the Same Project Tree
When multiple tasks in the same project tree are edited at the same time, the edit 
modifications may have affects on objects higher in the project tree (rollup) or lower in 
the project tree (rolldown).

Editing Tasks with a Predecessor and Successor Relationship
When a parent task is rescheduled to a specific end date, that end date rolls down to 
the child objects. You can also edit a child object end date, which then extends the 
bounds of the parent object (by rollup to the parent object). As each user makes and 
saves his modifications, the necessary rollup or rolldown takes place.
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In this scenario, it is possible for a user to enter a specific date on the edit page, yet see 
a different date upon save, because of the rollup or rolldown caused by another user's 
edits. However, the schedule remains accurate.

Examples
■ Task B (owned by Bob) is a predecessor to task A (owned by Mark). Bob and Mark 

are editing the schedule dates of their tasks at the same time, and save their edits 
one right after the other. If the new edited dates of the first saved task cause the 
dates of the second saved task to change, the person saving the second task is 
presented with a message explaining that the dates he entered will be changed and 
he can accept the change or cancel.

■ Mary is editing a parent activity and several other users are editing several child 
activities at the same time. Mary reschedules the specific end date of the parent 
activity. At the same time, some child activities have been modified in such a way 
that the end date of the parent activity is extended. As each edited activity is 
saved, the dates for the parent or child activity are updated correctly for schedule 
accuracy. A user may save his activity and see a different date than the one he 
entered on the edit page, but the schedule is accurate.

■ New roll-up data overwrites a common parent or root activity.

Susan owns task C and Fred owns task D. Both task C and task D have a common 
parent, task M, thus they are both in the same tree structure. Both Susan and Fred are 
editing their tasks, modifying data that rolls up to parent task M (percent complete, 
cost, or status data). Fred saves task D and task M is rescheduled according to Fred's 
edits. Then Susan saves task C, and task M is again rescheduled, this time according to 
Susan's edits.

Multiple Users Editing the Same Task
To keep other users from editing roll-up or roll-down attributes of the object you want 
to edit, use the feature in Web Client. Locking an object means that only you can edit 
rollup and rolldown attributes and other users who edit the object are "locked out". 
Although they can edit attributes that do not rollup and rolldown, they cannot edit 
roll-up and roll-down attributes until you have finished your edits and you have 
unlocked the object.

When you use Launch in Microsoft Project or Gantt Chart, Agile automatically locks 
the project. When you update from Gantt Chart or Microsoft Project, Agile 
automatically unlocks the project.

In Web Client, when you use Edit on the General Info, you must click Lock before you 
click Edit, to lock the object. The differences between locked editing and unlocked 
editing are explained below.

Locking Tasks for Editing
When a user (Mary) locks the task before entering edit mode, Agile provides the 
following safeguards when a second user (Carl) edits the same task:

■ Carl sees a message "This activity is currently locked by another user. For this 
reason some fields will not be editable."

■ While in edit mode, Carl can edit only non-rollup attributes on the General Info, 
Page Two, and Page Three. Carl can save his edits. When Mary saves her edits, 
Carl's edits may be overwritten. The most recent update of non-rollup attributes 
overwrites the others.



Editing a Project

4-6 Product Portfolio Management User Guide

■ The Name attribute on the General Info is an exception. Even though it is not a 
rollup attribute, when the task is locked, only the lock user may edit this attribute.

When you lock an object, its dependencies (both external and internal) are locked; the 
successors and their children are locked.

To lock and edit an activity object:

1. Open the object you want to edit.

2. Click Lock.

3. Click Edit on the General Info tab.

4. Edit the fields as required.

5. Click Save on the General Info tab.

6. Click Unlock.

Editing Unlocked Tasks
If you do not lock a task before editing it, the same safeguards do not apply.

For example, let's assume there are two users, Joe and Carl. When Joe enters edit mode 
for a task first, and Carl then enters edit mode, the following applies:

■ The second user, Carl, does not see a warning that another user is in edit mode.

■ Regardless of who entered edit mode first, the user who saves first will update the 
Agile database with his modified data. The second user who saves receives the 
following error message: "The current object has been modified by another user, 
please try again. To ensure that your changes are saved, lock the object before 
editing."

■ If the unlocked parent object has been rescheduled to a specific end date, and any 
child objects have been modified in a manner that extends the bounds of the 
parent, no messages are presented, and each modification is saved. The 
appropriate roll-up or roll-down date modifications are performed. Although the 
date information that a user saves might not match the date he entered (due to 
edits made by a different user), the schedule information remains accurate.

■ The exception to the above behavior is when two users edit the task status (use the 
Change Status button) or two users add to the Schedule at the same time. 
Multiple status changes and schedule additions are accepted and saved when 
done in parallel.

Reviewing Changes
After making changes to a project offline or online, you can review your changes using 
an HTML report before saving the project. This feature is available only in Gantt 
Chart.

To review your changes to a project:

1. From the Tools menu of the Gantt Chart, select Show Changes.

A new window opens, showing a comparative view of changes recorded on the server 
and on the Gantt Chart. Activities that have been modified, added or deleted are 
indicated by the colors shown in the legend below the table. A gray dot indicates a 
modified object.
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■ To see details of changes made to an activity or gate, click its name. A pop-up 
window shows Page One, Page Two, Page Three, Schedule and Resource 
information with old and new values. Scroll down to see all changes.

■ To view details of any modifications made to your project schedule, allocated 
resources, dependencies, Page One, Page Two or Page Three fields, click the 
appropriate icon in the respective columns.

Undoing Changes
The Gantt Chart enables you to undo any action that you perform, except Save. You 
can also undo actions such as the opening of a project. The Edit menu displays 
contextual Undo or Redo options based on the current action.

Only one undo or redo operation is supported per action. You can also use the shortcut 
key Ctrl+Z to undo an action. Pressing Ctrl+Z a second time will redo the action.

Activating a Project
A project can be in the Proposed state until the requirements such as schedule, team, 
and content are fixed. When all the project stake holders agree with the key aspects of 
the project specifications, you can activate the project.

When you change a project to Active, Agile PPM does the following:

■ Opens the project to activity by team members

■ Places an active load against all resources and resource pools based on team 
definitions and allocations

■ Starts calculating standard budgeted labor costs

■ Places assigned activities in the assignment lists of project participants.

 Changing a project to Active does not change the status of the project to "In Process".

To activate a project:

1. Navigate to the proposed project or template which you want to activate.

2. In the General Info tab, click Edit.

3. In the Activities Information section, select Active from the Template list.

4. Click Save.

You can change the status and report time against activities, only in an Active project.

Working with Project Content
The Content tab in the project page lists all content specific to the project. This section 
discusses ways to view and update content in Web Client.

The columns displayed in the Content table are configured using Agile PLM's Table 
Personalization feature. Click the Personalize link in the top right corner to select what 
fields you want displayed. For detailed information on table personalization, see the 
Getting Started with Agile PLM guide.

Viewing Content
You can manipulate the Content tab view in several ways to display the objects you 
want to focus on:
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■ Navigator: Click this button to display links to all project content (except for 
external reference objects), within the project tree in the left pane. You can drag 
and drop selected content, such as file attachments, from the Content tab of one 
project to the Content tab of another project using this view.

Figure 4–1 Navigator View of Content

If you do not want to view content in the project tree, you can disable the Display 
PPM Content in Navigator option in Java Client, under Admin > Server Settings > 
Preferences.

■ Display all Levels: Select this check box in the top right corner of the Content tab 
to ensure that your view displays objects at all levels of the project hierarchy 
below the current level.

■ Views: You can use the options in the Views drop-down list to filter the view by 
attributes that you configure. By default, the list includes options such as 
Complete, Pending, and Rule Not Specified. A Pending deliverable is an object 
which has not yet met the specified rule criteria, and a Completed deliverable is an 
object that has met the rule criteria.
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To change the name of any of these views:

1. Click the Personalize button.

2. In the Properties tab of the Table dialog that opens, edit the Name.

3. Click Save.

Note:  A view can be deleted only by the owner of the root project.

To add objects to a view, select the objects, click More Actions > Add Keyword, 
and select one of the available keywords.

Content that you mark with the Important Content keyword will also display in 
the Project Summary page.

To add more views, go to Personalize > Save As, enter a name for the new view in 
the Name field, and click Save. The newly created view appears in the Views list.

Note: Only the project owner can create a view. Program team 
members can add content to existing views.

To bookmark a selected content object, use the More > Bookmark option.

To subscribe to notifications on attribute changes for a selected item, use the More 
> Subscribe option.

To create a change order for an item, select the item and use the More > Create 
Change option.

■ Preview: Click Quick View on any object to see details of that object in the Quick 
View window. Within this window, you can take several actions on the object, 
such as:

■ View a selected revision.

■ View, add, edit, or remove a rule, to ensure hard dependencies.

■ Add, remove, check out, or view a file attachment in multiple formats.

■ Create Change for an item.

For more navigation tips and shortcuts, see the recorded demos under Tools & 
Settings > Quick Tours.

Updating Content
In the Content tab of the project page, you can do the following:

■ Edit rules

■ Edit content details

■ Change views

■ Add mandatory content on template programs

■ Assign keywords

You can also use the Quick View dialog to perform these actions.

To edit a rule:
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1. Select a content row for which you want to update the rule.

2. Click Edit Rule.

3. In the Relationship palette that appears, select a status of the content folder and a 
corresponding status of the project.

4. Click Save.

The updated rule appears in the Rule column of the selected content row.

To edit content details:

1. Click the Name in the content row, the details of which you want to modify. The 
Folder page appears.

2. Edit the details in the Title block as appropriate.

3. Click Save.

You can also  (a new URL or file) from the Content tab and post new content.

To change views:

In the Content tab, select a view from the Views list. This displays content specific to 
the selected view only.

To add mandatory content:

1. In a content row, double-click a cell in the Mandatory column. A drop-down list 
appears.

2. Select Yes from the list to mark the content mandatory.

When you generate a new 'Active' or 'Proposed' project from a template with defined 
mandatory deliverables, these deliverables cannot be deleted from the new project.

To assign keywords:

1. Select a content row.

2. Click More > Add keyword and choose a keyword.

3. The Project Keywords in the General Info tab appear in the More > Add 
Keyword choices.

The keyword you select appears in the Keywords column of the content row. Select a 
keyword from the Views list in the Content Tab, to view the content relevant to the 
selected keyword.

Note: The Add Keyword menu is not available if you have not 
added Project Keywords. To add Project Keywords, edit the Project 
Keywords field in the General Info tab of the project.

Managing Resources
Resource Management activities for a project in PPM include:

■ Adding resources to the project

■ Assigning activities to the resources

■ Monitoring resource utilization

■ Substituting resources

■ Delegating ownership of activities based on resource utilization



Managing Resources

Creating and Managing Projects 4-11

■ Searching for timesheets

■ Removing resources

Adding Resources
You can add resources to a project using Web Client or Gantt.

Adding Resources Using Web Client
In Web Client, you can add resources to a project using the Team or Schedule tab. The 
Team tab enables you to add a user group or a resource pool to a project.

Adding Team Members from Schedule Tab
You can select single or multiple activities and add team members or resources (the 
default allocation is 100%).

To add team members to an activity from the Schedule tab:

1. Select one or more activities and select Edit > Add Resources.

2. In the Add Resources dialog, launch the New Members palette and select the 
resources you want to add.

3. In the Team Member type section, specify the resource allocation details.

To add the selected users as resources (with a specific % allocation), select the 
Resource with % Allocation option. The default allocation is 100%. You can enter 
the desired allocation percentage.

Note: The resource allocation percentage can be a fractional value.

To add the selected users as team members (with a zero % allocation), select the 
Add as Team Member only option.

Launch the Roles palette to select the appropriate roles for the selected resources.

4. Select Apply to this level and below if you want the settings to apply to the 
current object and child objects.

5. Click Add.

Adding Team Members from Team Tab
You can add users or user groups as team members using the Team tab.

To add team members and apply roles:

1. In the Team tab of the project, click Add.

2. In the Add Resources dialog, launch the New Members palette and select 
resources you want to add.

Note: Before you select a resource or user group, you can review 
resource utilization details. Click the Utilization Report button. This 
opens a window where you can review resource utilization details 
based on query criteria. You must have Team.Name as an AppliedTo 
property within the Modify privilege to be able to assign members 
from a resource pool or user group.
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3. In the Team Member type section, specify the resource allocation details.

To add the selected users as resources (with a specific % allocation):

Select the Resource with % Allocation option. The default allocation is 100%. You 
can enter the desired allocation percentage. The maximum allocation percentage is 
400. You can change this setting in Java Client.

To add the selected users as team members (with a zero % allocation):

Select the Add as Team Member only option.

Launch the Roles palette to select the appropriate roles for the selected resources.

The roles available for selection are roles assigned to you (the login user) that have 
an associated PPM privilege.

4. Select Apply to this level and below if you want the settings to apply to the 
current object and child objects.

5. Click Add.

The selected resources and assigned roles are displayed in the Team tab. People added 
as resources, are also added as team members automatically. When you complete the 
addition of resources, each of the selected resources receives a notification in their 
Notifications tab.

If you add a resource pool or user group, the pool owner receives a notification. The 
request also appears in their My Assignments tab. When the pool owner accepts or 
rejects the request, the project owner receives a notification.

If you add a user who belongs to a pool, the pool owner receives a notification. The 
user receives a notification and a request. When the user accepts or rejects the request, 
the project owner and pool owner both receive notifications.

The % Allocation is divided among the selected users. If there is a fraction of a 
percent, the percentage is rounded off to the next lowest whole number, discarding the 
fractions of a percent.

For example, if the resource pool was assigned at 100% allocation, and you select three 
users, each user will be assigned 33.33%. If you remove the three users and reassign 
the % Allocation back to the resource pool, the % Allocation for the pool will be 
99.99% - the fractions of a percent are discarded. However, you can select the 
appropriate rows in the table and double-click the % Allocation cell to adjust the 
percentages for the users assigned from the resource pool, or (if you have assigned 
allocation back to the resource pool) adjust the percentage for the resource pool.

Adding Resources Using Gantt
You can assign resources to your project from within Gantt. Resource Management 
enables you to allocate resources to various projects and also split resources between 
projects.

To add resources to your project:

1. Select an activity and click the Task Assignment View icon on the left pane. The 
Manage Resources dialog opens.
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Figure 4–2 Manage Resources Dialog

2. In the Manage Resources dialog:

a. To add a resource, click the Add button. This creates a new row in the table. To 
enter a value in the new row under the Name column, double-click the cell 
and choose a resource name from the list of values that appears.

b. To add resources from a resource address book, click the Address Book icon. 
Click Find to view all the resources from the selected resource list. Use the 
Find From drop-down list to select a resource list from your existing resource 
sheets, for example, an existing resource pool or resource sheet list. Resources 
or resource pools that have already been added do not appear in the search 
results.

c. Depending upon your selection, more options become available. Click 
Options to perform a parametric search to find resources. For more 
information on Parametric Search, see the Agile PLM Getting Started Guide.

d. Click OK. Selected resources appear in the Manage Resources table.

e. In the Roles column, specify the role for each resource. To change cell values, 
double-click the cell and click the ... symbol. In the dialog that opens, select a 
role from the Available Roles column, move it to the Selected Roles column, 
and click OK.

f. In the % Allocation column, enter the percentage of the resource's time that 
you want to allocate for this activity. If the resource rejects the activity 
assignment, you will see an icon with an X mark in the Rejected column.

Note: The percentage (%) allocation for a full-time resource who is 
assigned to only one activity is 100%. If the resource is being shared 
across multiple projects, the percentage allocated would vary 
depending on the time allocation toward each project or activity.

3. To assign a resource, select the row and click Apply.

Before you assign resources, you can confirm availability of each resource. See 
"Viewing Resource Utilization" on page 4-13.

Viewing Resource Utilization
Resource utilization information is required to make informed decisions during the 
allocation of tasks to resources. PPM provides the following resource utilization 
reports:
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■ Project Resource Utilization Chart

■ Resource Utilization Report

Note: All of the utilization chart displays are only certified on the 
default zoom percentage (100%) of the browser. If you change the 
zoom size of the browser, the report chart view may be displayed 
incompletely.

Viewing Project Resource Utilization Chart
Project Resource Utilization chart enables you to view the overall resource utilization 
for the project in a given period. 

To view the Project Resource Utilization Chart in the Web Client:

1. In the program or project page, click Actions > Reports and Analytics > Project 
Resource Utilization menu.

2. In the Project Resource Utilization window, the Resource Utilization chart 
appears according to the default filter criteria.

You can modify the fields such as Report Type, Start Date, End Date, Reporting 
Intervals, Display Values by, Pool, and Chart Type to view resource utilization 
specific to the modified filter criteria.

1. Click Print to view the Project Resource Utilization report in a different window 
and print the report.

2. Click Export to csv to view the Resource Utilization report in Microsoft Excel.

Viewing Resource Utilization Reports
The Resource Utilization chart helps you to view resource availability, before you 
assign a resource to a particular activity. You can view resource utilization reports in 
both Web Client and Gantt.

Viewing Resource Utilization Reports using Web Client
In Web Client, you can view the Resource Utilization reports from the following:

■ Dashboard

■ Team tab

To view the resource utilization report for a resource pool from the Dashboard:

1. In the Resources widget, click in the row. The User Group Utilization window 
appears with the resource pool utilization chart and fields to specify filter criteria.

2. You can specify filter criteria as required, to view the User Group Utilization 
report.

To view the resource utilization for a particular resource or resource pool from the 
Team tab:

1. In the Team tab, select a row in the table.

2. Click Utilization to view the percentage utilization of the resource or resource 
pool in a graphical chart.

The results in the chart are based on the filter criteria. You can modify the filter criteria 
to view resource utilization according to your need.
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Editing Team Member Attributes
In the Web Client, you can edit the team member attributes such as resource pool, role 
and allocated percentage of effort.

To edit a team member's resource pool, roles, and % allocation:

1. In the Team tab, select the rows that you want to modify.

2. Double-click in the Assigned From cell.

3. Launch the Assigned From palette to select a different Resource pool, if required.

4. Double-click the Roles cell.

5. Launch the Roles palette to select a different Role, if required.

6. Double-click the % Allocation cell.

7. Enter a different % Allocation, if required.

8. Click anywhere outside the Team table to exit the edit mode and save the entries.

9. Click Utilization to view the User Group Utilization report. This report provides 
information on the time utilized by the resource based on the percentage of the 
allocated time.

The team member attributes in the Team table are:

Field Description

Name Name of team member or group.

Assigned From The name of the pool from which the resource is assigned. If the 
resource is assigned to multiple pools, the appropriate pool can be 
selected.

For best results in managing resource utilization, Agile recommends 
that a user be assigned as a member of only one resource pool.

Roles Program-specific roles assigned to team member for this activity.

Days Effort Days effort corresponds to the total sum for the resource or group.

Is Resource Identifies the user as a resource or just a team member with no time 
allocated to the activity. This information depends on % allocation of 
Resource/Team Member / User Group. If % allocation is greater than 0, 
it is Yes, otherwise No.

Rejected flag This indicates that the resource or pool has rejected the request.

% Allocation For both Fixed and Effort Driven duration type, this value determines 
utilization of a resource or group. This field accepts fractional values.

Pool Owner Name of the resource pool owner, if there is one.

Actual Hours The number of actual hours (duration) the team member has worked.

Reported Actual Hours are rolled up and compared to Estimated 
Duration and Scheduled Duration.

Actual hours are also used to determine the labor cost per activity. 
Actual hours are multiplied by the resource rate to determine the 
current applied cost of each resource. These totals by resource are 
added up to determine the applied cost per activity, and are then rolled 
up to the top to create labor costs for all parent objects.

Preferred Calendar Shows the preferred calendar setting of the team member.
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Assigning Tasks to Resources
You can choose to assign more than one task to multiple resources or split one task 
among multiple resources, based on your knowledge of the resource pool utilization. 
For information on resource utilization reports see "Viewing Resource Utilization" on 
page 4-13.

Bulk Assigning Tasks to a Resource
You can bulk assign several tasks to a single resource if necessary. For example, a 
project manager can bulk assign a set of tasks to a particular resource pool owner. This 
resource pool owner can then assign these tasks to members of the resource pool.

To bulk assign tasks to a resource:

1. In Web Client, click the name of the resource pool to view resource details. You can 
use the Search options to search for a particular user group by name.

You can also find the name of the resource pool in the Dashboard > Resources 
widget, My Settings > User Group page, and the project page Team tab.

2. In the User Group page, click the Assignments tab to view all the assignments and 
percentage allocation for the user group.

3. Use the Personalize menu to filter table display.

4. Select the assignments that you want to bulk assign to a resource.

5. Click Assign.

6. In the Activity Assignments dialog that opens, select the option button on the 
Allocate cell of a user to assign the selected assignments. The selected user 
becomes the owner of the selected assignments. The allocation percentage for this 
user is the sum of allocation percentages of all the assignments.

7. Click Finish.

View the existing assignment list and user group utilization details before you assign 
tasks to a resource. Use Actions > Reports and Analytics > Assignments List Report 
to view the list of assignments for all resources in the user group. Use Actions > 
Reports and Analytics > User Group Utilization Report to view a report of the 
resource utilization for the user group.

Important: It is recommended to verify your allocations using the 
same reports after you finish assigning tasks to the resources.

Splitting a Task Among Several Resources
As a resource pool owner, you have more visibility into the utilization status of each 
resource in your pool. Once a task has been assigned to your resource pool, you can 
split the % allocation of the task across several resources.

To split a task across several resources:

1. Navigate to My Settings> Address Book > User Groups.

2. In the Assignments tab, select the task and click Assign.

3. In the Activity Assignments dialog that opens, double-click the Allocate cell in 
the resource row to make it editable.

4. Enter the percentage allocation for all resources that share the assignment. 

The resource allocation percentage can be a fractional value.
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5. Click Finish.

Changing Ownership of Tasks in Projects Created from Templates
When you create a project from a template, if the owner of any activity except the root 
activity is defined in the template as a resource pool, the owner of the newly created 
(duplicated) activity will also be that resource pool. To change the owner of any 
activity or gate from a resource pool to an individual user, the owner of the resource 
pool must assign a user to the task owned by the pool.

To change ownership of a task to a resource pool member:

1. Navigate to My Settings> Address Book > User Groups.

2. Click the resource pool name to view assignments.

3. In the Assignments tab, select the task you want to reassign, and click Assign.

4. In the Activity Assignments dialog, select the option button in the Change 
Ownership column for the new owner of the task.

5. Click Finish.

The task can also be split between several users within a pool, from the Assignments 
tab of the user group. See "Splitting a Task Among Several Resources" on page 4-16.

Removing Resources
If your resource utilization report shows excess allocation for a resource, or if a 
resource is not available for the project, you can remove the resource from the project 
using Gantt or Web Client.

To remove assigned resources in Gantt Chart:

1. In the Manage Resources dialog, select a resource or multiple resources to delete.

2. Click the Delete icon. A message prompts you to confirm deletion.

3. Click Yes to confirm.

4. In the dialog that opens, select either of the following:

■ Delete resource and re-assign % allocation to pools (if applicable) - Select 
this option to delete the resource and re-assign the resource allocation 
percentage to other resources in the project resource pool.

■ Delete resource and discard % allocation - Select this option if you do not 
want to re-assign the resource allocation percentage.

The selected resources are removed according to your specification.

In the Manage Resources dialog, a black check mark next to the resource name 
indicates that the resource is allocated to all selected tasks. If the resource is allocated 
to at least one task, but not all tasks, the check mark will be gray.

To remove assigned resources in Web Client:

1. In the Team tab, select one or multiple resources to delete.

2. Click Remove.

3. In the Remove Team Members dialog, select either of the following options:

■ Remove only resources without a percent allocation - Select this option to 
delete the resources without the resource allocation percentage.
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■ Remove resources and assign their percent allocation to their resource pool 
if applicable - Select this option to delete the resource and re-assign the 
resource allocation percentage to other resources in the project resource pool.

■ Remove resources and discard their percent allocation - Select this option if 
you do not want to re-assign the resource allocation percentage.

4. Click OK.

The selected resources are removed according to your specification.

Delegating Ownership
When you create a project element, by default, you are the owner. The Delegate 
command enables you to change ownership of a project element.

An owner of a higher-level project element retains ownership of lower level items 
reporting to it, even when ownership of the lower level is delegated to another team 
member.

You can delegate ownership of an activity to a selected resource. In this way, you can 
assign an owner to each task in your project. When you delegate an owner to a task, a 
request is sent to the owner for approval. See also: "My Assignments" on page 2-11.

Once the delegated owner accepts the request, that resource owns the task and the 
delegated field becomes blank.

To delegate ownership of a project element from Web Client:

1. Open the project object you want to assign to a new owner.

2. Choose Actions > Delegate.

3. In the Delegate dialog:

1. You can optionally specify the reason for this action, for later use (Filtering 
data for reports, for example.).

In the Reason Code field, select an option from the list.

In the Comments field, enter comments as appropriate.

2. Select a new owner from the table. If the intended new owner is not listed, 
click Add.

3. In the Users field, enter the first few letters of the user's name and then select 
the name from the list that pops up. Or click the Address Book icon to launch 
the address book and select the user.

4. In the Roles field, use the palette to select a role and click Save.

5. Click Delegate to assign ownership to the new owner.

A gray dot appears beside the General Info tab link. In the Delegated Owner field, 
the ? icon appears next to the delegated user's name.

In the delegated user's Home page, there is a delegation notification in the 
Notifications tab, and a corresponding request in the My Assignments tab. Once the 
delegation is accepted, the gray dot is cleared and the Delegated Owner field is blank 
as the delegated owner has become the owner of the activity.

If the delegated owner has not yet accepted the delegation, you can use Actions > 
Delegate to choose a different user as the delegated owner.

To cancel the delegation, use Actions > Delegate and select the original owner as the 
delegate.



Action or condition Results or consequences

The activity is locked.

To unlock an activity, click the Unlock 
button.

The Delegate menu appears inactive when you 
click Actions menu.

The project is not active (the Template field 
setting on the General Info tab is not equal 
to Active).

Or

The project is active, but its status is Not 
Started.

To start a project (move it to the In Process 
status), change the status of one of its leaf 
activities. You cannot directly change the 
status of an activity if it has subordinate 
activities.

No delegations are sent to the delegated owners. 
Delegations are sent only when the project is 
Active.

A current team member is selected as the 
new owner, but has not yet accepted.

The new owner's name appears in the 
Delegated Owner field on the General Info tab.

The gray dot appears beside the General Info 
tab name indicating that the project has been 
delegated, but the delegation has not been 
accepted.

A user who is not a current team member is 
selected as the new owner, but has not yet 
accepted.

The new owner's name appears in the 
Delegated Owner field on the General Info tab.

The gray dot appears beside the General Info 
tab name indicating that the project has been 
delegated, but the delegation has not been 
accepted.

Because the delegation has not yet been 
accepted, the new owner does not appear on the 
Team tab.

The delegated user accepts the delegation in 
the My Assignments tab.

The gray dot beside the General Info tab name 
is removed.

If the delegated owner was not a current team 
member, he is added as a team member on the 
Team tab.

On the Team tab, the Agile PPM default owner 
role is automatically added to the delegated 
owner's assigned roles. By default, the default 
owner role is the Program Manager role, 
however, your Agile administrator may set a 
different role. For more information, see the 
Agile PLM Administrator Guide.

The delegated user rejects the delegation. The gray dot beside the General Info tab name 
is removed.

The Delegated Owner field on the General Info 
tab is empty.
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To delegate ownership of a project element from Gantt Chart:

1. Select the activity or task. The Delegate Owner icon is enabled.

2. Click the Delegate Owner icon. A list of default resources is displayed.

3. Select the resource from the list, or click the Address Book icon to select resources 
from the Address Book.
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4. Click OK to delegate ownership.

5. You can optionally enter a reason for the delegation and comments in the Reason 
for Delegation column. Double-click within the column row to open a dialog 
where you can enter these details.

When you save the current updates to the Gantt chart, the Reason for Delegation field 
appears blank. The information you entered is recorded in the History tab.

Changing Ownership Directly
You can also directly edit the Owner field in the General Info tab of projects that are 
in Active or Proposed state, if you have the necessary privileges.

Ownership can be changed to a user, but not to a user group. The new owner is added 
to the Team tab of the project, if not present already. When the ownership change is 
complete, any pending delegation is removed automatically.

Substituting Resources
You can use the Actions > Substitute Resource command to substitute one resource 
for another.

To substitute one resource for another:

1. Choose Actions > Substitute Resource.

Alternatively, 

2. In the Substitute Resource dialog, select a Resource to Remove from the list. The 
list contains all team members including those assigned to child activities.

Click the Substitute button in the Team tab.

3. In the Substitute To Resource palette, select a Replacement Resource.

4. To substitute the resource in all the child activities, select the Apply to Children 
check box.

5. Click Substitute. The replaced resource's role is assigned to the substituted 
resource.

Note: You can substitute a resource on a completed activity only if 
the % allocation is zero. For information on working with the Address 
Book Palette, see "Address Book Palette" on page 2-26. In the 
Substitute To Resource palette, the user groups that are already 
added to the team table are not available for selection, in the 
drop-down menu. Similarly, the Search within a User Group option 
in the drop down menu does not display the user groups already 
added to the team table.

Searching for Timesheets
You can search for timesheets only if you have the Update All Timesheets privilege 
and you log in as Administrator.

To search for timesheets:

You can search for timesheets by one or more of the following attributes:

■ User(s) -Launch the User(s) palette to select a resource, or several resources. This 
displays timesheets of the selected resources.
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■ Project(s) - Launch the Project(s) palette to select a project, or several projects. You 
can choose to include Canceled and Soft-Deleted Activities. This displays 
timesheets belonging to the selected projects.

■ Date Between - Launch the Calendar to choose the From and To dates. This 
displays the timesheets that fall within a particular period.

A blank search, where you do not choose any attributes as criteria, will return all 
timesheets recorded in the system.

1. On the Timesheet tab, click More >Timesheet Search.

2. Click Search. The search results display in a table.

3. To sort the results by a listed attribute, click the relevant column heading. By 
default, the list is sorted by Name.

4. To export selected rows to another project for analysis or computing in the Comma 
Separated Values format, click Export(csv). To export selected rows to another 
project for analysis or computing in the Microsoft Excel format, click Export(xls). 
You can then download the results to a local drive on your computer.

5. To print search results, click Print.

Defining Timesheet Views
To view and change timesheet data recorded for selected users, you require a 
personalized view of selected timesheets.

To define a timesheet view:

1. In the Timesheet tab, click Views > My TimeSheet View.

2. In the Personalize list, select Save As. The Table Personalization palette appears.

To name the view, select the Properties tab.

■ Enter the custom view name and select the view type.

■ Click Apply, then click Save.

To choose users, select the Filter tab.

■ Use the filter criteria to add timesheets of selected users to the view. For 
example, you may select all members of a project team or resource pool.

■ Click Apply, then click Save.

To choose which fields to display in the table, click the Format tab.

■ Move fields to the Hidden Fields column as required. The Name and Team 
Member fields must be displayed.

■ Click Apply, then click Save.

3. Click Close to return to the Timesheet tab.

The new view displays the timesheets of the selected users. You can now view and edit 
the timesheets.

Managing Schedules
Managing schedules in PPM involves:

■ Using customized calendars
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■ Creating dependencies between activities or projects

■ Rescheduling project dates

■ Creating baselines

You can establish dependencies between activities within your project schedule. A 
dependency between activities mandates that one activity's schedule is driven by the 
predecessor's schedule. You can also establish and change dependencies using the 
Gantt Chart. 

Using Calendars
When you create a project, the Default Calendar is assigned as the project calendar. (If 
you have a Preferred Calendar specified in your user profile (under My Settings), then 
that calendar is displayed by default.) All activities and gates use the project calendar 
to define work days, unless you explicitly assign a different calendar to a specific task 
or phase. If the project was created from a template, the project calendar is the same as 
the calendar specified in the template. 

Note: The Preferred Calendar attribute in the General Info tab of a 
user or user group is usually set by an administrator, who has 
privileges to modify user and user group settings.

You can assign a calendar for a project or any activity within the project from its 
General Info tab. The Calendar field provides a list of available calendars for selection. 
You can create or modify calendars in the system if you have the Calendar 
Administrator privilege. 

Identifying Calendar Conflicts
You can run the Activity Calendar Conflict Report to check for variances between a 
task-level calendar and the preferred calendar of resources assigned to that task. For 
example, you can see whether any of the working days in the project calendar are 
specified as non-working days in a user’s preferred calendar, creating a conflict. 

For example, let’s say you assigned a US Calendar to a task and assigned that task to a 
resource based in China. If the task period includes Oct 1st, which is a working day in 
the US but a national holiday in China, the report highlights the conflict and shows the 
reason why the date is marked as an exception.

To view the activity calendar report:

1. From the Actions menu of the task, choose Reports and Analytics, then choose 
Activity Calendar Conflict Report. You can also access the report from the 
Reports drawer in the left pane, where it appears in the Project Reports list under 
Standard Reports. 

2. Specify report parameters. The users and dates associated with the current task are 
automatically selected, but you can edit these as required.

3. Click Finish. The report appears, showing you a weekly view of the task, and the 
preferred calendars of the resources assigned to the task. Conflicts with the project 
calendar are highlighted in yellow. 

You can switch to the Daily View to drill down into the details.You can also click on 
the highlighted dates to get additional information, such as why these dates are 
marked as exceptions.
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To resolve a conflict in the dates, reschedule the dates or assign the task to other 
resources, as appropriate.

Accepting Calendar Changes
If an administrator makes an update to a calendar you are using, a warning message 
appears on the activities and gates that are affected by the change. The administrator 
can also choose to send you a notification informing you of the calendar change. When 
a calendar is updated, you can do the following:

■ To accept the calendar change, in the Actions menu, choose Accept Calendar 
Change. The affected projects are rescheduled according to the updated calendar.

■ To retain the current schedule, create a copy of your calendar with a different 
name and then assign the new calendar to affected projects. (You can access the 
updated calendar from the link provided in the notification.) For more information 
on creating a new calendar from an existing one, see "Configuring Calendars" on 
page 10-24.

Note: Calendar changes affect rescheduling only in Proposed or 
Active projects that are in Not Started or In Progress status. 

Creating and Editing Dependencies
Dependencies in Agile PPM control the schedule timing of any two tasks in a project 
timeline linked through a dependency. Dependencies do not control the activity in 
those tasks. To control the activity between two activities or gates, you can use content 
relationships and rules.

Dependencies can be offset positively or negatively with a time buffer.

Creating and Editing Dependencies in Web Client
The Dependencies tab in the Agile Web Client displays a list of all the predecessor 
(Dependent Upon) and successor (Required for) activities in the project. The Web 
Client also enables you to create external dependencies to other projects and tasks not 
in the current project timeline. If you establish such external dependencies, links to 
these also appear.

This tab page has the following buttons:

■ Add - Enables you to add a dependency to the selected activity. Dependencies can 
be made between activities in the same project or other projects. You can also 
create dependencies between a template project and an active project.

■ Remove - Deletes the selected object. The Remove button affects only the selected 
activities in the current page.

Navigate to the activity for which you want to create dependency.

To create dependencies:

1. Click the Dependencies Tab.

2. Click Add. The Add Dependency dialog appears.

3. In the Root Project palette, select the Root Project which has the predecessor 
activity.

4. In the next dialog, to view a filtered list of Activities, select the Type of the 
predecessor activity. The default selection is 'All'.
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5. Click Continue.

6. In the Activities palette, select the predecessor activity.

7. In the Type list, select a dependency relationship.

8. Enter the Time Buffer between the finish of the Predecessor activity and the 
beginning of the successor activity, if required.

9. Click Finish.

For quick editing of dependencies, use the Gantt Chart view. 

You can create external dependencies only in Web Client.

For information on types of dependency relationships and time buffers, see "Types of 
Dependencies" on page 4-24.

Creating and Editing Dependencies in Gantt
You can create a dependency between two activities in the Gantt Chart. By default, all 
project schedules begin on the start date of the first task and finish based on the date of 
the last task to complete. When dependencies are created, the Gantt Chart adjusts the 
schedule appropriately. Dependencies can change the project's finish date.

To create a dependency:

1. Click the Create Dependency icon on the toolbar. The cursor turns into a 
cross-hair pointer.

2. Drag the cross-hair pointer from the start point of the task to its end point. The 
direction you drag and the start point or end point of the task you select 
determines the dependency Type.

To create a dependency between two tasks that are not close to each other, you can 
type the dependency directly into the predecessor column. Type the predecessor's task 
ID no. (shown on the right-hand side of the tabular view) in the Predecessor column 
in the tabular view pane.

You can also create a Dependency using the Edit >Create Dependency menu 
command.

To edit a dependency:

1. Double-click the dependency arrow link on the graphical view of the Gantt Chart 
or select Edit > Edit Dependency.

2. Select the Type of dependency from the Types drop-down menu.

Types of Dependencies
There are four types of Dependencies:

■ Finish to Start (FS)

■ Start to Start (SS)

■ Finish to Finish (FF)

■ Start to Finish (SF)
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Figure 4–3 Types of Dependencies

For example, if the Predecessor task is Task A and the Successor task is Task B:

■ Finish to Start: In an FS scenario, the Schedule Finish date of Task A determines 
the Schedule Start date of Task B.

■ Start to Start: In an SS scenario, the Schedule Start date of Task A determines the 
Schedule Start date of Task B.

To maintain a schedule which enforces the parallel scheduling of tasks, use the SS 
dependency type.

■ Finish to Finish: In an FF scenario, the Schedule Finish date of Task A determines 
the Schedule Finish date of Task B.

■ Start to Finish: In an SF scenario, the Schedule Start date of Task A determines the 
Schedule Finish date of Task B.

Note: In the Gantt Chart, the Successor column shows the task that 
may be affected if the predecessor task is changed or moved. 

Dependency Time Buffer
A buffer can be inserted to maintain a gap between a predecessor and its successors. 
Positive or negative values are accepted for the buffer.

When creating or editing a dependency, you can enter a value in the Time Buffer field 
that represents "slack time" between the control dates of the predecessor and successor 
activities or gates.

Days set as time buffer follow the calendar of the target Activity or Gate. For instance, 
if you set an FS dependency between Task 1 and Task 2, with 3 days buffer, and each 
task has a different calendar assigned, the 3-day buffer is taken into consideration in 
the calendar for Task 2.
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You can also create and change dependencies from the Gantt Chart view. See "Creating 
and Editing Dependencies in Gantt" on page 4-24.

Dependencies Between Templates and Active Projects
You can create dependencies between a project and a project template. For example, 
you could create dependencies between Release Project A and a Feature Release 
Project Template.

Be aware that this can impact other projects that are subsequently created from the 
same template, as described below.

Let's assume Release Project B is created from the same Feature Release Project 
Template which has dependencies with Release Project A.

■ Slack defined in the template project is not copied over to the new project.

■ If internal and external dependencies conflict, the external dependencies are 
maintained and conflicting internal dependencies are removed.

■ If there are conflicting external dependencies, all dependencies are maintained, but 
dates are aligned to the last date of the dependency, adding slack to any earlier 
dependencies.

■ If there is a dependency to a parent activity in the template, the start date of the 
parent activity is moved. Slack is not removed from the child activities.

Note: A template activity or gate cannot be a predecessor. Only an 
active or proposed activity or gate can be a predecessor. You cannot 
create a dependency between two template projects

Editing Display Order
You can change the order in which tasks or phases appear on the Schedule tab.

To edit the sequence of the Program elements on the Schedule tab:

1. On the Schedule tab, select More > Change Display Order. The Change Display 
Order dialog appears.

2. In the boxes in the Order column, enter a number that represents the order in 
which you want the corresponding project elements to appear on the Schedule 
tab.

3. Click Save.

Rescheduling a Program
While other Schedule tab edit functions allow you to select and modify rows in the 
schedule table, the More > Move Schedule menu acts on the currently displayed 
object only, not on the rows in the schedule table.

To reschedule your Program:

1. From the Schedule tab, select More > Move Schedule. The Move Schedule Dates 
dialog opens.

2. To move the scheduled dates of a project element, do one of the following:

■ Select the Start Date or End Date options and use the calendar to select new 
dates.
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■ Select the Forward or Back options, as appropriate, and specify the number of 
days by which the schedule needs to move. For example, if your Schedule 
Start Date is January 5th, and you want to move this forward to January 8th, 
select Forward and specify 3 (days). If you want to move the date back to 
January 2nd, select Back and specify 3.

3. Click Save to reschedule the project.

When you move the end date of a project to reschedule it, errors occur if there is slack 
between the activities. To prevent such errors, you can do either of the following:

■ Quantify the slack in the Time Buffer field. See "Dependency Time Buffer" on 
page 4-25.

■ Remove slack. The quickest way to do this is to launch the Gantt Chart for the 
project and use the Edit > Remove Slack command. This action adjusts project 
dates to give you a 'best fit' schedule.

This error can also occur if you reschedule a parent project by moving the end date 
and the end dates of any child activities fall on weekend dates.

Creating a Baseline
You can create Baselines to capture schedule and resource snapshots of a project at 
regular intervals of time, for project tracking. Baselines are permanent reference points 
against which you can compare the updated task structure and changes to schedule, 
budgeted costs, and resource allocations. To be able to create baselines, your Agile 
administrator must assign you Modify privilege on the Schedule.Name attribute.

Baselines can be created only on the root project object. To take snapshots of extensive 
project data during the planning phase, you must save multiple baselines. For 
example, you may want to do this at major planning milestones.

When you open the project, all saved baselines for that project appear in the Version 
list on the Schedule tab. Baselines are versioned for easy identification.

To compare the current project against a saved baseline, select it in the Version list. 
The details of the selected baseline are displayed next to the Version field.

Note: If the baseline description exceeds 15 characters, it appears 
truncated. To view the complete description, place the cursor over the 
truncated description. A tool tip displays the complete baseline 
description.

You can create two types of special baselines:

■ Kickoff Baseline: This is the very first baseline of a project. Use the kickoff 
baseline as the preliminary version, against which you can compare the 
subsequently created baselines. Agile PPM provides you the option to mark the 
current version of a project as a kickoff baseline when you perform any of the 
following actions:

■ Create a baseline from the Schedule tab.

■ Create a project from a template.

■ Change the Template setting on the General Info tab of a project to Active.

■ Save a project using the Save As command on the Actions menu.



Managing Schedules

4-28 Product Portfolio Management User Guide

■ Plan Of Record: This is a special type of baseline which you may want to create at 
major milestones during the execution of the project.

The version number of a kickoff baseline or a plan of record baseline appears suffixed 
with an asterisk ('* ').

To create a baseline:

1. From the Schedule tab of a root project, click Create Baseline on the drop-down 
menu adjacent to the Baseline list.

2. In the Create Baseline dialog:

1. Enter a Description for the baseline. This description appears in the Baseline 
list.

2. To mark it as your Kickoff Baseline, select the Kickoff Baseline check box.

3. To mark it as a Plan of Record baseline, select the Plan of Record check box.

4. Click Save to save the baseline.

To remove a baseline:

1. Select the baseline in the Version list.

2. Click Remove Baseline on the drop-down menu adjacent to the Baseline list.

When you remove a baseline, the references to the baseline for all objects in the tree are 
also removed.

Comparing Baselines  

Baseline comparison can be done using either of the following:

■ Using the Compare Baselines feature.

■ Using the Baseline Comparison report.

To compare baselines using the Compare Baselines feature:

1. From the Actions menu of a project, click Compare Baselines. A new window 
displays all the baselines created for the project.

2. Select a baseline. A list of baselines against which you can compare the selected 
baseline appears to the right.

3. Select a baseline from this list for comparison. You can compare the selected 
baseline only against the current project, or against a baseline that was created after 
the selected baseline.

4. Click Compare. A new window opens, showing a comparative view of the 
selected baselines. Activities that have been modified, added or deleted are 
indicated by the colors shown in the legend below the table. A gray dot indicates a 
modified object.

■ To see details of changes made to an activity or gate, click its name. A pop-up 
window shows General Info, Schedule and Resource information with old and 
new values. Scroll down to see all changes.

■ To view details of any modifications made to your project schedule, allocated 
resources, or General Info fields, click the appropriate icon in the respective 
column.

To compare baselines using the Baseline Comparison Report:

1. In the left navigation pane, choose Analytics and Reports.
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2. Under Standard Reports, navigate to Program & Portfolio Reports > Program 
Reports, and choose Baseline Comparison Report.

3. Execute this report to compare selected baselines. For more information on 
running reports, see related documentation in Getting Started with Agile PLM.

Managing Discussions
Managing Discussions in PPM involves:

■ Adding, viewing, and joining a discussion

■ Replying to discussions

■ Viewing action items that were assigned during a discussion

Discussions Table
The Discussions table in Collaboration > Discussions tab displays important 
information about each discussion. The column heading with the Action Item icon 
appears on the rows which have action items associated with the Discussion. Click the 
gray dot or click the Subject of the discussion to open it.

Adding Discussions
You can add a new discussion or reply to an existing discussion from the Web Client.

To add a new discussion:

1. Open the activity, and click Collaboration > Discussions tab.

2. Click Add and choose the Create New icon.

3. In the Create New dialog, select Discussion from the Type drop-down list.

4. Enter a Subject for the discussion.

5. Type the Message you want to send.

6. From the Priority drop-down list, set the discussion priority.

7. In the Notify List palette, select the users who must receive notification of this 
discussion.

8. Click Add.

To search and add an existing discussion:

1. Open the activity, and click the Collaboration > Discussions tab.

2. Click Add and choose the Search option.

3. In the Discussions Search palette, search for one or more existing discussions.

4. In the search results, double-click the discussions you want to add to the activity.

You can run multiple searches to find and select additional discussions.

Replying to Discussions
You or your team members or notified users can reply to discussions.

To reply to discussions:

1. Open the activity, and click the Collaboration >Discussions tab.
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2. Click the discussion name to open it.

In the Schedule tab of the root project object, the discussions column indicated by 
the Discussions icon, displays the symbol for all activities that have discussions.

You can view the discussion thread in the preview pane just below the Discussion 
table on the Collaboration > Discussions tab.

3. On the Discussions tab, select the discussion you want to reply to.

4. Click the Reply button in the preview pane. Enter your message and the list of 
people to notify, and click Send.

To add a comment to an existing reply:

1. Open the activity, and click the Collaboration >Discussions tab.

2. Click the symbol in the discussion row for which you want to add a comment. In 
the discussion page, the Discussion tab displays the reply thread.

3. Click Reply to add a comment to the existing response.

4. Modify the subject, type a Message, and select the users to notify, if required.

5. Click Send.

Your reply is added as the latest response in the ongoing discussion thread.

Replying to Discussions from your Home Page
When a discussion appears in your Notifications tab on the home page, you can open 
the discussion object and either add a reply or add a comment to an existing reply.

To reply to Discussions from your Home page:

1. In your Notifications tab, click the link in the Regarding cell on a discussion row 
to open the discussion item.

The Discussions icon identifies the discussions in the Notification table.

2. In the Discussion tab of the Discussion page, click Reply.

3. Add the reply message and the list of people to notify, and click Save.

Replying to Discussions from the Project Summary Page
A list of recent discussions specific to the project appears in the Summary page of a 
project.

To reply to a discussion from the Project Summary page:

1. Navigate to the Summary page of a project.

2. In the Recent Discussions widget, select a discussion row to view the discussion 
thread within the widget.

3. Click Reply to respond to the discussion.

4. Modify the subject, type a message, and select users to notify in the Reply to 
Discussion window.

5. Click Send.

6. Click Cancel to exit from the Reply to Discussion window without sending the 
response.
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Viewing Discussion Replies
In the Web Client, navigate to the program or project page to view the replies to a 
discussion.

To see a list of replies to a discussion

1. Click Summary.

2. In the Recent Discussions widget, click a discussion to view the reply thread.

Alternatively:

1. Within the Collaboration tab, open the Discussion view.

2. Click the Discussions icon or the subject of discussion on any row. The discussion 
page appears with the reply thread.

Or

Click a discussion row to view the reply thread in the preview pane below the 
Discussion table.

Removing Discussions
After you finish all your discussions, you can remove the discussion objects.

To remove discussions:

1. Open the activity, and click the Collaboration > Discussions tab.

2. Select the discussion row you want to remove.

3. Click Remove.

The discussion object is removed from the activity.

To delete discussions from the Actions menu:

1. Open the activity, and click the Collaboration > Discussions tab.

2. Click the Subject of discussion. The discussion page appears.

3. Click Actions > Delete menu.

4. Click OK on the Confirmation message box.

If this discussion is not active in any other PPM activity, the system deletes the 
discussion from the Agile PLM database.

Viewing Action Items
In the Web Client, you can access action item details from the Collaboration > Action 
Items by clicking the name of the action item.

■ The list of action items in the table is a combined list of the action items associated 
with the project and the action items associated with the listed discussions.

■ The Belongs To column and Discussions icon indicate whether the action item is 
associated with a discussion object or with a project object. Click the link in the 
Belongs To column to open the object.

Click the name of the action item in the Subject column to open the action item.

To add an Action Item:

1. Open the activity and click the Collaboration > Discussions tab.
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2. Click Add.

3. In the Create Action Item dialog, enter the action item information. Fields that are 
in boldface are required.

4. Click Create.

The action item will appear in the Notifications and My Assignments tabs of the user 
to whom it is assigned.

The Action Items tab displays all action items related to the current activity, including 
those action items created on the associated discussion objects. If you have configured 
flex fields for the activity class, ensure that the same configuration is done for the 
Gates and Discussions classes as well. The list values that display in the flex fields 
columns of the Action Items table will be the values you configured for the activity 
class.

Archiving Projects
You can change the archive status of a root-level project from the Actions menu. 
Archiving old data can improve system performance. The archived project's data 
remains searchable.

Archiving requires the Projects.Generalinfo.Archived attribute enabled for the Modify All 
Projects, Programs, Phases, Tasks and Gates privilege in Java Client.

To change the archive status:

1. Select a root-level object.

2. Select Actions > Archive.

3. You can optionally specify the reason for this action, for later use (Filtering data 
for reports, for example.). This information is stored in the History tab of the 
object.

■ In the Reason Code field, select an option from the list.

■ In the Comments field, enter comments as appropriate.

This option becomes available only if the corresponding SmartRule is enabled in Java 
Client. For details, see the Agile PLM Administrator Guide.

When a project is archived, it is removed from all active project lists and from the 
project navigation tree. All buttons and Actions menu choices are grayed out, except 
for Actions > Unarchive. You can select this option to remove the archive status.

An archived program is automatically removed from the PLM Reference field of 
programs that reference it, but is retained on the Content tab. You must manually 
remove it from the Content tab if you do not want it to be visible there.

You can also change the archive status for Completed and Canceled projects.

Note: Once a project is archived, it is no longer searchable using 
Advanced Search. To search for an archived project, use Simple 
Search.
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5Participating in Projects

This chapter addresses the actions you can perform as a participant in a project. 

Working on Assignments
The Home page My Assignments tab shows a list of your assignments. You can 
accept, decline, and edit these assignments, or take other actions as appropriate.

Accepting Assignments
You can use the Home page My Assignments tab Accept function to accept multiple 
activities or action items simultaneously. The accept action applies to:

■ Activities where you are the delegated owner.

■ Project activities assigned to you.

■ Action items whose status is Not Accepted and you are the assignee.

To accept assignments on the My Assignment tab:

1. Click the Home button to display the Home page.

2. Click the My Assignments tab to display your list of assignments.

3. Select one or more rows in the table.

4. Click the Accept button.

The selected objects are accepted.

Declining Assignments
You can use the Home page My Assignments tab Decline function to decline multiple 
activities or action items simultaneously. The decline action applies to the:

■ Activities where you are the delegated owner.

■ Action items whose status is Not Accepted and you are the assignee.

When you decline an activity, you must enter a reason.

To decline assignments on the My Assignment tab:

1. Click the Home button to display the Home page.

2. Click the My Assignments tab to display your list of assignments.

3. Select one or more rows in the table.

4. Click the Decline button.
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5. If one or more of the selected rows are activities, you must enter a reason why you 
are declining the activities. Enter your reason in the pop-up dialog and click Send.

Editing Assignments
You can edit the assignment attributes in the My Assignments tab table. You must 
have the appropriate Modify privileges for the editable fields.

For example, depending on your privileges, for an activity, you can edit the Status, 
Percent Complete, Actual Hours, and Due Date.

To edit My Assignment table rows:

1. Click the Home button to display the Home page.

2. Click the My Assignments tab to display your list of assignments.

3. Locate the row of the assignment you want to edit.

4. Within the row, double-click a table cell to make the field editable.

5. Make the desired modifications.

The editable fields are determined by which fields your Agile administrator has 
included in the assignments table and your modify privileges.

6. To duplicate an existing cell value across multiple cells:

1. Select the range of cells that you want to fill with the same value.

2. To deselect a cell within the range, press CTRL and click the cell.

3. From the More dropdown menu, choose Fill Up or Fill Down as appropriate.

4. When you are finished, click Save.

Mark Assignments Complete
You can use the Home page My Assignments tab Mark Complete function to mark as 
complete multiple activities or action items simultaneously.

If you have not accepted an action item, you cannot mark it as complete. Accept the 
action item first and then mark it as complete.

When you mark an activity as complete, the Percent Complete field is automatically 
set to 100%.

To mark assignments as complete on the My Assignments tab:

1. Click the Home button to display the Home page.

2. Click the My Assignments tab to display your list of assignments.

3. Select one or more rows in the table.

4. Click the Mark Complete button.

The selected assignments are marked complete.

Flagging Assignments
On the Home page My Assignments tab, the flag icon included in each row is a useful 
assignment management tool. Because you can sort assignments according to whether 
they are flagged or not, you can use the flag to indicate assignments that you want to 
track differently from other assignments. The flags on your assignment table appear 
only on your My Assignments tab, so you can decide how you want to use them.



Working on Assignments

Participating in Projects 5-3

To set or unset the flag in a single assignments table row:

1. Click the Home button to display the Home page.

2. Click the My Assignments tab to display your list of assignments.

3. Click the flag icon in the row you want.

■ If the flag is not set, clicking it toggles the flag to set.

■ If the flag is set, clicking it toggles the flag to not set.

To set the flags in multiple assignments table rows:

1. Click the My Assignments tab to display your list of assignments.

If desired, use the Views dropdown list or the filter to sort which assignment rows 
are displayed.

2. Select the rows you want to flag.

3. Choose More > Add to Flagged View.

To unset the flags in multiple assignments table rows in the flagged view:

1. Click the My Assignments tab to display your list of assignments.

2. In the Views dropdown list, choose Flagged.

3. In the flagged assignments view, select the rows you want.

4. Choose More > Remove from View.

Reporting Time
A resource who has been assigned tasks on one or more projects can use the Timesheet 
feature to report actual hours spent on each task. Reporting can be done on a daily or 
weekly basis. To be able to report time, the Detailed Timesheet Entry SmartRule must 
be set to Allow in Java Client, and Timesheet tab visibility must be enabled in your 
user preference settings.

When a team member enters time data against a particular project task in the 
Timesheet, the hours reported are added to the Actual Hours recorded on the Team tab 
for that task. The labor cost and any other information impacted by the number of 
hours this resource has worked on the project are then automatically recalculated.

You can only report time against a leaf-level task that is In Process. You cannot report 
time against a root project. Only In Process tasks will be displayed in the Timesheet 
tab.

To report time against a particular task:

1. In the Timesheet tab, select the row for the task.

2. Enter actual hours worked in the columns for each day of the week. Double-click 
within the cell to make it editable. You can also simply fill in the Total column 
with actual hours for the whole week. For example, if you fill in 40 hours in the 
Total column, this value is equally distributed as 8 hours each for Monday 
through Friday.

3. Click Save to save your data.
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Subscribing to Events
The events you can subscribe to vary per object. Product Portfolio Management has 
the following Activity-specific subscription events that do not apply to other objects:

■ Add Discussion

■ Reply to Discussion

■ Add News

■ Add Action Item

■ Modify Schedule

The Apply to Children check box in activities and gates "push" a subscription to all 
child objects. If you subscribe to an activity that has a schedule and select this check 
box, you will automatically subscribe to all of the activity's projects, programs, phases, 
and tasks (that is, any object created in the out-of-box subclasses of Activities class). 
Since Page Two and Page Three fields can be defined differently for projects, 
programs, phases, and tasks, any of the attributes that do not apply are ignored.

Changing Workflow Status
The workflow status of leaf objects, or objects that have no children, can be changed 
using the Change Status button. The status of parent objects cannot be changed 
directly, since it is changed by rolling up the status from leaf-level objects. You must 
have the appropriate privileges; by default, the Program Manager and Program 
Administrator roles have the required privileges.

The Change Status button is only available for objects whose Template field is Active 
in the General Info tab. You cannot change the status of objects whose Template field 
is Proposed or Template. Changing the Template field must be done at the parent 
level, and child objects are automatically moved to the Template value of the parent.

If you have added a Functional Team to the project, members of this team are 
automatically included in the Change Status dialog as the designated approvers, 
acknowledgers or observers for the proposed change of status. If you have not added a 
Functional Team, you can manually add each of the approvers, acknowledgers or 
observers.

For detailed information on using the Functional Teams feature, see the Getting Started 
with Agile PLM Guide.
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6Tracking Projects

This chapter covers status tracking and reporting options for project or program 
managers.

Status Tracking
Agile PPM enables project status tracking according to criteria set up within Agile Java 
Client Administrator. Health Status values are rolled up for all objects that are 
configured to report health status. To ensure health status values are rolled up, the 
Rollup Health Status attribute must be set to Yes in the object's General Info tab.

The following status elements are rolled upward:

■ Overall

■ Schedule

■ Cost

■ Resource

■ Quality

Parent objects derive their status from the status of their child objects. If any one child 
of a project object is Off Track, the parent project is set to Off Track. If the Quality 
Status of a child object is Below Quality, the parent object is also set to Below Quality. 
Health attributes are maintained in Java Client Administrator settings, and each value 
has an activation period or value.

Default Health Statuses
The following table shows default schedule, cost, resource, and quality health statuses.

Status Values What triggers change?

Overall On Track (green), Needs 
Attention (yellow), Off Track 
(red)

Corresponds to the most negative setting of the 
four health statuses for any project. If any one 
of the other statuses is red, Overall status will 
be red.
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How Status Roll-Up works
Several attributes are passed upward from child objects to parents, in a process called 
rolling up.

The attributes that are rolled up include:

■ Activity workflow status

■ Health statuses

■ Scheduled dates and scheduled duration

■ Actual start/end dates and actual duration

■ Estimated start/end dates and estimated duration

■ Days effort

■ Percent complete

The rolling up of values starts with leaf nodes (child objects that have no children) that 
are not either Complete or Canceled, and moves upward to parent objects. If any leaf 
node object is determined to be Off Track, the parent object is considered to be Off 
Track.

Parent object fields that reflect rolled-up status of child objects, such as Days Effort or 
Scheduled Dates, cannot be edited because it is automatically rolled up from lower 
levels in the hierarchy. Status can only be edited at the lowest levels (leaf nodes).

The only way you can change the status of a parent object at the project level is to 
cancel the project using the Actions > Change to Canceled menu command. Once 
canceled, a project can be reset to the Not Started state, using Actions > Change to Not 
Started.

Schedule On Track (green), Needs 
Attention (yellow), Off Track 
(red)

Within the Java Client you can create a setting 
to trigger a health status change if there is 
schedule slippage of a certain number of days. 
The default setting for the Health Status to 
change from Not Started or On Track to Needs 
Attention is 1-5 days. If the task is overdue for 
more than 5 days, the status changes to Off 
Track. To learn how to configure these settings, 
see the Agile Administrator Guide.

Cost On Budget (green), Off Budget 
(yellow), Over Budget (red)

Cost status is calculated based on the 
percentage of deviation from the original cost 
as set in the cost status node in Agile 
Administrator.

Resource Staffed (green), Understaffed 
(yellow), Not Staffed (red)

Resource status is an editable field in the 
General Info tab of a project object which can 
be edited by a user with appropriate privileges, 
usually the project owner.

Quality Meets (green), Below (yellow), 
Poor (red)

Quality status is an editable field in the General 
Info tab of a project object which can be edited 
by a user with appropriate privileges, usually 
the project owner.

Status Values What triggers change?
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Workflow Status
Agile Web Client uses a workflow stamp in the upper right of the General Info tab to 
indicate the workflow status of an activity. The Agile administrator defines the name 
of each status in each workflow.

The default project workflow statuses are:

■ Not Started

■ In Process

■ Complete

■ Canceled

Your company may have its own customized workflows and status stamps, as 
displayed in the Workflow tab. For further information see "Workflow Routings Tab" 
on page 2-11.

If a user has the appropriate privileges, they can use the Change Status button to 
change an activity's status, promoting it to the next lifecycle state.

Important: Since lifecycle status of parent objects is rolled up from 
lower levels, you can only use the Change Status button to change 
status on individual leaf node objects, or objects with no children. You 
cannot promote an activity whose Template field setting is Template 
or Proposed.

Rules for Parent Status
The following rules apply for parent object status change:

■ Parent object workflows are affected when any of the related child workflows 
start. For example, if one child activity is in the In Process state, then Parent status 
is In Process.

■ Parent object workflows are affected when all related child objects workflows 
complete. For example, if all activities are Complete, then parent status is 
Complete.

■ When custom workflows are used, the rollup is governed by the transition 
between the Status Type, not necessarily a change in the step. For example, a 
workflow with seven steps can roll up to a parent with three steps because each 
has only one transition between the "Pending" and "Review" type (Pending, 
Review, Complete, and Cancel are the Status Types).

Note: It is not recommended to use multiple review states on parent 
tasks, as the review status on the parent is driven by the status of the 
child tasks.

For leaf-node objects, you can click the Change Status button to change the workflow 
status (provided you have the required role).

To change the workflow status of the parent activity, open a leaf-level child activity 
and click the Change Status button to change the workflow status of the leaf-level 
activity.

You cannot use the Change Status button to change the workflow status of an activity 
that has children (subordinate activities).
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For more information about workflows, see Getting Started with Agile PLM and the 
Agile PLM Administrator Guide.

Cost Status
Agile PPM enables you to calculate four types of project costs as listed below. Each of 
these costs have Actual, Budgeted and Estimated categories. There are 12 cost fields in 
total; all appear on the General Info tab.

■ Labor Costs - Actual and Budgeted Labor costs are automatically calculated. 
Budgeted Labor Cost uses scheduled duration, % allocation, and the users' 
resource pool rate, and man hours (8 hours per day) to calculate labor cost per 
resource assignment. These are summed for multiple resources assigned to an 
activity.

If an activity has a resource assigned, and has lower-level objects with Labor costs, 
then it is summed at the parent level and not replaced. Budgeted and Actual Labor 
Costs are always calculated in this way. However, Estimated Labor Cost can be 
editable at all levels. If not edited, it is rolled up by default.

■ Capital Expenses - Can be both rolled up values and edited values, depending on 
whether the Agile administrator has enabled the Calculate/Roll-up flag on each 
cost field.

■ Fixed Costs - Works in the same way as Capital Expenses.

■ Flex Costs - These cost fields can be customized according to your business 
requirement in Administrator. For example, you could call it Setup Costs, and use 
it for calculation of project setup costs. Works in the same way as Capital Expenses 
and Fixed Costs.

While calculating labor costs, if a Resource is not assigned to a Resource Pool, the 
user's individual Labor Rate is used. The labor rate must be defined for the resource in 
the User Settings before you add the resource to a project.

How Total Cost is Determined
Total Cost fields that appear on the General Info tab are calculated values and cannot 
be edited. Total Cost is the sum of the four cost types: Labor Cost, Capital Expenses, 
Fixed Cost and Flex Cost.

For example, Total Actual Cost is the sum of:

■ Actual Labor Cost

■ Actual Capital Expenses

■ Actual Fixed Cost

■ Actual Flex Cost

In the same manner, Total Estimated Cost is the sum of Estimated Labor Cost, 
Estimated Capital Expenses, Estimated Fixed Cost, and Estimated Flex Cost. Total 
Budgeted Cost is the sum of Budgeted Labor Cost, Budgeted Capital Expenses, 
Budgeted Fixed Cost, and Budgeted Flex Cost.

By default, cost information for each field will be rolled up through the project 
structure such that cost at the summary or parent task is a summation of the cost 
values of its child objects. If cost (Budgeted Labor Cost and Actual Labor Cost) is 
incurred at the Summary task level, then the cost is the summation of costs at the 
summary task level and the child levels below the summary task.There are flags (not 
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visible by default) that can be enabled to allow users to determine whether they want 
the parent/summary task's values to be calculated/rolled up or edited manually.

As you can see in the example below, if a cost is associated with the leaf node it gets 
added to the parent node. The total cost of the entire Program can be obtained in this 
manner.

Example 6–1 Program Cost Rollup 

In this diagram, the cost for Phase 2 is $30, which is the sum of the costs for its 
leaf-level objects. You can also edit Cost at the parent node level for Phase 2.

Costs Included in Baselines
All Cost fields are part of the baseline. Ten Calculate flags are also baselined. Budgeted 
and Actual Labor costs do not have the calculate/roll-up flags as they are always 
calculated and rolled up. See also "Enabling the Calculate Attributes" on page 10-3.

Use the Baseline Comparison Report in the Agile Standard Reports to compare these 
values.

Reports
Reports allow you to display the values of your Agile projects and product records. By 
accessing this information and summarizing it in a meaningful way, reports provide 
insight into your business processes and can help guide better-informed decisions. 

About Agile Standard Reports
Agile PLM provides a robust reporting platform that enables you to:
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■ Measure and monitor business performance using standard out-of-the-box 
reports. These standard reports capture the best practices in product lifecycle 
management business processes.

■ Configure reports with Agile's custom reporting to obtain the specific information 
you need.

■ Use a single point of access to all relevant reports-even those developed outside of 
the Agile PLM application- through Agile's external reporting capability.

For detailed information about using all types of Agile reports, see the Getting Started 
with Agile PLM Guide, which includes information about:

■ How your roles and privileges affect reports

■ Report object tabs

■ Creating and modifying report layouts

■ Creating custom and external reports

■ Running, scheduling, saving, and deleting reports

■ Report output window

Your browser may have default security settings that compromise report display. If 
you are using Internet Explorer with Windows XP, add the Agile site URL as a trusted 
site within the Tools > Internet Options > Security tab to enable proper downloading 
of reports.

Agile Standard Reports for PPM
This section discusses the Agile standard reports that are included as part of Agile 
Product Portfolio Management.

To access project reports:

1. In the left pane, click Reports to display the Reports folder structure.

2. Expand the Reports and Analytics tree and navigate to Standard Reports > 
Program & Portfolio Reports. Agile PPM standard reports are organized into 
subfolder under the Program and Portfolio Reports folder.

3. Click the report you want to view. Available reports are listed here for your 
reference. For details on selecting report parameters, using searches, and executing 
reports, see the Getting Started with Agile PLM Guide.

Reports for projects that are Complete or Canceled are not listed for selection.

Project Reports Description

Project Schedule The schedule report of all the activities of the 
selected root project.

Project Off Track Activities Report of all the activities based on the 
selected health status within the selected root 
project.

Project Top Discussions Report of all open discussions with priority 
you select, within the root project you select.

Project Open Action Items Report of all the open action items associated 
with discussions and tasks of the selected root 
project.
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Project Actual vs. Budgeted Cost Report of the Actual Cost and Budgeted Cost 
for the selected project.

Project User Assignments Report of assignments of a selected user 
within a selected root project.

Project Documents Report of all the documents of the selected 
root project.

Project Deliverable Gate Report of all the Gates and their dependent 
tasks and deliverables in the selected root 
projects.

Baseline Comparison Report of comparison of the baselines for the 
selected project.

All Cancelled Activities Report of all canceled activities that have been 
recorded in the system.

Activity Calendar Conflict Report Highlights weeks where the project activity 
calendar and a user’s preferred calendar show 
different working day exceptions.

For example, in the US Calendar, 3/9 is a 
working day, but in the CN Calendar, 3/9 is a 
non-working day. The task owner can use this 
report to identify the conflict.

End User Reports Description

My Discussions All open discussions owned by you with the 
priority selected when you execute the report.

My Open Action Items All the open action items associated with 
issues and tasks that are assigned to you.

User Time All the projects where the specified user has 
entered Actual Time.

My Documents All the documents for which you are the 
Creator or Checkout User.

My Activities and Utilization All your task assignments.

Resource Pool Reports Description

Pool Member Report Report of all the resources of the selected 
resource pool.

Resource Pool Consumption Report of the resource pool consumption 
during the specified time period.

Resource Pool Utilization Report of all your task assignments for all root 
projects and projects.

Portfolio Reports Description

Portfolio Status Status report of all the root projects to which 
you have access.

Portfolio Cost Cost report of all the root projects to which 
you have access.

Project Reports Description
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Portfolio Cross Program Dependencies Report of all the activities that have external 
dependencies.

Portfolio Deliverable Gate Report of all the Gates and their dependent 
tasks and deliverables in the portfolio of root 
projects.

Portfolio Priority Discussions Report of all the open discussions in your 
portfolio of projects.

Portfolio Reports Description
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7Working with Microsoft Project

The Agile PPM-Microsoft Project integration enables you to schedule projects using 
Microsoft® Project (MSP) and publish the results back to PPM. The integration uses 
Microsoft® Project data stored in XML format to facilitate import and export.

In order for the integration to work, it is imperative that you understand the following:

■ For every project that may be imported to, or exported from, PPM, a single 
schedule editor must be defined, and honored, for the life of the project.

– If MSP is the owner of the project/program schedule, no changes to the 
schedule dates, features that impact schedule dates, or resource assignments 
can be made in PPM.

– If PPM is the owner of the project/program schedule, exports to MSP can only 
be for distribution and will be prohibited from being imported back into PPM.

■ Agile PPM is a Project Management system designed to work as part of PLM, and 
is different from Microsoft Project. 

– Agile PPM is deliverable-oriented; MSP is constraint-oriented.

– Percent complete is calculated in each system independently, and may not be 
identical at time of integration, and as activities are executed in PPM the % 
complete will be different, as it recalculates based on task updates.

– PPM has a separate class of objects for Gates and Milestones. They are not 
tasks with 0 duration, as in MSP. Therefore, there are restrictions in the 
integration on how these items are transferred.

– Many other features in MSP are not supported in PPM, and vice versa.

Caution: Review all documentation for the integration before you 
begin your implementation.

As part of the integration, you can choose to do the following:

■ Create a project in PPM from a legacy MSP file.

■ Use a PPM project template to create a project in MSP.

■ Use MSP as the schedule editor for a project that is tracked in PPM, and has 
deliverables that are managed as part of the PLM context. 

■ Use MSP as a distribution tool, to send PPM projects or programs to users that are 
not registered PPM users (typically suppliers and/or customers).
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The integration XML can also be used to transfer PPM schedules from one server 
to another, for example, a test environment server to a production environment 
server.

Agile PLM imports and exports MSP files using the following features:

■ Create Project from XML - Imports an MSP file in XML format to create a PPM 
project.

■ Load Microsoft® Project XML - Updates the current PPM project with changes 
made in MSP.

For auditing and timing purposes, the import date and time is tracked on the project's 
General Info tab and the Gantt Chart. When you import XML into Agile PPM, there 
are 2 options for the schedule editor: PPM and Microsoft Project. For more 
information, see "Understanding How the Schedule Editors Differ" on page 7-5.

Data Supported in the Integration
The following is a list of data that is synchronized, as well as the schedule and 
resources supported in the integration:

■ Extended attributes mapped to Page Two attributes.

■ Customized calendars and working days. 

In MSP, you can define a specific calendar against each task level, but you need to 
correctly match each calendar to a PPM calendar during import. See "Creating a 
Project from an Existing Microsoft Project File" on page 7-8 for information about 
the mapping process.

Caution: If calendars are not mapped properly, a project reschedule 
may happen if a task starts/ends on a non-working day in a PPM 
calendar. For instance, you may have a calendar defined in MSP that 
has October 9 as a working day, which might be a non-working day in 
PPM. When this task is imported to PPM, the starting day of the task 
may be postponed to October 10, because a task cannot start on a 
non-working day in PPM.

■ MSP Constraints Retention.

Note: PPM does not use or support constraints, however, if MSP is 
the schedule editor for a project, the constraints are restored when the 
PPM version is exported back to MSP. Note that constraints are 
retained during export only if all scheduling and resource 
management operations for the project are done in MSP, and all 
execution-related operations are done in PPM. Scheduling and 
resource management operations include any operation that affects 
the project structure, dates, or resources. Execution-related operations 
include managing deliverables, updating task progress, and so on.

See "Maintaining PPM Constraints" on page A-15 for a specific list of 
unsupported scenarios.



Note: The Estimated flag has the same restrictions as Constraint type 
if the original data from MSP is to be retained. Note that any 
PPM-generated "Estimated" flag is set to No by default.

See "Maintaining PPM Constraints" on page A-15 for a specific list of 
unsupported scenarios.

Data Not Supported in the Integration
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Data validation is performed for:

■ Duplicate MSP Text30 values: Agile PPM uses two columns in MSP, Text29 and 
Text30, to control integration integrity. Text30 carries the unique identifier for all 
objects in the project and no duplicates are allowed. If these columns are not 
manipulated in MSP, then there should not be any issues.

■ Invalid Dependencies

– Self dependencies

– Parent-Child dependencies

■ Finish-to-Finish and Start-to-Finish type predecessor on parent task

■ Inactive users or user groups

■ Inactive roles

■ Name, Description, and Page Two text attributes

Exceptions are noted under "Data Not Supported in the Integration".

Data Not Supported in the Integration
The import operation does not support the following data:

■ Work Contour values - all assignments from MSP are converted as Flat values.

■ Split-task resource assignments.

– Split tasks from MSP are converted into new tasks in PPM and can cause the 
loss of constraints when re-imported since they will change the schedule in 
PPM.

– Best practice is to remove all split tasks prior to import to avoid loss of 
constraints.

■ Manually-edited rollup data on tasks, including both parent and leaf levels.

■ Estimated and Actual Duration values at the second level task node or leaf node is 
not supported by Oracle Agile PPM, both in import and in export functionality. 
This data is not retained during the import and export operation, and can cause 
data corruption.

■ Percent Complete value synchronization for parent task between MSP and in 
PPM. 

Percent Complete at the leaf node level is always synchronized, however, Percent 
Complete in the parent node will never be synchronized. The difference in percent 
complete occurs because MSP allows users to change Duration on the parent task 
if Schedule Mode is set to Manual. In this case the parent duration becomes out of 
sync with its children. Note that the Percent Complete value on Leaf nodes in MSP 
is the same as PPM after export/import.

■ Fractional values for Team.PercentAllocation value. 
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Fractional Values are supported in A9 PPM for the Team.PercentAllocation 
attribute, but it is not supported in Microsoft® Project. We recommend that you do 
not use MSP-PPM integration for projects that have fractional allocation for 
resources on the Team tab.

■ SmartURLs.

■ Microsoft® Project outline numbers.

■ Actual Date values are neither exported nor imported.

■ Estimated Date values are neither exported nor imported.

■ A Milestone/Gate cannot have any other activities/gates as its children, even 
though it is allowed in Microsoft® Project.

■ Milestones with a non-zero duration. If a user tries to import into PPM a milestone 
with a non-zero value for Duration, the data can become corrupted. Non-zero 
durations are supported in MSP, but not in PPM.

See also, "Transferring Microsoft Project Work Values to PPM" on page 7-7.

In addition, the Agile menu in MSP, installed with earlier versions of Agile, is no 
longer required or supported. See "Notes on the Agile Menu in Microsoft Project" on 
page 7-8.

Importing of multiple project XML files is not supported through the Web Client 
interface. You can use the Agile SDK to handle bulk loading requirements.

Before You Begin
Before you begin synchronizing projects between PPM and MSP, make sure the 
integration requirements are met.

■ Ensure that all your Microsoft® Project team members exist in the Agile database.

■ Ensure that you have the Microsoft Project Privilege assigned to you by your Agile 
administrator.

■ Ensure that the necessary attribute mapping has been configured on the 
MSP/Agile PPM mapping file (MSPSyncMapping.properties). See "Setting Up 
Microsoft Project Synchronization" on page 7-5. for details.

■ If your work site has previously used PPM 8.5 or 9.0, uninstall the 8.5 or 9.0 
macros. 

To uninstall macros:

1.  Open Microsoft® Project.

2.  Select Tools > Organizer > Modules.

3. Open Global.mpt and delete the Get File and XML macros.

■ Understand what could create integration challenges; see "Transferring Microsoft 
Project Work Values to PPM" on page 7-7.

■ Understand the impact of choosing a scheduling engine. See"Understanding How 
the Schedule Editors Differ" on page 7-5.
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Setting Up Microsoft Project Synchronization
To ensure that data synchronization works successfully, MSP project elements must be 
mapped to the correct PLM object attributes. Agile provides a mapping file, 
MSPSyncMapping.properties, where these values can be mapped appropriately.

You can find this file in the Agile installation directory under  
..\agileDomain\applications\application.ear\APP-INF\classes. Follow the 
instructions provided within the file to map attributes as required.

Understanding How the Schedule Editors Differ
The schedule editor can be set to either PPM or MSP. 

There are certain values that you need to pay extra attention to when importing a 
project into MSP or importing an MSP project into PPM. These values are as follows:

■ Schedule dates: Both in MSP and PPM

■ Schedule duration: Both in MSP and PPM

■ % complete: Both in MSP and PPM

■ Dependencies: Both in MSP and PPM

■ Effort/Fixed based: both MSP and PPM

■ Project status: Both in MSP and PPM

■ Calendar mapping: Both in MSP and PPM

■ Resource mapping: Both in MSP and PPM

■ Auto schedule: MSP specific value

■ Work contours like weeks /hours: MSP Specific value

■ Split task: MSP specific

When you create a project in PPM and export it into MSP in edit mode, the potential 
results and effects are documented in the following table.

Table 7–1  PPM Project Imported Into MSP

Action Results Warnings

Project created in 
PPM and exported 
to MSP

Project is loaded into 
MSP.

Schedule editor for 
that project in A9 
becomes "MSP".

The following values need attention in this case:

1. Effort/Fixed duration: Effort driven would be 
"Yes" and type is "Fixed Work".

2. By default the task mode is "Auto scheduled"

When you update a project in MSP and then export it into PPM in edit mode, the 
potential results and effects are documented in the following table.



Table 7–2  MSP Project Imported Into PPM

Action Results Warnings

Project exported 
into MSP from 
PPM

Project is in MSP.

Schedule editor can 
remain as MSP or 
PPM.

The following values need attention when project 
updates occur in MSP:

1. Schedule dates: Scheduling happens according 
to MSP logic.

2. Duration/percent complete: according to MSP 
logic.

3. Task with % complete becomes split task when 
dependencies are added.

4. Weekly/hourly work changes the schedule.

5. Only Auto schedule is supported to import 
back in A9.

Project imported 
from MSP to PPM, 
after being 
updated in MSP

Project is in PPM.

Schedule editor can 
remain as MSP or 
PPM. In this case, it is 
set to MSP.

The following are values that need attention 
when a project goes is exported into PPM and 
Schedule Editor is MSP: 
 
1. Schedule dates: Scheduling dates copied from 
MSP

2. Duration: Same duration copied to MSP

3. Percent complete: Rollup occurs according to 
PPM logic 

4. Weeks/hours in schedule duration/time buffer 
is converted as days as per PPM logic.

5. Split task: Duration is computed according to 
A9 logic with schedule dates the same as in MSP.

6. Dependencies: Same as in MSP. 
 
Note: Any addition of tasks, deletion of tasks,  
change in duration, change in dates of tasks, or  
rollup happens as per A9 logic.

Any changes in dependencies/time buffers does 
not reschedule the project unless the schedule 
editor is changed to PPM.

Project imported 
from MSP to PPM, 
after being 
updated in MSP

Project is in PPM.

Schedule editor can 
remain as MSP or 
PPM. In this case, it is 
set to PPM.

The following are values that need  attention 
when a project goes back into PPM and the 
schedule editor is PPM:

1. Rescheduling and rollup of dates happen 
according to PPM logic

2. Split task: Rescheduling happens according to 
PPM logic

Note: The schedule editor can be changed from any child level. 
Additionally, any child of the project can be exported to MSP and 
imported back.

In that case, the schedule editor of the child will be MSP and the 
parent will be PPM. There might be changes in schedule dates 
/duration /% complete due to this change.

Any rescheduling happens for that child only when the editor is 
changed to PPM.
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Note: Split tasks can be created unintentionally by adding a 
dependency to an activity which has % complete in MSP. 
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Choosing the Scheduling Engine
The scheduling engines used by PPM and MSP follow different rules for rescheduling 
and default settings. You cannot schedule projects using MSP and PPM at the same 
time.

PPM has a Schedule Editor switch that can be set for each project to indicate which 
scheduling engine (PPM or MSP) needs to control scheduling. By default, the Schedule 
Editor is set to PPM, but you can control the setting at a template level and thus retain 
that setting for all projects created from a particular template.

The first time you import an MSP file into PPM to create a PPM project, you are 
provided the option to select the preferred scheduling engine. After the PPM project is 
created, to update it with further changes made in MSP, the schedule editor must be 
set to MSP.

The Schedule Editor attribute can also be edited on the project's General Info page. To 
see what actions change the Schedule Editor setting automatically, see "Read Only and 
Edit Modes" on page 7-10.

Transferring Microsoft Project Work Values to PPM
To ensure the accurate mapping of work values from Microsoft® Project to a PPM 
project, you must understand the way each solution handles data, and configure your 
data accordingly.

■ Days Effort - In Agile PPM, days effort is always calculated based on % allocation 
and duration. Unlike in Microsoft® Project, Agile PPM requires an allocation to a 
resource or resource pool in order for days effort to be populated. To ensure that 
effort data values without resource or resource pool allocation are not lost while 
publishing tasks from Microsoft® Project, your Agile administrator can set up and 
define a generic resource pool to hold the work/days effort values. If your Agile 
administrator has defined the generic resource pool, you will notice that tasks 
which satisfy these conditions have a generic resource pool associated to them on 
the Team tab.

■ Custom Subclasses - While creating new tasks in MSP for a PPM project, you can 
override the default subclass values in the Text29 column with custom subclass 
values specified in the Java Client.

■ Page Two Attributes - To ensure the correct mapping of Page Two attributes, you 
must edit the appropriate values in the MSP/Agile PPM mapping file 
(MSPSyncMapping.properties on the Agile server) provided by Agile. Page Three 
attributes cannot be mapped.

■ Float Values - From release 9.3.1, PPM supports float values for duration and 
resource allocation in projects. You can add resources with fractional allocations, 
for example, 200.25, 100.35 and so on. After launching such projects in Microsoft® 
Project and publishing back to PPM, you may see minor variances in these values 
because Microsoft® Project does not support float values.

■ Project Tree Structure - The Agile PPM project name must be at outline level one 
in Microsoft® Project. All Agile PPM subtasks, phases, and gates must be indented 
under level one in Microsoft® Project.
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■ % allocation for resources - Within Microsoft® Project, the % allocation for a 
resource should be a value between 0 and 400 to ensure error-free data mapping. 
The default maximum value for the corresponding field in PPM is 400. To assign a 
higher value, you can change the default configuration for the Team attributes in 
Java Client as appropriate. To learn how to modify attributes, see the Agile PLM 
Administrator Guide.

Caution: Data in the Text30 column should not be tampered with, as this could 
interfere with the synchronization process and cause errors.

Notes on the Agile Menu in Microsoft Project
If you were using the MSP-PPM integration feature with an earlier version of Agile, 
the Agile menu may still appear in your Microsoft® Project toolbar. This feature is no 
longer supported or required, and can safely be removed from the list of COM add-ins 
in MSP.

This is an optional step; retaining the menu does not affect the integration.

To see a list of active COM add-ins for Microsoft® Project:

1. Go to Tools > Customize > Toolbars. The "Customize" window opens.

2. From the Commands tab, within the left-hand list, select Tools.

3. Locate "COM Add-Ins" in the right-hand list.

4. Drag and drop "COM Add-Ins" from the list onto the top menu bar.

5. Close the Customize window.

6. Click the newly added COM Add-Ins menu. A list of all the installed add-ins is 
displayed.

7. Select the add-in you want to uninstall.

8. Click the Remove button to uninstall the selected add-in.

Creating a Project from an Existing Microsoft Project File
You can use an existing MSP plan that contains at least one Level 1 task, as the basis 
for an Agile PPM project object. (All tasks must be rolled up under a single project; 
PPM transforms that project into the root project object.)

To create a PPM project from an existing MSP file:

1. Open the target file in MSP.

2. In the MSP menu, select File > Save As and save the project file in .xml format.

3. Move to the Agile Tools and Settings menu and select Create Project from XML 
File.

4. In the dialog that opens, choose the project XML file from your local directory.

5. If you want PPM to take care of the scheduling for the new project, select the Set 
scheduling engine to PPM option. If you leave this blank, scheduling engine is 
automatically set to the source application, MSP. For more information, see 
"Choosing the Scheduling Engine" on page 7-7.

6. Click Load.

7. Choose what type of project you want to create, Active, Proposed or Template.
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If your MSP file contains users or user groups that are not in the Agile system, you 
are prompted to map these resources to existing users. In the Map Resources 
dialog, the File Resource column lists the unmapped users.

a. Click in the System User cell against each resource name, and use the search 
palette to select and map users.

b. Assign roles in the same way. You can choose to do this later; by default the 
mapped users are assigned the Program Team Member role.

8. If your MSP file contains references to calendars that are not in the Agile system, 
you are prompted to map these calendars to existing calendars. From the System 
Calendars list, select appropriate calendars to map to the ones in the MSP file. 

9. Click Load again.

The Load Summary page confirms whether the file has been successfully uploaded. 
Click Close.

The new project is displayed, showing the data imported from the MSP project.

Note: The import date and timestamp appear in the attributes list on 
the General Info page. Before you work on an imported project, check 
this information to ensure that you are working on the latest version.

Updating a Project with Changes Made in Microsoft Project
It is recommended that you import changes made in MSP back to PPM.

To update your PPM project with changes made in MSP:

1.  Save the MSP project file in XML format.

2.  In Agile, open the PPM project you want to update.

3. From the Actions menu, select Microsoft® Project > Load Microsoft® Project 
XML.

4. Choose the MSP project XML file.

5. Click Load.

If your MSP file contains users or user groups that are not in the Agile system, you 
are prompted to map these resources to existing users. In the Map Resources 
dialog, the File Resource column lists the unmapped users.

a. Click in the System User cell against each resource name, and use the search 
palette to select and map users.

b. Assign roles in the same way. You can choose to do this later; by default the 
mapped users are assigned the Program Team Member role.

6. If your MSP file contains references to calendars that are not in the Agile system, 
you are prompted to map these calendars to existing calendars. From the System 
Calendars list, select appropriate calendars to map to the ones in the MSP file. 

7. Click Load again. The Load Summary confirms successful upload of your changes. 
Click Close.

You can verify the import date and time on the project's General Info tab.
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Using a PPM Project Template in Microsoft Project
You can export a PPM project template to MSP, edit project data in MSP, and then 
import the changes back to PPM. The export and import files should be in XML 
format.

To export a PPM project template to MSP:

1.  Create a project from a template in PPM.

2.  In the Actions menu, select Microsoft® Project > Save as XML - Edit.

3. Save the project file to your local directory.

4. From MSP, open the project XML file.

5. In the dialog that opens, choose As a new project.

6. Click Finish.

Once you finish editing the project in MSP, you can import the changes back to the 
PPM project you created. See "Updating a Project with Changes Made in Microsoft 
Project" on page 7-9.

Working Offline on a PPM Project
If you do not have MSP installed on your computer, you can save your PPM project to 
your local drive as an XML file, and work on it offline. You can access this file from a 
computer on your network that has MSP installed, view or edit it offline, and then 
publish your changes back to PPM when you are online again.

You can use either of the following commands to save your project as an XML file:

■ Save as XML - Read Only

■ Save as XML - Edit Mode

For considerations that you should be aware of before you choose Read Only or Edit 
mode, see "Read Only and Edit Modes" on page 7-10.

To save your project as an XML file:

1.  Open the project you want to save.

2.  From the Actions menu, choose Microsoft® Project > Save as XML - Read only 
or Save as XML - Edit.

3. Download the file to your local drive.

Note: If you are using Windows XP with Internet Explorer 7, default 
security settings for file downloads may result in duplication of 
History records during the Save as XML - Read only operation. To 
prevent this: Ensure that the Web Client URL is added under Tools > 
Internet Options > Trusted Sites > Sites. Under Custom Level 
settings, select Enable for "Automatic prompting for file downloads".

Read Only and Edit Modes
You can launch or save a PPM project in Read Only or Edit mode. The mode you 
choose can affect project data.
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■ Read Only Mode

When you save a PPM project using Microsoft® Project > Save as XML - Read 
Only, you can view, print, or analyze a PPM project in MSP without altering the 
project data in Agile PPM. In MSP, you can perform any edit, modification, or 
analysis actions you choose and save the project file to any local or network 
directory to which you have access.

You cannot, however, publish the launched-as-read-only project back into Agile 
PPM. When you launch as read-only, the PPM project is not locked, the Lock User 
field remains empty, and the Schedule Editor field remains set to PPM. It is 
therefore possible for another user to modify the PPM project by using any of the 
available Agile PPM edit methods: Edit in PPM, edit in MSP, or edit in Gantt 
Chart.

The MSP file that you create when you use Microsoft® Project > Save as XML - 
Read Only is not updated or affected by any subsequent edits made to the PPM 
project file.

■ Edit Mode

When you launch a PPM project in MSP using Microsoft® Project > Save as XML 
- Edit, the PPM project is automatically locked so that no other user can modify it. 
Your name appears in the Lock User field, and the Schedule Editor field is set to 
MSP.

You are able to publish the launched-in-edit-mode project back into Agile PPM.

For more information about locking projects, see "Multiple Users Editing the Same 
Task" on page 4-5.

Replicating a PPM Project Across Servers
You can create a project on one server and replicate it on another, following the process 
outlined here:

1.  In Agile PLM, open the PPM project you want to replicate.

2.  In the Actions menu, select Microsoft® Project > Save as XML - Edit.

3. Save the project XML file to your local directory.

4. From MSP, open the project XML file.

5. In the dialog that opens, choose As a new project.

6. Click Finish. The project opens in MSP, with updated data.

7. Save the project to your local drive in XML format.

8. Log in to Agile PLM on the server where you want the project replicated.

9. Import the project XML file as described in "Creating a Project from an Existing 
Microsoft Project File" on page 7-8.

The project is replicated on the current server.

Deleting Objects in Microsoft Project
You can delete projects, phases or tasks in Microsoft Project by using the Microsoft 
Project features.

When you update Agile PPM with the changes you have made in Microsoft Project, 
Agile PPM checks your assigned Delete privileges to ensure that you are allowed to 
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delete projects, programs, phases, or gates in Agile PPM. If you have deleted activities 
in Microsoft Project that you are not allowed to delete in Agile PPM, none of your 
Microsoft Project changes are saved to the Agile database, and you see an error 
message telling you that you do not have the appropriate privileges.

Note: If the publish to PPM fails because you do not have the 
appropriate Delete privileges, you will not be able to go back to the 
original project tree in Microsoft Project. However, you can go back to 
Agile PPM and launch Microsoft Project again.

If you are not able to delete specific types of PPM objects in Agile PPM, you will also 
not be able to delete them in Microsoft Project and update the Agile database.
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8Working with Recipe Management for 
Pharmaceuticals

The PPM integration with Recipe Management for Pharmaceuticals enables you to use 
PPM project management features to track and manage Active Pharmaceutical 
Ingredients (API) development. You can create and manage Recipe & Material 
Workspace (RMW) projects and work requests in PPM.

Work requests are handled in the same manner as tasks in PPM, and can be grouped 
under the appropriate project. Progress tracking is done using standard PPM status 
tracking functionality, as described in "Status Tracking" on page 6-1.

This integration enables you to do the following in PPM:

■ Create RMW projects and work requests.

You can create an RMW project or work request in the same way that you create a 
PPM project, phase or task. (See "Creating a Project" on page 4-1.) After you create 
an RMW project, you can create and add work requests to it, provided you have 
been assigned the RMW Administrator role. Work requests must be associated 
with a recipe to ensure successful integration.

■ Add recipes from RMW as content to the work request in PPM.

You can use the Add > By Search option on the Content tab to add recipes 
associated to the work requests. Only recipes that have been approved and set to 
Ready to Publish in RMW can be added to the work request.

■ Synchronize RMW data between PPM and RMW.

Work requests created in PPM are visible in RMW, and can be updated in RMW. 
Updates made to the work request in RMW are automatically synced to PPM. 
Updates made in PPM must be manually synced to RMW.

If you close out a work request in RMW, the following events are triggered:

■ The recipe is published to PPM in XML or PDF format.

■ If there are samples (results) in the BOM tab of the work request, these are also 
published to PPM.

■ In PPM, the status of the RMW project or work request changes from In Process to 
Completed.

Synchronizing Data between PPM and RMW
The PPM Sync to RMW feature enables data synchronization between the two 
solutions.
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To update the RMW project or work request in PPM with the latest data entered in 
RMW:

1. Open the RMW project or work request in PPM.

2. In the Actions menu, select PPM Sync to RMW.

A confirmation message appears - " The project hierarchy is integrated successfully." 
You can also see integration details in the last three fields on the General Info tab. The 
project data is refreshed to display current information.
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9Import and Export

Agile PLM provides the capability to import or export PLM data by the use of Import 
and Export wizards. To import or export Agile data, you must have the appropriate 
privileges.

For generic information on importing and exporting data in Agile PLM, see the Agile 
PLM Import Export Guide. If you have questions about privileges that are not covered in 
this guide, contact your Agile PLM administrator or refer to the Agile PLM 
Administrator Guide.

Importing Data
The Import wizard enables you to add and update large files (product content) from 
other formats into Agile PPM. Import not only brings in legacy data that is required to 
start your business processes within Agile, but also enables you to update product 
content periodically. The Import process must be implemented appropriately to reap 
the value of Agile solutions.

You can create large data source files and quickly upload them in bulk into Agile 
through the import procedures described here. Prior to import, you can set preferences 
to specify the conditions for import.

The Import Wizard enables you to import the following objects into Agile PPM:

■ Projects and project content such as Discussions or Action Items

■ User Groups

■ Users

Discussion and Action items can only be created and not updated. You cannot update 
or modify existing data.

Before You Begin
Before you import data from source files into Agile PPM:

■ Ensure that you have the appropriate Agile PPM user license and privileges. To 
import Agile data, you must have Create, Discover, Read, and Modify and Import 
privileges for each type of Agile object you are importing. You also must have the 
Import privilege options enabled in Java Client. If you have questions about 
privileges, contact your Agile administrator or refer to the Agile PLM Administrator 
Guide. To launch Import, you must have the My User Profile role, Read User 
privilege and Import privilege.

■ Ensure that you understand the specifications for each field. Certain fields are 
mandatory; therefore you must map them in the Import wizard fields. Fields also 
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have data types, which determine how the data should be formatted, and 
maximum lengths, which the Agile PPM system validates on import. These are set 
in the Import Wizard Preferences.

■ Ensure that your data is in the correct file format. If you are importing data from 
text files, check your source data to ensure that it is in a supported file format, and 
matches the Import Preferences settings. For details, see "Supported File Formats" 
on page 9-2. To create aXML files, use Agile Content Service (ACS), Agile 
Integration Services (AIS), or create an aXML file from the Export command. You 
can view aXML files in any XML viewer, including Internet Explorer.

■ Ensure that the Agile PPM system has sufficient hard disk space for importing 
large data files or create an aXML file from Export Wizard.

Persistence of Import Settings
When you use the Import Wizard in Web Client, the data stays for the duration of the 
session. The settings that persist include:

■ Import preference settings

■ Source file configuration

■ Selected content to import

■ Selected mapping file

■ Selected transformation file

■ Selected change number

When you choose a different source file, the selected content, mapping file, and 
transformation file are reset.

Importing Large Data Files
Before importing a large file, clear the Log Transformations preference check box for 
faster results. If you are importing large amounts of data during one import session, 
you should perform the session during non-business hours - when system usage is 
low. After the import session is finished, you can view the log file in a browser or save 
it to a file.

For more information, see the Import and Export Guide.

Supported File Formats
You can import and export data in several file formats. The following file formats are 
supported:

Use File Type Description To Import

Delimited Text File (.dtf) A standard flat text file where 
each field data is delimited by 
a special character, such as a 
comma or a tab.

Any object.

Excel Workbook (.txt, .csv, 
.xls)

Microsoft Excel workbook 
files. For details of the latest 
versions supported, see Agile 
PLM Capacity Planning Guide.

Users, User Groups, Root 
Projects, and Action Items.
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Data Transformation
Before you import data, you may need to transform the values in some fields to make 
them compatible with the Agile system. You can use a Transformation Definition file 
to perform this transformation. Transformation definition files are especially helpful 
for importing data from PDX or aXML packages. Generally, PDX or aXML packages 
are read-only. You cannot change the values contained in an archived file. If there are 
data inconsistencies in a PDX or aXML package, you must try to correct them using a 
transformation definition file.

A transformation definition file is a comma-delimited text file. Optionally, you can 
qualify text strings in the file using double-quotes ("). The file must contain a set of 
required fields needed to transform import data.

The Import wizard does not support transformation definition files created with 
previous Agile Product Cost Management or Agile Product Collaboration releases.

Transformation definition files are optional for importing data. If the source data does 
not need to be modified, you can skip the Data Transformation step in the Import 
Wizard. Transformation file step is used only in case of aXML data as it cannot be 
modified in any other tool.

Importing Projects and Project Content
To launch the Import function, choose Tools and Settings > Import. This opens the 
Import Wizard that guides you through the import procedure. Importing is done in 
the following sequence:

1. Define import preferences.

2. Select the source file to be imported and specify file type.

3. Select the content from the list of contents that can be imported.

4. Map source fields to target solution fields to store the imported data.

5. Transform source field data into the Agile format.

6. Review the information that you have entered and start the import.

An Import log records the process, and logs the results and errors.

The following sections describe each step of the import procedure in detail.

Define Import Preferences
Preference settings allow you to set different conditions to run the import. The Import 
wizard has several preference settings that you can set from any step in the wizard. 
These settings persist during the current Agile PLM client session, but they are not 
permanently saved with each user's profile.

Agile XML (.axml) Agile's proprietary XML 
format that includes data not 
supported by PDX.

Users, User Groups, and 
Discussions

MS Project Export File (.xml) XML data exported from 
Microsoft Project for import to 
Agile. For more information 
about this format, see the Agile 
Import and Export Guide.

Projects and project objects 
created in Microsoft Project.

Use File Type Description To Import
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These settings are optional; you can complete the import without specifying 
preferences.

To set import preferences:

1. Click the Preferences button at the bottom left corner of the Import wizard. The 
Import Preference window appears.

2. Select one of the following from the list:

■ Parsing and Validation Options

■ Business Rule Options

■ Default Types

■ AutoNumber Sources

Depending on the option you choose, the wizard displays a list of values that 
you can define. For complete details on the impact of each setting you define, 
see the Agile Import and Export Guide.

3. Select preference settings and click OK.

File Selection
The File Selection step in the Import Wizard lets you select the source file to be 
imported and configure it for import.

To select the source file for the import:

1. In the Import File field, click Browse to select the file from your local drive. 
Ensure that the file you select is in one of the supported formats. Depending on 
the format of the file you choose, additional configuration fields appear.

2. Select the appropriate options for your import as described in the table below.

Field Name Action

Template Type Select the template type of your import file.

Select Worksheet

(for Excel files)

Excel files consists of several sheets in a single file. In case more 
than 1 sheet exists, you can specify the sheet number here.

Field Delimiter Select the appropriate field delimiter which will separate figures or 
text within the file.

Text Qualifier Select the symbol which will qualify the data as text and not 
figures.

Location of Header Row Specify the row number within the worksheet which contains the 
text to be used as the header row.

Location of Last Row Specify the row number in the worksheet to be taken as the last 
row to import data.

Use this setting to import a table format file which may contain 
multiple object types. Import will only load specified data based 
on header row and last row specified.

You can also use it if the import sheet is too long and you do not 
want all the content to be imported.

File Encoding Specify File encoding.

3. Click Next.
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Specify File Content
The third step of the import wizard enables you to:

■ Specify the objects that you want to import.

■ Select mapping and data transformation methods to use.

To select project content to be imported:

1. Click Project to view the options available.

2. Select the content object you want to import. You can only select one object at a 
time.

3. Click Next to move to the next step.

To select mapping and transformation methods:

1. Under Data Mapping, select one of the following options to define mapping 
specifications:

■ Define attribute mapping in next step - To map each field manually, select 
this option.

■ Use a saved mapping file - If you already have an existing mapping file 
which corresponds to the file which is being imported, select this option. Then 
click Browse to locate and select the saved mapping file from your directory.

2. Under Data Transformation, select one of the following options to define 
transformation specifications:

■ Do not Perform any Transformations - If you are not importing an aXML file, 
select this option.

■ Use a saved transformation file - If you are importing an aXML file, select this 
option. Then click Browse and select a Transformation Definition file from 
your directory. You can also use the transformation template that Agile 
provides, if you want. Click Download Transformation Template. Save the 
file onto your computer and then select it for use in the import.

Any transformation that occurs during an import session is recorded in the Import 
Log file. For more information on transformation files, see "Data Transformation" 
on page 9-3.

3. Click Next to move to the next step.

Specify Attribute Mapping
You can map fields in the source data to Agile fields. The left column (Import Fields) 
lists the fields in the header row of the import source file. The data fields that can be 
imported are displayed in the right column (Agile Fields) categorized as Activities and 
Gates. Only fields that you map will be imported. The remaining data will not be 
included.

To map source fields to Agile fields:

1. Click Expand All to view all the fields listed under Agile fields. Mandatory fields 
for creating a project are displayed in bold. Required fields appear in green.

2. Click once on a field in the left column to select it. Click the corresponding Agile 
field in the right column to create the mapping. The mapped field appears next to 
the Agile field for your reference.

3. Continue mapping each field. Ensure that all required fields are mapped.
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If you have mapped the same import field more than once, the word [multiple] 
appears next to the field. To remove an incorrect mapping, click the x symbol next 
to the field name.

4. When you finish mapping source fields to Agile fields, you can choose to save this 
mapping file for future use. Click Save As and save the file to your local drive.

5. To review import settings, click Next.

Review Import Settings and Begin Import
The final step of the Import Wizard enables you to review all the specified import 
settings so that you can go back and make changes if necessary.

1. To check if your data is in order, click Validate.

2. To begin the import, click Import. The source data is imported into Agile PPM. To 
cancel the process, click Cancel.

An Import Log displays the results of the import action and error messages. To 
keep a record of the import errors, click Save Log.

3. To return to Agile Web Client, click Close.

Exporting Data
The Export Wizard enables the extraction of projects and other objects from Agile PLM 
into formats such as Microsoft Excel worksheets, comma-delimited text, PDX Packages 
or aXML Packages, for distribution to customers or vendors.

You can export the following types of objects from Agile PPM:

■ Discussions

■ Root Projects

■ Users and User Groups

You can also export a project, make modifications to P1, P2 and P3 fields, and then 
import it back into Agile.

To start the Export wizard from Agile Web Client:

1. Open an object to export.

2. Choose Tools and Settings > Export.

To start the Export wizard from Agile Java Client:

1. Open a root project to export.

2. Choose Actions > Export.

3. Search for objects that can be exported, and select one or more objects in the Search 
Results page.

4. Choose Tools > Export.

To export a project or PPM object:

1. In the Select Objects to Extract page, from the Format drop-down list, select the 
format to which you want to export data.

2. In the Site field, select a site. To export data for all sites, select All.
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The Site field is only available if your Agile system includes the Sites server 
license.

3. To identify the projects or other Agile objects for export, click Add. An Add 
Objects dialog opens, where you can search and locate objects.

4. Select the objects you want to export and click Next.

5. You can provide filter conditions for the export:

■ To define your own filter conditions, select the Create custom filter option 
and click Next. Then select the individual tabs for the content you want to 
export or select Select All to export all content. Click Next to continue.

■ To use a pre-defined filter for each of the selected objects, select the Use 
predefined filter option. Select the filter you want from the drop-down list for 
each object. To review details of each filter, select the filter and click Details. 
Once you make your selection, click Next.

6. In the next step, enter export header information for your reference.

7. To complete the export, click Export. Specify a directory or location to save your 
export data when prompted.

A confirmation dialog displays to indicate that the export is complete. If there are 
errors, an error log is displayed.

The export operation takes into consideration only base class-level attribute 
configuration. If you have enabled or disabled attributes at the subclass level, these 
configurations will not be maintained during export.
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Agile PLM is highly configurable and provides administrators considerable flexibility 
in determining the display and behavior of various Agile objects to suit discrete 
business needs. Configuration options are available both in Agile Java Client and 
Agile Web Client.

Administration in Agile Java Client
The administrative features in Agile's Java Client help you configure and adapt Agile 
PLM to fit the way you already do business. Administrator nodes let you manage 
users and tailor aspects of Agile PLM to meet your company's requirements.

Detailed instructions on how to perform all Agile PLM administration tasks are 
provided in the Agile PLM Administrator Guide. Some configuration settings that are 
required for Product Portfolio Management are listed here. You must be familiar with 
administering Agile objects to perform the PPM configuration tasks described here.

Product Portfolio Management Configuration Checklist
Use the following checklist to configure Agile PLM server settings for Product 
Portfolio Management. For instructions on how to perform these configuration tasks, 
refer the Agile PLM Administrator Guide.

■ Configure the Projects Class - Change base class and class names according to 
your business requirement. Enable, disable, or rename Page Two tabs and 
attributes.

■ Configure Subclasses of the Projects Class - Configure the Page Three tab and 
attributes. Create new autonumbers or modify predefined autonumbers.

■ Customize Lists - Create new lists or modify predefined lists to display attributes 
for user selection.

■ Configure Criteria - Define the criteria by which workflow and access control 
should be determined.

■ Configure Workflows - Define the workflows you require to facilitate your 
business processes.

■ Define Users - Define the users and resource pools (user groups) who will 
participate in projects.

■ Configure Roles and Privileges - Assign those users appropriate roles, such as 
Program Manager, Program Team Member, Program Administrator and so on. 
Check the privileges assigned to the predefined roles and modify if necessary.
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■ Configure SmartRules - Ensure that you properly configure SmartRules related to 
MSP integration, timesheet entries, adding activities to completed Projects, 
commenting, and other SmartRules related to workflows.

■ Configure Notifications - Configure settings for the predefined notifications or 
create new ones.

■ Configure My Assignments - Define the attributes that should display in your My 
Assignments tab. Enable, disable or rename the attributes as appropriate.

■ Define Company Profile - Specify the name, address, phone number, URL, and 
the corporate currency for your company.

■ Define Currency Exchange Rates - Ensure that currency exchange rates are 
current to reflect accurate project costs.

■ Configure the Dashboard - Define what tabs and tables you want displayed in the 
Dashboard.

■ Configure Status Indicators - Define status attributes for Schedule, Cost, Quality, 
and Resource status tracking.

■ Configure Default Roles - Specify which Agile PLM roles are assigned 
automatically to users when a task is delegated to them or when a Microsoft 
Project is published to Agile PPM.

■ Configure Quick View for Projects - Configure the display of the Quick View 
dialog that provides details of the project object. Define what fields and action 
buttons should display to facilitate user action.

■ Configure Events - Define custom actions that should occur before, after, or 
during predefined events.

■ Set Up Task Configuration - Schedule execution of project-specific background 
tasks.

■ Configure Calendars - Configure the display of custom calendars for use in 
projects. 

Notes on Data Settings
The following section provides information you need to keep in mind while 
configuring classes and sub-classes in Agile PLM.

Object Classes for Deliverables
The objects that a user can specify as a deliverable are determined by several factors:

■ If the appropriate Agile solution is installed at your site. For example, to select a 
Declaration, Agile PG&C must be installed at your site.

■ Whether the user has the appropriate privileges to discover and read the object.

Class
Target Event 
Attribute Notes

Deliverables 
tab table Add by

Item base class Lifecycle Defined in Agile 
Administrator Classes 
node, Lifecycle Phases 
tab.

Controlled by the 
Agile change process.

Affected By Search

Create New
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Enabling the Calculate Attributes
By default, all costs are calculated. However, by enabling the General Info tab 
Calculate attributes, the end user can choose whether to use the calculated cost or a 
cost value that he enters. The Calculate attributes are list type attributes that use a 
Yes/No selection list. When the Calculate attributes are disabled (not visible), the 
default setting is Yes (calculate). See also "How Total Cost is Determined" on page 6-4.

With the exception of Labor costs, each of the cost fields shown in the table below has 
an associated Calculate attribute. You can enable all the Calculate attributes or only the 
Calculate attributes you want to use.

If the Calculate attribute is visible and the end user has the privilege to modify the 
attribute, he has the option to select Yes or No.

■ Yes - When rolling up the costs of the current activity to its parent activity, use the 
calculated cost of the current activity's children.

■ No - When rolling up the costs of the current activity to its parent activity, do not 
use the calculated cost, rather, use the cost entered in the cost field. In this case, 
there will be no rollups. Instead, cost will be calculated based on the values 
specified for the parent activity.

Changes base 
class

Workflow.Stat
us

Target status list 
depends on the 
workflow that has 
been selected for the 
specified object.

Affected By 
Affects

Search

Create New

Manufacturer 
Part class

Lifecycle Defined in Agile 
Administrator Classes 
node, Lifecycle Phases 
tab.

Not controlled by the 
Agile change process.

Affected By Search

Create New

Manufacturer 
class

Lifecycle Defined in Agile 
Administrator Classes 
node, Lifecycle Phases 
tab.

Not controlled by the 
Agile change process.

Affected By Search

Create New

File Folder base 
class

Lifecycle Defined in Agile 
Administrator Classes 
node, Lifecycle Phases 
tab.

Not controlled by the 
Agile change process.

Affected By Search

Create New

PSR base class Workflow.Stat
us

Target status list 
depends on the 
workflow that has 
been selected for the 
specified object.

Affected By 
Affects

Search

Create New

QCR base class Workflow.Stat
us

Target status depends 
on the workflow that 
has been selected for 
the specified object.

Affected By 
Affects

Search

Create New

Class
Target Event 
Attribute Notes

Deliverables 
tab table Add by
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To use a Calculate attribute you must:

■ Enable the appropriate Calculate attribute of the object's General Info tab. 
(Settings > Data Settings > Classes)

■ Edit the appropriate Modify privilege masks by adding the Calculate attribute to 
the Applied To property of the privilege mask. (Settings > User Settings > 
Privileges > Modify)

For example, to use the Yes/No selection list for Calculate Capital Cost - Budget on 
the General Info tab of Activities, the user must have a Modify privilege mask for 
Activities that includes Activity.General Info.Calculate Capital Cost - Budget in the 
Applied To property.

The following table shows the cost attributes, their associated Calculate attributes, and 
the Modify privilege mask attributes that must be added to the Modify privilege mask 
Applied To property.

General Info tab Cost 
attribute:

Enable the associated 
General Info tab Calculate 
attribute:

Add to the appropriate 
Modify privilege mask 
Applied To property:

Actual Labor Cost

Budgeted Labor Cost

Estimated Labor Cost to 
Completion

Actual Labor Cost and 
Budgeted Labor Cost are 
always calculated.

Estimated Labor Cost to 
Completion can be edited on 
the General Info tab; it is not 
calculated.

No Calculate attributes are 
provided for labor costs.

(Not applicable)

Actual Capital Cost Calculate Capital Cost - 
Actual

<object>.General 
Info.Calculate Capital Cost - 
Actual

Budgeted Capital Cost Calculate Capital Cost - 
Budget

<object>.General 
Info.Calculate Capital Cost - 
Budget

Estimated Capital Cost to 
Completion

Calculate Capital Cost - EAC <object>.General Info. 
Calculate Capital Cost - EAC

Actual Fixed Cost Calculate Fixed Cost - Actual <object>.General 
Info.Calculate Fixed Cost - 
Actual

Budgeted Fixed Cost Calculate Fixed Cost - Budget <object>.General 
Info.Calculate Fixed Cost - 
Budget

Estimated Fixed Cost to 
Completion

Calculate Fixed Cost - EAC <object>.General Info. 
Calculate Fixed Cost - EAC

Actual Flex Cost Calculate Flex Cost - Actual <object>.General 
Info.Calculate Flex Cost - 
Actual

Budgeted Flex Cost Calculate Flex Cost - Budget <object>.General 
Info.Calculate Flex Cost - 
Budget

Estimated Flex Cost to 
Completion

Calculate Flex Cost - EAC <object>.General Info. 
Calculate Flex Cost - EAC
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Configuring Display of Date Attributes in Schedule Tab
In the Schedule tab, the order and display of date attributes in the header row of the 
activities table are controlled by settings for Date Group Table, Actual Date Group 
Table and Estimated Date Group Table attributes in Java Client (Admin > Classes > 
Activities > User Interface Tabs > Schedule > Attributes:Schedule). Settings for these 
group attributes override settings for individual date attributes.

You can enable or disable these attributes and also reorder the attributes to appear in 
the sequence you want them to appear.

Variances Displayed in the General Info Tab Summary Table
The following variance calculations appear in the summary table at the top of the 
General Info tab of Activity objects and Gate objects. Use the Classes node to make 
the variance calculations visible in the summary table by enabling the attributes. Work 
days indicate the variance in scheduled days of work. Calendar days indicate the 
variance according to days on the calendar. A four week variance would appear as 20 
work days and 28 calendar days.

If Actual and Estimated date fields are blank, no variance calculations are performed 
for those attributes.

Use the Classes node to choose which variance calculations will be visible in the 
summary table by enabling or disabling the attributes. In addition, you can use the 
Applied To property of PPM object Read privilege masks to control which users can 
read these attributes.

Variance attribute Difference between

Estimated Start Variance Work Days Estimated Start Date - Scheduled Start date (in 
work days)

Estimated Duration Variance Work Days Estimated Duration - Schedule Duration (in 
work days)

Estimated Finish Variance Work Days Estimated Finish Date - Scheduled Finish date 
(in work days)

Estimated Start Variance Calendar Days Estimated Start Date - Scheduled Start date (in 
calendar days)

Estimated Duration Variance Calendar Days Estimated Duration - Schedule Duration (in 
calendar days)

Estimated Finish Variance Calendar Days Estimated Finish Date - Scheduled Finish date 
(in calendar days)

Actual Start Variance Work Days Actual Start Date - Scheduled Start date (in 
work days)

Actual Duration Variance Work Days Actual Duration - Schedule Duration (in work 
days)

Actual Finish Variance Work Days Actual Finish Date - Scheduled Finish date (in 
work days)

Actual Start Variance Calendar Days Actual Start Date - Scheduled Start date (in 
calendar days)

Actual Duration Variance Calendar Days Actual Duration - Schedule Duration (in 
calendar days)

Actual Finish Variance Calendar Days Actual Finish Date - Scheduled Finish date (in 
calendar days)
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Notes on Setting Up Roles
The following section provides information you need to keep in mind while setting up 
Roles for users.

Default Roles Assigned Automatically to Agile PPM Users
The Default Role node enables you to specify which Agile PLM roles are assigned 
automatically to users when a task is delegated to them or when a Microsoft Project, 
along with its users and roles, is published to Agile PLM.

Access to the Default Role node requires that the administrator user have PPM Default 
Role selected in the Applied To property of that user's Administrator privilege mask. 
For more information, see the Agile PLM Administrator Guide.

When you open the Default Role node, the Default Role window appears. It lists two 
Agile PPM roles:

■ Default MSP Synchronization Role - Controls the role assigned to a user from a 
Microsoft Project that was published to Agile PLM. By default, the user is assigned 
the Program Team Member role.

■ Default Object Owner Role - Controls the role assigned to a user when another 
user delegates a task to him. By default, the user is assigned the Program Manager 
role.

The Default Object Owner Role is also assigned to the object owner in the Team tab 
when an activity is created. When an activity is delegated, the role is assigned to the 
delegated owner only after the delegated owner accepts the delegation.

You can change the roles used for Microsoft Project synchronization or task delegation. 
By default, available roles you can choose are:

■ Change Analyst

■ Program Team Member

■ Program Manager

■ Resource Pool Owner

■ Program Administrator

If you have modified the Agile PPM roles or defined additional roles for Agile PPM, 
the list of roles in the Default Role Role(s) lists may differ from the list above. For more 
information, see "How the Lists of Available Agile PPM Roles are Determined" on 
page 10-7.

To change default roles used for Microsoft Project synchronization and task 
delegation:

1. Under System Settings > Product Portfolio Management, double-click Default 
Role. The Default Role window opens.

2. Double-click the Default MSP Synchronization Role to open it.

3. Click the Role(s) list and select a role.

4. Click Save.

5. Click Close to close the window.

6. In the Default Role window, double-click the Default Object Owner Role to open 
it.

7. Click the Role(s) list and select a role.
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8. Click Save.

9. Click Close to close the window.

How the Lists of Available Agile PPM Roles are Determined
There are several actions in Agile PLM where the Agile administrator or the end user 
is required to select an Agile PPM role from a list. Agile PPM role-selection actions 
include:

■ When the Agile administrator selects the Default MSP Synchronization Role or 
the Default Object Owner Role, as described above.

■ When the end user adds team members or resources to the Team tab of an activity.

The Agile PPM roles that appear in these lists are roles assigned to the login user that 
include at least one privilege mask with an object type of activities or gates. For 
example, the Agile-supplied Change Analyst role includes the privilege mask 
Subscribe to Gates Class; therefore, the Change Analyst role appears in the list of 
available PPM roles. If you were to remove that privilege mask (thus removing all 
activity and gate privilege masks) from the Change Analyst role, the Change Analyst 
role would no longer appear on the list of available Agile PPM roles.

End users do not need to have these PPM roles assigned at the system level (that is, in 
the Roles property of their User Profiles), as these roles are applied only on specific 
Agile PPM objects.

Notes on Assigning PPM-specific Privileges
The following section provides information on PPM-specific privileges and what you 
must keep in mind while assigning these privileges to users.

Create from Template Privilege
This privilege, enabled for the Program Administrator and Program Manager roles, 
enables the user to create a project from an existing template. Users who do not have 
either of the "Program" roles will also need to have the following privileges to use the 
Create from Template privilege:

■ Read privilege for the template that is being accessed

■ Create privilege to create subclasses in the template

Share, Grant, and Delegate Owner Privileges
Share, Grant, and Delegate Owner privileges cannot be inherited from a project role or 
default role. These privileges need to be assigned to users separately, as appropriate.

Microsoft Project Privilege
Depending on the AppliedTo property of a Microsoft Project privilege mask, the 
Microsoft Project privilege enables the user to perform specific tasks between 
Microsoft Project and Agile PPM. By default, this privilege mask is enabled for the 
Program Administrator and Program Manager roles.

This privilege contains five properties in the Applied To field.

■ Save As XML-Read Only - save PPM project data in XML in Read Only mode

■ Save As XML-Edit - save PPM project data in XML in Edit mode

To enable these properties, move the required properties from the Choices list to the 
Selected list.
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Before Agile PLM Release. 9.2.2, the Modify privilege contained the capability to 
access MS Project, which is now broken out to the Microsoft Project privilege. In 
addition to this privilege, you must enable General Info.Lock User and General 
Info.Schedule Editor in the Modify privilege to access MS Project in PPM Gantt Chart.

Update All Timesheets Privilege
This privilege is enabled for the Timesheet Administrator role, and enables the user to 
administer all timesheets recorded in Agile PLM. With this privilege, a user can do the 
following:

■ Search and view timesheets for other users, using the Timesheet Tab tools. For 
more information, see "Searching for Timesheets" on page 4-20.

■ View all tasks for a selected user, then view and change timesheet data recorded 
for each task, using the View and Personalize tools. For more information, see 
"Defining Timesheet Views" on page 4-21.

This privilege overrides system privileges for viewing tasks. The user need not be a 
team member on the task to perform these actions.

Calendar Administrator Privilege
The Calendar Administrator privilege enables you to perform all administrative 
actions on calendars. This includes creating, editing, importing, exporting, and 
sending calendar change notifications. It is assigned to the Administrator role by 
default. 

This privilege contains four properties in the Applied To field.

■ Create - allows you to create calendars. Enabled by default.

■ Read - allows you to read all calendars. Enabled by default.

■ Modify - allows you to modify all calendars. Enabled by default.

■ Delete - allows you to delete all unused calendars. Disabled by default.

Adding Project Contents in Modify Privilege
In PLM 9.2.2, the Relationships tab was renamed to Content, for PPM objects. 
However, in the Projects classes, the properties under the Content tab are displayed 
under the Attributes: Relationships tab.

You can add other objects or contents to an existing project such as Customers, File 
Folders and so on. To enable this privilege, two properties have been added - 
Content.Name and Content.Rule. The AppliedTo property of any Modify privilege 
mask can be tailored to permit the user to add content (that is, add relationships) or 
add a Content rule (that is, add a rule to a relationship) based on the Name and Rule 
attributes, respectively, being enabled in the AppliedTo property.

To enable the ability to add content (Name attribute) and content rules (Rule 
attribute), in the Modify privilege mask's AppliedTo property, move Content.Name 
and Content.Rule properties from the Choices list to the Selected list. These 
properties are displayed in the AppliedTo property list as Activity.Content.Name and 
Activity.Content.Rule, and as Gates.Content.Name and Gates.Content.Rule. (In 
other classes, the format will read, for example, Substances. Relationships.Name.)

For more details on the AppliedTo property, see the section, "AppliedTo Capability" in 
the Agile PLM Administrator Guide.
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Accessing Gantt Charts
The Gantt capability is covered by Read Program Schedule and Modify Program 
Schedule privilege masks. For more information, see the following section.

Modify Privilege Mask Applied To Properties that Control Specific User Actions
Agile PLM uses Modify privilege mask Applied To properties to determine and 
control certain specific user actions and capabilities in Agile PPM. For example, if a 
user has a role that includes a Modify privilege mask for activities and the Applied To 
property includes the Activities.Schedule.Name attribute, then that user can use the 
Add function on the Schedule tab.

Agile PLM roles and privilege masks allow you to define very specific and narrow 
Agile PPM user capabilities if required. For detailed information about privilege 
masks, see Agile PLM Administrator Guide.

The following table lists the Modify privilege mask Applied To properties and which 
PPM actions they control.

This table uses <object> as a place holder for the class or subclass name in the Applied 
To attribute column. The actual class or subclass name in any privilege mask is 
determined by the reusable criteria specified in the privilege mask. If you view the 
example privilege masks mentioned in the Notes column, the Applied To properties 
will be appropriate for that specific privilege mask (for example, Activities.General 
Info.Lock User).

Object-level actions

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes

Lock or unlock projects

Lock and Unlock

<object>.General Info.Lock 
User

Example - Modify Program 
Schedule.

Cancel Locked Project

Unlock Enables user to cancel 
the locked condition of a 
project that was locked by a 
different user.

<object>.General Info.Locked 
From Program

Example - Cancel Lock 
Program.

Edit the Gantt chart

Gantt Chart

<object>.General Info.Lock 
User

and

<object>.General 
Info.Schedule Editor

Example - Modify Program 
Schedule (for Lock User).

and

Example - Read Program 
Schedule (for Schedule 
Editor).

The user requires modify 
privilege for both of these 
attributes to edit the Gantt 
chart.

Read the Gantt chart

Gantt Chart

<object>.General 
Info.Schedule Editor

(and the user does not also 
have<object>.General 
Info.Lock User)

Example - Read Program 
Schedule.

If the user has Modify applied 
to General Info.Schedule 
Editor, but he lacks Modify 
applied to Lock User, he will 
be able to open and read the 
Gantt chart, but he will not be 
able to edit the Gantt chart.



Administration in Agile Java Client

10-10 Product Portfolio Management User Guide

Schedule tab actions

Save as XML

Microsoft® Project >Save As 
XML

<object>.General 
Info.Schedule Editor

Example - Read Program 
Schedule.

This is a Modify type 
privilege mask, not a Read 
type privilege mask.

Note: Save as XML sets the 
Schedule Editor attribute to 
MSP. This disables the roll-up 
of dates in Agile PPM.

Substitute Resource

Actions > Substitute 
Resource

<object>.Team.Name Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Change Parent

Actions > Change Parent

<object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Change Archive Status

Actions > Change Archive 
Status

<object>.General 
Info.Archived

Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Delegate 

Delegate an activity (you are 
the owner) to a different 
owner

Actions > Delegate

<object>.General 
Info.Delegated Owner

Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Change Owner--Edit the 
Owner field of an activity 
from the General Info tab.

<object>.General Info.Owner Example - Read All Programs, 
Phases, Tasks and Gates

Modify All Programs, Phases, 
Tasks and Gates

Delete

Delete the current object

Actions > Delete

Always requires a Delete 
privilege mask for the current 
object where the delete action 
is performed in Agile PPM.

Requires Delete privileges for 
subordinate objects on the 
current object's Schedule tab.

If there is a parent object, 
Delete of the current object 
also requires the following:

Delete privilege mask for the 
parent object.

•Modify privilege mask for 
the parent object: <parent 
object>.Schedule.Name

When the current PPM object 
is deleted in Agile PPM Web 
Client, all three privilege 
masks are required (if there is 
a parent object).

Current object Delete 
privilege

Children objects Delete 
privileges

Parent object Delete privilege

Parent object Modify 
Schedule.Name

Change Preferred Calendar 

Edit the Preferred Calendar 
attribute on the General Info 
tab of a user or user group.

<object>.General 
Info.Preferred Calendar

Modify Users, Modify User 
Groups. 

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes



Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes

Add activities

Add button

<object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Delete activities

Delete button

<object>.Schedule.Name for 
the current Schedule tab 
object.

Requires Delete privileges for 
the deleted object and the 
deleted object's subordinate 
objects.

The user must have Modify 
privilege applied to 
Schedule.Name for the object 
where the Delete activities 
action (on the Schedule tab) is 
preformed. Also requires 
Delete privileges for the 
deleted objects and their 
children.

Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Note: Delete privileges for the 
current objects are not 
required.

Edit > Dependencies <object>. Dependencies 
Dependent Upon.Name for 
the object in Schedule tab row 
that is being edited.

Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Edit > Display Order <object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Edit > Reschedule <object>.General Info. 
Schedule Start Date

and

<object>.General Info. 
Schedule End Date

The user must have modify 
privilege masks that allow 
him to modify the Schedule 
Start Date and Schedule End 
Date of the object where the 
Reschedule action (on the 
Schedule tab) is performed.

Example - Modify All 
Programs, Phases, Tasks, and 
Gates.

Edit > Add Team <object>.Team.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Create Baseline <object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.

Remove Baseline <object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.
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Dependencies tab actions

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes

Add activities

Add button

<object>.Schedule.Name Example - Add Programs, 
Example - Add Phases, 
Example - Add Tasks.
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Team tab actions

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes

Add team members

Add button

<object>.Team.Name Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Modify privilege for attribute 
Team.Name enables the user 
only to add or to remove team 
members.

To edit the Team table, the 
user must have additional 
modify privileges for the 
specific Team table attributes; 
refer to the row below.

Edit team member

Edit button

<object>.Team.%_Allocation

<object>.Team.Actual_Hours

<object>.Team.Assigned From

<object>.Team.Roles

To edit the Team table, the 
user must also have a modify 
privilege mask with explicit 
Applied To properties for the 
specific Team table attributes 
that must be edited, for 
example, Actual Hours.

Content tab actions

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes

Set mandatory content Activities.Content.Mandatory To be able to make a Yes/No 
selection in the Content tab 
Mandatory column, the user 
must have a modify privilege 
mask with explicit Applied To 
properties for the Mandatory 
attribute.

About Privileges for Microsoft Project
The table above includes definitions of the Modify privilege masks necessary to grant 
users the ability to launch an Agile PPM activity in Microsoft Project and edit that 
activity, including editing its child activities and creating new child activities.

When activities are edited in Microsoft Project, Agile Create and Modify, privilege 
masks pertaining to the editing of the contents of specific fields cannot be checked 
within Microsoft Project applications. For example, a user may not be able to create a 
particular Agile PPM subclass when working in Agile PPM, but he may be able to 
create that subclass in Microsoft Project. In a similar manner, a user may not be able to 
edit the content of specific Agile PPM object attributes when working in Agile PPM, 
but he may be able to edit those fields in Microsoft Project.

Add or remove dependencies

Add button

Remove button

<object>. Dependencies 
Dependent Upon.Name

Example - Modify All 
Programs, Phases, Tasks and 
Gates.

Action or capability 
provided Applied To attribute

Example Privilege Mask / 
notes



Caution: To precisely limit the create and modify attribute privileges 
of some users, do not give those users the ability to edit in Microsoft 
Project. Microsoft Project edit capabilities are more appropriate for 
Agile PPM users requiring broad create and modify capabilities.
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When a user edits an Agile PPM project in Microsoft Project, he can perform many 
actions including deleting objects (activities or gates), changing the parent, changing 
dates or adding dependencies.

When the user uploads his changes to the Agile PPM server via an XML data file, 
Agile PLM checks to ensure that the user has the appropriate delete privilege masks 
for all activities and gates deleted. If the user does not have the appropriate delete 
privilege mask for an object that was deleted in Microsoft Project, none of the 
modifications made will be written to the Agile database. An error message informs 
the user that the action requires the necessary delete privileges.

Therefore, you can define mandated activities in Agile PPM, that is, activities that 
cannot be deleted from a project. This is enforced by configuring Delete privilege 
masks that do not allow users to delete mandated activities. See "Setting Up Restricted 
Delete Privileges" on page 10-14.

About Privileges in Gantt
Create privileges and Modify privileges, as well as Delete privileges (against subclass), 
are checked in Gantt. A user cannot create, modify, or delete any object data in Gantt 
without the necessary privileges. 

The privilege control behavior in Gantt is different than it is in Web Client. For 
example, to add a dependency in Web Client, only the modify privilege against 
Dependency.Name is required, however, in Gantt, a bundle of privileges are required.

The following table details the differences in modify privilege control between Web 
Client and Gantt client. 

Modify Privilege Control in Web Client Vs. Gantt Client

Scenario
Applied to attribute required 
in Web Client

Applied to attribute required in 
Gantt Client

Add Dependency <object>.Dependency.Name <object>.Dependency.Name

<object>.Dependency.Type

<object>.Dependency.Buffer

<object>.General Info.Schedule 
Start Date

<object>.General Info.Schedule 
End Date

<object>.General Info.Schedule 
Duration

Modify Dependency <object>.Dependency.Type

<object>.Dependency.Type

<object>.Dependency.Type

<object>.Dependency.Buffer<object
>.General Info.Schedule Start 
Date<object>.General 
Info.Schedule End 
Date<object>.General 
Info.Schedule Duration
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Setting Up Restricted Delete Privileges
The Agile-supplied Delete privileges masks are very broad, for example, Delete All 
Programs, Phases, and Gates enables the user to delete any object in the Projects base 
class, with no restriction. To create a restricted Delete privilege mask, create a reusable 
criterion that defines the objects the user will be allowed to delete, then use that 
criteria to create a Delete privilege mask. (For more information about reusable criteria 
and privilege masks, see the Agile PLM Administrator Guide).

When a user modifies a PPM project in the Gantt Chart or in Microsoft Project, the 
restricted Delete privilege masks are applied when the user updates or publishes back 
to Agile PPM.

Here are some examples of how you might set up and use restricted Delete privilege 
masks:

Update Assigned 
Calendar

<object>.General 
Info.Calendar

<object>.General Info.Calendar

<object>.General Info.Schedule 
Start Date

<object>.General Info.Schedule 
End Date<object>.General 
Info.Schedule Duration

Update Schedule Start 
Date

<object>.General Info.Schedule 
Start Date

<object>.General Info.Schedule 
Start Date

<object>.General Info.Schedule 
End Date

<object>.General Info.Schedule 
Duration

Update Schedule End 
Date

<object>.General Info.Schedule 
End Date

<object>.General Info.Schedule 
Start Date<object>.General 
Info.Schedule End 
Date<object>.General 
Info.Schedule Duration

Update Schedule 
Duration

<object>.General Info.Schedule 
Duration

<object>.General Info.Schedule 
Start Date<object>.General 
Info.Schedule End 
Date<object>.General 
Info.Schedule Duration

Update Actual Start Date <object>.General Info.Actual 
Start Date

<object>.General Info.Actual Start 
Date<object>.General Info.Actual 
End Date

Update Actual End Date <object>.General Info.Actual 
End Date

<object>.General Info.Actual Start 
Date<object>.General Info.Actual 
End Date

Update Estimated Start 
Date

<object>.General Info.Estimate 
Start Date

<object>.General Info.Estimate 
Start Date<object>.General 
Info.Estimate End Date

Update Estimated End 
Date

<object>.General Info.Estimate 
End Date

<object>.General Info.Estimate 
Start Date

<object>.General Info.Estimate End 
Date

Scenario
Applied to attribute required 
in Web Client

Applied to attribute required in 
Gantt Client
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■ Create a specific subclass for mandated activities that you will not allow to be 
deleted. You can then create reusable criteria that either exclude the mandated 
subclass, or include all subclasses except the mandated subclass.

■ Object Type: ActivitiesGeneral Info. Activities Type Not Equal to Mandated 
Task

Where Mandated Task is a subclass you created to use for tasks that cannot be 
deleted. 

The setting enables all other Activities subclasses to be deleted, but Mandated 
Tasks cannot be deleted.

■ Create individual criteria and individual Delete privilege masks for each subclass, 
but do not create or assign a Delete privilege mask for the Mandated Task 
subclass. For example, you might create Delete privilege masks using the reusable 
criteria:

Object Type: Programs

Object Type: Phase

Object Type: Task

(No Delete privilege mask created for Mandated Task.)

■ Define an object attribute that determines whether the task is mandated or not. 
The setting enables users to define mandated tasks on a case-by-case basis. This 
designation can be set up in a template and new projects copied from the template 
will carry over the value.

Once you have defined the attribute, you can create reusable criteria that evaluate the 
contents of that attribute. For example:

Page Two.List01 Not Equal to Mandated

Where Page Two.List01 is a list field that you have defined to set whether an activity is 
mandated or not.

Additionally:

■ You must define a list for the Page Two.List01 attribute, for example, list selections 
Mandated and Non-Mandated.

■ To limit who may edit the Page Two.List01 attribute, you must create and assign 
Modify privilege masks that allow and disallow the ability to change whether a 
task is mandated. Including Page Two.List01 in the Applied To property of a 
Modify privilege mask enables the user to change this attribute. Typically, you will 
allow very few users to change this attribute.

Caution If you plan to use restricted Delete privileges for Agile PPM, remove any 
broadly-defined Delete privilege masks from the Agile PPM roles.

Agile privilege masks are additive. If a user has a Delete privilege mask that restricts 
delete privileges for Mandated Task subclass objects, but he also has the Delete All 
Programs, Phases, and Gates privilege mask (which enables him to delete any object 
in the Programs base class), then the user will be able to delete Mandated Task 
subclass objects.

Settings Required for Menu Command: Actions > Change to Canceled
The Actions > Change to Canceled menu command enables users to cancel the 
displayed project object and automatically cancel all its children (change workflow 
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status to Canceled). In addition, users can also cancel leaf node objects by using the 
Change Status button.

Regardless of which method the user chooses, his ability to change the workflow 
status of a PPM object (including canceling a PPM object) is determined both by the 
workflow status property Valid Manual Next Status setting and by the user's assigned 
Change Status privilege masks.

The Agile-supplied default Change Status privilege masks for PPM objects provide the 
ability to change statuses from any status to any other status. If you use custom 
Change Status privilege masks for PPM objects, review them to verify that the end 
users will be able to perform a top-level cancellation.

Enabling Assign Action in User Groups
Resource Pool owners can assign pending assignments to resources across projects 
from the User Groups page in Agile Web Client. User groups that have resources with 
percentage allocation to any project appear in this tab. When you click a user group 
name a set of tabs display details of that user group. Under the Assignments tab, you 
can select a user and click Assign to assign a task. This Assign action button is made 
available based on a setting in the Agile Java Client.

To enable the Assign action button:

1. In the Java Client Admin tab, navigate to User Settings > Privileges.

2. Double-click Modify.

3. Search and locate the Modify User Groups privilege. Double-click the table row to 
view details.

4. Click the down arrow next to the Applied to field.

5. Move User groups.Assignments.Name from the Choices list to the Selected list 
and click Save. For details on the AppliedTo property, see the topic "AppliedTo 
Capability" in the Agile PLM Administrator Guide.

The User Groups > Assignments tab is not available for configuration in Java Client.

Configuring Stationary Gates
To allow selected users to define a Gate as a Stationary Gate, you must first create a 
specific privilege in Java Client Administrator. Then you can assign this privilege to a 
particular Role, and assign that role only to users who should be able to modify 
stationary gates.

To configure a privilege to modify stationary gates:

1. In the Java Client Admin tab, navigate to User Settings > Privileges.

2. Create a privilege. You can call it ModifyStationaryGates, for example.

3. In the Privilege Criteria field, choose All Gates.

4. In the Applied to field, click the down arrow to open the selection dialog.

5. Under Choices, select Gates.GeneralInfo.EnableStationaryGate. Click the right 
arrow to move it to the Selected list.

6. Click OK to save your changes.
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Notes on Setting Up SmartRules
The following section provides information you need to keep in mind while setting up 
SmartRules.

Automatic Installation from PPM SmartRule
Auto-Installs From PPM is a SmartRule that can be set to Allow, Disallow, or Warning. 
This SmartRule controls the automatic installation of Microsoft Project (2002 and 2003) 
DLLs into a user's system Registry. Installation of the DLLs enables seamless 
publishing using an Agile menu within Microsoft Project. Auto-Installs From PPM 
also controls the installation of Sun's JRE for the java-based Gantt Chart. The JRE is 
required to launch the Gantt Chart.

The default setting for Auto-Installs From PPM SmartRule is Allow. Set this to 
Disallow if your company does not want any applications to be automatically 
installed.

If end users do not have Administrator rights on their PCs, you should consider 
setting Auto-Installs From PPM to Disallow and have your IT organization load the 
DLLs or JRE.

If Auto-Installs From PPM is set to Allow and a user does not have Administrator 
rights on his PC, selecting the Gantt Chart or Microsoft Project buttons in Agile PPM 
will initiate the installation process but it will not successfully install. This will happen 
every time a user selects one of these buttons and will become a usability issue.

IT departments can do systemwide installations of the JRE or Microsoft Project DLLs, 
in which case, the functionality of the Microsoft Project integration and Gantt Chart 
will be fully supported regardless of the setting of this SmartRule. Auto-Installs From 
PPM SmartRule governs only the automatic installation of the JRE or Microsoft Project 
DLLs; it does not govern the launch of these applications.

Configuring Status Display
Status tracking for projects is achieved by the use of appropriate status indicator 
settings in Java Client. You can configure the display to show the types of statuses you 
want to monitor, using names, icons, colors, and other settings of your choice.

Status Nodes
The Status nodes provide visibility into whether a project's targets in the areas of 
Schedule, Cost, Quality, and Resources are currently being met (the 1 value), currently 
not being met (the 2 value), or are seriously off the target (the 3 value).

The Rollup Health Status attribute on the General Info tab of an activity object 
determines whether that activity object is included in the rollup. By default, statuses 
from leaf node activities (tasks with no children) roll up to higher levels in the project 
structure (Rollup Health Status = Yes). The user can determine which objects are 
excluded from the rollup by editing the Rollup Health Status attribute on the General 
Info tab to No. The setting enables the user to include or exclude a selected activity in 
the rollup.

Changing the Status Names the User Sees
In Agile PPM Web Client, the health statuses are attributes on the General Info tab. 
They are also reported in the health status indicators in the upper right of the activity 
window. By default, these are named: Overall Status, Schedule Status, Cost Status, 
Resource Status, and Quality Status.
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To change the labels or names that appear in Agile PLM Web Client, modify the names 
of the health status attributes on the General Info tab of Activities or Gates class.

For example, to change the name of the Activities object's Cost Status attribute to 
Accounting Status, change its name on the Classes node. The new name, Accounting 
Status, appears on the Activities object's General Info tab; it also appears in the health 
status indicators in the upper right of the activity window.

Modifying Status Node Settings
When you open one of the Status nodes (Schedule, Cost, Quality, or Resource), the 
appropriate Status window appears. The properties on the main table are Order (1, 2, 
or 3), Name, Description, and Enabled. The buttons are Create and Delete.

When you double-click anywhere in the row of a status table, the object opens to the 
General Information tab. You can edit the fields in this window as necessary.

Quality and Resource status are not programmatically set by Agile PPM. These fields 
can be renamed and used for other status purposes, such as Risk. These are subjective 
ratings. Cost and Schedule status are always calculated according to the thresholds set. 
It is not possible to turn off this automatic calculation.

Schedule Status
The Schedule Status window reports the status of the project regarding schedule.

The Overdue Value can be either a positive number or a negative number.

The Overdue Value can be either days or a percentage of the duration.

To set the Overdue Type (Days or Percentage):

1. In Agile Administrator, open the Schedule Status node under Settings | System 
Settings | Product Portfolio Management.

The Schedule Status window opens with the General tab displayed on top.

2. On the General tab, in the Overdue Type drop-down list, select either Days or 
Percentage.

3. When you are finished, click Save.

To modify the Schedule Status values:

1. In Agile Administrator, open the Schedule Status node under Settings | System 
Settings | Product Portfolio Management.

The Schedule Status window opens with the General tab displayed.

2. Click the Status tab to display the schedule statuses.

3. Double-click the status row you want to modify. The schedule status window is 
displayed.

4. Make the desired modifications.

It is important that you follow the guidelines explained in the section "Schedule 
Status Guidelines" in the Agile PLM Administrator Guide.

5. When you are finished, click Save.

Schedule Status Guidelines  The following table shows the default Schedule Status 
settings (Overdue Type = Days).



Order Name Description Overdue Value Icon

1 On Track On Track 0 Green

2 Needs Attention Needs Attention 1 Yellow

3 Off Track Off Track 5 Red
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In order for the schedule status to evaluate correctly, follow these rules when setting 
the Overdue Value attributes:

■ All three states (On Track, Needs Attention, and Off Track) must have a value for 
Day_Overdue. A blank value is not valid, however, zero (0) is a valid value.

■ The Overdue Value values must be ascending values that follow the order. That is, 
On Track (1) must have the lowest value, Needs Attention (2) must have a higher 
value than On Track, and Off Track (3) must have a higher value than Needs 
Attention.

■ The above rules apply for both Overdue Type = Days and Overdue Type = 
Percentage.

■ The following tables show some examples of valid Overdue Value settings:

Overdue Value settings, Days:

Order Name
Overdue Value 
Days

Overdue Value 
Days

Overdue Value 
Days

Overdue 
Value Days

1 On Track -10 -5 0 5

2 Needs 
Attention

-5 0 5 10

3 Off Track 0 5 10 15

Overdue Value settings, %

Order Name
Overdue Value 
%

Overdue Value 
%

Overdue Value 
%

1 On Track -150 -150 0

2 Needs Attention -100 0 50

3 Off Track 0 75 100

How Schedule Status is Determined  If the activity's workflow status is Not Started, 
Schedule Status is determined by comparing the current date against the calculation of 
the Scheduled Start Date and the Overdue Value.

If the activity's workflow status is In Process, Schedule Status is determined by 
comparing the current date against the calculation of the Scheduled End Date and the 
Overdue Value. The following examples illustrate how Needs Attention and Off Track 
statuses are determined:



Overdue 
Value 
Days

Overdue Value 
% of Duration Task Duration Calculation

Schedule Status 
changes when the 
current date is...

5 10 Scheduled End 
Date + 5

5 days after the 
scheduled end 
date

<specify date>

-5 10 Scheduled End 
Date - 5

5 days before the 
scheduled end 
date

<specify date>

0 10 Scheduled End 
Date

On the scheduled 
end date

<specify date>

5 2 Scheduled End 
Date + 5

5 days after the 
scheduled end 
date

<specify date>

-5 2 Scheduled End 
Date - 5

5 days before the 
scheduled end 
date (not 
dependent on 
duration)

<specify date>

-150 10 -150% * 10 = -15 
days

15 days before 
the scheduled 
end date

<specify date>

-100 10 -100% * 10 = -10 
days

10 days before 
the scheduled 
end date

<specify date>

-50 10 -50% * 10 = -5 
days

5 days before the 
scheduled end 
date

<specify date>

0 10 0% * 10 = 0 days On the scheduled 
end date

<specify date>

50 10 50% * 10 = 5 days 5 days after the 
scheduled end 
date

<specify date>

100 10 100% * 10 = 10 
days

10 days after the 
scheduled end 
date

<specify date>

150 10 150% * 10 = 15 
days

15 days after the 
scheduled end 
date

<specify date>
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Cost Status
The Cost Status window reports the status of the project regarding cost and budget. 
Total Cost is the sum of the four cost types: Labor Cost, Capital Expenses, Fixed Cost 
and Flex Cost. The Cost Status color indicator is based on comparing Total Budgeted 
Cost to the sum of Total Actual Cost and Total Estimated to Completion and 
determining the percentage over Total Budgeted Cost.

The Percentage value cannot be a negative number.

Order Name Description Percentage Icon

1 On Budget On Budget 0 Green

2 Off Budget Off Budget 5 Yellow
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Quality Status
The Quality Status window reports the status of the project regarding issues of 
quality.

Order Name Description Icon

1 Meets Quality Meets Quality Green

2 Below Quality Below Quality Yellow

3 Poor Quality Poor Quality Red

Resource Status
The Resource Status window reports the status of the team, or users with similar skill 
sets. Resource status enables you to evaluate the assignment of resources to programs 
and to help manage employees' workloads.

Order Name Description Icon

1 Staffed Staffed Green

2 Under Staffed Under Staffed Yellow

3 Not Staffed Not Staffed Red

Configuring Calendar Display
You can configure the legend names that appear in calendars. To do this, in the Java 
Client Admin tab, edit the legend names and descriptions in the Calendar Legend 
Settings List. Names can be customized, but colors cannot. These settings apply to the 
Default Calendar only.

Note: You cannot define exception settings within the Default 
Calendar. The Default Calendar cannot be disabled.

Configuring UI Data Display
In Web Client, you can click the Quick View tool tip that appears when you place your 
mouse cursor over an object to see details of that object. The task editing dialog that 
opens enables the user to view and edit subclass details. As an administrator, you can 
define the primary fields that task owners are required to edit and design how these 
fields should display. Task owners can then edit task details without having to 
navigate to the task details.

To configure the display, you must first define and select each component that you 
want to display in the dialog, such as attribute groups, tables and action menus. Think 
of attribute groups, tables, and actions as the building blocks of the task editing dialog. 
These can be combined in different ways to form different layouts. You can select the 
components, and assemble them into specific layouts. One layout can be associated to 
one subclass only.

The configuration for this is done in the UI Configuration Data node of the Java Client 
Admin tab.

3 Over Budget Over Budget 10 Red

Order Name Description Percentage Icon
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UI Configuration Data
To configure a Quick View dialog:

1. Navigate to System Settings > Product Portfolio Management.

2. Click UI Configuration Data. The UI Configuration window opens.

3. Configure the following:

■ Attribute Groups

■ Configure Tables

■ Configure Action Groups

4. Assign a layout.

To configure an attribute group:

1. Click Attribute Groups.

2. Provide a name for the group. For example, "Cost" or "Schedule".

3. From the Available Attributes list, select the attributes that you want to display. 
You can use the drop-down list to filter the attributes by subclass. Ensure that the 
Name field is in one of the attribute groups to ensure that it is in the header.

4. Use the forward arrow button to move the selected attributes to the Selected 
Attributes area. You can reorder the selected attributes using the arrow buttons.

5. Click Add to add the selected attributes to the dialog.

To configure tables:

1. Click Tables.

2. Choose a table and provide a display name for it. For example, "Relationships".

3. From the Available Columns list, select the columns that you want to display.

4. Use the forward arrow button to move the selected columns to the Selected 
Columns area. You can reorder the selected columns using the arrow buttons.

5. Click Add to add the selected columns to the dialog.

To configure Action Groups:

1. Click Action Groups.

2. Provide a name for the group. For example, "Task Actions".

3. From the Available Actions list, select the actions that you want to display for 
workflow sign-off. For example, Approve, Reject, and Mark Complete.

■ To add a process extension to an action, click New. In the dialog that opens, 
specify the Action Name and then select a process extension to apply.

■ To change the name of a selected action, click Edit and enter a new name for 
the action in the dialog that opens.

■ To delete a selected action name, click Delete. You can only delete action 
names that you created.

4. Use the forward arrow button to move the selected actions to the Selected Actions 
area. You can reorder the selected actions using the arrow buttons.

5. Click Add to add the selected actions to the dialog.

To assign a layout:
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1. Click Layout.

2. In the Define Layout For field, choose the object for which you want to assign a 
layout. For example, Program.

3. Select the desired attribute group, table and action group.

4. Use the forward arrow button to move your selections to the Form area. You can 
reorder the components using the arrow buttons.

5. Click Add to assign the layout for the specified object.

You can verify the results of your configuration actions in the Project Summary page.

Administration in Agile Web Client
A limited amount of configuration can be performed for PPM in Agile Web Client, 
primarily related to object display.

Configuring Project Summary Display
You can configure the layout and widgets of the Summary page if you have the 
Administrator privilege with "PPM Summary Page Configuration" as an AppliedTo 
value. This configuration applies to all Activities across the Agile PLM system.

To configure the Project Summary widget:

1. On the Summary page, click Configure.

2. To avoid displaying this widget in the Summary page, deselect the check box next 
to the widget name.

3. To configure the data that appears in the widget, click the Edit link that appears at 
the top right corner.

■ For Project Summary and Project Gates widgets, you need to manually 
configure the fields that are displayed. Select the fields you want from the 
Hidden Fields column on the left and move them to the Displayed Fields 
column on the right. You can reorder the displayed fields using the up and 
down arrows.

■ For all other widgets, you can only edit the widget name.

4. After you make changes to a widget, click Apply for the changes to take effect.

5. Click Save to save your settings, or click Cancel to revert to the default settings. 
Saved settings are immediately reflected on the Project Summary page.

Personalizing the Project Summary Page
You can personalize the Project Summary page to display chosen widgets only, in the 
order in which you want to see them.

The Summary page offers a two-column view - one wide and one narrow. Each 
column contains a set of configurable widgets.

To personalize summary page widgets:

1. On the Project Summary page, click Personalize. Two sets of configurable widgets 
are displayed.

2. To avoid displaying a widget in the Summary page, deselect the check box next to 
the widget name.
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3. To change the order in which the widgets display, drag each one up or down to the 
desired location.

4. After you make changes, click Save for the changes to take effect.

Configuring Timesheet Display
The Timesheet feature enables you to view records of actual time reported against all 
In Process projects in the system. Project managers with appropriate privileges can 
view time transactions reported against a project or group of projects, to conduct 
audits across projects, business units, or other criteria.

The Timesheet tab is visible only if your user settings are configured appropriately.

To display the Timesheet tab:

1. Click My Settings on the left panel.

2. In the Preferences tab, click Edit to make the fields editable.

3. Under Display Preferences, change the Show Timesheet option to Yes.

The Timesheet tab is displayed next to My Assignments.

When you change preference settings, you must log out and then log in again for the 
changes to become effective.

Configuring Calendars
As an administrator with the Calendar Administration privilege, you can create, 
update, import and export calendars.

Creating a Calendar
You can adapt an existing calendar to create a new calendar.

To create a calendar:

1. In the Tools and Settings menu, choose Calendar. The Calendar dialog opens. 

2. Click Create. 

3. In the Create From Calendar dialog, choose an existing calendar to adapt. If this is 
the first calendar being created, select Default Calendar.

4. Click Apply. 

5. In the Calendar Configuration dialog, enter calendar details. 

6. Provide a name and description for the new calendar. 

7. The Enabled field is set to Yes by default. The calendar will be available for use 
when you finish creating it. If you do not want to make this calendar available 
now, set this to No. You can enable it later when required. 

Note: If this field is set to No, the calendar will not be available for 
selection as a Preferred Calendar in the General Info tab of activities or 
users and user groups.

8. Under Work Week Setting, select the days of the week that are to be considered as 
working days.

Legend Settings can be edited in the Default Calendar only. 
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9. In the Calendar Settings tab, set exceptions to the regular working or non- 
working days. The color codes at the bottom of the dialog identify working, 
non-working, and exception days. Click on a date to bring up the Exception 
Settings dialog and mark exceptions to working or non-working days. 

10. Click Save. Your changes are visible on the calendar. 

11. To notify owners of related programs about the calendar changes you have made, 
click Notify.

Importing and Exporting Calendars
You can import or export a calendar in Web Client if you have the Calendar 
Administration privilege.

Calendars can be exported as AGL files only. All calendar settings including exception 
settings are exported.

To export a calendar:
1. In the Tools & Settings menu, choose Calendar. 

2. In the Calendar dialog, select the row of the calendar you want to export. You can 
select multiple rows to export several calendars at the same time.

3. Click Export. 

4. Save to a location of your choice.

To import a calendar:
1. In the Tools & Settings menu, choose Calendar. 

2. In the Calendar dialog, select the calendar you want to import.

3. Browse and select the AGL file to import.

4. Click Validate. If there is an existing calendar of the same name, a warning 
message appears. To overwrite the existing calendar, select the Accept check box 
and click Import. If you want to retain the existing calendar, you must rename it 
before importing the new calendar. 

5. To import more calendars, click Import Another File, and repeat the process.

Updating Calendars
When you update an existing calendar using the administration options in the Web 
Client, there can be a schedule impact on all programs and activities that use that 
calendar. Use the Where Used tab in the Calendar dialog to review all activities 
associated with the calendar and determine the impact of the update. (You can use the 
filter to narrow down search results. If the number of results exceeds 1000 rows, you 
can use the Export button and export the list to XLS format for detailed analysis.)

After you make the update, click Notify to send a notification to owners of affected 
activities so that they can take necessary action to maintain schedule accuracy. See also 
"Accepting Calendar Changes" on page 4-23.

Deleting Calendars
You can only delete calendars that are not in use. To delete a calendar, you must have 
the Delete attribute included as an AppliedTo attribute on your Calendar 
Administration privilege.

To delete a calendar:
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1. In the Tools and Settings menu, choose Calendar. The Calendar dialog opens. 

2. Select the row of the calendar you want to delete. You can select multiple rows to 
delete several calendars at the same time.

3. Click Remove. 

Note: The Default Calendar cannot be deleted.

Setting Preferred Calendar
You can specify preferred calendars for users or user groups in the General Info tab 
under My Settings. Edit the Preferred Calendar attribute to indicate your choice. This 
calendar setting is automatically applied during project creation. 

A calendar that has been disabled does not appear for selection as a preferred 
calendar.

Configuring Microsoft Project Integration
Integration with Microsoft Project 2010 is supported. For successful synchronization of 
data between MicroSoft Project and PPM, the MSPSyncMapping.properties file must be 
configured with the appropriate values. This file is available in the Agile PLM 
installation directory (under 

..\agileDomain\applications\application.ear\APP-INF\classes) along with the 
agile.properties file.

Follow the instructions within the file to map attributes in the recommended format.

See "Automatic Installation from PPM SmartRule" on page 10-17 for more information 
about automatic installation of the appropriate DLLs.

See also:

■ "Modify Privilege Mask Applied To Properties that Control Specific User Actions" 
on page 10-9 for information about modify privilege mask properties that control 
access to Microsoft Project integration features.

■ "Transferring Microsoft Project Work Values to Agile PPM as Days Effort" on 
page 10-27.

■ "Using Custom Agile PPM Subclasses in Microsoft Project" on page 10-26.

Using Custom Agile PPM Subclasses in Microsoft Project
If you have defined custom Agile PPM subclasses, users can specify those subclasses 
in Microsoft by using Microsoft Project column Text29.

To enable the use of custom Agile PPM subclasses in Microsoft Project:

1. In Microsoft Project, right-click the column headers.

2. Select Insert Column.

3. Select Text29 for the field name. The default Agile PPM subclass names are 
displayed.

4. As you create new tasks and enter them, you can type in this field the name of any 
custom Agile PPM activity subclass. If you leave the field blank, the Agile PPM 
default subclasses are used.
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The subclass name you enter must be spelled correctly; if the name is not spelled 
correctly, the out-of-box default subclass names will be displayed.

Transferring Microsoft Project Work Values to Agile PPM as Days Effort
In Agile, days effort is always calculated based on the % allocation and duration. Agile 
requires an allocation to a resource or resource pool in order for days effort to be 
populated.

To handle the publishing of tasks from Microsoft Project, where work values are 
entered, you can set up a global resource pool to hold the work/days effort values. If 
you set up a global resource pool, users will notice that tasks which satisfy these 
conditions have a global resource pool associated to them on the Team tab.

To set up the global resource pool:

1. Enter the resource pool name in the MSPSyncMapping.properties file.

2. Restart the server.

3. Create the resource pool ensuring that:

■ You use the name you entered in the MSPSyncMapping.properties file.

■ The resource pool is a Global resource pool.

The resource pool must be created as Global to enable the mapping.

Important: If either of the following is true, the system ignores the 
mapping and discards the work values:

The resource pool name is configured in the properties file, but the 
resource pool does not exist (not created).

The resource pool name is configured in the properties file and the 
resource pool has been created, but it does not meet the criteria; it is 
not a Global resource pool.
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ABest Practices

This chapter describes the best practices that you can follow to derive the most value 
out of PPM to meet your business needs.

Best Practices for General Project Management
This section provides recommendations on:

■ Process Definition and Acceptance

■ Implementation Realities and Requirements

Process Definition and Acceptance
Any enterprise project execution and management implementation requires a defined 
process or processes, and general acceptance or mandates that these processes will be 
followed. No automation or system can work if the stakeholders and solution 
constituents are not participating. The process or processes do not need to be fully 
developed, but they must be accepted and followed. As the system is used, processes 
will show their weaknesses and standard process improvement logic will apply.

The following are key areas for consideration before you turn on the computer:

■ Define the process and process steps that need to be managed. Start from the key 
milestones and gates, and work backward to the tasks that need to be 
accomplished, and the deliverables that need to be met.

■ Get general consensus from key stakeholders to ensure process adoption and 
compliance; or appoint an executive sponsor who will mandate that the process is 
followed.

■ Determine how many project types (templates) you need. It is probably more than 
one and less than 100. Start simple and grow into complexity.

■ Decide the categories in which you classify your projects and programs: Business 
unit, geography, demographics, customers, markets, and so on. These are critical 
to the ways in which PPM will build and control access to dashboard portfolios. 
Some categories will be used as security filters, and some as convenience filters.

Implementation Realities and Requirements
■ Take the schedule agreed to in the preparation stage and determine the initial 

depth of tracking required to manage your first pass. It is recommended that you 
start at a maximum of 4 levels of task indentation, which gives you the phase 
level, summary task level, and detail task level. For many organizations, this is 
deep enough with granulation covering the major items to be tracked. Later on, 
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when the process has been refined, there may be value in going into deeper layers, 
into a deep Work Breakdown structure.

■ Decide how deep your initial implementation needs are to track resources. It is 
advisable that you run the system with minimum expectations for resource 
management until you are confident of the process schedule, timing and sequence. 
Detailed resource planning against unreliable and erroneous schedules and 
durations can be frustrating and lead to distrust of the system. With the power of 
the template, it is not difficult to assign resource requirements to tasks in the 
system, but if the tasks are not correctly aligned in the schedule or in their 
duration, the resulting resource utilization calculations will also be out of 
alignment.

■ Understand the limits of coexistence with other project tracking systems. PPM 
adds value as a real-time enterprise project management solution. As such, 
changes made to projects and resources are made in real-time, providing 
up-to-the-minute task requirements, project health and status, and resource 
requirements. Projects that are managed in other systems and then uploaded 
create a set of reports and assignments that are only as accurate as the last 
uploads.

Best Practices for PPM Setup
Guidelines for general administrative setup and project-specific setup are detailed in 
this section.

Administrative Setup
Security

Agile PPM uses the PLM security model, and treats all users in an Agile PLM 
implementation as potential project participants. All default roles in PPM have default 
configurations but can be enhanced or reduced to meet internal security requirements. 
See the security section of the Agile PLM Administrator Guide for more details. 
Guidelines on the use of PPM roles and privileges:

■ Project Manager - Use as delivered. The Project Manager has access to all PPM 
objects that he or she owns or is authorized to access. Understand that a project 
manager is given access to object types; project owners are given access to specific 
projects. These two concepts work together.

■ Project Administrator - Use as delivered. The Project Administrator has specific 
privileges that allow access to projects that he or she does not own. He Or She can 
also cancel or delete projects, put projects on hold, or delete mandatory 
deliverables.

■ Executive Privilege - This privilege, used with the PPM dashboard and project 
categories, provides a single dashboard UI that builds a portfolio based on the 
user's executive privilege to access certain of those categories. Thus a General 
Manager of Business Unit 1 will see all projects for his/her business unit, while the 
General Manager of Business Unit 2 will see all projects for his/her business unit. 
Others may be authorized by markets, product lines, and so on.



Note: Agile Users - All Agile PLM users are potential participants as 
owners and resources of a project phase or task. When added to a 
project or added from a template, the participant is given an internal 
project role. Thus a development manager can be added to a project as 
the "project manager" of his or her group of tasks. This does not 
override the Project Owner's rights and access to all project activities.
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Resource Pools

In Agile PPM resources can be assigned to projects and templates as resource pools. 
These are user groups, identified as resource pools, that act as containers for groups of 
Agile users that have been identified as potential project participants.

Consider the following:

■ Pool Segmentation

Divide your pools with as much granularity as required to manage conflicts.

Set up pools to match departmental realities. Effective use of resource pools 
requires a resource pool manager that can respond to requests, overloads and 
employee issues.

■ Pool Attributes: Pools carry with them similar attributes as an Agile user. Key to 
the PPM implementation is the need to put a standard cost per hour in monetary 
value to the pool labor force. This is used at project creation time to calculate a 
standard cost labor budget.

■ Empty Pools: This is useful when you need to generate requirements and budgets 
for resources that may not have Agile access: contractors, partners, and so on.

■ Individual users - Any individual added to a project is a resource. Most, if not all, 
should be assigned from a resource pool. Ideally, no resource should be assigned 
to more than one pool.

■ The system uses the monetary values assigned in the user ID for standard resource 
costing when calculating labor budgets or actuals.

■ The executive privilege looks at the user profile and the categories assigned to that 
profile to allow viewing of projects that are not owned by that user.

Distributed Task Management (DTM)

DTM provides project participants with accurate real-time assignments and resource 
requirements, and direct access to the project without project navigation.

The following setup items should be considered to take full advantage of DTM:

■ "My Assignments" Configuration - This ensures that all project task owners and 
resources have a single place to go to get their up-to-the-minute task assignments 
and priorities. This UI is designed to provide dynamic and actionable access to all 
tasks that are assigned to a user without the need to "navigate" to the project. 
These tables, and the actions to be allowed, are configured in the administration 
setup.

■ "Quick View" Creation - Quick views allow users across PLM to review key 
details about an object and its data, directly from a list, without navigating to that 
object. Quick views are accessible from the "My Assignments" UI. PPM is the only 
module that has actionable and editable "Quick Views". (For information on how 
to set up "quick Views" see the Agile PLM Administrator Guide.) Every sub-class can 
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have a different quick view, with different access levels. Thus the Quick View for 
DG1 (Decision Gate, Phase One) can have different editable fields and actions.

Dashboard Categories

Using the segmentation needed for project filtering and security determined in the 
preparation stage, create the categories and category values required for your 
implementation. This is critical to the dashboard, analytics, reporting and security. 
None of the default categories are fixed. They can all be renamed and re-sequenced for 
selection.

Calendars

If you need to quickly add new exceptions or update existing exceptions within a 
calendar, directly edit the calendar AGL file. To do this, export the calendar from the 
Calendar Administration dialog in Web Client, and save the AGL file to your local 
drive. Unzip the file and edit the entries using a text editing tool such as Notepad.

■ To add additional exceptions, copy and paste an existing exception entry to create 
as many entries as you need. (Example entry: <EXCEPTION ID="2471926" 
DAYOFWEEK="2" DATE="2014-06-16" REASONFORCHANGE="Company 
Holiday" />) Modify the DATE and REASONFORCHANGE values in each entry.

■ To update existing exceptions, modify only the REASONFORCHANGE values. 
When you modify the DATE value, it is recognized as a new entry. 

Save your changes and import the file back into Agile PLM. The changes are reflected 
in the calendar in Web Client.

Timesheets

If you need to track hours spent against hours budgeted, with or without costs, you 
must enable timesheets in the setup.

Activity Sub-Classes (Types) and flex fields

The following sub-classes are delivered as defaults with PPM. They can mostly be 
used as delivered. Any sub-class that is not being used should be disabled to remove 
them from prompts and lists.

■ Project - Self explanatory. A project is defined in PPM as an activity without a 
parent. The object type does not necessarily define its behavior.

■ Phase - Used in phase gate management. Though decision gates are segmented for 
the phase in which they participate (DG1-DG6) it is not often necessary to have 
corresponding phase segmentation. However, if there is a need to have a similar 
phase segmentation, use new sub-classes such as "PH1", "PH2".

■ Task - Generally use as delivered. In some environments, another task type such 
as "Meeting" (with agendas and attendee lists) can be set up using a new sub-class.

■ Program - Use as delivered. Seen by Oracle PLA with a specific context when used 
with the PLM Reference Field on the Project Object.

■ Portfolio- Use as delivered. Seen by Oracle PLA with a specific context when used 
with the PLM Reference Field on the Project Object.

Milestone and Gate Sub-Classes (Types) and flex-fields

Gates are defined as any entry on a project timeline that does not have duration. Many 
project methodologies do not use the concept of a gate, though they do support "tasks" 
with a zero or single day duration or they support a milestone. Agile PPM uniquely 
supports gates of multiple types to support both phase-gate and standard project 
management environments.
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The following gate types exemplify the best practice definition of gates for project 
management:

■ Decision Gates

Phase gate methodology divides a project into distinct sets of tasks called a phase. 
Each phase is bounded at the end by a decision gate. In phase-gate processes a 
specific phase (P1) is bounded by a matching decision gate (DG1). In 
"Stage-Gate™" processes a specific phase is (P1) is bounded at the end by the next 
decision gate, (DG2).

Decision Gates are most often used for Phase-Gate or Stage-Gate™ processes and 
management. However they are not restricted to these environments. Decision 
gates, as implied by the name, are points in time in the project timeline that require 
a major decision. In the context of Phase-Gate, this is often referred to as a 
"go/no-go" or "kill" decision, essentially asking the question: "Should this project 
continue to be funded?" In phase-gate, the gates are connected as the end of a 
phase so Phase One is bounded at the end by Decision Gate.

Decision Gates should be set up as sub-classes for cross project reporting.

Agile is shipped with several pre-defined sub-classes that are designed to be used 
as decision gates: DG1, DG2, DG3, DG4, DG5, and DG6. If your organization has a 
nomenclature already established for gates, you can rename these defaults to 
reflect your terminology.

Each gate sub-class can have gate specific data fields by enabling Page Three 
flex-fields. DG1 will have a different Page Three from all other gates.

Decision gate workflows should be configured to reflect the specific gate type.

■ Review (Checkpoint) Gates

Review or check-point gates are points in time on the project timeline that set a 
border for a group of tasks within a phase. Typically, they are used as a checklist to 
validate that a set of deliverables or tasks have been completed as required. These 
gates are not typically routed for approval, but reviewed for completeness.

The default checkpoint gate sub-class in Agile is the "Review Gate". If your process 
requires additional stratification of review types it is recommended that you add 
additional sub-classes as required. Examples would be: CP1, CP2 or RV1, RV2.

Workflows are not typically used for review gates.

■ Milestones

Milestones are also a type of gate. In many different project methodologies the 
milestone is the only gate type. In phase-gate methodologies, milestones are 
typically used to mark significant points in the project that can trigger other 
activities.

The default milestone gate in Agile is the "Milestone" sub-class.

Typically milestones are not sub-classed. However, if your process has milestones 
that are important to you as a metric or that are needed to measure progress across 
the portfolio, it is recommended that you add sub-classes to meet that need. 
Examples would be MM1, MM2, or MS1, MS2.

Workflows are not typically used for milestones. However, using scripting and 
events, you could trigger a notification to mark the passing of a milestone. For 
example, when a customer project reaches a milestone, a notification is sent to 
accounting to bill the customer for work completed.
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Templates and Project Setup
Templates are an integral part of the best practice use of PPM. Templates are used at a 
minimum to establish the corporate baseline for a particular project type, such as NPD 
versus NPI. In more sophisticated environments, templates are defined by business 
unit or product line, or both, to set a standard process at the appropriate accountability 
level. Templates are also an integral part of using PPM in a project context that uses 
Phase-Gate methodologies. With templates, you can create a deep and broad schedule 
process that must be only set up once, and then used to generate thousands of 
activities over time. With templates, you can set up complex gate and deliverable 
controls, mandatory deliverables, deep accountability and team structures, and 
guarantee compliance with internal and external process control or regulatory 
agencies. (ISO, FDA, and so on.)

This section provides some practices to consider when setting up templates (or 
projects).

Schedules

Consider the following when setting up a schedule in a template (or project):

■ Depth of Schedule: Set as deep as your accountability levels and your ability to 
absorb. This will change over time as the system becomes more pervasive and 
schedules more accurate.

■ Avoid "checklists" converted to tasks: This is a common problem that creates 2000 
task projects. If you need to track 2000 tasks, then do so, but do not convert 
checklists to task lists. Checklists are best left as documents, attached to tasks.

■ Use gates to set boundaries: Even if you do not follow a Phase Gate process, 
milestones and checkpoints are powerful tools to set boundaries of activities, 
establish formal reviews, and mark significant progress that is visible to all.

■ Set up all necessary dependencies to ensure schedule integrity of any projects 
created from that template. Setting up project dependencies is a daunting task. To 
ensure the consistent durations required to manage task sequence generally 
requires a complex matrix of dependencies. When you set them up in the 
template, 80-90% of all dependencies required for the projects generated from that 
template can be pre-defined and automatically created.

Ownership

■ Ownership at the phase, summary task, task, or gate level is set in the template 
using resource pools. Owners, by default, are not given a percentage of activity 
and as such are not considered part of the resource load. If the owner is active in 
the activity and the owner of it, set the allocation to a number >0 that represents 
their contribution. Then, when projects are generated from a template, resource 
pool requests for task owners are generated, and if the owner allocation is >0, a 
resource load is also generated. Agile PPM enables you to set ownership at the 
deepest level, without giving up the master control of the project/program 
manager.

Resources

Resources for phase, summary task, task, and gate levels are set at each level in the 
template using resource pools. For each resource required, enter the pool which 
represents the resource, and set an allocation that represents their required 
contribution. When projects are generated from a template, the project team and labor 
cost budget are automatically created; resource loads are set at the proposed or active 
level; resource requests are sent to the resource pools. Always set resource 
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requirements at the task level that you can or must absorb. Avoid duplicating the 
resources at multiple levels. Typically this is at a minimum at the summary task level.

Content /Deliverables

Agile PPM is unique in allowing users to build all standard project deliverables in the 
template, and have the template automate deliverable creation and controls. All 
standard deliverables should be set in the template.

■ Digital File Content: File attachments such as documents, spreadsheets, and 
presentations can be set into the template as content or deliverables. The template 
can be set to recognize the content as static pulls from the vault, or copies of a 
boilerplate. Here are some examples:

Static Pull - You can establish a link in the template to an ISO process document, 
version controlled in Agile PLM, which triggers the template to copy the latest version 
of the ISO document to every project created from that template.

Boilerplates - You can attach a project deliverable boilerplate (that is, standard product 
requirements document) to a task or phase in a template and the template will create a 
blank copy of that boilerplate for every new project.

■ Agile PLM Items: PLM documents and parts/BOMs can be set as deliverables. 
For example, you can set-up a mandated project document, such as a Regulatory 
Requirements Document (RRD), as an item document sub-class in PLM. Create an 
RRD template object from that sub-class, attach a digital document boilerplate to 
that RRD and then attach the RRD document template to the project template. 
Every time the template creates a project, it creates a new RRD (RRD-2010, 
RRD-2011, and so on) with the digital file boilerplate, as content in the task that 
controls its due dates.

■ Agile PLM Processes: PLM process templates can also be set as deliverables in the 
template, and the template will create a copy of that process every time the 
template creates a project. For example, create a Part Number Request (PNR) 
process template, attach it to a task in the project template and every time the 
template creates a project, it creates a new PLM PNR in the content tab of that task.

■ PLM PPM Objects: Agile PPM activities and Gates can also be created in the 
template. You can set up a phase with 3 review gates, and a decision gate. Then, in 
the template, you can add the 3 review gates as content to the decision gate, and 
set up a relationship that will not allow the decision gate to go into review, unless 
all 3 review gates were open (approved).

Content Tab and Rules

Agile PPM is designed to control all deliverables and files from the tab on the UI called 
the "Content" tab. It is highly recommended as a best practice to disable the 
Attachments tab on all project classes (activities, gates) and place all project content 
including standard digital files into Content. This provides the highest level of 
visibility, control, and flexibility when working with deliverables.Approval 
Workflows

All gates and milestones in Agile PPM have a standard 3 step workflow, which can be 
enforced, and automated. As stated above, using PPM best practices, a template can 
establish for every NPD project that DG1 depends upon deliverables such as the three 
review gates being open, the PNR reaching release status, and a requirements 
document reaching review status. You can set up the rule to state at the moment the 
last deliverable rule is met DG1 will be set in "review" status on the gate workflow. 
This immediately notifies all approvers and observers of the gate process. Workflows 
for gate approval are essential is successfully implementing complex Phase-Gate 
procedures.
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Best Practices for PPM Process Execution
This section covers recommendations on general project execution and phase-gate 
project execution.

General Project Execution
Consider the following process execution recommendations before implementing 
PPM.

Using the PLM Reference Field

This field can be found on the General Info Tab of any project. The PLM Reference 
field is the primary way to associate a project with a specific PLM object in the project 
context. The PLM Reference field is pervasive across the entire project structure. Items 
entered here will be visible (based on security) to all other levels of the project. It is 
primarily used to identify the product or products to be developed within the project. 
You can also use it to associate the project with other projects, programs, or portfolios. 
Multiple objects can be entered here. With the additional implementation of Oracle 
PLA for PPM, you can use it to associate projects with a portfolio or program, or both. 
When used with Oracle PLA, the following concepts should be understood. 

■ Any portfolio or program object placed in the PLM reference field will link that 
project to those objects in Oracle PLA.

■ The first Item object encountered on that will be used by Oracle PLA as the 
product to be associated with this project for reporting and filtering.

Using Project Keywords

This field can be found on the General Info Tab of any project. Use this field to 
free-associate the project with concepts and categories (keywords) for searching and 
filtering.

Using the UI Navigator

The Navigator is especially useful for PPM users. Any project that is displayed can be 
"pushed" to the Navigator and used to navigate to other parts of the project, drag and 
drop deliverables, and maintain one project view while navigating to another.

Creating and Releasing Projects

PPM was designed to provide a multi-step process from creation of a project, 
publishing the project, and executing the project. The steps to follow, and their 
implications are as follows:

■ Create project from template in "Proposed" state. This sets up a project with all 
template constructs, resource requirements, and deliverables. However in the 
"Proposed" state, the project is not generally visible. In this state the resource 
requirements are set but not treated as firm. Thus they do not add a load to the 
resource calculations unless one asks explicitly for proposed projects to be added 
into the calculations. No resource requests or task assignments are generated. The 
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"proposed" project state is enabled for use by project managers to manipulate the 
project after it is created by the template, to mold its timeline and work to meet the 
specific needs of the new project: that is, add or subtract tasks or resources; reset 
dates; assign specific resources to the project, and so on. All changes to the project 
are audited, and any new tasks added can be identified as not coming from the 
template. Also, at the time of creation, the user can choose to establish a baseline.

■ Change project state from "Proposed" to "Active". This action is in effect the 
publication of the project to the community. The project is now "Active - Not 
Started". The project appears on dashboards, resource pool requirements are sent 
to pool owners, and any tasks assigned or owned by unique users appear on their 
"My Assignments" tab. However, no activity is taking place and the project can be 
activated well ahead of its scheduled start date. The setting enables projects to be 
published with the lead time necessary to staff the first group of tasks with 
resources and for users to see their workloads with the time needed to prepare. 
The system will prompt the user to set up a "Kick-off" baseline.

■ Change project status to "Active - In Progress". This is done by any task owner 
marking any task as "In Progress". When the first task is set to "In Progress", the 
project and all activities out-dented from that task are also marked "In Progress".

■ Assign resources as needed, not all at once. Because resources and owners can be 
set to resource pools, even without resources assigned the system sees the load. 
Thus it is logical to allow project and resource managers to assign specific 
resources close to the events for which they are needed.

Using Dependencies

Setting up complex dependencies in a project is essential yet onerous. The template 
functionality enables you to set up a very complex dependency model once, and use it 
over and over. The stepped process to project publication enables Project Owners to 
adjust those standard dependencies to meet specific needs. Agile PPM supports two 
dependency constructs: schedule dependencies, and progress dependencies.

■ Schedule dependencies: Agile PPM supports 4 types of schedule dependencies: 
Start to Start (SS), Start to Finish (SF), Finish to Start, and Finish to Finish. These 
dependencies, when set, will link the dates of the interlinked tasks, and if any task 
is moved in time (rescheduled), any linked task is automatically moved to keep 
the durations constant, based on the dependency type. This is standard to all 
project management systems, and is essential to maintaining schedule integrity 
when rescheduling any or all project activities.

■ Progress dependencies: Agile PPM supports the concept of progress 
dependencies using the content tab of the project, phase, gate, or task and content 
rules. There are two types of progress dependencies:

■ Project-based: This links any task or gate to another task or gate, and 
establishes a rule that predicates the progress of one task or gate, based on the 
progress (status) of another. For example you can prohibit a gate from opening 
until several previous tasks have been completed, or you can prohibit a gate 
from going into "Review" until several milestones have been completed, or 
you can automatically open a new project phase at the moment the pervious 
phase decision gate is approved/opened.

■ Deliverable-based: This links PLM deliverables, and their status to the 
progress of tasks and gates. For example, you can prohibit the start of the 
prototype phase of a project until the BOM of the product has been set to 
"Prototype", and when it is set to "Prototype", it can be set to automatically 
open the prototype phases and tasks.



Best Practices for PPM Process Execution

A-10 Product Portfolio Management User Guide

Defining Dynamic and Static Deliverables

■ Standard deliverables are those that can be pre-defined in the template and that 
are generated during the creation process. These have been discussed.

■ Dynamic deliverables are those deliverables that cannot be pre-defined. These can 
be broken down further in those that are anticipated, and those that are not 
anticipated.

■ Anticipated: Every project has deliverables that are required but are not 
specific until the project is active. The most common of these in the NPD 
process is the BOM (P/N) of the product to be developed. In Agile PPM, the 
PLM object that represents the BOM, once created, can be added to the project 
content at any level for control. The status of the BOM can control the progress 
of the project from one phase to another.

■ Unanticipated: Every project has deliverables/issues that impact the project 
and must be addressed. For example, during the test of a prototype, a major 
flaw is discovered. An Agile Change Request (CR) or Agile CAPA is launched 
to fix the problem. No further action on the project should go forward until the 
investigation is complete. The owner of the CAPA or CR can navigate to the 
relationship tab of that process and set a rule to prohibit the project task or 
phase from progressing until the CAPA or CR reach a certain status. (Security 
controls are set to control such activity appropriately)

Phase-Gate Project Execution
With unique abilities to track deliverables and use them to manage the sequence and 
requirements of a project PPM provides the most effective platform for true phase-gate 
process management.

This section provides a series of guidelines to follow when using Agile PPM for 
Phase-Gate Project methodologies.

Phase-Gate Management

■ Phase Management:

■ Phases should be owned by their logical center of accountability: that is, the 
Director of Development should own the "Development" phase.

■ Phases should always be bounded by a decision gate.

■ Phases should be linked by schedule or progress dependencies, or both, to 
other phases

■ Resources assigned at the phase level should not be duplicated at lower 
indented levels (tasks) within the phase.

■ Decision Gate Management:

■ Phase-Gate processes suggest that all phases must have a decision gate with 
an approval process linked to them that controls entry into the next phase. 
Decision gates should be automatically controlled by progress dependencies. 
For example, set a phase decision gate to automatically go into "Review" or 
"Open" when all of the checkpoint gates, defined in the phase are set to 
"Open".

■ Decision gates should be routed for review/approval in alignment with the 
phase that it bounds. The routing should include all stakeholders that can 
verify and support the work completed in the current phase, those 
stakeholders in the next phase that can verify readiness and confidence in that 
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next phase, project management that can summarize the project condition and 
health, and executive managers responsible for funding and resource 
management.

■ Decision gates should be baselined. Agile enables users to set multiple 
baselines. Decision Gates have a specific type of baseline called "Plan of 
Record". Every decision gate process should involve creating a "Plan of 
Record" baseline.

Task Management

Agile PPM is designed for two basic types of Project Management:

■ Centralized Task Management: Typical project management tools do not provide 
users with the environment to effectively manage a distributed task context. These 
systems focus all control and accountability for the project and all project activity 
on the project manager. Agile PPM can be operated in this fashion, simply by 
assigning ownership of all activity in the project to the project manager. This is 
done in the creation dialog or in the template.

■ Distributed Task Management: Agile PPM also provides for decentralized 
management of all project activities. Tasks are owned and resourced with resource 
pools. All activities that require resources are visible when released in the task 
owner's "My Assignments" home page.

■ Task Ownership: Task owners are free to manipulate the tasks they own, 
within the boundaries of the projects: secondary project managers. Set up task 
owners to represent the accountability associated with each phase, summary 
task, or task. For example, "Phase Two: Product Development" is owned by the 
pool "Development" "; the summary task, "Engineer Product Design" is owned 
by the pool "Product Managers", and the actual tasks needed to design the 
product are owned by the doers, that is, mechanical engineers for tasks 
needed for a box design, formula engineers for the tasks needed to create a 
formula or process model, and electrical engineers for the tasks to create a 
PCB. As soon as needed, but no sooner, ownership assignments are converted 
from pools to individuals from those pools.

■ Resources: Project participants can and should come from across the 
enterprise. When a project is created from a template, the system will copy all 
resource requirements as defined in the template "Team" tab into the project 
"Team" tab with an allocation >0. Typically all resource requirements are 
represented as a resource pools. At some point in the process, when needed, 
resource pool assignments should be given to individual resources.

■ Timesheets and Actual Standard Costs: It is recommended that organizations 
that need to track labor costs across a project enable the timesheet 
functionality. Users whose time tracking is not necessary can elect to not have 
the timesheet tab visible. When a user enters time spent into the timesheet, 
Agile will use the time entered and calculate an actual labor cost. The system 
will multiply the hours reported by either the hourly cost of the individual 
resource if available in the user profile, or if not available, by the hourly cost of 
the resource pool entered in the pool profile.

Best Practices: Using Oracle Product Lifecycle Analytics for PPM
Oracle Product Lifecycle Analytics (Oracle PLA) derives information from PPM 
projects to generate analytical reports. Follow the guidelines provided in this section to 
ensure that the metrics captured in the reports are accurate and meaningful. Usually, 
the following steps are required:
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■ Configure Oracle PLA correctly

■ Use the PLM Reference number correctly

■ Ensure projects have the right structure

Configuring Oracle PLA
Keep in mind that Oracle PLA provides an administrator the ability to configure the 
following using domain values:

■ Activity subclasses, to be configured as Portfolios, Programs, or Phases.

■ You can configure one Activity subclass as a Portfolio and another Activity 
subclass as a Program.

■ You can configure one or more Activity subclasses as Phases.

■ There are no configurations required for Projects and Tasks. Oracle PLA infers 
these based on the Phase domain value configuration and the structural 
hierarchy of the Projects. Therefore, it is extremely important to follow the 
hierarchy rules provided in the subsequent sections.

■ Gate subclasses, to be configured as one or more Decision Gates.

■ You can configure one or more Gate subclasses as Decision Gates. In addition 
to this configuration, the exact level and position of the Decision Gate plays an 
important role in ensuring that Decision Gates are displayed correctly within 
Oracle PLA.

■ The Gate dimension within Oracle PLA is populated using the Decision Gates 
configuration described above. The gates that are not configured as Decision 
Gates do not appear in the gate dimension.

■ You can configure one or more Gate subclasses as Decision Gates. In addition 
to this configuration, the exact level and position of the Decision Gate plays an 
important role in ensuring that Decision Gates are displayed correctly within 
Oracle PLA.

■ The Gate dimension within Oracle PLA is populated using the Decision Gates 
configuration described above. The gates that are not configured as Decision 
Gates do not appear in the gate dimension.

Using the PLM Reference Number
It is recommended that you follow the rules outlined in this section while using the 
PLM Reference field in PPM for Portfolio, Program, and Product objects.

Portfolio and Program objects can be created within PPM using the Activity subclass. 
You can use the subclass type Portfolio or Program, or the exact name of the object as 
configured in your system. Portfolio and Program are expected to be created as 
standalone objects; these objects should have no child objects under them.

The PLM Reference number in the Portfolio or Program object can group the programs 
and projects within Oracle PLA. Some fundamental rules for using the PLM reference 
number are provided here:

Rules for using PLM Reference field in a Portfolio:
■ The PLM reference field in a Portfolio object can refer to one or more projects or 

programs, or both. However, you cannot use the PLM Reference field on a 
Portfolio to refer to other Portfolios.
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■ A Portfolio cannot be aggregated as a collection of programs within Oracle PLA. 
Portfolio is shown as a collection of projects. If Programs are associated with a 
Portfolio, Oracle PLA will break down the Programs into referred Projects for 
display within Oracle PLA.

■ All projects in programs associated with a Portfolio are treated as belonging to a 
Portfolio.

Rules for using PLM Reference field in a Program:
■ The PLM reference field in a Program can refer to one or more Projects. You cannot 

use the PLM Reference field on a Program to refer to other Programs or Portfolios.

Rules for using PLM Reference field to identify a Product:
■ Typically, Projects result in one or more 'Products'. You can use the PLM Reference 

number on a Project to identify the Product. Only objects of type 'Items' are treated 
as Products and reference to any other type of object will be ignored by Oracle 
PLA.

The PLM Reference field is available from Agile PLM version 9.3 onwards. If you are a 
9.2.2.x customer, use a Defined field (P2/P3) instead of the PLM Reference field.

Using the Right Project Structure
Based on the domain value configurations for each Project, Phase, and Decision Gate, 
Oracle PLA 'locates' the object and makes hierarchical inferences, as explained below:

■ An activity situated one level above a Phase is considered to be a Project. As a 
result, it is important to have one and only one object above the Phase in a Project 
hierarchy.

■ Tasks are activities that are one or more levels below a Phase.

■ Decision Gates can be at same level as a Phase or one level below the Phase.

Therefore, it is necessary to ensure that you follow the guidelines provided here while 
defining project structure.

The following figure illustrates the Project hierarchy structures that are recommended:
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Figure A–1 Recommended Project Hierarchy

For more detailed metrics on Phases, you can split Phase subclasses into Phase 0, 1, 2... 
and so on.

Oracle PLA does not support a Phase subclass under another Phase subclass.

Note: While it is possible to look at a flat list of all Tasks below the 
Phase, Oracle PLA does not maintain or display a tree of tasks. For 
example, in the above Project hierarchies, it is possible to get Tasks 
under Phase 1 such as Task 1.1, 1.1.1 and 1.1.2 but it is not possible to 
get a list of Tasks under Task 1.1.

Using Category Fields
Use the Category Fields in PPM to capture project-level information. These fields are 
exposed as Project dimensions in Oracle PLA. These fields can also be used as 
Dimensions on Activities, but only in the Project Detail subject area.

Best Practices for MSP-PPM Integration
Due to data and functionality constraints, we recommend that you follow these best 
practices when using the MSP-PPM integration functionality.

Creating A Project
As a best practice, create your project in PPM, then export to MSP and publish it back 
to PPM.
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Maintaining PPM Constraints
The integration process does support constraints, however, there are some limitations 
to maintain data integrity. 

Constraint data is not supported in the following schedule-related scenarios:

■  Update XML Date element in xml like: start / finish date of task

■  Task is found in xml but deleted in PPM

■ Task has been cancelled in PPM

■ Task is changed to 0 duration in PPM

■ Task's duration is changed in PPM

■ Duration type of task is modified in PPM

■ Task parent outline number has been changed in PPM

■ 0 duration task milestone value is changed

■ Text30 for task is empty or missing

■ New tasks are added in PPM

■ New dependencies are added in PPM

■ The predecessor of activity has been deleted in PPM

■ Dependency has been removed in PPM

■ Time buffer/type of dependency is modified in PPM

■ Multiple resource in MSP is mapped to same user

■ Assignment has been deleted in PPM

■ Resource allocation has been changed in PPM

■ New assignments have been added in PPM

Constraint data is not supported in the following resource-related scenarios:

■ Multiple resource in MSP is mapped to same user

■ Assignment has been deleted in PPM

■ Resource allocation has been changed in PPM

■ New assignments have been added in PPM
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ACP

See Agile Configuration Propagation (ACP)

Activity

A project activity in Agile Product Portfolio Management, such as a program, task, or 
phase.

Affected Files

Similar to Affected Items, these objects are EC files that are Design Release Candidates.

Agile Configuration Propagation (ACP)

Propagating existing configuration the PLM to the newly installed version of PLM.

ACS

See Agile Content Service (ACS)

Agile Content Service (ACS) 

ACS is an event-driven XML-based publishing service that makes the product record 
available to a wide variety of business applications and users, internally and across the 
global manufacturing network

Agile Destination

A package created by an Agile PLM system in the target PLM using Web Services to 
import from the Attachments tab of the package in the target system.

Agile Integration Services (AIS)

A collection of predefined Web Services in the Agile Integration Framework that 
enable communication between the Agile Application Server and disparate systems

Agile Product Portfolio Management

The Agile PLM project management solution that is integrated with the product 
information in PLM.

AI

Affected Items tab on Change objects in Agile.

AIS

See Agile Integration Services (AIS).
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Approved Manufacturer Parts List (AML)

List of approved manufacturer parts associated with an item.

AML

See Approved Manufacturer Parts List (AML).

API

See Application programming interface (API).

Application programming interface (API)

A set of routines, protocols, and tools for building software applications. An API 
expresses a software component in terms of its operations, inputs, outputs, and 
underlying types.

Assembly

A product assembly lists the parts in a product and shows the substances and 
materials that comprise those parts. It is linked to specifications that can restrict how 
much of a particular substance that product assembly may contain

Automated transfer orders (ATO)

Content published by Agile PLM users in real time with a content transfer order (CTO) 
or set up subscribers to automatically create automated transfer orders (ATO) based on 
a schedule or triggered by a workflow status change.

Baseline

A snapshot of a project, usually in its initial stage, used as a reference for future 
comparison in Agile Product Portfolio Management.

Bill of Material (BOM)

A hierarchical representation of a product that is made up of other products.

Bill of Substances (BOS)

A hierarchical list of substances that are contained in the parts and assemblies that 
make up a BOM.

BOM

See Bill of Material (BOM).

BOS

See Bill of Substances (BOS). 

CAD

See Computer-aided design (CAD)

Commodity

A class of goods that is in demand, that is supplied without qualitative differentiation 
regardless of supplier.

Computer-aided design (CAD)

The use of computer systems to assist in the creation, modification, analysis, or 
optimization of a design. CAD software is used to increase the productivity of the 
designer, improve the quality of design, improve communications through 
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documentation, and to create a database for manufacturing. CAD output is often in the 
form of electronic files for print, machining, or other manufacturing operations.

Contract (Price)

This is a subclass of the Published Prices class. Contract prices are prices provided by 
the supplier for a specific item or manufacturer part. This price information applies 
only for the specified duration and can apply to any project.

Co-Sourcing

The process of leveraging product cost across suppliers. 

DCO

See Design Change Order (DCO)

Deliverable

A unit of work required for a project's success, usually fulfilled by generating a digital 
file. (Word processing documents, spreadsheet documents, PDFs, presentation 
documents, and so on.) Deliverables can also be Agile PLM objects and processes. Also 
called ’content’ in Agile Product Portfolio Management.

Design Change Order (DCO)

A Change Order subclass that is available when the effected File Tab is enabled and 
provides access to all Agile PLM Workflow functions.

Design File Folder

An EC file folder that is integrated with CAD and PLM files, providing full access to 
PLM Workflow function.

EC

See Engineering Collaboration (EC)

EC Client

A Java-based UI to access, administer and operated the EC solution.

ECO

See Engineering Change Order (ECO)

Engineering Change Order (ECO)

An object that carries with it all the proposed changes to a product and/or its BOM. 
When approved and implemented, the proposed changes become effective.

Engineering Collaboration (EC)

An application that provides data and process integration between CAD applications 
and Agile PLM. It allows CAD designers and engineers to capture and control the data 
representing a primary source of the product record.

Extensible Markup Language (XML) 

A markup language that defines a set of rules for encoding documents in a format that 
is both human-readable and machine-readable

File Manager

The File Manager manages files in a repository or vault in the file system and provides 
a place to store and retrieve files locally or remotely. You can install it on the same 
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server as the Agile Application Server or on a separate one. You can also install the File 
in a redundant configuration and/or distributed across geographic regions. 

File Transfer Protocol (FTP)

A standard network protocol used to transfer computer files from one host to another 
host over a TCP-based network, such as the Internet.

FQPN

See Fully qualified path name (FQPN).

FTP

See File Transfer Protocol (FTP)

Fully qualified file name

The exact name of a file on a computer that is completely specified such that it is 
unambiguous and cannot be mistaken for any other file on that system.

Fully qualified path name (FQPN)

The full path of a resource, directory or file, stored in a computer. It is composed by the 
full path to the resource and its syntax depends on the operating system.

Gantt Chart

A project management tool that shows project activities and schedule as a bar chart. 
The chart lists project activities in sequence, and presents critical information such as 
the start and end dates of each activity, as well as interdependencies between activities.

Item Master

The product record. It is the entire collection of Items - Parts, Documents, and any 
other user-defined subclasses of the Items class maintained under change control in 
the Agile system.

Java Message Service (JMS)

The Java Message Service (JMS) API is a Java Message Oriented Middleware (MOM) 
API for sending messages between two or more clients.

JMS

See Java Message Service (JMS).

Lifecycle Phase

Current state in an object’s workflow.

LRR

Latest Released Rev - concerning a Part or Document. 

NCNR

Non-Cancelable Non Returnable. Applies to an item. NCNR can be a Yes or No, 
depending on the supplier. You can ask for the NCNR information in the supplier 
response. This is one of the critical factors in finding the best deal among the supplier 
responses.

PDX

See Product Definition eXchange (PDX).
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PLM

See Product Lifecycle Management (PLM).

Percent allocation or % allocation

The percentage of a resource's time allocated to a specific task or tasks in Agile Product 
Portfolio Management..

Percent complete or % complete

Amount of time and effort expended on a project measured as a percentage of the time 
and effort required to complete the whole project. Used in Agile Product Portfolio 
Management.

Product Definition eXchange (PDX)

A standard designed for the e-supply chain. This standard is based on the XML format 
because it provides a simple yet powerful and flexible way to encode structured data 
into a format that is both human- and computer-readable. In PLM, PDX packages 
contain product content, such as items.

Product Lifecycle Management (PLM)

The process of taking parts/documents from inception to production to phase-out, 
and all the stages in between.

Protocol

A system of digital rules or agreed-upon format for data exchange within or between 
devices. It determines the type of error checking and data compression used.

Published Price

This is a subclass of the Published Prices class. Published prices are prices provided by 
the suppliers in response to an RFQ and published from the project. The published 
price information can also be used in other projects.

PCO

See Price Change Order

Price

An object that carries with it all the proposed changes to a product and/or its BOM. It 
can be approved and implemented to make the proposed changes effective.

Price Change Order

It is an object that carries with it all the proposed changes to a price. It can be approved 
and implemented to make the proposed changes effective.

Quote history

A subclass of the Quote Histories class. Quote history prices are the stored prices from 
supplier responses that you can use. Any change in the response line of an RFQ is 
stored in the historical response and is usable at any time.

Request for Information (RFI)

A material declaration that lists the parts in a product assembly and shows the 
substances and materials contained in the part.
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Request for Quote (RFQ)

A standard business process whose purpose is to invite suppliers into a bidding 
process to bid on specific products or services.

Request for Proposal (RFP)

A solicitation, often made through a bidding process, by an agency or company 
interested in procuring a commodity, service or valuable asset, to potential suppliers.

Response Line

A response line has information about only one item. The negotiation of price and 
terms for items is dealt with in a response line.

Resource Pool

A group of users who can be bulk assigned as resources for a particular project or task 
in Agile Product Portfolio Management.

RFI

SeeRequest for Information (RFI).

RFP

See Request for Proposal (RFP) 

RFQ

See Request for Quote (RFQ)

RFQ Response

A medium of communication between the user and the supplier. One response from a 
supplier can contain multiple response lines for different items. Price data is added to 
the project automatically when the supplier submits the response.

Schedule Editor

The scheduling engine that handles updates to the project schedule in Agile Product 
Portfolio Management.

Schema

In computer programming, a schema is the organization or structure for a database. 
The activity of data modeling leads to a schema.

SDK

See Software Development Kit (SDK or "devkit")

Software Development Kit (SDK or "devkit")

A set of software development tools that allows the creation of applications for a 
certain software package, software framework, hardware platform, computer system, 
video game console, operating system, or similar development platform.

Sourcing Project

The entry point of sourcing and product pricing. A sourcing project tracks data 
required for sourcing and pricing, to perform data analysis for effective pricing.

Standard Cost

Applies to an item. This is the market cost of the item. It is site-specific. The standard 
cost is for a unit.
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Supplier

A supplier of one or several commodities.

Target Cost

Applies to item. This is the expected cost of the item by you or the supplier. This can 
be a percentage of the standard cost. Target cost is for a unit.

Timesheet

The time entry system in Agile Product Portfolio Management, used to track actual 
hours spent by resources on project activities and to calculate corresponding labor 
cost. 

TLA

SeeTop Level Assembly (TLA)

Top Level Assembly (TLA)

The level in a BOM that indicates the ultimate product being manufactured. 

Transfer order

Every time Agile Content Service (ACS) publishes product content, it produces a 
transfer order that keeps track of what, where, and when product content is 
transferred.

UPK

See User Productivity Kit (UPK)

User Productivity Kit (UPK)

The Oracle online help system used in some Oracle products.

Web Service Extensions (WSX)

A Web service engine that enables communication between Agile Product Lifecycle 
Management system and disparate internal and external systems. 

WSX

See Web Service Extensions (WSX). 

XML

See Extensible Markup Language (XML).

XML Schema

Description of a type of XML document, typically expressed in terms of constraints on 
the structure and content of documents of that type, above and beyond the basic 
syntactical constraints imposed by XML rules.



XML Schema

Glossary-8


	Preface
	Audience
	Documentation Accessibility
	Related Documents
	Conventions

	1 Introduction
	Agile Product Portfolio Management Overview
	What's New in PPM 9.3.5
	Upgrade Considerations
	Configuration Notes
	Related Documentation
	Features Summary
	When to Use Web Client
	When to Use Gantt Chart
	Project Management Objects
	Project Tree Structure

	PPM Process Flow
	Where to Find Information


	2 Understanding the Interface
	Home Page
	Quick Links
	Home Page Inbox Tabs
	Dashboard
	Dashboard Tabs
	Accessing Gantt from the Dashboard

	Configuring Dashboard Tab Widgets
	Executive Tab
	Projects Tab
	Resources Tab
	Financial Tab
	My Stuff Tab
	Optional Tabs
	PPM Notifications
	Cost Impact Notifications
	Discussion-related Notifications
	Other Notifications
	Ownership, Assignment, or Delegation Notifications
	Schedule Change Notifications
	Setup-related Notifications
	Workflow-related Notifications

	Workflow Routings Tab
	My Assignments
	Project Assignments
	My Assignments Table
	Creating Personalized Views

	Timesheet
	Timesheet Tab Tools


	Project Page
	Viewing Project Details
	Viewing Project Summary
	Summary Page Actions

	Viewing General Information
	Dates
	Duration
	Audit Values

	Working with Attachments
	Collaborating on Project Activities
	Viewing History
	Actions Menu
	Address Book Palette

	Gantt Chart
	Prerequisites
	Modes of Operation
	Launching Gantt
	Launch Options
	Launching Gantt Using Shortcuts

	Privilege Checks in Gantt
	Gantt Toolbar
	Views in Gantt
	Gantt
	Task Assignment
	Calendar
	Critical Path
	Comparative Gantt
	Resource
	Resource Sheet
	Resource Utilization

	Customizing the Gantt Chart
	Setting Preferences
	Appearance and Style
	Bar Labels
	Grids
	View Bar

	Gantt Menu Options
	Working Offline on Single-Project Gantt
	Unlocking Projects before Exiting
	Filtering in Gantt
	Using Predefined Filters

	Toggling the View Between Gantt and Web Client
	Printing a Gantt Chart
	Working with Multi-Project Gantt
	Launching Multiple-project Gantt
	Launch Mode

	Editing in Multi-Project Gantt
	Inter-dependencies in Multi-Project Gantt


	Gantt Navigator
	Adding Projects or Deleting Projects From Gantt
	Locking and Unlocking Projects in Navigator



	3 Setting Up Project Management Processes
	Defining Calendars
	Setting up a Project Structure
	Creating a Project Template
	Identifying the Template Used to Create a Project
	Adding Activities
	Add Activities using Gantt Chart
	Add Activities

	Adding Gates
	Defining Stationary Gates

	Adding Milestones
	Editing Data
	Deleting Project Elements
	Setting Ownership to Resource Pools

	Managing Content
	Adding Content
	Adding Revision-controlled Objects
	Setting Mandatory Content
	Setting Up AutoNumbering
	Personalizing Views for Content
	Defining Rules for Content
	Duplicating Deliverables from a Project Template
	AutoNumbers
	Required Fields
	Tabs
	Activities and Gates
	Root Projects
	Templates



	4 Creating and Managing Projects
	Creating a Project
	Using Gantt Chart
	Using Web Client

	Editing a Project
	Editing Project Objects Concurrently
	Editing Multiple Tasks in the Same Project Tree
	Editing Tasks with a Predecessor and Successor Relationship
	Examples

	Multiple Users Editing the Same Task
	Locking Tasks for Editing
	Editing Unlocked Tasks
	Reviewing Changes
	Undoing Changes


	Activating a Project
	Working with Project Content
	Viewing Content
	Updating Content

	Managing Resources
	Adding Resources
	Adding Resources Using Web Client
	Adding Team Members from Schedule Tab
	Adding Team Members from Team Tab
	Adding Resources Using Gantt

	Viewing Resource Utilization
	Viewing Project Resource Utilization Chart
	Viewing Resource Utilization Reports
	Viewing Resource Utilization Reports using Web Client

	Editing Team Member Attributes
	Assigning Tasks to Resources
	Bulk Assigning Tasks to a Resource
	Splitting a Task Among Several Resources
	Changing Ownership of Tasks in Projects Created from Templates
	Removing Resources
	Delegating Ownership
	Changing Ownership Directly
	Substituting Resources

	Searching for Timesheets
	Defining Timesheet Views

	Managing Schedules
	Using Calendars
	Identifying Calendar Conflicts
	Accepting Calendar Changes

	Creating and Editing Dependencies
	Creating and Editing Dependencies in Web Client
	Creating and Editing Dependencies in Gantt
	Types of Dependencies
	Dependency Time Buffer
	Dependencies Between Templates and Active Projects
	Editing Display Order
	Rescheduling a Program
	Creating a Baseline
	Comparing Baselines



	Managing Discussions
	Discussions Table
	Adding Discussions
	Replying to Discussions
	Replying to Discussions from your Home Page
	Replying to Discussions from the Project Summary Page

	Viewing Discussion Replies
	Removing Discussions
	Viewing Action Items

	Archiving Projects

	5 Participating in Projects
	Working on Assignments
	Accepting Assignments
	Declining Assignments
	Editing Assignments
	Mark Assignments Complete
	Flagging Assignments
	Reporting Time

	Subscribing to Events
	Changing Workflow Status

	6 Tracking Projects
	Status Tracking
	Default Health Statuses
	How Status Roll-Up works
	Workflow Status
	Rules for Parent Status
	Cost Status
	How Total Cost is Determined
	Costs Included in Baselines

	Reports
	About Agile Standard Reports
	Agile Standard Reports for PPM


	7 Working with Microsoft Project
	Data Supported in the Integration
	Data Not Supported in the Integration
	Before You Begin
	Setting Up Microsoft Project Synchronization
	Understanding How the Schedule Editors Differ
	Choosing the Scheduling Engine

	Transferring Microsoft Project Work Values to PPM
	Notes on the Agile Menu in Microsoft Project

	Creating a Project from an Existing Microsoft Project File
	Updating a Project with Changes Made in Microsoft Project
	Using a PPM Project Template in Microsoft Project
	Working Offline on a PPM Project
	Read Only and Edit Modes
	Replicating a PPM Project Across Servers
	Deleting Objects in Microsoft Project

	8 Working with Recipe Management for Pharmaceuticals
	Synchronizing Data between PPM and RMW

	9 Import and Export
	Importing Data
	Before You Begin
	Persistence of Import Settings
	Importing Large Data Files
	Supported File Formats
	Data Transformation

	Importing Projects and Project Content
	Define Import Preferences
	File Selection
	Specify File Content
	Specify Attribute Mapping
	Review Import Settings and Begin Import

	Exporting Data

	10 Configuring Product Portfolio Management
	Administration in Agile Java Client
	Product Portfolio Management Configuration Checklist
	Notes on Data Settings
	Object Classes for Deliverables
	Enabling the Calculate Attributes
	Configuring Display of Date Attributes in Schedule Tab
	Variances Displayed in the General Info Tab Summary Table

	Notes on Setting Up Roles
	Default Roles Assigned Automatically to Agile PPM Users
	How the Lists of Available Agile PPM Roles are Determined

	Notes on Assigning PPM-specific Privileges
	Create from Template Privilege
	Share, Grant, and Delegate Owner Privileges
	Microsoft Project Privilege
	Update All Timesheets Privilege
	Calendar Administrator Privilege
	Adding Project Contents in Modify Privilege
	Accessing Gantt Charts
	Modify Privilege Mask Applied To Properties that Control Specific User Actions
	About Privileges for Microsoft Project
	About Privileges in Gantt
	Setting Up Restricted Delete Privileges
	Settings Required for Menu Command: Actions > Change to Canceled
	Enabling Assign Action in User Groups
	Configuring Stationary Gates

	Notes on Setting Up SmartRules
	Automatic Installation from PPM SmartRule

	Configuring Status Display
	Status Nodes
	Changing the Status Names the User Sees
	Modifying Status Node Settings
	Schedule Status
	Schedule Status Guidelines
	How Schedule Status is Determined

	Cost Status
	Quality Status
	Resource Status

	Configuring Calendar Display
	Configuring UI Data Display
	UI Configuration Data


	Administration in Agile Web Client
	Configuring Project Summary Display
	Personalizing the Project Summary Page
	Configuring Timesheet Display
	Configuring Calendars
	Creating a Calendar
	Importing and Exporting Calendars
	Updating Calendars
	Deleting Calendars
	Setting Preferred Calendar


	Configuring Microsoft Project Integration
	Using Custom Agile PPM Subclasses in Microsoft Project
	Transferring Microsoft Project Work Values to Agile PPM as Days Effort


	A Best Practices
	Best Practices for General Project Management
	Process Definition and Acceptance
	Implementation Realities and Requirements

	Best Practices for PPM Setup
	Administrative Setup
	Templates and Project Setup

	Best Practices for PPM Process Execution
	General Project Execution
	Phase-Gate Project Execution

	Best Practices: Using Oracle Product Lifecycle Analytics for PPM
	Configuring Oracle PLA
	Using the PLM Reference Number
	Rules for using PLM Reference field in a Portfolio:
	Rules for using PLM Reference field in a Program:
	Rules for using PLM Reference field to identify a Product:

	Using the Right Project Structure
	Using Category Fields

	Best Practices for MSP-PPM Integration
	Creating A Project
	Maintaining PPM Constraints


	Glossary

