The SUNW.rac_framework resource type is a single instance resource type. Only one resource of this type may be created in the cluster.
To register this resource type and create instances of this resource type, use one of the following means:
Oracle Solaris Cluster Manager
The clsetup(8CL) utility, specifying the option for configuring Oracle Solaris Cluster Support for Oracle Real Application Clusters
The following sequence of Oracle Solaris Cluster maintenance commands:
When a resource of this type is brought offline on a node, the transition from the online state to the offline state requires a finite time to complete. During the transition to the offline state, the resource continues to participate in reconfiguration processes. However, when the resource is offline on a node, changes to resource properties are not effective on the node until the resource is brought back online. Oracle Solaris Cluster displays a warning message to this effect when a resource of this type is disabled.
The transition to the unmanaged state of a resource group that contains a resource of this type requires a finite time to complete. During the transition to the unmanaged state, the Oracle RAC framework continues to participate in framework reconfiguration processes. However, when the resource group is unmanaged, changes to resource properties are not effective on the node. To stop the Oracle RAC framework, the node must be rebooted.
Type integer; minimum 100; maximum 99999; defaults to 325. This property specifies the timeout (in seconds) for the reservation step of a reconfiguration of Oracle Solaris Cluster Support for Oracle RAC. You can modify this property at any time.
This example registers the SUNW.rac_framework resource type and creates an instance of the SUNW.rac_framework resource type named rac_framework-rs. The example assumes that a resource group named rac-framework-rg has been created.
phys-host-sc1# clresourcetype register SUNW.rac_framework phys-host-sc1# clresource create -g rac-framework-rg \ -t SUNW.rac_framework rac_framework-rsExample 2 Changing a Property of a rac_framework Resource
This example sets the timeout for the reservation step of a reconfiguration of Oracle Solaris Cluster Support for Oracle RAC to 350 seconds. The example assumes that a resource of type SUNW.rac_framework that is named rac_framework-rs has been created.
phys-host-sc1# clresource set \-p reservation_timeout=350 rac_framework-rs
See attributes(7) for descriptions of the following attributes: