4.16 NFS Backend to Cinder Backup Requires NFS 4.1

To use NFS as the storage mechanism for Cinder Backup requires the storage hardware to support NFS release 4.1 or higher. Storage hardware which uses earlier versions of NFS may cause Cinder errors.

Workaround: Change the Cinder configuration on the storage nodes to downgrade the NFS version. Edit the /etc/kolla/config/cinder.conf file on the master node to include:

[DEFAULT] 
backup_mount_options="vers=3" 

Alternatively, you can use the following if your storage hardware supports NFS version 4:

[DEFAULT]
backup_mount_options="vers=4,minorversion=0" 

Redeploy the Cinder container using:

$ kollacli deploy --service cinder

Bug: 22040962