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Preface vii 

Preface 
This document describes the steps to install the MICROS Gateway Device Handler (MGDH) 
and the Oracle Payment Interface (OPI) including: 

• Installing MGDH 
• Installing OPI 
• POS configuration for OPI using MGDH 
• Middleware mode vs Terminal mode  
• Pay@Table.  

 
The Oracle Payment Interface RES Native Driver Installation Guide contains more information. 
 

Audience 
This document is intended for installers of Oracle Payment Interface and MGDH. 
 

Customer Support 
To contact Oracle Customer Support, access My Oracle Support at the following URL: 
https://support.oracle.com 
When contacting Customer Support, please provide the following: 

• Product version and program/module name 
• Functional and technical description of the problem (include business impact) 
• Detailed step-by-step instructions to re-create 
• Exact error message received and any associated log files 
• Screen shots of each step you take 

 

Documentation 
Oracle Hospitality product documentation is available on the Oracle Help Center at 
http://docs.oracle.com/en/industries/hospitality/ 
 

Revision History 
Date Description of Change 

April 2017 • Initial publication. 

 
 
 

https://support.oracle.com/
http://docs.oracle.com/en/industries/hospitality/
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1  Pre-Installation 
Before Installing 

Complete the following tasks before installing: 
• The OPI application requires Microsoft .NET Framework version 4.0 or higher.   
• You cannot upgrade from previous versions of MICROS Gateway Device Handler 

(MGDH) for other solutions to MGDH version 6.1 MR1. 
• You cannot upgrade from previous versions of MPG to OPI 6.1 MR1. 
• If a previous MGDH installation exists, go to Programs and Features to uninstall the 

previous MGDH installation, then you can install the latest MGDH release. 
• Verify with the merchant to setup table service (TSR) or quick service (QSR), or both.  

QSR does not support tips. 
• Verify with the merchant if activating the Refund functionality, the merchant must 

control the privilege for this function.  
• Verify with the merchant if they offer a guest the option to get cash back with their 

purchase, then activate the Sale&Cash option. This is only available for QSR.  
• Oracle Payment Interface requires at least 6 GB of free disk space.  
• You must install both MGDH and OPI as a System Administrator. 
• You must enter the user name and password of a Microsoft Windows local 

administrator during the OPI installation.   
• You must enter the MICROS database user name and password to install MGDH. 

 
During the installation you must confirm the following: 

• Merchant ID’s  
• Receipt “Header” and “Trailer” details 
• Tender Media numbers for each card type 
• IP address of the OPI Server  
• If there is an existing MySQL database installed the SQL root password is required. 
• Workstation ID’s and IP’s that integrate with the PIN pad. 
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2  Network Consideration 
You must consider the following points for the network: 

• OPI listens on the TCP port 5098 for incoming messages from MGDH by default, this 
port must be open internally on the merchant’s network. 

• The port for the PIN pad depends the partner, confirm with the partner and confirm the 
corresponding port is open. 
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3  Configuring the Simphony Server 
Adding an Interface 

To configure the server, you must add a new interface.  
1. In the Enterprise Management Console, go to the Interfaces tab and select MGDH. 
2. Define the following interface values on the General tab. 

 

Interface Value 

System Name MGDH 

Communication Name MGDH 

Service Type PMS/SIM 

Communications Type TCP/IP 

Timeout 210 

ISL Script Name pms7 
 

 
 

3. Click the Options tab, and then select Use 19 Digit Reference Entry for PMS Inquires. 
4. Click the Properties tab, and then select the property that processes the credit and debit 

transactions for OPI to activate it. 
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5. Click the Service Host tab, and then select the server to host the MGDH interface. 
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Configuring the RVC 
1. Link the interface for the MGDH to each RVC. 
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2. If the RVC uses QSR mode, then activate the following options. If using the TSR mode, 
do not activate these options. 

• Do Not Prompt for Tips (No Overtendering if Charge Tip is Required) 
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3. On the Format tab, configure and enable the following options for the TSR RVC. 

• Enter 32 for the Number of Guest Check Information Lines. 
• Select Skip Blank Lines When Print or Display Guest Check Info Lines. 
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Configuring the Employees 
1. Go to the Employee Maintenance tab, and then select the Cashier option.    
2. Select the check box to activate the ISL Employee Option #4 option to define the 

employee class that can process the refund. 
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Configuring Service Charges 
1. If the merchant uses the cash back option, then you can add a new Cashback service 

charge. For the Service Charge for OPI tenders, use the same option as the open 
amount service charge. If merchant doesn’t activate the SaleCash function, then skip 
this step. 
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Configuring Tender Options 
Configure the following options for the credit/debit tenders. 

1. Select the Options tab, and then select the category Interface Options.  
2. Select the PMS and Credit Card use 19 Digit Acct Number option. 

 
 
To configure the credit card options: 

1. Go to the Options tab and select Credit Card Options. 
2. Deactivate all options and remove the floor limit/preambles list. 
3. Enable the No Credit Card Length Check option. 

 
To configure the Ops options: 

1. Go to the Options tab, select Ops Behavior, and activate the following options: 
• Assume Paid in Full 
• Reference Entry Required 

2. Deactivate the following options: 
• Mask Account Number 
• Encrypt Tender/Media Reference Entry 

3. Link the tender to Service Charge for TSR environments. 
4. Add the debit tender option the same way you would for normal credit card tenders. 
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5. Add a new tender SaleCash option the same way as a normal credit card tender. This is 
only available for QSR. Skip this step if the merchant does not activate the SaleCash 
function.  
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Configuring a CAL Package  
1. Add a new CAL package for the Microsoft Win32 and Microsoft WinCE clients. 

 
 

2. Add deployments as shown in the following screen shot.  
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Designing the Touch Screen  
Before beginning, you must first consult with the Oracle Consulting Team. If required, you can 
then add the following buttons to the payment screen. The key type is Function and you can 
link to the interface MGDH. 

TSR Payment Screen 

Field  Value  

CC PAY SIM INQ #2 
CC REFUND SIM INQ #4 
CC AUTH SIM INQ #8 
CC FINAL SIM INQ #9 
TAB AUTH SIM INQ #12 
BALANCE INQUIRY SIM INQ #14 
CC REPRINT SIM INQ #7 
CC REPOST SIM INQ #16 
MANUAL AUTH SIM INQ #15 
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REFUND MANUAL 
MOTO AUTH 

SIM INQ #11 
SIM INQ #20  

QSR Payment Screen 

Field Value 

QSR SALE SIM INQ #1 
SALE CASH SIM INQ #5 
CC REFUND SIM INQ #4 
BALANCE INQUIRY SIM INQ #14 
CC REPRINT SIM INQ #7 
CC REPOST  SIM INQ #16 
REFUND MANUAL 
MOTO SALE 

SIM INQ #11 
SIM INQ #6 

 
OPI shares the VOID touchscreen key with the Simphony POS. Using the VOID key you can: 

• Void the transaction 
• Add Tips (for TSR only) 
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4  MGDH driver installation 
Installing MGDH on the Simphony Server 

1. Double-click the MGDH installer to start the installation. 
2. Click Next. 
3. Browse to select the location to install MGDH. 
4. Click Next. 
5. Enter your database information.  

Field Value 

Database Type MSSQL 

DB Server localhost 

Database Name mcrspos 

6. Select Next. 

7. Select the property. 

8. Select the Currency and Single MerchantID or Multiple MerchantID.  

9. Enter the MID number. Enter the Single MerchantID, and then click Next. If needed, 
confirm the MerchantID setup configuration with the Oracle Consulting Team. 

10. Select the RVC Mode for each RVC under the property. TSR is for Table Service and 
QSR is for Quick Service which enables the no tip option. 

11. Click OK to close the Header Editor. You do not need to configure the Header and 
Trailer information. This information is configured by the partner and the partner 
responds with all the print data. Click Next.  

12. Match the tender from the drop-down list for each card type, and then enter the 
Cashback service charge number for Cashback_svc.  If the tender is not used, then 
skip this step. Click Next. 

13. Select the transaction option required for the installation. Double-click the Trans 
Option Description to access the description for each option. Click Next. 
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14. Select the options required for the merchant, and then click Next. 
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15. Configure the following information, and then click Next. 

Option Value 

Host1 HTTP OPI server IP, for example: 
https://127.0.0.1 

Host1 Port OPI port, you can use the default 5098 

TIMEOUT MGDH timeout, you can use the default 60 
seconds 

 
16. Configure the following information for the POSEOD, and then click Next: 

Option Value 

Server OPI server 

Server port OPI port 

TIMEOUT(POSEOD) EOD TIMEOUT, you can use the default 
value 80 

Device MerchantID The MID or MID’s required for the RVC’s 

Multiple MID There must be a “|” between the MID’s 
 

https://127.0.0.1/
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17. Review the summary, and then click Ok to exit. 

18. Click Install to continue installing. 

19. Select the Edit options to edit the files configured in a previous installation. Otherwise, 
click Next. 

20. Ensure each module is selected for install, and then click Next. 

21. Select Yes to restart the computer or select No to restart the computer at a later time, 
and then click Finish. A restart is not required. 
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Point-of-Sale (POS) End-of-Day (EOD) 
 
You can use the Microsoft Windows Task Scheduler to run the OPI POSEOD using the 
following configuration details. 

 

Temporary Table 

Name OPI POSEOD 

Description Generates the OPI transaction report 

Trigger Daily 

Action Start a program 

Program/script Browse to find POSEOD.exe in 
MGDHDriver directory 

Add arguments(optional)  the upper level of the POSEOD.exe path 

Start in (optional) The upper level of the POSEOD.exe path 

 

For more information on how to setup the Microsoft Windows Task scheduler visit the 
Microsoft website at the following URL: http://www.microsoft.com 

 

http://www.microsoft.com/
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5  Installing OPI 
Complete the following steps to install OPI. 

1. Double-click the OPI installer. 

2. Click Next. 

3. Verifying your computer. Validating the required software may take about 10 
seconds. 

4. If the target computer doesn’t have MySQL installed, then OPI installs the MySQL 
database. If MySQL is already installed, then OPI uses the existing MySQL 
database and you must enter the MySQL credentials. 

5. Setup a password to use for creating the database schema. 

6. Select Next to continue and create the database user for OPI. 

7. Select MGDH and click Next. 

8. Create a password to secure a certificate for OPI to use in MGDH communication. 

9. Configure the date and time you want to restart the OPI Service.  

10. Select the location where you want OPI installed, and then click Next. 

11. Click Next, and then Next. 

12. Click Install. 

13. Installing OPI and MySQL starts and may take several minutes. Once the 
installation is complete, you can configure OPI. 
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Configuring OPI  
Complete the following steps to configure OPI. 

1. Log in with a Microsoft Windows System Administrator account. 

Terminal Mode 
2. Click Next.  

3. Enter the following information to configure the terminal mode. 

Field Value 

POS Interface  Enable 

OPI mode 
Port 

Terminal 
Terminal port 

 

 

Middleware Mode 
4. Click Next, and then configure the middleware mode by entering the following 

information. 

Field Value 

POS Interface Enable 

OPI mode Middleware 

PrimaryHost  Confirm with Oracle Consulting Team 
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BackupHost  
Proxy Address 
Proxy Port 

Confirm with Oracle Consulting Team 
Proxy Address if it is used 
Proxy Port 

4. Select POS Configuration, and then click Add New Property. 

5. Configure the merchant details using the following information, and then click 
Next. 

Temporary Table 

POS Type 
Port 

Simphony1 
5098 as defult 

Merchant ID  
Merchant Type 
PosCrossMerchant 
PosCrossCheck 

MID (same as the MGDH Merchant ID) 
Restaurant or Retail 
Disable 
Disable 

Merchant Name Merchant Name 

Merchant City Where merchant is located 

Merchant Country Merchant Country 

  
 

• If multiple merchants have multiple MID’s, refer to the steps above for Add 
New Property or contact the Oracle Consulting Team for assistance. 

• Merchant Name should be 5-25 letters, digits or special character [#.].. 
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4. Click Add Terminal, and then configure the Terminal with the following 
information: 

Field Value 

Workstation ID Workstation ID in EMC 

IP PINPad IP 
 

 
 

5. Click Next, and then click Exit. 

6. Click YES to save the configuration. 

7. Select Yes to restart the computer now or select No to restart the computer at a later 
time to complete installing and configuring OPI, and then click Finish. 
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