This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, then the following notice is applicable:

U.S. GOVERNMENT END USERS: Oracle programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, delivered to U.S. Government end users are "commercial computer software" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the programs, including any operating system, integrated software, any programs installed on the hardware, and/or documentation, shall be subject to license terms and license restrictions applicable to the programs. No other rights are granted to the U.S. Government.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

Intel and Intel Xeon are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. AMD, Opteron, the AMD logo, and the AMD Opteron logo are trademarks or registered trademarks of Advanced Micro Devices. UNIX is a registered trademark of The Open Group.

This software or hardware and documentation may provide access to or information about content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services unless otherwise set forth in an applicable agreement between you and Oracle. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services, except as set forth in an applicable agreement between you and Oracle.

Value-Added Reseller (VAR) Language

Oracle Retail VAR Applications

The following restrictions and provisions only apply to the programs referred to in this section and licensed to you. You acknowledge that the programs may contain third party software (VAR applications) licensed to Oracle. Depending upon your product and its version number, the VAR applications may include:

(i) the MicroStrategy Components developed and licensed by MicroStrategy Services Corporation (MicroStrategy) of McLean, Virginia to Oracle and imbedded in the MicroStrategy for Oracle Retail Data Warehouse and MicroStrategy for Oracle Retail Planning & Optimization applications.

(ii) the Wavelink component developed and licensed by Wavelink Corporation (Wavelink) of Kirkland, Washington, to Oracle and imbedded in Oracle Retail Mobile Store Inventory Management.

(iii) the software component known as Access Via™ licensed by Access Via of Seattle, Washington, and imbedded in Oracle Retail Signs and Oracle Retail Labels and Tags.

(iv) the software component known as Adobe Flex™ licensed by Adobe Systems Incorporated of San Jose, California, and imbedded in Oracle Retail Promotion Planning & Optimization application.

You acknowledge and confirm that Oracle grants you use of only the object code of the VAR Applications. Oracle will not deliver source code to the VAR Applications to you. Notwithstanding any other term or condition of the agreement and this ordering document, you shall not cause or permit alteration of any VAR Applications. For purposes of this section, "alteration" refers to all alterations, translations, upgrades, enhancements, customizations or modifications of all or any portion of the VAR Applications including all
reconfigurations, reassembly or reverse assembly, re-engineering or reverse engineering and recompilations or reverse compilations of the VAR Applications or any derivatives of the VAR Applications. You acknowledge that it shall be a breach of the agreement to utilize the relationship, and/or confidential information of the VAR Applications for purposes of competitive discovery.

The VAR Applications contain trade secrets of Oracle and Oracle’s licensors and Customer shall not attempt, cause, or permit the alteration, decompilation, reverse engineering, disassembly or other reduction of the VAR Applications to a human perceivable form. Oracle reserves the right to replace, with functional equivalent software, any of the VAR Applications in future releases of the applicable program.
# Contents

**Send Us Your Comments** ........................................................................................................................................... ix

**Preface** ........................................................................................................................................................................... xi
- Audience ........................................................................................................................................................................ xi
- Documentation Accessibility ................................................................................................................................................. xi
- Customer Support ............................................................................................................................................................. xi
- Review Patch Documentation .............................................................................................................................................. xi
- Improved Process for Oracle Retail Documentation Corrections ................................................................................... xii
- Oracle Retail Documentation on the Oracle Technology Network ................................................................................. xii
- Conventions ........................................................................................................................................................................ xii

## 1 Introducing Oracle Retail Sales Audit (ReSA)

- **Purpose and Benefits of ReSA** ................................................................................................................................. 1-1
- **User Roles** ................................................................................................................................................................... 1-2
- **Integrating ReSA with Other Applications** ................................................................................................................ 1-2
- **Understanding ReSA Terminology** .......................................................................................................................... 1-2
- **Understanding the ReSA Process** ............................................................................................................................ 1-4

## 2 Introducing the Common User Interface Controls

- **Logging on to the Application** ....................................................................................................................................... 2-1
- **Using the Help** ............................................................................................................................................................... 2-2
- **Navigation Area** ............................................................................................................................................................ 2-2
  - Application Navigator .................................................................................................................................................. 2-3
  - Favorites ........................................................................................................................................................................ 2-3
  - Tasks .............................................................................................................................................................................. 2-3
- **Notifications** ................................................................................................................................................................... 2-4
  - Notification Badge ....................................................................................................................................................... 2-5
  - Notification Sidebar .................................................................................................................................................. 2-5
  - Search Bar ................................................................................................................................................................... 2-6
  - Filtering Panel ............................................................................................................................................................ 2-6
  - Grouping Panel ........................................................................................................................................................ 2-7
  - Results Panel - List View ........................................................................................................................................ 2-7
  - Results Panel - Grouped View .................................................................................................................................. 2-8
  - Results Panel - Summarized View ............................................................................................................................. 2-8
  - All Notifications Tab ................................................................................................................................................... 2-9
3 Setting up ReSA

Setting up System Administration Options in ReSA .................................................. 3-1
  Defining System Options ......................................................................................... 3-1
    Adding Escheatment Details ............................................................................... 3-4
    Defining Voucher Options .................................................................................. 3-4
Managing Data ............................................................................................................. 3-5
  Downloading Data ................................................................................................. 3-5
  Uploading Data ....................................................................................................... 3-6
Manage Employees ....................................................................................................... 3-7
  Adding an Employee ............................................................................................... 3-7
  Assigning Stores to an Employee ......................................................................... 3-7

4 Defining Totals

Creating a Total Definition ......................................................................................... 4-1
  Defining Basic Information for Totals ................................................................. 4-2
  Defining Attributes ............................................................................................... 4-3
  Defining Realms and Joins ................................................................................... 4-4
  Defining Parameters and Roll-Ups ...................................................................... 4-5
  Defining Restrictions ............................................................................................ 4-6
  Defining Combined Total Details ........................................................................ 4-7
  Defining Location Traits ...................................................................................... 4-7
  Defining Usages ..................................................................................................... 4-8
Managing Total Definition .......................................................................................... 4-8
  Creating a Total Definition .................................................................................. 4-8
  Creating a Combined Total .................................................................................. 4-9
  Viewing a Total Definition .................................................................................... 4-10
  Editing a Total Definition ..................................................................................... 4-11
  Changing the Status of Total Definition .............................................................. 4-11
Frequently Asked Questions ......................................................................................... 4-12

5 Importing Transactional Data

Managing POS/OMS Data in ReSA ............................................................................ 5-1
Transaction Types in ReSA .......................................................................................... 5-1
6 Defining Audit Rules

Understanding the Rule Maintenance Wizard ................................................................. 6-1
Defining Basic Information for Rules ............................................................................... 6-2
Defining Rule Attributes .................................................................................................... 6-3
Defining Realms and Joins ............................................................................................... 6-4
Defining Parameters .......................................................................................................... 6-5
Defining Restrictions ......................................................................................................... 6-6
Defining Location Traits ................................................................................................... 6-6

Managing Rules .................................................................................................................. 6-7
Creating Rule Calculation Definition ................................................................................ 6-7
Viewing Rule Calculation Definition ................................................................................ 6-7
Editing Rules Calculation Definition ................................................................................ 6-8
Changing the Status of Rules Calculation Definition ....................................................... 6-8

7 Auditing Transactional Data

Working with the Transaction Maintenance Module ......................................................... 7-2
Creating a Transaction ...................................................................................................... 7-3
Adding Item Information to a Transaction ........................................................................ 7-4
To add an item to a transaction .......................................................................................... 7-4
To add return reason code ............................................................................................... 7-5
To add customer order information to an item ................................................................. 7-5
To add price override information to a transaction .......................................................... 7-6
To add item details ............................................................................................................ 7-6
To add item discounts to a transaction ............................................................................ 7-6
Adding Reference Information to a Transaction ............................................................... 7-7
Viewing Transaction Audit Trails ..................................................................................... 7-7
Adding Comments to a Transaction .................................................................................. 7-8
Viewing Errors Associated with a Transaction ............................................................... 7-8
Refreshing the Errors ...................................................................................................... 7-9
Adding Tender Information to a Transaction ................................................................... 7-9
Adding Customer Information to a Transaction ............................................................. 7-10
Adding Paid Out Details to a Transaction ....................................................................... 7-11
Viewing a Transaction .................................................................................................... 7-11

Managing ACH Transactions ............................................................................................ 7-12
Viewing Bank ACH Transactions ..................................................................................... 7-12
Adding a Bank ACH Transaction Amount ...................................................................... 7-12
Deleting a Bank ACH Transaction Amount ..................................................................... 7-13
Viewing a Store ACH Transaction ................................................................................... 7-13
Adding a Store ACH Transaction Amount ........................................................................ 7-14
Deleting a Store ACH Transaction Amount ...................................................................... 7-14

Bank Stores Window ......................................................................................................... 7-14
Creating a Bank/Store Relationship ................................................................................ 7-14
Deleting a Bank/Store Relationship ................................................................................ 7-15

Viewing the Store Day Transactions ................................................................................ 7-15
Viewing Transaction Audit Trails ..................................................................................... 7-15
Viewing a Total Audit Trail ............................................................................................. 7-16
Searching for an Item Summary ................................................................................................... 7-17
Searching for General Ledger Transactions ............................................................................... 7-17
Searching for Tender Summary Information ............................................................................... 7-18
Managing Store Audit .................................................................................................................. 7-18
Searching for a Store Day .............................................................................................................. 7-18
Viewing a Store Day Information .................................................................................................. 7-19
Resolving Errors ............................................................................................................................. 7-19
Viewing Over/Short Totals Information .......................................................................................... 7-20
Viewing Miscellaneous Totals ......................................................................................................... 7-20
Managing a Missing Transaction .................................................................................................... 7-20
To edit a missing transaction ........................................................................................................... 7-20
To delete a missing transaction ......................................................................................................... 7-21
Viewing the Import/Export Log ....................................................................................................... 7-21
Deleting a Store Day ....................................................................................................................... 7-21
Reopening a Store Day .................................................................................................................... 7-21

8 Exporting Data

Exporting Audited Data ................................................................................................................ 8-1

9 Operational Insights Reports

Dashboard Reports ...................................................................................................................... 9-1
Open Store Days Report .............................................................................................................. 9-2
Top Ten Late Stores Report ......................................................................................................... 9-3
Open Transaction Errors Report ................................................................................................. 9-3
Over/Short Summary Report ........................................................................................................ 9-4
In-context Business Intelligence (BI) Reports .............................................................................. 9-5

In-context BI Reports on Store Day Search Window .................................................................. 9-5
Store Status History Report ....................................................................................................... 9-6
Error History Report ..................................................................................................................... 9-6
Over/Short History Report ............................................................................................................ 9-7
In-context BI Reports on Store Day Summary Window ............................................................... 9-7
Store Status History Report ....................................................................................................... 9-8
Error History Report ..................................................................................................................... 9-8
Cashier/Register Over/Short Report ............................................................................................... 9-9
In-context BI Reports on Transaction Maintenance Window .................................................... 9-10
Error History Report ..................................................................................................................... 9-10
Item Errors Report ......................................................................................................................... 9-11
In-context BI Reports on Tender Summary Window .................................................................... 9-12
Tender Summary Report .............................................................................................................. 9-12

Index
Send Us Your Comments


Oracle welcomes customers’ comments and suggestions on the quality and usefulness of this document.

Your feedback is important, and helps us to best meet your needs as a user of our products. For example:

- Are the implementation steps correct and complete?
- Did you understand the context of the procedures?
- Did you find any errors in the information?
- Does the structure of the information help you with your tasks?
- Do you need different information or graphics? If so, where, and in what format?
- Are the examples correct? Do you need more examples?

If you find any errors or have any other suggestions for improvement, then please tell us your name, the name of the company who has licensed our products, the title and part number of the documentation and the chapter, section, and page number (if available).

Note: Before sending us your comments, you might like to check that you have the latest version of the document and if any concerns are already addressed. To do this, access the Online Documentation available on the Oracle Technology Network Web site. It contains the most current Documentation Library plus all documents revised or released recently.

Send your comments to us using the electronic mail address: retail-doc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number (optional).

If you need assistance with Oracle software, then please contact your support representative or Oracle Support Services.

If you require training or instruction in using Oracle software, then please contact your Oracle local office and inquire about our Oracle University offerings. A list of Oracle offices is available on our Web site at http://www.oracle.com.
Preface

The Oracle Retail Sales Audit User Guide describes the application user interface and how to navigate through it.

Audience

This User Guide is for users and administrators of Oracle Retail Sales Audit. This includes merchandisers, buyers, business analysts, and administrative personnel.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Customer Support

To contact Oracle Customer Support, access My Oracle Support at the following URL: https://support.oracle.com

When contacting Customer Support, please provide the following:

- Product version and program/module name
- Functional and technical description of the problem (include business impact)
- Detailed step-by-step instructions to re-create
- Exact error message received
- Screen shots of each step you take

Review Patch Documentation

When you install the application for the first time, you install either a base release (for example, 16.0) or a later patch release (for example, 16.0.024). If you are installing the base release and additional patch releases, read the documentation for all releases that
have occurred since the base release before you begin installation. Documentation for patch releases can contain critical information related to the base release, as well as information about code changes since the base release.

**Improved Process for Oracle Retail Documentation Corrections**

To more quickly address critical corrections to Oracle Retail documentation content, Oracle Retail documentation may be republished whenever a critical correction is needed. For critical corrections, the republication of an Oracle Retail document may at times not be attached to a numbered software release; instead, the Oracle Retail document will simply be replaced on the Oracle Technology Network Web site, or, in the case of Data Models, to the applicable My Oracle Support Documentation container where they reside.

This process will prevent delays in making critical corrections available to customers. For the customer, it means that before you begin installation, you must verify that you have the most recent version of the Oracle Retail documentation set. Oracle Retail documentation is available on the Oracle Technology Network at the following URL:

http://www.oracle.com/technetwork/documentation/oracle-retail-100266.html

An updated version of the applicable Oracle Retail document is indicated by Oracle part number, as well as print date (month and year). An updated version uses the same part number, with a higher-numbered suffix. For example, part number E123456-02 is an updated version of a document with part number E123456-01.

If a more recent version of a document is available, that version supersedes all previous versions.

**Oracle Retail Documentation on the Oracle Technology Network**

Oracle Retail product documentation is available on the following Web site:

http://www.oracle.com/technetwork/documentation/oracle-retail-100266.html

(Data Model documents are not available through Oracle Technology Network. You can obtain them through My Oracle Support.)

**Conventions**

The following text conventions are used in this document:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface</strong></td>
<td>Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.</td>
</tr>
<tr>
<td><strong>italic</strong></td>
<td>Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.</td>
</tr>
<tr>
<td><strong>monospace</strong></td>
<td>Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.</td>
</tr>
</tbody>
</table>
Introducing Oracle Retail Sales Audit (ReSA)

In retail, the sales audit function describes the process of reviewing the Point-of-Sale (POS) and Order Management System (OMS) transaction data for accuracy. ReSA provides a simplified sales audit process while ensuring the integrity of audited data and smooth integration with other retail applications. The retail sales audit function also allows for balancing out cashiers, cash registers, or an entire store day. This process validates the totals from POS and OMS against the calculated totals of transactions. If these totals are not equal, you can report this variance as an over or short value.

ReSA is a part of the Merchandise Operations Management (MOM) product group, which helps retailers to reduce shrinkage, reduce integration costs, improve internal control, increase productivity, and improve visibility to sales. Using real time inventory information, this system calculates need based on set parameters for any product, store or other category. It also manages foundation data, purchasing and cost, inventory, price, and financial processes.

This chapter contains the following topics:

- Purpose and Benefits of ReSA
- User Roles
- Integrating ReSA with Other Applications
- Understanding ReSA Terminology
- Understanding the ReSA Process

Purpose and Benefits of ReSA

ReSA accepts POS and OMS data and provides audited data to downstream applications such as, Retail Management System (RMS), Retail Analytics (RA), Retail Store Inventory Management (SIM), and General Ledger applications. It allows a single entry point for sales data from external systems into Oracle Retail applications and other financial systems. It accepts and validates transaction data while detecting and correcting errors according to pre-defined rules which are both system defined and user defined. It allows users to view and audit data at the store/day level or the cashier/register level selected by the user. This process results in correct data that you can export to other applications.

ReSA reduces shrinkage because it provides regular comparisons of inventory levels and sales. It can isolate irregularities at the point of sale. It reduces the cost of integration between sales audit functionality and other applications such as the Oracle Retail Merchandising System (RMS) and Oracle Retail Analytics (ORA). Audited POS
and OMS data, exported from ReSA, provides a single version of data across downstream solutions. It can support reporting and analysis to help reduce losses.

**User Roles**

The user roles provide a means of grouping privileges together for granting access to a user. The retailer can modify the roles to suit their business needs. The following are the default roles set up in ReSA:

- **Sales Audit Analyst**
  
  A Sales Audit Analyst is responsible for the daily reporting of company sales, auditing, and verifying accuracy of store sales. They are also responsible for coordinating month end closure, ensuring department deadlines are met, assisting with quarterly general ledger reconciliations, and researching unusual transactions.

- **Sales Audit Manager**
  
  A Sales Audit Manager is responsible for a team of Sales Audit Analysts. They serve as the main point of contact and represent finance in meetings that involve POS register issues and sales processing procedures.

- **Finance Manager**
  
  A Finance Manager is responsible for the financial accounting of a region.

- **Sales Audit System Administrator**
  
  A Sales Audit System Administrator is responsible for maintaining the administrative functions of the application. They are also responsible for the sales audit system functioning such as employee maintenance and reference field maintenance.

---

**Note:** For more information on merchandising security, see the *Oracle Retail Merchandising Security Guide.*

---

**Integrating ReSA with Other Applications**

ReSA can integrate with the following applications:

- Oracle Retail Management System (RMS)
- Oracle Retail Invoice Matching (ReIM)
- Oracle Retail Analytics
- Oracle Retail Store Inventory Management (SIM)
- Oracle Retail Xstore Point Of Service

You can also set up ReSA to interface with third-party applications including general ledger applications or any financial institutions such as, Account Clearing House (ACH) Order Management System (OMS), and Universal Account Reconciliation System (UAR).

**Understanding ReSA Terminology**

The following is a list of terms used in ReSA:
Understanding ReSA Terminology

Introducing Oracle Retail Sales Audit (ReSA)

■ Store day: A Store Day is the time between opening the cash registers at the start of a business day and closing the registers at the end of the day.

A business day is a calendar day except for the retailers running 24x7 operations. The retailers who operate 24 hours a day and seven days a week may have their Store Day spread to more than one calendar day. ReSA uses the Day Close transactions from the POS application to define the close of business day.

■ Transaction: A transaction is a record of events at a location, which may include sale, return, and exchange of items. The following is an illustration of the list of attributes that a transaction record may contain:
  - Date and time of transaction
  - Salesperson ID
  - Register number
  - Cashier
  - Invoice number
  - Item details
  - Item quantity
  - Item taxes
  - Discounts
  - Transactional taxes
  - Tender details
  - Customer details
  - Paid out details

■ Revision: Revision is an archive of updates made to transactions. Before updating the current data in transaction tables, a snapshot of the data is maintained as revisions to historical data. This process includes the following steps:
  - Creating a new version of the transaction record.
  - Keeping the older version of the record unchanged.
  - Moving the older version of the transaction record to a revision table.

Moving the older version to a separate version history table maintains a complete audit trail and also minimizes the amount of data held in main transaction tables.

■ Escheatment: Escheatment is the process of forwarding money of outstanding, non-expiring vouchers to the proper governing authorities after a defined period of time from the date of issuance.

The Escheatment functionality in ReSA is driven by the hierarchy of Store, Issuer, Recipient, and HQ. When performing escheatment, ReSA checks to determine whether there is an address for the first level of the hierarchy, the Store. If so, it checks if the state or country is defined in the Escheatment table in ReSA. If the state or country exists on the table, it then checks to determine whether the Store indicator for that state or country is set to yes. If so, ReSA escheats the money to that state or country. If no state or country exists for the store, or one does but does not exist on the Escheatment table, or it does exist on the table but the Store indicator is set to no, then ReSA checks the next level, Issuer, and so on. If no
matches are found after ReSA checks all four levels of the hierarchy, then the retailer claims the voucher as income.

- **Full disclosure**: A method of restating data by sending a negation of the entire first statement, then a second complete statement.

- **Totals**: A summation of one or more entities that are captured in the POS or OMS system and imported into ReSA. For example, summation of the quantity of items sold in a store during a particular store day. Totals are used to perform store balancing, perform analysis within the ReSA system to control losses, generate reports, and to export audited data to external systems. Totals can either be defined in ReSA or imported as reported by POS or OMS.

- **Report data**: Allows you to generate reports, such as, the Flash Sales Report and the Flash Totals Report.

- **ReSA status**: ReSA maintains status at three different levels, store status, data status, and audit status. The status associated with Stores level indicates the status of the store, like worksheet, fuel closed and closed. The status associated with Data level indicates the progress of data upload, like ready to load, loading, partially loaded, fully loaded, and purging. The status associated with Audit level indicates whether the sales data is audited, or is in the process of auditing, or if errors were identified at the store or headquarter for correction.

**Understanding the ReSA Process**

The ReSA process includes the following procedures:

1. **Setting up ReSA** – For more information, see Chapter 3, "Setting up ReSA".
2. **Generating totals** – For more information, see Chapter 4, "Defining Totals".
3. **Defining audit rules** – For more information, see Chapter 6, "Defining Audit Rules".
4. **Importing data** – For more information, see the section on Importing Transactional Data in Chapter 5, "Importing Transactional Data".
5. **Auditing transaction data** – For more information, see Chapter 7, "Auditing Transactional Data".
6. **Exporting data** – For more information, see Chapter 8, "Exporting Data".
Figure 1–1 ReSA Auditing Process
Introducing the Common User Interface Controls

Oracle Retail applications, such as, Oracle Retail Sales Audit, include some common interface options and controls that you can use throughout the application workflow. The following sections describe these user interface controls in more detail.

Although you may have more than one Oracle Retail application installed on your system, each application may use many of the same interface components and abide by common rules and constraints.

The following topics are covered in this chapter:

- Logging on to the Application
- Using the Help
- Navigation Area
- Specifying Preferences
- Table Menu Options
- Logging Out of the Application

Logging on to the Application

To log on to the application:

1. Click the User list menu on the top right of the Oracle Sales Audit window.

   ![Figure 2–1 User List Menu](image)

2. Click Login. The Welcome screen appears.
Using the Help

This application contains an online HTML help that can guide you through the user interface. User information is included to describe high-level processes and procedures, as well as provide step-by-step instructions for completing a task.

You can access online help for a particular page by clicking on the Help link at the top of the application home page or by clicking the Help icon 📚. Once in the help, you can access additional information through the table of contents or by using the index.

Navigation Area

You can quickly access the tasks of current applications and switch to other applications from the Navigation bar.

The following Navigation bar options are common across all the applications:

- Application Navigator
- Favorites
- Tasks
- Notifications
- Reports
Application Navigator

The Application Navigator is optional for the application and provides the ability to switch between applications.

**Note:** Your view may vary, depending upon the features selected during the setup process.

To switch between applications:

1. At the top left of the application, click the Application Navigator icon to open the list of available applications.

   ![Application Navigator Icon](image)

   **Figure 2–4 Application Navigator**

2. Select the listed applications. The application will open in a new tab.

Favorites

You can select your favorite tasks without accessing the Tasks menu. It helps you quickly get into your frequently used tasks.

You can click the Favorites icon in the Tasks menu to access tasks designated as favorites. You can also select the cog icon from the Favorites menu to edit the favorite list. Tasks can be selected or deselected as favorites in the Tasks menu.

![Favorites Icon](image)

**Figure 2–5 Favorites Area**

Tasks

Oracle Retail applications support a variety of navigational tools and methods that allow you to move efficiently between application pages. Information on how to use and manage each of the tools and methods is included in this section.

A task is a set of links to a series of task flows organized in a specific sequence to accomplish a business process or procedure. For example, tasks can be defined for common multi-step procedures or processes so that you can quickly step through tasks. By navigating sequentially to the pages outlined in the task, you are assisted in stepping through the business process or activity.
Your Tasks list appears on the extreme left side of the home page. All of the tasks to which you have access appear in the list on the Tasks window. You can either click on the specific task name to open or use the Task Search component to search for a Task that you want to open.

To begin working with a task, choose the application feature or process from the list.

**Note:** Your Tasks menu may appear slightly different, depending on your retail application.

![Tasks Menu](image)

**Notifications**

Notifications bring events within the application to your attention. See the following examples:

- A simple, informative message indicating a long-running process has completed
- A message indicating a critical exception has occurred
- The data upload request failed
Figure 2–7  Notifications

Notification Badge
The Notification Badge displays the number of unread notifications for the user in the sidebar menu. The Notification Badge displays ‘99+’, when there are more than 99 notifications.

The notification count is periodically refreshed at regular intervals. This interval is determined by a system-configured value.

Figure 2–8  Notification Badge

Notification Sidebar
When you click the Notification icon, the Notifications Sidebar is shown displaying the most recent set of unread notifications (depending on the filter set).
Each component of the Notifications Sidebar is discussed in detail in the following sections:

**Search Bar**
A search bar at the top of the panel allows for searching through notifications. The search bar has auto-suggest enabled, so it displays notifications as the user types.

Right next to the search bar is the 'List/Group' view toggle button. This causes the Notification results to be displayed either in a flat or grouped view.

**Filtering Panel**
The Filtering Panel allows you to filter notifications based on Creation time, Severity and Type.

The values for the Time Periods and Severity components are pre-seeded constants. The Type drop-down lists all the notification types available in the system.

When you click the **Apply** button, notifications that match the criteria are shown in the Results Panel.
Introducing the Common User Interface Controls

Figure 2–11  Filtering Panel

Grouping Panel
This panel allows you to group notifications based on different attributes. The values of the 'Group by' and the 'Then by' components are pre-seeded.

Figure 2–12  Grouping Panel

Results Panel - List View
When no selection is made in the Grouping Panel, the Results Panel displays notifications in a list format.

The image below shows a simple search without any filtering or grouping.

Figure 2–13  Results Panel - List View

1. Indicates that no filtering was done.
2. Notification Type - A description of the Type is displayed.
3. Read/Unread - A blue icon is shown next to the notification if it is unread.
4. Notification Severity - A colored label indicating the severity of the notification is shown.
5. **Description** - The description associated with the notification. If the notification was designed to launch into a relevant flow, then this is displayed as a link. Otherwise, the description is rendered as plain text.

6. **Creation Time** - A timestamp that shows the date and time at which the notification was created.

7. **User name** - Creator of the notification.

**Results Panel - Grouped View**

Notifications are displayed in a grouped format within the Results Panel, when the Group By drop-down in the Grouping Panel is selected.

Notifications are displayed in groups with three notifications shown for each group.

![Figure 2–14 Results Panel - Grouped View](image)

1. Indicates the Group-By drop-down is selected on the Grouping Panel.

2. The value of the Group-By attribute. In this example, the results were grouped by Notification Type. Hence the Notification Type is shown as the header of the group.

For each group, three notifications are shown followed by a ‘See More’ link. When you click this link, up to 25 notifications are displayed for that group.

**Results Panel - Summarized View**

Notifications are summarized as shown in this example, when both the Group By and the Then By drop-downs in the Grouping Panel are selected.

The summary view displays various groups and within them subgroups based on the selections on the Grouping Panel. For each subgroup, a count of the notifications within that subgroup, grouped by severity is displayed.

The example below depicts a grouping by department, then by class.
1. Indicates that both options on the Grouping Panel have been selected.
2. First level of grouping is by Department. Here the first department shown is ‘dept1’.
3. The subgroup within department ‘dept1’. In this example, this is the Class name.
4. The number of notifications within that combination of Group and Subgroup.
5. A grouping by severity of all notifications within that combination of Group and Subgroup.
6. The timestamp of the most recent notification of that combination of Group and Subgroup.

**All Notifications Tab**
The All Notifications tab is shown when you click the ‘See All’ link at the bottom of the Notifications side panel.
This tab lists all the Notifications for the logged-in user, regardless of whether they are in Read or Unread status. Information tiles display a break-up of the total notifications by severity. Clicking these tiles refreshes the table below to display only those notifications that are relevant to that tile.

You can perform the following operations from this tab.

- **Delete** - The table allows for multiple selection and hence multiple notifications can be deleted at a time. Use the row header to select the row.
- **Refresh** - This refreshes the list of notifications in the table.
- **Mark as Read** - Multiple Unread Notifications can be marked as Read by clicking this button.
- **Mark as Unread** - Multiple Read Notifications can be marked as Unread by clicking this button.
- **Reassign Notifications** - Notifications can be reassigned to individual recipients or a group by clicking the Reassign Notifications icon. On selecting a row in the All Notifications table, and clicking the icon, the reassign notification popup is displayed. The Type is set to Reassigned by default, and the Severity and Description are pre-populated from the selected row; you can then change any of these values and assign the notification to one or more recipients.
The All Notifications table displays the following columns:

- **Notification Severity** - A colored label indicating the Notification Severity.
- **Status** - If the status is unread, an icon 🔄 is shown. Otherwise it is blank.
- **Description** - The description of the notification itself.
- **Type** - The description of the Notification Type for the notification.
- **Recipients** - In case of individual notifications, this column contains the user ID of the user to whom the notification is assigned. When the notification is assigned to multiple users, it displays the text ‘Multiple’ and enables a context popup which lists all the recipients. This field is empty when the notification is assigned to a group associated with a type.
- **Creation Date** - Timestamp showing the date and time of creation.
- **Created By** - User ID of the user who created the notification.
- **Last Updated Date** - Timestamp showing the date and time when the last update was made.
- **Last Updated By** - User ID of the user who last updated the notification.
- **Application ID** - Unique identifier that identifies the application. Not visible by default.
- **Department** - The Department associated with the notification. Not visible by default.
- **Class** - The Class associated with the notification. Not visible by default.
- **Subclass** - The Subclass associated with the notification. Not visible by default.
- **Location** - The Location associated with the notification. Not visible by default.
- **Supplier** - The Supplier associated with the notification. Not visible by default.
- **Performance** - The Performance value associated with the notification. Not visible by default.
- **Brand** - The Brand associated with the notification. Not visible by default.
- **Rollup Count** - The Rollup Count associated with the notification. Not visible by default.
Specifying Preferences

- Additional Information - Refers to the Additional Information attribute associated with the notification. Not visible by default.

Reports

The functionality of Reports works similar to the Tasks menu.

Figure 2–18 Reports

Specifying Preferences

The Preferences pages are where you specify the default regional, language, and accessibility settings that you want to use throughout the system.

To set your preferred preferences, click user name > Preferences at the top of the application home page. The Preferences page appears. The standard preference options available are as follows:

- Regional
- Language
- Accessibility

To return to the application home page, click Back to Home at the top of the page. The Preferences pages are where you specify the default regional, language, and accessibility settings that you want to use throughout the system.

Regional Options

Use the following options to specify the default formats for territory, date, time, number, and time zone you want to use throughout the system.

Table 2–1 Regional Options

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Territory</td>
<td>Specify the country details.</td>
</tr>
<tr>
<td>Date Format</td>
<td>Select the date format that you want to use.</td>
</tr>
<tr>
<td>Time Format</td>
<td>Select the time format that you want to use.</td>
</tr>
<tr>
<td>Number Format</td>
<td>Select the number format that you want to use.</td>
</tr>
<tr>
<td>Time Zone</td>
<td>Select the time zone you want to use.</td>
</tr>
</tbody>
</table>
Language Options

Use the following options to specify the default language you want to use throughout the system.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Specify the default language you want to use.</td>
</tr>
<tr>
<td>Current Session</td>
<td>Specify the language you want to use for the current session.</td>
</tr>
</tbody>
</table>

Accessibility Options

Use the following options to specify the default accessibility preferences you want to use throughout the system.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessibility</td>
<td>Select the accessibility option you want applied.</td>
</tr>
<tr>
<td>Color Contrast</td>
<td>Specify the color contrast that you want to use.</td>
</tr>
<tr>
<td>Font Size</td>
<td>Specify the font size that you want to use.</td>
</tr>
</tbody>
</table>

Table Menu Options

Note:
- Figure 2–19, Figure 2–20, Figure 2–21 are mere representation and may be different for every window/table/popup.

The Actions menu, View menu, and icons are displayed in the form of a table. For more information on these options, see the sections Action Menu and Icons and View Menu.

Action Menu and Icons

The Actions menu provides the option to take different actions related to entries in the table. Depending on the nature of the table, these actions can be add, view, delete or edit table rows, create by moving to a new screen or export the table contents to the spreadsheet. Alternatively, these actions can also be performed by using the icon buttons on the table toolbar. For more information on the icon/buttons, see the Screen Level Action - Icons and Buttons.

In some tables, it may also contain some table specific actions.
Table Menu Options

Figure 2–19 Actions Menu and Icons of Components Section

Table 2–4 Actions Menu/Icons and Descriptions of Components Section

<table>
<thead>
<tr>
<th>Actions Menu/Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add and Add icon ✦</td>
<td>You can add a component by clicking Add from the Actions menu or by clicking the Add icon ✦. For more information on adding a component, see Chapter 7, section To add an item to a transaction.</td>
</tr>
<tr>
<td>Edit and Edit icon ✒</td>
<td>You can edit a component by clicking Edit from the Actions menu or by clicking the Edit icon ✒. For more information on editing a component, see Chapter 4, section Editing a Total Definition.</td>
</tr>
<tr>
<td>Delete and Delete icon ✗</td>
<td>You can delete a component by clicking Delete from the Actions menu or by clicking the Delete icon ✗. For more information on deleting a component, see Chapter 7, section Deleting a Bank ACH Transaction Amount.</td>
</tr>
<tr>
<td>Export to Excel icon ✎</td>
<td>You can save the table to a Microsoft Excel spreadsheet by clicking the Export to Excel option from the Actions menu or by clicking the Export to Excel icon ✎.</td>
</tr>
<tr>
<td>Wrap icon ✉</td>
<td>You can wrap the values in the table column by using the Wrap icon ✉ option.</td>
</tr>
</tbody>
</table>

Figure 2–20 Actions Menu and Icons of Audit Rule Search

Table 2–5 Actions Menu/Icons and Descriptions of Audit Rule Search

<table>
<thead>
<tr>
<th>Actions Menu/Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and Create icon CREATE</td>
<td>You can create an audit rule by clicking Create from the Actions menu or by clicking the Create icon CREATE.</td>
</tr>
<tr>
<td>Edit and Edit icon ✒</td>
<td>You can edit an audit rule by clicking Edit from the Actions menu or clicking the Edit icon ✒.</td>
</tr>
<tr>
<td>View and View icon ✧</td>
<td>You can view an audit rule by clicking View from the Actions menu or clicking the View icon ✧.</td>
</tr>
</tbody>
</table>
Introducing the Common User Interface Controls

Table 2–5  (Cont.) Actions Menu/Icons and Descriptions of Audit Rule Search

<table>
<thead>
<tr>
<th>Actions Menu/Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export to Excel icon [ ]</td>
<td>You can save the table to a Microsoft Excel spreadsheet by clicking the Export to Excel option from the Actions menu or by clicking the Export to Excel icon [ ].</td>
</tr>
<tr>
<td>Wrap icon [ ]</td>
<td>You can wrap the values in the table column by using the Wrap icon [ ] option.</td>
</tr>
</tbody>
</table>

View Menu

The View menu provides the options for managing the table columns and sorting and filtering the table data.

In some tables you have the option to choose a saved custom view, which is an arrangement of columns different from the default view of the table.

Figure 2–21  View Menu of Components Section

Table 2–6  Components Section - View Menu and Descriptions

<table>
<thead>
<tr>
<th>View Menu List</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns</td>
<td>You can manage which of the columns will be shown in the table by clicking the Show All and Manage Columns options.</td>
</tr>
<tr>
<td>Detach</td>
<td>You can view the tables in the application in a separate window by clicking Detach or by clicking the Detach icon [ ].</td>
</tr>
<tr>
<td>Sort</td>
<td>You can sort columns by the following options:</td>
</tr>
<tr>
<td>■ Ascending</td>
<td></td>
</tr>
<tr>
<td>■ Descending</td>
<td></td>
</tr>
<tr>
<td>■ Advanced</td>
<td></td>
</tr>
<tr>
<td>Reorder Columns</td>
<td>You can reorder columns by clicking the Reorder Columns option.</td>
</tr>
<tr>
<td>Query by Example</td>
<td>You can filter components by one of multiple column values by clicking the Query by Example option or by clicking the query by example icon [ ].</td>
</tr>
</tbody>
</table>

Screen Level Action - Icons and Buttons

The screen level actions display the icons and buttons.

Figure 2–22  Screen Level Action - Icons and Buttons
### Table 2–7  Screen Level Action - Icons/Buttons and Descriptions

<table>
<thead>
<tr>
<th>Icon/Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help icon</td>
<td>You can access online help for a particular page by clicking the Help icon.</td>
</tr>
<tr>
<td>Expand and Collapse icon</td>
<td>You can view all and collapse all the sections in the application window by clicking the Expand and Collapse icon.</td>
</tr>
<tr>
<td>Delete icon</td>
<td>You can delete a component by selecting the Delete icon.</td>
</tr>
<tr>
<td>Status Action Button</td>
<td>Depending on the status of your record, the status action button displays. For example, Submit. Wherever applicable, this button will be available to change the status of an entity. The status will be changed to the label specified on the button. If there is more than one status to which the entity can be changed, clicking the arrow on the right side of the button will display the additional status options.</td>
</tr>
<tr>
<td>More Actions</td>
<td>The More Actions button will have any additional actions and options for navigating to other screens.</td>
</tr>
<tr>
<td>Save</td>
<td>Click Save to save the entered records.</td>
</tr>
<tr>
<td>Save and Close</td>
<td>Click Save and Close to save the records and exit the window.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to reject your entries and exit the window.</td>
</tr>
</tbody>
</table>

### Logging Out of the Application

Use the User list menu, which is to the top right of the Oracle Retail Sales Audit window, to log out of the application.

**Figure 2–23  Logging Out of the Application**
Before you proceed with processing the raw transaction data, you need to set up system options to allow importing and exporting data from ReSA. This chapter covers the following topics:

- Setting up System Administration Options in ReSA
- Managing Data
- Manage Employees

## Setting up System Administration Options in ReSA

Use the system administration module of the ReSA application to customize information for your organization.

You can change system options to configure system validations around escheatment, voucher options, and information related to the Automated Clearing House (ACH).

## Defining System Options

You can customize various parameters, defaults, and constants that are used throughout the system. Normally, these elements are set when ReSA is installed by the system or database administrator. They tend to remain fixed unless a business practice is changed which necessitates a change in ReSA.
A System Administrator can set the following system options in ReSA.

- **Balancing Level**: Define the level (Cashier, Register, and Store) at which the system totals are summarized and reconciled against the reported value.
- **Locking Level**: Defines the level at which locking is done in ReSA. It can be done either at the Store Day level or at the Transaction level.
- **Unit of Work**: Defines the level at which transactions are processed within ReSA. It is used to determine when to export data to external systems, and it needs to indicate that a transaction or store day must be free of any errors that prevent export.
  - For Transaction level, an individual transaction is exported from ReSA as soon as it is validated.
  - For Store Day level, the data imported in ReSA is exported only once the entire store day is processed.
- **Maximum Number of Days Sales Audit Data Stored**: Defines the number of days for which the audited data is stored in the ReSA system.
- **Maximum Number of Days Post-Dated Transactions Allowed**: Define the number of days after a store day has elapsed, within which backdated transactions will be permitted for upload into the system.
- **Maximum Number of Days to Compare Duplicates**: Defines the number of previous days over which the ReSA system should look for duplicate transactions.
- **Inventory Reservation for Layaway**: Specifies whether the inventory for Layaway orders is reserved.
- **Inventory Reservation from SIM**: Specifies whether the inventory reserve for customer orders will come from SIM or ReSA will generate the flat file for RMS.
- **Determine Comp Store Status By**
- **Date**: Indicates which of the three following dates (Store Open Date, Acquire Date and Remodel Date) that form a part of the store definition, will be used as the basis for determining whether a store qualifies as a comparison store or not.

- **Elapsed Days**: Indicates that the number of days that must have passed since the "Comparison Store Basis Date" for a store to qualify as a comparison store.

**ACH Information**

- **Sender ID**: Contains the ID used by the originator to identify itself to the Originating Financial Depository Institution (ODFI).

- **Company ID**: Contains the alphanumeric code to identify the company. The first character may be the ANSI one-digit Identification Code Designators (ICD). For example, 1 IRS Employer ID Number or 9 User Assigned Number.

- **Consolidating Bank**
  
  - **Name**: Contains the name of the Originating Financial Depository Institution (ODFI), it is the name of the central bank at which funds from all branches are collected.
  
  - **Routing**: Contains the routing number of the consolidating bank.
  
  - **Account**: Contains the account number of the consolidating bank.

**Execute Automated Audit After Import**: Indicates whether the automated audit should run after each import or if the ReSA system should wait until the transaction data for the entire store day is loaded.

**Store Days Must Be Worked in Order**: Indicates whether the ReSA system can close a current day if the previous day is still open.

**Check for Duplicate and Missing Transactions**: Indicates whether the ReSA application should look for duplicate and missing transactions. ReSA can accept duplicate transaction numbers from OMS and POS. If this field is set as ‘Y’, then ReSA filters duplicate transactions when the transaction is originating from the same system. Whereas, if the transaction is originating from a different system, then a different sequence number is inserted in the record.

**Transaction Appended with Workstation ID**: Indicates whether ReSA should append the workstation ID of the employee with their employee ID.

**Cash Management**: Indicates whether Cash Management will be used within the system. Valid values are ‘Y’ and ‘N’.

**Partner ID**: Specify whether the partner ID is unique across all partner types.

**Partner for Income Adjustments**: Specify the type of the partner the deal applies to. Valid values are: S1 for supplier hierarchy level 1, S2 for supplier hierarchy level 2, and S3 for supplier hierarchy level 3.

**Credit Card Masking Character**: Specify the masking character used for credit/debit card numbers.

**Default Chain**: Defines the primary chain.

**Fuel Merchandise**: Specify whether items for audit include fuel items.

**Fuel Department**: If the items for audit include fuel item, specifies the department the fuel items reside in.

**Escheatment Details**: Specify whether you would like to escheat vouchers (such as, gift certificates and credit vouchers) back to the state after a defined period of
time. The value in the Escheatment field depends on the laws of the state/area where your organization’s headquarters is located.

**Adding Escheatment Details**
To add Escheatment details:

1. From the Tasks menu, select **Foundation Data > Application Administration > System Options**. The System Options window appears.
2. In the Escheatment section, select **Yes** in the **Escheat to Government Authorities** field.
3. Select the appropriate option in the **Partner for Income Adjustment** field.
4. In the Escheatment Details section, select **Actions > Add**. Add Escheatment Details window appears.
5. In the Escheat To field, select either Country or State.
   - If you select country, in the Country field, enter the country code, or select the country.
   - If you select state, in the Country and State fields, enter the country and state codes, or select them from the list.

**Figure 3-2  Add Escheatment Details Window**

6. In the **Escheat To Location Of** field, select the location to which the escheatment should be applied.
7. Click **OK** to save your changes and close the window.

**Defining Voucher Options**
To define Voucher Options:

1. From the Tasks menu, select **Foundation Data > Application Administration > System Options**. The System Options window appears.
2. In the Vouchers section, select **Actions > Add**. The Add Voucher Options window appears.
3. In the **Tender Type** field, select the tender type.
4. In the **Escheat No. Days** field, enter the desired number of escheatment days.
5. In the **Purge No. Days** field, enter the number of days a voucher will be valid before it is purged from RMS.
Managing Data

ReSA allows the setup and configuration of a set of standard templates which allow you to upload and update data using spreadsheets. These spreadsheets can be uploaded to the system using the Upload Data window.

The following process is followed to update data for the above ReSA modules:

1. Download the spreadsheet template for the module you want to update using the Download Data window.
2. Make the updates in the spreadsheet.
3. Upload the data using the Upload Data window.

Downloading Data

To download data as spreadsheets:

1. From the Tasks menu, select Foundation Data > Data Loading > Download Data. The Download Data window appears.
2. In the Template Type field, select the type of template. The following template types are available:
   - Error Codes
   - GL Cross Reference
   - Reference Fields
   - Currency Rounding Rules
   - Store Data
   - Tender Types
   - Constants
3. In the Template field, select the template you want to download.

6. Click OK to save your changes and close the window.
Managing Data

4. Click **Download**.

### Uploading Data

To upload data using spreadsheets:

1. From the Tasks menu, select **Foundation Data > Data Loading > Upload Data**. The Upload Data window appears.

2. In the **Template Type** field, select the type of template.
   
   The following template types are available:
   
   - Error Codes
   - Reference Field
   - Currency Rounding Rules
   - GL Cross Reference
   - Store Data
   - Tender Types
   - Constants

3. In the **Template** field, select the template of the spreadsheet.

---

Figure 3–4  Download Data Window for a Template Download from ReSA

Figure 3–5  Upload Data Window for a Template Upload into ReSA
4. Enter a process name in the Process Name field. The value specified in this field enables you to find the process created to identify the status of the upload and view any errors that were identified.

5. Select the spreadsheet to be uploaded in the Source File field.

6. Click Upload. The relevant data corresponding to the template is uploaded into the spreadsheet file specified.

Manage Employees

The Employees window is used for associating auditors with the locations based on location traits in the system. This window has two tables, the Employees table and the Assign Stores by Location Traits table. Data displayed in the Assign Stores by Location Traits is based on the records elected in the Employees table. The Employees table displays the Employee ID and the associated display name from the LDAP.

Figure 3–6 Employees Window

Adding an Employee

To add an employee:

1. From the Tasks menu, select Foundation Data > Application Administration > Employees. The Employees window appears.

2. In the Employees table, select Actions > Add. The Add Employee window appears.

3. Enter the employee name in the Employee field.

4. Click OK. If the employee exists in LDAP, the employee name is added.

Assigning Stores to an Employee

After an employee is added, you must assign stores using a location trait to the employee.

To assign a location trait:

1. From the Tasks menu, select Foundation Data > Application Administration > Employees. The Employees window appears.

2. Select an employee from the Employees table.
3. In the Assign Stores by Location Traits table, select **Actions** > **Add**. The Add Location Trait window appears.

4. Select the location trait in the Location Trait field.

5. Click **OK**. The location trait is assigned to the selected employee.
A total is a summation or count of two or more entities. For example, a total can be a summation of the quantity of items sold in the store on a particular store day.

You can use the Totals Definition Maintenance module of ReSA to define the totals, these totals can either be imported as transactional data from the POS/OMS system into ReSA through a RTLOG file or calculated by ReSA.

For more information on importing data through an RTLOG file, see Chapter 5, "Importing Transactional Data".

Source data can include transaction data and external data, such as money order totals or lottery ticket sales. You can choose the tables and columns for the total, build query statements to yield the desired information, and associate these totals with categories, such as stores or POS values.

You can use totals for the following:

■ Evaluating and consolidating data
■ Determining whether transactions meet defined tolerances
■ Determining over or shorts exported to external systems

Once the totals are calculated, you can export them to an external application.

This chapter contains the following topics to help you understand and manage total definition:

■ Creating a Total Definition
■ Managing Total Definition
■ Frequently Asked Questions

Creating a Total Definition

The Total Maintenance wizard allows you to create and update a total definition. It involves a series of steps where various details such as, total type, total entity, data source, roll up level, total usage can be specified. Each window in the wizard has a text box to the right that displays help text for each field. You should understand the following concepts before you create or update a total:

■ Revision Number

Each total definition is assigned a revision number because updates to the total definitions are saved as new revisions and the existing definition record is not updated. This allows you to maintain a full audit trail and ensures that if an export
is restarted after the total definition has changed, the system still has the total definition of the original export.

- **Status**

  Each total definition is assigned a status. Based on the status of the total, the values it produces are stored in respective tables. For example, if a total definition is in Worksheet status, the values it calculates are written to the specific tables. This allows you to test total definitions to ensure the definition meets the functional need before introducing the total into the main test or production system.

### Defining Basic Information for Totals

*Figure 4–1  Total Window*

The Overview window allows you to enter basic information for a total. You can enter the following information on the Overview window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>A unique ID and a description for the total. It is recommended that you add a description that is relevant to the objective you are trying to achieve with this total.</td>
</tr>
<tr>
<td>Description</td>
<td>A description for the total, any alpha numeric value is acceptable in this field.</td>
</tr>
<tr>
<td>Start Date and End Date</td>
<td>The period for which the total is active.</td>
</tr>
<tr>
<td>Update Date/Time</td>
<td>The system time when the total was last updated. This field is system generated and you cannot edit it.</td>
</tr>
<tr>
<td>Total Category</td>
<td>A grouping mechanism that helps to organize totals for display on the Over/Short and Miscellaneous Total windows. It does not influence the total in any way. It only helps to organize the total values for display. It determines the screens on which the total values are displayed. For over/short totals, you must specify an Over/Short Group and an Over/Short Operator.</td>
</tr>
</tbody>
</table>
Creating a Total Definition

Defining Totals

4-3

Defining Attributes

Figure 4–2 Attributes Window

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Over/Short Group</td>
<td>Determines if the total values are ‘Accounted For’ (actual in hand money) or ‘Accountable For’ (based on transaction data, money the store should have).</td>
</tr>
<tr>
<td>Over/Short Operator</td>
<td>Used to determine whether the values produced by the total are added or subtracted from either the ‘Accounted For’ or ‘Accountable For’ groups.</td>
</tr>
<tr>
<td>Raw Data or Existing Total</td>
<td>A raw data total is defined using transaction data in the database. A combined total is defined by combining existing totals. While creating a raw data total, the total definition involves building an SQL statement.</td>
</tr>
</tbody>
</table>

The Attributes window allows you to identify from where can the values for this total come from. The following are the options on the Attributes window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Corresponds to a value from the RTLOG</td>
<td>Determines whether the total is uploaded from the POS/OMS through an RTLOG file.</td>
</tr>
<tr>
<td>System calculated value</td>
<td>Determines whether the total is calculated by the system. For system calculated totals, you must either build a SQL statement or define a total through total maintenance wizard.</td>
</tr>
<tr>
<td>Count or sum</td>
<td>Determines whether the total values represent a number of occurrences (count) or an amount resulting from them (sum).</td>
</tr>
<tr>
<td>Store or system balancing level</td>
<td>Determines whether one value for the total is produced per store, or if one value is produced per cashier/store (if the balancing level is cashier) or per register/store (if the balancing level is register).</td>
</tr>
<tr>
<td>Created with the wizard</td>
<td>Determines whether the wizard is used to actually write the code for the total definition.</td>
</tr>
</tbody>
</table>
Defining Realms and Joins

The Realms section allows you to add existing realms (tables) to the total. The list of available realms is displayed in the window.

Availability of realms is determined by whether possible joins exist with the realms that are already added to the total definition (the wizard does not allow incomplete joins that create Cartesian products).

In general, you should add the general/parent tables, and then add the specific/child tables. If at any time, a realm that you want to use is unavailable, you should remove the realms already added to the total, and try again in another order.

The Joins section displays how the realms are joined together. These joins are based on metadata defined in the system.
Defining Parameters and Roll-Ups

The Parameters section allows you to choose the parameters for the total definition. You can only choose parameters (columns) that are available in one of the realms that were previously added to the total definition.

Begin by choosing one of the realms. The parameter list then displays a list of all of the parameters that belong to the selected realm. You must choose the parameter that you need to count or sum and any other parameters that may be used to limit the data set.

The Roll Ups section allows you to define the parameter that is counted (or summed). It also allows you to define up to three parameters to group by. Only parameters that were previously added to the total definition can be either counted (summed) or grouped by. The system by default rolls up the totals to either store or balancing level (cashier/register) level based on whether the total is defined at the store level or cashier/register level.
Defining Restrictions

The Restrictions window allows you to limit the data set that is included in the total values. You can only restrict with parameters that were previously added to the total definition.

**Restrict Results By Table Values**

Restricting allows you to make numerical as well as logical comparisons on the set of parameter values that have been added earlier to the total definition.

**Restrict Results By Constant Values**

Restricting by a constant value allows you to define totals that only apply to a simpler data set that can be identified by a constant.
Defining Combined Total Details

Figure 4–6  Combined Total Details

The Combined Total Details window allows you to combine two existing totals. In order to be combined, the totals must be compatible. To be compatible, totals must be defined at the same balancing level and have the same roll-ups.

Defining Location Traits

Figure 4–7  Location Traits Window

The Location Traits window allows you to associate total definitions with stores. The totals are calculated for each store that has the location trait. If multiple traits are added and have overlapping stores, the total is calculated once per store.

Location Traits are defined in RMS. It is recommended that when ReSA is used, you create an All Stores location trait and associate that trait with all available stores. While
some regional or loss prevention totals can be associated with limited groups of stores, you must associate other totals (such as, Over/Short) with every store that uploads data to ReSA.

Defining Usages

**Figure 4–8 Usages Window**

The Usages window allows you to define what should be done with values calculated by the total definition. There is a usage for each export. Total definitions that have export usages flag their resulting total values so that these values are selected and written to the export files. There is a usage for the Flash Totals Report and a Flash Sales Year to Date report too.

Managing Total Definition

You can manage totals using the following procedures:

- Creating a Total Definition
- Creating a Combined Total
- Viewing a Total Definition
- Editing a Total Definition
- Changing the Status of Total Definition

Creating a Total Definition

To create a total definition:

1. From the Tasks menu, select **Create Total Definition**. The Total window appears.
2. In the **Total** field, enter the ID and description of the total definition.
3. In the **Start Date** and **End Date** fields, enter the dates for which the total definition is effective.
Note: If you leave the End Date field blank, the total is calculated indefinitely.

4. Select a category for the total in the **Total Category** field.
5. Click **Next** to navigate through the wizard. Help for the selected field and button appears in the section on the right side of the window. For more information about the fields on each window, see **Frequently Asked Questions**.

Note: Select **Raw Data** or **Existing Total** from the Total Overview panel to indicate how the total is defined. If you select Raw Data, you create a completely new rule. To do this, you need a thorough knowledge of the tables and columns in the database. If you select Existing Data, you create a sum of existing totals.

You must associate all totals defined with a specific location list. For more information, see **Defining Location Traits**

6. Click **Save** to create the total definition.

**Creating a Combined Total**

You can combine existing totals to form a combined total using the Combined Total Details window.

To create a combined total:

1. From the Tasks menu, select **Foundation Data > Create Total Definition**. The Total Maintenance window appears.
2. In the **Total** field, enter the ID and description of the total definition.
3. In the **Start Date** and **End Date** fields, enter the dates for which the total definition is effective.

Note: If you leave the End Date field blank, the total is calculated indefinitely.

4. Select a category for the total in the **Total Category** field.
5. Click **Next**. The Attributes window appears.
6. In the **Display Group** field, select the order in which the total appears on the Over/Short and Miscellaneous totals window.
7. Click **Next**. The Combined Total Details window appears.
8. Select **Actions > Add**. The **Add Total**s window appears.
9. In the **Operator** field, select the operator.
10. In the **Total** field, select an existing total.
11. Click **OK** to add the total. You can add more totals by clicking **OK and Add Another**.

12. Click **Next** to navigate through the wizard. Help for the selected field and button appears in the section on the right side of the window.

13. Click **Save** to create the combined total.

**Viewing a Total Definition**

To view a total definition:

1. From the Tasks menu, select **Foundation Data > Manage Total Definitions**. The Total Search window appears.
2. Enter additional criteria as desired to make the search more restrictive.
3. Click **Search**. The totals that match the search criteria are displayed in a table.
4. Select the total you want to view and from the Actions menu select **View**.
   The Total Maintenance window for the selected total appears.

**Editing a Total Definition**

To edit a total definition:

1. From the Tasks menu, select **Foundation Data > Manage Total Definitions**. The Total Search window appears.
2. Search for and select the total definition you want to edit.
3. From the **Action** menu, select **Edit** or click the Edit icon.
   The Total Maintenance window appears.
4. Select the page you want to edit.
5. Make the necessary changes and click **Save** to save the changes.

**Changing the Status of Total Definition**

The default status of a defined total is Worksheet. You can set the status of a total definition to one of the following actions:

- **Submit a total definition for approval**
  You can submit a total definition using the **Submit** option, this changes the status to Submitted.
- **Approve a total definition**
  When a total definition is submitted for approval, you can approve it by changing the status of the total to **Approved** by using the Approve option.
- **Disable a total definition**
  You can disable a total definition by changing the status to **Disabled** by using the Disable option.
- **Delete a total definition**
You can delete a total definition by changing the status to **Deleted** by using the Delete option. You cannot delete an approved total.

To change the status of a total definition:

1. From the Tasks menu, select **Foundation Data > Manage Total Definition**. The Total Search window appears.
2. Search for and retrieve the total definition in Edit mode. The Total Maintenance window appears.

   **Note:** If you want to submit a total definition for approval, restrict the search to the totals in **Worksheet** status.

3. From the Submit menu, select a status for the total. You can select from Submit, Approve, Disable, or Delete.
4. When the system prompts you for a confirmation of status, click **Yes**.
5. Click **Save and Close** to save your changes and close the window.

### Frequently Asked Questions

1. **What is the difference between a Total and an Audit Rule in ReSA?**
   Totals in ReSA can either come from the POS or other external systems through the RTLOG. ReSA can also calculate the total itself based on raw transaction data or existing totals. Totals are used in performing store balancing (over/short), analysis within ReSA and exporting the transactions as well as totals. Audit Rules are a set of rules defined by the ReSA user to detect any error or exception in the data imported from external systems. Based on the given conditions if a rule fails, the system generates an exception, the retailer defines if the error can be overridden as well as what systems the error impacts. This system impact prevents a bottleneck in the export process by only prohibiting the export of the transaction or total to the systems defined in the system impact. Even if the transaction or total is in error, ReSA still exports it to other systems as long as they are not defined in the system impact for the given error.

2. **On the Total Maintenance wizard in ReSA, is the question “Is this total a component of the Over/Short or Miscellaneous total?” only used to define on which total screen the defined total appears?**
   Yes, this is only used to define the window that displays the total, the Over/Short or the Miscellaneous Totals form. Auditors use Over/Short Totals to perform store balancing (tender balance).

3. **On the Total Maintenance wizard in ReSA, there is a question “Does this total correspond to a value in RTLOG?” Where is the total value displayed when this is set to ‘Yes’ or ‘No’?**
   If this is set to ‘Yes’, it indicates the total is expected in the RTLOG such as a Declared Tender Total; therefore, the value is displayed in the RTLOG Reported column.

   If this is set to ‘No’, it indicates that ReSA calculates this value based on either raw data or existing totals; therefore, the value is displayed in the System Calculated column.
4. On the Total Maintenance wizard in Retail Sales Audit (ReSA), there is a list box for Display Group and a Display Group Details button. What tables hold this information and what purpose do they serve?

The Display Group list box defines in what order the total is displayed on the defined form in ReSA. This information is held on the sa_total_head table in the display_order field.

The Display Group Details button displays all other totals that are defined to be displayed on the same form, total category and share the same display group setting for the given total. If more than one total has the same display order, then they are displayed alphabetically. This information is not held on one specific field, but rather queries multiple fields on the sa_total_head table.

5. What is the difference between Accounted For and Accountable For?

**Accounted For** – These totals represent what is physically counted in the till. (for example, total cash on hand, total checks).

**Accountable For** – These represent what should be in the till (for example, Sales, Returns). These totals can either come from the RTLOG or ReSA can calculate these totals. Auditors use Miscellaneous Totals for other types of analysis (for example, loss prevention totals), which can have no relevance to the Over/Short screen.

6. What is the impact on store days when a total is edited?

If you make any changes and re-approve the total, then all the store days that fall in the total date range gets re-audited when total is moved back from approved to worksheet.
Importing Transactional Data

ReSA accepts POS/OMS data as an RTLOG file. It then performs an initial validation on the data. This data is then loaded into the ReSA database tables. A batch process then audits the uploaded data. The store day records in ReSA are locked during validation to prevent any manual updates of the data. All errors are written to error tables.

The data import is considered complete once the batch process has updated the store data and audit status for each store day record.

This chapter contains the following topics to help you understand the import process:

- Managing POS/OMS Data in ReSA
- Transaction Types in ReSA

Managing POS/OMS Data in ReSA

The following is the process followed while importing data into ReSA.

1. Create a Store Day.
   ReSA requires a store day to process data from POS/OMS. The creation of store day for the current day automatically happens at the end of processing for the previous day.
2. Receive RTLOG from POS and OMS.
3. Filter the duplicate transactions received from POS and OMS.
4. Import RTLOG into ReSA.
   Run batch files to import the RTLOG files into ReSA.
5. Validate RTLOG with the reference data and configuration options during import.
6. Run audit rules and totals on the uploaded data.
7. Flag auditing failures as well as mismatched with reference data for manual audit.
8. Close store day once all RTLOGs for the business day are processed.
   It is necessary to close the Store Day in the POS system, to enable the HQ auditors to perform audit of the sales data after it is imported in the ReSA system.

Transaction Types in ReSA

The following is a list of valid ReSA transaction types.
<table>
<thead>
<tr>
<th>Transaction Code</th>
<th>Transaction Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPEN</td>
<td>Open</td>
</tr>
<tr>
<td>CLOSE</td>
<td>Register Close</td>
</tr>
<tr>
<td>COND</td>
<td>Daily Store Conditions</td>
</tr>
<tr>
<td>DCLOSE</td>
<td>Day close indicator</td>
</tr>
<tr>
<td>LOAN</td>
<td>Loan</td>
</tr>
<tr>
<td>METER</td>
<td>Meter Reading for Fuel</td>
</tr>
<tr>
<td>NOSALE</td>
<td>No Sale</td>
</tr>
<tr>
<td>PAIDIN</td>
<td>Paid In</td>
</tr>
<tr>
<td>PAIDOU</td>
<td>Paid Out</td>
</tr>
<tr>
<td>PULL</td>
<td>Pull</td>
</tr>
<tr>
<td>PUMPT</td>
<td>Pump Test for Fuel</td>
</tr>
<tr>
<td>PVOID</td>
<td>Post Void</td>
</tr>
<tr>
<td>REFUND</td>
<td>Return of customer’s original check</td>
</tr>
<tr>
<td>RETURN</td>
<td>Return</td>
</tr>
<tr>
<td>SALE</td>
<td>Sale</td>
</tr>
<tr>
<td>TANKDP</td>
<td>Tank Dip</td>
</tr>
<tr>
<td>TOTAL</td>
<td>POS generated totals</td>
</tr>
<tr>
<td>EEXCH</td>
<td>Even exchange</td>
</tr>
<tr>
<td>VOID</td>
<td>Void (aborted transaction)</td>
</tr>
<tr>
<td>OTHER</td>
<td>Other supported transactions</td>
</tr>
<tr>
<td>ERR</td>
<td>Error</td>
</tr>
<tr>
<td>TERM</td>
<td>Temporary transactions created by upload batches for validating file loading</td>
</tr>
</tbody>
</table>
As a retailer, you may want to supplement the validation built into ReSA by defining your own audit rules. You can define these rules based on transaction data or totals using the Rule Definition module of ReSA.

Because rules are associated with specific errors, you must define the errors and their impacts before you create the audit rules you need. These definitions can disable exports to the impacted system until all errors concerning the system are corrected, or they can disable the export of a particular transaction until it is corrected based on the option selected.

When you create an audit rule, it is initially in the Worksheet Status. You can view, run, modify, and test the rule. Errors created by rules in Worksheet Status are stored in the Error Worksheet table. Once you are satisfied that the rule works correctly, you can submit it and then later approve it.

Rules are executed each time you choose to run the re-total or the audit process using the ReSA user interface.

This chapter contains the following topics to help you understand and manage audit rules in ReSA:

- Understanding the Rule Maintenance Wizard
- Managing Rules

**Understanding the Rule Maintenance Wizard**

The Rule Maintenance wizard allows you to create and update a rule definition. Each window in the wizard has a text box to the right that displays help text for each field.
Defining Basic Information for Rules

Figure 6–1  Audit Rule Overview Window

The Overview window allows you to define basic information for a rule. You can enter the following information using the Rule Overview window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rule</td>
<td>A unique ID and a description for the rule.</td>
</tr>
<tr>
<td>Start Date and End Date</td>
<td>The period for which the rule is active.</td>
</tr>
<tr>
<td>Status</td>
<td>The status (Worksheet, Approved, Submitted, Disabled, or Deleted) of the rule.</td>
</tr>
<tr>
<td>Revision</td>
<td>The revision number for the rule. The revisions are tracked by the system.</td>
</tr>
<tr>
<td>Updated By</td>
<td>User ID of the person who updates the rule. This field is recorded by the system and you cannot edit it.</td>
</tr>
<tr>
<td>Update Date/Time</td>
<td>The date and time when the rule was last updated.</td>
</tr>
<tr>
<td>Should failing this rule stop all other rule processing for a store/day?</td>
<td>Use this field for rules that determine whether basic data exists for a store/day. For example, there can be a rule that determines whether a basic piece of data is missing. In case the basic information is missing, it would not make sense to continue flagging errors that confuses the auditor.</td>
</tr>
<tr>
<td>Execute Order</td>
<td>Use this field to determine the order in which rules are processed. Rules are placed into various execute groups. Within groups, rules are executed in alphabetical order.</td>
</tr>
<tr>
<td>Will you use the wizard to create this rule?</td>
<td>Use this field to specify whether you are defining the rule using the rule definition wizard, or through a manually written rule definition function.</td>
</tr>
<tr>
<td>Should this be evaluated at the store or system balancing level?</td>
<td>Use this field to specify whether the rules are evaluated at store, register, or cashier level.</td>
</tr>
</tbody>
</table>
Defining Rule Attributes

Figure 6–2  Rule Attributes Window

The Rule Attributes window allows you to define characteristics of the rule.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Does the presence or absence of this condition constitute an error?</td>
<td>Specify whether the rule triggers an error when a constraint condition is met (presence) or when the data does not exist in the data set (absence).</td>
</tr>
<tr>
<td>Record Type</td>
<td>Specify the kind of record that errors are associated with.</td>
</tr>
<tr>
<td>Rule Errors</td>
<td>You can choose to associate any predefined errors with the rule. You can view details about all errors by clicking the Error Details button.</td>
</tr>
</tbody>
</table>
Defining Realms and Joins

Figure 6–3  Realms and Joins Window

The Selected Realms section allows you to add existing realms (tables) to the rule. The list of available realms is displayed in the window, this list also includes the views created for each total.

Availability of realms to be added to the rule is determined by whether possible joins exist with the realms that are already added to the rule definition.

In general, you should add the general/parent tables, and then add the specific/child tables. If at any time, a realm that you want to use is unavailable, you should remove the realms already added to the rule, and try again in another order.

The Joins section displays how the realms are joined together. These joins are based on metadata defined in the system.
Defining Parameters

Figure 6–4  Parameters Window

The Parameters window allows you to choose the parameters for the rule. You can only choose parameters (columns) that are available in one of the realms that were previously added to the rule. You should add all parameters that you need to use in defining the constraint conditions on the rule. The system uses the parameters needed to log the errors against the correct day and record type.

Begin by choosing one of the realms. The parameter list then displays a list of all of the parameters (columns) that belong to the selected realm (table/view). You must choose the parameter that you need to count or sum and any other parameters that may be used to limit the data set.
Defining Restrictions

**Figure 6–5  Restrictions Window**

The Restrictions window allows you to limit the data set that is included in the rule. You can only define these restrictions (constraint conditions) using the parameters that were previously added to the rule.

Defining Location Traits

**Figure 6–6  Location Traits Window**

The Location Traits window allows you to associate rules with location traits which link a group of stores. Once the association is specified, the rule is applied only for those stores. If the rule is based on a total, you can execute the rule only for stores for which the total is calculated.
Managing Rules

You can use the following procedures to manage audit rules in ReSA:

- Creating Rule Calculation Definition
- Viewing Rule Calculation Definition
- Editing Rules Calculation Definition
- Changing the Status of Rules Calculation Definition

Creating Rule Calculation Definition

To create a rule calculation definition:

1. From the Tasks menu, select Foundation Data > Create Audit Rule. The Rule Maintenance window appears.
2. In the Rule field, enter the ID and description of the rule definition.
3. In the Start Date and End Date fields, enter the dates for which the rule definition is effective.
4. Click Next to navigate through the wizard. For more information on the various fields on each window of the Rule Maintenance wizard, see Understanding the Rule Maintenance Wizard.
5. Click Save to create the rule calculation definition.

Viewing Rule Calculation Definition

To view a rule calculation definition:

1. From the Tasks menu, select Foundation Data > Manage Audit Rules. The Audit Rule Search window appears.

![Audit Rule Search Window](image)

2. Enter additional criteria as desired to make the search more restrictive.
3. Click Search. The rules that match the search criteria are displayed in the Audit Rule Search window.

4. If you want to view the details of any rule definition, click the rule definition and select Actions > View.
   The Rules Definition Wizard appears. You can only view all the details of the rules definition in this window.

**Editing Rules Calculation Definition**

To edit a rules calculation definition:

1. From the Tasks menu, select Foundation Data > Manage Audit Rules. The Audit Rule Search window appears.
2. Search for and retrieve the rules calculation definition in Edit mode. The Rule Calculation Definition Wizard window appears.
3. Once the changes are complete, click Finish to save your changes and close the window.

**Changing the Status of Rules Calculation Definition**

The default status of a defined rule is Worksheet. You can change the status of the rules calculation definition based on the following actions:

- **Submit for approval**
  You can submit a rule calculation definition using the Submit option, this changes the status to Submitted.

- **Approve a rules calculation definition**
  Once a rules calculation definition is submitted for approval, you can approve it by changing the status of the rule to Approved by using the Approve option.

- **Disable a rules calculation definition**
  You can disable a rule calculation definition by changing the status to Disabled by using the disable option.

- **Delete a rules calculation definition**
  You can delete a rules calculation definition by changing the status to Deleted by using delete option.

To change the status of a rules definition calculation:

1. From the Tasks menu, select Foundation Data > Manage Audit Rule. The Audit Rules Search window appears.
2. Search for and retrieve the rules calculation definition in Edit mode. The Rules Calculation Definition Wizard window appears.

   **Note:** While submitting a rules calculation definition for approval, restrict the search to the rules in Worksheet status.

3. Click the drop-down arrow next to the Submit button and select Submit, Approve, Disable, or Delete. You are prompted for confirmation.
4. Click Yes. The status is changed to Submitted, Approved, Disabled, or Deleted respectively.
5. Click **Save** to save your changes and close the window.
This chapter explains the auditing process in detail and provides procedures to assist you while auditing transactional data. The process flow for auditing is as follows:

1. At the end of the day or by trickle-poll method, transactions are transmitted from the store to the head office. This data includes order initiation, order complete, and order return transactions from both OMS and POS.

2. The duplicate records received from OMS and POS are filtered within ReSA.

3. The transmitted transactions are loaded to the database, totaled, audited, and reviewed.

4. Any errors that are generated as part of the validation process must be corrected or overridden.

5. Once the audit is complete, the data is exported.

Auditing process followed by the Auditor

As a ReSA auditor, your responsibility is to review all exception errors related to your stores and either correct or override these errors.

The following is a standard auditing workflow for an auditor within ReSA:

1. Find and select the store/day containing and navigate to either Balancing Level Summary or Store Day Summary.

2. Use the Store Day Summary to review and audit the following:
   - Error List
   - Miscellaneous totals
   - Over short totals
   - Missing transactions
   - Import and export log

3. Use the Cashier/Register Level Summary to review and audit the following:
   - Error list
   - Miscellaneous total
   - Over short total

4. You can also perform data analysis such as, reviewing the audit trails. You can use the following screens for the analysis:
   - Transaction Search
Working with the Transaction Maintenance Module

- Item Summary
- Tender Summary
- Transaction Audit Trail
- Total Audit Trail
- General Ledger Transactions
- Import/Export Log
- Bank ACH Maintenance
- Store ACH Maintenance

Note: Once all errors are corrected or overridden, sales audit sets the store/day audit status to Audited. The store/day audit is then available for export to an external application.

This chapter covers the following topics:
- Working with the Transaction Maintenance Module
- Managing ACH Transactions
- Viewing the Store Day Transactions
- Managing Store Audit

**Working with the Transaction Maintenance Module**

The Transaction Maintenance module allows you to investigate and correct errors in the external system transactions. You can review the transactions that were flagged by the automated audit process.

Transactions may have many types of errors, which need to be reviewed and corrected manually. In addition, it is also possible to review and edit the data from missing transactions or transactions that have passed the automated audit. Corrected transactions are exported to external systems by a batch program.

You can use the Transaction Maintenance window to view, create, and edit transactions.
Creating a Transaction

To create a transaction:

1. From the Tasks menu, select **Operations > Manage Transactions**. The Transaction Search window appears.

2. Select **Actions > Create**. The Transaction Maintenance window appears.

   **Note:** You can also navigate to the Transaction Maintenance window by selecting **Operations > Create Transaction**.

3. In the **Chain** field, enter a chain number.

4. In the **Store** field, enter the store ID.

5. In the **Business Day** field, enter a date, or click the calendar button and select a date.

   Entering a store results in opening a Search and Select pop-up which allows you to select a Business Date. The selection of store and business automatically populates the Chain, Banner and Business Date fields if they were not entered.

6. In the **Transaction Date/Time** field, enter the date and time the transaction occurred.

   **Note:** The **External Transaction** field displays the transaction number that was used by the external system.

7. In the **Transaction Type** field, enter the type of transaction you are creating.

   **Note:** Depending on the type of transaction you select, additional fields are enabled. Enter the appropriate information in the enabled fields.

8. Add any of the following details to the transaction as needed:
Items to a transaction.
- Discount to the item on a transaction.
- Tender records to a transaction.
- Customer order information to a transaction.
- Paid out details to a transaction.
- Employee details to a transaction.
- Tax details to a transaction.
- Tax to the items on a transaction
- Voucher details to either item or tender on a transaction
- Customer attributes

9. Click OK to save your changes and close the window.

Adding Item Information to a Transaction

You can use the following procedures to add item information to a transaction.

To add an item to a transaction

1. On the Transaction window, in the Items section, select Actions > Add. The Add Item window appears.
2. Select the item type.
3. Enter the item ID. Details such as Unit Retail, Selling UOM are defaulted and can be overridden.

Figure 7–2 Transaction - Add Item Window
4. Enter details such as **Quantity** and **Item Status**.
5. Click **OK** to save your changes and close the window.

**To add return reason code**
1. On the Transaction Maintenance window, in the Items section, select **Actions > Edit**. The Edit Item window appears.
2. In the **Item Status** field, select **Return**. The Return Reason field is activated.
3. In the **Return Reason** field, select the return reason code.
4. Click **OK** to save your changes and close the window.

**To add customer order information to an item**
1. On the Transaction Maintenance window, in the Items section, select **Actions > Edit**. The Edit Item window appears.
2. In the Customer Order Attributes section, select the type of sales from the **Sales Type** field.
3. Update the other fields as required.

*Figure 7–3 Edit Item Window*
4. Click OK to save your changes and close the window.

To add price override information to a transaction
1. On the Transaction Maintenance window, in the Items section, select Actions > Edit. The Edit Item window appears.
2. In the Price Override section, enter the override reason in the Override Reason field.
3. In the New Unit Retail Price field, enter the new price.
4. Click OK to save your changes and close the window.

To add item details
1. In the Items section, click the arrow next to Item Details.

The Items Details section is expanded. You can add taxes and discounts here.

![Figure 7-4 Item Details Section on the Transaction Maintenance Window](image)

To add item discounts to a transaction
1. In the Items section, click the arrow next to Discounts to expand the discounts section. Click Actions > Add. The Add Discount window appears.
2. In the Component Type field, select the type of promotion or discount you are creating.
   - If you are creating a promotion, in the Promotion field, enter the promotion.
   - If you are creating a discount, from the Discount Type field, select the type of discount that you want to apply to the item.
3. In the **Promotion Component** field, edit the component of the promotion as necessary.

4. In the **Coupon No.** field, enter the ID of the promotion or discount.

5. In the **Quantity** field, enter the quantity for the discount.

6. In the **Unit Discount Amount** field, enter the amount of the discount.

7. Add the appropriate reference information.

8. Click **OK** to save your changes and close the window.

### Adding Reference Information to a Transaction

1. On the Transaction Maintenance window, click the arrow next to the **Reference** section. The Reference section is expanded.

### Viewing Transaction Audit Trails

To view the revisions of a transaction:
1. On the Transaction Maintenance window, from the More Actions menu, select **Transaction Audit Trail**. The Transaction Audit Trail window displays an audit trail of all revisions to the transaction.

**Figure 7–7  Transaction Audit Trail Window**

![Image of Transaction Audit Trail Window]

2. Click **OK** to close the window.

**Adding Comments to a Transaction**

To add comments:

1. On the Transaction Maintenance window, from the More Actions menu, select **Comments**. The Comments window appears.
2. Select **Actions > Add**. The next line in the table is enabled for commenting.

**Figure 7–8  Comments Window**

![Image of Comments Window]

3. Enter your comments.
4. Click **OK** to save your changes and close the window.

**Viewing Errors Associated with a Transaction**

To view errors:
1. On the Transaction Maintenance window, from the **More Actions** menu, select **Errors**. The Sales Audit Errors window appears. You can view all the errors associated with the transaction in this window.

2. Click **OK** to close the window.

**Refreshing the Errors**

To refresh the errors:

1. On the Transaction Maintenance window, from the **More Actions** menu, select **Refresh Errors**.

   The errors are refreshed taking into account any updates that were made to the transaction.

   **Note:** When refreshing errors, Total and Store Day Level rules are not included during the refresh.

**Adding Tender Information to a Transaction**

To add tender information to a transaction:

1. On the Transaction Maintenance window, in the **Tender** section, select **Actions > Add**. The Add Tender window appears.

2. In the **Tender Type Group** field, select the tender type group.

3. In the **Tender Type** field, select the tender type.

4. In the **Amount** field, enter the tender amount.

   **Figure 7–9 Add Tender Window**

   ![Add Tender Window Image]

   You can enter details in the respective sections based on the tender type you select.
5. If you select a type of card payment in the Tender Type Group field the Credit Card section is enabled:
   a. In the Authorization No. field, enter the authorization for user ID.
   b. In the Token field, enter the credit card token.
   c. In the remaining fields, select the information needed.

   Figure 7–10  Credit Card Section on the Transaction Maintenance - Add Tender Window

   d. Click **OK** to save your changes and close the window.

   **Note:** The Token field is only available when the selected Tender Type Group is either Credit Card, Debit Card, PayPal, Fonacot or Others. The section label is updated dynamically, based on the selected Tender Type Group. For example, if you select the Tender Type Group Debit Card, the section is labeled Debit Card.

6. You can add user-defined reference information to a type of tender in the Reference section.
7. Click **OK** to save your changes and close the window.

**Adding Customer Information to a Transaction**

To add customer information to a transaction:

1. On the Transaction Maintenance window, expand the **Customer** section.
2. In the Identification Type field, select the source of the customer information.
3. In the Identification No. field, enter the ID from the source document selected in the Identification Type field.
4. In the remaining fields, enter the name and the address information for the customer.
5. In the **Customer Attributes** section, select **Actions > Add**. The Add Customer Attribute window appears.

6. In the **Attribute Type** field, select the attribute type.

7. In the **Attribute** field, enter an attribute.

8. Click **OK** to save your changes and close the window.

**Adding Paid Out Details to a Transaction**

To add paid out details to a transaction:

1. On the Transaction Maintenance window, expand the **Paid Out Details** section.
2. In the **Vendor** field, enter a vendor number.
3. In the **Vendor Invoice No.** field, enter a vendor invoice number.
4. In the **Proof of Delivery No.** field, enter a proof of delivery number.
5. In the **Payment Reference No.** field, enter a payment reference number.
6. Click **OK** to save your changes and close the window.

**Viewing a Transaction**

To view a transaction:

1. From the Tasks menu, select **Operations > Manage Transactions**. The Manage Transactions window appears.
2. Enter search criteria to find the transaction that you want to view and click **Search**.
3. Select the transaction from the Results table.
Managing ACH Transactions

The Automated Clearing House (ACH) Maintenance module allows you to declare and manage how much money is deposited in local bank accounts. ACH maintenance allows Headquarter (HQ) users to manage how money moves from local bank accounts to centralized bank accounts. You can manage ACH transactions using the following procedures.

Viewing Bank ACH Transactions

To view bank ACH transactions:

1. From the Tasks menu, select Operations > Bank ACH. The Bank ACH window appears.

![Figure 7–13 Bank ACH Window](image)

Adding a Bank ACH Transaction Amount

To add a bank ACH transaction amount:

1. From the Tasks menu, select Operations > Bank ACH. The Bank ACH window appears.
2. Select Actions > Add. The Bank ACH - Add Adjustment window appears.
3. In the Bank field, enter the bank ID.
4. In the Bank Account field, enter a bank account number.
5. In the Business Day field, enter a business day, or click the calendar button and select the date.
6. In the Next Day Manual ACH Adjustment field, enter an amount.
Managing ACH Transactions

Figure 7–14  Add Adjustment

![Add Adjustment](image)

7. Click OK to save your changes and close the window.

Deleting a Bank ACH Transaction Amount

To delete a bank ACH transaction amount:

1. From the Tasks menu, select Operations > Bank ACH. The Bank ACH window appears.
2. Select the record.
3. Click Delete.
4. Click Yes to confirm deletion.

Viewing a Store ACH Transaction

To view a store ACH transaction:

1. From the Tasks menu, select Operations > Store ACH. The Store ACH window appears.

![Store ACH Window](image)

2. To view the bank details for a selected store, click Bank Details. The Bank ACH window appears.
3. Click OK to close the window.

Adding a Store ACH Transaction Amount

To add a store ACH amount:

1. From the Tasks menu, select Operations > Store ACH. The Store ACH window appears.
2. Click Actions > Add. The Add Adjustment window appears.
3. In the Store field, enter a store ID.
4. In the Business Day field, enter a business day.
5. In the Bank field, enter a bank ID.
6. In the Next Day Manual Deposit Adjustment field, enter an amount.

**Figure 7–16 Add Adjustment Window**

7. Click OK to save your changes and close the window.

**Deleting a Store ACH Transaction Amount**

To delete a store ACH transaction amount:

1. From the Tasks menu, select Operations > Store ACH. The Store ACH window appears.
2. Select a record.
3. Select Actions > Delete.
4. Click Yes to confirm deletion.
5. Click Save and Close to save your changes and close the window.

**Bank Stores Window**

The Bank Stores window is used to enter and maintain the store/bank relationships and bank attributes. The bank attributes are exported to external ACH (Automated Clearing House) and UAR (Universal Account Reconciliation) systems.

**Creating a Bank/Store Relationship**

To create a bank/store relationship:

1. From the Tasks menu, select Foundation Data > Bank Store. The Bank Stores window appears.
2. Select the bank from the Bank field.
3. In the Bank Stores table, select Actions > Add. The Add Store window appears.
4. In the Store field, enter a store ID number, select or search for the store.
5. In the Account Type field, select the account type the bank has for the store. The options are: Checking, Savings.
6. In the Bank Account field, enter a bank account number.
7. In the Routing field, enter the routing number for the bank.
8. To indicate that the account is a consolidating account, select Consolidating.
9. Click OK to add a store. You can add more stores by clicking OK and Add Another.
10. Click Cancel to return to the Bank Stores window.

Deleting a Bank/Store Relationship

To delete a bank/store relationship:
1. From the Tasks menu, select Foundation Data > Bank Store. The Bank Stores window appears.
2. Select the bank stores you want to delete.
3. Select Actions > Delete.
4. Click Yes to confirm deletion.
5. Click Save and Close to save the changes and close the window.

Viewing the Store Day Transactions

Audit trails allow you to view the revisions made to a transaction or a total. Summaries allow you to view the transactions that occurred on a Store Day.

After modifying the information for a Store Day, you can view the information through audit trails or summaries. After you view the summaries, you can return to the Transaction Maintenance module to update any outstanding issues you find while reviewing the Store Day. For more information on working with the Transaction Maintenance module, see Working with the Transaction Maintenance Module.

Viewing Transaction Audit Trails

To view the revisions of a transaction:
1. From the Tasks menu, select **Operations > Manage Transactions**. The Manage Transactions window appears.

2. Search and select the transaction for which you want to view the audit trail.

3. Select **Actions > View**. The Transaction Maintenance window appears.

4. From the **More Actions** menu, select **Transaction Audit Trail**.

   The Transaction Audit Trail window appears. This window displays an audit trail of all revisions to the transaction.

**Figure 7–18  Transaction Audit Trail Window**

5. Select a revision from the table.

6. To view all revisions in detail:
   - **Item level**: Expand the Items section, select an item and expand the **Item Revisions** section. You can view all the revisions for the selected item.
   - **Tender level**: Expand the Tender section, select a tender and expand the **Tender Revisions** section. You can view all the revisions for the selected tender.
   - **Export level**: Expand the Exports section, select an export and expand the **Export Revisions** section. You can view all the revisions for the selected export.

7. Click **Done** to close the window.

**Viewing a Total Audit Trail**

To view a total audit trail:

1. From the Tasks menu, select **Operations > Total Audit Trail**. The Total Audit Trail Search window appears.

2. Enter criteria to make the search restrictive.

3. Click **Search**. A list of totals matching the criteria is displayed.

4. Select a total.

5. Select **Actions > View**. The Total Audit Trail window appears.
6. Click **Done** to close the window.

### Searching for an Item Summary

To search for an item summary:

1. From the Tasks menu, select **Operations > Item Summary**. The Item Summary window appears.
2. In the **Store** field, enter a store number.
3. In the **Item Type** field, select an item type.
4. In the **Item** field, enter an item number.
5. In the **Business Day** field, enter a business day, or click the calendar button and select the date.
6. Click **Search**. The table displays the items that match the search criteria.
7. Click **Done** to close the window.

### Searching for General Ledger Transactions

The Sales Audit General Ledger Transactions window facilitates you to search and view transactions related to all the totals in a date range. This window also aids to view finance drill down report and finance drill back report.

To search for general ledger transaction view:

1. From the Tasks menu, select **Operations > General Ledger Transactions**. The General Ledger Transactions window appears.
2. In the **Store** field, enter a store number.
3. In the **Processed Date** field, enter a processed date, or click the calendar button and select the date.
4. In the **Accounting Date** field, enter an accounting date, or click the calendar button to select the date.
5. In the **Total ID** field, enter or search the total ID.
6. In the **Business Day** field, enter a business day, or click the calendar button to select the date.
7. Click **Search**. The table displays the items that match the search criteria.
8. Click **Done** to close the window.

**Figure 7–20  General Ledger Transactions**

---

**Searching for Tender Summary Information**

To search for tender summary information:

1. From the Tasks menu, select **Operations > Tender Summary**. The Tender Summary window appears.
2. In the **Store** field, enter a valid store ID.
3. In the **Business Day** field, enter a valid business day, or click the calendar button and select a business day.
4. To narrow your search, enter or select values in additional search fields.
5. Click **Search**. The data matching your search criteria appears.
6. Click **Done** to close the window.

---

**Managing Store Audit**

You can perform various operations on a store day using the following procedures.

**Searching for a Store Day**

To search for a store day:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. In the **Store** field, select a store.
3. In the **Business Day** field, select a date.
4. In the status fields, select varying status criteria.
   - Valid **Overall Status** are:
     - In Progress
     - Complete
   - Valid **Data Status** are:
     - Ready for Import
     - Loading
1. Enter additional criteria as desired to make the search more restrictive.

2. Click Search. A list of selected stores appears by business date.

3. Click Done to close the window.

**Viewing a Store Day Information**

To view the store day summary:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.

2. Search for and select a store day.

3. From the Actions menu, select View. The Store Day Summary window appears.

![Store Day Summary Window](image)

4. Click Done to close the window.

**Resolving Errors**

To resolve errors:
1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. Search for and retrieve a store day in **Edit** mode.
3. In the **Error List** tab, select an error from the list.
4. Select **Actions > Fix Error**. The Sales Audit window appears.
5. Resolve the error.
6. Click **OK** to save your changes and close the window.

### Viewing Over/Short Totals Information
To view over/short totals information:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. Search for and retrieve a store day in **View** mode. The Store Day Summary window appears. You can view the Over/Short information in the **Over/Short Totals** tab.
3. From the **Options** menu, select **Over/Short Totals**. The Over/Short window appears.
4. According to the information that you want to view, select the appropriate option from the **Actions** menu.
   - Select **Exports** to view the Totals Export window.
   - Select **Audit Trail** to view the Audit Trail window.
5. Click **OK** to close the window.

### Viewing Miscellaneous Totals
To view miscellaneous totals:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. Search for and retrieve a store day in **View** mode. The Store Day Summary window appears. Select the **Miscellaneous Totals** tab.
3. From the **Actions** menu, select **Exports**, **Audit Trail**, **Combined Total Details**, or **Errors**.
4. Click **Done** to close the window.

### Managing a Missing Transaction
The Missing Transaction tab allows you to view and update missing transactions. Missing transactions can occur when a transaction number, without any details, is generated at the POS or OMS. Missing transactions may represent transactions that were not properly polled, so you need to add the details. Another possibility is that the transaction numbers were polled erroneously from the POS or OMS, and do not represent actual transactions. You need to delete such transaction numbers.

#### To edit a missing transaction
1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. Search for and retrieve a store day in Edit mode. The Store Day Summary window appears. Select the **Missing Transactions** tab.

3. Select an external system transaction to add details.

4. From the Actions menu, select **Edit**. The Transaction Maintenance window appears.

5. Enter the details of the transaction in the appropriate fields.

6. Click **Save** to save your changes and close the window.

**To delete a missing transaction**

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.

2. Search for and retrieve a store day in Edit mode. The Store Day Summary window appears. Select the **Missing Transactions** tab.

3. Select the missing transaction.

4. From the Actions menu, select **Delete**.

5. Click **Yes** to confirm.

6. Click **Done** to save your changes and close the window.

**Viewing the Import/Export Log**

To view import/export log:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.

2. Search for and retrieve a store day in Edit mode. The Store Day Summary window appears.

3. Select the **Import Log** tab to view the import log.

4. Select the **Export Log** tab to view the export log.

5. Click **Done** to close the window.

**Deleting a Store Day**

To delete a store day:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.

2. Search for and retrieve a store day in Edit mode. The Store Day Summary window appears.

3. From the More Actions menu, select **Delete Store Day**.

4. Click **Yes** to confirm.

**Reopening a Store Day**

To reopen a store day:

1. From the Tasks menu, select **Store Day Audit**. The Store Day Search window appears.
2. Search for and retrieve a store day in **Edit** mode. The Store Day Summary window appears.

3. From the **More Actions** menu, select **Reopen Store Day**.

---

**Note:** The Reopen Store Day function is only available if the Audit Status is Audited, the Data Status is Fully Loaded, the Store Day Status is Closed, and the Business Date is greater than last end of month date.

---

4. The Audit Status is set to Unaudited. The Data Status is set to Ready for Import and the Audit Changes Date/Time is updated. Click **Save** or **Save and Close** to save your changes.
Once the auditing process is complete, the transactional data is exported to different Oracle Retail systems. Exporting data involves retrieving data from the ReSA database, and writing it to a file formatted to the standards of the external systems such as, Retail Merchandising System (RMS), Store Inventory Management (SIM), Retail Invoice Matching (ReIM), Retail Analytics (RA)/Retail Insights (RI), and third party applications.

**Exporting Audited Data**

ReSA uses the following process to export audited data:

1. Transactions/Totals that are corrected in the interactive audit process are extracted from the database tables by the Sales Audit program.
2. This information is written to interface files/tables that are used by external systems.
3. A batch program extracts transactions with the status of Passed, Non-fatal, and Delete. The data is exported to temporary staging tables where additional batch programs manipulate the data and pass it to external systems, such as RMS or RA.
4. If a previous revision of a transaction was exported, a reversal of the revision is also included in the transmission.
5. After all reversal entries are created, the reversed transactions are deleted from the transaction tables.
ReSA Operational Insights reports can be divided into the Dashboard Reports and in-context BI Reports. These reports are embedded within the ReSA application.

This chapter contains the following reports:
- Dashboard Reports
- In-context Business Intelligence (BI) Reports

**Dashboard Reports**

The dashboard surfaces information in a manner that will help users - sales auditors - prioritize their day-to-day activities as well as quickly identify areas of concern. The dashboard allows a user to look at a consolidated view of their ‘to-dos’ and then directly and contextually launch into the corresponding windows to take an action. The Dashboard Reports show data across assigned stores that is the stores assigned to the logged in user.

Through the dashboard, a Sales Auditor can at a glance identify store days that are still open due to errors or late polling by stores and can resolve or escalate the issues.

A view of all open transactional errors across his stores for the last seven days is available that helps him see error patterns and helps estimate his workload in fixing them. The auditor can then start fixing the errors by launching the respective windows directly from the links provided in the dashboard reports.

The over short summary report helps the sales auditor in the important function of tracking the overages or shortages at his stores and identifying fraudulent behavior.

The dashboard reports can be viewed by navigating to Reports menu > ReSA Dashboard.
Open Store Days Report

The Open Store Days report indicates a sales auditor's open store days and whether they have not been audited, not been loaded or only partially loaded for the last seven days. There are three different actions that can be taken from this report:

Click 'Open Stores' bar in the report and the report contextually launches into the Store Day Search window. Therefore, the window is auto-populated for all store-days with a status of 'Sales Audit In-Progress'.

You will also be able to click 'Not Loaded Stores' bar in the report and the report contextually launches into the Store Day Search window. Therefore, the window is auto-populated for all store-days with a status of 'Ready for Import.'

Click 'Partially Loaded Stores' bar in the report and the report contextually launches into the Store Day Search window. Therefore, the window is auto-populated for all store-days with a status of Partially Loaded.

Figure 9–2 Top Ten Late Stores Report
**Top Ten Late Stores Report**

The Top 10 Late Stores report gives the auditor a view of the 10 stores that have the highest number of late polling days in the current or last month. This report shows the count of store days in status **Ready to Import** or **Partially Loaded** per store for the Current Month or Last Month based on view selected. Based on this analysis the Auditor can contact these stores or escalate them as high issue stores to management.

*Figure 9–3  Top Ten Late Stores Report*

**Open Transaction Errors Report**

The Open Transaction Errors report displays the number of open transactional errors across all stores color coded by error code over the last seven days.

You can hover over a section of the stacked bar to see the count of errors for a given error code on a given business date.

Click the stacked bar for a specific business day to refresh the tabular detail report on the right. The tabular report shows the store, item and transaction number details of all errors existing for the given business date.

Click the data in the Store column in the Open Transaction Error detail table and is contextually launched into the Transaction Search window. The window is auto populated with all transactions for the given store and business date where transaction level errors exist.

Click the data in the Transaction column in the open transaction error detail table and is contextually launched into the Transaction Maintenance window for the given transaction. The window is launched either in the **View** mode or **Edit** mode based on the privileges that role has.
Over/Short Summary Report

The Over/Short Summary report displays the sum of overage amounts for all stores that have an over amount and the sum of shortage amounts for all stores that have a short amount per business day for the last seven days.

Click the over or short bar for a given business day which refreshes the tabular detail report on the right. The tabular report shows the store and the corresponding over amount or short amount for the store and given business day.

If the over amount or short amount at a store exceeds the configured threshold amount, a warning symbol is displayed against the given row.

Note: The threshold for over amount and short amount can be configured through setting of system options.

If the stores have varied local currencies, the amounts are displayed in primary currency only. If all stores have the same common local currency, the amounts are displayed in local currency.

Click the data in the Store column in the Over/Short Detail report and is contextually launched into the Store Day Audit window with the Over/Short Totals tab highlighted for the selected store and business day. The window is launched either in the 'View' mode or 'Edit' Mode based on the privileges of the user.
In-context Business Intelligence (BI) Reports

In-context BI Reports are displayed in in-context pane of some windows. In-context BI reports provide additional in-context insights to the data being viewed in the window.

The following windows have in-context BI reports displayed in the right pane:

■ Store Day Search window
■ Store Day Summary window
■ Transaction Maintenance window
■ Tender Summary window

In-context BI Reports on Store Day Search Window

The following are in-context BI reports displayed on the Store Day Search window:

■ Store Status History Report
■ Error History Report
■ Over/Short History Report
Store Status History Report

The Store Status History report on Store Day Search window indicates a sales auditor’s open store days and represent them by color codes whether they have not been audited, not been loaded or only partially loaded for the last seven days. You can also hover over the bar charts to view the count.

Error History Report

The Error History report on Store Day Search window indicates the total number of errors for all auditor stores per business day for the last seven days. The error count includes current open errors and errors that were resolved. This would give the auditor insight into the occurrence of similar kinds of errors in the past that were resolved or that are still open. The errors are color coded by error code.

You can hover over the respective section of the chart to view the error count for the given error code.
Over/Short History Report
The Over/Short Summary report displays the sum of overage amounts for all stores that have an over amount and the sum of shortage amounts for all stores that have a short amount per business day for the last seven days.

If the stores have varied local currencies, the amounts are displayed in primary currency only. If all stores have the same common local currency, the amounts are displayed in local currency.
Store Status History Report
The Store Status History report on Store Day Summary window indicates the presence of not audited store days, not loaded store days, and partially loaded store days across the last seven days for the store that is being viewed in Store Day Summary window. An indicator signifies if the given store is not audited, is not loaded or is partially loaded for the last seven business days.

Error History Report
The Error History report on Store Day Summary window indicates the pattern of the errors existing for the store day being viewed in the Store Day Summary window. The report indicates the number of occurrences of errors similar to the errors open for the selected store day over the last seven days.

The error count includes both open errors and errors that were resolved for the store days. This would give the auditor insight into the occurrence of similar kinds of errors in the past that were resolved or that are still open. The errors are grouped and color coded by error code.

You can hover over a section of the chart to view the error count for the given error code and business day.
Figure 9–14  Error History Report

Cashier/Register Over Short Report
The Cashier/Register Over Short report on Store Day Summary window displays the overage or shortage amounts by cashier for the given store - business day being viewed in the Store Day Summary window if the system option - Balance Level Indicator is set to Cashier.

The report displays the overage or shortage amounts by register for the given store - business day being viewed in the Store Day Summary window if the system option - Balance Level Indicator is set to Register.

The amounts in the report are displayed in the RMS primary currency or the store's local currency based on the currency toggle in the store day summary window.

Figure 9–15  Cashier/Register/Over/Short Report
In-context BI Reports on Transaction Maintenance Window

The following are in-context BI reports displayed on the Transaction Maintenance window:

- Error History Report
- Item Errors Report

Figure 9–16  Transaction Maintenance Window

Error History Report

The Error History report on Transaction Maintenance window indicates the pattern of the errors existing for the transaction being viewed over the last seven business days. The report indicates the number of occurrences of errors similar to the errors open for the selected transaction for the given store over the last seven days.

The error count includes both open transactional errors and transactional errors that were resolved. This would give the auditor insight into the occurrence of similar kinds of errors in the past that were resolved or that are still open. The errors are grouped and color coded by error code.

You can hover over a section of the chart to view the error count for the given error code and business day.
Item Errors Report

This Item Errors report on Transaction Maintenance window indicates the pattern of the errors existing for the item selected on the window for the given store over the last seven business days. The report indicates the number of occurrences of errors similar to the errors open for the selected item for the given store over the last seven days.

The error count includes both open errors and errors that were resolved. The errors are grouped and color coded by error code.

You can hover over a section of the chart to view the error count for the given error code and business day for the selected item.

---

**Note:** Only item level errors (that is, errors with rec_type = TITEM, IDISC, IGTAX) are considered in this report.

The report appears only when an item is selected in the Items panel of the Transaction Maintenance window.
In-context BI Reports on Tender Summary Window

The following are in-context BI reports displayed on the Tender Summary window:

- Tender Summary Report

Figure 9–19  Tender Summary Window

Tender Summary Report

The Tender Summary report on Tender Summary window displays the net tender amount by tender types - Cash, Credit Card and Check per business day over the last seven days for the store selected in Tender Summary window.

The amounts in the report are displayed in the primary currency or the store's local currency based on the currency toggle in the Tender Summary window.

Note: The report appears only after the search has been executed.

Figure 9–20  Tender Summary Report
audit rules
Audit rules allow you to set your own sales data validation criteria.

errors
Errors arise when the conditions of a rule definition are not met. You can either correct these errors or you can override them.

error impact
Errors arising out of the transaction data validation performed by ReSA may have impact on the export of data to the external systems. At times, the data should not be exported to the external systems until the error is corrected. At other times, the impact of the error may be very negligible and limited only to the internal ReSA application. In such situations, the data can be exported to external systems.

overriding errors
There are some errors that cannot be corrected. For such errors, you need to acknowledge the error and then override these errors.

rules definition
By providing a Rule Definition in the ReSA system, you are actually defining the conditions that the ReSA system should meet to perform an additional level of transaction data validation.

sales audit
Sales audit is essentially the process of reviewing the point-of-sale transaction data for accuracy.

store day
A store day is the time spent between opening cash registers at the start of a calendar day and closing the registers at the end of the day. For some retailers, a store day spans over more than one calendar day.

totals
A total is a summation or count of two or more entities. For example, a total can be a summation of the quantity of items sold in the store on a particular store day.

total definition
By providing a Total Definition in the ReSA system, you are actually defining from where the total values will come into the ReSA system.
**total level**
Total level indicates the level at which the totals are calculated. The total level relates to the balancing level that is chosen for the system.

**total values**
This refers to the actual numeric value produced when the Total Definition is run against the transaction data.
## Index

| A | accessibility options preferences 13 |
|   | adding |
|   | customer 10 |
|   | customer order 5 |
|   | discount 6 |
|   | paid out details 11 |
|   | price override 6 |
|   | return code 5 |
| audit rules | basic information 2 |
|   | characteristics 3 |
|   | create 7 |
|   | defining 1 |
|   | view 7 |
|   | wizard 1 |
| C | creating |
|   | audit rules 7 |
|   | transactions 3 |
| customer order | add 5 |
| D | data |
|   | export 1 |
|   | discount |
|   | add 6 |
| L | language options |
|   | preferences 13 |
| M | maintaining |
|   | transactions 2 |
| P | preferences |
|   | accessibility options 13 |
|   | language options 13 |
|   | regional options 12 |
| price override | add 6 |
| R | regional options |
|   | preferences 12 |
|   | return code |
|   | add 5 |
| T | tasks |
|   | user interface 3 |
| transaction | add |
|   | customer 10 |
|   | customer order 5 |
|   | discount 6 |
|   | item 4 |
|   | paid out details 11 |
|   | price override 6 |
|   | return code 5 |
|   | create 3 |
|   | maintenance module 2 |
| U | user interface |
|   | tasks 3 |
| V | viewing |
|   | audit rules 7 |
|   | bank ACH transactions 12 |