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1. Release Notes 

1.1 Background / Environment 

Oracle Financial Services Software Limited has developed Oracle Financial Services Lending 

and Leasing solution. The suite is a comprehensive, end-to-end solution that supports full 

lifecycle of direct and indirect consumer lending business with Origination, Servicing and 

Collections modules. This enables financial institutions to make faster lending decisions, provide 

better customer service and minimize delinquency rates through a single integrated platform. It 

addresses each of the lending processes from design through execution. Its robust architecture 

and use of leading-edge industry standard products ensure almost limitless scalability. 

1.2 Purpose 

The purpose of this Release Note is to highlight the enhancements included in the Oracle 
Financial Services Lending and Leasing Release.  

1.3 Abbreviations 

Abbreviation Detailed Description 

OFSLL Oracle Financial Services Lending and Leasing 

ACX Account Boarding 

TXN Transaction Processing 

UIX User Interface 

ORG Origination 

CS Customer Service 

LN Loan / Line 

LS Lease 

OE Open Ended 

CE Close Ended 

XAE Web service Application Entry 

XCS Web service Customer Service 

CB Credit Bureau 
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Abbreviation Detailed Description 

WFP Wholesale floor Planning 

SQL Structured Query Language 

XML Extensible Mark up Language 

XSD XML Schema Definition 

POJO Plain Old java Object 

API Conversion Open Interface 

1.4 Product Summary 

Oracle Financial Services Lending and Leasing Release is built to meet various challenges faced 
by financial institutions. It addresses each of the lending processes from design through 
execution. Its unique value lies in its ability to provide the business with predefined processes and 
a world-class framework that takes care of business risk and compliance needs. 

1.5 Release Highlights 

The key highlight of this release is to fix the critical bugs and to enhance the industry specific 
requirements. 
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2. Enhancements 

Ref No. Enhancement Description 

OFSLL_PMG_INTERFACE
_RQT_091 

New REST Web Services 
Development.  

Following REST web services are developed: 

 ‘Call Activity’ REST web service 

 ‘Generic Post Transactions’ REST web 
service 

 ‘Account Search’ REST web service 

 ‘Account On Boarding REST web service 

OFSLL_PMG_INTERFACE
_RQT_085 

‘Scenario Analysis’ REST web 
service (POST and GET) 

 

New ‘Scenario Analysis’ REST web service is 
developed to  simulate and retrieve the 
customer’s Loan or Lease request (Loan amount, 
rate and create a mock proposal in Loan or Lease 
with concern lending policies. 

POST ‘Scenario Analysis’ web service requires 
simulation details and Inquiry ID will be received 
as part of response. 

GET ‘Scenario Analysis’ web service requires 
Inquiry ID and simulation details will be received 
as part of response. 

OFSLL_PMG_INTERFACE
_RQT_086 

‘Loan Calculator’ and ‘Lease 
Calculator’ REST web 
services. 

 

‘Loan Calculator’ and ‘Lease Calculator’ REST 
web services are developed for calculating 
Loan/Lease – Financed Amount, Term, Payment 
Amount and Rate. 

POST Loan calculator service simulates the 
standalone loan calculator features of OFSLL with 
Flexible Repayment options and Amortization 
Schedules.  

POST Lease calculator service simulates the 
standalone lease calculator features of OFSLL. 

Note: Simulation will not be saved. 

OFSLL_PMG_INTERFACE
_RQT_087 

‘Payment Posting’ REST web 
service. 

New ‘Payment Posting’ REST web service is 
developed for 'Payment Posting Transaction, and 
Payment Reversing Transaction'. 

Posts a payment for the account. 

OFSLL_PMG_INTERFACE
_RQT_088 

'Account Details' REST web 
service. 

'Account Details' REST web service is developed 
to search account details by String account 
number. 

OFSLL_PMG_INTERFACE
_RQT_089 

'Application Search' REST 
web service. 

 

'Application Search' REST web service is 
developed to search an application by various 
attributes such as  ApplicationNumber, 
CustomerFirstName, CustomerLastName, SSN, 
Creation Date, BirthDate. 

 

OFSLL_PMG_INTERFACE
_RQT_090 

‘LookUpRequestService' 
REST web service. 

‘LookUpRequestService' REST .This service 
gives flexibility to fetch all the Lookup’s enabled 
for a Lookup Type. By Passing a String that 
matches to Lookup Type system gives all the 
lookup codes and relevant lookup values. 

Ex: States, Asset Status Codes etc... 
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Ref No. Enhancement Description 

 

OFSLL_PMG_INTERFACE
_RQT_084 

‘Application Entry’ REST web 
service  is created and 
enhanced 

New 'Application Entry’ REST web service  is 
created and used for LOAN/LINE and LEASE 
Products 

OFSLL_PMG_INTERFACE
_RQT_092 

'Application Entry' SOAP web 
services is enhanced with 
MLA details. 

 Existing ‘Application Entry’ SOAP web service is 
enhanced with following ‘Military Service’ fields. 

 SCRA Military Duty Ind 

 SCRA Effective Dt 

 SCRA Order Nbr 

 SCRA Release Dt 

OFSLL_PMG_RQT_671 Initiate the Job Requests from 
Application Server. 

Bureau Pull should get initiated from Application 
server. 

OFSLL_PMG_RQT_694 Payment Posting 
Enhancements 

Any payment received after Account Closed- Paid 
off, Charge Off to be posted to ‘Suspense’, 
instead of showing ‘Error’.  

OFSLL_PMG_INTERFACE
_RQT_077 

Support for Parallel Profile 
(PPF) request and response 
processing and content 
display for Experian Premier 
Attribute consumer report.  

Note: PPF format displays 
both machine and human 
readable contents in the 
response file.  

While generating the request message for 
Experian Premier Attribute consumer report, 
system inserts PPF request code under the 
segment  <OutputType>  and in turn receives 
both machine and human readable contents in 
the  response file.  

 

OFSLL_PMG_RQT_677 Soft Pull request for Experian 
Premier Attribute consumer 
report. 

While manually requesting for Experian Premier 
Attribute consumer report, system allows the user 
to mark it as a ‘Soft Pull Request’ by ticking the 
new check box ‘Soft Pull’. Please note that this 
check box will get enabled only for the Experian 
Premier Attribute report. 

OFSLL_PMG_RQT_703 Enhance EXP Credit report to 
get MLA details 

Enhancing EXP Credit Report request to request  
MILITARY LENDING Covered Borrower details 
and process the response and show it in OFSLL 
screen 

Bug# 25037596 Export to Excel facility in 
securitization Screen 

Export to Excel facility provided in securitization 
Screen 

OFSLL_PMG_RQT_657 SCRA – Off Military Duty 
SCRA transaction reverts back to original interest 
amount and installment amount on posting of ‘Off 
Military Duty’. 

OFSLL_PMG_RQT_692 Customer Details Update flag 

 

‘Customer Details Update flag’ is provided in 
Origination and Account On boarding to indicate 
the customer data over ride. 

OFSLL_PMG_RQT_796  

 

Separate Parameters for 
‘Promise to Pay’ and ‘Payment 
Tolerance’ 

Created separate set of parameters for 'Promise 
to Pay' and 'Payment Tolerance’ 
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Ref No. Enhancement Description 

OFSLL_PMG_RQT_795 GL Reconciliation Screen New GL Query screen is developed to search the 
GL transaction by ‘Account’ Number; which 
fetches data for transaction types - Producer 
Transactions, Monetary Transactions, Amortized 
Transactions, Funding Transactions, Payment 
Transactions, Securitization Transactions, and 
Loan Sale Transactions 

OFSLL_PMG_RQT_800 Automatic update of CIIC 
Code 

At present in OFSLL, CIIC code reporting in Metro 
II report is manual and involves posting non-
monetary transactions, call activity creations and 
also creating bankruptcy tracking details. This 
enhancement addresses the bankruptcy 
processing efficiency improvement and also to 
ensure the automatic CIIC posting to the correct 
account relation(s) to reduce the number of 
manual steps involved. Automatic posting of CIIC 
will ensure that it has no dependency on end 
user’s knowledge on what needs to be reported in 
Metro II report. 

OFSLL_PMG_INTERFACE
_RQT_058 

Create Case Work Order Screen is enhanced to facilitate 
creating a Case in third party interface from 
OFSLL using add Case () web service. 

Vendors  Work Orders 

OFSLL_PMG_INTERFACE
_RQT_058 

Update Case Details Once the addCase() is created in Third Party 
Interface; Ability to send case updated details to 
third party system using following web service 
calls. 

 updateCaseAccountInfo() 

 updateCaseAddress() 

 updateCaseCollateral() 

 updateCaseDebtor() 

 updateCaseCosigner() 

OFSLL_PMG_INTERFACE
_RQT_058 

Case on Hold Ability to place a Case on Hold in third party 
interface using following web service. 

 holdCase() 

OFSLL_PMG_INTERFACE
_RQT_058 

Case Close Ability to place a Case on Close in third party 
interface using following web service. 

 closeCase() 

OFSLL_PMG_INTERFACE
_RQT_058 

Receiving the Case updates 
from third party interface using 
FireHose() web service 

Ability to receive the case updates from Third 
Party Interface by calling the following web 
service. 

 getRdnFireHose() 

OFSLL_PMG_RQT_ 612 Automatically Posting the 
Case Hold condition based on 
Delinquency Days Parameter 

When the account is less than certain number of 
delinquency days (System Parameter), system is 
posting the Hold condition on to the account. 

OFSLL_PMG_RQT_533 Vendor Assignment  New ‘Assignment Allocation’ screen provided to 
define vendor allocation weightage; which 
defaults vendor in CASE screen based on 
Channel, Work Order Type, Company and Branch 
Combination. 
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Ref No. Enhancement Description 

OFSLL_PMG_INTERFACE
_RQT_058 

Vendor work order screen is 
enhanced to interface with 
third party web services. 

1.  “reopenCase()” web service to request the 

case Reopen in Third Party portal. 

2.  “reassignCase()” Web service to Re Assign 

the case. 

3. “addCaseUpdate()” Web service to send 

case Comments to Third Party vendors. 

4.  “getCaseInvoiceData()” web service to get 

the case Invoice details. 

OFSLL_PMG_RQT_584 Business Rules  - Internal 
Work Orders 

Applying and Handling Invoice processing 
business rules for ‘Internal’ work orders. 

OFSLL_PMG_RQT_ 612 Handling ‘Repossession 
CASE’ 

Few changes taken up in Vendor and Work order 
Screen to handle CASE details (creating and 
maintaining) interfacing with external system.  

OFSLL_PMG_RQT_ 532 Fee Structure for Vendor 
Services 

 

 Ability to define the Fee at the vendor level. 

 Default fee in the work order based on the 
Vendor Service Offered.  

OFSLL_PMG_RQT_584 Invoice Related Changes Authorization Framework for ‘Payment 
Requisition’ Generation 

OFSLL_PMG_RQT_797 Generic Payment Upload Generic Payment Upload file format is created to 
provide a facility to upload payment transactions 
in bulk. 

OFSLL_PMG_RQT_703 SCRA changes to 
accommodate new changes in 
Military lending Act 

Facility provided to capture Active Military duty 
details at Applicant level in Origination and same 
details will be propagated to servicing. 

New edits are introduced to validate max SCRA 
rate and cross check the captured Active Military 
Details with Applicant bureau details. 

OFSLL_PMG_RQT_802 Account Timeline Servicing is enhanced to display “Transactions, 
Payments and Call Activities Timeline” for an 
Account. This will give user a visual 
representation of transactions and call activities 
posted on particular date. 

OFSLL_PMG_RQT_650 Statement Preference Mode Facility provided to capture ‘Statement 
Preference’ Mode in Origination and provided 
facility to change the preference in 
Servicing/collections stage. 

OFSLL_PMG_RQT_564 Default  Spread Based on 
Account Status-Condition 

Default ‘Spread’ is provided based on the account 
‘Status and Condition’ in ‘Payment Entry’ screens. 

OFSLL_PMG_RQT_ 566 Queue User Group  Centralized repository provided for adding 
and removing users from queue. 

 Facility of replacing hard assigned users for 
an account or multiple Accounts. 

OFSLL_PMG_RQT_569 ‘Recourse’ Enhancements 

 

‘Dealer Recourse’ feature enhanced in OFSLL in 
following modules. 

 Recourse details can be captured in Setup > 
Contract > Lease 

 Recourse details can be captured in 
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Ref No. Enhancement Description 

origination 

 Recourse details can be Added/Updated in 
servicing stage. 

 These changes are applicable only for LOAN 
and LEASE 

OFSLL_PMG_RQT_634 Payment Maintenance Screen 
Enhancement 

Payment posting is allowed to support single 
payment to multiple payments and vice versa 
payment maintenance after posting. 

OFSLL_PMG_RQT_651 ‘Customer Deceased’ 
Transaction Enhancement 

While posting ‘Customer Deceased’ Transaction, 
system to allow to choose whether "Permission to 
Call“ flag for deceased customer as Yes / No. 

OFSLL_PMG_RQT_562 Transaction Authorization – 
Maker/ Checker Framework 

Enhanced the Maker/Checker framework in 
OFSLL as ‘conditional checker’ for Monetary 
transactions; while providing separate tab to 
define ‘maker’ responsibilities. 

OFSLL_PMG_RQT_607 Actionable Alerts The ‘Alerts (Comments)’ functionality is enhanced 
to support the following: 

 Deleting alerts (comments) 

 Added Alert flag in the Offline Call activity file 
format. 

OFSLL_PMG_RQT_635 ‘Due Date Change’ override 
transactions 

Two new monetary transactions are provided in 
‘Due Date Change Override’ and ‘Due date 
Change Override Reverse’. 

OFSLL_PMG_RQT_007 Fee Selection Criteria 
Enhancement 

A new selection criteria is added at two places in 
setup-Amount Financed 

 Setup > Products > Fees  

 Setup> Contract > Fees Sub tab 

OFSLL_PMG_RQT_619 ‘Field Investigation’ in 
Servicing 

 

A new tab is introduced in Customer Service 
called ‘Field Investigation’, after the ‘Tracking 
Attributes’ tab under Customer Service tab 

OFSLL_PMG_RQT_608 Bureau Pull Validation 

 

Credit bureau pull process is enhanced/extended 
to consider time lag between last pull (days) for 
same Bureau Company before processing new 
request. 

OFSLL_PMG_RQT_606 Producer Payment Details 
Access Control 
 

“Producer Payment Details” functionality is 
enhanced to support the following: 

 Access Control for Producer Payment Details 

 Show ‘Unverified’ Bank Details Counter in 
Producer Dashboard with a hyperlink  

OFSLL_PMG_RQT_602 Servicing Summary Screen 
Enhancements 
 

 ‘Account Information’ related fields are added 
to customer summary screen 

  ‘Remaining’ Term, ‘Kept Promises’ Counter 
and ‘Outbound’ Call Counters are placed in 
summary screen 

 Capture ‘best day to call’ in telecom screen 
(Origination/ Servicing) and shown on 
summary screen 

 ‘Securitization Details’ in Account Summary 
page are shown in separate tab. 

 ‘Export’ feature provided to transaction 
screen 

OFSLL_PMG_RQT_561 
Masking Financial Data for 
Secured Accounts 

 Secure Accounts by masking financial details 
in search results to unauthorized users 
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Ref No. Enhancement Description 

OFSLL_PMG_RQT_656 Append ‘Delinquency Days’ to 
account comment 

 

 System generated comments will be posted 
on posting Call Activity and OFSLL enhanced 
to append Delinquency Days in Account 
Comment posted via call activities. 

OFSLL_PMG_RQT_655  ‘Time Barred’ Debt 

 

 Functionality to handle time barred debts; 
which considers period of limitation at state 
level and product type. 

OFSLL_PMG_RQT_525 Facility to Open Multi-tab  Facility to open multiple originations/ 
servicing tabs simultaneously. 

OFSLL_PMG_RQT_565 New Opt-Out Indicators Ability to Capture three new opt-outs - Insurance 
Opt-Out, Share Credit Opt-Out and Marketing 
Opt-Out in Origination stage and change the Opt-
Out preferences in servicing stage by using 
Add/Edit or posting transactions. 

OFSLL_PMG_RQT_605 

 

 ‘References’ Enhancements 

 

Facility to capture References Status and 
‘Permission to call’ indicator for ‘References’ 
phone numbers and ability to add/update 
‘References’ information in servicing stage. 

OFSLL_PMG_RQT_657 SCRA Transaction Changes 

 

SCRA transaction will result in lower payment 
amount during “Active Military Duty”, regardless of 
prior payment history. 

OFSLL_PMG_INTERFACE
_RQT_069 

Bankruptcy Interface 

 

 Bankruptcy Interface provides ‘Bankruptcy’ 
information for requested customer list of 
bank. 

 Automatic creation of daily Bankruptcy 
customer account output file. 

 Processing of scheduled Bankruptcy 
response file and saving the contents into 
OFSLL  

 Display the Bankruptcy details for user 
approval 

OFSLL_PMG_RQT_652 Currency Exchange Upload Ability to upload “Currency Exchange Rates” 
using input file upload. 

OFSLL_PMG_RQT_653 Account History Capture user access history of account, which is 
accessed through various navigation modes. 

OFSLL_PMG_RQT_789 Seed Data Seed Data screen in Oracle Financial Services 
Lending and Leasing displays the existing seed 
data details maintained in the system and allows 
you to compare and merge only the required 
differences in each record. 

OFSLL_PMG_RQT_794 Condition/Queue/User History 

 

Servicing > Account > Condition shows: Current 
Open Conditions, Queues and Hard Assigned 
Users 

Servicing > Condition History shows: Historical 
Open Conditions, Queues and Hard Assigned 
Users 

OFSLL_PMG_RQT_794 Delinquency Reason Delinquency Reasons captured for specific cases. 
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2.1 REST Web Services 

2.1.1 Overview 

Following REST web services are developed: 
 

I. ‘Call Activity’. 
II. ‘Generic Post Transactions’ 
III. ‘Account Search’ 
IV.  ‘Account on Boarding’ 
V. ‘Scenario Analysis’ POST and GET REST web services  

VI. ‘Loan Calculator and Lease Calculator’  
VII. ‘Payment Posting’  
VIII. ‘Account Details’  
IX. ‘Application Search’  
X. ‘LookUpRequestService’  

XI. ‘Application Entry’  
XII. ‘Dialer Integration’  

 

2.1.2 Description 

I. ‘Call Activity’ REST web service 

 New ‘Call Activity’ REST web service is developed. 
• Posting call activities to multiple accounts 
• Posting multiple call activities to one account 
• Posting multiple call activities to multiple accounts 
• Three custom fields are provided 

 Following are the provided custom fields 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

II. ‘Generic Post Transactions’ REST web service 

 New ‘Generic Post Transactions’ REST web service is developed. 

 System validates the transaction type is Manual or not. If transaction is not manual, 
sends error response. 

 System validates the transaction code relevant to Account (Account Monetary/Non 
Monetary transactions), if not sends error response. 

 If the Transaction Code is not enabled, system does not allow to post in OFSLL. 

 Based on the transaction code system stores the record in respective radio button in UI 
for producer transactions. 

 System validates the transaction code relevant to Producer, if not sends error response. 

 If the Transaction Code is not enabled, system does not allow to post in OFSLL. 

 System defaults the Effective Date to GL date. 

 System validates the “Account Number” and also validates whether the account number 
is linked to that producer or not, if not sends an error message 
 

Note: system will allow the following Transaction Action types through WS. 

 ADJUST_MINUS' 
 ‘ADJUST_PLUS' 
 ‘CHGOFF' 
 'POST' 
 'TERMINATE' 
 'VOID' 
 'WAIVE  

III. ‘Account Search’ REST web service 

 New ‘Account Search’ REST web service is developed. 

 Account can be searched with various customer attributes such as ‘Account Number, 
Customer First Name, Customer Last Name, SSN, Phone Number, Birth Date or Vehicle 
Identification Number’. 

 Any one of the above mentioned fields is mandatory. 

 System validates for the relevant customer data, if not sends error response. 
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 Response is tied with a system parameter ‘XWS_ACS_RESP_MULTI_RECORD_IND’ 
for multiple record responses. Default value of system parameter value will be ‘NO’.  

 If parameter value is NO, web service response shows ‘‘Too Many Records Found. 
Please Refine Search by Adding One More Parameter’; if query fetches multiple records. 

 If the Parameter value is set as ‘YES’, system shows the multiple rows in response; if 
query fetches multiple records. 

 Three custom fields are provided. 
 

 Following are the provided custom fields in the response. 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

IV. ‘Account on Boarding’ REST web service 

 New ‘Account on Boarding’ REST web service is developed. 

 Using this web service, third party origination systems can move the funded accounts 
data to OFSLL so that accounts can be created in OFSLL servicing module. 

 System validates for the relevant data, if not sends error response. 

 ‘Account Tracking Attributes’ are provided. 

 Details captured in web service > Account Tracking Attributes will be shown under 
‘Servicing > Customer Service > Tracking Attributes’.  

 Three custom fields are provided. 
 

 Following are the provided custom fields 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

 Following ‘Military Service’ fields are provided. 

 Active Military Duty 
 Effective Dt 
 Order Ref# 
 Release Dt 

 Details captured in ‘AccountOnBoarding’ web service >Military Service details will be 
shown under ‘Servicing > Customer Service > Respective account > Customer Details > 
Customer > Military Service section’. 

Following Edit is provided: 

1. New Edit is added to validate the Activate Military duty applicant APR, is not be more than 
36%. 

2. In case of Loan APR is considered and for Lease and Line “Rate” field is considered for 
validation. 

3. Edit Description:  

For Loan: “CONTRACT APR > THAN MAX ALLOWED FOR SCRA APPLICANT” 

For Lease: “LEASE CONTRACT RATE > THAN MAX ALLOWED FOR SCRA                                  
APPLICANT” 

For Line: “LINE CONTRACT RATE > THAN MAX ALLOWED FOR SCRA APPLICANT” 

4. Following are default values for ‘ACCOUNT ON BOARDING EDIT’ 

a. Default result is ERROR 

b. Default Value is “36” 

c. Override responsibility is “NO RESPONSIBILITY” 

d. Enable is “N” by default. 

e. If the applicant is Marked as SCRA (Applicant Block > Military Service > Active 
Military Duty checkbox =’Y’) 
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Note: Some mandatory fields in DB were non-mandatory in XSD, due to which Null pointer issue was 

coming. So provided default values in JAXB and JAVA classes. 

V. ‘Scenario Analysis’ REST web services (Both POST and GET) 
 

 New ‘Scenario Analysis’ POST REST web service is developed, which supports both Loan and 

Lease. User can simulate the customer’s Loan or Lease request (Loan amount, rate and create a 
mock proposal in Loan or Lease with concern lending policies).’Inquiry ID’ is created in the 
response. 

 Three custom fields are provided in the request and response. 

 Following are the provided custom fields 

 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

Service supports below for Loan 

1. Calculate Payment 
2. Calculate Interest Rate 
3. Calculate Term 
4. Calculate Loan Amount 
5. Calculate Blended rate 
6. Flexible Repayment 

 
Service supports below for Lease 

1. Calculate Lease rental 

 New ‘Scenario Analysis’ GET REST web service is developed, which supports both Loan and 

Lease. User can retrieve the saved Scenario Analysis details. (Loan amount, rate and different 
mock proposals in Loan or Lease with concern lending policies.).’Inquiry ID’ is sent as an input. 

 Three custom fields are provided. 

 Following are the provided custom fields 

 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

Service supports below for Loan 

1. Calculate Payment 
2. Calculate Interest Rate 
3. Calculate Term 
4. Calculate Loan Amount 
5. Calculate Blended rate 
6. Flexible Repayment 

 
Service supports below for Lease 

1. Calculate Lease rental 
 
 

VI. ‘Loan Calculator’ and ‘Lease Calculator’ REST web services 

 New ‘Loan Calculator’ and ‘Lease Calculator’ REST web services are developed. 

 Three custom fields are provided in the request and response. 

 Following are the provided custom fields 

 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

Service supports below for Loan 

 Following calculation parameters can be calculated in Loan Calculator Service along with 
Repayment Options and Amortization Schedules. 

 Calculate Payment 
 Calculate Interest Rate 
 Calculate Term 
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 Calculate Loan Amount 
 Calculate Blended Rate 

Service supports below for Lease 

 Following calculation parameters can be calculated in Lease Calculator. 

 Calculate Payment 
 Calculate Rate 
 Calculate Residual Percent 
 Calculate Gross Capitalized Cost 

VII. ‘Payment Posting’ REST web service 

 ‘Payment Posting’ REST Web Service is developed for 'Payment Posting Transaction’ 
and ‘Payment Reversing Transaction'. 

 If on Same Day, Same Account and Same Amounts - Reverse action is not allowed and 
system shows the message as "Multiple Records found, please contact Customer 
Service Agent". 

 Whereas Same Day, Same Account and Different Amounts - Reverse action is possible. 

 Three custom fields are provided. 
 

 Following are the provided custom fields 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

 Validation provided for User Code, Currency Code and Account Number. 

Note: Payments posted using this service will not be displayed in Payment Maintenance 
screen. 

VIII. ‘Account Details’ REST web service 

 New REST ‘Account Details’ web service is developed. 

 To search account details by String account number. 

IX. ‘Application Search’ REST web service 

 New REST ‘Application Search’ web service is developed. 

 To search an application by various attributes such as ApplicationNumber, 
ApplicantFirstName, ApplicantLastName, SSN, Creation Date, BirthDate. 

 Any one of the above mentioned fields is mandatory. 

 Three custom fields are provided in the response. 
 

 Following are the provided custom fields 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

X. ‘LookUpRequestService’ REST web service 

 This service gives flexibility to fetch all the Lookup’s enabled for a Lookup Type. By 
Passing a String that matches to Lookup Type system gives all the lookup codes and 
relevant lookup values. 

 New REST ‘LookUpRequestService’ web service is developed. 

 Three custom fields are provided in the response. 
 

 Following are the provided custom fields 
 Custom User Defined String Data 
 Custom User Defined Number Data 
 Custom User Defined Date Data 

XI. ‘Application Entry’ REST  Web Service 
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 New REST ‘Application Entry’ web service is developed with custom fields available at 

below elements 

 Applicant Address 
 Applicant Employers 
 Applicant Liabilities 
 Applicant Telecom 
 Business Partners 
 Business Affiliates 
 Business Financials 
 Business Liabilities 
 Collateral Valuation 
 Trade-in Details 

 Both SOAP and REST ‘Application Entry’ features will co-exist from this release. 
 

XII. ‘Dialer Integration’ REST web service 
 

 OFSLL has exposed a REST web service that can be called by Dialer system  

 OFSLL has a DIALER_AUTORUN_ACCOUNTS table. This web service inserts 
a record in this table with Account Number and User Id (Only for the first entry, 
then on Dialer will simply update the account number for the user). User can get 
only one account from Dialer at a time. 

 This service having below elements 

 User Code 

 Account Number 

 Both SOAP and REST ‘Dialer Integration’ features will co-exist from this release. 

2.1.3 Seed Data 

SNO TABLE KEY DATA Type 

1 NA NA NA 

Note: Go through following link for more details on web services. 

http://docs.oracle.com/cd/E79024_01/webservice.htm 

  

http://docs.oracle.com/cd/E79024_01/webservice.htm
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2.2 SOAP Web Services Enhancements 

2.2.1 Overview 

Following SOAP web services are enhanced. 

I. Existing ‘Application Entry’ SOAP web service is enhanced with Military details fields. 

 

2.2.2 Description 
 

I. ‘Application Entry’ SOAP  Web Service Enhancement 

 Existing ‘Application Entry’ SOAP web service is enhanced with following ‘Military Service’ fields. 

 SCRA Military Duty Ind 
 SCRA Effective Dt 
 SCRA Order Nbr 
 SCRA Release Dt 

 Details captured in ‘Application Entry’ SOAP web service >Applicant details, will be shown under 
‘Origination > Respective Application > Applicant > Military Service section’. 

Following Edit is provided: 

1. If SCRA Military duty indicator is equal to ‘Y’; SCRA Effective Dt, Order Nbr and Release 
Dt are mandatory. 

2. If SCRA Military duty indicator is equal to ‘N’; SCRA Effective Dt, Order Nbr and Release 
Dt are not required. 

2.2.3 Seed Data 

SNO TABLE KEY DATA Type 

1 NA NA NA 

Note: Go through following link for more details on web services. 

http://docs.oracle.com/cd/E82458_01/webservice.htm 

  

http://docs.oracle.com/cd/E82458_01/webservice.htm
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2.3 Support for Experian Premier Attribute Parallel Profile 
Format (PPF) request and response  

2.3.1 Description 

At present in OFSLL, Experian Premier Attribute consumer report cannot be pulled in PPF (Parallel Profile 
Format); instead it can be pulled only in ‘ARF’ (Automated Response Format). With this enhancement now user 
can pull the Premier Attribute consumer report in PPF format, meaning response file will have both machine 
and human readable contents. 

To enable the PPF, now system inserts the new <ParallelProfile> segment in the Premier Attribute request XML 
and as a result, Experian provides the Premier Attribute human readable contents under segment 700 along 
with the machine readable contents. Post processing of the segment 700, system shows the contents on the 
‘Bureau Report’ screen.  

 Provided a new Credit Bureau parameter under ‘REQUEST PARAMETERS FOR CREDIT BUREAU 

SERVICE’ parameter group as “PARALLEL PROFILE OUTPUT REQUEST FOR PREMIER 

ATTRIBUTE REPORT” with ‘Yes’ or ‘No’. 

o If this parameter is configured as ‘Yes’ and ‘Enabled’, then system will insert the 

<ParallelProfile><FormatType>2</FormatType></ParallelProfile> sub segment/tags under 

the <ARF> root segment. 

o If this parameter is configured as ‘No’ or ‘disabled’ then system won’t insert any new segment 

and existing <ARFVersion>  and <Parsed> tags will be inserted in the request file under the 

segment <ARF>.   

 After the successful response processing, user can see the human readable report under ‘Bureau 

Report’ tab depending up on whether the report has been pulled from Origination/Servicing/Collections 

modules.  

2.3.2 Screen shot            

Before implementing the changes, screen appearance was like there is no data in Bureau Report tab and 
Premier Attributes are displayed under the ‘Add-On’ tab. 
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After implementing the changes, screen appearance is as below: 

 

2.3.3 Seed Data: 

SNO TABLE KEY DATA TYPE 

1 CREDIT_BUREAU_PARAMETERS SET_CRP_REQUEST|EXP_PA_PP_OUTPUT_RESP|ALL|ALL INSERT 

2 FLEX_TABLE_ATTRIBUTES SET_CRP_REQUEST|EXP_PA_PP_OUTPUT_RESP INSERT 
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2.4 Soft Pull request for EXP Premier Attribute report 

2.4.1 Description 

‘Soft Pull’ is the facility provided by Experian credit bureau for lenders to pull the Premier Attribute consumer 
report without impacting the consumer FICO score because of the pull. With this enhancement, while manually 
requesting for Experian Premier Attribute consumer report, system allows the user to mark it as a ‘Soft Pull 
Request’ by ticking the new check box ‘Soft Pull’. Please note that this check box will get enabled only for the 
Experian Premier Attribute report. 

Once ‘Soft Pull’ check box is checked, system will insert the <AccountType> segment in the Premier Attribute 
consumer report request and post processing, system shows the same as part of ‘Report Header’ section in 
Origination and ‘Bureau Report’ tab in Servicing/Collections. 

 Provided a new ‘SET YES TO PREVIEW THE SOFT PULL INDICATOR FOR CREDIT BUREAU EXP 

PA REQUEST’ System Parameter with ‘Yes’ or ‘No’ values. 

o If this parameter is set to ‘Y’ & ‘Enabled’ and Bureau is ‘EXP’ and Report is ‘PREMIER 

ATTRIBUTE’ , then system will show the ‘Soft Pull’ indicator (check box) after click on ‘ADD > 

Create Request’ under ‘Origination > Bureau > Consumer’ or ‘Servicing/Collections > Bureau 

> Consumer’ tabs. 

o If the parameter is set to ‘N’ or ‘Disabled’ or Bureau selected is other than ‘EXP’ or report is 

other than PREMIER ATTRIBUTE, then system will not show ‘Soft Pull’ indicator (check box). 

 Provided a new Credit Bureau parameter under ‘REQUEST PARAMETERS FOR CREDIT BUREAU 

SERVICE’ parameter group as “ACCOUNT PURPOSE TYPE CODE FOR PREMIER ATTRIBUTE 

REPORT” with ‘Parameter Value’ 

o System will consider the value configured for this parameter to populate the <Type> element 

in case ‘Soft Pull’  check box is selected for a request 

 <AccountType> 

<Type>XX</Type> 

</AccountType> 

o If this parameter is disabled then system won’t insert the above segment in the request even 

if user enable the ‘Soft Pull’ indicator before submitting the request 

 After successful response processing, user can see the human readable report under ‘Bureau > 

Report Header’ tab in Origination/Servicing/Collections modules.  

2.4.2 Screen shot        

   

 Before implementing the changes, screen appearance was like this: 

Origination: 
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Servicing/Collections: 

 

After implementing the changes, screen appearance is as below: 

Origination:

 

Servicing/Collections: 
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Seed Data: 

SNO TABLE KEY DATA Type 

1 
CREDIT_BUREAU_PARA
METERS SET_CRP_REQUEST|EXP_PA_ACC_TYPE|ALL|ALL INSERT 

2 SYSTEM_PARAMETERS 
EXP_PA_SOFT_PULL_IND|SET_SYP_SYSTEM|ALL|ALL|A
LL|ALL|ALL|ALL|ALL INSERT 

3 
FLEX_TABLE_ATTRIBUT
ES SET_SYP_SYSTEM|EXP_PA_SOFT_PULL_IND  INSERT 
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2.5 Enhance EXP Credit report to get MLA details 

2.5.1 Description 

At present in OFSLL, Experian Credit Profile consumer report cannot be request for MLA (Military Lending Act) 
covered borrower details; with this enhancement now user can pull the consumer report to request with MLA 
details.  

To enable the MLA, now system inserts the new tag <MLA> in the Credit Profile request XML and as a result, 
Experian provides Military Lending Act covered borrower details under segment 361 along with the machine 
readable contents. Post processing of the segment 361, system shows the contents on the ‘Fraud Messages’ 
tab and ‘Bureau Tab’.  

 Provided a new Credit Bureau parameter under ‘REQUEST PARAMETERS FOR CREDIT BUREAU 

SERVICE’ parameter group as “MILITARY DATA REQUESTED ON CONSUMER EXP REPORT 

REQUEST” with ‘Yes’ or ‘No’. 

o If this parameter is configured as ‘Yes’ and ‘Enabled’, then system will insert the 

<MLA>Y</MLA element under the <AddOn> segment. 

o If this parameter is configured as ‘No’ or ‘disabled’ then system won’t insert any new element 

under available <AddOn> segment.   

 After the successful response processing, user can see the details under ‘Bureau Report’ tab depending up on 

whether the report has been pulled from Origination/Servicing/Collections. 

 Along with in Origination, user can see the details under ‘Fraud Messages’ tab also. 

 

2.5.2 Screen shot        
    After implementing the changes, screen appearance is as below:

 

 

2.5.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 
CREDIT_BUREAU_PARA
METERS SET_CRP_REQUEST|EXP_ARF_MLA|ALL|ALL INSERT 

2 
FLEX_TABLE_ATTRIBUT
ES SET_CRP_REQUEST|EXP_ARF_MLA INSERT 
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2.6 Automatic update of CIIC Code 

2.6.1 Overview 

At present in OFSLL, reporting a CIIC code in Metro II report is manual process and involves posting non-
monetary transaction, call activity creation and also creating bankruptcy tracking details. This enhancement 
addresses the bankruptcy processing efficiency improvement and also to ensure the automatic CIIC posting 
to the correct account relation(s) to reduce the number of manual steps involved. Automatic posting of CIIC 
will ensure that it has no dependency on end user’s knowledge on what needs to be reported in Metro II 
report. 

2.6.2 Description 

I. Automatic Update of CIIC Code 

1. User has to manually create a Bankruptcy record from ‘Collections > Bankruptcy > Customer 
Service > Bankruptcy’ or using ‘CUSTOMER BANKRUPTCY REPORTING INDICATOR- 
CUS_BANKRUPTCY_INFO’ non-monetary transaction. 

i. At present system will internally mark the ‘Customer Bankruptcy Indicator’ to ‘Y’ along 
with that now. 

2. Whenever the system runs the BATCH JOB TO GENERATE METRO 2 DATA 
(CBUUTL_BJ_100_02) system will look for the account relations with ‘Bankruptcy Indicator’ 
having the value ‘Y’ and to selects the applicable CIIC code (system will look into the below 
table) and populates the following columns of METRO_II_DATA table  

i. MET_BASE_CIIC for Primary account relation 
ii. MET_J2_1_CIIC/MET_J2_2_CIIC/MET_J2_3_CIIC/MET_J2_4_CIIC columns for non 

primary account relation (in a sequence of SPOUSE, 2NDRY, COS, COS_SPOUSE, 
COS2, COS2_SPOUSE) 

iii. Once the CIIC code is reported in one of the reporting cycle  and if there is no change 
in the next reporting period, then system will report it as BLANK (‘ ’) 

iv. To populate these MET_BASE_CIIC/ MET_J2_1_CIIC/ MET_J2_2_CIIC/ 
MET_J2_3_CIIC/ MET_J2_4_CIIC columns, System will look into the set of a 
particular account relation bankruptcy records with Current indicator ‘Y’ and based on 
the ‘Disposition’ and ‘Type’ selected, corresponding CIIC code as mentioned in the 
below table will be posted. 

Please Note: If system doesn’t found any of the following match then it will report BLANK (‘ ‘)

 and it is applicable for Loan/Line/Lease.  
 

# Disposition Type CIIC Code Derived 

1 Petition Chapter 7 A 

2 Discharged Chapter 7 E 

3 Dismissed Chapter 7 I 

4 Withdrawn Chapter 7 M 

5 Petition Chapter 11 B 

6 Discharged Chapter 11 F 

7 Dismissed Chapter 11 J 

8 Withdrawn Chapter 11 N 

9 Petition Chapter 12 C 

10 Dismissed Chapter 12 K 

11 Withdrawn Chapter 12 O 

12 Discharged Chapter 12 G 

13 Petition Chapter 13 D 

14 Discharged Chapter 13 H 

15 Dismissed Chapter 13 L 

16 Withdrawn Chapter 13 P 

17 Reaffirmed Reaffirmation of Debt R 

18 Reaff Rescinded Chapter 7 Reaffirmation of Debt Rescinded V 

3. Once customer is out of Bankruptcy protection and status is no more ‘Active Bankruptcy’, user 
needs to manually post the non-monetary transaction ‘CUS_BANKRUPTCY_INFO’ to mark 
the bankruptcy status of the customer as ‘No’. 

4. Now onwards, user need not post the QR-QUEUE/CONDITION REQUEST Call Activity to 
open the CIIC condition to report the same in Metro II. This also means system will not display 
the text ‘CONSUMER INFORMATION INDICATOR CODE (METRO2 - FCRA)’ under the 
account conditions table of Customer Service Summary page. 
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2.6.3 Screenshot 

NA 

2.6.4 Seed Data 

SNO TABLE KEY DATA Type 

1 LOOKUPS BKRP_DISPOSITION_CD|PE INSERT 

2 LOOKUPS BKRP_DISPOSITION_CD|DS INSERT 

3 LOOKUPS BKRP_DISPOSITION_CD|DM INSERT 

4 LOOKUPS BKRP_DISPOSITION_CD|WI INSERT 

5 LOOKUPS BKRP_DISPOSITION_CD|RA INSERT 

6 LOOKUPS BKRP_DISPOSITION_CD|RR INSERT 

7 LOOKUPS BKRP_TYPE_CD|11 INSERT 

8 LOOKUPS BKRP_TYPE_CD|RD_7 INSERT 

9 LOOKUPS BKRP_TYPE_CD|RD INSERT 

10 LOOKUPS BKRP_TYPE_CD|12 INSERT 
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2.7 Support for new Metro II account status codes 62, 93, 
DA and DF 

2.7.1 Description 

 At present, OFSLL is not reporting the following Metro II Account Status codes  

 62:Account paid in full, was a collection account 

 93:Account assigned to internal or external collections 

 DA: Delete entire account (for reasons other than fraud) 

 DF: Delete entire account due to confirmed fraud (fraud investigation completed) 

 

Provided a new ‘Account Event Notification’ non-monetary transaction with following two parameters 

 Transaction Date 

 Event Type 

Once the user posts this transaction manually or through generic post transaction web-service now, system 

will do the following actions based on the Event Type. If event type is 

i. Account assigned to internal or external collection 

a. System will open new “Account under internal/external collections” condition on to that account 

b. Here the ‘Account under internal/external collections’ condition Start Date will update with ‘TXN 

Date’ of the transaction posting 

c. While posting the transaction, system will check the account status is not ‘VOID’ and then only 

updates the Metro II account status (ACCOUNTS. ACC_CRB_ACC_STATUS_CD) as ‘93’ 

d. If the account status is ‘VOID’, then system will keep the transaction in FAILED status and 

shows “SELECTED EVENT TYPE IS NOT ALLOWED FOR VOID ACCOUNTS’ error 

message. 

e. When the account status changes to ‘Paid Off’ or ‘Terminate’ then when system runs the SET-

TPE > TXNTIP_BJ_100_01(TERMINATION PROCESSING) batch job then system will update 

the ACC_CRB_ACC_STATUS_CD to 62 and if there is no active ‘Account under 

internal/external collections’ condition account status will be updated as 13 only. 

ii. Account moved out from internal/external collections 

a. System closes an existing new “Account under internal/external collections” condition on to 

that account 

b. If there is no active ‘Account under internal/external collections’ condition on the account, while 

billing batch job executes (TXNDDT_BJ_100_01 (SET-TPE) BILLING / DUE DATES 

PROCESSING), it will update the metro account status code back based on the existing logic. 

c. If there is no Active ‘Account under internal/external collections’ condition exist on the 

Account, system will show ‘No Active Collections condition exist on the Account’ error 

iii. Delete Entire Account (for reason other than fraud) 

a. System will open a new “DELETE ACCOUNT – NON FRAUD” condition on to that account 

b. Here the ‘Delete Account – Non Fraud-DC’ condition Start Date will be ‘TXN Date’ of the 

transaction 

c. While posting the transaction, system will check the account status is ‘VOID’ and then system 

will update the Metro II account status (ACCOUNTS. ACC_CRB_ACC_STATUS_CD) as ‘DA’. 

d. If the account is not in ‘VOID’ status, then system will keep the transaction in FAILED status 

and show “SELECTED EVENT TYPE IS ALLOWED ONLY FOR VOID ACCOUNTS” error 

message. 

iv. Delete entire account due to confirmed fraud 

a. System will Open a new “DELETE ACCOUNT – FRAUD” condition on to that account 

b. Here the ‘Delete Account – Fraud’ condition Start Date will be ‘TXN Date’ of the transaction 

c. While posting the transaction, system will check the account status is ‘VOID’ and then system 

will update the Metro II account status (ACCOUNTS. ACC_CRB_ACC_STATUS_CD) as ‘DF’  

d. If the account is not in ‘VOID’ status, then system will keep the transaction in FAILED status 

and show “SELECTED EVENT TYPE IS ALLOWED ONLY FOR VOID ACCOUNTS” error 

message 
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2.7.2 Screen shot        
    After implementing the changes, screen appearance is as below:  
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2.7.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 LOOKUP_TYPE ACC_EVENT_NOTIFY_CD Insert 

2 LOOKUPS 
ACC_EVENT_NOTIFY_CD|AAC   

Insert 

3 LOOKUPS 
ACC_EVENT_NOTIFY_CD|COLL_CANCEL   

Insert 

4 LOOKUPS 
ACC_EVENT_NOTIFY_CD|DELETE_ACCOUNT 

Insert 

5 LOOKUPS 
ACC_EVENT_NOTIFY_CD|DELETE_ACCOUNT_FRAUD 

Insert 

6 LOOKUPS 
CRB_ACC_STATUS_CD | DF  

Insert 

7 
LOOKUPS 

ACC_CONDITION_CD | COLL 

Insert 

8 
LOOKUPS 

ACC_CONDITION_CD | DNF 

Insert 

9 LOOKUPS 
ACC_CONDITION_CD | DF 

Insert 

10 TXN_CODES 
ACC_EVENT_NOTIFY 

Insert 

11 
TXN_CODE_PARAMETE
RS 

ACC_EVENT_NOTIFY|TNM_ACC_EVENT_NOTIFY_CD 
Insert 

12 

TXN_CODE_PARAMETE
RS 

ACC_EVENT_NOTIFY|TNM_ACC_EVENT_NOTIFY_DT 

 

13 FLEX_TABLE 
INP_BMP_TNM|TNM_ACC_EVENT_NOTIFY_CD  

Insert 

14 FLEX_TABLE 
INP_BMP_TNM|TNM_ACC_EVENT_NOTIFY_DT  

Insert 
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2.8 Reporting Metro II Account Status for Paid-Off 

2.8.1 Description 

At present, OFSLL is reporting the Account Status code ‘13’ if the Account status is 'Paid' and it is a 
‘Closed’ account. But as per the Credit Reporting Resource Guide client should ability to report an 
account as paid-off at the time it is paid-off. 

Now OFSLL will report the Account Status ‘13’ if the account status is ‘Paid’ and either Account is in ‘Closed’ 
status or account balance is less than or equal to Zero. 

 

2.8.2 Screen shot        
    After implementing the changes, screen appearance is as below:  

 
2.8.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.9 Separate codes needs to be used to report customer 
name/address/SSN changes 

2.9.1 Description 

At present, OFSLL is reporting the limited number of ‘Consumer Transaction Type Codes’ as part of Credit 
Bureau reporting. As per the Credit Report Resource Guide client should use separate codes needs to be used 
to report customer name/address/SSN changes. At present OFSLL using ‘A’ and ‘3’ to report Name, Address 
and/or Social Security Number change. 

Consumer Transaction Type used to indicate a new record, a new borrower or a change in consumer 
identification. Values available:  

i. 1 = Newly opened account, or new borrower associated with existing account  

ii. 2 = Name change  

iii. 3 = Address change  

iv. 5 = Social Security Number change  

v. 6 = Name & Address change  

vi. 8 = Name & Social Security Number change  

vii. 9 = Address & Social Security Number change  

viii. A = Name, Address and/or Social Security Number change  

ix. If account or borrower is not new, or if no change in consumer information, blank fill. 

 Metro II reporting file fields involved –  

o Field 29 | Base Segment |  MET_BASE_CONSUMER_TXN_TYPE 

o Field 2 | J1-1/2/3/4 segments | MET_J2_1/2/3/4_CONSUMER_TXN_TYPE 

 At present system only checks whether LAST_UPDATE_DATE field of CUSTOMERS table is 
greater than the last Metro II reporting period and decides that Name and SSN number would have 
been changed and reports the value ‘A’. Similarly if LAST_UPDATE_DATE field of ADDRESS table 
is greater than the last Metro II reporting period, system decides CUSTOMER address would have  
been changed and reports the value  ‘3’. 

 Whenever METRO_II_DATA table population batch executes, system moves the current Name, 
SSN and Address details of the Borrower and other maximum of seven relation types i.e. Spouse, 
Secondary, Co-Signer, Co-Signer Spouse, Co-Signer 2 and Co-Signer2 Spouse (if exists) to this 
table.  

Now, OFSLL will populate the newly created CUS_METRO_II_TXN_TYPE column in Customers table 

whenever there is an update happens on Customer Information and/or Customer Address information based 
on the codes provided by Credit Report Resource Guidelines as below now system will report following 
codes 

o Txn Type 1 - Newly opened account, or new borrower associated with existing 

account with Existing logic 

o Txn Type 2  - If there is a change in any below Name columns 

 CUS_SURNAME 

 CUS_FIRST_NAME 

 CUS_MIDDLE_NAME 

o Txn Type 3 - If there is a change in any below Address  columns 

 ADR_COUNTRY_CODE 

 ADR_ADDRESS_LINE1 

 ADR_ADDRESS_LINE2 

 ADR_CITY 

 ADR _STATE 

 ADR_POSTAL_CODE 

o Txn Type 5  - If there is a change in CUS_SSN column 
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o Txn Type 6 - If there is change in both Name and Address   

o Txn Type 8 - If there is change in Name and SSN  

o Txn Type 9  - If there is a change in Address and SSN 

o Txn Type  A - If there is change in Name, Address and/or Social Security Number 

change 

 

2.9.2 Seed Data: 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.10 METRO II file generation changes 

2.10.1 Description 

Currently in OFSLL, when system executes the CBUUTL_BJ_100_03 (BATCH JOB FOR CREATING METRO 
2 DATA FILE) batch job to generate the Metro II file in the output location using C language. 

Provided a new system parameter (METRO_II_PROGRAM_MODE_CD) having value as C/ PLSQL 

Language. If this is set to ‘C Language’ or Disable or Enable then system will use the C code to generate the 
Metro II file, if it is set it as PLSQL and Enable then system will use the PL/SQL language to generate the Metro 
II file. 
2.10.2 Seed Data: 

SNO TABLE KEY DATA Type 

1 
FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|METRO_II_PROGRAM_MODE_
CD Insert 

2 System Parameter 

METRO_II_PROGRAM_MODE_CD|SET_SYP_SYST
EM|ALL|ALL|ALL|ALL|ALL|ALL|ALL Insert 

3 LOOKUPS PROGRAM_CD|C Insert 

4 LOOKUPS PROGRAM_CD|PLSQL  Insert 

5 LOOKUP_TYPES PROGRAM_CD Insert 

 

2.10.1 Seed Data: 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.11 Generic Payment Upload 

2.11.1 Overview 

Generic Payment Upload file format is created to provide a facility to upload payment transactions in bulk. 

2.11.2  Description 

I. New System Parameter to define action on file upload 

1. A new system parameter ‘Payment Batch Posting Preference’ (Refer existing 
lookup - BMT_STATUS_CD) is provided. 

a. Based upon the value selected in system parameter, system creates 
batch in OPEN or HOLD or POSTED. 

b. Here is user is supposed to choose OPEN/ HOLD/ POSTED in system 
parameter (correct setup). 

 

II. New File format to upload payments in bulk. 

This file format supports One Header and Multiple Detail records (which mean only On 
Header Section and one Currency). 

Header: 

Field 
Name 

Expected Values Mandatory 
(Y/N) 

Validations/Comments 

Company Provide Company 
Code 

Y System validates Company code in OFSLL and 
rejects entire batch, if no such company code 
found. 

Currency Provide Currency 
Code 

Y System validates Currency code/exchange rate 
in OFSLL and rejects entire batch, if no such 
Currency code found. 

Mode Provide ‘Mode’ 
Code 

Y System validates ‘Mode’ code in OFSLL and 
rejects entire batch, if no such Mode code 
found. 

Reason Provide ‘Reason 
Code’ 

N System validates ‘Reason’ code in OFSLL and 
rejects entire batch, if no such Reason code 
found. 

Total Provide ‘Total # of 
‘Detail Records’ 

Y Accepts only Numerical 

If user inputs Decimals/Negative Value/Text – 
System rejects the whole batch. 

Total 
Amount 

Provide ‘Total Amt’ 
i.e, sum of Details 
Records 

Y Accepts only Numerical 

If user inputs Negative Value/Text – System 
rejects the whole batch. 

 

Detail Record 

Field 
Name 

Expected 
Values 

Mandatory 
(Y/N) 

Default Validations/Comments 

Account # Account 
Number 

Y  If Account no. is not matched, 
system records the payment as 
‘Suspense’ against ‘Company’ 
provided in header. 
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Pmt Date Payment 
Date 

Y  Reject record, if date is future 
date. 

This would be added to bad 
records. 

User is expected to check bad 
file. 

Pmt 
Amount 

Payment 
Amount 

Y  Reject if input is not numeric or 
negative amount. 

This would be added to bad 
records. 

User is expected to check bad 
file. 

Spread Spread 
(Spread 
Code) 

N If user keeps this 
field blank, default 
spread applicable 
based on spread 
matrix OR value 
defined in contract. 

Reject if ‘Spread’ code is invalid. 

This would be added to bad 
records. 

User is expected to check bad 
file. 

Reference Free Text N  Reference Number 

 

III. Processing of Uploaded File 

a. New batch job created to process the payment upload file. 

b. New lookup code “PAYMENT_UPLOAD [PAYMENT LOAD]” added for lookup 
type GROUP_SUB_TYPE_CD with Sub Code as “PAY”. While uploading batch 
use the ‘Payment_Upload’ value by default. 

c. Existing system parameter LBX_TXN_GROUPING_CNT -BATCH SIZE OF 
LOCKBOX RECORDS used to define the batch size of payment upload 

d. Renamed the above system parameter as ‘BATCH SIZE OF PAYMENT 
UPLOAD RECORDS’. 

i. System rejects the payment batch in following cases and put in ‘Un-
Processed’ Records folder. 

1. If the records in upload file (Detail Records) is greater than the 
definition in ‘BATCH SIZE RECORDS’ parameter. 

2. If the records in upload file (Detail Records) is greater/less than 
‘Total #’ in header section. 

e. After successful run of batch job; system creates ‘Payment Batch’ in 
HOLD/POST based on the system parameter value. [Note: In case of batch 
created in HOLD; User is expected to verify the batch and payment records to 
click on POST]. 

 

Upload Action: 

Once user uploads the file format, system does the following actions. 

1. System identifies ‘Header’ and ‘Detail’ records in payment file and creates batch. 

i. Before uploading, system validates payment batch with Total #, Ctrl 
Total #, Total Amt, Ctrl Total Amt; based on ‘Header’ and ‘Detail’ 
records. 

2. Creates entries in ‘Payment Block’ and ‘Payment Transactions’ Block 
automatically. 

 

IV. Handling Exceptions 
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1. System creates batch with corresponding record in ‘SUSPENSE’ in case of 
following scenarios 

 Account no. does not match with ‘Company’ given in header 

 Also, System creates record in bad file with a reason ‘Invalid 
Account Number (for reconciliation purpose). 

Example: 

C-0001,USD,T,REG,1,2098,                                                                                 (Header) 
200001002113632,1/26/2017,2098,AC,FIRSTFILEUPLOAD1,                            (Detail) 

2.11.3 Screenshot 

 Not  Applicable 

2.11.4 Seed Data 

SNO TABLE KEY DATA Type 

1 FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|PMT_BATCH_POSTING        INSERT 

2 FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|IPU_DIRECTORY            INSERT 

3 FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|IPU_PROCESSED_DIRECTORY INSERT 

4 FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|LBX_TXN_GROUPING_CNT UPDATE  

5 JOB_THREADS SET-IFP|IPUPRC_BJ_100_01 INSERT 

6 JOBS SET-IFP|IPUPRC_BJ_100_01 INSERT 

7 LOOKUPS GROUP_SUB_TYPE_CD|PAYMENT_UPLOAD INSERT 

8 LOOKUPS INCOMING_FILE_TYPE_CD|IPU INSERT 

9 SYSTEM_PARAMETERS PMT_BATCH_POSTING|SET_SYP_SYSTEM|ALL|ALL|ALL|A
LL|ALL|ALL|ALL 

INSERT 
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2.12 Bankruptcy Interface 

2.12.1 Overview 

OFSLL is enhanced with new Bankruptcy interface to: 

 Generate customer output file per account and send to external interface to validate any new/update on 

Bankruptcy filing of existing customers. 

 Process ‘Bankruptcy’ input file received from external system and display in external interface screen.  

 On user approval in external interface screen, Bankruptcy details received are updated into tracking 

attributes. 

2.12.2 Description 

Enhancements to the Data files Setup screen 

1. Created ‘Output’ and ‘Input’ tabs under “Setup > Administrator > System > Data Files” 

a. Moved the existing “Data Files” tab under new ‘Output’ tab i.e. Output have following three 

sections  

1. Data File Definitions 

2. Record Definitions 

3. Column Definitions 

ii. ‘Input’ section have following two sections 

1. Input Data File Definition 

2. Column Definition 

Note: Based on sort order specified data in Customer Service  Account  External 

Interface data displayed in ascending order. 

2. A new batch job (SET-ODD2 OBIPRC_BJ_100_01) is created to generated customer bankruptcy 

files with below:  

a. Pick records accounts in ‘Active’ or ‘Charge off’ status. 

b. A New lookup [BKRP EXCLUDE CONDITIONS] is added to exclude conditions to be 

considered while creating this file to be sent to external interface. 

c. User is expected to maintain list of Exclude account conditions which are to be considered 

for report creation.  

3. A new batch job (SET-IFP  IDDPRC_BJ_000_01) is created to process bankruptcy updates sent 

from external system 

a. On the job executes successfully, system display records in respective account under 

“Servicing/Collections > Customer Service > External Interfaces tab (taking ‘Account No.’ 

as reference). 

b. Once record is placed in ‘External Interfaces’ tab, user is expected to validate and create 

‘Bankruptcy’ record, load tracking attributes and ‘Accept/Reject’ record’. 

c. Once the record is accepted, system copies bankruptcy details to ‘Tracking Attributes’ 

under Bankruptcy tab - based on customer SSN number. (Before that user is expected to 

create bankruptcy record and load tracking attributes). 

d. BANKO supports – New and Update File; both follows the same approach for 

‘Accept/Reject’. 
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2.12.3 Screenshot 

Setup > Data Files  

 
Setup > Data Files > Input 

 
Setup > Lookup Type  

 
Customer Service > External Interface  
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2.12.4 Seed Data: 

SNO TABLE KEY DATA Type 

1 OUTPUT_FILE_DEFINITIONS BKRP_INTERFACE INSERT 

2 OUTPUT_FILE_RECORD_TYPES BKRP_INTERFACE|1 INSERT 

3 OUTPUT_FILE_RECORD_TYPES BKRP_INTERFACE|2 INSERT 

4 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|ADDRESS INSERT 

5 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|ZIP INSERT 

6 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|AGREEMENT DATE INSERT 

7 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|CITY INSERT 

8 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|CLIENT INSERT 

9 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|CUSTOMER ACCOUNT INSERT 

10 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|FIRST NAME INSERT 

11 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|LAST NAME INSERT 

12 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|MIDDLE NAME INSERT 

13 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|PRODUCT CODE INSERT 

14 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|STATE INSERT 

15 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|SUFFIX INSERT 

16 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|US NATIONAL ID INSERT 

17 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|1|ZIP INSERT 

18 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|ADDRESS INSERT 

19 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|AGREEMENT DATE  INSERT 

20 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|CITY INSERT 

21 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|CLIENT INSERT 

22 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|CUSTOMER ACCOUNT INSERT 

23 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|FIRST NAME INSERT 

24 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|LAST NAME INSERT 

25 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|MIDDLE NAME INSERT 

26 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|PRODUCT CODE INSERT 

27 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|STATE INSERT 

28 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|SUFFIX INSERT 

29 OUTPUT_FILE_RECORD_DETAILS BKRP_INTERFACE|2|US NATIONAL ID INSERT 

30 INPUT_FILE_DEFINITIONS BKRP_NEW INSERT 

31 INPUT_FILE_DEFINITIONS BKRP_UPDATE INSERT 

32 INPUT_FILE_RECORD_DETAILS BKRP_NEW|ACCOUNT_NBR INSERT 

33 INPUT_FILE_RECORD_DETAILS BKRP_NEW|ATT_ADDRESS INSERT 

34 INPUT_FILE_RECORD_DETAILS BKRP_NEW|ATT_NAME INSERT 

35 INPUT_FILE_RECORD_DETAILS BKRP_NEW|ATT_PHONE_NO INSERT 

36 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_341A_DT INSERT 

37 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_341_LOCATION INSERT 

38 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_341_TIME INSERT 

39 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ADDRESS INSERT 

40 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ATTORNEY_CITY INSERT 

41 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ATTORNEY_STATE INSERT 

42 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ATTORNEY_ZIP INSERT 

43 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BKP_CITY INSERT 

44 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BKP_STATE INSERT 
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45 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BUSINESS1 INSERT 

46 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BUSINESS2 INSERT 

47 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BUSINESS3 INSERT 

48 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_BUSINESS4 INSERT 

49 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CASE_NO INSERT 

50 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CHAPTER INSERT 

51 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CITY INSERT 

52 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CLIENT_CODE INSERT 

53 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CLIENT_INPUT_SSN INSERT 

54 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CLIENT_UPDATE_FLAG INSERT 

55 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_CLOSED_DT INSERT 

56 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COUNTRY INSERT 

57 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_ADDRESS1 INSERT 

58 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_ADDRESS2 INSERT 

59 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_DISTRICT INSERT 

60 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_ID INSERT 

61 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_MAILING_CITY INSERT 

62 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_PHONE INSERT 

63 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_COURT_ZIP INSERT 

64 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_DEBTOR_PHONE INSERT 

65 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_DISCHARGE_BAR_DT INSERT 

66 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_DISPOSITION INSERT 

67 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ECOA INSERT 

68 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_FILE_DT INSERT 

69 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_FILING_STATUS INSERT 

70 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_FIRST_NAME INSERT 

71 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_FUNDS INSERT 

72 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_GENERATION INSERT 

73 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_INTERNAL_TRACKING INSERT 

74 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_JUDGES_INITIALS INSERT 

75 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_LAST_NAME INSERT 

76 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_LAW_FIRM INSERT 

77 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_MATCH_CODE INSERT 

78 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_MIDDLE_NAME INSERT 

79 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_PROOF_OF_CLAIM_BAR_DT INSERT 

80 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_REINSTATED_CASE_DT INSERT 

81 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_SSN INSERT 

82 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_STATE INSERT 

83 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_STATUS_DT INSERT 

84 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE INSERT 

85 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_ADDRESS INSERT 

86 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_CITY INSERT 

87 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_ID INSERT 

88 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_PHONE INSERT 

89 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_STATE INSERT 

90 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_TRUSTEE_ZIP INSERT 
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91 INPUT_FILE_RECORD_DETAILS 
BKRP_NEW|BKI_VOINVOLUNTARY_DISMISSA
L INSERT 

92 INPUT_FILE_RECORD_DETAILS BKRP_NEW|BKI_ZIP INSERT 

93 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|ACCOUNT_NBR INSERT 

94 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_CASE_NO INSERT 

95 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_CHAPTER INSERT 

96 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_CLIENT_FIELD INSERT 

97 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_DOCKET_TEXT INSERT 

98 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_DOC_LINK INSERT 

99 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_EVENT_CATEGORY INSERT 

100 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_EVENT_CODE INSERT 

101 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_EVENT_DESC INSERT 

102 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_EVENT_DT INSERT 

103 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_EVENT_SCORE INSERT 

104 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_KEY_SEARCH_FLAG INSERT 

105 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_LAST_NAME INSERT 

106 INPUT_FILE_RECORD_DETAILS BKRP_UPDATE|BKI_SSN INSERT 

107 LOOKUP_TYPES BKRP_CONDITION_CD INSERT 

108 LOOKUPS BKRP_CONDITION_CD|UNDEFINED INSERT 

109 LOOKUPS INCOMING_FILE_TYPE_CD|IBU UPDATE 

110 LOOKUPS INCOMING_FILE_TYPE_CD|IBN UPDATE 

111 LOOKUPS ACC_CONDITION_CD|BKRP_CHECK INSERT 

112 JOBS SET-ODD2|OBIPRC_BJ_100_01 UPDATE 

113 FLEX_TABLE_ATTRIBUTES SET_SYP_SYSTEM|BKRP_FILE_REC_LIMIT INSERT 

114 SYSTEM_PARAMETERS 
BKRP_FILE_REC_LIMIT|SET_SYP_SYSTEM|AL
L|ALL|ALL|ALL|ALL|ALL|ALL INSERT 

115 FLS_ACCESS FLL.SET.UAD.INPUTDATAFILE.ADD.BUTTON 
INSERT 

116 FLS_ACCESS FLL.SET.UAD.INPUTDATAFILE.AUDIT.BUTTON  
INSERT 

117 FLS_ACCESS FLL.SET.UAD.INPUTDATAFILE.EDIT.BUTTON  
INSERT 

118 FLS_ACCESS FLL.SET.UAD.INPUTDATAFILE.VIEW.BUTTON  
INSERT 

119 FLS_ACCESS 
FLL.SET.UAD.INPUTDATARECORDDETAIL.AD
D.BUTTON 

INSERT 

120 FLS_ACCESS 
FLL.SET.UAD.INPUTDATARECORDDETAIL. 
AUDIT.BUTTON 

INSERT 

121 FLS_ACCESS 
FLL.SET.UAD.INPUTDATARECORDDETAIL. 
EDIT.BUTTON 

INSERT 

122 FLS_ACCESS 
FLL.SET.UAD.INPUTDATARECORDDETAIL. 
VIEW.BUTTON 

INSERT 

123 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATAFILE.ADD.BUTTO
N 

INSERT 

124 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATAFILE.AUDIT.BUTT
ON  

INSERT 

125 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATAFILE.EDIT.BUTTO
N  

INSERT 

126 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATAFILE.VIEW.BUTTO
N 

INSERT 

127 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATARECORDDETAIL.A
DD.BUTTON 

INSERT 

128 FLS_ACCESS 

FLL.SET.UAD. 
OUTPUTDATARECORDDETAIL.AUDIT.BUTTO
N 

INSERT 

129 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATARECORDDETAIL.E
DIT.BUTTON 

INSERT 

130 FLS_ACCESS 
FLL.SET.UAD.OUTPUTDATARECORDDETAIL.V
IEW.BUTTON 

INSERT 
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2.13 Currency Exchange Upload 

2.13.1 Overview 

 Ability to upload “Currency Exchange Rates” using input file upload. 

2.13.2 Description 

 A new batch job (SET-IFP - ICEPRC_BJ_100_01) created to process the currency upload file. 

 System creates update logs, if any records failed to upload. 

 As per existing infrastructure for batch jobs, all the processed and unprocessed records are placed in 

processed folder with file name ‘Currency_Exchange_Upload_processed’ and unprocessed/ rejected 

records with file name ‘Currency_Exchange_Upload_bad’. 

 User is expected to correct issues and re-upload file for processing. 

 System checks the duplicate records, if exists in system and error out, based on date and time stamp. 

 

Sample format: 

USD,JPY,05192016230110,22.23, 

USD,INR,05192016231112,66.23 

INR,USD,05192016231112,0.01 
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2.14 Bureau Pull Validation 

2.14.1 Overview 

 Credit bureau pull process is enhanced to consider time lag between last pull (days) for same 

Bureau Company before processing new request. (Federal rule - Only pull 1 CB in X (30) days 

for same bureau).  

2.14.2 Description 

Validating bureau request creation based on the new system parameters. 

 Created a new system parameter (Days to Pull CRB Report) to configure the number days to 

validate the bureau pull.  

 New Organization Level parameter is created to specify whether bureau pull validation is 

warning/error. - CRB_ERROR_VALIDATION_IND.  

 While user tries to ‘Create Request’ from Servicing/Collections Customer Service  Bureau  

Add Create Request  

• System validates, if there is any existing Bureau Pulls are available in the system for that 

SSN. 

• If the number of days is less than or equal to the above parameter days; based on 

organization parameter, system will throw either warning/ error message, i.e. “Bureau 

Report is exists for this customer from the same Bureau” along with last pulled account 

number and/or application number. 

 

2.14.3 Seed Data 

SN
O TABLE KEY DATA 

Typ
e 

1 
SYSTEM_PARAME
TERS 

CRB_ERROR_VALIDATION_IND|SET_SYP_ORGANIZATION|ALL|ALL|ALL|
ALL|ALL|ALL|ALL NA 

2 
SYSTEM_PARAME
TERS 

DAYS_TO_PULL_CRB_REPORT|SET_SYP_SYSTEM|ALL|ALL|ALL|ALL|AL
L|ALL|ALL NA 
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2.15 Enhance EFX Credit Report to get MLA details in ACRO 
format 

2.15.1 Description 

At present in OFSLL, Equifax Credit Report consumer report cannot be request for MLA (Military Lending Act) 
covered borrower details; with this enhancement now user can pull the consumer report to request with MLA 
details in an ACRO format.  

To get the MLA segment, client can enable MLA add-on response at subscriber id level with EFX so that 
Equifax will send the MLA response irrespective of the request input. If the client is expected to get the MLA 
response based on the request, now system inserts the new ‘Output Format’ code which is T4 and New ‘Input 
Format Code’ which is 72 along with this New ‘Optional Feature Code’ which is B will be inserted in the request 

based on the ‘Report Type’ requested. 

Equifax provides Military Lending Act covered borrower details under a new ML segment along with the 
machine readable contents. Post processing of the ML segment, system shows the contents on the ‘Fraud 
Messages’ tab and ‘Bureau Tab’.  

 Provided a new BT4 (FFF/STD PRINT IMAGE COMBO REPORT PLUS/CREDIT REPORT W/MLA) 

Lookup Code under CRB_REPORT_TYPE_CD Lookup 

o With this, user can configure the new report under ‘Setup > Administration > User > Credit 

Bureau > Report Formats > Report Format Details’ using this Equifax Report Type. 

 After the successful response processing, user can see the details under ‘Bureau Report’ tab depending up on 

whether the report has been pulled from Origination/Servicing/Collections. 

 Along with in Origination, user can see the details under ‘Fraud Messages’ tab also. 

 

2.15.2 Screen shot        
    After implementing the changes, screen appearance is as below: 

 

 
2.15.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 LOOKUPS CRB_REPORT_TYPE_CD|BT4  Insert 
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2.16 SCRA Off-Military Duty 

2.16.1 Overview 

As per the act, once the ‘Off Military Duty’ transaction is posted; system restores back original rate 
and instalment amount. 

2.16.2 Description 

I. Changes to SCRA transactions to handle ‘Military Duty’ to revert back to contracted 
interest rate and Payment Amount 

A new parameter is introduced in “Borrower off military duty” transaction called ‘Payment 
Calculation Method’. 

Fixed/Variable Rate Loan 

a) If user selects ‘Calculate New Payment’; system recalculates the payment amount 
using contract interest rate (Current existing system behaviour). 

b) If user selects ‘Restore Account Payment’; system restores contract interest rate and 
instalment amount. 

 Here, any remaining balance after ‘Restore to Account Payment’ is adjusted to 
last instalment amount. 

 In case any ‘Rate Change’ transaction is posted on account before posting ‘On 
Military Duty’, system goes back to rate posted on account due to ‘Rate Change’ 
transaction (not contract rate).  

Transaction 
Parameter 

Description Data Type Default Mandatory Comments 

Txn Date Input Txn Date Date NULL Y Existing Parameter 

Borrower 
Relation with 
Account 

Select relation Dropdown 
(LOV) 

Primary Y Existing Parameter 

Payment Calc 
Method 

Select the 
payment 
calculation 
method 

Dropdown 
(LOV) 

Restore 
Account 
Payment 

Y List of values – 
 Restore Account 

Payment 
 Calculate New 

Payment 

2.16.3 Seed Data Changes: 

SNO TABLE KEY DATA Type 

1 FLEX_TABLE_ATTRIBUTES INP_BMP_TXN|TXN_SCRA_OFF_PMT_CAL_METHOD_CD INSERT 

2 LOOKUP_TYPES SCRA_OFF_PMT_CALC_METHOD_CD INSERT 

3 LOOKUPS SCRA_OFF_PMT_CALC_METHOD_CD|RESTORE_CON_PMT INSERT 

4 LOOKUPS SCRA_OFF_PMT_CALC_METHOD_CD|CALC_NEW_PMT INSERT 

5 TXN_CODE PARAMETERS CUST_OFF_MLTRY_DUTY|TXN_SCRA_OFF_PMT_CAL_METHOD_CD INSERT 
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2.17 SCRA changes to accommodate new changes in Military 
lending Act 

2.17.1 Overview 

Currently, there is no provision to capture Active Military Duty details in Origination. To provide this facility 
following enhancements are taken. 

 Added new fields to capture Active Military Duty Details at Applicant Level in Origination. 

 Two edits are added to validate Max APR allowed and cross check the captured Active military 
duty details with applicant Bureau Details. 

 Propagating the Active Military Duty details from Origination to servicing. 

2.17.2  Description 

I. Under the Applicant header in Origination >Applicant tab, following new fields added to 

capture the SCRA details/Military Service. 

Field Name Description Type Mandatory Remarks 

Active 
Military Duty 

Capture if applicant is on 
Active Military Duty 

Check 
box 

No  

Effective Dt Effective Dt  Date Y Mandatory when Active 
Military duty is flagged as 
Yes 

Order Ref# Capture Order reference 
number 

String Y Mandatory when Active 
Military duty is flagged as 
Yes 

Release Dt Date when the applicant is 
released from Active Military 
duty 

Date N Not mandatory 

 

 

II. New Edit - 1  

1. New Edit is added to validate the Activate Military duty application’s APR can’t be 
more than SCRA Max APR allowed. 

2. Edit Description: “RANGE: SCRA APPLICANT PRESENT: CONTRACT APR > MAX 
APR ALLOWED”. 
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a. In case of Loan, system will consider the APR and for Line and Lease 
system considers “Rate” field for validation 

3. This new edit is part of ‘CONTRACT EDIT’ and ‘ACCOUNT ON BOARDING EDIT’ 

a. Default result will be ERROR 

b. Default Value will be  “36” 

c. Override responsibility will be “NO RESPONSIBILITY” 

d. Enable is “N” by default. 

e. If the applicant is Marked as SCRA (Applicant Block > Military Service > 
Active Military Duty checkbox =’Y’) 

III. New Edit - 2 

1. New Edit set is added to validate Experian bureau report’s ‘Active Military Duty’ status 
against the user input details 

Edit Description: “EXPERIAN MILITARY DUTY INDICATOR MISMATCH FOR 
<Applicant Relation> APPLICANT”. 

2. This Edit is created for all 7 applicants. 

3. This new edit is part  of APP APPROVAL EDITS > ORIGINATION CREDIT BUREAU 
EDITS 

a. Default result is WARNING 

b. Default Value is  NA 

c. Override responsibility is “NO RESPONSIBILITY” 

d. Enable is “N” by default. 

e. In case of SCRA flag mismatch between Applicant Active Military Duty and 
Bureau details; system will trigger the edit for each Applicant type. 

f. Following reference column to validate the information for bureau: 

i. For Active Military duty - If text begins with “1203 MLA COVERED 

BORROWER”  

ii. For Non-Active Military duty - If text begins with “1204 NON-MLA 

COVERED BORROWER” 

IV. New Edit - 3 

i. New Edit set is added to validate Equifax bureau report’s ‘Active Military Duty’ status 
against the user input details 

Edit Description: “EQIFAX MILITARY DUTY INDICATOR MISMATCH FOR <Applicant 
Relation> APPLICANT”. 

1. This Edit is created for all 7 applicants 

2. This new edit is part  of APP APPROVAL EDITS > ORIGINATION CREDIT BUREAU 
EDITS  

a. Default result should be WARNING 

b. Default Value should be  NA 

c. Override responsibility should be “NO RESPONSIBILITY” 

d. Enable is “N” by default. 

e. In case of SCRA flag mismatch between Applicant Active Military Duty and 
Bureau details; system should trigger the edit for each Applicant type. 

f. Reference columns to validate the information for bureaus: 

i. Fraud Messages Tab  

1. For Active Military duty - If text begins with “COVERED 
BORROWER STATUS - YES”  

2. For Non-Active Military duty - If text begins with “COVERED 
BORROWER STATUS – NO” 
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ii. Servicing Changes 

1. When an application with applicant having Active Military duty is funded, Customer 
created for that applicant will have these attributes. 

2. When an application is funded, Active Military details are populated in customer table. 

1. When CUS_SCRA_IND is ‘YES’ at the time of account creation, 

o System posts the “ON ACTIVE MILITARY DUTY” and “DO NOT 
CHARGE OFF” conditions on the account for Loan, Line and Lease 
Products. 

o System shows the Contract interest rate as SCRA rate in account 
details tab in servicing for Loan and Line Accounts. 

o In case of Lease Accounts there will not be any impact on Interest 
rate. 

o And system prepares the repayment schedule with contract rate. 

3. If the customer is on active military duty  

a. A system parameter “MAXIMUM RATE ALLOWED FOR SCRA ACCOUNT” 
is added to specify Max SCRA rate for an active military duty account. 

b. When the user tries to post “INDEX / MARGIN RATE CHANGE” transaction 
and if it result in interest rate greater than System parameter value, system 
will validate and transaction is not allowed to post. 

4. To remain in “Contract Rate/Account Rate” even after entering Military Services 
multiple times in a life of a loan. 

a. A “Rate Benefit” Parameter is added to specify whether to consider SCRA 
specified rate or remain in “Contract Rate”. 

Parameter Name Type Default Mandatory 

Rate Benefit LOV (Yes/No) Y Yes 

b. If the parameter “Rate Benefit” is set to “Y”, system will consider SCRA specified 
rate which can be “System parameter rate or Rate mentioned in transaction” 
based on the Override flag (Current Behaviour). 

c. If the Parameter “Rate Benefit” is set to “N”, system will consider the “Contract 
Rate” for Flat Rate Accounts and “Account Rate” for Variable Rate Accounts. 

iii. API and I tables Impact:  

1. API tables and I-tables are modified to accommodate following applicant Active 
Military Duty Details. 

Field Name Description Type Mandatory Remarks 

Active 
Military Duty 

Capture if applicant is on 
Active Military Duty 

Check 
box 

No  

Effective Dt Effective Dt  Date Y Mandatory when Active 
Military duty is flagged as 
Yes 

Order Ref# Capture Order reference 
number 

String Y Mandatory when Active 
Military duty is flagged as 
Yes 

Release Dt Date when the applicant is 
released from Active Military 
duty 

Date N Not mandatory 



2-143 

 

 

2.17.3 Seed Data 

Sl No TABLE KEY DATA TYPE 

1 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_PRIM INSERT 

2 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_SPOUSE INSERT 

3 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_2NDRY INSERT 

4 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_COS INSERT 

5 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_SPOUSE_COS1 INSERT 

6 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_COS2 INSERT 

7 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_SPOUSE_COS2 INSERT 

8 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_BUS INSERT 

9 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_PRIM INSERT 

10 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_SPOUSE INSERT 

11 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_2NDRY INSERT 

12 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_COS INSERT 

13 FLEX_TABLE_ATTRIBUTES 
CNB_CRB|XVL_SCRA_MISMATCH_EFX_SPOUSE_C
OS1 INSERT 

14 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_COS2 INSERT 

15 FLEX_TABLE_ATTRIBUTES 
CNB_CRB|XVL_SCRA_MISMATCH_EFX_SPOUSE_C
OS2 INSERT 

16 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_EFX_BUS INSERT 

17 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_PRIM INSERT 

18 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_SPOUSE INSERT 

19 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_2NDRY INSERT 

20 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_COS INSERT 

21 FLEX_TABLE_ATTRIBUTES 
CNB_CRB|XVL_SCRA_MISMATCH_TUC_SPOUSE_C
OS1 INSERT 

22 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_COS2 INSERT 

23 FLEX_TABLE_ATTRIBUTES 
CNB_CRB|XVL_SCRA_MISMATCH_TUC_SPOUSE_C
OS2 INSERT 

24 FLEX_TABLE_ATTRIBUTES CNB_CRB|XVL_SCRA_MISMATCH_TUC_BUS INSERT 

25 FLEX_TABLE_ATTRIBUTES CNB_CON_LOAN|MAX_SCRA_CON_APR INSERT 

26 FLEX_TABLE_ATTRIBUTES CNB_CON_LEASE|MAX_SCRA_CON_RATE INSERT 

27 FLEX_TABLE_ATTRIBUTES CNB_CON_LOC|MAX_SCRA_CON_RATE INSERT 

28 FLEX_TABLE_ATTRIBUTES SET_SYP_SYSTEM|MAX_SCRA_RATE_ALLOWED INSERT 

29 TRANSLATION_DATA 
SYS|SYS|SYS|TXN|001781|RATEGREATERTHANMAX
IMUMSCRARATEALLOWED|SYS|MSG-SE INSERT 

30 SYSTEM_PARAMETERS 
MAX_SCRA_RATE_ALLOWED|SET_SYP_SYSTEM|AL
L|ALL|ALL|ALL|ALL|ALL|ALL INSERT 

31 EDIT_DETAILS CNLNCE_CON_EDIT_01|MAX_SCRA_CON_APR|36 INSERT 

32 EDIT_DETAILS CNLSCE_CON_EDIT_01|MAX_SCRA_CON_RATE|36 INSERT 

33 EDIT_DETAILS CNLNOE_CON_EDIT_01|MAX_SCRA_CON_RATE|36 INSERT 

34 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_PRI
M|NA INSERT 

35 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_PRI
M|NA INSERT 

36 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_PRI
M|NA INSERT 

37 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE|NA INSERT 

38 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SPO
USE|NA INSERT 
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39 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE|NA INSERT 

40 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S|NA INSERT 

41 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S|NA INSERT 

42 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S|NA INSERT 

43 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_2ND
RY|NA INSERT 

44 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_2ND
RY|NA INSERT 

45 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_2ND
RY|NA INSERT 

46 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S2|NA INSERT 

47 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S2|NA INSERT 

48 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_CO
S2|NA INSERT 

49 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE_COS1|NA INSERT 

50 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SPO
USE_COS1|NA INSERT 

51 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE_COS1|NA INSERT 

52 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE_COS2|NA INSERT 

53 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SPO
USE_COS2|NA INSERT 

54 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_SP
OUSE_COS2|NA INSERT 

55 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_BUS
|NA INSERT 

56 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_BUS
|NA INSERT 

57 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_BU
S|NA INSERT 

58 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_PRIM|NA INSERT 

59 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_PRIM|NA INSERT 

60 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_PRIM|NA INSERT 

61 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE|NA INSERT 

62 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE|NA INSERT 

63 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE|NA INSERT 

64 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS|NA INSERT 

65 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS|NA INSERT 

66 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS|NA INSERT 

67 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_2NDRY|NA INSERT 

68 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_2NDRY|NA INSERT 

69 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_2NDRY|NA INSERT 

70 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS2|NA INSERT 

71 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS2|NA INSERT 
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72 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_COS2|NA INSERT 

73 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS1|NA INSERT 

74 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS1|NA INSERT 

75 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS1|NA INSERT 

76 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS2|NA INSERT 

77 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS2|NA INSERT 

78 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_SPOUSE_COS2|NA INSERT 

79 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_BUS|NA INSERT 

80 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_BUS|NA INSERT 

81 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_EFX
_BUS|NA INSERT 

82 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_PRIM|NA INSERT 

83 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_PRIM|NA INSERT 

84 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_PRIM|NA INSERT 

85 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE|NA INSERT 

86 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE|NA INSERT 

87 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_SPOUSE|NA INSERT 

88 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_COS|NA INSERT 

89 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_COS|NA INSERT 

90 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_COS|NA INSERT 

91 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_2NDRY|NA INSERT 

92 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_2NDRY|NA INSERT 

93 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_2NDRY|NA INSERT 

94 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_COS2|NA INSERT 

95 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_COS2|NA INSERT 

96 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_COS2|NA INSERT 

97 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE_COS1|NA INSERT 

98 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE_COS1|NA INSERT 

99 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_SPOUSE_COS1|NA INSERT 

100 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE_COS2|NA INSERT 

101 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_SPOUSE_COS2|NA INSERT 

102 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_SPOUSE_COS2|NA INSERT 

103 EDIT_DETAILS 
CNLNCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_BUS|NA INSERT 

104 EDIT_DETAILS 
CNLSCE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TUC
_BUS|NA INSERT 
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105 EDIT_DETAILS 
CNLNOE_ADC_EDIT_01|XVL_SCRA_MISMATCH_TU
C_BUS|NA INSERT 
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2.18 SCRA Transaction Enhancements 

2.18.1 Overview 

 With this enhancement user will be allowed to address the regulatory requirement of keeping the 

Payment amount same or less than Contracted Payment amount when “Borrower on Active Military 

Duty” Transaction is posted on to the account.  

2.18.2 Description 

 A new lookup is added “CUST_ON_MLTRY_DUTY” with options as CONTRACT BALANCE AND 

TERM, OUTSTANDING BALANCE AND TERM. 

 Added a new parameter to the transaction “Borrower on Active Military Duty”, PAYMENT CALC 

METHOD. 

  When user selects “Payment Calc Method” as “Contract Balance & Term”, system will calculate 

the payment amount using contract ‘Amount Financed’ and ‘Term’ (New Behavior). 

 When user selects “Payment Calc Method” as “Outstanding Balance & Term”, system will calculate 

the payment amount using ‘Outstanding Principal Amount’ and ‘Term’ (Current Behavior). 

 

2.18.3 Seed Data 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.19 Queue User Group  

2.19.1 Overview 

Existing queue framework is enhanced to support following: 

1. Centralized repository for adding and removing users from queue. 

2. Replacing hard assigned users for individual accounts or multiple Accounts 

2.19.2 Description 

1. Added a “User Group” tab in OFSLL  Setup  Queues with following fields - Queue Name, 

Description, Responsibility and Enabled. 

2. Added a “User” tab in OFSLL  Setup  QueuesUser Groups with following fields – Name and 

Enabled. 

3. Group Assignment tab is used to add user groups to Origination and Customer Servicing Queue. 

Once user group is added to the queue; any subsequent addition/disable of user in ‘Group Assignment’ 

would implicitly updates to ‘Responsibilities and Users’ tab.  

4. Added ‘Un Assignment’ button to ‘Group Assignment tab’ 

5. On click of ‘Un-Assigned’ button, system un-assigns all the users of the group in the queue. 

6. User explicitly enables hard assigned flag for each user in the queue added through user group. 

7. The existing functionality of Adding/Modifying responsibility and users will remain the same. Any user 

added directly is disabled manually. For common users present at Queue and User Group, user should 

manually keep the data in sync. 

For example: Consider Data_Entry_Queue having users as X, Y and Z. A new user group Data_Entry is created with 

W and X. Once the Data_Entry use group is added to Data_Entry_Queue; total user assigned to the queue will be 

W,X,Y,Z. Enabling and disabling of user Y and Z should be done directly at the queue. For X, user should be enabled 

and disabled both at Data_Entry_Queue and Data_Entry use group. Data will not propagate to Data_Entry use group 

if X is disabled at Data_Entry_Queue.  

1. Following is the matrix for Enabling and disabling of user and user group from Queue and User group. 

Entity Queue User 

Groups 

Outcome 

User Yes No User should be disabled /enable only in that particular Queue. 

No Yes User should be disabled / enabled in all the Queues where the 

user group is attached. 

User 

Group  

Yes No User group should be disabled /enable only in that particular 

Queue. 

No Yes User group should be disabled / enabled in all the Queues 

where the user group is attached. 

 

8. An audit log is created every time account change from one queue/user/condition to other. The details 

are displayed in Customer Service/ Collection  Account Details  Condition Details. 

9. A new tab Queue Assignment is displayed in Customer Service to reassign hard assigned queues. 

a. New search criteria. 

SNO Field Name Description Field Type 

    
1 

Hard Assigned 

Queue 

Hard Assigned Queue 

Name 

Dropdown (Concatenate Queue 

name and Queue Description)  

3 Acc # Account Number Textbox 

4 Responsibility User Responsibility Dropdown 

5 User Name OFSLL User Name Dropdown 

 

b. Replacement User dropdown and Reason Text fields are rendered based on Select 

All check box in Queue Assignment table. 

 If Select All check box is selected Replacement User dropdown is 

disabled at record level. 
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c. Once successful replacement below system generated comments are posted on the 

account. 

 Alert (No) 

 Type (SYSTEM GENERATED) 

 Sub Type (SYSTEM GENERATED) 

 Comment (QUEUE USER CHANGED FROM XXX TO YYY 

BECAUSE OF <<REASON>> ON <<DATEFORMATE>> ) 

d. If user selects Search List By, Queue then below search results are displayed. 

e. “Replacement User” dropdown displays all the users assigned to the queue.  

f. To be updated individually user, select the individual record and update 

“Replacement User” dropdown with desired user and click on “Update Queue” 

button. 

g. To bulk update users; Select all records using “Select All” check box and update 

“Replacement User” dropdown with desired user and click on “Update Queue” 

button.  

h. If “Account Number” is used as search criteria then “Queue Assignment” child 

table displays filtered record with “Remove Filter” button on top of the table.  

i. “Remove Filter” button is used to clear account number and display all the records.  

 

Note: This functionality is similar to “Producers” hyperlink displayed in application table. 

j. If user selects Search List By, User then below search result will be displayed. 

k. “Replacement User” dropdown will display all the users assigned to all the queues.  

 If new user is not updated then a message will be displayed”<<XX>> 

records updated with <<new user>> out of <<YY>> records”.  

2.19.3 Screenshot 

Setup >User >Queue > User Group 
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Setup >User >Queue > Origination > Group Assignment  

 
 Setup >User >Queue > Customer Service > Group Assignment  

 
Customer Service > Queue Assignment  

 

  



2-151 

 

 

Customer Service > Account Details > Condition Details  

 

 

2.19.4 Seed Data 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.20 Account Access History 

2.20.1 Overview 

 OFSLL is enhanced to display user account access history in Customer Servicing and 

Collections.   

2.20.2 Description 

 A new screen is created in Servicing  Customer Service  History and Collections 

 Customer Service  History to display user account access history. 

 System posts the record, even is user doesn’t make any changes on account i.e., on 

Open/Close/View of account, system logs a record. 

 Multiple ways of accessing the account is tracked and logged:  

 Accessing the account by submitting account number (or other quick search 

items) 

 Accessing the account by using Queue/Condition dropdown 

 Accessing the account by Search Criteria 

 Accessing the account from Review Request tab 

 Accessing the account from Dialer (using Next Account button) 

 Accessing the account from FLEXCUBE UNIVERAL BANKING SYSTEM 

(UBS) environment (integrated environment) 

 Accessing the account by clicking in Origination > Existing Account 

Hyperlink. 
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2.21 Condition/Queue History 

2.21.1 Overview 

Existing ‘Condition History’ tab at Servicing renamed as ‘Condition Details’ 
 
This tab now shows two sections – Condition/Queue and Condition/Queue History 

 Servicing > Account > Condition shows: Current Open Conditions, Queues and Hard Assigned 
Users 

 Servicing > Condition History shows: Historical Open Conditions, Queues and Hard Assigned 
Users 

2.21.2 Description 

I. Changes in Customer Service >Account Details > Condition Details Tab 

1. Two independent blocks – Conditions/Queue, Condition/Queue History 

i.  ‘Condition/Queue ‘Block shows current Condition, Queue, User Data.   

 If the condition is being OPENED by any of the following mode: 

o On posting Call Activity that OPEN conditions on account. 

o Conditions posted by Batch events 

o Conditions posted by Transaction (Example – Borrower on Military duty) 

 When Queue is created on a ‘Condition’. 

 When user is being hard assigned to Queue. 

ii. Data shown under ‘Condition/Queue History’ Block: 

 When a condition is closed on account by any mode [Using Call Activity, 
Transaction or a batch job]. 

 When an account got out of a queue [Say, Account moved from 30 Day Delq 
Queue to 60 Day Delq Queue]. 

 When a user re-assigned to the queue for Hard Assigned queues. 

iii. Radio Buttons for ‘Condition/Queue History’ Block: 

 Shows ‘Queue, Condition, User and All’ radio buttons at Condition/Queue History 
block. 

 System shows only corresponding records on selection of radio button. 

 Default value is ‘Condition’. 

iv. Processing Logic 

i. System inserts record in condition history table in case of any change in Condition, 
Queue, User or Reason along with ‘Change Reason’ 

Example: If Condition is closed, system inserts 3 records in history table 

a. For Condition Closure 

b. For Queue Closure 

c. For User Change 

ii. System stamps ‘Condition Start Dt or Queue Start Dt, or User Start Dt in Condition/ Queue 
table; whenever a respective entity gets created. 

iii. When system inserts record in to history table; system stamps the ‘Start Dt’ = Date when 
historical entity got created. End Date = whenever historical ‘Condition or Queue or User 
gets closed. 
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2.21.3 Screenshot 

Condition/Queue History Screen 

User Change: 

 

Condition Change: 
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Queue Change: 

 

2.21.4 Seed Data 

SNO Table Key Data Type 

1 FLS_ACCESS FLL.SER.UCS.ACCOUNTCONDITIONMAIN.VIEW.BUTTON INSERT 
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2.22 Condition Reason 

2.22.1 Overview 

Delinquency Reasons captured for specific cases of delinquency. 

2.22.2 Description 

1. Following reason codes added to CAC_REASON_CD Lookup Type. 

i. 1st Payment Delinquency 

ii. NSF Delinquency 

iii. Matured Delinquency 

2. Whenever system updates the ‘DLQ’ condition, system updates respective reason code to 
Account Conditions table and it shows in Servicing > Header Block as shown in the fig. 

Scenario 1 - 1st Payment Delinquency 

1. When the first payment is delinquent for an account, system picks that account 
and update the Delinquency Reason as “1st Payment Delinquency”. 

2. After updating the Delinquency Reason as “1st Payment Delinquency”, if the 

payment is received for that account system removes the “1st Payment Default 
Delinquency” Delinquency Reason 

3. In case of payment reversal, system posts back the ‘1st Payment Default 

Delinquency’. 

Notes: Whenever payment is posted or reversed on account; system verifies if this is 

1st payment delinquency and inserts/removes the reason). 

Scenario 2 - NSF Delinquency 

1. When the Last Payment result in NSF for an account, system picks that 
account and update the Delinquency Reason as “NSF Delinquency” 

2. After updating the Delinquency Reason as “NSF Delinquency”, if the 

Last payment receives for that account system removes the “NSF 
Delinquency” Delinquency Reason. 

Notes: While making payment as NSF; system verifies ‘Last Due’ in Due Date 

History’ table and inserts the reason. 

Scenario 3 - Matured Delinquency 

1. When an Account reaches the ‘Maturity Date’ with some delinquency 
amount, system picks that account and update the Delinquency Reason 
as “Matured Delinquency” 

2. Once the Delinquency amount is completely paid off, system removes 
this Delinquency Reason 

3. In case of payment reversal, system posts back the ‘Matured 
Delinquency’. 

Notes: While reversing payment on account, system verifies if account reached 

‘Maturity Date’ and inserts the reason. 

Note: User is expected to enable ‘Audit’ field to record the history of this field. 

Closing Delinquency Reason Codes: 

 For 1st Payment Default Delinquency reason, the reason ends; once the Paid Terms moves from 0 
to >0, even if the account remains delinquent. 

 For NSF reason, any payment after the NSF that moves the due date ends the NSF reason. 
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2.22.3 Screenshot 

Condition Reason

 

2.22.4 Seed Data 

Sno 
Table Key Data Type 

1 LOOKUPS CAC_REASON_CD|1ST_PAYMENT_DLQ INSERT 

2 LOOKUPS CAC_REASON_CD|NSF_DLQ INSERT 

3 LOOKUPS CAC_REASON_CD|MATURED_DLQ INSERT 
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2.23 Export to Excel facility in Securitization Screen 

2.23.1 Overview 

‘Export to Excel’ facility provided in Servicing > Securitization > Pool Inquiry and Pool Transactions 
block. 

2.23.2 Description 

‘Export to Excel’ facility provided in Servicing > Securitization > Pool Inquiry and Pool Transactions 
block. 

2.23.3 Screenshot 

Customer Service > Securitization > Pool Inquiry

 

2.23.4 Seed Data 

SNO TABLE KEY DATA Type 

1 FLS ACCESS FLL.SER.UCS.ACCOUNTTRANSACTION.EXPORT.BUTTON INSERT 

2 FLS ACCESS FLL.SER.USC.SECURITIZATIONPOOLTRANSACTION.EXPORT.BUTTON INSERT 

3 FLS ACCESS FLL.SER.USC.SECURITIZATIONPOOL.EXPORT.BUTTON INSET 
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2.24 Customer Details Update flag 

2.24.1 Overview 

‘Customer Details Update’ flag is introduced in OFSLL at Origination Stage and Account On-
boarding Interface; indicating ‘Customer Data’ Override; while funding/on-boarding an account. 

2.24.2 Description 

‘Update Customer Info’ Flag 

New flag ‘Update Customer Info’ is introduced while funding/on-boarding an account. 

I. Account on-boarding Web service – Update Customer Info flag 
II. Changes at Origination > Application  Entry > Applicant > Update Customer Info 
III. Servicing > Customer Service > Customer Information > Update Customer Info field 

 

I. Account on-boarding Web service – Update Customer Info flag 

 Currently, when the account is linked to existing customer Id, no customer/address/telecom records 

are overwritten, but only new “cus_acc_relation” record is created. Also, system picks up the latest 

‘Customer Id’, considering application class. 

 A new flag ‘Update Customer Info’ flag is introduced in existing Account On-boarding web service 

at each applicant level. 

 System posts comments on accounts with old and new values of changes in Customer 

information [Not Address/Employment/Telecom blocks]; on accounts where ACC_OPEN_IND = ‘Y’ 

(not on closed accounts) and newly created account for all applicants/customers data changed.  

Message Format: Applicant/Customer Name: Field Name – Changed ‘From Value’, ‘To Value’. 

 Following new ‘ACCOUNT BOARDING EDITS’  interface introduced: 

Edit Description Type Comment 

System validates that ‘Update Customer Info’ flag =’Y’ 
only if ‘Existing Customer Id’ field is not NULL or Link to 
Existing Customer Flag =’Y’ 

Error  

Customer Sensitive Information changed with ‘Update 
Customer Info’ flag for Primary Applicant 

Error This EDIT is triggered, only if 
user selects ‘Update Customer 
Info’ Flag. 

Customer Sensitive Information changed with ‘Update 
Customer Info’ flag for Other Applicant 

Error This EDIT is triggered, only if 
user selects ‘Update Customer 
Info’ Flag. 

 While triggering above EDITS, system checks and compare value with applicant and customer 

data (Based on latest ‘Customer Id’ logic). 

II. Changes at Origination  Applicant Block 

 New ‘Update Customer Info’ flag is introduced at Origination > Applicant Block and if the 
flag value =’Y’ (appears for each applicant); system will override data in customer table. 

Origination > Applicant Block 

Attribute Description Input/ 
Selectable/ 
Display 
Only 

Object 
Type 

Mandatory 
Y/N 

Data 
Type/ 
Size 

Field 
Validation 

Default 
Values 

Comments 

Update 
Customer 
Info 

Select this 
flag to 
override 
existing 
customer 
information 

Input Check 
Box 

Y Bullion  N  

III. Changes at Servicing > Customer Details > Customer Information 
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 A new flag is introduced in Servicing as described below and system passes the flag information to servicing 
from Origination/ Account On-boarding. 

 System posts comments on accounts with old and new values of changes in customer information; on 

accounts where ACC_OPEN_IND = ‘Y’ (not on closed accounts) and newly created account for all 

applicants/customers data changed. 

 

Message Format: Applicant/Customer Name: Field Name – Changed ‘From Value’, ‘To Value’. 

 
Servicing > Customer Details > Customer Information 

Attribute Description 

Input/ 
Selectable/ 
Display 
Only 

Object 
Type 

Mandatory 
Y/N 

Data 
Type/ 
Size 

Field 
Validation 

Default 
Values 

Comments 

Update 
Customer 
Info 

View this flag 
indicating 
existing 
customer 
information 
override 

Display Check 
Box 

Y Bullion This flag 
gets 
updated 
from 
Origination 

NA  

IV. Handling Exceptions 

Account Void 

If user voids the account, where ‘Customer Information’ is overridden using ‘Update Customer 
Information’ flag, user is expected to manually update the customer data again by posting non-
monetary transactions. 

2.24.3 Screenshot 

 Origination > Applicant 

 
 
Servicing > Customer Details > Customer Information 

 
  



2-161 

 

 

2.24.4 Seed Data: 

SNO TABLE KEY DATA Type 

1 EDIT_DETAILS CNLNCE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_PRIM|NA INSERT 

2 EDIT_DETAILS CNLNOE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_PRIM|NA INSERT 

3 EDIT_DETAILS CNLSCE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_PRIM|NA INSERT 

4 EDIT_DETAILS CNLNCE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_OTHR|NA INSERT 

5 EDIT_DETAILS CNLNOE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_OTHR|NA INSERT 

6 EDIT_DETAILS CNLSCE_APP_EDIT_00|UPD_CUS_INFO_IND_SCRA_OTHR|NA INSERT 

7 EDIT_DETAILS CNLNCE_APP_EDIT_00|UPD_CUS_INFO_IND_PRIM|NA INSERT 

8 EDIT_DETAILS CNLNOE_APP_EDIT_00|UPD_CUS_INFO_IND_PRIM|NA INSERT 

9 EDIT_DETAILS CNLSCE_APP_EDIT_00|UPD_CUS_INFO_IND_PRIM|NA INSERT 

10 EDIT_DETAILS CNLNCE_APP_EDIT_00|UPD_CUS_INFO_IND_OTHR|NA INSERT 

11 EDIT_DETAILS CNLNOE_APP_EDIT_00|UPD_CUS_INFO_IND_OTHR|NA INSERT 

12 EDIT_DETAILS CNLSCE_APP_EDIT_00|UPD_CUS_INFO_IND_OTHR|NA INSERT 

13 EDIT_DETAILS CNLNCE_CON_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

14 EDIT_DETAILS CNLSCE_CON_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

15 EDIT_DETAILS CNLNOE_CON_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

16 EDIT_DETAILS CNLNCE_ACX_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

17 EDIT_DETAILS CNLNOE_ACX_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

18 EDIT_DETAILS CNLSCE_ACX_EDIT_01|UPD_EXISTING_CUST_IND|NA INSERT 

19 EDIT_DETAILS CNLNCE_ACX_EDIT_01|UPD_CUS_INFO_IND_PRIM|NA INSERT 

20 EDIT_DETAILS CNLNOE_ACX_EDIT_01|UPD_CUS_INFO_IND_PRIM|NA INSERT 

21 EDIT_DETAILS CNLSCE_ACX_EDIT_01|UPD_CUS_INFO_IND_PRIM|NA INSERT 

22 EDIT_DETAILS CNLNCE_ACX_EDIT_01|UPD_CUS_INFO_IND_OTHR|NA INSERT 

23 EDIT_DETAILS CNLNOE_ACX_EDIT_01|UPD_CUS_INFO_IND_OTHR|NA INSERT 

24 EDIT_DETAILS CNLSCE_ACX_EDIT_01|UPD_CUS_INFO_IND_OTHR|NA INSERT 

25 FLEX_TABLE_ATTRIBUTES CNB_APL|UPD_EXISTING_CUST_IND INSERT 

26 FLEX_TABLE_ATTRIBUTES CNB_APL|UPD_CUS_INFO_IND_PRIM INSERT 

27 FLEX_TABLE_ATTRIBUTES CNB_APL|UPD_CUS_INFO_IND_OTHR INSERT 

28 FLEX_TABLE_ATTRIBUTES CNB_CON_LOAN|UPD_EXISTING_CUST_IND INSERT 

29 FLEX_TABLE_ATTRIBUTES CNB_CON_LEASE|UPD_EXISTING_CUST_IND INSERT 

30 FLEX_TABLE_ATTRIBUTES CNB_CON_LOC|UPD_EXISTING_CUST_IND INSERT 

31 FLEX_TABLE_ATTRIBUTES CNB_APL|UPD_CUS_INFO_IND_SCRA_PRIM INSERT 

32 FLEX_TABLE_ATTRIBUTES CNB_APL|UPD_CUS_INFO_IND_SCRA_OTHR INSERT 
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2.25 Promise to Pay Tolerance 

2.25.1 Overview 

Current Functionality is Promise to Pay and Payment Tolerance use same parameter in contract to mark 
promise as broken or kept and payment as received/not received. 

Separate set of ‘Tolerance’ parameters provided for Promise to Pay. Regular installment will still refer 
existing ‘Tolerance’ parameters at Contract Tab. 

2.25.2 Description 

i. New Contract Parameters for ‘Promise Tolerance 

a. New parameters ‘Promise Tolerance and Promise Tolerance %’ introduced in 
Origination > Contract > VIEW Only. 

b. New parameters ‘Promise Tolerance and Promise Tolerance %’ introduced in 
Setup > Contract to input details. 

c. New parameters ‘Promise Tolerance and ‘Promise Tolerance %’ introduced in 
Servicing > Account Information > Contract > VIEW only. 

d. System refers ‘Promise Tolerance and Promise Tolerance% parameters while 
updating ‘Broken Indicator’ flag in Promises. 

e. When user copies the contract, system copies new parameter introduced. 

f. Change applicable for products – Loan, Line and Lease. 

ii. Validations: 

Promise Tolerance 
Amt 

This is the threshold amount that must be achieved before a 
due amount is considered KEPT or BROKEN. If (Payment 
Received + Promise Tolerance: $Value) >= Promise Amount, 
the Due Date will be considered KEPT. 

Promise Tolerance % This is the threshold percentage that must be achieved before 
a due amount is considered KEPT or BROKEN. If Payment 
Received >= (Promised Amt * Promise Tolerance%), the due 
date will be considered KEPT) 

 
Note: System uses the least value. 

iii. Migration/Conversion Impact 

Migration 

Data Fix script is provided for existing contract and accounts to populate from Payment 
tolerance fields to Promise Tolerance fields. 
 

  Conversion/Account Boarding 

 While doing conversion, system will derive data from contract based on ‘Instrument Name’  
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2.25.3 Screenshot 

Setup > Contract Screen 

 

Origination > Contract > Other Details 

 

Servicing > Contract > Other Details 

 

2.25.4 Seed Data 

SNO Table Key Data Type 

NA NA NA NA 
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2.26 GL Query by ‘Account’ 

2.26.1 Overview 

New GL Query screen is developed to search the GL transactions by ‘Account Number’; which fetches 

data for Producer Transactions, Monetary Transactions, Amortized Transactions, Funding Transactions, 
Payment Transactions, Securitization Transactions, and Loan Sale Transactions. 

User can view the GL Transactions in this screen by Account Number. 

This screen is placed as new tab under ‘Servicing > GL Transaction screen > Accounts (new tab)’. 

2.26.2 Description 

I. Working on GL Transaction Query Screen 

1. Search block have ‘Acc #’ field with Search button to search data on screen. 
2. On input of ‘Account Number’ and click of ‘Search’; system fetches following details: 

 Customer Name, Status, Product Contract Date and Currency. 

 Monetary Transactions and Securitization Transactions will display Effective Date, GL 

Post Date, Transaction Code, Transaction Description, Amt and Remarks. 

 Funding Transactions and Producer Transactions will display Effective Date, GL Post 

Dt, Transaction Code, Transaction Description, Amt, and Producer Name. 

 Amortized Transactions and Loan Sales Transactions will display Effective Date, GL 

Post Date, Transaction Code, Transaction Description, and Amt. 

 GL Entries block shows GL Post Date, GL Transaction Code, GL Transaction, 

Description Dr/Cr and Amounts 

3. System shows details for days selected in radio button- 1 Day, 2 Days, 5 Days and ALL Days. 
Default value on page load is ‘1 Day’. These radio buttons refer ‘Transaction Date’. 

2.26.3 Screenshot 

Servicing > Interface > GL Transactions> Account > Monetary Transactions
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Servicing > Interface > GL Transactions> Account > Amortized Transactions 

 

 

Servicing > Interface > GL Transactions> Account > Producer Transactions 

 

Servicing > Interface > GL Transactions> Account > Securitization Transactions 
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Servicing > Interface > GL Transactions> Account > Loan Sale Transactions 

 

Servicing > Interface > GL Transactions> Account > Payment Transactions 

 

Servicing > Interface > GL Transactions> Account > Funding Transactions 
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2.26.4 Seed Data 

SNO Table Key Data Type 

1 FLS_ACCESS FLL.INT.UGL.GLTRANSACTIONCOMPANY.TAB INSERT 

2 FLS_ACCESS FLL.INT.UGL.GLTRANSACTIONACCOUNT.TAB INSERT 

3 FLS_ACCESS FLL.INT.UGL.GLMONETARYTXNQUERY.TAB INSERT 

4 FLS_ACCESS FLL.INT.UGL.GLAMORTIZEDTXNQUERY.TAB INSERT 

5 FLS_ACCESS FLL.INT.UGL.GLPRODUCERTXNQUERY.TAB INSERT 

6 FLS_ACCESS FLL.INT.UGL.GLSECURITIZATIONTXNQUERY.TAB INSERT 

7 FLS_ACCESS FLL.INT.UGL.GLLOANSALETXNQUERY.TAB INSERT 

8 FLS_ACCESS FLL.INT.UGL.GLFUNDINGTXNQUERY.TAB INSERT 

9 FLS_ACCESS FLL.INT.UGL.GLPAYMENTTXNQUERY.TAB INSERT 
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2.27 Account Timeline: 

2.27.1 Overview 

Servicing is enhanced to display “Transactions, Payments and Call Activities Timeline” for an Account. This 

will give user a visual representation of transactions and call activities posted on particular date. 

2.27.2 Description 

1. Add Timeline for an Account to display the Transactions, Payments and Call Activities 
posted on an Account in a particular day. 

i. An ADF “Timeline” component is added to show the activities happened on an 
Account. 

ii. Start date of the time line is Account Creation Date and end date is Current Date +1. 

iii.  “Timeline” tab is added after the Customer Service >Bureau tab. 

iv. The Additions/Changes in following screens and sub screens will be showed on 
“Timeline”. 

Customer Service: 

a. Transaction History and Call Activities: 

1. Transactions: Display only Good Txns 

Display Description: “Txn Description” 

                          Date: Txn Dt 

2. In case of Call Activities, display Action/Result description and date 
in time line. 

3. Add the following radio buttons to filter the transactions/Call 
Activities 

i. Monetary 

1. Displays all good monetary transactions 

ii. Non-Monetary 

1. Displays all non monetary transactions 

iii. Payments 

1. Displays all Good Payments 

iv. Call Activities 

1. Displays all Call activities 

v. All Radio Button 

1. Display Monetary, Non Monetary, Payments and 
Call Activities.  
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2.27.3 Screenshot 

 

2.27.4 Seed Data 

SNO TABLE KEY DATA Type 

1 FLS_ACCESS FLL.SER.UCS.ACCOUNTTIMELINE.TAB INSERT 

  



2-170 

 

 

2.28 Statement Preference Mode 

2.28.1 Overview 

User can choose ‘Statement Preference Mode’ at the time of origination and is allowed to change the 

preference in servicing stage. 

2.28.2 Description 

 A field ‘Stmt Preference Mode’ with LOV (Email/ Physical) is added at ‘Setup > Contract Screen’. 

 Statement Preference maintained at setup is populated based on ‘Instrument’ selected in 
‘Origination > Contract’.  

 ‘Stmt Preference Mode’ field added in following screens of the system. 

 Setup > Contract Screen 

 Origination  > Contract Screen 

 Customer Service > Account Details > Account Details 

 Customer Service > Account Details > Contract Information 

 New non-monetary transaction ‘ACC_STMT_PREFERENCE_MODE’ added to update statement 
preference in servicing stage. 

 Column Definition added in Data Files ‘Customer Statement’ 

 For existing customers, in migration; this value can be sent as NULL. 

 

2.28.3 Screenshot 

‘Stmt Preference Mode’ field added in Setup > Contract screen 
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Stmt Preference Mode’ field added in Origination > Contract screen 

 

‘Stmt Preference Mode’ field added in Customer Service > Account Details > Account 

Details 

 

‘Stmt Preference Mode’ field added in Customer Service > Account Details > Contract 

Information 

 

2.28.4 Seed Data 

SNO TABLE KEY DATA Type 

1 LOOKUP_TYPES STMT_PREFERENCE_MODE_CD INSERT 

2 LOOKUPS STMT_PREFERENCE_MODE_CD|EMAIL INSERT 

3 LOOKUPS STMT_PREFERENCE_MODE_CD|PHYSICAL INSERT 
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2.29 Defaulting Spread Based on Selection Criteria 

2.29.1 Overview 

 Currently in OFSLL, ‘Spread’ is defaulting from ‘Setup > Contract. 

 ‘Spread Matrix’ screen is developed in ‘Setup > Spreads > Loan’ for loan spreads, ‘Setup > 
Spreads > Line’ for line spreads and ‘Setup > Spreads > Lease’ for lease spreads. 

 While applying payment to account; system checks of applicability of spread in the combination of 
Account Status, Condition, State and Amount financed and priority. 

2.29.2 Description 

 Setup provided in OFSLL to define spread matrix based on - Account Status, Condition, Primary 
Customer State and Amount financed; which defaults or applies spread based on above criteria. 

 User is allowed to add multiple records in the combination of Account Status, Condition, State and 
Amount financed; specifying the priority.  

 If user maintains setup with same combination - ‘Account Status’, ‘Condition’ and state = ALL and 
another record with similar parameters except with specific state name (like NEWYORK; instead of 
ALL); system considers ‘spread’ with specific name state on priority. 

 If multiple conditions are posted on the account, system defaults the least numbered ‘Priority’ (say 
1) to default the spread in payment entry screen; which user still be able to change it on necessity 
basis.  

 If ‘spread matrix’ is not at all maintained or no spread match available or none of spread definitions 
are active in matrix; system refers to the ‘Default Spread’ defined at the contract level. 

Applicability: 

 For defaulting the ‘Spread’ in ‘Payment Entry’ screen. 

 Any payment received through various modes like ACH, Lock Box upload process. 

2.29.3 Screenshot 

 

2.29.4 Seed Data 

SNO TABLE KEY DATA Type 

1 NA NA NA 

  



2-173 

 

 

2.30 ‘Customer Deceased’ Transaction Enhancements 

2.30.1 Overview 

While posting a ‘Customer Deceased’ Transaction, option to allow "Permission to Call" Yes / No. 

2.30.2 Description 

I. Changes in ‘Mark Customer as deceased’ transaction  

a) New transaction parameters are added for ‘Mark Customer as Deceased’ 

Transaction 

i. Transaction Date 

ii. Remove permission to call, by default it is set as NO 

 

 ‘Mark Customer as deceased’ transactions have following parameters. 

 

Parameter Name 
Field Type 

 

Description Required 

TRANSACTION DATE Date Input Date Yes 

DECEASED DATE Date Input Date Yes 

Relation Type code Dropdown Select relationship type  Yes 

REMOVE PERMISSION 

TO CALL Dropdown 

If selected ‘Y’, system removes 

‘Permission to Call’ flag for all 

phone numbers related to 

customers for all accounts 

 

If Selected ‘N’; no impact to 

‘Permission to call’ information. Yes 

 

b) Impact  

 If user posts this transaction with ‘Remove Permission to Call’ indicator as ‘Yes’; 

system updates the “Permission to Call” flag as ‘N’ on all accounts where the 

customer is attached. 

 If user posts this transaction with ‘Remove Permission to Call’ indicator as ‘No’; 

system does not impact any ‘Permission to Call’ information captured for the 

account/customer. 

 A comment is posted on all accounts, where the flag is being updated. 

 

Comment Format: “<<RELATION TYPE>> CUSTOMER (<<CUSTOMER NAME>>) MARKED AS DECEASED, 

UPDATED PERMISSION TO CALL FLAG AS 'N' FOR ALL CONTACTS”. 

 

Note:  

If user updates ‘Customer Deceased Date’ in servicing> Customer Details using EDIT button (instead of posting 

transaction); system will not impact any ‘Permission to Call’ information captured for the customer   
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2.31 Conditional Transaction Authorization 

2.31.1 Overview 

Existing Monetary transaction framework supports maker and checker but does not support conditional Authorization. 

Enhanced Conditional Authorization framework for monetary transaction:    

o Selection criteria to Checker framework 

2.31.2 Description 

 Existing  Setup  Transaction Codes Access Grid Access Type support only: 

a. Account Condition 

b. Account Status 

 
 Existing OFSLL  Setup Access  Transaction is enhanced with the below. 

 Existing Access Grid tab is renamed to “Maker Responsibility”. This tab only allows Access 

Types as “Responsibility”.  This tab is used to indicate list of user responsibilities 

allowed/disallowed to post a specific transaction. 

 

 A new tab “Checker Responsibility” is added to allow Access Types as “Checker 

Responsibility”. This tab is used to indicate list of user responsibilities allowed/disallowed to 

authorize a specific transaction. 
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 A new tab Authorization Criteria is created to provide the conditional authorization. Based on 

the criteria provided, if the checker authorization is enabled, on click on post of the transaction 

minimum authorization responsibility level will be stamped for the transaction. 

 

 As per the existing logic user adds multiple checker responsibility; for each checker 

responsibility added, user can define the multiple selection criteria. 

 This Selection Criteria contains attributes from transaction parameters and user defined table 

(TRANSACTION CODE ACCESS PARAMETERS).  

 Base on the Authorization Level configured, system will assign to corresponding checker 

responsibility. The checker responsibility levels are determined from sub code of “CHECKER 

RESPONSIBILITY CODES (SUB CODE USED FOR LEVEL)” lookup. 

 Customer Service  Transaction Authorization screen is enhanced to display existing 

authorization data as  

a. Maker:  

 Transaction posted by logged in user. 

 Include with transaction status “Waiting For Approval”, “Rejected”, “Error” 

and “Posted”. 

 Order data by Transaction posting date Descending. 

b. Checker: 

 Display all records with logged in user and below authorization level  

 Status is only Waiting For Approval  

c. Both: 

 Union of above records. 

 All the records where users is checker for Rejected, Error and Posted 
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2.32 Comment Enhancements 

2.32.1 Overview 

1. Ability to delete a comment. 

2. Offline Call activity is enhanced to receive Alert flag. 

2.32.2 Description 

1. ‘Delete’ for comments 

 A provision is provided to delete a comment in ‘Comment’ Tabs. 

 This provision is given in ALL modules of OFSLL - Origination/ Servicing/ Collection. 

 Only ‘Regular’ type of comments is allowed for deletion. 

 User has to select the row to be deleted and click on ‘Delete’ button. 

 If user selects a row and click on ‘Delete Button’, system shows warning message ‘Do you want to 

delete message’ with Yes/No Options. Choosing ‘YES’ system will delete that selected comment 

and choosing NO will close warning popup. 

 The ‘Delete’ button is disabled for the ‘System generated type’ comment. 

 Button is access controlled. (Ex: Collector will not be able view the button, Collector Manager will 

only be able to view the button and perform action.) 

  

2. Alert flag in the Offline Call activity file format 

 

 Existing offline call activity file format is enhanced to include ‘Alert’ flag.  

 With this enhancement user can provide ‘Alert’ flag either Y/N indicator.  

 

2.32.3 Screenshot 

Customer Service > Comments 
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2.33 ‘Due Date Change’ override transactions 

2.33.1 Overview 

A new due date override transaction is introduced. 

2.33.2 Description 

I. New Monetary transactions – DUE DATE CHANGE OVERRIDE & REVERSE DUE 

DATA CHANGE OVERRIDE  

 Two new monetary transactions are provided in OFSLL ‘Due Date Change Override’ and ‘Due date 

Change Override Reverse’. 

A. Due Date Change Override 

 This transaction is part of ‘Account Monetary Transaction’ super group. 

 On posting of this transaction, system posts Due day change on account; ignoring following 

contract parameters 

 Max Due Day Change/Yr 

 Max Due Day Change/Life  

 Max Due Day Change Days 

 Due Day Min 

 Due Day Max 

(Note: System increases the numbers on counters- Max Due Day Change/Yr & Max Due Day Change/Life)  

 System shows this transaction under Customer Service > Transaction History > Transactions. 

 

B. Reverse Due Date Change Override 

 

 This transaction is part of ‘Account Monetary Transaction’ super group and enabled for 

REVERSAL. 

 On click of REVERSE button in Transaction History > Transactions, system reverses the 

transaction and decrease the numbers on these counters - ‘Max Due Day Change/Yr’ and ‘Max 

Due Day Change/Life. 
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2.34 Fee Selection Criteria Enhancement 

2.34.1 Overview 

     A fee selection criterion is enhanced to include original Amount financed in Selection criteria. 

2.34.2 Description 

 Below selection criteria parameter is added in Setup  Products  Fees and Setup  Product  

Contact  Fees 

– Loan  Amount Financed From 

– Line  Credit Limit From 

– Lease  Gross Capitalized Cost From 

 Above fields are also provide in following screens. 

– Origination > Contract > Fees Tab 

– Servicing > Account Details > Contract Information > Fees tab 

 As part of Fee assessment (when system runs the Fee batch job), system validates and levies fee 

considering newly added parameter respectively (Loan/Line/Lease). 

2.34.3 Screenshot 

Setup > Fee Definition Screen > Loan  

Setup > Fee Definition Screen > Line  
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Setup > Fee Definition Screen > Lease  

 

Setup > Contract > Loan 

 

Setup > Contract > Line 
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Setup > Contract > Lease 

 

Origination > Contract Tab >Loan 

 

Origination > Contract Tab >Line 
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Origination > Contract Tab >Lease 
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2.35 Field Investigation  

2.35.1 Overview 

Servicing and Collection module is enhanced with Field Investigation feature. 

2.35.2 Description 

 A new tab ‘Field Investigation’ is introduced in Customer Service/ Collections after the ‘Tracking 

Attributes’. 

 Information captured in ‘Field Investigation’ during origination will not be carried to 

Servicing/Collections. 

 This screen can be used for ‘Field Investigation’ in Customer Servicing/Collections. 

2.35.3 Screenshot 
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2.36 Servicing Summary Screen Enhancements 

2.36.1 Overview 

• ‘Account Information’ related fields are added to customer summary screen 

•  ‘Remaining Term’, ‘Kept Promises’ Counter and ‘Outbound’ Call Counters are placed in summary 

screen 

• Captured ‘Best Day to Call’ in telecom screen (Origination/ Servicing) and shown on summary screen 

• ‘Securitization Details’ in Account Summary page are shown in separate tab. 

• ‘Export’ feature provided to transaction screen 

2.36.2 Description 
I. Following changes are taken at Customer Service > Summary screen (Loan/ 

Lease/ Line) 

a) Account Details Block > Account Information > Loan (This is new section with in 

‘Account Details -Current’) 

Field Name Reference 

Contract Date Derived from Contract Information 

Amt Financed Balances Tab > Balance Group - ADVANCE / PRINCIPAL > 

Balance 

Term Customer Service > Account Details > Account Details 

Interest Rate Customer Service > Account Details > Account Details 

Maturity Date Customer Service > Account Details > Account Details 

Note: In case of ‘Islamic Loans’ Interest Rate will be shown as ‘Profit Rate’ 

 

b) Account Details Block> Contract Information > Loan (This is new section with 

‘Contract Information) 

Field Name Reference 

Contract Date Derive from Contract Information 

Amt Financed Derive from Contract Information 

Term Derive from Contract Information 

Interest Rate Derive from Contract Information 

Maturity Date Derive from Contract Information 

Note: In case of ‘Islamic Loans’ Interest Rate will be shown as ‘Profit Rate’. 

 

c) Account Details Block> Contract Information > Lease (This is new section with in 

‘Contract Details’) 

Field Name Reference 

Contract Date Derive from Contract Information 

Adj Gross 

Capitalized Cost 

Balances Tab > Balance Group - ADVANCE / PRINCIPAL > 

Balance 

Term Customer Service > Account Details > Account Details 

Base Monthly 

Payment 

Customer Service > Account Details > Account Details 

Maturity Date Customer Service > Account Details > Account Details 

 

d) Account Details Block> Contract Information > Line (This is new section with in 

‘Contract Details’) 

Field Name Reference 

Contract Date Derive from Contract Information 
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Credit Limit Balances Tab > Balance Group - ADVANCE / PRINCIPAL > 

Balance 

Term Customer Service > Account Details > Account Details 

Interest Rate Customer Service > Account Details > Account Details 

Maturity Date Customer Service > Account Details > Account Details 

    

e) Other Information > Work Order Details (applicable for Loan/Line/Lease)  

Field Name Reference 

Work Order # Derive from Transaction History > Work Orders 

Case # Derive from Transaction History > Work Orders 

Work Order Type Derive from Transaction History > Work Orders 

 Vendor Derive from Transaction History > Work Orders 

Status Derive from Transaction History > Work Orders 

  

Changes applicable for Loan, Lease and Line 

a) Account Details > Dues section’ added following fields:  

 Paid Term (Count of ‘Paid Dues’) 

 Remaining Term (Count of remaining outstanding dues to bill) 

b) Renamed BP (Life), BP (Year):  

 Renamed BP (Life) as Broken Promises (Life) 

 Renamed BP (Year) as Broken Promises (Year) 

c) Introduced new counters for ‘Kept Promises’  

 Introduced ‘Kept Promises (Life) and Kept Promises (Year) 

 These counters show information of Kept promises for total life of loan, Line and 

Lease for that specific year. 

 

Generation Logic:  

Kept Promises = As of Current business date: (Total Promises – Broken Promises) – Cancelled 

Promises for Year and Life. 

Example:  

Current Business Date: 31st May 2016 

Customer given 12 promises to pay 100$ payment on 1st of every month on 25th Dec 2015 

12 Promises recorded in OFSLL as 1st Jan 2016, 1st Feb 2016.upto 1st Dec 2016. 

 

Date Activity Kept 

Promises 

Counter 

Cancelled 

Promises 

Broken 

Promises (Year/ 

Life) 

Jan 1st 2016 Payment 

Received 

1 0 0 

Feb 1st 2016 Payment 

Received 

2 (1+1) 0 0 

Feb 15th 2016 Cancel request 2 1 0 
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for Mar 1st 

Apr 1st 2016 Payment not 

received 

2 1 1 

Ma 1st 2016 Payment 

received 

3 1 1 

 

d) Telecom Information Block 

 Shows ‘Best Day to Call’ information from Telecom block. 

e) Outbound Call History (New block has added below ‘Telecom’ block) 

 System shows Today, Last 7 Days, Last 30 Days (Rolling dates) outbound call 

statistics with following reference: 

 Setup > Queues > Call Action Results > Call Actions > "Outgoing Call"  

 (Shows details at ‘Customer Level’) 

 

II. Captured ‘Best day to call’ field in Origination and Servicing (Loan/Lease/ Line) 

Introduced new field in telecom block at both Origination/ Servicing to capture ‘Best Day to Call’ 

Field Name Data Type Mandatory Default 

Best Day to call Text (LOV) N NULL 

This field refers New Lookup (Telecom Weekdays) to show values. 

  Impact of this change: 

 This new field is available in existing web services to propagate. 

 Seed data ‘Best Day to Call’ is added to existing non-monetary transactions - CUS_NEW_TEL, 

CUS_TEL_MAINT (as shown in below table). 

Field Name Mandatory Default Value 

Best Day to Call N NULL 

 This field is introduced in conversion tables (i-tables). 

III. ‘Securitization Details’ in separate tab (Loan only) 

Provided ‘Securitization Details’ in new tab under Servicing > Account Details > ‘Securitization 

Details’ tab 

IV. Export feature to transaction screen (Loan/ Lease/ Line) 

 At Customer Service > Transaction History, provided ‘Export to Excel’ button. 

 Based upon user selection of radio buttons – All Txns, Good Txns etc., system 

exports transactions to spread sheet for selected radio button output. 

 Button is Access Controlled. 

V. Payment Maintenance Screen – Default ‘Multi’ checkbox selected 

In Payment maintenance Screen, on navigation; system defaults the ‘Multi Account’ check box as 

‘Checked’. (Currently default value – Unchecked).  

VI. Highlight ‘Review Request’ tab, whenever requestor gets any response 

Whenever user gets any response for the ‘Review request’ (Response triggered using ‘Send 

Response’ button); system shows the text in servicing > Search Screen (Home Page) with text that 

user received response for review request. 
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Message disappears when user closes the request using ‘Close Request’ button. 

This change available at– Origination, Servicing and Transaction Authorization 

 

VII. ‘Profit Rate’ label shown based on Islamic Product selection  

                             System dynamically changes the label based on Islamic product selection at following screens.  

Module Name Screen/Field 

Origination > Decision Screen Approved Section >  In place of ‘Rate’; shows ‘Profit 

Rate’ 

Origination > Contract Screen Contract Section > Just below IRR; shows label as 

‘Profit Rate’ 

Origination > Contract > Loan Calculator > On 

selection of ‘Islamic Product’ 

Payment/Finance Charge Section 

Servicing > Statement Details Section > View Last Profit Rate Changed Date, 

Current Profit Rate 

Servicing > Account Information Contract Tab > Profit Rate 

Account Details Tab > Profit Rate 

Servicing> Summary Screen Interest Rate 
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2.36.3 Screenshot 

‘Customer Service > Summary’ Screen Shot 

 

‘Origination > Telecoms’ Screen Shot 
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‘Customer Service > Account Details > Securitization’ Screen Shot 

 

‘Export to Excel’ button in Transactions Screen  
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2.37 Masking Financial Data for Secured Accounts 

2.37.1 Overview 

 Restrict access of the secured accounts for unauthorized users and masking Account financial details in 

search result. 

2.37.2 Description 

Changes in Servicing 

 In case of secure accounts, system can’t display financial details for unauthorized users in search 

result. Following fields are masked: 

d. Status 

e. Delinquency Days 

f. Amount Due 

g. Outstanding Balance 

2.37.3 Screenshot 
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2.38 Append ‘Delinquency Days’ to account comment 

2.38.1 Overview 

 Delinquency Days in Account Comment is posted when a call activity is posted. 

2.38.2 Description 

 Comment is appended with the text based on current logic 

 Call Activity Type Description () 

 Contact Type (Contacted ) 

 Promise Amount (Promises ) 

 Posted By ( To Be Posted By ) and 

 Reason Code (Rsn) 

 Next Follow Up Date(Next Followup Date) 

 Comments 

 

 To this comment delinquency days is also appended if the account is delinquent. 

 Delinquency Days (DELQ – No of Days) 

Example: Call activity is posted on an account with 

 Action – Customer Called 

 Result – Promise to pay 

 Contacted – Son 

 Promise - $400 

 Reason – Notice 

 To Be Posted By - 03/04/2016 

 Next Follow Up Date - 02/29/2016 

 Comment - payment promised 

 Delinquency Days – 180 

 

Current System Generated Comment:  

CUSTOMER CALLED- PROMISE TO PAY, CONTACTED: SON, PROMISES: $400.00 TO BE POSTED BY: 

03/04/2016, Rsn: Notice, NEXT FOLLOWUP DATE:02/29/2016, COMMENT: PAYMENT PROMISED. 

 

After this change comment posted as 

CUSTOMER CALLED- PROMISE TO PAY, CONTACTED: SON, PROMISES: $400.00 TO BE POSTED BY: 

03/04/2016, Rsn: Notice, NEXT FOLLOWUP DATE:02/29/2016, COMMENT: PAYMENT PROMISED, DELQ:180 
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2.39 Account Time Barred 

2.39.1 Overview 

• If you have old debts, collectors have a limited number of years — known as the statute of limitations — 

to sue you to collect. After that, your unpaid debts are considered "time-barred." 

• Functionality to handle time barred debts considers period of limitation at state level and product type. 

2.39.2 Description 

I. Setup related changes to support ‘Time Barred Debt’ feature 

Setup > Contract attribute > Time-Bar Years parameter is added to indicate ‘Time Bar Years’ and also added at 

Origination > Contract (2), Servicing Summary Screen and Account Information.

 

II. Changes in Origination 

Added ‘Time Bar Years’ field at Origination > Contract (2); referring details captured at setup > contract. 

 

III. Changes in Servicing  

1. Added new field ‘Time Bar Years’ in servicing at Servicing > Account Details > Contract 

Information > Contract Details tab 
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2. New fields in Servicing > Account Details 

Created New fields in Servicing> Account Details > Account Details (In table and View) > Time Bar Details  

Field Name Data Type Default Value Mandatory 

Start Date Date (View Only) Last Payment Date Y 

End Date Date (View Only) Start Date + Time Bar Years Y 

Days to time bar Numeric (View Only) NULL Y 

 
 

3. ‘Days to Time-Bar’ in Servicing > Summary Screen 

Introduced new field ‘Days to time-bar’ in Servicing > Summary > Dues block 
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4. Validations to display ‘Time Bar Counter’ 

Field Name Validations/Action 

Start Date Accounts to be considered as time barred debts are: 

 ACTIVE or CHGOFF accounts 

 Total Due > 0  

 Start Date should always be last payment date 

 Account Open Indicator = ‘Y’   

 Display ‘Last Payment Date’ on account as ‘Start Date’ 

End Date Based on value maintained at Setup > Contract > Time Bar Years 

Time Bar Start Date + Contract time-bar Years 

Days to Time 

Bar 

End Date – GL Date 

 

5. New Queue Parameter Introduced 

‘Time-Bar Start Date, Time Bar End Date and Days to Time Bar’ are added as parameters to servicing queue. 

Note: Queue can be defined where “Time Bar End Date” > System Date; so that accounts that are not time barred 

will only come shortlisted to collection queues. 
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2.40 Opt-Out feature Enhancements 

2.40.1 Overview 

 Ability to Capture three new opt-outs - Insurance Opt-Out, Share Credit Opt-Out and Marketing Opt-Out 

in Origination stage  

 Ability to change the Opt-Out preferences in servicing stage by using Add/Edit or posting transactions. 

2.40.2 Description 

 Three new checkbox are added at ‘Origination > Applicant’ - Insurance Opt-Out, Share Credit Opt-Out 

and Marketing Opt-Out in to capture opt-out preferences of applicant. 

 

 Three new checkbox are added at ‘Customer Service > Customer Details > Customer Information’ 

screen. 

• Information captured at origination will be carried to servicing stage; if system creates ‘New Customer 

Id’. 

• These indicators can be updated in servicing using ‘Customer Service > Edit’ button or through posting 

‘Non-Monetary’ transaction 

• Whenever user updates these details using EDIT button, system posts transaction 

(CUS_PRIVACY_INFO) automatically with transaction remarks as ‘Direct Update’ - Transaction posted 

successfully. 

 

Transaction Update: 

Existing ‘CUS_PRIVACY_INFO’ transaction is enhanced: 

a) Changed the ‘Description’ of transaction as ‘Customer Opt-Out Preferences’ 

 Included three new parameters in the transaction -Insurance Opt-Out, Share Credit Opt-Out 

and Marketing Opt-Out. 
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2.41 References Enhancements 

2.41.1 Overview 

 Facility to capture References Status and ‘Permission to call’ indicator for ‘References’ phone numbers. 

 In origination User will be allowed to capture permission to call for each Phone number captured. 

 New non-monetary transactions to add/update ‘References’ information. 

2.41.2 Description 
 “Status” field and ‘Permission to Call’ fields (for each phone details) are introduced at Origination 

Funding  Contract tab  References sub tab. 

 “Status” field and ‘Permission to Call’ fields are introduced at Servicing Screen > Customer Service > 

Account Details tab>Contract Information sub tab> References sub tab. 

 User can add/update the reference details in customer service > References Tab 

 Alternatively, user can use non-monetary transactions - REF_STATUS_NEW and 

REF_STATUS_MAINT to add/modify ‘Reference’ details respectively. 

 

Add New reference using Transaction: REF_STATUS_NEW: REFERENCE DETAILS ADD 

Parameter Data Type/  Tool Mandatory Default 

Value 

Txn Date Transaction Date Y NULL 

Relationship Dropdown Y NULL 

Name Text box Y NULL 

Status Dropdown Y Active 

Years Textbox (Numeric) Y 0 

Months Textbox (Numeric) Y 0 

Country Dropdown Y NULL 

Address1 Text Box N NULL 

Address1 Text Box N NULL 

Zip Text Box N NULL 

City Textbox N NULL 

State Dropdown N NULL 

Phone Textbox (Numeric) N NULL 

Extn Textbox (Numeric) N NULL 

Permission to Call Dropdown N N 

Phone Textbox (Numeric) N NULL 

Extn Textbox (Numeric) N NULL 

Permission to Call Dropdown N N 

Comment Textbox N NULL 

 

Maintaining Existing reference using Transaction: REF_STATUS_MAINT: REFERENCE DETAILS 

MODIFY 
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Parameter Data Type/  Tool Mandatory Default 

Value 

Txn Date Transaction Date Y NULL 

Reference No. Textbox Y NULL 

Relationship Dropdown  N NULL 

Name Text box N NULL 

Status Dropdown Y Active 

Country Dropdown N NULL 

Years Textbox (Numeric) N 0 

Months Textbox (Numeric) N 0 

Address Text Box N NULL 

Zip Dropdown N NULL 

City Textbox N NULL 

State Dropdown N NULL 

Phone Textbox (Numeric) N NULL 

Extn Textbox (Numeric) N NULL 

Permission to Call Checkbox N N 

Phone Textbox (Numeric) N NULL 

Extn Textbox (Numeric) N NULL 

Permission to Call Checkbox N N 

Comment Textbox N NULL 
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2.42 Payment Posting Enhancements 

2.42.1 Overview 

Currently any payment received on account, where account is closed – Paid Off/ Charged-off or any 
backdated payment is received before posting account status to ‘Paid Off/Charged-Off (not closed), system 
throws the error message and no payment registered against any account in OFSLL. 

Enhancement handles the payment posting (Through Payment Entry Screen /Payment Upload’ file); so that 
any payment received after Account Closed - Paid off, Charge Off; system posts these payments to 
Suspense account; instead of showing ‘Error’.  

2.42.2 Description 

1. Closed accounts: 

Created a system parameter “TPE_PMT_POSTING_CLS_ACCOUNT“. If the value of system 
parameter is ‘Y’, then system posts the payment to SUSPENSE instead of raising error; otherwise 
system raises ERROR. 
 

2. For all Other cases where we set the backdated date 

Currently, OFSLL sets the backdated date in the below scenarios: 
1. Paid off  
2. Charged-off,  
3. Account activation  
4. Account Conversion 
5. Account NON PERFORM (NON_PERFORM) 
6. PC2 SI reschedule 

For all the above cases OFSLL refers the new system parameter “TPE_BACKDT_PMT_POSTING“. If 
the parameter value is ‘Y’, then system posts the payment to SUSPENSE instead of raising error. 

2.42.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 SYSTEM_PARAMETERS 
TPE_BACKDT_PMT_POSTING|SET_SYP_SYSTEM|ALL|AL
L|ALL|ALL|ALL|ALL|ALL|N|Y INSERT 

2 SYSTEM_PARAMETERS 
TPE_PMT_POSTING_CLS_ACCOUNT|SET_SYP_SYSTEM
|ALL|ALL|ALL|ALL|ALL|ALL|ALL|N|Y INSERT 

3 
FLEX_TABLE_ATTRIBUT
ES SET_SYP_SYSTEM|TPE_BACKDT_PMT_POSTING INSERT 

4 
FLEX_TABLE_ATTRIBUT
ES SET_SYP_SYSTEM|TPE_PMT_POSTING_CLS_ACCOUNT INSERT 
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2.43 ‘Payment Maintenance’ Screen Enhancement 

2.43.1 Overview 

Payment posting is able to support single payments to multi and vice versa payment maintenance after 

posting. 

2.43.2 Description 

I. System allows one-one, one-many, many-one, many-many combination of payment 

maintenance 

1. UI Changes in ‘Payment Maintenance’ Screen 

a. Renamed the “Edit” button as “Modify Payments” at “Payments” table in Servicing 

>Payments >Payment Maintenance. 

b. Renamed  the “Edit” button as “Modify Payment Transactions” at “Payment Txns” 

table in Servicing >Payments >Payment Maintenance. 

c. On click of “Modify Payment Transactions” button, system will open a non 

persisted “New Payment Txns” block below “Payment Txns” block. 

i. All “Add and Edit” actions are performed in “New Payment Txns” non 

persisted block. 

ii. All the modifications done in “New Payment Txns” block will be saved in 

“Payment Txns” block. 

d.  If the ‘Modify Payments’ button is clicked at “Payments” table, system allows to 

edit “Payments and New Payment Txns” table in case of single account 

payments. 

e. Account # and Spread fields will be read only in case of Single Account 

payments. 

f. Renders the “Modify Payment Transactions” button at “Payment Txn” table in 

case of single Account payment. 

Note: This is an existing function available in Case of “Multi Account Payments” 

g. On click of “Modify Payment Transactions”, system allows to modify ALL records 

in block and also system keeps ‘New Payment Txns’ block visible in edit mode. 

h. Following fields are allowed to EDIT in “New Payment Txns” table – Account #, 

Amount, Spread and Reason. 

i. “Add, Delete” and “Reset” buttons on top of “New Payment Txns” table, are 

rendered based on “Modify Payment Txns” button. 

i. After selecting a record from “New Payment Txns” table; if user clicks on 

“Delete” button, system removes the selected record from the new 

payment txns table and a “Payment Reversal” transaction posted on to 

the account. 

ii. This “Delete” button is rendered only when the ““Modify Payment 

Transactions”” button is clicked. 

iii. After deleting the record; if user try to Save and Post the changes, 

system validates all the existing validations. 

iv. This “Reset” button is rendered only when the “Modify Payment 

Transactions” button is clicked. 
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v. If user clicks on “Reset” button after making any changes in “New 

Payment Txns” table, system resets the data to previously saved data. 

j. ‘Save and Stay’, ‘Save and Return’ buttons are renamed as ‘Post and Stay’, ‘Post 

and Return’ in “Payments” and “New Payment Txns” tables. 

k.  ‘Add (+)’ button is provided at the end of each ‘New Payment Txns’ row; which is 

available if user is on ‘edit’ mode. 

l. If new records are added for ‘Non Multi Account’ record in New Payment Txns 

block; system automatically set the flag to ‘Multi Account’ and removes the 

account number at ‘Payments’ block. 

m.  Whenever user changes/add records in block, system does following actions: 

Scenario Action 

Amount changed from 100$ to 40$ Reverse transaction with amount 100$  

Post Transaction with amount 40$ 

New record inserted and payment amount 

provided 

Post payment on new account 

Record updated with ZERO amount Reverse Original Payment 

System does not post any payment with 

ZERO amount 

i. On Post & Stay/Post & Return, system matches sum of ‘Amounts’ in 

‘Payment Txns’ block with ‘Pmt Amt’ in ‘Payments’ block. 

 

II. Automatic posting of comments on respective accounts about 

payment/reversal of payment 

a) System posts comments on respective accounts on posting of payment [through payment 

entry screen or payment maintenance screen] or reversal (including NSF) of payments. 

b) In case of reversal, system posts comments on reversed account. 

c) While posting transactions for ‘multi accounts’ system compares the old value and new 

value and in case of any change, system reversal/posting transactions for respective 

accounts. 

d) System posts comment on account, if user modifies any details of payment like ‘Currency, 

Pmt Dt, Amount, Spread, Reason’. 

 

Example: 

Payment Record Status (Current): 

Block Name Field  

Payments Pmt Amt = 80 

Payment Txns Amount = 50 (Account 1) 

Amount = 30 (Account 2) 

 

Record Status after maintenance 

Block Name Field  

Payments Pmt Amt = 80 

Payment Txns Amount = 50 (Account 1) 

Amount = 20 (Account 2) 

Amount = 10 (Account 3) 

 

 System shows following messages on multiple accounts 

 Account 1- No message (because of no change) 
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 Account 2 –  

  Message 1 – Reversal of Amount 30 

  Message 2 – Txn post of Amount 20 

 Account 3 – Txn post of Amount 10 

 

Transaction type Comment to be posted on Account with Payment 

Transaction 

Payment Posted Payment Transaction with reference number  

XXXXXXXXXXX is applied with amount of XXX on date XX-

XX-XXXX : Time 

Payment Reversed Payment Transaction  with reference number XXXXX-XX-

XXX is reversed with Amount XXX on date XX-XX-XXXX : 

Time 

Payment Details modified Payment Transaction  with reference number XXXXX-XX-

XXX is modified and posted with << Txn Details>> on date 

XX-XX-XXXX : Time 

 

Here ‘Reference’ No. is details captured in ‘Payments’ block > Reference field. 

2.43.3 Screenshot 

Servicing >Payments >Payment Maintenance 
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2.44 Collections Account Settlement Transaction 

2.44.1 Description 

At present in OFSLL, when an account becomes delinquent and under ‘Collections’, then later point in time 
lender would agree for a ‘Settlement’ with the borrower. This means a net amount will be agreed as a 
‘settlement amount’ between both the parties  and if the customer makes that payment within the ‘Good through 
date’, lender would consider that corresponding account is paid off / closed even if actual payment is less than 
the actual outstanding balance. In this case even after 180 days of delinquency, lender would not charge-off the 
account. 

Provided a new ‘Account Settlement’ monetary transaction with the following parameters 

Parameter Name Type Description 

Transaction Date Date Can be a back dated. 

Effective Date Date Date should be after account active date. Effective 
date will accept a future date also. 

Agreed Settlement 
Amount 

Integer Any amount 

Good Through Date Date Greater than ‘Effective Date’ (even after maturity date) 

Comment A/N Any text 
 

i. Once user posted this monetary transaction successfully, then a new account condition ‘Account 
Under Settlement’  needs to be posted with end date as ‘Good Through Date’ 

 This is applicable for only Loan. 

 Also, system will insert one record in ‘Transactions’ tab (‘All’ ) 

 System will update the ‘Effective Date’, ‘Agreed Amount’ and ‘Good Through Date’ 

 System will not accept a past date as the ‘effective Date’ for the settlement. It can be 
current date or a future date 

ii. In case user wanted to reverse the SETTLEMNT monetary transaction posted, same can be done 
form the ‘Transactions’ screen by clicking the ‘Reverse’ button provided. 

iii. After posting this transaction, user can see the ‘Settlement Information’ in following two places 

 Under ‘Servicing/Collections >  Customer Service >  Summary > Account Details’  

 Under ‘Servicing/Collections > Account Details > Account Details’ 
o New block will have the following details 

Filed Name Type Description 

Effective Date Date Settlement agreement start date 

Good Through Date Date Settlement agreement expiry date 

Agreed Amount Integer Settlement amount agreed by customer to the lender 

Paid Till Date Integer During the agreed period (between effective date and Good through 
date), total amount paid by the customer and allocated to account 
balances. 
I.e. system will compute the ‘Sum of all Good payment amounts received 

between effective date and good through date’ after the new proposed 
batch runs. 

 
iv. System will update the new fields Effective Date, Agreed Amount and Good through Date after 

posting the new settlement monetary transaction. User can repost the same transaction that will 
update Settlement Information. 

v. In case of a ‘Charged Off’ account, system will not allow to post the ‘Settlement’ monetary 
transaction. Similarly once the settlement monetary transaction is in force on an account, then 
system will not allow the user to charge-off the account. 

vi. System will not update the ‘Paid Till Date’ amount field as and when a payment is posted or 
reversed. Once new batch (ACCOUNT SETTLEMENT PROCESSING) job runs, ‘Paid Till Date’ 
amount field will be updated. 

 When this batch job runs, system will look for all the accounts which are having open 
‘Account Under Settlement’  condition and if ‘Paid Till Date’ amount of the account is 
greater than or equal to ‘Agreed Amount’ then following actions will be triggered -  

o System will close the ‘Account Under Settlement’  condition  
o System will not clear the ‘Settlement Information’ displayed on the Customer 

Service Summary screen and Account Details screen i.e Effective Date, Good 
through Date, Agreed Amount and Paid Till Date, meaning last settlement 
information that leads to the PAIDOFF status of the account will be preserved. 

o System will post the ‘Paid Off’ transaction automatically so that account balance 
will be updated as zero  
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 System will ignore the Write-off Tolerance amount to post Paid-Off 
transaction and outstanding balances will be waived. This means to 
avoid the situation that if the write off tolerance amount set at contract 
level is greater than the account balance, then system will ignore and 
waive the all outstanding balances.  

 After a successful settlement, if there are any payment reversals then 
system won’t reverse the ‘Paid Off’ monetary transaction automatically 
and the same needs to be handled manually. 

 In case no payment has been made or only partial payment has been received against the 
current settlement in force, during the EOD process of ‘Good Through Date’ this batch will 
remove the current settlement information i.e. Effective Date, Good through Date, Agreed 
Amount and Paid Till Date from Customer Service Summary screen and Account Details 
screen. This is because post ‘Good through date’ current settlement date is not valid and if 
required, new settlement can be posted to the account. 

 

2.44.2 Screen shot        
    After implementing the changes, screen appearance is as below:  

 

 

 
2.44.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 TXN_CODES ACCOUNT_SETTLEMENT Insert 

2 TXN_CODES ACCOUNT_SETTLEMENT_REV 
Insert 
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3 TXN_CODE_PARAMETERS ACCOUNT_SETTLEMENT|TXN_COMMENT 
Insert 

4 
TXN_CODE_PARAMETERS 

ACCOUNT_SETTLEMENT|TXN_DT 
Insert 

5 
TXN_CODE_PARAMETERS 

ACCOUNT_SETTLEMENT|TXN_SETTL_AMT 
Insert 

6 
TXN_CODE_PARAMETERS 

ACCOUNT_SETTLEMENT|TXN_SETTL_EXPIRY_DT 
Insert 

7 
TXN_CODE_PARAMETERS 

ACCOUNT_SETTLEMENT|TXN_SETTL_START_DT 
Insert 

8 

TXN_CODE_PRODUCTS
  

ACCOUNT_SETTLEMENT|ALL|ALL|ALL  

Insert 
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2.45 Work Order Enhancements 

2.45.1 Overview 

 Work order screen is enhanced to support sending the Work order to external systems. This feature can 

now support handling work orders inside Financial Institute or sending to external interface to assign 

work Orders. When assigned to external systems we will be calling this as CASE. 

  Vendor and Work order Screen is modified to handle CASE details (creating and maintaining) 

interfacing with external system.  

2.45.2 Description 
I. “Case” related fields introduced in “Work Orders” tab. 

1. Added following fields under “Work Order” table. 

Field Name 
Field 

Format 

Default 

Value 
Reference Look ups and Navigations 

Seed Data Mandato

ry 

CASE DETAILS 

Case # Read Only Null 
Received from Third Party Vendor 

Interface 

 
N 

Channel LOV 
INTERN

AL 

Indicates which channel OFSLL is 

interfacing (Ex: RDN) 

INTERNAL, 

RDN 
Y 

Override 

Reason 
 LOV Null 

Reason for Overriding the Vendor 

(New Lookup) 

 
N 

Reason LOV Null 

“Reason” field updated based on the 

corresponding Status received from RDN 

like Pending on Hold, Release and 

Pending Close. 

 Mandator

y based 

on 

correspon

ding 

status. 

Collector LOV Null 

LOV values will show list of collectors, 

who are having responsibility of 

‘Collector’.  

 

N 

ACCOUNT INFORMATION 

Account 

Status 
Read Only  

Populated Based on selected Account 

status and conditions 

 
Y 

Charged off 

Dt 
Read Only Null 

Populated Based on selected Account 

Charge Off date 

 
N 

Due Amt Read Only  
Populated Based on Account Regular 

Due Amt 

 
Y 

Total 

Outstanding 

Balance 

Read Only  

Populated Based on Account outstanding 

Principal Balance for pre charge off/ 

“Deficiency balance” for post charge-off 

accounts 

 

Y 

Total Due Read Only  
Populated Based on Account Total Due 

Amt 

 
Y 

Due Dt Read Only  
Populated Based on Account Oldest Past 

Due Date 

 
Y 

Days Past 

Due  
Read Only  

Populated Based on Account Days Past 

Due  

 
Y 

Service 

Address  
LOV  

Concatenate the “Customer, Address 

Type and Address” 

 
N 

COLLATERAL DETAILS 

Identification 

# 
Read Only  

Populated Based on Asset Identification 

Number 

 
N 

Year Read only  Populated Based on Asset Year  Y 

Make Read only  Populated Based on Asset Make  Y 

Model Read only  Populated Based on Asset Model  Y 

VENDOR INFORMATION 
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Contact Text Box  
Populated based on selected Vendor 

(Vendor Contact person) 

 
N 

Phone Text Box  
Populated based on selected Vendor 

(Vendor Phone) 

 
N 

Extn Text Box  
Populated based on selected Vendor 

(Vendor Extn) 

 
N 

Fax Text Box  
Populated based on selected Vendor 

(Vendor Fax) 

 
N 

 

2. Introduced and rearranged fields related to CASE as shown in the picture. 

3.  ‘Edit’ button provided with access control  

 ‘Edit All’’ option allows user to edit – Vendor and all other editable fields. 

 ‘Edit’’ option allows user to edit all editable fields except ‘Vendor’ fields. 

4. Case #: Case # in screen is populated from third party system. 

5. Order Type:  

i. Renamed ‘Type’ field in work order screen as ‘Order Type’. Provide ‘Door Knock, 

Skip Trace, Voluntary Repossession, Involuntary Repossession, Impound 

Voluntary Repossession, Impound Involuntary Repossession’ as seed data for 

‘Order Type’ LOV. 

ii. Based on the “Order Type” selected in work order, system short lists the vendors 

populated in “Vendor” field. (Based on Order Type selected under each Vendor). 

iii. System will restrict to create multiple assignments of same type: 

Ex: Don’t allow 2 REPO cases open at the same time. 

Validations: 

On Save, System shows error message, if user tries to create the Work Order; where  

    Channel = RDN 

    Order Type = Work Order already existing on account 

    Order Status of existing work order not in ‘Completed, Closed, and Repossessed’ 

6. When user selects an “Account” from “Account #” LOV; system auto populates the 

respective account details in ‘Account Information’ section. 

7. ‘Channel’  

 If Channel is selected as ‘RDN’; System triggers web service call to RDN interface. 

 If Channel is selected as ‘Internal’; system considers this as regular work order. 

Once the work order gets saved, system makes the ‘Channel’ Field as read-only. 

 If Channel is selected as ‘RDN’; System will make the primary collateral description 

as default value in “Servicing >vendors >Work Orders screen. 

8. Vendor Field:  

Vendor LOV will be filtered and populate list of vendors based on Channel, Order Type and Account (Company, 

Branch).  

Example: Channel = RDN, Order Type = Door knock and Account = 123456789 (Country: US, Branch US01). 

Total Active Vendor with Channel as RDN = 100 

Out of 100 Vendors, Order Type as ‘Door Knock’ = 40 

Out of 40 Vendors, vendors belongs to Account company/branch (US, US01) = 20 

On selection of above criteria, system will show list of 20 vendors in ‘Vendor LOV’. 

9. Added “Channel” field in Origination/Servicing >Vendors. 

Field Name Field Format 
Default 

Value 
Reference Look ups and Navigations 

Seed Data Man

dator

y 

Channel LOV 
INTERN

AL 

Indicates which channel OFSLL is 

interfacing (Ex: RDN) 

ALL, 

INTERNAL, 

RDN 

Y 
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10. Status:  

Status LOV is populated based on selected ‘Order Type’; which is maintained in Vendor > Cycles > Work Order 

Status Cycle. 

Following seed data maintained for ‘Status’ LOV.  

Case Status Description Status 

NEW When new case gets created the default status will be “NEW”.  Default 

SENT TO RDN 

System sets this status, once the CASE creation request sent to RDN. 

In this status, system will not allow user to make any changes to Work 

Order. 

System 

RDN FAILED 

If no response received as part of CASE creation; system will update the 

status.  

In this status, system will not allow user to make any changes to Work 

Order. 

Web service 

ASSIGNED 

When System receives the “Case Number” from Third party interface, it 

will set the status to “ASSIGNED”. 

Web service 

OPEN 

When Vendor Accepts the Assignment, system will set the status to 

“OPEN”. 

Web service 

DECLINED 

When Vendor declines the Assignment, system will set the status to 

“DECLINED”. 

Web service 

PENDING ON 

HOLD User sent a hold request to third party interface 

Manual 

ON HOLD 

“HOLD” Request is accepted by the Vendor Service (Third Party 

Interface) 

Web service 

RELEASED User sent  a Release hold request to Third Party interface Manual 

PENDING CLOSE User sent a “CLOSE” request sent to Third Party interface Manual 

CLOSED “CLOSE” request accepted by the Vendor Service (Third Party Interface) Web service 

COMPLETED Vendor has completed the Repossession service Web service 

REPOSSESSED Repo info has been validated Web service 

11. Collector field added in Case tab and the LOV values populated based on user having 

responsibility as collector in Description.  

12.  “Reason” field updated based on the corresponding Status received from RDN like 

Pending on Hold, Release and Pending Close. 

13. “Service Address” field LOV is added, which displays the following addresses dropdown. 

i. System will display the concatenation of “Customer-Address type – Address” 

attached to the account; where current Indicator=’Y’. 

ii. This field will allow user to edit only when the Work Order status = NEW. 

iii. Default value is the Primary customers address with current = Y and Mailing = Y. 

 On Save, system does the following validation: 

 If Channel = ‘RDN’ and user tries to select any customer address other than Primary customer and secondary 

customer (chosen based on the customer sequence after primary); system will throw an error message “Selected 

address doesn’t belong to Primary or Secondary Customer’ and will not allow to save record. 

14. When user selects a “Collateral” from “Collateral Description” LOV; system will auto 

populate the respective collateral details. 

15. System default the “Collateral” with Primary Indicator = Y. 

16. Vendor Messages: 

 ‘Vendor Msg Type’ and ‘Vendor Message’ transient boxes are provided in Work Order Screen. These Message Type 

and Message box are rendered, if Channel = RDN. 
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 ‘Comments’ posted in ‘Account Comments’ with CASE No. appended. 

Comment Format:  

Type = SYSTEM GENERATED 

Sub Type = OUTBOUND TO INTERFACE 

Comment = [Case No]: <<Vendor Msg Text>>. 

Comment By = Login User ID 

Comment Dt = Comment Posted date 

 

II. Vendor setup screen changes 

A. Changes under ‘Cycles’ Tab 

 Added following fields to “Status Cycle” tab in Setup> Vendors >Cycles. 

Field Name Type Default Values 

Order Type LOV (VENDOR_ASG_TYPE_CD) Null 

i. Order Type (VENDOR_ASG_TYPE_CD) LOV has “ALL” as lookup value. 

ii. Added following fields in “Current/Next Status” block. 

 

Field Name Type Default Values 

Action Code 

LOV (Refer ‘Action’ lookup in Call 

Activities Tab) 

Null 

Result Code 

LOV (Refer ‘Result’ lookup in Call 

Activities Tab – Dependant LOV of 

Action Code) 

Null 
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 Whenever Order reaches the ‘Current Status to Next Status’ stage, system automatically posts 

‘Call Activity’ (if the Action/Result Code is not NULL). 

 If the “Condition” is not configured for an “Action and result code” combination, system shows 

the following warning message. 

o Warning: “No Condition posting available for this action-result pair” 

III.  “Case History” sub tab in Vendor > Case tab 

1. Added “Work Order History” details sub tab in Vendor >Work Order tab. 

i. Any modifications to Work Order Details logged as history record in “Work 

Order History” tab 

 All the details captured in ‘Work Order Tab’ stored in ‘History Tab’. 

Example: If the status changed from “NEW” to “Assigned” as History record will be created in “Work Order 

History” tab with previous status as “NEW”. 

  

IV. Case “Repo Details” included in Customer Details > Repo Screen 

New set of fields added to Customer Details > Repossession Screen and updated based on response received from 

“Third Party Interface”. 
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V. Vendor Screen Changes 

Vendor Id Generation 

 New system parameter ‘UVN_VEN_NBR_SYS_GENERATED’ added to indicate ‘Vendor Number is system 

generated’ with Yes/No LOV options.  

– If parameter value = ‘YES’, system auto generates the vendor id.  

– If parameter value = ‘NO’, system allows to input the vendor id manually as free text in ‘Vendor’ 

Screen. 

Vendor ‘COPY’ feature 

 Vendor Definition Screen > Vendor Copy feature is provided. 

– If the system parameter ‘Vendor Number is auto generated’ = Y; system automatically generates 

vendor number. 

– If the system parameter ‘Vendor Number is auto generated’ = N; system allows user to input 

Vendor number on EDIT. 

o If user input duplicate Vendor ID, system will validate and display error on 

SAVE. 

  

VI. Cure letter fields at Servicing > Account Information Tab 

 Cure Letter fields – Start Date and End Date provided at Account Details screen. 

 File upload and Non-monetary (CURE_LETTER_MAINT) is provided to update these dates.  
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VII. Invoice screen changes 

Case #’ in ‘Invoice’ Screen  

 Included ‘Case #’ field in Invoice Details screen. This field will be rendered only if CASE ID is attached for 

that work order or invoice.  

 

Work Order Details in Servicing >Summary page 

 Work Order related details are provided in summary screen 

 

Renamed “Order Type” field as “Work Order Type”  

 Order Type field name renamed as “Work Order Type” in following locations. 

 Servicing > Vendors >Work order screen 

 Servicing >Transaction History >Work Orders 

 Servicing >Summary Screen. 

 Servicing > Repo/Foreclosure Tab 
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2.46 Vendor Assignment Allocation 

2.46.1 Overview 

While creating the work order system will allocate the Vendor by assigning vendor allocation 
weightage.  

New ‘Assignment Allocation’ screen provided to define vendor allocation weightage; which defaults 
vendor in CASE screen based on Channel, Work Order Type, Company and Branch combination. 

2.46.2 Description 

I. New ‘Assignment Allocation’ tab 

Introduced new “Assignment Allocation’ tab besides Servicing > Vendors tab as shown below: 

On Selection of this row; system shows list of ‘Active’ and ‘Enabled’ vendors under ‘Vendor 
Assignment Allocation’ sub tab. 

Field Name Type Default 
Value 

Reference Mandatory 

Channel LOV NULL VENDOR_ASG_CHANNEL_CD Yes 

Work Order Type LOV NULL Work Order Type Yes 

Company LOV NULL Company Setup Yes 

Branch LOV NULL Branch Setup Yes 

Enabled Check 

box 

N Y/N Bullion Yes 

 

 

II. ‘Vendor Assignment Allocation’ sub tab 

1. Added ‘Assignment %’ field in Vendors> Vendor Assignment’ fragment. 

2. Data Validations: 

 “Assignment %” field is mandatory and default value = “0” 

 On EDIT; if sum is not equal to 100%, system shows an ERROR saying 
“Assignment sum not equal to 100” and system doesn’t allow saving the record. 

Field 
Name 

Type Default 
Value 

Mandatory Comments 

Vendor # Read Only NA Yes  

Name Read Only NA Yes  

Assigned 

Cases 

Read Only - 
Numerical 

NA Yes For behaviour; refer spread sheet 
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% Allocation Read Only- 
Numerical 

NA Yes For behaviour; refer spread sheet. 

On Save, system does following validation: 

‘% Allocation’ should not be same for any two 

vendors. If user tries to save, system gives 

error message ‘Duplicate values found in ‘% 

Allocation’ and should not allow saving the 

record. 

Assignment 

% 

Text Box - 

Numerical 

0 Yes  

Total % Read Only 

(Sum of 

Assignment %) 

   

Assignment/Re-assignment Logic 
 
System assigns “Case” to shortlisted vendors based on “% Allocation” logic. 

 Assignment is being done based on ‘Least %’ bucket. 

Exceptions to be handled while assigning: 

 If two or more cases are opened for an account, system allocates all the cases (belongs to 
same account) to the same vendor.  

 If the case is ‘Re-assigned’; system shout not assign the case to same vendor. 
 

2.46.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.ASSIGNMENTALLOCATION.TAB|RESPONSIBILITY_
CD|ALL|Y|Y Insert 

2 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.ADD.BUTTON|RE
SPONSIBILITY_CD|ALL|Y|Y Insert 

3 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.EDIT.BUTTON|RE
SPONSIBILITY_CD|ALL|Y|Y Insert 

4 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.VIEW.BUTTON|R
ESPONSIBILITY_CD|ALL|Y|Y Insert 

5 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.EDIT.BUTTON
|RESPONSIBILITY_CD|ALL|Y|Y Insert 

6 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.VIEW.BUTTO
N|RESPONSIBILITY_CD|ALL|Y|Y Insert 

7 FLS_ACCESS_DETAILS 
FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.AUDIT.BUTTO
N|RESPONSIBILITY_CD|ALL|Y|Y Insert 

8 FLS_ACCESS 
FLL.CMN.UVN.ASSIGNMENTALLOCATION.TAB|ACCESS TO CMN 
UVN ASSIGNMENT ALLOCATION TAB|Y|Y|CMN|UVN Insert 

9 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.ADD.BUTTON|AC
CESS TO CMN UVN ASSIGNMENT CRITERIA ADD 
BUTTON|Y|Y|CMN|UVN Insert 

10 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.EDIT.BUTTON|AC
CESS TO CMN UVN ASSIGNMENT CRITERIA EDIT 
BUTTON|Y|Y|CMN|UVN Insert 

11 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTCRITERIA.VIEW.BUTTON|A
CCESS TO CMN UVN ASSIGNMENT CRITERIA VIEW 
BUTTON|Y|Y|CMN|UVN Insert 

12 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.EDIT.BUTTON
|ACCESS TO CMN UVN ASSIGNMENT ALLOCATION EDIT 
BUTTON|Y|Y|CMN|UVN Insert 

13 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.VIEW.BUTTO
N|ACCESS TO CMN UVN ASSIGNMENT ALLOCATION VIEW 
BUTTON|Y|Y|CMN|UVN Insert 

14 FLS_ACCESS 

FLL.CMN.UVN.VENDORASSIGNMENTALLOCATION.AUDIT.BUTTO
N|ACCESS TO CMN UVN ASSIGNMENT ALLOCATION AUDIT 
BUTTON|Y|Y|CMN|UVN Insert 



2-214 

 

 

2.47 Vendor Fee Enhancements 

2.47.1 Overview 

I. Currently in OFSLL Fee is captured at the work order level; there is no fee definition available for 

vendor services. This allows user to select Fee type at the work order level. 

1. Enhancement is to provide fee definition for vendor services by vendor and it will get 

populated in ‘Estimated Cost’ of the assignment. 

2. When user creates the work order, with the vendor and service, Fee will get defaulted. 

User is allowed to change the ‘Currency and Estimated’ Fee amount.   

3. ‘Disbursement Currency’ field is added in ‘Vendors > Payments Details’. 

4.  ‘Estimated’ field in ‘Invoices’ screen is added. 

II. Changes in AP Transactions 

 AP Transactions>  Requisitions > Details > Description – Append ‘Payable Id’ 

 Add ‘Disbursement Amount’ Column in AP Transactions screen 

III. ‘Service #’ is added at Work Order > Services Screen 

IV. ‘Service #’ in drop down at Servicing > Vendors > Invoices > Work Order Drop down 

V. Account Currency and ‘Amount in Account Currency’ fields in Vendors > Invoices > Payment 

Schedules 

VI. Currency related changes in Vendor > Work Order and Invoice Screens 

VII. AP Transaction and GL Generation based on Currency 

2.47.2 Description 
I. Defaulting ‘Estimated’ Fee based on setup defined 

Setup >Vendors 

To default estimated fee, new ‘Fees’ tab is introduced in ‘Setup > Vendors’ screen with following fields: 

 

Field Name Field Format Description 

Default 

Value 

 Look ups 

& 

Validations 

Mandato

ry 

Start Dt 

Text Box with 

Calendar  Specify the ‘Start Dt’. 

CURRENT 

DATE 

NA  Yes 

End Dt 

Text Box with 

Calendar Specify the ‘End Dt’. 

12/31/4000 NA No 

Enabled Check Box 

Check to enable the ‘Fee 

Rule’ 

UNCHECKE

D 

NA Yes 

Amt Text Box 

Provide only numeric values 

to specify estimated fee. 

NA NA Yes 

Vendor Group Drop Down Show list of ‘Vendor Groups’ ALL NA Yes 

Vendor Drop Down 

Show list of ‘Active Vendors’ 

which belongs to selected 

Vendor Groups’ 

ALL NA Yes 

Services Drop Down 

Show list of services attached 

to ‘Vendor Group’ 

Undefined NA Yes 

Company Drop Down 

Refer ‘Company’ definition 

table 

ALL NA Yes 

Branch Drop Down 

Refer ‘Company’ definition 

table 

ALL NA Yes 

Vendor Drop Down Show list of channels in  VENDOR_A Yes 
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Channel dropdown SG_CHANN

EL_CD 

State Drop Down Specify the ‘State’. ALL STATE_CD Yes 

 

Selection Criteria 

 ‘Start Dt’ and ‘End Date’ value should not be less than current date. 

 State in selection criteria indicates ‘Vendor State’. 

 Company, Branch indicates Vendor Country, Branch. 

 System defaults fees based on selected Vendor Group, Vendor, Services, Account 

Company, Branch and Work Order – Channel. 

 If all the above criteria are matched; system checks, if the record is enabled and default 

the fee. 

Note: System considers specific value before considering ‘ALL’.  

Example: Fee defined for ‘specific Vendor’ is applicable, even if ‘fee’ definition is applicable for ‘Vendor = ALL’ 

II. ‘Customer Service >Vendors > Work Orders > Services’ Changes 

 When user creates the work order and on selection of ‘Service’, system auto populates 

(default) Fee in combination of selection criteria in ‘Vendor Fee’ setup. 

 User is still allowed to edit the ‘Estimated’ field.  

 

Note: Removed ‘Fee Type’ field from this screen 

 

III. Added ‘Currency’ and ‘disbursement currency’ fields in ‘Origination/Customer 

Service > Vendors > Vendors > Payment Details’ 

 System will auto-populate ‘Currency’ and ‘Disbursement Currency’ of vendor based on 

currency selected. 

 User can still update ‘Disbursement Currency’ from LOV. 
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IV. Default ‘Currency’ based on ‘Vendor Currency’ at ‘Work Order Screen’ 

 System defaults ‘Vendor Currency’ based on Vendor selected (Vendor Company 

Currency) at Work Order screen and this field is now made as ‘read only’. 

  

V. ‘Estimated’ field in ‘Invoices’ screen 

  Added a new field estimated amount in Invoice details [Vendor>Invoices] 

 This field gets defaulted from WO>Services 

 System auto populates ‘Estimated’ amount on selection of ‘Work Order #” dropdown in 

‘Invoice Details’ block. 

 Added ‘Estimated’ field in Vendors > Invoices > Invoice Information. This ‘Estimated’ field 

value is summation of all ‘Estimated’ amount at Vendors > Invoices >‘Invoice Details’ tab. 

 

VI. ‘Service #’ at Work Order > Services Screen 

 Added ‘Service # (free text field) at Work Order > Services Screen to record external 

invoice numbers. 

 System now appends ‘Service #’ in drop down at Invoice details [Vendor>Invoices] > Work 

Order Drop down as shown in the fig. 
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VII. Account Currency and ‘Amount in Account Currency’ fields in Vendors > Invoices 

> Payment Schedules 

 Two new fields – Account Currency and Amount in Account Currency added at Vendors > 

Invoices > Payment Schedules tab. 

 System generates ‘AP Transaction’ request based on ‘Disbursement Currency’ given at 

‘Payment Schedule’ tab. 

o While calculating ‘Amount in Account Currency’ system considers following 

parameters: 

From Currency = ‘Vendor Currency’ 

To Currency = ‘Account Currency’ 

‘Exchange Rate’ consideration date = Payment Schedule -> Payment Date. 
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VIII. Currency related changes in Vendor > Work Order and Invoice Screens 

 Vendor > Work Order > Services > Currency field is made ‘Read only’. Defaulting of 

currency from work order (Vendor Currency) will remain same. 

 Vendor > Invoice > Payment Schedule > Currency field defaults the ‘Vendor 

Currency’.  This field is made ‘Read only’. 

 Disbursement Currency field in Payment Schedule vendor is defaulted with ‘Vendor 

Currency’ still user can change the disbursement currency. 

IX. AP Transaction generation based on Disbursement Currency 

AP Transaction Generation: 

 System generates ‘AP Transaction’ based on ‘disbursement currency’ provided at 

Vendors > Invoices > Payment Schedule. 

 

Changes in AP Transaction Screen 

 Renamed the existing ‘Amount’ field as ‘Disbursement Amount’. 

 Rearranged fields in AP transaction screen as - Currency, Amount, Disbursement 

Currency, Disbursement Amount and Pmt Mode. 

 Introduced new column in AP Transaction screen to show amount in ‘Account 

Currency’. 

 

X. Changes in AP Transaction Screen 

a. Showing requisition details based on requisition number 

 Showing ‘Requisition Id’ at AP Transactions > Requisitions Block  

 Showing ‘Payment Id’ at AP Transactions > Details Block  

 

b. Changes in Servicing ‘Vendor > Invoices > Payment Schedule tab 

 Show ‘Requisition Id’ (VIP ID) generated at AP Transactions > Requisitions Block as 

“Payable ID” in Payment Schedule screen. 
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2.48 Create Case in third party interface 

2.48.1 Overview 

As part of the Vendor assignment integration with third party interface, User need to create a case 
in OFSLL that will be communicated using the addCase() web service. 

2.48.2 Description 

1. When user changes the work order status from “NEW” to “SEND TO GRI”, system will trigger the 
“addCase()”web service and case will be created in third party portal. 

 

2. As part of web service, following Case details will be sent to third party interface 

 Primary Customer 

 Secondary Customer (Based on the sequence) 

 Address Details 

 Account Details 

 Collateral Details  

3. Following account level comment (Servicing >Account Customer Service >Comments) will be 
posted when “Case #” is received as part of the web service response and work order status will be 
changed from “SEND TO GRI” to “ASSIGNED”. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = [Case No]: “NEW CASE CREATED”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 
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4. Following account level comment (Servicing >Account Customer Service >Comments) will be 
posted when “Error” is received as part of the web service response and work order status will be 
changed from “SEND TO GRI” to “GRI FAILED”. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “<<Error Message>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 
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5. Web service call will fail, if user sends a work order type which is not mapped with third party 
interface and system will change the status from “SEND TO GRI” to “GRI FAILED” and comment 

will be posted to account. 

MDB Configuration: 

a. Following parameters are configured in CSF Frame work to establish the connection with Third 
Party interface. 

 WSDL URL 

 API Key 

 Certificate 

Note: Refer the “patch_installation_guide.pdf” document for detailed configuration. 

2.48.3 Seed Data Changes: 

SNO TABLE KEY DATA Type 

1 LOOKUPS VENDOR_ASG_STATUS_CD|N Insert 

2 LOOKUPS VENDOR_ASG_STATUS_CD|A Insert 

3 LOOKUPS VENDOR_ASG_STATUS_CD|SR Insert 

4 LOOKUPS VENDOR_ASG_STATUS_CD|RF Insert 
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2.49 Update Case details in third party interface 

2.49.1 Overview 

As part of the Vendor assignment integration with third party interface; after creating a case in third 
party interface using addCase() web service; system will send ‘Case Update’ details to Third Party 
Interface and receives updates from Third Party interface. 

2.49.2 Description 

I. Case Updates: 

a. Whenever account details (which are mapped) gets updated, system triggers 
“updateCaseAccountInfo()” web service. 

 

b. Whenever Address details (which are mapped) gets updated, system triggers the 
“updateCaseAddress()” web service. 

 

c. Whenever Collateral details (which are mapped) gets updated, system triggers the 
“updateCaseCollateral()” web service. 

 

d. Whenever Primary Customer details (which are mapped) gets updated, system triggers 
the “updateCaseDebtor()” web service. 
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e. Whenever Secondary Customer (Based the sequence of customers type) details gets 
updated, system triggers the “updateCaseCosigner()” web service. 

 

f. If response from interface is “YES”, then system posts a comment with following 
parameters in Servicing >Account Customer Service >Comments. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<UPDATED ACCOUNT DETAILS ACCEPTED 

BY THIRD PARTY INTERFACE>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date and time. 

g. If response from interface is “NO”, system posts a comment with following parameters in 
Servicing >Account Customer Service >Comments. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<UPDATED ACCOUNT DETAILS NOT 

UPDATED IN THIRD PARTY INTERFACE>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date and time. 

II. Hold Case: 

a. If work order status changed to “PENDING ON HOLD”, system triggers “holdCase()” web 

service to request the case to be kept in hold status in the third party portal. 

b. If response from interface is “YES”, system posts a comment with following parameters in 
Servicing >Account Customer Service >Comments. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<CASE HOLD REQUEST ACCEPTED BY 

THIRD PARTY INTERFACE (Reference No)>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 
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 If response from interface is “NO”, system posts a comment with following 
parameters in Servicing >Account Customer Service >Comments with alert flag 
=’Y’ and system will not change the status of work order. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<CASE HOLD REQUEST NOT UPDATED IN 

THIRD PARTY INTERFACE>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

III. Close Case 

a. If work order status changed to “PENDING CLOSE”, system triggers “closeCase()” 

web service to request the case to be closed in the third party portal. 

b. If response from interface is “YES”, system posts a comment with following 
parameters in Servicing >Account Customer Service >Comments. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = CASE NO: “<<CASE CLOSE REQUEST ACCEPTED BY 

THIRD PARTY INTERFACE >>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 
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c. If response from interface is “NO”, system posts a comment with following parameters 
in Servicing >Account Customer Service >Comments with alert flag =’Y’ and system 
will not change the status of work order. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = CASE NO: “<<CASE CLOSE REQUEST NOT UPDATED 

IN THIRD PARTY INTERFACE >>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

 

2.49.3 Seed Data Changes: 

SNO TABLE KEY DATA Type 

1 LOOKUPS VENDOR_ASG_STATUS_CD|PC INSERT 

2 LOOKUPS VENDOR_ASG_STATUS_CD|PH INSERT 
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2.50 Receive Case updates from Third Party Interface: 

2.50.1 Overview 

As part of the Vendor assignment integration with third party interface; after creating a case in third 
party interface using addCase() web service; system will receives updates from Third Party 
interface by calling FireHose() Web service. 

2.50.2 Description 

FireHose() Web service: 

d. A system parameter is created to schedule the time for triggering the 
“getRdnFireHose” web service. 

e. Based on the system parameter, system triggers the “getRdnFireHose” web service 
with latest even id. 

f. Based on “Event type” received as part of web service response, system does the 

following actions. 

Event 
Type 

Event Description Actions will be taken 
by OFSLL 

Account Comments 

600 ACCEPTED CASE System will change the 
Work order status to 
“OPEN” 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor] 
ACCEPTED CASE>>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 

601 DECLINED CASE System will change the 
Work order status to 
“DECLINED” 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor] DECLINED 
CASE>>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time. 

602 ACKNOWLEDGED 
CLOSE 

System will change the 
Work order status to 
“CLOSE” 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: 
ACKNOWLEDGED CASE CLOSER >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time. 

603 ACKNOWLEDGED 
HOLD 

System will change the 
Work order status to 
“ON HOLD” 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: 
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ACKNOWLEDGED CASE HOLD >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time. 

300 CASE WAS REPOED System will change the 
Work order status to 
“REPOSSESSED” 

And 

System will call the 
“getRepossessionDet
ails()” web service to 

get the repossession 
details and changes 
can be view in 
Servicing > 
Repo/Foreclosure” tab. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: CASE 
GOT REPOSSESSED >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date 

302 CASE COMPLETED System will change the 
Work order status to 
“COMPLETED” 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: CASE 
COMPLETED >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time. 

200 FIRST UPDATE 
ADDED CUSTOM 

System will post the 
received update as 
“Inbound Comment” 

from Interface in 
Servicing >Customer 
Service >Comments 
tab. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: Vendor 
Msg Text >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time. 

201 UPDATE EDITED System will post the 
received update as 
“Inbound Comment” 

from Interface in 
Servicing >Customer 
Service >Comments 
tab. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: Vendor 
Msg Text >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 

203 UPDATE UNHIDDEN System will post the 
received update as 
“Inbound Comment” 

from Interface in 
Servicing >Customer 
Service >Comments 
tab. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: Vendor 
Msg Text >>” 

Comment By = “INTERNAL” 



2-228 

 

 

Comment Dt = Comment Posted date and time 

811 INVOICE SENT TO 
CLIENT 

System will call the 
“getCaseInvoiceData()

” web service and 
creates the invoices in 
OFSLL. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: INVOICE 
CREATED IN THIRD PARTY INTERFACE >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 

1300 CR ADDED System will update 
‘Condition Report 
Status =’Y’ and 
Condition Report Recd 
Dt = Event Received 
Date 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: 
CONDITION REPORT AVAILABLE IN THIRD 
PARTY INTERFACE >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 

a. Exceptions: 

 Before updating new status based on Third Party Interface event type; system 
validates previous status.  

 If the previous status is not matching as per cycle setup, system will not update the 
Work Order status and post a comment in “Servicing >Customer Service >Comments 
tab. 

Type = SYSTEM GENERATED 
Sub Type = SYSTEM GENERATED 
Comment = “[Case No]: <<[Vendor]: Work Order Status Update failed 
due to mismatch of previous status >>” 
Comment By = “INTERNAL” 

Comment Dt = Comment Posted date 

Note: User is expected run “upgrade_fix_RDN_Day0_Setup.sql” script to update the 

“Last Event ID” at day zero setup. 

 
 

b. Once the “Repossession details” received as part of response, system posts a comment in 
customer Service >Comments tab with following parameters. 

a. System posts a Customer Service >Comments with following parameters. 

Type = SYSTEM GENERATED 
Sub Type = INBOUND FROM INTERFACE 
Comment = “[Case No]: <<[Vendor]: REPO DETAILS 
RECEIVED FROM THIRD PARTY INTERFACE >>” 
Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 
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c. Once the “Repo details” are received from third party, system updates the mapped details in 

“Servicing > Repo/Foreclosure > Case Repo Details section. 
 

 
 
 

2.50.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 JOB_THREADS SET-GRI2|RDNFRH_BJ_100_01|1 INSERT 

2 JOBS SET-GRI2|RDNFRH_BJ_100_01 INSERT 

3 JOB_SETS SET-GRI2 INSERT 

4 SYSTEM_PARAMETERS Get fire house system parapeter INSERT 
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2.51 Work order “Auto Hold” based on Delinquency Days: 

2.51.1 Overview 

As part of the Vendor assignment integration with third party interface; After creating a case in third 
party interface using addCase() web service; system has the ability to place a Case on Hold 
automatically based on delinquency days system parameter. 

2.51.2 Description 

a. New system parameter ‘Delinquency Days for Automatic Case Status Change’ is introduced to 
define the delinquency days to place the work order in Hold status.  

      This parameter is having following fields. 

Field Name Data Type/Tool Default 

Delinquency Days for Automatic 
Case Status Change 

Text Box  - Accept only 
Numeric (Positive Value) 

SET ME 

Hold Reason LOV “Customer Promised to 
Pay Current” 

 
b. A batch job is created to run at a set frequency and perform following functionality. 

i. When a payment is received on account and ‘Delinquency Days’ falls below the value 
defined in system parameter; system will automatically change the ‘CASE status’ to 
‘Pending Hold’ and updates the ‘Status Dt’ and triggers the web service to update the 
information to Third Party Interface. 

Please Note: In case of ‘Payment Reversal’, user is expected to handle the impact on CASE status 

manually. 

2.51.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 
FLEX_TABLE_AT
TRIBUTES 

SET_SYP_SYSTEM|GRI_DLQ_DAYS_AUTO_STATUS_CH
G INSERT 

2 JOB_SETS SET-GRI1 INSERT 

3 JOBS SET-GRI1|RDNDLQ_BJ_100_01 INSERT 

4 JOB_THREADS SET-GRI1|RDNDLQ_BJ_100_01|1 INSERT 

5 
SYSTEM_PARAM
ETERS 

GRI_DLQ_DAYS_AUTO_STATUS_CHG|SET_SYP_SYSTE
M|ALL|ALL|ALL|ALL|ALL|ALL|ALL INSERT 

6 LOOKUPS VENDOR_ASG_STATUS_CD|C UPDATE 

7 LOOKUPS VENDOR_ASG_STATUS_CD|L UPDATE 

8 LOOKUPS VENDOR_ASG_STATUS_CD|H UPDATE 

9 LOOKUPS VENDOR_ASG_STATUS_CD|PH UPDATE 

10 LOOKUPS VENDOR_ASG_STATUS_CD|PC UPDATE 

11 LOOKUPS VENDOR_ASG_STATUS_CD|RP UPDATE 

12 LOOKUPS VENDOR_ASG_REASON_CD|4H UPDATE 

13 LOOKUPS VENDOR_ASG_REASON_CD|5H UPDATE 

14 LOOKUPS VENDOR_ASG_REASON_CD|6H UPDATE 

15 LOOKUPS VENDOR_ASG_REASON_CD|7H UPDATE 

16 LOOKUPS VENDOR_ASG_REASON_CD|8H UPDATE 

17 LOOKUPS VENDOR_ASG_REASON_CD|9H UPDATE 

18 LOOKUPS VENDOR_ASG_REASON_CD|10H UPDATE 

19 LOOKUPS VENDOR_ASG_REASON_CD|11H UPDATE 

20 LOOKUPS VENDOR_ASG_REASON_CD|100H UPDATE 

21 LOOKUPS VENDOR_ASG_REASON_CD|12H INSERT 

22 LOOKUPS VENDOR_ASG_REASON_CD|13H INSERT 
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2.52 REPO Third Party Integration Web services 

2.52.1 Overview 

OFSLL Repossession/Vendor management functionality has been enhanced to integrate with third 
party REPO service providers. 

2.52.2 Description 

Vendor screen has been enhanced to interface with the third party service providers to perform following 
actions using web services. 

reopenCase()  Web service to request the case to be Reopen in Third Party 
portal. 

reassignCase() Web service to request the reassign the case to a new vendor in 
third party portal. 
 

addCaseUpdate() Web service to post a comment on to the account in Customer 
Service > Comments. If a comment is updated in “Vendor Msg” 
field with “Vendor Msg Type”. 
 

getCaseInvoiceData() Web service to receive Invoice data 

 

I. Reopen Case 

a. If work order status changed from “On Hold” to “Released”, system will trigger 
“reopenCase()” web service will request the case to be Reopen in Third Party 

portal. 

b. If response from interface is “True”, system will post a comment with following 
parameters in Servicing >Account Customer Service >Comments. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<CASE REOPEN UPDATED IN THIRD 

PARTY INTERFACE>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

c. If response from interface is “NO”, system will post a comment with following 
parameters in Servicing >Account Customer Service >Comments with alert flag 
=’Y’ and system will not change the status of work order. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “CASE NO: <<CASE REOPEN REQUEST NOT 

UPDATED IN THIRD PARTY INTERFACE>>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

 

II. Reassign the Case: 

a. If the vendor field updated from old vendor to a new vendor, system will do the 
following activities  

 System will change the current case status to “Pending Close - Reassign”. 

Note: 

a. In case of Reassignment of case, GRI will automatically send a close 
request to current case and create new case request and returns new 
case # as a response. 
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b. Once the current case “Close” confirmation received from interface as 
part FireHose() web service, system will change the Current case status 
to “Close”.  

 System triggers the “reassignCase()” web service to request reassignment of case 

to a new vendor in third party portal. 

a. If response from interface is “Case #”, system will create a new Work Order with 
new case #, new vendor and previous work order account details. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = NEW CASE NO: “<<CASE REASSIGNMENT REQUEST 

ACCEPTED BY THIRD PARTY INTERFACE >>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

b. If response from interface is “error”, system will post a comment with following 
parameters in Servicing >Account Customer Service >Comments. Here, system 
will not change the status of work order, Change vendor and create a new case. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = CASE NO: “<<CASE REASSIGNMENT REQUEST NOT 

UPDATED IN THIRD PARTY INTERFACE >>”  

Comment By = “INTERNAL”  

Comment Dt = Comment Posted date 

c. In case of “Reassignment”, current case will get a “Close” event from firehouse 
web service and a new case will be created with current case details with 
Assigned status. 

d. In case of work order with no Case #, if vendor gets changed; system will not 
create a new work order. 

III. Case Comments: 

a. If a comment is updated in “Vendor Msg” field with “Vendor Msg Type” in Servicing 

>Vendors >Work Order and click on Save and Return or Save and Stay, system will 
call the “addCaseUpdate()” web service and comment will be posted on to the 
account in Customer Service > Comments. 

Type = SYSTEM GENERATED 

Sub Type = OUTBOUND TO INTERFACE 

Comment = “[Case No]: <<Vendor Msg Text >>”  

Comment By = “USER”  

Comment Dt = Comment Posted date 

IV. Case Invoice : 

a. Once the invoice data received as part of getCaseInvoiceData() web service 

request, System will create the  “Invoice Information”, “Invoice Details” and “payment 
Schedule” in OPEN Status. 

1. System will post a Customer Service >Comments with following parameters. 

Type = SYSTEM GENERATED 

Sub Type = INBOUND FROM INTERFACE 

Comment = “[Case No]: <<[Vendor]: INVOICE RECEIVED FROM 

THIRD PARTY INTERFACE >>” 

Comment By = “INTERNAL” 

Comment Dt = Comment Posted date and time 
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b. When Work Order Channel = GRI, Invoices (“Invoice Information”, “Invoice Details” 
and “payment Schedule”) received from Third Party will be in read only mode . 

c. Payment schedule record can be populated with same Invoice details received as 
part of web service response.(Payment Amt, Payment Dt and Status = OPEN). 

 

2.52.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 LOOKUPS VENDOR_ASG_TYPE_CD|SKP UPDATE 

2 LOOKUPS VENDOR_ASG_TYPE_CD|DRK UPDATE 

3 LOOKUPS VENDOR_ASG_TYPE_CD|VRP UPDATE 

4 LOOKUPS VENDOR_ASG_TYPE_CD|IRP UPDATE 

5 LOOKUPS VENDOR_ASG_TYPE_CD|IVR UPDATE 

6 LOOKUPS VENDOR_ASG_TYPE_CD|IIR UPDATE 

7 LOOKUPS INVOICE_PMT_STATUS_CD|A UPDATE 

8 LOOKUPS INVOICE_STATUS_CD|A UPDATE 

9 LOOKUPS INVOICE_PMT_STATUS_CD|F INSERT 

10 LOOKUPS INVOICE_STATUS_CD|F INSERT 

11 
FLS_ACCE
SS FLL.CMN.UVN.VENDORINVOICE.VALIDATEINVOICE.BUTTON INSERT 

12 
FLS_ACCE
SS FLL.CMN.UVN.VENDORINVOICEDETAIL.REJECT.BUTTON INSERT 

13 
FLS_ACCE
SS FLL.CMN.UVN.VENDORINVOICEDETAIL.ACCEPT.BUTTON INSERT 

14 

FLS_ACCE
SS_DETAIL
S 

FLL.CMN.UVN.VENDORINVOICE.VALIDATEINVOICE.BUTTON|
RESPONSIBILITY_CD|ALL INSERT 

15 

FLS_ACCE
SS_DETAIL
S 

FLL.CMN.UVN.VENDORINVOICEDETAIL.ACCEPT.BUTTON|RE
SPONSIBILITY_CD|ALL INSERT 

16 

FLS_ACCE
SS_DETAIL
S 

FLL.CMN.UVN.VENDORINVOICEDETAIL.REJECT.BUTTON|RE
SPONSIBILITY_CD|ALL INSERT 

17 LOOKUPS VENDOR_SERVICE_TYPE_CD|IRP  INSERT 

18 LOOKUPS VENDOR_SERVICE_TYPE_CD|VRP  INSERT 

19 LOOKUPS VENDOR_SERVICE_TYPE_CD|SPR  INSERT 

20 LOOKUPS VENDOR_SERVICE_TYPE_CD|IVR  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|IIR  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|CLF  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|MLF  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|CUF  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|DRK  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|STR  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|SKF  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|CLFS INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|FCS  INSERT 

21 LOOKUPS VENDOR_SERVICE_TYPE_CD|SPC  INSERT 

21 LOOKUPS VENDOR_ASG_STATUS_CD|P INSERT 

21 
TRANSLATI
ON_DATA 

SYS|SYS|SYS|UVN|001771|INVOICECANNOTBEVALIDATEDWI
THOUTINVOICEDETAILS.|SYS|MSG-SE INSERT 

21 
TRANSLATI
ON_DATA 

SYS|SYS|SYS|UVN|001772|INVOICECANNOTBEVALIDATEDWI
THOUTPAYMENTSCHEDULE.|SYS|MSG-SE INSERT 

21 
TRANSLATI
ON_DATA 

SYS|SYS|SYS|UVN|001774|INVOICECANNOTBEVALIDATEDAS
INVOICEDETAILS/PAYMENTSCHEDULESARENOTINOPENST INSERT 
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ATUS|SYS|MSG-SE 

21 CYCLES CN_LN_CE_ORG UPDATE 

21 CYCLES CN_LN_OE_ORG UPDATE 

21 CYCLES CN_LS_CE_ORG UPDATE 

21 CYCLES POO_POOL_ACC_STATUS UPDATE 

21 CYCLES POO_POOL_STATUS UPDATE 

21 CYCLES PRO UPDATE 

21 CYCLES VEN_INVOICE_PMT_STATUS UPDATE 

21 CYCLES VEN_INVOICE_STATUS UPDATE 

21 CYCLES VEN_VENDOR_STATUS UPDATE 

21 CYCLES COL_DEFC_DISP_STATUS UPDATE 

21 CYCLES COL_REPO_FORC_DISP_STATUS UPDATE 

21 CYCLES COL_BKRP_DISP_STATUS UPDATE 
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2.53 Invoice Authorization Framework  

2.53.1 Overview 

‘Authorized By’ and ‘Authorized Date’ fields are added in ‘Invoice Details’ block. 

2.53.2 Description 

i. Vendors > Invoices tab shows ‘Authorized By’ and Authorized Dt’ fields 

1. New fields ‘Authorized By’ and ‘Authorized Date’ are added in ‘Vendors > Invoices 
tab. 

2. On click of ‘Accept/Reject’ buttons, system stamps the user name and date in 
‘Authorized By’ and ‘Authorized Dt’ fields respectively. 

3. Once user clicks on record; status of record is set to ‘Accepted/Rejected’ and once 
user changes the status from ‘Approved’ to ‘Close’, system generates ‘Payment 
Requisition’ Record. 

 

2.53.3 Seed Data Changes 

SNO TABLE KEY DATA Type 

1 NA NA NA 
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2.54 Business Rules – Internal Work Orders 

2.54.1 Overview 

Business Rules Execution for ‘Internal’ work orders. 

2.54.2 Description 

I. Drop down at ‘Invoice Information’ block 

Dropdown is provided at ‘Invoice Information’ block to filter the records based on values selected in 
LOV (Earlier, these statuses was shown in ‘Radio Button’ for selection). 

II. Record Level Validation of invoices for ‘Internal’ work orders 

1. Validate Invoice button is available only for records with status = OPEN 

2. If user clicks on ‘Validate Invoice’ button, system does the following check before running business 
rules: 

a. On successful validation, system will run the business rules on selected work order. These 
business rules are similar to ‘Generic Recovery Interface’ business rules. 

b. If the validation is unsuccessful, then system will keep the Invoice status to ‘For Approval’ 

3. Accept/Reject buttons are shown in ‘Invoice Details’ block, where record status = ‘For Approval’. 

 

 

III. Added a new service status in ‘Vendor > Work orders> Services 

1. If the invoice payment schedule is in “Close” status in Invoices >Invoice Information 
>Payment Schedule 

2. Services Status will be changed based on work Order status in Vendors > Work 
Orders. 

2.54.3 Seed Data Changes 

SNO TABLE KEY DATA Type 

1 LOOKUPS VENDOR_ASG_STATUS_CD|P INSERT 

2 FLS_ACCESS FLL.CMN.UVN.VENDORINVOICEDETAIL.ACCEPT.BUTTON  INSERT 

3 FLS_ACCESS FLL.CMN.UVN.VENDORINVOICEDETAIL.REJECT.BUTTON  INSERT 

4 FLS_ACCESS FLL.CMN.UVN.VENDORINVOICE.VALIDATEINVOICE.BUTTON INSERT 
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2.55 ‘Recourse’ Enhancements 

2.55.1 Overview 

               ‘Dealer Recourse’ feature enhanced in OFSLL (Applicable for Loan & Lease) 

 To Capture Recourse details in origination 

 Add/Update recourse details in servicing stage. 

2.55.2 Description 

  Added “Recourse” check box and “Max Recourse %” fields to ‘Setup >Contract >Lease’. 

 Introduced ‘Recourse Details’ section in ‘Origination > Contract’ screen as shown in the 

figure below. 

 System allow user to input details in ‘Origination > Contract’, if ‘Recourse’ indicator is ‘Y’ in 

setup. 

 

I. Changes in  ‘Origination > Contract’ (Loan/Lease) 

 Introduced ‘Recourse Details’ section in ‘Origination > Contract’ screen as shown in the 

figure below. 

 System allow user to input details, if ‘Recourse’ indicator is ‘Y’ in setup. 

Verification Edit: 

A new verification EDIT is created to validate the following: 

 ‘Max Recourse %’ and ‘Recourse Flat Amount’, both can’t be greater than zero. 

 “Max Recourse %” can’t be more than 100%. 

 “Max Recourse %” can’t be more than the “Max %” value defined in setup> 

Contract >Loan/Lease. 

 Seed Data of this EDIT is set to ERROR. 

 

‘Recourse Details’ section is having following fields: 

 Recourse 

 Recourse Type 

 Recourse Reason 

 Recourse Max % 

 Recourse Amt 

 

‘Origination > Contract’ screen shot 

 

 

‘Origination > Contract (2)’-- (Loan Only) 
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 Removed ‘Recourse Details’ in ‘Origination > Contract (2)’ screen as shown in the figure 

below. 

‘Origination > Contract (2)’ screen shot 

 

II. Changes in  ‘Servicing’ (Loan/Lease) 

1. Recourse fields in Servicing> Account Details > Contract Information Tab & 

Account Details 

 Recourse information captured in Origination are propagated to Servicing > Account 

details > Contract information tab. 

 New set of fields are created – Recourse Type, Recourse Reason, and 

Recourse amount. 

 Recourse information captured in Origination are propagated to Servicing > Account 

details > Account Details tab. 

 New set of fields are created – Recourse, Recourse Type, Recourse 

Reason, Max Recourse % and Recourse Amount. 

 

 
2. Non-monetary Transaction for Recourse (Loan/Lease) 

Following non-monetary transaction introduced to change existing recourse information. 

 Recourse Maintenance (To change recourse parameters) 

Validations: 
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 If “Recourse Flat Amount” and “Max Recourse %” values greater than ZERO, system 

through error message - ‘Max Recourse %’ and ‘Recourse Flat Amount’, both can’t be 

greater than zero. 

Actions: 

 On successful posting of transaction, system generates comment with Alert flag = ‘Y’ 

 Message Format – Recourse preferences changed from ‘Partial’ to ‘Full’ or ‘Full to 

Partial’ (Depending upon value selected and changed in transaction). 

 User will be able to add/change ‘Recourse’ preference in servicing. Even if ‘Recourse’ 

is not selected at origination stage/ no recourse information on boarded to account 

servicing stage, still system allows posting of recourse at servicing stage. 

 

3. ‘Customer Service’ queue parameters are provided 

 Following recourse parameters are provided for queue building in customer service. 

 Recourse Type 

 Recourse Reason   

III. ‘Producer Level – Recourse transaction 

 Following recourse transactions are available under Producer > Transactions > others (radio 

button). 

i. Recourse Recovered From Dealer loss reserve 

Whenever user posts this transaction, system deducts the specified amount from dealer loss reserve. 

ii. Reverse Recourse Recovered From Dealer loss reserve  

Whenever user posts this transaction, system adjusts specified amount from dealer loss reserve. 
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2.56 Producer Payment Details Verification 

2.56.1 Overview 

Facility provided to ‘Approve’ payment details of producer. 

2.56.2 Description 

 A new button named ‘Approve Payment Detail’ and new fields (‘Approved By’, ‘Approved Date’ and 

‘Status’) were introduced in the ‘Producer  Producer Details  Payment Details’ tab 

 New fields in database are created – ‘Initiated By’ and ‘Initiated Dt’. Whenever user updates 

‘Producer Payment’ details, system stamps ‘Initiated By’ and ‘Initiated Dt’ on SAVE. 

Validations for ‘Verified Payment Record’ 

 On click of ‘Approve Payment Detail’ button, system stamps user name (logged in user) and Date 

(current system date) in above fields validating user id stored as ‘Maker’. 

• System validates that ‘Approved By’ is not same as value in ‘Initiated By’; else shows an 

error – Maker cannot verify record. 

• If mandatory fields are not filled and user tries to ‘Approve’ record; system shows error 

message ‘Required Information is missing to verify record’. 

Validation on edited ‘Verified Payment Record’  

 If user modifies any data in ‘Payment Detail’ block, on save – system removes ‘Approved By’ and 

‘Approved Dt’ data in screen. 

 System validates that ‘Approved By’ is not same as value in ‘Initiated By’; else shows an error – 

Maker cannot verify record. 

 On click of ‘Approve Payment Detail’, System validates that ‘Initiated By’ is not NULL; else shows 

error message. 

 Change in ACH Batch Job 

 Additional validation is added in Producer ACH batch job, where it refers ‘Status’ = APPROVED. 

 If these values are NULL or waiting for approval, ACH batch job does not pick the record for 

processing. 

 Existing validations related to ACH record pick will prevail. 

Showing ‘Producer Count by ACH Status’ in Producer Dashboard with a hyperlink  

Provided Producer Bank Details Counter in Dashboard > Producer Count By Waiting for Approval 

and Approved counters. 

 System shows ‘Status’ and ‘Count’ in new section 

 On click of ‘ACH Status’ hyperlink, system takes user to producer screen filtered 

with ‘Waiting for Approval’ or ‘Approved’. 

 

Impact on Existing Customers- Migrated Data 

For existing records of producers – ‘Initiated By, Initiated Date’ details captured in producers table are stamped for 

‘Payment Details’ – ‘Verified By, Verified Dt’. 

Note: Validation related to ‘Initiated By’ and ‘Verified By’ is not applicable for migrated data (being inserted to 

database) and the same is triggered from subsequent record edit. 
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2.56.3 Screenshot 

Producers > Payment Details > Approval Detail 

 

Dashboard > Producer >Producers Count By ACH Status 
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2.57 ‘Seed Data’ (Functionality) 

Seed data in general is referred to as any data delivered with the standard product installation 

and is required to be present in the production environment for application to work properly. 

Seed data basically consists of Table with its associated data that are uploaded into the 

system through DAT files. 

 
Seed Data screen in Oracle Financial Services Lending and Leasing displays the seed data 

details maintained in the system along with the updated seed data provided with the latest 

release or patch installation. 

 
Note that, when you upgrade OFSLL from an existing version to higher version, 

 New seed data provided as part of that release is automatically updated into the 
system. 

 Seed data which are modified from previous release to current release needs to be 
manually accepted and updated into the system. 

 
The modified seed data can have updates on base tables and/or its associated data and the 

changes can either be updated or skipped depending on the need. 
 

Navigating to Seed Data screen 

 
1.   Click Setup > Setup > Administration > System > Seed Data. The system displays the 

Seed Data screen. 
 

2.   On this screen you can do the following: 

 View the factory shipped seed data and update/skip the seed data differences between 
existing and updated seed data in ‘Factory Data’ tab. 

 View the customized (i.e. changed or configured) seed data as part of implementation 
in ‘Current Data’ tab. 

 View the differences between Factory data and Current data in ‘Comparison Data’ tab. 

 Download all or only the required table specific seed data in “Download Data’ tab. 

2.57.1 Factory Data 

The Factory Data tab displays the list of both existing and updated seed data which are 

provided though release/patch installation. In the Factory Data tab you can select and update 

only the required seed data changes into the respective seed data tables. During update, you 

can also skip the seed data changes for later updates (if required). 

 
Accordingly, you can sort the view in Factory Data tab by selecting ‘Skipped’, ‘Update’ or ‘All’ 
options to display the list of corresponding seed data. 

 
In the ‘Patch #’ drop-down list, you can further sort the list to display ‘ALL’ the seed data or 

only the additions or updates available as part of latest patch which has seed data changes. 
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To View Factory Data 

 
Click Setup > Setup > Administration > System > Seed Data > Factory Data tab. 
 

 
 
The ‘Factory Data’ section displays the list of seed data with the following details: 
 

Field View this: 

Table Displays the seed data table name. 

Type Displays the category of seed data as either System or 
Combination Data. 

Key Column Displays the unique identifier columns. 

Key Column Type Displays the unique identifier column data types. 

Other Columns Displays the non unique identifier column names. 

Other Column Types Displays the non unique identifier column data types. 

Count Displays the total count of updated records in the seed data 

table. 

 
The ‘Factory Data Details’ section displays the associated data of the selected seed data 

table along with the following details: 
 

Field View this: 

Key Column Data Displays the unique identifier column names. 

Other Column Data Displays the non unique identifier column names. 

Patch # Displays the patch number with which the seed data changes 

are identified. 
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Status Displays the current status of seed data as one 

of the following: 
 

INSERT: This status indicates new seed data. 
 

UPDATE: This status indicates if there are changes in 

the record when compared to the seed data released in 

previous patch. 
 

POSTED: This status indicates that the seed data 

changes are updated into the main tables and is 

subsequently updated from previous status - SKIPPED 

OR UPDATE OR INSERT. 
 

SKIPPED: This status indicates that the seed data 

is not updated into the main tables. 
 

DEPRECATED - This status indicates that the seed data 

is no longer used. 

 

 

 

 

 

 

In the ‘Factory Data’ tab, you can click refresh to fetch the latest details and click ‘View’ to 
display the detailed information of the selected record. 

2.57.2 Update/Skip Seed Data 

The ‘Update’ option in the Factory Data tab allows you to replace the existing seed data with the 
current update. However, ensure to double check the details before performing ‘Update’ 
operation since the same can have significant impact on system behaviour. 
 
To Update/Skip Data 

1. In the Factory Data’ tab, select ‘Update’. System displays those records which can 

be updated to the existing seed data tables. 

2. Inspect the required record in Factory Data section with the Factory Data Details 

in subsequent section. 

3. Select the required record to be updated by clicking on the adjacent check box. 

You can also click ‘Select All’ to select all the records. 

4. Do one of the following: 

– Click ‘Update Data’. This action updates the existing seed data with the 

updated seed data provided as part of the current patch release. 

– Click ‘Skip Data’. This action skips the seed data changes received as a part 

of the patch release. The skipped records can be viewed by selecting 

‘Skipped’ option in Factory Data tab. However, the same can further be 

updated into the system, by selecting ‘Update Data’. 

5. Click ‘Yes’ in confirmation dialog to confirm the setup data changes. 

 
On successful update, system does the following: 

 When individual records are selected and updated, the same is removed from 

Factory Data Details section and the ‘Count’ column in Factory Data section is 

updated with the remaining number of records. 

 In case of Bulk update, the record is removed from Factory Data tab. 

2.57.3 Current Data 

The Current data tab displays the customized seed data which are changed or 

configured as part of implementation. In the ‘Current Data’ tab, you can click ‘refresh’ to 

fetch the latest details and click ‘View’ to display the detailed information of the selected 

record.  

Additionally you can click “Refresh Data’ to pull the seed data details from the production 

system and update the current seed data tables. 
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To View Current Data 

Click Setup > Setup > Administration > System > Seed Data > Current Data tab. 

 

The ‘Current Data’ section displays the following details: 
 

Field View this: 

Table Displays the current seed data table name. 

Type Displays the category of seed data as either System or 

Combination Data. 

Key Column Displays the unique identifier columns. 

Key Column Type Displays the unique identifier column data types. 

Other Columns Displays the non unique identifier column names. 

Other Column Types Displays the non unique identifier column data types. 

Count Displays the total count of records in the seed data table. 

Last Refreshed Dt Displays the date and time when seed data for the selected 

table was last updated in the system. 

 

The subsequent ‘Current Data Details’ section displays the associated data of the selected 

seed data table along with the following details: 
 

Field View this: 

Key Column Data Displays the unique identifier column names. 

Other Column Data Displays the non unique identifier column names. 

2.57.4 Comparison Data 

The ‘Comparison Data’ tab displays the differences between factory shipped seed data and 

current customized seed data. 
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To View Comparison Data 

Click Setup > Setup > Administration > System > Seed Data > Comparison Data tab.

 

The ‘Comparison Data’ section displays the list of seed data records with the following details: 
 

Field View this: 

Table Displays the seed data table name to be inserted or updated. 

Type Displays the category of seed data as either System or 

Combination Data. 

Key Column Displays the unique identifier columns. 

Key Column Type Displays the unique identifier column data types. 

Other Columns Displays the non unique identifier column names. 

Other Column Types Displays the non unique identifier column data types. 

Count Displays the total count of records in the seed data table. 

 

The subsequent ‘Comparison Data Details’ section displays the associated data of the 

selected seed data table along with the following details: 
 

Field View this: 

Key Column Data Displays the unique identifier column names. 

Other Column Data Displays the non unique identifier column names. 

Patch # Displays the patch release version with which the seed data 

was inserted / updated. 

 

In the ‘Comparison Data’ tab, you can click   (refresh) to fetch the latest details and 

click ‘View’ to display the detailed information of the selected record.
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2.57.5 Download Data 

The Download Data tab allows you to download table specific seed data available in the 

system in ‘.dat’ format. While migrating from one environment to other, you can use the 

Download Data tab to download the existing seed data and perform a bulk upload of all/ 

required files. 

Similar to other file download process, based on the value defined for the system parameter 

‘CMN_FILE_PROCESS_TO_LOB’, the seed data download file can be accessed from the 

Process Files interface (if value is ‘Y’) or Database Files system (if value is ‘N’). For more 

information on handling Incoming/Outgoing process files, refer to ‘Dashboard’ section in User 

Guides. 
 

To Download Data 

1.   Click Setup > Setup > Administration > System > Seed Data > Download Data tab. 

 
 

The Download Data section displays the list of tables maintained in the system with ‘Table 

Name’ and ‘Table Type’. Click ‘refresh’ to fetch the latest details. 

 

2.   Select the check box adjacent to the required table in the list. You can choose ‘Select All’   
 check box to select all the tables with seed data maintained in the system. 
3.   Click ‘Submit For Download’ button. System displays an information message in the 

header indicating that the request has been submitted along with a reference number. 

The reference number is generated in format - useridDDMMHHMISS# followed by table 

name with ‘.dat’ extension. For example, (USER1230603121517#lookups.dat) 

4.   (Optional) If ‘CMN_FILE_PROCESS_TO_LOB’ is set to ‘Y’, navigate to DashBoard > 

Process Files screen > Outgoing Process File tab to download the selected seed data file 

which will be listed with the same reference number. The file can be downloaded to 

Application server. 

 

2.57.6 Seed Data 

SNO TABLE KEY DATA TYPE 

1 LOOKUP_TYPES SEED_DATA_STATUS_CD INSERT 

2 LOOKUPS SEED_DATA_STATUS_CD|D INSERT 

3 LOOKUPS SEED_DATA_STATUS_CD|I INSERT 

4 LOOKUPS SEED_DATA_STATUS_CD|P INSERT 

5 LOOKUPS SEED_DATA_STATUS_CD|S INSERT 
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6 LOOKUPS SEED_DATA_STATUS_CD|U INSERT 

7 FLS_ACCESS FLL.SET.UAD.SEEDDATASETUP.MENU INSERT 

8 FLS_ACCESS FLL.SET.UAD.FACTORYDATA.VIEW.BUTTON INSERT 

9 FLS_ACCESS FLL.SET.UAD.FACTORYDATADETAIL.INSERTDATA.BUTTON INSERT 

10 FLS_ACCESS FLL.SET.UAD.FACTORYDATADETAIL.SKIPDATA.BUTTON INSERT 

11 FLS_ACCESS FLL.SET.UAD.FACTORYDATADETAIL.UPDATEDATA.BUTTON INSERT 

12 FLS_ACCESS FLL.SET.UAD.FACTORYDATADETAIL.VIEW.BUTTON INSERT 

13 FLS_ACCESS FLL.SET.UAD.CURRENTDATA.REFRESHDATA.BUTTON INSERT 

14 FLS_ACCESS FLL.SET.UAD.CURRENTDATA.TAB INSERT 

15 FLS_ACCESS FLL.SET.UAD.CURRENTDATA.VIEW.BUTTON INSERT 

16 FLS_ACCESS FLL.SET.UAD.CURRENTDATADETAIL.VIEW.BUTTON INSERT 

17 FLS_ACCESS FLL.SET.UAD.COMPARISONDATA.TAB INSERT 

18 FLS_ACCESS FLL.SET.UAD.COMPARISONDATA.VIEW.BUTTON INSERT 

19 FLS_ACCESS FLL.SET.UAD.COMPARISONDATADETAIL.VIEW.BUTTON INSERT 
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2.58 Triggering the Job Requests from Application Server 

2.58.1 Description 

Today OFSLL have services (ex: Credit Bureau, Letters, etc.) initiated from database server. As part of this 
release, some of the services which are initiated from database server will be moved to Application Server. 
To reduce the load on database server and increase the performance of the system; “Credit Bureau Pulls”, 
“Letters” and “Correspondence” are now initiated from Application server.  

2.58.2 New Parameters 

 For Letters and correspondence which are initiated from Origination and Servicing will create a 
background job request. Once the Job Request is created then, system will process the request using  

o New System Parameter OUTBOUND_CALL_Q having ‘Yes or No’ value ( this can be 

configured under Setup > System > System Parameter) 

- If this parameter is set to ‘N’, system processes the generated job requests using 
Existing Flow. 

- If this parameter is set to ‘Y’, system processes the generated job requests using 
MDB Flow. 

 For Credit Bureau pull’s which are initiated from Origination and Servicing will create a background job 
request. Once the Job Request is created then, system will process the request using  

o New credit bureau parameter “OUTBOUND CALL INDICATOR FOR CREDIT BUREAU 
REQUEST” having ‘Yes or No’ value ( this can be configured under Setup > Credit Bureau > 

Parameters) 

- If this parameter is set to ‘N’, system processes the generated job requests using 
Existing Flow. 

- If this parameter is set to ‘Y’, system processes the generated job requests using 
MDB Flow. 

Please Note: Configuration required to setup this in Application Server is explained in Configure AQ-JMS 
Bridge. 

2.58.3 Seed Data 

SNO TABLE KEY DATA Type 

1 SYSTEM_PARAMETERS 
OUTBOUND_CALL_Q|SET_SYP_SYSTEM|ALL|ALL|ALL|
ALL|ALL|ALL|ALL 

INSERT 

2 
FLEX_TABLE_ATTRIBUT
ES 

SET_CRP_SERVICE|OUTBOUND_CALL_Q INSERT 

3 
FLEX_TABLE_ATTRIBUT
ES 

SET_SYP_SYSTEM|OUTBOUND_CALL_Q INSERT 

4 
CREDIT_BUREAU_PARA
METERS 

SET_CRP_SERVICE|OUTBOUND_CALL_Q|ALL|ALL INSERT 
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2.59 Facility to Open Multi-tab 

2.59.1 Overview 

 Facility to open multiple originations/ servicing/Collections tabs simultaneously. 

2.59.2 Description 

 In MENU_ACCESS table; enable 'Mac_Multi_tab_Ind' = ‘Y‘ for respective screens to enable multi tab 

access. Max 15 parallel tabs allowed. 

2.59.3 Screenshots 

Origination: 

 

Servicing:  
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2.60 New Credit Practices Late Fee Calculation Rule 

2.60.1 Description 

 At present OFSLL supports two types of late fee calculations – i.e. Pyramid Law based and Non-Pyramid 

law based. As part of this new Fee calculation methods called ‘Credit Practices Rule’ has been introduced i.e 

 Flat Amount Credit Practices rule 

 Percentage of Payment Due Credit Practices rule 

 Percentage of Standard Payment Credit Practices rule 

User can configure these new late fee Calculation Methods under ‘Setup >Products > Fees’ or ‘Setup > 

Products > Contract > Fees’ rules only if ‘Fee Type’ is ‘Fee Late Charge’. 

 

Whenever the user configured any of these late fee rules for the contract or at fee setup, while system runs 

TXNLTC_BJ_100_01 (LATE CHARGE PROCESSING) batch job on payment due date, system will not 

compute the late fee if the following criteria satisfies - 

 Total payment made (i.e. sum of all payments made from the due date to the expiration of the grace 

period) on the account as on due date is exactly same or more than the scheduled monthly payment 

amount and also within the payment tolerance and late charge grace days 

 No previous scheduled payments outstanding, however a previously assessed late fee is outstanding. 

 

In case of an account with last payment received is a past date, and irrespective of the current payment is 

partial or exactly equal to the monthly standard payment, system will assess the late fee. 

 

 Below table contains current Late Fee assessment behaviour based on the LF method selected as ‘Flat 
Amount’. 

Payment Due Date: 1st of Every Month, Flat Late Fee: 25 $ 

Payment Date Payment Amount Balance Amount Whether Late Fee is assessed 

11/01/2015 4,280.56 0 No 

12/15/2015 4,280.56 0 + 25 Yes 

01/01/2016 4,280.56 25 +  25 (New late fee) Yes  

 In the above table, please note (bolded portion) that system assessed a LF even though no previous 
scheduled payment is outstanding and current payment is made in full and exactly on the due date.  

 In the below table, highlighted portion shows the expected behaviour i.e. LF will not be assessed in this 
case because it is against the US regulation. 

Payment Date Payment Amount Balance Amount Whether Late Fee is assessed 

11/01/2015 4,280.56 0 No 

12/15/2015 4,280.56 0 + 25 Yes 

01/01/2016 4,280.56 25 No 

 

 When account receives any payment on or before the ‘Late Charge Grace’ days, then system will 
reverse the already posted late fee. 

 When user selects ‘FLAT AMOUNT CREDIT PRACTICES RULE’ 

o System will directly apply the late fee provided in the ‘Min Amt’ (Setup  Products 
Contract Fees Contract Fees  * Min Amt) field. 

 When user selects ‘PERCENTAGE OF PAYMENT DUE CREDIT PRACTICES RULE’ 

o System will compute the ‘Percentage’ provided on the Fee definition on ‘Total Outstanding Due 
Amount’  

 If computed amount is less than the ‘Min Amt’ then system will apply Minimum 
amount or 

 If computed amount is greater than ‘Max Amt’ system will apply the Maximum 
Amount. 

 When user selects ‘PERCENTAGE OF STANDARD PAYMENT CREDIT PRACTICES RULE’ 
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o System will compute the ‘Percentage’ provided on the Fee definition on ‘Latest Billed Amount’. 

  If computed amount is less than the ‘Min Amt’ then system will apply Minimum 
amount or  

 If computed amount is greater than ‘Max Amt’ then system will apply the Maximum 
Amount. 

 Late Fee can be configured under ‘Set up > Product > Fee’ or ‘Setup > Product > Contract > Fee’. 
System will give the preference to the ‘Contract > Fee’ and  if it is not available, system will apply fee 
configured at   ‘Set up > Product > Fee’ 

 

2.60.2 Screen shot        
    After implementing the changes, screen appearance is as below:  

 
2.60.3 Seed Data: 

SNO TABLE KEY DATA Type 

1 LOOKUPS 

FEE_CALC_METHOD_CD|LC_FLAT_AMT_CRED_P
RACTICE Insert 

2 
LOOKUPS 

FEE_CALC_METHOD_CD|LC_PCT_PMT_DUE_CRE
D_PRACTICE 

Insert 

3 
LOOKUPS 

FEE_CALC_METHOD_CD|LC_PCT_STD_PMT_CRE
D_PRACTICE 

Insert 
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3. Patches and Bugs 
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4. Security Fixes 

-NA- 
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5. Limitations and Open issues 

5.1 Limitations and open issues 

BugId Bug Description 
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6. Components of the Software 

6.1 Documents accompanying the software 

The various documents accompanying the software are as follows: 

 Release Note  

 Installer Kit 

 User Manuals and Installation manuals - These can be accessed from the link 

 http://docs.oracle.com/cd/E72985_01/homepage.htm 

6.2 Software Components 

Software Components of OFSLL 14.3.1.0.0 that form part of this release are as follows: 

 Core 

 UI Components Ear file ( JSF, XML, XLF) 

 Stored Procedures (Packages, Views, Java Stored procedures) 

 Reporting Components(Data models(xdm), Reports(xdo,  rtf)) 

 BIP / canned reports 

 Interface 

 Stored Procedures (Packages, Views, Types) 

 The WSDL files for the service supported 

 XSD Structure (dictionary) for the web service 

 Configuration files for the web service 

 Java classes for the web service 

 The service documents – describing the services 

 Installation utilities 

 Script based installation for Database components 

 Installation documents for Database, UI,  Web services 

 

http://docs.oracle.com/cd/E72985_01/homepage.htm
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7. Annexure – A: Environment Details 

Component 
Deploymen
t option 

Machine 
Operating 
System 

Software Version 

Oracle 
Financial 
Services Le
nding and 
Leasing 

Centralized 

Application 
server 

Oracle 

Enterprise 

Linux 6.7+ 

(64 Bit) and 
Sun 

SPARC  

with Oracle 
Solaris 11 

(64 Bit) 

Oracle Weblogic 
Enterprise 

Edition(Fusion 
Middleware 

Infrastructure installer 
– includes ADF and 

RCU) 

 

12.2.1.0.0 

Oracle Sun JDK 1.8.0_121 

Application 

Development 

Framework 

12.2.1.0.0 

Database 
Server 

Oracle 

Database 

Enterprise 

Edition 

12.1.0.2.0 

Reporting 
Server 

Oracle 

Business 

Intelligence 

Publisher 

12.2.1.0.0 

Client 
Machines 

Windows 7 

 

Internet Explorer 11.0 

Mozilla Firefox 36 

Google Chrome 49 

Apple Safari 8 

Note: Download and install the Merge Patch 25818409 available for ADF 12.2.1.0.0 on Oracle 

Weblogic Enterprise Edition 12.2.1.0.0 to support ADF customizations on EO/VO and diagnostic 

fix to reduce high CPU consumption. 

 

https://updates.oracle.com/Orion/Services/download/p25818409_122100_Generic.zip?aru=21159811&patch_file=p25818409_122100_Generic.zip
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8. Annexure – B: Third Party Software Details 

Licensor Name Licensed Technology Version 

Apache SOAP 2.3.1 

Jason Hunter & Brett McLaughlin JDOM 2.0.6 

Apache Ant 1.10.1 

 

9. Annexure – C: Module Code and Description 

Module Code Module Description 

ORG Origination  

CS Customer Service  

COL Collection  

CRB Credit Bureau 

ACX Account Boarding 

API Application Conversion Interface 

LN-CE Loan 

LN-OE Line 

LS-CE Lease 

TXN Transaction 

UIX User Interface 
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