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Supported coding dictionaries 
The Central Coding application supports: 

• Using the following industry-standard coding dictionaries. 

• MedDRA and MedDRA-J—Medical Dictionary for Regulatory Activities. 

• WHO-DD (C and C3 formats)—World Health Organization Drug Dictionary. 

When using WHO-DD you can configure the Central Coding application to autocode to the 
Trade Name (default) or to the Medicinal Product. With either configuration option, you can 
report (return) the Trade Name, Preferred Name, and Ingredients to the source application. 

• JDrug—Data File for Ethical Drugs (Coding Table) from Iyaku-Joho-Kenkyujo, Inc. 

• Using multiple standard and custom dictionaries, and using multiple versions of those 
dictionaries. 

For more information, contact Oracle Support. 
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Multilingual data 
The Central Coding application can accept both English and Japanese verbatims (multilingual data). 

• When you install the Central Coding application on an English operating system, you can choose 
whether to use multilingual data. 

• When you install the Central Coding application on a Japanese operating system, the installation 
program assumes that there will be multilingual data. 

If you choose to use multilingual data, the Central Coding installation program: 

• Loads the Japanese report templates. These reports contain the MS Mincho or MS UI Gothic 
font so that Japanese text appears correctly in the reports. These reports can contain both 
Japanese and English data. 

• Sets the default date format to YYYY/MON/DD HH24:MI:SS. In an environment with native 
authentication, you can modify this setting as needed on the System Configuration page. 

Note: You cannot perform an upgrade to support the Japanese language. 
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Japanese dictionary support 
The Central Coding application supports: 

• English and Japanese versions of the supported operating systems. 

This feature does not include localization. The Central Coding user interface is available only in 
English. 

• The MedDRA-J and JDrug (Data File for Ethical Drugs (Coding Table) from Iyaku-Joho-
Kenkyujo, Inc.) dictionaries. 

The Central Coding application supports data to be coded in any left to right language supported 
by MedDRA, WHO-DD, or JDrug.  

• Sorting and searching of the Japanese character sets. 

• Coding algorithms for the Japanese dictionaries. 

• Synonyms and autocoding for Japanese dictionaries are supported. 

• Stopwords for Japanese dictionaries are not supported because they are not used in the 
Japanese character sets. 

• Coding with both Japanese and English dictionaries in the same database and in the same study. 
 

Dictionary types and language packs 
A dictionary type file and a Japanese language pack are provided for each supported coding 
dictionary. For more information, see About dictionary types and dictionary schemas (on page 
53). 

A language pack displays the dictionary level names and additional information labels in the user 
interface in an alternate language. You install the language pack using the Dictionary Loader tool. For 
more information, see Installing the language packs for the Japanese dictionaries (on page 72). 
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Architectural overview 
The Central Coding software is built on a Microsoft .NET and Oracle Database platform. It uses 
web services over a network for the transmission of coding requests and responses, and uses Internet 
Information Services (IIS) to provide its web-based user interface to the coding team, so they can 
provide coding services through the Internet. 

The Central Coding software requires a database server and an application server. This architecture 
provides for flexibility and scalability, allowing you to configure the web server, application server, 
and database server layers independently. In all configurations, you access the Central Coding 
software on the application server through HTTP sessions from Windows clients using Internet 
Explorer or Mozilla Firefox. Each Central Coding application server runs on a Windows server, 
which uses the Oracle client with the Oracle Data Provider for .NET interface with an Oracle 
database server.  

• Central Coding and Clintrial integration—The two applications communicate through a web 
service that is configured using the Clintrial application. This integration does not require an 
adapter. For more information, see the Clintrial Admin and Design guide. 

The Clintrial application initiates all communication to and from the Central Coding application. 

• Central Coding and InForm integration—The Central Coding software uses the InForm 
Adapter software to control communication between Central Coding servers and InForm 
studies. 

The Central Coding application initiates all communication to and from the InForm application. 
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Physical configuration options 
• Central Coding and Clintrial integration—The Clintrial software is installed on a different 

machine than any of the Central Coding application servers. 

• Central Coding and InForm integration—The InForm software and the InForm Adapter 
software are installed on different machines than any of the Central Coding application servers. 
The InForm Adapter software can be installed on the same machine as the InForm software or 
on its own machine. 

 

Single application server configurations 
• The Central Coding application server and database server running on the same machine. 

• The Central Coding application server running on one machine and the database server running 
on a separate machine. 

In a production environment, Oracle recommends running the Central Coding application server 
and database server on separate machines. This configuration allows more flexibility, scalability, 
and performance; is easier to manage and troubleshoot; and is easier to expand in the future by 
adding additional application servers. 

 

Configurations with multiple Central Coding instances 
• Multiple Central Coding instances and the database server on the same machine. 

• Multiple Central Coding instances on one machine and the database server on a different 
machine. 

• Multiple Central Coding instances on different machines and the database server on a different 
machine. 

This configuration might be practical  if, for example, you use the Central Coding application 
across different geographic regions. 

You can configure application servers as logical entities, allowing multiple Central Coding instances 
to co-exist on the same machine. Central Coding instances can map to either: 

• Unique database instances, each of which has its own dictionaries. 

• A single database instance that shares dictionaries. 

In environments with multiple Central Coding instances, each instance has its own: 

• URL 

• Job scheduler 
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Deployment scenarios 

About integrating with the Clintrial or InForm application 
The Central Coding application supports integration with the InForm application and the Clintrial 
application at the same time under the following circumstances: 

• One of the following is true: 

• The InForm application, Clintrial application, and Central Coding application are behind the 
same firewall. 

• The InForm application, Clintrial application, and Central Coding application are not behind 
the same firewall, but a VPN is used between the Central Coding application and the 
Clintrial application. 

• The Clintrial software is installed on a different machine than any of the Central Coding 
application servers. 

• The InForm software and the InForm Adapter software are installed on different machines than 
any of the Central Coding application servers. The InForm Adapter software can be installed on 
the same machine as the InForm software or on its own machine. 

To determine the hardware and software requirements for using the Central Coding application with 
another application through the Services Interface (API), consult your Oracle Services representative. 
 

Central Coding and Clintrial application components 
The Central Coding and Clintrial applications must be hosted at the customer site behind the 
customer firewall. 
 

Central Coding and InForm application components 
The Central Coding application components can be deployed with or without enabling security. 
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All InForm and Central Coding components behind a firewall 

When integrating with the InForm application, the application servers for all the software 
components in the Central Coding environment can be behind a firewall. This is the typical scenario 
when Oracle hosts all the applications.  
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Central Coding server(s) outside a firewall 

When integrating with the InForm application, the application servers for the InForm and InForm 
Adapter software components can be behind a firewall, while the Central Coding server(s) are 
outside the firewall. This is the typical scenario when Oracle hosts the InForm servers and a 
customer hosts its own Central Coding application server(s). 
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About the Central Coding 3.1.0.1 release 
The Central Coding 3.1.0.1 release includes the following components: 

• Central Coding 3.1.0.1 product. 

• Central Coding 3.1.0.1 documentation. 

• InForm Adapter product and documentation. 

Before beginning the installation, check the Oracle Software Delivery Cloud 
(https://edelivery.oracle.com) for the latest patchsets and patches, as well as the accompanying 
Release Notes and Known Issues documents, and the latest versions of the documentation. 
 

InForm Adapter product and documentation 
To use the Central Coding software with the InForm application, the InForm Adapter software must 
also be installed and configured. For more information, see the InForm Adapter Installation Guide. 
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Prerequisites 

Set the regional language option on the client and application servers—English 
operating systems only 

Before performing a fresh installation on an English operating system, if you want to support both 
English and Japanese verbatims, you must set the regional language option on the client server(s) and 
the application server where you install the Central Coding software. 

1 Select Start > Settings > Control Panel > Regional and Language options. 

The Regional and Language Options dialog box appears. 

2 Click the Languages tab. 

3 In the Supplemental language support group, select Install files for East Asian languages, and click 
OK. 

 

Rename the dictionary file for the JDrug dictionary 
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you must rename the 
JDrug dictionary file so that the Dictionary Loader can recognize the file name and load the 
dictionary. 

• Rename, or copy and rename, the JDrug dictionary file ( ) to all_cases.txt. 

Note: Make sure that this file is in a local directory with only English names in its path. 

For instructions on loading the coding dictionaries, see Loading and managing the coding 
dictionaries (on page 51). 
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Checklist: Setup tasks for integrating the Central Coding and Clintrial 
applications 

 

Step Task For details, see... 
1 Install the Clintrial software. Clintrial Getting Started guide. 

Note: The Clintrial software is installed on a different 
machine than any of the Central Coding application 
servers. 

2 Configure network or Internet 
access to the Central Coding 
application server.  

Clintrial Getting Started guide. 

3 Configure the CC_HOST 
parameter with the HTTP address 
of the Central Coding interface. 

Clintrial Admin and Design guide. 

This may be set in the Clintrial Admin module as a 
System or Protocol parameter. 

4 Set the 
USE_CENTRAL_CODING 
parameter to Yes for the target 
protocol. 

Clintrial Admin and Design guide. 

This may be set in the Clintrial Admin module as a 
System or Protocol parameter. 

5 Create a new dictionary definition. Clintrial Manage, Classify and Lab Loader guide. 

6 Define labels for the dictionary 
definition.  

Clintrial Manage, Classify and Lab Loader guide. 

7 Select a dictionary definition for 
an item in a panel. 

Clintrial Admin and Design guide. 

8 Create a Central Coding encoding 
target.  

Clintrial Manage, Classify and Lab Loader guide. 

9 Map the target items with the 
defined labels. 

Clintrial Manage, Classify and Lab Loader guide. 

10 Use the Clintrial Manage module 
to send coding requests (define 
the delivery schedule) to the 
Central Coding application. 

Clintrial Admin and Design guide. 
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Checklist: Setup tasks for integrating the Central Coding and InForm 
applications 

 

Step Task For details, see... 
1 Install the Central Designer 

software. 
Central Designer Installation Guide. 

2 Install the InForm software on a 
different machine than the Central 
Coding application server. 

InForm Installation Guide. 

Note: Set up the InForm Adapter to accept data 
securely. 

3 On the InForm application server, 
install the InForm Adapter 
software with the Administration, 
Coding, and Discrepancy 
Enhanced interfaces. 

InForm Adapter Installation Guide. 

Note: Set up the InForm Adapter to accept data 
securely. 

4 On the InForm application server, 
install the InForm Server Adapter 
Interface (ISA). 

InForm Adapter Installation Guide. 

5 On the InForm Adapter server, 
register studies with InForm 
Adapter. 

InForm Adapter Installation Guide. 

6 Using the Central Designer and 
InForm applications, set up one or 
more InForm studies. 

Specify mappings and add InForm users for use with 
the Central Coding application. 

For integration with the InForm 5.0 release or later, see 
the InForm Study and Reporting Setup Guide. 

For integration with releases prior to the InForm 5.0 
release, see the InForm Installation and Configuration 
guide. 

For more information, see Checklist: Set up InForm 
studies for use with the Central Coding application 
(on page 16) and About mapping data for coding 
with the Central Coding application (on page 17). 
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Checklist: Set up InForm studies for use with the Central Coding 
application 

 

Step Task Description 

1 In the InForm application, specify 
a valid InForm user whose 
credentials can be used by the 
Central Coding application to 
access the InForm application. 

Required only if you are using user 
name/password authentication for 
communication with the InForm 
Adapter web services. 

Enter the InForm authentication user name and 
password in the Central Coding application:  

• On the System Configuration page (Get/Put Job 
Options section) to use for all studies. 

• On the [Study Name] Study Information page for 
any study, to define the user separately for that 
study. 

In addition, when you create a new InForm adapter, 
you must also select the option to Call InForm Adapter 
Web Services with User Name/Password 
Authentication on the [Adapter Name] page. 

2 In the Central Designer 
application, create a rule in the 
InForm application to clear the 
coding targets (optional). 

If the following key items are changed in the InForm 
application after a verbatim is coded, they will not be 
updated in the Central Coding application. To get the 
key items to be updated, you must create a rule in the 
InForm application to clear the coding targets. 

• SubjectInitials 

• SubjectNumber 

• Visit 

• Site Name 

• Site 

• Study 

Note: The key items are updated in the Central Coding 
application if the verbatim is not coded in the InForm 
application. 

3 In the Central Designer 
application, create the coding 
maps. 

Specify mapping definitions for controls that hold 
verbatim text and controls that hold the coded values 
assigned by the InForm application. 

For more information, see the Central Designer InForm 
Design Guide. 

Note: Oracle recommends that you do not modify 
coding maps after coding begins for the study. Doing 
so can slow the coding process. 
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About mapping InForm data for coding with the Central Coding application 
Use the Central Designer application to specify the InForm mapping definitions for controls that 
hold verbatim text and controls that hold the coded values. For more information, see the Central 
Designer InForm Design Guide. 

1 For each form that contains data to be coded, design controls to hold data as entered 
(verbatims), controls to hold coded data (code targets), items to hold query data (query targets), 
and if supported by the dictionary, controls to hold additional context information (context 
items).  

Verbatim, code target, query target, and context items must be: 

• In the same visit, if the visit is repeating. 

• On the same form, if the form is repeating. 

• In the same itemset, if the coded data appears in an itemset. 

• Different from each other. 

2 Create a mapping definition that specifies: 

• Each verbatim to be coded. 

• The dictionary used for coding. 

• Each code target to which the Central Coding application returns a coded value. 

• Each context item used to provide additional context data to the Central Coding application. 

• Each applicable verbatim type. 

• Each query target on which to place a query associated with the verbatim. The query target 
can be the verbatim item, or any other visible, editable item on the form. 

3 In a production study, use the Central Coding application to: 

a Export the verbatim and context data from the InForm application to the Central 
Coding application. 

b Code the data. 

c Import the coded data from the Central Coding application to the InForm application. 
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Overview of the Central Coding installation process 
Note: Before performing the tasks in the table, be sure you have met the requirements listed in 
the Prerequisites (on page 13). 

 

Step Task For details, see... 
1 Prepare the database and application 

servers, and the client computers. 
Preparing the Central Coding installation 
(on page 19). 

2 Install the Central Coding software. Installing the Central Coding software (on 
page 29). 

3 Load the coding dictionaries. Loading and managing the coding 
dictionaries (on page 51). 

4 Configure the Central Coding 
application. 

User Guide. 
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Install the Oracle software on the database server 
When the database server requirements are met, install the Oracle database software. For more 
information, see: 

• System Requirements in the Central Coding Release Notes. 

• Oracle installation documentation. 

Note: Oracle recommends that you configure both the application server and the database server 
to use the Coordinated Universal Time (UTC) time zone. In this way you can avoid any confusion in 
timestamp data in scenarios such as migration to a new database server that uses a different 
time zone. 

 

Mandatory database parameters 
Most of the default Oracle configuration parameters can be used for the Central Coding database. 
However, the following parameters must be set to the specified values. 

 

Parameter Value 
Database Character Set AL32UTF8 - Unicode UTF-8 Universal character set 

National Character Set AL16UTF16 - Unicode UTF-16 Universal character set 

db_cache_size 80 MB 

sga_max_size 1000 MB 

sga_target 600 MB (dependent on how much memory is available for 
Oracle)  

pga_aggregate_target 300 MB (dependent on how much memory is available for 
Oracle) 

BLOCK_SIZE Database: 16k   

Tablespace: 16k 

Note: Your database administrator should dynamically adjust the sga_target and 
pga_aggregate_target values using Oracle Enterprise Manager Advisors as the system grows. 

Note: Oracle recommends that the Oracle instance registry parameter ORA_*SID*_AUTOSTART 
be set to True. This ensures that Oracle is synchronized with the job scheduler, which is an auto-
started service. 
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Create the database and tablespaces 
After installing the Oracle software, create the database and tablespaces. The Central Coding 
application uses the Coding application and Coding platform tablespaces listed in the following table. 

• Note the names of the tablespaces you create. 

You need the names when you enter values for the database users during the Central Coding 
software installation.  

Each tablespace has one or more associated database users, which the installation wizard creates 
when you install a Central Coding application server. For more information, see Installing a 
Central Coding application server (on page 31). 

Note: For demonstration purposes in this guide, example names are provided for the 
recommended tablespaces, and for their associated database users and passwords. The 
same example name is used for both the user name and password. 

The Central Coding Database User name and the Coding Platform Database User name 
cannot be the same. 

The tablespace and user names are not case-sensitive. The passwords are case-sensitive. 

• The Coding application tablespace contains the coding dictionary database, which is created by 
the Dictionary Loader tool. For more information, see About the Dictionary Loader tool (on 
page 55). 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

 

Tablespace Size Contains Database user(s) 
Coding application 

Example name: 
CODING 

500 MB 

Auto extend 
enabled,  
10 MB 
increments. 

Central Coding 
application 

 

• Central Coding Database 
User 

Example name: cca 

Coding platform 

Example name: CCP 

100 MB 

Auto extend 
enabled,  
10 MB 
increments. 

Coding 
dictionaries 

• Coding Platform Database 
User 

Example name: 
codingplatform 

• Coding Dictionary Database 
User 

Example name: 
codingdictionaries 
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Verify the version of ASP.Net on the application server 
After completing the database installation, verify the version of ASP.Net on the application server. If 
the correct version of ASP.Net is not being used by the IIS Manager, you cannot view the login page 
for the Central Coding application. 

1 Select Start > Programs > Administrative Tools > Internet Information Services (IIS) Manager. 

The Internet Information Services (IIS) Manager dialog box appears. 

2 Select the server node > Sites > Default Web Site. 

3 Select Basic Settings under Actions. 

The Basic Settings dialog box appears. 

4 Make a note of the Application Pool value and close the dialog box. 

5 In the Connections pane, select Application Pools. 

6 Make sure the value 4.0 appears in the .NET Framework Version column for the application 
pool noted during step 4. 
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Install a certificate to secure internal communication with 
the Job Scheduler service 

On each Central Coding application server, an administrator must install the certificate that is used to 
secure communication with the Job Scheduler service.  

• The certificate must be installed to the LOCAL_MACHINE\MY store directory and made 
usable by the user who runs the ASP.NET worker process (by default, NETWORK SERVICE 
or IIS AppPool\Central Coding New Pool). You must also grant the NETWORK SERVICE 
and IIS AppPool\Central Coding New Pool users Full Control rights to the private key for the 
certificate. 

• The certificate and each certificate in the certification path must be 2048 bits or higher. 

To install the certificate: 

1 Open the Microsoft Management console: 

a Open a Command Prompt window. 

b Enter mmc. 

2 Select File > Add/Remove Snap-in. 

The Add or Remove Snap-ins dialog box appears. 

3 In the list of available snap-ins, select Certificates. 

4 Click Add. 

The Add dialog box appears. 

5 Click Computer account. 

6 Click Next.  

7 Click Local Computer. 

8 Click Finish. 

9 Click OK. 

10 In the Console Root tree of the Microsoft Management console, select Certificates (Local 
Computer). 

11 In the Logical Store Name field, right-click the Personal folder. 

12 Select All Tasks > Import. 

The Certificate Import Wizard appears. 

13 Click Next. 

14 Click Browse, and select the PFX file provided by the certificate vendor.  

15 At the prompt, enter the password for the PFX file. 

16 Click Next to accept the default options for the remaining dialog boxes. 

17 Click Finish. 

The new certificate appears in the displayed list.  

18 Right-click the certificate, and select All Tasks > Manage Private Keys. 
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19 Click Add > Locations, and then select the computer name. 

20 Give full control rights to the users NETWORK SERVICE and IIS AppPool\Central Coding 
New Pool. 

21 Click OK. 
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Enable TLS 1.2 
Oracle recommends that you configure the following security settings on the Central Coding 
application server: 

• Enable TLS 1.2 and higher. 

• Disable SSL 2.0, SSL 3.0, TLS 1.0, and TLS 1.1. 

If TLS 1.2 is enabled on the InForm Adapter computer or on the address translator (in a load-
balanced configuration, for example), you must enable TLS 1.2 on the Central Coding application 
server: 

• In HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols, 
create the following keys and subkeys: 

 

Key Subkey Entries 
SSL 2.0 

 

Client 

 

• DisabledByDefault=1 

• Enabled=0 

 Server • DisabledByDefault=1 

• Enabled=0 

SSL 3.0 Client • DisabledByDefault=1 

• Enabled=0 

 Server • DisabledByDefault=1 

• Enabled=0 

TLS 1.0 Client • DisabledByDefault=1 

• Enabled=0 

 Server • DisabledByDefault=1 

• Enabled=0 

TLS 1.1 Client • DisabledByDefault=1 

• Enabled=0 

 Server • DisabledByDefault=1 

• Enabled=0 

TLS 1.2 Client • DisabledByDefault=0 

• Enabled=1 

 Server • DisabledByDefault=0 

• Enabled=1 
 

• In HKLM\SOFTWARE\Microsoft\.NetFramework\v4.0.30319, create a key called 
SchUseStrongCrypto with the DWORD value=1. 
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Configure the web browsers on the client computers 

Browser settings for Internet Explorer 
Configure the following Internet Explorer settings to access the Central Coding application. 

• Configure pop-up blocking to allow pop-ups for the Central Coding website domain. 

• Prevent automatic password completion. 

• Automatically check for newer versions of stored pages. 

• Set the HTTP and TLS options to use HTTP 1.1 and TLS 1.2 and higher. 

• Disable the SSL settings. 

• Allow META REFRESH. 

• Enable active scripting. 

• Enable native XMLHTTP support. 

• Set up tabbed browsing to launch links in a new tab. 

For more information, see the Internet Explorer documentation. 
 

Browser settings for Mozilla Firefox 
Configure the following Firefox settings to access the Central Coding application. 

• Specify the preferred browser language. 

• Configure pop-up blocking to allow pop-ups for the Central Coding website domain. 

• Prevent Firefox from using stored passwords. 

• Set the security protocol option to use TLS 1.2 and higher. 

• Modify security settings to accept cookies. 

• Set up tabbed browsing to launch links in a new tab. 

For more information, see the Mozilla Firefox documentation. 
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Create database user accounts 
If you are performing a new Central Coding installation, Oracle recommends that a database 
administrator performs the following steps before the Central Coding application is installed: 

1 Download the Central Coding 3.1.0.1 ZIP file. 

2 Extract the ZIP contents. 

• To create the Central Coding Database User and Coding Platform Database User:  

a Open a Windows command prompt from the CodingDBSetup folder. 

b Enter the following command: 

sqlplus /nolog CodingDBSetup.sql 

c Enter the user account information when prompted. 

During the Central Coding installation, when configuring the two database user accounts, 
the system administrator can select the options to use existing users, and enter the 
credentials of the users created during this step. 

Note: If you create the Central Coding Database User and Coding Platform Database 
User during the installation, you must enter the Oracle SYS account password. 

• To create the Coding Dictionary Database Administrator User, run 
CreateDictAdminUser.sql located in the CodingDBSetup folder. 

In the Dictionary Loader tool, when performing certain operations, such as creating a 
dictionary repository or a dictionary, the dictionary administrator must enter the credentials 
of the user you created during this step. 
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Before you begin 
You can perform either a manual or a silent installation of the Central Coding software. 

Before you run the installation, make sure that: 

• The database instance is running.  

• All clocks are synchronized on the machines where you are installing the Central Coding 
software and the database server.  

The installation program verifies that the clocks are synchronized. If they are not synchronized, 
an error message appears. Installation cannot continue until the clocks are synchronized. 

Note: Oracle recommends that you configure both the application server and the database 
server to use the Coordinated Universal Time (UTC) time zone. In this way you can avoid any 
confusion in timestamp data in scenarios such as migration to a new database server that 
uses a different time zone. 

• The ASP.NET state service is started. 

• The job scheduler is turned off. 
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Interactive installation or upgrade 

Installing a Central Coding application server 
Use this procedure to install an instance of the Central Coding software. After you install one 
instance of the Central Coding software, you can run the installation program as many times as 
necessary to install additional instances. 

Perform this procedure on each application server. 

Note: This installation procedure requires that you enter the names of the database tablespaces 
and their associated database users and passwords. For demonstration purposes in this guide, 
example names for the tablespaces, users, and passwords are provided in this procedure in the 
appropriate steps. For more information, see Create the database and tablespaces (on page 21). 

Caution: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

 

Configure application settings 
1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

• If you are installing the Central Coding application for the first time, the Welcome page 
appears. 

• If you have already installed an instance of the Central Coding application, the Existing 
Installed Instances Detected page appears. 

• Select Install a new instance of this application, and click Next. 

The Welcome page appears. 

3 Click Next. 

The page that appears depends on the operating system.  

• If you are performing a fresh installation on a Japanese operating system, the Required 
System Components page appears. Proceed to step 5. 

• If you are performing a fresh installation on an English operating system, the Determine 
Database Sort page appears. 

Use this page to specify the locale, which determines the correct linguistic sorting in the 
database. The choice affects the language of verbatims that can be supported, the default 
date format, and which report templates are installed. 

4 Select the locale. 

• English—Sets the default database sort group to English. The English option maps to the 
Binary Oracle sort value. 

Select this option to: 



Chapter 4  Installing the Central Coding software  
 

32 Oracle® Health Sciences Central Coding 3.1.0.1 

• Support only English verbatims. 

• Set the default date format to DD/MON/YYYY HH24:MI:SS. 

• Load the English report templates. The reports can contain only English data. 

• European—Sets the default database sort group to WesternEuropean. The European 
option supports more character sets than the English option. It maps to the Generic_M 
Oracle sort value, which generally handles the order of the Latin, Cyrillic, Greek, and other 
European characters. 

Select this option to: 

• Support only English verbatims. 

• Set the default date format to DD/MON/YYYY HH24:MI:SS. 

• Load the English report templates. The reports can contain only English data. 

• Global—Sets the default database sort group to JapaneseWesternEuropean. The Global 
option maps to the Japanese_M Oracle sort value. 

Select this option: 

• If you are using an English operating system and you want to support both English and 
Japanese verbatims, or if you are using a Japanese operating system.  

• To set the default date format to YYYY/MON/DD HH24:MI:SS. 

• To load the Japanese report templates. The reports can contain both Japanese and 
English data. 

Note: For the best performance, Oracle recommends that you select Global only if you 
are working with Japanese studies. 

5 Click Next. 

The Required System Components page appears. The installation wizard verifies that the server 
has all the necessary software components, including the operating system, IIS, .NET, and the 
Oracle client.  

If required components are missing or are the wrong version, installation stops. The missing and 
invalid components are listed on the Required System Components page. You must install them 
before continuing the installation. 

6 Click Next. 

The Company Information page appears. 

7 Enter the following information: 

• Company name—Name of the company licensed to use the software. 

The company name may include any characters. This is informational only. 

• Company URL—URL that is unique to the company. 

This is used to define the security domain in inter-product communication. The Company 
URL: 

• Must be in English. 

• Must follow the proper URL convention and be in valid URL (ASCII) narrow 
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characters. 

The URL does not need to point to an actual running website or service. 

• Should not begin with a protocol designation such as http://.  

For example, www.oracle.com. 

8 Click Next. 

The Select Features page appears. 

9 Select the features to install. At least one feature must be selected in order to continue with the 
installation. If you select only the Dictionary Loader tool, the installation program skips to the 
end of the wizard. 

• Central Coding Server. 

• Dictionary Loader. 

The Dictionary Loader tool must be installed in order to load standard and custom 
dictionaries. However, the Dictionary Loader tool: 

• Does not need to be installed on every machine or on every application server.  

• Can be on a different machine from the Central Coding application server(s). 

• Can be installed without also installing the Central Coding Server. 

If you want to verify whether the Dictionary Loader tool is installed, select Start Menu > 
Programs > Phase Forward > Central Coding. If Dictionary Loader appears, it is already 
installed. 

10 Click Next. 

The Authentication Scheme page appears. 

11 Select Native Authentication, and click Next. 

Note: Trust Authentication is available only for Oracle-hosted installations. 

 

Configure the application instance 
On the Application Instance Settings page, you enter the instance name and job scheduler port 
number. From the instance name, the installer derives the virtual directories and job scheduler service 
name. The port must be numeric and should designate a port that is currently open and will be 
reserved for only this service. The installation program attempts to select a port that has not been 
used by a prior run of the installation. 

1 Enter the following information: 

• Instance Name—Unique string identifier for this instance. The Instance Name derives 
names for the various services. 

• Do not use special characters and make sure that there are no spaces in the name. 

• If you plan to have multiple application servers, consider using a naming convention for 
the names that allows you to easily identify each instance. 

• TCP port—Port through which the job scheduler communicates on this Central Coding 
application server.  
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• The Central Coding software reserves the range 14000 through 14100 by convention, 
although it can be any open port. 

• Each instance must be assigned a different open port.  

• The installation program defaults to a unique number for each instance being installed, 
starting in the conventional range, but not limited to it. 

The following information is automatically populated: 

• Service name—Job scheduler Windows service name for this Central Coding instance. By 
default, this is set to Central Coding Job Scheduler. 

This must be a unique name across multiple instances so that the services can be 
distinguished from one another. The installation appends the instance name to the service 
name. 

• Application URL—URL for the application server. 

• Application Server—Name of the virtual directory under which the application is published 
in IIS. 

The installation appends the instance name to this name. 

• Coding Service Virtual Directory—Unique name for the application server you are 
creating. 

The installation appends the instance name to this name. 

• Secure Coding Service Virtual Directory. 

• Platform Service Virtual Directory—Unique name for the platform you are creating for 
this application server. 

The installation appends the instance name to this name. 

• Job Service Host Name—Machine name of the host. The default is localhost. 

2 Click Next. 

The Choose Destination Location page appears. 

3 Specify where on the local file system to install the instance of the application. 

By default, the installation wizard installs the Central Coding software in C:\Program Files (on 
32-bit operating systems) or C:\Program Files (x86) (on 64-bit operating systems) in the \Phase 
Forward\Central Coding Application folder. However, you can click Change and navigate to 
another location. The folder must not be the same as any other installed instance. 

Note: The instructions, paths, and Start Menu navigation in this guide assume you are 
installing to the default location. Oracle strongly recommends that you install the software 
to the default directory. If you select a different location, the uninstaller might not remove 
all related files during the uninstall process. 

4 Click Next. 
 

Configure the Central Coding database user 
On the Central Coding Database User page, you create or select an existing user for the Central 
Coding database. To create a new user, you must enter the connection string and the password for 
the Oracle SYS user account; the database user and password; and the default tablespace for the 
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Central Coding application. 

The installation program detects the Oracle home location, finds all currently configured connection 
strings, and presents them in a list. Instead of typing in the connection string, you pick it from the 
list. 

Note: If the connection string that you want to use is not in the list, it means the connection has 
not been set up. 

Select or enter the following information for the Central Coding Database User, and then click 
Next. 

• Connection string—TNS name to use when connecting to the database. 

Note: To receive the best performance, Oracle recommends that you specify different 
connection strings for the Central Coding Database User, the Coding Platform Database 
User, and the Coding Dictionary Database User. 

• Create/Recreate User—Select to create a new Central Coding Database User. Select this 
option only if a database administrator did not create the user before the installation. For more 
information, see Create database user accounts (on page 27). 

If you choose to create a new user, you must also enter data for the default tablespace. If the 
Create/Recreate User option is selected and an existing user is supplied, that user will be 
dropped and re-created. 

• SYS User Password—Password for the Oracle SYS account. 

• Test Connection—Click to attempt an actual database connection using the selected 
Connection string and SYS User Password. You can continue with the installation only 
after the connection test succeeds.  

• Default tablespace—Select the name that was created for the Central Coding application. 

This list is populated from the database. For the example in this guide, that name is 
CODING. For more information, see Create the database and tablespaces (on page 21). 

• Create—Click to create a new tablespace. 

The Create New Default Tablespace dialog box appears. In the Name field, enter a name for 
the tablespace, and click Create. The dialog box closes and the name of the newly created 
tablespace appears in the Default tablespace field on the Central Coding Database User 
page. 

Note: The tablespace that is created is the default size and in the default location. If 
you want the tablespace to be a different size or in a different location, you must 
create the tablespace from the database. 

• User Name—Oracle user account name.  

The Central Coding Database User name and the Coding Platform Database User name 
cannot be the same. 

• Password, Retype Password—Password for the Oracle user account. 

The password must contain: 
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• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

Note: Do not use Oracle reserved words for the user name or password. 

• Existing User—Select if the user was created before the installation, or to reuse an existing 
user. In this case, the database is assumed to be present already, and the specified user is not 
dropped. You can test a connection with this user before proceeding. 

• User Name—Oracle user account name. The list is populated with users from the database. 

• Password—Password for the Oracle user account. 

• Test User—Click to test the database connection with this user. 
 

Configure the Coding Platform database user 
On the Central Coding Platform Database User page, you create or select an existing user for the 
Central Coding Platform database. To create a new user, you must enter the connection string and 
the password for the Oracle SYS user account; the database user and password; and the default 
tablespace for the Central Coding Platform. 

Select or enter the following information for the Coding Platform Database User, and then click 
Next. 

• Connection string—The TNS name to use when connecting to the Platform database. 

• Create/Recreate User—Select to create a new Coding Platform Database User. Select this 
option only if a database administrator did not create the user before the installation. For more 
information, see Create database user accounts (on page 27). 

If you choose to create a new user, you must also enter data for the default tablespace. If the 
Create/Recreate User option is selected and an existing user is supplied, that user will be 
dropped and re-created. 

• SYS User Password—The password for the Oracle SYS account. 

• Default tablespace—Select the name that was created for the Central Coding application. 

This list is populated from the database. For the example in this guide, that name is CCP. 
For more information, see Create the database and tablespaces (on page 21). 

• Create—Click to create a new tablespace. 

The Create New Default Tablespace dialog box appears. In the Name field, enter a name for 
the tablespace and click Create. The dialog box closes and the name of the newly created 
tablespace appears in the Default tablespace field. 

Note: The tablespace that is created is the default size and in the default location. If 
you want the tablespace to be a different size or in a different location, you must 
create the tablespace from the database. 

• User Name—The Oracle user account (Example name: codingplatform). 
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The Central Coding Database User name and the Coding Platform Database User name 
cannot be the same. 

• Password, Retype Password—The password for the Oracle user account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

• Existing User—Select if you created the user before the installation, or to reuse an existing 
user. In this case, the database is assumed to be present already, and the specified user is not 
dropped. You can test a connection with this user before proceeding. 

• User Name—The Oracle user account name. The list is populated with users from the 
database. 

• Password—The password for the Oracle user account 

• Test User—Click to test the database connection with this user. 
 

Configure the Coding Dictionary database user 
On the Create Coding Dictionary Database User page, you enter the user and password that the 
Central Coding application will use to connect to the dictionary database. This user is not dropped or 
created, and does not have to exist at the time of the installation. You create the dictionary database 
using the Dictionary Loader tool. For more information, see Setting up the dictionary database 
(on page 56). 

Enter the following information, and then click Next. 

• Connection string—The TNS name to use when connecting to the dictionary database. 

Note: To receive the best performance, Oracle recommends that you specify different 
connection strings for the Central Coding Database User, the Coding Platform Database 
User, and the Coding Dictionary Database User. 

• User—The name of the user account for the dictionaries (Example name: codingdictionaries). 

• Password, Retype Password—The password for the user account for the dictionaries. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

Note: Make a note of these values. You must use them when you create the repository for the 
dictionaries and when you connect to the database. For more information, see Creating a 
dictionary repository (on page 56) and Creating a connection to the database (on page 57). 
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Complete the installation 
1 On the Create Coding Administrator Account page, enter the following information, and click 

Next. 

• User—The name of the initial user account for the Central Coding application. 

• Password—The password for the initial user account. 

The password must contain: 

• One or more alphabetical (A-Z, a-z) and numeric (0-9) characters. 

• At least one non-alphanumeric character. 

• One or more upper case (A-Z) and lower case (a-z) characters. 

• A minimum of 8 characters. 

• Retype password—The password for the initial user account. 

2 Click Choose Certificate. 

A list of X.509 certificates on the machine appears in a new window.  

Note: The certificate is for internal communication only, and must already be installed. For 
more information, see Install a certificate to secure internal communication with the Job 
Scheduler service (on page 23). 

3 Select the certificate to use, and click OK. 

The certificate properties appear on the page. 

4 Click Next. 

The Ready to Install the Program page appears. 

5 Click Install. 

After the installation completes, the Central Coding Installation Wizard Complete page appears. 

6 Click Finish. 
 

Modifying an existing Central Coding application server installation of the same 
version 

Use this procedure to change the feature(s) of the same version of the software that you installed on 
an application server. The combination of features includes: 

• Central Coding Server. 

• Dictionary Loader. 

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 
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4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Modify, and click Next.  

The Select Features page appears. 

6 To modify an application server installation, select the features to change: 

• Central Coding Server. 

• Dictionary Loader. 

The Dictionary Loader tool must be installed in order to load standard and custom 
dictionaries. However, the Dictionary Loader tool: 

• Does not need to be installed on every machine or on every application server.  

• Can be on a different machine from the Central Coding application server(s). 

• Can be installed without also installing the Central Coding Server. 

To verify whether the Dictionary Loader tool is installed, from the Start Menu, select Programs > 
Phase Forward > Central Coding. If Dictionary Loader appears, it is already installed. 

7 Select the features to install, deselect the features to uninstall, and click Next. 

The files are updated and the Maintenance Complete page appears. 

8 Click Finish. 
 

Performing an in-place upgrade to the Central Coding 3.1.0.1 software 
Use this procedure to update the Central Coding software to the current version. The installation 
program verifies the components that are currently installed on your system and prompts you to 
update the existing application instance. 

Note: You can upgrade to the current release from the Central Coding 3.0.3.1, 3.0.4, or 3.1 
releases. If you are using an earlier version of the Central Coding software, you must first upgrade 
to the 3.0.3.1, 3.0.4, or 3.1 release on an English operating system. You cannot perform an 
upgrade to support the Japanese language. To accommodate multilingual studies, you must do a 
complete install of the Central Coding software. 

1 If the Central Coding job scheduler service is running, stop the service.  

2 Reset IIS, and restart the World Wide Web Publishing Service. 

3 Back up the coding database (all schema owners defined for the Central Coding application). 

Oracle recommends that you run a full export of the Central Coding database. 

4 Back up the Central Coding installation directory.  

This creates backup copies of all CONFIG files and can provide information about the Central 
Coding configuration before the upgrade. 

5 Make sure that the Central Coding release 3.0.3.1, 3.0.4, or 3.1 software is installed. 

6 Download the Central Coding 3.1.0.1 ZIP file. 

7 Distribute the Central Coding 3.1.0.1 ZIP file to every machine where you installed the Central 
Coding software and extract the ZIP contents. 
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8 Locate setup.exe. 

9 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

10 Select Maintain or update the instance of this application selected below. 

When an existing instance is selected, the installation program enters the upgrade mode. Details 
about the existing instance are read from the instance itself, so that you do not need to supply 
information again. The installation program: 

• Verifies the updated software prerequisites. 

• Copies over all assemblies and relevant files with the new versions, except for configuration 
files that have been modified since the previous installation. 

• Updates the configuration and database. 

11 Select the application server to upgrade, and click Next. 

The Welcome page appears. 

12 Click Next. 

The Required System Components page appears. 

13 Click Next. 

The Authentication Scheme page appears. 

14 Select Native Authentication, and click Next. 

The Choose Certificate page appears. 

15 Click Choose Certificate. 

A list of X.509 certificates on the machine appears in a new window.  

Note: The certificate is for internal communication only, and must already be installed. For 
more information, see Install a certificate to secure internal communication with the Job 
Scheduler service (on page 23). 

16 Select the certificate to use, and click OK. 

The certificate properties appear on the page. 

17 Click Next. 

The Setup Status page appears. When the setup is complete, a command prompt window opens 
that displays the upgrade steps as they occur. When the upgrade is complete, the command 
prompt window closes and the Central Coding Update Wizard Complete page appears. 

18 Click Finish. 

Note: The upgrade may delete the connections that were defined for the dictionary 
repository. After the upgrade is complete, you can restore the connections using the 
previous user information, and the dictionary repository objects will be available again. For 
more information, see Creating a connection to the database (on page 57). 

19 Clear the browser's cache on your local machine. 
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In Internet Explorer: 

a Click Tools > Internet Options. 

The Internet Options dialog box appears. 

b In the Browsing history section, click Delete. 

The Delete Browsing History dialog box appears. 

c In the Temporary Internet Files section, click Delete files. 

In Mozilla Firefox: 

d Click the menu button, and then select Options. 

e Select Advanced > Network. 

f In the Cached Web Content section, click Clear Now. 

20 Optionally, before starting the job scheduler, specify the length of time that you want entries in 
the job log to remain in the Central Coding database. 

The PhaseForward.Platform.JobScheduler.exe.config file includes a job entry that manages 
the size of the job log table in the database for scheduled jobs.  

The job runs daily and by default deletes entries that are 45 days old. If you want to keep entries 
in the job log for a different amount of time you must edit the file. The file is in <Installation 
Folder>\CentralCodingServer\CodingWebUI\bin. 

 

Migrating an existing installation to a new application server 
Use this procedure to migrate a Central Coding installation from an older release running on a 32-bit 
server to the current release running on a 64-bit server: 

1 Prepare the new server.  

For more information, see: 

• System Requirements in the Release Notes. 

• Preparing the Central Coding installation (on page 19). 

2 Central Coding 3.1.0.1 supports Oracle 11.2.0.4 and higher. If necessary, upgrade the Oracle 
database software, or migrate it to a new database server. 

3 On the old application server, upgrade the Central Coding application to release 3.1.0.1. 

4 On the old application server, disable all jobs. 

5 If you are migrating to a new database server, on the old database server, export the schema files 
for the Coding, Platform and Dictionary database users. 

6 On the new database server, import the schema files exported during the previous step. 

7 Install the Central Coding application on the new server. During the installation, select the 
options for using the existing Coding, Platform, and Dictionary Database users. For more 
information, see Installing a Central Coding application server (on page 31). 

8 Make sure jobs are running on the new application server. 

9 Uninstall the Central Coding application from the old server. 
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Silent installation or upgrade 

Performing a silent installation 
After you install one instance of the Central Coding software, you can run the silent installation as 
many times as necessary to install additional instances. To perform a silent installation of the Central 
Coding software: 

1 Modify the response file. 

For more information, see Modifying the response file (on page 42). 

2 Run the installation from the command line. 

For more information, see Running the installation (on page 44). 
 

Modifying the response file 
Perform this procedure on each application server. 

Note: All entries used as Oracle database objects (such as user names, passwords, and 
tablespaces) should follow Oracle recommendations for naming conventions. In addition, Oracle 
recommends using strong passwords, as described in the Secure Configuration Guide. 

1 Copy the Central Coding installation folder to your local machine. 

2 Locate the setup.iss response file. 

3 Save the setup.iss response file with a different name.  

Note: Oracle recommends saving the response file with a name that references the Central 
Coding instance with which it is associated. 

4 Modify the response file with the following information: 
 

Parameter Description 
svLanguage Locale: 

• English 

• Western European 

• JapaneseWesternEuropean 

szCompanyName Company name. 

szCompanyURL Company URL. 

szDir 

(First) 

Base installation directory. 

This should match the information you specify in the parameter for 
the Central Coding instance directory. 

svAuthChoice Authentication scheme used.  

This must be NATIVE for self-hosted installations. 
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Parameter Description 
instanceName Instance name. 

svPort Job Scheduler communication port number. 

This must be an empty port that has not been used by any other 
software. 

szDir 

(Second) 

Directory for the Central Coding instance.  

This should match the information you specified in the installation 
directory parameter. 

Central Coding Database 
user parameters 

 

svDBServer Database server connection string for the Central Coding Database 
user. 

svOracleSysPassword Oracle system password. 

This must be entered only if svCreateUser is TRUE. 

svdbUID Central Coding Database user ID. 

svdbPID Central Coding Database user password. 

svDBTablespace Name of the tablespace for the Central Coding database. 

svCreateUser Controls whether the user specified by svdbUID is created (TRUE), 
or if an existing user identified by svdbUID will be reused (FALSE). 

Platform Database user 
parameters 

 

svDBServer Database server connection string for the Platform Database user. 

svOracleSysPassword Oracle system password. 

This must be entered only if svCreateUser is TRUE. 

svdbUID Platform Database user ID. 

svdbPID Platform Database user password. 

svDBTablespace Name of the tablespace for the Platform database. 

svCreateUser Controls whether the user specified by svdbUID is created (TRUE), 
or if an existing user identified by svdbUID will be reused (FALSE). 

Dictionary Database user 
parameters 

 

svDBServer Database server connection string for the Dictionary Database user. 

svdbUID Dictionary Database user ID. 

svdbPID Dictionary Database user password. 

Certificate parameters  
svCertSubject Certificate subject. 
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Parameter Description 
svCertIssuer Certificate issuer. 

svCertName Certificate name. 

svCertExpiration Certificate expiration date, in the format MM/DD/YYYY H:MM:SS 
AM/PM. 

svCertThumbprint Certificate thumbprint. 

Note: Make sure there are no spaces in the value of the parameter. 
 

 

Running the installation 
1 Open a Command Prompt window and navigate to the installation folder on your local machine. 

2 Run the following command: 

...setup.exe -s -f1"[Location of response file]\[Response file name]" -f2"[Location of log file]\[Log file 
name]" 

In the command syntax: 

• Location of response file—The directory where the response file you modified exists. 

• Response file name—The name you gave the response file to use during the silent 
installation. 

• Location of log file—The directory where you want the log file to be created. 

Note: Make sure the directory exists; otherwise the installation fails. 

• Log file name—The name to give the log file. 

Note: The log file is automatically created during the installation. 

3 After you run the silent installation, Oracle recommends that you check the log file to ensure 
that the installation was successful. For more information, see Checking the log file (on page 
46). 

 

Performing a silent upgrade 
Use this procedure to update the Central Coding software to the current version. The installation 
program verifies the components that are currently installed on your system and prompts you to 
update the existing application instance. 

Note: You can upgrade to the current release from the Central Coding 3.0.3.1, 3.0.4, or 3.1 
releases. If you are using an earlier version of the Central Coding software, you must first upgrade 
to the 3.0.3.1, 3.0.4, or 3.1 release on an English operating system. You cannot perform an 
upgrade to support the Japanese language. To accommodate multilingual studies, you must do a 
complete install of the Central Coding software. 

1 Make sure that the Central Coding release 3.0.3.1, 3.0.4, or 3.1 software is installed. 

2 Download the Central Coding 3.1.0.1 ZIP file. 
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3 Distribute the Central Coding 3.1.0.1 ZIP file to every machine where you installed the Central 
Coding software and extract the ZIP contents. 

4 If the Central Coding job scheduler service is running, stop the service.  

5 Reset IIS, and restart the World Wide Web Publishing Service. 

6 Back up the coding database (all schema owners defined for the Central Coding application). 

Oracle recommends that you run a full export of the Central Coding database. 

7 Back up the Central Coding installation directory.  

This creates backup copies of all CONFIG files and can provide information about the Central 
Coding configuration before the upgrade. 

8 Navigate to the installation folder. 

9 Locate the upgrade.iss response file and open it with any text editor. 

a Locate the Job Scheduler certificate parameters (svCertSubject, svCertIssuer, svCertName, 
svCertExpiration, svCertThumbprint) and enter a value for each parameter to match with 
the value in the authentication certificate.  

If the value for a parameter is empty, set its value in the response file to ' ' (a single blank 
character enclosed in single quotes). 

b Save and close the file. 

10 In order to successfully run the silent upgrade, you need to know the GUID for the existing 
instance of the Central Coding application that you are upgrading. To find this information: 

a Click Start > Run. 

The Run dialog box appears. 

b Enter regedit. 

The Registry Editor dialog box appears. 

c Expand the HKEY_LOCAL_MACHINE/SOFTWARE/PHASEFORWARD node. 

d Locate the instance of the Central Coding application that you are upgrading. 

e Copy the GUID information into a text file so that you can easily copy and paste it into the 
command line during the upgrade. 

11 Open a Command Prompt window and navigate to the installation folder on your local machine. 

12 Run the following command: 

...setup.exe –s –ig"[Central Coding instance GUID]" -f1"[Location of upgrade response file]\[Response 
file name]" -f2"[Location of the log file]\[Log file name]" 

In the command syntax: 

• Central Coding instance GUID—GUID for the Central Coding instance to upgrade. The 
GUID must be enclosed in curly braces, for example {94EFC52F-AAFF-41BD-9A11-
7A5FA3FAA763}. 

• Location of response file—The directory containing the modified upgrade response file. 

• Response file name—The name of the upgrade response file. 

• Location of log file—The directory in which to create the upgrade log file. 
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Note: Make sure the directory exists, otherwise the installation fails. 

• Log file name—The name to give the upgrade log file. 

Note: The upgrade log file is automatically created during the installation. 

For example, a silent install upgrade command, that is run from the C:\TEMP folder, might look 
like the following: 

C:\TEMP\setup –s –ig"{94EFC52F-AAFF-41BD-9A11-7A5FA3FAA763}" -f1"C:\TEMP\upgrade.iss" 
-f2"C:\TEMP\upgrade.log" 

13 Clear the browser's cache on your local machine. 

a Click Tools > Internet Options. 

The Internet Options dialog box appears. 

b In the Browsing history section, click Delete. 

The Delete Browsing History dialog box appears. 

c In the Temporary Internet Files section, click Delete files. 

14 After you run the silent upgrade, Oracle recommends that you check the error log to ensure that 
the upgrade was successful. For more information, see Checking the log file (on page 46). 

 

Checking the log file 
1 Navigate to the directory in which the response file that you modified exists. 

2 Open the log file with the name you specified during the installation. 

• For successful installations, the log file includes ResultCode=0. 

• For unsuccessful installations, the ResultCode field is populated with a number that specifies 
the type of error that occurred during the installation. 

Note: The error codes in the log file are created by InstallShield. If an error occurs during the 
installation, contact Oracle for details. 
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Verify the installation 
After the application server is created, do the following to verify that the installation was successful: 

• Review the setup log. 

This log contains messages the system generated during the installation. It is available in 
<Installation Folder>\CentralCodingServer\Setuplog.txt. 

If the following message appears in Setuplog.txt it indicates that the block size of the tablespace 
for the Central Coding user is not large enough. For more information, see Mandatory 
database parameters (on page 20). 

      
create index CCA_FLAT_LEVELS_IDX1 on CCA_FLAT_LEVELS (* 
      
ERROR at line 1: 
ORA-01450: maximum key length (6398) exceeded 
 

• In IIS, verify that centralcoding<InstanceName> exists; <InstanceName> is the Instance Name 
you entered on the Application Instance Settings page during the Central Coding installation. 

1 To open IIS, select Start > Settings > Control Panel > Administrative Tools > Internet Information 
Services (IIS) Manager.  

2 Double-click the machine name, expand Web Sites > Default Web Sites, and locate 
centralcoding<InstanceName>. 

• Verify that the Dictionary Loader tool is installed.  

If you selected Dictionary Loader on the Select Features page when you installed the Central 
Coding software, the Dictionary Loader tool is available from the Start menu. Select Program 
Files > Phase Forward > Central Coding > Dictionary Loader.  

Note: For instructions on using the Dictionary Loader tool to load and manage the coding 
dictionaries, see Loading and managing the coding dictionaries (on page 51). 
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Repairing an installation 
Use this procedure to re-copy all relevant installation files onto the target machine. This option is 
useful if the installation files were corrupted.  

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 

4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Repair, and click Next. 
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Uninstalling a Central Coding application server 
Use this procedure to perform a complete uninstall of the Central Coding software. 

1 Locate setup.exe. 

2 Right-click and select Run as administrator. 

The Existing Installed Instances Detected page appears. 

3 Select Maintain or update the instance of this application selected below. 

4 Select the appropriate server, and click Next. 

The Welcome page appears. 

5 Select Remove, and click Next.  

A confirmation dialog box appears. 

6 Click Yes. 

Messages display as the system removes the Central Coding components. When the process is 
complete, the Uninstall Complete page appears. 

7 Select whether to restart the computer now or later, and click Finish. 

8 Remove the Central Coding folder from the Start menu. 
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About loading and managing the coding dictionaries 
After you install the Central Coding software, you must load the coding dictionaries on the Central 
Coding application server. 

Note: Coding dictionaries are not included as part of the Central Coding installation; you must 
purchase and install your own coding dictionaries. 
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About dictionary types and dictionary schemas 
A dictionary type is a Central Coding concept that identifies a family of coding dictionaries. 

Dictionary types are defined in XML files that contain the metadata for the dictionary levels and the 
SQL needed to set up the tables in the database. These files also contain the default element 
configuration settings that control which coding features and information are available to users in the 
Central Coding user interface. 

Dictionary schemas are created from dictionary types. Each dictionary version is loaded into a 
separate Oracle database schema. 
 

Standard dictionary type XML files 
The Central Coding software includes XML files for the standard dictionary types in <Installation 
Folder>\DictionaryLoader\Setup. 

 

Dictionary type XML file Description 
MedDRA_DictionaryType.xml All versions of MedDRA dictionaries have the dictionary 

type MedDRA. 

MedDRAJ_DictionaryType.xml All versions of MedDRA-J dictionaries have the dictionary 
type MedDRAJ. 

MedDRAJ_ja-JP.xml Used by the Dictionary Loader tool to install the language 
pack for the MedDRA-J dictionary. 

The language pack displays the dictionary level names and 
additional information labels in Japanese in the user 
interface. 

WHO-DD_DictionaryType.xml All versions of WHO-DD dictionaries have the dictionary 
type WHODD. 

JDrug_DictionaryType.xml All versions of JDrug dictionaries have the dictionary type 
JDrug. 

Note: You must rename the dictionary file so that the 
Dictionary Loader tool can recognize the file name. For 
more information, see Renaming the dictionary type file 
for the JDrug dictionary (on page 54). 

JDrug_ja-JP.xml Used by the Dictionary Loader tool to install the language 
pack for the JDrug dictionary. The language pack displays 
the dictionary level names and additional information labels 
in Japanese in the user interface. 

 
 

Custom dictionary type XML files 
For custom dictionaries, you must create the required XML file that defines the dictionary type. 
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Renaming the dictionary file for the JDrug dictionary 
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you must rename the 
JDrug dictionary file so that the Dictionary Loader can recognize the file name and load the 
dictionary. 

• Rename, or copy and rename, the JDrug dictionary file ( ) to all_cases.txt. 

Note: Make sure that this file is in a local directory with only English names in its path. 
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About the Dictionary Loader tool 
The Central Coding software includes a stand-alone component, called the Dictionary Loader tool, 
that you use to manage all functions associated with loading and managing the coding dictionaries. 
The Dictionary Loader tool can be installed on a machine as part of the Central Coding software 
installation. 

• The Dictionary Loader tool is installed into the Central Coding application directory and added 
to the Start menu for the Central Coding application. 

The Dictionary Loader tool is accessible only from the Central Coding server. You must have 
server-level access to run the Dictionary Loader tool; you cannot run it from the user interface. 

• Dictionaries can be loaded on the same machine as the Central Coding application or on a 
different machine. 

Coding dictionaries are not included as part of the Central Coding installation; you must 
purchase and install your own coding dictionaries. 

• All dictionaries can be loaded into a single tablespace, or you can create a separate tablespace for 
each dictionary. 

The instructions in this guide assume that all dictionaries are loaded into one tablespace. 

• Dictionaries can be used by multiple application servers. 
 

Launching the Dictionary Loader tool 
Use the Dictionary Loader tool for all dictionary installation and maintenance tasks. 

• Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

Note: When you upgrade the Central Coding software, information about previously defined 
connections appears in the Data Connections tree. The upgrade may delete the connections 
that were defined for the dictionary repository. You can restore the connections using the 
previous user information so that the dictionary repository objects become available again. 
For more information, see Creating a connection to the database (on page 57). 
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Setting up the dictionary database 

Overview of the steps to set up the dictionary database 

Note: Setting up the dictionary database is the same for both standard and custom dictionaries. 

 

Step Task Description 
1 Create a dictionary repository 

(on page 56). 
Use to create a repository in the database to hold the 
dictionaries associated with a connection. 

Although you can create multiple repositories, only 
one repository can be connected at a time. 

2 Create a connection to the 
database (on page 57). 

Use to create a connection to the database. 

Connections are created within repositories. Although 
you can create multiple connections, only one 
connection can be active at a time. 

3 Connect to the database (on page 
58). 

Use to connect to an existing database connection. 

4 View the dictionaries available 
for a database connection (on 
page 58). 

Use to view information about the dictionary types 
that are available for a connection. 

5 Import the dictionary type XML 
file (on page 59). 

Use to import the dictionary type XML file for a 
dictionary. 

 
 

Creating a dictionary repository 
Use this procedure to create a repository in the database to hold the dictionaries associated with a 
connection. Although you can create multiple repositories, only one repository can be connected at a 
time. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select File > New > Dictionary Repository. 

The New Repository dialog box appears. 

3 Enter the following information:  

The values you enter here must match the values you specified during the Central Coding 
software installation. 

• Oracle Server—Oracle database server connection string.  

• Schema Owner—Name of the coding dictionary database user. 

• This must be the same name that was entered for the Central Coding Dictionary User 
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during the Central Coding installation. 

• This name is also required when creating a connection to the database. 

For more information, see Creating a connection to the database (on page 57). 

• Schema Password and Confirm Schema Password—Password for the coding dictionary 
database user. 

This password is also required when connecting to the database. For more information, see 
Connecting to the database (on page 58). 

• Tablespace—The tablespace for the coding dictionaries. 

The example used in this guide is coding. 

Note: For more information about the Oracle fields, see Create the database and 
tablespaces (on page 21). For instructions on installing the Central Coding software, 
see Installing the Central Coding software (on page 29). 

4 Click OK. 

The Enter Dictionary Administrator Credentials page appears. 

5 Enter the user name and password for the dictionary database administrator, and click OK. 

A database administrator creates the dictionary database administrator account before the 
Central Coding installation. For more information, see Create database user accounts (on 
page 27). 

Messages appear in a window as the repository is created. 

When repository creation is complete: 

• A message appears in the Output pane in the Dictionary Loader tool. 

• The log for the job is available in <Installation 
Folder>\DictionaryLoader\Setup\CreateRepository.log. 

 

Creating a connection to the database 
Connections are created within repositories. Although you can create multiple connections, only one 
connection can be active at a time. 

Note: If a connection is already active, select File > Disconnect before beginning this procedure. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 In the Dictionary Loader tool, select File > New > Connection.  

The Connection Information dialog box appears. 

3 Enter the following information: 

• Connection Name—Unique name for the connection. 

• Server—TNS name for the database. 

• User Name—Name of the coding dictionary database user that was created when the 
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repository was set up. 

This is the name you entered in the Schema Owner field in the New Repository dialog 
box. For more information, see Creating a dictionary repository (on page 56). 

Note: For more information about the Oracle fields, see Create the database and 
tablespaces (on page 21). For instructions on installing the Central Coding software, see 
Installing the Central Coding software (on page 29).   

4 Click Save.  

The connection is created. It appears in the Data Connections tree view in the left pane of the 
Dictionary Loader tool dialog box. 

Note: If the connection does not appear in the tree, close the Dictionary Loader tool and 
open it again. 

 

Connecting to the database 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 In the Dictionary Loader tool, select a connection from the Data Connections tree view in the left 
pane. 

3 Select File > Connect.  

The Connection Information dialog box appears. 

4 Enter the password that was created when the repository was set up. 

This is the name you entered in the Schema Password field in the New Repository dialog box. 
For more information, see Creating a dictionary repository (on page 56). 

5 Click Connect.  

When the connection is established: 

• A Dictionaries node is added to the Data Connections tree for this connection. 

Select this node for information about the installed dictionaries. 

• A Types node is added to the Data Connections tree for this connection. 

Select this node for information about the installed dictionary types. 
 

Viewing the dictionary types for a connection 
Use this procedure to view information about the dictionary types that are available for a connection.  

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 
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Information about the Dictionary Types for this connection appears in the top pane. 

4 If the dictionary type file for the coding dictionary you want to load does not appear in the 
Dictionary Loader tool, you can import the dictionary type. 

For more information, see Importing the dictionary type file (on page 59). 
 

Importing the dictionary type XML file 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Import.  

The Locate Files dialog box appears. 

5 Browse to the folder that contains the XML file to import.  

The Central Coding software includes XML files for the standard dictionary types in <Installation 
Folder>\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

Note: If you created a custom dictionary type, browse to the file you created. For more 
information, see Creating a new dictionary type for a custom dictionary (on page 66). 

6 Select a file and click Open.  

The full path to the XML file appears in the Location field. 

7 Click OK. 

When the import is complete, a message appears in the Output pane and information about the 
dictionary type appears at the top of the Dictionary Types pane. 
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Loading standard dictionaries 

Overview of the steps to load a standard coding dictionary 
 

Step Task Description 
1 If you are using a WHO-DD 

dictionary, determine whether you 
are using a pre-ICH or ICH 
format of the dictionary. 

For more information, see: 

• About pre-ICH and ICH formats of the 
WHO-DD dictionary (on page 60). 

• Loading a pre-ICH version of the WHO-DD 
dictionary (on page 61). 

2 Make sure that the dictionary type 
for the dictionary that you want to 
load has been imported. 

For more information, see Importing the dictionary 
type XML file (on page 59). 

3 Make sure that the dictionary 
connection is established. 

For more information, see Viewing the dictionaries 
available for a database connection (on page 61). 

4 Generate the schema for a 
dictionary (on page 62). 

The Dictionary Loader tool uses dictionary types to 
create dictionary schemas. 

5 Load the dictionary data (on 
page 63). 

Load dictionary data into the database using the 
schema that you generated. The dictionary schema 
must exist before you can load data into it. 

6 Activate the dictionary (on page 
63). 

Dictionaries must be activated to be used for coding. 

 
 

About pre-ICH and ICH formats of the WHO-DD dictionary 
The format of the WHO-DD C dictionary files was changed for compliance with the ICH guidelines 
for drug dictionaries. The Central Coding application ships with the control files for both the pre-
ICH and ICH dictionary formats. You can load either format of the WHO-DD dictionary for use in 
the Central Coding application. 

• ICH format—An ICH version of the WHO-DD dictionary is one released in or after March 
2006. 

The control files for the ICH version of the dictionary are stored in two locations: 

• <Installation Folder>\Dictionary Loader\bin\setup\control files\whodd 

• <Installation Folder>\Dictionary Loader\bin\setup\control files\whodd\ICH 
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The Central Coding application is set up by default to use the ICH version of the WHO-DD 
dictionary. Therefore, if you want to use this dictionary format, no changes to the control files 
are required. 

• Pre-ICH format—A pre-ICH version of the WHO-DD dictionary is one released prior to 
March 2006. 

The control files for the pre-ICH version of the dictionary are stored in: 

• <Installation Folder>\Dictionary Loader\bin\setup\control files\whodd\Pre-ICH 

If you want to use this dictionary format, you must copy the control files to a different directory. 

For more information, see Loading a pre-ICH version of the WHO-DD dictionary (on page 
61). 

 

Loading a pre-ICH version of the WHO-DD dictionary 

Note: Use this procedure only if you plan to load a pre-ICH version of the WHO-DD dictionary. A 
pre-ICH version of the WHO-DD dictionary is one released prior to March 2006. 

1 Navigate to <Installation Folder>\DictionaryLoader\bin\setup\control files\whodd. 

2 Delete the control files (CTRL) from the whodd directory. 

The control files for the ICH dictionary format are also stored in <Installation Folder>\Dictionary 
Loader\bin\setup\control files\whodd\ICH so that they are available if you decide to use the 
ICH dictionary format at a later time. 

3 Navigate to <Installation Folder>\DictionaryLoader\bin\setup\control files\whodd\Pre-ICH 
and copy the CTRL files into the <Installation Folder>\DictionaryLoader\bin\setup\control 
files\whodd directory. 

 

Viewing the dictionaries available for a database connection 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection.  

The Dictionaries pane displays one row of information for every dictionary associated with this 
connection. 

 

Dictionary statuses 
 

Status Description 
DEFINED The type, version, culture, and schema that hold data for the dictionary are 

defined. Data is not loaded into the schema. 

LOADED Data is loaded into the schema for the defined dictionary. 
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Status Description 
ACTIVE The dictionary is defined, data is loaded into the schema, and the dictionary is 

available for coding. 

INACTIVE The dictionary is defined and data is loaded into the schema, but the dictionary 
is not available for coding. 

REMOVED The schema and data associated with the dictionary are deleted. 

 
 

Generating the schema for the dictionary data 

Note: The Dictionary Loader tool uses dictionary types to create dictionary schemas. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Verify that the dictionary type for the dictionary that you want to create has been imported. 

If necessary, import the dictionary type. For more information, see Importing the dictionary 
type file (on page 59). 

4 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

5 Select File > New > Dictionary.  

The New Dictionary dialog box appears. 

6 Enter the following information: 

• Type—Dictionary type that exists for this connection. Standard dictionary types are 
WHO-DD and MedDRA. If you imported custom types, they appear in the drop-down list. 

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4 version 
for WHO-DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters maximum. 

• Culture—The culture setting for the dictionary data. For example, en-US. 10 characters 
maximum. 

• Punctuation Filter—The characters that are to be considered as punctuation by the coding 
algorithm in the step that removes punctuation. OPTIONAL. 100 characters maximum. 

• Description—A brief description of the dictionary. OPTIONAL. 200 characters maximum. 

• Owner for Schema—The unique name for the schema.  

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• Tablespace—The name of the tablespace that was created for the dictionaries. 
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7 Click OK. 

The Enter Dictionary Administrator Credentials page appears. 

8 Enter the user name and password for the dictionary database administrator, and click OK. 

When the dictionary has been created, a message appears in the Output pane and information 
about the dictionary appears in the Dictionaries list in the top pane in the Dictionary Loader 
tool. 

 

Loading dictionary data 
Use this procedure to Load dictionary data into the database using the schema that you generated. 
The dictionary schema must exist before you can load data into it. For more information, see 
Generating the schema for a dictionary (on page 62). 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionaries for this connection appears in the top pane. 

4 In the Dictionaries pane, select the dictionary to load data into. 

5 Select Dictionary > Load.  

The Locate Files dialog box appears. 

6 Enter the following information: 

• Location—Browse to the folder that contains the file with the dictionary data to load. 

Select a directory and click Open. The full path to the files appears in the Location field. 

• Dictionary schema password—Password for this dictionary schema, which was created 
when the dictionary was created. 

7 Click OK.  

The dictionary data loads. Messages appear in the Output pane in the Dictionary Loader tool. 
When the load is complete, you can check the log file to verify the status of the load operation. 
The log file is in <Installation Folder>\DictionaryLoader\Setup\gather_stats_[schemaowner].log. 

 

Activating the dictionary 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections pane, select a connection. 

4 Select Dictionary > Activate.  
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The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded into the 
schema, and the dictionary is available for coding. 
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Loading custom dictionaries 

Overview of the steps to load a custom dictionary 
 

Step Task Description 
1 Create a custom dictionary 

definition XML file (on page 65). 
Create an XML file that contains the metadata for the 
dictionary levels and the SQL needed to set up the 
tables in the database. 

2 Create a new dictionary type for a 
custom dictionary. 

For more information, see Creating a new 
dictionary type for a custom dictionary (on page 
66). 

3 Import the dictionary type XML 
file. 

For more information, see Importing the dictionary 
type XML file (on page 59). 

4 View the dictionaries available for a 
database connection. 

For more information, see Viewing the dictionaries 
available for a database connection (on page 58). 

5 Generate the schema for a 
dictionary (on page 62). 

The Dictionary Loader tool uses dictionary types to 
create dictionary schemas. 

6 Load dictionary data (on page 
63). 

Load dictionary data into the database using the 
schema that you generated. 

The dictionary schema must exist before you can load 
data into it. 

7 Activate the dictionary (on page 
63). 

Dictionaries must be activated to be used for coding. 

8 Create custom icons for the 
coding browser (on page 71). 

Create custom dictionary icons for use in the coding 
browser Browse mode. 

 
 

Creating a custom dictionary definition XML file 
Use the standard XML files for the MedDRA, MedDRA-J, WHO-DD, and JDrug dictionaries as the 
basis for your custom XML files. These files are in 
...Central Coding Application\DictionaryLoader\Setup. 

For the DictionaryType element: 

• adaptertype sub-element must be Custom. 

• numlevels must be greater than 0 and must equal the number of Level elements. 
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Creating a new dictionary type for a custom dictionary 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears.  

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select the Types node for the active connection from the Data Connections tree in the left pane.  

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select File > New > New Dictionary Type.  

The New Type dialog box appears.  

When working in the grid: 

• Note that each row represents one level in the dictionary. 

• Use the buttons to add and remove levels and to change the order of levels for the 
dictionary type. 

• Create at least one level. 

• Create the same number of terms (one or two) at each level. 

5 Enter the following information: 

• Type—The name for the new dictionary type. 

• Description—A description of the dictionary type. OPTIONAL. 

• Supports Stopwords—Select if you want to run the algorithm steps that remove stopwords 
from the text to be coded for dictionaries of this type. 

• Term—A label for the first term of this level. 

• Additional Information—A label for each additional level of the dictionary. Separate each 
additional information item with a pipe ( | ). 

• Abbreviation—An abbreviated name to identify this level. 

The full name of this level is the label for the first term, concatenated with the label for the 
second term. 

• Tablename—The name of the table to create in the schema of a dictionary of this type to 
hold data for this level. 

• Filename—The name of the flat file that contains the data for this level. 

• Encoding—The encoding type of the file specified in the Filename field. OPTIONAL. 

If not specified, the default encoding type is used. 

• Delimiter—The field delimiter used in records in the file specified in the Filename field. 
OPTIONAL. 

If not specified, the default delimiter is used. 

6 Click OK.  
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The custom dictionary type is added to the Dictionary Types pane in the Dictionary Loader tool. 
 

Importing the dictionary type XML file 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Import.  

The Locate Files dialog box appears. 

5 Browse to the folder that contains the XML file to import.  

The Central Coding software includes XML files for the standard dictionary types in <Installation 
Folder>\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

Note: If you created a custom dictionary type, browse to the file you created. For more 
information, see Creating a new dictionary type for a custom dictionary (on page 66). 

6 Select a file and click Open.  

The full path to the XML file appears in the Location field. 

7 Click OK. 

When the import is complete, a message appears in the Output pane and information about the 
dictionary type appears at the top of the Dictionary Types pane. 

 

Viewing the dictionary types for a connection 
Use this procedure to view information about the dictionary types that are available for a connection. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 If the dictionary type file for the coding dictionary you want to load does not appear in the 
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Dictionary Loader tool, you can import the dictionary type. 

For more information, see Importing the dictionary type file (on page 59). 
 

Dictionary statuses 
 

Status Description 
DEFINED The type, version, culture, and schema that hold data for the dictionary are 

defined. Data is not loaded into the schema. 

LOADED Data is loaded into the schema for the defined dictionary. 

ACTIVE The dictionary is defined, data is loaded into the schema, and the dictionary is 
available for coding. 

INACTIVE The dictionary is defined and data is loaded into the schema, but the dictionary 
is not available for coding. 

REMOVED The schema and data associated with the dictionary are deleted. 

 
 

Generating the schema for the dictionary data 

Note: The Dictionary Loader tool uses dictionary types to create dictionary schemas. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Verify that the dictionary type for the dictionary that you want to create has been imported. 

If necessary, import the dictionary type. For more information, see Importing the dictionary 
type file (on page 59). 

4 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

5 Select File > New > Dictionary.  

The New Dictionary dialog box appears. 

6 Enter the following information: 

• Type—Dictionary type that exists for this connection. Standard dictionary types are 
WHO-DD and MedDRA. If you imported custom types, they appear in the drop-down list. 

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4 version 
for WHO-DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters maximum. 

• Culture—The culture setting for the dictionary data. For example, en-US. 10 characters 
maximum. 

• Punctuation Filter—The characters that are to be considered as punctuation by the coding 
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algorithm in the step that removes punctuation. OPTIONAL. 100 characters maximum. 

• Description—A brief description of the dictionary. OPTIONAL. 200 characters maximum. 

• Owner for Schema—The unique name for the schema.  

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• Tablespace—The name of the tablespace that was created for the dictionaries. 

7 Click OK. 

The Enter Dictionary Administrator Credentials page appears. 

8 Enter the user name and password for the dictionary database administrator, and click OK. 

When the dictionary has been created, a message appears in the Output pane and information 
about the dictionary appears in the Dictionaries list in the top pane in the Dictionary Loader 
tool. 

 

Loading dictionary data 
Use this procedure to Load dictionary data into the database using the schema that you generated. 
The dictionary schema must exist before you can load data into it. For more information, see 
Generating the schema for a dictionary (on page 62). 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the Dictionaries for this connection appears in the top pane. 

4 In the Dictionaries pane, select the dictionary to load data into. 

5 Select Dictionary > Load.  

The Locate Files dialog box appears. 

6 Enter the following information: 

• Location—Browse to the folder that contains the file with the dictionary data to load. 

Select a directory and click Open. The full path to the files appears in the Location field. 

• Dictionary schema password—Password for this dictionary schema, which was created 
when the dictionary was created. 

7 Click OK.  

The dictionary data loads. Messages appear in the Output pane in the Dictionary Loader tool. 
When the load is complete, you can check the log file to verify the status of the load operation. 
The log file is in <Installation Folder>\DictionaryLoader\Setup\gather_stats_[schemaowner].log. 
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Activating the dictionary 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections pane, select a connection. 

4 Select Dictionary > Activate.  

The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded into the 
schema, and the dictionary is available for coding. 
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Using custom icons in the coding browser 
The coding browser in the Central Coding application displays icons for the levels of the coding 
dictionary. When you create a custom dictionary, you must also provide the icons for the coding 
browser. 

To identify the custom dictionary icons to use in the coding browser: 

1 Copy the graphics for the icons to the Resources folder in the virtual directory where the Central 
Coding application is running.  

2 Use the following naming convention for the custom icons: 
<dictionary type>_<tablename for the level>.gif 

In the previous example: 

• <dictionary type> is the name of the XML file that defines the dictionary type. 

For more information, see Creating a custom dictionary definition XML file (on page 
65). 

• <tablename for the level> is the name of the Oracle table, where the data for that level is 
stored. 

For example, if a custom dictionary type XML file is named CustomTest.xml and it has three 
levels named soc, pt, and llt, name the icons for the levels as follows: 

• CustomTest_soc.gif 

• CustomTest_pt.gif 

• CustomTest_llt.gif 
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Installing the language packs for the Japanese dictionaries 
Use this procedure to install the language pack for the MedDRA-J or JDrug dictionary. The language 
pack displays the dictionary level names and additional information labels in Japanese in the user 
interface. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Make sure that the dictionary database is set up, that you are connected to the database, and that 
the dictionary or dictionaries are loaded. 

For more information, see Setting up the dictionary database (on page 56) and Loading 
dictionaries (on page 51). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select the Dictionary Type for which you want to install the language pack. 

5 Select Dictionary Type > Localized Elements. 

The Localized Elements dialog box appears. 

6 Click Import. 

The Locate Files dialog box appears. 

7 Browse to the <LanguagePack>.xml file that you want to install. 

The Central Coding software includes XML files for the standard dictionary types in <Installation 
Folder>\DictionaryLoader\Setup. 

• MedDRA_ja-JP.xml 

• JDrug_ja-JP.xml 

8 Click OK. 
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Maintaining the coding dictionaries 

Changing the punctuation filter for a dictionary type 
Use this procedure to change the characters in the punctuation filter for a dictionary type. The 
punctuation filter identifies characters that you want the coding algorithm to consider as punctuation 
in the step that removes punctuation. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select the Types node for the active connection from the Data Connections tree in the left pane.  

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select a dictionary type.  

An arrow appears in the column to the left of the Type column. 

5 Select Dictionary > Change Punctuation Filter.  

The Punctuation Filter dialog box appears.  

6 Add or remove characters as necessary. 

7 Click OK. 
 

Updating a dictionary type and applying the changes to installed dictionaries 
Use this procedure to apply changes from a <Dictionary_Type>.xml file to installed dictionaries. For 
more information, see About dictionary types (on page 53). 

The <Dictionary_Type>.xml file contains, among other things, the element configuration settings 
for each dictionary type (MedDRA, MedDRA-J, WHO-DD, JDrug, and custom). These settings 
control which coding features and information are available to users in the Central Coding user 
interface. To apply the updated settings to existing coding definitions, you must manually reset your 
element configuration settings for the coding definitions created before the update and associated 
with the dictionary. For more information, see the User Guide. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select the Types node for the active connection. 

4 Select a dictionary type. 

5 Select Dictionary Type > Update. 

The Locate Files dialog box appears. 

6 Browse to the <Dictionary_Type>.xml file to use for the update. 



Chapter 5  Loading and managing the coding dictionaries  
 

74 Oracle® Health Sciences Central Coding 3.1.0.1 

The Central Coding software includes XML files for the standard dictionary types in <Installation 
Folder>\DictionaryLoader\Setup. 

• MedDRA_DictionaryType.xml 

• MedDRAJ_DictionaryType.xml 

• WHODD_DictionaryType.xml 

• JDrug_DictionaryType.xml 

If you are using a custom dictionary type, browse to the file you created. For more information, 
see Creating a new dictionary type for a custom dictionary (on page 66). 

7 Click OK. 

The Dictionary Selection Form dialog box appears. 

8 Select one or more versions of the dictionary. 

9 Click OK. 
 

Converting the WHO-DD dictionary to C format 
You can use the Dictionary Loader or the ConvertToC utility to convert the WHO-DD dictionary to 
the C format. 
 

Using the Dictionary Loader to convert the WHO-DD dictionary to C format 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Dictionaries node for the active 
connection. 

Information about the dictionaries for this connection appears in the top pane. 

4 Select the WHO-DD B format dictionary. 

5 Select Dictionary > Convert WHODD B to C. 

The Locate File dialog box appears. 

6 Click Browse and locate the folder that contains WHO-DD B format dictionary files. 

7 Select the directory and click Open.  

The full path to the files appears in the Location field. 
 

Using the ConvertToC utility to convert the WHO-DD dictionary to C format 
1 Open a Command Prompt window and enter the name of the drive in which the executable file 

is installed. 

By default, the executable file is installed in the same location as the Central Coding application. 

2 Enter the location of the executable file in the drive that you specified. 
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3 Enter the following syntax for converting the WHO-DD B format dictionary to C format: 

ConvertToC [File Path] 

In the command syntax: 

• File Path—Path for the location of the WHO-DD B format dictionary files. 

The ConvertToC utility creates a folder called C in the folder in which the WHO-DD B format 
dictionary files are installed. 

 

Deleting a dictionary type 
You can delete dictionary types that do not have schemas associated with them. If a dictionary 
schema that uses this dictionary type exists, you must delete the schema before you can delete the 
dictionary type. For more information, see Removing a dictionary schema (on page 76). 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 In the Data Connections tree in the left pane, select the Types node for the active connection. 

Information about the Dictionary Types for this connection appears in the top pane. 

4 Select Dictionary Type > Delete.  

A confirmation dialog box appears. 

5 Click Yes. 
 

Inactivating a dictionary 
Inactive dictionaries remain in the list of dictionaries for a connection and can be reactivated if 
necessary. You must inactivate a dictionary before you can delete it. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select the Dictionaries node for the active connection. 

4 Select a dictionary. 

5 Select Dictionary > Inactivate.  

The dictionary status changes to INACTIVE. The dictionary is defined and data is loaded into 
the schema, but the dictionary is not available for coding. 

 

Deleting a connection to the database 
1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 
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The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select Connection > Delete. 

Deleted connections remain visible in the Data Connections tree view in the left pane of the 
Dictionary Loader tool until you close the dialog box. 
 

Removing a dictionary schema 
 Removing a dictionary removes the dictionary schema and all data. When you remove a dictionary 
schema, all synonym lists, coding definitions, assignment rules, and requests entered against the 
dictionary are lost and cannot be retrieved. 

Caution: Oracle recommends that you do not remove the dictionary schema or delete a dictionary 
that has been used for coding. Delete only dictionaries that you have set up but have not coded 
against. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Make sure that you have inactivated the dictionary whose dictionary schema you want to remove. 

For more information, see Inactivating a dictionary (on page 75). 

4 Select the Dictionaries node for the active connection. 

5 Select a dictionary to remove. 

6 Select Dictionary > Remove. 

A confirmation dialog box appears. 

7 Click Yes.  

8 If prompted, enter the user name and password for the dictionary schema administrator, and 
click OK. 

The dictionary remains in the list of Dictionaries. The dictionary status changes to REMOVED. 

Note: You must revive this dictionary type before you can use it again to load dictionaries. 
For more information, see Reviving a dictionary schema (on page 76). 

 

Reviving a dictionary schema 
Reviving a dictionary schema recreates the schema of a previously removed dictionary. For more 
information, see Removing a dictionary schema (on page 76). After reviving a dictionary schema, 
you can load data into the dictionary. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 
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The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Select the Dictionaries node for the active connection. 

4 Select a dictionary with a status of REMOVED. 

5 Select Dictionary > Revive. 

The New Dictionary dialog box appears. The information in most fields is read-only because it 
already exists in the database. 

6 Enter the following information. 

• Schema Password—The password for this dictionary schema. 

• Confirm Schema Password—The password for this dictionary schema. 

• Tablespace—The name of the tablespace that was created for the dictionaries. 

7 Click OK. 

8 If prompted, enter the user name and password for the dictionary database administrator, and 
click OK. 

 

Deleting a dictionary 
Deleted dictionaries cannot be revived or reactivated. When you delete a dictionary, all synonym lists, 
coding definitions, assignment rules, and requests entered against the dictionary become invalid and 
cannot be retrieved. 

Caution: Oracle recommends that you do not remove the dictionary schema or delete a dictionary 
that has been used for coding. Delete only dictionaries that you have set up but have not coded 
against. 

1 Select Start > Program Files > Phase Forward > Central Coding > Dictionary Loader. 

The Dictionary Loader dialog box appears. 

2 Select a connection and connect to the database. 

For more information, see Connecting to the database (on page 58). 

3 Make sure that you have removed the schema for the dictionary that you want to delete. 

For more information, see Removing a dictionary schema (on page 76). 

4 Select the Dictionaries node for the active connection. 

5 Select a dictionary.  

6 Select Dictionary > Delete. 

A confirmation dialog box appears. 

7 Click Yes.  

8 If prompted, enter the user name and password for the dictionary database administrator, and 
click OK. 
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Using the Data Installer 

About the Data Installer 
The Central Coding software includes a command line application, called the Data Installer, that you 
can use to import data instead of entering the data through the user interface, and to export the data.  

The Data Installer is installed automatically as part of the Central Coding software installation in 
<Installation Folder>\CentralCodingServer\CodingWebUI\bin. 

Oracle recommends that you use the Data Installer to export data from a configured instance of the 
Central Coding application, and import the data file as is, or edit it and perform an update. Oracle 
does not recommend creating your own configuration file for import. 

You can use the Data Installer to: 

• Export and import synonym lists, stopword lists, coding algorithms, and coding definitions. 

Note: You cannot update coding definitions. You can replace or update a synonym list. 

• Import assignment rules.  

Note: You cannot update assignment rules. 

• Export and import security data such as users, rights, roles, and workteams from an existing 
installation to another installation. 

Note: Security data cannot be created manually. You must export it and then import it to 
the new instance. 

• Export and import system settings such as the authentication options, application settings and 
lock management options, and impact analysis options from an existing installation to another 
installation. 

 

Data Installer modes 
The Data Installer has the following modes:  

• Download—Used to export data from the Central Coding application. 

When you export data using the Download mode, an export configuration XML file is created. 
You can use this file with the Data Installer to import or update data in the Central Coding 
application. 

• Setup—Used to import data into the Central Coding application. 

To import data in the Central Coding application, you can use the export configuration XML file 
that is created when you run the Data Installer in Download mode, a manually created XML 
configuration file, or the sample XML configuration file called 
CentralCodingConfigMaster.xml, which you can edit as needed.  

• Update—Used to update existing data in the Central Coding application. 

To update data in the Central Coding application, you can use the export configuration XML file 
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that is created when you run the Data Installer in Download mode, a manually created XML 
configuration file, or the sample XML configuration file called 
CentralCodingConfigMaster.xml, which you can edit as needed. 

Note: The sample XML file is installed in the same location as the Data Installer. 

 

Data Installer parameters 
 

Parameter Description 
ApplicationName Name of the Central Coding application. The application name is 

located in the PhaseForward.Platform.Config.xml file, which is 
installed in the same directory as the Data Installer. The default 
application name is CentralCodingApplication.  

Mode Type of action to perform. The available options are: 

• Download—Export data from the Central Coding application. 

• Setup—Import data to the Central Coding application. 

• Update—Update existing data in the Central Coding application. 

Note: When using the Data Installer in Update mode, make sure 
that the GUIDs for the data in the update configuration file do not 
already exist in the Central Coding application. If duplicate GUIDs 
exist, the Data Installer displays an error message and the update 
does not complete.  

Type SysConfig. 

MasterFile Path to the master configuration file, called MasterConfig.xml. The 
master configuration file is installed in the same directory as the Data 
Installer. 

/DISABLESINGLETRA
NSACTION 

Instructs the Data Installer to execute each transaction separately. By 
default, the Data Installer executes all commands in a single 
transaction. 

 
 

Exporting data with the Data Installer 
To export data from an instance of the Central Coding application, use the Data Installer in 
Download mode. You can export synonym lists, stopword lists, coding algorithms, coding 
definitions, and system settings. 

1 Specify the data to export: 

• Edit an existing configuration file. 

• Create a configuration file. 

Make sure to specify the directory path in which to generate the export files. The directory must 
exist before you run the Data Installer. 

2 Open a Command Prompt window and enter the name of the drive in which the Data Installer 
is installed. 
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3 Enter the location of the Data Installer in the drive you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Download mode, using the following syntax: 
PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Download] [SysConfig] [MasterFile] 

In the command syntax:  

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer extracts the data and generates the XML files in the directory that you 
specified in the export configuration file. 

 

Importing data with the Data Installer 
To import data into an instance of the Central Coding application, use the Data Installer in Setup 
mode. You can import users, roles, workteams, assignment rules, synonym lists, stopword lists, 
coding algorithms, and coding definitions. 

Note: You cannot import an object if its GUID is already used in the database into which you are 
importing. If duplicate GUIDs exist, an error message appears, and the import stops. 

1 Specify the data to import: 

• Edit an existing configuration file. 

• Create a configuration file. 

• Locate an existing export file. 

For more information about the export procedure, see Exporting data with the Data 
Installer (on page 81). 

Note: Oracle recommends that you use the Data Installer to export data from a configured 
instance of the Central Coding application, and import the data file as is, or edit it and 
perform an update. Oracle does not recommend creating your own configuration file for 
import. 

Make sure to specify the directory path of the file to import. 

Note: Data in XML files is case-sensitive. 

2 Open a Command Prompt window and enter the name of the drive in which the Data Installer 
is installed. 

3 Enter the location of the Data Installer in the drive you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Setup mode, using the following syntax: 
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PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Setup] [SysConfig] [MasterFile] 

In the command syntax: 

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer adds the data to the appropriate tables in the target Central Coding database, 
based on the import data type. 

 

Updating data with the Data Installer 
To update existing data in the Central Coding application using the Data Installer, run the utility in 
Update mode. You can update users, roles, workteams, synonym lists, stopword lists, coding 
algorithms, and system settings. You cannot update coding definitions or assignment rules. 

Note: You cannot import an object if its GUID is already used in the database into which you are 
importing. If duplicate GUIDs exist, an error message appears, and the import stops. 

1 Specify the data to update: 

• Edit an existing configuration file. 

• Create a configuration file. 

• Locate an existing export file. 

For more information about the export procedure, see Exporting data with the Data 
Installer (on page 81). 

Note: Oracle recommends that you use the Data Installer to export data from a configured 
instance of the Central Coding application, and import the data file as is, or edit it and 
perform an update. Oracle does not recommend creating your own configuration file for 
import. 

Make sure to specify the directory path of the file to use in the update procedure. 

Note: Data in XML files is case-sensitive. 

2 Open a Command Prompt window and enter the name of the drive in which the Data Installer 
is installed. 

3 Enter the location of the Data Installer in the drive you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

4 Run the utility in Update mode, using the following syntax: 
PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName] 
[Update] [SysConfig] [MasterFile] 

In the command syntax:  

• ApplicationName—Name of the Central Coding application. The application name is 
located in the PhaseForward.Platform.Config config file, which is installed in the 
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same directory as the Data Installer. The default application name is 
CentralCodingApplication.  

• MasterFile—Path to the master configuration file. The master configuration file is 
called MasterConfig.xml, and is located in the same directory as the Data Installer. 

The Data Installer adds the data to the appropriate tables in your target Central Coding database, 
based on the update data type. 
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Adding adapters and studies using the command line 

About adding adapters and studies using the command line 
You can add adapters and studies from the user interface, and also through the command line. The 
following executable files are installed as part of the Central Coding software installation. Run the 
executable files to install adapters and studies into the Central Coding application. 

• PhaseForward.CentralCoding.SetAdapter.exe—Installs an adapter to a Central Coding 
instance. 

When you install the adapter using the executable file, you use the available parameters to define 
Get Requests and Return Codes schedules for the adapter. 

For more information, see Adding an adapter and defining its job schedules using the 
command line (on page 85). 

• PhaseForward.CentralCoding.SetStudyGroup.exe—Creates a study group in a Central 
Coding instance. 

When you create a study group, you use the available parameters to specify the study to add to 
the group, and the Get Requests and Return Codes schedules for the study. 

For more information, see Adding a study group using the command line (on page 86). 

• PhaseForward.CentralCoding.SetStudy.exe—Installs a study to a Central Coding instance. 

When you add the study, you use the available parameters to specify which adapter with which to 
associate the study, and you add the study to Get Requests and Return Codes schedules. 

For more information, see Adding a study to an adapter and job schedules using the 
command line (on page 87). 

Note: You can add a study to a Get Requests or Return Codes schedule only if the schedule 
is already defined for the adapter to which you are adding the study. 

The files are available in the following location: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

Note: You must run the executable files in the location in which they were installed. 

 

Adding an adapter and defining its job schedules using the command line 
1 Open a Command Prompt window and enter the name of the drive in which the executable file 

is installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Enter the location of the executable file in the drive that you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 
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3 Enter the following command for adding an adapter and defining its job schedules: 

PhaseForward.CentralCoding.SetAdapter.exe [AdapterName] [AdapterURL] 
[GetVerbatimsSchedule] [ReturnCodesSchedule] 

In the command syntax: 

• AdapterName—Name of the adapter to add. 

• AdapterURL—URL of the adapter to add. 

• GetVerbatimsSchedule—Rate at which to run the Get Requests job schedule. This 
parameter corresponds to the Time span configuration setting on the Schedule GetRequests 
Job page in the user interface. 

• 0—Indicates that you will run manual Get Requests jobs for the adapter, and the 
adapter should not be added to a Get Requests schedule. 

• 1—Set a Get Requests job schedule to run every minute for the adapter. 

• 5—Set a Get Requests job schedule to run every five minutes for the adapter. 

• 15—Set a Get Requests job schedule to run every fifteen minutes for the adapter. 

• 30—Set a Get Requests job schedule to run every thirty minutes for the adapter. 

Note: This parameter is optional. 

• ReturnCodesSchedule—Rate at which to run the Return Codes job schedule. This 
parameter corresponds to the Time span configuration setting on the Schedule ReturnCodes 
Job page in the user interface. 

• 0—Indicates that you will run manual Return Codes jobs for the adapter, and the 
adapter should not be added to a Return Codes schedule. 

• 1—Set a Return Codes job schedule to run every minute for the adapter. 

• 5—Set a Return Codes job schedule to run every five minutes for the adapter. 

• 15—Set a Return Codes job schedule to run every fifteen minutes for the adapter. 

• 30—Set a Return Codes job schedule to run every thirty minutes for the adapter. 

Note: This parameter is optional. 

 

Adding a study group using the command line 
1 Open a Command Prompt window and enter the name of the drive in which the executable file 

is installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Enter the location of the executable file in the drive that you specified: 
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<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 

3 Enter the following command for adding a study group: 

PhaseForward.CentralCoding.SetStudyGroup.exe [StudyGroupName] 
[AllowAutoQuery] [AllowAutoClose] 

In the command syntax: 

• StudyGroupName—Name of the study group to add.  

• AllowAutoQuery—Y or N, specifying whether to allow the Central Coding application to 
duplicate an existing query and apply it to all matching verbatims in the study group that are 
subsequently entered in the Central Coding application.  

• AllowAutoClose—Y or N, specifying whether to allow the Central Coding application to 
automatically close a query if the verbatim associated with the query is successfully coded 
and approved. 

 

Adding a study to an adapter and job schedules using the command line 
1 Open a Command Prompt window and enter the name of the drive in which the executable file 

is installed. 

Note: By default, the executable file is installed in the same location as the Central Coding 
application. 

2 Enter the location of the executable file in the drive that you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\bin 

Note: You must run the application from this directory. 

3 Enter the following command for adding a study to an adapter and job schedules: 

PhaseForward.CentralCoding.SetStudy.exe [SourceApplication] [AdapterName] 
[StudyName] [StudyURL] [StudyGroupName] [ClientAuditUser] [InForm QueryUser] 
[InFormAuthenticationUser] [SupportQuery] [StudyLocked] [GetVerbatimsSchedule] 
[ReturnCodesSchedule] 

In the command syntax: 

• SourceApplication—The name of the application that is integrated with the Central Coding 
application. 

• InForm 

• Clintrial 

• Other—Any supported third-party application. 

• AdapterName—Name of the adapter to which to add the study. 

• StudyName—Name of the study to add. 

• StudyURL—URL of the study to add. 
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• StudyGroupName—Name of the study group with which to associate the study. 

• ClientAuditUser—User name for the audit records that are created in the InForm 
application to record the codes that are returned by the Central Coding application. 

• InFormQueryUser—User name used to create and update queries in the InForm 
application.  

• InFormAuthenticationUser—User name of an InForm application user created to 
communicate with the InForm server through web services. 

• SupportQuery—Y or N, specifying whether the study supports query management. 
Available for InForm studies. 

• StudyLocked—Y or N, specifying whether to lock the study. 

• GetVerbatimsSchedule—Y or N, specifying whether to add the study to the Get Requests 
schedule for the adapter you specified. 

Note: You can only specify Y if a Get Requests schedule is already defined for the 
adapter to which you are adding the study. 

• ReturnCodesSchedule—Y or N, specifying whether to add the study to the ReturnCodes 
schedule for the adapter you specified. 

Note: You can only specify Y if a Return Codes schedule is already defined for the 
adapter to which you are adding the study. 
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Replacing the certificate to secure internal communication 
with the Job Scheduler service 

You select a certificate to secure internal communication with the Job Scheduler service during the 
Central Coding application server installation.  

To replace the certificate: 

1 Install a new certificate. For more information, see Install a certificate to secure internal 
communication with the Job Scheduler service (on page 23). 

2 Run UpdateJSCertificate.cmd (located in <Installation 
Folder>\CentralCodingServer\CodingWebUI\bin) using the following syntax: 
UpdateJSCertificate.cmd <CertificateName> <CertificateThumbprint> 

In the previous example: 

• CertificateName—Name of the new certificate. 

• CertificateThumbprint—Thumbprint of the new certificate. 
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Selecting a certificate for InForm Adapter authentication 
Certificate authentication can be used in the following cases between Central Coding and InForm 
Adapter interfaces:  

• Adapter Admin—When the Adapter URL starts with https. 

• Coding and Discrepancy web services—When you prefer the certificate authentication method 
to the username/password method, when the Adapter URL starts with https. 

To select a certificate, or replace the certificate that is currently in use, run the utility 
PhaseForward.CentralCoding.UpdateIACertificate.exe located in <Installation 
Folder>\CentralCodingServer\CodingWebUI\bin. 

Run the utility from the command line with one of the parameters: 

• /?—Displays command help and exit codes. 

• /s <certificate name> <certificate thumbprint>—Selects the specified certificate to be used 
for InForm Adapter authentication. 

• /r—Removes the certificate that is used for InForm Adapter authentication. 
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Setting a web proxy for outgoing calls 
Central Coding supports proxy servers during web service invocation for outbound calls. 

To configure the outbound proxy, use PhaseforwardCentralCodingSetDefaultProxy.exe, which is 
installed during the Central Coding software installation in <Installation 
Folder>\CentralCodingServer\CodingWebUI\bin. 

Edit parameters in the following files: 

• web.config 

• PhaseForward.Platform.JobScheduler.exe.config 

• PhaseForward.CentralCoding.SetStudy.exe.config 

• PhaseForward.CentralCoding.SetAdapter.exe.config 

Parameters: 

• ProxyAddress {URL}—Sets ProxyAddress to the specified URL. 

• BypassProxyOnLocal [True|False]—Sets the BypassProxyOnLocal attribute. The default 
value is False. 

• UseDefaultWebProxy [True|False]—Sets the UseDefaultWebProxy attribute. The default 
value is False. 

• REMOVE—Removes the current proxy settings. 

• DISPLAY—Displays the current proxy settings. 

Exit codes: 

• 0—Success. 

• 1—Command line argument is missing. 

• 2—Invalid command on command line. 

• 3—An exception occurred during processing. 

Note: If exit code 3 appears, contact Oracle Support. 
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About performance reports 
The Central Coding software installation includes an executable file that gathers coding data, and a 
Microsoft Excel spreadsheet template that uses the data to create reports for analysis and 
troubleshooting assistance. You can produce data for a specified set of studies, for the entire system, 
or a combination of both options, according to the parameters you set when running the utility. 

To produce the performance reports, you must have server-level access. If you do not have access to 
the Central Coding server for your studies, please contact Oracle for assistance. 
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Generating performance reports 
To generate performance reports: 

1 Run a script to gather study or system data, which is compiled into a CSV file.  

For more information, see Gathering data for performance reports (on page 95). 

2 Create histograms from the data in a Microsoft Excel spreadsheet. 

For more information, see Generating performance reports in Microsoft Excel (on page 95). 
 

Gathering data for performance reports 
1 Open a Command Prompt window and enter the name of the drive in which the executable file 

is installed. 

2 Enter the location of the executable file in the drive you specified: 

<Installation Folder>\CentralCodingServer\CodingWebUI\Utilities\UsageCharts 

3 Run PhaseForward.CentralCoding.CreateUsageCharts.exe, using the following syntax: 

PhaseForward.CentralCoding.CreateUsageCharts.exe [dbUser] [UsageType] 
[csvFileDirectory] [TrialList] 

In the command syntax: 

• dbUser—Central Coding Database user ID. 

• UsageType—The type of data to compile and display in Microsoft Excel. 

• DAILYUSAGE—Produce reports for data from one or more specified studies. 

• SYSTEMSUMMARY—Produce reports for data from the entire system. 

• BOTH—Produce separate reports for individual studies, and reports for the system as a 
whole. 

• csvFileDirectory—The directory in which you want to store the CSV data file. 

• TrialList—For DAILYUSAGE or BOTH usage type, the list of studies for which to 
produce the reports. 

• For one study, specify the study name. 

• For more than one study, list the study names in quotation marks, separated by commas 
(for example, "PFST50, PFSTCardio"). 

4 When prompted for a password, enter the Central Coding Database user password. 

The utility produces a CSV file that you open in Microsoft Excel. 
 

Generating performance reports in Microsoft Excel 
1 Navigate to the Central Coding installation folder. 

2 Open the UsageCharts.xlsm file. 
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A Microsoft Excel spreadsheet opens. 

3 Click the Data tab. 

4 In the Get External Data section of the ribbon, click From Text. 

The Import Text File dialog box appears. 

5 Navigate to the directory you specified for the csvFileDirectory parameter. 

6 Click Import. 

The Text Import Wizard - Step 1 of 3 dialog box appears. 

7 Click Next. 

8 Select the Tab and Comma delimiters, and click Next. 

9 Click Finish. 

The Import Data dialog box appears. 

10 Select Existing worksheet and specify that you want to put the data in cell A1. 

11 Click OK. 

The worksheet is populated with the data from the CSV file. 

12 Click the Process Usage Data button. 

Note: You may need to scroll to the right in order to see the button. 

It may take several minutes to process the data. 
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Performance report descriptions 
The following table describes daily usage reports: 

 

Tab Name Report Name Description 
<StudyName> Daily Tally of <StudyName>'s 

Verbatim Traffic 
For the specified study, the number of 
verbatims that were received, delivered, 
undelivered, or deleted each day, from the 
beginning of the study. 

<StudyName> Total Number of Verbatims in 
<StudyName> Measured Daily 

For the specified study, the total number of 
verbatims that existed and the total number 
of verbatims that were delivered each day, 
from the beginning of the study. 

 

The following table describes System summary reports: 
 

Tab Name Report Name Description 
Days of Activity Days of Activity For each study in the system, the number of 

days during which preprocessing occurred, 
verbatims were received, and verbatims 
were returned to the source application. 

Trial Running Days Trial Running Days The duration of each study in the system, in 
days. 

Verbatim and 
Transaction Counts 

Verbatim and Transaction 
Counts 

For each study in the system, the number of 
verbatims that exist, the number of 
deletions that occurred, the number of 
times a verbatim was received by the 
Central Coding application, and the largest 
number of times a single verbatim was 
received by the Central Coding application. 

Percentage of 
Activity 

Percentage of Activity During 
Trial Up-Time 

For each study in the system, the percentage 
of time taken for preprocessing, receiving 
verbatims, and returning verbatims to the 
source application. 

Each percentage is calculated based on a 20-
hour day, allowing for 4 hours of system 
inactivity. The number of hours per day is a 
configurable setting in Microsoft Excel. 
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Tab Name Report Name Description 
Verbatim 
Throughput 

Number of Verbatims 
Processed per Hour over a 
Day 

The maximum and the average number of 
verbatims processed in one hour. This data 
is calculated based on a 20-hour day and 
normalized to one hour. 

This data is displayed in two graphs. The 
first graph is organized by system, and the 
second graph displays the data for each 
study in the system. 

Percentage 
Autocoded 

Percentage of Verbatims 
Autocoded 

For each study in the system, the percentage 
of verbatims that were autocoded. 

Active Trials Active Trials shown with 
Median Verbatims Received 
per Day 

The number of studies in the system on any 
given day, and the corresponding median 
number of verbatims received on that day. 

Verbatim Trial Size Size of Trial by # of 
Verbatims 

The number of verbatims in each study, and 
the percent of total verbatims in the system 
to which it corresponds. 

Histograms Preprocess Median/Active 
Day 

The median number of verbatims that were 
preprocessed in a day, and the number of 
studies that fall into each category. 

Preprocess Average/All Days The average number of verbatims that were 
preprocessed in a day, and the number of 
studies that fall into each category. 

Return Median/Active Day The median number of verbatims that were 
returned to the source application in a day, 
and the number of studies that fall into each 
category. 

Return Average/All Days The average number of verbatims that were 
returned to the source application in a day, 
and the number of studies that fall into each 
category. 

Receive Median/Active Day The median number of verbatims that were 
received in the Central Coding application 
in a day, and the number of studies that fall 
into each category. 

Receive Average/All Days The average number of verbatims that were 
received in the Central Coding application 
in a day, and the number of studies that fall 
into each category 

Verbatim Trial Size The number of verbatims in the system, and 
the number of studies that fall into each 
category. 
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Analyzing tables and indexes for performance 
Oracle recommends analyzing all tables and indexes for better performance. You should perform this 
analysis whenever a significant amount of coding data is entered. To help analyze tables and indexes, 
Oracle recommends that you run the following Oracle database utilities: 

• dbms_utility.analyze_schema—Run this utility as the Central Coding application schema 
owner. 

This utility updates the Oracle system tables that are used to perform analysis on a schema. 

• dbms_utility.analyze_schema—Run this utility to update the Oracle system tables for the 
Central Coding database. 
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Installation failure due to error accessing product user 
profile 

If an error occurs during installation indicating that the PRODUCT_USER_PROFILE table cannot 
be accessed, run PUPBLD.SQL as SYSTEM and then start the installation again. 
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Changing the execution timeout value 
The execution timeout value determines the number of seconds the Central Coding application waits 
to receive information from the InForm application. The Central Coding installation program sets 
the default value to 900 seconds.  

If you consistently receive the Request timed out error message, you can change the value for 
executionTimeout in the web.config file. The file is available in <Installation 
Folder>\CentralCodingServer\CodingWebUI. The following shows a sample web.config file. 

<httpRuntime executionTimeout="900" maxRequestLength="4096" 
useFullyQualifiedRedirectUrl="false" 
minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100" 
enableVersionHeader="true" /> <!-- compilation Attributes: 
tempDirectory="directory" 
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Changing the transaction timeout value 
If an error occurs when you are importing a large synonym file or when running the Code and 
Propagate action, increase the transaction timeout value for the Microsoft Distributed Transaction 
Coordinator (MS DTC). 

1 Select Start > All Programs > Administrative Tools > Component Services.  

2 Expand Component Services. 

3 Expand Computers.  

4 Right-click My Computer and select Properties. 

5 Click the Options tab.  

6 Set the Transaction timeout (seconds) to 300 or more, and click Apply.  

7 Click OK. 
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Changing the number of matched terms that display in the 
coding browser 

In the Coding Browser dialog box—Search mode, the Return All Matches checkbox indicates 
whether you want all the matched terms found to display in the browser. By default, the coding 
browser displays 200 matches. This number, and whether this option is available, is set by your 
administrator. 

The CodingPlatform.config file, located in <Installation 
Folder>\CentralCodingServer\CodingWebUI\bin\config, contains the following section (these are 
the default values the Central Coding application ships with): 

<CodingBrowserSettings> 
<QuickRowLimit>200</QuickRowLimit> 
<AllowReturnAllMatches>true</AllowReturnAllMatches> 
<HardRowLimit>500</HardRowLimit> 

</CodingBrowserSettings> 
 
In the file: 

• QuickRowLimit—The number of matched terms to display in the browser. 

The browser displays only the number of terms specified in this setting. It does not allow you to 
page through the terms in lists. 

• AllowReturnAllMatches—Determines whether the Return All Matches option appears in the 
browser. 

If you change this setting to false, the Return All Matches checkbox does not appear in the 
coding browser, and the number of terms specified in the HardRowLimit display in the browser. 

• HardRowLimit—The number of matched terms to display in the browser when the Return 
All Matches option does not appear in the browser or if the option is not selected. 

If the QuickRowLimit is set to -1, or the Return All Matches checkbox is selected, the 
HardRowLimit determines the maximum number of matches that can be returned. 

If HardRowLimit is set to -1, all matches will be returned if the QuickRowLimit is -1 or the 
Return All Matches checkbox is selected. Oracle does not recommend setting the 
HardRowLimit to -1, as there could be thousands of possible returns. 
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About running statistics on the Central Coding application 
Oracle recommends that a database administrator run statistics on a Central Coding application if: 

• The performance of the Central Coding application is slow. 

• A timeout exception error occurs when running a large get verbatims job. 

If the job runs for a long time and a timeout exception error occurs, the ExceptionMap.xml 
file contains an entry that instructs you to ask a database administrator to gather statistics on the 
Central Coding account. 

Oracle recommends that the database administrator monitor the statistics for the account during 
the day and gather statistics if the statistics start to be out of date and the performance of the 
application slows down. 
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Cross-product issues 

Extra audit records in the Central Coding application 
 

Issue Additional audit records in the Central Coding application.  

Possible 
cause 

If you change a verbatim in the InForm application that has already been coded, 
and then change it back to what it was originally, the next time the InForm Adapter 
Coding interface delivers coding data to the Central Coding application, you will see 
additional audit records in the Audit History Report in the Central Coding 
application. This is because although the verbatim is unchanged, it is newer than its 
targets. 

Solution If you use the InForm Adapter software with the Central Coding application, you 
must: 

• Create a rule in the InForm software that is applied to every verbatim that 
clears the verbatim targets whenever the verbatim is changed. 

• Make sure the rule is case-sensitive. 

The rule ensures that the verbatim is treated as uncoded when it is delivered to the 
Central Coding application. 

 
 

Code map not found—Undeliverable requests 
Issue Codes are not returned to the InForm application and the Code map not found 

error appears in the Central Coding application for undeliverable requests when: 

• The mappings for the Central Coding application have been updated in the 
InForm application. 

• Data that is in the Central Coding application was not delivered prior to the 
mapping change.  

Possible 
cause 

When the Central Coding mappings are updated in the InForm application using 
the same RefName, the InForm application does not create a new revision for the 
mappings. Instead, the InForm application creates an entirely new set of mappings 
with new GUIDs. 

As a result, when a verbatim is recoded in the Central Coding application after the 
updated mappings are installed in the InForm application, the request is 
undeliverable from the Central Coding application. 

The Code map not found error appears when you view the hover help for a 
request with a delivery status of Undeliverable ( ) on the Coding Requests, 
Approvals, or All Requests page in the Central Coding application. 

For more information, see the User Guide. 

Solution Contact Oracle CAG. 
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Note: This issue does not affect InForm release 6.1.1 and higher. 

 

Key items not updated 
If the following key items are changed in the InForm application after a verbatim is coded, they will not 
be updated in the Central Coding application. 

Note: The key items are updated in the Central Coding application if the verbatim is not coded in 
the InForm application. 

• Subject Initials 

• Subject Number 

• Visit 

• Site Name 

• Site 

• Study 

If you want the key items to be updated, you must create a rule in the InForm application to clear the 
coding targets. 
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Where to find the product documentation 
The product documentation is available from the following locations: 

• My Oracle Support (https://support.oracle.com)—Release Notes and Known Issues. 

• Oracle Help Center (https://docs.oracle.com/en/industries/health-sciences/central-
coding/index.html)—The most current documentation set. 

Documentation accessibility 
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program 
website: http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc. 

Access to Oracle Support 
Oracle customers that have purchased support have access to electronic support through My Oracle 
Support. For information, visit http://www.oracle.com/us/support/contact/health-sciences-
cloud-support/index.html or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired. 
 

About the documentation 

https://support.oracle.com/
https://docs.oracle.com/en/industries/health-sciences/central-coding/index.html
https://docs.oracle.com/en/industries/health-sciences/central-coding/index.html
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc
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