installgrub - install GRUB in a disk partition
/usr/sbin/installgrub [-fm] stage1 stage2 raw-device
The installgrub command is an x86–only program. GRUB stands for GRand Unified Bootloader. installgrub is deprecated, as it applies to the GRUB Legacy boot loader, which was the boot loader present in Oracle Solaris 11 11/11 and earlier revisions. To install the boot loader, see the bootadm(1M) install-bootloader subcommand.
installgrub installs GRUB Legacy stage 1 and stage 2 files on the boot area of a disk partition. If you specify the –m option, installgrub installs the stage 1 file onto first sector (the master boot sector [MBR]) of the disk.
The installgrub command accepts the following options:
Suppresses interaction when overwriting the master boot sector.
Installs GRUB stage1 on the master boot sector interactively. You must use this option if Solaris is installed on an extended partition.
The installgrub command accepts the following operands:
The name of the GRUB stage 1 file.
The name of the GRUB stage 2 file.
The name of the device onto which GRUB code is to be installed. It must be a character device that is readable and writable. For disk devices, specify the slice where the GRUB menu file is located. (For Solaris it is the root slice.)
The following command installs GRUB on a system where the root slice is c0d0s0:
example# /usr/sbin/installgrub /boot/grub/stage1 \ /boot/grub/stage2 /dev/rdsk/c0d0s0
Directory where GRUB files reside.
See attributes(5) for descriptions of the following attributes:
Installing GRUB on the master boot sector (–m option) overrides any boot manager currently installed on the machine. The system will always boot the GRUB in the Solaris partition regardless of which fdisk partition is active.
Do not use the installgrub command to install the boot loader on systems that have GRUB 2 installed, otherwise you can render the system unbootable. GRUB Legacy should be reinstalled with the installgrub command only after you have verified that the version of GRUB Legacy you are installing supports the ZFS pool version of your ZFS root pool, and that you no longer have any Solaris boot environments present that use GRUB2 as their boot loader. If the system is using GRUB 2, then use the bootadm install-bootloader command to install the GRUB 2 bootloader. For more information, see the bootadm(1M) man page.
This command might be obselete and will be removed from a future release of Oracle Solaris.