ypinit - set up NIS client
/usr/sbin/ypinit [-c] [-m] [-s master_server]
ypinit can be used to set up an NIS client system. You must be the superuser to run this command. This script need not be used at all if ypbind(1M) is started with the –broadcast option (it is invoked with this option from the svc:/network/nis/client:default service).
Normally, ypinit is run only once after installing the system. It may be run whenever a new NIS server is added to the network or an existing one is decommissioned.
ypinit prompts for a list of NIS servers to bind the client to; this list should be ordered from the closest to the furthest server. It is recommended that you list each of these NIS servers by name and numeric IP address in /etc/hosts. Though the practice is not recommended, NIS allows you to list servers by numeric address only, bypassing /etc/hosts. In such a configuration, ypwhich(1) returns a numeric address instead of a name.
ypinit stores the list of servers to which a client can bind in the file /var/yp/binding/domain/ypservers. This file is used by ypbind when run without the –broadcast option.
NIS client configuration is managed in Location profiles (refer to netcfg(1M) for more information about location profiles). These profiles are either fixed, meaning the network configuration is being managed in the traditional way, or reactive, meaning the network configuration is being managed automatically, reacting to changes in the network environment according to policy rules specified in the profiles.
When a fixed location (there can currently be only one, the DefaultFixed location) is active, changes made to the SMF repository will be applied to the location when it is disabled, and thus will be restored if that location is later re-enabled.
When a reactive location is active, changes should not be applied directly to the SMF repository; these changes will not be preserved in the location profile, and will thus be lost if the location is disabled, or if the system's network configuration, as managed by svc:/network/physical:default and svc:/network/location:default, is refreshed or restarted. Changes should instead be applied to the location itself, using the netcfg(1M) command; this will save the change to the location profile repository, and will also apply it to the SMF repository (if the change is made to the currently active location).
NIS client configuration is stored the default-domain and nis-nameservice-servers properties of a location profile.
Set up a ypclient system.
Build a master ypserver data base.
Slave data base. master_server must be the same master configured in the YP maps and returned by the ypwhich –m command.
File in which it is recommended that NIS servers be listed.
Lists the servers to which the NIS client is allowed to bind.
See attributes(5) for descriptions of the following attributes:
The NIS client service is managed by the service management facility, smf(5), under the service identifier:
ypinit sets up the list of NIS servers only for the current domain on the system when it is run, that is, the domain returned by the SI_SRPC_DOMAIN command to sysinfo(2). Care should be taken to ensure that this is the same as the desired domain for NIS client processes.