nfsref - NFS referral utility
nfsref [-t svc_type] add path location [location ...]
nfsref [-t svc_type] remove path
nfsref [-t svc_type] lookup path
The nfsref command manages NFS Version 4 referrals, which are server-side pointers used to redirect clients to actual locations of file systems. Referrals are based on reparse points (see reparsed(8) and libreparse(3LIB)). The path arguments in all forms of the synopsis refer to the path to the reparse point symbolic link. This command currently implements one service type: nfs-basic, which embeds location information within the reparse point.
The first form of the command, nfsref add, creates a referral pointing to the specified locations. If a reparse point does not exist, one is created. If it does exist, NFS service data is added or replaces existing NFS service data. Each location has a host :/path format. The path can contain spaces, which must be escaped to ensure proper shell parsing.
The second form of the command, nfsref remove, removes an NFS referral. It removes NFS service data from the specified reparse point, and removes the reparse point if there are no other types of service data present.
The third form of the command, nfsref lookup, displays the locations to which the specified NFS referral points.
The following options are supported:
Specify a service type. Currently, only nfs-basic is supported.
The following command creates an NFS referral at the server path /pool/home/bob, pointing to the resource homeserver:/homepool/bob.
# nfsref add /pool/home/bob homeserver:/homepool/bob Created reparse point /pool/home/bob # nfsref lookup /pool/home/bob /pool/home/bob points to: homeserver:/homepool/bobExample 2 Removing an NFS Referral
The following command removes an NFS referral at the server path /pool/home/bob.
# nfsref remove /pool/home/bob Removed svc_type 'nfs-basic' from /pool/home/bob
An error occurred.
Per-service plugins for reparsed.
See attributes(7) for descriptions of the following attributes: