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License: Apache 1.1

Module: Crimson v1.1.1, Xalan J2

Copyright © 1999-2000 The Apache Software Foundation. All rights reserved.

Use of Crimson 1.1.1 and Xalan J2 within the product is governed by the following (Apache 1.1):

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) The end-user documentation included with the redistribution, if any, must include the 
following acknowledgment: “This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/) .”  Alternately, this acknowledgment may appear in the software itself, if and 
wherever such third-party acknowledgments normally appear. (4) Neither the component name nor Apache 
Software Foundation may be used to endorse or promote products derived from the software without specific 
prior written permission. (5) Products derived from the software may not be called “Apache”, nor may 
“Apache” appear in their name, without prior written permission.

THIS SOFTWARE IS PROVIDED “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, 
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PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

License: CoolServlets.com
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Copyright © 1999 by CoolServlets.com
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disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor Coolservlets.com may be used to endorse or promote 
products derived from the software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY COOLSERVLETS.COM AND CONTRIBUTORS “AS IS” AND 
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."

License: Justin Frankel, justin@nullsoft.com

Module: NSIS 1.0j (Sun JRE Component)

Use of this module within the product is governed by the following:

(1) The origin of the module must not be misrepresented, and Oracle may not claim that it wrote the original 
software. If Oracle uses this module in a product, an acknowledgment in the product documentation is 
appreciated but not required. (2) Altered source versions of the module must be plainly marked as such, and 



must not be misrepresented as being the original software. (3) The following notice may not be removed or 
altered from any source distribution: “Justin Frankel  justin@nullsoft.com”.

License: ICU4j License

Module: ICU4j

Copyright © 1995-2001 International Business Machines Corporation and others. All rights reserved.

Oracle may use the software without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, and/or sell copies of the software, and to permit persons to whom the software is 
furnished to do so, provided that the above copyright notice and the permission notice appear in all copies of 
the software and that both the above copyright notice and the permission notice appear in supporting 
documentation.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY 
RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS 
NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL 
DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 
PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS 
ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS 
SOFTWARE. 

License: Info-ZIP

Module: INFO-ZIP ZIP32.DLL (Binary Form)

Copyright (c) 1990-2005 Info-ZIP.  All rights reserved

Use of this dll within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
definition and disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, 
this list of conditions and the definition and disclaimer below in the documentation and/or other materials 
provided with the distribution. The sole exception to this condition is redistribution of a standard UnZipSFX 
binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this 
license, as long as the normal SFX banner has not been removed from the binary or disabled. (3) Altered 
versions--including, but not limited to, ports to new operating systems, existing ports with new graphical 
interfaces, and dynamic, shared, or static library versions--must be plainly marked as such and must not be 
misrepresented as being the original source. Such altered versions also must not be misrepresented as being 
Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names “Info-ZIP” (or 
any variation thereof, including, but not limited to, different capitalizations), “Pocket UnZip,” “WiZ” or 
“MacZip” without the explicit permission of Info-ZIP. Such altered versions are further prohibited from 
misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s). (4) Info-ZIP 
retains the right to use the names “Info-ZIP,” “Zip,” “UnZip,” “UnZipSFX,” “WiZ,” “Pocket UnZip,” “Pocket 
Zip,” and “MacZip” for its own source and binary releases.

[Definition]: For the purposes of this copyright and license, “Info-ZIP” is defined as the following set of 
individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed 
Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul 
Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio 
Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven 
M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White

[Disclaimer:] “This software is provided “as is,” without warranty of any kind, express or implied. In no event 
shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential 
damages arising out of the use of or inability to use this software.”

License: Paul Johnston

Modules: md5.js

Copyright (C) Paul Johnston 1999 - 2002

Use of these modules within the product is governed by the following:



(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the names of the copyright holders and contributors may be 
used to endorse or promote products derived from the software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

License: Jef Poskanzer

Modules: DES, 3xDES (Sun JRE Components)

Copyright © 2000 by Jef Poskanzer <jef@acme.com>. All rights reserved

Use of these modules within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the name of Jef Poskanzer may be used to endorse or 
promote products derived from the software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

License: Sun Microsystems, Inc. 

Modules: Sun Swing Tutorials

Copyright© 1995-2006 Sun Microsystems, Inc. All Rights Reserved.

Use of these modules within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the name of Sun Microsystems, Inc. and contributors may 
be used to endorse or promote products derived from the software without specific prior written permission. 
(4) Oracle must acknowledge that the software is not designed, licensed or intended for use in the design, 
construction, operation or maintenance of any nuclear facility.

THIS SOFTWARE IS PROVIDED “AS IS,” WITHOUT A WARRANTY OF ANY KIND. ALL EXPRESS 
OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY 
IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR 
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. (“SUN”) AND ITS 
LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A 
RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES. 
IN NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT 
OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR 



PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF 
LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE, EVEN IF 
SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

License: Tom Wu

Module: jsbn library

Copyright © 2003-2005 Tom Wu. All rights reserved

Use of this module within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, 
IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL TOM 
WU BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES 
OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 
PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY 
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR 
PERFORMANCE OF THIS SOFTWARE.
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Chapter 1
Introduction to Oracle Utilities Billing

Component

This chapter provides an overview of Oracle Utilities Billing Component, including:

• The Billing Process

• How Do You Work with Oracle Utilities Billing Component?

• International and Multiple Currency Support

• Oracle Utilities Billing Component Documentation Overview

Important Note
Before you can use Oracle Utilities Billing Component or any of its functions, you must first make 
sure that appropriate data and records have been created in the Oracle Utilities Data Repository. 
The instructions in this manual assume that these records exist. For more information about 
creating, updating, or editing records in the Oracle Utilities Data Repository, see the Data Manager 
User’s Guide.
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The Billing Process
The Billing Process
The primary function of Oracle Utilities Billing Component is to calculate customer charges, 
regardless of their complexity, and pass the results to either a CIS system that issues and records 
the actual bills, or to a stand-alone billing system.

While the specifics will vary at your facility, depending upon your goals, policies, and the types of 
hardware and software with which the system must interface, a typical billing process with Oracle 
Utilities Billing Component runs something like this.

Each business day, usage data is collected for a portion of your power billing customers. The 
customers are grouped according to billing cycles or specific bill dates. The bill date is noted in the 
Billing Cycles table in the Oracle Utilities Data Repository and used as a “trigger” for initiating the 
billing process.

There are two types of usage data that can be used to measure and bill a customer’s energy 
consumption:

• Billing determinants: A billing determinant is typically a scalar measure of a customer’s 
electricity or gas consumption that is represented by one value for a given bill period—for 
example, a customer might have used a total of 230 kWh of energy during a given month, and 
its highest demand during that month might have been 10 kW. Both 230 kWh and 10 kW are 
potentially scalar values for bill determinants that could be used to calculate the customer’s 
bill for April.

• Interval data: Interval data (also called “time-series data”) measures a quantity such as 
demand, energy, voltage, or temperature at regular intervals — such as every 5, 10, 15, or 60 
minutes. So, rather than having just one value for a determinant for given period, there can be 
many values. For example, a 31-day month of 15-minute interval data consists of 2,976 values. 
Interval data is important because it can measure the demand that the customer places on the 
system at any given moment — and therefore provides a much more accurate picture of how 
much it actually costs to serve the customer.

Interval data is recorded at a customer’s location by a special interval data recorder, which 
has one or more data recording channels. The utility assigns each channel to measure a 
different end use or other quantity of interest. A record that contains the interval values for 
one recorder-channel for one recording period is called a cut. The end of a cut is its read date 
and time; its beginning is the end of the previous cut. The boundaries of a cut are also 
referred to as the cut’s start-date and -time, and stop-date and -time. Cuts for the same 
account but from different recorders may have different stop dates and times, and the periods 
covered by the cuts may or may not correspond to the dates of the bill period. However, once 
set up properly, Oracle Utilities Billing Component automatically determines the correct 
interval values and if they are available, synchronizes them to the bill period.

A customer may be billed using just interval data, or just billing determinants, or a combination of 
both, depending upon its rate code or contract with the utility.

Every time billing is triggered, Oracle Utilities Billing Component checks the Oracle Utilities Data 
Repository for accounts that are ready to be billed. The system uses the following criteria for 
“billable” accounts:

• First, Oracle Utilities Billing Component gathers a list of all accounts that are eligible for 
billing. An account is “eligible” if the scheduled read date falls within a user-defined window 
of time that extends some number of days before and after the account's scheduled read date. 
An account’s scheduled meter read date is specified by the Billing Cycle date in its Account 
History record in the Oracle Utilities Data Repository. The default time window is defined 
using the “Prewindow” and “Postwindow” settings in Oracle Utilities Billing Component 
Default Billing Options. It is also possible to specify the size of the Prewindow and 
Postwindow for rate codes or even individual accounts or recorders in the Oracle Utilities 
Data Repository.
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The Billing Process
• If an account is deemed eligible, Oracle Utilities Billing Component then determines whether 
or not it is available. An account is “available” if all data required to compute its bill for the 
current bill period is ready. Oracle Utilities Billing Component checks for three types of data 
— bill determinant values, interval data, and special events values and dates.

• Bill Determinants: Oracle Utilities Billing Component checks the account’s Bill 
Determinant Use record(s) to find which, if any, bill determinants are required for computing 
the bill. For each bill determinant that is required, Oracle Utilities Billing Component looks in 
the account’s Bill History record for a value for the current scheduled read date.

• Interval Data: Oracle Utilities Billing Component also checks each account’s Channel 
History records to find whether any recorder-channels assigned to measure interval data for 
the account are to be used for billing. For each channel assigned to measure billable interval 
data, Oracle Utilities Billing Component looks for a cut with a stop-date and stop-time that 
falls within the corresponding recorder’s eligibility window around the scheduled read date.

• Special Events: An account may have agreed with the utility to pay a different rate for the 
energy that it consumes during a “special event” — for example, a standby period, 
maintenance period, system peak, and so on. For every eligible account, Oracle Utilities 
Billing Component checks its Account Override Use records in the Oracle Utilities Data 
Repository to determine whether the account might be subject to any special events pricing. 
If any special events are potentially applicable to the account and require validation, Oracle 
Utilities Billing Component checks the account’s Override Ready record to ensure that a 
Billing Analyst has input the actual dates and values for each event that did occur during the 
bill period, or (alternatively) specified that no events occurred.

If Oracle Utilities Billing Component finds that any required data is still missing for an eligible 
account on the day after the post-window, the system puts a “system rejected” note in the 
account’s Account Note record in the Oracle Utilities Data Repository. Nothing further happens 
until a billing analyst reviews and corrects the problems.

If all the data required to bill an account is ready, Oracle Utilities Billing Component calculates the 
bill. The system first finds the applicable rate schedule (associated with the account via the rate 
code stored in the Account Rate Code History record). The system then calculates the account’s 
charges for the bill period by applying the appropriate tariffs (encoded in rate forms using the 
Oracle Utilities Rules Language) and any special event overrides to the account’s usage data.

After Oracle Utilities Billing Component calculates the charges, it writes the results to a file that 
has a user-specified name and location. As Oracle Utilities Billing Component continues to 
process bills for customers, it appends each new “transaction record” to the end of the file. 
Periodically, this file can be processed by other applications. Typically when this happens, the file is 
renamed. When Oracle Utilities Billing Component finds that the file it had been using no longer 
exists, it creates a new one with the original name, and resumes writing transaction records to it.

If specified in the rate form, Oracle Utilities Billing Component also saves the data to the Oracle 
Utilities Data Repository.
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How Do You Work with Oracle Utilities Billing Component?
How Do You Work with Oracle Utilities Billing Component?
Much of the billing process can occur automatically without user intervention. However, to ensure 
that bills are produced accurately and on time, and to accommodate the unique needs of special 
customers, Oracle Utilities Billing Component requires some manual data entry and monitoring, 
and allows for customer’s whose bills require manual review.

The following describes the tasks that billing analysts would typically perform every day with 
Oracle Utilities Billing Component:

Review Billing Checklist
As described in the previous section, Oracle Utilities Billing Component requires three sets of 
values that change from month to month to determine a bill—interval data, bill determinant 
values, and special events times and values. Since accurate data does not always come from the 
field as expected, it is recommended that you make it a part of your daily routine to apply Oracle 
Utilities Billing Component’s Review Billing Checklist module to one day’s set of eligible accounts. 
This report pinpoints any problems with the required data, such as a missing or incomplete cut. 
To ensure that bills are produced on time, you should apply the checklists one or two days prior to 
the accounts’ actual bill date. In that way, you have some time to correct any problems before the 
bills are due to be issued. See Chapter 4: Review Billing Checklist for more information.

Enter Special Events
 Required. As described earlier, Oracle Utilities Billing Component computes billing charges by 
applying the tariffs encoded in rate forms (using the Oracle Utilities Rules Language) to the 
customer’s usage data. There can be circumstances (e.g., “special events”) when other billing rules 
and values should override the standard tariffs. Before Oracle Utilities Billing Component can 
calculate an account’s charges for a bill period, a billing analyst must manually enter the dates and 
values for each special event that applied to the account during the bill period. Even if no special 
events took place, the billing analyst must still make a note to that effect in the account’s Override 
Ready record. Chapter 6: Setting Up and Applying Overrides and Special Events in the Oracle 
Utilities Billing Component Installation and Configuration Guide, Volume 1 explains how to define a special 
event in the Oracle Utilities Data Repository, and how to add the actual dates and values for each 
occurrence.
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Process Customer/Account Bills
Oracle Utilities Billing Component offers several different ways of processing customer/account 
bills. Each is briefly described below.

Automatic Billing
Some accounts and customers can be billed in “automatic” mode, meaning that once Automatic 
Billing is activated, the program scans the database for these accounts and determines if they are 
“ready” to be billed (see The Billing Process on page 1-2). Accounts that are ready to be billed 
are processed automatically, and if billing is successful, their transaction records are automatically 
written to the CIS file. See Chapter 5: Automatic Billing for more information.

Note: In most cases, Automatic Billing is configured to run on a scheduled 
basis on either a dedicated machine or an application server.

Approval Required
In some cases (such as accounts that have especially complex tariffs or other special needs) it may 
be advisable for a Billing Analyst to review the results of the successful bill calculations before the 
transactions records are passed to the output file. These accounts are flagged “Approval Required” 
and are processed using Approval Required billing.

Approval Required billing applies the same concepts of “eligible” and “available” and performs 
the calculations according to the Billing Cycle schedule as described in The Billing Process on 
page 1-2. However, unlike Automatic Billing which runs continuously without user intervention, 
you must explicitly start Approval Required billing. Also, it does not automatically write the 
transaction records or update the Bill History records when the calculations are complete. Instead, 
Oracle Utilities Billing Component displays an on-screen bill report that enables you to review the 
calculations and accept or reject the results. When you’ve approved the bills they are passed to the 
output file and updated in the Bill History records.   See Chapter 6: Approval Required Billing 
for more information.

 Current/Final Bill
Current/Final Bill gives you greater flexibility in the billing process by allowing you to override 
some of the rules built into the automatic and approval required modes. Specifically, you can issue 
a bill:

• on-demand — that is, on a date other than its normal, automatic issue date (billing cycle 
date). This is particularly useful for creating preliminary bills for a customer’s approval prior 
to issuing the actual bill.

• despite missing data.

• for a user-specified period of time.

You can also specify that a bill is a final bill—in which case Oracle Utilities Billing Component 
automatically writes a stop date to the Account Table in the Oracle Utilities Data Repository when 
the bill is approved. This effectively closes the account as far as Oracle Utilities Billing Component 
is concerned. See Chapter 7: Current/Final Bill for more information.

Bill Correction
In case a billing analyst or customer finds a problem with a previously-issued bill, this feature 
enables you either to cancel the old bill and issue a new one in its place, or to address the problem 
by adjusting the current bill. See Chapter 9: Bill Corrections for more information.

Late Bills
This report tracks interest lost on bills that were issued late, or are pending and will be late. See 
Chapter 10: Problem Bills and the Late Bill Report for more information.
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Mass Billing
This allows you to process bills for accounts that are eligible for mass billing. See Mass Billing on 
page 8-18 in the Oracle Utilities Billing Component Installation and Configuration Guide, Volume 1 for 
more information.

Review Billing Exceptions
Each day, a billing analyst should run the “Review Billing Exceptions and Rejections” report to 
verify that all accounts (in particular “automatic” accounts) processed as expected. This report 
lists any accounts that were not billed, and why. See Chapter 8: Review Billing Exceptions for 
more information.

Trial Bill Calculation
The Trial Bill Calculation function calculates a bill for a selected account and rate schedule over a 
user-defined period of time, but it does not write transaction records to the output file. Trial Bill 
also will not save any data to any Oracle Utilities databases (unless otherwise specified in the 
Advanced options). This module is useful for testing the setup of a new customer, training new 
users, and testing a customer on a new rate. In addition, the module’s Single Step Analysis feature 
displays the results of a bill calculation for an account and bill month, line by line in the rate 
schedule. This feature is useful for explaining charges to a customer, for debugging a rate form, 
and for “what-if” analysis -- that is, to demonstrate the impact of a different bill determinant value 
on the customer’s bill. See Chapter 12: Calculating Trial Bills for more information.

Reports
In addition to the various billing modules, Oracle Utilities Billing Component features several 
reports that you can use to examine billing data in the Oracle Utilities Data Repository. They 
include the Special Events, Bill History, Late Billing, Top Accounts, and Rider Summary reports, 
as well as other reports customized for your utility. See Chapter 11: Other Reports for more 
information.

Running Billing in Batch Mode
You can also run billing in batch mode, using the Oracle Utilities Billing Component batch 
executable programs. See Chapter 8: Setting Up Billing to run in Batch Mode in the Oracle 
Utilities Billing Component Installation and Configuration Guide, Volume 1 for more information.
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International and Multiple Currency Support
This section outlines international and multiple currency support in the Oracle Utilities Energy 
Information Platform, including:

• Locales and Languages

• Date and Numeric Presentation

• Currency Presentation

• Multiple Currency Support

• File Formats

• Database Support

Locales and Languages
Two fundamental concepts underlying international support in Oracle Utilities applications are 
languages and locales. Languages determine the specific language in which text labels and 
controls of an application appear. Locales determine the specific region or country in which the 
user is working. Specifically, locales are used to specify display and input formatting for:

• Date/time and numeric presentation, and

• Currency presentation

How a user selects a language and/or locale is determined by the type of application being used.

Web-enabled Products
For web-enabled products, a user’s locale and language are selected from the Locales tab of the 
Set Preferences screen. The selected locale and language are stored in the user’s security 
properties. The available locales on this screen are specified in the LOCALES.CFG.XML 
configuration file (see Chapter 2: Configuration Files in the Oracle Utilities Energy Information 
Platform Configuration Guide for more information). Locales included in the LOCALES.CFG.XML 
file must also be installed on the web server and be accessible from the Regional Settings Control 
Panel. If a selected locale is not installed on the web server, currency formatting and presentation 
may be incorrect.

If a user does not select a locale (or selects a locale of “None”), the default locale is the Server 
System Locale (defined by the operating system installed on the web server). Oracle Utilities 
recommends that all users specify a locale before using internationalized applications.

Client/Server Products
For client/server products, the user’s locale is determined by the Regional Settings of the client 
and/or application server machine.

Languages
The language for client/server products is specified using a command line switch and/or a 
parameter in the LODESTAR.CFG file. See Oracle Utilities Application Command Line 
Parameters on page 4-11 in the Oracle Utilities Energy Information Platform Installation Guide for more 
information about command line parameters. See LODESTAR.CFG on page 2-2 in the Oracle 
Utilities Energy Information Platform Configuration Guide for more information about the 
LODESTAR.CFG file. At this time, available languages include English, French, German, and 
Italian.
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Reports
For client/server applications, the locale for reports is determined by the Regional Settings of the 
machine on which the report is run.

For web-enabled applications, the locale for reports is based on the Server System Locale (defined 
by the operating system installed on the web server)

Languages
For client/server applications, the language that appears on reports is determined by the language 
of the application that generated the report, specified either by a command line parameter or a 
configuration file parameter.

For web-enabled applications, the language is specified by the Regional Settings  of the machine 
on which the report is run, unless overridden by the LANGUAGE parameter in the 
LODESTAR.CFG file.

Date and Numeric Presentation
The display and input of dates and numbers is based on the selected locale.

Web-enabled products
Display formatting of both numbers and date/times is based on the user's selected locale.

Copy, cut, and paste operations are supported for all input controls. Required fields are identified 
by asterisks. Null values are represented by blank (empty) controls. Moving the mouse pointer 
over an input area displays sample formatting for that field.

Number input controls only accept formatting based on the user's selected locale. The only 
allowable characters include digits, decimal separator, and minus sign. Any other characters are 
filtered from input.

Date input controls only accept formatting based on the user's selected locale. Dates can either be 
keyed in or selected from a pop-up calendar control. All times are keyed in and based on 24 hour 
format (no AM or PM indicator).

Input validation occurs upon data entry.

Client/Server Products
Formatting for numbers and date/times is based on the locale determined by the regional settings 
of the client and/or application server machine. Date/time formatting can be overridden from the 
General Options tab of the Default Options dialog.

Reports
Display formatting of both numbers and date/times for reports is based on the Server System 
Locale on the machine on which the reports are run.

Currency Presentation
Currency information is stored in the LSCurrency table in the Oracle Utilities Data Repository. 
This table contains one or more currencies, each defined by a currency code, currency symbol, and 
formatting rules (such as the number of decimal places). Currency codes in this table use ISO-
4217 codes. The LSCurrency table also indicates the Default currency for the database. See 
LSCurrency on page 3-3 in the Oracle Utilities Energy Information Platform Configuration Guide for 
more information about setting up the LSCurrency table.

Note: Although records in the LSCurrency table are not required, Oracle Utilities strongly 
recommends that at least one record with all properties specified be created and set as “Default”. 
This will ensure consistent display of currency information.
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Currency Presentation in Oracle Utilities Receivables Component and Oracle 
Utilities Quotations Management

Currency input and display is identical to that for numbers with two exceptions: 

• A currency indicator is also displayed next to currency input controls and currency displays. 
The specific currency symbol displayed and the manner in which currency is formatted are 
determined in the following order:

a. The currency associated with the account being viewed (from the LSCurrency field in 
the Account table).

b. The default currency in the LSCurrency table. If there is no default currency, the first 
record in the LSCurrency table (sorted alpha-numerically by Currency Code).

b. If the LSCurrency table is not present or does not contain any records, the currency and 
formatting of the Server System Locale (defined by the operating system installed on the 
web server),specified in the HKEY_USERS\.DEFAULT\Control 
Panel\International key in the Windows Registry on the web server.

• Currency formatting rules for the user's selected locale are overridden if specific formatting 
rules for the currency are stored in the LSCurrency table. Typically, the only formatting rules 
that would be overridden at the currency level would be the ISO code, symbol, and number 
of decimal places. This applies to Oracle Utilities Receivables Component reports as well, 
except that the initial locale formatting rules come from the regional settings of the machine 
on which the report is run.

Currency Presentation in Other Web-enabled Products
Currently, other web-enabled products do not require input of currency values.

Display of currencies is based on the formatting of the selected locale and of the default currency 
in the database (currency specific formatting always overrides locale specific formatting).

Enabling Display of International Currency Symbols
Display of international currency symbols requires the appropriate Encoding option is selected on 
Internet Explorer.

How to select encoding options:

1. Select View-›Encoding from the Internet Explorer menu bar.

2. Select the appropriate option from the list. For example, to enable displaying of the Euro 
symbol and other Western European currency symbols, select the Western European 
(Windows) option.

Currency Presentation in Client/Server Products
Client/server products do not require input of currency values.

Display of currencies is based on the formatting of the client machine's regional settings and of 
the default currency in the database. Currency specific formatting always overrides locale specific 
formatting. If the default currency in the database does not specify any formatting, the currency 
symbol is used for formatting. If the currency table does not exist or does not contain any records 
then the default currency is determined by the Regional Settings on the client/server machine. 
This applies to reports as well.
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Multiple Currency Support
Multiple Currency Support allows for accounts with different associated currencies. This is 
accomplished through the presence of the Currency Code column on the Account, Journal 
Account, and Checking Account tables in the Oracle Utilities Data Repository. This column 
references records in the LSCurrency table

Multiple Currency and Oracle Utilities Receivables Component
All input screens which have amount fields on them indicate what currency type is expected as 
input.

All elements that represent a currency in Oracle Utilities Receivables Component XML structures 
have a CURRENCY attribute that indicates the corresponding currency type for the amount. The 
string values used for this attribute are the same as the Currency Code values in the LSCurrency 
table. On output, the CURRENCY attribute is set for the account as specified in the database. If 
the account's currency type is not specified in the database, the default currency is used.

A CURRENCY attribute (using the standard stem.tail notation) is supported for Oracle Utilities 
Receivables Component transaction identifiers to specify the currency type for the account.

On input, the CURRENCY attribute of all Oracle Utilities Receivables Component transactions is 
checked against the currency value of the account against which the transaction is being posted 
using the following rules:

1. If a currency type is specified for the account in the database, the transaction must indicate 
the same currency type or it is an error.

2. If a currency type is not specified for the account in the database, the transaction must 
indicate either no specific currency type or the default currency type for the database or it is 
an error.

All transactions that involve two or more accounts (such as Payment and Balance Transfers) 
validate that the currency types are the same for each account (no currency translation will occur). 
The credit/debit account pairs for each journal translation record are validated to ensure that they 
both have the same currency type. Only journal translation records that have credit/debit 
accounts with the same currency type as the account against which the transaction is being posted 
are used. Additional currency validations occur for payment files and refund checks.

Multiple Currency and Oracle Utilities Receivables Component Reports
Where applicable, Oracle Utilities Receivables Component reports are grouped by Currency Code.

Multiple Currency and Other Oracle Utilities Products
Oracle Utilities Billing Component, Oracle Utilities Rate Management and Data Manager reports 
display the Currency Code associated with each account where applicable. Reports that contain 
multiple currency types do not include the Summary Results page.

In Oracle Utilities Rate Management - Revenue Forecasting, the default currency type is used for 
all presentation of currency amounts, regardless of whether or not a specific currency has been 
indicated in the database for any accounts.
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File Formats

Input/Output File Formats
Numbers and date/times in input and output files (such as files used with the PLIMPORT 
program) are independent from locale settings.

Non-English characters are supported in input/output files.

XML Formats
All dates, times, and numbers contained in XML files are represented using the standard 
formatting rules as defined by the W3C XML Schema Recommendation. For backward 
compatibility, previously accepted formats for dates and times will continue to be accepted on 
input, however, all output will use the XML Schema representation.

Note: XML files created by the SAVE TO XML Rules Language statement are  
an exception. The date, time, and number formats in Rules Language generated 
XML files are based on the Rules Language configuration used to create them.

Non-English characters are supported in XML files

Database Support
In addition to the LSCurrency table and related columns in the Account, Journal Account, and 
Checking Account tables, database support for internationalization includes the addition of the 
COUNTRY column in the Address table and the change from ZIP Code to Postal Code on user 
interfaces.
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Oracle Utilities Billing Component Documentation Overview
In addition to the Oracle Utilities Billing Component User's Guide (this book), Oracle Utilities Billing 
Component comes with a number of other manuals and documents. These are described briefly 
below.

Oracle Utilities Billing Component Installation Guide
This manual describes how to install Oracle Utilities Billing Component, including software and 
database installation.

Oracle Utilities Billing Component Configuration Guide (Volume 1 & 2)
This manual describes how to configure Oracle Utilities Billing Component, including setting up 
database records, setting up billing to run in batch mode, configuring contract management, 
receivables management, and workflow management.

Oracle Utilities Energy Information Platform User’s Guide
The Oracle Utilities Energy Information Platform is the name of the features and functions 
shared by Oracle Utilities applications including Oracle Utilities Billing Component, Oracle 
Utilities Meter Data Management, Oracle Utilities Quotations Management, and others. The Oracle 
Utilities Energy Information Platform User’s Guide contains describes how you work with the Oracle 
Utilities Energy Information Platform web -user interface.

Data Manager User’s Guide
Data Manager is the tool you use to view, edit, and update records in the Oracle Utilities Data 
Repository. The Data Manager User’s Guide explains how to use Data Manager to view and maintain 
data in the Oracle Utilities Data Repository. 

Oracle Utilities Rules Language User’s Guide
The Oracle Utilities Rules Language is a powerful command language that defines business rules 
and specific items such as rate tariffs. The Oracle Utilities Rules Language User’s Guide and Oracle 
Utilities Rules Language Reference Guide describe the Oracle Utilities Rules Language and how it is 
used with Oracle Utilities products.

Oracle Utilities Energy Information Platform Installation Guide
The Oracle Utilities Energy Information Platform Installation Guide contains installation information 
related to the Oracle Utilities Energy Information Platform.

Oracle Utilities Energy Information Platform Configuration Guide
The Oracle Utilities Energy Information Platform Configuration Guide contains configuration and system 
administration information related to the Oracle Utilities Energy Information Platform.
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Chapter 2
Working with Oracle Utilities Billing Component

This chapter describes how you work with the Oracle Utilities Billing Component application, 
including:

• Starting Oracle Utilities Billing Component

• Oracle Utilities Billing Component Menus

• Oracle Utilities Billing Component Toolbar

• Default Options

• Default Billing Options

• Browsing and Viewing Account Data

• Using Online Help

• Shortcut Tips

• Saving and Applying Settings for Dialog Boxes
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Starting Oracle Utilities Billing Component
This section describes how to start the Oracle Utilities Billing Component application.

From the Windows Desktop
Depending upon how your system is configured, you can start Data Oracle Utilities Billing 
Component using one of two methods:

• Double-click the Oracle Utilities Billing Component icon, or

• Click the Start button in the lower-left corner of the Windows desktop. Then, select 
Programs-›Oracle Utilities-›Oracle Utilities Billing Component.

Depending upon your system configuration (or if an error occurs during database initialization), 
the logon screen appears.

• User Name: the user ID for the database connection*

• Password: the password for the supplied user ID*

• Data Source Name: The data source name and provider for the database, in one of the 
following formats:

For Oracle databases:

"Data Source=<data_source>;LSProvider=ODP;"

where:

• <data_source> is Oracle TNS Name from the TNS_NAMES.ora file (typically located 
in the \\<machine>\oracle\network\admin directory)

* User Name and Password are optional—if you do not supply them, the UserID defaults to your 
Windows logon ID.

When you complete the fields and click OK, the Oracle Utilities Billing Component desktop 
appears. You are now ready to begin.

From Another Oracle Utilities Application
You can also start Oracle Utilities Billing Component while working in another Oracle Utilities 
application program, such as Data Manager. From that program’s desktop, select Tools-›Oracle 
Utilities Billing Component. The Oracle Utilities Billing Component desktop appears.

Note: If Oracle Utilities Billing Component is not available on the Tools menu, 
contact your System Administrator. (Oracle Utilities Billing Component must 
be added to the *.tls files.)
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Oracle Utilities Billing Component Menus
The Oracle Utilities Billing Component menus provide access to all Oracle Utilities Billing 
Component functions, as well as to all other Oracle Utilities products installed on your system. 
The following pages describe each option on each menu.

Note: Many of the options available via the menus are also available via the 
Toolbar. If the Toolbar does not appear on your screen, select Tools-›Display 
Toolbar.

File Menu
Browse Customer/Account(s): This lets you view any information in the Oracle Utilities Data 
Repository for one or more selected accounts or customers; information is displayed via the 
browser. See Chapter Six: Browsing Data, in the Data Manager User’s Guide for a complete 
description of that tool. Also see Browsing and Viewing Account Data on page 2-22.

View-›Account: This lets you view, update, add, and delete information about a selected account 
using the Account-Centric View. See Chapter Five: The Account-Centric View, in the Data 
Manager User’s Guide for a complete description of the Account-Centric View. Also see Browsing 
and Viewing Account Data on page 2-22.

Close: Close an open report window.

Save: Not applicable to Oracle Utilities Billing Component.

Save As...: Not applicable to Oracle Utilities Billing Component.

Export: Export contents of an open report window to a file.

Print: Print contents of an open report window. See Changing the Appearance of Reports on 
page 3-13 for more information.

Exit: Close the Oracle Utilities Billing Component application.

Edit Menu
Cut: Cuts selected text and saves temporarily to the Clipboard.

Copy: Copies selected text to the Clipboard.

Paste: Pastes text from the Clipboard.

Undo: Undoes last cut, copy, or paste.

Redo: Undoes the last Undo.

Add: Add a new record to the database.

Update: Update a record in the database.

Delete: Delete a record from the database.

Note: The Add, Update, and Delete options are operable only when the 
browser window is open.

Find: This option allows you to search for a word or words in an open report window. When you 
select this option (or press F3), the Find dialog opens. See Changing the Appearance of 
Reports on page 3-13 for more information.

Find Next (Shift-F3): This option finds the next instance of the word or words last entered in 
the Find dialog.

Find Previous (Ctrl-F3): This option find the previous instance of the word or words last 
entered in the Find Dialog.
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Go To (Ctrl-G): This option opens the Go To tab on the Find dialog and allows you to go to a 
specific line in an open report window. 

Browse Account: Examine information in the Oracle Utilities Data Repository for a selected 
account using the Browser.

Note: You must first highlight an Account ID in a report in order for this 
feature to be available.

View Account: Examine information in the Oracle Utilities Data Repository for a selected 
account using the Account-Centric View.

Note: You must first highlight an Account ID in a report in order for this 
feature to be available.

Refresh Cached Tables: Refreshes the contents of tables displayed in the browser.

Font: Allows you to change the font in an open report window. See Changing the Appearance 
of Reports on page 3-13 for more information.

CIS Billing Menu
Automatic Billing: This option is available only on designated machines. Start, stop, and set parameters 
for automatic billing based on billing cycle dates. See Chapter 5: Automatic Billing for more 
information.

Approval Required: This option lets you initiate bill calculations for eligible accounts designated 
as “Approval Required.” See Chapter 6: Approval Required Billing for more information.

Current/Final Bill: This option enables you to:

• manually create a “review” copy of a bill for the customer’s approval before issuing the 
actual bill.

• issue a final bill for a closing account.

• issue a bill for a user-specified stop

• issue a bill despite missing data.

See Chapter 7: Current/Final Bill for more information about the Current/Final Bill module.

Bill Correction: This option lets you correct bill calculations, by either cancelling and re-issuing 
an old bill, or applying an adjustment to a new one. Transactions written to the output file reflect 
the re-billing and/or the cancellation. See Chapter 9: Bill Corrections for more information 
about processing bill corrections.

Review Billing Checklist: This option lets you preview the billing needs of accounts or 
customers due to be billed. See Chapter 4: Review Billing Checklist for more information 
about the billing checklist report.

Review Billing Exceptions: This option lets you review billing errors. See Chapter 8: Review 
Billing Exceptions for more information about the billing exceptions report.

Billing Options: This lets you set default options for all Oracle Utilities Billing Component 
modules and all Oracle Utilities Billing Component users. See Default Billing Options on page 
2-16 or more information about setting Billing Options.
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Analysis Menu
Trial Bill Calculation: This option lets you calculate a bill for a selected account and rate 
schedule over a user-defined period of time, and examine the results of the calculations, line by 
line in the rate form. Trial Bill does not issue transaction records to CIS or save records to Oracle 
Utilities Database (unless specified in Advanced options). See Chapter 12: Calculating Trial 
Bills for more information. 

Billing History: This option lets you generate a summary of bill determinants for one or more 
accounts over any desired time period for which data is available. See Chapter 11: Other Reports 
for more information about this report.

Special Event: This option lets you generate a summary of special event overrides that apply to 
one or more accounts over any desired time period for which data is available. See Chapter 11: 
Other Reports for more information about this report.

Late Billings: This option lets you report interest lost on late bills. See Chapter 10: Problem 
Bills and the Late Bill Report for more information about this report.

The Top Accounts: This option lets you report revenue and usage for largest customers, and 
compare to same period one year earlier. See Chapter 11: Other Reports for more information 
about this report.

Rider Summary: This option lets you list tariff riders applied to accounts over a user-specified 
date range. See Chapter 11: Other Reports for more information about this report.

Records Menu
The Records menu contains options for working with records in the Oracle Utilities Data 
Repository. Note that the Records menu is only available when the Browser is displayed.

Insert New: Inserts a new record in the selected table.

Filter: Opens the Set Filter dialog and allows you to filter records in the browser based on 
specified criteria. See the Data Manager User’s Guide for more information.

Export: Exports all records from a selected table, as well as all associated parent, child, and 
lookup records, when specified. See the Data Manager User’s Guide for more information.

Delete: Deletes all records from a selected table, as well as all associated child records. No Export 
file is created. See the Data Manager User’s Guide for more information.

Export/Delete: Exports all records* in a selected table, as well as all associated child records, and 
deletes same records from the database. See the Data Manager User’s Guide for more information.

Refresh: Refreshes the selected table.

Browse Interval Data: This option opens the Interval Data Browser. This option is only active if 
you’ve selected the Channels, Recorders, or Channel History table, or one of the records in one of 
those tables. If you select a table, the Interval Data Browser displays the entire Interval Database. 
If you select a single record, the Interval Data Browser displays only the selected record. See the 
Data Manager User’s Guide for more information.

Refresh All: Refreshes all the tables in the Oracle Utilities Data Repository.

Single-Step Menu
The Single-Step menu contains options for working with the Trial Calculation window. Note that 
the Single-Step menu is only available when the Single-Step windows are displayed.

Step: Executes the selected line in the statements (upper left) window.

Jog: Executes the rate form slowly, line by line, allowing users to view the results.

Run: Runs the rate form.
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Jog to Selection: Executes the rate form slowly, line by line, up to a selected line.

Run to Selection: Runs the rate form up to a selected line.

Break: Stops processing when “jogging” through a rate form.

ReStart: Reloads the rate form, allowing users to restart processing.

Graph Interval Data: If selected, displays interval data loaded in the rate form in the lower 
window. The default for this option is on.

Show Selected Identifiers: Shows the values of selected identifiers in the rate form. Identifiers 
are selected on the Customer Bill Modification - Edit Id dialog accessible when running a 
Single Step Analysis. See How to run the Single Step Analysis on page 12-4 for more 
information.

Show All Identifiers: Shows the values of all identifiers in the rate form.

View Open Interval Data Handles: Opens the Browse Open Interval Data Handles window, 
displaying interval data handles loaded in the rate form.

Display Report: Opens a report window for the trial calculation.

Display Profile: Opens a performance profile that lists the processing time for each line in the 
rate form.

Insert/Remove Breakpoint: Inserts or removes a breakpoint at the selected line in the top left 
window in the Single Step module. See How to run the Single Step Analysis on page 12-4 for 
more information.

Clear All Breakpoints: Clears all breakpoints in the rate form currently open in the Single Step 
module. See How to run the Single Step Analysis on page 12-4 for more information.

View Menu
The View menu contains options for altering the view of reports. Note that the View menu is only 
available when an open report window is displayed.

Note: The contents of the View menu change when viewing graphs. See 
Creating Graphs on page 3-14 for more information.

Graph: Opens the Create Graph dialog and allows you to create a graph based data in the report. 
This option is only available if the data in the report can be graphed. See Creating Graphs on 
page 3-14 for more information.

Auto Vertical Scroll: Selecting this option causes the last page of the report to be displayed as the 
report progresses; if it is not checked, no automatic scrolling occurs. 

Display Only Pages With Errors: Creates a new report window based on an open report 
window that contains only pages that contain errors. This option is only available if an open report 
window contains pages with errors.

Display Only Pages Without Errors: Creates a new report window based on an open report 
window that contains only pages that contain no errors. This option is only available if an open 
report window contains pages with no errors.
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Tools Menu
Options: This option provides you with options for tailoring Oracle Utilities Billing Component 
to your needs and environment. See Default Options on page 2-9 for more information.

Display ToolBar: This option lets you toggle display of Toolbar on and off. See Oracle Utilities 
Billing Component Toolbar on page 2-8 for more information.

Customize: Available in future release. This option lets you make other programs accessible from 
the Oracle Utilities Billing Component menu bar.

[application]: This option opens another Oracle Utilities or user-specified application program. 
If other Oracle Utilities applications are not listed on your Options menu, contact your System 
Administrator.

Windows Menu
Cascade: This option lets you overlap multiple open windows in Oracle Utilities Billing 
Component desktop, providing largest view of the active window.

Tile: This option lets you display multiple open windows side by side.

Arrange Icons: This option lets you organize icons on Oracle Utilities Billing Component 
desktop.

Close All: Closes all open windows.

Help Menu
Help: Displays the on-line help for currently-displayed window. See Using Online Help on page 
2-23 for more information.

Help contents: Displays the table of contents for on-line help. See Using Online Help on page 
2-23 for more information.

About: Displays the version number of the software. Also displayed are user name, computer 
(network) name, and database name.

Display Error Window: Displays the database version, configuration settings, and error log. This 
is useful when calling the Help Line.
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Oracle Utilities Billing Component Toolbar
The Toolbar gives you quick access to the program’s most frequently used tools and commands. If 
the toolbar is not visible, select
Tools-›Display ToolBar.

The following describes the function of each Toolbar button. Additional details are provided in 
other parts of this guide.

Click To

New Not Available in Oracle Utilities Billing Component.

Open Not Available in Oracle Utilities Billing Component.

Save Save the currently displayed report.

Print Print the currently displayed report.

Export Export the currently displayed report.

Cut Remove selected text from the currently displayed report.

Copy Copy selected text and store it on the Clipboard.

Paste Insert contents of the Clipboard at the insertion point or selection.

Browse View information in the Data Repository about selected accounts 
or customers; information is displayed via the Browser.

View Account View, update, add, and delete information about a selected account 
using the Account-Centric View.

Error Window Display database version, configuration file settings, and error log. 
Useful when calling the Help Line.

Help Display on-line help for currently displayed window.
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Default Options
The Options feature allows you to set your own default values for several frequently used 
parameters. You can set your preferred defaults via Data Manager or another Oracle Utilities 
product (such as Oracle Utilities Billing Component) and store them in the Oracle Utilities Data 
Repository. In that way, whenever you open a Oracle Utilities program, these values are 
automatically supplied—saving you the time and effort of defining them each and every time.

When you are working in any of the Oracle Utilities application programs, you can also override 
your defaults for individual work sessions, or even specific dialog boxes throughout the programs.  
Whenever you see the Options button on a dialog box, you can click it to open the Options box 
to override the defaults.

Available options include:

• General Options

• Rate Analysis Options

• Billing Options

• Interval Data Source

• Interval Data Options

• Interval Data Merge

• Error Handling

• User Files

How to set default options:

1. At the Desktop, select Tools-›Options.  Or, Click the Options button on the current active 
dialog box.

2. Set your options on each tab as desired.

3.  When you have completed the tabs as desired, click OK to save the new settings as your 
defaults, replacing the previous settings. Any Oracle Utilities program you run will 
automatically use these defaults. If you click Apply, the result depends on how you opened 
the Default Options dialog:

• If you opened the Default Options dialog from the main menu, your new settings apply 
to all of your work for remainder of your current session. The settings will revert to the 
original defaults when you quit the Oracle Utilities programs.

• If you opened the Default Options dialog by selecting the Options button in a dialog 
box, your new settings apply to just the current job.

The next several pages contain detailed information about the Default Option tabs.
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General Options
The General tab specifies a number of default values and formatting preferences used by the 
system.

Default Operating Company:  Choose the default operating company for bill calculations 
and rate analyses.

Default Jurisdiction:  Choose the default jurisdiction for bill calculations and rate analyses.

Account ID:  Choose the default ID for bill calculations and rate analyses.

Minimum printed line width:  The type size in printed reports is partially determined by 
the number of characters that you specify here. The recommended setting is 110 characters, 
which yields approximately 10 to 12 point type (depending upon your printer).  If you do not 
supply a value here the programs automatically sizes the type based on the longest line in the 
report.  So for example, if the longest line were 40 characters, the program would size the 
type so that the 40 characters filled the entire width of the page, which most likely would yield 
uncomfortably large type. On the other hand, if the longest line in the report is longer than 
the value you specify here, the value has no effect.

Default to landscape printing after this # of characters: If a line single line in a report 
contains this many characters, the report will default to landscape printing. This allows the 
user to print reports in landscape mode without having to manually change the mode in the 
printer’s properties dialog box.

Display calculation time with date on each report page:  The date/time is displayed on 
every page of every report. If this option is checked,  the time is also displayed with the date. 

Date Format: Your selection here dictates the format used to enter dates via the graphical 
user interface, and how they are displayed in reports. (This setting is not dependant upon, nor 
does it affect, how dates are stored by your database software.)

Your three options are:

• MM/dd/yyyy hh:mm:ss:  Month-day-year, hours-minutes-seconds.

• yyyy-MM-dd hh:mm:ss:  Year-month-day, hours-minutes-seconds.

• Windows Regional Settings:  Default Options will draw from the Date tab of the 
Regional Settings Windows Control Panel.

Using the Windows Regional Settings, you will have greater flexibility in the formats 
available to you.  You can set a 2-digit year (although the 4-digit, Y2K-compliant date will 
still be used internally), a European format (day-month-year), and so on.

Note: If you change the Windows Regional Settings while an application (Data Manager, 
Oracle Utilities Billing Component, etc.) is running, you must restart the application in 
order for the new settings to take effect.
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Rate Analysis Options
The Rate Analysis tab specifies default values for processing rate schedules and running reports.

Default Rate Schedule:  Choose a default rate schedule for calculating charges. This is the 
default schedule selected when running trial calculations.

Test Period:  Can be any period, one month or greater. This period is used as the default 
time range for the Billing History Report, Special Events Report, and Trial Calculations.

Default Season Schedule:  Select a season schedule for the calculations.

Note:  If when running an analysis or calculation, the input rate form includes 
a statement that assigns a value to the SEASON_SCHEDULE_NAME 
identifier, the value in the rate form takes precedence over the Options 
selection.

Display Line Numbers: If this checkbox is checked, the Rules Language Editor and Rules 
Language Text Editor display line numbers at the beginning of each statement/line. Line 
numbers also appear in the Trial Calculuation window.

Maximum number of Undo’s allowed: This field sets the maximum number of Undos 
allowed in the Rules Language Editor. The default is 1.

Display ‘Saved by’ comments at end: If selected, the ‘Saved by’ comments inserted in rate 
schedules are inserted at the bottom of rate schedules instead of at the top. This option 
unselected by default.

Billing Options
The Billing tab specifies how billing information is displayed by the system.

Round Revenue: Specifies the precision of revenue values in reports.  This setting affects only 
values that have been assigned to revenue identifiers via an Assignment, All, or Block statement in the 
applicable rate form.  A value of 0 (zero) means don’t round, -1 means round to dollars, -2 means 
round to tens of dollars, 1 to tens of cents, 2 to cents, and so on.

Currency displayed to n decimal places: Specifies the number of decimal places shown in 
reports for dollar values. It is usually set to be consistent with your choice for Round 
Revenue. A value of 0 (zero) means use the default (display cents), 1 means display tens of 
cents, 2 means display cents, 3 means display tenths of cents, 4 means display hundredths of 
cents, and so on.

Note: This setting applies only to Oracle Utilities Billing Component reports; 
Oracle Utilities Rate Management reports always display dollars with two 
decimal places (cents).

Billing Units displayed to n decimal places: Specifies the number of decimal places 
shown in reports for billing units.

Display midnight as 00:00:00 (not blank): Specifies whether or not a value (00:00:00) is 
displayed and printed when the time is midnight or unspecified.

If you leave this option unchecked (the default), the programs print and display the date 
without a time when either the time has not been specified or the time is midnight. For 
example, if either 12/01/1998 or 12/01/1998 00:00:00 were specified, the program would 
display 12/01/1998.

If you check this option, the programs print and display 00:00:00 when the time is either 
unspecified or midnight. For example, if either 12/01/1998 or 12/01/1998 00:00:00 were 
specified, the program would display
12/01/1998 00:00:00.
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Interval Data Source
The Interval Data Source tab specifies the source of interval data used by the system.

Interval Data Database:  Select a Type from the three options:

• File: Specify an interval data file. The File option below becomes active when this 
button is selected, allowing you to specify a file (and path) in the File Name field, or to 
Browse to a file.

• Default: Specifies that the default Interval Data Database identified in the 
LODESTAR.CFG File be used. See the Oracle Utilities Energy Information Platform 
Installation and Configuration Guide for more information about setting a default Interval 
Data Database.

• Customer Database: Specifies that interval data stored in the Oracle Utilities Data 
Repository be used. When this button is selected, a drop-down list appears listing all 
available interval data header tables. The default table is the Channel Cut Header 
(LSCHANNELCUTHEADER) table. 

Export Records Overwritten by SAVE to File:  This option saves interval data cuts from 
the Interval Database to an export file before they are overwritten by new cuts created by a 
Rules Language SAVE Statement.  The full path and name of the file (including a valid 
extension) must be specified.

This option appends new cuts to the same file without overwriting previously exported cuts.

Interval Data Options
The Interval Data Options tab specifies how interval data is loaded and processed by the system.

Exclude intervals with quality less than: Specify a status code level that the interval data 
must meet or exceed in order to be included in the calculations.  All interval values with a 
code less than your selection will be ignored by the programs.

The codes are listed in order of decreasing quality—alpha codes generally indicate that the 
data is acceptable; numeric codes indicate that the data is suspect and should be corrected..

Status Code  Classification of interval data

(blank) Normal

A Normal, alternate-recorded (e.g., hand-entered)

J Data inserted by Oracle Utilities Load Analysis to correct outage

L Default for data modified by Oracle Utilities Load Analysis Load Data 
Editor

M Splice peak interval (estimated value)

N Interruptible or curtailable load

P Inserted outage

Q Corrected outage

X Cuts resulting from merging invalid data or from unrecognized status codes

Y Reserved

1 Uncorrected outage

2 Non-normal (usually timing-pulse defects)
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Day Start:  Specify the time that your facility considers the beginning of the day—8:00 am or 
midnight.  This setting pertains to the ROUNDATE Rules Language function.

Use in all day calculations:  Check this box if you want the Day Start time to apply to all 
date calculations that round to a full day or higher.

Use interval end time when displaying time of the interval:  Specifies whether the start- 
or end-times of intervals are displayed for the MAXDATE values in INTDVALUE and 
INTDTOUVALUE functions. If checked, the end-time is displayed.  If unchecked, the start-
time is displayed (the default).

Add Fall Daylight Savings Time value to Energy requests:  Because previous versions of 
the Oracle Utilities Data Repository stored energy in a 24-hour format, the system had to 
compensate for the extra hour of interval data that is left over on the day when the clocks are 
turned back for Daylight Savings Time. To do this, the system automatically takes each 
account’s interval data values for the two DST hours (2:00 AM in the US) and averages them 
together for a single hour. This option enables you to specify how Oracle Utilities Billing 
Component (or other Oracle Utilities products) handles the “leftover” hour when calculating 
energy from interval data.  If this option is checked, the system doubles the averaged value. If 
the option is unchecked, it uses just the single, averaged value. This option should only be 
used if the DST Participant flag is set to “A” in your interval data.

Version 3.70 (and above) can store interval data in 25-hour format (for the day when DST 
ends). Oracle recommends this option remain unchecked when using version 3.70 or above. 
Enabling this option in version 3.70 or above can result in incorrect energy calculations.

Export Validation Flag: Controls the settings of the Validate_Record_Flag upon export. 
This can be set to one of the following:

• Valid (default): Sets all Validate_Record_Flags of each cut within the exported file to 
“N”, ignoring the Validation status of the requested cuts.

• Invalid: Sets all Validate_Record_Flags of each cut within the exported file to “Y”, 
effectively ignoring the Validation status of the requested cuts.

• Use Cut's Status: Sets the Validate_Record_Flag to either “Y” or “N” depending upon 
the combination of validation flags that are current in the cut when exporting takes 
place. If either the Merge flag or the Internal_Validation flag are “Y”, then the 
Validate_Record_Flag in the exported cut is set to “N”.  If both are set to “N” then the 
Validate_Record_Flag is set to “Y”. 

5 Aggregated interval used in rolling format with partially missing or 
unavailable data

7 Marged, aggregated, or transformed interval with partially missing data

9 Missing

Status Code  Classification of interval data
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Interval Data Merge
The Interval Data Merge tab allows you to specific how interval data cuts are merged when using 
the INTDJOIN Rules Language function.

Note: The Interval Data Merge options tab only appears if you include the 
INTD_NEW_JOIN parameter in the configuration file. See the Oracle Utilities 
Energy Information Platform Installation and Configuration Guide for more 
information.

Check Interval Data Validation before Merge: Check this checkbox to cause the program 
to check cuts' merge validation flag before merging. The default is not to check.

Interval Data Merge Selection Criterion: Choose a criterion for merging overlapping 
interval cuts (i.e., a rule how to merge two cuts into one). There are four criteria for merge: 

• Most Recent Start: Pick the interval from the cut that starts later.

• Best Status: Pick the interval from the cut with a better status code. If the intervals have 
the same status code, the values are averaged.

• Average Value: Pick the time-weighted average of the overlapping intervals. The status 
code of the averaged interval will be the worse of the overlapping intervals.

• Maximum Value: Pick the interval from the cut with a larger value.

• Time Stamp: Pick the interval from the cut with the later Timestamp.

The default criterion is Most Recent Start.

Error Handling
The Error Handling tab specifies how errors are handled by the system.

Display error messages:  If checked, the program will display the number of errors (if any) 
it encountered during the job run.

Stop analysis after ## errors:  The number of errors to allow when running an analysis or 
bill.

On Rules Language Interval Data Error:  Use this option to specify how the programs 
handle interval data problems encountered while the rate schedule is running:

• Stop with Error.  Stop processing in any mode.

• Log Message.  Complete processing; include warning message in error log, but not in 
report.

• Continue.  Complete processing; do not issue any messages.

• Issue Warning Message.  In the Automatic Billing mode, stop processing the bill.  In 
the Automatic or Approval Required modes, complete processing, but issue a warning 
message in the bill report.

• Issue Information Message.  Complete processing; include informational message in 
report.
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User Files
The User Files tab specifies where files created by the user are stored by the system.

Default User Directory: If there is a value in this field it will override the USERDIR setting 
in the configuration file (after the database is opened). Files put in the user directory before 
the database is opened - such as .log files - will still be placed in the USERDIR directory. 

Use last save/open path as default for next save/open? - If this checkbox is checked, the 
path used in the last open or save operation will be the default path for the next open and 
save operation, for the duration of the application's run. Each time an application starts it will 
use the Default User Directory/USERDIR path in the first open or save.
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Default Billing Options

The Default Billing Options dialog box lets you specify default global options that apply to all 

accounts in the system.  These options apply to all billing modules and to all Oracle Utilities 
Billing Component users (unlike the user-specific Tools-›Options preferences described in 
Chapter Two of the Oracle Utilities Billing Component User’s Guide).  However, you can override any 
of these settings for specific rate schedules, rate codes, or accounts in the Oracle Utilities Data 
Repository, or for individual jobs. Available Billing options include:

• Billing Options

• Billing Rules

• Report Options

• Summary Options

• Multiple Bill History Records

• Check Options

How to set a global billing mode:

1. Select CIS Billing (or Analysis)-›Billing Options.

The Default Billing Options dialog box appears.

2. Set your options on each tab as desired.

3.  When you have completed the tabs as desired, you have the following choices for applying 
the options:

• OK:  Saves the new settings as your defaults, replacing the previous settings.

• Apply:  The new settings apply to all of your work for remainder of your current session. 
The settings will revert to the original defaults when you exit the application.

Billing Options
The Billing Options tab specifies a number of default values and preferences used when 
performing billing calculations.

Default Billing Mode:  Use this option to specify the mode that Oracle Utilities Billing 
Component applies to accounts that have not otherwise been assigned a billing mode.  If you 
select Automatic Billing, Oracle Utilities Billing Component calculates the bills, updates the 
Oracle Utilities Data Repository, and issues transaction records—all without review and 
approval by a user.  If you select Approval Required, Oracle Utilities Billing Component 
puts the results of its bill calculations in a bill report which you must approve before the 
software issues any transaction records or updates the bill history record in the Oracle 
Utilities Data Repository).

Note:  Any billing mode flags set for individual rate schedules, rate codes, or 
accounts in the Oracle Utilities Data Repository records automatically override 
this setting.

Default Eligibility Pre- and Post-Windows:  Specify the number of days before an 
account’s scheduled read date (the Pre-Window) and the number of days after an account’s 
scheduled read date (the Post-Window) that defines the “eligibility” window. You can supply 
any value from 0 to 28 for either. In the Automatic Billing and Approval Required modes, 
Oracle Utilities Billing Component uses this window to identify “eligible” accounts. That is, if 
today’s date falls within this window, Oracle Utilities Billing Component begins scanning for 
the data required to bill the account and continues scanning until the data is available or the 
window for the account passes today.
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Note: If you set the Post Window to 0, the data must be available by the end of 
the read date, or it is considered missing. You can override the eligibility 
window setting for individual accounts and recorder types.

Note: The Default Pre- and Post-Windows should be set the same or larger 
than  the largest Pre- and Post-Window for any single account.

Special Event Pre Window:  Specify the number of days prior to the billing date within 
which a Billing Analyst must approve an account’s Special Events information in order for the 
account to be billed.  You can enter any value from 0 to 28.

This feature is designed to ensure that all Special Events are included in a bill.  For example, 
suppose that the Billing Analyst approved an account’s Special Event information on 
schedule.  However, for some reason the account’s meter could not be read until seven days 
after the scheduled date.  That would mean there would be seven days during which a Special 
Event could occur but not be included in the current bill.  However, if you set the Special 
Event Pre Window to some number less than 7, Oracle Utilities Billing Component would 
flag the account as “ineligible” and the billing analyst would have to update the special events 
information.

Automatic Repeat Frequency:  The default amount of time between a completed 
Automatic Billing cycle and the next. Set this number in minutes, from 0 (do not repeat) to 
1440 (24 hours later).

Note: The setting here does not actually define the repeat frequency; it simply 
specifies the default. The repeat frequency is set on the Automatic BIlling 
Parameters dialog box.

Billing Rules
The Billing Rules tab specifies a number of default rules and settings used when performing billing 
calculations.

Effective Date is:  The date used to determine Rate Form versions, factor values and the 
default for determining the season. There are four options:

• Bill Stop

• Bill Start

• 1st of Bill Month

• Scheduled Read Date

See General Billing Rules on page 4-4 of the Oracle Utilities Billing Component Installation and 
Configuration Guide for more information.

Allow Saves without SAVE TO CIS statement:  Normally output records are created as 
part of a bill calculation.  These records are used with non-Oracle Utilities Billing Component 
systems such as printing, accounts receivable, and so on. Oracle Utilities Billing Component 
verifies that at least one output record has been created before saving any data to the Oracle 
Utilities Data Repository. Check this box to turn this verification off, then you can save to the 
database without creating an output record.

You must Approve a bill to save it to the Oracle Utilities Data Repository.  When you 
Approve the bill, data is saved and the Bill Time (BILLTIME) column in the Bill History is 
set.

Retrieve all Account Determinants:  Normally, to improve performance, Oracle Utilities 
Billing Component loads only the determinants that are explicitly used in the Rate Schedule. 
However, if you are using indirection (the @ operator) to retrieve determinant values you 
need to turn this option on. Oracle Utilities Billing Component then loads all determinants in 
the account’s Bill History records.
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Use 2.10 and before Account Note generation in Automatic Billing and Approval 
Required: Check this checkbox to generate Account Notes/Work Queue Items in 
Automatic and Approval Required billing as was in version 2.10 and earlier versions of Oracle 
Utilities Billing Component. The primary difference between pre-2.10 and post-2.10 is that 
for 2.10 and earlier, Account Notes/Work Queue Items are generated on the day after the 
scheduled read date, while for post-2.10 they are generated the day after the end of the 
postwindow from the scheduled read date. See Billing Account Note/Work Queue Item 
Generation on page 4-11 in the Oracle Utilities Billing Component Installation and Configuration 
Guide for more information.

Note: When using Work Queues, exceptions are written to the Work Queue 
Open Item table instead of the Account Notes table. To enable the Work 
Queues application, include the 
USE_WORK_Q_FOR_ACCOUNT_NOTES = 1 parameter in the 
LODESTAR.CFG file.

Report Options
The Report Options tab specifies a number of default values used with printing reports.

Print Detail:  This option determines the level of detail included in the bill reports, 
transaction records, and bill faxes or E-mail. Select one of the following:

• None:  Effective revenue only.

• Normal:  Effective revenue, plus any charges assigned to a revenue identifier and any 
values assigned to a Report Statement in the applicable rate form.

• All:  Effective revenue, plus revenue identifiers, plus the values associated with the Rules 
Language Label and Report statements in the rate form.

Note: You can override this setting for selected accounts, rate codes, or rate 
schedules using the Billing Mode Flags in the corresponding records in the 
Oracle Utilities Data Repository.

Show Bill History Problems/Resolutions in Bill Reports:  If checked, this option 
specifies that any problems or resolutions that a Billing Analyst has entered into the Bill 
History Problem record for the current bill period appear near the top of the bill report (in 
the header section, just after the customer and account information). This option applies to 
all bill reports produced by Oracle Utilities Billing Component.

Summary Options
The Summary Options tab specifies how summary customers and accounts are processed. See 
Summary Bill Calculation on page 4-20 in the Oracle Utilities Billing Component Installation and 
Configuration Guide for more information.

Compute Multiple Rates per Account:  This option specifies whether all effective rates, or 
only the most recent rate is used for billing. The options available include:

• No: Oracle Utilities Billing Component calculates each account’s bill using just the most 
recent rate specified in the Rate Code History Table for that account.

• Throughout Bill Period: Compute multiple rates using all rates in effect for that 
account throughout the Bill Period, as specified in the Account Rate Code History Table. 
When computing multiple rates, Oracle Utilities Billing Component executes the rates in 
reverse order starting with the record with the most recent Start Time.

Note: If you use either of the first two options, be sure that all inactive rate 
codes have a stop time in the Account Rate Code History Table; otherwise they 
will be included in the calculations.
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• On Effective Date: Compute multiple rates using all rates in effect for that account on 
the Effective Date, as specified in the Account Rate Code History Table.

Enable Customer SUMMARY Rate Schedules: If this is checked, Oracle Utilities Billing 
Component can process Summary rate schedules.

Multiple Bill History Records
The Multiple Bill History Records tab specifies how customers/accounts with multiple Bill 
History records per bill period and/or read date are handled. See Multiple Bill History Records 
per Bill Period on page 4-29 in the Oracle Utilities Billing Component Installation and Configuration 
Guide for more information.

Allow Multiple Bill History Records per Bill Period/Read Date:  Normally, Oracle 
Utilities Billing Component uses the billing cycle’s scheduled meter read dates to match an 
account’s Bill History records with the correct bill periods. However, this may not suffice in 
all cases, either because the metered data does not come in from the field on a reliable 
schedule, or because the metering and billing schedule at your company is more complex. 
This tab enables you to choose the action that Oracle Utilities Billing Component takes when 
it encounters two or more account Bill History records associated with the same read date. 
The option you choose depends upon the metering and billing policies of your company. 
(This setting applies to Automatic Billing, Approval Required, and Current/Final Bill.)

• No:  Oracle Utilities Billing Component rejects all Bill History records for the specified 
account that have the same read date. It does not process the bills, and issues an error 
message instead.

• Bill Individually - Allow Out of Order Bill Periods:  This option is designed primarily 
for situations in which metered data comes in from the field irregularly—for example, 
readings for bill periods arrive out of sequence, and/or scheduled read dates are missed 
altogether. If you select this option, Oracle Utilities Billing Component treats any 
account Bill History records that have the same read date as valid records, and processes 
them as separate and complete bills. It retrieves and bills the previously unbilled Bill 
History records for the account (Bill Time value equals NULL), in sequence, from oldest 
to most recent. To determine the bill period that the Bill History record actually belongs 
to, it looks at the Bill History record’s Start Date/Time for the metered data and 
processes the bill accordingly. If the applicable rate form includes any SAVE statements, 
the computed values are saved to the Bill History record for the correct bill period.

• Bill Individually - Monthly Merge Historical Values:  This option is designed 
primarily for companies whose bill calculations require determinant values for sub-
periods within the current bill period (e.g., weekly kWh), as well as values for entire 
historical bill periods (e.g., maximum kW for the past 12 bill months). In this case, 
multiple sub-period records (e.g., records with different start- and stop-dates) may be 
associated with a single scheduled read date. If you select this option, Oracle Utilities 
Billing Component assumes that multiple bill history records with the same read date for 
one account are in fact sub-period records. To perform the calculations (depending upon 
the rate schedule), Oracle Utilities Billing Component first aggregates historical sub-
period values and start- and stop-dates to find values for entire historical bill periods. It 
then bills each sub-period for the bill period (same scheduled read date), from oldest 
through most recent.

• Aggregate to Read Date and Bill as One:  This option is designed primarily for 
companies that take multiple meter readings for an account within a single bill period 
(i.e., partial reads), but bills the account using values for the entire bill period. In this case, 
two or more Bill History records are allowed per read date. If you select this option, 
Oracle Utilities Billing Component aggregates all determinant values and dates to the 
read date (in other words, records with the same read date are combined into one). If the 
applicable rate form includes any SAVE statements for the sub-periods, it saves them to 
the latest record with the current read date.
Working with Oracle Utilities Billing Component 2-19



Default Billing Options
• Aggregate to Read Date and Bill as One (Oracle Utilities Rate Management 
Style):  This option is used only for testing, and should not be selected for billing in a 
production mode. It is similar to the option described above, except that the process is 
oriented to bill months. That is, two or more Bill History records with the same bill 
month are combined into one record for the entire bill month.

Check Options
The Check Options specifies how certain checks are performed before processing calculations. In 
some systems, some of these checks are unnecessary. Use these options to turn off the unneeded 
checks, to improve performance.

Do not use Interval Data:  Turn off all support for Interval Data during calculations.

Do not use Interval Data to Compute Start/Stop:  Don’t use interval data cuts to 
compute the bill start and stop, and do not verify that all the account's interval data is ready. If 
neither Interval Data check is turned off and Multiple Bill History Records are allowed, only 
the verification is performed.

Do not check for Interval Data gaps: Turn off checking for gaps between cuts. The rate 
schedule should then check for missing data (status code '9') to validate the data. If this is not 
checked, a Warning will be reported if there are gaps between the interval data cuts. 

Do not check Account Notes:  Don’t check for Account Notes that stop billing in 
Automatic Billing or Approval Required. Do not write Account Notes from Automatic 
Billing or Approval Required.

Do not check Override Ready:  Don’t check that Special Events or Overrides are Ready.

Do not check Account’s Meter Values:  Don’t verify that account’s scalar data is in the 
Meter Value Table.

Do not check Rate Code Flags:  Do not use the BILLINGMODEFLAG, 
PRINTDETAIL or FULLDAYBILL values in the RATECODE Table. If this is checked, it 
also turns off the same flags in the Rate Forms (RATEFORM) Table. 

Do not check Rate Schedule Flags:  Do not use the BILLINGMODEFLAG, 
PRINTDETAIL or FULLDAYBILL values in the RATEFORM Table, independent of the 
RATECODE Table.

Do not display “Reason for Change” dialog when updating the Bill History [Value] 
records: Don’t display the Reason for Change dialog after updating Bill History or Bill 
History Value records.

Do not check Bill Determinant Use:  Don’t check the Bill Determinants’ Use table.

Use MDM schema: When this option is checked, Oracle Utilities Billing Component checks 
the Oracle Utilities Meter Data Management (MDM) tables, specifically the Meter Data 
Channel Cut table, for interval data when billing accounts.

Checking this option also automatically checks the following other options:

• Do not check for Interval Data Gaps

• Do not check Account’s Meter Values

It also disables the following options:

• Do not use Interval Data

• Do not use Interval Data to compute Start/Stop

Use MDM check data:  When this option is checked, usage in the Oracle Utilities Meter 
Data Management tables is validated when Oracle Utilities Billing Component checks for 
data.
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Each of these checks requires at least one query to a database so turning one off eliminates its 
database query and saves time. The most time consuming check is using Interval Data to Compute 
Start/Stop, followed by checks for Account Notes, Account's Meter Values, Override Ready and 
Bill Determinant Use. To determine what you can turn off, look at the rate schedules. If no rate 
schedule, rider or contract uses Overrides, for example, turn off the Override Ready check. 
Likewise, if there your system doesn’t use interval data, turn off the Interval Data checks.
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Browsing and Viewing Account Data
From time to time , you might need to verify account data in the Oracle Utilities Data Repository. 
This can include checking Bill History records, or the specific rate forms associated with a given 
account. Oracle Utilities applications include methods for viewing data using Data Manager’s 
Browser and Account Centric View. Each of these is described below.

How to Browse Account Data:

1. Select File-›Browse Customer/Account(s)...

The View Customer/Account(s) Inputs dialog box appears.

2. Complete the dialog as follows:

Select By:  Choose either Account or Customer.

Select:  Select the accounts or customers of interest using one of the following options:

• ID - Type the ID of the customer or account of interest.

• List - Select the list of interest. (See Chapter Eleven in the Data Manager User’s Guide for 
information about creating lists.)

• All - View all customers or accounts in the database.

• File - Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

3. Click OK. The Browse Customer/Account(s) window opens, with just the selected 
customer or account records displayed.

Additional information about using the Browser can be found in Chapter Six: Browsing 
Data in the Data Manager User’s Guide.

Viewing Account Data:

1. Select File-›View-›Account.

The Enter Account ID window appears.

2. Enter the ID for the account you wish to view, and click OK.

The View Account window appears, with information about the selected account displayed. 
The View has two sections.  The top section displays the “header” or “indicative” data.  This 
data remains on the screen for easy reference while you work with the account information 
displayed in the various tabs below.  For instance, if you’re on the phone with a customer 
researching his or her bills, the customer’s name is always visible at the top of the screen.

Each tab in the lower portion of the screen is devoted to a particular category of information.  
To view the contents of a tab page, simply click on its tab.

The tabs are organized in four columns.  The fields displayed on each tab page are detailed in 
the last section of this chapter.

Note: The specific tabs and fields in your company’s version of the Account-Centric View 
may differ from those shown in the illustration below.

Additional information about using the Account Centric View can be found in Chapter Five: 
The Account-Centric View in the Data Manager User’s Guide.
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Using Online Help
Oracle Utilities applications provide browser-based online help.

How to open online help:

1. Select Help Contents from the Help menu. The online help opens in a browser window.

2. Locate the topic you need help about via the Contents tab, Index tab, or Search tab.

• The Contents tab allows users to expand/collapse sections of the table of contents as 

needed to find a particular topic. Click on the book icons (  and ) to open/close 

headings. Click on the topic icon ( )to open it.

• The Index tab allows the user to browse an index for the online help. Click on the index 
entry for the topic to open it.

• The Search tab allows the user to search the online help for specific words. Enter the 
word(s) for the search in the text box and click Go! The search results appear beneath 
the text box. Click on the topic to open it. 

3. The selected topic will appear in the right pane of the online help window.

Help Icons
A number of icons appear along the top of the online help window. These icons are used for 
navigating the online help and other functions.These icons perform the following functions:

Context-Sensitive Help
Users can also get online help based on a specific function or screen. This is referred to as 
context-sensitive help.

How to open context-sensitive help:

1. Open the function or screen you wish to find help about.

2. Click the Help button in the Toolbar or press F1.

3. An online help window opens displaying the corresponding topic.

Icon Description

Show Navigation: Open the navigation frame. Used after opening 
a single help topic.

Previous: Display the previous help topic.

Next: Display the next help topic.

Show in Contents: Expand the Contents tab to display the current 
topic.

E-mail: Send email to Customer Support.

Print: Print the current topic.

Bookmark: Save the current topic as an Internet Explorer 
Favorite..
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Shortcut Tips

Account ID Hyperlinks
Oracle Utilities Billing Component and Oracle Utilities Rate Management includes a convenient 
and time-saving shortcut for “jumping” from an open report to another module, while zeroing in 
on information about an account of interest.

How to use the account shortcut:

1. Highlight the ID of an account of interest in an open report window. If the report was 
generated based on a customer/account list, you can also select the list name.

2. Right-click in the report window, and select the desired option from the menu that appears.

When the next dialog opens, the ID is already supplied.

Copying Text Between Windows
This is another timesaving tip that enables you to copy information from one text entry field and 
paste it into another, saving you the effort of retyping the data and ensuring that it is the same.  It 
is especially useful for Account IDs.  The fields can be in the same or different windows.

How to copy text from one data entry field and paste it into another:

1. Highlight the desired text, and with the I-beam cursor still positioned in the text field, click the right 
mouse button.

A menu appears.

2. Select Copy.

The text is now saved to the Clipboard.

3. Go to the window containing the field in which you wish to paste the text.

4. Click the cursor in the desired field.  Without moving the cursor out of the field, click the right 
mouse button.  When the menu appears, click Paste.  The text appears in the field.

Alternate approach:

Here is another method that does the same thing, but with the keyboard instead of the mouse.

1. Highlight the desired text in a text entry field.  Do not move the cursor out of the text field.

2. Press CTRL+INSERT (or CTRL+C) on your keyboard.

3. Go to the window containing the field in which you wish to paste the text.

4. Click the cursor in the desired field.  Without moving the cursor out of the field, press 
SHIFT+INSERT (or CTRL+V) on your keyboard.
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Saving and Applying Settings for Dialog Boxes
This section describes a very convenient and time-saving feature that enables you to save input 
parameters for tasks you perform frequently. Specifically, you can save your selections for 
account/customer and date(s). To use this feature, complete an input dialog box as you would 
normally before running a billing, analysis, or reporting module, save the settings with a name of 
your choosing, and recall them the next time you want to perform the same or a similar task.

How to save settings:

1. With the desired setting specified in an input dialog box, right-click in any blank area of the 
dialog. The Save/Restore dialog box appears.

2. Enter a name and optional descriptive note for your settings, and click Save.

The settings are now saved to the database.

How to import/export settings:

To export:

1. Select the report settings and click Export. The Select File for Dialog Settings Report dialog 
opens.

2. Navigate to the desired directory and click Save. The report settings are exported in XML 
format, and can now be imported for use with other dialogs.

To Import:

1. Click Import. The Select File for Dialog Settings Report dialog opens.

2. Select the desired file and click Open. The report settings are now available for use with the 
current dialog.

How to apply the settings:

1. Open the dialog box for which you’ve saved settings. Right-click in any blank area of the 
dialog.  The Save/Restore dialog appears.

2. Select the desired settings and click Restore.

The dialog is updated with the settings.  You can use them as is, or modify them before 
running the job.

How to delete the settings from the database:

The following instructions explain how to delete unwanted settings, so that they no longer appear 
in the pop-up menu.  You can delete reports by highlighting the report settings you wish to delete 
and clicking Delete or by deleting the settings from the Data Repository using the Browser. To 
delete report settings using the Browser, using the following procedure.

1. Select File-›Browse-›Customer Database. The Browser opens.

2. Click on the plus sign that appears to the left of the Report Settings table icon (you may 
have to scroll down the tree to bring that table icon into view).

A list of the Report Setting records that are currently stored in the database appears under the 
table icon. Each report setting record is identified by a combination of three IDs: the logon 
ID of the user that saved the setting, the internal ID that identifies the dialog box to the 
system, and the name that the user assigned to the settings when he/she saved them.

3. Highlight the icon for the record you wish to delete.

4. Select Edit-›Delete from the menu bar.

A message box appears, asking you to confirm that you wish to delete the record.  Click OK 
to delete the record. Click Cancel to keep it.
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Chapter 3
Working with Reports

One of the primary functions of Oracle Utilities Billing Component, beyond calculating bills, is to 
generate reports. Each of the various billing modules available through Oracle Utilities Billing 
Component (Automatic Billing, Approval Required, Current/Final) generate bill reports, and the 
program also generates a number of other useful reports, such as a Late Bill Report and a Bill 
History Report.

You have a number of options when generating Oracle Utilities Billing Component reports that 
can affect the format and content of each report. These options include customizing the contents 
of a report, such as adding titles to your reports and setting the level of print detail for each report, 
as well as writing a report directly to a file or exporting data from a report for use with other 
applications (such as spreadsheets or text editors).

You can also set up bills to be e-mailed or faxed to your customers.

This chapter explains how to set report options for individual reports and how to apply several 
tools that Oracle Utilities Billing Component provides for reports, such as printing and text 
search. This includes:

• Report Options

• Writing a Report Directly to a File

• Exporting Data from a Report

• Setting Up Bills to be Faxed or E-mailed

• Viewing and Printing Reports
Working with Reports 3-1



Report Options
Report Options
Report options allow users to customize the contents of a report, including the report 
presentation and output, the print detail level, problem determination options, and the appearance 
of the Bill Calculation Results section of reports.

Note: Changes to report options as described in this section apply only to the 
report currently being run.

Users access the Report Options via tabs at the top of the Report Options dialog. Clicking on 
these tabs allows users to navigate between types of report options, including:

• General Options

• Print Detail Options

• Problem Determination Options

• Bill Calculation Results Columns Options

How to set and save report options:

1. Click the Report Options button in the input dialog box for the report you’re creating. The 
Report Options dialog appears.

2. Make any appropriate changes on the General, Print Detail, Problem Determination, and 
Bill Calculation Results Columns tabs.

Note: Not all report options are available for all reports. If an option is not available, it is 
greyed out.

3. Click OK to save the changes. To close the Report Options dialog without saving changes, 
click Cancel.

General Options
The General tab allows users to set presentation and output options for a report.

Report Titles
To add optional titles to a report, enter the title in one of the three optional title fields.

Saving Reports to Files
To write the report to a file, check the “Write report directly to File” check box and specify the 
path and filename for the file. Use the “Browse” button to locate an existing file. To display the 
report also, check the “Also Display Report” checkbox.

Other Options
• To disable graphing for the report, check the “Disable graphing of data” checkbox.

• To display only summaries for the report, check the “Display summaries only” checkbox.

• To keep the report data for CSV/XML exporting, check the “Keep data” checkbox.
3-2 Billing Component (C/S) User’s Guide



Report Options
Print Detail Options
The Print Detail tab allow users to specify the level of detail included in both a bill report and 
transaction record. The information computed and available for reporting is determined by the 
statements used in the applicable rate form. The Print Detail tab enables you to specify how 
much of that available data is included in the reports and transaction records.

Print Detail Options
Default: This option means the program will use the Print Detail setting normally applied to the 
account (via the Account, Rate Code, Rate Schedule, or Global options specified). Alternately, you 
can override the usual setting for just this job by selecting one of the following:

None: This option displays effective revenue only.

Normal Detail: This option displays effective revenue, plus any charges assigned to a revenue 
identifier and any values assigned to a Report Statement in the applicable rate form.

All Detail: This option displays effective revenue, plus revenue identifiers, plus the values 
associated with the Rules Language Label and Report statements in the rate form.

The table below details how these options apply to specific components of a report and 
transaction record. 

Print Detail Items
To override the Print Detail Options setting for specific components of a bill report and 
transaction record, select the specific options for each component in the Print Detail Items 
section of the dialog. For each report component type, select one of the following:

• On - Include the component in the report and transaction record.

• Off - Exclude the component from the report and transaction record.

• Print Detail Option - Apply the setting specified under Print Detail Options. The specific 
manner in which these settings affect individual report components is detailed in the table 
above. For example, if you had selected “None” under Print Detail Options, and selected 
Print Detail Option here for Input Values, the input values would not appear in the report.

Following is a brief description of each of the report components.

Customer/Account Detail. Date activated, billing mode, number of days specified for the 
eligibility pre- and post-windows.

Input values. This option reports the parameters specified for the bill calculations: bill start and 
end date; date that the account's meter was scheduled to be read; rate code applied to the account; 
number of days in bill period, and the bill month.

LABELed Identifier Values. This option reports the any identifier values and text strings 
specified using a LABEL Statement in the rate form. LABEL statements are typically used to 
substitute meaningful labels for bill determinant names or other brief and sometimes-cryptic 
identifiers (e.g., LABEL LF “LOAD FACTOR” displays LOAD FACTOR and its value in the 
report). They are often used for column headings or report subtitles.

Report Component None Normal All 

Customer/Account Detail X X X

Input Values X X

LABELed Identifier Values X

Simple Report Values X X

Compound Report Values X X
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Note: If a report component type is designated to appear in a report, and it is 
assigned a name using a LABEL Statement, its values will automatically appear 
in the report, with the new label. In other words, it is not necessary in that case 
to apply the LABELED identifier values option to get the label and value to 
appear. For example, the applicable rate form might have the statement 
LABEL $EFFECTIVE_REVENUE “Total Charges”. Because Effective 
Revenue is automatically included in all report types, “Total Charges” will 
appear, no matter what print details options you choose.

Simple report values. This option reports any values that were assigned to an identifier using a 
REPORT Statement in the rate form. REPORT statements are typically used to report values of 
interest that are calculated and/or drawn from the database, such as peak times.

Compound report values. This option reports any values associated with a stem identifier using 
a REPORT Statement in the rate form.

Problem Determination Options
The Problem Determination tab allows users to specify the level of problem determination detail 
included in both a bill report and a transaction record.

When problems occur during the processing of a bill, error messages and other information useful 
in determining the cause of the problem are created. The Problem Determination tab option 
enables you to specify how much of that data is included in the reports and transaction records.

Problem Determination Options
Show All Error Messages: This option reports all error messages that occur while processing 
the bill.

Show All Input Options: This option reports all input options used in processing the bill.

Show Bill records to Save (BillHistory, CSS, etc). This option includes the Bill History records 
in the Bill Report. It is typically only used for testing. If you turn this option off, the records are still 
output when you approve a bill, but they are not displayed or printed in the bill report.

Show Rate Schedule Used in Bill Calculation: This option includes the rate schedule used in 
processing the bill on the bill report.

Bill Calculation Results Columns Options
The Bill Calculation Results Columns tab allows users to specify the labels of the Bill Calculation 
Results section of a bill report.

The Bill Calculation Results section displays the number of billing units, the distribution of those 
billing units, the charge rate, and revenue for each revenue identifier used in a rate schedule.

Bill Calculation Results Columns Options
• To change one or more of the Bill Calculation labels, check the Change Bill Calculation 

Labels checkbox and edit the labels as appropriate.

• To omit one or more of the columns from the bill report (except the Revenue column), check 
the Change Bill Calculation Labels checkbox and delete the appropriate label.

Billing Units Label: The label for the Billing Units column. If blank, the column is omitted.

Distribution Label: The label for the Distribution column. If blank, the column is omitted.

Charge Rate Label: The label for the Charge Rate column. If blank, the column is omitted.

Revenue Label: The label for the Revenue column. This column cannot be omitted. If blank, the 
column label is Revenue.
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Writing a Report Directly to a File
In some cases, you may find it useful to write a report directly to a text file, without displaying it on 
screen—for example, if the report is very long and you don’t want to wait the extra time for the 
report to display.  The text file created can be opened using a text editor or word processor.

How to write a report directly to a file:

1. Click the Report Options button in the input dialog box for the report you’re creating.

The Report Options dialog box appears.

2. In the Write to file section, check the Write Directly to File box.

3. Click the Save As...button. 

The Save Report As dialog appears.

4. Assign a name and destination directory for the output file. Click Save to close the dialog.

5. Click OK to close the Report Options dialog.

6. In the input dialog for the report, click OK to run the report.

The report is not displayed on screen, but a confirmation message appears to let you know 
that the report has been saved. You can now open the text file using a text editor or word 
processor.

Note: This option is not available for all types of reports. If the “Write Directly 
to file option is grayed out, this option is not available for the type of report you 
are currently creating. 
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Exporting Data from a Report

You can export data from a report in a number of formats:

• CSV (Comma-Separated Value) - compatible with most spreadsheet programs

• HTML (Hyper-Text Markup Language)  - compatible with web browsers

• XML (Extensible Markup Language) - used to export data for use with external systems

• Text - compatible with text editors and word processing programs.

How to export data for use in other programs: 

1. Click Report Options in the input dialog box for the report you’re creating.

The Report Options dialog box appears.

2. Check Keep Data (for CSV/HTML/XML export, line selection, Approval, etc.).

Note: For many types of files this option is permanently selected and cannot be unchecked.

3. Click OK to close the dialog.

4. In the input dialog box for the report, click OK to create it.

5. With the report displayed in the window, select File-›Export.

6. In the dialog box that appears, specify a name and destination directory for the file, select the 
appropriate file type Text (*.txt),  Comma Separated Files (*.csv), HTML (*.htm), or 
XML (*.xml) in the Save as type box.

7. Click Save.

The file is saved to the designated directory. You can open it in an appropriate program for 
further analysis.
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Setting Up Bills to be Faxed or E-mailed
Oracle Utilities Billing Component includes a convenient feature that automatically or upon 
demand outputs bills in an E-mail- or fax-ready format. After Oracle Utilities Billing Component 
produces the fax page or writes the E-mail file, you must manually transmit it to the addressees via 
your fax machine or E-mail software.

You can set up faxes or E-mail at the customer- or account-level. In addition,  you can address the 
faxes or E-mail to a customer, account manager, utility contact, and/or any other individual of 
your choosing. The E-mail or fax contains the same level of billing information that is sent to the 
output file, formatted appropriately.

This feature is both a useful customer service tool and a management tool. For example, you can 
use it to quickly and easily give customers a preview of their bills (in case they want to waive a 
peak, for example). This can also help account managers keep track of their accounts’ activity and 
bills.

Before you can create a fax or E-mail, you must set up a number of records of information in the 
Oracle Utilities Data Repository. Instructions for setting up that information appear later in this 
chapter.

How and When are the Faxes and/or E-mail Created?
If you specify E-mail, Oracle Utilities Billing Component creates a file in the LODESTAR\USER 
directory and assigns it a name of your choosing (or the default name EMAIL.TXT). If you 
specify a fax, Oracle Utilities Billing Component prints the fax to your default printer.

How and when the actual fax page or E-mail letter is generated depends partly on the billing mode 
for the customer or account:

• Automatic Billing: Oracle Utilities Billing Component automatically prints the fax or 
outputs the E-mail file when it issues the transaction records to the output file.

• Approval Required: When you approve the bill, Oracle Utilities Billing Component 
automatically prints the fax or outputs the E-mail file.

• Manual Billing — Bill Correction or Current/Final: You can also generate a fax or E-
mail from any of the manual billing modules (Bill Correction and Current/Final Bill). To do 
so, select Review-›Fax/Email when viewing the bill in the bill report window after the bill 
has been calculated. See How to issue a fax or E-mail for an account or customer: on 
page 7-4 for more information.

For both Approval Required and Manual accounts, there is an option on the input parameters 
dialog box for the billing module that turns off the approve or reject step.  Turning this feature off 
enables you to calculate the bill and generate the fax or E-mail from the Bill Reports window as 
described above, without the possibility of accidentally sending records to the output file. The 
Enable Approve and Reject option is described in each of the chapters covering the various 
billing modules.

Note:  All of the approaches described here—whether on demand or 
automatic—require you to set up the information described on the following 
pages.  If some of the information is missing, the fax page or E-mail will be 
produced, but with blanks where the missing information should be.

A sample of the fax/E-mail output format is shown on the previous page.  The sources of the 
information are noted in the left column. The following pages provide detailed instructions 
concerning how to set up the database records necessary to create fax/E-mail bills.
Working with Reports 3-7



Setting Up Bills to be Faxed or E-mailed
Setting Up the Directory and Service Center Lookup Codes
The Oracle Utilities Data Repository uses lookup codes as a convenient way of encapsulating 
frequently-used information. Before you can set up bills to be faxed/emailed, you must set up the 
Directory and Service Center lookup codes for the faxes/e-mails, as described below.

Note: You must use the Browser when setting up Directory and Service Center 
records in the database. The Account-Centric View does not apply to lookup 
codes.

How to set up an entry in the Directory Lookup Table:

Think of the Directory Table as a Rolodex that contains the names and addresses of potential 
recipients of the faxes or E-mail. Each recipient is assigned a code. When you address the fax or 
E-mail, you simply refer to the code rather than that actual address.

This Directory does double duty by storing the names and numbers of the individuals that the 
fax/E-mail recipients should contact with any questions, such as the account manager or other 
utility contact. Again, you’ll tell Oracle Utilities Billing Component to include this information in 
the fax or E-mail by simply referring to the appropriate code.

1. In Data Manager, select File-›Browse-›Customer Database.

The Browser appears.

2. Click on the Directory table icon.

A list of all currently defined directory codes appears in the right pane.

3. Select Records-›Insert New.

A blank data entry form appears.

4. Complete the form:

Directory Code:  Enter a unique code (up to 64 characters) to identify this record.

Name:  The name of the account manager, utility contact, or other recipient.

Phone #1:  Phone number of the account manager, utility contact, or other recipient.

Phone #2:  Alternate phone number for the account manager, utility contact, or other 
recipient.

Fax:  Fax number for the account manager, utility contact, or other recipient.

Pager:  The pager number of the account manager, utility contact, or other recipient.

EMail:  E-mail address of the account manager, utility contact, or other recipient.

Title:  Title of the account manager, utility contact, or other recipient.

Name of File: The name of the E-mail file. Do not include the extension. Oracle Utilities Billing 
Component automatically writes the file to the LODESTAR\USER directory, and adds the 
.txt extension. If you do not supply a name, Oracle Utilities Billing Component uses the 
default (EMAIL.TXT).

Note about faxes: You should associate a unique filename with each Directory 
record. If you use the same file name for multiple records, Oracle Utilities 
Billing Component will append all new E-mail to the end of that file.

After a fax or E-mail file is issued, delete or move the file. Otherwise, the next time Oracle Utilities 
Billing Component creates the fax or E-mail, it will append the new information to the old file. 
You will have to manually delete the old information from the file before sending it.
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How to set up an entry in the Service Center Lookup Table:

The Service Center Table assigns an identifying code to each service center that you might want 
to reference in an account’s fax or E-mail. Later, when you set up the fax or E-mail, you simply 
refer to the code and the system automatically supplies the full name of the service center in the 
fax or E-mail.

1. In Data Manager, select File-›Browse-›Customer Database.

The Browser appears.

2. Click on the Service Center table icon.

A list of all currently defined Service Center codes appears in the right pane.

3. Select Records-›Insert New.

A blank data entry form appears.

4. Add the following information to the form:

Code:  Enter a unique code (up to 64 characters) to identify this service center.

Name:  Enter the name of the service center, as you wish it to appear in the fax or E-mail.

Unit of Measure: Optional. Uncheck the ‘NULL’ checkbox and click on the words ‘Unit of 
Measure.’ Select the appropriate Unit of Measure code from the list that appears.

End Use: Optional. Uncheck the ‘NULL’ checkbox and click on the words ‘End Use.’ Select 
the appropriate End Use code from the list that appears.

5. Select Edit-›Add to save the information to the database.

6. Select Records-›Refresh or Records-›Refresh All to update the displays with the new 
information.
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Specifying an Operating Company Address
The standard fax or E-mail format displays the name, address, and number of the operating 
company issuing the bill. You may have to add this information to the Operating Company Table.

How to supply an operating company address for the top of the fax or E-mail:

1. In Data Manager. select File-›Browse-›Customer Database.

The Browser appears.

2. Expand the list of Operating Companies by clicking on the plus sign to the left of the 
Operating Company table icon.

3. Highlight the record icon for the operating company of interest.

A data entry form for the operating company appears.

4. Supply the street address, city, state (2-character postal code), ZIP, and telephone number as 
you wish it to appear on the fax or E-mail.

5. Select Edit-›Update to save the information to the database.

6. Select Records-›Refresh or Records-›Refresh All to update the displays with the new 
information.
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Setting Up Faxes or E-mail for Customer-Level Billing Information
When you have defined the required supporting information, you are ready to modify the 
appropriate customer records. The following instructions assume that you are using the Browser 
to modify the records. You could also modify records using the Account-Centric View or the 
Import utility.

How to specify the name of the Customer’s Account Manager and/or Utility 
Contact and whether he/she receives a fax or E-mail:

In this step, you’ll specify the name of the customer’s account manager and whether or not the 
customer receives fax or E-mail copies of the customer’s account bills; and the name of the utility 
contact (the person the customer calls with questions) and whether or not the contact receives fax 
or E-mail copies of the customer’s account bills.

1. In Data Manager, select File-›Browse-›Customer/Account(s). 

2. Select Customer and enter the customer’s ID.

A data entry form for the Customer record appears in the right pane.

You can also create faxes or E-mail of billing information at the account level.   To do so, you 
must turn on the fax flag for the account in the Account Directory Table. You can direct the 
fax or E-mail to any individual inside or outside of the utility, as long as they are registered in 
the Directory Lookup Table.

3. Add the following information to the form:

Directory - Account Manager:  Use this field to specify the name of customer’s account 
manager. First, clear the Null checkbox. Then, click the cursor in the field and select the 
directory lookup code that identifies the account manager. You can either double-click on the 
code, or highlight it and press ENTER or click OK.

Directory - Contact:  Use this field to specify the name of the customer’s contact at the 
utility. Click the cursor in the field and select the directory code that identifies the contact.

Note: If you don’t supply a name, Oracle Utilities Billing Component will use the name 
specified in the Directory - Account Manager field as the name of the contact when printing 
the fax or E-mail.

Account Manager Fax Flag: Specify whether you want Oracle Utilities Billing Component 
to produce a copy of the E-mail or a fax for the individual identified in the Directory - 
Account Manager field. If you do not want the account manager to receive a copy of the fax 
or E-mail, leave the Null box checked.

Contact Fax Flag: Specify whether you want Oracle Utilities Billing Component to produce 
an E-mail or a fax for the individual identified in the Directory - Contact field. Pick one of the 
following options: Null (nothing produced); E-mail; or Fax. If you do not want the person 
specified in the Contact field to receive a fax or E-mail, leave the Null box checked.

Note: If you set the fax/Email flag for either or both the account manager or contact, but do 
not provide a code in either the Account Manager or Contact fields, Oracle Utilities Billing 
Component will put an error message on the fax or E-mail.

4. Select Edit-›Update to save the information to the database.

5. Select Records-›Refresh or Records-›Refresh All to update the displays with the new 
information.
Working with Reports 3-11



Setting Up Bills to be Faxed or E-mailed
Specifying Fax or E-Mail Output
The following instructions assume that you are using the Browser. You could also specify fax or 
E-mail output using the Account-Centric View or the Import utility.

How to specify that an account’s billing information be output as a fax or E-mail:

1. In Data Manager, select File-›Browse-›Customer Database. 

The Browser appears.

2. Click on the Account Directory table icon in the left pane.

You see a list of all accounts that have been set up to receive faxes or E-mail, along with the 
associated directory code.

3. Select Records-›Insert New.

A blank data entry form appears.

4. Complete the form:

Account ID.  Click the cursor in the field and select the desired account from the list that 
appears. You can double-click on it, or highlight it and press ENTER or click OK.

Directory.  Select the directory code that identifies the individual you wish to receive the fax 
or E-mail, using the same procedure.

Fax Flag. Specify whether you want Oracle Utilities Billing Component to produce an E-
mail or a fax. You must clear the Null checkbox before you can make a selection.

5. Select Edit-›Add to save the information to the database.

6. Select Records-›Refresh or Records-›Refresh All to update the displays with the new 
information. 

How to include the Service Center in the fax or E-mail:

You may want to identify the Service Center responsible for the account in its fax or E-mail. If so, 
you’ll need to supply that information in the account’s record in the Account Table.

1. Select File-›Browse Customer/Account(s). 

The View Customer/Accounts Input dialog box appears.

2. Specify the ID of the desired account.

A data entry form for the account appears.

3. Scroll down to the Service Center Code field. Click the Null checkbox to remove the 
checkmark. Then, click the words ‘Service Center Code’ and select the lookup code that 
identifies the desired service center. You can double-click on the code, or highlight it and 
press ENTER or click OK.

4. Select Edit-›Add to save the information to the database.

5. Select Records-›Refresh or Records-›Refresh All to update the displays with the new 
information.
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Viewing and Printing Reports
One of the primary functions of Oracle Utilities applications is to generate reports. Each of the 
various analysis modules generate reports, and the programs also generate a number of other 
useful reports as well. 

Once a report has been generated, it appears in an open report window on the application 
desktop. Once in an open report window, you can view and/or print the report. This section 
describes how to view and print reports generated using Oracle Utilities applications.

Viewing and Searching Reports
You can search for a specific word or words (or numbers) in an open report window using the 
Find option. The Find option (selected from the Edit Menu) allows you to search for a word or 
words in an open report window. When you select this option (or press F3), the Find dialog opens.

Enter the word or words you wish to find and click OK. To find the next instance of the word or 
words with the Find dialog still open, click Find Next. To find the previous instance of the word 
or words with the Find dialog still open, click Find Previous.

Once you’ve entered a word or words in the Find dialog, you can search by using the Find Next or 
Find Previous options from the Edit menu.

• To search for the next instance of the word or words last entered in the Find dialog, select the 
Find Next (or press Shift-F3) option.

• To find the previous instance of the word or words last entered in the Find dialog, select the 
Find Previous (or press Ctrl-F3) option.

Moving to a Specific Line in a Report
You can also jump to a specified line number within an open report window by using the Go to 
option. The Go to option (selected from the Edit Menu) allows you to move to a specific line in 
an open report window. When you select this option (or press Ctrl-G), the Go To tab on the Find 
dialog opens.

Enter the line number in the report that you wish to move to and click OK.

Changing the Appearance of Reports
You can also change the appearance of the text in an open report window using the Font option 
(from the Edit menu). When you select the Font option, the Font dialog opens.

To change the font in the report window, select a new Font, Style, and Size and click OK. The text 
in the report window will display and print the font/style/size selected.

Printing Reports
You can also print reports using the Print option (from the File menu). When you select the Print 
option, the Print dialog opens.

To print the report, complete the Print dialog as appropriate:

• Ignore page breaks: Check this to ignore the page breaks in the report.

• Page width in characters:  Enter the desired width of the report.

• Display line numbers:  Check this to include line numbers on the report.

Once you’ve completed the dialog, click OK. A standard Windows Print dialog will open, allowing 
to set any desired print options.
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Creating Graphs
You can also create graphs from data in open report windows. 

How to Create a Graph:

1. Select the Graph option from the View Menu (available only when an open report window is 
displayed), the Create Graph dialog opens.

2. Select an Account ID you wish to graph from the Select Account ID to Graph box. A list of 
available rows to graph will appear in the Select Rows to Graph box.

3. Select a row to include on the graph and click Add. The selected row will appear in the Pairs 
to Graph box. Repeat this step for each Account ID/row pair you wish to include in the 
graph. 

To remove a pair, select it and click Remove.

4. Enter an optional title for the graph in the Title box and click OK. The graph will appear in a 
window.

5. To change the view of the graph, select from the options in the View menu.

• The Style option allows you to select from bar graph style (as above) or line graph style.

• The Background Color option allows you select the background color for the graph 
(White, Gray, Dark Gray, or Black).
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Chapter 4
Review Billing Checklist

To help ensure that bills are issued on time, Oracle Utilities Billing Component provides a 
convenient report that checks the availability of data required for billing selected accounts or 
customers. The Review Billing Checklist function creates a report that lists any missing data for 
each customer and/or account you specify over a given data range. Missing data can include 
special events, interval data, and bill determinants. You can then use this report to track down the 
required data you need in order to process bills on time.

This chapter explains how to run the Review Billing Checklist function to preview the availability 
of required billing data for selected accounts and customers, including:

• Running the Review Billing Checklist

• Tips for Tracking Down Missing Data
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Running the Review Billing Checklist
It’s recommended that you run the Review Billing Checklist function one or two days before the 
bills are scheduled to be computed, to provide ample time for resolving any problems.

How to run the “Review Billing Checklist”:

1. Select CIS Billing-›Review Billing Checklist.

The Review Billing Checklist dialog appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• All: Oracle Utilities Billing Component automatically applies the checklist to all accounts 
or customers whose scheduled meter read date falls within the date range specified in the 
“Read Dates From” fields lower in the dialog box.

• ID:  Type the ID of the account or customer for this report.

• List: Select the list for this report. For example, you might have a list of all accounts that 
use a particular special event code. If you believe that the contents of the list may have 
changed since the last time that the query associated with it was run, check the box for 
Refresh list before using. This option updates the list for this job and saves the new 
version of the list to the database, replacing the old version. See the Data Manager User’s 
Guide for information about creating Customer and Account lists.

• File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Enter the Read Dates for the report. This is the date range within which an account’s 
scheduled meter read date must fall in order for its data to be evaluated. The date range 
initially displayed is automatically calculated using the Eligibility Pre and Post Window 
settings in the Default Billing Options dialog. See Chapter 7: Setting Global Defaults 
and Applying Settings to Accounts, Rate Codes, and Rate Schedules in the Oracle 
Utilities Billing Component Installation and Configuration Guide, Volume 1 for more information.

5. Select the accounts to Display in the report. Select one of the following:

• All accounts:  Report all accounts that match the above specified criteria, regardless of 
the status of their data.

• Only Those With Missing Data: Report all accounts that match the above specified 
criteria, and have problems with their data that need to be addressed.

• Ignore bill accounts: Ignore accounts that have been previously billed (those that have 
a non-NULL Bill Time in the Bill History record for the specified bill period).

• Check Merge and Validation Flags: Check the Merge and Internal Validation flags on 
interval data cuts applicable for the specified bill period. A cut is considered valid when 
one of the following conditions is true:

• The Merge Flag is set to ‘Y’, or

• The Merge flag is set to ‘N’ but the Internal Validation flag is set to ‘Y’.

6. Select the types of missing data to check for. This option is available only when the display 
Only Those With Missing Data radio button is selected under Display. Check every data 
type that you wish to include in the report:

• Special events: Report displays every applicable special event that’s missing a valid ready 
flag (see Approving Overrides Prior to Billing (Override Ready Table) on page 6-7 
in the Oracle Utilities Billing Component Installation and Configuration Guide, Volume 1).

• Interval data:  Report identifies missing or invalid cuts.
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• Bill determinants:  Report identifies missing or invalid bill determinant values.

7. Optional. If you want to override your default report options for this report, output the bill 
report to a file, or add titles to the report, click the Report Options button. See Chapter 3: 
Working with Reports for more information.

8. Click OK to run the report.

The report alerts you to missing data that requires attention.

9. To close the report, select File-›Close.
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Tips for Tracking Down Missing Data
The Review Billing Checklist report lists any missing data based on the specified accounts/
customers and date range. Here are a few tips that can help you track down missing data.

Missing Special Events
Problem: Oracle Utilities Billing Component was unable to locate a Special Event Ready Flag 
required for the account. Or, a billing analyst set the Ready flag, but too many days elapsed 
between the time he/she set the flag and the time that all of the account’s other billing data was 
available. The requirement for a Special Event Ready Flag is specified in the Override Use Table. 
The number of days in the Special Events Pre Window is defined in the Default Billing Options 
dialog box.

Solution: Verify that all required special event overrides have been entered for the account for the 
bill period in the Override History and/or Name Override History tables. When you have verified 
this information, set the Override Ready flag. See Approving Overrides Prior to Billing 
(Override Ready Table) on page 6-7 in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information.

Reminder: If a special event is recorded in the Override Use Table for an account, you must set 
the Ready flag in the Override Ready Table in order for the account’s bill to be issued, even if the 
special event did not occur that month.

Missing Interval Data (Channels)
Problem: Oracle Utilities Billing Component was unable to locate a required interval data cut for 
a specific recorder-channel. Either the cut was never entered into the Interval Database; or, if it 
was, its stop-time was outside the eligibility window.

Solution: Look for the cut in the Interval Database using the Interval Data Browser (see the Data 
Manager User’s Guide). If the cut is not listed, contact your meter shop to determine if there was a 
problem reading the meter.

If the cut is available in the Interval Database, check its stop-date to make sure that it falls within 
the eligibility window that applies to this cut.  If the stop-date and time is outside the window, 
there are two possible solutions that will enable you to bill the account:

• You can bill the account with Current/Final Bill using the cut’s recorded stop-date. In the 
Current/Final Bill Input dialog box, select the User Specified option for “Bill to Date and 
Time” and enter the cut’s actual stop-date and -time.

• If this problem is a frequent occurrence for this account, you might consider increasing the 
size of the eligibility pre- or post-window for the account or its recorder (see Chapter 7: 
Setting Global Defaults and Applying Settings to Accounts, Rate Codes, and Rate 
Schedules in the Oracle Utilities Billing Component Installation and Configuration Guide, Volume 1).

Missing Bill Determinants
Problem: Oracle Utilities Billing Component was unable to locate a required bill determinant 
value in the account’s Bill History record.

Solution: Look at the Bill History tab for the account using Data Manager’s Account-Centric 
View (see the Data Manager User’s Guide) to determine the specific data that is missing.
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Chapter 5
Automatic Billing

In the Automatic Billing mode, the software automatically identifies “eligible” and “available” 
accounts, calculates their bills, updates the Bill History records, and puts the results in transaction 
records that can be processed—all without user intervention. This chapter describes how you set 
up and run automatic billing, including:

• Purpose of Automatic Billing

• Defining Automatic Billing Parameters and Starting the Automatic Billing Process

This chapter assumes that you are familiar with the way in which bills are processed by Automatic 
Billing. If not, read The Billing Process in Chapter 1: Introduction to Oracle Utilities Billing 
Component before continuing.
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Purpose of Automatic Billing
Automatic Billing calculates bills automatically without requiring a billing analyst to visually 
inspect and approve the results before the transaction records can be issued and bill history record 
updated. The user sets the parameters the module uses to process the bills, including the Bill Date, 
the Repeat Frequency (the amount of time between jobs) and other settings.

Automatic Billing selects “eligible” accounts based on scheduled meter read dates and “available” 
accounts based on the presence of required billing data (special event overrides, bill determinants, 
and interval data).

Note: In most cases, Automatic Billing is configured to run on a scheduled 
basis on either a dedicated machine or an application server.
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Defining Automatic Billing Parameters and Starting the Automatic 
Billing Process

You start and stop Automatic Billing using the Automatic Billing Parameters dialog box. In 
addition, you can override some of the global billing parameters for Automatic Billing based on 
the parameters you assign.

Note: Access to the Automatic Billing Parameters dialog box is limited to 
authorized workstations.

How to set up and start Automatic Billing:

1. Select CIS Billing-›Automatic Billing. (If the option is grayed out, you may not have access 
to it.)

The Automatic Billing Parameters dialog box appears.

2. Select the Bill Date. This is the date that Oracle Utilities Billing Component compares 
against the eligibility windows. It should usually be set to the current date (except during 
software testing), but can be set to any date.

Note: Each 24 hours after Automatic Billing is started, the bill date set is incremented by one 
day.

3. Set the Repeat Frequency for the run. This is the number of minutes between automatic 
billing job runs—that is, after completing the billing of one set of accounts, Oracle Utilities 
Billing Component waits the specified number of minutes before scanning for data for the 
remaining eligible accounts. When all information is available for the eligible accounts, Oracle 
Utilities Billing Component automatically calculates their bills.

Note: Due to memory limitations in the GUI version of Automatic Billing, only 10,000 
accounts are billed per try. If more accounts can be billed, they will be billed when Automatic 
Billing tries again. The batch executable autobill.exe does not have this limitation.

Specify any value from 0 to 1440. If you specify 0, Oracle Utilities Billing Component runs 
one job and stops. If you specify 1, the jobs run continuously. If you specify 60, the system 
runs one job each hour. If you specify 1440, Oracle Utilities Billing Component runs one job 
per day.

4. Select the appropriate Save/Approve Options. This option allows you to specify if and how 
results are saved to the database. The available options are:

• Do not enable saves of any kind: With this option selected, Rules Language SAVEs do 
not save and no CIS transaction record are written to the CIS file. This is the option 
you’ll choose most often when testing rate forms.

• Automatically save/approve each group of related pages if all OK: If you select this 
option and there are no errors while billing an account (or related accounts, for a 
summary customer), it is automatically approved and its database and CIS records 
written. If one account of a summary group of accounts has an error, all other related 
accounts are not approved.

Note: If a Warning occurs during Automatic Billing processing for an account, the bill is 
not approved.

5. Select the appropriate Summary Options. This option allows you to specify how to handle 
summary billing. The available options are:

• Include Related Summary Accounts: Select this option to bill all accounts that belong 
to a customer with the Summary Bill flag set to ‘Y’ at the same time.

• Bill All Accounts Individually: Select this option to bill only the accounts with read 
date near today, ignoring the Summary Bill flag.
Automatic Billing 5-3



Defining Automatic Billing Parameters and Starting the Automatic Billing Process
• Bill Only non-Summary Accounts: Select this option to bill only non-summary 
accounts.

• Bill Only Summary Accounts: Select this option to bill only summary accounts. See 
Setting Up Summary Bills for Customers on page 7-15, and Summary Bill 
Calculation on page 4-20 in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information about processing summary bills.

6. Select the data to display in the report. You can select the following options:

• Display only Accounts with Billing Errors/Warnings: This option is checked by 
default, because most accounts should automatically bill successfully. If this option is 
unchecked, all accounts will be displayed.

• Display Accounts not billed: If this box is checked, Oracle Utilities Billing Component 
displays why eligible accounts were not billed. If this box is unchecked, Oracle Utilities 
Billing Component displays only successful bills.

• Do not delete report display when done: This option leaves the display window 
visible after a run completes. If this is not checked, the report display window will be 
deleted when the run completes (after it is written to a file). The report should be deleted 
if Automatic Billing is run repeatedly, as the displayed reports use memory.

7. Specify the Output File Name: Name of the file to which Oracle Utilities Billing 
Component writes the results of the bill calculations (e.g., the “transaction records”) at the 
conclusion of the job. The default is LODESTAR.CIS. See Appendix A: Creating a CIS 
Transaction Record Output File in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information.

8. Select a Message from the drop-down list. This field displays error messages based on the 
parameters set. These alert you to any problems that have occurred while attempting to 
process the bills.

9. Optional. If you wish to override any of default report options, click Report Options, and 
complete the dialog box that appears. See Chapter 3: Working with Reports for more 
information.

10. To start the Automatic Billing process, click OK.

While Automatic Billing is running, a Progress Indicator is displayed. It shows the current 
status of a job in process, or the time until the next job begins.

How to Stop Automatic Billing:

1. To stop Automatic Billing, click the Abort button in the Progress Indicator window.

The software finishes processing the current account, then stops.
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Chapter 6
Approval Required Billing

This chapter explains how to process billing calculations using Approval Required billing, 
including:

• Calculating Approval Required Bills

• Approving/Exporting/Rejecting Bills

Approval Required billing calculates bills that a billing analyst must visually inspect and approve 
before the transaction records can be issued and the bill history record updated. This module 
differs from Automatic Billing in two ways:

• You must manually initiate the calculations. Approval required billing still selects “eligible” 
accounts based on scheduled meter read dates, and “available” accounts based on the 
presence of required billing data (special event overrides, bill determinants, and interval data).

• You must view and approve the results in order for Oracle Utilities Billing Component to 
issue the transaction records and update the Oracle Utilities Data Repository.

When viewing the results, you have the option to either reject or skip bills that appear 
unsatisfactory. If you reject a bill, Oracle Utilities Billing Component attaches a “USER 
REJECTED” note to it, and from that point the account’s bill for that period can only be 
issued manually via the Current/Final Bill module (see Chapter 7: Current/Final Bill). If 
you skip a bill (that is, neither approve or reject it), the “Approval Required” module will retry 
the calculations the next time it is run. In general, it is recommended that you skip the bill and 
let Oracle Utilities Billing Component rerun it. However, if you want to ensure that it is not 
approved (by another user, for example), then rejecting the bill is the best course.
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Calculating Approval Required Bills
How to set up and start the calculations:

1. Select CIS Billing-›Approval Required.

The Approval Required Billing Parameters dialog box appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers to be billed using one of the following options:

• ID:  Type the ID of the account or customer to be billed.

• List: Select the list of accounts or customers to be billed. If the contents of the list may 
have changed since the last time that the query associated with it was run, check the box 
for Refresh list before using. This option updates the list for this job and saves the new 
version of the list to the database, replacing the old version.

• All: Oracle Utilities Billing Component looks for all accounts or customers whose 
scheduled meter read date falls some number of days before and after the Bill Date 
specified below. The number of days is indicated in the Default Eligibility Pre Window 
and Default Eligibility Post Window fields in the Default Billing Options dialog 
box. See Chapter 7: Setting Global Defaults and Applying Settings to Accounts, 
Rate Codes, and Rate Schedules in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information.

• File - Select a file containing a list of customer/account IDs (*.ids), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Select the Bill Date for the bill. This date is compared against the eligibility window. 
Typically, this should be today (the current date), but you can use other dates for testing 
purposes.

5. Select the Billing Mode for the bill. As described in Chapter 7: Setting Global Defaults 
and Applying Settings to Accounts, Rate Codes, and Rate Schedulesin the Oracle 
Utilities Billing Component Installation and Configuration Guide, Volume 1, there are many methods 
of setting the billing mode for an account. Use this feature to select accounts for billing based 
on how the Approval Required flags were set in the Oracle Utilities Data Repository. You 
can select any one or a combination of the three options:

• Account Level:  Only bill accounts that have their billing mode flag set to “Approval 
Required” in the Account Table.

• Rate Schedule/Rate Code Level: Only bill accounts that are on a rate schedule whose 
billing mode flag is set to “Approval Required” in the Rate Form Table.

• Default Level: Bill accounts that default to approval required. This option is only 
enabled if Approval Required is the default billing mode set on the Billing Options tab of 
the Default Billing Options dialog. See Default Billing Options on page 2-16 for more 
information.

To bill all accounts that require approval, leave all boxes checked.

6. Also show accounts not billed: Check this box to display why an eligible account was not 
billed. This option is particularly useful for testing. If the box is unchecked, Oracle Utilities 
Billing Component displays only bills that calculated successfully. 

7. Select the appropriate Save/Approve Options. This option allows you to specify if and how 
results are saved to the database. The available options are:

• Do not enable saves of any kind: With this option selected, Rules Language SAVEs do 
not save and no CIS transactions record are written to the CIS file. This is the option 
you’ll choose most often when testing rate forms.
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• Enable user approve/reject of saves: When this option is selected, you can either 
Approve or Reject each set of results. If you approve an account (or an account and all 
its related accounts), the bill will be rerun with Automatic Approval. This second run will 
generate the same results, and will create database and CIS records.

• Automatically save/approve each group of related pages if all OK: If you select this 
option, then if there are no errors while billing an account (or related accounts for a 
summary customer) it is automatically approved and its database and CIS records 
written.

• Automatically save/approve each page if it is OK:  If you select this option, then 
data from each non-error page of an account is automatically written, regardless of the 
errors in other pages of the account or other related accounts. 

8. Select the appropriate Summary Options. This option allows you to specify how to handle 
summary billing. The available options are:

• Include Related Summary Accounts:  This option enables you to bill only the 
account(s) with read date near today, ignoring the Summary Bill flag. Usually all accounts 
that belong to a customer with the Summary Bill flag set to ‘Y’ are billed at the same 
time.

• Bill All Accounts Individually: Select this option to bill all accounts individually.

• Bill Only non-Summary Accounts: Select this option to bill only non-summary 
accounts.

• Bill Only Summary Accounts: Select this option to bill only summary accounts. See 
Setting Up Summary Bills for Customers on page 7-15, and Summary Bill 
Calculation on page 4-20 in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information about processing summary bills.

9. Specify the Output File Name for the bill. Name of the file to which Oracle Utilities Billing 
Component writes the transaction record for approved bills. The default is LODESTAR.CIS. 
See Appendix A: Creating a CIS Transaction Record Output File in the Oracle Utilities 
Billing Component Installation and Configuration Guide, Volume 1 for more information.

10. If desired, click Report Options to modify settings. See Chapter 3: Working with Reports 
for more information.

11. Click OK to run the report.
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Approving/Exporting/Rejecting Bills
As Oracle Utilities Billing Component runs the job, it displays the results of the bill calculations in 
a report window. You can begin to review and approve/reject the bills even before the job has 
completed. You can approve, export, reject, or skip each bill.

Each page in the report contains the results for one bill. Before approving or rejecting a bill, you 
must scroll the report so that the desired bill is the “current” page. The current page is the one 
with the highlighted line in it. The line automatically moves down the window as you scroll the 
display. If desired, you can simply click in a page to make it the current one.

How to approve a bill:

1. With the report properly positioned in the window, select Review-›Approve Account, or 
click the right mouse button and select “Approve” from the pop-up menu. Approving a bill 
creates the transaction record and updates the bill history record.

How to Export the bill to a CIS File: 

1. With the report properly positioned in the window, select 
Review-›Export to CIS, or click the right mouse button and select “Export to CIS” from the 
pop-up menu. Exporting a bill does not create the transaction record, and does not update 
the bill history record.

After exporting the report, you can still either Approve or Reject the bill.

How to reject a bill:

1. With the report properly positioned in the window, select Review-›Reject Account, or click 
the right mouse button and select “Reject” from the pop-up menu. Enter your reasons for 
rejecting the account in the window that appears. When you or another user runs the Billing 
Exceptions report, your entry here will appear in the report next to the USER REJECTED 
code for the account. See Chapter 8: Review Billing Exceptions for more information.

How to skip a bill:

1. Simply scroll past the page. Oracle Utilities Billing Component will retry the bill in the next 
run of the Approval Required module.

How to issue a fax or E-mail for an account or customer:

• For Approval Required accounts: If an “approval required” account or customer is set up 
to receive a bill fax or E-mail, it is automatically created when you approve the account. The 
E-mail is saved to a file in the USER directory, or in the case of a fax, the fax is printed.

• To create a fax/E-mail “on demand”: You can issue the fax or E-mail “on demand” 
without approving the bill by selecting Review-›Fax/Email after the report is properly 
positioned in the window. 

Note: The account or customer must have already been set up to receive a fax 
or E-mail in order for this feature to work. See Chapter 3: Working with 
Reports for more information.

Important notes about Approving/Rejecting Bills
Here are some important points to keep in mind when approving or rejecting a bill:

• Approval/rejection on one page of a bill approves or rejects all calculations in the bill.

• Approval/rejection for one month of a period rebill or cancel/rebill approves/rejects all 
months.

• Approval/rejection on one account of a summary bill approves/rejects the summary bill and 
all accounts.
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After it is approved or rejected, a bill for an account will not be rerun in Approval Required mode 
for this bill period. Rejected bills must be corrected and issued manually using the Current/Final 
Bill module. See Chapter 7: Current/Final Bill, for more information.
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Chapter 7
Current/Final Bill

This chapter explains how to process billing calculations using Current/Final Bill, including:

• Calculating a Current/Final Bill

• Approving/Exporting/Rejecting Bills

Current/Final Bill enables you to manually initiate bill calculations for a single account for a user-
specified period. There are four primary applications for this feature:

• Issue an “approval” copy for the customer’s examination - In some cases, the customer 
may wish to preview a bill before it’s actually issued. You can use Current/Final Bill to create 
a preliminary report for the customer. When the customer has OK’d the bill, you can approve 
the calculations, which in turn creates the transaction records and updates the Bill History 
record.

• Issue a bill that had been Rejected in the Approval Required or Automatic mode - If a 
bill was stopped or rejected in the Approval Required or Automatic mode, you must correct it 
and rerun it using “Current/Final Bill.” When a bill has been stopped or rejected, it cannot be 
rerun in Approval Required or Automatic mode.

• Issue the current bill for an account, despite missing data - There may be special 
instances when you need to issue a bill for an account, despite the lack of normally-required 
data. For example, an interval data cut for a required recorder may be missing. Current/Final 
Bill enables you to overrule any requirements and calculate the bill using the data that is 
available.

• Issue the final bill for an account - In this mode, Oracle Utilities Billing Component not 
only issues the transaction record with the correct code for a final bill, but also automatically 
closes the account in the Oracle Utilities Data Repository by adding a stop-date and -time to 
the Account Table. Oracle Utilities Billing Component will not bill an account after its stop 
date.

Note: If you want verification of final bills, include the 
CHECK_FINAL_BILL configuration parameter in the LODESTAR.CFG 
file. This causes a confirmation dialog to open when approving the bill that asks 
if you’re sure you want to create a Final Bill. This option only functions when 
you select the “Enable User Approve/Reject of Saves” option on the Current/
Final Bill Input dialog.
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Calculating a Current/Final Bill
How to process a Current/Final Bill:

1. Select CIS Billing-›Current/Final Bill.

The Current/Final Bill Input dialog box appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers to be billed using one of the following options:

• ID:  Type the ID of the account or customer to be billed.

• List: Select the list of accounts or customers to be billed. If the contents of the list may 
have changed since the last time that the query associated with it was run, check the box 
for Refresh list before using. This option updates the list for this job and saves the new 
version of the list to the database, replacing the old version.

• All: Oracle Utilities Billing Component looks for all accounts or customers whose 
scheduled meter read date falls some number of days before and after the Bill Date 
specified below. The number of days is indicated in the Default Eligibility Pre Window 
and Default Eligibility Post Window fields in the Default Billing Options dialog 
box. See Chapter 7: Setting Global Defaults and Applying Settings to Accounts, 
Rate Codes, and Rate Schedules in the Oracle Utilities Billing Component Installation and 
Configuration Guide, Volume 1 for more information.

• File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Select the Bill Type. Specify the type of bill to issue:

• Current Bill:  Issues a “regular” transaction record.

• Final Bill: Issues a “final bill” transaction record, and puts a stop date and time in the 
Account Table in the Oracle Utilities Data Repository, closing the account.

5. Select the Bill To Date and Time: The start date of the bill period is automatically the end 
of the previous bill period (unless the account is new, in which case it is the account’s start 
date). You have two options:

• Compute: The program determines the end of the current bill period, using the 
following rules:

• If the account is billed using one channel of interval data, Oracle Utilities Billing 
Component uses the stop date and time of the last cut recorded by the channel.

• If the account is billed using multiple channels of interval data, it uses the earliest 
stop date and time among the multiple cuts.

• If the account is billed using billing determinants only (no interval data), it uses the 
actual read date and time recorded with the billing determinant data in the account’s 
most recent Bill History record. Note: The cut’s stop time must be within the pre- 
and post-window of the account’s scheduled read date, or else the cut is considered 
“missing” and Oracle Utilities Billing Component will not issue the bill.

• User specified: You supply the desired stop date and time. Your input here overrides 
any stop dates specified elsewhere, such as the account’s actual read date in its Bill 
History record.

Use the MM/DD/YYYY and HH:MM:SS formats for start-date and -time, respectively. 
The beginning of the day is 00:00:00, the end is 23:59:59.

Click Today to apply today’s date and the current time (you can type a new time, if 
desired).
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6. Select the appropriate Save/Approve Options. This option allows you to specify if and how 
results are saved to the database. The available options are:

• Do not enable saves of any kind: With this option selected, Rules Language SAVEs do 
not save and no CIS transactions record are written to the CIS file. This is the option 
you’ll choose most often when testing rate forms.

• Enable user approve/reject of saves: When this option is selected, you can either 
Approve or Reject each set of results. If you approve an account (or an account and all 
its related accounts), the bill will be rerun with Automatic Approval. This second run will 
generate the same results, and will create database and CIS records.

• Automatically save/approve each group of related pages if all OK: If you select this 
option, then if there are no errors while billing an account (or related accounts for a 
summary customer) it is automatically approved and its database and CIS records 
written.

• Automatically save/approve each page if it is OK:  If you select this option, then 
data from each non-error page of an account is automatically written, regardless of the 
errors in other pages of the account or other related accounts. 

7. Select whether or not to Include Related Summary Accounts: To bill only the account(s) 
you select, ignoring the Summary Bill flag, uncheck this option. Usually all accounts that 
belong to a customer with the Summary Bill flag set to ‘Y’ are billed at the same time. 

8. Specify an Output File Name. Name of the file to which Oracle Utilities Billing Component 
writes the transaction record for approved bills. The default is LODESTAR.CIS. See 
Appendix A: Creating a CIS Transaction Record Output File in the Oracle Utilities Billing 
Component Installation and Configuration Guide, Volume 1 for more information.

9. If desired, click Report Options to modify settings. See Chapter 3: Working with Reports 
for more information.

10. Click OK to run the report.
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Approving/Exporting/Rejecting Bills
As Oracle Utilities Billing Component runs the job, it displays the results of the bill calculations in 
a report window. You can begin to review and approve/export/reject the bills even before the job 
has completed. You can approve, export, reject, or skip each bill.

Each page in the report contains the results for one bill. Before approving or rejecting a bill, you 
must scroll the report so that the desired bill is the “current” page. The current page is the one 
with the highlighted line in it. The line automatically moves down the window as you scroll the 
display. If desired, you can simply click in a page to make it the current one.

How to approve a bill:

1. With the report properly positioned in the window, select 
Review-›Approve Account, or click the right mouse button and select “Approve” from the 
pop-up menu. Approving a bill creates the transaction record and updates the bill history 
record.

Note: If you have the CHECK_FINAL_BILL configuration parameter in the 
LODESTAR.CFG file, when approving a Final Bill, a confirmation dialog 
opens asking you if you’re sure you want to create a Final Bill. This option only 
functions when you select the “Enable User Approve/Reject of Saves” option 
on the Current/Final Bill Input dialog.

How to Export the bill to a CIS File: 

1. With the report properly positioned in the window, select 
Review-›Export to CIS, or click the right mouse button and select “Export to CIS” from the 
pop-up menu. Exporting a bill does not create the transaction record, and does not update 
the bill history record.

After exporting the report, you can still either Approve or Reject the bill.

How to reject a bill:

1. With the report properly positioned in the window, select 
Review-›Reject Account, or click the right mouse button and select “Reject” from the pop-
up menu. Enter your reasons for rejecting the account in the window that appears. When you 
or another user runs the Billing Exceptions report, your entry here will appear in the report 
next to the USER REJECTED code for the account. See Chapter 8: Review Billing 
Exceptions for more information.

How to skip a bill:

1. Simply scroll past the page. Oracle Utilities Billing Component will retry the bill in the next 
run of the Current/Final module.

issued manually using the Current/Final Bill module.

How to issue a fax or E-mail for an account or customer:

• For Current/Final Bills: If an account or customer is set up to receive a bill fax or E-mail, it 
is automatically created when you approve the account. The E-mail is saved to a file in the 
USER directory; the fax is printed.

• To create a fax/E-mail “on demand”: You can issue the fax or E-mail “on demand” 
without approving the bill by selecting Review-›Fax/Email after the report is properly 
positioned in the window. 

Note: The account or customer must have already been set up to receive a fax 
or E-mail in order for this feature to work. See Chapter 3: Working with 
Reports for more information.
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Important notes about Approving/Rejecting Bills
Here are some important points to keep in mind when approving or rejecting a bill:

• Approval/rejection on one page of a bill approves or rejects all calculations in the bill.

• Approval/rejection for one month of a period rebill or cancel/rebill approves/rejects all 
months.

• Approval/rejection on one account of a summary bill approves/rejects the summary bill and 
all accounts.

When it is approved or rejected, a bill for an account will not be rerun in Approval Required mode 
for this bill period. Rejected bills must be corrected and issued manually using the Current/Final 
Bill module.
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Chapter 8
Review Billing Exceptions

The Review Billing Exceptions report gives you a “snapshot” of the status of bills in the system 
based on “account notes” or work queue items. These are records that alert billing analysts to 
actual or potential problems that occurred during the billing process, such as missing data or 
charges that appear to be “too high”. Account Notes/Work Queue Items can be entered either by 
Oracle Utilities Billing Component or by a user. For example, the report shows accounts that 
should have been billed but were not (eligible but not available), or that were rejected by a user 
upon inspecting the results of the calculations. With the report displayed, you can immediately 
jump to the appropriate Oracle Utilities Billing Component module to further examine and 
correct the problem.

This chapter explains how to review the status of bills using the Review Billing Exceptions report, 
including:

• Running the “Review Billing Exceptions” Report

• Description of Account Notes/Work Queue Items
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Running the “Review Billing Exceptions” Report
You should run the Billing Exceptions Report each day, to check for any errors or problems that 
may have occurred during the billing process.

How to run the “Review Billing Exceptions” report:

1. Select CIS Billing-›Review Billing Exceptions.

The Review Billing Exceptions and Rejections dialog appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List: Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for. If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using. 
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• All: Oracle Utilities Billing Component applies the report to all accounts

• File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Select the Account Note Period for the period. Specify the date range covered by the report. 
The date that an account note was entered must fall within this range in order for the note to 
be included in the report.

5. Select the Account Note Codes to include in the report. Select one of the following:

• All Codes: Include all Account Notes/Work Queue Items that were entered for the 
specified accounts during the reporting period.

• Codes List:  Include just selected codes.  When you select this button, you can then 
highlight any and all desired codes in the list box to the right. To select more than one 
code, hold down the CTRL key and select each code to be included. 

6. Select whether or not to Ignore billed accounts. Check this box to exclude notes for any 
bills that had errors but have since been corrected and billed.

7. If desired, click Report Options to modify settings. See Chapter 3: Working with Reports 
for more information.

8. Click OK to run the report.

The report alerts you to any problems that require attention. The dialog box below is an 
example.

9. To close the report, select File-›Close.

Important: If an account has an EXCEPTION or other note that indicates the bill will be issued 
late, be sure to attach a PROBLEM description to it, so that it can be tracked using the Late Billing 
report. See Chapter 10: Problem Bills and the Late Bill Report for more information.
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Description of Account Notes/Work Queue Items
Account Notes and/or Work Queue Items can stop an account from being billed in the 
Automatic or Approval Required modes, or they can be informational only. When a bill is 
stopped because of an Account Note/Work Queue Item, it can still be issued automatically if 
corrected before the eligibility window expires. If the eligibility window passes, the bill can only be 
issued manually via the Current/Final Bill module. See Chapter 7: Current/Final Bill for more 
information.

Note: When using Work Queues, exceptions are written to the Work Queue 
Open Item table instead of the Account Notes table. To enable the Work 
Queues application, include the 
USE_WORK_Q_FOR_ACCOUNT_NOTES = 1 parameter in the 
LODESTAR.CFG file.

Below is a list of the standard Account Note/Work Queue Item types, their meaning, and impact 
on the billing process. Your facility may have more note types (the types in use at your facility are 
stored in the Account Note Type Table or the Work Queue Type table in the Oracle Utilities Data 
Repository).

Note: Changing the Stop Billing flag on these Account Notes/Work Queue 
Item types has no effect on the billing process.

Prevents billing for an account?

Code  Automatic  Appr Req  Meaning

ABORT     An ABORT statement in the rate 
form executed during bill 
calculation.

EXCEPTION  Data missing on day after post-
window.

HOLD  User requested hold via Browser 
or Account-Centric View.

INFO Informative note supplied by user 
via Browser or Account-Centric 
View.

SYSTEM 
REJECTED

 Invalid data or failure during bill 
calculation.

USER REJECTED  User rejected after review of 
calculations.

WARNING  A WARN statement in the rate 
form executed during bill 
calculation.
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Chapter 9
Bill Corrections

This chapter explains how to correct and re-issue old bills, or add an adjustment to a current bill 
using Bill Corrections, including:

• Correcting a Bill

• Approving/Exporting/Rejecting Bills

Bill Corrections enable you to cancel previously issued bills and issue either an adjustment or new 
bills. Adjustments can be made to any bill. New bills (rebills) can be issued for the current bill 
period, as well as for any previous bill period. This module is useful for fixing problems found by 
a billing analyst or customer, and for responding to customer requests for a change in the 
application of an override (to waive a peak, for example).
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Correcting a Bill
How to process a Bill Correction:

1. Select CIS Billing-›Bill Correction.

The Bill Correction dialog box appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List: Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for. If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using. 
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• All: Oracle Utilities Billing Component applies the report to all accounts

• File: Select a file containing a list of customer/account IDs (*.ids), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Select the Bill Type. Select one of the following:

• Cancel/Rebill: Cancels the previous bill(s) and issues new one(s) in their place. Issues 
Cancel transactions to the output file for the current bill month through the oldest 
month, and Issues Rebill transactions from the oldest month through the current month.

• Adjustment: Leaves the old bills in place and adds an adjustment to the new one. 

• Cancel Only: Sends transactions to the output file to cancel bill(s). If there are multiple 
bills, the order of the Cancel transaction records is current bill month through the oldest 
month. WARNING: The system does not ask for a confirmation before issuing the 
cancellations. Note: If you cancel a bill, you must rebill it. The separate Cancel Only and 
Rebill Only options enable you to perform the operation in two steps—if you need some 
time to investigate the rebill, for example. 

• Rebill Only: Issues a new bill or bills to replace the canceled bill(s). If there are multiple 
bills, the order of the Rebill transaction records is oldest bill month through the current.

5. Select the Billing Dates for the bill. Enter the billing dates for the bill correction. The 
available options are:

• Bill Period(s) to correct: Enter the number of previous bill periods to correct—0 for 
the current bill period, 1 for the current and next most recent bill period, 2 for the 
current and two previous bill periods, and so on. For the current period, Oracle Utilities 
Billing Component uses the account’s most recent Bill History record that does not have 
a null value for Bill Date. The next bill period (in the case of multiple period corrections) 
is the next most recent bill history record, regardless of the value for Bill Date. Note: 
When you enter 0, Oracle Utilities Billing Component actually sends the number 01 to 
the output file; 1 is sent as 02, and so on.

• From bill history: This option allows you to select a specific bill period for the bill 
correction. Click Select to select a Bill History record. The Bill Month, Read Date, Bill 
From, and Bill To values are automatically populated. Note: This option calculates 
adjustments for the selected bill period only, and does not affect any subsequent billing 
periods. When you select this option, the following dialog opens, warning the user of this 
limitation.

6. Select the appropriate Save/Approve Options. This option allows you to specify if and how 
results are saved to the database. The available options are:
9-2 Billing Component (C/S) User’s Guide



Correcting a Bill
• Do not enable saves of any kind: With this option selected, Rules Language SAVEs do 
not save, and no CIS transactions record are written to the CIS file. This is the option 
you’ll choose most often when testing rate forms.

• Enable user approve/reject of saves: When this option is selected, you can either 
Approve or Reject each set of results. If you approve an account (or an account and all 
its related accounts), the bill will be rerun with Automatic Approval. This second run will 
generate the same results, and will create database and CIS records.

• Automatically save/approve each group of related pages if all OK: If you select this 
option, if there are no errors while billing an account (or related accounts for a summary 
customer), it is automatically approved and its database and CIS records written.

• Automatically save/approve each page if it is OK: If you select this option, data 
from each non-error page of an account is automatically written, regardless of the errors 
in other pages of the account or other related accounts. 

7. Select whether or not to Include Related Summary Accounts. To bill only the account(s) 
you select, ignoring the Summary Bill flag, uncheck this option. Usually, all accounts that 
belong to a customer with the Summary Bill flag set to ‘Y’ are billed at the same time. 

8. Select whether or not to Use Bill History Dates and Times. In the other billing modes 
there may not be a Bill History record for the bill period, and these modes may compute the 
bill start and stop dates. There is always a Bill History record to correct when issuing a Bill 
Correction. Checking this option tells Bill Correction to use the Bill History dates instead of 
computing them. It should almost always be left on. You can uncheck this option if you wish 
to view computed dates.

9. Select the Do not use current Bill History determinant values option f the account uses 
interval data, has already been billed, and you want to run the bill correction without using the 
saved bill determinants. Otherwise the current Bill History values will be used.

10. Select the Rebill Reason. This option is only available if the Rebill Reason 
(REBILLREASON) Table is present in the Oracle Utilities Data Repository. When available, 
this option allows you to select from a list of Rebill Reason codes when selecting one of the 
Rebill options (Cancel/Rebill or Rebill Only).

11. Specify the Output File Name: Name of the file to which Oracle Utilities Billing 
Component writes the transaction record for approved bills. The default is LODESTAR.CIS. 
See Appendix A: Creating a CIS Transaction Record Output File in the Oracle Utilities 
Billing Component Installation and Configuration Guide, Volume 1 for more information.

12. If desired, click Report Options to modify settings. See Chapter 3: Working with Reports 
for more information.

13. Click OK to run the report.
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Approving/Exporting/Rejecting Bills
As Oracle Utilities Billing Component runs the job, it displays the results of the bill calculations in 
a report window. You can begin to review and approve/export/reject the bills even before the job 
has completed. You can approve, export, reject, or skip each bill.

Each page in the report contains the results for one bill. Before approving or rejecting a bill, you 
must scroll the report so that the desired bill is the “current” page. The current page is the one 
with the highlighted line in it. The line automatically moves down the window as you scroll the 
display. If desired, you can simply click in a page to make it the current one.

How to approve a bill:

1. With the report properly positioned in the window, select Review-›Approve Account, or 
click the right mouse button and select “Approve” from the pop-up menu. Approving a bill 
creates the transaction record and updates the bill history record.

Important: If you approve one of the rebilled months, any and all others are approved as 
well.

How to Export the bill to a CIS File: 

1. With the report properly positioned in the window, select                     Review-›Export to 
CIS, or click the right mouse button and select “Export to CIS” from the pop-up menu. 
Exporting a bill does not create the transaction record, and does not update the bill history 
record.

After exporting the report, you can still either Approve or Reject the bill.

How to reject a bill:

1. With the report properly positioned in the window, select                     Review-›Reject 
Account, or click the right mouse button and select “Reject” from the pop-up menu. Enter 
your reasons for rejecting the account in the window that appears. When you or another user 
runs the Billing Exceptions report, your entry here will appear in the report next to the 
USER REJECTED code for the account. See Chapter 8: Review Billing Exceptions for 
more information.

How to skip a bill:

1. Simply scroll past the page. Oracle Utilities Billing Component will retry the bill in the next 
run of the Approval Required module.

How to issue a fax or e-mail for an account or customer:

• For Bill Corrections: If an account or customer is set up to receive a bill fax or e-mail, it is 
automatically created when you approve the account. The e-mail is saved to a file in the 
USER directory; the fax is printed.

• To create a fax/E-mail “on demand”: You can issue the fax or E-mail “on demand” 
without approving the bill by selecting Review-›Fax/Email after the report is properly 
positioned in the window. 

Note: The account or customer must have already been set up to receive a fax 
or E-mail in order for this feature to work. See Chapter 3: Working with 
Reports for more information.
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Important notes about Approving/Rejecting Bills:
Here are some important points to keep in mind when approving or rejecting a bill:

• Approval/rejection on one page of a bill approves or rejects all calculations in the bill.

• Approval/rejection for one month of a period rebill or cancel/rebill approves/rejects all 
months.

• Approval/rejection on one account of a summary bill approves/rejects the summary bill and 
all accounts.

When it is approved or rejected, a bill for an account will not be rerun in Approval Required mode 
for this bill period. Rejected bills must be corrected and issued manually using the Current/Final 
Bill module.
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Chapter 10
Problem Bills and the Late Bill Report

This chapter explains how to flag bills for inclusion in the Late Bill report, and how to produce the 
report itself, including:

• Flagging “Problem” Bills

• Creating a Late Bill Report

The Late Bill report makes it possible to monitor the progress of individual bills, track the interest 
lost due to the billing delays, and summarize all late bills so that you can identify and resolve any 
recurring problems.

There are two situations in which a bill is considered “late” and therefore included in the Late Bill 
report:

• Bills that were issued after their scheduled meter read date – A bill is considered on time 
if it is calculated and sent to the output file on or before the date that its meter was scheduled 
to be read. If Oracle Utilities Billing Component sends the transaction record to the output 
file on any day after the scheduled read date, the bill is considered late. Oracle Utilities Billing 
Component automatically finds late bills by comparing the date that the bill was issued to the 
output file with the account’s scheduled read date. Specifically, the program compares the 
account’s value for Bill Time with its value for Read Date in the Bill History Table. If the 
bill date was any time after the read date, the software automatically includes the account in 
the Late Bill report, even if the bill date was within the account’s post-window for eligibility.

• Unbilled accounts that are both past their read date, and have a manually assigned 
“Problem” description – Oracle Utilities Billing Component automatically attaches an 
EXCEPTION to any account whose billing data was unavailable by the scheduled read date 
and therefore could not be billed on time. In addition, Oracle Utilities Billing Component or 
a billing analyst can attach other kinds of Account Notes/Work Queue Items to an account 
to indicate a problem. These notes can actually halt the billing process for the account’s bill. It 
is the billing analyst’s responsibility to examine the Billing Exceptions and Rejections 
report for Account Notes/Work Queue Items such as an EXCEPTION, and to resolve any 
problems. If you want to use the Late Bill report to track bills that are being delayed in this 
manner, you must manually attach a “PROBLEM” description to the account. If you do not 
attach a “PROBLEM” description to the account, the account only appears in the report after 
the bill has been issued.
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Flagging “Problem” Bills
The following instructions explain how to flag an unissued bill as having a “problem.” You can 
also enter a brief description of the problem and its resolution.

As explained in the overview to this chapter, the “problem” flag causes an unbilled bill to be 
included in the Late Bill report. In addition, any problems and resolutions you enter into the Bill 
History Problem Table appear in the account’s bill report, as long as the Show Bill History 
Problems/Resolutions in Bill Reports option is checked on the Report Options tab under                            
CIS Billing-›Billing Options. See Default Billing Options on page 2-16 for more information. 
This feature applies to Approval Required, Current/Final Bill, and Bill Correction reports, but not 
Automatic Billing.

When you have identified the “problem” account via the Billing Exceptions and Rejection 
report., use the following procedure to attach a Problem flag to the account.

How to attach a Problem Flag to an account using the Browser: 

1. With the Billing Exceptions and Rejections report displayed, highlight a line containing the 
desired account ID.

2. Click the right mouse button, and select Browse Account from the pop-up menu that 
appears.

The Browser appears with tables for the selected account displayed.

3. Click the plus sign next to the Bill History table icon in the left pane. Verify that a Bill History 
record exists for the bill period in question. If Oracle Utilities Billing Component receives bill 
determinant data for the account, a record for the current month will exist. If the account is 
not billed using determinants from an external source, there won’t be a Bill History record for 
the current month. If that’s the month you want to attach a problem description to, you must 
create a bill history record for it.

4. If the bill history record exists, skip this step. With the Bill History Table still highlighted in the left 
pane, select Records-›Insert New or click the right mouse button. Enter the appropriate 
Start Time and Stop Time for the bill period using the MM/DD/YYYY HH:MM:SS 
format. Oracle Utilities Billing Component updates the other fields in the record with the 
proper information when it actually creates the bill. Enter the actual Bill Month using the 
MM/YYYY format. Then select Edit-›Add to save the record to the database.

5. In the left pane, click the plus sign next to the desired Bill History record. When the record 
tree expands, position the mouse pointer on the Bill History Problem icon and select 
Records-›Insert New, or click the right mouse button.

A data entry form for the Bill History Problem Table appears.

6. Remove the checkmark from the Null box above the Problem window, and enter a brief 
description of the problem (up to 254 characters) to appear in the Late Bill report.

7. If the problem has been resolved, remove the checkmark from the Null box above the 
Resolution window and enter a brief description (up to 254 characters) to appear in the Late 
Bill report. If the problem has not yet been resolved, leave the Null checkmark in place.

To calculate interest lost, you must have a YEARLY_INTEREST_RATE factor with the interest 
rate in the Factor Value Table, or the interest will be zero. See the Data Manager User’s Guide for 
more information about Factors and the Factor Value Table.
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Creating a Late Bill Report
The Late Bill Report summarizes bills that were either issued late (that is, on any day after their 
scheduled read date), or are as yet unissued and have been assigned a “PROBLEM” description by 
a billing analyst.

You can apply the report to all accounts or customers in the database, to a user-defined subset 
(list) of accounts or customers, or to even a single account or customer. The report includes the 
following information: the account’s name, number, account manager, and read dates (both 
scheduled and actual); the number of days late; dollar amount of the bill based on a user-selected 
bill determinant; and the interest lost. It also includes any problems entered by the Billing Analyst 
to explain why the bill was not issued on time (the “problem”) and its resolution.

How to run a Late Bill Report: 

1. Select Analysis-›Late Billings.

The Late Billing Explanation Report Input dialog box appears.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers you wish to process using one of the following options:

• ID: Type the ID of the account or customer you wish to process.

• List: Select an appropriate list to process. For example, you might have a list of the 
accounts or customers you are responsible for. If the contents of the list may have 
changed since the last time that the query associated with it was run, check the box for 
Refresh list before using. This option updates the list for this job and saves the new 
version of the list to the database, replacing the old one.

• All: Oracle Utilities Billing Component automatically applies the report to all accounts or 
customers in the Data Repository.

• File: Select a file containing a list of customer/account IDs (*.ids), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Select the date range for the report in the Select Period By area. Specify the date range 
covered by the report, using either bill month or read dates:

• Bill Month: Enter the month(s) for the report using the mm/yyyy format—for 
example, 10/1997. If you want just one month, enter the same date in both fields.

• Read Date: Enter the beginning and end of the period of interest, using the mm/dd/
yyyy format. Any account with a late bill associated with a read date between those dates 
is included in the report.

Note: Whether you specify Bill Month or Read Date, the information is reported for bill 
months.

5. Enter the Number of Days Late for the report. Enter the number of days late. For example, 
if you want to see a list of bills that are least 5 days late but no more than 30, enter 5 and 30. 
If you want to see all late bills, enter a 1 in just the From field. Valid values for both the From 
and To fields are 1 - 999.

6.  Select Determinant to be used for Bill Amt. Choose one determinant from the drop-
down list. For each late bill, Oracle Utilities Billing Component will calculate the report using 
that determinant.

7. Select whether or not to Sort by Jurisdiction: Check this option to sort the report by 
Jurisdiction.

8. Select how to Sort the report. Specify the value that Oracle Utilities Billing Component uses 
to organize the information in the report. The bills are always sorted first by bill month, then 
by the value you specify here:
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• Account Number (ascending order)

• Days Late (descending order)

• Bill Amount (descending order).

9. If you want to change the report settings for this report, click Report Options. See Chapter 
3: Working with Reports for more information.

10. Click OK to run the report.

A progress indicator is shown until the calculations are complete. After a few moments, the 
report appears in a window.

The following information is displayed in a Late Bill report:

• Read Date: Day that the account was scheduled to be read (as defined in the Read Date field 
in the Bill History Table).

• Late: The number of days late. If the bill has been issued, this number is the difference 
between the scheduled read date and the date that the bill was issued. If the bill is pending, 
this number is the difference between the scheduled read date and today.

• Bill Amount: The value for the determinant selected in the Late Billing Explanation 
Report Input dialog box.

• Interest Lost: This is the interest lost due to the bill being issued late. This option uses the 
YEARLY_INTEREST_RATE factor. Oracle Utilities Billing Component calculates this 
value using the following formula:

Int. Lost = Days Late x Daily Interest Rate x Bill Amount

The daily interest rate is the simple interest calculated from the yearly interest rate; that is, the 
yearly interest rate divided by 365. The yearly interest rate should be stored in the Factor 
Table as YEARLY_INTEREST_RATE. See the Data Manager User’s Guide for more 
information about Factors and the Factor and Factor Value tables.

• Problem: This is a brief explanation of why the bill was not issued on time, as entered by a 
Billing Analyst. See Flagging “Problem” Bills on page 10-2 for more information. If the 
report reads Not Available, no one recorded a problem.

• Resolution: This is a brief explanation of how the problem was resolved, as entered by a 
Billing Analyst. See Flagging “Problem” Bills on page 10-2 for more information. If the 
report reads Not Available, no one recorded a resolution.
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Chapter 11
Other Reports

This chapter explains how to create a variety of useful reports, including:

• The Billing History Report: This report displays billing information for one account or a 
list of accounts over a user-specified number of bill periods. You can specify that the report 
include one page for each account as well as a summary report showing totals for all accounts. 
The individual account information includes: bill start date, bill end date, rate code, number 
of days in the period, and bill determinant values. The information is presented in a tabular 
format, with each column representing a bill period.

• The Special Events Report: This report lists the overrides that were applied to one or a list 
of accounts over a user-specified time period.

• The Top Accounts Report: This report identifies your largest customers by revenue, energy, 
or demand, and compares their monthly billing information with the same periods one year 
earlier.

• The Rider Summary Report: This report lists the accounts or customers that were subject 
to all or a selected group of tariff riders during a user-specified period.

Note: If Oracle has developed custom reports for your company, they will be 
described in an appendix.
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The Billing History Report

The Billing History Report is useful for examining and comparing bill determinant values and 

other billing information for one or more accounts over a user-specified number of bill periods. 
This report also allows you to produce a summary report which totals the data for all accounts.

How to create a Billing History Report:

1. Select Analysis-›Billing History.

The Billing History Report Input dialog box opens.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List:  Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for.  If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using.  
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• File:  Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Enter the beginning and end of the period for the report  in the Test Period From/To box 
using the date format specified via Tools-›Options.

5. Optional.  Enter a name for the analysis in the Analysis Name field, to appear in the title bar 
of the report window and on the printed report. 

6. Enter the level of detail to be included in the report.  You can check one or both of the 
following options, but you must check at least one:

• Individual Account Report: The report displays a page of information for each 
account in the list.

• Grand Total Summary:  The report displays the total data for all accounts in the list. 
This option is always checked.

7. Optional. Add Override Codes: If this checkbox is checked, the report includes the override 
codes in effect for each accuont and bill period in the report. This option requires the 
Individual Account Report option be selected.

8. Select the number of decimal places to display from the Bill Determinants Displayed to n 
Decimal Places drop-down list. If the number in the database has more decimal places than 
the number selected, the number displayed on the report is rounded off the number of 
decimals selected. If the number in the database has less decimal places than the number 
selected, the number displayed on the report will have zeros appended to the end to display 
the number of decimals selected. The default setting is 1.

9. If you want to change the report options, click Report Options. See Report Options for 
more information.

10. Click OK to run the report.

A progress indicator is shown until the calculations are complete. The requested information 
then appears in the report window.

11. To close the report, select File-›Close.
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The Special Events Report

The Special Events Report summarizes all of the overrides that have been applied to an account 

over a user-specified date range. 

How to create a Special Events Report:

1. Select Analysis-›Special Events.

The Special Events Report Input dialog box opens.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List:  Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for.  If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using.  
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• All:  Oracle Utilities Billing Component applies the report to all accounts

• File:  Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Type the start date and end date for the period you wish to report in the Special Events 
Period From/To box.  Use the MM/DD/YYYY date format.

5. Select one of the following Event Codes:

• All Codes:  Include all overrides that were applied to the specified accounts or 
customers during the reporting period.

• Codes List:  Include just selected overrides.  When you select this button, you can then 
highlight any and all desired codes in the list box to the right. To select more than one 
code, hold down the CTRL key and select each code to be included. You can select up to 
64 specific event codes. This box displays all of the Account Override codes that are 
currently stored in the Override Table in the Oracle Utilities Database.

6. If you want to change your report options, click  Report Options. See Report Options for 
more information.

7. Click OK to run the report.

A progress indicator is shown until the calculations are complete. The requested information 
appears in the report window.

8. To close the report, select File-›Close.
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The Top Accounts Report
 The Top Accounts Report lists your largest customers by revenue, energy, or demand, and lets 
you see how their bills have changed from the previous year.  You can apply the report to the 
entire database, to just selected rate codes, or to a user-defined subset (list) of accounts or 
customers.

The report includes the following information: 

• the top n customers by revenue, energy, or demand for each bill month in the analysis 
period (where n is a value you specify), 

• each customer’s monthly value for revenue, energy, and demand, along with its value for 
the same period one year earlier (if available),

• the percentage change.

The report also totals the values for all of the customers in the system for the selected revenue 
classes in each bill month.

When setting up the report, you can specify which determinants from the Bill History Table are 
used as the measure for Revenue, Energy, and Demand.

How to create The Top Accounts Report:

1. Select Analysis-›The Top Accounts.

The Top Accounts Report Input dialog box opens.
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2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List:  Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for.  If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using.  
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• All: Oracle Utilities Billing Component applies the report to all accounts

• File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Enter the Comparison Period from/To. Specify the range of bill months you wish to report 
using the MM/YYYY format. Oracle Utilities Billing Component will find the biggest 
customers for each bill month in the date range and will automatically compare their revenue 
and usage for those months with the same months in the previous year. For example, if you 
specified from 09/1997 to 10/1997, Oracle Utilities Billing Component would compare 
values for September 1997 with September 1996 and October 1997 with October 1996. If 
you want just one month, enter the same date in both the From and To fields. (For example, 
if you entered 10/1997 and 10/1997, the report would compare October 1997 with October 
1996.)

5. Select the Revenue Codes for the report. Highlight each revenue code you wish to include in 
the report. You can highlight as many codes as desired. To select more than one code, hold 
down the CTRL key and select each code to be included. Highlight [NULL] to include any 
accounts or customers that have not been assigned a revenue code. Any codes that you do not 
highlight will be excluded from the report.

6. Specify the number of Top Customer(s) to report (you can specify any number but zero). 
Then, specify how you want Oracle Utilities Billing Component to select the top customers: 
by highest revenue, by most energy used, or by highest demand. The Advanced option 
described later lets you specify the billing determinant that represents these quantities.

7. Select the Type of Report: Specify whether the report treats each revenue code separately or 
combines them all into one group:

• By Revenue Code:  Reports the top n customers in each revenue code.

• As One Large Group:  Reports the top n customers in the combined group.

Select how to Sort the Report. Specify the value that Oracle Utilities Billing Component uses 
to organize the information in the report. The information is always sorted first by bill 
month, then by the value you specify here:

• Revenue (descending order)

• Energy (descending order)

• Demand (descending order)

• Customer Name (alphabetically, ascending order).

8. Optional. To view or change which determinants Oracle Utilities Billing Component uses as 
the measure for Revenue, Energy, and Demand, click the Advanced button at the bottom of 
the screen.

The Top Accounts Advanced Options dialog box opens.

9. Select the determinants as desired, then click OK to close the dialog and return to the Top 
Accounts Report Input dialog.
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10. If you want to change your report options, click Report Options. See Chapter 3: Working 
with Reports for more information.

11. Click OK to run the report.

A progress indicator appears.  After a few moments, the requested information appears in the 
report window.

12. To close the report, select File-›Close.

Reporting Top Account based on Database Relationships
It is also possible to create a Top Accounts report based on database relationships with the 
Account Table. Specifically, you can either 1) list the top accounts for one specific value in the 
relationship, or 2) list the Top Accounts for each value in the relationship. For example, list the top 
accounts with Revenue Code ABC, or list the top accounts for each revenue code.

The way to establish a relationship between some database value and the Account table is through 
the List functionality.  If a List targeting the Accounts is used in the Customer/Account selection 
in the Top Accounts dialog, then the Top Accounts will be selected only from accounts in the list. 

The List functionality includes an option that supports determining Top Accounts for all values in 
a relationship.  If a question mark (?) is used as the Equals value of a column in a List query clause, 
the List will be repeated for each value of the column in the database.  That is, all values for the 
column will be retrieved (with a reasonable ordering), and then the List query will be rerun once 
with each value substituted for the question mark.  The Top Accounts for a value will be displayed 
(if there are one or more accounts related to the value).  There may be only one question mark in 
the List.

Example: Top Accounts by Supplier
Below is an example of generating a Top Accounts list by supplier.

First, the Name Override History Table is used to link accounts to their suppliers. The Override 
Code is SUPPLIER, and there are two suppliers - GECO and LITTLE_SUPPLIER.

The next step is to create a list that relates the Account Table to the Name Override History 
Table, using the override code for Supplier. If the List also includes the name of a specific supplier 
then the Top Accounts for that supplier will be determined. If the List uses a question mark then 
there will be one Top Account page per supplier.

The following list can be used to determine the Top Accounts with supplier GECO:

The following list can be used to get the Top Accounts for each supplier:

List: Account List (from Customer/Accounts List).

Query: Name Override History.Override Code = SUPPLIER

And

Name Override History.Name = GECO

List: Account List (from Customer/Accounts List).

Query: Name Override History.Override Code = SUPPLIER

And

Name Override History.Name = ?
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The Rider Summary Report
The Rider Summary report lists the tariff riders that were applied to selected customers or 
accounts over a user-specified date range.  The results can be organized in either of two ways: you 
can generate a list of riders that were applied to each account, or a list of accounts that were 
subject to each rider.

For purposes of Oracle Utilities Billing Component and the Oracle Utilities Energy Information 
Platform, the term “rider” refers to both:

• A tariff rider that has been explicitly attached to an account by a billing or rate analyst in 
the Rider History Table. See Applying Tariff Riders to Accounts on page 7-18 in the 
Oracle Utilities Billing Component Installation and Configuration Guide, Volume 1 for more 
information.

• A generic rider that is included as part of another rate form.  This type of rider is simply 
a set of language statements that perform a common function used in several rate 
schedules, such as calculating a determinant value.  These riders are created and stored 
separately like a library of “standard text,” so that the rate analyst can quickly incorporate 
them into another rate form without having to re-write them from scratch every time.

The Rider Summary reports only tariff riders.

How to create a Rider Summary:

1. Select Analysis-›Rider Summary.

The Rider Summary Report Input dialog box opens.

2. Select either Account or Customer in the Select By box.

3. Select the accounts or customers of interest using one of the following options:

• ID:  Type the ID of the account or customer for the report.

• List:  Select a list for the report. For example, you might have a list of the accounts that 
you are responsible for.  If the contents of the list may have changed since the last time 
that the query associated with it was run, check the box for Refresh list before using.  
This option updates the list for this job and saves the new version of the list to the 
database, replacing the old one.

• All: Oracle Utilities Billing Component applies the report to all accounts

• File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

4. Enter the Rider Summary Period: Type the start date and end date for the period you wish 
to report. Use the MM/DD/YYYY format. It reports riders in effect during the summary 
period.

5. Select Rider Options for the report. Highlight each rider you wish to include in the report. 
You can highlight as many as desired.

6. Select how to Sort the report. Specify the value that Oracle Utilities Billing Component uses 
to organize the information in the report. The information is always sorted first by 
jurisdiction, then by the value you specify here:

• Rider:  The report displays a list of accounts subject to each rider.

• Account Number:  The report displays a list of riders applied to each account.

7. If desired, click Report Options to modify settings. See Chapter Seven: Setting Report 
Options for more information.

8. Click OK to run the report.

A progress indicator appears. The requested information appears in the report.
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9. To close the report, select File-›Close.
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Chapter 12
Calculating Trial Bills

The Trial Bill module enables you to create “trial bills” by applying any rate form to any account’s 
historical data over a user-specified date range. You can view and modify any of the billing 
determinants or rate form statements used in the calculations, and quickly recalculate the bill to 
see the impact of your changes. Because it is intended for testing and analysis, this module does 
not send transaction records to the CIS. Unless otherwise specified in Advanced options, this 
module does not permit data to be saved to the Data Repository.

This module has several important applications:

• “debugging” new rate forms before they are used in a production mode.

• demonstrating to a customer the potential impact of switching to an alternative rate, or 
of modifying their usage patterns on the same rate.

• training new users.

This chapter explains how to calculate a “trial bill” by applying a user-selected rate form to 
historical data for an account, including:

• Running a Trial Bill Calculation
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Running a Trial Bill Calculation
How to Run a Trial Calculation: 

1. Select Analysis-›Trial [Bill] Calculation.

The Trial Calculation dialog box opens.

2. Select the customer or account for the calculation:

Select By:  Select Account or Customer.  Account must be selected to run Single Step. 
Customer can only be used with the Report option. 

Select:  Enter the ID of the account/customer you wish to use in your trial bill.

3. Enter the Billing Dates for the calculation by selecting one of the following options:

• From bill history:  Click Select to use a specific Bill History record.

• Compute: Calculates the bill exactly as the billing engine calculates.  This option 
supports recalculating existing bills.

• User specified: This option only applies to accounts whose bills are based on interval 
data.  Specify the following for any period for which interval data is available for the 
account. Note that Bill History values will not be prorated to user-specified dates.

Bill Month:  Enter the desired bill month.

Read Date: Enter the desired read date.

Bill From: Enter the start date of the trial bill.

Bill To: Enter the stop date of the trial bill.

4. Select the Billing Rate Schedule for the calculation using one of the following options:

• Select Rate Schedule:  Click this radio button, then the Select Rate Schedule button 
if you want to select a rate form from the database.  The Select Rate Schedule and 
Optional Rate Code dialog box appears.  This box gives you access to all current, 
historical, and trial rate schedules stored in the Oracle Utilities Data Repository. If you 
select this option, skip to step 5.

• Use Applicable Rate Schedules:  Click this radio button if you want to use the rate 
form that was in effect for the account during the bill month you specified above.  If you 
select this option, skip to step 6.

5. Optional. Select the rate schedule to use for the calculation on the Select Rate Schedule and 
Optional Rate Code dialog box.

• Select an operating company, jurisdiction, and rate schedule.

• Check the desired rate schedule Type (Current/Historical and/or Trial).  A list of all 
of the versions of the rate schedule that meet your criteria appears in the Rate Form 
Version selection box.

• Highlight one rate form version in the Rate Form Version selection box.  The language 
script for that rate form appears in the box below, so that you can determine whether or 
not it’s the desired version.

• Select Rate Code:  The program requires a rate code to determine how to price out the 
billing determinants.

You can select a rate code from the From Rate Schedule Rate Code list.  If you do not 
select a rate code, the program will use the customer’s current rate code to determine the 
correct pricing.

• Click OK. You are back at the Trial Bill Calculation dialog box.  Notice that the 
selected rate schedule version appears under Billing Rate Schedule.
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6. Optional.  Click Options.

The Default Options dialog box opens. See Default Options in Chapter Two for more 
information about setting Default Options.

Set the options as appropriate, and click OK.

7. Optional.  Click Advanced.

The Advanced Trial Bill Calculation Options dialog box opens.

Set the options as desired then click OK to close this dialog.

• INTDLOAD...ENERGY loads all energy used:  This options loads energy from cuts 
that extend past the bill stop date and time.  The default is to only load energy used 
within the bill period.

• Save Options: This option allows you to specify if and how results are saved to the 
database. There are four options available:

• Do not enable saves of any kind: With this option selected, Rules Language 
SAVEs do not save and no CIS transactions record are written to the CIS file. This 
is the option you’ll choose most often when testing rate forms and when using Trial 
Bill.

• Enable user approve/reject of saves: When this option is selected, you can either 
Approve or Reject each set of results. If you approve an account (or an account and 
all its related accounts), the bill will be rerun with Automatic Approval. This second 
run will generate the same results, and will create database and CIS records.

• Automatically save/approve each page if it is OK:  If you select this option, 
then data from each non-error page of an account is automatically written, 
regardless of the errors in other pages of the account or other related accounts. 

• Use cut dates nearest the supplied dates:  If the account uses interval data and you 
want to use the best cut dates, check this option.  Otherwise, to subset the interval data 
based on the supplied dates, uncheck this option.

• Do not Display Graph for Interval Data: If this checkbox is checked, the lower graph 
window does not open. The default for this option is unchecked.

• Do not use current Bill History determinant values:  If the account uses interval 
data, has already been billed, and you want to check the computation without using the 
saved bill determinants, check this option.  Otherwise the current Bill History values will 
be used, and the NOVALUE statements may not execute.

• Do not use Account/Customer selection:  This option runs the calculation in the 
same manner as the RUNRS.EXE program (see the Oracle Utilities Energy Information 
Platform Installation and Configuration Guide). When Report or Single Step is pressed (see 
below) the Account/Customer selection will be ignored and the rate schedule will be run 
just as if it was run from RUNRS.

8. Choose one of the following options to view the calculations:

• Report:  Displays the results of the calculations in a report window.  Go to the section 
How to View the Bill Calculation Report on the next page.

• Single Step:  Lets you execute one rate form statement at a time. See How to run the 
Single Step Analysis, later in this chapter.

How to View the Bill Calculation Report

1. On the Trial Calculation dialog, click the Report button.

A progress indicator displays until the calculations are complete.  Then, the Bill Calculation 
Report appears in a window.
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2. Review the report to make sure that the data processed as expected.

If you want to override your default report options for this report, output the bill report to a 
file, or add titles to the report, click Report Options. The Report Options dialog opens.

3. To close the report, select File-›Close.

How to run the Single Step Analysis

The Single Step Analysis feature lets you execute one rate form statement at a time so that 
you can see the changes to identifier values.

1. On the Trial Calculation dialog, click the Single Step button.

The windows for the Single Step module appear.

The module consists of two (or three) windows. The top left window displays the statements 
that make up the rate form. The next statement to be executed is highlighted (comments are 
skipped). The top right window displays the identifiers in the rate form and their values. The 
lower window is a graphical display of the interval data. This window appears only when an 
interval data identifier is highlighted in the top right window.

You can use the Find, Find Next, Find Previous, and Go to options from the Edit menu to 
search in either the top left or top right windows. To do so, select the starting point for the 
search in the appropriate window, and select the desired options from the Edit menu.

2. When the rate form is first displayed, the first executable statement is highlighted.  To execute 
the statement, select Single-Step-›Step, or press F8.  You can execute each statement this 
way.

3. If you want to execute a portion of the rate form up to a particular statement, highlight the 
target statement and select Single-Step-›Run to Selection, or press F4. This allows you to 
avoid having to single-step through every statement prior to the one of interest.

4. To run all statements to completion, select Single-Step-›Run or press F5. Note that when 
running a rate form, processing stops at each breakpoint encountered. To stop executing the 
rate form, select Single-Step-›Stop or press F12.

5. To restart executing the rate form, select Single-Step-›Restart or press F10. Note that all 
warning and informational messages set before restarting will be cleared. Also, any values for 
identifiers calculated before restarting will be cleared.

6. After you have run the statements, you can view the resulting bill report by selecting Single-
Step-›Display Report, or pressing F6.

The bill report appears (it has the same format as other bill reports in the system).  You can 
export or print the report using options from the File menu.  You can also search for selected 
text or copy all or a selected portion to the clipboard using options from the Edit menu.

7. To close the report, select File-›Close.
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Single Step Module Advanced Options

The Single Step module also provides advanced options when executing rate forms. These include 
Changing Identifiers Values, Setting Breakpoints, and Selecting Identifiers to Display.

Changing Identifier Values: To change the value of an identifier before you generate the bill 
report, double-click on the identifier in the right window. The Customer Bill Modification - 
Edit Id dialog box opens with the current value in an edit box. Change the value as appropriate, 
and click OK to save the value in the executing rate schedule.

Note:  You must enter the same value type - Integer, Float, etc. - as the current 
value.  If the identifier is an interval data handle, the value displayed contains its 
total, maximum, pulse multiplier, and pulse offset.  This value is not modifiable.

Setting Breakpoints: You can specify points within the rate form at which you want execution of 
the rate to stop or break. These are called breakpoints. To set breakpoints within the rate form, 
select the line at which you wish the execution to break and select Single-Step-›Insert/Remove 
Breakpoint or press F9. This inserts a breakpoint (“=>”) at the selected line. When the rate form 
is executed, processing stops at each breakpoint. To remove a breakpoint, select a line that 
contains a breakpoint and select Single-Step-›Insert/Remove Breakpoint or press F9. 
Breakpoints inserted into a rate form are stored in the Oracle Utilities Data Repository until 
specifically cleared.

You can also create “conditional” breakpoints. These are breakpoints related to a specific 
identifier in the rate form which can be set to stop processing when the value of a specified 
identifier changes or when the value equals a user-specified value. To set a conditional breakpoint 
for an identifier, double-click the identifier and click Breakpoint on the Customer Bill 
Modification - Edit Id dialog. The Customer Bill Modification - Breakpoint dialog opens.

This dialog allows you to set the conditions for the breakpoint in one of two ways:

• To specify that rate form execution breaks when the value of the identifier changes, select 
“Break when value changes” in the Breakpoint box on the dialog and click OK.

• To specify that rate form execution breaks when the identifier reaches a specified value, select 
select “Break when value equals” in the Breakpoint box on the dialog, select the type of the 
identifier from the Type drop-down list, enter the specified value in the Value field,  and 
click OK.

Selecting Identifiers to Display: Normally the top right window displays all identifiers used in 
the rate form, but in some cases it may be preferable to view only selected identifiers, as this can 
help users more easily track the values of specific identifiers while the rate form executes. To select 
an identifier for display in the top right window, double-click the identifier, check the Add 
identifier to Selected list checkbox on the Customer Bill Modification - Edit Id dialog, and 
click OK. The identifier will appear in the top right window when the user selects the Show 
Selected Identifiers option from the Single-Step menu.
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Graphing Options

The Trial Calculation Single Step Analysis graphing tool provides the following features:

Zoom View: The Zoom View allows users to zoom in on the graph by dragging the mouse over a 
portion of the graph. To return it to it’s original size, select the Undo Zoom option on the 
Graphing Options menu (see below).

Graphing Options: The Graphing Options menu provides access to several other graphing 
options.

To open the Graphing Options menu, right-click on the graph. This menu provides the following 
options:

• Viewing Style opens a menu of options that change the appearance of the graph. Using 
these options you can make the graph color or monochrome. You can also select Bitmap/
Gradient to add a predefined style to the graph. A variety of predefined styles are listed under 
the Bitmap/Gradient item on the menu.

• Border Style opens a menu of options that change the borders of the graph. Using these 
options you can add or remove a border, line, shadow, or inset.

• Font Style opens a menu of options for the size of the graph’s font.

• Show Legend allows you to turn off and on the graph’s legend.

• Numeric Precision opens a menu of options that allow you to change the number of 
decimal points displayed in the graph’s data. Using these options you can display the data with 
0 to 3 decimal places.

• Plotting Method opens a menu of options that allow you to change the appearance of the 
graph’s data. Using these options you can display the data as points, a line, bars, sticks, or 
spline. You can also display the data as points combined with other options, for example, a 
line with points.

• Data Shadows opens a menu of options that affect the shadow of the data. You can add or 
remove a shadow or 3D effect.

• Grid Options opens a menu of options that alter the display of the X axis and Y axis. Using 
these options you can place the grid in front of the graph, extend the Y axis tick marks, 
display or hide grid lines, and change the style of the lines.

• Include Data Labels hides or displays the data labels.

• Mark Data Points hides or displays the data points.

• Undo Zoom returns the graph to its original size after you have zoomed in by dragging the 
mouse over a portion of the graph.

• Maximize displays the graph at full screen size. To return it to it’s original size, either press 
the Esc key, or click in the blue bar at the top of the graph.

• Customization Dialog opens the Customization dialog box.

• Export Dialog opens the Export Dialog box. 

Customization Dialog: To open the Customization Dialog box, right-click on the graph and 
select Customization Dialog. The Customization Dialog box can be used to change the settings 
of the graph and to export or maximize the graph. Many of the options in this box are also 
available in the menu that appears when you right-click on the graph. The dialog box contains the 
following tabs:

General Tab: On the General tab you can change the following settings for the graph:

• Main Title is a text box in which you can add or edit the graph’s title.

• Sub Title is a text box in which you can add or edit the graph’s subtitle.
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• Border Style allows you to change the border style of the graph.

• Viewing Style allows you to change the viewing style for the graph.

• Font Size allows you to change the size of the graph’s fonts.

• Numeric Precision allows you to choose from 0 to 3 decimal places for the graph’s 
data.

• Grid Lines allows you to change the display settings of the graph’s grid lines.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Plot Tab: On the Plot tab you can change the following settings for the graph:

• Axes

• Plot Style allows you to choose the style of plot points for the graph.

• Comparison Plot Style allows you to choose the style of plot points for the comparison 
graph.

• 3D allows you to choose the 3D effects for the plot style

• Mark Data Points allows you to mark or unmark the data points.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Subsets Tab: On the Subsets tab you can change the following settings for the graph:

• Subsets to Graph allows you to scroll through subsets of the graph.

If more than one interval data cut is graphed, you can select the cuts individually and make 
different changes to each. The data cuts are listed in the text field on the tab.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Axis Tab: On the Axis tab you can change the following settings for the X Axis and Y Axis:

• Linear or Log allows you to set the graph’s tick marks in either linear or log values.

• Maximum and Minimum allows you to change the minimum and/or maximum values 
for the axes.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Font Tab: On the Font tab you can change the following settings for the graph’s fonts:

• Main Title allows you to choose the font for the graph’s main title. You can also choose 
to make the title bold, italic, and/or underlined.

• Sub-Title allows you to choose the font for the graph’s main sub-title. You can also 
choose to make the subtitle bold, italic, and/or underlined.

• Subset / Point / Axis Labels allows you to choose the font for the graph’s subsets, 
points and axis labels. You can also choose to make those items bold, italic, and/or 
underlined.
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To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Color Tab: On the Color tab you can change the colors of the following parts of the graph:

• Desk Foreground 

• Desk Background 

• Shadow Color 

• Graph Foreground 

• Graph Background 

• Table Foreground 

• Table Background

You can also add a bitmap image or a gradient to the graph by selecting Bitmap/Gradient 
Styles in the QuickStyles area of the tab. This area also lists an assortment of predefined 
bitmap and gradient styles that can be applied to the graph.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Style Tab: On the Style tab you can change the following settings for the graph’s lines:

• Color allows you to select a color for the graph’s lines.

• Point Type allows you to select a style for the graphs points. 

• Line Type allows you to choose the type of line for the graph.

If more than one interval data cut is graphed, you can select the cuts individually and make 
different changes to each. The data cuts are listed in the text field on the Style tab.

To apply your changes select Apply. To close the dialog box without applying your change 
select Cancel. To apply your changes and close the dialog box select OK. You can also select 
Maximize to make the graph full screen size. (To return the graph to it’s original size press 
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Export Dialog: To open the Export Dialog box, right-click on the graph and select Export 
Dialog. 

To Export a graph, use the following procedure:

1. In the Export area of the box, choose the type of file you would like to export. You can 
choose from EMF, WMF, BMP, JPG, PNG or Text/Data.

2. In the Export Destination are of the box, select the destination of the exported file. You can 
choose from ClipBoard, File or Printer. 

3. In the Export Size area of the box, choose the unit of measurement of the file, and then set 
the size. You can choose from Millimeters, Inches, or Points. BMP, JPG and PNG files will 
default to Pixels. You can set the width and length of the file. You can also set the DPI for the 
file. Select Large Font if you want the file to have a larger font.

4. Select Export to export the file, or Cancel to close the dialog box.
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