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License: Apache 1.1

Module: Crimson v1.1.1, Xalan J2

Copyright © 1999-2000 The Apache Software Foundation. All rights reserved.

Use of Crimson 1.1.1 and Xalan J2 within the product is governed by the following (Apache 1.1):
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Use of this module within the product is governed by the following:
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WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
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DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."

License: Justin Frankel, justin@nullsoft.com

Module: NSIS 1.0j (Sun JRE Component)

Use of this module within the product is governed by the following:

(1) The origin of the module must not be misrepresented, and Oracle may not claim that it wrote the original 
software. If Oracle uses this module in a product, an acknowledgment in the product documentation is 
appreciated but not required. (2) Altered source versions of the module must be plainly marked as such, and 



must not be misrepresented as being the original software. (3) The following notice may not be removed or 
altered from any source distribution: “Justin Frankel  justin@nullsoft.com”.

License: ICU4j License

Module: ICU4j

Copyright © 1995-2001 International Business Machines Corporation and others. All rights reserved.

Oracle may use the software without restriction, including without limitation the rights to use, copy, modify, 
merge, publish, distribute, and/or sell copies of the software, and to permit persons to whom the software is 
furnished to do so, provided that the above copyright notice and the permission notice appear in all copies of 
the software and that both the above copyright notice and the permission notice appear in supporting 
documentation.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
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FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY 
RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS 
NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL 
DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 
PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS 
ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS 
SOFTWARE. 

License: Info-ZIP

Module: INFO-ZIP ZIP32.DLL (Binary Form)

Copyright (c) 1990-2005 Info-ZIP.  All rights reserved
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versions--including, but not limited to, ports to new operating systems, existing ports with new graphical 
interfaces, and dynamic, shared, or static library versions--must be plainly marked as such and must not be 
misrepresented as being the original source. Such altered versions also must not be misrepresented as being 
Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names “Info-ZIP” (or 
any variation thereof, including, but not limited to, different capitalizations), “Pocket UnZip,” “WiZ” or 
“MacZip” without the explicit permission of Info-ZIP. Such altered versions are further prohibited from 
misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s). (4) Info-ZIP 
retains the right to use the names “Info-ZIP,” “Zip,” “UnZip,” “UnZipSFX,” “WiZ,” “Pocket UnZip,” “Pocket 
Zip,” and “MacZip” for its own source and binary releases.
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Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed 
Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul 
Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio 
Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven 
M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White

[Disclaimer:] “This software is provided “as is,” without warranty of any kind, express or implied. In no event 
shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential 
damages arising out of the use of or inability to use this software.”

License: Paul Johnston

Modules: md5.js

Copyright (C) Paul Johnston 1999 - 2002

Use of these modules within the product is governed by the following:



(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the names of the copyright holders and contributors may be 
used to endorse or promote products derived from the software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” 
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE 
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

License: Jef Poskanzer

Modules: DES, 3xDES (Sun JRE Components)

Copyright © 2000 by Jef Poskanzer <jef@acme.com>. All rights reserved

Use of these modules within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the name of Jef Poskanzer may be used to endorse or 
promote products derived from the software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE 
DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; 
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

License: Sun Microsystems, Inc. 

Modules: Sun Swing Tutorials

Copyright© 1995-2006 Sun Microsystems, Inc. All Rights Reserved.

Use of these modules within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution. (3) Neither the component name nor the name of Sun Microsystems, Inc. and contributors may 
be used to endorse or promote products derived from the software without specific prior written permission. 
(4) Oracle must acknowledge that the software is not designed, licensed or intended for use in the design, 
construction, operation or maintenance of any nuclear facility.

THIS SOFTWARE IS PROVIDED “AS IS,” WITHOUT A WARRANTY OF ANY KIND. ALL EXPRESS 
OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY 
IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR 
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. (“SUN”) AND ITS 
LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A 
RESULT OF USING, MODIFYING OR DISTRIBUTING THIS SOFTWARE OR ITS DERIVATIVES. 
IN NO EVENT WILL SUN OR ITS LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT 
OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR 



PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE THEORY OF 
LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THIS SOFTWARE, EVEN IF 
SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

License: Tom Wu

Module: jsbn library

Copyright © 2003-2005 Tom Wu. All rights reserved

Use of this module within the product is governed by the following:

(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the 
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the disclaimer below in the documentation and/or other materials provided with the 
distribution.

THE SOFTWARE IS PROVIDED “AS-IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, 
IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL TOM 
WU BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES 
OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 
PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY 
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR 
PERFORMANCE OF THIS SOFTWARE.
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Chapter 1
Introduction to Oracle Utilities Revenue

Management

This chapter provides a brief overview of Oracle Utilities Revenue Management and the 
forecasting process, including:

• What Does Oracle Utilities Revenue Management Do?

• How Do You Work with Oracle Utilities Revenue Management?

• About Extended Block Rates

• Oracle Utilities Revenue Management Documentation Overview
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What Does Oracle Utilities Revenue Management Do?
What Does Oracle Utilities Revenue Management Do?
Oracle Utilities Revenue Management can be used to forecast a utility’s revenues at all levels of the 
organization—from entire operating companies to individual billing determinants within a rate 
schedule. The graphical interface is designed to allow the user to quickly define the parameters of 
a forecast and immediately view the results. Oracle Utilities Revenue Management can produce 
several different reports which in turn can be used for budgeting and marketing purposes.

Although some of the calculations which are performed behind the scenes are complicated, the 
premise of Oracle Utilities Revenue Management is fairly simple. After defining the internal 
organization, or hierarchy, of one or more operating companies to be used in the forecast, the user 
then provides the system with historical information for each of the rate schedules within the 
forecast hierarchy. This historical information is provided in the form of Bill Frequency Tables 
(BFTs). A BFT is a file that can be created either with Oracle Utilities Rate Management or by 
other external means. A BFT contains information about the number of customers and amount of 
billing determinant usage for a rate schedule over a defined period of time. This information is 
summarized into blocks for each of the billing determinants. For some rate schedules, additional 
historical information is required to calculate determinant usage for extended blocks.

Oracle Utilities Rate Management - Revenue Management uses the historical information supplied 
in the BFT to determine three types of allocation factors. First is the percentage of kWh usage and 
number of customers attributed to each rate schedule within a business class. Second is the linear 
relationship between kWh and any other billing determinants within each rate schedule. Last is an 
Ogive curve that represents the normalized accumulated usage with respect to the number of 
customers over the specified BFT blocking. This Ogive curve is used to calculate determinant 
usage for fixed-size blocks.

Next, forecasted billed kWh usage and number of customers for each business class within the 
forecast hierarchy is entered via a single text file.  This forecast can be for any number of years.  A 
file containing the net power supply forecasts for each jurisdiction within the forecast hierarchy 
can also be entered to provide information necessary to calculate unbilled revenue forecasts.

Oracle Utilities Revenue Management uses the forecasted information for each business class, 
along with the allocation factors determined from the historical information for each rate 
schedule, to calculate forecasted determinant usage for each pricing block within each billing 
determinant within each rate schedule in the forecast hierarchy. This forecasted determinant usage 
is then used, along with tariff information either entered by the user or obtained from the Oracle 
Utilities Data Repository via factors, to calculate actual forecasted revenue. Both the resultant 
billing determinant usage and revenues can be summarized at the business class, jurisdiction, or 
operating company levels via the various reports provided by the application. Forecasted 
information for individual rate schedules, business classes, or jurisdictions that span more than 
one operating company can also be summarized.

The application also allows for various factors to be associated with each rate schedule to account 
for other revenue sources such as fuel adjustments and tax surcharges.  This information can also 
be summarized at the various levels of the forecast via the reports.  Finally, unbilled revenue 
forecasts are also calculated using entered forecasted net power supply information along with the 
billed revenue calculations provided by the system.

Operating
Company

Jurisdiction

Business
   Class

   Rate
Schedule

    Billing
Determinant

 Factors

Figure 1.1 - Basic elements
 of the forecast hierarchy
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What Does Oracle Utilities Revenue Management Do?
* Allocation factors include:

• Percentage of kWh and number of customers attributed to each rate schedule within a 
business class.

• Linear relationship between kWh and other billing determinants in rate schedule.

• Usage attributed to each pricing block.

Calculate

Factors
 Allocation

Hierarchy
Block
Allocation
Method

Calculate
 Revenue

Allocation
 Factors*

Manual
 Adjustments
to Allocation
Factors

Tariffs

Revenue Reports
Customer & Energy Use Forecast

Net Power Supply Forecast

Factors

Bill
Frequency
Table

(Historical Usage
Data and Customer
Counts summarized by
block.)

Figure 1.2 - Overview of the Forecasting Process
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How Do You Work with Oracle Utilities Revenue Management?
How Do You Work with Oracle Utilities Revenue Management?
Below is a visual summary of the steps you’ll follow to generate a forecast. These steps are 
explained in detail in chapters 2, 4, and 5.

1. User prepares
    inputs
     
    Chapter 2.

Verify that hierarchy entities have
been defined in lookup tables
If not, add or update. 

      

Create Bill Frequency Table (one year
each Rate Schedule in hierarchy)
a. Create Account List with
     Data Manager.
b. Verify that Account Bill Determinant
     data is available.
     
c. Create Blockings with Data Manager.
d. Create Bill Frequency Table with
     Oracle Utilities Rate Management.

Put Customer and Energy Load
Forecast file in POWRLINE\RCDATA
directory.

Put Net Power Supply Forecast file
in POWRLINE\RCDATA directory.

Update keymap.txt and keymap2.txt
if lookup codes have changed.

2. User specifies
    Forecast

(Chapter 4)
    parameters

Complete tab pages 

3. User specifies
    Report

(Chapter 5)
    parameters

Select types and options
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About Extended Block Rates
About Extended Block Rates
Extended-block rates generally include any rate where a block size for one billing determinant is 
dependent on the value of another billing determinant. For fixed-block rates, Oracle Utilities 
Revenue Management uses Ogive curves–calculated from Bill Frequency Tables (BFTs)–to 
determine the distribution of forecasted usage over the blocks. However, because the block sizes 
in the BFTs are fixed, they are not suitable alone for rates that have variable blocks.

To accommodate extended-block rates, Oracle Utilities Revenue Management can calculate the 
historical averages using the actual determinant blockings as defined in the rate schedule (written 
in the Oracle Utilities Rules Language). Oracle Utilities Revenue Management uses the bill history 
information from the Oracle Utilities Data Repository together with the rate form to calculate the 
total summarized bill determinant blocking distributions. The total summarized bill determinant 
blocking distributions are then used by Oracle Utilities Revenue Management as a basis for 
calculating the historical averages for the rate schedule. Oracle Utilities Revenue Management 
applies either the Ogives or the Historical Averages method on a per block basis, as opposed to a 
per billing determinant basis.

When combined with BFTs, this approach supports rates that contain both fixed-size and 
extended blocks.

Important Note
Before you can use Oracle Utilities Revenue Management or any of its functions, you must first 
make sure that appropriate data and records have been created in the Oracle Utilities Data 
Repository. The instructions in this manual assume that these records exist. For more information 
about creating, updating, or editing records in the Oracle Utilities Data Repository, please refer to 
the Data Manager User’s Guide.
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Oracle Utilities Revenue Management Documentation Overview
Oracle Utilities Revenue Management Documentation Overview
In addition to the Oracle Utilities Revenue Management User's Guide (this book), Oracle Utilities 
Revenue Management also comes with a number of other manuals and documents. These are 
described briefly below.

Oracle Utilities Energy Information Platform User’ Guide
The Oracle Utilities Energy Information Platform User’s Guide contains describes how you work with the 
Oracle Utilities Energy Information Platform web -user interface.

Data Manager User’s Guide
Data Manager is the tool you use to view, edit, and update records in the Oracle Utilities Data 
Repository. The Data Manager User’s Guide explains how to use Data Manager to view and maintain 
data in the Oracle Utilities Data Repository. 

Oracle Utilities Rules Language
The Oracle Utilities Rules Language is a powerful command language that defines business rules 
and specific items such as rate tariffs. The Oracle Utilities Rules Language User’s Guide and Oracle 
Utilities Rules Language Reference Guide describe the Oracle Utilities Rules Language and how it is 
used with Oracle Utilities products.

Oracle Utilities Energy Information Platform Installation Guide
The Oracle Utilities Energy Information Platform Installation Guide contains installation information 
related to the Oracle Utilities Energy Information Platform.

Oracle Utilities Energy Information Platform Configuration Guide
The Oracle Utilities Energy Information Platform Configuration Guide contains configuration and system 
administration information related to the Oracle Utilities Energy Information Platform.
1-6 Revenue Management User’s Guide



Chapter 2
Working with Oracle Utilities Revenue

Management

This chapter describes how you work with the Oracle Utilities Revenue Management application, 
including:

• Starting Oracle Utilities Revenue Management

• Oracle Utilities Revenue Management Menus

• Default Options

• Report Options

• Viewing and Printing Reports

• Using Online Help

• Creating and Opening Forecasts

• Navigating the Revenue Forecast Window

• Closing, Saving, and Deleting
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Starting Oracle Utilities Revenue Management
Starting Oracle Utilities Revenue Management

From the Windows Desktop
Depending upon how your system is configured, you can start Oracle Utilities Revenue 
Management using one of two methods:

• Double-click the Oracle Utilities Revenue Management icon, or

• Click the Start button in the lower-left corner of the Windows desktop. Then, select 
Programs-›Oracle Utilities-›Oracle Utilities Revenue Management.

Depending upon your system configuration (or if an error occurs during database initialization), 
the logon screen appears.

• User Name: the user ID for the database connection*

• Password: the password for the supplied user ID*

• Data Source Name: The data source name and provider for the database, in one of the 
following formats:

For Oracle databases:

"Data Source=<data_source>;LSProvider=ODP;"

where:

• <data_source> is Oracle TNS Name from the TNS_NAMES.ora file (typically located 
in the \\<machine>\oracle\network\admin directory)

* User Name and Password are optional—if you do not supply them, the UserID defaults to your 
Windows logon ID.

When you complete the fields and click OK, the Oracle Utilities Revenue Management desktop 
appears. You are now ready to begin.

From Another Oracle Utilities Application
You can start Oracle Utilities Revenue Management while working in another Oracle Utilities 
application program, such as Oracle Utilities Rate Management. From that program’s desktop, 
select
Tools-›Oracle Utilities Revenue Management. The Oracle Utilities Revenue Management 
desktop appears.

Note:   If Oracle Utilities Revenue Management is not available on the Tools 
menu, contact your System Administrator. (The program must be added to the 
*.tls files.)
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Oracle Utilities Revenue Management Menus
The Oracle Utilities Revenue Management menu provides access to all Oracle Utilities Revenue 
Management functions, as well as to all other Oracle Utilities products installed on your system. 
The following pages describe each option on each menu.

File Menu
New: Creates a new revenue forecast.

Open: Opens an existing revenue forecast.

Close: Closes an open report or revenue forecast window.

Save: Saves the current revenue forecast.

Save As...: Saves the current revenue forecast to a different file.

Export: Exports the contents of an open report window to a file.

Print: Prints the contents of an open report or graph window. See Viewing and Printing 
Reports on page 2-16 for more information.

Exit: Closes the Oracle Utilities Revenue Management application.

Edit Menu
Cut: Cuts value in an editable cell.

Copy: Copies a line of text that you have selected in a report, to the Clipboard where it is available 
for pasting into other applications such as Word.

Paste: Pastes value into an editable cell.

Undo: Not applicable to Oracle Utilities Revenue Management.

Redo: Not applicable to Oracle Utilities Revenue Management.

Add: Not applicable to Oracle Utilities Revenue Management.

Update: Not applicable to Oracle Utilities Revenue Management.

Delete: Deletes value in an editable cell.

Find - This option allows you to search for a word or words in an open report window. When you 
select this option (or press F3), the Find dialog opens. See Viewing and Printing Reports on 
page 2-16 for more information.

Find Next (Shift-F3) - This option finds the next instance of the word or words last entered in 
the Find dialog.

Find Previous (Ctrl-F3) - This option find the previous instance of the word or words last 
entered in the Find Dialog.

Go To (Ctrl-G) - This option opens the Go To tab on the Find dialog and allows you to go to a 
specific line in an open report window. 

Browse Account: Examine information in the Oracle Utilities Data Repository for a selected 
account using the Browser.

Note: You must first highlight an Account ID in a report in order for this 
feature to be available.

View Account: Examine information in the Oracle Utilities Data Repository for a selected 
account using the Account-Centric View.

Note: You must first highlight an Account ID in a report in order for this 
feature to be available.
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Refresh Cached Tables: If you have made changes to the Operating Company and/or Bill 
Determinants tables, you can select this option to display the changes in the Data Manager 
Account-Centric View or Browser.

Font: Allows you to change the font in an open report window. See Viewing and Printing 
Reports on page 2-16 for more information.

Revenue Forecast Menu
Reports: Generates the following reports. For more information concerning reports, see Chapter 
5: Reports and Other Output.

• Bill Determinants: Total number of customers and usage for each selected rate schedule in 
the hierarchy.

• Revenue Detail: Forecast revenue by block and factor.

• Revenue Summary: Base and total revenue.

• Revenue Comparison: Base and total revenue, and percentage difference between current 
forecast and prior year forecast.

• Unbilled Revenue: Unbilled revenue and unbilled fuel revenue.

Corporate Model Output: Generates the Corporate Model Output File. See Corporate Model 
Output File on page 5-5 for more information.

Edit Unbundled Components: Specifies unbundled components. See Unbundled Component 
Setup on page 4-7 for more information.

Revenue Output Data File: Generates the Revenue Output Data File. See Revenue Output 
Data File on page 5-6 for more information.

Unbilled Revenue Output File: Generates the Unbilled Revenue Output File. See Unbilled 
Revenue Output File on page 5-8 for more information.

Setup kWh and kW…: Opens the Setup kWh and kW dialog. Select the appropriate kWh and 
kW Bill Determinants and click OK.

Refresh Factor Values: Updates and refreshes factor values stored in the Oracle Utilities Data 
Repository. See Factor Refresh on page 4-7 for more information.

View Menu
The View menu contains options for altering the view of reports. Note that the View menu is only 
available when an open report window is displayed.

Note: The contents of the View menu change when viewing graphs. See 
Creating Graphs on page 2-17 for more information.

Graph: Opens the Create Graph dialog and allows you to create a graph based data in the report. 
This option is only available if the data in the report can be graphed. See Creating Graphs on 
page 2-17 for more information.

Auto Vertical Scroll: Selecting this options causes the last page of the report to be displayed as 
the report progresses, if it is not checked then no automatic scrolling occurs. 

Display Only Pages With Errors: Creates a new report window based on an open report 
window that contains only pages that contain errors. This option is only available if an open report 
window contains pages with errors.

Display Only Pages Without Errors: Creates a new report window based on an open report 
window that contains only pages that contain no errors. This option is only available if an open 
report window contains pages with errors.
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Tools Menu
Options: This option provides you with options for tailoring Oracle Utilities Revenue 
Management to your needs and environment. See Default Options on page 2-6 for more 
information.

Display Toolbar: Available in future release. Displays the Oracle Utilities Revenue Management 
toolbar.

Customize: Available in future release. Make other programs accessible from the menu bar.

[application program]: Open another Oracle Utilities or user-supplied application.

Window Menu
Cascade: Overlap multiple open windows the desktop; provides largest view of active window.

Tile: Display multiple open windows side by side.

Arrange Icons: Organize icons on Oracle Utilities Revenue Management desktop.

Close All: Closes all open windows.

Help Menu
Help: Displays on-line help for currently-displayed window. See Using Online Help on page 2-
18 for more information.

Help contents: Displays table of contents for on-line help.See Using Online Help on page 2-18 
for more information.

About: Displays version number of software. Also displays the username, computer/network 
name, and database name.

Display Error Window: Displays database version, configuration settings, and error log. 
Especially useful when calling the HelpLine.
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Default Options
The Options feature allows you to set your own default values for several frequently used 
parameters. You can set your preferred defaults via Data Manager or another Oracle Utilities 
product (such as Oracle Utilities Billing Component) and store them in the Oracle Utilities Data 
Repository. In that way, whenever you open a Oracle Utilities program, these values are 
automatically supplied—saving you the time and effort of defining them each and every time.

When you are working in any of the Oracle Utilities application programs, you can also override 
your defaults for individual work sessions, or even specific dialog boxes throughout the programs.  
Whenever you see the Options button on a dialog box, you can click it to open the Options box 
to override the defaults.

Available options include:

• General Options

• Rate Analysis Options

• Billing Options

• Interval Data Source

• Interval Data Options

• Interval Data Merge

• Error Handling

• User Files

How to set default options:

1. At the Desktop, select Tools-›Options.  Or, Click the Options button on the current active 
dialog box.

2. Set your options on each tab as desired.

3.  When you have completed the tabs as desired, click OK to save the new settings as your 
defaults, replacing the previous settings. Any Oracle Utilities program you run will 
automatically use these defaults. If you click Apply, the result depends on how you opened 
the Default Options dialog:

• If you opened the Default Options dialog from the main menu, your new settings apply 
to all of your work for remainder of your current session. The settings will revert to the 
original defaults when you quit the Oracle Utilities programs.

• If you opened the Default Options dialog by selecting the Options button in a dialog 
box, your new settings apply to just the current job.

The next several pages contain detailed information about the Default Option tabs.
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General Options
The General tab specifies a number of default values and formatting preferences used by the 
system.

Default Operating Company:  Choose the default operating company for bill calculations 
and rate analyses.

Default Jurisdiction:  Choose the default jurisdiction for bill calculations and rate analyses.

Account ID:  Choose the default ID for bill calculations and rate analyses.

Minimum printed line width:  The type size in printed reports is partially determined by 
the number of characters that you specify here. The recommended setting is 110 characters, 
which yields approximately 10 to 12 point type (depending upon your printer).  If you do not 
supply a value here the programs automatically sizes the type based on the longest line in the 
report.  So for example, if the longest line were 40 characters, the program would size the 
type so that the 40 characters filled the entire width of the page, which most likely would yield 
uncomfortably large type. On the other hand, if the longest line in the report is longer than 
the value you specify here, the value has no effect.

Default to landscape printing after this # of characters: If a line single line in a report 
contains this many characters, the report will default to landscape printing. This allows the 
user to print reports in landscape mode without having to manually change the mode in the 
printer’s properties dialog box.

Display calculation time with date on each report page:  The date/time is displayed on 
every page of every report. If this option is checked,  the time is also displayed with the date. 

Date Format: Your selection here dictates the format used to enter dates via the graphical 
user interface, and how they are displayed in reports. (This setting is not dependant upon, nor 
does it affect, how dates are stored by your database software.)

Your three options are:

• MM/dd/yyyy hh:mm:ss:  Month-day-year, hours-minutes-seconds.

• yyyy-MM-dd hh:mm:ss:  Year-month-day, hours-minutes-seconds.

• Windows Regional Settings:  Default Options will draw from the Date tab of the 
Regional Settings Windows Control Panel.

Using the Windows Regional Settings, you will have greater flexibility in the formats 
available to you.  You can set a 2-digit year (although the 4-digit, Y2K-compliant date will 
still be used internally), a European format (day-month-year), and so on.

Note: If you change the Windows Regional Settings while an application (Data Manager, 
Oracle Utilities Billing Component, etc.) is running, you must restart the application in 
order for the new settings to take effect.
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Rate Analysis Options
The Rate Analysis tab specifies default values for processing rate schedules and running reports.

Default Rate Schedule:  Choose a default rate schedule for calculating charges. This is the 
default schedule selected when running trial calculations.

Test Period:  Can be any period, one month or greater. This period is used as the default 
time range for the Billing History Report, Special Events Report, and Trial Calculations.

Default Season Schedule:  Select a season schedule for the calculations.

Note:  If when running an analysis or calculation, the input rate form includes 
a statement that assigns a value to the SEASON_SCHEDULE_NAME 
identifier, the value in the rate form takes precedence over the Options 
selection.

Display Line Numbers: If this checkbox is checked, the Rules Language Editor and Rules 
Language Text Editor display line numbers at the beginning of each statement/line. Line 
numbers also appear in the Trial Calculuation window.

Maximum number of Undo’s allowed: This field sets the maximum number of Undos 
allowed in the Rules Language Editor. The default is 1.

Display ‘Saved by’ comments at end: If selected, the ‘Saved by’ comments inserted in rate 
schedules are inserted at the bottom of rate schedules instead of at the top. This option 
unselected by default.

Billing Options
The Billing tab specifies how billing information is displayed by the system.

Round Revenue: Specifies the precision of revenue values in reports.  This setting affects only 
values that have been assigned to revenue identifiers via an Assignment, All, or Block statement in the 
applicable rate form.  A value of 0 (zero) means don’t round, -1 means round to dollars, -2 means 
round to tens of dollars, 1 to tens of cents, 2 to cents, and so on.

Currency displayed to n decimal places: Specifies the number of decimal places shown in 
reports for dollar values. It is usually set to be consistent with your choice for Round 
Revenue. A value of 0 (zero) means use the default (display cents), 1 means display tens of 
cents, 2 means display cents, 3 means display tenths of cents, 4 means display hundredths of 
cents, and so on.

Note: This setting applies only to Oracle Utilities Billing Component reports; 
Oracle Utilities Rate Management reports always display dollars with two 
decimal places (cents).

Billing Units displayed to n decimal places: Specifies the number of decimal places 
shown in reports for billing units.

Display midnight as 00:00:00 (not blank): Specifies whether or not a value (00:00:00) is 
displayed and printed when the time is midnight or unspecified.

If you leave this option unchecked (the default), the programs print and display the date 
without a time when either the time has not been specified or the time is midnight. For 
example, if either 12/01/1998 or 12/01/1998 00:00:00 were specified, the program would 
display 12/01/1998.

If you check this option, the programs print and display 00:00:00 when the time is either 
unspecified or midnight. For example, if either 12/01/1998 or 12/01/1998 00:00:00 were 
specified, the program would display
12/01/1998 00:00:00.
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Interval Data Source
The Interval Data Source tab specifies the source of interval data used by the system.

Interval Data Database:  Select a Type from the three options:

• File: Specify an interval data file. The File option below becomes active when this 
button is selected, allowing you to specify a file (and path) in the File Name field, or to 
Browse to a file.

• Default: Specifies that the default Interval Data Database identified in the 
LODESTAR.CFG File be used. See the Oracle Utilities Energy Information Platform 
Installation and Configuration Guide for more information about setting a default Interval 
Data Database.

• Customer Database: Specifies that interval data stored in the Oracle Utilities Data 
Repository be used. When this button is selected, a drop-down list appears listing all 
available interval data header tables. The default table is the Channel Cut Header 
(LSCHANNELCUTHEADER) table. 

Export Records Overwritten by SAVE to File:  This option saves interval data cuts from 
the Interval Database to an export file before they are overwritten by new cuts created by a 
Rules Language SAVE Statement.  The full path and name of the file (including a valid 
extension) must be specified.

This option appends new cuts to the same file without overwriting previously exported cuts.

Interval Data Options
The Interval Data Options tab specifies how interval data is loaded and processed by the system.

Exclude intervals with quality less than: Specify a status code level that the interval data 
must meet or exceed in order to be included in the calculations.  All interval values with a 
code less than your selection will be ignored by the programs.

The codes are listed in order of decreasing quality—alpha codes generally indicate that the 
data is acceptable; numeric codes indicate that the data is suspect and should be corrected..

Status Code  Classification of interval data

(blank) Normal

A Normal, alternate-recorded (e.g., hand-entered)

J Data inserted by Oracle Utilities Load Analysis to correct outage

L Default for data modified by Oracle Utilities Load Analysis Load Data 
Editor

M Splice peak interval (estimated value)

N Interruptible or curtailable load

P Inserted outage

Q Corrected outage

X Cuts resulting from merging invalid data or from unrecognized status codes

Y Reserved

1 Uncorrected outage

2 Non-normal (usually timing-pulse defects)
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Day Start:  Specify the time that your facility considers the beginning of the day—8:00 am or 
midnight.  This setting pertains to the ROUNDATE Rules Language function.

Use in all day calculations:  Check this box if you want the Day Start time to apply to all 
date calculations that round to a full day or higher.

Use interval end time when displaying time of the interval:  Specifies whether the start- 
or end-times of intervals are displayed for the MAXDATE values in INTDVALUE and 
INTDTOUVALUE functions. If checked, the end-time is displayed.  If unchecked, the start-
time is displayed (the default).

Add Fall Daylight Savings Time value to Energy requests:  Because previous versions of 
the Oracle Utilities Data Repository stored energy in a 24-hour format, the system had to 
compensate for the extra hour of interval data that is left over on the day when the clocks are 
turned back for Daylight Savings Time. To do this, the system automatically takes each 
account’s interval data values for the two DST hours (2:00 AM in the US) and averages them 
together for a single hour. This option enables you to specify how Oracle Utilities Billing 
Component (or other Oracle Utilities products) handles the “leftover” hour when calculating 
energy from interval data.  If this option is checked, the system doubles the averaged value. If 
the option is unchecked, it uses just the single, averaged value. This option should only be 
used if the DST Participant flag is set to “A” in your interval data.

Version 3.70 (and above) can store interval data in 25-hour format (for the day when DST 
ends). Oracle recommends this option remain unchecked when using version 3.70 or above. 
Enabling this option in version 3.70 or above can result in incorrect energy calculations.

Export Validation Flag: Controls the settings of the Validate_Record_Flag upon export. 
This can be set to one of the following:

• Valid (default): Sets all Validate_Record_Flags of each cut within the exported file to 
“N”, ignoring the Validation status of the requested cuts.

• Invalid: Sets all Validate_Record_Flags of each cut within the exported file to “Y”, 
effectively ignoring the Validation status of the requested cuts.

• Use Cut's Status: Sets the Validate_Record_Flag to either “Y” or “N” depending upon 
the combination of validation flags that are current in the cut when exporting takes 
place. If either the Merge flag or the Internal_Validation flag are “Y”, then the 
Validate_Record_Flag in the exported cut is set to “N”.  If both are set to “N” then the 
Validate_Record_Flag is set to “Y”. 

5 Aggregated interval used in rolling format with partially missing or 
unavailable data

7 Marged, aggregated, or transformed interval with partially missing data

9 Missing

Status Code  Classification of interval data
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Interval Data Merge
The Interval Data Merge tab allows you to specific how interval data cuts are merged when using 
the INTDJOIN Rules Language function.

Note: The Interval Data Merge options tab only appears if you include the 
INTD_NEW_JOIN parameter in the configuration file. See the Oracle Utilities 
Energy Information Platform Installation and Configuration Guide for more 
information.

Check Interval Data Validation before Merge: Check this checkbox to cause the program 
to check cuts' merge validation flag before merging. The default is not to check.

Interval Data Merge Selection Criterion: Choose a criterion for merging overlapping 
interval cuts (i.e., a rule how to merge two cuts into one). There are four criteria for merge: 

• Most Recent Start: Pick the interval from the cut that starts later.

• Best Status: Pick the interval from the cut with a better status code. If the intervals have 
the same status code, the values are averaged.

• Average Value: Pick the time-weighted average of the overlapping intervals. The status 
code of the averaged interval will be the worse of the overlapping intervals.

• Maximum Value: Pick the interval from the cut with a larger value.

• Time Stamp: Pick the interval from the cut with the later Timestamp.

The default criterion is Most Recent Start.

Error Handling
The Error Handling tab specifies how errors are handled by the system.

Display error messages:  If checked, the program will display the number of errors (if any) 
it encountered during the job run.

Stop analysis after ## errors:  The number of errors to allow when running an analysis or 
bill.

On Rules Language Interval Data Error:  Use this option to specify how the programs 
handle interval data problems encountered while the rate schedule is running:

• Stop with Error.  Stop processing in any mode.

• Log Message.  Complete processing; include warning message in error log, but not in 
report.

• Continue.  Complete processing; do not issue any messages.

• Issue Warning Message.  In the Automatic Billing mode, stop processing the bill.  In 
the Automatic or Approval Required modes, complete processing, but issue a warning 
message in the bill report.

• Issue Information Message.  Complete processing; include informational message in 
report.
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User Files
The User Files tab specifies where files created by the user are stored by the system.

Default User Directory: If there is a value in this field it will override the USERDIR setting 
in the configuration file (after the database is opened). Files put in the user directory before 
the database is opened - such as .log files - will still be placed in the USERDIR directory. 

Use last save/open path as default for next save/open? - If this checkbox is checked, the 
path used in the last open or save operation will be the default path for the next open and 
save operation, for the duration of the application's run. Each time an application starts it will 
use the Default User Directory/USERDIR path in the first open or save.

Hierarchy
The Hierarchy tab specifies the behavior of the Revenue Management Hierarchy screen.

Hierarchy Expansion Initial Display: Choose a criterion for the initial display of the 
revenue forecast hierarchy: 

• Full Expansion: Display the hierarchy fully expanded.

• Saved Expansion: Display the hierarchy in the same expansion as when Oracle Utilities 
Revenue Management was last closed.

• No Expansion: Display the hierarchy with no expansion.

The default criteria is Full Expansion.

For more information on the uses of the Revenue Forecast Hierarchy tab, see the section 
entitled Hierarchy Page on page 4-3.
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Report Options
Report options allow users to customize the contents of a report, including the report 
presentation and output, the print detail level, problem determination options, and the appearance 
of the Bill Calculation Results section of reports.

Note: Changes to report options as described in this section apply only to the 
report currently being run.

Users access the Report Options via tabs at the top of the Report Options dialog. Clicking on 
these tabs allows users to navigate between types of report options, including:

• General Options

• Print Detail Options

• Problem Determination Options

• Bill Calculation Results Columns Options

How to set and save report options:

1. Click the Report Options button in the input dialog box for the report you’re creating. The 
Report Options dialog appears.

2. Make any appropriate changes on the General, Print Detail, Problem Determination, and 
Bill Calculation Results Columns tabs.

Note: Not all report options are available for all reports. If an option is not available, it is 
greyed out.

3. Click OK to save the changes. To close the Report Options dialog without saving changes, 
click Cancel.

General Options
The General tab allows users to set presentation and output options for a report.

Report Titles
To add optional titles to a report, enter the title in one of the three optional title fields.

Saving Reports to Files
To write the report to a file, check the “Write report directly to File” check box and specify the 
path and filename for the file. Use the “Browse” button to locate an existing file. To display the 
report also, check the “Also Display Report” checkbox.

Other Options
• To disable graphing for the report, check the “Disable graphing of data” checkbox.

• To display only summaries for the report, check the “Display summaries only” checkbox.

• To keep the report data for CSV/XML exporting, check the “Keep data” checkbox.
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Print Detail Options
The Print Detail tab allow users to specify the level of detail included in both a bill report and 
transaction record. The information computed and available for reporting is determined by the 
statements used in the applicable rate form. The Print Detail tab enables you to specify how 
much of that available data is included in the reports and transaction records.

Print Detail Options
Default: This option means the program will use the Print Detail setting normally applied to the 
account (via the Account, Rate Code, Rate Schedule, or Global options specified). Alternately, you 
can override the usual setting for just this job by selecting one of the following:

None: This option displays effective revenue only.

Normal Detail: This option displays effective revenue, plus any charges assigned to a revenue 
identifier and any values assigned to a Report Statement in the applicable rate form.

All Detail: This option displays effective revenue, plus revenue identifiers, plus the values 
associated with the Rules Language Label and Report statements in the rate form.

The table below details how these options apply to specific components of a report and 
transaction record. 

Print Detail Items
To override the Print Detail Options setting for specific components of a bill report and 
transaction record, select the specific options for each component in the Print Detail Items 
section of the dialog. For each report component type, select one of the following:

• On - Include the component in the report and transaction record.

• Off - Exclude the component from the report and transaction record.

• Print Detail Option - Apply the setting specified under Print Detail Options. The specific 
manner in which these settings affect individual report components is detailed in the table 
above. For example, if you had selected “None” under Print Detail Options, and selected 
Print Detail Option here for Input Values, the input values would not appear in the report.

Following is a brief description of each of the report components.

Customer/Account Detail. Date activated, billing mode, number of days specified for the 
eligibility pre- and post-windows.

Input values. This option reports the parameters specified for the bill calculations: bill start and 
end date; date that the account's meter was scheduled to be read; rate code applied to the account; 
number of days in bill period, and the bill month.

LABELed Identifier Values. This option reports the any identifier values and text strings 
specified using a LABEL Statement in the rate form. LABEL statements are typically used to 
substitute meaningful labels for bill determinant names or other brief and sometimes-cryptic 
identifiers (e.g., LABEL LF “LOAD FACTOR” displays LOAD FACTOR and its value in the 
report). They are often used for column headings or report subtitles.

Report Component None Normal All 

Customer/Account Detail X X X

Input Values X X

LABELed Identifier Values X

Simple Report Values X X

Compound Report Values X X
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Note: If a report component type is designated to appear in a report, and it is 
assigned a name using a LABEL Statement, its values will automatically appear 
in the report, with the new label. In other words, it is not necessary in that case 
to apply the LABELED identifier values option to get the label and value to 
appear. For example, the applicable rate form might have the statement 
LABEL $EFFECTIVE_REVENUE “Total Charges”. Because Effective 
Revenue is automatically included in all report types, “Total Charges” will 
appear, no matter what print details options you choose.

Simple report values. This option reports any values that were assigned to an identifier using a 
REPORT Statement in the rate form. REPORT statements are typically used to report values of 
interest that are calculated and/or drawn from the database, such as peak times.

Compound report values. This option reports any values associated with a stem identifier using 
a REPORT Statement in the rate form.

Problem Determination Options
The Problem Determination tab allows users to specify the level of problem determination detail 
included in both a bill report and a transaction record.

When problems occur during the processing of a bill, error messages and other information useful 
in determining the cause of the problem are created. The Problem Determination tab option 
enables you to specify how much of that data is included in the reports and transaction records.

Problem Determination Options
Show All Error Messages: This option reports all error messages that occur while processing 
the bill.

Show All Input Options: This option reports all input options used in processing the bill.

Show Bill records to Save (BillHistory, CSS, etc). This option includes the Bill History records 
in the Bill Report. It is typically only used for testing. If you turn this option off, the records are still 
output when you approve a bill, but they are not displayed or printed in the bill report.

Show Rate Schedule Used in Bill Calculation: This option includes the rate schedule used in 
processing the bill on the bill report.

Bill Calculation Results Columns Options
The Bill Calculation Results Columns tab allows users to specify the labels of the Bill Calculation 
Results section of a bill report.

The Bill Calculation Results section displays the number of billing units, the distribution of those 
billing units, the charge rate, and revenue for each revenue identifier used in a rate schedule.

Bill Calculation Results Columns Options
• To change one or more of the Bill Calculation labels, check the Change Bill Calculation 

Labels checkbox and edit the labels as appropriate.

• To omit one or more of the columns from the bill report (except the Revenue column), check 
the Change Bill Calculation Labels checkbox and delete the appropriate label.

Billing Units Label: The label for the Billing Units column. If blank, the column is omitted.

Distribution Label: The label for the Distribution column. If blank, the column is omitted.

Charge Rate Label: The label for the Charge Rate column. If blank, the column is omitted.

Revenue Label: The label for the Revenue column. This column cannot be omitted. If blank, the 
column label is Revenue.
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Viewing and Printing Reports
One of the primary functions of Oracle Utilities applications is to generate reports. Each of the 
various analysis modules generate reports, and the programs also generate a number of other 
useful reports as well. 

Once a report has been generated, it appears in an open report window on the application 
desktop. Once in an open report window, you can view and/or print the report. This section 
describes how to view and print reports generated using Oracle Utilities applications.

Viewing and Searching Reports
You can search for a specific word or words (or numbers) in an open report window using the 
Find option. The Find option (selected from the Edit Menu) allows you to search for a word or 
words in an open report window. When you select this option (or press F3), the Find dialog opens.

Enter the word or words you wish to find and click OK. To find the next instance of the word or 
words with the Find dialog still open, click Find Next. To find the previous instance of the word 
or words with the Find dialog still open, click Find Previous.

Once you’ve entered a word or words in the Find dialog, you can search by using the Find Next or 
Find Previous options from the Edit menu.

• To search for the next instance of the word or words last entered in the Find dialog, select the 
Find Next (or press Shift-F3) option.

• To find the previous instance of the word or words last entered in the Find dialog, select the 
Find Previous (or press Ctrl-F3) option.

Moving to a Specific Line in a Report
You can also jump to a specified line number within an open report window by using the Go to 
option. The Go to option (selected from the Edit Menu) allows you to move to a specific line in 
an open report window. When you select this option (or press Ctrl-G), the Go To tab on the Find 
dialog opens.

Enter the line number in the report that you wish to move to and click OK.

Changing the Appearance of Reports
You can also change the appearance of the text in an open report window using the Font option 
(from the Edit menu). When you select the Font option, the Font dialog opens.

To change the font in the report window, select a new Font, Style, and Size and click OK. The text 
in the report window will display and print the font/style/size selected.

Printing Reports
You can also print reports using the Print option (from the File menu). When you select the Print 
option, the Print dialog opens.

To print the report, complete the Print dialog as appropriate:

• Ignore page breaks: Check this to ignore the page breaks in the report.

• Page width in characters:  Enter the desired width of the report.

• Display line numbers:  Check this to include line numbers on the report.

Once you’ve completed the dialog, click OK. A standard Windows Print dialog will open, allowing 
to set any desired print options.
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Creating Graphs
You can also create graphs from data in open report windows. 

How to Create a Graph:

1. Select the Graph option from the View Menu (available only when an open report window is 
displayed), the Create Graph dialog opens.

2. Select an Account ID you wish to graph from the Select Account ID to Graph box. A list of 
available rows to graph will appear in the Select Rows to Graph box.

3. Select a row to include on the graph and click Add. The selected row will appear in the Pairs 
to Graph box. Repeat this step for each Account ID/row pair you wish to include in the 
graph. 

To remove a pair, select it and click Remove.

4. Enter an optional title for the graph in the Title box and click OK. The graph will appear in a 
window.

5. To change the view of the graph, select from the options in the View menu.

• The Style option allows you to select from bar graph style (as above) or line graph style.

• The Background Color option allows you select the background color for the graph 
(White, Gray, Dark Gray, or Black).
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Using Online Help
Oracle Utilities applications provide browser-based online help.

How to open online help:

1. Select Help Contents from the Help menu. The online help opens in a browser window.

2. Locate the topic you need help about via the Contents tab, Index tab, or Search tab.

• The Contents tab allows users to expand/collapse sections of the table of contents as 

needed to find a particular topic. Click on the book icons (  and ) to open/close 

headings. Click on the topic icon ( )to open it.

• The Index tab allows the user to browse an index for the online help. Click on the index 
entry for the topic to open it.

• The Search tab allows the user to search the online help for specific words. Enter the 
word(s) for the search in the text box and click Go! The search results appear beneath 
the text box. Click on the topic to open it. 

3. The selected topic will appear in the right pane of the online help window.

Help Icons
A number of icons appear along the top of the online help window. These icons are used for 
navigating the online help and other functions.These icons perform the following functions:

Context-Sensitive Help
Users can also get online help based on a specific function or screen. This is referred to as 
context-sensitive help.

How to open context-sensitive help:

1. Open the function or screen you wish to find help about.

2. Click the Help button in the Toolbar or press F1.

3. An online help window opens displaying the corresponding topic.

Icon Description

Show Navigation: Open the navigation frame. Used after opening 
a single help topic.

Previous: Display the previous help topic.

Next: Display the next help topic.

Show in Contents: Expand the Contents tab to display the current 
topic.

E-mail: Send email to Customer Support.

Print: Print the current topic.

Bookmark: Save the current topic as an Internet Explorer 
Favorite..
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Creating and Opening Forecasts
Once you’ve started Oracle Utilities Revenue Management, you can create a new forecast or open 
an existing one.

Creating a New Forecast
1. At the Oracle Utilities Revenue Management desktop, select File-›New.

A Revenue Forecast window appears.

This is where you specify the inputs and parameters for your forecast, as detailed in Chapter 
4.

Opening an Existing Forecast
1. Select File-›Open.

A list of the previously saved forecasts appears.

2. Highlight the desired forecast and click Open.

All input parameters and results for this forecast appear for viewing and/or modification.

Note: Revenue forecasts can only be opened in read/write mode by one user at 
a time. If you select a forecast that is currently in use by another user, a warning 
dialog will alert you, and ask if you want to open the forecast read-only mode.
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Opening Multiple Forecasts
You can have several Revenue Forecast windows open on the Oracle Utilities Revenue 
Management desktop at one time—including different forecasts or multiple instances of the same 
one. The changes you make to one are not automatically updated in another, but you can apply the 
Edit commands in the menu bar to cut and paste data between them—specifically the table data in 
the Allocation Factors, Bill Determinants, Tariffs, Revenue, and Unbilled Revenue tab pages.

How to control how multiple windows are displayed:

As you open each new Revenue Forecast window, the program layers them one on top of the 
other.

• To display all open windows side by side, select Window-›Tile.

• To return to the previous configuration, select Window-›Cascade.

• To bring one of the partially-covered windows to the front, simply click on its title bar.

Deleting a Forecast
Should you decide to delete an existing revenue forecast:

1. Select File-›Open.

A list of the previously saved forecasts appears.

2. Highlight the desired forecast and click Delete.

Note: If you select a forecast that is currently in use by another user, a warning 
dialog will alert you. 
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Navigating the Revenue Forecast Window
The Revenue Forecast window contains a series of eight tabs.  To create or modify a forecast, you 
simply “fill out” each one of the tab pages, moving left to right.

How to move between tab pages:

You have two choices:

• Click on the < Back or Next> button in the lower right corner of the tab page.  (If either 
button is grayed out, you are at the first or last tab in the sequence.)

• Click on the tab for the desired page.

How to Resize the Panes on a Tab Page

Several of the tab pages in the Revenue Forecast window consist of two panes, side-by-side.  You 
can manipulate the relative sizes of the panes to make more room for the information you’re 
interested in:

1. Move the mouse pointer over the divider that separates the two panes until a double-headed 
arrow appears.

2. Drag left or right to resize the panes.
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Closing, Saving, and Deleting
You can save your work at any time—regardless of whether or not you have completed all of the 
tabs. However, if any of the information you’ve supplied on a single tab is invalid or incomplete, 
Oracle Utilities Revenue Management will display a warning message. You must correct the 
problem before you can move to a different tab or save the forecast.

Saving a Forecast
1. Select File-›Save or File-›Save As. If you select File-›Save, Oracle Utilities Revenue 

Management saves the information using the name you supplied on the Parameters tab page, 
overwriting any previously-saved information with that name. If you select File-›Save As, 
Oracle Utilities Revenue Management prompts you for a new name, and any previously-saved 
work with the old name is preserved.

Closing a Revenue Forecast Window
To close a Revenue Forecast window, either:

1. Click the Close button in the upper right corner of the window (the “X”), or

2. Select File-›Close.

If you have not already saved your work, Oracle Utilities Revenue Management displays a 
message asking if you wish to do so now. If you respond “yes,” any previously saved inputs 
and results are overwritten with the current information on the tabs. If you want to retain the 
earlier version as well as the new, click Cancel, then select File-›Save As, and provide a new 
name in the window that appears.

Deleting a Forecast
To conserve space on your system, you should periodically delete old forecasts.

How to delete a forecast:

1. At the Oracle Utilities Revenue Management desktop, select File-›Open.

A list of forecasts appears.

2. Highlight the name of the forecast you wish to delete, and click Delete.

A message appears asking for confirmation.  Click yes or no as desired.

Troubleshooting with the Error Log
Oracle Utilities Revenue Management automatically maintains a log of any errors—both system 
and user—in a file called revxprt.log, stored in the LODESTAR\USER directory. If you 
experience any problems, you may find it helpful to examine this report by selecting Help-
›Display Error Window.
2-22 Revenue Management User’s Guide



Chapter 3
Preparing Inputs

This chapter describes the inputs you must assemble before you can create a revenue forecast with 
Oracle Utilities Revenue Management, including:

• Lookup Codes

• Customer and Energy Load Forecast File

• Net Power Supply Forecast File

• Bill Frequency Tables

• Additional Inputs Required for Extended Block Rates
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Lookup Codes

What are Lookup Codes?
Before you can apply Oracle Utilities Revenue Management, every entity you want to include in a 
forecast must have been defined in the Oracle Utilities Data Repository Lookup tables. These 
entities include both the organizational entities that you use to define the forecast hierarchy and 
segment the customer population (e.g., operating company, jurisdiction, business class, and rate 
schedule) and the specific billing determinants and charges for which you want to calculate and 
display revenue as line items in the revenue forecast reports. The types of entities you can specify 
for a forecast are:

Note: A forecast requires at least one operating company, jurisdiction, business 
class, and rate schedule. Bill determinants and factors are optional.

• Operating company:  Entity that bills accounts; for example, Monongahela Power.

• Jurisdiction:  Territory in which the operating company’s billing practices are subject to a 
particular regulatory agency (typically a state or the Federal Energy Regulatory Commission).

• Business class (also referred to as revenue code):  Class of accounts, for example, 
Commercial or Residential.

• Rate schedule:  Sub-class of accounts, subject to a particular rate schedule. 

• Bill determinant:  A measurement of customer energy consumption that is used to 
determine a bill, such as “metered energy” or “metered demand.”

• Factors:  Variables used to represent taxes or other charges (described further on the 
following page).

For most types of entities, the lookup tables require a lookup code (a unique identifier) and a 
more descriptive name that appears on the user interface. Since the lookup tables are utilized 
by all Oracle Utilities programs, most or all of the lookup codes you'll require for your 
forecasts have already been entered in the database. (Factors are the exception; there are a few 
that are unique to Oracle Utilities Revenue Management. See below.)

If an entity is not defined in the Oracle Utilities Data Repository lookup tables, it will not be 
available for selection via the Oracle Utilities Revenue Management user interface.

How Do You Add Lookup Codes?
To view, add, or update an entity in the lookup tables, use the Data Manager Browser, as described 
in Chapter 6: Browsing Data and Chapter 7: Maintaining Data in the Data Manager User's 
Guide. If you have a great number of lookup codes to add, you can also use the Import program.

About Factors and UOMs in Oracle Utilities Revenue Management
Factor names are variables used to represent taxes and other charges. A factor name is stored in 
the Factor Lookup Table, while the actual values associated with the factor are kept in the Factor 
Value Table (both the current value and values that were in effect in the past). When you use a 
factor in a revenue forecast, Oracle Utilities Revenue Management automatically retrieves the 
correct values for the factor for each bill period in the forecast range.

Any factor that will be used in a revenue forecast must have the appropriate unit of measure 
(UOM) code associated with it in the Factor Table, since the UOM determines how Revenue 
Expert applies the factor value when calculating revenue. Oracle Utilities Revenue Management 
recognizes the following UOM codes:

• 85 - Dollars per kWh 
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• REVBASE:  Indicates that the factor is a percentage of base revenue.  The factor value 
should directly represent the percentage to apply (i.e., to indicate 5%, enter the value 
‘0.05’).

• REVTOTAL:  Indicates that the factor is a percentage of total revenue.  The factor value 
should directly represent the percentage to apply (i.e., to indicate 5%, enter the value 
‘0.05’).

Note:  Only one factor in a rate schedule can have this UOM.

• CUSTCHARGE:  Indicates that the factor is applied as dollars per customer.  Any factor in 
the hierarchy that uses the CUSTCHARGE UOM code is included in the base revenue for its 
parent rate schedule.

• TAX_SURCHARGE:  Percentage of total revenue less any other factor using this UOM.

• TAX_SURCHARGE_KWH:  Applied as dollars per kWh.

• UNBUNDLED_SURCHARGE:  Revenue for factors with this UOM will be calculated as 
a percentage of the base revenue attributed to the unbundled component associated with the 
factor.  The percentage will be the factor’s tariff value, which is the factor’s value plus any 
adjustment (a value of 0.05 is equivalent to 5%).  If the factor is not associated with an 
unbundled component then its revenue will be zero.

• FUEL_ADJ:  Applied as dollars per kWh.

• FUEL_ADJ_KW: Applied as dollars per kW.

Note: Reports will show fuel adjustment revenues as the sum of FUEL_ADJ 
and FUEL_ADJ_KW factor revenues.

• BASE_FUEL_ADJ: Revenue for factors with this UOM will be calculated as dollars per 
kWh.

• BASE_FUEL_ADJ_KW:   Revenue for factors with this UOM will be calculated as dollars 
per kW.

If a factor with any other UOM is selected for a forecast, Oracle Utilities Revenue Management 
substitutes dollars per kWh.

Setting up kWh and kW
You also need to specify which bill determinant to use with kWh (kilowatt hours) and which bill 
determinant to use with kW (kilowatts).

How to setup kWh and kW:

1. Select File-›Open-›[name of forecast] if the Revenue Forecast window is not already open.

2. Select Revenue Forecast-›Setup kWh and kW.

The Setup kWh and kW dialog box appears.

3. Select the bill determinant to use for kWh from the kWh Bill Determinant drop-down list.

4. Select the bill determinant to use for kW from the kW Bill Determinant drop-down list.

5. Click OK to save the settings. Click Cancel to close the dialog.
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Customer and Energy Load Forecast File
This file contains your utility’s projected customer count and Megawatt-hour (MWH) sales for 
each business class that you wish to include in the revenue forecast. It is required.

This file typically comes from the department in your utility that is responsible for forecasting 
future energy use. It must be placed any where on your system or network that is accessible from 
the machine you’re using to run Oracle Utilities Revenue Management (typically 
LODESTAR\RCDATA on the local drive).

Keymap.txt - Mapping Codes
The codes used to identify operating companies, jurisdictions, and business classes in the 
Customer and Energy Forecast File are not the same as those used in the Oracle Utilities Data 
Repository Lookup tables. To accommodate this situation, there is a special file that maps keys in 
the forecast file to the appropriate lookup codes. The file is called “keymap.txt” and is located in 
the LODESTAR\CFG directory. If and when lookup codes in the Oracle Utilities Data 
Repository are added or modified, you must update this file as well. You can edit the file using 
Notepad or another text editor.

Here is an example of a portion of a keymap.txt file. The values must be separated by a comma; 
blanks are optional (for readability).

The table above shows a sample keymap.txt file

• Column 1: The key as it appears in the Customer and Energy forecast file.

• Column 2: Lookup codes as they appear in the Oracle Utilities Data Repository; operating 
company code, jurisdiction code, and revenue code.

• Column 3: Flag indicating whether the first key (1) represents MWH or number of 
customers. Possible values are MWH or CUST.

1 2 3

“MHTR@WP@F”,    “WP”, “PA”, “00”, MWH

“MHTCM@WP@F”,   “WP”, “PA”, “20”, MWH

“MHTIN@WP@F”,   “WP”, “PA”, “40”, MWH

“MHSTL@WP@F”,   “WP”, “PA”, “50”, MWH

“MHWHO@WP@F”,   “WP”, “PA”, “60”, MWH

“MHTR@MPWV@F”,  “MP”, “WV”, “00”, MWH

“MHTCM@MPWV@F”, “MP”, “WV”, “20”, MWH

“MHTIN@MPWV@F”, “MP”, “WV”, “40”, MWH

“MHSTL@MPWV@F”, “MP”, “WV”, “50”, MWH

“MHWHO@MPWV@F”, “MP”, “WV”, “60”, MWH

“MHTR@MPOH@F”,  “MP”, “OH”, “00”, MWH

“MHTCM@MPOH@F”, “MP”, “OH”, “20”, MWH

“MHTIN@MPOH@F”, “MP”, “OH”, “40”, MWH

“MHSTL@MPOH@F”, “MP”, “OH”, “50”, MWH

“MHWHO@MPOH@F”, “MP”, “OH”, “60”, MWH

“MHTR@PEVA@F”,  “PE”, “VA”, “00”, MWH

“MHTCM@PEVA@F”, “PE”, “VA”, “20”, MWH

“MHTIN@PEVA@F”, “PE”, “VA”, “40”, MWH

“MHSTL@PEVA@F”, “PE”, “VA”, “50”, MWH
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Net Power Supply Forecast File
This file contains data required for calculating unbilled kWh for each operating company in a 
forecast. Its format is similar to that of the Customer and Energy Forecast File, except that it 
contains data just down to the jurisdiction level (as opposed to the business class level).

Keymap2.txt - Mapping Codes
As with the Customer and Energy Forecast File, the codes used to identify operating companies 
and jurisdictions in the Net Power Supply Forecast File are not the same as those used in the 
Oracle Utilities Data Repository Lookup tables. A file called “keymap2.txt” is used to map keys 
between the two files. This file is located in the LODESTAR\CFG directory. If and when lookup 
codes in the Oracle Utilities Data Repository are added or modified, you must update this file as 
well. You can edit the file using Notepad or another text editor.

Here is an example of keymap2.txt.

.

The table above shows a sample keymap2.txt file

• Column 1: The key as it appears in the Net Power Supply Forecast File.

• Column 2: Lookup codes as in the Oracle Utilities Data Repository: operating company code 
and jurisdiction code.

1 2

“MHNPS@MPOH@F”, “MP”, “OH”
“MHNPS@MPWV@F”, “MP”, “WV”
“MHNPS@PEMD@F”, “PE”, “MD”
“MHNPS@PEVA@F”, “PE”, “VA”
“MHNPS@PEWV@F”, “PE”, “WV”
“MHNPS@WP@F”,   “WP”, “PA”
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Bill Frequency Tables

What are Bill Frequency Tables?
Oracle Utilities Revenue Management uses the historical data that you input in the Bill Frequency 
tables as the basis for allocating a Business Class’ total kWh and customers among its rate 
schedules; for allocating billing determinant usage to blocks in a rate schedule; and for 
determining the relationship between kWh and other determinants in the forecast. You should 
create one Bill Frequency Table for every customer group that represents a rate schedule 
in each Operating Company/Jurisdiction/Business Class combination in the forecast.

Bill Frequency tables summarize historical usage data for a customer group by blocks over a range 
of months.  A single Bill Frequency Table can summarize data for one bill determinant, or a 
number of them.  In addition, the customer group can be segmented by rate code (more about 
that later).

For each determinant of interest, you divide the range of possible usage values into “bins” or 
“blocks.” For example, for kWh/month, you might have bins of 0 to 250, 251 to 500, 501 to 
infinity. To create the Bill Frequency Table, the software examines each customer’s bill history 
information, month by month. When a customer's value for the determinant falls within a given 
block, the software increments the customer count for the block by 1, and adds the value of the 
billing determinant to the total value for the block. The result is a table of customer counts and 
total usage for each block, for every month in the date range.

12 “mpwva” “” 276814 1 1995 12 1995 “mpwva” “ ”
{ 1   “KWH”:“mpwva”
}
( 1   “Z1”:“ ”
)
<
1 274452 1 1995 1 1995     /* Bill month: 7/1992 thru 7/
1992  */
    <
    1 274452  “Z1”         /* Rate code: Z1  */
    <
    3 “KWH”
        <
          { -1.0000, 0, 0.0000 }
          { 0.0000, 110440, 33036631.0000 }
          { 550.0000, 164012, 196066066.00 }

Portion of a ‘.bft’ file
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How Do You Create a Bill Frequency Table?
You can create a Bill Frequency Table using the Data Manager and Oracle Utilities Rate 
Management applications. Step-by-step instructions are provided on the following pages.

Required Inputs
Before you can create a Bill Frequency Table, the following inputs must be available: 

• Account List.
• Bill history data for every account in the list over the test period.
• Blocking(s).

Data
ManagerAccount Information

Query Bock Boundaries

Date Range

Rate Code Groups (Optional)

Bill Frequency Table
Rate

Account Bill Histories

Account List

Figure 2.4 - Overview of the
Bill Frequency Table
Creation Process

Management
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Creating an Account List
The Account List is a list of IDs for all of the accounts you wish to include in the Bill Frequency 
Table (and hence in your forecast for a particular rate schedule).

Typically, you create the list using Data Manager’s Query feature. See Chapter 8: Working with 
Lists and Queries of the Data Manager's User's Guide for information about creating lists. In 
general, for Oracle Utilities Revenue Management you specify a query that will find all accounts belonging to the 
desired operating company/jurisdiction/revenue code/rate schedule combination. For example, you would first 
specify that you want to create an account list, and then supply a query similar to the one shown 
below:

Operating Companies.Code = WP
AND
Jurisdictions.Code = PA
AND
Revenue Code.Code = 20
AND
Rate Forms.Code = 1

Note: The term “Business Class” used in Oracle Utilities Revenue 
Management and “Revenue Code” in Data Manager are equivalent.

You can further filter the list by specifying one or more rate codes. However, if you leave rate 
codes out of the query now, you’ll have the option of segmenting the Bill Frequency Table by rate 
code group later in the process (e.g., when you actually create the table).

About Account Billing Determinant Data
Billing Determinant values for accounts are stored in the Account Bill History and/or Account 
Bill History Values tables in the Customer Database.  Billing determinant data must be available in 
these tables for every account in your list over the desired date range.  This information is typically 
loaded into the database on a regular, production basis, and no additional effort is required on 
your part.

Creating Blockings
For each billing determinant you want to include in the Bill Frequency Table, you must specify a 
“Blocking.”  A Blocking is a set of values that defines the boundaries between blocks in the Bill 
Frequency Table.

The blockings should generally match the blockings that you’ll specify for Ogives in the actual 
forecasting process.

You create a blocking using Data Manager.  Blockings are stored in the Customer Database, so 
that you can reuse them.

When you create a blocking, you can specify the high and low values that define each individual 
block. Or, if all or a portion of the blocking consists of a series of contiguous, equal-size blocks, 
the software gives you a shortcut—in that case, you can supply the high and low values that define 
the range covered by the series of equal-sized blocks, and then the value of the block (called the 
“Step” value).

How to create a new blocking:

1. Go to the Data Manager desktop. If you are at the Oracle Utilities Rate Management desktop, 
you can open Data Manager by selecting Tools-›Data Manager.

2. At the Data Manager desktop, select File-›Setup-›Blocking Tables.

The Open Blocking dialog box appears.

3. Click New.

The Blocking dialog box appears.
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4. Under Values, enter the Low and High values for the current block (or the range of 
contiguous, equal-size blocks). The High value must be greater than the Low value for each 
block, except for the last block in the blocking, which may be zero (a High value of zero 
indicates infinity).

You can specify negative numbers for the low and high values that define a block (however, 
these are used only in the Billing Impact Frequency report in Customer Impact). If you 
change your mind and want to remove a minus sign, simply type a + sign in the Values field 
for that value.

5. Enter a Step value for the block. If you are defining each block individually, then the Step 
value must equal the difference between the High and Low values. If you are using the step 
feature to specify a set of contiguous, equal-size blocks, the Step value must evenly divide into 
the difference between the High and Low values. If you are specifying the last block with a 
High value of 0, the Step value should be 0, too.

Note: If any usage values fall outside of the specified blockings (either at the high end if you 
did not specify 0 for the High value in the last block, or at the low end if there are negative 
values), the program automatically creates an “additional” blocking at that end when the 
program creates the Bill Frequency Table.

6. Click Add to insert the block(s) into the Blocking Contents list box. A block is automatically 
inserted into its proper position in the list box based on its Low and High values.

7. Repeat Steps 3 through 6 to add any other blocks necessary to complete the definition of the 
Blocking. Make sure that the High values match the Low values for consecutive 
blocks.

8. Click OK to save the new blocking in the Customer Database. The Save Blocking Table As 
dialog appears.

9. Enter a name and comments for the blocking, and click OK.

You can also open an existing blocking file.

How to Open an Existing Blocking:

1. At the Data Manager desktop, select File-›Setup-›Blocking Tables.

The Open Blocking dialog box appears.

2. Select the desired blocking and click Open. You can also import a Common Blocking file by 
clicking Import and selecting the appropriate Common Blocking file. The imported blocking 
file then appears in the Open Blocking dialog.
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Creating a Bill Frequency Table
Once you have assembled all of the required inputs as described on the previous pages, you are 
ready to create the Bill Frequency Table. For this part of the process, you’ll use the Oracle Utilities 
Rate Management application.

1. Start Oracle Utilities Rate Management.

To start Oracle Utilities Rate Management from Data Manager, select Tools-›Oracle 
Utilities Rate Management.

2. At the Oracle Utilities Rate Management desktop, select Analysis-›Bill Frequency-›Create.

The Create Bill Frequency Table dialog box appears.

3. Select either Account or Customer in the Select By box.

4. Select the accounts or customers of interest using one of the following options:

• ID: Type the ID of the account or customer of interest.

• List: Select the list that contains the IDs of the customers or accounts whose usage you 
want to use as the basis for the Bill Frequency Table. If the contents of the list may have 
changed since the last time that the query associated with it was run, check Refresh list 
before using. This option updates the list for this job and saves the new version of the 
list to the database, replacing the old version.

• All: Select this option to include all customers or accounts that are in the Customer 
Database.

• File - Select a file containing a list of customer/account IDs (*.IDS), a list file (*.lst), an 
account query file (*.qra), or a customer query file (*.qrc).

5. Test Period. Enter the start and stop dates for the test period in the MM/YYYY format. 
The period covered by the Bill Frequency Table can be greater than the period desired for the 
forecast, but not less.

6. Select the Determinant/Blocking. In the Determinant list box, highlight a desired billing 
determinant. Then, in the Blocking list box, highlight the Blocking you wish to apply to the 
selected determinant. Click Add to put the results in the Determinant/Block Pairs list box. 
Repeat for each billing determinant you want to include in the Bill Frequency Table.

7. Click Advanced if you want to break down the Bill Frequency Table by Rate Code Groups. If 
so, go to Step 5. If not, click OK and go to Step 7.

8. If you clicked Advanced, you are at the Advanced Create Bill Frequency Table dialog box 
shown above.  This dialog lets you select billing information for inclusion in the Bill 
Frequency Table by rate code group.  This is useful to further segment customers within a 
business class or jurisdiction.  Complete the box as follows:

• Select a Rate Schedule in the Rate Schedule combo box.  All Rate Codes for the selected 
Rate Schedule then appear in the Rate Codes list box.

• Select one or more Rate Codes from the Rate Codes list box to define a single Rate Code 
Group.

• Click Add to add the selected Rate Codes to the Rate Code Groups list box as a single 
Rate Code Group.

• Repeat the above three steps for each desired rate code group.

9. Click OK to accept the defined Rate Code Groups.

10. When you are satisfied with your options in the Create Bill Frequency Table dialog box, click 
OK.  The system will prompt you for a name (up to 8 characters). 

A Progress Indicator dialog appears and tracks the progress of the Bill Frequency Table 
creation. If you want to stop the process for some reason, click Abort.
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Bill Frequency Tables
When the process ends, the software creates a Bill Frequency table in the Oracle Utilities Data 
Repository. You can examine and analyze the contents of the file by applying the Bill 
Frequency Analysis feature of Oracle Utilities Rate Management to it (see the Oracle Utilities 
Rate Management User's Guide).
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Additional Inputs Required for Extended Block Rates
Forecasts that include extended block rates require that historical averages be calculated for per 
block usage via the actual rate schedule.  For that reason, you must supply the following inputs, in 
addition to those described on the preceding pages:

• Account List

• Rate Schedule Version (written in the Oracle Utilities Rules Language)

• Rate Code (optional).

The Data Manager User’s Guide provides instructions for creating these inputs.

Note:  All rates require BFTs for the allocation factors.

Using the above inputs, Oracle Utilities Revenue Management iterates the calculations over each 
account in the list, for each month in the specified historical date range, using the specified rate 
schedule version language to calculate the amount of bill determinant usage in each price block. If 
you do not explicitly specify a rate code, Oracle Utilities Revenue Management will use the 
account's rate code history. In most cases, the account's rate code history specifies the same rate 
schedule as the one being used in the calculation; however, if not, then Oracle Utilities Revenue 
Management queries the interschedule mapping information in the database to determine which 
rate code to use.

About Rate Schedules
It is important that when the rate schedule is run, the result is just one set of blocks per bill 
determinant per month.  For example, the following rate schedule  could be used only if either all 
accounts in the account list were on rate code MI, or all accounts in the list were not on rate code 
MI. If some accounts were subject to the first set of blocks and some to the second (e.g., some on 
MI and some not), then the rate schedule could not be used because it would yield two sets of 
blocks for KWH.

SELECT RATE_CODE
WHEN “MI”

BLOCK KWH
FROM 0 TO 4000 CHARGE $.0982 INTO $BK1
FROM 4000 TO 10000 CHARGE $.0815 INTO $BK2
FROM 10000 CHARGE $.0736 INTO $BK3
TOTAL $ENERGY_CHARGE;

OTHERWISE
BLOCK KWH
FROM 0 TO 5000 CHARGE $.0982 INTO $BK_OTH1
FROM 5000 TO 8000 CHARGE $.0815 INTO $BK_OTH2
FROM 8000 CHARGE $.0736 INTO $BK_OTH3
TOTAL $ENERGY_CHARGE;

END SELECT;
$EFFECTIVE_REVENUE = 10:
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Chapter 4
Running a Revenue Forecast

Once you have created all of the inputs required for a forecast as described in Chapter 3: 
Preparing Inputs, you are ready to use the system to actually generate a forecast. This chapter 
takes you step-by-step through the process of specifying all of the necessary parameters and 
running the calculations.

• Specifying Inputs and Parameters

• Saving the Forecast
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Specifying Inputs and Parameters
You select inputs and define parameters for a forecast in the Revenue Forecast window.  Select 
File-›New or File-›Open-›[name of existing forecast] to open this window.

The Revenue Forecast Window displays a series of eight tabs.  Each tab page represents a set of 
parameters or inputs you must specify.  As explained in the remainder of this chapter, you must 
“fill out” each one of these tab pages, in sequence, moving from left to right.  (As you progress 
from tab to tab, you may decide to go back and modify your inputs to a previously completed tab 
page—however, keep in mind that information on tabs to the right may be affected.)

Parameters Page
Oracle Utilities Revenue Management lets you save the forecast parameters and results. The 
information you provide on this tab page will help you identify and retrieve the information in the 
future:

• Name:  Enter a unique name for your forecast (up to 64 characters).

• Note:   Enter a description of your forecast (up to 254 characters).
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Hierarchy Page
The Hierarchy page is used to specify several important aspects of the forecast:

• the hierarchy of entities of one or more operating companies to be used in the forecast

• whether or not to calculate a deferred fuel expense for each jurisdiction, and whether or not 
to include a business class in the calculation of an operating company’s “regular customer 
unbilled kWh” (both calculations pertain to unbilled revenue)

• the historical usage data to be used in the forecast

• the methodology for forecasting usage for bill determinant blocks in a rate schedule.  You’ll 
also associate a charge factor with each block.

Using the Hierarchy Page to Specify Entities for Inclusion in the Forecast
The Hierarchy page gives you a graphical tool for specifying the entities for which you want to 
generate a forecast. You can specify one or more operating companies, jurisdictions, revenue 
codes (business classes), rate schedules, billing determinants, and factors. You can choose as many 
entities as desired; however, for each operating company you choose you must also specify at least 
one jurisdiction; for each jurisdiction at least one business class (revenue code); and for each 
business class at least one rate schedule.

How to add an entity to the tree:

1. In the Tree Pane, highlight the folder that represents the level of the entity you wish to add.  
(When you first begin, only the Operating Companies folder is visible.)

2. Click the Add [entity] button in the right pane (where “entity” is the name of the currently 
selected folder). 

A window opens, displaying the list of the entities that are currently available at the selected 
level (see the illustration on the next page). If the list is long, you may have to scroll the 
window to view all of the options. If the desired entity is not included in the list, it has not 
been defined in the Customer Database Lookup tables (refer to Chapter 2 for more 
information).

3. Highlight one or more entities in the list and click OK.

The selected entities appear in the Tree, as does as the folder for the subordinate level.  You 
can add an entity at the new level, or you can highlight a higher-level folder and add additional 
entities there.

Continue this process until all desired entities have been added to the tree.

How to remove an entity from the tree:

Note: When you remove an entity, any and all of its subordinate entities are automatically 
removed as well.

1.  In the Tree Pane, highlight the icon for the entity that you wish to remove.

2. Click the Remove [entity] button that appears in the right pane. 

A message appears, asking you to confirm that you wish to remove the selected entity.  Click 
Yes or No as desired.

How to replace an entity in the tree:

1. In the Tree Pane, highlight the icon for the entity that you wish to replace with a different 
one.

2. Click the Replace button that appears in the right pane.

3. Highlight the icon for the new entity in the Tree Pane and click OK.  (Alternatively, you can 
double-click the icon.)
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How to navigate the tree view:

As you build and modify the Tree, you may find it advantageous to modify the amount of 
information displayed in the Tree Pane. You can collapse or expand the tree, and you can resize 
the pane to make more room for the information you’re interested in. None of these actions 
affects which entities are included in the calculations.

Using the Hierarchy Page to Specify Options for Unbilled Revenue
The Hierarchy page also lets you specify whether or not to calculate a deferred fuel expense for 
each jurisdiction, and whether or not to include a business class in the calculation of an operating 
company’s “regular customer unbilled kWh.” Both calculations pertain to unbilled revenue.

How to include calculations of deferred fuel expense for a jurisdiction:

1. In the Tree Pane, highlight the icon for the jurisdiction of interest.

2. In the right pane, check Show Deferred Fuel Expense to have the software perform the 
calculations, or leave the option unchecked if you don’t want the calculations.  The default is 
unchecked (no deferred fuel expense calculations will be performed for the jurisdiction).

How to include (or exclude) a business class in the calculations of an operating 
company’s “regular customer unbilled kWh”:

1. In the Tree Pane, highlight the icon for the business class of interest.

2. In the right pane, check Include as Regular Customer Unbilled KWH to include the 
business class; remove the checkmark to exclude it.  The default is checked (will be included).

3. Check Exclude from Unbilled Fuel Revenue Calculations as desired.

This box, when checked, alters the way the Unbilled Fuel Revenue, Unbilled Fuel Costs, and 
Deferred Fuel Expense are calculated for the parent Jurisdiction.  The formulae below show 
how this is calculated:

Unbilled Fuel Revenue =Average Fuel Rate (excluding the checked 
Business Classes) *
Unbilled kWh (excluding checked business classes) *
GRT Effective Rate

Unbilled Fuel Costs =Fuel Rate * Unbilled kWh (excluding checked 
business classes)

Deferred Fuel Expense =Unbilled Fuel Revenue - Unbilled Fuel Costs
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Using the Hierarchy Page to Specify Historical Usage Data
Prior to starting the Oracle Utilities Revenue Management software, you should have assembled 
historical usage data for each customer group that represents a rate schedule in the forecast, and 
put it in a Bill Frequency Table. (If you have not already created the tables, see Chapter 3 for 
instructions.) Oracle Utilities Revenue Management will use the historical data in the Bill 
Frequency tables as the basis for allocating a Business Class’ total kWh and customers among its 
rate schedules, as well as to determine relationships between kWh and other determinants.

In this step, you will associate each rate schedule in the hierarchy with the appropriate Bill 
Frequency Table.  You must also specify the 12-month period within the Bill Frequency Table that 
you wish to apply for each rate schedule.  If your rate schedule includes extended-block rates, your 
must also specify an account list, rate schedule version, and (optionally) rate code. 

How to specify historical usage data:

1. Highlight a rate schedule in the Tree Pane.

A form appears in the right pane.

2. In the right pane, specify the Date Range for the historical data to be used in the forecast:

• All Rate Schedules:  To specify a “global” historical date range that the program will 
apply to all rate schedules in this forecast’s hierarchy, click All Rate Schedules.  Then, 
specify the start and end month of the date range in the From and To fields, described 
below.

• This Rate Schedule:  To apply a date range to just one rate schedule, highlight the rate 
schedule in the tree pane and click This Rate Schedule. Then, specify the start and end 
month as described under From, To: (below).  This date range overrides any dates 
specified using the
All Rate Schedules option just described.

• From, To:  Type the start and end month that defines the date range.  The specified date 
range must span 12 months exactly, and there must be data for that period in the Bill Frequency Table.  
July through June of the previous year are the defaults.

3. In the right pane, specify the Bill Frequency Table for the historical data to be used in the 
forecast. Click the small arrow to the right of the field, and highlight the name of the file 
containing the data you want to apply to the selected rate schedule. The filename appears in 
the field. If the file you want does not appear in the list, verify that it is stored in the 
LODESTAR\RCDATA directory.

Select None if you want to manually specify allocation factors, rather than have Oracle 
Utilities Revenue Management calculate them. (A Bill Frequency Table is absolutely necessary 
only if the rate schedule contains a bill determinant with more than one block, and one of 
those blocks is fixed. Otherwise, you can manually allocate a business class’ usage and 
customers among its rate schedules using the Allocations Factors tab page described later in 
this chapter.)

4. If you had previously run this forecast and want to use the same Bill Frequency Table now, 
but the contents of the table have been modified since, click the Reload button. Or, if you 
add a new billing determinant for the rate schedule on the Hierarchy tab page after selecting 
the file here, you must reload the file.

5. Click the Calculate... button if the rate schedule includes extended blocks rates. The Select 
Rate Schedule and Optional Rate Code dialog box appears. Specify the following:

• Account List:  List of accounts on this rate schedule.  (If you have not yet created this 
input, refer to Chapter 3.)

• Rate Schedule Version:  The version of the rate schedule to apply. (If you have not yet 
created this input, refer to Chapter 3.)
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• Rate Code: If you want to apply a specific rate code, select it in the Rate Code listbox in 
the upper right corner of the dialog. If you do not specify a rate code, Oracle Utilities 
Revenue Management will use the account's rate code history. If you click Via Inter-
Schedule Mapping, Oracle Utilities Revenue Management will query the interschedule 
mapping information in the database to determine which rate code to use.

6. Repeat steps 2 through 5 for each rate schedule in the hierarchy.

Using the Hierarchy Page to Specify Unbundled Components
Each billing determinant in the forecast hierarchy will be able to be associated with an unbundled 
component.  The Unbundled Component combo box control will be added to the Hierarchy 
Tab control when a billing determinant is selected in the tree.  The drop-down list of the combo 
box will contain all unbundled components defined for the forecast.  Selecting an unbundled 
component in the combo box will associate that component with the selected billing determinant.  
A “<None>” selection will also be provided so that a billing determinant can be disassociated 
from any unbundled components.  This “<None>” selection will be the default value for any new 
billing determinants added to the forecast and also for any billing determinants in existing revenue 
forecasts created prior to this new version.

In addition to being able to associate billing determinants with unbundled components, the same 
billing determinant will be allowed to be added to a rate schedule in the forecast hierarchy more 
than once.  This will allow for a bundled determinant to be broken down into its unbundled 
components within the revenue forecast.

The billing determinant’s associated unbundled component, if any, will appear in parentheses to 
the right of the determinant’s identifier in both the hierarchy tree and in any reports in which it 
appears.

Associating a Factor with an Unbundled Component
Each factor in the forecast hierarchy will also be able to be associated with an unbundled 
component.  The Unbundled Component combo box control will be added to the Hierarchy 
Tab control when a factor is selected in the tree.  The drop-down list of the combo box will 
contain all unbundled components defined for the forecast.  Selecting an unbundled component 
in the combo box will associate that component with the selected factor.  A “<None>” selection 
will also be provided so that a factor can be disassociated from any unbundled components.  This 
“<None>” selection will be the default value for any new factors added to the forecast and also 
for any factors in existing revenue forecasts created prior to this new version.

In addition to being able to associate factors with unbundled components, the same factor will be 
allowed to be added to a rate schedule in the forecast hierarchy more than once.  This will allow 
for a bundled factor to be broken down into its unbundled components within the revenue 
forecast.

The factor’s associated unbundled component, if any, will appear in parentheses to the right of the 
factor’s name in both the hierarchy tree and in any reports in which it appears.
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Unbundled Component Setup
Unbundled components are specified via the Edit Unbundled Components dialog.  Select 
Revenue Forecast-›Edit Unbundled Components… to access this dialog.

The unbundled components specified here will be saved with the revenue forecast.  New 
components can be added by entering the component name in the edit box at the bottom of the 
dialog and then clicking Add.  The new component name will be inserted above the selected 
component in the list box.

The selected component’s name can be edited by changing the text in the edit box and then 
clicking Update.

A component can be removed by selecting the component in the list box and clicking Delete.  An 
unbundled component cannot be removed if any billing determinants or factors in the forecast 
hierarchy are associated with it.

The order of the unbundled components as they appear in the list box will be the order in which 
they appear in any reports in which they are included.  A component can be moved up or down in 
the list box by selecting the component and then clicking Up or Down.

Clicking OK will accept any changes and close the dialog. Clicking Cancel will ignore any changes 
and close the dialog. Clicking Help will display online help for the dialog.

Factor Refresh
Factor values may be stored in a database or in a cached revenue forecast object.  These cached 
objects can be updated from the database by selecting
Revenue Forecast-›Refresh Factor Values.

After you select this option, you will be prompted to confirm the action.  Click Yes to proceed, or 
No to abort.

Using the Hierarchy Page to Specify the Methodology for 
Calculating Forecast Usage for Bill Determinant Blocks and to Associate Fac-
tors with Bill Determinant Blocks

The Hierarchy tab page also enables you to select a methodology for calculating forecast usage per 
bill determinant price block (you can even specify a different method for individual blocks).  You 
can specify different blocks boundaries for selected date ranges within a 12-month period (January 
through December).

In addition, you can associate a factor code with each bill determinant price block. The program 
uses the factors referenced by these factor codes to derive tariffs (prices) for the blocks. These 
tariffs appear on the Tariffs page for the selected Bill Determinant as the derived values for the 
blocks. Like the factor tariffs, these block tariffs reflect the factor values of the corresponding 
factors in the Oracle Utilities Data Repository over the forecast date range.

You must perform the following steps for each Billing Determinant in every rate schedule that is 
priced according to block rates.  If none of your rate schedules include price blocks, leave the 
default block range in place (e.g. “From 0 To -”); the dash represents infinity.  Conceptually, a 
determinant always has at least this one block (from zero to infinity).

How to select an allocation methodology and specify block boundaries:

1. Highlight a bill determinant in the Tree Pane.

A form appears in the right pane.

2. In the right pane, specify the blocking type, the blocks and associated factor codes, and the 
month(s) each set of blocks is in effect.

Rate Schedule Identifier:  Applies only if one or more extended blocks exist for the bill determinant.  
Enter the identifier that the rate schedule uses for the bill determinant.

Date Ranges: You can divide the test year into sub-periods during which different blockings 
are in effect. When a new tab is first displayed, the Date Range is “From 01 To 12,” which 
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means that there is one period covering January through December. To subdivide the year, 
modify the “To” values. In other words, click the cursor in a cell in the To column and type a 
value for the end month of the new period. Press the ENTER key. Oracle Utilities Revenue 
Management automatically creates a following period consisting of the remaining months. 
For example, say you want to divide the year into two periods, the first consisting of January 
through June, the second consisting of July through December. Click the cursor in the first 
cell in the To column (which initially reads 12). Type 3 and press Enter. Oracle Utilities 
Revenue Management automatically subdivides the year appropriately. You can divide the year 
into as many as 12 periods using this method.

Note: If the rate schedule contains seasons, the divisions of the year you specify here must 
match the seasons.

Blocks: Specify the blocks in effect for each date range. First, select the date range in the 
Date Ranges Table by clicking anywhere in its row. Then, specify the desired blocks in the 
Blocks Table. The default is one block, from 0 to infinity (the dash in the To column 
represents infinity). You can create smaller blocks using the same method desired above (e.g., 
specify new block boundaries by modifying values in the “To” column). The first block must 
begin with 0 and the last must end with -. Even if you are specifying extended blocks, it is 
recommended that you supply block ends (see Tips About Rates that Include Extended Blocks, 
below).

Note about Blocks, Bill Frequency tables, and Rate Schedules: It is not necessary for 
each block boundary in the Blocks Table to align with a block boundary in the Bill Frequency 
Table.  However, the number of blocks in the BFT must be equal to or greater than the 
number of blocks you specify here.  (With fixed blocks, a more accurate forecast will result if 
the Bill Frequency Table defines many blocks for each one defined here.)  For extended 
blocks, the number of blocks in the blocking must exactly match the number of 
blocks specified in the rate schedule.  See also Tips About Rates that Include Extended Blocks, 
below.

Factor Code:  Associate a factor code with each bill determinant block.  First, click the 
mouse pointer in the Factor Code cell in the row for the block.  Then click the Associate 
Factor button near the bottom of the screen.  The “Select Factor” dialog box appears.  
Highlight the desired factor, and click OK. 

Block Type:   Specify a block type for each bill determinant block.  First, click the mouse 
pointer in the block’s row, then click either Fixed or Extended.  Fixed blocks will be calculated 
using the Ogives method; Extended, the Historical Average.  Repeat for each applicable 
block.  See also Tips About Rates that Include Extended Blocks, below.

Tips About Rates that Include Extended Blocks
When calculating bill determinant block distribution, Oracle Utilities Revenue Management 
applies either the Ogives or Historical Averages method on a per block basis, rather than on a per 
determinant basis.

In order to do that, Oracle Utilities Revenue Management applies the Historical Averages method 
first, using the total forecasted usage for the month; then distributes the remaining usage over the 
fixed-size blocks using the Ogives method.

For the best results here, it is recommended that any extended blocks that consist of a fixed-size 
portion and a load factor-based portion be split into two separate blocks.

For example, say you have a rate schedule that defines the first energy block as follows:

The first energy block shall consist of 300 kilowatt-hours plus 30 kilowatt-hours for each one-half kilowatt of 
Customer's Demand in excess of 5 kilowatts.

The forecast for this block could be more accurate if you split the block into a fixed block from 0 
to 300 kWh, and an extended block consisting of the additional 30 kWh increments.
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Also, it is best if you use the Ogives method for all fixed sized blocks, even those that come after 
an extended block.  However, when a fixed-size block is preceded by an extended block, it is not 
possible to determine an absolute value for the block end.  But since the Ogives method requires 
the block end as an input, it is recommended that you estimate the block end in such cases.

Allocation Factors Page
Oracle Utilities Revenue Management allocates a Business Class’s total kWh usage and number of 
customers to its rate schedules (if you've specified more than one in the hierarchy) according to 
data in the Bill Frequency Table. You can manually adjust these derived percentages using the 
Allocation Factors tab page.

This tab also enables you to adjust the linear relationship between kWh and other Billing 
Determinants in a rate schedule (also originally derived from the Bill Frequency Table data).

How to manually alter allocation of Business Class usage among its customer 
population on different rate schedules:

• In the Tree pane, highlight the icon for the desired Business Class.

A spreadsheet-type table appears in the right pane. This table displays both the percentage of 
kWh and the percentage of customers for each Rate Schedule in the selected Business Class, 
for each month in the historical date range for all Rate Schedules.

Edit the derived values as desired using the “adjustment” cells. Refer to How to edit values 
in a table using the adjustment cells: on page 4-9 for more information.

Note: The total for each and every column in the table must equal 100.00%. When you adjust 
a value in one cell, you must compensate for the change by adjusting other values in the 
column (the software does not do this for you). If the total of any column is more or less than 
100%, Oracle Utilities Revenue Management will display a warning message when you 
attempt to go to a different tab.

How to manually alter the linear relationship between kWh and other Billing 
Determinants for a selected rate schedule:

• In the Tree pane, highlight the icon for the desired rate schedule.

A spreadsheet-like table appears in the right pane.  This table displays the linear relationships 
between kWh and the other bill determinants for the selected rate schedule.  The data is 
displayed for each month in the historical date range for the selected rate schedule.

Edit the derived values as desired using the “adjustment” cells. Refer to How to edit values 
in a table using the adjustment cells: on page 4-9 for more information.

How to edit values in a table using the adjustment cells: 

Enter a value in one of the “adjustment” cells, and press the ENTER key. Oracle Utilities 
Revenue Management displays the “adjusted” value. You can make changes to the table values only 
via the adjustment cells; you cannot directly edit information in any of the other cell types.

An adjustment can be one of three possible types: additive, multiplicative, or absolute.  Additive 
adjustments are indicated by a leading plus (+) character.  Multiplicative adjustments are 
indicated by a leading asterisk (*) character. Absolute values are indicated by no leading plus 
or asterisk character.  You can use a minus (-) sign with any of the three types for a negative 
value.

For example, to change 89.00% to 90.00%, type +1 in the adjustment cell.  To change 42.00% 
to 40.00%, type +-2.00.  To change 3.00% to 4.5%, type *1.5.  To replace 51.00% with 
53.00%, type 53.

In addition to typing adjustments in one cell at a time as just described, you can also highlight 
one or more cells and apply the Edit menu commands, e.g., Cut, Copy, Paste, or Delete as you 
would in a spreadsheet program. For example, to copy adjustment values from one pair of 
contiguous cells to another: highlight two adjustment cells that are side-by-side and select 
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Edit-›Copy. Oracle Utilities Revenue Management copies the values to the clipboard. Then 
highlight two other side-by-side cells and select Edit-›Paste. Oracle Utilities Revenue 
Management copies the values into the cells.

You can even apply the Edit operations to a whole row or a whole table of adjustment cells.  
To highlight an entire row of cells, click the leftmost cell in the row (the one containing the 
row’s title).  To highlight all adjustment cells in the table, click the first cell in the table (the 
blank one in the very upper left corner).  Then apply the Edit operations as desired.

Note: Oracle Utilities Revenue Management saves all of your adjustments independent of the 
derived values. If you make a series of adjustments, the result is cumulative (a new adjustment is 
applied to the most recent value, not the original derived value).

Energy Forecast Page
In this step, you will specify the forecast date range and the Customer and Energy Load Forecast 
File that you wish to use as the basis for the forecast. (If you have not assembled this file, see 
Chapter 2 for instructions.) In addition, if you wish to calculate unbilled kWh for one or more 
operating companies, you’ll specify the applicable Net Power Supply Forecast File here.

Forecast Date Range: Specify the date range for the forecast by typing the start and end month 
in the From: and To: boxes.  January and December of the current year are the defaults.  Valid 
data for the specified date range must exist within the Customer and Energy Load Forecast File 
and (optionally) the Net Power Supply Forecast File.

Note: If you increase the forecast date range after selecting one of the forecast 
files, you must reload the file (see Reload below).

Customer and Energy Load Forecast File: Type the absolute path and name of the file, 
including the extension (which should be ‘.prn’). Alternatively, you can click the Browse button to 
locate and select the file.

Net Power Supply Forecast File: Type the absolute path and name of the file, including the 
extension (which should be ‘.prn’).  Alternatively, you can click the Browse button to locate and 
select the file.

Reload:  If—after selecting the forecast files in the dialog box—you change your mind about any 
of the options as described below, you must click the Reload button for the affected file:

• You expand the forecast date range (affects either file).

• You add a jurisdiction to the hierarchy on the Hierarchy tab page (affects either file).

• You add a business class to the hierarchy on the Hierarchy tab page (affects the Customer and 
Energy Load Forecast File).

If you change the contents of the files themselves, you must reload the files.

Note: The codes used to identify Operating Companies, Jurisdictions, and 
Business Classes in the forecast files are not the same as those used in the Data 
Repository Lookup tables. There are two special files that map keys in the 
forecast files to the appropriate lookup codes—“keymap.txt” for the Customer 
and Energy Load Forecast File and “keymap2.txt” for the Net Power Supply 
Forecast File. If the lookup codes have recently been added to or modified, you 
must update these files. Refer to Chapter 3 for instructions.
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Bill Determinants Page
The Bill Determinants tab page enables you to view and edit the forecasted kWh determinant 
usage and number of customers allocated to each Rate Schedule within a selected Business Class, 
as well as the allocation of any other forecast billing determinants for a selected rate schedule. 
Oracle Utilities Revenue Management derived this data from the Customer and Energy Load 
Forecast File and the allocation factors.

If desired, you can edit the values manually, as described below.

How to manually alter the allocation of Business Class usage (kWh) and/or customers to 
rate schedules:

• In the Tree pane, highlight the icon for the desired Business Class.

A spreadsheet-type table appears in the right pane.  This table displays the number of forecast 
kWh and customers allocated to each Rate Schedule in the selected Business Class, for each 
month in the historical date range. 

You can edit the derived values as desired using the “adjustment” cells. See How to edit 
values in a table using the adjustment cells: on page 4-9 for more information.

Note: You cannot change the total number of customers and kWh forecast for 
each month. In other words, when you adjust a value in one cell, you must 
compensate for the change by adjusting other values in the column (the 
software does not do this for you). If the total adjusted value at the bottom of a 
column does not match the original forecast value, Oracle Utilities Revenue 
Management will display a warning message when you attempt to go to a 
different tab.

How to manually alter allocation of the forecast billing determinants:

• In the Tree pane, highlight the icon for the desired rate schedule.

A spreadsheet-type table appears in the right pane. This table displays the values for all other 
determinants for the selected rate schedule. The data is displayed for each month in the 
forecast date range. Oracle Utilities Revenue Management derived this data from the 
Customer and Energy Load Forecast File and your input in the Allocation Factors tables.

Edit the derived values as desired using the “adjustment” cells. See How to edit values in a 
table using the adjustment cells: on page 4-9 for more information.

Tariffs Page
This tab page lets you view, add, and edit pricing information for each rate schedule in the 
forecast. If you specified a factor code for bill determinant blocks on the Hierarchy page, Oracle 
Utilities Revenue Management automatically computes the per unit prices and displays them on 
this tab page as the Derived values for the blocks. You can edit these prices as desired.

How to enter bill determinant prices and (optionally) adjust factor values:

• In the Tree pane, highlight the icon for the desired rate schedule.

A spreadsheet-type table appears in the right pane. This table displays tariff and pricing 
information for all Bill Determinants and Factors for the selected Rate Schedule, for each 
month in the forecast date range. Current pricing for Factors is loaded from the database, but 
values for the Bill Determinants default to 0 unless a factor was associated with the Bill 
Determinants as described on page 4-14. Supply prices for the bill determinants by typing 
values in the adjustment cells. You can also modify the factors using the adjustment cells. See 
How to edit values in a table using the adjustment cells: on page 4-9 for more 
information.
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Revenue Page
Finally, this tab page lets you view and edit the revenue forecast for each rate schedule in the 
hierarchy. Oracle Utilities Revenue Management derives this data from the Customer and Energy 
Load Forecast File and your inputs on the previous pages.

How to view forecast revenue for a rate schedule:

• In the Tree pane, highlight the icon for the desired rate schedule.

A spreadsheet-type table appears in the right pane.  This table displays the derived revenue for 
each bill determinant and factor for the selected rate schedule.  The data is displayed for each 
month in the forecast date range.

You can edit the data using the adjustment cells. See How to edit values in a table using 
the adjustment cells: on page 4-9 for more information.

Once you are satisfied with the forecast, you can generate a number of useful reports. See 
Chapter 5: Reports and Other Output for more information about Oracle Utilities Revenue 
Management reports.

Unbilled Revenue Page
This tab page lets you calculate, view, and edit the unbilled revenue forecast for an operating 
company, jurisdiction, and/or business class. Oracle Utilities Revenue Management derives this 
data from the Net Power Supply Forecast File and your inputs on this page and on the previous 
ones.

How to calculate and view unbilled revenue for an operating company:

• In the Tree pane, highlight the icon for the operating company of interest.

A spreadsheet-type table appears in the right pane. This table displays all of the components 
of unbilled kWh for the selected operating company for each bill month in the forecast date 
range. Spread factors represent the percentage of unbilled kWh for each business class within 
the parent operating company. Keep in mind that the spread factors must total 100% for each 
bill month.

Note: You must supply values for the “Unbilled KWH” for the first month in 
the forecast, as well as “Percentage of Losses” and business class “Spread 
Factors” for every month in the forecast.

Oracle Utilities Revenue Management derives the total unbilled kWh using the following 
formula:

unbilled kWh =previous month unbilled kWh
+ net power supply
- (net power supply x percentage of losses)
- current month billed kWh

where the previous month unbilled kWh value is carried forward from the total unbilled kWh 
value for the previous month.  Net power supply values come from the Net Power Supply 
Forecast File that you specified on the Energy Forecast tab page.  Percentage of losses is a 
number you supply.  Current billed kWh is carried forward from the Bill Determinants page 
(values for each business class for all jurisdictions in the operating company are summed 
together, unless you indicated otherwise for a business class by deselecting the Include as 
Regular Customer Unbilled kWh option on the Hierarchy tab page).

You can, if desired, modify the calculated total unbilled kWh value for each month, using the 
adjustment cells.See How to edit values in a table using the adjustment cells: on page 4-
9 for more information.
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How to calculate and view unbilled revenue for a jurisdiction:

• In the Tree pane, highlight the icon for the jurisdiction of interest.

A spreadsheet-type table appears in the right pane.  This table enables you to view and enter 
information required to calculate Unbilled Fuel Revenue and Deferred Fuel Expense values.

Note: You must supply values for every month in the forecast for the “GRT 
Effective Rate” and “Unbilled Fuel Revenue” (unbilled fuel revenue is required 
only if you had requested the “Show Deferred Fuel Expense” option on 
Hierarchy tab page for the jurisdiction).

Oracle Utilities Revenue Management calculates the Average Fuel Rate from existing revenue 
information within the revenue forecast using the following formula:

average fuel rate  = billed fuel revenue / billed kWh 

where billed fuel revenue is the sum of all revenues from factors with a UOM code of 
FUEL_ADJ, FUEL_ADJ_KW, BASE_FUEL_ADJ, or BASE_FUEL_ADJ_KW.

Note: You must supply values for “GRT” and “Fuel Cost.” Otherwise, Oracle Utilities Revenue 
Management uses the default values 1.00 for GRT and $0.00 for Fuel Cost. Oracle Utilities 
Revenue Management calculates Deferred Fuel Expense by summing any Unbilled Fuel 
Revenue for each business class within the selected jurisdiction and then subtracting any fuel 
costs (see below for a description of Unbilled Fuel Revenue for a business class).

You can, if desired, modify the results of the calculations using the adjustment cells. See How 
to edit values in a table using the adjustment cells: on page 4-9 for more information.

How to view unbilled revenue for a business class:

• In the Tree pane, highlight the icon for the business class of interest.

A spreadsheet-type table appears in the right pane.  This table displays components for both 
Unbilled Revenue and Unbilled Fuel Revenue for the selected business class.

Unbilled kWh is calculated by multiplying the Unbilled kWh for the parent Operating 
Company by the Unbilled kWh spread factor for the selected business class.  Average Rate is 
calculated by dividing Total Revenue by Billed kWh for the business class.  The Unbilled 
Revenue is then calculated by multiplying the Unbilled kWh for the business class by the 
Average Rate.

The Average Fuel Rate and GRT values are carried over from entries made on the Jurisdiction 
Table. Unbilled Fuel Revenue is then calculated by multiplying the Average Fuel Rate, GRT, 
and Unbilled kWh for the business class. You can edit the data using the adjustment cells as 
described on page 4 - 17.

See Chapter 5: Reports and Other Output for information about generating an unbilled 
revenue report.
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Saving the Forecast
You can save the inputs and results for future use. Select File-›Save or
File-›Save As. If you select Save, Oracle Utilities Revenue Management saves the information 
using the name you supplied on the Parameters tab page. If you select Save As, Oracle Utilities 
Revenue Management prompts you for a new name.
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Chapter 5
Reports and Other Output

This chapter explains how to create reports and output files from a revenue forecast, including:

• What Report Types are Available?

• Creating a Report

• Report Tools

• Corporate Model Output File

• Revenue Output Data File
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What Report Types are Available?
Oracle Utilities Revenue Management lets you print and save five types of forecast reports:

• Bill Determinants: Total number of customers and usage per each selected rate schedule in 
the hierarchy.

• Revenue Detail: Forecast revenue by block and factor.

• Revenue Summary: Base and total revenue.

• Revenue Comparison: Base and total revenue, and percentage difference between current 
forecast and prior year forecast.

• Unbilled Revenue: Unbilled revenue and unbilled fuel revenue.

Note
The Revenue Summary report, Revenue Comparison report, Bill Determinants report, and 
Unbilled Revenue report include revenue class totals listed by revenue class name in sorted ASCII 
order for each operating company.
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Creating a Report
The following pages explain how to create any of the five types of reports listed in the previous 
section.

How to create a report:

1. Select File-›Open-›[name of forecast] if the Revenue Forecast window for the desired 
forecast is not already open.

2. Go to the appropriate tab, depending upon the type of report you wish to create:

• Bill Determinants tab for the Bill Determinants report

• Unbilled Revenue tab for the Unbilled Revenue report

• Revenue tab for all other report types.

3. In the Tree Pane of the tab, highlight the entity for which you wish to generate the report. 
The entity can be at any one of the following levels: Operating Company, Jurisdiction, 
Business Class, or Rate Schedule (the exception is the Unbilled Revenue report, which applies 
to the first three entity levels—not rate schedule).

4. Select Revenue Forecast-›Reports-›[report type].

5. Complete the Revenue Forecast Report dialog that appears.

Date Range: Specify start and end month for the period you wish to report (must be the 
same as, or a subset of, the forecast year).

Report Level: These options limit the report for the selected entity to just the context of its 
parent entity. The specific options that are available depends upon the level of the entity that 
you selected. Deselecting some options makes others available.

Include Selected Unbundled Components: Select the components to include in the 
report. To select more than one component, hold down the Ctrl key and select additional 
items.

Scale: Choose one of the following options:

• Monthly: Report data for each month in the forecast period.

• Quarterly: Report data for each quarter in the forecast period.

• Annual: Report data for entire year.

6. (Optional) Complete the Report Options dialog. See Report Options on page 2-13 for more 
information.
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Report Tools
Oracle Utilities Revenue Management offers several useful features and tools for working with the 
reports. All require that the report be displayed on-screen. 

How to print the report:

• Select File-›Print.

A dialog box appears, giving you additional options for printing.

How to export the report in a text or CSV-format file:

• Select File-›Export.

A dialog appears. Specify a name and destination directory for the file. Then specify a file type 
in the Save as type box. If you specify .txt, you can open the file with Notepad or other text 
editor or word processor. If you specify .csv, you can load the data into a spreadsheet program 
for further analysis.

Note: in order for the Comma Separated Files .csv option to be available in the 
Save as type drop-down list, you must have checked the Keep Data (for CSV 
export) option described on the previous page.

How to search the report for desired text strings:

• Select Edit-›Find, then the text you want to find.

Be sure to keep in mind that the search is case-sensitive. To find the next instance of the text, 
select Edit-›Find Next. To find the previous instance of the text, select Edit-›Find 
Previous.
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Corporate Model Output File
The Corporate Model Output File contains data on the average rate at different levels of the 
hierarchy for a selected operating company. It has been designed for input to budgeting and other 
external programs. 

How to create the Corporate Model Output File: 

1. Select File-›Open-›[name of forecast] if the Revenue Forecast window for the desired 
forecast is not already open.

2. Go to the Revenue tab page.

3. In the Tree Pane, highlight the operating company of interest.

4. Select Revenue Forecast-›Corporate Model Output.

5. The Corporate Model Output dialog box appears.

Specify a date range, destination directory and file name, and click OK.
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Revenue Output Data File
The Revenue Output Data File contains one or more revenue line items for every business class in 
the selected node of the forecast hierarchy. The content of the revenue line items will be 
determined by a text-based control file that you can edit.

Each line in the file contains comma-separated values described below:

The revenue values for each month are formatted as thousands of dollars and scaled to three 
decimal places.

The control file is named REVDATA.TXT and is located in the C:\LODESTAR\CFG directory. 
It contains one line for each unique revenue item description that is required to appear in the 
output file. Each line in the control file consists of a keyword, an optional argument list in 
parentheses, an optional multiplier in square brackets, and a description in double quotes. All 
argument lists should be comma-separated.

The keyword, along with any arguments, is used to determine how revenue for the line item is 
calculated.  The resultant revenue is multiplied by the multiplier, if it exists.  The description is 
what will appear as the fourth value (Revenue Item Description) in each line of the output file.  
The valid keywords are described below.

• DETERMINANT (arglist): Specifies that the line item should contain revenue for all 
billing determinants listed in the required argument list by identifier.

• DETERMINANTUSAGE (arglist): Specifies that the line item should be usage data for 
the billing determinant listed in the required argument list by identifier. The data is 
represented in non-scaled usage units. Note that only a single argument is permitted.

• FACTORUOM (arglist): Specifies that the line item should contain revenue for all factors 
with the UOMs listed in the required argument list by code.

• BASEUNBUNDLED (arglist):  Specifies that the line item should contain base revenue 
for all unbundled components listed in the required argument list by name.

• TOTALUNBUNDLED (arglist):  Specifies that the line item should contain total revenue 
for all unbundled components listed in the required argument list by name.

• BASE:  Specifies that the line item should contain base revenue.

• TOTAL:  Specifies that the line item should contain total revenue.

For any keywords that require arguments, if a particular business class does not contain any data 
for the arguments listed, then the line will not appear in the output file for that business class.

Keywords are case-insensitive.  All identifiers, codes, and unbundled component names are, 
however, case-sensitive.  An example of a control file is shown below:

TOTAL “Total Revenue”
TOTALUNBUNDLED (CTC) “Unbundled CTC”
TOTALUNBUNDLED (Generation) “Unbundled Generation”
TOTALUNBUNDLED (Distribution) “Unbundled Distribution”
TOTALUNBUNDLED (Transmission) “Unbundled Transmission”

Value Code

First Value Operating Company Code

Second Value Jurisdiction Code

Third Value Business Class Code

Fourth Value Revenue Item Description

Additional Values Revenue Item Value for each month in report range
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DETERMINANT (KWH) [0.001] “MWH”
DETERMINANTUSAGE (KWH) [0.001] “Megawatt-hours”

How to create the Revenue Output Data File:

1. Select File-›Open-›[name of forecast] if the Revenue Forecast window for the desired 
forecast is not already open.

2. Go to the Revenue tab page.

3. In the Tree Pane, select the Operating Company, Jurisdiction, or Business Class to report on 
(all Operating Companies may also be selected).

4. Select Revenue Forecast-›Revenue Output Data File.

5. The Revenue Output Data File dialog box appears.

Specify a date range, destination directory and file name, and click OK.
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Unbilled Revenue Output File
The Unbilled Revenue Output File contains one or more unbilled revenue line items for every 
business class in the selected node of the forecast hierarchy. The content of the revenue line items 
will be determined by a text-based control file that you can edit.

Each line in the file contains comma-separated values described below:

The revenue values for each month are formatted as thousands of dollars and scaled to three 
decimal places. The revenue megawatt-hour values for each time period are formatted as 
megawatt-hour units scaled to three decimal places. The time period is either one month, one 
quarter, or one year and is specified in the Unbilled Revenue Output dialog (see below).

The control file is named UBDATA.TXT and is located in the C:\LODESTAR\CFG directory. It 
contains one line for each unique revenue item description that is required to appear in the output 
file. Each line in the control file consists of a keyword, an optional argument list in parentheses, an 
optional multiplier in square brackets, and a description in double quotes. All argument lists 
should be comma-separated.

The keyword, along with any arguments, is used to determine how revenue for the line item is 
calculated.  The resultant revenue is multiplied by the multiplier, if it exists.  The description is 
what will appear as the fourth value (Revenue Item Description) in each line of the output file.  
The valid keywords are described below.

• UNBILLEDMWH (arglist):  Specifies that the line item should contain unbilled megawatt-
hour data (in megawatt-hours).

• UNBILLEDREV (arglist):  Specifies that the line item should contain unbilled revenue (in 
thousands of dollars).

• UNBILLEDFUELREV (arglist):  Specifies that the line item should contain unbilled fuel 
revenue (in thousands of dollars).

• TOTALFUELREV (arglist):  Specifies that the line item should contain  total fuel revenue 
(in thousands of dollars).

For any keywords that require arguments, if a particular business class does not contain any data 
for the arguments listed, then the line will not appear in the output file for that business class.

Keywords are case-insensitive.  All identifiers, codes, and unbundled component names are, 
however, case-sensitive.  An example of a control file is shown below:

UNBILLEDMWH “Unbilled Megawatt-Hours”
UNBILLEDREV (CTC) “Unbilled Revenue (thousands)”
UNBILLEDFUELREV “Unbilled Fuel Revenue (thousands)”
TOTALFUELREV [0.001] “Total Revenue (millions)”

How to create the Unbilled Revenue Output File:

1. Select File-›Open-›[name of forecast] if the Revenue Forecast window for the desired 
forecast is not already open.

2. Go to the Unbilled Revenue tab page.

Value Code

First Value Operating Company Code

Second Value Jurisdiction Code

Third Value Business Class Code

Fourth Value Revenue Item Description

Additional Values Revenue Item Value for each month in report range
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3. In the Tree Pane, select the Operating Company, Jurisdiction, or Business Class to report on 
(all Operating Companies may also be selected).

4. Select Revenue Forecast-›Unbilled Revenue Output File.

5. The Revenue Output Data File dialog box appears.

Specify the scale, a date range, destination directory and file name, and click OK.
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