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PPrreeffaaccee  

This document provides step-by-step instructions to install the Oracle Financial Services 

Analytical Applications IFRS Pack 8.0.4.1.0 Interim Release. 

This chapter discusses the following topics: 

 Audience 

 How this Guide is organized 

 Recommended Environment 

 Related Documents 

 Conventions Used 

Audience  

The Oracle Financial Services Analytical Applications (OFSAA) IFRS pack Installation and 

Configuration Guide is intended for administrators and implementation consultants who are 

responsible for installing and maintaining the application pack components.  

The document assumes you have experience in installing Enterprise components. Basic 

knowledge about the OFSAA IFRS pack components, OFSAA Architecture, UNIX commands, 

Database concepts, and Web Server / Web Application Server is recommended. 

PPrreerreeqquuiissiitteess  ffoorr  tthhee  AAuuddiieennccee  

The document assumes that you have experience in installing Enterprise components and basic 

knowledge about the following is recommended.  

The following are the expected preparations from the administrator before starting the actual 

installation: 

 Oracle Financial Services Advanced Analytical Applications Infrastructure pack components 

 OFSAA Architecture 

 UNIX Commands 

 Database Concepts 

  Web Server/ Web Application Server  

How this Guide is Organized 

The Oracle Financial Services Analytical Applications (OFSAA) IFRS pack Installation and 

Configuration Guide includes the following topic: 

 OFS IFRS Release 8.0.4.1.0 
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RReeccoommmmeennddeedd  EEnnvviirroonnmmeenntt  

The infrastructure application has been tested with Microsoft Internet Explorer™ browser. For 

best viewing of Infrastructure pages, set the screen resolution to a minimum resolution of 1024 x 

768 pixels. 

RReellaatteedd  DDooccuummeennttss  

This section identifies additional documents related to OFS IFRS Infrastructure. You can access 

Oracle documentation online from Documentation Library OHC Documentation Library. 

 Oracle Financial Services Loan Loss Forecasting and Provisioning User Guide 

 Oracle Financial Services Hedge Management User Guide 

CCoonnvveennttiioonnss  aanndd  AAccrroonnyymmss  

Conventions Description 

Actions are indicated in Bold. 

Command or query is indicated in Courier New font. 

AIX Advanced Interactive eXecutive 

Atomic Schema Database schema where the application data model is uploaded. 

Config Schema Database schema which contains setup related configurations and metadata. 

DEFQ Data Entry Forms and Queries 

DML Data Manipulation Language 

EAR Enterprise Archive 

EJB Enterprise JavaBean 

ERM Enterprise Resource Management 

FTP File Transfer Protocol 

GUI Graphical User Interface 

HTTPS Hypertext Transfer Protocol Secure 

IR Interim Release 

J2C J2EE Connector 

J2EE Java 2 Enterprise Edition 

JDBC Java Database Connectivity 

http://docs.oracle.com/cd/E60529_01/homepage.htm
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Conventions Description 

JDK Java Development Kit 

JNDI Java Naming and Directory Interface 

JRE Java Runtime Environment 

JVM Java Virtual Machine 

ML Maintenance Level  

OFSAAI Oracle Financial Services Analytical Applications Infrastructure 

OFS AAAI Oracle Financial Services Advanced Analytical Applications Infrastructure 

Application Pack 

OHC Oracle Help Center 

RHEL Red Hat Enterprise Linux 
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11  OOFFSS  IIFFRRSS  PPaacckk  RReelleeaassee  88..00..44..11..00  

This Maintenance Level release (ML) of OFS Analytical Applications (OFSAA) IFRS is cumulative 

and includes all enhancements and bug fixes done since the OFS Analytical Applications 

(OFSAA) IFRS Application Pack v8.0 GA release. For more information, refer to the Oracle 

Financial Services IFRS Release 8.0.2.0.0 Installation Guide. 

11..11  PPrree  IInnssttaallllaattiioonn  RReeqquuiirreemmeennttss  

 The minimum patch set level should be 8.0.4.0.0. 

 If the Webserver used is WebLogic version 12.2.X or above, download and apply the 

patch 25343603 from the Patches & Updates tab in https://support.oracle.com/. 

 OFS IFRS Application pack v8.0.4.1.0 installer download contains only the ERwin XML file 

that is required for uploading the model. This file is sufficient to install the v8.0.4.1.0 

Application pack. However, this XML file cannot be opened in the ERwin Data modeler 

tool and hence cannot be used for any data model customization. ERwin file is delivered 

as a patch and needs to be downloaded separately. This ERwin file should be used for 

any customization of the data model. To download the Data Model Erwin file, log in to 

https://support.oracle.com/ and search for 26335451 under the Patches & Updates tab. If 

customization to the data model has been done in the environment being upgraded, then 

before uploading the same, customizations need to be applied again in the merged data 

model. 

11..22  HHooww  ttoo  aappppllyy  tthhiiss  ppaattcchh??  

11..22..11  IInnssttaalllliinngg  OOFFSS  IIFFRRSS  

Refer to the following instructions to download, extract, install, and configure this patch: 

1. Login to https://support.oracle.com/ and search for 26114116 under the Patches & 

Updates tab. 

2. Download the OFSAA 8.0.4.0.0 IFRS ML RELEASE #1 archive file and copy it to your 

OFSAA server in Binary mode. 

NOTE:  There are different archive files for different operating systems such as AIX, 

Solaris, and RHEL/OEL. 

3. Stop all the OFSAAI services. For more information, see the Start/Stop Infrastructure 

Services section in Oracle Financial Services International Financial Reporting 

Standards Pack Installation Guide Release 8.0.2.0.0. 

4. Login to the OFSAA server as a non-root user and navigate to the $FIC_HOME folder. 

http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
https://support.oracle.com/
https://support.oracle.com/
https://support.oracle.com/
http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
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5. Assign WRITE permission to the files/ folders such as common scripts, 

EXEWebService, ficapp, ficweb, and ficdb in the $FIC_HOME folder by executing the 

command: 

chmod -R 775 * 

6. If you have to Unzip utility, skip to the next step or download the Unzip utility (OS-

specific) and copy it in Binary mode to the directory that is included in your PATH 

variable, typically $HOME path or directory in which you have copied the 8.0.4.1.0 ML. 

 Uncompress the unzip installer file using the command: 

uncompress unzip_<os>.Z 

NOTE:  If you notice an error message “uncompress: not found [No such file or 

directory]” when the package is not installed, contact your UNIX 

administrator. 

7. Give EXECUTE permission to the utility using the command: 

chmod 751 unzip_<os> 

8. Extract the contents of the 8.0.4.1.0 ML archive file using either of the following 

commands: 

unzip_<os> -a <name of the file to be unzipped> 

OR 

unzip –a <name of the file to be unzipped> 

NOTE:  The above “-an” option is mandatory to unzip the archive file. 

9. Update the params.conf file present in the OFS_IFRS_PACK/OFS_IFRS/conf folder. 

The update instructions are present in this file itself. 

If you do not have permission to create a new folder for backup, then provide an 

alternate location as value for BACKUP_LOCATION tag in params.conf file, present in 

the OFS_IFRS_PACK folder. 

In case of customized datamodel upload, then update the params.conf file present in 

the OFS_IFRS_PACK/OFS_IFRS/conf/ folder accordingly. 

10. Give EXECUTE permission to the ML patch installer script. Navigate to the folder 

OFS_AAI and execute the command: 

chmod 755 OFSAAIUpdate.sh 

11. Execute the following command:  

./OFSAAIUpdate.sh 
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12. Verify if the ML is applied successfully by checking the log files generated in 

OFS_IFRS_PACK/OFS_IFRS/logs and OFS_IFRS_PACK/logs folders. You can ignore 

ORA-00001 and ORA-02292 in the log file. In case of any other errors, contact Oracle 

Support. 

13. Post successful installation of the ML, perform the following steps: 

 Clear the application cache. Navigate to the following path depending on the 

configured web application server and delete the files. 

o Tomcat: <Tomcat installation folder>/work/Catalina/localhost/<Application 

name>/org/apache/jsp 

o Weblogic: <Weblogic installation location>/domains/<Domain 

name>/servers/<Server name>/tmp/_WL_user/<Application name> 

o Websphere: <Websphere installation directory>/AppServer/profiles/<Profile 

name>/temp/<Node name>/server1/<Application name>/<.war file name> 

14. Delete the existing EAR/WAR file available in the folder $FIC_HOME/ficweb. 

15. Execute the file DeleteStrutsLibrary.sh present under FIC_HOME directory using the 

following command. You need to execute this only if the patch OFS IFRS 8.0.4.0.1 

(25769239) is NOT applied already. 

./DeleteStrutsLibrary.sh 

16. (Mandatory) Download and install the one-off patch 26590449 form the Patches & 

Updates tab of https://support.oracle.com/. For more information and installation 

instructions, refer to the Readme file attached within the patch. 

17. Generate the application EAR/WAR file and redeploy the application onto your 

configured web application server. For more information on generating and deploying 

the EAR/ WAR file, refer to the Post Installation Configuration section in Oracle 

Financial Services International Financial Reporting Standards Pack Installation Guide 

Release 8.0.2.0.0. 

18. Restart all the OFSAAI services. For more information, refer to the Start/Stop 

Infrastructure Services section in Oracle Financial Services International Financial 

Reporting Standards Pack Installation Guide Release 8.0.2.0.0. 

19. Install the one-off patch 25343603, if OFSAA is deployed on Oracle WebLogic Server 

version 12.2.x. Refer to the Readme available with the patch for further instructions on 

installing the patch. 

11..33  PPoosstt  IInnssttaallllaattiioonn  CCoonnffiigguurraattiioonnss  

 Download and install the mandatory patch 30092768, from My Oracle Support. See the 

Readme available with the patch for instructions on installing the patch. 

https://support.oracle.com/
https://support.oracle.com/
https://support.oracle.com/
http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
http://docs.oracle.com/cd/E60529_01/homepage.htm
https://support.oracle.com/
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 The default tasks present in the LLFP application are included in ECL and Stage runs to 

gather 100% table statistics. Based on the data volume, you need to optimize these tasks to 

gather statistics on the appropriate sample size. To do this, you need to modify the function 

fn_gather_stats in the atomic schema by passing the parameter estimate_percent to the 

GATHER_TABLE_STATS function call. 

 Download and install the one-off patch 26590449 form the Patches & Updates tab of 

https://support.oracle.com/. For more information and installation instructions, refer to the 

Readme file attached within the patch. 

 Install the security patch for OFS IFRS from the MOS Document 2308427.1. 

11..33..11  CCoonnffiigguurraattiioonnss  ffoorr  VVeerriiffyyiinngg  aanndd  EExxeeccuuttiinngg  PPDD  MMooddeell  

This configuration procedure is specific to OFS LLFP and is required only if you have a licensed 

OFSAAI Enterprise Modelling Framework. 

Once you license OFS AAAI, the following configurations must be made to use the PD Modelling 

feature in OFS LLFP application. These steps are required to verify and execute the PD model 

that is packaged with the LLFP application.  

NOTE:  Ensure that Oracle R Enterprise Server version 1.5 is installed on the database server 

and AAAI Runner Package is installed on the DB server before you perform these 

configurations. Also, you must access the application with the required privileges. 

1. Create a new schema with the following grants: 

grant create SESSION to <<schema_user>>; 

grant create PROCEDURE to <<schema_user>>; 

grant create SEQUENCE to <<schema_user>>; 

grant create TABLE to <<schema_user>>; 

grant create TRIGGER to <<schema_user>>; 

grant create VIEW to <<schema_user>>; 

grant create MATERIALIZED VIEW to <<schema_user>>; 

grant create SYNONYM to <<schema_user>>; 

2. Grant RQADMIN role to the Config schema user: 

GRANT RQADMIN TO <<config_schema>>; 

GRANT RQADMIN TO <<atomic_schema>>; 

GRANT RQADMIN TO <<pdmodel_schema>>; 

3. Create a new database from System Configuration menu. 

4. Add the TNS entry for the newly created database. 

5. Create a new Information Domain for Sandbox and create a new Segment. 

https://support.oracle.com/
https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=554284296491229&id=2308427.1
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6. Map the Sandbox Information Domain to the group LLFP Admin Group. 

7. Map the EMF groups to the LLFP admin user. 

8. Login to Config schema and execute the file ofs_llfp_aai_model_menu.sql. This file is 

present in $FIC_HOME/scripts_OFS_IFRS_8.0.6.1.0/config/insert folder. 

9. Log in as LLFP Admin user and create a Sandbox from the OFSAAI menu. Use the 

dataset IFRS ECL Consolidated for creating this Sandbox. 

10. Disable the FK constraint (FK_MF_MODEL_DS_QUERY_1) defined in the table 

MF_MODEL_DS_QUERY, in Config schema. 

11. Replace the place holders ##LLFPSBXINFODOM## and ##LLFPSANDBOX_ID## 

with Sandbox Information Domain name and Sandbox ID respectively, in the following 

tables of Config schema: 

 MF_MODEL_MASTER 

 MF_MODEL_SCRIPT_MASTER 

 MF_MODEL_DS_QUERY 

12. Enable the FK constraint FK_MF_MODEL_DS_QUERY_1, in Config schema. 

13. Update all the occurrences of the term “Timestamp” to “Date Time” in the following 

files, present in the folder ftpshare/<<SANDBOX_INFODOM>>/erwin/scripts/sandbox: 

 FSI_TRANSITION_MATRIX_MST.xml 

 FSI_PERIOD_TM_MAP_MST.xml 

 FSI_IFRS_ECON_SCENARIO_MST.xml 

Once these configurations are set, you can follow the OFSAAAI Installation Guide to view, 

execute, and deploy the model from Sandbox. For more information, see Oracle Financial 

Services Advanced Analytical Applications Infrastructure Application Pack Installation and 

Configuration Guide available in Oracle Help Centre Documentation Library.  

11..33..22  DDaattaa  TTrraannssffoorrmmaattiioonn  RReessaavvee  

This configuration procedure is specific to OFS HM. 

The valuation function - fair_value_transformation, for Level 3 contains only Level 1 and Level 

2 valuation codes and does not reflect the latest changes done to the function, concerning Level 

3.  

To reflect the changes for Level 3, update the fair_value_transformation function from the Post 

Load changes section of OFSAAI, by performing the following procedure: 

1. Navigate to Data Management Tools > Post Load Changes. 

The Post Load Changes section is displayed: 

http://docs.oracle.com/cd/E60058_01/homepage.htm
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2. Select the function fair_value_transformation form the LHS list. 

The details of the function are displayed in the RHS in Transformation Process Flow and 

Transformation Definition grids. 

3. Click  button. The Description field is enabled for editing. 

4. Click  button. 

The Parameter Definition, Stored Procedure Editor, and Business Process Flow grids are 

displayed. 

5. Click  button. The function is saved and a dialog box confirming the save 

operation is displayed. Click  button. 

11..33..33  CCrreeaattiinngg  GGlloobbaall  VVaarriiaabblleess  ffoorr  OOBBIIEEEE  

To create the global variables for OBIEE, in this release of IFRS application, perform the following 

procedure: 

1. Host the RPD and Catalog for LLFP solution as part of this release. 

2. Login into OBIEE/analytics using the application URL. 

3. Click the Analytics link. 
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4. Click and select the subject area as IFRS 9. 

 

5. The subject area details are displayed. 

Expand a folder and double click on any column from the subject area. 

Click the Edit formula menu item. 

 

6. Click the Variables tab and select the Global option from the menu. 
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7. Create a global variable with the following details: 

 Variable Name: denomination 

Value: case when '@{denomination}{in thousand}' = 'in thousand' then 1000 

else 1000000 end 

This variable is used to divide all amount values by thousand or million, 

depending on the selected criteria. 

 Variable Name: RSkey 

Value: case when "Run"."Run Execution Id" = '@{RunId}{1476270723292}' 

then "Run"."Run Skey" end 

 Variable Name: stage 

Value: "Previous IFRS9 Stages"."IFRS Stage Code" 

8. Refresh the materialized by executing the following queries: 

 EXECUTE 

DBMS_MVIEW.REFRESH(LIST=>'FCT_IFRS_STG_DETERMINATION_MV'); 

This refreshing of MV should be done when there is a change to the Stage 

Determination table. 

 EXECUTE 

DBMS_MVIEW.REFRESH(LIST=>'FCT_COLLECTIVE_ASSESSMENT_MV’); 

11..33..44  CCoonnffiigguurraattiioonnss  ttoo  DDeeppllooyy  tthhee  LLLLFFPP//HHMM  BBII  AApppplliiccaattiioonn  

The following are the steps to configure the LLFP/HM BI Analytics:  

Before you begin this process, ensure that Oracle Business Intelligence (Version 11.1.1.9.0) 

installation is completed and is available. 

1. Set the <Oracle BI Instance Home> directory. 

For example: /u01/OBIEE11G/instances/instance1 

2. Start WebLogic AdminServer.  

a. Set the <BI Domain Home> directory. 
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i. For Example: 

/u01/OBIEE11G/user_projects/domains/bifoundation_domain 

b. Navigate to <BI Domain Home >/bin and execute the following command: 

nohup ./startWebLogic.sh & 

NOTE:  Bringing up this service may take a few minutes depending on your 

environment. Check the logs using the command: 

tail –f nohup.out 

3. Start Node Manager.  

a. Set the < WebLogic Server Home > directory>.  

For example: /u01/OBIEE11G/wlserver_10.3 

b. Navigate to <WebLogic Server Home>/server/bin and execute the following 

command: 

nohup ./startNodeManager.sh & 

4. Start WebLogic Managed Server (bi_server1).  

a. Login onto http://localhost:7001/console using your Administrator credentials 

created during platform install (Replace the hostname based on your setup).  

b. Under the Environment tab, click the Servers link. 

 

The bi_server1 displays the shutdown state at this point. 
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c. Click the Control tab.  

d. Select the bi_server1 line by clicking on the left tick box.  

e. Click the Start button at the top of the list and confirm starting this service. 

 

f. The state will update to the “RUNNING” mode after a few minutes. 

5. Start OBIEE services and login  

a. Starting services From EM screen: 

i. Log in to the EM administration screen using the URL: http://localhost:7001/em 

(Replace the hostname and port number based on your setup). Use the login 

you created in the OBIEE installation to log in.  

ii. Expand the 'Business Intelligence' node on the left and choose the Core 

application.  

 

iii. Click the Overview Tab. 
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iv. Click Restart (or Start) under the Manage System section.  

v. Click Yes on the dialog box to confirm the action. Wait for a message that 

confirms the successful restart. 

b. If the start process using EM is not successful and returning an error about 

OPMNCTL not up, follow the starting process with OPMNCTL.  

i. Open a command prompt, navigate to <Oracle BI Instance Home>/bin.  

ii. Execute the command ./opmnctl status. This displays the status of all the 

OBIEE core services  

iii. Execute the command ./opmnctl startall or ./opmnctl stopall depending on 

your requirement. 

6. Deploy RPD and web catalog file(s).  

a. Navigate to folder $FIC_HOME/LLFP_DASHBOARDS// which contains LLFP.rpd 

file and $FIC_HOME/LLFP_DASHBOARDS// which contains LLFP.catalog file.  

i. Login to OBIEE – Enterprise Manager URL (http://<ip address>:<port>/em).  

ii. Click on core application from the Business Intelligence tab on the left-hand 

side.  

iii. Under core application, select the Deployment tab and click the Lock and 

Edit Configuration button located below the title core application. The 

following screen is displayed: 
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iv. RPD Deployment: Select the Browse button available under the Upload BI 

Server Repository section and select the LLFP.rpd file from the local folder. 

Enter the Repository password ‘Administrator1’.  

v. Web catalog Deployment:  

 Create a new web catalog folder for the LLFPBI application through the 

Enterprise Manager of OBIEE. 

 Set the Catalog Location available under ‘BI Presentation Catalog’ as 

$ORACLE_INSTANCE/bifoundation/OracleBIPresentationServicesComp

onent/$COM PONENT_NAME/catalog/LLFPBI.  

 Click Apply and then click Activate changes. The following pop up is 

displayed after successful activation.  

 

 Click the Close button and switch to the Capacity management tab.  

 Restart the presentation services. Under the System Components 

Availability, select Presentation Services and click on Restart Selected 

option.  
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vi. Once the Presentation Service is restarted, it displays the pop up notifying the 

successful restart. Click Close.  

vii. Verify that the new folder structure is created in the system. It can be found 

under path: <Oracle BI Instance Home> 

\bifoundation\OracleBIPresentationServicesComponent\coreapplication_obips1

\catalog\LLFPBI 

viii. This LLFPBI folder will be having a root folder which in turn contains three 

folders named shared, system, and users. 

 

b. Open the Catalog Manager  

i. Navigate to File menu and open the catalog online (File->Open catalog) by 

giving the necessary credentials based on your setup (Type - (online), URL - 

(http://<ipaddress>:<port>/analytics/saw.dll).  

ii. Once the catalog is opened, it displays a folder structure on the left-hand side. 

Select the shared folder in the LHS tree structure.  

iii. Go to the ‘File’ menu and select ‘Unarchive’. It asks for the path for a file.  

iv. Browse the path of the archived catalog file saved in your local folder using the 

Browse button in the pop-up. Click OK.  

v. The catalog is unarchived in a specified location. A pop up for successful 

operation is displayed. Restart the presentation services once again.  

c. Open the analytics OBIEE URL- (http://<ipaddress>:<port>/analytics) and login with 

credentials based on your setup. Verify the availability of the catalog. 
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7. Configure tnsnames.ora.  

a. Open tnsnames.ora file under the folder - <Oracle Home>/network/admin.  

b. Make sure that an entry is made in the tnsnames.ora to connect to the atomic 

schema of the OFSAA application.  

c. Save the tnsnames.ora file.  

8. Configure the ODBC data source to connect to Oracle BI Server.  

a. Navigate to Control Panel>Administrative Tools>Data Sources (ODBC).  

b. Select the System DSN tab and click the Add button.  

c. Select a driver-specific to (Oracle BI Server 11g) and click the Finish button.  

d. Enter Name and Server details (specify the Host Name or IP Address of the BI 

Server) and click Next.  

e. Enter Oracle BI Server login id and password (Enter User Name and Password 

created at the time of OBIEE installation). Click Next.  

f. Click Finish.  

9. Modify the connection pool and set the properties.  

a. Open the OBI Administration tool.  

b. Select Start > Programs > Oracle Business Intelligence > BI Administration.  

c. Select File > Open > Online and select LLFP.rpd file. 

d. In the Open dialog box, select and open LLFP.rpd file. 

e. Enter the Repository password as ‘Administrator1’.  

f. In the Physical layer, double-click the Connect Pool. The properties of 

Connection Pool LLFP is displayed. 

g. In the General tab, edit / check the following entries:  

i. Call Interface: (OCI 10g/11g).  

ii. Data source name: <tnsnames.ora entry created in the step 8.b connecting to 

OFSAA atomic schema>.  

iii. User name: <enter atomic db user name>.  

iv. Password: <enter atomic db user password>.  

v. Confirm password and Click OK to close the window.  

vi. Similarly, configure the connection pools for ‘LLFPBI’. 
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NOTE:  Repeat similar steps from (g) above for connection pool 'Connection 

Pool MR' under Database 'Market Risk'.  

vii. Click Save to save the RPD file.  

viii. Click No for the Global Consistency Message.  

ix. Close the RPD file (File / Exit).  

10. Login into LLFP/HM BI Application using the URL: http://localhost:<port 

number>/analytics.(Replace the port number based on your setup). 

11..33..55  EEnnaabbllee  MMuullttiippllee  EECCLL  RRuunnss  iinn  EECCLL  DDaasshhbbooaarrdd  

Perform the following procedure to enable Multiple ECL Runs in ECL Dashboard: 

1. Go to EDIT mode in ECL Dashboard. 

2. Select Prompt - Run Details link and go to EDIT mode. 

3. Click the Options tab, General tab, select the dropdown for Choice List Values. 

4. Select SQL Results. 

5. Enter an SQL query to modify the filter of Run ID selection. For example:  

SELECT "Run"."Run Description" FROM "IFRS 9" WHERE "Run"."Run 

Type"=2 FETCH FIRST 65001 ROWS ONLY 

6. Save the settings. 
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