1.2.6 Oracle Linux 6 Update 8 Fails to Run yum Commands After Registration

Registration of an Oracle Linux 6 Update 8 server succeeds with the built-in packages, but subsequent yum commands fail with the error: "KeyError: 'X-RHN-Auth-Expiration’”.

Installing the full Spacewalk 2.7 client for Oracle Linux 6 resolves this problem and should be done prior to registration. Follow the steps in Installing the Spacewalk Client Software and Registering a Client System by Using the rhnreg_ks Command.