3.5 Installing the Oracle-Supported OFED Packages

This section describes how to install the OFED packages provided by Oracle, including how to remove any existing OFED packages.

To install the OFED packages provided by Oracle:

  1. If your system is registered with ULN, subscribe the system to the ol6_x86_64_UEKR4_OFED or ol7_x86_64_UEKR4_OFED channel on ULN as appropriate.

    If you want to install the packages from Oracle Linux Yum Server:

    1. Move the existing yum repository file to a backup file, for example:

      # mv /etc/yum.repos.d/public-yum-olN.repo /etc/yum.repos.d/public-yum-olN.repo.bck
    2. Download the latest yum repository file for Oracle Linux 6 or Oracle Linux 7 from Oracle Linux yum server.

      # wget -O /etc/yum.repos.d/public-yum-olN.repo https://yum.oracle.com/public-yum-olN.repo
    3. Edit the downloaded yum repository file and enable the ol6_UEKR4_OFED or ol7_UEKR4_OFED repository as appropriate.

  2. Remove any existing OFED packages.

    # yum remove 'ibacm*'
    # yum remove 'ib-bonding*'
    # yum remove 'ibutils*'
    # yum remove 'infiniband-diags*'
    # yum remove 'libibcm*'
    # yum remove 'libibmad*'
    # yum remove 'libibumad*'
    # yum remove 'libibverbs*'
    # yum remove 'libmlx4*'
    # yum remove 'librdmacm*'
    # yum remove 'libsdp*'
    # yum remove 'mstflint*'
    # yum remove 'ofed-docs*'
    # yum remove 'ofed-scripts*'
    # yum remove 'opensm*'
    # yum remove 'perftest*'
    # yum remove 'qperf*'
    # yum remove 'sdpnetstat*'
    # yum remove 'rdma-*'
    # yum remove 'rds-tools*'
  3. Clean all yum cached files from all enabled repositories.

    # yum clean all
  4. Install the OFED packages for UEK R4.

    # yum install oracle-ofed-release
  5. If the SDP feature is required, install the libsdp package.

    # yum install libsdp
  6. Enable the RDMA service by entering the following command:

    # chkconfig rdma on
Note

Each UEK release requires a different set of OFED packages. If you change the kernel on your system to a UEK release other than UEK R4, use the following command to remove the existing UEK R4-based OFED packages before installing the correct packages for the new kernel:

# yum remove --setopt=clean_requirements_on_remove=1 oracle-ofed-release