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DESIGN TIME REPORTING

The IBRM database is the repository for content created in RateManager. Data is stored in a
proprietary format. A design time reporting feature is available for the IBRM database that allows
for access to the IBRM data in a relational data structure and format that can be used for
reporting. The data can be extracted and evaluated by a third party reporting tool.

The Insbridge Reporting Doc zip file contains detailed documentation that describes what data is
available, the relationships of all data elements, how to access the data, and a sample report that
can be created using the available data.

Requirements for design time reporting are database server name or IP address, database user
name and password. Read only permissions are required to create a connection to the design
time reporting feature. Contact your system administrator to request the information.

To access the design time reporting feature, a third party tool, such as Microsoft Excel, can be
used to create a connection to the IBRM database and download data.

Insbridge User Reporting Schema

The Insbridge User Reporting Schema offers a reporting view into the Insbridge RateManager
(IBRM) database.

This data is available to any standard SQL Server Database reporting software. Please contact
your IT department for your reporting options.
Reporting View Categories
Program Explorer Reporting Views
Universals Reporting Views
GlobalsReporting Views
Locals Reporting Views
Summary Reporting Views

General Reporting Views

Table Variable Data Views

See the Insbridge Reporting Doc zip for more information.
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Setting Up

A Reporting script must be run from within the RateManager application. Running db update
scripts requires admin permissions.

On the DB Updates screen, the current version is highlighted and the status is Current. The
updates below the current version are grayed out. These updates cannot be run again. Current
updates can be re-run if necessary. You will receive an error message if you attempt to run a
lower version update. Any version update above the current version is also grayed out but will be
available for executing.

New installations may show the latest version as current but still have only the Tools option
available. You may have to run the current script again. To see if you have complete access, click
File>Reload to refresh the system.
Navigate to the Tools->Database->Updates.
1. The Updates tab is displayed. Select the database you want to view from the Show
updates for drop down. The database updates for your selection is listed. The last
column, the Status column, shows you which update is the Current one installed.

2. For safety, run or rerun the IBRM and IB_CLIENT scripts before running the Reporting
script.

3. Run the reporting script. The Reporting script must be run last.

ORACLE" Insurance Insbridge RateManager
Fle Modules Tools  Help
Home (3} DB Updates X
|3 DB Updates

J:’D Execute Update Script JB Open Update Script - Save Update Script to File G@ Refresh

Show updates fOlH REPORTING v

Script Release Date ' Database Status |
v05.06.00.00 12/1/2017 IBRM

4. Click File->Reload to refresh the system.
5. Return to the Tools menu and Open Setup—>Reporting Data Model
6. Click the Update Reporting Views.

This option updates the algorithm steps in the Reporting Data Model. This option only needs to
be run once. After it has been run, the data should be in sync.
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Insbridge Reporting Doc zip

7.

Download the Insbridge Reporting Doc zip from the documentation download on Oracle
Cloud delivery or the Oracle Technical Network. Extract to a location on your local

machine.

Open the file and locate the Index.html file.

19 items

Home

-

Share View

r « Products > Insbridge > Reports > InsbridgeReportingDoc > InsbridgeReportingDoc5 »

Marketing
Naming_Conventions
Oracle_DB
Pet Insurance
Programs
Reports
Global Versioning
1A
InsbridgeReportingDoc
InsbridgeReportingDoc5
Previous
« InsbridgeReportingDoc5.zip
Program Version Reports
SRP Difference
RNG
Roadmaps
Security
Testing Files

1item selected 567 bytes

2 = | InsbridgeReportingDoc5

~

- O

v O Search InsbridgeReportingDoc5
[0 Name ® Date modified Type Size

businessinfo 11/28/2017 12: File folder
datatypes /2 File folder
domains File folder
logical File folder
mapping File folder
pm File folder
rdbms File folder
rel File folder
table File folder
table - Copy File folder

,;l ChangeRequests.local LOCAL File 1KB

| dbdoc.css Cascading Style S... 3KB

@ dbdocjs JavaScript File 12KB

=] dl_settings.xml XML Document 19KB

[7] dmd_open.local LOCAL File 1KB

[2] empty.html HTML File 1KB

I 2] indexhtml HTML File 1KB

2] nodelypes.html HTML File TKB

&) round_text.png PNG File 1KB

X

¥l

9. Right click and Open with Internet Explorer.

10. This opens the Insbridge Reporting Details screen.




Design Time Reporting

The left side of the Insbridge Reporting Doc lists the available views.

B3 DpiProducts\insbridge\f X+ E——

é = O I file:///D:/Prod!

Insbridge Runtime Reporting

dexhtml

sbridge/Rep

sbridgeReportingDoc/Insbrid

Insbridge Reporting Views Data Model

Views A PDF of of the Insbridge reporting views data model.

= = The Reporting Views data model gives access to data created by the Insbridge Design Process.
Filter Reporting Views by:

Reporting Views Data Model
DOMAIN TYPES

DOMAINS

PROJECTS

PRODUCTS

PROGRAM FOLDERS
PROGRAMS

PROGRAM VERSIONS

NOTES

CATEGORIES

INSTRUCTIONS

ALL TABLE VARS

ALL TABLE QUALIFIERS

TABLE VAR VIEWS

UNIVERSAL ALGORITHMS
UNIVERSAL CALCULATED VARS
UNIVERSAL CONSTANTS
UNIVERSAL FIELD VARS
UNIVERSAL FILTER RULES
UNIVERSAL REPORT MASTER
UNIVERSAL RESULTS
UNIVERSAL TABLE VARS
UNIVERSAL TABLE VARS ACTIVE USED
GLOBAL ALGORITHMS

GLOBAL CALCULATED VARS
GLOBAL CONSTANTS

GLOBAL DRIVER ASSIGNMENT
GLOBAL FIELD VARS

GLOBAL FILTER RULES
GLOBAL REPORT MASTER
GLOBAL RESULTS

GLOBAL TABLE VARS

GLOBAL VERSIONING DATA
GLOBAL VERSIONING QUALIFIERS
GLOBAL TABLE VARS ACTIVE USED
LOCAL ALGORITHMS

LOCAL CAICULATED VARS
LOCAL DRIVER ASSIGNMENT

11. The left side is the views you can select. Click a view to see what details that are
presented.
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The right side is the naming convention for the view.

In this example, Universal Algorithms was selected. On the right is a listing of columns and

column details.

E3 DaProducts\insbridge\f X 4

¢« > 0

Views

Insbridge Runtime Reporting

UNIVERSAL_ALGORITHMS

Algorithms entered in the Insbridge application.

Filter Reporting Views by:

Reporting Views Data Model
DOMAIN TYPES

DOMAINS

PROJECTS

PRODUCTS

PROGRAM FOLDERS
PROGRAMS

PROGRAM VERSIONS
NOTES

CATEGORIES
INSTRUCTIONS

ALL TABLE VARS

ALL TABLE QUALIFIERS
bt

UNIVERSAL CONSTANTS
UNIVERSAL FIELD VARS
UNIVERSAL FILTER RULES
UNIVERSAL REPORT MASTER
UNIVERSAL RESULTS

UNIVERSAL TABLE VARS
UNIVERSAL TABLE VARS ACTIVE USED
GLOBAL ALGORITHMS

GLOBAL CALCULATED VARS
GLOBAL CONSTANTS

GLOBAL DRIVER ASSIGNMENT
GLOBAL FIELD VARS

GLOBAL FILTER RULES

GLOBAL REPORT MASTER
GLOBAL RESULTS

GLOBAL TABLE VARS

GLOBAL VERSIONING DATA
GLOBAL VERSIONING QUALIFIERS
GLOBAL TABLE VARS ACTIVE USED
LOCAL ALGORITHMS

LOCAL CALCULATED VARS

LOCAL DRIVER ASSIGNMENT

| Columns |

COLUMN NAME DATA TYPE
DOMAIN_TYPE_ID INTEGER
DOMAIN_TYPE_NAME INVARCHAR(S0)
DOMAIN_ID INTEGER
DOMAIN_NAME NVARCHAR(50)
PROJECT_ID INTEGER
PROJECT_NAME NVARCHAR(S0)
PRI_MODEL_ID INTEGER
PRJ_MODEL_VER INTEGER
CATEGORY_ID INTEGER
CATEGORY_NAME NVARCHAR(S0)
ALGORITHM_ID INTEGER
ALGORITHM_VERSION INTEGER
INSTRUCTION_GRP_TYPE_NAME  NVARCHAR(75)
ALGORITHM_NAME INVARCHAR(S0)
SUB_TYPE INTEGER
DATE_LAST_MODIFIED SMALLDATETIME

NULLABLE
Yes

Yes

No

Yes

DATA DEFAULT
null
null
null
null
null
null
null
null
nuil
null
null
null
null
null
null
null

Copyright © 2015, Oracle and/or its affiliates. All rights reserved.

COLUMN ID

COMMENTS
A unique identifier indicating the Domain Type
The Domain Type Name
A unique identifier indicating the Domain
‘The Domain Name
A unique identifier indicating the Project
The Project Name.
A unique identifier indicating the Project Model
The Project Model Version
A unique identifier indicating the Category
The Category Name
A unique identifier indicating the Algorithm
The Algorithm Version
The Instruction Grp Type Name
The Algorithm Name
The Sub Type
‘The Date Last Modified

12. You can leave this screen open while you work with the data. It is a good reference.

13. Close the screen when you are finished.
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Setting Up a Connection to SQL Server Example

Setting up a connection to SQL Server requires a database name or IP address, a database user
ID and password. Read only permissions are required to create a connection to the design time
reporting feature. Contact your system administrator to obtain this information. In this example, a
database user dbReportsReader is used.

1. In Excel, select the Data tab.

2. Inthe Get External Data section, select From Other Sources.

3. Select From SQL Server.

s 2
a5

Home Insert Page Layout Formulas Review View

Ij‘% D [‘;1 D D F 7 Show Queries W‘b, Connections
@ S El .¢. = m From Table ot Properties
From From From [From Other Existing New Refresh
Access Web Text | Sources~ | Connections Query~ [ Recent Sources All~ o Edit Links
GetBq — ~ From SQL Server
Create a connection to a SQL Server table. Import data into Excel as a
Al N = Table or PivotTable report.
B From Analysis Services
Create a connection to a SQL Server Analysis Services cube. Import data
_ into Excel as a Table or PivotTable report.
A B T From OData Data Feed
. I == Create a cgnnection to an OData Data Feed, Import data into Excel as a
] e Table or PivotTable report.
= B From XML Data Import
3 = Open or map a XML file into Excel.
4 ==
5 B From Data Connection Wizard
6 3 Import data for an unlisted format by using the Data Connection Wizard
- T and OLEDB.
L I From Microsoft Query
8 Import data for an unlisted format by using the Microsoft Query Wizard
g 4 and ODBC, Functionality is limited for compatibility in previous versions.
in

4. Enter the server name and your database credentials. You must have at least read-only
access. If you do not have this information, ask your system administrator.
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Data Connection Wizard

Connect to Database Server

Enter the information required to connect to the database server.

1. Server name: | RMDatabase

2. Log on credentials

(0 Use Windows Authentication
(@ Use the following User Name and Password

User Name: ;arﬁﬁepor’t’;ﬁeiader \
(

Password: (eeeseseee ‘

K

Cancel < Back \ Finish

5. Click Next.

Data Connection Wizard

Select Database and Table

Select the Database and Table/Cube which contains the data you want.

Select the database that contains the data you want:

‘master

IBRM Alamere A
IBSR_184_LNX
IBSR_184_WIN

¥

IBSR_407_WIN
IBSR_559_LNX Type
IBSR_Al v

<

Import relationships between selected tables

Cancel < Back Next->
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6. Select the IBRM database. Be aware that all available tables are listed. You may have to
scroll to see the RM database.

7. Select Connect to a specific table and click Next.

Data Connection Wizard ? X
Select Database and Table
Select the Database and Table/Cube which contains the data you want.
Select the database that contains the data you want:

IBRM_Alamere v

Connect to a specific table:
D Enable selection of multiple tables

Name Owner De ™
ALL_TABLE_QUALIFIERS [REPORTING|

REPORTING

CATEGORIES REPORTING

DOMAIN_TYPES REPORTING

DOMAINS REPORTING

GLOBAL_ALGORITHMS REPORTING

GLOBAL CALCULATED VARS REPORTING | v
< >

Import relationships between selected tables

Cancel || <Back ’ Finish

A

8. Select the table that contains the data that you want to view. The Owner must be
REPORTING. These are the design time reporting views available.

9. Clicking Next allows for the connection to be saved.
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Data Connection Wizard ? X

Save Data Connection File and Finish D

Enter a name and description for your new Data Connection file, and press Finish
to save.

File Name:
RMDatabase IBRM_Alamere ALL_TABLE_VARS.odc Browse...

[[] save password in file
Description:
(To help others understand what your data connection points to)

Friendly Name:

RMDatabase IBRM_Alamere ALL_TABLE_VARS

E] Always attempt to use this file to refresh data

Excel Services: | Authentication Settings...

Cancel < Back eyt ‘ Finish

10. The friendly name can be updated. Click Finish to download the data to your local
machine.

11. Select how you want to view the data.

Import Data ? X

Select how you want to view this data in your workbook.

7] (@ Table
(O PivotTable Report
15 O PivotChart
[‘ O Only Create Connection
Where do you want to put the data?
(® Existing worksheet:
=sAs1| ||
(O New worksheet
|:| Add this data to the Data Model

Properties... Cancel

12. The data is presented in the spreadsheet. This data can be shared and manipulated as
needed. Algorithms have steps presented in a readable format.

10
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%
Home  Insert  Pagelayout  Formulas  Data  Review
Table Name: [i] Summarize with PivotTable ’—\ [‘1 [=] Properties V| Header Row First Column I Filter Button «
o Ee===
Table RMDatabs £-f Remove Duplicates e EXZ pee [ Open in Browser Total Row Last Column -
B Resize Table 52 Convert to Range [ - €3 Unlink /| Banded Rows || Banded Columns. == S
Properties Tools External Table Data Table Style Options Table Styles -~

Al v f || TABLE_VAR_TYPE -
2 |UNIVERSAL 0 RateManager 1 Alamere 2 Commercial 1 0 N/A 0 N/A

3 |UNIVERSAL 0 RateManager 1 Alamere 2 Commercial 1 0 N/A 0 N/A

4 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

5 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

6 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0N/A 0 N/A

7 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

8 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

9 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

10 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

11 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

12 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

13 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

14 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

15 [UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

16 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

17 [UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

18 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

19 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

20 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

21 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

22 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

23 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

24 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

25 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

26 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

27 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

28 |UNIVERSAL 0 RateManager 1 Alamere 3 personal 1 0 N/A 0 N/A

29 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

30 |UNIVERSAL 0 RateManager 1 Alamere 3 Personal 1 0 N/A 0 N/A

1 [UNIVERSAL 0 1 Alamere 3 Personal 1 ON/A ON/A =

Sheet1 @ < >

Ready i E & 1 + 100%

13. If you click Finish on the Select Database and table, the data is downloaded immediately
but the connection will not be saved.

For more information regarding the columns and information presented, please see the Insbridge
Reporting Doc zip.

If you saved your connection, you can access the table at a later time by clicking the Existing
Connections under Get External Data.

11
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Accessing a Saved Connections

A saved connection saves the database information. The data presented is the latest data.

1. A saved connection can be found in the Get External Data section, select Existing
Connections.

Home Insert Page Layout Formulas Review View Q Tell me what you want to do...

‘ = [5]Show Queries WA (=] Connections & H S, ¢ v = —/
3 P e 2l AlZ = E]E = Bl —
@ & El -¢ Ej D From Table & [:z] Properties ll eapply ="
From From From From Other New resh Zl Sort Filter Textto Flash Remove Data
Access Web Text Sources~ | Connections| Query~ (% Recent Sources g1~ Edit Links Y Advanced  Columns  Fill Duplicates Validation
Get External Data Get & Transform Connections Sort & Filter Data Tools
Al ¥ Fx
Existing Connections ? X
A B | ¢ D E E | 6 | H L
1 I Select a Connection or Table
| ]
2 | Connections  Tables
3 -
4 | Show: | Al Connections v
5 | Connections in this Workbook
6 1 <No connections found >
7 | VT g
i Connection files on the Network
5 —i <No connections found >
10| Connection files on this computer
T 1’] RMDatabase GLOBAL_TABLE_VARS_ACTIVE_USED
- -7 [Blank]
127! L RMDatabase IBRM_Alamere ALL_TABLE VARS
1 3| gE [Blank]
14| [j!s, RMDatabase IBRM_Alamere UNIVERSAL_ALGORITHMS
15 T Biank
16 |
17
18|
19|
20|
21| :
22 | Browse for More... Open Cancel
2|

2. Select the connection you want.
3. Select the presentation format.

4. You may be required to log in again.

SQL Server Login X
Server: IRMDatabase _v_J
™ Use Trusted Connection Cancel |
Login ID: Isa Help
Password: I“““"l Options >>

5. Datais presented and can be manipulated and saved.

12
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Permissions Error

If you do not have the proper permissions, an error message is presented.

Microsoft Office Excel lﬂ

[DBMETLIE] [ConnectionOpen (Connect()).]5QL Server does not exist or access denied.

13
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Contacting Support

If you need assistance with an Oracle Insurance Insbridge Enterprise Rating System product,
please log a Service Request using My Oracle Support at https://support.oracle.com/.

Oracle customers have access to electronic support through My Oracle Support. For information,
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Address any additional inquiries to:

Oracle Corporation
World Headquarters
500 Oracle Parkway
BeSdVAVOOd Shores, CA 94065

Worldwide Inquiries:
Phone: +1.650.506.7000
Fax: +1.650.506.7200
oracle.com

14
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