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Introduction

The BEA JRockit Memory Leak Detector detects memory leaks within Java applications that run
on BEA JRockit. A memory leak means application code is holding on to memory that is not used
by the application any more. The BEA JRockit Memory Leak Detector is a real-time profiling
tool that gives information about what type of objects are allocated, how many, of what size, and
how they relate to each other. Unlike other similar tools, there is no need to create full heap dumps
that you need to analyze at a later stage. The data presented is fetched directly from the running
JVM, which can continue to run with a relatively small overhead. When the analysis is done, the
tool can be disconnected and the JVM will run at full speed again. This makes the tool viable for
use in a production environment.

The purpose of this tool is to display memory leaking object types (that is, classes) and provide
help to track the source of the problem. Another purpose of this tool is to help increase the
understanding and knowledge to avoid similar programming errors in future projects.

The following subjects are covered in this section:
e What is New in the BEA JRockit Memory Leak Detector
e The BEA JRockit Memory Leak Detector Overhead
e About this User Guide

e Finding Additional Information
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Introduction

What is New in the BEA JRockit Memory Leak Detector

e For JRockit releases R26.2 and later, you can also connect the BEA JRockit Memory Leak
Detector to 1.4.2 JRockits by using the RMP protocol.

e The BEA JRockit Memory Leak Detector is now part of the JRockit Mission Control
version 1.0. That means that you now need a license to run the tool.

Please see the Release Notes for more information.

JRockit Mission Control License Information

The following license types are currently available:

e Developer License—The Developer License is free and allows JRockit to run the tools for
one hour.

e Enterprise License—The Enterprise License allows unlimited use of the tools. It is bound
to an IP address.

To download the license you need, please visit:

http://dev2dev.bea.com/jrockit/tools.html

The BEA JRockit Memory Leak Detector Overhead

The extra cost of running the BEA JRockit Memory Leak Detector against a running BEA
JRockit is very small and is noticeable only in that garbage collections take a little bit more time.
The overhead of enabling allocation stack traces can be more significant and should therefore be
used with care. This provides for a low cost monitoring and profiling of your application.

About this User Guide

In this document you will be guided through how you can spot a memory leak in your Java
application. You will also get hints on how to repair a memory leak. This user guide assumes that
you know what a JVM is and that you are familiar with Java application development.
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Finding Additional Information

Finding Additional Information

You can find additional information about BEA JRockit throughout the BEA JRockit
documentation set. For a complete list of available documents, please refer to the BEA JRockit
JDK Online Documentation.
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CHAPTERa

Getting Started with Memory Leak
Detection

This section describes the BEA JRockit Memory Leak Detector (from now on referred to as
Memory Leak Detector) start-up procedure and the user interface. Information on the following
topics are included:

e Overview of the Memory Leak Detection Process
e Starting the Memory Leak Detector

e Touring the Memory Leak Detector Interface

Overview of the Memory Leak Detection Process

The memory leak detection process consists of three phases:
1. Trend analysis
2. Object type relations study

3. Instance investigation

Trend analysis means to observe continuously updated object type related information and try
to discover object types with suspicious memory growth. These object types should then be
studied in the next phase of the memory leak detection process. The information in the trend
analysis table is updated every ten seconds or more often if there are very frequent garbage
collections.

Studying object type relations means following reference paths between object types. The goal
is to find interesting connections between growing object types and what types of objects point
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Getting Started with Memory Leak Detection

to them. Finding the object type guilty of unusual memory growth will lead to the third and final
phase of the memory leak detection process.

Instance investigation consists of finding an instance of abnormal memory size or an abnormal
amount of references being held and then inspecting that instance. When inspecting an instance,
values will be displayed; e.g. field names, field types, and field values. These values will
hopefully lead you to the correct place for the error in the application code; i.e. where that
particular instance of that particular object type is allocated, modified, or removed from the
collection, depending upon what the situation implies. Minimizing the problem areas of the ones
connected to the suspected instance will most likely lead you on the right track to finding the
actual problem causing the memory leak and you will be able to fix it.

Starting the Memory Leak Detector

2-2

Before you start the Memory Leak Detector and your application, you need to start the
management server.

1. Start your Java application with the BEA JRockit JVM as usual, but add the -Xmanagement
option to the command line.

2. Start the Memory Leak Detector by typing memleak in a command window.
The Connect to JRockit window appears.

3. Enter a name for the server in Server name. This is the name (or IP address) of the computer
that runs JRockit and the application that you want to monitor.

4. Enter a port number in Port.

For information on ports, see the User Guides for the Management Console:
http://edocs.bea.com/jrockit/tools/usingjmc/start.html#1035010 (for JRockit 5.0)
http://edocs.bea.com/jrockit/tools/usingjmc142/mancons.html#1001904 (for JRockit 1.4.2)

5. Click Connect.

The Memory Leak Detector window opens (see Figure 2-1).

JMX Authentication

There are two system properties that can be set to enable authentication:

e memleak. jmx.username

e memleak. jmx.password
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To enable the authentication, you need to set these properties when launching the Memory Leak
Detector by typing, for example:

Jjava -Dmemleak.jmx.username=<username> -Dmemleak.jmx.username=<password>
-jar <path to MemorylLeakDetector.jar>

If you are using the memleak launcher in the \bin catalog, the command can, for example, look
like this:

-J-Dmemleak. jmx.username=<password>

Touring the Memory Leak Detector Interface

When it is not connected to any BEA JRockit JVM, the Memory Leak Detector window looks
like Figure 2-1. The interface consists of four tabs, a tool bar, main menus, and a status bar.

Figure 2-1 The Main Window of the Memory Leak Detector

® JRockit Memory Leak Detector,
File Edit View Actions Help

S¥> ¢ aam

Trend | Types | Instances | E: Allocation Stack Traces

Trend Analysis - Which types are |

Type Growth {bytes/sec) % of Heap Size (KB} # Instances

Type filter: |

Ignoring types that occupy less than 0,1%: of the heap,

% Disconnected | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

Tabs Explained

The main window of the Memory Leak Detector contains four tabs as shown in Figure 2-2.
Table 2-1 explains what you can do under the different tabs.

Figure 2-2 The Tabs in the Memory Leak Detector (Indicates Work Flow)

| Trend | Types | Instances | E: Allocation Stack Traces
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Table 2-1 Memory Leak Detector Tabs Explained

Tab Description

From the Trend tab you view a trend analysis of the object types on the Java heap.

fred You will see a list of all types that occupy more than 0.1% of the heap (this number
can be changed in File > Preferences > Trend). The object type with the highest
growth rate will be listed first.
S From the Types tab you view a type graph that shows how different types point to
= each other.
B From the Instances tab you view an instance graph that shows how different

instances point to each other.

From the Allocation Stack Traces tab you view where a certain type is allocated

Allocation Stack Traces .
4 in the code.

Toolbar Explained

The Memory Leak Detector tool bar, see Figure 2-3, contains, for example, buttons to connect to
the JRockit instance. See Table 2-2 for an explanation of the different tools in the tool bar.

Figure 2-3 The Toolbar in the Memory Leak Detector

| Y TIEIECYE

Table 2-2 Toolbar Icons Explained

Icon  Description

Connect to the management server. This button connects you to the management server, which
in turn allows you to monitor your Java application.

L

Disconnect from the management server and your Java application.

b Start monitoring your Java application.

- Pause the screen updating.

Stop the current monitoring.
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Tahle 2-2 Toolbar Icons Explained

Icon  Description

Refresh the current view.

@

& Zoom in on a type or an instance. This tool helps you navigate in the graph.
& Zoom out from a type or an instance.

= Center objects in your viewing area.

Status Bar Explained

The status bar (Figure 2-4) at the bottom of the window displays information regarding the
current connection, whether the trend analysis is on or not, and whether the allocation stack trace
is on or not.

Figure 2-4 The Status bar in the Memory Leak Detector

| g Connected | Trend Analysis: Disabled | Allocation Stack Traces: Disabled
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CHAPTERa

Using the Memory Leak Detector

Now you understand how a flow of events for memory leak detection works and the basic
functions of the user interface, it is time to get to know how powerful the Memory Leak Detector
actually is in action. This part of the user guide describes the different tabs of the interface in
detail and how the Memory Leak Detector works when monitoring a Java application with a real
memory leak. Each tab of the interface will be explained in detail in this section.

The following topics will be covered in this section:
e Analyzing the Application
e Investigating a Suspicious Object Type
e Investigating an Object Instance
e Viewing Allocation Stack Traces

e Customizing Settings

Analyzing the Application

From the Trend tab (see Figure 3-1), you start the analysis of your applications. The object types
with the highest growth in bytes/sec are marked red (darkest) in the Trend Analysis table and
they are listed at the top of the table. For each update, the list can change and the type that was
the highest move down the list. The object types listed in Figure 3-1 are fetched from an example
application, where you can suspect a memory leak at the objects marked red.
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3-2

Figure 3-1 Memory Leak Analysis

® JRockit Memory Leak Detector [ localhost@7091 |
Eile Edit Wew aActions Help

ex» ua¢ Q4

= java.lang,String
= java.util Hashtable$Entry

3, Trend ‘ Types Instances | El Allocation Stack Traces |
Trend Analysis - Which types are leaking?
Type Growth (bytes/sec) < of Hesp Size (KB) # Instances
[ charl] 7 42.08% 9,058 252,467

25.02%: 5,921 252,655
24.56% 5,812 248,009

[ 1 java.util Hashtable$Entry[] 65,53% 1,544 45
=% java.lang.Class 0.52%, 122 1,426
[ 1 java.lang.Stringl] ] 0.17% 39 1,178
= java.lang.reflect.Method 1] 0 11% 25 462
[ btel] -695 0,2% 47 56
Type Filker: |

Ignoring kypes that occupy less than 0. 1% of the heap,

% Connected | Trend Analysis: Enabled | Allocation Stack Traces: Disabled

Table 3-1 explains what each column in the Trend tab displays.

Table 3-1 Trend Analysis - Which types are leaking?

Column Title Displays

Type The type of object (class).

Growth The amount of memory (in bytes) with which the type is growing, per second.

(bytes/sec)

% of Heap How much of the Java heap is occupied by this type of object, measured in
percentages of the entire heap.

Size (KB) What size in KB does that percentage correspond to.

# Instances The number of live objects of this type that currently exist.

To Start Analyzing Your Application

e Make sure the Memory Leak Detector is connected to JRockit and that your JRockit
application is running with the -Xmanagement option turned on.
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The trend analysis should start automatically. If not, click the Start button to start the trend
analysis.

If you have an application with a memory leak, the trend analysis can look something like
Figure 3-1.

To Pause Analysis of Your Application
e Click the Pause button.

This operation freezes the updating of the trend analysis in the Trend tab and you can start
to analyze the application. If you want to view more data from the same analysis run, click
the Play button again and the Memory Leak Detector resumes displaying samples from the
application.

To Stop Analysis of Your Application
e Click the Stop button.

This operation stops the continuous update of the data. When you start the trend analysis
again, the data that is currently displayed will be reset.

Note: You do not stop the application itself by stopping the analysis.

To Start the Investigation
1. Right-click the object you think contains a memory leak.

2. Select Show Referring Types.

The Types tab appears (see Figure 3-2). For instructions on how to investigate further, see
To Get Closer to the Memory Leaking Object.

Investigating a Suspicious Object Type

Once you have found a suspected memory leak (a type that is high in growth and is colored red),
you investigate the suspected leak further in the Types tab, see Figure 3-2. Before anything is
displayed in this tab, you need to start the investigation by selecting a type from the Trend tab,
see To Start the Investigation.

The Types tab offers a view of the relationships between all the types pointing to the type you
are investigating. For each type you also see a number, which is the number of instances that point
to that type.
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Figure 3-2 Types Tab

£ JRockit Memory Leak Detector, [ localhost@ 7091 ]
Eile Edit Wew aActions Help

Q% Ha ¢ |aam

Trend Types ‘ Instances | El Allocation Stack Traces |

Types Graph

+]

@ java.io.BufferedWriter

[+ ] jaua.in.objectstreamclasssFialdReﬂeﬂurri 7.

T

b java.lang.String 84500

© | | o

Select a node in the graph and select Yiew-=List Instances, Yiew- =List Largest Arrays or double click the node.

% Connected | Trend Analysis: Disabled ‘ Allocation Stack Traces: Disabled

The color red (dark) means that the type has a high growth rate (which may or may not be related
to a memory leak).

To Get Closer to the Memory Leaking Object

1. Double-click on the type with the darkest color.
The type expands further (see Figure 3-3).
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Figure 3-3 Type Graph Expanded

 JRockit Memory Leak Detector [ localhost@7091 ]
File Edit Wiew Actions Help

&> In % AQE

=] trend Types

Types Graph
— . IE

@ java.lang.Thread ? 14

305

@ Instances ‘ E, Allocation Stack Traces

javax. |

557.

) Java.util

d jaua.lang.string[ﬁll 3235

%) Java.utilHashtable$Entry

BO0753

3 \'ni javalang.String .I

K|

Select a node in the graph and select Yiew-=List Instances, ¥iew->List Largest Arrays or double click the node.

@ Connecked | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

2. Keep clicking the type with the darkest color red, until you get down to a “natural end” where
you think you can pinpoint the memory leak.

3. Right-click the type where you suspect a leak (see Figure 3-4).
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Figure 3-4 Type Graph with Memory Leak Pinpointed

® JRockit Memory Leak Detector [ localhost@7091 ]
Eile Edit Wiew Actions Help

&> la ¢ A’ m

E Trend Types | @ Instances ‘ El Allocation Stack Traces

Types Graph

[ essamenegt]
) fava.
Q¥
[Q smascaety provider sun?” 0w,
326543

3]

lzll % Show allocation Traces
Restart graph on node
—i Expand 4l Nodes

7
‘;J jruckit.license.LicensePropertiesF 1

|u) sun.security.jca.ProviderList$1 F 1

, Wiew-=List Largest Arrays or double click the node.

Select a node in the gr
X Remowve

@ Connecked | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

4. Select List Instances.
The Instances part of the Types tab opens.

List instances shows you instances of the selected type. The instances shown will only be
those that have references to the type indicated by the arrow from the selected type in the

above type graph.
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Figure 3-5 List of Instances in Types Tab

 JRockit Memory Leak Detector [ localhost@7091 ]

File Edit Wiew Actions Help
@ [ % aQm
E Trend Types | Instances ‘ El Allocation Stack Traces |
Types Graph
E Overview
|J sun.security.jca.ProviderList$1 r— 1 Daocked:
il %ﬁ
@ s““'SECUFity-pmuider.Sun‘? java.utiLH il Y gaaasr—
L+ ] java.util.Properties 4
J java,util, P 38
[l | 0]
Instances |
Instances of java.util.Hashtable pointing to java.util.Hashtable$Entry[]
From instance Data kept alive (bytes)
java utl.Hashtable<0> =1Z,582, 965
java.utl.Hashtable=1> =102,443 (.
java.utl.Hashtable<2 = »102,424
java,utl.Hashtable<3> 69,864
java,utl.Hashtable <4 > 53,112
java utl.Hashtable<5 > 50,216 lz‘
% Connecked | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

The lower half of the tab lists all instances of type A pointing to type B if the instance list
is not too large (see Figure 3-5). If the list is too large, the Memory Leak Detector might
time out when trying to display the list. You can change the time out setting under File >
Preferences.

The column Data kept alive (bytes) shows how much data a certain instance keeps alive.
This data cannot be garbage collected.

Have the Overview part of the window open to see where you are in the graph (see To Get
an Overview of the Graph for how to turn on the overview). You can also zoom in/out or
re-center the view (see Table 2-2 for an explanation of the zooming tools).

To Get an Overview of the Graph

e Click View > Birds-eye Overview.
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A small Overview window opens on the tab. This Overview is good to help you navigate
in large graphs. You can refocus the view in the current tab by moving the shaded area.

To Investigate an Instance of a Type
1. Right-click an instance in the Types tab (probably one with the highest data kept alive).

2. Select Show Referring Instances.

The Instances tab appears (see Figure 3-6).

Investigating an Object Instance

In the Instance tab, see Figure 3-6, you view the instances of the type that you suspect is leaking
memory. You can also see the name of the specific field by looking at the arrow that is referring.
Right-click an instance to get a popup menu with the Inspect Instance option. When inspecting

an instance you will see all instance variables that the object contains. This information will help
you pinpoint where in your application the leaking object is located.
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Figure 3-6 Referring Instances Tab

® JRockit Memory Leak Detector [ localhost@7091 ]
Eile Edit Wiew Actions Help

I LCECE

E Trend | Types | Instances ‘ El Allocation Stack Traces |

Instances Graph - Instances referring to: java.util.Hashtable <0
E Overview
™ Docked:

) com.jrockit test, 4 Threadc:ﬂb]_ tahle
Jjava.util.Hashtable<0>
Threadroot: Thread-fﬁ

~]

Kl

Select a node in the graph and select ¥iew->Inspect Instance, or double click the node.

% Connecked | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

Table 3-2 explains what you will be able to view in the Instances tab.

Table 3-2 Instances of Suspected Memory Leaks

Part of Tab Displays

Instances Graph  This graph shows how the instances are connected to each other.

Inspector In the inspector view you can see all fields the object contains and their values. The
information that is displayed is depending on the application you monitor.

Viewing Allocation Stack Traces

In the Allocation Stack Traces tab, see Figure 3-7, you can check for where in the code
allocations of a certain type are done. Enabling allocation stack traces may deteriorate the
performance of JRockit. Collecting information about all the allocation points might take a while.
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Figure 3-7 Allocation Stack Traces Tah

** JRockit Memory Leak Detector, [ localhost@ 7091 |
Eile Edit Wew aActions Help

s¥ Hu¢[Qam
Trend | Types ‘ Instances | El Allocation Stack Traces

Allocation Stack Traces

= com, jrockit.memleak, test HashtableLeak$DemoThread
[Z] 4= [100% 1) java.util logging. Logger .getHandlers{)[Liavafutilflogging/Handler;
[= 4= {100% 1) java.util.logging. LogManager.resetLogger [LogManager. java:653]
[=1-4= {100% 1) java.util.logging. LogManager. reset [LogManager. java:641]
4= (100% 1) java.util.logging LogManager$Cleaner run [LogManager . java: 204]

g Disconnected | Trend Analysis: Disabled | Allocation Stack Traces: Disabled

Customizing Settings

The Memory Leak Detector can be customized in many different ways. Figure 3-8 through
Figure 3-13 explains the different settings you can make.

To Open the Preferences Window
e Click File > Preferences.
The Preferences window opens (see Figure 3-8).

When you have set your preferences, click OK for them to take effect.

To Reset Preferences to Default Values
1. Click File > Preferences.

2. Click Defaults.
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3. Click OK.

Figure 3-8 Confirm Exit Setting

Preferences

Customizing Settings

X

General
Trend
Graph
Inspeck
Inskance Inspector
Types

Connection

Confirm Exit

Controls whether exiting the application should be confirmed or not.

Confirm Exit: []

‘ o4 ‘ | Cancel || Defaults ‘

Select the Confirm EXxit option if you want to get a confirmation message when you are closing
the Memory Leak Detector.
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Figure 3-9 Display of Heap Usage

Preferences

E3

General
Lowest heap usage to report
Trend P L
Graph Speifies the minimurn ratia of the heap that a bype should accupy
for it to be reported in the trend table, Types whose total size
Inspect occupy less than this ratio of the total heap will be ignored,
Instance Inspectar Specify zern bo see all kypes.
Types Lowest heap usage to report: | 0,001
Connection

‘ OF H Cancel || Defaulks ‘

Here you set the ratio of the Java heap that you want displayed. Those types that are smaller than
the set ratio are not displayed. If you want to display all types, set the ratio to O (zero).
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Figure 3-10 Graph Settings

Preferences le
General .
Trand Animate Layout
Braph Specifies whether layouts of graphs should be animated.
Inspect Animate Layout;
Instance [nspectar
Center at Expand
Types
. This setting controls whether graphs should automatically center
Connection
the last expanded object.
Cenker at Expand:
Number of Nodes to Expand
Specify the number of referred nodes bo expand when a nodes is expanded.
Mumber of Nodes to Expand:
Show Package Names
Enable this property if you want complete class names to appear in
the types and instances graphs.
Show Package Marmes:
‘ OF ‘ | Cancel | | Defaulks ‘

e Select Animate Layout if you want the types graph in the Types tab and the Instances
tab to be animated when you expand a node on the type.

Select Center at Expand if you want the graphs in the Types tab and Instances tab to be
centered in the viewing area when you expand a node on the type or instance.

Specify the value for Number of Nodes to Expand to control how many nodes you want
to be displayed in the Types tab and Instances tab. If you specify a very high number, the
view can become cluttered.

e Select Show Package Names if you want the complete class name displayed.
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Figure 3-11 Number of Instances that are fetched

Preferences [z|
General
Max number of Instances to fetch
Trend
Graph Speifies the maximum number of instances ko fetch.
Inspect IMax number of Instances to fetch:
Instance [nspectar
Types
Connection
‘ OF ‘ | Cancel | | Defaulks ‘

Here you set the number of instances you want to list when doing List instances of a type. The
list is shown in the Types tab under Instances.
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Figure 3-12 Number of Array Elements that are Fetched

Preferences [z|
General
Mumber of Array El s to fetch
Trend
Graph Specifies the number of array elements to fetch when inspecting array
elements in the instance inspector,

Humber of Array Elements ko Fietch: | 50
Instance [nspectar v
Types
Connection

‘ OF H Cancel || Defaulks ‘

Specify the value for the Max number of Array Elements to fetch. These elements are

displayed in the Types tab when you have selected List Largest Arrays.
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Figure 3-13 Timeout Setting

Preferences F§|
General
Timeout for fetching instance relations

Trend
Graph Specifies the timeout in seconds when Fetching instance relations

in the instance inspectar.
Inspect

Timeout For Fetching instance relations: | 20

Instance [nspectar @ -
Types Maximum keep alive size to trace
Conrection Specifies the maximum size in bytes that the server will calculate for

what an object keeps alive. A larger value will cause server requests

to take longer when Fetching instance relations in the instance inspectar.

Maximum keep alive size to trace: | 100000
‘ OF ‘ | Cancel | | Defaulks ‘

e Set a number for Timeout for fetching instance relations. This number is measured in
seconds. The instance relation is showed in the Instances tab. The time out error can be
caused by too many instances that need to be fetched.

e Set a value, in bytes, for the Maximum keep alive size to trace. When the Memory Leak
Detector looks at an object until it reaches this value.
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Figure 3-14 Connection Settings

General
IMX connector host
Trend
Graph Specifies the host name {or IP-address) of the JM¥ connector to connect ta.
Inspect I conmector host: | localhost

Instance [nspectar

IMX connector port
Types

Specifies the TCP part number of the JMX connectar ko connect ta,
JMi connector pork: | 7091

Remember last used JMX connector

Connection

Controls whether the last used connector will be used as default the next time the application is used,

Remember last used M connector!

‘ OF H Cancel || Defaulks ‘

e Set a name for the JIMX connector host.
e Seta TCP port number for IMX connector port.

e Select Remember last used JMX connector if you want the tool to default to that setting.
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Help Us Improve JRockit

The Memory Leak Detector is designed to help you find memory leaks more easily and to better
understand critical points of program engineering. It provides an easy way to capture information
about object type allocation statistics.

If you have any suggestions about how to improve this tool or information on how it is most
commonly used in your development environments, we would be grateful to receive your input.
This information would contribute to our understanding on how to best further improve this tool
in the future.

Please, send an email with feedback and your ideas on how to use it to:

jrockit-improve@bea.com

How will BEA Systems Use This Feedback

The feedback will be considered by the development team designing the Memory Leak Detector.
We will look at collected ideas and improve the tools of BEA JRockit to make them even easier
to use. Our goal with the development of this tool is to simplify the difficult task of finding
memory leaks and help developers work more efficiently.

BEA JRockit is already providing a lot of appreciated manageability tools and, to keep a close
dialogue with developers using Java Runtime Environments, BEA Systems is always trying to
find ways to improve BEA JRockit. This is one of the ways.
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Help Us Improve JRockit

BEA JRockit Support for the Memory Leak Detector

Only more recent versions of BEA JRockit fully support the stand-alone Memory Leak Detector:
BEA JRockit 1.4.2 (R26.2), BEA JRockit 5.0 sp1 and forward.

Frequently Asked Questions

4-2

Following are some questions we have frequently been asked about the Memory Leak Detector:
e Does the Memory Leak Detector Cause Any Overhead?

e |Is There a Forum Where | can Discuss the Memory Leak Detector?

Does the Memory Leak Detector Cause Any Overhead?

In the trend analysis of the memory leak detection process, the data presented is continuously
updated; however, the overhead during this phase is very small. Each garbage collection will take
a bit longer. During the second and third phase the only overhead will be some additional garbage
collections, which in most cases is negligible. Overall, there is practically no overhead and it
should not affect the speed or results of your application.

Is There a Forum Where | can Discuss the Memory Leak
Detector?

If you have any questions you are welcome to share them in the BEA JRockit general interest
newsgroup, which is monitored by our engineering team. To access the newsgroup, go to:

http://newsgroups.bea.com
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