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About This Guide 

Primavera Virtual Desktop enables you to run P6 Professional over a secure network 
connection.  

Scope 

This guide describes how to administer and use Primavera Virtual Desktop with P6 Professional. 

Audience 

P6 administrators and users working in Primavera Virtual Desktop should use this guide. 

Using Primavera Virtual Desktop for Cloud 

This section contains information about how to access Primavera Virtual Desktop, how to export 
and import data, comparing schedules and printing in Primavera Virtual Desktop. 

About Primavera Virtual Desktop 

Primavera Virtual Desktop enables you to run P6 Professional over a secure network 
connection. 

Notes: 

 If the numeric lock status for your keyboard is not synchronized from 
your computer to Primavera Virtual Desktop, use the number keys at 
the top of your keyboard. 

 The selected database alias and file locations are not saved from the 
last time you logged into Primavera Virtual Desktop. Each time you 
log into Primavera Virtual Desktop, you will need to select the 
database alias and specify the locations to save files. 

Prerequisites for Cloud 

You must do the following before using Primavera Virtual Desktop:  

1) Check the version of browser installed on your computer and upgrade if necessary.  

 The supported browser for 18.7 and earlier is Microsoft Internet Explorer 11. 

 To see the supported browsers for 18.8 and later, see the Client System Requirements
spreadsheet. 

2) Add https://*.oracleindustry.com as a trusted site in your internet options. See Adding the 
Oracle Industry URL to Trusted Sites (on page 6). 
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3) Check the version of Java Runtime Environment (JRE) installed on your computer and 
upgrade if necessary. You must have administrator privileges on your computer to install 
JRE. 

 To find the supported version of JRE for 18.7 and earlier see: 
http://docs.oracle.com/cd/E51728_01/E51729/html/reqs-client.html.  

 For 18.8 and later, JRE is not required. 

4) Install Adobe Acrobat Reader on your local computer. Adobe Acrobat Reader can be 
downloaded from https://get.adobe.com/reader. 

5) For P6 Professional version 18.8 and later, install the Secure Global Desktop (SGD) client. 
See Accessing P6 Professional with Primavera Virtual Desktop for Cloud (on page 7) 

6) Optionally configure access to your local drives from Primavera Virtual Desktop. See 
Accessing Local Drives (on page 6). 

In addition, some further prerequisites for use of Primavera Virtual Desktop must be carried out 
by a P6 administrator and system administrator. For further information see: Administering 
Primavera Virtual Desktop for Cloud (on page 13). 

Adding the Oracle Industry URL to Trusted Sites 

To add the Oracle Industry URL to the trusted sites list: 

1) In Internet Explorer, click the Tools menu and select Internet Options. 

2) In the Internet Options dialog box: 

a. Select the Security tab. 

b. Select Trusted sites. 

c. Select the Sites button. 

3) In the Trusted sites dialog box: 

a. In the Add this website to the zone: field, type https://*.oracleindustry.com. 

b. Select Add. 

c. Select Close. 

4) In the Internet Options dialog box, select OK. 

Accessing Local Drives 

Primavera Virtual Desktop automatically maps to all the local drives you have configured on your 
computer. This allows you to save documents to locations which you can access when you are 
not logged in to Primavera Virtual Desktop. 

Prerequisites for Accessing P6 Professional with Primavera Virtual Desktop for 
Cloud 

The first time you access P6 Professional with Primavera Virtual Desktop version 18.8 or later, 
you must install the Oracle Secure Global Desktop client. 

To install the Oracle Secure Global Desktop client: 
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1) Uninstall any existing versions of the Secure Global Desktop client from your system. 

2) Browse to the Primavera Portal page. 

3) Click the Primavera Virtual Desktop link. 

Note: If you receive a prompt to launch the application, click Cancel. 

4) On the Secure Global Desktop loading page, click the Client Options link. 

5) On the Secure Global Desktop welcome page, click Install the Oracle Secure Global 
Desktop Client. 

6) In the installation wizard: 

a. Select the Install Only For Me option. 

Note: You can select the Install For Everyone option if you have 
administrative privileges. 

b. Accept the default options on all further installation screens. 

7) Log in to the Primavera Portal. 

a. Click the Primavera Virtual Desktop link. 

b. Select the option to launch the application with Oracle Secure Global Desktop Client. 

c. Select Remember my choice for sgd links. 

d. Click Open Link. 

Note: Launching Primavera Virtual Desktop in HTML5 mode is not 
supported in Primavera Cloud. 

Tip 

 For information about Secure Global Desktop product and patch announcements, and 
up-to-date details on the latest recommended version, see the following knowledge 
management document: 

Oracle Secure Global Desktop, Release Announcement Reference (Doc ID 2093579.2)
(https://mosemp.us.oracle.com/epmos/faces/DocumentDisplay?id=2093579.2) 

 Ten minutes after closing the browser or logging out of Primavera Virtual Desktop, the P6 
Professional session times out. If you log back in within ten minutes, the session remains 
active.  

 For a demonstration of how to download and install the Secure Desktop Client, watch the 
video at https://youtu.be/vXIbzNeTVd4 

Accessing P6 Professional with Primavera Virtual Desktop for Cloud 

Primavera Virtual Desktop enables you to access P6 Professional using your browser via the 
Primavera Portal. After you enter your username and password and P6 Professional has 
authenticated your credentials, a virtual desktop for P6 Professional launches. 

Note: P6 Professional requires the Oracle Secure Global Desktop Client. 
See Prerequisites for Accessing P6 Professional with Primavera 

https://mosemp.us.oracle.com/epmos/faces/DocumentDisplay?id=2093579.2
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Virtual Desktop for Cloud (on page 6) 

To access P6 Professional with Primavera Virtual Desktop: 

1) Log in to the Primavera Portal. 

2) Click Primavera Virtual Desktop for P6 Professional. 

3) In the login dialog box: 

a. Enter your username in the Login Name field. 

b. Enter your password in the Password field. 

c. Click OK. 

Resizing the Primavera Virtual Desktop Window 

You can resize the Primavera Virtual Desktop window. To resize the window, hold shift while 
dragging the corner of the window. 

Dialog boxes which appear inside the Primavera Virtual Desktop window cannot be moved 
outside the window. To make dialog boxes larger, resize the entire Primavera Virtual Desktop 
window. 

Exporting Project, Roles, and Resources for Cloud 

When you attempt to export projects, roles, and resources with P6 Professional on Primavera 
Virtual Desktop, you must select a location on one of your network drives.  

To export project, roles, or resources:  

1) On the File menu, select Export.  

2) On the Export Format screen: 

a. Select the Primavera PM - (XER) option. 

b. Optionally select a version number from the list. 

c. Click Next. 

3) On the Export Type screen: 

 To export projects, select Project. 

 To export resources or roles, select either Resource Only or Role Only. 

4) If you selected to export a project, on the Projects To Export screen, select the projects to 
export. 

5) On the File Name screen: 

a. Click Browse. 

b. In the Save File dialog box: 

c. Select a location on your local network. 

d. Enter a file name. 

e. Click Save. 

6) Click Finish. 
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Importing Projects, Roles, and Resources for Cloud 

When you attempt to import projects, roles, and resources to P6 Professional on Primavera 
Virtual Desktop, you must select a file from a location on one of your local network drives. 

To import projects, roles, or resources: 

1) From the File menu, select Import. 

2) In the Import dialog box: 

a. On the Import Format screen, select the format of the file you want to import and click 
Next. 

b. If you selected Primavera PM - (XER), on the Import Type screen select the type of data 
to import and click Next. 

c. On the File Name or Files to Import screen: 

 Click Browse and select the file to import. 

 If you selected to import a Primavera P6 - (XML) file, choose whether to import all 
project level layouts. 

 If you selected to import a Microsoft Project file, click Select and select the files to 
import. 

Click Next. 

d. Continue through the wizard selecting options as necessary and click Next on each 
screen. 

e. Click Finish. 

Configuring the Scheduling Log Location 

When scheduling in P6 Professional, set the location for the log file to a folder on your local 
machine so that you can view the log when you are not logged into Primavera Virtual Desktop. 

To set the location for the scheduling log file: 

1) On the Tools menu, select Schedule. 

2) In the Schedule dialog box: 

a. Select Log to file. 

 Select Overwrite existing to overwrite the existing schedule log file with a new 
file. 

 Select Append to existing to add to the existing schedule log file. 

b. Select Browse. 

3) In the Specify Log File dialog box: 

a. Navigate to the location on your local drive where you want to save the scheduling log 
files. 

b. In the File name: field, enter a name for the file. 

c. Select Open. 

4) In the Schedule dialog box, select Schedule. 
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Using Schedule Comparison for Cloud 

Schedule Comparison is used to compare the current version of a project against its baseline so 
that you can access a report that displays the differences between added, deleted, or changed 
information between projects. 

When you use Schedule Comparison, you must designate a location to which your project 
comparison will be exported. You must export Schedule Comparison reports to your local 
network drive. 

Printing Using Primavera Virtual Desktop for Cloud 

Primavera Virtual Desktop offers several ways to print from P6 Professional: 

 Universal PDF Viewer enables you to open a PDF of your schedule in a PDF viewer. This 
option requires that Adobe Acrobat Reader is installed on your computer. 

 Universal PDF Printer enables you to print a hard copy of your schedule. This option 
automatically selects the printer you have selected as the default. When you print to your 
default printer, you can change the page orientation in Primavera Virtual Desktop. All other 
printer settings must be configured for the printer before launching Primavera Virtual 
Desktop. 

 Print to PDF enables you to create a PDF of your schedule in a location you specify. You 
must specify a destination for the file each time you print. 

Notes: 

 Oracle recommends using the Print to PDF option unless you are 
printing a hard copy to your default printer. 

 If Universal PDF Printer is not enabled, submit a Service Request in 
My Oracle Support. The necessary configuration change applies to 
all users. 

 If you are using version 18.8.3 or earlier time stamps in the header 
and footer of printed output might not show the time in your local 
timezone. Submit a Service Request in My Oracle Support to request 
that this is changed. This configuration change allows all users in 
your system to see their local time in headers and footers. If you are 
using version 18.8.4 or later, time stamps in the header and footer 
always show your local time. 

Printing From The File Menu 

Note: At each step there might be a delay. The length of the delay 
depends on several factors, including the bandwidth of your connection, 
network latency, and the number of pages in the report. You must wait 
for each of these steps to be completed before continuing to work in 
Primavera Virtual Desktop. 

To print from the file menu: 
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1) On the File menu, select Print. 

2) In the Print Options dialog box: 

a. In the Name list: 

 Select Print to PDF to print a copy of your P6 Professional screen to a PDF file in 
a location you specify. 

 Select Universal PDF Printer to print your P6 Professional screen using your 
default printer. 

3) Optionally if you selected the Print to PDF option, select Properties. 

a. In the Print To PDF Properties dialog box: 

 Select the File System option. 

 Optionally, select Options and configure any further output settings. 

 Click OK. 

b. In the save dialog box: 

 If you see a Network icon, double click Network and then double click tsclient to 
list your local drives. Browse to your desired location and provide a file name for 
the PDF, then select OK. 

 If you do not see a Network icon, select the desired folder location from the list 
and provide a file name. 

Note: To save files more efficiently, you can enter the full path and file 
name. The path must begin with "\\tsclient\D (rw)\" and the file 
name must include the extension ".pdf" at the end. 
For example: 
\\tsclient\D (rw)\myfiles\myprint.pdf

4) In the Report Printed dialog box, select OK. 

Printing From Page Setup or Print Preview 

Note: At each step there might be a delay. The length of the delay 
depends on several factors, including the bandwidth of your connection, 
network latency, and the number of pages in the report. You must wait 
for each of these steps to be completed before continuing to work in 
Primavera Virtual Desktop. 

To print from Page Setup or Print Preview in P6 Professional: 

1) From the File menu, select Print Setup. 

2) In the Print Setup dialog box: 

a. On the Name list, select Print to PDF. 

b. In the Size section, select the paper size you want to use for the PDF file. 

c. Optionally select Properties to configure final PDF output settings. 

d. Click OK. 
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3) From the File menu, select Page Setup or Print Preview and select the option to print using 
Print to PDF. 

Viewing the Primavera Virtual Desktop Print Queue 

To view the print queue for Primavera Virtual Desktop: 

1) Browse to the Primavera Portal page. 

2) Click the Primavera Virtual Desktop link. 

3) In the Navigation pane, select the List All Jobs button. 

Changing The Default Overwrite Setting For Print To PDF 

When you use the Print to PDF option, by default any existing file will be overwritten with the 
new file. 

To change the default overwrite setting: 

1) From the File menu, select Print Setup. 

2) In the Print Setup dialog box: 

a. On the Name list, select Print to PDF. 

b. Click Properties. 

c. Select Destination>. 

d. In the Print to PDF Properties screen, select File system and click Options. 

e. Click Overwrite without asking and select a different action from the list. 

f. Click OK. 

Troubleshooting 

Java Version and Browser Mismatch 

It is important for Internet Explorer and the Java Runtime Environment (JRE) to be compatible. 

To check whether Internet Explorer is using 64 or 32 bit tabs: 

1) Open Internet Explorer and open several tabs. 

2) Right click on the Windows start bar and select Task Manager. 

3) In the Image Name column, look for iexplore.exe 

 If you see multiple entries of iexploere.exe *32, Internet Explorer is using 32-bit tabs. 

 If you see only entries of iexplore.exe, Internet Explorer is using 64-bit tabs. 

If Internet Explorer is using 64 bit tabs, download and install 64-bit JRE. 

If Internet Explorer is using 32-bit tabs, you can either switch on Enhanced Protection Mode in 
Internet Explorer, or download and install 32-bit JRE. 

To switch on Enhanced Protection Mode: 

1) Open Windows Control Panel and select Internet Options. 

2) In the Internet Properties dialog box: 



Administering Primavera Virtual Desktop for Cloud

13

a. Click the Advanced tab. 

b. Scroll to the Security section and select Enable Enhanced Protection Mode*. 

c. Click OK. 

3) Restart your computer. 

Secure Global Desktop Is Blocked By Virus Scanning Software 

If the virus protection software installed on your computer incorrectly identifies components of 
Cloud Services as suspicious, contact your IT team. 

Network Level Authentication Failure 

If you receive an message about network level authentication having failed, see: Secure Global 
Desktop Error "Session Failed: Network Level Authentication Failed" When Attempting to 
Launch P6 Professional via Primavera Virtual Desktop (Doc ID 2200935.1) at 
https://support.oracle.com/epmos/faces/DocumentDisplay?id=2200935.1 

P6 Professional Does Not Allow You to Select a File Destination 

When you are printing in Primavera Virtual Desktop, if you receive a message that a report has 
been printed, but you are not able to select a destination for the report output: 

1) In the Print dialog box, select Properties. 

2) In the Print to PDF Properties dialog box, select a file location for the report. 

Network Connectivity Loss 

If Primavera Virtual Desktop crashes because of a loss of network connectivity, ensure that you 
have a reliable internet connection with your provider before logging back into Primavera Virtual 
Desktop. 

Local Drives Are Not Available 

If the local drives configured for your computer are not available inside Primavera Virtual 
Desktop, log out of P6 Professional and then log out of Primavera Virtual Desktop. Log in to 
Primavera Virtual Desktop. 

Administering Primavera Virtual Desktop for 
Cloud 

This section contains information about configuring P6 Professional users and Windows users 
for using Primavera Virtual Desktop. 

Administration Prerequisites 

Before users can log into P6 Professional using Primavera Virtual Desktop, you must: 

1) Assign users P6 Professional module access rights and project privilege rights in P6. 
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2) Assign users the Primavera Virtual Desktop role in Primavera Administration. See the 
Primavera Administration Identity Management Guide for details. 

Note: After you assign the role assignment, users must wait 
approximately 10 minutes for the assignment to take effect. 

3) Ensure that all usernames in Primavera Administration meet the following requirements. 

 User names must be unique on the computer that is being administered. User names 
must not be the same as any group names on the computer that is being administered. 

 The user name can be up to 20 alphanumeric characters and symbols and is not case 
sensitive. 

 The user name cannot contain the following characters: " / \ [ ] : ; | = , + * ? < > @  

 The user name cannot consist solely of periods (.) or spaces. 

Note: Password can contain up to 127 characters. 
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