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Working with Unifier Managers 

The following explains how to work with Unifier managers. 

Within our documentation, some content might be specific for cloud deployments while other 
content is relevant for on-premises deployments. Any content that applies to only one of these 
deployments is labeled accordingly. 

Collapse by Default Option in Manager Attribute Forms 

In the Block Properties window of a manager attribute form, there is a new checkbox called 
Collapse by Default. If the checkbox is checked, the block is collapsed by default. If the 
checkbox is unchecked, the block is expanded by default. 

With the Collapse by Default option, you can avoid scrolling through irrelevant information. 

The Block Properties are searched during the rendering of a manager attribute form to 
determine whether a block is collapsed or expanded at runtime. 

Collapse by Default is applicable to most manager attribute forms, including: Activity Manager, 
Configurable Manager, Cost Manager, Document Manager, and Space Manager. This option is 
also applicable to Shell attribute forms as well as places where a preview of a manager attribute 
form is displayed, such as a variety of logs. 

Note: If you change the default behavior by performing the opposite 
action at runtime, the default expand or collapse option is displayed 
when the page is reloaded. 

In This Section 

Unifier Asset Manager ............................................................................................. 23 
Unifier Configurable Managers (Configurable Modules) .......................................... 33 
Unifier Cost Manager .............................................................................................. 71 
Unifier Document Manager .................................................................................... 373 
Unifier Portfolio Manager ....................................................................................... 461 
Unifier Planning Manager ...................................................................................... 503 
Unifier Resource Manager ..................................................................................... 519 
Unifier Schedule Manager ..................................................................................... 555 
Unifier Activity Manager ......................................................................................... 683 
Unifier Space Manager .......................................................................................... 685 
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Unifier Asset Manager 

The Asset Manager module is part of the company workspace. It is used to manage assets and 
depreciation. You can track assets and depreciation on their associated asset sheets. 

The Asset Manager allows you to: 

 Create, organize, and manage company assets 

 Define an unlimited number of asset classes, and design an asset attribute form per asset 
class 

 Create assets manually, using templates, or importing 

 Apply multiple asset depreciation methods: straight line, double decline, sum of years digits, 
manual 

 Track the asset’s total cost of ownership: roll up maintenance-related costs from projects or 
company level business processes to specific company account codes 

The Asset Manager uses the three most common depreciation methods: 

 Straight line 

 Double decline, or sum of year digits 

 Manual depreciation 

Irrespective of method, asset depreciation is calculated for the entire life of the asset over 
whatever period you specify. For example, if an asset is depreciating over two years and you 
specify a monthly depreciation increment, then the asset’s value will be recalculated each month 
for two years from the date of acquisition. 

Asset Classes: Assets are grouped in classes (for example, buildings, equipment, etc.). The 
detail forms that are used to enter asset information can be designed in uDesigner, per class. 
For example, you can design and use different forms for entering information about your 
company’s building assets and equipment assets. Each asset exists as a unique record. 

Asset Codes: Asset codes are generated automatically when assets are created. The asset 
code will be built using different data elements defined on the asset form as segments. At 
runtime, the asset code is built automatically based on the data element values selected. A tree 
structure is automatically built to access these assets based on the asset codes. Assets with the 
same segment values will be grouped together to form a hierarchy. 

Asset Sheets: You can track assets and depreciation on asset sheets. There is one asset sheet 
per class, listing details about each asset in that class, plus an asset summary sheet, which 
helps you track all of your assets in one place. User permissions are granted per asset class or 
sheet. If you cannot view any part of the Asset Manager to which you require access, contact 
your company administrator. 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 
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Creating and Managing Assets ................................................................................ 24 
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Editing Multiple Assets from Asset Log (Bulk Edit) .................................................. 29 
Printing an Asset Manager Form ............................................................................. 30 

Creating and Managing Assets 

You can create and manage your company assets in the Asset Manager in the company 
workspace portion of the Navigator. 

Each asset that you add to the system exists as a unique record. You can create new assets 
manually by copying from a template within the same asset class, copying another asset in the 
same class, or by importing assets. The form that is used to enter the details about each asset is 
designed in Designerr for each class. The form design can vary greatly from class to class. 

Access the Asset Manager 

To access the asset manager 

1) In User Mode, go to the Company Workspace tab and click Asset Manager in the left 
Navigator. The Asset Manager displays asset sheets and asset classes. 

2) To access asset sheets, click the Asset Sheets node. 

3) To access assets, select an asset class. The log opens for the asset class. 

The center navigation pane displays the segments of the asset codes hierarchically by their 
segments, as selected in the properties window for each asset. These nodes are created as 
asset codes are created. The right pane lists all assets created under the selected class. 

Asset Manager navigation and asset codes 

Assets are organized by the segments of the asset codes. Asset codes are based on segments. 
These segments are created when the asset is created, based on the values entered on the 
asset form. For example, for an asset class Buildings, the asset codes for individual assets may 
be built by location segments: country-state-city. You can then view all buildings in the asset 
class or drill down to all buildings per segment (per country, state or province, and city). 

Click the asset class name in the asset navigator to view all assets created under the class, or 
click each segment to view assets matching the segment. 

Create a new asset 

You can create new assets manually by copying from a template within the same asset class, 
copying another asset in the same class, or by importing assets. 

The form that is used to enter the details about each asset is designed in uDesigner for each 
class. The form design can vary greatly from class to class. 
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Each asset that you add to the system exists as a unique record. 

You can manually create new assets or create assets by copying from another asset or from a 
template. If the asset record or template also has a depreciate schedule set up, it will also be 
copied to the new asset. 

To create a new asset manually 

1) In User Mode, go to the Company Workspace tab and click Asset Manager in the left 
Navigator. Select an asset class. The Asset Class navigator opens. 

2) Select the node under which you want to create the new asset. 

3) Click New. The Create New Asset form opens. 

4) Complete the form. This form is similar to a non-workflow business process form and has 
two sections: 

 General: In the upper portion of the form, enter all the details about the asset. 

 Depreciation Schedule: Setting up a depreciation schedule is optional. Before you can 
set up a depreciation schedule, you must first save the form. 

5) After completing the form, click Save to save changes to the upper form, or Finish Editing
to save and close the form. 

To create an asset by copying from a template 

1) In the Asset Class navigator, click the Copy button and choose Template. A list window 
opens displaying all templates for the asset class. 

2) Select a template and click Open. The Create New Asset form opens. The form may be 
populated with general and depreciation information from the template. 

3) Make changes as needed and click Save or Finish Editing to save the new asset. After 
saving, the Depreciation Setup button becomes available. 

To copy an asset 

1) Select an asset from the log and click Copy > Asset. The form opens, with the information 
from the original asset. 

2) Make changes as needed and click Save or Finish Editing to save the new asset. After 
saving, the Depreciation Setup button becomes available. 

Working with Asset Sheets 

Asset sheets are created automatically when asset classes are imported and activated. Asset 
sheets are listed in the Asset Sheet log window in the User Mode Asset Manager. There is one 
sheet per asset class, plus an asset summary sheet that summarizes all asset sheets. Assets 
are added to asset sheets as rows automatically, listed by the segmented asset code. In the 
asset summary sheet, the rows are the asset classes. 

The asset summary sheet displays information of all asset sheets. It displays total values from 
individual asset class sheets. The asset summary sheet is created automatically once the first 
asset class is imported. Asset classes imported into Unifier are automatically added as rows. 

Columns can be added to asset sheets. Some examples of columns include: 
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 Business processes (company-level BPs with the line items with asset code subtype are 
available; only the amount field is available.) 

 Project cost columns; most columns from project cost sheets are available (only the amount 
field is available). This is available when projects are created under asset categories. 

 Manual entry or formula columns. 

Access asset sheets 

Asset sheets are listed in the Asset Sheet log window in the Asset Manager. There is one sheet 
per class, plus a summary sheet which lists all sheets in all classes. 

Note: You must have permissions to access any listed sheet. If you 
need access to a sheet not listed in the log, contact your company 
administrator. 

To access asset sheets 

In User Mode, go to the Company Workspace tab and click Asset Manager > Asset Sheets in 
the left Navigator. The Asset Sheets log opens. The log lists any existing asset sheets: one 
asset sheet per class, which is automatically created when an asset class is activated, plus an 
asset summary sheet that summarizes asset class information. 

To open an asset sheet 

Select the sheet in the log and click Open. 

View asset and column details 

To view column details 

Open the asset sheet and click a column heading. A view-only window opens displaying the 
column details. 

To view asset details 

Open the asset sheet and click a listed asset. Assets appear on the sheet as hyperlinks. A 
view-only window opens displaying the asset details. 

View asset sheet properties 

The Properties window for the asset sheet maintains the name and display options, and can be 
used to map a column to a company account code. 

To open the asset sheet Properties window 

In the Asset Sheets log, select the sheet and click the Properties button. In the Options tab, 
asset sheet columns can be mapped to company account codes. The total value of the column 
will roll up to the company accounts sheet. 
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Enter or edit asset sheet data 

For manual data-entry columns, you can enter data directly into the sheet. 

To enter asset sheet data 

1) Open the asset sheet. 

2) Click inside a manual entry column cell to enter data. 

3) Click the Save button to save changes. 

Create and view a snapshot 

You can save a snapshot of an asset sheet or the asset summary sheet. 

To save a snapshot 

1) Open the asset sheet or asset summary sheet. 

2) Choose File > Create Snapshot. The Create Snapshot window opens. 

3) Enter a title and click OK. 

To view a saved snapshot 

1) Open the asset sheet or asset summary sheet. 

2) Choose View > Snapshot Log. The snapshot log opens. 

3) Select the snapshot from the list and click Open. A read-only view of the asset sheet or 
asset summary sheet opens, displaying the sheet data at the time of the snapshot. 

Import asset sheet column data 

You can enter column data into manual-entry columns by importing a CSV sheet. Columns are 
limited to those of numeric data elements on the asset form. 

First, export the CSV structure, enter the data into the CSV file, and then re-import the CSV file. 

To export a manual-entry column 

1) Open the asset sheet. 

2) Click Export > Column Data. 

3) Save the CSV file to your local drive. 

To enter column data 

1) Open the CSV file. 

2) Enter column data for each listed asset. Be careful not to change the CSV file structure. 

3) Save the CSV file. 

To import column data 

1) Open the asset sheet. 

2) Click Import > Column Data. 

3) Browse to the CSV file containing the column data and click OK. 
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Copy data from one column to another 

You can copy data from one manual entry column to another. 

To copy data from one column to another 

1) Click the Edit menu and choose Copy > Column Data. The Copy Column Data window 
opens. 

2) Complete the window as described in the following table. 

In this field Do this 

Copy from column 
Select the manual entry column to copy the data from (numeric 
or date). 

Percentage 
Enter the percent of the value to copy. Enter 100% to copy the 
entire value. 

Copy to column 
Select the manual-entry column to copy the data to (numeric or 
date, based on the Copy from column selection. 

Search for assets on an asset sheet 

To search for assets: 

1) Open the asset sheet. 

2) Click View > Find. The Find window opens. 

3) Choose a column from the asset sheet and enter a value to search. 

4) Select the direction to search (up or down from the selection on the sheet). 

5) Click Find Next to search for the entered value. You can click again to continue searching. 

6) Click Cancel to cancel the search. 

Export asset sheet or summary sheet data 

You can export data from asset sheets or the asset summary sheet in CSV format. 

To export an asset summary sheet 

1) Open the asset summary sheet. 

2) Click the Export button and choose Summary Sheet. 

3) Save the CSV file to your local drive. The data is for reference only and cannot be 
re-imported. 

To export summary data on an asset sheet 

1) Open an asset sheet. 

2) Click the Export button and choose Summary Sheet. 

3) Save the CSV file to your local drive. The data is for reference only and cannot be 
re-imported. 
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Note: In Cash Flow, Cost Sheet, and Earned Value, you can replace the 
Summary Sheet with the Activity Sheet as a source. 

Understanding Reverse Auto-population 

Certain data elements support reverse auto-population. These are specified in uDesigner. 
Reverse auto-population means that some values can be updated when other values are 
modified in a business process that has reached a specified status. Auto-population can occur 
on BPs that are in the same shell or across shells. 

Depending on the setup in uDesigner, auto-population can occur in these instances: 

 Changes to data elements in a BP upper form can result in changes to the upper form of 
another BP. 

 Changes to the detail form in a BP can result in changes to the upper form and detail form of 
another BP. 

 Changes to the upper form or detail form of a BP can result in changes in the Asset, 
Resource, or Planning Manager forms. 

In the Asset Manager, reverse auto-population might occur if a move-order BP references an 
asset record. Updates on the move order can be reverse auto-populated on the asset. 

Editing Multiple Assets from Asset Log (Bulk Edit) 

If you have a large number of assets that need similar edits, you can use bulk edit to update all 
of the assets at once. You can update a maximum of 200 records using bulk asset edit. The bulk 
asset edit must be defined in uDesigner, and you must have the Allow Bulk Edit permission set 
on the asset class. 

Note: Bulk edits overwrite data without stopping for you to verify the 
overwrite of each record. Be sure that you have entered the data you 
want to edit correctly. 

To update assets using bulk edit 

1) Navigate to the asset log. 

2) Select one asset or several assets, or perform a find to search for a group of assets to work 
with. You can select the assets from the asset log or the Find log. 

3) Choose Edit > Bulk Edit. The Bulk Edit window opens. The fields displayed in this window 
depend on what was specified for detail form integration in uDesigner for the asset class. 

The Bulk Edit form includes all editable fields for the detail form for the asset class. 

4) Modify the bulk edit form as needed. 

5) Select the Update checkbox for the fields you want to update. The checkbox is automatically 
selected when you type into or modify a field. You can deselect it if you do not want to 
modify the field at this time. 

6) Click Update. This launches the bulk update of the selected assets. 
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7) The Bulk Actions Status window displays after you click Update. This window allows you to 
monitor the progress of the bulk asset update. Click OK after all records have processed. 
Click Cancel if you want to cancel the bulk update in progress. 

Printing an Asset Manager Form 

You can print a copy of an Asset form. You can choose PDF, HTML or Custom print formats and 
select one of the following options: 

 Save a copy of the form as a PDF file and print the file 

 Print an HTML view 

 Print from a Word file if a custom print layout has been created for the form 

The Custom Print formats include the BI Publisher custom print templates designed in the 
Custom Templates node. If custom print layouts have been created for the Asset Manager, the 
form will print according to the layout that you select. See the following Printing Options - 
Custom Format for details. 

To preview and print an Asset Manager form: 

1) Open the Asset Manager record that you want to print. 

2) From the File menu, choose Print Preview, then choose one of the following: 

 HTML to view the form in the browser which can then be printed. 

 PDF to open the form in Adobe Reader, which can be saved or emailed as a PDF file, or 
printed process, you are asked to save the changes to the form. 

 Custom to select the BI Publisher, Microsoft Word, and PDF custom print templates from 
the same place as the current custom prints. See the following Printing Options - 
Custom Format for details. 

The Print Options window opens. This window displays the record information that can be 
printed. 

3) Select the check boxes for the information that you want to print. 

4) To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the 
Select All checkbox. If you deselect all checkboxes, only the header and footer will print. 

5) Click OK. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, 
from which you can print. 

If you chose PDF, you can save a copy by clicking the Save a Copy button, or print. To print 
from HTML format, click on the Print icon in the upper right corner. 

Printing Options for an Asset Manager Form 

Following is a summary of the print options for an Asset Form. 

Print option What it prints 

Detail Form 
This prints the information entered on the form. Depreciation details 
in the line items are not printed. 

General 
Comments 

The general comment text and create details are printed. 
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Record 
Attachments 

File attachments to the record are listed alphabetically by file name, 
and also include the file title, issue date, revision number, and file 
size. 

Record 
Attachments > 
Comments 

Prints comments associated with file attachments to the record. 
"Record Attachments" must also be selected to select this option. 

To print an Asset Manager form with a custom print layout: 

1) Open the Asset Manager form that you want to print. Be sure it is in a view mode. 

2) From the File menu, choose Print Preview, then choose Custom to select the BI Publisher, 
Microsoft Word, or PDF custom print templates from the same place as the current custom 
prints (Custom Format Print selection window). 

3) Select a layout and click OK. The File Download window opens. 

4) Choose to Open or Save the file, which is a Microsoft Word DOC file. 

5) Open the file in Microsoft Word and print. This feature can be used with Microsoft Word 2003 
and 2007. 

Printing Options - Custom Format 

The Custom Format Print window has two sections: 

 Select a custom print template 

 Select a template and format to print 

Both sections facilitate custom print template and format selections. 

Select a custom print template

Lists all the custom print templates, including the custom print templates created in the Custom 
Templates node and the custom print templates. For example, the list may include BI Publisher 
custom print templates, Word, and PDF custom print templates.  

If there are multiple custom print templates, all the published templates are listed in this section.  

The "Select a template and format to print" is populated by the selection made in the "Select a 
custom print template" section.  

Select a template and format to print

 If you select a BI Publisher custom print, then you can select the desired template and 
format from the drop-down lists. 

 Template drop-down displays all the available templates for the selected format.  

 Format drop-down displays the available formats for the selected template. 

 If the custom print template was created using PDF or Word, then the "Select a template and 
format to print" is disabled. 

Default template and format

 If a BI Publisher print template is selected, then the default values in the drop-down lists are 
set based on the default in the custom print template.  
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 When a BI Publisher print template is selected in the "Select a custom print template" 
section, the template and format are populated based on the default value selected at the 
time of designing the print template. 



33

Unifier Configurable Managers (Configurable Modules) 

Configurable managers have flexible coding structures that allow you to analyze your data. 
Configurable managers are created and named in uDesigner depending on the intended task. 
They can be created at the shell, project, or company level. Configurable managers provide 
additional functionality and do not replace existing managers. A configurable manager behaves 
like any other module in the Unifier.  

There are two types of configurable managers: 

 Code-based (code based) 

 Code- and record-based (code and record based) 

You can have up to 25 configurable managers (CM1, CM2, ..., CMx). 

For Generic Cost Manager (CM0 or CM zero), see the Working with a Generic Cost Manager
(on page 363) topic in this guide. 

The configurable managers are nested under the Configurable Modules as shown below: 

Configurable Modules

 <name> Manager [Code-based configurable manager] 

 <name> Manager [Code- and record-based configurable manager] 

 Sheets 

 Class 

Note: The following sections may use the sub-nodes Parts Manager, 
Material Inventory Manager, Condition Assessment Manager, and 
so forth as examples of code-based or Code- and Record-based 
configurable managers. 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 
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Code- and Record-based Configurable Managers 

A code-and-record-based configurable manager allows you to define codes and capture data 
using records. This type of manager allows multiple classes of sheets and records to be created 
(each with its own coding structure). For a code- and record-based manager, you must first 
create the manager sheet. Thereafter, Unifier automatically adds information to the sheet as it is 
gathered from records that were created from business processes tied to the sheet. 

For example, a Parts Manager could be created to do the following: 

 Categorize parts by type (or class) by creating records for classes 

 Track inventory at various locations 

 Maintain basic cost information 

 Track parts transactions (bought, sold, received, or shipped) 

 Monitor costs generated by transactions 

Code-based Configurable Managers 

A code-based configurable manager also allows you to define codes, but it works with sheets to 
analyze information generated manually or from BPs. All the data is consolidated in one sheet. 
For a code-based manager, you must manually enter the rows on the sheet. Thereafter, Unifier 
automatically adds data to the rows as you manually enter it, or as it is gathered from records 
that were created from business processes tied to the sheet. 

For example, a Condition Assessment Manager could be created to do the following: 

 Define a building systems code structure at the company level, project level, or shell level 

 Design multiple BPs to track and calculate: 

 Maintenance requirements 

 Inspections 

 Work orders 

 Repairs 
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 Cost of maintenance 

 Deficiency costs 

 Renewal costs 

 Various indexes, such as a facility condition index, to monitor the condition and usability of 
facilities 

Access a Configurable Manager (Configurable Modules) 

The configurable manager modules are designed in uDesigner and configured by your company 
administrator. 

Note: User permissions are granted per class or sheet. If you cannot 
view any part of the configurable manager to which you require access, 
contact your company administrator. 

To access a configurable manager at the project level or shell level 

1) Go to your project or shell (User mode). 

2) Click Configurable Modules node to expand. 

The managers reside under the Configurable Modules > [configurable manager name] in the 
left Navigator. 

 If you are using a code- and record-based configurable manager, there are sheets and 
classes (for example, Sheets and Material Inventory Manager). 

 To access a sheet, click the Sheets node, and select a sheet from the log. 

 To access a class, select a class. The log for the class opens. 

 If you are using a code-based configurable manager, there is just one sheet, which is listed 
under the log (for example Parts Manager). 

To access a configurable manager at the company level (User mode) 

1) Go to your company (Company Workspace > User mode). 

2) Click Configurable Managers to expand. 

3) Click a manager, class, or sheet sub-node to open. 

To access a configurable manager at the company level (Admin mode) 

1) Go to your company (Company Workspace > Admin mode). 

2) Click Templates to expand. 

3) Click Shells or Configurable Modules node to expand. 
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Reverse auto-population and Code- and Record-Based Managers 

Certain Data Elements (DEs) support reverse auto-population (RAP). These are specified in 
uDesigner. RAP means that some values can be automatically updated when other values are 
modified in a Business Process (BP) form or record attribute form. 

You can use RAP to update the fields on records, as well as, Attribute forms and Line items. 
This option can streamline the use of forms by keeping the information on them up-to-date with 
the latest Unifier data from components inside or outside the BP. 

Depending on the set up in uDesigner, RAP can occur in these instances: 

 Changes to the DEs in a BP Detail form under the Company level can result in changes to 
the record attribute form of a generic manager at  the Company level 

 Changes to the DEs in a BP Detail form under the Standard Project level can result in 
changes to the record Attribute form of a generic manager at the Standard Project level 

 Changes to the DEs in a BP Detail form under the Shell level can result in changes to the 
record attribute form of a generic manager at the Shell level 

Creating Sheets and Records for a Code-and Record-based Manager (Standard View) 

You can use the Create option to create a new code- and record-based sheet by way of the 
following methods:  

 Manually

Read the process for manually creating a sheet, below. 

 From Template

This option enables you to create a configurable manager from a template. The From 
Template option is available only if one or more configurable manager templates are defined 
at Company Workspace (admin mode). 

 From Shell

When you click this option, Unifier opens a window which lists all the shells that the 
administrator has created. You can copy a configurable manager sheet from a shell that is 
listed. 

To create a code- and record-based sheet manually: 

1) Click Create and click Manual to open the create sheet window. 

2) In the overlay, enter the values. You can also edit existing values in the Properties tab, for 
example, change the Picker field value from All Records to records with their statuses set 
as "Active," "InActive," or both in the Records with statuses field. 

The Default Filter View drop-down field does not have any values when you create a new 
sheet. This field has a value for an existing sheet and can be changed. 

3) When finished, from the top, click Save. 

4) Click Save on the create sheet window. 

You can use the Create option to create a new code- and record-based class. 
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Creating Sheets for a Code-based Manager (Standard View) 

You can use the Create option to create a code-based configurable manger sheet; 

 Manually

Read the process for manually creating a sheet, below. 

 From Template

This option enables you to create a configurable manager from a template. The From 
Template option is available only if one or more configurable manager templates are defined 
at Company Workspace (admin mode). If no templates are defined, then this menu option 
will not be available. If you do not have create permission, this option is disabled. In this 
scenario, you can access rows or create more rows irrespective of the way that a sheet is 
created, manually or by template. 

you cannot modify the segment sources. Creating as sheet by way of a template enables you 
to access the sheet rows. 

 From Shell

When you click this option, Unifier opens a window which lists all the sheets that can be 
copied from other shells that the administrator has created. 

To create a code-based configurable manager sheet manually: 

1) Click Create and click Manual to open the create sheet window. 

2) In the Properties tab, enter the values. You can also edit existing values in the Properties 
tab, for example, change the Picker field value from All Records to records with their 
statuses set as "Active," "InActive," or both in the Records with statuses field. 

The Default Filter View drop-down field does not have any values when you create a new 
sheet. This field has a value for an existing sheet and can be changed. 

3) Click the Segments tab and add segments. 

You can add multiple segments by clicking the plus icon (+). When you click the plus icon 
(+), Unifier inserts a new row on the grid. Once you add a row, you must click the cell under 
the Segment Source label and select a source, which has been designed in uDesigner. You 
can use drag-and-drop to move the segments. To delete a segment click on the segment row 
and click the delete option (trash can icon). The Segments tab has a grid that is similar to 
the grid and fields of the Line Items in BPs. 

4) When finished, from the top, click Save. 

Click Save on the create sheet window. 

Working with Configurable Manager Sheets (Classic View) 

The following topics describe how to use configurable manager sheets. 

Create a new sheet from an existing template 

You can create a sheet by copying an existing template from the same class. 
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To copy an existing template 

1) Select a class template from the log. 

2) To copy a template, do one of the following depending on which level the template is: 

 At the company level, click Copy > Template. 

 At the project level, click Copy > Project. 

 At the shell level, click Copy > <shell name>. 

The Properties window opens with the information from the original template. 

3) Make changes as needed in the Properties window, and click OK to create the new sheet. 

Add columns to a sheet 

If you have created permission, you can add columns, but not rows, to a Configurable Manager 
sheet template. The columns can capture data from business processes or manually entered 
data. 

To add a column to a sheet 

1) Open the sheet. 

2) Click Columns. The Columns log opens. 

3) Click New. The Column Properties window opens. Complete the window as described in the 
table below. 

In this field: Do this: 

Name 
The Name field is populated with the data source value 
selected. 

Datasource 

Select a data source. The data sources available are data 
elements that are defined in the detail form for a class in 
uDesigner. Also listed are data elements based on SYS 
Numeric Logical Datasource, SYS Date Logical Datasource,
SYS Project Cost Datasource, SYS BP Currency Amount, 
SYS BP Decimal Amount, and SYS BP Integer Amount data 
definitions. 

Note: You can add data picker fields as columns, but you 
cannot invoke the data picker from the sheet. 

Width (pixels) 
Enter the width the column should be. Maximum is 2000 pixels. 
(You can also manually resize the columns on the sheet.) 

Alignment 
Specify whether the data in the column should be left- or 
right-aligned, or centered. 
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Entry Method 

Choose a data entry method for the column. The options vary 
depending on the data source selected: 

 Manual entry: You can enter data directly into the cell, or 
data is rolled up from another source, such as the form. 

 Formula: Formula types are numeric, date difference, and 
date add. See Add a formula column (on page 40) for 
details on working with formulas. 

 Define: Use this method to specify data that should roll up 
from line items. Click the Define button and in the Formula 
Creation window, select the business processes and fields 
whose values should roll up to the manager sheet. You can 
select single fields to roll up, or you can add several fields 
together for a combined roll up amount. 

Data Format 

Specify how the column data appears for numeric columns. The 
options are: 

 Show as Percentage: Data entered in a column is 
displayed as a percentage. For example, if you enter 0.25, it 
displays as 25%. 

 Decimal Places: Select the number of decimal places to 
display (0 to 8). 

 Use 1000 Separator (,): If you select this option, the 
entered data is formatted with a separator for numbers with 
more than three digits. For example, 1,000 rather than 1000.

 Negative Number Format: Specify if negative values are 
displayed with a negative sign or in parentheses. 

Display Mode 
Select Hide to make the column invisible to users. Select Show
to display it. You can show/hide any column on the sheet, 
including the code name column. 

Summary Rows 

Specify what the summary rows display. 

 Blank: Summary row remains blank. 

 Sum of All Rows: Summary row displays the sum total of 
all row values for this column. 

 Use Formula Definition: Formula entered in the Formula 
field applies to the summary row. 

Total 

Specifies what displays in the bottom summary row for each 
column: 

Blank: Summary row remains blank. 

Sum of All Rows: Summary row displays the sum total of all 
row values for this column. 

Use Formula Definition: Formula entered in the Formula field 
applies to the summary row. 
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Column Position After Determines the position of the column on the sheet. 

To copy a column 

1) In the Column log, select a column and click Copy. 

2) The Column Properties window opens. Make changes as necessary for the new column. 
You must change at least the data source. 

View column properties 

The Properties window for a column maintains the column name, data source, entry method, 
and other properties for that column. 

To open the column properties window 

In the sheet, click on a column link. The View Column window opens, showing the data source 
from which the column values are gathered and the data entry method, including any formula 
used to calculate the values. 

Add a formula column 

You can add a formula column to the sheet for data sources that are based on either the data 
definitions SYS Numeric Logical Datasource or SYS Date Logical Datasource. 

You can define formulas for the following types: 

 Numeric: This option is available if the data source is SYS Numeric Logical. 

 Data Difference: This option is available if the data source is SYS Numeric Logical. It is 
used for formulas that calculate the difference between two dates. 

 Date Add: This option is available if the data source is SYS Date Logical. It can be used to 
add values to a date to calculate a new date. 

To create a numeric formula 

1) In the column Properties window, choose Formula and select Numeric. 

2) Click Create. The Create Formula window for numeric formulas opens. 

3) Select either Item or Sheet from the data type drop-down list. Item lists data elements that 
are defined on the form. Sheet lists columns that are already defined on sheet. 

4) Build a formula by doing the following: 

 To include a data source in the formula, select the data source from the list and click 
Select. 

 Click a mathematical modifier (plus, minus, and so on) and numbers on the keypad. 

5) When the formula is complete, click OK. 

To create a date difference formula 

1) In the column Properties window, choose Formula and choose Data Difference. Click 
Create. The Date Difference window opens. 
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2) For Earlier Date and Later Date, click Select. Select a data element. The list includes date 
type data elements from the form or existing date type columns on the sheet. 

3) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 

 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

 Show Partial Day

4) Click OK. 

To create a date add formula 

1) In the column Properties window, choose Formula and choose Data Add. Click Create. The 
Date Add window opens. 

2) For the Date field, click Select and choose a data element from the list. 

3) For the Add field, click Select and choose a data element from the list. 

4) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 

 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

5) Click OK. 

Open a sheet 

Manager sheets are listed on the Sheet log of the configurable manager. 

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

To open a sheet for a code-based manager 

1) Open the project or shell in which the manager resides and click Configurable Modules in the 
left Navigator. The Navigator expands to display the configurable managers that have been 
created for this project or shell. 

2) Select the configurable manager you want to work in. Unifier displays the sheets log. 

3) On the sheets log, double-click the name of the sheet. Unifier opens the sheet. 

To open a sheet for a code-and-record-based manager 

1) Open the project or shell in which the manager resides and click Configurable Modules in the 
left Navigator. The Navigator expands to display the configurable managers that have been 
created for this project or shell. 

2) In the Navigator, click the name of the manager you want to work in. The Navigator expands 
to display a Sheets node. 

3) In the Navigator, click the Sheets node. Unifier displays the sheets log, listing a sheet for 
every class created for the manager. 
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4) On the sheets log, double-click the name of the sheet. Unifier opens the sheet. 

View record details 

To view the details of a listed record, click the record. A view-only window opens displaying the 
record details. 

View sheet properties 

The Properties window for the sheet maintains the name and display options. It can be used to 
map a column to a company account code. 

To open the sheet Properties window 

In the Sheets log, select the sheet and click the Properties button. 

 The General tab is described in the following table. 

 In the Options tab, sheet columns can be mapped to company account codes. 

Expand or collapse the sheet rows 

For convenience in viewing sheet data, you can expand and collapse the rows to expose and 
close sub-items on the sheet. 
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Drill down to more data 

From the sheet, you can use hyperlinks to drill down to additional detail about the item. 

View or edit code details 

Each row item on the sheet is identified by a code, which is in the first column on the sheet. The 
code is hyperlinked. If you want to see more details about a row item, click Link. 

Code-based manager and record-based manager

Unifier displays a read-only copy of the Detail form, or the Attribute form, for that item. You 
cannot edit the displayed form because the manager retrieves the information from the records 
that have been created, automatically. 

The sheet for a code-based manager is designed to be dynamically editable, so you can edit the 
fields that are not read-only (grayed out).  For a code-based manager, Unifier displays the Code 
Details window which shows the fields from the manager Attribute form. Note that the "Code" 
field is not editable. 

If the field appears as a column on the sheet, any changes that you make to the field (in the 
Code Details window) will appear on the sheet. Reciprocally, any changes you make on the 
sheet will also appear on the Code Details window, for the item. 
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View rollup data 

For code-and-record-based managers, BP line item data, such as costs and quantities, can be 
configured to roll up to the manager sheet from across shells. Cells that contain rolled-up data 
will show a hyperlinked value. You can click on this hyperlink to open a cell details window and 
view all the business process transactions that contributed to the rollup. 

Sort the sheet content 

If the manager sheet is in flat mode (that is, it lists the codes in a flat structure, rather than 
hierarchically), you can sort the content on the sheet by column. By default, Unifier shows 
column data in ascending order. 
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To sort column data 

Click the column heading. Unifier will re-display the data in that column in descending order. To 
return the column data to ascending order, click the heading again. 

Filter the sheet content 

Some managers, particularly those configured to function across shells, can accumulate a 
substantial amount of data. To make viewing this data easier, you can create filters to restrict the 
content of the sheet. 

To create a filter 

1) Open the sheet. 

2) From the View menu, choose Filters.... The Setup Filters window opens. 

3) Click the Add button. The Add Filter window opens. 

4) In the Filter Name field, enter a name for this filter. 

5) Click the Add button. The Query Condition window opens. 

6) In the Data Element field, enter the name of the field you want to appear on the manager 
sheet. 

The values in the field must meet a condition (such as "equals" or is "greater than") to be 
included on the sheet. 

Depending on the data element you enter, the Query Condition window will display variable 
fields. 

7) Click OK, or click Apply Filter to filter the sheet content. 

To apply a filter to a sheet 

1) Open the sheet. 

2) From the View menu, choose Filters.... The Setup Filters window opens, showing a list of 
the filters that have been created for the sheet. 

3) Select the filter you want to use and click Apply Filter. 
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Unifier displays a filtered view of the manager sheet. While in a filtered view, you can use all 
sheet functions except Export and Import. 

If you want to re-display all the rows on the sheet, you can clear the filter by choosing 
ClearFilters from the View menu. 

To edit a filter 

1) Open the sheet. 

2) From the View menu, choose Filters.... The Setup Filters window opens, showing a list of 
the filters that have been created for the sheet. 

3) Select the filter you want to edit and click Edit. 

Enter sheet data 

For manual data-entry columns, you can enter data directly into the sheet. 

To enter data on a sheet 

1) Open the sheet. 

2) Click inside a manual-entry cell and enter the data. 

3) Click Save. 

Edit sheet data 

You can perform some editing on the sheet itself. Columns are designated with an entry method 
when they are added to the sheet. If the column specified "manual entry," you can enter data 
directly into that column on the sheet. If you change a field value on the sheet, Unifier will also 
change the field on the item’s attribute or detail form. 

Note: The name of the row item is always editable. The code, however, 
is never editable. 

To enter data on a sheet 

1) Double-click inside a manual-entry cell. Unifier will highlight the cell data and open a text 
box. 

2) Enter the data in the text box and click Save. 

Create and view a snapshot 

You can take a snapshot of a sheet to keep as a record and view later. 

To create a snapshot 

1) Open the sheet. 

2) Select File > Create Snapshot. The Create Snapshot window opens. 

3) Enter a title and click OK. 

To view a saved snapshot 

1) Open the sheet. 
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2) Select View > Snapshot Log. The Snapshot log opens. 

3) Select a snapshot from the list and click Open. A read-only view of the sheet opens, 
displaying the sheet data at the time of the snapshot. 

Copy data to another column 

You can copy data from one manual-entry column to another. 

To copy data from one column to another 

1) Select Edit > Copy > Column Data. The Copy Column Data window opens. 

2) Select the manual-entry column to copy, the percentage value, and the column to which to 
copy. 

3) Click Copy. 

Search for records on a sheet 

To search for records: 

1) Open the sheet. 

2) Click Find. The Find window opens. 

3) Select the search criteria: 

 Column: Choose a column from the sheet. 

 Value: Enter a value to search. 

 Search: Select the direction to search from the selection on the sheet. 

4) Click Find Next to search for the entered value. You can click again to continue searching. 

5) Click Cancel to cancel the search. 

Export sheet data 

You can export data from columns that have been manually entered to a CSV file. The data is 
for reference only and cannot be re-imported. 

To export columns from a sheet 

1) Open the sheet. 

2) Click the Export button and choose Codes (for code-based managers only) or Column 
Details. 

3) Select the columns to export and click OK. 

4) Save the CSV file to your local drive. 

Import sheet column data 

You can enter data into manual-entry columns by importing a CSV sheet. The column must be 
configured on the record detail form to accept numeric data elements. 
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To import column data 

1) In the CSV file, enter data for each listed record. Be careful not to change the CSV file 
structure. 

2) Save the CSV file. 

3) Open the sheet to which you want to import the data. 

4) Click the Import button and choose Codes (for code-based managers only) or Column 
Details. 

5) Browse to the CSV file containing the column data and click OK. 

Note: You cannot delete summary rows from the sheet using a CSV 
import. You also cannot delete existing rows using CSV import if their 
codes have been added to business processes. 

Working with Configurable Manager Sheets (Standard View) 

The configurable managers are nested under the Configurable Modules as shown below:  

Configurable Modules

 <name> Manager [Code-based configurable manager] 

 <name> Manager [Code- and record-based configurable manager] 

 Sheets 

 Class 

The following explains applicable actions for each sub-node. 

Add Columns or Rows to a Sheet 

The following explains how to add columns or rows to a sheet, where applicable.  

Configurable Modules: <name> Manager [Code-based configurable manager] 

Note: You must have the "Create" permission in order to proceed with 
adding columns or rows. 

To add columns to a code-based configurable manager sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 
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3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side). 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) From the toolbar options, click Add Column (the icon with three vertical lines)  to 
open the Add Column window. 

6) Enter values in the fields that are displayed. 

7) After you are finished, select one of the following options: 

a. Cancel: To cancel the changes and close the window. 

b. Save: To save your work for creating a new column. 

c. Save & Add New: To save your work and begin creating a new column. 

To add rows to a code-based configurable manager sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side). 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) From the toolbar options, click Add Row (the icon with three horizontal lines)  to open 
the Add Row window. 

6) Enter values in the fields that are displayed. 

7) After you are finished, select one of the following options: 

a. Cancel: To cancel the changes and close the window. 

b. Save: To save your work for creating a new row. 

c. Save & Add New: To save your work and begin creating a new row. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

Note: You must have the "Create" permission in order to proceed with 
adding columns. You cannot add rows. The columns can capture data 
from business processes or manually entered data. 

To add columns to a Code- and record-based configurable manager sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 
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3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

6) From the toolbar options, click Add Column (the icon with three vertical lines)  to 
open the Add Column window. 

7) Enter values in the fields that are displayed. 

8) After you are finished, select one of the following options: 

a. Cancel: To cancel the changes and close the window. 

b. Save: To save your work for creating a new column. 

c. Save & Add New: To save your work and begin creating a new column. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

You can create new <name> Manager [Code- and record-based configurable 
manager]-Class, only. 

Fields 

The following details some of the fields: 

In this field: Do this: 

Name 
The Name field is populated with the data source value 
selected. 

Datasource 

Select a data source. The data sources available are data 
elements that are defined in the detail form for a class in 
uDesigner. Also listed are data elements based on SYS 
Numeric Logical Datasource, SYS Date Logical Datasource,
SYS Project Cost Datasource, SYS BP Currency Amount, 
SYS BP Decimal Amount, and SYS BP Integer Amount data 
definitions. 

Note: You can add data picker fields as columns, but you 
cannot invoke the data picker from the sheet. 

Type  

Data Format 

Specify how the column data appears for numeric columns. The 
options are: 

 Show as Percentage: Data entered in a column is 
displayed as a percentage. For example, if you enter 0.25, it 
displays as 25%. 

 Decimal Places: Select the number of decimal places to 
display (0 to 8). 
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 Use 1000 Separator (,): If you select this option, the 
entered data is formatted with a separator for numbers with 
more than three digits. For example, 1,000 rather than 1000.

 Negative Number Format: Specify if negative values are 
displayed with a negative sign or in parentheses. 

Display Mode 
Select Hide to make the column invisible to users. Select Show
to display it. You can show/hide any column on the sheet, 
including the code name column. 

Summary Rows 

Specify what the summary rows display. 

 Blank: Summary row remains blank. 

 Sum of All Rows: Summary row displays the sum total of 
all row values for this column. 

 Use Formula Definition: Formula entered in the Formula 
field applies to the summary row. 

Total 

Specifies what displays in the bottom summary row for each 
column: 

Blank: Summary row remains blank. 

Sum of All Rows: Summary row displays the sum total of all 
row values for this column. 

Use Formula Definition: Formula entered in the Formula field 
applies to the summary row. 

Column Position After Determines the position of the column on the sheet. 

You cannot copy a column.  

View Column Properties 

The following explains how to open the column properties for each configurable manager.  

Configurable Modules: <name> Manager [Code-based configurable manager] 

To view the column properties: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side). 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) In a column click on a cell that has a link. The screen will divide in half and the lower portion 
of the screen displays the following tabs which provide details about the cell: 

 General

 Audit Log

 Transactions

 Cell Details
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Use the Expand and Dock icons  to adjust the 
display. 

To close an expanded screen double-click on the three dots, on the boarder of the two screens. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To view the column properties: 

1) Go to your <name> Code- and record-based configurable manager]-Sheets. The log 
displays a list of sheets. 

2) In a column click on a cell that has a link. A new window opens and the screen will divide in 
half. The properties pane (right-hand side of the window) contains the following tabs which 
provide details on each cell: 

 Comments

 Linked Records

 Linked Mail

 Audit Log

Click Maximize icon  to expand the properties pane. To minimize click the icon again. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To view the column properties: 

1) Go to your <name> Manager [Code-based configurable manager]-Class. The log 
displays a list of sheets and the corresponding properties (on the right-hand side). 

2) Double click on the sheet to open the sheet log window that displays the columns. 

3) In a column click on a cell that has a link. The screen will divide in half and the lower portion 
of the screen displays the following tabs which provide details about the cell: 

 General

 Audit Log

 Transactions

 Cell Details

Use the Expand and Dock icons  to adjust the 
display. 

To close an expanded screen double-click on the three dots, on the boarder of the two screens. 
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Open a Sheet 

Manager sheets are listed on the sheet log of the configurable manager.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

To open a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side). 

4) Double click on the sheet to open the sheet log window that displays the columns. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To open a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To open a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the class sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Class) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 
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View Record Details 

To view the details of a listed record, click the record. A view-only window opens displaying the 
record details.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

To view record details: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side), Properties tab. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To view record details: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. 

5) Click on a record to see the corresponding properties (on the right-hand side), Properties
tab. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To view record details: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the class sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Class) to open the log. 

5) Click on a record to see the corresponding properties (on the right-hand side), Record 
Details tab. 
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View Sheet Properties 

The following explains how to view the properties of a sheet.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

To view the properties of a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side), Properties tab. 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) Click the Menu Options drop-down icon  and select Properties. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To view the properties of a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. 

5) Click on a record to see the corresponding properties (on the right-hand side), Properties
tab. 

6) Double click on the sheet to open the sheet log window that displays the columns. 

7) Click the Menu Options drop-down icon  and select Properties. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To view the properties of a sheet: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 
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3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the class sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Class) to open the log. 

5) Click on a record to see the corresponding properties (on the right-hand side), Record 
Details tab. 

Create and View a Snapshot 

You can take a snapshot of a sheet to keep as a record and view later.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

You cannot create a snapshot. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To create and view a snapshot: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node ( <name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

6) Click the Menu Options drop-down icon  and select Snapshots. 

7) Select one of these options: 

a. Create

When you select Create, the Save As Snapshot New window opens which enables you 
to create a snapshot by entering the snapshot title and clicking OK. 

b. Open

To open and view an existing snapshot, if available. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

You cannot create a snapshot. 
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Export Sheet Data 

You can export data from columns that have been manually entered to a CSV file. The data is 
for reference only and cannot be re-imported.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

To export sheet data: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side), Properties tab. 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) Click the Menu Options drop-down icon  and select Export. 

6) Select one of the following options: 

a. Codes

To export a Microsoft Excel Comma Separated Values File. 

b. Column Data

To export column details. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To export sheet data: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node (<name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

6) Click the Menu Options drop-down icon  and select Export. 

7) Select one of the following options: 

a. <sheet name> Summary Sheet

To export a Microsoft Excel Comma Separated Values File. 
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b. Column Data

To export column details. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To export sheet data: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the class sub-node (<name> Manager [Code- and record-based configurable 
manager]-Class) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

6) Click the Actions drop-down icon  and select Export CSV Template.... 

7) Follow the prompts to complete the export. 

Import Sheet Column Data 

To import column data 

1) In the CSV file, enter data for each listed record. Be careful not to change the CSV file 
structure. 

2) Save the CSV file. 

3) Open the sheet to which you want to import the data. 

4) Select Menu Options.

5) Click the Import button and choose Codes (for code-based managers only) or Column 
Details. 

6) Browse to the CSV file containing the column data and click Import. 

Note: You cannot delete summary rows from the sheet using a CSV 
import. You also cannot delete existing rows using CSV import if their 
codes have been added to business processes. 

You can enter data into manual-entry columns by importing a CSV sheet. The column must be 
configured on the record detail form to accept numeric data elements.  

Note: You must have permissions to access a sheet. If you need access 
to a sheet not listed in the log, contact your company administrator. 

Configurable Modules: <name> Manager [Code-based configurable manager] 

To import sheet data: 

1) Go to your shell or project in User mode. 
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2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code-based configurable manager (<name> Manager [Code-based 
configurable manager]). The log displays a list of sheets and the corresponding properties 
(on the right-hand side), Properties tab. 

4) Double click on the sheet to open the sheet log window that displays the columns. 

5) Click the Menu Options drop-down icon  and select Import. 

6) Select one of the following options: 

a. Codes

To import by opening a local folder and selecting a file. 

b. Column Data

To import column details. 

Configurable Modules: Generic Cost Manager 

For details see Working with a Generic Cost Manager (on page 363). 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Sheets 

To import sheet data: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the Sheets sub-node (<name> Manager [Code- and record-based configurable 
manager]-Sheets) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 

6) Click the Menu Options drop-down icon  and select Import. 

7) Click Column Data to import column details. 

Configurable Modules: <name> Manager [Code- and record-based configurable 
manager]-Class 

To import sheet data: 

1) Go to your shell or project in User mode. 

2) From the left Navigator, click Configurable Modules node to expand. 

3) Click your code- and record-based configurable manager (<name> Manager [Code- and 
record-based configurable manager]) to expand. 

4) Click the class sub-node (<name> Manager [Code- and record-based configurable 
manager]-Class) to open the log. The log displays a list of sheets. 

5) Double click on the sheet to open the sheet log window that displays the columns. 
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6) Click the Actions drop-down icon  and select Import to open the Upload CSV
window and select a file. 

Working with Configurable Manager Logs (Standard View) 

The following topics describe how to use configurable manager sheets in Standard view. In 
particular, this section explains how to access, review, and create both code-based and code- 
and record-based configurable managers. 

Code-Based Managers Log (Standard View) 

The code-based configurable manager log is divided into two panes, left and right. The following 
explains the left pane elements of the log in details. 

Left pane elements: 

 Toolbar: Create

This option is available if a sheet has not been created. Once you create a configurable 
manager sheet, then there are will be no toolbar options. 

 Column: Title, Description, and Last updated

Right pane elements: 

This right pane is blank for an empty log. When you create a sheet, the right pane displays the 
Properties tab that captures the details of the sheet. 

 Properties tab 

 Title

 Description

 Display Mode

 Default Filter View

 Picker

 Segments

 Expand toggle key 

To expand the tab window. 

Creating a Code-Based Configurable Manager (Standard View) 

You can use the Create option to create a code-based configurable manger sheet; 

 Manually

Read the process for manually creating a sheet, below. 

 From Template
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This option enables you to create a configurable manager from a template. The From 
Template option is available only if one or more configurable manager templates are defined 
at Company Workspace (admin mode). If no templates are defined, then this menu option 
will not be available. If you do not have create permission, this option is disabled. In this 
scenario, you can access rows or create more rows irrespective of the way that a sheet is 
created, manually or by template. 

you cannot modify the segment sources. Creating as sheet by way of a template enables you 
to access the sheet rows. 

 From Shell

When you click this option, Unifier opens a window which lists all the sheets that can be 
copied from other shells that the administrator has created. 

To create a code-based configurable manager sheet manually: 

1) Click Create and click Manual to open the create sheet window. 

2) In the Properties tab, enter the values. You can also edit existing values in the Properties 
tab, for example, change the Picker field value from All Records to records with their 
statuses set as "Active," "InActive," or both in the Records with statuses field. 

The Default Filter View drop-down field does not have any values when you create a new 
sheet. This field has a value for an existing sheet and can be changed. 

3) Click the Segments tab and add segments. 

You can add multiple segments by clicking the plus icon (+). When you click the plus icon 
(+), Unifier inserts a new row on the grid. Once you add a row, you must click the cell under 
the Segment Source label and select a source, which has been designed in uDesigner. You 
can use drag-and-drop to move the segments. To delete a segment click on the segment row 
and click the delete option (trash can icon). The Segments tab has a grid that is similar to 
the grid and fields of the Line Items in BPs. 

4) When finished, from the top, click Save. 

5) Click Save on the create sheet window. 

Code- and Record-Based Managers Log (Standard View) 

Sheets 

The sheets log is divided into two panes, left and right. The following explains the left pane 
elements of the log in details. 

Left pane elements: 

 Toolbar: Create, Find on Page, and Print

Empty log has one option on the toolbar: Create.  

A non-empty log, in which sheets for all classes within the manager have not been created, 
has three options on the toolbar: Create, Find on Page, and Print.  

A log in which sheets for all classes have been created shows the options: Find on Page, 
Print.  

 Columns: Title, Description, Class, and Last updated

Right pane elements: 
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This pane is blank for an empty log. When one or more sheets have been created, this pane 
shows a tab that captures the properties of a selected sheet. 

 Properties tab 

 Title

 Description

 Class

 Display Mode

 To determine how the entries in a sheet are going to be displayed. 

 Default Filter View

 Picker

 Expand toggle key 

To expand the tab window. 

Class 

The class log is divided into two panes, left and right. The following explains the left pane 
elements of the log in details. 

Left pane elements: 

 Toolbar: Create, Actions, View, Edit View, Refresh, Print, Search, Find on Page, and 
Help

 Column: Attachments and class-related titles 

Right pane elements: 

 Record Details tab which displays all the details related to the highlighted class. 

 Expand toggle key 

To expand the tab window. 

 Tooltip 

If an attribute form is present, then you can hover over the question mark (?) symbol to see 
more information in the form of a tooltip.  

You can: 

 The Actions option to perform: 

 Import 

 To import CSV file in order to create records in bulk. 

 Export CSV Template  

 Same as: Export Template > CSV. To export a CSV template. 

 Bulk Edit. 

 You must have permission to perform a bulk edit (similar to the same option in the 
non-Workflow BP record log). 

 Print the log based on the current view. This would output a report similar to a UDR. You can 
use the print functionality to print the CM Class log. When you click Print, Unifier displays a 
Print Preview in HTML format. 
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 The layout of the printed information is based on the view. This means that the column order, 
columns displayed, applied filtering conditions, etc. will all be printed. You can print all 
pages. 

Note: If you select a record and the record summary is displayed, this 
information will not be included as part of the log print. 

 Select the order of the columns in the log and define which columns must be visible. 

 Sort on one or many columns within the log. 

 Search the parameters displayed on the search window have all been configured in 
uDesigner. Search user interface and logic is similar to the search function in the 
non-Workflow BP record log). 

 Group based on one column, or up to 3 columns, and define how the groups are sorted and 
how rows are sorted within the groups. 

 Apply filters to individual columns. 

 Lock columns so that they are fixed on the left-hand side and the remaining columns scroll 
on the right-hand side. 

 The Help option to view the CM Class specific help, which has been set up by the 
Administrator. The tool tip for this icon are: 

 <Class Name> help 

 User Productivity Kit 

 Use the gear menu ( ) for each record to: 

 Open 

To open a record. 

 Copy 

To copy a record. 

 Print-HTML 

 Print-PDF 

 Print-Custom 

The system default for viewing Code- and Record-Based records is All Records. You others 
option are: 

 Records Created by Me

 Create New View

You can create new views by clicking the Create New View... option. Similar to the Tasks 
log view creation, the New View window has the following tabs: 

 Columns 

 Filters 

 Group By 

 Sort By 

 Manage Views

Use Manage Views to manage the user-defined views and the default views (OOTB). 

Note: Certain restrictions are placed for the view options provided in the OOTB. 
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Note: Unifier uses the Classic view of the log (of the CM class) for the 
view definition. 

The views, based on the designs, provide the following information: 

Columns: The column layout, based on the uDesigner layout. 

Sort By: Based on the Sort Order, in the uDesigner Sort Order. 

Find: All search parameters in the Find are in the Filter page of the view. 

Navigation: The Unifier Standard view does not display the navigation structure elements that 
are defined in uDesigner. 

CM Class Record 

You view the CM Class record summary from the logs. 

Visibility of the panel

The Panel is displayed when you select a record. 

The details in the panel is available only when a single record is selected. 

When multiple records are selected, the panel displays the following content: 

Details of multiple records cannot be viewed. 

Content displayed in the Panel

The detail form of the CM Class attribute. 

The Panel consists of one tab: Record Details. 

Use maximize option to view the record details in the full screen mode. When the full screen 
mode is active, the screen occupies the right-hand section. Click minimize to return to the 
previous screen. 

The record details contain the layout, block description, etc. This option is available in View 
only mode. 

The picker type fields are displayed with just the values. There will be no hyperlinks. Click 
maximize to view this in an expanded form. 

Group By row highlighted

When Group By row is highlighted, then the right-hand section does not display any details. 

When you click the CM Class log, a log similar to the log of a non-Workflow BP record appears. 
You can double-click a record to open it. The following explains the log options. 

Columns 

As set of pre-designed columns and labels. You can adjust the columns in the log as follows: 

 Visibility 

Right-click on the column header and select to hide the column. 

 Reposition 

Drag and drop. 

 Resize 
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Unifier keeps your adjustments without saving. 

 Locking 

Use the view option. 

Note: When you adjust the columns in the log, you modify the view 
settings. Unifier does not save your view automatically, except where it 
is noted. You can save the view using the "Save as" option. Unifier 
saves the column width adjustments that are made on top of the default 
settings (in uDesigner); however, you can change the width of a column. 

The column marked with the "x" icon captures the errors if you attempt to save the grid with 
incorrect entries. This function is similar to the errors column in the BP Detail Form grid entry. 

Row Number: This is a read-only column. This column does not have a header. As you insert 
new rows, delete rows, or reorders rows, the row numbers throughout the grid gets updated 
accordingly. 

Segment Source: This is an editable, type-ahead and drop-down field. The drop-down values 
are the same as in the Classic view. 

Delete Row: This column does not have a header. This column displays a delete icon for each 
row. Clicking at the icon deletes the selected row. 

Drag Row: This column does not have a header. This column displays the reorder icon. You can 
select multiple rows and drag them to another position. 

Creating a New Code- and Record-Based Configurable Manager Sheet (Standard View) 

You can use the Create option to create a new code- and record-based sheet by way of the 
following methods: 

 Manually

Read the process for manually creating a sheet, below. 

 From Template

This option enables you to create a configurable manager from a template. The From 
Template option is available only if one or more configurable manager templates are defined 
at Company Workspace (admin mode). 

 From Shell

When you click this option, Unifier opens a window which lists all the shells that the 
administrator has created. You can copy a configurable manager sheet from a shell that is 
listed. 

To create a code- and record-based sheet manually: 

1) Click Create and click Manual to open the create sheet window. 

2) In the overlay, enter the values. You can also edit existing values in the Properties tab, for 
example, change the Picker field value from All Records to records with their statuses set 
as "Active," "InActive," or both in the Records with statuses field. 

The Default Filter View drop-down field does not have any values when you create a new 
sheet. This field has a value for an existing sheet and can be changed. 
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3) When finished, from the top, click Save. 

4) Click Save on the create sheet window. 

You can use the Create option to create a new code- and record-based class. 

Bulk Editing Configurable Manager Records 

If you have a large number of records that need the same edits, you can use Bulk Edit to 
update all the records at once. You can update up to 200 records at a time. Bulk editing must be 
defined in uDesigner, and you must have the Allow Bulk Edit permission set for the manager. 

Note: You cannot bulk edit codes or names. 

To update records using bulk edit 

1) Navigate to the Configurable Manager log. 

2) Select one or more records or use Find to search for a group of records with specific criteria. 
You can select the records from the class log or the Find log. 

3) Select Edit > Bulk Edit. The Bulk Edit window opens. The fields displayed depend on what 
is specified in uDesigner for detail form integration for the class. 

Note: Bulk edits overwrite data without asking you to verify each change. 
Be sure that you have entered the data you want to edit correctly. 

4) The Bulk Edit form includes all editable fields for the detail form. Modify the Bulk Edit form as 
needed. 

5) Select the Update checkbox for the fields that you want to update. The checkbox is 
automatically selected when you type in a field. You can deselect it if you do not want to 
modify the field. 

6) To start the bulk update of the selected records, click Update. The Bulk Actions Status 
window displays the progress of the update. 

7) Click OK after all records have processed. Click Cancel if you want to cancel the bulk 
update in progress. 

Printing a Configurable Manager Form 

You can print a copy of the record form for Code-based manager and record-based manager. 
You can choose PDF, HTML or Custom print formats and select one of the following options: 

 Save a copy of the form as a PDF file and print the file 

 Print an HTML view 

 Print from a Word file if a custom print layout has been created for the form 

The Custom Print formats include the BI Publisher custom print templates designed in the 
Custom Templates node. If custom print layouts have been created for the Configurable 
Manager, the form will print according to the layout that you select. See the following Custom 
Format Print Options for details. See the following Printing Options - Custom Format for 
details. 
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To preview and print a Configurable Managers form: 

1) Open a Configurable Managers record that you want to print. 

2) From the File menu, choose Print Preview, then choose one of the following: 

 HTML to view the form in the browser which can then be printed. 

 PDF to open the form in Adobe Reader, which can be saved or emailed as a PDF file, or 
printed process, you are asked to save the changes to the form. 

 Custom to select the BI Publisher, Microsoft Word, and PDF custom print templates from 
the same place as the current custom prints. See the following Printing Options - 
Custom Format for details. 

The Print Options window opens. This window displays the record information that can be 
printed. 

3) Select the checkboxes for the information that you want to print. 

4) To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the 
SelectAll checkbox. If you deselect all checkboxes, only the header and footer will print. 

5) Click OK. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, 
from which you can print. 

If you chose PDF, you can save a copy by clicking the Save a Copy button, or print. To print 
from HTML format, click on the Print icon in the upper right corner. 

Print Options for Configurable Manager Form 

The following summarizes print options. 

Print option What it prints 

Detail Form This prints the information entered on the form. 

General 
Comments 

The general comment text and create details are printed. 

Record 
Attachments 

File attachments to the record are listed alphabetically by file name, 
and also include the file title, issue date, revision number, and file 
size. 

Note: For BI Publisher template the sorting is done in the template; 
as a result, the alphabetical list of file names may not always apply.

Record 
Attachments > 
Comments 

Prints comments associated with file attachments to the record. 
"Record Attachments" must also be selected to select this option. 

Record 
Attachments > 
Comments > 
Attachments 

List of file attachments attached to the comment are listed and 
contain the file title, issue date, revision number, and file size. 

To print a Configurable Managers form with a custom print layout: 

1) Open the form that you want to print. Be sure it is in a view mode. 
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2) From the File menu, choose Print Preview, then choose Custom to select the BI Publisher, 
Microsoft Word, or PDF custom print templates from the same place as the current custom 
prints (Custom Format Print selection window). 

3) Select a layout and click Ok. The File Download window opens. 

Notes: 

 In case of the BI Publisher templates, you can select an output format 
and based on that selected output format the output file is generated. 
The output file appears in a new window. 

 In case of the PDF format, the output is a .pdf file and is displayed in 
a new window and save. 

 In case of the RTF format, the output is a .rtf file and you can open 
the .rtf file with Microsoft Word and save. 

 In case of the Excel format, the output is a .xls file and you can open 
the .xls file with Microsoft Excel and save. 

Custom Format Print Options for Configurable Manager 

The Custom Format Print Window for non-Workflow Configurable Manager forms has two 
sections: 

 Select a custom print template 

 Select a template and format to print 

Both sections facilitate custom print template and format selections. 

Select a custom print template

Lists all the custom print templates existing for the non-Workflow Configurable Manager forms, 
including the custom print templates created in the Custom Templates node and the custom 
print templates created in the configuration of the non-Workflow Configurable Manager forms. 
For example, the list may include BI Publisher custom print templates, Word, and PDF custom 
print templates.  

If there are multiple custom print templates for the same non-Workflow Configurable Manager 
forms, all the published templates are listed in this section.  

The "Select a template and format to print" is populated by the selection made in the "Select a 
custom print template" section.  

Select a template and format to print

 If you select a BI Publisher custom print, then you can select the desired template and 
format from the drop-down lists. 

 Template drop-down displays all the available templates for the selected format.  

 Format drop-down displays the available formats for the selected template. 

 If the custom print template was created using PDF or Word, then the "Select a template and 
format to print" is disabled. 

Default template and format (non-Workflow)
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 If a BI Publisher print template is selected, then the default values in the drop-down lists are 
set based on the default in the custom print template.  

 When a BI Publisher print template is selected in the "Select a custom print template" 
section, the template and format are populated based on the default value selected at the 
time of designing the print template. 

Custom Format Print Window for Workflow Configurable Manager forms 

If there is only one custom print template, and it happens to be a BI Publisher template, then the 
print template is selected in the “Select a custom print template” section, and the template and 
format are populated based on the default value selected at the time of designing the print 
template. 

The Custom Format Print window has three sections for Workflow Configurable Manager forms. 

 Select a custom print template 

 Select a template and format to print 

 Select options for Workflow Progress 

By default, when the Custom Format Print window is launched, all three sections are enabled 
and the first template is selected. The options seen in the subsequent sections are based on the 
selection made in the "Select a custom print template" section. 

You are able to select options for workflow progress in the 'Select options for Workflow 
Progress" section of the Custom Format Print window for PDF and Word templates, which are 
created at the time of configuring the Workflow Configurable Manager forms.  

If the selected custom print template is of a BI Publisher type, then the “Select options for 
Workflow Progress” section is disabled. This is because the custom print template designers can 
always use the system provided Workflow views to include workflow-related information in the 
template. 

Default template and format (Workflow)

 When a BI Publisher print template is selected in the "Select a custom print template" 
section, the "Select a template and format to print" section is populated based on the default 
value selected at the time of designing the print template. 

 If there is only one custom print template, and it is a BI Publisher template, then the print 
template is selected in the “Select a custom print template” section, and the template and 
format is populated based on the default value selected at the time of designing the print 
template. 
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Unifier Cost Manager 

The Cost Manager consists of the modules and features listed below. 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 

In This Section 
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Accounts Sheet 

The company accounts sheet is used to track company level accounts information, such as 
assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using 
account codes instead of CBS codes. 

Cost Sheets 

Project/Shell Cost Sheet: The project or shell cost sheet is a detailed accounting of the 
project’s or shell’s budget and costs. It works much like a spreadsheet within Unifier that 
calculates and maintains the project or shell cost information stored in the project or shell. The 
project or shell cost sheet rows contain unique CBS codes (or cost codes), which can be used to 
link project or shell or program costs to the general ledger for finance. Cost information can be 
entered manually, pulled from work packages or worksheets, or rolled up automatically from 
business processes when transactions occur in Unifier. 

Project/Shell Cost Sheet Column Properties)

 The Datasource drop-down list contains a list of Single, Logical, and P6 datasources (only 
Published P6 Data sources as defined in the Standards and Libraries--Administration mode). 

 The Element drop-down contains a list of options as defined in the Cost Sheets Templates. 

 The Data Format option, Decimal, is selected for all the "Unit" fields that you have selected 
from the Element drop-down list. 

Note: The data sources do not list the P6 Summary Sheets in a Shell. 
Instead, the P6 Summary Sheets are from P6 Data Sources node, under 
Standards and Libraries. Unifier identifies the P6 Summary Sheet that is 
required for supplying data to the Cost Sheet by mapping the Summary 
Sheet "Type" to the column data source. 

Program Cost Sheet: Program cost sheets are created automatically once a project cost sheet 
has been created in at least one project within the program. The columns of the program cost 
sheet can be set up to allow cost sheet data to roll up automatically from individual project cost 
sheets. The program cost sheet will display cost data for all projects within the program that 
have a status of active or on hold. The currency used is the company base currency. Projects on 
the program cost sheet are sorted automatically by ascending project number. As new projects 
are added to the program, and cost sheets are created for them, the new projects will be 
automatically added to the program cost sheet. 

Company Cost Sheet: The company administrator can create a company-level cost sheet to 
display cost data across project or shells. Projects or shells on the company cost sheet are 
added by default as project- or shell-level cost sheets are created. Only active and on-hold 
projects or shells should be rolled up to a company-level cost sheet. Projects and shells are 
listed in order by project or shell number in an ascending order. Data rolls up to the company 
cost sheet columns from individual project or shell cost sheet columns by data source. The data 
displayed on the program cost sheet is view only. 

Company Workspace (Company Cost Sheet Column Properties)

 The Datasource drop-down list contains a list of Single, Logical, and P6 datasources (only 
Published P6 Data sources as defined in the Standards and Libraries--Administration mode). 
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 The Element drop-down list contains a list of available options. 

 The Data Format option, Decimal, is selected for all the "Unit" fields that you have selected 
from the Element drop-down list. 

Note: If the Base Currency is different from the Shell Currency, then the 
current "Active" Exchange Rate is used to display Costs in the Company 
Cost Sheet. 

If you add a P6 Source column to the Company Cost Sheet, the data is acquired from the 
corresponding P6 Source column of the Shells in the Company. 

Projects and Programs (Program Cost Sheet Column Properties)

 The Datasource drop-down list contains a list of Single, Logical, and P6 datasources (only 
Published P6 Data sources as defined in the Standards and Libraries--Administration mode). 

 The Element drop-down list contains a list of available options. 

 The Data Format option, Decimal, is selected for all the "Unit" fields that you have selected 
from the Element drop-down list. 

Work packages: In addition to a project or shell cost sheet, multiple work packages may also be 
defined. A work package is a group of cost sheet rows that is a subset of the project or shell cost 
sheet. Work packages provide insight into the budget without providing full access to the details 
of the project or shell cost sheet. 

Worksheets: Cost worksheets can be created to support the project or shell cost sheet. They 
can be used as sub-cost sheets, enabling specific calculations or data entry in a separate sheet, 
which can then be rolled up into a defined project or shell cost sheet column. For example, a 
worksheet can be used to offload complex calculations, which can be rolled up into a single cost 
sheet column. Worksheets support manual data entry and formulas. Business processes do not 
roll up to worksheets. Permissions can be controlled for individual worksheets. Worksheets are 
not independently reportable; however, cost sheet columns that reference worksheets can be 
reported on. 

Notes: For Base Commits, Change Commits, and Payment Application 
BPs of Summary Payment Application SOV type. 

 The Costed line items (in Base Commits, Change Commits, and 
Payment Applications with SOV type, "Summary Payment 
Applications BPs) roll up to the Cost Sheet by using the "Amount" 
field. 

 The Amount that rolls up to the Cost Sheet is the Costed Amount for 
each of the CBS codes that is added to the Cost Distribution grid. 

 If the Line Item Amount = Costed Amount, you will see a discrepancy 
between the Total Amount seen in the Record > Line Item section, 
and the rolled up Amount to the Cost Sheet. 

 You are able to go to the Line Item level details by opening the record 
in the Transactions section. 
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Funding 

Company funding sheets: The company funding sheet tracks all sources of funding across all 
projects or shells and programs. You create only one sheet per company. Funding sources that 
are made available at project or shell sheet level are rolled up to the company sheet, which 
maintains the overall fund information. Once created, the company funding sheet can be edited, 
but not deleted. The company funding sheet must be created before creating individual project 
or shell funding sheets. 

Project/Shell funding sheets: The project or shell funding sheet tracks how funding is being 
allocated and consumed at the project or shell level. Project or shell fund sheets work in 
conjunction with the company funding sheet. Allocating funding sources at project or shell level 
can be done manually or through a business process. A funding template and company funding 
sheet must be complete before you can create a project or shell funding sheet. 

Commitment funding sheets: You can optionally set up commitment level funding, which 
allows you to allocate specific project/shell funds to individual base commit records. This works 
in conjunction with the SOV sheet to track base and change commit lines and balances. 

Cash Flow Module and Cash Flow Curves 

Unifier Cash Flow module includes the ability to create the following multiple curves and 
compare them on one Cash Flow Worksheet: 

 Baseline

 Forecast

 Actual (or Spends)

 Portfolio Budget

 Derived

 Custom curves

You can create data source, distribution profiles, and cash flow curve templates to simplify 
creation of cash flow in multiple projects and shells.  

Administrators can also set up base commit business processes to automatically create cash 
flow curves for the commitment record at a particular workflow step, or for non-workflow 
business processes, when the record is complete. 

Note: The Cash Flow worksheet in Standard View shows a blank page 
on safari browser.  

Earned Value (EV) Module 

The earned value module provides quantitative tracking information about project or shell status 
using earned value analysis. It provides specific numerical measurements for reviewing progress 
as the project or shell team advances through the work tasks allotted to the project or shell 
schedule.  
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The module helps project or shell managers track whether projects or shells are on schedule 
and on budget. It provides accurate and consistent methods to estimate the percent of budget 
spent, percent of work done, and percent of time elapsed. 

See Earned Value (EV) (on page 317) section for more details. 

Schedule of Values (SOV) 

The Schedule of Values (SOV) module provides a way to assemble information from contract, 
change order and invoice/payment Business Processes into an Schedule of Values (SOV) 
sheet, streamlining the process of invoicing for completed phases of a Project/Shell. 

SOV functionality is available with uDesigner-created Cost BPs for which the Allow creation of 
SOV option is defined. The Business Processes can be designed to create an SOV sheet 
automatically upon reaching the designated step.  

The following is a list of Schedule of Values (SOV) sheet types: 

 General spends 

 Payment applications 

 Summary Payment Applications 

Generic Cost Manager 

The Generic Cost Manager captures non-CBS cost-related activities such as rent, lease 
payments, landscape care, building maintenance and repair, remodel of building interiors, and 
more. 

With this manager, you can capture and view cost transaction information based on a timescale, 
such as quarterly or yearly. Each shell can have one Generic Cost Manager. The Generic Cost 
Manager uses specific generic cost business processes as data sources. 

Cost Manager (Standard) 

The standard Cost Manager and the Generic Cost Manager work much the same way, but with 
different areas in Unifier. This table lists the areas and the indicates which cost manager works 
with each area. 

The cost data from Project (Standard) and Shell (CBS) can both roll up to the Company level. 
The cost data from Shell (Generic) does not roll up to Company Level. See the Working with a 
Generic Cost Manager (on page 363) section for more information about Generic Cost 
Manager. 

Cost Manager Company Program 
Project 
(Standard) 

Shell (CBS) Shell (Generic)

Cost Manager (for 
CBS codes) 

X X X X 
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Generic Cost 
Manager 

X 

The Generic Cost Business Process works with the Generic Cost Manager, in the context of a 
Shell, only. See the Working with Generic Cost Business Processes (on page 369) section 
for more information about Generic Cost Manager. 

Rules and Rule Exceptions 

Unifier employs a rules engine to help control costs as they roll up to the Cost Sheet. Your 
administrator creates rules to work with the rules engine. For example, your administrator might 
create a rule that enforces a budget limit on contracts so that invoices do not exceed the 
contract amounts. 

When a cost exceeds a rule, it triggers a "rule exception," and Unifier displays a message 
window warning you of the exception. The window shows the level of the rule, an identifier, the 
rule that was exceeded, the current value of the field, and the value that triggered the rule 
exception. 

Rule exceptions can be triggered by: 

 Adding or copying a line item on the Cost Sheet 

 Copying data from one column to another on the Cost Sheet 

 Entering data directly into a cell on the Cost Sheet 

 An email action that sends cost data to the sheet 

 An integration transaction that sends cost data to the sheet 

 I Step and S Step business process auto-creation 

 A business process record that rolls up cost data to the sheet 

Some users can override a rule violation. These users are specified when the administrator 
creates the rule. These users can choose to override the exception, or accept it. 

If you override the rule exception, Unifier sends your user information and any comments you 
include to the audit log. If notification was specified when the rule was created, those users who 
were designated will be notified by email of the override. 

If you accept the rule exception (click Cancel), you will stay on the current step. 

Note: Unifier does not display the rule exception warning if the cost data 
comes from an email action, an integration transaction. If you have 
override control, Unifier will assume that you want to override the rule 
and sends information to the audit log. 

When your Administrator creates a rule template:  

 If the checkbox Include positive pendings in calculation is selected, then Unifier adds the 
positive pending values when calculating the Limit Expression. 

 If the checkbox Include positive pendings in calculation is selected, then Unifier adds the 
negative pending values when calculating the Data Expression. 

Note: Your Administrator can check both options or either one, when 



Working with Unifier Managers

77

creating a rule template. 

The rule is implemented during runtime (as a cost type BP is routed in its workflow or is Finish 
Edited) and according to your choices. 

Using Cost Manager 

The Cost Manager consists of the modules and features listed below. 

 Cash Flow Curves

Cash Flow is the distribution of cost over time; in other words, it is the movement of cash into 
or out of a project measured during a specific time period. Unifier displays this data using 
Cash Flow Worksheets that can display Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves. 

 Cost Sheet

Cost Sheet captures data from data sources, such as cost code data values, budget, 
business processes by status, and manager sheets, for example Schedule Manager. Unifier 
dynamically updates the Company Cost Sheet with information from Project Cost Sheet. 

 Funding Sheet

Funding Sheet tracks Company funding through allocation to, and consumption at, the 
Project level. 

 Schedules of Values

Unifier Schedule of Values (SOV) feature provides a way to assemble information from 
Contract, Change Order, Invoice, and Payment Business Process into an SOV sheet and 
stream the process of invoicing for completed phases of a project. The following is a list of 
Schedule of Values (SOV) types: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

The following Cost rules affect how you can work with the Cost Manager modules: 

 Budget

 The Budget must be greater than 0. 

 This rule validates that a budget line item cannot be reduced below $0. 

 Revised Budget

 The Revised Budget must be greater than or equal to Approved Commitments. 

 This rule validates revised budget (approved budgets, budget transfers and budget 
changes) versus approved commitments (approved contracts, change orders, purchase 
orders and po amendments). 

 Invoice

 An Invoice must be less than or equal to Approved Purchase Orders and PO 
Amendments. 

 This rule validates invoices (approved invoices) versus approved purchase orders 
(approved purchase orders and po amendments). 
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 Payment Application

 A Payment Application must be less than Approved Contracts and Change Orders. 

 This rule validates approved payment applications vs approved commitments (approved 
contracts, change orders). 

The following actions can trigger the Cost rules: 

 When you attempt to send a Business Process record to the next step, whose status 
activates the rule. For example, the rule may activate when a Business Process record 
reaches to the Pending or Approved status. 

 When you have entered the data into a Cost Sheet manually. 

 Web Services calls create records. 

 Records are auto-created from other records. 

About Cost Sheets 

A Cost Sheet is a detailed accounting of the project budget and costs. A cost sheet works like a 
spreadsheet within Unifier, calculating and maintaining the project cost information stored in the 
project. Cost information is either entered manually or rolls up into the Project Cost Sheet when 
transactions occur in Unifier. 

Types of Cost Sheet Data Entry 

Cost sheet cells can be populated with data in the following ways, depending on how the column 
has been set up: 

Manual entry: Your cost sheet may include some columns in which you can enter data through 
line items or directly into a cell. Line items can be added manually by copying data from an 
existing line item within the cell or from copying existing line item data from one column to 
another. 

Business processes: Cost sheet data can also be rolled up automatically when cost-type 
business processes reach a specified status. For example, when a purchase order is approved, 
the amount can be rolled up to the appropriate column and CBS codes. 

Formulas: Cell data is calculated from other column entries based on a formula defined for the 
column. The formula may include data from other columns. 

Budget: Information from the project or shell budget can be rolled up to budget columns. This 
data is entered in the Budget window. 

Worksheet: Data can be entered into worksheets and rolled up to cost sheet columns. 

The following sections discuss how to view, enter, and manage cost sheet data and budget 
information. 

Adding a New Cost Sheet 

When adding a new Cost Sheet either by way of copying from a template or by way of copying 
from a CBS Shell instance, note the following: 

Adding a new Cost Sheet by way of copying from a template
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 If the CBS Shell instance does not have the Schedule Type Data Element on the attribute 
form, the templates that have the option "Enable P6 sources" selected are not available for 
use. That is to say, you are not able to add a cost sheet that has P6 Sources to the Shell. 

 If the CBS Shell instance does have the Schedule Type Data Element on the attribute form, 
you can select the "Tree" structure cost sheet, only. 

Adding a new Cost Sheet by way of copying from a Shell instance

 If the CBS Shell instance does not have the Schedule Type Data Element on the attribute 
form, the  Shell instance that have the option "Enable P6 sources" selected are not 
available for use. That is to say, you are not able to add a cost sheet that has P6 Sources to 
the Shell. 

 If the CBS Shell instance does have the Schedule Type Data Element on the attribute form, 
you can select the "Tree" structure cost sheet, only. 

More information about adding a new Cost Sheet

 Enable P6 sources 

You can select any Cost Sheet with the option "Enable P6 sources" selected, or without the 
option "Enable P6 sources" selected. 

Once a new Cost Sheet is created within a CBS Shell instance, the option "Enable P6 
sources" is carried over from the source. The "Enable P6 sources" option is editable as long 
as no columns are added to the Cost Sheet via the P6 Data sources. If a Cost Sheet 
contains columns that use P6 Data Sources, you cannot edit (Select or Deselect) the 
"Enable P6 sources." 

Working with Project or Shell Cost Sheets 

This section discusses working with cost sheets in Standard Projects and in CBS-code based 
shells. 

For information about cost sheets in generic shells, see Working with a Generic Cost Manager
(on page 363). 

Cost Sheet Sub-node (Standard View) 

When you click the Cost Sheet sub-node (Project or Shell > User mode > Cost Manager), the 
Cost Sheet log opens which displays the cost sheets, worksheets, and work packages (where 
available) within the project or shell. The log has the following elements:   

 Toolbar 

 Grid displaying the list of all the sheets within the project or shell 

 Right-hand pane capturing the details of each sheet 

The Cost Sheet log toolbar options: 
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Create Enables you to create a: 

 Worksheet

 From Template

 From Projects

 Work Package

Actions Enables you to set the permissions (Permissions). 

View Enables you to set the view of the log by showing all sheets or group the 
sheets by type, through selecting one of these options, respectively: 

 All

 Group by Type

Refresh Enables you to update the information of the items listed on the log. 

Print Enables you to: 

 Print

 Export To CSV

 Export To Excel

Find on 
Page

Enables you to activate the find cells for each column in order to find a 
particular item. 

The Cost Sheet log grid column headings: 

 Name

 Reference No.

 Date Created

 Created By

 Type

 Status

The Cost Sheet log tabs (right-hand pane), when you select a worksheet: 

 Properties tab 

 Permissions tab 

 Audit Log tab 

The Cost Sheet log tabs (right-hand pane), when you select a work package: 

 Properties tab 

 Audit Log tab 

To open a sheet, you can double-click on the sheet or click the gear menu ( ) and select open. 
Once you open a cost sheet, the Cost Sheet overlay opens. The following explains the 
elements of the Cost Sheet overlay. 
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Project or Shell Cost Sheet (Standard View) 

When you open a project or shell cost sheet (Cost Manager node > Cost Sheet sub-node > 
<Project Cost Sheet>), the Cost Sheet overlay window opens and the following elements 
appear on the screen:   

 Cost Sheet header and locked/unlocked indicator   

 Toolbar enabling access to several actions 

 Grid with rows (if available) and columns 

The Cost Sheet overlay window toolbar options are as follows: 



Unifier Managers User Guide

82

Manage Rows Note: This option is available only to those users who have 
permission to modify the cost sheet rows. Clicking at this option 
enables you to open a new grid sheet (inline), on top of the cost 
sheet, titled: Manage Rows. 

For a tree-structure cost sheets, the Manage Rows sheet has the 
following toolbar options: 

 Add Sibling

 Add Child

Note: When no cost code has been created yet, the toolbar has 
only the Add option (instead of the two separate Add Sibling
and Add Child options). 

 Refresh

 Print

 Find on Page

 Expand All Groups or Collapse All Groups

For a flat-structure cost sheets, the Manage Rows sheet has the 
following toolbar options: 

 Add

Clicking Add, when no row has been selected, adds a new row 
at the bottom of the existing rows. 

Clicking Add, when a row has been selected, insert a new row 
below the selected row. 

You can always drag the row to move it above or to any other 
valid place. 

 Refresh

 Print

 Find on Page

When you make changes, the following additional options (appear 
on the top, right-hand corner of the screen) enable you to cancel or 
save your changes: 

 Cancel

 Save

The Manage Rows sheet has the following columns that are 
stationary: 

 Cost Code 

 Code Name 

Other columns on the Manage Rows sheet vary as per design (as 
defined in the cost sheet attribute form in uDesigner). 

For each cost code row in the Manage Rows sheet, you have the 
following options columns at the very end: 

 Notes

An indicator to show if a cost code row is associated with notes.

 Attachments

An indicator to show if a cost code row is associated with 
attachments. 

 Delete

If a row is eligible for deletion (i.e., there is no cost associated 
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Add Column Enables you to open the New Column overlay window which 
contains the following fields: 

 Name

Similar to the Classic View of Column Properties window, when 
you create a new column in the current cost sheet. 

 Type

The drop-down menu enables you to select the values: 

 From Business Processes (the default value for Type) 

Select the From Business Processes option if you want to 
have a column in the Cost Sheet log the pulls data from the 
Amount field of a Business Process. If you select this 
option, then: 

- The New Column form (overlay window) stays as is. 

- The Data Source drop-down menu gets updated to show a 
list of all Business Process datasources which can be used 
to create a column. 

Note: The datasources that have already been used to 
create a column will not be included in the list. You must 
populate the mandatory options, on the form, in order to 
create the new column successfully. 

 Direct Entry 

Select the Direct Entry option when you want to enter 
Numeric values into the cell directly. When you select this 
option on the overlay form, similar to the "From Business 
Process" option, the form stays as is. The only difference is 
that the Data Source drop-down menu displays "Logical 
Sources," only. Also, those sources that have already been 
used to create a column will not be displayed in this list. 

 Line Item Content 

Select the Line Item Content option when you want to enter 
data for each cell in the column in a line item format, 
allowing multiple line item entries per cell. The total is 
displayed in the cell. When you select this option on the 
overlay form, the overlay form stays as is. The behavior of 
the Data Source drop-down menu is the same as when you 
select the "Direct Entry" option. 

 From Worksheet 

Select the From Worksheet option when you want to 
populate the data in the Cost Sheet column from another 
column in an already existing worksheet within the project or 
shell. When you select this option: 

- The Data Source drop-down menu displays a list of all 
those logical sources that allow the "Sheet" type entry 
method. 

- The sources that have already been used to create a 
column do not show up in the list. 

The Type drop-down menu will contain two additional 
options: 

- Sheet Name 

This is an editable drop-down menu (same as the "Name" 
drop-down for the "Sheet" radio option in the Classic View 
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Forecasting Note: This option is available only if the cost sheet is enabled for 
forecasting. When you click this option, the Classic View of 
Forecast Adjustment window opens. 

Refresh Enables you to see the added values to the columns of the sheet. 

Print Enables you to print or export the log content. 

Find on Page Enables you to search for a sheet on the log. 

Expand All 
Groups or 
Collapse All 
Groups

Enables you to expand or collapse the sheets to see the 
subordinates.  

Menu Options Enables you to conduct and access: 

 Import

 Summary Budget

 CBS Details

 Export

 Summary Cost Sheet

 Summary Budget

 CBS Details

 Column Details

 Columns

 Unhide

 Restrictions

 Snapshots

 Create

 Open

 Currency

 Project Currency

 Base Currency

 Budget Distribution

See Budget Distribution below for details.  

 Row Coloring

 Multi-Color

 Single-Color

 Properties

 Audit Log
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Currency Toggle Enables you to switch the cost sheet currency from Project 
Currency to Base Currency (or vice versa).  

The Cost Sheet overlay window column options may vary. The following are a list of possible 
columns: 

 Sequence No. 

 CBS Code (or Cost Code): Static column 

 CBS Item (or Code Name): Static column 

 Assigned Budget 

 Purchase Orders (Approved) 

 Change Orders (Approved) 

 Invoices (Approved) 

 Contingencies 

 LI Content 

 Risks & Issues (Closed) 

 Forecasts 

 Budget Approval (Approved) 

 Budget Transfers (Approved) 

 CBS/WBS Actuals (Approved) 

 Contract Change Orders (Approved) 

 Contracts (Approved) 

The bottom of the Cost Sheet log (underneath the second column from the left--after the 
Sequence No. column) displays the totals for the amounts for each column. 

The bottom of the Cost Sheet log (left-hand corner) displays the total number of items. 

When you right-click on a cell heading, you will see the following options: 

 Insert

 Properties

 Hide

 Delete

 Lock after this column

When you right-click on a cell within the cost sheet, you will see the following options: 

 Add Sibling Row

 Add Child Row (available only if the selected cell row is not associated with any cost item or 
line item data) 

 Insert Column Before (not available if you select a cell within the CBS Code or the CBS 
Item columns) 

 Insert Column After (not available if you select a cell within the CBS Code column column) 

 Copy

 Delete

When you click on a cell, the Cost Sheet screen opens a pane on the right-hand side that has 
the following tabs: 
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 General

 Attachments

 Notes

 Fund Assignment Order

These tabs provide additional information about each cell. Where allowable, you can update the 
fields within each tab. 

The Budget Distribution overlay window contains the following elements: 

When the Budget Distribution is locked 
(padlock icon in locked position) 

The following blocks (accordion menu) are 
visible: 

 Overview

If available, the right-hand pane of this 
block (accordion menu) contains the 
following tabs: 

 Attachments

 Audit Log

 Lock/Unlock History

 Distributed Amount

Enables you to see the Cost Code, 
Code Name, Type, and Distributed 
Amount. You can use the toolbar 
options to refresh, print (or export), 
find, and collapse the information in the 
log. 

The right-hand pane of this block 
(accordion menu) contains the 
following tabs: 

 General

 Attachments

 Notes

All of the fields are read-only. 

If you click Unlock, you must enter a 
reason. 

When the Budget Distribution is 
unlocked (padlock icon in unlocked 
position) 

You have all the options available in the 
locked position, and you can change the 
values in the editable fields. 

Once finished, you must click Save & 
Lock. 
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Cost Sheet Views 

In addition to opening and viewing a cost sheet within a project or shell, you can create your own 
views with filters, groupings, etc. to modify the default view of the cost sheet. Upon navigating to 
the cost sheet node in the new interface, a Views option is available after the Add Column
option. This is similar to how views are seen in Business Process logs in the Standard interface.  

When the cost sheet is created from the source template, the sheet has only one view. This view 
is the Default view, which is selected from the View dropdown. You can also select the Create 
New View option to create new views or the Manage Views option to manage (Rearrange or 
Delete) existing views from the View dropdown. 

Similar to BP logs in the Standard interface, the View dropdown within the cost sheet log is 
followed by the Edit View option. 

Creating New Cost Sheet Views 

When you choose Create New View, a New View window is displayed. A View Name text box 
with New View as the default value can be seen at the top of the window. Validations are 
performed to ensure that the view has been given a unique name. 

The View Name text box is followed by the Cancel, Apply, and Save options. If you choose 
Cancel, then the creation of the new view is cancelled and you are brought to the previous view 
in the cost sheet. If you choose Apply, then the changes in the New View window are applied 
while the overlay window remains as is. If you choose Save, then the new view is saved and 
loaded into the cost sheet. 

There are four tabs below the View Name text box, including: Columns, Filters, Group By, and 
Sort By. 

Columns Tab in the Create New Views Window  

The three sections under the Columns tab are: Available Columns, Selected Columns, and 
Lock after Columns. 

In addition to the previous sections, there are three options located between the Selected 
Columns section and the Lock after Columns section. These options are: Group 
Management, Group Selected Columns, and Delete Group.  

For a new view, the Available Columns section displays a list of all the columns from the 
Default Cost Sheet view. Cost Code and Cost Name columns are not available in the list 
because they are part of all views by default. The columns that you have view restrictions for are 
also not available in the list. 

In the case of a new view, the list in the Selected Columns section is blank. You can select one 
or more columns from the Available Columns list and move those columns to the Selected 
Columns list. The following tooltip is next to the Selected Columns label: “These columns will 
be seen in the view. The last column in this list will not be available for locking.” 
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Note: If you select Apply or Save without choosing a column from the 
Available Columns list, then a view with Cost Code and Cost Name
columns is created. 

If you choose one or more columns from the Selected Columns section and select the Delete 
Group option, then the following message is displayed: “Only Groups can be Deleted.”  

When you select multiple columns and then select the Group Selected Columns option, a 
dialog box that contains a Group Name text box is displayed. You can enter the group name 
and save that group name by selecting the Save option. In order to create a column group, you 
must enter a name into the Group Name text box. The max character limit for a group name is 
255 characters.  

Upon choosing the Group Management option, a new window that shows the created groups 
as tabs is displayed. You can enter or edit the Group Title, but know that the Group Title is a 
mandatory field. Along with the lists of Available Columns and Selected Columns in the 
Group, there are also two checkboxes. You can select the Show last column when group 
collapsed checkbox as well as the Collapse group by default checkbox.  

The Available Columns list displays the columns that exist in the default view of the cost sheet. 
One or more columns can be selected from the Available Columns list and moved to the 
Selected Columns in the Group list. Columns that are apart of another group are italicized. 
Each group must contain at least one column, as empty groups are not honored. You can 
re-order the columns in a group by selecting any of the arrow options.  

Once you create a group, the group is displayed in the Selected Columns section of the 
previous window with a Column Tree icon and the group name. This group name contains a 
hyperlink that takes you to the Group Management window and selects the previously selected 
column.  

All changes are saved upon selecting the Save option.  

The Lock after Columns section contains a Left Lock after column dropdown and a Right 
Lock after column.  

If you choose a column in the Left Lock after column dropdown, then the list for Right Lock 
after column displays the remaining columns from the Selected Columns list. For example, if 
there are 20 columns in the Selected Columns list and you choose column 4 in Left Lock after 
column, then Right Lock after column displays columns 4-19. Another scenario is if you select 
column 19 in Left Lock after column, then Right Lock after column displays column 19. 

The Left Lock after column dropdown initially displays every column from the Selected 
Columns list, except for the last column. None is selected in the dropdown by default. When 
None is the value in the dropdown, it means that no column has been chosen to be locked from 
the left side of the sheet. 

This Lock dropdown contains a list of entries from the Selected Columns section. No group 
columns are displayed.  

For the Right lock after column dropdown, None is selected by default. When None is the 
value in the dropdown, it means that a right lock column has not been chosen for the view. The 
remaining values in the dropdown consist of a dynamic list that gets populated based on the 
value chosen in the Left Lock after column dropdown. 
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Filters Tab in the Create New Views Window  

For both Tree and Flat Structure cost sheets, there are three sections in the Filters tab, 
including: Cost Code Segment, System-Defined Cost Attributes, and Sheet Columns. The 
Cost Code Segment section displays each cost code segment as an attribute that can be used 
to apply filters to the cost sheet. The System-Defined Cost Attributes section displays all “uuu” 
data elements from the Cost Attribute form in uDesigner. The Sheet Columns section displays 
all columns from the cost sheet in order. 

Note: Filters get applied to only leaf-level codes within the cost sheet. 
Summary cost codes do not show up in the filter results. 

Group By in the Create New Views Window 

The dropdown in the Group By tab displays all attributes from the Cost Attribute form and all 
cost code segments. 

Sort By in the Create New Views Window  

In the Sort By tab, all the columns from the default cost sheet are available. 

Managing Cost Sheet Views  

Similar to BP logs in the Standard interface, the Default view and all the manually created views 
are available in the Manage Views window. This window has the same features as other logs, 
which also have the Views feature within them. 

Editing Cost Sheet Views  

Similar to other logs in the Standard interface, the view name is read-only in the Edit View
window. The view name is followed by the options available for cancelling the edit action, saving 
changes, and saving the view with a new name, or Cancel, Apply, and Save. When you select 
Save, a small overlay form is displayed where you can save the view with a new name. 

Functionality within Cost Sheet Views  

In the Default view, you can perform any of the actions listed below: 

 Drag and drop columns 

 Rearrange column order 

 Select a column header to change the Sort By column 

 Right-click on a column header to choose the Lock after this column option 

When you perform any of the above actions, the prefix of the view name becomes Modified. 
The Edit View option is disabled. Therefore, you cannot save the Modified view. 

The remaining gear menu ( ) for the rows and columns remain as they are in the Standard 
interface of the cost sheet. All of the toolbar options remain as they are in the Standard interface 
of the cost sheet. You must save any modifications that were made to the Default view without 
changing the view name to Modified. 

In a manually created view, you cannot perform any of the actions listed below: 
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 Manage rows 

 Add columns 

 All Menu (A.K.A. Hamburger) actions 

 The only exceptions are Row Coloring in the case of a Tree structure cost sheet, and 
Import and Export options for both Flat and Tree structure of the cost sheet. 

 Import options: This has the sub-menu option ‘Column Details’ using which 
customer can choose a column from the view and import data into it. The import 
action allows import into all leaf rows of the cost sheet and not just the ones 
present within the view. 

 Export options: Same as above, this has a sub-menu option: ‘Column Details’. 
Use this option to select the column from which data should be exported. Once 
chosen, customer can export of column data.This exports data from all leaf rows 
from the cost sheet and not just the ones present within the view. 

 All gear menu ( ) actions 

 All Column Menu actions 

When you select a value in any of the cost sheet cells, the General tab in the right pane is 
displayed as read-only. 

You can drag and drop columns to any place on the cost sheet. When this action is performed, 
the prefix of the view name becomes Modified. However, in the case of a manually created 
view, you can select Edit View and ultimately choose Cancel, Apply, or Save after making 
modifications in the Columns, Filters, Group By, or Sort By tabs. 

After the View drop-down, there are many available options from the Standard interface of the 
cost sheet, including: Refresh, Print, Find on Page, Expand/Collapse, Menu Options—Row 
Coloring, and Currency. If you make changes to the Row Coloring or the Currency of the cost 
sheet, these changes are not saved to the view. 

The Group By options that are within the view definition are visible as a grouping section with 
the appropriate rows grouped in it. Each group, along with its appropriate rows, displays an 
additional column that shows the group’s name before the Cost Code column. There is no 
column header for this grouping column. 

When a Group By option applies to the view, the group’s summary row displays the summary 
value that is based on the Total option in the column’s properties. 

A special case for creating views is the addition of a few columns. After creating a view, your 
administrator can take away your permissions to the columns that you added. When you try to 
open the view, those columns are no longer visible. The Edit View window does not show the 
columns in the Selected Columns section nor the Available Columns section.  

Menu Options in Worksheet  

A typical Cost Sheet log (<Project or Shell> > Cost Manger node > Cost Sheet sub-node) has 
the following types of sheets when you switch the view of the log from default to another type of 
view (View > Group by Type): 

 Cost Sheet

 Work Package

 Worksheet
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In the Group by Type view, the records are grouped under each category. 

When you open the project cost sheet (Cost Sheet), when it is locked, you can use the 
Menu Options (the three horizontal line drop-down icon) to perform the following actions for 
the project cost sheet: 

 Import - Column Details 

 Export - Column Details 

 Row Coloring - Multi-Color and Single-Color 

The Menu Options (the three horizontal line drop-down icon) and sub-menu options are not 
available for work package (Work Package) records.  

When you open a worksheet (Worksheet), you can use the Menu Options (the three 
horizontal line drop-down icon) to perform the following actions for the worksheet: 

 Note: The view of the worksheet can be Default. 

 Import - Column Details 

 Export - Summary Work Sheet and Column Details 

 Columns - Copy Column Data 

 Snapshots - Create and Open 

 Currency - Project Currency and Base Currency 

 Row Coloring - Multi-Color and Single-Color 

 Properties

 Audit Log

Open a Project or Shell Cost Sheet 

The ability to open, view, enter data, work with the column structure or modify properties on a 
cost sheet is dependent upon the permissions that you have. Contact your project or company 
administrator if you have questions regarding your permission levels. 

Note: When you first open the sheet, the opening view will depend on 
the Default View option selected in the Properties window. Your cost 
sheet administrator can set this default view. Cost sheets can be resized 
and split/unsplit (see Resize cost sheet window (on page 94) or Split 
or unsplit cost sheet window (on page 94)). 

To open a project or shell cost sheet 

1) Open the project or shell. 

2) Click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log opens. 

3) The cost sheet will be displayed in bold font in the log. Select the sheet from the log and click 
Open. The Project Cost Sheet opens. 

This item Does this 

Save As 
Click this button to save a snapshot copy of the cost 
sheet. 

Rows Opens the Rows window, from which you can add 
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This item Does this 

or manage rows. 

Columns 
Opens the Columns log, from which you can add or 
manage cost sheet columns, or assign access 
restrictions. 

Find Click to search for a cost code. 

Split 
Splits the window vertically so you can scroll 
through the columns while maintaining a view of the 
CBS code. 

Fund Assignment Order 
Opens the Fund Assignment window (if the Funding 
Manager is used). Allows you to set the project or 
shell fund assignment order at the CBS level. 

Cost Sheet cells Click on a cell to view the Cell Details window. 

CBS Code 
Click on the CBS code name to open the CBS 
Detail window. 

Column Heading 
Click on a column heading to view more information 
about the column type. 

File Menu > Open Opens the Snapshot log. 

File Menu > Import 

Click and select one of the following: 

 Summary Cost Sheet 

 Summary Budget 

 CBS Details 

 Column Details 

File Menu > Export 

Click and select one of the following: 

 Summary Budget 

 CBS Details 

 Column Details 

File Menu > Properties Opens the Properties window. 

Edit Menu > Budget Distribution 
Opens the Budget Distribution window, in which you 
can manage the budget or lock/unlock the budget. 

Edit Menu > Copy > Column Data
Copy data from one column to another, from one or 
multiple rows. 

View Menu > Currency 
Click and select the display currency in which to 
display the cost sheet data. 

View Menu > Audit Log Opens the Audit log for the cost sheet. 

View Menu > Expand 
Expands all CBS codes. There is also an Expand 
button. 

View Menu > Collapse Collapses all CBS codes. There is also a Collapse 
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This item Does this 

button. 

Cost Sheet Restrictions 

Your Administrator can configure cost sheet restrictions to restrict users or groups from viewing 
or editing columns within a cost sheet. The behavior of these restrictions depends upon the 
Company-level Global setting Override column restrictions.  

The following feature applies to the following cost sheets: 

 Company-level 

 Program-level 

 Shell-level 

 Project-level 

For each type of cost sheet, the user's corresponding groups must be taken into account 
(company-level, program-level, and project/shell level) for the column restrictions. 

If the option Override column restrictions is not selected, then: 

If the user belongs to a group which does not allow editing or viewing a column in the cost 
sheet (or a user is individually restricted), then the user will be restricted from editing or 
viewing a column in the cost sheet. 

If the option Override column restrictions is selected, then: 

It allows user to view or edit a cost sheet column if any of the restricted groups or the 
individual user is allowed to view or edit the column. 

For more details on Unifier Cost Sheet column behavior, when the checkbox is checked, 
consider the following scenarios: 

For all the groups which are configured for restrictions on a cost sheet column, if all of the 
groups to which a user belongs are restricted from viewing or editing the column and 
if the user is individually configured and restricted to view or edit that column, then the 
user will be restricted from viewing that column. 

If the user (who is configured for restrictions in the cost sheet) is not restricted from 
viewing or editing the column, or if the user belongs to a group that is not restricted 
from viewing or editing the column, then the user is not restricted from viewing or 
editing that column. 

If the user does not belong to any groups that are configured for restrictions on a column 
in the cost sheet, and the user is not configured individually for restrictions in the cost 
sheet, then the user is not restricted from viewing or editing the column.  

In order for the user to be able to view a cost sheet column, the user must have View 
permission for the cost sheet. If the user does not have View permission for the cost sheet, 
the user cannot view the cost sheet columns even if the user belongs to a group that is 
configured to view the cost sheet columns. 
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When you select or deselect the option of Override column restrictions and save the change, 
Unifier approves the change immediately, and you do not need to sign out and sign back in 
Unifier. 

Resize cost sheet window 

The cost sheet window can be resized by clicking the Minimize or Maximize/Restore buttons in 
the upper right corner of the window, or by dragging the edges of the window to the size that you 
need. 

Split or unsplit cost sheet window 

When working with a cost sheet with many columns, it can be useful to split the window using 
the Split and Freeze toggle buttons. This allows you to scroll through the columns in the right 
half of the window, while maintaining a view of the CBS Code and CBS Item columns in the left 
half. 

To display the cost sheet in split window mode 

1) In the cost sheet window, click the Split button. The sheet is split into two sections. 

2) You can click on the vertical split line and move it horizontally to adjust the size of the panes, 
if desired. 

3) Use the scroll bars at the bottom of the window to scroll horizontally through the columns. 
When you have the left portion of the window in the position you want (for example, to view 
the CBS Code or CBS Item column), click the Freeze button to lock it in place. 

4) Scroll through the columns in the right half of the window to view or enter data as necessary. 

5) You can click Freeze again to unlock the left half, or click Split again to restore the window. 
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Entering Data into a Cost Sheet 

The following topics describe how to enter data into a cost sheet.  

Add a line item to a project or shell cost sheet 

A cost sheet column may be defined for manual data entry, depending on the column definition: 

 Manual, line item content: The data is entered in a line item format, allowing multiple line 
item entries per cell. The total is displayed in the cell. 

 Manual, direct entry: Numeric values are entered directly into the cell. 

To add a line item to a project or shell cost sheet 

1) From the project or shell Cost Sheet window, click the link in the line item cell. The Cell 
Detail window opens. 

2) Click the Add button. The Line Item window opens. 

3) Complete the Line Item window as described in the following table. 

4) Click OK. The new line item will be added to the Cell Detail window. 

In this field Do this 

Short Description This description will appear on the Cell Detail window. 

Long Description Optional, to provide more information. 

Work Package 
Select a work package, if any, with which to associate the line 
item. 

Spend Category Select a spend category if this has been set up to be tracked. 

Quantity Enter a quantity (at least 1) as applicable. 

Unit of Measure Select the appropriate choice from the list. 

Unit Cost Enter this manually. 

Amount Automatically calculated as Quantity X Unit Cost. 

Delete Line Item 
Click this button to delete the line item from the Cell Detail 
window. 
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Note: For budget-related columns (for example, Assigned Budget), you 
can enter line item data as long as the undistributed balance is at least 
as large as the line item amount. The undistributed balance will adjust as 
line items are added, displaying the budget amount left. 

To add a line item cost entry by copying an existing line item 

1) In the project or shell Cost Sheet window, click the link in the line item cell. The Cell Detail 
window opens. Any existing line items will be listed in the lower portion of the window. 

2) Select the line item to copy and click the Copy Line Item button. The Line Item window 
opens with the original line item entry information filled in. 

3) You may make changes as necessary for the new entry, or leave as is to make an exact 
copy of the original line item. 

4) Click OK. The new line item will be added to the Cell Detail window. 

Enter data directly into a cell 

Some manual entry cells are configured for direct entry, rather than line item entry. Data entry 
cells do not have links. 

To enter data into direct entry cells 

1) Click inside the cell. The cell becomes editable. 

2) Enter the numeric value directly into the cell. 

Copy data from one column to another 

You can copy the data from any manual entry column to another. 

To add line items by copying existing data from one column to another 

1) Open the project or shell Cost Sheet window, click the Edit menu and choose Copy > 
Column Data. The Copy Column Data window opens. 

2) Complete the Copy Column Data window as described in the table below. 

3) Click Copy. The data in the first column will be copied into the second column. 

In this 
field 

Do this 

Copy 
type 

Choose one of the following: 

 Cell total only: Copies the total value displayed in the cell. The new line 
item will be labeled as "Copy of original column name," ignoring quantity 
and unit cost. 

 Cell detail: Copies all cell detail information from the original line item. 

Copy 
from 
column 

From the drop-down list, select the column to copy. Only line item entry 
columns will be listed. 

Percenta You may enter a percentage value to copy. For example, if you choose 10%, 
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ge then 10% of the value of the original column value will be copied into the new 
column. 

Copy to 
column 

From the drop-down list, select the column into which you want the line items 
copied 

Rows 

Choose one of the following from which you want to copy the values: 

 All: To copy values to all of the rows. 

 Partial: To copy the values of selected rows only. Click the Select button 
to choose the rows to copy. 

View column properties 

To view column properties 

Click the column heading. All column headings except the first two (CBS Details and CBS Item) 
are hyperlinks that open the View Column window. The window shows information about the 
column, such as the data source, entry method or formula, data format, and format of the last 
total row. 

Change cost sheet currency 

You can view cost sheet data in the company base currency or the project or shell currency, 
which may differ. 

Note: This is also applicable to work packages and worksheets. 

To choose the display currency on a cost sheet or worksheet 

1) Open the project or shell Cost Sheet or worksheet window. 

2) From the Edit menu, click Currency and choose the currency from the list. 

To choose the display currency on a work package 

1) Open the work package window. 

2) Click the currency drop-down list in the upper right corner of the sheet and choose the 
currency from the list. 

Expand or collapse CBS codes 

You can expand or collapse all CBS codes in a cost sheet. If you have a large number of CBS 
codes in a tree structure, you can expand that structure to view all of the CBS codes at once. 

To expand or collapse CBS codes in a cost sheet 

1) Open the project or shell Cost Sheet or worksheet window. 

2) Click View > Expand to expand all of the CBS codes in the cost sheet. Click View > 
Collapse to collapse all of the CBS codes in the cost sheet. Alternatively, you can click the 
Expand and Collapse buttons. 



Unifier Managers User Guide

98

View cost sheet cell details 

The values displayed in a cost sheet cell may reflect information from multiple line items, 
business process transactions, or results of a calculation from other cells. The following 
procedures discuss how to view the details about an entry in a cost sheet cell. 

To open the Cell Detail window  

In the project or shell Cost Sheet dialog, click the link of the cost code. The Cell Detail tab in the 
right pane displays the contents of the cost attribute form. 

Note: If the data elements in the Cost Attribute form have tooltips, then 
they will appear in the form of a questions mark (?) symbol. You can 
hover over the question mark (?) symbol to see more information.  

To view manual line item entry details 

From the Cell Detail window, double-click a listed line item. The Line Item window opens. 

To view business process transaction details 

1) From the Cell Detail window, double-click a listed line item. A copy of the business process 
transaction opens. In here, you can view or take action on the BP transaction.  

2) Double-click a BP line item. The BP’s Line Item window opens. 

To view formula cell details 

1) In the Cell Detail window, if line items from manual entry columns or BP transaction columns 
are included in the calculation, they will be listed in the lower portion of the window, with the 
calculated value for each line item. 

Note: In the Forecasts and Forecasts (Unaccepted) columns, if data 
sources are from a business process enabled for costs sheet 
forecasting, the Cell Detail window contains an Include in Forecast 
button. 

2) Click a listed line item. If the line item is a BP transaction, the BP form opens. If the line item 
is a manual entry, the Line Item window opens. 

3) To view the formula used for the column, click the Formula link. 

To view budget cell details 

The Cell Detail window displays as line items information generated from the budget, as 
applicable. Typical budget columns include assigned budget. The undistributed balance amount 
will be displayed as a line item. You may add line items if the undistributed balance is at least as 
large as the line item amount. 

This item Does this 

Attach 
Allows you to attach files to the cell from your local machine (My 
Computer) or from the Document Manager (Primavera Unifier Folder). You 
can view existing file attachments by clicking the Attachments link in the 
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upper portion of the window. 

Add Notes
Click to add a note to the cell. You can view existing notes by clicking the 
Notes link in the upper portion of the window. 

Add 
Click to add a line item (transaction) to the cost sheet (applicable for 
manual transaction columns). 

Remove Allows you to remove a selected line item. 

Copy Adds a line item by copying an existing one. 

View 
Menu > 
Audit Log 

Opens the Audit Log for the cell. 

To open a workflow BP record from cost sheet  

For a workflow BP, you can: 

 Accept task, if the BP record is not in the end-step 

 Modify the BP record and route it to the next step. The cost sheet will be refreshed if the 
record is routed to next step. If you edit the BP record and save it, then Unifier saves a draft. 

To open a non-workflow BP record from cost sheet  

You can open and take action on a non-workflow BP record if you have Edit permission. If the 
BP record is in non-edit mode, then the Edit option is available. 

If you do not have Edit permission, then you can view the BP record, only. 

If you do not have View permission, then Unifier will display the message, "You do not have 
permission to view record." 

To open a BP record from cost sheet (Record Editors or Step Editors)  

When the BP record editor, or step editor, opens the BP record from cost sheet, then editor can 
edit the BP record if the BP record is in accepted state, and the editor has View permissions to 
view the BP record. 

Upon opening the record, the editor will see the Save option, only. The editor can edit the BP 
record but cannot route the BP record to the next step, or submit the BP record. 

Add Notes or Attachments to a Cell 

You can add notes or attach files to any cell in the cost sheet. Files can be uploaded from your 
local environment (My Computer) or from the Document Manager (Primavera Unifier Folder). 

To access cell detail notes and attachments 

1) In the Cost Sheet window, click in any cell that displays as a link (line item entry, formula, or 
automatic entry from a BP). The Cell Detail window opens. 

2) You can add a note, view existing notes, add a file attachment, or view attached files. 
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To add notes to a cell 

1) In the Cell Detail window, click Add Notes. The Add Notes window opens. 

2) Type the note in the text box and click OK. Each time you add a new note, the Notes 
counter in the Cell Detail window updates to reflect the number of notes that exist for the 
cell. 

To view notes attached to a cell 

1) If any notes have been added to the cell, the Notes link on the Cell Detail window will display 
the number of notes. 

2) Click the Notes link. The Notes List opens, displaying all of the notes that have been added. 
Each note displays the user who added the note, and the date and time it was added. 

To modify or delete cell detail notes 

Notes added to a cost sheet cell cannot be modified or deleted. 

To attach files to a cell 

In the Cell Detail window, click Attach and choose: 

 My Computer to attach the file from your local system. The procedure is the same as for 
uploading files to the Document Manager. For rules on attaching files in Unifier refer to 
Unifier General User Guide. 

 Primavera Unifier Folder to attach documents from the Document Manager. The window 
opens, displaying the project or shell documents files and folders. Select the files and folders 
to attach and click OK. 

Note: Folders are not attached. The contents of selected folders are 
attached in a flat list. Documents with duplicate file names will not attach. 

To view attached files 

1) If any files have been attached to the cell, the Attachments link on the Cell Detail window 
will display the number of attached files. 

2) Click the Attachments link. The Attachments window opens. 

3) Choose a file and click Open. The document will open in the viewer selected in your user 
preferences. 

To delete an attached file 

1) In the Cell Detail window, click the Attachments link to open the Attachments window. 

2) Select the file to be deleted, then click the Delete button. 

To download a copy of an attached file 

1) In the Cell Detail window, click the Attachments link to open the Attachments window. 

2) Select the file to be downloaded and click Download. 

3) Browse to a location on your local system and click OK. Click Yes to confirm. 
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Search for CBS codes (rows) 

You can search for a particular cost code by searching for one or multiple segments. 

To search for a cost code 

1) In the Cost Sheet window, click Find. The Cost Code Find window opens. 

2) Select the cost code segments you want to search by and click OK. 

The results will be shown in a separate cost sheet window. The new window also has split 
capability so that you can keep the CBS code in view and scroll through the columns. 

Edit cost sheet data 

The following procedures discuss how to modify cost sheet data. Manually entered cost sheet 
data can be edited or modified directly from the cost sheet (assuming you have modify 
permissions). 

Cost sheet entries rolled up from transaction BPs or calculated in formula columns are not 
editable. Data rolled up through business processes can only be modified by submitting 
business processes such as change orders. Formula column cells will reflect changes made to 
other column data used in the calculations. 

To edit direct entry data 

1) In the project or shell Cost Sheet window, click inside the cell to edit. The cell becomes 
editable. 

2) Enter the new value. 

To edit line item data 

1) In the project or shell Cost Sheet window, click the link in the cell to edit. The Cell Detail 
window opens. Line items are listed in the lower portion of the window. 

2) Double-click the line item to edit. The Line Item window opens. 

3) Edit the Line Item window as needed. 

4) Click OK to save changes and close the Line Item window. 

To delete a line item 

1) From the project or shell Cost Sheet window, click the link in the cell in which to delete the 
line item. The Cell Detail window opens. 

2) Do one of the following: 

 Select the line item to delete, then click Remove. The line item is deleted. 

 Double-click the line item to open the Line Item window. Click the Delete button. 

3) Click Yes to confirm. 

To edit or delete data rolled up from a business process 

Cost sheet data originating from a business process cannot be edited from the cost sheet. 

Data must be edited in the business process record if it is still active or through an appropriate 
change BP, such as a change order. 
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To edit or delete data calculated in a formula column 

Formula column cells will reflect changes made to other column data used in the calculations. 
Click the column heading to view the formula and display the cost sheet columns used in the 
calculation. This will help you determine whether to edit the formula, the data on another 
column, or other source. 

Save or view cost snapshots 

You can save a snapshot or a read-only view of the project or shell cost sheet and worksheets. 
You can view a snapshot in both project and transaction currencies. Snapshots cannot be 
deleted. 

To save a snapshot of the cost sheet or worksheet 

1) Open the cost sheet or work sheet. 

2) Click the Save As button. The Save As Snapshot window opens. 

3) Enter a title and click OK. 

To view the snapshot 

1) Open the cost sheet, work package, or worksheet. 

2) Click the File menu and choose Open. The Snapshot Log window opens, displaying the list 
of snapshots. 

3) Select a snapshot and click Open. A non-editable view of the cost sheet or worksheet 
opens, displaying the sheet at the time the snapshot was taken. 

Importing and Exporting Cost Sheet Data 

You can import CBS detail information into a cost sheet manual entry column from a 
comma-delimited-value (CSV) file, such as a Microsoft Excel spreadsheet saved in CSV format.  

Note: For information about internationalization and CSV files refer to 
Unifier General User Guide. 

To import project or shell cost sheet information 

1) In the project or shell cost sheet, click File > Import and then choose one of the following: 

 Summary Budget:

Summarizes the budget information. 

 CBS Details:

Lists CBS codes and CBS details information for each. 

 Column Details:

Summarizes column details for specific columns.  

For a project level cost sheet, the following columns are available for import/export: 

- Assigned Budget 

- Yet To Buy 

- AFC 
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- Project Cost 1 to Project Cost 100, for columns where the Entry Method is set to Manual 
Entry for either Direct entry into cell or Line Item content (either visible or hidden) 

2) Browse to the CSV file to import, select it, and click OK. 

Note the following: 

Import Option Rules 

Summary Budget 

The following rules apply when importing into the cost 
sheet: 

 Negative numbers are not allowed for budget 
distribution amount. 

 There is no check on import whether the total capital or 
expense budget was exceeded. 

After the import is completed, return to the Budget 
Distribution page and save and lock the budget. Once the 
budget is locked, the system performs the necessary 
check to determine if the total capital or expense budget 
has exceeded the original budget. 

CBS Details 

The following rules apply to the CBS details when 
importing into the cost sheet: 

 CBS details are updated, and new, valid CBS details 
are added in the order specified in the CSV file. 

 The complete CBS code, including the parent code, 
must be valid and in the correct order in the CSV file. 

Column Details 

The following rules apply to the column details when 
importing into the cost sheet: 

 This selection adds a column to the cost sheet and is 
usually done as part of the administration of the cost 
sheet. 

 For the Assigned Budget (or Budget Remaining 
Balance) column and Manual Entry column, all of the 
existing budget line items are deleted and replaced 
with the new budget line items defined in the CSV  file, 
even if the CSV file only provides a partial list of CBS 
codes. 

 Values in the Distributed Budget column are for 
reference only. 

Once you have constructed the cost sheet and distributed the budget, you can export specific 
cost sheet information, saving it to a local file system in a comma-separated-value (CSV) format. 

To export project or shell cost sheet data 

1) In the project or shell cost sheet, select File > Export and then choose one of the following 
options. 

 Summary Cost Sheet:
Creates a summary of all rows, columns, and data on the cost sheet. 
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 Summary Budget:
Creates a summary of the budget window information. 

 CBS Details:
Lists all of the CBS codes on the cost sheet and the CBS details information for each. 

 Column Details:

Creates a summary of column details for the selected column.  

For a project level cost sheet, the following columns are available for import/export: 

- Assigned Budget 

- Yet To Buy 

- AFC 

- Project Cost 1 to Project Cost 100, for columns where the Entry Method is set to Manual 
Entry for either Direct entry into cell or Line Item content (either visible or hidden) 

The Summary Cost Sheet option only supports saving the structure for reference purposes. 
The other three exported files can be modified and then imported into a new or existing 
project or shell cost sheet. 

2) Read the confirmation message and click Yes to continue. 

You can open the file in a compatible program, such as Microsoft Excel, to review it before 
saving. 

3) Click Save and specify the location in which to save the CSV file. 

Note: If you open the CSV file, you will see that it contains notes 
regarding modifying the columns and data in the exported file for 
re-importing into a cost sheet. Follow the notes embedded in the CSV 
file for modifying columns and data in the exported file. 

You can create Cost Based Structure (CBS) Codes in Cost Sheets.  

Importing Cost Sheet Data from P6 

P6 Schedule contains CBS Structure, or Codes, and sends the CBS codes to Unifier Cost Sheet 
CBS Codes, also called CBS Codes. 

 If you select to use, or run, the Synchronization "Create CBS in Unifier Cost Sheet" within 
the Gateway, the Unifier Cost Sheet within the integrated Unifier Projects receive the CBS 
Codes created via integration. 

 If the Unifier Cost Sheet contains preexisting CBS Codes, or contains no Cost Codes, you 
can choose to run the Synchronization to create CBS Codes in Unifier, via integration. 

CBS Codes created in P6 have "imported" root to Leaf Structure and are not under any 
hierarchy that has been created manually. An "imported" Leaf CBS Code in Unifier appears 
under an "imported" root and non-root Summary CBS Codes; however, you can create "manual" 
Leaf CBS Codes under "imported" Summary CBS Codes. 
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Notes: 

 When you are creating a Summary CBS Codes in Unifier by using a 
CSV file, ensure that you select the corresponding "Exposed to P6" 
correctly. 

 When you are creating a Summary CBS Codes in Unifier by using 
Web Services, the "Exposed to P6" option remains deselected. 

 If you hide a parent Summary CBS Code, all the corresponding 
children will be hidden. 

 If you do not select a Summary CBS Code, the corresponding Leaf 
codes will remain unselected. 

 If you select one Leaf code, the corresponding parent Summary CBS 
Code will be selected. 

 If you hide a Leaf code, the hidden Leaf code remains hidden in P6 
CBS picker, but the Summary CBS Codes stay as they were. 

About Synchronization methods

Note: The Synchronization Methods are defined in P6 and not Unifier. 

Complete: 

When Synchronization Method = Complete, P6 sends all CBS levels/codes to Unifier via 
Gateway. 

Unifier receives the attributes for each CBS and uses the "Default" value of each Cost Segment 
to create Cost Codes within Unifier Cost Sheet. 

If the number of CBS levels in P6 Schedule is fewer than the number of Cost Segments in 
corresponding Unifier Cost Sheet, then Unifier creates two CBS Codes for each lowest level 
CBS code sent from P6:  

 One Summary CBS code 

 One dummy Leaf CBS Code under the Summary CBS code 

Levels: 

When Synchronization Method = Levels, P6 sends selected CBS levels/codes to Unifier via 
Gateway. The selected CBS levels/codes are the codes that are up to a defined number of 
levels within the P6 Schedule. The remaining CBS codes are not sent. 

Unifier receives the attributes for each CBS and uses the "Default" value of each Cost Segment 
to create Cost Codes within Unifier Cost Sheet. 

If the number of CBS levels in P6 Schedule is fewer than the number of Cost Segments in 
corresponding Unifier Cost Sheet, then Unifier creates two CBS Codes for each lowest level 
CBS code sent from P6:  

 One Summary CBS code 

 One dummy Leaf CBS Code under the Summary CBS code 

Partial: 
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When Synchronization Method = Partial, P6 sends selected CBS levels/codes to Unifier via 
Gateway. The selected CBS levels/codes are the codes that are selected as "Integrated." The 
remaining CBS codes are not sent. 

Unifier receives the attributes for each CBS and uses the "Default" value of each Cost Segment 
to create Cost Codes within Unifier Cost Sheet. 

If the number of CBS levels in P6 Schedule is fewer than the number of Cost Segments in 
corresponding Unifier Cost Sheet, then Unifier creates two CBS Codes for each lowest level 
CBS code sent from P6:  

 One Summary CBS code 

 One dummy Leaf CBS Code under the Summary CBS code 

Notes: 

 You can switch between the synchronization methods at any point. 

 When CBS codes are sent from P6 to Unifier, mark the codes as 
Imported from P6. 

Defining the budget 

Once the project or shell cost sheet is defined, you can define the project or shell capital and 
expense budget amounts and begin distributing the budget to the various CBS accounts. 
Budgets are managed in the Budget Distribution window. 

About budget and budget distribution 

Once the project or shell cost sheet is defined, you can define the project or shell capital and 
expense budget amounts and begin distributing the budget to the various CBS accounts. 
Budgets are managed in the Budget Distribution window. 

Note: Users with module-level modify permission can lock and unlock 
the budget distribution. An exception to this is if Assigned Budget is one 
of the cost sheet columns, and the user has view restrictions on the 
column. If a user cannot view the Assigned Budget column, the Budget 
Distribution menu option is not available. In addition, the user cannot 
import a summary budget. 

Open the Budget Distribution window 

To open the Budget Distribution window: 

1) Open the project or shell cost sheet. 

2) Click the Edit menu and select Budget Distribution. The Budget Distribution window 
opens. 

3) Use the information in the table below to enter budget information as necessary. 

4) Click OK to save and exit. 
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Item Description 

Project or Shell Capital Budget  

Project or Shell Expense Budget

Scope of Budget 

Comments A text field for any budget-related comments. 

Undistributed Capital Amount  

Undistributed Expense Amount  

Lock Date 
If the budget is currently locked, the lock date 
displays. 

Status Shows if the budget is currently locked or unlocked. 

Lock/Unlock Explanation (View) 
Click the View link to open an audit log that lists the 
dates, times, and explanations for lock and unlock 
budget instances. 

Project or Shell Currency 
Displays the currency used in the project or shell. 
This may differ from the base currency. 

Base Currency Displays the base currency used for your company. 

Exchange Rate 
This is the calculation that is used to convert the 
base currency to the project or shell currency. 

No. of Attachments 
Displays the number of files, if any, attached to the 
budget window. Click on the link to view or download.

Budget Distributed Amount 

The lower part of the window displays each CBS 
code row that appears on the cost sheet. Enter the 
budget amount for each one. Clicking on a CBS code 
link will open the CBS Detail window. 

Attach 
Click this button to attach files to the budget 
distribution window. 

Save & Lock 

This button is available if the budget is currently 
unlocked. Clicking it locks and distributes the budget. 
You will be prompted to provide an explanation for 
this action. 

Unlock 

This button is available if the budget is currently 
locked. Clicking it unlocks the budget to allow for 
modification to the budget window and cost sheet 
rows. You will be prompted to provide an explanation 
for this action. 

Audit Log 
This button accesses the audit log, which records 
budget activity. 
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Distribute and lock the budget 

Once the Budget Distribution window has been completed, you can distribute the budget and 
lock the budget. 

To distribute and lock the budget 

1) Complete the Budget Distribution window. 

2) Click Apply to save changes. 

3) Click Save & Lock. 

4) When prompted, enter an explanation for locking the budget, then click OK. 

5) Click Close to close the Budget Distribution window. 

Unlock the budget 

If the budget has been locked, you must unlock it to make any budget changes or certain cost 
sheet modifications, such as adding or modifying cost sheet rows. 

To unlock the budget 

1) From the Budget Distribution window, click the Unlock button. 

2) When prompted, enter an explanation for unlocking the budget, then click OK. 

3) You can make edits to the budget or cost sheet as needed, then save and lock the budget 
again. 

Permission matrix for the Budget Distribution window 

Assigned Budget Budget Distribution 
Import 
Summar
y Budget

Not 
Added 

Added Lock Unlock View Edit 

X X Yes Yes Yes Yes Yes 

Restrictions

(View) 

Restrictions

(Edit) 

Yes No No Yes No No 

Yes Yes Yes Yes Yes Yes Yes 

No No No No No No 

Managing Project/Shell Cost Sheets and Properties 

The ability to modify cost sheet rows, columns or properties is dependent on your user 
permissions. Contact your project or company administrator regarding your permission levels. 
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View or edit cost sheet properties 

Cost sheet properties include the name, description, structure definition (flat or tree), CBS code, 
CBS item titles, and switches for forecast details and forecast inclusion functionality. 

Most properties are not editable in the cost sheet once it has been created. The exception is the 
Default View, which can be edited. 

To open the cost sheet Properties window 

1) Open the cost sheet Properties window by doing one of the following: 

 Select the cost sheet from the log and click the Properties button on the toolbar. 

 Open the cost sheet. Click the File menu and choose Properties. 

2) The Properties window opens. 

 The General tab displays the Title and Description, and enables the administrator to set 
a Default View for when the cost sheet is opened from the log. 

 The Structure tab displays the CBS Code segment and display structure used in the cost 
sheet. This information is view-only once the cost sheet has been created. 

 The Options tab displays display and forecasting information used in the cost sheet. This 
information is also view-only after the cost sheet is created. 

Working with Cost Sheet Forecasting 

Cost sheet forecasting allows you to manage the forecast process by detail line items. It utilizes 
cost-type base commits, change commits, or generic business processes that were included in 
the Forecasts (Unaccepted) formula. 

Here is a high level overview of the Cost sheet forecasting process. 

1) When a forecast-enabled commitment routes to a terminal status it attains "Unaccepted" 
status, for example, Base Commits (Unaccepted). Note: this is different from Base Commits 
(Approved) or any other routing status. 

2) In this example Base Commits (Unaccepted) line items become available for inclusion in the 
cost sheet forecast. 

3) When you click the Forecasting button, the Forecast Adjustment log opens, where you can 
see all unaccepted line items, based upon the formula used in the Forecasts (Unaccepted) 
column. 

4) As these line items are accepted into the forecast, the unaccepted status changes to 
accepted, for example, Base Commits (Accepted). 

5) Depending upon cost sheet configuration, for the amount accepted into the forecast: 

 Yet To Buy automatically decreases 

 Forecast (Unaccepted) decreases 

 Forecast increases 

To accept line items into the forecast 

1) In the cost sheet, click the Forecast button. The Forecast Adjustment log opens. 
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2) Select the line items that you want to include in the forecast and click the Include in 
Forecast button. Select either All Line Items or Selected Line Items. The Select 
Adjustment Option window opens. 

3) In the Select Adjustment Option window you have three options. Your selection of an option 
controls how your cost sheet uses the Yet To Buy (YTB) and Allowance For Change data 
sources to construct the forecast. Option behavior is as follows: 

Automatically adjust YTB

 The system automatically changes the line item to Accepted status, subtracts the amount 
from the YTB (or adds it if designed to do so), and includes the line item amount in the 
forecast, if configured to do so. 

 Cell Details displays a line item for System Auto Adjustment that shows the transaction in 
the YTB column 

 Because the value of the YTB cannot become negative, each transaction will be 
processed individually. This may result in only certain transactions being processed, and 
others staying at Unaccepted status. If the transaction was not processed because doing 
so would have yielded a negative YTB, the system will cause an alert. The unaccepted 
line items will be available to view in the Forecast Adjustment window. 

Manually adjust YTB and AFC

 This option becomes available in the Cell Detail window when you click the Include in 
Forecast button 

 You can add, delete, or modify line items before including commits into the forecast 

 The system does not validate the entry or automatically update the YTB in the cost sheet 

No adjustment

 The system will automatically add the commitment into the forecast, if configured, and 
change the status to Accepted. It will not update the Yet To Buy or Allowance For 
Change columns. 

Working with Yet to Buy (YTB) and Allowance for Change (AFC) data sources 

Cost sheet forecasting is designed to leverage the YTB and AFC data sources. If your 
company’s forecast process uses the YTB and AFC data sources then you may configure Unifier 
to automatically reduce the YTB as you accept commits into the forecast. 

In the following example Total Commits is at $4,000, Yet To Buy is at $2,000, Pending Forecasts 
(i.e. Forecasts (Unaccepted)) is at $2,000, and Forecasts is at $2,000. 

When the $2,000 in the Pending Forecasts column is accepted into the Forecasts column, then 
the Yet To Buy decreases by that amount. 

Here we see the amounts in Yet To Buy and Pending Forecasts are reduced and the amount in 
Forecasts is increased. The Yet To Buy value may never go below zero. 
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If designed to do so, the line item commitment may increase the YTB instead of reducing it. For 
example, if you have a change commit that adds scope to a project, when that change commit is 
approved you may want to add scope to the YTB. 

If your company’s forecast process does not use YTB or AFC, you may still use cost sheet 
forecasting. When the Yet To Buy column is added to the cost sheet, column details will show 
any actions previously taken with the YTB. 

To manually adjust YTB and AFC 

1) Click the link in the cost sheet cell to open the Cell Detail window. 

In any column built with the Forecast(Unaccepted) data source, the Cell Detail window will 
have an Include in Forecast button. 

2) Select the line item in the Transactions log and then click Include in Forecast. 

The Select Adjustment Option window is now available. 

3) Select Manually adjust YTB and AFC. The Forecast Adjustment window opens. 

4) To include items in Transactions in the forecast: 

a. Select a line item. 

b. In the Action field select Mark. Unifier refreshes the sheet. 

c. Repeat the last step and select Include marked in Forecast. 

The option Include marked in Forecast changes the status of any marked transactions to 
Accepted and becomes a data source for use in the forecast, if included in the Forecast 
formula. 

Manual actions taken are not validated; you can include a value in the forecast without 
touching the YTB or AFC. 

Working with Work Packages 

A work package is a group of cost sheet rows that is a subset of the project or shell cost sheet. 
Work packages display view-only data taken directly from the project or shell cost sheet and is 
not editable in the Work Package window. Data must be edited in the project or shell Cost Sheet 
window. 

Create a work package 

The following procedure discusses how to create a work package. 

Note: Once a work package has been created, it cannot be deleted. 

To create a work package 

1) In the Navigator in User Mode, open the project or shell. 

2) Click Cost Manager in the left Navigator and then Cost Sheet. The Cost Sheet log opens. 

3) Click the New button. The Work Package Properties window opens. 

4) You can attach files to the work package by clicking the Attach button. 

5) Use the information in the following table to complete the Work Package Properties window 
and click OK. 
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In this field Do this 

Title Enter a title, which displays in the log. 

Reference No. Enter a unique reference number. 

Creator 
This will be populated automatically with the name of the user 
creating the work package. 

Date Initiated This is populated automatically with the initiated date. 

Status Select Active or Inactive. 

Owner 

Vendor 

Description You may enter a description of the work package here. 

Comments Allows for any additional comments. 

Attach Click this button to attach files to the work package. 

No. of Attachments
This link displays the number of files, if any, attached to the work 
package. Click on the link to view or download. 

Open a work package 

To open a work package: 

1) Open the project or shell. 

2) Click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log opens. 

3) Work packages are listed in the log in regular (not bold) font. Select a work package from the 
log and click Open. The Work Package opens. 

Note: You can click the Split button to split the window to scroll through 
the columns while maintaining the CBS code in view. A summary of the 
work package data can be exported into a CSV file from this window. 

Change work package currency 

You can view work packages in the company base currency or the project currency, which may 
differ. 

To choose the currency in which to display the work package data 

Open the Work Package window. In the upper right corner of the window, click the Currency
drop-down list and choose the currency. 

View work package properties 

To open the Work Package Properties window: 



Working with Unifier Managers

113

From the project or shell Cost Sheet log, select the work package and click the Properties
button. The Properties window opens. 

Export work package data 

You can save summary work package data to a local file system in a CSV format. 

To export work package data 

1) From the Work Package window, click the Export button. 

2) Read the confirmation message and then click Yes to continue. 

3) You may choose to open the file in a compatible program such as Microsoft Excel to review 
it before saving. 

4) Click Save and specify the location in which to save the CSV file. 

Working with Worksheets 

Worksheets are extensions of the cost sheet. They can be used as subcost sheets, enabling 
specific calculations or data entry in a separate sheet, which can then be rolled up into a defined 
project or shell cost sheet column. The rows equal the CBS codes on the cost sheet. 
Worksheets can have multiple columns for data entry or formula calculations, but do not support 
data rolled up from business processes. 

Example uses of a worksheet: 

 A worksheet can be used to off-load complex calculations requiring multiple columns. The 
final value can be rolled up into a single cost sheet column. 

 Worksheets are governed by individual permissions. You can design worksheets to use as a 
method of data entry or review for users that you do not want to have any access to the 
project or shell cost sheet, for example, a contractor who is developing an estimate. 

A cost sheet column can be associated with a worksheet as the data entry method. A worksheet 
column can also be associated with another worksheet, as long as there is not a circular 
reference. There can be multiple worksheets in a project or shell. 

Note: A circular reference is referred to a reference in which the last field 
references the first field and creates a closed loop. 

A worksheet template can be created in Administration Mode. Permissions can be controlled for 
individual worksheets. Worksheets are not independently reportable; however, cost sheet 
columns that reference worksheets can be reported on. 

Create a worksheet 

You can create a worksheet by copying a worksheet template or copying a worksheet from 
another project or shell. 

To create a worksheet from a template 

1) In User Mode, click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log 
opens. 
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2) Click New and select Worksheet > Copy from Template. The Copy from Template window 
opens. 

3) Select the template to copy and click OK. The worksheet appears in the log. 

To create a worksheet from another worksheet 

1) In User Mode, click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log 
opens. 

2) Click New and select Worksheet > Copy from Project or Copy from Shell. The Copy from 
Project or Shell window opens. The window lists each worksheet in each project or shell. If 
there are multiple worksheets in a project or shell, each will be listed separately. 

3) Select the project or shell worksheet to copy and click OK. The worksheet appears in the 
log. 

You can add manual-entry or formula columns to a worksheet. Rows are created automatically 
from the CBS codes in the cost sheet. 

Open a worksheet 

To open a worksheet directly from the log 

In User Mode, click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log 
opens. Select the worksheet from the log and click Open. 

Note: When you first open the sheet, the opening view will depend on 
the Default View option selected in the Properties window. Your cost 
sheet administrator can set this default view. Worksheets can be resized 
and split/unsplit the same way as cost sheets (see Resize cost sheet 
window (on page 94) or Split or unsplit cost sheet window (on page 
94)). 

To open a worksheet from the cost sheet 

Click on cost sheet column data that refers to a worksheet as data entry. 

Adding a column to a worksheet is similar to adding a column to the cost sheet. You can add 
manual-entry (direct or line item) columns or formula columns. You can also add columns that 
reference other worksheets. This allows interaction between worksheets. 

The available data sources are Project Worksheet Cost 1 through 50. 

To add a column 

1) Open the worksheet and click the Columns button. The Columns Log opens. 

2) Click New. The Column Properties window opens. 

3) Complete the column properties as usual for a column. 

If you are creating a formula, the data sources that are available for the formula are limited to 
the other columns on the worksheet. 

4) Complete the window and click OK. 
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View or edit worksheet properties 

Worksheet and worksheet type properties can be viewed and edited. The ability to edit 
worksheet properties is dependent on your user permission settings. Contact your project or 
company administrator if you have questions regarding your user permission settings. 

To view or edit worksheet properties 

When you click on your existing project cost sheet from the Cost Sheet log (<Project/Shell> > 
Cost Manager node > Cost Sheet sub node), the right-hand pane of the log displays the 
following tabs:  

 Properties tab

 Audit Log tab

When you open (gear ( ) menu or double-click) your existing project cost sheet from the Cost 
Sheet log (<Project/Shell> > Cost Manager node > Cost Sheet sub node), the Cost Sheet 
window opens and displays the currency, series of toolbar options, and the project cost sheet. 

Note: You cannot edit your existing project cost sheet from the Cost 
Sheet log. 

When you click on a worksheet type in the Cost Sheet log (<Project/Shell> > Cost Manager
node > Cost Sheet sub node), the right-hand pane of the log displays the following tabs:  

 Properties tab

 Permissions tab

 Audit Log tab

These tabs enable you to edit or change the name or description of a worksheet type, view 
permissions for it, and view a log listing the changes in it. 

When you open (gear ( ) menu or double-click) a worksheet type in the Cost Sheet log 
(<Project/Shell> > Cost Manager node > Cost Sheet sub node), the worksheet overlay window 
opens which contains details about the worksheet. If you click on any of the cells, under any 
column in the worksheet, then the Cell Detail window opens which enable you to view the 
information, add attachments, add notes, and so forth. 

Modify worksheet default view 

You cannot modify a worksheet default view, but you can create new views and set any newly 
created view as the default view.  

Add a worksheet column to the cost sheet 

You can roll up the data from a worksheet column into a project or shell cost sheet column. 

To add a worksheet column to the cost sheet 

1) In the cost sheet, click Columns, then click New. The Column Properties window opens. 
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2) In the Datasource column, choose any of the project or shell cost data sources Project 
Cost 1 through Project Cost 25. 

3) For Entry Method, choose Worksheet. 

4) Choose the worksheet (name), and then the column within the worksheet. 

5) Complete the rest of the Properties window and click OK. 

Assign permissions to the worksheet 

You can configure the permission settings for each worksheet, allowing you to control access to 
each worksheet individually. The owner of the worksheet is granted permission to access and 
modify it automatically. The owner must grant permissions for other users or groups to access a 
worksheet. 

To assign permissions to a worksheet  

1) In User Mode, click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log 
opens. 

2) Select one or more worksheets and click Actions > Permissions. You can also click the 

gear menu ( ) and click Permissions to assign permissions to only one worksheet. The 
Permissions window opens.  

3) In the Permissions table, type the user or group name in the Add box and select the user or 
group to grant access. 

4) By default, each listed user or group will be granted View permission, allowing them to open 
the worksheet. To grant additional permissions, select the checkboxes that correspond to the 
user or group: 

 All: User will have View, Edit, and Modify Permission.  

 Modify Permissions: Allows user to control the worksheet’s permission settings. 

 Edit Data: User can import worksheet information, save a snapshot, edit worksheet 
properties, and add columns. 

 View: User can view the worksheet.  

5) Click Save, or click Save & Next to go to the next worksheet. 

You can Remove user or group permission by clicking the trash-can icon in the Remove
column. 

Note: Permissions can only be set for worksheets. You cannot set 
permissions for cost sheets or work packages. 

Import worksheet column details 

You can only import data into columns that are defined as manual data entry. 

To import column details 

1) Click File > Import > Column Details, or click the Import button and choose Column 
Details. The Select Column window opens. 

2) Select the column and click OK. 
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Export worksheet details 

This will allow the user to export details of the worksheet. The following options are available 
under Export: 

 Summary Worksheet: This option will export the entire worksheet similar to cost sheets. 

 Column Details: You can only export data from manual data-entry columns. 

To export a summary worksheet 

Click File > Export > Summary Worksheet, or click the Export button and choose Summary 
Worksheet. 

Project or Shell Cost Sheet Log 

When you click the Cost Sheet node on the left-hand navigator (user mode), you can see the 
Cost Sheet log layout.  

Note: The functions of the options presented in this section have been 
explained in the preceding sections of the Working wit Project or Shell 
Cost Sheet. This section explains new functions and procedural 
differences. 

The log contains the following types of records: 

 Cost Sheet 

 Worksheets 

 Work Packages 

Cost Sheet Log 

When you select a cost sheet row (click on a cost sheet row) the right-hand pane opens. The 
right-hand pane has the following tabs that provide more details on a cost sheet that you have 
selected: 

 Properties

 Audit Log

The Properties tab contains the following fields: 

 Name

Cost Sheet Name. Read only field. 

 Description

Cost Sheet Description. Read-only field. 

 Structure

Read-only field. Displays the selected Radio option only. For example, if cost sheet Structure 
is 'Flat', then this field displays the 'Flat' only (and not 'Tree') structure. 

 Sort WBS

Editable checkbox that is displayed only if the structure is 'Flat'. 

 Segments
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Displays a preview of the cost code structure using the segments and cost code separator as 
defined by the user. 

 CBS Code Label

Read-only field. 

 CBS Item Label

Read-only field. This is same as existing field 'CBS Item' within the block 'Labels' and tab 
'Options.' 

 Forecast Details

Read-only. Displays the radio option selected by the user when defining the cost sheet. 

 Forecast Inclusion

Read-only. Displays the radio option selected by the user when defining the cost sheet. 

 Enable Cost Sheet Forecasting

Read-only checkbox. It is displayed only if the user has selected this option. 

 Enable P6 sources

Editable checkbox. 

The Audit Log tab displays the Audit log (View > Audit Log) for the cost sheet. 

The right-hand pane has the 'Expand' icon at the top right. Use it to expand or collapse the pane. 

The left-hand pane lists all of the shell instances of the same type (the shell in which cost sheet 
is being created). 

If you create a cost sheet in a standard project, then the list shows a list of all standard project 
instances in the company, and you can copy cost sheet from any source. 

The Cost Sheet log layout contains the following columns: 

 Name

 Type

This will be the default sort column, followed by sort on Name

 Status

 Date Created

 Created By

 Reference No.

This column does not appear in an empty log or if there are no work packages in the log. 
That is to say that this column appears only if there are work packages within the log. 

The following options are available on the toolbar:  

 Create

 View

 Find

The following explains each option in details. 

Create

When no Cost Sheet has been created yet, there are two sub-menu options available: 
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 from Template

Lists all of the available Cost Sheet Templates within the company. You can create a Cost 
Sheet within the project/shell when you click New > Cost Sheet > Copy from Template. 

 from <shell type>

When you select this option, the Create Cost Sheet from Project window opens. In this 
window you can: 

 See the selected project 

 Manually enter columns from a list of available columns 

 Determine the shell size, location, and duration 

The fields in this window capture the factors that you can copy over manual entry columns from 
source project/shell cost sheet to destination. The Available Columns displays a list of all manual 
entry columns from the selected project cost sheet. You can select none or any number of 
available columns in the right section. The Factors fields enable you to enter a factor to copy 
over the manual entry columns into the cost sheet.  

When you click Done, a new cost sheet will be created in the project.   

View

The default view is All which results in the display of all sheets in the log. You can select 
Group by Type view which results in the cost sheets grouped by type, with the cost sheet at 
the top. 

Find

To find an item on the log. You can do a text based 'Find' on each column. 

When no records have been created within the log, the right-hand pane is blank. You can 
collapses the right-hand pane. 

When there are records within the Cost Sheet node, then the Project Cost Sheet is selected by 
default. 

When there are records within the Cost Sheet node, the Create option has the following 
sub-menu options: 

 Worksheet (Same as creating the cost sheet from a template or from another project. 
Selecting any template creates a new worksheet in the project by copying the selected 
template.) 

 from Template (Selecting any template creates a new worksheet in the project by copying 
the selected template.) 

Project Cost Sheet - Template 1 < listing all the available WorkSheet Templates in the 
Company 

Project Cost Sheet - Template 2 < listing all the available WorkSheet Templates in the 
Company 
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 from Project (Selecting from project enables you to select a worksheet from another shell 
of the same type in which the worksheet is being created. This picker is similar to the 
'Select Project' picker in 'Create Cost Sheet from Project' window. Similar to 'Select 
Project' picker in 'Create Cost Sheet from Project' form, when you click at the 'Select 
Project' picker a flat list of all worksheets from all shells of same type as the one in which 
the worksheet is being created. You can select 'Create Worksheet (from project) and 
then navigate to some other log within Unifier without taking any action in the resulting 
overlay form. In such scenario, when you return to the Cost Sheet log, the previously 
opened overlay form will continue to show up in the log. 

 Work Package 

When you select to create a new Work Package, you will see a new overlay window (Create 
Work Package). The 'Owner' picker is similar to a single-select type-ahead user picker at 
other places in Unifier (For example: Transfer Ownership action within BP logs). The 'Vendor' 
picker is a single select type-ahead Company picker (similar to the single select user picker). 
Both pickers provide suggestive text informing you that these are type-ahead boxes. 

If you select more than one record from the cost sheet log at the same time, the right-hand pane 
will be blank with message: Details of multiple records cannot be viewed. 

Note: If you select more than one worksheet at the same time, then the 
right-hand pane displays the Permissions tab. 

Worksheet Log 

When you select a project or shell worksheet (click on the row), the right-hand pane opens and 
displays the following tabs: 

 Properties

 Audit Log

The Properties tab is displayed by default and contains properties of the Worksheet. The 
General block in this tab has the following tabs: 

 Name: Worksheet Name. Editable Text Box, DD will be same as existing 

 Description: Worksheet description. Editable text box, DD will be same as existing. 

The Audit Log tab displays the Audit log (View > Audit Log) for the Worksheet. 

The right-hand pane has the 'Expand' icon at the top right. Use it to expand or collapse the pane. 

If you select more than one record from the worksheet at the same time, the right-hand pane 
displays the Permissions tab. This will enables you to set permissions for more than one 
worksheet at the same time. 

To grant permission to a worksheet  

1) In User Mode, click Cost Manager > Cost Sheet in the left Navigator. The Cost Sheet log 
opens. 

2) Select one or more worksheets and click Actions > Permissions. You can also click the 

gear menu ( ) and click Permissions to assign permissions to only one worksheet. The 
Permissions window opens.  
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3) In the Permissions table, type the user or group name in the Add box and select the user or 
group to grant access. 

4) By default, each listed user or group will be granted View permission, allowing them to open 
the worksheet. To grant additional permissions, select the checkboxes that correspond to the 
user or group: 

 All: User will have View, Edit, and Modify Permission.  

 Modify Permissions: Allows user to control the worksheet’s permission settings. 

 Edit Data: User can import worksheet information, save a snapshot, edit worksheet 
properties, and add columns. 

 View: User can view the worksheet.  

5) Click Save.

6) When editing one record at a time, click the left arrow to view the previous worksheet or the 
right arrow to view the next worksheet. 

7) After exiting the Permissions window, the Permissions tab will be refreshed with the updated 
information. 

You can Remove user or group permission by clicking the trash-can icon in the Remove
column. 

Work Packages 

When you hover over a Work Package row, the gear menu ( ) displays. 

When user will select a Work Package row (click on the Work Package row), the right-hand pane 
opens and displays the following tabs: 

 Properties

 Attachments

Note: The 'Vendor' is a company picker. 

The Properties tab is displayed by default and contains properties of the Work Package. The 
General block contains all of the elements of the Work Package properties window. 

The Attachments tab has the same elements of the Attachments tab in a BP log. You can add 
attachments from a Document Manager, or your local computer, from this tab. 

The gear ( ) menu, for any attachment has the following options: 

 Review

 Autoview Review

 Download

 Remove

You can right-click on multiple attachments and perform download or remove. 
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Working with the Company Cost Sheet 

Like other cost sheets, the ability to work with a company cost sheet is dependent upon the 
permissions that you have. Contact your project or company administrator if you have questions 
regarding your permission levels. 

Open the company cost sheet 

When you first open a company cost sheet, the opening view that you see will depend on the 
Default View option selected in the cost sheet Properties window. 

To open a company cost sheet 

1) Go to the Company Workspace tab and click Cost Manager > Cost Sheet in the left 
Navigator. The Cost Sheet log opens. 

2) Select the company cost sheet from the log and click Open. The Company Cost Sheet 
opens. 

Note: Company cost sheets can be resized and split/unsplit the same 
way as project or shell cost sheets (see Resize cost sheet window (on 
page 94) or Split or unsplit cost sheet window (on page 94)). 

Search for project or shells (rows) 

You can search for projects or shells that are listed on the sheet. A new Company Cost window 
will open, displaying only those project or shells meeting the search criteria. 

To search for a project or shell 

1) In the Company Cost Sheet window, click Find. The Search window opens. 

2) Select the search criteria and click OK. 

Export company cost sheet data 

You can export summary cost data and column details into a CSV file. 

To export company-level cost sheet data 

1) From the company cost sheet, click the Export button and then choose one of the following: 

 Summary Cost Sheet: This allows you to export complete cost sheet information, 
including project or shell name, number, and data from all columns. 

 Column Details: This exports only Company Cost 1 to Column Cost 25 logical data 
sources that are configured as manual entry. Click Column Details to open the Select 
Column window and select the columns to export. 

2) Read the confirmation message and then click Yes to continue. 

3) You may choose to open the file in a compatible program such as Microsoft Excel to review 
it before saving. 

4) Click Save and specify the location in which to save the CSV file. 
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Import company cost sheet data 

You can import manual entry columns into the cost sheet from a CSV file, such as a Microsoft 
Excel spreadsheet saved in CSV format. 

To import company cost sheet data 

1) In the company cost sheet, click the Import button then choose Column Details. 

2) Browse to the CSV file to import, select it, and click. 

View or edit company cost sheet properties 

The ability to edit company cost sheet properties is dependent on your user permission levels. 

To view or edit company cost sheet properties 

Select the cost sheet from the log and click the Properties button, or open the cost sheet and 
click File > Properties. The Properties window opens. In this window, you can change the 
default view in the General tab or map account codes to company cost sheet columns in the 
Options tab. 

Working with the Program Cost Sheet 

The following sections describe how to open a program cost sheet, search for listed project or 
shell cost sheets, and import and export cost sheet information. 

Data rolls up to the program cost sheet columns from individual project or shell cost sheet 
columns by data source. The data displayed on the program cost sheet is view only. 

Open the program cost sheet 

To open a program cost sheet: 

1) Open the program and click Cost Manager > Cost Sheet in the left Navigator. The Cost 
Sheet log opens. 

2) Select the program cost sheet from the log and click Open. The Program Cost Sheet opens. 

Note: You can click the Split button to split the window to scroll through 
the columns while maintaining the CBS code in view. A summary of the 
work package data can be exported into a CSV file from this window. 

This item Does this 

Save As Click this button to save a snapshot copy of the cost sheet. 

Export 

Click and select one of the following: 

Summary Cost Sheet 

Column Details 
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Import Imports column details. 

Columns 
Opens the Columns log, from which you can add or manage cost sheet 
columns. 

Find Click to search for a cost code. 

Split 
Splits the window vertically so you can scroll through the columns while 
maintaining a view of the project or shell number. 

Cost Sheet 
cells 

Click on a cell to view the Cell Details window. 

Project or 
Shell 
Number 

Click on the project or shell number to open the project or shell cost sheet.

Column 
Heading 

Click on a column heading to view more information about the column 
type. 

File Menu 
> Open 

Opens the Snapshot log. 

Search for project or shells (rows) 

You can search for projects or shells by project or shell type and project or shell site. A new 
Program Cost window will open, displaying only those project or shells meeting the search 
criteria. 

To search for a project or shell 

1) In the Program Cost Sheet window, click Find. The Search window opens. 

2) Select the search criteria and click OK. 

Export program cost sheet data 

To export program-level cost sheet data 

1) In the program cost sheet, click the Export button and then choose one of the following: 

 Summary Cost Sheet: This allows you to export complete cost sheet information, 
including project or shell name, number, and data from all columns. 

 Column Details: This exports only Program Cost 1 to Program Cost 25 logical data 
sources that are configured as manual entry. Click Column Details to open the Select 
Column window and select the columns to export. 

2) Read the confirmation message and then click Yes to continue. 

3) You may choose to open the file in a compatible program such as Microsoft Excel to review 
it before saving. 

4) Click Save and specify the location in which to save the CSV file. 
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Import program cost sheet data 

You can import manual entry columns into the Cost Sheet from a comma-delimited (CSV) file 
(such as a Microsoft Excel spreadsheet saved in CSV format.) 

To import program cost sheet information 

1) From the program cost sheet, click the Import button then choose Column Details. 

2) Browse to the CSV file to import, select it, and click OK. 

Working with Company Accounts Sheets 

The company accounts sheet is used to track company level accounts information, such as 
assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using 
account codes instead of CBS codes. 

Account codes are independent of CBS codes, but are similar in structure format. 
Company-level business processes can be designed in uDesigner to roll up to the accounts 
sheet (line items are associated with account codes). 

Open the accounts sheet 

To open the accounts sheet: 

1) In User Mode, select Company Workspace > Cost Manager > Accounts Sheet. The 
Accounts Sheet log opens. If an accounts sheet has been created, it will be displayed in the 
log. 

2) Select the sheet and click Open (example below.) 

Note: When you first open the sheet, the opening view will depend on 
the Default View option selected in the Properties window. Your 
accounts sheet administrator can set this default view. Accounts sheets 
can be resized and split/unsplit the same way as project or shell cost 
sheets (see Resize cost sheet window (on page 94) or Split or unsplit 
cost sheet window (on page 94)). 

The accounts sheet works similarly to cost sheets. Like cost sheets, you can: 

 Enter data into manual data-entry columns. 

 View rolled up transaction details by clicking a cell with a hyperlink. 

 View a column definition by clicking a column heading. 

 Copy column data from one column to another (Edit > Copy > Column Data; the original 
values will be overwritten). 

 Save and view snapshots (File > Create Snapshot; View > Snapshot Log). 

 Import and export column details. 

 Export accounts summary sheet. 



Unifier Managers User Guide

126

Activate or deactivate account codes 

You can control the status of account codes. If an account code is inactive, it will be displayed 
on the accounts sheet, but will not be available for selection in an Account Code picker, such as 
on company account business process transactions. 

To activate or deactivate an accounts code 

1) Open the accounts sheet. 

2) Click the Account Status button. The Account Code Status window opens. 

3) Select one or more account codes. 

4) Click Activate or Deactivate. 

View or edit accounts sheet properties 

Accounts sheet properties can be viewed and edited. The ability to edit properties is dependent 
on your user permission settings. Contact your project or company administrator if you have 
questions regarding your user permission settings. 

To view or edit accounts sheet properties 

Select the accounts sheet from the log and click the Properties button, or open the accounts 
sheet and click File > Properties. The Properties window opens. The following properties are 
displayed and are editable by the cost administrator: 

 Title: This is the title of the sheet, and displays in the log. 

 Description: This optional field can be used to provide a description or other information 
about the accounts sheet. 

 Display Mode: This determines whether the accounts codes are displayed in a flat list, or 
a hierarchical tree mode. This setting can be switched back and forth as needed. 

 Default View: These are the settings that determine how the sheet appears when first 
opened by any user from the log. 

About Funding 

The Funding manager helps you to keep track of where project or shell funding comes from and 
how it is being spent. This feature is accessed via the Funding node under the Cost Manager. 
Use the Funding sheet to specify the appropriation and assignment of funds from each source. 
You can automate fund appropriation and assignment when used with Cost business processes. 

Company and project/shell funding 

 Design and import a fund attribute form in uDesigner. This will be used as the Fund 
Details window when adding new funds to the company funding sheet, or viewing fund 
properties. A fund picker, used to add funds to business processes or the project/shell 
funding sheet, can also be designed. This is an optional step. If you do not create a fund 
attribute form, a default fund code form and fund picker will be used. 

 Import and set up fund business processes. You can use business processes for fund 
allocations, fund assignment (consumption), and fund credits. 
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 Create and set up the Company Funding Sheet. The company funding sheet tracks the 
funds that can be used to fund project or shell expenses. The following procedures assume 
that the rows (funds) and columns of the funding sheet have already been created. 

Create and set up the Project/Shell Funding Template and Sheet. The project or shell 
funding sheet tracks the funds that have been allocated from company funds for a particular 
project or shell. The project or shell funding sheet is based on the funding template, which is 
created first. The following procedures assume that the project/shell funding sheet has been 
created, rows and columns have been added. Note: The rows correspond to funds chosen 
from the company funding sheet. Funds can be added manually, or can be added via fund 
allocation business processes, discussed later in this section. 

 Define funding assignment rules. Funding assignment rules are set up in the project/shell 
funding sheet and/or template. These determine which business processes are used for fund 
appropriations and assignments and how to consume funds (ratio or fund order) if you will be 
using automatic fund assignment from business processes. The following procedures 
assume these options have been set up. 

 Create funding rules in the rules engine. Optionally, funding rules can be created in the 
rules engine that can help you manage your funds and fund balances, for example, to 
prevent fund balances from becoming less than zero. 

Commitment level funding 

Optionally, funding at the base commit (contract) level can be set up. 

Commitment funding works in conjunction with the Schedule of Values (SOV) sheet. SOV line 
items have an impact on the commitment funding sheet and its data through fund assignment. 

Before you begin. Be sure that the project/shell funding has been set up, with funds allocated 
and available on the project/shell funding sheet. Data sources are available for project/shell 
funding sheets (and company funding sheets) to track funding that is assigned for specific base 
commits. Also, be sure the data source Scheduled Value has been added as a column to the 
SOV structure for the project or shell. Commitment funding uses the SOV to track base commit 
and change commit amounts, and uses the Scheduled Value column to track remaining 
balances. 

 Import and set up business processes for commitment funding. In addition to business 
processes that are used for project/shell funding, you can design business processes for use 
with commitment funding. In uDesigner, commitment funding is enabled on the base commit; 
automatic generation of an SOV must also be enabled. Then, the ability to view and/or 
assign funds is enabled per step on the base commit and the corresponding change commit. 
Be sure the linked spends business process has been enabled to consume funding. 

 Create and set up Commitment Funding Template. This template is used to create a 
commitment funding structures in the project or shell, which in turn is used to create the 
individual commitment funding sheets for each base commit record. These procedures 
assume a template has been created and set up with columns. 

 Define funding assignment rules. This is done in the Assignment tab of the Properties 
window. Assignment rules can be defined in the commitment funding template, structure or 
sheets. (This procedure assumes assignment rules have been defined in the template, and 
will be copied to the structure and individual sheets.) 
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 Create Commitment Funding Sheet Structure. Structures are created at the project level in 
user mode from a commitment funding template. When commitment funding sheets are 
created from base commit records, this default structure is used. Details about creating 
commitment funding structures from an existing template are found later in this section. 

 Create individual commitment funding sheets. This is done automatically the first time you 
click the Funding button on a base commit business process form (this button becomes 
available on specific steps as designed in uDesigner). After creation, the commitment 
funding sheet is available for viewing or modification by clicking the Funding button on the 
base commit or associated change commits, or from the Commitment Funding log itself. 
Details about creating commitment funding sheets is found later in this section. 

 Configure permissions. In addition to module level permissions that are needed to create 
and modify templates, structures and sheets, record level permission must be granted to 
individual commitment funding sheets. By default, the owner of the base commit will have 
permissions to the sheet. Additional users must be granted view or edit permissions. This is 
discussed later in this section. 

Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding 
Sheets 

The first step to setting up funding is to create and set up a company funding sheet, where 
individual funding sources are set up. 

For example, a corporation's funding sources may include different types of corporate accounts. 
For municipal or educational facilities, funds may come from bond measures, grants, donations 
or other sources. All of these funding sources will be listed and tracked on the company funding 
sheet. As funds are consumed via business processes or manually in individual project or shells, 
this data is rolled up to the company funding sheet. 

Project or shell funding sheets track how your company’s funding is being spent on each project 
or shell. It tracks individual transactions, which are rolled up to the company funding sheet. All 
project or shell funding sheets must be created based on a funding template. 

If you are using commitment funding, you will create a commitment funding template, which is 
used to create the commitment funding structure within a project or shell. As base commits (that 
are designed for commitment funding in uDesigner) are routed and approved, a commitment 
funding sheet is created, based on this structure, for each base commit record. 

Working with the Company Funding Sheet 

The following procedures described managing funds on the company funding sheet. 

Open the company funding sheet 

The company funding sheet is accessed from the company level Cost Manager. 

To open the company funding sheet 

1) Go to the Company Workspace tab and click Cost Manager > Funding in the left Navigator. 
The Funding log opens. 

2) Select the company funding sheet and click Open. The Company Funding Sheet opens. 
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Note: You can click the Split button to split the window to scroll through 
the columns while maintaining the fund listing in view. 

About company funding sheet columns 

The columns on the company funding sheet are used to track project and shell level funding and 
keep track of fund balances. 

A common way to enter the starting value of a fund is by adding a Company Funding column to 
the company funding sheet. This is generally a manual entry column (either direct entry or line 
item entry). The original value of each fund (one fund per row) is entered into this column. 

Additional columns commonly track fund assignments (consumption) made against each fund in 
projects or shells. These can be in the form of business process transactions or manual funding 
assignments. Each project or shell level business process or manual entry column can be rolled 
up to the company funding sheet separately, or project/shell fund assignments can be totaled in 
the project/shell sheet, and rolled up to the company sheet. A good practice is to have a fund 
balance formula column that tracks the difference between the original fund value minus all 
funding assignments, which provides a running balance for each fund. A rule can be created in 
the Rules Engine to make sure that this fund balance never becomes less than zero (or other 
specified value). 

To view column details 

In the funding sheet, click a column header link to view the column details. This will display the 
data source and, for formula columns, display the formula used. 

About company funding sheet rows 

Each row in the company funding sheet corresponds to one fund. Depending on how the 
company funding sheet is set up, the starting value of each fund may need to be manually 
entered. This is commonly done in a column using the Company Funding data source. 

If you are working with a large number of funds, there are ways to help you find the fund that you 
are looking for. You can search for individual fund codes using the Find feature. You can also 
create and apply filters, which can be used to temporarily limit the number of funds displayed on 
the sheet. For more information, see the following topics: Searching for Fund Codes (on page 
143), Creating and Applying Filters (on page 144). 

To view fund details 

In the funding sheet, click the fund code link (in the Fund Code column) to open the Fund 
Details.  

 If a Fund Attribute form has been designed in uDesigner, this window shows the fields on 
the form.  

 If a Fund Attribute form is not being used, the default window opens, showing basic 
information such as the fund code, fund name and description. 
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Add currency amounts to company funds 

Once the company funding sheet has been set up, the funds must be "funded" -- enter the 
funding amounts that will be used to fund your projects and shells. Commonly, the Company 
Funding data source is used as a manual entry column to enter the starting amount of each 
fund, or add additional funds to it. This column can be direct entry or line item entry. 

This procedure assumes the funds have already been added to the sheet. It also assumes that a 
column has been added to the sheet for manual fund entry. Commonly, this uses the Company 
Funding data source. You can click a column heading to verify the data source used. 

To add a value to a company fund 

1) Open the company funding sheet. 

2) Locate the column that is used for adding value to company funds on the sheet, commonly, 
the Company Funding column. 

3) Do one of the following: 

 If the column is direct entry, click inside the cell and enter the amount. If the cell already 
has a value, you can modify it. 

 If the column is line item entry, click the link in the cell. The Cell Detail window opens in 
which you can can take these actions. 

 Click Add Line Item to add a new line item. 

 Select a line item and click Copy Line Item to add a line item by copying another.  

 Double-click an existing line item to modify it.  

 Select a line item and click Remove Line Item to remove it. 

4) Enter the line item information in the Line Item window and click OK. 

The amount in the Company Funding column can be used as the starting amount of a fund. 
Other columns on the company funding sheet can be used to roll up transaction and manual 
funding amounts from project/shell funding sheets, and formula columns can be added to keep 
track of the fund balance. 

Activate or deactivate company funds 

You can active or deactivate company funds, which controls their availability for project or shell 
funding. If you set a fund to "Inactive" at company level, then that fund will no longer be available 
for project- or shell-level funding sheets; however, if a fund is already listed on a project or shell 
funding sheet, inactivating the fund at the company level will not affect the fund. 

To set the company fund status 

1) Open the company funding sheet 

2) Click the Fund Status button on the toolbar. The Fund Status window opens. 

3) Select a fund in the table, then click Activate or Deactivate. 

4) Click Close to exit the window. 
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Import or export Company funding sheet information 

You can export a summary of the funding sheet, which creates a CSV file that contains the rows, 
columns and data on the funding sheet. You can also export a CSV file containing fund details, 
which includes all fund codes on the sheet and the data captured for them from the Fund Details 
window. This is available in company, project and shell funding sheets. 

You can also import fund details to a company funding sheet. This allows you to add fund codes 
to a funding sheet directly from a CSV file, rather than add them manually. 

For details, see Importing and Exporting Project/Shell Funding Sheet Information (on page 
146) 

Working with Project or Shell Funding Sheets 

The Project/Shell Funding Sheet tracks how funding is being allocated and consumed at the 
project or shell level. Project or shell funding sheets work in conjunction with the company 
funding sheet. Fund allocation, assignment and credits can be done manually, or through a 
business processes. 

Note: Since funding originates at the company level in the company 
funding sheet, funding is always done in base currency, even if the 
project currency is different. 

Open a project or shell funding sheet 

The project or shell funding sheet is accessed from the Cost Manager > Funding > Funding 
Sheet log. 

Note: There is only one funding sheet per project or shell. 

To open a project or shell funding sheet 

1) Open the project or shell and click Cost Manager > Funding > Funding Sheet in the left 
Navigator. The Funding Sheet log opens. 

2) Click the gear menu ( ) and select Open, or double-click, on the project or shell funding 
sheet to open the funding sheet window. 

You can click the gear menu ( ) and select Open Classic Interface, to open the project or 
shell funding sheet in Classic View.  

The Funding Sheet window has the following, typical, page headers: 

 Funding Sheet 

 Currency 

 Unassigned (Project Level) 

 Commitment Level 

 CBS Level 

The Funding Sheet window has the following toolbar options: 
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Note: For projects that do not have funding sheet, you can use the 
Create toolbar option (in Funding Sheet window) to create a funding 
sheet. The Create option will not be displayed for the users with View 
permission. To create a funding sheet, click Create to open the Select 
Template window and select a template. 

Funding Sheet 
Window Toolbar 
Option

Description

Manage Rows

(icon with three 
horizontal lines) 

Opens the Manage Rows window which enables you to manage 
the displayed rows based on the available company fund codes. 

Add Column

(icon with three 
horizontal lines) 

Opens the New Column window that enables you to enter data 
about the new column. 

View  Default 

 Create New View 

 Manage Views 

Edit View Opens the Edit View window which enables you to manage the 
displayed view based on the following tabs: 

 Columns 

 Filters 

 Group By 

 Sort By 

Fund Assignment 
Order

Opens the Fund Assignment Order window which enables you to 
manage the order for: 

 Fund Code 

 Fund Name 

 Status 

 Reorder: Bring the pointer to the cell to activate the 
move-pointer, click and hold, and move the row to a desired 
location. 

Refresh Enables you to refresh the contents of the Funding Sheet
window. 

Print  Print 

 Export To CSV 

 Export To Excel 
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Find on Page Enables you to find a particular record on the page. 

Menu Options  Export 

 Summary Fund Sheet 

 Fund Details 

 Row Coloring 

 Multi-Color 

 Single Color 

 Properties 

 Audit Log 

Create and Edit Transactions 

You can manually enter transaction line item. 

Note: Including attachments is not permitted in line items. Cloud 
customers who have migrated to the 20.6 version of Unifier will not be 
able to see the previous attachments or add new attachments post 
migration. 

About project/shell funding sheet columns 

The columns on the project/shell funding sheet are used to track the funding on that project or 
shell, and to keep track of the fund balances that have been appropriated for its use. 

Commonly, the Project Funding column is used to enter the allocation amount of each fund for 
that project/shell. 

Additional columns commonly track fund assignments (consumption) made against each fund. 
These can be in the form of business process transactions or manual funding assignments, with 
one column for each business process, and manual entry columns for project level funding and 
CBS level funding. 

The Records Funded at Project Level (or CBS Level) column(s) can be used to track the totals 
of business process transactions involving fund assignment. This is used for records already 
reaching terminal status. The Transient Records Funded at Project Level (or CBS Level) 
column(s) works similarly, but is used for records that are currently in process, and have already 
been funded before reaching terminal status. These columns can also include any credited 
funding that may occur due to invoice credits or other negative amounts. 

Commitment level funding can be tracked on the project/shell funding sheet using the columns 
Commitment Funding (tracks funds that are allocated across base commit and change commit 
business process records enabled for commitment funding), Records Funded at Commitment 
Level (sum of all spends records that are funded at the commitment level), and Transient 
Records Funded at Commitment Level (sum of all in-process records that are funded at the 
commitment level). 
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A good practice is to add a fund balance formula column that tracks the difference between the 
original fund value minus all funding assignments, which provides a running balance for each 
fund. 

To view column details 

In the funding sheet, click a column header link to view the column details. This will include the 
data source and, for formula columns, display the formula used. 

About project/shell funding sheet rows 

Each row in the project or shell funding sheet corresponds to a fund that has been allocated for 
use on this project or shell. Each fund originates on the company funding sheet. 

Fund allocation can be done manually, by adding rows to the project/shell funding sheet. A fund 
picker is used to select which funds from the company funding sheet to add. 

Funds can also be allocated to a project by using a fund allocation business process that is 
designed to choose the funds and funding allocation amounts for the project/shell. 

For manually allocated funds, the starting amount of each fund can be entered manually. 
Commonly, the Project Funding column is used to enter the starting value of each fund when 
funds can be used for the project regardless of CBS code, or the CBS Funding column is used 
when funding is specified per CBS code. These value can roll up to the company funding sheet 
column of the same data source. 

If you are working with a large number of funds, there are ways to help you find the fund that you 
are looking for. You can search for individual fund codes using the Find feature. You can also 
create and apply filters, which can be used to temporarily limit the number of funds displayed on 
the sheet. For more information, see the following topics: Searching for Fund Codes (on page 
143), Creating and Applying Filters (on page 144). 

To view fund details 

In the funding sheet, click the fund code link (in the Fund Code column). The Fund Details 
opens. If a Fund Attribute form has been designed in uDesigner, this window will include the 
fields added to the form in the design. If a Fund Attribute form is not being used, the default 
window opens, listing basic information such as the fund code, fund name and description. 

View Project/Shell funding sheet properties 

The Properties window defines general setup information and assignment details for the funding 
sheet. 

To view project or shell funding sheet properties 

1) In the project or shell Funding log, select the funding sheet and click the Properties button. 
The Properties window opens. 

 The General tab defines the Title, Description and Display Mode for the sheet. If you 
have edit permissions, you can edit these, including switching back and forth between 
the display mode options as needed. 

 The Assignment tab is used to define the funding assignment options: 
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 Project and CBS Level: Specifies the sources of fund allocation for the project or 
shell, either manual entry or via fund appropriation business processes. 

 Assignment Levels and Rules: For each funding business process that has 
been set up for the project or shell, this specifies how funds are assigned, either 
manually, Auto Order, or Auto Ratio: 

For more information, see About Project/Shell funding assignment options (on page 
135). 

2) Click OK or Cancel to close the window. 

About Project/Shell funding assignment options 

Funding assignment options for the project or shell are defined on the Assignment tab of the 
Properties window. (Open the funding sheet, and choose File > Properties.) This includes 
defining how fund allocation can be done, specifying whether manual assignment is allowed, 
defining the business processes that can be used to assign funds to project or shells or to 
specific CBS codes, and defining assignment levels. 

Project Level and CBS Level: Specifies how funds can be added for this project or shell. This 
can be Manual (appropriate funds manually from the company funding sheet), and/or through 
funding appropriation business processes. 

You can define funding appropriations at the project level (not associated with specific CBS 
codes), and at the CBS level (funding is specified per CBS code). You can "mix and match" for 
each project, with some business processes using project level funding, and others CBS level. 
Manual fund appropriations can be done at both levels. 

Assignment Levels and Rules: Specifies how assignment is done for each funding business 
process that has been set up for the project or shell: Manual, Auto Order, or Auto Ratio. It also 
specifies whether funds are assigned at the Project Level (funding is consumed based on the 
total of the spends business process, providing greater flexibility for fund assignment), or CBS 
Level (funding is consumed per line item of a spends business process, which provides greater 
control over how funds are spent on each item.) 

 Manual: Funds can be manually assigned. As spends business processes (e.g., invoices or 
payment applications) are routed and reach specified statuses, the amounts to be funded 
are collected under the Unassigned total on the funding sheet. A Funding button becomes 
available on the business process form. Clicking the button opens the Funding window, in 
which funds can be assigned. 

 Auto Order: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund order, which is defined on the 
funding sheet by clicking the Fund Assignment Order button. When funds are consumed 
on one fund, then the next funding source is used for funding. Once all funds are consumed, 
remaining spends are collected under Unassigned. 

 Auto Ratio: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund ratio, which is automatically 
calculated based on current fund levels. Once all funds are consumed, remaining spends are 
collected under Unassigned. 
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View funding sheet cell details 

The values displayed in a cell on the funding sheet may reflect information from multiple line 
items, business process transactions, or results of a calculation from other cells. The following 
procedures discuss how to view the details about an entry in a funding sheet cell. 

To open the Cell Details window 

In the Funding Sheet window, click the link in the line item cell to view information. The Cell 
Detail window opens. 

To view manual line item entry details 

In the Cell Detail window, double-click a listed line item. The Line Item window opens. 

To view business process transaction details 

1) In the Cell Detail window, double-click a listed line item. A view-only copy of the business 
process transaction opens. 

2) Double-click a line item. The Line Item window opens. 

To view formula cell details 

In the Cell Detail window, if line items from manual-entry columns or business process 
transaction columns are included in the calculation, they will be listed in the lower portion of the 
window, with the calculated value for each line item. 

1) Click a listed line item. If the line item is a BP transaction, the business process form opens. 
If the line item is a manual entry, the Line Item window opens. 

2) To view the formula used for the column, click the Formula link. 

View Audit Logs 

Audit logs are available within the Fund Detail and Cell Detail windows of the project or shell 
funding sheet. The Audit log captures all of the events that took place, including what action 
occurred, who took the action, and the value that was created or modified. 

To view the project or shell funding audit log 

Open the project or shell funding sheet and do one of the following: 

 From the View menu, click Audit Log. 

 Click a listed fund to open the Fund Detail window, and then click the Audit Log button. 

 Click a cell link (line item or project or shell allocation entry) to open the Cell Detail 
window. From the View menu, click Audit Log. 

To view commitment funding audit logs 

Open the commitment funding sheet and do one of the following: 

 From the View menu, click Audit Log. 

 Click a listed fund to open the Fund Detail window, and then click the Audit Log button. 

 Click a cell link (line item or project or shell allocation entry) to open the Cell Detail 
window. From the View menu, click Audit Log. 
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To view an audit log of company funding 

Open the company funding sheet and do one of the following: 

 From the Funding Sheet View menu, click Audit Log. 

 Click on a listed fund to open the Fund Detail window, then click the Audit Log button. 

 Open the Cell Detail window. From the View menu, click Audit Log. 

The Audit log captures all of the events that took place, including what action occurred, who took 
the action, and the value that was created or modified. 

Allocating Funds to a Project or Shell 

This section discusses fund allocation. Allocation refers to reserving a certain amount of a 
company fund to a particular project or shell. 

Funds can be allocated to a project or shell either by manually adding rows to the project/shell 
funding sheet and entering allocation amounts, or through business processes transactions, 
which automatically add the rows and allocation amounts. 

Refer to Unifier Business Processes User Guide to review information about Schedule of Values 
(SOV) Sheets and Business Processes. 

Fund allocation can be done at the project/shell level (funds are available to any expense in the 
project or shell), or at the CBS level (funding is allocated per CBS code). 

Manually enter project/shell fund allocation amounts 

Once the project/shell funding sheet has been set up, the funds must be "funded" -- enter the 
funding amounts that will be used to fund your projects and shells. The following procedures 
discuss manually allocating funds and entering amounts to the funds that will be used in the 
project or shell. (Fund allocation using business processes is discussed in a later section.) 

Commonly, the Manual Funding By Project data source is used as a manual entry column to 
enter the starting amount of each fund, or add additional funds to it. This column can be direct 
entry or line item entry, and is used for project level fund allocation. The Manual Project by CBS 
data source can be added to the project/fund cost sheet, and values added there. The same 
column data source can be added to the project/shell funding sheet to display the values added 
to the cost sheet column. This is used for CBS level fund allocation. 

The following procedures assume that the appropriate funds (rows) and columns have already 
been added to the funding sheet. You can click a column heading to verify the data source used. 
For details about adding funds (rows) or columns to the company funding sheet. 

To enter project level fund allocation values (on the funding sheet) 

1) Open the project or shell funding sheet. 

2) Locate the column that is used for adding value to funds on the sheet, commonly, the 
Manual Funding by Project column. 

3) Do one of the following: 

 If the column is direct entry, click inside the cell and enter the amount. If the cell already 
has a value, you can modify it. 
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 If the column is line item entry, click the link in the cell. The Cell Detail window opens. 
You can: 

 Click Add Line Item to add a new line item. 

 Select a line item and click Copy Line Item to add a line item by copying another. 

 Double-click an existing line item to modify it. 

 Select a line item and click Remove Line Item to remove it. 

Enter the line item information in the Line Item window and click OK. 

This amount can be used as the starting project level amount of a fund. Other columns on the 
funding sheet can be used to track transactions, and formula columns can be added to keep 
track of the fund balance. 

To enter CBS level fund allocation values (on the cost sheet) 

1) Open the project or shell cost sheet. 

2) Locate the column that is used for adding value to funds by CBS code, commonly, the 
Manual Funding by CBS column. 

3) Click the link in the cell. The Cell Detail window opens. You can: 

 Click Add Line Item to add a new line item. 

 Select a line item and click Copy Line Item to add a line item by copying another. 

 Double-click an existing line item to modify it. 

 Select a line item and click Remove Line Item to remove it. 

4) Complete the Line Item window. 

5) Select a fund from the fund picker by clicking the Select button for the Funding Source. The 
fund picker lists the funds that are active at the company level. To search for a specific fund, 
click Find. 

6) Click OK. The new line item will be added to the Cell Detail window. If the Manual Funding 
by CBS column has also been added to the project/shell funding sheet, the value will display 
there. 

To add funding sheet data through a formula 

Formula columns calculate results based on data entered in other columns. You cannot enter 
data directly into a formula column. You may click the funding sheet column header to view the 
data source for the cells in the column. If the column is a formula column, it will be displayed, 
and you can view which other columns are used in the calculation. 

Allocate funds through business processes 

Funds can be allocated to a project or shell using a fund allocation business process, which was 
defined in uDesigner. Following is a summary of the business process types and design options 
that may be used: 

 Project level: 

 Cost type, subtype line items with fund code, classification generic. 

 Workflow or non-workflow 

 CBS level: 
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 Cost type, subtype line items with CBS and fund code, classification generic. 

 Workflow or non-workflow 

Commonly, columns are added to the funding sheet to capture funding allocation business 
process transactions. The Project Funding column might be used (as a formula) to capture the 
sum of all allocations and manual allocation for each fund. 

To allocate funds and enter amounts through a business process 

1) Create the business process record. 

2) Add line items as necessary. 

 Select a fund from the fund picker by clicking the Select button for the Funding Source. 
The fund picker lists the funds that are active at the company level. To search for a 
specific fund, click Find. 

 The Line Item window may also include a CBS picker, for CBS level allocations. 

3) Route the business process record as usual. 

Assigning and Crediting Project/Shell Funds 

This section discusses assigning (consuming) funds on project and shell funding sheets. When 
funds are "assigned," it means they are consumed from the allocated amount for that project or 
shell. Funds can also be credited back to the source when necessary. 

Fund assignments are based on spends type business processes within the project or shell 
(e.g., invoices or payment applications), which enables accurate funding and tracking of project 
expenses. Funds are assigned based on the amount of a spends record, and can never exceed 
that amount. The behavior of funding business processes depends both on the design options 
chosen in uDesigner and the Assignment Levels chosen on the project/shell funding sheet 
properties. 

Funding assignments are based on business processes transactions, and commonly, columns 
are added to the funding sheet to track spends business processes eligible for funding. Formula 
columns may also be added to track the totals of these records, which may include Records 
Funded at Project Level (and/or CBS Level), for completed records; and Transient Records 
Funded at Project Level (or CBS Level), to track funding on records that are funded while in 
process. Values can also roll up to the company funding sheet if the same data source columns 
are added. 

View Unassigned amounts 

When spends business processes are set up to be funded manually, the amount of the record 
initially is captured in one of the Unassigned fields on the funding sheet. This value displays until 
the entire amount of the record has been fully funded. For Project level funding, the amount 
displays in the Unassigned (Project Level) field; for CBS level funding, the amount shows up in 
the Unassigned (CBS Level) field. 

If commitment level funding is being done, you may also see an amount under Unassigned 
(Commitment Level). These funds are managed on the commitment funding sheet. 

It is possible that an Unassigned amount can be negative, as the result of a credit invoice that 
has not yet been credited back to the funding source. 
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Note: These can also be rolled up to the cost sheet using the Unfunded 
Record data source. 

To view unassigned amounts 

1) Open the project or shell funding sheet. 

If business process transactions have occurred that have not yet been funded, the total of 
the record(s) will display in one of the Unassigned fields in the upper portion of the sheet. 

2) Click the link next to Unassigned (Project Level) or Unassigned (CBS Level). The Cell Detail 
window opens. The window lists transaction records that have not yet been fully funded. 

Manual vs. automatic fund assignment 

Funding assignments can be done automatically or manually. This is set in the funding 
assignment levels in the funding sheet properties. 

Manual fund assignment 

For manual assignments, and depending on the design of the business process, the following 
may occur: 

 You may be able to view or perform funding assignments or credits at any step in the 
workflow (or for a non-workflow business process, any status). When the business 
process is in process, it is referred to as a "Transient Record." This allows the record to 
be funded, edited and reviewed before the record is finalized and closed. 

 When funding is enabled (or can be viewed), a Funding button appears on the business 
process form. Click the button to open the Funding Window. 

 It is possible that the business process can be designed to disallow funding assignments 
or credits at the end step (or terminal status if non-workflow). This option prevents further 
editing of funding assignments or credits after the record has gone through a review 
process. 

Good practice tips: Review the invoice line items and be sure they are accurate before doing 
funding. A good practice for design is to disallow line item from being edited after fund 
assignment steps. This will prevent the invoice line items from being edited after funding has 
already been assigned. 

Automatic fund assignment 

For automatic assignments, the following generally occurs 

 Automatic funding occurs when the record reaches the End step in the workflow business 
process, or when Finish Editing is clicked in the non-workflow business process. 

 The funds are assigned based either on the fund assignment order, or by the ratio of the 
amounts of each fund, as determined in the assignment options in the Properties. 

It is possible to adjust funding after automatic fund assignments. 

About crediting funds 

Sometimes it is necessary to credit back funds that have already been assigned. The same 
general procedures for assigning funds can be used for crediting funds as well. You may need to 
credit funds back to the credit source if: 
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 You receive an invoice credit from a vendor, and funds have already been assigned to the 
original invoice amount. 

 A mistake was made in the original fund assignment, either by assigning too high a value, or 
assigning funds from the wrong fund. 

You cannot credit more of a fund than has been consumed. 

You can also credit previously assigned funds back to the fund source, either due to receiving a 
credit invoice or line item (e.g., a vendor credit), or to correct a previous assignment error. 

About business processes enabled for funding 

Business process behavior is dependent on the how the business process was designed in 
uDesigner, and the assignment options chosen in the project/shell funding sheet. In general, the 
design determines when funding assignments can be viewed or performed, and the assignment 
options determine whether the assignment is done manually or automatically, and at what 
levels. 

Spends type business processes (e.g., invoices or payment applications) can be designed in 
uDesigner to consume funds. Following is a summary of the business process types and design 
options that can be used: 

Project level: 

 Cost type, subtype line items with fund code, classification generic, general spends or 
payment application. 

 Workflow or non-workflow. 

 Each action form can be enabled with the following options: "View fund assignment" and 
"Allow fund assignment." This option allows funding assignments to be viewed or performed 
at any step in the workflow (or any status if non-workflow). The "Allow fund assignment" 
option is applicable when the business process is set up for manual assignment in the 
funding assignment levels in the funding sheet properties. 

 An option can be set for the business process that disallows manual fund assignment once 
the record reaches end step (or terminal status for non-workflow). When this option is 
chosen, it takes precedence over the "Allow fund assignment" setting, even if an action form 
is used on the end step. This option does not affect automatic fund assignments. This option 
is found on the Edit Studio window, Options tab. 

CBS level: 

 Cost type, subtype line items with CBS and fund code, classification generic, general spends 
or payment application. 

 Other options are the same as for project level. 

Manually assign or credit funds (unassigned funds) 

Normally, if a spends business process record has not been set up to automatically assign funds 
upon reaching a certain status, then that record total will show as Unassigned Funds in the 
project/shell funding sheet. 

When the funding business process reaches a specified workflow step or status, a Funding
button appears on the business process form. Clicking the Funding button opens the Funding 
window, allowing manual fund assignment. 
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Funds can be manually assigned at the project or shell level (project or shell funding sheet), 
CBS level (project or shell cost sheet), or business process level (spends business process 
record designed to consume funds). 

If a credit invoice (negative line item or invoice amount) has been submitted, this can be used to 
credit previously consumed funds back to the source, or can be used to credit another fund. You 
cannot credit an amount that is more than has been consumed. 

Note: This section discusses assigning and crediting funds on the 
project/shell funding sheet. See also Assigning and crediting 
commitment level funds (on page 155). 

To manually assign funds at the project or shell level from the funding sheet 

1) Open the project or shell funding sheet. 

2) In the upper portion of the window, click the link next to Unassigned (project or shell 
Level). This link displays the amount of funds that are not currently assigned to a particular 
fund. 

The Cell Detail window opens. The Cell Detail window displays the list of spends business 
process records that have not yet been fully funded. A record can appear on this list if you do 
not have enough funds available during an auto-assignment process, or if you set Manual as 
the assignment rule for the business process under the funding sheet Assignment tab. 

3) Select one or more records from the list and click the Assign to Funds button on toolbar. 
The Manual Fund Assignment window opens 

4) Enter a percent (%) amount for each record against a funding source. 

5) Click OK. 

Note: Because the number of decimal places is limited to two in the 
Manual Fund Assignment window, some amounts from funds can never 
be consumed. If you cannot use funds completely through the Assign to 
Funds window, go to the Spend BP record and manually consume the 
fund by entering the amount. 

To manually assign funds at the CBS level from the cost sheet 

1) Open the project or shell cost sheet. 

2) In the upper portion of the window, note the amount shown in the Unassigned at CBS Level
field. This is an amount that gets rolled up from the unfunded record data source in the 
project or shell cost sheet. 

3) Click on a cell under the Unfunded Records column for a CBS code. 

4) The Cell Detail window opens. The Cell Detail window displays the list of records that are not 
funded. 

5) Select one or more records from the list and click the Assign to Funds button on the 
toolbar. 

6) Enter a percent (%) amount for each record against a funding source. 

7) Click OK to close the form. 
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Note: Funds can be automatically consumed at the CBS level by 
defining the fund order for each CBS Code from the Fund Assignment 
Order window on the Project/Shell cost sheet, and setting the 
assignment level to CBS Auto Order. 

To manually assign or credit funds from a business process record 

1) Open the business process record that needs to be funded. If the record is at a specified 
workflow step and status that allows funding, a Funding button is available. 

2) Click the Funding button on the toolbar. The Funding window opens. 

3) Select a line item from the upper pane. The bottom pane will display a list of funds that are 
available for that line item. 

4) Enter the amounts for fund assignment. This is subtracted from the fund balance. For 
credits, enter negative amounts; the amount entered is added back to the fund balance. 

5) Click OK. 

If the business process is configured to use individual commit line items as SOV line items, 
the upper pane will not show a list of line items. You will see a total amount under the 
Unassigned Amount field. 

Reassign project/shell funds from a business process record 

In addition to assigning or crediting funds from the funding sheet, you can also adjust the 
funding allocations that were rolled up to the funding sheet directly from the business process 
record in which the transaction took place. 

To reassign project or shell funds 

1) Open the business process record in which you want to reassign funds. 

2) Click the Funding button. The Cell Detail window opens. 

3) Click Select. The fund picker opens. 

4) Select the funding source from which to assign funds. 

Depending on the design of the BP, the Fund picker may display all funds being used by the 
company or only those funds currently allocated to the project or shell. 

5) Click OK. The Assign to Fund window opens. 

6) Enter the percentage of the transaction amount to assign to the new fund and click OK. 

Searching for Fund Codes 

If you are working with a large number of funds, there are ways to help you find the fund or 
funds that you are looking for. You can search for individual fund codes using the Find feature. 
You can also create and apply filters, which can be used to temporarily limit the number of funds 
displayed on the sheet. 

You can use the Find button to help you find a particular fund on company, project or shell 
funding sheet, or a funding template. You can search by any column on the funding sheet, and 
is available if the display mode is Flat or Tree. Find is available on company, project and shell 
funding sheets and templates. 
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In addition, you can search for funds in a fund picker. The fund picker displays when you are 
adding funds to a project/shell funding sheet, or funds when adding line items to a business 
process record used for funding. 

To search for a fund on a funding sheet 

1) Open the project or shell funding sheet. 

2) Click the Find button on the toolbar. The Find window opens. 

3) Complete the Find window: 

 Column: Choose a column name. This drop-down contains the names of all columns that 
are displayed on the funding sheet, including Fund Code and Fund Name. 

 Value: Enter a value for which to search. You can enter a full or partial word, number or 
other value. (Do not enter a wildcard character for partial entries.) The format of your 
entry will depend on the type of value you are searching for. If you are searching for a 
fund code, you can include the code separator if one is used (for example, a dash). 

 Search: Choose Up or Down. For new searches, use Down. If a value is found, it will be 
selected on the sheet. If you want to continue to search, you can choose to search up or 
down from the current selection. 

4) Click Cancel to close the Find window. 

To search for a fund in a fund picker 

1) Open the funding sheet or business process record. 

2) Open the fund picker by doing one of the following: 

 On a project or shell funding sheet or template, add a row to the sheet by clicking Rows, 
then Add Row. In the Fund Details window, click the Select button next to the field for 
choosing a fund (e.g., Fund Code). 

 In the business process record, click the Select button next to the field for choosing a 
fund (e.g., Fund Code). 

The Fund Picker opens. 

3) You can search for a specific fund in the fund picker: 

a. Click the Find button. The Find window opens. The window that opens will depend on the 
design in uDesigner. 

 If an attribute form is not defined, the default Find window will allow you to search 
by Fund Code or Fund Name. 

 If an attribute form is defined, the Find window can also be designed in uDesigner, 
and you may have additional fields to search by. 

b. Enter search criteria and click Search. This limits the number of funds that are displayed 
to those that match the search criteria. 

4) Click OK. The fund appears as a row on the Funding Sheet. Funds are displayed in 
alphabetical order on funding sheet. 

Creating and Applying Filters 

If you are working with a large number of funds, it may be useful to display a subset of the total 
number of funds when working with the funding sheet. For example, you may want to only view 
new funds for the current year. 
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You can temporarily limit the number of funds displayed on the sheet by applying a filter. This 
feature is available on company, project and shell funding sheets, and funding sheet templates. 

Create and manage filters on a project/shell funding sheet 

If you have Create or Modify permissions, you can create and save any number of filters. 
Anyone with permission to view the funding sheet can view and apply saved filters. 

These procedures are applicable to company, project or shell funding sheets, and funding 
templates. 

To create a new filter 

1) Open the funding sheet. 

2) Click the View menu and choose Filters. The Filters window opens. This window lists any 
filters that may have been created and saved previously. 

3) Click the Add button. The Edit Filter window opens. In this window, you can add one or more 
conditions to use for filtering the funds display. 

4) Enter a Filter Name. This name will display in the Filters window. 

5) Click the Add button. The Add Query Condition window opens. You can enter one or 
multiple conditions. 

6) Do the following: 

a. Choose a Data Element: This drop-down lists all data elements that are on the fund 
attribute form. Any data elements in a hidden block are not available. 

b. Choose a Condition: This drop-down displays a list of conditions. This list is based on the 
type of data element selected. 

c. Choose a value: Depending on the type of data element, choose a value that the query 
condition must meet. 

 Data Element: Lists the data elements on the fund attribute form. 

 Constant Value: You can enter a full or partial entry of the value to filter by. This is 
similar to entering search criteria. For example, if you want to display only funds 
with "2010" in the fund code, then choose the data element Fund Code, condition 
of equals, and 2010 as a constant value. For pulldown or other multiple-entry 
fields, a Select button appears, allowing you to select a value. 

7) If you add multiple conditions, and want the filter to be applied if any one listed condition is 
met, then select the Show result matching ANY condition checkbox. 

Note: By default, the conditions are additive, meaning that all conditions 
must be met in order for the condition to be applicable. Select the 
checkbox if any one condition will suffice. 

8) Click OK to save and close each window. 

To modify a filter 

1) Open the funding sheet. 

2) Click the View menu and choose Filters. The Filters window opens. 

3) Choose a filter from the list and click the Edit button. The Edit Filter window opens. 
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4) You can edit the filter name, or add, modify or remove a condition. 

 To modify a condition, select the condition from the list and click the Modify button. 

 To remove a condition, select the condition and click the Remove button. 

5) Click OK to save your changes. 

To delete a filter 

1) Open the funding sheet. 

2) Click the View menu and choose Filters. The Filters window opens. 

3) Choose a filter from the list and click the Remove button. Click Yes to confirm. 

Apply a filter to limit the fund code display 

By applying a filter to the funding sheet, you can temporarily reduce the number of fund codes 
that are displayed on the sheet. 

To apply a filter 

1) Open the funding sheet. 

2) Click the View menu and choose Filters. The Filters window opens. This window lists any 
filters that have been created and saved. 

3) Choose a filter from the list and click the Apply Filter button. 

The funding sheet will display only those funds meeting the conditions of the filter selected. The 
top of the sheet will display the name of the filter. 

To clear the filter and display all funds 

If the funding sheet has a filter applied, click the View menu and choose Clear Filter. The sheet 
will refresh to display all funds. 

Importing and Exporting Project/Shell Funding Sheet Information 

You can export a summary of a funding sheet, which creates a CSV file that contains the rows, 
columns and data on the funding sheet. You can also export a CSV file containing fund details, 
which includes all fund codes on the sheet and the data captured for them from the Fund Details 
window. 

You can also import fund details to a company funding sheet. This allows you to add fund codes 
to a funding sheet directly from a CSV file, rather than add them manually. 

This procedures are applicable to company, project and shell funding sheets. 

Export funding sheet information 

You can export a summary funding sheet, which is a CSV file containing the rows (funds), 
columns and data on the funding sheet. You can do this in a company, project or shell funding 
sheet. Summary funding sheet information cannot be re-imported. 

To export a funding sheet summary 

1) Open the company, project or shell funding sheet. 

2) Click the Export button and then choose Summary Fund Sheet.
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3) Read the confirmation message and then click Yes to continue. 

You may choose to open the file in a compatible program such as Microsoft Excel to review it 
before saving. 

4) Click Save and specify the location in which to save the CSV file. 

Import and export fund details 

You can export fund detail information from a company, project or shell funding sheet to a CSV 
file. This contains all of the information captured in the Fund Details form when the funds were 
added to the company funding sheet. When you export the fund details from the company 
funding sheet, the details of all funds are exported; exporting from a project or shell funding 
sheet gives the details of those funds added to that sheet. 

When adding funds to a company funding sheet, you can use the export file as a template, add 
fund details to the CSV file, then re-import the file to add funds to the company funding sheet. 
You cannot use import to add funds to a project or shell funding sheet. 

To export fund details from a funding sheet 

1) Open the company, project or shell funding sheet. 

2) Click the Export button and then choose Fund Details.

3) Read the confirmation message and then click Yes to continue. 

You may choose to open the file in a compatible program such as Microsoft Excel to review it 
before saving. 

4) Click Save and specify the location in which to save the CSV file. 

To import fund details into a company funding sheet 

1) Open the company funding sheet. 

2) Be sure you first export the fund details and save the CSV file. 

Note the instructions at the top of the file. Remove any existing funds that may be listed in 
the export file, so that only the column headings remain. The instructions at the top of the file 
can remain. Save the file. 

3) Add the fund details for the funds that you want to import. Be sure to complete all required 
fields. Do not add fund codes that already exist on the funding sheet. 

4) Click the Import Fund Details button.

5) Browse to the CSV file and click Ok. The funds you added to the import file will be added to 
the company funding sheet. 

Note: If any errors occur, download and open the error file, and correct 
the CSV file before reimporting. Common errors include trying to import 
fund codes that already exist on the sheet, or not completing required 
fields. 
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Working with Commitment Funding Sheets 

When using project/shell level funding (described in the previous sections), the fund assignment 
procedure does not distinguish which funds to consume for invoices or payment applications 
that come in for different base commit records (i.e., contracts or purchase orders). There may be 
times when a base commit needs to be funded by a specific fund or funds. If you want to 
allocate and assign specific funds for each contract, then you can use commitment funding. 

Commitment funding works in conjunction with project/shell level funding (the funds allocated to 
a commit must first be present in the project/shell funding sheet), and with the schedule of 
values (SOV) sheet that is created for the base commits (as the SOV keeps track of the line 
items and amounts of the base commits and any change commits). 

Notes:  

 The terms "base commit" and "contract" may be interchanged in the 
descriptions, but both refer to cost-type business processes of 
sub-type "Line items with CBS Code" and classification "base 
commit." Common examples are contracts and purchase orders. 

 If you are enabling a base commit for commitment funding, its linked 
spends business process (general spends invoice or payment 
application) will then consume funds at the commitment level, not the 
project level. If you want to do commitment funding with some 
contracts, and project level funding with other contracts, you should 
use a different "set" of base commit, change commit and spends 
business processes to use for each type of funding that you want to 
do. 

If you will be using commitment level funding, then a sheet structure must be created for the 
project or shell, which consists of columns and assignment rules (in the Properties). 
Commitment funding sheets are created for each base commit record, using this default 
structure. Funds (rows) are added to the commitment funding sheets, and fund amounts are 
allocated from available project/shell funds to each sheet. 

Note: Although commitment funding sheets are based on the structure, 
you can still modify the columns and properties of individual sheets. You 
can also modify the commitment funding structure after sheets have 
been created. Modifications to the structure will be reflected on new 
sheets, but will not affect existing sheets. 

Create a commitment funding sheet structure 

Structures are created by copying a commitment funding template. The commitment funding 
structure defines the column structure that will be used for the individual commitment funding 
sheets that are created from base commit records. It can also define the assignment levels and 
rules to use for each sheet (in the Properties window). (These procedures assume a 
commitment funding template has been created and set up). 

Structures can also be created in a project or shell template, which will then be copied to 
projects/shells created from it. Structures created in project/shell templates can also be "pushed" 
to existing projects using Update Projects or Update Shells. 
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If you modify the columns or properties of the commitment funding structure, existing sheets will 
not be affected. New sheets created from the edited structure will reflect the modifications. You 
can modify the columns and properties of individual commitment funding sheets without affecting 
the default structure. 

To create a commitment funding sheet structure 

1) Open the project or shell and click Cost Manager > Funding > Commitment Funding 
Sheet in the left Navigator. The Commitment Funding Sheet log opens. The log should be 
empty. If commitment funding sheets are already present, then a structure already exists. 

2) Click the Create Structure button. The Commitment Funding Sheet window opens, listing 
the available templates. 

Note: When a structure is created, the Create Structure button becomes 
Update Structure. 

3) Select a template from the list and click Open. Click Yes to confirm. You can use this 
structure as is or make edits as necessary. 

To view or edit the commitment funding sheet structure 

1) From the Commitment Funding Sheet log, click the Update Structure button. The 
Commitment Funding Structure window opens. 

2) Click the Columns button to add, view or edit columns. Managing columns on the structure 
is done the same way as on a commitment funding sheet template. For details about 
commitment funding columns. 

3) You can also modify the structure properties: 

a. In the structure window, click the File menu and choose Properties. 

b. In the General tab, you can modify the Title and Description. The Title will be used as 
the default name of each commitment funding sheet created from it. 

c. You can also modify assignment levels and rules. Click the Assignment tab. 

4) Close the Commitment Funding Structure window 

Create a commitment funding sheet 

The Commitment Funding Sheet allows you to allocate project or shell funds to a specific 
"commitment" (base commit) business process record (for example, a contract or a purchase 
order). Changes to the original contract through the use of associated change commits will also 
be reflected on the funding sheet. The commitment funding sheet is also used to track the 
consumption of those funds as spends business processes (invoices or payment applications) 
are created. 

There is one commitment funding sheet for each base commit business process record. You 
create the sheet directly from the base commit record once it reaches a step at which funding 
has been enabled. (The design is done in uDesigner. For workflow BPs, funding can be enabled 
per step; for non-workflow BPs, funding will be enabled when the form is editable. The funding 
sheet may also be available for viewing on view forms, depending on the design. The funding 
sheet is available if a Funding button is present on the base or change commit record toolbar.) 

Be sure the following is in place before creating the commitment funding sheet: 
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 A commitment funding structure has been created. The sheet will use this default structure. 
Columns can be modified, removed or added to the sheet; this will not affect the default 
structure. 

 The project or shell funding sheet has been created, and funds allocated to it from the 
company funding sheet. 

 In order to use commitment level funding, a Schedule of Values (SOV) sheet must be 
created for the base commit. The commitment funding sheet uses the SOV to track base 
commit and change commit line items, amounts, and remaining balances. Be sure the SOV 
sheet has a column using the datasource Scheduled Value, as this is used by the 
commitment funding sheet. 

If the fund assignment levels and rules have been defined in the structure, then these will be 
copied to the new sheet. These definitions can be added or edited in the sheet as needed. 

The user who creates the sheet becomes the owner and automatically has full permissions to 
view and edit the sheet. If other users will need to view or edit the sheet, you will need to give 
them permission. 

After the sheet is created, you then allocate funding for that record from the available project or 
shell funds. Fund allocation is done manually on the commitment funding sheet; allocation and 
consumption can be tracked on the project/shell funding sheet by adding the appropriate 
columns. 

To create a commitment sheet 

1) Open the base commit business process record on which you want to perform commitment 
funding. 

If commitment funding has been enabled on the base commit itself, and on the current step, 
a Funding button will be present on the business process toolbar. 

Note: If the Funding button is not present, contact your project/shell 
administrator, or other administrator managing business processes, to 
verify that commitment funding is available for the business process, that 
it is available on the current step, and that you have the proper 
permissions. In addition, it is possible that on some steps (and on View 
forms), the Funding button will be present, but has been designed to 
open a view-only version of the sheet. 

2) Click the Funding button. 

3) Click Yes to confirm. The Commitment Funding Sheet is created, based on the structure. 

Grant permission to a commitment funding sheet 

Grant permission to a commitment funding sheet 

The user who creates the commitment funding sheet automatically becomes the owner and has 
full permissions to modify the sheet and enter data. If other users will need to view or edit the 
sheet, the owner will need to give them permission. 

To grant a user or group commitment funding sheet permissions 

1) On the Commitment Funding Sheet log, select a sheet. 
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2) Click the Permissions button. The Edit Permission window opens. 

The upper pane of the window displays any users or groups who have already been granted 
permission to the sheet. 

3) To add users or groups who are not listed, click the Add button. The User/Group Picker 
opens. 

4) Select one or more users and/or groups, and click OK. 

5) In the upper pane of the Edit Permission window, select one or more users or groups. 

6) Select the permission level for the selection: 

 Modify Permission: This will allow user to modify record level permissions 

 Edit: This will allow user to modify data on the sheet 

 View: This will allow user to view the sheet 

7) Click OK. 

8) Repeat if you have more users or groups to add, or that you need to assign different 
permission levels. 

9) To remove permissions from a listed user or group, select user/group and either modify the 
permission levels to a lower level, or click the Remove button to remove all sheet-level 
permissions. 

Access commitment funding sheets 

Commitment funding sheets are based on individual base commit records (e.g., contracts or 
purchase orders) on which commitment funding has been enabled in the uDesigner design. The 
structure (columns) of the sheets is based on a structure, which in turn is based on a 
commitment funding sheet template. 

Commitment funding sheets can be accessed from the Commitment Funding Sheet log, or from 
the base commit record with which the sheet is associated. (Accessing the sheet from the 
commit record is dependent upon the business process design: for workflow business 
processes, funding is enabled per step; for non-workflow business processes, funding will be 
enabled when the form is editable. The funding sheet may also be available for viewing on view 
forms, depending on the design. The funding sheet is available if a Funding button is present on 
the base commit record toolbar.) 

Note: Remember that commitment funding sheets have record-level 
permission. The creator of the base commit becomes the creator of the 
commitment funding sheet created from it, and must grant view or edit 
permission to other users that may need to access it. 

To access commitment funding sheets 

Do one of the following: 

 In the Commitment Funding Sheet log, select a sheet and click Open (or double-click the 
sheet). 

 Open the base commit or change commit record. If a Funding button is present on the 
toolbar, you can click it to open the commitment funding sheet. 
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About commitment funding columns 

The columns on the commitment funding sheet are used to manage and track the funding 
allocation, assignment and fund balances for the commit record. 

Note: In these column definitions, the terms All Funds and Discrete Fund 
refer to the fund assignment options (from the Fund Assignment window, 
accessed from the SOV sheet or commitment funding sheet). These 
options determine how the SOV lines (and therefore, the commit lines) 
will be funded, either automatically or manually from the entire list of 
funds available to the commit, or by one specific fund. 

The Funding Across All Funds column is used to enter (or calculate) the amount of each fund 
to allocate for this base commit record. The rows on the sheet are the funds that will be used to 
fund the commit. The value entered here will be the fund amount available for all commit lines 
that have "All Funds" as assignment. This can be a manual entry column, or a formula that uses 
another manual entry column as the basis of the formula. 

Additional columns commonly track fund assignments (consumption) made against each fund. 
These can be in the form of business process transactions or manual funding assignments. 
System provided data sources that can be used for columns include the following: 

 Funding By Discrete Fund: This column displays the sum total of all the line items of base 
and change commits that are funded by a specific (or "discrete") fund This value can be 
used to determine the fund balance during consumption. 

 Records Funded Across All Funds: Reflects the total of funds consumed from records that 
are funded based on All Funds, whether funding is done manually or automatically. 

 Records Funded By Discrete Fund: Displays the total of funds consumed from records 
that are funded based on a discrete fund, whether funding is done manually or automatically. 

 Fund Balance Across All Funds: This column tracks the fund balance across all funds. 
The formula used is (Funding Across All Funds) - (Records Funded By All Funds). 

 Fund Balance By Discrete Fund: This column tracks the fund balance by specific fund 
chosen in the Fund Assignment window. The formula used is (Funding By Discrete Fund) - 
(Records Funded By Discrete Fund). 

 Funding Ratio Across All Funds: The value of this column is calculated automatically. It 
reflects the % ratio to use when performing fund assignment ratio during consumption. The 
formula is (Funding Across All Funds Per Fund) / Total of Fund Balance Across All Funds). 

Assignment rules 

The assignment levels and rules are defined on the Assignments tab in the Properties window of 
the commitment funding sheet. This step is mandatory in order to do commitment level funding. 

The Assignment tab lists the spends business processes that are linked to base commits 
enabled for commitment level funding. For each listed business process, you define how fund 
assignment will be done when these spends records come in against the base commit: 
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 Commitment Level - Manual: Funds are manually assigned at runtime. As spends business 
processes are routed and reach specified status, the amounts to be funded are collected 
under the Unassigned total on the commitment funding sheet, similar to project/shell level 
manual funding. You can then select each line of the spends BP and assign funds at 
runtime. This can be done on transient records or in terminal status (depending on design). 
Consumed funds roll up to the commitment funding sheet and the project funding sheet. 

 Commitment Level - Auto Ratio: Funds are assigned automatically when the spends 
business process reaches a specified status. Funds are assigned based on the fund ratio, 
which is calculated based on the current fund levels, and is managed and tracked on the 
commitment funding sheet. If all funds are consumed, any remaining spends amounts are 
collected under Unassigned. 

You can define these assignment rules on the commitment funding template. When you create a 
commitment funding structure in a project or shell, these assignment rules will be copied to it, 
and when you create new sheets from the structure, they will be copied to the sheets. If you 
need to, you can modify these rules on individual structures and sheets. 

Fund Assignment details per SOV line 

This is an optional step that allows you to provide details about fund assignment or consumption 
for each line on the base commit or any change commits. You access the Fund Assignment 
window by clicking the Fund Assignment button on the commitment funding sheet or the SOV 
sheet associated with the base commit. 

 If you do not define any assignment options in this window, then All Funds is the default 
selection. This means that all funds that have been allocated to the base commit on the 
commitment funding sheet will be available for funding each line of the spends business 
process created against it (either manually or by auto ratio, as defined by the assignment 
rules). When this is chosen, funding information is captured on the commitment funding 
sheet in columns using data sources referencing "across all funds." 

 There may be times when you need to specify that a specific fund must be used to fund a 
specific CBS code on the base commit or a change commit. You can select a specific fund 
(or "discrete fund") to fund selected SOV lines. When this is chosen, funding information is 
captured on the commitment funding sheet in columns using data sources referencing "by 
discrete fund." 

Once the commitment funding sheet is created, you can add rows and allocate funds to it. 

About commitment funding sheet rows 

Each row in the commitment funding sheet corresponds to a fund that has been allocated for 
use on that commitment. Fund allocation can be done manually, by adding rows to the 
commitment funding sheet. The funds that are available for allocation are those on the project or 
shell funding sheet. 

View or edit commitment funding sheet properties 

The properties of a commitment funding sheet are copied from the structure it was created from 
(which in turn was copied from a template). You can use these properties, or modify them as 
necessary. 
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To view or edit commitment funding sheet properties 

1) On the Commitment Funding Sheet log, select a sheet. 

2) Click the Properties button. The Properties window opens. 

3) In the General tab, you can modify the Title and Description. 

4) In the Assignment tab, you can modify the assignment levels and rules to use for this sheet. 

Note: Assignment Levels must be defined before you will be able to 
process spends records (invoices or payment applications) against this 
base commit. If you change an assignment rule (for example, from 
Manual to Auto Ratio), the change will take place on new spends 
records, it will not affect spends records already in process. See About 
commitment funding assignment options (on page 154) 

About commitment funding assignment options 

Fund Assignment refers to how funds are to be consumed as spends type business processes 
(e.g., invoices and payment applications) come in against the base commit that is being funded. 

Initial assignment rules are defined in the Assignment tab on the commitment funding Properties 
window. Additional details can be defined in the Fund Assignment window. To access the fund 
assignment window, click the Fund Assignment button on the commitment funding sheet or 
SOV sheet for the base commit. The Fund Assignment window is not accessible until the SOV 
sheet has been created. 

Allocating funds for commitment funding 

Similar to project/shell funding sheets, the rows of a commitment funding sheet correspond to 
the funds that you want to use to fund the associated base commit (plus any linked change 
commits). The funds that are available to add as rows are those that have been added to the 
project/shell funding sheet. 

After adding a row, you allocate how much of that fund you want to make available to the base 
commit directly on the sheet. That is, you must add a column to the commitment funding sheet 
using the data source Funding Across All Rows. This is the column to use for fund allocation. 

This column can be manual entry or formula. If it is manual entry, you can enter the fund 
allocation amount directly to the cell. If you use a formula, you must also include another manual 
entry column to use to enter an amount, and include that in the formula. For example, you might 
want to use your own ratio of certain funds in the initial allocations. You can add a manual entry 
column, then use the formula calculation for the Funding Across All Rows column. 

Add and manage commitment funding sheet rows (funds) 

The rows that you add to a commitment funding sheet are the project or shell funds that you are 
allocating to the associated base commit and any change commits. 

You add rows (funds) to the project/shell commitment funding sheet, but not the template or 
structure. You can delete a row as long as no assignments have been made against the fund. 

Note: Once fund assignments have been made against them, you will 
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not be able to delete the row. Once the sheet is saved, you cannot edit 
the fund; if you need to choose a different fund, first delete the row then 
create a new one. 

To add rows (funds) to the commitment funding sheet 

1) Open the commitment funding sheet. 

2) Click Add Rows. A new row is added to the sheet. 

3) Click the drop-down in the Fund Code column and select a fund code from the list. The fund 
codes listed are those that are on the project or shell funding sheet. 

For each row, you will need to allocate how much of the fund to make available to the 
commit. You can do that now or wait until all the rows have been added. 

4) To add another row, click the Add Rows button again, and choose a code. Fund codes can 
only be used once on the sheet; therefore, once a code has been used in a row, it will not 
appear on the list again. 

5) Click Save on the commitment funding sheet to save your changes. 

To delete rows 

1) On the commitment funding sheet, select one or more rows. 

2) Click the Delete Rows button. 

3) Click Yes to confirm. 

Allocate fund amounts to a commitment funding sheet row 

You allocate the project/shell funds to use for each fund directly on the commitment funding 
sheet per row. The sheet must have a column that uses the data source "Funding Across All 
Rows." This is the column to use for fund allocation. 

This column can be manual entry or formula. If it is manual entry, you can enter the fund 
allocation amount directly to the cell. If you use a formula, you must also include another manual 
entry column to use to enter an amount, and include that in the formula. For example, you might 
want to use a ratio of certain funds in the initial allocations. You can add a manual entry column, 
then use the formula calculation for the Funding Across All Rows column. 

To allocate fund values to a row 

1) Open the commitment funding sheet. 

2) For each row, double-click the cell of the column you are using for the manual entry portion 
of fund allocation (e.g., the Funding Across All Rows column). This makes the cell editable. 

3) Enter the amount to use for fund allocation. 

4) Click Save on the commitment funding sheet to save your changes. When you save the 
sheet, a validation check will be run to make sure that the allocation amounts do not exceed 
the fund balance of each fund on the project/shell funding sheet. 

Assigning and crediting commitment level funds 

Assigning (consuming) or crediting funds on a commitment funding sheet is similar to a project 
or shell funding sheet, with some exceptions. This section assumes that the concepts of 
assigning and crediting funds of project or shell funding sheets is already understood. 
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As with project/shell funding, fund consumption on commitment funding sheets is done using 
general spends or payment application business processes that have been designed to 
consume funds. (When the spends BP is linked to a base commit that has been enabled to do 
commitment funding, then funds are consumed from the commitment funding sheet, not the 
project/shell funding sheet.) As in project/shell funding, funds are assigned from the spends 
record based on the amount of that record. The behavior of funding business processes 
depends both on the design options chosen in uDesigner and the Assignment Levels chosen on 
the commitment funding sheet properties. 

Like project/shell funding, fund assignment can be done manually or automatically (by fund 
balance ratio). This is determined in the Fund Assignment rules set in the sheet Properties. 

About business processes enabled for commitment funding 

Commitment funding is enabled on the CBS-code-based base commit. The design of the base 
commit forms determine when the Funding button appears on the base commit or change 
commit record. This button allows you to create the commitment funding sheet for the record, 
and also to access the funding sheet from the record. (Commitment funding sheets can also be 
accessed directly from the commitment funding sheet log.) 

As in project and shell funding, you use spends type business processes (e.g., invoices or 
payment applications) to consume funds. If the spends business process is linked to a base 
commit that is enabled for commitment funding, then the spends record will consume funds from 
the commitment funding sheet rather than the project/shell funding sheet. 

If you will be doing both project/shell funding and commitment funding, then use a different set of 
linked base commit / change commit / spends business processes for each. 

View Unassigned amounts (Commitment Level) 

When spends business processes are set up to be funded manually, the amount of the record 
initially is captured in the Unassigned (Commitment Level) field on the commitment funding 
sheet. This value displays until the entire amount of the record has been fully funded. For 
Project level funding, the amount displays in the Unassigned (Project Level) field; for CBS level 
funding, the amount shows up in the Unassigned (CBS Level) field. 

It is possible that an Unassigned amount can be negative, as the result of a credit invoice that 
has not yet been credited back to the funding source. 

Note: These can also be rolled up to the cost sheet using the Unfunded 
Record data source. 

To view unassigned commitment funding amounts 

1) Open the commitment funding sheet. 

If business process transactions have occurred that have not yet been funded, the total of 
the record(s) will display in the Unassigned field in the upper portion of the sheet. 

2) Click the link next to Unassigned (Commitment Level). The Cell Detail window opens. The 
window lists transaction records that have not yet been fully funded. 
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Assigning or crediting unassigned funds on the commitment funding sheet 

Manually assign or credit unassigned funds 

If there are unassigned funds, you can assign them manually from the spends business process 
record or from the commitment funding sheet. 

When the spends record reaches a specified workflow step or status, a Funding button appears 
on the form. Clicking the Funding button opens the Funding window, allowing manual fund 
assignment. 

If a credit invoice (negative line item or invoice amount) has been submitted, this can be used to 
credit previously consumed funds back to the source, or can be used to credit another fund. You 
cannot credit an amount that is more than has been consumed. 

To manually assign funds from the commitment funding sheet 

1) Open the commitment funding sheet. 

2) In the upper portion of the window, click the link next to Unassigned (Commitment Level). 
This link displays the amount of funds that are not currently assigned to a particular fund. 

The Cell Detail window opens. The Cell Detail window displays the list of spends business 
process records that have not yet been fully funded. A record can appear on this list if you do 
not have enough funds available during an auto-assignment process, or if you set Manual as 
the assignment rule for the business process under the funding sheet Assignment tab. 

3) Select one or more records from the list and click the Assign to Funds button on toolbar. 
The Manual Fund Assignment window opens 

4) Enter a percent (%) amount for each record against a funding source. 

5) Click OK. 

Note: Because the number of decimal places is limited to two in the 
Manual Fund Assignment window, some amounts from funds can never 
be consumed. If you cannot use funds completely through the Assign to 
Funds window, go to the Spend BP record and manually consume the 
fund by entering the amount. 

To manually assign or credit funds from a spends business process record 

1) Open the business process record that needs to be funded. If the record is at a specified 
workflow step and status that allows funding, a Funding button is available. 

2) Click the Funding button on the toolbar. The Funding window opens. 

3) Select a line item from the upper pane. The bottom pane will display a list of funds that are 
available for that line item. 

4) Enter the amounts for fund assignment. This is subtracted from the fund balance. For 
credits, enter negative amounts; the amount entered is added back to the fund balance. 

5) Click OK
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Automatic fund assignments at the commitment level 

Automatic fund assignment works similarly at the commitment level as it does in project/shell 
funding. The available automatic funding option is auto-ratio by fund balance (if All Funds is 
chosen in the Fund Assignment window), or a specific (discrete) fund can be used. 

See Manual vs. automatic fund assignment (on page 140), About crediting funds (on page 
140), About commitment funding assignment options (on page 154), About commitment 
funding columns (on page 152). 

About Cash Flow 

Cash Flow 

Cash flow is the distribution of cost over time. That is to say, cash flow is the movement of 
money in or out of a project (or business) during a specific time period. 

Note: In the context of capital projects, cash flow is the estimating of 
future spends to be incurred on a project, based on current actuals. 

The term cash flow is synonymous with cash flow forecasting, spends forecasting, and 
time-phasing of budget, which all refer to the availability of proper funding in each future period 
(month, quarter, or year). 

Cash flow management includes the following steps: 

1) Establishing a baseline spending plan: Baseline

2) Tracking actual costs: Actuals

3) Calculating future expenditures based on project schedules: Forecast

Note: Cash flow forecasting is used to ensure that cash is available 
when payments are due. 

You can create cash flow at multiple levels in a project to: 

 Track cash flow for the entire Project/Shell: Project/Shell

 Track the costs associated with summary CBS code: Summary CBS

 Track cash flow at the CBS code level, across all or specific CBS code: CBS

 Track cash flow data for an entire commit record, including base commits, change commits, 
and related invoice: Commitment

About Cash Flow Curves 

In general, cash flow curves are graphical presentations of the expenditures or spends. Cash 
flow curves enable you to: 

 Pull data from cost sheets, business process records, or schedule sheets 

 Record cash flow history by way of using snapshots 

 Generate cash flow curve reports 

The cash flow management steps can be displayed as cash flow curves in Primavera Unifier. 



Working with Unifier Managers

159

The following are three most common, and important, standard cash flow curves. See Creating 
Cash Flow Curves (Classic View) (on page 170) for details on all types of Cash Flow Curves. 

Baseline

 The time-phased distribution of the project budget over the project duration. 

 The project budget distributed over the duration of the project, indicating how the budget 
might be spent. 

Note: A project can have multiple baselines (original, revised, etc.). 

Actuals

 The spends that have actually been incurred (approved invoices, or in some cases, 
accruals). 

 Spends is defined as periodic outlay of money, tracked per CBS. 

 The project spending, which includes actual invoices received for each period. 

Note: The Actuals (spends) can be compared to baseline budget to 
maintain budgetary control. 

Forecast

 The time-phased distribution of the project forecast, from the latest Actuals (spends). 

 The expected spends for the future. 

Notes: 

 The start point of a Forecast curve is the end of the latest Actuals, 
and the end point is the total forecast. 

 You can use cash flow forecasting to ensure that cash is available 
when payments are due. 

 Forecast is updated as new actuals are incurred. 

A Cash Flow Curve requires a data source, which your administrator can create in the Standards 
&Libraries node. 

 Data Sources

Used to identify Cash Flow Curves and Roll up data to program and company worksheets. 
Multiple data sources can be defined per curve type, depending upon business needs. 
Example: “Original baseline and Current baseline” data sources can be defined for type 
“Baseline”. For roll ups, curves are summarized across data sources. 

 Curve Type

Used with pre-defined categories of Cash Flow Curves: Baseline, Forecast, Actual (or 
Spends), Portfolio Budget, Derived, and Custom. Each curve type has its own logic to 
address different business requirements. 

 Distribution Profiles

Used to distribute data automatically in the Cash Flow Worksheet. 

 Detail curve templates

Used to make Cash Flow Worksheet. 
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 Roll up curve templates

Used to create curves in Programs that roll up cash flow data from Projects/Shells. 

Cash Flow Curves Types 

There are two types of cash flow curves: 

1) Detail curves: Cost per period.  

2) Rollup curves: Each period includes sum of all previous periods.  

Detail curves 

A family of curves can be defined at a Project/Shell level or Program/Company level. Each curve 
within the family is based on a data source (one curve per unique data source). 

A Cash Flow Detail curve is a curve that is used to monitor the movement of cash at different 
detail levels in a project. 

The following is a list of detail levels in a project: 

 Project/Shell

 Summary CBS

 CBS

 Commitment

For each detail level in a project, you can specify the following curve types: 

 Baseline

Depicts the project budget that is spread over the duration of the project. Users can define 
multiple baselines for a project. 

 Actuals (Spends) 

Depicts the expenditures (spends) that have actually incurred. 

 Forecast

Depicts the projection of the future costs, based on current expenditures (Actuals or 
Spends). 

 Portfolio Budget

Depicts the Baseline curve, or Forecast curve, used for portfolio optimization scenarios in 
Unifier Portfolio Manager. 

 Derived

Depicts the Baseline curve, or Forecast curve, used for portfolio optimization scenarios in 
Unifier Portfolio Manager. 

Note: The Derived curve is used to convert the sources currencies to a 
currency used by the Portfolio Budget curve. 

 Custom

Depicts cost data other than Baseline, Actuals, etc. 

Note: Custom curves can include any other cost data you want to view 
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graphically. 

Rollup curves 

A Rollup curve includes a group of curves with Active status, summarized by data source, 
across Projects/Shells in a Program or across all Projects/Shells in a Company. 

A Cash Flow Rollup curve facilitates the aggregation of cash flow data source (from 
Projects/Shells and CBS) to Company and Program Cash Flow WorkSheets. 

Note: A Cash Flow Rollup curve can only be created in Company 
Workspace and Program levels. 

You can compare curves side-by-side, in the Cash Flow Worksheet, to view Cash Flow 
distribution over time. 

Cash Flow Log Window (Standard View) 

The Cash Flow log is the starting place for cash flow operations.  

To access the Cash Flow log go to the shell and switch to the user mode. Click the Cost 
Manager module to expand. Click the Cash Flow node to see the Cash Flow log. 

The Cash Flow log: 

 Displays all existing cash flow curves that you have access to 

 Provides options for managing cash flow curves (creating new curves, copying curves, 
viewing curve properties, and assigning curve usage privileges to other users) 

Note: If you are working in a shell or project, the Cash Flow log displays 
cash flow detail curves. If you are working in a company or a program, 
the log displays the rollup curves. 

The project or shell Cash Flow log has the following toolbar options: 

Create Create new cash flow curves. Your options are: 

 Manual: Create curves manually. 

 From Template: Create curves by using available templates. 

 Summary Curve: Create summary curves using existing curves in the 
log 
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Actions To do the following on the log items as a whole or individually: 

 Refresh 

 Roll up Status 

 Delete 

 Manage Distribution Profiles 

Notes: 

Distribution profiles are generally managed by an administrator. 

If you select one or more detail curves and one or more Summary curves 
and proceed to update the roll up status, then the system ignores the 
selected Summary curves and updates the roll up statuses of the 
selected detail curves. 

View View the log of all cash flow curves. You can create new views, manage 
views, or edit the current view. 

Edit View Open the Edit View page and change the columns, filters, groups, and 
sorting of the items on the log. 

Refresh Log Refresh cash flow curves on the log. 

Print To print, export to CSV, or export to Excel the log items. 

Find on 
Page 

Search the Cash Flow log 

The Cash Flow log displays a list of cash flows. Information about each cash flow record is 
presented in the following columns: 

Refresh 
Data 

To refresh each curve data and view the refresh status, as well. 

Refresh Data has three states: Refresh Now, In Progress, and Refresh 
Complete. 

The refresh actions apply to Detail Curves and not to Summary Curves. 

Name Name of the curve. 

Description Description for the curve 

Detail Level This option applies to Detail Curves only and will be blank for Summary 
Curves. 

Type Type of the curve. 

Status Curve status. 

The Status column applies to Summary Curves and not to Detail Curves. 
This column should be blank for Detail curves. 

Time Scale The time taken by the process. 

This option applies to Detail Curves only and will be blank for Summary 
Curves. 
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Rollup 
Status 

This can be "Active" or "Inactive." This option controls whether the cash 
flow data from the current project or shell is rolled up to the Program or 
Company cash flow curves, or not. 

This option applies to Detail Curves only and will be blank for Summary 
Curves. 

Last Saved The date the cash flow curve properties were last updated and saved. 

This option applies to Detail Curves only and will be blank for Summary 
Curves. 

Auto 
Refresh 

A detail cash flow curve can be set up to refresh automatically as per a 
schedule. This column shows the auto-refresh frequency, if the curve has 
been set up for the same, else, it shows as blank. 

This option applies to Detail Curves only and will be blank for Summary 
Curves. 

Each cash flow detail curve has a Refresh Data Now option (Refresh Data has three states: 
Refresh Now, In Progress, and Refresh Complete) to allow you to get the most up-to-date 

information about the highlighted record, and a gear menu ( ) that enable you to conduct the 
following: 

Note: When you highlight a number of detail curves on the log, the gear 

menu ( ) menu enables you to View Summary. This options enables 
you to display the Summary Curve window for all selected curves. 

Open Open a curve. 

Copy Copy a curve. It opens the Create New Cash Flow Curve window. All 
options and values within this window are pre-populated by way of 
information in the Properties of the source curve. 

Note: The Name field in this window will be prefixed with "Copy of."  

You can make changes as needed and click OK to open the new detail 
curve window. 

Delete Delete existing cash flow curves. 

Note: When you select one or more curves (cash flow detail curves or 
summary cash flow curves) and click Delete, if you select, Yes in the 
resulting window, then the selected cash flow detail curves will be 
deleted. 

Refresh 
Now 

Refresh Data has three states: Refresh Now, In Progress, and Refresh 
Complete. 

Roll up 
Status 

A single menu option with two sub-options: 

 Active 

 Inactive 

To manage cash flow curves rollup status.  
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Properties To open the Properties window and access the following tabs: 

 General (Detail Level, Time Scale, and Period Close Settings) 

 Curves 

 Filter (Filter settings) 

 Options (Number Format) 

 Schedule (Refresh Cashflow, Frequency, Range of Recurrence) 

 Summary (add the curve to Summary curves) 

When you click and highlight a cash flow, the right pane displays the following tabs: 

Permissions Grant cash flow curves viewing and/or usage permission to other users 

Schedule Set Scheduled Runs, Frequency, and Range of Recurrence. 

History See the history of all refreshes (manual or scheduled) on a detail curve. 

Summary Cash Flow Curve

If there is more than one detail curve in the log, then one additional (system-generated) curve, 
the "Summary Cash Flow Curve" will be displayed in the log. Also, in this case, the view is 
defaulted to the "Group by Type" such that the detail curves and the summary curves are seen 
grouped by their type in separate arrangement or structure. The following shows the additional 
options specific to the "Summary Cash Flow Curve." 

Create Summary Curve window options:

This window (overlay page) appears when you select Summary Curve from the Create toolbar 
option. 

 Name

 Status

 Description

 Detail Curves

Enables you to select from available detail curves from the project or shell. You can select 
one or more curves and move them to the "Selected" section. 

 Cancel and Save

When you click Save, the Create Summary Curve window (Overlay page) closes, and the 
newly created summary curve appears in the log, as a row. 

As soon as you create a second detail curve, the system- defined "Summary Cash Flow Curve" 
is created automatically, and the Cash Flow log view changes to "Group by Type." The 
"Summary Cash Flow Curve" is displayed under the "Summary Curves" grouping. Similarly, if 
you delete the second last detail curve from the log, the Summary Cash Flow Curve will get 
deleted automatically from the grid. In this case, if there are no more user-defined summary 
curves, then the view returns to "All" instead of "Group by Type." 

The following explains the gear menu ( ) options (or right-click at a single Summary Curve) for 
the Summary Curves: 

 Open

To open the Summary curve window. 
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 Copy

To open the "Create Summary Curve" window (overlay) form in Standard View. When you 
copy, all of the options from the source curve properties are copied into the "Create 
Summary Curve" window (overlay) form. 

 Delete

To delete the Summary Curve. This option will not be available for the system-defined 
Summary Cash Flow Curve. 

The right pane for a Summary Curve log displays one tab: Properties. The Properties tab 
displays all of the options of the "Create Summary Curve" window (overlay) form and allows you 
to make changes. 

Note: You cannot make changes to the properties of the system-defined 
Cash Flow Summary Curve. For the system-defined Cash Flow 
Summary Curve, all options in the Properties tab appears as read-only.  

The system-defined Cash Flow Summary Curve values, for each option, are: 

 Name: Summary Cash Flow Curve 

 Status: Active 

 Description: System-defined Summary Cash Flow Curve 

 Detail Curves: The names of all Detail Curves from the Cash Flow log (the "Selected 
Curves" section). 

If you select multiple Detail Curves, then the right pane displays the following tabs: 

 Permissions 

This tab is similar to that of the single Detail Curve. 

 Schedule 

This tab is similar to that of the single Detail Curve. When you select multiple curves then all 
of the options in this tab will be empty. Any changes made in this tab, when saved, applies to 
all of the selected curves.  

If you select multiple Summary curves, then the right pane will be blank. 

If you select a combination of Detail and Summary curves, then the right pane will be blank. 

Note: If you have "View-only" permission, for Cash flow, then none of 
the right pane tabs (for both Detail as well as Summary curves) will be 
visible to you. 

Cash Flow Project Overview (Standard View) 

When you open a curve from the cash flow log, you see the cash flow project overview. The 
cash flow project overview provides a visualization of key information, snapshot changes, and 
system snapshots for faster understanding of project financial conditions. 

 Calculating Inflow, Outflow, and Variance  

 Inflow = the sum of all inflow amounts against a common timeline 
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 Outflow= the sum of all outflow amounts against a common timeline 

 Variance = outflow – inflow 

 Variance Analysis 

You can view inflow vs. outflow analysis in the three tiles at the top of the cash flow worksheet: 

 Current Cost Variance shows the difference between the current cost inflow and the current 
cost outflow. The change in current cost variance against the last snapshot displays beside 
the total. 

 At Completion Cost Variance shows the difference between the at completion cost inflow 
and the at completion cost outflow. The change in the at completion cost variance against 
the last snapshot displays beside the total. 

 At Completion Schedule Variance shows the difference between the at completion 
schedule inflow and the at completion schedule outflow in months. The change in the at 
completion schedule variance against the last snapshot displays beside the total. 

A bar chart corresponding to the colors of the curves is visible below the variance amount. Hover 
over a bar to display a tooltip with corresponding information, and click Click to Open to open 
the curve worksheet. 

Variance Analysis Table 

Click Show More at the bottom of the tile to view a Variance Analysis Table containing the 
following columns: 

 Curve Name 

 Current total 

 Changes from last Snapshot 

 At Completion Total  

 Changes from last Snapshot 

 End Date 

 Changes from last Snapshot 

 Forecast Analysis 

Forecast curves include a separate forecast analysis section in which you can view Spends vs. 
Forecast analysis and Forecast vs. Baseline analysis. This section contains four tiles: 

 Remaining <Forecast Curve Name> Amount shows the difference between the at 
completion forecast amount and the approved spends till date. The change in the remaining 
forecast amount against the last snapshot is displayed beside the total.  

 Remaining <Forecast Curve Name> Amount shows the difference between the at 
completion baseline amount and the approved spends till date. The change in the remaining 
baseline amount against the last snapshot is displayed beside the total. 

 Remaining <Forecast Curve Name> Time shows the difference in date between the 
forecast curve end date and the actuals end date. The change in the remaining forecast end 
date against the last snapshot displays beside the total. 

 Remaining <Forecast Curve Name> Time shows the difference in date between the 
baseline curve end date and the actuals end date. The change in the remaining baseline end 
date against the last snapshot displays beside the total. 
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 Forecast Analysis Table 

Click Show More at the bottom of the tile to view a Forecast Analysis Table containing the 
following columns: 

 Curve Name 

 Total 

 Changes from last Snapshot 

 Remaining Total 

 Changes from last Snapshot 

 End Date 

 Changes from last Snapshot 

 Remaining Time 

 Changes from last Snapshot  

Granting Cash Flow User Mode Permissions 

Before others can access a cash flow curve that you created, they need user mode permission. 
This is different from permission granted in Administration Mode, which is for general access to 
the module. You grant user mode permission per detail curve in the project or shell. 

Note: Granting cash flow User Mode permissions explained in this 
section is different from permission granted in Administration Mode, 
which is for general access to the module (Refer to the Unifier 
Administration Guide for details. You grant User Mode permission per 
detail curve in the Project/Shell. 

To give users permissions to work with a cash flow curve 

1) Open the Company Workspace tab and click Cost Manager > Cash Flow in the left 
Navigator. The Cash Flow log opens. 

2) Select one or more detail curves from the log, click Actions, and click Permission to open 
the Edit Permission window.  

3) Click picker in the Add to open the User/Groups window. Select one or more users or 
groups to grant permission to, click Done and then click OK. 

4) In the Edit Permission window, select one or more users or groups, and select any of the 
following permissions: 

 Modify Permission: Allows user to modify permissions to the curve. This also 
automatically selects Edit Data. 

 Edit Data: Allows user to enter or edit data for manual data entry curves. 

 View: By default, when you add a user or group to the window, they are granted View 
permission, which allows them to access and view the curves and data. 

5) Click Save. 

When the user creates a Cash Flow by way of copying from Project/Shell template through the 
Workflow Setup sub-node:  
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If the step in the Workflow Setup (in the project, admin mode) has a Cash Flow template, 
then all of the permissions in the Cash Flow template will be copied over to the created Cash 
Flow. 

When the user selects a Cash Flow template at the record level: 

If at the time of creating a commit BP record, the user has selected a Cash Flow template, 
then all of the permissions in the Cash Flow template will be copied over to the created Cash 
Flow. 

About Portfolio Manager Budget Curves 

The Portfolio Budget curve is linked to scenarios in the Portfolio Manager. The project manager 
must create this curve. Once created, the curve shows the initial budget projections. 

When you open a Portfolio Budget curve, you can view the data in the transaction currency, if 
different from the project currency. 

Note: If the currencies of your data sources are different, you can create 
a base currency using the Derived curve as your data source. 

For cash flow purposes, the Portfolio Manager extracts a project's baseline or forecast budget 
numbers for use in a scenario sheet. 

During a portfolio analysis, the Portfolio Manager can produce three different Portfolio Budget 
curves: 

1) Shared Budget curve

2) Approved Budget curve

3) Original Budget curve

Note: Before you can use these curves, you must add them to your 
project. 

You can pull data from the three different Portfolio Budget curves (Unifier Portfolio Manager) into 
the Cash Flow curves within your Project/Shell. 

Note: If the currency of data pulled from any of the three different 
Portfolio Budget curves (Unifier Portfolio Manager) is different from the 
Project/Shell currency, you can create a Derived curve (using the 
existing curves within a family) that converts data from existing curves to 
a different currency. 

Shared Budget curve 

This curve shows the portfolio planner's proposed number for the project. You will not have 
access to this curve until the planner shares a scenario. You can include this curve on the cost 
worksheet, along with the forecast budget, or any other budget curve, in order to see the 
difference between your project's numbers and the planner's proposed budget numbers. 
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Approved Budget curve 

When a scenario is approved in the Portfolio Manager, the budgets for each project in the 
scenario are marked "approved." They are then locked and stored in the Portfolio Manager. An 
Approved Budget curves shows the approved budget for the project for that planning period 
(usually a year). 

Original Budget curve 

This curve is for a project in execution. This budget is the last approved budget for the project 
before it moves into its execution phase. This approved budget becomes the project's original 
budget; and this original budget, plus any changes that occur to the numbers during the life of 
the project, becomes the project's approved budget. 

Financial Period in Cost Manager 

The Portfolio Budget curves (Shared, Approved, and Original), in Cash Flow, are linked to 
Portfolio Manager scenarios.  

User can attain data from the Portfolio Budget curves (Shared, Approved, and Original), from the 
Portfolio Manager scenario in Parent Shell, into the Cash Flow curves within a Project/Shell. 

During a portfolio analysis, the Portfolio Manager can produce the following Portfolio Budget 
curves: 

 Shared Budget curve

The Shared Budget curve displays the portfolio planner's proposed number for the project. 

The User can include the Shared Budget curve on the Cost worksheet (along with the 
forecast budget or any other budget curve) in order to see the difference between the project 
numbers and the planner's proposed budget numbers. 

 Approved Budget curve

When a scenario is approved in the Portfolio Manager, the budgets for each project in the 
scenario are marked "approved." 

Unifier lock and stores the budgets in Portfolio Manager. 

An Approved Budget curve displays the approved budget for the project for the planning 
period (usually a year). 

 Original Budget curve

The  Original Budget is the last approved budget for the project before it moves into its 
execution phase. 

The approved  Original Budget becomes the project original budget. This original budget 
(and any changes that occur to the numbers during the life of the project) becomes the 
project approved budget. 

The Portfolio Manager scenario (with Financial Period as the Period Structure) created in the 
parent Shell will push/pull the data from respective curve only. That is to say: 

 For the child Shell, it has the same Financial Period in its options, and 

 It will consolidate the data for only those Cash Flows where the timescale has been 
selected as Financial Period. 
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If the user selects a financial period from the ‘by’ drop-down list, then the corresponding 
drop-down list for financial period will get populated with the Financial Period present in the 
Shell options. 

Other options, in timescale, will be disabled (for format and so forth), and it will remain blank 
with other options enabled (for format and so forth). 

For Baseline and Forecast type curves, the summary sheet spreads and schedule manager 
spreads will be assigned to the relevant period. 

For the Actuals, the cost sheet columns and effective dates will be used to assign the values 
to the relevant period. 

For a Cash Flow curve, the X-axis for graph will still remain the same but the points in the curve 
will be based on the Financial Period that has been selected. The columns in the grid will be 
based on the Financial Period that has been selected, also. 

Creating Cash Flow Curves (Classic View) 

You can create cash flow curves either manually or automatically. You can also use existing 
cash flow curve templates to facilitate the creation of cash flow curves.  

Cash flow curves require a data source, which your administrator can create in Standards & 
Libraries. For details refer to the Unifier Administration Guide. 

There are multiple ways to create a cash flow curve (new, from a template, or copy). The 
following describes the basics of how to create a cash flow curve in Unifier. 

Note: You must have permission to access and configure cash flows. 

To create a cash flow detail curve: 

1) Open Unifier and go to your project or shell tab. 

2) Ensure that you are in User Mode. 

3) From the left Navigator click Cost Manager > Cash Flow. 

4) From the Cash Flow log select your project or shell. 

5) From the Cash Flow log toolbar click New to open the Properties window (the General tab is 
open by default). 

 Note: At this point, you can also select a cash flow template, if one is 
made available by your administrator. To select a template, click the 
down-arrow next to New and select a template.  

6) In the Name field, enter a name for the new cash flow curve. 

7) In the Description field, enter a brief description about the new cash flow curve. 

8) Ensure that the following options are selected: 

Rollup Status: Active

Values represented by this new cash flow curve will roll up to program and company level 
Cash Flow WorkSheets. 

Detail Level: Project/Shell

This new cash flow detail curve will track cash flow for the entire Project/Shell. 
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9) Click the Curves tab. 

10) Click Add to a list of available data source options. Each curve that you add is based on a 
data source that your administrator has defined as is available in this list. 

 Note: Each data source can only be used once in a Cash Flow 
WorkSheet. 

11) Click to select the desired data source (Example: Baseline) for the new cash flow detail 
curve.  

12) Based on your selected data source, a Curve Setup window (Cash flow by ...) for your 
selected data source opens (Example: Cash flow by Project/Shell – Baseline). 

13) Review the information in the Curve Setup window. The contents o the Name and the Type
fields are auto-populated and cannot be changed. The default option settings for all 
subsections of this window specify manual entry for all cash flow values (Manual). 

14) Click OK to go back to the Properties window. Notice that the curve is now listed in the 
Curves tab window. 

You can click Add to create another curve based on a different data source.  

When finished, click the curve that is listeded in the Curves tab window (Example: Baseline) to 
select, and then click the Filter tab. 

In the Filter tab you can determine the cash flow data displayed by the curves. Your filtering 
options are: 

 All CBS codes from cost sheet (selected by default) 

 Summary CBS codes 

 CBS codes 

Click the Options tab to set the Number Format for your curve. 

Click the Schedule tab to set the following schedule options for your curve: 

 Refresh Cash Flow 

 Frequency 

 Range of Recurrence 

When finished, click OK to open the Cash Flow WorkSheet window for your curve. 

Cash Flow Properties Settings Highlights (Classic View) 

The cash flow Properties window contains six tabs: 

 General

Specify timescale, detail level, and period close settings that will apply to all curves you 
create on the Curves tab. 

 Curves
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Create the family of curves (Baseline, Forecast, Actual (or Spends), Portfolio Budget, 
Derived, and Custom curves) to be added to the Detail Curve Cash Flow WorkSheet. You 
can add multiple curves to the worksheet. Each curve must be associated with a data 
source, which is defined by an administrator. Curves are color-coded based on data source. 

 Filter

Specify CBS codes or Summary CBS codes (for hierarchical CBS structures only) that are 
included in the cash flow data. If no codes are specified, cash flow curves will reflect all CBS 
codes present on the project cost sheet. 

 Options

Specify format for numbers displayed on the Cash Flow WorkSheet. 

 Schedule

Enable automatic refresh of the cash flow curve or specify a refresh schedule. 

 Summary

Displays the default summary tab within the tab. 

The Properties descriptions below apply to Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves. The descriptions were written to familiarize you with 
available cash flow capabilities. 

For Cash Flow by Project/Shell Detail Level 

 Curves tab 

Distribute amount from cost sheet column field and From/To Dates. This is where you add 
the curves based on available data sources. 

 Baseline, Forecast, Portfolio Budget, Derived, and Custom curves 

If you want to automatically distribute a Cost amount from a cost column, the column must be 
selected in the Project/Shell. You can choose a curve for a Project/Shell template as long as 
you are creating a new Project/Shell from the template and are copying both the curve and 
the cost sheet. 

 Actuals (or Spends) curve 

Because you must select a cost sheet column associated with Spends data in the 
Project/Shell, a Spends curve can only be created in a Project/Shell (or similar to the above, 
in a project/shell template). You will not be able to add a Spends curve in a company-level 
template. 

 Forecast curve 

If you define Forecast to start a the end of the Spends curve, the Forecast options use data 
from the Spends curve. Forecast options can only be set if a Spends curve is present. 

 Portfolio Budget curve 

The Portfolio Budget curve shows current project-row plan data from a Portfolio Sheet. When 
plan data changes, it becomes visible in the cash flow graph as a parallel curve so project 
managers can clearly see the variance between their projections and portfolio 
planner-initiated changes. 

 From Date and To Date
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These fields can be set up to pull start and finish dates from the master schedule sheet in the 
project or shell. These can be selected in a project or shell template. At runtime, be sure the 
master schedule sheet is set up and has dates in the date element fields chosen for the 
curves. 

Note: In manual mode, Unifier pegs cost data distribution to the From 
Date. If there are date changes, Unifier shifts the curve on the timeline 
based on From Date modifications. Each time period (month or year) on 
the curve retains the value of the original distribution as long as the 
duration remains the same. If date changes make the cash flow curve 
duration longer or shorter, Unifier will not re-balance or redistribute cost 
data to match the modified curve length (the data will change.) 

For Cash Flow by CBS Detail Level 

Curves tab 

Use dates from Schedule Sheet field - Effective for the baseline curve only, you can view cost 
distribution information by CBS code in a schedule sheet. 

The properties window for each curve type displays these settings: 

 Distribute amount from cost sheet column field and From/To Date fields. This is similar to 
Cash Flow by Project/Shell Detail Level above. 

 Auto by default profile by CBS field. 

For Baseline, Forecast and Custom curves, you cannot select "Auto by default profile by CBS" in 
a company template, but you can in the project/shell, since this setting relies on the CBS codes 
used in the project or shell. You can choose it for a project/shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 

Note: You won't be able to double-click the CBS Summary to view the 
CBS details. 

For Cash Flow by Summary CBS Detail Level 

Curves tab 

Distribute amount from cost sheet column field and From/To Date fields. This is similar to Cash 
Flow by CBS Detail Level above. 

Curves tab 

Auto by default profile by Summary CBS field. Similar to CBS detail level, for Baseline, Forecast 
and Custom curves, you cannot select "Auto by default profile by Summary CBS" in a company 
template, but you can in the Project/Shell, and a Project/Shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 

For Cash Flow by Commitment Detail Level 

General tab 
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 Business Process and Base Commit Record fields. 

 For a Commitment detail level, you must select the base commit type business process to 
use. Be sure that you selected business processes that are being used in the Project/Shell. 

 In the Base Commit Record field, you must select the record at runtime. This is not 
selectable in the template, since records do not exist in templates. The list displays all 
records you have permission to view. If a detail curve already exists for that record, you will 
not be able to choose the same record again. 

 Curves tab, Include Change Commits and Spends Business Process. 

If you chose these options, ensure that you have selected Change Commits that are being used 
in the Project/Shell, and are associated with the selected Base Commit. 

Note: If the cash flow is attached to a Portfolio Manager scenario, the 
planner-modified baseline curve appears adjacent to the original 
baseline in the Cash Flow WorkSheet. This lets the project Manager 
easily spot the difference between the initial projection and the planned 
suggestion. 

Distribution Profiles (Classic View) 

When working with templates versus detail curves in Project /Shell, distribution profiles can be:  

 Created in Administration Mode (in Standards & Libraries).  

 Used when selecting auto distribution for curves. 

At runtime, you can create additional distribution profiles within the project's cash flow module. 
When working with curves, you can apply the profiles created in Administration Mode, or in the 
project or shell. 

Note: If you are creating a new Project /Shell from a Project /Shell 
template, and are copying the cash flow module, then template 
properties and permissions will be copied into the new project or shell. 

Cash Flow Properties Settings: General tab (Classic View) 

The General tab of the cash flow Properties window is where you define shared characteristics 
for this family of curves. For example, all of the curves added here will share the same Time 
Scale, Detail Level, and Period close settings. 

To create a cash flow details curve and complete the Properties General tab: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 
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3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General 
tab as default. 

Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) Complete the fields in the General tab using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

After the General tab is complete, you can save as is, or continue by adding the curves that will 
make up the detail curve. See Cash Flow Properties Settings: Curves tab (Classic View) (on 
page 179). 

In this 
Field: 

Do this: 

Name Enter a unique name for the curve in the Name field. 

Description (Optional) Enter a brief description in the Description field. 

Rollup 
Status 

Select an option for Rollup Status. The options control whether the data is 
rolled up to Program or Company cash flow curves, or not. 

Active: The curve will roll up to Program or Company cash flow the next 
time the curves are refreshed. 

Inactive: The curve will not roll up to Program or Company cash flow the 
next time the curves are refreshed. 

Detail Level

Select a detail level option from the Detail Level box. The selected option 
determines the level-of-data the cash flow curves will display. Choose 
one: 

Project/Shell: Choose this to track cash flow for the entire project or shell. 
For example, Baseline and Actuals curves might chart the budget and 
cash outlay across the entire project. 

Summary CBS: Choose this option to track cash flow by summary CBS 
codes.  

Note: In order to select this option, the cost sheet used in the 
Project/Shell must be a tree structure. 

CBS: Choose this to track cash flow within a Project/Shell at the CBS 
code level. This allows you to track cash flow across the project for 
specific CBS codes, or for all CBS codes. 

Commitment: Choose this option to track cash flow associated with a 
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In this 
Field: 

Do this: 

particular commitment record and its line items. This includes, for 
example, a base contract and optionally their referenced change commits. 
This selection activates the following fields: 

Business Process: Click the drop down menu and choose a business 
process. Listed are the Project/Shell level business processes of type 
"Base Commit." When creating a template, choose the one that is likely to 
be used in the projects/shells the template will be used in. When creating 
the curve in a Project/Shell from the template, you may need to verify that 
the business process chosen here is active in the project or shell, or pick 
another from the list. 

Reference Elements: The worksheet will display the reference elements. 
By default, the Record Number will display as the number. You can click 
the drop down menu and choose an element to display as the Name 
(Record Number, Status or Title). 

Base Commit Record: This is selectable in a project or shell, but not in a 
template. Click the Select button. Choose the commitment record from the 
list of available records in the project or shell. Each commitment record 
can be selected only once. 

Note: You can set up the automatic creation of a cash flow curve when a 
base commit record is created and completed or reaches a particular 
step. This is done in the BP Setup for the business process. 

Time Scale 

Select the Time Scale. The time scale determines the scale and format in 
which the data is shown on the Cash Flow WorkSheet. 

By Month or Year. The default is Month. 

Format: Choose the format that you want the month and year displayed 
on the graphs. The default is M YYYY. 

Period 
Close 
Settings 

Define the Period Close Settings. The options allow you to choose some 
automatic settings that will happen at the end of each period (month or 
year, as chosen in the Time Scale field). 

Enable auto snapshot on 

The Enable auto snapshot on option determines when an automatic 
snapshot will be taken of the data. Click Select to open the Details 
window. 

The Enable auto snapshot on option determines when an automatic 
snapshot will be taken of the data. Click Select to open the Details 
window. 

If you selected Month for Time Scale (the preceding step): You can 
choose a specific date each month to automatically take a snapshot, or 
specify a particular day (such as the first Monday of the month), in the 
Details window.  

If you selected Year for Time Scale (the preceding step): You can specify 
the exact date to take the snapshot each year (or a particular day such as 
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In this 
Field: 

Do this: 

the first Monday of January), in the Details window. See the examples 
after the final step. 

Note: After an auto-snapshot is taken, the curve will be refreshed 
immediately. Actuals (or "spends") will resume after the auto-snapshot is 
completed. 

Examples of using Enable auto snapshot on, Cutoff spends, and Resume 
Spends 

Company A wants to take an auto snapshot of its cash flow data every 
time period. Company A would choose a particular date (such as the 3rd 
of the month for Month, or anuary 3 for Year). Unifier would take the 
snapshot and refresh the cash flow curve. They do not select the Cut off 
spends option. 

Company B regularly reviews and revises forecast projections during fixed 
days every time period. Because it does not want new Spends records to 
hit the Cash Flow WorkSheet during this period, they choose the Cut off 
spends option. This option requires that Enable auto snapshot be 
selected first. The company sets this option so that an auto snapshot is 
taken of their changes just before spends are resumed. Snapshots can 
then be used for comparison of previous forecasts with the current month. 
Any spends records that came in during the forecast period are not lost; 
the Resume Spends option determines whether those spends records will 
be included in the previous month’s cash flow, or pushed to the next time 
period. 

Cutoff spends

This option is applicable for Actuals (or "spends") type curves. 

Selecting this option will temporarily stop spends business processes (for 
example, Invoices) from hitting the Cash Flow WorkSheet during analysis 
periods.  

Notes:  

 The Enable auto snapshot on option must be selected first. Actuals 
(or "spends") will resume after the auto-snapshot is completed.  

 If no value is specified, then the last date of the current month is 
presumed. 

 Unifier marks the time of the Cutoff spends date at the beginning of 
the day. For example, on June 30, the data can become locked at the 
beginning of the day and not at the end of the day, therefore, 
preventing the user from making any last minute changes before the 
start of the next month. 

Period 
Close 
Settings 
(Continued)

Apply Spends to

The selections under this period close settings option allow you to apply 
spends to an effective date or before/after a Cutoff spends date. 

By default, Cutoff spends will resume immediately after an auto-snapshot 
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In this 
Field: 

Do this: 

is taken. 

Note: If there is a gap between the Cutoff spends date and the Enable 
auto snapshot on date, any spends that came during that period are not 
lost. 

For example, if a Cutoff spends date is October 26 and the Enable auto 
snapshot on date is November 2, (and the Time Scale is monthly) that 
defines the freeze period. Any spends that come in on October 27, 28, 29, 
30, 31, and November 1 will not hit the cash flow sheet during the freeze 
period. After the Enable auto snapshot on date is reached, spends will be 
included back in October for spends (Oct 27-31) or November for spends 
(Nov 1-2), and the effective date will be honored. 

The same month/year as the effective date 

Note: The text of the options under Apply Spends to change based on the 
selection that you made for the Time Scale (By: Month or By: Year). 

If this option is chosen, once the freeze period is lifted, spends data is 
included back in the current period. The final output is similar to the case 
where no period close settings are applied since the effective date is 
honored. Spends for Oct 26-31 will be included in October and Nov. 1-2 
spends will be included for November. 

For example, if the cutoff date is the 26th of October and the snapshot 
date is the 2nd November, the freeze period is Oct 26 – Nov 2nd. Any 
spends that come in on Oct. 27, 28, 29, 30, 31 and Nov. 1, and 2 will not 
show on the cash flow sheet during the freeze period. After the auto 
snapshot date is reached, these spends will be included back in either Oct 
for spends (Oct 27-31) or Nov for spends (Nov 1- 2) and the effective date 
will be honored. 

The next month/year if after the cutoff date 

Once the freeze period is lifted, spends data from the cutoff date to the 
end of the month will be included in the next month/year. Spends for Oct 
26-31 will be included in November and Nov. 1-2 spends will be included 
for November. 

The previous month/year if on or before the cutoff date 

Once the freeze period is lifted, spends data from the start of the month 
up to the cutoff date will be included in the previous month/year. Spends 
for Oct 26-31 will be included in September and Nov. 1-2 spends will be 
included for November. 

Note: During the Cutoff spends period, even if automatic refresh of the 
curve occurs as set in the Schedule tab, spends data will not hit the cash 
flow sheet until spends are resumed again. 
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Cash Flow Properties Settings: Curves tab (Classic View) 

In the Curves tab of the cash flow Properties window, you can add the curves you would like to 
include in the Cash Flow WorkSheet. See the About Cash Flow Worksheets (on page 301) 
section for more for details.   

Based on the data sources that you have defined in Company Workspace > Administration 
Mode > Standards & Libraries > Cash Flow > Data Sources, you can create: 

 Baseline curve 

 Custom curve 

 Derived curve 

 Forecast curve 

 Portfolio Budget curve 

 Actual (Spends) curve 

Depending on the type, the curve setup options will differ. You can define one curve for every 
data source. 

Note: The Portfolio Budget curve is linked to scenarios in the Portfolio 
Manager. The project manager must create this curve. Once created, 
the curve shows the initial budget projections. 

When you open a curve, you can view the data in the transaction currency, if the transaction 
currency is different than the project currency. 

Baseline Curve (Classic View) 

You can construct cash flow curves by Project/Shell, Summary CBS codes, by CBS, or by a 
specific Commitment business process and record. The Baseline curve options reflect the detail 
level selections you made on the General tab.  

This section explains the following topics: 

 To add a Baseline curve for cash flow by Project/Shell 

 To add a Baseline curve for cash flow by Summary CBS or CBS 

 To add a Baseline curve for cash flow by Commitment 

To add a Baseline curve for cash flow by Project/Shell: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users.  

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default.  
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Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Project/Shell under Detail Level. 

6) Click the Curves tab. 

7) Click Add and select the data source of type Baseline. The Cash Flow by Project/Shell - 
Baseline window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source 

Type No action. This field displays the curve type: Baseline 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual

You enter values into each field manually. 

Auto by default profile

You can choose one of the available Distribution Profiles, that 
were defined in Standards & Libraries > Cash Flow > Distribution 
Profiles, or from those that were defined directly in the 
Project/Shell cash flow log (Edit > Distribution Profiles). This will 
be used as the default profile; however, at runtime, you can 
change which profile to use. 

Click Select to open the Select Distribution Profiles window. Select 
a distribution profile to use as the default profile for the curve. 

The default profile is used for the initial display and calculations in 
the Cash Flow WorkSheet. You can change the distribution profile 
from the worksheet. If you do this, the default profile will 
automatically update to reflect the current selection. 
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In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you chose 
Manual above) 

You can enter cost information in the Total field on the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above) 

This will automatically distribute the amount in the Total field using 
the selected default profile. 

Distribute amount from cost sheet column 

This option will take the amount in the selected Cost Sheet 
column, and either allows you to distribute it manually (if you 
chose Manual distribution), or use the default distribution profile (if 
you chose Auto by default profile). An example column would be a 
budget. 

Schedule 

From Date  

To Date 

Define the range of dates to use to plot the cash flow data.  

If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 

Determine what dates to start the curve and end the curve. Choose 
one of the following options for each date: 

Manual

User enters the date directly in the Cash Flow WorkSheet. 

Data element from schedule sheet

Choose a schedule sheet data element from the list. The date will 
be populated automatically from the schedule sheet name (picker) 
when the cash flow curve is refreshed. 

If these dates are changed on the selected schedule sheet, then 
the changes will be reflected on cash flow after the next refresh of 
the curves. 

To add a Baseline curve for cash flow by Summary CBS or CBS: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 
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Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Summary CBS (for summary CBS codes) or CBS (for cash flow by individual CBS 
codes) under Detail Level. 

6) Click the Curves tab. 

7) Click Add and select the data source of type Baseline. The Cash Flow by Summary CBS - 
Baseline or Cash Flow by CBS - Baseline window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source 

Type No action. This field displays the curve type: Baseline 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual

You enter values into each field manually. 

Auto by default profile per CBS (for CBS Detail Level curves) or Auto 
by default profile summary CBS (for Summary CBS Detail Level 
curves) 

You can specify a default profile per CBS code (or Summary CBS 
code) one CBS at a time or by selecting multiple CBS codes. See 
the following instructions for details. 

The initial distribution profile is default. You can change the 
distribution profile at runtime. 

Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

- Click Auto by default profile per CBS > Details to open the Edit
Distribution Profiles (CBS Details) window. 

- Click to select a CBS > double-click the cell under the Default 
Profile column for that CBS > Click the desired distribution 
profile from the list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

- Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

- Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > 
Click Bulk Edit to open the Select Distribution Profiles 
(Distribution Profiles) window > Click the desired distribution 
profile from the list > Click Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window appears, 
ensure that the correct profiles have been selected and when 
finished, click Save. 
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In this Field: Do this: 

Distribution 
(continued) 

Use data from Schedule Sheet

This option enables you to choose a schedule sheet and view the 
cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Baseline does not have 
this option. 

To use data from schedule sheet, follow these instructions: 

Select Use data from Schedule Sheet > Click Select to open 
the Schedule Sheets window > Select the desired schedule 
sheet > Click Open. The selected schedule sheet appears in 
the Use dates from Schedule Sheet field. 

Use Data from P6 Source

Note: The Cash Flow by Summary CBS – Baseline does not have this 
option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when Shell Schedule 
Type = Duration Based. 

If you select this option, Cost and Dates information data come 
from P6 Summary Sheet (spread) based on P6 Data Sources.  

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Planned. 

If you select At Completion, the system draws the Baseline 
curve using the At Completion Cost spread. 

If you select Planned, the system draws the Baseline curve 
using the Planned Cost spread. 
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In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you chose 
Manual above) 

You can enter cost information in the Total field on the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above) 

This option automatically distributes the amount in the Total field 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column, 
and either enables you to distribute it manually (if you chose 
Manual distribution), or it enables you to use the default distribution 
profile (if you chose Auto by default profile).  

An example column would be a budget. 

Schedule 

From Date 

To Date 

Here you define the range of dates to use to plot the cash flow data. 
Your options are: 

Use dates from Schedule Sheet

To take dates from the schedule sheet elements, the Master 
schedule sheet for the project/shell is used. 

Use dates from P6 Summary Sheet

The data picker lists all sheets from the ‘P6 Summary Sheets’ node 
under the Schedule Manager node. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Resource Loaded or Cost Loaded. 

If you select this option, the dates information data come from P6 
Summary Sheet (spread). 

Note: This option is available when the Distribution option is 
Manual, or Auto by default profile per CBS. 

A secondary drop-down list, Dates Type, contains the date types 
available: Planned and At Completion, with Planned as default 
selection. Using the Start and Finish dates of the selected dates 
type, the system draws the cash flow curve. 

If you select Planned, the system draws the Baseline curve 
using the Planned Start and Planned Finish dates of the 
selected Summary Sheet. 

If you select At Completion, the system draws the Baseline 
curve using the At Completion Start and At Completion Finish 
dates of the selected Summary Sheet. 

To add a Baseline curve for cash flow by Commitment 
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You can build one Baseline curve per Commitment record. When you build a Baseline curve for 
individual line items, the Schedule of Value (SOV) type influences distribution options.  

 If the SOV lists individual line items by CBS you can distribute cost for each line item 
individually. 

 If the SOV groups line items, you cannot distribute cost for each line item individually.  

For costs distributed in the transaction currency, Unifier calculates and stores the distribution in 
project currency using the exchange rate table. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users.  

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Commitment under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Baseline. The Cash Flow Commitment - 
Baseline window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source 

Type No action. This field displays the curve type: Baseline 

Cash Flow 
Granularity 

Note: The Cash Flow Granularity option that you select determines 
the Distribution Method options that are available. 

The Cash flow granularity options determine the level of record detail 
available in the cash flow curve.  

You can roll up base and change commits and see individual records 
separately, or you can drill to individual line items in a Commitment 
record. 
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In this Field: Do this: 

Single 
distribution of 
sum of base 
commit and all 
changes 

Note: Selecting this option limits the Distribution Method to Manual 
entry of values per cash flow period, only. 

In User Mode, you must open the Cash Flow Details window to 
complete time scale fields and distribute the rolled up values of the 
base commit record and any change commit records. 

By individual 
record (base 
commit and all 
changes 
separately) 

Selecting this option enables you to select the following options from 
the Distribution Method: 

Manual entry of values per cash flow period 

Use this option to manually enter the time scale and to distribute 
costs. 

Auto distribution 

Use this option to utilize a pre-defined distribution curve. In User 
Mode, the curve data is read-only, but you can change the 
distribution profile. This selection requires a sub-selection. 

Manual Dates and manual profile selection 

Use this option to manually enter the time scale and select a 
distribution curve. 

Business process dates and default profile selection 

Use this option to select the time scale from fields on the business 
process. Click Details to open the selection window. There are 
four columns in the Auto Distribution window. 

Business Process: List comes from the Cost-type business 
processes available in your company 

From Data Element: Select the date you want the distribution 
to start 

Note: You can only select a Date element from the Upper 
Forms and not from the Business Process Detail forms.  

To Data Element: Select the date you want the distribution to 
end 

Default Profile: If desired, select a pre-defined profile. 
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In this Field: Do this: 

By line items 
within each 
individual record

Selecting this option enables you to select the following options from 
the Distribution Method: 

Manual entry of values per cash flow period 

Use this option to select record line items. In User Mode you can: 

See each selected line item in the Cash Flow Details window; 
the columns come from the business process. 

Select a profile on the detail window for each line. 

Select the distribution profile manually. 

Auto distribution 

Use this option to manually enter dates and select a distribution 
profile. 

Distribution 
Method 

Note: The Cash Flow Granularity that you selected determines the 
Distribution Method options that are available.  

Read the following sections in this table for details: 

Single distribution of sum of base commit and all changes 

By individual record (base commit and all changes separately) 

By line items within each individual record 

Note: By default, Unifier displays Commitment curve cost data in the 
record transaction currency, which is stored in project currency (using 
the active currency exchange rate table). If the transaction currency 
is different from the project currency, you can change the currency 
view between transaction and project currencies, but you can only 
edit data in the transaction currency. If there is a more recent value in 
the exchange rate table, refreshing the curve will refresh the cost 
data. 

Commit Change 
Processes to be 
included 

Add Commit Change business processes according to the status. 

Note: These line items are also seen in the Cash Flow Curve Details 
window. 

Actuals (Spends) Curve (Classic View) 

The Actuals (or "spends") Curve tracks actual invoice transactions. It pulls the data from a 
column of the cost sheet. Choose a column associated with the data source for the Spends-type 
business process and status that you want to track. 

This section explains the following topics: 

 To add Actuals (or "spends") curve for cash flow by Project/Shell 

 To add Actuals (or "spends") curve for cash flow by Summary CBS or CBS 

 To add Actuals (or "spends") curve for cash flow by Commitment 

 About Actuals (Spends) Curve and Forecast Curve 
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Note:  For Base Commits, Change Commits, and Payment Application 
BPs of Summary Payment Application SOV type (the Cash Flow family 
curves for Actuals (or "spends") curve for cash flow by Commitment): 

 If the Effective Date (uuu_effective_date) field has been defined in the 
Detail Form design, then this date is used as the effective date for 
the Costed Line Items. 

 In the absence of the Effective Date (uuu_effective_date) field, the 
Workflow end date will be used for Cash Flow. 

 You can see the Costed Amount for the Cash Flow curves of Actual 
(Spends) type level CBS and Summary CBS. 

 You can see the Line Item amount for the Cash Flow curves of Actual 
(Spends) type level Project/Shell. 

To add Actuals (or "spends") curve for cash flow by Project/Shell 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Project/Shell under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Actuals. The Cash Flow Project/Shell - Spends 
window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source: Acutals 

Type No action. This field displays the curve type: Spends 
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In this Field: Do this: 

Cost 

Distribute amount from cost sheet column

Choose a cost sheet column associated with the Spends-type 
business process and status. 

The Cost sheet column selection is only available when creating 
curves in a Project/Shell, not a template (since there is no cost 
sheet to reference).  

If you are creating a detail curve template, you will not be able to 
add a Spends curve. 

To add Actuals (or "spends") curve for cash flow by Summary CBS or CBS 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left  Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash flow 
Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Summary CBS or CBS under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Actuals. The Cash Flow by Summary CBS - 
Spends or Cash Flow by CBS - Spends window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name No action. This field is filled in automatically with the name of the data 
source: Actuals. 

Type No action. This field displays the curve type: Spends 
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In this Field: Do this: 

Cost Distribute amount from cost sheet column

Choose a cost sheet column associated with the Spends-type 
business process and status. 

The Cost sheet column selection is only available when creating 
curves in a Project/Shell, not a template (since there is no cost 
sheet to reference).  

If you are creating a detail curve template, you will not be able to 
add a Spends curve. 

Use Actuals from P6 Data Source

Note: The Cash Flow by Summary CBS – Actuals does not have 
this option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Duration Based. 

If you select this option, the system draws the Spends curve using 
the Actual Cost spread from the selected P6 Data source.  

To add Actuals (or "spends") curve for cash flow by Commitment 

Note: When you open this curve, you can view the data in two different 
currencies by switching between project and transaction currencies. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Commitment under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Actuals. The Cash Flow by Commitment - 
Spends window opens. 
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8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name No action. This field is filled in automatically with the name of the data 
source: Acutals 

Type No action. This field displays the curve type: Spends 

Cash Flow 
Granularity 

Select By line items from Schedule of Values if you want to get cash 
flow individual line items from the Actuals (or "spends") record. 

Cost Select Spends Business Process

Choose the Spends Business Process to use. 

The Spends-type business processes and the related status that 
are associated with the Base Commit are listed in the box. 
Choose the business processes and statuses that you want to 
include in the curve. 

About Actuals (Spends) Curve and Forecast Curve 

Unifier complies with the initial profile. If Actuals (or "spends") are received for a portion of the 
curve, and the Forecast curve is connected to Actuals (or "spends"), Unifier takes the 
already-consumed-profile portion out of the equation and redistributes the unconsumed pending 
profile portion.  

Examples 

 The Forecast curve starts from Jan 2012- Dec 2014, stretching Unifier's default 20 point 
distribution profile over 36 periods. 

 Actuals were received January 2012 February 2012, and March 2012. 

 These three periods of Forecast curve already consumed 1.67 points of period 
distribution. 

 The Forecast end date is now changed to December 2015. 

 The Forecast curve is now March 31 2012 to December 2015. 

 Unifier then distributes the remaining 18.33 points of profile over 45 periods. 

If there are some CBS codes that have received Actuals (or "spends") and some CBS codes 
that did not, then the CBS codes that did not receive Actuals (or "spends") will be replaced by 0 
at the end of the month, or on the cutoff date (depending on the UI settings). 

If there are some CBS codes that have received future Actuals (or "spends") and some CBS 
codes that did not, then the Forecast Curve will not reflect future Actuals (or "spends") until they 
become current. 

The following section explains the Forecast Curve. 

Forecast Curve (Classic View) 

This section explains the following topics: 

 General Information about Forecast Curve 
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 To add a Forecast Curve for cash flow by Project/Shell 

 To add a Forecast Curve for cash flow by Summary CBS or CBS 

 To add a Forecast Curve for cash flow by Commitment 

 Forecast Curve Behavior Test Cases 

To add a Forecast Curve for cash flow by Project/Shell 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. 

The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Project/Shell under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Forecast. The Cash Flow by Project/Shell - 
Forecast window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name No action. This field is filled in automatically with the name of the data 
source: Forecast 

Type No action. This field displays the curve type: Forecast 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one of the following options: 

Manual

To enter values in each field manually. 

Note: Selecting the Manual distribution option enables you to 
select the following two Cost options, only: 

Manually enter amounts for each period 

Distribute amount from cost sheet column 

Auto by default profile

To select one of the available profiles from the Distribution 
Profiles. 

You can choose one of the available Distribution Profiles, that 
were defined in Standards & Libraries > Cash Flow > Distribution 
Profiles, or from those that were defined directly in the 
Project/Shell cash flow log (Edit > Distribution Profiles).  

The selected profile will be used as the default profile; however, at 
runtime, you can change which profile to use. 

Select Auto by default profile > Click Select. The Select 
Distribution Profiles (Distribution Profiles) window opens. 

Select a profile to use for the curve, as default profile, and click 
Select. 

Note: If the initial Forecast uses a distribution profile, and has a 
configuration start at the end of Actuals (or "spends"), the profile 
does not impact Forecast distribution when you receive Actuals (or 
"spends"). 
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In this Field: Do this: 

Cost 

Note: The distribution method that you select determines the Cost 
options that are available. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual distribution) 

You can enter cost information in the Total field on the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile distribution) 

This option distributes the amount in the Total field automatically, 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column 
and enables you to either: 

Distribute it manually (if you chose Manual distribution) 

or 

Use the default distribution profile (if you chose Auto by default 
profile distribution) 

For a forecast column, an example of a column choice would 
be a Spends-type business process and status. 

Schedule 

From Date 

To Date 

Select, or define, the range of dates to use to plot the cash flow data. 
If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 
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In this Field: Do this: 

Schedule 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down list 
and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends 
are available only if you have chosen: 

Auto by default profile for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated or 
underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods 

Enter the number of time periods. 

using weighted average over next _____ period(s) 

Enter the number of time periods, 1 or more, not to exceed the 
number of periods remaining. 

To add a Forecast Curve for cash flow by Summary CBS or CBS  

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 
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3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations.  

The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users.  

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Summary CBS or CBS under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Forecast. The Cash Flow by Summary CBS - 
Forecast or Cash Flow by CBS - Forecast window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name No action. This field is filled in automatically with the name of the data 
source: Forecast 

Type No action. This field displays the curve type: Forecast 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one of the following options: 

Manual

To enter values in each field manually. 

Note: Selecting the Manual distribution option enables you to 
select the following two Cost options, only: 

Manually enter amounts for each period 

Distribute amount from cost sheet column 

Auto by default profile per CBS

To select one of the available profiles from the Distribution 
Profiles. Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > double-click the cell under the Default 
Profile column for that CBS > Click the desired distribution 
profile from the list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > 
Click Bulk Edit to open the Select Distribution Profiles 
(Distribution Profiles) window > Click the desired distribution 
profile from the list > Click Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window 
appears, ensure that the correct profiles have been selected 
and when finished, click Save.  
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In this Field: Do this: 

Distribution 
(continued) 

Use data from Schedule Sheet

This option enables you to choose a schedule sheet and view the 
cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Forecast does not have 
this option. 

To use data from schedule sheet, follow these instructions: 

Select Use data from Schedule Sheet > Click Select to open 
the Schedule Sheets window > Select the desired schedule 
sheet > Click Open. The selected schedule sheet appears in 
the Use dates from Schedule Sheet field. 

Use Data from P6 Source

Note: The Cash Flow by Summary CBS – Forecast does not have 
this option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when Shell Schedule 
Type = Duration Based. 

If you select this option, Cost and Dates information data come 
from P6 Summary Sheet (spread) based on P6 Data Sources. 

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Remaining. 

If you select At Completion, the system draws the Forecast 
curve using the At Completion Cost spread. 

If you select Remaining, the system draws the Forecast curve 
using the Remaining Cost spread. 



Unifier Managers User Guide

200

In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you chose 
Manual above) 

You can enter cost information in the Total field on the worksheet.

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above) 

This option automatically distributes the amount in the Total field 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column, 
and either enables you to distribute it manually (if you chose 
Manual distribution), or it enables you to use the default 
distribution profile (if you chose Auto by default profile).  

An example column would be a budget. 

Schedule 

From Date 

To Date 

Select, or define, the range of dates to use to plot the cash flow data. 

If you choose to take dates from the schedule sheet elements, the 
schedule sheet name (picker) for the Forecast is used. 

Use dates from P6 Source

Note: This option is available for CBS, only. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when Shell 
Schedule Type = Cost or Resource Based 

If you select this option, the Dates information data come from P6 
Summary Sheet (spread) based on P6 Data Sources.  

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Remaining. 

If you select At Completion, the system draws the schedule from 
At Completion Start and At Completion Finish. 

If you select Remaining, the system draws the schedule from 
Remaining Start and Remaining Finish. 
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In this Field: Do this: 

Schedule 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down 
list and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends are 
available only if you have chosen: 

Auto by default profile per CBS for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated or 
underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods 

Enter the number of time periods. 

Using weighted average over next _____ period(s) 

Enter the number of time periods, 1 or more, not to exceed the 
number of periods remaining. 
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In this Field: Do this: 

Schedule 

Forecast 
Options 
(continued) 

Use dates from P6 Summary Sheet

The data picker lists all sheets from the ‘P6 Summary Sheets’ 
node under the Schedule Manager node. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Resource Loaded or Cost Loaded. 

If you select this option, the dates information data come from P6 
Summary Sheet (spread). 

Note: This option is available when the Distribution option is 
Manual, or Auto by default profile per CBS. 

A secondary drop-down list, Dates Type, contains the date types 
available: At Completion and Remaining. Using the Start and 
Finish dates of the selected dates type, the system draws the 
cash flow curve. 

If you select At Completion, the system draws the Forecast 
curve using the At Completion Start and At Completion Finish 
dates of the selected Summary Sheet (spread). 

If you select Remaining, the system draws the Forecast curve 
using the Remaining Early Start and Remaining Early Finish 
dates of the selected Summary Sheet (spread). 

To add a Forecast Curve for cash flow by Commitment 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Commitment under Detail Level. 

6) Click the Curves tab. 

7) Click Add and choose a data source of type Commitment. The Cash Flow by Commitment - 
Forecast window opens. 

8) Complete the fields in this window using the information in the following table. When finished 
click OK to save work and open the Cash Flow WorkSheet that you added. 
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In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source: Forecast 

Type No action. This field displays the curve type: Forecast 

Cash Flow 
Granularity 

Single 
distribution of 
sum of base 
commit and all 
changes 

Manual entry of values per cash flow period.  

Note: This is the only available option. If you select this option, you 
can only select the Manual entry of values per cash flow period option 
for Distribution Method. 

In User Mode, you must open the Cash Flow Details window to 
complete time scale fields and distribute the rolled up values of the 
base commit record and any change commit records. 
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In this Field: Do this: 

Cash Flow 
Granularity 

By individual 
record (base 
commit and all 
changes 
separately) 

Use with:  

Manual entry of values per cash flow period option under Distribution 
Method 

Auto distribution option under Distribution Method 

Either with the Manual dates and manual profile selection option, 
or the Business process dates and default profile selection option.

Selecting the Manual entry of values per cash flow period option 
under Distribution Method enables you to manually enter the time 
scale and to distribute costs. 

Selecting the Auto distribution option under Distribution Method 
enables you to utilize a pre-defined distribution curve. In User 
Mode curve data is read-only, but you can change the distribution 
profile. 

Selecting the Auto distribution option under Distribution Method 
requires selecting one the following sub-selection: 

Manual Dates and manual selection of profile: Use this option 
to manually enter the time scale and select a distribution 
curve. 

Business process dates and default profile selection: Use this 
option to select the time scale from fields on the business 
process. Click Details to open the selection window. There are 
four columns in the Auto Distribution window and you can 
select one of the following option: 

Business Process 

List comes from the Cost-type business processes available in 
your company. 

From Data Element 

Select the date you want the distribution to start. 

To Data Element 

Select the date you want the distribution to end. 

Default Profile 

If desired, select a pre-defined profile. 
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In this Field: Do this: 

Cash Flow 
Granularity 

By line items 
from Schedule 
of Values 

Use with:  

Manual entry of values per cash flow period option under Distribution 
Method.  

Manual entry with auto distribution of unassigned amount option 
under Distribution Method. 

Auto distribution option under Distribution Method. 

Manual dates and manual profile selection option, only. 

Selecting the Manual entry of values per cash flow period option 
under Distribution Method enables you to select record line items. 
In User Mode you can: 

See each selected line item in the cash flow Details window; 
the columns come from the business process. 

Select a profile on the detail window for each line. 

Select the distribution profile manually. 

Selecting the Manual entry with auto distribution of unassigned 
amount option under Distribution Method enables you to 
auto-distribute the total cost.  

You must select a Default profile for new records. Initially the 
curve uses auto-distribution based on both the dates you entered 
in the Forecast details window and the default profile you selected 
for the distribution method. Once you modify data-period dates: 

If the Unassigned amount is not equal to zero, you must 
manually enter dates and manually adjust the Unassigned 
amount. 

If the Unassigned amount equals zero, the Cash flow by 
Commitment - Forecast curve uses a weighted average to 
redistribute the Unassigned amount. 

Selecting the Auto distribution option under Distribution Method 
automatically selects the Manual Dates and manual selection of 
profile option and enables you to manually enter dates and select 
a distribution profile. In the Cash Flow Details window, Unifier 
populates column values from the Business Process Schedule of 
Values (SOV).  

Distribution 
Method 

See Cash Flow Granularity in this table for details. 

Commit Change 
Processes to be 
included 

Add Commit Change business processes according to the status. 

Note: These line items are also seen in the Cash Flow Curve Details 
window. 
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In this Field: Do this: 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down 
list and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends 
are available only if you have chosen: 

Auto by default profile per CBS for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated 
or underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods: Enter the 
number of time periods. 

using weighted average over next _____ period(s): Enter the 
number of time periods, 1 or more, not to exceed the number 
of periods remaining. 

Forecast Curve Behavior Test Cases 
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Cases Condition Time Manual 
Distribution 

Auto 
Distribution 

Forecast Curve NA NA Manual 

Schedule 
(Dates) 

Schedule Sheet

Auto 

Schedule 
(Dates) 

Schedule Sheet

Set in the past Forecast with 
Actuals (no 
Actuals data) 

Start Date No change Moves to 
current 

Set in the past Forecast with 
Actuals (no 
Actuals data) 

End Date No change Future: No 
change 

Past: Moves to 
current 

Set in the past Forecast with 
Actuals (with 
Actuals data) 

Start Date Moves to 
current 

Moves to 
current 

Set in the past Forecast with 
Actuals (with 
Actuals data) 

End Date Future: No 
change 

Past: Moves to 
current 

Future: No 
change 

Past: Moves to 
current 

Set in the future Forecast with 
Actuals (no 
Actuals data) 

Start Date No change No change 

Set in the future Forecast with 
Actuals (no 
Actuals data) 

End Date No change No change 

Set in the future Forecast with 
Actuals (with 
Actuals data) 

Start Date Moves to 
current 

Moves to 
current 

Set in the future Forecast with 
Actuals (with 
Actuals data) 

End Date No change No change 

Portfolio Budget Curve (Classic View) 

Unifier Portfolio Manager allows you to pull the Baseline, or Forecast, data from more than one 
Project/Shell into the following three Portfolio Budget curves: 

 Shared Budget curve 

 Approved Budget curve 

 Original Budget curve 
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For an explanation of these options see About Portfolio Manager Budget Curves (on page 
168). 

The General tab of the "Cash flow Portfolio Budget" window contains the following fields and 
sub-fields: 

 Name

 Type

 Cost

 Distribute amount from 

 Currency 

The following explains how to enter data in the "Cash flow Portfolio Budget" window fields and 
sub-fields in details. 

In the Distribute amount from field drop-down list (under Cost), you can select Original, 
Shared, or Approved, then click OK. The portfolio curve opens in the Properties window. 

Note: If the currency of data pulled from any of the three different 
Portfolio Budget curves (Unifier Portfolio Manager) is different from the 
Project/Shell currency, you can create a Derived curve (using the 
existing curves within a family) that converts data from existing curves to 
a different currency. 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

This section explains the following topics: 

 To add a Portfolio Budget Curve for cash flow by Project/Shell 

 To add a Portfolio Budget Curve for cash flow by CBS or Summary CBS 

 To add a Portfolio Budget Curve for cash flow by Commitment 

 To add a Portfolio Roll Up Curve for cash flow (by Program) 

 To view Portfolio Budget Curve for cash flow 

To add a Portfolio Budget Curve for cash flow by Project/Shell: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 



Working with Unifier Managers

209

Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Project/Shell under Detail Level, and enter settings for Time Scale and Period 
Close Settings. 

6) Click the Curves tab. 

7) Click Add and choose a data source based on a portfolio budget type (Original Budget - 
Approved Budget - Shared Budget). The Cash flow by Project/Shell - Portfolio window 
opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

Note: If you need additional curves, repeat steps 6 to 8. 

In this Field: Do this: 

Name 

No action. This field is filled in automatically with the name of the data 
source. 

The names are: Original Budget - Approved Budget - Shared Budget 

Type No action. This field displays the curve type: Portfolio Budget 

Cost 
Select an option from the Distribute amount from field list.  

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

To add a Portfolio Budget Curve for cash flow by CBS or Summary CBS: 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 
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Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Summary CBS or CBS under Detail Level, and enter settings for Time Scale and 
Period Close Settings. 

6) Click the Curves tab. 

7) Click Add and choose a data source based on a portfolio budget type (Original Budget - 
Approved Budget - Shared Budget). The Cash flow by Summary CBS - Portfolio Budget or 
Cash flow by CBS - Portfolio Budget window opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

Note: If you need additional curves, repeat steps 6 to 8. 

In this Field: Do this: 

Name 

No action. This field is filled in automatically with the name of the data 
source. 

The names are: Original Budget - Approved Budget - Shared Budget 

Type No action. This field displays the curve type: Portfolio Budget 

Cost 
Select an option from the Distribute amount from field list. 

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

To add a Portfolio Budget Curve for cash flow by Commitment: 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 
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Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Commitment under Detail Level, and enter settings for Time Scale and Period 
Close Settings. 

6) Click the Curves tab. 

7) Click Add and choose a data source based on a portfolio budget type (Original Budget - 
Approved Budget - Shared Budget). The Cash flow by Commitment - Portfolio Budget 
window opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

Note: If you need additional curves, repeat steps 6 to 8. 

In this Field: Do this: 

Name 

No action. This field is filled in automatically with the name of the data 
source. 

The names are: Original Budget - Approved Budget - Shared Budget 

Type No action. This field displays the curve type: Portfolio Budget 

Cost 
Select an option from the Distribute amount from field list. 

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

To add a Portfolio Roll Up Curve for cash flow (by Program): 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

1) Open Unifier. 

2) Click Company Workspace tab. 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane) 

4) The Cash Flow log is the starting place for cash flow operations. 

The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users.  

5) To create a new cash flow, click the New drop-down list (the down arrow) and select Roll Up 
Curves. The Properties window opens and displays the General tab as default. 
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6) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Active for Status. 

7) In the Data Sources box, select as many data source items as you want. 

8) In the Time Scale box, enter the settings that you want and when finished click OK to save 
work and open the Cash Flow WorkSheet that you added. 

To view Portfolio Budget Curve for cash flow: 

You can view the curves and data source based on a portfolio budget type (Original Budget - 
Approved Budget - Shared Budget). 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Commitment under Detail Level, and enter settings for Time Scale and Period 
Close Settings. 

6) Click the Curves tab.  

7) Click Add and choose a data source based on a portfolio budget type (Original Budget - 
Approved Budget - Shared Budget). The Cash flow by Project/Shell - Portfolio Budget 
window opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

Note: If you need additional curves, repeat steps 6 to 8. 

In this Field: Do this: 

Name 

No action. This field is filled in automatically with the name of the data 
source. 

The names are: Original Budget - Approved Budget - Shared Budget 

Type No action. This field displays the curve type: Portfolio Budget 
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In this Field: Do this: 

Cost 
Select an option from the Distribute amount from field list. 

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

Currency 

When you define a Portfolio Budget curve within any curve family type (CBS, Summary CBS, 
Commitment, and Project/Shell), you have the option to select the currency (Currency field 
under Cost) of the Portfolio Budget data source from the Portfolio Manager. 

The Currency field is a required field (default value: Project Currency) if you have Portfolio 
Budget curves. You can change the value of the Currency field to another value by opening the 
curve configuration window. 

Note: When you run a report, the value of Currency, in the report, is 
Project Currency unless you have selected another value. 

The Currency field lists all Active and future currencies from Exchange Rates (Company 
Workspace > Admin mode > Standards & Libraries > Exchange Rates). The Show Currency 
List window lists the available currencies that you can select. 

Derived Curve (Classic View) 

The Cash Flow Data Sources of type = Derived is available to create Cash Flow curves within 
any family (CBS, Summary CBS, Commitment, and Project/Shell).  

When creating a new Cash Flow curve within any Cash Flow family: 

 Data Sources of type = Derived must be enabled only when there is at least one non-Derived 
(i.e., Baseline, Spends, Forecast, Portfolio Budget, or Custom) type curve exists in the 
family.  

 If there is no non-Derived type curve exists in the family, all Data Sources of type = Derived 
are grayed out. 

When the "Derived" type data sources are enabled, and the user clicks at such a data source, 
then a window is displayed that enables the user to enter the details for creating the new curve. 
The following explains the fields in the "Derived" type cash flow curve configuration window: 

Option Description Behavior 

Name Captures the name of the cash 
flow curve as defined in cash 
flow data sources in Company 
Workspace -> Admin Mode 

Same behavior as in existing cash flow 
curves- 

Type Captures the type of cash flow 
curve viz., Baseline, Custom, 
Forecast, Spends, Portfolio 

Same behavior as in existing cash flow 
curves- 
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Option Description Behavior 

Budget, Derived. 

Base 
Curren
cy 

Captures the base currency for 
user to see and make 
exchange rate decisions. 

Behavior: Read-Only 

Displays the Base Currency as a read-only 
value 

Source 
Curve 

To select an existing curve 
which should be used as the 
basis of the ‘Derived’ curve.  

Behavior – Drop-down 

List all the non-Derived existing curves within 
the family in which the ‘Derived’ curve is being 
configured. Values are: <Curve Name> 
(<Type>), example: Shared (Portfolio 
Budget). 

Note: Derived curve cannot be a source curve 
to create another Derived curve. 

Required? (Not Null) – Required option. The 
user must select a value for this drop-down to 
complete the curve configuration.  

Derive
d 
Curve 
Curren
cy 

To select the currency that 
must be used to convert the 
‘Source Curve’ 

Behavior – Currency Selector  

User has the ability to select any currency 
from Company Workspace -> Standard & 
Libraries -> Exchange Rates (active and 
future) 

Required? (Not Null) – Required option. The 
user must select a value for this selector to 
complete the curve configuration. 

Excha
nge 
Rate 

To define how the exchange 
rates must be used so that 
those can be applied to the 
source curve data. That is to 
say, should the exchange rate 
be picked up from as defined in 
Company Workspace -> 
Standards & Libraries, or 
should the rate be ‘Pegged’ to 
a value as chosen by user. 

Behavior: Radio button, two options: Float, 
Peg 

Default Value = Float 

When user selects the option ‘Float’, another 
drop-down option appears: ‘Use Rate as’ (see 
below) . 

Use 
Rate 
as 

To choose how to make use of 
exchange rate data from 
Company Workspace -> 
Standards & Libraries, 
especially if more than one rate 
is found for a given period 
(month / year) 

Behavior –Radio button 

Values: 

- At the beginning of the period 

- At the end of the period 

- A weighted average for the period 

Required? (Not Null) – Required option if 
‘Exchange rate’ = ‘Float’. 
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Option Description Behavior 

If the user clicks ‘OK’ on the window without 
selecting this option, the following message 
appears: Invalid data entered in the following 
field(s): Input Required: Use rate as. 

If you choose the option ‘Exchange Rate’ = ‘Peg’, then Unifier provides another block titled ‘Peg 
Rate as’: 

 If Base Currency = Project Currency, then Peg Rate options should be available for 
conversion Base Currency -> Derived Curve Currency 

 If Base Currency ≠ (not equal) Project Currency and Project Properties list the conversion 
Base Currency -> Project Currency as ‘Peg’ option, then also behavior should be same as 
above, i.e., list options only for Base Currency -> Derived Curve Currency  

 If Base Currency ≠ (not equal) Project Currency but Project Properties list the conversion 
Base Currency -> Project Currency as ‘Float’ option, then peg rate options are available for 
both: 

 Base Currency -> Derived Curve currency 

 Base currency -> Project Currency 

The following explains the Derived’ curve ‘Peg’ Rate options: 

Option: 

Peg Rate options 

Description: 

To define the value by which the exchange rate must be pegged. The user will have to enter a 
value manually, or point to an attribute on shell attribute form / single record BPs within the shell, 
or choose if they wish to use the pegged rate from shell properties. In latter case, Unifier will look 
into the value of the data element each time when rendering the curve. 

Behavior: 

Behavior  - Radio button 

Base Currency -> Derived Curve Currency: 

There should be helpful text informing user that conversion is for 1.0 Base Currency -> Derived 
Currency (text: 1.0 Base Currency =) This is be followed by three options:  

 Constant 

 Dynamic 

 Use Project Rate 

Default Radio Option: Constant 

If the user selects 'Constant', Unifier opens a field (DD = Decimal Amount). The decimal places 
appear when user types a digit after decimal point, only; otherwise, an integer value will appear. 
The field enables the user to enter an Integer or Decimal value. 

Default Radio Option: Dynamic 
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If the user selects ‘Dynamic’, Unifier enables two drop-downs which will capture the Data Source 
for the multiplication factor: 

Drop-down 1: 

The shell attribute form of the current shell within which curve is being created. 

The shell attribute forms of all parent/grandparent shells of current shell in which curve is 
being created (i.e., attribute forms of all shells in hierarchy of current shell, up to the root) 

All single record BPs within the shell in which curve is being created. 

The above should be prefixed by identifiers ‘Shell Attribute Form / <Shell name>’, or ‘Single 
Record BPs / <BP name>. For example: 

Shell Attribute Form / All Properties 

Shell Attribute Form / Buildings 

Shell Attribute Form / Sites 

Single Record BPs / Project Information 

Single Record BPs / Important Contacts 

… 

Drop-down 2: 

Lists all linked and custom Data Elements from the selected source form whose Data 
Definition = Integer / Decimal Amount / Currency Amount. (No standard elements) 

Note: The user can change the location / hierarchy of a shell. So the above two drop-down 
values must be refreshed each time the curve is refreshed. 

Note: If the user chooses the options ‘Constant’ / ‘Dynamic’, then the user must define a value 
(Constant integer/decimal or Dynamic data source). If not selected, the user will see a standard 
prompt after clicking ‘OK’: 

‘Invalid data entered in the following field(s): Input Required: ‘Constant’ or ‘Data Source’ 

The user can choose to use the third option: ‘Use Project Rate’ Selecting this option does not 
open up any additional field, but Unifier picks up the exchange rate as defined in project 
properties (described in Peg rate as ‘Use Project Rate’ section below). The user receive 
appropriate error message in either of following scenarios: 

 The user selects a ‘Derived Curve Currency’ which does not exist in Project Properties 
(Message: Selected currency is not defined in project.), or 

 The user selects a ‘Derived Curve Currency’ which is listed in Project Properties, but its 
conversion rate is set to ‘Float’ (Message: Selected currency does not have pegged rate 
within project.). 

Error should be presented when user clicks ‘OK’ on curve configuration window. 

Base Currency -> Project Currency 

The radio options are for user to select how to use the rate from Company Workspace -> 
Standards and Libraries (label: Use Rate as). 

The radio options are visible only if Base Currency ≠ Project Currency AND rate Base Currency 
-> Project Currency is set as ‘Float’ in project properties. 

Options same as when user chooses to ‘Float’ rate: 
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User can choose to use the rate as: 

 At the beginning of the Period 

 At the end of the period 

 A weighted average for the period 

Default value: At the beginning of the period. 

Note: This block ‘Peg Rate options’ is displayed only if ‘Exchange Rate’ is selected as ‘Peg’. 

The following provides some scenarios. 

User selects the Peg Rate option for Base Currency -> Derived Curve Currency as = ‘Use 
Project Rate’, and the curve configuration is successful (i.e., ‘Derived Curve Currency’ is listed in 
Project Rate with a pegged conversion rate). 

The user then goes to Project Properties and changes the exchange rate for Base Currency -> 
Derived Curve Currency as ‘Float’, and reopens the cash flow. 

Since the curve has not been refreshed, the Cash Flow worksheet continues to show data as 
per previous value. 

If user opens the ‘Derived’ curve configuration window, the message, "Selected currency does 
not have pegged rate within project" appears. 

If user refreshes the curve, then cash flow worksheet shows all values as zero as the curve 
configuration is not longer valid. 

If user opens the ‘Derived’ curve configuration window, the message, "Selected currency does 
not have pegged rate within project" appears. 

In case Base currency ≠ Project Currency 

User selects the Peg Rate option for Base Currency -> Derived Curve Currency as either of the 
three possible options, 

Base Currency -> Project Currency is set as ‘Peg’ in project properties. So there are no 
additional options to choose from, the curve configuration is successful  

Then user goes to Project Properties and changes the exchange rate for Base Currency -> 
Project Currency as ‘Float’ 

Then reopens the cash flow 

Since the curve has not been refreshed, the Cash Flow worksheet continues to show data as 
per previous value. 

If user opens the ‘Derived’ curve configuration window, the options for Base Currency -> Project 
currency appears, and the default value is selected as ‘At the beginning of the period’. 

If user refreshes the curve, then cash flow worksheet values are refreshed as per the options for 
Base Currency -> Project Currency. 

When user selects a currency to derive the curve, Unifier uses the data from source curve per 
period and convert it into the selected currency as per the float or peg exchange rate option as 
selected by user within curve definition: 

If user chooses the ‘Float’ option, Unifier uses the exchange rates as defined in Company 
Workspace -> Standards and Libraries -> Exchange Rates  
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If the user chooses ‘Peg’ option, exchange rate values should be as per user selection in the 
block ‘Peg Rate as’ 

See following sections on how the derived curve should calculate its data per period… 

Note: The user can select the currency to be same as source curve currency. In that case, the 
derived curve would be same as source curve, exchange rates would not apply. 

Exchange Rate = Float (Rate at beginning of the period)

The user can select the Derived curve definition such that the exchange rate for currency 
conversion from source to destination is picked up from Company Workspace -> Standards and 
Libraries in such a way that the Rate from the beginning of the period is used. 

In other words, when doing the currency conversion, of all the available rates for a given period, 
Unifier selects the Rate closest to the beginning of the period. 

Note: If more than one rate is defined for the same day, Unifier picks the latest rate on that day. 
If no exchange rate is available for a past date, Unifier uses zero. 

Exchange Rate = Float (Rate at the end of the period)

The user can select the Derived curve definition such that if multiple exchange rates are 
available for a given period (month / year), Unifier uses the rate ‘At the end of the period’.  

In other words, when doing the currency conversion, of all the available rates for a given period, 
Unifier selects the Rate closest to the end of the period. 

Exchange Rate = Float (A weighted average for the period)

If the user chooses to apply the exchange rate as a weighted of all values for a given period 
(Exchange Rate = ‘Use a weighted average for the period’), then the value will be based on the 
number of days in a given month. That is to say, the total of all "Rate * No. of days it is 
applicable during the period" divided by "Total number of days within the period~" (~Month / 
Year). 

When the Exchange Rate = ‘Float’, Oracle recommends that the user set a ‘Refresh’ frequency 
(Cost Manager > Cash Flow > Refresh drop-down > Set Frequency...), for the Derived curves, to 
cover the following scenarios: 

Scenario 1 

Future Exchange Rates from ‘Company Workspace -> Standards & Libraries’ can get 
changed with time. If ‘Derived’ cash flow curve is not set to automatic refresh, it will 
continue to hold values as per older exchange rate values (unless manually opened & 
refreshed) 

Scenario 2 

The ‘Source Curve’ might undergo a change in its configuration / values. If ‘Derived’ cash 
flow curve is not set to automatic refresh, it will continue to hold values as per older 
source curve data (unless manually opened & refreshed). 

Exchange Rate = Peg

This option means that the user does not want to use exchange rate as captured within 
Company Workspace -> Standards and Libraries -> Exchange Rates, but the user prefers to 
define the rate as one of the following: 
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 Constant 

 Dynamic 

 Use Project Rate 

If Constant: 

To do the currency conversion (1.0 Base Currency = <constant value> Derived Curve 
currency), Unifier uses the constant value entered by the user. 

The source curve defaults to be in Project currency. If Base Currency ≠ Project Currency, 
Unifier picks the  exchange rate for Base Currency -> Project Currency from Project 
Properties and makes appropriate conversion to calculate the Derived curve in Derived 
Currency as selected by user. 

If Base Currency -> Project Currency in Project properties is set as ‘Float’, then unifier uses 
the option as selected by user for ‘Base Currency -> Project currency’ conversion. 

Unifier picks rates from Company workspace -> Standards and Libraries -> Exchange Rates 
by using one of the following options selected by user: 

 At the beginning of the period 

 At the end of the period 

 A weighted average for the period 

If Dynamic: 

When rendering the curve, Unifier accesses the Data Element (DE) selected by the user and 
uses the value as the exchange rate to do conversion (1.0 Base Currency = <Selected DE 
value> Derived Curve currency). 

If the DE value is blank/null (in source shell attribute form/single record BP), then Unifier 
applies zero as the exchange rate. 

If Base Currency ≠ Project Currency, then Unifier does one of the following: 

 Unifier picks the exchange rate for Base Currency -> Project Currency from Project 
Properties 

 Unifier calculates the Derived curve (in Derived Currency) as selected by user. 

If Use Project Rate: 

The exchange rate is pegged as specified in the shell properties. 

If Base Currency ≠ Project Currency, then Unifier does one of the following: 

 Unifier picks exchange rate for Base Currency -> Project Currency from Project 
Properties 

 Unifier calculates the Derived curve (in Derived Currency) as selected by user. 

Note: For Commitment type curves, user can flip the view between Project and Transaction 
currencies. Unifier calculates for Source Curve data -> Derived Curve data by taking the 
source data in Project currency. 

When the Exchange Rate = ‘Peg’, Oracle recommends that the user set a ‘Refresh’ frequency 
(Cost Manager > Cash Flow > Refresh drop-down > Set Frequency...), for the Derived curves, to 
cover the following scenarios: 

Scenario 1 
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Peg rates as defined in project properties might undergo a change. If ‘Derived’ cash flow 
curve is not set to automatic refresh, it will continue to hold values as per older 
pegged exchange rate values (unless manually opened & refreshed). 

Scenario 2 

The ‘Source Curve’ might undergo a change in its configuration / values. If ‘Derived’ cash 
flow curve is not set to automatic refresh, it will continue to hold values as per older 
source curve data (unless manually opened & refreshed). 

For all types of Cash flow families, the ‘Derived’ curve values are always displayed in its 
currency, as selected by user in curve configuration window. 

For Commitment type cash flow families, the user can choose to view the family curves in 
‘Project’ / ‘Transaction’ currency. 

In either case, the ‘Derived’ curve renders in the currency, as selected by user for the ‘Derived’ 
curve configuration window--irrespective of whether the rate is ‘Float’ or ‘Pegged’. 

The following explains special scenarios related to the exchange rate. 

Special Scenario 1 

The user selects a ‘Source Curve’ while configuring the ‘Derived’ curve 

Completes ‘Derived’ curve configuration and clicks ‘OK’ 

Removes the ‘Source Curve’ itself from the cash flow family definition. 

In this scenario: 

When the user opens the curve worksheet, the derived curve will render all values as 
zero--irrespective of whether the cash flow family has been refreshed or not. 

When the user opens the curve configuration window, the ‘Source Curve’ drop-down 
continues to show original value. When the user clicks ‘OK’, the message, "Invalid curve 
configuration" is displayed. 

Special Scenario 2 

The user selects the ‘Exchange Rate’ as ‘Peg’ > Peg as ‘Dynamic’, and then chooses a data 
source DE from grandparent shell attributes. 

The user completes ‘Derived’ curve configuration and clicks 'OK'. 

The user changes the location of shell in which the curve was defined. 

In this scenario: 

If the new parent is the same type of shell (or another shell having the data Source DE on its 
attribute form), then this is not an error scenario. The curve renders by using the Rate value 
from new location. 

If, however, the new parent does not have the Data Source DE on its attribute form, then the 
curve configuration is invalid: 

When the user opens the curve worksheet, the Derived curve renders all values as zero.  

When the user opens the curve configuration window, the Data Source continues to show 
original value. When the user clicks ‘OK’, the message, "Invalid curve configuration" is 
displayed. 

Special Scenario 3 
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The user selects a ‘Source Curve’ while configuring the ‘Derived’ curve,  

The user completes ‘Derived’ curve configuration and clicks 'OK'. 

The user removes the ‘Source Curve’ Datasource from company Workspace Cash Flow 
Datasources definitions. 

In this scenario: 

When the user opens the curve worksheet, the Derived curve (as well as the source curve) 
renders all values as zero--irrespective of whether the cash flow family has been refreshed 
or not. 

When the user opens the Derived curve configuration window, the ‘Source Curve’ drop-down 
shows original value, and when the user clicks ‘OK’, the message, "Invalid curve 
configuration" is displayed. 

Monthly actuals for Derived Forecast Curve  

If the checkbox is checked in the configuration then in the Portfolio Manager, then the user will 
be able to the see the monthly breakdown for actuals and the values seen would be read-only 
for months prior to the current month for the current year. The behavior and validation, which 
exist in support for monthly actuals for Forecast curve, is available for Derived forecast curve as 
well. 

Actuals for Derived Actuals Curve 

If Derived Actuals curve is defined, then Unifier uses the Derived Actuals curve data, and the 
derived forecast data will be pushed from Cashflow to PPM. The derived actuals data links to the 
source actuals. In case of multiple derived curve for the same project with inconsistent settings 
(either different currency or settings such as float versus peg), a cumulative data value is 
displayed in the project currency, which is used by PPM, and the red triangle is displayed 
against that cell to depict the inconsistency. When the user hovers over, this warning message is 
displayed: {ppmname} Portfolio Manager received data from multiple actuals curves that have 
inconsistent settings. The correct value will be seen once the settings are corrected. 

Custom Curve (Classic View) 

You can create a Custom Curve when you want to create and compare curves in a Cash Flow 
WorkSheet, but you do not want to associate them with data sources of the other curve types 
(Baseline, Forecast, Actuals (or "spends"), Portfolio).  

Custom Curve setup is essentially the same as setting up Baseline Curves. 

The following instructions assume that you have created your data sources: 

 Go to: Company Workspace > Administration Mode > Standards & Libraries > Cash Flow > 
Data Sources 

 Click Data Sources > Click Open to open the Cash Flow Data Sources (Cashflow 
Datasources) window > Click Add to add new cash flow data source 

 Follow the prompts and click OK when finished 

This section explains the following topics: 

 To add a Custom Curve for cash flow by Project/Shell 

 To add a Custom Curve for cash flow by Summary CBS or CBS 
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 To add a Custom Curve for cash flow by Commitment 

To add a Custom Curve for cash flow by Project/Shell 

1) Open Unifier 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General tab 
as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Project/Shell under Detail Level. 

6) Click the Curves tab. 

7) Click Add and select the data source of type Custom. The Cash Flow by Project/Shell - 
Baseline window opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source: Custom 

Type No action. This field displays the curve type: Custom 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual: You enter values into each field manually. 

Auto by default profile: You can choose one of the available 
Distribution Profiles, that were defined in Standards & Libraries > 
Cash Flow > Distribution Profiles, or from those that were defined 
directly in the Project/Shell cash flow log (Edit > Distribution Profiles). 
This will be used as the default profile; however, at runtime, you can 
change which profile to use. 

Click the Select button. The Select Distribution Profiles window 
opens. Select a distribution profile to use as the default profile for the 
curve. 

The default profile is used for the initial display and calculations in the 
Cash Flow WorkSheet. You can change the distribution profile from 
the worksheet. If you do this, the default profile will automatically 
update to reflect the current selection. 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual above): You can enter cost information in the Total field on 
the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above): This will automatically distribute the 
amount in the Total field using the selected default profile. 

Distribute amount from cost sheet column: This option will take the 
amount in the selected Cost Sheet column, and either allows you to 
distribute it manually (if you chose Manual distribution), or use the 
default distribution profile (if you chose Auto by default profile). An 
example column would be a budget. 

Note: Cost column can be chosen when creating a curve in a project 
or shell, but not in templates. 
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In this Field: Do this: 

Schedule 

From Date  

To Date 

Define the range of dates to use to plot the cash flow data.  

If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 

Determine what dates to start the curve and end the curve.  

Choose one of the following options for each date: 

Manual: User enters the date directly in the Cash Flow WorkSheet. 

Data element from schedule sheet: Choose a schedule sheet data 
element from the list. The date will be populated automatically from 
the Master schedule sheet when the cash flow curve is refreshed. 

If these dates are changed on the Master schedule sheet, then the 
changes will be reflected on cash flow after the next refresh of the 
curves. 

To add a Custom Curve for cash flow by Summary CBS or CBS 

1) Open Unifier 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General tab 
as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list (the 
down arrow) and select From Template to open the Template Log (Cash Flow Templates) 
window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General tab, enter Name, enter Description (optional), select Active for Rollup Status, 
and select Summary CBS or CBS under Detail Level. 

6) Click the Curves tab. 

7) Click Add and select the data source of type Custom. The Cash Flow by Summary CBS - 
Custom or Cash Flow by CBS - Custom window opens. 

8) Complete the fields in this window using the information in the following table and when 
finished click OK to save work and open the Cash Flow WorkSheet that you added. 

In this Field: Do this: 

Name 
No action. This field is filled in automatically with the name of the data 
source: Custom 

Type No action. This field displays the curve type: Custom 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual: You enter values into each field manually. 

Auto by default profile per CBS (for CBS Detail Level curves) or Auto 
by default profile summary CBS (for Summary CBS Detail Level 
curves) 

You can specify a default profile per CBS code (or Summary CBS 
code) one CBS at a time or by selecting multiple CBS codes. See the 
following instructions for details. 

The initial distribution profile is default. You can change the 
distribution profile at runtime. 

Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > double-click the cell under the Default Profile 
column for that CBS > Click the desired distribution profile from the 
list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > Click 
Bulk Edit to open the Select Distribution Profiles (Distribution Profiles) 
window > Click the desired distribution profile from the list > Click 
Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window appears, 
ensure that the correct profiles have been selected and when 
finished, click Save. 
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In this Field: Do this: 

Distribution 
(continued) 

Use dates from Schedule Sheet: This option enables you to choose a 
schedule sheet and view the cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Baseline does not have 
this option. 

To use dates from schedule sheet, follow these instructions: 

Select Use dates from Schedule Sheet > Click Select to open the 
Schedule Sheets window > Select the desired schedule sheet > Click 
Open. The selected schedule sheet appears in the Use dates from 
Schedule Sheet field. 

Note: If a schedule sheet is not selected, the distribution profile 
displays zeros along the bottom of a Cash Flow Curve graph. When 
you click OK in the details window, the filter will be applied against 
the CBS codes coming from the schedule sheet. 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual above): You can enter cost information in the Total field on 
the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above): This option automatically distributes 
the amount in the Total field using the selected default profile. 

Distribute amount from cost sheet column: This option takes the 
amount in the selected Cost Sheet column, and either enables you to 
distribute it manually (if you chose Manual distribution), or it enables 
you to use the default distribution profile (if you chose Auto by default 
profile).  

An example column would be a budget. 

Schedule 

From Date 

To Date 

Here you define the range of dates to use to plot the cash flow data. If 
you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the project/shell is used. 

To add a Custom Curve for cash flow by Commitment 

Custom curves are not available for cash flow by commitment. 
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Cash Flow Properties Settings: Filter tab (Classic View) 

The Filter tab of the cash flow Properties window enables you to select one or more CBS codes 
(or, if the Project/Shell cost sheet uses a tree structure, Summary CBS codes) to include in the 
cash flow data. This allows you to limit the cash flow data to a subset of the CBS Codes or 
Summary CBS Codes that are on the cost sheet. If you do not select any codes on this tab, then 
the cash flow curves will default to all CBS codes present on the Project/Shell cost sheet. 

Note: Filtering is not available on company-level curves, or for curves of detail level 
Commitment. To choose codes, the cost sheet must be defined in the Project/Shell or 
Project/Shell template. 

To filter curve data by CBS or Summary CBS codes: 

1) Open Unifier 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General tab 
as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list (the 
down arrow) and select From Template to open the Template Log (Cash Flow Templates) 
window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the Filter tab and select one of the available options: 

 All CBS codes from cost sheet: This is the default filter, and the cash flow data reflects all 
CBS codes. The Add and Remove buttons, at the bottom of the window, are disabled. 

 Select Summary CBS codes: This filter allows you to select specific summary CBS codes 
to include in the cash flow data. This option is available if the cost sheet has a tree 
structure, and the curve Detail Level is Project/Shell or Summary CBS (on the General 
tab). 

 Select CBS codes: This filter allows you to select which CBS codes to include in the cash 
flow data. 

6) Select a filter option: 

7) If you Select Summary CBS codes and click Add, the Select summary CBS codes window 
opens. 

8) If you Select CBS codes and click Add, the Cost Code Picker window opens. 

9) Click the desired code (or codes), click Select to include the selected CBS codes in the filter. 
You can use Remove to delete codes from the list, if necessary. 

10) Click OK, when finished, to open the Cash Flow WorkSheet window. 
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Cash Flow Properties Settings: Options tab (Classic View) 

The Options tab of the Cash flow Properties window enables you to define the format to use for 
the numbers displayed on the Cash Flow WorkSheet.  

The following Number Format choices are available. 

 Decimal Places: Choose from 0-8; default is 2. 

 Use 1000 Separator (,): Example: 1,000; default is deselected. 

 Negative Number Format: Choose from the list; default is -1234. 

Cash Flow Properties Settings: Schedule tab (Classic View) 

The Schedule tab of the cash flow Properties window enables you to set up the refresh 
frequency of a selected cash flow curve. 

To enable cash flow refresh: 

1) Open the cash flow Properties window. 

2) Click the Schedule tab. 

3) Select the Enable Refresh checkbox. 

Notes: 

 If you select this checkbox, then you can set up scheduled refresh of the cash flow curve.  

 The cash flow sheet will refresh automatically to reflect the most recent cost data or any 
changes that may have been made to the distribution profile or other properties. 

 If you do not select this checkbox, the curve can still be manually refreshed at runtime. 

4) For Frequency, choose when you want the refresh to run. The options are: 

 Daily: At the end of every day. 

 Weekly: The refresh runs at the end of the day that you select. 

 Monthly: You can choose a specific date in the month (For example, the 31st), or you can 
choose a particular day (e.g., first Monday of the month). If you choose the 31st, the 
system runs the refresh on the last day of the month for those having less than 31 days. 

 Quarterly: Refresh runs on the day into the quarter that you specify. For example, Day 1 
of the quarter. (Refers to a standard calendar quarter.) 

5) For Range of recurrence, you can define when the refresh schedule begins and ends. 

6) In the Start On field, using the calendar, choose a date to start the refresh schedule. 

 Select, or deselect No end date based on your preference. If you select No end date, the 
refresh runs at the scheduled intervals until the refresh is turned off, or the Project/Shell 
is inactive or set as view-only. 

 Select or deselect End by based on your preference. If you select End by and determine 
a date, using the calendar, the automatic refresh stops on the day that you selected for 
this field. 

7) When finished setting up Refresh Cash Flow, click OK to save and close the Cash Flow 
WorkSheet window. 
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Cash Flow Properties Settings Highlights (Classic View) 

The cash flow Properties window contains six tabs: 

 General

Specify timescale, detail level, and period close settings that will apply to all curves you 
create on the Curves tab. 

 Curves

Create the family of curves (Baseline, Forecast, Actual (or Spends), Portfolio Budget, 
Derived, and Custom curves) to be added to the Detail Curve Cash Flow WorkSheet. You 
can add multiple curves to the worksheet. Each curve must be associated with a data 
source, which is defined by an administrator. Curves are color-coded based on data source. 

 Filter

Specify CBS codes or Summary CBS codes (for hierarchical CBS structures only) that are 
included in the cash flow data. If no codes are specified, cash flow curves will reflect all CBS 
codes present on the project cost sheet. 

 Options

Specify format for numbers displayed on the Cash Flow WorkSheet. 

 Schedule

Enable automatic refresh of the cash flow curve or specify a refresh schedule. 

 Summary

Displays the default summary tab within the tab. 

The Properties descriptions below apply to Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves. The descriptions were written to familiarize you with 
available cash flow capabilities. 

For Cash Flow by Project/Shell Detail Level 

 Curves tab 

Distribute amount from cost sheet column field and From/To Dates. This is where you add 
the curves based on available data sources. 

 Baseline, Forecast, Portfolio Budget, Derived, and Custom curves 

If you want to automatically distribute a Cost amount from a cost column, the column must be 
selected in the Project/Shell. You can choose a curve for a Project/Shell template as long as 
you are creating a new Project/Shell from the template and are copying both the curve and 
the cost sheet. 

 Actuals (or Spends) curve 

Because you must select a cost sheet column associated with Spends data in the 
Project/Shell, a Spends curve can only be created in a Project/Shell (or similar to the above, 
in a project/shell template). You will not be able to add a Spends curve in a company-level 
template. 

 Forecast curve 

If you define Forecast to start a the end of the Spends curve, the Forecast options use data 
from the Spends curve. Forecast options can only be set if a Spends curve is present. 

 Portfolio Budget curve 
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The Portfolio Budget curve shows current project-row plan data from a Portfolio Sheet. When 
plan data changes, it becomes visible in the cash flow graph as a parallel curve so project 
managers can clearly see the variance between their projections and portfolio 
planner-initiated changes. 

 From Date and To Date

These fields can be set up to pull start and finish dates from the master schedule sheet in the 
project or shell. These can be selected in a project or shell template. At runtime, be sure the 
master schedule sheet is set up and has dates in the date element fields chosen for the 
curves. 

Note: In manual mode, Unifier pegs cost data distribution to the From 
Date. If there are date changes, Unifier shifts the curve on the timeline 
based on From Date modifications. Each time period (month or year) on 
the curve retains the value of the original distribution as long as the 
duration remains the same. If date changes make the cash flow curve 
duration longer or shorter, Unifier will not re-balance or redistribute cost 
data to match the modified curve length (the data will change.) 

For Cash Flow by CBS Detail Level 

Curves tab 

Use dates from Schedule Sheet field - Effective for the baseline curve only, you can view cost 
distribution information by CBS code in a schedule sheet. 

The properties window for each curve type displays these settings: 

 Distribute amount from cost sheet column field and From/To Date fields. This is similar to 
Cash Flow by Project/Shell Detail Level above. 

 Auto by default profile by CBS field. 

For Baseline, Forecast and Custom curves, you cannot select "Auto by default profile by CBS" in 
a company template, but you can in the project/shell, since this setting relies on the CBS codes 
used in the project or shell. You can choose it for a project/shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 

Note: You won't be able to double-click the CBS Summary to view the 
CBS details. 

For Cash Flow by Summary CBS Detail Level 

Curves tab 

Distribute amount from cost sheet column field and From/To Date fields. This is similar to Cash 
Flow by CBS Detail Level above. 

Curves tab 
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Auto by default profile by Summary CBS field. Similar to CBS detail level, for Baseline, Forecast 
and Custom curves, you cannot select "Auto by default profile by Summary CBS" in a company 
template, but you can in the Project/Shell, and a Project/Shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 

For Cash Flow by Commitment Detail Level 

General tab 

 Business Process and Base Commit Record fields. 

 For a Commitment detail level, you must select the base commit type business process to 
use. Be sure that you selected business processes that are being used in the Project/Shell. 

 In the Base Commit Record field, you must select the record at runtime. This is not 
selectable in the template, since records do not exist in templates. The list displays all 
records you have permission to view. If a detail curve already exists for that record, you will 
not be able to choose the same record again. 

 Curves tab, Include Change Commits and Spends Business Process. 

If you chose these options, ensure that you have selected Change Commits that are being used 
in the Project/Shell, and are associated with the selected Base Commit. 

Note: If the cash flow is attached to a Portfolio Manager scenario, the 
planner-modified baseline curve appears adjacent to the original 
baseline in the Cash Flow WorkSheet. This lets the project Manager 
easily spot the difference between the initial projection and the planned 
suggestion. 

Cash Flow Properties Settings: Summary tab (Classic View) 

A Summary Cash Flow Curve displays selected cash flows from your project. For example, you 
can collect and view:  

 Forecast data across all commitment curves in a project. 

 Data from contracts and schedule sheets. 

 Baseline, Forecast, Actuals (or "spends"), and Derived information from contracts and 
commitments. 

In Summary curves, Unifier aggregates cost data according to Cash Flow Data Sources (set in 
the Cashflow Datasources window).  

Example 

 Baseline  

 Forecast 

 Actuals (or "spends") 

 Portfolio Budget 

 Derived 

See Cash Flow Properties Settings: Curves tab (Classic View) (on page 179) for more 
information. 
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Unifier displays summarized cost data in a Cash Flow WorkSheet. The main window charts 
summary data, and the curves window lists each cost data source. You can open a data source 
and see the source cash flow curves. 

Once you define at least one Summary Curve in your project, Unifier lists the Summary curve as 
a selection on the curve properties Summary tab. 

Showing Detailed CBS Codes in Summary Curves 

For Summary curves with all child curves at the CBS detail level, when creating a summary cash 
flow curve, if CBS details are available for all of the curves, summarized data is displayed at 
individual CBS levels in the details. 

However, if there is a curve in the selection that does not have CBS level details (for example, 
Project/Shell or Commitment levels), then summary details will display individual curve names. 

Data will always be in project currency. If child curves have the same transaction currency, then 
you have the option to show data in transaction currency, as well.  
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Cash Flow Summary Curves 

You must have at least one cash flow summary curve defined in order to see Summary Curves 
listed on the Summary Curves tab. 

You can create cash flow summary curves in the project Cash Flow log or by using Manage 
Summary Curves (on page 240).  

The following topics are explained in this section: 

 About Summary Curves 

 Summary Curve Cash Flow WorkSheet 

 Filter for Summary Curves 

 Filter for Detail Curve 

 Showing Detailed CBS Codes in Summary Curves and Curve Combinations 

 Creating Cash Flow Summary Curves 

 Opening an existing Summary Curves Cash Flow Window 

About Summary Curves 

Each Project/Shell cash flow has a system defined Project/Shell Summary Curve. The Summary 
menu item displays the system defined Project/Shell summary curves with a separator lines 
between Manage Summary Curves and each Project/Shell Summary Curve. This feature applies 
to existing Detail Curves as well as all new curves that a user created. 

A user can access the list of available individual Project/Shell Summary Curve by clicking the 
Summary drop-down list (the down arrow).  

Notes: 

 Similar to users with permission to access Custom Summary Curves, users with access to 
Cash Flow module have access to each Project/Shell Summary Curve, automatically. 

 The Manage Summary Curves menu item is not available to users who do not have Edit 
permission for cash flows. 

 If users do not have Edit permission and no Custom Curves are created, the Summary menu 
option shows system defined Project/Shell Summary Curve, only. 

Summary Curve Cash Flow WorkSheet 

The Summary Curve WorkSheet, automatically, includes all Cash Flow records for the 
Project/Shell when a user accesses the Project/Shell Summary Curve. 

When the Summary Curve WorkSheet is open, Unifier uses the current Summary Curves default 
settings: 

 All Curves Types are selected 

 No Saved Filter options are enabled by default (based on new Filter functionality). 

 Entire Date range of all Curves are available in the Timeline (Graph, Timeline, and Table) 

 Information is rolled up if Roll Up Status is set to Active on a record 

Once the system defined Project/Shell Summary Curve is open, the same functionality for a 
Summary Curve is available to the user, which includes the enhanced Filter functionality as 
described in the following sections. 
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Filter for Summary Curves 

When viewing Cash Flow WorkSheet Filter for Summary Curves, the Filter option provides 
additional filtering options. The following settings are available when filtering for Summary 
Curves: 

 Date Range 

 CBS Code Filter 

 Save and Manage Filters 

 Apply Filter settings to entire Worksheet (includes the Graph, Timeline, and Table) 

The Filter menu option of the Summary Curves enables you to open the Filter window and select 
the Curve Types, set the Timescale, add and determine the Detail Level for both the Graph and 
the Table sections. The Filter window also enables you to save the filter through the Save As 
field. The saved filters are available in a global collection and can be accessed by users. 

The Cash Flow WorkSheet Filter for Summary Curves is accessible through Project/Shell, only. 

When a Summary Curve Cash Flow WorkSheet is open, you can access the Filter menu options 
through: 

 Filter icon 

 View > Filter 

 Edit > Manage Filters 

The Filter icon and the View > Filter options are available for both Detail Curve and Summary 
Curves. These options are not available (disabled) if the Cash Flow WorkSheet does not contain 
any Curve Types.  

Note: At least one curve type must be selected. 

The Saved Filter dropdown field enables you to access previously saved filters. 

To reload records after updates, do the following: 

1) Close Summary Curve Cash Flow WorkSheet 

2) Open Summary Curve Cash Flow WorkSheet 

3) Click Reset and switch to a different saved filter or a blank filter. 

On the Summary Curve Table section, the following options are available: 

 Zoom: To set the zoom level for the Graph 

 Reset: To reset the zoom level and all applied filters (enable all curve types) 

 Y (icon): To view the Summary Curve by year (Y) 

 Print: To print the Summary Curve. 

The Filter menu option of the Summary Curves enables you to open the Filter window and select 
the Curve Types, set the Timescale, and determine the Detail Level.  

Curve Types

This section lists all the curve types that are available for the Summary Curve WorkSheet. 

Selecting a curve from the Curve Types box in the Filter window enables you to filter both the 
Graph and the Table. 
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The Filter menu option for Summary Curve is accessible through Project/Shell, only. 

When opening a previously saved filter, only previously saved Curve Types appear and 
checked. If a curve type is disabled (not available in the current Summary Curve), the curve type 
remains checked but disabled. Users cannot uncheck a disabled Curve Type. If a curve type is 
disabled, the current Summary Curve WorkSheet does not have that particular curve type as a 
data source. 

For Summary Curves, all curve types are selected and enabled. Curve types can be deselected 
or selected individually. Only the curve types that are available in summary curve are shown in 
the filter window.  

Note: At least one curve type must be selected. 

Timescale

The From Date and To Date fields are read only. Users can enable the dates through date 
picker. 

Once a date is selected the proper date format appears in the field, based on user date format 
preferences. 

The Summary Curve date range consists of the available date range based on included Curve 
data. When a user adds a Timescale or timeline to a Filter, then the Timescale or timeline for the 
Curve Graph and Table begins and ends with the From Date and To Date in the filter. 

Users can also adjust the Timescale or timeline using the sliders (left or right) within the Graph. 

The default value for Timescale is the entire unfiltered timeline. 

The following conditions apply to The Summary Curve date range: 

 Users cannot move forward or backward in time beyond the filter Timeline definition. 

 If the Timescale or timeline is not defined, then the timeline cannot be moved forward or 
backward beyond the available curve schedule. 

 When the Timescale or timeline filter is applied, both the Graph and Table reflect the new 
timeline and Graph and Table columns only displays the date range that has been 
configured in the Filter. 

From Date

The date for the From Date must be equal to or earlier than the date for the To Date. If 
this condition is not present, Unifier displays an alert and reverts the value to a date 
selected during the previous entry, or displays a blank field. 

If the Cash Flow Timescale supports Month increments, then the selected Month in the 
From Date is the starting Month. 

If the Cash Flow Timescale supports Year increments, then the selected Year in the From 
Date is the starting Year. 

Note: The selected Day is never used. 

If users do not enter a date in the From Date field, then the worksheet starts the date 
based on the curve date. 

If users enter a date earlier than the curve date, then Unifier updates this error and starts 
the From Date based the curve date. 

To Date
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The date for the To Date must be equal to or later than the date for the From Date. If this 
condition is not present, Unifier displays an alert and reverts the incorrect date to a 
date selected during the previous entry, or displays a blank field. 

If the Cash Flow Timescale supports Month increments, then the selected Month in the 
To Date is the ending Month. 

If the Cash Flow Timescale supports Year increments, then the selected Year in the To 
Date is the ending Year. 

Note: The selected Day is never used. 

If users do not enter a date in the To Date field, then the worksheet starts the date based 
on the curve date. 

If users enter a date later than the curve date, then Unifier updates this error and ends 
the To Date based the curve date. 

Detail Level

There are two options available: Summary CBS and CBS. When applicable, the CBS option is 
selected as default. You can only select one option. 

Your project Cost Sheet determines which of the two options are enabled in this window. 

Note: Since the Cost Sheet at the Company and Program levels does not display CBS 
information: 

 If the cost sheet structure is Flat, then only CBS option is enabled. 

 If the Summary CBS and CBS are both enabled, then the condition is Tree. 

 If values have been added to the list of CBS codes in the Detail Level section, switching from 
one option to another will remove the existing values automatically.  

 If one of the options is checked and disabled, you cannot select that option. 

The Add button in the Detail Level section enables users to: 

 Filter worksheet data by adding information related to Summary CBS or CBS. 

 Open an existing Summary CBS or CBS code picker window and to the Detail Level list. You 
can open and add more than one saved curve. 

Note: The Program and Company level Filter window contains the "Curve Types" section 
(similar to the Detail Curve), but the Program and Company level Filter window does not have 
the Timescale, Detail Level, and Save" options. 

Users can only add Summary CBS or CBS codes that are available on the Project Cost Sheet. 
Also: 

 At least one value must be added the list to enable Detail Level filtering. 

 Curves that may be filtered by the appropriate Detail Level can be filtered, only. See the 
following "Showing Detailed CBS Codes in Summary Curves and Curve Combinations" 
section for a list of possible combination of curves that support Summary CBS or CBS 
curves. 

 Values that match the Filter criteria appear in the worksheet (Graph and Table), only. 

 Only Summary CBS or CBS codes that are included in the Detail Level filter appear in Curve 
Type detail window. 
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The Remove button in the Detail Level section enables users to remove an existing Summary 
CBS or CBS code that was added. 

Note: The Program and Company level Filter window contains the "Curve Types" section 
(similar to the Detail Curve), but the Program and Company level Filter window does not have 
the Timescale, Detail Level, and Save" options. 

Save As

The Filter window enables users to save the filter through the Save As field. The saved filters are 
available in a global collection and can be accessed by users at anytime. 

Notes:  

 The Save button remains disabled until you enter a name. 

 If a name has already been used for a filter, using the same name for a new filter generates 
an alert notifying the user that the name already exists. You cannot override an existing Filter 
unless you modify the existing Filter, without changing the name. 

 Click OK or Save to apply the filter and close the window. Saved filters appear in the Filter 
drop-down list. 

To manage and access saved filters click Edit from the menu and select Manage Filters. The 
Manage Filters window opens and enables you to: 

 Open or remove saved filters. 

 Change name and description of a filter. 

OK and Cancel

 OK: Use this option to confirm changes. 

 Cancel: Use this option to cancel changes in the form and exit the Filter window. 

Filter for Detail Curve 

The Detail Curve Cash Flow WorSheet contains the Graph and the Table sections. 

On the Detail Curve Table section, the following options are available: 

 Zoom: To set the zoom level for the Graph 

 Reset: To reset the zoom level and all applied filters (enable all curve types) 

 Y (icon): To view the Summary Curve by year (Y). 

 Print: To print the Summary Curve. 

When a Detail Curve Cash Flow WorkSheet is open, users can access the Filter menu options 
through: 

 Filter icon 

 View > Filter 

 Edit > Manage Filters 

The Filter icon and the View > Filter options are available for both Detail Curve and Summary 
Curves. These options are not available (disabled) if the Cash Flow WorkSheet does not contain 
any Curve Types.  
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The Filter menu option of the Detail Curves enables users to open the Filter window and select 
the Curve Types, set the Timescale, and determine the Detail Level. The saved filters are 
available in a global collection (within the project) and can be accessed by users. 

Curve Types

This section lists all the curve types that are available for the Detail Curve WorkSheet. 

Selecting a curve from the Curve Types box in the Filter window enables users to filter both the 
Graph and the Table. 

The Filter menu option for Detail Curve is accessible through Project/Shell, Company, and 
Program. 

For Detail Curves, all curve types are selected and enabled. Curve types can be deselected or 
selected individually. 

Note: At least one curve type must be selected. 

OK and Cancel

 OK: Use this option to confirm changes. 

 Cancel: Use this option to cancel changes in the form and exit the Filter window. 

Showing Detailed CBS Codes in Summary Curves and Curve Combinations 

For Summary curves with all child curves at the CBS detail level, when creating a summary cash 
flow curve, if CBS details are available for all of the curves, summarized data is displayed at 
individual CBS levels in the details. However, if there is a curve in the selection that does not 
have CBS level details (for example, Project/Shell or Commitment levels), then summary details 
will display individual curve names. 

Data will always be in project currency. If child curves have the same transaction currency, then 
you have the option to show data in transaction currency, as well. 

Curve Combinations

This section describes what Detail level is shown when multiple Curves are summarized. The 
Detail level displays in Summary CBS or CBS when multiple Cash Flow Curves are of matching 
type. For Commitment Detail Type curves, the Detail type is defined at the individual curve level. 

All Data Source 

Commitment 

Cash Flow Granularity per Data 
Source 

Curves 
On 

Project/S
hell 

Summary 
CBS 

CBS 
Single 
Distributi
on 

Individual 
Records 

By Line 
Items of 
SOV 

All Data 
Source 

Project/S
hell 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

Summary 
CBS 

One Line 
per Detail 
Curve 

By 
Summary 
CBS 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 



Working with Unifier Managers

239

CBS 
One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

By CBS 
One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

By CBS 

Commit
ment 

Cash 
Flow 
Granular
ity per 
Data 
Source 

Single 
Distributi
on 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

Individual 
Records 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

By Line 
Items of 
SOV 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

By CBS 
One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

One Line 
per Detail 
Curve 

Creating Cash Flow Summary Curves 

You have two options for creating a Summary Curve: 

 Option one: Creating a Summary Curve using the Cash Flow log 

 Option two: Creating a Summary Curve using the Manage Summary Curves 

Note: By default, summary curves in the Summary tab are displayed in bold, checked, and 
cannot be unchecked. 

Option one: Creating a Summary Curve using the Cash Flow log

1) Open the project for which you want to create a Summary Curve. 

2) Click Cost Manager > Cash Flow to open the Cash Flow log window. 

3) From the Cash Flow log window select the cash flow curves that you want to include in the 
Summary Curve. 

4) Click Summary to open the Cash Flow WorkSheet window and see both the Graph and 
Table views. The View option in the Table pane enables you to toggle between incremental 
and cumulative Table views. 

Incremental curve: An incremental curve displays the cash flow for a certain period. 

Cumulative curve: A Cumulative curve displays the net of all cash flows over a period of time. 

Option two: Creating a Summary Curve using the Manage Summary Curves

You can create cash flow summary curves in the project Cash Flow log using Manage Summary 
Curves (see Manage Summary Curves (on page 240)).  

1) Open the project for which you want to create a Summary Curve. 

2) Click Cost Manager > Cash Flow to open the Cash Flow log window. 

3) Click the Summary drop-down list (the down arrow) and select Manage Summary Curve to 
open the Manage Summary Curves window. 

4) Form the Detail Curves pane, select as many detail curves as you need and click New to 
open the Manage Summary Curves pane. 

5) Enter a name for your new Summary Curve in the field and click Add. The Detail Curves 
window opens. 
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6) From the Detail Curves window, click to select the cash flow curves that you want to include 
in the Summary Curve, and click Select. 

7) In Manage Summary Curves window, click Save and close the window. 

The cash flow summary curves display in the Summary Curves tab. 

There are no additional permissions for summary curves; if you can see a cash flow curve, you 
can add it to a Summary Curve.  

After you save a Summary Curve, the users with View permission can see your summary curve. 

Opening an existing Summary Curves Cash Flow Window 

To open an existing Summary Curves Cash Flow window: 

1) Open the project or shell where the summary curve exists. 

2) Click Cost Manager > Cash Flow. The Cash Flow log opens. 

3) On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select any 
previously created summary curves listed below Manage Summary Curves. 

 Clicking a listed summary curve opens the Cash Flow WorkSheet for that summary. 

 In the Cash Flow WorkSheet, in the Curves detail window you can open a data source to 
see its source cash flows.  

 Data in this mode is read-only; however, you can edit the data in the source cash flow 
Details window.  

4) Click the Close Window button when ready. 

Manage Summary Curves 

Note: The Manage Summary Curves menu item is not available to users who do not have Edit 
permission for cash flows. 

To create summary curve using the manage summary curves: 

1) Open the project for which you want to create a Summary Curve. 

2) Click Cost Manager > Cash Flow to open the Cash Flow log window. 

3) Click the Summary drop-down list (the down arrow) and select Manage Summary Curve to 
open the Manage Summary Curves window. 

4) Form the Detail Curves pane, select as many detail curves as you need and click New to 
open the Manage Summary Curves pane. 

5) Enter a name for your new Summary Curve in the field and click Add. The Detail Curves 
window opens. 

6) From the Detail Curves window, click to select the cash flow curves that you want to include 
in the Summary Curve, and click Select. 
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7) In Manage Summary Curves window, click Save and close the window. 

To manage summary curve content: 

1) Open the project or shell where you want to manage summary curve content. 

2) Click Cost Manager > Cash Flow. The Cash Flow log opens. 

3) On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select 
Manage Summary Curves.

4) In the Name column, select a summary curve. In the Detail Curves log you can see all 
source detail curves included in the summary. Add or remove data sources for a summary 
curve as needed. 

5) Click Save to retain changes to summary curves, and click Close Window when finished. 

To rename a summary curve: 

1) Open the project or shell where you want to rename a summary curve. 

2) Click Cost Manager>Cash Flow. The Cash Flow log opens. 

3) On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select 
Manage Summary Curves. 

4) Double-click the name of the curve to activate editing, and enter the new name. 

5) Click the Save button to save changes, and click the Close Window button when ready. 

To copy a summary curve: 

1) Open the project or shell where you want to rename a summary curve. 

2) Click Cost Manager > Cash Flow.. The Cash Flow log opens. 

3) On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select 
Manage Summary Curves. 

4) Select a summary curve from the list and click the Copy button. 

5) Enter a name for the copied curve. 

6) Click the Save button to save changes, and click the Close Window button when ready. 

To delete a summary curve: 

1) Open the project or shell where you want to delete a summary curve. 

2) Click Cost Manager > Cash Flow.. The Cash Flow log opens. 

3) On the Cash Flow log toolbar, click the Summary button drop-down arrow, and select 
Manage Summary Curves. 

4) Select a summary curve from the list and click the Delete button. 

5) Click the Save button to save changes, and click the Close Window button when read. 

Creating Cash Flow Curves (Standard View) 

You can create cash flow curves either manually or automatically. You can also use existing 
cash flow curve templates to facilitate the creation of cash flow curves.  

Cash flow curves require a data source, which your administrator can create in Standards & 
Libraries. For details refer to the Unifier Administration Guide. 
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There are multiple ways to create a cash flow curve (new, from a template, or copy). The 
following describes the basics of how to create a cash flow curve in Unifier. 

Note: You must have permission to access and configure cash flows. 

To create a cash flow detail curve: 

1) Open Unifier and go to your project or shell tab. 

2) Ensure that you are in User Mode. 

3) From the left Navigator click Cost Manager > Cash Flow. 

4) From the Cash Flow log select your project or shell. 

5) From the Cash Flow log toolbar click Create to open the New Cash Flow Worksheet. 

 Note: At this point, you can also select a cash flow template, if one is 
made available by your administrator. To select a template, click the 
down-arrow next to New and select a template.  

6) In the Name field, enter a name for the new cash flow curve. 

7) In the Description field, enter a brief description about the new cash flow curve. 

8) In the Detail Level field, select the desired detail level from the dropdown menu.  

 When Project / Shell is selected as the detail level, you can choose between two filtering 
options to determine the cash flow data displayed by the curves:  

1. Filter CBS codes (selected by default) 

2. Filter Summary CBS codes 

 A dropdown menu will appear based on your selections. 

 When Summary CBS is selected as the detail level, a Summary CBS Codes Filter dropdown 
menu will appear. CBS codes will be filtered based on your selections. 

 When CBS is selected as the detail level, a CBS Codes Filter dropdown menu will appear. 
CBS codes will be filtered based on your selections. 

 When a Commitment type Business Process is selected as the detail level, a Select Base 
Commit Record dropdown menu will appear.  

9. Under Rollup cashflow data to company/program, select Yes or No. 

10. Under Time Scale, select the desired Period Type from the Period Type dropdown menu.  

 When Standard Planning Period is selected, you will see two dropdown menus: 

1. By: Select Month or Year  

2. Format: Select the desired date format 

 When Financial Periods is selected, you will see a read only text box with the project 
financial period name. 

11. In the Curves pane, select the desired data source for the new cash flow detail curve from 
the Add Curve dropdown menu. Each curve that you add is based on a data source that your 
administrator has defined as is available in this list. 

 Note: Each data source can only be used once in a Cash Flow Work 
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Sheet. 

12. Based on your selected data source, a curve setup window opens. 

13. Review the information in the curve setup window. The Name and the Curve Type fields are 
auto-populated and cannot be changed. 

14. Click OK to go back to the New Cash Flow Worksheet. Notice that the curve is now listed in 
the Curves pane. 

You can select another curve from the Add Curve dropdown menu to create a curve based on a 
different data source.  

When finished, click Save & Close. 

Cash Flow Properties Worksheet Highlights (Standard View) 

The New Cash Flow Worksheet contains two panes: 

 General

Specify name, description, detail level, and timescale that will apply to all curves you create 
in the Curves pane.  

Specify Filter CBS codes or Filter Summary CBS codes (for hierarchical CBS structures only) 
that are included in the cash flow data. If no codes are specified, cash flow curves will reflect 
all CBS codes present on the project cost sheet. 

Select More Options to specify period close settings, add curves to summary curves, and 
specify decimal options.  

 Curves

Create the family of curves (Baseline, Forecast, Actual (or Spends), Portfolio Budget, 
Derived, and Custom curves) to be added to the Detail Curve Cash Flow WorkSheet. You 
can add multiple curves to the worksheet. Each curve must be associated with a data 
source, which is defined by an administrator. Curves are color-coded based on data source. 

The Properties descriptions below apply to Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves. The descriptions were written to familiarize you with 
available cash flow capabilities. 

For Cash Flow by Project/Shell Detail Level 

 Curves pane 

Distribute amount from cost sheet column field and From/To Dates. This is where you add 
the curves based on available data sources. 

 Baseline, Forecast, Portfolio Budget, Derived, and Custom curves 

If you want to automatically distribute a Cost amount from a cost column, the column must be 
selected in the Project/Shell. You can choose a curve for a Project/Shell template as long as 
you are creating a new Project/Shell from the template and are copying both the curve and 
the cost sheet. 

 Actuals (or Spends) curve 
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Because you must select a cost sheet column associated with Spends data in the 
Project/Shell, a Spends curve can only be created in a Project/Shell (or similar to the above, 
in a project/shell template). You will not be able to add a Spends curve in a company-level 
template. 

 Forecast curve 

If you define Forecast to start a the end of the Spends curve, the Forecast options use data 
from the Spends curve. Forecast options can only be set if a Spends curve is present. 

 Portfolio Budget curve 

The Portfolio Budget curve shows current project-row plan data from a Portfolio Sheet. When 
plan data changes, it becomes visible in the cash flow graph as a parallel curve so project 
managers can clearly see the variance between their projections and portfolio 
planner-initiated changes. 

 From Date and To Date

These fields can be set up to pull start and finish dates from the master schedule sheet in the 
project or shell. These can be selected in a project or shell template. At runtime, be sure the 
master schedule sheet is set up and has dates in the date element fields chosen for the 
curves. 

Note: In manual mode, Unifier pegs cost data distribution to the From 
Date. If there are date changes, Unifier shifts the curve on the timeline 
based on From Date modifications. Each time period (month or year) on 
the curve retains the value of the original distribution as long as the 
duration remains the same. If date changes make the cash flow curve 
duration longer or shorter, Unifier will not re-balance or redistribute cost 
data to match the modified curve length (the data will change.) 

For Cash Flow by CBS Detail Level 

Curves pane 

Use dates from Schedule Sheet field - Effective for the baseline curve only, you can view cost 
distribution information by CBS code in a schedule sheet. 

The properties window for each curve type displays these settings: 

 Distribute amount from cost sheet column field and From/To Date fields. This is similar to 
Cash Flow by Project/Shell Detail Level above. 

 Auto by default profile by CBS field. 

For Baseline, Forecast and Custom curves, you cannot select "Auto by default profile by CBS" in 
a company template, but you can in the project/shell, since this setting relies on the CBS codes 
used in the project or shell. You can choose it for a project/shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 
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Note: You won't be able to double-click the CBS Summary to view the 
CBS details. 

For Cash Flow by Summary CBS Detail Level 

Curves pane 

Distribute amount from cost sheet column field and From/To Date fields. This is similar to Cash 
Flow by CBS Detail Level above. 

Curves pane 

Auto by default profile by Summary CBS field. Similar to CBS detail level, for Baseline, Forecast 
and Custom curves, you cannot select "Auto by default profile by Summary CBS" in a company 
template, but you can in the Project/Shell, and a Project/Shell template as long as you are 
creating a new project or shell from the template and are copying both the curve and the cost 
sheet. 

For Cash Flow by Commitment Detail Level 

General pane 

 Business Process and Base Commit Record fields. 

 For a Commitment detail level, you must select the base commit type business process to 
use. Be sure that you selected business processes that are being used in the Project/Shell. 

 In the Base Commit Record field, you must select the record at runtime. This is not 
selectable in the template, since records do not exist in templates. The list displays all 
records you have permission to view. If a detail curve already exists for that record, you will 
not be able to choose the same record again. 

 Curves tab, Include Change Commits and Spends Business Process. 

If you chose these options, ensure that you have selected Change Commits that are being used 
in the Project/Shell, and are associated with the selected Base Commit. 

Note: If the cash flow is attached to a Portfolio Manager scenario, the 
planner-modified baseline curve appears adjacent to the original 
baseline in the Cash Flow WorkSheet. This lets the project Manager 
easily spot the difference between the initial projection and the planned 
suggestion. 

Distribution Profiles (Standard View) 

When working with templates versus detail curves in Project /Shell, distribution profiles can be:  

 Created in Administration Mode (in Standards & Libraries).  

 Used when selecting auto distribution for curves. 

At runtime, you can create additional distribution profiles within the project's cash flow module. 
When working with curves, you can apply the profiles created in Administration Mode, or in the 
project or shell. 
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Note: If you are creating a new Project /Shell from a Project /Shell 
template, and are copying the cash flow module, then template 
properties and permissions will be copied into the new project or shell. 

Cash Flow Properties Worksheet General Pane (Standard View) 

The General pane of the cash flow Properties window is where you define shared 
characteristics for this family of curves. For example, all of the curves added here will share the 
same Time Scale, Detail Level, and Period close settings. 

To create a cash flow details curve and complete the Properties General pane: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window. The Cash Flow log is the starting place for cash flow operations. 
The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users. To create a new cash flow, click the Create drop-down list and select Manual. 
The New Cash Flow Worksheet window opens. 

Note: If you have a cash flow template that you want to use, click the 
Create drop-down list and select From Template to open the Template 
Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties worksheet. 

5) Complete the fields in the General pane using the information in the following table and 
when finished click Save & Close. 

After the General pane is complete, you can save as is, or continue by adding the curves that 
will make up the detail curve. See Cash Flow Properties Worksheet: Curves pane (Standard 
View). 

In this 
Field: 

Do this: 

Name Enter a unique name for the curve in the Name field. 

Description (Optional) Enter a brief description in the Description field. 

Detail Level

Select a detail level option from the Detail Level box. The selected option 
determines the level-of-data the cash flow curves will display. Choose 
one: 

Project/Shell: Choose this to track cash flow for the entire project or shell. 
For example, Baseline and Actuals curves might chart the budget and 
cash outlay across the entire project. 

Summary CBS: Choose this option to track cash flow by summary CBS 
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In this 
Field: 

Do this: 

codes.  

Note: In order to select this option, the cost sheet used in the 
Project/Shell must be a tree structure. 

CBS: Choose this to track cash flow within a Project/Shell at the CBS 
code level. This allows you to track cash flow across the project for 
specific CBS codes, or for all CBS codes. 

Commitment: Choose this option to track cash flow associated with a 
particular commitment record and its line items. This includes, for 
example, a base contract and optionally their referenced change commits. 
This selection activates the following fields: 

Business Process: Click the drop down menu and choose a business 
process. Listed are the Project/Shell level business processes of type 
"Base Commit." When creating a template, choose the one that is likely to 
be used in the projects/shells the template will be used in. When creating 
the curve in a Project/Shell from the template, you may need to verify that 
the business process chosen here is active in the project or shell, or pick 
another from the list. 

Reference Elements: The worksheet will display the reference elements. 
By default, the Record Number will display as the number. You can click 
the drop down menu and choose an element to display as the Name 
(Record Number, Status or Title). 

Base Commit Record: This is selectable in a project or shell, but not in a 
template. Click the Select button. Choose the commitment record from the 
list of available records in the project or shell. Each commitment record 
can be selected only once. 

Note: You can set up the automatic creation of a cash flow curve when a 
base commit record is created and completed or reaches a particular 
step. This is done in the BP Setup for the business process. 

Filter CBS 
Codes 

Select Filter CBS Codes or Filter Summary CBS codes or neither 

Rollup 
cashflow 
data to 
company/pr
ogram? 

Yes: The curve will roll up to Program or Company cash flow the next time 
the curves are refreshed. 

No: The curve will not roll up to Program or Company cash flow the next 
time the curves are refreshed. 

Time Scale 

Select the Time Scale. The time scale determines the scale and format in 
which the data is shown on the Cash Flow WorkSheet. 

By Month or Year. The default is Month. 

Format: Choose the format that you want the month and year displayed 
on the graphs. The default is M YYYY. 
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Select More Options to specify period close settings, add curves to summary curves, and 
specify decimal options. Complete the fields in the More Options window using the information 
in the following table and when finished click Save. 

In this 
Field: 

Do this: 

Period 
Close 
Settings 

Define the Period Close Settings. The options allow you to choose some 
automatic settings that will happen at the end of each period (month or 
year, as chosen in the Time Scale field). 

When selected, the Enable auto snapshot option determines when an 
automatic snapshot will be taken of the data.  

If you selected Month for Time Scale: You can choose a specific date 
each month to automatically take a snapshot, or specify a particular day 
(such as the first Monday of the month).  

If you selected Year for Time Scale: You can specify the exact date to 
take the snapshot each year (or a particular day such as the first Monday 
of January). 

Note: After an auto-snapshot is taken, the curve will be refreshed 
immediately. Actuals (or "spends") will resume after the auto-snapshot is 
completed. 

Examples of using Enable auto snapshot on, Cutoff spends, and Resume 
Spends 

Company A wants to take an auto snapshot of its cash flow data every 
time period. Company A would choose a particular date (such as the 3rd 
of the month for Month, or January 3 for Year). Unifier would take the 
snapshot and refresh the cash flow curve. They do not select the Cut off 
spends option. 

Company B regularly reviews and revises forecast projections during fixed 
days every time period. Because it does not want new Spends records to 
hit the Cash Flow WorkSheet during this period, they choose the Cut off 
spends option. This option requires that Enable auto snapshot be 
selected first. The company sets this option so that an auto snapshot is 
taken of their changes just before spends are resumed. Snapshots can 
then be used for comparison of previous forecasts with the current month. 
Any spends records that came in during the forecast period are not lost; 
the Resume Spends option determines whether those spends records will 
be included in the previous month’s cash flow, or pushed to the next time 
period. 

Cutoff spends

This option is applicable for Actuals (or "spends") type curves. 

Selecting this option will temporarily stop spends business processes (for 
example, Invoices) from hitting the Cash Flow WorkSheet during analysis 
periods.  

Notes:  

 The Enable auto snapshot option must be selected first. Actuals (or 
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In this 
Field: 

Do this: 

"spends") will resume after the auto-snapshot is completed.  

 If no value is specified, then the last date of the current month is 
presumed. 

 Unifier marks the time of the Cutoff spends date at the beginning of 
the day. For example, on June 30, the data can become locked at the 
beginning of the day and not at the end of the day, therefore, 
preventing the user from making any last minute changes before the 
start of the next month. 

Period 
Close 
Settings 
(Continued)

Apply Spends to

The selections under this period close settings option allow you to apply 
spends to an effective date or before/after a Cutoff spends date. 

By default, Cutoff spends will resume immediately after an auto-snapshot 
is taken. 

Note: If there is a gap between the Cutoff spends date and the Enable 
auto snapshot date, any spends that came during that period are not lost. 

For example, if a Cutoff spends date is October 26 and the Enable auto 
snapshot on date is November 2, (and the Time Scale is monthly) that 
defines the freeze period. Any spends that come in on October 27, 28, 29, 
30, 31, and November 1 will not hit the cash flow sheet during the freeze 
period. After the Enable auto snapshot on date is reached, spends will be 
included back in October for spends (Oct 27-31) or November for spends 
(Nov 1-2), and the effective date will be honored. 

The same month/year as the effective date 

Note: The text of the options under Apply Spends to change based on the 
selection that you made for the Time Scale (By: Month or By: Year). 

If this option is chosen, once the freeze period is lifted, spends data is 
included back in the current period. The final output is similar to the case 
where no period close settings are applied since the effective date is 
honored. Spends for Oct 26-31 will be included in October and Nov. 1-2 
spends will be included for November. 

For example, if the cutoff date is the 26th of October and the snapshot 
date is the 2nd November, the freeze period is Oct 26 – Nov 2nd. Any 
spends that come in on Oct 27, 28, 29, 30, 31 and Nov. 1, and 2 will not 
show on the cash flow sheet during the freeze period. After the auto 
snapshot date is reached, these spends will be included back in either Oct 
for spends (Oct 27-31) or Nov for spends (Nov 1- 2) and the effective date 
will be honored. 

The next month/year if after the cutoff date 

Once the freeze period is lifted, spends data from the cutoff date to the 
end of the month will be included in the next month/year. Spends for Oct 
26-31 will be included in November and Nov. 1-2 spends will be included 
for November. 
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In this 
Field: 

Do this: 

The previous month/year if on or before the cutoff date 

Once the freeze period is lifted, spends data from the start of the month 
up to the cutoff date will be included in the previous month/year. Spends 
for Oct 26-31 will be included in September and Nov. 1-2 spends will be 
included for November. 

Note: During the Cutoff spends period, even if automatic refresh of the 
curve occurs as set in the Schedule tab, spends data will not hit the cash 
flow sheet until spends are resumed again. 

Summary Add curves to selected summary curves. 

Decimal 
Options 

Select the desired number of decimal places from the drop-down menu. 

Cash Flow Properties Worksheet Curves Pane (Standard View) 

In the Curves pane of the Cash Flow Properties worksheet, you can add the curves you would 
like to include in the Cash Flow WorkSheet.  

Based on the data sources that you have defined in Company Workspace > Administration 
Mode > Standards & Libraries > Cash Flow > Data Sources, you can create: 

 Baseline curve 

 Custom curve 

 Derived curve 

 Forecast curve 

 Portfolio Budget curve 

 Actual (Spends) curve 

Depending on the type, the curve setup options will differ. You can define one curve for every 
data source. 

Note: The Portfolio Budget curve is linked to scenarios in the Portfolio 
Manager. The project manager must create this curve. Once created, 
the curve shows the initial budget projections. 

When you open a curve, you can view the data in the transaction currency, if the transaction 
currency is different than the project currency. 

Baseline Curve (Standard View) 

You can construct cash flow curves by Project/Shell, Summary CBS codes, by CBS, or by a 
specific Commitment business process and record. The Baseline curve options reflect the detail 
level selections you made in the General pane.  
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This section explains the following topics: 

 To add a Baseline curve for cash flow by Project/Shell 

 To add a Baseline curve for cash flow by Summary CBS or CBS 

 To add a Baseline curve for cash flow by Commitment 

To add a Baseline curve for cash flow by Project/Shell: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users.  

To create a new cash flow, click the Create drop-down list (the down arrow) and select 
Manual. The New Cash Flow Worksheet opens.  

Note: If you have a cash flow template that you want to use, click the Create drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties worksheet. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Project/Shell under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of type 
Baseline. The Cash Flow by Project/Shell - Baseline window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you choose 
Manual in the Distribution drop-down list) 

You can enter cost information in the Total field on the worksheet. 

Distribute amount from cost sheet column 

This option will take the amount in the selected Cost Sheet 
column, and either allows you to distribute it manually (if you 
choose Manual distribution in the Distribution drop-down list), or 
use the default distribution profile (if you choose Auto by default 
profile in the Distribution drop-down list). An example column 
would be a budget. 
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In this Field: Do this: 

Schedule 

Define the range of dates to use to plot the cash flow data.  

If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 

Determine what dates to start the curve and end the curve. Choose 
one of the following options for each date: 

Manual

User enters the date directly in the Cash Flow WorkSheet. 

Data element from schedule sheet

Choose a schedule sheet data element from the list. The date will 
be populated automatically from the schedule sheet name (picker) 
when the cash flow curve is refreshed. 

If these dates are changed on the selected schedule sheet, then 
the changes will be reflected on cash flow after the next refresh of 
the curves. 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual

You enter values into each field manually. 

Auto by default profile

You can choose one of the available Distribution Profiles, that 
were defined in Standards & Libraries > Cash Flow > Distribution 
Profiles, or from those that were defined directly in the 
Project/Shell cash flow log (Edit > Distribution Profiles). This will 
be used as the default profile; however, at runtime, you can 
change which profile to use. 

Click Select to open the Select Distribution Profiles window. Select 
a distribution profile to use as the default profile for the curve. 

The default profile is used for the initial display and calculations in 
the Cash Flow WorkSheet. You can change the distribution profile 
from the worksheet. If you do this, the default profile will 
automatically update to reflect the current selection. 

Variance Choose Inflow or Outflow or neither. 

To add a Baseline curve for cash flow by Summary CBS or CBS: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 
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To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Summary CBS (for summary CBS codes) or CBS (for cash flow by 
individual CBS codes) under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of type 
Baseline. The Cash Flow by Summary CBS - Baseline or Cash Flow by CBS - Baseline 
window opens.. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Bring Baseline 
Data From 

General

Schedule Sheet

This option enables you to choose a schedule sheet and view the 
cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Baseline does not have 
this option. 

To use data from schedule sheet, follow these instructions: 

Select Use data from Schedule Sheet > Click Select to open 
the Schedule Sheets window > Select the desired schedule 
sheet > Click Open. The selected schedule sheet appears in 
the Use dates from Schedule Sheet field. 

P6 Summary Sheet

Note: The Cash Flow by Summary CBS – Baseline does not have this 
option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (grayed out) when Shell Schedule 
Type = Duration Based. 

If you select this option, Cost and Dates information data come 
from P6 Summary Sheet (spread) based on P6 Data Sources.  

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Planned. 

If you select At Completion, the system draws the Baseline 
curve using the At Completion Cost spread. 

If you select Planned, the system draws the Baseline curve 
using the Planned Cost spread. 

Activity Sheet
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In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you chose 
Manual above) 

You can enter cost information in the Total field on the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above) 

This option automatically distributes the amount in the Total field 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column, 
and either enables you to distribute it manually (if you chose 
Manual distribution), or it enables you to use the default distribution 
profile (if you chose Auto by default profile).  

An example column would be a budget. 

Schedule 

Here you define the range of dates to use to plot the cash flow data. 
Your options are: 

Use dates from Schedule Sheet

To take dates from the schedule sheet elements, the Master 
schedule sheet for the project/shell is used. 

Use dates from P6 Summary Sheet

The data picker lists all sheets from the ‘P6 Summary Sheets’ node 
under the Schedule Manager node. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Resource Loaded or Cost Loaded. 

If you select this option, the dates information data come from P6 
Summary Sheet (spread). 

Note: This option is available when the Distribution option is 
Manual, or Auto by default profile per CBS. 

A secondary drop-down list, Dates Type, contains the date types 
available: Planned and At Completion, with Planned as default 
selection. Using the Start and Finish dates of the selected dates 
type, the system draws the cash flow curve. 

If you select Planned, the system draws the Baseline curve 
using the Planned Start and Planned Finish dates of the 
selected Summary Sheet. 

If you select At Completion, the system draws the Baseline 
curve using the At Completion Start and At Completion Finish 
dates of the selected Summary Sheet. 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual

You enter values into each field manually. 

Auto by default profile per CBS (for CBS Detail Level curves) or Auto 
by default profile summary CBS (for Summary CBS Detail Level 
curves) 

You can specify a default profile per CBS code (or Summary CBS 
code) one CBS at a time or by selecting multiple CBS codes. See 
the following instructions for details. 

The initial distribution profile is default. You can change the 
distribution profile at runtime. 

Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

- Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

- Click to select a CBS > double-click the cell under the Default 
Profile column for that CBS > Click the desired distribution 
profile from the list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

- Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

- Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > 
Click Bulk Edit to open the Select Distribution Profiles 
(Distribution Profiles) window > Click the desired distribution 
profile from the list > Click Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window appears, 
ensure that the correct profiles have been selected and when 
finished, click Save. 

Variance Choose Inflow or Outflow or neither. 

To add a Baseline curve for cash flow by Commitment 

You can build one Baseline curve per Commitment record. When you build a Baseline curve for 
individual line items, the Schedule of Value (SOV) type influences distribution options.  

 If the SOV lists individual line items by CBS you can distribute cost for each line item 
individually. 
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 If the SOV groups line items, you cannot distribute cost for each line item individually.  

For costs distributed in the transaction currency, Unifier calculates and stores the distribution in 
project currency using the exchange rate table. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users.  

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Commitment under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of type 
Baseline. The Cash Flow Commitment - Baseline window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

In this Field: Do this: 

Cash Flow 
Granularity 

Note: The Cash Flow Granularity option that you select determines 
the Distribution Method options that are available. 

The Cash flow granularity options determine the level of record detail 
available in the cash flow curve.  

You can roll up base and change commits and see individual records 
separately, or you can drill to individual line items in a Commitment 
record. 

Single 
distribution of 
sum of base 
commit and all 
changes 

Note: Selecting this option limits the Distribution Method to Manual 
entry of values per cash flow period, only. 

In User Mode, you must open the Cash Flow Details window to 
complete time scale fields and distribute the rolled up values of the 
base commit record and any change commit records. 
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In this Field: Do this: 

By individual 
record (base 
commit and all 
changes 
separately) 

Selecting this option enables you to select the following options from 
the Distribution Method: 

Manual entry of values per cash flow period 

Use this option to manually enter the time scale and to distribute 
costs. 

Auto distribution 

Use this option to utilize a pre-defined distribution curve. In User 
Mode, the curve data is read-only, but you can change the 
distribution profile. This selection requires a sub-selection. 

Manual Dates and manual profile selection 

Use this option to manually enter the time scale and select a 
distribution curve. 

Business process dates and default profile selection 

Use this option to select the time scale from fields on the business 
process. Click Details to open the selection window. There are 
four columns in the Auto Distribution window. 

Business Process: List comes from the Cost-type business 
processes available in your company 

From Data Element: Select the date you want the distribution 
to start 

Note: You can only select a Date element from the Upper 
Forms and not from the Business Process Detail forms.  

To Data Element: Select the date you want the distribution to 
end 

Default Profile: If desired, select a pre-defined profile. 

By line items 
within each 
individual record

Selecting this option enables you to select the following options from 
the Distribution Method: 

Manual entry of values per cash flow period 

Use this option to select record line items. In User Mode you can: 

See each selected line item in the Cash Flow Details window; 
the columns come from the business process. 

Select a profile on the detail window for each line. 

Select the distribution profile manually. 

Auto distribution 

Use this option to manually enter dates and select a distribution 
profile. 
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In this Field: Do this: 

Distribution 
Method 

Note: The Cash Flow Granularity that you selected determines the 
Distribution Method options that are available.  

Read the following sections in this table for details: 

Single distribution of sum of base commit and all changes 

By individual record (base commit and all changes separately) 

By line items within each individual record 

Note: By default, Unifier displays Commitment curve cost data in the 
record transaction currency, which is stored in project currency (using 
the active currency exchange rate table). If the transaction currency 
is different from the project currency, you can change the currency 
view between transaction and project currencies, but you can only 
edit data in the transaction currency. If there is a more recent value in 
the exchange rate table, refreshing the curve will refresh the cost 
data. 

Commit Change 
Processes to be 
included 

Add Commit Change business processes according to the status. 

Note: These line items are also seen in the Cash Flow Curve Details 
window. 

Actuals (Spends) Curve (Standard View) 

The Actuals (or "spends") Curve tracks actual invoice transactions. It pulls the data from a 
column of the cost sheet. Choose a column associated with the data source for the Spends-type 
business process and status that you want to track.  

This section explains the following topics: 

 To add Actuals (or "spends") curve for cash flow by Project/Shell 

 To add Actuals (or "spends") curve for cash flow by Summary CBS or CBS 

 To add Actuals (or "spends") curve for cash flow by Commitment 

 About Actuals (Spends) Curve and Forecast Curve 
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Note:  For Base Commits, Change Commits, and Payment Application 
BPs of Summary Payment Application SOV type (the Cash Flow family 
curves for Actuals (or "spends") curve for cash flow by Commitment): 

 If the Effective Date (uuu_effective_date) field has been defined in the 
Detail Form design, then this date is used as the effective date for 
the Costed Line Items. 

 In the absence of the Effective Date (uuu_effective_date) field, the 
Workflow end date will be used for Cash Flow. 

 You can see the Costed Amount for the Cash Flow curves of Actual 
(Spends) type level CBS and Summary CBS. 

 You can see the Line Item amount for the Cash Flow curves of Actual 
(Spends) type level Project/Shell. 

To add Actuals (or "spends") curve for cash flow by Project/Shell 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users.  

To create a new cash flow, click the Create drop-down list (the down arrow) and select 
Manual. The New Cash Flow Worksheet opens.  

Note: If you have a cash flow template that you want to use, click the Create drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Project/Shell under Detail Level.  

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type Actuals. The Cash Flow by Project/Shell - Actuals window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Cost 

Select from cost sheet column

Choose a cost sheet column associated with the Spends-type 
business process and status. 

The Cost sheet column selection is only available when creating 
curves in a Project/Shell, not a template (since there is no cost 
sheet to reference).  

If you are creating a detail curve template, you will not be able to 
add a Spends curve. 

Variance Choose Inflow or Outflow or neither. 

To add Actuals (or "spends") curve for cash flow by Summary CBS or CBS 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left  Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash flow 
Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Summary CBS or CBS under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type Actuals. The Cash Flow by Summary CBS - Spends or Cash Flow by CBS - 
Spends window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Bring Actuals 
Data From 

General

TBD 

P6 Summary Sheet

Note: The Cash Flow by Summary CBS – Actuals does not have 
this option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Duration Based. 

If you select this option, the system draws the Spends curve using 
the Actual Cost spread from the selected P6 Data source. 

Activity Sheet

TBD 

Cost Select from cost sheet column

Choose a cost sheet column associated with the Spends-type 
business process and status. 

The Cost sheet column selection is only available when creating 
curves in a Project/Shell, not a template (since there is no cost 
sheet to reference).  

If you are creating a detail curve template, you will not be able to 
add a Spends curve. 

Variance Choose Inflow or Outflow or neither. 

To add Actuals (or "spends") curve for cash flow by Commitment 

Note: When you open this curve, you can view the data in two different 
currencies by switching between project and transaction currencies. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 
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4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Commitment under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type Actuals. The Cash Flow by Commitment - Spends window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

In this Field: Do this: 

Granularity Select By line items from Schedule of Values if you want to get cash 
flow individual line items from the Actuals (or "spends") record. 

Cost Select Spends Business Process

Click Add to choose the Spends Business Processes that you 
want to use. 

The Spends-type business processes and the related status that 
are associated with the Base Commit open in a window. Choose 
the business processes and statuses that you want to include in 
the curve and click Save.  

Variance Choose Inflow or Outflow or neither. 

About Actuals (Spends) Curve and Forecast Curve 

Unifier complies with the initial profile. If Actuals (or "spends") are received for a portion of the 
curve, and the Forecast curve is connected to Actuals (or "spends"), Unifier takes the 
already-consumed-profile portion out of the equation and redistributes the unconsumed pending 
profile portion.  

Examples 

 The Forecast curve starts from Jan 2012- Dec 2014, stretching Unifier's default 20 point 
distribution profile over 36 periods. 

 Actuals were received January 2012 February 2012, and March 2012. 

 These three periods of Forecast curve already consumed 1.67 points of period 
distribution. 

 The Forecast end date is now changed to December 2015. 

 The Forecast curve is now March 31 2012 to December 2015. 

 Unifier then distributes the remaining 18.33 points of profile over 45 periods. 

If there are some CBS codes that have received Actuals (or "spends") and some CBS codes 
that did not, then the CBS codes that did not receive Actuals (or "spends") will be replaced by 0 
at the end of the month, or on the cutoff date (depending on the UI settings). 

If there are some CBS codes that have received future Actuals (or "spends") and some CBS 
codes that did not, then the Forecast Curve will not reflect future Actuals (or "spends") until they 
become current. 

The following section explains the Forecast Curve. 
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Forecast Curve (Standard View) 

 This section explains the following topics:General Information about Forecast Curve  

 To add a Forecast Curve for cash flow by Project/Shell 

 To add a Forecast Curve for cash flow by Summary CBS or CBS 

 To add a Forecast Curve for cash flow by Commitment 

 Forecast Curve Behavior Test Cases 

To add a Forecast Curve for cash flow by Project/Shell 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. 

The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Project/Shell under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type  Forecast. The Cash Flow by Project/Shell - Forecast window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Cost 

Note: The distribution method that you select determines the Cost 
options that are available. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual distribution) 

You can enter cost information in the Total field on the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile distribution) 

This option distributes the amount in the Total field automatically, 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column 
and enables you to either: 

Distribute it manually (if you chose Manual distribution) 

or 

Use the default distribution profile (if you chose Auto by default 
profile distribution) 

For a forecast column, an example of a column choice would 
be a Spends-type business process and status. 

Schedule 

From Date 

To Date 

Select, or define, the range of dates to use to plot the cash flow data. 
If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one of the following options: 

Manual

To enter values in each field manually. 

Note: Selecting the Manual distribution option enables you to 
select the following two Cost options, only: 

Manually enter amounts for each period 

Distribute amount from cost sheet column 

Auto by default profile

To select one of the available profiles from the Distribution 
Profiles. 

You can choose one of the available Distribution Profiles, that 
were defined in Standards & Libraries > Cash Flow > Distribution 
Profiles, or from those that were defined directly in the 
Project/Shell cash flow log (Edit > Distribution Profiles).  

The selected profile will be used as the default profile; however, at 
runtime, you can change which profile to use. 

Select Auto by default profile > Click Select. The Select 
Distribution Profiles (Distribution Profiles) window opens. 

Select a profile to use for the curve, as default profile, and click 
Select. 

Note: If the initial Forecast uses a distribution profile, and has a 
configuration start at the end of Actuals (or "spends"), the profile 
does not impact Forecast distribution when you receive Actuals (or 
"spends"). 

Variance Choose Inflow or Outflow or neither. 
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In this Field: Do this: 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down list 
and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends 
are available only if you have chosen: 

Auto by default profile for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated or 
underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods 

Enter the number of time periods. 

using weighted average over next _____ period(s) 

Enter the number of time periods, 1 or more, not to exceed the 
number of periods remaining. 

To add a Forecast Curve for cash flow by Summary CBS or CBS  

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 
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3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations.  

The log displays all existing cash flow curves and also provides options for creating new 
curves, copying curves, viewing curve properties, and assigning curve usage privileges to 
other users.  

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Select a cash flow from the Cash Flow log window and click Properties to open the cash 
flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Summary CBS or CBS under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type  Forecast. The Cash Flow by Summary CBS - Forecast or Cash Flow by 
CBS - Forecast window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

In this Field: 
Do this: 
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In this Field: 
Do this: 

Bring Forecast 
Data From 

Use data from Schedule Sheet

This option enables you to choose a schedule sheet and view the 
cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Forecast does not have 
this option. 

To use data from schedule sheet, follow these instructions: 

Select Use data from Schedule Sheet > Click Select to open 
the Schedule Sheets window > Select the desired schedule 
sheet > Click Open. The selected schedule sheet appears in 
the Use dates from Schedule Sheet field. 

Use Data from P6 Source

Note: The Cash Flow by Summary CBS – Forecast does not have 
this option. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when Shell Schedule 
Type = Duration Based. 

If you select this option, Cost and Dates information data come 
from P6 Summary Sheet (spread) based on P6 Data Sources. 

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Remaining. 

If you select At Completion, the system draws the Forecast 
curve using the At Completion Cost spread. 

If you select Remaining, the system draws the Forecast curve 
using the Remaining Cost spread. 
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In this Field: 
Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. Choose one of the following 
options: 

Manually enter amounts for each period (available if you chose 
Manual above) 

You can enter cost information in the Total field on the worksheet.

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above) 

This option automatically distributes the amount in the Total field 
using the selected default profile. 

Distribute amount from cost sheet column 

This option takes the amount in the selected Cost Sheet column, 
and either enables you to distribute it manually (if you chose 
Manual distribution), or it enables you to use the default 
distribution profile (if you chose Auto by default profile).  

An example column would be a budget. 

Schedule 

From Date 

To Date 

Select, or define, the range of dates to use to plot the cash flow data. 

If you choose to take dates from the schedule sheet elements, the 
schedule sheet name (picker) for the Forecast is used. 

Use dates from P6 Source

Note: This option is available for CBS, only. 

The data picker lists all the P6 Data sources under the Standards 
& Libraries node (User mode > Company Workspace > P6 Data 
Sources. 

Note: This option is unavailable (greyed out) when Shell 
Schedule Type = Cost or Resource Based 

If you select this option, the Dates information data come from P6 
Summary Sheet (spread) based on P6 Data Sources.  

A secondary drop-down list, Data Type, contains the data types 
available: At Completion and Remaining. 

If you select At Completion, the system draws the schedule from 
At Completion Start and At Completion Finish. 

If you select Remaining, the system draws the schedule from 
Remaining Start and Remaining Finish. 
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In this Field: 
Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one of the following options: 

Manual

To enter values in each field manually. 

Note: Selecting the Manual distribution option enables you to 
select the following two Cost options, only: 

Manually enter amounts for each period 

Distribute amount from cost sheet column 

Auto by default profile per CBS

To select one of the available profiles from the Distribution 
Profiles. Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > double-click the cell under the Default 
Profile column for that CBS > Click the desired distribution 
profile from the list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > 
Click Bulk Edit to open the Select Distribution Profiles 
(Distribution Profiles) window > Click the desired distribution 
profile from the list > Click Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window 
appears, ensure that the correct profiles have been selected 
and when finished, click Save.  

Variance Choose Inflow or Outflow or neither. 
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In this Field: 
Do this: 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down 
list and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends are 
available only if you have chosen: 

Auto by default profile per CBS for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated or 
underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods 

Enter the number of time periods. 

Using weighted average over next _____ period(s) 

Enter the number of time periods, 1 or more, not to exceed the 
number of periods remaining. 
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In this Field: 
Do this: 

Forecast 
Options 
(continued) 

Use dates from P6 Summary Sheet

The data picker lists all sheets from the ‘P6 Summary Sheets’ 
node under the Schedule Manager node. 

Note: This option is unavailable (greyed out) when shell Schedule 
Type = Resource Loaded or Cost Loaded. 

If you select this option, the dates information data come from P6 
Summary Sheet (spread). 

Note: This option is available when the Distribution option is 
Manual, or Auto by default profile per CBS. 

A secondary drop-down list, Dates Type, contains the date types 
available: At Completion and Remaining. Using the Start and 
Finish dates of the selected dates type, the system draws the 
cash flow curve. 

If you select At Completion, the system draws the Forecast 
curve using the At Completion Start and At Completion Finish 
dates of the selected Summary Sheet (spread). 

If you select Remaining, the system draws the Forecast curve 
using the Remaining Early Start and Remaining Early Finish 
dates of the selected Summary Sheet (spread). 

To add a Forecast Curve for cash flow by Commitment 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the left Navigator pane, click Cost Manager to expand and click Cash Flow to open 
the Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for 
cash flow operations. The log displays all existing cash flow curves and also provides 
options for creating new curves, copying curves, viewing curve properties, and assigning 
curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Commitment under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type  Forecast. The Cash Flow by Commitment - Forecast window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Cash Flow 
Granularity 

Single 
distribution of 
sum of base 
commit and all 
changes 

Manual entry of values per cash flow period.  

Note: This is the only available option. If you select this option, you 
can only select the Manual entry of values per cash flow period option 
for Distribution Method. 

In User Mode, you must open the Cash Flow Details window to 
complete time scale fields and distribute the rolled up values of the 
base commit record and any change commit records. 

Cash Flow 
Granularity 

By individual 
record (base 
commit and all 
changes 
separately) 

Use with:  

Manual entry of values per cash flow period option under Distribution 
Method 

Auto distribution option under Distribution Method 

Either with the Manual dates and manual profile selection option, 
or the Business process dates and default profile selection option.

Selecting the Manual entry of values per cash flow period option 
under Distribution Method enables you to manually enter the time 
scale and to distribute costs. 

Selecting the Auto distribution option under Distribution Method 
enables you to utilize a pre-defined distribution curve. In User 
Mode curve data is read-only, but you can change the distribution 
profile. 

Selecting the Auto distribution option under Distribution Method 
requires selecting one the following sub-selection: 

Manual Dates and manual selection of profile: Use this option 
to manually enter the time scale and select a distribution 
curve. 

Business process dates and default profile selection: Use this 
option to select the time scale from fields on the business 
process. Click Details to open the selection window. There are 
four columns in the Auto Distribution window and you can 
select one of the following option: 

Business Process 

List comes from the Cost-type business processes available in 
your company. 

From Data Element 

Select the date you want the distribution to start. 

To Data Element 

Select the date you want the distribution to end. 

Default Profile 

If desired, select a pre-defined profile. 
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In this Field: Do this: 

Cash Flow 
Granularity 

By line items 
from Schedule 
of Values 

Use with:  

Manual entry of values per cash flow period option under Distribution 
Method.  

Manual entry with auto distribution of unassigned amount option 
under Distribution Method. 

Auto distribution option under Distribution Method. 

Manual dates and manual profile selection option, only. 

Selecting the Manual entry of values per cash flow period option 
under Distribution Method enables you to select record line items. 
In User Mode you can: 

See each selected line item in the cash flow Details window; 
the columns come from the business process. 

Select a profile on the detail window for each line. 

Select the distribution profile manually. 

Selecting the Manual entry with auto distribution of unassigned 
amount option under Distribution Method enables you to 
auto-distribute the total cost.  

You must select a Default profile for new records. Initially the 
curve uses auto-distribution based on both the dates you entered 
in the Forecast details window and the default profile you selected 
for the distribution method. Once you modify data-period dates: 

If the Unassigned amount is not equal to zero, you must 
manually enter dates and manually adjust the Unassigned 
amount. 

If the Unassigned amount equals zero, the Cash flow by 
Commitment - Forecast curve uses a weighted average to 
redistribute the Unassigned amount. 

Selecting the Auto distribution option under Distribution Method 
automatically selects the Manual Dates and manual selection of 
profile option and enables you to manually enter dates and select 
a distribution profile. In the Cash Flow Details window, Unifier 
populates column values from the Business Process Schedule of 
Values (SOV).  

Distribution 
Method 

See Cash Flow Granularity in this table for details. 

Commit Change 
Processes to be 
included 

Add Commit Change business processes according to the status. 

Note: These line items are also seen in the Cash Flow Curve Details 
window. 

Variance Choose Inflow or Outflow or neither. 
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In this Field: Do this: 

Forecast 
Options 

Choose one of the following options: 

Begin calculations at end of curve 

Select this option if you want to automatically start the forecast at 
the end of a selected spends curve for each time period. 

Select Begin calculations at end of curve > Click the drop-down 
list and select your desired option. For example, you can select 
Actuals (or "spends") curve if this curve exists. 

Replace current period forecast with Actuals on cut off date 

If you select this option, and the period close settings have not 
been specified, then Unifier replaces the Forecast Curve with 
Actuals (or "spends") Curve on the end of the month curve. 

Note: The cumulative graph will not show the forecast connected 
to Actuals until Unifier overwrites the Forecast with Actuals. 

Allow edit of current period forecast until replacement by Actuals 

This option enables you to reconfigure the forecast until the date 
set to replace the forecasted values with Actuals (or "spends"). 

Note: If the cutoff date is not specified, but the Replace current 
period forecast with Actuals on cut off date and Allow edit of 
current period forecast until replacement by Actuals checkboxes 
are marked, then Unifier does not allow edits to the Forecast 
Curve after the end of the month curve. 

The options under Distribute unassigned amounts from Spends 
are available only if you have chosen: 

Auto by default profile per CBS for Distribution 

Begin calculations at end of curve for Forecast Options 

The following options, under Distribute unassigned amounts from 
Spends enable you to automatically distribute any overestimated 
or underestimated Actuals (or "spends") amounts from the original 
forecast.  

using weighted average over all remaining periods: Enter the 
number of time periods. 

using weighted average over next _____ period(s): Enter the 
number of time periods, 1 or more, not to exceed the number 
of periods remaining. 

Forecast Curve Behavior Test Cases 
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Cases Condition Time Manual 
Distribution 

Auto 
Distribution 

Forecast Curve NA NA Manual 

Schedule 
(Dates) 

Schedule Sheet

Auto 

Schedule 
(Dates) 

Schedule Sheet

Set in the past Forecast with 
Actuals (no 
Actuals data) 

Start Date No change Moves to 
current 

Set in the past Forecast with 
Actuals (no 
Actuals data) 

End Date No change Future: No 
change 

Past: Moves to 
current 

Set in the past Forecast with 
Actuals (with 
Actuals data) 

Start Date Moves to 
current 

Moves to 
current 

Set in the past Forecast with 
Actuals (with 
Actuals data) 

End Date Future: No 
change 

Past: Moves to 
current 

Future: No 
change 

Past: Moves to 
current 

Set in the future Forecast with 
Actuals (no 
Actuals data) 

Start Date No change No change 

Set in the future Forecast with 
Actuals (no 
Actuals data) 

End Date No change No change 

Set in the future Forecast with 
Actuals (with 
Actuals data) 

Start Date Moves to 
current 

Moves to 
current 

Set in the future Forecast with 
Actuals (with 
Actuals data) 

End Date No change No change 

Portfolio Budget Curve (Standard View) 

Unifier Portfolio Manager allows you to pull the Baseline, or Forecast, data from more than one 
Project/Shell into the following three Portfolio Budget curves: 

 Shared Budget curve 

 Approved Budget curve 
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 Original Budget curve 

For an explanation of these options see About Portfolio Manager Budget Curves. 

The General tab of the "Cash flow Portfolio Budget" window contains the following fields and 
sub-fields: 

 Name

 Type

 Cost

 Distribute amount from 

 Currency 

The following explains how to enter data in the "Cash flow Portfolio Budget" window fields and 
sub-fields in details. 

In the Distribute amount from field drop-down list (under Cost), you can select Original, 
Shared, or Approved, then click OK. The portfolio curve opens in the Properties window. 

Note: If the currency of data pulled from any of the three different 
Portfolio Budget curves (Unifier Portfolio Manager) is different from the 
Project/Shell currency, you can create a Derived curve (using the 
existing curves within a family) that converts data from existing curves to 
a different currency. 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

This section explains the following topics: 

 To add a Portfolio Budget Curve for cash flow by Project/Shell 

 To add a Portfolio Budget Curve for cash flow by CBS or Summary CBS 

 To add a Portfolio Budget Curve for cash flow by Commitment 

 To add a Portfolio Roll Up Curve for cash flow (by Program) 

 To view Portfolio Budget Curve for cash flow 

To add a Portfolio Budget Curve for cash flow by Project/Shell: 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 



Working with Unifier Managers

279

Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Project/Shell under Detail Level, and enter settings for Time Scale and 
Period Close Settings. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of portfolio budget type (Original Budget - Approved Budget - Shared Budget).. The 
Cash flow by Project/Shell - Portfolio window opens 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

Note: If you need additional curves, repeat steps 6 to 7. 

In this Field: Do this: 

Cost 
Select an option from the Distribute amount from field list.  

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

Variance Choose Inflow or Outflow or neither. 

To add a Portfolio Budget Curve for cash flow by CBS or Summary CBS: 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 
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Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Summary CBS or CBS under Detail Level, and enter settings for Time 
Scale and Period Close Settings. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of portfolio budget type (Original Budget - Approved Budget - Shared Budget). The 
Cash flow by Summary CBS - Portfolio Budget or Cash flow by CBS - Portfolio Budget 
window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

Note: If you need additional curves, repeat steps 6 to 7. 

In this Field: Do this: 

Cost 
Select an option from the Distribute amount from field list. 

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

Variance Choose Inflow or Outflow or neither. 

To add a Portfolio Budget Curve for cash flow by Commitment: 

You can add a Portfolio Curve for each cash flow detail level after you create portfolio budget 
data sources. See the following instructions. 

1) Open Unifier. 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). 

The Cash Flow log is the starting place for cash flow operations. The log displays all existing 
cash flow curves and also provides options for creating new curves, copying curves, viewing 
curve properties, and assigning curve usage privileges to other users. 

To create a new cash flow, click the New drop-down list (the down arrow) and select Detail 
Curves. The Properties window opens and displays the General tab as default. 
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Note: If you have a cash flow template that you want to use, click the 
New drop-down list (the down arrow) and select From Template to open 
the Template Log (Cash Flow Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Commitment under Detail Level, and enter settings for Time Scale and 
Period Close Settings. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of portfolio budget type (Original Budget - Approved Budget - Shared Budget).The 
Cash flow by Commitment - Portfolio Budget window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added.  

Note: If you need additional curves, repeat steps 6 to7. 

In this Field: Do this: 

Cost 
Select an option from the Distribute amount from field list. 

The choices are: Original - Shared - Approved 

Currency 
Select the currency of "Portfolio Budget" type curves within the Cash 
Flow family. See the topic "Currency" at the end of this section for 
more information. 

Variance Choose Inflow or Outflow or neither. 

Currency 

When you define a Portfolio Budget curve within any curve family type (CBS, Summary CBS, 
Commitment, and Project/Shell), you have the option to select the currency (Currency field 
under Cost) of the Portfolio Budget data source from the Portfolio Manager. 

The Currency field is a required field (default value: Project Currency) if you have Portfolio 
Budget curves. You can change the value of the Currency field to another value by opening the 
curve configuration window. 

Note: When you run a report, the value of Currency, in the report, is 
Project Currency unless you have selected another value. 

The Currency field lists all Active and future currencies from Exchange Rates (Company 
Workspace > Admin mode > Standards & Libraries > Exchange Rates). The Show Currency 
List window lists the available currencies that you can select. 
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Derived Curve (Standard View) 

The Cash Flow Data Sources of type = Derived is available to create Cash Flow curves within 
any family (CBS, Summary CBS, Commitment, and Project/Shell).  

When creating a new Cash Flow curve within any Cash Flow family: 

 Data Sources of type = Derived must be enabled only when there is at least one non-Derived 
(i.e., Baseline, Spends, Forecast, Portfolio Budget, or Custom) type curve exists in the 
family.  

 If there is no non-Derived type curve exists in the family, all Data Sources of type = Derived 
are grayed out. 

When the "Derived" type data sources are enabled, and the user clicks at such a data source, 
then a window is displayed that enables the user to enter the details for creating the new curve. 
The following explains the fields in the "Derived" type cash flow curve configuration window: 

Option Description Behavior 

Name Captures the name of the cash 
flow curve as defined in cash 
flow data sources in Company 
Workspace -> Admin Mode 

Same behavior as in existing cash flow 
curves- 

Type Captures the type of cash flow 
curve viz., Baseline, Custom, 
Forecast, Spends, Portfolio 
Budget, Derived. 

Same behavior as in existing cash flow 
curves- 

Base 
Curren
cy 

Captures the base currency for 
user to see and make 
exchange rate decisions. 

Behavior: Read-Only 

Displays the Base Currency as a read-only 
value 

Source 
Curve 

To select an existing curve 
which should be used as the 
basis of the ‘Derived’ curve.  

Behavior – Drop-down 

List all the non-Derived existing curves within 
the family in which the ‘Derived’ curve is being 
configured. Values are: <Curve Name> 
(<Type>), example: Shared (Portfolio 
Budget). 

Note: Derived curve cannot be a source curve 
to create another Derived curve. 

Required? (Not Null) – Required option. The 
user must select a value for this drop-down to 
complete the curve configuration.  

Derive
d 
Curve 
Curren
cy 

To select the currency that 
must be used to convert the 
‘Source Curve’ 

Behavior – Currency Selector  

User has the ability to select any currency 
from Company Workspace -> Standard & 
Libraries -> Exchange Rates (active and 
future) 

Required? (Not Null) – Required option. The 
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Option Description Behavior 

user must select a value for this selector to 
complete the curve configuration. 

Excha
nge 
Rate 

To define how the exchange 
rates must be used so that 
those can be applied to the 
source curve data. That is to 
say, should the exchange rate 
be picked up from as defined in 
Company Workspace -> 
Standards & Libraries, or 
should the rate be ‘Pegged’ to 
a value as chosen by user. 

Behavior: Radio button, two options: Float, 
Peg 

Default Value = Float 

When user selects the option ‘Float’, another 
drop-down option appears: ‘Use Rate as’ (see 
below) . 

Use 
Rate 
as 

To choose how to make use of 
exchange rate data from 
Company Workspace -> 
Standards & Libraries, 
especially if more than one rate 
is found for a given period 
(month / year) 

Behavior –Radio button 

Values: 

- At the beginning of the period 

- At the end of the period 

- A weighted average for the period 

Required? (Not Null) – Required option if 
‘Exchange rate’ = ‘Float’. 

If the user clicks ‘OK’ on the window without 
selecting this option, the following message 
appears: Invalid data entered in the following 
field(s): Input Required: Use rate as. 

If you choose the option ‘Exchange Rate’ = ‘Peg’, then Unifier provides another block titled ‘Peg 
Rate as’: 

 If Base Currency = Project Currency, then Peg Rate options should be available for 
conversion Base Currency -> Derived Curve Currency 

 If Base Currency ≠ (not equal) Project Currency and Project Properties list the conversion 
Base Currency -> Project Currency as ‘Peg’ option, then also behavior should be same as 
above, i.e., list options only for Base Currency -> Derived Curve Currency  

 If Base Currency ≠ (not equal) Project Currency but Project Properties list the conversion 
Base Currency -> Project Currency as ‘Float’ option, then peg rate options are available for 
both: 

 Base Currency -> Derived Curve currency 

 Base currency -> Project Currency 

The following explains the Derived’ curve ‘Peg’ Rate options: 

Option: 

Peg Rate options 

Description: 
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To define the value by which the exchange rate must be pegged. The user will have to enter a 
value manually, or point to an attribute on shell attribute form / single record BPs within the shell, 
or choose if they wish to use the pegged rate from shell properties. In latter case, Unifier will look 
into the value of the data element each time when rendering the curve. 

Behavior: 

Behavior  - Radio button 

Base Currency -> Derived Curve Currency: 

There should be helpful text informing user that conversion is for 1.0 Base Currency -> Derived 
Currency (text: 1.0 Base Currency =) This is be followed by three options:  

 Constant 

 Dynamic 

 Use Project Rate 

Default Radio Option: Constant 

If the user selects 'Constant', Unifier opens a field (DD = Decimal Amount). The decimal places 
appear when user types a digit after decimal point, only; otherwise, an integer value will appear. 
The field enables the user to enter an Integer or Decimal value. 

Default Radio Option: Dynamic 

If the user selects ‘Dynamic’, Unifier enables two drop-downs which will capture the Data Source 
for the multiplication factor: 

Drop-down 1: 

The shell attribute form of the current shell within which curve is being created. 

The shell attribute forms of all parent/grandparent shells of current shell in which curve is 
being created (i.e., attribute forms of all shells in hierarchy of current shell, up to the root) 

All single record BPs within the shell in which curve is being created. 

The above should be prefixed by identifiers ‘Shell Attribute Form / <Shell name>’, or ‘Single 
Record BPs / <BP name>. For example: 

Shell Attribute Form / All Properties 

Shell Attribute Form / Buildings 

Shell Attribute Form / Sites 

Single Record BPs / Project Information 

Single Record BPs / Important Contacts 

… 

Drop-down 2: 

Lists all linked and custom Data Elements from the selected source form whose Data 
Definition = Integer / Decimal Amount / Currency Amount. (No standard elements) 

Note: The user can change the location / hierarchy of a shell. So the above two drop-down 
values must be refreshed each time the curve is refreshed. 
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Note: If the user chooses the options ‘Constant’ / ‘Dynamic’, then the user must define a value 
(Constant integer/decimal or Dynamic data source). If not selected, the user will see a standard 
prompt after clicking ‘OK’: 

‘Invalid data entered in the following field(s): Input Required: ‘Constant’ or ‘Data Source’ 

The user can choose to use the third option: ‘Use Project Rate’ Selecting this option does not 
open up any additional field, but Unifier picks up the exchange rate as defined in project 
properties (described in Peg rate as ‘Use Project Rate’ section below). The user receive 
appropriate error message in either of following scenarios: 

 The user selects a ‘Derived Curve Currency’ which does not exist in Project Properties 
(Message: Selected currency is not defined in project.), or 

 The user selects a ‘Derived Curve Currency’ which is listed in Project Properties, but its 
conversion rate is set to ‘Float’ (Message: Selected currency does not have pegged rate 
within project.). 

Error should be presented when user clicks ‘OK’ on curve configuration window. 

Base Currency -> Project Currency 

The radio options are for user to select how to use the rate from Company Workspace -> 
Standards and Libraries (label: Use Rate as). 

The radio options are visible only if Base Currency ≠ Project Currency AND rate Base Currency 
-> Project Currency is set as ‘Float’ in project properties. 

Options same as when user chooses to ‘Float’ rate: 

User can choose to use the rate as: 

 At the beginning of the Period 

 At the end of the period 

 A weighted average for the period 

Default value: At the beginning of the period. 

Note: This block ‘Peg Rate options’ is displayed only if ‘Exchange Rate’ is selected as ‘Peg’. 

The following provides some scenarios. 

User selects the Peg Rate option for Base Currency -> Derived Curve Currency as = ‘Use 
Project Rate’, and the curve configuration is successful (i.e., ‘Derived Curve Currency’ is listed in 
Project Rate with a pegged conversion rate). 

The user then goes to Project Properties and changes the exchange rate for Base Currency -> 
Derived Curve Currency as ‘Float’, and reopens the cash flow. 

Since the curve has not been refreshed, the Cash Flow worksheet continues to show data as 
per previous value. 

If user opens the ‘Derived’ curve configuration window, the message, "Selected currency does 
not have pegged rate within project" appears. 

If user refreshes the curve, then cash flow worksheet shows all values as zero as the curve 
configuration is not longer valid. 
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If user opens the ‘Derived’ curve configuration window, the message, "Selected currency does 
not have pegged rate within project" appears. 

In case Base currency ≠ Project Currency 

User selects the Peg Rate option for Base Currency -> Derived Curve Currency as either of the 
three possible options, 

Base Currency -> Project Currency is set as ‘Peg’ in project properties. So there are no 
additional options to choose from, the curve configuration is successful  

Then user goes to Project Properties and changes the exchange rate for Base Currency -> 
Project Currency as ‘Float’ 

Then reopens the cash flow 

Since the curve has not been refreshed, the Cash Flow worksheet continues to show data as 
per previous value. 

If user opens the ‘Derived’ curve configuration window, the options for Base Currency -> Project 
currency appears, and the default value is selected as ‘At the beginning of the period’. 

If user refreshes the curve, then cash flow worksheet values are refreshed as per the options for 
Base Currency -> Project Currency. 

When user selects a currency to derive the curve, Unifier uses the data from source curve per 
period and convert it into the selected currency as per the float or peg exchange rate option as 
selected by user within curve definition: 

If user chooses the ‘Float’ option, Unifier uses the exchange rates as defined in Company 
Workspace -> Standards and Libraries -> Exchange Rates  

If the user chooses ‘Peg’ option, exchange rate values should be as per user selection in the 
block ‘Peg Rate as’ 

See following sections on how the derived curve should calculate its data per period… 

Note: The user can select the currency to be same as source curve currency. In that case, the 
derived curve would be same as source curve, exchange rates would not apply. 

Exchange Rate = Float (Rate at beginning of the period)

The user can select the Derived curve definition such that the exchange rate for currency 
conversion from source to destination is picked up from Company Workspace -> Standards and 
Libraries in such a way that the Rate from the beginning of the period is used. 

In other words, when doing the currency conversion, of all the available rates for a given period, 
Unifier selects the Rate closest to the beginning of the period. 

Note: If more than one rate is defined for the same day, Unifier picks the latest rate on that day. 
If no exchange rate is available for a past date, Unifier uses zero. 

Exchange Rate = Float (Rate at the end of the period)

The user can select the Derived curve definition such that if multiple exchange rates are 
available for a given period (month / year), Unifier uses the rate ‘At the end of the period’.  

In other words, when doing the currency conversion, of all the available rates for a given period, 
Unifier selects the Rate closest to the end of the period. 
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Exchange Rate = Float (A weighted average for the period)

If the user chooses to apply the exchange rate as a weighted of all values for a given period 
(Exchange Rate = ‘Use a weighted average for the period’), then the value will be based on the 
number of days in a given month. That is to say, the total of all "Rate * No. of days it is 
applicable during the period" divided by "Total number of days within the period~" (~Month / 
Year). 

When the Exchange Rate = ‘Float’, Oracle recommends that the user set a ‘Refresh’ frequency 
(Cost Manager > Cash Flow > Refresh drop-down > Set Frequency...), for the Derived curves, to 
cover the following scenarios: 

Scenario 1 

Future Exchange Rates from ‘Company Workspace -> Standards & Libraries’ can get 
changed with time. If ‘Derived’ cash flow curve is not set to automatic refresh, it will 
continue to hold values as per older exchange rate values (unless manually opened & 
refreshed) 

Scenario 2 

The ‘Source Curve’ might undergo a change in its configuration / values. If ‘Derived’ cash 
flow curve is not set to automatic refresh, it will continue to hold values as per older 
source curve data (unless manually opened & refreshed). 

Exchange Rate = Peg

This option means that the user does not want to use exchange rate as captured within 
Company Workspace -> Standards and Libraries -> Exchange Rates, but the user prefers to 
define the rate as one of the following: 

 Constant 

 Dynamic 

 Use Project Rate 

If Constant: 

To do the currency conversion (1.0 Base Currency = <constant value> Derived Curve 
currency), Unifier uses the constant value entered by the user. 

The source curve defaults to be in Project currency. If Base Currency ≠ Project Currency, 
Unifier picks the  exchange rate for Base Currency -> Project Currency from Project 
Properties and makes appropriate conversion to calculate the Derived curve in Derived 
Currency as selected by user. 

If Base Currency -> Project Currency in Project properties is set as ‘Float’, then unifier uses 
the option as selected by user for ‘Base Currency -> Project currency’ conversion. 

Unifier picks rates from Company workspace -> Standards and Libraries -> Exchange Rates 
by using one of the following options selected by user: 

 At the beginning of the period 

 At the end of the period 

 A weighted average for the period 

If Dynamic: 
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When rendering the curve, Unifier accesses the Data Element (DE) selected by the user and 
uses the value as the exchange rate to do conversion (1.0 Base Currency = <Selected DE 
value> Derived Curve currency). 

If the DE value is blank/null (in source shell attribute form/single record BP), then Unifier 
applies zero as the exchange rate. 

If Base Currency ≠ Project Currency, then Unifier does one of the following: 

 Unifier picks the exchange rate for Base Currency -> Project Currency from Project 
Properties 

 Unifier calculates the Derived curve (in Derived Currency) as selected by user. 

If Use Project Rate: 

The exchange rate is pegged as specified in the shell properties. 

If Base Currency ≠ Project Currency, then Unifier does one of the following: 

 Unifier picks exchange rate for Base Currency -> Project Currency from Project 
Properties 

 Unifier calculates the Derived curve (in Derived Currency) as selected by user. 

Note: For Commitment type curves, user can flip the view between Project and Transaction 
currencies. Unifier calculates for Source Curve data -> Derived Curve data by taking the 
source data in Project currency. 

When the Exchange Rate = ‘Peg’, Oracle recommends that the user set a ‘Refresh’ frequency 
(Cost Manager > Cash Flow > Refresh drop-down > Set Frequency...), for the Derived curves, to 
cover the following scenarios: 

Scenario 1 

Peg rates as defined in project properties might undergo a change. If ‘Derived’ cash flow 
curve is not set to automatic refresh, it will continue to hold values as per older 
pegged exchange rate values (unless manually opened & refreshed). 

Scenario 2 

The ‘Source Curve’ might undergo a change in its configuration / values. If ‘Derived’ cash 
flow curve is not set to automatic refresh, it will continue to hold values as per older 
source curve data (unless manually opened & refreshed). 

For all types of Cash flow families, the ‘Derived’ curve values are always displayed in its 
currency, as selected by user in curve configuration window. 

For Commitment type cash flow families, the user can choose to view the family curves in 
‘Project’ / ‘Transaction’ currency. 

In either case, the ‘Derived’ curve renders in the currency, as selected by user for the ‘Derived’ 
curve configuration window--irrespective of whether the rate is ‘Float’ or ‘Pegged’. 

The following explains special scenarios related to the exchange rate. 

Special Scenario 1 

The user selects a ‘Source Curve’ while configuring the ‘Derived’ curve 

Completes ‘Derived’ curve configuration and clicks ‘OK’ 

Removes the ‘Source Curve’ itself from the cash flow family definition. 
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In this scenario: 

When the user opens the curve worksheet, the derived curve will render all values as 
zero--irrespective of whether the cash flow family has been refreshed or not. 

When the user opens the curve configuration window, the ‘Source Curve’ drop-down 
continues to show original value. When the user clicks ‘OK’, the message, "Invalid curve 
configuration" is displayed. 

Special Scenario 2 

The user selects the ‘Exchange Rate’ as ‘Peg’ > Peg as ‘Dynamic’, and then chooses a data 
source DE from grandparent shell attributes. 

The user completes ‘Derived’ curve configuration and clicks 'OK'. 

The user changes the location of shell in which the curve was defined. 

In this scenario: 

If the new parent is the same type of shell (or another shell having the data Source DE on its 
attribute form), then this is not an error scenario. The curve renders by using the Rate value 
from new location. 

If, however, the new parent does not have the Data Source DE on its attribute form, then the 
curve configuration is invalid: 

When the user opens the curve worksheet, the Derived curve renders all values as zero.  

When the user opens the curve configuration window, the Data Source continues to show 
original value. When the user clicks ‘OK’, the message, "Invalid curve configuration" is 
displayed. 

Special Scenario 3 

The user selects a ‘Source Curve’ while configuring the ‘Derived’ curve,  

The user completes ‘Derived’ curve configuration and clicks 'OK'. 

The user removes the ‘Source Curve’ Datasource from company Workspace Cash Flow 
Datasources definitions. 

In this scenario: 

When the user opens the curve worksheet, the Derived curve (as well as the source curve) 
renders all values as zero--irrespective of whether the cash flow family has been refreshed 
or not. 

When the user opens the Derived curve configuration window, the ‘Source Curve’ drop-down 
shows original value, and when the user clicks ‘OK’, the message, "Invalid curve 
configuration" is displayed. 

Monthly actuals for Derived Forecast Curve  

If the checkbox is checked in the configuration then in the Portfolio Manager, then the user will 
be able to the see the monthly breakdown for actuals and the values seen would be read-only 
for months prior to the current month for the current year. The behavior and validation, which 
exist in support for monthly actuals for Forecast curve, is available for Derived forecast curve as 
well. 
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Actuals for Derived Actuals Curve 

If Derived Actuals curve is defined, then Unifier uses the Derived Actuals curve data, and the 
derived forecast data will be pushed from Cashflow to PPM. The derived actuals data links to the 
source actuals. In case of multiple derived curve for the same project with inconsistent settings 
(either different currency or settings such as float versus peg), a cumulative data value is 
displayed in the project currency, which is used by PPM, and the red triangle is displayed 
against that cell to depict the inconsistency. When the user hovers over, this warning message is 
displayed: {ppmname} Portfolio Manager received data from multiple actuals curves that have 
inconsistent settings. The correct value will be seen once the settings are corrected. 

Custom Curve (Standard View) 

You can create a Custom Curve when you want to create and compare curves in a Cash Flow 
WorkSheet, but you do not want to associate them with data sources of the other curve types 
(Baseline, Forecast, Actuals (or "spends"), Portfolio). 

Custom Curve setup is essentially the same as setting up Baseline Curves. 

The following instructions assume that you have created your data sources: 

 Go to: Company Workspace > Administration Mode > Standards & Libraries > Cash Flow > 
Data Sources 

 Click Data Sources > Click Open to open the Cash Flow Data Sources (Cashflow 
Datasources) window > Click Add to add new cash flow data source 

 Follow the prompts and click OK when finished 

This section explains the following topics: 

 To add a Custom Curve for cash flow by Project/Shell 

 To add a Custom Curve for cash flow by Summary CBS or CBS 

 To add a Custom Curve for cash flow by Commitment 

To add a Custom Curve for cash flow by Project/Shell 

1) Open Unifier 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General tab 
as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list 
(the down arrow) and select From Template to open the Template Log (Cash Flow 
Templates) window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 
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5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Project/Shell under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type  Custom. The Cash Flow by Project/Shell - Custom window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 

In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual above): You can enter cost information in the Total field on 
the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above): This will automatically distribute the 
amount in the Total field using the selected default profile. 

Distribute amount from cost sheet column: This option will take the 
amount in the selected Cost Sheet column, and either allows you to 
distribute it manually (if you chose Manual distribution), or use the 
default distribution profile (if you chose Auto by default profile). An 
example column would be a budget. 

Note: Cost column can be chosen when creating a curve in a project 
or shell, but not in templates. 

Schedule 

From Date  

To Date 

Define the range of dates to use to plot the cash flow data.  

If you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the Project/Shell is used. 

Determine what dates to start the curve and end the curve.  

Choose one of the following options for each date: 

Manual: User enters the date directly in the Cash Flow WorkSheet. 

Data element from schedule sheet: Choose a schedule sheet data 
element from the list. The date will be populated automatically from 
the Master schedule sheet when the cash flow curve is refreshed. 

If these dates are changed on the Master schedule sheet, then the 
changes will be reflected on cash flow after the next refresh of the 
curves. 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual: You enter values into each field manually. 

Auto by default profile: You can choose one of the available 
Distribution Profiles, that were defined in Standards & Libraries > 
Cash Flow > Distribution Profiles, or from those that were defined 
directly in the Project/Shell cash flow log (Edit > Distribution Profiles). 
This will be used as the default profile; however, at runtime, you can 
change which profile to use. 

Click the Select button. The Select Distribution Profiles window 
opens. Select a distribution profile to use as the default profile for the 
curve. 

The default profile is used for the initial display and calculations in the 
Cash Flow WorkSheet. You can change the distribution profile from 
the worksheet. If you do this, the default profile will automatically 
update to reflect the current selection. 

Variance Choose Inflow or Outflow or neither. 

To add a Custom Curve for cash flow by Summary CBS or CBS 

1) Open Unifier 

2) Click All Projects tab (or your project tab or the tab whose cash flow you want to work with). 

3) From the Navigator pane, click Cost Manager to expand and click Cash Flow to open the 
Cash Flow log window (right-hand pane). The Cash Flow log is the starting place for cash 
flow operations. The log displays all existing cash flow curves and also provides options for 
creating new curves, copying curves, viewing curve properties, and assigning curve usage 
privileges to other users. To create a new cash flow, click the New drop-down list (the down 
arrow) and select Detail Curves. The Properties window opens and displays the General tab 
as default. 

Note: If you have a cash flow template that you want to use, click the New drop-down list (the 
down arrow) and select From Template to open the Template Log (Cash Flow Templates) 
window. 

4) Click to select a cash flow from the Cash Flow log window and click Properties to open the 
cash flow Properties window. 

5) In the General pane, enter Name, enter Description (optional), select Active for Rollup 
Status, and select Summary CBS or CBS under Detail Level. 

6) In the Curves pane, click the Add Curve drop-down list and select the data source of data 
source of type  Custom. The Cash Flow by Summary CBS - Custom or Cash Flow by CBS 
- Custom window opens. 

7) Complete the fields in this window using the information in the following table. When finished 
click Save & Close to save work and open the Cash Flow Worksheet that you added. 
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In this Field: Do this: 

Cost 

You can choose the cost column when creating a curve in a 
Project/Shell but not in templates. 

Choose one of the following options: 

Manually enter amounts for each period (available if you chose 
Manual above): You can enter cost information in the Total field on 
the worksheet. 

Auto distribute total amount across all periods (available if you chose 
Auto by default profile above): This option automatically distributes 
the amount in the Total field using the selected default profile. 

Distribute amount from cost sheet column: This option takes the 
amount in the selected Cost Sheet column, and either enables you to 
distribute it manually (if you chose Manual distribution), or it enables 
you to use the default distribution profile (if you chose Auto by default 
profile).  

An example column would be a budget. 

Schedule 

From Date 

To Date 

Here you define the range of dates to use to plot the cash flow data. If 
you choose to take dates from the schedule sheet elements, the 
Master schedule sheet for the project/shell is used. 
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In this Field: Do this: 

Distribution 

Distribution spreads the amount value between cash flow time 
periods. Choose one: 

Manual: You enter values into each field manually. 

Auto by default profile per CBS (for CBS Detail Level curves) or Auto 
by default profile summary CBS (for Summary CBS Detail Level 
curves) 

You can specify a default profile per CBS code (or Summary CBS 
code) one CBS at a time or by selecting multiple CBS codes. See the 
following instructions for details. 

The initial distribution profile is default. You can change the 
distribution profile at runtime. 

Follow these instructions for CBS Detail Level curves: 

Note: You can use the same instructions for Summary CBS Detail 
Level curves 

To set default distribution profile for one CBS: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > double-click the cell under the Default Profile 
column for that CBS > Click the desired distribution profile from the 
list. 

Note: You can use Find to search for a specific CBS code. 

To set default distribution profile for multiple CBSs: 

Click Auto by default profile per CBS > Details to open the Edit 
Distribution Profiles (CBS Details) window. 

Click to select a CBS > Hold down the Ctrl or Shift key on your 
keyboard and then click each CBS that you want to select > Click 
Bulk Edit to open the Select Distribution Profiles (Distribution Profiles) 
window > Click the desired distribution profile from the list > Click 
Select. 

Note: You can use Find to search for specific CBS codes. 

When the Edit Distribution Profiles (CBS Details) window appears, 
ensure that the correct profiles have been selected and when 
finished, click Save. 
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In this Field: Do this: 

Distribution 
(continued) 

Use dates from Schedule Sheet: This option enables you to choose a 
schedule sheet and view the cost distribution information by CBS. 

Note: The Cash Flow by Summary CBS – Baseline does not have 
this option. 

To use dates from schedule sheet, follow these instructions: 

Select Use dates from Schedule Sheet > Click Select to open the 
Schedule Sheets window > Select the desired schedule sheet > Click 
Open. The selected schedule sheet appears in the Use dates from 
Schedule Sheet field. 

Note: If a schedule sheet is not selected, the distribution profile 
displays zeros along the bottom of a Cash Flow Curve graph. When 
you click OK in the details window, the filter will be applied against 
the CBS codes coming from the schedule sheet. 

Variance Choose Inflow or Outflow or neither. 

To add a Custom Curve for cash flow by Commitment 

Custom curves are not available for cash flow by commitment. 

Auto-create a Cash Flow Curve from a Base Commit Record 

As long as Cash Flow is set up in the project or shell you are working in, and you have 
permissions to both Cash Flow and to the commit business process record, you can create and 
view a commitment detail level cash flow worksheet directly from the business process record. 
There can only be one cash flow curve per record; that is, if you create the commitment curve 
through the record, the base commit cannot be referenced in a new cash flow curve. 

Auto-creation of a commitment cash flow curve works this way: 

 Auto-creation is enabled in the Business Process Workflow Setup for the project or shell. It is 
only available for base commit business processes and requires a Commitment detail level 
template. 

 For a workflow business process, the administrator can specify the step on which to 
auto-create a commitment cash flow curve. The curve is created upon reaching that step 
when a user accepts the task. 

 For a non-workflow business process, the administrator specifies the business process 
status that will trigger curve auto-creation from the commitment cash flow template specified 
in the business process setup. 

 Given the proper permissions, you will see the Cash Flow button on the business process 
record regardless of whether the auto-create feature has been enabled in the business 
process setup. This means that you have the option to create a commitment cash flow curve 
manually if the curve has not yet been auto-created. 
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 Creating the curve manually (by completing the curve properties, or by copying a 
project/shell level template) means Unifier will ignore an auto-create trigger when the record 
reaches the specified step or status. 

A few things to keep in mind: 

 If a detail curve already exists for the record, clicking the Cash Flow button will open the 
cash flow worksheet, which is view-only when opened from here. 

 If there are changes to the base commit record (such as additional or modified line item 
amounts), these changes will be reflected on the commitment cash flow curve the next time 
it is refreshed. 

 If the base commit record is terminated after the cash flow curve has been created, the curve 
will not be deleted. However, the next time the curve is refreshed, any data will be removed. 

To auto-create a Commitment detail level curve from a base commit business process 
record 

1) Open the base commit business process record. If cash flow is set up and you have 
permissions set, a Cash Flow button is available. 

2) Click the Cash Flow button on the business process toolbar.  

 If a cash flow Commitment detail level curve exists, the cash flow worksheet opens. 

 If at least one curve summary exists in your project, you can add this commitment 
curve to a summary curve listed on the Properties Summary tab. 

 From the View menu click  

 If the curve does not yet exist, you will be prompted to create a new curve. The Cash 
Flow by Commitment window opens. Choose one of the options: 

 Manual. This allows you to create a new curve manually. 

 From Template. This allows you to copy from a template. Click the Select button. 
The Templates log opens. Select a template to copy then click Select. 

3) Click OK on the Cash Flow by Commit window. The Properties window opens. 

4) Complete the Properties window and click OK. The cash flow worksheet will open to display 
the data. The curve will be saved in the Cash Flow log. 

To open a cash flow worksheet from a base commit record 

1) Open the base commit business process record. If cash flow is set up and you have 
permissions set, a Cash Flow button is available. 

2) Click the Cash Flow button on the toolbar. 

 If a cash flow Commitment detail level curve exists, a view-only cash flow worksheet 
opens. 

 If the curve does not exist, you will be prompted to create a new curve manually or by 
copying a template. 
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Create a Cash Flow Curve from a Schedule Sheet 

You can cost-load a schedule sheet by assigning roles and resources to project-related 
activities. When you associate a CBS code with an activity in the schedule sheet, Unifier can 
distribute its cost over a period of time based on activity dates and the calendar. You will be able 
to view this distributed cost along with other cash flow curves related to the project. 

In the baseline curve you can view the cost distribution information by CBS code in a schedule 
sheet. When defining the cash flow curves, you select the schedule sheet so you can view the 
curve in the cash flow worksheet. 

To set the cash flow curve for a schedule sheet 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Click New > Detail Curves. The Properties window opens. 

3) Enter your settings into the General tab. Detail Level selections can be Project/Shell, or 
CBS. 

4) Click the Curves tab and Click Add to add a curve type. Example: Baseline 

5) Determine the Distribution and Cost options. 

6) Under Schedule option, click to select Use dates from Schedule Sheet, click Select, and 
select the appropriate schedule sheet. 

Notes:  

 Selecting "Use dates from Schedule Sheet" option allows you to 
access the individual Schedule Sheet. 

 The CBS (or Summary CBS) code shows the dates of the actual CBS 
(or Summary CBS) related activities. 

7) Select values for the From Date and To Date fields. 

8) Click OK. The cash flow worksheet displays the cash flow worksheet with the CBS codes 
from the Schedule sheet in the details level. 

In the detail window, the following information for the cash flow baseline type of curve will be 
pulled from the schedule sheet: 

Field Definition 

Number CBS Codes taken from the Schedule Sheet 

Name Name of the CBS code 

From Date 
Taken from the "from" date of the activity that the CBS code is 
assigned to. 

To Date 
Taken from the "to" date of the activity that the CBS code is 
assigned to. 

Profile 
This field is blank as the distribution is coming from the schedule 
sheet. 
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Notes:

 You can open the details sheet and view the distribution of the costs 
by individual CBS code. Data in the details sheet is read-only. 

 It is possible for a user to create another baseline curve by selecting 
Cost Sheet as the source for cost or create a Forecast, Spends, and 
Custom curve. In all these cases, the list of CBS codes will be from 
the cost sheet and will not be filtered by the schedule sheet. 

 Cash Flow will pull distribution data (Linear, S-Curve, On Start and 
Finish) from a schedule sheet. 

Create a Cash Flow Curve from a Template 

You can pre-set curve options, except, for example, actual business process records, and cost 
sheet columns, which are set at run time. There are two types of cash flow templates: 
company-level templates, which are created in Administration Mode, and project or 
shell-level templates, which are created in a project or shell. 

When creating new curves from templates, only curve properties are copied; data and 
permissions are not copied. In addition, curve properties such as cost sheet column selections 
will not be copied, even if they have been chosen in a project or shell template, because you can 
choose a template from any project or shell template. 

To create a cash flow details curve by copying a template 

1) Open the Cash Flow log. 

2) Click the New button and choose From Template. The Cash Flow Templates window 
opens. 

The Cash Flow Templates window displays information about the templates such as detail 
level, rollup status and more. These properties can be edited in the newly created curve. 
Also, note the Project/Shell Level column. A "Yes" in this column indicates that the template 
exists within a project or shell template. 

3) Choose a template and click Select. The Properties window opens. 

4) Give the detail curve a unique Name. Depending on the curve type and the options chosen 
in the Properties window, you may need to choose a specific business process record or 
cost sheet column when creating a new curve in a project or shell. 

You can make other changes as necessary to the tabs in the Properties window. If the 
selected schedule sheet exists under the destination project / shell (matched by name), then 
the curve will be linked to the schedule sheet under the destination project. If the schedule 
sheet in the template does not exist in the destination project/shell location, then the 
schedule sheet name on the curve properties will remain empty. 

5) Click OK to save and close the Properties window. This also opens the Cash Flow 
Worksheet window. 
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Copy Cash flow curves and curve data 

You can select a curve from the worksheet window and copy curve data (time and amount) to 
another curve with manual entry as distribution. Process data (time, amount and distribution) 
associated with CBS Codes (from schedule sheet) will be copied over to the destination curve. 

You cannot copy data to a curve that pulls data from a business process record, cost sheet or 
schedule sheet. You can, however, copy data from an auto-distribution curve. 

 For example, Spends curves pull actual spends transaction data from a cost sheet 
column (usually, cost sheet columns that show spends business process transactions). If 
you want to work with this data manually, you can create a custom curve in the 
Properties, be sure that all data entry is manual, then copy the spends curve data to the 
manual custom curve. 

 For another example, you can make a copy of the original Baseline curve, make 
adjustments, and save the revised version. 

When you copy data, any existing data in the destination curve will be overwritten with the data 
from the source curve. 

To create a cash flow curve by copying another curve 

1) Open the Cash Flow log. 

2) Select a curve from the log and click Copy. The Properties window opens. 

3) Enter a unique Name for the new curve. You can make other changes as necessary to the 
tabs in the Properties window. 

4) Click OK to save and close the Properties window. This also opens the Cash Flow 
Worksheet window. 

You can copy the data from one curve to another. The destination curve must be a manual 
curve -- that is, the distribution and From/To dates must be manual data entry. You cannot copy 
data to a curve that pulls data from a business process record, cost sheet or schedule sheet. 
You can, however, copy data from an auto-distribution curve. 

For example, Spends curves pull actual spends transaction data from a cost sheet column 
(usually, cost sheet columns that show spends business process transactions). If you want to 
work with this data manually, you can create a custom curve in the Properties, be sure that all 
data entry is manual, then copy the spends curve data to the manual custom curve. 

For another example, you can make a copy of the original Baseline curve, make adjustments, 
and save the revised version. 

When you copy data, any existing data in the destination curve will be overwritten with the data 
from the source curve. 

To copy a worksheet row 

1) In the Cash Flow Worksheet, select a row to copy. This is the source curve. 

2) Click the Copy button. The Copy To window opens. 

3) Click the Destination Curve drop down menu. The drop down menu lists all manual entry 
curves. 

4) Select a curve from the list and click OK. 
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5) At the confirmation window, click Yes. 

6) The Details window opens. All values in the destination curve will be overwritten by the 
values from the source curve. The new values are displayed in the Details window. 

7) You can make necessary changes to values in the Details window. To save the Details 
window with the new values, click Save. 

Note: Special note for Forecast curves: If the intended destination curve 
is a Forecast curve and the forecast is set up to start at the end of 
Spends record, this forecast curve is only available as a destination 
curve as long as no spends records have yet been received. If spends 
data has already hit the forecast curve, then the forecast curve will not 
be available in the Destination Curve drop-down list. 

Cash Flow Curves in Cost Controls Base Product 

Cash Flow Curves in Cost Controls Base Product 

With the Cost Controls Base Product, you receive a cost control cash flow that shows Baseline, 
Forecast, Actual (or Spends), Portfolio Budget, Derived, and Custom curves using an S-curve 
distribution profile.  

Once your project is in operation, your manager sheets are set up, and the Business Processes 
are in use, Unifier will retrieve the curve data from the Project Cost Sheet to render the Cost 
Controls cash flow curves.  

For Baseline and Forecast curves you can enter dates manually or set the Schedule Manager to 
automatically control the start and finish dates. 

You can create as many Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, and 
Custom curves as you need in a Cash Flow WorkSheet.  

Within a Project/Shell, each curve can be created in one of the following detail levels:  

 Cash Flow Curve by Project/Shell 

 Cash Flow Curve by CBS 

 Cash Flow Curve by Summary CBS 

 Cash Flow Curve by Commitment (one per base contract) 

Note: For company- and program-level cash flow, see Program-Level 
and Company-Level Cash Flow (on page 316). 

The Cash Flow WorkSheet allows you to: 

 View or enter data 

 View and compare the curves that you added 

There are several ways to create a cash flow curve, including:  

 Manual creation 

You define all curve properties from scratch. See Cash Flow Properties Settings: General 
tab (Classic View) (on page 174). 
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 Templates 

You can pre-set curve options, except, for example, actual business process records, and 
cost sheet columns, which are set at run time. There are two types of cash flow templates:  

 Company-level templates, which are created in Standards & Libraries (in Administration 
Mode). 

 Project or shell-level templates, which are created within a Project /Shell template (in 
User Mode). 

 See Create a Cash Flow Curve from a Template (on page 298).  

 Auto-creation 

Auto-creation of a commitment curve from a base commit record. In the base commit 
business process workflow set up you can associate a cash flow template with any step 
except the Creation step. When the base commit record reaches that step, Unifier will 
automatically create a cash flow curve. See Auto-creation of a commitment curve from a 
Base commit record (see "Auto-create a Cash Flow Curve from a Base Commit 
Record" on page 295). 

 Copy 

You can copy existing curves from the Cash Flow log, or you can copy data from existing 
curves. See Copy Cash flow curves and curve data (on page 299). 

About Cash Flow Worksheets 

Cash Flow WorkSheets are used in conjunction with the Cash Flow log to define and manage 
cash flow detail and rollup curves. The Cash Flow WorkSheet opens automatically after you 
define properties for a new cash flow curve. 

Unifier collects data from various managers, including cost, portfolio, resource and schedule, 
and displays it in cash flow curves. Curve options (for example, data sources, and distribution 
selections), determine the appearance of a curve in a Cash Flow WorkSheet. The Cash Flow 
WorkSheet window displays a graph on the top portion of the window, and a list of included 
curves on the bottom portion. Each curve listed has its own data set, which you can view in the 
Details window. Depending on the curve set up, the Details window is where you manage the 
curve data. 

To open a Cash Flow WorkSheet for an existing curve 

1) Navigate to the Cost Manager and select Cash Flow to open the Cash Flow log window. 

2) Select a curve from the log and click Open, or double-click the curve to open the Cash Flow 
WorkSheet window. 

The Cash Flow WorkSheet is divided into two parts: 

 The Graph view simultaneously displays incremental and cumulative cash flow data. You 
can filter data in the graph sections. The Cash Flow WorkSheet for a new curve does not 
display graphs because no curve data has been entered or spends values (Actuals) 
generated. After graphs are displayed, the zoom level can be switched from monthly to 
yearly. 

 The Table view displays the names of the individual curves that you defined in the Properties 
window as well as incremental data values (by default). You can split the table for easier 
viewing of the information. 
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Incremental curve: An incremental curve displays the cash flow for a certain period. 

Cumulative curve: A Cumulative curve displays the net of all cash flows over a period of time. 

The other parts of the Cash Flow WorkSheet are: 

 The View option (on the menu bar) enables you to toggle between incremental (default) and 
cumulative table values. 

 The sliders (located between the graph and the table views) enable you to limit the graph to 
specific time periods. 

Each part of the Cash Flow WorkSheet can be individually maximized. Additional options enable 
you to filter the information on the Cash Flow WorkSheet to display selected curves and to print 
the worksheet, or both. 

To set curves for viewing in the Cash Flow WorkSheet 

1) Navigate to the Cost Manager and select Cash Flow to open the Cash Flow log window. 

2) Select a log and click Properties. 

3) On the General tab, check the data sources that have the curve types you want to view. 

4) Click OK. The Properties window opens and the selected worksheet opens with a graphic of 
the curves. 

Graph 

The worksheet is divided into two parts: a graph view on top, and a table view below. Each part 
can be individually maximized. 

There can be multiple curves displayed on the graph. You can add as many curves as you need 
to the worksheet. Each curve must be associated with a data source, which are created in 
Administration Mode. The curves are color coded; the color is determined in the data source. 

In the graph, you have the option to filter out some curves and display a subset of the available 
curves; change the zoom level between monthly and yearly; or print the graph. You can switch 
between incremental view or a cumulative view. 

The graph section in cash flow shows both the incremental and the cumulative views. The 
graphs for both incremental and cumulative views are plotted on separate Y-axes.  

Note: You can use the View Finder, below the chart, to zoom and 
display graphs in selected timeframes. 

Split screen 

Just as you would with a spreadsheet, you can use the split screen view to make your 
information much easier to read. In the Detail window, you can see two parts of a row by splitting 
the view so that you can see the beginning part of a row and the middle or end of the same row. 
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To get the split screen, click on the Split button and the bottom of the Detail window displays 
two columns. The same row is highlighted across both columns. You can drag the vertical 
column separator to suit, and use the horizontal scroll bars to view different parts of the row. 

Zoom level 

You can switch the display of the curve and worksheet data between a monthly view or yearly 
view by changing the zoom level. This will not affect the time scale itself, just the data and curve 
display. The Year zoom level is only applicable if you have data that spans over multiple years. 

 The Zoom buttons are in the top right portion of the Cash Flow Worksheet. 

 Month (M): This changes the time line focus of the curve and table to show months and 
year in the cash flow time period. 

 Year (Y): The displays time period increments in years, and is useful for multi-year 
projects or contracts. 

Changing the zoom setting will adjust the zoom for both the graph and the table. 

Curve Columns 

The table underneath the graph shows the data for the curves. Each row corresponds to one of 
the curves on the graph, and displays the curve data in columns. The view is incremental; you 
can click the drop-down on the right to change the view to cumulative, which is view-only. The 
columns are: 

Color: The color of the graph displays in the first column 

Name: This is the name of curve, taken from the Data Source 

From Date: The starting point of the curve. This can be entered manually or taken from a date 
field on the project/shell master schedule sheet, as defined in the curve properties. 

To Date: The ending point of the curve, also manually entered or pulled from the schedule 
sheet. This can be entered manually or taken from the schedule sheet. 

Total: This amount is the cost portion of the curve. It can be pulled from a specified cost sheet 
column or business process. This total amount will then be distributed over the time period 
(From Date to To Date) to generate the cash flow curve. This is defined in the curve properties. 

Unassigned: Any amount left over from the Total amount that has not yet been distributed. 

Time Period Columns: These are the incremental time periods for the duration of the cash flow 
time period. That is, the From Date to the To Date, entered above. For monthly distribution, 
these will display each month and year from the From Date to the To Date. If shown Yearly, then 
each period is one year. 
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Curve Data Distribution 

The data in these columns show the distribution of cost -- the value in the Total field. If you are 
doing auto distribution using a distribution profile, these values will be calculated based on the 
distribution percentages. If you are doing manual distribution, you will enter values into each 
time period (distributing the amount in the Total column). The Unassigned column will display 
how much of the Total column is left to be distributed. Unifier displays cost data using the latest 
exchange rate table. 

Commitment Curves Transaction and Project Currency Views 

Unifier displays commitment costs in both the graph and the curve portions of the worksheet 
window. Use the Currency drop-down list to switch between the Transaction and Project
currency, if they are different (otherwise, you will not see this menu). For more information, see 
Transaction Currency in Cash Flow Curves (on page 304). 

Curve replication 

You can select a curve from main window and copy the data (time and amount) to another 
curve, with manual entry as distribution. Additionally, process data (time, amount and 
distribution) associated with CBS Codes (from schedule sheet) will be copied over to destination 
curve. See Copy Cash flow curves and curve data (on page 299) 

To view details for the curves 

Select a row from the table and click Open (or double-click the row). The Details window opens. 

 For cash flow by CBS or Summary CBS, all CBS or Summary CBS codes will display. If 
selected CBS or Summary CBS codes have been chosen in the Filter tab of the Properties 
window, then those codes display. 

Note: For cash flow by CBS in a baseline curve, the list of CBS codes 
displayed in the details window are from the schedule sheet and are 
read-only. 

 For cash flow by commitment, all associated records (the base commit, any change orders, 
etc.) display. 

 If the curve has been designed for manual entry rather than in auto-mode, you can enter 
values in the Details window. 

Transaction Currency in Cash Flow Curves 

General currency information 

During company creation, the administrator set a base currency that became the default project 
currency for each project or shell. When you create a project or shell you can change the default 
project currency to any currency listed in the company-level exchange rate table. After creation 
you can add additional currencies to the project or shell as needed. 
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Depending upon the commitment business process design, during record creation you can 
select a transaction currency from the list of available currencies in the project or shell. Unifier 
stores costs in the project currency and uses the active company-level exchange rate table for 
currency conversion. 

Transaction currency in curves 

In Project, CBS, and Summary-level cash flow curves, Unifier displays cash flow costs in the 
project currency. By default, Unifier displays commitment curve cost data in the record 
transaction currency, which is stored in project currency using the active currency exchange rate 
table.  

 If the transaction currency is different from the project currency, you can change the 
currency view between transaction and project currencies, but you can only edit data in the 
transaction currency. 

Note: The Summary Curve displays 0 (zero), if: 

 The transaction currency is different from the project currency, and 

 No exchange rate has been defined 

 If there is a more recent value in the exchange rate table, refreshing the curve will refresh 
the cost data. 

 If the transaction currency is different from the project currency, then the system conducts 
the exchange rate conversion before rendering the Summary Cash Flow curves. 

 If the base currency is the only currency used in the company, then the system does not 
conduct the exchange rate conversion, and the Summary Cash Flow curves show the 
Summary Cash Flow curves in project currency, which is the same as the base currency. 

To switch between transaction and project currency in the cash flow worksheet 

1) Open the project or shell, or go to the Company Workspace tab and click Cost Manager > 
Cash Flow in the left Navigator. 

2) Select a cash flow worksheet from the log. 

3) Open the cash flow worksheet. By default the worksheet opens in the transaction currency if 
different from project currency. 

4) Use the drop-down currency menu located at the top-center of the worksheet to change 
currency views. If the transaction currency and the project currency are the same, you will 
not see the drop-down field. The numbers and curve refresh to display the new currency 
values. 

5) In the cash flow window curves list, located on the bottom portion of the window, select a 
curve and open the curve details window. If you selected the project currency view before 
opening the curve details window, and the curve is in transaction currency, the data will be 
read only. 

6) In the Details window use the currency menu to switch to the transaction currency. 
Depending upon the curve set up, you can manually enter data or change the automatically 
distribution profile. 

7) When finished, click Save. The cash flow window will refresh with changes. 
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Cash Flow Details Window 

When you open a cash flow worksheet, the data is view-only in both the chart and the curves 
list. You can double-click a curve to open the Details window for that curve, which is where you 
enter or edit cost data. If the details window is open and you click on another curve in the 
worksheet, the details window will refresh with the data of the new curve. 

Below are considerations for Baseline, Spends, and CBS curves. 

Baseline curves 

 In commitment-based curves, Unifier shows cash flow in the transaction currency of record 
creation. Unifier stores the data in project currency. If the project currency is different from 
the transaction currency, both the main and detail windows contain a currency drop-down 
list, which you can use to show costs in the project currency; however, you can only edit data 
in the transaction currency mode. Currency conversion is based on the active company-level 
Exchange Rates table. Bulk edit is unavailable if the detail window is in project currency 
mode. 

 In commitment-based curves the detail window shows columns from the Business Process. 
For example, Number, Name, Line No, CBS Code, Description (Short Description) 

Actual (Spends) curves 

These curves display actual spent amounts per time period, and are not editable or 
distributed. 

CBS curves 

CBS codes in the worksheet appear in the order as listed in the cost sheet. The following 
procedure describes how to enter data on worksheet fields that have been set up to be 
editable. Data can be entered by manual entry or by importing. 

To manually enter or edit cash flow data on a worksheet 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. 

2) Select a curve from the log and click Open, or double-click the curve. 

3) Select the curve to edit from the list of curves in the lower portion of the worksheet. 
Double-click the row to open the Details window.  

Depending on curve options, the curve can be set up for manual or auto-distribution. 
Worksheet selections may vary according to distribution methods. 

4) In the Details window you can: 

 Click the From Date and/or To Date to select different start and end dates for the cash 
flow curve. 

Unifier pegs cost data distribution to the From Date. If there are date changes, Unifier shifts 
the curve on the timeline based on From Date modifications. Each time period (e.g., month 
or year) on the curve retains the value of the original distribution. If date changes make the 
cash flow curve longer or shorter, Unifier will not re-balance or redistribute cost data to match 
the modified curve length. 

 Click the Total field and enter the cost value for which you want to generate the cash flow 
curve. 

 Track undistributed cost in the read-only Unassigned field . 
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 Change the distribution profile if the curve was set up with auto-distribution. Click the 
Profile field. The Select Distribution Profile window opens. Select a new profile and 
click Select. 

 Enter values in each of the time periods to equal the amount in the Total field. The 
Unassigned column will show you how much of the Total you have left to distribute. 

5) Click Save to save and close the Details window. 

Import Cash Flow Data 

You can import cash flow data via CSV file. This includes curve setup data (From and To dates, 
Profile and Total columns), and curve distribution data (distribution values of the Total amount 
entered in the date period columns). It is important to observe the order of curve operations: 
import the setup values first, then import the distribution values. 

 Manual entry generally allows data import, but depends upon the curve set up. 

 Auto-distribution precludes data import. 

 Fields that display data from other sources (schedule sheet, cost column, business 
process record), cannot be edited via CSV import. 

You can change curve distribution settings; however, Unifier will replace your data with data 
collected by the new distribution method. For example, if you change a manual entry field to 
auto, all manually entered data will be lost and replaced with the auto-generated data. 

To import curve setup data into the Cash Flow Worksheet by CSV import 

1) Open the Cash Flow Worksheet. Select a row and click Open to open the Details window. 

If you are importing both setup and distribution data, then import the setup data first to 
establish the distribution time period. 

2) Click Export to export the CSV template. The CSV opens in Microsoft Excel®. You can Save
the CSV file to your desktop first, or Open it directly. 

Note: Cash flow data exports the currency and the values to the CSV 
template. 

3) Add the Curve Distribution data to the CSV file. 

 From Date, To Date: use the date format. 

 Profile: If using auto-profile, enter the name of the default profile you want to use. This is 
from the Distribution Profiles list maintained in Administration Mode. 

 Total: Enter a value to use as the cost total. 

 Save the CSV file. 

4) Import the CSV file. 

 In the Details sheet, click Import > Curve Setup. The File Upload window opens. 

 Locate the CSV file and click OK. The data will populate edited fields on the Details 
sheet. 

5) Save the Details window. 
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To import curve distribution data into the Cash Flow Worksheet by CSV import 

1) Open the Cash Flow Worksheet. Select a row and click Open to open the Details window. 

If you are importing both setup and distribution data, then import the setup data first to 
establish the distribution time period. 

2) Click Export to export the CSV template. You can Save the CSV file to your desktop first, or 
Open it directly. 

3) Add the Curve Distribution data to the CSV file. 

 Enter values in the time period distribution fields. Do not exceed the amount for 
Unassigned. 

 The Currency field must have the currency listed. 

 Save the CSV file. 

4) Import the CSV file. 

 In the Details sheet, click Import > Curve Distribution. The File Upload window opens. 

 Locate the CSV file and click OK. The data will populate edited fields on the Details 
sheet. 

5) Save the Details window. 

Note: You can import data into cash flow by commitment curves in either 
transaction or project currencies. If you try to import data in an incorrect 
currency, you will be notified. For example, if the transaction currency is 
in Yen and the project currency is in USD, and you try to import in Euro, 
you will get an error message in the CSV file. You will need to correct 
the errors in the CSV before re-importing. 

Use Bulk Edit to Edit Cash Flow Data for Multiple Rows in Details Window 

Bulk Edit is available on the Details window for the Cash Flow Worksheet. This is useful when 
there are multiple items to be edited that are associated with the curve data. 

For example, if you are doing cash flow by CBS, the data in the Details window displays the 
CBS codes in use. You can enter curve data for one or multiple CBS codes using Bulk Edit. 

If you are doing cash flow by commitment, and are including change orders in the curves (for 
cost information and auto distribution), then you will see all commitment records in the Details 
window -- the base commit and any change commits. You can enter curve data for one or 
multiple records using Bulk Edit. 

Note: If you are editing a Contract-type BP, the total in the Bulk Edit will 
be highlighted in the details screen of the cash flow by contract curve. 

To enter cash flow data using Bulk Edit 

1) Open the Cash Flow Worksheet. Select a row and click Open. The Details window opens. 

2) Select one or more rows and click Bulk Edit. The Bulk Edit window opens. 
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3) The fields that are editable for the curve (based on the Properties window options) will 
display. 

4) Enter values for the fields. 

5) Select the Update checkbox for the fields you want to update. 

Note: You can use the Bulk Edit button to edit multiple items in the 
chosen currency. The total in the Bulk edit window will be interpreted in 
the currency selected in the details screen (lower part of the worksheet 
window.) 

6) Click the Update button. 

Filter the Curves to Display on the Cash Flow Worksheet 

To show or hide curves on the cash flow worksheet 

1) Go to your Project/Shell > User mode > Cost Manager > Cash Flow

2) Select and open the Cash Flow Worksheet (Summary or Detail). 

3) Click View and select Filter. 

Note: Alternatively, you can open the Filter window by way of clicking 
the filter icon on the upper right-hand corner of the Cashflow Worksheet 
window. 

4) Select which curves to display. Deselect any curves you do not want to display. 

5) Click OK. 

The graph will display only the curves that are selected. The data at the bottom of the worksheet 
will be unaffected. This display remains active as long as the window is open. The next time you 
open the worksheet window, all curves will again display by default. 

To save the filter for both Summary level and Detail level Cash Flow Curves 

1) Go to Unifier > your Project/Shell > User mode > Cost Manager > Cash Flow

2) Select and open the Cash Flow Worksheet (Summary or Detail). 

3) Click View and select Filter. 

Note: Alternatively, you can open the Filter window by way of clicking 
the filter icon on the upper right-hand corner of the Cashflow Worksheet 
window. 

4) Select which curves to display. Deselect any curves you do not want to display. 

5) In the Save As field box enter a name for the filter. 

6) Click OK to close the window. 

The name of the filter that you have saved appears on the upper right-hand corner of the 
Cashflow Worksheet window. This window contains a list of saved filters that have been saved. 

Note: The Default View option allows you to select which particular filter 
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to display when you open a Cash Flow Worksheet. 

You can click Edit > select Manage Filters to delete, set default view, change name, and 
change the description of your filter. 

Create and Manage Distribution Profiles 

Administrators can create a library of distribution profiles in Administration Mode, Standards & 
Libraries. In addition to these profiles, you may also want to create additional distribution profiles 
in a project or shell. At runtime, when you select a distribution profile, you will see the list of 
profiles created in Administration Mode, as well as the ones created in User Mode. 

To add a distribution profile in User Mode 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Click the Edit menu and choose Distribution Profiles. The Edit Distribution Profiles window 
opens. 

3) Edit and manage distribution profiles in this window in the same way as the default 
distribution profiles created in Administration Mode. 

View and Manage Cash Flow Properties 

You can view or edit the curve properties from the Cash Flow log. You can open a view-only 
Properties window from the cash flow worksheet. 

To edit cash flow curve properties 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Select a curve from the log and click Properties. The Properties window opens. 

3) When the Properties window is complete, click OK to save and close the window. When you 
save and exit the Properties window, the Cash Flow Worksheet opens for the curve you just 
edited. 

To view cash flow curve properties from the worksheet window 

1) Open the cash flow worksheet 

 Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. 
Select a curve from the log and click Open, or double-click the curve. 

 In a base commit record, click the Cash Flow button. If a detail curve exists for the 
record, the cash flow worksheet opens in a view-only mode. 

2) Click the View menu and choose Properties. The Properties window opens, but is not 
editable in this view. 

Some notes on editing cash flow properties

 If you edit the time scale, the period close settings will be reset, and 
you will need to enter new ones for the new time scale.  

 For curves in auto mode, you can switch to manual mode and adjust 
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the data. 

 If you switch back to auto mode, the default profile will be used, and 
manual data will be overwritten. 

Activate or Deactivate Rollup Status 

You can change the rollup status of one or more curves. Active curves roll data up to program 
and company cash flow sheets; this status also affects scheduled refresh. 

To activate or deactivate the rollup status 

1) Open the project or shell that uses the curve you want to change. 

2) In the left Navigate, click Cost Manager > Cash Flow. The Cash Flow log opens. 

3) Select a curve from the log. 

4) Click the Rollup Status button and select Active or Inactive. 

Add Curves to the Detail Curve Cash Flow Worksheet 

You can add as many curves as you need to the cash flow worksheet. Each curve is associated 
with a cash flow data source so that curve data can be rolled up and is reportable. Each data 
source can be used once per worksheet. (Data sources are created in Administration Mode in 
Standards & Libraries). Be sure that you have created enough data sources to add the curves 
you need to the worksheet. 

When creating the curves, you can choose to make them editable so data can be entered and 
adjusted manually, or automated so that data is pulled from other sources, such as the project 
schedule sheet, cost sheet columns, and cost business process records. Distribution of cost 
data over time can also be done manually, or can be automatically distributed by creating and 
applying distribution profiles. 

Curves are added to the cash flow detail curve Properties window. 

To add curves to the cash flow detail worksheet 

1) From the project/shell cash flow log or cash flow template log, select the detail curve in the 
log and click the Properties button. The Properties window opens. 

2) Modify the Properties window and add curves as needed. See Cash flow curves (see 
"Creating Cash Flow Curves (Classic View)" on page 170) 

3) Click OK when done. The cash flow worksheet opens and displays the added curve. 

Delete Cash Flow Curves 

You can delete a cash flow curve. If a detail curve is deleted, Program and Company level roll 
up curves will ignore the data from the detail curve the next time they are refreshed. 

You can also delete an individual curve from the detail curve family. 



Unifier Managers User Guide

312

To delete a cash flow detail curve 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Select a curve from the log. 

3) Click the Edit menu and choose Delete. 

4) At the confirmation window, click Yes. 

To delete a Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, or Custom 
curve 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Open the Cash Flow Worksheet. 

3) Select a row from the table. 

4) Click the Edit menu and choose Delete. 

5) Click Yes at the confirmation window. 

View Summary Cash Flow Data 

The summary view can be used to automatically summarize all of the active curves in the cash 
flow log. 

Summary is done at the data source level - that is, it summarizes the data for each data source 
used in at least one curve. 

If the active curves use different time scales (some use monthly and some yearly), then the 
Summary view will display the highest time scale, which would be yearly. 

To summarize cash flow data 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Click the Summary button. The Cash Flow Worksheet window opens. The curves that are 
included in the cash flow curve are shown in a summary view on the graph, by data source. 

Printing Cash Flow Curves 

You can print a copy of a cash flow worksheet. The print output will essentially be what you see 
on the screen, both the graphical display and the data. 

To print a cash flow worksheet 

1) In the top right portion of the Cash Flow Worksheet, click the Print button. 

2) Follow the prompts and settings for your printer. 

Note: For improved print output, you can try a few things, such as: adjust 
the curve zoom level; print the worksheet in Landscape mode (choose 
this in your printer settings); adjust the worksheet window size (for 
example, drag the side or bottom of the window to expand the height or 
width to see more rows or columns); you can also maximize the window 
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(click the Maximize button in the upper right corner of the window). 

Refresh Cash Flow Curves 

You can enable or disable auto-refresh, and set the frequency. This setup is done in the Cash 
Flow Properties Settings: Schedule tab (Classic View) (on page 228) on the Properties 
window of the detail curve during setup, or set at runtime. You can also manually refresh a curve 
at any time. 

You can see the refresh history of a curve at any time by clicking Refresh>History. This shows 
not only each manual or automatic refresh performed on the curve, but will also display any 
errors that were found during a refresh. 

What refresh does 

 Checks to see if there are any new spends records that are not part of the curve. Depending 
on Period Close settings, the spends record is added to the correct period, and therefore, 
changes in values will appear for Spends curves and for Forecast curves that consider 
spends records. 

 Checks to see if a distribution profile definition has changed, either in Administration Mode, 
or in the project/shell. Any changes will be applied to the curve. 

 If dates are based on master schedule sheet, checks to see if values have changed in the 
schedule sheet. 

 For a curve in the auto mode, refresh distributes unassigned values automatically. 

 Refresh checks for changes to CBS structure. 

 Checks for errors, such as not selecting a valid business process record or cost column, or 
missing data such as a blank schedule sheet date column. The error alert will display in red 
font on the worksheet (below the curve section). Click the error to view the reason. 

Unassigned field 

If there is a value in the Unassigned field, hover over or click the field. The reasons for the value 
is displayed. For example, 

 Excess or deficit because of Spends (invoice) records 

 Incoming Change Orders 

 For Forecast curves with option to start at the end of Actuals (Spends amount), the amount 
is put in the Unassigned field if the To Date of the forecast curve is less than effective date of 
a Spends value. 

To refresh a cash flow curve manually 

Do one of the following: 

 You can refresh one or more curves from the cash flow log. Open the project or shell and 
click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens. Select one 
or more curves from the log and click the Refresh button. 

 You can also refresh a curve directly from the Cash Flow Worksheet window. Click the 
Refresh button. 
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To set the cash flow curve auto-refresh schedule 

1) You can access the auto-refresh schedule options in two ways: 

 To edit a single curve, you can select the curve from the cash flow log and click the 
Properties button. Click the Schedule tab. 

 To edit the schedule information for multiple curves from the Cash Flow log, select one or 
more curves in the log. Click the Refresh button and choose Set Frequency. The Set 
Frequency window opens. 

In either window, you can enable (or disable) automatic refresh of the selected cash flow 
curve (or curves), and set the refresh schedule. If you are setting the frequency in multiple 
curves using Refresh> Set Frequency, these settings will be pushed to the Schedule tab of 
each curve’s Properties window when the window is saved. 

2) Complete the fields. 

In this 
Field: 

DO This: 

Enable 
Refres
h

If you select this checkbox, you can then define the refresh schedule. 

The cash flow sheet will refresh automatically to reflect the most recent cost 
or schedule data, or any changes that may have been made to the 
distribution profile or other properties. If you do not select this checkbox, the 
curve can still be manually refreshed at runtime. 

Freque
ncy

Choose when the refresh will be run. 

Daily. At the end of every day. 

Weekly. Select the day of the week to run the refresh. 

Monthly. Refresh will run on the last day of the month. 

Quarterly. Refresh will run on the last day of the calendar quarter. 

Range 
of 
recurre
nce

You can define when the refresh schedule will begin and end. 

Start On. Enter a date to begin the refresh schedule. 

To define when the scheduled refresh ends, select either No end date (the 
refresh will run at the scheduled intervals until it is turned off or as long as the 
project/shell is active, or select End by and choose an end date to stop the 
automatic refresh. 

To view a curve’s refresh history 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Select a cash flow curve from the log, click the Refresh button and choose History. The 
Refresh History window opens, displaying the refresh events for the selected curve. This 
window also displays the status of a curve that is currently being refreshed. 

To cancel a curve refresh 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 
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2) Select the curve being refreshed and click Refresh > History. The Refresh History window 
opens. 

3) If the refresh Status does not yet display Finished, click Cancel Request. If the cancellation 
is successful, the entry will display the Status as Canceled. 

Search for Cash Flow Curves 

You can search the Cash Flow log for a specific curve using the Find feature. Cash Flow uses a 
floating find window. 

To search for a curve in the log 

1) Open the project or shell and click Cost Manager > Cash Flow in the left Navigator. The 
Cash Flow log opens. 

2) Click the Find button. The Find window opens. You can search on any of the fields that 
appear in the Cash Flow log. 

Working with Snapshots 

You can manually save a snapshot of cash flow curves at any time. You can also automatically 
take a snapshot of a detail level curve as part of the Period Close settings on the General tab of 
the Properties window. 

A snapshot displays the graph, curves and curve data on the worksheet. You can open the 
Details window from the snapshot. Snapshots are not editable. 

You can take a Snapshot and view it in both project and transaction currencies as well as 
reports. 

To take a snapshot at any time 

1) Open the Cash Flow worksheet. 

2) Click File and choose Create Snapshot. The Create Snapshot window opens. 

3) Enter a Snapshot Title and click OK. 

To schedule automatic snapshots 

You can schedule automatic snapshots as part of the Period Close settings on the General tab 
of the Detail Curve Properties window. 

1) Click the option Enable auto snapshot on. 

2) Click the Select button. The Details window opens. 

3) Choose when you want Unifier to take the snapshot. 

4) Click OK. 

After taking an auto-snapshot Unifier refreshes the curve immediately. Spends will resume after 
the auto-snapshot. 

To view a snapshot 

1) Open the Cash Flow worksheet. 

2) Click View and choose Snapshot Log. The Snapshots opens. 
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3) Choose a snapshot to view and click Open. The Cash Flow Worksheet opens. You can view 
the Details window, cumulative view, and most other interactive elements, but the snapshot 
data is not editable. 

To search for a snapshot 

1) Open the Cash Flow worksheet. 

2) Click View and choose Snapshot Log. The Snapshots opens. 

3) Click Find. 

4) Enter search criteria and click Search. 

5) To restore the entire list, click Cancel Filter. 

To delete a snapshot 

1) Open the Cash Flow worksheet. 

2) Click View and choose Snapshot Log. The Snapshots opens. 

3) Select the snapshot and click Delete. At the confirmation, click Yes. The snapshot is deleted. 

Program-Level and Company-Level Cash Flow 

Creating and managing roll-up curves in a Program and in the Company Workspace is similar to 
creating detail curves in projects and shells. Program roll-up curves can be created from a 
template. Runtime permission must be granted to each curve for other users to have access to 
it. 

Data rolls up to the program and company level based on the data sources used to add the 
individual Baseline, Forecast, Actual (or Spends), Portfolio Budget, Derived, and Custom curves 
that make up the Project/Shell detail curves. 

Note: Projects/Shells included in a Program can use different currencies. 

Only project and shell-level cash flow curves with Roll-up Status equal to Active will roll up to 
program and company level cash flow. 

To create a Roll-up Curve in a Program 

1) Go to the Programs tab, switch to User mode, and click Programs. The Programs log opens. 

2) Open a program from the Programs log. 

3) Click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens. (If you 
can’t see the Cash Flow module, be sure your company administrator has granted 
permissions to the module.) 

4) Click New; you have two options. 

Roll Up Curves: You can use this option to create a new curve. Complete the General tab 
and select the data sources you want to include from this project. Then click OK. 

From Template: Select a cash flow template from the list and click OK. 
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Note: To use a template for the roll up curve, there must already be a 
cash flow curve roll up template created in Standards & Libraries. 

To create a Roll-up Curve in the Company Workspace 

1) Go to the Company Workspace tab and switch and to User mode. 

2) Click Cost Manager > Cash Flow in the left Navigator. The Cash Flow log opens. (If you 
can’t see the Cash Flow module, be sure your company administrator has granted 
permissions to the module.) 

3) Click New > Rollup Curves. Complete the Properties window. 

To view details of a roll-up curve 

1) Go to the Company Workspace tab, and click Cost Manage r> Cash Flow in the left 
Navigator. The Cash Flow log opens. 

2) Select the curve to view and click Open. The Cash Flow Worksheet opens. 

3) Select a row (curve) from the list and click Open. The Details window opens. The Details 
window lists the project/shell curves that comprise the roll up curve. 

What Else you can do with a Roll-up Curve 

Like detail-level curves in projects and shells, the roll up curves can be printed, snapshots taken, 
zoom levels adjusted, data sources filtered from the view, and curves permission-controlled — 
you can do just about everything except work with the data itself, since the data on the roll up 
curve is generated in the projects and shells, and rolled up to the program and company level. 
The procedures for working with roll up curves are similar to project/shell detail curves.  

Earned Value (EV) 

Earned value analysis is an industry standard designed to help project managers quantify 
project performance through:  

 Measuring project performance and progress 

 Analyzing schedule and budget variances 

 Forecasting schedule and cost overruns 

In Unifier, the earned value sheet always represents data by CBS code. Earned value 
calculations depend on the Company Cash Flow, and can optionally include activities on the 
Schedule Sheet. Users can also view a graphical representation of Earned Value, Budget at 
Completion (BAC) and Actual Cost. 

Available in Unifier standard projects and CBS-based shells, you can create any number of 
earned value sheets. Data collection source have different settings and prerequisites. 

When the source is the schedule manager: 

 The detail-level selection display schedule sheet activity progress. 

 The summary-level selection compares rows from other earned value sheets. 

 Unifier users progress dates to calculate BCWS, BCWP, ACWP, and EAC. 
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 Progress dates are calculated as of the current date. In a schedule imported from Primavera, 
Unifier honors the Current Data Date entry as the latest progress date. This date may be a 
future date that you might use in project modeling. Unifier will calculate curves up to the 
entered date. 

Working with Earned Value Sheets 

This section discusses working with the earned value sheets you have created. 

View additional sheets and worksheets: When you create an earned value sheet, you can 
choose to display the data in additional sheet views, or to view worksheets that show the 
calculations for BCWS, BCWP and custom entry curves added to the sheet. Manual cost 
distribution can be done on custom curve worksheets, depending on the curve setup. 

Display earned value data graphically: The information captured on the earned value sheet 
can be displayed on graphs. 

Change display options: You can change the display to show information by cost data, by a 
chosen unit of measure (hours, linear feet, etc.), or for a particular period of time. 

Add sheet columns: In addition to default columns, you can add your own formula columns to 
do earned value sheet calculations. 

Save snapshots of data: This allows you to save snapshots of data at periodic interviews on 
the some sheet views. 

Export earned value data: Some sheet views allow you to export the data on them to a CSV 
file. 

Details about these procedures are found in the following sections. 

About Earned Value Sheets 

You can create multiple earned value sheets per project or CBS-based shell. Each sheet can 
have any schedule sheet in the Schedule Manager as the source for the calculations. Each 
sheet can include multiple curves, including those listed here. 

 BCWS (Budgeted Cost of Work Scheduled) 

This is the curve of the budget for the project. The budget can be based on cost or on unit of 
measure. In terms of cost, it is the total planned budget for the project. Contributors to this 
cost can be labor, material, equipment or any other cost. In terms of units of measure, it is 
the total units needed to complete the project. Units can be hours, linear feet, etc., depending 
upon the activity and the resources that are assigned to an activity. 

Note: This option is unavailable (greyed out) when shell Schedule Type = Resource Loaded 
or Cost Loaded. 

 BCWP (Budgeted Cost of Work Performed) 

This is the means of assessing performance against the planned budget. It can help you 
determine whether you are behind, ahead of or on schedule. The budget is based on what 
you have planned for the schedule, so if the schedule slips, it affects the budget. BCWP 
calculations are based on the schedule sheet and captured from the progress log for 
activities and resources. 

Note: This option is unavailable (greyed out) when shell Schedule Type = Resource Loaded 
or Cost Loaded. 
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 ACWP (Actual Cost of Work Performed) 

These are actual costs incurred to perform project-related activities, such as payments to 
subcontractors or purchase of materials. If your actuals are higher than the budget, you may 
be over budget. If your actuals are under the budget, it is possible contractors are not 
submitting invoices. 

 EAC (Estimate at Completion) 

This refers to the final cost of any other key quantity (for example, hours, feet of material, or 
other quantity) associated with any work breakdown structure (CBS). 

 Custom curves

Create custom curves to generate Forecast, ETC, and others. 

Curve Source = Cost Sheet Source = Schedule Manager 

BCWS 
Derive budget data from a 
Cash Flow curve 

Derive budget data from an active 
schedule  

BCWP 
Derive budget data from a 
Cash Flow curve 

Calculate based on earned progress and 
earned amount information captured on 
schedule sheet activities 

ACWP 
Select Actual Costs from a 
Cash Flow curve or a Business 
Process Cost Sheet Column 

Select Actual Costs from a cash flow 
curve or a BP cost sheet column 

EAC Not applicable. 
Calculate forecast from actual completion 
information 

Work package names appear on the sheet if the source is schedule manager, and one or more 
schedule sheets associated with EV curves are linked to a work package. 

Note: The Source = Cost Sheet option is available for Unifier Shells that 
are integrated with P6. The option Source = Cost Sheet is not available 
for other Shell instances. 

Display options 

You can select display options, to display the curves in terms of cost or unit of measure (such as 
hours, linear feet, etc., as defined in schedule activity properties). See Change the sheet 
display options (on page 322). 

Views 

You can also generate earned value data in different views, for example, grouped by work 
package. Access these views using the More Sheets option. You also view the worksheets used 
for the individual components and curves used in each earned value sheet (More Worksheets). 
See Open additional sheet views (on page 320) and View and work with worksheets (on 
page 321). 

Access earned value sheets 

Earned value sheets can be created for projects and shells, and are maintained in the Earned 
Value log, which is part of the Cost Manager. 
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To access earned value sheets 

Open a project or shell and click Cost Manager > Earned Value in the left Navigator. The 
Earned Value log opens. 

To open an earned value sheet 

Double-click it from the log window, or select the sheet and click Open. 

Open additional sheet views 

From an earned value sheet, more sheet views may be available, depending on the data source 
for the sheet (Schedule Manager). 

If the source is schedule manager, you can view additional sheets described below. 

 CBS Codes is the default view when the EV sheet source is Schedule Manager. It 
displays EV data by CBS code in a flat list. It is applicable when Progress option on 
BCWP is "Activity % Complete." 

 CBS Codes - Group by Summary Codes: The data in this view is grouped by summary 
CBS codes retrieved from the cost sheet. The summary codes show all levels that are 
defined in the cost sheet. It assumes that there are summary CBS codes. If the cost 
sheet is in flat mode, data is shown with leaf level CBS codes. 

 CBS Codes - Group by Work Package: The data is grouped by work package, and then 
by summary CBS codes. This is applicable even if cost sheet is in flat mode. Summary 
rows show totals from leaf codes; work package summary rows show the totals per work 
package. 

 Earned Value Components: In this view, data is grouped by earned value components. 
The rows are the components of the earned value sheet: BCWS, BCWP, ACWP, EAC. 
The columns are time periods based on the time scale for the sheet. Data is not totaled 
at the bottom of the sheet. Note the sliding scale in the upper portion of the sheet. This 
allows you to move the view of the sheet to display different time periods. Display 
Options allows you to change UOM (unit of measure) value only. 

 Schedule Sheet - Activities: The activities displayed on this view are the activities 
defined in the schedule sheet. All activities are displayed regardless of whether progress 
entries have been made for them. 

 Schedule Sheet - Activities - Group by CBS Codes: In this view, EV data is grouped 
by CBS code, and by activity associated with each CBS code. 

For these additional sheets, you can create snapshots in the default CBS Codes view and the 
Schedule Sheet-Activities view. You can change the Display Options and export data from any 
view. 

To view more sheets 

1) Open the earned value sheet. 

2) Click the More Sheets button. The More Sheets window opens. The window lists sheets that 
are generated along with the current sheet. 

3) Select a sheet and click OK. The sheet opens. 
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View and work with worksheets 

You can view worksheets for BCWS, BCWP, EAC as well as custom curves that have the 
"Manual entry intermediate points" option selected in curve properties. These worksheets 
display the BCWS, BCWP, EAC and custom curve calculations used in the earned value 
analysis. 

BCWS, BCWP and EAC worksheets are read-only. Custom curve worksheets allow manual 
distribution of cost data in the Incremental view. 

You can export data from worksheets. A graphical view is available for the BCWP worksheet. In 
addition, you can add notes to worksheets. 

The More Worksheets option is available from the default CBS Codes view of the earned value 
sheet, and also the Schedule Sheet-Activities view available from the More Sheets option. 

To open a worksheet 

1) Open the earned value sheet. 

2) Click the View button and choose More Worksheets. The More Worksheets window opens, 
listing BCWS, BCWP, EAC (if defined) and any custom curves. 

3) Select a worksheet and click OK. The worksheet opens. The default view is incremental. 

In incremental view, the columns are time based. The range is determined by the Start and 
Finish dates in the Source Details. Manual entry of cost data, if applicable, can be done in 
this view. 

4) To view the cumulative view of the data, click the Cumulative button. (A graphical view of 
the Cumulative curve is available; click the Graph button from the Cumulative view.) 

5) For BCWP, to view the graphical view, click the Graph button, then choose All Rows or 
Selected Row. For more information about displaying graphs, see the example below. 

To add or view notes on a worksheet 

1) Open the BCWS, BCWP, EAC or custom curve worksheet. 

2) Click the Notes button. The Notes window opens. Any notes that have previously been 
added will display in the Notes field. 

3) You can enter a note in the Notes field and click Ok. 

To enter or distribute cost data in a custom curve worksheet 

1) Open the worksheet for the custom curve. 

 If (in the custom curve properties) the Data option has been set to manual, then the 
values that you entered in the Cost field of the Source Details window for each CBS code 
display by default in the last column on the worksheet. This amount can be distributed 
among all time periods (columns) on the worksheet. 

 If the Data option has been set to Cost Sheet column, then when the earned value sheet 
is refreshed, actuals data will roll up from the cost sheet column directly to the last period 
(column) on the worksheet. You can distribute this amount manually across other 
columns. 

2) To distribute this cost data, scroll to the last column on the worksheet. The value in the 
column is the total amount that needs to be distributed. 
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You can click the Find button to search for a specific value in any column, including to 
search for a CBS code. 

3) Double-click inside a cell to make it editable. 

4) For each applicable CBS code, change the value in the last column to the correct distribution 
amount and press Enter. The rest of the original cost amount displays in the Undistributed 
Amount field at the top of the worksheet. If you distribute a total amount that exceeds the 
original total, the Undistributed Amount field displays a negative amount. 

For example, if the original value is $12,000 in the last column (either added manually in the 
Source Details window or rolled up from a cost column), and the distribution should be 
$1,000 per month over a 12 month period, then enter $1000 in the last column. The 
remaining $11,000 will display in the Undistributed Amount field. As you enter $1000 in each 
of the other month columns, this Undistributed Amount will decrease. 

After distribution, if the amount in the cost sheet column or the Cost field in the Source 
Details (depending on the source) either increases or decreases in amount, then when the 
earned value sheet is refreshed again, this difference will be reflected automatically in the 
last column of the worksheet. If there is a decrease that takes the last column to a value of 
zero, then the difference will be reflected in the next-to-last column. 

5) Click Save to save the worksheet. 

Change the sheet display options 

The display options allow you to view earned value data in a variety of ways. You can view data: 

 By cost data 

 By a chosen unit of measure (such as hours, linear feet, etc.) 

 For a particular period of time 

Display options are available on the default CBS Codes view, as well as the other views 
available through More Sheets, with one exception: the Earned Value Component view cannot 
set a time period. 

You can change the display options on any of the views available through the More Sheets 
option. If you set the display options on the default view, then open another sheet through More 
Sheets, the display option settings will be in effect when the second sheet is opened. 
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To change the display options 

1) Open the earned value sheet. 

2) On the toolbar, click the Display Options button. The Display Options window opens. 

3) Choose a Show By option. 

 Cost: this is the default display, showing the EV sheet using cost data 

 UOM: this will display EV data by unit of measure, such as hours. This list is in the Unit of 
Measure data definition, such as hours, feet, etc. 

Note: UOM is not available if EV sheet source is Schedule Manager 
sheet and the BCWP Progress is Activity % Complete.

4) In the Display as of field, click the data picker and choose a date. This setting is optional. If 
you choose a date, the system will use the date as a cut off date and will show earned value 
data as of that date. If you do not select a date, then the display will default to the Last 
Update Date of the EV sheet. 

Choose a date that is no later than today's date, as you cannot choose a date in the future, 
and no earlier than the earliest date for which data is available across the curves. 

Note: This option is not available if EV sheet source is Schedule 
Manager sheet and the BCWP Progress is Activity % Complete, This 
option is also not available for the Earned Value Component view, as 
the columns of this sheet are time based. 

5) Click the Refresh button. This will refresh the sheet to reflect the new display options. 

Add a column to the earned value sheet 

In addition to the system defined columns that are added to the earned value sheet 
automatically (BAC, BCWS, BCWP, ACWP, EAC), you can create columns for your own 
formulas. 

You can define additional columns on a sheet the EV sheet source is Schedule Manager, and 
the display option is set to Show By: Cost. 

To add a column to the earned value sheet 

1) Open the earned value sheet. 

2) Click the Columns button. The Column Log window opens. 

3) Click New. The Column Properties window opens. 

4) Complete the fields and click OK. 

Note: You can create formulas based on any of the columns on the 
earned value sheet. 

In this field Do this 

Name Name the column. 

Datasource Select a data source. Available selections depend upon the level of 
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the earned value sheet. 

Summary Level: 

Select components from the detail-level earned value sheets 
included in the summary sheet settings. Each selection will 
generate a column in the summary earned value sheet. 

Detail Level: 

Earned Value 1 to 25. Allows you to define your own formulas 

Custom curves, BAC, BCWS, BCWP, ACWP, EAC are default 
columns that cannot be edited or deleted. 

Entry Method 

The sheet accepts formulas only. Your options depend upon the 
level of the earned value sheet. 

Summary Level: The entry level is unavailable. 

Detail Level: Requires a formula. Click Create to create a formula. 

Data Format 
Choose Currency or Percentage. This defines how the value is 
displayed on the sheet. 

Display Mode Choose to Show or Hide the column on the sheet. 

Total 

Choose how to display the summary row, which is the last row for 
the column: Blank to leave the summary row blank; Sum of All 
Rows to add up all the rows; or Use Formula Definition to apply 
the columns formula to the last column (based on values in other 
summary rows). 

Column Position 
After 

Choose a column. The new column will be placed after the 
selection. 

Example earned value formulas 

Following are some examples of earned value definitions and formula columns that can be 
added to the earned value sheet. For the examples below, we will start the following values: 

 BAC = $1,000 

 BCWS = $600 

 BCWP = $400 

 ACWP = $750 

 EAC = $1800 

Cost Variance 

Cost Variance (CV) is the difference between a task’s estimated or budgeted cost and its actual 
cost. A negative variance indicates the project or shell is over budget. 

CV = BCWP – ACWP 

Example: $400 – $750 = –$350 
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Scheduled Variance 

Scheduled Variance (SV) is the difference between the current progress and the scheduled 
progress of a task, in terms of cost. It is a comparison of the amount of work performed during a 
given period to what was scheduled to be performed. A negative variance means the project or 
shell is behind schedule. 

SV = BCWP – BCWS 

Example: $400 – $600 = –$200 

Cost Performance Index 

Cost Performance Index (CPI) is the ratio of budgeted costs of work performed to actual costs of 
work performed. A value of less than 1 (less than 100%) indicates that the project or shell is over 
budget, and you are getting less work per dollar than planned. 

CPI = BCWP/ACWP 

Example: 400/750 = 0.53 or 53% 

Scheduled Performance Index (SPI) 

Schedule Performance Index (SPI) is the ratio of budgeted costs of work performed to budgeted 
costs of work scheduled. A value of less than 1 (less than 100%) indicates that the project or 
shell is behind schedule. 

SPI = BCWP/BCWS 

Example: 400/600 = 0.67 or 67%. 

Cost Schedule Index (CSI) 

The Cost Schedule Index (CSI) reflects the relationship between CPI and SPI. The CSI value 
should be close to 1.0. The farther the value from 1.0, project or shell recovery becomes more 
difficult to achieve. 

CSI = CPI x SPI 

Example: 0.53 x 0.67 = 0.3551 

To Complete Performance Index (TCPI) 

The To Complete Performance Index (TCPI) is the ratio of the work remaining to be done to 
funds remaining to be spent as of the status date. A TCPI value greater than 1 indicates a need 
for increased performance; less than 1 indicates performance can decrease. This helps 
determine how much of an increase in performance is necessary on the remaining project or 
shell tasks to remain within budget. 

TCPI = (BAC - BCWP) / (BAC - ACWP) 

Example: ($1,000 – $400) / ($1,000 – $750) = 2.4 

Variance at Completion (VAC) 

VAC is the difference between the BAC) and the EAC. 

VAC = BAC – EAC 
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Example: $1,000 – $1,800 = –$800 

Filter Earned Value sheets by CBS code 

Schedule sheets and earned value sheets share the CBS code associated with schedule sheet 
activities. (For more information about this, see the Schedule Manager setup instructions in the 
Unifier Administration Guide.) Because of this association, earned value sheets can display 
schedule sheet data, and you can filter this data by CBS codes. You can graph filtered data and 
view the results by currency or percentage. 

If your administrator included an "Activity Earned Value Filter" field on the schedule sheet 
attribute form, you can further refine earned value filters by activity criteria, such as progress. If 
this field is on the form, you can include or exclude specific activities from the Master Schedule 
Sheet. 

To create a filter 

1) From the Edit menu, choose Filters. The Setup Filters window opens. 

2) Click Add. The Add filter window opens. 

3) Name the filter. 

4) Select one or more segments of a CBS code to create the filter. 

5) Click OK to save the filter. 

To change a filter 

1) From the Edit menu, choose Filters. The Setup Filters window opens. 

2) Click Edit. The Modify Filter window opens. You can rename the filter, or change the CBS 
segments. 

To remove a filter 

1) From the Edit menu, choose Filters. The Setup Filters window opens. 

2) In the Setup Filters window, highlight the filter and click Remove. 

3) Click Yes in the confirmation window. 

This action cannot be undone. 

To apply a filter to the EV sheet 

1) Open the EV sheet in which you want to filter data. 

2) From the Edit menu, choose Filters. The Setup Filters window opens. 

3) Select the filter you want to apply and click Apply Filter. 

The EV sheet will display only those rows that meet the filter condition. You can graph the 
filter data and view it by currency or percentage. 

4) To restore all the rows to the EV sheet, click [Cancel Filter]. 

Filter Earned Value sheets by progress 

If your administrator included an "Activity Earned Value Filter" field on the schedule sheet 
attribute form, you can further refine earned value filters by activity criteria, such as progress. If 
this field is on the form, you can include or exclude specific activities from the Master Schedule 
Sheet. 
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To create a progress filter for the EV sheet 

1) Open the EV sheet that you want to filter by progress. 

2) Click the Filters icon. The Setup Filters window opens. 

3) Click Add. The Add Filter window opens. 

4) Complete the Add Filter form. 

The activity earned value filter uses an "and" condition. This means that it will display all 
activities associated with the CBS codes selected, but will display a BCWS value only for 
those activities with a text entry in the Activity Earned Value Filter column that matches the 
text entry in the filter. 

5) Click OK to save and close the form. 

To apply the progress filter to the EV sheet 

1) Click the Filters icon. The Setup Filters window opens. 

2) Select the filter you want to use and click Apply Filter. 

The filtered EV sheet will display: 

 All the CBS codes specified in the filter 

 Only the values that are specified in the filter 

3) To restore all the rows to the EV sheet, click [Cancel Filter]. 

Save a snapshot of the earned value sheet 

You can save a snapshot copy of the default CBS Codes view of the earned value sheet, as well 
as the Schedule Sheet-Activities view available through the More Sheets option. 

To save a snapshot copy 

1) Open the earned value sheet. 

2) Click the File menu and choose Create Snapshot. 

3) Enter a title for the snapshot and click OK. 

To view a saved snapshot 

1) Open the earned value sheet. 

2) Click the File menu and choose Open. The Snapshot Log opens. 
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3) Select a snapshot and click Open. 

Export earned value data 

You can export a CSV file with the earned value sheet data of any view of the earned value 
sheet, and any worksheet. 

To export the earned value sheet as a CSV file 

1) Open the earned value sheet. 

2) Click the Export button. Save the CSV file to your local drive and click OK. 

Refresh earned value sheets 

You can manually refresh earned value sheets so that they reflect the latest data, depending on 
their source: information from cash flow curves or information such as earned progress from 
schedule sheets. Earned value sheets are automatically refreshed if you make changes to the 
Properties window, Settings tab. 

To refresh an earned value sheet 

1) Select a sheet in the Earned Value log. 

2) Click the Refresh button. 

As data is refreshed, the Last Update column in the log will display In Progress. This may 
take a few moments. When the update is complete, the current date will display in the 
column. You will not be able to access the sheet while the update is in progress. 

Display Earned Value Data as a Graph 

You can view a graphical representation of earned value by clicking the Graph button from the 
Earned Value log window or from an earned value sheet. This is available for the default earned 
value sheet and additional sheets available through the More Sheets option. Earned value data 
can be viewed either by currency over time, or by value percentage over time. The default view 
is currency. 

You must have Adobe Flash Player installed on your system to view earned value graphs. 

To display the earned value sheet as a graph 

1) Open the earned value sheet. 

2) Click the Graph button and select one of the following: 

 All Rows: Shows graphical representation of the sum of all rows on the sheet. 

 Selected Row: Shows graphical representation of the row that is currently selected on 
the sheet (summary or leaf row). 
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Note: The graph displays the names of the curves as they appear as 
column names on the sheet. If you change the name of a custom curve, 
you must also change the column name in order for the name change to 
display on the graph. The graphical display will also automatically 
include any custom curves you have added, even if you have not added 
them as columns on the sheet. You can filter which curves to display. 

To change the view 

Click the Project Currency or Percentage button next to the View By field. Unifier will gray-out 
the current view. 

To filter which graphs are displayed 

1) Click the Curves button. The Filter Graphs window opens. 

2) Select the graphs that you want to display and click OK. 

To change the zoom level of the graph 

Click Zoom and choose Week (W), Month (M), Quarter (Q), or Year (Y). This will change the 
plotting of the graph display (not the data calculations), and enable you to view data by time 
period. Graphs using the Week (W) and Month (M) zoom levels are displayed using the Date 
Format set in your User Preferences. Refer to Unifier General User Guide for details on setting 
the date format in User Preferences. Graphs using the Quarter (Q) or Year (Y) are displayed 
using the Time Scale Format set in the EV Properties General tab. 

Note: Some earned value calculations can lead to a negative number. 
These results are shown on the graphs. 

The zoom level that you choose works with the time period by which data is captured. For 
example, if you are capturing data by the month, and select the zoom level Quarter (Q), the 
graph will display three months of data. If you select the zoom level Year (y), the graph will show 
12 months of data. 
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For example: 

You can create your own time scale by using the scale slider bar at the bottom of the graph. 
Drag to the right or left to experiment with the time scale. 

Note: Custom unit of measure (UOM) - based curves are not shown on 
earned value graphs. 

To reset the zoom level of the graph 

Click Reset to return the graph to the default view. 

To print the graph 

Click the Print icon on the upper right corner of the sheet. 

Creating and Managing Earned Value (EV) Sheets 

This section describes the following procedures: 

 Creating an EV Sheet

 Defining EV Settings

 Creating Custom EV Curves

 Modifying EV Sheet Properties

 Setting Permissions on EV Sheet
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Note: The Source = Cost Sheet option is available for Unifier Shells that 
are integrated with P6. The option Source = Cost Sheet is not available 
for other Shell instances. 

Creating an EV Sheet 

You can create an Earned Value (EV) sheet individually, or by copying an existing EV sheet, 
and as many as you need. 

In a Project or Shell, the EV sheet can be based on a: 

 Schedule Sheet 

or 

 Cost Sheet 

Note: When an EV sheet is based on a schedule sheet, you can create 
a summary EV sheet to compare data (such as baselines) from multiple 
schedule sheets.  

To create an earned value (EV) sheet: 

1) Open a project or shell and click Cost Manager > Earned Value in the left Navigator. 

2) Click the New button. The earned value Properties window opens. 

3) Use the information in the table below to complete the General tab. 

4) Click Apply. Once you click Apply, the Settings tab becomes available; however, the 
Source, Level, and Timescale fields on the General tab will no longer be editable. 

5) Click the Settings tab. The Settings window opens. 

Depending on the level you have selected in the General tab, the Settings tab displays 
different options: 

 If you selected Detail level, you can add the components (such as BCWP, BCWS, 
ACWP, Custom, and EAC curves) that will be used to calculate the earned value from a 
Schedule Sheet or a a Cost Sheet. 

 If you selected Summary level, you can choose the schedule sheets for the EV sheet 
from a schedule sheet. 

Details about defining these settings are in Defining EV Settings (on page 332) . 

6) Click OK. 

In this 
field 

Do this 

Name Name the earned value sheet. 

Descriptio
n 

Enter an optional description. This description is searchable from the 
earned value sheet log. 

Level This option defines the level of the EV sheet as either "detail" or "summary."
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 Use Detail for individual schedule sheets 

 Use Summary to compare values (such as baselines) from multiple 
earned value sheets 

Source 

This option determines the source of the data used to calculate earned 
value. 

The source of the calculations comes from schedule sheets. You can 
choose from any schedule sheet in the project or shell. 

Time 
Scale 

This setting determines the granularity of EV data that will be calculated 
based on source data. 

 By: The choices are Year, Quarter, Month and Week. 

 Format: Choose the format. The choices are determined by the By 
setting chosen. 

Defining EV Settings 

Depending on the level you have selected, the Settings tab displays different options: 

 If you selected Detail level, you can add the components (such as BCWP, BCWS, ACWP, 
Custom, and EAC curves) that will be used to calculate earned value from a schedule sheet. 

 If you selected Summary level, you can choose the schedule sheets for the EV sheet from a 
schedule sheet. 

Adding Detail Schedule Sheet to Summary EV Sheet 

To add a detail schedule sheet to the Summary EV sheet: 

1) On the Settings tab, click Add. The Earned Value log opens and displays all the available 
detail-level EV sheets. 

2) Highlight the sheet(s) you want to add to the summary sheet. 

3) Click Open. 

4) Click OK.

Adding Cost Curve to an EV Sheet 

To add a cost curve to an EV sheet: 

1) On the Settings tab, click Add. The Select a Type window opens. 

2) Click the Type drop-down list, and select the curve to add. 

 BCWS: Budgeted Cost of Work Scheduled.  

If you choose this option, you must specify where the budget comes from. 

 BCWP: Budgeted Cost of Work Performed.  

If you choose this option, Unifier identifies the progress source (if you are using the 
Schedule Manager as a source). 

 ACWP: Actual Cost of Work Performed.  

If you choose this option, you must specify the cost sheet column. 

 Custom
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If you choose this option, you will have to specify curve parameters in a Properties 
window. See the next section, Creating Custom EV Curves for details. 

 EAC: Estimate at Completion. (Available when the source is the Schedule Manager)  

If you choose this option, you must include cost and start/finish information from the 
schedule manager. 

3) Click OK. The entry will be added to the Settings tab of the earned value Properties window. 

Note: Adding settings updates the earned value (EV) sheet. This can 
take a few moments. The Last Update column on the earned value log 
displays an "In Progress" message while the sheet is being updated. 
The EV sheet will not be accessible until the update is complete. 

BCWS: Source = Cost Sheet 

If you choose BCWS as the Type, and your Source is Cost Sheet, then you will define BCWS 
based on a cash flow curve. 

Note: If you want to retain the data from previous curve, retain the 
values of Spread, Budge, and Apply Form. 

In this field Do this 

Name Name must be unique 

Description Enter an optional description 

Type Type is BCWS

Budget 

Shell Schedule Type = Duration Based

This drop-down list enables you to: 

 Select a Cash Flow curve that must be used as basis to draw 
the BCWS curve. The system lists all of the family curves 
(Detail Level = CBS). 

 Select a Cash Flow curve in the Cash Flow module. The curve 
is used as a basis for drawing the BCWS curve. All family 
curves (Detail Level = CBS), from the Project or Shell, appear 
in the list. You can select any Cash Flow curve that you prefer 
(Example: Earned Value curve family). The Cash Flow curve 
receives data from a P6 Summary Sheet. The choices are 
curves with the same Time Scale settings as the curves 
selected on the General tab of the EV sheet. 

Shell Schedule Type = Resource Loaded or Cost Loaded

This drop-down list enables you to select the P6 Summary Sheet 
that contains the data needed to draw the BCWS curve, directly. 
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Curve 

Shell Schedule Type = Duration Based

The Curve drop-down list enables you to select one Cash Flow 
curve from Baseline or Custom type curves within the selected 
family.   

By default, this drop-down list is disabled (greyed out), but if you 
select a family Cash Flow curve from the Budget, then the Curve 
drop-down list is enabled and Required. 

Spread 

Note: The following applies when the Shell Schedule Type = 
Resource Loaded or Cost Loaded. 

Select the relevant cost spread from a P6 Summary Sheet. 

Apply From 

Note: The following applies when the Shell Schedule Type = 
Resource Loaded or Cost Loaded. 

Select the date that you want to pull the spread data from P6 
Summary Sheet 

BCWS: Source = Schedule Manager 

If you choose BCWS (Budgeted Cost of Work Scheduled) as the Type, and your Source is 
Schedule Manager Sheet, then you define BCWS based on one or more schedule sheets. 

In this field Do this 

Name Name must be unique 

Description Enter an optional description 

Type Type is BCWS

Budget 

You can add any number of active schedule sheets from the 
project or shell. 

To add schedule sheets, click Add. The Schedule Sheet picker 
opens. The list displays all active schedule sheets in the Schedule 
Manager for this project or shell. Select one or more schedule 
sheets and click Open. 

To remove a schedule sheet from the list: 

Select the schedule sheets that you want to delete from the 
Budget list and click Remove. 

BCWP: Source = Cost Sheet 

When the source is cost sheet, define BCWP based on a percent (%) column from the Project or 
Shell cost sheet. 

In this field Do this 

Name Name must be unique 

Description Enter an optional description 
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Type Type is BCWP

Progress 

Note: The following applies when the Shell Schedule Type = 
Duration Based. 

Click the Progress drop-down list to display the columns on the 
Project or Shell cost sheet that are percent (%) columns. 

In addition to the percent (%) columns, you can select P6 
Schedule.  

If you select P6 Schedule from the drop-down list, then the 
system uses the following to calculate the Progress Spread that is 
used for drawing the BCWP curve: 

 % Complete is per CBS, from the master P6 Schedule 
Summary Sheet  

 BAC is per CBS, from the BCWS curve 

The Progress Spread is maintained in Unifier as data is integrated 
into Unifier from P6.  

Note: You must define a BCWS curve type before creating a 
BCWP curve. 

Unifier processes the data acquired from the master P6 Schedule 
Summary Sheet % Complete to calculate the Progress Amount 
for each Data Date. 

Note: Data Date is a property in each P6 Summary Sheet. The 
system updates the Date each time data is integrated into Unifier 
from P6. Unifier calculates the Progress Amount each time the 
master P6 Summary Sheet data is updated, via P6, and Unifier 
maintains a Progress Spread by data date. 

Note: The following applies when the Shell Schedule Type = 
Resource Loaded or Cost Loaded. 

In addition to % columns from Cost Sheet, the Spread drop-down 
lists all P6 Summary Sheets. 

Spread 

Note: The following applies when the Shell Schedule Type = 
Resource Loaded or Cost Loaded. 

Select the Cost (Cost Spread) that you want to use to draw the 
BCWP curve. 

Use the Spread drop-down list to select the Cost spread that must 
be used to draw the BCWP curve. 

By default, this drop-down list is disabled (greyed out), but if you 
select a P6 Summary Sheet from the Progress drop-down list, 
then the Spread drop-down list is enabled and Required. 
(Dataset: Actual Cost) 
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BCWP: Source = Schedule Manager 

If you choose BCWP (Budgeted Cost of Work Performed) as the Type, and your Source is 
Schedule Manager Sheet, then you define BCWP based on progress (activity and resource) 
captured in a schedule sheet. 

In this field Do this 

Name Name must be unique 

Description Enter an optional description 

Type Type is BCWP
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Progress There is one option: Activity and Resource Progress. 

ACWP: Source = Cost Sheet  or Schedule Manager 

If you choose ACWP as the Type, the setup is the same when the Source is Cost Sheet or the 
Schedule Manager Sheet. You can define ACWP based on Cash Flow Curve or Cost Sheet 
Column. 

The ACWP curve is drawn to scale per data from selected Cash Flow curve.  

In this field Do this 

Name Name must be unique 

Description Enter an optional description 
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Type Type is ACWP

Source 

Choose one of the following: 

Cash Flow and Curve

The drop-down list displays all ‘Actual' or ‘Custom’ type 
curves within the selected family, in the Project or Shell, 
that have the same granularity as defined for the current EV 
sheet. 

Cost Sheet Column

The drop-down list displays cost sheet columns that have 
actual cost data derived from cost business processes, 
including formula columns that include business records in 
the formula. 

Cut-off Date

You can also specify a cut-off date, which will be used to 
filter data retrieved from the column selected. 

Custom 

See the next section, Creating Custom EV Curves for details. 

EAC: Source = Cost Sheet 

EAC (Estimate at Completion) is available when the source is Cost Sheet.  

When you import schedule activities from an external source, such as Primavera P6, Unifier 
needs to determine the spread for the EAC curve. By selecting Import Distribution data (from 
external source in the Default Budget and Progress Method Setup window, Activity Budget 
Distribution Profile block), Unifier will use a linear distribution profile to generate the EAC curve. 

The EAC curve is drawn to scale per data from selected Cash Flow curve.  



Working with Unifier Managers

339

Note: You can use At Completion data from P6 Summary sheets to draw 
EAC curves. 

In this field Do this 

Name Determine the name of the curve. Name must be unique. 

Description Enter an optional description 

Type Type is EAC

EAC 

Schedule Type = Duration Based

Lists all Cash Flow family curves from the Shell where the EAC curve 
has been created. 

Schedule Type = Resource Loaded or Cost Loaded

Select the source for the EAC curve. A list of all P6 Summary Sheets 
included in the Project or Shell is displayed. 
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In this field Do this 

Curve 
Enabled once you select a Cash Flow family curve from the EAC 
drop-down list. The Dataset includes Forecast or Custom type curves 
from the select family curves. 

Spread 
Select the Cost (Cost Spread) that you want to use to draw the EAC 
curve, per timescale on the curve (month, year, quarter, and week). 

EAC: Source = Schedule Manager 

EAC (Estimate at Completion) is available when the source is Schedule Manager.  

When you import schedule activities from an external source, such as Primavera P6, Unifier 
needs to determine the spread for the EAC curve. By selecting Import Distribution data (from 
external source in the Default Budget and Progress Method Setup window, Activity Budget 
Distribution Profile block), Unifier will use a linear distribution profile to generate the EAC curve. 

If you choose EAC as the Type, and your Source is Schedule Manager Sheet, then you define 
EAC based on a start and end point.. 

The EAC curve is drawn to scale per data from selected Cash Flow curve.  
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Note: You can use At Completion data from P6 Summary sheets to draw 
EAC curves. 

In this field Do this 

Name Determine the name of the curve. Name must be unique. 

Description Enter an optional description 

Type Type is EAC
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In this field Do this 

Start Point 

Choose the following options from the schedule manager activity 
attribute form: 

Cost (Required): Choose a Schedule Manager data element that has 
been associated with the starting cost of the forecast. 

Schedule: Choose a Schedule Manager data element with the start date 
that is associated with your forecast information (e.g., Forecast 

Start Date). 

This date will be used in the calculation if the activity has not yet started. 
Once the activity starts, the calculation will default to the "progress as of 
date" if provided, or it will default to the actual start date.. 

End Point 

Choose the following (from the schedule manager activity attribute 
form): 

Cost: Choose a Schedule Manager data element that can provide 
estimated completion cost value. 

Schedule: Choose a Schedule Manager data element with the finish 
date element from the schedule manager that is associated with your 
forecast information (e.g., Forecast Finish Date). 

Creating Custom EV Curves 

You can create custom curves to generate other earned value calculations such as forecast or 
EAC. You must create a BCWS (Budgeted Cost of Work Scheduled) entry before you can create 
a custom curve. This is applicable when the source is either Cost Sheet or Schedule Manager. 

This following sections describe: 

 Custom Curves (Source = Schedule Manager) 

 Custom Curves: Source Details 

Follow the procedure Defining EV Settings (on page 332) as the Type. 

Custom Curves (Source = Cost Sheet or Schedule Manager) 

Use the information in the following table to complete the fields for Custom Curves: 
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In this field Do this 

Name Name must be unique 

Description Enter an optional description 

Type Type is Custom 

Curve Properties 

This determines the shape of the curve that will be generated. 
Choose one of following options: 

 S-Curve: The system will generate the curve based on 
Curve Shape (sigma) and Center Location (mu). The 
system will generate data points (intermediate points) for 
the curve. 

 Linear: This generates a straight line curve. The system 
generates data points for the curve. 

 Manual entry intermediate points: This generates a 
curve based on data you enter, distributed over the time 
period range of the curve. 

Start Point 

This determines the start point of the curve. You define the 
starting value (Data), and when the curve should start 
(Schedule). 

Data: Choose an option: 

 Zero: curve starts at zero. 

 Begin calculations at end of actual cost of work 
performed

Schedule: Choose an option: 

 Manual Start Date: You can choose a start date for the 
curve in the Source Details window 

 Schedule Manager Start Date: Click the pull-down. This 
lists the date-type data elements that are on the Activity 
Attribute form. Choose which to use as the curve start date.

End Point 

This determines of the end point of the curve. You define the 
end value (Data) and when the curve should end (Schedule). 

Data: Choose an option: 

 Manual: Allows you to enter cost data in the Source Details 
window. 

 Cost Sheet Column: Click the drop-down list. This lists all 
columns defined on the cost sheet. The values that are in 
that cost sheet column will display in Cost column on the 
Source Details window. 

Schedule: Choose an option: 

 Manual Finish Date: You can choose a finish date for the 



Unifier Managers User Guide

344

curve in the Source Details window. 

 Schedule Manager Finish Date: Click the pull-down. This 
lists the date-type data elements that are on the Activity 
Attribute form. Choose which to use as the curve end date. 

Source Details 

This allows you to enter any manual information required to 
generate the curve. 

Click Details. The Source Details window opens. The Source 
Details window is based on the other options selected in the 
Properties window. 

See the following section for more information about the 
Source Details. 

Custom Curves: Source Details 

Data displayed on the window is based on several options chosen during setup of the sheet: 

 The source chosen on the General tab (Cost Sheet or Schedule Sheet) 

Cost Sheet: All CBS Codes on the Cost Sheet are listed. 

Schedule Manager: Depending on which schedule sheets are selected for BCWS 
calculation, and whether any schedule sheet is linked to a work package, the CBS codes 
may be filtered by the CBS codes on the work package. 

 The budget option selected for BCWS entry. 

 Options selected on the custom entry. 

Fields on this sheet may be editable depending on the options you chose in the Properties 
window. 

Note: When you click Details, on the Properties window, the system 
saves the curve even if you click Cancel to exit the Properties window. 

Column Description 

CBS Code 
All CBS codes on the project/shell cost sheet are displayed, with 
one exception: 

If the schedule sheet(s) in the BCWS entry are associated with 
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work packages, rather than the cost sheet, then only those CBS 
codes within those work packages will be displayed here. 

If at least one schedule sheet in the BCWS entry is associated with 
the cost sheet, then this window displays all cost sheet CBS codes.

CBS Item The item, as defined on the cost sheet, displays for each code. 

Cost 

The details presented in this column depends on what you select in 
the Properties window for End Point, on the Custom Curves Details 
window: 

Data

 If you chose Manual, then you can enter cost data manually 
here. You can also import this cost data (see the following 
procedure). You can later distribute this amount across the 
Custom Curve worksheet. 

 If you chose a Cost Sheet Column, then the data that is in the 
column for each CBS code will display here. 

Cost Sheet

The data that is in the column for each CBS code displays here.

Schedule

Each activity on the schedule sheet can be associated with one 
or more CBS codes, and distributed based on % entered there. 

Start 

The details presented in this column depends on what you select in 
the Properties window for Start Point, on the Custom Curves 
Details window: 

 If you chose Zero (Data), and Manual Start Date (Schedule), 
then you can enter date manually. 

 If you chose Zero (Data), and selected a Schedule Manager 
start date (Schedule), then the column displays the earliest date 
across all activities for that CBS code. 

 If you chose begin calculation at end of ACWP, then the date is 
automatically calculated based on ACWP end period. 

Finish 

The details presented in this column depends on what you select in 
the Properties window for the End Point Schedule, on the Custom 
Curves Details window: 

 If you chose Manual finish date, then you can manually enter a 
finish date for the custom curve. 

 If you chose Schedule Manager finish date, this date is taken 
from the schedule sheet finish date you chose in the Properties 
window. 

To enter data in the Source Details window: 

1) Open the custom curve Source Details window: 
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For the earned value sheet, open the EV Properties window, Settings tab. Select a custom 
curve and click Modify, or create a new custom curve. In the custom curve Properties 
window, click the Details button. 

2) Depending on the options defined in the custom curve Properties window, the Cost, Start
and/or Finish Date fields may be editable across the CBS codes. Add this information as 
needed. 

 Start is the starting date of the curve. 

 End is the end date of the curve. 

 If you enter a value in the Cost column, the value automatically appears in the last 
column of the incremental view of the worksheet for the custom curve. You can then 
open the worksheet and distribute this cost amount across the other columns (and the 
other time periods) in the worksheet. (See View and work with worksheets (on page 
321).) 

To import cost data into the Source Details window: 

1) Open the custom curve Source Details window: 

For the earned value sheet, open the Properties window, Settings tab. Select a custom curve 
and click Modify, or create a new custom curve. In the custom curve Properties window, 
click the Details button. 

2) Click the Export button and download the CSV file. Save the file to your local drive or open 
the file directly. 

3) Enter the cost or date information in editable Start, End and/or Cost fields as applicable, 
depending on the entry settings you specified in the custom curve Properties window. 

4) Save the CSV file. 

5) In the Source Details window, click Import, and import the CSV file. 

Modifying EV Sheet Properties 

You can modify most of the Properties information on existing EV sheets, including adding 
additional curves, entering source detail information, changing the sheet name, etc. 

Note: Source and Time Scale, as defined on the EV Properties window 
(General tab) cannot be modified on an EV sheet. 

To modify EV sheet properties: 

1) Open a project or shell and click Cost Manager > Earned Value in the left Navigator. 

2) In the log, select a sheet and click Properties on the toolbar. 

 Click General tab to change general properties information. 

 Click Settings tab, then select a curve and click Modify to modify the settings for the 
curve. 

Note: If you rename a custom curve (in the Settings tab), the new name 
may not be reflected in the graphical display. The graph displays the 
curve names as they appear in the sheet as column names. If you 
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rename a custom curve, be sure to rename the corresponding column 
name on the sheet (you may need to add the curve as a column in order 
for the new name to be reflected on the graph). 

Deleting EV Sheet 

You can delete any earned value sheet. 

To delete an earned value sheet 

1) Open the project or shell and click Cost Manager > Earned Value in the left Navigator. 

2) In the log, select a sheet and click Delete on the toolbar.  

3) Click Yes to confirm. 

Setting Permissions on EV Sheet 

After creating an earned value sheet, you can determine which other project or shell team 
members can access it. These sheet level permissions can be assigned by the creator or a user 
with Full Access permission in the Earned Value module. 

Sheet level permissions are setup on each earned value sheet in User Mode. 

To assign permissions to an earned value sheet 

1) Select a sheet in the Earned Value log. 

2) Click Permission. 

3) Add users or groups and assign permissions: 

 Modify Permissions: Allows the user to modify the permissions of the earned value 
sheet. Selecting this permission will select all permissions below. 

 Edit Data: Allows the user to edit earned value data, properties and columns. 

 View: User can view earned value data and curves. 

4) Click OK. 

About Schedule of Values (SOV) 

When a Base Commits Business Process (BP) is approved, it creates a Schedule of Values 
(SOV) sheet. The SOV sheet is the "working document" on which committed amount are 
entered. The committed monies shown on the SOV sheet are rolled up to the Company Cost 
Sheet. 

Note: The Change Commit BPs continue to change or add costs to the 
SOV during the life of the Project/Shell. 

Unifier Schedule of Values (SOV) functionality provides a way to assemble information from 
contract, change order, and invoice/payment BPs into a SOV sheet, streamlining the process of 
invoicing for completed phases of a Project/Shell. 
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SOV functionality is available for Cost type BPs in which the "Allow creation of Schedule of 
Values" option is defined, or selected, in the design properties. The BPs can be designed to 
create an SOV sheet automatically upon reaching the designated step. 

You may define one SOV sheet per Commit BP, for example, a Purchase Order or a Contract. 
Rows are automatically populated based on the CBS/Cost/Accounts codes defined in the 
Commit BP. 

Similar to the Cost Sheet, you can create SOV sheet views for better view of data. From the 
SOV sheet log (User mode > Cost Manager > Schedule of Values > General Spends), you 
can open:  

 BP records 

 Base Commits BP records 

When you double-click the SOV Sheet of a Base Commits BP record, a window opens that 
enable you to see the SOV of the Base Commits BP record. 

In the Schedule of Values: General Spends window, when you select a SOV Base Record, 

you can click the gear menu ( ) and perform one of the following: 

 Open a record (Open) 

You can also open a record by clicking the record number link in the Properties tab 
(right-hand pane of the log window). 

 Set permissions for a record (Permissions) 

 Open a SOV Base Record in Standard View (Open Base Record) 

 Open a record in Classic View (Open Classic Interface) 

When you open an SOV Base Record, the Lineitem Type column includes an active data 
element link, which enables you to access the line item and edit the data. 

When you open an SOV Base Record, the following tabs are displayed on the right-pane: 

 General

 Breakdown

 Attachments

In classic view, you could add attachments, but in the standard view this option is not 
supported.  

 Notes

 Fund Assignment Order

The contents of this tabs are read-only, and the View Transactions is similar to Cost Sheet. 

Types of SOV Sheets 

The following lists the types of Schedule of Values (SOV) sheets: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

General Spends
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Use the General Spends SOV type for any Commit Business Process and associated Change 
Commits and Spends/Invoices. 

Payment Applications

Use the Payment Applications SOV type: 

 In association with Commit and Spends Business Processes that are designed for payment 
applications. This allows direct entry of values in an SOV sheet, which are automatically 
added to a payment application. 

 For invoicing at the CBS or breakdown level. Payment Applications auto-populate data to 
and from the SOV to manage balance-forward formulas. The breakdown is similar to the 
General Spends SOV sheet. 

Note: The General Spends and Payment Applications SOV types can 
show CBS information either by grouping CBS codes (CBS mode) or as 
individual line items from commits (base commit and change commit 
together). The information that the SOV displays is dependent upon the 
design of the base commit. 

Summary Payment Applications

The Summary Payment Applications SOV allows users to allocate cost to line items based on 
the line item type (Lump Sum or Unit Cost). 

Use the Summary Payment Applications SOV type in association with Commit and Spends 
Business Processes (BPs) that are designed for Summary payment applications SOV type. 

Note: The Summary Payment Applications sub-node will be available 
under the Schedule of Values node only if a Base Commits, or Change 
Commits, of SOV type Summary Payment Applications is deployed in 
uDesigner. 

Creating an SOV Structure 

The SOV structure is defined at the Project level (User Mode). Any modifications applied to an 
SOV structure will be reflected on all SOV sheets using that structure, that is, all SOV sheets 
used in a Project. If an SOV structure does not exist when you auto-create an SOV sheet with a 
Cost type Business Process (BP), one will be created automatically with the default columns 
CBS Code, CBS Item, and Breakdown. You can edit this structure as needed. The default 
columns are not editable. 

This section explains how to create, view, add columns to, and edit an SOV sheet structure. 

Follow these steps to create an SOV sheet structure: 

1) Open the Project/Shell, switch to User mode, and click Cost Manager > Schedule of 
Values in the left Navigator. 

2) In the Navigator, click one of these options: General Spends, Payment Applications, or 
Summary Payment Applications to open the Schedule of Values log. 

If SOV sheets related to your options are already present, then a structure already exists and 
you can click Update Structure to update the existing structure. 
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3) Click the Create Structure button. The Select Template window opens. 

4) Select an SOV template from the list and click OK. 

5) Read the confirmation message and click Yes to confirm. The SOV sheets will be created 
using the structure defined by the template. You can use this structure as is or make edits as 
necessary. 

Follow these steps to view, or to set up, the SOV structure: 

1) From the Schedule of Values log, click the Update Structure button the toolbar to open the 
SOV Structure window and view the contents and information that is listed under each 
column. 

2) Click the Columns button to begin the process of adding additional columns. 

3) In the Columns log window, click New to open the Column Properties window. 

4) Enter a name for the column in the Name field.. 

5) Select a data source from the Datasource drop-down list. 

6) Select a Display Mode to determine whether the new column should appear on the SOV 
sheet or not. 

7) Select a position for the new column from the Column Position After field. 

8) Click OK. 

Notes: 

 While setting up the SOV structure, you may click the Split button to 
divide the window in half. This allows you to scroll through columns 
and rows on the right while maintaining a view of the activity column 
on the left. Clicking the Split button again restores the whole 
window. While the window is split, you may click the Freeze button to 
lock the left half of the window in place. Click Freeze again to 
unfreeze. 

 The structure may contain hidden columns. For example, one or more 
columns used in the formulas for other columns where the 
information in the hidden columns is not important to be viewed may 
have been hidden, leaving more room in the display for the formula 
column. Hidden columns otherwise behave normally. 

Follow these steps to edit an existing SOV structure: 

1) From the Schedule of Values log, click Update Structure to open the SOV Structure 
window. 

2) Click the File menu and choose Properties to open the Properties window. 

3) Make edits as needed in both General and Options tabs and when finished, click OK. 

Note: You cannot edit read-only (grayed-out) fields. 
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Creating General Spends SOV Sheet 

Typically, Commit Business Processes (BPs) such as Contracts and Purchase Orders, will be 
designed in uDesigner to automatically create an SOV sheet upon reaching a specified status. 
Occasionally, the Business Process (BP) may allow manual sheet creation. 

When you create and send a Cost-type BP in a Project, Unifier automatically creates a Schedule 
of Values (SOV) sheet for that BP record. The General Spends SOV sheet column structure 
must include required columns and correct formulas for validating summary commitments (by 
Cost code) and remaining commits balance. You need to define a formula for remaining commits 
balance, which reflects the amount of commits minus actual spends. This is to ensure that the 
Spends BP line items are not overdrawn from SOV breakdowns. 

Once the SOV template structure is set up for a General Spends SOV sheet, the rest of the SOV 
sheets are created based on the same structure. 

Note: If you manually create an SOV sheet, you can only create one 
based on an approved commit BP record. 

Follow these steps to create a General Spends SOV sheet manually: 

1) In the Schedule of Values log, click the New button. The Select Commit window opens. 

2) Select a commit BP (e.g., a purchase order) and click OK. The SOV sheet is added to the 
log. 

Note: If the commit BP has been set up in uDesigner to automatically 
create an SOV sheet upon the end step, the above procedure is not 
required. 

To view cell details, click a link (e.g., Amount or Ref) to open the Cell Detail window. 
Double-clicking on a record from the list window shows the details of the record. 

Creating Payment Applications SOV Sheet 

You can define the structure of a Payment Applications SOV sheet based on a Payment 
Application Business Process (BP) in the Project/Shell. 

The Payment Applications SOV type: 

 Allows tracking of payment schedule against your commits similar to industry-standard 
forms. 

 Allows you to create a breakdown for line items. 

The Payment Applications SOV sheet column structure uses Data Elements (DEs) from the 
Detail form. Once the SOV template structure is set up for a Payment Applications SOV sheet, 
the rest of the SOV sheets are created based on the same structure. 

Follow these steps to create a Payment Applications SOV sheet, manually: 

1) Open the Project/Shell, switch to User mode, and click Cost Manager > Schedule of 
Values in the left Navigator. 

2) Select Payment Applications. 
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3) Click the New button to open the Select Commit window. 

4) Select a Commit BP such as a Purchase Order and click OK. The SOV sheet is added to the 
log. 

Note: If a BP has been set up in uDesigner to automatically create a 
Payment Applications SOV sheet upon the end step, the above 
procedure is not required. 

From the right-hand pane, Schedule of Values: Payment Applications window, you have the 
option to click the record number and open the base record. The gear icon, for each SOV Base 
Record, enables you to:  

 Open

Open a record. 

 Permissions

Set permissions to a record. 

 Open Base Record

Open the base record. 

 Open Classic Interface

Open the base record in Classic View. 

In the Schedules of Values window of a base record, the Ref column displays information when 
you select an SOV line item type as individual Commit Lines. The Ref column is not displayed 
when you select an SOV line item type as Group by Commit Codes. 

The right-hand pane tabs of the CBS Code, when you click a CBS Code, are: 

 General tab 

 Breakdown tab 

You can add breakdown for each row in the right-hand pane, under the Breakdown tab. 

 Attachments tab 

The added attachments will be shown in a grid similar to cost sheet. You cannot not add 
attachments in this tab. 

 Notes tab 

The CBS notes added in the cost sheet will be displayed here. You cannot add notes in this 
tab.   

In the Schedules of Values window of a base record, the Schedule Value lists a series of 
values, when you click on a value, the following tabs are displayed on the right-hand pane: 

 Line Items tab 

The tab displays all of the transactions in the cell. 

 Cell Details tab 

 Attachments tab 

 Notes tab 

You can reorder rows by drag and drop in the sheet, similar to General Spends SOV. 
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Creating Summary Payment Applications SOV Sheet Structure 

The Summary Payment Applications SOV is associated with the Base Commits, Change 
Commits, and Payment Applications Business Processes of Summary Application type. 

You can access the Summary Payment Applications node based on your permission, which is 
set in Access Control. 

The log window (Schedule of Values: Summary Payment Application for <BP name>) is similar 
to the Payment Applications log window, except the title. The log window displays multiple 
application type. 

In the log, you can create or update the structure of a Summary Payment Applications SOV 
sheet, related to a Base Commits Business Process of SOV Type = Summary Payment 
Applications. You also add items to, or remove items from, the columns and modify the SOV 
structure. 

The following is a list of default structure within a column 

 Ref. 

 Cost Code [CBS Code/bitemID] 

 Code Name 

 Cost Line item Type [uuu_cost_li_type (Label comes from DE label of uuu_cost_li_type] 

 Description 

Note: Different Summary Payment Applications might have different 
columns, but the default structure will always be the same. 

You can modify the following default column names: 

 Ref. 

 Cost Line Item Type 

 Description 

To modify the default column names, use the Options tab of the SOV Structure Properties 
window. 

Note: The Cost Code [CBS Code/bitemID] and Item labels will be based 
on the Cost Sheet and are disabled. 

If you auto-populate the Payment Application with the Line Item fields from the Base Commits 
(done in Options tab of the Base Commits in uDesigner), then these fields are available to be 
added as columns in the SOV. 

Note: If there are any picker fields that refer to other sources, such fields 
cannot be added as a column. The drop-down list of the Auto-populate 
on Payment Application field includes the datasources. 

Adding columns is similar to adding columns for Payment Applications SOV (including all Data 
elements from Payment Applications BP, and additional sources such as Scheduled Value, 
Commits Remaining Balance, etc.). 



Unifier Managers User Guide

354

Additional system fields introduced in the Detail form of the Payment Application BP should be 
available to be added as columns.  

Note: Summary and Detail line items are displayed for the logical source 
that you have added to the SOV sheet, for example, Commits 
Remaining Balance. 

From the right-hand pane, Schedule of Values: Summary Payment Applications for <BP 
NAME> window, you have the option to click the record number and open the base record. The 
gear icon, for each SOV Base Record, enables you to:  

 Open

Open a record. 

 Permissions

Set permissions to a record. 

 Open Base Record

Open the base record. 

 Open Classic Interface

Open the base record in Classic View. 

When you open a record, in the Schedules of Values: Summary Payment Application
window of a base record (, the following toolbar options are available: 

 Refresh

 Print

 Find on Page

 Menu drop-down option (three-horizontal lines icon) 

This option enables you to export or access the record properties. 

Use Expand-Collapse option (the plus or minus icon) to adjust the list view. 

When you open a record, in the Schedules of Values: Summary Payment Application
window of a base record (Payment Application BPs of Summary Payment Application SOV 
type), the Ref column displays information when you select an SOV line item type as individual 
Commit Lines. The Ref column is not displayed when you select an SOV line item type as Group 
by Commit Codes. 

The right-hand pane tabs of the CBS Code, when you click a CBS Code, are: 

 General tab 

 Attachments tab 

The added attachments will be shown in a grid similar to cost sheet. You cannot not add 
attachments in this tab. 

 Notes tab 

The CBS notes added in the cost sheet will be displayed here. You cannot add notes in this 
tab.   

In the Schedules of Values window of a base record, the Schedule Value lists a series of 
values, when you click on a value, the following tabs are displayed on the right-hand pane: 
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 Line Items tab 

The tab displays all of the transactions in the cell. 

 Cell Details tab 

 Attachments tab 

 Notes tab 

You can reorder rows by drag and drop in the sheet, similar to General Spends SOV. 

Granting Permissions to Other Users 

The creator of a Commit BP becomes the owner of the associated SOV sheet and can grant 
permission to other users to view or modify the SOV sheet. 

Follow these steps to grant permissions to other users or groups: 

1) Open the SOV sheet from the Schedule of Values log (Cost Manager > User mode > 
Schedule of Values). 

The SOV sheet displays a structure with fields that are populated by the values in the commit 
BP. 

2) The Schedule of Values log (right-hand pane) displays the available records. From the 
toolbar, click to select a record and click Permission. 

3) From User/Group Name block, select users or groups. 

4) From Permissions block, select the permissions that you want to grant (Modify Permission
or Edit, or both). 

5) Click Apply and then click OK. 

Granting Permissions to Other Users (Standard View) 

The SOV sheets can be seen for project-level or shell-level Commit BPs, only. The following 
applies to the project-level or shell-level SOV sheets.  

The creator of a Commit BP becomes the owner of the associated SOV sheet and can grant 
permission to other users to view or modify the SOV sheet.  

Follow these steps to grant permissions to users or groups, other than the sheet owner: 

1) Open the Schedule of Values log (Cost Manager > User mode > Schedule of Values > 
for example: General Spends). 

2) In the General Spends log click the Actions toolbar option and click Permissions. 

Project or Shell Level SOV Sheets (Standard View) 

The following details apply to logs of all the following types of the SOV Sheets:  

 General Spends 

 Payment Applications 

 Summary Payment Applications 

When you open the SOV sheet from the Schedule of Values log (Cost Manager > User mode 
> Schedule of Values > for example: General Spends), you will see: 
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 Toolbar options 

 Grid 

 Right-hand pane 

The following explains the toolbar options. The explanations for the grid and the right-hand pane 
will follow. 

Create
Note: This option is available in toolbar of the 
General Spends type and the Payment Application 
type SOV logs, only. This option is not available for 
the Summary Payment Application type SOV log. 

Enables you to create an SOV. This option is available only if: 

 You have permission to create an SOV. 

 There are Commits BP records (without a created SOV) in Terminal 
step. 

When you click Create, the Commits window opens that lists all of the 
Commit BPs for which an Schedule of Value (SOV) has not been created, 
yet. Use the Find on Page option to search for a particular Commits BP 
record. The column headers are according to the Commits BP log column 
headers in uDesigner. 

Once you select a Commits BP record from the list, Unifier creates the 
SOV for the selected record. 
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Create 
Structure

You will see this option on the toolbar if: 

 You have permission to edit the SOV structure. 

 The SOV structure has not been created, yet. 

The Create Structure option in the General Spends type SOV sheets: 

 When an SOV sheet has not been created, and there are no General 
Spends SOV templates defined at the company-level (Company 
Workspace > Templates), then when you click this option Unifier 
displays this message, "No General Spends SOV Template exists." 

 When an SOV sheet has not been created, and there is one, or more, 
General Spends SOV templates defined at the company-level 
(Company Workspace > Templates), then when you click this option 
you will see a list of templates that have been defined at the 
company-level (Company Workspace > Templates). When you 
select a template from this list, Unifier displays this message, "You 
may create only one SOV structure per project. Do you want to 
continue?" If you select Yes, then Unifier creates a default SOV 
structure and displays this message, "Structure created successfully." 

The Create Structure option in the Payment Applications or Summary 
Payment Applications type SOV sheets: 

When you click Create Structure, the SOV Structure window opens. See 
"Update Structure" for the details on the SOV Structure window. 
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Update 
Structure

You will see this option on the toolbar if you have permission to edit the 
SOV structure when an SOV structure has been created. When you click 
this option, the SOV Structure window opens. The following elements are 
accessible in this window: 

 Add Column (the plus symbol icon): When you click this option, the 
New Column window opens which enables you to set the column 
properties. You can edit fields that are allowed, only. 

 SOV Structure Properties (the grid and plus symbol icon): When you 
click this option, an overlay window (SOV Properties) opens which 
contains the following blocks: 

 General: Displays the Name and Description fields. 

 Labels: displays all the fields in the Classic View of of the Options 
tab (Update Structure > File > Properties window). 

 Find On Page

 Name column 

 Data Source column 

 Data Format column 

 Visible column 

For each SOV structure that is listed you have the following options: 

 Delete 

 Menu (the three horizontal bar icon): Enables you to open the 
Permissions window (similar to Non-Workflow BP or Cost Sheet log). 
You can use this window to grant or edit permissions to user or groups. 
All permission fields are read-only. 

Actions To access the Permissions window. 

Refresh To update the list on the screen. 

Print To print the items on the log. 

Search To search for a SOV structure. 

Find on 
Page

To find an item on the page. 

When you open the SOV sheet from the Schedule of Values log (Cost Manager > User mode 
> Schedule of Values > for example: General Spends), you will also see the grid and the 
right-hand pane. 

The gird displays the columns shown in the General Spends SOV sheet log (Classic View). 

The right-hand pane displays details related to a record and if there are no details, the following 
message, "You do not have any details for this view." is displayed on the screen. 
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Managing SOV Structure, Templates, and Sheets 

The following topics apply to all SOV sheets. This section explains the following: 

 Editing SOV sheet 

 Editing SOV columns 

 Deleting SOV sheet 

 Searching for SOV sheet 

 Managing SOV sheet data 

 Exporting SOV data 

 Viewing and editing SOV sheet properties 

Editing SOV sheet 

1) Open the SOV sheet from the Schedule of Values log (Cost Manager > User mode > 
Schedule of Values). The SOV sheet displays a structure with fields that are populated by 
the values in the commit BP. 

2) Open the Project/Shell, switch to User mode, and click Cost Manager > Schedule of 
Values in the left Navigator. 

3) In the Navigator, click one of these options: General Spends, Payment Applications, or 
Summary Payment Applications to open the Schedule of Values log. 

Note: If SOV sheets related to your options are already present, then a 
structure already exists and you can click Update Structure to update the 
existing structure. 

4) Click to select a record from the Schedule of Values log and click Properties from the 
toolbar to open the Properties window for the SOV sheet record that you want to edit. 

5) Click the Options tab and proceed to edit the fields. 

Note: You can enter a custom label for the Ref, Breakdown, and 
Description fields. These are the labels that will appear as column 
names on the SOV sheet. You cannot modify CBS Code and CBS Item. 
These labels can be modified only on the cost sheet. 

6) Click Close to close the Properties window. 

7) Click Apply and then click OK. 

Editing SOV columns 

1) Open the SOV sheet from the Schedule of Values log (Cost Manager > User mode > 
Schedule of Values). The SOV sheet displays a structure with fields that are populated by 
the values in the commit BP. 

2) Open the Project/Shell, switch to User mode, and click Cost Manager > Schedule of 
Values in the left Navigator. 

3) In the Navigator, click one of these options: General Spends, Payment Applications, or 
Summary Payment Applications to open the Schedule of Values log. 

4) Click to select a record from the Schedule of Values log and click Update Structure from the 
toolbar to open the SOV Structure window for the SOV sheet record that you want to edit. 
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Note: If SOV sheets related to your options are already present, then a 
structure already exists and you can click Update Structure to update the 
existing structure. 

5) Click Columns and click to select a column from the Columns Log window. 

6) Click Open to open the Column Properties window and proceed to edit the fields. 

 Notes: 

 Some fields may not be editable. It may be necessary to delete the 
column and create a new one. 

 Although it is possible to change the entry method for a column (for 
example, from line item content to direct entry into a cell) use caution 
when doing so if you have already entered values in the column 
cells. For example, if you change from line item entry to direct cell 
entry, the amount value shown in the cell will display correctly. Since 
this field is an editable field, if you edit this field, the direct entry 
amount and detailed line item information will be lost. 

To move a column, from the Columns log, select a column to move, and then click Move Up 
(Left) or Move Down (Right). The order that the columns appear in the log window is the order 
(from left to right) that they appear on the sheet. 

To delete SOV columns: 

1) Select a column from the Columns log and click Open to open the Column Properties 
window. 

2) Click Delete. The column will be deleted. 

Note: If the column is being used in a formula in another column, you 
must remove the column from the formula before you can delete it. If the 
column contains a cell with line item data, you must first remove each 
line item before it can be deleted. 

Deleting SOV sheet 

Select the sheet from the log window and click Delete. If you delete an automatically created 
SOV sheet, you will have to recreate it manually. 

Note: You cannot delete an SOV for Payment Applications. 

Searching for SOV sheet 

You can search for SOV sheets by the SOV Base Record or SOV Description. 

1) In the Schedule of Values log window, click Find. 

2) In the Search by drop-down list, select SOV Base Record or SOV Description. 

3) In the Search for field, enter the search criteria. Click the Search button. The log will display 
the records meeting the search criteria. 
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Managing SOV sheet data 

SOV data is rolled up from Cost-type BPs that have been set up for SOV sheets. As a result, the 
SOV sheets cannot be edited. 

Exporting SOV data 

You can export SOV data to a local file system in a CSV format. 

1) Select an SOV Base Record and open. 

2) In the Schedule of Values window, click File > Export (or click Export from the toolbar). 

3) Open the file and review it before saving. 

4) Click Save and specify the location in which to save the CSV file. 

Viewing and editing SOV sheet properties 

To open the SOV Properties window, from the SOV log, select an SOV sheet and click the 
Properties button. The Properties window opens. Click the tabs to view properties information. 

To edit SOV sheet properties: 

1) Click the Update Structure button on the toolbar. 

2) Click File > Properties. 

3) Click the Options tab to modify information. 

You can enter a custom label for the Ref, Breakdown, and Description fields. These are the 
labels that will appear as column names on the SOV sheet. 

Note: You cannot modify the CBS Code and CBS Item labels here. 
These labels can only be modified in the cost sheet. 

Adding or Deleting CBS Breakdowns on an SOV Sheet 

CBS breakdowns can be added to an SOV sheet. This enables each contract to have its own 
set of CBS breakdowns. These breakdowns can be added directly on the SOV sheet, or they 
can be imported from a CSV file. Breakdowns can be added to general spends or payment 
application SOVs. 

Note: You cannot add a breakdown to an SOV if there is a pending 
spends record against the row, or a pending change commit with a 
negative line item (which may potentially reduce the Schedule Value 
after routing). 

To add a breakdown to an SOV line 

1) Open the SOV sheet. 

2) Click the Rows button. The Rows window opens. 
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3) Select an SOV line by clicking the checkbox. If you select an SOV line, the breakdown will 
be added to that line. If you select an existing breakdown, the new breakdown will be 
inserted directly below the existing breakdown. 

4) Click the Add Detail button. The Details window opens. 

5) Enter the Breakdown.  

 This will appear on the SOV sheet in the Breakdown column.  

 You can add an optional Description. 

6) Click OK. The breakdown is added to the sheet. 

7) Close the Rows window. 

8) You may need to click the plus (+) by the checkbox on the Rows window and on the SOV 
sheet to expand rows and display the breakdowns. 

To delete a breakdown row 

1) Open the SOV sheet. 

2) Click the Rows button. The Rows window opens. 

3) Select one or more breakdown rows to delete. 

4) Click the Delete Detail button. Click Yes to confirm. 

Adding Breakdowns to SOV sheet by Importing 

If you have multiple breakdowns to enter, you can do it in bulk through CSV file import. You can 
add as many breakdowns as you need to multiple CBS codes. 

You can also optionally enter breakdown scheduled value amounts. In order to do this, there 
must be a column to the SOV sheet using the data source Scheduled Value. The amount you 
enter on the CSV file will appear in the Scheduled Value column. 

Note: By default, the Scheduled Value column will validate that the sum 
of all breakdowns added to an SOV line will not exceed the scheduled 
value for summary line. That is, if the scheduled value for a line is $1000 
from the base commit record, and you add breakdowns, the amounts 
that you enter for the breakdown amounts for that line cannot add up to 
more than $1000. (It can, however, add up to less than $1000.) 

To add breakdowns by importing a CSV sheet 

1) Open the SOV sheet. 

2) Click the Rows button. The Rows window opens. 

3) Click the Export button and choose Breakdowns. 

4) Save the CSV file. This provides the structure for the import file. 

5) Add the breakdown rows to the CSV file. 

a. Open the CSV file. 

b. Insert a line under the CBS code to which you are adding the breakdown. 

c. Add the breakdown name in the Breakdown column. You can enter an amount in the 
Scheduled Value column. Do not add any additional information in the new row. 
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d. Add additional breakdown rows as needed. 

e. Save the file. 

6) On the SOV sheet, click the Import button. 

7) Browse to the CSV file and click OK. The breakdowns and amounts will be added to the 
sheet. Any breakdowns in the CSV file that already exist on the sheet will be updated with 
the Scheduled Value amount on the CSV file. 

If any errors occur, download and open the error file, and correct the CSV file before reimporting. 
Validations include:  

 The sum of breakdown amounts cannot add up to more than the scheduled value amount of 
the summary CBS code line 

 They cannot exceed Commits Remaining Balance, if used 

 They cannot cause Commits Remaining Balance to fall below zero. 

Working with a Generic Cost Manager 

A "Generic Cost Manager" captures cost-related activities for a configurable shell. These include 
costs like: 

 Rent 

 Lease payments 

 Landscape care 

 Building maintenance and repair 

 Remodel of building interiors 

With this manager, you can capture and view cost transaction information based on a timescale, 
such as monthly, quarterly or yearly. Each configurable shell can have one Generic Cost 
Manager. 

Most of the functionality for the Generic Cost Manager is the same as that for the standard Cost 
Manager. Rather than re-document all of the cost management sheet functionality that is 
common between the Generic Cost Manager and the standard Cost Manager, this section 
documents the differences between the managers, and tell you how to use that functionality in 
context of the task you will be performing. 

Note: The names of the Generic Cost Manager, the various shells and 
sub-shells, and the generic cost sheet you will work with are determined 
by the names defined in uDesigner. For documentation purposes, in 
these instructions, this manager is referred to as the Generic Cost 
Manager. 

The Generic Cost Manager: 

 Defines a code structure that can be used to capture cost-related activities for a configurable 
shell. 

 Tracks and rolls up costs to upper management levels 

 Enables interaction with cost data 

 Operating budgets (monthly, quarterly, yearly) 
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 Projects with life cycles that span over extended time 

 Costs covering the entire life cycle of the product/operation 

 Transactions based on timescale 

 Transactions in varying currencies 

The following procedures discuss how to access and work with generic cost sheets. The generic 
cost sheet is created from a template. See Working with Configurable Manager Sheets 
(Standard View) (on page 48) for additional details. 

Data Sources for Generic Cost Sheets 

The Generic Cost Manager uses information in cost sheets that is manually entered, calculated, 
or comes from Generic Cost BPs. The difference between the Generic Cost Manager and the 
standard Cost Manager is that the data used in the Generic Cost Manager comes from shells 
and sub-shells, not from projects. 

The Generic Cost Manager uses specific Cost BPs as a data source. These BPs have the type 
cost and the classification Line Items with Multiple Codes. 

Opening Generic Cost Sheet 

To open a generic cost sheet:  

1) Go to your shell, User mode, and from the left Navigator click Configurable Manager node 
to expand. 

2) Click Generic Cost Manager sub-node to open the Generic Cost Manager log. The log 
lists all of the generic cost sheets. 

3) Click to select a generic cost sheet and click the gear  ( ) menu to open. 

4) Click Open to open the generic cost sheet (Generic Cost Manager overlay window) log. 

You can click Open in Classic View to see the details of the generic cost sheet in classic 
view. See the Opening Generic Cost Sheet (Classic View) (on page 364) for details. 

You work with a generic cost sheet in the same way as a standard cost sheet, seen in standard 
projects and CBS shells. The difference is that the data in the generic cost sheet comes from 
generic shells and sub-shells. The first two columns are displayed by default. The view is fixed, 
and there is no split screen capability. 

Opening Generic Cost Sheet (Classic View) 

To open a generic cost sheet in classic view:  

1) Go to your shell, User mode, and from the left Navigator click Configurable Manager node 
to expand. 

2) Click Generic Cost Manager sub-node to open the Generic Cost Manager log. The log 
lists all of the generic cost sheets. 

3) Click to select a generic cost sheet and click the gear  ( ) menu to open. 
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4) Click Open in Classic View to open the generic cost sheet (Cost Manager pop-up window) 
log in classic view. The pop-up window will display the generic cost sheet in sub-shells, only 
(when you click the Open in Classic View option). 

You work with a generic cost sheet in the same way as a standard cost sheet, seen in standard 
projects and CBS shells. The difference is that the data in the generic cost sheet comes from 
generic shells and sub-shells. The first two columns are displayed by default. The view is fixed, 
and there is no split screen capability. 

Opening Generic Cost Sheet (Structure) 

To open a generic cost sheet structure:  

1) Go to your shell, User mode, and from the left Navigator click Configurable Manager node 
to expand. 

2) Click Generic Cost Manager sub-node to open the Generic Cost Manager log. The log 
lists all of the generic cost sheets. 

3) Click to select a generic cost sheet and click the gear  ( ) menu to open. 

4) Click Open Structure to open the generic cost sheet (Cost Manager pop-up window) log in 
classic view. The pop-up window will display the generic cost sheet structure, only (when 
you click the Open Structure option). 
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Viewing Data for Shells and Sub-shells in Generic Cost Sheet 

The generic cost sheet displays transactional data by period and shell level. In the context of 
working with the generic cost sheet, you can filter the cost data you are viewing by shells or 
sub-shells. The generic cost sheet is accessed from the Shell > Configurable Managers > 
Generic Cost Manager > Generic Cost Sheet log. You can use the shell or sub-shell filter in 
combination with the timescale selector documented in the next section to create various views 
in your spreadsheet based on shell or sub-shell and time period.  

See Working with Configurable Manager Sheets (Standard View) (on page 48) for additional 
details. 

Viewing Data for Shells and Sub-shells in Generic Cost Sheet (Classic View) 

The generic cost sheet displays transactional data by period and shell level. In the context of 
working with the generic cost sheet, you can filter the cost data you are viewing by shells or 
sub-shells. The generic cost sheet is accessed from the Shell > Configurable Managers > 
Generic Cost Manager > Generic Cost Sheet log. You can use the shell or sub-shell filter in 
combination with the timescale selector documented in the next section to create various views 
in your spreadsheet based on shell or sub-shell and time period.  

To view generic cost sheet data by shell or sub-shell 

1) Open the shell and click Configurable Managers > Generic Cost Manager > Generic 
Cost Sheet in the left Navigator. The Generic Cost Sheet log opens. 

2) Open the Generic Cost Sheet you want to work with by double-clicking the cost sheet name 
or by selecting the cost sheet name in the log and then choosing File > Open. 

3) In the View By selection list, choose one of the following: 

 Current Shell only: Data from the current shell you have selected. Manual column data 
is editable in the Current Shell only view. 

 Current Shell and Subshells only: Data from both the current shell and its sub-shells. 

 Subshells only: Data from the sub-shells of the current shell. 

In Generic Cost Sheet views, data is rolled up from the current shell and sub-shells. When data 
is rolled up from sub-shells, the generic cost sheet under a shell can roll up data from other 
shells that are created as sub-shells and their sub-shells. The Current Shell and sub-shells only 
and Subshells only views support this rollup. For example: 

 North Region (shell) 

 Property A (sub-shell) 

 Building 101 (sub-shell) 

 Building 102 (sub-shell) 

 Property B 

 Building 201 

 Building 202 

In this example, the North Region Generic Cost Sheet will have data from Property A, Property 
B, Building 101, Building 102, Building 201, and Building 202. Property A has data from Building 
101 and Building 102. Property B has data from Building 201 and Building 202. 
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Also, data from a sub-shell to its parent shell can only roll up if the codes match. For example, 

 North Region (Shell) 

 Property A (1000–1001: $500) 

 Building 101 (1000–1001: $500) 

 Building 102 (1000–1002:$200) 

In this example, Building 101 will roll up to Property A as the codes match (1000–1001). Building 
102 will not roll up because the codes are different (1000–1002). Parent and child shell cost 
codes must match for roll up to occur. Timescale and column definition must also match across 
the shells and sub-shells. 

Also, all sub-shells that will roll up must have the same currency as the parent shell. If all of the 
sub-shells and the current parent shell have the same currency, the data displays in that 
currency. If at least on sub-shell has a different currency, the data displays in the Base 
Currency. A confirmation message alerts you to this currency display. 

While rolling up, only parent shell generic cost sheet codes should be considered. This is 
applicable under all views. 

Change the timescale on a generic cost sheet 

With the Generic Cost Manager, you can capture and view cost transaction information based 
on a timescale, such as quarterly or yearly. For example, you might be working with time-based 
transactions such as lease payments. In the context of working with the generic cost sheet, you 
can change the timescale on the cost data with which you are working. The generic cost sheet is 
accessed from the [shell name] > Configurable Modules > Generic Cost Manager > Generic 
Cost Sheet log. You can use the shell or sub-shell filter described in Viewing Data for Shells 
and Sub-shells in Generic Cost Sheet (Classic View) (on page 366) in combination with the 
timescale selector to create various views in your spreadsheet based on shell or sub-shell and 
time period. 

To change the timescale on generic cost sheet data by shell or sub-shell 

1) Open the shell and click Configurable Managers > Generic Cost Manager > Generic 
Cost Sheet in the left Navigator. The Generic Cost Sheet log opens. 

2) Open the cost sheet you want to work with by double-clicking the cost sheet name, or by 
selecting the cost sheet name in the log and then choosing File > Open. 

3) Click on the Display Period button. The Display Period window opens. 

4) Select a date range (Monthly, Quarterly, or Yearly) and the time period to go with the 
range. The data for the timescale you select is displayed in the cost sheet. The default view 
is Monthly, and shows the current month. Data is always stored in months. Changing the 
timescale units updates the totals based on the period and the calendar year. 

Monthly view data is editable in the manual columns only, and in the Current Shell view only. 
Quarterly and Yearly views are read-only. 
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Modify shell and base exchange rates for manual data entry 

Data entered manually (directly) on a generic cost sheet should have a rate associated with it. 
This is because any transaction that occurs under a shell will be calculated and stamped with 
two currency rates: the shell currency and Base Currency. The rate in this case will be the 
conversion rate between the shell currency and Base Currency (the Base Currency is the 
company currency). 

When you modify the exchange rate the new rate takes effect for the currency month, and 
applies until you change it again. You can revert it to the rate stored in the shell properties. The 
modified exchange rate applies only to data you enter manually on the sheet. It does not affect 
data that is entered through business processes, which uses the exchange rate from shell 
properties. 

To change the exchange rates on a Generic Cost Sheet for manual data entry 

1) Open the shell and click Configurable Managers > Generic Cost Manager > Generic 
Cost Sheet in the left Navigator. The Generic Cost Sheet log opens. 

2) Open the cost sheet you want to work with by double-clicking the cost sheet name, or by 
selecting the cost sheet name in the log and then choosing File > Open. 

3) Choose Edit > Exchange Rate. The Exchange Rate for manual data entry window opens. 

4) Choose the rate you want to change and enter the rate. Click Refresh to revert to the shell 
property exchange rate as needed. The original exchange rates were set up by the 
Company Administrator. 

5) Click OK. 

To view exchange rate history 

1) Open the shell and click Configurable Managers > Generic Cost Manager > Generic 
Cost Sheet in the left Navigator. 

2) From the View menu, choose Exchange Rate History. 

To view the data in either the shell or Base Currency 

1) Open the shell and click Configurable Managers > Generic Cost Manager > Generic 
Cost Sheet in the left Navigator. 

2) Choose View > Currency > Shell Currency or the Base Currency to view the data in either 
of these currencies. 

Export and import Generic Cost Sheet data 

You can export the structure of a generic cost manager.  

In the Generic Cost Manager log, click the sheet, click the gear icon menu, and select Open 
Structure to open the structure in a new window. From the toolbar options click Export and 
select Cost Codes. Browse to the CSV file to import, select it, and click OK. 

You can export a generic cost sheet, only. 
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In the Generic Cost Manager log, click the sheet, click the gear icon menu, and select Open to 
open the Generic Cost Manager window that displays all of the columns. Click the Menu 

Options , click Export, and select one of the following options: 

a. Summary Sheet

b. Cost Codes

c. Column Data

Proceed with following the prompts. 

Note: If you open the CSV file, you will see that it contains notes 
regarding modifying the columns and data in the exported file for 
reimporting into a cost sheet. Follow the notes embedded in the CSV file 
for modifying columns and data in the exported file. 

Import Generic Cost Sheet data 

You can import the structure of a generic cost manager.  

In the Generic Cost Manager log, click the sheet, click the gear icon menu, and select Open 
Structure to open the structure in a new window. From the toolbar options click Import and 
select Cost Codes. Browse to the CSV file to import, select it, and click OK. 

Working with Generic Cost Business Processes 

The Generic Cost Manager can use generic Cost BPs as data sources. These BPs are created 
in uDesigner. These generic Cost BPs work only with the Generic Cost Manager, and also only 
in the context of a shell. The possible Generic cost BP types are: 

 Generic: Reference against company-level commit; enforce against company-level commit 
amount. 

 Transfer: Transfer value from one code to another. 

 Base Commit: Creates an entry in the Commitment Summary. Works in conjunction with 
change commit and general spends generic Cost BPs. Reference against company-level 
commit; enforce against company-level commit amount. Click the Commitment Summary
button to access the Commitment Summary. 

 Change Commit: Works in conjunction with base commit and general spends generic Cost 
BPs. Updates the Commitment Summary. Reference against company-level commit; enforce 
against company-level commit amount. Click the Commitment Summary button to access 
the Commitment Summary. 

 General Spends: Works in conjunction with base commit and change commit generic Cost 
BPs. Updates the Commitment Summary. Click the Commitment Summary button to 
access the Commitment Summary. 

 Lease: Works in a shell to manage lease payments and payment history. 



Unifier Managers User Guide

370

View and edit the Commitment Summary 

When a base commit record goes to Terminal status, it creates an entry in the Commitment 
Summary for the shell. When change commit and general spends records go to Terminal status, 
they update the associated base commit record in the Commitment Summary. If you have the 
appropriate permissions, you can view and edit the Commitment Summary. 

To view and edit a Commitment Summary for a shell 

1) Open the shell and click Cost Manager > Commitment Summary in the left Navigator. 

2) In the Commitment Summary log, select the Commitment Summary and click Open. 

3) Click Create Structure to add columns to the sheet. 

4) To view or edit the sheet properties, choose Edit > Properties. In the General tab, enter a 
unique name and an optional description. In the Options tab, enter the following column 
names: Ref, Cost Code, Code Name, Breakdown, and Description. 

Depending on the design in uDesigner, some columns may not display in the Commitment 
Summary sheet. 

5) Click OK. 

Drill down from the Commitment Summary to related BPs 

You can view BP information for the various entries in the Commitment Summary. 

To drill down from the Commitment Summary to related BPs 

1) Open the shell and click Cost Manager > Commitment Summary in the left Navigator. 

2) In the Commitment Summary log, click the BP reference in the Commitment Summary. The 
Cell Detail window opens. 

3) Click the Close Window button when you are done viewing the BP information. 

P6, Cost Manager, and Cash Flow 

You can copy the Cash Flow curve properties that exist in a Shell template to the Cash Flow 
curves that exist in instances if: 

 The Shell template push is done 

 The Shell template is used to create new instances 

The system uses the P6 data source that was used in the Cash Flow template as the reference 
for attaining the Summary Sheet data information. 

User mode > Schedule Manager > P6 Summary Sheets

For example, if the Type in your P6 Summary Sheets is Current Schedule, then in the Cash flow 
by CBS - Baseline window the Current Schedule was selected for the Use data from P6 Source 
field. That is to say, if you select data from P6 Source, along with the source and data type, then 
the Cash Flow template has the P6 data source as Current Schedule for your Shell template and 
a new Shell is created in Unifier. The system pushes the Shell template to the new Shell and the 
Cash Flow curves are generated.  
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When the P6 and Unifier are synced, the Shell has been integrated with P6 (i.e., the Type or P6 
data source of the Summary Sheet is Current Schedule) and the Cash Flow data is calculated 
correctly. If the distribution option selected in the Cash Flow template is a valid option for Cost 
loaded Cash Flow curve, then the data in Cash Flow curve is calculated correctly. 

If the properties in the Cash Flow curves are incorrect, then the curves display in red, in the 
Properties window. You must change the Distribution, or Schedule, option if the Cash Flow 
curve is opened based on the Schedule type. 

If the Schedule type of the Shell is Cost- or Resource-based, then in: 

 The Distribution section the "Use data from P6 Source” option is enabled. 

 The Schedule section the "Use dates from P6 Source” option is disabled. 

If the Schedule type of the Shell is Duration-based, then in: 

 The Distribution section the "Use data from P6 Source” option is disabled. 

 The Schedule section the "Use dates from P6 Source” option is enabled. 

See the following sections (Cash Flow Properties Settings: Curves tab (Classic View) (on 
page 179)) for additional information about P6 Data source: 

 Baseline Curve 

 Forecast Curve 

 Actuals (Spends) Curve 
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Unifier Document Manager 

The Document Manager provides a robust platform for maintaining a wide variety of files and 
documents, for example, drawings, spreadsheets, image files, specifications, and various 
Microsoft Office files. Files can be stored directly in the project or shell Documents node or 
organized into folders. You can also create shortcuts to commonly used files and folders. The 
system ensures that all members of your team are always working on the most current versions, 
and dramatically increases efficiencies by providing ready access to all documents from 
anywhere at any time.  

The Document Manager is available at the project or shell level for project- or shell-specific 
documents, and at the company level for company-specific or cross-project or shell documents. 
At project/shell or company level, the Document Manager is integrated with business processes 
and the user-defined reports module. Files uploaded into the Document Manager are stored on 
the Unifier file server. 

The Document Manager is integrated with business processes. This means that you can initiate 
a business process directly from the Document Manager and automatically attach files and 
folders to it. In addition, if designed to do so, any business process can automatically publish 
records, along with their comments and attachments, to the Document Manager. In effect, this 
produces a detailed audit trail of the business process. Depending on how your administrator set 
up the business process, it can be automatically published to the Document Manager at a 
specific step in a workflow, or whenever an email notification is sent regarding the status of the 
business process, or both. 

At both the project or shell level and the company level, the Document Manager consists of two 
nodes: 

 Project or shell/Company Documents: This is the root node where published documents 
(that is, documents that are ready to be used by team members) are stored and managed. 
(The node is labeled project or shell Documents at the project or shell level, and Company 
Documents at the company level.) You will typically work out of this node when working with 
your company or project or shell documents. All uploads, downloads, revisions, markups, 
etc., are performed within this node. Access to specific folders, documents, and shortcuts is 
independently controlled by permissions. 

 Unpublished Documents: This is the temporary, automatic repository for files that have 
been uploaded from local machines and attached to business processes, but which have not 
yet been published in project or shell documents or company documents. Typically, access 
to this node is limited by permissions, and a designated document administrator will publish 
documents from this node into the project or shell or Company Documents nodes for use by 
team members. 

Note: By default, files attached to business processes are placed in the 
Unpublished Documents folder in the Document Manager. A Publish 
Path data element can be designed in business processes in uDesigner 
to specify the automatic publishing of documents to a specified path and 
override the default. 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 
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Before you Begin Working with Document Manager 

Ensure that you have the following defined in your user preferences. 

 File Viewer option: This option affects how files are opened and viewed within Unifier. 

 Additional software applications: Use of the AutoVue viewer markup tool requires a 
license and Java installed. For translation-related information about Oracle Map, AutoVue 
Server, and Flex replacement (O charts). Refer to Unifier General User Guide for more 
information about internationalization. 

 Permission settings: Like other modules within Unifier, access and use of the Document 
Manager is fully permission based, including for specific files and folders. Contact your 
project or shell or company administrator regarding general permission access to the 
Document Manager. 
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Note: For security, the Company Administrators can specify the list and 
size of files that can be uploaded to the Company Properties page, by 
users and per company policy. Contact your Company Administrator for 
more information. 

Downloading AutoVue Client Certificate 

Before you can use AutoVue in Unifier, you must download the AutoVue Client certificate and 
place it in the browser certificate exception list. Follow these instructions for each user accessing 
Unifier AutoVue. 

For more information refer to the "Setup for Java Web Start AutoVue Client in HTTPS 
Environments" page of the Oracle Support (support.oracle.com (http://support.oracle.com/ \t 
_top)), Knowledge tab.  

Downloading on Windows 

To download the localhost certificate: 

1) In Unifier, select Help > Download Plugins. 

2) From the Download page, select the download for the localhost certificate. 

3) Double-click to open the localhost.cer file you just downloaded. 

4) Click Install Certificate... to start the Certificate Import Wizard. 

5) Select the store location (Current User or Local Machine) and click Next. 

6) Select the option Place all certificates in the following store and click Browse.  

7) Select the Trusted Root Certification Authorities store and click OK. 

8) Click Next and click Finish. A dialog box opens warning you about the risk of installing this 
certificate.  

9) Click Yes to accept installing this certificate.  

10) After the install certificate has imported, click OK. 

After installing the localhost certificate, you can use AutoVue client in Chrome. For Mozilla 
Firefox, perform these additional steps: 

1) Open a new tab and type: about:config. 

2) In the Search box,  type security.enterprise_roots.enabled. 

3) Double click security.enterprise_roots.enabled to set the flag to True. 

For more information on installing the certificate in Mozilla Firefox (and if your Firefox version is 
lower than version 49), refer to the mozilla wiki page (https://wiki.mozilla.org): Installing 
Certificates Into Firefox. 

Downloading on Mac OS 

To download the localhost certificate: 

1) In Unifier, select Help > Download Plugins. 

2) Double-click the downloaded localhost.cer file to add it to Keychain Access. 

3) From the Keychain Access window, open the localhost certificate. 

http://support.oracle.com/ t _top
http://support.oracle.com/ t _top
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4) Expand the Trust node and set the value of the Secure Dockets Layer (SSL) field to 
Always Trust. 

5) Close the Keychain Access window. 

Launching AutoVue Web Start Client 

Windows  

 Using Mozilla Firefox 

The AutoVue JNLP file is automatically downloaded and a confirmation message is 
displayed. Select the Open with radio button and click OK. To open AutoVue files 
automatically and bypass the confirmation message, select the Do this automatically for 
files like this from now on checkbox. 

 Using Chrome 

The AutoVue JNLP file is flagged as a dangerous file extension. Each time you open an 
AutoVue file, you must select the Keep option and open the downloaded file from the 
Downloads folder. 

Mac OS 

Modify Security Settings 

1) Click the Apple menu and launch System Preferences. 

2) Select Security & Privacy. 

3) Click the General tab. 

4) For the Allow apps downloaded from option, select Anywhere. 

This option is available for Mac OS X El Capitan. For other Mac operating systems, refer to 
the pertinent installation guides. 

5) Click Allow From Anywhere to confirm your selection. 

Launching AutoVue Files 

 Using Chrome 

When an AutoVue file is opened a confirmation message is displayed. Select Open to open 
the file in AutoVue. 

 Using Safari 

Open Preferences and select the Privacy tab and check the Always Allow option under 
Cookies and website data. The AutoVue JNLP files are permanently saved on the disk, you 
can launch the file from the Downloads folder. 

About Ownership and Permissions 

Like other Unifier modules, access to the Document Manager features is based on permissions 
set at the module level in Administration mode. Each Document Manager node—project or shell 
Documents, Company Documents, and Unpublished Documents—have separate permissions. 
The Unpublished Documents node is controlled by module-level permissions in Administration 
Mode only. 
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In the project or shell and Company Documents nodes, access to specific folders, documents, 
and shortcuts is also independently controlled by permissions that can be set within the 
Document Manager. 

Note: Folder and document permissions are set at the folder level and 
can be changed independently or inherited by subfolders and 
documents. Unlike module-level permissions, permissions set at the 
folder level can differ from project or shell to project or shell. 

The creator of a folder, document or shortcut is, by default, its owner, and has full access 
(privileges to view, manage, grant permissions, delete, transfer ownership, etc.). The owner 
must grant other users or groups permission to view and manage these documents, folders, or 
shortcuts. Otherwise, other users will not have access to them. (Exception: some administrators 
will have access permissions and will be able to view all items in the document manager.)  

For this reason, it is also important to verify the permission settings for all files and folders that 
you upload, create, revise, check in, copy, or modify to make sure that it is accessible by the 
people who need them. For example, if one user creates folders, and then another user 
attempts to move documents among those folders, the move will not be permitted by the system 
unless that user attempting that move has specific permissions granted (in this case, Copy and 
Delete to achieve the document move). 

For more information about permission settings, see View, Add, or Modify Folder Permissions
(on page 404), View or Modify Document Permissions (on page 413), and Modify Shortcut 
permissions. 

Note: Document Manager email notifications as set in User Preferences 
are only sent if the user has at least view permission in the Document 
Manager node on the item triggering the email, and if the item owner 
enables email notification. If you make changes in the Document 
Manager root folder, to get email notifications regarding events in the 
root folder, you must have at least view permission because the root 
folder has no owner. 

Using the Document Manager 

In Primavera Unifier, the Document Manager maintains all the files and documents for a project. 
Each project includes its own Document Manager, and another Document Manager resides at 
the company level. The manager ensures that employees and project members are always 
using the most current versions of documents and makes accessing and distributing documents 
efficient. Documents are organized into a "folder" structure to categorize them and make them 
easily available, much like a filing cabinet. 

The Document Manager is integrated with business processes. You can initiate a business 
process directly from the Document Manager and automatically attach files and folders to it. 
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The Documents node in the left Navigator is where all documents—such as drawings, 
spreadsheets, image files, Microsoft Office files—are stored and managed. Under this node, at 
the project level,  we have provided an extensive Project Documents node containing a folder 
structure to support an array of document types, such as Project Budgets and Schedules, Bids 
and Contracts, and Permits and Fees.  You can upload, download, revise, or mark up all 
documents from this node. The Documents node has check-in/check-out, document lock, and 
revision history features for version control. 

The Unpublished Documents node is the temporary, automatic repository for files that have 
been uploaded from local machines and attached to business processes, but which have not yet 
been "published" to the Documents node. When you upload a file from a local machine and 
attach it to a business process, the document is automatically stored in the Unpublished 
Documents node with a link to the business process to which it belongs. The link to the 
business process allows the administrator to review where the document originated from. This 
way, the administrator can control the documents that are accessible in the Document Manager. 
For example, a subcontractor might submit a Request for Information (RFI) with attached 
documents requesting input from the architect. The attached documents can be traced to the 
original business process through the link, and the documents will become available in the 
unpublished node. The administrator can then review the documents, decide where to store 
them, and publish them to the Documents node; or the administrator can decide not to publish 
them at all. 

Automatic Publishing of BP Records to the Document Manager 

A business process can be designed to automatically publish its records, along with their 
comments and attachments, to the Document Manager in a folder the administrator specifies 
when the business process is set up. In effect, this produces a detailed audit trail of the record 
information through the business process (for both workflow and non-workflow processes). You 
can open these records and their information from the Document Manager. 

Depending on how the administrator sets up the business process, the record information can 
be automatically published to the Document Manager when the business process reaches a 
specific step in a workflow, or whenever an email notification is sent regarding the status of the 
business process, or both. According to its setup, the business process will publish the record to 
a designated folder in the Document Manager. If you, as owner of the record, do not have 
permission for this folder, Unifier will send the record and its contents to the Unpublished 
Documents node in the manager. If the record already exists in the folder, Unifier will publish 
the record as a revision. If the folder’s path in the business process record is invalid for any 
reason, the record will be sent to the Unpublished Documents node. 

Note: On Creation Step of Workflow-type Business process, the record_no in 
uuu_dm_record_info_path is evaluated or replaced when it is used directly as part of 
formula.  

Example:  

Suppose 'uuu_dm_publish_path' and 'title' are defined as formula. 

=> uuu_dm_publish_path = firstName + record_no + title 

=> title = subject + record_no 
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uuu_dm_publish_path would be evaluated as 'firstName + record_no + subject' ('record_no' 
in data element 'title' is ignored) 

Enabling Document Manager-Generated Email Notification 

As with other modules within Unifier, there are events in Document Manager that can trigger 
email notifications to other team members. There are three conditions that must be met in order 
for a user to receive Document Manager emails: 

 Folder Properties, Options tab:The owner or a user with modify properties permissions on 
a folder can select the Send email notification to subscribed users checkbox on the 
Options tab. 

This option enables notifications to be generated in the first place for items in the folder. That 
is, select the checkbox to notify users whenever the folder properties are modified. If the 
checkbox is not selected, no emails will be generated for the folder (or subfolders either, 
unless the box is selected for subfolders). 

Selecting or deselecting this checkbox will automatically apply to all subfolders automatically. 
This option will not override a user’s email subscription selection in User Preferences. 

 Permission setting in Document Manager: A user has to be explicitly assigned at least 
view permissions (at the folder or document level in the Document Manager) to the specific 
folder, document, or shortcut target in order to subscribe to email notifications. 

For example, even if users have full access permission at the module level, they will not get 
email notifications unless they are on the permission list for the folder, document, or shortcut 
for which the e-mail notification would normally be generated. 

 Email Subscription Preference: The user must subscribe to the Document Manager email 
notifications in User Preferences. 

The events that can trigger email notifications are document upload, transfer ownership, move, 
delete, document revise, and folder rename. 

Working with Project or Shell and Company Documents 

The project or shell Documents node (in the project- or shell-level Document Manager) and the 
Company Documents node (in the company-level Document Manager) are the root nodes in 
which published documents (that is, documents that are ready to be used by team members) are 
stored and managed. You will typically work out of these nodes when working with your 
company or project or shell documents. All uploads, downloads, revisions, markups, etc., are 
performed here. 

Permission-based access: Similar to a shared network storage drive, access to specific 
folders, files, and shortcuts is independently controlled by permissions. The user who creates a 
folder or shortcut, or uploads a file, is, by default, its owner, and has full access (privileges to 
view, upload, delete, download, etc.). The owner (could be the project or shell or company 
administrator) can set these permissions to allow or disallow access by other team members. 
For this reason, it is important to verify the permission settings for all files or folders of which you 
are the owner to make sure that they are accessible by the people who need them. 
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Editing and version control: The project or shell Documents and Company Documents nodes 
have check-in and check-out, document lock, and revision history capabilities enabling full 
version control. 

Use with business processes: The Document Manager is integrated with business processes. 
You can initiate a BP from directly within the Document Manager and automatically attach 
selected files and folders. 

Reporting: In addition, document and folder properties are associated with data elements, and 
are therefore fully reportable through user-defined reports. 

Note: The Document Manager does not support multibyte or Unicode 
characters in file names. 

Accessing Project or Shell Documents and Company Documents 

To access project or shell documents 

1) Open a project or shell and click Document Manager in the left Navigator. 

2) Click Documents. 

To access company documents 

1) Go to the Company Workspace tab and click Document Manager in the left Navigator. 

2) Click Company Documents. 

Navigating Project or Shell Documents and Company Documents (Classic View) 

Document Manager navigation works the same way at the company level and the project or 
shell level. 

There are two panes in the project or shell and Company Documents node: 

Folder view (or folder tree): Displays the project or shell or company documents folders and 
subfolders, similar to a network or local drive. Click the plus sign (+) next to the folder name to 
expand it and reveal subfolders, or click the minus sign (-) to collapse the structure. The order of 
the folders in this view can be changed (see Organize Folders (on page 437)). 

Project, shell, or company documents log (or document view): Displays the contents 
(subfolders, documents, empty documents, shortcuts) of the folder selected in the Folders view, 
in alphabetical order. The pane also displays the Recycle Bin, which contains files to be deleted 
from the system. 

At the project or shell level, a Phase drop-down list at the top of the pane allows users to display 
documents and folders applicable to the current phase or all phases (referring to the project or 
shell phase as maintained by the project or shell administrator; your project or shell may or may 
not contain phase-specific documents). 

Tip: You can expand the project or shell Documents or Company Documents log and 
workspace by contracting the Unifier Navigator. 
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Navigating Project or Shell Documents and Company Documents (Standard View) 

Document Manager navigation works the same way at the company level and the project or 
shell level, user mode. 

There are two panes in the project or shell Documents and Company Documents nodes: 

 The main document log or document view:  Displays the contents (subfolders, documents, 
empty documents, shortcuts) of the folder selected in the Folders view, in alphabetical order. 
Click the plus sign (+) next to the folder name to expand it and reveal subfolders, or click the 
minus sign (-) to collapse the structure. 

Tip:  Hover over a folder to view the number of subfolders and documents under it. 

 The right-pane view: The document summary (right-hand pane) displays tabs that contain 
information pertaining to the selected folder, subfolder, document, shortcut, or empty 
document. The following tabs are displayed based on the object selected:  

 Properties 

 References 

 Linked Records 

Open the tab and click any of the linked record row, from the grid, to view the record 
details. 

 Audit Log 

 Permissions 

 Options 

 Revisions 

Note: If you are using a custom user mode navigator, you must add the 
Recycle Bin to the navigator. 

Essentially, the Document Manager navigation works the same way at the project level, shell 
level, and company level, user mode. 

Working with Document Logs (Classic View) 

The project or shell Documents and Company Documents logs display attributes about the 
documents and folders listed in them. 

The log can be designed in uDesigner if the folder and document properties have been 
designed. The following shows the default display of the project or shell Documents and 
Company Documents logs. The log used in your Document Manager may vary. You may need 
to use the horizontal scroll bar to view all of the columns. 

Icon/Column 
Heading 

Description 

The folder or Document-type or shortcut icon. The document icons 
shown in this example are for a bitmap, a formatted document, and a 
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text file. 

Indicates that the file has comments. 

Indicates that the file is locked or unlocked. 

Ref (check or 
X) 

A checkmark indicates that reference files exist and are resolved; an X 
indicates that there are missing reference files. 

BP 
An icon indicates that the document is attached to one or more BP 
records. 

Name The file name of the document and its extension (file type). 

Size The size of the file. 

Upload Date The date the file was uploaded into project or shell Documents. 

Owner Owner of the document, folder, or shortcut. 

Title 
The identifier given to the document upon uploading, which may differ 
from the file name. 

Rev. No. 
An optional, manually entered revision number (or version number) of 
the document. 

Issue Date 
An optional date and time stamp that the user can define at the time of 
upload or checking in a file, to identify the issue or publication date 
outside of Unifier. 

Pub. No. 

This system-generated number identifies the number of times the 
document has been published in the Document Manager. Upon initial 
upload, the Pub. No. is 1; if it is checked out, revised, and checked back 
in, it becomes 2, etc. 

% Complete 
The percent complete of the folder or document. This is a calculated 
field derived from the overall percent complete as entered for the 
documents contained within the folder. 

Publication 
Date 

Automatic date and time stamp when the document was published in 
Unifier. 

Location 
Shows the full folder path of the item within the project or shell 
Document node. 

Documents Log or Company Documents Log Menu Bar (Classic View) 

The following describes the functions available from the project or shell Documents or Company 
Documents menu bar.  
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File 

File Menu 
Option 

Description 

New 
Create new folder, file, empty document, shortcut, or business process 
record. 

Open Open folders, documents, or shortcuts. 

Upload Add files and folders to the Document Manager from your local drive. 

Download Download copies of documents and folders to your local drive. 

Export 
Export a document or folder structure and property information in a CSV 
file. 

Import 
Import a folder structure template from within Unifier, or folders, empty 
documents and properties in a CSV file. 

Recycle Bin View, restore, or delete the contents of the Recycle Bin. 

Index 
Report 

Easily run or print a report showing the contents of a selected folder and 
phase and category information in HTML, PDF, or CSV format. 

Edit 

Edit Menu 
Option 

Description 

Transfer 
Ownership 

Transfer the ownership of a folder or document to another user. 

Move Move documents, folders, and shortcuts. 

Copy Copy documents, folders, and shortcuts. 

Rename Rename folders and shortcuts. 

Delete Delete documents, folders, and shortcuts. 

Properties View or edit folder or document properties. 

Permissions
View or define permissions for other users to access folders, documents, 
and shortcuts. 

Revise 
Upload a revised document from your local system and replace the 
current version of the document in the Document Manager. The older 
version is accessed in the View Revisions window. 

Check In 
Check in documents that you have previously checked out. If the 
document was revised and checked back in, the Pub. No. is updated. 

Check Out Check out a document to edit, or add markups or comments. 

Cancel 
Check Out 

Cancel checkout of a document without saving any edits or comments. 
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Lock Lock documents to prevent editing by other users. 

Unlock Unlock locked records. 

Organize 
Folders 

Move folders within the folder structure. 

View 

View Menu Option Description 

Comments 
Add or view comments on documents and file attachments on 
documents. 

References 

Refers to reference files associated with a base drawing file 
(DWG or DGN format). A checkmark in this column indicates 
that all the reference files are resolved; an X indicates there is 
at least one missing reference file. 

Linked BP Records 
Display list of business process records to which a selected 
document is linked. 

Revisions Access previous revisions of a selected document. 

Audit Log 
View the audit log (history of actions) for folders, documents, 
and shortcuts 

Find 

Properties: Search for documents, folders, or shortcuts by 
information that is part of their properties, e.g., name, owner, 
etc. Data that can be searched on can be customized by the 
project or shell Manager. 

Content: Search by content, or keywords, within documents. 

Filter By 

Filter how documents are displayed in the log. Affects a 
selected folder and its subfolders. 

All: Displays all contents of the selected folder. Subfolder 
contents are not displayed unless they are selected. 

Locked: Displays locked documents in the selected folder 
and subfolders. 

Unlocked: Displays contents of the selected folder, except for 
locked documents. 

Published Today: Displays documents that have been 
published today to the selected folder and subfolders. 

Checkout Out By Me: Displays documents in the selected 
folder and subfolders that are currently checked out by you. 
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Documents Log or Company Documents Log Toolbar (Classic View) 

You can perform the following functions from the toolbar. Click the down arrow next to a button 
to view the options.   

Button Action 

New 

Folder: Creates new folder or subfolder in the selected folder. 

Document > File: Uploads the file to the selected folder. 

Document > Empty Document: Creates an empty document in the 
selected folder. 

Business Process: Creates a new BP record with the selected documents 
attached. 

Open 
Opens the selected folder or document (document opens in the native 
software application or AutoVue viewer, depending on the File Viewer 
option in your User Preferences). 

Find 

Properties: Search for documents, folders, or shortcuts by information that 
is part of their properties, e.g., name, owner, etc. 

Content: Search by content, or keywords, within documents. 

Upload 
Uploads files and folders from your local machine into the Document 
Manager. 

Download Downloads files and folders to the local machine. 

Delete Deletes the selected file or folder (moves it to Recycle Bin). 

Check Out

Allows you to check out documents for editing or markup. 

Check In: Check in documents (with changes). This automatically updates 
the documents Pub. No. 

Cancel Check Out: Cancel the check-out status without saving changes. 

Comments
Opens the File Comments window for the selected document. Add or view 
comments, markups, or attach another file to a document. 

Permissio
ns 

Configure user permissions for the selected document, folder or shortcut. 

Properties View or add properties to the selected document, folder, or shortcut. 

Searching for a Document, Folder, or Shortcut (Classic View) 

There are two ways to find items in project or shell Documents or Company Documents: 
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 Search by Properties: This searches on specific properties (metadata) of the document, 
empty document, folder, or shortcut being searched for. The default search options are 
name, owner, title, revision number (documents), and upload by (user who uploaded the 
item). 

Note: This search option can be customized through uDesigner. If a 
designer has imported Document Managers attribute forms, the search 
criteria can also be customized. This means that the fields on which you 
can search may differ from the above list. 

 Search by Content: This allows you to search for a document by specific content, or 
keywords, within the document. This option works on most file types other than drawing files. 
You can search by single word or exact phrase in quotes (for example, "training document"). 

The supported file types for content search are listed below: 

doc, pdf, txt, xls, htm, rtf, html, csv, xml, xsd, java, c, cpp, vm, bat, bak, css, log, sql, ncs, sh, 
properties, vpp, wtx, xhtml, xslt, ppt, mpp, vsd 

The Find function works on the latest revisions of documents only. It does not search on 
older revisions. 

Note: The search bar is not case-sensitive. Accented characters and 
wild card searches are not supported. 

To search for documents, folders, or shortcuts by properties (Classic View) 

1) In the folder view, select the folder in which to perform the search. The search will be 
performed on the selected folder and its subfolders. To search all folders, select the project 
or shell Documents node. 

2) Click the Find button and choose Search By Properties, or click the View menu and 
choose Find > Search By Properties. The upper portion of the log expands to display the 
Find fields. 

3) Enter search criteria in one or more of the Find fields, for example, the full or partial name of 
a file. You can use the wildcard % when searching for names. 

4) Click the Search button. The log will display the search results. 

5) To search the contents of another folder, select it in the folder view. The search results will 
automatically display the search results of the new selected folder. 

6) To close the Search fields, click the X in the upper right corner. 

To search for documents by content (Classic View) 

1) Select the folder in which to perform the search. The search will be performed on the 
selected folder and its subfolders. To search all folders, select the project or shell 
Documents or Company Documents node. 

2) Click the Find button and choose Search By Content, or click the View menu and choose 
Find > Search By Content. 

3) Enter one or more keywords to search for within the documents. 

4) Click the Search button. The log will display the search results on the folder selected and its 
subfolders in the folder tree. 
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5) To search the contents of another folder, select it in the folder tree. The search will 
automatically run again when you select any other folder in the folder tree. 

6) To close the Search fields, click the X in the upper right corner. 

Note: Modifications to files, folders, or documents (such as uploading, 
renaming, moving, etc.) may not be reflected in the search results 
immediately as the index file associated with the content search is 
updated. 

Tip: For best results, use only alpha-numeric characters in your search criteria. If you are not 
receiving the search results you are expecting, try placing your criteria in quotes. 

Display Folders by Project or Shell Phase (Standard View) 

This is applicable to the project or shell level Document Manager only, as phase is not 
applicable at the company level. 

A project or shell documents folder can be associated with one or more project or shell phases, 
which will make it accessible only during specific phases of a project or shell. This helps insure 
that important, phase-specific documents are visible at the appropriate times during the life cycle 
of the project or shell. For example, if a folder or subfolder is associated with the construction 
phase of a project or shell, then it will appear in the project or shell Documents folder view and 
log for the project or shell only when the project or shell is in that phase. 

If a phase has not been designated on a folder or subfolder, it will display for all project or shell 
phases. 

The folder’s phase is designated in the Phase selection box in the folder’s Properties window. 
The project or shell phase is maintained in the project or shell Properties window by a project or 
shell administrator. 

You have the option to view folders for the current project or shell phase, or you can choose to 
view all folders regardless of project or shell phase. 

To display folders by current phase (Standard View) 

1) Open the project or shell and open the Document Manager in the left Navigator. 

2) From the View drop-down menu, select Current Phase. Folders and subfolders that have 
been associated with the current phase of your project or shell, as well as those with no 
specific phase designation, will be displayed. Those that have been associated with a 
different project or shell phase will not display. To display folders for all project or shell 
phases, from the View drop-down menu, select All. All folders, regardless of project or shell 
phase, will display. 

Working with Document Manager in Company and Project or Shell (Standard View) 

Navigating to Document Manager at the company:  

1) Go to your company (Company Workspace)  and switch to the user mode. 

2) Click the Document Manager module to expand. 

Navigating to Document Manager at the project or shell levels: 
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1) Go to your project or shell and switch to the user mode. 

2) Click the Document Manager module to expand. 

In general, the following nodes appear under the Document Manager module at the company, 
shell, or project levels: 

 Documents (or Company Documents) 

 Recycle Bin

 Unpublished Documents

The following explanation applies to company, shell, and project document manager. 

Documents or Company Documents 

The Documents or Company Documents page is divided into two left and right panes. The 
following explains each pane. The Documents or Company Documents page left pane has the 
following toolbars: 

The home 
icon and 
link to the 
Project 
Document
s page 
(current 
page) 

In case of 
working in 
the 
company, 
the home 
icon and 
link to the 
Company 
Document
s page 
(current 
page) 

A toggle key to display the child nodes, and the locator links 
(breadcrumbs). 

This portion displays the locator links (breadcrumbs) to the current 
location within the Document Manager folder hierarchy. By default, user is 
presented with the files or folders contained within the "Project 
Documents" folder.  

Create Enables you to create: 

 Folder

 Empty Document

 Business Process records
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Actions Enables you to conduct the following actions on multiple files or folders: 

 Add to Favorites

 Move

 Copy

 Delete

 Send for E-Signature

 Recall E-sign Request

 Transfer Ownership

 Edit

 Revise

 Check In

 Check Out

 Cancel Check Out

 Lock

 Unlock

 Export

 Structure and Properties

 Import

 Folder Structure Template

 Structure and Properties

 Index Report

 HTML Format

 PDF Format

 CSV Format

Flat View Enables you to see a flat list (default view) of all files and folders, located 
in the root (Project Documents) folder. To browse a folder, in this view, 
double-click the folder name. This opens the contents of that folder in the 
log.  

When you click a file or folder, the relevant tabs open on the right-hand 
pane which enable you to define the file or folder properties, permissions, 
etc.  

The locator links (breadcrumbs), on top, show the home page icon before 
the Project Documents folder. Click the icon to see the root (Project 
Documents) folder in the log below. You can set the root (Project 
Documents) folder properties, etc. by way of the tabs. 

Tile View To change the views between tile and list views. 
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Three View To change the view of folders and documents. You can open any number 
of folders, in the hierarchy, and view their contents in the same view.  

Download To download documents or folders onto your local or network drive. 

Upload To upload files from your local system into project or shell or company 
level Document Manager. 

View To customize the Documents log to display files based your filter criteria. 
For details, see Working with Views (Standard View) (on page 395). 

 All

 Owned by me

 Checked out by me

 Locked

 Uploaded in last 7 days

 Uploaded in lat 30 days

 Create New View

 Manage Views

Edit View To change the log view (columns, filters, sort, etc.) 

Refresh To refresh the items on the log. 

Favorites To view the favorites list. 

Initiate 
Bluebeam 
Studio 
Session

To initiate a Bluebeam Studio Session. For details about Bluebeam, refer 
to the Unifier Bluebeam User Guide. 

Search To open the search window and search for a specific document. For more 
information, see Searching Content (Standard View) (on page 396). 

Find on 
Page

To find a item on the page or log. For more information, see Finding on 
Page (Standard View) (on page 397). 

Next to each item on the log (next to a folder, subfolder, document, shortcut, or empty 

document), there is a gear menu ( ). The gear menu for each document are explained below: 
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Note: The following menu options change for empty documents. 

Open To open a file in File Viewer. 

Open in Autovue To open the file in AutoVue. 

Download To download a file. 

Add to Favorites To add the item to the list of favorites. 

Create To create a file based on a business process. 

Actions Enables you to perform the following on a file: 

 Revise

 Check Out

 Check In

 Cancel Check out

 Lock

 Unlock

Transfer Ownership To transfer the ownership of the file. 

Move To open the Move window and move the file to the destination 
folder. 

Copy To open the Copy window and copy the file to the destination 
folder and include comments. 

Delete To delete the row or item. 

The gear ( ) menu for each folder are: 
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Create To create a folder. 

Upload To upload folder. 

Download To download folder. 

Add to Favorites To add the folder to the favorites list. 

Move To open the Move window and move the folder. 

Copy To open the Copy window and copy the file to the destination 
folder and include comments. 

Delete To delete the row or item. 

The gear ( ) menu for each PDF are: 

Self-sign To sign the PDF. 

Send for E-Signature To send for E-signature. 

Initiate Bluebeam 
Studio Session

To initiate a Bluebeam Studio Session. For details about 
Bluebeam, refer to the Unifier Bluebeam User Guide. 

The Documents or Company Documents left pane has the following columns: 

Name The name of the document or folder. 

Comments Comments associated with a file. 
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Lock Indicates whether the file is locked or not. 

Bluebeam 
Session 
Status

Indicates the status of the document in the Bluebeam studio session. 

Reference
s

Any references included in the file. 

Linked 
Records 
(BP)

Any linked records included in the file. 

Title The file title. 

Creation 
Date

Creation date. 

Issue Date Date that the file was issued. 

Owner The owner of the file. 

Revision 
No.

If the file has been revised, the the revision number appears here. 

Pub No. Publication number. 

% 
Complete

The status of a file. 

Size File sized. 

Upload By The name of the user who has uploaded the file. 
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Upload 
Date

The date that the file was uploaded. 

Location The location of the file. 

The Documents or Company Documents right pane has the following tabs: 

Properties Displays detailed information about a selected item on the log (left pane). 

Linked 
Records

This tab applies to Documents, only. 

Displays the information about records that are linked to the file. 

Audit Log Displays the actions that have been taken on an item, with details. You 
can print the audits or search for a particular audit. 

Permissio
ns

Displays the name of the users or groups that are permitted to work on 
the selected item, and the permission type. 

Options Displays the type of options available for each item selected. 

Recycle Bin 

Lists all files that have been deleted along with details about each deleted file. You can use the 
following toolbar options to restore deleted files, search among deleted files, or permanently 
delete the deleted files: 

 Restore

 Restore All

 Delete

 Empty Recycle Bin

 Find on Page

Unpublished Documents 

Lists all unpublished documents and provides details on each one. You have the option to 

publish or download documents on the Unpublished Documents log. The gear menu ( ) for 
each file enables you to conduct the following operations on a selected file. 

 Open

 Open in AutoVue

 Publish
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 Download

The Unpublished Documents node log is divided into two panes. The left pane provides a list 
of unpublished documents and the right pane provides details on each document in the following 
tabs: 

 Properties

 Linked Record

Working with Views (Standard View) 

Use the View drop-down list to customize the Document Manager log to display files based your 
filter criteria. You can use the following pre-defined views or create your own view:  

 All

 Owned by me

 Checked out by me

 Locked

 Uploaded in last 7 days

 Uploaded in lat 30 days

 Create New View

 Manage Views

If the option DM View is available, it enables you to see the views defined in Log views, in 
Document configuration, at runtime. In such scenario, you can only see the active views at 
runtime, and you can see all active views pertaining to a the Documents log, if you who have 
permission to access to the DM log.  

To create a new view: 

1) Go to your Documents log. 

2) Click the View drop-down list and select Create New View to open the New View page. 

3) On the New View page, enter a name for your new view under the field  Save View As. 

4) In the Columns tab, select columns that you want to display. 

5) Select the columns that you want to remain static on the page from: Lock after selected 
Column drop-down list. 

In addition to arranging the columns, you can go to the Filters, Group By, and Sort By tabs 
to customize the new view by applying more refined selections. 

6) Click Save to create your new view. 

Your new view appears in View drop-down list. 

To manage your views: 

1) Go to your Documents log.  

2) Click the View drop-down list and select Manage Views to open the Manage Views
window. 

Use the Manage Views to create, delete, or hide views within any log. In addition, you can 
reorder views by dragging and dropping them in the Manage Views window. 

3) When finished, click Apply. 
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Your arrangement appears in the View drop-down list. 

To edit or delete an existing view: 

1) Go to your Documents log. 

2)  Click the Edit View ( ) icon . 

Note: If you modify the view and do not save the changes, the system 
keeps the existing name and adds the word "Modify" to the existing 
name. 

3) You can edit the view of the following elements on your log: 

 Columns 

 Filters 

 Group By 

 Sort By 

1) Click Apply when you have finished editing. 

Using the DM Log Tile View (Standard View) 

The Tile view allows you to view files and folders as thumbnails. All folders and files are grouped 
separately, you can expand and collapse each group. The Tile view only show the immediate 
children of the folder.  

When a file is selected, the right hand pane displays all the information tabs. The Gear  
menu allows you to take action on an individual file or folder. The folder and file names are 
hyperlinks, you can click the hyperlink to open a folder or file. 

To use the tile view, from the Document Manager log, select  Tile View. To switch to list view, 
select List View. 

Searching Content (Standard View) 

When a search is initiated by typing text in the search box, the system displays suggested areas 
to search in. Some of these suggested areas are system-defined (such as: Content or Linked 
Records) and others can be defined by the user in the Document Manager attribute form Log, in 
uDesigner. The user can configure to search on any attribute of a document including text, 
drop-down, numeric, or date type attributes.  

Note: The default elements and fields (log layout, view, search, etc.) that 
are defined in the Standard Log, in uDesigner, determine the Standard 
user interface elements and fields of all logs.  

After selecting the areas you want to search in, Unifier displays a filtered list based on your 
search criteria. In addition, you can also use the quick filters to further refine your search criteria.  
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From within the search result screen, you can choose to open, download, create a business 

process record, or go to the folder by selecting the options under the gear menu. The 
following menu and toolbar options are displayed on the Search pages. 

Menu and Toolbar Options Description 

Create Allows you to create a business process. 
Select a business process and workflow, 
and click Create. 

Download To download a file. 

Tile View

List View

To view the search results in Tile view or 
List view. 

Find on Page Allows you to find a file on the page.  

Select one of the following options: Open,
Open In AutoVue, Download, Create> 
Business Process, and Go to Folder.

To search the document log: 

1) Click the Search  icon.  

2) Enter one or more keywords. 

3) Select the areas you want to search in, for example Content, Linked Records, etc. 

4) Click Search. The search results are displayed. 

5) From the quick filters displayed on the left pane, select  filters to further narrow your search. 

6) To change the area you want to search in, or to include multiple search areas, click Change. 

7) Click the Add  icon to add additional search areas. Use the Trash icon to remove 
search areas.  

8) Select if you want the search results to display only if it matches all or any of the search 
criteria by selecting the  Match All or Match Any buttons. 

9) Click the Search button. The search results are displayed. 

Note: The search bar is not case-sensitive. Accented characters and 
wild card searches are not supported. 

Finding on Page (Standard View) 

The Find on Page option enables you to find items on the displayed page. 

1) Click the Find on Page  icon. The system inserts a new row that enables you to enter 
your search parameters.  

2) Enter your search parameters.  
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The system displays a list of files, folders, subfolders, or shortcuts that match the criteria you 
entered. 

If you decide to cancel the find for one of cell, then you must remove the parameters that you 
have entered. If you decide to cancel the find for an entire row, then you must click Find on 
Page. 

Sorting Columns (Standard View) 

You can sort columns in the Document Manager (DM) Log and the Search Results page. The 
View menu, is prefixed with the word Modified  if the sort is applied to the columns.  

To sort columns, click the up and down arrows next to the column name. 

Creating and Managing Folders 

If you have proper permissions, you can create any number of folders and subfolders to 
organize documents and shortcuts. Folders can be created in various ways: 

 Manually create a folder. 

 Upload folders from your local machine. 

 Import folders from a CSV file. 

 Create folders in a project or shell template (Administration Mode). When a new project 
or shell is created from the template, the folder structure will be copied. 

 Import a folder structure from a folder structure template. 

Note: You must have permission to create or modify folders to perform 
the following procedures. 

View Folder Contents (Standard View) 

To view folder contents: 

In the folders view, click a folder to select it. The contents of the folder appear in the project or 
shell or Company Documents log. If a folder has a plus sign (+), click it to reveal subfolders.  

About Locked Folder Structures 

The document administrator (the project or shell or company administrator or other designated 
user with full administrative permissions) has the ability to lock the first-level folder structure. 
First level refers to folders and documents directly under the root folder. It does not refer to the 
sub-folders within the first-level folders. 

Locking the first level folder structure prevents other users from adding, modifying, or deleting 
folders and documents on the first level, or changing the document or folder properties. Users 
can modify permissions on first-level folders and documents. 
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This ability allows the administrator to establish and maintain a consistent main folder structure 
within and across project or shells. 

Locked Folder Structure (Standard View) 

To check if the first-level folder structure is locked (Standard View): 

1) Open the Document Manager. 

2) Click Documents or Company Documents in the left Navigator. 

3) Select the first level folder in the Document Manager log. 

4) From the right pane, select the Options tab. If the Lock first level folder structure below 
Project Documents or shell Documents checkbox is selected, the first-level folder 
structure is locked. 

Create a Folder 

When you create a folder, you become its owner by default and have full read, write, and edit 
privileges. In order for other users to access the folder and its contents, you must grant 
permission. It is recommended that you understand the permissions settings before creating 
folders. 

You can also easily create multiple folders under the same parent folder and with similar 
properties. 

Note: It is possible for the first-level folders to be locked by a document 
administrator, which prevents folders directly under the project or shell or 
Company Documents node from being changed or added. This prevents 
the main folder structure from being altered. Subfolders can be added to 
existing folders. 

Create a Folder in Project/Shell/Company Documents Node (Standard View) 

To create a new folder in the project or shell or Company Documents node (Standard View):  

1) Select the folder in which you want to create the new folder, or the project or shell or 
Company Documents root node. 

2) Select Create > Folder. The Create Folder window opens. The Create Folder window 
opens. The Create Folder window is identical to the Folder Properties window, which can be 
viewed for existing folders. 

3) In the Properties tab, enter values in the editable fields. The other fields are system-defined 
or optional. 

4) Click Options tab and select the desired options. 

5) Click Save. The new folder is created, and the Create Folder window closes. 

If you want to create another folder, click Save & Create New. 

To cancel creating a new folder, click Cancel. 

Create Multiple Folders in the Same Parent Folder (Standard View) 
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To create multiple folders in the same parent folder (Standard View): 

1) In the Create Folder window, click the Create Multiple button. This allows you to create 
multiple folders with similar properties. 

2) Add the information in the General and Options tabs for the first folder. 

3) When the General and Options tabs are complete for the first folder, click the Create button. 
The first folder will be created and the Create Folder window will remain open. 

4) Give a new name to the second folder and verify the other information in the General and 
Options tabs. (By default, the same as the first folder, but can be modified.) 

5) Click Create to create the second folder. 

6) Continue to create folders as needed. 

7) Close the Create Folder window when you are done creating folders. 

Folder Properties Window (Standard View) 

To open the Folder Properties window:  

1) Go to your project (User mode). 

2) Click Document Manager > Documents. 

3) Click on a folder to select. 

When you select a folder, the right-hand pane displays the following tabs:   

 Properties

 Audit Log

 Permissions

 Options

If a data element in the right-hand pane contains a tooltip (a description of the field), then a 
question mark (?) symbol appears next to that field. When you hover over the question mark, the 
tooltip appears.  

Folder Properties Window (Properties Tab) 

The Properties tab has several fields that are categorized under the following blocks: 

 General

 Other

General

In this field Do this 

Name 
This always appears at the top and is mandatory. For the project or 
shell Documents or Company Documents root folder, this is not 
editable. 

Location 
The folder location within the project or shell Documents node. "/" 
indicates the project or shell Documents root folder. 

Owner 
The name of the folder creator or current owner. Click to view the 
user profile. 
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Creation Date The date that the folder was created. 

% Complete 
This is a calculated field derived from the overall percent complete 
of all documents within the folder. The % Complete for documents 
is maintained manually in the Document Properties window. 

Description You can enter an optional description for the folder. 

Other

Categories 

(applicable to 
project-level 
Document 
Manager only) 

Project administrators can group folders into customized 
categories. You cannot use Find to search for Category 
designations, but you can include them in a report (user-defined 
reports). This field is not present at the company level. 

Phases 

(applicable to 
project or shell 
level Document 
Manager only) 

In the project or shell level Document Manager, a folder can be 
associated with one or more project or shell phases, making it 
accessible only during those phases of the project or shell. This 
helps insure that important, phase-specific documents are visible at 
the appropriate times during the life cycle of the project or shell. 
Click the Select button and select one or more phases. 

The Phase setting controls the visibility of folders. For example, if 
the project or shell administrator sets the project or shell phase to 
conceptual design, then only those folders tagged with the phase 
conceptual design, as well as those without a phase tag, will be 
visible during that phase. If you do not specify a phase, the folder 
will display during all project or shell phases. 

Folder Properties Window (Permissions Tab) 

The Permissions tab has several fields that are categorized under the following blocks: 

 Inherit permissions from the parent folder

This option is not available for folders or files that do not have a parent folder (i.e., are 
located at the root).  

This option has the following are the two blocks: 

 User Name or Group Name

A selection section on the left. You can enter in the field (picker). Alternatively, you can 
click at an option to open a user or group picker, select one or more users or groups, and 
add your selections. When you select users or groups, an expanded list of selected users 
or groups appears. 

If there are both users and groups, the first group is displayed as selected by default. The 
permissions are in the right section. 

If there are no groups, but users only, the first user is displayed as selected by default. 
The permissions are in the right section. 

You can delete any of the existing or saved permission (trash can icon). 
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The usernames shows the user's profile picture next to the username. Also, the user Title 
(from user's Unifier profile) is displayed below the username. 

 Document Permissions 

A definition section on the right. This section displays a list of all folder or file permissions. 
If the option "Inherit permissions from the parent folder" is selected, this section will 
become read-only. You can edit the contents of this section only when the option "Inherit 
permissions from the parent folder" does not exist (for root level files or folders), or if the 
option "Inherit permissions from the parent folder" is selected. 

When you select multiple files (from the Document Manager > Documents log), the right 
pane displays the following tabs: 

Revisions tab: The Revisions tab is not available if more than one file has been selected 
in the DM. This tab is displayed only if the document has revisions. 

Permissions tab 

Options tab: Revisions must have same file name 

Audit Log tab: Print, Export To CSV, and Export to Excel. 

 Selected Users/Groups

 Folder Permissions

 Document Permissions

 Apply these permissions to documents and sub-folders

Folder Properties Window (Audit LogTab) 

The Audit Log tab has a tabular log that displays the following information: 

 Date

 Event

 Action

 Field Name

 Old Value

 New Value

 User Name

 Proxy User

Folder Properties Window (Options Tab) 

The Options tab has several fields that are categorized under the following blocks: 

 Folder Upload

 Upload files only: Default selection; when a folder is selected for upload, only the files 
within it are uploaded, not the folder itself. 

 Upload folders and files: Allows uploading of both files and folders. 

 Apply these options to all sub-folders

 Document Upload

 Do not include references: Applies to drawing reference files. If this option is selected, 
reference files will not be uploaded automatically with their base files. 

 Include references: Reference files will be uploaded automatically with their base files 
based on the option selected: 
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Upload References from My Computer: Searches for reference files on the local 
machine based on the path defined in the base file header. 

Auto-resolve from project or shell Documents as Dynamic Links: Searches for 
reference files already present in project or shell documents and links dynamically. If the 
reference file is revised, the newer version is used. 

Auto-resolve from project or shell Documents as Static Links: Searches for 
reference files already present in project or shell Documents and links statically. If the 
reference file is revised, the newer version is ignored. 

 Apply these options to all sub-folders

 Folder Download

 Download files only: Default selection; when a folder is selected for download, only the 
files within it are downloaded, not the folder itself. 

 Download folders and  files: Allows downloading of both files and folders. 

 Apply these options to all sub-folders

 Document Download

 Do not include references: Do not download drawing reference files automatically with 
base files. 

 Include references: Reference files will be downloaded automatically with their base 
files based on the option selected: 

Download references to same folder as Base file

Download references to Logical Path specified in Base file: As defined in the base 
file header information 

 Apply these options to all sub-folders

For categories and phases (Properties tab). If you select this option for the current folder, 
then all new and existing subfolders and documents within the folder will be modified when 
the window is saved. 

This is unchecked by default. If this option is selected, the upload or download options will 
apply to all new and existing subfolders (and documents if specified) when the options are 
saved. 

 Send email notification to subscribed users

Select this box if you want the owner to receive an email notification whenever the folder 
properties are modified. If you select or deselect this box on a folder, the checkbox will 
update on all subfolders automatically. This option will not override users’ email subscription 
selections in user preferences. 

Users also have to have at least view permissions on the specific folder or document to get 
the notification. 

Lock folder structure for the first level below project or shell Documents: This option 
appears only for the root project or shell Documents folder. It disallows the addition, 
modification, or deletion of any first-level folder: folders that are directly under the project or shell 
Documents node. Subfolders can still be added to the first-level folders. The administrator can 
unlock the structure to make changes to first-level folders if necessary. 
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View or Modify Folder Properties 

You can view or modify (with proper permissions) the folder properties of existing folders. When 
you create or upload a folder, you become its owner, and have full access to the folder and its 
contents. 

View or Modify Folder Properties (Standard View) 

To view folder properties (Standard View): 

1) From the project or shell or Company Document log, select any folder or subfolder, or the 
project or shell or Company Documents root folder. 

2) From the right-pane, select the Properties tab. The folder properties are displayed in the 
right-pane. 

To modify folder properties (Standard View):  

1) From the project or shell or Company Document log, select any folder or subfolder, or the 
project or shell or Company Documents root folder. 

2) From the right-pane, select the Properties tab.   

3) Make your changes and select OK. 

View or Modify Folder Options (Standard View) 

To view folder options (Standard View): 

1) From the project or shell or Company Document log, select any folder or subfolder, or the 
project or shell or Company Documents root folder. 

2) From the right-pane, select the Options tab. The folder options are displayed in the 
right-pane. 

To modify folder options (Standard View): 

1) From the project or shell or Company Document log, select any folder or subfolder, or the 
project or shell or Company Documents root folder. 

2) From the right pane, select the Options tab. 

3) Make your changes and select Save. 

View, Add, or Modify Folder Permissions 

When you create or upload a folder, you become its owner and have full access to the folder 
and its contents.  

Setting permissions at the folder level allows you to grant other users access not only to the 
selected folder, but also (optionally) its contents as well, such as subfolders, shortcuts, and 
documents. You also have the option of setting individual permission settings to specific 
shortcuts and documents within the folder, as discussed in the documents and shortcuts 
sections. 

Notes:  

 You many want to add yourself to the permissions list. Though not 
necessary as long as you remain the owner, if you decide later to 
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transfer ownership of the folder, you will no longer have owner 
permissions. However, you will retain the permissions, if any, that 
you specify in the permission window. 

 The project or shell Documents root folder is selectable for modifying 
permissions. 

View, Add, or Modify Folder Permissions (Standard View) 

To view the folder permissions (Standard View):  

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (folder) from the log to select. 

4) On the right-hand pane, click the Permissions tab to view the folder permissions. 

To add or modify the folder permissions (Standard View): 

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (folder) from the log to select. You can select more than one item. 

4) From the toolbar, click the Actions drop-down list and select Permissions to open the 
Permissions overlay page. Alternatively, if you are working with one item (folder) only, then 

you can click the gear menu ( ), next to the item, and click Permissions. 

5) On the Permissions overlay page, you can add or modify the folder permissions by using 
the following options: 

 Inherit form parent folder <parent folder name>

If the Inherit permissions from the parent folder checkbox at the top of the window is 
selected, then the folder-level permissions will apply automatically and cannot be 
modified.  

 Assign new permissions

 Apply these permissions to documents and sub-folders   

You can select this option to apply the selected permissions to all of the documents and 
folder contained within the selected items (folders). This selection erases the existing 
permissions assigned to the selected items (folders). 

6) Click Save when done, or click Cancel to close the Permissions overlay page without any 
changes. 

When you are working with more than one item (folder), there is an additional option: Save 
and Close. 

When you are working with permission of one item (folder) only, there are additional options: 
Previous and Next. These additional options enable you to finish your work and navigate to 
permissions of the previous or the next item. 

7) Do any of the following:  

 To add a new user, click Add and add users or groups to grant permission. Select the 
user from the list and grant or remove individual permissions (see below). 

 To remove a user’s permissions, select the user from the list and click Remove. 
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 To modify a user’s permissions, select the user from the list and grant or remove 
individual permissions. 

Add or Modify Multiple Folder Permissions (Standard View) 

To add permissions to multiple folders: 

Note: This option does not enable you to use the existing permissions 
for the selected folders. For example, if a user 'A' already has permission 
to one of the selected folders, and if the same user is selected again 
from the user group picker, then the user A's existing permissions will 
get overwritten with the new permissions. 

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Select multiple folders. 

4) From the toolbar, click the Actions drop-down list and select Permissions to open the 
Permissions overlay page. 

5) On the Permissions overlay page, you can assign permissions to users or groups.  

By default, permissions will be inherited from the common parent folder of all the chosen files. 
The inherited permissions will all be read-only. You have option to assign new permissions 
instead of choosing to inherit from parent folder. 

The permissions of folder owners can never be removed. If you select multiple folders, add the 
folder owners from the users- or group-picker, and click Remove, Unifier removes the folder 
owners from the current permission window. Unifier does not remove permissions for the folder 
owner. 

If you switch between the Inherit form parent folder <parent folder name> and Assign new 
permissions options, then all the inherited permissions are removed and the Permissions 
page toolbar and grid is updated as if you are proceeding to create new permissions from 
scratch. 

If you have already inserted one or more rows in the grid (manually or by copying from parent), 
and you decide to switch between the Assign new permissions and Inherit form parent 
folder <parent folder name> options, then Unifier displays a message stating that the manually 
added permissions will be erased and replaced with the inherited permissions. You will have the 
option to proceed or cancel. 

Copy a Folder 

You can copy a folder from one location to another. When you copy a folder, you become the 
owner with ownership permissions of the copied folder and its contents. The owner of the 
original folder and other users with permissions to the original folder retain their permissions on 
the original and the copied folder. You can copy more than one folder at a time. 

Note: If a folder contains attachments, then you can copy the folder with 
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the attachments in the Standard View, only.  

Copy a Folder (Standard View) 

To copy a folder (Standard View) 

1) Select a folder in the project or shell Documents log. 

2) Select  > Edit > Copy.  

3) Select the target location from the folders shown. 

4) Select the Include Comments check box if you want to copy any comments or markups that 
may be on documents within the copied folder. 

5) Click Copy. The folder and all contents (subfolders, documents, shortcuts) are copied to the 
target location. 

Note: To copy multiple folders, select the folders and click Actions > 
Edit > Copy. 

Move a Folder 

If you are the owner of the folder (or otherwise have proper permissions), you can move a folder 
to a new location. When you move a folder from one location to another, all subfolders, 
documents, and any comments or markups on the documents are moved to the new location. 
Original ownership and user permissions are maintained. To move a folder, you must have the 
following permissions: Create Sub -Folder permission in the destination folder and Move 
permission in the source folder. If a folder with the same name exists in the destination folder, 
you can choose to either cancel the move  or keep both the folders. When you select the option 
to keep both, the folder you are moving will be appended with a number to distinguish it from the 
folder that already exists. If you are moving multiple folders at the same time, you can select the 
Apply for all conflicts checkbox to apply the same action for subsequent conflicts. 

Move a Folder (Standard View) 

To move a folder (Standard View) 

1) Select a folder in the project or shell Documents log. 

2) Select  > Edit > Move.  

3) Select the target location from the folders shown. 

4) Click Move. The folder and its contents are moved to the target location. 

Note: To move multiple folders, select the folders and click Actions > 
Edit > Move. 

Rename a Folder (Standard View) 

To rename a folder (Standard View): 

1) Select the folder in the project or shell Documents log. 
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2) Select  > Edit >  Properties. 

3) Enter the new folder name and click OK. 

Delete a Folder 

When you delete a folder, it is moved to the Recycle Bin. Items in the Recycle Bin can be 
restored back to their original location or permanently deleted. See The Recycle Bin (on page 
447). You can delete more than one folder at a time. 

Note: Documents attached to business processes cannot be deleted. 
Therefore, in order to delete a folder that contains a document that 
cannot be deleted, you must first move that document to a different 
location. 

Delete a Folder (Standard View) 

To delete a folder (Standard View): 

1) Select a folder in the project or shell Documents log. 

2) Select > Edit > Delete.  

3) Click Yes to confirm. The folder is moved to the Recycle Bin. 

Note: To delete multiple folders, select the folders and click Actions > 
Edit > Delete. 

Creating and Managing Documents 

A document refers to a file that is uploaded into Unifier and stored in the Document Manager. A 
document in the Document Manager can be thought of as a container of the file that was 
uploaded. 

View and Open Documents 

Documents can be stored in folders or directly in the root project or shell documents or company 
documents node. The project or shell documents log displays the contents of the selected folder, 
including subfolders, documents, and shortcuts. 

Documents can be opened in two ways from within Unifier: 

 Native: Documents are opened in their native software applications; for example, Microsoft 
Word documents are opened in Microsoft Word. This option requires that users have the 
native software application installed on their machine in order to view the document. 

 Primavera Unifier viewer: Documents are displayed in the either the Unifier default viewer 
or AutoVue viewer, which can display virtually any type of file. Documents are opened in a 
read-only view that supports adding graphical markups and text comments. 

The Viewer Options is set in the Preferences window, More tab.  
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View and Open Documents (Standard View) 

To view a document (Standard View): 

1) From the Documents log view, select a document. 

2) Click  > Open in AutoVue, to open the document in AutoVue, or select > Open to 
open a document in the default Unifier viewer. 

You will see the option to open in AutoVue only if your Unifier server is configured to use 
AutoVue. 

Create an Empty Document 

Empty documents are used as placeholders for documents that have yet to be uploaded into 
Document Manager. For example, a project or shell manager might create an empty document 
in a folder and then send an action item to a team member to upload the file into it. 

You can also import empty documents. See Import and Export Folders, Properties, and Empty 
Documents. 

Empty documents can be populated with files by revising them (replacing the empty document 
with the completed document. See Revising Documents (on page 417). 

Create an Empty Document (Standard View) 

To create an empty document (Standard View):  

1) From the Documents log, click Create > Empty Document. The Create Document window 
opens. 

2) In the Properties tab, under File Properties, enter the document name. 

3) Complete the other fields and if necessary select Apply this setting onto this folder, 
sub-folders and documents. 

4) Click the Options tab and ensure to select Revisions must have same file name, if 
necessary. 

5) Click Save. The empty document is created. 

Note: To upload a file into the empty document, see Uploading Files
(on page 443). 

Document Properties Window (Standard View) 

To open the Documents Properties window:  

1) Go to your project (User mode). 

2) Click Document Manager > Documents. 

3) Click on a document to select. 

When you select a document , the right-hand pane displays the following tabs:   

 Properties
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 Linked Records

 Audit Log 

 Permissions

 Options

If a data element in the right-hand pane contains a tooltip (a description of the field), then a 
question mark (?) symbol appears next to that field. When you hover over the question mark, the 
tooltip appears.  

Document Properties Window (Properties Tab) 

The Properties tab has several fields that are categorized under the following blocks: 

 General

 Other

General

In this field Do this 

Name 
This always appears at the top and is mandatory. For the project or 
shell Documents or Company Documents root folder, this is not 
editable. 

Location 
The folder location within the project or shell Documents node. "/" 
indicates the project or shell Documents root folder. 

Document URL The URL for the selected document. 

Owner 
The name of the folder creator or current owner. Click to view the 
user profile. 

Creation Date The date that the folder was created. 

% Complete 
This is a calculated field derived from the overall percent complete 
of all documents within the folder. The % Complete for documents 
is maintained manually in the Document Properties window. 

Description You can enter an optional description for the folder. 

Other

Categories 

(applicable to 
project-level 
Document 
Manager only) 

Project administrators can group folders into customized 
categories. You cannot use Find to search for Category 
designations, but you can include them in a report (user-defined 
reports). This field is not present at the company level. 

Phases 

(applicable to 
project or shell 
level Document 

In the project or shell level Document Manager, a folder can be 
associated with one or more project or shell phases, making it 
accessible only during those phases of the project or shell. This 
helps insure that important, phase-specific documents are visible at 
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Manager only) the appropriate times during the life cycle of the project or shell. 
Click the Select button and select one or more phases. 

The Phase setting controls the visibility of folders. For example, if 
the project or shell administrator sets the project or shell phase to 
conceptual design, then only those folders tagged with the phase 
conceptual design, as well as those without a phase tag, will be 
visible during that phase. If you do not specify a phase, the folder 
will display during all project or shell phases. 

Document Properties Window (Linked Records Tab) 

Click the Expand icon ( ) to expand the Linked Records tab. 

The Linked Records tab has a tabular log that displays the following information: 

 Record Number

 Name

 Title

 Status

 Upload Date

The right-had pane of the Linked Records tab displays the Record Details tab. The Record 
Details tab has several fields that are categorized under the following blocks: 

 General

 Details

 Calculation

Document Properties Window (Audit Log) 

The Audit Log tab has a tabular log that displays the following information: 

 Date

 Event

 Action

 Field Name

 Old Value

 New Value

 User Name

 Proxy User

Document Properties Window (Permissions Log) 

The Permissions tab has several fields that are categorized under the following blocks: 

 Inherit permissions from the parent folder

 Selected Users/Groups

 Document Permissions
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Document Properties Window (Options Log) 

The Options tab allows you to select the following option: 

 Revisions must have same file name

Document Properties Window (E-Sign Log) 

The e-Sign Log tab has a tabular log that displays the following information:  

 Signer

 Sign Status

 Initiated Date

 Completion Date

View or Modify Document Properties 

You can view or modify (with proper permissions) the Document Properties of uploaded files 
and empty documents. You can also import properties values. See Import and Export Folders, 
Properties, and Empty Documents. 

View or Modify Document Properties (Standard View) 

To view document properties (Standard View) 

1) Select the document in the project or shell Documents log.  

2) From the right-pane, select the Properties tab. The folder properties are displayed in the 
right-pane. 

To view document options (Standard View) 

1) Select the document in the project or shell Documents log. 

2) From the right-pane, select the Options tab. The folder options are displayed in the 
right-pane. 

To modify document properties (Standard View) 

1) Select the document in the project or shell Documents log. 

2) From the right pane, select the Properties tab. 

3) Make your changes and select OK. 

To modify document options (Standard View) 

1) Select the document in the project or shell Documents log. 

2) From the right pane, select the Options tab. 

3) Make your changes and select Save. 

Note: The Administrator can specify values on the Document Attribute 
form (for Document Properties) that enable auto-sequencing 
(auto-numbering of documents). You can use document auto-numbering 
on documents across the Company level or the project/shell level. For 
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example, the Administrator can specify that a Document Name field uses 
auto-sequencing in order to give each document a unique number as it 
is created. The auto-numbering occurs when you click Apply or OK in 
the Document Properties window. Later, you can view the 
auto-numbering of the document by clicking the Properties button to 
view the Document Properties. 

View or Modify Document Permissions 

When you upload a document, or publish a document from the Unpublished Documents
sub-node, you become its owner and have full access to it. You can grant other users access to 
it.  

If you have granted folder-level permission to other users and allowed the permission to apply to 
the contents of the folder, those permissions will apply to the documents that you add to it 
automatically. They will appear as selected in the document permissions window. However, you 
can modify these permissions per document if needed. 

View, Add, or Modify Document Permissions (Standard View) 

To view the document permissions (Standard View):  

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (document) from the log to select. 

4) On the right-hand pane, click the Permissions tab to view the document permissions. 

To add or modify the document permissions (Standard View): 

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (document) from the log to select. You can select more than one item. 

4) From the toolbar, click the Actions drop-down list and select Permissions to open the 
Permissions overlay page. Alternatively, if you are working with one item (document) only, 

then you can click the gear menu ( ), next to the item, and click Permissions. 

5) On the Permissions overlay page, you can add or modify the document permissions by 
using the following options: 

 Inherit form parent folder <parent folder name>

If the Inherit permissions from the parent folder checkbox at the top of the window is 
selected, the folder-level permissions will apply automatically and cannot be modified. 

 Assign new permissions

1) Click Save when done, or click Cancel to close the Permissions overlay page without any 
changes. 

When you are working with more than one item (document), there is an additional option: 
Save and Close. 
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When you are working with permission of one item (document) only, there are additional 
options: Previous and Next. These additional options enable you to finish your work and 
navigate to permissions of the previous or the next item. 

To modify the folder permissions, deselect Inherit permissions from the parent folder. 

Do any of the following: 

 To add a new user, click Add and add users or groups to grant permission. Select the 
user from the list and grant or remove individual permission. 

 To remove a user’s permissions, select the user from the list and click Remove. 

 To modify a user’s permissions, select the user from the list and grant or remove 
individual permissions. 

Add or Modify Multiple Documents Permissions (Standard View) 

 To add permissions to multiple documents: 

Note: This option does not enable you to use the existing permissions 
for the selected documents. For example, if a user 'A' already has 
permission to one of the selected documents, and if the same user is 
selected again from the user group picker, then the user A's existing 
permissions will get overwritten with the new permissions. 

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Select multiple documents. 

4) From the toolbar, click the Actions drop-down list and select Permissions to open the 
Permissions overlay page. 

5) On the Permissions overlay page, you can assign permissions to users or groups.  

By default, permissions will be inherited from the common parent folder of all the chosen files. 
The inherited permissions will all be read-only. You have option to assign new permissions 
instead of choosing to inherit from parent folder. 

The permissions of file owners can never be removed. If you select multiple files, add the file 
owners from the users- or group-picker, and click Remove, Unifier removes the file owners from 
the current permission window. Unifier does not remove permissions for the file owner. 

If you switch between the Inherit form parent folder <parent folder name> and Assign new 
permissions options, then all the inherited permissions are removed and the Permissions 
page toolbar and grid is updated as if you are proceeding to create new permissions from 
scratch. 

If you have already inserted one or more rows in the grid (manually or by copying from parent), 
and you decide to switch between the Assign new permissions and Inherit form parent 
folder <parent folder name> options, then Unifier displays a message stating that the manually 
added permissions will be erased and replaced with the inherited permissions. You will have the 
option to proceed or cancel. 
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Transferring Ownership (Standard View) 

You can transfer ownership of a document, or multiple documents in a folder. The new owner 
will have all privileges of the original owner.  

To transfer ownership (Standard View) 

1) Select a folder, document, or multiple documents. 

2) From the Actions menu, select Transfer Ownership. 

3) Type the name of the user you would like to transfer the ownership to. As you type, the list of 
users are refined to show you the closest match. 

4) Select a user from the list. 

5) Click Transfer. 

6) Click Ok. 

Copy a Document (Standard View) 

A document can be copied from one location to another, with the option to include any 
comments or markups associated with it. You can select and copy multiple documents or folders 
at once. If you copy a document owned by another user, you become the owner of the copy, and 
the original owner maintains original permissions on the original and copied versions. 

Note: You must select a destination folder that is different from the 
source folder. You cannot copy a document into the same location you 
are copying it from. 

To copy a document (Standard View) 

1) Select the document in the project or shell Documents log. 

2) Select  > Edit > Copy.  

3) Select the destination folder into which you want to place the document copy. 

4) To copy with comments or markups attached to the document, select the Include 
Comments/Markups checkbox. 

5) Click Copy. 

Note: To copy multiple document, select the documents and click 
Actions > Edit > Copy. 
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Move a Document (Standard View) 

When a file is moved, comments or markups associated with the document are moved with it 
automatically. To move a document, you must have the following permissions: Add Document
folder permission in the destination folder and Move document permission in the source folder. If 
a file with the same name exists in the destination folder, you can choose to either cancel the 
move, revise the file in the destination folder, or keep both the files. When you select the option 
to revise, the file in the destination folder is  revised and an entry is made in the Revisions tab. 
When you select the option to keep both files, the file you are moving will be appended with a 
number to distinguish it from the file that already exists. If you are moving multiple files at the 
same time, you can select the Apply for all conflicts checkbox to apply the same action for 
subsequent conflicts. 

To move a document (Standard View) 

1) Select the document in the project or shell Documents log. 

2) Select > Edit > Move.  

3) Select the target folder into which you want to move the document. 

4) Click Move. 

Note: To move multiple document, select the documents and click 
Actions > Edit > Move. 

Rename a Document (Standard View) 

You can rename a document, if your administrator has enabled the document name field as an 
editable and required field. When you rename a document, the change is reflected everywhere 
the document is referenced or linked. The name is also updated in formulas that use file name in 
its calculations. Each time a file is renamed, it is tracked and can be viewed from the Audit Log 
tab. 

If you rename a file with a name that already exists in the same folder, an alert message is 
displayed. You can rename the file or choose to keep the same file name. If you choose to keep 
the same file name, it is appended with an integer. For example: Architecture Diagram.png will 
be renamed as Architecture Diagram(1).png. 

Note: You cannot change the extension of a file, you can only rename 
the file. 

To rename a document (Standard View):  

1) Select the document in the project or shell Documents log. 

2) Select  > Edit >  Properties. 

3) Enter a new file name and click OK. 

Delete a Document (Standard View) 
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When you delete a document, it is moved to the Recycle Bin. Items in the Recycle Bin can be 
restored to their original location or permanently deleted. You can select and delete more than 
one document at once. 

A document that is attached to a business process record is linked to it and cannot be deleted 
from the Document Manager. The document will show a linked records icon next to the 
document in the BP column of the document log. However, if the latest version of the document 
is not linked to a business process, the icon will not display in the log. You can select the 
document and click View > Revisions to check if an older revision has linked records. In 
addition, a document may also contain links to business processes that are still in draft, and 
which will not display as a link to the document until the BP record is sent. 

Caution: Use caution when deleting drawing base or reference files. 
Deleting a linked reference file will cause the file to be marked as 
missing on the corresponding base drawing file. 

Tip: If you need to remove a document that cannot be deleted, move it from its original location 
into another folder with limited user access. 

To delete a document (Standard View) 

1) Select the document in the project or shell Documents log. 

2) Select > Edit > Delete.  

3) Click Yes to confirm. The document is moved to the Recycle Bin. 

Note: To delete multiple document, select the documents and click 
Actions > Edit > Delete. 

Revising Documents 

To revise a document, you replace the current version with a new one that you upload from your 
local machine. The new file does not necessarily have to have the same file name as the 
original. This is also how you populate an empty document in Unifier with the completed 
document from your local machine. 

The newest version of a document is available in the project or shell Documents log. Earlier 
versions can still be accessible in the View Revisions window. When a document is revised, the 
file itself is never changed. It remains untouched. Each version is maintained separately. 

The procedures for uploading revisions are the same as for uploading files. 

Note: You can help control revisions by locking documents or checking 
them out prior to revising. If you have locked the file, you must unlock it 
before proceeding. If you have checked it out, you can revise it by 
checking it in, or cancel the check out before proceeding. 

To revise a document using the revise function 

1) Do one of the following: 



Unifier Managers User Guide

418

 If you are revising a file with a new version with the same file name, proceed to the next 
step. 

 If the revised file has a different name, select the document in the documents log, click 
the Properties button and select the Options tab. Be sure the Revisions must have 
the same file name checkbox is not selected. 

2) Select the document in the documents log. 

3) From the Edit menu, click Revise. The Revise File window opens. 

4) Click Upload to upload the revised file into the Document Manager. 

The publication number (Pub. No.) of the file increases by one for each revision uploaded. For 
example, the first time you upload a document, the publication number is 1. If you revise it, the 
publication number becomes 2, and so on. 

To revise a document automatically upon uploading 

1) Follow the procedure for uploading documents. 

2) In the Upload window select the Revise automatically if file with same name exists
option. 

3) If you are uploading a file that has the same file name as a document that already exists in 
the Document Manager target folder, that document will automatically be revised to the 
newly uploaded version. 

To learn more about comparing two versions of a document and file attachments refer to Unifier 
Business Processes User Guide. 

Viewing Previous Revisions (Standard View) 

You can view earlier versions of a revised document, including any comments or markups or 
linked BPs on previous versions. 

To view earlier versions of a document (Standard View) 

1) Open the project or shell and click Document Manager > Documents in the left Navigator. 

2) Select a document in the log. 

3) From the right-pane, select the Revisions tab. The current and any previous versions of the 
document are displayed on the right-pane. 

4) You can select a file version and perform one the following actions: 

 Open to view the file in the default viewer. 

 Open In AutoVue to open the file using AutoVUe 

 Download to download the selected version. 

 Restore this Revision to make the selected file the current version of the file 

 Comments to view any comments added to the selected version. 

 View References to view any associated drawing reference files. 

 View Linked Records to view the list of business process records to which the selected 
version may be linked. 
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Restoring to a Previous Revision 

You can revert to a previous version of the file,  if you have the Revise Document and 
Resolve References permission. When you restore a file, all comments and references 
associated with it are also restored. It also gets tracked in the Audit log.   

If the option Revisions must have same file name is checked, you cannot restore to a revision 
with a different name. 

Note: The following HTML special characters  / \ : * ? " < > | cannot be 
used in the file name. 

 The selected version becomes the current version. 

1) Open the project or shell and click Document Manager > Documents in the left Navigator. 

2) Select a document in the log. 

3) From the right-pane, select the Revisions tab. The Revisions tab is displayed only if the file 
has revisions. The Revisions tab displays all previous versions of the document. 

4) Select the version you want to revert to and select  > Restore this Revision. The 
selected file now becomes the current file. This change is tracked and can be viewed from 
the Audit tab. The Restore this Revision option is displayed only if you have the  Revise 
Document and Resolve References permission. 

Check-in and Check-Out Documents 

The Document Manager’s check-in and check-out capability helps you have greater control over 
document revisions. If you need to revise a file, you have the option of checking it out, which 
locks it and prevents others from modifying it. It is available to other users as view only. You can 
make changes to the document as necessary, then check in the new revision. 

The procedure for checking out a document is similar to downloading a document. The 
procedure for checking in a document is similar to the procedure for revising a document. 

When a document is checked out, the check-out icon appears next to the document name in the 
Document Manager log. 

To check out a document 

1) Select the document in the project or shell Documents log. 

2) In Classic View: click the Check Out button or click Edit > Check Out. In Standard View: 

select  > Actions > Check out. 

3) Download a copy of the file to your local system. 
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Notes:  

 If you cancel the download procedure, the document will still be 
checked out to you. 

 To check out multiple documents, in Standard View, select multiple 
documents and select  Actions > Edit > Check Out. 

The Check Out icon appears next to the document in the log. You can upload a new revision 
and check the document back in, or you can cancel the check out without revising the 
document. 

To check in a new revision of a checked out document 

1) Select the document in the project or shell Documents log. Checked-out documents have an 
icon in the lock column. 

2) In Classic View: click the arrow next to the Check Out button and choose Check In or select 

Edit > Check In. In Standard View: select  > Actions > Check in. 

3) Click Upload to upload and check in the revised file into the Document Manager. 

The publication number (Pub. No.) of the file increases by one for each revision uploaded. 

Note: To check in multiple documents, in Standard View, select multiple 
documents and select  Actions > Edit > Check In. 

To restore a checked out document without checking in a new revision 

1) Select the checked out document in the project or shell Documents log. 

2) In Classic View: click the arrow next to the Check Out button and choose Cancel Check 

Out or select Edit > Cancel Check Out. In Standard View: select  > Actions > Cancel 
check out. 

The document will no longer be checked out. 

Note: To restore multiple checked out documents, in Standard View, 
select multiple documents and select  Actions > Edit > Cancel Check 
Out. 

To ascertain which user has a document checked out 

1) Select the checked out document in the project or shell Documents log. 

2) In Classic View: click the View menu and choose Audit Log. In Standard View: from the 
right-pane, select the Audit Log tab. The Audit Log report displays the complete history of 
the document, including who last checked out or revised it. 

Lock and Unlock Documents (Standard View) 

If you are the owner of a document, you have the option of locking the document to prevent it 
from being revised or modified. Once a document is locked, only the document owner (or an 
administrator with proper permissions) can unlock it. 

When a document is locked, users can: 
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 View the document, revision log, and audit log. 

 Download or copy the document. 

 Create a shortcut to the document. 

 Modify document permissions. 

 Move a document, or move the folder containing the document. 

When a document is locked, users cannot: 

 Delete, revise, edit properties, transfer ownership, or add comments or markups. 

To lock or unlock a document (Standard View) 

1) Select the document in the project or shell Documents log. 

2) Select  > Actions > Lock or Unlock. 

Notes:  

 Only the document owner or an administrator with full access can lock 
or unlock a document. 

 To lock or unlock multiple documents, select Actions > Edit > Lock
or Unlock. 

 Only the document owner or an administrator with full access can lock 
or unlock a document. 

Adding and Viewing Graphic Markups and Comments 

You can add text comments or graphical markups to a document in project or shell Documents. 
You can even add a file attachment directly to the comment, for example, supporting 
documentation. 

Comments and markups can be added to the latest version of a document only. You can view 
but not add or modify comments or markups made to previous versions. 

Text comments are like notes that accompany the document but do not become part of it. 

Markups can be thought of as an invisible layer, like a sheet of acetate that can be laid over the 
document. If multiple users create markups, each markup is on a separate sheet and can be 
viewed together, one at a time, or not at all. Markups are always associated with a text 
comment. 

Text comments and graphic markups can be copied between business process records and the 
Document Manager, including: 

 Comments added to documents in the Document Manager 

 General comments added to business process records 

 Comments added to file attachments on non-Document-type BP records 

 Comments added to file attachments (line item content) of Document-type BP records 

 Markups on file attachments that have been added to comments 
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Opening a Document to View Comments (Standard View) 

To open a document using the default Unifier Viewer (Standard View) 

1) Select a document 

2) Select > Open to open a document in the default Unifier viewer. The document along with 
the associated comments are displayed in one window 

To open a document using AutoVue (Standard View) 

1) Select a document 

2) Select > Open in AutoVue to open a document in AutoVue. This option displays only if 
your Unifier server is configured to use AutoVue. 

Adding Markups, Comments, and File Attachments (Standard View) 

Note: All comments are displayed in both viewers regardless of which 
viewer the comments were added in. Markups are visible only in the 
viewer they were made in. 

Using Unifier Default Viewer 

1) Select a document 

2) Select > Open to open a document in the default Unifier viewer. 

3) Click the Comments icon. 

4) Click the Annotation icon to display the annotation toolbar. 

5) Use the annotation toolbar to markup your document. 

6) Enter your comments and click Post. 

7) To add attachments to your comments, click the Attachment icon. 

Using Autovue Viewer 

This option displays only if your Unifier server is configured to use AutoVue.  

1) Select a document 

2) Select   > Open in AutoVue to open a document in AutoVue. 

3) Ensure you have selected the latest revisions of the document. 

4) Click the Markup icon in the Comments and Revision window. 

5) Use the markup toolbar displayed in the Document window to markup up your document. 

6) Enter your comments in the Comments and Revisions window and click Post. 

7) To add attachments to your comments, click the Attachment icon. 

Viewing and Adding New Markups in AutoVue 

In addition to adding markups to a DM document, you can add and view old markups 
simultaneously. With this functionality, multiple members can add various markups across 
shared files throughout the life cycle of a design document. 
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When you select Open in AutoVue in the gear menu ( ) of the document, a View All 
Markups option is available in the File Viewer of the Comments and Revisions window. If you 
select View All Markups, the document is displayed in View-Only mode. 

You can also choose the markups that are displayed by selecting the checkbox next to each 
markup. After selecting OK, all the chosen markups are displayed. 

Add a Comment to a Document in the Document Manager (Classic View) 

To add comments to a document (Classic View) 

1) Open the project or shell and click Document Manager > Documents in the left Navigator. 

2) In the documents log, open the document. 

3) Click the Comments button. The File Comments window opens. 

4) Add a text comment in the Text Comments box. You can click the Spelling button to run 
the spell check on your comment. 

Note: You also have the option of adding graphic markups and attaching 
a file to the comment. You must add some text in order to save the View 
Comments window, even if you are adding graphical markups or 
attaching a file. 

5) Click OK to save your changes and exit the File Comments window. 

Note: Until you click OK in the File Comments window, the comments, 
including any attachments and markups, are still in Draft mode. At this 
time, you can add or edit comments or markups to any file attachments, 
or add or remove file attachments from the comment. 

Add a graphic markup to a document in the Document Manager (Classic View) 

Graphic markups are added through the comments function. These are stored with the 
document (e.g., a drawing) in the attached comment, but do not become part of the document 
itself. 

To add a graphic markup to a Document Manager document 

1) In the project or shell Documents log, select the document to markup. 

2) Click the Comments button. The File Comments window opens. 

3) Click the Markup button. You can also click the Graphic Markup link, which displays as Add 
if there are no markups on the document, or View if there are existing markups associated 
with this comment. 

The AutoVue viewer opens displaying the document content. The window opens initially in 
view mode, which allows you to view and print the document only. 

4) In the viewer window, click the New Markup tool or File > New Markup. 

If there are existing markups, the Markup Files window opens. Each saved markup session 
is listed in the window. Select the checkbox by the markups to view and click OK. 
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The viewer switches to markup mode and the markup tools become available. 

5) Add graphic markups to the document as necessary, using the tools on the horizontal 
toolbar. 

Note: Each markup is a separate entity. The navigation pane on the left 
shows the Bookmarks tab and Markup Tree tab. The Markup Tree tab 
shows the markups. Click an entity to select it and delete, modify, etc. 

6) Click the Save button or File > Save to save your markups. Enter a name for the markup 
and click OK. 

Note: Markups are saved as a single layer and are no longer editable 
once you close the window. Each markup is listed by name in the 
Markup Tree tab (in the viewer window) as a separate layer. To add 
another markup layer, click the New button. 

7) When you have completed your markups, close the viewer window to return to the File 
Comments window. 

Note: At this point, the comment is still in Draft mode. You can add 
additional markups or file attachments if desired. You must enter some 
text in the Text Comment box in order to save. 

8) Click OK to save and exit the File Comments window. 

Attach files to a comment (Classic View) 

If you want to provide additional information regarding a comment or markup, you can attach a 
file to the comment. The file attachment is associated with a specific comment. If you attach a 
file, you must also enter text in the Text Comments window. 

You can add graphical markups to files that you attach to a comment, as long as it is in Draft 
mode. This means that you can add the markups to the attachment as long as the comment has 
not yet been saved, and the file attachments are accessible from the Add New Comments 
portion of the View Comments window. 

To attach files to a comment 

1) Open a folder and select a document in the project or shell Documents log. 

2) Click the Comments button. The View Comments window opens. 

3) Add a comment. 

4) Click the Attach button and choose one of the following: 

 My Computer to attach the file from your local system. The procedure is the same as for 
uploading files to the Document Manager. 

 Primavera Unifier Folder to attach documents from the Document Manager. The 
window opens, displaying the project or shell Documents files and folders. Select the files 
and folders to attach and click OK. Folders are not attached. The contents of selected 
folders are attached in a flat list. Documents with duplicate files names will not attach. 

5) When you are done attaching files, click OK to save the comment with the attachment. Once 
you save the comment with file attachments and markups, it cannot be modified. 
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Note: Until you click OK in the View Comments window, the comment, 
including any attachments and markups, are still in Draft mode. At this 
time, you can add or edit comments or markups to any file attachments, 
or add or remove file attachments from the comment. You must add text 
in the Text Comments area to save the View Comments window, even if 
you are adding markups or attaching a file. 

To remove a file attached to a comment 

1) In the Add New Comments portion of the View Comments window, click the link next to 
Attachments. The Attachments window opens. 

2) Select the file to be removed and click Remove. 

To mark up a file attached to a comment 

1) In the Add New Comments portion of the View Comments window, click the link next to 
Attachments. The Attachments window opens (see below.) 

2) Select the file and click Markup. Follow the procedures for marking up a document. 

View comments, markups, and file attachments on comments (Classic View) 

Documents with comments or markups are displayed in the documents log with an icon in the 
Comments column. 

To view text comments (Classic View) 

1) Select the file with the Comments icon next to it. 

2) Click the Comments button. The View Comments window opens. 

Any previously added comments, attachments, and graphical markups are listed in the 
Existing Comments (lower) portion of the View Comments window. As you add new 
comments, markups, or attachments, they are displayed in the Add New Comments (upper) 
portion of the window. 
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Text comments are displayed in their entirety. 

View comments

To view markups per comment (Classic View) 

1) In the project or shell Documents log, select the document to view. 

2) Click the Comments button. The File Comments window opens. 

3) Click the Markup button. The AutoVue viewer opens displaying the document content. The 
window opens initially in view mode. 
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AutoVue viewer in view mode

4) Click the New Markup button or select File > New Markup to switch from view to markup 
mode, and choose which existing markups to view. 
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AutoVue viewer in markup mode
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To view or download files attached to a comment (Classic View) 

1) In the View Comments window, if there are file attachments to an existing comment, the 
number of file attachments will display as a link. Click the link next to Attachments. The 
Attachments window opens listing the attached files (see below.) 

2) You can do the following: 

 To view any graphical markups made on the attached file, select the file and click the 
View Markup button. 

 To view the file attachment, select it and click the View button. The file will open in the 
native software application or the AutoVue viewer, depending on your File Viewer option 
in your user preferences. 

 If any of the attached files is a drawing file, select it and click the View References
button to view the associated reference files. 

 To download a file attachment, select it and click the Download button. Follow the 
procedure for downloading files from the Document Manager. 

3) Close the window. 

Resolving Missing Reference Files (Reference Manager) 

Base files store the reference file paths in the header. During the auto-resolve process, 
Primavera Unifier reads the path in the header and then looks for the reference files based on 
this path. If the reference file path cannot be read, or if the reference files cannot be found in the 
path specified by the header, the references are flagged as missing. 
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Note: Nested reference files are not supported. For example, a base file 
references a reference file, which in turn references another reference 
file (that is, the first reference file is a base file for the second). 
Primavera Unifier does not try to resolve missing nested reference files. 

You can resolve missing reference files during or after uploading into Primavera Unifier. You can 
resolve missing references within the Document Manager in several ways: manually upload a 
missing file from your computer; link to a reference file that is already in project or shell or 
company documents; or let Primavera Unifier attempt to auto-resolve it by searching for the 
missing reference. 

Note: The auto-resolve process will search for the missing attachment in 
the Primavera Unifier folder path as defined in the base file header and 
in the same folder as the base file. 

View Missing and Attached Reference Files (Standard View) 

To view missing and attached reference files (Standard View) 

1) In the document log, select a drawing file that has reference files. The drawing file will have a 
checkmark or an X in the Ref column of the log if there are associated references. 

2) From the right-pane, select the References tab. The following information is displayed: 

 Missing: Reference files could not be found. They can be auto-resolved or resolved 
manually. 

 Private: Reference files are bundled with the drawing file, not linked. 

 Static link: Links to a particular version of an existing reference file within the Document 
Manager. Static links can only be created to the latest document version. If the reference 
file is then revised, the link will point to the original version. Once linked, files cannot be 
revised with a different file name. 

 Dynamic link: Links to an existing reference file within the Document Manager. If the file 
is revised, the link is refreshed and points to the newer version. Once linked, files cannot 
be revised with a different file name. 

Manually Resolve Reference Files 

To resolve a missing reference file by uploading from your computer 

1) In the Reference Manager tab, select the missing reference file. 

2) Click the Add from My Computer button. The File Upload window opens. 

3) Browse to the file and click OK.window 

To resolve a missing reference file by linking to an existing file 

1) In the Reference Manager tab, select the missing reference file. 

2) Click Link To Document. The Link to Document window opens. 

3) Browse to the reference file to link to. 

4) Select one of the following options: 
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 Static link: Links to a particular version of an existing reference file within the Document 
Manager. Static links can only be created to the latest document version. If the reference 
file is then revised, the link will point to the original version. Once linked, files cannot be 
revised with a different file name. 

 Dynamic link: Links to an existing reference file within the Document Manager. If the file 
is revised, the link is refreshed and points to the newer version. Once linked, files cannot 
be revised with a different file name. 

 Local copy of the Primavera Unifier document: Makes a copy of the existing reference 
file into the current folder and is not linked directly to the original version. 

5) Click OK to save and close the Link to Document window. 

Auto-Resolve Missing Reference Files 

To auto-resolve missing reference files: 

1) In the Reference Manager tab, select the missing reference file. 

2) Click the Auto-resolve Missing References button. 

3) Select Static Link or Dynamic Link. 

 Static link: Links to a particular version of an existing reference file within the Document 
Manager. Static links can only be created to the latest document version. If the reference 
file is then revised, the link will point to the original version. Once linked, files cannot be 
revised with a different file name. 

 Dynamic link: Links to an existing reference file within the Document Manager. If the file 
is revised, the link is refreshed and points to the newer version. Once linked, files cannot 
be revised with a different file name. 

4) Click OK. Unifier will search for the missing reference file based on information in the header 
of the base file. If the missing file is found, it is listed in the Auto-resolve window. 

Copy or Move Reference Files (Classic View) 

If you need to copy or move reference files, it is recommended that you do so through the 
Reference Manager in order to maintain proper links between drawing and reference files. 

To copy a reference file (Classic View) 

1) In the document log, select a drawing file that has reference files. The drawing file will have a 
checkmark or an X in the Ref column of the log if there are associated references. 

2) Click the View menu and choose References. The Reference Manager window opens. 

3) Select the reference to copy and click the Copy button. The Copy Reference window opens. 

4) Browse to the target folder within project or shell Documents. 

5) Click OK. A reference will be copied to the target folder. 

To move a reference file (Classic View) 

1) In the Reference Manager window, select the reference to move and click the Move button. 
The Move Reference window opens. 

2) Browse to the target folder. 

3) Choose one of the options in the lower portion of the window. The reference file will maintain 
a link to the drawing file based on the option you choose: 
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 Create reference as dynamic link: If the reference is revised, the link is refreshed and 
points to the newer version. 

 Create reference as static link: If the reference is revised, the link points to the original 
version. 

4) Click OK. The reference file is moved to the target folder. 

Send for E-Signature (Standard View) 

To send a document to an internal or external user for electronic signature:  

1) Go to your project (User mode). 

2) Click Document Manager node to expand. 

3) Click Documents. 

4) Select a document, click Actions drop-down menu, and click Send for e-signature to open 
the Send for E-Signature window. 

You can select more than one document. 

5) Select either an internal or external user. 

The Internal user field enables you to either enter a user name or select from the User 
Picker window. 

The External user field enables you to either enter a user name. 

6) Enter the subject. The Subject field is mandatory. The attached document appears under 
the Subject field. Click the drop-down menu to see your options. 

7) Enter a message (fewer than 4000 characters) in the field (Optional). 

8) Click Send. 

Alternatively, you can click to select the document, click the gear menu ( ), and use Sign or 
Send for e-Signature. 

The gear menu ( ) enables you to conduct the following operations on a document: 

 Open

 Open in AutoVue

 Download

 Add to Favorites

 Create

 Business Process

 Actions

 Revise

 Check Out

 Check In

 Cancel

 Lock

 Unlock

 Transfer Ownership
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 Properties

 Move

 Copy

 Delete

E-sign Log tab 

If you configure and activate the entity that provides electronic signature technology (DocuSign 
or AdobeSign) credentials in the Company Properties > E-Signatures tab and a document has 
been self-signed, or a document has been sent to internal or external user, when the recipient 
selects the document in the Document Manager log, in addition to the existing tabs on the 
right-hand side, the log displays the E-sign Log tab. The E-sign Log tab contains: 

 The message that was sent when the sender clicked Send in the Send for E-Signature
window.  

 A list of all users who received the document for signature. 

 A list of all users who self-signed the document. 

 Print option. 

 Download option. 

 The columns for Signer, Sign Status, Initiated Date, and Completion Date. 

E-Signature Status column 

If you configure and activate the entity that provides electronic signature technology (DocuSign 
or AdobeSign) credentials in the Company Properties > E-Signatures tab, Unifier displays the 
E-Signature Status column in the Document Manager log (View > All). When creating a new 
view, you can include the E-Signature Status column in any order you select for the log. The 
following values are displayed in the E-Signature Status column: 

 In-Progress

When at least one signer or assignee has to bring the signing task to a Terminal status 
(Completed, Declined, or Reassigned). 

 Completed

When the status is marked Completed or Reassigned. 

 Declined

When the status is marked Declined by at least one signer or assignee. 

If there are more than one signer, then the Declined status overrides the status for other 
signers. 

Note: These values are represented by yellow, green, and red icons. 

In the E-Signature Status column, the values are sorted by Completed, In-Progress, and 
Declined statuses. 

You can use the following file types if you select DocuSign: 

Docu
ment

.doc, .docm, .docx, .dot, .dotm, .dotx, .htm, .html, .msg, .pdf, .rtf, .txt, .wpd, 

.xps 
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Image .bmp, .gif, .jpg, .jpeg, .png, .tif, .tiff 

.dwg: If DocuSign does not support this type of file, then Unifier converts it to a 

.pdf prior to sending it for e-sign. 

Prese
ntatio
n

.pot, .potx, .pps, .ppt, .pptm, .pptx 

Sprea
dsheet

.csv, .xls, .xlsm, .xlsx 

You can use the following file types if you select AdobeSign: 

Docu
ment

.doc, .docx, .txt, .rtf, .odt 

Image .jpg, .png, .gif, .tif 

.dwg: If AdobeSign does not support this type of file, then Unifier converts it to 
a .pdf prior to sending it for e-sign. 

Prese
ntatio
n

.ppt, .pptx 

Sprea
dsheet

.xls, .xlsx 

Some LiveCycle Designer forms for dynamic XFA PDFs created by LiveCycle are not supported. 

About Actions options 

If a document is already sent for E-Signature, and the signing process is not yet complete (the 
E-Signature status has not yet reached a terminal state), you cannot check-out, lock, or revise 
that document. If you try to check-out, lock, or revise the document, Unifier displays: This action 
cannot be performed on documents whose E-Signature process is not yet complete. 

About email containing an E-Signature task 

When you (a Unifier user) receive an E-Signature email notification to sign a document, click the 
Login option in the email, enter your sign-in credentials. Unifier opens the document in 
DocuSign or AdobeSign and you can sign. 

Note: To receive E-signature task notification emails, ensure that you 
have selected to receive emails with E-Signature task in your 
Preferences. 

Exceptions: 

 If the E-signature node is not deployed from the user mode navigator for the project or 
shell in which the task resides, then, when you sign in, Unifier takes you to the home tab 
of the E-Signature Tasks node, and the E-Sign task can be accessed from this log. 
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 If the E-signature  node is not deployed for the Home tab as well, then, when you sign 
in, Unifier takes you to the project or shell landing page and displays the message: You 
do not have permission to view E-Signature tasks. Contact your Company Administrator. 

The above conditions apply only if the status of E-Signature Task that is sent to you is "In 
Progress." If the status is not "In Progress," then the task window does not appear. Instead, 
you will be navigated to the E-Signature node in the respective project, shell, or home tab (or 
to the shell landing page, if the node is not deployed. In this case, you will be presented with 
the message: You do not have permission to view E-Signature tasks. Contact your Company 
Administrator.). 

Document Manager (DM) and E-Signature 

When the E-signature process for a document is incomplete (E-Signature Status = In Progress), 
the E-Signature request sender or the document owner can right click at the document or click 

the gear menu ( ) and select Recall E-Sign Request. 

Note: This option is not available when the E-Sign process is already 
complete or when a document has not been sent for E-Sign. 
Alternatively, you can click the Actions option (toolbar) and select Recall 
E-Sign Request. 

If you select multiple documents in the Document Manager (DM) Log and select Recall E-Sign 
Request, then: 

 If all of the selected documents are such that their E-Signature Status = In Progress, then for 
each document: 

 The E-Signature request sent out to each signee who has not yet completed the 
E-Signature request (E-Signature Status = In Progress) is recalled, and the E-Signature 
Status = Recalled.  

 The E-Signature status column in the DM log is set to Recalled. 

Note: There might be signees who have completed the E-Sign request. 
Irrespective, the E-Signature Status for the file in DM is set = Recalled. 

 The E-Signature Status in the E-Signatures node for each signee who has not yet 
completed the E-Sign task is set = Recalled, in the E-sign log as well as in the 
E-Signatures log. 

 When you proceed to open a task that has been recalled, Unifier displays the alert: This 
E-signature task has been recalled and cannot be acted upon. 

 If an E-Sign request is recalled for an external user, then that user will not be able to act 
upon the E-Sign request by clicking at relevant links in the E-Sign email from AdobeSign 
or DocuSign. 

 If any document in the user's selection has a completed E-Signature request, or it has not 
been sent for E-Signature at all, no change will take place, and Unifier ignores the recall 
request. 

The Recall E-Sign Request option is available only to the: 

 E-Signature request sender 

 Document Owner 
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Other users will not be able to view or take action even if all other conditions are met. 

When you select a file in DM Tile View and click the gear menu ( ), the following options are 
available depending on the E-Signature Status of the selected document: 

 Self-sign 

 Send for E-Signature 

 Recall E-Sign Request 

Additionally, similar to the Flat View, the E-Signature related actions are available when you 
select one or more files in Tile View and click Actions. 

Document Manager (DM) Filters 

You can filter files (Document Manager > Documents > Edit View > Filters) in the DM log based 
on the E-Signature status. If all of the E-Signature features are enabled for the Company, Shell, 
and Project home landing pages, then the Edit View > Filters tab within the Document Manager 
log displays the E-Signature status as a field on the basis of which user can filter the records. 
You can filter on basis of multiple E-Signature statuses, and you can see the operators "equals" 
and "does not equal." The options are available at the end of all other fields, if configured, in 
uDesigner. 

Document Manager (DM) Log 

If your company, shell, or project is configured for E-Signatures (E-Signatures functionality is 
enabled), then: 

 The "Search" window within the DM log displays the "E-Signature Status" as an option 
enabling you to search for files with particular E-Signature statuses within the DM. The 
search parameters are available at the very end of the list of all other parameters within the 
"Search" window, and you can conduct a search on the basis of E-Signature Status. 

 Your search results log displays the "E-Signature Status" enabling you to filter the DM files 
based on the E-Signature status that you are searching for. 

 The View > All option enables you to view all files and run the find option on the 
"E-Signature Status." 

If your company, shell, or project is configured to display a value for the E-Signature type 
(AdobeSign or DocuSign), then: 

 When you export, or import, the structure and properties of a file in the DM, the csv will 
contain an additional column: "E-Signature Status," before the "Categories" column. The 
value of the status cannot be modified because the value is system-populated based on the 
file status through the E-Signature process. 

 An export file is populated with the E-Signature status value, but an import file will always 
ignore the values contained in the "E-Signature Status" column. 
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Note: If you enter values in this column during import, Unifier will ignore 
your input and run the import for remaining columns that allow 
modification. 

If there are pending e-signature tasks for an existing E-signature type and you change the 
E-Signature type at shell or project level, then Unifier will display an alert message allowing you 
to recall those pending e-signature tasks and change the E-Signature type. If you do not recall 
the pending tasks, then the E-Signature type at shell or project level will not change.  

If you change the E-Signature type of a shell or project from "Default" to another value that 
matches the "Default" set at the company level, and there are pending E-Signature tasks for the 
"Default" E-Signature type, then Unifier displays a message that the newly chosen E-Signature 
Type value is the same as the company Default and allows you to decide whether you still want 
to change the E-Signature type, or not. The same behavior applies when you change the 
E-signature type to "Default," and the "Default' value is the same as the current E-Signature type 
value. 

Linked Documents 

If a DM file is attached to a BP record, Unifier allows you to sign or send it for E-Signature from 
within the DM. 

If a linked file is sent out for E-signature, the BP record will remain linked to the original file. The 
E-signature status, E-Signature log, etc. from DM does not reflect back into the BP record. When 
the E-Signature process from DM is completed, then the BP continues to show as linked to the 
original file. The DM, however, displays the signed and revised file. 

Note: If you link a DM file to a BP record and send the DM file for 
E-Signature from the DM as well as the BP record, the result will be 
similar to as if you attached a checked-out file from DM to a BP record. 
In this case, Unifier revises the file on the BP record (the E-Signature 
request (DM or BP record) that is completed first revises the file in the 
DM first). 

Organize Folders 

If you have the permission settings, you can quickly move folders up and down the folder tree 
using the organize folders feature. This only reorganizes the folder order on the folder tree (left 
pane). The documents view (the right pane) always lists folders alphanumerically. 

Note: Unless you have module-level organize permission, you will not be 
able to move first-level folders if the first-level structure is locked. 

Organize Folders (Classic View) 

To organize folders (Classic View): 

1) In project or shell Documents, click Edit > Organize Folders. The Organize Folders window 
opens, displaying the project or shell documents folder structure. 
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2) You can expand folders to display subfolders by clicking the + next to the folder name. 

3) Select a folder and click Move Up or Move Down as needed. Any subfolders will move with 
the selected folder. 

4) Click OK. 

Rename a Folder (Classic View) 

To rename a folder (Classic View): 

1) Select the folder in the project or shell Documents log. 

2) Click the Edit menu and choose Rename. The Rename Folder window opens. 

3) Enter the new folder name in the To field and click OK. 

Creating and Managing Shortcuts 

You may create convenient shortcuts to frequently used documents or folders. 

Document and folder permissions always take precedence. That is, you must have the proper 
permissions to view, open, or modify the document or folder to which the shortcut is pointing. 

Use Shortcuts 

Shortcuts are a convenient way to quickly navigate to important or frequently used documents 
and folders. They can be used to quickly access and view a document or folder. Shortcuts 
cannot be downloaded. 

Note: If a folder or document is moved, any shortcuts that have been 
created for it will point to the new location. However, if you rename or 
delete a document or folder, any associated shortcuts will not be 
automatically modified. Users who try to use a shortcut to a document or 
folder that has been renamed or deleted will see an error message. 

To use a shortcut 

Do one of the following: 

 Select the shortcut in the project or shell Documents log and click Open. 

 Double-click the shortcut. 

If the shortcut is to a folder, the folder opens in the folders view, displaying the contents. If the 
shortcut is to a document, the document opens. 

Create a Shortcut (Standard View) 

You may create a shortcut to a document or a folder. Clicking a shortcut to a folder displays the 
folder contents. Clicking a shortcut to a document opens the document for viewing. 

Tip: For ease of use, create shortcuts to commonly used documents and 
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folders and store them in a central folder. 

To create a shortcut (Standard View) 

1) Select the folder in which you want the shortcut to reside. 

2) Select  > Create  Shortcut. The New Shortcut window opens. 

In the Name field, enter a name for this shortcut. You can rename the shortcut  

3) In the Source field, click the Browse button. The Select Files window opens.  

4) Select to the document or folder for which you want to create the shortcut. You can select 

the Find on Page icon to help you find a particular document or folder. 

5) Click Select.. The shortcut is created in the selected folder. 

View or Modify Shortcut Properties (Standard View) 

The Shortcut Properties window consists of the name of the shortcut as it appears in the project 
or shell Documents log and the path of the document or folder to which it points. It is not 
customizable in uDesigner.  

In this field Do this 

Name The name of the shortcut, as displayed in the log. 

Source 
The path of the file or folder to which the shortcut points. You can click the 
Browse button to change the source. 

To view shortcut properties (Standard View) 

1) In the project or shell Documents log, select the shortcut. 

2) From the right-pane, select the Properties tab. The folder properties are displayed in the 
right-pane. 

To modify shortcut properties (Standard View) 

1) In the project or shell Documents log, select the shortcut. 

2) Select  > Edit > Properties. 

3) Make your changes and select OK. 

Modify Shortcut Permissions (Standard View) 

When you create a shortcut, you become its owner and have full access to it. You can grant 
other users access to it. A shortcut will have limited permission settings related to the document 
or folder to which it points.  

If you have granted folder-level permission to other users and allowed the permission to apply to 
the contents of the folder, those permissions will apply to the documents that you add to it 
automatically; however, you can modify these permissions per document if needed. 

To view the shortcut permissions (Standard View):  

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 
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2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (shortcut) from the log to select. 

4) On the right-hand pane, click the Permissions tab to view the folder permissions. 

To add or modify the shortcut permissions (Standard View): 

1) Go to your project or shell (User mode) and click the Document Manager node to expand. 

2) Click the Documents sub-node to open the Documents log (for Project Documents). 

3) Click an item (shortcut) from the log to select. 

4) From the toolbar, click the Actions drop-down list and select Permissions to open the 

Permissions overlay page. Alternatively, you can click the gear menu ( ), next to an item 
and click Permissions. 

5) On the Permissions overlay page, you can add or modify the shortcut permissions by using 
the following options: 

 Inherit form parent folder <project name> 

If the Inherit permissions from the parent folder checkbox at the top of the window is 
selected, the folder-level permissions will apply automatically and cannot be modified. 

 Assign new permissions

 Inherit Permissions (View drop-down list) 

 Apply these permissions to documents and sub-folders

6. Click Save when done, or click Cancel to close the Permissions overlay page without any 
changes. 

Copy a Shortcut (Standard View) 

To copy a shortcut (Standard View) 

1) Select the shortcut in the project or shell Documents log. 

2) Select  > Edit > Copy.  

3) Select the destination folder into which you want to copy the shortcut. 

4) To copy with comments or markups attached to the document, select the Include 
Comments/Markups checkbox. 

5) Click Copy. 

Move a Shortcut (Standard View) 

To move a shortcut (Standard View) 

1) Select the shortcut in the project or shell Documents log. 

2) Select > Edit > Move.  

3) Select the target folder into which you want to move the shortcut. 

4) Click Move. 
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Rename a Shortcut (Standard View) 

To rename a shortcut (Standard View) 

1) Select the shortcut in the project or shell Documents log. 

2) Select  > Edit > Properties. 

3) Enter the new name and click OK. 

Delete a Shortcut (Standard View) 

When you delete a shortcut, it is moved to the Recycle Bin. Items in the Recycle Bin can be 
restored back to their original location or permanently deleted. Deleting a shortcut does not 
delete the folder or document to which it points. 

To delete a shortcut(Standard View) 

1) Select the shortcut in the project or shell Documents log. 

2) Select > Edit > Delete.  

3) Click Yes to confirm. The document is moved to the Recycle Bin. 

Note: To delete multiple shortcuts, select the shortcuts and click 
Actions > Edit > Delete. 

Change the Shortcut Source (Standard View) 

You can change the file or folder to which the shortcut points by choosing a different source in 
the Shortcut Properties window. 

To change a shortcut source (Standard View) 

1) In the project or shell Documents log, select the shortcut. 

2) Select  > Edit Properties. 

3) If you want to rename the shortcut automatically with the name of the new source document 
or folder, delete the name in the Name field. 

4) In the Source field, click the Browse button and browse to the new source document or 
folder. 

5) Make your changes and select OK. 

Favorites 

Creating your Favorites List 

Select and tag your frequently used files and folders within DM log, as favorites. This list is user 
specific and allows you to view, access, and delete frequently visited items in Document 
Manager.  
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To add files or folders to your favorites list: 

1) From the DM log, select a file or folder. 

2) Select > Add to Favorites. 

Managing your Favorites List 

To view your Favorites list, from the Document Manager log, select Favorites.  A pop-up 
window displays all your files and folders that you have marked as favorite. 

Task Action 

Sort the order of your files and folders. From the Favorites pop-up window, drop 
and drag files or folders to change the 
order. 

Find files or folder From the Favorites pop-up window, click 
the Find on Page icon and start typing the 
name of your file or folder. 

Remove files or folders from your 
Favorites list. 

From the Favorites pop-up window, select 

a file or folder and click > Delete, or 
click the Delete icon. 

View the path of your file or folder From the Favorites pop-up window,  hover 
over a file or folder to view its location. 

View the folder and file in the DM log From the Favorites pop-up window, select 

a file or folder and click > Go to Folder.

Opening your Favorite File or Folder 

To open your favorite file or folder:  

1) From the Document Manager log, select Favorites. A pop-up window displays all your files 
and folders that you have marked as favorite. 

2) To open a file: 

From the Favorites pop-up window, select a file and click > Open to open the file 
using the default Unifier viewer. To open the file in AutoVue, select a file and and click 

> Open in AutoVue. 

3) To open a folder: 
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From the Favorites pop-up window, select a folder and click > Open to open the 
folder in the Document Manager log. 

Uploading Files 

You can upload files or folder from your local system into Document Manager. If you are using 
Chrome or Firefox browser, you can navigate to other parts of the application while the upload 
continues in the background. Asynchronous upload of files or folders allows you to upload files 
while simultaneously using the application. The login session is kept active if there are pending 
uploads; uploads are canceled if you sign out of the application. If you are using IE or Edge 
browser, you can only perform synchronous uploads. 

Asynchronous uploads are supported in both Classic and Standard views. You can view the 
status of your upload by clicking the Upload Status icon on the top banner. The color of 
this icon changes from blue (in progress) to green (successful) or red (failed) to indicate the 
status of the uploads. The Upload Status window displays a list of all files or folders that were 
uploaded within the last 15 days. From this window, you can see the name of the uploaded file 
or folder, size of the file, the reason for the failed upload, and the number of files in the uploaded 
folder. You can click on the file name or folder name to open or save the file. From the Upload 
Status window, you can also cancel pending and in progress uploads, and clear the upload 
history. 

The file size for the uploads must be more than 0 byte and less than the size limit that has been 
specified in the configurator. If the file size for the uploads is not specified in the configurator, 
then the actual file size for the uploads depends on the following: 

 The network bandwidth, session time-out setting, and other pertinent parameters. 

 Browser restrictions. For example, IE (9, 10, 11) allows uploading files up to 4GB in size, 
only. 

Notes:

 Drawing files are always uploaded synchronously, regardless of the 
browser you are using. When selecting multiple files all the files will 
be uploaded synchronously, if the upload contains one or more DWG 
files. 

 On IE and Edge browsers, you can only perform synchronous 
uploads. 

 You can drop and drag folders onto the Upload window only if you are 
using Chrome. 

 You can view the parent folder of the uploaded file in the Update 
Status window only in Standard View. 

 You can navigate to the uploaded folder from the Update Status 
window only in Standard View. 

 On Chrome and Firefox, only drawing files (.dwg) are considered as 
reference files during asynchronous uploads. 

 In Async upload only .dwg file is considered as reference file when 
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chrome/mozilla browser is used. 

 Using the Upload Status Window 

From the top banner, select the Upload Status  icon to view the Upload Status window. From 
this window, you can do the following: 

 View a count of pending uploads. 

 View the status of uploads. Failed uploads are in red, you can click on the Info icon to view 
the reason for the failed upload. 

 Cancel a pending or in-progress upload. Hover around the file or folder name and click on 
the X icon. To cancel all pending and in-progress uploads, click Cancel All. 

 Open or save the uploaded file or folder. Click on the file or folder name. 

 Open the parent folder of the uploaded file. Click on the folder icon next the uploaded file. 
This option is available on in Standard View. 

 Clear the upload history. Click the Clear button. The history is saved for 15 days. 

Uploading Files and Folders 

1) Navigate to the project or shell or Company Documents node. 

2) Select the destination (target) folder into which you want to upload the files. 

3) In Classic View: click the Upload button or select File > Upload.  

In Standard View: click the Upload  icon. The Upload Files window opens. 

4) Drop and drag files or folder, or click the Browse button and select the file or folder to 
upload, and select Open. 

5) On the Upload Files window, you can include additional information, such as: document title, 
revision number, and issue date. This information is optional, and can be added or imported 

at a later time. To remove a file from the list, select the row and click > Delete. 

6) From the Advanced Options section, you can select the following additional options: 
Include reference files (applicable for drawing files only), Revise automatically if file with 
same name exists, Upload files only, and Upload folders and files. 

7) Click Upload. The Progress Status indicator on the top banner displays the progress and 
status of the upload. 

8) If you are  uploading drawing files and have selected the option to Include Reference Files, 
an upload window opens and you can select the reference files associated with the base fie. 

Note: If you have uploaded drawing and reference files marked as 
missing, see Resolving Missing Reference Files (Reference 
Manager) (on page 429) 

Uploading Drawing and Reference Files 

The following drawing file types are supported: DWG and DGN.  

The following lists the ways to manage uploading drawing files with associated reference files:  
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 The base file can be dynamically linked to the reference files, meaning that the base file 
always links to the latest version of each reference file. If a reference file is revised, the 
revised version will be linked to the base file. 

 The base file can be statically linked to the reference files (i.e., the base file always points to 
a particular version of the reference file) regardless of whether it is the latest version, or not. 

Downloading Documents and Folders 

You can download copies of documents from the Document Manager to your local or network 
drive. 

The file size for the downloading must be more than 0 byte. The actual file size for the 
downloading depends on the following: 

 The network bandwidth, session time-out setting, and other pertinent parameters. 

 Browser restrictions. For example, IE (9, 10, 11) allows downloading files up to 4GB in size, 
only. 

By default, the latest version of a document will be downloaded. 

Notes: 

 Shortcuts cannot be downloaded. 

 If the download window (Java console plug-in) is still open on your 
machine, you may not be able to delete, move, or modify the 
downloaded file as it will appear to be in use. If this is the case, close 
the plug-in window. 

To download a document: 

1) Select the document to be downloaded. You can choose only one document at a 
time.Shortcuts, folders, and empty documents cannot be downloaded. 

2) In Classic View: click the Download button or select File > Download. In Standard View: 
click the Download button. 

3) If the document is a drawing file with reference files, the Reference window opens, listing all 
drawing and reference files. Click the Download button next to one of the files to download. 
The File Download window opens. 

4) Click the Save button. The Save As window opens. 

5) Browse to the location where you want to download the file and click Save. 

6) If you are downloading drawing and reference files, repeat for each file. 

To download a file or folder: 

1) Select one or more documents or folders in the documents log. Shortcuts and empty 
documents cannot be downloaded. 

2) From the File menu, click Download, or click the Download button. The Download Files 
and Folders window opens. 

3) Browse to the location where you want to download the files. 
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Importing and Exporting in Document Manager 

The following topics describe how to import and export using the Document Manager. 

Import a folder structure template (Standard View) 

If a folder structure template has been created in the Administration Mode standards and 
libraries, you can import it into your project or shell document manager to quickly create a 
pre-designed structure of folders and subfolders. You can import the folder structure template 
into the root project or shell Documents or Company Documents node or into any subfolder. 

To import a folder structure template (Standard View) 

1) In the project or shell or Company Documents node, navigate to the target folder (or the 
project or shell Documents root node) into which you want to import the new folder structure. 

2) Click the Actions menu and choose Import > Folder Structure Template. The Select 
Folder Template window opens. 

3) Select a template from the drop-down list. 

4) You can preview the template structure by clicking the Preview button. 

5) When you are ready to import, click Import. The folders and subfolders defined in the 
template are created within the target folder you selected. 

Import and Export Folders, Properties, and Empty Documents (Standard View) 

You can import a folder structure and folder metadata (properties) from a CSV file. This 
procedure also allows the import of empty documents into the structure. 

Step 1: Export structure and properties to a CSV file. Exporting the existing structure and 
properties creates the CSV structure (rows and columns). The CSV template will contain a list of 
documents and folders with their full paths and all attributes displayed on the General tab of 
folder and document properties (either default or uDesigner created). 

Documents and folder rows are identified by the first column (type). The location of the folder or 
document is identified in the second column. The order in which the columns appear is the same 
as they appear in the folder and document properties forms. 

Step 2: Modify the CSV file. Add new folders, folder, document properties, or empty documents 
to the CSV files, being careful not to change the structure. Only the columns that are modifiable 
in project or shell documents can be modified in the CSV file. Read-only fields cannot be 
modified by importing. Folder and document names are case sensitive. 
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Note: As of the date of publication, there is a known issue with Microsoft 
Excel CSV files with 15 or more rows. See the procedure below for 
details. 

Step 3: Import the modified CSV file. The imported file can include new folders and 
documents (empty documents), as well as modified or additional properties to existing folders 
and documents. You can upload files into empty documents later by using Revise. 

To export structure and properties to a CSV file (Standard View) 

1) Select specific folders or documents to export. 

2) Click Actions> Export > Structure and Properties. Click Yes to confirm. 

3) Save the CSV file to your local system. 

To modify the import file 

1) Open the CSV file in Microsoft Excel or a compatible software application. 

2) You can add new folders or documents in rows (will be added as empty documents) as 
needed. You can also add property information to existing folders and documents. 

3) Save the file. 

Caution: As of the date of publication, there is a known issue in the way 
that Microsoft Excel handles CSV files with 15 or more rows. In CSV 
files, columns are separated with commas. However, when the CSV 
template is opened with Excel, if one or more columns toward the end 
are empty, Excel will drop the additional commas from the 15th row 
onward, resulting in an error when you try to import the file. You can 
work around this in one of two ways: 

Add your data to the CSV file in Excel and save the file. Then reopen the 
file in a text editor such as Notepad, find the rows that have the missing 
commas, and add the additional commas to these rows. 

Use the text editor instead of Excel to modify column values in the CSV 
file. 

To import a CSV file into the Document Manager (Standard View) 

1) In project or shell Documents, select the folder into which to import the structure or 
properties. 

2) Click the Actions menu and choose Import > Structure and Properties. The File Upload 
window opens. 

3) Browse for the CSV file and click OK. Click Yes to confirm. 

4) At the File Download window, click Save, browse to a destination folder and click Save. 

The Recycle Bin 

When you delete documents, folders, or shortcuts from project or shell Documents, they are 
stored temporarily in the Recycle Bin. These items can be restored back to their original location. 
Items in the Recycle Bin remain there until you permanently delete them. 
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Note: If you are using a custom user mode navigator, you must add the 
Recycle Bin to the navigator. 

Restore deleted items (Standard View) 

Deleted documents, folders, and shortcuts that are still in the Recycle Bin can be restored back 
to their original locations. 

Note: If you restore a folder whose parent folder has been deleted, the 
folder structure will be recreated. However, the other contents of the 
parent folder will not automatically be restored. 

To restore deleted items in the Recycle Bin (Standard View) 

1) Select the  Recycle Bin node from left pane. 

 To restore a single item, select it and click the Restore button. 

 To restore all items in the Recycle Bin, click the Restore All button. 

2) Click Yes to confirm. 

Delete items from the Recycle Bin (Standard View) 

Once documents, folders, or shortcuts are deleted from the Recycle Bin, they cannot be 
retrieved. 

To permanently delete items from the Recycle Bin (Standard View) 

1) Select the Recycle Bin node in left pane and do one of the following: 

 Select the item and click the Delete button. 

 Click the Empty Recycle Bin button to permanently delete all items in the Recycle Bin. 

2) Click Yes to confirm. 

Index Reports (Standard View) 

The index report utilizes the Primavera Unifier user-defined report engine. It lists content 
(documents, subfolders, shortcuts) within a selected folder, properties, and phase (contents may 
be associated with more than one phase). The index report can be generated in HTML, PDF, or 
CSV format. 

To view an index report (Standard View) 

1) Select a folder in folders view of the project or shell Documents or Company Documents 
node. 

2) From the Actions menu, click Index Report and choose the format to display: 

 HTML: Displays the report in a browser window. 

 PDF: Creates a PDF file of the report. 

 CSV: Creates a CSV file of the report. 
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View Document Manager Audit log (Standard View) 

To view the Audit log (Standard View) 

1) Select a folder or document in the project or shell Documents or Company Documents log 
(or a folder in the folders view). 

2) From the right-pane, select the Audit Log tab. The audit details are displayed on the 
right-pane. 

Project or Shell Documents or Company Documents Attached to a Business Process 

A document that is attached to a business process record maintains a link with that record. You 
can view the business process records to which any document is linked (permissions to view 
BPs apply). Because of this link, documents that are attached to BP records cannot be deleted. 

Launch a Business Process from the Document Manager 

A business process record can be launched directly from documents (Documents sub-node) 
within the Document Manager node. 

Refer to Unifier Business Process User Guide for creating a BP record in Document Manager.  

View Linked Business Process Records (Standard View) 

If a document in project or shell Documents or Company Documents has been attached to one 
or more business process records, an icon will appear in the BP column next to the document in 
the log. You can view the records to which the document is attached as long as you have view 
permissions for that BP. 

To view business process records to which a document is linked (Standard View) 

1) In the project or shell Documents or Company Documents log, select a document. 

Documents with the paper clip icon ( ) in the BP column are linked to BP records. 

2) From the right-pane, select Linked BP Records. 

3) To open the BP record form, click the hyperlink for the Record No. You must have 
permission to view the specific BP in order to open the record. 

View and print the business process audit log 

To view a business process Audit log (Classic View) 

From the View menu of the BP record, click Audit Log. The Audit Log window opens, listing 
each event associated with the business process and workflow. The date and time stamp of 
each event reflect users’ current time zone as set in their User Preferences. 
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To view business process audit details (Classic View) 

From the Audit Log window, double-click a listed event to view the audit record detail, which 
details the action taken. The details also include the user’s current time zone for reference. 

To print a business process Audit log (Classic View) 

1) On the Audit Log window, click the Print button. A PDF file is created. 

2) Do one of the following: 

 Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can 
view, save, or print the file. 

 Click Save. In the Save As window, navigate to the location in which you want to save 
the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print. 

Unpublished Documents 

To access the Unpublished Documents log in Project/Shell: 

1) Go to one of the following: 

 Company Workspace 

 All standard Project instances  

 All Shell instances 

2) Click the Document Manager node to expand. 

3) Click Unpublished Documents to open the Unpublished Documents log. 

The Unpublished Documents sub-node is an automatic repository for files that have been 
attached to business processes and which have not yet been published in project or shell 
Documents or Company Documents. That is, when a user uploads a file from a local machine 
and attaches it to a business process, the document is automatically stored in the Unpublished 
Documents log as soon as the business process is sent. The link to the business process is 
also listed in the Unpublished Documents log. 

The link to the BP allows the BP record to be reviewed, allowing the administrator to review 
where the document originated from. This provides a means to control the documents that are 
accessible in the Document Manager. For example, a subcontractor submits a Request for 
Information (RFI) with attached documents requesting input from the architect. These attached 
documents can be traced back to the original BP through the link, and the documents become 
available in the unpublished area of the Document Manager. The administrator can then review 
the documents and make the decision to publish them into the project or shell or Company 
Documents node and where to store them, or not to publish them at all. 

Note the following: 

 This process applies only to business processes that support form attachments. 

 Text-type BPs, such as action items or RFIs, are excluded. This is because text-type BPs, by 
design, can have file attachments only in comments, not to the form itself. 

 Files cannot be directly uploaded to or deleted from the Unpublished Documents folder. 

 Permissions for unpublished documents are at the node-level only. You can either see all the 
documents or you cannot see any. There are no document-level permissions. Folder-level 
permissions are not applicable, as there are no folders in Unpublished Documents. 
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 Drawing files are handled with the base file listed and the associated reference files bundled 
with it, similar to a zip file. 

Unpublished Documents Log (Standard View) 

Unpublished Documents Log Standard View 

The documents in the Unpublished Documents log has the following toolbars:  

 Publish ( ) 

To publish a document. When you click this option the Publish -Select Destination Folder
window opens. The function of Publish is similar to the Move option in Document Manager 
(DM). In the Publish -Select Destination Folder window you can: 

 Select the document phase (All Phases or Current Phase) from the drop-down list field 
on top to load pertinent folders from Document Manager into the space below. 

 Use the Find on Page link to open a row under the Name block and search for a 
particular folder from the Document Manager. 

 Use the scroll-bar to parse through all folders from the selected phase so you can browse 
and select a destination folder for the document publication. 

 Include comments by selecting the Include Comments option. 

 Ensure that if a file with same name exists in the Document Manager, then it gets revised 
by the selected file in Unpublished Documents by selecting the Revise automatically if 
file with same name exists option. 

 Discard your changes by clicking Cancel. 

 Publish the selected file to the chosen folder in the Documents sub-node under 
Document Manager node, by clicking Publish. This option is available only after you 
have selected a destination folder from the available list. When you click Publish, the 
Publish Status window opens. This window displays a grid with the following columns: 

 No 

 File Name 

 Title 

 Status 

 Message 

If you select more than one file and click Publish, the Publish -Select Destination Folder
window opens and the names of all of the selected files will be listed at top of the window. 

 Download ( ) 

To download documents or folders onto your local or network drive. If you select more than 
one file to download, Unifier creates a zip file for all of the selected files and opens the 
download window. 

 Switch to Tile View ( ) 

To view documents and folders as tiles. When this option is selected, the icon changes to 

Switch to List View ( ). 

 Search ( ) 



Unifier Managers User Guide

452

To search for unpublished documents in the log. For more information, see topic Searching 
Content (Standard View) (on page 396). 

 Find on Page ( ) 

To find files on the displayed page. For more information, see topic Finding on Page 
(Standard View) (on page 397) 

The documents in the Unpublished Documents log has the following columns: 

 File Name 

 Record Number 

 Comments 

 Ref 

 Size 

 Title 

 Rev. No. 

 Publication Date 

 Issue Date 

For each record, the Unpublished Documents log screen displays the following tabs in the 
right-hand screen: 

 Properties 

Under General, this tab displays the following read-only information about the selected file: 

 File Name 

To change the file name, access Properties from the gear menu ( ). 

 Title 

 Size 

 Issue Date 

 Revision No. 

 Publication No. 

 Publication Date 

 Linked Record 

To see records linked from the same, or different, business process log. The Linked Record 
tab displays the Record Number, Name, Title, Status, and Upload Date of the linked records 

 References 

This tab appears only if the selected file has associated references. 

You can use the Expand icon ( ) to expand the right-hand screen. 

Each record has a gear menu ( ) that enables you to perform the following actions: 

 Open

To open the selected document in viewer. 

 Open in AutoVue

To open the selected document in AutoVue viewer. 
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 Properties

To review the document properties and change the file name. 

 Publish

 Download

Manually Add or Remove Projects To or From a Scenario 

When you create a scenario, Unifier collects all the projects that have met the criteria for 
inclusion on the sheet. (These criteria were created in a query by your administrator when the 
Portfolio Manager was configured.) The query that extracts the projects from the database is a 
dynamic process that occurs whenever you open a scenario sheet. The projects that appear on 
the sheet will fluctuate, depending on whether they still meet the criteria for inclusion. For 
example, a project that was previously on the sheet may be dropped from the sheet if it no 
longer meets the query criteria. Another project may be added to the sheet because it now 
meets the query criteria. 

 If the portfolio has been configured for automatic adding and removing projects, Unifier 
will populate the sheet with these projects. 

 If the portfolio has been configured for manual adding and removing projects, Unifier will 
display these projects at the bottom of the scenario window in a "candidates list," a 
separate grid from which you can manually select and add projects to the scenario sheet. 
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Add a project to a scenario 

At the bottom of the scenario window, Unifier displays a "candidates list" showing all the projects 
that have met the query criteria for inclusion on the scenario sheet. The candidate list shows 
only those projects that have not been added to any other portfolio for the same planning period. 
Also, it does not show any projects that have already been added to the scenario. 

To add a project 

1) Select the project in the candidate list at the bottom of the window. 

To select multiple projects, hold down the CTRL key on your keyboard and click on the 
projects. To select all the projects, highlight the first project, then hold down the SHIFT key 
and select the last project. 

2) Click the Add arrow. Unifier adds the project(s) to the scenario and recalculates the 
numbers. 

 If the scenario sheet has been sorted, the project(s) will be added to the 
scenario according to the sort specification. 

 If the scenario sheet has been grouped, the project(s) will be added to the 
correct group on the scenario according to the grouping specification. Unifier will 
recalculate sub-totals and group counts. 

 If the scenario sheet has been filtered and sorted, the project(s) will be inserted 
at the top of the list. Unifier will not re-filter or re-sort the data. 
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Remove a project from a scenario 

When you remove a project from a scenario, Unifier moves the project back to the candidates 
list at the bottom of the window. If that project continues to match the query criteria for inclusion 
on the scenario, it will remain on the candidates list; otherwise, it will drop from the list. 

To remove a project 

1) Select the project in the scenario. 

To select multiple projects, hold down the CTRL key on your keyboard and click on the 
projects. To select all the projects, highlight the first project, then hold down the SHIFT key 
and select the last project. 

2) Click the Remove arrow. Unifier removes the project(s) from the scenario and recalculates 
the numbers. 

About Automatic Publishing of Documents 

By default, files attached to business processes are placed in the Unpublished Documents folder 
in the Document Manager. A Publish Path data element can be designed in business processes 
in uDesigner to specify the automatic publishing of documents to a specified path and override 
the default. For Document-type business processes With Folder Structure, the designer can 
specify that a configured folder path be appended to the folder structure. This appended path is 
based on the path configured in the uuu_dm_publish_path data element on the business 
process form, and the selection of the Append Line Items Folder Structure to AutoPublish Path 
option, which is documented in the Unifier uDesigner User Guide.  

The automatic document publication folder path is built based on the values of data elements 
specified in the path defined in the data element uuu_dm_publish_path (Publish Path) in 
uDesigner. To help you understand why automatic publishing does or does not occur and the 
results of automatic publication, these are the rules for the automatic publication of documents: 

 The data element uuu_dm_ publish _path is used in business process design to specify 
the folder path into which the file should be published in the Document Manager. This 
applies to Company, project, or shell business processes. A formula is configured to define 
the value of the path to use when automatically publishing documents. 

Note: On Creation Step of Workflow-type Business process, record_no in 
uuu_dm_publish_path is evaluated/replaced when it is used directly as part of formula.  

Example:  

Suppose 'uuu_dm_publish_path' and 'title' are defined as formula. 

=> uuu_dm_publish_path = firstName + record_no + title 

=> title = subject + record_no 

uuu_dm_publish_path would be evaluated as 'firstName + record_no + subject' 
('record_no' in data element 'title' is ignored) 

 In order to use the automatic publishing feature, you must know (from your Administrator) 
which data elements comprise the publish path that will populate the Publish Path field. The 
values in this field are used to create and populate the folders in the Document Manager with 
the business process attachment. 

 If you do not have permissions granted to upload documents to the Document Manager, 
then the file is placed in the Unpublished Documents folder. 
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 If there is no folder defined or the path is invalid then the file will be placed in the 
Unpublished Documents folder. 

 If the folder specified in the defined path does not exist in the Document Manager as defined 
by the data element uuu_dm_publish_path (Publish Path) in uDesigner, then it should be 
created automatically and inherit rights from the parent folder, (if you have permission to 
create folders), otherwise the file will be placed in the Unpublished Documents folder. 

 If file already exists in target file, then the file shall be published as a revision. 

 The owner of the automatically published document is the owner of the business process 
that published it. 

 The folders created and used for automatic publication are based on the values of the data 
elements specified in the uuu_dm_publish_path data element (Publish Path). For example, 
if the publication path contains the data elements State and City, and the values for those 
data elements are Iowa and Rapid City, the folder structure will be Documents/Iowa/Rapid 
City. 

 The publication path displays in the Publish Path data element on the business process 
form. If the path is shown as /, the documents will publish to the Documents folder. Usually, 
when the / to shows in the Publish Path field, this indicates that you have no values in the 
fields for the data elements configured as the publication path. Be sure that you have values 
in the fields that are part of the publication path. 

 If a business process has a publication path configured on the upper form, and another on a 
line item, and the path on the line item is invalid, the attachment will be published to the path 
designated on the upper form. If the paths on the line item and the upper form are both 
invalid, the attachment is published to the Unpublished Documents folder. The exception is 
that in a non-workflow business process, if the publication path configured on the line item is 
invalid, the attached document is not published in any folder. 

 When a document is published from a business process (BP) record, the system compares 
the data elements (DEs) in the BP record with the DEs in the Document Attribute Form and 
where the DEs match, the system copies the values from one DE to the other DE. 

 If the attachment is on the Upper Form, then the system matches the DEs on the Upper 
Form with the DEs on the Document Attribute Form and updates the values. 

 If the attachment is on the Detail form, then the system compares the DEs on the Detail and 
the Upper Form. If a DE exists on both the Upper Form and the Detail form, then the system 
matches the value of the DE that is on the Detail form, only. This enables you to override the 
"default" value that exists on the Upper Form. 

 Unifier allows you to selectively restrict attachments from getting published, as explained 
below: 

 For Document-type BPs: Open the Document Review window and deselect the Publish
checkbox for the attachments that you do not want published. 

 For non-Document-type BPs: Open the Document Review window, or the respective 
attachment log (record or Line Item) and deselect the Publish checkbox for the 
attachments that you do not want published. 

 On a Document-type BP, when a value is added to uuu_revision_no or uuu_title or 
uuu_issue_date, it will get respectively copied over to uuu_file_revision_no or 
uuu_file_title or uuu_file_issue_date when the document is published to Document 
Manager. 
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 Once a document that has been attached to a business process is published, it will not get 
published again even if you have the uuu_dm_publish_path defined in consecutive forms in 
your workflow. 

 If you are attaching a document to your business process by selecting the document from 
Document Manager, the document will not get published again from your business process 
because it is already published in Document Manager. 

Open an unpublished document (Classic View) 

To open and view an unpublished document 

Select a document in the Unpublished Documents log and click Open. The document will open 
in the viewer. 

To view reference files 

Select a drawing file in the Unpublished Documents log, click the View menu and select 
References. If references are associated with the document, they will be listed. Drawing and 
reference files are bundled. 

Open a linked business process record (Classic View) 

To open the BP record to which an unpublished document is linked: 

1) Select the document in the Unpublished Documents log. 

2) Click the View menu and select Linked BP Record. The BP record opens, assuming you 
have permission to view it. 

View unpublished document properties (Classic View) 

To view the properties of an unpublished document 

Select a document in the Unpublished Documents log and click Properties. The Properties 
window opens. 

View unpublished document comments (Classic View) 

Comments and markups added to the document from the BP can be viewed. 

To view comments or markups on an unpublished document 

Select a document in the Unpublished Documents log and click Comments. The Comments 
window opens. 
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Download an unpublished document (Classic View) 

To download an unpublished document 

Select a document in the Unpublished Documents log and click Download. Follow the 
procedure for downloading a document in the project or shell Documents node. 

Delete an unpublished document (Classic View) 

A document cannot be deleted directly from the Unpublished Documents or the project or shell 
Documents folders if it is linked to a BP. 

A document is stored in the Unpublished Documents node automatically when it is uploaded 
directly from a local machine or network and attached to a business process. If that document is 
then deleted from the BP during the workflow (or for a non-workflow BP, the document is deleted 
when the BP is in Draft mode), then it will be deleted automatically from the Unpublished 
Documents log. 

The document cannot be deleted if the BP has already completed the workflow, or if the 
document has already been moved by an administrator to the Published Documents folder. 

Tip: You can create a special folder in project or shell Documents for documents that you want 
to publish and limit access to, but the documents remain traceable. 

Renaming an Unpublished Document (Classic View) 

You can rename an unpublished document, if you administrator has enabled the document 
name field as an editable and required field. When you rename a document, the change is 
reflected everywhere the document is referenced or linked. The name is also updated in 
formulas that use file name in its calculations. 

If you rename a file with a name that already exists in the same folder, an alert message is 
displayed. You can rename the file or choose to keep the same file name. If you choose to keep 
the same file name, it is appended with an integer.  For example: Architecture Diagram.png will 
be renamed as Architecture Diagram(1).png. 

Note: You cannot change the extension of a file, you can only rename 
the file. 

To rename a document  

1) From the Unpublished Document log, select a document. 

2) Click the Properties button. The Document Properties window opens. 

3) Enter a new file name and select OK. 

Search for an unpublished document (Classic View) 

There are two ways to find an Unpublished Document: 
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 Search by Properties: You can search by document title, file name, or record number (the 
linked BP record). 

Note: This search option can be customized through uDesigner. If a 
designer has imported Document Manager attribute forms, the search 
criteria can also be customized. This means that the fields on which you 
can search may differ from the above list. 

 Search by Content: This allows you to search for a document by specific content or 
keywords within the document. This option works on most file types other than drawing files. 
You can search by single word or exact phrase in quotes ("training document"). 

The supported file types for content search are listed below: 

doc, pdf, txt, xls, htm, rtf, html, csv, xml, xsd, java, c, cpp, vm, bat, bak, css, log, sql, ncs, sh, 
properties, vpp, wtx, xhtml, xslt, ppt, mpp, vsd 

To search for documents by properties 

1) In Unpublished Documents, click the Find button and choose Search By Properties (or 
click the View menu and choose Find > Search By Properties). The upper portion of the 
log expands to display the Find fields. 

2) Enter search criteria in one or more of the Find fields, for example, the full or partial name of 
a file. 

3) Click the Search button. The log will display the search results. 

4) To close the Search fields, click the X in the upper right corner. 

To search for documents by content 

1) In Unpublished Documents, click the Find button and choose Search By Content (or click 
the View menu and choose Find > Search By Content). 

2) Enter one or more keywords to search for within the documents. 

3) Click the Search button. The log will display the search results. 

4) To close the Search fields, click the X in the upper right corner. 

Tip: For best results, use only alpha-numeric characters in your search criteria. If you are not 
receiving the search results you are expecting, try placing your criteria in quotes. 

Publish a document to project or shell or Company Documents (Classic View) 

Publishing a document from Unpublished Documents to the project or shell Documents or 
Company Documents node makes it available to team members, with the full functionality 
available in that node. 

Only a document administrator (administrator or other user with full access to the Document 
Manager) can publish documents from the Unpublished Documents node into project or shell or 
Company Documents. Documents can be published one at a time. 
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To publish an unpublished document to the project or shell Documents node 

1) In the Unpublished Documents node, select the document or documents to publish and click 
Publish. The Publish File window opens. If you select duplicate files (documents with the 
same name) to publish, you will be asked to remove the duplicates. 

2) Select the destination folder. 

3) Select the Include Comments checkbox if you want to include any attached comments with 
the document. To review the comments, select the document from the log and click the 
Comments button. 

4) The Revise automatically if the file already exists checkbox is selected by default. 
Deselect if you do not want to automatically revise existing documents. If you deselect this 
checkbox, the new version of the document will not be copied into the Document Manager 
and are skipped. 

5) Click OK. The Publish Files Status window opens, and displays the status of the documents 
as they are published. Click OK to close this window. 

Note: The user who publishes the document becomes the owner. In the 
project or shell Documents or Company Documents node, select the 
document and click Permissions to grant the proper permissions to the 
team members who need it. You may want to click Properties to review 
properties and update if necessary. 
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Unifier Portfolio Manager 

The Portfolio Manager is where the budget forecast planners in your company can gather cost 
and schedule information on projects (both planned and in execution) and perform analyses on 
"what if" scenarios. These scenarios are used to propose an optimal mix of projects for a 
portfolio, based on available budget targets and the strategic goals of the company. 

As a planner, you can create a portfolio for a specific "planning horizon" (for example, from 2014 
through 2020) and then create multiple scenarios in that portfolio. Each scenario can use 
forecast numbers and actuals, as well as schedule dates, for both planned and active projects in 
a specific shell type across a hierarchy in the company. 

You create these scenarios on sheets, one for each scenario. The scenario sheets can pull in 
the following data from any shell type in a hierarchy: 

 Project information from the shell attribute form or single-record business process 

 Project start and end dates from the shell attribute form or single-record business 
process 

 Cash flow data (both forecasted and actual) from each project’s Cost Manager 

With this data, you can forecast costs over a specific time period (called a "period structure"). 
You can then manipulate scenarios by: 

 Including or excluding projects 

 Pushing start dates for planned projects into the future 

 Modifying project end dates to change the project’s duration 

 Proposing different cash flow distribution numbers by manually editing the cash flow 
columns 

 Negotiating proposed budgets with project managers 

Once these scenario analyses have been completed, the best (or several best) scenario(s) can 
be sent to the executive decision makers for approval. 

Once a scenario has been approved, Unifier: 

 Marks the approved scenario "shared" so that project managers can see the approved 
dates and numbers. The scenario is set to read-only mode and can no longer be 
modified or deleted. 

 Updates each projects’ original budget numbers with the proposed numbers on the 
approved scenario. 

 Updates each projects’ monthly or yearly cash flow numbers with the proposed numbers 
on the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio’s planning period. 

 Locks the budget and cash flow numbers to prevent any further changes. 



Unifier Managers User Guide

462

In This Section 

About Portfolio Budget Curves .............................................................................. 462 
View and Open Portfolios ...................................................................................... 463 
About Scenario Sheets (Classic View) .................................................................. 468 
About Scenario Sheets (Standard View) ............................................................... 488 
Financial Period in Portfolio Manager .................................................................... 501 

About Portfolio Budget Curves 

Portfolio budget curves are part of the Cost Manager function. You can view these budget 
curves from the Cash Flow node of the Cost Manager. Before you can view them, however, you 
must add these curves to your project/shell. For instructions on adding these curves, see Add a 
Portfolio Curve (see "Portfolio Budget Curve (Classic View)" on page 207) 

There are three of them: 

 A Shared Budget curve. This curve shows your proposed numbers for the project. The 
project manager will not have access to this curve until you share a scenario. The project 
manager can include this curve on the cost worksheet, along with the forecast budget, or any 
other budget curve, in order to see the difference between the project’s numbers and your 
proposed budget numbers. 

 An Approved Budget curve. When a scenario is approved in the Portfolio Manager, the 
budgets for each project in the scenario are marked "approved." They are then locked and 
stored in the Portfolio Manager. An Approved Budget curve shows the approved budget for 
the project for that planning period (usually a year). 

 An Original Budget curve. This curve is for a project in execution. This budget is the last 
approved budget for the project before it moved into its execution phase. This approved 
budget becomes the project’s original budget; and this original budget, plus any changes that 
occur to the numbers during the life of the project, becomes the project’s approved budget. 
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For example, an approved budget for the year 2015 might include a planned project for road 
construction that is scheduled to begin in 2017 with a budget of $100,000. The approved budget 
for the year 2016 will continue to include the planned road construction budget, with an addition 
of $15,000 to the forecasted budget. In the year 2017, the road construction project goes into 
execution, and the approved budget is $115,000. This figure becomes the original budget for 
the road construction project. From then on, as budget forecasting continues, the approved 
budget for the road construction will be the original budget, plus any changes that occur to the 
numbers during the life of that project. 

View and Open Portfolios 

Portfolios are grouped by their portfolio type. Scenarios are grouped under each portfolio. 

To view portfolios 

1) In User mode, open the shell where the Portfolio Manager resides. 

2) In the Navigator, click Portfolio Manager. Unifier expands the navigator to show the 
portfolio types currently loaded into Unifier. 

3) In the Navigator, click the portfolio type that contains the portfolio you want to view. Unifier 
displays the portfolios for this type in the right pane.  

The portfolio type log window contains the following toolbar options: 
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 Create

To create a new portfolio manager sheet, or to create a new portfolio manager sheet for 
the next planning period. 

When you select an existing portfolio and click Create > Portfolio, or click Create > Plan 
for next period, the Add Portfolio window opens which has two blocks; the general 
block and the options block. For each block, enter the values in the fields and click Save. 

 Delete

To delete a selected portfolio in the portfolio type log window. 

 Refresh

To refresh the list of portfolios in the portfolio type log window. 

 Print

To print the list of portfolios in the portfolio type log window or export to CSV or Excel. 

 Search

To open the Search block and search for a particular portfolio in the portfolio type log 
window. Use the following toolbars (the icons on the right-hand corner) to dock the 
Search block, clear values in the search fields, apply the search criteria, or close the 
Search block: 

 Dock Right

 Clear

 Apply

 Close

 Find on Page

To open a row in the list of portfolios in the portfolio type log window and find items 
according to the column headings. See the portfolio type log window contains the 
following columns, below. To close the row, click the Find on Page option again. 

 View Help menu

To access the portfolio type help (not available), or the portfolio type training (User 
Productivity Kit). 

The portfolio type log window contains the following columns: 

 Attachments

 Portfolio Name

 Planning Period

 Creation Date

 Creator

The portfolio type log window contains the Properties pane (the right-pane) that appears 
when you click to select a portfolio. The Properties pane, similar to the Properties window 
(accessed by the Properties toolbar option available in an opened portfolio), enables you to 
access the following information: 

 Portfolio Name

 Planning Period

 Creation Date

 Creator
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 Planner Comments

 Decimal Places

To open a portfolio 

1) In User Mode, open the shell where the Portfolio Manager resides. 

2) In the Navigator, click Portfolio Manager. Unifier expands the navigator to show the 
portfolio types currently loaded into Unifier. 

3) In the Navigator, click the portfolio type that contains the portfolio you want to open. Unifier 
displays the portfolios for this type in the right pane.  

4) In the portfolio type log window, click to select a portfolio and either double-click to open it, or 

click on the gear menu ( ) and click Open to open the portfolio details page or pop-up to 
either: 

 The scenario that has been marked for sharing 

 The most recently updated scenario 

Use the toolbar options of the window to: 

 Save changes 

 include a link or unlink an existing link 

 Access the properties window 

 Export portfolio 

At the bottom of the widow, you have the option (the plus symbol +) to add a new scenario in a 

tab and use the gear menu ( ) to: 

 Duplicate a selected tab 

 Delete a tab 

 Share a tab 

 Approve a tab 

Create or Modify a Portfolio 

You can create a portfolio "from scratch," or you can create one using a portfolio that has been 
approved for the current planning period. 

To create a portfolio, you must have Create or Full Access permission. 

To create a portfolio 

1) In User mode, open the shell where the Portfolio Manager resides. 

2) In the Navigator, click Portfolio Manager. Unifier expands the navigator to show the 
portfolio types currently loaded into Unifier. 

3) In the Navigator, click the portfolio type that contains the portfolio you want to view. Unifier 
displays the portfolios for this type in the right pane.  

4) In the portfolio type log window, click Create to create a new portfolio manager sheet, or to 
create a new portfolio manager sheet for the next planning period. 
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When you select an existing portfolio and click Create > Portfolio, or click Create > Plan for 
next period, the Add Portfolio window opens which has two blocks; the general block and 
the options block. For each block, enter the values in the fields and click Save. 

After you create a new portfolio, Unifier displays the portfolio name in the right pane and 
automatically creates an initial scenario sheet called Scenario 1. On this sheet, Unifier displays 
the projects that: 

 Are included in the scenario, if the projects are configured to be automatically added 

 Can be included on the scenario, if the project are configured to be manually added. 

The project records for the scenario sheet are extracted from the database using a query 
that your Administrator created when the portfolio was configured. Whenever you open a 
portfolio, Unifier re-runs the query and adds or removes projects from the scenario 
depending on whether or not the project matches the query criteria. For example, a project 
that was previously on the sheet may be dropped from the sheet if it no longer meets the 
query criteria. Another project may be added to the sheet because it now meets the query 
criteria. 

In this field: Do this: 

Portfolio 
Name 

Enter a name for the portfolio you are creating. 

Period Picker Select the year for which you want to analyze the data in this scenario. 

Creation Date This field shows the current date. 

In this field: Do this: 

Decimal 
Places 

Specify the number of decimal places the column data should display. 

Use 1000 
Separator (,) 

If you want the data to be formatted with a separator (for example, 
1,000, not 1000), select this check box. 

Negative 
Number 
Format 

Specify how negative values will be displayed on the sheet: with a 
negative sign, or in parentheses. 

Create a portfolio from an approved or shared portfolio 

Rather than create a completely new portfolio for your next planning period, you can save time 
and effort by "copying" a portfolio that has already been shared or approved for the current 
planning period. 

To create a new portfolio from an approved one 

1) Open the Portfolio Manager log and select the portfolio you want to copy for the new 
planning period. 

2) From the File menu, choose Plan for next period. The Portfolio Properties window opens. 
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The General tab of the Properties window will show the name of the portfolio you selected as 
the new portfolio’s name. In addition, the Planning Period field will display that portfolio’s next 
planning period by default. 

3) In the Name field, change the portfolio name. 

4) If necessary, you can change the planning period by clicking the drop-down list beside the 
Planning Period field. 

Note: The combination of the portfolio name and the planning period 
must be unique. 

5) If necessary, you can change the numeric format on the Options tab. 

6) Click OK. 

Unifier displays the portfolio name in the right pane and automatically creates an initial 
scenario sheet called Scenario 1. This scenario sheet will contain all the projects that were 
present in the portfolio you copied. These projects will show the data that was current for 
each project at the time the portfolio was copied, based on the matching monthly and yearly 
cash flow columns. For the new scenarios, Unifier will calculate the new totals and then 
calculate the variances to show the differences. 

Note: If the original portfolio contained monthly numbers, and the new 
portfolio contains only a year column, the monthly numbers will be 
consolidated for the year. Conversely, if a year column is being copied 
into a portfolio with monthly columns, the number will be divided into 
monthly columns. 

Sort a Portfolio Log 

You can sort the portfolio log by portfolio name into ascending or descending alphanumeric 
order. To do so, click the triangle icon on the right side of the Portfolio Name column. 

Find, Sort, and Delete a Portfolio 

Find a Portfolio 

For information on searching for a portfolio refer to Unifier General User Guide for details. 

Sort a Portfolio 

You can sort the portfolio log by portfolio name into ascending or descending alphanumeric 
order. To do so, click the triangle icon on the right side of the Portfolio Name column. 

Delete a Portfolio 

1) Open the Portfolio Manager log. 

2) Select the portfolio(s) you want to delete. 

3) On the toolbar, click the Delete button. 
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About Scenario Sheets (Classic View) 

As the budget forecast planner, you can create scenarios to plan an optimal portfolio of projects 
for the company, based on available budget targets and strategic goals.  

Portfolio management entails collaboration and negotiation between you, as the budget 
forecaster, and the project managers in your company. At their respective project levels, project 
managers maintain project information and create cash flow budgets and projections in the Cost 
Manager. 

In the Portfolio Manager, on the scenario sheets you create, Unifier collects the budget and 
projection numbers from the projects’ Cost Managers, as well as project start and end dates 
from the project information. 

During a scenario analysis, you can: 

a) Apply regional budget targets 

b) Group the projects in the scenario according to project characteristics 

c) Sort and filter the rows of project data and analyze the summary totals 

d) Accept the project managers’ budget numbers or propose new numbers 

e) Accept the schedule dates, or remove or postpone planned projects 

f) Create additional scenarios to reflect other possible forecasts 

Note: The numbers you propose in a scenario will NOT affect a project’s 
live data. Your proposed numbers are stored only in the Portfolio 
Manager and will not affect live project data until a scenario has been 
approved by your company management. 

During this analysis, you will likely be in touch with project managers to negotiate these numbers 
and dates until you reach agreement. 

Project managers will not see the changes you make on the scenario sheet. Instead, the project 
managers must create a "shared" type of portfolio budget curve. This curve shows your 
proposed numbers for the project. The project manager can include this curve on the cost 
worksheet, along with the forecast budget, or any other budget curve, in order to see the 
difference between the project’s numbers and your proposed budget numbers. 

In order for them to see the curve, you must share the scenario (see Share a Scenario (Classic 
View) (on page 485)). 

For information about the portfolio budget curve, see Creating Cash Flow Detail Curves in 
Projects and Shells. 

Once you have completed a budget forecast analysis using these scenarios, you can send the 
best (or several best) scenario(s) to the executive decision makers for approval by "sharing" the 
scenario. 



Working with Unifier Managers

469

Overview of a Scenario sheet 

Following is an example of a scenario sheet, shown in sections: 
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Open a Scenario Sheet (Classic View) 

On the Portfolio Manager log, double-click the portfolio that contains the sheet you want to open.   

Unifier displays one of these scenario sheets: 

 The scenario sheet marked "shared" 

 The scenario sheet that was last updated, if there is no shared scenario 

You can resize the column that is available in the left of the split. The fields, in the left side of the 
split, will be editable along with the fields in the right side of the split.  

In the Project Portfolio Manager (PPM) scenario sheet, regardless of their position (left or right 
splits), the following are considered special columns, and read-only: 

 Project Name 

 Project Number 

 Project State 

These fields are read-only because the option “Enable Column Editing” (in the Column 
Properties window) is not selected.  
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For the “Start Date” column, if the Project State is in execution, then the column will not be 
editable in the scenario sheet, whether placed in right or left side of the split. 

For the “Start Date” column, if the Project state is not in execution, since the field is editable in 
the right side of the split, if the column is moved to left it can be edited in that scenario sheet. 

The read-only fields will have font in italics and in color. 

The read-only columns will have a background color. 

The Editable fields will be in regular font. 

Upon selecting a row, the editable fields will get a white background, and the read-only cells will 
remain as they were. 

For a selected cell, the corresponding row, and column header, will be highlighted in color, with 
border. 

In a current scenario sheet, a triangle around the number of a cell, and row, denotes change in 
that cell for a particular project. Also, the tool-tip enables you review the changes in row, and 
change on particular cell.  

The current Project Data row and the selected row for the project will both have same 
background. 

You can distinguish which is the selected scenario sheet as against the other scenario sheets. 
The selected tab will be highlighted to help you distinguish the selected scenario sheet, against 
the other scenario sheets. 

Monthly Breakdown of Actuals Values in Scenario Sheet (Classic View) 

For the projects that are in-progress, where Forecast Curve is used (not the Baseline Curve), if 
the Administration has selected to display the monthly breakdown of Actuals (Display monthly 
breakdown of Actuals option in the portfolio Configuration window), then:   

 Within the Portfolio Manager for the current year, all months prior to the current month will 
display the corresponding value from the Actuals curve, and the fields will be read-only. 

 The current month will display the value from the Forecast, or the value from Actuals curve. 
Once the Actuals value is displayed, then the cell becomes read only. 

Similarly, the Pre-Actuals (in the Project Portfolio Manager) will contain the total, from the 
Actuals curve, for all previous years if the Actuals source is defined. 

Example 

For project City4, the user has defined Actuals source (in the Configuration window of the 
portfolio) for period 2017. 

For period between 1/1/16 to 12/1/17, the total Actuals amount is $7200. 

The Actuals total for period 1/1/16 to 12/16 is $5806.45.  

When the user opens the Project Portfolio Manager for period 2017, the "Pre-Actuals" 
column will show the total amount from Actuals for previous year (1/1/16 to 12/1/16), and the 
Cash flow Curve displays a steady incline. 

Considering it is May 2017: 
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When the Actuals source is defined (in project City4) for the columns from Jan 2017 to April 
2017, then when the selected tab in the Portfolio Manager is not shared or is not approved, 
the screen displays the corresponding value (read-only) that is coming from the Actuals 
curve in the Cashflow. 

For the month of May 2017, the corresponding values displayed for City4 will be editable, or 
read-only, based on the Period Close Settings fields, defined in the Cash flow properties 
("Enable auto snapshot on"). 

For the current year and current month, in the Portfolio Manager, the same logic applies as 
for the Forecast Curve in the Cashflow. 

Within the Portfolio Manager for the current year, for the current month, the logic will follow 
the same logic as for the forecast curve in the Cash flow (Cash flow by Forecast - CBS). 

If the "Enable auto snapshot on" option is checked, then: 

 If the current date is before the date defined then the value shown in Portfolio Manager 
(for the current month) will show the value from the Forecast Curve. 

 If "Replace current period forecast with Actual on cut off date" (in the Forecast options) is 
checked, then the value shown in the Portfolio Manager (for the current month) will be 
the value from the Forecast curve. 

 If the "Allow edit of current period forecast until replacement by Actuals" is checked, then 
the value shown in the Portfolio Manager (for the current month) will be editable; 
otherwise, it will be read-only. 

 If "Replace current period forecast with Actual on cut off date" (in the Forecast options) is 
not checked, then the value shown in the Portfolio Manager (for the current month) will 
be the value from the Actuals curve. 

 If the current date is on, or after, the date defined, then the value shown in the Portfolio 
Manager (for the current month) will show value from the Actuals curve and will be 
read-only. 

If the "Enable auto snapshot on" option is not checked, then the value shown in the Portfolio 
Manager (for the current month) will be from the Actuals curve and will be read-only. 

When the user shares the scenario in the Portfolio Manager, then only the "ALL values of 
Forecast" will be shared. 

If the Project Portfolio Manager (PPM) is unlinked, then for those scenarios the Actuals will 
be read-only for the previous months. 

For approved scenarios, the monthly Actuals are displayed as read-only only when the PPM 
is linked.  

Unless the Cash flow is refreshed (even after the checkbox is checked), the Actuals will not 
be displayed. 

Additional information 

Approved/shared date will reflect actuals spread data only if the project is unlinked. 

For the existing PPM Sheet, for prior years (e.g.,2014), the actual data is not displayed for yearly 
columns (e.g., 2015 or 2016). 

As the cash flow is refreshed, the current month forecast data will become non-editable in PPM 
even if the project is not linked. 
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As the cash flow is refreshed, the current month and the previous month baseline data will 
become non-editable in PPM even if the project is not linked. 

Multiple Forecast Curve 

If there are multiple forecast curves defined within a project, with different option setting, then 
Unifier displays a warning message (through a red triangle) in the current month cell when you 
hover over. In this case: 

 For the future months, the scenario sheet shows cumulative values on forecast. 

 For the prior months, the scenario sheet shows cumulative values for actuals. 

 For current month, the scenario sheet shows the cumulative actuals values which are linked 
to forecast as read-only, always. 

For support for monthly actuals, in case of consistent settings in multiple forecast curves, the 
behavior for the current, prior, and future months will be determined according to the existing 
functionality. 

Project Portfolio Manager (PPM)

Whether linked, or unlinked, in the scenario sheet, the approved and shared data actuals spread 
are displayed in the Cashflow. 

For the current month forecast data, whether the PPM is linked or unlinked, Unifier honors the 
forecast settings in the Cashflow. 

Yearly PPM

In an existing PPM scenario sheet, for prior years actuals, data is seen as read-only for yearly 
columns if the checkbox to show monthly actuals is checked in the PPM configuration. 

The current and future years will be determined according to the existing functionality. 

View a Scenario Sheet's Properties (Classic View) 

To view a scenario sheet’s properties, click the Properties button at the top of the sheet. The 
Properties will show you the following information:  

 Portfolio name 

 Planning period for the portfolio analysis 

 Date the portfolio was created 

 Any other fields of information that were added to the Portfolio Manager form 

Unlink or Link Projects (Classic View) 

When you create a scenario, Unifier populates the sheet with all the projects that have met the 
criteria for inclusion on the sheet. (These criteria were created in a query by your administrator 
when the Portfolio Manager was configured.) This is a dynamic process that occurs whenever 
you open a scenario sheet. The projects that appear on the sheet will fluctuate, depending on 
whether they still meet the criteria for inclusion. For example, a project that was previously on 
the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project 
may be added to the sheet because it now meets the query criteria.  
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According to the configuration your administrator created for the Portfolio Manager, all the 
projects on the scenario sheet will be automatically either linked or unlinked when you first open 
the scenario sheet. 

 If they are linked, the data on the scenario sheet is linked to the project data and is 
updated every time you open the sheet. Any new project that is added to the sheet will 
also be linked. 

 If they are unlinked, the data on the scenario sheet is not linked to the project data, and 
will not be updated by changes in the project data. Any new project that is added to the 
sheet will also be unlinked. 

You can link and unlink one or multiple projects. 

To link a project on the scenario sheet to current project data 

1) Select the project row(s) you want to link. 

2) Click the Link/Unlink button. Unifier will display a warning that any numbers you changed on 
the sheet will be lost if the project is linked. When the project is linked, you will see a link icon 
in the second column beside the project(s) name(s). 

3) Click the Save icon. 

To unlink a project from the scenario sheet 

1) Select the project row(s) you want to unlink. 

 For a single project row, click the link icon in the second column, or click the Link/Unlink
button. 

 For multiple project rows, click the Link/Unlink button. 

When the project is unlinked, Unifier will delete the link icon in the second column beside the 
project(s) name(s). 

2) Click the Save icon. 

You can also unlink a project by editing any cell in the row. Once you start editing, Unifier will 
automatically unlink the project from the project data. 
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If an unlinked project shows a discrepancy between the actual project data and the data you 
entered on the sheet, Unifier will display the numbers in italics and flag the actual cell data 
that differs with a dark bar. 

Edit Numbers on a Sheet (Classic View) 

A primary function of scenario sheets is to make it easy for you to modify numbers and see the 
resulting budget analysis quickly. You can edit the following numbers on the scenario sheet:  

 Cash flow projections 

 Targets for cash flows and numeric columns 

 Start and end dates for planned projects 

When you edit any of these numbers, Unifier dynamically updates totals and calculates the 
differences between target numbers and those totals; however, it does NOT change a project’s 
live data. Your proposed numbers are stored only in the Portfolio Manager and will not affect live 
project data until a scenario has been approved by your company management. 
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Note: When you edit numbers in any project row, Unifier automatically 
unlinks that project row from the project data. 

To edit numbers on the sheet 

1) Double-click the cell containing the number you want to change. The cell becomes editable. 

Note: If any yearly projections have been broken down into months, you 
must make your edits in the month cells, not the yearly total. 

2) Enter the change. 

3) Press the Enter key on your keyboard, or press the Tab key to move to the next editable cell 
in the row. 

Unifier updates the values in the Total and Difference rows for this column, and flags the cell 
to indicate that there is a discrepancy between the number you entered and the project data. 

Note: To leave a cell without saving your changes, press the ESC key 
on your keyboard. Unifier restores the original numbers to the cell. 

4) Click the Save All button. 

Drill Down to Project Data (Classic View) 

During the planning cycle, you might need quick access to project data in order to view project 
characteristics, schedule activities, cost data, cash flow data, and other information. In addition, 
you might need to update some of this data as you are working on a scenario. For this purpose, 
the project names on a scenario sheet are hyperlinked to the project. If you have permissions, 
you can open the project's landing page from the scenario sheet and view or edit data directly in 
the project.  

To drill down to project data 

On the scenario sheet, click the hyperlinked project name. Unifier opens the project landing 
page in a new window. From this page, you can navigate to project data and view or edit it 
directly. 

The scenario sheet remains open in a separate window so that you can easily work on both the 
project data and the scenario sheet at the same time. 

Change Start Dates (Classic View) 

You can change the start dates of planned projects, but not those in execution. When you 
change a start date, Unifier shifts the end date to preserve the project duration, and also shifts 
the cash flow numbers (excluding pre-actuals) left or right to preserve the cash flow distribution.  

To change a start date 

1) Double-click the date in the Start Date column. Unifier displays a calendar. 

2) Choose the new date from the calendar and press the Enter key on your keyboard. 

Unifier shifts the end date and the cash flow numbers to reflect the change. 
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Before date change: 

After date change: 

How Unifier Distributes Cash Flow 

Unifier stores all cash flow amounts by month in the database. The logic Unifier uses to 
distribute cash flow dollars is rendered in monthly allocations and presented as follows: 

 If you move the start date backwards by (for example) three months, Unifier will move all the 
cash flow amounts (excluding the pre-actuals column) left by three months and display a 
zero dollar amount in the last three month columns for that year. Amounts from the following 
fiscal year will not move left. 

 If you move a start date forward by three months, Unifier will move all the cash flow amounts 
(excluding the pre-actuals column) right by three months and display a zero dollar amount in 
the first three month columns. The cash flow amounts will continue to move forward in time, 
replacing the values of the next three months with the values of the past three months. If the 
cash flows through multiple years, the total for the next year will increase by the three 
months’ amount, and the monthly cash flow for the last three months of the previous year will 
replace the new year’s first three months. The rest of the new year’s monthly values will 
move forward three columns. 

Change Cash Flow Amounts (Classic View) 

You can change the cash flow amounts of any project on the sheet, planned or in execution. 
When you change a number in the cash flow amounts, Unifier unlinks the project from the live 
project data.  

To change a cash flow amount 

1) Double-click the cell containing the amount you want to change. 

2) Enter your change and press the Enter key on your keyboard. 

The project’s Total amount and the year’s total amount increases or decreases by the 
amount you entered. Unifier calculates the difference, indicates the edited column amounts 
in italics, and also places a dark bar at the top of the cell in the actual project data. 
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Before change: 

After change: 

Edit Project Information (Classic View) 

Your scenario sheets will typically contain some project information. If this project information 
was configured to be editable, you can edit it. If you do so, these changes will NOT affect the 
project’s live data. Your edits are stored only in the Portfolio Manager and will not affect live 
project data until a scenario has been approved by your company management. When the 
scenario is approved, specified edited shell information will be updated with the approved 
scenario data, and you will be notified by email of the updates.  
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You cannot edit: 

 Project name 

 Number 

 Status 

 Location 

Note: When you edit information in a project row, Unifier automatically 
unlinks that project row from the project data. 

To edit project information 

1) Double-click the cell containing the information you want to change. The cell becomes 
editable. 

2) Enter the change. 

3) Press the Enter key on your keyboard, or press the Tab key to move to the next editable cell 
in the row. 

Unifier updates the information in this column, and flags the cell to indicate that there is a 
discrepancy between the data you entered and the project's data. 

Note: To leave a cell without saving your changes, press the ESC key 
on your keyboard. Unifier restores the original numbers to the cell. 

4) Click the Save All button. 

Hide or Show Columns (Classic View) 

To make viewing information easier on either the scenario sheet or the project candidate list, you 
can hide any cash flow columns that might not contain data relevant to your current task.   

To hide a column 

1) Click the arrow beside the column name and choose Columns. 

2) On the list that appears, select the check box beside the columns you want to hide. Unifier 
removes those columns from view. 

To show a hidden column 

1) Click the arrow beside the column name and choose Columns. 

2) On the list that appears, de-select the check box beside the columns you want to show. 
Unifier opens those columns to view. 

Filter the Scenario Sheet (Classic View) 

To make viewing project information easier, you can use filters on both the scenario sheet and 
the project candidate list to narrow the focus of information to particular specifics, such as a date 
range, or a budget amount. For example, you might want to see only those projects in a specific 
date range, or only those projects with budgets greater than a specific amount, or projects of a 
specific type.  
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How you filter information depends on the column you choose to use as a filter. 

To filter information using a text column 

1) Click the arrow beside the column name and choose Filters. 

2) In the text box that appears, enter the text you want to use as a filter, such as a project name 
or prefix. 

Unifier displays those projects that match the text you entered. 

To filter information using a date column 

Click the arrow beside the column name and choose Filters. 

 Choose Before to specify a date period before a particular date. Click the date on the 
calendar that appears. Unifier displays all the projects with a date value that occurs 
before the date you specified on the calendar. 

 Choose After to specify a date period after a particular date. Click the date on the 
calendar that appears. Unifier displays all the projects with a date value that occurs after 
the date you specified on the calendar. 

 Choose On to specify a specific date. Click the date on the calendar that appears. Unifier 
displays all the projects with a date value that matches the date you specified on the 
calendar. 

To filter information using a numeric column 

Click the arrow beside the column name and choose Filters. 

 Enter a number "greater than" a specific number to display all the projects with numbers 
in that column greater than the number you specified. 

 Enter a number "less than" a specific number to display all the projects with numbers in 
that column less than the number you specified. 
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 Enter a number "equal to" a specific number to display all the projects with numbers in 
that column that match the number you specified. 

To return the sheet to an unfiltered state 

To return the sheet to an unfiltered state, click the arrow beside the column name and deselect 
the Filters check box. 

Group the Data on a Scenario Sheet (Classic View) 

You can group the data on the sheet by column. Grouping data can make it easier to identify 
projects with similar characteristics, such as estimated cost or start date. You can group by any 
column except the Pre-Actuals and year columns. When you group data, Unifier displays a 
sub-total amount by group.  

To group the data 

1) Identify the column by which you want to group the data and click the down arrow beside the 
heading. 

2) Select Group By This Field. 
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Unifier groups the data by the column value. Groupings are separated and identified by the 
column value you grouped on, such as Project State "In Execution" and "Planning." 

Once you have grouped the data, you can further refine the view by sorting and filtering the 
data within each group. 

3) If you want to maintain the data in this grouping, click the Save icon. Whenever you open the 
sheet, it will display the data in this grouping. 

To ungroup data 

1) Click the down arrow beside the column heading. 

2) Select Clear Grouping. 

Sort the Data on a Scenario Sheet (Classic View) 

To make data easier to locate alphanumerically on either the scenario sheet or the project 
candidate list, you can sort the information by column in ascending or descending order. To sort 
the sheet by column, click the arrow beside the column heading and choose Sort Ascending or 
Sort Descending.  

You can also sort the data by multiple columns. To do so, hold down the Ctrl key on your 
keyboard and click the arrows beside the column headings you want to sort by. 
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Create a New Scenario (Classic View) 

When you create a portfolio, Unifier automatically creates one initial scenario sheet. You can 
create additional scenario sheets.  

To create a new scenario sheet 

1) To add a new scenario sheet, click the plus sign at the bottom of the scenario sheet window. 

Unifier adds a "new scenario" tab to the bottom of the window. 

2) Enter a name for the new scenario and press the Enter key on your keyboard. 

You can include up to 30 characters in the name. Letters, numbers, hyphens, spaces, 
underscores, and special characters are allowed. 

3) Click Save All. 

The project records that will be included on the scenario sheet are extracted from the 
database using a query that your Administrator created when the portfolio was configured. 
Whenever you create or open a scenario sheet, Unifier re-runs the query and adds or 
removes projects from the scenario depending on whether or not the project matches the 
query criteria. For example, a project that was previously on the sheet may be dropped from 
the sheet if it no longer meets the query criteria. Another project may be added to the sheet 
because it now meets the query criteria. 

Edit the Name of a Scenario Sheet (Classic View) 

1) At the bottom of the scenario sheet window, double click on the tab showing the name you 
want to edit. The tab name becomes editable.  

2) Change the name as necessary. You can include up to 30 characters in the name. Letters, 
numbers, hyphens, spaces, underscores, and special characters are allowed. 

Copy a Scenario (Classic View) 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to copy.  

2) Click the manage scenarios icon and choose Duplicate Selected Tab. 

3) Click Save. 
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Unifier copies the scenario into a new tab, which you can rename. All the projects in the 
original scenario will be copied to the new scenario, including their linked or unlinked state, 
and current column widths, targets, sorting, etc. For the new scenario, Unifier will calculate 
the new totals and then calculate the variance to show the difference. 

Share a Scenario (Classic View) 

Sharing a scenario makes the budget numbers you propose available to project managers for 
viewing. Project managers will not see the changes you make on the scenario sheet itself. 
Instead, the project managers will use a read-only portfolio budget curve in their Cost Manager 
Cash Flow node to view both their original budget curve and a parallel scenario curve that 
shows the differences between their initial forecast projections and your proposed numbers.  

In order for project managers to see the portfolio budge curve, you must share the scenario. For 
information about the portfolio budget curve, see Creating Cash Flow Detail Curves in Projects 
and Shells. 

You must have "full access" permission to share a scenario. You can share only one scenario at 
a time. 

To share a scenario 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to share. 

2) Click the manage scenarios icon and choose Share Selected Tab. 

3) Click Save All. 

Unifier visually marks the scenario tab with a "shared" icon and makes the scenario numbers 
visible on the portfolio budget cash flow curve for the project manager to see. 

Stop sharing a scenario 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to stop sharing. 
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2) Click the manage scenarios icon and choose Stop Sharing Selected Tab. 

3) Click Save All. 

Delete a Scenario (Classic View) 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to delete.  

2) Click the manage scenarios icon and choose Delete Selected Tab. 

3) Click Save All. 

Approve a Scenario (Classic View) 

After management has approved a scenario for the portfolio, you can mark the scenario as 
"approved." You must have "full access" permission to approve a scenario.  

Once you approve a scenario, Unifier: 

 Marks the approved scenario "shared" so that project managers can see the approved dates 
and numbers. The scenario is set to read-only mode and can no longer be modified or 
deleted. 

 Updates each projects’ original budget numbers with the proposed numbers on the approved 
scenario. 

 Updates each projects’ monthly or yearly cash flow numbers with the proposed numbers on 
the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio’s planning period. 

 Updates the project/shell data with any project/shell information that was changed on the 
scenario sheet, and sends you an email notification of the updates 

 Locks the budget and cash flow numbers to prevent any further changes. 

To approve a scenario 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to approve. 
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2) Click the Manage Scenarios icon and choose Approve Selected Tab. 

3) Click Save All. 

When you approve a scenario, Unifier automatically shares the scenario and visually marks 
the scenario tab with an Approved and Shared icon to indicate to project managers that this 
is the approved scenario. 

To "un-approve" a scenario 

1) At the bottom of the scenario sheet window, select the tab containing the scenario you want 
to un-approve. 

2) Click the manage scenarios icon and choose Un-Approve Selected Tab. 

The Portfolio Manager deletes the approval icon from the tab, but does not delete the shared 
icon. If you want to stop sharing the scenario as well, you must click the manage scenarios 
icon and choose Unshare Selected Tab. 

3) Click Save All. 

Note: If you "un-approve" a scenario, Unifier does NOT reset dates to 
their original values. Date fields will retain the approved values. 

Export the Scenarios to Excel (Classic View) 

To use scenario data for additional purposes, you can export your scenario sheets to Excel.  

To export scenarios 

Click the Export button at the top of the window. The Portfolio Manager will export all of your 
scenario sheets to Excel. 

You will see a prompt at the bottom of the window, asking you to open or save the Excel sheets. 
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When you open the Excel sheet, it displays the data from each scenario sheet, arrayed in tabs 
and columns identical to the Portfolio Manager scenarios. The Excel sheet will include any 
formulas that were created in the Portfolio Manager for calculating values. The Excel sheet also 
honors the frozen columns, as well as the scrolling ability so that you can scroll through the cash 
flow columns. 

About Scenario Sheets (Standard View) 

As the budget forecast planner, you can create scenarios to plan an optimal portfolio of projects 
for the company, based on available budget targets and strategic goals.   

Portfolio management entails collaboration and negotiation between you, as the budget 
forecaster, and the project managers in your company. At their respective project levels, project 
managers maintain project information and create cash flow budgets and projections in the Cost 
Manager. 

In the Portfolio Manager, on the scenario sheets you create, Unifier collects the budget and 
projection numbers from the projects’ Cost Managers, as well as project start and end dates 
from the project information. 

During a scenario analysis, you can: 

a) Apply regional budget targets 

b) Group the projects in the scenario according to project characteristics 

c) Sort and filter the rows of project data and analyze the summary totals 

d) Accept the project managers’ budget numbers or propose new numbers 

e) Accept the schedule dates, or remove or postpone planned projects 

f) Create additional scenarios to reflect other possible forecasts 

Note: The numbers you propose in a scenario will NOT affect a project’s 
live data. Your proposed numbers are stored only in the Portfolio 
Manager and will not affect live project data until a scenario has been 
approved by your company management. 

During this analysis, you will likely be in touch with project managers to negotiate these numbers 
and dates until you reach agreement. 

Project managers will not see the changes you make on the scenario sheet. Instead, the project 
managers must create a "shared" type of portfolio budget curve. This curve shows your 
proposed numbers for the project. The project manager can include this curve on the cost 
worksheet, along with the forecast budget, or any other budget curve, in order to see the 
difference between the project’s numbers and your proposed budget numbers. 

In order for them to see the curve, you must share the scenario (see Share a Scenario (Classic 
View) (on page 485)). 

For information about the portfolio budget curve, see Creating Cash Flow Detail Curves in 
Projects and Shells. 
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Once you have completed a budget forecast analysis using these scenarios, you can send the 
best (or several best) scenario(s) to the executive decision makers for approval by "sharing" the 
scenario. 

Gannt View 

Gannt view shows you how capital is used over time. It allows you to quickly adjust schedules to 
achieve a better combination of projects within schedule and target. You can access a Gannt 
view of any scenario in which one or more projects is selected for budget planning. Click Gannt 
in the tool bar to display a Gannt distribution of proposed total over time on the grid. You can 
open the dialogue of select projects and add projects to the Gannt view. 

Make schedule adjustments by moving Gannt bars and adjusting the project schedule. You can 
view the target and difference rows simultaneously. You can also change start and end dates, 
and the Gannt view will update accordingly. Click Save or Cancel after making changes. 

Note: In the case of a standard planning period and if you have chosen 
some years as monthly, all Proposal Distribution columns will be 
displayed in months. 

Portfolio Dashboard 

The portfolio dashboard allows you to gather insights by looking at visual representations of Risk 
vs. Benefit, Investment vs. Return on Investment (ROI), and so forth. The dashboard displays all 
project data that has been selected in Budget Planning of the current scenario. Click Dashboard
at the top of the scenario sheet to view the portfolio dashboard. A bubble chart displays 
alongside six fields with drop-down menus: Chart Type, X-Axis, Y-Axis, Bubble Size, Shape, and 
Color. Use the drop-down menus to select values for each field. A bubble color legend is 
displayed below the chart.  

Click Reset to change all drop-down values to select.  

Click Apply to configure the chart based on your selections.  

Click Update to apply your configuration to the chart. The chart configuration saves upon 
clicking Update. 

Open a Scenario Sheet (Standard View) 

On the Portfolio Manager log, double-click the portfolio that contains the sheet you want to open. 

Unifier displays one of these scenario sheets: 

 The scenario sheet marked "shared" 

 The scenario sheet that was last updated, if there is no shared scenario 

You can resize the column that is available in the left of the split. The fields, in the left side of the 
split, will be editable along with the fields in the right side of the split.  

In the Project Portfolio Manager (PPM) scenario sheet, regardless of their position (left or right 
splits), the following are considered special columns, and read-only: 
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 Project Name 

 Project Number 

 Project State 

These fields are read-only because the option “Enable Column Editing” (in the Column 
Properties window) is not selected.  

For the “Start Date” column, if the Project State is in execution, then the column will not be 
editable in the scenario sheet, whether placed in right or left side of the split. 

For the “Start Date” column, if the Project state is not in execution, since the field is editable in 
the right side of the split, if the column is moved to left it can be edited in that scenario sheet. 

The read-only columns will have a background color. 

For a selected cell, the corresponding row, and column header, will be highlighted in color, with 
border. 

Monthly Breakdown of Actuals Values in Scenario Sheet (Standard View) 

For the projects that are in-progress, where Forecast Curve is used (not the Baseline Curve), if 
the Administration has selected to display the monthly breakdown of Actuals (Display monthly 
breakdown of Actuals option in the portfolio Configuration window), then:  

 Within the Portfolio Manager for the current year, all months prior to the current month will 
display the corresponding value from the Actuals curve, and the fields will be read-only. 

 The current month will display the value from the Forecast, or the value from Actuals curve. 
Once the Actuals value is displayed, then the cell becomes read only. 

Similarly, the Pre-Actuals (in the Project Portfolio Manager) will contain the total, from the 
Actuals curve, for all previous years if the Actuals source is defined. 

Example 

For project City4, the user has defined Actuals source (in the Configuration window of the 
portfolio) for period 2017. 

For period between 1/1/16 to 12/1/17, the total Actuals amount is $7200. 

The Actuals total for period 1/1/16 to 12/16 is $5806.45.  

When the user opens the Project Portfolio Manager for period 2017, the "Pre-Actuals" 
column will show the total amount from Actuals for previous year (1/1/16 to 12/1/16), and the 
Cash flow Curve displays a steady incline. 

Considering it is May 2017: 

When the Actuals source is defined (in project City4) for the columns from Jan 2017 to April 
2017, then when the selected tab in the Portfolio Manager is not shared or is not approved, 
the screen displays the corresponding value (read-only) that is coming from the Actuals 
curve in the Cashflow. 

For the month of May 2017, the corresponding values displayed for City4 will be editable, or 
read-only, based on the Period Close Settings fields, defined in the Cash flow properties 
("Enable auto snapshot on"). 

For the current year and current month, in the Portfolio Manager, the same logic applies as 
for the Forecast Curve in the Cashflow. 
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Within the Portfolio Manager for the current year, for the current month, the logic will follow 
the same logic as for the forecast curve in the Cash flow (Cash flow by Forecast - CBS). 

If the "Enable auto snapshot on" option is checked, then: 

 If the current date is before the date defined then the value shown in Portfolio Manager 
(for the current month) will show the value from the Forecast Curve. 

 If "Replace current period forecast with Actual on cut off date" (in the Forecast options) is 
checked, then the value shown in the Portfolio Manager (for the current month) will be 
the value from the Forecast curve. 

 If the "Allow edit of current period forecast until replacement by Actuals" is checked, then 
the value shown in the Portfolio Manager (for the current month) will be editable; 
otherwise, it will be read-only. 

 If "Replace current period forecast with Actual on cut off date" (in the Forecast options) is 
not checked, then the value shown in the Portfolio Manager (for the current month) will 
be the value from the Actuals curve. 

 If the current date is on, or after, the date defined, then the value shown in the Portfolio 
Manager (for the current month) will show value from the Actuals curve and will be 
read-only. 

If the "Enable auto snapshot on" option is not checked, then the value shown in the Portfolio 
Manager (for the current month) will be from the Actuals curve and will be read-only. 

When the user shares the scenario in the Portfolio Manager, then only the "ALL values of 
Forecast" will be shared. 

If the Project Portfolio Manager (PPM) is unlinked, then for those scenarios the Actuals will 
be read-only for the previous months. 

For approved scenarios, the monthly Actuals are displayed as read-only only when the PPM 
is linked.  

Unless the Cash flow is refreshed (even after the checkbox is checked), the Actuals will not 
be displayed. 

Additional information 

Approved/shared date will reflect actuals spread data only if the project is unlinked. 

For the existing PPM Sheet, for prior years (e.g.,2014), the actual data is not displayed for yearly 
columns (e.g., 2015 or 2016). 

As the cash flow is refreshed, the current month forecast data will become non-editable in PPM 
even if the project is not linked. 

As the cash flow is refreshed, the current month and the previous month baseline data will 
become non-editable in PPM even if the project is not linked. 

Multiple Forecast Curve 

If there are multiple forecast curves defined within a project, with different option setting, then 
Unifier displays a warning message (through a red triangle) in the current month cell when you 
hover over. In this case: 
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 For the future months, the scenario sheet shows cumulative values on forecast.For the prior 
months, the scenario sheet shows cumulative values for actuals. 

 For current month, the scenario sheet shows the cumulative actuals values which are linked 
to forecast as read-only, always. 

For support for monthly actuals, in case of consistent settings in multiple forecast curves, the 
behavior for the current, prior, and future months will be determined according to the existing 
functionality. 

Project Portfolio Manager (PPM)

Whether linked, or unlinked, in the scenario sheet, the approved and shared data actuals spread 
are displayed in the Cashflow. 

For the current month forecast data, whether the PPM is linked or unlinked, Unifier honors the 
forecast settings in the Cashflow. 

Yearly PPM

In an existing PPM scenario sheet, for prior years actuals, data is seen as read-only for yearly 
columns if the checkbox to show monthly actuals is checked in the PPM configuration. 

The current and future years will be determined according to the existing functionality. 

View a Scenario Sheet's Properties (Standard View) 

To view a scenario sheet’s properties, click the Menu Options button (icon with three horizontal 
lines) in the toolbar and select Properties. The Properties will show you the following 
information:   

 Portfolio name 

 Planning period for the portfolio analysis 

 Date the portfolio was created 

 Any other fields of information that were added to the Portfolio Manager form 

Unlink or Link Projects (Standard View) 

When you create a scenario, Unifier populates the sheet with all the projects that have met the 
criteria for inclusion on the sheet. (These criteria were created in a query by your administrator 
when the Portfolio Manager was configured.) This is a dynamic process that occurs whenever 
you open a scenario sheet. The projects that appear on the sheet will fluctuate, depending on 
whether they still meet the criteria for inclusion. For example, a project that was previously on 
the sheet may be dropped from the sheet if it no longer meets the query criteria. Another project 
may be added to the sheet because it now meets the query criteria.  

According to the configuration your administrator created for the Portfolio Manager, all the 
projects on the scenario sheet will be automatically either linked or unlinked when you first open 
the scenario sheet. 
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 If they are linked, the data on the scenario sheet is linked to the project data and is 
updated every time you open the sheet. Any new project that is added to the sheet will 
also be linked. 

 If they are unlinked, the data on the scenario sheet is not linked to the project data, and 
will not be updated by changes in the project data. Any new project that is added to the 
sheet will also be unlinked. 

You can link and unlink one or multiple projects. 

To link a project on the scenario sheet to current project data 

1) Select the project row(s) you want to link. 

2) Click the gear icon beside one of the selected rows and select Link, or click the cell in the 
Linked column of that row. Unifier will display a warning that any numbers you changed on 
the sheet will be lost if the project is linked. When the project is linked, you will see a link icon 
in the Linked column beside the project(s) name(s). 

3) Click the Save icon. 

To unlink a project from the scenario sheet 

1) Select the project row(s) you want to unlink. 

2) Click the gear icon beside one of the selected rows and select Unlink, or click the cell in the 
Linked column of that row. When the project is unlinked, Unifier will delete the link icon in 
the Linked column beside the project(s) name(s). 

3) Click the Save icon. 

You can also unlink a project by editing any cell in the row. Once you start editing, Unifier will 
automatically unlink the project from the project data. 

Edit Numbers on a Sheet (Standard View) 

A primary function of scenario sheets is to make it easy for you to modify numbers and see the 
resulting budget analysis quickly. You can edit the following numbers on the scenario sheet:  

 Cash flow projections 

 Targets for cash flows and numeric columns 

 Start and end dates for planned projects 

When you edit any of these numbers, Unifier dynamically updates totals and calculates the 
differences between target numbers and those totals; however, it does NOT change a project’s 
live data. Your proposed numbers are stored only in the Portfolio Manager and will not affect live 
project data until a scenario has been approved by your company management. 

Note: When you edit numbers in any project row, Unifier automatically 
unlinks that project row from the project data. 

To edit numbers on the sheet 

1) Double-click the cell containing the number you want to change. The cell becomes editable. 
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Note: If any yearly projections have been broken down into months, you 
must make your edits in the month cells, not the yearly total. 

2) Enter the change. 

3) Press the Enter key on your keyboard, or press the Tab key to move to the next editable cell 
in the row. 

Unifier updates the values in the Total and Difference rows for this column, and flags the cell 
to indicate that there is a discrepancy between the number you entered and the project data. 

Note: To leave a cell without saving your changes, press the ESC key 
on your keyboard. Unifier restores the original numbers to the cell. 

Click the Save All button. 

You cannot edit: 

 Project name 

 Number 

 Status 

 Location 

Drill Down to Project Data (Standard View) 

During the planning cycle, you might need quick access to project data in order to view project 
characteristics, schedule activities, cost data, cash flow data, and other information. In addition, 
you might need to update some of this data as you are working on a scenario. For this purpose, 
the project names on a scenario sheet are hyperlinked to the project. If you have permissions, 
you can open the project's landing page from the scenario sheet and view or edit data directly in 
the project.   

To drill down to project data 

On the scenario sheet, click the hyperlinked project name. Unifier opens the project landing 
page in a new window. From this page, you can navigate to project data and view or edit it 
directly. 

The scenario sheet remains open in a separate window so that you can easily work on both the 
project data and the scenario sheet at the same time. 

Change Start Dates (Standard View) 

You can change the start dates of planned projects, but not those in execution. When you 
change a start date, Unifier shifts the end date to preserve the project duration, and also shifts 
the cash flow numbers (excluding pre-actuals) left or right to preserve the cash flow distribution.  

To change a start date 

1) Double-click the date in the Start Date column. Unifier displays a calendar. 

2) Choose the new date from the calendar. 

Unifier shifts the end date and the cash flow numbers to reflect the change. 



Working with Unifier Managers

495

How Unifier Distributes Cash Flow 

Unifier stores all cash flow amounts by month in the database. The logic Unifier uses to 
distribute cash flow dollars is rendered in monthly allocations and presented as follows: 

 If you move the start date backwards by (for example) three months, Unifier will move all the 
cash flow amounts (excluding the pre-actuals column) left by three months and display a 
zero dollar amount in the last three month columns for that year. Amounts from the following 
fiscal year will not move left. 

If you move a start date forward by three months, Unifier will move all the cash flow amounts 
(excluding the pre-actuals column) right by three months and display a zero dollar amount in the 
first three month columns. The cash flow amounts will continue to move forward in time, 
replacing the values of the next three months with the values of the past three months. If the 
cash flows through multiple years, the total for the next year will increase by the three months’ 
amount, and the monthly cash flow for the last three months of the previous year will replace the 
new year’s first three months. The rest of the new year’s monthly values will move forward three 
columns.  

Change Cash Flow Amounts (Standard View) 

You can change the cash flow amounts of any project on the sheet, planned or in execution. 
When you change a number in the cash flow amounts, Unifier unlinks the project from the live 
project data. 

To change a cash flow amount 

1) Double-click the cell containing the amount you want to change. 

2) Enter your change and press the Enter key on your keyboard. 

The project’s Total amount and the year’s total amount increases or decreases by the 
amount you entered. Unifier calculates the difference, indicates the edited column amounts 
in italics, and changes the color of the text in the cell. 

Create and Manage Views on a Scenario Sheet (Standard View) 

To make viewing information easier on either the scenario sheet or the project candidate list, you 
can create views that show relevant cash flow columns. 

Create New View 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) In the Save View As field, enter a name for the view. 

3) Complete the Columns tab to determine which columns will be visible in this view. 

a. In the Columns tab, choose columns from the Available Columns list, and click the Move 
arrow to add columns to the Selected Columns list, or select the Move All double arrow 
to move all available columns to the Selected Columns list. 

b. You can remove columns from the Selected Columns list by selecting columns and 
clicking the Remove arrow or clicking the Remove All double arrow. 

4) Complete the Filters tab. See Filter the Scenario Sheet (Classic View). 

5) Complete the Group By tab. See Group the Data on a Scenario Sheet (Standard View). 
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6) Complete the Sort By tab. See Sort the Data on a Scenario Sheet (Standard View). 

7) When finished, click Save. 

Manage Views 

1) Click the View drop-down menu and select Manage Views. The Manage Views window 
opens.  

 In the Manage Views window, you can check the box in the Visible column to Show View 
or uncheck it to Hide View. 

 You can click the trash-can icon to Delete View. 

 You can click and drag views to reorder the way they will appear in the View drop-down 
menu. 

2) When finished, click Save. 

Filter the Scenario Sheet (Standard View) 

When creating a new view, you can make viewing project information easier by using filters on 
both the scenario sheet and the project candidate list to narrow the focus of information to 
particular specifics, such as a date range, or a budget amount. For example, you might want to 
see only those projects in a specific date range, or only those projects with budgets greater than 
a specific amount, or projects of a specific type.  

How you filter information depends on the column you choose to use as a filter. 

To filter information using a text column 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) Navigate to the Filters tab. 

3) Click into the drop-down menu of the text column that you want to filter. 

4) Select the appropriate qualifier from the drop-down menu, such as contains. 

5) In the text box that appears, enter the text you want to use as a filter, such as a project name 
or prefix. 

Unifier displays those projects that match the text you entered. 

To filter information using a date column 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) Navigate to the Filters tab. 

3) Click into the drop-down menu of the date column that you want to filter. 

 Choose a date "greater than" a specific date to display all the projects with dates in that 
column that occur after the date you specified. 

 Choose a date that is "greater than or equals" a specific date to display all the projects 
with dates in that column that occur after or on the date you specified. 

 Choose a date "less than" a specific date to display all the projects with dates in that 
column that occur before the date you specified. 

 Choose a date that is "less than or equals" a specific date to display all the projects with 
dates in that column that occur before or on the date you specified. 
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 Choose a date that "equals" a specific date to display all the projects with dates in that 
column that match the date you specified. 

 Choose a date that "does not equal" a specific date to display all the projects with dates 
in that column that do not match the date you specified. 

 Choose a date that is "between" specific dates to display all the projects with dates in 
that column that are between the dates you specified. 

 Choose a date that "is empty" to display all the projects without dates in the column that 
you specified. 

 Choose a date that "is not empty" to display all the projects that have dates in the 
column that you specified. 

To filter information using a numeric column 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) Navigate to the Filters tab. 

3) Click into the drop-down menu of the numeric column that you want to filter. 

 Enter a number "greater than" a specific number to display all the projects with numbers 
in that column greater than the number you specified. 

 Enter a number that is "greater than or equals" a specific number to display all the 
projects with numbers in that column greater than or equal to the number you specified. 

 Enter a number "less than" a specific number to display all the projects with numbers in 
that column less than the number you specified. 

 Enter a number that is "less than or equals" a specific number to display all the projects 
with numbers in that column less than or equal to the number you specified. 

 Enter a number that "equals" a specific number to display all the projects with numbers 
in that column that match the number you specified. 

 Enter a number that "does not equal" a specific number to display all the projects with 
numbers in that column that do not match the number you specified. 

 Enter a number that is "between" specific numbers to display all the projects with 
numbers in that column that are between the numbers you specified. 

When finished, you can click Clear to remove the filters you have created or Save to save them. 

Group the Data on a Scenario Sheet (Standard View) 

When creating a new view, you can group the data on the sheet by column. Grouping data can 
make it easier to identify projects with similar characteristics, such as estimated cost or start 
date. You can group by any column except the Pre-Actuals and year columns. When you group 
data, Unifier displays a sub-total amount by group.  

To group the data 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) Navigate to the Group By tab. 

3) Select the column by which you want to group the data from the drop-down menu. 

4) Next, select Ascending or Descending from the Order drop-down menu to determine the 
order in which the data will be displayed. 
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5) Add more groups by clicking on the gear menu and then clicking Add Below.  

 When you create multiple groups, you can use the gear menu to Add Above or Add 
Below.  

 When you create multiple groups, you can use the gear menu to Move Up or Move 
Down, to determine the order in which your groups will appear on the scenario sheet. 

 You can use the gear menu to Delete groups that you have created. 

6) When finished, click the Save icon. Whenever you open this view, it will display the data in 
this grouping 

Sort the Data on a Scenario Sheet (Standard View) 

To make data easier to locate alphanumerically on either the scenario sheet or the project 
candidate list, you can sort the information by column in ascending or descending order.  

To sort the sheet by column: 

Hover over the column heading. A set of arrows will appear. Click the arrows to sort the data. 

 Click the arrow once to sort Ascending. 

 Click the arrow second time to sort Descending. 

To sort the sheet by column when creating a view: 

1) In the View drop-down menu, select Create New View. The New View window opens. 

2) Navigate to the Sort By tab. 

3) Select the column in which you want to sort the data from the drop-down menu. 

4) Next, select Ascending or Descending from the Order drop-down menu to determine the 
order in which the data will be displayed. 

5) Sort more columns by clicking on the gear menu and then clicking Add Below.  

 When you sort multiple columns, you can use the gear menu to Add Above or Add 
Below.  

 You can use the gear menu to Delete sortings that you have created. 

6) When finished, click the Save icon. Whenever you open this view, it will display the data in 
the way you have sorted it.  

Create a New Scenario (Standard View) 

When you create a portfolio, Unifier automatically creates one initial scenario sheet. You can 
create additional scenario sheets. 

To create a new scenario sheet 

1) Click the plus sign at the top of the scenario sheet window. 

Unifier adds a "new scenario" tab to the top of the window. 

2) Enter a name for the new scenario and press the Enter key on your keyboard. 
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You can include up to 30 characters in the name. Letters, numbers, hyphens, spaces, 
underscores, and special characters are allowed. 

The project records that will be included on the scenario sheet are extracted from the database 
using a query that your Administrator created when the portfolio was configured. Whenever you 
create or open a scenario sheet, Unifier re-runs the query and adds or removes projects from 
the scenario depending on whether or not the project matches the query criteria. For example, a 
project that was previously on the sheet may be dropped from the sheet if it no longer meets the 
query criteria. Another project may be added to the sheet because it now meets the query 
criteria.  

Edit the Name of a Scenario Sheet (Standard View) 

To edit the name of a scenario sheet 

1) At the top of the scenario sheet window, double click on the tab showing the name you want 
to edit. The tab name becomes editable. 

2) Change the name as necessary. You can include up to 30 characters in the name. Letters, 
numbers, hyphens, spaces, underscores, and special characters are allowed. 

Duplicate a Scenario (Standard View) 

To duplicate a scenario 

1) At the top of the scenario sheet window, select the tab containing the scenario you want to 
duplicate.  

2) Click Duplicate in the top, right-hand corner of the window. 

Unifier duplicates the scenario into a new tab, which you can rename. All the projects in the 
original scenario will be duplicated to the new scenario, including their linked or unlinked 
state, and current column widths, targets, sorting, etc. For the new scenario, Unifier will 
calculate the new totals and then calculate the variance to show the difference. 

Share a Scenario (Standard View) 

Sharing a scenario makes the budget numbers you propose available to project managers for 
viewing. Project managers will not see the changes you make on the scenario sheet itself. 
Instead, the project managers will use a read-only portfolio budget curve in their Cost Manager 
Cash Flow node to view both their original budget curve and a parallel scenario curve that 
shows the differences between their initial forecast projections and your proposed numbers.  

In order for project managers to see the portfolio budge curve, you must share the scenario. For 
information about the portfolio budget curve, see Creating Cash Flow Detail Curves in Projects 
and Shells. 

You must have "full access" permission to share a scenario. You can share only one scenario at 
a time. 

To share a scenario 

1) At the top of the scenario sheet window, select the tab containing the scenario you want to 
share.  
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2) Click Share in the top, right-hand corner of the window. 

3) Click Save. 

Unifier visually marks the scenario tab with a "shared" icon and makes the scenario numbers 
visible on the portfolio budget cash flow curve for the project manager to see. 

To stop sharing a scenario 

1) At the top of the scenario sheet window, select the tab containing the scenario you want to 
stop sharing.  

2) Click UnShare in the top, right-hand corner of the window. 

3) Click Save. 

Remove a Scenario (Standard View) 

To remove a scenario 

1) At the top of the scenario sheet window, click the x on the tab containing the scenario you 
want to delete, or 

2) Right click the tab containing the scenario you want to delete, and select Remove. 

3) Click Save.   

Approve a Scenario (Standard View) 

After management has approved a scenario for the portfolio, you can mark the scenario as 
"approved." You must have "full access" permission to approve a scenario.  

Once you approve a scenario, Unifier: 

 Marks the approved scenario "shared" so that project managers can see the approved dates 
and numbers. The scenario is set to read-only mode and can no longer be modified or 
deleted. 

 Updates each projects’ original budget numbers with the proposed numbers on the approved 
scenario. 

 Updates each projects’ monthly or yearly cash flow numbers with the proposed numbers on 
the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio’s planning period. 

 Updates the project/shell data with any project/shell information that was changed on the 
scenario sheet, and sends you an email notification of the updates 

 Locks the budget and cash flow numbers to prevent any further changes. 

To approve a scenario 

1) At the top of the scenario sheet window, select the tab containing the scenario you want to 
approve. 

2) Click Approve in the top, right-hand corner of the window. 

3) Click Save. 
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When you approve a scenario, Unifier automatically shares the scenario and visually marks 
the scenario tab with an Approved and Shared icon to indicate to project managers that this 
is the approved scenario. 

To "un-approve" a scenario 

1) At the top of the scenario sheet window, select the tab containing the scenario you want to 
un-approve. 

2) Click UnApprove in the top, right-hand corner of the window. 

3) Click Save. 

The Portfolio Manager deletes the approval icon from the tab, but does not delete the shared 
icon. If you want to stop sharing the scenario as well, you must click Unshare in the top, 
right-hand corner of the window. 

Note: If you "un-approve" a scenario, Unifier does NOT reset dates to 
their original values. Date fields will retain the approved values. 

Export the Scenarios (Standard View) 

To use scenario data for additional purposes, you can export your scenario sheets to CSV files 
or Excel sheets.  

To export scenarios 

Click the Print button at the top of the window. Then select Export to CSV or Export to Excel. 
The Portfolio Manager will export all of your scenario sheets. 

You will see a prompt at the bottom of the window, asking you to open or save the files. 

When you open the file, it displays the data from each scenario sheet, arrayed in tabs and 
columns identical to the Portfolio Manager scenarios. The sheet will include any formulas that 
were created in the Portfolio Manager for calculating values. The sheet also honors the frozen 
columns, as well as the scrolling ability so that you can scroll through the cash flow columns. 

Financial Period in Portfolio Manager 

If you select the financial period type of the period structure in the configuration of Portfolio 
Manager, then Unifier summons all of the sub-periods, based on the selected planning period 
(drop-down list), starting from the year.  

When you select Financial period in the time scale of Cash Flow curve, then Unifier populates 
the financial period (present in the Shell options) in the financial period field of that Cash Flow 
curve. 

The financial period present in the Shell options of parent Shell will not be used to filter projects 
in Portfolio Manager 

Note: Once, a financial period from the Shell is being used in a portfolio, 
then you will not be able to change it in the future unless you delete all of 
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the scenarios associated with it. 

Unifier displays all of the periods (and their names) in Portfolio Manager as individual columns. 

The scenario sheets brings in the following data from any Shell type in a hierarchy: 

 Project information from the Shell Attribute Form 

 Project information from a single-record business process 

 Project start and end dates from the Shell Attribute Form 

 Project start and end dates from a single-record business process 

 Cash Flow data (both forecasted and actual) from each project Cost Manager 

 Column names in the Portfolio manager will be the period name from financial period. 

 Forecast & Actuals data will be populated only when user chooses the Forecast option in 
Cashflow “Begin calculations at the end of the curve.” 

 Forecast data will be populated if “Display financial period breakdown of Actuals” checkbox 
is unchecked. 

 Actuals data will be populated if “Display financial period breakdown of Actuals” checkbox is 
checked. 

 Baseline data will be populated if user has not used the option in Forecast “Begin 
calculations at the end of the curve.” 

Once these scenario analyses have been completed, you can send the best (or several best) 
scenarios to the executive decision makers for approval. Once a scenario has been approved, 
Unifier: 

 Marks the approved scenario "shared" so that project managers can see the approved dates 
and numbers. In this case, the scenario is set to read-only mode and can no longer be 
modified or deleted. 

 Updates each project's original budget numbers with the proposed numbers on the approved 
scenario. 

 Updates each project's monthly or yearly cash flow numbers with the proposed numbers on 
the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio’s planning period. 

 Locks the budget and cash flow numbers to prevent any further changes. 

Note: The pre-actuals will be the consolidated amount for actuals before 
the start of Financial Period. 
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Unifier Planning Manager 

The Planning Manager provides sponsoring companies the ability to create, organize, manage, 
and update all company or project/shell planning initiatives from conception to completion. It 
supports the ability to define unlimited number of planning categories, such as capital project 
planning, IT planning, resource planning, etc., providing a flexible method for managing and 
organizing any type of planning initiative. 

The Planning Manager provides the flexibility of defining unique planning item property forms 
and planning sheets. Each planning sheet can be configured with any number of columns to 
capture and manage data for all planned items. 

In addition, the planning sheet can be configured to compare planned data with actual rolled up 
data from Unifier projects/shells, related to each planned initiative. 

The Planning Sheet is central to Planning Manager functions. Each planning item "type" (such 
as a capital plan or a campus remodel) can have one or more planning sheets that contain 
information about the plans of this type being considered by your company or project. It is from 
these sheets that you can access, create, update, and import or export company plans. 
Business processes designed for planning items can roll up information onto the planning 
sheets. In addition, Project/Shell Creation types of business processes can be designed to 
create new projects or shells for planning items when they reach a certain status or condition. If 
the Project/Shell Creation BP includes a Planning Item Picker, you can link new projects/shells 
with a planning item. At runtime in Unifier, this BP will automatically create a link to the planning 
item when the project/shell is created, and data will begin to roll up to the Planning Sheet from 
the business processes in this project/shell. 

In Unifier, the Planning Items node is where you create new plans and proposals, import plans 
from outside applications, export a plan template, and link a plan to a running project or shell in 
Unifier. 

The Planning Sheets node is where you create and manage planning sheets. A planning sheet 
can contain data for one or multiple plans and proposals. From the planning sheet, users can 
automatically update individual plans with data added to the planning sheet and refresh the data 
on the sheet, such as changes to dates or cost numbers. 
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About the Planning Manager 

The Planning Manager is where you can plan for new projects/shells and proposals and create 
forecasts for those projects/shells that are already running in Unifier. You cannot administer 
planned projects/shells the way you administer real projects/shells in Unifier; however, you can 
manage the planning phases for these projects/shells as business processes in Unifier using the 
same functions used by other business processes. Planned projects/shells can include cost 
sheets, resource sheets, funding sheets, and other typical business processes; but certain data, 
such as dates and monies, can be viewed as future forecasts. 

You can have a Planning Manager at both the company and project/shell levels. 

The Planning Sheet is central to Planning Manager functions. This sheet contains information 
about all the plans (planning items) being considered by your company. It is from this sheet that 
you access, create, update, and import or export the company’s plans. From the planning sheet, 
you can automatically update plans with changes made on the planning sheet. Reciprocally, you 
can refresh the planning sheet with changes made to individual plans. In addition, planning 
sheets can be configured to compare planned data with actual rolled-up data from Unifier 
projects/shells related to each planning item. 

Using a Project/Shell Creation type of business process, you can create new projects or shells 
for planning items when they reach a certain status or condition. If the Project/Shell Creation 
business process includes a Planning Item Picker, you can link new projects/shells with planning 
items. Instead of linking a planning item to a project in the Planning Manager, this business 
process will automatically create the link when the project/shell is created, and data will begin to 
roll up to the Planning Sheet from the business processes in this project/shell. 
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Using Unifier’s snapshot feature, you can take a "picture" of the planning sheet at any point in 
time. This is a way of "drilling down" into the planning process to expose specific plans or 
planning phases for particular attention. 

In Unifier, the Planning Items node is where you create new plans and proposals, import plans 
from outside software applications, export a plan template, and link a plan to a running project or 
shell in Unifier. 

The Planning Sheets node is where you create and manage planning sheets. A planning sheet 
can contain data for one or multiple plans and proposals. From the planning sheet, you can 
automatically update individual plans with data added to the planning sheet and refresh the data 
on the sheet, such as changes to dates or cost numbers. 

Access planning items and planning sheets 

The Planning Manager groups planning initiatives by planning type; for example, Capital 
Planning or IT Planning. Each planning type will have a node available for planning items in that 
type, and also for planning sheets to manage the planning initiatives. 

Planning items and sheets are grouped by their planning type. 

To view planning items and planning sheets 

1) In User Mode, navigate to: 

 (For a Planning Manager at the company level) Go to the Company Workspace tab and 
click Planning Manager in the left Navigator. 

 (For a Planning Manager at the project/shell level) Open the shell or sub-shell where the 
Planning Manager resides. In the Navigator, click Planning Manager. 

Unifier expands the navigator to show the planning types and their corresponding items and 
sheets. 

2) To view: 

 Planning items, choose a <planning type> - Items

 Planning sheets, choose a <planning type> - Sheets

Unifier displays the items or sheets in the right pane. 

Note: If an advanced log has been designed for the Planning Manager, 
the log will display a tree structure with a middle column that narrows the 
navigation to help you locate and select the correct item or sheet. 

3) To open the item or sheet, double-click the name of it in the right pane. 

Access Planning Items from Master Log - Business Processes node 

The Master Log - Business Processes node can list all planning items at the shell/project level 
in separate nodes for each type. 
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Note: The name of the Master Log - Business Processes node can be 
customized. 

If you are an active member of the project, shell, or sub-shell, and you have permissions, you 
can access shell/project planning item records from the Master Log - Business Processes
node. The Master Log - Business Processes node is in the Home page. The Master Log - 
Business Processes node allows you to access all or a subset of records of the same type, in 
a single log that spans multiple shells/projects. Also, you can create and use saved searches 
under the Master Log - Business Processes node. 

Note: If you do not have permissions to view any of the business 
process types listed under the Master Log - Business Processes
node, then you will not see the Master Log - Business Processes node 
in the Home page. 

Records are listed under the Master Log - Business Processes node by planning item type. 
The Master Log - Business Processes node can be renamed by your Administrator, and 
access to the node depends on permissions. 

Depending on permissions, you can perform these actions on records listed in a Master Log: 

 Create a new record 

 Edit an existing record 

 Perform bulk edits on records 

You can also save searches of records in the Master Logs as needed. 

To access Master Logs 

1) Go to the Home page and click Master Log - Business Processes node (or Master Logs - 
Planning Items node) in the left Navigator. 

2) Click the name of the planning item you want to access. 

Create a planning item 

To create a planning item 

1) Navigate to: 

 (For a Planning Manager at the company level) Go to the Company Workspace tab and 
click Planning Manager in the left Navigator. 

 (For a Planning Manager at the project/shell level) Open the project or shell here the 
Planning Manager resides and click Planning Manager in the left Navigator. 

Unifier expands the navigator to show the planning types and their corresponding items and 
sheets. 

2) Click the [planning item] - Items node. The [planning item] log opens. 

3) Click New. The planning item form opens. 

4) Complete the form fields. The form fields will vary depending on the design of the form for 
this planning type. 
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Note: If the planning item form has a Project or Shell Picker, you can 
use it to link the planning item directly to a project/shell. Business 
processes in the project or shell with fields that match those on the 
planning item form will roll up values to the Planning Sheet. 

5) (Optional) Add an attachment to the planning item. 

Click the Add Attachment button on the tool bar and select the place where the attachment 
resides, on your computer, or in a Unifier folder. 

For a file on your computer, the File Upload window opens. Under Document Title, enter the 
title of the attachment you want to include, or click the Browse button to browse the 
directories on your computer for the file. 

To add multiple attachments, click the Add Row button and repeat the step above. 

When you have added the attachments, click OK. 

You can also choose other options, such as including reference files and automatic revision. 
To do so, click the Advanced Options button. 

For a Unifier file, the Select Files window opens, showing the company documents you can 
choose from. 

Select the file and click OK. 

6) Save the form (click Save to save or Finish Editing to prevent further editing). 

Bulk Edit Planning Items from the Planning Manager Log 

For instructions on editing these records in bulk refer to the Unifier Business Processes User 
Guide. 

Delete planning items 

You can delete planning items if they are in a non-terminal status. You can delete planning items 
in two ways: 

 From the planning item record itself 

 From the Planning Manager Log using Bulk Delete mode 

Note: When you delete a record in Unifier, it is not actually deleted. It is 
only hidden from view on the log; the record remains in the system. 
Consequently, you cannot create another record with the same name. If 
there is a business process that auto-creates a planning item record, the 
name of that planning item will need to be changed; otherwise, you will 
never see it on the log. 

To delete a planning item from a record 

Open the record and click the Delete button on the toolbar. 

To delete planning items from the Planning Manager log 

1) Open the planning items log. 
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2) Highlight the item or items you want to delete. 

3) From the Edit menu, choose Bulk Delete. 

Note: You cannot delete planning items from a master log. 

Create a planning sheet 

You can create planning sheets for each planning type. These are based on templates created 
in Administration Mode. 

To create a planning sheet 

1) Navigate to: 

 (For a Planning Manager at the company level) Go to the Company Workspace tab and 
click Planning Manager in the left Navigator. 

 (For a Planning Manager at the project/shell level) Open the shell or sub-shell where the 
Planning Manager resides and click Planning Manager in the left Navigator. 

The Navigator expands to show the planning types and their corresponding items and 
sheets. 

2) Under the planning type for which you want to create a sheet, click the [planning item] - 
Sheet node. The planning sheets log opens. 

3) Click New. The Properties window opens. 

4) On the General tab, name the planning sheet and enter an optional description. 

5) Click the Options tab. For: 

 Sort by Column: Choose the column to sort the planning item rows by. The default is 
Name (planning item name). As you add additional columns to the sheet, these columns 
will be available to select. 

 Sort Order: Choose Ascending or Descending; works in conjunction with Sort by 
Column. 

 Update Planning Items: Select this checkbox if you want planning sheet users to be 
able to manually edit planned item data. This helps prevent conflicting data from multiple 
planning items. This box can be checked on only one sheet per planning type. When you 
select this box, the sheet is moved to the top of the log and displayed in bold font, 
thereby acting as a master planning sheet. 

6) Click OK. The planning sheet opens. The columns are those defined in the default structure. 
You can add additional columns as needed. Rows correspond to planning items. See Add 
and manage planning sheet rows (on page 509). 

Copy a planning sheet 

The user will be allowed to create a new planning sheet under a planning type by copying 
another planning sheet. When a planning sheet is created by copying another planning sheet, all 
column definitions, manually entered data with each row should be replicated (copied over) 
including column definitions. 
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To create a planning sheet by copying another planning sheet 

1) Select a planning sheet from the Planning Sheet log window. 

2) Click the Copy button. The Properties window opens. 

3) Enter a name for the new sheet. You can change the selections in the Options tab. 

4) Click OK. 

Open the planning sheet 

To open a planning sheet: 

From the log window, double-click a sheet or select a sheet and click the Open button. 

Columns displayed initially are based on the planning sheet default structure defined in 
Administration Mode (Configuration node). 

Add and manage planning sheet rows 

You can add planning items of the same type to create rows on the planning sheet. By default, 
there are two rows at the bottom of the sheet, one for total and one for average, which add a 
summary row for the column data. 

To add a row (planning item) to a planning sheet 

1) Open the planning sheet. 

2) Click the Add Rows button. The planning items window opens, displaying the planning items 
created for the planning type. 

3) Select one or more items and click Add Row. The rows are added to the sheet. 

To delete a row from the planning sheet 

1) Open the planning sheet. 
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2) On the planning sheet, select one or more rows to delete. 

3) Click the Delete Rows button. 

4) Click Yes to confirm. The rows will be removed from the sheet. 

View column details 

Clicking on a column link from the planning sheet will display the column details. 

View column details

Refresh a planning sheet 

Refreshing the planning sheet will update all rolled-up column data. This process runs in the 
background and may take some time to complete, depending on the design of the sheets being 
updated. 

To refresh a planning sheet 

1) Navigate to the planning sheet log. 

2) Select one or more planning sheets and click the Refresh button. 

Once the Refresh button is clicked, the Last Update column (if the log window was designed 
to show this column) will display In Progress to indicate that the planning sheet is getting 
refreshed. When the refresh is complete, the Last Update column will show the date on 
which the sheet was updated. Do not open the sheet while refresh is in progress. 

Modify planning items from a planning sheet 

You can update planning item information from a planning sheet. The Update planning items
option must be selected in the planning sheet properties (Options tab). 

While defining columns on a planning sheet, data elements from the planning item can be 
selected. Some of these data elements can be edited from the planning sheet. Changes made 
to these elements are reflected on planning items automatically. 

Data elements that are editable and not required on the planning item form will be editable from 
the planning sheet. The following are conditions under which a data element is not editable from 
the sheet: 

 BP picker data elements 

 Project picker 
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 Shell picker 

 Data elements that are required on the form 

 Data elements that are of SYS Logical Datasource (formulas) 

 Data elements that are SYS Datasource 

You cannot change the planning name. This can only be changed from the planning item 
window. 

Grant planning sheet permission 

In addition to module-level permission, access to each planning item and planning sheet can be 
controlled based on user side permissions. The creator of a planning sheet is the owner of the 
sheet. By default, the owner has full sheet permissions. The owner can grant permission to other 
users or groups as needed. 

To grant permissions to a planning sheet 

1) In the planning sheet log, select the planning sheet. 

2) Click the Permissions button. The Edit Permission window opens. 

3) Add the users or groups you wish to grant permission, set the permission level, and click 
OK. The permission settings are: 

 Modify Permission: Can view, edit, and modify permissions of a planning sheet. 

 Modify Properties: Can edit planning sheet properties. 

 Edit: Can view, add, edit, or import data on a planning sheet. The user cannot change 
the column structure. 

 View: Can view the planning sheet in view-only mode. 
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Grant permission to the planning sheet 

To grant permissions to a planning item 

1) Open the Planning Item log that contains the item you want to grant permissions to. 

2) Select the planning item. 

3) Click the Permission button. The Edit Permission windows opens. 

4) Add the users or groups to whom you want to grant permissions and set the permissions you 
want to grant. 

 Modify Permission: Users can view, edit, and modify permissions of the planning item. 
With this permission, you automatically give the user edit and view permissions. 

 Edit Data: Users can edit the planning item information. 

 View: Users can view the planning item but cannot make changes. 

5) Click Apply if you want to grant permissions to more users. Click OK to apply the 
permissions and close the window. 

Understanding Reverse Auto-population 

Certain data elements support reverse auto-population. These are specified in uDesigner. 
Reverse auto-population means that some values can be updated when other values are 
modified in a business process record that has reached a specified status. 

Depending on the setup in uDesigner, auto-population can occur in these instances: 

 Changes to data elements in a BP upper form can result in changes to the upper form of 
another BP. 

 Changes to the detail form in a BP can result in changes to the upper form and detail form of 
another BP. 

 Changes to the upper form or detail form of a BP can result in changes in the Asset, 
Resource, or Planning Manager forms. 

Print a Planning Manager Form 

You can print a copy of a Planning form. You can choose PDF, HTML or Custom print formats 
and select one of the following options: 

 Save a copy of the form as a PDF file and print the file 

 Print an HTML view 

 Print from a Word file if a custom print layout has been created for the form 

The Custom Print formats include the BI Publisher custom print templates designed in the 
Custom Templates node. If custom print layouts have been created for the Planning Manager, 
the form will print according to the layout that you select. See the following Custom Format Print 
Options for details. See the following Printing Options - Custom Format for details. 

To preview and print a Planning Manager item: 

1) Open the planning item that you want to print. 

2) From the File menu, choose Print Preview, then choose one of the following: 

 HTML to view the form in the browser which can then be printed. 
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 PDF to open the form in Adobe Reader, which can be saved or emailed as a PDF file, or 
printed process, you are asked to save the changes to the form. 

 Custom to select the BI Publisher, Microsoft Word, and PDF custom print templates from 
the same place as the current custom prints. See the following Printing Options - 
Custom Format for details. 

The Print Options window opens. This window displays the record information that can be 
printed. 

3) Select the checkboxes for the information that you want to print. 

4) To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the 
Select All checkbox. If you deselect all checkboxes, only the header and footer will print. 

5) Click OK. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, 
from which you can print. 

If you chose PDF, you can save a copy by clicking the Save a Copy button, or print. To print 
from HTML format, click on the Print icon in the upper right corner. 

Print Options for Planning Manager Form 

Following is a summary of the print options. 

Print option What it prints 

Detail Form This prints the information entered on the form. 

General 
Comments 

The general comment text and create details are printed. 

Record 
Attachments 

File attachments to the record are listed alphabetically by file name, 
and also include the file title, issue date, revision number, and file 
size. 

Record 
Attachments > 
Comments 

Prints comments associated with file attachments to the record. 
"Record Attachments" must also be selected to select this option. 

To print a Planning Manager item with a custom print layout: 

1) Open the planning item that you want to print. Be sure it is in a view mode. 

2) From the File menu, choose Print Preview, then choose Custom to select the BI Publisher, 
Microsoft Word, or PDF custom print templates from the same place as the current custom 
prints (Custom Format Print selection window). 

3) Select a layout and click OK. The File Download window opens. 

4) Choose to Open or Save the file, which is a Microsoft Word DOC file. 

5) Open the file in Microsoft Word and print. (This feature works with Microsoft Word 2003 and 
2007.) 

Printing Options - Custom Format 

The Custom Format Print window has two sections: 

 Select a custom print template 
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 Select a template and format to print 

Both sections facilitate custom print template and format selections. 

Select a custom print template

Lists all the custom print templates, including the custom print templates created in the Custom 
Templates node and the custom print templates. For example, the list may include BI Publisher 
custom print templates, Word, and PDF custom print templates.  

If there are multiple custom print templates, all the published templates are listed in this section.  

The "Select a template and format to print" is populated by the selection made in the "Select a 
custom print template" section.  

Select a template and format to print

 If you select a BI Publisher custom print, then you can select the desired template and 
format from the drop-down lists. 

 Template drop-down displays all the available templates for the selected format.  

 Format drop-down displays the available formats for the selected template. 

 If the custom print template was created using PDF or Word, then the "Select a template and 
format to print" is disabled. 

Default template and format

 If a BI Publisher print template is selected, then the default values in the drop-down lists are 
set based on the default in the custom print template.  

 When a BI Publisher print template is selected in the "Select a custom print template" 
section, the template and format are populated based on the default value selected at the 
time of designing the print template. 

Planning Manager with Redesigned User Interface 

Similar to a business process, the Level attributes can be accessed through the redesigned user 
interface which provides a better visibility.  

Note: For details about the existing functionalities, not described in this 
section, refer to the topics under the Unifier Planning Manager. 

Planning Manager Item Log (Attributes) 

The Planning Item log displays the log and the preview pane (Company Workspace > User
mode > Planning Manager). 

Note: The functions of the options presented below have been explained 
in the preceding sections. This section explains new functions and 
procedural differences. 

The log contains the following toolbar options: 

 Create
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When you click Create to create a new record, the Create New Planning - Item window 
opens. The three horizontal bars icon enables you to update a record and access the 
following: 

 Auto-create

 Print

 Reload

 Terminate Record

 Transfer Ownership

 Delete

 Help

 Close

Note: When you are updating a record, the following additional tabs are displayed: Audit 
Log and Reference Records. 

During the creation step, the record has the following tabs: 

 Comments

Enables you to add comments to the Planning attribute, only in the edit mode. 

 Linked Records

Enables you to link records to the Planning attribute. The functional flow is the same as a 
non-workflow business process. 

 Actions

 View

 Settings

 Refresh

 Print

 Search

 Find on page

 Help

The Actions option enables you to: 

 Import

 Export CSV Template

 Edit Permission

 Bulk Edit

 Print

 Transfer Ownership

 Terminate Record

 Delete

For each record, the gear ( ) menus are as follows and each option enables you to conduct 
the action on one particular record. 

 Open

 Edit Permission
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 Print -  HTML

 Print - PDF

 Print - Custom

 Transfer Ownership

 Terminate Record

 Delete

The log preview pane has two tabs: 

 Record Details

 Permission

Note: If an attribute form is present, then you can hover over the 
question mark (?) symbol to see more information in the form of a tooltip.  

Planning Manager Sheet Log 

Similar to the Cost Sheet log (new user interface), the Planning Manager Sheet log (for 
Company level, Shell level, and Project level sheets) contains the following elements:  

 Log header 

 Toolbar 

 Grid with columns and rows 

 Right-hand pane with tabs corresponding to each row of the sheet log 

Toolbar

Option Description 

Create As designed in uDesigner, the Create window enables you to enter values in 
fields that are categorized in different blocks. 

To modify the Data Sort options, open the Planning Sheet > Properties 
(Classic view): File > Properties. 

Delete Enables you to delete one sheet, or a selected number of sheets, from the 
log. 

Refresh To refresh the items on the log, after updating. 

Print To print the log. 
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Search Similar to the Search option in the Business Processes log, this option 
enables you to search among log items. 

The Search window contains all of the elements from the Planning sheet 
detail form log Find section, from uDesigner. 

If the Find option is not defined in uDesigner, then there will be two fields in 
this window: <label of DE uuu_name> and <label of DE 
uuu_last_update_date>. You can run a search on these two sheet attributes.

If the elements are defined in the log (the Find option is defined in 
uDesigner), then all the defined elements appear in the window in the same 
order as defined in uDesigner. 

Find on 
Page

To find an item on the log. 

<Planni
ng 
name> 
Help

To access corresponding help. 

Columns

All columns are displayed according to the log design in uDesigner. In addition, there is one 
system defined column (Updates Planning Items) which shows up as the first column in the 
Planning Sheet log. This column is used to capture which planning sheet updates the Planning 
Items. 

Rows

If the newly created sheet is the one that updates the planning items, then the first column 
(Updates Planning Items) displays a checkmark icon. 

At a given time, only one planning sheet in the log can updated Planning Items. So, if you modify 
the properties of a sheet to change the value of "Update Planning Items," the checkmark icon (in 
the first column) will appear or disappear based on your changes. 

When you open the log (clicking the Planning Sheets node in the Navigator), and there are no 
records in the log, the right-hand pane does not have any contents. 

When you open the log (clicking the Planning Sheets node in the Navigator), and there are 
records, then: 

 If no sheet is set to update the planning items: The topmost row in the log is selected by 
default and the right-hand pane displays the selected sheet properties. 

 If one of the sheets in the log is set to update the planning items: The sheet is selected by 
default and the right-hand pane displays the sheet properties. 

The tabs in the right-hand pane are: 

 Properties

This tab is selected by default and displays all attributes of the planning sheet as defined in 
uDesigner. The tab also contains the option to choose whether a sheet updates the planning 
items, or not. 

 Permissions
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If you do not have Modify permission or Full Access permission (for planning sheets), then 
you will not be able to view the Permissions tab. Also, if you do not have the Modify 
Properties permission (for Planning Sheet), then you will not be able to modify the planning 
sheets properties. 

 Audit Log

Similar to the other audit logs in Standard view in Unifier, it displays the actions taken by the 
users. 

The gear ( ) menus for each planning sheet: 

 Open: To open the planning sheet. 

 Copy: Use Create Planning Sheet overlay form. All properties of the source sheet are shown 
as copied into this overlay form. 

 Delete: To delete a sheet. 

You can select multiple sheets and right click to delete. 

The gear ( ) menu is not available when you select multiple sheets. 
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Unifier Resource Manager 

The Resource Manager is where you can set up and manage a company’s or shell’s personnel 
resources. Resources can include those of a partner company. The Resource Manager has 
limited functionality in generic shells. 

 You cannot allocate resources in a generic shell. This means you cannot view the 
Allocation and Utilization sheets. 

 The Resource Booking business process is not available; however, you can book resources 
directly onto the Resource Summary sheet in a generic shell. 

The Resource Manager manages the planning, deploying, and tracking company or project/shell 
resources. It supports the creation and management of resources and roles, with the ability to 
define and leverage multiple role rates, skills, proficiency levels, resource capacities, and more. 

Resources can be associated with Unifier users, which enables the ability for resources to log in 
and view individual calendars and respond to assignments. Resources can be associated with 
one or multiple roles with different role rates. This allows for accurate resource cost tracking and 
management at the project level. 

The Resource Manager supports timesheet business processes for capturing and tracking 
actual resource costs associated with activities and assignments at the project, shell, and the 
company level. The manager also supports hard and soft Resource Booking business 
processes using a calendar that shows what project/shells a resource has been booked for, as 
well as the times during which the resource is unavailable. 

An interactive Resource dashboard provides the ability to track and report on all resource 
allocations, booking, utilization, and more. 

In the Resource Manager, your administrator can classify job functions into roles that can then 
be allocated to projects. These roles will be used to define billable rates, which are used in 
budgeting, and can also be used in planning for resource demands across projects. Roles are 
associated with personnel resources—the people who can perform these roles in a project. The 
Resource Manager is where personnel are assigned to roles and projects. 

In the Resource Manager, a company’s or shell’s personnel can serve multiple roles, depending 
on their skills or interests. For example, a construction role and a plumbing role might be served 
by one person who has both carpentry and plumbing skills. The Resource Manager 
automatically creates the following Resource sheets you need to manage resources, bookings, 
and certain budgeting functions: 

Sheet Description 

Allocations 
Summary

Master allocation sheet that shows role allocations at the company 
and project/shell level in both hourly and currency views. Read-only. 

Resource 
Allocation

Allows manual entry of role allocations against projects/shells from 
company level so users can balance resources across 
projects/shells. The Resource Allocation Sheet rolls up to the 
Allocations Summary Sheet at both the project/shell and company 
level. 

Booking Shows hard resource bookings across projects/shells in both hourly 
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Summary and currency views. Can add or edit hard-booked resources directly 
on the Booking Summary Sheet, or though the Resource Booking 
business process. If the Resource Booking business process has 
been designed to include resource capacity, the Booking Summary 
can also show each resource’s availability for booking hours. 

Actuals 
Summary

Shows resource actuals from timesheet data for the company in both 
hourly and currency views. Read-only. Populated by the Time Sheet 
business process. 

Utilization 
Summary

Shows current total utilization of resources as a percentage of the 
total at the company level. Read-only. 

Note: Resources that are hard-booked in the Schedule Manager will 
roll up to this sheet. 

Bookings vs. 
Actuals

At both company and project/shell level, shows hard resource 
bookings across projects/shells in both hourly and currency views, 
similar to the Booking Summary Sheet. Also shows columns per 
resource for booked hours, actual hours, and the variance (booked, 
minus actual hours). Read-only. 

Availability

At the company level, shows current availability of each resource 
across projects/shells. The resource availability equals the 
resource’s total capacity, minus the total bookings for the resource 
across the projects/shells, and minus the non-project times specified 
for the resource. 
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Using the Resource Manager 

The Resource Manager is available at the company and project level, and allows you to: 

 View and configure resource charts 

 View resources, roles, and various resource sheets 

 Allocate roles to projects 

 Have resources enter their own time sheets 

At the company level, the Resource Manager has four nodes: 
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 Resource Dashboard: Allows you to configure displaying Resource Manager information 
across projects. 

 Roles: Displays the company-level roles entered in Administration Mode. 

 Resources: Displays the company-level resources that are hard-booked across projects. 

 Resource Sheets: Lists the available company-level (cross-project) resource sheets. 

At the Project level, the Resource Manager has three nodes: 

 Resource Dashboard: Allows you to configure displaying Resource Manager information 
across projects. 

 Resources: Displays resources that are hard-booked for the project. 

 Resource Sheets: Lists the available project-level resource sheets. 

View roles 

Roles are defined and maintained in Administration Mode at the company level. At the company 
level, you can view role details, which includes resources and rates. 

To view role details 

1) In User Mode, select Company Workspace tab> Resource Manager > Roles. The Roles 
log opens. 

2) Select a role and click Open. The Role Properties window opens. The window has three 
tabs: 

 General: Displays the role name, description, and status, and may display other fields; 
the fields on this tab correspond to the role attribute form. 

 Rates: Displays standard and overtime rates defined for the role. 

 Resources: Displays resources that have been associated with the role. 

View resources 

Resources are defined and maintained in Administration Mode at the company level. You can 
view resources that are hard-booked for a project or across multiple projects. 
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To view resource details 

1) In User Mode, do one of the following: 

 To view resources across projects, select Company Workspace tab> Resource 
Manager > Resources. 

 To view resources for a project, select Projects tab > project > Resource Manager > 
Resources. 

The Resources log opens. 

2) Select a resource and click Open. The Resource Properties window opens. The window has 
five tabs: 

 Resource Code: Automatically generated, manually entered, based on the 
configuration. 

 Resource Name: This is the name of the resource. 

 Description: Description of the resource. 

 Resource Capacity (Hrs): Default value is 8. This defines the number of hours a 
person can work in a day. 

 Sunday (Hrs.).....Saturday (Hrs.): Depending on the design of the Resource 
Attribute form, these fields may or may not appear on the General tab. If they do, 
they will show the number of hours the resource can work on each of these days. 
Unifier will use these values to calculate the resource’s Capacity per week. 

 General: This tab may vary greatly with the design of the resource attribute form you 
imported. Fields may include: 

 Roles: Displays any roles that have been associated with the resource. 

 Skills: Displays any skills associated with the resource. 

 Calendar: The calendar displays bookings, vacation days, etc. for the resource. 

 Projects: Displays the projects in which the resource is booked and booking specifics. 

Edit your own resource properties 

At the company level, you can edit your own resource properties and calendar. From your user 
sign in, Unifier identifies you and automatically gives you permissions to modify your properties 
and calendar. However, you must have View permission to the Resource Log. 

To edit your resource properties 

1) Click the Company Workspace tab and go to Resource Manager > Resources in the 
Navigator. 

2) On the Resources Log, double-click your name. The Resource Properties window opens. 

3) Edit your information under each tab as necessary. 

General Tab 

This tab may vary according to the design of the resource attribute form. Fields may include: 

Resource Code: Automatically generated, manually entered, based on the configuration. 

Resource Name: Edit your name, if necessary. 
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Description: Edit your description. 

Resource Status: Edit your status. The default is active. 

Capacity per week (Hrs): Edit the number of hours you can work in a day. Default value is 8. 

Sunday (Hrs.).....Saturday (Hrs.): These fields may or may not appear. If they do, you can edit 
the number of hours you can work on each of these days. Unifier will use these values to 
calculate your Capacity per week. 

Roles Tab 

To add a role to your profile: 

a) Click Add. 

b) Select a role from the Role picker and click Open. 

Unifier adds the role to your profile. 

To remove a role from your profile, select the role and click Remove. 

Skills Tab 

To add a skill to your profile: 

a) Click Add. 

b) Select the skill from the drop-down list. 

c) Specify your proficiency in this skill. 

d) Specify your interest in this skill. 

To remove a skill from your profile, select the skill and click Remove. 

Calendar Tab 

You can view and manage booking dates as well as unavailable dates (non-project time, such 
as vacation days). The calendar shows both your soft and hard bookings.  

To edit your booking calendar: 

1) You can click the Month tab or Week tab to change the calendar view. A maximum of five 
projects/shells can be shown for any day in the month view. If you are booked for more than 
five project/shells in a day, you can view them all in the week view. 

2) To view all projects/shells for any given day, select a day and click the Booking Details
button. 

The Resource Booking Details window opens. The window displays the project/shell 
bookings for you on the selected date. For each project/shell, it shows project/shell number, 
project/shell name, booking status, dates when the booking starts and ends, total hours 
booked during this period on the project/shell, and total hours booked on the current date on 
the project/shell. The dates and hours shown include non-project time. 

3) To make yourself unavailable for booking on a certain date, select the date and check the 
Unavailable checkbox. You can click the drop-down list and select an option. 
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Projects/Shells Tab 

The Projects/Shells tab is read-only. You cannot edit the information on this tab. 

Working with Resource Sheets 

The company-level and project-level resource manager sheets are created automatically when 
the Resource Manager is activated in Administration Mode. The available resource sheets are 
listed below. 

 Allocations Summary Sheet: This is the master allocation sheet, which shows role 
allocations entered at the company and project level. This is a read-only sheet. 

 Resource Allocation Sheet: The company-level resource allocation sheet allows role 
allocations against projects from the company level. The project-level resource allocation 
sheet allows role allocations for the project. 

 Booking Summary Sheet: The booking summary sheet shows resource bookings for a 
project or across projects in the company. This sheet can be populated by the Resource 
Booking business process, or by resources directly added to the sheet. 

 Actuals Summary Sheet: The actuals summary sheet is a read-only sheet that shows 
resource actuals (time sheet data) for a project or across projects in the company. This sheet 
is populated by the Timesheet business process. 

 Utilization Summary Sheet: The utilization summary sheet is a read-only sheet that shows 
total utilization of resources for a project or across projects. 

View Resource Manager sheets 

Resource Manager sheets are available in the Company Workspace, and in projects and shells. 

To view company-level sheets 

1) In User Mode, select Company Workspace tab> Resource Manager > Resource Sheets. 
The Resource Sheets log opens. 

2) Select a sheet from the log and click Open. 

To view project-level sheets 

1) In User Mode, select Projects tab > project > Resource Manager > Resource Sheets. 
The Resource Sheets log opens. 

2) Select a sheet from the log and click Open. 

See the descriptions below for details about each of the sheets. In general, the sheets work 
similarly to each other at the company and project level. In general, you can: 

 View data by hours or by cost (not available on all sheets) 

 Save or open the sheet as a PDF file, allowing you to save and print the sheet 

 Create and view snapshots (not available on the resource allocation sheets) 

The structure of each resource sheet is similar: 

 The left pane of the sheet displays default columns, which depend on the sheet. For 
example, resource name, role name, etc. 
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 The right pane displays the time line columns. Depending upon the display (day, week, 
month), the time line will show a column for each period with the actual allocation in hours 
(hours view) or in currency (cost view). 

 To change the timescale, click the Display field at the top of the sheet and choose one of 
the following: 

 Day: The column header will show the actual date of the allocation. 

 Week: The column header will show the actual date of the start of the week (Monday) 
from the company calendar. 

 Month: The column header will show the actual date of the start of the month from the 
company calendar. 

 In the upper right corner of each sheet is a time line slider: 

 Start of the time line: The earliest date that can be displayed on the time line will be the 
minimum of the default start date specified in the Resource Manager configuration and 
the earliest transaction date. 

 End of the time line: The latest date displayed on the time line will be the maximum of 
the default date specified in the Resource Manager configuration and the latest 
transaction date. 

 To quickly scroll through the date columns, you can click the slider in the top right corner 
of the sheet and slide it to the time period you wish to view. 

 Default view: By default, when the sheet is opened, the time line will always center on 
the current period (day, week, month). Scroll left or right to see other periods. 

Note: If the sheet is currently being edited, you will not be able to 
change the Display By field or the time line slider. To change the sheet 
display, first save any edits by clicking the Save button. 

Allocations summary sheet 

This is a read-only sheet that totals resource data by role. In company-level sheets, there are 
two possible sources of the information displayed on the sheet: the company-level resource 
allocation sheet and project/shell level resource allocation sheets. For project/shell allocation 
summary sheets, the source is the resource allocation sheet for that project or shell. 

Allocations are shown for each role. At the company level, allocations are shown for each role 
against one or more projects. The combination of role and project is always unique. The Role 
Name column is sorted alphabetically. The role name is hyperlinked. Clicking on the role name 
will open the Role properties window in view-only mode. 

You can view summary information by hours allocated for that role, or by cost (hours multiplied 
by hourly rate, as defined in the Role properties in Administration mode). 
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Note: This sheet is not available in generic shells. 

To view the allocations summary sheet 

1) In the company-level or project/shell level Resource Sheets log, select Allocations 
Summary and click Open. 

The window opens in a split mode by default. You may need to use the scroll bars at the 
bottom of the window to view the columns you want to see on either side of the sheet. 

Each row corresponds to a role that has been allocated to a project or shell, either in the 
company level or project/shell level resource allocation sheet. On the left side of the sheet, 
you will see the role name, project/shell number and name (in company-level sheets), the 
date range in which the role is allocated, and the total number of hours, which is the sum of 
all the values entered for that row in the resource allocation sheet. On the right side of the 
sheet are the hours allocated to each role. 

2) You can view this sheet by hours or by cost: 

 To view by hours, click the View menu and choose Mode > Hours. The sheet displays 
the hours allocated to each resource, as rolled up from the resource allocation sheets. 

 To view data by cost, click the View menu and choose Mode > Currency Amount. The 
sheet displays the cost charged against each resource: hours are rolled up from the 
resource allocation sheets, then multiplied by the hourly rate defined for the role in 
Administration mode. 

 To display the most current costs, click the Refresh Rates button. Select the effective 
date when prompted. Rates will refresh from the selected date to all dates in the future 
for which values exist on the sheet. Costs for dates earlier than the selected date will not 
be refreshed. The date will default to the current date. 

Column Description 

Role Name Allocations are shown for each role against one or more projects. 
The combination of role and project is always unique. The Role 
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Name column is sorted alphabetically. Clicking on the role name 
will open the Role properties window in view-only mode. 

Project Number 
The project number is shown hyperlinked. Clicking on the Project 
Number will open the corresponding project allocation summary 
sheet. This is shown in the company-level sheet only. 

Project Name The name of the project. This is in the company-level sheet only. 

Date From Displays the earliest date that has a non-zero allocation for the role.

Date To Displays the latest date that has a non-zero allocation for the role. 

Total Hours 
Displays the sum of hours allocated to the role. This field is 
displayed only in hours view. 

Total Cost 
Displays the total amount allocated to the role. This field is 
displayed only in cost view. 

Resource allocation sheet 

In this sheet, you can allocate resources, based on roles, to a project or CBS-code based shell. 
The Resource Allocation sheet is available at the company level and also in projects and shells 
in which resource allocation is enabled. 

Note: The ability to allocate resources to a project/shell with this sheet is 
dependent upon how the Resource Manager has been set up in 
Administration Mode. During the setup of the Resource Manager in a 
project or CBS-based shell, the Administrator can choose to allow 
resource allocation from the company level sheet (the allocations are roll 
down to the specific project/shell Resource Allocation sheet, which is 
view-only); directly from the project/shell level sheet (this will show up in 
the project/shell and the company level Allocation Summary sheet); or 
the administrator can choose to disallow allocation for a particular project 
or shell (in this case, the Resource Allocation sheet and Allocation 
Summary sheet are not available for that project/shell). 

Allocations at the company level: 

 Roll up to the company allocations summary sheet. 

 Roll down to the individual projects/shells, in their resource allocation sheet and allocation 
summary sheet. 

Allocations at the project/shell level: 

 Roll up to the project/shell allocations summary sheet. 

 Roll up to the company allocations summary sheet and resource allocation sheet. 

The resource allocation sheet can be viewed by hours only. 
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Note: This is not available in generic shells. 

To view the resource allocation sheet 

In the company-level or project-level Resource Sheets log, select Resource Allocations Sheet
and click Open. 

Company-level resource allocation sheet 

Column Description 

Role Name 

Allocations are shown for each role against one or more 
projects. The combination of role and project is always unique. 
The Role Name column is sorted alphabetically. Clicking on the 
role name will open the Role properties window in view-only 
mode. 

Project Number 
The project number of the allocation. This is displayed in the 
company-level sheet only. 

Project Name 
The name of the project. This is displayed in the company-level 
sheet only. 

Date From 
Displays the earliest date that has a non-zero allocation for the 
role. 

Date To 
Displays the latest date that has a non-zero allocation for the 
role. 

Total Hours 
Displays the sum of hours allocated to the role, This field is 
displayed only in hours view. 
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To allocate a resource 

1) Open the Resource Allocation sheet. 

2) Click the Add button. The Resource Allocation window opens (see below.) 

3) Complete the window: 

 Role Name: Click Select, choose a role, and click OK. 

 Project: Click Select, choose a project, and click OK. 

 Date From: Click the calendar and choose the start date for the allocation. 

 Date To: Click the calendar and choose the end date for the allocation. 

 Allocated Hours: This field will auto-populate based on the dates selected (number of 
workdays x capacity). This is an editable field. You can adjust the amount as needed. 

4) Click OK. 

To edit allocation information 

1) Open the company level or project/shell level Resource Allocation sheet. 

As mentioned at the start of this topic, the ability to allocate resources to a project/shell with 
this sheet is dependent upon how the Resource Manager has been set up in Administration 
Mode. Depending on project/shell setup, allocations may be done for that project or shell in 
the company-level sheet, the project/shell-level sheet (or allocations may not be allowed for a 
particular project or shell). 

If you have questions regarding allocations, contact your Project/Shell Administrator. 

2) If the sheet is editable, click in the cell to edit. The cell becomes editable. You may need to 
scroll to the cell, or use the Display By or timeline slider to navigate to the column to edit. 

3) Make changes to the cell. 

Note: If the sheet is currently being edited, you will not be able to 
change the Display By field or the time line slider. To change the sheet 
display, first save any edits by clicking the Save button. 

4) Click Save to save the sheet. 

To delete an allocation 

Select a row and click Delete. 
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Booking summary sheet 

You can only see the Booking Summary sheet in active or on-hold projects or shells in which 
the Resource Manager is active. In the sheet you can view, add, or update hardbooked 
resources. In Unifier, resources are of two types: hardbooked or non-hardbooked. 

 Hardbooked resources are labor resources that are firmly committed to a project and not 
available for other work. 

 Non-hardbooked resources can include things like labor, equipment, or materials 
Non-hardbooked resource leverage roles and are added to a project through the Resource 
Assignment form in the schedule sheet activity attribute form. See Resources tab of the 
Activity properties (on page 569) 

Resource booking rows can be added to the sheet using the Resource Booking business 
process, or you can manually add them directly to the sheet. You can also modify data manually 
on the sheet. Data is rolled up from the project/shell Resource Booking Summary sheet. You 
can also view rates for each resource booking. 

Note: Resource Booking business processes are not supported in 
generic shells. To compensate, however, you can manually add 
bookings to the Booking Summary sheet in shells. 

To view the booking summary sheet 

1) In the company-level or project/shell-level Resource Sheets log, select Booking Summary 
Sheet and click Open. 

2) You can view this sheet by hours or cost: 

 To view by hours, click the View menu and choose Mode > Hours. The sheet displays 
the hours charged against each resource, as rolled up from the resource allocation 
sheets. 

 To view data by cost, click the View menu and choose Mode > Currency Amount. The 
sheet displays the cost charged against each resource, as rolled up from the resource 
allocation sheets. 

3) You can group by role or resource: 

 To group by role, click the View menu and choose Group By > Role. This is the default. 

 To group by resource, click the View menu and choose Group By > Resource. This 
groups the information by resource only. The role column is not applicable. 

Column Description 

Role Name 

Allocations are shown for each role. The role is always unique. 
The Role Name column is sorted alphabetically. The role name 
is hyperlinked. Clicking on the role name will open the Role 
properties window in view-only mode. 

Resource Name 

Bookings are shown for each resource against a role allocation. 
Resources are sorted alphabetically within a role. The resource 
name is hyperlinked. Clicking on the resource name will open 
the Resource properties window in view-only mode. 
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Project Name 

Displays the project name for the booking row. The project 
name is hyperlinked and will open the project-level booking 
sheet. This column is displayed in the company-level sheet 
only. 

Non-Project Time 
This column only appears on the company-level Booking 
Summary. Displays a resource’s time that has been charged 
against non-project hours, such as PTO or vacation. 

Date From Earliest date that a non-zero booking exists for the resource. 

Date To Latest date that a non-zero booking exists for the resource. 

Total Hours Total hours (shown in the hours view only). 

Total Cost Total cost in base currency (shown in the cost view only). 

Average Rate 
Average resource rate per hour in company currency (shown in 
the cost view only). 

To view cell details 

1) Click on hyperlinked values (in View mode). With Modify permission, you can edit cell values 
(in Edit Mode). You can view information by hours or cost. You can also group information by 
roles or by resources. The cell details are read-only, see the table below. 

2) Click Close Window when you are done viewing cell details. 

Field Description 

Resource Code The resource code assigned to the resource. 

Resource Name The resource name. 

Role Name The role name assigned to the resource. 

Project Name The name of the project associated with the resource. 

Booked Week 
The current time based on the timescale represented in the 
Booking Summary Sheet. 

Total Booked Hrs. 

The total hours booked through the Resource Booking business 
process transactions combined with manual booking 
transactions. All transactions are listed under Booking 
Transactions on the lower part of the Cell Details window. 

Booking 
Transactions 

The total hours booked through the Resource Booking business 
process. 

Manual Booking 
Hrs. 

The total hours booked through manual booking changes. 

Average Rate (per 
Hour) 

This can be the Role rate, or the rate specified when the booking 
was added. 

Cost The total of the rate multiplied by the hours. 

Currency The Company or project currency. 
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Booking 
Transactions 

The various transactions that affect the booking hours. These 
transactions can occur through manual changes to the booking, 
or through the Resource Booking business process. Booking 
transactions that occur through the manual changes are 
specified as Manual Entry; transactions that occur through the 
Resource Booking business process are designated with the title 
of the business process. 

To update a hard-booked resource to the Booking Summary Sheet 

In Edit mode, and with Modify permission, you can manually update the values on the Booking 
Summary Sheet. You can update values for resource bookings that were added to the sheet 
through the Resource Booking business process, or values for resources that were added to the 
Booking Summary Sheet manually. Manually entered transactions costs are calculated based 
on the current day’s rate. 

Note: The Resource Booking business process is used only to add 
bookings, not to modify existing bookings. 

1) In the company-level or project-level Resource Sheets log, select Booking Summary Sheet
and click Open. 

2) Click Edit to enter Edit Mode. 

Note: If you are in these modes: Mode > Currency Amount, Group By > 
Role, or Group By > Resource, you must choose the Mode > Hours to 
be able to access Edit Mode. 

3) Increase or decrease the booking hours on the sheet as needed. You can select a row and 
click Clear to clear any row of values, and then enter new values. 

All cells that contain hours values on the Booking Summary Sheet are editable. Hyperlinks to 
the Cell Details are not displayed in Edit Mode. You can edit hours in any display mode (Day, 
Week, Month). You can increase or decrease hours to any value greater than or equal to 
zero (0). Hours cannot exceed 24 hours for any day. 

4) Click Save, or click View to return to View Mode without saving the changes. The cost or 
hours values are then displayed as hyperlinks. You can click these hyperlinks to view the 
Cell Details for the values. 

All values that you change directly in the Booking Summary Sheet are reflected in the Cell 
Details for the resource booking. Each change to the resource bookings is listed in the 
Booking Transactions list, whether the change was made through the Resource Booking 
business process, or was made directly on the Booking Summary Sheet. 
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Note: Utilization Summary Sheet values are recalculated when the 
resource bookings are modified in the Booking Summary Sheet. 

To manually add a hard-booked resource on the Booking Summary Sheet 

You can add resource bookings using the Resource Booking business process, or by adding the 
resources directly into the Booking Summary sheet. Manually entered transactions costs are 
calculated based on the current day’s rate. 

Note: The resource bookings that you add directly into the sheet have 
not been through the approval process inherent in the Resource Booking 
business process. Keep this in mind when you are using this method to 
add bookings to the sheet. 

You must have Modify permission to be able add a resource booking to the Booking Summary 
Sheet. 

1) In the company-level or project-level Resource Sheets log, select Booking Summary Sheet
and click Open. 

2) Click Add to enter Edit Mode. The Resource Booking window opens.Complete the form 
using the table below these directions as a reference. 

Note: If you are in these modes: Mode > Currency Amount, Group By > 
Role, or Group By > Resource, you must choose the Mode > Hours to 
be able to access Edit Mode. 

3) Click OK. 

A new row is created in the Booking Summary Sheet. Enter values in the new row as 
needed. If the booking type is non-project time, Unifier will create a new row and populate 
the Non-Project time column with the type of time, such as "PTO" or "vacation," or 
"administration." All values for the row will be zero, which you can change manually where 
necessary. 

4) Click Save, or click View to return to View Mode without saving the changes. The hours 
values are then displayed as hyperlinks. You can click these hyperlinks to view the Cell 
Detail values. 

Note: Utilization Summary Sheet values are recalculated when resource 
bookings are added to the Booking Summary Sheet. 

In this field Do this 

Booking Type 

Select Project/Shell if you are booking the resource against a 
project or shell.  

Select Non-Project Time if you are booking the resource 
against non-project work. 

 If you select this option, you will not need to specify a role 
name or a project/shell against which to book this time.  

 You can select Non-Project Time only on company-level 
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Booking Summary sheets. 

Role Name Select a role. 

Resource Name Select a resource name. 

Project/Shell 
Select a project or shell against which to book this time. At the 
Company level, this list includes active projects that have 
Resource Manager configured. 

Non-Project Time 
If the Booking Type is Non-Project Time, select the type of 
non-project work you are booking this resource against. 

Actuals summary sheet 

This sheet lists the actual time (hours) entered by each resource using time sheet business 
processes, displaying resource hours for the project/shell or across projects/shells. 

You can select the time sheet business process to use. 

To view the actuals summary sheet 

1) In the company-level or project-level Resource Sheets log, select Actuals Summary Sheet
and click Open. 

2) You can view this sheet by hours or cost: 

 To view by hours, click the View menu and choose Mode > Hours. The sheet displays 
the actual hours from time sheets. 

 To view data by cost, click the View menu and choose Mode > Currency Amount. The 
sheet displays the cost charged against each resource from time sheets. 

Column Description 

Resource Name 
This sheet displays hour and cost information for each resource 
that has submitted time sheet business processes. 

To define the time sheet to roll up to the actuals sheet 

1) On the actuals summary sheet, click the Properties button. 

2) In the Business Process field, click the drop-down list and choose the Timesheet business 
process to use to roll up. 

3) Click OK. 

Booking vs. Actuals summary sheet 

At both the company level and project/shell level, you can use this sheet to see booking 
information versus actual time usage against a project or shell. 

To view the Booking vs. Actuals summary sheet 

1) In the company-level or project-level Resource Sheets log, select Bookings vs. Actuals 
Summary Sheet and click Open. Unifier displays a Properties window. 
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2) In the Properties window, specify the time sheet business process that should roll up values 
to the Booking vs. Actuals Sheet. 

3) Click OK. 

Unifier uses the values on the time sheet business process you specified to calculate the 
data on the Booking vs. Actuals summary. 

The sheet shows all booked resources, along with their roles and the projects/shells they are 
booked in. It shows both the booked hours and the actual hours the resources worked on the 
project/shell. The sheet does not show non-project hours. 

To see details 

To see a resource’s booking details, click the hyperlinked hours in the Booked column. Unifier 
opens a Cell Detail window showing the booking details for the resource. To see details on a 
resource’s actual hours worked, click the hyperlinked hours in the Actuals column. Unifier opens 
a Cell Detail window showing the actuals for the resource. 

Utilization summary sheet 

This sheet displays utilization in hours for each resource, per role. 

Note: This sheet is not available in generic shells. 

Project level 

The sheet displays utilization of resources as a percentage at the project level and is shown for 
each resource-role combination. 

Utilization% = (Total Assigned Hours / Hard-booked Hours) *100 

 Rolling over the cell value shows a break up of hard-booked hours and assigned hours. 

 Utilization over 100% (over-utilization) is displayed in red. 
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This sheet cannot be opened unless the Schedule Manager is loaded or a master schedule 
sheet is created. 

To view the project-level utilization summary sheet 

In the project-level Resource Sheets log, select Utilization Summary Sheet and click Open. 
You can view this sheet by hours only. 

Company level 

The information is displayed across projects. 

To view the company-level utilization summary sheet 

In the company-level Resource Sheets log, select Utilization Summary Sheet and click Open. 
You can view this sheet by hours only. 

Column Description 

Resource Name Displays resources by name. 

Role Displays the role, per resource. 

Resource Availability sheet 

The Resource Availability Sheet resides at the company level. This sheet shows the current 
availability of each resource across all projects/shells. A resource’s availability equals the 
resource’s total capacity (hours available), minus the total bookings across the projects/shells, 
and minus the non-project times specified. The sheet also shows over-bookings and zero hours 
where the resource is not available due to PTO, vacation, or administrative duties. 

Unifier automatically adds the Resource Name column to the sheet; you cannot move this 
column. Unifier adds rows to the sheet whenever a Resource Booking business process is 
submitted. You can manually add columns directly to the sheet to show more information. You 
can also modify data manually on the sheet. 
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To open an Availability Sheet 

In the company-level Resource Sheets log, select Availability Sheet and click Open. 
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To view a resource’s available hours and other information 

Click the resource’s name. Unifier opens a read-only copy of the resource’s properties. These 
can include the resource’s address and phone number. This window will also show the 
resource’s capacity of work hours per week. Depending on the design of the Resource 
Attribute form, this window might also show a breakdown (as in the example below) of the 
resource’s hourly working capacity by day. 
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To view booking details 

You can drill down to an individual resource to see a read-only copy of the booking information. 
To do so, click on the value in any date column. Unifier displays the cell details. 

The cell details show the following information: 

Resource 
Code 

The code assigned to the resource 

Resource 
Name 

The name of the resource. 

Period 
Type 

The period of availability being displayed. (This reflects what the Display 
By choice was.) 

Period 
The time the data on this window covers (day, week ending date, month 
ending date). 

Capacity The hours the resource is available during the period. 

Booked 
Hours 

The number of hours the resource is booked during this period. 

Available 
Hours 

The number of available hours the resource has left for booking during this 
period. 

Transactio
ns 

The booking transactions that are reflected in the data in this window. 

Project/Shell No. shows the number of the project/shell for which the 
resource is booked. 

Record Number shows the number of the business process record (unless 
the entry was manual). 

Title shows the title of the business process. This column will show 
"Manual Entry" for any hours that were manually entered on the sheet. 

From Date shows the beginning date of the resource’s period of 
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availability. 

To Date shows the end date of the resource’s period of availability. 

Total Hrs shows the total number of hours the resource is available during 
the period. 

To add columns to the sheet 

By default, the left column of the sheet displays the name of the resource and cannot be edited 
or moved. You can add additional columns to the left side of the sheet to customize it to your 
needs. To add columns: 

1) On the sheet, click the Columns button. The Columns window opens, showing the columns 
currently displayed on the left side of the sheet. 

2) Click the New button. The Column Properties window opens. 

3) Use the information in the table below to complete the fields in this window. 

4) Click OK. Unifier closes the Column Properties window. 

On the Columns window, you can adjust the order of the column(s) you added by using the 
Move Up (Left) and Move Down (Right) buttons. 

In this field: Do this: 

Name 
This field will show the name of the element you choose in the 
Datasource field (below). 

Datasource 
Select a Data Source from the drop-down list. The list displays the 
data elements from the Resource Attribute form. 

Data Format 

This controls how data is displayed on the sheet. Select: 

Show as percentage to display the data as a percentage. 

Decimal places if you want the data to include decimal amounts. 
Choose 0 to 8. 

Use 1000 Separator if you want to include a comma (,) separator in 
numbers. 

Negative Number Format if you want to show negative numbers in 
parentheses or with a minus sign. 

Display Mode Show or Hide to display or hide the column from user view. 

Column Position 
After 

Specify the column after which this new column should appear. 

View resource sheets 

The company and project/shell Resource Manager sheets are created automatically when the 
Resource Manager is activated in Administration Mode. 
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To view company-level sheets 

1) In User Mode, select Company Workspace tab> Resource Manager > Resource Sheets. 
The Resource Sheets log opens. 

2) Select a sheet from the log and click Open. 

To view project/shell level sheets 

1) In User Mode: 

 For a standard project, select the Std. Projects tab > project > Resource Manager > 
Resource Sheets. The Resource Sheets log opens. 

 For a shell, select the <shell tab> Resource Manager > Resource Sheets. The 
Resource Sheets log opens. 

2) Select a sheet from the log and click Open. 

See the descriptions below for details about each of the sheets. In general, the sheets work 
similarly to each other at the company and project/shell level. In general, you can: 

 View data by hours or by cost (not available on all sheets) 

 Save or open the sheet as a PDF file, allowing you to save and print the sheet 

 Create and view snapshots (not available on the resource allocation sheets) 

The structure of each resource sheet is similar: 

 The left pane of the sheet displays default columns, which depend on the sheet. For 
example, resource name, role name, etc. 
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 The right pane displays the time line columns. Depending upon the display (day, week, 
month), the time line will show a column for each period with the actual allocation in hours 
(hours view) or in currency (cost view). 

 To change the timescale, click the Display by field at the top of the sheet and choose one of 
the following: 

 Day: The column header will show the actual date of the allocation. 

 Week: The column header will show the actual date of the start of the week (Monday) 
from the company calendar. 

 Month: The column header will show the actual date of the start of the month from the 
company calendar. 

 In the upper right corner of each sheet is a time line slider: 

 To quickly scroll through the date columns, you can click the slider in the top right corner 
of the sheet and slide it to the time period you wish to view. 

 Start of the time line: The earliest date that can be displayed on the time line will be the 
minimum of the default start date specified in the Resource Manager configuration and 
the earliest transaction date. 

 End of the time line: The latest date displayed on the time line will be the maximum of 
the default date specified in the Resource Manager configuration and the latest 
transaction date. 

 Default view: By default, when the sheet is opened, the time line will always center on 
the current period (day, week, month). Scroll left or right to see other periods. 

Filter Data on a Resource Sheet 

The resource sheets can contain large amounts of data. To make working on the sheets easier, 
you can create a filter to limit the amount of data they display. For example, you could filter the 
sheet to show only certain resource roles, such as carpenters or electricians. Once you have 
created a filter, Unifier includes it on a list of filters available to anyone who uses the sheet. To 
create a filter: 

1) Open the resource sheet from the log and choose View > Filters. The Set Up Filters
window opens, showing a list of filters that have already been created (if any). 

2) Click the Add button. The Add Filter window opens. 

3) In the Filter Name field, enter a name for this filter. 

4) Click the Add button. The Query Condition window opens. 
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Use this window to create a query that will extract the data you want to see on the sheet. For 
information about creating a query refer to Unifier General User Guide. 

5) To filter the sheet, click Apply Filter. 

6) To save the filter, click OK. 

To apply a filter to the sheet 

1) Open the sheet in the log. 

2) Click the Filtered by drop-down list and select the filter you want to use. 

3) Click Apply Filter. 

Unifier refreshes the sheet to show the filtered records. 

If you want to re-display all the rows on the sheet, you can clear the filter by choosing Clear 
Filters from the View menu. 

To edit a filter 

1) Open the sheet. 

2) From the View menu, choose Filters. The Setup Filters window opens, showing a list of the 
filters that have been created for the sheet. 

3) Select the filter you want to edit and click Edit. 

Print resource sheets 

To print or create a PDF file of the sheet: 

1) Open the sheet. Choose to view by hours or cost. 

2) Click the File menu and choose Print. 

3) At the prompt, choose to open the file or save as a PDF file. 

If you open the file, the file will open in Acrobat Reader, from which you can print the file. If you 
choose to save the file, you can save to your local drive and print or distribute as needed. 

Save and view resource sheet snapshots 

You can save a snapshot of all of the view-only sheets, except the resource allocation sheet. 

To save a snapshot of the sheet 

1) Open the sheet, and choose to view by hours or cost, where applicable. 

2) Click the File menu and choose Create Snapshot. 

3) Enter a title and click OK. 

To view a snapshot 

1) From the sheet, click the File menu and choose Open Snapshot. 

2) Select a snapshot from the log and click Open. 
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Viewing and Configuring Resource Dashboards 

The dashboard is available in the company-level and project-level Resource Manager. It allows 
you to monitor resource planning and deployment. 

Data is refreshed when the Resource Dashboard node is selected or changes are made. 

You can configure the dashboard to display charts in two-column layout. Configuring the 
Resource Dashboard is similar to setting up the project or company summary, except that the 
available charts are system-based and not based on user-defined reports. 

You can choose to display system-defined charts in resource management key performance 
areas. 

Company Level Project Level 

Booking Booking 

Actuals Actuals 

Utilization Utilization 

Supply vs. Demand 

Supply vs. demand charts 

These charts: 

 Show allocations by role and compare them with resource daily capacity. 

 Highlight issues with having too much demand that cannot be satisfied. 

 Measure ability to satisfy resource demand and identify additional staffing needs. 

These charts are used to display the existing demand (allocation) versus available capacity in 
the company. You can use these reports to verify that sufficient manpower is available in the 
company to satisfy this demand. The supply (or capacity) in this case is unconstrained and 
unnetted. This means that the capacity does not consider existing bookings (soft or hard). 

Calculating values on the demand vs. supply charts: 

Allocation % = Total Allocation / Total Capacity * 100 

Allocation is obtained from the company allocation summary sheet for the specified range of 
dates. Total capacity will add capacity hours of all resources at the company level that can play 
the role (not limited to default roles) for the range of dates. Allocation cost is obtained from the 
company allocation summary sheet. The charts include active roles and active resources only. 
Capacity is based on the company calendar (working days only). 

Actuals charts 

These charts: 

 Show actuals by role and corresponding bookings against the role. Non-project time can 
be included on the charts. 

 Highlight issues with costs going over budget. 

Calculations on actuals charts (company level): 
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 Data obtained from the company-level summary sheets based on the current 
configuration of the time sheet BP on the sheet. 

 Booking used is hard-booking. 

 Booking is obtained from company booking summary sheet. 

Calculations on actuals charts (project level): 

 Data obtained from the project-level summary sheet based on the current configuration of 
the time sheet BP on the sheet. 

 Booking used is hard-booking. 

 Booking is obtained from the project booking summary sheet. 

Booking charts 

These charts are used to plot resource booking (soft and hard) against demand (allocation) and 
capacity: 

 Show allocations by role and corresponding bookings against the role. 

 Highlight issues with underbooking or overbooking. 

 Show hard- and soft-booking. Non-project time can also be shown. 

 Successful satisfaction of resource demand via resource commitments (booking). 

Calculations on the booking charts (company level): 

 Booking obtained from company booking summary sheet for the specified range of dates. 

 Allocation obtained from the company allocation summary sheet for the specified range 
of dates. 

 Overbooking % = [(Total Booking – Capacity)/Capacity] * 100 (0% if negative). 

 Total capacity will add capacity hours of all resources at the company level that can play 
the role (not limited to default roles). 

 Booking cost is obtained from the company allocation summary sheet. 

 Total Booking = Soft + Hard booking. 

Calculations on the booking charts (project level): 

 Booking obtained from the project booking summary sheet for the specified range of 
dates. 

 Allocation obtained from the project allocation summary sheet for the specified range of 
dates. 

 Booking cost is obtained from the project allocation summary sheet. 

 Capacity, Overbooking and Unmatched Supply column to show only at company level. 

 Total Booking = Soft + Hard booking. 

Utilization charts 

These charts: 

 Show utilization of resources against budgeted project work. 

 Resource Manager can see that all resources are adequately occupied with billable 
project work. Administrative work at the company level does not count. 
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Calculating values on the utilization charts (company level): 

 Utilization % obtained from the company utilization summary sheet for the specified 
range of dates. 

 Booking is obtained from the company booking summary sheet. 

 Assigned hours is obtained by adding assigned hours on project schedule sheets across 
all projects. 

 Utilization % = (Total Assigned Hours / Hard-booked Hours) * 100 (shows two decimal 
places). 

Calculating values on the utilization charts (project level): 

 Utilization % obtained from the project utilization summary sheet for the specified range 
of dates. 

 Booking is obtained from the project booking summary sheet. 

 Assigned hours is obtained by adding assigned hours from the project schedule sheets. 

About Resource dashboards 

The dashboard is available in the company-level and project/shell level Resource Manager. It 
allows you to monitor resource planning and deployment. Data is refreshed when the Resource 
Dashboard node is selected or changes are made. 

You can configure the dashboard to display charts in two-column layout. Configuring the 
Resource Dashboard is similar to setting up the project/shell or company summary, except that 
the available charts are system-based and not based on user-defined reports. You can display 
system-defined charts in resource management key performance areas. 

Company Level Project Level 

Booking Booking 

Actuals Actuals 

Utilization Utilization 

Supply vs. Demand

Supply vs. demand charts 

These charts: 

 Show allocations by role and compare them with resource daily capacity. 

 Highlight issues with having too much demand that cannot be satisfied. 

 Measure ability to satisfy resource demand and identify additional staffing needs. 

These charts are used to display the existing demand (allocation) versus available capacity in 
the company. You can use these reports to verify that sufficient manpower is available in the 
company to satisfy this demand. The supply (or capacity) in this case is unconstrained and 
unnetted. This means that the capacity does not consider existing bookings (soft or hard). 

Calculating values on the demand vs. supply charts: 

 Allocation % = Total Allocation / Total Capacity * 100 
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Allocation is obtained from the company allocation summary sheet for the specified range of 
dates. Total capacity will add capacity hours of all resources at the company level that can play 
the role (not limited to default roles) for the range of dates. Allocation cost is obtained from the 
company allocation summary sheet. The charts include active roles and active resources only. 
Capacity is based on the company calendar (working days only). 

Actuals charts 

These charts: 

 Show actuals by role and corresponding bookings against the role. Non-project time can be 
included on the charts. 

 Highlight issues with costs going over budget. 

Calculations on actuals charts (company level): 

 Data obtained from the company-level summary sheets based on the current configuration of 
the time sheet e sheet. 

 Booking used is hard-booking. 

 Booking is obtained from company booking summary sheet. 

Calculations on actuals charts (project level): 

 Data obtained from the project-level summary sheet based on the current configuration of 
the time sheet BP on the sheet. 

 Booking used is hard-booking. 

 Booking is obtained from the project booking summary sheet. 

Booking charts 

These charts are used to plot resource booking (soft and hard) against demand (allocation) and 
capacity: 

 Show allocations by role and corresponding bookings against the role. 

 Highlight issues with underbooking or overbooking. 

 Show hard- and soft-booking. Non-project time can also be shown. 

 Successful satisfaction of resource demand via resource commitments (booking). 

Calculations on the booking charts (company level): 

 Booking obtained from company booking summary sheet for the specified range of dates. 

 Allocation obtained from the company allocation summary sheet for the specified range of 
dates. 

 Overbooking % = [(Total Booking – Capacity)/Capacity] * 100 (0% if negative). 

 Total capacity will add capacity hours of all resources at the company level that can play 
the role (not limited to default roles). 

 Booking cost is obtained from the company allocation summary sheet. 

 Total Booking = Soft + Hard booking. 

Calculations on the booking charts (project level): 

 Booking obtained from the project booking summary sheet for the specified range of 
dates. 
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 Allocation obtained from the project allocation summary sheet for the specified range of 
dates. 

 Booking cost is obtained from the project allocation summary sheet. 

 Capacity, Overbooking and Unmatched Supply column to show only at company level. 

 Total Booking = Soft + Hard booking. 

Utilization charts 

These charts: 

 Show utilization of resources against budgeted project work. 

 Resource Manager can see that all resources are adequately occupied with billable 
project work. Administrative work at the company level does not count. 

Calculating values on the utilization charts (company level): 

 Utilization % obtained from the company utilization summary sheet for the specified 
range of dates. 

 Booking is obtained from the company booking summary sheet. 

 Assigned hours is obtained by adding assigned hours on project schedule sheets across 
all projects. 

 Utilization % = (Total Assigned Hours / Hard-booked Hours) * 100 (shows two decimal 
places). 

Calculating values on the utilization charts (project level): 

 Utilization % obtained from the project utilization summary sheet for the specified range 
of dates. 

 Booking is obtained from the project booking summary sheet. 

 Assigned hours is obtained by adding assigned hours from the project schedule sheets. 

Configure the dashboard 

You can configure the content layout by doing the following: 

 Add one or more charts in each column. 

 Set up filter conditions and title for each chart. 

 Add the same chart multiple times to the same column and display the same report with 
different query parameters. 

To configure the resource manager dashboard 

1) From the Resource Dashboard log, click Edit and choose one of the following: 

 Left Column: The Left Column Blocks window opens. 

 Right Column: The Right Column Blocks window opens. 

These are set up the same way. 

2) To add a chart, click Add. Complete the Add Summary Block window: 

 Report Name: Click Select. Choose a chart from the list and click OK. The report fields 
are auto-populated. You can edit the title if desired. 
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 Specify filter conditions: 

 Roles and projects are multiselect fields (you can choose one or more from the 
list). 

 If fields are left empty, it means all. 

 Project field is disabled in the project-level dashboard and displays the current 
project. 

To edit a chart on the blocks list 

Select it from the list and click Open. 

To delete a chart on the blocks list 

Select it from the list and click Delete. 

 Roles and projects are multiselect fields (you can choose one or more from the list). 

 If fields are left empty, it means all. 

 Project field is disabled in the project-level dashboard and displays the current project. 

 Shows current project. 

Example project resource dashboard

Print the dashboard 

To print the dashboard: 

1) Navigate to the company-level or project-level resource dashboard. 

2) Click File > Print Preview. A print preview window of the dashboard opens in an HTML 
view. 

3) Click the Print button. 
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About Resource Business Processes 

Resource-type business processes can be designed in uDesigner and deployed in Unifier to 
work with the Resource Manager. There are two resource-type business processes that work 
with the Resource Manager: 

 Resource Booking  

 Timesheet 

Resource Booking business process 

This is used to book resources; that is, to fill project requirements with an available resource 
from the company. Resources can be booked within the duration of resource allocation. 
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Notes: 

 The Resource Booking business process is used only to add 
bookings, not to modify existing bookings. 

 The Resource Booking business process is not available in generic 
shells. However, you can book resources via manual entry on the 
Resource Booking Sheet. 

 When a record reaches a defined terminal status, the resource is 
hard-booked. 

 While the record is in a non-terminal status, the resource is 
considered soft-booked. 

 Resource Manager configuration determines if overbooking is 
allowed. 

To use a Resource Booking business process 

Open a project or shell and launch the resource booking business process. In the upper form, 
pick a date range to book resources. The date range will constrain the detail form grid display. 
The line item list displays a summary of booking rows. 

Example Resource Booking business process 
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 Click the Add button and choose Detail Line Item. The Find window opens. 

 Click Select to allocate the role, and then click the Search button. The business process 
pre-populates with rows from the project allocations summary sheet. 

 The resource is hard-booked when the terminal status Approved is reached in the workflow. 
The resource is soft-booked when the status is other than the terminal status, for example, 
Pending. 

Timesheet business process 

Use the Timesheet business process to submit your time sheets. Actual hours and costs can be 
rolled up to the actuals summary sheets of the Resource Manager. The business process can 
also be designed to roll up costs to the project/shell cost sheet (Resource Actuals column). 

The Timesheet business process: 

 Specifies the time you spend on a project. 

 Calculates rates based on role properties 

 Rolls up actuals to the actuals summary sheet at the company level and project/shell level. 

Multiple Timesheet business processes can exist for a company. For example, a company may 
design one Timesheet business process to capture and roll up time (hours) only. Another time 
sheet type BP can be used to design a reconciliation business process that references the time 
sheet and is used to specify, modify, and roll up actuals costs. 

The Timesheet business process is used to enter the actual hours you worked on each day. 
Time can be entered as regular work hours or over-time so that the appropriate billable rate can 
be applied. Time can be entered for company-level tasks, holidays, paid time off, and project or 
shell-level work. For billable activities, the billable rate is obtained from the role or from the 
project/shell booking (average booking rate), as applicable. 

In addition to your own time sheet, a separate time sheet can be designed with a workflow 
schema that will accommodate someone else reporting your time on your behalf. For example, a 
company may allow a project manager or resource manager to report time for you. 

If the Timesheet business process has been designed for line item entries, you can enter line 
items for time you spent on different types of work during a week, such as different projects. You 
could use other line items to report holidays, PTO, or company-level work. 

The actual hours and corresponding costs from Timesheet business processes feed various 
sheets at the company and project/shell level, including company and project/shell actuals 
sheets, and company account and project/shell costs sheets. 

To use a time sheet business process 

Open a project, and launch the time sheet business process. 

The Week Of required field is the limiting factor for the line items. The week begins on Sunday. 
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Understanding Reverse Auto-population 

Certain data elements support reverse auto-population. These are specified in uDesigner. 
Reverse auto-population means that some values can be updated when other values are 
modified in a BP that has reached a specified status. Auto-population can occur on BPs that are 
in the same shell or across shells. 

Depending on the setup in uDesigner, reverse auto-population can occur in these instances: 

 Changes to data elements in a business process upper form can result in changes to the 
upper form of another business process. 

 Changes to the detail form in a business process can result in changes to the upper form 
and detail form of another business process. 

 Changes to the upper form or detail form of a business process can result in changes in the 
Asset, Resource, or Planning Manager forms. 

In the Resource Manager, reverse auto-population might occur if a Resource Booking business 
process references a move order business process. 
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Unifier Schedule Manager 

The Schedule Manager helps you manage project or shell and program schedules. You can 
create a Project Schedule Sheet that is customized to the project's needs. Once these sheets 
are created, you can then use them to create project activities and tasks, assign resources to 
tasks, create relationships between activities, track schedule progress and variables, and 
calculate the schedule’s critical path. 

In Unifier, you can also import project schedule records from Primavera Project Planner® or 
Microsoft® Project. These external project schedules can provide additional detail or supporting 
schedule information; for example, resource information, or subcontractor or vendor schedules. 
Imported schedules are editable within Unifier, and the data can be used in reports. 

The Schedule Manager presents schedule activities as interactive Gantt charts, where you can: 

 Zoom in to see tasks at the day, week, or month level 

 Move activities and add dependency relationships, and automatically update the dates on 
the schedule 

 Create critical path calculations that will flag activities that, if delayed, can cause the 
schedule to go beyond the planned project end date 

Using Unifier snapshot feature, you can take a "picture" of the schedule sheet at any point in 
time. Using the Schedule Manager’s baseline function, you can measure progress and 
determine payments against original estimates; and with the tracking Gantt feature, you can 
compare schedule dates, such as baseline estimates against the actual schedule. 

If you copy activities from one schedule to another, Unifier will immediately notify you if the 
change will create a schedule conflict so that you can make corrections as you work. Each 
change in the Schedule Manager creates a record in Unifier, which is useful for auditing 
purposes. An audit report of these records shows detailed information on dates, events, actions, 
and old values versus new values, along with the user or proxy user who performed the action. 

Each project/shell can have multiple schedule sheets, and one master schedule sheet. This 
master sheet drives project start and end dates, tracks the project’s progress, and serves as the 
interface between the Schedule Manager and other Unifier modules. In particular, the master 
schedule updates resource assignment information in the Resource Manager, which affects 
timesheets and resource utilization figures; and it integrates cost items on the schedule with the 
Cost Manager. Unifier users can refresh resource rates on the schedule sheet and post the new 
rates to the Cost Manager, update the cost sheet with assignment costs, and refresh costs on 
the sheet to recalculate labor costs and post them to the cost sheet. 

Features include the following: 

 Fully configurable activity attributes form 

 Activities and Gantt chart on the same schedule sheet 

 Interactive Gantt chart with ability to drag activity end dates and link activities 

 Tracking Gantt chart 

 Filters for activities 

 Baselines for schedule sheets and activity sheets 

 Activity update 

 Ability to create one or multiple interactive schedule sheets for the same project or shell 
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 Integration of Schedule Manager with the Resource Manager, enabling resource loading of 
schedule activities 

 Multiple CBS codes for each activity to capture activity costs, such as labor, non-labor, and 
fixed costs. If designed in uDesigner, you can add a column to the schedule sheet to display 
the CBS codes associated with each activity. 

 View the cost distribution information by CBS codes from a schedule sheet 

 Cut and paste and copy and paste of rows in a sheet 

 Update of schedule sheets from linked templates 

 Critical path calculation and display 

 Streamlined and enhanced integration and interaction between Unifier Schedule Manager, 
Primavera, and Microsoft® Project 

 Activity progress tracking and percentage of work completed per assigned resource 

 Works with shells that have the CBS cost type 

 Scope Management, with the ability to launch business processes from activities and 
automate schedule management. 

 Budget and progress settings, and the ability to work with progress and earned progress 
data 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 
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Schedule Sheet permissions 

User Mode sheet-level permissions can be assigned by the creator or a user with Full Access 
permission. 

Sheet-level permissions are set up on each project or shell Schedule Sheet on the user side, 
and can also be set up on schedule sheets within project or shell templates. 

To assign permissions to a schedule sheet 

1) Open the project or shell, or the project/shell template. 

2) Select the schedule sheet in the Schedule Sheets log. 

3) Click the Permission button. 

4) Add users or groups and assign permissions: 

 Modify Permissions: Allows the user to modify the permissions of a schedule sheet. 
Checking this permission will check all permissions below. 

 Edit Data: Allows the user to edit the sheet, including data, columns, and rows, cut and 
paste activities. Users that have the Edit Data permission can import data. They can also 
edit Activity Progress and refresh the schedule sheet. 

 Edit Data and Structure: Allows the user to set and clear baselines on schedule sheets 
and Activity Sheets; also to copy and paste activities. Enables users to add or remove 
linked schedule sheet templates. Also enables users to edit data element level 
restrictions on activities on a schedule sheet. 

Users with the Edit Data and Structure permission can edit these activity progress related 
components: 

 Options tab of the Schedule Sheet Properties 

 Budget and Progress Setup (schedule sheet level or activity level) 

 Activity Progress 

 Activity Progress Log 

 Schedule sheet refresh 

 View: Allows the user view-only access to the sheet. Automatically granted if any of the 
permissions above are granted. Can also view the Linked Template window. 

5) Click OK. 

Create a Schedule Sheet 

Each schedule sheet that you create has its own set of properties, which you can use to control 
schedule sheet behavior. 

Unifier separates Schedule Sheet Properties into five tabs; each tab has a distinct purpose. 

 The General tab is where you can define basic schedule information, for example, 
Schedule Sheet Name, and Start Date. 

 The Gantt Chart tab is where you can define what you want to see in the visual 
representation of the sheet, for example, common choices are Activity Name, Start Date, 
and Finish Date. 
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 The Tracking Gantt tab is where you can set up comparisons of activities, for example, 
you can compare Actual Start Date with the originally planned Start Date. 

 The Options tab is where you can set up how you want Unifier to update activity status 
and progress requirements. 

 The Schedule tab is where you set the schedule sheet refresh schedule. 

You can create a project or shell schedule sheet in the following ways: 

 Manually 

 Copying from a project/shell schedule sheet template 

 Copying from another schedule sheet in your project 

 Importing a schedule file. 

You can have any number of schedule sheets in a project or shell. You can designate one sheet 
as a master schedule sheet, which appears in bold in the log. The master schedule sheet drives 
the activity start and finish dates, and allows you to assign resources to activities. You can use it 
to track progress and resource assignment information to other modules in Unifier. 

Note: You may want to set up the schedule sheet before selecting it as 
the master sheet. Once you select the sheet as the master sheet, it 
cannot be deselected. 

To create a project or shell schedule sheet manually 

1) In User Mode, select the project or shell, and select Schedule Manager > Schedule 
Sheets. The Schedule Sheets log opens. 

2) Click New. The Schedule Properties window opens. 

3) Complete the Schedule Properties tabs. See Schedule Sheet Properties General Tab (on 
page 560). 

To create a schedule sheet by copying from a project or shell template 

1) In User Mode, select the project or shell, and select Schedule Manager > Schedule 
Sheets. The Schedule Sheets log opens. 

2) In the Schedule Sheets log, click Copy > Template. 

3) Select the template to copy and click Open. 

4) Complete the Schedule Properties tabs. See Schedule Sheet Properties General Tab (on 
page 560). 

To create a project or shell schedule sheet by copying another sheet 

1) In User Mode, select the project or shell, and select Schedule Manager > Schedule 
Sheets. The Schedule Sheets log opens. 

2) In the Schedule Sheets log, click Copy. The Schedule Sheets window opens showing all 
sheets in the project/shell (both active and inactive) 

3) Select the schedule sheet to copy and click Open. The Schedule Sheet Properties window 
opens. 

4) Complete the Schedule Properties tabs. See Schedule Sheet Properties General Tab (on 
page 560). 
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To import CSV files 

1) Open the schedule sheet. 

2) Choose File > Import > From CSV. If a default mapping is not selected, the Select Data 
Mapping window opens. 

3) Select the data mapping you want to use for this import and click OK. The File Upload 
window opens. 

4) Browse to select the file to upload. 

5) Click OK. 

To import XML and MPP files 

1) Open the schedule sheet. 

2) Choose File > Import > From External Source. If a default mapping is not selected, the 
Select Data Mapping window opens. 

3) Use the table below to complete the fields in this window. 

4) Click OK. The File Upload window opens. 

5) Browse to select the file to upload. 

6) Click OK. 

In this field: Do this: 

MPP 
Data mapping is not required; leave the Data Mapping 
field empty. 

MPP XML 
Data mapping is required; select the mapping you want to 
use. 

MPP activity calendar 

Select Consider Activity Calendar. 

This requires an existing calendar in Unifier with the 
same name. 

If an activity calendar is not imported and considered, the 
activity will use the existing calendar defined in the 
schedule sheet properties. 

MPP Resource 
assignments 

Data mapping is not required; leave the Data Mapping 
field empty. This requires a data set for the SYS 
Resource Type data element. 

Use MPP standard resource types: Work, Material, and 
Cost. Upon import, Unifier will soft-book these resource 
types. 

Before you begin: 

 You must have permission to import files. See Schedule Sheet permissions (on page 
557). 

 For CSV or XML files, your administrator must first define the data mapping. 

 To use the Activity Calendar from Microsoft Project, first create a calendar in Unifier with 
the same name as the external calendar. 
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 To import Resource Assignments from Microsoft Project, first add the same MPP 
resource types to the SYS Resource Type data set in Unifier. We recommend using MPP 
standard resource types: Work, Material, and Cost. 

Schedule Sheet Properties General Tab 

To complete the General tab of the schedule sheet properties: 

1) In User Mode, open the project or shell in the left Navigator. Click Schedule Manager > 
Schedule Sheets. The Schedule Sheets log opens. 

2) Click New or open an existing schedule sheet. The Schedule Sheet Properties window 
opens. 

3) Complete the General tab as described in the table below. 

4) Click OK. The new schedule is available in the log. 

From here you can: 

 Open the Properties window, the Gantt Chart tab, the Tracking Gantt tab, the Options 
tab, and the Schedule tab. 

 Open the sheet and add columns and rows (activities). 

In this field: Do this: 

Schedule Title 
Enter a title for the template. This is used as the template 
identifier and must be unique. (up to 120 characters) 

Description Enter an optional description. (up to 400 characters) 

Master Schedule 

When you create a new schedule sheet in a project or shell or 
project or shell template, you can select this checkbox to make 
the schedule sheet the "master schedule (one per project or 
shell or project or shell template; once selected, it cannot be 
deselected). 

Status 
When you are ready to make the template active and available 
for use, click Active. 

Auto-control 

Controls the automatic update of tasks for Scope Management. 
The default is Off. Setting Auto-control to On enables the 
automatic launch of BP records. Setting Auto-control to Off 
means that BPs will not be launched automatically on activities. 
Also, completion conditions will not be checked on activities. 
Users can still launch BPs manually. 

Note: Unifier disregards predecessor/successor dependency 
relationships when you manually start an activity, even if 
auto-control is set to On in the schedule sheet properties. 

Calendar 

Select a calendar to use with the schedule sheet. You can 
choose from Standard Calendars (company-level calendars), 
Project/Shell Calendars, or Custom Calendars (defined for the 
Schedule Manager). This calendar is used by all activities on 
the schedule sheet. The Calendar data element is also 
available for use as a column in the schedule sheet. When a 
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new schedule sheet is created, the Project/Shell Calendar is 
selected by default. Users can change this default selection. 
The calendar selected affects project durations and due dates. 

For templates, the only choice is Standard calendars. 

The Schedule Start Date always uses the Project/Shell 
Calendar. Activity start dates are not affected when you change 
the calendar. 

The selected Start Date or Finish Date for an activity can be a 
non-working calendar day, however the duration of the activity 
will only account for working calendar days. 

Schedule Start Date 

Drives the dates of floating activities on the schedule sheet for 
Scope Management. No activities can begin before this date; 
however, activities do not have to begin on this date if their 
preceding activities complete previous to this date. 

The Manual and Shell Attribute radio buttons are active for a 
master schedule sheet if the Project Start Date data element 
has been added to the Shell Attribute form (for CBS shells) in 
uDesigner, and if no activity has started on the sheet. These 
buttons allow you to specify whether the Schedule Start Date 
should be set manually, or automatically populate. For 
non-master schedule sheets, the choice is always Manual, and 
Shell Attribute is not selectable. 

If you select the Manual radio button, you can select a 
Schedule Start Date. 

If you select Shell Attribute radio button, the Schedule Start 
Date automatically populates from the Project Start Date 
specified on the General tab of the shell properties. 

Also, the shell Project Start Date can update the master 
schedule sheet start date if no activity has been started on the 
sheet. Sheets other than the master schedule sheet are 
created with the Project Start Date specified on the shell, but 
this date cannot be updated from the Project Start Date field in 
the shell properties. 

Notify users and/or 
groups on errors 

Select Users and groups to be notified if there are errors during 
any point during the Scope Management task routing. 

Permission: Enforce 
Activity Level 
Permissions by Group

Select to specify that you are implementing group activity 
editing. If you select this checkbox, you must also select a 
default group. 

Default Group 
Required if you select Permission Enforce Activity Level 
Permissions by Group. Select the group to use as the default 
group for activity-level editing. 
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Gantt Chart tab of the Schedule Sheet Properties 

You can define the display of data elements on the activity bars on the Gantt chart. You can add 
up to three labels: to the left, on top, and to the right of each activity bar. The labels correspond 
with the data element fields that are available on the Properties window (activity attribute form) 
for each activity. 

Note: If you are selecting specific calendars for your project/shell and 
schedule sheet, the Gantt chart uses the project-level or shell-level 
calendar, not the calendar selected for the schedule sheet. 

To configure Gantt chart activity bar text 

1) Click the Gantt Chart tab. 

2) Select data elements. You can add one label or all three. The selected data element(s) will 
display at the Top, Left or Right of the activity bar. The available data element options are 
derived from the activity form (schedule attribute form or default form). 

3) Click OK. 

Schedule Sheet Properties: Tracking Gantt Chart tab 

A tracking Gantt chart allows you to compare two sets of dates for a specific activity. It allows 
you to track activity progress against the original plan. For example, the tracking Gantt chart 
allows the comparison between two sets of dates such as baseline and actuals. Users with view 
permissions can view a tracking Gantt chart. The tracking Gantt chart is view only. It is not 
interactive like the regular Gantt chart. 

You can define the display of data elements on the activity bars on the Tracking Gantt chart. 
You can add up to three labels: to the left, on top, and to the right of each activity bar. The labels 
correspond with the data element fields that are available on the Properties window (activity 
attribute form) for each activity. 

To configure Tracking Gantt chart activity bar text 

1) Click the Tracking Gantt Chart tab. 

2) Select data elements. You can add one label or all three. The selected data elements will 
display at the Top, Left or Right of the activity bar. The available data element options are 
derived from the activity form (schedule attribute form or default form). 

3) Click OK. 

Options Tab of the Schedule Sheet Properties 

These options allow you to control the automatic update of activity status based on Actual Start 
and Actual Finish dates, to specify that activity progress requires an Actual Start Date, and to 
enforce a dependency between Activity % Complete and the Actual Finish Date (with the option 
of auto-update of the Activity % Complete). 

See Project Progress Data Accumulation and Calculation (on page 635) for details on 
progress data accumulation and earned progress. 
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To specify that activity status auto updates based on actual start and finish dates 

By default, the Activity Status controls Actual Start and Finish of an activity. If you select the 
Auto update activity based on Actual Start/Finish Dates, the Actual Start date and Actual Finish 
date control the Activity Status. Selecting this box, makes the Activity Status field read-only on 
the Activity Properties. When this checkbox is deselected, you can change the Activity Status. 

The following table describes the interactivity of the Actual Start, Actual Finish, and Activity 
Status fields when the Auto update activity status based on Actual Start/Finish Dates checkbox 
is selected: 

Actual Start Actual Finish Activity Status 

Editable (no date selected) Editable (no date selected)
Read-only. Not Started option 
is selected. 

Editable (date selected) Editable (no date selected)
Read-only. In Progress 
option is selected. 

Editable (date selected) Editable (date selected) 
Read-only. Complete option 
is selected. 

1) Click the Options tab. 

2) Select the Auto update activity status based on Actual Start/Finish Dates checkbox. 

3) Click OK. 

To specify that activity progress requires an actual start date 

You can specify that activity progress information cannot be entered if there is no actual start 
date for the activity. For example, an actual start date must be specified for users to be able to 
enter any activity progress, including Activity % Complete and Earned Progress on the Activity 
Properties. 

When the Checking the Activity Progress requires an Actual Start date checkbox is selected, 
Unifier validates that there is an Actual Start date specified for the activity. If there is no Actual 
Start date, and this checkbox is selected, users will not be able to enter activity progress data 
until the Actual Start date is added for the activity. 

Note: You cannot select the Activity Progress requires an Actual Start 
date checkbox if the activity has recorded progress. If there are any 
progress entries, Unifier will not allow you to select this checkbox until a 
start date is provided or the existing progress data is deleted. 

1) Click the Options tab. 

2) Select the Activity Progress requires an Actual Start date checkbox. 

3) Click OK. 
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To enforce dependency between Activity % Complete and Actual Finish Date for an 
activity 

You can enforce a dependency between the Activity % Complete and the Actual Finish Date of 
an activity. When you select Enforce Activity 100% Complete again Actual Finish, Unifier will 
require the user to enter the percentage for Activity % Complete as 100%. Conversely, when the 
user specifies that Activity % Complete is 100%, Unifier will require the user to enter a value for 
the Actual Finish Date. Also, you can enforce that Activity % Complete is changed to 100% if an 
Actual Finish Date is entered. 

Note: If data has been entered (Activity Finish Data is entered or the 
Activity % Complete is less than 100%, or vice versa), and then you 
attempt to select the Enforce Activity 100% Complete against Actual 
Finish checkbox, the system will prevent you from selecting the 
checkbox for this option. In this case, you must clear the existing data to 
be able to select the Enforce Activity 100% Complete against Actual 
Finish checkbox. 

1) Click the Options tab. 

2) Select the Enforce Activity 100% Complete against Actual Finish checkbox. 

3) Click OK. 

Note: Impact on Scope Management: If you have specified a 
dependency between the Actual Finish Date of an activity and the 
Activity % Complete, the Activity % Complete value for an activity will 
automatically update to 100% when an Actual Finish Date is entered for 
that activity. This can occur when the Activity Status is updated to 
Complete, whether through a business process or manually. 

To auto-update Activity % Complete based on Actual Finish Date for an activity 

If you have selected Enforce Activity 100% Complete again Actual Finish, you can further 
specify that the Activity % Complete value is automatically updated to 100% when the user 
enters a Actual Finish Date. 

1) Click the Options tab. 

2) Select the Enforce Activity 100% Complete against Actual Finish checkbox, and the 
Auto-Update % Complete to 100% after entering Actual checkbox. 

3) Click OK. 

Schedule Tab of the Schedule Sheet Properties 

The schedule sheet refresh updates cost data associated with the schedule sheet. The refresh 
updates activity costs and resource/role costs. 

A schedule sheet refresh can fail if: 

 An activity has more than one CBS code 

 A cost sheet column to which a schedule sheet column is associated is deleted from the cost 
sheet 
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You can set the refresh frequency. The refresh frequency you set is shown in the schedule 
sheet log under the column heading Scheduled. Schedule sheets that require refresh are listed 
in the Schedule Sheet log displaying the refresh icon. 

To set the refresh frequency of schedule sheet template data 

1) In User Mode, open the project or shell in the left Navigator. Click Schedule Manager > 
Schedule Sheets. The Schedule Sheets log open. 

2) Select one or more schedule sheet templates. 

3) Choose Refresh > Set Frequency. The Set Frequency window opens. 

4) Select the Enable scheduled refresh checkbox. 

5) Select the Frequency and the Range of Recurrence. 

6) Click OK. 

Create a master schedule sheet 

Unifier allows one master schedule sheet per project/shell. You can mark a schedule sheet in a 
project or shell and project or shell template as the Master Schedule sheet. 

Caution: Upon saving, Master Schedule designation is permanent and cannot be undone. 

You can use the master schedule sheet to: 

 Drive project dates, for example start date, finish date, planned completion, revised 
completion 

 Drive activity start and end dates 

 Track progress of activities over the lifetime of the project 

 Drive scope management 

 Post costs to the Cost Manager 

 Support Cash Flow and Earned Value analysis 

 Interface with the Resource Manager for resource assignments and availability 

You can mark one schedule sheet in a project/shell as the master schedule sheet. 

Once you save a schedule sheet as the master, there is no un-do to non-master status. 

To mark a sheet as the master schedule sheet 

1) In User Mode open the project/shell in the left navigator. 

2) Click Schedule Manager > Schedule Sheets. The Schedule Sheets log opens. 

3) Select the sheet that you want to make a Master Schedule Sheet and click the Properties 
button. The Properties window opens on the General tab. 

4) Select the Create as master schedule sheet checkbox. 

5) Click Yes to confirm. 

Open / Modify schedule sheet template properties 

You can modify the properties of a schedule sheet template. 
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To modify schedule sheet template properties 

1) In User Mode, open the project or shell in the left Navigator and click Schedule Manager > 
Schedule Sheets. The Schedule Sheets log opens. 

2) Select a template. 

3) Click the Properties button. 

4) Modify the properties as needed. 

5) Click OK. 

Changes that occur to copied and pasted activities 

 Status will be set to Not Started for the pasted activity. 

 Actual Start Date and Actual Finish Date will be cleared. 

 Links to BP Record, Record Status are not copied. 

 Critical Path elements are recalculated. 

 Copying an activity will not copy dependencies. 

 Moving Summary Activities will automatically move all activities below the summary 
whether the summary is expanded or collapsed. If the activity is not a summary row, any 
corresponding summary tasks will be updated automatically to reflect any changes in start, 
finish, and duration. The Gantt Chart View will reflect the new ordering of activities without 
affecting dependencies. 

Activities remain in the buffer until the next copy/cut or save. Allowed actions that do not empty 
the buffer are: 

 Find 

 Zoom In or Zoom Out 

 Focus 

 Opening the Activity Attribute form without changing data. 

If you perform any other actions before clicking Paste then the contents of the buffer are lost. A 
subsequent paste will not result in any action. Actions that empty the buffer are: 

 All actions on the toolbar (Save, Add, Delete, Indent/Outdent, Gantt, Progress, Close 
Window.) 

 All actions under the File menu 

 All actions under the Edit menu (Except Paste) 

 All actions under the View menu except Find 

 Clicking into any editable cell or modifying dates via Gantt or the Activity Attribute form. 

Add an activity to a schedule sheet 

Before you begin: Schedule sheet permission is granted on a sheet-by-sheet basis. Adding or 
editing an activity requires Edit Data or greater permission. If you only have View permission 
you cannot add or edit activities. See Schedule Sheet permissions (on page 557). 

This page contains information on adding activities manually, copying activities from another 
sheet, and using copy/cut and paste. 
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For information about importing schedule sheet data directly into Unifier see Create a Schedule 
Sheet (on page 557). 

Add activities 

You can add activities to a schedule sheet in the Activity Properties window.  

Click the topic links for information and directions on completing:  

 The General tab of the Activity properties (on page 568) 

 The CBS tab of the Activity properties (on page 569)  

 The Resources tab of the Activity properties (on page 569), and Role-related 
Calculations (on page 571) 

 The Dependencies tab of the Activity properties (on page 574) 

To manually add an activity to a schedule sheet 

1) In User Mode, open the project/shell where the schedule sheet resides, and click Schedule 
Manager in the left navigator. 

2) Select Schedule Sheets. The Schedule Sheets log opens. 

3) From the Edit menu, or from the toolbar, click Add and select Manual. The Activity 
Properties window opens. 

4) Complete the activity property tabs as described in General tab of the Activity properties
(on page 568). 

To copy an activity from another sheet 

1) In User Mode, open the project/shell where the schedule sheet resides, and click Schedule 
Manager in the left navigator. 

2) Select Schedule Sheets. The Schedule Sheets log opens. 

3) Open the sheet you want to change. 

The default order for a new row is at the end of the activities list. You can insert a row where 
you want it by selecting a row on the sheet. Unifier adds the new row above the selected 
row. 

4) From the Edit menu, or from the toolbar, click Add and select Copy Activity From. The 
Schedule Manager Picker window opens. 

5) Select a schedule sheet from the Schedule Sheet drop-down list, which lists all the active 
schedule sheets in the current project. 

6) Select an activity from that sheet and click Copy. 

Non-hardbooked roles are copied into the destination schedule sheet. 

The role amount is recalculated for the added activity and for any activity that has its start or 
finish dates changed as a result of the addition. 

7) If you want to make changes to the activity properties, click the activity to open it. 

To copy and paste activities in a sheet 

1) Open the schedule sheet in the log. 

2) Highlight the row or rows you want to copy. 

3) Choose Edit > Copy. 
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4) Select the destination for the copied rows. The rows you copy will be inserted above the 
selected destination row. 

5) Choose Edit > Paste. You can choose Edit > Paste multiple times to repeat pasting the 
copied rows. 

6) Copy and paste copies all data on the copied activity including Scope Management Setup, 
dependency relationships, Baselines, CBS, and resource assignments. 

To cut and paste activities in a sheet 

1) Open the schedule sheet in the log. 

2) Highlight the row or rows you want to cut. 

3) Choose Edit > Cut. The row you want to cut is highlighted, and remains in place until you 
paste it. 

4) Select the destination for the cut rows. The rows you paste will be inserted above the 
selected destination row. 

5) Choose Edit > Paste. You can choose Edit > Paste multiple times to repeat the pasting of 
the cut rows. 

6) You can undo the cut action by choosing Edit > Undo Cut. 

General tab of the Activity properties 

General tab 

The General tab shows fields from the schedule sheet. The fields may vary depending upon how 
the designer created the schedule sheet attribute form. The table below shows mandatory fields. 

In this field: Do this:

Activity ID 
The Activity ID reflects the list order of activities on the schedule sheet. 
This field is automatically populated and can change if activities are 
added or removed. 

Activity name
The activity name reflects the activity on the schedule sheet. This is an 
editable field; any changes in the attribute form will show up on the 
schedule sheet. 

Start Date 
Enter or edit the date an activity will start. 

role-related calculation 

Finish Date 

Enter or edit the date an activity will end. 

Any changes to the finish date, either in Activity Properties or directly in 
a schedule sheet column, will trigger Unifier to recalculate the role 
amount of the role assigned to the activity. This helps you understand 
the cost impact of a schedule change. 

Task 
Duration 

The task duration is automatically calculated from the start and finish 
dates. If you enter a value that is larger than the difference between the 
start and finish dates, then the duration is re-calculated from the start 
date. 
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CBS tab of the Activity properties 

CBS Codes tab 

Here you can link a CBS code to an activity, which makes the activity available for cash flow 
analysis. 

To add a CBS code 

1) Click the Add button located on the bottom left of the window. The Add CBS Code window 
opens. 

2) Select a CBS code from the CBS code picker. The CBS Item automatically populates based 
on the CBS code selection. 

3) Add a value for Split Percent. Unifier highly recommends using 100%. 

To remove a CBS code 

1) Select the CBS code you want to remove. 

2) Click the Remove button located on the bottom left of the window. 

Resources tab of the Activity properties 

Resource tab 

Here you can assign resources and roles to an activity using the Schedule Sheet Resource 
Assignment form, which can be different than the one shown here. Fields can be in a different 
order on the form, the form can include additional fields than this form, and the form can 
dynamically change, depending on field selections. 

Before you begin, be sure your administrator defined resources and roles in the company-level 
Resource Manager. 

To add or edit a resource 

1) Click the Add button located on the bottom left of the window. The Resource Assignment 
window opens. 

2) Use the information in the table below to complete the fields on this form. 

3) Click OK to save the form. 

In this field: Do this: 

Resource Type 

Select a resource type for the activity. 

Hard Booked resource costs roll up to the total activity cost 
as a labor cost.They are company defined and can be 
virtually anything from a person to something like pipe or 
concrete. 

Non-hard booked resource costs roll up to the non-labor 
costs of an activity. They are company defined as well, and 
can be virtually anything from a person to something like 
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pipe or concrete. 

Note: Data set values for this drop-down field must start on 
row 1 and cannot be 0 (zero). 

Resource Picker 

Select a resource for the activity. 

If you selected a hard booked resource for the activity, you 
can use the Resource Picker to assign a resource to this 
activity. 

If you selected a non-hard booked resource, the Resource 
Picker is unavailable and you must enter the Resource 
Name. 

Resource Name 

View or enter the resource name. 

If you selected a hard booked resource, this field is 
automatically populated. 

If you selected a non-hard booked resources, you must 
enter the name of the activity resource. 

Resource Code 

View or enter the resource code of the assigned resource. 

If you selected a hard booked resource, this field is 
populated with the code of the selected resource. 

If you selected a non-hard booked resource, this field is 
editable and you can enter a value. 

Role Data Picker 

If this field is not on your form, disregard these instructions. 

If this field is on your form, you can select a role for the 
activity. See Role-related Calculations (on page 571) for 
instructions on working with this field. 

Role Name 

This is a read-only field where you can the role of the 
resource assigned to the activity. 

If a hard booked resource is selected, then this field is 
auto-populated. 

If a non-hard booked resource is selected, then this field is 
not populated. 

If a role data picker is on your form, and you selected a role 
using the picker, the Role Name is automatically populated.

Quantity (Qty) 
Enter the resource quantity, for example tonnage or 
number of days, as suitable for the resource. 

UOM 
Select the unit of measure associated with the effort. For 
example, if the Resource Type is Man-hours, the unit of 
measure is hours. 

Rate 

View or enter the unit rate of the effort. 

If a hard booked resource is selected, this value is 
read-only and populated based on the rate at which the 
resource is booked. 
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If a non-hard booked resource is selected, you must enter a 
rate. 

If you used a role data picker to select the role, the rate is 
pre-populated. 

Amount 

View or enter the amount or cost of the effort. If the 
resource selected is hard booked, this field is read-only and 
the value is calculated automatically by multiplying Quantity 
(Qty) with Rate. 

Otherwise, this data element is editable. You can enter a 
value in Primavera Unifier or a formula can be defined in 
uDesigner to calculate the amount. 

Role Amount 

If this field is not on your form, disregard these instructions. 

If this field is on your form, this field is automatically 
calculated. 

% Units 

View or enter the percentage of the resource available for 
the activity 

If a hard booked resource is selected, enter the 
percentage. 

If a non-hard booked resource is selected,this field is 
unavailable. 

If a role is selected using the role picker, this field is 
automatically calculated. 

% Complete 
this is a read-only field that shows the percentage 
completion of the activity.The value of this data element is 
calculated using Progress Quantity / Quantity (Qty). 

Role-related Calculations 

When you use a role data picker to assign a role to an activity, Unifier can use the role 
information to calculate role costs. 

Role-related calculations 

Activity role rate: For the activity role rate calculation, Unifier takes into account the effective 
date of the current role rate and the active currency exchange rate. Unifier recalculates the role 
amount under these circumstances: 

 The activity role rate changes, or any other activity dates change, for example, finish date or 
duration. 

 The role changes. 

 An activity is copied in the sheet. 

 An activity is copied from another sheet. 

Activity role amount: Unifier calculates the activity role amount on a daily basis. It considers: 
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 Value of the role rate, as of the effective date (this can differ by effective date) 

 Activity duration (this is the length of time the role rate was applicable before another rate 
became effective) 

 Active currency exchange rate (this can change due to currency fluctuations) 

 Percentage of a role’s assignment to the activity (% Unit) (this can differ during the activity) 

Unifier uses active currency exchange rates for transaction-to-project currency conversions. 
Exchange rate changes will flag the schedule sheet for refresh. 

Role amount recalculation: Any changes to start and finish dates, duration, predecessor 
activities, constraints, available days (via the calendar), activity levels (indent or out-dent) can 
trigger Unifier to recalculate the activity role amount. You can see the effect of activity role rate 
changes in cash flow distribution. Unifier calculates all values on a daily basis and adds up all 
amounts. 

Activity amount: An activity can have more than one role, each with its own costs. If the activity 
is associated with at least one CBS code, Unifier tallies the role amounts for an activity, rolls up 
costs to non-labor costs, and displays the sum of CBS code in cash flow. 

To use the role picker 

1) Open the project or shell where the schedule sheet resides, and click Schedule Manager > 
Schedule Sheets in the left Navigator. The Schedule Sheets log opens. 

2) Select the schedule sheet that contains the activity you want to modify and open it. 

3) Click the activity you want to modify. The Activities Properties window opens. 

4) Click the Resources tab and click the Add button located on the bottom left of the window. 
The Resource Assignment window opens. 

5) If you are using a role data picker, complete these fields: 

In this field: Do this: 

Resource Type 

Select a non-hard booked resource type for the 
activity. 

Non-hard booked resource costs roll up to the 
non-labor costs of an activity. 

They are company defined, and can be virtually 
anything from a person to something like pipe or 
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concrete. 

Resource Picker This field is not available. 

Resource Name Enter the name of the activity resource. 

Resource Code Enter the resource code of the assigned resource. 

Role Data Picker 

Select a role for the activity. You can click the Select 
button or the drop-down arrow and click Roles. 

This is a dynamic button whose label changes 
according to the previous selection. 

For example, after you select a role, the button 
name changes to Rateso you can access the 
Role Rate Override. 

Role Name The Role Name is automatically populated. 

Quantity (Qty) 
Enter the resource quantity, for example tonnage or 
number of days, as suitable for the resource. 

UOM 
Select the unit of measure associated with the effort. 
For example, if the Resource Type is Man-hours, the 
unit of measure is hours. 

Rate 
This field is not available for direct edit. Rates can be 
changed either at the company level or via Role 
Rate Override. 

Amount 
This data element is editable. You can enter a value 
in Unifier or a formula can be defined in uDesigner to 
calculate the amount. 

Role Amount This field is automatically calculated. 

% Units This field is automatically calculated. 

% Complete 

This field is read-only; it shows the percentage 
completion of the activity.The value of this data 
element is calculated using Progress Quantity / 
Quantity (Qty). 

If you want to override the role rate, go to the next procedure to override the role rate, below. If 
not, click OK to save and close the form. 
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To override the role rate 

1) In the Role picker field click the Rates button. 

The Current Effective Rate window opens, which shows the Effective Date, Standard Rate, 
and Custom Rate for the role selected. 

2) In the Current Effective Rates window select the Custom Rate field and enter the new rate 
for the role. You cannot change the Standard Rate from this window. 

3) If you want to add another rate that will take effect at a later date, click the Add button. 
Unifier adds a line to the form. 

4) In the Effective Date field, specify when this rate should take effect. Dates must be unique 
and fall within Start / Finish dates. 

5) In the Custom Rate field, specify the rate you want for the role. 

6) Click OK. Role rates recalculate upon schedule sheet refresh. 

Dependencies tab of the Activity properties 

Dependencies tab 

Here you can add dependencies between the current activity and other activities from the 
schedule sheet. You can select another activity on the schedule sheet, determine the 
relationship, (e.g. Finish to Start, Start to Finish, Start to Start, or Finish to Finish), and add a 
Lag. 

Note: Unifier disregards predecessor/successor dependency 
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relationships when you manually start an activity, even if auto-control is 
set to On in the schedule sheet properties. 

To add or edit a dependency 

1) Click the Add button located on the bottom left of the window. The Add Dependency window 
opens. 

2) In the Activity Name field, select the activity to make dependent upon the current activity. 

3) In the Relationship field, select from one of the following options: 

 Finish to Start: the dependency must finish before the Activity can start. 

 Start to Finish: the dependency must start before the Activity can finish. 

 Start to Start: the dependency must start before the Activity can start. 

 Finish to Finish: the dependency must finish before the Activity can finish. 

4) In the Lag field, enter the number of days for a gap or overlap between the selected activity 
and the current activity. A positive lag indicates a gap. A negative number indicates an 
overlap. 

To remove a dependency 

1) Select the dependency to remove. 

2) Click the Remove button located on the bottom left of the window. 

Add a schedule Sheet column 

There are three default columns: Start Date, Finish Date, and Duration. Duration always 
displays the result of Finish Date minus Start Date. You can add other columns as needed. You 
can add baseline columns that map to Start Date, Finish Date, and Duration. See Set 
Schedule Sheet Baselines (on page 591) 
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Note: Any changes to an activity start date, either in Activity Properties 
or directly in a schedule sheet column, will trigger Unifier to recalculate 
the role amount of the role assigned to the activity. For more 
information,See Role-related Calculations (on page 571)  

To add a schedule column 

1) In User Mode, open the project or shell where the schedule sheet resides and click 
Schedule Manager > Schedule Sheet. The Schedule Sheets log opens. 

2) Open the schedule sheet and click the Columns button. The Columns Log opens 

3) Click the New button. The Column Properties window opens. 

4) Complete the Column Properties window as described in the following table. 

5) Click OK. 

In this field: Do this: 

Name This field is populated with the chosen Data Source 

Data Source 

Select a Data Source from the drop-down list. The options include 
the data elements in the activity Properties window. When a 
schedule attribute form is designed in uDesigner, the data sources 
include all elements on the form, including hidden elements. This 
list also shows data elements based on Sys Project Cost Data 



Working with Unifier Managers

577

Source data definitions. 

Entry Method 

Choose one (the options that are available are dependent on the 
data source chosen): 

 Manual Entry: Users enter values directly on the schedule 
sheet 

 Formula: Value is calculated using the entered formula. 
Formulas can include calculating differences between date 
columns, or adding / subtracting numeric columns / values from 
dates. This is useful to calculate durations or to calculate one 
date from another date by adding/subtracting days. 

 Cost Sheet Column: Select a Cost Sheet column to associate 
with the data element based on the data definition Sys Project 
Cost Data Source. This pull-down menu lists all of the columns 
defined on the Cost Sheet. The cost data is refreshed when 
you or a user choose File > Refresh in a Schedule Sheet and 
refresh immediately or set up a refresh frequency. The Cost 
Sheet Column selector is available on schedule sheets in 
projects or shells and in project or shell templates. 

 The Cost Sheet Column definition must be reselected in a new 
schedule sheet that you create by copying a sheet or template, 
or by copying a project or shell. Definition must also be 
reselected if you link the schedule sheet. 

Data Format 

This controls how data is displayed on the schedule sheet. Options 
are: 

 Show as percentage. Data is displayed as % 

 Decimal places. Choose 1 to 8 

 Use 1000 Separator. Select checkbox to include a comma (,) 
separator 

 Negative Number Format. Choose parentheses or minus sign

Summary 

This controls the display of numeric and date column data on 
summary rows. 

 Display: Select the checkbox to display summary data for the 
column 

 Date Rollup: Available only for Date data types. Select Earliest 
Date or Latest Date. 

 Earliest Date: To summarize columns that represent activity 
start dates (e.g. start, planned start, actual start, etc.). The cell 
on the summary activity will show the earliest date from all 
child activities. 

 Latest Date: Tto summarize columns that represent activity 
finish dates (e.g. finish, planned finish, actual finish, etc.). The 
cell on the summary activity will show the latest date from all 
child activities. 

 Number Rollup: Available for numeric columns. Choose Total 
(displays sum total of the rows), Average (displays average 
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value of the rows), or Weighted Average based on and select a 
field from the Activity Attributes form. For example, you might 
choose Total for currency or other numeric types; for 
percentage columns, you might want to choose Average. 

 Weighted Average Based On: The drop-down list for this 
option lists the data elements available on the Activity Attribute 
form. Only data elements of the type Numeric are available for 
selection. Selecting this option and a data element allows 
Unifier to calculate the weighted average of summary rows. For 
example: 

Display Mode 
Choose to Show or Hide the column from user view. Users with 
Create permissions can see hidden column in the Columns Log. 

Column Position 
After 

The new column will be inserted after the column selected. 

Create a formula column in a schedule sheet 

You can create formula columns on a schedule sheet or template. Formulas can calculate 
differences between date columns, or add / subtract numeric columns / values from dates. This 
is useful to calculate durations or to calculate one date from another date by adding/subtracting 
days. 

You can define formulas of the following types: 

 Numeric: Build a numeric formula. This choice is available if the data source is SYS 
Numeric Logical. 

 Date Difference: Formula is by default Later Date – Earlier Date. This choice is available 
if the datasource is SYS Numeric Logical. 

 Date Add: Add a numeric value to a date. This is available if the datasource is SYS Date 
Logical. 

SYS Numeric Logical and SYS Date Logical are data definitions form which data elements can 
be created in uDesigner and used on schedule attribute forms. 

How to tell which data source to use in building a formula
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The ability to build formulas is dependent on the data definitions used to create the data 
elements on the schedule attribute form. You can navigate to Administration Mode > Data 
Structure > Data Elements to see which data elements are based on the above data definitions 
(click the column heading in the Data Elements log to sort by data definition. Alternatively, you 
can choose a Data Source in the drop-down list, then, with the Data Source field still active, 
press your keyboard’s up and down arrow keys to scroll through the data source options. When 
one of the above data definitions is reached, the Formula radio button becomes active. 

To create a numeric formula 

Choose Numeric and click Create. Activity data type displays data elements that are defined on 
the detail form along with "SYS Numeric Datasource" and "SYS Numeric Logical Datasource". 

To create a date difference formula 

1) Choose Date Difference and click Create. 

2) Enter Earlier Date and Later Date: 

a. Click Select. The Data Element picker opens. 

b. Choose a data element. Options are data elements from schedule sheet detail form or 
columns defined on schedule sheet. Only date type (Timestamp) data elements are 
displayed. 

c. Choose Calculation based on Calendar days (non-working days will be counted) or 
Work days (non-working days will be ignored). Work days are defined in the company 
calendar. 

3) Click OK. 

To create data add formula 

1) Choose Data Add and click Create. 

2) Choose a data element for Date and Add (click Select to open the data element picker). 
Data elements on the schedule sheet detail form and schedule sheet columns are available. 

 For Date, only date type (Timestamp) of data elements are displayed. 

 For Add, only numeric (integer, float) type of data elements or columns are displayed in 
the picker list. This includes Total and Average columns. 

3) Choose Calculation based on Calendar days (non-working days will be counted) or Work 
days (non-working days will be ignored). Work days are defined in the company calendar. 

4) Click OK. 

Working with Schedule Sheets 

Working with schedule sheets entails, for example: 

 Adding or managing rows and columns. 

 Tracking activity progress and costs. 

 Managing dependencies and constraints. 

In the open schedule sheet you can view activities and columns in the left pane and view the 
Gantt chart in the right pane. You can move the split screen bar to the left or right as needed. 
Scroll bars are available on the bottom of the sheet. 
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Refer to the Unifier Earned Value Management User Guide for more details about Activity 
Sheets and Schedule Sheets. 

To open a project or shell schedule sheet 

1) In User Mode, open the project or shell where the schedule sheet resides, and select 
Schedule Manager > Schedule Sheets in the left Navigator. The Schedule Sheets log 
opens. 

 The log lists all active schedule sheets. To view all active and inactive sheets, click the 
View menu and choose All. 

 The Refresh icon  indicates whether you must refresh a schedule sheet to display the 
latest data. The refresh icon is not displayed for schedule sheets that are Inactive, or are 
in a view-only project or shell. 

2) Double-click a schedule sheet in the log to open the sheet. 

If the sheet requires a refresh of the data, you will be asked if you want to refresh the sheet. 
Click OK to refresh the sheet, or No to close the sheet with out refreshing the data. 

3) Select the sheet in the log and click Open, or double-click the sheet. The schedule sheet 
opens. 

Schedule sheet toolbar 

You can perform the following functions from the toolbar. Click the down arrow next to a button 
to view further options. 

Button Action 

Save Saves changes made to the schedule sheet. 

Add 

Click the arrow next to the button and choose one of the 
options: 

Manual: Add a row (activity) manually. 

Copy Activity From: Add a row by copying a row in a selected 
sheet. 

Delete Select a row and click Delete to delete the activity. 

Indent 
Select a row and click to indent the row. The row above 
become a summary row. 

Outdent Select an indented row and click to out-dent. 

Gantt Return to the Gantt chart view. 

Progress 
Access the Activity Progress view. See Entering Progress in 
the Activity Progress Window (on page 650) for details on 
activity progress. 

Columns Add and manage columns on the sheet. 
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Find 
Click to search for an activity. You can search on any column 
on the sheet. 

Zoom In 
Click to zoom in the Gantt chart. The default view is week (by 
day), which is the maximum zoom-in view. 

Zoom Out 
Click to zoom out the Gantt chart. You can zoom out to month 
(by week) view and year (by month) view. 

Focus 
Select an activity and click to move the activity into focus. The 
Gantt chart view moves to the beginning date of the selected 
activity. 

Close Window Close the schedule sheet. 

Using a Gantt Chart 

The Gantt Chart is displayed in the right pane of the schedule sheet. The activities are shown as 
bars and align with activities in the left pane. The activity bar is drawn with the start date, finish 
date, and duration elements of the activity. The Gantt chart is shown in week/day zoom mode by 
default. 

The Gantt chart displays: 

 Activity bars, which illustrate start and finish dates and duration 

 Dependency links between dependent activities 

 Summary rows 

 Milestones 

 Critical paths 

The Gantt chart is interactive. You can: 

 Zoom in or out of the Gantt chart view to display detail or overview of scheduled 
activities. 

 Configure activity bar labels; for example, you can display percent complete to monitor 
the progress of activities, or names of resources assigned to activities, or virtually any 
activity property. See Gantt Chart tab of the Schedule Sheet Properties (on page 
562). 

 Increase and decrease activity schedule durations by dragging on bar ends. 

 Move activities from one time frame to another (modifying start and end dates). 

 Add or remove a predecessor (dependency). See Dependencies tab of the Activity 
properties (on page 574). 

 Resize Gantt window by dragging the vertical split bar. 

 Display critical paths. 
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The Gantt chart is refreshed automatically when any changes are made on the activities. 

Understanding the Gantt chart view 

Zoom in or out of the Gantt chart 

You can view the Gantt chart by week (per day), month (per week), or year (per month) by 
zooming in and out. This allows you to view the Gantt chart in detail or over an extended period 
of time. 

To zoom in or out of the Gantt chart 

1) Open the schedule sheet. 

2) Do one of the following: 

 Click the Zoom In button on the toolbar. The default view is weekly, with each day of the 
week displayed. This is the maximum detail level that you can zoom in to the schedule 
sheet. 

 Click the Zoom Out button. You can zoom out to view the Gantt chart by month with 
each week in the month displayed, or by year with each month displayed. 

View the critical path 

The critical path calculation can be used to flag activities on the schedule that, if delayed, can 
cause the schedule to go beyond the pre-planned project or shell end date. Therefore, it is 
important to have fixed project or shell start and end dates defined for the project or shell. 
Project or shell start and end dates should not automatically adjust as activities are added or 
rescheduled. 

To view the critical path 

1) Open the schedule sheet. 

2) Click the View menu and choose Critical Path. 

The activities that are on the critical path will change to red on the Gantt chart. The critical 
path action will also update the system-defined data element uuu_float to zero if it has been 
included on the activity attributes form (Activity Properties window). 
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3) To restore the Gantt chart view, click the View menu and choose Gantt Chart. 

View a tracking Gantt chart 

A tracking Gantt chart allows you to compare two sets of dates for a specific activity. It allows 
you to track activity progress against the original plan. For example, the tracking Gantt chart 
allows the comparison between two sets of dates such as baseline and actuals. Users with view 
permissions can view a tracking Gantt chart. See Set Schedule Sheet Baselines (on page 591) 
for details on setting baselines. 

The tracking Gantt chart is view only. It is not interactive like the regular Gantt chart. 

To view a tracking Gantt chart 

1) Select the schedule sheet in the log and choose View > Tracking Gantt. 

2) You can switch back to the regular Gantt chart by choosing View > Gantt. 

The tracking Gantt chart displays the data elements as a set of two bars (upper and lower) 
that allow you to make the comparison. 

Using a Tracking Gantt Chart 

You can use a Tracking Gantt chart to the compare data sets defined in the schedule sheet 
properties. The read-only Tracking Gantt chart displays comparison as a set of two bars (upper 
and lower). 

To view a tracking Gantt chart 

1) Select the schedule sheet in the log and choose View > Tracking Gantt. 

2) You can switch back to the regular Gantt chart by choosing View > Gantt. 

Find an activity 

You can search for a specific activity by the values of any column on the schedule sheet. 

To search for an activity 

1) Open the schedule sheet. 

2) Click the Find button on the toolbar. The Find window opens. 

3) Complete the window: 

 Column: Click the drop-down list and choose a column to search on. The default is 
activity name. 

 Value: Enter all or part of a value to search for. For example, to search for the word 
Construction, you can enter the entire word or any part of the word. 

 Search: Click the drop-down list and choose to search down or up from a selected row. If 
you do not select a row, the search will begin at the top row. 

4) Click Find Next. If an activity is found that matches the search criteria, the row will be 
highlighted. To keep searching, click Find Next again. 

5) When you are done searching, click Cancel to close the window. 
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About activity-level editing restrictions 

Your Administrator can set up cell editing restrictions in schedule sheets. These restrictions can 
allow certain work groups to edit specific dates in the sheet, and prevent other groups from 
editing these dates. If you are a member of a specific work group that has these restrictions set, 
you will find that you are able to edit only certain cells on the schedule sheet. 

The following image shows an example of the impact on dates in a schedule sheet with 
activity-level editing configured, and with activities and group-specific date columns. In this 
example, the groups Const, IT, and ATM all have group-specific start and finish dates for 
activities: 

As shown in the example, the date cells in the schedule sheet that are specific to a certain group 
can be edited only by that group. 

Restrict Access to Activity fields and columns 

You can restrict user access to selected fields and columns (those based system defined data 
elements on the General tab, which are on the Activity Attribute form and on the Resource tab, 
which are on the Resource Assignment Attribute form). 

Note: These restrictions also apply to schedule sheet columns when a 
restricted data element is used as a column. 

After a field or column is marked with restricted access for selected users or groups, those users 
or group members cannot modify those data elements (fields). For Start Data, Finish Date and 
Duration data elements, users that are restricted cannot modify this group data elements, even if 
they have restriction on any one of the data elements in the group. Also, the Gantt Chart will be 
disabled for a user if the Start, Finish, and Duration data elements are restricted for that user. 

If a data element cannot be modified by a user or group then data imported through CSV / XML 
for that data element is ignored. If there is any failure in validation (both user and system 
defined), Unifier will stop data import. 

To restrict access to specified system defined data elements 

1) Navigate to the schedule sheet log. 

2) Open a schedule sheet. 

3) Choose File > Restrictions. The Restrictions Setup window opens. 

4) Add the user or group name whose access you want to restrict. 
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5) Choose the data elements to restrict. The data elements listed for the Activity Attribute form 
and the Resource Assignment Attribute form are those that are system defined (the data 
element name starts with uuu_) and were added to the forms. You can select all of the listed 
data elements, or individual data elements. 

6) Click OK. 

Use filters in a schedule sheet 

You can use filters to locate certain activities in a schedule sheet. The filter is based on criteria 
that you specify. When you use a filter, it applies only to the schedule sheet you are working 
with, but the filters you create are visible to all other users. 

To add a filter for activities in a schedule sheet 

1) Select the records in the schedule sheet that you want to filter. 

2) Open the schedule sheet in the log and choose View > Filters. The Filters window opens. 

3) Click Add. 

4) In the Add Filter window, specify the filter criteria. Each filter can have multiple criteria based 
on the data elements in the activity attribute form. You can also use this window to edit or 
remove filters. The Add and Remove buttons are enabled only for users who have edit 
permissions on the schedule sheet. 

5) Selecting the Display Summary Activities checkbox controls whether the filtered schedule 
sheet displays summary activities corresponding to any leaf activities displayed in the sheet. 
The filter is not applied to the summary activities. 

6) Click Apply to save and immediately apply the filter to the schedule sheet. 

7) Click OK to save the filter for later use. 

To apply a filter to schedule sheet activities 

1) Open the schedule sheet in the log and choose View > Filters. The Filters window opens. 

2) Select the activities you want to filter. 

3) Select a filter name and click Apply Filter. The schedule sheet refreshes with the filter 
applied. 

To clear a filter from a schedule sheet 

1) To return the schedule sheet to the original view, select the schedule sheet in the log. 

2) Choose View > Clear Filters. 

Update rates and cost data 

When a resource is assigned, the average booking rate is used to calculate assignment costs. 

Average Booking Rate = Total Booking Cost / Total Hours for the entire booking row 
selected while assigning the resource. 

Labor Cost (for a resource assignment) = Total Assigned Hours x Average Booking Rate. 

After assignment, the booking rate may change as changes occur to the booking sheet. These 
rate changes will not automatically affect the assignment (labor) costs stored in the schedule 
sheet. 
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You can update resource rates on the master schedule sheet and also update the project or 
shell cost sheet with corresponding assignment costs. The active currency exchange rate at the 
time of assignment will be used. 

The update has two options: 

 Resource Utilization: This updates resource rates only. 

 Resource Utilization and Cost Manager: This updates resource rates on the schedule 
sheet and posts costs to the cost manager. This option is only enabled on the master 
schedule sheet. 

To update rates on the schedule sheet 

1) Open the master schedule sheet. 

2) Choose Edit > Update > Resource Utilization. Labor costs on the entire schedule sheet 
are recalculated based on the latest average booking costs and exchange rate. 

To update costs on the cost sheet 

1) Open the schedule sheet. 

2) Choose Edit > Update > Resource Utilization and Cost Manager. Labor costs are 
updated and posted to the cost sheet (column with labor cost data source) based on the 
CBS codes and split percentage specified on each activity. The existing cost in the cost 
sheet columns will be replaced by new values. Similarly, any values in the Fixed Cost, 
Non-Labor Cost, and Total Cost columns in the schedule sheet will be posted to 
corresponding data sources on the cost sheet. 

Constrain Schedule Sheet Activities 

You are able to constrain activities on a schedule sheet. A constraint ties a successor activity 
start date to a predecessor activity completion date, after observing dependencies and lags. 
Available constraints in Unifier are As soon as possible (ASAP) and None. 

To constrain a schedule sheet activity 

Before you can constrain an activity, the activity's dependencies must be set. 

1) Navigate to the schedule sheet where you want to constrain activities and open the sheet. 

2) Double-click the activity you want to constrain. The Activity form window opens. 

Note: If the schedule sheet displays the Activity Constraint column, you 
can assign the constraint without opening the Activity form window. 

3) For each activity you want to constrain, select the activity constraint you want, either As 
soon as possible or None. 

As soon as possible: If the start date of a predecessor activity changes, either pulls in or 
pushes out, the start date of an ASAP-constrained successor activity changes accordingly. If 
an ASAP-constrained activity does not have a predecessor, the schedule sheet start date 
determines the activity start date; unstarted ASAP-constrained successor activities align 
accordingly. 



Working with Unifier Managers

587

None: The start date of a None-constrained activity does not change if the start date of a 
predecessor activity changes. The schedule sheet start date does not determine the start 
date of None-constrained activities that do not have predecessor activities. The only in-built 
rule is that the start date of the None-constrained activity should not be earlier than the 
schedule sheet start date. 

Integration: When activities are created through CSV, MPP, MPP XML, or P6, the default 
value will be None. Upon modification of the activity constraint type, Unifier scheduler will 
readjust the schedule sheet accordingly. 

4) Click OK to close the Activity form window and save the schedule sheet. 

Add general comments (with or without file attachments) 

You can add general comments to a schedule sheet, and can include file attachments with the 
comments. This is similar to adding general comments to a business process. 

To add a general comment to a schedule sheet 

1) Select the schedule sheet in the log and click the Comments button. The General 
Comments window opens. 

2) Add your text comments in the Text Comments box in the upper portion of the window. You 
can view any previous comments in the Existing Comments section of the window. 

3) To attach a file to the general comment, click the Attach button. 
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Note: Once you add a general comment to a schedule sheet, you cannot 
edit or delete it. 

4) Click OK to save the general comment. 

Refreshing Schedule Sheet data 

A schedule sheet refresh is required if there are changes to project costs, activity costs, for 
example role rates and amounts, currency rates, and schedule sheet or activity calendars. When 
the schedule sheet requires a refresh, you will see a refresh icon in the log. When you open a 
schedule sheet that requires a refresh, you will be asked if you want to refresh the data in the 
sheet. If you decline the refresh the schedule sheet will not open. 

Schedule sheet refresh options are set on the Refresh tab of the schedule sheet properties. 
Options include: 

 Cost: Refresh the cost data only from the associated CBS code 

 Schedule: Refresh the schedule data only, based on dates 

 Cost and Schedule: Refresh both the cost and schedule data 

 Set Frequency: Define the schedule sheet refresh frequency. This scheduled refresh 
updates both cost and schedule data. 
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 History: View the schedule sheet refresh history 

Schedule sheet refresh can fail if: 

 An activity has more than one CBS code 

 A cost sheet column to which a schedule sheet column is associated is deleted from the cost 
sheet 

To set the frequency of schedule sheet refresh 

The schedule sheet refresh frequency you set is shown in the schedule sheet log under the 
column heading Scheduled. 

1) Navigate to the schedule sheet log. 

2) Select one or more schedule sheets. 

3) Choose Refresh > Set Frequency. 

4) Select the Enable scheduled refresh checkbox. 

5) Select the Frequency and the Range of Recurrence. 

6) Click OK. 

To view schedule sheet refresh history 

1) Navigate to the schedule sheet log. 
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2) Choose Refresh > History. 

3) Select a record and click Open to view history details. 

4) Click Cancel Request to cancel any history query that has not started (has no Start Date). 

5) Click Close Window. 

Print a Schedule Sheet 

You can print schedule sheet columns and Gantt charts from the PDF of the schedule sheet. 

To print a schedule sheet 

1) Navigate to your project or shell and open the schedule sheet you want to print. 

2) Click File > Print to open the print option window. 

3) Select the print options you want. 

 All columns - Check to print all columns of the schedule sheet (default.) 

 Gantt Chart - Prints the current view of the Gantt chart (Gantt, Critical and Tracking.) This 
is checked by default. 

4) Click the Print to PDF button. 

Your browser may require you to confirm opening the PDF or saving the PDF. If saving the 
PDF, click Save. Browse to where you saved the file and open the PDF. If you click Open, an 
Adobe PDF opens with the schedule sheet. 

5) From within Adobe PDF file, click File > Print. The Adobe Print window displays. 

6) For multiple pages of a schedule sheet, select Tile All Pages from the Page Scaling
drop-down. 
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Note: This option is not available on older Adobe Reader versions. It is 
recommended that you upgrade to the latest Adobe Reader (free). If you 
have Adobe Acrobat or Adobe Professional, the Tile All Pages option will 
print multiple pages of the schedule sheet. 

7) Click OK. To cancel the print, click Cancel. 

Schedule Manager audit log 

Each change in the Schedule Manager creates a record in Unifier, which is useful for auditing 
purposes. An audit report of these records shows detailed information on dates, events, actions, 
and old values versus new values, along with the user or proxy user who performed the action. 

To view schedule sheet details in the audit log 

1) Navigate to the Schedule Sheets log in the Schedule Manager node. 

2) In the View menu, click Audit Log. 

You can review audit log entries for Date, Event, Action, Field, Old Value, New Value, User 
Name, Proxy User, and Attachments. 

To view cell details in the audit log 

1) Navigate to the Schedule Sheets log in the Schedule Manager node and open a schedule 
sheet. 

2) Under the File menu, click Audit Log. 

You can review audit log entries for Date, Event, Action, Field, Old Value, New Value, User 
Name, Proxy User, and Attachments. 

Set Schedule Sheet Baselines 

A baseline is a set of original project or shell estimates. It consists of the following for a task: 

 Start 

 Finish 

 Duration 

Comparing multiple baselines provides insight into project health. With the original estimates, 
you can track the progress of a project or shell and compare its state at any given time. Unifier 
leverages the CBS code association between schedule sheets and earned value (EV) sheets to 
construct baseline comparison. The best way to do this is to: 

 Copy the schedule sheet to establish a new baseline 

 Create a corresponding detail-level EV sheet for the new schedule sheet 

 Create a summary EV sheet to compare selected baseline information 

For more information, see Creating an EV Sheet (on page 331). 

You can save up to 11 sets of baselines in a single project or shell schedule sheet. You can use 
these various baselines as snapshots of your project or shell progress over time, with each 
baseline corresponding to key project or shell events. 
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The first baseline that you save is named Baseline. Subsequent baselines are named Baseline 1 
through Baseline 10. The baseline sets are system-defined data elements that your 
administrator has included on the activity attribute form. When you set up the baselines, the 
values from the start, finish, and duration elements are mapped to the baseline set. 

Note: The baseline columns are not required, but you must use all three 
of them, if you use them at all. You must use the complete baseline set 
of columns (start, finish, and duration) in your sheet. You cannot use one 
baseline column alone. 

All baseline attributes are read only in the schedule sheet. They can be modified only via the 
set/clear schedule sheet baseline actions. Users with the Edit Data and Structure permission on 
the schedule sheet can set or clear baselines. 

Note: The Edit data permission allows you to import data. 

All baseline attributes are read-only on the schedule sheet. They can be modified only via the 
set/clear schedule sheet baseline actions. Users with the Edit Data and Structure permission on 
the schedule sheet can set or clear baselines.. 

You can also set baselines on projects or shells listed on an Activity Sheet. See Set up Activity 
Sheet Baselines (on page 608) for details. 

To set a baseline on a schedule sheet 

1) Open the schedule sheet in the log. If you modify the schedule sheet, you must save the 
sheet before you can set baselines. 

2) Choose Edit > Baseline. The Set Baseline window opens. 

3) Select the baseline to set. The Set baseline radio button is selected by default. Only 
baselines that have been designed in uDesigner are available. 

4) Click OK. The values from the start, finish, and duration elements are copied into the 
corresponding baseline elements. If the baseline elements contain data, you will receive a 
warning that the baseline will be overwritten You can choose whether to override the data. 

To clear a baseline on a schedule sheet 

1) Open the schedule sheet in the log. 

2) Choose Edit > Baseline. The Set Baseline window opens. 

3) Select the baseline you want to clear. 

4) Select the Clear baseline radio button. 

5) Click OK. 

Lock or unlock the schedule sheet structure 

You can lock a schedule sheet. This locks the columns and activity rows, preventing editing of 
the sheet structure. 

To lock or unlock a schedule sheet 

1) Open the schedule sheet. 
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2) Click the File menu and choose Lock Structure or Unlock Structure. 

Linked schedule sheets 

Linked schedule sheets are project or shell schedule sheets that are dynamically linked to a 
schedule sheet template. You must work with your Administrator to enable and setup the 
schedule sheet linking. 

Linking is optional; it is useful if you have numerous project or shell schedule sheets to update 
simultaneously with the exact same information and structure. 

Linked schedule sheets can be updated manually, but you can only make limited changes to 
dates and data. 

You can change: 

 Start and Finish dates 

 Durations 

 Schedule sheet properties; however a linked template push cannot change sheet properties 

You cannot: 

 Add Activities 

 Delete Activities 

 Indent/Outdent Activities 

 Import CSV, MPP 

 Import with Overwrite or Merge (XML, WS) 

 Modify Activity Name, Activity Codes 

 Modify Scope Management Setup 

 Cannot add /modify/delete columns 

 Re-arrange (cut/paste) activities 

The overall structure of the sheet (adding or deleting activities, for example) is updated only 
through the associated linked template. The Administrator must unlink the linked schedule 
sheets for you to be able to modify the structure of the sheet. 

Note: Updating schedule sheets through linked schedule sheet 
templates can overlay the structure of schedule sheets and the data 
elements listed below. Be sure that you want the linked sheets to be 
updated to this extent by the template. 

A linked schedule sheet template update to a linked schedule sheet can push: 

 Changes to Activity Name 

 Changes to Activity Codes 

 Changes Activity Id (caused by re-ordering of activities) 

 Addition of new activities or deletion of activities 

 New or changed predecessor relationships 

 Addition, deletion, or modification of column definitions 

 Ordering of activities in sheet 

 Changes to the indentation of activities 
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Note: Changes to dependent activity Start Date or Finish Date caused 
by changes such as modifications to predecessors or the addition or 
deletion of activities are handled dynamically by the schedule sheet 

To view the linked template for a linked schedule sheet 

1) Navigate to the schedule sheet log. 

2) Select a schedule sheet that is linked to a schedule sheet template. 

3) Choose View > Linked Template. The Linked Template window opens. 

Linked Template window 

4) Click Close Window when you are done viewing the linked templates. 

To link existing schedule sheets to a link-enabled template 

You can link an existing schedule sheet to a link-enabled template. Linking an existing schedule 
sheet causes loss of existing data on the project or shell schedule sheet, including all activities, 
columns and cell data. Project or shell schedule sheet properties, including the Schedule Start 
Date are retained. 

1) Navigate to the schedule sheet log. 

2) Select a schedule sheet that you want to link to a schedule sheet template. 
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3) Choose View > Linked Template. The Linked Template window opens. 

4) Click Add. The Schedule Sheet Templates window opens. 

5) Select a template and click Select. 

6) Click OK on the confirmation message that data in the newly-linked sheet will be modified 
when the update is completed using the link between the template and the sheet. 

7) Click OK. 

To unlink schedule sheets from a link-enabled template 

Unlinking removes the link between the schedule sheet and the template so no further updates 
can occur from the template. 

1) Navigate to the schedule sheet log. 

2) Select a schedule sheet that is linked to a schedule sheet template. 

3) Choose View > Linked Template. The Linked Template window opens. 

4) Click Remove. 

5) Select the template. 

6) Click OK. 

Linked tags and Business Process fields 

Tags work with linked elements to connect schedule sheet activities with business processes, 
shells, and configurable manager objects. With this feature, you can view key activity dates, 
such as milestones, on forms like project details, without having to open the schedule sheet. 

To select a link tag to populate a business process field 

1) Add a "Tag" column to the schedule sheet. 

2) On the schedule sheet, select the row containing the activity you want to link. 

3) Click in the Tag column. The cell becomes editable. 

4) Click the arrow and select the tag you want to assign to this activity. 
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5) When you assign this tag to the activity, any form associated with this schedule that contains 
a linked element with a matching tag will now show the current value of that activity. 

Search for schedule sheets 

To search for a schedule sheet in the log: 

1) In User Mode, select the project or shell, and select Schedule Manager > Schedule 
Sheets. The Schedule Sheets log opens. 

2) Click the Find button. The Find box opens at the top of the log. 

3) Click the Search By drop-down list and enter the field to search by. 

4) Enter search criteria in the Search for field. 

5) Click Search. 

Program Schedule Sheets 

Program-level schedule sheets are created automatically when a project or shell schedule sheet 
(for a project or shell within the program) is created. The rows are the project or shell sheets. 
You can configure columns. There is one schedule sheet per program. 

To open a program schedule sheet 

In User Mode, select Programs > Schedule Manager > Schedule Sheets. The Schedule 
Sheet log opens. 

Rows correspond to project schedule sheets. You can click the row to open the project schedule 
sheet. Default columns are Project Name, Start Date, and Finish Date. You can create additional 
columns in the same way that you do for a project/shell schedule sheet. 
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Add a program schedule sheet column 

To create a column on a program schedule sheet 

1) Open the program schedule sheet. 

2) Click the Columns button. The Columns Log window opens. 

3) Click New. The Column Properties window opens. 

4) Complete the window as described in the following table. 

5) Click OK. 

In this field: Do this: 

Name This field is populated with the chosen Data Source 

Data Source 

Select a Data Source from the drop-down list. The options are 
from project schedule sheets. The drop-down will only show data 
elements of type Date and SYS Date Logical Data Source (from 
activity detail form). 

Rollup from Project
Configure rollup parameters from project schedule sheets. Select
Enable rollup from project schedule to rollup project data. 

When you select Enable rollup from project schedule, the data 
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comes from the top-level summary row for the schedule sheet. If 
you do not have a top-level summary row, do not select Enable 
rollup from project schedule. Instead, select from these options:

 Date rollup: Choose to roll up the Earliest Date or the Latest 
Date across all projects for Date type data. 

 Number rollup: Choose roll up Total or Average values for 
Numeric type data, or Weighted Average based on and select 
a data element from the Activity Attributes form. 

Entry Method 

Choose one (the options that are available are dependent on the 
data source chosen): 

 Manual Entry: Users enter values directly on the schedule 
sheet 

 Formula: Value is calculated using the entered formula. 
Formulas can include calculating differences between date 
columns, or adding/subtracting numeric columns/values from 
dates. This is useful to calculate durations or to calculate one 
date from another date by adding/subtracting days. 

Data Format 

This controls how data is displayed on the schedule sheet. 
Options are: 

 Show as percentage. Data is displayed as % 

 Decimal places. Choose 1 to 8. If the data element was 
defined in uDesigner with a specific number of decimal 
amount, it will override any decimal places you specify here. 

 Use 1000 Separator. Select checkbox to include a comma (,) 
separator 

 Negative Number Format. Choose parentheses or minus 
sign 

Summary 

This controls the display of numeric and date column data on 
summary rows. 

 Display: Select the checkbox to display summary data for the 
column 

 Date Rollup: Available only for Date data types. Select 
Earliest Date or Latest Date. 

 Earliest Date: To summarize columns that represent activity 
start dates (e.g. start, planned start, actual start, etc.). The cell 
on the summary activity will show the earliest date from all 
child activities. 

 Latest Date. To summarize columns that represent activity 
finish dates (e.g. finish, planned finish, actual finish, etc.). The 
cell on the summary activity will show the latest date from all 
child activities. 

 Number Rollup: Available for numeric columns. Choose Total 
(displays sum total of the rows) or Average (displays average 
value of the rows). For example, you might Total for currency 
or other numeric types; for percentage columns, you might 
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want to choose Average. 

Display Mode 
Choose to Show or Hide the column from user view. Users with 
Create permissions can see hidden column in the Columns Log. 

Column Position 
After 

The new column will be inserted after the column selected. 

Activity Sheets 

Activity sheets exist in the Schedule Manager at the Program level. An activity sheet allows you 
to view, edit, and update activity dates across project and shells. The activity data is from the 
Master Schedule Sheets only. 

For example, uParks Company has 1000 projects that fall within four categories. Four programs 
are created to manage the Schedule Sheet activities. Each program has its own Program 
Manager, controlling 250 projects. uParks has a finite number of resources and needs to stagger 
the work so resources can be used evenly over time. The Program Managers want to adjust 
their project forecast dates so that 20 projects will complete each month for the next 12 months 
(with 30 completing in month 12, so that all 250 are completed in a year). Using activity sheets, 
you can manage your project and shell data in this way. 

Activity sheet terminology 

 Activity Sheets: Used to view and update the Master Schedule Sheet data from projects 
and shells within Programs. 

 Activity Code: A value in a Program activity sheet used to map to an activity in one or more 
projects or shells. 

 Sub-columns: 

 Columns grouped under an Activity Code 

 Displays data from projects/shells 

 Updates data in a project/shell 

The activity sheet allows you to: 

 Display and edit Master Schedule Sheets activity data across projects and shells as columns 
and sub-columns 

 Modify editable elements 

 Affects down stream dates of linked activities 

 Start, Finish, Duration 

 Estimated Start, Finish, Duration 

 Critical path dates 

Project or shell names form the rows of the activity sheet; the activity codes and activity data 
elements form the columns and sub-columns in the sheet. The activity sheet also allows you to 
update multiple activities after modifying and saving the activity sheet. This update automatically 
updates the downstream dates of linked activities, such as Start Date, Finish Date, Duration, 
Estimated Start Date, Estimated Finish Date, or other dates. 
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Note: In Cash Flow, Cost Sheet, and Earned Value, you can replace the 
Summary Sheet with the Activity Sheet as a source. 

Create an Activity Sheet 

The permissions for creating an Activity Sheet are the same as those for creating a Schedule 
Sheet. You can create a new sheet or use a template. 

To create an activity sheet 

1) Navigate to Projects tab > Programs > Schedule Manager > Activity Sheets. The Activity 
Sheets log opens. 

2) Click New. Select an Activity Sheet template. 

Activity Sheet templates window, example 

The Activities Sheet properties window opens. 
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3) Complete the General tab as needed, as described in the table below. 

Activity Sheet properties window, General tab

4) Complete the Activity Codes tab (as needed, or use the codes set up in the template) by 
clicking Add to add rows and select activity codes. The Activity Codes make up the columns 
in the Activity Sheet. 

Select the activity codes that make up the columns of the activity sheet. Confer with your 
uDesigner user and Company Administrator to ensure that you can create activity sheets that 
contain the correct activity codes to form the sheet columns. 

Activity names on the Master Schedule Sheet map to the Activity Codes that you add to the 
activity sheet. There is a one-to-one correspondence between activities and Activity Codes. 

If you add the activity picker in a business process, then Unifier automatically populates the 
CBS cost code after you select the activity from the activity picker.  
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Note: Only elements that are marked as editable can be modified. 

5) Click the Move Up (Left) or Move Down (Right) buttons to change the sorting order of the 
activity codes. 

Activity Sheet properties window, Activity Codes tab example

6) Click Add to add click Apply to save your changes. 

7) Complete the Data Elements tab by clicking Add to add rows and select activity attributes. 
The Data Elements make up the sub-columns in the Activity Sheet. The sub-columns are 
repeated under the columns. Modify these data elements as needed, or use those defined in 
the template. 

8) Use the Editable checkbox to designate which data elements will be editable in the Activity 
Sheet. Only one of Start Date, Finish Date, or Duration elements can be made Editable (the 
other two elements of the group, if added, are not selectable). 

These elements are always read-only, and cannot be marked as editable: 

 Actual Start/Finish/Duration 

 Auto-update Activity checkbox 

 Milestone checkbox 

 Activity Code 

 Activity Status 

 Baseline elements 
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9) Select the Allow negative lag to accommodate specified Start/Finish Dates checkbox to 
specify that the activity update process adjusts lag automatically to accommodate 
user-specified values (for Start Date, Finish Date, and Duration only). The default is 
unchecked. 

10) Click the Move Up (Left) or Move Down (Right) buttons to change the sorting order of the 
data elements. 

Activity Sheet properties window, Data Elements tab example 
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11) Click OK. The new Activity Sheet is available in the log. 

Example Activity Sheet 

The rows in the sheet list the projects and shells related to the selected activity codes. The 
headings for the columns in the sheet are the selected activity codes; the sub-columns are 
the represented as the data elements for the activity codes. 

The Number column lists the project or shell number; the Name column lists the project or 
shell name. The Location column lists the location of each shell, and is blank for projects. 

Cell values are obtained from the project or shell Master Schedule Sheet from activities that 
the match Activity Code. 

NA displays in a cell if: 

 The Activity Code is not found 

 You do not have permissions to view or update a Master Schedule Sheet 

 A project or shell does not have a Master Schedule Sheet 

In this field Do this 

Title 
Enter a title for the sheet. This is used as the sheet 
identifier and must be unique. (up to 120 characters) 

Description Enter an optional description. (up to 400 characters) 

Status When you are ready to make the sheet active and 
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available for use, click Active. The default is Active. 

Update Multiple Activities 

You can use the Activity Sheet to update multiple activities at once. 

 Changes to activity Start and Finish dates made via program activity sheets prompt role 
amount recalculation on the affected schedule sheets. 

 All changes are captured in the Audit log. 

To update multiple activities 

1) In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity 
Sheets. The Activity Sheet log opens. 

2) Select the Activity Sheet and click Open. 

3) Modify the data as needed. Cells that are modified are highlighted on the sheet. Only 
elements that were marked as editable can be modified. To undo changes in a row, select 
the row and click Refresh. 

4) Click the Save button. The Activity Update Status window opens. 

Activity Update Status window 

You cannot modify the Activity Sheet while the status window is active. The status window 
scrolls to display In Process projects. 

These are some possible activity update errors: 

 Date (either manually entered or automatically calculated) conflicts with a dependency 

 Date entered is before the scheduled Start Date 
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5) Click on the OK button to return to the Activity Sheet. 

There are icons in the first column. The check mark icon displays for successfully processed 
project rows. 

Successful update of an Activity Sheet 

The X mark icon displays for rows that could not complete the processing due to errors. The 
X mark icons are hyperlinks. Click the icon to open a dialog box that describes the error 
encountered by the update process for that specific project row in the update. 

Error on update of Activity Sheet 

You can modify data elements other than the system defined Start Date, Finish, Date or 
Duration directly to matching activities without affecting other activities. 

If there are Finish-Start dependencies: 

 If you modify the Start Date on any activity, the system will compute the Finish Date of 
current activity, keeping the Duration Constant 

 If you modify the Start Date on any activity, the Start Date of the successor (downstream) 
activity is updated 

 If you modify the Finish Date on any activity, the system will compute the Start Date, 
keeping Duration constant 

 If you modify the Finish Date on any activity, the system will modify the Start Date of 
successor (downstream) activity 

 If you modify the Duration on any activity, the system will compute a new Finish Date, 
keeping the Start Date constant 

 If you modify the Duration on any activity, the system modifies the Start Date of 
successor (downstream) activities 

Changes to activities that occur through Activity Sheet update are shown on the Audit Log. 

Undo Activity row changes 

Refresh allows you to undo changes to cells in selected rows, so you can save the Activity Sheet 
without updating those cells. 
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To refresh Activity Sheet rows 

1) In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity 
Sheets. The Activity Sheet log opens. 

2) Select the Activity Sheet and click Open. 

3) Select one or more rows in the sheet. 

4) Click the Refresh button. Highlighting is removed from the selected rows. Those rows are 
not modified when you click Save to update the Activity Sheet. 

Update Activity Sheet Properties 

To update Activity Sheet properties: 

1) In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity 
Sheets. The Activity Sheet log opens. 

2) Select the Activity Sheet and click Open. 

3) Click the Properties button. 

4) Update the properties as needed and click OK. 

Export Activity Sheets 

You can export the entire Activity Sheet to a CSV file. 

To export an Activity Sheet 

1) In User Mode, navigate to Projects tab > Programs > Schedule Manager > Activity 
Sheets. The Activity Sheet log opens. 

2) Select the Activity Sheet and click Open. 

3) Choose Edit > Export to CSV. 
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Set up Activity Sheet Baselines 

You can set baselines on Activity Sheets at the program level. On Activity Sheets, baselines can 
be set for multiple projects or shells, and so affect all activities on the selected project or shell 
schedule sheets. The baselines you set on the Activity Sheet will affect all of the activities on the 
selected projects or shells, regardless of which activities are displayed on the Activity Sheet. 
Setting baselines at the Activity Sheet level can be useful if you are managing several projects 
or shells as a program. This functionality enables you to have insight into the activities for all of 
the selected projects or shells, and be able, for example, to discover quickly whether there has 
been any delay in any of the project or shell activities. 

Users with the Edit Data and Structure permission on the project or shell schedule sheet can set 
or clear baselines for the activities from those projects or shells on the activity sheet. 

See Set Schedule Sheet Baselines (on page 591) for further details on baselines. 

To set a baseline on an Activity Sheet 

1) Open the Activity Sheet in the log. If you have modified the Activity Sheet, you must save it 
before you can set baselines. 

2) Choose Edit > Baseline. You can select this action only if you have saved changes to the 
Activity Sheet. 

3) Select Baseline > All to apply the baseline to all of the projects and shells listing in the 
Activity Sheet. Select Baseline > Selected to select one or more project or shell rows. The 
Set Baseline window opens. 

4) Select the baseline to set. The Set baseline radio button is selected by default. Only 
baselines that have been designed in uDesigner are available. 

5) Click OK. The values from the start, finish, and duration elements are copied into the 
corresponding baseline elements. If the baseline elements contain data, you will receive a 
warning that the baseline will be overwritten. You can choose whether to override the data. 
The Confirmation window opens. 

6) Click Yes to confirm the baseline settings. The Processing Status window opens. After the 
system processes the baselines, you will see a check mark next to the rows in the Activity 
Sheet that indicate the baseline was set successfully. If the baseline was not set, failed rows 
in the sheet are marked with an X. 

To clear a baseline on an Activity Sheet 

1) Open the schedule sheet in the log. 
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2) Choose Edit > Baseline. The Set Baseline window opens. 

3) Select the baseline you want to clear. 

4) Select the Clear baseline radio button. 

5) Click OK. The Confirmation window opens. Click Yes to confirm the cleared baselines. The 
Processing Status window opens. After the system processes the baselines, you will see a 
check mark next to the rows in the Activity Sheet that indicate the baseline was cleared 
successfully. If the baseline was not cleared, failed rows in the sheet are marked with an X. 

Activity Sheet (Integrated with an External Application) 

Note: Integration with P6 application applies to Unifier CBS type Shell 
only. The integration does not apply to the Unifier Project (Standard). 

For details about the Activity Sheet, see Unifier Activity Manager and Master Rate Sheet.  

Additional information about an Activity Sheet integrated with an external application 

 It is required that an Activity Sheet to have the following fields as fixed columns: 

 Activity ID

 Activity Name

Note: You cannot remove the two required fields from an Activity Sheet. 

 When an Activity Sheet attribute form is deployed to Unifier for the first time, all fields present 
in the Activity Sheet attribute form are saved and displayed as columns in the Activity Sheet 
following the same order. 

 If you remove a field from an Activity Sheet attribute form and the Activity Sheet attribute 
form is deployed to Unifier, then the deployment does not go through if the field that you had 
removed from the Activity Sheet attribute form is present as a column in the Activity Sheet in 
Unifier; otherwise, the deployment goes through if the field that you had removed from the 
Activity Sheet attribute form is not present as a column in the Activity Sheet. 

 If you add a new field to an existing Activity Sheet attribute form and the Activity Sheet 
attribute form is deployed to Unifier, then the columns in the Activity Sheet do not reflect this 
change and you need to add the field to the columns in the Activity Sheet manually. 

 You can add columns to or remove columns from an Activity Sheet view. 

 You can arrange the columns order in an Activity Sheet. 

 You can find, sort, group, and filter Activity Sheets. 

 The data within and Activity Sheet is synchronized with P6 by way of Gateway 
(Import/Export Synchronization) daily. 

Note: Exchange of data with inactive Unifier CBS type Shells is not 
permitted whether initiated manually or by Gateway.  

You can map the P6 CBS Code to the Unifier CBS Code (bitemID) in Gateway (in the field 
mappings).   
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When the Activity Sheet data is synchronized between P6 and Unifier, then Unifier Provider 
converts the P6 CBS Code to the corresponding Unifier CBS Code (bitemID), and the Activity 
Sheet, in Unifier, is populated automatically. 

When the data is synchronized between Unifier and P6, then Unifier Provider converts the 
Unifier CBS Code (bitemID) to the corresponding P6 CBS Code, and the Activity Sheet, in P6, 
is populated automatically. 

The CBS auto-population works differently in Base commit, Change commit, and Payments with 
respect to other classifications that are under Cost type business processes.  

The auto-population for the CBS Code occurs in Base Commit business processes and Change 
Commit business processes. 

In Payments business processes, the CBS Code matches with the Commit line item of SOV, 
then the CBS Code is auto-populated; otherwise, the CBS Code does not auto-populate. 

 If there is only one Commit line item matching the CBS Code/Cost Code, then the CBS Code 
will be auto-populated along with the Commit line item from the SOV, if the CBS Code/Cost 
Code matches with what is present in the SOV. 

 If there is more than one Committed line item (where the CBS Code matches with the 
Activity picker), then the value for the CBS code remains as it was. 

 If the Activity picker is associated with a CBS Code that is not used by any of the Committed 
line items in the SOV, then the value for the CBS code remains as it was. 

You can change the CBS Code by clicking the CBS Picker, which will over-write the 
auto-populated value. 

Gateway and Unifier Provider 

The Activity Sheet object in Unifier must be available for integration through Gateway. 

Note: The Activity Sheet object, in its entirety, must be available as a 
fields in both Gateway and Unifier. 

To synchronize data between a P6 Activity object and a Unifier Activity Sheet object, data 
mapping must take place. The following sections explain data mapping in detail. 

Data Mapping Templates 

About Data Mapping templates 

When a project in Unifier is linked to a project in P6, each project retain their respective name, 
with no changes applied to the names. 

Establishing a link between a project in Unifier and a project in P6 is based on a specific Data 
Element (DE) in Unifier (uuu_int_p6_Project_id) corresponding to a specific P6 element (Project 
ID). 

The following lists the out-of-the-box (OOTB) Data Mapping templates available for use and 
provides a description for each template. 

Create Activity Sheet from P6
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Use this template to map all the fields in the Activity Sheet to the P6 Activity object that is 
needed from P6. You can use this template to create a new Activity Sheet in Unifier projects. 

There are 26 pre-defined elements that are included in the Activity Sheet Attribute form. By 
default, this template contains the first 24 pre-defined elements that are included in the Activity 
Sheet Attribute form, and the fields are mapped to the corresponding P6 Activity object.  

The following elements are excluded from this template: 

 Primary Constraint 

 Secondary Constraint 

You can deploy custom activity attributes to Gateway and then add those attributes to this 
template. 

Update Activity Sheet from P6

Use this template to update an existing Activity Sheet in a Unifier project based on P6 data. 

There are 26 pre-defined elements that are included in the Activity Sheet Attribute form. By 
default, this template contains 22 pre-defined elements that are included in the Activity Sheet 
Attribute form, which cannot be populated by Reverse Auto-Population. As a result, the template 
does not contain the following elements: 

 Actual Start 

 Actual Finish 

 Primary Constraint 

 Secondary Constraint 

You can deploy custom activity attributes to Gateway and then add those attributes to this 
template. 

Send Activity data to P6

Use this template to map those fields in the Activity Sheet Attribute form, to P6 Activity object, 
that might get updated in Unifier by way of a Business Process record. These fields need to be 
updated from Unifier to P6 through Gateway. 

There are 26 pre-defined elements that are included in the Activity Sheet Attribute form. By 
default, this template contains the 2 fields that can be populated by Reverse Auto-Population. As 
a result, the template contain the following two elements, only: 

 Actual Start 

 Actual Finish 

You can deploy custom activity attributes to Gateway and then add those attributes to this 
template. 
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Note: The fields in this template must be maintained exclusive of the 
fields in the "Update Activity Sheet from P6" template. There are no 
common fields between the "Send Activity Data to P6" template and the 
"Update Activity Sheet from P6" template. If you add the common fields 
to the two templates, inaccurate information can be generated in either 
application (Unifier or P6). 

Editing Data Mapping templates 

You can edit (take out a field or add a new field) any of the Data Mapping templates mentioned 
in this section by going to Gateway > Configuration > Customization. 

1) From the Customization window, select the "Activity" business object from the "Select 
Business Object’' drop-down list to see all Data Mappings, based on the "Activity" object. 

2) Select any Data Mapping template. 

3) Click Edit and go to the Mappings tab. 

4) Add a new field, to exchange data for example. 

You can add any custom field to an Activity Sheet Attribute form in uDesigner and Deploy the 
Activity Sheet Attribute form to Gateway. All the fields from the Activity Sheet Attribute form 
appear in Unifier (P6 Activity Sheet drop-down list). As a result, you can select any Activity 
Sheet Attribute form that you have defined in Unifier and map the Activity Sheet Attribute form to 
a corresponding activity field (fixed field or user-defined field) in P6; however, ensure that you 
map the Unifier element to the Activity Sheet Attribute form in a way that the "Data Types" of the 
P6 Activity elements match the Data Definitions (DEs) of the Unifier Activity Sheet Attribute form. 
The following shows the mapping of data between the P6 Data Types and the corresponding 
Unifier DEs. 

P6 Data Type Corresponding Unifier Data Definition 

Text (40 chars) SYS Short Description Text 50 

Text (120 chars) SYS Short Description Text 120 

Text (UDF* Fields) SYS Short Description Text 255 

Date Date Picker 

Cost Currency Amount 

Number Decimal Amount 

Integer Integer Amount 

Indicator SYS P6 Indicator 

Note: In the Edit window of the Data Mapping template, 
Gateway does not display "Indicator," as an available 
field type. As a reasult, you need to map an "Indicator" 
type field from Unifier to P6 UDF and set the "Data Type" 
as "String." 

Activity Status Pulldown SYS Short Description Text 50 
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P6 Data Type Corresponding Unifier Data Definition 

Activity Type Pulldown SYS Short Description Text 50 

*UDF: User-defined Field 

Additional information about editing Data Mapping templates 

In P6 some activity attributes fields, cannot be updated manually, or by way of any other 
methods. These fields must be calculated using the P6 internal logic. If you modify the "Send 
Activity Data to P6" Data Mapping template to map to a P6 activity attributes field that cannot be 
updated, then: 

 The P6 internal logic prevents the mapping during integration and synchronization will fail. 

 The data in P6 is updated incorrectly. 

Ensure that you are aware of the limitations when you add a new field to the "Send Activity Data 
to P6" Data Mapping template. 

Since the "Actual Finish" field is added to the "Send Activity Data to P6" Data Mapping template 
and based on the value of the "Activity Type" field in P6, the "Actual Finish" field gets calculated, 
in P6, you must not keep the "Actual Finish" field in the "Send Activity Data to P6" Data Mapping 
template. Instead, you must keep the "Actual Finish" field in the "Update Activity Sheet from P6' 
Data Mapping template. 

In short, you need to keep, or designate, only one application (Unifier or P6) as the source for 
each field. This is to prevent a field to get updated in both applications (Unifier or P6). 

Business Flows 

The Unifier Provider allows you to filter Unifier Shells using "Project IDs." You can do this 
filtering in two ways: 

 By entering a fixed list of comma-separated Project IDs values (corresponding to each 
Unifier Shell), and when you synchronize, all the Projects in Unifier that match those Project 
IDs are pulled. 

 By using any Shell attribute (custom or system defined). When Object = Project, you can go 
to the "Source App Parameters" window and add filter conditions to a synchronization, using 
any data element of "Data Type = String" or "Data Type = Integer’" from a Shell attribute 
form. The "Field" drop-down lists in the Edit Business Flow window has an option called, 
"Shell Attribute." You can: 

1. Select Shell Attribute. 

2. Use the information presented (in the Value box) to enter any Shell attribute DE name of 
Data Type = "String" or "Integer." 

3. Click Add Row and set the item as a condition to filter the Unifier Shell. 
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Notes: 

 You can set only one value for a Shell attribute within a given 
condition; however, you can add more than one condition for a Shell 
attribute. 

 If you set conditions for a DE which is neither "Text" nor "Integer," the 
synchronization will fail and you will receive an error-message. 

There are two templates available for OOTB Business Flows: 

 Get Activity data from P6

 To create Activity Sheet in the Unifier Projects. 

 To update an existing Activity sheet. 

 Send Activity data to P6

To transfer, or push, data from a Unifier Activity Sheet object to a P6 Activity object. 

Note: For details, see the "Data Mapping Templates" section. 

The "Import Project data" flow ("Send Activity Data to P6" flow) has the Data Mapping template 
the "Send Activity Data to P6" set a "Update" only to prevent the accidental creation of activities 
in P6 from Unifier. P6 is the source for all activities. 

Synchronization 

The synchronization of the following two commands (on the OOTB Data Mapping templates) is 
scheduled to run daily: 

 Get Activity Data from P6

 Send Activity Data to P6

Note: For details, see the "Data Mapping Templates" section. 

Synchronization can be performed: 

 From Unifier by executing the "Get Data" or "Get Activity Sheet Data" commands from the 
"Activity Sheet" log or the Shell log. 

 From Gateway, manually. 

The Unifier Provider performs a check to see if the Unifier Project is linked to the corresponding 
P6 Project. 

 If the Unifier Project is not linked to the corresponding P6 Project, you need to establish the 
link. 

 If P6 does not have a corresponding project, then a message will notify you that the project 
has not been created in P6. 

To ensure a successful synchronization, do the following: 

1) Set the Shell attribute DE = uuu_integrated_with to P6. 

Note: If the attribute was missing, after this setup the integration will take 
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place. 

2) Receive the Activity Sheet data from Gateway and: 

 If an "Activity Sheet" does not exist in Unifier, create the "Activity Sheet," populate the 
fields with the data received, and name the sheet as: <P6 project name>. 

 If an "Activity Sheet" exist in Unifier, update the "Activity Sheet" with the data from 
Gateway. 

You need to perform the steps above to create the "Activity Sheet" within Unifier Shells for the 
first time, only. Once you create an "Activity Sheet," the hourly synchronization updates the 
"Activity Sheet" with the latest data received from Gateway. 

When projects between Unifier and P6 are linked for the first time, Gateway ensures that a P6 
Project attribute that is integrated is checked. 

If a "Get Activity Data from " synchronization is performed, but the P6 Project that must 
correspond to the Unifier Project is not found by Gateway, then Unifier will generate an 
error-message. 

Sending Activity Sheet data to P6 

When you synchronize, the Unifier Provider performs the following: 

 Checks to ensure that the Unifier Project contains an "Activity Sheet." 

 If an "Activity Sheet" does not exist, then the system generates an error-message. 

 If an "Activity Sheet" exist, then you can continue on with pulling (receiving) data. 

 Pull all updated "Activity Sheet" data by way of Reverse Auto-Population since the last "Send 
Activity Data to P6" synchronization. You can send the updated "Activity Sheet" to Gateway 
in Portable Database Image (PDI) format. 

 If the "Activity Sheet" has not been updated by way of Reverse Auto-Population, then you 
do not need to send data to P6. 

 If you add a DE to a Data Mapping template that is read-only in P6, then the system 
generates an error-message. 

Additional information about synchronization 

 If an Activity Type, in a Schedule, is set as “Start Milestone,” then P6 does not allow you to 
update the "Actual Finish Date." If you proceed with updating the "Actual Finish Date," then 
you generate inconsistent data. 

 If an Activity Type, in a Schedule, is set as “Finish Milestone,” then P6 does not allow you to 
update the "Actual Start Date." If you proceed with updating the "Actual Finish Date," then 
you generate inconsistent data. 

 You must define the filter condition before you filter the Unifier Project using the "Send 
Activity Data to P6" synchronization command. 
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Note: If a filter condition is defined in Business Flow, but a filter condition 
is not defined in the synchronization, Gateway will not know which 
Unifier Project to send data from. As a result, filter condition must be 
defined within the synchronization itself. 

Connectivity issues with Gateway or incorrect Gateway parameters will cause synchronization to 
fail. Use History, Admin mode, to see the list of failed synchronizations, if any. 

Criteria for successful data exchange 

Ensure that the fields ("Update Activity Sheet from P6" and "Send Activity data to P6") in the 
Data Mapping templates are not overlapping and a field that is set to map from P6 to Unifier is 
not added to the "Send" template. 

Note: The OOTB Data Mapping templates are designed in a way that 
the fields are exclusive; therefore, when you edit a Data Mapping 
template, ensure that you keep the fields that are exclusive intact. 

If you use DE = uuu_int_p6_project_id for linking P6 and Unifier projects, when the "Project ID" 
field in P6 is updated, then the "P6 Project ID" (uuu_p6_project_id), field in corresponding Unifier 
Shell, must be updated manually. 

UDR, Data Views, and ER View 

You can access and open an "Activity Sheet" in Unifier by way of User-Defined Reports (UDRs), 
Data Views, and ER views. 

The new Data Type that you need to use for creating UDRs is the "Shell Activity Sheet." 

Using Schedule Sheets 

Before you begin: Schedule Sheet permissions (on page 557) are granted on a 
sheet-by-sheet basis. Adding or editing an activity requires Edit Data or greater permission. If 
you only have View permission you cannot add or edit activities. The Schedule Manager helps 
you manage project or shell and program schedules by: 

 Creating project activities 

 Assigning cost codes to activities 

 Assigning  roles to activities 

 Creating relationships between activities 

 Tracking schedule progress and variables 

 Calculating the schedule’s critical path 

Best Practice is to set up your schedule sheets and complete with activity rows, in the project 
template.  However, you can create Project Schedule Sheets and add activities in existing 
projects. 



Working with Unifier Managers

617

In Primavera Unifier, you can also import project schedule records from Primavera P6.  
Imported schedules are editable within Primavera Unifier, and the data can be used in reports. If 
you copy activities from one schedule to another, Primavera Unifier will immediately notify you if 
the change will create a schedule conflict so that you can make corrections as you work.  

Each change in the Schedule Manager creates a record in Primavera Unifier, which is useful for 
auditing purposes. An audit report of these records shows detailed information on dates, events, 
actions, and old values versus new values, along with the user or proxy user who performed the 
action. 

Each project can have multiple schedule sheets, and one Master Schedule Sheet. The master 
schedule sheet drives project start and end dates, tracks the project’s progress, and serves as 
the interface between the Schedule Manager and other Primavera Unifier modules. The master 
schedule integrates cost items on the schedule with the Cost Manager. Primavera Unifier users 
can refresh resource rates on the schedule sheet and post the new rates to the Cost Manager, 
update the cost sheet with assignment costs, and refresh costs on the sheet to recalculate labor 
costs and post them to the cost sheet. 

Features include the following: 

 Fully configurable activity attributes form 

 Activities and Gantt chart on the same schedule sheet 

 Interactive Gantt chart with ability to drag activity end dates and link activities 

 Tracking Gantt chart 

 Filters for activities 

 Baselines for schedule sheets and activity sheets 

 Activity update 

 Ability to create one or multiple interactive schedule sheets for the same project or shell 

 Integration of Schedule Manager with the Resource Manager, enabling resource loading of 
schedule activities 

 Multiple CBS codes for each activity to capture activity costs, such as labor, non-labor, and 
fixed costs. If designed in Primavera uDesigner, you can add a column to the schedule sheet 
to display the CBS codes associated with each activity. 

 View the cost distribution information by CBS codes from a schedule sheet 

 Cut and paste and copy and paste of rows in a sheet 

 Update of schedule sheets from linked templates 

 Critical path calculation and display 

 Streamlined and enhanced integration and interaction between Primavera Unifier’s Schedule 
Manager and Primavera and Microsoft Project 

 Activity progress tracking and percentage of work completed per assigned resource 

 Works with shells that have the CBS cost type 

 Scope Management, with the ability to launch business processes from activities and 
automate schedule management. 

 Budget and progress settings, and the ability to work with progress and earned progress 
data 

You will need to add activity rows to the schedule sheet before you can enter your company 
data to the schedule sheet. 
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Scope Management 

The Scope Management defines deliverables, responsible roles, actual assignees and their 
schedules, and drives coordinated production of these deliverables. The Scope Management 
initiates actions for producing deliverables based on the completion of dependencies. It routes 
them to the responsible person or group, monitors their completion, and updates deliverable 
statuses automatically. It manages different activities across schedules for different team 
members simultaneously. 

Team members work on BPs that are linked to activities in a schedule sheet. The Scope 
Management allows you to use existing schedule management functionality with added data 
elements to automate the management of a project’s scope and schedule with all associated 
activities, tasks, and deliverables. This feature provides project managers with the ability to 
manage each scope item’s task assignments, ownerships, and durations. 

Project managers can use scope management to manage high-volume, quick turnaround 
projects that have standardized scope and scheduled activities. Examples of projects that would 
benefit from the use of scope management functionality are retail construction projects such as 
bank branches or chain fast food restaurants. Unifier scope management capabilities are also 
useful for large capital projects with complex scope and schedules, and that have numerous 
dependent activities and milestones with associated tasks and deadlines. 

Scope management: 

 Coordinates the creation of the defined deliverables using the schedules of the various 
assignees 

 Automatically moves tasks to the next assignee. 

 Routes tasks related to the deliverables to the next responsible assignee (person or group), 
monitors the state of the tasks, and updates deliverable status automatically. Actions for the 
creation of deliverables are based on fixed-time durations and the completion of 
dependencies. 

 Launches business processes that are linked to activities 

This functionality can be enabled on any schedule sheet, including a master schedule sheet. 
Scope management enables you to link BPs with schedule sheet task activities and route those 
BPs with an automatic update of status as they are routed and worked on. The BPs represent 
the work that needs to be done to complete the task. You can override automatic routing at any 
time and launch the BPs manually. The BP-related task is completed when specified conditions 
are met. 

Working with Schedule Sheets with Scope Management 

You can have any number of schedule sheets. There is one master sheet, which appears in bold 
in the log. The master schedule sheet drives the activity start and finish dates. You can use it to 
track progress and resource assignment information to other modules in Primavera Unifier. You 
can use scope management on any schedule sheet. You must have the correct permissions to 
be able to view and modify scope management data. If you find that you cannot access the 
functionality that you need, see your company administrator. 
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To access project schedule sheets 

1) In User Mode, select Project Standard tab > project > Schedule Manager > Schedule 
Sheets or Shells tab > shell type> shell instance > Schedule Manager > Schedule 
Sheets. The Schedule Sheets log opens. 

2) By default, the log lists all active schedule sheets. To view all active and inactive sheets, 
click the View menu and choose All. 

Scope management and multiple calendars 

In Scope Management a business process record can be created from an activity based on the 
setup. As part of setup, you can define how the system should calculate the workflow duration of 
the business process record that gets created. 

These are the following options: 

Enforce Activity Duration: System will take the planned duration of the activity and will pass it to 
business process record to calculate workflow due date and the workflow duration.With multiple 
calendars, it is possible that the activity has a different calendar than the calendar used on 
business process (which was the project/shell calendar). In this scenario, the system will take 
the duration from the activity and calculate the record/workflow due date based on business 
process calendar. 

Enforce Activity Finish Date: System will set planned finish date as the workflow due date. With 
multiple calendars, it is possible that the activity has a different calendar than the calendar used 
on business process (project/shell calendar). In this scenario system will take planned finish date 
of activity and force it to due date of business process record. 

In both cases when progress comes back from business process record to the activity, the 
system will take the actual end date and updates activity actual finish date. In this scenario, the 
system will not consider activity calendar. 

Manage scope management properties 

Scope Management functionality can be enabled on any schedule sheet (including master 
schedule sheets). You can modify the properties associated with scope management. These 
include: 

 Auto-control 

 Schedule start date 

 Error notification to users and groups 

To manage scope management properties 

1) In User Mode, navigate to the project or shell Schedule Manager and select Schedule Log. 
The Schedule Sheets log opens. 

2) Select a schedule sheet and click Properties. 

3) On the General tab, complete or modify the fields described in the following table and then 
click OK. 

In this field: Do this: 

Auto-control Controls the automatic update of tasks. The default is Off. 
Setting auto-control to On enables the automatic launch of 
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BP records. Setting auto-control to Off means that BPs will 
not be launched automatically on activities and completion 
conditions will not be checked on activities. Users can still 
launch BPs manually. 

Note: Unifier disregards predecessor/successor dependency 
relationships when you manually start an activity, even if 
auto-control is set to On in the schedule sheet properties. 

Schedule Start Date 
Drives the dates of floating activities on the schedule sheet. 
Activities cannot begin before this date, unless their 
preceding activities complete previous to this date. 

Notify users and/or 
groups on errors 

Select users and groups to be notified if there are errors 
during the scope management task routing. 

About scope management data elements 

There are data elements that are specific to scope management, which were added to the 
schedule attribute form in uDesigner. These data elements can be added to the scope 
management schedule sheet as columns as you work with the sheet. If data elements are on 
both the schedule attribute form and on the business process that you will be using to run the 
activity task for scope management, the values are copied from the form to the business process 
and vice versa. 

When you are planning to use scope management, consult with the uDesigner user and your 
company administrator to achieve the setup of data elements and business processes that will 
meet your business needs for managing scope. 

The scope management-specific data elements that are added to the schedule attribute form 
are: 

Data Element 
Name 

Description 

Actual Start 
Date 

Actual start date of the activity. 

Actual Finish 
Date 

Actual finish date of the activity. 

Actual 
Duration 

Actual duration of the activity. This is calculated from the Actual Start 
Date and Actual Finish Date. 

Status Activity status. The default is Not Started. 

Predecessors 

A list of the predecessor activities. 

Note: Activities that have no predecessors are known as floating 
activities. 

Record 
Number 

Hyperlink to the linked business process record. 
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Record Status Hyperlink to the linked business process record. 

Estimated 
Start Date 

Calculated date. 

Estimated 
Finish Date 

Calculated date. 

Estimated 
Duration 

Calculated duration. 

Auto-update 
Activity Data 

Enables the automatic update of activity data. The default is 
unchecked. If this checkbox is not selected, the activity must be 
completed manually, and automatic completion will be turned off. This 
means you must change the activity status to compete and enter an 
actual finish date. 

Linked BP 
Name 

Name of the linked business process. 

Set up scope management for activities 

You can set up the schedule sheet activities to link to BPs, specify responsible users or groups, 
enter a due date, and create completion conditions. 

You can change all setup options for activities that have the status of not started or not 
applicable. For activities that have an in-progress status and have a linked BP record, you can 
change only the completion conditions. You cannot change setup options for activities with the 
status complete. 

To set up scope management for an activity 

1) In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule 
Sheets log opens. 

2) Select a schedule sheet click the Open button. 

3) Select an activity in the sheet. 

4) Choose File > Setup Scope Management. The Activity Task Setup window displays on the 
right side of the pane, replacing the view of the Gantt portion of the window. 
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Note: You can return to the Gantt chart view by clicking the Gantt
button. 

Activity Task Setup example window 

5) Complete the Activity Task Setup portion of the window as described in the table below. 

6) Repeat these steps for each activity. 

7) Click the Save button when your changes are complete. 

In this field: Do this: 

Linked Business Process 
Select a project or shell level workflow BP that will launch 
from the activity. 

Bypass initiation step 
during auto-creation 

Auto-created records normally appear in users’ Tasks and 
BP logs as an initiation step (I Step). Select this check box 
if you want to bypass the I step that this auto-creation 
normally creates. If you select this option, the auto-created 
record will skip the initiation step and will appear in the 
user’s BP log at the step that the Administrator designated 
on the BP’s Auto-Creation tab during setup. 

Record Due Date 

Select Enforce Activity Duration (default) or Enforce 
Activity Finish Date. When a BP is launched 
automatically or manually from an activity, you can specify 
whether the record due date on the newly launched BP 
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record is set to use the activity duration or the activity finish 
date. 

Enforce Activity Duration: The finish date of the activity is 
not considered. If the Record Due Date option is set to 
enforce the activity duration, the value is calculated as: 

Record Due Date = Current Date (date/time) + Activity 
Duration (days) 

Enforce Activity Finish Date: If the Record Due Date 
option is set to enforce the activity finish date, it is 
calculated as: 

Record Due Date = Activity Finish Date 

Note: This functionality applies to workflow BPs launched 
from Scope Management only. Non-workflow BPs cannot 
be launched using Scope Management. 

Note: If you select Enforce Activity Finish Date, the 
workflow due date for the business process might be 
affected. Be sure to select Yes for Override Workflow Due 
Date in the workflow setup for the affected business 
process. 

Responsible User(s) 
/Group(s) 

Select one or more users or groups to which to route the 
business process. Be sure to add users and groups to this 
field so the business process associated with the activity 
will launch properly. 

Completion Conditions 

Add one or more conditions to indicate the completion 
condition on the activity. Click Add and select from the 
data elements for the selected BP, enter a label for the 
condition data element, select a condition, and select a 
value. Click OK. Conditions can be a BP status, a 
monetary value, or the completion of certain predecessor 
activities. You set up several completion conditions for 
each activity. See Completion Conditions (on page 623) 
for details. 

Show results matching 
ANY condition 

Select to complete the activity if any of the completion 
conditions are met for the activity. 

Completion Conditions 

You can set up completion conditions for a string or a date.  



Unifier Managers User Guide

624

For example, for the string Amount: 

For example, for a date: 

Launching Business Processes from Activities 

While the scope management functionality is automatic after it is set up, you can also manually 
launch or remove BPs from activities and manage the activity properties. 

Note: If a project or shell changes status from Active to View-Only or 
Inactive, business processes associated with activities are not launched 
while the project or shell has the View-Only or Inactive status. When the 
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project or shell reverts to Active status, you must adjust the dates on 
these business processes and launch them manually. 

Manually launch a business process 

When you manually launch a BP associated with an activity, you override the Auto-control 
property setting. See Manage scope management properties (on page 619) for details on 
properties. 

See About Launching or Removing Business Processes from Activities (on page 627) for 
details on the conditions under which you can manually launch BPs. 

To manually launch a BP associated with an activity 

1) In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule 
Sheets log opens. 

2) Select a schedule sheet and click the Open button. 

3) Select an activity. 

4) Choose Edit > Linked Business Process > Start. You can select one or more BPs and 
launch them. They will be routed to the assignees that have been specified. 

Remove the link between a business process and an activity 

You can remove (unlink) a BP from an activity. See About Launching or Removing Business 
Processes from Activities (on page 627) for details on the conditions under which you can 
remove BPs from activities. 

To remove the link between an activity and a BP 

1) In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule 
Sheets log opens. 

2) Select a schedule sheet and click the Open button. 

3) Select an activity. 

4) Choose Edit > Linked Business Process > Remove Record. You can select one or more 
BPs. The BP itself is not deleted. 

Note: The link between a BP and an activity is automatically removed if 
the BP is terminated. When a linked BP is terminated, the BP hyperlink 
is removed from the associated activity, and the activity is set to not 
started. 

Update activity properties 

To update activity properties for scope management: 

1) In User Mode, navigate to the Schedule Manager and select Schedule Log. The Schedule 
Sheets log opens. 

2) Select a schedule sheet and click the Open button. 

3) Click the link for an activity. The Activity Properties window displays. 
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4) Modify the activity properties as needed. The properties shown in the Activity Properties 
window depend on the design configured in uDesigner. Activity properties associated with 
scope management can include what is shown in the table below. 

5) Click OK. 

Property 
Name 

Definition 

Activity 
Statuses 

Read-only for automatically controlled activities. Editable for manually 
controlled activities. The statuses are: 

Not Started: All activities have this as the initial status by default. 
Indicates that the BP linked to the activity has not yet been launched. 

In Progress: Indicates that predecessor activities are complete and that 
the current activity is not started. A new BP record is created and linked to 
the activity. 

Note: You cannot modify certain activity attributes while an activity is In 
progress. 

Complete: Indicates that an activity is complete based on the completion 
conditions set up for the activity. 

Linked BP 
Name 

Read-only; displays the BP linked to the activity. 

Record 
Number 

Read-only; displays the current record number that is linked with the 
activity. 

Record 
Status 

Read-only; displays the current status of the BP record linked to the 
activity. 

Actual 
Start Date 

Read-only or editable, depending on the setting for the Auto-update 
activity data box. This value is set when the linked BP is launched for the 
activity. 

Actual 
Finish Date

Read-only or editable, depending on the setting for the Auto-update 
activity data box. This value is set when the linked BP is completed based 
on the completion conditions. 

Estimated 
Start Date 

Read-only; indicates the estimated start date for the activity. 

Estimated 
Finish Date

Read-only, indicates the estimated finish date for the activity. 

Auto-updat
e activity 
status 

The default is not selected. Indicates if the current activity is automatically 
controlled or manually controlled. 

Dependenc
ies 

Read-only; lists the predecessor activities for the current activity using a 
coding format indicating lag and lead time: Finish to Start (FS), Start to 
Start (SS), Finish to Finish (FF), and Start to Finish (SF). For example: 

3FS + 3d (Activity 3 is a predecessor with FS relationship with 3 days lag) 

2SS - 1d (Activity 2 is a predecessor with SS relationship with a 1 day 



Working with Unifier Managers

627

lead) 

An activity can have multiple dependencies separated by a comma. The 
value is updated every time there is an addition or change to the 
predecessors. 

Status Transitions and Activities 

Scope management activities have statuses that control the transition of the activity from one 
state to another as it progresses toward completion. You can perform certain changes to the 
activity during its progress, but it can be limited as to what you can change while an activity has 
the status In Progress. The activity status transitions vary depending on whether an activity is 
automatically or manually launched. 

Automatic activity status transitions 

When activities are auto-controlled (the Auto-update Activity Status box is checked), activity 
status is read only. The statuses automatically transition as follows: 

 Not started (default) 

 In progress (this is when the linked BP is launched) 

 Complete (when the BP completion conditions are met) 

Manual activity status transitions 

You can change the activity status manually when the Auto-update Activity Status box is not 
checked. You can change the status during any of the states (not started, in progress, or 
complete). 

 If you change the status of an activity to In Progress, you can enter the actual start date. This 
clears the existing actual finish date. 

 If you change the status of an activity to Not Started, both the actual start date and the actual 
finish date are read only. 

 If you change the status of an activity to Complete, you can enter an actual finish date. In 
this case, the actual start date, if it is not populated, is set to the actual finish date at activity 
completion. 

About Launching or Removing Business Processes from Activities 

Scope management functionality enables automatic or manual creation of business processes 
(BPs) from activities on a schedule sheet. A new BP record can be created for every eligible 
activity. The BP record will be permanently linked to the activity, unless you terminate or remove 
the BP. An activity can be linked to only one BP record at a time. Any two activities cannot link to 
the same BP record. 

Automatic launching of business processes 

For BPs to launch automatically from activities, these conditions must be met: 

 Auto-control must be set to On on the Schedule Sheet properties 

 Activity is not manually controlled, which means that Auto-update Activity is selected 
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 Activity has a BP setup 

 Activity has the status Not Started

 Activity has no predecessors or the predecessors are all in Complete status 

 The Start Date for the activity is not in the future 

Manually launching business processes 

You can launch BPs manually by selecting an activity and choosing Edit > Linked Business 
Process > Start. To manually launch BPs, these conditions must be met: 

 Activity has the status Not Started 

 BP setup is present on the activity 

Note: A BP can be launched manually to override the setting of the 
Auto-control flag on the Schedule Sheet Properties and Auto-update 
Activity Data on the Activity Properties. 

Manual launch under various conditions: 

Auto-control on 
Schedule Sheet 
Properties 

Auto-update Activity Status on 
Activity 

System Behavior 

On/Off Checked 

Manually launched BP is 
tracked by the system, and 
actuals will be 
auto-populated on launch 
and completion. 

On/Off Unchecked 

Scope Management will not 
keep track of BP completion 
and auto-population of 
actual start and finish dates 
of manually launched BP. 

Manually remove business process link 

You can remove a linked BP record manually if these conditions are met: 

 Activity is in manual mode; that is, Auto-update Activity Status on Activity is unchecked 

 Activity is in any status. 

Automatic removal of business process link 

If a BP is terminated by the user, the termination removes the BP link from the activity and sets 
the activity back to Not Started. 

About Activity Completion 

This section covers the criteria for automatic and manual completion of scope management 
activities. 
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Conditions for the automatic completion of activities 

Unifier checks the linked BP record workflow for in-progress status activities that are not 
manually controlled (Auto-update Activity Data box is checked for the activity). 

When the system detects BP completion based on the conditions, it performs the following 
actions: 

1) Actual finish is updated with current date 

2) Activity status is updated to complete 

3) Success of activities is evaluated for the automatic launching of further BPs 

If there is no BP setup or if the activity is manually controlled, the system does not evaluate the 
BP completion conditions but waits for you to manually complete the activity. 

Conditions for the manual completion of activities 

Activities that are manually controlled (Auto-update Activity Data box is unchecked) can only 
be completed manually. In this case, you must change the activity status to Complete and enter 
the actual finish date, which is required for the activity to complete successfully. 

About Manual or Automatic Control of Individual Activities 

This section describes the behavior of manual and automatic control of scope management 
activities. 

Auto-update activity data on activity attributes 

Activities can be controlled in two modes: automatic or manual. This choice depends on the 
value of the Auto-update Activity Data checkbox. 

If Auto-update Activity Data is checked, automatic launching of BPs and completion checks 
with the possibility of launching the BP sooner. 

If Auto-update Activity Data is unchecked (default value), the user has manual control, but 
basic scope completion rules are enforced. BP link is maintained. New BPs can be launched 
manually. The BP is not checked for completion. 

The following table summarizes the behavior in each mode: 

Behavior Automatic Manual 

Auto-update Activity 
Data checkbox 

Checked Unchecked (default) 

BP setup allowed Yes Yes 

Create BP record link Yes Retain existing link if any exists 

BPs launched by 
scheduler 

Yes No 

Manual BP launch Yes 
Yes, but completion and actuals are 
not tracked 
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BP condition check Yes No 

Scope status updated Updated by system 
Manual update via drop-down list 
choice 

Scope status update 
rules enforced 

Yes Yes 

Actual dates Automatic Manual 

Rules for modifying the Auto-update Activity Data checkbox 

These are the rules for using the Auto-update Activity Data checkbox. 

 The Auto-Update Activity Data checkbox is unchecked by default for all schedule sheets. 

 As soon as a new BP is set up for the activity (by choosing File > Setup Scope 
Management), the Auto-update Activity Data checkbox will be checked only for activities in 
the Not Started status. 

 Updating the BP setup on an activity later will only check the Auto-update Activity Data 
checkbox automatically if the activity is in the Not Started status. If you have not set up any 
BP linking, by default, the box is unchecked. In that case, you can update the Actual Start, 
Actual Finish, and Status fields. 

 You can manually modify the Auto-update Activity Data checkbox for any activity status, 
including complete. 

System behavior when the Auto-update Activity Data checkbox is modified 

The following is the sequence of the system behavior when the Auto-update Activity Data 
checkbox is modified: 

1) The Auto-update Activity Data checkbox is unchecked by default, assuming that no BP setup 
exists for the activity. As soon as a new BP is set up or modified for the activity, the 
Auto-update Activity Data checkbox is checked. 

2) Unchecking the Auto-update Activity Data checkbox will: 

a. Retain the BP record link (if any). 

b. Retain the original status of the activity. 

c. Change the activity status of an editable field. 

d. Retain existing actuals but allow them to be modified. 

3) Subsequent checking of the Auto-update Activity Data checkbox will: 

a. Retain the BP record link if it exists. 

b. If a BP record link exists, update BP record status on the activity, and check the BP 
record for complete condition and set the appropriate status of the activity (either 
Complete or In Progress). 

c. If a link does not exist and conditions allow the start of the BP, the system launches the 
BP and sets the activity status to In Progress. 

d. If a link does not exist and conditions do not allow the start of the BP, the system sets the 
activity status to Not Started. 
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Note: Setting the status to Not Started or Not Applicable in manual 
control mode does not clear the BP record link. The actual start cannot 
be a future date when entered manually, and the actual finish cannot be 
a future date when entered manually. 

Impact of Schedule Start Date 

The schedule start date on schedule sheet properties defines the earliest possible date on the 
schedule sheet. The start dates of all activities on the schedule sheet must be greater than or 
equal to the schedule start date. 

The schedule start date affects the first activity in a group of linked activities and controls the 
start of any floating activities. Floating activities are activities that have no predecessor activities. 

When you change the schedule start date, the entire schedule moves, and all the dates adjust in 
relation to the new schedule start date. 

The schedule start date is a required field on schedule sheet properties. Updates to the 
schedule start date start activities are based on following rules: 

 Floating activities start and retain the offset from the schedule start date specified on the 
sheet properties. 

 The start date on floating activities can be updated; however, the activities start date cannot 
be earlier than the schedule start date. 

 The start date of any floating activity will drive the start of the system update process. Each 
floating item may be the root of a tree and hence will have its own system update process 
that drives launching and completion of BPs for the current activity and successor activities. 

 Forecast dates (start date, finish date) can only be changed for not started or in-progress 
activities. 

 The schedule start date cannot be changed when at least one activity is in progress or 
complete. 

 Manual launch cannot be done on any activity before the schedule start date on the sheet 
properties. 

Calculation of Estimated Start and Finish Dates 

Estimated dates are used to predict the effect of delayed or early completion of predecessor 
activities on successor activities. They are useful to identify potential problems or the potential 
for schedule compression. 

The estimated start, finish, and duration are read-only elements calculated by the system. They 
are updated by the system each time activities complete. Succeeding estimated dates are 
adjusted based on the logic below. 

For completed or predecessor complete activities: 

 Estimated Start Date = Actual Start Date 

 Estimated Finish Date = Actual Finish Date 

For in-progress or not started activities: 

 Estimated Start Date = Predecessor (latest) Estimated Finish Date 
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 Estimated Finish Date = Estimated Start Date + Forecast Duration 

Impact of Successor and Predecessor Activities on Launching and Completion of BPs 

This section discusses the interaction of activities and the launching of BPs. The start of an 
activity is affected by whether there is a lag or a lead, as shown in the examples below. 

Finish-to-start (FS) 

The successor activity is launched when the activity completes or the Calculated Date = 
Predecessor Actual Finish + Lag (if not already past). 

In case of a lead, the successor activity is launched on the forecast start date (similar to a 
floating activity. 

Finish-to-start

Start-to-start (SS) 

When an activity’s predecessor is started (for example, status = in-progress), it is also placed 
into an in-progress status (assuming zero lag). 

 Lag: Success, or activity will be started on forecast date 

 Lead: Success, or activity will be started on forecast date 

Start-to-start 

Finish-to-finish (FF) and start-to-finish (SF) 

The activities will be treated as floating activities. They are launched on their forecast date. 

 Lag: Success, or activity will be started on forecast date 

 Lead: Success, or activity will be started on forecast date 
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Finish-to-finish, start-to-finish

Entering and Viewing Cost Data 

In uDesigner, data elements can be added that allow you to enter and view cost data on 
schedule sheets. These data elements are Activity Cost 1 (and Activity Total Cost 1 Per CBS) 
and Activity Cost 2 (and Activity Total Cost 2 Per CBS). The Cost and Per CBS data elements 
have a predefined association between them. Also, the Activity Latest Progress As Of data 
element can be added to allow you to track the date of the last change to an activity. 

Note: Unifier refreshes the cost data when you choose File > Refresh in 
a Schedule Sheet and refresh immediately or set up a refresh frequency. 
See Refreshing Schedule Sheet data (on page 588) for details. 

In the activity setup performed by the Administrator, one of more CBS Codes can be associated 
with an activity. The value carried by the Total Cost data element on add to a Schedule Activity 
Attribute form gets passed onto these CBS codes as the result of calculations such as data roll 
up to a Cost Sheet, or earned value calculations. The logic used by the Activity Cost 1 and 
Activity Cost 2 and the associated Activity Total Cost 1 Per CBS and Activity Total Cost 2 Per 
CBS data elements is based on the association of an activity to a CBS code. 

The values for Activity Total Cost 1 Per CBS and Activity Total Cost 2 Per CBS data elements 
are calculated by the system based on the corresponding Activity Cost 1 or Activity Cost 2 data 
element values. 

These are the steps the system follows to calculate values for Activity Total Cost 1 Per CBS and 
Activity Total Cost 2 Per CBS data elements: 

1) If the combination of Cost and Per CBS data elements are used on an Schedule Activity 
Attribute form, the system will scan through all of the activities and associated CBS codes. 

2) The system will accumulate all of the values in the Activity Cost 1 or Activity Cost 2 data 
elements for all activities per CBS code associated with each activity. 

3) Use the total value calculated in step 2 per CBS code as the value for each Activity Total 
Cost 1 Per CBS and Activity Total Cost 2 Per CBS data element specified for each activity. 

4) Each activity gets a total value calculated in step 2 based on the CBS code associated with 
it. 

The following example explains these calculations. For this example, the data elements Activity 
Cost 1 and Activity Total Cost 1 Per CBS have been added to the attribute form: 

Activity 
Name 

Activity Cost 1 Activity Total Cost 1 Per CBS 

Control 
Account 1 

$28,000.00 

Control 
Activity 1.1 

$19,000.00 

Control 
Point 1.1.1 

$10,000.00 $28,000.00 
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CBS - 1 $10,000.00 

Control 
Point 1.1.2 

$9,000.00 $28,000.00 

CBS - 1 $9,000.00 

Control 
Activity 1.2 

$9,000.00 

Control 
Point 1.2.1 

$5,000.00 $28,000.00 

CBS - 1 $5,000.00 

Control 
Point 1.2.2 

$4,000.00 $28,000.00 

CBS - 1 $4,000.00 

Control 
Account 2 

$20,000.00 

Control 
Activity 2.1 

$20,000.00 

Control 
Point 2.1.1 

$8,000.00 $20,000.00 

CBS - 2 $8,000.00 

Control 
Point 2.1.2 

$12,000.00 $20,000.00 

CBS - 2 $12,000.00 

In the above example, Control Point 1.1.1 has a value $28000.00, which was arrived at by 
adding the value of CBS - 1 across all activities. 

Effects of multiple calendars 

Activities can be affected by calendar selection, if there are multiple calendars implemented. 
There can be a Calendar column in the activity sheet, for example. This column will allow to 
select a calendar per activity as needed. If this column exists, you can select from the Company 
level calendars and Project/Shell calendars as permissions allow. Any defined Custom 
calendars (which are defined for the Schedule Manager at the project or shell level) are not 
available for selection on the Activity Sheet. 

If you are using an Activity Attribute form designed in uDesigner to manage activities, the data 
element uuu_activity_calendar can be added to the form so users can select calendars. If you 
are not using a designed Activity Attribute form (are letting Unifier use the default form provided), 
the data element uuu_activity_calendar is automatically included in the Activity Attribute form. 
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When activities are updated through the Activity Sheet, they consider the calendar in use for the 
activity. The Start Dates, Finish Dates and Durations can be affected by the calendar used for an 
activity. Double-click on the Calendar cell to see a list of Company level calendars and 
project/shell calendars (not the custom calendar). You can select another calendar for the 
activity. 

The selected Start Date or Finish Date for an activity can be a non-working calendar day, 
however the duration of the activity will only account for working calendar days. 

Note: When you select the alternate calendar and click Save, the 
schedule sheet associated with the activity is marked for refresh with the 
refresh icon (rotating arrows). 

Project Progress Data Accumulation and Calculation 

The Schedule Manager allows you to enter activity progress, which is accumulated and used to 
calculate the earned progress for each activity. Earned progress represents how much has been 
earned on an activity. Depending on type of activity, earned progress can be tied to activity 
progress directly. However, it is also possible nothing is earned even if the progress is 99%, if 
the activity has been defined to have earned progress counted upon 100% of activity 
completion. 

Earned progress is a quantitative measurement to indicate how much has been earned on an 
activity over the duration of the activity. Earned Progress can be represented by amount, 
quantity and a percentage value. Earned Progress is based on the progress entered by the user 
on an activity. 

Each activity can earn progress in different ways. One way to earn is when progress is entered. 
Another way to earn is by % of activity when the activity is started and earn remaining % when 
that activity is finished. Unifier captures earned progress for an activity as well as resources that 
assigned to an activity. Earned progress data from the Schedule Manager is related to CBS 
codes and is used by the Earned Value module (in the Cost Manager) to calculate different key 
components that are required to perform Earned Value analysis. 

The Schedule Manager also allows you to enter activity progress in the activity properties. 

The calculations described in this section pertain to the progress and earned progress data 
accumulation and calculation discussed in Progress and Earned Progress Calculations (on 
page 655). If you do not need to work with progress or earned progress data to ultimately 
calculate Earned Value, you do not need to read this section. 

Note: The calculations described in this section pertain to the progress 
and earned progress data accumulation and calculation. If you do not 
need to work with progress or earned progress data to ultimately 
calculate Earned Value, you do not need to read this section. 

Terminology 

Progress: A percentage that indicates how much of an activity has been accomplished. 
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Earned Progress: This quantity represents the progress earned for a given activity over a time 
period. Depending on type of activity, earned progress can be tied directly to activity progress. 
Also, earned progress can be set up to be given at activity finish. For example, earned progress 
might not be awarded for incremental percentages of progress, and not be counted until 100% 
of an activity is complete. 

Earned Progress and Earned Value 

The Earned Value module uses the concept of Earned Value Management (EVM), which is an 
analytical tool that allows Project Managers and stake holders of a project to determine whether 
a project is on schedule and on budget. Based on the outcome of the earned value analysis, the 
project manager can determine if corrective action is needed to ensure that the project can be 
completed with in its constraints. Examples of corrective action can be the change of project 
scope, extension of the schedule, or the addition of resources. 

There are a number of parameters that are used to calculate Earned Value to determine if a 
project is on schedule and on budget. Some of these parameters are Budget, Progress, or 
Actual Cost. All of these parameters must be considered together to determine the current state 
of a project. One of the key components of this technique is to capture the progress of a project. 
This progress is usually provided by a General Contractor or the person who is in charge of the 
project. These progress entries are analyzed to determine the state of the project. Progress 
information entered by user can be analyzed to determine the progress of the project with 
respect to budget and schedule. 

Add a progress filter for earned value to a column 

If the Schedule Attribute form includes an Activity Earned Value Filter field 
(uuu_activity_ev_filter), you can set up progress filtering for earned value sheets in the Cost 
Manager. 

To set up the schedule sheet for progress filtering 

1) Open a schedule sheet in a template or project/shell. 

2) Add the Activity Earned Value Filter data element as a column to the schedule sheet. 

3) Enter an alphanumeric value, such as "progressable" or "non-progressable," into the column 
cell. (Use whatever term you like.) 

4) Save the schedule sheet. 

Enter progress and earned progress information 

In Unifier, there are several areas that enable you to enter (based on settings), view progress 
and earned progress information, or control the accumulation of progress information: 

1) Budget and Progress Setup window: First, set up how you want your progress data 
calculated. See Setting Up the Budget and Progress Method (on page 637) for details. 

2) Enter data on the attribute forms. The fields that allow you to enter data are determined by 
the settings on the Budget and Progress Setup window: 

 Resource Assignment Attribute form (Resource tab of Activity Properties) 

 Schedule Attribute form (General tab of Activity Properties) 
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See Entering Progress Data on the General and Resource Tabs of Activity Properties
(on page 648) for details. 

3) Activity Progress window: View activity and resource progress; depending on settings on 
the Budget and Progress Setup window, you can enter progress data in this window. This 
window is available only if you have imported the Resource Assignment Attribute form. See 
Entering Progress in the Activity Progress Window (on page 650) for details. 

4) Check activity and resource progress in the logs: View and enter progress data as 
needed: 

 Activity Progress log 

 Resource Progress log 

See Using the Activity Progress and Resource Progress Logs (on page 654) for details. 

5) Options tab of the Schedule Sheet Properties: The options on this tab allow you to control 
the automatic update of activity status based on Actual Start and Actual Finish dates, and to 
specify that activity progress requires an Actual Start Date. 

Setting Up the Budget and Progress Method 

The Schedule Manager allows you to set up a budgeted cost of work schedule profile for each 
activity on a schedule sheet to distribute budget associated with the activity.You can enter this 
profile information in the Budget and Progress setup window, either at the schedule sheet level 
(for all of the activities on the sheet) or at the individual activity level. 

These settings include selecting a profile, an entry method, and calculation methods for % 
Complete and % Earned. The settings you select in this window control how the progress and 
earned progress data that is entered on the Resource Assignment Attribute form (Resource tab 
for Activity Properties) and the Activity form (General tab for Activity Properties) is calculated. 
Also, you can choose the workpackage-related CBS codes to link to, and lock the progress so it 
cannot be updated outside of a defined period. 

You can configure the setup for progress (both resource and activity) and earned progress 
settings independently. At the same time, you can also have activity or resource progress 
calculate earned progress automatically or the earned progress calculate the progress. 

Most of the Budget and Progress settings that you can use at the schedule sheet level are also 
available at the activity level, however there are some differences. This section will first 
document the settings for the schedule sheet level, and mention when there are variations at the 
activity level and refer to the appropriate section. 

Note: The Budget and Progress Method setup options for an activity 
cannot be modified after a user begins to enter progress for that activity. 
This includes activity progress or progress of the resource assigned to 
that activity. 

The calculations used to derive progress and earned progress are explained in Progress and 
Earned Progress Calculations (on page 655). 

To setup the budget and progress method 

1) Navigate to a schedule sheet log. 

2) Open a schedule sheet. 
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3) Choose File > Budget and Progress Setup > Schedule Sheet or File > Budget and 
Progress Setup > Activity. A the activity level, the Budget and Progress Method Setup 
window opens in the right side of the schedule sheet window, and replaces the Gantt chart. 
When you are done working with the activity-level Budget and Progress Method Setup 
window, you can choose View > Gantt Chart. 
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4) Select the Budget and Progress settings. The Budget and Progress Method Setup window 
has several sections where you can choose settings. 

 Activity Budget Distribution Profile: See Select the activity budget distribution 
profile (on page 640) for details on the profile setting choices. 
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 % Complete and Earned Progress: See Select the entry method for the % complete 
and earned progress (on page 642) for details on the entry methods. 

 % Complete Calculation Method: See Select the calculation method for % complete
(on page 643) for details on these calculation methods. 

 % Earned Calculation Method: See Select the calculation method for % earned (on 
page 645) for details on these calculation methods. 

 Additional Options (schedule sheet level only): See Select CBS codes filtered by 
workpackage (schedule sheet level only) (on page 647) and Lock the reporting and 
progress entry period (schedule sheet level only) (on page 648) for details. 

5) Click OK. 

Select the activity budget distribution profile 

You can choose the option that determine how the budget of an activity is distributed. 

To set up budget distribution for activities at the schedule sheet level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. The Default Budget and 
Progress Method Setup window opens. 

3) Under the Activity Budget Distribution Profile section, choose an option. This option will 
apply to all activities in the schedule sheet, unless it is overridden by the selection of a 
different option for an individual activity. 

Data Element Name Description 

Linear This option distributes the activity budget linearly. 

S-curve 

Sigma 

Mu % 

This option distributes the activity budget based on Sigma 
and Mu values. 

S-curve calculations are based on Sigma and Mu values 
that are provided as setup parameters. The system will 
generate data using following probability density function:

Parameters in this equations are: 

X is determined based on the number of periods. 

Mu is the mean that is calculated based on user input. 

Sigma is the standard deviation that is used based on 
user input. 

On Start and Finish 

% budgeted on Start 

and Finish 

This option distributes the activity budget based on the 
Start and Finish Dates of the activity. 

% budgeted on Start: This option allows you to enter the 
percentage that should be budgeted on start of the 
activity. 

% budgeted on Finish: This is a read-only field, and is 
calculated based on the % budgeted on Start value. The 
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value for this filed is (100 - % budgeted on Start). 

Import distribution data from 
external sources 

This option allows Unifier to import progress data from 
Primavera. Data mapping is required in the schedule 
sheet to ensure the spread will be populated correctly in 
the EV sheet. All required fields must be mapped. 

Distribution profile based on 
resource 

This option distributes the cost of a role per activity by 
rolling up the rate of all the resources assigned to the 
activity. If hard booked resources are allocated, the total 
cost = (role rate) x (currency rate) x (quantity.) If the 
resources are not allocated, the total cost is manual entry 
(from a formula). 

In a schedule sheet’s activity, you will need to match the 
activity’s total cost to the role cost total. The total amount 
is rolled up to the cash flow module to create a cash flow 
profile based on the resource(s) cost on the activity. 

The tables below show incremental and cumulative examples of how these three options work, 
and the differences between them. This data is assumed for these examples: 

 Start Date: 01/1/2009 

 Finish Date: 12/1/2009 

 Total Cost: $12000.00 

 For S-Curve: Sigma = 2 and Mu = 50% 

 For Start and Finish: % budget distribution on start = 5%, % budget distribution on finish = 
95% 

Incremental 

Option 
01-0
9 

02-0
9 

03-0
9 

04-0
9 

05-09 
06-0
9 

07-0
9 

08-09 
09-0
9 

10-0
9 

11-0
9 

12-0
9 

Linear 1000
100
0 

100
0 

100
0 

1000 1000 1000 1000 1000
100
0 

1000 1000

S-Curve 
26.5
2 

104.
88 

323.
06 

789.
30 

1462.
17 

2120
.93 

2401
.43 

2120.
93 

1447
.85 

774.
98 

323.
06 

104.
88 

On Start 
and Finish

600 0 0 0 0 0 0 0 0 0 0 
1140
0 

Cumulative 

Option 
01-0
9 

02-0
9 

03-0
9 

04-0
9 

05-09 06-09
07-0
9 

08-0
9 

09-09 10-09 11-09 12-09

Linear 
100
0 

200
0 

300
0 

400
0 

5000 6000
700
0 

800
0 

9000
1000
0 

1100
0 

1200
0 

S-Curve 
26.5
2 

131.
40 

454.
46 

124
3.76

2705
.93 

4826
.86 

722
8.29

934
9.22

1079
7.07 

1157
2.10 

1189
5.10 

1199
9.99 
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On Start 
and Finish

600 600 600 600 600 600 600 600 600 600 600 
1200
0 

To set up budget distribution for activities at the activity level 

1) Open a schedule sheet. 

2) Highlight an activity row in the sheet. 

3) Choose File > Budget and Progress Setup > Activity. 

4) Under the Activity Budget Distribution Profile section, choose an option. This option will 
apply specifically to the selected activity, and will override any default option set up at the 
schedule sheet level. The behavior of these Activity Budget Distribution Profile options at the 
activity level is the same as the default options at the schedule sheet level. 

Select the entry method for the % complete and earned progress 

You can select an entry method for the progress and earned progress data, and can enter 
progress (both resource and activity) and earned progress independently. Also, you can select 
an entry method that allows you to enter the progress of activity or resource then calculate 
earned progress, or enter earned progress and calculate progress for an activity or resource. 

To select the entry method for the % complete and earned progress for activities at the 
schedule sheet level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. 

3) In the Default % Complete and Earned Progress section, choose a default entry method. 
This entry method will apply to all activities in the schedule sheet, unless it is overridden by 
the selection of a different entry method for an individual activity. 

Use this Entry Method To do this: 

Independently Control % complete and 
earned quantity 

Enter the progress of activity or resource 
independent of earned progress. 

Activity and resource % complete updates 
% earned 

Enter the progress of activity or resource, 
and earned progress will be automatically 
calculated. 

Activity and resource % earned updated % 
complete 

Enter the earned progress of activity or 
resource, and progress will be 
automatically calculated. 

Do not allow update of % complete and % 
earned 

Not enter either progress or earned 
progress. You cannot enter any type of 
activity progress information with this 
option selected. 

To select the entry method for the % complete and earned progress for activities at the 
activity level 

1) Open a schedule sheet. 

2) Highlight an activity row in the sheet. 
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3) Choose File > Budget and Progress Setup > Activity. 

4) Under the % Complete and Earned Progress section, choose an entry method. This option 
will apply specifically to the selected activity, and will override any default entry method set 
up at the schedule sheet level. The behavior of these % Complete and Earned Progress 
Entry Method options at the activity level is the same as the default options at the schedule 
sheet level. 

Select the calculation method for % complete 

You can select an option that allows you to enter progress information for a key quantity 
(referred to as the Leader) of an activity which will determine the overall progress of other 
resources and the activity itself. For example: 

 Example 1: Assume that there are two resources on an activity, called Resource 1 and 
Resource 2. If the key quantity is Resource 1 and you enter progress (say 30%) on 
Resource 1, then Resource 2 should also progress with same 30%. Also, overall activity 
progress should progress by 30%. 

 Example 2: Assume that the key quantity (Leader) in this example is Activity % Complete. If 
you enter progress of 50% on the activity, Resource 1 and Resource 2 are updated with the 
same progress of 50%. 

The key quantity is referred to as the Leader in Unifier. 

To select the % complete calculation method for activities at the schedule sheet level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. 

3) Under the Default % Complete Calculation Method section, choose an option. This option 
will apply to all activities in the schedule sheet, unless it is overridden by the selection of a 
different option for an individual activity. 

Note: Company holidays based on company calendar should be 
considered while distributing budget. Budget should not be distributed on 
days that are marked as holidays on company calendar. 

Use this Calculation Method To do this: 

Manual activity % complete and 
resource % complete 

Enter the progress of activity and resource 
independent of each other. Entering Activity % 
Complete will not update resource progress 
and entering resource % complete will not 
update Activity % Complete. 

Manual activity % complete - updates 
resource % complete 

Enter the progress of an activity, and resource 
% complete will be updated automatically. If 
this option is selected, Activity % Complete will 
become the key quantity or Leader, which will 
control the progress of the entire activity, 
including resources. 

Resource updates Activity - weighted Enter progress for each resource 
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average of resource costs independently. Activity % Complete is 
read-only and will be automatically calculated 
based on weighted resource cost. 

The following formula is used to calculate this 
value: 

{Sum of [Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources are considered in this 
calculation, including hard booked resources. 

Resource updates Activity - weighted 
avg. of resource hours 

Enter progress for each resource 
independently. Activity % Complete will be 
read-only and will be automatically calculated 
based on weighted resource man hours. 

The following formula is used to calculate this 
value: 

{Sum of [Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Quantity) } * 100 

The only resources considered in this 
calculation are hard booked resources. 

Note: Progress entry for Resource and Activity before importing 
Resource Assignment Attribute form is based on Activity % Complete 
and Resource % Complete. After the Resource Assignment Attribute 
form is imported, progress on activity will be Activity % Complete, but for 
Resource it is Progress Quantity the data element. Resource % 
Complete is then read-only and always calculated. 

To select the % complete calculation method for activities at the activity level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Activity. 

3) Under the % Complete Calculation Method section, choose an option. This option will 
apply specifically to the selected activity, and will override any default entry method set up at 
the schedule sheet level. The behavior of these % Complete Calculation Method options at 
the activity level is the same as the default options at the schedule sheet level. The 
exception is Lead resource updates Activity and other resources, described in the next 
step. 

4) Under the activity level, you can select Lead resource updates Activity and other 
resources, and choose resources (including hard booked) that are assigned to the activity 
on the Resource tab. This option allows you to select a resource as a key quantity or a 
Leader. If you select this option and a resource from the drop down menu, then you can 
enter progress on only that resource. Activity % Complete and Resource % Complete on all 
other resources are read-only and will be automatically calculated based on the progress 
entered on key quantity or leader resource. 
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For example: 

Assume that there is an activity with Resource 1 and Resource 2, with the Activity % 
Complete at 0%: 

Resource Work Hours % Complete 

Resource 1 200 0 

Resource 2 500 0 (read-only) 

For a further example, assume that Resource 1 is the key quantity or Leader, with the 
Activity % Complete at 30%: 

Resource Work Hours % Complete 

Resource 1 200 30 

Resource 2 500 30 (read-only) 

You can change the Lead resource updates Activity and other resources drop down menu 
selection until there is progress or earned progress entries for the activity or resource. After 
progress or earned progress data is entered, the Budget and Progress Method Setup for the 
activity is disabled and you cannot delete the resource selected as Leader. If you find that 
you must change the settings for the activity, you must delete the activity and start over with 
new data and settings. 

Select the calculation method for % earned 

Earned progress is a quantitative measurement to indicate how much has been earned on an 
activity over its duration. Earned progress can be represented by amount, quantity and a 
percentage value. 

Earned progress is based on the progress entered on an activity. Activities can earn progress in 
when progress is entered, or by % of activity budget, when the activity is started and earn 
remaining the remaining percentage when that activity completes. 

Unifier allows you to accumulate and calculate earned progress for an activity as well as 
resources assigned to an activity: 

 Earned Progress is calculated at activity level and each resource assigned to that activity. 

 Earned Progress calculated under a schedule sheet for activity and assigned resources is 
used later in the Earned Value module (in the Cost Manager) to calculate Budgeted Cost of 
Work Performed (BCWP). 

 Earned Progress calculated at the activity level is used when BCWP needs to be 
represented by the cost. 

 Earned Progress calculated at resource assignment level is used when BCWP is 
represented by a unit of measure (for example, Hours). 

To select the % earned calculation method for activities at the schedule sheet level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. 
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3) Under the Default % Earned Calculation Method section, choose an option. This option 
will apply to all activities in the schedule sheet, unless it is overridden by the selection of a 
different option for an individual activity. 

Use this Calculation Method To do this: 

Manual activity % earned and 
resource % earned 

Enter earned progress of activity and resource 
independent of each other. Entering Activity 
earned progress will not update resource earned 
progress and entering resource earned progress 
will not update activity earned progress. 

Manual activity % earned - updates 
resource % earned 

You can select this option only if Manual activity 
% earned and resource % earned is selected. 
Allows you to enter earned progress of an activity 
and resource earned progress will be updated 
automatically. 

Resource updates Activity - 
weighted average of resource costs

Enter earned progress for each resource 
independently. Activity earned progress will be 
read-only and will be automatically calculated 
based on weighted resource cost. 

Following formula will be used. 

(Sum of Resource Cost * Resource Earned 
Progress / Total Activity Work Hours) * 100 

All resources will be considered in this calculation 
including hard booked resources. 

Update Activity and all resources 
on activity start and finish 

% earned on Actual Start and 
Actual Finish 

Allow the system to calculate earned progress 
based on actual start and finish of the activity 

% earned on Actual Start: This option will allow 
user to enter % that should be earned on start of 
the activity. User can enter a value. 

% earned on Actual Finish: This is a read-only 
field. Should always be calculated based on % 
earned on Actual Start. Value for this filed should 
be (100 - % earned on Actual Start). 

If you select this option, earned progress is 
calculated based on Update Activity and all 
resources on activity start and finish of the 
activity. Unifier will automatically calculate earned 
progress for activity and assigned resources 
when actual start and finish dates are entered. 

To select the % earned calculation method for activities at the activity level 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Activity. 
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3) Under the % Earned Calculation Method section, choose an option. This option will apply 
specifically to the selected activity, and will override any default entry method set up at the 
schedule sheet level. The behavior of these % Earned Calculation Method options at the 
activity level is the same as the default options at the schedule sheet level. The exception is 
Lead resource updates Activity and other resources, described in the next step. 

4) Under the activity level, you can select Lead resource updates Activity and other 
resources, and choose resources (including hard booked) that are assigned to the activity 
on the Resource tab. This option allows you to select a resource as a key quantity or a 
Leader. If you select this option and a resource from the drop down menu, then you can 
enter progress on only that resource. 

For example: 

Assume that there is an activity with Resource 1 and Resource 2, with the Earned Progress 
at 0%: 

Resource Work Hours % Complete 

Resource 1 200 0 

Resource 2 500 0 (read-only) 

For a further example, assume that Resource 1 is the key quantity or Leader, with the 
Earned Progress at 30%: 

Resource Work Hours % Complete 

Resource 1 200 30 

Resource 2 500 30 (read-only) 

You can change the Lead resource updates Activity and other resources drop down menu 
selection until there is progress or earned progress entries for the activity or resource. After 
progress or earned progress data is entered, the Budget and Progress Method Setup for the 
activity is disabled and you cannot delete the resource selected as Leader. If you find that 
you must change the settings for the activity, you must delete the activity and start over with 
new data and settings. 

Select CBS codes filtered by workpackage (schedule sheet level only) 

An activity in a schedule sheet can be associated with one or more CBS Codes. This 
assignment is used to create a mapping between costs associated with an activity to a Cost 
Code (CBS Code). Unifier allows you to choose a workpackage to use to filter the CBS codes 
you can select in the Activity Properties, CBS Codes tab. You can choose one workpackage to 
use as a filter. 

Note: The Workpackage must be active and contain CBS codes, and 
also transactions must have occurred using the pertinent CBS codes, or 
the CBS codes tab will not contain codes for you to select. 

To filter CBS codes by workpackage 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. 
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3) Under the Additional Options section, in the Workpackage field, click Select. 

Workpackage selection

Lock the reporting and progress entry period (schedule sheet level only) 

You can prevent users from entering or modifying progress data entries made prior to the 
current week or the current month. These selections allow you to control the activity and 
resource data entered on the Activity Progress window. See Entering Progress in the Activity 
Progress Window (on page 650) for details. 

To specify a restriction on data entry or reporting for progress data 

1) Open a schedule sheet. 

2) Choose File > Budget and Progress Setup > Schedule Sheet. 

3) Under the Additional Options section, in the Reporting Period field, select Week or 
Month. If there is an activity calendar specified, that calendar affects the reporting period for 
these options. 

Reporting Period selections 

4) Check the Do not allow progress entry older than current period checkbox. This 
checkbox works in conjunction with Reporting Period that you select. If you select Week as 
the reporting period then users cannot enter or modify progress entered prior to current 
week; if you select Month as the reporting period then users cannot enter or modify progress 
entered prior to current month. 

5) In addition, you can select Allow editing of last period progress and specify a number of 
working days into the current period. Selecting this option allows users to modify progress of 
the last period (based on the reporting period) until a specified number of days into the 
current period. 

6) Click OK. 

Entering Progress Data on the General and Resource Tabs of Activity Properties 

The Resource Assignment Attribute form (when imported, replaces the Resources tab of the 
Activity Properties and provides data elements to other areas) contains fields related to 
resources assigned to an activity to that allow you to enter effort and expense information 
related to that effort. The Resource Assignment Attribute form allows you to assign a resource to 
a Resource Type, rather than to a hard booked resource. Also, it allows the capture of progress 
with respect to effort, and the base lining of resource assignment. 
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The Schedule Attribute form is used as the General tab of the Activity Properties can also 
include fields that allow you to enter progress and earned progress data. 

The ability to enter progress and earned progress on the Schedule Attribute and the Resource 
Assignment Attribute forms is based on the options selected on the Budget and Progress Setup 
for a given activity. See Setting Up the Budget and Progress Method (on page 637). Fields on 
the forms are editable or read-only and calculated based on the option settings. 

This progress or earned progress is time stamped when entered: 

 For an activity: 

 Date on which the progress or earned progress is entered or calculated. 

 Activity % Complete value 

 Earned Progress value 

 For a resource: 

 Date on which the progress quantity and or earned progress is entered or calculated 

 Progress Quantity value 

 Earned Progress value 

You can access time stamped information through the Activity Progress Log or the Resource 
Progress Log. See Using the Activity Progress and Resource Progress Logs (on page 654) 
for details on the logs. 

The calculations used to derive progress and earned progress are explained in Progress and 
Earned Progress Calculations (on page 655). 

To enter data into the attribute forms 

1) Navigate to a schedule sheet. 

2) Click an activity name. 

3) On the General tab, you can enter progress or earned progress data in these fields, 
depending on settings on the Budget and Progress Setup window, and if the data elements 
for these fields have been added to the Schedule Attribute form and that form has been 
imported: 

 Earned Progress 

 Earned Amount 

 Forecast 1 Start 

 Forecast 1 Finish 

 Activity Percent 1 

4) On the Resource tab, you can enter progress or earned progress data in these fields, 
depending on settings on the Budget and Progress Setup window, and if the data elements 
for these fields have been added to the Resource Assignment Attribute form and that form 
has been imported The fields you see may vary: 

 Resource Name 

 Role Name (Picker) 

 Resource Type 

 Quantity (Qty) 
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 UOM 

 Amount 

 % Units 

 Earned Progress 

 Earned Amount 

 ETC 

 ETC Amount 

 Resource % 1 

Note: You can double-click the resource name to view the Resource 
Assignment Attribute form in view-only mode. 

5) Click Add. 

6) Enter resource data as needed. 

7) Click OK. 

Entering Progress in the Activity Progress Window 

The Activity Progress window allows users to quickly modify the daily activity and resource 
progress data for a selected activity. Users can move down the rows of activities with the Activity 
Progress window open and quickly modify the progress for each activity without having to open 
the activity. 

Note: The Activity Progress window is available only if the Resource 
Assignment Attribute form is designed and imported into Unifier. 

You can access the Activity Progress Log and the Resource Progress Log from the Activity 
Progress window. The logs display the progress data that is entered over time, and allow the 
user to view and modify the progress data for activities and resources. See Using the Activity 
Progress and Resource Progress Logs (on page 654) for details. 

Note: If you enter partial activity progress data, for example enter 
Activity Progress for a day, but do not enter the Resource Progress (or 
enter Resource Progress and do not enter Activity Progress at that time), 
and then save the data, you cannot enter the Resource Progress later 
that day. You can however, enter the progress the next day. 

To view or enter activity progress on the Activity Progress window 

1) Navigate to a schedule sheet. 

2) Highlight an activity name. 
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3) Click the Progress button. The Activity Progress window opens on the right side. 

The Activity Progress and Resource Progress fields are editable or read-only depending on 
settings on the Budget and Progress Method setup window. 

4) Click Save. 

In this field: Do this: 

Activity 
progress as of 

Select a date for which you want to enter progress data. Today’s date 
shows by default. This date is used as the time stamp for progress 
data entered on this window. If you choose a date that conflicts with 
the date restriction you have set up on the Budget and Progress 
Method Setup under Additional Options (see Lock the reporting and 
progress entry period (schedule sheet level only) (on page 648) for 
details) you will receive a warning message. 

If you have select the Reporting Period: 

 Week: You cannot select a date prior to current week. Weeks are 
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counted as Sunday to Saturday. For example, if today is Monday, 
June 22, you cannot select a date prior to Sunday, June 21. 

 Month: You cannot select a date prior to current month. For 
example if the current month is June 2009, you cannot select a 
month prior to June 2009. 

You can select a date in the future if it is in the current period. You 
cannot select a date which is designated as a company holiday on 
company calendar. 

Activity Progress - latest activity progress information 

Activity 
Progress Log 
button 

Click to access the Activity Progress Log. See Using the Activity 
Progress and Resource Progress Logs (on page 654) for details. 
This log displays all activity progress entries made by user. 

Activity 
Percent 
Complete 

Enter or view activity progress data. This field is read-only or editable 
based on settings in Budget and Progress Method setup window for 
the activity. Unless you enter a value, the latest previously-entered 
value is retained in this field. 

Earned 
Progress 

Enter or view activity progress data. This field is read-only or editable 
based on settings in Budget and Progress Method setup window for 
the activity. Unless you enter a value, the latest previously-entered 
value is retained in this field. 

Latest 
Progress as of

View the date on which Unifier last calculated activity progress. 

This field corresponds with Primavera Current Data Date. Unifier 
honors Current Data Date on schedule sheets imported from 
Primavera. 

Latest % 
Complete 

View the latest activity % complete. 

Latest Earned 
Progress 

View the latest earned progress of the activity. 

Resource Progress - latest resource progress information 

Activity 
Progress Log 
button 

Click to access the Resource Progress Log. See Using the Activity 
Progress and Resource Progress Logs (on page 654) for details. 
This log displays all resource progress entries made by user. 

Leader 
Column 

View an icon to indicate the leader selected on the Budget and 
Progress Method Setup window. 

Resource 
Name 

View the name of the resource. This column will show Resource Name 
for each resource from resource assignment form. 

Quantity 
View the quantity for each resource from the Resource Assignment 
Attribute form. 

Progress 
Quantity 

Enter progress quantity. Unless you enter a value, the latest 
previously-entered value is retained in this field. 
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Earned 
Progress 

View the earned quantity of each resource, which is associated with 
the Earned Progress on Resource Assignment Attribute form. Unless 
you enter a value, the latest previously-entered value is retained in this 
field. 

UOM 
View the unit of measure for each resource from the Resource 
Assignment Attribute form. 

Resource Latest Progress - latest progress information for each resource. Select a 
resource listed under Resource Progress to see the latest progress for each resource. 

Resource 
Name 

View the name of the selected resource. 

Progress as of View the latest progress entry date of the resource. 

Progress 
Quantity 

View the latest progress quantity entered. 

Earned 
Progress 

View the latest earned quantity of the resource. 

UOM View the unit of measure for the resource. 

To view or enter activity progress on the Activity Progress window for a summary activity 

1) Navigate to a schedule sheet. 

2) Highlight a summary activity name. 

3) Click the Progress button. The Activity Progress window opens on the right side. For an 
explanation of the fields on this window, see the table below. 

4) Click Save. 

Activity Progress window fields: 

In this field: Do this: 

Activity % 
Complete 

View the activity percent complete for the activities. 

Latest 
Progress as of 

View the latest progress entry date across all leaf activities under the 
selected summary activity. 

Earned 
Progress 

View the latest earned quantity of the activities. 
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Export and Import Activity Progress data 

You can export and import to import Activity Progress using CSV files. This CSV export and 
import functionality is available only if the Resource Assignment Attribute form has been 
imported. 

To export Activity Progress data 

You can export Activity Progress data to a CSV file with latest activity and resource information. 
The CSV will only contain leaf level activities. This is an example of an exported Activity 
Progress CSV file: 

Example of Activity Progress CSV file

In the example, notice that the first column is named Progress as of!. This date is used as a 
timestamp on the progress information. There are two headers in this example file: 

Notice that there is a Leader! Column. This column identifies which row is a leader for an 
activity. This is based on Budget and Progress setup profile option of an activity. If the activity is 
updating all resources then the activity shows Yes in the Leader column. If a resource is 
updated all other resources then the resource shows Yes in the Leader column. For all other 
options, the Leader column will be empty. 

1) In a schedule sheet, choose File > Export > Activity Progress Template. 

2) Modify the CSV file as needed to add activity progress data. 

3) Save the CSV file and import. 

To import Activity Progress data 

1) In a schedule sheet, choose File > Import > Activity Progress. 

2) Browse to select the CSV file to import. 

3) Click OK. 

Using the Activity Progress and Resource Progress Logs 

After entering activity or resource progress data, the user can view or modify the data by going 
to an Activity Progress Log or Resource Progress Log. These logs are accessible only from the 
Activity Progress window. From these logs, the user can view progress effective date, progress 
quantity and earned quantity. The user can also modify the progress and earned quantity data, 
for the most recent entry and for entries in the past, depending on the settings for the editing of 
period progress on the Budget Progress and Method Setup window. See Lock the reporting 
and progress entry period (schedule sheet level only) (on page 648) for details. 
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For example, you might want to use this log to modify data if you need to change past progress 
data based on actual start of data calculation, which saves you from having to delete the activity 
and loose all of the data associated with that activity. 

Note: Modifying log information will not change the current information 
on Schedule Attribute form and Resource Assignment Attribute form 
unless data related to today is modified. 

To view or modify progress data from the Activity Progress or Resource Progress logs 

1) Navigate to a schedule sheet. 

2) Highlight a summary activity name. 

3) Click the Progress button. The Activity Progress window opens on the right side. 

4) Click the Activity Progress Log button or Resource Progress Log button. 

5) Modify progress data as needed. Select the row you want to modify and double click the cell 
that needs to modify. The Progress Quantity or Earned Progress columns can be editable 
depending on settings on Budget and Progress Method Setup window for the activity. 

6) Click Save. 

Progress and Earned Progress Calculations 

Note: The calculations described in this section pertain to the progress 
and earned progress data accumulation and calculation discussed in 
Project Progress Data Accumulation and Calculation (on page 635). 
If you do not need to work with progress or earned progress data to 
ultimately calculate Earned Value, you do not need to read this section. 

This section explains calculations involved in calculating progress and earned progress at 
activity and resource level based on different options selected on Budget and Progress Method 
setup window. The data elements on the Schedule Attribute and Resource Assignment Attribute 
forms are considered and affected by the progress and earned progress calculations are: 

 Activity 

 Total Cost 

 Activity % Complete 

 Earned Progress 

 Earned Amount (Value of this data element is always based on uDesigner design) 

 Resource 

 Role 

 Quantity 

 Rate 

 Amount 

 Resource % Complete (Value of this data element is calculated as (Progress Quantity / 
Quantity) % 

 Progress Quantity 
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 Earned Quantity 

 Earned Amount (Value of this data element is always based on uDesigner design) 

The calculations are described in terms of the calculation options in relation to the % Complete 
and Earned Progress entry method selected: 

 Independently Control % complete and Earned quantity (on page 656) 

 Activity and resource % complete updates % earned (on page 669) 

 Activity and resource % earned updates % complete (on page 673) 

 Do not allow update of % complete and % earned (on page 679) 

See Select the entry method for the % complete and earned progress (on page 642) for 
details on these methods. 

Independently Control % complete and Earned quantity 

This section contains scenarios for calculations based on the entry method Independently 
Control % complete and earned quantity and the % Complete Calculation Method option 
selected. 

Method is Manual activity % complete and resource % complete 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Manual activity % complete and resource % complete. 

% Earned Calculation Method option is Manual activity % earned and resource % earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete and resource % 
complete 

 % Earned Calculation Method option = Manual activity % earned and resource % earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress Manual entry 
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% Earned Calculation Method option is Manual activity % earned - updates resource % 
earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete and resource % 
complete 

 % Earned Calculation Method option = Manual activity % earned - updates resource % 
earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated (read-only) 

(Activity-level Earned Progress * Quantity) 

% Earned Calculation Method option is Resource updates Activity - weighted average of 
resource costs 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete and resource % 
complete 

 % Earned Calculation Method option = Resource updates Activity - weighted average of 
resource costs 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 
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Earned Progress 

Calculated (Weighted Cost) and read-only. 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity Manual entry 

Earned Progress Manual entry 

% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

This combination of settings is not available. 

% Earned Calculation Method option is Update Activity and all resources on activity start 
and finish 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete and resource % 
complete 

 % Earned Calculation Method option = Update Activity and all resources on activity start and 
finish 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress 

Calculated (Weighted Cost) and read-only. 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity Manual entry 

Earned Progress 

Calculated (read-only) based Update Activity 
and all resources on activity start and finish. 

For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 

when Actual Start is entered, Earned Progress 
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= 5% * Quantity 

When Actual Finish is entered, Earned 
Progress = 100% * Quantity. 

Method is Manual activity % complete - updates resource % complete 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Manual activity % complete - updates resource % complete. 

% Earned Calculation Method option is Manual activity % earned and resource % earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete - updates resource % 
complete 

 % Earned Calculation Method option = Manual activity % earned and resource % earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete Manual entry 

Earned Progress Manual entry 

Resource 

Progress Quantity 
Calculated (read-only). 

(Activity-level Activity % Complete * Quantity) 

Earned Progress Manual entry 

% Earned Calculation Method option is Manual activity % earned - updates resource % 
earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete - updates resource % 
complete 

 % Earned Calculation Method option = Manual activity % earned - updates resource % 
earned 

This data entry method scenario results: 
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Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress Manual entry 

Resource 

Progress Quantity 
Calculated (read-only). 

(Activity-level Activity % Complete * Quantity) 

Earned Progress 
Calculated (read-only). 

(Activity-level Earned Progress * Quantity) 

% Earned Calculation Method option is Resource updates Activity - weighted average of 
resource costs 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete - updates resource % 
complete 

 % Earned Calculation Method option = Resource updates Activity - weighted average of 
resource costs 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress 

Calculated (Weighted Cost) 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity 
Calculated (read-only). 

(Activity-level Activity % Complete * Quantity) 

Earned Progress Manual Entry 
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% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

This combination of settings is not available. 

% Earned Calculation Method option is Update Activity and all resources on activity start 
and finish 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Manual activity % complete - updates resource % 
complete 

 % Earned Calculation Method option = Update Activity and all resources on activity start and 
finish 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress 

Calculated (Weighted Cost) 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity 
Calculated (read-only). 

(Activity-level Activity % Complete * Quantity) 

Earned Progress 

Calculated based Update Activity and all 
resources on activity start and finish. 

For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 

when Actual Start is entered, Earned Progress 
= 5% * Quantity 

When Actual Finish is entered, Earned 
Progress = 100% * Quantity. 

Method is Resource updates Activity - weighted avg. of resource hours 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Resource updates Activity - weighted avg. of resource hours. 
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% Earned Calculation Method option is Manual activity % earned and resource % earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource hours 

 % Earned Calculation Method option = Manual activity % earned and resource % earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete

Calculated (Weighted Hours) and (read-only). 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Quantity)] / 
Sum of (Resource Quantity) } * 100 

Only hard booked resources will be 
considered. 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress Manual entry 

% Earned Calculation Method option is Manual Activity % earned - updates resource % 
earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource hours 

 % Earned Calculation Method option = Manual activity % earned - updates resource % 
earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and (read-only). 

{Sum of [ (Resource Progress Quantity / 
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Resource Quantity) * (Resource Quantity)] / 
Sum of (Resource Quantity) } * 100 

Only hard booked resources will be 
considered. 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated 

(Activity-level Earned Progress * Quantity) 

% Earned Calculation Method option is Resource updates Activity - weighted avg. of 
resource costs 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource hours 

 % Earned Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and (read-only). 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Quantity)] / 
Sum of (Resource Quantity) } * 100 

Only hard booked resources will be 
considered. 

Earned Progress 

Calculated (Weighted Cost) 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity Manual entry 

Earned Progress Manual entry 
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% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

This combination of settings is not available. 

% Earned Calculation Method option is Update Activity and all resources on activity start 
and finish 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource hours 

 % Earned Calculation Method option = Update Activity and all resources on activity start and 
finish 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete

Calculated (Weighted Hours) and (read-only). 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Quantity)] / 
Sum of (Resource Quantity) } * 100 

Only hard booked resources will be 
considered. 

Earned Progress 

Calculated (Weighted Cost) 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity Manual entry 

Earned Progress 

Calculated based Update Activity and all 
resources on activity start and finish. 

For example: If % earned on Actual Start = 
5% and % earned on Actual Finish = 95 % 
then, 

When Actual Start is entered, Earned 
Progress = 5% * Quantity 

When Actual Finish is entered, Earned 
Progress = 100% * Quantity. 
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Method is Resource updates Activity - weighted avg. of resource costs 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Resource updates Activity - weighted avg. of resource costs. 

% Earned Calculation Method option is Manual activity % earned and resource % earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

 % Earned Calculation Method option = Manual activity % earned and resource % earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered. 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress Manual entry 

% Earned Calculation Method option is Manual activity % earned - updates resource % 
earned 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

 % Earned Calculation Method option = Manual activity % earned - updates resource % 
earned 

then this data entry method scenario results: 
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Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All booked resources will be considered. 

Earned Progress Manual entry 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated 

(Activity-level Earned Progress * Quantity) 

% Earned Calculation Method option is Resource updates Activity - weighted avg. of 
resource costs 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

 % Earned Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered. 

Earned Progress 

Calculated (Weighted Cost). 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 
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Progress Quantity Manual entry 

Earned Progress Manual entry 

% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

This combination of settings is not available. 

% Earned Calculation Method option is Update Activity and all resources on activity start 
and finish 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

 % Earned Calculation Method option = Update Activity and all resource on activity start and 
finish 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered. 

Earned Progress 

Calculated (read-only) based Update Activity 
and all resources on activity start and finish. 

For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 

When Actual Start is entered, Earned 
Progress = 5% 

When Actual Finish is entered, Earned 
Progress = 100% 

Resource 

Progress Quantity Manual entry 

Earned Progress 

Calculated (read-only) based Update Activity 
and all resources on activity start and finish. 

For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 
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When Actual Start is entered, Earned 
Progress = 5% * Quantity 

When Actual Finish is entered, Earned 
Progress = 100% * Quantity. 

Method is Lead resource updates Activity and other resources 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Lead resource updates Activity and other resources. There is only one data 
entry scenario for this setting. 

% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Independently Control % complete and 
earned quantity 

 % Complete Calculation Method option = Lead resources updates Activity and other 
resources. 

 % Earned Calculation Method option = Lead resource updates Activity and other resources 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered. 

Earned Progress 

Calculated (Weighted Cost) and read-only. 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Resource 

Progress Quantity 

Manual Entry (Only resource that is selected 
under drop-down). For all other resources, 
Progress Quantity will be calculated based on 

(Leader Progress Quantity / Leader Quantity) 
* Resource Quantity 

Earned Progress Manual Entry (only resource that is selected 
under drop-down). For all other resources, 
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Progress Quantity will be calculated based on 

(Leader Earned Quantity / Leader Quantity) * 
Resource Quantity 

Activity and resource % complete updates % earned 

This section contains scenarios for calculations based on the entry method Activity and 
Resource % Complete Updates % Earned and the % Complete Calculation Method option 
selected. 

Method is Manual activity % complete and resource % complete 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Manual activity % complete and resource % complete. There is only one data 
entry scenario for this setting. 

% Earned Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % complete updates 
% earned 

 % Complete Calculation Method option = Manual activity % complete and resource % 
complete 

 % Earned Calculation Method option = Not available 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress 
Calculated (read-only) 

Same as Activity % Complete 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated (read-only) 

Same as Progress Quantity 
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Method is Manual activity % complete - updates resource % complete 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Manual activity % complete - updates resource % complete. There is only one 
data entry scenario for this setting. 

% Earned Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % complete updates 
% earned 

 % Complete Calculation Method option = Manual activity % complete - updates resource % 
complete 

 % Earned Calculation Method option = Not available 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Manual entry 

Earned Progress 
Calculated (read-only) 

Same as Activity % Complete 

Resource 

Progress Quantity 
Calculated (read-only) 

(Activity-level Activity % Complete * Quantity) 

Earned Progress 
Calculated (read-only) 

Same as Progress Quantity 

Method is Resource updates Activity - weighted avg. of resource hours 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Resource updates Activity - weighted avg. of resource hours. There is only 
one data entry scenario for this setting. 

% Earned Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % complete updates 
% earned 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource hours 

 % Earned Calculation Method option = Not available 
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then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Only hard booked resources will be considered

Earned Progress 
Calculated (read-only) 

Same as Activity % Complete 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated (read-only) 

Same as Progress Quantity 

Method is Resource updates Activity - weighted avg. of resource costs 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Resource updates Activity - weighted avg. of resource costs. There is only 
one data entry scenario for this setting. 

% Earned Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % complete updates 
% earned 

 % Complete Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

 % Earned Calculation Method option = Not available 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

Only hard booked resources will be considered
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Earned Progress 
Calculated (read-only) 

Same as Activity % Complete 

Resource 

Progress Quantity Manual entry 

Earned Progress 
Calculated (read-only) 

Same as Progress Quantity 

Method is Lead resource updates Activity and other resources 

This section contains scenarios based on the option selected for % Complete Calculation 
Method being Lead resource updates Activity and other resources. There is only one data 
entry scenario for this setting. 

% Earned Calculation Method option is Lead resource updates Activity and other 
resources 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % complete updates 
% earned 

 % Complete Calculation Method option = Lead resource updates Activity and other 
resources 

 % Earned Calculation Method option = Lead resource updates Activity and other resources 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Progress Quantity / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered 

Earned Progress 
Calculated (read-only) 

Same as Activity % Complete 

Resource 

Progress Quantity 

Manual entry. (Only resource that is selected 
under drop-down). For all other resources, 
Progress Quantity will be calculated based on 

(Leader Progress Quantity / Leader Quantity) 
* Resource Quantity 
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Earned Progress 
Calculated (read-only) 

Same as Progress Quantity 

Activity and resource % earned updates % complete 

This section contains scenarios for calculations based on the entry method Activity % Earned 
and Resource % Earned Updates % Complete and the % Earned Calculation Method option 
selected. 

Method is Manual activity % earned and resource % earned 

This section contains scenarios based on the option selected for % Earned Calculation Method 
being Manual activity % earned and resource % earned. There is only one data entry 
scenario for this setting. 

% Complete Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % earned updates 
% complete 

 % Complete Calculation Method option = Not available 

 % Earned Calculation Method option = Manual activity % earned and resource % earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (read-only) 

Same as Earned Progress 

Earned Progress Manual entry 

Resource 

Progress Quantity 
Calculated (read-only) 

Same as Earned Progress 

Earned Progress Manual entry 

Method is Manual activity % earned - updates resource % earned 

This section contains scenarios based on the option selected for % Earned Calculation Method 
being Manual activity % earned - updates resource % earned. There is only one data entry 
scenario for this setting. 
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% Complete Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % earned updates 
% complete 

 % Complete Calculation Method option = Not available 

 % Earned Calculation Method option = Manual activity % earned - updates resource % 
earned 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete
Calculated (read-only) 

Same as Earned Progress 

Earned Progress Manual entry 

Resource 

Progress Quantity 
Calculated (read-only) 

Same as Earned Progress 

Earned Progress 
Calculated (read-only) 

(Activity-level Earned Progress * Quantity) 

Method is Resource updates Activity - weighted avg. of resource costs 

This section contains scenarios based on the option selected for % Earned Calculation Method 
being Resource updates Activity - weighted avg. of resource costs. There is only one data 
entry scenario for this setting. 

% Complete Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % earned updates 
% complete 

 % Complete Calculation Method option = Not available 

 % Earned Calculation Method option = Resource updates Activity - weighted avg. of 
resource costs 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 
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Activity % 
Complete 

Calculated (read-only) 

Same as Earned Progress 

Earned Progress 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / 
Sum of (Resource Amount) } * 100 

All resources will be considered 

Resource 

Progress Quantity 
Calculated (read-only) 

Same as Earned Progress 

Earned Progress Manual entry 

Method is Lead resource updates Activity and other resources 

This section contains scenarios based on the option selected for % Earned Calculation Method 
being Lead resource updates Activity and other resources. There is only one data entry 
scenario for this setting. 

% Complete Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % earned updates 
% complete 

 % Complete Calculation Method option = Not available 

 % Earned Calculation Method option = Lead resource updates Activity and other resources 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % 
Complete 

Calculated (read-only) 

Same as Earned Progress 

Earned Progress 

Calculated (Weighted Hours) and read-only. 

{Sum of [ (Resource Earned Progress / 
Resource Quantity) * (Resource Amount)] / Sum 
of (Resource Amount) } * 100 

Resource 

Progress 
Quantity 

Calculated (read-only) 

Same as Earned Progress 

Earned Progress
Manual Entry (Only resource that is selected 
under drop-down). 
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For all other resources, Earned Progress will be 
calculated based on(Leader Earned Progress / 
Leader Quantity) * Resource Quantity 

Method is Update Activity and all resources on start and finish 

This section contains scenarios based on the option selected for % Earned Calculation Method 
being Update Activity and all resources on activity start and finish. There is only one data 
entry scenario for this setting. 

% Complete Calculation Method options are not available 

If the entry method and option settings on the Budget and Progress Method Setup window are: 

 % Complete and Earned Progress entry method = Activity and resource % earned updates 
% complete 

 % Complete Calculation Method option = Not available 

 % Earned Calculation Method option = Update Activity and all resources on activity start and 
finish 

then this data entry method scenario results: 

Activity or 
Resource 

Data Element Data Entry Method 

Activity 

Activity % Complete
Calculated (read-only) 

Same as Earned Progress 

Earned Progress 

Calculated (read-Only) based Update Activity 
and all resources on activity start and finish. 

For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 

When Actual Start is entered, Earned 
Progress = 5% 

When Actual Finish is entered, Earned 
Progress = 100% 

Resource 

Progress Quantity 
Calculated (read-only) 

Same as Earned Progress 

Earned Progress 
Calculated (read Only) based Update Activity 
and all resources on activity start and finish. 
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For example: If % earned on Actual Start = 5% 
and % earned on Actual Finish = 95 % then, 

When Actual Start is entered, Earned 
Progress = 5% * Quantity 

When Actual Finish is entered, Earned 
Progress = 100% * Quantity. 

Creating Schedule Manager Custom Calendars 

Unifier allows you to create Custom Calendars to be used by the Schedule Manager. The 
Custom Calendar that you specify can override the company-level Standard Calendar. If there is 
no Custom Calendar, the Standard Calendar marked as the default calendar is the calendar that 
is used by the Schedule Manager. 

Unifier allows you to create multiple Custom Calendars, enabling you to create a library of 
calendars that can be selected for use on your schedule sheets. The multiple calendars enable 
you to have calendars to support varying work schedules (depending on locality) and to account 
for holidays and other non-working days. For example, some countries in the Middle East have 
weekends that are other than Saturday and Sunday. 

You must have permissions granted to create, modify, delete, or view Custom Calendars. 

About Calendars and Activities 

When you select or change an activity calendar, the calendar affects the following dates and 
date pickers: 

 Start Date date picker 

 Finish Date date picker 

 Duration calculation 

 Actual Start Date date picker 

 Actual Finish Date date picker 

 Actual Duration 

 Forecast Start calculation 

 Forecast Finish calculation 

 Forecast Duration calculation 

 Critical Path 

 Estimate dates 

 Estimate duration 

 Float calculation 

 Progress window Progress As Of Date date picker 

 Budget and Progress options Do not allow progress entry older than the current period
and Allow editing of last progress

 Any date or date only picker data element 
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This is how the dates are changed when the activity calendar changes. Changes occur when the 
schedule sheet is refreshed. 

 Activity (not started): If the Start Date is affected by a new activity calendar, the Start Date 
and Finish Date will change to keep the Duration as specified. The system will use the next 
day on the calendar. 

 Activity (not started): If the Finish Date is affected by a new activity calendar, the system will 
select either a previous or next working day on the calendar. 

 Activity (in progress): If the Finish Date is affected by a new activity calendar, the system will 
select either a previous or next working day on the calendar. The Start Date is not affected in 
this case. 

 Activity (completed): No impact on Start Date or Finish Date for the activity. 

Create a custom calendar in the schedule manager 

To create a custom calendar in the Schedule Manager, you must have Create permission. You 
can create a new calendar manually, or by copying and modifying an existing calendar. 

To create Custom Calendars 

1) In User Mode, select the project or shell, and select Schedule Manager > Custom 
Calendars. The Custom Calendars log window opens. 

2) Click New. The Calendar Properties window opens. 

3) Enter the calendar name and an optional description. 

4) Specify the working and non-working days for the calendar you are creating. Browse to the 
month and year using the pull-down menus at the top of the calendar. Saturdays and 
Sundays are set as non-working days by default. Do one of the following: 

 To set a particular date as a non-working day (for example, a holiday), click the date on 
the calendar and select Non Working. The date will appear greyed out, and will not be 
used in date calculations. 

 To set a non-working day as a working day, click a greyed cell and select Working. 

 To set a particular day of the week (for example, every Saturday) as a non-working day, 
click the day at the top of the calendar (for example "Sat"), then click Non Working. All 
Saturdays in the calendar will be changed to non-working days (grey). 

 To set a particular day of the week as a working day, click the day at the top of the 
calendar, then click Working. 

 If you only want to set the day of the week in a particular month as working or 
non-working days, select each day individually and click Working or Non Working. 

Note: If you have marked the day of the week as a non-working day 
throughout the calendar by selecting the day at the top of the calendar 
(for example "Sat"), then you will not be able to mark individual days 
(that is, individual Saturdays in this example) as working days. To be 
able to include both working and non-working instances of a day of the 
week on the calendar, you must select them individually. 

5) Click OK. 
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To copy an existing calendar 

1) In User Mode, select the project or shell, and select Schedule Manager > Custom 
Calendars. The Custom Calendars log window opens. 

2) Select a calendar in the log. 

3) Click Copy. The Calendar Properties window opens with the calendar description and 
calendars days specified. You can copy from Standard (Company level) or Custom (project 
or shell level) calendars. 

4) Enter the calendar name and change the optional description as needed. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Browse to the calendar months you want to modify. Select the calendar day and 
click the Working or Non Working radio buttons as needed. 

6) Click OK. 

Do not allow update of % complete and % earned 

When the Do not allow update of % complete and % earned entry method is selected, these 
fields are disabled. 

 Activity 

 Activity % Complete 

 Earned Progress 

 Resource 

 Resource % Complete 

 Progress Quantity 

 Earned Quantity 

P6 Summary Sheets 

Unifier allows you to store summarized data from P6 in the P6 Summary Sheets node. 

Refer to the Unifier Earned Value Management User Guide for more details about Activity 
Sheets and P6 Summary Sheets. 

To view the P6 Summary Sheets node in a Project or Shell, User mode, the Project or Shell 
attribute form must have the Data Element (DE) uuu_int_schedule_type, and you (User) must 
have the appropriate permissions for accessing the node. 

The placement of P6 Summary Sheet node under the Schedule Manager is by default. A User 
can move P6 Summary Sheet node under other Summary nodes (Example: Cost Manager) if 
needed. 

The P6 Summary Sheets node contains one sheet, or more, that contains “summarized” P6 
data: 

 Master Summary Sheet

Contains summarized data from the P6 Project and the sheet is linked to the current Project 
or Shell. 
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Note: the Master Summary Sheet is not displayed as "Master" in the Master Summary Sheet 
properties. 

 Baseline Summary Sheet

A P6 Project can contain any number of baselines, or not baselines at all. A baseline is a 
copy of the P6 Project that contains frozen data per Data Date. You can select to bring 
summarized baseline data from a P6 Project to Unifier, via Gateway. The Baseline Summary 
Sheets that you bring to Unifier, from a P6 Project, reside in the Master sheet below the P6 
Summary Sheets node, in Unifier. 

Note: The Baseline Summary Sheet appears as an additional Schedule Sheets node under 
the Schedule Manager. 

Notes:  

 When a P6 User enters the actual and progress data in P6 Schedule, 
the date is displayed as "Progress as of" date in P6 Schedule. 

 You cannot create a new P6 Summary Sheet in Unifier, manually. 
Unifier allows a total of 12 summary sheets to be integrated: 1 
current Schedule Summary sheet and 11 Baseline Summary Sheets, 
or 12 Baseline Summary Sheets. 

Schedule Sheet Integration 

Unifier supports out of the box (OOTB) mapping for integration between P6 and Unifier, using 
Schedule Sheets.  

This OOTB mapping is available as part of Project Control installation as a shell template 
(T-002). You must create a new shell by copying shell template (T-002) in order to integrate P6 
and Unifier using Schedule Sheets. 

To view the data mapping fields in Unifier: 

1) Go to Company Workspace > Admin mode > Templates > Shells > Projects. 

2) Open the T-002 (Project #) Owner Project Template(Project Name). 

3) From the left-hand navigator, click Schedule Manager > Schedule Sheets. 

4) In the Schedule Sheets log, open Project Schedule Sheet. 

5) From the menu bar, click File > Data Mappings. 

6) Click P6 (to select) > Modify > Activity tab. 

The column name and XML elements are listed as shown below. You can use the XML 
elements for integration with P6. 

Column XML Element 

Activity Name Name 

Activity Percent PercentComplete 

Actual Finish Date ActualFinishDate 

Actual Start Date ActualStartDate 
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Column XML Element 

Duration PlannedDuration 

Early Start date EarlyStartDate 

Early finish date EarlyFinishDate 

Finish date PlannedFinishDate 

Late Start date LateStartDate 

Late finish date LateFinishDate 

P6 Activity Number Id 

P6 CBS CBSCode 

Start date PlannedStartDate 

Auto-Scheduling of Activities 

You can disable automatic re-scheduling within Unifier Schedule Sheet to:  

 Schedule Activities manually. 

 Integrate Activities with their dependencies with the same schedule as exists in P6 and MPP. 

Disabling Automatic Scheduling of Activities 

When Activities with dependencies are integrated by Direct Integration with P6, or imported 
through MPP XMLS, the activities are re-scheduled automatically within Unifier Schedule Sheet 
to honor the dependencies, leading to Data change. You can disable this automatic reschedule 
in Schedule sheet to integrate or import the data as is and to schedule the Activities manually, if 
desired. 

To enable or disable auto-scheduling: 

1) Go to the Schedule Sheet Properties window, General tab. 

2) Select your option in Auto-Schedule field. The default selection is Enable. 

In the Schedule Sheets log, the column Auto-Schedule displays the condition of the sheet. 

When the auto-scheduling is disabled: 

 You will be able to edit the Activity Properties of a particular Activity, for example Start 
Date, Finish Date, Duration, Predecessor, Dependencies, etc. The properties of the 
dependent activities are not impacted because of disabling automatic scheduling is disabled. 

 You can, manually, reschedule the schedule sheet to implement your changes by refreshing 
it through manual Schedule refresh, Cost and Schedule refresh, or enabling scheduled 
refresh (Set Frequency). These options are available under Refresh option in the log 
toolbar. 
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 After changing the Activity Properties of individual activities, when the schedule sheet is 
refreshed manually or through Schedule refresh, then the entire schedule sheet will be 
re-scheduled. The impact on dependent activities can be reviewed after refresh. 

 The refresh status of schedule sheet is displayed on Schedule Sheet Refresh window 
(History Details window). 

 No updates will take place for resource rates on the master schedule sheet and also update 
to shell cost sheet with corresponding assignment costs until you allow manual scheduling 
through manual or Schedule refresh. Once the schedule sheet is manual scheduled, the 
updates will take place. 

 On clicking Update > Resource Utilization (on the master schedule sheet) and also Update 
> Resource Utilization and Cost Manager, the following alert message is displayed: 
Cannot update cost till Sheet is scheduled.

Calendar

When the calendar that is defined for a particular Activity is changed in the Activity 
Properties, then Unifier changes the Finish Date. In this case, if the auto-scheduling is 
disabled, then no impact of this change is reflected in the dependent activities. 

When the calendar that is defined for a particular Schedule Sheet is changed in the 
Schedule Sheet Properties, then the next time you open the schedule sheet, the following 
message is displayed: Schedule sheet requires a refresh due to modifications to a Calendar 
or Rates associated to a Role on a Resource. Do you want to refresh schedule sheet?

If you select Yes, then the schedule sheet will be rescheduled on refresh, as an impact of 
Calendar change, irrespective of whether Auto-scheduling is enabled or disabled. 

If you select No, then no impact of Calendar change is reflected in the schedule sheet. 
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Unifier Activity Manager 

Unifier enables you to create, consolidate, and monitor activities that must be completed on a 
schedule by way of the Activity Manager.  

Refer to the Unifier Earned Value Management User Guide for details about the Unifier Activity 
Manager, Master Rate Sheet, and Rate Sheet.  
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Unifier Space Manager 

In Unifier, the Space Manager is where you can perform the tasks of facilities management. The 
Space Manager integrates the AutoCAD® application to provide drawing and modeling 
capabilities for your architectural, layout, and design needs. 

Notes:  

 The Space Manager is only available to shells; it cannot be used in 
the Projects (Standard) node. 

 You cannot view .DWF files in Google Chrome or Mozilla Firefox 
browsers. To view .DWF files, use Microsoft Internet Explorer. 

Using the Space Manager, you can gather data about the levels in your facility (such as floors 
and parking lots) and the spaces that exist on each level (cubicles, offices, conference rooms, 
etc.). Each level is supported by an AutoCAD® drawing. You can enter individual spaces into 
Unifier, or directly onto an AutoCAD® drawing and classify them into categories (such as 
common areas, or usable space) to make managing them more efficient. Similar to the Asset 
Manager, categories (called types) of spaces can be designed in uDesigner, and you can then 
add records of individual spaces to these types and manage them on an electronic sheet. 

The Space Manager is a means of organizing all the square footage in your facility to make 
monitoring, maintaining, and revising your facility more efficient. The Space Manager can be 
integrated with other managers or business processes to give you a broader view of your 
company’s physical capital and resources. For example, the Space Manager can be integrated 
with the Asset Manager to include the computers that reside in each cubicle on a level; or 
integrated with the Resource Manager to include the employees who occupy each space on a 
level. 

In uDesigner, one attribute form is designed for a “level” type in your facility and multiple attribute 
forms for “spaces” types. With these attribute forms, you can create a hierarchy of levels and 
spaces within levels to store the facilities data you choose to collect. 

In Unifier, the Sheets node in the Space Manager stores the manager sheet on which all the 
levels in your facility are shown. Unifier automatically creates a level sheet for every level type 
that is created. On these sheets, you can import and export drawing files to and from 
AutoCAD®, and also import and export column data. From the level sheet, you can also 
automatically update individual level records with data added to the sheet, either manually or via 
a formula created for a column. 

The Stack Plans node is where you can create stack plans to show the actual usage of the 
levels in the company’s building(s). You can choose the information (data elements or specific 
spaces) you want to see on the stack plan and update the plan periodically to keep abreast of 
changes in the levels’ space usage. For example, you might want to know the square footage 
used by each department on each floor (level); or how many square feet of a floor are vacant 
versus leased. 
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The Levels node lists all the levels that exist in your facility. Each level is supported by an 
AutoCAD® drawing. This node is where you can create new levels or update existing ones, 
download drawing files, attach a drawing to the level, and print the drawing. This is where you 
can create new levels or update existing ones, import data from CSV files, export templates to 
CSV. 

The Spaces node shows a list of all the space types, and under the space type sub-node, all the 
spaces that exist in your facility. This is where you can create new spaces or update existing 
ones, import data from CSV files, export templates to CSV, and select spaces to view on the 
level drawing. 

The Space Manager allows you to identify floors and each space by type and associate 
attributes to the particular spaces. For example, a multi-floor building could have many types of 
spaces, such as offices, cubicles, restrooms, conferences room, laboratories, and eating areas. 

You manage spaces according to space type. Examples of space types are: 

 Gross measured area, which is the entire square footage of a floor, from wall to wall 

 Common area, such as hallways, lobbies, and entrances 

 Usable space, such as cubicles, offices, and conference rooms 

 Vertical penetration, which includes elevators, stairwells, and columns 

The Space Manager is available within a shell. Each shell can have only one Space Manager. A 
building is at the shell level. An example hierarchical arrangement of objects in the Space 
Manager is as follows: 

 Buildings (shell level) 

 Levels (Floors) of the building or other similar structures (in this case, Floor is an example 
of a level record) 

 Spaces in the building. These are the various spaces in the structure, such as 
storage rooms, offices, and other interior spaces (space records). Spaces is a 
fixed node designed in uDesigner. 

The Space Manager includes a sheet to help you manage levels and spaces. The sheet will 
allow you to create formulas to calculate total leasable and rentable space for a facility or 
building. 

uCAD Plug-In 

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in 
application, which can be downloaded from Unifier. uCAD enables: 

 Authoring of space objects in AutoCAD® 

 Identifying spaces on a floor drawing and link them to Unifier space objects 

 Associate a drawing file to a Unifier level record 

 Transferring changes to level and space records between the Unifier Space Manager 
and AutoCAD® 

Space Manager prerequisites 

 Generic or CBS shells configured 

 Level and space attribute forms defined in uDesigner 
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 uCAD plug-in and AutoCAD® installed on your desktop (if you are going to use the 
Space Manager with the optional AutoCAD® integration) 

The Unifier uCAD Installation and User Guide is also available from the Unifier Support 
window, on the Download tab. After you download the uCAD plug-in you can access 
uCAD from the Windows Start menu > Programs> uCAD. When you install the plug-in, 
the uClient Configurator is also installed. 

The Unifier uCAD Installation Guide is available in the uCAD Help menu. 

 AutoVue installed and properly licensed, which is used to view the uploaded drawing files 
within the Space Manager window. 

For information about language (internationalization) and CSV files refer to Unifier General User 
Guide. 
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Accessing the Space Manager 

The Space Manager is available within a shell. Each shell can have one space manager. 

To access the Space Manager: 

1) In user mode, select the shell that you are working in. 

2) In the shell, Click the Space Manager module to open. 

3) Click the appropriate node to access a level or space. 

Quick Calendar 

The Quick Calendar is available for Space Manager. For details, refer to the "Working with Quick 
Calender Entry" section in the Unifier Business Processes User Guide.  
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Working with Levels (Standard View) 

The Levels log enables you to view record summary, take actions from the log, and make log 
adjustments as explained in the following sections.  

When you select a record in the log, Unifier opens a pane (on the right-hand side of the page), 
Record Details tab, that enables you to view the details of the selected record. In addition, you 
can: 

 Print the log based on the current view. This would output a report similar to a UDR. 

 Select the order of the columns in the log and define which columns must be visible. 

 Sort on one or many columns within the log. 

 Group based on one column, or up to 3 columns, and define how the groups are sorted and 
how rows are sorted within the groups. 

 Apply filters to individual columns. 

 Lock columns so that they are fixed on the left-hand side and the remaining columns scroll 
on the right-hand side. 

Note: For details about the existing functionalities, not described in this 
section, refer to the topics under the Unifier Space Manager. 

Levels Log Options (Standard View) 

Levels log toolbar options: 

 Create

 Actions

 Import

 Export CSV Template

 Bulk Edit

 Last Import Log

Enables you to open the Last Import Log window which displays the pertinent 
information. 

 Download drawing file

Enables you to download the drawing file that is associated with the level. 

 Upload drawing file

Enables you to upload the drawing file that is associated with the level. 

 View

The system-defined views are: 

 All Records

 Records Created by Me

 Create New View

 Manage Views

 Edit View

Enables you to change the View settings. 
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 Refresh

 Printing the log content

 Search as defined in uDesigner

 Find on Page

 Help

The gear ( ) menus: 

 Open

 Copy

 View on Drawing

 View Spaces (Spaces) 

Enables you to open the space picker field. The title is "Spaces on <Level Name>," and the 
floor name is considered the level name value for the level that you select. 

 Print - HTML

 Print - PDF

 Print - Custom

Note: If an attribute form is present, then you can hover over the 
question mark (?) symbol to see more information in the form of a tooltip.  

Creating a New Level Record (Standard View) 

To create a new level: 

1) Go to your project (User mode).  

2) Click Space Manager to expand. 

3) Click Levels to open the log. The log is divided into two panes. The left-hand pane contains 
the toolbar options and columns which provide details about the level. The right-hand pane 
(properties pane) contains the following tabs: 

 Record Details

 Permissions

4) Click Create. 

5) When the Create New Levels window opens, enter the values in the required fields. At this 
point, you are creating the floor details. If the properties window is not open, click the three 
vertical dots icon (located on the right-hand border of the Create New Levels window, in the 
middle) to open the properties pane. The properties pane contains the following tabs: 

 Comments

Contains additional details about the record. You can add comments to the space 
attribute in the edit mode, only. 

 Linked Records

Enables you to link records to the space attribute. The functional flow is similar to that of a 
non-Workflow BP. 
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 Linked Mail

Enables you to link email to the space attribute. The functional flow is similar to that of a 
non-Workflow BP. 

6) When finished, click Submit. 

7) When the log appears, click the refresh icon to refresh the screen. Review your recently 
created level. 

The details of a level: 

1) Open a level from the log to see the level window. The window is divided into two panes. 
The left-hand pane contains the following blocks: 

 General

 Floor Plan Image

The right-hand pane (properties pane) contains the following tabs: 

 Comments

 Linked Records

 Linked Mail

 Audit Log

Lists all the actions taken by a user (Bulk Edit, Create, etc.) 

 Level Content

The toolbar options are Edit and the horizontal lines icon drop-down arrow (hamburger icon). 
Use the hamburger icon to print, view spaces, access help, or close the record. Depending 
on the availability of associated images, the menu options can change (View Drawing). The 
View Spaces option enables you to access information about any space associated with the 
level, if any. Records with associated drawings have a file icon next to the record, on the log. 

2) If you change or add any information, click Submit to make your changes a part of reference 
record to the level details or content. Click the Level Content tab to see the details. 

To copy an existing level record:  

1) In User Mode, in the shell, select Space Manager > Levels. 

2) In the level log, select a level and select Copy. The levels form opens with the information 
from the original level record. 

3) Modify the form as needed. 

4) Click Finish Editing to save the new level record. 

Exporting and Importing CSV Level Templates and Records (Standard View) 

1) Navigate to the Space Manager levels log. 

2) Click the Export Template button. The exported CSV template is based on the Integration 
interfaced design of Level that was created in uDesigner. 

3) Save the CSV file to your desktop. 
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To modify an imported file 

1) Open the CSV file in Microsoft Excel or a compatible software application. You can also edit 
the CSV file in a text editor such as Notepad. 

2) Add data to the CSV file, one record per row. Do not add, move, or delete columns or 
change the structure of the file. 

3) Save the file. 

Note: Excel 2003 cannot handle CSV files with 15 or more rows. In CSV 
files, columns are separated with commas. When you open a CSV file 
with Excel that has empty columns at the end of the file, Excel drops the 
additional commas from the 15th row onward, resulting in an error when 
you try to import the file. To work around this problem, do one of the 
following: 

 Add your data to the CSV file in Excel and save the file. Then reopen 
the file in a text editor such as Notepad, find the rows that have the 
missing commas, and add the additional commas to these rows. 

 Use the text editor instead of Excel to modify column values in the 
CSV file. 

To import CSV files or drawing files 

1) In the Space Manager, select the level which you want to import the new record or drawing 
file. Be sure that you are importing the correct file. 

2) Click Import. 

3) In the File Upload window, browse for the file and click OK. 

Unifier checks the file for the following items to make sure that valid records are created: 

 The file format of the imported file matches the interface design created in uDesigner. 

 Make sure that you are importing into the same log from which you exported the CSV 
template file. 

 The required fields contain data in the correct format. 

If an error occurs, an error message gives you the option to save a text file that lists the 
errors. 

To view the import validation error file 

1) At the import error message, click Yes. You can then choose Open to open the file or Save 
to save the file to your local machine. 

2) The error file is a CSV file. Click on a cell to view the full contents of the listed error. 

3) After fixing the errors, you can use this file to re-import the records. 

Opening Levels (Standard View) 

You can view any of the level or space records in the logs. If there are many records listed in a 
level or space log, you can use search criteria to narrow the options. 
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To view a level record and its associated drawing 

1) In User Mode, in the shell, select Space Manager > Levels.

2) Select a level record from the log window and click the Open button to open the levels detail 
page. 

3) Click the Spaces option (on the toolbar) to view the associated spaces of the selected level. 
To view the space records of a particular space type, click the Space Type drop-down menu 
and select the desired space type. 

To view the level on the associated drawing, click View on Drawing option on the toolbar. 

Locating and Opening Space Records from Within a Level Record (Standard View) 

Note: This is only available if there is a drawing file associated with level 
record and the user used uCAD to author space objects in AutoCAD®. 

To highlight space records in a level record on a drawing 

1) In User Mode, in the shell, select Space Manager > Levels. 

2) Select a level. 

3) Click Open. 

4) Select a space record from the bottom of the window. If the space record selected is 
associated with a drawing using uCAD then the corresponding spaces in the drawing will be 
highlighted. 

To open a space record from a level 

1) In User Mode, in the shell, select Space Manager > Levels. 

2) Select a level. 

3) Click Open. 

4) Select a space record in the bottom portion of the window. 

5) Click Open. The detail form for the selected space record opens. 

You can highlight the entire floor and view all available spaces. 

Downloading a Drawing File to a Level Record (Standard View) 

You can download a drawing to the level record from the Levels log, or from the level record 
itself. This action is possible only if a drawing has already been imported and associated with 
the level. Downloading a drawing file downloads a read-only copy of the drawing, which you can 
modify for this Space Manager session only. Any changes you make to the drawing will not be 
permanent. 

Note: For security, the Company Administrators can specify the list and 
size of files that can be uploaded to the Company Properties page, by 
users and per company policy. Contact your Company Administrator for 
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more information. 

Download a drawing file 

1) Do either of the following: 

 On the Levels log, select the level and click the Download button. The Download Files 
and Folders window opens. 

 Open the level record and click the Download button. The Download Files and Folders 
window opens. 

2) Use the Save In field and the list of folders beneath it to navigate to the directory where you 
want the drawing file to reside. 

3) Specify the Document Download Options, if necessary. 

4) Click Save. 

Working with Space Log (Standard View) 

The Space log enables you to view record summary, take actions from the log, and make log 
adjustments as explained in the following sections.  

When you select a record in the log, Unifier opens a pane (on the right-hand side of the page), 
Record Details tab, that enables you to view the details of the selected record. In addition, you 
can: 

 Print the log based on the current view. This would output a report similar to a UDR. 

 Select the order of the columns in the log and define which columns must be visible. 

 Sort on one or many columns within the log. 

 Group based on one column, or up to 3 columns, and define how the groups are sorted and 
how rows are sorted within the groups. 

 Apply filters to individual columns. 

 Lock columns so that they are fixed on the left-hand side and the remaining columns scroll 
on the right-hand side. 

Opening Space Records (Standard View) 

To open a Space record follow these steps: 

1) User mode > Shell > Space Manager > Spaces > <space type>. 

2) Select a Space record from the log and click Open. 

You can open a Space record from an advanced log, also. An advanced log creates a tree 
hierarchy structure for records. This tree structure makes it easier to view and select records 
from a log of spaces in the Space Manager. To open a space record from an advanced log, use 
the middle navigation column to narrow the focus of the log; then pick the space from the log in 
the right pane. 
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Business Process (BP) Query-based Tab (QBT) in the Space Records 

Once a BP QBT is configured and the Space is deployed after changes made, the QBT appears 
in the Space for which the QBT has been configured. 

Space Log Options (Standard View) 

Space log toolbar options: 

 Create

 Actions

 Import

 Export CSV Template

 Bulk Edit

 Print

 Delete

The Delete option in the Delete Records window is disabled until you enter a reason for 
deletion. If you enter the reason and then remove it completely, then the Delete option 
will become disabled again. You cannot leave a blank space in the available box and click 
Delete. 

 Deleted Record History

A window opens and displays the history of deleted items. 

 View

The system-defined views are: 

 All Records

 Records Created by Me

In addition, there are option for user to: 

 Create New View

 Manage Views

 Edit View

Enables you to change the View settings. Rules for changing views will be the same as other 
logs. 

 Reload the page

 View on Drawing
Enables you to select multiple records and view the space records in the associated drawing 
file. 

 Printing the log content

 Print

 Export to CSV

 Export to Excel

 Search as defined in uDesigner

 Find on Page

 Help
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The gear ( ) menus: 

 Open

 Copy

 View on Drawing

 Delete

Note: If an attribute form is present, then you can hover over the 
question mark (?) symbol to see more information in the form of a tooltip.  

Creating a New Space Record (Standard View) 

To create a new space: 

1) Go to your project (User mode).  

2) Click Space Manager to expand. 

3) Click Spaces to expand. 

4) If available, click an element (for example, Leasable Spaces) to open the log. The log is 
divided into two panes. The left-hand pane contains the toolbar options and columns which 
provide details about the space. The right-hand pane (properties pane) contains the 
following tabs: 

 Record Details

 Permissions

5) Click Create. 

6) When the Create New <space> window opens, enter the values in the required fields. At 
this point, you are creating a space. If the properties window is not open, click the three 
vertical dots icon (located on the right-hand border of the Create New <space> window, in 
the middle) to open the properties pane. The properties pane contains the following tabs: 

 Comments

Contains additional details about the record. You can add comments to the space 
attribute in the edit mode, only. 

 Linked Records

Enables you to link records to the space attribute. The functional flow is similar to that of a 
non-Workflow BP. 

 Linked Mail

Enables you to link email to the space attribute. The functional flow is similar to that of a 
non-Workflow BP. 

7) When finished, click Submit. 

8) When the log appears, click the refresh icon to refresh the screen. Review your recently 
created space. 

The details of a space: 
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1) Open a space from the log to see the space window. The window is divided into two panes. 
The left-hand pane contains the following tabs: 

 Details

 Asset

Contains the assets associated with the space. If any QBDEs are associated with the 
record, the Asset tab will list the QBDEs. You can click Create, to open the Create New 
Assets window and enter asset information. The Create New Assets window has the 
following elements: 

Left-hand pane: Asset Details tab (General and Preventive Maintenance Information
blocks), Gauges & Meters tab, and Components tab. 

Right-hand pane: Attachments tab, Comments tab, Linked Records tab, and Linked 
Mail tab. 

The right-hand pane (properties pane) contains the following tabs: 

 Comments

 Linked Records

 Linked Mail

 Audit Log

Lists all the actions taken by a user (Bulk Edit, Create, etc.) 

 Space Content

This tab contains the list of records that are associated with the space. A graphical 
representation is also present for the same. The Space Content tab will be similar to the 
Reference Records seen in the Business Processes, with the following differences: 

'Reference Records' = 'Space Content' 

'Business Process' = 'Record Type' 

Objects seen in the link will be based on the referring or referred object type. 

Similar to Reference records, the Space Content tab displays the linked records and the 
reference records. 

2) If you change or add any information, click Submit to make your changes a part of reference 
record to the space details or content. Click the Space Content tab to see the details. 

Click the horizontal lines icon drop-down arrow (hamburger icon) to print, reload, view 
associated drawing (for a floor/level), access help, or close the record. 

Viewing a Space on a Drawing (Standard View) 

This feature is only available if a drawing file has been associated with a level record and uCAD 
was used to author the space object in AutoCAD. 

To view a space on a drawing 

1) In User Mode, in the shell, select Space Manager > Spaces > <space type>. The Spaces 
log opens. 

2) Select a space record and click View on Drawing. The View on Drawing window opens with 
the selected spaces highlighted on the drawing.  
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Working with Levels Sheet (Standard View) 

The Space Manager includes a sheet to help you manage levels and spaces. The sheets allow 
you to create formulas to calculate "leasable" space and other related information in a building. 
You can create levels sheets for a Space Manager. You can create only one sheet per shell.  

The levels sheet is listed in the Levels Sheet log in the Space Manager.  

Note: You must have permissions to access a sheet. 

Levels Sheet Log Options (Standard View) 

The Levels Sheet log contains two panes. The left pane contains a list of sheets, and the right 
pane displays the Properties tab which displays the following properties for each sheet: 

 Title

 Description

 Levels that are included in the sheet (All Levels or Levels with statuses) 

 Status of the levels such as occupied and inactive 

You can modify and save the properties, provided that you have permission. 

The left pane contains the levels sheet and the following information is provided in column 
format: 

 Name

 Description

 Last Modified Date

Creating a New Levels Sheet Record (Standard View) 

When there is no levels sheet available, Unifier displays the Create toolbar option. To create a 
new levels sheet: 

Note: You must have the Create permission in order to be able to create 
a levels sheet. 

1) Go to your shell or project and switch to user mode. 

2) Click Space Manager to expand. 

3) Click Levels Sheet. 

4) Click Create. and select one of the following options: 

 Manual

 From <shell or project> 

If you click the Manual option, the Create Levels Sheet window opens. Enter and select values 
in each field and click Save. 
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If you decide to create levels sheet from a shell or project, click the From <shell or project> 
option, to open  the Levels Sheet window. Use the Find on Page option to find the desired 
shell or project, click Select, and follow the prompts. You can create one levels sheet per shell 
or project, only. 

Once the sheet is created, use the Refresh Sheet Data toolbar option to refresh the data on a 
sheet (updating the data). This toolbar option does not refresh the log items that are displayed in 
the Levels Sheet log. Note that when you click the Refresh Sheet Data toolbar option, the cell 
under Last Modified Date will show "In Progress" until the data update is complete, after which 
the date of the refresh is displayed. 

To add columns to a level sheet: 

1) In User Mode, navigate to the Space Manager in a shell and select Level Sheets. 

2) Select the level sheet, and click Open. 

3) Click Columns. The Columns Log window opens. 

4) Click New. The Column Definition window opens. 

5) In the Datasource drop-down list, select the data element to use. The list includes the data 
elements found on the level form. 

6) For Entry Method, choose how information is entered in the column. The choices depend 
on the data source selected. 

7) For Data Format, select the format for numeric columns. The options are: 

 Show as Percentage: Displays data in percentage. For example, if 0.25 is entered, it 
displays as 25%. 

 Decimal Places: Select the number of decimal places to display. 

 Use 1000 Separator (,): Data is formatted using separators. For example, one thousand 
is displayed as 1,000 with a comma, not 1000. 

 Negative Number Format: Select how negative values are displayed: with a negative 
sign or in parentheses. 

8) For Display Mode, select Hide to make the column invisible to users or Show to display it. 

9) For Total, select what is shown in the bottom summary row for each column. The options 
are: 

 Blank: Summary row is blank. 

 Sum of All Rows: Displays the sum total of all row values for this column. 

 User Formula Definition: Displays the result of the formula entered in the Formula field. 

10) For Average, select Blank or the average of all rows. 

11) For Column Position After, select a column from the list to specify its position on the sheet. 

12) Click OK. 

Exporting and Importing CSV Files (Standard View) 

To export a sheet 

1) In User Mode, in the shell, select Space Manager > Levels Sheet. 
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2) Select a sheet, and click Export. See Exporting and Importing CSV Level Templates and 
Records to export and modify the template. 

To import a CSV file 

For instructions on importing a CSV file, see Exporting and Importing CSV Level Templates and 
Records 

Working with Stack Plans 

A stack plan is a two-dimensional graphical display of facility or building data. Usually, these 
graphs display area calculations by different attributes (for example, rented, leased, vacant, 
occupied by a tenant). The y-axis lists levels, and the x-axis lists areas. Stack plans allow you to 
view area information across all building levels or floors based on defined attributes. Stack plans 
display only space records. If you have permission, you can create and modify stack plans. 

Creating a Stack Plan 

 To create a stack plan: 

1) In User Mode, select <shell> > Space Manager > Stack Plans. 

2) Click New. The Properties window opens. 

3) Complete the General tab as described in the first table below. 

4) Click the Options tab and complete as shown in the second table below. 

5) Click Apply to save changes, or OK to save and exit. 

In this field: Do this:

Name Enter the stack plan name. 

Description Enter an optional description. 

Include: 

 All levels 

 Levels with statuses 

Select to specify that all levels be included in the stack 
plan, or that only levels of selected status be included in 
the stack plan. 

In this field: Do this:

Space Types Select a space type. 

Stack By: 

 Space Type 

 Data Element 

Select whether to stack by selected space type or by a 
data element. 

Stacking View Select to specify standard stacking or 100% stacking. 

Sort Floors By: Select to sort floors by a selected data element from the 
Level Attribute form. 

Show Legend Select to display a legend for the stack chart. 
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Conditions Add a condition to filter the number of space records 
included in the stack plan calculation. The stack plan 
calculation logic sums up the values from the uuu_area 
data element used on the space-type detail form. 

Viewing a Stack Plan 

 To view a stack plan: 

1) In User Mode, select <shell> > Space Manager > Stack Plans. 

2) Select a stack plan from the log. 

3) Click Open. If your stack plan contains no data, you will see a gray box. Your stack plan 
must contain data in order to display. You can scroll up and down the stack plan if there are 
numerous records listed. 

Modifying a Stack Plasn Display Mode 

You can change the display mode of the Stack Plans to display a standard view (Stack Plans - 
Current View) or display the bars in the graph as proportional percentages of varying length. 

To change the display mode for a stack plan 

1) Go to your shell > User mode > Space Manager > Stack Plans. 

2) Select a stack plan from the log. 

3) Click Open. 

4) Select the Explicit Value or Percent radio buttons to modify the stack plan view. 

Printing a Stack Plan 

 To print a stack plan: 

1) In User Mode, select <shell> > Space Manager > Stack Plans. 

2) Select a stack plan from the log. 

3) Click Open. 

4) Click the print icon. The displayed area is printed. Scroll down the stack plan and click the 
print icon again to print more of the stack plan records. 

Working with the uCAD Plugin 

Unifier uCAD is an AutoCAD® plug-in (a desktop client application) that allows Space Manager 
to graphically define levels/floors and spaces based on customer-specific space definitions and 
details. 

Unifier uCAD works in conjunction with Unifier Space Manager module (you can upload drawing 
files for use with Space Manager) and provides a seamless integration between AutoCAD® and 
Unifier. 

Installing and configuring uCAD provides the following capabilities: 
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 Dynamic level and space data creation and updates between Unifier and AutoCAD®. 

 Ability to integrate with multiple Unifier environments by leveraging the connections created 
under uClient Configurator. 

 Link uCAD space objects and polylines with Unifier's Space Manager Levels and Space 
records. 

 Ability to associate attributes to drawing objects to designate their space location. 

 Ability to publish AutoCAD® drawings with uCAD Space information to Unifier, and ability for 
Unifier users to view these drawings without the need for the native AutoCAD® application 
on your desktop. 

 Ability to keep uCAD's Space and Level attribute form designs in synchronize with Unifier via 
an Auto Synchronize feature. 

In addition, your desktop system must have one of the following supported AutoCAD® versions:  

 2011 

 2012 

 2013 

 2014 

 2015 

 2016 

 2017 

Note: The uCAD Application and uClient Configurator are installed 
locally and run as client-side applications on your local system. If you 
access Unifier from a different computer where you have not installed 
these applications, and attempt to upload, download or attach files, you 
will be presented with an error. You must install uCAD and uClient 
Configurator on each computer on which you intend to use the 
functionality. 

About the uCAD Plug-In 

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in 
application, which can be downloaded from Unifier. uCAD enables: 

 Authoring of space objects in AutoCAD® 

 Identifying spaces on a floor drawing and link them to Unifier space objects 

 Associating a drawing file to a level record 

 Transferring changes to level and space records between the Space Manager and 
AutoCAD® 

Installing the uCAD Plug-In 

Refer to the Unifier uCAD Installation Guide for details on how to install the uCAD plug-in. 
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Configuring uCAD 

After installing uCAD, you can configure it. This consists of the following: 

 View uCAD connections. These connections are maintained in the uClient Configurator. 

 You can optionally configure uCAD to automatically synchronize with your AutoCAD® 
designs. 

To open the uCAD Configurator window 

From the Windows Start button, click Start > uClient > uCAD > uCAD Configurator. The 
uCAD Configurator window opens, listing the connections and import options for your 
implementation. 

About the Connections 

uCAD connects to Unifier to download level-type and space-type design definitions (the 
properties of which correspond to the attribute forms that were designed in uDesigner for the 
Space type and Level type records). These designs must be imported into Unifier before uCAD 
can take advantage of them. 

The connections between uCAD and Unifier are set up in the uClient Configurator. 

To view connection details follow these steps: 

1) Open the uCAD Configurator window. 

2) Click on each connection listed in the window. This displays the connection name and 
details, and the last date designs were imported. 

These connections are created and maintained in the uClient Configurator. 

To access uClient Configurator and create connections follow these steps: 

1) If you have not already done so, you must create the connections in uClient that will be used 
by uCAD. From the Windows Start button, click Programs, Oracle, Primavera-Unifier, 
uClient. The uClient Configurator window opens.  

2) For details about setting up connections in the uClient Configurator, see topic "Setting Up 
Primavera uClient Configurator" in the Unifier uCAD Installation Guide for details. 

Enabling Auto-Synchronization 

uCAD enables you to integrate your AutoCAD® drawings with Unifier's Space Manager. In order 
to do this, you must first import Space Manager designs into uCAD. These designs include level 
type, space types, and the data elements on the Space Manager attribute forms that have been 
enabled for uCAD Integration in uDesigner. 

This import process can be done manually, or you can choose the uCAD Auto Synchronization 
option. When this option is enabled, uCAD will check for any new space types that have been 
imported into Unifier from uDesigner, or any changes to the data elements enabled for uCAD 
Integration in existing level or space types. 



Working with Unifier Managers

703

With Auto Synchronization is enabled, uCAD tries to connect to Unifier when you open a 
drawing file that was previously set up with a connection to check if there have been any 
changes to the design. This is done in the background. If the application detects changes, you 
are asked if you want to import them into Unifier. If you ignore the message, you can continue 
working with the drawing file. If you accept the changes, close the drawing file so that uCAD can 
rebuild the menu structure and map data to the new imported design. 

If you choose not to enable Auto Synchronization, you must manually import any new designs. 

To enable auto synchronization of drawing file changes between AutoCAD® and Unifier follow 
these steps: 

1) Open the uCAD Configurator window, and select the Connections node. 

2) Click the Edit button. 

3) Select Auto Synchronize Design and click OK. 

To manually import Space Manager design for the Levels and Space types follow these steps: 

1) Open the uCAD Configurator window. 

2) Click on a connection listed in the Connections node. 

3) Click the Import button. 

Working in AutoCAD with the uCAD Plugin 

The following is an overview of how uCAD integrates your AutoCAD® drawings with Unifier 
Space Manager. 

a) Before you can use the uCAD plug-in with AutoCAD, the Space Manager attribute forms for 
the Level definition (as well as Space types) must have been designed in uDesigner and 
imported into Unifier. 

In uDesigner, you create one Level type form, and any number of Space type forms. 

As part of the design process, you also specify which data elements to use to integrate with 
uCAD (this is done in the Integration > uCAD node in uDesigner). 

Examples 

For Level integration, at a minimum, you must include the Level name and Status. 

For Spaces, you must include Space Name, Area, and Level Picker. Refer to the Unifier 
uDesigner User Guide to learn more about Space Manager designs. 

b) Install the uCAD plugin, for AutoCAD®, and establish connections in uClient. A Unifier menu 
will be available from your AutoCAD® menu bar. 

c) Import the attribute forms into Unifier. 

d) Activate the attribute forms in the Configuration. Refer to the Unifier Administration Guide to 
learn more about Space Manager setup. 

e) Open the drawing file in AutoCAD®. 

In Space Manager each drawing file, when imported into Unifier, represents, corresponds, 
and is associated with a Level record in Unifier.  

Example 

Each floor of a building corresponds to a Level-type record in Unifier. 

f) Import the Unifier designs into uCAD. 
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You can do this manually, or choose to enable automatic synchronization. 

This process imports level and space type details into uCAD. 

Note: The level and space type details refer to the level type, all space types, and the data 
elements that have been enabled for uCAD integration, in uDesigner, for the corresponding 
level and space types. 

g) Set up a new AutoCAD® drawing for use with uCAD. 

This needs to be done only once for each drawing. 

h) Work with uCAD to create level and space objects on the drawing. 

i) Link them to uCAD. 

j) Import the drawing file into Unifier Space Manager. 

The level or space objects linked to uCAD will create level and space records in Unifier. 
Refer to the Unifier User Guide and Unifier Administration Guide for information about 
working with the Space Manager. 

Note: If the system displays a message, proceed by adding the installation location to the 
Trusted Locations option (Tools > Options > System). 

Importing or Auto-Synchronizing Level and Space Forms 

The first step is to synchronize the Level and Space types attribute form designs from Unifier to 
uCAD. You can do this manually, or by auto synchronization. 

See Enabling Auto-Synchronization (on page 702) for details on enabling auto 
synchronization. If the Auto Synchronization is enabled, then uCAD will attempt to create a 
connection to Unifier and automatically import Space Manager design information.  

To manually import Space Manager designs for the Levels and Space types, follow these steps: 

1) Open the uCAD Configurator window. 

2) Click on a connection listed in the Connections node. 

3) Click the Import button. 

Setting Up an AutoCAD Drawing for Use with uCAD 

For each new drawing that you want to use with uCAD, you must choose which connection to 
use for that drawing. (These are the connections you added in uClient.) This setup only needs to 
be done once per drawing. 

To set up an AutoCAD® drawing for use with uCAD, follow these steps: 

1) Start AutoCAD® and open the drawing file that you want to use with the Space Manager. 

2) On the AutoCAD® menu bar, click the Unifier menu, and select Setup uCAD. 

3) In the Setup window, select a connection. The URL and company name associated with the 
connection name are populated. 

4) Click OK. 

The following additional options are now available under the Unifier menu: 
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 Create or Modify <Level type>: Allows you to associate a drawing with a Space Manager 
level. In the above example, Floors was the name given in uDesigner to define the level 
type. 

 Create Spaces: Allows you to create a new space object. The sub-menu lists all of the 
available space types as defined in uDesigner. 

 Establish Link: Allows you to link existing AutoCAD® polylines to uCAD space records. 

 View or Modify Spaces: Allows you to list or modify all spaces defined on this drawing. 

 Outlines: Allows you to turn on or turn off the outlines around spaces in a drawing in uCAD. 

 Fill: Allows you to turn on or turn off fill colors in the various spaces in the drawing. These fill 
colors were configured for the space type by the Administrator. 

 Text: Allows you to turn on or turn off fill colors in the various spaces in the drawing. These 
fill colors were configured for the space type by the Administrator. 

 Generate uCAD Files: Allows you to publish your drawing. 

The levels type and space types displayed under the Unifier menu are based on the Space 
Manager designs created in uDesigner, imported into a Unifier environment, and associated with 
the connection selected in the Setup uCAD window.  

Associating a Drawing File with a Level 

Any drawing file that will be used with Unifier's Space Manager needs to be associated with a 
Level record. Each Level record in the Space Manager is eventually associated with an 
AutoCAD® drawing file. 

To associate a drawing file with a level record follow these steps: 

1) In AutoCAD®, select Unifier > Create or Modify <level>. The <level> form opens. In this 
example, the level name that was designed in uDesigner is Floors. 

2) The data elements displayed on this Level form are controlled by the data elements added to 
the uCAD integration interface design in uDesigner. This form and its content is based on the 
selected connection (that is, the Unifier environment from which the designs were imported) 
while setting up this drawing file. 

Note: If a picker data element has been added to uCAD integration, it 
will display on the form as a text entry field. You must enter a valid value. 
For example, if you have a Level Picker field, you must type the level 
name exactly as it appears in the space record form. 

3) After completing the form, click OK. The drawing file is now ready to be associated with a 
level record. This level record will either be created new, if never created before, or updated 
with new data if this level and associated drawing has not yet been imported into the Space 
Manager in Unifier. 
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Creating New Space Objects or Link Existing Spaces 

The next step is to create space objects. You can create spaces in AutoCAD® using uCAD. 
Each space object is dynamically linked to an AutoCAD® polyline entity during creation. You can 
also link existing AutoCAD® polylines to uCAD space objects. For example, if you have a space 
type called Common Areas, you might define individual spaces for each restroom, hallway, or 
reception area. You will then associate each of these spaces with the Common Areas space 
type, and give each space a unique name. 

Linking a uCAD space object to a polyline provides these benefits: 

 The area of the polyline is automatically calculated, and the space object associated with it is 
updated. 

 Once a drawing file has been imported into Unifier's Space Manager, the system can 
dynamically create new space records that are associated with the uCAD space object or 
update existing spaces with new space data. 

 In Unifier, spaces can be viewed or highlighted in Unifier's Space Manager when searching 
or selecting a space record. 

When you import the drawing file into Unifier, these become space records. You control the 
information to capture with that space record, such as the space name, the area, the unit of 
measure (such as square feet). These are based on the attributes that were designed in 
uDesigner for each space type. 

To create space objects, you can create a new object in AutoCAD® using polylines, or you can 
link existing polylines to uCAD. 

Creating a new space object using polylines 

To create a new space object using polylines follow these steps: 

With this procedure, you are create a new space object on the drawing using polylines 
(conference room, office, or hallway, for example). These new spaces will create new space 
records automatically in Unifier for the corresponding level. 

1) In AutoCAD®, open the drawing that you want to add spaces to. Be sure that the drawing 
has already been set up to work with uCAD (see the instructions above). 

2) Select Unifier > Create Space > <space type>. 

3) Select a space type. 

Common Spaces, Gross Building Area, Gross Measured Area, Major Vertical Penetration, or 
Usable Areas. 

4) Draw the boundaries of your space. When you have defined the space boundaries and 
completed the space by closing the polyline or by pressing Enter, the space form opens. 

5) Complete the form. 

The data elements displayed on this space form are those that were added to the uCAD 
integration design in uDesigner. This form and its content is based on the selected 
connection (that is, the Unifier environment from which the designs were imported) while 
setting up this drawing file. 
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In the example shown above, the Usable Areas space type form is show. Notice that the 
Area for this Usable Area space is pre-calculated based on the space boundaries defined on 
the drawing. 

Note: If a picker data element has been added to uCAD integration, it 
will display on the form as a text entry field. You must enter a valid value. 
For example, if you have a Level Picker field, you must type the level 
name exactly as it appears in the space record form. 

6) Click OK. 

The space polyline is now created and linked to the uCAD space object. 

Notice the space tag that has been placed in the middle of the space on the drawing 
reflecting the space Name, Type, and Area. These data elements are defined for the space 
type (Edit Studio window, Options tab; refer to the Unifier uDesigner User Guide). 

Linking an existing space to an existing polyline 

You can also dynamically link an existing space (that already exists as a space record in Unifier) 
to a polyline on the drawing. 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select Establish Link > space type. In this example, the space 
type is Major Vertical Penetration. 

3) Double-click a polyline space in the drawing. You can select only one polyline. The Space 
Type window opens, listing all the space objects of the selected type. 

4) Select a space object from the list and click Link. If the space object already has a link, a 
message displays telling you to first unlink the object before establishing a new link. 

5) When the link is established, click OK. 

Adding a new space object to an existing polyline 

You can also create a new Unifier space record by linking to an existing polyline. 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select Establish Link > space type. 

3) Double-click a polyline space on the drawing. You can select only one polyline. The Space 
Type window opens, listing all the space objects of the selected type. 

4) Click New to create a new space object. The Space form opens. 

5) Enter the data for the new space object. 

6) Select the new space object from the list and click Link. 

7) When the link is established, click OK. 

Working with Space Objects in a Drawing 

You can view and work with all space objects that are available in uCAD. 

Viewing a space object that is linked to a polyline 

To view a space object that is linked to a polyline on a drawing follow these steps: 
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1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select View > space type. The Space Type window opens, 
listing the space objects for the selected space type. 

3) Select one or more space objects from the list. 

4) Click Show on Drawing. The linked polylines are highlighted in the drawing. The Space 
Type window remains open, so you can look for other space objects in the drawing. The 
drawing pans to show multiple polylines. 

Opening a space object 

This opens the space object so that you can make changes to the data element fields. 

To open a space object: 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select View > space type. The Space Type window opens, 
listing the space objects for the selected space type. 

3) Select a space object from the list and click Open. The Space Object window opens. 

4) You can view or modify the data for the space object. 

5) Click OK. 

Deleting a space object 

This procedure will remove the link between a polyline and the Unifier space record, and remove 
the space object from the drawing. You can also optionally remove the polyline. This procedure 
will not delete space records from Unifier. 

Note: Space records and logs can include the field Polyline Deleted (or a 
similarly named field) that indicates whether a polyline that was linked to 
a space record has been deleted in uCAD. The field is blank if there is 
no linked polyline provided in uCAD, or if the polyline exists and is not 
deleted. If there was a linked polyline, and it has been deleted, this field 
will contain the value “Deleted”. This indicates that the space record can 
be linked to another polyline. This field is always read-only. The space 
record in Unifier is not deleted. 

To delete a space object: 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select View > space type. The Space Type window opens, 
listing the space objects for the selected space type. 

3) Select a space object from the list and click Delete. 

4) Choose one of the following: 

 Space Record and Polylines: Deletes the space record and the polyline from the 
drawing. 

 Space Record Only: Deletes the space record from the drawing but leaves the polyline. 

5) Click OK. 
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De-linking a space object 

You can de-link a space object record from a polyline. 

To de-link a space object: 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select View > space type. The Space Type window opens, listing 
the space objects for the selected space type. 

3) Select a space object from the list and click Delink. 

4) Click Yes to confirm.  

Filtering space records to access a subset of those records 

You can filter a long list of space records to quickly access records that meet certain filtering 
criteria. For example, you might want to see only those records for which Department is Human 
Resources and Occupancy is Vacant. You can filter by using the fields available to the space 
record (that are not based on constants) from the Space Detail form designed in uDesigner. 

To filter a list of space records: 

1) In AutoCAD®, open the drawing. 

2) Click the Unifier menu and select View > space type. The Space Type window opens, listing 
the space objects for the selected space type. 

3) Click Filter. The Filter window displays. 

4) Select the filtering criteria. 

5) Click OK. The list of records is refreshed to show the records that meet the filtering criteria. 

6) You can click Show on Drawing to show highlighting (dashed lines) around the polylines that 
are found using the search criteria. Click Cancel Highlighting to turn off the highlighting. 

7) Click Remove Filter to return to the original list of space records. 

Working with Options Under Unifier Menu 

If configured by your administrator, you can turn on or turn off space outlines, fill colors, and fill 
text. The outlines, colors, and text display support visual analysis of the drawings and facilitate 
space planning. For example, you might want to see a floor plan with each space type on that 
plan highlighted in a different color based on the department using that space. Or, you might 
want to outline all common areas, or all usable space, or both types of spaces.  

Try turning on and off outlines, color fills, and text fills to gain insight into the various aspects of 
the drawings you are working with. The outlines and fill settings do not change any data and do 
not persist. Each time you view the drawing, you can turn these setting on and off to emphasize 
different aspects of the drawing. 

To turn on or turn off space outlines follow these steps: 

1) In AutoCAD®, open the drawing. 

2) Choose Unifier > Outlines. The Outlines window opens. 
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3) Select All to view all outlines around all spaces in the drawing, or select space types to view 
outlines around specific space types. 

4) Click OK. 

To turn on or turn off space color fills follow these steps: 

1) In AutoCAD®, open the drawing. 

2) Choose Unifier > Fill. The Fill window opens. 

3) Select All Space Types to show color fills for all space types in the drawing, or choose a 
space type from the Space Type drop-down list, and any associated data elements. 

4) Click OK. 

To turn on or turn off space text fills follow these steps: 

1) In AutoCAD®, open the drawing. 

2) Choose Unifier > Text > <space type>. The Text window opens. 

3) Select All Space Types to view all text fills in spaces in the drawing, or choose the specific 
text that you want to display on the spaces. 

4) Click OK. 

Generating uCAD Files 

The Generate uCAD Files option allows you to publish your drawing. Once you save your 
drawing file in AutoCAD, use the Generate uCAD Files option to publish your drawing file, which 
can later be imported into Unifier.  

Note: Ensure that you save your drawing file in AutoCAD prior to using 
the Generate uCAD Files option. This is to ensure that the drawing file 
and the published file are in synch. 

Accessing User-Defined Reports (UDRs) 

User-defined reports (UDRs) are set up and run in User mode.  

You can run UDRs at: 

 Project-level 

 Shell-level 

 Program-level 

 Company-level 

When you are running a report based on a permission-aware Document Manager data source, 
Unifier allows you to see the report only if you have permission to see the data source, in case 
of:  

 Document Manager - Company 

 Document Manager - Project/Shell 

To access a project-level user-defined reports 
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In User mode, open a project or shell. Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

To access a shell-level user-defined reports 

In User mode, open a project or shell. Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

To access a program-level user-defined reports 

In User mode, open a program. Navigate to Reports > User-Defined. The User-Defined 
Reports log opens. 

To access a company-level user-defined reports 

In User mode, open the company (User mode). Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

The following describes the User-Defined Reports log elements, for the Company Workspace 
tab (Admin mode) > Templates > Project (Standard) > All > click a [project] to open > 
Reports > User-Defined Reports.  

User-Defined Reports log menu options: 

File Enables you to perform the following actions: 

 New

 Copy

 Report

 Template

 Open

 Update Projects

 Projects

 All Projects

 History

 Import

Edit Enables you to edit or Delete a report. 

View Enables you to perform the following actions: 

 All

 Find

 Saved Results

 Audit Log

Help Enables you to access: 

 Unifier Help

 Unifier Library

 User Productivity Kit

 About Unifier
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User-Defined Reports log toolbar options: 

New Enables you open the Create a new report (Create User-defined Report) 
window and set up the following fields: 

 Data Type

 Element

 Report Type

 Access Type

Copy Enables you to copy a: 

 Report

 Template

Open Enables you to open a record. 

Edit Enables you to edit a report. 

Delete Enables you to delete a report. 

Find Enables you to find a report on the log. 

Saved 
Results

Enables you to see the saved results. 

Update 
Project
s

Enables you to access: 

 Projects

 All Projects

 History

Import Enables you to import a report. 

User-Defined Reports log columns: 

The columns provide the following details about each UDR. 

 Name

 Description

 Data Type

 Access Type

 Report Type

 Owner

 Creation Date

 Last Modified By

 Last Modified Date

 Scheduled

 Last Run Date
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Working with Drawing Files 

You can import drawing files into Unifier from a level log or from a level record. You can 
download drawing files as well.  

If a level drawing has reference files, you must put all polylines and space objects on the base 
level drawing file and not on the reference files. Unifier Space Manager cannot process 
reference files for space objects. 

When a drawing file is set up with an uCAD connection, the system creates a data file with .unf 
extension under a location managed by the uCAD desktop application. The .unf file contains 
following information: 

 Connection that is associated with the drawing file during setup step. 

 Level related information. Information that is entered by user on level detail form 

 Space related information. Information that is entered by user on space detail form. 

 Link between space object and polyline. 

There is a one-to-one relationship between: 

 Drawing file and setup 

 Connection and .unf file 

Importing Drawing Files into Unifier 

You can import drawing files (.dwg files) into Unifier from the level records log or from the level 
record. 

Note: The uCAD plug-in must be installed on the machine from which 
you import the drawing files. If uCAD is not installed, you receive a 
message to install it. 

To import drawing files into Unifier from level records log: 

1) From the toolbar click Import and select Drawing Files to open the Upload Files window. 

Notes: 

 The File Upload window enables the user to upload the .unf and .dwf 
files in addition to the .dwg files and after a successful upload, the 
level processing window is displayed. 

 The .dwf and .unf files, associated with each drawing file, must be 
uploaded. 

 The default paths for Windows OS are: 
- .dwf file: C:\Program Files 
(x86)\Oracle\Primavera-Unifier\uCAD\data\dwf
- .unf file: C:\Program Files 
(x86)\Oracle\Primavera-Unifier\uCAD\data\unf

2) Click Browse and select the drawing file and the corresponding .unf and .dwf files. 

3) Click Upload to upload the files to Unifier.  
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4) When the level processing window displays, click the star symbol on the upper left-hand 
corner, and then click Process to process the drawing file. 

If multiple files are available and you want to process all the files, click Upload from the 
bottom right-hand portion of the window. 

Note: You can click Remove to remove one or more drawing files from 
the list.  

You receive a confirmation message that the files are being processed, and you will be 
notified, by email, when the processing is complete. 

You can upload multiple drawing files to either create or update the levels and spaces. 

To get the most recent import information: 

After the drawing files are uploaded, Unifier generates a drawing processing log. 

1) In User Mode in Unifier, select <shell> > Space Manager > Levels. 

2) Select View > Last Import Log. The Last Import Log window opens, listing who performed 
the import, the date and time of the import, and the drawings that were imported. This log is 
always updated to show the last import. It does not contain history of imports over time. 

To import drawing files into Unifier from level record: 

You can import a drawing file from a level record if you have create permission on the Levels 
log. You can import one drawing file per level. You cannot import when the record is still in Draft 
mode. 

Processing a drawing file from a level record is similar to processing files from level records log.  

Downloading Drawing Files 

You can download drawing files from the level records log window, only. 

To download drawing files: 

1) In User mode in Unifier, select <shell> > Space Manager > Levels. 

2) Select one or more level records from the level records log window and click Download. 

A zip file (containing the .dwg and .unf files) will be downloaded, which contains the path, for 
example: C:\Program Files\Oracle\Primavera-Unifier\uCAD\data\unf 
location

Filling a Space with Color 

This feature in Unifier works the same way it does in AutoCAD. The colors you can choose from 
for a space are dictated by the space type you are working with. 

Note: Anytime the administrator changes the fill space colors, you will 
have to send the drawing back to AutoCAD and re-import it into Unifier in 
order to acquire the new colors. 

1) In Unifier, open the drawing. Unifier displays the drawing and a mini-log of spaces below the 
drawing. 
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2) On the toolbar above the mini-log, click the Fill By button (or choose Fill By from the View 
menu). 

3) From the list that appears, choose the fill you want to see on the drawing. 

The drawing will change to show the color you selected. 

Note: When you save the drawing, Unifier will save it with the current fill 
settings. These are the settings you will see the next time you open the 
drawing. 

Displaying Text for a Space 

This feature in Unifier works the same way it does in AutoCAD. The text types you can choose 
from for a space are dictated by the space type you are working with. 

Note: Anytime the administrator changes the display text, you will have 
to send the drawing back to AutoCAD and re-import it into Unifier in 
order to acquire the new text. 

1) In Unifier, open the drawing. 

Unifier displays the drawing and a mini-log of spaces below the drawing. 

2) On the toolbar above the mini-log, click the Text By button (or choose Text By from the 
View menu). 

3) From the list that appears, choose the text you want to see on the drawing. 

The drawing will change to show the text type you selected. 

Note: When you save the drawing, Unifier will save it with the current 
text settings. These are the settings you will see the next time you open 
the drawing. 

Print a Space Manager Form 

You can print a copy of a Space Manager form. When printing Level or Space attribute forms, 
you can choose PDF, HTML or Custom print formats and select one of the following options: 

 Save a copy of the form as a PDF file and print the file 

 Print an HTML view 

 Print from a Word file if a custom print layout has been created for the form 

The Custom Print formats include the BI Publisher custom print templates designed in the 
Custom Templates node. If custom print layouts have been created for the Planning Manager, 
the form will print according to the layout that you select. See the following Custom Format Print 
Options for details. See the following Printing Options - Custom Format for details. 

To preview and print an Space Manager form: 

1) Open the Space Manager record that you want to print. 

2) From the File menu, choose Print Preview, then choose one of the following: 

 HTML to view the form in the browser which can then be printed. 
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 PDF to open the form in Adobe Reader, which can be saved or emailed as a PDF file, or 
printed process, you are asked to save the changes to the form. 

 Custom to select the BI Publisher, Microsoft Word, and PDF custom print templates from 
the same place as the current custom prints. See the following Printing Options - 
Custom Format for details. 

The Print Options window opens. This window displays the record information that can be 
printed. 

3) Select the check boxes for the information that you want to print. 

4) To select all the checkboxes, click the Select All checkbox. To deselect all, uncheck the 
Select All checkbox. If you deselect all checkboxes, only the header and footer will print. 

5) Click OK. The preview form opens in an HTML or PDF (Adobe Acrobat or Reader) window, 
from which you can print. 

If you chose PDF, you can save a copy by clicking the Save a Copy button, or print. To print 
from HTML format, click on the Print icon in the upper right corner. 

Print Options for Space Manager Form 

Following is a summary of the print options for a Space Form. 

Print option What it prints 

Line Item List 
Selected by default. This prints the information present on the tabs 
displayed on the Space. 

Detail Form 
This prints the information entered on the form. Depreciation details 
in the line items are not printed. 

General 
Comments 

The general comment text and create details are printed. 

Record 
Attachments 

File attachments to the record are listed alphabetically by file name, 
and also include the file title, issue date, revision number, and file 
size. 

Record 
Attachments > 
Comments 

Prints comments associated with file attachments to the record. 
"Record Attachments" must also be selected to select this option. 

To print an Space Manager form with a custom print layout: 

1) Open the Space Manager form that you want to print. Be sure it is in a view mode. 

2) From the File menu, choose Print Preview, then choose Custom to select the BI Publisher, 
Microsoft Word, or PDF custom print templates from the same place as the current custom 
prints (Custom Format Print selection window). 

3) Select a layout and click OK. The File Download window opens. 

4) Choose to Open or Save the file, which is a Microsoft Word DOC file. 

5) Open the file in Microsoft Word and print. This feature can be used with Microsoft Word 2003 
and 2007. 
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Printing Options - Custom Format 

The Custom Format Print window has two sections: 

 Select a custom print template 

 Select a template and format to print 

Both sections facilitate custom print template and format selections. 

Select a custom print template

Lists all the custom print templates, including the custom print templates created in the Custom 
Templates node and the custom print templates. For example, the list may include BI Publisher 
custom print templates, Word, and PDF custom print templates.  

If there are multiple custom print templates, all the published templates are listed in this section.  

The "Select a template and format to print" is populated by the selection made in the "Select a 
custom print template" section.  

Select a template and format to print

 If you select a BI Publisher custom print, then you can select the desired template and 
format from the drop-down lists. 

 Template drop-down displays all the available templates for the selected format.  

 Format drop-down displays the available formats for the selected template. 

 If the custom print template was created using PDF or Word, then the "Select a template and 
format to print" is disabled. 

Default template and format

 If a BI Publisher print template is selected, then the default values in the drop-down lists are 
set based on the default in the custom print template.  

 When a BI Publisher print template is selected in the "Select a custom print template" 
section, the template and format are populated based on the default value selected at the 
time of designing the print template. 
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