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Setting up Data Structure Setup Node 

This section explains how to set up the information in the Data Structure Setup node. These 
include: 

System Modules

Unifier functionality is loaded into the system through various Modules. Only the Site 
Administrator can load new modules. 

Application Modules

Unifier Applications are deployed into the system through the Application Modules node. 

Data Cube Definitions

A data cube definition is a query tool you can use to extract data and display it on a block of a 
configurable dashboard. 

Data Definitions

Data definitions describe how data is entered into Unifier and stored. The definition consists of 
the data type (whether it is an alphabetical string or a number), the data size (in number of 
characters for strings), and the input method (from a text box, pull-down menu, radio button, or 
check box).  

Notes: 

 Users can translate custom defined strings into various supported 
languages. The Internationalization module (under the Configuration 
node in the left Navigator) contains a list of custom strings developed 
by the user, which provides the necessary details for translators. 

 The numeric fields support international number formats (standards). 

 Unifier displays all available currencies and their respective symbols 

You must create data definitions before you specify the data elements for forms. For information 
on creating new data definitions, refer to the Unifier uDesigner User Guide. The data definitions 
dictate how the data element will enter and store the information in Unifier. A data definition can 
belong to one of the following categories: 

 Basic: Predefined or user-defined Data Definitions that contain all Data Definitions except 
the Cost Code definitions. 

For the SYS User Date Format Data Definition, the data set supports the 24-hour time 
format. In the User Preferences form, under the Regions tab, the field Date Format uses 
SYS User Date Format Data Definition.  

 Line Item Data Picker: This is a system-defined Basic data definition.  

 Cost Codes: Displays the type of cost code (fields that define the structure of the Cost 
Codes) specified in uDesigner for the project. The type of cost code available for Projects 
(Standard) is CBS. 
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 Data Picker: Data pickers work with master business process logs, shells, and configurable 
managers that function across a shell hierarchy. The purpose of a data picker is to make it 
easier for users to choose records: 

 From a master business process log 

 From a class in a configurable manager that operates across shells 

 For auto-creation across shells 

A data picker usually displays an extra navigation structure that makes it easier for users 
to choose records to work with. In operation, a data picker navigates to a specific 
business process, shell, or configurable manager and then extracts the records to display 
on the list by using a query the Unifier Administrator sets up. 

Data Elements

Data elements combine a “Data Definitions” with a field label to become what users see on the 
forms in Unifier. The fields on the forms the users see are filled by data elements. A data 
element can be a text box, where the user types in information; a pull-down menu of choices 
(also known as a picker), such as dates or names; radio buttons, where the user must select one 
of the options presented; or a check box, where the user has the option of choosing something 
or not. Data elements are the name and form label only—the element is essentially an empty 
“shell” that will not contain values until they are specified in Unifier. For information on creating 
new data elements, refer the uDesigner User Guide. 

Data Indexes

Allows the creation of user-defined database indexes that speed up the performance of large 
data sets. The database index name is constructed by a fixed prefix, UUU, plus internal row_id, 
followed by _ and a user-defined suffix and description. 

Data Views

Provides a view of Unifier data obtained via SQL query. It allows access to all Unifier database 
tables in a company registry (registry dependency ensures data security). Data Views enable 
administrators to design and deploy custom reports (program- and shell-level), create 
user-defined reports (UDRs), and utilize data as a source for Data Cube Definitions (used to 
display live, or cached data in a custom company or shell dashboards). 

Dynamic Data Sets

A dynamic data set is comprised of a "set" of data elements that includes a master data element 
and dependent data elements, which can be pull-down menus or radio buttons. You set up the 
elements and behavior of the set. 

Public Searches

A public search is any set of criteria that was specified to search a log for specific records. 

Reports

The System and Logs report modules are loaded by the Site Administrator. 

Statuses

Statuses are created in the Data Structure Setup node and indicate the position of an asset, line 
item, record, and tag at any point in the business process, such as “approved,” “pending,” or 
“closed.” The status is what drives the workflow from one step to the next.  
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 Assets Statuses: An asset status controls which assets are displayed on an Asset class 
sheet, instead of impacting the disposition of a business process or line item like other 
statuses. 

 Line Item Statuses: A line item status is part of the form that moves through the workflow, 
but it is not a visible part of a workflow. 

 Record Statuses: At each transaction, the Unifier user must apply a status to the record. 
Each business process produces at least one, and sometimes many, transaction records 
during its workflow. 

ER Views

Provides a tabular view of Data Elements and Data Definitions used in modules. 

In This Section 

Working with System and Configurable Modules ..................................................... 21 
Working with Data Definitions .................................................................................. 23 
Adding and Managing Data Sets ............................................................................. 28 
Working with Data Elements.................................................................................... 35 
Configuring Dynamic Data Sets ............................................................................... 37 

Working with System and Configurable Modules 

Unifier functionality is loaded into the system through various modules. For example, the Cost 
Manager and Schedule Manager are system modules that provide cost and scheduling 
functionality. Also, your system might contain various configurable modules created in 
uDesigner. Only the Site Administrator can load new modules. 

Some modules can be customized with "custom attributes," which are customized data fields, 
described later in this section. 

View Available System and Configurable modules 

To view the System Modules log 

1) Go to the Company Workspace tab and switch to Administration Mode. 

2) Click Data Structure Setup > System Modules in the left Navigator. The modules log 
opens, showing all the modules and Unifier functions that have been loaded into your 
environment. 

Add Custom Attributes to the Project/Shell SponsorshipModule 

Custom Attributes are customized data fields that can be created and added to the Project/Shell 
Sponsorship module. For example, you can use Custom Attributes to: 

 Add a Region designation to a Project (accessed in the Custom tab of the Project or Shell 
window) 
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 Add a Division or Building designation to a Project/Shell User or Group (accessed in the 
Custom tab of the User or Group window in project user administration) 

You can modify, delete, or change the order of custom attributes, as long as they have not yet 
been deployed. Once deployed, custom attributes cannot be deleted; form labels and the list 
order can be modified as needed. 

To add custom attributes to the Project/Shell Sponsorship module 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > System Modules in the left Navigator. The Modules log 
opens. 

3) Click Project/Shell Sponsorship in the left Navigator and click Open. The Custom 
Attributes window opens. 

4) Click the Project, Shell, Project/Shell User or Project/Shell Group tab. 

5) Click Add. The New Custom Attribute window opens. Complete the window fields as 
described in the table below. 

6) Click OK. 

In this field: Do this: 

Attribute Name 
Enter a name for the custom attribute, with no spaces (an 
underscore _ can be used). The Attribute Name appears on the 
Basic Data Definitions Log but does not appear on the form. 

Data Definition 
Source 

Select a Data Definition from the drop-down list. 

Form Label Enter the label that will be displayed on the form. 

Number of Lines 

This field appears for multi-line text fields. Enter the number of 
lines to display and make available to users to enter text. This 
affects the display of the text field only (for example, entering "4" 
will allow the first four lines of text to display). Additional lines of 
text may still be added, depending on the character size of the 
field, and can be accessed with a scroll bar on the text field. 

Append a Line 
Separator 

Select the checkbox if you want to create a separator line on the 
form as each Custom Attribute is added. 

To modify or delete custom attributes 

From the Custom Attribute window, select the data definition and click the Modify button to 
make changes, or Remove to delete. 

To change the list order 

In the Custom Attribute window, select an attribute and click Move Up or Move Down. 

To preview custom attributes 

Click the Preview button from the Custom Attribute window. 
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To deploy the custom attributes 

From the Custom Attribute window, select the data definition and click the Deploy button. The 
data definition will be available for use within Unifier. 

Note: Once a data definition is deployed, it cannot be deleted or 
renamed. 

Working with Data Definitions 

Data definitions define the data type and input type of a data element. Data elements are 
created from data definitions. The following lists the types of Data Definitions: 

 Basic: allow a company to provide values for certain types of data fields where a list of 
available choices is desired, for example, Project Phase, or to make data entry fields 
reportable 

 Cost Codes: structure used for CBS Codes on the cost sheet and cost business 
processes 

 Data Picker: makes it easier for users to choose items such business process records, 
configurable manager records, users, shells and spaces from across shells, or for 
auto-creation across shells. 

Note: Data definitions are defined under the Data Structure Setup node 
in Unifier. 

About Data Definition properties 

Data definitions can be of the following Data Types: 

 String: Any alphanumeric character or special character like * or # 

 Integer: A non-decimal number. Can be used for pull-down menu, radio button or checkbox 
fields 

 Date: For date fields 

 Float: This is applicable to currency amounts only 

 Input: This determines how data is entered or displayed in the field 

This input method: Does this: 

Check box 
Provides an option that the user can select ("check") or not. "Not 
checked" is the default value. 

Multi-line text area 
Use this element for multiple text lines for entries up to 4000 
characters long, such as descriptions or remarks. 

Multi-select Input Allows the user to make multiple selections from a list. 

Picker 
Allows users to choose from lists of items. Unifier and uDesigner 
are shipped with a number of predefined pickers. 
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Pickers are system-defined in uDesigner, and cannot be created in 
Unifier. A Picker can be added to a uDesigner BP and allows 
users to cross reference another Unifier record. Pickers include 
BP Picker, BPO Picker, User Picker, Company Picker, Line Item 
Picker, SOV Picker, Fund Picker, Asset Picker, Project Picker, 
Shell Picker, and more. 

Pull-down menu 
Provides a list of items the user can choose from but cannot 
change (e.g., a date picker). 

Radio buttons Use where two values are possible and one must be selected. 

Text box 
A text box is usually used for smaller text (1 to 64 characters), but 
could be longer. 

Dynamic Data Set 

A dynamic data set allows one data element on the form to control 
both values and behavior of other data elements on the same 
form. 

(In this example, choosing Yes in the Single Project field activated 
the Project Picker field below it.) 

Data Definitions from uDesigner 

The Data Definitions provide the structure for fields used on forms created in uDesigner. In 
uDesigner, the Data Elements are created to build fields to put on the forms. The Data Elements 
use the Data Definitions in uDesigner as the structure for the data. 

The Data Definitions used are added to the list of Basic Data Definitions and the data values are 
added to the Data Definitions in Basic Data Definitions. 

Note: All Basic or Cost Code Data Definitions must be created in 
uDesigner. This enables the user to distinguish between Data Definitions 
created in uDesigner, and the Data Definitions created in Unifier. Refer 
to the Unifier uDesigner User Guide for a full description of creating Data 
Definitions and Data Elements in uDesigner. 

View Basic Data Definitions 

Basic Data Definitions enable Unifier to provide fields, such as Phase, in which a company can 
enter their own data values. This enables companies to customize the values presented in some 
fields in Unifier. 

Several data definitions are predefined in Unifier. Basic Data Definitions are found in the Basic 
Data Definitions log. 
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Note: New data definitions must be deployed before use. Data 
definitions that have not been deployed will show Not deployed in the 
Status column. 

To access Basic Data Definitions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Definitions > Basic in the left Navigator. The Basic 
Data Definitions log opens. The system-generated data definitions are listed as Company or 
System in the Category field. 

Field Description 

Name 
Descriptive name for the data definition. This is the database 
name, and accepts alphanumeric characters, spaces, - (dash) 
and _ (underline). 

Category 
General: Defaults to Company 

Cost Code: Defaults to CBS Code 

Data Type 

String or Integer 

String: Any alphanumeric character or special character like * or 
# 

Integer: Non-decimal numbers 

If a Data Definition (DD) with the Data Type = Integer or Input 
Type - Pull-down Menu, and the Data Set value of 0 (zero), then 
the value of 0 (zero) overrides the default value. If a Data 
Element (DE) exists for such DD, and the DE is used as the 
master DE in a Data Definition Structure (DDS), then the DDS 
will not override the DE value when the DD is created, if the 
default value of the master DE is set to a field that has the value 
of 0 (zero).  

Data Size 

This field is available for text entry fields. Displays the number of 
characters that the data definition will accept. 

Notes: 

 The maximum limit for the Data Size is determined by the 
database being used with your installation. Check with your 
Site Administrator for the actual maximum allowable 
characters in a field. 

 Ensure that the data you enter is within the limit set in Unifier; 
otherwise, the system will ask you to shorten the number of 
the characters that you had entered (Unifier message: Data 
entered exceeds the allowed space limit for this field in the 
database. You must remove few characters before 
submitting.). This is mainly applicable to multi-byte character 
languages such as Japanese, Korean, and Chinese.  

Input Type Select one of the options. This determines how data is entered 
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or displayed in the field: 

Pull-down Menu: users can choose a value from a selection list 

Text Box: for short text entries 

Multi-line Text Area: for longer text entries 

Radio Buttons: users select one of multiple options presented 

Checkbox: users have the option of selecting or not 

Multi-select Input: users can choose one or more values from a 
selection list 

Default Value 
Available for text entry fields. You may enter an optional default 
value to the field. 

Separator 
For multi-select input, where users can select one or more 
values to enter into a field. The separate (for example, a comma) 
is used to separate the values. 

View Cost Code Data Definitions 

Cost Code Data Definitions are used in the Cost Manager to build the identifier for a row of cost 
data. Your company may refer to these as Account Codes, Cost Codes or CBS Codes. For 
example, these could link costs on a project or shell to the General Ledger for Finance. 

CBS Codes can be built with one to a maximum of 10 cost code segments. Each segment is 
defined by a different data definition, so a five-segment CBS Code would require five cost code 
data definitions. 

Cost Code values may be entered one at a time or imported from a CSV file. 

To access Cost Code Data Definitions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Definitions > Cost Codes in the left Navigator. The 
Cost Code Data Definitions log opens. 

Add a Basic Data Definition 

The following procedures describe how to add a new Basic data definition to Unifier.  

To create a basic data definition 

1) Click the Company Workspace tab and switch to the Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Basic. 

3) Click the New button. The Create New Data Definition window opens. 

4) In the Name field, enter a unique name for the data definition. 

 The name can include alphanumeric characters, spaces, dashes, and underlines. 

 The name is case-sensitive. 
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 The name cannot begin the name with a prefix reserved by Oracle Primavera: SYS, 
UUU, or Picker. 

5) In the Data Type field, specify whether the definition will be a string or integer data type. 

When you specify the data type, Unifier displays an additional field, Input Type. 

6) In the Input Type field, select the method the user will use to enter the data. 

7) Click Apply to open the data set tab, or OK to close the Create New Data Definition window.  

Add a Cost Code Data Definition 

 To create a cost code data definition 

1) Click the Company Workspace tab and switch to Administration Mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Cost Codes. 

3) Click the New button. The Create New Data Definition window opens. 

4) Enter a unique name for the cost code (General tab - Create New Data Definition block). 

The Category field is read only. 

5) Enter a Label for the cost code. 

6) Select an input type: either Text Box or Pull-down Menu. 

7) Click OK. 

Add a Data Picker Data Definition 

 To create a Data Picker data definition 

1) Click the Company Workspace tab and switch to Administration Mode. 

2) In the left Navigator, click Data Structure Setup > Data Definitions > Data Picker. 

3) Click the New button. The Create New Data Definition window opens. 

4) Enter a unique name for the Data Picker. 

5) Click the Select drop-down list and select a category for the list. 

6) Click the Data Source drop-down list and select a source. 

7) Click the Display Element drop-down list and select an element. 

The Data Element field is read only. 

8) Click OK. 

The Data Picker Data Definition appears in the Data Picker Data Definitions log window. 
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Adding and Managing Data Sets 

Data Set Values are applicable to data definitions that provide the user with a set of values from 
which to choose, for example, pull-down menus, radio buttons, and multi-select types. Some 
data definitions have been supplied with data set values; others must be entered. Data Set 
values can be added, removed or changed. 

Some examples of Data Definitions for which data sets must be defined: 

 Project/Shell Type, Project/Shell Site and Project/Shell Phase 

 Discipline (for example, Architectural or Engineering; appears on some business process 
forms) 

 Unit of Measure (appears for Line Item entry) 

 Spend Category (for certain Cost-type business processes) 

Add data set values to a pull-down (drop-down) menu or radio button 

You can add or import data set values for data definitions that require data sets. These values 
are used to populate the available choices on pull-down menu fields, radio buttons, or 
checkboxes on a form or attribute form. 

Note: The default values (in a drop-down list) are populated only on 
creation form of the business process.  

A couple of things to take note of: 

 You cannot set a default cost code value. 

 If the data definition is an integer type, and will be used in a formula, the value will be used in 
the formula, not the label. For integer data definitions, use care when assigning the value. 

 Avoid semicolons and commas in data set values, as this can cause problems in the 
selection list. 

To add data set values to a Data Definition (all except Multi-select Input) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Data Definitions>Basic or Cost Codes in the left Navigator. 

3) Select a data definition and click Open. The Modify Data Definition window opens. 
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4) Click the Data Set tab. 

5) Click Add. An editable row appears on the window. You can press the Tab key to move from 
one field to the next, or click inside a field. 

6) Enter a Value. This value is the data that is stored in the database. This value will appear on 
the form if you do not enter a label. 

7) Enter an optional Label. This is what is presented to the user as a pull-down menu or radio 
button option. This can be different from the value. 

8) In the Status field, enter Active or Inactive. The default is Active. If you want the value to 
remain on the data set but not show up for users at runtime, you can Inactivate it, rather than 
remove it. 

9) You can select the Default checkbox for one of the values on the data set list. This will 
display in the field at runtime. Selecting a default value is optional. 

10) To add another row, click Add. 

 To insert a data set value in the middle of the list, select a value and click Add. The new 
row will be added above your selection. 

 To add a new value to the bottom of the list, be sure a row is not selected, and click Add. 
(Or, press the Tab key and tab through the fields of the last row, until the Add button is 
highlighted.) 

11) If you want the data set list to be non-editable, then select the Non-Modifiable checkbox. 

Select this if you do want other users to be able to alter the list. Use caution before selecting
Non-Modifiable. Once you select this you will be able to rearrange the order and select a 
different default value but you will not be able to modify or remove values from the data set. 

If this option is selected by a user with create permissions, other users cannot modify the 
data set value list. If it is selected by a user with modify permissions, the option cannot be 
deselected again, except by a user with create permissions. 

12) Click Apply to save your entries, or OK to save and exit. 
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Add data set values to a multi-select Input data definition 

Multi-select input type data definitions allow users at runtime to select more than one value to 
enter into the field at runtime. In the field, the values the user selected are separated with the 
Separator displayed on the General tab of the Data Definition window (such as a comma). 

Note: Do not use an apostrophe (‘) in the data for a multi-select input 
type data definition. This can result in blank data in the selector. You 
cannot set a default value for this input type. 

To add data set values to a Multi-select Input data definition 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Data Definitions>Basic in the left Navigator. The Modify Data 
Definition window opens. 

3) Click the Data Set tab. 

4) Click Add. An editable row appears on the window. You can press the Tab key to move from 
one field to the next, or click inside a field. 

5) Enter a Value (128 character limit). This value will appear on the form. Values can contain 
spaces, but cannot contain the separate value (displayed on the General tab, for example, 
comma). 

6) In the Status field, enter Active or Inactive. The default is Active. If you want the value to 
remain on the data set but not show up for users at runtime, you can Inactivate it, rather than 
remove it. 

7) To add another row, click Add. (Or press the Tab key and tab through the fields of the last 
row, until the Add button is selected.) 

8) If you want the data set list to be non-editable, then select the Non-Modifiable checkbox. 

Select this if you do want other users to be able to alter the list. Use caution before selecting 
Non-Modifiable. Once you select this you will be able to rearrange the order and select a 
different default value but you will not be able to modify or remove values from the data set. 

If this option is selected by a user with create permissions, other users cannot modify the 
data set value list. If it is selected by a user with modify permissions, the option cannot be 
deselected again, except by a user with create permissions. 

9) Click Apply to save your entries, or OK to save and exit. 

Import data set values 

If you have a large number of data set values to enter (for example, if you want to populate a 
State pull-down menu with all 50 U.S. states), you can use a CSV file to import the values. This 
can be done for any data definition that uses a Data Set. 

Importing data set values consists of the following: 

Step 1: Export the CSV template file

a. Open the Data Definition and click the Data Set tab. 

b. Click the Export button. 
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c. Save the file to your local drive. The file will contain any values that have already been 
entered for the data set. 

Step 2: Complete the CSV file

a. Open the CSV template file. 

Note there are no column headers in the template. Start at the top left corner of the file. 
The first column of the CSV file is the Value and the second column is the Label. 

b. Delete any existing values. There cannot be duplicate values in a data set. 

c. For each row, enter the Value and the Label. Include only two columns, and do not 
include a header row in the file. Do not add a status column; the status will be Active by 
default upon import. 

d. Save the CSV file. 

Step 3: Import the CSV file

a. Click the Import button. 

b. Browse to the completed CSV file and click OK. 

New rows are appended to any existing entries. Unifier performs validation of the import 
file to ensure that valid CSV format is used. Duplicate entries are not allowed. After 
importing, you can rearrange the order of the rows if necessary. 

c. If you see an error message after importing, proceed to Step 4 below. 

Step 4: View the import validation error file (if applicable)

a. If an error occurs during import and you are presented with an error message, click Yes. 
You can then choose Open to open the file or Save to save the file to your local machine 
before opening. 

b. Open the error file, which is a CSV file. Error messages are listed next to the row in which 
the error occurred (for example, if you have a duplicate row). 

c. You can use fix the errors in this file (for example, remove duplicate rows) and re-import it 
after fixing the listed errors. Be sure to remove all extraneous text, including the error 
messages, before importing. 
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Modify or remove data set values 

You can edit or remove values in data set lists. When you modify an existing data set, the new 
values will become available when new records are created that use the field (for example, 
create a new business processes). 

To edit a data set value 

1) Open a Data Definition and click the Data Set tab. 

2) Double-click the value or label to modify. The field becomes editable. Edit the field as 
needed and click OK. 

To activate or deactivate a data set value 

1) Open a Data Definition and click the Data Set tab. 

2) Click the Status pull-down menu and choose Active to activate, or Inactive to deactivate. 
Click OK. 

Inactive values do not appear on the list at runtime. 

Active and Inactive data set values 

To remove a data set value from the data definition drop-down list 

1) Open a Data Definition and click the Data Set tab. 

2) Do one of the following: 

 To permanently remove a value, select it form the list and click Remove. 
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 To remove the value from the data definition drop-down selection list that the user is 
presented with, but retain it in the data set value list, click Inactive. 

3) Click OK. 

Reorder data set values 

You can rearrange the order of data set lists. When you modify an existing data set, the new 
values will become available when new records are created that use the field (for example, 
create a new business processes). 

To rearrange the order of the data set value list 

Once you have added the data set values, you can rearrange the order of their appearance on 
drop-down lists, multi-select input fields, and radio buttons. You can do this in two ways: 

 Using the Move Up and Move Down keys 

 Changing the order of the rows by editing the Row column 

To rearrange the order using the Move Up/Move Down keys 

1) Open the Status Definition window and click the Data Set tab. 

2) On the Data Set tab, highlight the data element and click the Move Up or Move Down key 
until the element is in the order you want. 

3) Click OK. 

To rearrange the order by Editing the Row column: 

1) Open the Status Definition window and click the Data Set tab. 

2) On the Data Set tab, highlight (or double-click) the row number of the element you want to 
reorder. 

3) Enter the new row number the element should occupy. 

4) Repeat step 2 for any other data elements you want to reorder. 

5) Click the Update Order button; click OK to save the change and close the window. 

Row numbering follows a relative numerical progression 

Row numbers on the list start at 1. When you change the order of the rows, you can enter just 
about any number; even positive, negative, and duplicate numbers. uDesigner will re-sort the 
rows by honoring the relative order of the numbers you enter. 

If you enter: 

 A negative number (e.g., -100): The row will move to the top, becoming row 1. If you enter 
two negative numbers, the "most negative" number becomes row 1, and the "next negative" 
number becomes row 2. 

 Zero (0): The row will move to the top, becoming row 1 (or the row following any negative 
number you entered). 
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 A number greater than the existing number of rows (e.g., 100 when there are only 50 rows): 
The row will move to the end, becoming row 50. If you enter two numbers greater than the 
existing number of rows (e.g., 100 and 101), the sort will honor the order of the numbers. In 
this example, 100 and 101 will become rows 49 and 50. 

 A duplicate number (i.e., the same number for two or more different rows): The 
duplicate-numbered rows will become adjacent rows (in no specific order). 

Example of row numbers before sorting: 

Edited row numbers: 

Row numbers after sorting: 
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Working with Data Elements 

A data element is a data field on a business process. Data Elements are defined by Data 
Definitions. The data element properties are defined by the Data Definitions.  

You can use a Data Definition to define the properties of more than one data element. Data 
Elements are defined under the Data Structure Setup node as well as the Attribute forms in 
Unifier. 

You can export a CSV file listing specific data elements.  

You can also view the usage of each data element, that is, the list of specific business 
processes where the data element is used. 

Access Data Elements 

To access the Data Elements log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Elements in the left Navigator. The Data Elements log 
opens. 

The log lists the data elements used for your company. For each data element, the log 
displays the Data Definition on which it is based, the Form Label, which is how the data 
element appears on a form, and Usage. 

Export Data Elements 

You can create a CSV file containing the current list of data elements. This can be useful if you 
need to create different combinations of data set values for Dynamic Data Sets, taking from 
different sources of data definition data set values. 

To export data elements 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Elements in the left Navigator. The Data Elements log 
opens. 

3) From the Data Elements log, click the Export button. You may Open the file to preview it or 
Save it to your local drive. 

4) Name the file and click Save. 

View Data Element Usage 

The Usage button in the Data Elements allows you to view the business processes or attribute 
forms that the data element is being used. 

To view data element usage 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Elements in the left Navigator. The Data Elements log 
opens. 
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3) From the Data Elements log, select a data element and click Usage. The Usage window 
displays the forms that use the data element. 

Modify Data Element 

When you open a Data Element in the Data Elements log, the Modify Data Element window 
opens. The following fields are available in this window:  

 Data Element Name 

 Data Definition Source 

 Form label 

 Description 

 Tooltip 

You can enter the system-level tooltip in the field. 

Upper Forms

Navigate to Company Workspace tab > Admin mode > uDesigner node > Business 
Processes node. Click to select a BP > Click Upper Forms to open the Forms log. In the 
Forms log, the Tooltip toolbar option enables you to see the list of Data Elements of the 
combined Upper Forms. 

Detail Forms

Navigate to Company Workspace tab > Admin mode > uDesigner node > Business 
Processes node. Click to select a BP > Click Detail Form to open the Detail Form log. In 
the Detail Form log, the Tooltip toolbar option enables you to see the list of Data Elements 
of the combined Detail Form. 

RFB Business Process

There are four types of tooltip: 

 Requestor > Upper Forms

 Requestor > Detail Form

 Bidder > Upper Forms

 Bidder > Detail Form

Other Business Processes 

There are two types of tooltip: 

 Upper Forms

 Detail Form

In the Tooltip window, click the Data Element (for example, status), click Update from Data 
Element Properties (system-level) to open the Edit Tooltip window, enter the text in the 
field. Use the arrows (<< or >>) to move to the next Data Element (for example, title) and 
enter the text in the field.  

You can perform bulk update from Data Element properties. In the Tooltip window click 
Update from Data Element Properties to open the Update tooltip Description window. 
Ctrl+click on multiple data elements to select and click Update. 

Internationalization and Tooltips 

All the tooltips are extracted as custom strings. 
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Go to Company Workspace tab (Admin mode) > Configuration > Internationalization. 

Click Find to open the Find window. 

Select uDesigner in the Source Type equals field. 

Enter "tooltip" in the String contains field. 

Configuring Dynamic Data Sets 

This flexible uDesigner option can be used on business processes and attributes forms. It allows 
one data element on the form to the control both values and behavior of other data elements on 
the same form. 

A dynamic data set is comprised of a "set" of data elements that includes a master data element 
and dependent data elements, which can be pull-down menus or radio buttons. The values that 
are available to users at runtime for the dependent fields are dependent on the selection the 
user makes for the master data element field. A dynamic data set can be used on business 
processes and attributes forms, and allows one data element on the form to the control both 
values and behavior of other data elements on the same form. 

For example, you can define a dynamic data set that includes a Country, State, City, Postal 
Code and Zip Code data elements that function as pull-down menus on a form. The Country 
field is a master data element. The set can be configured so that, at runtime, the user must 
select a value for Country, which dynamically controls the values that are available to be chosen 
for State. The user then selects a State, which drives the choices available for City. 

Field behavior (such as required, or read-only) can also be controlled by the dynamic data set. 
For example, a dynamic data set might include data elements for Country, Zip Code and Postal 
Code. At runtime, depending on the selected value for the Country, the Zip code field may get 
become enabled and a required field, while the Postal Code field becomes disabled. 

How to set up a dynamic data set 

Dynamic data sets are imported automatically when you import a business process or attribute 
form that has the dynamic data set on it. 

Setting up a dynamic data set consists of the following: 

1) Prepare elements and data set values. View dynamic data set properties to identify 
elements of the dynamic data set: 

 Master Data Element, which drives the behavior of the set. 

 Value Set, which lists the data elements whose values will be controlled by the master 
element (for example, if the master element is Country, then the value set might include a 
pull-down data element State, the values of which will change depending on the country 
chosen). 

 Behavior Set, listing elements whose behavior is controlled by the master element (for 
example, a field that becomes Required, Disabled, or Disabled and Clear depending on 
the value chosen for the master element (for example, the Country chosen might dictate 
whether the Postal Code or Zip Code field is enabled for the user). 
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Verify that data definition data sets are populated. The data elements that can be part of a 
dynamic data set can be pull-down menus or radio buttons. The values for the selections are 
maintained in the Data Set tab of the data definition properties. Be sure that the individual 
data definitions have valid data sets. (For example, if you have a State pull-down data 
element, the data set corresponding to the data definition for the State field must be 
populated with the state options you wish to make available to users. 

2) Define the Value Set and Behavior Set. The value set consists of the fields whose values 
will be controlled by the master data element selection at runtime. The Master data element 
is the first element on the list. You will define the values that display at runtime. 

The behavior set contains the fields whose behavior (Required, Disabled, Disabled and 
Clear) will be controlled by the master data element selection at runtime. While Required
contains a required text field and Disabled changes the field to read-only, Disabled and 
Clear clears any previous values in the field and then disables the field, making it read-only. 
With selecting Disabled and Clear, you avoid entering invalid data and therefore improve 
data entry.  

Access dynamic data sets 

Dynamic data sets are imported into Unifier when a business process or attribute form on which 
they appear are imported. 

To access dynamic data sets 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

View dynamic data set properties 

The dynamic data set properties and data elements are designed in uDesigner. The properties 
window identifies: 

 Master Data Element, which drives the behavior of the set. 
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 Value Set, which lists the data elements whose values will be controlled by the master 
element (for example, if the master element is Country, then the value set might include a 
pull-down data element State, the values of which will change depending on the country 
chosen. 

 Behavior Set, listing elements whose behavior is controlled by the master element (for 
example, a field that becomes Required or Disabled depending on the value chosen for 
the master element (for example, the Country chosen might dictate whether the Postal 
Code or Zip Code field is enabled for the user). 

To view dynamic data set properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set to edit and click Properties. The Properties window opens. The 
Properties window is view-only. 

4) The General tab displays the general information about the dynamic data set: 

 Name and Description 

 Master Data Element: the data element that serves as the master data element for the 
set 

 Data Definition: the data definition corresponding to the master data element. The data 
definition will be a pull-down menu or radio buttons. The values available for the master 
data element are entered in the Data Set tab for the data definition. 

 Form Label: the form label of the master data element 

5) Click the Value Set tab. This tab displays the data elements of the value set, which are the 
fields whose values will be controlled by the master data element selection at runtime. The 
Master data element is the first element on the list. Values of each data element are based 
on the data set values defined under base Data Definition. 

6) Click the Behavior Set tab. This tab displays the data elements of the behavior set, whose 
behavior (Required, Disabled) will be controlled by the master data element selection at 
runtime.  

Define the value set and behavior set values 

You can add values to dynamic data sets manually one a time, or by importing multiple values 
from a CSV file. The following describes adding dynamic data set values manually. 

Fields defined with a Value Set have values limited by the master data element. For example, a 
Country master data element can control the values that display for a State field. 

To define the value set and behavior set combination 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 
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4) Click New. The Add/Edit <set name> window opens. 

5) Complete the window. The fields on the window will depend on how the dynamic data set 
was designed. It may include a value set, a behavior set, or both: 

 Value Set: These are the data elements that will be controlled by master data element 
selection at runtime. The Master data element is the first element on the list. 

Click the drop-down list and select a value for each data element. The drop-down list values 
are based on the data set values defined under the base data definition. 

In the example in the following figure, the value set is Country and State. At runtime on the 
form, when the user selects a Country, the State field will populate with the states that are 
associated with that country. These value sets determine the combinations of Country-State 
that display. 

 Behavior Set: The behavior of these data elements (Required, Disabled, Disabled and 
Clear) will be controlled by the master data element selection at runtime. 

Click the drop-down and select Required (Field displays a *), Disabled (Field is read-only), 
or Disabled and Clear (Field is cleared and disabled, becoming read-only). If you leave the 
selection blank (or "Select" on the drop-down), there will be no change in behavior for the 
element. 

In the example in the following figure, the behavior set is Mail Stop and Zip Code. In this 
case, at runtime, depending on the Country chosen, either Mail Stop or Zip Code will become 
a required field, or will be disabled. 

6) To add another Value Set and Behavior Set combination, click Add, which will save the 
combination you just entered and allow you to add another. 

7) When you are done adding combinations, click OK. The set displays on the dynamic data 
set log. 
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Data Elements that can be set as Disabled and Clear 

The behavior set fields of all data types can be set as Disabled and Clear. Exceptions are 
mentioned below: 

 Status 

 Due_Date 

 Creator_ID 

 Record_No 

 Data elements starting with “uuu”  

 Data definitions starting with “SYS,” and the ones not of the following input types: 

 Text 

 Textarea 

 Picker 

 Date Picker 

 Date Only Picker 

 Bitemid  

Import dynamic data set values 

Importing dynamic data set values consists of: 

Step 1: Export the CSV template file

a) Click the Export button. 

b) Save the file to your local drive. 

Step 2: Complete the CSV file

a) Open the CSV template file. 

b) Enter values for each column as applicable: 

 Value set: The columns correspond to the date elements that make up the value set. 
The values you enter here must match values in the data set for the data definition. 

 Behavior set: The behavior set column is labeled with a (B). Valid values are Required
(makes the data element a required field), Disabled (the data element is read-only),
Disabled and Clear (Field is cleared and disabled, becoming read-only), or you can 
leave it blank. 

c) Save the CSV file. 

Notes:

 When using a CSV template file, the following header is displayed: 
"For data elements that are required, enter Required as a value. To 
disable a data element, enter Disabled as a value. To disable and 
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clear any previous value, enter Disabled and Clear. Do not enter 
any value if there is no behavior change needed.” 

 If the CSV template has restricted DEs in the behavior set and the 
value of Disabled and Clear has been set for the restricted DEs, 
then the system prevents the import and an alert is seen.  

Step 3: Import the CSV file

a) Click the Import button. 

b) Browse to the completed CSV file and click OK. 

c) To download a CSV file containing status details of the import, click Yes at the prompt. 

The rows that you completed in the CSV file are appended to existing entries. Duplicate 
entries are allowed. 

Delete a dynamic data set combination 

You can delete a dynamic data set combination (value set and behavior set). This removes the 
combination from use with the dynamic data set. 

To delete a dynamic data set combination 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 

4) Select an entry and click Delete. Click Yes to confirm. 

Edit a dynamic data set combination 

When you edit a dynamic data set, any changes you make will not reflect in forms. The data 
element must be deleted from the form and added again in uDesigner, and the form re-imported. 

To edit a dynamic data set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

3) Select the dynamic data set and click Open. The dynamic data set log opens for the 
selected set. 

4) Select an entry and click Open, or double-click to open. 

5) Make modifications to Value Set or Behavior Set as necessary and save. 

View dynamic data set usage 

You can view the forms on which a dynamic data set is used. 
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To view dynamic data set usage 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup>Dynamic Data Sets in the left Navigator. The Dynamic Data 
Sets log opens. 

3) Select a dynamic data set and click the Usage button in the toolbar. The Usage window 
opens, listing the forms on which the dynamic data set is used. 
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Creating Data Views 

Unifier Data Views use SQL queries that are defined against Unifier system tables and business 
process tables. Data Views are used in Unifier Custom Reports, User-Defined Reports (UDRs), 
and Shell dashboards. 

Note: The User-Defined Reports (UDRs) can be created at Company, 
Shell, or Project levels. 

Data views must contain project_id in the SQL query for the data view to be displayed in a 
Project/Shell level UDR data type list. 

Note: Data views published prior to the Primavera Unifier 9.5 release 
must be republished (i.e., set to draft status and then reset to published 
status) before they show up in the UDR data type list. 

Before you begin: Define your reporting requirements first. Collaboration between business 
users and technical development teams helps identify the data you need to collect and how to 
present that data so report recipients will have an easy-to-read, useful report. 

Step 1: Set permissions for data view creation. See Grant Permissions for Data View 
Creation (on page 46). 

Step 2: Create data views. See Create and Publish Data Views and Metadata (on page 46). 

 Data views must be published (as indicated by the Publish Date) before you can use 
them as data sources in UDRs, data cubes, or custom reports. 

 Test your data view SQL queries in the Unifier Development/Test environment before 
deploying them in the Unifier Production environment because only by testing can you 
be sure the query is valid and returns the desired data. Oracle recommends that you test 
your SQL queries in the Development environment prior to deploying them in the Test
environment or Production environment.  

Note: See the Internationalizing Unifier Environments section for 
translation information. 

Step 3: View data and metadata. See View data (query results) and metadata (columns) in 
the view (on page 49). 

Step 4: Export data. See Export data (query results) (on page 50). 

The Data Views are included in:  

 Custom Report that are using Data Views and ready for Production environment. 

 Data Cube that are using Data Views and ready for Production environment. 

 User-Defined Report (UDR) that are using Data Views and ready for Production 
environment. 
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Grant Permissions for Data View Creation 

To grant permission for data view creation 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select Administration Mode Access > Data Structure Setup > Data 
Views. The Permission Settings window opens. Here you can add, modify, or remove 
permission settings. 

4) Click the Add button. Another window called Permission Settings opens. 

5) Click the Add Users/Groups button. The Users/Groups window opens. 

6) Select the intended users and/or groups and click the Add button 

7) Click the OK button to return to the Permission Settings window. 

8) Select the users or groups in Select Users/Groups, located in the upper portion of the 
window, and select the appropriate level of access for the user or group in Permissions 
Settings, located in the lower portion of the window. 

View: allows users and groups to see the data view settings 

Create/Modify, allows users and groups to define or change data view settings. This setting 
includes View permission. 

9) Click the OK button. 

10) Click the Apply button to save changes and keep the window open, or the OK button to save 
changes and close the window. 

Create and Publish Data Views and Metadata 

After you create a data view, you must publish it to be able to use it in user-defined reports, data 
cubes, or custom reports. There are two things to know about using data views in user-defined 
reports: 

 Data views must contain project_id in the SQL query for the data view to show up in a 
project or shell-level UDR data type list 

 Data views published prior to the Primavera Unifier 9.5 release, must be republished (i.e., 
set to draft status and then reset to published status) before they show up in the UDR data 
type list 
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Depending on the data elements you choose, you might need to publish the metadata 
associated with the data view. For example, if the selected data element has a data definition 
type of pull-down Menu, you will have to publish the metadata to see the actual label of the 
pull-down rather than the value. In the case where a data element is defined as Actual Value?
based on a Yes/No data element, with 0= No and 1=Yes, if Actual Value? is used in the data 
view, then you need to publish the metadata of Actual Value? to get the Yes or No value rather 
than 0 or 1. 

To create Data Views 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Views in the left Navigator. The User-Defined Data 
Views log opens. 

3) Click New. The User-defined View window opens. 

4) The Prefix is auto-populated with the company short name. Enter the name of the Data 
View, the label, an optional description, and the SQL query for the Data View. For further 
details on how to create SQL queries used in the creation and management of Data Views, 
please consult the Oracle Consulting Services team. 

5) Click OK. 

Note: When creating data views, the column naming convention must 
follow the Oracle DB guidelines. Do not use the Oracle-reserved words 
such as "(", ")" and so forth to name the column. For details, refer to 
Oracle DB guidelines.  

To publish Data Views 

1) Go to Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Data Structure Setup > Data Views. The User-Defined Data Views 
log opens. 

3) Select an unpublished Data View. 

4) Click the Status button. 

5) Select Published. 

6) Click OK. 

To publish metadata 

You can associate metadata with its Unifier data set for both labels and values. Data views tend 
to contain technical shorthand from system and SQL abbreviations. While clear to the technical 
person who wrote the data view, report consumers will appreciate seeing the same field labels 
and field value selections they see in their business processes and managers. 

For example, in your data view you might include the data element "year_pd," which represents 
a pull down menu with selections for different years assigned to its data set. In your user-defined 
report, you might want to see the label "Year" instead of "year_pd;" and you might want to query 
on meaningful values, such as 1999, 2001, 2002, etc., instead of the numeric values of the data 
definition, 1,2,3, etc. 

1) In the User-Defined Data Views log, select a published Data View. 
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2) Click the Metadata button. 

3) Double-click in the Definition field for each data element and select the data definition for 
the selected element. The data definitions available for selection are filtered by the data 
elements used. 

4) Double-click the Label field for each element you want to use in the UDR. Rename it to 
whatever you want to see in the report. 

5) Click Publish Metadata. 

Tips 

The SQL definition will consist of the SQL query used to populate the report with specific data 
based on the desired output.  

Note: If using the data view as a Main view in a Project level report, you 
must have a column named project_id. If using the data view in a 
Program level report, you must have a column named program_id. 

For example, a Project level data view for a company registry "companyReg" can be like this 
below: 

SELECT   pu.PID as PROJECT_ID,  

         p.PROJECTNUMBER as PROJECTNUMBER,

         c.COMPANYNAME as COMPANY_NAME,

         c.SHORTNAME as COMPANY_SHORT_NAME,

         c.DESCRIPTION as COMPANY_DESCRIPTION,

         c.CONTACTNAME as COMPANY_CONTACT_NAME,
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         u.FULLNAME as USER_FULL_NAME,

         u.USERID as USER_ID,

         u.USERNAME as USER_NAME,

         u.EMAIL as USER_EMAIL

FROM     companyReg_SYS_USER_INFO_VIEW u,

         companyReg_SYS_COMPANY_INFO c,

         companyReg_SYS_PROJECT_INFO p,

         companyReg_SYS_PROJECTUSER pu

WHERE    c.COMPANYID = p.COMPANYID

  AND    p.PID = pu.PID

  AND    u.userid = pu.userid

View data (query results) and metadata (columns) in the view 

The Data button will return the query results of the view (essentially, a preview of the report 
results, without any user entered parameters). 

The Metadata button will return all of the columns in the view. The Metadata button will return 
the definition of the columns: names, type and labels of the columns used in the view. For 
example: 

To view query results 

1) In Administration Mode, go to the Company Workspace tab and click Company > Data 
Structure Setup > Data Views in the left Navigator. The User-Defined Data Views log 
opens. 

2) Select a view in the User-Defined Data Views log. 

3) Click the Data button. The results window will display the query results. 

To view columns 

1) Select a view in the User-Defined Data Views log. 

2) Click the Metadata button. The results window will return all of the columns in the view. 

If the Data View is in Draft status, then the metadata that you see will be based on the last 
Published data. If the Data View has not been published before, then no data is displayed. 

You can delete a Data View that was included in the configuration package, indirectly. 

Note: Although deletion of a Data View is possible, if a Data View has 
been used in a UDR, Custom BI Publisher report, or Data Cube that was 
included in a configuration package, then the configuration package 
creation will fail because of the missing data views. 
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Export data (query results) 

The results of the data query can be exported as CSV or SQL files. 

To export data as CSV 

1) Select a view in the User-Defined Data Views log and click the Data button. The results 
window will display the query results. 

2) Click the Export As CSV button. 

3) At the prompt, you can choose to Open or Save the resulting CSV file to your local drive. 

The CSV file will contain the data that is displayed on the results log window. By default, the first 
100 lines will be displayed. You can click the Display drop-down (in the upper right corner of the 
results log window) and choose 200 to display the first 200 lines. When you click Export As CSV, 
the CSV file will contain the 100 (or 200) lines displayed in the window. 

Only the 100 or 200 rows will be exported at a time. You cannot export the entire result of the 
view (for example, if there are more than 200 rows) in one click. You must export in groups of 
200 rows at the maximum and then manually combine the exported results. 

To export data as SQL 

1) Select a view in the User-Defined Data Views log and click the Data button. The results 
window will display the query results. 

2) Click the Export As SQL button. 

3) At the prompt, you can choose to Open or Save the resulting SQL file to your local drive. 

This will export your SQL script to create the table required for the data view and the data 
itself. 

Notes on Working with the Oracle Database

 Only the 100 or 200 rows will be exported at a time. You cannot 
export the entire result of the view (for example, if there are more 
than 200 rows) in one click. You must export in groups of 200 rows at 
the maximum and then manually combine the exported results. 

 Note that SQL export files have the .sql extension and work best with 
the Oracle database as the field types used in the creation of the 
data view are of Oracle type (for example, VARCHAR). If the 
exported SQL file is to be used in a database other than Oracle, you 
must manually modify that file to replace the field types with the 
types that work with the non-Oracle database. 

 Unifier uses a field type called TIMESTAMP for all date or time fields, 
so you must modify the session date format to match the timestamp 
used in Unifier. For example, you can run the following statement for 
an Oracle database: ALTER SESSION SET NLS_DATE_FORMAT = 
'YYYY-MM-DD HH24:MI:SS'; 

 If you are building multiple data views based on other data views, 
changes a data view in the lower hierarchy (example adding a new 
data element) will necessitate the dependent views to be refreshed 
by changing them to Draft and then republish the data views to 
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incorporate the changes. For example, if Dataview 2 is based on 
Dataview 1, and you add a new field to Dataview 1 and then 
republish it. You must then change Dataview 2 to Draft and then 
republish it so that it will contain the change you made in Dataview 1. 

 Additional cleaning of the data (in case of export to SQL file) might be 
needed if there are (‘) apostrophes in the values of some fields, or if 
there are ampersands (&). This will result in inconsistent values 
between the results in Unifier and the result in the local database 
after import. 

View Data View Usage in Reports and Data Cubes 

To view reports and data cubes in which a Data View is used 

1) Select a view in the User-Defined Data Views log. 

2) Click the Usage button. The Usage window opens, listing the reports and data cubes in 
which the data view is used. 

Edit data views 

Data views must be in draft mode to edit. 

To edit data views 

1) In Administration Mode, go to the Company Workspace tab and click Data Structure 
Setup > Data Views in the left Navigator. The user defined Data Views log opens. 

2) Select a data view in the User-Defined Data Views log. 

3) Click Status and select Draft. 

4) Click the Open button to access the SQL statement. 

5) Edit the SQL statement and click Apply or OK to save changes. 

6) Highlight the data view and click Status. 

7) Select Publish to make the data view available for use in user defined reports, data cubes, 
and custom reports. 

Delete Data Views 

To delete Data Views 

1) Select a view in the User-Defined Data Views log. 

2) Click the Delete button. You will receive a confirmation message that you want to delete the 
selected Data View. 
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Notes: 

 You cannot delete Published Data Views. You must change the 
Status to Draft to be able to delete a Data View. 

 Although deletion of a Data View is possible (when in Draft status), if 
a Data View has been used in a UDR, Custom BI Publisher report, or 
Data Cube that was included in a configuration package, then the 
configuration package creation will fail because of the missing data 
views. 

Review Unifier Database Table Structure 

Before building your SQL statement, review the Unifier database table structure. 

You can find the Unifier database table name in two ways: 

1) Using Entity Reference (ER) Views

1. Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > Data Structure Setup > ER Views. 

2. Open Business Processes View. 

3. Use your browser search function and search for a BP you want to report against (for 
example, Invoices). 

4. The name of the table appears under the BP Name, in blue (for example, UNIFIER_UI. 
The word "unifier" is the prefix and common to all BP tables. The UI is the ID of the 
Invoices BP).  

2) Using BP IDs

1. Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > uDesigner > Business Processes. 

2. Locate the BPs that you want to use in the report and find the IDs (first column). 

3. Add your deployment prefix and add an underscore ( _ ) to get the table name (for 
example, UNIFIER_UI). 

Note: To access the Line Items of a BP, add _LINEITEM to the table name (for example, 
UNIFIER_UI_LINEITEM). 

The following lists the column names: 

 Field Name 

 Definition 

 SQL Type 

 Label 

 Description 
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Creating Data Cubes 

Data cubes comprise data that you can use to render a variety of charts (bar, area, column, line, 
and table) in a custom dashboard (either at company-level or shell-level), or in a custom data 
block of a shell dashboard. In this way you can visually compare aspects of your data set. 

Data cubes are either company level or shell level. The data source for data cubes can be from 
a business process or a manager attribute form, or from a data base query. Unifier does not limit 
the number of data cubes you can create. 

Creating a data cube requires that you: 

 Granting permissions for Data Cube (on page 56) to create a data cube 

 Defining a Data Cube (on page 53) a new data cube, which includes 

 Selecting the data source for the data cube 

 Completing the data cube properties 

 Publishing the data cube 

 Granting permissions for Data Cube (on page 56) so they can view the data cube 
composition in Data Cube Definitions 

In This Section 

Defining a Data Cube .............................................................................................. 53 
Selecting data sources ............................................................................................ 55 
Adding data elements .............................................................................................. 55 
Defining queries ....................................................................................................... 56 
Granting permissions for Data Cube ........................................................................ 56 
Publishing Data Cube .............................................................................................. 57 

Defining a Data Cube 

To define a data cube 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Cube Definitions in the left Navigator. The Data Cubes 
log window opens. 

3) Click either New > Shell Data Cube or New > Company Data Cube. The Create Data Cube 
window opens. 

4) Select Data Type or Data View. 

 A data type comprises business process and manager attribute forms 

 A data view comprises results from a data base query 
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Note: When creating data cubes, data views are only seen when you 
select Data View as the source. This is different from UDR creation 
when data views are listed with data types. 

5) Click OK. The Data Cube window opens. 

6) Complete the General tab. 

Name: enter a unique name for the data cube 

Description: this field is optional 

Data Type: this read-only field is automatically completed with the data type selection 

Type: this read-only field is automatically completed with the level selection 

7) Click the Data Source tab. On this tab you can add the data sources you want to include in 
the data cube, for example, a business process, workflow, or shell. 

8) Click the Add button. The Data Sources window opens listing all available data sources for 
this data cube. 

9) Select at least one data source. You cannot move to the next tab or save the data cube 
without a data source selection. You can add as many data sources as are available. 

10) Click the Data Elements tab. 

11) Select at least one data element. You cannot save the data cube without a data element 
selection. You can add as many data elements as are available. 

The selected data elements are arranged in the Data Elements pane in a grid; the table 
below describes the columns. 

Field Description 

Data Source The data element data source. 

Label The data element label. You can modify this label. 

Name The data element name. 

Type The data element type. 

Group 
Click to define whether the data element can be used as a Grouping 
element when the data cube is used. 

Summary 
Click to define whether the data element can be used as a Summary 
type. 

On this pane you have the option to add functions. To do so, click Add Functions. Select a 
function type: Formula, Date Difference, Date Add, Date Function. 

 For Formula click Create. Create a formula and click OK. The data source available for 
the formula are based on the data sources you selected in the Data Sources tab. 

 For Date Difference enter a column heading name, specify the dates, and whether to 
show partial days. Click OK. 

 For Date Add enter a column heading name, specify the date and the add function. Click 
OK. 

 For Date Function enter a column heading name and specify the date. Click OK. 

To modify a data element, select the data element and click the Modify button. 
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To remove a data element, select the data element and click the Remove button. 

Use the Move Up or Move Down buttons to reorder the listed data elements. 

12. Click the Query tab if you want to add one or more queries to the data cube. See Define 
report queries (query condition) (on page 583). 

Data Cubes and Configuration Package 

Data Cubes are used for creating Shell dashboards. Data Cubes defined in the 
Development/Test environment can be transferred to the Production environment.  

You can pick and choose which Data Cubes to transfer by including the needed Data Cubes in 
the Component List and creating a Configuration Package by using the list.  

The Data Cubes log window contains the following columns: 

 Name 

 Description 

 Type 

 Source 

 Last Modified 

 Published Date 

 Last Published By 

When the configuration package is created, the system will check to ensure that the Data Cubes 
that have been included are in Publish status or not. If the Data Cubes that have been included 
are not in Publish status, then an error message is displayed at the time of creating the 
configuration package. 

Selecting data sources 

To select data sources for data cubes: 

1) Click the Data Sources tab. This tab lists the available data sources for the data cube. 

2) Click Add to add a data source. The Data Sources window opens. 

3) Select one data source or multiple data sources and click OK. 

4) To remove a data source, select a data source and click the Remove button. 

5) Next, define data elements in the Data Elements tab, as described in the following 
procedure. 

Adding data elements 

To add data elements for data cubes 

1) Click the Data Elements tab where you will see the fields listed in the table below these 
directions. 

2) Click Add Elements. 

3) Select one data element or multiple data elements and click OK. 

4) Click Add Functions. Select a function type: 
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 Formula: Click Create a formula and click OK. The data source available for the formula 
are based on the data sources you selected in the Data Sources tab Date Difference: 
Enter a column heading name, specify the dates, and whether to show partial days. Click 
OK. 

 Date Add: Enter a column heading name, specify the date and the add function. Click 
OK.  

 Date Function: Enter a column heading name and specify the date. Click OK. 

Field Description 

Data Source The data element data source. 

Label The data element label. You can modify this label. 

Name The data element name. 

Type The data element type. 

Group 
Click to define whether the data element can be used as a
Grouping element when the data cube is used. 

Summary 
Click to define whether the data element can be used as a 
Summary type. 

Additional actions you can take 

 Modify a data element by selecting the data element and clicking the Modify button. 

 Remove a data element by selecting the data element and clicking the Remove button. 

 Reorder the listed data element by using the Move Up or Move Down buttons. 

Defining queries 

To define queries for data cubes 

1) Click the Queries tab. 

2) Build a query. See Define report queries (query condition) (on page 583) for details on 
creating queries. 

3) When you have finished working with the Data Cube window tabs, click OK. 

Granting permissions for Data Cube 

To grant permission for data cube creation, modification, or viewing 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select Administration Mode Access > Data Structure Setup > Data 
Cube Definitions. The Permission Settings window opens. Here you can add, modify, or 
remove permission settings. 

4) Click the Add button. Another window called Permission Settings opens. 

5) Click the Add Users/Groups button. The Users/Groups window opens. 
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6) Select the intended users and/or groups and click the Add button 

7) Click the OK button to return to the Permission Settings window. 

8) Select the users or groups in Select Users/Groups, located in the upper portion of the 
window, and select the appropriate level of access for the user or group in Permissions 
Settings, located in the lower portion of the window. 

Create/Modify: You must have Create/View permission to create or define or change data 
cubes. This setting includes View permission. 

View: You can use this setting to allow users and groups to see the data cubes. 

9) Click the OK button. 

10) Click the Apply button to save changes and keep the window open, or the OK button to save 
changes and close the window. 

Publishing Data Cube 

You must publish data cubes to make them available for use in the configurable dashboard. 

To publish data cubes 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Data Structure Setup > Data Cube Definitions in the left Navigator. The Data Cubes 
log window opens. 

3) Select a data cube and click the Publish button. 

Note: You can modify a published data cube, but you must republish it to 
make the changes available to users. 
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Configuring and Publishing BI Publisher Custom 
Templates (Custom Prints and Reports) 

Unifier integrates with BI Publisher to deliver on-demand web-based reporting through Unifier. 

Custom Reports, built in BI Publisher, enable the Company Administrator (or power user) to 
build visually stunning, detailed reports. For example: 

 A report that combines  information from multiple (and possibly non-linked) Business 
Processes (BPs) 

 A report that needs professional looking graphics, charts, images, or clip art 

The following sections explain the steps you need to take for creating Custom Reports in Unifier 
with BI Publisher. 

The following sections explain how to configure custom prints and custom reports in the BI 
Publisher (Oracle Business Intelligence (BI) Publisher or BIP). 

To publish custom prints and custom reports: 

1) Prepare the custom print or custom report 

2) Click Status

3) Select Publish



Unifier Modules Setup Administration Guide

60

Note: Oracle supports the delivery of BI Publisher reports in PDF format 
by way of email, only. 

In This Section 

Custom Templates (Custom Prints and Reports) Overview ..................................... 60 
Assigning Roles and Permissions to BI Publisher User to Publish and Run Unifier 
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Custom Templates Windows Log ............................................................................ 65 
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Custom Templates (Custom Prints and Reports) Overview 

To access Custom Prints and Reports sub-node: Open Unifier > Company Workspace tab > 
Admin mode > Configuration > Custom Templates.  

Note: To run custom reports, access Reports node: Open Unifier > 
Company Workspace tab > User mode > Reports. Data views are 
required for creating custom reports. 

The New option of the Custom Templates log window (or File > New) enables you to create 
the following: 

Option Description 

Custom Print When the user clicks New > Custom Print > Custom Print with 
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Option Description 

with Internal Data 
Model

Internal Data Model, the print template window displays the Data 
Model Type set as Internal Multiple. 

Any new custom print templates will be of data model Internal 
Multiple and can be used for bulk printing and single-record 
printing. Existing custom print templates of data model type 
Internal can still be used for single-record printing. 

The tags generated for the XML data in the Sample data tab are 
grouped differently for data model type of Internal Multiple, and 
the template designers must use the new XML data structure and 
create layout templates. 

Custom Print 
with External 
Data Model

External data models can be created outside of the Unifier system. 
They can include links to multiple tables and pull data from 
multiple Business Processes. These data models can be used to 
create custom print templates. You can create a Custom Print 
template based on an external data model. The concept of 
creating a Custom Print template based on an external data model 
is similar to the concept of creating a Custom Print template based 
on an internal data model, except that the user creates, uploads, 
and maintains the data model needed for creating Custom Print 
template based on an external data model. 

When the user clicks New > Custom Print > Custom Print with 
External Data Model, the print template window displays the Data 
Model Type set as External Multiple. 

Any new custom print templates will be of data model External 
Multiple and can be used for bulk printing and single-record 
printing. Existing custom print templates of data model type 
External can still be used for single-record printing. 

The external data model must contain parameters that support 
printing of multiple records. The Record IDs pass as comma 
separated value. 

Report with 
Internal Data 
Model

Create a new BI Publisher Custom Report based on the standard 
data model, which is generated and maintained internally by 
Unifier. When you save the BI Publisher Custom Report, Unifier 
saves changes applied to the following in the data model: 

 Data views 

 Data links 

 Query parameters 

 Additional parameters 

The Custom Report window contains the following tabs and 
fields: 

General

 Name 

 Description 
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Option Description 

 Data Model Type  

The value for the Data Model Type field in the General tab is set 
to Internal (read-only). 

 Report Level 

 Main View 

Views

Your selected values for the Report Level and Main View fields 
(General tab) determines the fields in the Views tab. 

 Description 

 Data Model Type  

The value for the Data Model Type field in the General tab is set 
to Internal (read-only). 

 Report Level 

 Main View 

- The Main View is no longer a mandatory field while creating the 
Report with External Data Model. 

- Users can add the Main View to a Report with External Data 
Model if they want to add query parameters for the report. 

Query

Parameters

Report with 
External Data 
Model

Create a new BI Publisher Custom Report to upload the custom 
data model file created using BI Publisher.  

Unifier will not maintain the data model file. 

You can generate sample data for external model based report 
provided that the external model based report is published at least 
once. To do this, you have to externally modify the .XDM file either 
manually or by using the BI Publisher data model editor, then 
re-upload the report. 

This option has the same tabs as the Report with Internal Data 
Model option. 

The value for Data Model Type field in the General tab is set to 
External (read-only). 

The value for Main View depends on the following conditions: 

 If an External Data Model was generated by converting an 
Internal Data Model report, then the value for Main View will 
be set according to the Internal Data Model report.  

 The user will be allowed to deselect the value for Main View
and save the report only if there are no Query parameters 
defined for the converted report. 

 The user will be able to generate sample data as before. 
Generation of sample data will be possible after the report has 
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Option Description 

been published at least once. 

Custom Email 
with Internal Data 
Model

Customize the emails that are sent to bidders who are not a part of 
the Unifier system. You can include any of the business process 
data, and the email-related data, in the notification that you want to 
sent to the bidder. This option is used to send email notifications 
for the Request for Bid (RFB) business processes. 

The Custom Email window contains the following tab and fields: 

General

 Name 

 Description 

 Data Source 

Lists the Request for Bid (RFB) business processes to enable 
you to create the custom email notification. 

 Data Model Type  

The value for the Data Model Type field in the General tab is 
set to Internal (read-only). 

 Email Type 

 Login Information 

 Bid Invitation 

 Due Date Change 

Once finished, click Apply to set the values for your template and 
sample data in the following tabs of the updated Custom Email
window: 

Template File

You can upload multiple Rich Text Format (RTF) templates. You 
can select any template as the default template and change the 
default when required. Click Add to upload a template file that you 
want to use to customize your email. Unifier uses the parameters 
set in the Add Template window to format the email, using the BI 
Publisher. 

Sample Data

After you add a template, go to the Sample Data tab to select a 
sample data for the custom email. You can generate the sample 
data xml from the Sample Data tab and download the sample data 
xml in order to create the layout files. 

You can export the published Custom Emails using the 
Configuration Packages feature. 

All the fields available in the Custom Print version of a Request for 
Bid (RFB) business processes are available for the Custom Email 
version. In addition, the following email-specific fields are available 
as sample data: 

 From Requestor: The user who has sent across the Bid 
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Option Description 

invitation. 

 Email: Email ID of the requestor. 

 Phone: Phone number of the requestor. 

 Sent for: This field signifies what is the invitation for and has a 
value of ‘Bid’. 

 Username: The user name of the Bidder (Email ID of the 
Bidder) 

 Password: The password that needs to be sent across to the 
Bidder (when OIM is not being used). The password 
notification, when sent from OIM, is translated if the bidder is 
receiving the custom email. 

 New Due: The changed value of the Due Date of the Bid. 

 Bid URL: This is the URL which the bidder needs to use to 
login into the Bid portal. 

 Contact First Name(uuu_contact_first_name): This is the 
First Name of the Vendor's Contact. 

 Contact Last Name(uuu_contact_last_name): This is the 
last Name of the Vendor's Contact. 

Once you have configured the design of the custom email, you can 
save your changes and publish your design to the BI Publisher 
server. The Notification tab of the Request for Bid (RFB) 
business processes will contain all your added options. You must 
select a notification (Custom Notifications) for: 

 Bid Invitation 

 Login Information 

 Due Date Change 

Each notification has a list of templates that have been published 
at least once. 

When Unifier is integrated with OIM, the option to select the Login 
Information template would not be available to the users. 

When Unifier is integrated with OIM, the password will not be sent 
over via the template even if the user has put in the password field 
in the template. 

When BI Publisher Custom Print templates are created using external data model, Unifier does 
not generate any additional data models for use in the print template. 

If a custom print template of Internal_Multiple has been converted, then the resulting data 
model will be External_Multiple and will be available for bulk printing. 

Copying a template will copy the data model associated with the source template. 

Use the options in Find to select the data models Internal_Multiple and External_Multiple. 
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Assigning Roles and Permissions to BI Publisher User to Publish and Run Unifier 
Reports 

If you want to publish and run Unifier reports, the following roles and permissions must be 
assigned to the BI Publisher user (who integrates Unifier and OBIEE): 

 BI Consumer: Open 

 BI Content Author: Traverse 

 BI Service Administrator: Full Control 

Creating Data Model (.XDM) File 

To create a new .XDM file, you can either: 

a. Create the .XDM file from a local BI Publisher server, or 

b. Copy any existing .XDM file, from an existing report, and create a new .XDM file. 

Note: To create an .XDM file that works with Unifier, you need to make 
changes in the .XDM file, accordingly. 

Custom Templates Windows Log 

The following applies to all Custom Prints and Reports (Internal Reports and External Reports). 

Users do not need separate set of permissions to access the External Reports in the Custom 
Prints and Reports log. Users who have permissions to the Custom Templates node are able to 
view the External Reports in the Admin mode. 

In the User mode, since the External Reports appear as a list, the permission settings are the 
same as those for Internal Custom Reports (View).  

The Custom Prints and Reports windows log (Custom Templates  - Current View:  All) 
displays the following information: 

 Name 

 Description 

 Type 

 Location 

 Data Model Type 

 Key 

 Report Level 

 status 

 Publish/Synch Date  

 Last Modified By 

Name

 Name of Print template or name of Report. 

 For External Reports: This field displays the name of the report populated from the BI 
Publisher server. 
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 For Custom Print: The name of the print template, as entered in Unifier. 

 For Internal Reports: The name of the report as entered in Unifier. 

 The maximum character length in Unifier is 255. After 255, the characters will be truncated. 

Description

 Description of Print template or description of Report. 

 For External Reports: This field displays the description of the report populated from the BI 
Publisher server. 

 For Custom Print: The description of the print template, as entered in Unifier. 

 For Internal Reports: The description of the report, as entered in Unifier. 

Type

 Custom Print 

 External Reports: The reports that are created in the BI Publisher server, and are displayed 
here, will have a Type: External Reports. 

 Internal Reports: The reports that are created in Unifier will have a Type: Internal Reports. 

 Custom Email  

Location

 Location of the report in the BI Publisher server relative to the path specified in the Unifier 
Configurator. 

 For the External Reports, the path is relative to the property value for the BIP External 
Report Folder. 

 For the Internal Reports, the path is relative to the property value for the BIP Report Folder. 

 This column displays the path of the report in the BI Publisher server. The location plays an 
important role when there are two reports with the same name.  

Data Model Type

Internal or External for both Print and Report. 

Key

 System-generated unique ID. 

 For External Reports: The key starts with "uuu_ext" 

 For Print or Internal Report: The key starts with "uuu_" 

Report Level

The value is blank for Print and for both Internal and External reports, it shows Project, 
Program, or Application (for Internal Reports, only). 

Status

 Displays whether the report is in one of the following conditions: 

 Invalid (only applicable for the External Reports) 

 Draft 

 Publish 

Publish Date/Synch Date
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 Date the record was last published, or synchronized, in the BI Publisher server and Unifier. 
This field will be blank when status is changed to Draft/Invalid. 

 For External Reports: The date when the report is synchronized in Unifier (from BI Publisher 
server to Unifier). 

 For Custom Print: The date that the print template was published to the BI Publisher server. 

 For Internal Reports: The date the reports was published to the BI Publisher server. 

Last Modified By

Name of the user who last synchronized the record. 

Note: When transferring Custom Reports by way of configuration 
package, the Custom Reports name and level must match in both 
source environment and destination environment.  

The toolbar contains the following options: 

 New 

 Custom Print with Internal Data Model 

 Custom Print with External Data Model 

 Report with Internal Data Model 

 Report with External Data Model 

 Custom Email with Internal Data Model 

 Open 

 Copy 

 Delete 

 Status 

 Find 

 Synchronize External Reports 

 Tag 

 Configuration Package 

 Clear 

New

The External Reports are created in the BI Publisher server. The New option enables the user to 
create Internal Reports and Custom Print templates. 

Open

The user uses the Open option to open an External Report. 

Copy

This option is disabled if you select a record in the Custom Print, or Reports, logs that is an 
External Report type. 

Delete

For External Reports: The user can use this option to delete External Reports that have "Invalid" 
status. This option is disabled if the selected External Report is in "Published" status. 
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For Internal Reports: The user can use this option to delete an Internal Report that has never 
been Published. 

For Custom Prints: The user can use this option to delete a Custom Print that is in "Draft" or 
"Published" status. 

Status

The status for all imported External Reports is "Published." The values for this column are: 

 Draft 

 Published 

 Invalid 

 The "Invalid" status is applicable to External Reports, only. This status does not apply, 
and is not available, for Internal Reports and Custom Print records. 

 The system assigns the "Invalid" status if a report that has been previously imported to 
Unifier is no longer in the BI Publisher server. 

 You can delete an External Report that has the status "Invalid" from the log. 

 If the user had the permission to view an External Report at runtime, and the status is 
now set as "Invalid," then the user cannot view the External Report at runtime. 

Find

The Find option, on the toolbar, allows you to search for a particular record in Custom Prints and 
Reports log. The options for finding a report are: 

 Name 

 Type 

 Location 

 Data Model Type 

 Last Modified By 

Synchronize External Reports

The Synchronize External Reports option, on the toolbar, enables you to synchronize data 
between the BI Publisher server and Unifier. 

This option allows you, the Administrator, to update Unifier with the reports created in the BI 
Publisher server. When you click Synchronize External Reports, the system connects to BI 
Publisher server to retrieve reports through Web Services. 

You can set the level of the report (Report Level) in the Synchronize External Reports window 
that opens after you click Synchronize External Reports. 

Once the synchronization is complete, you can set the permissions, per Report Level, in Unifier. 
During the runtime, all changes to the report design, such as data model, layout, translation files, 
and so forth, will be applied. 

The following rules apply when you synchronize external reports: 

 The Synchronize External Reports window displays all the new reports that exist in the BI 
Publisher server. 

 Reports that exist in both BI Publisher server and Unifier (same reports in terms of count, 
name, and location), do not appear in the Synchronize External Reports window. 
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 When you click Synchronize External Reports, the system synchronizes all reports. You 
cannot select a particular report to be imported into Unifier. 

 If you have imported a report to Unifier and the report no longer exists in the BIP server, then 
when you click Synchronize External Reports the status of the report will be "Invalid" and you 
cannot see the report at runtime. 

 If you change the name of a report in BI Publisher server, the system treats the report as a 
new report after synchronization. 

 The system sets the original report, in Unifier, as "Invalid" and you cannot see the report 
at runtime. 

 If you change the location of a report in BI Publisher server, the system treats the report as a 
new report, after synchronization 

 The Synchronize External Reports window displays the report and the report new 
location, after import. 

 The system sets the original report, in Unifier, as "Invalid" and you cannot see the report 
at runtime. 

 If multiple reports, with same names exist in BI Publisher server, after synchronization, all 
reports will be imported into Unifier. 

 After the reports are synchronized, the system updates the descriptions of the reports. There 
will be a small delay for this operation. 

 If the report parameter (external reports) starts with "uuu_hidden_", it will not be available 
for the user to edit  in Unifier.  

Synchronize External Reports window

 The Report Name is a read-only field and lists the names in alphabetical order. 

 The Location is a read-only field and lists the location of the report in the BI Publisher server. 

 The Report Level is drop-down field and contains two values to select from: Project and 
Program. The default value is Project, and you can modify the Report Level at the time of 
import, only. Once you import the report, you cannot modify the Report Level. If you select 
an incorrect Report Level, then the system sets the status of that report as "Invalid." You can 
select Synchronized External Reports option and set the Report Level in the Edit Report 
Level window. 

 The Description field provides a description for the BI Publisher Report on the BI Publisher 
server. 

BI Publisher Report Levels 

There two major levels for BI Publisher report. 

 Project level which means the report is running in Project/Shell context. 

 Program level which means the report is running in Program context. 

For a Project or Program report, respectively, ensure that the following predefined Unifier 
parameters are applied on the "Where" clause as conditions in the query of the Data Set related 
to the Main view: 

 :uuu_p_context_project_id

 :uuu_p_context_program_id
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The following are examples of the parameters used in a "Where" clause: 

 project_id = nvl(:uuu_p_context_project_id,project_id)

 program_id = nvl(:uuu_p_context_program_id,program_id)

Sample XML Data for Custom Templates (Custom Prints and Reports) 

In case of a Custom Print, the sample data contains data elements that will be used in the layout 
files to capture information about a business process. 

Some data elements are specific to the business process selected as they map to the standard 
and custom elements included in the business process forms. 

If you have an image picker Data Element (DE) on your business process form, then the sample 
data includes the XML element, which provides the data for the ID that corresponds to the image 
as well as the name of the image.  

Example 

If the image picker DE "AE_Image" is placed on the business process form, then the 
generated data XML will have the "AE_Image" DE, which provides value for the uploaded 
image name, and the "k__AE_Image" DE, which provides value for the uploaded image ID. 

You must use the image ID in the BI Publisher template for the custom print of the business 
process. 

There are some data elements present in the sample data for all the business process since 
they apply to all. These data elements provide information such as record attachments, 
attachment comments, line item attachments, workflow steps, and so forth. 

The following is a list of data elements and their descriptions:  

Notes:

 The top level data set, in the Internal Multiple Data Model Type is the 
project_company_info. This has to be the very first grouping since 
the Internal Multiple Custom Print template can be selected for 
multiple business process records, from the Tasks log, Business 
Processes log, or Master Log pages. These pages display business 
process records from multiple shells that the user has access to 
(permission). This data-set has fields providing information of the 
company and project to which the Business Process record is 
associated with. 

 All other data-sets are children to this data-set. 

 Each XML Data Element Group represents a unique data-set in the 
data model uploaded to the BI Publisher Server and has a field that 
its value uniquely represents the record. 

 The unique field in each data-set is the field to be used as a group-by 
field on the template for rendering the data grouped under the 
business process record. 

 The unique fields are important to the template designers because of 
the layout and the data that needs to be displayed on the BI 
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Publisher Custom Print output. 

 The unique field in each data-set can be suffixed by a number. This 
applies to other data-sets as well as a similar field.  

 The number suffix is added automatically to maintain the uniqueness 
of the field across the datasets. This is used by the BI Publisher for 
the correct grouping of the data. For example, for multiple ID fields in 
different datasets, the ID field appears as: <ID_3></ID_3>. 

 The following explains the unique field value for the dataset along 
with a description. 

<li_attachments>

 Unique Field: <ID_<<no>>>..</ID_<<no>>>

 The sub-elements under this provide information about line item attachments for the 
business process when the business process has line items 

<lic_attachments>

 Unique Field: <ID_<<no>>>..</ID_<<no>>>

 The element is a child of <la_comments> and it's sub-elements provide information about 
attachments linked to the comment of line-item attachment 

<li_ca>

 Unique Field: <ID_<<no>>>..</ID_<<no>>>

 The element is a sub-element that provides information about cost allocation line item 
element for Summary Payment Application of SOV type BP 

<la_comments>

 Unique Field: <. Unique Field: <COMMENT_ID_<<no>>>..<COMMENT_ID_<<no>>>

 This element is a child of <li_attachments> and it's sub-elements provide information on the 
comments associated with the line-item attachment 

<standard_elements>

 This is applicable to Custom Print of Data Model Type Internal. 

 The sub-elements of this group element provide information about company name, project 
name, project number etc 

<general_comments>

 Unique Field: <. Unique Field: <COMMENT_ID_<<no>>>..<COMMENT_ID_<<no>>>

 The sub-elements of this group element provides information about general comments on 
the business process 

<gc_attachments>

The element is a child of <general_comments>and it's sub-elements provide information 
about attachments  linked to the general comment 

<record_attachments>

 Unique Field: <ID_<<no>>>..</ID_<<no>>>
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 The sub-elements under this provide information about record attachments for the business 
process  

<ra_comments>

 Unique Field: <COMMENT_ID_<<no>>>..<COMMENT_ID_<<no>>>

 This element is a child of <record_attachments> and it's sub-elements provide information 
on the comments associated with the record attachments 

<rac_attachments>

 Unique Field: <ID_<<no>>>..</ID_<<no>>>

 The element is a child of <ra_comments> and it's sub-elements provide information about 
attachments linked to the comment of record attachment 

For a workflow business processes, there are additional elements which provide information 
about the workflow process and its details. The following is a list of data elements: 

Unique Field: <ID_<<no>>>..</ID_<<no>>>

<workflow_steps>

 <WF_PROCESS_ID></WF_PROCESS_ID> Process Id

 <SOURCE_ID_1></SOURCE_ID_1> BP record Id

 The sub-element of this element provide information about the workflow steps associated 
with the business process. Details like step name, step assignees 

<task_assignees>

 <WFTEMPLATE_ID></WFTEMPLATE_ID>

 <BIP_SOURCE_ID></BIP_SOURCE_ID>

 <BIP_WF_PROCESS_ID></BIP_WF_PROCESS_ID>

 The sub-element of this element provide information about task and assignee details. 
Information like Task name, Task Status, Assigned From, Assigned To and more 

<workflow_progress>

 <WF_PROCESS_ID></WF_PROCESS_ID> Process Id

 <SOURCE_ID_1></SOURCE_ID_1>

 The sub-elements of this element provide information about status of the workflow 

<group_assignment_notes>

 <PROCESS_ID></PROCESS_ID>

 <STEP_ID></STEP_ID>

 The sub-elements of this element provide information about the notes sent when a task is 
assigned to the group in the workflow process 

Creating BI Publisher Custom Print 

To create a new BI Publisher custom print configuration: 

1) Open Unifier

2) Go to Company Workspace tab 
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3) Switch to Admin mode 

4) Click Configuration to open the node 

5) Click Custom Templates

6) From the log window (Custom Templates  - Current View:  All) click New

7) Select one of the following options to open the Custom Print window: 

 Custom Print with Internal Data Model, or  

 Custom Print with External Data Model

Note: To view a BI Publisher custom print template, select the template 
and click Open. 

See the Custom Templates (Custom Prints and Reports) Overview (on page 60) section for 
more details. 

Custom Print Window (General tab) 

In the General tab, you can define the general custom print information. 

1) Enter and select values in the following fields: 

Note: Required fields are marked with an asterisk (*), or a star. 

 Name

Enter a unique name for the custom print, up to 50 characters (use alphanumeric 
characters, non-ASCII characters, or spaces). 

 Description

(Optional) Enter a brief description about the custom print up to 250 characters (use 
non-ASCII characters) 

 Data Source

Select one of the values from the drop-down list. The list contains all the design objects 
that support custom print, such as BP names, Space attribute names, CM attribute 
names, and so forth. 

 Data Model Type

This is pre-populated read-only field, based on the selected custom print type. The 
values, based on the option selected at the time of creating the custom print, can be one 
of the following:  

Internal 

External 

Internal Multiple 

External Multiple 

Internal or External 

2) Click Apply to continue. 
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When you click Apply, Unifier processes the information that you have provided and prepares 
the custom print for publication. As a result of this process, two additional tabs are added to the 
Custom Print window that require your input: 

 Template File tab 

The Template File tab allows you to upload: 

 Multiple templates for the custom print (RTF, PDF, Excel, eText) 

 Data model (.XDM) file (for print with external data model) 

 Sample Data tab 

The Sample Data tab allows you to generate the sample XML, which you can use to create 
layouts for the custom print. In the case of an external data model-based report, the report 
must have been published to the BI Publisher server at least once before the sample XML 
data can be generated. 

See the following topics for details: 

 Custom Print Window (Template File tab)

 Custom Print Window (Sample Data tab)

Custom Print Window (Template File tab) 

The Template File tab contains information about the print layout, along with the corresponding 
templates and XLIFF translations. 

You can build a Rich Text Format (RTF) print template and upload the template to your Custom 
Print in Unifier. 

To create a simple RTF template: 

1) Open Microsoft Word. 

The application must have the Microsoft Word BI Publisher plug-in installed. See Download 
and Install BI Publisher Desktop for Microsoft Office. 

2) Click the Word BI Publisher ribbon. 

3) Click Sample XML to import your sample data and wait until the data is loaded successfully. 

You can use the following option for each template: 

 Add 

 Modify 

 Remove 

 Download 

Add

Use Add to upload the print layout and the translated XLIFF files. The XLIFF files are used for 
translation purposes. When you click Add, the "Add template and Files" window opens. 

The "Add template and Files" window has two sections: 

 Template 

 Translated XLIFF files for the Template 
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Note: Required fields are marked with an asterisk (*), or a star. 

Template

The Template section contains the following fields: 

 Template Name: Enter a unique name for the template (use non-ASCII characters). 

 Template Type: From the drop-down list, select a template type: RTF, PDF, Excel, or eText. 

A Template Type can be changed as long as the template is in Creation stage. Once 
created, the Template Type cannot be modified, and the custom print designer must create a 
new template (of the desired type) and remove the one that is no longer required. 

 Layout File: Browse to find and upload the layout files, based on the template type. 

Translated XLIFF files for the Template

If you want to internationalize the product, then the translated XLIFF files can be uploaded, 
for the corresponding languages, in the Translated XLIFF filed for template section. 

Note: The languages listed are the active languages selected in the 
Configuration - Internationalization log window, by the administrator.  

Click Apply when finished. 

When you open an existing Custom Print, the Template File tab lists all available templates. The 
first template is always marked as Default, but you can change the default template. 

Modify

Use Modify to modify the existing print template and XLIFF files. You must select an existing file 
before your can proceed. When you click Modify, the "Modify Template and Files" window 
opens. 

The "Modify Template and Files" window has two sections: 

 Template 

 Translated XLIFF files for the Template 

Note: Required fields are marked with an asterisk (*), or a star. 

Template

The Template section contains the following fields: 

 Template Name: The unique name for the template. 

 Template Type: This is pre-populated read-only field, based on the selected Template Type. 

A Template Type can be changed as long as the template is in Creation stage. Once 
created, the Template Type cannot be modified, and the custom print designer must create a 
new template (of the desired type) and remove the one that is no longer required. 

 Layout File: Browse to find and upload the layout files, based on the template type. The 
original custom print file is displayed. 

Notes: 

 You can modify a BI Publisher Custom Print template only if the 



Unifier Modules Setup Administration Guide

76

status is set as "Draft." 

 You cannot modify a Data Source of a Custom Print template after 
the Custom Print template has been created. 

 You can modify the contents of the Description field at any time. 

Translated XLIFF files for the Template

If you want to internationalize the product, then the translated XLIFF files can be uploaded, 
for the corresponding languages, in the Translated XLIFF filed for template section. 

Click Apply when finished. 

Remove

To remove a Custom Print template, click to select the template, and click Remove. 

Note: To delete a Custom Print template, you can select the Custom 
Print template from the log and click Delete. You can delete a Custom 
Print template regardless of the Custom Print template status. 

Download

The Download option allows you to download the template and the corresponding translated 
XLIFF files. You must select an existing file before your can proceed. 

When you click Download, a zip file is generated. The zip file name format must be: 

Template_<Numeric part of report key>_<File Type>.zip

Example 

Template_483_PDF.zip

You can copy a Custom Print template to use as a base for a new Custom Print template. 

Note: After copying a Custom Print template, the term, "Copy of" 
appears at the beginning of the name of the new Custom Print template. 

Custom Print Window (Sample Data tab) 

You can use the Custom Print window Sample Data tab to download sample data for designing 
the custom print template file. You can use the XML data to design the print template file in the 
BI Publisher. 

The XML tags in the sample data are displayed for all the fields that are relevant to the selected 
data source. The XML tags are grouped according to the XML elements or data sets. The data 
sets displayed in the Sample Data tab are driven by the data source type. For a Workflow BP, 
the various elements are the upper forms, line items, workflow details, comments, and so forth. 

1) In the Sample Data tab click Generate.  

2) When finished, click Download. 

3) Click Apply. 

4) Click OK. 
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Creating Custom Email Template 

To be able to create (or add) a custom email template:  

1) Go to the Company Workspace tab (Admin mode). 

2) From the left-hand Navigator pane, click the Configuration node to expand. 

3) Click the Business Process sub-node to open the Configuration - Business Processes
log. 

4) Click to select your Workflow BP and click Open. 

5) From the left-hand Navigator pane, click the Customize Email sub-node to expand. 

6) Click the Content sub-node to open the Email Content log window. 

7) Click Create to open the Create Template window. 

8) Select your language and enter a name for the template in the Name field. 

9) Compose your email body text and if applicable double-click on the necessary data 
elements, from the right-hand pane (Available Data Elements), to include them in your 
email. You need to enter the title of the DE, manually. Use the elements of rich text editor in 
the body to create a custom email format. The list of DEs can be broadly categorized as: 

 Workspace and Workflow Information (Shell details, Workflow information, and Task 
assignee details) 

 Upper form details 

See the "List of DEs and Categories" table below for details. 

If the DE value is not present a blank value will be updated in the email content. 

Use the Find on Page option to search for a particular DE. 

The active languages appear in separate tabs, according to their order in the language log. 

Select one of the following options, when finished: 

 Save: To save your modified email in the log and keep the Email Content log window open 
to conduct other operations. 

 Save and Close: To save your modified email in the log and close the Email Content log 
window. 

 Use the Cancel option to discard your changes, if any, and return to the Email Content log 
window. 

To be able to modify a custom email template, follow the steps above to access the Email 
Content log window, then open the email that you want to modify and incorporate your changes. 
If there are several email templates in the Email Content log window, you can use the Find on 
Page option to search and find the email template that you need. 

Within the Email Content log window, on the top right-hand, Unifier displays the value of the 
maximum size of the outgoing email. 

Note: Ensure that you keep the size of your emails <20% of the 
maximum size of the outgoing email. 

The Email Content log window displays the size of the email configured under each language 
on the right-hand side of the window. 
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The custom email template will be available at the company-level (or global-level) when the 
Business Process Setup is made available at a shell-level template, similar to the setup of the 
custom email subject line. After the Business Process Setup, at the shell-level template, is 
complete, the email content template will become available in the Notifications tab of the 
Business Process Setup. When a task is created during the run-time, for a BP, the email 
generation appears per the custom format that was defined at the customize email content 
node, provided that the format is selected as default format. Email templates for multiple 
languages can be created in the same window. 

If the size of the configured email template, for any language, exceeds the maximum set limit, or 
if the size falls between preferred size-range, an error or a warning message will be displayed 
respectively. 

If you modify a template name, and the email is already in use, then the system changes the 
email name at the selection (BP Setup > Notification tab > any particular task type). 

Once you save a custom email, the system displays the record with log containing the following 
fields: 

 Name: Name or title of the template. 

 Last Modified By: Name of the user who last modified the template. 

 Last Modified: Date when the template was last modified. 

 Active Languages: Listed according to the order of the language log. If custom email content, 
for any language type, is defined, then the size of the email configured under each language 
is be displayed in the log. 

List of DEs and Categories

Task 
assignee 

Sent From/Task From 

Sent To 

Task To (All assigned users in the To step of the task) 

Task CC (Where all CC users are fetched from the task assigned) 

Task Status 

Task Due Date 

Workflow 
setup 

Workflow Step Name  

Workflow Email Content 

Shell Shell Name 

Shell Number 

Administrator 

Hierarchy Path 

Environment Name 

Additional Information

The general comments (any comments that have been added as a part of the record 
modification) are sent out as a part of the system default footer, for the mail. 
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Also, the line items and attachments that have been added to a record will be included 
through a system-generated footer for the record modification emails. The following DEs are 
not included: 

 <SOURCE_ID></SOURCE_ID> 

 <STEP_ASSIGNEE></STEP_ASSIGNEE> 

 <ASSIGNEE_COMPANY></ASSIGNEE_COMPANY> 

 <STEP_STATUS></STEP_STATUS> 

 <STEP_ACTION></STEP_ACTION> 

 <STEP_COMPLETION_DATE></STEP_COMPLETION_DATE> 

 <WORKFLOW_STATUS></WORKFLOW_STATUS> 

 <WFTEMPLATE_ID></WFTEMPLATE_ID> 

 <PROCESS_ID></PROCESS_ID> 

 <TASK_NAME></TASK_NAME> 

 <ACTION_NAME></ACTION_NAME> 

 <ASSIGNED_FROM></ASSIGNED_FROM> 

 <ASSIGNEE_COMPANY_1></ASSIGNEE_COMPANY_1> 

 <TASK_COMPLETION_DATE></TASK_COMPLETION_DATE> 

 <ASSIGNEE_ID></ASSIGNEE_ID> 

 <TASK_NOTE></TASK_NOTE> 

 <SUBWORKFLOW_NAME></SUBWORKFLOW_NAME> 

 <SUBWORKFLOW_DUEDATE></SUBWORKFLOW_DUEDATE> 

 <TASKNODEID></TASKNODEID> 

 <ACT_STEPTEMP_ID></ACT_STEPTEMP_ID> 

When you click Create, Unifier opens the first language tab, as listed in the language log. 
You can select any of the languages tabs and paste the content to be translated. You can 
also save an email format in multiple languages. At run-time, the custom email is drafted for 
the selected language, and if the custom email content is not present for the language, 
Unifier uses the system default format. 

The user can select any of the created records and click Delete in order to delete the 
selected custom email format. If a selection includes a template which is being used, Unifier 
will display a confirmation message. The user can delete multiple templates at once. Once a 
template is selected for deletion, Unifier automatically reverts the selected template to the 
system default. 

The header and footer section of the custom email is auto-generated by Unifier and 
appended to the created custom email. 

Use the Additional Information field that is available as one of the DEs like a note. The 
Additional Information field is configured at the email content section of the BP Setup. 

You (the admin) can select the customized email format under the Notification tab of a BP 
Setup. Go to Notification tab, under Custom Notifications sub-section, click on the 
drop-down option for each email type, and select the desired format. The name of the 
custom template defined is listed in the drop-down list. 
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If the user selects "Include both record and line item attachments" or "Include record 
information as attachment," the attachments will be sent as part of custom email. 

The drop-down lists all of the custom email formats defined at the customize mail Content 
node. The same format can be selected for all of the task types. Once selected, the user can 
click OK or Apply to save the changes. The selected format email is triggered, when the 
user: 

 Creates BP log, by way of create. 

 Creates Project Task log, by way of create BP. 

 Goes to the Home Task log, by way of create BP, in Project. 

 Goes to the Document Manager, by way of create BP with attachment. 

 Goes to the Query Based Tabs, by way of create 

 Initiates auto create. 

 Wants to use the email for CSV uploads. 

 Creates a task, by way of Unifier Mobile App. 

The subject line for email is either a system-default text, or a customized one which is 
defined under the Customize Subject Line node. 

You (the admin) must assign the right user at each and every step of the workflow, to 
indicate the recipient of the notifications. 

When the user has selected custom email for a particular task and Unifier does not generate 
a custom email (due to errors), Unifier sends a default email, automatically. 

DEs of type Rich text are not available to be added in the email subject line configuration, or 
to be added to the custom email content.  

Publishing BI Publisher Custom Print 

You must publish the BI Publisher Custom Prints in the BI Publisher Server.  

To publish a BI Publisher Custom Print: 

1) Prepare the custom print. 

2) Click Status. 

The status of a BI Publisher Custom Print template is either set as Draft, or the status is set 
as Published. For either case, in order to print the BI Publisher Custom Print template, you 
must select Publish. 

You can delete a Custom Print template regardless of the Custom Print template status. 

3) Select Publish. 

After you publish, the system performs validation and if there are no errors the system 
publishes the Custom Print template and assigns the new Published Date in the log. 
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Notes: 

 If you remove the data elements from the design of the data source 
that has been used in the BI Publisher Custom Print template, then 
you must republish the Custom Print template to the BI Publisher 
server. 

 If you add new data elements to the Upper Form, or Detail Form, of 
the BP Design, then to be able to see and used these new elements 
of a data schema in the template you must re-publish the Custom 
Print template and download a new copy of data schema.  

 You can update the Custom Print template layout by regenerating the 
sample data. 

 When the status of a Custom Print changes from "Draft" to 
"Published," Unifier generates the data model with respect to the 
current BP Design. As a result, if the BP design has changed 
between the time of first download of the Sample Data and the 
publishing of the Custom Print, then the developed report Template 
must be tested again with the new Data XML. 

Parameters for External Multiple Custom Print 

The following is a list of parameters for the External Multiple type custom print that you need to 
use in the data model to ensure that the Bulk Action (in Tasks and Business Processes logs) 
works properly:  

Parameter Name Description Required Comma Separated 
Values 

uuu_p_project_i
d

Contains the value 
of the Project IDs 

Yes Yes 

uuu_p_context_c
ompany_id

Contains the value 
of the customer's 
Company ID. 

Yes No 

uuu_p_process_i
d

Contains the value 
of the Workflow 
Process IDs. 

Yes 

Only for Workflow 
type business 
processes. 

Yes 

uuu_p_source_id Contains the value 
of the Record IDs. 

Yes Yes 

uuu_p_space_sou
rce_id

Contains the value 
of the space Record 
ID 

Yes 

Only for Space type 
business processes.

Yes 
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uuu_p_object_ty
pe

Contains the value 
of the business 
process ID, in 
udesigner 

Yes No 

Creating BI Publisher Custom Report 

o create a new BI Publisher custom report configuration: 

1) Open Unifier

2) Go to Company Workspace tab 

3) Switch to Admin mode 

4) Click Configuration to open the node 

5) Click Custom Prints and Reports

6) From the log window (Custom Prints and Reports - Current View: All) click New

7) Select one of the following options to open the Custom Report window: 

 Report with Internal Data Model, or  

 Report with External Data Model

See the Custom Templates (Custom Prints and Reports) Overview (on page 60) section for 
details. 

Note: Oracle supports the delivery of BI Publisher reports from P6 in 
PDF format by way of email, only. 

Custom Report Window (General tab) 

In the General tab, you can define the general custom report information. 

1) Enter and select values in the following fields: 

Note: Required fields are marked with an asterisk (*), or a star. 

 Name

Enter a unique name for the custom report, up to 50 characters (use alphanumeric 
characters or spaces). 

 Description

(Optional) Enter a brief description about the custom report. 

 Data Model Type

This is pre-populated read-only field, based on the selected custom report type. The 
values can either be Internal or External, based on the option selected at the time of 
creating the custom report. 

 Report Level
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A drop-down list that allows you to select Project for a project-level custom report, 
Program for a program-level custom report, or Application for an application-level custom 
report. 

 Main View

A drop-down list that allows you to select a data view to use as the main view of the 
custom report. The items in the drop-down list are populated with the data views that 
have been published. 

Note: When you are selecting a Main View, ensure that you select a 
view that has the level-appropriate ID, as a column, in the view 
definition. For example, if you are selecting a Main View for a Program 
(report level), the view must have "program_id", as a column, in the view 
definition. 

2) Click Apply to continue. 

When you click Apply, Unifier processes the information that you have provided and prepares 
the custom report for publication. As a result of this process, two additional tabs are added to the 
Custom Report window that require your input: 

 Template File tab 

The Template File tab allows you to upload: 

 Multiple templates for the custom report (RTF, PDF, Excel, eText) 

 Data model (.XDM) file (for report with external data model) 

 Sample Data tab 

The Sample Data tab allows you to generate the sample XML data which you can use to 
create layouts for the custom report. 

See the following topics for details: 

 Custom Print Window (Template File tab)

 Custom Report Window (Sample Data tab)

Custom Report Window (Views tab) 

On the Views tab, you can: 

 Set the views used as data sets (Views used as data sets) 

 Determine data links (Data links) 

To set additional views, used as data sets, follow these steps: 

1) On the Custom Reports window, click the Views tab. 

2) In the "Views used as data sets" section click Add to add a new row to the Views list. 

3) In the "View Name" column, from the drop-down list, select a view. The drop-down list 
displays the available published data views. 

In the "View Type" column, double-click the entry to make the cell editable, and select a view 
type from the drop-down list. You can select one view as the main view, only. The other 
views are sub-report views. 
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4) In the "Data Set Name" column, double-click the cell to make it editable, and enter the name 
of the data set to which this view should belong. 

5) In the "Data Set" Tag column, double-click the cell to make it editable, and enter the tag for 
the data set. 

6) To add another view, repeat steps 1 to 5. 

You can enter any number of data views for a custom report and group them into data sets. 

Once you have specified the data views and grouped them into data sets, you can link one data 
set to another in order to extract related information from multiple sources. 

For translation-related information about Oracle Business Intelligence Publisher (BI Publisher or 
BIP) Reports, see the Internationalization (BI Publisher Custom Reports) section. 

Note: For External Data Model based reports, you cannot add or remove 
views. 

You can create only one link level; that is, you can create one "sub-link." You cannot create 
another link under a sub-link. 

To determine data links, follow these steps: 

1) In the Data links section of the window, click Add to open the Add Link window. 

2) In the Source Data Set field, select the name of the data set you want to link to another set. 
The selection list shows the data sets you created in the upper section of the Views tab. 

3) In the Source Element Name field, select the name of the field on the source data set that 
you want to map to the target data set. 

The element data type must match the data type of the target element; for example, you 
must match an integer to an integer, a string to a string. 

4) In the Target Data Set field, select the name of the data set the source data set should link 
to. 

5) In the Target Element field, select the name of the field on the target set that the source 
element field should map to. 

6) To add another link, click the Add button and repeat steps 2 to 5, or click OK to save the 
links the exit the Add Link window. 

7) Click Apply, and click OK to exit the Custom Report window. 

Example for creating a data link: 

Row View Name View Type Data Set Name Data Set Tag 

0 Invoices Main View inv inv 

1 InvoicesLI Sub Report View LineItem LineItem 

At this point, set the relationship between the Main View and the Sub Report View that you have 
added. 

1) Go to the Data Links section and click Add. 

2) Link the ID field, from the Invoices Data View, to the RECORD_ID field, from the Invoices 
Line Item Data View. 



Configuring and Publishing BI Publisher Custom Templates (Custom Prints and Reports)

85

Example 

Source Data Set: inv

Source Element Name: INV_ID

Target Data Set: LineItem

Target Element: INV_LI_RECORD_NO

3) Click OK to add to add the link. 

4) Click Apply. 

Custom Report Window (Query tab) 

When creating, you can specify two types of parameters before running a report: 

 Search Parameters 

Use these to filter the SQL results. Data View result rows that do not match the filter will not 
be sent from Unifier to BI Publisher.  

 Additional Parameters 

Use these to pass additional parameters for BI Publisher to consume at runtime. All values 
are sent from Unifier to BI Publisher for further operation. See Parameters tab below. 

Search Parameters 

Search parameters allow the report runner to filter the data that gets sent to BI Publisher. For 
example, a Contract Report may need to be filtered by Vendor or Contract Type. A Ball-in-court 
report may be filtered for a specific task assignee, or task type. 

At runtime, the report runner can select or multi-select from a list of values based on the search 
parameters specified in the report configuration. This means that Unifier basically runs the Data 
View before the report is run to give the report runner a list of the SQL results. He can then 
select or multi-select values from this initial run to filter what will appear in the report output. For 
more information on the Search Parameters, see "Add query parameters to custom report 
(Query tab)" in the Unifier Help. 

On this tab, you can add query parameters to the configuration. The query parameters are 
created on the columns of the main view, selected for the Custom Report. At runtime, these 
parameters appear in the Search Parameters block. 

To add query parameters to the custom report 

1) On the Custom Reports window, click the Query tab. 

2) Click the Add button. The Add Query window opens. Complete the window: 

 Element Name: Click the drop-down list and choose from the elements (all columns from 
the main view). 

 Label: Enter a label to use for the Element Name. This label appears to the user 
at runtime. 

 Operator: Select the appropriate operator to use for the query. The operators will 
depend on the data type of the element chosen. 

 Source Type: This is the source of the value. Choose one of the following: 
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 Data Definition: Allows you to choose a data definition. The following field 
becomes available: 

 Select Definition: Select from the drop-down list. The list displays data definitions 
defined in the company that apply to the type of element chosen. (For example, if 
you choose a pull-down or radio button, the data set values defined for the data 
definition will be displayed to the user at runtime.) This allows you to use existing 
data definition values, rather than entering them manually (see Ad Hoc below). 

 View: Allows you to compare columns in your current view against another view chosen 
here. The following fields become available: 

 Select View: Lists all published data views. Choose the view to compare. 

 Value Column: Lists the columns for view chosen in Select View. This is the 
column that will be compared. 

 Label Column: What you choose here will be displayed to the user at runtime. 

 Context Sensitive: If this checkbox is selected, the results will automatically apply 
the filter for project_id at runtime (results will be for the current project only). 

 Ad Hoc: Allows user to select values in User Mode from selection list. If you choose this 
option, you must specify the list of values here. This is similar to defining a data definition 
data set. 

 Click the Add button. The Ad Hoc window opens. 

 Click Add. A new row is added. 

 Enter a Value and Label. 

3) You can modify the query parameters by doing the following: 

 Delete a row by selecting it and clicking Remove. 

 Modify parameter by selecting a row and clicking Modify. 

 Change the order of the query parameters (as they appear in User Mode), by selecting a 
row and clicking Move Up or Move Down. 

4) When done, click Apply to save changes. You can click OK to save and exit, or click another 
tab to continue to define the configuration. 

Custom Report Window (Parameters tab) 

If the report designer has defined a formula using parameters with the same name that was 
used in the Parameters tab, then it will be displayed on the report at runtime. In User Mode, 
these parameters appear in the Additional Parameters block. 

Additional Parameters 

Additional parameters allow the report runner to specify parameters that can be used at 
report runtime to alter how the data is displayed.  

Unlike Search Parameters: 

 Additional Parameters only support entering text. You cannot select or multi-select values 
from Unifier. 

 Additional Parameters allow us to specify a default value so that the user only needs to 
change the value if needed. 
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A good example of where to use Additional Parameters is for calculations, for example, when 
you enter a target future exchange rate. You can also use Additional Parameters for 
conditional highlighting so that only rows over/under a certain value are highlighted.  

Note: In the section Conditional Formatting, You need to hard-code a value (for example, 
10,000). 

To add additional parameters to the custom report: 

1) On the Custom Reports window, click the Parameters tab. 

2) Click Add to add a new row. Enter the following information. 

 Name: Double-click in the field to make it editable. The Name entered here must match 
the parameter name used in the BIP report. The behavior and default values for the 
parameters specified here can be applied automatically to the report at run time. 

 Editable: If this checkbox is selected, the field will be editable in User Mode. If not, the 
field is read-only. 

 Hidden: If selected, the field will be hidden in User Mode. The report may still use the 
parameter at runtime, depending on the design. 

 Label: Defines the label of the parameter field in User Mode. 

 Default: You can enter a default value that will be used in User Mode. 

3) To delete a row, select it and click Remove. 

4) Click Apply to save changes. You can click OK to save and exit, or click another tab to 
continue to define the configuration. 

Predefined BI Publisher Parameter Examples 

The name for a Parameter is mapped to a BIP parameter based on the format: 
:uuu_p_{Parameter Name}

Note: Ensure the length of {Parameter Name} is less than 24 characters. 

Any parameters created on the Parameters tab also need to be appropriately added into the 
Parameters tag in the .XDM file. 

Predefined Unifier Parameters 

Predefined parameters are reserved for Unifier to pass the runtime values to BI Publisher 
runtime context. 

Here is example from a XDM file. 

<parameters xmlns="http://xmlns.oracle.com/oxp/xmlp">

  …

   <parameter name="uuu_p_context_project_id" dataType="xsd:string" 
rowPlacement="7">

     <input label="context project id" size="10"/>

   </parameter>

   <parameter name="uuu_p_context_program_id" dataType="xsd:string" 
rowPlacement="8">
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     <input label="context program id" size="10"/>

   </parameter>

   <parameter name="uuu_p_reportByF" dataType="xsd:string" 
rowPlacement="9">

     <input label="uuu_p_reportByF" size="20"/>

   </parameter>

   <parameter name="uuu_p_timeZoneF" dataType="xsd:string" 
rowPlacement="10">

     <input label="uuu_p_timeZoneF" size="20"/>

   </parameter>

   <parameter name="uuu_p_diffMinutesF" defaultValue="0" 
dataType="xsd:string" rowPlacement="11">

     <input label="uuu_p_diffMinutesF" size="20"/>

   </parameter>

   <parameter name="uuu_p_sysyTimeZoneID" dataType="xsd:string" 
rowPlacement="12">

     <input label="uuu_p_sysyTimeZoneID" size="20"/>

   </parameter>

   <parameter name="uuu_p_searchConditionF" dataType="xsd:string" 
rowPlacement="13">

     <input label="uuu_p_searchConditionF" size="50"/>

   </parameter>

   <parameter name="uuu_p_urlF" dataType="xsd:string" rowPlacement="14">

     <input label="uuu_p_urlF" size="40"/>

   </parameter>

   <parameter name="uuu_p_sessionIdF" dataType="xsd:string" 
rowPlacement="15">

     <input label="uuu_p_sessionIdF" size="50"/>

   </parameter>

   <parameter name="uuu_p_companyRegistryF" dataType="xsd:string" 
rowPlacement="16">

     <input label="uuu_p_companyRegistryF" size="50"/>

   </parameter>

The following is an example for how to use the predefined BI Publisher Parameters to display an 
image in the Report layout: 

1) Create Form fields in the .rtf.  
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2) In the HelpText of the form field, define variable matching the parameter names used in the 
image URL. 

3) Right-click the dummy image and select Size (and its AltText), then enter the following 
content: 

url:{concat($uuu_p_urlF,'companyRegistry=',$uuu_p_companyRegistryF,'
&sessionId=',$uuu_p_sessionIdF,'&id=',PROJECTIMAGE)}

Note: The uuu_p_* are the predefined parameters in the data model. 
They are also the variable names defined in the RTF form fields. The 
PROJECTIMAGE is the element for image file ID from Unifier. 

In the HelpText of the form field enter: 

<?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>

Custom Report Window (Template File tab) 

The Template File tab allows you to upload: 

 Multiple templates for the custom report (RTF, PDF, Excel, eText). 

 Data model (.XDM) file (for report with external data model) 

 XLIFF translation files 

Use this tab to add, modify, remove, or download files and click Apply when finished. 

You can build a Rich Text Format (RTF) report template and upload the template to your 
Custom Report in Unifier. 

To create a simple RTF template: 

1) Open Microsoft Word. 

The application must have the Microsoft Word BI Publisher plug-in installed. See Download 
and Install BI Publisher Desktop for Microsoft Office. 

2) Click the Word BI Publisher ribbon. 

3) Click Sample XML to import your sample data and wait until the data is loaded successfully. 

Note: You may need to complete the General tab first and click Apply
before this tab appears. 

Custom Report Window (Sample Data tab) 

The Sample Data tab allows you to generate the sample XML data, which you can use to create 
layouts for the custom report. In the case of an external data model-based report, the report 
must have been published to the BI Publisher server at least once before the sample XML data 
can be generated. 
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Note: Depending on the Report Level that you have selected in the 
General tab, the fields and selections in this tab changes. 

1) In the Sample Data tab select a sample, determine the number of rows that you want to see, 
and click Generate.  

2) When finished, click Download. 

3) Click Apply

4) Click OK

Download and Install BI Publisher Desktop for Microsoft Office 

To download and install BI Publisher desktop for Microsoft Office: 

1) Download Oracle BI Publisher Desktop for Microsoft Office from: 
http://www.oracle.com/technetwork/middleware/bi-publisher/downloads/index.html 

Ensure that you choose the BI Publisher Desktop version (32bit vs. 64bit) based on your 
version of Microsoft Office 32 bit or 64 bit. 

Tip: If your Microsoft Word executable is found at C:\Program Files 
(x86)\Microsoft Office\Office12\WINWORD.EXE, then you 
have the 32 bit version). 

2) Run the installer. 

No additional setup is required after running the installer. To ensure that the installation was 
successful, check to see that the plug-in has been added to your Microsoft Word user 
interface. The BI Publisher ribbon appears after launching Microsoft Word. 

(Optional) SQL Text Editor 

Once you start to write more complex reports, having a text editor that highlights SQL keywords 
can make a big difference. For your needs, a simple editor such as Notepad++ would suffice. 
Ensure that you set the Language to SQL. You can copy the queries developed through the text 
editor and paste them into the Data View window.  

(Optional) SQL Developer 

You can download Oracle SQL Developer from: 
http://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html 

1) Download the first option in the list: Windows 64-bit - zip file includes the JDK 7 

2) Extract the file onto your computer (for example, C:\Oracle\sqldeveloper\) 

3) Run sqldeveloper.exe

Building Report Template (RTF) 

You can build a Rich Text Format (RTF) template and upload the template to your Custom 
Report in Unifier, and generate live reports. 
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Using Invoice as an example, the following explains how to build a simple RTF template 
(non-tabular report).  

To create a simple RTF template: 

1) Open Microsoft Word. 

The application must have the Microsoft Word BI Publisher plug-in installed. See Download 
and Install BI Publisher Desktop for Microsoft Office. 

2) Click the Word BI Publisher ribbon. 

3) Click Sample XML to import your sample data and wait until the data is loaded successfully. 

Note: Alternatively, you can use a template file (for example, A Word 
template file from your customer). 

4) Click Repeating Group to generate a loop on each Invoice. The Repeating Group window 
opens. 

5) In the For Each field, enter a value in the Data Set Name for each of the Invoices that you 
chose, when defining your Custom Report (for example, inv). This does not apply to the 
Invoices Line Items. 

6) In the Group By field, select a field for your Invoice loop. Use the INV_ID because it is a 
unique identifier for each Invoice. 

7) (Optional) Insert a page break after each Invoice to keep your report formatted. 

8) (Optional) Select the Data already sorted option. You can select this option because you 
have already sorted your data in your SQL statement, using: ORDER BY. 

9) Click OK. 

The BI Publisher plug-in application adds a code to the document which includes: a start 
(for-each), a page break (page break), and an end (end) for your Invoice loop. 

10) Add a blank line after "for-each" operator to make room for your Invoice information. 

11) Click the field icon (ab|Field) to open the field browser. 

The field browser window enables you to add fields from you XML sample data file. 

12) After each "for-each" operator, double-click Inv_Record_No in the field browser. 

13) Add a hyphen ( – ) [n-dash] after the record number. 

14) Double-click Inv_Title to add the Invoice title. 

Example 

for-eachINV_RECORD_NO-INV_TITLE

page breakend

15) (Optional) Run the report by clicking PDF on the Word BI Publisher Ribbon (Word will 
prompt you to save your RTF file if you have not, already). 

The first report is now ready. 

The report only has the Invoice record number and title for each Invoice in your sample XML (the 
approved and pending ones because: WHERE inv.STATUS = 'Approved' OR inv.STATUS 
= 'Pending' in our SQL statement). 
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You can continue to build on the generated report by adding additional fields from the Upper 
Form of the Invoices BP, as well as headers, footers, formatting, and so forth. 

Creating a Report with Line Items 

You can use the Table Wizard to create a report with all the Line Items. 

Using Invoice as an example, the following explains how to create a report with Line Items: 

1) Add a blank line after for-eachINV_RECORD_NO - INV_TITLE operator and leave your 
cursor. 

2) Click Table Wizard on the Word BI Publisher Ribbon. 

3) Select Table as your Report Format and click Next. 

4) Select /DATA_DS/Inv/LineItem as your Data Set (or the name that you had given your Line 
Item data set). 

5) Select the fields that you want to add to the table. Since this is for the Invoice line items, you 
must only add fields that are specific to the line items. 

If you need to add a field for "group on" (for example, Inv_Li_Record_No), the grouping 
process is similar to the process explained in the preceding section. Since you have grouped 
the records by Invoice in the preceding section, you can leave the value blank. 

The order of the selected columns must match the order that you want in your table, except 
for the column that you use for grouping, which is outside the table. In the "Which fields do 
you want to show in your report" window, match the order as shown here: 

Inv Li Record No  --> In Li Record 

Inv Li No -->Inv Li No  

Inv Li Desc --> Inv Li Desc 

Inv Li Unit Price --> Inv Li Unit Price  

Inv Li Quality --> Inv Li Quality 

Inv Li Amount --> Inv Li Amount 

Inv Li Uom --> Li Uom 

Code --> CodeInv  

Item --> Item 

6) In the "How would you like to group your report" window, leave every option as is because 
you have already grouped your data by Invoice in the preceding section. 

7) In the "Which fields would you like to user to sort the data" window, within each table, sort 
the lines by Inv_Li_No (Invoice Line Item Number). Specify that this is a Number so that it is 
sorted correctly. 

8) Click Finish. 

The Table Wizard inserts the table and the necessary code: 

for-eachINV_RECORD_No - INV_TITLE
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Inv Li No 
Inv Li 
Desc 

Code Item 
Inv Li 
Quantity 

Inv Li 
Uom 

Inv Li Unit 
Price 

Inv Li 
Amount 

F 
INV_LI_
NO 

INV_LI_D
E SC 

CODE ITEM INV_LI_QU
ANTITY 

INV_LI_
UOM 

INV_LI_UNI
T_PRICE 

INV_LI_AM
OUNT E 

page breakend

You must run the report to see what information is generated. While the data is correct, you 
need to work on formatting the data. See Formatting Data for details. 

Formatting Data 

To format the data generated: 

 Provide a descriptive text (not SQL column names) for Column titles. 

 Adjust the Column widths. 

 Apply general table coloring (borders and shading, font sizes, cell alignment, etc.). 

 Ensure that the "dollar" format is used for the two price columns (for example, $110.00). See 
the details that follow. 

 Add useful information, from the Upper Form of the Invoice, above the table. See the details 
that follow. 

 Provide a "Total" for the amount column. See the details that follow. 

Once finished, generate a PDF and repeat the process if necessary. 

To change the formatting of the Price & Amount columns (for example, 110.0 > $110.00): 

1) Double-click on INV_LI_UNIT_PRICE (the code under the Unit Price field) to launch its BI 
Publisher properties. 

2) Change the Formatting Type to Number. 

3) Set the Formatting Format to $#,##0.00;($#,##0.00) (paste in the blue text). 

4) Repeat the preceding steps for the Amount column. 

To add useful information, from the Upper Form of the Invoice, above the table: 

Note: Tables are efficient formatting tool for organizing data from the 
Upper Form. Include separate columns for the field name (align right) 
and the field value (align left). You can also hide the borders if you 
prefer. 

1) Create a 4-row and 2-column table and add field names. 

2) Place your cursor where the first inserted field value must be entered. 

3) Click the field icon (ab|Field) to open the field browser and add fields from your XML sample 
data. 

4) Add useful information such as Creator, Email, and Status (or other fields you added to your 
SQL statement) above our Line Item Table. 
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5) Double-click on the correct field value from the Field window to add the Title to the report (for 
example, add Invoice title in the Title field). 

To provide a "Total" for the amount column, using Invoice as an example: 

1) Right-Click somewhere in the last row of your Invoice Line Item table and select Insert > 
Insert Rows Below. 

2) Highlight all the columns in the new row, except for the last one, and Merge the cells (from 
the right-click menu). 

3) Click in the newly created cell and enter: Total 

4) Right-align the cell. 

5) Place your cursor into your last column of the new row. 

6) Click the field icon (ab|Field) to open the field browser and add fields from your XML sample 
data. 

7) Click Inv_Li_Amount column to highlight.  

8) Set the calculation (at the bottom) to Sum. 

9) Click Insert to add the calculation into the table. 

10) (Optional) Select the Total row and make the text bold. 

Adding Summary Page to Report 

Your report lists details. The Summary page contains a table with a summary of all the details 
(for example, Invoices) as well as charts to add graphical information. 

To add a summary page to your report, using Invoice as an example: 

1) Add Project information. 

In preceding sections, you have set your template to loop through each Invoice. In order to 
create a summary page, you need to include the following information: 

a. Using Word, insert a page break before the "for-each code" at the top of the document. 
Do not use the page break command in BI Publisher. 

b. Add a title to the Summary page (for example, Invoice Report). 

c. Click the field icon (ab|Field) to open the field browser and add information about the 
project, if you have not done so in your SQL statement. 

d. Add additional information about the Project below the title (in a table) such as the Project 
number, Project name, Start/End dates and Initial/Revised budgets. 

e. Format dollar values as numbers with the formatting $#,##0.00;($#,##0.00). You can 
format dates as type Date using date formatting options such as: MM/dd/yyyy 

2) Add Summary table. 

A summary table contains the Invoice data that goes in the report. You can use the Table 
Wizard, similar to the process in the "Creating a Report with Line Items" section. 

a. Place the cursor on a new line under the table on the title page, where you want your 
table of Invoices to appear. 

b. Click Table Wizard on the Word BI Publisher Ribbon. 

c. Select Table as your Report Format and click Next. 

d. Select /DATA_DS/Inv as your Data Set (or the name you used in your Invoice data set). 
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e. Select the fields that you want to add to the table. Since this is for the Invoice, you must 
only add fields that are specific to the Invoices and not the Invoices Line Items. 

You do not need to group because your SQL statement provides one line per Invoice. 

f. Sort by Invoice Record Number, in the "Which fields would you like to use to sort the 
data?" window. 

g. Click Finish. The Table Wizard inserts the table and the necessary code. 

h. Format the data. See Formatting Data for details on how to format the data. 

Adding a Chart 

Using Invoice as an example, you can include a chart in the summary page to demonstrate how 
the Invoices are split. 

There are several chart types available in BI Publisher. The following is for creating a Pie-chart. 

To add a pie chart: 

1) Place the cursor above the summary table. The goal is to include the chart between the 
Project summary table and Invoice summary table because the table can get long and 
expand to the next page. 

2) Click Chart on the Word BI Publisher Ribbon. 

3) Set the Chart Type (on the right) to Pie Chart. 

4) (Optional) Select one of the Chart Styles. 

5) Drag Inv_Amount from the Data tree to the Values box to ensure that the size of each pie 
slice is determined by the dollar amount of the Invoice. 

6) Drag Inv_Title from the Data tree to the Labels box to ensure that the: 

 Pie slices are determined by Invoice 

 Invoice Title appears in the legend 

7) (Optional) Click Preview (top right corner) to see a preview of the chart and make changes if 
necessary. 

8) (Optional) Use the Properties table on the right side to set Chart Title, Legend properties, 
and so on. 

9) Click OK. You change the chart settings by double-clicking the chart in the template. 

10) (Optional) Add spacing between the chart and the two tables and center-align the chart. 

Adding Headers and Footers 

Use a 3-column table in the header and footer of your template to allow for a uniform adjustment 
of items such as titles, logos, and page numbers. Use Microsoft Help to learn how to add the first 
page to your document that does not include Header or Footer. 
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Adding Images from Unifier 

Note: Microsoft Word does not support form fields in the header and 
footer. If need to add an image to the header or footer of your Custom 
Report and you want the image to repeat on each page, see the "Adding 
BI Fields to the RTF Header or Footer" section. 

To add an image (Examples: Company logo, Shell image, or image picker from a BP record: jpg, 
gif, or png) from Unifier into your Custom reports, use the Sample XML file (Sample Data) that 
you have created and exported into Unifier. 

Note: Company logo cannot be displayed in Unifier interface. Create a 
company-level business process to place your Company logo. 

The following shows the procedure by using an example: 

1) Open the XML file. 

2) On top, identify the XML elements that are blank (shown in bold in the following code). 

<?xml version="1.0" encoding="UTF-8"?>

<DATA_DS>

<uuu_p_reportByF></uuu_p_reportByF>

<uuu_p_timeZoneF></uuu_p_timeZoneF>

<uuu_p_diffMinutesF>0</uuu_p_diffMinutesF>

<uuu_p_sysyTimeZoneID></uuu_p_sysyTimeZoneID>

<uuu_p_searchConditionF></uuu_p_searchConditionF>

<uuu_p_urlF></uuu_p_urlF>

<uuu_p_sessionIdF></uuu_p_sessionIdF>

<uuu_p_companyRegistryF></uuu_p_companyRegistryF>

<inv>

<PROJECT_ID>1012</PROJECT_ID>

<INV_ID>1</INV_ID>

<INV_RECORD_NO>INV-001</INV_RECORD_NO>

<INV_TITLE>Lumber Contract - Initial Invoice</INV_TITLE>

<INV_STATUS>Approved</INV_STATUS>

Note: At runtime, these blank elements are fully populated with 
information about the Unifier server base URL, the User’s session ID, 
and the Unifier company registry. 

3) Using the included parameters, plus the ID of a specific image (the image that you want), 
construct a URL of the format: 

<uuu_p_urlF>CompanyRegistry=<uuu_p_companyRegistryF>&sessionId=<uuu_
p_sessionIdF>&id=<image_ID>

Note: To build a similar URL in your BI Publisher report, ensure that you 
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have the Image ID because the other three parameters have already 
been identified. 

4) Access the Image ID of the image that you want and: 

Note: If applicable, you can find the Company logo Image ID in the 
companylogo column of the table sys_company_info. 

a.  JOIN the information into your existing Data Views. 

or 

b. Add the information as a new Data View, which you can add as a Sub-Report View to any 
Custom Report. The SQL to create a new Data View: 

SELECT companylogo

FROM sys_company_info

WHERE companyregistry = 'unifier';

5) Define the variables: 

Once you have an Image ID, you must define the variables needed to build the image URL 
by hiding the variables in a Data Field: 

a. Add a data field somewhere at the top of your report. This can be any field. You only 
need a placeholder for your variables. 

b. Double-click on the newly added data field and click the Advanced tab. Delete the text in 
the code box, if any. 

c. Add the following text into the code box: 

<?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>  
<?variable@begin:uuu_p_companyRegistryF;(.//uuu_p_companyRegistryF
)[1]?>

<?variable@begin:uuu_p_sessionIdF;(.//uuu_p_sessionIdF)[1]?>

<?variable@begin: image;(/DATA_DS/co/COMPANYLOGO)?>

Notes:  

 If you are adding a Shell image or Image Picker Data Element, you do 
not need that last line. Add the last line only if you have created a 
Company log Data View (If applicable, you can find the Company 
logo Image ID in the companylogo column of the table 
sys_company_info). 

 The example code presumes that you added an unlinked Sub Report 
View with the Data Set Tag "co" (for Company). You can change the 
Data Set Tag "co" (for Company) to the value that you have in the 
last column of Company Logo row in the Views used as data sets 
table on the Views tab of the Custom Report dialog. 

 If you want to insert the Project Shell ID, you must access that 
variable. Depending on where you are in your grouping, the variable 
can be: <?variable@begin:image;(SHELLIMAGE)[1]?>

To access the Project or Shell Image ID: 
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1) Go to table: unifier_shell_info.  

2) Identify the shellimage column of the table. The Project or Shell Image ID is in the 
shellimage column. 

You can JOIN this table to your main report view based on the unifier_shell_info.pid column, 
which contains the project ID. 

After you defined your variables, you can add an image. The BI Publisher leverages the 
Alternative Text of an image to dynamically set the image source. For more information, refer to 
the BI Publisher Report Designer’s Guide. 

To add a dummy image: 

1) Create an image (for example, Dummy_Image.jpg) and size it appropriately (for example, 
300 x 200 px). 

2) Right-click on the image and select Size… 

3) Click the Alt Text tab of the Size dialog 

4) Paste the following into the Alternative Text box: 
url:{concat($uuu_p_urlF,'companyRegistry=',$uuu_p_companyRegistryF,'
&sessionId=',$uuu_p_sessionIdF,'&id=',$image)}

Note: The last parameter ($image) was set as a variable to either the 
Company logo or the Project or Shell image. You must adjust the 
parameter if you want to include both images. Ensure that you use 
separate variable names for each. 

To test an image: 

The three parameters that you used to build your URL to the image are not downloaded as part 
of the sample data: 

uuu_p_urlF

uuu_p_sessionIdF

uuu_p_companyRegistry 

You must upload your RTF template to Unifier, publish the Custom Report, and then run the 
report to ensure that your image was inserted successfully. 

Adding BI Fields to RTF File Header or Footer 

Microsoft Word does not support form fields in the header and footer. As a result, you need to 
populate the headers and footers with text or images from Unifier. Refer to the BI Publisher 
Report Designer’s Guide for more details. 

To populate the headers and footers with text or images from Unifier, follow these steps: 

1) At the top of our RTF template (in the body, not the header), place the following tags:  

<?template:header?>

<?end header?>
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2) These tags form the start and end of our header. In between them, place the text and 
images want to include in the report header. Use a 3-column table in the header and footer 
of your template to allow for a uniform adjustment. 

3) Double-click into the header of the document. Ensure that none of the BI Publisher fields are 
highlighted. 

4) Add the text: <? call@:header?> to place everything in the tags added above into the header 
at report runtime. 

Importing Template into Unifier 

After you have completed creating your Template, you can upload your template into Unifier. 

To upload your template into Unifier: 

Note: Invoices is used as an example. 

1) Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > Configuration > Custom Reports. 

2) Open your Invoices Custom Report. 

3) In the Report File tab (consisting of Add, Modify, Remove, and Download options) 

a. Click Add to open the template window. 

b. Enter information in the following fields: Template Name, Template Type, and Report 
Layout File. 

 To localize the Custom Report output for different languages, you can provide 
XLIFF files for RTF-type templates here. 

 The Template Name field accepts spaces and other characters. 

c. Click Browse to select the template file for uploading. 

d. Click OK to confirm the upload. 

4) Click Browse and upload the RTF file. 

5) Click OK to close the window. 

6) Publish your report by selecting your report from the log and selecting Status > Published 
from the toolbar. 

Your report is added to list and Users can access the report from Projects, if they have the 
appropriate permissions. 

Adding a Report to Navigator 

To add your report to the Navigator: 

1) Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > Configuration > Navigator (User mode). 

2) Open your Project or Shell Navigator. You must be able to see your Custom Report on the 
right-hand side. If you do not see your Custom Report ensure that you have published the 
report. See Importing Template into Unifier. 

3) Add your Custom Report to the Reports section on the left-hand side (in the Navigator, you 
can create a new subfolder under Reports called Advanced Reports). 



Unifier Modules Setup Administration Guide

100

4) Click OK to close the window. 

5) Deploy the Navigator by highlighting it and clicking Deploy from the toolbar. 

Setting Permissions on Report 

You must give permissions to users so that they can run the new, custom report. 

You can give permissions using a Project template (to distribute the permission to all projects), 
or do it on case-by-case bases, one project at a time. 

To set permissions: 

1) Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > Company Sponsored Shells > Projects. 

2) Find your Project (the project that you want to add the Custom Report to) and open. 

3) Click Access Control. 

4) Go to the Custom Report, click the report to open the Permission Settings window. 

5) Add View access for any Users or Groups that you want to be able to run the Custom Report 
in your Project. 

Repeat the preceding steps if you want to add your Custom Report to other Projects. 

Running the Report 

To run your Custom Report: 

1) Navigate to you Project that has your Custom Report (for example, The Project with Invoice 
BPs created and in an approved or pending state) 

2) Run the report. 

Advanced BI Publisher Functions 

The following topics explain the advanced functions of the BI Publisher. 

Conditional Formatting 

With BI Publisher, it is easy to use conditional formatting to highlight table cells or entire table 
rows using conditional formatting.  

Example 

Highlight invoices with an amount over $10,000. 

Highlighting a Table Cell 

1) After you create a table, place the cursor in the cell where want to apply conditional 
formatting. 

Note: The cell must be either text or a Data Field. 

2) Click Conditional Format. The BI Publisher Properties window open on the Properties tab. 
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3) From the Data field drop-down list select the data element that you want to evaluate to 
determine the conditional highlighting. This does not need to be the same data field in the 
cell that you are trying to highlight. 

4) Specify whether that Data Field is a Number or Date/Text Field. 

5) Enter the conditions for this Data Field using the pertinent drop-down list. 

6) For each condition, specify the formatting that you want to be applied when that condition is 
met. 

Only two conditions can be entered by using this window. If you have more than two conditions, 
you can click on the Advanced tab and copy/paste the conditions already entered to create 
additional conditions. Ensure that you copy an entire "if" statement, up to and including the 
"<?end if?>" 

Example 

<?if:number(INV_AMOUNT)>10000?><?attribute@incontext:background-colo
r;'#FFB9B9'?><?end if?>

Highlighting an Entire Table Row 

To highlight an entire table row, follow the preceding instructions; however, ensure that you 
select Apply to Entire Table Row. 

Publishing BI Publisher Custom Report 

To publish a BI Publisher Custom Report: 

1) Prepare the custom report 

2) Click Status

3) Select Publish

Making a New Custom Report or Custom Print Appear in Unifier Navigation 

To make newly defined reports appear: 

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) Navigate to Configuration > User Mode Navigator. 

Note: If the company does not use User Mode Navigator, you will be 
able to see the report name under Access Control of the project or 
program. 

3) Open the project/shell User Mode Navigator. 

4) In the dialog box, find the newly created BIP reports on the right side and move them to the 
left side under Reports > Custom. 

5) Save the changes and close the window.  

6) Select the project/shell User Mode Navigator and click the Deploy button to ensure the 
changes take effect. 
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Note: BI Publisher User Group requirement: To be able to create 
reports, users must be added to BI Publisher Author user group through 
IDCS. 

Setting Permissions for Custom Reports 

To set permissions for Custom Reports: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. In the Access Control log window, there are two 
modules: 

 Administration Mode Access

 User Mode Access

If the reports are at the Program level, in the right pane, select User Mode Access > 
Programs > Reports > Custom > <report name>. 

If the reports are at the Project level, in the right pane, select User Mode Access > 
Shells/Projects (Standard) > Reports > Custom > <Report Name>.

3) Select the access for the appropriate user. 

4) Click OK. 

Notes: 

 A user with the configure permission to the Custom Report node, 
can configure custom print templates. There are no separate 
permissions for performing actions on the custom print templates. 

 If you have a User Mode Navigator, you must include the Custom 
Report in the navigator and redeploy before the user can assign 
permission through Access Control. 

Running a Report in Unifier 

To run the BI Publisher Report in Primavera Unifier: 

1) Sign in to your Unifier environment. 

2) Select a Project or Shell. 

3) Ensure you are in User mode. 

4) Under the Project/shell navigation tree, select Reports, Custom node.  

5) Select a report and a dialog box will open. 

6) In the dialog box, enter the search conditions and click Report to run the report. 

Uploading a Template for External Data Model Type Custom Report 

To upload a template for External data model type custom report: 

1) In the Report file tab click the Add/Modify button.  
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2) Click the Browse button, navigate to the .XDM file you want to use for the data model, and 
click the Upload button. 

Unifier uploads the data model for the report to the BI server. 

3) (Optional) To modify the data model, you can download it to your local drive by clicking the 
Download button. 

4) Click OK. 

You need to upload the Data Model file (.XDM) from the custom report Template File tab, using 
the following parameters: 

 uuu_p_project_id

Project ID 

 uuu_p_context_company_id

Company ID 

 uuu_p_process_id

Workflow process ID 

 uuu_p_source_id

Business process record ID 

 uuu_p_object_type

Business process id as in uDesigner 

 uuu_p_hide_task_details

To hide the task status if the user does not have permission. The value of 0 is passed if the 
user does not have permission to view the task statuses 

 uuu_p_hidden_comments

To view the hidden comments, if the user has the permission. The value of 1 is passed if the 
user has the permission to view hidden comments 

These parameters are used to pass information from the Unifier runtime to the BI Publisher 
server (integration at runtime). 

Downloading Sample XML Data for Designing New Templates 

This part of the Sample Data tab is for downloading sample data to use in designing a new 
report template file. You can download data from a specific project. 

To download sample XML data for designing new templates: 

1) (Optional) In the Sample Project field, select the project or shell data you want to generate. 

If you do not specify a sample project or shell, Unifier will use data from the main view that 
was specified on the Views tab. 

2) In the Number of rows to return field, specify the number of rows of data you want to use 
for designing the template. 

3) Click the Generate button. This button is disabled in case of external data model report until 
the report has been published at least once. 

Unifier generates a random sample of the XML from the Sample Project, or the main view of 
data. 
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4) Click OK. 

You can then use this XML data in BI Publisher to design the template file. 

Modifying Existing XDM for Custom Report or Custom Print Configuration 

Changes to the Data view, Data Set, Query and Parameters are not applied to the XDM file by 
Unifier. Users need to apply those changes manually to the XDM file. 

Data View 

If a data view is changed, it may require a modification in the XDM file. For instance, if a new 
column is added and it is required in the layout of the report, then the column must be added 
into the query in the data set in the XDM file. 

Main View for Data set 

If a main view is changed for the data set, it requires a modification in the XDM file to reflect the 
change in the From clause of the query of the main data set. 

Query Parameter 

The Element name for a Query is mapped to a BI Publisher parameter based on the format: 

:uuu_p_{Element Name}

Note: Ensure the length of {Element Name} is less than 24 characters. 

Any query parameters created on the elements of the main view on the query tab also need to 
be appropriately mapped in the Where clause of the main view query in the XDM. Refer to 
Adding or Modifying Unifier report parameters section of the Unifier Reporting using BI Publisher 
11g document. 

To modify an existing custom report configuration: 

1) Go to the Company Workspace tab and switch to Administration mode. 

2) Click Configuration > Custom Templates in the left Navigator to open the log. 

3) Select a custom report and click Open to open the custom report window. 

Note: The custom report must be in Draft status for modification. 

4) Modify the fields as necessary. All fields except the "Report Level" can be modified, as long 
as the custom report has not yet been published. Once the report has been published, the 
"Report Name" files also becomes un-editable. 

Adding a Dynamic Image in the Custom Print Template 

To add images from within Unifier to the Custom Print template: 

1) Create form fields in the .rtf file, corresponding to the following parameters: 

 <?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>

 <?variable@begin:uuu_p_sessionIdF;(.//uuu_p_sessionIdF)[1]?>
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 <?variable@begin:uuu_p_companyRegistryF;(.//uuu_p_companyRegistryF)[
1]?>

Note: The uuu_p_* is a predefined parameter in the data model. 

1) Right-click the dummy image and select Size and provide the following value in the 
Description field of the AltText information for the image: 

Description: 
url:{concat($uuu_p_urlF,'companyRegistry=',$uuu_p_companyRegistryF,'&sessionId=',$uuu
_p_sessionIdF,'&id=',BPIMAGE)} 

For example, you must replace the <BPIMAGE> data element, in the above URL value, with 
the image file ID "k__<image element>" from the sample XML. See Sample XML Data for 
Custom Templates (Custom Prints and Reports) (on page 70). 

Adding a Dynamic Image in the Custom Report Template 

To add images, from within Unifier, to the Custom Report template: 

1) Create form fields in the .rtf file, corresponding to the following parameters: 

 <?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>

 <?variable@begin:uuu_p_sessionIdF;(.//uuu_p_sessionIdF)[1]?>

 <?variable@begin:uuu_p_companyRegistryF;(.//uuu_p_companyRegistry
F)[1]?>

Note: The uuu_p_* is a predefined parameter in the data model. 

2) Right-click the dummy image and select Size and provide the following value in the 
Description field of the AltText information for the image: 

Description: 
url:{concat($uuu_p_urlF,'companyRegistry=',$uuu_p_companyRegistryF,'&sessionId=',$uuu
_p_sessionIdF,'&id=',PROJECTIMAGE)} 

For example, you must replace the <PROJECTIMAGE> data element, in the above URL 
value, with the image element taken from your sample data XML. See Sample XML Data for 
Custom Templates (Custom Prints and Reports) (on page 70). 

Adding a Dynamic Image in BI Publisher Report 

To add a dynamic Unifier image in BI Publisher report, we need to create a new data set in the 
Data Model (XDM) file, as explained below.  

Note: The following instructions apply to reports that run on BI Publisher 
server, directly. The BI Publisher reports run via Unifier does not need to 
make these changes. 

In the .XDM file: 

<dataSet name="security_token" type="complex">

         <sql>
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            <![CDATA[SELECT token_value sec_token from ( SELECT 
token_value,expired,ROW_NUMBER() OVER (ORDER BY expired desc) rn FROM 
sys_server_token WHERE token_type = 'img') where rn = 1]]>

         </sql>

</dataSet>

<group name="security_token" label="security_token" 
source="security_token">

      <element name="SEC_TOKEN" value="SEC_TOKEN" label="SEC_TOKEN" 
dataType="xsd:string" breakOrder="" fieldOrder="1"/>

</group>

Note: The purpose is to get the server token from database where 
"expired" is the maximum from all the rows. 

In the report template that requires to have the image to be inserted, change the "Alt text" of the 
image to point to image retrieval URL. 

To retrieve a Unifier image, use the URL: https://unifier-server-address 
/bluedoor/rest/image/<image_id>/<server_token>

The report parameter uuu_p_urlF can be created in Data Model (XDM) file with a default 
value, so at the runtime the Unifier server address-part of the URL can be changed 
appropriately: 

  <parameter name="uuu_p_urlF" 
defaultValue="https://unifier-server-address/bluedoor/rest/image" 
dataType="xsd:string" rowPlacement="8">

            <input label="uuu_p_urlF" size="100"/>

        </parameter>

The report template uses this URL in the "Alt text" of the image, as in: 
url:{concat($uuu_p_urlF,'/',DATA_IMAGE_ID,'/',//security_token/SEC_TOKE
N[1])}

Where: uuu_p_urlF can be the template variable, for example: 
<?variable@begin:uuu_p_urlF;(.//uuu_p_urlF)[1]?>

The security token, retrieved from DB by the dataset is: 
//security_token/SEC_TOKEN[1]

The runtime data (image ID) is: DATA_IMAGE_ID

Adding Rich Text Data Element in BI Publisher Report and Custom Print 

Unifier supports custom print, and custom report, for the “Rich Text” data element. You can use 
the “Rich Text” data element (of your BP form) in your data model. Furthermore, the HTML 
version of the “Rich Text” data element can be rendered as HTML, in the report, if the HTML 
version needs to be seen in BI Publisher template.  

To include the “Rich Text” data element: 
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1) Go to the report template file, for “Rich Text” data element. 

The Rich Text fields in the BI Publisher template file are prefixed with: ?html2fo. For 
example, if the DE name is RTECODE, then the DE name must be wrapped as it was in the 
template file as: <?html2fo: RTECODE?>. This will allow the template processor to treat the 
element as HTML. 

2) To view the Rich Text type DE in correct format, in the BI Publisher reports (in the BI 
Publisher server), go to the data model editor for the report and set the data type of the 
RTECODE data element column to XML. 

In the BI Publisher, the Rich Text type DEs can be found in the <model>_richtext data model.  
In addition, when defining queries and Data Links in Custom Templates: 

 The Rich Text type DE from the BP richtext views (model_richtext) must be restricted. 

 The plain Rich Text type DE content, from the BP model, must be allowed. 

Connect to Unifier Database 

A direct connections to the Unifier database using SQL Developer is not possible. The creation 
of SQL queries must be done in Unifier Data Views, or by pulling rows down from Unifier into a 
local database. 

If you need to pull the data into a local database for the purpose of SQL development, Oracle 
offers Oracle Database 11g Express Edition (XE) free of charge. You can install this lightweight 
DB on your computer and use it for development purposes. 

Download Oracle Database Express Edition (XE). Refer to the XE documentation for instructions 
on how to install the software and create a local database. 

(Optional) Pulling Down the Data 

In Unifier, once you know the table names, you can export 200 lines so it can be inserted into 
your local Database (DB). To pull down the data: 

1) Sign in to Unifier as a Company Administrator and go to the Company Workspace tab, 
ensure that you are in Administration mode > Data Structure Setup > Data Views. 

2) Click New to create a new Data View. 

3) Enter a name (for example, Export DV) and a Label (for example, Export Data View). 

4) In the SQL Definition field, enter the following for a particular table: SELECT * FROM 
<tablename>

5) Click OK. 

6) Click the Status drop-down list and set the newly created Data View to Published. 

7) Highlight the Data View you just created and click Data on the toolbar. 

8) In the window, click Export as SQL on the toolbar to save the .sql file locally. This SQL file 
includes the CREATE and INSERT commands required to get your data into your local XE 
database. 

At this point, you can create the table and insert the exported rows into your local XE database 
using tools like SQL Developer. 

Repeat the steps above for any tables that you like to access offline.  
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Note: You can reuse the same Data View multiple times; however, you 
need to do find and replace in the downloaded SQL to ensure that the 
table names match the names that are in Unifier. 

Since you have a subset of the database locally, you can use SQL Developer to write complex 
queries, offline, before bringing them into Unifier. 
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Configuring Project Numbering, Cost Codes, and 
Status 

To configure project numbering, cost codes, and status: 

1) Go to the Company Workspace tab and click Configuration > Shell Manager in the left 
Navigator. 

2) Select Projects (Standard) and click the Open button. The Configuration - Projects 
(Standard) window opens. 

3) Complete the General tab as described in the table below. 

4) Click Apply to save your changes, or OK to save and exit the window. 

In this field Do this 

Enable 
automatic 
numbering 

Select to allow automatic numbering of projects based on the specified 
Format and Start values. You can deselect this checkbox to disable 
automatic numbering. This checkbox is selected by default. 

Format/Star
t 

Specify the format and starting number for projects if automatic 
numbering is enabled. Format determines the format of the numbering 
schema. Start determines the starting number of the numeric schema. By 
default, Format is blank and Start is 0001. The numbering schema format 
cannot be changed after a user creates projects using the originally 
specified format. 

Cost 
Codes: 
CBS/Gener
ic 

Displays the type of cost code specified in uDesigner for the project. The 
type available for Projects (Standard) is CBS. 

Status 
Status can be Active or Inactive. Users cannot access projects with the 
status Inactive. The default is Inactive. 

In This Section 

Create and manage project categories (organize projects) .................................... 109 

Create and manage project categories (organize projects) 

You may create project categories to help organize multiple projects. Project categories have no 
effect in User Mode and are invisible. Users who are assigned to a project, regardless of the 
category, will see the project listed in their Projects log. 
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Once a project has been created under one category, it cannot be moved to another. New 
projects may be created under the new categories. Once you create a category, you cannot edit 
or delete it, but you can deactivate it to prevent it from being displayed in the Navigator. 

Tip: Project Administration permissions can be set based on category. 
For example, you might create a category called Large Construction 
Projects, another called Small Construction Projects, and another called 
Maintenance and Facilities. You can grant project administration 
permissions to one set of project administrators for the All category, to 
another group for the construction categories, and to a third group to 
handle project administration of the maintenance/facilities projects. Once 
you create a category, you cannot edit or delete it, but you can 
deactivate it to prevent it from being displayed in the Navigator. 
Remember to grant permissions to yourself or others to view the new 
categories and to create/edit projects in the category. 

To create a project category 

1) Go to the Company Workspace tab and switch to User mode. 

2) In the left Navigator, click Configuration > Shell Manager. 

3) Select Projects (Standard) and click the Open button. The Configuration - Projects 
(Standard) window opens. 

4) In the Organize tab, click Add. The Add Project Category window opens. 

5) Type a name for the new category. The status for the newly-added category is Active: 

 Active: projects can be created in the category, which appears in the Navigator 

 Inactive: the category will not appear in the Navigator until it is activated 

6) Click OK to add the category. 

7) After all categories have been added, click OK to save and exit the Configuration - Projects 
(Standard) window. 

To rename a project category 

1) In the Configuration - Projects (Standard) window, select a category. 

2) Edit the project category Name and click OK. 

3) Click OK to close the Configuration - Projects (Standard) window. 

To activate/deactivate a project category 

1) Open the Configuration - Projects (Standard) window and do one of the following: 

 To deactivate an active category, deselect the Activate checkbox. Deactivating a 
category will cause it to not be displayed under Company Sponsored Projects, but this 
does not affect any projects organized within it. Any projects in a deactivated category 
are still accessible to administrators under Administration Mode > Projects, and to 
users in User Mode. 

 To activate an inactive category, select the category and select the Activate checkbox. 

2) Click OK to close the Configuration - Projects (Standard) window. 
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To grant permission to access the new project category 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, do one of the following: 

a. Click User Administration > Company Users or Partner Users (to grant permissions to 
company or partner users), or 

b. Click User Administration > Groups (to grant permissions to a group or individual 
users.) 

3) Select a company, partner, group, or user from the log and click Open. 

4) Click the Permissions tab. 

5) In the upper portion of the window, under Administration Mode Access, do one of the 
following: 

a. Click User Administration > Company Users, 

b. Click User Administration > Partner Users, 

c. Click User Administration > Groups, 

d. Click User Administration > Task Reassignment, or 

e. Click Company Sponsored Projects (Standard). 

6) Select the new categories to which you want the user to have administration access, and 
click OK. The user may already have access to All which allows them to administer (create 
or edit) projects in the All category. 

Note: Having "Administer All" permission does not automatically grant 
administration access to other custom categories. This permission 
setting allows the user access to the project category only, and does not 
set specific permissions regarding project administration. 

To access the categories 

New categories appear under the Company Sponsored Projects (Standard) node in the 
Company Workspace tab (Admin mode). You may need to refresh the page (reopen the 
company record, or press the F5 key) before you can see the new categories. 
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Getting Started with Unifier Modules Setup 
Administration Guide 

Within our documentation, some content might be specific for cloud deployments while other 
content is relevant for on-premises deployments. Any content that applies to only one of these 
deployments is labeled accordingly. 

Access to Unifier functionality is granted through permissions. The ability to utilize a specific 
function in Unifier depends on permissions settings (accessed in Admin mode). 

The Unifier Modules Setup Administration Guide explains how to setup the Unifier modules that 
are used in the administration mode (admin), or in the user mode, of operation.  

Primavera Unifier has two modes of operation: 

 Admin (Administration) mode

Company administrators work in Admin mode to set up, for example, company, program, 
and project or shell properties, user permissions, templates for major Unifier features, data 
structures, and configure and set up business process (BP) workflows. 

 User mode

Users spend most of their time in the User mode. The User mode allows users perform the 
day-to-day activities, collaborate through business processes and Mailbox, maintain, for 
example, the Cost Manager, Schedule Manager, and Document Manager, and run reports. 

The Unifier User Guide explains how to use the options that are available in the user mode of 
operation. 

You can switch between modes using the mode icons ( ). 

Note: This option is not available in Home page because Home page 
does not support the Admin mode. 
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Setting up Multiple Company Calendars 

Unifier supports multiple calendars, enabling you to create a library of calendars that can be 
selected for use at the company, shell, and project levels. The multiple calendars enable you to 
have calendars to support varying work schedules (depending on locality) and to account for 
holidays and other non-working days. For example, some countries in the Middle East have 
weekends that are other than Saturday and Sunday. Unless otherwise specified, the default 
calendar for a project or shell is the Company calendar that is designated as the default 
calendar. The calendar selected affects project or shell durations and due dates. 

The calendars can be used in project/shell templates, and are automatically applied when the 
template is updated. Also, users can create activity calendars to use in schedule sheets, specific 
activities in schedule sheets. Calendars also affect business process task dues dates, workflow 
due dates, and formula calculations. 

Step 1: Set permissions for multiple calendars. Grant permissions to allow the configuration of 
company-level multiple calendars. See Setting Multiple Calendar Permissions (on page 115). 

Step 2: Create and manage calendars (create, copy, modify, delete, set as default). See 
Creating Multiple Calendars (on page 116) and Modify, Delete, or Mark a Calendar as 
Default at Company Level (on page 117). 

In This Section 

Setting Multiple Calendar Permissions .................................................................. 115 
Creating Multiple Calendars .................................................................................. 116 
Modify, Delete, or Mark a Calendar as Default at Company Level ......................... 117 

Setting Multiple Calendar Permissions 

You must have permissions granted to be able to create, modify, or view the calendars. 

To set multiple calendar permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click the Access Control node. 

3) On the right pane, select Administration Mode Access > Standards & Libraries > 
Calendars. 

4) Set the permissions as needed: 

 Create: Users can create, modify, view, delete, mark as default. These calendars are 
known as Standard Calendars. 

 Modify: Users can modify and view Standard Calendars. 

 View: Users can view existing Standard Calendars. 
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Creating Multiple Calendars 

You can create a calendar and use it as the standard calendar for use in Unifier at the company 
level, shell level, project level, template level, activity level, and business processes.  

There is a default company calendar available in Unifier titled: Company Calendar (Default). 
You can: 

 Use the default calendar as the standard calendar. 

 Use the default calendar to create a standard calendar. 

 Copy an existing calendar and modify it to create a new calendar that can be used as 
standard calendar. 

 Create a custom calendar. 

You must have Create permission to be able to create standard calendars. See Create a Project 
Calendar (Calendar Tab) for more details. 

To create a standard calendar at company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window 
opens. 

3) Click New. The Calendar Properties window opens. 

4) Enter the calendar name and an optional description. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Select the calendar day and click the Working or Non Working options as needed. 
By default, the standard calendar will have Saturdays and Sundays marked as non-working 
days. For more information about modifying the calendar days, see Modify, Delete, or Mark 
a Calendar as Default at Company Level (on page 117). 

6) Click OK. 

To copy an existing calendar at company level 

1) Go to the Company Workspace tab and click Standards & Libraries > Calendars in the 
left Navigator. The Calendars log window opens. 

2) Select a calendar in the log. 

3) Click Copy. The Calendar Properties window opens with the calendar description and 
calendars days specified. 

4) Enter the calendar name and change the optional description as needed. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Select the calendar day and click the Working or Non Working radio buttons as 
needed. 

6) Click OK. 
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Modify, Delete, or Mark a Calendar as Default at Company Level 

You can modify a standard calendar if you have Modify permission. You can delete a standard 
calendar if you have Create permission. If you use a calendar in a shell, project, schedule 
sheets, or schedule sheet activities, and you are asked to replace the calendar, you can delete 
the existing calendar and replace it with a new one. You can also specify a default standard 
calendar if you have Create permission. Unless otherwise specified, the default calendar for a 
project or shell is the company calendar that is designated as the default calendar.  

Note: The calendar selected affects project or shell durations and due 
dates. 

To modify a calendar at company level (Classic View) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window 
opens. 

3) Click the company calendar to select and click Open. The Calendar Properties window 
opens. 

4) Modify the calendar name and change the optional description as needed. 

5) Modify the working and non-working days that are specific to the new calendar you are 
creating. Select the calendar day and click the Working or Non Working options as needed. 

a. To change a particular date from a working to a non-working day, click the date cell to 
highlight and click Non Working. You can select multiple dates. This change impacts the 
months individually and does not impact the rest of the calendar or subsequent years. 

b. To change Saturdays and Sundays from non- working days to working days, click the day 
cell for example "Sat," to highlight and click Working. This will make all Saturdays, or 
Sundays, of the calendar as working days, including subsequent years. In this scenario, 
you can select individual dates under Saturdays or Sundays and mark them as 
non-working dates. 

6) Click OK. 

To delete a calendar at company level (Classic View) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window 
opens. 

3) Select one or more calendars in the log. 

4) Click Delete. If a calendar is not in use, it is deleted. If a calendar is in use, the Select a 
Calendar window displays to enable you to select a replacement calendar. Select an 
alternate calendar and click OK. 

Note: You cannot delete calendars that are used by view-only projects 
or shells. 

To specify a default calendar (Classic View) 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window 
opens. 

3) Select a calendar in the log. 

4) Click Default. 

To change working and non-working days on a calendar at company level (Classic View) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Calendars in the left Navigator. The Calendars log window 
opens. 

3) Click to select a calendar and click Open to open the Calendar Properties window. 

a. To change a particular date from a working to a non-working day, click the date cell to 
highlight and click Non Working. You can select multiple dates. This change impacts the 
months individually and does not impact the rest of the calendar or subsequent years. 

b. To change Saturdays and Sundays from non- working days to working days, click the day 
cell for example "Sat," to highlight and click Working. This will make all Saturdays, or 
Sundays, of the calendar as working days, including subsequent years. In this scenario, 
you can select individual dates under Saturdays or Sundays and mark them as 
non-working dates. 

A non-working date appears grayed out, and it will not be used in date calculations. 
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Configuring the User Mode Navigator 

You (Company administrator) can configure the User mode Navigator (Company Workspace 
tab > Admin mode > Configuration > User Mode Navigator) to better suit the company 
business needs. The User Mode Navigator enables you to modify the appearance and 
organization of the modules and business processes that are available in the left-hand Navigator 
for all company users. 

This functionality of the User Mode Navigator is limited to the collaborative portions of the User 
mode Navigator in the Home, Company Workspace, Programs, Shells, and Projects. 

Note: This configuration will affect the User mode Navigation for all 
users in your company. We strongly recommend that you fully test your 
configurations in the Development/Test environment.  

Within the User Mode Navigator, you can create new grouping nodes, rename existing ones, 
reorder items within the nodes, and even remove unused modules from the Navigator, in order 
to provide increased flexibility to organize and view Unifier modules and business processes. 
The configured view will appear for all users. 

As always, access to any module or business process is strictly controlled by permission 
settings. The User Mode Navigator feature does not override permission settings in any way; it 
simply allows you to customize the look and organization of navigator modules that a user has 
permissions to access. Any changes you make to the User mode navigation tree will be 
reflected in the Access Control view. 

Example 

 If a user has permission to access at least one leaf node under a grouping node, then the 
grouping node will appear in the user’s view of the navigator. 

 If the user does not have permission to any leaf nodes under a grouping node, then the 
grouping node will not appear in the user’s Navigator. 

The following terminology is used with User Mode Navigator: 

 Grouping node: This is a container "parent" node. Grouping nodes are easy to identify 
because they have a (+) next to them in the navigation tree. Clicking a grouping node, in the 
left-hand Navigator, expands the node to display any child nodes below it; the child nodes 
can be leaf nodes, or another grouping node, for example, Project Logs, Cost Manager, and 
so forth. 

 Actionable grouping node: This type of grouping node not only expands to display child 
nodes underneath it, but also refreshes the right pane and displays an associated log or 
page, for example, Projects node, which expands to display the project nodes in the 
Navigator and opens the Project home page, also. 

 Leaf node: This is a child node that cannot become a grouping node. In the last node of the 
navigation "tree," no further branching can take place. Clicking a child node refreshes the 
right-hand Unifier pane to display the associated module or log, for example, Cost Sheet 
within the Cost Manager, or the individual business process logs under Project Logs. 

The configurable navigator allows you to:  
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 Configure navigation trees for: 

 Company Workspace Navigator 

 Home Navigator 

 Program Navigator 

 Project / Shell Navigator 

Note: The settings do not take effect in your users’ navigators until you 
deploy them. 

The User Mode Navigator enables you to: 

 Create new grouping nodes (New) for: 

 Company Workspace 

 Home 

 Program 

 Project/Shell 

 Copy an existing navigator setup (Copy) 

 Deploy a navigator (Deploy) 

The system performs a check to see if there are any other navigators of the same type 
currently active, or not.  If yes, then the system notifies you that the currently deployed 
navigator will be set to "Inactive" status. 

 Undeploy a navigator (Undeploy) 

When selecting this option for an Active navigator, the navigator (for the type selected) 
displays system defaults during the runtime. 

 Include a navigator for your configuration package  

 To be able to define multiple navigators per object and create configuration packages to 
suit various out of the box (OOTB) solutions. Each OOTB solution has its own 
configuration of business processes, reports, and so forth along with the User mode. 

 You can include multiple navigators in the component list and create your configuration 
package. 

 The status of a navigator does not impact export. 

 When you package a User Mode Navigator setup for the first time, you must include all 
the designs (on the left-hand side of the navigator) in the package. If you do not include 
the designs, the configuration package creation will result in an error.  

 For Active navigator setups, the Last Deployed Date must be greater than the Last 
Saved Date. 

 If the navigator status is set to Active, then the system deploys that navigator to the 
destination environment. If the status is Inactive, then the system adds the navigator to 
the User Mode Navigator list. 

 If a navigator with the same name exists in both the package and the destination server, 
then the system updates the content at the destination server. 

 If the status of the navigator in the destination server is Inactive and the status of the 
navigator in the package is Active, then the system deploys the navigator and changes 
the status to Active in the destination server. 
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 If the status of the navigator in the destination server is Active and the status of the 
navigator in the package is Inactive, upon import of the configuration package, the 
system updates the content of the navigator, but the navigator will not be deployed.  

 Custom BI Publisher reports can be a part of the User Mode Navigation setup.  

 Internal BI Publisher reports, included in the setup, must be either a part of the package 
or exist in the destination server. If the Internal BI Publisher report is in Draft status, the 
import will succeed if the Internal BI Publisher report has been published, in the 
destination server, at least once. 

 External BI Publisher reports, included in the setup, must be either a part of the package 
or exist in the destination server. The External BI Publisher report name, location, and 
report level that exists in the destination server must match the attributes existing in the 
package. 

 Rename new and existing grouping nodes 

 Change the icons associated with the nodes 

 Move nodes up and down the navigation tree, or from one grouping node to another 

 Remove unused modules from the navigator without deleting the modules themselves 

 Move business process logs or other modules between new or existing grouping nodes 

 Store the following versions of the navigator: 

 Last saved version 

 Last deployed version 

 System default version, 

 Restore the navigator to any of the above versions at any time 

Note: Configuring navigator is a separate setup. As a result, the new 
business processes do no appear in the log selected in the 
configuration. Instead, the new business processes appear in the 
right-hand pane of the user's configurable navigator window. To place 
the new business processes inside the corresponding node in the 
left-hand pane Navigator, and make it available to the users, you must 
transfer the new business processes manually. 

In This Section 

Create a New User Mode Navigator Configuration ................................................ 122 
Create a new grouping node .................................................................................. 123 
Rename a grouping node ...................................................................................... 123 
Change the icon of a grouping node ...................................................................... 124 
Move nodes within the navigator ............................................................................ 125 
Remove unused modules from the navigator ......................................................... 127 
Delete a grouping node .......................................................................................... 129 
Deploying a navigator configuration ....................................................................... 129 
Delete a navigator configuration ............................................................................ 129 
Restore the navigator to previous or default configuration ..................................... 130 



Unifier Modules Setup Administration Guide

122

Create a New User Mode Navigator Configuration 

You can create one configuration for user mode Project, Shell, Program or Company 
Workspace. 

To create a new project, program or company workspace navigator configuration 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > User Mode Navigator. The User Mode 
Navigator log lists all previously created configurations. 

3) Click New and choose one of the following: 

 Home: configures the navigation node for the Master Log - Business Processes node. 

Note: You cannot hide the Tasks, Notifications, Drafts, and Mailbox 
nodes in the Home page. 

 Company Workspace: configures the navigation nodes within the Company Workspace 
portion of the User Mode navigator 

 Program: configures the program level navigation 

 Project/Shell: configures the project/shell level navigation 

The Create New Navigator window opens. The left portion of the window displays the 
navigation as it would appear for users. In the example below, the default navigation is 
displays, since a new configuration has not been deployed. 

The right pane of the window displays available modules or business process logs that can 
be added to the navigation on the left. 

4) Configure the new navigator configuration as described below. 

5) To save the configuration, click OK. 

The configuration will be displayed in the log. There can be one configuration each for 
Project, Shell, Program or Company Workspace. After saving, you must deploy the 
configuration for it to take effect. See Deploying a navigator configuration (on page 129). 

You can configure the new project, program or company workspace navigation. After 
deploying, the configuration will appear in the user mode navigator for all users in your 
company. 

Use the toolbar to configure the navigation: 
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To expand all navigator nodes 

In the navigator window, click the Expand All button. This expands all grouping nodes and 
allows you to view all of the nodes currently present in the navigation. You can contract a 
grouping node to hide the leaf nodes by clicking the (-) next to the grouping node name. 

Create a new grouping node 

You can create a grouping node to use to organize modules or business process logs. 

To create a new grouping node 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the left Navigator, select a valid parent node. This can be the root node (Company 
Workspace, Program, Shell, or Project), or any other grouping node in the navigator tree (for 
example, Cost Manager or Project Logs). 

4) Click New. The newly created node is created under the selected node. The default name is 
New Grouping Node, and uses the default icon of a file folder. Grouping nodes can be 
renamed, moved and given a new icon. 

Rename a grouping node 

You can rename any new or existing grouping node in the navigator, with the exception of the 
root node (Project, Shell, Program or Company Workspace). You cannot rename leaf nodes. 

To rename a grouping node 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 



Unifier Modules Setup Administration Guide

124

3) In the navigator window, double-click the grouping node, or select the node and click the 
Rename button. The field becomes editable. 

4) Enter a new name for the field, up to 32 characters. Grouping nodes under same parent 
node cannot have same name. 

Change the icon of a grouping node 

You can change the icon of any grouping node except the root node (Projects, Shells, 
Programs, Company Workspace). 

To change the icon of a grouping node 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the navigator window, select the grouping node and click the Change Icon button. The 
available icons are displayed. 
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4) Click the new icon. The icon immediately appears on the selected grouping node. 

Move nodes within the navigator 

You can move any grouping node or leaf node up or down the navigator, either within the 
original grouping node, or from one grouping node to another. There are three ways to move 
nodes within the navigator: 

 Move a node up and down the navigation tree within its parent grouping node 

 Move a node from one grouping node to another 

See the following procedures for more details. 

To move a node up or down the navigator 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the navigator window, select the node to move. 
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4) Click the Move Up or Move Down button to move the node up or down within the parent 
grouping node. If you move a grouping node, all child nodes move with it. 

To move a leaf node from one grouping node to another 

1) In the navigator window, select the node to move. 

2) Click the > button to move the node to the right pane. Continue with each node that you want 
to move. 

Only leaf nodes will be moved. If you select a grouping node, only the leaf nodes underneath 
it will move to the right pane. The grouping node itself will be deleted. 

3) In the left pane, select the destination grouping node into which you want to move the leaf 
nodes. 

4) In the right pane, select the leaf node to move and click the < button. The leaf node moves to 
the grouping node on the left. Repeat as needed with any other leaf nodes to move. 
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Note: If you leave a leaf node in the right pane and deploy the 
configuration, that module or business process will not appear on the 
user mode navigator for users. 

To move a node from one grouping node to another by cut and paste 

1) In the navigator window, select the node to move. You can select a grouping node or leaf 
node. 

2) Click the Cut button. (The selected node will not yet be removed). 

3) In the left pane, select the destination grouping node in which to move the selection. 

4) Click the Paste button. The node will be moved the new location. If you have selected a 
grouping node, the grouping node and all leaf nodes will be moved. 

Remove unused modules from the navigator 

If there are Unifier modules that your company never uses, and that cannot be hidden by use of 
permission settings (for example, the Mailbox module), you can remove them from the User 
Mode Navigator. The modules themselves will not be deleted, and can be restored to the 
Navigator at any time. 

To remove a module from the User Mode Navigator 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the navigator window, select the node to remove. 

4) Click the > button to move the node to the right pane. Continue with each node that you want 
to remove. 

Only leaf nodes will be moved. If you select a grouping node, only the leaf nodes underneath 
it will move to the right pane. The grouping node itself will be deleted. 

5) Save and deploy the configuration. The nodes that remain in the right pane will not appear in 
the user mode navigator. 

In the above example, the Mailbox module nodes are moved to the right pane, which remove 
them from the user mode navigator for all users. Note that the original Mailbox grouping 
node has been deleted. 
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Delete a grouping node 

Any grouping node can be deleted. Leaf nodes cannot be deleted; however, you can remove 
them from the user mode navigator that appears to all users. See Remove unused modules 
from the navigator (on page 127). 

To delete a grouping node 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the left pane of the navigator window, select a grouping node. 

4) Click the > button. The grouping node is deleted. If the grouping node contains leaf nodes, 
the leaf nodes are moved to the right pane, and the grouping node is deleted. 

Deploying a navigator configuration 

Once you have created a navigator configuration, it must be deployed for changes to take effect 
in the user mode. Once you deploy the navigation, the view will be displayed to all users. 

To deploy a new navigator 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the User Mode Navigator log, select the configuration to deploy. 

4) Click the Deploy button. When the navigation configuration is deployed, a confirmation 
window opens. Click OK. 

The navigator change takes effect immediately for all users. 

Delete a navigator configuration 

If you delete a configuration from the User Mode Navigator log, the system defaults for the 
applicable portion of the User Mode Navigator (Project, Shell, Program or Company Workspace) 
will be restored back to the system defaults automatically. 

To delete a configuration and restore the navigator to system defaults 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration>User Mode Navigator. The User Mode Navigator 
log opens. The log lists any previously created configurations. 

3) In the User Mode Navigator log, select the configuration to delete. 

4) Click the Delete button. At the confirmation window, click Yes. The user mode navigator will 
be restored to system defaults immediately. 
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Restore the navigator to previous or default configuration 

You can restore the navigator configuration to a previously saved version, the last deployed 
version, or to original system default at any time. You must still deploy the restored navigator in 
order for it to take effect. 

To restore the navigator to a previous or default version 

In the configurable navigator window, click the Restore button and choose one of the following 
options: 

 Last Saved: Restores the navigation tree to the last saved version, regardless of 
deployment 

 Last Deployment: Restores the navigator to the version that was last deployed (not 
applicable for new configurations that have not yet been deployed) 

 System Default: Restores the navigator to the original system defaults 
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Setting up the Users (User Administration) 

This section covers adding, managing, related permission settings, and related access control 
for:  

 Company Users (sponsor company and partner company users) 

 Partner Users (partner users) 

 Groups (user groups) 

 Task Reassignment (access control) 

 Integration Users

In This Section 
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Owner Company or Sponsor Company 

The entity that engages in business and has the complete control (or ownership) of the Unifier 
application with all its rights and privileges. 
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Partner Company or Member Company 

The consultants, contractors, and vendors that have been invited to participate in a project by 
the Owner Company/Sponsor Company. Unifier allows adding Partner Company/ Member 
Company to enable project users to collaborate on (and coordinate) the execution of a project.  

Note: A Member Company is a Partner Company. When a Partner 
Company is added to a shell or project, the Partner Company becomes 
a Member Company. That is to state: When a Partner Company
participates in a project or shell, the Partner Company becomes a 
Member Company in that project or shell, and the Partner Company
users that are added to the project or shell become the Member 
Company users. 

To access the User Administration node, go to Company Workspace tab > Admin mode > 
User Administration. The following explains each sub-node in details. 

For more details about company types, see Companies in Unifier. 

Generally, the values of the user attributes are specified under the General tab of the members 
in Company Users or Partner Users:  

1. Go to your Company Workspace tab in Admin mode. 

2. From the left-hand Navigator click the User Administration node to expand it. 

3. Click the Company Users, or Partner Users, sub-node to open the log. 

4. Select a member from the log and click Open. The Edit User window for the user that 
you selected opens, and the General tab is displayed by default showing the values of 
the user attributes. 

The same values of the user attributes that are specified under the General tab of the members 
in Company Users or Partner Users are also displayed (read-only) in the shells, within the 
Users or Groups sub-nodes: 

1. Go to your <shell> tab in Admin mode. 

2. From the left-hand Navigator click the User Administration node to expand it. 

3. Click the Users, or Groups, sub-node to open the log. 

4. Select a member from the log and click Open. The Edit Projects User window for the 
user that you selected opens, and the General tab is displayed (read-only) by default 
showing the values of the user attributes. 

Note: You can edit the user attribute fields that are relevant to each 
project or shell, only. 

Within a shell, the General tab (of the members in Users or Groups) you can click the Copy 
Attributes from Company Workspace option to fetch all of the company-level user attribute 
values from the company (Company Workspace tab) and populate the user attributes values 
the General tab. 

1. Go to your Company Workspace tab in Admin mode. 

2. From the left-hand Navigator click the User Administration node to expand it. 
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3. Click the Company Users, or Partner Users, sub-node to open the log. 

4. Select a member from the log and click Open. 

5. In the Edit User window for the user that you selected (General tab) enter the user 
attributes.  

6. Click Apply to save your changes and then click OK to close the window. 

7. Go to your <shell> tab in Admin mode. 

8. From the left-hand Navigator click the User Administration node to expand it. 

9. Click the Users, or Groups, sub-node to open the log. 

10. Select the member from the log and click Open.  

11. In the Edit User window for the user that you selected (General tab) click Copy 
Attributes from Company Workspace. 

12. Follow the prompts so Unifier can fetch all of the company-level user attribute values from 
the company (Company Workspace tab) and populate the user attributes values the 
General tab. 

Note: If a user attribute value changes at the company-level, Unifier will 
not update the corresponding value at the shell-level.  

When finished, click Apply to save your changes and then click OK to close the window. 

Click Cancel to discard your changes and close the window. 

Assigning Application Access to Primavera Unifier (Cloud Only) 

To assign application access to Primavera Unifier: 

1) Log in to Primavera Administration and do the following: 

a. Add a user. 

b. Assign application access for that user to Primavera Unifier Production. 

Note: For details on using Primavera Administration, see the Primavera 
Administration Identity Management Guide. 

2) Log in to Primavera Unifier as a company administrator. 

3) Assign the users permissions that are specific to module access, functions, and tasks that 
they will use in Primavera Unifier. 

4) Repeat these steps for each user account that requires access to Primavera Unifier. 

Editing User Permissions at Company, Shell, and Project Levels 

The following user permission setting applies to editing a user permissions both at 
company-level, shell-level, and project-level:  

When a user has the Create permission, all of the fields on the User Properties window are 
editable. The Apply and OK options are displayed. 
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A user with Create permission at the company-level will be able to create users and modify all 
the properties of the users, including the status and permissions.  

When a user has Modify Status permission only, the Status option is enabled. The Apply and 
OK options are displayed and enabled. All of the other fields are not editable. A user who only 
has the Modify Status permission will be able to modify the status of users both from the User 
Properties window and the log. 

Note: The ability to update the status from the log is not available at the 
shell, or project, level.  

When a user has the Modify Properties permission only, the Status option is not enabled 
(disabled). In this case, the user needs the Modify Status permission in order to be able to edit 
the Status field. The Apply and OK options are displayed and enabled. All of the other fields are 
editable. 

A user who has the Modify Properties permission without the Modify Status permission can 
modify the properties of the user. A user who has the Modify Properties permission without the 
Modify Status permission cannot modify the status of the users. 

Importing User Attribute Form 

For company user administration, Unifier displays a default log, General tab (used when 
creating a user with the Company or Partner detail form), and User/Group picker, unless you 
design and import your own user administration attribute form. 

In uDesigner, you can add additional data elements to the User Attribute form, configure 
Company User and Partner User logs, add additional attributes to the View User Profile form, 
and a User/Group picker. The additional data elements appear as user properties on the 
General tab for Company and Partner users, as well as on the user View Profile form. For 
example, the additional user properties can include a user’s department and location, or other 
details. 

Refer to the user administration of the Unifier uDesigner User Guide for more details.  

Note: The new attribute will be available only for Company Users log 
and Partner Users log and will not be available as part of custom 
attributes in other module designs. 

All designs, including user attribute forms, are designed in uDesigner and deployed to Unifier. 
See Importing Configuration Packages (on page 640). 
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Adding and Managing Company Users 

Company Administrators can add new users to the sponsor company. Each new user creates a 
new user record. These are known as company users. Company users can be entered manually 
one at a time, or multiple user records can be imported into Unifier from a CSV file.  

Note: The Internationalization and CSV Files section contains 
information about translating CSV files. 

To ensure compliance with company standards and restrict access, Oracle recommends that the 
responsibility for user administration (at the company level) be delegated to one person, or a 
small group of people. 

Note: If you are using Oracle Identity Management (OIM) to add users to 
your company, some of the instructions that follow do not apply. OIM 
creates the user's login name, first and last names, and email account. 
OIM does not honor user attribute forms or user preference templates. 
Users manage their own passwords with OIM. OIM will honor the 
permissions and proxy users you specify in Unifier. You can use a CSV 
file to bulk update user information (see Managing Users in Bulk (on 
page 169)), except for passwords. The Template Name columns is 
mandatory field in order to update user information, successfully. 

To access the Company Users log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. To open an existing 
user record, select a user from the log and click Open. 

Note: If a User Attribute form has been imported, the columns that 
appear in the Users Log can vary. If designed in uDesigner, the log can 
include navigation in the left pane. This navigation allows you to filter the 
display of users listed in the log. If you decide that you want a standard 
log to display, you can remove the navigation from the log in uDesigner. 
Also, the search criteria in the Find window and sort order can also vary 
depending on what was added to the User log design in the User 
Attribute form. 

User Type 

As part of the log attributes in uDesigner, the column, "User Type" in the Company Workspace
log page (Company Users node Company Workspace > Admin mode > User Administration
> Company Users) identifies the type of user, available in Unifier, per following: 

 SYS User Type/Standard

The SYS User Type/Standard, which refers to both Company and Partner users, can have 
access to all Unifier modules, except the Earned Value Management. If the Earned Value 
Management component is checked for a Standard User, the Earned Value Management will 
be available to the Standard User.   
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Note: For information specific to the Earned Value Management module, 
refer to the Unifier Earned Value Management User Guide. 

 SYS User Type/Portal

 The SYS User Type/Portal, which refers to Portal users, can have access to self-service 
portal login, only. 

The Company Workspace log page (for Company Users node) has the following menu 
options:  

 File

 New

Manual

Import

 Open

 Export

All

Selection

Export Structure

 Send e-mail

 Status

Active

Inactive

On-Hold

 Edit

 Bulk Edit

 Delete

 Update User Type

To Portal

To Standard

 View

 All

 Find...

 Audit Log...

 Help

 Unifier Help

 Unifier Library

 User Productivity Kit

 About Unifier

The Company Workspace log page (for Company Users node) has the following toolbar
options: 

 New
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 Manual

 Import

 Open

 Find

 Send e-mail

 Status

 Active

 Inactive

 On-Hold

 Update User Type

 To Portal

 To Standard

The Update User Type (To Portal and To Standard) option, collectively, work as a bulk action 
on one or more selected user rows by enabling you to update the type of user. For example, you 
can select one row, or multiple rows, click Update User Type, and change the user type to 
portal, or standard, by clicking To Portal, or To Standard. 

If user assignment results in number of users exceeding the licenses allocated, Unifier displays 
a notification. 

If the user type attribute is not mentioned when creating the user, the user type for that user will 
be set to Standard user type by default.  

When you are creating a user, the User Type drop-down list is defaulted to Standard user, but 
you can change the User type to Portal. 

The Attribute "Earned Value Management" displayed is unchecked by default. If the user checks 
this option, then the user will be granted access to the Earned Value Management module. This 
checkbox will be disabled for Portal type of users.  

Note: The checkbox for Earned Value Management users will be seen 
only when the Earned Value Management module is loaded. 

In the License Manager, the Company user and Partner user are considered Standard users in 
terms of license count and combined count for License Terms and Current Usage. The License 
Manager landing page will define Gauge chart for all the following license types: 

 Standard Users 

 Portal Users 

 Earned Value Management Users 

A new count for Portal users and Earned Value Management (EVM) users are shown for 
License Terms and Current Usage. This count will depend on: 

 Whether a particular Company user is marked as Portal user, and 

 The Earned Value Management user in User Administration. 

The excess or surplus (overage) is calculated in the same way as the Standard users. 
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The Site Administrator can edit the license terms and view the audit log for the users by clicking 
the Settings icon. 

When editing the user count, the Site Administrator will have to put a combined number for 
active named users. 

The Site Administrator will also be able to edit the Portal users and EVM users count by using 
the following tabs on the License Terms window: 

 General tab 

 Notifications tab 

For users other than the Site Administrator, only the Notification tab will be available to be 
edited.  

Note: Unifier considers the existing Company users and all users added 
by way of import (File > New > Import) as Standard users. 

The User Type column will be seen by default in the standard user data picker. For the custom 
user data picker, if the user has added the column, then the user will be seen in User Type
column. 

In addition to the standard user (a user with access to all Unifier functionalities) and the portal 
user (a user with access to limited Unifier functionalities), Unifier supports the Contractor User.  

Notes: 

 The Contractor User is a Partner User. Any user can be declared as a 
Contract User, but a Contract User will have limited access to unifier 
functionalities. The Contractor User status must be granted to the 
external users such as vendors. 

 A Contractor User will also have access to Mailbox module and its 
sub-modules. 

License terms for a company (customer) can only be changed by the Site Administrator (for 
the cloud customers this will be the Oracle Cloud Administrator). As a result, in order to allow 
a Company Administrator to add a Contractor User, the Site Administrator must first add 
licenses for the Contractor User. See Contractor User (on page 140) for more details. 

Add a New Company User 

This section describes how to manually add a new user record to your company. For information 
about importing multiple user records from a CSV file, see the following section. 

If you have created a User Preference template (in Standards & Libraries > User Preference 
Templates), the active template will automatically be used to generate the new user’s user 
preferences. If there is no active template present, then the system default settings will be used 
for the user preferences. 

The following information is for adding users from Unifier. 
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Notes: 

 If you access Unifier through Oracle Identity Management (OIM), you 
cannot add a new user.  

 You can import a CSV file, but if the CSV file has a new user, the user 
will not be added.  

 Users manage their own passwords with OIM.  

 OIM does not honor user attribute forms and does not use user 
preference templates. Users will be able to edit the user attributes 
and the preferences in Unifier. 

 OIM has its own password policy which supersedes other policies. 

To add a new company user 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. 

3) Click New from the toolbar to open the Edit User window and complete the form. 

4) The Edit User window opens. 

5) Complete the fields of the General tab as discussed in the following table. 

6) Click the Security tab. You must also add a login user name before saving the record. See 
Manage user login information (Security tab) (on page 147) for details. 

7) At this point, you can activate the user, save the record, or complete the rest of the tabs: 

 Permissions: You can configure individual permission settings for the user in this tab. 
See Edit user permissions (Permissions tab) (on page 148) for details. Alternatively, 
you can assign the user to a group (the user will automatically inherit group permissions), 
or assign permission through Access Control. 

 Projects: This tab lists the projects to which the user has been added and is view-only. 
See View user’s project, program, and shell membership (Project/Program/Shell 
tabs) (on page 149). 

 Shells: This tab lists the shells to which the user has been added and is view-only. See 
View user’s project, program, and shell membership (Project/Program/Shell tabs)
(on page 149). 

 Programs: This tab lists the programs to which the user has been added and is 
view-only. See View user’s project, program, and shell membership 
(Project/Program/Shell tabs) (on page 149). 

 Proxy: You can add or view the user’s proxy users in this tab. See Designate a proxy 
user (Proxy tab) (on page 149). 

8) Click Apply to save changes, or OK to save and exit the window. 

In this field: Do this: 

First Name, 
Last Name 

Enter the first and last name of the user. These are required fields. 

Title Enter an optional company title for the user. 

Email Enter the user’s email address, which will be used to send system 
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In this field: Do this: 

notifications to the user, and will display in the user’s contact 
information. This is a required field. 

Work Phone Enter the user’s work telephone number. 

Mobile 
Phone 

Enter the user’s mobile telephone number. 

Home Phone Enter the user’s home telephone number. 

Pager Enter the user’s page number. 

Fax Enter the user’s fax number. 

Address 
Click the Select button to add a company address to the user profile 
(From Edit Company, Address Tab) 

Time Zone 
Choose the default time zone for the user. This can be changed in the 
User Preferences window. 

Language 

Select a language from the drop-down list. 

Note: The languages listed are the active languages selected in the 
Configuration - Internationalization log window, by the administrator.  

Date Format 
This setting controls the display of dates on reports, business process 
forms, etc. This can be changed in the User Preferences window. 

Status 

New users are Active by default. Status can be Active, Inactive or 
On-hold. Neither Inactive nor On-Hold users can sign in to Unifier: 

 Active: User is listed in Project or Shell Directory, in User/Group 
Picker, User can sign in and participate in project or shell. 

 Inactive: User’s name does not appear anywhere for selection on 
any project-or shell-related functions or User Picker. User cannot 
sign in but they can be given permissions and added to groups. 

 On-hold: User can be added to a project or shell and assigned as a 
participant in a business process workflow but cannot sign in. 
Normally used to pre-assign users to a new project or shell before 
activating it. 

Active and On Hold users will be counted against your user license 
terms; Inactive users will not. 

Contractor User 

The Company Administration can: 

 Create a user of the type "contractor" in in the Partner Users sub-module, only (Company 
Workspace tab > Admin mode > User Administration module). 

 Bulk update the user type to "Contractor." 
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Note: All license constraints will be in place. 



Impact on the Audit Log

Changes made to the Contractor User license terms will also get captured in the Audit Log tab.  

A Contractor User license type can only be added as a Partner User (Company Workspace > 
User Administration node), manually. 

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) From the left Navigator click User Administration node to expand. 

3) Click Partner Users sub-node to open the log. 

4) Click to select the company you want to add the Contractor User to and open it. The Edit 
User window opens. 

5) In the Edit User window, General tab, enter the user information, click the User Type
drop-down, and select Contractor. 

The Update User Type toolbar option enables you to use the sub-menu option of "To 
Contractor". The same option will be available in Edit in the Menu. 

The following table outlines the behavior of various options: 

Selection Update 
License 
Type 

Usage 

When one or more users are 
selected 

Update to 
Standard 

For all the selected users the user type will 
be updated to Standard 

When one or more users are 
selected 

Update to 
Contractor

For selected users, the user type if not 
Contractor will be changed to Contractor 

When one or more Standard 
partner users are selected 

Update to 
Portal 

For the selected Standard Partner users, the 
user type will be changed from Standard to 
Portal 
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When one or more Standard 
partner users are selected 

Update to 
Contractor

For the selected Standard Partner users, the 
user type will be changed from Standard to 
Contractor 

When one or more portal 
users are selected 

Update to 
Portal 

For selected users, the user type if not 
Portal will be changed to Portal 

When a mix of Standard, 
Portal & Contractor users 
are selected 

Update to 
Contractor

For selected users, the type if not Contractor 
will be changed to the Contractor 

When a mix of Standard and 
portal users are selected 

Update to 
Portal 

For selected users, the type if not Portal will 
be changed to Portal 

You can add Contractor User of the new license type in User Administration for Partner Users 
through CSV. If the license count is exceeded, then Unifier displays the message: License limits 
for Standard/Portal/Contractor Active Named Users and Overage have been reached. {total 
number of users} user(s) cannot be added/updated. Contact your Site Administrator. 

For the IDCS or Cloud Admin tool, to create a Contractor User a new attribute for the user type 
must be created, when creating a user.  

Navigational nodes seen (Home): 

 Home 

 Tasks

 E-Signatures

 Notifications

 Inbox

 Drafts

 Sent items

Note: The Master log is not displayed. 

The Standard Projects would still be accessible to contract type user. 

Navigational nodes seen (Shell): 

 Tasks

 E-Signatures

 Drafts

 Mailbox

 Drafts

 Inbox

 Notifications

 Sent Items

 Delete Items

 Document Manager, with all the sub-nodes (based on logged-in user permissions). 

 Logs, with all of the business processes (that the logged-in user has navigational-level 
access to). 
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Since Project Mailbox is not available to the Contract type user, the same option would not be 
available under "Linked Mail" of a BP, for the contract user. If there are any existing emails from 
the Project Mailbox in the linked mail of the particular BP, the emails would still be visible 
accessible. 

The Contract type user will not access to any non-BP type object, in the left Navigation. If there 
are references on the BP forms, the Contract user will be able to access them. Also, any records 
that can be opened by way of a hyperlink in a non-BP type pickers will be accessible to user.  

Note: A user who does not have permissions for any shells can today 
click on any shell picker on the BP forms and add reference a shell in a 
BP, and Unifier does not restrict this based on the permissions. The 
same rule applies to a Contract user. 

Here is a list of some of the pickers that are non-BP type: 

 Space Manager 

 Planning Items 

 Code or Record Based Managers 

 Shell Manager 

A Contract type user cannot act as a proxy user for any of the existing users in Unifier and the 
Proxy login option will not be available for a Contract type user. There is no restriction for the 
Company Administrator to assign a Contract user as proxy for another Contract user. 

A Contract user can have other users (Standard user or Portal user) who can act as proxies. A 
Contract user can view this list in the "My Proxy" tab. In the Preferences window (Company 
Workspace > Admin mode > User Administration > Company Users), the I am Proxy tab is 
hidden from the Contract type user. All other sub-options seen in the Preferences window will 
be the same as other Standard users, including the Email Subscription options. 

Note: Unifier does not prevent the Company Administrator from setting Contractor user types as 
Proxy users; however, at runtime these type of users will not see the option to proxy on behalf of 
someone else. 

The User Type "Contract user" is not available the Bulk Edit log, and the  license count will not 
be checked when updates are made through bulk edit. 

A Contract user has access to the following options in the top pane: 

 Announcements

 Bookmarks

 Help

 Recent Locations

 Key Locations

Import company users (add users or update users) 

If you have a large number of users to add or update, you may want to import the records, so 
you do not have to manually open and update each user record. You can import multiple users 
with a CSV file by doing the following: 
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 Export a copy of the CSV file structure. 

 Populate the CSV file with user information. 

 Import the CSV file into Unifier. 

Note: If you are using Oracle Identity Management (OIM) to add users to 
your company, you cannot import users via CSV file. You can, however, 
update user information via CSV, except for the user's password. 

Once the OIM is enabled, the following features will be disabled in Unifier: 

 Manual User Creation 

 CSV Import User 

Note: The CSV Import User feature continues to support the User 
Update function but not the Create User function. 

 Editing the username and password in the user admin 

 Web Sevice (Create User) 

To export a copy of the CSV file structure 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. 

3) Click the File menu and choose Export > Export Structure. A confirmation window opens. 
Do one of the following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save. 

To export existing users for update 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. 

3) Choose File > Export > All, or select users in the log and choose File > Export > 
Selection. A confirmation window opens. Do one of the following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save. 

To populate the CSV file with user information 

1) Open Microsoft® Excel (or other program compatible with CSV format), and open the CSV 
file you just saved. 

2) Enter or modify user information in the spreadsheet. The fields are discussed in the following 
table. Ensure that you review the notes after the table. 

3) Save in CSV format. 
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In this column: Do this: 

First Name* Enter user’s first name. 

Last Name* Enter user’s last name. 

Title Enter user’s company title 

Email* Enter user’s email address 

Work Phone Enter user’s work phone number 

Mobile Phone Enter user’s cell phone number 

Home Phone Enter user’s home phone number 

Pager Enter user’s pager number 

Fax Enter user’s fax number 

Login Username* 
Enter a unique username that the user will use to log 
into Primavera Unifier 

Password 
Enter a password that will allow the user to log in for 
the first time. The user can change the password 
after signing in to Unifier. 

Time Zone* 

Enter the code for the Time Zone (refer to the Unifier 
Reference Guide for the list of codes). This is a 
required field, even if you are entering a User 
Preferences Template Name (if the time zone 
specified in the template is different from this cell, 
the template selection will take precedence). 

Date Format* 

Enter the code for the Date Format (refer to the 
Unifier Reference Guide for the list of codes). This is 
a required field, even if you are entering a User 
Preferences Template Name (if the date format 
specified in the template is different from this cell, 
the template selection will take precedence). 

Address 
Enter the code for the company address to use with 
this user. (Refer to the Unifier Reference Guide for 
the list of codes) 

Template Name 
If you have created User Preferences Templates, 
enter the name of the template to use for this user. 

Status* 
Enter a status code for this user: Active=1, 
On-Hold=2, Inactive=0 

* = mandatory column 

Note the following: 

 Do not delete or change the order of the columns; this will make the file invalid. 
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 Valid information must be entered into columns corresponding to required fields. An asterisk 
in the column header indicates required fields. (Expand the columns to see the asterisks if 
necessary.) 

 For non-text-entry fields (Time Zone, Date Format, Address), enter the corresponding code. 
Valid codes are found in the Unifier Reference Guide. 

 Non-required fields (column heading does not have an asterisk) are optional. You may enter 
information or leave these fields blank. 

 The length of "Username" cannot exceed 64 characters and cannot include the following:  

 Space  

 Non-printable characters 

To import the CSV file into Unifier 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Users in the left Navigator. 

3) Choose New > Import to import the completed CSV file. 

4) Click Browse and navigate to where you saved the file. 

5) Click OK to import. New users are created and existing users are updated. 

6) Open the User record and setup the Groups, Permissions, Projects/Shells, Programs, and 
Proxy tabs as needed. 

If any rows contain errors, no rows are imported. Error messages are listed in the CSV file. 

To fix import errors 

If you receive the Confirmation message: 

Import could not be completed. Do you want to download a file with errors 
shown?

1) Click Yes to open the CSV file. 

2) Fix the rows that contain errors. 

3) Re-import the file. 

Export user records 

You can export a CSV file with current user information. 

To export a CSV file containing all user records 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. 

3) Click the File menu and choose Export > All. A confirmation window opens. Do one of the 
following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save. 
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To export a CSV file containing selected user records 

1) In the Company Users log, select one or more users to export (press the Ctrl or Shift keys to 
select multiple users). 

2) Click the File menu and choose Export > Selection. A confirmation window opens. Do one 
of the following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save. 

Manage user login information (Security tab) 

Before you activate a new user, you must enter a Login Username. To allow the user to sign in 
to the system, you must also add an initial password. You can also change the user’s password 
here, for example if the user has forgotten their password. 

Users can change their password later in the User Preferences window. 

Note: If you are using Oracle Identity Management (OIM) to add users to 
your company, the instructions that follow do not apply. OIM creates the 
user's login name, first and last names, and email account. Users 
manage their own passwords with OIM. OIM does not honor user 
attribute forms. 

To add or manage user login information 

1) In the User Administration log, select a user and click Open. The Edit User window opens. 

2) Click the Security tab. 

3) Complete the fields as shown in the following table. 

4) Click Apply to save changes, or OK to save and exit. 

In this field: Do this: 

Login Username 
Enter the Users Sign In ID (required). This value can 
be changed by the System or Company 
Administrator but not by the User. 

Password 
Enter the value the user will use as their Sign In ID. 
Passwords must match the company 
Security/Password policy, if one is in force. 

Confirm Password Confirm password by re-entering. 

View Password Policy 

Click this link to verify the password is conforming to 
your company’s Security/Password policy (Edit 
Company window, Security tab). A password that 
does not comply will generate a warning message. 

Note: If you are using OIM to 
provision your company 
users, the password policy 
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specified here will be 
superseded by the password 
policy in OIM. 

Note: The Security tab is not available if Unifier is integrated with SSO 
(LDAP, OAM). 

Manage a user’s group membership (Groups tab) 

You can manage a user’s group membership from the Groups tab of the Edit User window. This 
tab displays all the groups the user is a member of, and allows you to quickly add or remove 
groups. The default groups are Company Administrators, Project Administrators, Shell 
Administrators, and Support. For information about adding or managing groups, see Adding 
and Managing Groups (on page 163). 

Note: If you are using OIM to add users to your company, you will still 
have to use these instructions to add users to groups.  

To add a user to a group 

1) In the User Administration log, select a user and click Open. The Edit User window opens. 

2) Select the Groups tab. 

3) Click Add. The User/Group Picker opens. 

4) Select the Group and click Add. The group will appear in the Selected Groups window. Click 
OK to save. 

To remove a user from a group 

On the Groups tab, select a group and click Remove. 

Edit user permissions (Permissions tab) 

This procedure allows you to grant or remove specific user permissions. This is useful if a user 
needs special permissions that are not likely to be repeated with other users, or is not part of a 
group. You can also specify permissions for groups (if you add the user to the group, the user 
will automatically inherit all group permissions, or control permissions through Access Control. 

To edit a user’s permission settings 

1) In the User Administration log, select a user and click Open. The Edit User window opens. 

2) Select the Permissions tab. 

3) Click a plus sign to expand the choices. Scroll up or down as needed. 

4) Select the Permission module in which to grant permissions. Choose the Permission level in 
the bottom window. Permissions are described in the Unifier Reference Guide. 

5) Click OK to save. 
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To copy permissions from a template 

1) In the Permissions tab, click the Copy Permissions button. 

2) Select the template and click OK. All permissions settings in the user record will be 
overwritten and replaced with the permission settings from the template. 

View user’s project, program, and shell membership (Project/Program/Shell tabs) 

Users can be added to projects, programs, and shells giving them access to participate in them. 
You can view a user’s project membership in the Projects/Shells tab, and program membership 
in the Program tab. 

To view a user’s project membership 

1) In the User Administration log, select a user and click Open. The Edit User window opens. 

2) Select the Projects tab. This tab displays the list of programs of which the user is a member. 
Users cannot be added or removed from Programs here. 

To view a user’s program membership 

1) In the User Administration log, select a user and click Open. The Edit User window opens. 

2) Select the Programs tab. This tab displays the list of programs of which the user is a 
member. Users cannot be added or removed from Programs here. 

Designate a proxy user (Proxy tab) 

A Site/Company Administrator can designate a user to be a proxy user for another user.  

 Proxy users can be granted permission to access another user’s account and perform 
various functions on that person’s behalf if that person is unavailable, such as on vacation. 

 Proxy users who are active (Status: Active) receive email notification of tasks to perform as 
proxy. This applies during the time specified time period, using the Start Date/Time and End 
Date/Time. 

 Proxy users have access to all of the records, settings and functions of the original user. A 
proxy user signed in to another’s account cannot change Preference settings. The Audit logs 
reflect the actions taken by a proxy user as "on behalf of" the original user. 

Note: If the specified proxy user has Send notifications in a single daily 
digest selected on the Options tab of their User Preferences, it will 
impact when they receive notification of the task they must perform as 
proxy. Ensure that the Send notifications in a single daily digest 
checkbox is deselected for the proxy user if that user must receive the 
task notifications immediately. 

To designate a proxy user follow these steps: 

Note: The following applies to Company Users, Partner Users, and 
Groups. 

1) Launch Unifier > Company Workspace tab > Admin mode > User Administration > 
Company Users.
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2) Select a user from the Users log and click open to open the Edit User window 

3) Click Proxy tab. 

4) Set the options per following descriptions. 

Do not allow Proxies 

The Site/Company Administrators, Company users, and Partner users) are permitted to select 
the Do not allow Proxies option. 

Note: This option is read-only in the user's User Preferences window. 

Users are able to add proxy users in their User Preferences window only if the Site/Company 
Administrator has not checked the Do not allow Proxies option in the Proxy tab of Edit User 
window. 

Users who can act as my Proxy 

This section of the Proxy tab lists the users who can act as proxy and allows you to add, adjust 
the settings, remove proxies, and view the proxy login history. 

Note: You can select/designate more than one proxy user. 

Add

The Company Administrator can assign other users to act as proxies to your account. if you are 
unable to do so. 

To add a proxy: 

1) Click Add to open the Proxy User Settings window. 

2) Click Select to open the Users/Group Picker window. 

3) Select users, click Add, and then click OK to go back to the Proxy User Settings window. 

4) Enter the Start Date/Time and End Date/Time values. 

5) Select the Status (Active) and click OK. 

Settings

Use this option to select an existing proxy and change the user settings of the proxy, such as 
start and end date/time. To change the user settings of the proxy, click Settings and follow the 
prompts. 

The system sets the values in the time-related fields base on the user's preferred data and time 
formats. 

Note: If you do not specify a start or end date, the proxy user can access 
your account immediately and their access privileges will not expire. 

You can select Active to activate proxy's access. To disable proxy's access, select Inactive. 

Remove

You can use this option to remove a selected proxy. To remove a user as a proxy, click to select 
the proxy from the list and click Remove. 
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Proxy Login History

Use this option to view the following information about the proxies: 

 Name 

 Login Date 

 Logout Date 

The last login information appears on top. 

Note: The Sign Out link at the upper right portion of the Unifier window 
allows a proxy's session to end. 

Send email to a company user 

This is available for company users only, and is not available for partner company users. 

To send an email to a company user 

1) Navigate to the Company Users log. 

2) Select one or more names in the log, then click Send email on the button bar. Your email 
client window opens, where you can then send an email to the user(s) you selected. 

Unlock a locked user account 

A user account can be locked if the user exceeds the maximum logon attempts, or if the user 
has not signed in after a specified number of days. These password criteria are configured on 
the Security tab of the Edit Company window. 

Users who are locked out of Unifier will receive a message stating the condition that needs to be 
corrected. 

Note: If you are using Oracle Identity Management (OIM) to provision 
the users in your company, you must use OIM to unlock a user account. 
For information, see the documentation that accompanies the OIM 
product. 

To unlock a locked user account 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users or User Administration > Partner Users in 
the left Navigator. 

3) Select the user from the log. 

4) Click Open, and click the Security tab. When a user’s account is locked, the Unlock account 
checkbox appears selected. This checkbox is provided only if the user’s account is locked. 
Otherwise, it does not appear on the user’s Security tab. 

5) Deselect the Unlock account checkbox. 

6) Click Apply to save or OK to save and exit. 
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Change the status of multiple company users 

If you want to change the status of multiple users at the same time you can select the users from 
the log and change the status for all of those users. This eliminates the need for you to open 
each user record to modify the user status. 

The License Manager controls the number of active users within a system. If the new users will 
exceed your license terms, you will receive an error message. 

To change the status of multiple company users 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users in the left Navigator. 

3) Select the users whose status you want to change. 

4) Choose Status and one of the available statuses (Active, Inactive, On-Hold). 

View or print user audit log 

To view the Audit Log for a user record: 

1) Select a user from the Users log. 

2) Click the View menu and choose Audit Log. The Audit Log window opens, listing each 
event associated with the user. 

3) From the Audit Log window, you can double-click a listed event to view the audit record 
detail, which details the action taken. The details also include for reference the current time 
zone of the user viewing the audit log. 

To print the audit log: 

1) From the Audit Log window, click the Print button. A PDF file of the audit log is created. 

2) Do one of the following: 

 Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can 
view, save, or print the file. 

 Click Save. In the Save As window, navigate to the location in which you want to save 
the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print. 

Reactivating Users 

When a Partner Company participates in a project or shell, the Partner Company becomes a 
Member Company in that project or shell, and the Partner Company users that are added to the 
project or shell become the Member Company users.  

Note: Project and shell access is limited to Unifier users (including 
Sponsor Company users or Member Company users) who are chosen 
for the project or shell and permissions are configurable for each 
company. 

For more details about company types, see Companies in Unifier. 
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Note: These processes apply to the proxy users. 

Go to the Company Workspace tab (Admin mode). From the left Navigator, click User 
Administration > Partner Users, and open a user to open the Edit User window. In this 
window: 

 If you (the administrator) deactivate a Partner Company user from a project or shell that the 
Partner company was associated with and later decide to reactivate the Partner Company 
user for that project or shell, the status of that Partner Company user changes to what it was 
prior to the deactivation of that Partner Company user. 

 If you (the administrator) remove a Partner Company from a project or shell and later 
decided to re-add the Partner Company to that project or shell, the status of the Partner 
Company users changes to what it was prior to the removal of the Partner Company. In this 
scenario, the administrator has to manually activate the Partner Company user at the 
company level (global), and Unifier automatically changes the status of the Partner Company 
user to what it was prior to the removal, or deactivation. 

Important Information about Reactivating Users

When you deactivate the Partner Company users who are active in a project or shell and later 
activate the same users, Unifier reverts the status of the users to "Active" or whatever the user's 
status was prior to the deactivation. 

When you deactivate a Partner Company, in Company Workspace, Unifier removes the Partner 
Company that exists as a Member Company (in a project or shell). If you deactivate a Member 
Company from the list of Partner Company, in the Company Workspace, Unifier removes the 
Member Company from all associated projects or shells and sets all Member Company users as 
"Inactive." When you reactivate the Member Company, at the company level, unifier adds the 
Member Company to all previously associated projects and shells. 

If a Partner Company is a member of a project or shell, but the Partner Company users are all 
set as "Inactive" in that project or shell, when you (the administrator) decide to reactivate the 
Partner Company users at the company level, the status of the Partner Company users at the 
shell level will remain as "Inactive." 

When there are limited licenses available in the system, you need to deactivate the Member 
Company users at company-level. In this case, the Partner Company users are deactivated 
automatically. 

You can reactivate a deactivated Member Company at company-level (Company Workspace 
tab). 

Exceeding License Limit

Example 

If you have three licenses, but you have added or activated five users, then Unifier assigns 
the three licenses that you had to the first three users (most recent users) that you added or 
activated. 
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Creating Partner Companies, Users, and Permission Settings (On-Premises Only) 

Creating Partner Companies 

A Company Administrator of an Owner Company (Sponsor Company) can create multiple 
partner companies. 

To create multiple partner companies go to Company Workspace tab > Admin mode > 
Partner Companies > New. 

In the New Company window, enter information in fields of the following tabs: 

 General

 Address

 Security

 Contact

The Partner Companies log toolbar allows you to add (New), open (Open), and find (Find) 
partner companies. 

The Partner Companies log page allows you to see a list of partner companies (Company 
Name), the name of the contact for the partner company (Contact Name), phone (Phone), and 
the partner company standing such as active or inactive (Status). 

The Partner Users node has the following menu options:  

 File

 New

 Open

 Send e-mail

 Status

Active

Inactive

On-Hold

 Edit

 Bulk Edit

 Delete

 Update User Type

To Portal

To Standard

 View

 All

 Find...

 Audit Log...

 Help

 Unifier Help

 Unifier Library
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 User Productivity Kit

 About Unifier

The Company Workspace log page (for Partner Users node) has the following toolbar options: 

 New

 Open

 Find

 Status

 Active

 Inactive

 On-Hold

 Update User Type

 To Portal

 To Standard

The Update User Type (To Portal and To Standard) option, collectively, work as a bulk action 
on one or more selected user rows by enabling you to update the type of user. For example, you 
can select one row, or multiple rows, click Update User Type, and change the user type to 
portal, or standard, by clicking To Portal, or To Standard. 

Creating Users for the Partner Company 

To add users to a Partner Company go to Company Workspace tab > Admin mode > User 
Administration > Partner Users > New. 

When the Edit User window opens, you can see the following tabs. Enter data in the fields 
within each tab. 

 General

1. Enter the name of the Partner Company (the system conducts a search and displays a 
filtered list of partner companies) 

2. Alternatively, you (Company Administrator) can select the name of the Partner Company 
from the list by clicking the arrow. 

3. Fill out the fields under "Contact Information as in Company Directory."  

4. Select the Status, and click OK. 

 Security

To enter the password for the user. 

 Groups

To add the user to an existing group. 

 Permissions

To assign permissions to various modules in Unifier. 

 Projects/Shells

The content in this tab is blank when creating a user, and any existing content varies based 
on the Projects/Shells that the user has access to. 

 Programs
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The content in this tab is blank when creating a user, and any existing content varies based 
on the Programs that the user has access to. 

 Proxy

To manage Proxy settings. 

If user assignment results in number of users exceeding the licenses allocated, Unifier displays 
a notification. 

If the user type attribute is not mentioned when creating the user, the user type for that user will 
be set to Standard user type by default.  

When you are creating a user, the User Type drop-down list is defaulted to Standard user, but 
you can change the User type to Portal. 

The Attribute "Earned Value Management" displayed is unchecked by default. If the user checks 
this option, then the user will be granted access to the Earned Value Management module. This 
checkbox will be disabled for Portal type of users.  

Note: The checkbox for Earned Value Management users will be seen 
only when the Earned Value Management module is loaded. 

In the License Manager, the Company user and Partner user are considered Standard users in 
terms of license count and combined count for License Terms and Current Usage. The License 
Manager landing page will define Gauge chart for all the following license types: 

 Standard Users 

 Portal Users 

 Earned Value Management Users 

In addition, a new count for Portal users and Earned Value Management (EVM) users are 
shown for License Terms and Current Usage. This count will depend on: 

 Whether a particular Company user is marked as Portal user, and 

 The Earned Value Management user in User Administration. 

The excess or surplus (overage) is calculated in the same way as the Standard users. 

The Site Administrator can edit the license terms and view the audit log for the users by clicking 
the Settings icon. 

When editing the user count, the Site Administrator will have to put a combined number for 
active named users. 

The Site Administrator will also be able to edit the Portal users and EVM users count by using 
the following tabs on the License Terms window: 

 General tab 

 Notifications tab 

For users other than the Site Administrator, only the Notification tab will be available to be 
edited.  

Notes: 

 Any user who has not yet been added to the existing partner 
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companies will be added to the Partner Users log of the Owner 
Company as Inactive user. 

 Partner user creation through CSV is not supported. 

Permission Settings for Partner Companies 

To set permissions for partner companies go to Company Workspace tab > Admin mode > 
Access Control > Administration Mode Access > Partner Companies. 

In the Module Permission Settings window, determine the level of permission for each user (in 
the Partner Company) that is listed. You can click Add (to add a new name), Modify (to change 
the permission setting for a user, by way of Permission/Access Control window), or Remove
(to delete a name) in this window. 

If you (Company Administrator) create a Partner Company and select Inactive for the Partner 
Company Status, then the users that you add for that Partner Company will be inactive. When 
the contract with a Partner Company ends, you can select Inactive for the Partner Company 
Status and inactivate the contract. 

Creating Partner Companies and Users (Cloud Only) 

A partner company is a consultant, contractor, or vendor company that is associated with a 
owner company. A partner company may work on some or all of the projects or shells that the 
owner company commissions. 

Creating partner companies and users require you to use perform a series of tasks in both 
Primavera Unifier and Primavera Administration. 

For the prerequisites and tasks to create partner companies and users, see the Primavera 
Administration Identity Management Guide.

Adding and Managing Partner Company Users 

Adding a partner company user enables you to grant them access to your company Unifier 
features in the company workspace, programs, projects, or shells. You can manage their status, 
group membership, and permissions. users, can have access to self-service portal login, only. 

User Type 

As part of the log attributes in uDesigner, the column, "User Type" in the Company Workspace
log page (Partner Users node Company Workspace > Admin mode > User Administration > 
Partner Users) identifies the type of user, available in Unifier, per following: 

 SYS User Type/Standard

The SYS User Type/Standard, which refers to both Company and Partner users, can have 
access to all Unifier modules, except the Earned Value Management. If the Earned Value 
Management component is checked for a Standard User, the Earned Value Management will 
be available to the Standard User.   

 SYS User Type/Portal
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The SYS User Type/Portal, which refers to Portal 

Adding a Partner Company User 

Partner company user details are managed by the Site Administrator or the company 
administrator for the partner company. As the company administrator for the your company, you 
can add partner company users to your own company at the company, program, project, or shell 
level, and control their status and permissions within your company. 

Partner company users can be added to projects or shells, even if the users do not show up on 
this list. If a partner company user is added to a project or shell, the user will be added to the 
Partner Company Users log automatically. 

The License Manager (Company Workspace tab > Admin mode > Access Control > 
Administration Mode Access) controls the number of active partner company users within a 
system. If the new users will exceed your license terms, you will receive an error message. 

By default, new users will have a status of Active. You can change the status or other user 
detail information selecting the user from the list and clicking Open. 

To access the Partner Users log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Partner Users in the left Navigator. To open an existing user 
record, select a user from the log and click Open. 

Note: If a User Attribute form has been imported, the columns that 
appear in the Users Log can vary. If designed in uDesigner, the log can 
include navigation in the left pane. This navigation allows you to filter the 
display of users listed in the log. If you decide that you want a standard 
log to display, you can remove the navigation from the log in uDesigner. 
Also, the search criteria in the Find window and sort order can also vary 
depending on what was added to the User log design in the User 
Attribute form. 

To add a partner company user 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Partner Users in the left Navigator. 

3) Click New. The User/Group Picker opens. 

Note: If a User Administration design has been imported, the content of 
the User/Group Picker (in User view) can vary. The Find window and 
sort order can also vary depending on the optional design created in 
uDesigner. 

4) Click the List Names from drop-down list at the top of the picker window and choose the 
company from which to add the new project or shell user. 

This drop-down lists your sponsor company plus any Partner Companies. You can click the 
Partner Companies node under your company to view the list of available partner 
companies. 
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5) Select one or more users to add. You can press the Shift or Ctrl keys to select multiple 
users at once. 

6) Click the Add button. You can continue to select and add names to the Selected Users
portion of the picker window. 

7) Click OK to add the users to the Partner Users log. 

Managing Partner Company User: Status, Groups, and Permissions 

User details such as contact information are managed for individual users by the company 
administrator for the partner company. 

Note: Partner company users can be granted Company Administrator 
permissions if you add them to the Company Administrators group. See 
Manage a user’s group membership (Groups tab) (on page 148) for 
details on adding users to groups. 

You can manage the following information for partner company users: 

Status: You can change the partner company user to Active, Inactive, or On-Hold. 

 Active users are eligible to participate in company or project- or shell-level activities to 
which they have permissions. 

 On-Hold users appear on user pickers, and can be added to business process set ups, 
project or shell user lists. However, the user cannot log onto the system until they are 
activated. 

 Inactive users will not appear in user pickers. If you inactivate partner company users, 
they will automatically become inactive throughout the system, including in any projects 
or shells to which they belong. After inactivating, if you then change the status back 
Active, their status in projects or shells will not automatically change back to Active; you 
will need to reactivate them at the project or shell level. 

Groups: You can add a partner company user to a company or project- or shell-level group as 
needed. 

Permissions: You control permission access for partner company users within your company. 

To edit a partner company user’s details 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration>Partner Users in the left Navigator. The Users log opens. 

3) Select a partner company user and click Open. The Partner Company Edit User window 
opens. 

Note: If a User Administration design has been imported, the data 
elements that appear in the General tab of the User Properties can vary. 

4) Do any of the following: 

 To change the status of the partner company user, click the General tab and change the 
Status field. 
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 To manage a partner company user’s group membership, click the Groups tab. Click 
Add or Remove. 

 To manage a partner company user’s permissions, click the Permissions tab. Grant 
permissions to the user as needed. (In addition, when using Access Control, both partner 
company users and sponsor company users can be added to a module.) 

5) Click OK to save and exit. 

Changing the Status for Multiple Partner Users 

If you want to change the status of multiple users at the same time you can select the users from 
the log and change the status for all of those users. This eliminates the need for you to open 
each user record to modify the user status. 

Note: The License Manager controls the number of active users within 
a system. If the new users will exceed your license terms, you will 
receive an error message. 

To change the status of multiple partner users 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Partner Users in the left Navigator. 

3) Select the users whose status you want to change. 

4) Choose Status and one of the available statuses (Active, Inactive, On-Hold). 

Importing and Exporting Company and Partner Users 

Importing and Exporting for Company Users  

When the direction for the Data Element (DE) "uuu_user_company" is set to Input/Both, then 
the DE "Company" will be available in the CSV when the user performs Export Structure. 

When the direction for the DE "uuu_user_company" is set to Output , then the CSV retrieved 
through the Export Structure action will not have the DE "Company". In this scenario, the CSV 
can be used to create Company Users. 

If the DE "Company" is present in the CSV, then the user must include the Owner Company 
name to complete the CSV import. Unifier will not validate because the value in the DE 
"Company" is ignored. 

Importing and Exporting for Partner Users 

When the User Attribute Form is present, the following conditions apply:

The Partner Users log enables you to export and import, similar to Company Users log. 

Go to the Company Workspace tab (Admin mode). 

From the menu bar, click File. Click Export to see the following sub-options: 

 All

To export the list of partner users to a CSV file. 
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 Selection

To export a list of selected partner users to a CSV file. 

 Export Structure

To export the structure for partner users to a CSV file based on the DEs set in the 
Integration node of Partner Users. 

If the Direction is set to Output, in uDesigner, then: 

 The CSV file generated using All and Selection will export data, but it will not contain the 
company attribute in the CSV file. 

 The CSV file generated using Export Structure will not include company attribute. Such 
CSV file, when used to create user by way of the Import option, will return the error, 
"Company is required" indicating that a partner user cannot be created without a company 
attribute. 

Similarly, the Import option will be available as a sub-option of the New option in toolbar and 
menu options (File > New > Manual or Import > Manual or Import). The Import option, in this 
case, enables you to perform a bulk import by way of a CSV file. The functionality is similar to 
the Import option on the Company Users log. 

The user can import partner users through a CSV file only when the company attribute is 
present. In this scenario, the Direction (for Integration) must be set to Input or Both in 
uDesigner in order for the user to be able to create partner users by way of the Import option.  

Note: The company attribute is a mandatory field when creating Partner 
Users by way of the Import option. 

When the User Attribute Form is not present, the options to import or export will be available the 
same ways as when a User Attribute Form is present. 

If the User Attribute Form is not defined, and the user clicks Export Structure for Partner Users, 
then the DE "Company" is displayed by default in the exported CSV file. 

Reactivating Users 

When a Partner Company participates in a project or shell, the Partner Company becomes a 
Member Company in that project or shell, and the Partner Company users that are added to the 
project or shell become the Member Company users.  

Note: Project and shell access is limited to Unifier users (including 
Sponsor Company users or Member Company users) who are chosen 
for the project or shell and permissions are configurable for each 
company. 

For more details about company types, see Companies in Unifier. 
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Note: These processes apply to the proxy users. 

Go to the Company Workspace tab (Admin mode). From the left Navigator, click User 
Administration > Partner Users, and open a user to open the Edit User window. In this 
window: 

 If you (the administrator) deactivate a Partner Company user from a project or shell that the 
Partner company was associated with and later decide to reactivate the Partner Company 
user for that project or shell, the status of that Partner Company user changes to what it was 
prior to the deactivation of that Partner Company user. 

 If you (the administrator) remove a Partner Company from a project or shell and later 
decided to re-add the Partner Company to that project or shell, the status of the Partner 
Company users changes to what it was prior to the removal of the Partner Company. In this 
scenario, the administrator has to manually activate the Partner Company user at the 
company level (global), and Unifier automatically changes the status of the Partner Company 
user to what it was prior to the removal, or deactivation. 

Important Information about Reactivating Users

When you deactivate the Partner Company users who are active in a project or shell and later 
activate the same users, Unifier reverts the status of the users to "Active" or whatever the user's 
status was prior to the deactivation. 

When you deactivate a Partner Company, in Company Workspace, Unifier removes the Partner 
Company that exists as a Member Company (in a project or shell). If you deactivate a Member 
Company from the list of Partner Company, in the Company Workspace, Unifier removes the 
Member Company from all associated projects or shells and sets all Member Company users as 
"Inactive." When you reactivate the Member Company, at the company level, unifier adds the 
Member Company to all previously associated projects and shells. 

If a Partner Company is a member of a project or shell, but the Partner Company users are all 
set as "Inactive" in that project or shell, when you (the administrator) decide to reactivate the 
Partner Company users at the company level, the status of the Partner Company users at the 
shell level will remain as "Inactive." 

When there are limited licenses available in the system, you need to deactivate the Member 
Company users at company-level. In this case, the Partner Company users are deactivated 
automatically. 

You can reactivate a deactivated Member Company at company-level (Company Workspace 
tab). 

Exceeding License Limit

Example 

If you have three licenses, but you have added or activated five users, then Unifier assigns 
the three licenses that you had to the first three users (most recent users) that you added or 
activated. 
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Adding and Managing Groups 

Company-level user groups can be used to group users who will be using the same functionality 
in Primavera Unifier and assigned the same Permissions. Anytime a new person comes onto the 
project or shell you can assign them to the appropriate groups and their permissions will be set 
automatically. 

There are three default groups created for new companies: Company Administrators, Project 
Administrators, and Support. You can edit group information and permissions as necessary, and 
create new groups as needed. 

For example, you may want to create a "Finance Admin" group and give them permission to 
create and modify Cost Sheet Templates. Another "Finance User" group may have permission 
to access and work with project- and shell-level cost sheets, but not the templates. These users 
may require access to only those modules and reports dealing with finances, but not other areas 
of the company, project or shell. 

To access user groups 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Groups in the left Navigator. 

Create a new group 

The following discusses how to create a new group. 

To create a new group 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration>Groups in the left Navigator. The Groups log opens. 

3) Click the New button. The Groups window opens. 

4) Complete the General tab as outlined in the following table. 

5) At this point you can also complete the other two tabs: 

 Add user to the groups in the Members tab. 

 Add group permissions in the Permissions tab. 

6) Click OK to add the new Group. 

In this field: Do this: 

Group Name Enter a name for the group. 

Group Manager 
Click Select and select the person responsible for administering 
the group. This person automatically becomes a member of the 
Group. 

Group Description 
Enter a description, such as the group’s function or permission 
level. 
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Add users to a group (Members tab) 

This section discusses how to add and manage a group’s membership. You can add company 
users or partner company users to a group. You can also manage a user’s group membership in 
the Groups tab of the Edit User window of both company and partner users. 

To add a user to a group 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration>Groups in the left Navigator. The Groups log opens. 

3) Select a group and click Open. The Groups window opens. 

4) Click the Members tab, and click Add. The User/Group Picker opens. The User/Group 
Picker displays all Active or On-Hold users from the sponsor company and all Partner 
Companies. The company affiliation is noted in the Company column on the picker. 

Note: If a User Administration design has been imported, the content of 
the User/Group picker (in User view) can vary. The Find window and sort 
order can also vary depending on the optional design created in 
uDesigner. 

5) Select the user(s) to add to the group. (Press the Ctrl or Shift keys to select more than one 
user name.) 

6) Click Add. Users will appear in the Selected Users box. 

7) Click OK, then click OK to close the Groups window. 

To remove a user from a group 

From the Groups window, Members tab, select the user on the list and click Remove. 

Edit group permissions (Permissions tab) 

The permissions assigned here will be applied to all members of the group. Users within the 
group inherit permissions from the group. If a user is in more than one group, then the highest 
level of permissions granted in any group for a module will prevail. 

Note: Permissions are described in the Unifier Reference Guide. 

To assign permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration>Groups in the left Navigator. The Groups log opens. 

3) Select a group and click Open. The Groups window opens. 

4) Click the Permissions tab. 

5) You may click on the plus sign next to a module to expand the options. Scroll up or down, 
as needed. 

6) Select a module in the upper portion of the window. Choose the Permission level for that 
module in the lower portion. 

7) Click OK to save. 
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To copy permissions from a template 

1) In the Permissions tab, click the Copy Permissions button. 

2) Select the template and click OK. All permissions settings in the user record will be 
overwritten and replaced with the permission settings from the template. 

Integration Users 

Integration user is referred to a user who is performing integration, using the SOAP and REST 
services. This user will be a part of standard user licensing.  

You (Administrator) can use the Integration Users sub-node (under User Administration
node) to view the list of integrated user, create new integrated users, and assign or edit 
permissions for Document Manager and access protocol (Legacy). 

To access the Integration Users sub-node: 

1) Go to Company Workspace tab and switch to Admin mode. 

2) Click User Administration node to expand. 

3) Click Integration Users sub-node log. 

The Integration Users sub-node log contains the following elements: 

Toolbar options

 Create

 Refresh

 Print

 Find on Page

Columns

 First Name

 Last Name

 User Name

 Status

 Description

 Timezone

When you select a user, a right-hand pane displays the general details for the user that you 
selected. 

The following explains each element in details. 

Creating Integration Users 

To create a new integration user: 

1) Go to the Integration Users log. 

2) Click Create to open the Create User window. 

3) Fill out the form. 

4) Click Done. 
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The following explains each block and field in the Create User window: 

General block 

It provides general information about the integration user. The General block has the following 
fields: 

 First Name

 Last Name

 Status

 Active

 Inactive

 Email

 Language (system default language) 

 Description

 Time Zone (system default time zone) 

Security block 

It provides the ability to add "username" and "password" for a user. The Security block has the 
following fields: 

 Username

 Password

 Confirm Password

Permissions block 

It provides the ability to determine the permissions that the user has (for modules in Unifier). The 
Permissions block has the following fields: 

Document Manager

 Folder Services 

 Create: This permission will provide access to all the POST services for Folders. 

Create Folder by Path 

Create Folder by Parent Folder ID 

 Update: This permission will provide access to all the PUT services for Folders. 

Update Folders Metadata by Path 

Update Folder Metadata by Folder ID 

 Get: This permission will provide access to all the PUT services for Folders. 

Get Folders, or Documents, Metadata by Path. 

Get Folders, or Documents, Metadata by Parent Folder ID 

 Document Services 

 Create: This permission will provide access to all the POST services for Documents. 

Create Documents by Path 

Create Documents by Parent Folder ID 

 Update: This permission will provide access to all the PUT services for Documents. 

Update Documents Metadata by Path 
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Update Document Metadata by Document ID 

 Get: This permission will provide access to all the PUT services for Documents. 

Get Documents by Path 

Get Documents by Parent Folder ID 

Get Document by File ID 









Legacy block 

Legacy SOAP services 

 The Full Access permission will be supported for all the Legacy SOAP services. 

 The check-boxes will be checked by default when clicked on Full Access. 

Setting Permissions to Integration Users 

To set permissions to integration user: 

1) Go to the Integration Users log. 

2) Click Create to open the Create User window. 

3) Click Permissions to expand the form. 

4) Set the integration user permission for Document Manager. 

5) Set the integration user permission for Legacy accesses. 

6) Click Done. 

Printing and Exporting Integration Users 

To print a list of the integration users: 
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1) Go to the Integration Users log. 

2) Click the Print drop-down. 

3) Select Print and follow the prompts. 

To export the integration users to CSV: 

1) Go to the Integration Users log. 

2) Click the Print drop-down. 

3) Select Export to CSV and follow the prompts. 

To export the integration users to Excel: 

1) Go to the Integration Users log. 

2) Click the Print drop-down. 

3) Select Export to Excel and follow the prompts. 

Access Control for Integration Users 

To set permissions for Integration Users: 

1) Go to Company Workspace tab, Admin mode. 

2) Click Access Control node to open the Access Control log. 

3) Click Administration Mode Access to expand. 

4) Click User Administration to expand. 

5) Click Integration Users. 

You can assign the following permissions: 

Permissi
on 

Expected Behavior When Checked 

Create When you check this option, Unifier selects the following permissions: 

 Modify 

 View 

A user with the "Create" permission can add users, modify the user status, 
and view the user details. 

Modify When you check this option, Unifier selects the "View" permission. 

A user with the "Modify Status" permission can modify the user status and 
view the user details. 

View A user with the "View" permission can view the user details. 
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Managing Users in Bulk 

You can use bulk processing to manage users across a large number of projects or shells. Bulk 
processing means that you can perform the same action on a large number of user records 
without having to navigate to each record and perform the same action repeatedly. You can 
perform this bulk processing at the shell or project level. Bulk user management is performed 
using CSV file export and import. Importing user group assignments and importing users uses 
the existing Add Users permissions on a project or shell. 

Note: For cases where users have the same first and last name, the 
combination of first name, last name, company, and email address is 
used to uniquely identify a user. The email address is required on all 
imported rows. 

You can use bulk processing to: 

 Add or remove user group assignments 

 Add new users 

Note: If you are using Oracle Identity Management (OIM) to add users to 
your company, you cannot use CSV files to add users. OIM creates the 
user's login name, first and last names, and email account. Users 
manage their own passwords with OIM. OIM does not honor user 
attribute forms. For information, see the documentation that 
accompanies the OIM product. 

 Change the status of existing users 

 Update multiple users in the User logs for Company or Partner users 

Change user group assignments or add new users in bulk 

To add or remove user group assignments in bulk 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Projects > All or CompanySponsored 
Shells > shell log (for the shells that you have configured). 

3) Select projects or shells from the log. 

4) Choose File > Export > Export User Group Assignments > All Projects/Shells or File > 
Export > Export User Group Assignments > Selected Projects/Shells. This will export 
the current user group assignments for all or the selected projects or shells to a CSV file. 
The exported file contains all users and group assignments for the selected projects or 
shells. Empty project groups are exported as well. Users that are not assigned to groups are 
not exported. 

5) All columns are required, except the Action column. The Action column determines if a user 
is added to a group, removed from a group, or if no action occurs for a user’s group 
assignment. Enter Remove to remove a user from a group; enter Add to add a user to a 
group. Users are automatically added in the Active status. If you leave the Action column 
blank for a user, no action occurs for that user’s group assignment. 
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Note: The words Remove and Add must be initial capitalized. 

To change a group assignment for a user, remove the user from one group and then add 
them to another. 

6) You can also add new users at this point by adding new lines to the sheet and entering the 
data for the new users. On import, these new users are added to the project or shell with 
Active status. When you add new users, you must enter data into all columns except for 
Action, which is optional. New partner company users are added to Partner Company Users 
as well as to the project or shell. 

7) Save the CSV sheet when you are finished modifying the user group assignments or adding 
new users. 

8) Navigate back to the log and choose File > Import > Import User Group Assignments. 

9) Upload the modified CSV file and click OK. 

The import process will load all rows that have no errors. The import can issue exceptions if: 

 A user is not a valid user in Unifier 

 The user/company combination is not valid 

 The group is not valid in the project/shell 

 The Partner user license is exceeded 

 Action specified is invalid 

 Insufficient permissions exist to add users or add and remove group assignments 

Change user status in bulk 

To change user status in bulk: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Projects > All or CompanySponsored 
Shells > shell log (for the shells that you have configured). 

3) Select projects or shells from the log. 

4) Choose File > Export > Export Users. This will export the current users for the selected 
projects or shells to a CSV file. 

5) In the Status column of the CSV file, change the status of the user as needed. Valid status 
designations are: 

 Active 

 Inactive 

 On-Hold 

Also, you can add new users. Be sure to provide valid values in all columns. 

6) Save the CSV sheet when you are finished modifying the user statuses. 

7) Navigate back to the log and choose File > Import > Import Users. 

The import process will change the status of existing users and add new users as specified 
in the CSV sheet. Users can be added from companies listed under the Member Companies 
node at the project/shell level. 

The import process will load all rows that have no errors. The import can issue exceptions if: 
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 A user is not a valid user in Unifier 

 The user/company combination is not valid 

 The group is not valid in the project/shell 

 The Partner user license is exceeded 

 Insufficient permissions exist to change the user status or add a user 

8) Upload the modified CSV file and click OK. 

Update multiple company or partner users 

Bulk edit of Company or Partner users relies on fields defined in Integration and is available only 
if the User Attribute form has been imported. For Partner users, the only additional attributes that 
are available for bulk edit are those that were added by importing the User Attribute form. 

Note: Bulk update of status is available through the Status button in the 
Users log toolbar. 

To update multiple users in the Users log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration > Company Users or User Administration > Partner Users in 
the left Navigator. 

3) From the log, select users to modify. 

4) Choose Edit > Bulk Edit. 

5) Modify the Bulk Edit form as needed. 

6) Select the Update checkbox for the fields you want to update. The checkbox is automatically 
selected when you type into or modify a field. You can deselect it if you do not want to 
modify the field at this time. 

7) Click Update. This launches the bulk update of the selected records. 

The Bulk Actions Status window displays after you click Update. This window allows you to 
monitor the progress of the bulk update. Click OK after all records have processed. Click 
Cancel if you want to cancel the bulk update in progress. 

Creating and Managing User Preference Templates 

User Preference templates can be used to configure the default user preference settings for new 
users. It can also be used to update existing users’ user preferences by "pushing" the 
preference options. In this way, you can establish a standard for your users’ preference settings. 

Note: If you are using Oracle Identity Management (OIM) to enter users 
into your company, preference templates will be ignored. 

Create a User Preferences Template 

1) You can create any number of user preferences templates. 

To create a new User Preferences Template: 
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1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries and then User Preference Templates in the left Navigator. 
The Preference Templates log opens. 

3) Click New. The User Preferences Template window opens. 

4) On the General tab, enter a name for the template. Each template must have a unique 
name. Enter an optional description. 

5) For Status, choose Active or Inactive. You can create any number of templates, but only 
one can be active at a time. 

The Active template will be used as the default user preference settings when adding new 
company users. The other templates can be used to update ("push") preference settings to 
existing users. 

6) Click the Preference tab. The Preferences tab appears exactly like the Options tab of a 
user’s User Preference window. Complete the fields in the window as described earlier in the 
Preferences section of this guide. 

7) Click the Region Format tab. Select the following: Language, Time Zone, Date Format, and 
Number and Currency Formats. 

Note: The languages listed are the active languages selected in the 
Configuration - Internationalization log window, by the administrator.  

8) Click Apply to save changes, or OK to save and close the window. 

Update Users with the User Preferences Template 

You can create multiple user preference templates. The Active template will be used as the 
default template when creating new users. The other templates can be used to update ("push") 
preference settings to existing users. 

The Update Users process runs in the background. Depending on the number of records and 
projects or shells you are updating, it can take a considerable amount of time to complete. The 
process is complete when the End Date column in the Update History window shows the 
complete date. 

To apply the user preferences template to selected users 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards and Libraries > User Preference Templates in the left Navigator. The 
Preference Templates log opens. 

3) Select any template in the log. 

4) Click the Update Users button and choose Users. The User Picker opens. The picker lists 
Company Users. 

5) Select the users to update and click Add. Click OK to close the picker window. 

6) Select preferences to update. Only selected options are updated. Email subscription choices 
are not selectable; they are determined by the template. 

7) Click OK. 

8) Click Yes to confirm. The user preferences of the selected user(s) will be updated with the 
template settings. 
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To apply the user preferences template to all users 

1) In the Preference Templates log, select a template. 

2) Click the Update Users button and choose All Users. This includes Company Users. 

Users are identified by their unique User ID. 

3) Select preferences to update. Only selected options are updated. Email subscription choices 
are not selectable; they are determined by the template. 

4) Click OK. 

5) Click Yes to confirm. 

View update users history 

You can view details about previous Update User runs. 

To view Update Users History 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards and Libraries>User Preference Templates in the left Navigator. The 
Preference Templates log opens. 

3) Click the Update Users button and choose History. The Update Users: History window 
opens. It lists the following: 

 Requestor: User who initiated the update process 

 Users: Either user selected or all users 

 Submit date: When the update request was submitted 

 Start date: When the update process started 

 End date: When the update process ended 

 Status: Status of the request 

4) Select an instance from the list and click Open (or double-click to open). The History Details 
window opens, displaying which users were updated by the request. 

Cancel a user update request 

You can cancel an update request that has not yet started, that is, the status is not In Process
or Finished. 

To cancel a user update request 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards and Libraries > User Preference Templates in the left Navigator. The 
Preference Templates log opens. 

3) Click the Update Projects or Update Shells button and choose History. The Update 
Projects or Shells: History window opens. 

4) Select an update that has not yet started. 

5) Click Cancel Request. 



Unifier Modules Setup Administration Guide

174

Creating an Approved Email List for Project/Shell Mailboxes 

Emails are important tools for communication and they need to be included in Project/Shell. 
Emails can come from: 

 Project/Shell members who send emails from outside Unifier. 

 External users who do not use Unifier. 

The system collects emails, and their attachments, in a central repository, called a Mailbox.. 
This repository enables users to use emails in managing and documenting a Project/Shell. 

Note: Emails can also be linked to business process records. 

Once an email resides in the Project/Shell Mailbox, a user can forward the email to appropriate 
members, flag the email for review, or reply to the email. 

When Unifier is installed on your system, a dedicated email address for your company is 
specified. When you create a Project/Shell, the system assigns a unique identifier to the 
Project/Shell. To create a dedicated mailbox as the communication repository for the 
Project/Shell, Unifier combines you company email address and the Project/Shell identifier. 

Since the system considers email addresses used by any company or partner user as 
"approved" and automatically adds the email addresses to the Approved Email List, to prevent 
spam and virus attacks from infiltrating your system, by way of external emails, you must create 
a list of approved email addresses that are be accepted by the Project/Shell Mailbox. 

Note: Unifier accepts up to 1,000 emails from any single address per 
day. Unifier ignores, as spam, any number of emails beyond 1,000. 

To prevent adding all possible email addresses that can send emails to the Project/Shell Mailbox 
in the Approved Email List, one by one, you (Unifier Administrator) can enter the Internet domain 
name for all of the users (Unifier users or external users) to the Approved Email List. See the 
following for details on both options. 

To create an approved email list (email address of an individual) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Approved Email List in the left Navigator. 

3) Click New to open the Add address or domain window. 

4) In the Email/Domain field, enter the email address of the individual, for example: 
someone@example.com

5) (Optional) In the First Name and Last Name fields, enter the name of the user. 

6) If you want to add another email address, click Apply; otherwise, click OK to close the 
window. 

To create an approved email list (Internet domain name) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Approved Email List in the left Navigator. 

3) Click New to open the Add address or domain window. 

4) In the Email/Domain field, enter the Internet domain name, for example: @example.com



Setting up the Users (User Administration)

175

Notes: 

 Domain names have to start with the "at" (@) symbol. 

 Names can include letters (abc), numbers (123), period (.), and 
dashes or hyphens (- - -). 

 Names cannot include any other special characters or space. 

 Names cannot begin with a dash or hyphen, and end with a dash or 
hyphen. 

 If the system detects a domain name, then the system disables the 
First Name and Last Name fields. 

5) Click Apply and then OK. 

Editing, Deleting, and Finding Email Addresses 

When Unifier is installed, a dedicated email address is specified for the company. When a 
Project/Shell is created, Unifier assigns a unique identifier to the Project/Shell. The system 
combines the dedicated email address and the Project/Shell identifier and creates the Project 
Mailbox. The Project/Shell email address appears on the Options tab of the Project/Shell details 
page.  

The Administrator can define the project email address in order to create a more meaningful 
name that is related to the project. 

The existing format for an email address in Prefix pattern is: <PID>-<Configurator 
email>@<Domain>. 

The existing format for an email address in Suffix pattern is: <Configurator 
email>@<Domain>+<PID>@<Domain>.

The string that you enter in the Email Address field is prefixed/suffixed to the project email 
address based on the Configurator settings. By default, the system generates the "<PID>" and 
places it as the first part of the project email address. 

You can change the project email address at any time; however, the system retains the emails 
belonging to a previous mailbox of the Project/Shell in the new mailbox. 

The following explains the rules for naming an email address: 

 Must be alpha numeric. 

 Can include non-ISO characters. 

 Cannot contain more than 170 characters. 

 Cannot include the at (@), plus (+), or dash (-), symbols. 

The following characters are not acceptable for the <PID>:  / \( ) ~ ! @ # $ % ^ & * { | , ; " < > ' } 
+ - : ? space characters = [ ]. 

Note: For an existing Project/Shell, the input box for Email address 
cannot contain zero (0) because internally the system uses zero (0), at 
the time of creating the Project/Shell, to populate the Project ID 
(<PID>_). As a result, zero (0) is not a valid input for the Email Address 
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field. 

To edit an email address 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Approved Email List in the left Navigator. 

3) In the log click to select the email address that you want to edit and double-click the email 
address to open. The Add/Edit Approved Emails opens. 

4) Edit the information and click OK. 

To delete an email address 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Approved Email List in the left Navigator. 

3) In the log click to select the email address you want to delete and click Delete. 

To find a specific email address 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Approved Email List in the left Navigator. 

3) In the log click Find to open the Find window. 

The Find window shows fields from the list, which you can use to narrow the list of items you 
see on the list. These fields show an operator, such as "contains" or "equals," which you can 
use to specify more precisely which items you want to search for. 

4) Click the operator beside the field and choose the operator you want to use on the field, such 
as "equals," "does not contain," or "is empty". 

5) Enter the value the field should contain. 

You can enter a partial name or address. 

6) Click Search (or press Enter). 

Unifier will display the address(es) or name(s) that match the criteria you entered. It will also 
identify the criteria by which you have searched the list in the "Current View: filtered by" 
line above the list. If you choose to, you can cancel the find action by clicking [Cancel 
Filter]. Unifier will restore the list to its unfiltered state. 

Importing and Exporting Email Addresses 

If the user and email address information is stored in another software application, such as 
Microsoft Excel, you can import the information from the software application into the Approved 
Email List. You can also export the information from the Approved Email List to another software 
application, if necessary. 

The Export option, on the toolbar, enables you to export: 

 All 

 Selected Rows 

 Structure 

Note: If you choose the Export > All option, you do not need to create a 
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template structure. 

The Import option, on the toolbar, enables you to open the File Upload window and select files. 

To import and export email addresses, you (Unifier Administrator) need to create a template 
structure, to use for both the import and export actions, first. 

To create a template structure 

1) On the Approved Email List log, click Export and select Structure. 

2) At the prompt, click Open. 

Unifier opens a CSV file (for example: unifier_approved_emails.csv) showing the 
user information in the columns for: 

 Email / Domain* 

 First Name 

 Last Name 

3) Save the CSV file. 

This CSV file becomes the template for importing and exporting Approved Email List data. 

In the CSV file, you can enter the email address information. If an email, or Internet domain 
name, is already in use and you try to add it again, then the system notifies you about the 
duplicate record. 

Notes: 

 Do not change column structure. Columns marked with asterisk (*) 
contain mandatory/required information. 

 Upon importing, if the email, or Internet domain name, is not present 
in the Approved Email List log, then the system creates a new 
record. 

 Upon importing, if the email is present in the Approved Email List log, 
then the system updates the First and Last Name information for that 
associated record  

 Upon importing, if the Internet domain name is present in the 
Approved Email List log, then the system ignores the First and Last 
Name information for that associated record. 

Example 

Email / Domain* First Name Last Name 

user1@example.com User1 Partner 

user2@oracle.com User2 Contractor 

To import approved email addresses 

1) On the Approved Email List log, click Import. The File Upload window opens. 

2) Use Browse to navigate to the CSV file you want to import. 

3) Click OK to upload the file into the Approved Email List. 
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To export all approved email addresses 

1) On the Approved Email List log, click Import and select All. 

2) Select the CSV file and click OK to begin export. 

Unifier exports all the email addresses on the approved list to the CSV file and open the file. 

You can edit the file and import it back into Unifier, or you can save the file for later updates. 

To export specific approved email addresses 

1) On the Approved Email List log, select the email addresses that you want to export. 

2) Click Export and select Selected Rows. 

Unifier exports all the email addresses that you selected to the CSV file and open the file. 

You can edit the file and import it back into Unifier, or you can save the file for later updates. 

Managing permissions and access control 

Permissions can be set at the company level, program level, or project and shell level. This 
section discusses managing company level permissions. 

Company level permissions can be set on company, program, shell, and project level functions. 
Changes to program and project or shell level permission settings made here will take affect for 
new programs and projects or shells to which users will be assigned. These settings can be 
overridden by adjusting specific permissions at the program or project or shell. 

About Permissions 

 Permissions are granted to users, or groups, to allow them access to Unifier features. 
Specific permission settings are described in the Unifier Reference Guide. 

 A user can be granted permissions individually, or can inherit them from the groups to which 
the user belongs. 

 If a user is in more than one group, then the highest level of permissions granted in any 
group for a module will prevail. 

 Users can be granted individual permissions in addition to group permissions. If user-level 
and group-level permissions are different for a module, the highest level will be granted to 
the user. 

 If you grant permissions to project or shell level User Mode features from the company-level 
Permissions tab, the new permission settings will take effect on future projects or shells the 
user is assigned to, but not on current projects or shells. To grant permissions to a user for a 
current project, be sure to change the permissions from the project or shell level user record. 

 Permissions in a project or shell template from which the project or shell is created override 
Company level permissions. 

Permission tab versus Access Control 

There are two ways to control permissions and access to Unifier features and records: Access 
Control and the Permissions tab. Both of these will allow you to manage permissions. See below 
to help you decide which to use. 
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Access Control 

Access Control displays the permissions granted to all users and groups per module. It allows 
you to quickly see which users and groups have access to each module and at what permission 
setting. 

You can add, remove or adjust permissions for multiple users or groups at once, rather than 
editing the properties for each user or group individually. For example, if you need to grant 
access permissions to a newly setup business process, or want to verify that all team members 
have access to a new feature, it may be easier to do this in Access Control rather than opening 
each individual group or user record. 

You can also generate and print an Access Information table summarizing permission settings. 

Permissions tab 

You can manage individual user or group permissions in the Permissions tab, which is part of 
the Properties window for the user or group record. Use the Permissions tab to quickly view or 
adjust permission settings for a particular user or group. 

The Permissions tab also enables access to permission templates. You can copy a permission 
template to quickly set up the permissions for a new user or group; you can also save an 
existing user or group’s permission settings as a new template for later use. 

See Edit user permissions (Permissions tab) (on page 148) or Edit group permissions 
(Permissions tab) (on page 164). 

Edit user or group permissions using Access Control 

To adjust permission settings using Access Control 

1) Do one of the following: 

 To open company level access control, go to the Company Workspace tab and switch 
to Admin mode. Click Access Control in the left Navigator. The Access Control window 
opens in the right pane of the Unifier window. The window displays a copy of the 
Navigator. 

 To open access control for a program, go to the Company Workspace tab and switch to 
Admin mode. Click Access Control in the left Navigator. The Access Control window 
opens in the right pane of the Unifier window. The window displays a copy of the 
Navigator. 

 To open access control for a project, open the project and click Access Control in the 
left Navigator. The Access Control window opens in the right pane of the Unifier window. 
The window displays a copy of the Navigator. 

 To open access control for a shell, open the shell and click Access Control in the left 
Navigator. The Access Control window opens in the right pane of the Unifier window. The 
window displays a copy of the Navigator. 

2) Select a module in the Access Control window. The Module Permission Settings window 
opens. It lists the user(s) and group(s) which currently have access to the selected module 
and their permission settings. 
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You can Add, Modify, or Remove users or groups, and grant permission levels. See the 
following procedures. 

To add user and group access to a module 

1) From the Module Permission Settings window, click Add. The Permission/Access Control 
window opens. 

2) Click Add Users/Groups. The User/Group Picker opens. 

3) Select users and/or groups from the list, click Add to add them to the Selected Users/Groups 
list, and click OK. 

4) In the Permission Settings window, select the level of permissions you want to assign to 
the Users/Groups. Click OK. 

To remove a user/group and their related module permissions 

In the Module Permission Settings window, select the checkbox next to the user or group and 
then click the Remove button. 

To modify permission settings 

In the Module Permission Settings window, select the checkbox next to the user or group and 
then click the Modify button. Make changes to permission settings as needed and click OK. 

Create or edit a permission template 

Permission templates are sets of permissions that can be applied to users or groups of users as 
a whole. This is often an easier alternative to setting individual access permissions, especially 
when setting up groups and working with large project or shell teams. You can apply the 
template to a user or group to set basic permissions, then modify the permissions for individuals 
or groups if needed. 

Note that any project or shell level permission granted at the company level and then applied to 
a specific user or group of users is inherited at project or shell creation time. The user 
permissions can then be modified at the project or shell level if further modifications are 
necessary. 

To create a new permission template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Permission Templates in the left Navigator. The Permission 
Templates log opens. 

3) Click the New button. The Edit Permission Template window opens. 

4) Add a name and description of the template in the General tab. 

5) Click the Permissions tab. This window is the same as the Permissions tab for an individual 
user or group record. 

6) Configure the permissions settings and click OK. 
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To edit a permission template 

1) Select the template from the Permission Template log and click the Open button. The Edit 
Permission Template window opens. 

2) You can edit the name or description in the General tab. 

3) Click the Permissions tab and adjust permission settings as needed. 

4) Click OK. 

To create a new permission template from existing permission settings 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click User Administration>Groups in the left Navigator. 

3) Select a group and click Open. 

4) Click the Permissions tab. 

5) Click the Save as Template button. Enter a template name and click OK. 

Generate and print an Access Information report 

You can generate and print an Access Information summary report of user and group permission 
settings. The report will display all user and group permissions. 

To generate the Access Information report 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) Click the Access Information button. The Access Information window opens. It may take 
several moments to generate the report. 

To print the Access Information report 

1) Generate the Access Information report. When the report is complete, the Print button 
becomes available on the toolbar. 
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2) Click the Print button. Select the printer and click OK. 

Announcements Node 

In addition to the Site (or System) Administrator, a Company Administrator will be able to create 
Announcements. Also, A Company Administrator will be able to define whether a particular 
announcement should be displayed to the:  

 Users. 

 Bidders. 

 Users and bidders. 

Note: Announcements are displayed to all the users of the owner 
company and all partner users. Bidders are also able to view all 
announcements by Owner Company, in the Bidder Portal. 

To access the Announcements module: 

1) Go to the Company Workspace tab. 
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2) Switch to the Admin mode. 

3) From the left-hand Navigator click the Announcements node to open both the 
Announcements log, and the Announcement properties page (the right-hand pane). 

The Announcements log (toolbar options) enables you to: 

 Create a new announcement (+ Create icon). 

 Delete or change the status of an existing announcement (Actions drop-down menu). 

 Refresh the log items (Refresh icon). 

 Print, or export, the contents of the log (Print icon). 

 Find items on the log (Find on Page icon). If the you decide to cancel the find for an entire 
row, then you must click the Find on Page icon, again. 

The Announcements log contains the following columns: 

 Title

 Status

 Last Modified By

 Last Modified Date 

When the log page is displayed, the default sort order is descending date of records (Last 
Modified Date). 

When you select an announcement record, or you hover over an announcement record, a gear 
menu will be displayed. The gear menu enables you to delete the selected announcement or 
change the announcement status. 

The Announcement properties page (the right-hand pane) also enables you to see, or change, 
the details of an existing announcement. You must click to select an announcement on the 
Announcements log, first. The Announcement properties page (the right-hand pane) also 
enables you to: 

 Enter a title for your new announcement (Title). You must click the create a new 
announcement (+ Create icon) option, first. 

 Enter the text for a new announcement (Announcement Text). Maximum of 4000 
characters, including formatting and HTML tags. 

 Assign a status for your new announcement (Status). Active announcements cannot be 
deleted. 

 Determine the audience (Make an Announcement for). The default is "Both" the Unifier 
Users and Bidders. 

Announcement Properties 

When you create a new announcement record which is unread, a red bubble count-indicator 
icon appears on top of the grey announcement icon (the megaphone icon). In the bubble icon, 
the number of unread announcements is displayed. 

When there are no unread announcements, the bubble count-indicator disappears. 

When you click the announcement icon (the megaphone icon), a grid appears that displays all of 
the unread announcements, highlighted in red. All the announcements are displayed in 
descending order, according to the date. 
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Once an announcement record has been read by a user, the title of the record is displayed in 
black. When you click the announcement hyperlink, the announcement grid appears. 

In the announcement grid, the active (Status = Active) announcement records are displayed, 
only. The Title, Last Modified By, and Last Modified Date (for both company and system 
announcements) fields are also displayed. 

For the system announcements created by the Site Administrator, the sign-in name of the Site 
Administrator is displayed in the Last Modified By field. 

For company announcements, the full name (First + Last Name) of the user who created (Last 
Modified By) the record, is displayed in the Last Modified By field. 

Access Control for the Announcements Node 

To assign access: 

1) Go to the Company Workspace tab. 

2) Switch to the Admin mode. 

3) From the left-hand Navigator click the Access Control node to open the Access Control
log. 

4) Click to expand the Administration Mode Access. 

5) Click the Announcements sub-node to open the Module Permission Settings window 
(Permission Settings for: Announcements). 

6) Click Add, click Add Users/Groups, click and select user, group, or both, and click Add. 

7) Assign permission: Create or View. 

Create: Users/Groups with Create announcements permission will be able to create, modify, 
and view all announcements. 

View: Users/Groups with View permission will be able to the existing announcements, 
without the ability to modify them. 

Site Administrator Announcements Log 

A Site Administrator can access announcements under Customer Support node: 

1) Sign in as Site Administrator. 

2) On the left-hand Navigator click to expand Customer Support node 

3) Click Announcements sub-node. 

A Site Administrator can create announcements in the same way that a Company Administrator 
creates announcements. 

Announcements created by a Site Administrator are displayed to all Unifier users. 

Note: The Make an Announcement for" option is not available for the 
Site Administrator. 

For a Site Administrator, the following columns are displayed in the Announcements log: 

 Title
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The title from the announcement displayed in the log. 

 Status

The current status of the announcement record is displayed in this column. 

 Last Modified Date

The date on which the announcement record was created or last modified. This an 
auto-populated field. The date is displayed in the format selected by the user, in the user 
Preferences window. When a field in an announcement record is modified, and the 
modification is saved, then the Last Modified Date is updated. 

Note: The Announcements log does not display the Last Modified By 
column for Site Administrator. 

Working with the License Manager 

The License Manager (Company Workspace tab > Admin mode > License Manager) 
controls the number of active users (Standard Users, Portal Users, and Earned Value 
Management Users) allowed in the system based on an agreed license terms.  

Note: The standard users refer to both Company and Partner users. 

The license terms (i.e., number of allowed users) used for License Manager are maintained by 
the Site Administrator, and cannot be edited by the Company Administrator. 

You can click the Settings icon to define the notification threshold for license terms and overage 
thresholds. 

The Earned Value Management block in License Manager is seen only when the module is 
loaded. When licenses are provided for the Earned Value Management module in Unifier, an 
additional Earned Value Management check box is available in the Edit User dialog for standard 
users. Select the check box to designate users as Earned Value Management module users, 
within license terms. 

Your Company Administrator can access the License Manager to: 

 View the current named users and user record limits. 

 View the usage charts. 

 Print usage reports. 

Your Company Administrator can set up the License Manager to: 

 Automatically notify the Company Administrator (or other designated user) when the number 
of users is approaching the limit. 

 Allow for an overage (i.e., a certain number of users that are over the limit, as determined by 
the terms of the license agreement). 

If the number of users exceeds the number of available licenses, then the system sends 
notifications to the following: 

 Users specified in the configurator (Unifier Configurator WebLogic). 

 Users who have Notify permission in the License Manager, which was set in Access 
Control. 



Unifier Modules Setup Administration Guide

186

The License Manager counts users with status of Active or On-Hold. The term "active named 
user" refers to any user in the system who has an Active or an On-hold status. 

A user with the Inactive status is not counted against the license terms, and you can add/import 
any number of Inactive users. 

View License Manager Terms and Usage 

The License Manager console provides easy access for viewing license terms and usage. 

To view the License Manager console 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click License Manager in the left Navigator. The License Manager console opens in the 
right pane.  

The License Manager displays the following blocks: 

 Standard Users: This block is always displayed and provide the total license count for 
Company and Partner users. 

 Portal Users: This block is displayed when the environment has license-count of portal 
users greater than zero. 

 Earned Value Management Users: This block is displayed when the module is loaded. 

Each block has the following information: 

 License Terms: Displays the number of Active Named Users — that is, any user with a 
specific user name and password — in the sponsor company and all partner companies. 
("Active" refers to users with a status of Active or On-Hold.) It also displays any Overage
limits, which allow companies to exceed their active named user limits by an agreed upon 
amount. 

 Current Usage: Displays the current number of Active Named Users (users with status 
Active or On Hold for your company and partner companies, and whether the Overage is 
being used. Usage refers to user records only, regardless of whether the users are 
currently signed in, or not. (Current Usage also displays the "as of" date and time of the 
last update.) 

To view the License Terms window 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click License Manager in the left Navigator. The License Manager console displays in the 
right pane. 

The Site Administrator will be able to edit the license terms and view the audit log for the 
users by clicking the Settings icon (gear menu). 

The Site Administrator when editing the user count will have to put a combined number for 
active named users. The Site Administrator will also be able to edit the Portal Users and 
Earned Value Management Users counts.  

 The General tab displays your company’s current license terms. This tab is read-only, 
and managed by the Site Administrator. 

 The Notifications tab allows you to schedule regular usage checks, and configure 
thresholds for notifying you when you are getting close to license term limits. 
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Note: If you exceed license limits while adding or importing users, then: 

 While adding company or partner company users, if license limits 
have been reached, a warning message will appear. You may 
receive this warning message if: 

 The license limit for active named users has been reached, but not 
the overage limits. Any new users will be counted against the 
overage limits. 

 The license limits for both active named users and overage have 
been reached. You will be able to add new user records, but will not 
be able to activate them without adjusting your current license limits, 
or deactivating other users. 

 If you are adding partner company users to the company workspace 
or a project or shell, you can add the users, but will not be able to 
activate them. 

 If you are importing users (via XML or CSV), and the license limits are 
reached, any user records that would exceed the limit will not be 
created, and you will receive an error message informing you of the 
number of user records that could not be created. 

 In addition, if your license limits have been reached, you will not be 
able to activate any currently inactive users. 

Set Up License Manager Scheduled Runs and Notifications 

You can set up the License Manager to notify you when the number of active users in your 
company or partner companies is approaching the established license limits. 

Note: Notifications will only be sent if a scheduled run is set up and 
enabled. Notifications will only be sent to users or groups who have 
been given explicit Modify or Notify Permissions. 

To set up notification and threshold limits 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click License Manager in the left Navigator. The License Manager console appears in the 
right pane. 

3) Click the Open button. The License Terms window opens. 

4) Click the Notifications tab. Complete the fields as described in the following table and click 
OK. 

In this field: Do this: 

Enable 
Notifications 

Select this checkbox to enable notifications regarding License Term 
thresholds. These email notifications will be sent to users or groups who 
explicitly have Modify or Notify permissions. Notifications are sent only 
after scheduled runs. 

Notification Enter the threshold values for active named users in your company and 
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Thresholds: 

Active 
Named 
Users 

partner company. For example, if you want to be notified when the 
number of active named users in the system reaches 80% of your 
license terms, then enter 80 in this field. 

Note: The threshold value calculates against the number of allowed 
active users in the license terms, and does not count overage amounts. 
Once the threshold limit has been reached, users will continue to receive 
notifications during every scheduled run. 

Scheduled 
Runs 
Frequency 

You must schedule usage runs in order to generate notifications. These 
runs check for currently active named users in your company and 
partner company. You will receive notification of these runs only if 
threshold values have been reached. Choose frequency: 

Weekly: select the day of the week. 

Monthly: select the day of the month. 

Print License Manager Information 

You can print a copy of the current license manager console view.  

To print license manager terms and usage 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click License Manager in the left Navigator. The License Manager displays in the right 
pane. 

3) Click the Print icon in the upper right corner. The information appears in a printable HTML 
format in a separate browser window. 

View or Print the License Manager Audit Log 

The audit log captures changes made to license terms. You can view the audit log, print a copy, 
or save a PDF copy of the audit log to your local drive. 

To view a license manager audit log 

1) From the License Manager log, click the View menu and choose Audit Log. The Audit Log 
window opens. 

2) From the Audit Log window, you can double-click a listed event to view the audit record 
detail, which includes for reference the current time zone of the user viewing the audit log. 

To print the audit log 

1) From the Audit Log window, click the Print button. A PDF file is created. 

2) Do one of the following: 

 Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can 
view, save, or print the file. 
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 Click Save. In the Save As window, navigate to the location in which you want to save 
the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print. 

Running System Usage Reports 

You can track current system usage using the predefined system usage reports. These reports 
provide an accurate and efficient way to track and manage licenses and system usage. Usage 
reports can be run based on company workspace or individual projects or shells, and can track 
both sponsor company users and partner company users. 

The available reports are: 

 Usage Detail By Company 

 Usage Summary By Company 

 Usage Detail By Project/Shell 

 Usage Summary By Project/Shell 

 Usage Detail By Company Workspace 

 Usage Summary By Company Workspace 

 Usage Detail By User 

 Usage Summary By User 

 User Account Details 

 User Account Summary 

 User Session Detail 

 Last Login 

 Current Login 

 Proxy Login 

The reports are described in the following sections. 

Run a System Usage Report 

The following is the general procedure for running a system usage report. The availability for the 
reports is based on permissions. 

To run a system usage report 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click System Reports in the left Navigator. 

3) Select a report from the log and click Open (or double-click the selected report). The query 
window for the report opens. The query window will differ depending on the report selected. 

4) Use the table below to complete the Query fields. You can leave the fields blank to return all 
records without filtering. 

5) Choose a report format. The User Account Details include Programs as a source, and allows 
you to choose a program name for the report. The options are: 
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 HTML: Displays the report in the standard format in a browser window. You may print a 
copy of the report from the browser window. (Click the File menu and select Print or Print 
Preview.) 

 CSV: Formats the report in an exportable CSV format, usually in Microsoft Excel, or other 
software application you have setup for this format. You will be prompted to save the file 
or open it. 

 Excel: The report displays in Microsoft Excel format in the browser window. You can 
save an Excel formatted copy of the report or print from the window. (Click the File menu 
and select Save As or Print.) 

 PDF: Opens Adobe Acrobat Reader and displays the report in PDF format. You can save 
a copy of the report and/or print it from the PDF window. (Click the File menu and select 
Save or Print.) 

 XML: Generates the output in XML format. Before the results are generated, a 
confirmation window will open, giving you the option to save the XML file to your local 
machine (click Save), or display the results in a popup browser window (click Open). 

6) Click Run to run the report. The report results are generated in the format you chose. 

For this query parameter: Do this: 

Owner Company (The field displays the owner company.) 

Source 

Select one of the following options to see where users’ 
time was spent: 

All: All areas of the system 

Company Workspace 

Project: If you select Project, the Project picker is 
activated. 

Shell: If you select Shell, the Shell picker is activated. 

Other: Other areas of the system that are not par t of a 
project or shell or the company workspace, such as the 
Asset Manager, Administration Mode, program 
features, user home page, etc. 

Project/Shell 

If you chose Project /Shell or All as the source, the 
Project /Shell picker is activated. Click Select to select 
a specific project. If you do not select a project or shell, 
the default is all projects or shells. 

Partner Company 
Click Select to select a specific partner, or leave blank 
to include all partner companies (in addition to the 
owner company results). 

Date Range From 
Click the calendar icon to enter a start date for the 
report. If you leave it blank, then the report will start at 
the company activation date. 

Date Range To 
Click the calendar icon to enter a start date for the 
report. If you leave it blank, then the report will include 
results up to the current date. 
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System Usage Report Types 

The following describes details for running the predefined system usage reports. 

Usage Detail By Company 

This report allows you to view usage times across a company and all of its partner users 
grouped by Company /Partner name. This report uses the login time to track usage, and shows 
usage per day (not per session). 

The report results are sorted as follows: 

 Company name in alphabetical order. 

 For each company, the list of user names: first name, last name 

 For each user, lists the source alphabetically 

 When source = Project, then project names are listed alphabetically 

Report Query Parameters: 

 Owner Company: Read-only 

 Source: All, Company Workspace, Project/ Shell or Other 

 Project/Shell: Select a Project/Shell or leave blank 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

Company 
Name 

The name of the company for which the report is being generated. 
Depending on filter condition, this report can be generated for a 
particular company or all. 

User Name 
The user names that are involved either in Projects or Shells or directly 
at Company Level. 

User ID 
The user ids that are involved either in Projects or Shells or directly at 
Company Level 

Source Company Workspace, Project, Shell, or Other 

Name 

The names of projects or shells that have users assigned to it either 
from Company or Partner levels. If user does not participate in any 
Projects or Shells the Project or Shell Name and number columns is 
empty. 

Number The number that corresponds to the Project or Shell Name 

Date Date when user signed in to Unifier 

Usage (Min) Time taken by User in minutes between sign in and sign out 
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This column: Shows: 

Usage (Hrs) Time taken by User in hours between sign in and sign out 

Total 
Total time taken by all users per company login level and per Company 
Partner level 

Grand Total 
Total time taken by all users at a company level as well as Company 
Partner level 

Usage Summary By Company 

This report allows you to view summarized usage times across the sponsor company and 
partner companies. These are usage times logged by users, once they sign in to Unifier, 
independent of whether they are working for their own company or other companies. The report 
results are sorted alphabetically by company name. 

Report Query Parameters: 

 Source: All, Company Workspace, Project/Shell or Other 

 Project: Select a project or leave blank for all projects 

 Shell: Select a shell or leave blank for all shells 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

Company Name 
The company name. Depending on filter condition, this 
report can be generated for a particular company or all 
companies. 

Usage (Min) 
Total Time taken by all Company Users in minutes at 
"Source" level between sign in and sign out in the 
specified date ranges 

Usage (Hrs) 
Total Time taken by all Company Users in hours at 
"Source" level between sign in and sign out in the 
specified date ranges 

Usage Detail By Project/Shell 

The Usage Detail By Project/Shell report shows usage details per project or shells across a 
company and its partners grouped by project or shell name. Results are sorted by: 

 Project/Shell names alphabetically for all projects belonging to user company 

 For each project or shell, lists users belonging to owner company first followed by partner 
company sorted alphabetically 

 Within a company, users are sorted alphabetically by first name, last name 

Report Query Parameters: 

 Source: defaults to Project/Shell 
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 Project/Shell: Select a Project/Shell or leave blank 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

Name 
The names of projects or shells that have users assigned to it either 
from Company or Partner levels. 

Number The corresponding Project or Shell Numbers. 

Company 
Name 

Name of the owner company. Depending on filter condition, this report 
can be generated for a particular Sponsoring company. 

If no users from current company are assigned to the Project, the row 
will start with Partner name. 

User Name The user names that are involved in Projects/Shells 

User ID The user ids that are involved either in Projects/Shells 

Date Date when user signed in to Unifier 

Usage (Min) 
Time taken by User in minutes between sign in and sign out working on 
that Project/Shell 

Usage (Hrs) 
Time taken by User in hours between sign in and sign out working on 
that Project/Shell 

Total 
Total time taken by sponsor company or partner company users for a 
given project or shell 

Grand Total 
Total time taken by sponsor company or partner company users across 
Projects/Shells. 

Usage Summary By Project/Shell 

This report displays summarized usage times per project or shell across a company and partner 
users grouped by project name. 

Report Query Parameters: 

 Source: defaults to Project/Shell 

 Project/Shell: Select a Project/Shell or leave blank 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

Name 
The names of projects or shells that have users assigned 
to it either from Company or Partner levels 

Number The corresponding Project/Shell Numbers 
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This column: Shows: 

Company Name 
Either the Sponsoring Company Name or Partner 
Company Name. Distribution across Owner Company 
and Partner users in a given Project 

Usage (Min) 
Total Time taken by all Users in minutes between sign in 
and sign out per Project/Shell 

Usage (Hrs) 
Total Time taken by all Users in hours between sign in 
and sign out per Project/Shell 

Total 
Total time taken by users at a company level as well as 
Company Partner level for across all company projects or 
shells 

Usage Detail By Company Workspace 

This report displays usage times for company and partner users working in the owner company’s 
Company Workspace. 

Report Query Parameters: 

 Source: defaults to Company Workspace 

 Project/Shell: Not applicable 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

Company Name 

The company name. Depending on filter condition this 
report can be generated for a particular Sponsoring 
company. 

If no users from current company are assigned to work in 
the Company Workspace the row will start with Partner 
name. 

User Name The user names that are involved at Company Level 

User ID The user ids that are involved either at Company Level 

Date Date when user signed in to Unifier 

Usage (Min) 
Time taken by User in minutes between sign in and sign 
out working at the Company Workspace 

Usage (Hrs) 
Time taken by User in hours between sign in and sign out 
working at the Company Workspace 

Total 
Total time taken by users at a company level as well as 
Company Partner level at Company level 
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This column: Shows: 

Grand Total 
Total time taken by users at a company level as well as 
Company Partner level across Company and its Partners.

Usage Summary By Company Workspace 

This report summarizes usage times for company and partner users working in the owner 
company’s Company Workspace. 

Report Query Parameters: 

 Source: defaults to Company Workspace 

 Project/Shell: Not applicable 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This 
column: 

Shows: 

Company Name of the Sponsoring Company or Partner 

Usage (Min)
Total Time taken by all Users in minutes between sign in and sign out in 
Company Workspace per Company/Partner 

Usage (Hrs)
Total Time taken by all Users in hours between sign in and sign out in 
Company Workspace per Company/Partner 

Total 
Total time taken by users at the owner company level as well as 
Company Partner level in the Owner Company Workspace 

Usage Detail By User 

This report details usage across a company and all of its partner users grouped by user name. 
The results sort by user’s first name and last name independent of whether user belongs to the 
owner company or a partner company. 

Report Query Parameters: 

 Source: All, Company Workspace, Project/Shell or Other 

 Project/Shell: Select a Project/Shell or leave blank 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This column: Shows: 

User Name 
The user names that are involved either in Projects or 
directly at Company Level 
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This column: Shows: 

User ID 
The user ids that are involved either in Projects or directly 
at Company Level 

Company Name Company Name of the User 

Source Either Company Workspace/Project/ Other 

Name 
The names of projects or shells that have users assigned 
to it either from Company or Partner levels. This column 
is empty if Source is Company Workspace or Other. 

Number 
The corresponding Project/Shell Numbers. This column is 
empty if Source is Company Workspace or Other 

Date Date when user signed in to Unifier 

Usage (Min) 
Time taken by User in minutes between sign in and sign 
out 

Usage (Hrs) Time taken by User in hours between sign in and sign out

Total 
Total time taken by a particular user at a company level 
as well as Company Partner level across Source criteria 

Grand Total 
Total time taken by all users at a co. level as well as 
Company Partner level across Source criteria 

Usage Summary By User 

This report displays summarized usage times per user. The report is sorted alphabetically by 
user first name, last name. 

Report Query Parameters: 

 Source: All, Company Workspace, Project/Shell or Other 

 Project/Shell: Select a Project/Shell or leave blank for all projects or shells 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This 
column: 

Shows: 

User 
Name 

All user names for sponsor company and partner companies 

User ID The corresponding User IDs 

Company 
Name 

Each user’s company 

Usage 
(Min) 

Total Time taken by a user in minutes between sign in and sign out 
summed up in the date ranges 
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This 
column: 

Shows: 

Usage 
(Hrs) 

Total Time taken by a User in hours between sign in and sign out summed 
up in the date ranges 

User Account Details 

This report displays account status details across a company and partners grouped first by 
Company User Names and then Partner User Names. 

Report Query Parameters: 

 Source: All, Company Workspace, Programs or Projects/Shells 

 Source Name: Active if Programs or Projects/Shells is the source. Click Select and select 
the Program or Project/Shell name from the list. 

 Partner Company: Select a partner or leave blank for all partners 

This column: Shows: 

Company 
Name 

The Sponsor Company Name, followed by the Partner Names 

User Name 
All user Names from a company and partner users assigned to 
Sponsoring Company Projects 

User ID The corresponding User IDs 

Source The Project/Shell Name the user is a part of 

Source 
Name 

The name of the project or shell 

Date Added 
The date that this user was added to the company. This column is empty 
for Partner users 

User Status 
The Status of the User at the project or shell level whether 
(Active/Inactive) 

Status 
Effective 
Date 

The date the Status of the user changed at the project Level. 

User Account Summary 

This report summarizes account status details across a company and partners grouped first by 
Company User Names and then Partner User Names. 

Report Query Parameters: 

 Partner Company: Select a partner or leave blank for all partners 
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This column: Shows: 

Company 
Name 

The Sponsoring Company or Partner 

Company 
Short Name 

The short name for the Company 

Total Users 
Total number of users at Owner Company/Partner working on Owner 
Company Workspace or Owner Company Projects 

Current 
Active Users 

Total number of active users at Owner Company/Partner working on 
Owner Company Workspace or Owner Company Projects 

Current 
Inactive 
Users 

Total number of inactive users at Owner Company/Partner working on 
Owner Company Workspace or Owner Company Projects 

Current On 
Hold Users 

Total number of inactive users at Owner Company/Partner working on 
Owner Company Workspace or Owner Company Projects 

User Session Detail 

This report displays user sign in session details. 

Report Query Parameters: 

 Owner Company 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

 Platform  

 Website 

 Mobile App 

 Website & Mobile App 

This 
column: 

Shows: 

User Name All user Names from an Owner Company 

User ID The corresponding User IDs 

Company 
Name 

The Sponsoring Company or Partner 

Login Date Date user signed in to Unifier 

Logout 
Date 

Date user signed out. (Dates will displayed in Server Time zone) 

Session 
End Type 

Timeout or Logout 
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This 
column: 

Shows: 

Usage 
(Min) 

Usage between sign in and sign out in minutes 

Usage 
(Hrs) 

Usage between sign in and sign out in Hours 

Total Total time taken 

The following shows the columns according to the platform:  

This column: Shows: 

Website As is. 

Mobile App Output for User Session Detail Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Report Run by, and the date that the report was run 
on. 

Columns displayed in the report output: 

 User Name 

 User ID 

 User Type 

 Company Name 

 Operating System  

 Device  

 Login Date 

 Logout Date 

 Session End Type 

 Usage (Min) 

 Usage (Hrs) 
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Website & 
Mobile App 

Output for User Session Detail Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Report Run by, and the date that the report was run 
on. 

Columns displayed in the report output: 

 User Name 

 User ID 

 User Type 

 Company Name 

 Operating System  

 Device  

 Login Date 

 Logout Date 

 Session End Type 

 Usage (Min) 

 Usage (Hrs) 

About Platform 

Unifier can be accessed through various platforms (website, mobile app, or both), and you have 
the option to track the users when they sign in through these platforms. This is to enable you to 
to capture information such as number of sign-ins, device type, and so forth.  

When you select the platform, the report output, will have the following columns: 

This column: Shows: 

Operating 
System 

The version of the device operating system. 

Device The device model. For example, Apple iPhone 7 plus. 

The following shows the columns according to the platform:  

This column: Shows: 

Website As is. 
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Mobile App Output for Last Login Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Report Run by, and the date that the report was run 
on. 

Columns displayed in the report output: 

 User Name 

 User ID 

 User Type 

 Company Name 

 User Status 

 Operating System  

 Device   

 Last Login Date 

 Days Since Last Login 

Website & 
Mobile App 

Output for Last Login Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Report Run by, and the date that the report was run 
on. 

Columns displayed in the report output: 

 User Name 

 User ID 

 User Type 

 Company Name 

 User Status 

 Operating System  

 Device  

 Last Login Date 

 Days Since Last Login 

The information above applies to the following reports (Company Workspace tab > Admin 
mode > System Reports):  

 User Session Detail 

 Last Login 

 Current Login 

The available report formats are: 

 HTML 

 CSV 

 Excel 

 PDF 

 XML 
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Last Login 

This report displays last sign in details for a user. It lists the users that have signed in, not all 
user accounts. If a user has never signed in to Unifier, that user will not be listed on the Last 
Login Report. 

Report Query Parameters: 

 Partner Company: Select a partner or leave blank for all partners 

 Platform: Select a platform to monitor.  

This column: Shows: 

User Name All user Names from an Owner Company 

User ID The corresponding User IDs 

Company 
Name 

The Sponsoring Company or Partner 

User Status The status of the user 

Last Login 
Date 

Date when Company User last signed in. For a partner user, this date 
should be the last date the user signed in to Partner Company 
Workspace. 

Days Since 
Last Login 

Number of days since the user last signed in. Calculated as difference 
between last sign in date and the date on which the report is run. 

Current Login 

The Current Login Report displays currently logged in users. 

Report Query Parameters: 

 Source: All, Company Workspace, Programs or Projects 

 Source Name: Active if Programs or Projects is the source. Click Select and select the 
program or Project name from the list. 

 Partner Company: Select a partner or leave blank for all partners 

 Platform: Select a platform to monitor.  

This 
column: 

Shows: 

Company Sponsor company 

User Name All user names from an Owner Company 

User ID The corresponding User IDs 

Source The source 

Source 
Name 

The source name 
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This 
column: 

Shows: 

Source 
Number 

Corresponding number 

Login Time Login time for the current session 

Remote 
Address 

The IP address of the computer from which the user is logged on 

The following shows the columns according to the platform:  

This column: Shows: 

Website As is. 

Mobile App Output for Current Login Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Source, Source Name, Report Run by, and the date 
that the report was run on. 

Columns displayed in the report output: 

 Company Name 

 User Name 

 User ID 

 User Type 

 Operating System  

 Device  

 Source 

 Source Number 

 Login Time 

 Remote Address 
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Website & 
Mobile App 

Output for Current Login Report: 

The header of the Report will have the fields of Owner Company, 
Partner Company, Source, Source Name, Report Run by, and the date 
that the report was run on. 

Columns displayed in the report output: 

 Company Name 

 User Name 

 User ID 

 User Type 

 Platform 

 Operating System  

 Device  

 Source 

 Source Number 

 Login Time 

 Remote Address 

Proxy Login 

This report displays user sign in proxy details. 

Report Query Parameters: 

 Partner Company: Select a partner or leave blank for all partners 

 Date Range From 

 Date Range To 

This 
column: 

Shows: 

First Name The Proxy first name 

Last Name The Proxy last name 

Login User 
Name 

The user who logged in 

Company 
Short Name

The Company name of the Proxy user 

Proxy User 
Name 

Then name of the Proxy 

Login Date The date the user logged in 
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Setting Permissions for Inbox 

To set Inbox permissions for Company Workspace, Shell Instances, and Standard Project 
Instances:  

1) Go to Company Workspace tab (Admin mode). 

2) Click Access Control to open the log. 

3) Click User Mode Access to expand. 

4) Click Shells / Projects (Standard) to expand. 

5) Click Mailbox to expand. 

6) Click Project Mailbox to expand. 

7) Click Inbox to open the Permissions Setting for: Inbox window. 

8) Click Add or Modify and grant the following permissions: 

 Delete 

To delete messages. 

 Reply 

To reply to messages. 

 View 

To view messages. 

 Create/Manage Folders 

To create, rename, and move folders under Inbox. 

9) Click Apply when finished. 

Note: You cannot grant permissions at Project Mailbox level. All 
Project Mailbox permissions must be granted at Inbox level. 

For Permission Templates: 

1) Go to Company Workspace tab (Admin mode). 

2) Click Access Control to open the log. 

3) Click Administration Mode Access to expand. 

4) Click Standards & Libraries to expand. 

5) Click Permission Templates to open the Permission Settings for: Permission Templates
window. 

6) Click New. 

7) Click Permissions. 

8) Go to User Mode Access and expand. 

9) Click Mailbox to expand. 

10) Click Project Mailbox to expand. 
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Setting Permissions for Unpublished Attachments 

Whenever a mail is received through the Unifier Project Mailbox, the attachment associated with 
the email will be captured within the Document Manager (DM). A new folder will be available 
under Project Mailbox node in which all unpublished mail attachments will be available for 
publishing to Shell DM. 

To set Unpublished Attachments permissions for Shell Instances and Standard Project 
Instances:  

1) Go to your project or shell mailbox. 

2) Click Access Control to open the log. 

3) Click User Mode Access to expand. 

4) Click Shells / Projects (Standard) to expand. 

5) Click Mailbox to expand. 

6) Click Project Mailbox to expand. 

7) Click Unpublished Attachments to open the Unpublished Attachments window. 

8) Click Add or Modify and grant the following permissions: 

 Publish 

To allow publishing into the DM. 

 Download 

 Open 

 View 

9) Click Apply when finished. 

Task Reassignment (Company and Project) 

When a user with assigned tasks is removed from a project, you (Company Administrator, 
Project Administrator, or Administrator user) can reassign the removed user's tasks to an active 
user.  

Note: In this scenario, you can only reassign tasks that have not been 
started, or tasks that are in progress. 

In the case of a dynamic assignment (when a workflow is routed back to the previous step, and 
the task on that step was assigned to the removed user), Unifier enables you to send the task 
the new active user. This also applies to a situation in which a record must be sent back to 
review. 

To reassign a task from a removed user to an active user: 

1) Go to Company Workspace tab (Admin mode). 

2) Click to expand User Administration. 

3) Click to expand Task Reassignment. 

There are two sub-nodes under the Task Reassignment node: 

 Active User Tasks
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 Inactive User Tasks

The following explains each sub-node in details. 

Active User Tasks 

The Active User Tasks log will house the following tasks: 

 Tasks for all active users existing at the company level.  

 Company level - This includes users from both owner and all partner companies 

 Project level - This includes users from both owner and the member companies. 

 Tasks where the active user is an assignee and the record has not yet reached the terminal 
step. 

This means that the previous user would no longer be seeing the task in the log but because 
of a previous action taken by the previous user the task would still appear in the log. The 
reasons for this appearing in the log are as follows: 

- To account for Dynamic step assignment. For example, the Workflow setup might have 
"Match <step>" in a subsequent step. 

- To account for step revisits. 

Active User Tasks log (toolbar options)

Option Description 

Reassign To open the Select New Assignee window and select the following 
information about the assignee: 

 Name

 Company

Select one or more tasks and click Reassign to open the user 
picker-window. 

View This option enables you to view the following pre-defined views: 

 All Tasks

 Group by Assignee

 Group by Origin

 Group by Business Process

 Reassignment History (See the "Reassignment History" section below 
for important details) 

 Create New View

 Manage Views

The Create New View option can be used to define user specific views. 

Refresh To refresh the items listed in the log. 

Print 
To print the items listed in the log, based on the current view of the log. 
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Option Description 

Edit View To view and edit the settings of items listed in the log. 

Use the View Name field to enter a name for your new view. 

Use the Columns tab to: 

- Determine which columns to display: Available Columns

- Select the columns: Selected Columns

- Lock the columns in place: Lock after selected Column

Use the Filters tab to: 

- Determine the field for your filter: Field

- Indicate the operator for your filter: Operator

- Include any values: Value

- Determine the number of records that you want to be displayed: Number 
of Records

Use the Group By tab to: 

- Group the list based on the options available from the drop-down list. 

- Adjust the order of your list: Order

Use the Sort By tab to sort items according to: 

- Previous assignee 

- New assignee 

- Origin 

- Business Process 

- Record Number 

- Reassigned on 

Click Cancel to discard your changes and return to the log. 

Click Apply to apply your changes to the view. 

Click Save As to save an existing view with another name. 

Filter The quick filter option enables you to quickly filter the tasks based on the 
values that you enter. The quick filter works on the visible contents, only. 
For example, if 200 records are displayed in the view, then the quick filter 
will work on the 200 visible records, only. 

Active User Tasks log (columns)

Column 
Heading 

Description 

Reassign
ment 
Status 

The (X symbol)  signifies that the task cannot be reassigned. 
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Column 
Heading 

Description 

Assignee Name of the inactive user assignee. 

Company Company name of the inactive user. 

Origin The source. The source can be project, shell, or company tab name. 

Business 
Process

Name of the business process. 

Record 
Number

The record number 

Title The title. 

Record 
Due

The due date for the record. 

Creation 
Date

The creation date for the task. 

Workflow 
Name

The workflow name. 

Inactive User Tasks 

The Inactive User Tasks log lists records that are in progress (workflow has not yet been 
completed) for inactive users. 

For the inactive users at the company, the Inactive User Tasks log lists all the tasks for inactive 
users. 

 At the Company level, the tasks included may belong to owner company users or all partner 
company users. 

 At the Project level, the tasks included may belong to owner company users or member 
company users. 

Note: A Member Company is a Partner Company. When a Partner 
Company is added to a shell or project, the Partner Company becomes 
a Member Company. 

The Inactive User Tasks log also lists the records that an inactive user is an assignee and the 
record has not yet reached the terminal step. This means that the inactive user would no longer 
be seeing the task in the log but because of a previous action taken by the inactive user the task 
would still appear in the log. This display allows to account for both Dynamic step assignment 
and step revisits for in-flight records. 
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Example 

Workflow setup might have "Match <step>" in a subsequent step. 

The Task Reassignment log has the following columns: 

Note: The following information applies to both the Company-level and 
Project-level unless it is noted otherwise. 

Column 
Heading 

Description 

Reassign
ment 
Status 

The (X symbol)  signifies that the task cannot be reassigned. 

Assignee Name of the inactive user assignee. 

Company Company name of the inactive user. 

Origin The source. The source can be project, shell, or company tab name. 

Business 
Process

Name of the business process. 

Record 
Number

The record number 

Title The title. 

Record 
Due

The due date for the record. 

Creation 
Date

The creation date for the task. 

Workflow 
Name

The workflow name. 
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Reassigning Tasks (Workflow) 

The following chart describes the workflow for reassigning tasks. The following topics explain 
each step in details. 
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Reassigning Tasks (Scenarios) 

In the following cases, the company administrator is a user who has permissions to reassign the 
tasks. 

Case 1: Selected new assignee is a CC user

1) Business Process record R1 currently has been assigned to user A and has been CC'd to 
user B 

2) User A has been inactivated 

3) Company Administrator has now reassigned this task to user B 

4) User B will receive the task reassignment notification in addition to seeing the task in the 
Tasks log. 

5) In addition to this, the notification for this task which the User B had received because of 
being a CC'd user, will be removed from the Notifications log.  

Case 2: Selected new assignee is not in the Workflow (WF)  setup

In the event that the selected assignee is not in the WF setup, the user will still get the 
reassigned task. This means that the task will be seen in the Tasks log.  

Note: By means of Tasks reassignment, the system will not add the user 
to the Workflow setup. This action has to be performed by the 
administrator who is setting up the workflow setup. Similarly the user will 
not have navigation level permissions to the Business Process log that 
the task belongs to. This action again has to be performed by the 
administrator. 

Case 3: Selected new assignee had previously declined the task

If the selected new assignee had previously declined the task, then post reassignment, the task 
will be seen in the Tasks log. 

Assumption: The workflow setup allows declining of the task. 

Case 4: Single Completion policy - Non participating assignee has been inactivated

A non participating assignee is one who has not acted on a task. When such a user is 
inactivated, the in-flight records which had this user in one of the steps will not be seen in the 
Tasks reassignment log. 

Case 5: Completion Policy - All Consensus

1) Business Process record R1 currently has been assigned to users A, B and C 

2) User A accepts the Task routes the record to step A 

3) User B declines the task 

4) User C has been inactivated 

5) Company Administrator reassigns the Task of User C from the Tasks Reassignment log to 
user D 

6) User D accepts the Task and routes the record to step B 
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7) The record will get routed to the resolving action since the users have taken different actions 

Case 6: Completion Policy - All Majority

1) Business Process record R1, currently has been assigned to users A, B and C 

2) User A accepts the Task and routes the record to step A 

3) User B accepts the Task and routes the record to step B 

4) User C has been inactivated 

5) Company Administrator reassigns the Task of User C to user D 

6) User D accepts the task and routes the record to step B 

7) The record will get routed to Step B since the majority of the users took the action of routing 
it to Step B 

Views 

You can use the views to sort or group tasks based on various attributes. The following displays 
the views and their definitions: 

View Definition 

All Tasks Columns are in the following order. 

 Assignee 

 Company 

 Origin 

 Business Process 

 Record Number 

 Title 

 Record Due 

 Creation Date 

 Workflow Name 

Other definitions are the same as in the Tasks log. 

Group by 
Assignee 

The Group By element will be Assignee.  

Columns are in the following order. 

 Assignee 

 Company 

 Origin 

 Business Process 

 Record Number 

 Title 

 Record Due 

 Creation Date 

 Workflow Name 

Other view attributes are the same as in the All Tasks. 
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View Definition 

Group by 
Origin 

The Group By element will be Origin.  

Columns are in the following order. 

 Assignee 

 Company 

 Origin 

 Business Process 

 Record Number 

 Title 

 Received 

 Creation Date 

 Workflow Name 

Other view attributes are the same as in the Group by Origin in the 
Tasks log. 

Group by 
Business 
Process 

The Group By element will be Business Process.  

Columns are in the following order. 

 Assignee 

 Company 

 Origin 

 Business Process 

 Record Number 

 Title 

 Received 

 Creation Date 

 Workflow Name 

Other view attributes are the same as in the Group by Business Process 
in the Tasks log. 

Reassignme
nt History - 
log 

It is important to maintain the reassignment history of tasks. The view 
Reassignment History will enable administrators to view all the past 
reassignments. When this view is active: 

Toolbar option of Reassign will not be seen. All other toolbar options will 
remain as is. 

Log columns will be Previous assignee, New assignee, Origin, Business 
Process, Record Number and Reassigned on. 

The date column of Reassigned on will honor user preferences. 
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View Definition 

Reassignme
nt History - 
View 
settings 

Columns 

    Previous assignee 

    New assignee 

    Origin 

    Business Process 

    Record Number 

    Reassigned on 

Filter fields 

    Previous assignee 

    New assignee 

    Origin 

    Business Process 

    Record Number 

    Reassigned on 

The operators available will be dependent on the data type. In addition to 
the filter fields, the view definition will also have Number of Records. 

Group By 

    String fields 

View buttons 

The view settings will only have Cancel and Apply. There can be only 
one view of this type and this is already provided by the system. Any 
changes made to the view cannot be saved. 

Workflow of Reassigning Tasks (Company) 

 The administrator user selects tasks. 

Tasks may or may not be from the same Origin. For example, the Tasks may belong to two 
different projects P1 and P2. 

 The administrator user clicks Reassign. 

 The user picker window opens that displays the list of users as follows: 

 All active owner company users from P1 and P2. 

 All active member company users from P1 and P2. 

 Users belonging to either of the two projects. 

 The administrator user selects a new assignee. 

 Unifier assigns all selected tasks to the new assignee. 

 If user exists in the project, then the task will get reassigned and an email notification will be 
sent to the new assignee. See the "New Assignee Email Notifications" for details. 
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 If user does not exist in the project, then the task will not get reassigned and will continue to 
remain in the log. 

Workflow of Reassigning Tasks (Project) 

 The administrator user selects tasks. 

Tasks belong to the same project. 

 The administrator user clicks Reassign. 

 The user picker window opens that displays the list of users as follows: 

 All active owner company users. 

 All active member company users. 

 The administrator user selects a new assignee. 

 Unifier assigns all selected tasks to the new assignee. 

 If reassignment is successful, then the task will get reassigned and an email notification will 
be sent to the new assignee. See the "New Assignee Email Notifications" for details. 

 If reassignment is no successful, then the task will not get reassigned and will continue to 
remain in the log. 

Reassigning Tasks Access Control 

Access to the Tasks Reassignment node is by permissions. To grant permission: 

1) Go to the Access Control node. 

2) Click Administration Mode Access. 

3) Click User Administration. 

4) Click Tasks Reassignments. 

5) Select users, or groups, and set permissions. 

The "Enable" permission enables the user to: 

 View the task 

 Reassign the task 

You can assign the permissions to either an individual user or a group. 

The permission changes are applicable to all modules of Unifier, where the permissions can be 
set, for example: 

 User > Permissions 

 Group > Permissions 

 Permission template 

New Assignee Email Notifications 

The Subject line of the new assignee email notification states how many task have been 
assigned and by whom. 

The body of the new assignee email notification contains the following information: 
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 Project name 

 Record number of the business process 

 Title of the business process 

 Unifier login link 
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Setting up the Business Processes 

Information is entered and stored in Unifier using electronic business process forms and routed 
via configurable workflows. Business processes -- and their workflows, logs, and even search 
parameters -- can be created and designed in uDesigner. They are then imported into Unifier, 
configured for use, and set up for use in specific projects, shells or the company workspace. 

Setting up business processes for use in Unifier consists of the following steps: 

Step 1: Import and deploy business processes from uDesigner. 

Step 2: Configure the BPs. This configuration enables the BP to be set up for use. It consists of 
establishing the record number sequence, determining which BP log the records will be stored 
in, and activating workflows. 

Step 3: Set up the BPs. After configuring, BPs must be set up for use at the company level or in 
individual projects or shells. For workflow BPs, you can create multiple setups that allow you to 
use the same BP form with any number of customized workflows. 

Step 4: Grant permissions. After setting up and activating a business process, you must grant 
User Mode permission to all users (including yourself) who will need to view records or 
participate in a workflow. 
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Note: Not all BPs work in all areas of Unifier. Business Process 
Functionality in Unifier (on page 309) for a table listing all available 
business processes and the functional areas in Unifier in which they are 
available for use. 
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Master Log - Business Processes Node 

The Master Log - Business Processes node is located in the Home page of Unifier. 

The Master Log - Business Processes node allows you to access all or a subset of records of 
the same type, in a single log that spans multiple shells or projects. The Master Log - Business 
Processes node lists all business process types at the shell/project level in separate nodes for 
each type. This includes workflow, non-workflow, and multiple record business processes. 
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Note: The company-level and single-record business processes are not 
listed under the Master Log - Business Processes node. 

For example, your company might have a shell hierarchy of buildings. A dispatcher who is 
responsible for translating service requests into work orders could use the Master Log - 
Business Processes node to create and edit work order records for any building shell from a 
single, "master" log, rather than drilling into each building shell to access the records. 

The Master Log - Business Processes node can also be filtered to display only certain 
records. For example, a regional Lease Manager might need to access all of the active leases in 
the system that have lease amounts greater than $50,000 per year. Using the filter feature, the 
lease manager could display these leases in the Master Log, thereby making his/her work 
easier. 

Note: If you do not grant users the permission to view or access any of 
the business process types listed under the Master Log - Business 
Processes node, then the users will not see the Master Log - Business 
Processes node in the Home page. 

Setting the Master Log - Business Processes node permissions 

You must give explicit permission(s) to users access the Master Log - Business Processes
node. You can grant permissions for users to access all business processes in the Master Log, 
or to individual business process types. To view business process records, users must also: 

 Be an active member in the project, shell, or sub-shell 

 Have access to at least one business process in the Master Log - Business Processes
node 

All shell/project business processes in the system (except inactive and single-record BPs) are 
listed alphabetically in their corresponding Master Log - Business Processes node. 

To set permissions for Master Log - Business Processes node: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select User Mode Access > Home > Master Log > <business 
process>. 

4) Set the permissions as needed: 

 View: Users can view all business process records across all projects and all records in 
the shell hierarchy (subject to their highest level of shell membership in the hierarchy) 
independent of whether or not they are assignees on or have permissions to view and 
manage individual records within a particular Shell or Project. These users can also view 
saved searches. 

 Allow Bulk Edit: Users can select one or more records within a Master Log and perform 
Bulk Edit on business process records. Selected records can potentially span across 
multiple shells. Users having this permission automatically have View permissions. 
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Advanced Logs and Standard Logs 

For Business Processes, Shells, the Space Manager, and code-and-record-based managers, 
you can design either a Standard log, or an Advanced log for display in Data Pickers. An 
Advanced Log creates an extra navigation structure that makes it easier for the user to choose 
records to work with.  

Note: The default elements and fields (log layout, view, search, etc.) that 
are defined in the Standard Log, in uDesigner, determine the Standard 
user interface elements and fields of all logs.  

Importing Business Processes (BPs) 

All designs, including Business Processes, are designed in uDesigner and deployed to Unifier. 
See Importing Configuration Packages (on page 640). 

Configuring Business Processes (BPs) 

Business process configuration allows you to configure and activate the company-level 
information for each business process you will use. After business processes are deployed from 
uDesigner, they are available for use. Configuring allows activation of the business process and 
specific workflow schema that can be used in projects, shells, or the company level. 

The "Enable for Mobile Application" checkbox must be selected for BPs that you want to be used 
in the Unifier Mobile App. 

Configuration consists of: 

 Activating or deactivating a BP (deactivating an active BP will also deactivate all of its 
setups) 

 Determining which BP log the BP records will be stored in (e.g., project logs, shell logs, 
company logs, Data Manager, etc.) 

 Establishing the BP record numbering sequence 

 For workflow BPs, activating the workflows that will be allowed for use with the BP 

 Creating a custom-designed print layout that can be used to print BP records 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

Accessing Business Process configuration log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Business Process in the left Navigator. The Configuration - 
Business Processes log opens. The log lists the Business Processes that have been 
imported into Primavera Unifier. 
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The newly imported Business Processes are inactive by default and are activated during 
configuration. The ID column shows the short code used to identify the Business Process, as 
defined in uDesigner. During configuration, you can choose to include this identifier as part of 
the record number (for example, if a BP has an ID of uaici, individual record numbers created 
for the BP might be uaici-0001, uaici-0002, etc.). 

Create Custom-Designed BP Print Layout (Custom Print tab) 

In the Business Process Configuration window, the Custom Print tab allows you to customize the 
layout of a document, using either MS Word® (leveraging the XML style design ) or PDF format 
(using Adobe® LiveCycle® Design View.) 

You can use the custom print templates to print one record at a time. The document shows all 
the values of the record that are available. This feature is similar to Print Preview for HTML or 
PDF. The only difference is that you can custom design the format for the selected record. 

Unifier automatically generates the XML schema, which is used to define the custom layout in 
Word or in LiveCycle. For a given business process, you can export the schema and use it to 
develop your own customized template. You then save the template and upload it to Unifier. 

With This button: Do this: 

Export Schema 
Creates a custom print template using the PDF or 
Word option. 

Download 
Select a template and click Download to use a 
prepared custom template. 

Upload, Rename, or Remove 
Add, change, or remove the custom template. Select 
the template from the list and click the relevant 
button. 

Rename an existing template 

In the Custom Print window, you can make changes to the names of existing templates. 

1) Select the template from the list and click Rename. 

2) In the Rename window, make the changes in the Title field. 

Note: If the template you chose was a MS Word template, there will be 
an additional field, Export As. This allows you to export the template as a 
different name. 

3) Click OK. 

Preparing to build a custom print PDF template 

Prior to starting, make sure Adobe LiveCycle Designer has been downloaded to your computer. 

1) In the Business Process Configuration log, open the desired business process form. 

2) Click the Custom Print tab. 
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3) Click the Export Schema drop-down and select Schema for PDF. A pop-up window 
appears. 

4) Save the XSD schema file to a location. 

5) Open Adobe LiveCycle and click File > New Blank document. 

6) Click File > New Data Connection. 

7) Name the new connection and select XML Schema. 

8) Click Next. 

9) In the Select XML Schema File field, click the browse button and find the XML Schema file 
you just saved. 

10) In the Options section, select Embed XML Schema. 

11) Click Finish. The XSD tags appear in the Data View tab on the left pane of LiveCycle. 

Note: The tag naming scheme is a combination of LiveCycle and Unifier 
names. The first word before the underscore is LiveCycle’s term, for 
example, "task," "form," and "lineitem." Everything after the first 
underscore is a Unifier data element. For a full list of the Unifier data 
elements definitions (XSD tags), see "XSD tags used in creating a PDF 
template" below. 

Building the template 

From the XSD tag list in the Data View tab on the left pane of LiveCycle and drag and drop your 
tags onto the template. For Attachments, Comments, Tabs and Workflow tags, special care 
needs to be made to ensure that the tags do not overlap in the printed output. 

1) Select an Attachment, Comment, Tab or Workflow tag and drag and drop it onto the 
template, for example, "Attachments." The XSD tags display as a group inside a frame 
("subform") with four small squares at each corner of the frame. The subform frame rests 
inside a frame called "top form." 

2) Right-click on the subform’s frame corner and choose Palette > Objects. The Object tab 
opens on the right side of the LiveCycle window. 
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3) In the Content field, select Flowed. 

4) Right-click on the top form’s frame corner and choose Palette > Objects. 

5) In the Content field of the Object tab, select Positioned. 

6) To add current workflow steps to the template, use the Task_Details tags. 

7) When finished, click File > Save. 

Uploading the template into Unifier 

1) In Unifier Custom Print window, click Upload. 

2) Navigate to the saved LiveCycle template and upload it. The name of the template appears 
in the Custom Print screen. 

The user can now print the business process record using the PDF template option (File > 
Print Preview > Custom.) The printed output will look similar to this: 

XSD tags used in creating a PDF template 

Below is a list of all the default XSD tags imported from Unifier into LiveCycle. Comments and 
attachments are recursive and repeatable. For example, an upper form can have comments with 
attachments. Line items can have attachments and comments to the attachments recursively 
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Type of tag 
Name 
Description 

Type of tag Name 
Description 

Type of tag Name Description 

Standard 
Element 

 Shell_Logo - shell 
or project logo / 
image 

 Shell_Number - 
shell or project 
number 

 Shell_Name - shell 
or project name 

 Applicable to all types of BP records 

 Use these tags to have project/shell 
information as part of the printed output 

Task_Details 

 Assigned_To 

 CC 

 Sent_For 

 Task_Due_Date 

 Task_Status 

 Task_Note 

 Sub_Workflow 

 Sub_Workflow_Du
e_Date 

 Tags appear in the task section of a BP 
record 

 Use these tags to print out the current 
step of the workflow 

 Applicable to all types of BP records 

Upper_Forms 

 <upper form1 
name> - name of 
the upper form, 
Example: contract 
view form 

 <Elements from 
form1> - elements 
within upper form 

 <upper form2 
name> - name of 
the upper form, 
Example: contract 
action form 

 <Elements from 
form2> -elements 
within the upper 
form 

 Tags for all the upper forms available for 
a BP. Example: view form, action form 
etc. 

 Applicable to all types of BP records 

Tabs 

 <tab1 name> - 
name of the tab 

 Line_Items - line 
item tag that 
encloses all the 
elements within the 
line item 

 Use these tags to include the information 
in the line item tabs in the printed output. 
The printed output will show the name of 
the line item tab name with the line items 
under it. 

 Elements of each tab are listed under the 
corresponding tab. 
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 * element1 - the 
data *element 
name 

 *element 2 

 *element n 

 Repeat for all other 
tabs 

 Applicable to all BP types except: Simple 
and Document type (Without Folder) 

General_Com
ments 

 Comment 

 Comment_Date 

 Commenters_Nam
e 

 Commenters_Com
pany 

 <Attachments> - 
the tag that 
encloses the 
attachments for the 
comment 

 Tag that encloses all comments and their 
related attachments 

 Applicable to all BP types 

Record_Attach
ments 

 <Attachments> - 
Tag that encloses 
the attachments 

 Title 

 File_Name 

 Revision_Number 

 Issue_Date 

 File_Size 

 <Comments> - tag 
that encloses 
comments for 
attachments 

 Tag that encloses the attachments related 
to the BP record 

 Applicable to all BP types 

Workflow_detai
ls 

 Workflow_Steps - 
tag that encloses 
the steps within a 
workflow 

 Step_Name 

 Step_Assignee 

 Assignee_Compan
y 

 Step_Status 

 Step_Action 

 Step_Completion_
Date 

 Tags for the workflow details of a 
workflow BP record 

 Applicable to all workflow BP types 

 Use these tags to include the current BP 
workflow step in the printed output 
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To create a customized XML template in Word 

1) In the Business Process Configuration log, open the desired business process form. 

2) Click the Custom Print tab. 

3) Click the Export Schema drop-down and select Schema for Word 2003. The File Download 
window opens prompting you to save the file. Click Save. 

4) Open a new Microsoft Word document. 

5) Import the XSD file into Word by selecting Tools > Templates and Add-ins. 

6) Click the XML Schema tab and click Add Schema. 

7) Navigate to the bp_schema.xsd file and click Open. 

In the Schema Settings window, type a unique name for the schema in the URI and Alias
field (for example, "Submittal"). The name you enter for the alias appears in the list of 
available schemas in the Templates and Add-ins window. 

Note: Do not select the Schema validate options checkbox. 

8) Click OK. An MS Word document opens with a list of available Unifier BP tags under "XML 
Structure" on the right side of the window. 

9) To add XML tags to the Word document, enter text (e.g.,xxx_project_name to print Project 
Name) and click the project_name tag that is available as part of the XML structure. 

Note: For custom print to work properly, do not add XML tags to the 
header and footer. 

The text will be surrounded with project_name tag. You can follow this process for any 
element. 

10) To print line item information, first select the text for all the line item elements and select the 
appropriate XML tags. Then select all the elements that are part of the line items and click 
the _bp_lineitems tag. 

By doing this you are enclosing all line item elements within the_bp_lineitems XML tag. At 
runtime, Unifier will know that the elements that are part of _bp_lineitems should be printed 
for each line item of the BP. Elements that are part of the upper form are prefixed with 
"form_", and detail form elements are prefixed with "lineitem_". 

11) Turn off the XML tags before saving. 

12) Click File > Save As. Name the document, and select XML format for the save option. The 
document must be saved in XML format. Now you are ready to upload the completed 
document through the Business Process Configuration window. 

13) In the Business Process Configuration window, on the Custom Print tab, click Upload. The 
File Upload window opens. 

14) Browse and select the Word file you created. You can enter document title, rev. no., and 
issue date. 

15) Click OK to save and close the window. 
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Configure and Activate a BP 

The following procedure describes how to configure and activate a business process. If the 
business process form contains a data picker, you will also have to configure the data picker. 

To configure and activate a business process 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Business Process in the left Navigator. The Configuration - Business 
Processes log opens, displaying the BPs that have been imported into your company. 

3) Select a business process and click Open > General. The Configuration window for the 
business process opens. 

4) Complete the General tab according to the table below Step 9.  

In this tab, you can specify the log in which the BP records will appear, the numbering 
sequence for the records, the status, and record termination restrictions. The tab also shows 
whether the BP is company, project, or shell level. 

5) Click the Workflow tab (applicable for workflow BPs only). Business processes may have 
multiple workflows that have been defined in uDesigner. Use this tab to activate one or more 
workflows that have been imported with the BP. Non-workflow BPs will not appear in this tab. 

6) Click the Custom Print tab. This tab is optional. It allows you to customize the BP layout of a 
Word document. See Create Custom-Designed BP Print Layout (Custom Print tab) (on 
page 223) 

7) When you have completed the configuration information, you can make the BP available for 
setup and use by changing the status to active in the General tab. 

8) When the window is complete, click OK. 

Fields on the General tab: 

In this field: Do this: 

Level 
Displays whether the BP is company, project, or shell level, as 
determined in uDesigner. 

Default Location 

Choose where the BP records will be stored. Some BP types will 
default to a log and cannot be changed. 

Note: If you are using the user configurable Navigator, you may not 
see the BP in the User Mode log immediately, even after granting 
permissions. You need to manually move the BP into the correct 
User Mode node. 

Sequence Policy 

This determines how the record numbers for each BP record are 
sequenced. The record number is displayed on the form and in the 
Business Process log. 

Company Based: Record numbering starts with this number on 
the first record of the first project or shell and is sequential on each 
record after that, no matter what project a BP record is created in. 

Project/Shell Based: Record numbering starts over in each new 
project or shell, and is sequential within the project or shell. 



Unifier Modules Setup Administration Guide

230

Sequence Format 

The prefix and starting number that will be used for BP record 
numbers. 

Use Base Commit's Record Number: This is for identifying 
workflow Change Commits (Line Items with CBS Code Cost BPs) 
at the project or shell level. For this type of change commit, you 
can use the base commit's record number as part of the prefix for 
the change commit's record number. This will clearly identify the 
base commit to which the change commit refers. It will also provide 
sequential numbering for the change commits so that users can 
see how many change orders have been initiated for the base 
commit. 

To specify this addition to the prefix number, you need to include a 
separator, such as a period, and a starting number for the change 
commits. The maximum number of characters for the starting 
number is 8. For the total format, including the base commit's 
record number and the sequential numbers, the maximum number 
of characters is 20. 

For example, a base commit record might be numbered 
PO-00123456. For a change commit record that refers to this base 
commit, the change commit record number could be 
PO-00123456, followed by a separator (such as - ) and a number 
for the change commit. The sequence format for change commits 
attached to this base commit could be numbered: 

PO-00123456-001

PO-00123456-002

PO-00123456-003

Note: This numbering sequence will be frozen once it is used for a 
change commit in a project or shell. Any change to this numbering 
sequence will only affect change commits created in a new project 
or shell. 

Business Process 
Log 

If standard, the option Standard is selected. 

Record Creator 

Options available are: 

 Do not allow to terminate record

 Allow to modify record

 Do not allow to transfer ownership of records
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Enable audit of 
record print 

Deselected by default.  

If selected, the user can view the audit log entries for print and 
discover the number of times that a record has been printed. 

When you select this option, the following user actions on a record 
will create an audit entry: 

 Printing from BP record 

 Single & Bulk Printing from the BP log.  

 Single & Bulk Printing from the Task log 

Note: For bulk print, the number of entries seen in the audit log will 
be the same as the number of records that were printed by way of 
the bulk print action. 

Enable for Mobile 
application 

Selecting this option enables the BP to be used for mobile app. 

The Cost Type: Line Items with Both CBS and WBS Codes 
business process cannot be enabled for mobile application.  

Record Creator 

This option gives administrators more control over who can edit or 
terminate a BP record once it is created. 

Do not allow to terminate record. If selected, once a BP record has 
been created, the owner or creator cannot terminate it. If not 
selected, after a BP record has been created, the owner or creator 
of the record can terminate it. 

Caution: Any user with terminate workflow permission for the BP, 
regardless of BP record ownership, will be able to terminate a 
record for that BP, regardless of whether this option is selected. 

Allow to modify record. If selected, the creator or owner of the 
record will be able to modify the record at any time, whether or not 
s/he is the assignee on a step. 

Do not allow to transfer ownership of records: If selected, the 
record creator cannot transfer the ownership of records to another 
user.  

Status 
Active enables the BP to be set up and used to create BP records. 
Inactive prevents set up or use of the BP. 

Configure a Query for a Query Based Data Element on a BP 

You can configure a Query, for a Query-based data element, on a BP. The Query-based data 
elements give you the ability to query data from business processes and manager sheets, and 
display the results on a business process. For example, you can create a small cost report on a 
business process. This reduces referring back to the cost sheet while a user is working in the 
business process. 

When a Query-based data element (Query Based Data Element) is added in a BP Form, you 
can define the query on which the element gets refreshed (trigger element). 
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Example 

Go to: Company Workspace > Admin mode > uDesigner > Business Processes > 
Action items - Home > Upper Forms. 

Add a Query-based data element in an Upper form of a BP and deploy it. 

Go to the Configuration Tab > Business Process> Required BP and open it to see the 
Query tab. 

During configuration, for each query-based data element (up to five per business process), you 
can define a query formula and any conditions that will filter query results. For example, if you 
want to see the total project commitment, which includes the original commitment amount plus 
any changes to the original commitment, you can build a query formula to show that value from 
the cost sheet. You may limit, or filter, the query results by adding a condition. You also define 
the refresh condition that will prompt a data update for these query-based data elements. When 
a user opens the business process, Unifier looks at the refresh condition to determine if it can 
display the last calculated value or values in the business process. 

Notes:  

 This feature is not available for company-level, single-record business 
processes. 

 The difference between a refresh condition and a trigger. A refresh 
occurs when a user opens a business process. A trigger works when 
the business process is already open and a user changes a value in 
a "trigger element" on that form. The trigger element prompts Unifier 
to run the query again and dynamically update the value in the 
query-based field. 

To configure the query 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Navigate to Configuration > Business Process. The Configuration-Business Processes log 
opens, displaying the BPs that have been imported into your company. Click Business 
Process Setup in the left Navigator. 

3) Select the business process that contains the query-based data element, click Open and go 
to the Query tab. 

4) Under Query Conditions, click the Add button. The Define Query window opens. 

The Define Query window shows two sections, a Definition section and a Condition
section. 

Fields in the Definition section: 

 Data Element: Select the data element you want to configure. The list shows only the 
query-based data elements on the form. 

 Data Type: Select the source from which Unifier will extract the values (e.g., a column in 
the CBS Cost Sheet or a business process). 

 Datasource: Click the Select button and on the Formula Creation window that appears, 
build a formula to calculate the value you want to see in the field on the BP form. For 
information on creating a formula for a query, see About Queries. 

5) If you want, you can specify a condition to filter the data that is extracted by the definition. 
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A condition is not mandatory for a query definition, but your results will be more refined if you 
build a condition. 

a. Click the Add button. The Add Query Condition window opens. 

b. Use the instructions under About Queries to complete the query condition. 

c. Click OK. 

6) On the Define Query window, click OK. 

7) On the Data Elements Configuration window, under Refresh Conditions, click the Add 
button. The Refresh Condition window opens. Fields in the Refresh section: 

 Data Element: Select the data element you want to prompt the field refresh. 

 Condition: Select the condition this data element must meet to prompt the refresh. 

 Values: Enter or select the value this data element must contain to prompt the refresh. 

 AND/OR: Select the "And" or "Or" condition between multiple queries.  

8) Click OK, then click Close on the Data Elements Configuration window. 

Configure a BP workflow (Workflow tab) 

Workflow business processes may have one or more workflows, which, along with the BP 
settings, control how BP records flow through the steps of the creation, response, review, and 
approval process. Workflows are designed in uDesigner and included with the BP. You must 
activate the workflows that you plan to set up and use. 

Note: This is applicable for workflow BPs only. Non-workflow BPs will 
not display this tab. 

To configure and activate a workflow 

1) In the Business Process Configuration window, click the Workflow tab. 

2) To activate a workflow, select the workflow and click Activate. 

3) Alternatively, you can select a workflow and click Modify. The Workflow Configuration
window opens. 

 In the General tab, you can edit the name or description if necessary. 

 You can change the status to active in this tab. 

 To view the steps of the workflow, click the Step tab. 

 Click OK to exit the Workflow Configuration window. 

4) If you have edited or added a workflow to an existing business process and re-imported, you 
may need to add the new workflow. Click Add to add newly defined workflows, if any exist. 

5) Click Apply to save your changes, and OK to exit the Business Process Configuration 
window. 

Create a custom XML template in MS Word 

In the Business Process Configuration window, the Custom Print tab allows you to customize the 
layout of a document, using either MS Word® (leveraging the XML style design) or PDF format 
(using Adobe® LiveCycle® Design View.) 
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You can use the custom print templates to print one record at a time. The document shows all 
the values of the record that are available. This feature is similar to Print Preview for HTML or 
PDF. The only difference is that you can custom design the format for the selected record. 

Unifier automatically generates the XML schema, which is used to define the custom layout in 
Word or in LiveCycle. For a given business process, you can export the schema and use it to 
develop your own customized template. You then save the template and upload it to Unifier. 

To create a custom XML template in MS Word 

1) In the Business Process Configuration log, open the desired business process form. 

2) Click the Custom Print tab. 

3) Click the Export Schema drop-down and select Schema for Word 2003. The File Download 
window opens, prompting you to save the file. 

4) Click Save. 

5) Open a new Microsoft Word document. 

6) Import the XSD file into Word by selecting Tools > Templates and Add-ins. 

7) Click the XML Schema tab and click Add Schema. 

8) Navigate to the bp_schema.xsd file and click Open. 

9) In the Schema Settings window, type a unique name for the schema in the URI and Alias
field (for example, "Submittal"). 

The name you enter for the alias appears in the list of available schemas in the Templates 
and Add-ins window. 

Note: Do not select the Schema validate options checkbox. 

10) Click OK. An MS Word document opens with a list of available Unifier BP tags under "XML 
Structure" on the right side of the window. 

11) To add XML tags to the Word document, enter text (e.g., xxx_project_name to print Project 
Name) and click the project_name tag that is available as part of the XML structure. 

Note: For custom print to work properly, do not add XML tags to the 
header and footer. 

The text will be surrounded with project_name tag. You can follow this process for any 
element. 

12) To print line item information, select the text for all the line item elements and select the 
appropriate XML tags. Then select all the elements that are part of the line items and click 
the _bp_lineitems tag. 
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By doing this you are enclosing all line item elements within the _bp_lineitems XML tag. At 
runtime, Unifier will know that the elements that are part of _bp_lineitems should be printed 
for each line item of the business process. Elements that are part of the upper form are 
prefixed with "form_", and detail form elements are prefixed with "lineitem_". 

13) Turn off the XML tags before saving. 

14) Click File > Save As. Name the document, and select XML format for the save option. The 
document must be saved in XML format. Now you are ready to upload the completed 
document through the Business Process Configuration window. 

15) In the Business Process Configuration window, on the Custom Print tab, click Upload. The 
File Upload window opens. 

16) Browse and select the Word file you created. You can enter the document title, rev. no., and 
issue date. 

17) Click OK to save and close the window. 

Creating BP Log Views in Admin Mode 

When users configure Business Processes (BPs), they can create log views for the BPs, also.  

Log views are the views which drive the content and behavior of the BP logs seen at run time. 
The Administrators can create customized "default" log views that meet the requirements of the 
company and users. 
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Note: Users can create the view in each project for the BPs that the 
users have access to, only. 

This topic explains the following: 

 BP Log Views 

 BP Log Views at Runtime 

 BP Log Views and Configuration Package 

BP Log Views 

BP log views can be created for: 

 Project-level BPs 

 Company-level BPs 

The views defined for the BPs are applicable to both BP logs and Master Log - Business 
Processes log. 

The Business Process node (Company Workspace tab > Admin mode > Configuration) has 
the following sub-nodes: 

 Action Items

 Log Views

The Log Views sub-node, seen in all types of BPs, enables you to: 

Create your log view, similar to creating BP logs in User mode. 

 Reorder the BPs. 

 Change the status of a BP. 

 Delete inactive views. 

Note: Users must have "Configuration" permission before they can 
access the Log Views node or create new log views. 

The Log Views log has the following features: 

 Toolbar 

 Create: To enable the administrator create a new view. Refer to the Unifier User Guide
(Tasks log) for details. 

 Actions: To take one of the following two actions: Check the status of a view (Status) or 
delete a view (Delete). 

Status identifies whether a view is active or inactive.. You can select one or more views, 
click Status, and activate or deactivate a view. 

Delete enables you to delete a view. You can delete a view that has been marked as 
inactive. If you select multiple views and delete, only the inactive views will be deleted.  

 Find on Page: To find a specific view on the displayed page. 

 Columns 

 No.: The system-generated number to help the user identify the sequence of the views. 
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Changing the sequence of the views (moving them up or down on the page) will result in 
change of the system-generated number. 

At least one BP log view must be active. The administrator cannot deactivate all BP log 
views. 

The user cannot create two BP log views with the same name for a single BP. 

When a user changes the sequence of the BP log views that were initially provided 
according to the BP configuration, Unifier retains the user's sequence even if the 
administrator makes changes to the sequence. 

If an administrator creates new BP log views, Unifier appends the new BP log views to 
the end of the BP log views list. 

 Name: The name of the view. 

 Status: Active or Inactive 

 Last Modified Date: The date that the view was last modified. For a new view this will be 
the creation date. The field is blank for existing system-defined views, for the first time 
when no modifications have been done. 

 Last Modified By: The name of the user who last modified the view. The field is blank for 
existing system-defined views, for the first time when no modifications have been done. 

The gear menu ( ), which appears when you click on a record, has the following options: 

 Move Up: To move a record up on the log. This option is not available for the first view on 
the log. 

 Move Down: To move a record down on the log. This option is not available for the last view 
on the log. 

 Status: Active and Inactive. If a view is Active, then the status option will be Inactive. 

 Delete: To delete a view. This option is not available for an Active view. 

BP Log Views at Runtime 

BP log views will be a part of BP configuration. Only active views will be seen at runtime. All 
active views pertaining to a BP can be seen by all user who have access to the log (BP logs and 
Master Log - Business Processes log). System provided views can also be modified in the Log 
Views to better suit your business needs. 

 All Records

 Records Created by Me

 Records Received by Me

 Records Created and Received by Me

 AI view

 Create New View

 Manage Views

BP Log Views and Configuration Package 

Use the Log Views node (Company Workspace tab > Admin mode > Configuration Package 
Management > Component Lists > Configuration > Log Views) to include the designs for the 
selected log views in your configuration package. 
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BP log views in Component list/Configuration Package: 

The users can include BP log views and deployed designs. 

The users can include updated BP log views without any changes to the underlying columns 
used in View definition. 

When the configuration package is imported, it replaces any existing BP log views that were 
created by the administrator. 

Note: The BP log view component will be included as part of impact 
analysis report, error report, and print report. 

Customizing Email Subject Line 

When you send Unifier task notification emails from various trigger points, you can customize 
the email subject line to provide more context to those notifications. You must have the 
permissions to configure Business Process to access the node Customize Email Subject. The 
customized email subject can be a combination of simple text, shell information, data elements 
from the Business Process Upper forms, and Workflow steps.  

Note: The email subject lines can be configured only for workflow-type 
business processes. 

The Customize Email Subject node contains a table of email types and preferred languages. 
You can configure email subject line in multiple languages as set in the Company Preferences. 
The language that is set to "Active" in the Internationalization node is the only language 
displayed in the right pane. 

To Customize the Email Subject Line 

1) Click Configuration > Business Process > select a Business Process name from the right 
pane > select Customize Email Subject. 

2) In the language column, select the Configure icon for the email type. 

Note: The preferred language must be selected as "Active" in the Internationalization node.  

3) In the window that appears, enter or edit the subject line in the free form text field. 

Notes: 

The subject line can be a combination of simple text, shell information, data elements from 
the BP Upper Forms, and Workflow steps. 

The maximum number of characters must be less than 299..Select the data element from the 
grid that follows. 

4) Select the data elements from the grid that follows. 

Note: The <DE Label> is displayed if the selected data element does not hold a value in the 
runtime. 

5) Click Save. 

The language column shows the email subject line corresponding to the email type. 
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Note: DEs of type Rich text are not available to be added in the email 
subject line configuration, or to be added to the custom email content.  

Configuring Business Process Configuration Package 

If tagged for Configuration Package, the system allows you to include the following 
configurations in the Business Processes:  

 General setup 

All the fields included in the General Configuration (General tab). 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the BIP Custom Print in the Custom Prints and Reports. 

 Workflows 

All configured Workflows. 

 Query 

All queries that have been configured based on data elements. 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 

General Procedures for Setting up Business Processes 

Business processes must be set up before use. The general procedures apply to company-level 
and project-or shell-level business processes, with some differences. 

Workflow Business Processes

Workflow business processes can have one or more BP setups, which define the workflow setup 
options. These include configuring the workflow and each step. These options control step 
behaviors as the BP moves through the steps of the workflow. Each step can have an 
associated duration and the workflow (consisting of all the steps) can have an overall duration, 
which facilitates project or shell data flow-through and tracking. BP setup is the process of 
choosing a configuration, assigning users or groups to each step, configuring the actions they 
can take on that step, and setting the durations. 

You may want to create multiple workflows per BP to accommodate different ways for the 
workflow to operate. For example, you can configure an RFI workflow with or without a 
coordinator. You may or may not have a need for both workflows on your project or shell. 

Non-workflow Business Processes

For non-workflow business processes, one setup is allowed. Setup includes adding the list of 
users who can create a new non-workflow BP. 

Set up of auto-creation of business processes or line items

Both workflow and non-workflow BPs support auto-creation. Auto-creation can be based on a: 
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 Condition that is met 

 Date that passes 

 Condition and a date 

 Frequency (at periodic intervals, for example) 

 Condition and frequency 

You can auto-create BPs or line items from the upper form or the detail form, using creator 
elements. See Set up auto-creation for a non-workflow BP or planning item (on page 245) 
for non-workflow auto-creation setup and Set up auto-creation for a workflow BP (on page 
262) for workflow auto-creation. 

Auto-creation of BPs based on workflow steps

You can specify that some workflow BPs include steps during the workflow that enable the 
auto-creation of BPs from an S-Step. Define the Business Process Workflow (on page 267) 
for details. 

Special setups

There are special setup procedures for blanket purchase order BPs and Request for Bid (RFB) 
BPs. There is an additional option for auto-creation of a commitment-level cash flow curve in 
setups for base commit business processes. 

Loading a Business Process 

Loading the business process is part of setting it up. In this step, you will be loading the 
configured business process into the area where it should reside—the Company Workspace, a 
shell, or a standard project. This step filters the business processes by company, shell, or 
project level, thereby narrowing the number of BPs so that the users do not have to sift through 
your company’s entire list of BPs. 

When you load a business process, you also load the permission infrastructure and the ability to 
grant permissions for this BP. 

To load a business process 

1) Go to the Company Workspace tab and switch to Admin mode. 

 To load a BP into the Company Workspace, click Company Workspace > Business 
Process Setup in the left Navigator. 

 To load a BP into a shell, click Company Sponsored Shells > [shell type] > [shell] > 
Setup > Business Process in the left Navigator. 

 To load a BP into a standard project, click Company Sponsored Projects > All > 
[project] > Setup > Business Process in the left Navigator. 

 To load a BP into the templates for a project, click Templates > Projects (Standard) > 
All > [template]. Then select Setup > Business Process in the left Navigator. 

 To load a BP into the templates for a shell, click Templates > Shells > in the left 
Navigator. Then choose the [shell type] > [template]. Then select Setup > Business 
Process in the left Navigator. 

2) Click New. The New Business Processes window opens, showing the business processes 
that are available for loading. 
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3) Select the business process you want to load and click OK. Unifier displays the business 
process in the right pane. 

Setting Up a Non-Workflow Business Process 

This procedure is applicable to project, shell, and company level non-workflow business 
processes. Be sure you have added the business process to the log first. 

Basic non-workflow set up in General tab and Settings tab 

To set up a non-workflow business process - General Tab 

1) Open the project or shell, or (for a company-level business process) go to the Company 
Workspace tab, and switch to Admin mode. 

2) Navigate to the Business Processes log. 

3) Select the non-workflow BP and click Open. The Setup log opens on the General tab. 

4) Click New. The Business Process Setup window opens. 

5) Complete the tabs as described below and click OK. 

6) Click Yes to activate the BP and make it available to users, or click No to keep the BP 
inactive until a later date. 

In this field: Do this: 

Setup Name Enter a unique name (required field). 

Description Enter a description. This is optional, but recommended. 

Help File Allows you to add a custom PDF help file. 

Default Record 
Status 

Use this field in setting up the creation of non-workflow business 
processes. The status you enter here will be used as the 
beginning status for a record created using any method—manual, 
integration, or auto-creation of any type. 

Send error 
notification to: 

Specify the user to receive error notifications. 

Save Record 
Information to 
Document Manager 

Select this check box if the records produced by this business 
process should be automatically saved in the Document 
Manager. If you select this option, Unifier will send a copy of the 
business process’ records, along with their comments and 
attachments, to a specified folder* in the Document Manager. 
The owner of the published record will be the assignee of the 
business process that published it. If the record already exists in 
the folder, the record will be published as a revision. If the path to 
the folder is invalid for any reason, the record will be sent to the 
Unpublished Documents node. 

Depending on how you set up the business process, it can be 
automatically published to the Document Manager whenever an 
email notification is sent regarding the status of the business 
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process. 

* This folder is identified on the business process with this data 
element uuu_dm_record_info_path. For information about this 
element, refer to the Unifier Reference Guide. 

Default Record 
format for 
Notification and 
Document Manager 

This option has two purposes: 

 If you want notification sent to users whenever a business 
process record is created or modified, use this option to 
specify the format in which you want the notification to be 
sent. 

 If you have checked the Save Record Information to 
Document Manager check box, use this option to specify the 
format in which the business process records should be 
saved. 

Cash Flow: Default 
Template 

This option only appears in CBS code-based Base Commit 
business processes. It allows you to enable the auto-creation of a 
commitment-level cash flow curve at runtime for the business 
process record. The curve is based on the selected 
commitment-level cash flow template, and is created when the 
record is completed. 

Click Add and choose a template. 

For more information, see Setting Up Auto-Creation of Cash 
Flow Curves from Contracts (on page 293). 

Settings tab 

Add the creator and editor on the Settings tab: 

In this field: Do this: 

Creator(s) 
Click Select to choose the creators of the BP, those users who 
may create a new BP record from this setup. 

Editor(s) 

Optionally, click Select to choose users and/or groups who can 
edit the business process without being granted explicit 
record-level permission. This allows users other than the 
assignee to edit the business process record. The Editors field 
can include users and groups that are also entered under 
Creator(s). 

The Editors can be added on these BP types: 

 Line Item 

 Cost (all types, including Lease and Line Item with Multiple 
Codes) 

 Document 

 Simple 

 RFB 

 Text 
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Users or groups that you add as Editors can open and edit any 
record that they can see listed in the business process log, per 
their view access permission. Access permissions are View 
User Records, View Company Records, or View All Records. 
The user who is designated as an Editor must have at least one 
of these permissions to be able to view the record in the log to 
access it to edit. 

Allow Quick 
Calendar Entry 

Click Select and choose the users and/or groups who will be 
allowed to use the quick entry feature to reserve the object of this 
business process, or to edit or delete it from the calendar. 

Note: This option will appear only on those business processes 
that have been calendar-enabled by design. 

Selecting BIP Custom Print (Format > Custom) 

The following is a list of conditions applicable to BIP Custom Print.  

 Only Published BIP Custom print templates can be selected while setting up the Business 
Process; however, if you make any changes to the Published template and do not re-publish 
it to BI server, the selected template will continue to remain in the Business Process (BP) 
setup option. Any record information sent as email attachments will contain data from the 
last published version existing in the BI server. 

 If the BP setup has been done in a Project/Shell template, then when you update the setup 
information onto instances of Projects/Shells, the setup gets pushed. 

 If you delete the BIP Custom Print template selected in the BP Setup window, then the 
system removes the deleted BIP Custom Print template from the BP setup. 

 If the system does not generate the print output, for example due to server issues, then the 
email attachment, which contains the record information, generates an error message. 

 Custom Print template included in the BP setup can be exported in the Configuration 
Package. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell 
template will also be included. If the Custom Print Template is not tagged, then the 
Configuration Package export will result in an error. 

Note: If the BIP Custom Print output could not be generated because of 
connection issues to BIP Server or inconsistencies in between Custom 
Print on Unifier and BIP Server, then notification emails for Business 
Process modification will have an "error.html" document (as an 
attachment) instead of a record information document. If the record 
information is Published to Document Manager, then a 0 KB document 
will be published to the Document Manager.   
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Set up email notification for a non-workflow BP 

Use the Notification tab to set up automatic email notifications to users and groups whenever a 
non-workflow business process is created or modified, either manually, or via auto-creation, 
reverse auto-population, CSV, or integration. 

Note: If the business process has been designed to allow users to 
include additional users or groups in the email, the email notification will 
be sent to them as well. 

1) Use the information in the table below to complete the Notification tab. 

2) Click Apply to save your changes and OK to exit. 

In this field:  Do this:  

Send 
notifications to 

Click Select and choose those users or groups that should be notified 
whenever a non-workflow business process is created or modified. 

Notify creator 
on record 
modification 

By default, this check box is checked. If you do not want the BP 
creator to be notified when the business process is modified, 
de-select this check box. 

Notification 
triggering 
events 

The fields you select here will tell Unifier when to notify the users or 
groups. 

Create Record 
Select this check box if notification should go out whenever a record 
is created. 

Edit Upper 
Form 

Select this check box if notification should go out whenever the upper 
form of a record is edited. 

Add/Edit/Delete 
Line Items 

Select this check box if notification should go out whenever a line 
item is added to the record, edited, or deleted from the record. 

Add General 
Comments 

Select this check box if notification should go out whenever 
comments are added to a record. 

Add/Remove 
Attachments 

Select this check box if notification should go out whenever 
attachments are added to or removed from a record. 

Attachments 
The fields you select here will tell Unifier how to add attachments to 
the record. 

Include both 
record and line 
item 
attachments 

Select this check box if the notification should include both the record 
and the line item attachments. 

Include record 
information as 
attachment 

Select this check box if the notification should include the record 
information as an attachment. 

Override default If you have specified a default record format on the General tab, you 
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format can use this check box to override the default format. For example, 
you can use the General tab to specify that the default record format 
for both email notifications and records saved in the Document 
Manager be in PDF format. If necessary, you could then use the 
Override default format check box to override the format and choose 
Custom for the notification only. 

Format 
PDF/Custom 

Select the form. 

The attachments are PDF or a custom format. 

BI Publisher (BIP) Custom Prints are available to be selected for the 
Notification format. 

For custom format, select the print format defined for the business 
process. 

Note: Unifier sends emails for reverse auto-population failures. There 
may be cases when email notifications are not sent. For such cases, you 
can find the reasons for the reverse auto-population (RAP) failures in the 
audit log of the business process record. In addition, on occasion Unifier 
generates error codes for reverse auto population failures which can be 
used to troubleshoot the reverse auto population failures.  

Set up auto-creation for a non-workflow BP or planning item 

On the Auto-Creation tab, you can set up the auto-creation of another record or line item for the 
business process you are setting up. You can also set up the auto-creation for other business 
processes that will be spawned by this business process. 

For information about auto-creating business processes, see Auto-creating a Business 
Process record or Planning Item Based on conditions or frequency (on page 288). 

Note: DEs of type Rich text are not available to create conditions for 
auto-creation elements in a BP Setup (Company Workspace > BP Setup 
and Shell > BP Setup). 

To set up auto-creation of a non-workflow business process or planning item 

1) Click the Autocreation tab. 

2) Under Settings for auto creation of [name of the business process, planning item, or line 
item you are setting up], in the Creator field, click the Select button and choose the name of 
the auto-creator. 
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3) Under the section Settings for auto-creation of other business process records or line 
items, select the BP creator element under the upper or detail form. 

4) (Not an option for line item creation.) In the Assignee/Creator field, click the Select button 
and choose the name of the user or group who should assume ownership of the 
auto-created record. 

5) Ignore the Duration field. 

6) To create the conditions that will trigger the auto-creation, select the Enable condition 
based auto creation check box and continue as follows: 

Note: If you leave this check box un-checked, the BP, planning item, or 
line item will be available for manual creation only. 

a. To add a trigger condition, click the Add button. The Add Condition window opens. 

b. On the General tab, enter a name for the trigger and a description. 
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c. Click the Query tab. 

The Query tab is where you will define the conditions the data must meet before Unifier 
will auto-create the new business process record or line item. 

In the upper section of the window, you can specify that a field on the business process 
form: 

 Must meet a certain criteria or value 

 Must meet a certain value based on a formula using the numeric fields on the form 

Click the Add button to specify a condition for a field on the business process form. Click 
the Add Formula button to create a formula that the value of the field must meet. Use the 
information in the Queries section to complete the query. 

In the lower section of the window, you can specify a date condition that will trigger the 
auto-creation. Use the information in the Queries section to complete the query. 

Notes:  

Date condition triggers are not available for line item auto-creation. 

About Date Triggers:  

 If you want to create a continual date trigger condition, make sure you 
use the Date Trigger Condition section of the window to create it. 
Although you can also create a date trigger using a formula in the 
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upper section of the window, Unifier will process the triggers 
differently. 

 The conditions you specify in the upper section of the window will be 
processed only once, when the user clicks the Finish Editing button 
on the form. However, the date conditions you specify in the 
DateTrigger Condition section will be processed daily. 

 This behavior is important to consider when you are creating a date 
condition that occurs in the future. A date trigger specified under the 
Date Trigger Condition section will be processed daily, and will, 
therefore, "catch" the trigger condition when the future date occurs. 

d. Click OK. 

7) If you want the auto-created record or line item to include attachments from the original 
(source) record, select the Include Attachments check box. 

Note: This step is not applicable for Document type business processes. 

If you select this option: 

 Any record-level attachments made to the source record will appear at the record 
level of the destination record. 

 Any attachments made to the line items of the source record will appear at the line 
item level of the destination record. 

8) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation 
normally creates, select the Bypass initiation step during auto creation checkbox. 

If you select this option, the auto-created BP or planning item will skip the initiation step and 
will appear in the user’s Tasks Log and BP Log or Planning Item Log with the status that was 
specified on the General tab of the business process setup window. For more information, 
see Auto-creating a Business Process record or Planning Item Based on conditions or 
frequency (on page 288). 

9) If you want to copy any records that are linked to the original record, select the Copy Linked 
Records check box. 

10) (Not an option for line item creation.) If you are creating a record from a detail form, you can 
group line items into a single record. To do so, select the Enable grouping of line items 
when autocreating records from line item tabs check box. 

In the Group By field, click Select and select the data element (or elements) you want to 
group by. If the values in these data elements match for any of the line items, Unifier will 
auto-create a single record for them. For more information, see Grouping line items into 
single records (on page 289). 

Note: If you leave the Group By field blank, Unifier will auto-create a 
single record containing all the line items on the source record. 

11) Click Apply to save your changes, or OK to save and exit the window. 

Note: You can find the reasons for the auto-creation failures in the audit 
log of the business process record. In addition, on occasion Unifier 
generates error codes for auto-creation failures which can be used to 
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troubleshoot the auto-creation failures.  

Set up record and line item copy options 

Use this feature to set up copy options for users when they copy a record with line items and 
references. 

The options you specify here will give the Unifier user the ability to copy specific (rather than all) 
line items, as well as the ability to include attachments and linked records, and retain or remove 
references to auto-created records. 

To set up these options, you must create a condition the data element must meet in order for the 
line item to be included for these copy options. 

For example, you could create a set of options specifying that all line items with a status of 
"open" be copied, and their attachments be included in the copy. Using this example, you could 
set up a weekly meeting minutes business process that automatically generates action item 
business processes for each task that arises from the meeting. Using these copy options, you 
could roll over action items that are still open to the next week’s meeting minutes. 

At runtime, the options you set up here will be given to users to choose from when they copy 
records. The following shows a list of BPs where the Record Copy option is supported:  

Type Sub-type Classification 

Cost Line item with WBS Code Generic 

Transfer 

Base Commit 

Change Commit 

General Spends 

Line Item with Multiple Codes Generic 

Transfer 

Base Commit 

Change Commit 

General Spends 

Line Item Generic 

Transfer 

Line Items to filter 
company Business 
Process records 
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To set up copy options 

1) Open the business process for which you want to set up the copy options. 

2) Click the Record Copy tab. The Record Copy Setup window opens. 

3) Click the Add button. The Copy Condition Setup window opens. 

4) In the Name field, enter a name for this copy setup. The name should be unique, and can be 
up to 250 characters long. 

This is the name that will appear on the list of copy options the Unifier user will see when 
they copy a record or line item. 

5) (Optional) In the Description field, enter a description of what this setup does. 

Tip: It’s a good idea to include a precise description of what the copy 
options are for the setup. This description will appear on the list of copy 
options the Unifier user will see when they copy the record, and a good 
description will tell them exactly what will be copied. You can enter up to 
4000 characters. 

6) Under the Condition area of the window, click the Add button. The Query Condition window 
opens. 

7) In the Data Element field, select the of the field on the line item form that you want to use to 
identify which lines items can be copied. 

8) In the Condition field, select the operator Unifier should use to test the data element you 
selected. 

A condition is a state or restriction the value in the data element (field) must meet. A 
condition of the value might be that it must be equal to a certain number (maybe 10) or that it 
must contain a certain string of letters (such as "due date of"). 

If the data element meets the condition you specify, Unifier will include this line item on the 
list the user can choose from. Use the information in the Queries section to complete the 
query. 

9) Click OK. 

10) On the Copy Condition Setup window, specify these additional copy options as shown in 
the table below. 

11) Click OK. 

Select this 
checkbox: 

To: 

Include 
Attachments 

Include attachments in the copy operation. 

Copy Linked 
Records 

Include any linked records in the copy operation. 

Retain 
reference to 
auto-created 
business 
process 

Keep the references to business processes that were auto-created from 
the upper form. 
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records on 
record upper 
form 

Retain 
reference to 
auto-created 
business 
process 
records on 
line items 
across all 
tabs 

Keep the references to business processes that were auto-created from 
the line item (detail) form. This applies to all line items from all tabs. 

Single-record business processes 

Single-record business processes store information that you use repeatedly in your projects. 
Think of them as file cabinets where you keep things like: industry standards; federal, state, and 
local regulations and statutes; policies; and FAQs. You can have multiple single-record business 
processes in a project, each with its own information focus. From these single-records you can 
auto-populate fields in business processes, including constant values. 

To facilitate single-sourcing of your data, create the single-record business process in the project 
or shell template prior to creating your project from the template. When you clone a project or 
shell template, you have the option to select BP Setup, which not only copies all business 
process setups, but all single-record business process records and their data. 

Data copied from single record business processes includes: 

 Attachments to records and line items, if applicable 

 All data pickers (Business Process, Configurable Managers, Shell Manager, User Attributes) 

 Any other pickers except business process pickers 

 Linked elements 

 Permissions associated with the single-record business process 

Copying a single record business process does not include: 

 Business process pickers 

 Linked records 

 Linked mail 

 General comments 

You can also use CSV or web services to clone a shell or project template that contains the 
single record business process. 

To create a single-record business process 

Before you begin: 



Unifier Modules Setup Administration Guide

252

 Ensure you have Setup permission for the business process. See Edit user or group 
permissions using Access Control (on page 179) 

 Follow the directions to set up a non-workflow business process. See Basic 
non-workflow set up in General tab and Settings tab (on page 241) 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

3) In the left Navigator, click Projects (Standard) > [project] or Shells > [shell] and on the 
right pane, open the template in which the single-record business process resides. 

4) In the left Navigator, click Information > General. 

5) On the right pane, open the single-record business process record and complete all required 
fields. 

6) Click Save or Finish Editing, as appropriate. Both actions save the record, but Save leaves 
the record in Edit mode, and Finish Editing leaves the record in a read-only state. 

Caution: If you click Finish Editing and the record is in a terminal status 
you will not be able to edit that record again. 

7) Assign record permissions as appropriate. 

Set up View Forms for Non-Workflow Business Processes 

As an Administrator, for non-workflow BPs, you can set up different view forms such that details 
that are relevant to users are seen.  

Note: Up until now, a non-workflow business process had only one form 
(Action form) that held all the data.   

Assigning view forms to non-workflow BPs enables administrators to control the visibility of 
certain data to various users or groups. 

You can create view forms for all: 

 Non-workflow BPs regardless of the type. 

 Non-workflow BPs existing at both Project and Company Level 

 Non-workflow BPs of both Single Record and Multiple records 

Furthermore, the validations applicable to all: 

 Non-workflow BPs that have one Action form, only. 

 Non-workflow BPs that have multiple view forms. 

To add, remove, or edit view reports open the non-workflow BP and follow the instructions in the 
Set up View Forms for Workflow Business Processes (on page 280) section of this guide. 

If users have access to a deployed view form and that view form is deleted in uDesigner, then at 
runtime, the a user opens the BP record, Unifier checks that user's permission to any of the BP 
view forms that exist in the setup. If the use does not have access to any of the BP view forms 
that exist in the setup, the Unifier displays the Action form for that BP in view-only mode. 
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Important information about deleting View Forms 

As indicated in the Unifier uDesigner User Guide, you can design a BP form (in the Staging 
environment), add view forms associated with a BP form design to the Business Process Setup 
(View Forms tab), assign permissions to users and groups for the individual view forms, and 
deploy the view forms so they can be accessed through the record preview in the log (Logs and 
Company Logs) for viewing record details. 

Due to the system limitations, an anomaly occurs when you delete a view form from the 
Business Process Setup. The following explains this anomaly: 

You have created and deployed the following view forms for a BP form ABC: 

 VF01 

 VF02 

 VF03 

You decide to delete one of the view forms. As a result, you navigate to uDesigner, delete the 
view form (for example, VF01), and ensure that the deleted view form has been remove from the 
Business Process Setup. 

You decide to add a new view form (for example, VF04), for the BP form ABC, so you proceed 
to add the new view form in uDesigner and deploy the new view form, VF04. 

At this point, due to the system limitations, the system will automatically add the newly created 
view from, VF04, to the Business Process Setup using the users and groups assignments 
originally assigned to the deleted view form, VF01. Furthermore, the availability of this added 
new view form (in the Business Process Setup) goes against the method that is used to deploy a 
new view form. 

As an administrator, you must ensure that in such scenario, you open the newly created view 
form and assign appropriate permissions. 

Additional information about View Forms for Non-Workflow Business Processes 

If a view form that users have access to gets deleted in uDesigner, then at runtime (when a user 
opens the Non-Workflow BP record), Unifier checks to see if the user has permission to any of 
the view forms that exist in the BP Setup, or not. If the user does not have access to any of the 
other view forms, then Unifier displays the default form, the Action form, in view mode. 

Set up Record Properties for Non-Workflow Business Processes 

In both Non-Workflow BPs and Workflow BPs (at the company, shell, and project levels) you 
(the administrator) can use the Record Properties tab to establish:  

 The availability or visibility of the BP form properties tabs for users and groups. 

 The ability to download attachments when users and groups access the BP records in user 
mode. 

The Record Properties tab has the following sections: 

Top: For setting up restrictions (setting restriction is done through Edit Restrictions) 
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Left: For Upper Form and Line Item (detail forms) properties and setting up restrictions for 
downloading attachments from the Upper Form and Line Items (detail forms). The left 
section displays all of the record tabs seen in both upper and detail forms. In case of Simple 
type and Text type BPs, only the upper form properties tabs will be seen. The Upper Form or 
Line Item properties options that were hidden in uDesigner will not be displayed. 

Right: Users info (users or groups who cannot see the properties) 

The Record Properties window displays read-only view of the all the users and groups who are 
restricted to the visibility of selected tabs, or to download of attachments for selected tabs, in 
Edit Restrictions window. You can duse the Edit Restrictions button to apply restrictions to 
users and groups. 

Restricting the Audit Log and Workflow Progress options below will result in the automatic 
update of the same options in Permissions Settings of Access Control. The same operation 
applies in reverse. 

The Attachments in Upper Form Properties section will not be shown for the system-defined 
Line Item tab in the Document type BP.  

The additional section Do not allow download of Attachments will show the users and groups 
who are restricted to download the attachments from Upper Form or Line Item tabs in the 
business process record, when the attachments are visible. 

The first tab seen in the Do not allow download of Attachments is the Upper Form 
Attachments followed by the Line Item tabs names (for example Guages & Meters or 
Components) which will be in same order as seen in the Line Item Properties. 

The Upper Form Attachments tab will not be shown for the Text type and Document type BPs. 
Additionally, the  system-defined tab will not be shown for the Document type BP, under the Do 
not allow download of Attachments section. 

The tabs seen in the Upper Form and Detail Form properties will be based on each BP type. 

The tabs shown in Upper Form and Line item Properties will be in the same order seen in the 
BP record at run time. 

The Upper Form Properties and Line Item Form Properties which are already hidden in 
uDesigner will not be shown in this list. 

Example 

If Linked Records and Linked Mail tabs, from the Upper Form Properties, are set to be 
hidden in uDesigner > Record Properties, then those two tabs will not be seen in the BP 
Setup under Upper Form Properties. Similarly, if the user-set Attachments tab in the Upper 
Form Properties is hidden in uDesigner > Record Properties, then in the BP Setup > Record 
Properties the user will not be able to see the following tabs: 

 Do not allow download of Attachments 

Upper Form Attachments 

 Upper Form Properties 

Attachments 
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Adding tab visibility and download of attachments restrictions to users and groups 

You can add restrictions to the users and groups through the Edit Restrictions option. The 
restricted users and groups will be seen on the right-hand block for the property selected on the 
left-hand side. 

Edit Restrictions window: 

When you click the Edit Restrictions option, a window displays which enables you to select 
or add user and groups and assign attribute form restrictions. The Select Users/Groups
block (the left pane of the window) will be empty if there are no existing restrictions; 
otherwise, the block will list the existing restricted users and groups. Use the Remove option 
to remove the users and groups listed in this block. You can select one or more users or 
groups and select the Remove option to remove users or groups from the tab visibility 
restrictions. 

In the right-hand section of the window, you can access and hide all of the following form 
properties: 

Hide All Upper Form Properties

 Attachments    

 Do not allow download of Attachments 

 Comments 

 Linked Records 

 Linked Mail 

 Workflow Progress 

 Audit Log 

 Reference Records 

Hide All Line Item Properties

 <Line item tab1 name> Attachments   

 Do not allow download of Attachments         

 <Line item tab2  name> Linked Records 

 <Line item tab2 name> Attachments 

 Do not allow download of Attachments 

 <Line item tab2 name> Linked Records 

The Detail Form Attributes will be shown based on the Line Item tabs available in the 
selected business process. Additionally, users and groups can be restricted to download the 
attachments only from the business process record. 

If a single user or group is selected on the left-hand side, then the selected user or group's 
existing restrictions will be shown. 

The Cancel and Save options will remain disabled if you do not make any changes in the 
right-hand block. If you select a user or group and change the restriction options, the the 
Cancel and Save options will be enabled. The Cancel and Save options enable you to save 
or cancel the changes that have made in the right-hand block. 

Once you close the Edit Restrictions window, the restricted users and groups will be added 
in Record Properties window. 
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You can select multiple rows in Users/Groups section, edit the restriction check boxes, and 
save or cancel your changes.  

If multiple users or groups (on left-hand block) are selected, then the existing restrictions will 
not be shown in the right-hand block. 

In the Attachments case, a user who has restrictions to Download will be able to view or 
access the attachment but cannot download or save to a local system. 

Users/Groups window 

When you click Add, the User/Group window opens. This picker window displays all of the 
users and groups that are available and selected. Once the users and groups are added, you 
can select the users or groups (from the left-hand block) and set the hide permissions for the 
form attributes (in the right-hand block). 

Note: Users or groups cannot be removed from the User/Group Picker 
window. You can use this picker window to add additional users and 
groups to the Edit Restrictions window. You can remove your added 
users and groups by selecting one or multiple rows in the Selected 
Users/Groups block. 

After you add restrictions in the Edit Restrictions window the left-hand block displays the list 
of all users and groups with restrictions to the form attributes. When you select a form 
attribute such as Audit Log or Comments, the right-hand block displays the list of all the 
restricted users and groups. A user who has restricted access to selected record attributes 
like Audit Log, Comments, or Linked Mail viewing in the business process record will not 
see those tabs. 

Example 

User U1 has "Hide Upper Form Properties - Comments and Linked Records." At run time, 
when user U1 creates a new business process record or opens an existing record, 
both the Comments and the Linked Records tabs will not be seen in the record. 

Attachments

When a user is restricted to only the download of the attachments, in user mode the user can 
view the attachments in the business process record but will not be able to download them. 
The Download option is removed from Attachments tab and also in Review window. 

In this case a restricted user who views the attachment in native view the attachment will 
open in Unifier viewer, in read-only mode. 

A restricted user will not be able to receive the attachments through email notifications 
received from a business process record for which the user has restrictions to download 
attachments. 

Line item Attributes

You can assign restrictions to users and groups for the Detail Form properties (Attachments 
and Linked Records for each Line Item tab). These additional Detail Form attributes will be 
seen only for the business processes that have the Detail Form defined in them. 

The Detail Form properties seen in the Record Properties window will vary for each business 
process and is based on the design, in uDesigner. 
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Users and groups can be restricted to download attachments from the Line Item tab, similar 
to the Upper Form, as described in the Attachments section above. 

Additional information

Users and Groups who have permissions to "Hide Record Audit Log" and "Hide Task Statuses" 
are added to the restricted users and groups viewers list in the "Record Properties" tab, in the 
business process setup. 

All of the record level and Line Item tab restrictions are available for all business processes 
(company, shell, and project levels) that supports standard UI. 

The restrictions are applicable to all users or creators, task assignees, step editors, record 
editors, and CC'd users who are part of the workflow in the record. 

Visibility of tabs will be applicable to both Action and View Forms when user has tab restrictions 
to the BP. 

For Non-Workflow BPs, "Workflow Progress" (under the Upper Form properties) will not be 
available in the Record Properties, both at the design and at the setup level. 

For Company-level BPs, "Linked Mail" will not be available in Form Properties. 

For Simple and Text-type BPs, the option to hide the Detail Form properties will not be available. 

For Document-type BPs, "Attachments" will not be seen in Upper Form Properties and system 
defined tab in Line Item Properties. 

Note: The additional restrictions are not applicable to bid users. Bidders 
will be able to see all the attributes even though requestor have 
restricted access. 

When certain form properties are hidden in uDesigner, for a business process, then those form 
properties will not be shown in the Record Properties tab in the BP setup. 

Users or Groups who have record tabs view restrictions, in the BP setup, then at run time those 
selected tabs will not be seen in the business process record. This is applicable to both 
company sponsored and partner users. 

Projects or shells do not show Rich Text type DEs in the following scenarios:  

 When creating conditions for auto-creation elements in a BP setup. 

 When editing Gate settings and setting up Gate Condition Elements. 

Assigning restrictions to users and groups will impact their ability to see the record properties 
tabs (tabs in the right-hand pane, when the user opens a record) of the following nodes: 

 Logs 

 Drafts 

 Tasks 

 Master Log 

 Company Log 

 Single-Record BP Log 

 Portal BP Log 
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Set up Permissions for Record Properties Tab (Non-Workflow) 

To set up permissions for the Record Properties tab:  

1) Go to Company Workspace tab and switch to the Admin mode. 

2) Click Company Sponsored Shells to expand and click to select the <BP NAME> and open 
the BP (Workflow or Non-Workflow). 

3) Click Setup to expand. 

4) Click Business Process, open <SETUP NAME>, and click the Records Properties tab. 

Setting Up a Workflow Business Process 

These procedures are applicable to project, shell, and company-level workflow business 
processes. 

Important information 

Once a workflow record is created by using any workflow schema (unique combination of Setup 
Name + Workflow Name), the workflow record continues to reference the workflow schema even 
if the Status of the workflow schema has been set to Inactive. 

This condition includes workflow records that are in the following statuses: 

 Draft 

 Initiation Step (I-Step) 

 Also, this condition includes any workflow record at any other step in the workflow.  

If there is an Active BP Template, then the Template continues to create records referencing the 
Inactive workflow schema. For instructions on creating a template, see Create BP Templates 
and Schedule BP Creation. 

Basic workflow set up in General tab 

To set up a workflow business process 

1) From the Business Processes log, select a BP and click Open. The Setup log opens. 

2) Click New. The Select Workflow window opens. 

3) Click the Workflow selection list and click OK. The Business Process Setup window opens. 

Note: You may configure a setup for multiple workflows by repeating this 
procedure for each workflow available for the business process. 

4) Complete the General tab (see the table below). 

In this field: Do this: 

Setup Name Enter a unique name (required field). 

Description Enter an optional description of the setup. 

Help File Allows you to add a custom PDF help file. 

Auto Creation The workflow to use for the auto-created BP. Workflow Setup 
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Workflow in General and Setting Tabs (on page 266). 

Auto Creator 
Select the name to use as the creator of any auto-created 
records of this BP. 

Auto Action 
Select the step to use as the first step in the workflow of 
auto-created records. 

Send error 
notification to 

Specify the user to receive error notifications. 

Default Record 
format for Notification 
and Document 
Manager 

This option has two purposes:  

 If you want notification sent to users whenever a business 
process record is created or modified, use this option to 
specify the format in which you want the notification to be 
sent.  

 If you have checked the Save Record Information to 
Document Manager check box, use this option to specify the 
format in which the business process records should be 
saved. 

Selecting BIP Custom Print (Format > Custom) 

The following is a list of conditions applicable to BIP Custom Print.  

 Only Published BIP Custom print templates can be selected while setting up the Business 
Process; however, if you make any changes to the Published template and do not re-publish 
it to BI server, the selected template will continue to remain in the Business Process (BP) 
setup option. Any record information sent as email attachments will contain data from the 
last published version existing in the BI server. 

 If the BP setup has been done in a Project/Shell template, then when you update the setup 
information onto instances of Projects/Shells, the setup gets pushed. 

 If you delete the BIP Custom Print template selected in the BP Setup window, then the 
system removes the deleted BIP Custom Print template from the BP setup. 

 If the system does not generate the print output, for example due to server issues, then the 
email attachment, which contains the record information, generates an error message. 

 Custom Print template included in the BP setup can be exported in the Configuration 
Package. By virtue of tagged BP design, the corresponding BP Setup from the tagged Shell 
template will also be included. If the Custom Print Template is not tagged, then the 
Configuration Package export will result in an error. 
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Note: If the BIP Custom Print output could not be generated because of 
connection issues to BIP Server or inconsistencies in between Custom 
Print on Unifier and BIP Server, then notification emails for Business 
Process modification will have an "error.html" document (as an 
attachment) instead of a record information document. If the record 
information is Published to Document Manager, then a 0 KB document 
will be published to the Document Manager.   

Designate additional editors for Business Process records 

Normally, the editors of any record must be an assignee on the step of the workflow. However, 
there are times when a record may need editing by someone other than the step assignees. For 
example, the owner of a purchase order record should be able to attach revised documents to 
the PO at the end step of the workflow. Or, an engineer who has sent a task to an architect 
realizes that some drawings are missing from the record. The engineer should be able to attach 
the documents to the record, even though the task assignee is now the architect. 

The Settings tab is where you can designate non-assignee editors for business process records. 
(These editors must have permission to at least view the record.) Editors designated on this tab 
can open records and modify the upper or line item content of the record. Changes made by 
these editors are recorded in the audit log. Whereas step assignees will see the form that is 
attached to a step, the record editors you designate on this tab will see a specific form for 
editing. This form must be specified in uDesigner when the business process is created. 

Note: The editors you specify on this tab are record-level editors. You 
can designate additional editors at the step level when you set up the 
workflow. See Define the Business Process Workflow (on page 267) 

To designate additional editors for records. 

1) Click the Settings tab. 

2) In the Record Editor(s) field, click the Select button and choose the users or groups who 
should have editing privileges on this record. 

3) Click Apply to save these settings. 

Set up email notification for a workflow BP 

Use the Notification tab to set up automatic email notifications to users and groups whenever a 
non-workflow business process is created or modified, either manually, or via auto-creation, 
reverse auto-population, CSV, or integration. 

Note: If the business process has been designed to allow users to 
include additional users or groups in the email, the email notification will 
be sent to them as well. 

1) Use the information in the table below to complete the Notification tab. 

2) Click Apply to save your changes and OK to exit. 
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In this field: Do this: 

Send notifications 
to 

Click Select and choose those users or groups that should be 
notified whenever a non-workflow business process is created or 
modified. 

Notify creator on 
record modification 

By default, this check box is checked. If you do not want the BP 
creator to be notified when the business process is modified, 
de-select this check box. 

Notify Assignee of 
Record 
Modification 

Select this check box if you want the assignee(s) on a step to be 
notified whenever the business process record is edited. 

Notify Cc on 
Record 
Modification 

Select this check box if you want the users who have been Cc’d 
on a step to be notified whenever the business process record is 
edited. 

Notification 
triggering events 

The fields you select here will tell Unifier when to notify the users 
or groups. 

Edit Upper Form 
Select this check box if notification should go out whenever the 
upper form of a record is edited. 

Add/Edit/Delete 
Line Items 

Select this check box if notification should go out whenever a line 
item is added to the record, edited, or deleted from the record. 

Add General 
Comments 

Select this check box if notification should go out whenever 
comments are added to a record. 

Add/Remove 
Attachments 

Select this check box if notification should go out whenever 
attachments are added to or removed from a record. 

Attachments 
The fields you select here will tell Unifier how to add attachments 
to the record. 

Include both record 
and line item 
attachments 

Select this check box if the notification should include both the 
record and the line item attachments. 

Include record 
information as 
attachment 

Select this check box if the notification should include the record 
information as an attachment. 

Note: Unifier sends emails for reverse auto-population failures. There 
may be cases when email notifications are not sent. For such cases, you 
can find the reasons for the reverse auto-population (RAP) failures in the 
audit log of the business process record. In addition, on occasion Unifier 
generates error codes for reverse auto population failures which can be 
used to troubleshoot the reverse auto population failures.  
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Set up auto-creation for a workflow BP 

On the Auto-Creation tab, you can set up this business process to automatically create another 
record or line item for this business process. You can also set up this business process to 
automatically create other business processes, planning items, or line items if the form includes 
a creator element. 

For information about auto-creating business processes or planning items, see Auto-creating a 
Business Process record or Planning Item Based on conditions or frequency (on page 
288). 

Note: DEs of type Rich text are not available to create conditions for 
auto-creation elements in a BP Setup (Company Workspace > BP Setup 
and Shell > BP Setup). 

To set up auto-creation of a workflow business process 

1) Click the Autocreation tab. 

2) Under Settings for auto creation of [name of the business process, planning item, or line 
item you are setting up], complete the following fields as shown in the table below (at the end 
of this topic). 
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3) Under the section Settings for auto-creation of other business process records or line 
items, select the creator element under the upper or detail form. 

4) (Not an option for line item creation.) In the Assignee/Creator field, click the Select button 
and choose the name of the user or group who should assume ownership of the 
auto-created record. 

5) (Not an option for line item creation.) In the Duration field, specify the duration of the 
workflow for the auto-created record. 

6) If you want the auto-created record to include attachments from the original (source) record, 
select the Include Attachments check box. 

If you select this option: 

 Any record-level attachments made to the source record will appear at the record level of 
the destination record. 

 Any attachments made to the line items of the source record will appear at the line item 
level of the destination record. 
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Note: This step is not applicable for Document type business processes. 

7) (Not an option for line item creation.) If you want to bypass the I step that this auto-creation 
normally creates, select the Bypass initiation step during auto creation. 

If you select this option, the auto-created BP will skip the initiation step and will appear in the 
user’s BP log at the appropriate step in the workflow. (For more information, see 
Auto-creating a Business Process record or Planning Item Based on conditions or 
frequency (on page 288).) 

8) If you want to copy any records that are linked to the original record, select the Copy Linked 
Records check box. 

9) (Not an option for line item creation.) If you want to group line items into a single record, 
select the Enable grouping of line items when autocreating records from line item tabs
check box. 

In the Group By field, click Select and select the data element (or elements) you want to 
group by. If the values in these data elements match for any of the line items, Unifier will 
auto-create a single record for them. For more information, see Grouping line items into 
single records (on page 289). 

Copying line items is limited to a single picker or a single referenced data element.  

Note: If you leave the Group By field blank, Unifier will auto-create a 
single record containing all the line items on the source record. 

10) To create the conditions that will trigger the auto-creation, select the Enable condition 
based auto creation check box and continue as follows: 

Note: If you leave this check box un-checked, the BP, planning item, or 
line item will be available for manual creation only. 

a. To add a trigger condition, click the Add button. The Add Condition window opens. 

b. On the General tab, enter a name for the trigger and a description. 
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c. Click the Query tab. 

The Query tab is where you will define the conditions the data must meet before Unifier 
will auto-create the new business process record. 

In the upper section of the window, you can specify that a field on the business process 
form: 

 Must meet a certain criteria or value 

 Must meet a certain value based on a formula using the numeric fields on the form 

Click the Add button to specify a condition for a field on the business process form. Click 
the Add Formula button to create a formula that the value of the field must meet. Use the 
information in the Queries section to complete the query. 

In the lower section of the window, you can specify a date condition that will trigger the 
auto-creation. Use the information in the Queries section to complete the query. 

Notes:  

Date condition triggers are not available for line item auto-creation. 

About Date Triggers: 

 If you want to create a continual date trigger condition, make sure you 
use the Date Trigger Condition section of the window to create it. 
Although you can also create a date trigger using a formula in the 
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upper section of the window, Unifier will process the triggers 
differently. 

 The conditions you specify in the upper section of the window will be 
processed only once, when the user clicks the Send button on the 
form to send the form to the next step in the workflow. However, the 
date conditions you specify in the Date Trigger Condition section will 
be processed daily. 

 This behavior is important to consider when you are creating a date 
condition that occurs in the future. A date trigger specified under the 
Date Trigger Condition section will be processed daily, and will, 
therefore, "catch" the trigger condition when the future date occurs. 

d. Click OK. 

11) Click Apply to save your changes, or OK to save and exit the window. 

In this field: Do this: 

Setup 
Specify the workflow setup that the auto-created business 
process or planning item should use. 

Creator 
Click the Select button and choose the name of the person or 
group who should assume ownership of the auto-created 
record. 

Action 
Specify the step in the workflow that should be used as the 
first step in the workflow of the auto-created BP or planning 
item records. 

Note: You can find the reasons for the auto-creation failures in the audit 
log of the business process record. In addition, on occasion Unifier 
generates error codes for auto-creation failures which can be used to 
troubleshoot the auto-creation failures.  

Workflow Setup in General and Setting Tabs 

This section explains how to set up workflows. Workflow setups can be time-consuming. Unifier 
offers other options of copying or importing workflow setups. To use these options, see Copying 
Workflow Setups from Other Schemas (on page 295) or Importing Workflow Setups from 
One Environment to Another (on page 301). 

1) In Administration mode: 

 To set up a workflow in a company level business process, click the Company 
Workspace tab and, in the Navigator, go to Company Workspace node > Business 
Process Setup. 

 To set up a workflow in a project/shell level business process, click the project or shell 
tab and, in the Navigator, go to Setup > Business Process. 

2) On the right pane, double-click the business process you want to set up. 
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3) In the Navigator, click Workflow Setup and on the right pane, double-click the name of the 
workflow you want to set up. 

The Workflow Setup window opens. 

4) Complete the General tab for the workflow. See the table below. 

5) Click the Settings tab to configure the workflow. Define the Business Process Workflow
(on page 267). 

You can filter assignees (Assignees block) and use some specific conditions on filtering the 
users.  

To create the conditions you must choose among the list of the user attributes that are 
available. After you select an assignee, from the Assignee drop-down list, for the selected 
workflow step, click Define (next to the Additional conditions to filter assignees option) to 
define the additional conditions in the pop-up window. When finished, click Add and then 
click the drop-down field and select: 

 User Attributes from the company (Company Workspace): Represented with a prefix 
"Company/" 

 User Attributes defined at project-level or shell-level: Represented with a prefix "Shell/" 

The same conditions apply to Allow Cc field. 

When the setup is complete, return to the General tab and click the Error Check button. This 
validates the setup, including checking that all steps have assignees. An error window opens 
identifying any errors that will prevent the setup from being activated. 

If there are no errors, click OK in the Setup window. You will be prompted to activate the BP. 
Click Yes to activate the BP and make it available to users, or click No to keep the BP inactive 
until a later date. 

In this field: Do this: 

Setup Name Enter a workflow business process setup name. 

Description Enter an optional description of the workflow setup. 

Status Select Active or Inactive. 

Error Check 
Click to check the workflow for errors when the 
workflow setup is complete. 

Default format of record 
information attached to email 
notification 

Select PDF of Custom. If you select Custom, click 
Add to choose the custom print format. 

Define the Business Process Workflow 

In the Settings tab of the Business Process Setup window, you can configure the workflow 
details. The workflow step settings are arranged in a tree structure, showing all of the steps. 
From here you can set up the overall workflow setup, individual step setting, steps that lead to 
conditional routing, links with auto-creation of business process, and sub-workflow settings. 
These procedures are applicable to project- and company-level workflow business processes. 
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Overall Workflow Settings 

The following describes the settings for the overall workflow. Select the top option in the left 
navigation pane to access these settings. Click the scroll bar on the right to scroll down the 
window and view all fields. 

In this field: Do this: 

Enable Workflow Duration 
When Yes is selected, records created with 
this instance will be marked as late when the 
defined amount of time passes. 

Workflow Duration 
You can optionally set the duration of the 
workflow. 

Override Workflow Due Date 

User can override the due date for the 
workflow. Be sure to select Yes for this option 
if you are using Scope Management and have 
selected Enforce Activity Finish Date for the 
Record Due Date for the activity business 
process. Setting up Scope Management for 
Activities (on page 544). 

Project Phase (Project-level BPs only) 
Setup is valid only during the specified project 
phase. This is not applicable for company level 
BPs. 

Notify users or groups on workflow 
completion 

Selected users or groups will be notified once 
the workflow is complete. 

Settings for Standard Workflow Steps 

This setup is for standard workflow steps. The Settings tab displays the steps that are available 
for the selected BP, and therefore will vary depending upon how the BP has been designed in 
uDesigner. Not all selections discussed below will be available for all workflow steps. In addition, 
depending on the BP design, not all fields will be editable. The following is an example of a 
creation step. Click the scroll bar on the right to scroll down the window and view all fields. 

Select a workflow step to access these settings. 

About Create and End Steps 

The Create and End steps in a workflow have unique characteristics you should be aware of 
during the design and set up of the workflow. 

In uDesigner In Unifier Administration 
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In uDesigner In Unifier Administration 

For the 
Create 
step 

You can rename the Create step to 
something else if you want. 

You can place only outgoing links on 
the Create step. 

You can attach only action forms to the 
Create step. 

You cannot send a link back to the 
Create step. If the workflow requires 
that a form be sent back to the creator 
(Create step), add a separate "back 
step" or "revision step" that will send the 
form back to the creator. 

You cannot "Cc" users on the 
Create step. 

A workflow cannot send a link 
back to the Create step. If the 
workflow requires that a form be 
sent back to the creator (Create 
step), the workflow design 
should include a separate "back 
step" or "revision step" that will 
send the form back to the 
creator. If your workflow includes 
such a "back step," specify 
match step <Creation> for the 
Assignees on that step. 

For the 
End step 

You cannot rename the End step. 

You can place only incoming links on 
the End step 

You can attach either an action form or 
a view form to the End step. 

You can "Cc" users on the End 
step. 

You can send the form to the 
editors who have been assigned 
to the form. 

You can add comments to a 
business process at the End 
step, and also at any status in a 
workflow, including 
"terminated.". 

In this field: Do this: 

Step Name

You can click the link to view a graphical representation of the workflow, 
with the current step highlighted. Be aware that workflows can often be 
very large. If you are viewing a large workflow, you can enlarge the 
canvas screen to make it easier to see all the steps to the workflow 
progression. 

To enlarge the canvas, you can drag the window sides until the workflow 
fits in the window, or you can quickly maximize the canvas. To maximize 
the canvas, click the icon in the upper-right corner of the window. To 
restore the canvas window to its normal size, click the Restore icon. 

Description Enter an optional description to help identify the workflow. 

Duration Choose the time length for this step. 
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In this field: Do this: 

Override 
Task Due 
Date 

Allows user to override due date for an individual task. 

Allow 
Decline 
Step Task 

Click Yes if you want the assignees to have the ability to decline an action 
on an assigned task. 

Enable 
Step for 
Integration 

Click the radio button if you want this step to be available for integration 
with an external system, such as Web Services. If you make the step 
available for integration, the user can use the external system to view a 
read-only copy of the BP at that step. 

Note: If you select this option, the Completion Policy field (see below) will 
be set to "Single," and the Assignment Policy field for the following step 
must be set to "Preassigned." 

Assignmen
t Policy 

For User Select (default), the individual who creates a record (such as an 
invoice) from this workflow instance can choose the users to assign to this 
task from the list of assignees for this step. For Preassigned, every user 
on the assignee list is automatically assigned to the step when the record 
is created. 

Assignees 

Select the users to assign to this step. These users will receive task 
notifications, instructing them to take action at this step. When you click 
the Select button, you can choose one these options: 

User Picker: Unifier displays the User/Group Picker window. Choose one 
or more users or groups to add as assignees. 

Dynamic: Choose a step in the workflow from the Select Step pop-up 
window. The assignees from that step become the assignees used on this 
step. You cannot choose Dynamic when adding assignees to the first step 
(Creation) in the workflow. 

You can constrain the list of assignees for this step by selecting the 
Additional conditions to filter assignees check box. To constrain the list of 
assignees, you need to create a query to filter the assignees using criteria 
you specify. To do this, click the Define button and specify a field 
comparison. For information on creating this type of query, use the 
information in the Queries section to complete the query. 

The filter conditions defined are used, as AND/OR, depending on the 
checkbox: Show results matching any condition (instead of All)
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In this field: Do this: 

Allow Cc 

Allows assignees to add cc users who will receive a view-only copy of the 
BP record. Choose one of the options: 

No: Does not allow sending copies to other users. 

Yes: Click Select to create the list of users or groups from whom the BP 
users can choose to Cc. (This option also activates the Allow Add Cc 
functionality.) 

Preassigned: Click Select to choose the users who will be automatically 
cc’d. No other users can be copied. 

Preassigned and Allow Add Cc: Click Select to choose the users who 
will be automatically cc’d. The Allow Add Cc option is set to Yes. 

Note: You cannot allow Ccs on the Create step. 

You can constrain the list of Cc users for this step by selecting the 
Additional conditions to filter Cc users checkbox. To constrain the list of 
Cc users, you need to create a query to filter the Cc users using criteria 
you specify. To do this, click the Define button and specify a field 
comparison. For information on creating this type of query, use the 
information in the Queries section to complete the query.  

The filter conditions defined are used, as AND/OR, depending on the 
checkbox: Show results matching any condition (instead of All)

Allow Add 
Assignees 

Allows assignees to add additional assignees in addition to those defined 
in the Assignees field to the current step. Assignees can add the 
additional assignees before accepting the task. This is done by clicking 
the Edit menu and choosing Add Assignees to Current Step. 

For example, user A has been sent a BP for review. User A wishes to add 
user B as an assignee to the review step as well. Before clicking Accept 
Task, user A chooses Edit > Add Assignees to Current Step and adds 
user B. User B is notified (depending on email preferences) of the new 
task. Both user A and user B can accept the task and participate in the 
review step of the workflow. 

Note: You cannot add assignees on the Create step. 



Unifier Modules Setup Administration Guide

272

In this field: Do this: 

Allow Add 
Cc 

This option has two functions: 

1. When the Allow Cc field is set to Preassigned and Allow Add Cc, this 
option is set to Yes automatically. It enables BP users at runtime to copy 
additional users on a BP step that already has a preassigned cc user. This 
is done on the action form of the BP during the regular workflow step by 
selecting the Cc button. Click Select and choose the users/ or groups that 
can be copied. 

2. This option becomes available (choose Yes or No) if Allow Cc is set to 
Yes. Similar to Allow Add Assignees, this option allows assignees to send 
a copy of the current step of the BP to additional users in addition to those 
defined in the Add Cc field. Assignees can add the additional cc users 
before accepting the task. This is done by clicking the Edit menu and 
choosing Copy Users to Current Step. 

For example, user A has been sent a BP for review. User A wishes to add 
user B as an assignee to the review step as well. Before clicking Accept 
Task, user A chooses Edit > Add Assignees to Current Step and adds 
user B. User B is notified (depending on email preferences) of the new 
task. User A can accept the task and participate in the review step of the 
workflow. User B can review the view-only copy. 

Note: You cannot add Ccs on the Create step. 
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In this field: Do this: 

Step 
Editors 

Optionally, you can define one or more editors per each defined step in 
the business process workflow setup. Editors are users who can edit the 
business process without being granted explicit record-level permission or 
as assignees of the step. This allows users other than the assignee to edit 
the business process record. If you are an Editor on a business process 
step, you can open and edit any record on the step. 

Editors can be added on these BP types: 

Line Item 

Cost (all types, including Lease and Line Item with Multiple Codes) 

Document 

Simple 

RFB 

Text 

The Editor functionality has these attributes: 

The user who is designated as an editor must have a minimum of View 
User Records to the BP log in question. 

All edits are done through the BP Log. 

Editors cannot edit a workflow record until the task assignee accepts the 
task, and saves the draft. 

Editors cannot be defined on the creation step of a business process. 

Editors can be defined on the end step. 

Editors can be defined on a workflow step only if the Completion Policy is 
Single. (Unifier will generate an error if Completion Policy is set to All 
Majority or Consensus.) 

Editor on a task receive notification each time a draft is created. 

If multiple editors and the assignee are editing the business process 
record draft, the data saved by the last update will overwrite all previous 
updates. 

Edits performed on the End step of a workflow business process affect the 
record directly, as no draft exists. 

Edits that occur on the end step are captured in the audit listing the editor 
who performed the edit. 

Edits performed by record editors appear in the Audit log. 

Note: You cannot assign editors on the Create step. 

Discussion 
Group 
(Classic 
View only) 

Specify assignees for discussion groups on the BP. 

Note: You cannot assign discussion groups on the Create step. 
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In this field: Do this: 

Step 
Revisiting 

If a step is rejected and sent back for clarification or editing, this option 
determines to whom the BP can be sent back (which assignees will be 
available for selection): 

Include only previous action takers: Only the assignee users who were 
selected when the workflow moved into that step originally are eligible to 
be reselected. 

Include all step assignees: All assignee users are eligible to be selected.

Note: You cannot specify step revisiting on the Create step. 

Completion 
Policy 

Choose one of the following: 

Single: If any assignee completes the task, no matter which action is 
taken, the record moves forward to the next step. 

All-Majority: All assignees are required to respond. If there is no clear 
majority, Unifier uses the resolving action to determine what path through 
the workflow to take. 

All-Consensus: All assignees are required to respond. If there is no 
consensus (all must agree on the action), Unifier uses the resolving action 
to determine what path through the workflow to take. 

Note: You cannot assign a completion policy on the Create step. 

Advance 
workflow 
when next 
step is 
determined

Select this option if you want to allow the user to choose that a step be 
completed without all assignees having to act on it, if the result can be 
determined without the assignee action. This is to prevent unnecessarily 
wait for all users to take action on the record before moving it to next step. 

Note: If you select the Completion Policy as "All - Majority" or "All - 
Consensus", then Unifier enables this checkbox. The checkbox is 
unchecked by default.  

Resolving 
Action 

This moves the step to either a following step, a previous step, or a 
conditional step that essentially "re-addresses" the task. This step must be 
completed before the workflow can continue. The assignees on this 
resolving action step can include the original task assignees and can also 
include new assignees. 

Note: You cannot assign a resolving action on the Create step. 

Overdue 
Policy 

You can choose to send late notifications to all assignees if the step 
passes its duration. 

Note: You cannot assign an overdue policy on the Create step. 
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In this field: Do this: 

Commentin
g 

You may select either of these options regarding commenting. These refer 
to the general comments on BP forms, as well as comments regarding 
individual file attachments on document-type BPs. 

Allow hiding of comments: Allows users to hide comments. The 
comments will remain as part of the record, and administrators and others 
with permissions can view the comments, which are not visible to others 
without the view permission. 

Allow deletion of comments: Allows users with permission to delete 
comments previously added to the BP record. 

Allow cc users to add general comments: Allows users copied on a 
step to add general comments without accepting the task. Not available on 
the end step. 

Notes: 

- You cannot include comments on the Create step. 

- Task assignees can also add general comments without accepting the 
task if they have been given the Add General Comments permission on 
the business process. With this permission, they can add a general 
comment to any BP record they can view (workflow or non-workflow), 
regardless of the workflow step (including the End step), and regardless of 
the assignee or Cc settings. For more information on this permission, refer 
to the Permissions chapter in the Unifier Reference Guide. 

Email 
Response: 
Enable 
response 
via email 

By default, this checkbox is unchecked. When enabled, this allows users 
who receive email that is sent out when a workflow reaches the current 
step to respond and take actions in Unifier via email. The checkbox 
appears on all workflow steps other than the creation step. The email that 
the user receives includes hyperlinks to workflow actions. 

When you are taking an action in a Workflow by way of email, if you 
include attachments, the attachments can be seen under the General 
Comments section of the BP record. 

Notes: 

- You cannot enable email response on the Create step. 

- To enable the attachment of files to email responses to workflow actions, 
this option must be selected as well as the Add Attachments option on the 
Options tab in the Action Form design in uDesigner. 
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In this field: Do this: 

Email 
Attachment
s: 

Include 
both record 
and line 
item 
attachment
s 

Include 
record 
information 
as 
attachment

Select to specify the content and format of email attachments. You can 
include business process record and line item attachments, as well as 
business process record information. Also, you can override the 
attachment format set in the General tab if necessary. 

Note: You cannot enable email attachments on the Create step. 

Override 
default 
format 

If you have specified a default record format on the General tab, you can 
use this check box to override the default format. For example, you can 
use the General tab to specify that the default record format for both email 
notifications and records saved in the Document Manager be in PDF 
format. If necessary, you could then use the Override default format check 
box to override the format and choose Custom for the notification only. 

Note: Hidden comments on a particular step in the Workflow and 
permission settings applied to certain data in the UI are retained in the 
custom print output. 

Email 
Content 

You can add additional information that will be sent out as part of task 
notification. 

Note: You cannot add additional information on the Create step. 

Cash Flow 
Default 
Template 

This option only appears in CBS code-based Base Commit business 
processes. It allows you to enable the auto-creation of a commitment-level 
cash flow curve at runtime for the business process record. The curve is 
based on the selected commitment-level cash flow template, and is 
created upon being sent from the step. 

Click Add and choose a template. 

For more information, see Setting Up Auto-Creation of Cash Flow 
Curves from Contracts (on page 293). 

Additional 
Information

Save 
Record 
information 
to 
Document 
Manager 

Select this check box if the record information (including BP comments 
and attachments) should be automatically saved at this step in the 
Document Manager. 
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About Completion Policies, Resolving Actions, and Their Statuses 

As administrator, you will set a completion policy on each step in a workflow. This policy 
determines when the step is complete and where the step proceeds from there. A step can be 
complete under the following conditions: 

 Any single user can accept a task and complete it, and the record will move forward to the 
next step. This is called a single completion policy. 

 All assignees to the task have responded to it and a majority has agreed on the action that 
moves the record forward to the next step. This is called an all-majority completion policy. If 
there is no clear majority on the action, Unifier will use a resolving action to determine how 
the record moves forward. 

 All assignees to the task have responded to it and all assignees have agreed on the action 
that moves the record forward to the next step. This is called an all-consensus policy. If 
there is no consensus on the action, Unifier will use a resolving action to determine how the 
record moves forward. 

A resolving action moves the step to either a following step, a previous step, or a conditional 
step that essentially "re-addresses" the task. This step must be completed before the workflow 
can continue. The assignees on this resolving action step can include the original task 
assignees and can also include new assignees. 

The statuses you see on this window are internal to Unifier and are used only to display the 
status of the workflow step relative to the completion policy. These statuses are: 

 Not Started: The assignee has not accepted the task. 

 In Progress: The assignee has accepted the task. 

 Locked: This status is used when the step has a single completion policy and one of the 
assignees accepted the task. This status denotes those assignees who were also assigned 
to the task, but because of the single completion policy, the task was locked and these 
assignees no longer have access to it. 

 View Only: This status indicates that this user was cc’d on the task, but is not expected to 
take action on the task. 

 Completed: This status is given to an assignee’s action if the task was finished and needed 
no resolving action. At any step, a task can have only one status of "Completed." 

 Closed: This status is given to an assignee’s action if the task was finished, but triggered a 
resolving action. The task will either return to a previous step, move forward to a next step, 
or divert to a conditional step, which will resolve the condition and move the task forward in 
the workflow. The step the action moves to for resolution will show a status of "Not Started." 
The number of times the task shows a "Closed" status indicates the number of times the 
step has been revisited. 
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To illustrate: 

Settings for Conditional Routing Steps 

Conditional routing steps are child nodes of the steps that lead to the condition routing. 
Auto-routing steps are shown with a diamond in front. Set up routing conditions on these steps. 

Remember that the next step in the business process workflow will be dependent upon the value 
entered on the BP for the data element. When you are finished setting up this conditional routing 
step, the Settings tab will show two steps that represent the two options for the step that follows 
this auto-routing step. You define both of them, but the BP will follow just one of them based on 
the trigger. 

In this field: Do this: 

Condition 
Name 

Name of the condition. Can be configured for each setup. 

Resolving 
Condition 

Select this checkbox if this routing action goes to a step that is meant to 
resolve the condition. 

Operator 

AND: All the conditions that are defined should be satisfied to satisfy a 
condition. 

OR: At least one of the conditions should be satisfied to satisfy a 
condition. 
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Trigger 
Elements 

Elements that are selected as part of design. Value of these elements will 
be resolved to route workflow. Can be one or more elements depending 
upon design. 

Settings for Auto-Create Steps 

Some steps include the ability to auto-create other records, depending on the status of the 
previous step. It is displayed as a child node from which the link is drawn out. For document-type 
BPs, the auto-creation of BP records will also copy attachments from the original record. 

In this field: Do this: 

Auto-create records 

Choose one of the following: 

As per workflow design: Auto-create BPs that were 
configured as part of the design in uDesigner. 

Based on user selection during execution: During 
execution, user will be given a list of BPs that are selected 
under workflow design in uDesigner. User can choose which 
BP record should be auto-created. 

Process list: Select a list of BPs for which the system will 
auto-create records during execution. 

Settings for Sub-Workflows 

A sub-workflow is a mini workflow within a main workflow and is part of the uDesigner workflow 
design. It is a grouping of one or more steps. A sub-workflow node will be child node of the main 
workflow and a sibling of other steps and sub-workflow nodes. 

In this field: Do this: 

Sub-workflo
w Name 

You can click the link to view the graphic of the sub-workflow. 

Description Capture more information about the sub-workflow. 

Enable 
Sub-workflo
w duration 

Similar to the main workflow. A duration can be set for the group of steps.

Overall 
Sub-workflo
w duration 

Similar to the main workflow. Overall duration for the group of steps. 

Override 
Sub-workflo
w due date 

Similar to main workflow. User can override sub-workflow due date 
during execution. 
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Set up View Forms for Workflow Business Processes 

A view form is the read-only version of a business process form that appears when the recipient 
first opens the form. Unifier uses the view form to show a preview of the record in the log. The 
view form enables the user to view record details. The fields in a view form cannot be edited. A 
view form may also be used when the designer does not want the user to be able to change the 
data on the form.  

Note: Business process forms can only be printed from a view form. 

As an Administrator, you can set up different view forms such that details that are relevant to 
users are seen. Up until now, there was no provision to assign view options to specific users or 
groups. That is to state that the users with only "View" permission could see the entire form and 
there was no way to control which segments of the form could be viewed. With this 
enhancements you can set user-permissions so users can view the entire form, a portion of the 
form, or a limited set of data on the form, for record preview in the log as well as for viewing 
record details.  

When you set up a workflow business process (all levels and record instances), you can use the 
View Forms tab of the Business Process Setup window to set up different view forms such 
that details that are relevant to users are seen. To access the View Forms tab: 

1) Go to your project or shell and switch to the Admin mode. 

2) From the left-hand Navigator click Setup to expand and click Business Process sub-node. 

3) Open the business process that you want to set up different view forms for. 

4) Select an item under the Setup Name column and open. 

5) Click the View Forms tab to open. 

Use the steps above to remove, move up, or move down existing view forms. 

From the View Forms tab: 

 You can add view forms to a BP setup. 

 Assign settings to users and groups for individual view forms. 

 Apply your settings to task assignees and copied (cc’d) users who view the record. 

 If ask assignees and copied (cc’d) users have restricted access to only one of the view 
forms listed in the window, then that view form will be displayed at runtime. 

 If ask assignees and copied (cc’d) users have access to none of the view forms listed in 
the window, then the step form will be displayed at runtime. 

 For copied (cc’d) users the restricted view form will be seen both from Notifications and 
Logs. 

Note: If the users or groups have permission to view multiple view forms, 
then they will see the view forms based on the sequence listed in this 
window. 

To add a view form: 
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1) In the View Forms tab, click Add to open the Select View Forms window. 

2) Under the View Forms column, a list of view forms from the BP design is displayed. Select 
as many forms as you need and click OK to add the view forms. 

3) After the form has been added, the right section will display the Permission Settings block. 
The Permission Settings block contains the Viewers field. Use the Select option to see the 
users or groups picker (Users/Groups) and add. The list of users and groups seen here will 
be the same as the ones seen when assignees are being set up in the workflow setup. 

An administrator can select the view forms that need to be set up for a given project or shell. The 
design for a BP can have multiple view forms, but for a select project template, or shell template, 
the administrator can set up one view form, only. 

If users have access to a deployed view form and that view form is deleted in uDesigner, then at 
runtime, the a user opens the BP record, Unifier checks that user's permission to any of the BP 
view forms that exist in the setup. If the use does not have access to any of the BP view forms 
that exist in the setup, the Unifier displays the Action form for that BP in view-only mode. 

Important information about deleting View Forms 

As indicated in the Unifier uDesigner User Guide, you can design a BP form (in the Staging 
environment), add view forms associated with a BP form design to the Business Process Setup 
(View Forms tab), assign permissions to users and groups for the individual view forms, and 
deploy the view forms so they can be accessed through the record preview in the log (Logs and 
Company Logs) for viewing record details. 

Due to the system limitations, an anomaly occurs when you delete a view form from the 
Business Process Setup. The following explains this anomaly: 

You have created and deployed the following view forms for a BP form ABC: 

 VF01 

 VF02 

 VF03 

You decide to delete one of the view forms. As a result, you navigate to uDesigner, delete the 
view form (for example, VF01), and ensure that the deleted view form has been remove from the 
Business Process Setup. 

You decide to add a new view form (for example, VF04), for the BP form ABC, so you proceed 
to add the new view form in uDesigner and deploy the new view form, VF04. 

At this point, due to the system limitations, the system will automatically add the newly created 
view from, VF04, to the Business Process Setup using the users and groups assignments 
originally assigned to the deleted view form, VF01. Furthermore, the availability of this added 
new view form (in the Business Process Setup) goes against the method that is used to deploy a 
new view form. 

As an administrator, you must ensure that in such scenario, you open the newly created view 
form and assign appropriate permissions. 
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Set up Record Properties for Workflow Business Processes 

In both Non-Workflow BPs and Workflow BPs (at the company, shell, and project levels) you 
(the administrator) can use the Record Properties tab to establish:  

 The availability or visibility of the BP form properties tabs for users and groups. 

 The ability to download attachments when users and groups access the BP records in user 
mode. 

The Record Properties tab has the following sections: 

Top: For setting up restrictions (setting restriction is done through Edit Restrictions) 

Left: For Upper Form and Line Item (detail forms) properties and setting up restrictions for 
downloading attachments from the Upper Form and Line Items (detail forms). The left 
section displays all of the record tabs seen in both upper and detail forms. In case of Simple 
type and Text type BPs, only the upper form properties tabs will be seen. The Upper Form or 
Line Item properties options that were hidden in uDesigner will not be displayed. 

Right: Users info (users or groups who cannot see the properties) 

The Record Properties window displays read-only view of the all the users and groups who are 
restricted to the visibility of selected tabs, or to download of attachments for selected tabs, in 
Edit Restrictions window. You can duse the Edit Restrictions button to apply restrictions to 
users and groups. 

Restricting the Audit Log and Workflow Progress options below will result in the automatic 
update of the same options in Permissions Settings of Access Control. The same operation 
applies in reverse. 

The Attachments in Upper Form Properties section will not be shown for the system-defined 
Line Item tab in the Document type BP.  

The additional section Do not allow download of Attachments will show the users and groups 
who are restricted to download the attachments from Upper Form or Line Item tabs in the 
business process record, when the attachments are visible. 

The first tab seen in the Do not allow download of Attachments is the Upper Form 
Attachments followed by the Line Item tabs names (for example Guages & Meters or 
Components) which will be in same order as seen in the Line Item Properties. 

The Upper Form Attachments tab will not be shown for the Text type and Document type BPs. 
Additionally, the  system-defined tab will not be shown for the Document type BP, under the Do 
not allow download of Attachments section. 

The tabs seen in the Upper Form and Detail Form properties will be based on each BP type. 

The tabs shown in Upper Form and Line item Properties will be in the same order seen in the 
BP record at run time. 

The Upper Form Properties and Line Item Form Properties which are already hidden in 
uDesigner will not be shown in this list. 

Example 
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If Linked Records and Linked Mail tabs, from the Upper Form Properties, are set to be 
hidden in uDesigner > Record Properties, then those two tabs will not be seen in the BP 
Setup under Upper Form Properties. Similarly, if the user-set Attachments tab in the Upper 
Form Properties is hidden in uDesigner > Record Properties, then in the BP Setup > Record 
Properties the user will not be able to see the following tabs: 

 Do not allow download of Attachments 

Upper Form Attachments 

 Upper Form Properties 

Attachments 

Adding tab visibility and download of attachments restrictions to users and groups 

You can add restrictions to the users and groups through the Edit Restrictions option. The 
restricted users and groups will be seen on the right-hand block for the property selected on the 
left-hand side. 

Edit Restrictions window: 

When you click the Edit Restrictions option, a window displays which enables you to select 
or add user and groups and assign attribute form restrictions. The Select Users/Groups
block (the left pane of the window) will be empty if there are no existing restrictions; 
otherwise, the block will list the existing restricted users and groups. Use the Remove option 
to remove the users and groups listed in this block. You can select one or more users or 
groups and select the Remove option to remove users or groups from the tab visibility 
restrictions. 

In the right-hand section of the window, you can access and hide all of the following form 
properties: 

Hide All Upper Form Properties

 Attachments    

 Do not allow download of Attachments 

 Comments 

 Linked Records 

 Linked Mail 

 Workflow Progress 

 Audit Log 

 Reference Records 

Hide All Line Item Properties

 <Line item tab1 name> Attachments   

 Do not allow download of Attachments         

 <Line item tab2  name> Linked Records 

 <Line item tab2 name> Attachments 

 Do not allow download of Attachments 

 <Line item tab2 name> Linked Records 
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The Detail Form Attributes will be shown based on the Line Item tabs available in the 
selected business process. Additionally, users and groups can be restricted to download the 
attachments only from the business process record. 

If a single user or group is selected on the left-hand side, then the selected user or group's 
existing restrictions will be shown. 

The Cancel and Save options will remain disabled if you do not make any changes in the 
right-hand block. If you select a user or group and change the restriction options, the the 
Cancel and Save options will be enabled. The Cancel and Save options enable you to save 
or cancel the changes that have made in the right-hand block. 

Once you close the Edit Restrictions window, the restricted users and groups will be added 
in Record Properties window. 

You can select multiple rows in Users/Groups section, edit the restriction check boxes, and 
save or cancel your changes.  

If multiple users or groups (on left-hand block) are selected, then the existing restrictions will 
not be shown in the right-hand block. 

In the Attachments case, a user who has restrictions to Download will be able to view or 
access the attachment but cannot download or save to a local system. 

Users/Groups window 

When you click Add, the User/Group window opens. This picker window displays all of the 
users and groups that are available and selected. Once the users and groups are added, you 
can select the users or groups (from the left-hand block) and set the hide permissions for the 
form attributes (in the right-hand block). 

Note: Users or groups cannot be removed from the User/Group Picker 
window. You can use this picker window to add additional users and 
groups to the Edit Restrictions window. You can remove your added 
users and groups by selecting one or multiple rows in the Selected 
Users/Groups block. 

After you add restrictions in the Edit Restrictions window the left-hand block displays the list 
of all users and groups with restrictions to the form attributes. When you select a form 
attribute such as Audit Log or Comments, the right-hand block displays the list of all the 
restricted users and groups. A user who has restricted access to selected record attributes 
like Audit Log, Comments, or Linked Mail viewing in the business process record will not 
see those tabs. 

Example 

User U1 has "Hide Upper Form Properties - Comments and Linked Records." At run time, 
when user U1 creates a new business process record or opens an existing record, 
both the Comments and the Linked Records tabs will not be seen in the record. 

Attachments

When a user is restricted to only the download of the attachments, in user mode the user can 
view the attachments in the business process record but will not be able to download them. 
The Download option is removed from Attachments tab and also in Review window. 

In this case a restricted user who views the attachment in native view the attachment will 
open in Unifier viewer, in read-only mode. 
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A restricted user will not be able to receive the attachments through email notifications 
received from a business process record for which the user has restrictions to download 
attachments. 

Line item Attributes

You can assign restrictions to users and groups for the Detail Form properties (Attachments 
and Linked Records for each Line Item tab). These additional Detail Form attributes will be 
seen only for the business processes that have the Detail Form defined in them. 

The Detail Form properties seen in the Record Properties window will vary for each business 
process and is based on the design, in uDesigner. 

Users and groups can be restricted to download attachments from the Line Item tab, similar 
to the Upper Form, as described in the Attachments section above. 

Additional information

Users and Groups who have permissions to "Hide Record Audit Log" and "Hide Task Statuses" 
are added to the restricted users and groups viewers list in the "Record Properties" tab, in the 
business process setup. 

All of the record level and Line Item tab restrictions are available for all business processes 
(company, shell, and project levels) that supports standard UI. 

The restrictions are applicable to all users or creators, task assignees, step editors, record 
editors, and CC'd users who are part of the workflow in the record. 

Visibility of tabs will be applicable to both Action and View Forms when user has tab restrictions 
to the BP. 

For Non-Workflow BPs, "Workflow Progress" (under the Upper Form properties) will not be 
available in the Record Properties, both at the design and at the setup level. 

For Company-level BPs, "Linked Mail" will not be available in Form Properties. 

For Simple and Text-type BPs, the option to hide the Detail Form properties will not be available. 

For Document-type BPs, "Attachments" will not be seen in Upper Form Properties and system 
defined tab in Line Item Properties. 

Note: The additional restrictions are not applicable to bid users. Bidders 
will be able to see all the attributes even though requestor have 
restricted access. 

When certain form properties are hidden in uDesigner, for a business process, then those form 
properties will not be shown in the Record Properties tab in the BP setup. 

Users or Groups who have record tabs view restrictions, in the BP setup, then at run time those 
selected tabs will not be seen in the business process record. This is applicable to both 
company sponsored and partner users. 

Projects or shells do not show Rich Text type DEs in the following scenarios:  

 When creating conditions for auto-creation elements in a BP setup. 

 When editing Gate settings and setting up Gate Condition Elements. 
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Assigning restrictions to users and groups will impact their ability to see the record properties 
tabs (tabs in the right-hand pane, when the user opens a record) of the following nodes: 

 Logs 

 Drafts 

 Tasks 

 Master Log 

 Company Log 

 Single-Record BP Log 

 Portal BP Log 

Set up Permissions for Record Properties Tab (Workflow) 

To set up permissions for the Record Properties tab:  

1) Go to Company Workspace tab and switch to the Admin mode. 

2) Click Company Sponsored Shells to expand and click to select the <BP NAME> and open 
the BP (Workflow or Non-Workflow). 

3) Click Setup to expand. 

4) Click Business Process, open <SETUP NAME>, and click the Records Properties tab. 

Creating, Adding, and Deleting Business Process Help Files 

Oracle provides standard business processes.  

For Cloud

If you need to download, deploy, and access a local copy of the business processes help files, 
download the help.zip. Contact your cloud administrator for more information. 

For On-Premises

If you need to download, deploy, and access a local copy of the business processes help files, 
download the help.zip file and follow the instructions in the Unifier Installation Guide. 

You can also develop your customized business process and create your own help files.  

Note: The help files must be in Adobe Acrobat PDF format. 

You can add the help file to new or existing business process setups. If you add the help file 
after individual business process records have already been created, the help file will not be 
available to the existing records; however, it will be available immediately from the business 
process log or in any new business process that is created after the help file has been added. 

Note: Custom business process help files can be added to project-level 
or company-level BPs. 

To create a custom business process help file 

1) Be sure that you have installed on your system Adobe Acrobat or other software application 
that includes a plug-in allowing the ability to create a PDF file. 



Setting up the Business Processes

287

2) In Microsoft Word or a similar software application, write the business process instructions 
that you wish to be made available to other business process users. Save the business 
process help file, but do not close it. 

3) With your business process help file still open, do one of the following to create a PDF file. 
This will depend on how your system is set up. 

 Print to PDF file: Click the File menu and choose Print. From the Printer drop-down list, 
select Adobe PDF as the printer, and click OK. Name the PDF file and click OK. 

 Save as PDF file: Click the File menu and choose Save as PDF. Name the PDF file and 
click OK. 

The PDF file will be generated, and can be viewed using Adobe Acrobat Reader. 

To add a custom business process help file to a new or existing business process setup 

1) In Administration Mode: 

 For a business process at the company level, go to the Company Workspace tab and 
click Company Workspace node > Business Process Setup. 

 For a business process in a project or shell, open the project or shell and, in the 
Navigator, click Setup > Business Process. 

Note: Even though the help file is added to an individual setup window, it 
is automatically added to all setups for that business process. The help 
file will be available immediately to all users with access to the business 
process log in User Mode, and will be available to any individual 
business process record created after adding the help file. 

2) Select the business process from the log and click Open. The Setup log for the business 
process opens. 

3) Click New to create a new setup, or select an existing setup from the log and click Open. 
The Business Process Setup window opens. 

4) In the General tab, click the Help File Add button. The File Upload window opens. 

5) Click Browse and navigate to the help file that you want to add. The help file must be an 
Adobe Acrobat PDF file. Click OK to attach the file and close the File Upload window. 

6) When you have completed the Business Process Setup window, click OK. 

To delete a business process from an existing setup 

Note: You can delete a business process from a specific shell template 
but not from other Projects/Shells that have been created using the 
template. 

In Administration mode: 

1) Open the project or shell and in the left navigation pane, click Setup > Business Process. 

2) Select a business process for deletion. 

3) Click Delete. 
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Note: System prompts the user asking to confirm deletion of the 
business process. 

4) Click Yes to delete the business process. 

To access the business process Help link 

1) In User Mode, navigate to the business process log. 

2) Click the Help menu, then click the business process name, which appears at the bottom of 
the Help menu. If a business process help file has been added to the business process form 
setup, the PDF file will open. 

3) You can also access the file from business process form. Open a business process record, 
click the Help menu, and click on the business process name. 

Auto-creating a Business Process record or Planning Item Based on conditions or 
frequency 

Using uDesigner, users can design a form that automatically creates a new business process 
(BP), line item, or planning item from a source form to a destination (auto-created) form after 
certain criteria are met. Users who have modify ownership permissions in the source record can 
enable auto-creation. You can override conditional auto-creation and immediately invoke the 
auto-creation manually if needed. 

This type of auto-creation automatically generates a new record based on: 

 A condition, such as a dollar amount 

 A frequency, such as a daily or weekly time frame 

Note: Line items cannot be created with a frequency trigger. 

 Both a condition and a frequency 

When a business process or line item reaches the trigger(s), the form will automatically create a 
new record or line item. This type of auto-creation uses a BP Creator, Planning Item Creator, or 
BP Line Item Creator data element on the upper and/or detail form to generate the new business 
process(es), line items, or planning item(s). 

You can use auto-created business processes to manage repeated events, such as: 

 Line items of lease business process generating payment request business process 
records: A lease business process with a pre-generated payment schedule can use this 
functionality to generate payment request records at appropriate preset days in advance of 
the payment due date to be routed for approvals. 

 Preventive maintenance business process line items generating work orders business 
process records: A preventive maintenance type business process (Preventive 
Maintenance Book) can be set up to create work orders for assets at periodic intervals 
depending on the service needs of the asset. 
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For example, if you wanted to use auto-creation to create a work order business process to 
order maintenance on a vehicle, you would first create a preventative maintenance business 
process (the source business process) and have your administrator set up the auto-creation 
of a work order for vehicle maintenance business process (the destination business process) 
to order the work on the vehicle. 

In this example, the uDesigner user set up which business process is the source business 
process and which is the destination business process. The company administrator specifies 
the conditions and defaults for the auto-creation. End users can set up the periodic 
auto-creation, based on their needs. 

 Create action items from meeting minutes: Create and assign tasks to different people 
creating a fully automated flow for routing of action items from meeting minutes. 

 Create a planning item: Create a planning item when an initiative business process has 
been approved. The planning item could then be fleshed out with details, such as budgets, 
locations, personnel. 

 Add a new line item to an existing record: You can add a line item to an existing business 
process. For example, a submittal registry record could contain line items that auto-create 
separate submittal business process forms for each contractor on a project. In the course of 
work, you might realize that the original submittal registry record is missing a submittal for an 
architectural drawing. You could submit a new submittal business process form that would 
add the missing architectural drawing submittal to the original registry record. 

For Line Item Creation: 

 Users cannot create a line item on a record that is at a terminal or terminated status. 

 For line items created on a non-workflow cost type business process, the cost amount(s) will 
roll up to the Cost Sheet. 

 For line items created on workflow cost type business process, the cost amount(s) will NOT 
roll up to the Cost Sheet. 

After a new workflow record is created, Unifier sends it to the assignees as an initiation task (I 
Step) that appears on the user’s Tasks log and the business process log to which the record 
belongs. If a new record is sent as an initiation task, the user must accept the task to manually 
launch the record. 

Note: Regardless of the number of assignees or creators, only one user 
may accept the I-Step task. 

After a new non-workflow record is created, Unifier sends it to the designated creators as an 
initiation task (I Step) that appears on the user’s Tasks log and the business process log to 
which the record belongs. The user must accept the task to view the record. 

Grouping line items into single records 

Unifier auto-creates new business process records using a BP Creator element. If this element 
is on the upper form of the business process, it will auto-create a single record. If the BP Creator 
element is on the detail or line item form, it will auto-create a record for every line item on the 
source record. For example, if source tab A has a BP Creator element and 10 line items, and 
source tab B has the same BP Creator element and 7 line items, 17 new records will be 
auto-created. 
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Sometimes, however, creating a record for every line item is cumbersome. You can end up with 
17 records that differ in only one aspect, such as a color. For cases like this, you can group line 
items for auto-creation in order to create fewer generated records. In a simple example for a 
lumber yard order, you might have doors made of wood or steel, both in colors of white and red. 
You could group the line items according the material (wood or steel) and color (red or white) to 
create fewer work order records. 

Notes:

 If the auto-created business process is set up to include line item 
attachments, the attachments will be appended to the upper form of 
the destination business process if it is not a line item type. 

 If the auto-creation uses a date trigger, Unifier will ignore this 
grouping feature. 

 Unifier will not group line items if: 
- The steps in the workflow are of different duration 
- The task assignees are different 
- The locations (such as shells) are different 

See also Set up auto-creation for a non-workflow BP or planning item (on page 245) and 
Set up auto-creation for a workflow BP (on page 262). 
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Bypassing the I Step 

During business process setup you can set up an auto-created workflow BP to skip the 
Initiation step and send the record directly into the workflow, where it normally arrives at the first 
step after the Create step (or the first step in a conditional routing). For a workflow BP, you can 
specify the schema, the step in the workflow that the record should use as its first step, the 
workflow duration, and the name of the person or group who will be the owner of the 
auto-created record. When the record is created, data will roll up to the manager sheets at the 
appropriate status; however, if Unifier encounters errors or invalid data, the record will remain at 
the Create step, and roll-ups will not occur until the user resolves the errors. 

For a non-workflow BP, you can set up an auto-created record to skip the Initiation step. In this 
case, the non-workflow BP will be created and will appear in the BP log in either an "edit" or 
"finish edit" mode. If it appears in an "edit" mode, the user will have to open the record and add 
or correct information on the form. If it appears in a "finish edit" mode, the record is considered 
complete, and data will roll up to manager sheets. 

Auto-Creation Protocol for Bypassing the I Step 

Auto-creation uses details specified in the BP Creator element to create the record. If these 
details are not present in the BP Creator element, the auto-creation feature will use the following 
protocol to attempt to create the record. 

For a Non-Workflow BP For a Workflow BP 

Checks for owner specification:

Checks the source BP setup 

Checks the destination BP 
setup 

If no owner can be identified, 
sends an error notification to 
those specified in source BP 

Checks for owner specification:

Checks the source BP setup 

Checks the destination BP setup 

If no owner can be identified, sends an error 
notification to those specified in source BP. 

Checks for status:

Checks the destination BP 
setup 

If no status found, creates the 
record and puts it into "edit" 
mode for user to correct. 

Checks for a workflow schema:

Checks the destination BP setup 

If no schema is specified, the record will be sent as an 
I Step to the user’s Tasks log and the BP log to which 
the record belongs. The user must accept the task to 
manually launch the record. 

Checks for an action specification

Checks the destination BP setup 

If no action is specified, the record will be sent as an I 
Step to the user’s Tasks log and the BP log to which 
the record belongs. The user must accept the task to 
manually launch the record. 
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Rules for Checking Conditions for Auto-Creation 

There are rules that govern when Unifier scheduler checks the conditions for auto-creation, and 
then if the conditions are met, auto-creates the BP. 

Rule 1 

The Company Administrator selected the Enable Auto creation checkbox for BP Creator when 
the auto-creation was set up in Unifier. 

If the Enable Auto creation checkbox is checked, it implies system based auto-creation, and the 
BP Creator Select button is not displayed in User Mode. 

For non-workflow BPs: The condition check occurs on Finish Edit. If condition met, creates 
record and shows the link for the auto-created BP. If no condition is specified auto-creates 
records and shows the link for the auto-created BP. 

For workflow BPs: The condition check occurs on Send. If end step reached and Action Form 
is used on End Step, the condition check occurs on Save instead of Send. If condition met, 
creates record and shows the link for the auto-created BP. If no condition specified blindly 
creates records and shows the link for the auto-created BP. 

If the Enable Auto creation checkbox is not checked, it implies manual creation. 

For non-workflow BPs: The condition check does not occur on Finish Edit. 

For workflow BPs: The condition check does not occur on Send. 

BP Creator- Select button shown in User Mode so that the user can create the business process 
manually. If clicked, creates BP record without checking any condition, and creates record and 
shows the link. 

Rule 2 

Date Trigger Condition check: Are checks on the specified Date Data Element. Setting this up 
implies that condition checks are done on a date instead of Finish Edit/Send in case of Non 
workflow and Workflow respectively provided a link does not already exist next to BP creator 
element. If a link already exists, it will not create any new records for that BP Creator element in 
the chosen line item of the record. 

Rule 3 

Trigger Condition check based on frequency (Periodic): Are checks on frequency for BP 
Creator elements with Enable Auto creator checked. If specified, these are the only time 
condition checks are done. This overrides any other checks for date. This is the only method to 
create multiple records even if a link already exists and a record has already been creator for 
this BP Creator element. The link created using this will always point to last auto-created record. 
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Setting Up Auto-Creation of Cash Flow Curves from Contracts 

An additional cash flow option is available on the setup window for CBS code-based base 
commit business processes. This option enables the automatic creation of a commitment cash 
flow curve for each base commit record in a project or shell. In order to do this, you simply 
designate a commitment-level cash flow template to use for the auto-created curve. 

For workflow business processes, this option is available in the Workflow Setup window Settings 
tab for every step other than the Create step. At runtime, when the record is sent from that step, 
the cash flow curve auto-creation is triggered and the curve is created in the Cash Flow log for 
the project or shell. 

Note: The permissions will get copied over to the created Cash Flow.  

For non-workflow business processes, this option is available in the Business Process Setup 
window on the General tab. At runtime, the cash flow curve auto-creation will be triggered when 
the Finish Edit button is clicked on the BP record. 

When copying a cash flow to create a new one, all permissions will be copied to the new cash 
flow curve.  

The following procedures describe enabling the auto-create cash flow option. See Setting Up a 
Non-Workflow Business Process (on page 241) and Setting Up a Workflow Business 
Process (on page 258) for more details on setting up business processes. 

Note: This option is available for base commit business processes only; 
that is, cost-type business processes with sub-type of "Line Items with 
CBS Code," and classification of "Base Commit." For all other types of 
business processes, this option will not display. The cash flow curves 
that are auto-created are based on commitment detail level curve 
templates (either company-level, or curves created in project or shell 
templates). 

To enable auto-creation of commitment-level cash flow curves in non-workflow base 
commit BP records 

1) Navigate to the Business Process Setup window for the base commit business process. 

a. Open the project/shell (or project/shell template) and switch to Admin mode. 

b. In the left Navigator, click Setup>Business Process. Double-click the base commit 
business process from the log. 

c. Double-click the business process again to open the Business Process Setup window. 

2) On the General tab, locate the Cash Flow Template field. 

3) Click Add. The Cash Flow Templates window opens. It lists all commitment detail-level cash 
flow templates created in the Company Workspace tab (in the Standards & Libraries > 
Cash Flow >Templates) or in project or shell templates (in the Cash Flow node). 

4) Choose a template and click Select. 

Note: Entering a template in this field enables the cash flow auto-create 
feature. To disable this feature, click the Remove button to remove the 
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cash flow template from the field. 

5) Click OK to save and exit the Business Process Setup window. 

At runtime, a commitment cash flow curve will be created in the project or shell when the 
base commit record is complete -- that is, the user clicks the Finish Editing button on the 
record. The data used for the cash flow curve will be taken from the line item values on the 
record at the time the record is sent. 

To enable auto-creation of commitment-level cash flow curves in workflow base commit 
BP records 

1) Navigate to the Business Process Setup window for the base commit business process. 

a. Open the project/shell (or project/shell template) and switch to Admin mode. 

b. In the left Navigator, open Setup>Business Process. Double-click the base commit 
business process from the log. 

c. Click Workflow Setup, then double-click a setup name (or create a new BP setup) to open 
the Workflow Setup window. 

2) Click the Settings tab. 

3) Select any step other than the Create step. Scroll down the Step Configuration options and 
locate the Cash Flow: Default Template field. 

4) Click Add. The Cash Flow Templates window opens. It lists all commitment detail-level cash 
flow templates created in the Company Workspace tab (in Standards & Libraries > Cash 
Flow > Templates) or in project or shell templates (in the Cash Flow node). 

5) Choose a template and click Select. 

Note: Entering a template in this field enables the cash flow auto-create 
feature. To disable this feature, click the Remove button to remove the 
cash flow template from the field. 

6) Click OK to save and exit the Workflow Setup window. 

At runtime, a commitment cash flow curve will be created in the project or shell when the 
base commit record is sent from the selected step. The data used for the cash flow curve will 
be taken from the line item values on the record at the time the record is sent. If record line 
item values are edited during the course of the workflow, then the curve values will update 
the next time the curve is refreshed. 

Note: This option is not available in the Create step. If you designate a 
cash flow template in more than one workflow step, the cash flow curve 
will be created at the first step in which this option is enabled; the 
auto-creation will be ignored in any subsequent steps, because only one 
cash flow curve can be created per base commit record. 
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Copying Workflow Setups from Other Schemas 

Some workflows can encompass many steps, as well as conditional routing and sub-workflows. 
Most of your time as administrator can be spent setting up the workflow schemas in your 
company. To make setting up workflow schemas easier and faster, Unifier provides you the 
option of copying existing setups from other workflow schemas. 

For example, if you have set up a large schema for an approval process that includes separate 
workflows for different provisos, you can copy the setup of one schema to another workflow, and 
make incidental changes where necessary, rather than set up the entire workflow schema again. 

Or, if you have a complex schema for setting up a project or shell, you can copy that schema to 
set up a different project or shell in your same Unifier environment. 

You can copy a setup 
from here: 

To here: 

A business process in 
the Company 
Workspace 

The same business process in the same Company 
Workspace 

If any users or groups are defined in the setup, they will be 
copied over if they do not already exist; matching will be 
done on the name. 

A project template for a 
business process 

Another project template for the same business process 

If any users or groups are defined in the setup, they will be 
copied over if they do not already exist; matching will be 
done on the name. 

A business process in a 
project 

A project template for the same business process 

If any users or groups are defined in the setup, they will be 
copied over if they do not already exist; matching will be 
done on the name. 

A shell template for a 
business process 

Another shell template (of any shell type) for the same 
business process 

If any users or groups are defined in the setup, they will be 
copied over if they do not already exist; matching will be 
done on the name. 

A business process in a 
shell 

A shell template (of any shell type) for the same business 
process 

If any users or groups are defined in the setup, they will be 
copied over if they do not already exist; matching will be 
done on the name. 

Business Processes Must Match

In all cases, the business process name, type, sub-type, classification, studio owner, and version 
number must match or the copy function will fail. 

About the version number
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The number in the Version column of the business process log shows the uDesigner version 
number. This number represents the number of times the design has been changed from Draft 
mode to Complete.  

The uDesigner module automatically increments the version number whenever a design is 
returned to Draft mode. When the draft is changed to Complete, it shows that number. This 
version of the design in uDesigner may or may not be the version that is active in Unifier.  

The version number that appears on this log in Unifier shows the last deployed version that was 
imported. This number may not match the version number uDesigner, but it is the last active 
version of the design in Unifier. The version number of the BP you are copying from must match 
the version number of the BP you are copying into. 

At the Company Level, Copy a Setup from Another Setup in the Same BP 

In this copy action, you copy a setup to another setup in the same business process in the same 
company workspace. 

To copy a workflow setup 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Company Workspace node > Business Process Setup in the left Navigator. 

3) On the right pane, double-click the business process to open it. 

4) In the Navigator, click Workflow Setup, and in the right pane, select the setup you want to 
copy. 

5) Click the Copy button. The Workflow Setup window opens. 

6) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

7) Click Apply. 

8) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you 
copied. 

On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

9) To save the new setup, click OK. 

If you made the setup Active, Unifier will perform an error check on the new setup and notify 
you of any errors it encounters; otherwise, the error check will not occur until the setup is 
activated. 
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Copy a Setup from One Project/Shell Template to Another 

In this copy action, you copy a setup from a business process in one project/shell template to 
the same business process in another project/shell template. 

To copy a setup from one project/shell template to another 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Do one of the following: 

 To copy a setup into a BP in a standard project template, click Templates > Projects 
(Standard) > All in the left Navigator. In the right pane, double-click the project that 
contains the BP you want to copy the setup into. 

 To copy a setup into a BP in a shell template, click Templates > Shells > [shell type] in 
the left Navigator. In the right pane, double-click the shell that contains the BP you want 
to copy the setup into. 

3) In the Navigator, click Setup > Business Process. 

4) In the right pane, double-click the name of the business process into which you want to copy 
the setup. 

5) In the Navigator, click Workflow Setup. 

6) Click the Copy From button and choose Templates. A copy window opens, listing all the 
workflow templates for that BP that exist in all the projects and shells in your environment. 

7) Select the template you want to copy and click Copy. The Workflow Setup window opens. 

8) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

9) Click Apply. 

10) Click the Settings tab. The Settings tab opens, showing the workflow of the schema you 
copied. 

On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

11) To save the new setup, click OK. 

Unifier adds the template to the workflow setup log. If you made the setup Active, Unifier will 
perform an error check on the new setup and notify you of any errors it encounters; 
otherwise, the error check will not occur until the setup is activated. 
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Copy a Setup from a Project/Shell to a Template 

In this copy action, you copy a workflow setup from a business process in a project or shell and 
make it a template in the BP you copy the setup into. 

To copy a setup from a project/shell to a template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Do one of the following: 

 To copy a setup into a BP in a standard project template, click Templates > Projects 
(Standard) > All in the left Navigator. In the right pane, double-click the project that 
contains the BP you want to copy the setup into. 

 To copy a setup into a BP in a shell template, click Templates > Shells > [shell type] in 
the left Navigator. In the right pane, double-click the shell that contains the BP you want 
to copy into. 

3) In the Navigator, click Setup > Business Process. 

4) In the right pane, double-click the name of the business process into which you want to copy 
the setup. 

5) In the Navigator, click Workflow Setup. The right pane lists the workflow setups that 
currently exist for this business process. 

6) Click the Copy From button and choose Project/Shell. 

A copy window opens, listing all the workflow setups for that BP that exist in all the projects 
and shells in your environment. 

7) Select the setup you want to copy and click Copy. The Workflow Setup window opens. 

8) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

9) Click Apply. 

10) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you 
copied. 

On this tab, you can make any changes you want to the setup you copied to accommodate 
the new setup. 

11) To save the new setup, click OK. 
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Unifier makes a template of the setup you copied and adds the template to the workflow 
setup log. If you made the setup Active, Unifier will perform an error check on the new 
schema and notify you of any errors it encounters; otherwise, the error check will not occur 
until the setup is activated. 

Importing Workflow Setups from One Company to Another Company In the Same 
Environment 

Unifier provides you the option of copying existing workflow setups into other workflows in your 
company (Copying Workflow Setups from Other Schemas (on page 295)). 

In addition to that option, you can import workflow setups from one company to another 
company in your environment, such as from one company in the Development environment to 
another company in the same Development environment.  

This import option is critically useful if your company is undergoing a significant reorganization or 
redesign, and the current designs in your Unifier environment are no longer sufficient. 

You can import a setup from 
here: 

To here: 

A business process in a 
Company Workspace 

The same business process in another Company 
Workspace 

If any groups are defined in the setup, they will be 
copied over if they do not already exist; matching will 
be done on the name. 

A project template for a 
business process 

A project template for the same business process in 
another company 

If any groups are defined in the setup, they will be 
copied over if they do not already exist; matching will 
be done on the name. 

A shell template for a business 
process 

A shell template (of the same shell type) for the same 
business process in another company 

If any groups are defined in the setup, they will be 
copied over if they do not already exist; matching will 
be done on the name. 

Business Processes Must Match

In all cases, the business process name, type, sub-type, classification, studio owner, and version 
number must match or the copy function will fail. 

About the version number
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The number in the Version column of the business process log shows the uDesigner version 
number. This number represents the number of times the design has been changed from Draft 
mode to Complete. The uDesigner module automatically increments the version number 
whenever a design is returned to Draft mode. When the draft is changed to Complete, it shows 
that number. This version of the design in uDesigner may or may not be the version that is active 
in Unifier. The version number that appears on this log in uDesigner shows the last design 
version that was imported. This number may not match the version number in uDesigner, but it 
is the last active version of the design in uDesigner. The version number of the BP you are 
copying from must match the version number of the BP you are copying into. 

To import a workflow setup from one company to another company 

1) In Administration mode, go to the Company Workspace tab and click Company 
Workspace node > Business Process Setup in the left Navigator. 

2) Open the business process you want to import the setup into. 

3) In the Navigator, click Workflow Setup, and click the Import button. The Unifier sign in 
window opens. 

This is where you sign in to the company from which you want to import a workflow setup. 

4) Enter the following information: 

 Company Short Name: This is the identifier for the company that you are signing in to. 

 Authentication Key: This is the key of the company that you are signing in to. This key 
was set up at the time the company was configured. It is like a password that provides 
import access to the BPs of the company you want to import from. 

 Unifier URL: (Optional) This is the web address of the Unifier server you want to sign in 
to. If you leave this field blank, Unifier will assume you are importing within the same 
environment. 

Note: The Unifier at this URL must be the same version number as the 
Unifier you are working in. The import function does not work across 
companies with different versions of Unifier. 

5) Click OK. 

The import window opens, listing the matching workflow setups (active and inactive) that 
currently reside in the company you have signed in to for the business process you selected 
under the Company Workspace node. 

6) Select the workflow setup(s) you want to import and click the Import button. 

Unifier imports the workflow setup(s) using the following guidelines: 

 If a setup does not currently exist in the destination company, the import will happen 
immediately and Unifier will mark the new setup Inactive. 

 If a setup already exists, Unifier will verify that you want to replace the existing setup with 
the one you are importing. If you import the setup, Unifier will replace the existing setup 
and mark the new setup Inactive. 

7) Click the Close Window button. 

8) In the right pane, double-click the setup you imported. The Workflow Setup window opens. 

9) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 
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10) Click Apply, then click the Settings tab. The Settings tab opens, showing the workflow of 
the setup you copied. 

On this tab, you can make any changes you want to the setup you imported to accommodate 
the new setup. 

11) To save the new setup, click OK. 

Unifier adds the setup you imported to the workflow setup log. If you made the setup Active, 
Unifier will perform an error check on the new setup and notify you of any errors it 
encounters; otherwise, the error check will not occur until the setup is activated. 

Importing Workflow Setups from One Environment to Another 

Unifier provides you the option of importing existing workflow setups from one company to 
another in the same environment (see Importing Workflow Setups from One Company to 
Another Company In the Same Environment (on page 299)). 

In addition to that option, you can also import workflow setups from one environment to another, 
such as from Development/Test environment to your Production environment.  

Note: To support the import function, the versions of the environments 
must match. For example, you cannot import a setup from one version of 
Development environment to a different version of Unifier. 

You can import a setup from here: To here: 

A business process in a Company 
Workspace 

The same business process in another Company 
Workspace 

If any groups are defined in the setup, they will be 
copied over if they do not already exist; matching 
will be done on the name. 

A project template for a business 
process 

A project template for the same business process 
in another environment 

If any groups are defined in the setup, they will be 
copied over if they do not already exist; matching 
will be done on the name. 

A shell template for a business 
process 

A shell template (of the same shell type) for the 
same business process in another environment 

If any are defined in the setup, they will be copied 
over if they do not already exist; matching will be 
done on the name. 

Business Processes Must Match

In all cases, the business process name, type, sub-type, classification, studio owner, and version 
number must match or the copy function will fail. 

About the version number
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The number in the Version column of the business process log shows the uDesigner version 
number. This number represents the number of times the design has been changed from Draft 
mode to Complete. The uDesigner module automatically increments the version number 
whenever a design is returned to Draft mode. When the draft is changed to Complete, it shows 
that number. This version of the design in uDesigner may or may not be the version that is active 
in Unifier. The version number that appears on this log in uDesigner shows the last design 
version that was imported. This number may not match the version number in uDesigner, but it 
is the last active version of the design in uDesigner. The version number of the BP you are 
copying from must match the version number of the BP you are copying into. 

Import a Setup From One Company to Another Company 

In this import action, you import a setup from one company to a setup in the same business 
process in another company. 

To import a workflow setup from one company to another company 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Company Workspace node > Business Process Setup in the left Navigator. 

3) Open the business process you want to import the setup into. 

4) In the Navigator, click Workflow Setup, and click the Import button. The Unifier sign in 
window opens. 

This is where you sign in to the environment from which you want to import a workflow setup. 

5) Enter the following information: 

 Company Short Name: This is the identifier for the company that you are signing in to. 

 Authentication Key: This is the key of the company that you are signing in to. This key 
was set up at the time the company was configured. It is like a password that provides 
import access to the BPs of the company you want to import from. 

 Primavera Unifier URL: This is the web address of the Unifier server you want to sign in 
to. 

Note: The Unifier at this URL must be the same version number as the 
Unifier you are working in. The import function does not work across 
environments with different versions of Unifier. 

6) Click OK. 

The import window opens, listing the workflow setups that currently reside in the environment 
you have signed in for the business process you selected under the Company Workspace
node. 

7) Select the workflow setup(s) you want to import and click the Import button. 

Unifier imports the workflow setup(s) using the following guidelines: 

 If a setup does not currently exist in the destination environment, the import will happen 
immediately and Unifier will mark the new setup Inactive. 

 If a setup already exists, Unifier will verify that you want to replace the existing setup with 
the one you are importing. If you import the setup, Unifier will replace the existing setup 
and mark the new setup Inactive. 
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8) Click the Close Window button. 

9) In the right pane, double-click the setup you imported. The Workflow Setup window opens. 

10) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

11) Click Apply, then click the Settings tab. The Settings tab opens, showing the workflow of 
the setup you copied. 

On this tab, you can make any changes you want to the setup you imported to accommodate 
the new setup. 

12) To save the new setup, click OK. 

Unifier adds the setup you imported to the workflow setup log. If you made the setup Active, 
Unifier will perform an error check on the new setup and notify you of any errors it 
encounters; otherwise, the error check will not occur until the setup is activated. 

Import a Setup for a BP to a Project/Shell Template for the Same BP in Another 
Environment 

When importing to a shell template, the source and destination shells must be of the same type. 

To import a BP setup to a project/shell template in another environment 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Do one of the following: 

 To import a setup into a BP in a standard project template, click Templates > Projects 
(Standard) > All in the left Navigator. In the right pane, double-click the project template 
that contains the BP you want to import the setup into. 

 To import a setup into a BP in a shell template click Templates > Shells > [shell type] in 
the left Navigator. In the right pane, double-click the shell template that contains the BP 
you want to import the setup into. 

3) In the Navigator, click Setup > Business Process. 

4) In the right pane, double-click the name of the business process you want to import the 
setup into. 

5) In the Navigator, click Workflow Setup. The right pane lists the workflow setups that 
currently exist for this business process. 

6) Click Import to open the sign in window. 

This is where you sign in to the environment from which you want to import a workflow setup. 

7) Enter the following information: 

 Company Short Name: This is the identifier for the company that you are signing in to. 

 Authentication Key: This is the key of the company that you are signing in to. This key 
was set up at the time the company was configured. It is like a password that provides 
import access to the BPs of the company you want to import from. 

 Primavera Unifier URL: This is the web address of the Unifier server you want to sign in 
to. 

Note: The Unifier at this URL must be the same version number as the 
Unifier you are working in. The import function does not work across 
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environments with different versions of Unifier. 

8) Click OK. 

The import window opens, listing all the workflow setups for that BP that exist in all the 
projects (if you chose a project template) or shells (if you chose a shell template) in the 
environment you signed in to. 

9) Select the setup you want to import and click Import, then click Close Window. 

10) In the right pane, double-click the setup you imported. The Workflow Setup window opens. 

11) On the General tab, enter a name and description for the new setup and make the status 
Active or Inactive as necessary. 

12) Click Apply. 

13) Click the Settings tab. The Settings tab opens, showing the workflow of the setup you 
imported. 

On this tab, you can make any changes you want to the setup you imported to accommodate 
the new setup. 

14) To save the new setup, click OK. 

Unifier adds the setup you imported to the workflow setup log. If you made the setup Active, 
Unifier will perform an error check on the new setup and notify you of any errors it 
encounters; otherwise, the error check will not occur until the setup is activated. 

Setting Up a Blanket Purchase Order Summary Template 

If you have set up a company-level blanket purchase order (a uDesigner created, company-level 
cost subtype commit BP), you must then set up a summary template to enable validation against 
individual commit BPs that reference the blanket PO. 

To set up the summary template for a blanket PO 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Workspace node > Business Process Setup. The 
business process log opens. 

3) In the log, double-click the name of the blanket PO business process. A setup log opens. 

4) On the log, select the business process and click the Summary Template button. 

5) You may add additional columns as needed. Click Columns, then click New. Complete the 
Column Properties. The data source choices for columns include: 

 Single source: All active cost BPs for your company (and their statuses), regardless of 
project. You determine which statuses you want to appear on the sheet. If you import and 
set up cost BPs that might reference the blanket PO, be sure to add them to the 
summary sheet template to track them against the total. 

 Logical source: Total commits and remaining balance. These should be set up as 
formulas, where total commits is the sum of the commits that you added as columns, and 
the remaining balance is the difference between the original amount and total commits. 
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To enable validation, include a total commits column to keep track of commit BPs that 
reference the blanket PO, and a remaining balance column to ensure that you do not exceed 
the original amount. 

Setting Up a Base Commit Business Process 

A Base Commit classification of a Cost Type Business Process (BP) can create a schedule of 
values; a General Spends classification can create an invoice at the CBS level.  

Use the Base Commit BP for: 

 For monies committed to be spent; for example, a contract or purchase order. 

 For creating a Schedule of Values (SOV) sheet for a General Spends, Payment Applications, 
or Summary Payment Applications. 

 Note: In Standard Cost Manager, the Base Commit BP creates a Schedule of Values (SOV) 
sheet. 

With the Base Commit type of BP, you can: 

 Reference against a company-level commit BP 

 Enforce the line items against a company-level commit amount 
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 Create a commitment summary when the BP is in a terminal status 

 Consolidate line items 

From this type of BP, you can: 

 Select only a General Spends type of commitment summary 

 View commitment summary line items only by individual line items, or grouped by commit 
codes 

To set up the for a Base Commit BP: 

1) Go to the project and switch to Admin mode. 

2) In the left Navigator, click the Setup node. 

3) In the left Navigator, click Business Process to open the Business Process Setup - 
Current View/log. 

4) Select the business process that you want to set up and open. 

5) In the Business Process Setup window, General tab, enter values. 

6) Continue on with entering values in the Settings, Notifications, Auto Creation, and 
Record Copy tabs. 

7) When finished, click Apply and OK. 

Removing Restrictions Related to the Multiple Payment Application Submissions 
(Remove SOV restrictions) 

When you create a Workflow BP record, the BP record shall remain in progress (in-flight) until 
the record reaches its terminal stage.  

You can set up a Base Commit type of BP that is based on an existing Schedule of Value 
(SOV), and in progress (in-flight), to accommodate: 

 Multiple Payment Application records can be created for the same commit record.  

 Multiple Negative Change Orders can also be created for a given Base Commit. 

 Payment application when a negative change order is in-flight. 

A negative change order refers to a Change Commit (change order) that has been issued to 
deduct the original committed contract amount. In Unifier, this means that a user has created 
a record of Change Commit BP type with negative line item amounts. 

In the Business Process Setup window, General tab, you have the option of applying or 
removing restrictions on multiple payment applications or multiple negative Change Commit in 
the Base Commit BP. This enables users to create: 

 Create and submit a Payment Application when another Payment Application is in progress. 

 Create and submit a Payment Application when a Change Commit (change order), with a 
negative line item, is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when a 
Payment Application is in progress. 

 Create and submit a Change Commit (change order), with a negative line item, when 
another Change Commit (change order), with a negative line item, is in progress.  

Note: The options listed above are available for Base commits of SOV 
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type = Payment Applications or Summary Payment Applications. 

Additional information about removing SOV restrictions 

Users can modify this option (Remove SOV restrictions) at any time except when all the 
Payment Applications and Negative Change Orders that refer to the BP have reached the 
terminal step. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use for updating existing Workflow schema in the destination 
Project/Shell, then the selected SOV restriction option (existing in the BP setup level) will get 
updated in the Project/Shell instance. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use to create new Workflow schema in the destination Project/Shell, 
then the selected SOV restriction option (existing in the BP setup level) will not get updated in 
the Project/Shell instance. 

When you select or deselect this option (Remove SOV restrictions) in an existing Workflow 
template that you plan to use to create new Workflow schema in the destination Project/Shell, 
and if this new Workflow schema are used in the Auto Creation tab of the BP setup, then the 
selected SOV restriction option (existing in the BP setup level) will get updated in the 
Project/Shell instance. 

When the SOV restriction option setup is ready and you include the BP in the Configuration 
Package, if there are any in progress (in-flight) records for the Payment Application, or Change 
Commit (change order), then the import will be successful but the system does not update the 
setup information for that BP. 

Setting Up a Request for Bid (RFB) Business Process 

A Request for Bid (RFB) business process allows companies to invite bids from multiple 
vendors. The Request for Bid process requires the following components to operate in 
Primavera Unifier: 

 Master Vendor BP (Vendor Master BP): A simple or Line Item type BP (Company level) 
that lists the available vendors who can be invited to bid. A company can have only one 
master vendor BP. Unifier allows your company to only designate one Vendors business 
process as the RFB master vendor list. 

 Requestor form: This is the BP form the Primavera Unifier user uses to distribute bid 
requests from vendors. 

 Bidder form: This is the BP form the vendors use to submit their bids. 

 A workflow for the requestor form: This workflow or workflows can be used to approve the 
RFB before inviting bids, to distribute the RFB, and to approve the final bid award. 

 (Optional) A bid comparison sheet: This is a sheet designed specifically for your company 
for the purpose of comparing the bids you receive from vendors. (If your company has not 
designed one, Primavera Unifier provides a default sheet you can use.) 
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Verify the RFB Has Been Designed Correctly 

In uDesigner:  

1) Verify that the correct vendor list is linked to the RFB. 

a. Open your vendor master (Master Vendor BP/Vendor Master BP) business process 
properties and click the Options tab. 

b. Make sure the field Use this process as RFB master vendor list is checked. This 
option links the vendor list to your RFB. 

2) Make sure the correct vendor list has been specified as the RFB’s reference process. 

a. Open the RFB and click Reference Processes in the Navigator. 

b. Verify that the RFB references the correct vendor BP. 

In uDesigner, for the RFB business process (BP), you can select a BP Data Picker that 
references a Line Item type BP that can be used to filter the available bidders in the Option tab.  

The BP Data Picker that is available for selection is the one that has been added to the 
Requestor Upper Forms. 

The selected BP Data Picker points to the Line Item type BP that contains the BP Data Picker 
(BP Picker) that is in the Detail Form and subsequently points to the Master Vendor BP/Vendor 
Master BP, at the Company level. 

The following explains the workflow: 

 In the RFB BP, the Options tab enables you to set the data picker that you need to connect 
to the Line Item type BP. 

 The Requestor BP form contains the data picker that points to the Line Item type BP. 

 In the Line Item type BP, the Details Line Item record contains the BP Data Picker/BP Picker 
that is required to connect to the Vendor BP. 

 The Data Picker/BP Picker points to a Master Vendor BP/Vendor Master BP record at the 
Company level. You can use the query condition, on the data picker, to filter the list of 
vendors. 

 The Vendor BP contains the list of vendors who are available for bidding. 

Set Up a Bid Management Account in Primavera Unifier 

To enable the vendors to sign in to Primavera Unifier and submit bids, you need to create a 
"bidder" account. In the preferences you set up for this account, you need to specify certain 
settings to make the bidding process possible. You will enter this bidder's account in your 
company’s preferences. 

Tip: Do not link the bid management account to an actual user in your 
company. Create this account strictly for the bidding process so that you 
can set up the account preferences specifically for bidding. If you set up 
a special "bid management" user account, you can prevent users from 
inadvertently changing the settings. 

1) To set up this "bidder" account, add the bidder as a user. See Setting up the Users (User 
Administration) (on page 131). 
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2) Sign in to Primavera Unifier as the user with the bidder account. 

3) From the top right-corner of your window, click your User Name to open a contextual menu. 

4) Click the Preferences link. The User Preferences window opens. 

5) Click the Options tab. 

6) Set the Time Zone field to match that of the bid requestor’s (either your company’s time 
zone, or the zone from which the bid invitation is sent). 

If your bidders are in a different time zone from yours, this will protect them from mistakenly 
submitting bids after the bidding process is closed. 

Set Up the RFB in Unifier 

To set up the RFB (in Administration Mode): 

1) Follow the standard procedures to import (Importing Business Processes (BPs) (on page 
222)), configure (Configuring Business Processes (BPs) (on page 222)), and set up (see 
General Procedures for Setting up Business Processes (on page 239)) the RFB. 

2) Define a link for the bidders to use to submit bids: 

a. Go to the Company Workspace tab and switch to Admin mode. 

b. In the left Navigator, click your company name. The company landing page opens. 

c. Click the Open button. The Edit Company properties window opens. 

d. Click the General tab. 

e. In the Bid Access URL field, finish the URL address (usually with the name of your 
company). 

This is the link that will appear on the bid invitation you send to the bidder. The bidder will 
use this link to sign in to Unifier and submit a bid. 

f. In the Bid Management Account field, enter the account name of the user who will be 
managing the bids that your company receives. 

This is the account that contains the bidder’s preferences you created using the 
instructions under Set Up a Bid Management Account in Primavera Unifier (on page 
308). 

Business Process Permission Settings 

Refer to the Unifier Reference Guide for permission settings. 

Business Process Functionality in Unifier 

Not all BPs work with all functional areas of Primavera Unifier. This table lists the available BPs 
and the areas in which the BP works. 

Type Subtype 
Classificatio
n 

Project 
(Standard) 

Shell 
(CBS) 

Shell 
(Generic) 

Compa
ny 

Cost 
Commit at 
Company level 

- X 
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Cost 
Line item with 
CBS code 

Generic X X 

Cost 
Line item with 
CBS code 

Transfer X X 

Cost 
Line item with 
CBS code 

Base 
Commit 

X X 

Cost 
Line item with 
CBS code 

Change 
Commit 

X X 

Cost 
Line item with 
CBS code 

General 
Spends 

X X 

Cost 
Line item with 
CBS code 

Payment 
Applications 

X X 

Cost 
Line item with 
fund code 

Generic X X 

Cost 
Line item with 
fund code 

Transfer X X 

Cost 
Line item with 
both fund and 
CBS code 

Generic X X 

Cost 
Line item with 
both fund and 
CBS code 

Transfer X X 

Cost 
Line item with 
company 
account code 

Generic X 

Cost 
Line item with 
company 
account code 

Transfer X 

Cost 
Line item with 
asset code 

- X 

Cost 
Line item with 
multiple codes 

Generic X 

Cost 
Line item with 
multiple codes 

Transfer X 

Cost 
Line item with 
multiple codes 

Base 
Commit 

X 

Cost 
Line item with 
multiple codes 

Change 
Commit 

X 

Cost Line item with General X 
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multiple codes Spends 

Cost 
Line item with 
multiple codes 

Lease X 

Line 
item 

- - X 

Line 
item 

- - X X X 

RFB - - X 

Simple - - X 

Simple - - X X X 

Docum
ent 

With folder 
structure 

No detail 
form 

X X X X 

Docum
ent 

With folder 
structure 

With detail 
form 

X X X X 

Docum
ent 

Without folder 
structure 

No detail 
form 

X X X X 

Docum
ent 

Without folder 
structure 

With detail 
form 

X X X X 

Text - - X X X X 

Resour
ce 

Resource 
booking 

- X 

Resour
ce 

Time sheets - X 

Query-Based Tab in Business Processes 

The Query tab allows access to all Business Processes/Space/Level records, related to a 
Business Process, by way of Query-based Tab (QBT). 

Example 

If you need to see all approved Spaces related to your BP, you can use the QBT to 
query/fetch those records. Once a Query-based Tab (QBT) is successfully created and 
deployed using uDesigner, the Query Tabs appear in the Unifier required BP, in User mode. 

A Query-based tab (QBT) is a mini business process log that displays a filtered list of a business 
process records in the tab line item list. The QBT can be used in all: 

 Line Item business processes 

 Cost business processes 

 Space business processes 

 Document-type business processes 
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Example 

A contract QBT can display just the change orders issued against the contract. Another QBT 
can display only invoices against the contract. Records displayed in the QBT line item list are 
from the same level (shell/project or company.)  

QBTs are not supported in the following business processes: 

 Simple 

 Resource 

 Text 

 Request for Bid (RFB) 

 Project/Shell creation 

In uDesigner, the "Query Items" is a new parent node in the Business Processes (left-hand 
Navigator) with two sub-nodes: 

 Query Tabs

To define the QBTs that will be added to the business process. Query tabs can be created as 
long as the maximum number of tabs (fifteen) has not been reached.  

 Summary Elements

To define summary data elements to be added to the Upper Form of the business process. 
The summary elements specify the type of summary information 
(average/count/total/maximum/minimum) that will be shown from the selected query tab, for 
example, the total amount of records in the tab. 

As a pre-process to defining the Query tab in the business process, you need to use a reference 
picker in one of the upper forms of the business process, Space, or Level from where you want 
to create the Query tab. For defining a Query tab, click on the Query Tabs link in uDesigner, 
click New, and select a business process, Space, or Level. The system allows you to create a 
maximum of fifteen tabs in uDesigner, including the QBT.  

Query-based tab enables the user to: 

 View a filtered list of business process records associated with the parent business process. 

Once the QBT in a business process is correctly configured and deployed, the QBT appears 
in the business process (User mode) for which the QBT has been configured. 

 Create a new business process from the QBT in the same Project/Shell, where the parent 
business process resides. 

Users can create new business process records from the QBT provided that the users have 
permission to create business process records for the Project/Shell that contains the 
business process. 

 Copy a business process in the same location as the parent business process. 

Users can copy a business process either with or without attachments. In addition, a user 
can copy any of the records, in the QBT, and create a new business process record. 
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Note: Users can copy one record at a time.  

When the user copies a business process record in order to create a new business process, 
the new business process record contains all the information present in the copied/based 
business process record.. So, in case of business records with attachments, the user has the 
option of including or excluding (copying or not copying) the attachments when copying a 
business process record. 

 Search for business process records based on user-entered criteria. 

Users can find any record from the list of records included in the QBT. 

Note: The fields available for the Find feature must be defined in the 
uDesigner for the business process. 

Use the Properties option (log toolbar) to configure the tab. The options are: 

 Line Items 

 Standard 

 Gauges & Meters 

 Hide current tab 

User-Defined Report (UDR) and Query-Based Tab 

Users will be able to use the Summary Elements, from any of the QBTs, in any of the UDRs 
that the user wants to use if the UDR is based on the same business process record.  

Query Tab and Document-type Business Process 

The Document-type business processes support QBTs and Line Item tabs along with the 
existing standard tab. 

To define the Query tab in a Document-type business process, you must add a reference picker 
in the Upper Form of the business process that you want to run the query against. This includes 
business process picker, new data definition, or business process picker for the destination 
business process.   

When users click the Properties option, for an Upper Form on a Document-type business 
process, the Options tab displays the following: 

 Standard Tab (for Document-type business process) 

 Line Item Tab (similar options across each line item type tab) 

 Query Based Tab (similar options across each QBTs) 

Standard Tab (for Document-type business process)

 Hide current tab 

 Add/Copy Line Items 

 Remove Line Items 

 Allow Modification of Line Item, except when status is 

 Allow Line Item Status to be modified 

 Add Attachments 
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 Remove Attachments 

 Append Line Item Folder Structure to Auto Publish Path 

 Make Attachment to a Line Item mandatory 

 Allow comments 

 Allow marking of comments as 'Final' 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

Line Item Tab (similar options across each line item type tab)

 Hide current tab 

 Add/Copy Line Items 

 Remove Line Items 

 Allow Attachments to the line item 

 Allow Modification of Line Item, except when status is 

 Allow Line Item Status to be modified 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

Query Based Tab (similar options across each QBTs)

 Hide Tab 

 Additional 

 Allow linking Mailbox 

 Attachment Source 

 Unifier Folders 

 My Computer 

To create a QBT: 

1) Go to the Company Workspace tab, switch to the Admin mode, and click to expand the 
Business Processes node. 

2) Open a line item, or a Cost business process. 

3) In Query Items node, select Query Tabs. 

4) Click New to create a new query tab, and then define query conditions for the tab in Item 
Logs. 

You can click New or Copy to create a record. 

To view, or use, a QBT 

1) Go to the parent business process log in Project/Shell. 
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2) Open a record to view the QBT. 

Note: The source business process of the QBT must be active in order 
for the tab to display. 

See the following for more information about creating QBTs. 

Creating Query-Based Tab in Business Processes 

To create a Query tab, go to Company Workspace tab > Admin mode > uDesigner  > 
Business Processes: 

1) Select a business process. 

2) From the left-hand Navigator, click Query Items to open the sub-nodes. 

3) Click Query Tabs. 

4) Click New. 

5) In the Select Business Process window, click the drop-down list (under Select Business 
Process/ Attribute field), select a business process or attribute, and click OK to open the 
Query Tab window. 

6) In the Query Tab window, enter values in the Name, Description, and Reference Picker
fields (this is to filter records in the Query tab). 

The value for the Reference Picker field is auto-populated when a user creates a new 
business process record based on a QBT. In such a case, the record number of the parent 
record will be auto-populated and the user can edit the number and change it to a desired 
record number. Once the business process record is successfully created, the reference 
graph shows the intended business process record.  

7) When finished, click OK. 

8) From the left-hand Navigator, click Item Logs (previously, the Line Item List node) to begin 
designing the log. You can have a total of 8 (eight) tabs, including the Query tabs. 

The log for the Items Log (previously, the Line Item List node) has several columns. The 
column, "Type," enables you to distinguish between the Detail Form line items list and the 
Query Items. The "Tab Name" column appears before "Name" column. Define query 
conditions in the setup for filtering the list of records returned at runtime. 

9) Click to open the Query items widow and click the Query tab to begin setting your condition. 

10) Click Add to open the Query Condition window. If you do not add a query, the tab returns 
all the records, based on the reference process. 

11) Select and enter values in the Data Element and Condition fields. You can add multiple 
conditions. the system performs the query with "And" operand, on the conditions. 

12) From the left-hand Navigator, go to the Upper Forms node to configure the Query tab 
options, similar to the Detail Forms. 

13) Complete your business process. 

14) Deploy the business process form. 

Additional information: 

Within a selected BP, the Query Items sub-node provides the following two links: 
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 Query Tabs

 Summary Elements

Query Tabs

You can use the Query Tabs sub-node to define and maintain the various Query tabs that are 
defined within the business process. 

General Tab

In the General tab, you can enter the name, description, and reference picker for the required 
QBT. 

In case, you have already included the reference picker in the Upper Form of the business 
process, the reference picker appears in the drop-down list of the Reference Picker field. In this 
case, the Name field is populated with the name of the business process, but you can change 
the name of the QBT, if necessary. The name and reference pickers are mandatory fields on the 
General Tab, so you cannot create a QBT if you have not included the reference picker on the 
Upper Form of the business process. 

Query Tab

The Query Tab of the QBT is used to create a query to filter the results, displayed within the 
QBT, based on any particular condition. 

To access the Query Tab, go to Item Logs sub-node, open the QBT that was created, and 
switch to the Query tab. 

Note: It is not mandatory to have a query, so in case no queries are 
defined all records display in the QBT, in User mode.  

You can define multiple queries within the Query tab. 

The Query Tabs log page allows you to: 

 See all the Query Tabs 

 Create a new QBT (New). 

 Open an existing QBT to review or change content (Open). 

 Delete an existing QBT (Delete). 

Summary Elements

You can use the summary elements on the Upper Form of the business process to show the 
data that is being exchanged. You can use the following types of the summary elements in QBT: 

 Average 

 Count 

 Total 

 Maximum 

 Minimum 

You can define multiple summary elements. To create summary elements: 

1) Go to Company Workspace tab > Admin mode > uDesigner  > Business Processes. 
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2) Go to your business process, click Summary Elements node and use the QBT to create 
your summary elements. After defining the summary elements, click OK to save. 

The log page for the Summary Elements node allows you to: 

 See all the Summary Elements. 

 Create a new Summary Element (New). 

 Open an existing Summary Element to review or change content (Open). 

 Delete an existing Summary Element (Delete). 

Once you create the summary elements, you can include them in the Upper Form of your 
business process. 
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Setting up Updates for Business Process 
Records 

Business Processes (BPs) can be associated with specific Project or Shell (Project/Shell-level 
BP), or they can be applicable for the entire Company (company-level BP) and not to be specific 
to a Project/Shell. The Administrator (Project/Shell or Company) determines which forms are to 
be used and how the workflows operate. 

To set up a BP record to receive updates in a Company or Project/Shell, do one of the following: 

For a Company, switch to the Admin mode > Company Workspace > Business Process 
Updates

For a Project/Shell, switch to the Admin mode > Company Sponsored Shells > Business 
Process Updates

In This Section 

Company Workspace and Business Process Updates .......................................... 319 
Project/Shell and Business Process Updates ........................................................ 323 

Company Workspace and Business Process Updates 

To update a Business Process (BP) in the Company Workspace, go to Company, switch to the 
Admin mode > Company Workspace > Business Process Updates. 

Business Process Updates Log in Company Workspace 

The Business Process Updates log in Company Workspace allows you to set up updates from 
a template to a record, at the Company level. The log consists of the following: 

Menu

 File 

 Edit 

 View 

 Help 

Toolbar

 New 

 Cancel Request 

 Open 

 Find 

 View Details 
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Note: These options can be accessed through the Business Process 
Updates log window menu options. 

Columns

 Name 

 Source Business Process 

 Source Business Process Record 

 Submit Date 

 Schedule date 

 Start Date 

 Completion Date 

 Status 

 Requested By 

The functions of the elements in the Business Process Updates log are explained in the 
proceeding sections. 

Company Workspace and Preventive Maintenance Type BP 

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. 
You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create 
Work Order BP records for assets at periodic intervals according to the service needs of the 
asset. 

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive 
Maintenance Book) in order to view all the Work Order BP records for that Preventive 
Maintenance type BP (Preventive Maintenance Book). 

The Business Process Updates log in Company Workspace allows you to set up updates from a 
PM Book Template to a PM Book record, at the Company level. 

The following explains the following toolbar options:  

Note: These options can be accessed through the Business Process 
Updates log window menu options. 

 New

 Cancel Request

 Open

 Find

 View Details

The New option enables you to create new update requests from the PM Book Template type, 
and the log displays all the PM Book Template updates that exist at the Company level. 

The drop-down list of the New option lists all the BPs of PM Book Template type that have been 
set up in the Company Workspace. If a BP is not Active, or it does not have Active setups, then 
the system does not include the BP in this list. 
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Note: If there are no BPs that have Active setups, the New option will be 
disabled. 

When you select a BP from the New option list, the BP record selection window opens which 
enables you to select the source PM Book Template record for the update. 

The BP record selection window contains the log elements/options that have been set in the 
Business Process Configuration. 

The toolbar of the BP record selection window has the same option as the Data Picker window. 

The Cancel Request option enables you to cancel a scheduled update. You can only cancel a 
request that has not started (i.e., you can cancel a record that is not stamped with a Start Date.). 
You can cancel multiple requests. After you cancel an update request, the system changes the: 

 Status of the request to: Not Started 

 Schedule option to: None 

The Open option enables you to view the request details; however, depending on the status of a 
record, this option may not be available, as explained here: 

 If the Status of a record is "Completed/In Progress/Error/Failed," then the log window has a 
Close option. In this case, you can only view the update request details. 

 If the Status of a record is "Not Started/Not Scheduled," then the update setup window 
opens. 

The Find option enables you to search for a particular request in the log, using the following 
search parameters: 

 Name

 Source Business Process

 Source Business Process Record

 Status

Note: The logical operators are the same as in any String or Pull Down 
field. 

The View Details option enables you to view the details of an update request. When you click 
this option, the system opens a report in PDF format that outlines the details of all of the PM 
Book records that were updated successfully and those that were not. 

PM Book Record Update Window 

After you select the source PM Book Template record for the update, the PM Book Record 
Update window opens which contains multiple tabs. These tabs are based on the PM Book 
Template design and are not query-based tabs. 

Note: Depending on the design of the Asset Business Process in 
uDesigner, you may see other tabs (Detail Form tabs) in the PM Book 
Record Update window. For example, you can see Time Schedules tab, 
Gauge Meter Schedules tab, and so forth. 

The following describes each tab in details: 
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 General tab

The General tab is fixed and has the following fields: 

 Name (required) 

 Description (optional) 

 Source Business Process (read-only): The value in this field is the name of the PM 
Book Template Business Process. 

 Source Business Process Record (read-only): The value in this field is the number of 
the PM Book Template record that is the source of the update. 

 Schedule (block): This block has two fields (date and time picker) impacting the schedule 
of the update (Date and None). The date that you select must be greater than the current 
date and time.  

 Main Form tab

The Main Form tab is fixed. The fields in this tab enables you to update the Upper Form field 
values of the PM Book record from the Upper Form field values of the PM Book Template 
record. 

The Data Elements in the Main Form tab are based on the Data Elements that exist in the 
PM Book Template. 

By default, all Data Elements are selected. Use the check box next to Data Element to select 
or deselect all other Data Elements. 

The order of the fields are based on the Upper Form design. 

Use the View Record Details option to open a read-only copy of a record. This is to assist 
the user with reviewing the existing values of the PM Book Template record. 

 Detail Form tabs (Other tabs) 

The Update PM Book Records window displays tabs based on the design of the Detail 
Form (uDesigner > Business Processes > PM Book Templates > Design Form). For 
example, if the Detail Form contains Time Schedules and Gauge Meter Schedules, then the 
Update PM Book Records window displays the Time Schedules tab, Gauge Meter Schedules 
tab, in addition to the fixed tabs (General tab and Main Form tab). 

The Detail Form tabs enables you to select the Line Items that need to be updated in the 
auto-created PM Book records, form the PM Book Template. 

The following elements are available in each Detail Form tab: 

Line Items

From this block, you can specify the Line Items that you want to get updated in the PM Book 
records, from the PM Book Template. The Line Items block displays all Line Items that exist 
in the selected template record and includes the following information about each Line Item: 

 Line No.

The line number of the Line Item in the PM Book Template. The line number in the PM 
Book record may not have a one-to-one connection with the line number existing in the 
BP Book Template.  

 Short Description

 Line Item Details 

Each Line Item has a View, hyperlink, option that enables you to view the Line Item 
details, in View only mode. 
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Data Elements - <name> tab

This section displays the list of applicable Data Elements. Use the Data Element check box 
to select/deselect all elements. The Line Items listed here exist in the auto-created PM Book 
record. 

When an Asset auto-creates a PM Book record, the Line Items, and contents, are copied 
over from the PM Book Template record associated with the Asset. The system associates a 
unique "guid" for each of the Line Items in the PM Book record and maintains a reference to 
the Line Items in the parent PM Book Template record. Since such a reference exists, the 
Line Item in the parent PM Book template record is changed, and the corresponding Line 
Item in the destination PM Book record is updated by means of this Push update. 

New line items can only be added to the Time based tab. If new Line Items are added to the 
PM Book Template record, you need to conduct a push to add the new Line Items to the PM 
Book record, as new Line Items. The Data Elements of the PM Book records are updated as 
part of this push. 

If the Line Items do not exist in the auto-created PM Book records, then the system creates 
the Line Items. The new Line Item creation, in the PM Book records, follow the Line Item 
auto-creation logic, and the new Line Item creation does not refer to the Data Elements 
section of the tabs, at the time of update. The tab mapping that has been set in the design of 
the Asset BP forms the basis for copying over the field values in the PM Book records. 

Project/Shell and Business Process Updates 

To update a Business Process (BP) in the Project/Shell, go to Project/Shell, switch to the 
Admin mode > Company Sponsored Shells > Business Process Updates. 

Business Process Updates Log in Project/Shell 

The Business Process Updates log in Project/Shell allows you to set up updates from a 
template to a record, at the Project/Shell level. The log consists of the following: 

Menu

 File 

 Edit 

 View 

 Help 

Toolbar

 New 

 Cancel Request 

 Open 

 Find 

 View Details 
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Note: These options can be accessed through the Business Process 
Updates log window menu options. 

Columns

 Name 

 Source Business Process 

 Source Business Process Record 

 Submit Date 

 Schedule date 

 Start Date 

 Completion Date 

 Status 

 Requested By 

The functions of the elements in the Business Process Updates log are explained in the 
proceeding sections. 

Project/Shells and Preventive Maintenance Type BP 

Preventive Maintenance Business Process (BP) Line Items generate Work Order BP records. 
You can set up a Preventive Maintenance type BP (Preventive Maintenance Book) to create 
Work Order BP records for assets at periodic intervals according to the service needs of the 
asset. 

The Work Order BP records refer to a Preventive Maintenance type BP (Preventive 
Maintenance Book) in order to view all the Work Order BP records for that Preventive 
Maintenance type BP (Preventive Maintenance Book). 

The Business Process Updates log in Project/Shell allows you to set up updates from a PM 
Book Template to a PM Book record, at the Project/Shell level. 

If you link your Time and Meter Schedules within a PM Book BP, you can avoid generating 
multiple PM work orders if a meter-schedule occurs sooner than a time-schedule, or vice versa. 
The following scenario provides a good example for this feature:  

A commercial vehicle is scheduled for an oil change either when it reaches 5000 miles 
(meter) or 12 months (time) after the last oil change, whichever is reached first. If the vehicle 
reaches 5000 miles prior to 12 months, then Unifier generates a PM work order and 
automatically prevents a second PM work order when the 12 months time-frame comes. 
Conversely, if 12 months passes and the vehicle does not reach 5000 miles, then Unifier 
generates a PM work order and automatically prevents a second PM work order when the 
vehicle reaches 5000 miles. 

To prevent generating an additional work order, in such a case, you can use the 
"uuu_rec_related_family_id" data element to link the meter-schedule and the time-schedule 
within a PM book or PM book template. To update the "uuu_rec_related_family_id" data 
element from PM Book templates to use for all PM Books, go to either of these locations: 

  Shell (Admin mode >Business Process Updates node > Setup
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 Company Workspace tab (Admin mode > Company Workspace node > Business 
Process Updates) 

Once selected, all of the PM Books will be updated with correct values from the related PM Book 
Template, according to the push schedule defined within this log. 

See the Company Workspace and Preventive Maintenance Type BP (on page 320) section 
for details. 
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Setting up the Asset Manager 

About the Asset Manager 

The Asset Manager module is part of the company workspace. It is used to manage assets and 
depreciation. This manager allows users to can track assets and depreciation on their 
associated asset sheets. It allows users to enter company assets, set up depreciation schedules 
for them, and classify them into categories to make managing them more efficient. Ultimately, 
users can gather these assets onto a sheet to track asset depreciation in monthly, quarterly, or 
yearly increments. 

The Asset Manager uses four depreciation methods: straight line, double decline, sum of year 
digits, and manual depreciation. For each method, asset depreciation is calculated for the entire 
life of the asset over a specified period. For example, if an asset is depreciating over two years 
and you specify a monthly depreciation increment, then the asset’s value is recalculated each 
month for two years from the date of acquisition. 

The Asset Manager allows you to: 

 Create, organize, and manage company assets 

 Define an unlimited number of asset classes, and design an asset attribute form per asset 
class 

 Create assets: manual, templates, or import 

 Apply multiple asset depreciation methods: straight line, double decline, sum of years digits, 
manual 

 Track an asset’s total cost of ownership (roll up maintenance-related costs from projects or 
company-level BPs to specific company account codes) 

The Asset Manager does not directly use business processes; rather, it uses attribute forms to 
create asset classes and detail forms to create the assets themselves. In Unifier, an asset class 
maps assets to company account codes, tracks asset costs and depreciation, and keeps the 
company account sheet updated with current asset values. In addition, the manager uses 
reference processes to extract the asset’s acquisition cost from a company-level BP. 

In User Mode, the Asset Management node lists the names of every class. These nodes are 
where users create and modify new assets, set up their depreciation schedules, and refresh 
assets to recalculate their values and update the asset class sheet and the company account 
sheet. 

Asset Sheets: You can track assets and depreciation on asset sheets. There is one asset sheet 
per class, listing details about each asset in that class, plus an asset summary sheet, which 
helps you track all of your assets in one place. 

Asset Classes: Assets are grouped in classes (for example, buildings, equipment, etc.). The 
detail forms that are used to enter asset information can be configured in uDesigner, per class. 
For example, you can design and use different forms for entering information about your 
company’s building assets and equipment assets. Each asset exists as a unique record. 
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Asset Codes: Asset codes are generated automatically when assets are created. The asset 
code will be built using different data elements defined on the asset form as segments. At 
runtime, the asset code is built automatically based on the data element values selected. A tree 
structure is automatically built to access these assets based on the asset codes. Assets with the 
same segment values will be grouped together to form a hierarchy. 

Note: User permissions are granted per asset class or sheet. If you 
cannot view any part of the Asset Manager to which you require access, 
contact your company administrator. 

Setting up the Asset Manager 

Asset class forms must be designed in uDesigner. An asset class is a way to group assets of a 
similar type together. Examples of asset classes are buildings, vehicles, computer equipment, 
etc. Asset class forms are used to create new assets within each asset class, with a different 
form for different classes. The classes, forms, and corresponding logs are designed in 
uDesigner. 

Step 1: Design the asset classes and forms in uDesigner and deploy them into Unifier. 

Step 2: Configure and activate each class. This enables assets and asset sheets to be created 
for the class. It also enables projects to be associated with assets by creating asset categories 
for project creation. 

Step 3: Grant template administration permissions. 

Step 4: Create asset templates. These can be used to create assets under an asset class in 
User Mode. 

Step 5: Set up a depreciation schedule in an asset template or in individual company assets. 

Step 6: Create assets under asset classes in User Mode. You can create assets manually or by 
copying a template. If you did not set up the depreciation schedule in a template, you can do it 
per asset (Step 5). 

Step 7: Set up the asset sheets. Asset sheets are maintained in User Mode. 

In This Section 

Importing Asset Classes ........................................................................................ 329 
Configuring the Asset Manager ............................................................................. 329 
Configuring Asset Manager Configuration Package .............................................. 330 
Grant asset class template permissions ................................................................ 330 
Creating and Managing Asset Templates .............................................................. 330 
Creating a Depreciation Schedule ......................................................................... 332 
Setting Up and Managing Asset Sheets ................................................................ 338 
Managing Asset Sheet Properties ......................................................................... 342 
Map asset sheet columns to company account codes ........................................... 344 
Associating Projects with Asset Classes ............................................................... 345 
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Importing Asset Classes 

All designs, including asset classes, are designed in uDesigner and deployed to Unifier. See 
Importing Configuration Packages (on page 640). 

Configuring the Asset Manager 

Once an asset class has been imported, it must be configured and activated to create assets. 
Asset classes are listed in the Asset Manager configuration log automatically after importing, 
with a default status of inactive. 

To configure an asset class 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Asset Manager. The Asset Manager log opens. 
Any asset classes that have been designed in uDesigner will be listed in the log. 

3) Select an asset class record from the log window and click Open. The asset class window 
opens. 

4) Complete the General tab as described in the following table. 

5) In the Custom Print tab, utilizing MS Word’s XML schema, you can create a customized 
printed output. This is similar to creating custom-designed BP print layout as explained in the 
Create Custom-Designed BP Print Layout (Custom Print tab) section. 

6) To make the asset class active, click Active for the status. This will enable assets and asset 
sheets to be created in User Mode. The asset class is also available to use as a project 
category. 

7) Click OK. 

In this field: Do this: 

Sequence Format

Define the sequence used to create record numbers for new assets 
created for this class in User Mode. This is similar to business 
process numbering. Each time a new asset is created under this 
asset class, this sequence format will be used. 

Note: A sequence format change will not take affect once an asset 
is created under an asset class. 

Help File 
You can upload a PDF file as a help file for the Asset Manager. 
This file will be available from the asset class log window and 
individual asset record. 

Auto Creator Specify the auto-creator. 

Status 

Active or Inactive. Activating the configuration will make the class 
available in User Mode and Administration Mode to create assets, 
asset sheets, and asset templates. It also makes the asset class 
available as a project category in which to create projects that are 
associated with the assets. 
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Configuring Asset Manager Configuration Package 

The following configurations can be included in the Asset Manager Configuration Package:  

 General setup (in General tab) 

All the fields included in the General Configuration (General tab). 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the BIP Custom Print in the Custom Prints and Reports. 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 

Grant asset class template permissions 

Once you have activated an asset class configuration, you can create asset class templates that 
can be used to quickly create assets within the class. 

When you activate a new asset class in the configuration window, you must grant permission (to 
yourself, another administrator, or a group such as company administrators) to administer asset 
class templates and create assets in user mode. 

Creating and Managing Asset Templates 

You can create one or more asset class templates that can be used to create assets within the 
class. 

To access asset class templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Assets in the left Navigator and select the asset class for which you want 
to create a template. The templates log for the class opens. The log lists any templates that 
have been created for the asset class. 

The columns that appear on the log will depend on the asset class design. The design 
controls the appearance of the asset form, the log, and which fields you can search on using 
the Find button. This is true for templates as well as assets created in User Mode. 

To search for an asset template 

In the asset template log, click the Find button. You can search for the template based on fields 
available on the asset form used for the template. These fields will vary depending upon the 
design for your company. 
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Create an asset template 

The following describes how to create a new asset template manually. 

To manually create an asset template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, select the asset class under Templates > Assets. The templates log 
for the class displays. 

3) Click the New button. The Create New asset form opens. 

This form is similar to a non-workflow business process form. The form has two sections: 

 General: In the upper portion of the form, enter all the details about the asset. The fields 
on this form depend on the asset class attribute form design. 

 Standard tab: You can choose to define the depreciation schedule in a template. 
Creating a Depreciation Schedule (on page 332). Setting up the depreciation schedule 
is optional and can be defined in User Mode for each asset. Before you can set up a 
depreciation schedule, you must first save the form. 

4) Click Save to save changes to the upper form, or Finish Editing to save and close the form. 

Create a new template from an existing template or asset 

You can create a template by copying an existing asset or a template from the same class. 

To copy an existing template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Assets in the left Navigator and select the asset class for which you want 
to create a template. The templates log for the class opens. 

3) Select an asset class template from the log and click Copy > Template. The form opens 
with the information from the original template. 

4) Make changes as needed and click Finish Editing to save the new template. 

To copy an asset 

1) Select Copy > Asset. The Copy from Asset window opens. Assets from the same class are 
displayed in this list. 

2) Select an asset and click Copy to create a template. You can click Find to search for an 
asset by name. 

To edit an asset template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Assets in the left Navigator and select the asset class under which the 
template resides. The templates log for the class opens. 

3) Select the template and click the Open button. The asset class form opens. 

Note: If you previously clicked the Finish Editing button for the form, 
you can make it editable again by clicking the Edit button at the top of 
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the form. 

4) To edit the depreciation schedule, click the Depreciation Setup button. 

To delete an asset template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Assets in the left Navigator and select the asset class under which the 
template resides. The templates log for the class opens. 

3) Select the template and click the Delete button. Click Yes to confirm. 

Creating a Depreciation Schedule 

Each asset can be depreciated based on the depreciation definition associated with it. 
Depreciation of an asset will be based on acquisition cost, acquisition date, salvage value, etc. 
The Asset Manager will perform these calculations for each asset and update the asset form. 
These calculations can be shown on the asset class sheet and asset summary sheet, and can 
be optionally rolled up to the company accounts sheet. 

Note: Before you can create a depreciation schedule for an asset, you 
must populate the data set for the SYS Depreciation Name data 
definition. To do this, use the instructions under Adding and Managing 
Data Sets (on page 28). 

Depreciation calculation for an asset will be based on the selected method. The following 
methods are available: 

 Straight line method 

 Double decline method 

 Sum of year digits 

 Manual 

Regardless of which method is used, depreciation for an asset will be calculated from the 
specified asset acquisition date to the end of the depreciation period. 

These are the input parameters to calculate depreciation: 

 Acquisition date 

 Acquisition cost 

 Salvage value 

 Depreciation period 

 Factor% (only for double decline method) 

 Timescale units 

Depreciation output values: 

Output Value Description 

Net book value Book value of an asset as of a particular period 

Cumulative depreciation Accumulated depreciation cost of an asset over a period of 
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time 

Current period 
depreciation 

Depreciation cost of an asset for a particular period 

Straight line method 

This method is the simplest of all depreciation methods. Depreciation for each time period 
(timescale units) will be calculated by dividing acquisition cost by depreciation period. If asset 
has salvage value, it should be considered while calculating depreciation. 

Without Salvage 

Timescale Units Formula to Calculate Depreciation per Period 

Monthly Acquisition Cost / (Depreciation Period * 12) 

Quarterly Acquisition Cost / (Depreciation Period * 4) 

Yearly Acquisition Cost / (Depreciation Period * 1) 

With Salvage 

Timescale Units Formula to Calculate Depreciation per Period 

Monthly (Acquisition Cost – Salvage Value) / (Depreciation Period * 12)

Quarterly (Acquisition Cost – Salvage Value) / (Depreciation Period * 4) 

Yearly (Acquisition Cost – Salvage Value) / (Depreciation Period * 1) 

Net Book Value = Starting Book Value – Current Period Depreciation 

Starting Book Value = Net Book Value of Previous Period 

Starting Book Value of First Period = Acquisition Cost 

Example 

An asset with an original cost of $3,000 is depreciated yearly over three years beginning 
January 1, 2006, using the straight line method with no salvage value. 

 Depreciation beginning January 1, 2006 means that the acquisition date is 12/31/2006. This 
can be the purchase date of an asset or when the asset was put into service. 

 The asset form is updated with current period depreciation, net book value, and cumulative 
depreciation periodically based on timescale units. If the timescale units are years, these 
data elements on the asset detail form should be updated every year with the calculated 
values displayed on the depreciation sheet. In this example, the asset detail form will be 
updated every January. 
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The depreciation table would look like this: 

Period 
Starting Book 
Value 

Current Period 
Depreciation 

Net Book Value 
Cumulative 
Depreciation 

12/31/2006 
3000 
(Acquisition 
Cost) 

1000 
2000 
(3000-2000) 

1000 

12/31/2007 
2000 (Previous 
Net Book Value)

1000 
1000 
(2000-1000) 

2000 

12/31/2008 
1000 (Previous 
Net Book Value)

1000 0 (1000-1000) 3000 

Double decline method 

This method allows depreciation of an asset at an accelerated pace. The following formula is 
used while calculating depreciation per period. 

Current Period Depreciation = Net Book Value of Previous Period x Factor x (1/n) 

Net Book Value = Starting Book Value – Current Period Depreciation 

Starting Book Value = Net Book Value of Previous Period 

 Starting Book Value of First Period = Acquisition Cost 

 Factor = Value entered while defining the depreciation definition (enter a percentage value, 
usually 200% or 150% 

 n = Number of depreciation periods 

Salvage value is not considered while calculating depreciation for each period. But the 
acquisition cost – accumulated depreciation value should not go below the salvage value. For 
any depreciation period, if the acquisition cost – accumulated depreciation value goes below the 
salvage value, the depreciation for that period should be reduced so that the total value of the 
asset does not go below the salvage value. 

Example 

An asset value is $140,000. It will be depreciated over five years, and the factor entered is 
200%. The depreciation rate for this method is 200% x (1/5) = 40%. 

The first period calculation is 140,000 x 40% = 56,000. 

Sum of year digits 

The following formula is used for this method: 

Current Period Depreciation = (Cost – Salvage Value) * [Factor] 
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The calculation factor depends upon the depreciation period and will change for each period 
based on the following formula, where n is the number of depreciation periods: 

Fraction for first year = n / (1+2+3+4+5…n) 

Fraction for second year = (n-1) / (1+2+3….n) 

Fraction for third year = (n-2) / (1+2+3+…n) 

Manual 

With the manual method, you enter the current depreciation value for each period on the 
depreciation sheet. The net book value and cumulative depreciation are calculated automatically 
based on the depreciation value. Depreciation is calculated for each time period and displayed 
on the depreciation sheet. Once the depreciation calculation sheet is updated, the asset detail 
form is updated. 

Example 

An asset with an original cost of $3,000 is depreciated yearly over three years beginning 
January 1, 2006. The salvage value is $500. 

The initial depreciation sheet shows the following: 

Period 
Current Period 
Depreciation 

Net Book Value 
Cumulative 
Depreciation 

12/31/2006 0 3000 0 

12/31/2007 0 3000 0 

12/31/2008 0 3000 0 

Net book value and cumulative depreciation are calculated, read-only fields. 

Enter the depreciation amounts for each period. The net book value and cumulative deprecation 
are calculated as follows: 

Period 
Current Period 
Depreciation 

Net Book Value 
Cumulative 
Depreciation 

12/31/2006 500 2500 500 

12/31/2007 1000 1500 1500 

12/31/2008 1000 500 2500 

Set up a depreciation schedule 

You can set up the depreciation of an asset template after the general information has been 
completed, and you have clicked the Save or Finish Editing button. This is optional in a 
template. 
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Depreciation schedule columns are predefined. Columns are populated based on the 
depreciation calculation. Below is a sample depreciation schedule. 

Note: Before you can create a depreciation schedule for an asset, you 
must populate the data set for the SYS Depreciation Name data 
definition. To do this, use the instructions under Adding and Managing 
Data Sets (on page 28) 

To set up depreciation 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Asset Manager in the left Navigator and select the asset class. The asset log for the 
class opens. 

3) Click the Open button. The asset class form opens. 

If you previously clicked the Finish Editing button for the form, you can make it editable 
again by clicking the Edit button at the top of the form. 

4) Click the Depreciation Setup button. The Depreciation Setup window opens. 

5) Add a row by clicking the Add Row button. 

6) Complete the information for the depreciation setup as described in the table below. 
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7) Click OK to save and exit the window. 

8) When the asset template is complete, click Finish Editing. 

In this field: Do this: 

Default 
Choose one of the depreciation methods to use as a 
default for the assets that are created based on this 
template. This is optional. 

Name (required) 
Select from the drop-down list. The list is managed in 
the depreciation data source data definition. 

Depreciation Method (required) 

This drop-down lists the following depreciation 
methods: 

Straight line method 

Double decline method 

Sum of years digits 

Manual 

Timescale Units (required) 

This value determines the frequency of asset 
depreciation: 

Months: Asset will be depreciated every month 

Quarters: Depreciate asset quarterly 

Years: Depreciate asset yearly 

Factor% 

This is required for the double decline depreciation 
method. It is the value entered while defining the 
depreciation definition. Enter a percentage value, 
usually 200% or 150%. 
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Verify the depreciation data source list 

The list of available depreciation data sources is managed in the depreciation data source data 
definition data set. Below is a sample depreciation data source list. 

Setting Up and Managing Asset Sheets 

Asset sheets are created automatically when asset classes are imported and activated. Asset 
sheets are listed in the Asset Sheet log window in the User Mode Asset Manager. There is one 
sheet per asset class, plus an asset summary sheet that summarizes all asset sheets. Assets 
are added to asset sheets as rows automatically, listed by the segmented asset code. In the 
asset summary sheet, the rows are the asset classes. 

The asset summary sheet displays information of all asset sheets. It displays total values from 
individual asset class sheets. The asset summary sheet is created automatically once the first 
asset class is imported. Asset classes imported into Unifier are automatically added as rows. 

Columns can be added to asset sheets. Some examples of columns include: 

 To capture data from the asset form. 

 Business processes—Company-level BPs with line items with asset code subtype are 
available; only the Amount field is available. 

 Project cost columns—Most columns from project cost sheets are available; only the Amount 
field is available. This is available when projects are created under asset categories. 

 Manual entry or formula columns 

Users with create permission on asset class sheets will be allowed to create and define 
columns. 

Create an asset sheet column 

Columns can be added to asset sheets. These columns can be used to capture data from the 
asset form, business processes, or manually entered data on the sheet. Users with create 
permission on asset class sheets are allowed to create and define columns. 
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To create a new asset sheet column 

1) In the asset sheet, click the Columns button in the menu bar. The Asset Sheet Columns Log 
opens. 

2) In the menu bar click New. The Column Properties window opens. Complete the window as 
described in the following table. 

In this field: Do this: 

Name 
The Name field is populated with the data source value 
selected. 

Datasource 

Select a data source. The drop-down list lists the data 
elements found on the asset class form. This list also shows 
data elements based on SYS Numeric Logical Datasource, 
Sys Date Logical Datasource, Sys Business Process 
Datasource, and Sys Project Cost Datasource data 
definitions. Data sources of type SYS Numeric Logical 
Datasource, SYS Date Logical Datasource, Sys Business 
Process Datasource, and Sys Project Cost Datasource can 
only be used once. 

Examples include: 

Business processes: Company-level BPs with line items with 
asset code subtype are available. Only the Amount field is 
available. 

Project cost sheet: Columns defined with Sys Project Cost. 

Entry Method 

Choose one of the following data-entry methods to use for 
the column. The available choices vary depending on the 
data source selected. Options include: 

Manual entry: User enters data directly into the cell, or data 
is rolled up from another source, such as the asset form. 

Formula: Options are Numeric, Date Difference, and Date 
Add. 

Data Type: This option is applicable if the data source is SYS 
Business Process, a business process or information from 
the project cost sheet. After selecting the data type, click 
Define to choose the data element or define a formula based 
on the data element. 

Date Format 

Specify how you want the column data to appear. This is 
applicable to numeric columns. Options are: 

 Show as Percentage: Data entered in a column will 
display in percentage format. For example, if a user 
enters 0.25, it will display as 25%. 

 Decimal Places: Select the number of decimal places to 
display. 

 Use 1000 Separator (,): Data entered is formatted with a 
separator; for example, 1,000, not 1000. 
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 Negative Number Format: Select how negative values 
will be displayed on the sheet: with a negative sign or in 
parentheses. 

Display Mode 
Select Hide to make the column invisible to users, or Show
to display it. 

Total 

This controls what displays in the bottom summary row for 
each column: 

 Blank: Summary row will remain blank. 

 Sum of All Rows: Displays the sum total of all row 
values for this column. 

 User Formula Definition: Formula entered in the 
Formula field will apply to the summary row. 

Column Position After 
Select a column from the list. This determines the position of 
the column on the sheet. 

To copy a column 

1) In the Column log, select a column and click Copy. The Column Properties window opens. 

2) Make changes as necessary for the new column. You must change at least the data source. 

Add a column for business process data 

You can add a column that captures data from a selected business process. The business 
process must be company level of type line items with asset code. 

You can roll up data directly from the business process or create a formula for the column based 
on the data. 

To add a column for business process data 

1) Open the Asset Sheet to which you want to add a column. 

2) Click the Column button, located in the sheet tool bar. 

3) In the Column Properties window, choose a data source of type Sys Business Process. 

This allows you to link the column to a company-level business process of type line items 
with asset code. 

4) For the entry method, choose Data Type and click the Define button. The Define Data Type 
window opens. The window is similar to a formula window. 

5) Click the Select button and select a business process from the list. The list includes only 
company-level BPs with the line items with asset code subtype. Only the Amount field is 
available. You can optionally use the field to define a formula. 

6) Click OK. Save the column definition. 

Add a column for project cost data 

You can add a column that captures data from a project cost sheet, allowing you to link assets 
with project cost data. You can roll up data directly from the project cost sheet or create a 
formula for the column based on the data. 
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To add a project cost data column 

1) Create a new column. 

2) In the Column Properties window, choose a data source of type SYS Project Cost. 

3) For the entry method, choose Data Type and click the Define button. The Define Data Type 
window opens. The window is similar to a formula window. 

4) Click the Select button and select from the list. The list includes data sources that are 
available while defining a project cost sheet, such as an assigned budget, revised budget, all 
cost business processes, and project cost 1 to project cost 25. Only the Amount field is 
available. Data from the project will be rolled up to an asset class sheet in the base currency. 
You can optionally use the field to define a formula. 

5) Click OK. Save the column definition. 

Add a formula column 

You can add a formula column to the sheet for data sources that are based on either the data 
definitions SYS Numeric Logical Datasource or SYS Date Logical Datasource. 

You can define formulas for the following types: 

 Numeric: This option is available if the data source is SYS Numeric Logical. 

 Data Difference: This option is available if the data source is SYS Numeric Logical. It is 
used for formulas that calculate the difference between two dates. 

 Date Add: This option is available if the data source is SYS Date Logical. It can be used to 
add values to a date to calculate a new date. 

To create a numeric formula 

1) In the column Properties window, choose Formula and select Numeric. 

2) Click Create. The Create Formula window for numeric formulas opens. 

3) Select either Item or Sheet from the data type drop-down list. Item lists data elements that 
are defined on the form. Sheet lists columns that are already defined on sheet. 

4) Build a formula by doing the following: 

 To include a data source in the formula, select the data source from the list and click 
Select. 

 Click a mathematical modifier (plus, minus, and so on) and numbers on the keypad. 

5) When the formula is complete, click OK. 

To create a date difference formula 

1) In the column Properties window, choose Formula and choose Data Difference. Click 
Create. The Date Difference window opens. 

2) For Earlier Date and Later Date, click Select. Select a data element. The list includes date 
type data elements from the form or existing date type columns on the sheet. 

3) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 
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 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

 Show Partial Day

4) Click OK. 

To create a date add formula 

1) In the column Properties window, choose Formula and choose Data Add. Click Create. The 
Date Add window opens. 

2) For the Date field, click Select and choose a data element from the list. 

3) For the Add field, click Select and choose a data element from the list. 

4) Choose one of the following: 

 Calculations based on Calendar Days: The calculation is based on calendar days and 
does not take company non-working days into account. 

 Calculations based on Work Days: The calculation is based on the company calendar 
working and non-working days. 

5) Click OK. 

Create an asset summary sheet column 

You can add columns to the asset summary sheet to display information from individual asset 
sheets. Available data types are the columns on the asset summary sheet. 

Edit asset details from the asset sheet 

You can edit asset detail information directly from the asset sheet, without having to open the 
asset form. 

 Modify data elements from the asset when defining columns. 

 Data elements are editable from the asset class sheet. 

 Changes made to elements from the sheet will be reflected on the asset detail form 
automatically. 

 Data elements that are editable and not required are editable from the sheet. 

 Conditions under which a data source is not editable from a sheet object include: 

 All pickers except the Date picker 

 Data elements that are of SYS Logical Datasource formulas 

 Data elements that are SYS Business Process Datasource and SYS Project Cost 
Datasource 

Managing Asset Sheet Properties 

The Properties window for the asset sheet maintains the name and display options. You can 
also track asset value by associating a column on an asset sheet with a company account code. 
The company accounts sheet must be defined and account codes created before you can 
perform this mapping. 
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To open the asset summary sheet Properties window 

1) In the Asset Sheets log, select the asset summary sheet and click the Properties button. 

2) Complete the General tab as described in the following table. 

3) In the Options tab, asset sheet columns can be mapped to company account codes. The 
total value of the column will roll up to the company accounts sheet. 

In this field: Do this: 

Title 
This is the name of the asset sheet, which reflects the class 
name and is read only. 

Description Enter an optional description. 

Display Mode 

Choose one of the following: 

Tree: Lists the asset codes in a hierarchical manner based 
on the code segments and mimicking the tree structure in 
the Navigator. 

Flat: Lists the codes in a flat structure. 
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Include 

Choose one of the following: 

All Assets: All asset records created in the class will be 
displayed on the sheet 

Assets with statuses: Click Select and choose one or 
more statuses from the list. Only assets with one of the 
selected statuses will be displayed on the sheet. 

Map asset sheet columns to company account codes 

You can track asset value by associating a column on an asset sheet with a company account 
code. The company accounts sheet must be defined, and account codes must be created before 
you can perform this mapping. 

Notes:  

 You can map an asset sheet column to more than one account code. 
For example, Column A can be mapped to both Account Code X and 
Account Code Y. This means that the total will display for both 
account codes in that column. However, each account code can be 
mapped only once. Account Codes X and Y cannot be mapped to 
any other columns; that is, you cannot map two columns of an asset 
sheet to a single account code. 

 If you remove a column from the asset sheet that is associated with 
an account code, the mapping will be lost. 

Once mapping is done, data from the asset sheet is rolled up to the accounts sheet under the 
Assets data source, which can be used to define an accounts sheet column. Only the total value 
will be rolled up. 

Whenever there is change to an asset sheet column, that column data (total value) will roll up to 
the accounts sheet based on the mapping. 

Following are the triggering conditions under which data is rolled up to the accounts sheet: 

 When a column is mapped to an accounts sheet after the Properties window of the asset 
sheet is saved. 

 When a column mapping is changed or removed on the asset sheet properties window. 

 When a column in the asset sheet gets updated due to changes in the asset or asset sheet. 
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Note: The process used to update the accounts sheet with mapped 
asset sheet data runs in the background. After mapping an asset column 
to the accounts sheet or updating the asset sheet data, the change may 
not be reflected in the accounts sheet immediately. 

To map an asset sheet column to a company account code 

1) In User mode, go to the Company Workspace tab and open the Asset Sheets log in the left 
Navigator, select an asset sheet, and click the Properties button. The Properties window 
opens. 

2) Click the Options tab, then click the Add button. The Add Mapping window opens. 

3) Use the table below to complete the fields in this window. 

4) Click OK. 

In this field: Do this: 

Column Name 
The drop-down list lists all columns that are defined on the asset 
sheet. Select the column you want to map to the account sheet. 

Account Code 
Click Select. A picker window opens displaying active codes from 
the accounts sheet. Select a code and click Open. 

Account Name 
This field is populated with the name of the account code chosen in 
the previous field. 

To modify or remove mapping 

Select a row and click Modify to edit mapping, or Remove to remove mapping. You cannot map 
two columns of an asset sheet to a single account code. 

Associating Projects with Asset Classes 

You can associate one or more projects with an asset. This allows you to manage assets using 
projects with full project functionality (cost sheet, business processes, etc.). 

The asset class is added to the list of available categories that can be used to organize projects. 
By default, the new asset class categories are inactive. You must activate them to use them. 
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To associate a project to an asset class: 

 Activate the asset classes as project categories. This enables projects or project templates 
to be created under the asset category. 

 Create a new project or project template under the asset. Creating a project under the new 
asset category allows you to associate a project with an asset. You cannot associate an 
existing project to an asset. 

To activate asset classes and use them as project categories 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Configuration > Shell Manager. 

3) Select Projects (Standard) and click the Open > General button. The Configuration 
Projects (Standard) window opens. 

4) Click the Organize tab. 

5) Select the asset class on the list and click the Active button. The asset class can now be 
associated with a project. 

6) Click OK. Click Yes to confirm. 

7) Click OK to save and exit the Edit Company window. 

Note: You must grant user permission to yourself or other users or 
groups to view the new category. 

To create a new project under an asset 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) select the asset class category under one of the following in the left Navigator: 

 Templates > Projects (Standard)> project >Asset Manager > [asset class category]

 Company Sponsored Projects > project >Asset Manager > [asset class category]

3) Create a new project or project template under the asset class category. 

4) Complete the project or project template properties window. 

When created under an asset class, an Asset picker is preset on the General tab. 

5) In the Asset field, click the Select button. The Assets window opens, listing the assets 
created under the asset class. 

6) Select an asset from the list and click Open. 

Selecting an asset is not required for project templates, but is required when creating new 
projects. This selection cannot be edited. The asset is displayed in the Projects log. 

Note: The Asset picker is not available on projects or templates that are 
not created under category nodes based on asset classes. 
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Setting up the Code-Based and Records-Based 
Configurable Manager 

Configurable manager, as well as classes, forms, and corresponding logs are designed in 
uDesigner (Configurable Modules) and deployed to Unifier. You must also define the business 
processes that work with the configurable manager. 

Note: Assign a specific name for the configurable manager in 
uDesigner. The generic term used in the instructions is configurable 
manager. 

Step 1: Design code-based and records-based configurable manager in uDesigner 
(Configurable Modules). 

Step 2: Setup the Business Process Data elements under the Options tab and deploy the 
manager. After the manager has been deployed, classes can be designed and deployed. 

Step 3 Set permissions. 

Step 4: Configure the code and records-based manager. 

Step 5: Set the template administration permissions. 

Step 6: Create template sheets and add columns. 

Step 7: Set permissions for the user. 

In This Section 
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Setting Permissions to Import Configurable Managers 

You must have modify permission under Access Control > Administration Mode Access > Data 
Structure Setup > Configurable Modules to import configurable managers. You can set view 
permissions to allow users to view configurable modules. 

Importing Code and Records-Based Configurable Managers 

All designs, including configurable managers, are designed in uDesigner and deployed to 
Unifier. See Importing Configuration Packages (on page 640). 

Note: Importing Forms that Contain Data Pickers: Data pickers point to a 
data source for the records they display. If that data source—the BP, 
shell, or manager class—to which the picker is pointing is not already in 
Unifier, you will receive a warning. The business process will not operate 
correctly until the data source is imported. 

Deleting a Material Inventory Manager 

This section describes how to manually delete a record under Material Inventory Manager from a 
shell template.  

Note: You can delete a record under Material Inventory Manager from a 
specific shell template but not from other Projects/Shells that have been 
created using the template. 

In Administration mode: 

1) Open the project or shell and in the left navigation pane, click Setup > Material Inventory 
Manager. 

2) Select a record from Material Inventory Manager for deletion. 

3) Click Delete. 

Note: System prompts the user asking to confirm deletion of the record. 

4) Click Yes to delete the record from the Material Inventory Manager. 

Setting Permissions to Import Classes 

Classes must be deployed before you can set permissions. Set permissions based on existing 
permissions for the Company > uDesigner. 

Importing Classes for Code and Records-based Configurable Managers 

To import a class into the Unifier Production environment, see Importing Configuration 
Packages (on page 640). 
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Configure configurable manager classes 

Imported configurable manager classes are listed in the manager configuration log, with a 
default status of inactive. 

To configure a configurable manager class 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > [configurable manager] in the left Navigator. The Configurable 
Manager log opens. The log lists the classes. 

3) Select a class record from the log window and click Open. The Configuration window opens. 

4) Complete the General tab as described in the table below. 

5) On the Custom Print tab, using MS Word’s XML schema, you can create a customized 
printed output (similar to Create Custom-Designed BP Print Layout (Custom Print tab)
(on page 223)). 

6) To make the class active, click Active. This enables classes and sheets to be created in 
User Mode. The class is also available to use as a project category or shell type. 

7) Click OK. 

In this field: Do this: 

Sequence Format 
Define the sequence of the record numbers for records created 
for this class in User Mode. This is similar to business process 
numbering. 

Help File You can upload a PDF file to use as a help file for the manager. 

Auto Creator Select the auto-creator. 

Status 
Activating the configuration makes the class available in User 
Mode and Administration Mode for creating records, sheets, and 
templates. 

Run an error check on a class 

To error-check imported classes: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click uDesigner > [configurable manager] in the left Navigator to open the Configurable 
Manager log. 

3) Select one or more classes in the log. To select multiple classes, press the Ctrl key or Shift
key while selecting the classes. 

4) Click the Error Check button. After validation, the error check window opens, listing any 
errors that were found. 

5) To fix the errors, make the changes in uDesigner. 
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Configure a Data Picker for the Manager 

If your code-and-record-based manager includes a data picker or a user data picker, it must be 
configured to examine and extract the records that should appear on the picker list. To do this, 
you need to create a database query. (For more information on data pickers, see the Unifier 
uDesigner User Guide. And for more information on queries, see Queries. 

Once you have set up the query or queries for a data picker, and the picker is active in Unifier, 
the queries will be launched whenever: 

 The user clicks the data picker field on a form 

 The business process is auto-created 

 A record is created or updated through integration (both CSV and Web Services) 

 The data picker is updated via reverse-auto-population 

For more information on data pickers, see "About Data Pickers" and "About User Data Pickers" 
in the Unifier uDesigner User Guide. 

In addition to setting up queries to extract records for the picker, you can configure the picker to 
filter the records that the query returns so that only certain records appear on the picker. This is 
particularly convenient, for example, if the manager attribute form contains a user data picker 
that automatically assigns users to an object as it is created. 

To configure a data picker 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click uDesigner > [design object] in the left Navigator to open the design log window. 

3) Select the design and click Open > Data Picker to open the Data Picker Configuration
window. 

4) In the left pane, click the name of the data picker. 

5) Create the query. 

The query will search the database and extract the records to display on the data picker. The 
query will filter the records returned from the database according to a condition or conditions 
you specify. The condition(s) will "test" a field on the form to see if it passes or fails the 
criteria. If the field passes the criteria, Unifier will include it on the data picker. 

a. Click the Add button. Unifier displays the Add Query Condition window. 

b. In the Data Element field, select the field on the business process that you want to test 
with the condition. 

For example, the condition might be that the status field on the shell must be "Active." 

The window expands to show an active Condition field and additional fields where you 
can specify the query criteria. 

Note: If any field in the query or queries is subsequently removed from 
the configurable manager attribute form, the entire query operation will 
be ignored. That is, if one query fails because a field was removed from 
the design, Unifier will ignore all the queries. If a field has been removed 
from a design, you must amend the query. 

c. In the Condition field, select the condition the value in the field must meet. 
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The remaining fields on this window vary, depending on the data element and the 
condition you specified. For help in completing these fields, use the information in the 
Queries section to complete the query. 

d. Repeat steps a through c to include additional query conditions. 

6) (Optional) Filter the returned records. 

This filtering option appears on configurable manager attribute forms that contain user data 
pickers. This option will filter the list of groups or users that appear on the picker. Use the 
instructions in the table below to filter the returned records. 

7) When you have finished, click OK. 

In this field: Do this: 

Filter list of 
Users/Groups 
based on 
Project/Shell 
Membership 

Select this checkbox if you want to filter the list of users on the 
picker to show only those with project or shell membership. 

In operation, Unifier will auto-populate and reverse-auto-populate 
the data picker with all users or groups, regardless of this 
checkbox. However, at runtime, Unifier will filter the picker for the 
user if you select this checkbox. 

Note: If you select this option, the rest of the filtering options will 
be disabled. 

Group Membership 
Select the group from which you want to specify a user or users. 
The drop-down list shows all the groups that are at the company 
level. 

Project/Shell 
Membership. 

If you want Unifier to add these users to the shell membership, 
select the Add user to Project/Shell checkbox. If you want to also 
add these users to the group under the shell, select the Add user 
as a member to the selected group checkbox 

Note: To use this option, the user data picker must be on the 
upper form, not the detail form. 

Show results 
matching any 
condition  

If the checkbox is checked, the query conditions will be "OR." 
When this option is selected, the value in the AND/OR column 
will be updated to "OR." 

If the checkbox in unchecked, the value in AND/OR column will 
be "AND." If the checkbox is checked, then records satisfying any 
of the query conditions would be displayed at run-time. 

If the checkbox is unchecked, then records which satisfy all of the 
query conditions will be displayed.  

Setting Template Administration Permissions 

After you have configured a configurable manager, you can create templates to use with the 
manager. 
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When you activate a new class, you must grant permission to yourself, another administrator, or 
a group such as company administrators to administer class templates and create classes in 
User Mode. 

You must have administrator permission granted under Access Control > Administration Mode 
Access > Data Structure Setup > Configurable Modules to administer configurable managers. 

Managing Class Template Sheets (Classic view) 

You can create one or more class templates for each class for each configurable manager.  

Create a class template 

You can create a new class template manually or by copying an existing template that is the 
same class as the new template. 

To manually create a class template 

1) In Administration Mode, go to the Company Workspace tab and click Templates > 
Configurable Modules in the left Navigator. 

2) In the Navigator, select the configurable manager. The templates log for the classes opens. 

3) Click the New button. Select the class for which you want to create the new template. The 
Properties window opens. Complete the window as described in the following table and then 
click OK. 

In this field: Do this: 

Title 
Enter the name of the sheet, which reflects the class name and is 
read only. 

Description Enter an optional description. 

Display Mode 

Choose one of the following: 

Tree: Lists the codes in a hierarchical manner based on the code 
segments, mimicking the tree structure in the Navigator. 

Flat: Lists the codes in a flat structure. 

Picker 

Choose one of the following to include: 

All Records: All records created in the class are displayed on the 
sheet. 

Records with statuses: Only records of the selected status are 
displayed on the sheet. Click Select and choose one or more 
statuses from the list. 

To copy an existing template 

1) To copy a template from the company level, select a class template from the log and click 
Copy > Template. The Properties window opens with the information from the original 
template. 
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2) To copy a template from the project or shell level, click Copy > Project or Copy > shell 
name. 

3) Make changes as needed and click OK to save the new template. 

To access configurable manager class templates 

1) In Administration Mode, go to the Company Workspace tab and click Company > 
Templates > Configurable Modules. 

2) In the Navigator, select the configurable manager. The templates log for the classes opens. 

To search for a class template 

In the class template log, click Find. You can search for the template based on the fields 
available on the form used for the template. These fields vary depending on the design. 

Add columns to sheet templates 

You can add columns to configurable manager sheet templates. You can use these columns to 
capture data from business processes or manually entered data. You can add columns to the 
template, but cannot add rows. 

Users with create permission on class sheets are allowed to create and define columns. 

To add a sheet column 

1) Open the sheet. 

2) Click Columns. The Columns Log opens. 

3) Click New. The Column Properties window opens. Complete the window as described in the 
following table. 

In this field: Do this: 

Name 
The Name field is populated with the data source value selected. 
You can change this name as desired. It is helpful, but not required, 
to use a unique name. 

Datasource 

Select a data source. You can use a data source only once; 
however, you can use the column in a formula. For example, if one 
data source is Commits (Approved), and another is Change 
Commits (Approved), you can add them together in a new column 
called Total Commits (Approved). 

Entry Method 

Choose the data-entry method to use for the column. The choices 
available depend on the data source selected. The options include: 

 Manual entry: Users can enter data directly into the cell, or 
data is rolled up from another source, such as the form. 

 Formula: The options are Numeric, Date Difference, and Date 
Add. See Add a formula column (on page 341) for details on 
adding formula columns. 

 Data Type: Applicable if the data source is SYS Business 
Process, a business process, or information from the project 
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cost sheet. After selecting the data type, click Define to choose 
the data element or define a formula based on the data 
element. 

Data Format 

Specify how you want the data in numeric columns to appear. 

 Show as Percentage: Data displays as a percentage. For 
example, if a user enters 0.25, it displays as 25%. 

 Decimal Places: Select the number of decimal places to 
display. 

Note: If the data element was defined in uDesigner with a specific decimal amount, it will override 

any decimal amount you specify here. 

 Use 1000 Separator (,): Data uses a separator for thousands. 
For example, 1,000 with a comma, not 1000. 

 Negative Number Format: Select whether negative values are 
displayed with a negative sign or in parentheses. 

Display Mode 
Select Hide to make the column invisible to users, or Show to 
display it. 

Total 

Controls what displays in the bottom summary row for each column:

 Blank: The summary row remains blank. 

 Sum of All Rows: Displays the sum total of all row values for 
this column. 

 Use Formula Definition: Use the formula entered in the 
Formula field. 

Column Position 
After 

Determines the position of the column on the sheet. Select a 
column from the list. 

To copy a column 

1) In the Column log, select a column and click Copy. The Column Properties window opens. 

2) Make changes as necessary for the new column. You must change at least the data source. 

Copy sheets under project or shell templates 

You can copy one sheet for each project or shell template. 

To copy a sheet under a project or shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Templates > Projects > All or Company > Templates > Shells > 
[shell]. 

3) To copy a template from the company level, select a class template from the log and click 
Copy > Template. The Properties window opens with the information from the original 
template. 

4) To copy a template from the project or shell level, click Copy > Project or Copy > shell. 

5) Make changes as needed and click OK to save the new template. 
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Deleting Sheets Template 

This section describes how to manually delete a sheet associated with code-based or 
record-based Manager from a shell.  

Note: You can delete a sheet associated with code-based or 
record-based Manager from a specific shell template but not from other 
Projects/Shells that have been created using the template. 

In Administration mode: 

1) Go to Company Workspace tab and open the project or shell. 

2) From the left Navigator, click Templates > Configurable Modules > Material Inventory 
Manager > Sheets. 

3) Select a sheet associated with code-based or record-based Managers. 

4) Click the Delete icon. 

Note: System prompts the user asking to confirm deletion of the sheet. 

5) Click Yes to delete the sheet from the code-based or record-based Managers. 

Manage sheet properties 

The Properties window for the sheet maintains the name and display options. 

To open the summary sheet Properties window 

In the Configurable Manager Sheets log, select the sheet and click the Properties button. 

In this field: Do this: 

Title 
This is the name of the sheet, which reflects the class name 
and is read-only. 

Description Enter an optional description. 

Class 
Read-only field that displays the class associated with the 
sheet. 

Display Mode 

Choose one of the following: 

Tree: Lists the codes in a hierarchical manner based on the 
code segments, mimicking the tree structure in the Navigator. 

Flat: Lists the codes in a flat structure. 

Picker 

Choose one of the following to include: 

All Records: All records created in the class are displayed on 
the sheet. 

Records with statuses: Only records of the selected status 
are displayed on the sheet. Click Select and choose one or 
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more statuses from the list. 

Managing Class Template Sheets (Standard view) 

View Code-Based Managers Log 

For details on how to view the code-based managers log refer to the Unifier Managers User 
Guide. 

View Code- and Record-Based Managers Log 

For details on how to view the code- and record-based managers log refer to the Unifier 
Managers User Guide. 

Setting User Permissions for Code and Records-Based Managers 

For users to be able to work with the configurable manager class sheet, you must set user 
permissions for the class sheet under Access Control > User Mode Access > Company 
Workspace > configurable manager name > Class Sheets. 



357

Setting up the Cost Manager 

Unifier Cost Manager consists of several modules designed to help you track and manage cost 
in projects, shells, programs, and across the company. Setup of the cost manager modules 
includes the following. 

In This Section 

Cost Manager Overview ........................................................................................ 357 
Cost Managers and Unifier Functional Areas ........................................................ 360 
About Currencies and Exchange Rates ................................................................. 361 
Setting up Cost Sheets .......................................................................................... 370 
Setting up a Company Accounts Sheet ................................................................. 408 
Setting up the Funding Manager ........................................................................... 413 
Setting Up Schedule of Values (SOV) ................................................................... 441 
Setting Up Cash Flow ............................................................................................ 446 
Setting up the Rules Engine .................................................................................. 461 
Setting up a Generic Cost Manager....................................................................... 470 

Cost Manager Overview 

The Cost Manager consists of the modules and features listed below. 

Cost Sheets 

Project/Shell cost sheet: The project or shell cost sheet is a detailed accounting of the project’s 
or shell’s budget and costs. It works much like a spreadsheet within Unifier that calculates and 
maintains the project or shell cost information stored in the project or shell. The project or shell 
cost sheet rows contain unique CBS codes (or cost codes), which can be used to link project or 
shell or program costs to the general ledger for finance. Cost information can be entered 
manually, pulled from work packages or worksheets, or rolled up automatically from business 
processes when transactions occur in Unifier. 

Program cost sheet: Program cost sheets are created automatically once a project cost sheet 
has been created in at least one project within the program. The columns of the program cost 
sheet can be set up to allow cost sheet data to roll up automatically from individual project cost 
sheets. The Program Cost Sheet will display cost data for all projects (within the program) that 
have a status of Active, On-hold, or View-Only.  The currency used is the company base 
currency. Projects on the program cost sheet are sorted automatically by ascending project 
number. As new projects are added to the program, and cost sheets are created for them, the 
new projects will be automatically added to the program cost sheet. 
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Company cost sheet: The company administrator can create a company-level cost sheet to 
display cost data across project or shells. Projects or shells on the company cost sheet are 
added by default as project- or shell-level cost sheets are created. Only active and on-hold 
projects or shells should be rolled up to a company-level cost sheet. Projects and shells are 
listed in order by project or shell number in an ascending order. Data rolls up to the company 
cost sheet columns from individual project or shell cost sheet columns by data source. The data 
displayed on the program cost sheet is view only. 

Work packages: In addition to a project or shell cost sheet, multiple work packages may also be 
defined. A work package is a group of cost sheet rows that is a subset of the project or shell cost 
sheet. Work packages provide insight into the budget without providing full access to the details 
of the project or shell cost sheet. 

Worksheets: Cost worksheets can be created to support the project or shell cost sheet. They 
can be used as sub-cost sheets, enabling specific calculations or data entry in a separate sheet, 
which can then be rolled up into a defined project or shell cost sheet column. For example, a 
worksheet can be used to offload complex calculations, which can be rolled up into a single cost 
sheet column. Worksheets support manual data entry and formulas. Business processes do not 
roll up to worksheets. Permissions can be controlled for individual worksheets. Worksheets are 
not independently reportable; however, cost sheet columns that reference worksheets can be 
reported on. 

Funding Manager 

Company funding sheets: The company funding sheet tracks all sources of funding across all 
projects or shells and programs. You create only one sheet per company. Funding sources that 
are made available at project or shell sheet level are rolled up to the company sheet, which 
maintains the overall fund information. Once created, the company funding sheet can be edited, 
but not deleted. The company funding sheet must be created before creating individual project 
or shell funding sheets. 

Project/Shell funding sheets: The project or shell funding sheet tracks how funding is being 
allocated and consumed at the project or shell level. Project or shell fund sheets work in 
conjunction with the company funding sheet. Allocating funding sources at project or shell level 
can be done manually or through a business process. A funding template and company funding 
sheet must be complete before you can create a project or shell funding sheet. 

Commitment funding sheets: You can optionally set up commitment level funding, which 
allows you to allocate specific project/shell funds to individual base commit records. This works 
in conjunction with the SOV sheet to track base and change commit lines and balances. 

Cash Flow 

Unifier advanced Cash Flow module includes the ability to create multiple baseline, spends, 
forecast and custom curves and compare them on one cash flow worksheet. You can create 
data source, distribution profiles, and cash flow curve templates to simplify creation of cash flow 
in multiple projects and shells. Administrators can also set up base commit business processes 
to automatically create cash flow curves for the commitment record at a particular workflow 
step,(or for non-workflow BPs, when the record is complete). 
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Earned Value 

The earned value module provides quantitative tracking information about project or shell status 
using earned value analysis. It provides specific numerical measurements for reviewing progress 
as the project or shell team advances through the work tasks allotted to the project or shell 
schedule. The module helps project or shell managers track whether projects or shells are on 
schedule and on budget. It provides accurate and consistent methods to estimate the percent of 
budget spent, percent of work done, and percent of time elapsed. 

Schedule of Values (SOV) Sheet 

The schedule of values (SOV) module provides a way to assemble information from contract, 
change order and invoice/payment business processes into an SOV sheet, streamlining the 
process of invoicing for completed phases of a project or shell. SOV functionality is available 
with uDesigner-created cost BPs for which the Allow creation of Schedule of Values option is 
defined. 

The business processes can be designed to create an SOV sheet automatically upon reaching 
the designated step. 

The following are the SOV sheets types: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

Generic Cost Manager 

The Generic Cost Manager captures cost-related activities for a generic shell. These include 
costs like rent, lease payments, landscape care, building maintenance and repair, remodel of 
building interiors, and more. 

With this manager, you can capture and view cost transaction information based on a timescale, 
such as quarterly or yearly. Each shell can have one Generic Cost Manager. The Generic Cost 
Manager uses specific generic cost business processes as a data source. 

About Cost Managers and Unifier functional areas 

The standard Cost Manager and the Generic Cost Manager work with different areas of Unifier. 
This table lists the areas and indicates which cost manager works with each area. 

Cost Manager Company Program 
Project 
(Standard) 

Shell (CBS) Shell (Generic)

Cost Manager 
(standard CBS) 

X X X X 

Generic Cost 
Manager 

X 
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The cost data from Project (Standard) and Shell (CBS) can both roll up to the Company level. 
The cost data from Shell (Generic) does not roll up to Company Level. 

Grouping Line Items and Auto-Creation 

You can group line items during auto-creation of BP records, in Lease type business process 
(BP). 

1) Go to the project/shell and switch to Admin mode. 

2) From the left-hand Navigator, click Setup node to expand. 

3) Click the Business Processes node to open the Business Processes log pane. 

4) From the Business Processes log click to select a Leases BP, for example, Leases - 
Tenant BP. 

5) Click to select a BP record and click Open to open the Business Process Setup window. 

6) Click the Auto Creation tab. 

7) From the left-hand pane, click Payment Request (or Payment Invoice). 

8) On the right-hand pane click to select Enable grouping of line items when auto-creating 
records from line item tabs. 

9) From the Group By field, click Select and proceed to select the data element, or elements, 
that you want from the Select Data Elements window. 

10) When finished, click Apply, and then click OK. 

Consolidating strings cannot take place if the field values are different. As a result: 

 If you select a data element other than "Payment Type" (uuu_lse_pay_type), in the 
Group By field and the auto-created record, has different payment type across the grouped 
line items, then the auto-created BP record will have a blank payment type. 

 Same logic is followed if a data element is present in the auto-created BP record, but the 
data element has a different value across the line items. 

Cost Managers and Unifier Functional Areas 

The standard Cost Manager and the Generic Cost Manager work with different areas of Unifier. 
This table lists the areas and indicates which cost manager works with each area. 

Cost Manager Company Program 
Project 
(Standard) 

Shell (CBS) 
Shell 
(Generic) 

Cost Manager 
(standard 
CBS) 

X X X X 

Generic Cost 
Manager 

X 

The cost data from Project (Standard) and Shell (CBS) can both roll up to the Company level. 
The cost data from Shell (Generic) does not roll up to Company Level. 
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About Currencies and Exchange Rates 

Unifier cost management system supports multiple currencies and exchange rates. The 
functions Unifier uses are exchange rates sets, effective dates, future exchange rates, base 
currency, project currency, transaction currency, project/shell currency options, and currency 
pickers. What follows are descriptions of each of these functions and how they are used in 
Unifier. 

Currencies 

Standards & Libraries> Currencies: This is where a Unifier Administrator can manually add 
new company currencies to suit the company business needs, in addition to the predefined list 
of currencies. You need to have appropriate permission to access the Currencies sub-node. 

You can see the Currencies node in the Permission tab of the User properties: Company 
Workspace > Access Control > Administration Mode Access > Currencies. 

A Unifier Administrator can setup both users and Groups permissions to the Currencies 
sub-node. There are three types of permissions allowed: Create, Modify, and View. 

 A user that has the "Create" permission, can add, modify, and view currencies. 

 A user that has the "Modify" permission, can modify and view currencies. 

 A user that has the "View" permission, can view currencies. 

The log for Currencies sub-node has the following elements: 

Toolbar options 

 New: to add new currencies 

 Open: to view and modify existing currencies in the log 

 Delete: to delete the currencies in the log  

 Find: to search for a specific currency 

Menu bar options 

 File > New, Open 

 Edit > Delete 

 View > All, Find, Audit Log 

 Help > Unifier Help, Unifier Library, About Unifier 

Log columns 

 Currency Name: Displays the Currency Name 

 Currency Code: Displays the Currency code for the country 

 Currency Symbol: Displays the Currency symbol for the currency 

 Description: Description for Currency 
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The Currencies log has a list of predefined currencies. When you click Currencies, a predefined 
list of currencies displays in alphabetical order. In addition: 

 Currency code is displayed for all the existing currencies. 

 If currency symbols exist, the currency symbols are populated under the Currency symbol 
column. 

 Users who have permissions can modify the predefined currencies. 

 Description lists all the countries that use that currency. 

To add new currencies: 

1) Click New to open the Currency Details Window 

2) Enter the Currency Name, Currency Code, Currency Symbol, and Description 

 Currency Name is a required field. Currency Name is a text field (maximum of 250 
characters) 

 Currency Code is a required field. Currency Code is a text field (maximum of 8 
characters) 

 Currency Symbol is an optional text field (maximum of 8 characters)  

- Single characters such as . , () -  are not allowed 

- Characters such as | ' " \ are not allowed 

- Patterns such as $$ $& $` $' are not allowed  

Note: You cannot type just a comma as a currency symbol. Also, the Pipe character (|) 
and back slash (\) are not allowed in the Currency Name, Code and Symbol fields. 

 Description is an optional text field (maximum of 500 characters) 

3) Click OK to save 

4) Validate the new currency by ensuring that the: 

 Currency Name is unique and does not exist in the predefined list. 

 Currency Code is unique and does not exist in the predefined list. 

 Number of characters entered in the text field does not exceed the limit. 

To view the details of an existing currency, click the currency and select open from the Menu 
bar. 

You can modify the Currency Name, Currency Symbol, and Description after you have created a 
currency and defined the currency Exchange Rates. You cannot modify the Currency Code, 
once a currency is created. 

To delete a currency, select the currency and click Delete. 

Notes: 

 You cannot delete a currency that has been used to define exchange 
rates. 

 Currency selected as Base Currency, at the time of creating the 
company, cannot be deleted. 

To search in Currencies, use Find in the Currencies log view. The search parameters are 
Currency Code and Currency Name. The logical operators for both parameters are the following: 
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 contains 

 does not contain 

 equals 

 does not equal 

The Audits log displays the additions and modifications applied to currencies. Audits log allows 
you to select a record to see the audit information. The top part of the Audit log window displays 
the currency name, for example, Audit Log for: Australian Dollar (AUD). 

The Currency List window, which you can see when you are defining the exchange rates, 
displays a list of currencies that you have defined in the Currencies sub-node. Fields in the 
Currency List window are Currency Name, Currency Code, Currency Symbol, and Description. 
The Description field includes the country name and if there are multiple countries that share the 
same Currency Name, the country names are listed and separated by a comma, for example, for 
Currency Name, Euro (EUR), the Description field lists: Andorra, Belgium, France, and so forth, 
in alphabetic order. 

Note: If the currency name is modified, then existing exchange rate CSV 
template fails. You must export the exchange rate template again for the 
new currency name. The existing Web Services calls for record 
creations and updates fails if the currency names are modified. 

Similar to other custom string translations the currency names can be translated for 
internationalization. 

Base currency 

The currency the company creator selected as the default currency during company creation. 
Upon creation, the base currency is fixed and cannot be changed. The base currency becomes 
the default currency for projects and shells; however, the default currency can be changed 
during project or shell creation. Company-level cost data roll-ups can draw from multiple projects 
and shells. Each of these projects or shells can have a different project currency. 

Project currency 

A Project Currency is the currency that was selected as the project or shell-level default currency 
during project or shell creation. This can be different from the Base Currency, and you must take 
the following steps before you save the new project or shell. 

 First: Before creating the new project or shell, verify that the non-base currency exists in 
the Exchange Rate Set. 

 If it does not, you can add it. 

 If the exchange rate effective date is in the future you cannot add it to the 
project or shell currency set. 

 Second: During project/shell creation, add the non-base currency to the project or shell. 

 Third: During project/shell creation, select the non-base currency as the project or shell 
default currency. 

Unifier calculates and stores costs in the project currency. Business process records created in 
a non-project currency, such as a transaction currency, use the exchange rate that was active at 
the time of record creation for currency conversion to project currency. 
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Project/shell currency options 

When adding a currency to a project or a shell, you have the options to float, hedge, or peg the 
currency rate. These options establish how to handle fluctuations in that currency’s market rate. 

 Float - A currency's value fluctuates according to the foreign exchange market. Unifier 
updates currency exchange rates according to the effective date of the Exchange Rate 
set. 

 Hedge - Intended to reduce future risk of currency fluctuations. 

 Peg - The currency exchange rate is fixed. Pegging impedes project currency conversion 
in a project or a shell. 

Role rates changes due to currency exchange rate changes only consider Float and disregard 
Hedged or Pegged rates. 

Transaction currency 

This is a currency that was added to the project or shell Currencies, and picked at run time using 
a currency picker on the commitment business process. Upon record creation, Unifier uses the 
current active currency exchange rate in the Exchange Rate table to convert a transaction 
currency to the project currency. 

Cash flow curves display data in the transaction currency, if different from the project currency. 
At run time, users can switch between currency views, but they can only modify values in the 
transaction currency view. 

Currency picker 

Currency pickers are available only for the upper form of a cost-type commitment business 
processes such a contract or a change order. This means all line items will be in the record, or 
transaction, currency. 

Exchange Rates 

Standards & Libraries > Exchange Rates: This is where you can add currencies and define 
their exchange rates against the base currency, which was defined during company creation. 
You can add currencies, manage currency exchange rates, and set currency effective dates as 
needed. Each line in the Exchange Rates log is considered a set. 

Note: In addition to the predefined list of currencies, a Unifier 
Administrator can add new company currencies to suit the company 
business needs. 

Currency conversions use the exchange rate defined in the active Exchange Rates set. Until you 
modify a currency rate, Unifier uses the last active rate for that currency. 

You can take the following actions to manage currencies:  

 Create a New Exchange Rates set. You can make the set active today, or you can set the 
effective date to a future date, or you can set the effective date in the past. 
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 Modify an existing Exchange Rates set that has a future effective date. You can modify rates 
in a set until it reaches the effective date. You can change the effective date to as soon as 
tomorrow, but you cannot change the effective date to today. you can edit Exchange Rate 
Records whose effective dates are in the past. 

 Set an Effective date: On the chosen date, at 12:00 am system date and time -- in your time 
zone -- the effective date becomes active. 

For example: 

 Your time zone is Munich, Germany (UTC + 1) 

 April 20 you add a future exchange rate and set the effective date as May 1 

 May 1 at 12:00 am the currency rate takes effect in Munich’s time zone 

 April 30 at 3:00 pm the currency rate takes effect in Los Angeles’ time zone 

Note: Effective dates for the new exchange rates records can be set in 
the past.  

View Exchange Rates 

According to the date, it displays: 

 Currency Name 

 Currency Symbol 

 1.0 Base Currency 

 Effective Date 

Future currency exchange rates 

Future exchange rates allow you to plan ahead for currency fluctuations. Unifier uses the active 
exchange rate based on the effective date; however, cash flow curves show currency rate 
changes at the beginning of the first full month the rate is in effect. 

In the Baseline details example that follows, you can see differences in values due to future 
exchange rate conversions. 

 The transaction currency is INR. 

 The project currency is EUR. 

 The distribution is linear. 

 The distributed values are 37,000 INR per time period. 

 May and June rates take effect on the first of the month, respectively. 

 A July future exchange rate takes effect in Unifier on 07/02/2012, so Unifier continues to 
display the value of the June rate in the cash flow. 
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 The August rate shows up in the cash flow curve on 08/01/2012. 

Additional information  

For Cost transactions, the exchange rate used is based on the latest update date of the BP 
record.  

The uuu_effective_date is not used for determining the rate to be used on a BP Record. 

Managing Currencies and Exchange Rates 

The exchange rate set defines the currencies that are available for use within the system and 
their corresponding exchange rates, which are based on the company base currency. The 
exchange rate set that is currently active in the system will display a status of Active. All previous 
sets are retained, so you can view the currencies and rates that were active in the system in the 
past. Future currency rates are also listed in the log. 

To view the company base currency 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens, displaying the following information: 

 Effective Date: This is the date the base currency and its associated exchange rates 
became active. If you have not yet created an exchange rate set, there will be one default 
listed in the log, created by the Site Administrator. 

 Base Currency: This is the base currency used by the company. 

 Created By: This field identifies the user who created or modified the exchange rate set. 

 Status: The status indicates which set is active. Only one exchange rate set can be 
active at a time. View currencies and exchange rates (exchange rate set). 

To view an exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 



Setting up the Cost Manager

367

3) Select a set from the list and click Open (or double-click the selection). The Edit Currency 
window opens, displaying the list of available currencies and their exchange rates. 

Add a currency to the exchange rates 

To add additional currencies you must create a new exchange rate set. Existing exchange rate 
sets can be modified until the effective date is reached and that set becomes active. Old sets 
are inactivated and saved for archival purposes. You can add as many sets as you like, as long 
as each set uses a unique effective date. 

To add a currency to the exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens 

3) Click New. The Edit Currency window opens. The window displays all currencies that were 
added in previous exchange rates sets. 

 The Base Currency field is fixed. 

 In the Effective Date field you can select a future effective date, or a past effective date, 
for any exchange rate in the exchange rate set.  

4) Click Add. The Edit Exchange Rate window opens. 

 In the Currency Name field select a currency from the currency list. 

 In the Rate field, enter the exchange rate multiplier to convert the new rate to the 
company base rate. For example, if the base currency is United States Dollar (USD), and 
you are adding Euro (EUR), then the exchange rate is the number of EUR in $1 USD; 
that could look like 0.76 = $1, so in this case you would enter .76. 

5) Click the date icon in the Effective Date field, and select the date this exchange rate set 
becomes effective. 

 If you do not select an effective date, Unifier uses 12:00 am local time (tomorrow 
morning) as the effective date. 

 If the effective date is in the future, the current exchange rate set remains active until the 
effective date of the new exchange rate set. 

 The future exchange rate set remains editable until the effective date is reached. 

 Before you save the exchange rate set, you can remove a currency that you just added. 
Once the exchange rate set is saved you cannot remove that currency and Unifier will 
carry forward that currency in any new currency exchange rate sets. 

 You can create new exchange rates records for effective dates in the past.  

 These past dated exchange rates can only be used to define Derived Curves within Cash 
Flow, in Schedule Manager and for EVA calculations. 

 Existing cost transactions in the system will not get updated on creation of new Exchange 
rate records with historical effective dates. 

6) Click OK to save the exchange rate set. 

To modify an exchange rate 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Click New. The Edit Currency window opens. 

4) Select a currency from the list and click Modify. The Edit Exchange Rate window opens. 

5) Enter the new rate and click OK. 

6) Enter the Effective Date. The effective date defaults to 12:00 am local time tomorrow 
morning. 

 If you want the rate to take effect immediately, you can enter today’s date. 

 You can enter a future effective date, and the current exchange rate set remains active 
until the effective date. 

7) Click OK to save and exit the Edit Currency window.

Note: You can edit the Exchange Rates defined in existing Exchange 
rate records (open an existing record to open the Edit Currency
window).  

To copy an exchange rate set 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates 
log opens. 

3) Select an exchange rate set. 

4) Click the Copy button. The Edit Currency window opens. 

From here you can: 

 Add additional currencies. 

 Modify exchange rates. 

 Set an effective date for the exchange rate set. 

5) Click OK to save and exit the Edit Currency window. 

Importing and Exporting Exchange Rates 

You can create and update exchange rates through a CSV file. For example, you can import the 
exchange rates you are using in your enterprise resource planning (ERP) system into Unifier so 
that the rates match in both systems. 

You can import exchange rates with a CSV file by doing the following: 

 Export a copy of the CSV file structure. 

 Populate the CSV file with currency rate information. 

 Import the CSV file into Unifier. 

To export a copy of the CSV file structure 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log opens 
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3) Choose File > Export. A confirmation window opens. You export the active exchange rates. 
Do one of the following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save.

To populate the CSV file with exchange rate information 

1) Open Microsoft® Excel (or other program compatible with the CSV format), and open the 
exported CSV file. 

2) Enter currency exchange rate information in the spreadsheet. The fields are discussed in the 
table below. 

Notes: 

 Do not delete or change the order of the columns. 

 Successful import creates a currency exchange rate set with 
the Active status. 

 Only the currency code is validated, but Unifier will add to 
the exchange rate set the values you specify in the CSV 
upload file. 

 Only the absolute value for the exchange rate is considered. 
If you enter a negative value, the negative sign is dropped 
and only the value is considered. 

 You can enter new rates, or update existing rates. 

 Only the first five decimal values of the exchange rate are 
imported; if less than five decimal values are entered, zeros 
are added during the import to add up to five values. 

 If you remove an exchange rate from the CSV file, the rate is 
retained in Unifier, and is not deleted. 

 If there are errors in the CSV file Unifier will not import the 
CSV file. 

3) Save in CSV format. 

In this column: Do this: 

Currency Name 
Enter the name of the currency. For example, United States 
Dollar. This currency name is not validated and is for reference 
only. 

Currency Code 
Enter a valid currency code. Only the Currency Code is 
required and validated. 

1.0 Base Currency = 
Enter the exchange rate for the currency. The number you 
enter rounds at ten decimal places. Enter numbers and decimal 
points only; do not enter special characters. 
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To import the CSV file into Unifier 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log opens 

3) Choose File > Import to import the completed CSV file. 

4) Click Browse and navigate to where you saved the file. 

5) Click OK to import. 

Only files with exchange rate information in the correct format will be imported. If the upload 
fails, the CSV file will contain an error message that explains why the upload failed. The user 
who imported the CSV file is listed in the Audit log as the User. 

To fix import errors 

1) Re-open the CSV file. 

2) Delete rows that were successfully imported. 

3) Fix the rows that were not imported correctly. 

4) Re-import the file. 

To export exchange rates to your desktop 

1) Go to the Company Workspace tab and switch to Admin mode.

2) In the left Navigator, click Standards & Libraries > Exchange Rates. The Exchange Rates
log opens 

3) Choose File > Export. A confirmation window opens. Do one of the following: 

 Click Open to open the file in Excel (or other editor that supports CSV files). You can 
save the file from here after previewing. 

 Click Save to save the file to your local drive. Enter a name for the file and click Save. 

Setting up Cost Sheets 

The following is provided as a reference for creating, setting up and managing the Cost Sheet 
portion of the Cost Manager. 

How to set up the cost manager (cost sheets) 

Before you begin: Ensure that currencies and exchange rates have been set up. Verify that all 
Cost Codes have been added or imported. Before you can create the Cost Template, you must 
create the necessary Cost Codes Data Definition(s) which will be used to build your CBS Codes. 
CBS Cost Codes can be single or multi segment codes. See Importing and Exporting 
Exchange Rates (on page 368), Add a Basic Data Definition (on page 26). 

Step 1: Design and deploy the cost attribute form. Once deployed, the cost attribute form 
becomes the CBS Detail window in Unifier, used to create and manage CBS codes in the project 
or shell cost sheet. This is an optional step. If you do not create a cost attribute, a default form 
will be used to create CBS codes. (See Importing the Cost Attribute Form (on page 371).) 

Step 2: Configure permissions. (Refer to the Unifier Reference Guide for cost manager 
permission settings.) 
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Step 3: Create a cost sheet template. You must create at least one cost template before you 
can create cost sheets. You can use the template to create project or shell cost sheets, or a cost 
sheet within a project or shell template. You can add columns to the template, which can be 
used to capture transaction data from cost business processes, create formulas, manage the 
budget, manually enter data, link to the funding manager, and much more. You can create the 
CBS codes in the template, which are the rows on the sheet. (You can also set up columns and 
rows on individual cost sheets, following the same procedures). (See Creating and Setting up 
Cost Templates.) 

Step 4: Create a project or shell cost sheet. You can create a cost sheet directly in the project 
or shell, or in a project or shell template (when you create project or shells from the template, 
you can include the cost sheet). (See Creating a Project or Shell Cost Sheet (on page 396).) 

Step 5: Define the project or shell budget. After creating the project or shell cost sheet, you 
can distribute the budget. This is done in User Mode. 

Optional steps:

 Create work packages. This is done in user mode. 

 Create worksheets. Worksheets can be used as mini-cost sheets, linked to project or 
shell cost sheet columns. You create a worksheet template first. (See Creating 
Worksheet Templates (on page 388).) 

 Create program and company cost sheets. This is optional. The program and 
company cost sheets are used to summarize project data. You can configure these 
sheets to display specific data by adding or removing desired columns. The rows 
correspond to each individual project cost sheet. The program cost sheet will summarize 
the cost sheet data for the project in the program. The company level cost sheet 
summarizes project data across the company. The company cost sheet can also be 
mapped to company level account codes, which can allow you to link project CBS codes 
with company level account codes. (See Setting up a Program Cost Sheet (on page 
401), Setting up the Company Cost Sheet (on page 404).) 

 Design and deploy cost business processes. Use these to enable transactions 
against the cost sheet. 

 Set up a company accounts sheet. (See Setting up a Company Accounts Sheet (on 
page 408)) 

 Set up SOV. (See Setting Up Schedule of Values (SOV) (on page 441)) 

 Set up Funding. (See Setting up the Funding Manager (on page 413)) 

 Set up Rules. (See Setting up the Rules Engine (on page 461)) 

Importing the Cost Attribute Form 

A cost attribute form (created in uDesigner) is used as the CBS Detail window. The CBS Details 
window is used to create rows (CBS Codes) to project or shell cost sheets. 

You can have only one Cost Attribute form per company, which will be used for CBS Details 
window across all projects or shells. 

To import and deploy a cost attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 640). 
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Configuring Cost Manager Permissions 

Refer to the Unifier Reference Guide for cost manager permission settings. 

Cost Sheet Template at Company Level (Standard View) 

To access cost sheet templates at the Company level:  

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

You can use this log (Create) to create a Cost Sheet or Worksheet. 

Create a New Cost Sheet Template at Company Level 

The following procedure describes how create a cost sheet template at the Company level, from 
the Company Workspace tab.  

1) Go to the Company Workspace tab (Admin mode).  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Click Create and select Cost Sheet. to open the Create Cost Sheet Template window. 

4) Enter the needed information in the fields under the following blocks: 

 General block 

Defines general properties of the template: 

 Enter a unique Title, which is used to identify the template in the log and when 
creating a new project or shell cost sheet from the template. When you create a 
cost sheet from the template, the title will default to Project Cost Sheet and will not 
be editable. 

 Enter an optional Description for the template. This description will be copied to 
the Project Cost Sheet when you create one, and will not be editable. 

You can select a Default View for the template. This can be edited in the Project Cost 
Sheet. For details, see Define Cost Sheet Default View (General tab). 

 Structure block 

Defines the structure of the CBS Codes (or Cost Codes) for use within the cost sheet. 
This remains editable in cost templates, but once it is set in a project or shell cost sheet, it 
cannot be changed as this tab defines the CBS Code structure for the project or shell. For 
details, see Define cost code structure (Structure tab). 

 Options block 

Defines labels for the two default columns, and details on forecast handling. For details, 
see Define cost sheet options (Options tab). 

5) Click Save. 

The cost template that you create appears in the Cost Templates log. After creating the cost 
sheet template, you must open the sheet to add columns and rows.  

To open the cost sheet template 

1) Go to the Company Workspace tab and switch to the Admin mode. 
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2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Click to select a template and open it either by double-clicking on it, or by way of the gear 
icon. 

Define Cost Sheet Default View (General Block) at Company Level 

The cost sheet default view refers to how the cost sheet appears when it is first opened. 

Note: Unlike other cost sheet properties, the default view settings can be 
modified in the Project Cost Sheet. See Define Cost Sheet Default 
View (General Tab) at Shell Level (on page 381) for details. 

To define the general properties of the template: 

Enter values in the following fields: 

 Name

Enter a unique name. This field is used to identify the template in the log and when creating 
a new project or shell cost sheet from the template. When you create a cost sheet from the 
template, the title will default to Project Cost Sheet and will not be editable. 

 Description (no more than 3950 characters) 

Enter an optional Description for the template. This description will be copied to the Project 
Cost Sheet when you create one, and will not be editable. 

 CBS Code Label (no more than 32 characters) 

Enter the CBS Code title that your company uses. For example, Account Code, Cost Code, 
or CBS Code. 

 CBS Item Label (no more than 32 characters) 

Enter the CBS label that your company uses. For example, CBS Item, Cost Item, or 
Account Description. 

The labels determine how the CBS code columns will be labeled, according to your company 
conventions. 

Note: If you will be importing cost sheet data, it is important that the 
column labels match those in the import files. 

To define the cost column labels 

1) In the cost Properties windows, click the Options tab. 

2) Enter new labels for the CBS Code and/or CBS Item columns. 

3) Click Apply to save changes, or OK to save and exit the window. 

Note: You can also define the forecast (Forecast block) behavior for the 
sheet as well as enabling P6 as a source (P6 Integration block). You 
must select Tree as the structure of the new cost sheet template when it 
is enabled for P6 integration. 
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Define Cost Sheet Options (Options Block) at Company Level 

Under the Options block, you can set the following options for the cost sheet template: 

 Forecast Details

 User Line Items

 Transactions

 Forecast Inclusion

 Manual

 Auto

 Enable Cost Sheet Forecasting

 Enable p6 sources

For the Forecast Details and Forecast Inclusion options, specify the configuration for managing 
the Forecast column of the Cost Sheet. User Line Items/Manual is the default configuration; the 
following are the configuration options: 

 User Line Items and Manual: At any time, the cost sheet user can add, edit, or delete Line 
Items in the Cell Detail Window of the Project or Shell Cost Sheet for the Yet to 
Buy/Allowance For Change (YTB/AFC) column. The user has to manually choose which 
commits are included in the forecast. Options for choices are: 

 Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast, then 
$100 is automatically deducted from YTB 

 Manually adjust YTB/AFC 

 Make no change to YTB/AFC 

 User Line Items and Auto: Do not use this combination. This scenario will automatically 
inflate the Forecast due to the manual adjustment of Yet To Buy (YTB). 

 Transactions and Auto: Note the following: 

 Commits (for example Base Contract, Change Order, Purchase Requisition) are 
automatically updated with changes to the Forecast, depending on the formula. 

 Adjustments are automatically included in the Forecast column upon approval as defined 
by the workflow. 

 Transactions and Manual: Line Items can be added to the Cell Detail window of the Project 
or Shell Cost Sheet. No deletions or modifications can occur on existing line items. The user 
has to manually choose which commits are included in the forecast. Options for choices are: 

 Auto-adjust YTB/AFC: For example, if you include a Commit for $100 in Forecast then 
$100 is automatically deducted from YTB 

 Manually adjust YTB/AFC 

 Make no change to YTB/AFC 

To define the cost forecast details and inclusion 

1) In the cost Properties windows, click the Options tab. 

2) Complete the forecast details fields as described in the following table. 

3) Click Apply to save changes, or OK to save and exit the window. 
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For the P6 Integration, the Enable P6 sources allows you to enable the Cost Sheet Template 
in Unifier to acquire data from the P6 Summary Sheets. 

 If you select this option, you must select Tree for the Cost Sheet Structure. 

 The Data Format in Cost Sheet Template Column "Properties" window shows has the 
"Decimal" option. 

Define Cost Code Structure (Structure Block) at Company Level 

You can define the structure of the cost codes used in the sheet, in the Structure block. The 
cost codes that are built from this structure are used throughout the project or shell, for example, 
in cost type business processes for cost transactions. 

For an existing template, you can edit the cost template properties, rows, and columns, in the 
Structure block.You can also add default data to direct entry cells which can be copied to cost 
sheets created from the template. The following procedure describes how edit a cost sheet 
template from Company Workspace tab.  

This structure remains editable in cost templates, allowing you to make adjustments to the 
structure as needed. In project or shell cost sheets, once the structure has been defined, it 
cannot be edited. 

The Structure block has the following elements: 

 Structure

This defines the structure of the CBS Code rows and how they will appear on the cost 
template and sheets. Choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows, and summary).  

 Flat

If you choose Flat, the cost sheet will display the CBS codes (rows) in a flat structure, 
with no indented rows. This is useful if you want to display all CBS codes at once. 

 Tree

If you choose Tree, you have the option of creating indented, nested rows, which can be 
collapsed into summary, or grouping, rows. This is useful if you will be creating a large 
amount of rows that can be grouped into categories. 

 Sort CBS

If you select the Sort CBS checkbox, the rows will be sorted in ascending order by CBS 
Code automatically when new cost codes are added (flat structure only). 

The summary rows act only as grouping rows for their indented child, or leaf, rows. Data 
cannot be entered directly into a summary row. 

 Segment Preview

 Segment 1

 ...

 Segment 10

Determine how many segments to use for cost codes. For example, your company may have 
a three-segment CBS code based on numerical values. You may have as little as one 
segment (each cost code is a single entity), or as many as 10. For Segment 1, click the 
pull-down menu and choose the first segment. 
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The available segments correspond to the list of Cost Code Data Definitions found in 
Administration Mode in Company > Data Structure Setup > Data Definitions > Cost 
Codes. 

This is where you build the CBS codes (or "account" codes) that will be used for the cost 
sheet rows. CBS codes may consist of one or multiple (up to 10) segments. Each segment 
consists of a separate cost code data definition, as defined in Administration Mode>Your 
Company>Data Definitions>Cost Codes. You must define at least one segment. 

Select one or more segments, up to 10, in the order (left to right) you want them to appear in 
the Cost Sheet rows. 

Repeat the previous step for each additional segment you wish to add. 

Cost Sheet Columns at Company Level 

Cost columns specify the data sources (business process transactions, formulas, values entered 
manually, etc.) that will be displayed on the cost sheet. Default columns are the CBS Code and 
CBS Item. Cost columns can be added to cost templates, to project- or shell-level, 
program-level and company-level cost sheets, and to worksheets.  

These procedures apply to adding columns to a Cost Sheet, a Cost Sheet template, or a 
Worksheet template at the following levels: 

 Project or Shell 

 Program 

 Company 

Cost Sheet columns can be of the following types:  

 From Business Process

Data is rolled up automatically from cost type business processes when the BP reaches the 
specified status (Business process transaction column). 

 Direct Entry

Users can enter data directly to the sheet through line item or direct entries. Custom data 
sources can be applied to these columns to allow project or shell cost data to roll up to 
program or company cost sheets, and be reportable through user-defined reports (Manual 
entry column). 

 Line Item Content

 From Worksheet

 From Activity Sheet

 Formula

The column values are calculated based on a formula that normally includes values from 
other columns. For example, if there are multiple cost type business processes affecting the 
sheet, you may want to have a column that shows the sum of all of them ("Total Commits"). 
Custom data sources can be applied to these columns to enable them to roll up to program 
or company cost sheets, and be reportable (Formula column) 

 Fund

Provides additional functionality to work with the Funding sheet. For more information, see 
Add a funding column to project or shell cost sheet (on page 425) (Fund column). 

 SOV
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Provides additional functionality to work with Schedule of Value sheets. 

Add a Cost Sheet Column at Company Level 

This general procedure can be used for adding columns is the same whether you are adding 
columns to a cost sheet (project or shell, program or company level), a cost sheet template, or a 
worksheet.  

1) Go to the Company Workspace tab and switch to the Admin mode.  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Click to select a cost template from the log. 

4) Click the gear icon next to the cost template and click open. 

5) Form the toolbar options, click Add Column (the icon with three vertical lines) to open the 
New Column window. 

6) Complete the fields as described below. 

7) Click: 

a. Cancel to discard your changes 

b. Save to save your changes 

c. Save & Add New to save your changes and begin to add a new column. 

In this field: Do this: 

Name

The name you choose will appear as the column header on the 
Project or Shell Cost Sheet. If you leave the Name field blank, the 
selection you make in the Datasource field will automatically 
populate the Name field. 

Type See "Cost Sheet Column Types." 

Datasource

All columns must be associated with a data source. The data 
source that you choose will determine which of the following 
options are available. The types of Data sources available are: 

 Single Sources: These values roll up from other sources. 
These include cost type business processes, some predefined 
cost columns. 

 Logical Sources: Choose one to create Manual Entry or 
Formula columns. 

 P6 Sources: To select the P6 Summary Sheet from which cost 
should role up. 

See "Project or shell Cost Sheet Column Data Sources." 
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Element

If you select the "Enable P6 sources" option when defining your 
Cost Sheet options (Creating a new Cost Sheet Template, Options 
tab), the following occurs in the Column Properties window: 

The Datasource drop-down list contains the Published P6 Data 
Sources that have been defined in Standards and Libraries, in P6 
Sources. Once you select a P6 Source as a Datasource for a 
column, you must select an Element (Required). The Element 
drop-down list contains a fixed list of available options. 

If you select any P6 Datasource or Element to define a column, 
then: 

 Column Name defaults to the Element that you selected. 

Example 

You select DataSource or Element as Sanctioned Baseline or 
Planned Cost. The Column Name, then, appears as: Planned 
Cost. 

 You can edit the Name and Data Format. 

Notes: 

- For all "Cost" elements (Planned Cost, Actual Cost, etc.), the 
Data Format is pre-selected as "Currency" 

- For all "Unit" elements (Planned Units, Actual Units, etc.), the 
Data Format s pre-selected as "Decimal" 

 All P6 Sources are available for Formula Creation (Format: <P6 
Source>: <Element>). 

 You can edit the Display Mode 

 You can edit the Total 

Entry Method

This is applicable for logical data sources. 

 Manual Entry, Direct entry into cell: Users enter values by 
clicking the cell and entering values directly into the cell. 

 Manual Entry, Line item content: Users enter values 
manually via a line-item entry window for each CBS Code 
(clicking the cell opens the cell details window.) 

 Worksheet: From the drop-down lists, select the Name of the 
worksheet and the Column within it. 

 Formula: Values are calculated based on a specified formula 
entered for the column. Formulas can include the values of 
other columns. Click the Create button to create the formula. 

Data Format

 Currency: Right-aligns column contents and includes a 
currency symbol, a thousandths separator and two decimal 
places 

 Percentage: Right-aligns the contents and includes a 
percentage symbol 

 Decimal: Right-aligns column contents and presents the value 
for the column as a Decimal (with two decimal digits). The 
prefix of currency symbol, or the suffix of percent symbol, does 
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not appear in columns with a Decimal data format. 

Display Mode

Refers to whether the column is displayed on the cost sheet. 

 Show: This is the default choice. This indicates that column will 
display by default on the cost sheet to all users with at least 
"view" permission for the cost sheet. 

 Hide: Hidden columns are active but not displayed on the cost 
sheet. Hidden columns can be accessed by users with "create" 
permission on the cost sheet. 

Total

Determines what will display in the "Total" (bottom) row for the 
column: 

 Blank: The total of this column is not applicable and will not 
display on the cost sheet. Choose this column for percentage 
columns and other columns where it does not make sense to 
display the sum total. 

 Sum of All Rows: The sum total of the column values is 
displayed. 

 Use Formula Definition: For formula columns; the formula will 
be applied to the "Total" row in the same way it is applied to 
other rows in the column. 

Column Position 
After

The new column will be inserted after the column selected. 

Create a Formula in a Cost Sheet Column 

This procedure addresses how to create a formula column for use on a cost sheet. (The general 
procedure also applies to cost sheet templates and work sheets.) 

When creating a cost sheet column, selecting a logical data source allows you to build a formula 
in which you can include: 

 Other columns from this cost sheet 

 Single data sources, such as business processes in a certain status 

 Total elements, such as the tallied value of a column 

 Data elements from single-record, non-workflow business processes 

If you are creating a formula for forecasts (unaccepted), data sources are limited to business 
processes flagged in uDesigner for cost sheet forecasting. For example, if base commits and 
change commits were enabled for cost sheet forecasting, you will see base commits 
(unaccepted) and change commits (unaccepted) as available data sources for use in the 
forecasts (unaccepted) formula. You will not see other data sources that were not flagged in 
uDesigner for this purpose. 

When you build your formula, think about which data sources will generate the result you want in 
your cost sheet column. For example, if you want to see total commitments, you can add 
contracts (approved) and change orders (approved). 
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Note: Use care when selecting the Cost Column that you use to build 
your formula. You can possibly choose from Columns (columns in the 
sheet), Data Sources (values of business processes), Total Elements 
(totals from columns), or Data Elements (data elements on 
Information/General record(s), typically named Project Information). The 
source column that you use can affect the data values in your cost 
sheet. If you select an incorrect source, you can get a result you do not 
expect. Be sure that you know the source to use before you build your 
formula. 

To create a formula 

1) In the Column Properties window, choose Formula, then click the Create button. The 
Formula Creation window opens. 

2) Enter the first value in the formula: 

 To enter numerical values into the formula, click the number keys on the on-screen 
keypad. (Include parentheses, % or decimal point as necessary.) 

 To add a data source or column value (existing columns on the sheet you are working 
on) into the formula, select it from the list in the left pane, then click the Select button. 

As you build the formula, it appears in the Formula box in the upper right portion of the 
window. 

3) Click on the appropriate operator: add, subtract, multiply, or divide. 

4) Continue to alternate between choosing values and operators to add to the formula. 

Note: Unifier applies the operators in the order of proper mathematical 
procedure: from left to right, with multiplication and division first, followed 
by addition and subtraction. 

5) You may click Undo at any time to undo the last action. Click the Clear All button to clear 
the entire formula. 

6) When the formula is complete, click OK to save your formula and return to the Column 
Properties window. 

Example Formula 

A user wants to create a "Yet To Buy" column that calculates 7% of the Assigned Budget 
column. To create this formula using the keypad in the Formula Creation window: 

1) Click 7 then click the percent % key. The value is displayed as 7/100 

2) Click the multiplier X 

3) Select Assigned Budget from the Cost Column pane on the left, then click Select 

The final formula looks like this: 7/100 * Assigned Budget
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Cost Sheet Template at Shell Level 

Project or shell cost sheets are created by copying from a cost sheet template or from an 
existing project or shell cost sheet in another project or shell; therefore, when you first set up the 
cost manager, you must start with at least one cost template that you can use to create a project 
or shell cost sheet (or cost sheet in a project or shell template).  

To access cost sheet templates at the shell level: 

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) From the left Navigator, click Templates > Shells > Projects. 

3) Click Cost Manager to expand and click Cost Sheet to open the Cost Sheet log. 

You can only use this log (New) to create Worksheet by way of: 

a) Copy from Template

b) Copy from Projects

You cannot create a project cost sheet. 

Create a New Cost Sheet Template at Shell Level 

You cannot create a project cost sheet template at shell level; however, a Cost Sheet is created 
by copying from a cost template or another project or shell cost sheet. See Creating a Project 
or Shell Cost Sheet (on page 396) for details.  

Define Cost Sheet Default View (General Tab) at Shell Level 

The cost sheet default view refers to how the cost sheet appears when it is first opened. There 
are two options regarding the cost sheet default view, at shell level, described in the procedure 
below. These options control how the cost sheet opens for all shell or project users.  

Note: Unlike other cost sheet properties, the default view settings can be 
modified in the Project Cost Sheet after it has been created in User 
mode. 

To define the cost sheet default view for Shells:  

1) Go to the Company Workspace tab and switch to the Admin mode. 

2) From the left Navigator, click Templates > Shells > Projects. 

3) Click Cost Manager to expand and click Cost Sheet to open the Cost Sheet log. 

4) Select the template and click the Properties button from the log toolbar. 

5) From the toolbar, click Properties to open the Properties window. Alternatively, you can 
open the template and click File > Properties. 

6) On the General tab, you may choose either or both of the Default View checkbox options: 

 Open in maximized view: when the cost sheet or template is opened, it will 
automatically open maximized, or full-screen 

 Open in split mode: when the cost sheet or template is opened, it will automatically 
open as split (same as clicking the Split button) 
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If these options are not selected, the cost sheet or template will open by default to a size 
slightly smaller than the Unifier screen, and not split. 

Note: The cost sheet window can be resized by clicking the Minimize or 
Maximize/Restore buttons in the upper right corner of the window, or by 
dragging the edges of the window to the size that you need. When 
working with a cost sheet with many columns, it can be useful to split the 
window. You can click the Split button to scroll through the columns in 
the right half of the window, while maintaining a view of the CBS Code 
and CBS Item columns in the left half. To return the sheet to normal 
view, click the Split button again. 

Define Cost Sheet Options (Options Tab) at Shell Level 

In the cost sheet template at shell level, Properties window, Options tab, you can only define 
the P6 Integration option by enabling P6 as source (Enable P6 sources). This option allows 
you to enable the Cost Sheet Template in Unifier to acquire data from the P6 Summary Sheets. 
You can select this option only if Tree is selected as the Cost Sheet Structure, at the Company 
level (cost sheet template). 

The Options tab at shell level has the following blocks and the options that are selected are 
based on the selection at the Company level (cost sheet template): 

 Labels block 

 CBS Code

 CBS Item

 Forecast Details block 

 User Line Items

 Transactions

 Forecast Inclusion block 

 Manual

 Auto

 Forecast Type block 

 Enable Cost Sheet Forecasting

 P6 Integration block 

 Enable P6 sources

Define Cost Code Structure (Structure Tab) at Shell Level 

In the Structure tab of the cost sheet, you can see the structure of the cost codes used in the 
sheet. The cost codes that are built from this structure are used throughout the project or shell, 
for example, in cost type business processes for cost transactions. 

In project or shell cost sheets, once the structure has been defined, it cannot be edited. 
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In the Structure tab, you can click the Preview to view the result. 

Cost Sheet Columns at Shell Level 

Cost columns specify the data sources (business process transactions, formulas, values entered 
manually, etc.) that will be displayed on the cost sheet. Default columns are the CBS Code and 
CBS Item. Cost columns can be added to cost templates, to project- or shell-level, 
program-level and company-level cost sheets, and to worksheets.  

These procedures apply to adding columns to a Cost Sheet, a Cost Sheet template, or a 
Worksheet template at the following levels: 

 Project or Shell 

 Program 

 Company 

Cost Sheet columns can be of the following types:  

 From Business Process
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Data is rolled up automatically from cost type business processes when the BP reaches the 
specified status (Business process transaction column). 

 Direct Entry

Users can enter data directly to the sheet through line item or direct entries. Custom data 
sources can be applied to these columns to allow project or shell cost data to roll up to 
program or company cost sheets, and be reportable through user-defined reports (Manual 
entry column). 

 Line Item Content

 From Worksheet

 From Activity Sheet

 Formula

The column values are calculated based on a formula that normally includes values from 
other columns. For example, if there are multiple cost type business processes affecting the 
sheet, you may want to have a column that shows the sum of all of them ("Total Commits"). 
Custom data sources can be applied to these columns to enable them to roll up to program 
or company cost sheets, and be reportable (Formula column) 

 Fund

Provides additional functionality to work with the Funding sheet. For more information, see 
Add a funding column to project or shell cost sheet (on page 425) (Fund column). 

 SOV

Provides additional functionality to work with Schedule of Value sheets. 

Project or Shell Cost Sheet Column Data Sources 

Data Source Description 

Single 
Sources 

Columns in which data is manually rolled up from business processes 
once the appropriate terminal status is reached. Can also include other 
specified sources. 

Cost-type 
Business 
Processes 

Included in the Single Sources list are all of Cost BPs that are available 
for your project or shell, and all of their terminal statuses. 

AFC 

Assigned 
Budget 

This column goes hand-in-hand with budget distribution. It allows the 
user to create specific, detailed line-items for each CBS code in the 
budget. Each line item can be assigned individually. 

Funded 
Records 

This column shows records in which the CBS code is funded, that is, 
spend-type business process records that consume funds. 

Unfunded 
Records 

This corresponds to spend-type BP records that are not funded. 

Prior 
Forecasts 
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Yet To Buy 

Part of the commitment that still must be purchased. For example, a 
base contract is for 1000 items, and 500 have been bought. There are 
500 items "yet to buy." It is based on a currency amount. In Cost Sheet 
Properties, setting "Auto" "Transaction" options will track the yet to buy 
information. 

Logical 
Sources 

Budget 
Remaining 
Balance 

This is a place holder for a formula you create (optional). 

Budget 
Variance 

This is a place holder for a formula you create (optional). 

Commits 
This is a place holder for a formula you create (include all commit 
columns; optional). 

Forecasts This is a place holder for a formula you create (optional). 

Forecasts 
(Unaccepted)

This is a place holder for a formula you create (optional). 

Forecasts 
Variance 

This is a place holder for a formula you create (optional). 

CBS Funding
Requires additional setting in Funding Sheet; see Setting up the 
Funding Manager (on page 413). 

Manual 
Funding by 
CBS 

Requires additional setting in Funding Sheet; see Setting up the 
Funding Manager (on page 413). 

Revised 
Budget 

This is a place holder for a formula you create (optional) 

Spends 
This is a place holder for a formula you create (include all spend 
columns; optional). 

Project or 
shell Cost 
1-25 

These can be used to rollup manual and formula columns to company 
and program cost sheets. Each data source can be used for one 
column. 

Adding Cost Rows (CBS Codes) 

The following procedures are applicable to Cost Templates and Cost Sheets 

Each cost sheet row corresponds to the unique CBS (or Cost) codes that link costs on a project 
or shell to the General Ledger for Finance. They may be added manually or imported from a 
CSV file. 
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CBS codes may consist of one or a maximum of 10 segments. Each segment is defined by a 
different data definition. For example, a five segment CBS Code would require five data 
definitions. Segments can be defined via a selection list or text entry. 

If the cost sheet has been setup to automatically sort CBS codes, then all new rows will be 
sorted by ascending order. 

You cannot create duplicate CBS Codes at the same row level on the sheet. If you choose a Flat 
structure for your cost sheet (no indented rows), then you will not be allowed to create duplicate 
CBS Codes. If you choose a Tree structure, you can use the same CBS Code as long as each 
instance is within a different grouping (or parent) row. 

To manually add rows to a cost sheet or cost template 

1) Open the Cost Template or Cost Sheet. 

2) Click the Rows button. The Rows window opens. 

3) Click Add Row. The CBS Detail window opens. 

4) Complete the CBS Detail window as described in the following section. 

5) Click OK. 

To insert a row between existing rows 

1) In the Rows window, select the checkbox next to the row after which you want to insert the 
new row. 

2) Click Add Row and follow the procedure to add a new row. The new row will be added after 
the selected row. 

About the CBS Detail Window 

Following is an overview of the fields and tabs in the CBS Detail window. 

The CBS Detail window displays CBS properties. You can add notes or file attachments to the 
CBS code in this window. You can also specify CBS Breakdowns in this window, which are used 
in Schedule of Values (SOV) sheets. 

The values that are available in the CBS code selection come from the Cost Codes data 
definitions. 

Navigate to Company Workspace tab > Admin mode >Data Structure Setup > Data 
Definitions > Cost Codes. The log will show whether the code is a Text Box or Pulldown Menu. 

The codes listed in the log are those that are available to use when building the CBS Code 
segments. 

This section discusses the default CBS Detail window. If your company has designed a 
uDesigner-created Cost Attribute Form, the fields may differ. Fields with a red asterisk are 
mandatory. 

In this field: Do this: 

CBS Code 
Click Select to choose the cost code segments for the CBS 
code.  The Cost Code Selection window opens. 

CBS Item Enter a label that will display on the cost sheet next to the CBS Code, 
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In this field: Do this: 

this can help other users to identify what the code represents. 

Description Enter an optional description to describe the row. 

Additional information about the CBS Detail window: 

 The appearance of the Cost Code Selection window will depend on how your cost sheet was 
set up, which CBS Codes (cost codes) were used in the definition, and how each code was 
set up. 

 If the CBS code segment has a Select button, then click the button and choose the segment 
values from the list. 

 If the CBS code segment does not have a Select button, then type the value of the segment 
into the field. 

Create a summary row 

If you selected a Tree Structure format, you can indent rows. These indented rows can be used 
to capture cost transactions. The parent node acts as a summary row, summarizing the 
information present for each of the indented "child" rows. You cannot enter information directly 
into a summary row. 

To create a summary row by indenting 

1) In the Rows window, select the checkbox of the row(s) to indent under the summary row. 

2) Click the Indent button. The row immediately above will become a summary row. All 
monetary values in the detail lines below a summary row will be rolled up to the summary 
row automatically. 

To outdent a row 

1) In the Rows window, select an indented row by clicking its checkbox. 

2) Click the Outdent button. The row will no longer be part of the summary row. 

Import cost rows (CBS codes) 

You can create CBS Codes in a cost sheet by importing them from a CSV file. This procedure 
can also be used to copy the CBS codes from one cost sheet or template to another (the 
structure and code segments must be the same). 

Step 1: Export the file template

a) Open the cost sheet or template, click the Export button and select CBS Details. 

b) On the File Download window, click Save. 

c) Enter a file name, browse to where you want to save the file, and click Save. 

Step 2: Add the CBS code rows to the CSV file

a) Navigate to and open the CSV file (in Microsoft Excel or other compatible program). 

If the Cost Template already contains rows, they will be listed. If summary rows exist, the 
CBS column will display them with two tilde symbols (~~) separating the parent row from the 
child row. 
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e.g.: 2000000 ~~210000, where 2000000 is the parent and 210000 is the child. 

b) Enter information in the required fields and save the file. 

Note: Do not change or delete any of the listed CBS Codes that already 
exist in Unifier or you will get an error. Changes to the CBS Code must 
be done within Unifier. 

Required fields: 

 CBS Code: must be a match to a CBS Code in the Cost Sheet 

 CBS Item: must be a match to the CBS Item for the associated CBS Code in the 
Cost Sheet 

 Cost Type: Capital or Expense 

 Status: Active or Inactive 

Step 3: Import the rows

a) In the cost sheet or template, click the Import button and select CBS Details. 

b) In the Upload window, browse to and add the CSV file. 

c) Click OK. After the import, your Cost Sheet will show the new rows. 

To copy CBS codes from one cost sheet or template to another 

1) In the source cost sheet or template, click Export > CBS Details. Save the CSV files. You 
can go in to the file and add additional codes if needed. 

2) In the destination cost sheet or template, click Import > CBS Details. Browse to the CSV file 
and import. 

Note: The structure of the two sheets must be the same: Both must be 
tree or flat structure. Verify the structures by opening the Properties 
window and clicking the Structure tab. Be sure you are using the same 
CBS code segments. 

Creating Worksheet Templates 

Worksheets are extensions of the cost sheet. They can be used as "sub-cost sheets," enabling 
specific calculations or data entry in a separate sheet, which can then be rolled up into a defined 
project or shell cost sheet column. For example, a worksheet can be used to off-load complex 
calculations, which can be rolled up into a single cost sheet column. The rows equal the CBS 
codes on the cost sheet. Worksheets can have multiple columns for data entry or formula 
calculations, but do not support data rolled up from business processes. 

A cost sheet column can be associated with a worksheet as the data entry method. A worksheet 
column can also be associated with another worksheet, as long as there is not a circular 
reference. There can be multiple worksheets in a project or shell. 
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Note: A circular reference is referred to a reference in which the last field 
references the first field and creates a closed loop. 

A worksheet template can be created in Administration Mode. Permissions can be controlled for 
individual worksheets. Worksheets are not independently reportable; however, cost sheet 
columns that reference worksheets can be reported on. 

Create a new worksheet template 

You can use this template to create worksheets for individual project or shell cost sheets, or for 
cost sheets in project or shell templates. 

Worksheets are created similarly to cost sheets. The user who creates a worksheet will be the 
owner of the Worksheet. The owner can grant permissions to other users / groups in User Mode. 

To create a new worksheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Cost Sheets in the left Navigator. The Cost Templates log opens. 

3) Click the New button and choose Worksheet. The Worksheet Properties window opens. 

4) Complete the Worksheet Properties window: 

 Title: Enter a unique title to identify the worksheet or template. This is a required field. 

 Description: Enter an optional description. This is especially useful if you plan to create 
multiple templates for use in different project or shells, or multiple worksheets for a 
project or shell. 

 Default View: You may choose either or both of the Default View checkbox options: 

 Open in maximized view: when the worksheet or template is opened, it will 
automatically open maximized, or full-screen 

 Open in split mode: when the worksheet or template is opened, it will 
automatically open as split (same as clicking the Split button) 

If these options are not selected, the worksheet or template will open by default to a size 
slightly smaller than the Unifier screen, and not split. The window can be resized by clicking 
the Minimize or Maximize/Restore buttons in the upper right corner of the window, or by 
dragging the edges of the window to the size that you need. 

5) Click OK to save and exit the window. The worksheet template is listed in the log. 

You can open the worksheet template and configure it by adding columns; the rows will be 
the CBS codes within the corresponding cost sheet. 

Open the worksheet template 

After creating the worksheet template, you must open the sheet to add columns. 

To open the worksheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Cost Sheets in the left Navigator. 
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3) Select the worksheet template and click Open (or double-click the selected sheet). The 
worksheet template window opens. 

Create a worksheet column 

Adding a column to a worksheet is similar to adding a column to the cost sheet. You can add 
manual entry (direct or line item) columns or formula columns. You can also add columns that 
reference other worksheets. This allows interaction between worksheets. 

The available datasources are Project Worksheet Cost 1 through 50. 

To add a column 

1) Open the worksheet and click the Columns button. The Columns Log opens. 

2) Click New. The Column Properties window opens. 

3) Complete the Column Properties as usual for a column. 

If you are creating a formula, the datasources that are available for the formula are limited to 
the other columns on the worksheet. 

4) Complete the window and click OK. 

Create a worksheet in a project or shell 

You can create a new worksheet in the project or shell level Cost Manager by copying from a 
template or copying from a project or shell. 

To create a new worksheet from a template 

1) Click New and select Copy from Template. This option will allow you to create a worksheet 
by copying one from a company level template. 

2) Select a worksheet template and click Copy. 

To create a new worksheet from another project or shell 

1) Click New and select Copy from Project or Shell. The Copy from Projects or Shells window 
opens. This window will list worksheets from all project or shells. 

2) Select any Cost Sheet and click the Copy button to create a new Cost Sheet. 

Delete a worksheet 

User will not be allowed to delete a Worksheet if it is referred as a Column Entry method in Cost 
Sheet. Only owner of Worksheet will be allowed to delete Worksheet along with user with Create 
permission at module level. 

To delete a worksheet 

Select the worksheet in the log and click the Delete button. 

Managing Cost Templates 

You can edit the cost template properties, rows, columns, or add default data to rows.  



Setting up the Cost Manager

391

Note: Your edits to a template will be reflected in cost sheets that are 
created from it, but will not affect exiting cost sheets. 

To access your cost templates 

1) Go to the Company Workspace tab and switch to the Admin mode.  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log 
which lists the cost templates. 

The Cost Templates log has the following toolbar options: 

Create To enable you to create: 

 Cost Sheet

 Worksheet

Refresh To refresh the items listed on the page. 

Delete To delete a cost template. 

Find on 
Page

To search for an item on the page. 

The Cost Templates log has the following tabs on the right-hand pane: 

Properties 
tab 

To view or edit the fields of your cost template. 

Audit Log
tab 

To review the history of changes that have been incorporated on a 
selected cost template. 

View or Edit Cost Template Properties 

The Properties tab of a cost template is fully editable. This allows you to make changes as 
necessary to use when creating subsequent cost sheets from the template.  

Notes: 

 Many of the properties that are editable in cost templates are not 
editable in the Properties tab of the cost sheet itself, once it has been 
created in the project or shell or in a project or shell template. 

 Any edits that you make to a cost template will affect new project or 
shell cost sheets created from the template, and the existing cost 
sheets will not be affected. 

To view or edit cost template properties 

1) Go to the Company Workspace tab and switch to the Admin mode.  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 



Unifier Modules Setup Administration Guide

392

3) Click to select a cost template from the log. The Properties tab is displayed on the 
right-hand pane. The Properties tab has the following blocks with fields that enable you to 
enter values, when permitted: 

 General

 Name 

 Description 

 CBS Code Label 

 CBS Item Label 

 Structure

 Flat 

 Tree 

 Sort CBS 

 Segment Preview 

 Options

 Forecast Details: User Line Items - Transactions 

 Forecast Inclusion: Manual - Auto 

 Enable Cost Sheet Forecasting 

 Enable P6 source 

4) In the Properties tab, you can make edits as necessary. 

Note: Any edits that you make to a cost template will affect new project 
or shell cost sheets created from the template, and the existing cost 
sheets will not be affected. 

5) When finished, click Save to save your changes. Click Cancel to discard your changes. 

Delete a Cost Template 

You can delete a cost template from the Cost Templates log.  

Note: The cost sheets in project or shell templates or in project or shells 
cannot be deleted. Deleting a template will have no affect on cost sheets 
created from it. 

To delete a template 

1) Go to the Company Workspace tab and switch to the Admin mode.  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Click to select a cost template from the log. 

4) Click the gear icon next to the cost template and click Delete. 

Edit Cost Templates Log Columns 

You can edit the properties of a column, including the entry method, as long as this is applicable 
for the selected data source.  
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Note: Although it is possible to change the entry method for a column, 
use caution when doing so when data exists in the column. Information 
such as detailed line item entries could be lost. For example, if you 
change the data entry method from line item entry to direct entry, the 
value will appear in the cell, but all line item details will be lost. 

1)  

2)  

3)  

To edit Cost Templates log columns  

1) Go to the Company Workspace tab and switch to the Admin mode.  

2) From the left Navigator, click Templates > Cost Sheets to open the Cost Templates log. 

3) Right-click on a (any) column heading, and you can: 

a. Sort Ascending

b. Sort Descending

c. Columns (Name, Date Created, Created By, Type) 

d. Lock after this Column

4) Click to select a cost template from the log. 

5) Click the gear icon next to the cost template and click Open. The Cost  Sheet <name> 
window opens. See the table below for the the Cost  Sheet <name> window elements. 

You can delete a cost template from the Cost Templates log. 

Note: The cost sheets in project or shell templates or in project or shells 
cannot be deleted. Deleting a template will have no affect on cost sheets 
created from it. 

Move a Column (Project Cost Sheet) 

To move a column of a project cost sheet (Company Workspace tab > Templates > Shells > 
Projects > PROJECT TEMPLATE > Cost Manger > Cost Sheet > Project Cost Sheet).  

1) From the Columns log, select a column to move. 

2) Click Move Up (Left) or Move Down (Right). The order that the columns appear in the Log 
window is the order (from left to right) that they appear on the sheet. 

Delete a Column (Project Cost Sheet) 

If a column is being used in a formula in another column, you must remove the column from the 
formula before you can delete it. If the column contains a cell with line item data, you must first 
remove each line item before it can be deleted.  
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To delete a column 

1) Select a column from the Columns Log and click Open to open the Column Properties 
window. 

2) Click the Delete button. Click Yes to confirm. 

Hide Cost Sheet Columns (Project Cost Sheet) 

You can hide a cost sheet column. Hidden columns are not visible on the cost sheet, but 
otherwise function like other cost columns. For example, you might want to hide a column that is 
used in a formula column, but is unnecessary to display. Hidden columns can be viewed from 
the Columns Log by users with "create" permission on the cost sheet.  

To hide a cost sheet column 

1) Select a column from the Columns Log and click Open to open the Column Properties 
window. 

2) For Display Mode, choose Hide. 

3) Click OK to close the window. The Columns log will show the column as Hidden in the 
Display Mode column. Hidden columns do not display on the cost sheet, but are listed in the 
Columns log. 

To unhide a hidden cost sheet column 

1) Select the hidden column from the Columns Log and click Open to open the Column 
Properties window. Hidden columns are labeled as "Hidden" in the Display Mode column in 
the Columns Log. 

2) For Display Mode, choose Unhide. 

3) Click OK to close the window. The column will display on the cost sheet, to all users with at 
least View permissions, and who have not been given View restrictions. 

Edit a Cost Row 

You can edit rows in templates and cost sheets. However, in cost sheets, if you have already 
distributed and locked the budget, you must unlock it first before you can access the Rows 
window and edit rows.  

To edit a row 

1) From the Cost Templates log (Templates node > Cost Sheets > ...), open the cost sheet. 
The Cost Sheet - <name> window opens. 

2) From the toolbar options row, click Manage Rows (icon with three horizontal lines) to open 
the Manage Rows window. 

3) In the Manage Rows window, you can use the Add option to add a row, select a row and 
delete it, "Indent" a row under a summary row, or "Outdent" a row, bringing it out from under 
a summary row. For more information, see Adding Cost Rows (CBS Codes) (on page 
385). 

For the Project Cost Sheet: 

1) From the Cost Sheet log (Templates node > Shells > ... > Cost Manager > Cost Sheet), 
open the cost sheet. The Cost Sheet - <name> window opens. 
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2) From the toolbar options row, click Manage Rows (icon with three horizontal lines) to open 
the Manage Rows window. 

3) In the Manage Rows window, you can use the Add option to add a row, select a row and 
delete it, "Indent" a row under a summary row, or "Outdent" a row, bringing it out from under 
a summary row. For more information, see Adding Cost Rows (CBS Codes) (on page 
385). 

View or Edit CBS Details 

The CBS Detail window displays CBS properties. Notes and files can be attached to 
transactions via the CBS Detail window. You can also specify CBS Breakdowns in the CBS 
Detail window, which are used in SOV sheets. 

Note: If you have locked the budget, you will need to unlock it first in 
order to access the Rows window or CBS Detail window. 

To view CBS Details 

1) Open the Cost Sheet. 

2) Do one of the following: 

 From the cost sheet, click the CBS Code to be edited, which appears as a link in the first 
column of the cost sheet row. The CBS Detail window opens as a read-only window. 

 From the cost sheet, click the Rows button to open the Rows window, then click a CBS 
Code. The CBS Details opens in an editable view, provided you have edit permissions. 

The General tab displays information about the CBS Code. The Breakdown tab displays 
breakdown information. 

To edit CBS Details 

For more information about adding CBS Breakdown, see the following section. 

1) From the Cost Sheet, click the Rows button. The Rows window opens. 

2) Click the CBS Code to be edited, which appears as a link. The CBS Detail window opens. 

3) Make changes to the General Tab or Breakdown Tab as necessary. 
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4) Click Apply and OK. 

Creating a Project or Shell Cost Sheet 

The Cost Sheet is created by copying from a cost template or another project or shell cost sheet. 
Only one project or shell cost sheet may be defined per project or shell. You may define multiple 
work packages or work sheets. 

If a worksheet is associated with the cost sheet or template (that is, if a cost sheet column 
definition refers to Worksheet as Data Entry method), the worksheet will also be copied. 

Note: Once a cost sheet has been created, it cannot be deleted. Be sure 
the structure (tree or flat) of the template is what you want to use for the 
cost sheet. The structure is not editable for cost sheets. You can add, 
modify or delete columns and rows to the sheet as necessary. 

To create a cost sheet by copying a template 

1) Go to your Company Workspace tab (Admin mode):  

2) Click the Templates node to expand. 

3) Click Projects sub-node to expand. 

4) Click PROJECT TEMPLATE sub-node to expand. 

5) Click Cost Manager sub-node to expand. 

6) Click Cost Sheet sub-node to open the Cost Sheet log. 

7) Click New, click Cost Sheet, select Copy from Template. This option will allow the user to 
create a Cost Sheet by copying one from a company level template. 

8) Select a template and click Copy. 

To create a cost sheet by copying from another project or shell 

1) Go to your Company Workspace tab (Admin mode):  
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2) Click the Templates node to expand. 

3) Click Projects sub-node to expand. 

4) Click PROJECT TEMPLATE sub-node to expand. 

5) Click Cost Manager sub-node to expand. 

6) Click Cost Sheet sub-node to open the Cost Sheet log. 

7) Click New, click Cost Sheet, select Copy from Projects. This option will allow the user to 
create a Cost Sheet by copying one from a company level template. 

8) Select a template and click Copy. 

Add cost sheet columns and rows 

Rows and columns are added to project or shell cost sheet the same way as they are to cost 
templates. See Creating and Setting up Cost Templates. 

Add column view or edit restrictions 

The Restrictions setting allows you to restrict viewing or editing permissions for particular 
columns. This functionality allows you to restrict specific users or groups from viewing or editing 
columns that they would normally be able to access. 

Column restrictions can be added to project or shell, program and company level cost sheet 
columns and work package columns, but not the cost template. 

A user may have general view and/or edit permissions on the cost sheet, but can be restricted 
from viewing or editing cost information in specific columns within the cost sheet. Users or 
Groups with Create permissions can set these additional column restrictions from within the cost 
sheet in User Mode. 

Column restrictions differ from "hidden columns" in that users with edit and/or view permissions 
for the entire cost sheet will by default have edit and/or view permissions for each column in the 
cost sheet, unless restricted from doing so. "Hidden" columns are not displayed on the cost 
sheet, regardless of the permissions of the user. 

Restriction setup affects Budget Distribution and Assigned Budget. If Assigned Budget is 
available on the cost sheet, the following applies: 

 No Restriction setup for a user: User can view and edit both Budget distribution and 
Assigned Budget 

 Disallow Viewing checked for a user: User cannot view and edit both Budget distribution and 
Assigned Budget. Cannot import Summary Budget 

 Disallow Viewing unchecked for a user: User can view Budget distribution and Assigned 
Budget. Cannot import Summary Budget 

 Disallow Editing checked for a user: User cannot view and modify Budget distribution and 
Assigned Budget. Cannot import Summary Budget. 

 Disallow Editing unchecked for a user: User can view and modify Budget distribution and 
Assigned Budget. Can import Summary Budget 

Restrictions and permissions: 
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 Opening a worksheet directly from the log window is based on the worksheet permission 
defined for that worksheet.  

 Accessing and viewing worksheet data from a Cost Sheet column is subject to column 
restrictions. Worksheet ownership (creator) and permissions work on top of Cost Sheet 
column restrictions. 

 Be sure you have cost sheet "Create" permissions. Users with create permissions for the 
cost sheet will be allowed to access the Restrictions button. 

To set cost sheet column restrictions 

1) In User Mode, open the work package or project or shell, program or company level cost 
sheet. 

2) Click the Columns button. The Columns Log opens. 

3) Click the Restrictions button. The Edit Restrictions window opens. 

4) Click the Add button. The User/Group Picker opens. 

The users or groups that are displayed in the picker are limited to those users and groups 
that have cost sheet permissions. For example, if you have given project or shell cost sheet 
permission to a single group, that group will display in the User/Group Picker window. 

5) Select the user or group to edit restrictions and click OK. The Edit Restrictions window 
opens. 

6) Select one or more user/group in the upper portion of the Edit Restrictions window (press the 
Shift or Ctrl keys to select more than one user or group). The permission settings for each 
cost sheet column are displayed in the lower portion of the window. 

7) For each column, you may set the following restrictions: 

 Disallow Editing: if a user or group is not allowed to edit a column, then that user or 
group will not be allowed to add, modify, or delete data in any of the cells in the column. 

 Disallow Viewing: select this checkbox if you want to restrict the user/group from 
viewing a particular column. 

8) Click OK. 

Cost sheet column permission matrix 

The following summarizes the relationship between user cost sheet permission settings in 
Administration mode with the additional column restrictions in User Mode. 

Column restrictions will not override View or Edit permissions for users with 
module-level Create permission. If a user has Cost Sheet module Create permission (in 
permission settings), this overrides any User Mode column restrictions. This also means that if a 
user has a "Disallow Editing" or "Disallow Viewing" column restriction, and then is subsequently 
granted module-level Create permission for the cost sheet, that Create permission will override 
the column restriction and the user will be able to view/edit the column (even if the restriction is 
still selected in User Mode). 
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Note: These restrictions apply to work packages as well. If a user does 
not have view permission on a column, then that user will not be allowed 
to view the same column in a work package. 

With this Permission/RestrictionSetting: The User Can: 

Cost 
Sheet 
Module 

Column 
"Disallow 
Editing" 

Column 
"Disallow 
Viewing" 

Edit 
column 
data 

View 
column 
data 

Import 
Column 

Export 
Column 

View not selected not selected No Yes No Yes 

View x not selected No Yes No Yes 

View x x No No No No 

Modify not selected not selected Yes Yes Yes Yes 

Modify x x No No No No 

Modify x x No No No No 

Create not selected not selected Yes Yes Yes Yes 

Create x not selected Yes Yes Yes Yes 

Create x x Yes Yes Yes Yes 

If a user or group is removed from module level permission but was previously configured in the 
Restrictions window to edit or view columns, then that user or group will not be removed from 
the restrictions list. 

Edit Restriction is available only for manual entry column, for example: Manual datasource, 
Assigned Budget, YTB, Manual Funding at Project or Shell and CBS Level. For all other 
columns, Edit Restriction option is disabled, as the user cannot edit information. 

Effects of column restrictions on viewing a worksheet 

Cost Sheet Column Worksheet 

Case 

Can 
view/edit 
column 
data 

Can view 
column 
data 

Owner 
Edit 
permissi
on 

View 
permissi
on 

Access in 
view 
mode 

Access in 
edit mode

1 Yes Yes Yes Yes Yes n/a Yes 

2 Yes Yes No Yes Yes n/a Yes 

3 Yes Yes No No Yes Yes No 

4 Yes Yes No No No No No 

5 No Yes Yes Yes Yes n/a Yes 

6 No Yes No Yes Yes n/a Yes 
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7 No Yes No No Yes Yes No 

8 No Yes No No No No No 

9 No No Yes Yes Yes No No 

In cases 4 and 8, the user will see an error message that they cannot view the worksheet as 
they do not have view permissions for the worksheet. In case 9, they will not see any message, 
as they cannot see the column with worksheet as the data entry method. 

Add CBS breakdown 

Breakdowns are used in SOV sheets. Invoices can be created from SOVs that can include CBS 
breakdowns. The breakdowns are not accessible in any BP except Spends BPs, and are not 
associated with data definitions, and so are not reportable. 

The breakdown applies to a single project or shell, and can be applied across projects or shells 
by adding CBS code rows and breakdowns to Cost templates, or creating cost sheets from 
previous project or shell cost sheets with breakdowns. 

You may add as many breakdowns as you need. When you click OK, the system will perform a 
validation check. If the CBS code is already in use in a cost sheet transaction, the system will 
not allow the addition of a breakdown. 

Note: If you have locked the budget, you will need to unlock it first to 
access the Rows window. 

You can also add breakdowns directly to SOV sheet. This is done in User mode on the SOV 
sheet. 

To add a CBS Breakdown 

1) From the Cost Sheet, click the Rows button. The Rows window opens. 

2) Click the CBS Code to be edited, which appears as a link. The CBS Detail window opens. 

3) Make changes to the General tab or Breakdown tab as necessary. 

4) Open the CBS Details window and click the Breakdown tab. 

Note: The Breakdown tab becomes accessible after the row has been 
created. To see the Breakdown tab, you must first create the CBS Code 
and click OK. 

5) Click the Add button. 

6) Add a Breakdown Name and Description and click OK. 

Add notes and attachments to a CBS code 

To add notes to a CBS code: 

1) From the CBS Detail window, click Add Notes. 

2) Enter the note and click OK. The number of Notes attached to the record will display in the 
lower left corner of the window. 



Setting up the Cost Manager

401

3) Click the Number link to view the notes. 

To attach files to a CBS code: 

From the CBS Detail window, click Attach and select one of the following options: 

a. My Computer: To attach a file from your local system. When you attach files from your 
local system. 

b. Primavera Unifier Folder: To attach documents from the Document Manager. The 
window opens, displaying the Documents files and folders. Select the files and folders to 
attach and click OK. (Folders are not attached; the contents of selected folders are 
attached in a flat list. Documents with duplicate files names will not attach.) You must 
have at least view permission to the folders and files within the Document Manager in 
order to view and attach them. 

Modify cost sheet default view 

The cost sheet default view refers to how the cost sheet appears when it is first opened. The 
cost sheet Properties window offers two options regarding the cost sheet default view, described 
in the procedure below. These options control how the cost sheet opens for all users. 

To modify the cost sheet default view 

1) In User Mode, open the cost sheet Properties window (click the Properties button from the 
log toolbar, or open the cost sheet and click File > Properties). 

2) On the General tab, you may optionally choose either or both of the Default View checkbox 
options: 

 Open in maximized view: when the cost sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the cost sheet is opened, it will automatically open as split 
(same as clicking the Split button) 

If these options are not selected, the cost sheet will open by default to a size slightly smaller 
than the Unifier screen, and not split. 

Setting up a Program Cost Sheet 

Program Cost Sheets are created automatically once a project cost sheet has been created for 
one of the project in the program. It includes all projects that are active an on-hold and that are 
included as part of program definition. Newly added projects will be displayed on Cost Sheet at 
appropriate location based on sorting order. 

The Program Cost Sheet will display cost data for all projects (within the program) that have a 
status of Active, On-hold, or View-Only.  The currency used is the company Base Currency. 

Projects on the Program Cost Sheet are sorted automatically by ascending project number. As 
new projects are added to the program, and cost sheets are created for them, the new projects 
will be automatically added to the Program Cost Sheet. 

You can add columns to correspond to and roll up project cost sheet data. Rows correspond to 
project cost sheets. 
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Access the program cost sheet 

When you create a new Program, the Program Cost Sheet is created automatically, based on 
the cost sheets of the individual projects in the program. As project cost sheets are updated, the 
program cost sheet is updated automatically. You may add additional Cost Groups which 
incorporate program-related cost data. 

To view a program cost sheet or cost group 

1) Open the program. 

2) From the Navigator, click Cost Manager > Cost Sheet. The log lists the Program Cost 
Sheet and any cost groups. 

 Title: The Program Cost Sheet name or the Cost Group name. 

 Reference No.: The Reference number assigned to the Cost Group at time of creation. 

 Date Created: The date the Cost Sheet or Cost Group was added to the Program. 

 Creator: The project team member that added the Program Cost Sheet or Cost Group to 
the Program. 

 Type: The type is either Program Cost Sheet or Cost Group. 

 Status: The current status of the Program Cost Sheet or Cost Group.  

3) Select the Cost Sheet or Cost Group to view and click Open. 

The Program Cost Sheet opens, listing each of the projects in the program. The Project 
Numbers are hyperlinks that open the associated project cost sheet. Depending on your 
permission levels, you can view the current project data that was used in the current 
Program. 

4) To view a project cost sheet, click on the Project Number link. The Project Cost Sheet 
opens. Close the project cost sheet window when you are done viewing it. 

5) Close the Program Cost Sheet when you are done making modifications. 

Add Program Cost Sheet Columns 

Cost sheet columns can be added to program cost sheets the way they are added to cost 
templates. Predefined data sources at project level will be rolled up to program level 
automatically. 

Note: Column restrictions can be added to program cost sheet columns. 
See the Project Cost Sheet section. See Add column view or edit 
restrictions (on page 397). 

Program cost sheet data sources 

Data Source Description 

Single Sources 

Data from single datasources Project Cost1 to Project Cost25 is 
rolled up from project-level cost sheets. Users can also view 
datasources based on business process data rollup from the 
project-level. Following are the available datasources: 

Business Included in the Single Sources list are all of Cost BPs that are 
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Process (All 
statuses) 

available for your project, and all of their terminal statuses. 

AFC AFC 

Funded 
Records 

This column shows records in which the CBS code is funded, that is, 
spend-type business process records that consume funds. 

Unfunded 
Records 

This corresponds to spend-type BP records that are not funded. 

Prior Forecasts  

Yet To Buy 

Project Cost 1 
to Project Cost 
25 

Rollup from all projects 

All Project 
Single Sources 

All other data sources are similar to Project Cost Sheet. 

Logical Sources

Program 
Budget 
Remaining 
Balance 

This is a place holder for a formula you create (optional). 

Program 
Budget 
Variance 

This is a place holder for a formula you create (optional). 

Program 
Commits 

You can add all your BP commits here. 

Program 
Forecasts 

This is a place holder for a formula you create (optional). 

Program 
Forecasts 
(Unaccepted) 

This is a place holder for a formula you create (optional). 

Program 
Forecasts 
Variance 

This is a place holder for a formula you create (optional). 

Program 
Funding 

You can roll up all project funding here 

Program 
Spends 

You can rollup spends BPs here. 

Program CBS 
Funding 

This requires additional setting in Funding Sheet; see Setting up the 
Funding Manager (on page 413). 

Program 
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Manual Funding 
by CBS 

Program Cost 
1-25 

Create and manage program cost groups 

To create a new program cost group 

1) Open a program and click Cost Manager > Cost Sheet in the left Navigator. The Cost 
Manager log opens. 

2) Click the New button. The Cost Group Properties window opens. 

3) Enter the Properties information: 

 Title: Enter a unique title for the cost group. 

 Record No.: Enter a record number. 

 Status: Choose to make the Cost Group Active or Inactive. 

 Owner: Click Select and select an owner. 

 Enter an optional Description and any Comments. 

 You may click the Attach button to attach files to the Cost Group.  

4) Click Apply and OK to save the Cost Group properties information. The new Cost Group 
appears in the Cost Summary log. 

To set up the Cost Group 

1) Select the Cost Group from the Program Cost Manager log. 

2) Click Open. The Cost Group sheet opens. 

Depending on your permission levels, you can view the current project data that was used in 
the current Program, or you can Add and Delete columns and select new data sources to 
use in the Program. 

3) Close the Program Cost Sheet when you are done making modifications, then navigate to 
the Summary node to view the new Program data. 

Setting up the Company Cost Sheet 

The company cost sheet can be setup to rollup project or shell cost data across all company 
project or shells. 

Create a company cost sheet 

Company cost sheet will not be auto-created. The company administrator must create one. Cost 
sheets are added by default. 
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To create a company cost sheet 

1) In User Mode, navigate to Company > Cost Manager> Cost Sheet. The Cost Sheet log 
opens. 

2) Click New. Once a cost sheet has been created it cannot be deleted. 

Modify company cost sheet default view 

The company cost sheet Properties window offers two options regarding how the cost sheet will 
appear when it is first opened. These options control how the company cost sheet opens for all 
users. 

To modify the company cost sheet default view 

1) Open the company cost sheet Properties window (click the Properties button from the log 
toolbar, or open the cost sheet and click File > Properties). 

2) On the General tab, you may choose either or both of the Default View checkbox options: 

 Open in maximized view: when the sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the sheet is opened, it will automatically open as split (same 
as clicking the Split button) 

If these options are not selected, the company cost sheet will open by default to a size 
slightly smaller than the Unifier screen, and not split. 

Add Company Cost Sheet Columns 

Cost sheet columns can be added to company cost sheets the way they are added to cost 
templates. Predefined data sources at project or shell (CBS) level will roll up to company level 
automatically. 

Note: Column restrictions can be added to company cost sheet columns. 
See Add column view or edit restrictions (on page 397). 

Company Cost Sheet Data Sources 

Data Source Description 

Single Sources 

Data from single datasources Project Cost1 to Project Cost25
is rolled up from project-level cost sheets. Users can also view 
datasources based on business process data rollup from the 
project-level. Following are the available datasources: 

Business Process 
(All statuses) 

Included in the Single Sources list are all of Cost BPs that are 
available for your project, and all of their terminal statuses. 

AFC Allowance for Change. This is a contingency value. 

Funded Records 
This column shows records in which the CBS code is funded, 
that is, spend-type business process records that consume 
funds. 

Unfunded Records This corresponds to spend-type BP records that are not funded. 
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Prior Forecasts Prior forecasts 

Yet To Buy 

This is a portion of a commit that you still need to buy. This can 
be automated for uDesigner BPs (commit BPs can track YTB), 
In Unifier Cost Properties, you need to set "Auto" "Transaction" 
options, which track YTB. 

Project Cost 1 to 
Project Cost 25 

Rollup from all projects 

All Project Single 
Sources 

All other data sources are similar to Project Cost Sheet. 

Logical Sources These sources are formulas. 

Company Budget 
Remaining Balance 

This is a place holder for a formula you create (optional). 

Company Budget 
Variance 

This is a place holder for a formula you create (optional). 

Company Commits Can be used for company commit BPs 

Company Forecasts This is a place holder for a formula you create (optional). 

Company Forecasts 
(Unaccepted) 

This is a place holder for a formula you create (optional). 

Company Forecasts 
Variance 

This is a place holder for a formula you create (optional). 

Company Funding You can roll up all project funding here. 

Company Spends You can rollup spends BPs here. 

Company CBS 
Funding 

This requires additional setting in Funding Sheet; see Setting 
up the Funding Manager (on page 413). 

Company Manual 
Funding by CBS 

Company Cost 1-25  

Map cost sheet column to an account code 

You can define mapping between a company cost sheet column and a company account code. 
This allows you to link an account code with project or shell cost data that is rolled up from a 
project or shell cost sheet into the cost sheet. 

Notes:  

 You can map a cost column to more than one account code. For 
example, Column A can be mapped to both Account Code X and 
Account Code Y. This means that the Total will display for both 
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account codes in that column. However, each account code can be 
mapped only once (Account Codes X and Y cannot be mapped to 
any other columns). 

 If you remove a column from the asset sheet that is associated with 
an account code, the mapping will be lost. 

To map a cost sheet column to an account code 

1) In User Mode, navigate to the company cost sheet. 

2) Open the Properties window and click the Options tab. 

3) Click Add. The Add Mapping window opens. 

4) Complete the window: 

 Column Name: Company Cost Sheet Column drop-down will show list of all columns 
that are defined on the cost sheet. 

 Account Code: Click Select. A picker window opens displaying active codes from the 
accounts sheet. Select a code and click Open. 

 Account Name: This field is populated with the name of the account code chosen in the 
previous field, as defined in the accounts sheet. 

5) Click OK to save the Add Mapping window. 

6) Click Add to add additional mapping if necessary. 

7) Click OK to save and exit the Properties window. 

Once mapping is complete, data from the company cost sheet (which reflects data rolled up from 
project or shell cost sheets) will be rolled up to the Accounts Sheet under the Projects data 
source. Only the total value will be rolled up. If the Total value in the cost sheet column changes, 
the change is reflected on the accounts sheet. 

Note: Note: The process used to update the accounts sheet with 
mapped cost sheet data runs in the background. After mapping a cost 
column to the accounts sheet, or updating the cost sheet data, the 
change may not reflect in the accounts sheet immediately. 

To modify mapping 

In the Properties window, Options tab, select a mapping and click Modify. You can make 
changes in the Add Mapping window. 

To remove mapping 

In the Properties window, Options tab, select a mapping and click Remove. This removes the 
mapping. Data will no longer roll up to the accounts sheet. 

Deleting Cost Sheets 

This section describes how to manually delete a cost sheet from a shell.  

Note: You can delete a cost sheet from a specific shell template but not 
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from other Projects/Shells that have been created using the template. 

In Administration mode: 

1) Go to Company Workspace tab, open the project or shell and in the left navigation pane, 
click Templates > Shells > {Shell Type} > {Shell Template}> Cost Manager > Cash Flow. 

2) Select a sheet for deletion. 

3) Click Delete. 

Note: System prompts the user asking to confirm deletion of the cost 
sheet. 

4) Click Yes to delete the cost sheet. 

Setting up a Company Accounts Sheet 

The company accounts sheet is used to track company level accounts information, such as 
assets, resources, and facility maintenance. It is similar to a project or shell cost sheet, using 
account codes instead of CBS codes. 

Account codes are independent of CBS codes, but are similar in structure format. Company 
level business processes can be designed in uDesigner to roll up to the accounts sheet (line 
items are associated with account codes). 

How to set up a company accounts sheet 

Before you begin: A Company Account code attribute form must be deployed in uDesigner. 
This is used as the detail form for creating account codes (rows) on the accounts sheet. There is 
no default form available. The design also includes creating an account code picker, which can 
be used on BP forms used with the accounts sheet, and for mapping account codes to project or 
shell cost sheet columns. 

Step 1: Deploy the company Account Code attribute form in uDesigner, similar to other design 
deployment in uDesigner. 

Step 2: Grant Accounts Sheet permissions. 

Step 3: Create a company level accounts sheet. There is one accounts sheet per company. 
There is no template for an accounts sheet. After creation, you add columns and rows. The 
columns can be formulas, they can roll up data from company cost (accounts) business 
processes, or they can roll up asset data, project or shell cost data, or resource data. Adding 
rows to the accounts sheet creates the account codes that are used. You need to activate the 
account codes after adding the rows. 

Optional steps: To roll up transactions to the accounts sheet, you must create and set up 
company-level cost business processes (also known as an account type business process). 
These BPs use account codes rather than the CBS codes used in project or shell level cost BPs. 
These are discussed in the Business Process sections. Other options assume that you have 
configured and set up an Assets Sheet (for rolling up asset data). 
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Import Company Account Code Attributes Form 

To import Company Account Code Attributes form, see Importing Configuration Packages (on 
page 640). 

Create a company accounts sheet 

You can create a, accounts sheet to create new company account codes and capture and view 
company level cost. 

To create an accounts sheet 

1) In User Mode, go to the Company Workspace tab and click Cost Manager > Accounts 
Sheet in the left Navigator. The Accounts Sheet log opens. You can have one accounts 
sheet per company. 

2) Click New. The Properties window opens. 

3) Complete the General tab. 

 Title: This will be displayed in the log 

 Description: Enter an optional description 

 Display Mode: Choose Flat or Tree. Account codes are segmented, similar to CBS 
Codes. You can switch between Flat or Tree at any time. The same data is displayed in 
Tree or Flat structure. 

 Default View: You may choose either or both of the Default View checkbox options: 

 Open in maximized view: when the sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the sheet is opened, it will automatically open as split 
(same as clicking the Split button) 

If these options are not selected, the accounts sheet will open by default to a size slightly 
smaller than the Unifier screen, and not split. The window can be resized by clicking the 
Minimize or Maximize/Restore buttons in the upper right corner of the window, or by dragging 
the edges of the window to the size that you need. 

4) Click OK. The new accounts sheet appears in the log. 

To open the company accounts sheet 

1) In User Mode, go to the Company Workspace tab and click Cost Manager > Accounts 
Sheet in the left Navigator. 

2) Select the accounts sheet in the log and click Open, or double-click the sheet to open it. The 
Accounts Sheet opens. You can do the following: 

 Add rows (account codes) or columns 

 Resize the window as needed (click and drag the sides) 

 Split the screen vertically, which is useful for viewing columns or entering data while 
keeping the account codes in view (click the Split button) 
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Add a column to an accounts sheet 

You can add as many columns as necessary to the accounts sheet. There are two default 
columns: Company Account Code and Company Account Name. You can add columns for 
formulas, for transaction data from company level cost business processes (account type), or to 
roll up data from project or shell cost sheets, asset sheets, or resource actuals. 

To add a column 

1) Open the accounts sheet. 

2) Click the Columns button. The Columns log opens. 

3) Click New. The Column Properties window opens. 

4) Complete the columns log as described in the following table. 

5) Click OK. 

In this field: Do this: 

Name The name is populated with the data source 

Data Source 

Click the drop-down and choose the data source for the column. 
Options include: 

Single Sources: 

 Company account type BPs, listed by name and status. 
These are company level cost BPs of subtype line items with 
accounts code or line items with asset code. 

 Projects/Shells (CBS): Data is rolled up from project or shell 
cost sheets into the company cost sheet, based on the 
mapping of cost sheet columns and account code. 

 Assets: Data is rolled up based on the mapping between asset 
sheet columns and account code. 

 Resource Actuals: Data is rolled up from company level time 
sheet records. 

Logical Sources:  

 Accounts Code 1 through 25. You can use these to create a 
formula or manual entry column. These are reportable. 

Entry Method 

Select one of the options (options available are dependent on the 
data source; applicable when a Logical data source is selected): 

 Manual: User enters data directly into an accounts sheet cell 

 Formula: Can create a formula from other accounts sheet 
columns 

Data Format Choose Currency (base currency) or Percentage (%) 

Display Mode Show or Hide the column from user view 

Column Position 
After 

Select the column after which you want the current column to 
appear 
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To roll up project or shell cost sheet data to the accounts sheet 

1) Be sure the project or shell cost sheet data rolls up to a company cost sheet column, using a 
data source Project/Shell Cost 1 through 25 for the cost sheet column. 

2) Map the company cost column to an account code. (In the company cost sheet Properties 
window, Options tab. See Map cost sheet column to an account code (on page 406).) 

3) Roll up the mapped company cost column data to the accounts sheet column, choosing 
Projects/Shell data source. The column will show the Total of the company cost column. 

As project or shell level transactions take place, the company cost column will reflect the 
changes, which in turn will roll up to the accounts sheet. 

To roll up project or shell asset sheet data 

1) Map the asset sheet column to an account code. See Setting up the Asset Manager (on 
page 327). 

2) Roll up the mapped asset data to the accounts sheet column, choosing Assets data source. 
The column will show the Total of the asset column. 

Note: The process used to update the accounts sheet with mapped cost 
or asset sheet data runs in the background. After mapping a cost or 
asset column to the accounts sheet, or updating the cost or asset sheet 
data, the change may not be reflected in the accounts sheet 
immediately. 

Adding and Managing Accounts Sheet Rows 

Regardless of the order you add or import rows, they are automatically sorted alphanumerically 
by account code. 

Add rows to the accounts sheet 

You can add account codes to the accounts sheet manually or by importing. 

To add a row to the accounts sheet manually 

1) Open the Accounts Sheet. 

2) Click the Add Rows button. 

3) Complete the Account Code Details form. This is the attribute form will vary based on your 
company’s design. Account codes are built like CBS codes, from segments that can be text 
fields or pulldown menus. 

4) Click OK. 

Delete accounts sheet rows 

You cannot delete a row if it contains line item or rolled-up data, or if the code is mapped to a 
cost or asset sheet column. 

To delete rows from the accounts sheet 

1) Open the accounts sheet. 
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2) If you are using a tree structure, click the plus (+) next to segment rows (shaded blue) to 
view account code rows. 

3) Select a checkbox next to the account code to be deleted. 

4) Click the Delete Rows button. 

5) Click Yes to confirm. 

Import account sheet rows 

Step 1: Export template

a) Open the accounts sheet. 

b) Click the Export button and choose Account Codes. 

c) In the File Download window, click Save. Enter a file name, browse to where you want to 
save the file, and click Save. 

Step 2: Edit Template in Excel

a) Open the CSV file you just exported. 

b) If the accounts sheet already contains rows, they will be listed. Note the format and 
structure. 

c) Delete any existing rows. 

d) Enter new account codes into the columns and save the file. 

Step 3: Import the CSV file

a) On the Account Sheet toolbar, click Import and choose Account Codes. 

b) In the Upload window, browse to and add the CSV file. 

c) Click OK. After the import, the accounts sheet will show the new rows. Rows are 
automatically alphabetically by account code (adjusts for tree or flat structure). 

Activate an account code 

If an account code is inactive it should still be displayed on accounts sheet but should not be 
available through an account code picker. 

To activate or deactivate an account code 

1) Open the Accounts Sheet. 

2) Click the Account Status button. The Account Code Status window opens. 

3) Select one or more account codes and click Activate or Deactivate. 

Modify accounts sheet default view 

The accounts sheet Properties window offers two options regarding how the sheet will appear 
when it is first opened. These options control how the sheet opens for all users. 

To modify the accounts sheet default view 

1) Open the accounts sheet Properties window (select the sheet and click the Properties
button from the log toolbar, or open the sheet and click File > Properties). 
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2) On the General tab, you may choose either or both of the Default View checkbox options: 

 Open in maximized view: when the accounts sheet is opened, it will automatically open 
maximized, or full-screen 

 Open in split mode: when the sheet is opened, it will automatically open as split (same 
as clicking the Split button) 

If these options are not selected, the accounts sheet will open by default to a size slightly 
smaller than the Unifier screen, and not split. 

Setting up the Funding Manager 

The Funding Manager helps you to keep track of where project or shell funding comes from and 
how it is being spent. The Funding Manager is available in standard projects and CBS shells. 
Use the Project or Shell Funding sheet to specify the appropriation and assignment of funds 
from each funding source. You can automate fund appropriation and assignment when used 
with cost business processes. 

Sometimes, it may be necessary to allocate specific funds to use on a particular contract, and 
have a means to control consumption on the invoices created against that contract. This can be 
done through commitment-level funding. A commitment funding sheet is created for each base 
commit that has been designed for commitment funding. You allocate funds from the project or 
shell funding sheet to the commitment funding sheet. This sheet works in conjunction with the 
Schedule of Values (SOV) sheet to track base commit and change commit line items and 
balances. 

Company Funding Sheet vs. Project or Shell Funding Sheets vs. Commitment Funding 
Sheets 

The first step to setting up funding is to create and set up a company funding sheet, where 
individual funding sources are maintained. 

For example, a corporation's funding sources may include different types of corporate accounts. 
For municipal or educational facilities, funds may come from bond measures, grants, donations 
or other sources. All of these funding sources will be listed and tracked on the company funding 
sheet. As funds are consumed via business processes or manually in individual project or shells, 
this data is rolled up to the company funding sheet. 

Project or shell funding sheets track how your company’s funding is being spent on each project 
or shell. It tracks individual transactions, which are rolled up to the company funding sheet. All 
project or shell funding sheets must be created based on a funding template. 

If you are using commitment funding, you will start with a commitment funding template, which is 
used to create the commitment funding structure within a project or shell. As base commits (that 
are designed for commitment funding in uDesigner) are routed and approved, a commitment 
funding sheet is created, based on this structure, for each base commit record. This sheet works 
with the SOV sheet to track and control funding of each SOV line. 
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How to set up the Funding Manager 

The following is an overview of the steps needed to set up funding for use in projects and shells, 
plus the steps needed to set up the optional commitment level funding. Details for each step are 
in the sections that follow, unless otherwise noted. 

Setting up company and project/shell funding 

Before you begin. The fund attribute form can be designed in uDesigner. This will be used as 
the Fund Details window when adding new funds to the company funding sheet, or viewing fund 
properties. If your company does not design a fund attribute form, a simple default form is used. 

Import and set up fund business processes. You can use business processes for fund 
allocations, fund assignment (also known as consumption; enabled on spends type business 
processes), and fund credits (also enabled on spends business processes). This step can be 
done at any point in this general procedure. Be sure you know which funding business 
processes you will be using for the project or shell before defining funding rules on the project or 
shell funding sheet. 

Step 1: Import and deploy the fund attribute form. Once imported, the fund attribute form 
becomes the Fund Details window in Unifier, used to create and manage fund codes in the 
company funding sheet. When designing the form, you can also design the fund picker, which is 
used to add funds to business processes and project/shell funding sheets, as well as "Find" on 
the picker. This is an optional step. If you do not create a fund attribute form, a default fund code 
form and fund picker will be used. 

Step 2: Create and set up the Company Funding Sheet (User Mode). You define the funds in 
the company funding sheet, which can then be used for funding project or shells. Only one 
company-level funding may be created per company. All project or shell funding sheets refer to 
the company funding sheet. 

Step 3: Create and set up Project/Shell Funding Template (Administration Mode). The 
funding template is used to create project or shell funding sheets. 

Step 4: Create and set up the Project/Shell Funding Sheet (User Mode). The project or shell 
funding sheet is based on the funding template. (You can also define the project/shell funding 
sheet in a project or shell template.) The funding sources available for the project or shell are 
defined in the company funding sheet. 

Step 5: Define funding assignment rules. Funding assignment rules can be defined in the 
project/shell funding sheet or the funding template (or both). You can also determine the order in 
which to consume funds if you will be using automatic fund assignment from business 
processes. (This step can be done any time after creating the funding template. If you define 
assignment rules in a template, they will be carried over to the sheets created from them.) 

Additional steps: Create funding rules in the rules engine. You can create funding rules in 
the rules engine that can help you manage your funds and fund balances. The most common 
rule is to keep your company fund balances from becoming less than zero. Configure 
permissions. As you create funding sheets and set up funding business processes, remember to 
configure the permissions to go with them. Refer to the Unifier Reference Guide for funding 
permissions. 
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Setting up commitment level funding 

Commitment level funding is optional. To set it up, first set up funding in the project or shell, then 
follow these additional steps. 

Commitment funding works in conjunction with general spends and payment applications SOV 
sheets. 

Before you begin. Be sure that the project/shell funding has been set up, with funds allocated 
and available on the project/shell funding sheet. Data sources are available for project/shell 
funding sheets (and company funding sheets) to track funding that is assigned for specific base 
commits. Also, be sure you have added the data source "Scheduled Value" to the SOV structure 
for the project or shell. Commitment funding uses the SOV to track base commit and change 
commit amounts, and uses the Scheduled Value column to track remaining balances. 

Import and set up business processes for commitment funding. In addition to business 
processes that are used for project/shell funding, you can design business processes for use 
with commitment funding. In uDesigner, commitment funding is enabled on the base commit 
(and linked change commit); automatic generation of an SOV must also be enabled. Then, the 
ability to create (and later access) the commitment funding sheet can be enabled on the form. 
Be sure the spends business process that is linked to the base commit has been enabled to 
consume funding. 

Step 1: Create and set up Commitment Funding Template (Administration Mode). This 
template is used to create a commitment funding structures in the project or shell, which in turn 
is used to create the individual commitment funding sheets for each base commit record. You 
can add columns to the template, but not rows. 

Step 2: Define funding assignment rules. This is done in the Assignment tab of the Properties 
window. Assignment rules can be defined in the commitment funding template, structure or 
sheets. (This step can be done any time after creating the funding or commitment funding 
template. If you define assignment rules in a template, they will be carried over to the structure 
and sheets created from them.) 

Step 3: Create Commitment Funding Sheet Structure (User Mode). Structures are created at 
the project level in user mode from a commitment funding template. When commitment funding 
sheets are created from base commit records, this default structure is used. You can also create 
a commitment funding structure in a project or shell template. 

Step 4: Create individual commitment funding sheets. This is done automatically the first 
time you click the Funding button on a base commit business process form (this button becomes 
available on specific steps as designed in uDesigner). After creation, the commitment funding 
sheet is available for viewing or modification by clicking the Funding button on the base commit 
or associated change commits, or from the Commitment Funding log itself. 
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Additional steps: Configure permissions. Module permissions must be granted to the 
commitment funding template, to the commitment funding sheet in a project or shell template (if 
using), to commitment funding sheet in a project or shell (in order for the node to be visible). In 
addition, record level permission must be granted to individual commitment funding sheets. By 
default, the owner of the base commit will have permissions to the sheet. Additional users must 
be granted view or edit permissions. Refer to the Unifier Reference Guide for general funding 
permissions. Sheet permissions are granted User mode. Additional assignment details. After 
the commitment funding sheet and SOV sheet are created, additional funding assignment 
details can be defined on the Fund Assignment window (accessed from the SOV sheet or 
commitment funding sheet). 

Importing Fund Attribute Form 

The Fund Details form can be configured by creating a Fund Attribute form in uDesigner. With 
the import of this attribute form, you are also importing designs for the fund picker, which is used 
to add funds to business processes and project/shell funding sheets, as well as "Find" on the 
picker. If you do not create a fund attribute form, a default fund code form and fund picker will be 
used. 

Only one fund attribute form may be created and imported per company. 

Notes:  

 Use caution when modifying and re-importing an attribute form. For 
example, if you make changes to a data definition, such as Fund 
Category after it is being used in the funding sheet, the system may 
not see the new data definition and will produce an error. 

 Oracle strongly recommends that you use the Development
environment to create your uDesigner business processes and 
attribute forms before deploying to the Test/Production 
environment.  

To import a fund attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 640). 

Creating a Company Funding Sheet 

The Company Funding Sheet tracks all sources of funding across all projects or CBS shells. You 
create only one sheet per company. Funding sources that are made available at project or shell 
sheet level or commitment level are rolled up to the company sheet, which maintains the overall 
fund information. 

Once created, the company funding sheet can be edited, but not deleted. The company funding 
sheet must be created before creating individual project or shell funding sheets. 

To create the company funding sheet 

1) In User Mode, go to the Company Workspace tab and click Cost Manager > Funding in 
the left Navigator. The Company Funding Log opens. 

2) Click New. The Properties window opens. 
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3) Enter a Title and Description. 

4) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows). 

5) Click OK. The funding sheet is listed in the Company Funding log. 

Add columns to the company funding sheet 

The columns on the company funding sheet are used to track project/shell level funding, as well 
as commitment level funding if you are using it, and keep track of fund balances. 

To add a column to the company funding sheet 

1) From the Company Funding log, select the company funding sheet and click Open (or 
double-click on the company funding sheet). The Company Funding Sheet window opens. 

2) Click the Columns button. The Column Log window opens. 

3) Click New. The Column Properties window opens. Complete the Properties window as 
described in the following table. 

4) Click OK to add the new column to the company funding sheet. 
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In this field: Do this: 

Name 

The name you choose will appear as the column header. You 
may manually enter a column name, or, if you leave the Name 
field blank, the selection you make in the Datasource field will 
automatically populate the Name field. 

Datasource 

All columns must be associated with a data source. The data 
source that you choose will determine which of the following 
options are available. The types of Data sources available are 
as follow. 

 Single Sources: These values roll up from a single, defined 
source, such as a business process or a system defined 
source. 

 Logical Sources: These include user-defined Manual Entry 
or Formula columns. 

Single Source 

Data sources that contain funding sources and consumption 
information; that is, Fund subtype of Cost business processes, 
which allocate funding, Spends business processes that 
consume funding, and Commit business processes that trigger 
commitment funding, if used. 

 Business Processes: List of cost-type business processes 
that include funding data definitions. 

 Project/Shell Funding: Sum of all funding sources at 
project or shell level for each project or shell, as rolled up 
from each individual project or shell funding sheet. The 
information that gets rolled up to this column is dependent 
on the project or shell funding sheet setup for each project or 
shell. 

 CBS Funding: Sum of all funding sources at CBS level for 
each project or shell, rolled up from each individual project 
or shell funding sheet. The information that gets rolled up to 
this column is dependent on the project or shell funding 
sheet setup for each project or shell. 

 Manual Funding by project/shell: Sum of all project or 
shell-level funds that are allocated at project or shell level 
manually. 

 Manual Funding by CBS: Sum of all funds that are 
allocated at CBS level manually. 

 Commitment Funding: Sum of all funds that are allocated 
at the commitment level (if used) for each project or shell. 

 Records Funded at Project/Shell Level: Sum of all records 
that are funded at project or shell level. These are records 
that have already ended their workflow or hit terminal status.

 Records Funded at CBS Level: Sum of all records that are 
funded at CBS Level. These are records that have already 
ended their workflow or hit terminal status. 
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 Records Funded at Commitment Level: Sum of all records 
that are funded at the commitment level (spends BPs that 
are linked to base commits enabled for commitment 
funding). These are records that have already ended their 
workflow or hit terminal status. 

 Transient Records Funded at CBS Level: Sum of all 
records that are funded at CBS Level. These are records 
that are currently in process. 

 Transient Records Funded at Project Level: Sum of all 
records that are funded at project or shell level. These are 
records that are currently in process. 

 Transient Records Funded at Commitment Level: Sum of 
all in-process records that are funded at the commitment 
level. 

 Fund1 to Fund25: Generic data sources that can be used 
for manual entry or formula columns to make the values 
reportable. 

Logical Sources 

Logical sources include the following data sources. 

 Company Funding: This is commonly the column to use to 
manually enter the starting amount for each fund. 

 Company Fund1 to Fund25: Generic data sources that can 
be used for manual entry or formula columns to make the 
values reportable. 

Entry Method 

The following options are applicable for logical data sources. 

 Manual Entry: Choose Direct Entry into Cell to allow entry 
directly into the cell, or Line Item Content to allow data entry 
through a line item window. 

 Formula: Values are calculated based on a specified 
formula entered for the column. Formulas can include the 
values of other columns. Click the Create button to create 
the formula. 

Data Format 

The following options are applicable for Manual Entry or 
Formula columns. 

 Currency: right-aligns column contents and includes a 
currency symbol, a thousands separator and two decimal 
places 

 Percentage: right-aligns the contents and includes a 
percentage symbol 

Display Mode 

The following options refer to whether the column is displayed 
on the sheet. 

 Show: Choose this option to allow users to view this column.

 Hide: Hidden columns are active but not displayed and can 
be accessed by users with "create" permission on the 
funding sheet. 
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Total 

These options determine what will appear in the "Total" (bottom) 
row for the column: 

 Blank: The total of this column is not applicable and will not 
appear on the sheet. Choose this column for percentage 
columns and other columns where it does not make sense to 
display the sum total. 

 Sum of All Rows: The sum total of the column values is 
displayed. 

 Use Formula Definition: For formula columns; the formula 
will be applied to the "Total" row in the same way it is 
applied to other rows in the column. 

Column Position 
After 

The new column will be inserted after the column selected. 

Note: As funding is consumed from individual funds, the new balance 
will not be reflected on the company funding sheet by default. You can 
track your fund balances by adding columns to roll up funding 
assignments from business process or by manual assignments from the 
project/shell funding sheets, and commitment funding sheets if used, 
then adding a formula column to keep track of the balance. You can also 
use the rules engine to create a rule to keep this balance from going less 
than zero (or another amount). 

Add rows (Funds) to the company funding sheet 

Each row of a Company Funding Sheet represents an individual source of funds. The funds 
defined here are used in individual project or shell funding sheets. 

Note: Once fund assignments have been made against them on project 
or shell funding sheets, you will not be able to edit company funding 
sheet rows. 

To add company funding sheet rows (funds) 

1) From the Company Funding Sheet, click Rows. 

2) Click Add Row. The Fund Details window opens. If you have imported a Fund Attribute 
form, this will be displayed as the Fund Details window. 

3) Complete the Fund Details window. 

The table below describes the fields on the default Fund Details window. If your company 
has imported a Fund Attribute form, the fields you see may differ greatly. 



Setting up the Cost Manager

421

4) Click OK. The fund appears as a row on the Funding Sheet in alphabetical order. 

To edit a row 

1) From the Funding Sheet, click on the Rows button. 

2) Click on a row title. The Fund Detail window opens. 

3) Make changes and click OK. 

To delete a row 

1) From the Funding Sheet, click on the Rows button. 

2) Click the selection box next to the row or rows to be deleted. 

3) Click the Delete Rows button. The selected rows will be deleted. 

4) Click Close to close the window and refresh the Funding Sheet window. 
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Creating a Project or Shell Funding Sheet Template 

Funding templates are created and setup in the Templates node, and are used to create 
individual project or shell funding sheets. They can also be used to create a funding sheet in a 
project or shell template. 

Setting up the funding template consists of adding columns, which correspond to the data 
sources (e.g., business process transactions, formulas, values you enter manually, etc.) that you 
wish to track for each funding source. It can also include adding rows (funds). 

You can specify fund assignment rules in the template or individual project/shell funding sheets. 
See Defining Fund Assignment Options for Project/Shell Funding (on page 428). 

To create a new funding sheet template 

1) In Administration mode, go to the Company Workspace tab and click Templates > 
Funding > Funding Sheet in the left Navigator. 

2) Click the New button. The Properties window opens. 

3) Enter a Title and Description. 

4) For Display Mode, choose Flat (no indenting of rows) or Tree (allows indented, nested 
rows). 

5) Click OK. The template is listed in the log. 

After creating the funding template, you can open the sheet and define columns and add 
funds (rows). 

Add a column to the funding template (or project/shell funding sheet) 

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets 
created in project or shell templates. 

Funding columns specify the data sources (business process transactions, formulas, values 
entered manually, etc.) that will be displayed on the project or shell funding sheet. Default 
columns on funding sheet are Fund Code and Fund Name. If a Fund Attribute form has been 
imported, in which the label of Fund Code data element and Fund Name data element were 
modified, then the new labels will be displayed as column headers. 

Note: Some project funding columns require assignment information at 
the project level and cannot be created in the template (for example, 
Consumed Funds, CBS Funding). 

To add a funding column 

1) Open the funding sheet or template: 

2) Open the funding template and click the Columns button. The Column Log window opens, 
displaying the list of existing columns. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window as described in the table below. 
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5) Click OK to add the new column. 

In this field: Do this: 

Name 

The name you choose will appear as the column header. You may 
manually enter a column name, or, if you leave the Name field 
blank, the selection you make in the Datasource field will 
automatically populate the Name field. 

Datasource 

All columns must be associated with a data source. The data 
source that you choose will determine which of the following 
options are available. The types of Data sources available are: 

Single Sources: These values roll up from other sources. These 
include cost type business processes, some pre-defined cost 
columns. 

Logical Sources: These include user-defined Manual Entry or 
Formula columns. 

Single Source 

Data sources that contain funding sources and consumption 
information; that is, Fund subtype of Cost business processes, 
which allocate funding, Spends business processes that consume 
funding, and Commit business processes that trigger commitment 
funding, if used. 

 Business Processes: List of cost-type business processes 
that include funding data definitions. 

 Manual Funding by CBS: Sum of all funds that are allocated 
at CBS level manually. 

 Commitment Funding: If commitment funding is used, this 
datasource tracks funds that are allocated across base commit 
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and change commit business process records enabled for 
commitment funding. Reflects sum of Funding Across All 
Funds and Funding By Discrete Funds datasources on 
commitment funding sheets. Click the link to view cell details. 

 Records Funded at Project/Shell Level: Sum of all records 
that are funded at project or shell level. These are records that 
have already ended their workflow or hit terminal status. 

 Records Funded at CBS Level: Sum of all records that are 
funded at CBS Level. These are records that have already 
ended their workflow or hit terminal status. 

 Records Funded at Commitment Level: Sum of all records 
that are funded at the commitment level (spends BPs that are 
linked to base commits enabled for commitment funding). 
These are records that have already ended their workflow or hit 
terminal status. 

 Transient Records Funded at CBS Level: Sum of all records 
that are funded at CBS Level. These are records that are 
currently in process. 

 Transient Records Funded at Project Level: Sum of all 
records that are funded at project or shell level. These are 
records that are currently in process. 

 Transient Records Funded at Commitment Level: Sum of 
all in-process records that are funded at the commitment level. 

Logical Sources 

Logical sources include: 

 Project/Shell Funding: Sum of all funding sources at project 
or shell level. The information that gets rolled up to this data 
source is dependent on project or shell Funding Sheet setup 
for each project or shell. 

 CBS Funding: Sum of all funding sources at CBS level. The 
information that gets rolled up to this data source is dependent 
on project or shell Funding Sheet setup for each project or 
shell. 

 Manual Funding by Project/Shell: Sum of all funds that are 
allocated at project or shell level manually. 

 Fund1 to Fund25: Generic data sources that can be used for 
manual entry columns to make the values reportable. 

Entry Method 

This is applicable for logical data sources. 

Manual Entry: Choose Direct Entry into Cell to allow entry directly 
into the cell, or Line Item Content to allow data entry through a line 
item window. 

Formula: Values are calculated based on a specified formula 
entered for the column. Formulas can include the values of other 
columns. Click the Create button to create the formula. 

Data Format 
Applicable for Manual Entry or Formula columns: 

Currency: right-aligns column contents and includes a currency 
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symbol, a thousands separator and two decimal places 

Percentage: right-aligns the contents and includes a percentage 
symbol 

Display Mode 

Refers to whether the column is displayed on the sheet. 

Show: This is the default choice. This indicates that column will 
display by default on the funding sheet to all users with at least 
"view" permission for the funding sheet. 

Hide: Hidden columns are active but not displayed and can be 
accessed by users with "create" permission on the funding sheet. 

Total 

Determines what will display in the "Total" (bottom) row for the 
column: 

Blank: The total of this column is not applicable and will not 
display on the cost sheet. Choose this column for percentage 
columns and other columns where it does not make sense to 
display the sum total. 

Sum of All Rows: The sum total of the column values is 
displayed. 

Use Formula Definition: For formula columns; the formula will be 
applied to the "Total" row in the same way it is applied to other 
rows in the column. 

Column Position 
After 

The new column will be inserted after the column selected 

Add a funding column to project or shell cost sheet 

Cost sheets can show fund related information as part of Funding Manager solution. The 
following section discusses funding columns you can add to the project or shell cost sheet. 

To add a funding column to the Project/Shell Cost Sheet 

1) Open the Cost Sheet cost sheet and click the Columns button. The Column Log window 
opens. 

2) Click New. The Column Properties window opens. 

3) Complete the Properties window. For Data Source, choose from the following: 

 Single sources: Data sources that contain fund related information: 

 Funded Records: Sum of all Records that are funded at CBS Level. 

 Unfunded Records: Sum of all Records that are not funded at CBS Level. 

 Manual Funding by CBS Level: Sum of all funding sources that are allocated at 
CBS level manually. 

 Logical sources: Data sources that are available at project or shell level: 

 CBS Funding: Sum of all funding sources at CBS level. The information that gets 
rolled up to this data source is dependent on Project/Shell Funding Sheet setup for 
each project or shell. 
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Note: You cannot select this data source unless a funding source is 
selected under "Processes Contributing Assignable Funds" for CBS 
level. This is located under Project Funding sheet > Properties > 
Assignment Tab. 

4) Click OK to add the new funding column to the project or shell cost sheet. 

To edit a column 

1) From the Columns Log window, select a column and click Open. The Column Properties 
window opens. 

2) Make edits as necessary and click OK. 

Note: Changing entry methods. Although it is possible to change the 
entry methods for a column (for example, from "Line item content" to 
"Direct entry into cell"), use caution when doing so if you have already 
entered values in the column cells. For example, if you change from line 
item entry to direct cell entry, the Amount value shown in the cell will 
appear correctly, but will be an editable direct entry amount, and detailed 
line item information will be lost. 

To move a column 

From the Columns Log window, select a column to move, then click Move Up (Left) or Move 
Down (Right). The order in which the columns appear in the Log window is the order (from left 
to right) that they appear on the sheet. 

To delete a column 

Select a column from the Columns Log and click Open to open the Column Properties window, 
and then click Delete. The column will be deleted. 

Note: If the column is being used in a formula in another column, you 
must remove the column from the formula before you can delete it.  If 
the column contains a cell with line item data, you must first remove 
each line item before it can be deleted 

Add rows to the funding template (or project/shell funding sheet) 

These procedures are applicable to funding sheet templates, funding sheets, and funding sheets 
created in project or shell templates. 

Each row of a project or shell funding sheet represents an individual source of funds. The funds 
added here are funds that are active under the company funding sheet. 
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Note: Once fund assignments have been made against them, you will 
not be able to edit project or shell funding sheet rows. To view the status 
of a fund, click the Fund Status button on the tool bar. 

To add rows (funds) to the funding template or project/shell funding sheet) 

1) Open the funding sheet or template. 

2) Click Rows, and then click Add Row. The Fund Detail window opens. If you have imported 
a Fund Attribute form, a customized Fund Detail window will open. 

3) Select a fund from the fund picker (or Fund Source field). 

You can search for a specific fund in the fund picker by clicking the Find button and opening 
the Find form. Enter search criteria and click Search. This limits the number of funds that are 
displayed to those that match the search criteria. 

4) You can search for a specific fund in the fund picker: 

a. Click the Find button. The Find window opens. The window that opens will depend on the 
design in uDesigner. 

 If an attribute form is not defined, the default Find window will allow you to search 
by Fund Code or Fund Name. 

 If an attribute form is defined, the Find window can also be designed in uDesigner, 
and you may have additional fields to search by. 

b. Enter search criteria and click Search. This limits the number of funds that are displayed 
to those that match the search criteria. 

5) Click OK. The fund appears as a row on the Funding Sheet. Funds are displayed in 
alphabetical order on funding sheet. 

6) To view fund details click on a fund under fund code column. If you import a Fund Attribute 
form then you will see customized detail form instead of a generic fund detail form. 

Creating a Project/Shell Funding Sheet 

The Project/Shell Funding Sheet tracks how funding is being allocated and consumed at the 
project or shell level. Project or shell funding sheets work in conjunction with the company 
funding sheet. Allocating funding sources at project or shell level can be done manually, or 
through a business processes. 

A Funding Template and Company Funding Sheet must be complete before you can create a 
project or shell Funding Sheet. 

To create the project or shell funding sheet 

1) In User Mode, open the project and click Cost Manager>Funding in the left Navigator. The 
Project/Shell Funding Log opens. 

2) Click New. The Select Template window opens. 

3) Select a template and click OK. Click Yes to confirm. The Project/Shell Funding Sheet 
displays in the log. You can use the funding sheet as it is or set it up to meet the needs of 
the project or shell. 
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Add columns to the project/shell funding sheet 

Columns are added to a Project/Shell Funding Sheet in the same way as they are added to a 
Funding Template. See Add a column to the funding template (or project/shell funding 
sheet) (on page 422). 

Add project or shell funds (rows) 

Rows are added to a Project/Shell Funding Sheet in the same way as they are added to a 
funding template. Add rows to the funding template (or project/shell funding sheet) (on 
page 426) 

To edit a row 

1) From the Funding Sheet, click the Rows button. 

2) Click a row title. The Fund Detail window opens. 

3) Make changes and click OK. 

To delete a row 

1) From the Funding Sheet, click on the Rows button. 

2) Click the selection box next to the row or rows to be deleted. 

3) Click the Delete Rows button. The selected rows will be deleted. 

4) Click Close to close the window and refresh the funding sheet window. 

Defining Fund Assignment Options for Project/Shell Funding 

The following options are available as part of assignment rules at project or shell level and CBS 
level. These can be defined in a funding template, or individual project/shell funding sheets. 

Project and CBS Level: Specify the sources of funds for this project or shell, either manual or 
via fund appropriation business processes. 

Assignment Levels and Rules: For each funding business process (and each status) that has 
been set up for the project or shell, you specify manual, Auto Order, or Auto Ratio: 

For details, see the following procedures. 

Set up funding assignment options 

After you create a project or shell funding sheet, you can set up assignment options. This 
includes specifying whether manual assignment is allowed; defining the business processes that 
can be used to assign funds to project or shells or to specific CBS codes; and defining 
assignment levels. 

Project Level and CBS Level: Specify how funds can be added for this project or shell. This 
can be Manual (appropriate funds manually from the company funding sheet, and/or through 
funding appropriation business processes that appropriate company funds for the project or 
shell. 
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You can define funding appropriations at the project level (not associated with specific CBS 
codes), and at the CBS level (funding is specified per CBS code). You can "mix and match" for 
each project, with some business processes using project level funding, and others CBS level. 
Manual fund appropriations can be done at both levels. 

Assignment Levels and Rules: For each funding business process that has been set up for the 
project or shell, you specify manual, Auto Order, or Auto Ratio. You also choose to assign funds 
at the Project Level (funding is consumed based on the total of the spends business process, 
providing greater flexibility for fund assignment), or CBS Level (funding is consumed per line 
item of a spends business process, which provides greater control over how funds are spent on 
each item.) 

 Manual: Funds can be manually assigned. As spends business processes (e.g., invoices or 
payment applications) are routed and reach specified statuses, the amounts to be funded 
are collected under the Unassigned total on the funding sheet. Funds are assigned manually 
to these spends records. 

 Auto Order: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund order, which is defined on the 
funding sheet by clicking the Fund Assignment Order button. When funds are consumed on 
one fund, then the next funding source is used for funding. Once all funds are consumed, 
remaining spends are collected under Unassigned. 

 Auto Ratio: Funds are assigned automatically when a spends business process reaches a 
specified status. Funds are assigned based on the fund ratio, which is automatically 
calculated based on current fund levels. Once all funds are consumed, remaining spends are 
collected under Unassigned. 

Note: Be sure you have imported and set up any business processes 
you will be using for fund appropriation and assignment in the project or 
shell before setting assignment rules 

To set up fund assignment rules 

1) Open the project or shell funding sheet. 

2) Select the template in the log and click the Properties button. 

3) Click the Assignment tab. 

4) Complete the window as described in the following table. 

5) Click OK. 

In this field: Do this: 

Funding 
Assignment 

Select the Funding Assignments sources. The sources can be at the 
CBS level, where funds are assigned to specific CBS codes, or project 
or shell level, which allows project or shell level funding without 
assigning funds to specific CBS codes. 

Project/Shell 
Level 

Click Add to add project or shell level sources. Options include: 

Manual: Allows manual entry of project or shell fund assignments on the 
sheet 

Business Processes: Any cost type business process that is created 
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with sub-type Line Items with Fund Code and Classification as Generic. 

CBS Level 

Click Add to add CBS level sources. Options include: 

Manual: Allows manual entry of CBS level fund assignments on the 
sheet 

Business Processes: Any cost type business process that is created 
with sub-type Line Items with both CBS Code and Fund Code and 
Classification as Generic. 

Assignment 
Levels 

Allows you to set fund assignment rule for each spend-type business 
process that is configured in your project or shell. The assignment level 
will only show those spend type business processes that consume 
funds. This option is available while designing spend type business 
process in uDesigner. 

Assignment 
Rules 

Click the drop-down list and select a project- or shell-level or CBS-level 
rule. 

Project /Shell Level:

Manual (Assign by BP Record Total): All spends are collected as 
Unassigned. These spends should be assigned manually to one or 
more funds at project or shell record Level. 

Manual (Assign by BP Line Item): All spends are collected as 
Unassigned. These spends should be assigned manually to one or 
more funds at the project or shell line item. 

Auto Order (Assign by BP Record Total): Funding sources are arranged 
in a prescribed order, and spend are assigned in that order. The 
assignment order is defined under project or shell Funding Sheet 
Fund Assignment Order  Fund Assignment Order Window. 

Auto Order (Assign by BP Line Item): Funding sources are arranged in a 
prescribed order, and spend are assigned in that order at line item level. 
The assignment order is defined under project or shell Funding Sheet 
Fund Assignment Order  Fund Assignment Order Window. 

Auto Ratio (Assign by BP Record Total): Funding sources are 
proportionally consumed until fully depleted. The fund level itself 
automatically defines the ratio. Once the funds are consumed, 
remaining spends are collected as Unassigned. 

Auto Ratio (Assign by BP Line Item): Funding sources are proportionally 
consumed until fully depleted at line item level. The fund level itself 
automatically defines the ratio. Once the funds are consumed, 
remaining spends are collected as Unassigned. 

CBS Level:

Manual: All spends are collected as Unassigned, and are manually 
assigned to one or more funds at CBS level. 

Auto Order: Funding sources assigned to that CBS are arranged in a 
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prescribed order, and spends are assigned in that order. Once all funds 
are consumed, remaining spends are collected as Unassigned. Fund 
Assignment Order for CBS can be defined under Cost Sheet>Fund 
Assignment Order>Fund Assignment Order Window. 

Auto Ratio: Funding sources assigned to that CBS are proportionally 
consumed until fully depleted. The fund level itself automatically defines 
the ratio. Once all funds are consumed, remaining spends are collected 
as Unassigned. 

SOV Auto Order: This option indicates that the assignment should be at 
SOV level using Auto order option. The order assignment will be defined 
under SOV>Fund Assignment Window. 

SOV Auto Ratio: This option indicates that the assignment should be at 
SOV level using Auto ratio option. The ratio will be defined under 
SOV>Fund Assignment Window. 

Set fund assignment status and order 

You can control whether a fund is available when assigning funds to spend by activating or 
deactivating the fund at the project or shell level. Fund assignment order is required if you 
decide to consume funds automatically. You can also view the Fund order. This will be the order 
that will be used while assigning funds with Auto Order option. 

Funds can be automatically consumed at project or shell level by following fund order defined 
under Fund Assignment Order window on project or shell Funding Sheet. 

To set the fund assignment status and assignment order 

1) Open the project or shell Funding Sheet. 

2) Click Fund Assignment Order button on the toolbar. The Fund Assignment Order window 
opens showing whether funds are active or inactive. 

3) Select a fund in the table, and click Activate or Deactivate. Deactivating a fund prevents it 
from being available when assigning funds to spend. 

4) If you want to change the assignment order, select a fund and click Move Up or Move 
Down. 

5) Click Close to exit the window. 

Set fund assignment order at the CBS level 

The Unassigned (CBS Level) link on the Project/Shell Funding Sheet displays the total of funds 
at the CBS level. Funds can be automatically consumed at CBS level by following fund order 
defined for each CBS Code from the Fund Assignment Order window on the Project/Shell Cost 
Sheet. 

To set fund assignment order at CBS Level 

1) Open the Project/Shell Cost Sheet. 
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2) Click the Fund Assignment Order button on the toolbar. The Fund Assignment Order 
window opens. 

3) Select a CBS code from the upper pane. A list of funds that are available for this CBS will be 
displayed on the bottom pane. 

The bottom pane will also display assignment status of funds. You can modify assignment 
status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with 
Inactive status will not be used as part of consumption process. 

4) Select a fund and click Move Up or Move Down button to change fund order. 

5) If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

Set fund assignment order at SOV level 

Funds can be automatically consumed at the SOV level by following fund order or fund ratio 
defined for each CBS under Fund Assignment Order window on SOV Sheet. You have ability to 
defined order or ratio for each SOV. 

Note: Fund assignment details can be set on the SOV sheet when you 
are doing project/shell level funding as well as commitment level funding. 
The following procedure discusses how to do SOV Auto Order at the 
project/shell level. If the base commit that created the SOV has been 
enabled for commitment funding, then fund assignment is done at the 
commitment level. 

To set fund assignment order at SOV Level: For CBS—SOV Auto Order 

1) Open the SOV Sheet. 

2) Click the Fund Assignment button on the toolbar. The Fund Assignment window opens. 
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You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that 
you choose for spend under the Project/Shell Funding Sheet > Properties > Assignment Tab. 

3) Select a CBS code from the upper pane. 

4) Select a fund from the list and click OK. 

The bottom pane will also display assignment status of funds. You can modify assignment 
status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with 
Inactive status will not be used as part of consumption process. 

5) Select a fund and click Move Up or Move Down button to change fund order. 

6) If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

7) To add a fund, click the Add button. The Add Funds window lists the funds that are available 
for the selected CBS Code. Select a fund from the list and click OK. 

To set fund assignment order and Ratio at SOV Level: For CBS—SOV Auto Ratio 

1) Open the SOV Sheet. 
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2) Click the Fund Assignment button on the toolbar. The Fund Assignment Order window 
opens. 

3) You can set Fund Order or Fund Ratio. This is dependent upon the Assignment Rule that 
you choose for spend under Project/Shell Funding Sheet > Properties > Assignment Tab. 

4) Select a CBS code from the upper pane. A list of funds that are available for this CBS will be 
displayed on the bottom pane. 

The bottom pane will also display assignment status of funds. You can modify assignment 
status of a fund from Project Funding Sheet > Fund Assignment Order window. Funds with 
Inactive status will not be used as part of consumption process. 

5) Select a fund and click Move Up or Move Down button to change fund order. 

6) If you have defined Breakdowns for a CBS code, then select breakdown to view funds. 

7) To add a fund, click the Add button. The Add Funds window lists the funds that are available 
for the selected CBS Code. Select a fund from the list and click OK. 

8) Select a fund and enter a % value. 

Creating Commitment Funding Sheet Templates 

Commitment Funding Sheet templates are created and set up in the Templates node, and are 
used to create the commitment funding sheet structure in a project or shell (or in a project or 
shell template). This structure is then used when sheets are created for individual base commit 
records. 

Setting up the commitment funding template consists of adding columns, which correspond to 
the data sources (e.g., business process transactions, formulas, values you enter manually, etc.) 
that you wish to track for each funding source. 

You can specify fund assignment rules in the template, structure or individual commitment 
funding sheets. 

To create a new commitment funding sheet template 

1) In Administration mode, go to the Company Workspace tab and click Templates > 
Funding > Commitment Funding Sheet in the left Navigator. 

2) Click the New button. The Properties window opens. 

3) Enter a Title and Description. 

4) Click OK. The template is listed in the log. 

After creating the funding template, you can open the sheet and define columns. 

Add and Manage commitment funding sheet columns 

These procedures are applicable to commitment funding sheet templates, commitment funding 
structures created in a project or shell, commitment funding sheet structures created in project or 
shell templates, or individual commitment funding sheets. 

Funding columns specify the data sources (business process transactions, formulas, values 
entered manually, etc.) that will be displayed on commitment funding sheet. 
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To add a column to a commitment funding template, structure or sheet 

1) Open the commitment funding sheet, template or structure. 

2) Click the Columns button. The Column Log window opens, displaying the list of existing 
columns. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window as described in the following table. 

5) Click OK to add the new column. 

In this field: Do this: 

Name 

The name you choose will appear as the column header. You 
may manually enter a column name, or, if you leave the Name 
field blank, the selection you make in the Datasource field will 
automatically populate the Name field. 

Datasource 

All columns must be associated with a data source. 

Note: In these datasource definitions, the terms All Funds and 
Discrete Fund refer to the fund assignment options. These 
options determine how the SOV lines (and therefore, the 
commit lines) will be funded, either automatically or manually 
from the entire list of funds available to the commit, or by one 
specific fund. (See "Define commitment fund assignment 
details (on page 439)). 

The data sources available for commitment funding sheets are:

 Funding Across All Funds: Use this column to enter (or 
calculate) the amount of each fund to allocate for this base 
commit record. The rows on the sheet are the funds that 
will be used to fund the commit. The value entered here will 
be the fund amount available for all commit lines that have 
"All Funds" as assignment. This can be a manual entry 
column, or a formula that uses another manual entry 
column as the basis of the formula. 

 Funding By Discrete Fund: This column displays the sum 
total of all the line items of base and change commits that 
are funded by a specific (or "discrete") fund. This value can 
be used to determine the fund balance during consumption.

 Records Funded Across All Funds: Reflects the total of 
funds consumed from records that are funded based on All 
Funds, whether funding is done manually or automatically. 

 Records Funded By Discrete Fund: Displays the total of 
funds consumed from records that are funded based on a 
discrete fund, whether funding is done manually or 
automatically. 

 Fund Balance Across All Funds: This column tracks the 
fund balance across all funds. The formula used is 
(Funding Across All Funds) - (Records Funded By All 
Funds). 
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 Fund Balance By Discrete Fund: This column tracks the 
fund balance by specific fund chosen in the Fund 
Assignment window. The formula used is (Funding By 
Discrete Fund) - (Records Funded By Discrete Fund). 

 Funding Ratio Across All Funds: The value of this 
column is calculated automatically. It reflects the % ratio to 
use when performing fund assignment ratio during 
consumption. The formula is (Fund Balance Across All 
Funds Per Fund) / Total of Fund Balance Across All 
Funds). 

 Commitment Funding 1 to 25: Numeric data sources that 
are available to use to enter values manually or create 
formulas based on other columns. These are reportable via 
user-defined reports. 

Entry Method 

Choose one (the options that are available are dependent on 
the data source chosen): 

 Manual Entry: Users enter values directly on the sheet. 

 Formula: Values are calculated using the entered formula. 
Formulas can include the values of other columns. Click 
the Create button to create the formula. 

Display Mode 

This controls the display of numeric column data. 

 Show as percentage. Data is displayed as % 

 Decimal places. Choose 2 to 8 

 Use 1000 Separator. Select checkbox to include a comma 
separator 

 Negative Number Format. Choose parentheses or minus 
sign 

Total 

Determines what will display in the "Total" (bottom) row for the 
column: 

 Blank: The total of this column is not applicable and will not 
display on the cost sheet. Choose this column for 
percentage columns and other columns where it does not 
make sense to display the sum total. 

 Sum of All Rows: The sum total of the column values is 
displayed. 

 Use Formula Definition: For formula columns; the formula 
will be applied to the "Total" row in the same way it is 
applied to other rows in the column. 

Column Position After The new column will be inserted after the column selected 

To create a formula column 

1) In the Column Properties window, choose Formula as the Entry Method, then click the 
Create button. The Formula Creation window opens. 

2) Enter the first value in the formula: 
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To enter numerical values into the formula, click the number keys on the on-screen keypad. 
(Include parentheses, % or decimal point as necessary.) 

To add a column value into the formula, select it from the list in the left pane, then click the 
Select button (or double-click it). Options include: 

 Columns: These are columns that have been added to the sheet. The value in the 
corresponding row will be used in the formula. 

 Total Elements: These are the columns on the sheet that display a total (either the sum 
or formula definition, as defined in the Total option for that column). The value of the 
Total for that column will be used in the formula. 

 An additional default Total Element is also available: Commitment Total Funded By All 
Funds. It is the sum of all commit line items (base and change commits) that have the 
assignment option "All Funds" (as selected for each commit line on the Fund Assignment 
window). 

As you build the formula, it appears in the Formula box in the upper right portion of the 
window. 

3) Click on the appropriate operator: add, subtract, multiply, or divide. 

4) Continue to alternate between choosing values and operators to add to the formula. 

5) You may click Undo at any time to undo the last action. Click the Clear All button to clear 
the entire formula. 

6) When the formula is complete, click OK to save your formula and return to the Column 
Properties window. 

7) If you need to change the formula after creating it, click the Modify button (next to the 
Formula option). Clear the old formula first (click Undo or Clear All), then re-enter it. 

To create a column by copying an existing column 

1) In the Column log, select a column and click Copy. The Column Properties window opens. 

2) Make changes as necessary for the new column. You must change at least the data source. 

To edit a column 

From the Columns Log window, select a column and click Open. The Column Properties window 
opens. 

Make edits as necessary and click OK. 

Note: Although it is possible to change the entry methods for a column, 
use caution when doing so. For example, if you change the entry method 
from Manual Entry to Formula, any existing values you have entered in 
that column will be replaced with the formula. Some column properties 
for some system data sources cannot be modified. 

To move a column 

From the Columns Log window, select a column to move, then click Move Up (Left) or Move 
Down (Right). The order in which the columns appear in the Log window is the order (from left to 
right) that they appear on the sheet. 
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To delete a column 

Select a column from the Columns Log and click Delete. The column will be deleted. 

Note: If the column is being used in a formula in another column, you 
must remove the column from the formula before you can delete it. 

Defining Fund Assignment Options for Commitment Funding 

Fund Assignment refers to how funds are to be consumed as spends type business processes 
(e.g., invoices and payment applications) come in against the base commit that is being funded. 

The first step in defining the Assignment rules -- whether funding is to be done manually or by 
auto ratio. The assignment levels and rules are defined on the Assignments tab in the Properties 
window of the commitment funding sheet. This step is mandatory in order to do commitment 
level funding. 

The Assignment tab lists the spends business processes that are linked to base commits 
enabled for commitment level funding. For each listed business process, you define how fund 
assignment will be done when these spends records come in against the base commit (either 
manually, or automatically by fund ratio). 

You can define these assignment rules on the commitment funding template. When you create a 
commitment funding structure in a project or shell, these assignment rules will be copied to it, 
and when you create new sheets from the structure, they will be copied to the sheets. If you 
need to, you can modify these rules on individual structures and sheets. 

The next step is optional: define Fund Assignment details per SOV line; that is, define whether a 
specific fund must be used to fund a particular line on the commit. This allows you to provide 
details about fund assignment or consumption for each line on the base commit or any change 
commits. You access the Fund Assignment window by clicking the Fund Assignment button on 
the commitment funding sheet or SOV sheet associated with the base commit. 

If you do not define any assignment options in this window, then All Funds is the default 
selection. This means that all funds that have been allocated to the base commit on the 
commitment funding sheet will be available for funding each line of the spends business process 
created against it (either manually or by auto ratio, as defined by the assignment rules). 

Fund assignment on these lines is tracked by commitment funding sheet columns using data 
sources that for records or fund balance "across all funds." Add and Manage commitment 
funding sheet columns (on page 434). 

Sometimes, you may need to specify that a specific fund be used to fund a specific CBS code or 
SOV line. For these lines, you can select a specific fund (or "discrete fund"). Fund assignment is 
then tracked by commitment funding sheet columns using data sources for records or fund 
balance "by discrete fund.") 

For details, see the following procedures. 
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Define commitment fund assignment rules 

The fund assignment rules define how assignment will be done on the spends business 
processes created against the base commit being funded: either manually or automatically by 
fund ratio. 

Funding assignment levels and rules can be defined in the commitment funding template, 
structure, or individual sheets. It is easiest to set them once -- in the template -- and have them 
carried forward into the structures and sheets created from it. If necessary, these options can be 
modified later for individual structures and sheets. These rules must be defined on the 
commitment funding sheet in order to do commitment level funding. 

To set up commitment funding assignment rules 

1) Open the Properties window of the commitment funding template, structure or sheet. (From 
the File menu, choose Properties.) 

2) Click the Assignment tab. The list displays all General Spends and Payment Application 
Business Processes that are linked to a Base Commits that has been enabled for 
commitment funding and have been designed to consume fund according to the design in 
uDesigner). 

3) For each listed spends business process, click the Assignment Rule drop-down and select 
one of the following: 

 Commitment Level - Manual: Funds are manually assigned at runtime. As spends 
business processes are routed and reach specified status, the amounts to be funded are 
collected under the Unassigned total on the commitment funding sheet, similar to 
project/shell level manual funding. You can then select each line of the spends BP and 
assign funds at runtime. Consumed funds roll up to the commitment funding sheet and 
the project funding sheet. 

 Commitment Level - Auto Ratio: Funds are assigned automatically when the spends 
business process reaches a specified status. Funds are assigned based on the fund 
ratio, which is calculated based on the fund levels (using the value in the column of data 
source Funding Ratio Across All Funds on the commitment funding sheet), and is 
managed and tracked on the commitment funding sheet. If all funds are consumed, any 
remaining spends amounts are collected under Unassigned. 

4) Click OK. 

Define commitment fund assignment details 

This is an optional step that allows you to provide details about fund assignment or consumption 
for each line on the base commit or any change commits. The commitment funding sheet works 
in conjunction with the SOV sheet in tracking the individual line items on the base commit and 
any change commits. Therefore, you can define details about fund assignment per SOV line. 
This is done on the Fund Assignment window. 

By default, all funds that have been allocated to the base commit on the commitment funding 
sheet will be available for funding each line of the spends business process created against it 
(either manually or by auto ratio, as defined by the assignment rules). 

However, if you need to specify that a specific fund must be used to fund a specific CBS code 
(or SOV line), you can specify a specific (or "discrete") fund to use. 



Unifier Modules Setup Administration Guide

440

You can do fund assignment one row at a time, or several rows at a time (bulk assignment). See 
the following procedures. 

Note: If you do not define fund assignment options, the default will be All 
Funds for each SOV line. 

To set fund assignment details (one row at a time) 

1) Open the commitment funding sheet or the SOV sheet. 

2) Click the Fund Assignment button on the toolbar. The fund assignment grid view displays 
each line that is present on the SOV sheet, including CBS breakdowns. (The Fund 
Assignment button is available on the commitment funding sheet once the SOV has been 
created for the base commit.) 

3) In the Assignment column, click the drop-down and choose the assignment: 

 All Funds: This is the default option. This means that all funds allocated to the 
commitment funding sheet are available to fund the SOV line or breakdown. (This option 
must be used if you are doing assignment by auto-ratio.) 

On the commitment funding sheet at runtime, funding consumption will roll up to the column 
using data source "Funding Across All Funds." 

 <Fund Code-Fund Name>: Each fund that has been allocated to the commitment funding 
sheet will display on the drop-down alphabetically. These are referred to as "discrete 
funds." You can choose to assign a specific fund to an SOV line or breakdown. This 
means that only that fund will be used to fund that line. (You can choose the same fund 
code for multiple lines.) 

On the commitment funding sheet at runtime, funding consumption will roll up to the column 
using data source "Funding By Discrete Fund." 

Note: If an SOV line has a breakdown, then select an assignment for 
each breakdown, not the SOV line itself. 

4) Click Save to save the sheet. 

To set fund assignment on multiple rows on the SOV sheet (bulk assignment) 

1) Open the commitment funding sheet or SOV sheet. 

2) Click the Fund Assignment button on the toolbar. The fund assignment grid view displays 
each line that is present on the SOV sheet, and includes an Assignment column. 

3) Select a row, or multiple rows by holding down the Shift key (to select a range of rows) or 
Ctrl key (to select rows throughout the sheet) while clicking the rows. 

4) Click the Bulk Assignment button. The Bulk Assignment window opens. 

5) Click the Assignment drop-down and choose the assignment. The values listed are the 
same as on the Fund Assignment window for the individual SOV lines. 

6) Click the Update button. 

7) Click Save on the Fund Assignment window to save your changes. 
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Setting Up Schedule of Values (SOV) 

The Schedule of Values (SOV) sheet in Unifier provides a view of all the following information in 
one Sheet:  

 Purchase Orders (Base Commits) 

 Change Orders (Change Commits) 

 Payment History (Pay App) 

Unifier supports the following types of SOV: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

The needed SOV type is designed in uDesigner. 

The data for the SOV sheet comes from the following BP types: 

 Base Commit 

 Change Commit 

The business processes can be designed to create an SOV sheet automatically upon reaching 
the designated step. 

When line items are added to the SOV sheet, the order of line items in the sheet is based on the 
time line that the line items were rolled up from the Base Commit and Change Commit records. 

The data seen in the SOV sheet is based on the order in which the SOV lines were created. You 
can use the numeric column to sort the data based on the number that you specify. 

When a Base Commits Business Process (BP) is approved, it creates a Schedule of Values 
(SOV) sheet. The SOV sheet is the "working document" on which committed monies are 
entered. The committed monies shown on the SOV sheet are rolled up to the Company Cost 
Sheet. 

Note: The Change Commits BPs continue to change or add costs to the 
SOV during the life of the Project/Shell. 

Unifier Schedule of Values (SOV) functionality provides a way to assemble information from 
contract, change order, and invoice/payment BPs into a SOV sheet, streamlining the process of 
invoicing for completed phases of a Project/Shell. 

SOV functionality is available for Cost type BPs in which the "Allow creation of Schedule of 
Values" option is defined, or selected, in the design properties. The BPs can be designed to 
create an SOV sheet automatically upon reaching the designated step. 

You may define one SOV sheet per Commit BP, for example, a Purchase Order or a Contract. 
Rows are automatically populated based on the CBS/Cost/Accounts codes defined in the 
Commit BP. 

Before you can create an SOV: 

 Design Commit type BP in uDesigner and deploy. 

 Configure and set up commit BP. 
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SOV functionality is available with commit BPs, for example a Purchase Order for which the 
Create SOV option is selected in uDesigner. For these BPs, the system automatically 
creates a SOV sheet upon reaching the designated step. There may be one SOV sheet per 
Commit Business Process. Rows are automatically populated based on the CBS/Account 
Codes defined in the Commit BP. 

 Create and set up the Project/Shell Cost sheet. 

How to Set Up SOV 

Before you begin

Base Commits and Change Commits Business Processes must be set up for the Project/Shell. 

Step 1: Create and set up SOV template (General Spends only) 

You can create a template in the Templates log in Administration Mode. If you are using General 
Spends SOV, the structure that will be used for the SOV sheets is created from the template. 

Note: You can define a General Spends SOV structure by copying from 
an SOV template in the Templates log. 

Step 2: Set up SOV Structure (User mode) 

a) SOV Sheets are created, either manually or automatically, from Base Commits, based on 
the structure that is set up in Step 1. 

b) For General Spends SOV, the SOV structure is copied from an SOV template. 

c) For Payment Application SOV and Summary Payment Application SOV, the structure is 
copied from the line item grid structure of the Payment Application Business Process. This 
means that you must first complete the Business Process (BP) setup for the Payment 
Application BP before you can create the structure. 

Step 3: Create SOV Sheets

You can create General Spends, Payment Applications, and Summary Payment Applications 
SOV structures in project templates. 

Creating an SOV Template 

An SOV Template needs to be created and set up before you can create a SOV sheet. SOV 
sheets are created using an SOV Template that defines the columns that will appear on the 
SOV sheet. 

Note: All SOV sheets in a single Project/Shell will use the same template 
structure. 

If an SOV Template does not exist when an SOV sheet is auto-created from a Cost type BP, one 
will be created automatically with the default columns CBS Code and CBS Item and Breakdown 
Data. You can edit this structure as needed, but the default columns are not editable. 

To create a new SOV Template 

1) Go to Company Workspace tab > Admin mode. 
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2) Click Templates > Shells.  

3) Click on a project to expand. 

4) Click shell template > Cost Manager > Schedule of Values > Payment Applications. 

5) From the toolbar, click Update Structure to open the Payment SOV Structure window. 

6) From the menu, click File > Properties to open the Properties window. 

The Properties window has two tabs: General and Options. 

7) In the General tab, enter values in the Name and Description fields. 

8) Click Options tab. 

Use the Options tab to define the labels (Labels block) that will be used for the SOV column 
headings. 

The fields listed in the Labels block are the name of labels that are displayed as column 
headings on the SOV sheet. 

You may change the labels or accept them as is. 

Oracle recommends that you use the same labels as is used in the Cost Template and Cost 
sheets. 

9) Read the following and when finished click Apply and then OK. 

The following explains how to set up the fields in the Properties window, Options tab:  

Field Description 

Item # Applicable to both Company level templates and Project/Shell level 
templates. 

 At the Project/Shell level: Company Workspace tab > Admin mode > 
Templates > shell templates > Cost Manager > Schedule of Values > 
Payment Applications. 

 At the Project/Shell level: Company Workspace tab > Admin mode > 
Templates > shell templates > Cost Manager > Schedule of Values > 
Summary Payment Applications. 

 At the company level: Company Workspace tab > Admin mode > 
Templates > General Spends SOV. 

The Item # field is a system-defined column, with a fixed location on the 
screen, and it is not available in the column structure window. 

You can chance the Item # column name in the SOV properties page. 

Ref Refers to a reference number for the entire commit. (Another example of a 
label for this column is "Order Number.") 

CBS 
Code

This field is not editable. 

CBS 
Item

This field is not editable. 

Breakd
own

The CBS Code Breakdown that you specify in the CBS Detail window for that 
code. 
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Field Description 

Descrip
tion

This label refers to the line item description when the SOV is in line item 
mode. 

The Schedule of Values node, under Project/Shell templates, contains the following sub-nodes: 

 General Spends 

 Payment Applications 

 Summary Payment Applications 

The Summary Payment Applications sub-node lists the Business Processes (BPs) of the 
Summary Payment Applications SOV sheets that have been configured in the template. 

You cannot define the structure if a Base Commits or Change Commits BP of Summary 
Payment Applications SOV sheet is not configured in the template. 

You can define one Summary Payment Applications SOV type template for every Base Commits 
of Summary Payment Applications SOV type BP. 

If the Summary Payment Applications SOV sheet is configured in the Project/Shell templates, 
then you can select columns from the Data Elements that are defined on the Detail form of the 
Summary Payment Applications SOV sheet, and the Base Commits. 

Add SOV Columns 

Columns determine what data is displayed on the SOV sheets. You can add, modify, delete, 
hide/unhide columns on the structure. Any modifications you make on the structure will be 
reflected on all SOV sheets for that project or shell. Columns can be added to the SOV Template 
or Structure. Each column represents a data source. At a minimum, include a column for 
Commits Remaining Balance to enable validation of Spends against the Commits. 

Note: This information is applicable to adding or editing columns in an 
SOV template or structure. 

To add an SOV column 

1) Open the SOV template or structure. 

2) Click the Columns button. The columns log opens. 

 The three default columns (CBS Code, CBS Item, and Breakdown), for the General 
Spends and Payment Applications, are not editable and do not appear in the log. 

 The default columns (Cost Code, Code Name, Cost Line Item Type, and Description), for 
the Summary Payment Applications, are also not editable and do not appear in the log. 

3) Click New. The Column Properties window opens. 

4) Complete the Column Properties window and click OK. 
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In this field: Do this: 

Name 

The name you choose will appear as the column header. You may 
manually enter a column name, or, if you leave the Name field 
blank, the selection you make in the Datasource field will 
automatically populate the Name field. 

Datasource 
All columns must be associated with a data source. The data 
source that you choose will determine which of the following 
options are available: 

Single Sources 
These values roll up from single defined sources, including 
business processes. 

Logical Sources 

The options are: 

 None: allows you to manually configure the column as a 
manual entry or formula column to suit your needs 

 Commits Remaining Balance: Commits Remaining Balance 
is a column on the SOV Template/Structure. It reflects the 
amount of your commits minus the spends, according to a 
formula you define. 

 Scheduled Value: This is a formula column can be used to 
keep track of the remaining SOV balance. (Example formula: 
Base Commit (Approved) + Change Commit (Approved) - 
General Spends Invoice (Approved)) 

Note: Be sure to add a Scheduled Value column to the SOV 
sheet if you will be doing commitment level funding. 

Entry Method 

This is applicable for logical data sources. 

 Manual Entry: Choose Direct Entry into Cell to allow entry 
directly into the cell, or Line Item Content to allow data entry 
through a line item window. 

 Formula: Values are calculated based on a specified formula 
entered for the column. Formulas can include the values of 
other columns. Click the Create button to create the formula. 

Data Format 

Applicable for Manual Entry or Formula columns: 

 Currency: right-aligns column contents and includes a 
currency symbol, a thousands separator and two decimal 
places 

 Percentage: right-aligns the contents and includes a 
percentage symbol 

Display Mode 

Refers to whether the column is displayed on the cost sheet. 

 Show: The default choice. This indicates that column will 
display by default on the cost sheet to all users with at least 
"view" permission for the cost sheet. 

 Hide: Hidden columns are active but not displayed on the cost 
sheet. Hidden columns can be accessed by users with "create" 
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permission on the cost sheet. 

Column Position 
After 

The new column will be inserted after the column selected 

Allow 
sub-breakdown 
with validation 

If this option is selected, the sum of breakdown amounts is 
validated against the CBS summary amount. That is, the sum of 
the breakdowns cannot exceed the amount of the CBS code itself. 

Deleting Schedule of Values 

This section describes how to delete a Schedule of value-based record from a specific shell 
template.  

Note: You can delete a Schedule of value-based record from a specific 
shell template but not from other Projects/Shells that have been created 
using the template. 

In Administration mode: 

1) Go to Company Workspace tab, open the project or shell and in the left navigation pane, 
click Templates > Shells > {Shell Type} > {Shell Template}> Cost Manager > Schedule 
of Values. 

2) Select a schedule of value-based record for deletion. 

3) Click Delete. 

Note: System prompts the user asking to confirm deletion of the 
schedule of value-based record. 

4) Click Yes to delete the cost sheet. 

Setting Up Cash Flow 

Unifier Cash Flow module allows you generate and compare Baseline, Actuals (or "spends"), 
Portfolio, Forecast, Derived, and Custom curves in a project or CBS code-based shell. The 
curve detail levels include: 

 Cash Flow by Project/Shell

You can track the costs associated with an entire Project/Shell over time. 

 Cash Flow by CBS

The creation of a CBS detail curve is similar to cash flow by Project/Shell. Use this option if 
cash flow needs to be tracked at the CBS level as opposed to the Project/Shell level, by 
allowing you plot cash flow curves by specific CBS codes, or all codes, in the Project/Shell. 

 Cash Flow by Summary CBS
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The creation of a Summary CBS detail curve is very similar to cash flow by CBS. Use this 
option if cash flow needs to be tracked by summary CBS codes. In order to select this option, 
the Project/Shell cost sheet must use a tree structure (and therefore has summary CBS 
codes) rather than a flat structure. 

 Cash Flow by Commitment

This option allows you to plot and analyze cash flow data for an entire commit record 
(including base commit, any change commits, and related invoices). You can choose a 
specific business process commitment record within the Project/Shell, such as a purchase 
order or contract, and track the cost information over time. Each commitment record can 
have one baseline curve. 

 Unifier displays Cash Flow curve detail level data in a Cash Flow Worksheet. The cash flow 
curve worksheet can display any number of Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, or Custom curves (based on the same detail level). Depending on curve 
set up you can manually enter manual, pull data automatically from other sources such as 
business processes, cost sheet columns and schedule manager dates (depending on the 
curve type), and compare multiple curves. Here is an example of a cash flow detail curve 
worksheet and curves. 

At runtime, the user can view the cost distribution information by CBS code from a schedule 
sheet see Create a Cash flow curve from a Schedule Sheet. 

To facilitate creation of cash flow curves and roll up of data to program and company cash flow 
worksheets, you can create the following in Administration Mode (Admin mode): 

 Data Sources
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 You create data sources that can be used to create and identify cash flow curves, and 
roll up data to program and company worksheets. You will need to create data sources in 
order to create cash flow curves. 

 Data sources are created based on a Curve Type: Baseline, Forecast, Actual (or 
Spends), Portfolio Budget, Derived, or Custom curves. Each curve type has its own logic 
to address different business requirements. 

 Distribution Profiles

These are optional. Distribution profiles can be applied to cash flow curves to 
automatically distribute cost data across a specified time period. At runtime, you will have 
the option of manually distributing data in the cash flow worksheet, or automatically 
distributing the data using one of these profiles. 

 Company-level Templates

These are also optional. You can create cash flow detail curve templates, which can be 
used to create new curves at runtime within a project and shell; and rollup curve 
templates, which you can use to create program curves to roll up cash flow data from 
projects or shells. 

 Project/Shell-level Templates

You can create cash flow curves within a project template or a CBS-code based shell 
template. These can be used to create new curves in projects or shells; they can also be 
used to "push" out updates to existing curves. Update cash flow curve properties and 
permissions. 

How to Set Up Cash Flow 

Here is an overview of the steps required to set up the cash flow module. 

Note: There are two Cash Flow modules: the module in effect prior to 
the 9.3 release is called Cash Flow (Basic); the module introduced in 9.3 
and discussed here is named Cash Flow. Each module has its own user 
and administration mode permissions. 

Step 1: Grant yourself permissions to configure the cash flow modules.

Step 2: Create custom cash flow data sources. These are used to create curves in projects 
and shells. You also define a color for each data source, which will display as the curve color on 
the cash flow graphs. See Creating Cash Flow Data Sources (on page 451) 

Step 3: Create distribution profiles. These profiles can be used to distribute cost or any value 
over a period of time. (See Distributing Cost Data (on page 453).) 

Step 4: Create cash flow templates. You can create any number of cash flow templates at the 
company level, or create cash flow curves within a project/shell template. Setting up cash flow 
templates is essentially the same as creating the curves manually in a project or shell (or a 
project/shell template), with some exceptions that are mentioned in the setup procedure details. 
You can use company-level and project/shell level templates to quickly create cash flow detail 
curves and rollup curves in projects and shells. See Create a template for a cash flow curve
(on page 456). 
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Step 5: Create cash flow in a project or shell. You can create any number of cash flow curves 
in a project or shell. These can be detail level or rollup curves. You can create them manually, 
by copying an existing curve, or by copying a template, see Cash Flow in the Unifier User Guide. 

Step 6: Create cash flow in a program or company. You can create rollup curves in programs 
and in the company workspace (Company Workspace tab), and roll up cash flow data from 
projects and shells. See Create Roll-up Templates (on page 458) in the Unifier User Guide. 

Step 7: Grant cash flow permissions to users.

Grant Yourself Permissions to Configure Cash Flow 

You must grant permission to yourself, another administrator, or group such as Company 
Administrators, to configure cash flow modules. 

To grant yourself configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, select Administration Mode Access > Standards & Libraries > Cash 
Flow > Data Sources. 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

Unifier adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Modify and View and click OK. Unifier adds the name(s) 
to the Permission Settings window. 

8) Repeat these instructions to grant permission to cash flow Distribution Profiles and cash flow 
Templates. (Give these modules Create permission.) 

9) Click OK. 

Create a Cash Flow Distribution Profile 

You can create new profiles manually or by copying an existing profile. 

To create a distribution profile manually 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Distribution Profiles in 
the left Navigator. The Distribution Profiles log opens. 

The default Distribution Profiles record displays in the log. All profiles are stored in this 
record. 

3) Select Distribution Profiles in the log and click Open (or double-click Distribution Profiles). 
The Edit Distribution Profiles window opens. 

The left side of the window displays the list of the distribution profiles. The right side of the 
window displays a graphical representation of the profile and is used to define it. 
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4) Click the New button. This adds a new row to the Distribution Profiles list. 

5) Enter a unique Name for the profile (up to 30 characters). 

6) Be sure the Active checkbox is selected if you want it to be available for cash flow curves. If 
you deselect this checkbox, the profile will not be available for selection on curves. 

7) Define the distribution profile on the graph by entering values in the Profile % slots. 

By default, when you create a new distribution profile, the graphical display will be a linear 
distribution. (5% is entered into each of the 20 slots: 5% x 20=100%.) You can modify this 
profile by entering a value for each slot for the Profile %. The graph will reflect the values that 
you enter. 

You can enter values with up to two decimal places per slot. Press the Tab key to move one 
slot to the next. The total of all the slots for the Profile % must add up to exactly 100%. 

8) When the distribution profile is complete, click the Save button. 

To create a distribution profile by copying an existing profile 

1) In the Edit Distribution Profiles window, select a profile and click Copy. A new row is added, 
and the selected profile information is copied. 

2) Enter a new Name for the copied profile. Make any changes to the profile values as needed 
and click Save. 

Note: Per design (for example, in a Front Loaded Distribution Profile), if 
the Profile % reaches 100% before the 20th bucket (the zero is 
displayed at this point), and there is still unallocated budget remaining, 
when a Cash Flow Forecasting is linked to the Spends, the remaining 
unallocated budget will not be automatically distributed to the buckets 
with zeros.  

Delete a Distribution Profile 

You can delete distribution profiles as long as they are not currently being used in the system. If 
a distribution profile is being used, you can delete it as long as you replace it with another profile 
first. This is explained in the following procedure. 

To delete a distribution profile 

1) Open the Distribution Profile window. 

2) Select one or more profiles from the list on the left. Press the Ctrl or Shift key to select 
multiple profiles. 

3) Click the Delete button. 

 If the profiles you selected are not currently being used by the system, a warning 
message opens. Confirm that you want to delete the profiles by clicking Yes. 

 If you selected multiple profiles and one or more of them are being used by the system, 
an error message opens displaying the profiles currently in use. 

 To delete a profile that is currently in use, go to Step 4. 

 Close the error window. 
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 You can delete the profiles that are not in use by selecting them again from the 
Distribution Profiles window and clicking Delete. 

4) If you select a single profile that is being used by the system, you will be prompted to replace 
the profile with another profile. 

 The Select a Distribution Profile window opens. 

 Click the Select button and select a new profile from the list. 

 Click OK. The profile being deleted is replaced with the profile selected in this window. 
When the curve using the profile is refreshed at runtime, the new profile will take effect. 

Edit a Distribution Profile 

You can edit a distribution profile. The change will take effect in curves that use the profile the 
next time the curve is refreshed. 

To edit a distribution profile 

1) Open the Distribution profile window. 

2) On the left side of the window, select the distribution profile to edit. 

 You can edit the profile Name. If the profile is used by a curve, the name change will be 
reflected in the curve Properties. 

 You can select or deselect the Active checkbox. Active profiles are available for selection 
when choosing a default profile for auto distribution. Inactive profiles will not show up on 
the selection list. If you inactivate a profile and a curve is already using it, the curve will 
not be affected; it will still use the profile. 

 On the right side of the window, you can change the Profile % values. Change will be 
reflected in curves that use the profile when the curve is refreshed. 

3) Click Save to save the changes. If the profile is being used by one or more curves, the 
profile change will take affect the next time the curves are refreshed. 

Creating Cash Flow Data Sources 

You can add multiple curves to a cash flow worksheet so you can view and compare curves side 
by side. These curves are based on the data sources you add here. 

Each data source is used to identify one of the curves on a worksheet, and therefore can be 
used once per worksheet. You can however, reuse the data sources on different worksheets. 
You can create as many data sources as you need to create cash flow curves. 

When you create a data source, you associate it with a Curve Type. Each curve type has a 
built-in logic when creating the curve using the data source. The curve types are: 

 Baseline

Choose this to create a Baseline curve. You can choose to manually enter the cost data, or 
automatically pull the data from a cost column, such as a Budget. 

 Forecast

Choose this to create a curve that helps forecast future cash flow based on actual spends 
records. 

 Actuals (Spends) 
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Choose this to plot spends data over time. 

 Portfolio Budget

Choose original or shared option to create a Portfolio Budget curve. 

 Derived

Choose to create a Derived curve. 

 Custom

You can create Custom curves that you can use to enter data, or to compare against other 
curves. The setup is similar to the Baseline curves. 

To create a Cash Flow data source 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Data Sources. The Data 
Sources log opens. By default, there is one Data Sources record displayed in the log. All 
data sources are stored in this record. 

3) Select Data Sources in the log and click Open (or double-click Data Sources). The Edit Data 
Source window opens. 

4) Click the Add button. This adds a new row to the window. 

5) Enter a Name for the data source. The name must be unique and not exceed 30 characters. 

Press the Tab key to move to the next field. 

6) Select a Curve Type from the drop-down list: Baseline, Forecast, Actual (or Spends), 
Portfolio Budget, Derived, or Custom curves. 

You can make your selection by clicking the field and selecting from the list, pressing the first 
letter of your selection on the keyboard (e.g., press the B key to select Baseline), or you can 
use the arrow keys on your keyboard to browse the list and make your selection. 

Press Tab to move to the next field. 

7) Select a Color. 

This color will be used on the cash flow graph at runtime when a curve is generated from the 
data source. There are 256 colors (including "0" for black) to choose from. 

Like the Curve Type field, you can click the field and select from the list; press the arrow keys 
to browse the colors; or, if you know the number of the color that you want, you can type it 
directly then press Enter. 

8) To rearrange the data sources, select on the list and click the Move Up or Move Down
buttons. This is the order in which the data sources will be presented when a user creates a 
curve. 

9) Click OK to save and exit the window. 

Delete a Cash Flow Data Source 

You can remove a data source from the list only if it is not being used by any cash flow curves. 

If a data source is in use and you want to delete it, you must first delete any curves using it 
(these are the curves defined in the cash flow Properties window, Curves tab). 
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To delete a cash flow data source 

1) Open the Edit Data Source window. (In Administration Mode, navigate to Standards & 
Libraries > Cash Flow > Data Sources. Double-click Data Sources.) 

2) Select the data source to delete and click the Remove button. The row is deleted. 

3) Click OK to save and exit the window. 

Edit a Cash Flow Data Source 

You can edit the data source color, which changes the color of the curves using the data source. 
You can also change the row order, which changes the order that data sources appear on the 
selection list when creating a new curve. 

Notes: 

 Curve Type is not editable. 

 The data source name can be changed, but use caution when doing 
so. If you rename a data source, the curves that use the data source 
will not recognize the new name, and the data will not be visible on 
the curves. If you change the name back to the original name, the 
data will appear again on the curves.  

To edit a cash flow data source 

1) Open the Cash Flow Data Sources (Cashflow Datasources) window. 

2) You can make changes as necessary, based on the information. 

3) Click OK to save and exit the window. 

Distributing Cost Data 

When you create a cash flow curve, Unifier distributes cost data using the distribution method 
defined in the cash flow curve properties. Distribution can be either manual, or automatic from a 
defined profile. 

In User Mode, Unifier displays commitment curve cost data in the record transaction currency, 
but stores costs in project currency. Currency conversion uses the active exchange rate set. 

 Baseline curves use the exchange rate that was active at the time of record 
creation.

 Actuals curves use the exchange rate that was active at the time the money was 
paid.

 Forecast curves use the exchange rates in effect for each time period over the 
duration of the curve.

If the transaction currency is different from the project currency, you can change the currency 
view between transaction and project currencies. You can only edit data in the transaction 
currency view. If there is a more recent value in the exchange rate table, refreshing the curve will 
refresh the cost data. You will not see the currency menu if the business process record was 
created in the project currency. 
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Manual distribution 

When you select manual distribution in the curve properties, you manually enter the data for 
distribution in the curve details window at run time. Unifier preserves cost distribution and 
duration when you change the From Date (start date) of baseline, custom, and forecast curves 
(when there are no actuals) in project/shell, summary CBS, and CBS detail curves. In other 
words, if you change a cash flow curve to start on a different date then it originally did, Unifier 
shifts the curve along the timeline to reflect the new date and moves the cost data to retain the 
integrity of the curve. Unifier pegs the distribution of cost data to the From Date, rather than the 
end or To Date. Here is how this works when the From Date changes: 

 If the modified curve is the same length as the original curve, the curve shifts along the 
timeline to reflect the new start date and all cost data remains in the curve. 

 If the modified curve is longer than the original curve, the curve will shift along the timeline to 
reflect the new start date, but existing data is not redistributed to the additional time periods. 
Each time period retains its original value and additional columns have values of zero. 

 If the modified curve is shorter than the original curve, then the curve will shift along the 
timeline to reflect the new start date, and existing data is truncated at the new end date. 

Auto by default profile distribution 

A distribution profile lets you predefine the way you want Unifier to distribute cost data in User 
Mode. You can add any number of profiles in the Edit Distribution Profiles window. 

The left side of the window contains: 

 A list of previously created distribution profiles. Initially this list is empty. 

 The Active checkbox, which controls whether the profile is available for selection for a curve. 

The right side of the window contains: 

 Graph: The graph is a graphical representation of the profile % that you enter over the 
duration %. 

 Duration %: These are the x-axis units of the graph. The x-axis starts at zero (0), with 
another 20 slots, equally distributed up to 100%. 

 Profile %: Starts at 0, with 20 remaining slots to enter the profile distribution percent values. 
You will enter incremental values in these slots. The total value of the profile % must add up 
to 100%. You cannot enter negative numbers in these slots. The values you enter will 
determine the shape of the curve, and distribution of the data. 

By default, when you create a new distribution profile, the graphical display will be a linear 
distribution (5% is entered in each of the 20 data slots). 

Following are some distribution profile examples. 
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Cash Flow Curve Templates 

You can create cash flow curve templates that can be used to create cash flow curves in 
projects and CBS-code based shells. If you are using programs or company-level cash flow, you 
can create roll-up curve templates. See Create Roll-up Templates (on page 458). 

Template creation methods are manual or copying an existing one. After creating a template, 
you can set refresh frequency and activate or deactivate curves. 

Creating and setting up a template is essentially the same as setting up the curves manually in a 
project or shell. The major difference is you cannot select individual records in the template; 
these must be chosen from within the projects or shells. See Cash flow curves in the Unifier 
User Guide. 

The detail curve creates a worksheet in the project or shell that can include several curves. You 
can create detail curves and detail curve templates at the following detail levels: 

 Cash flow by project or shell: You can track the costs associated with an entire project or 
shell over time. 

 Cash flow by CBS: The creation of a CBS detail curve is similar to cash flow by 
project/shell. Use this option if cash flow needs to be tracked at the CBS level as opposed to 
the project or shell level, by allowing you plot cash flow curves by specific CBS codes, or all 
codes, in the project or shell. 

 Cash flow by Summary CBS: The creation of a Summary CBS detail curve is very similar 
to cash flow by CBS. Use this option if cash flow needs to be tracked by summary CBS 
codes. In order to select this option, the project/shell cost sheet must use a tree structure -- 
and therefore has summary CBS codes -- rather than a flat structure. 

 Cash flow by commitment: This option allows you to plot and analyze cash flow data for an 
entire commit record (including base commit, any change commits, and related invoices). 
You can choose the specific business process commitment record within the project/shell, 
such as a purchase order or contract, and track the cost information over time. 

 Note: You can set up the automatic creation of a cash flow curve 
when a base commit record is created and completed or reaches a 
particular step. This is done in the BP Setup for the business 
process. See Setting Up Auto-Creation of Cash Flow Curves 
from Contracts (on page 293) 

To create a cash flow detail level curve in a template 

1) Go to the Company Workspace tab and switch to Administration Mode. 

2) In the left Navigator, do one of the following: 

 To create a template, click Standards & Libraries > Cash Flow > Templates. This is a 
template users can select at run time. 

 To create a detail curve in a project or shell template, click Templates. Open the project 
or shell template, then click Cost Manager>Cash Flow in the Navigator. This cash flow 
model can be copied during project or shell cloning. 

The Cash Flow log opens. 

3) Click the New button. The Properties window opens. 
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Directions for completing the cash flow curve properties are in the Unifier User Guide. 

 General tab: Define the name, description, detail level, time scale and period close 
settings. 

 Curves tab: Define individual curves (Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves) that will be part of the group of curves that make 
up the cash flow detail curve. 

 Filters tab: Limit the cash flow data on your curve to a particular set of CBS codes or (if 
the cost sheet is tree structure) summary CBS codes. If you do not specify a filter, then 
all codes will be used for the data. 

 Options tab: Define the format to use for the numbers displayed on the cash flow 
worksheet.  

 Schedule tab: Enable automatic refresh of the cash flow curve, and set the refresh 
schedule. 

 Summary tab: A Summary Cash Flow Curve displays selected cash flows from your 
project. 

Create a Template for a Cash Flow Curve 

This topic discusses cash flow templates that you can create in Standards and Libraries > Cash 
Flow > Templates. For instructions on how to create cash flow curves, refer to the Unifier User 
Guide. 

Cash Flow Curve templates 

You can create cash flow curve templates that can be used to create cash flow curves in 
projects and CBS-code based shells. If you are using programs or company-level cash flow, you 
can create rollup curve templates. See Create Roll-up Templates (on page 458). 

Template creation methods are manual or copying an existing one. After creating a template, 
you can set refresh frequency and activate or deactivate curves. Creating and setting up a 
template is essentially the same as setting up the curves manually in a project or shell. The 
major difference is you cannot select individual records in the template; these must be chosen 
from within the projects or shells. 

The detail curve creates a worksheet in the project or shell that can include several curves. You 
can create detail curve templates at the following detail levels: 

 Cash Flow by Project/Shell

Used to track the costs associated with an entire Project/Shell over time. 

 Cash flow by CBS

Used to track cash flow at the CBS level as opposed to the project or shell level. Allows you 
to plot cash flow curves by specific CBS codes, or all codes, in the project or shell. 

 Cash flow by Summary CBS

Used to track cash flow by summary CBS codes. In order to select this option, the 
project/shell cost sheet must use a tree structure -- and therefore has summary CBS codes -- 
rather than a flat structure. 

 Cash flow by Commitment
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Used to plot and analyze cash flow data for a base commit record (including base commit, 
any change commits, and related invoices). You can choose a specific business process 
commitment record within the project/shell, such as a purchase order or contract, and track 
the cost information over time. Each commitment record can have one baseline curve. 

Note: You can set up the automatic creation of a cash flow curve when a 
base commit record is created and completed or reaches a particular 
step. This is done in the BP Setup for the business process. 

To create a new cash flow detail level curve in a template 

1) Do one of the following: 

 To create a template: In Administration mode, go to the Company Workspace tab and 
click Standards & Libraries > Cash Flow > Templates in the left navigator. 

 To create a detail curve in a project or shell template: In Administration mode, go to the 
Company Workspace tab and click Templates in the left Navigator. Open the 
project/shell template. Go to Cost Manager > Cash Flow. The Cash Flow log opens. 

2) Click the New button. The Properties window opens. Refer to the Unifier User Guide for 
instructions on completing the Cash Flow Curve properties. 

 General tab: Define the name, description, detail level, time scale and period close 
settings.  

 Curves tab: Define individual curves (Baseline, Forecast, Actual (or Spends), Portfolio 
Budget, Derived, and Custom curves) that will be part of the group of curves that make 
up the cash flow detail curve.  

 Filters tab: Limit the cash flow data on your curve to a particular set of CBS codes or (if 
the cost sheet is tree structure) summary CBS codes. If you do not specify a filter, then 
all codes will be used for the data.  

 Options tab: Define the format to use for the numbers displayed on the cash flow 
worksheet.  

 Schedule tab: Enable automatic refresh of the cash flow curve, and set the refresh 
schedule. 

 Summary tab: A Summary Cash Flow Curve displays selected cash flows from your 
project. 

To add filters on a Cash Flow Curve template 

1) Go to Company Workspace tab > Admin mode > Templates > Project/Shells. 

2) Open your Project/Shell template > Cost Manager > Cash Flow. 

3) Click New to configure your Cash Flow curve or open an existing Cash Flow curve. 

4) Click View and select Filter. 

Note: Alternatively, you can open the Filter window by way of clicking 
the filter icon on the upper right-hand corner of the Cashflow Worksheet 
window. 

5) Select which curves to display. Deselect any curves you do not want to display. 

6) In the Save As field box enter a name for the filter. 



Unifier Modules Setup Administration Guide

458

7) Click OK to close the window. 

8) The name of the filter that you have saved appears on the upper right-hand corner of the 
Cashflow Worksheet window. This window contains a list of saved filters that have been 
saved. 

Note: The Default View option allows you to select which particular filter 
to display when you open a Cash Flow Worksheet. 

9) You can click Edit > select Manage Filters to delete, set default view, change name, and 
change the description of your filter. 

10) In the Cash Flow log window, ensure that your Cash Flow curve is selected and click Update 
Shells. 

Create Roll-up Templates 

Use roll-up curves in programs and in the company-level Cost Manager to roll up cash flow data 
from all the projects and shells in which cash flow is being used. You can create roll-up curve 
templates, and use these to create the roll-up curves. 

To create a new roll-up template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Standards & Libraries > Cash Flow > Templates. The Cash 
Flow Standard Templates log opens. 

3) Click New > Rollup Curves. The Properties window opens in the General tab. 
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4) Click the Options tab. On this tab you can define the format to use for the numbers displayed 
on the worksheet. This is similar to the Options tab on detail curves. See Create a template 
for a cash flow curve (on page 456) in the Unifier User Guide. 

In this Field: Do This: 

Name Enter a unique name for the roll-up curve 

Description Enter an optional description. 
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Status 

Active: Data can be rolled up from project and shell cash flow 
curves. 

Inactive: Data is not rolled up to the curve. 

Data Sources 

This list displays the data sources that have been defined in 
Standards & Libraries > Cash Flow > Data Sources. Select one 
or more of the listed data sources that you want to roll up from 
the project or shell cash flow curves to the roll-up curve. To 
quickly select all data sources, you can select the checkbox at 
the top of the list, next to Data Sources. 

Time Scale 
Choose Month or Year, and the format. The roll-up curve will roll 
up data from curves that use the same time scale. 

Granting Cash Flow User Mode Permissions 

Before others can access a cash flow curve that you created, they need user mode permission. 
This is different from permission granted in Administration Mode, which is for general access to 
the module. You grant user mode permission per detail curve in the project or shell. 

Note: Granting cash flow User Mode permissions explained in this 
section is different from permission granted in Administration Mode, 
which is for general access to the module (Refer to the Unifier 
Administration Guide for details. You grant User Mode permission per 
detail curve in the Project/Shell. 

To give users permissions to work with a cash flow curve 

1) Open the Company Workspace tab and click Cost Manager > Cash Flow in the left 
Navigator. The Cash Flow log opens. 

2) Select one or more detail curves from the log, click Actions, and click Permission to open 
the Edit Permission window.  

3) Click picker in the Add to open the User/Groups window. Select one or more users or 
groups to grant permission to, click Done and then click OK. 

4) In the Edit Permission window, select one or more users or groups, and select any of the 
following permissions: 

 Modify Permission: Allows user to modify permissions to the curve. This also 
automatically selects Edit Data. 

 Edit Data: Allows user to enter or edit data for manual data entry curves. 

 View: By default, when you add a user or group to the window, they are granted View 
permission, which allows them to access and view the curves and data. 

5) Click Save. 

When the user creates a Cash Flow by way of copying from Project/Shell template through the 
Workflow Setup sub-node:  
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If the step in the Workflow Setup (in the project, admin mode) has a Cash Flow template, 
then all of the permissions in the Cash Flow template will be copied over to the created Cash 
Flow. 

When the user selects a Cash Flow template at the record level: 

If at the time of creating a commit BP record, the user has selected a Cash Flow template, 
then all of the permissions in the Cash Flow template will be copied over to the created Cash 
Flow. 

Setting up the Rules Engine 

Rules constrain the sending of cost-type business process records, and affect making changes 
to Cost and Funding sheets. That is, they give some control over costs by helping you to enforce 
cost constraints. For example, you could create a rule that prevents invoices from exceeding a 
contract budget. 

As the administrator, you can create rules and rule templates. Rules can be created at the 
project or shell level or company level. Rule templates can be created for project- or shell-level 
rules. 

You will be using a formula to create a rule, much as you use formulas to create field values. 

About Rules 

A rule is triggered when a user attempts to "send" a business process record to the next step 
whose status activates the rule. For example, the rule may be designed to activate when a 
record gets to the Pending or Approved status. A rule can prevent the record from proceeding to 
the next step if doing so will violate the rule. Rules affect how users can work with: 

 Funding sheets (at project or shell or company level) 

 Project/Shell Cost sheets 

 Schedule of Values 

When you create a rule, you can designate specific groups or users who can override the rule 
exception. 

When a rule violation occurs, Unifier displays a "Rule Exceptions" window. 

If the user has override control, they can click Override to ignore the rule exception, or Cancel to 
accept the rule and remain on the step. If the user clicks Override, Unifier will ignore the rule 
exception and send information to the audit log about the override transaction. 

Rule exceptions can be triggered by: 

 Adding or copying a line item on the Cost Sheet 

 Copying data from one column to another on the Cost Sheet 

 Entering data directly into a cell on the Cost Sheet 

 An email action that sends cost data to the sheet 

 An integration transaction that sends cost data to the sheet 

 I Step and S Step business process auto-creation 

 A business process record that rolls up cost data to the sheet 
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Note: Unifier does not display a Rule Exception window if the rule 
validation is triggered from an email action, or integration. If the user has 
override control, Unifier will assume the user wants to override the rule 
exception and sends the override information to the audit log. 

About control sources and levels 

When you create a new rule, you choose the control source (that is, whether the rule will affect 
cost or fund transactions), and the rule level (what the rule will enforce). 

Control Source 

In projects or shells, you can create rules for cost (choose Project Cost as the control source) 
or funding (choose Project Fund as the source). At the company level, you can create rules for 
funding (the control source is Company Fund). 

Note: "Commit" refers to a commit business process, such as a 
purchase order, and also would include change commit business 
processes if specified in the rule; additionally, the term "budget" can 
mean any cost sheet data source being validated against with the rule, 
which is usually, but not necessarily, budget-related. 

Rule Levels 

Project Cost: Rules with Project Cost as the source provide validation to business processes 
that affect project or shell cost sheets. Rule levels are: 

 Per CBS: These rules provide control per CBS code across the project or shell budget. 
For example, if you have an assigned budget amount for specific CBS codes, you can 
create rules that check all commit business processes (and change commits if specified) 
to verify that those assigned budget amounts, per CBS code, are not exceeded. 

Note: If a business process record has several line items, even if only 
one of the line items will violate the rule, the entire record will be 
rejected. 

 Per Total for Entire Project: This rule looks at the total, cumulative amount of commit 
business processes and verifies the total against the project or shell budget (or other 
parameter you choose). This type of rule can ensure that the project or shell budget is 
not exceeded, but does not verify specific CBS code or funding amounts. 

 Per Fund within each CBS: Applicable if the project or shell includes funding at the CBS 
level. The rule will validate the amount being charged on the commit business process 
record for each CBS code against the assigned fund amount per CBS, as specified in the 
fund information on the cost sheet. 

 Per CBS within each Commit: Related to SOV. For example, the rule can validate that 
the total amount of a purchase order and related change orders will not exceed a certain 
amount for a specific CBS code. 
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 Per selected Summary CBS Codes: Allows you to select one or more summary CBS 
codes on which to enforce the rule. This option is applicable when the cost sheet has a 
tree structure; cost sheets with flat structures do not have summary codes. You can 
choose to enforce the rule on each summary code individually, or on the total of the 
selected codes. Because you must select summary CBS codes from the cost sheet for 
this rule, this option is not available in rule templates; it is available for rules within project 
templates and shell templates, and within projects and shells. 

 Per selected CBS Codes: Allows you to select one or more "leaf" level CBS codes (that 
is, codes that are not summary codes) on which to enforce the rule. You can choose to 
enforce the rule on each code individually, or on the total of the selected codes. This 
option is applicable for cost sheets with a tree or flat structure. Similar to the previous 
option, this is available in rules within project templates and shell templates, and within 
projects and shells, not in rule templates. 

Project Fund: This control source option provides validation to business processes that affect 
project or shell funding sheets. Rule levels are: 

 Per Fund: These rules provide control per fund per project or shell, similar to "Per CBS" 
above. 

 Per Total for Entire Project/Shell: Provide control over entire funding amount for the 
project or shell, similar to cost rules. 

Company Fund: Company level rules can be created for company funding sheets: 

 Per Fund: These rules provide validation against the total amount of each fund, 
regardless of project or shell distribution. 

 Per Total of all funds: Provides validation for the total of all funds available to the 
company. 

Access a rule or rule template 

To access a rule or rule template 

Rules can be created and accessed in the following logs in Administration Mode: 

 Company Workspace node > Rules

 Company > Templates > Rules

 Project > Rules

 Project Template > Rules

 Shell > Rules

 Shell Template > Rules

Creating Rules and Rules Templates 

All new rules are created in a similar way. You can create new rules and rules templates 
manually or by copying from another rule or template. 

Rules can also be added to existing active and on-hold projects and shells by updating 
("pushing") them from a project or shell template using Update Projects or Update Shells. 
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Note: In order to start using a rule after it has been created, it must be 
validated and activated. After creating rules, see Validating and 
Activating Rules (on page 468). 

Create a Rule Template 

You can create a rule template, or a rule within a project or shell template. By default, rule 
templates remain inactive; the Validate, Activate and Deactivate buttons on the toolbar are 
disabled. Rules within project and shell templates can be validated and activated. 

You can create a new rule manually or by copying an existing rule. If you create a rule within a 
project or shell template, the rule can be "pushed" to existing projects or shells. 

To create a rule template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click one of the following: 

 Company Workspace node > Rules

 Templates > Rules

 Templates > Projects (Standard) > [project] > [template] > Rules

 Templates > Shells > [shell] > [template] > Rules

Note: At the Template > Shells level, you can create rules only for CBS 
shells, not generic shells. 

3) Click New. The Create a New Rule window opens. 

4) Select the Control Source and Rule Level. 

Note: For details on choosing the source and level, see About control 
sources and levels (on page 462). 

5) Click OK. The Edit Rule window opens. 

6) Use the information in the first table below to complete the fields on the General tab. 

7) Click the Rule tab and complete the fields using the information in the second table below. 

8) In project or shell templates, if you chose "Per selected CBS Summary Codes" or "Per 
selected CBS Codes" as the rule Level, then the CBS Codes tab appears in the Edit Rule 
window. See the following procedure for selecting CBS codes. 

9) Click OK to save and close the Edit Rule window. 

In this field: Do this: 

Name Enter a name for the rule. 

Description Enter a description of the rule. 

Control Source Unifier displays the control source you chose in this field. 

Rule Level Unifier displays the rule level you chose in this field. 
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Status Unifier displays the current status of the rule. 

Users/Groups who can 
override 

(Optional; appears only at the project and shell templates 
level) 

This option is available only for the following rule levels: 

 Per selected summary CBS codes 

 Per selected CBS codes 

Click the Select button and from the picker that appears, 
select the users or groups that will be allowed to override 
this rule at runtime. 

If you select this option, the specified users/groups should 
be able to override a rule failure condition during a 
workflow. Unifier will display the name(s) of the overriding 
user(s) and any comments in the Audit Log. 

Note: If you use this option, users/groups can override 
this rule, even if the data is not valid. Also, the 
users/groups specified in this option will be added to the 
project/shell if they do not already exist there 

Notify Users/Groups when 
overridden 

(Optional; appears only at the project and shell templates 
level) Click the Select button and from the picker that 
appears, select the users or groups that should be 
notified if this rule is overridden. 

In this field: Do this: 

Limit Expression 

This defines the Upper Limit that the rule validates 
against and is static. For example, for cost rules, this 
might be the Assigned Budget, or can include the sum of 
several budget-related data sources on the cost sheet. 

Click the Formula button. The Formula Creation window 
opens. The data source list includes all available cost 
sheet data sources for cost-related rules, or funding 
sheets data sources for fund-related rules. This is the 
value on the left of the Condition. Pending positive 
values are not considered. 

Note: Unifier identifies the non-terminal documents as pending.  

Include positive pendings in 
calculation 

Deselected by default.  

When this option is selected (checked) by the user, 
Unifier will consider positive values from non-terminal 
records in the Limit Expression formula calculation. 

When this option is deselected (unchecked) by the user, 
Unifier will ignore positive values from non-terminal 
records in the Limit Expression formula calculation.  
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Condition 

The option "greater than or equal to" is the only selection 
available. Rules always check that the "Upper Limit" 
(Limit Expression) is greater than or equal to the amount 
calculated by the Data Expression. 

Data Expression 

This is what is being validated. For example: 

Purchase Order (Pending) + Purchase Order (Approved) 
+ Change Commit (Pending) + Change Commit 
(Approved) 

Click the Formula button. The Formula Creation window 
opens. The data source list includes all available cost 
sheet data sources for cost-related rules, or funding 
sheets data sources for fund-related rules. This is the 
value on the right of the Condition. Pending negative 
values are not considered. 

Include negative pendings in 
calculation 

Deselected by default.  

When this option is selected (checked) by the user, 
Unifier will consider positive values from non-terminal 
records in the Data Expression formula calculation. 

When this option is deselected (unchecked) by the user, 
Unifier will ignore positive values from non-terminal 
records in the Data Expression formula calculation. 

Show this message when 
condition is not met 

This field is required. Enter a message to display to 
users if the rule condition is not met. 

Select CBS Codes or Summary Codes 

To select CBS codes or summary codes: 

1) In the Edit Rule window, click the CBS Codes tab. (This tab is available if you chose "Per 
selected CBS Summary Codes" or "Per selected CBS Codes" as the rule Level.) 

2) Click Add. The CBS Picker opens. 

 If you chose "Per selected CBS Summary Codes," the picker displays the summary CBS 
codes on the sheet. This is only applicable if the project/shell cost sheet uses a tree 
structure. Cost sheets with flat structures do not have summary CBS codes. 

 If you chose "Per selected CBS Codes," the picker displays the "leaf" CBS codes 
(individual, non-summary codes). This is applicable for both tree and flat cost sheets. 

3) Select one or more codes from the picker and click Select. 

To locate the CBS codes you need, you can click the Find button in the CBS Picker. For tree 
structure cost sheets, you can also click Expand or Collapse to help you navigate the code 
structure. 

After you select the CBS codes, they are listed in the CBS Codes tab. You can add as many 
CBS codes as needed. At runtime, the rule will be applied only to the CBS codes selected. 
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Note: Summary CBS codes must all be at the same summary level (i.e., 
the same indent level). 

4) For Validation, choose one of the following: 

 Validate total of selected rows: the system will calculate the sum of the selected CBS 
codes and then apply the rule to the total 

 Validate selected rows independently: the system will apply the rule to each selected 
CBS code individually 

5) To remove a CBS code from the list, select it and click Remove. 

6) Click OK to save and close the Edit Rule window. 

Note: If you add a CBS code or summary code to this list and it is later 
removed from the cost sheet, the rule will not be affected. The code will 
still appear on the CBS Codes tab. At runtime, the rule engine will ignore 
the code that was removed from the cost sheet. Similarly, in a tree 
structure, if a summary code is changed to a leaf code (or vice versa) 
after adding it to the CBS Codes tab, at runtime, the rule engine will 
ignore the code that was changed and not create an error. 

Create a Project or Shell Rule 

You can create a new rule in a project or shell manually or by copying a rule template or existing 
rule. 

In addition to these procedures, rules can also be added to existing active and on-hold projects 
and shells by updating ("pushing") them from a project or shell template using Update Projects 
(Update project cost or fund rules) or Update Shells (Updating Shells - Rules Node). 

To create a new project or shell level rule 

1) Open the project or shell and switch to Admin mode. 

2) Click to Rules in the left Navigator. 

3) Click New. Follow the procedure for creating a Rule Template. 

To create a rule by copying a rule template 

1) Open the project or shell and switch to Admin mode. 

2) Click Rules in the left Navigator. 

3) Click the Copy button and select Template. The Copy from Rule Template window opens. 

4) Select a template from the list and click Copy. The Edit Rule window opens. 

You may make edits to the Edit Rule window if necessary. For example, by default, the 
Name will display as "Copy of (name of rule template)," which you may wish to change. 

5) Click OK. The new project or shell rule will be added to the project or shell Rules log. 

To create a rule by copying an existing rule 

1) Open the project or shell and switch to Admin mode. 

2) Click Rules in the left Navigator. 
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3) Select a Rule from the log. 

4) Click the Copy button and select Rule. The Edit Rule window opens. 

You may make edits to the Edit Rule window if necessary. For example, by default, the 
Name will display as "Copy of (name of the copied rule)," which you may wish to change. 

5) Click OK. The new project or shell rule will be added to the project or shell Rules log. 

Create a Company Rule 

At the company level, you can create rules for the company funding sheet. You can create rules 
that help you manage you manage each fund, or the total of all funds. 

To create a company level rule 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) From the left Navigator, click the Company Workspace node > Rules. 

3) Click New. The Create a new rule window opens. 

4) Select the Control Source: Company Fund. 

5) Select the Rule Level: Per Fund or Per Total of all funds. 

6) Click OK. The Edit Rule window opens. 

7) Complete the Edit Rule window as in the Rule Template procedure and click OK. 

Validating and Activating Rules 

Rules must be active before they can take effect. Before activating a rule, they must first be 
validated to make sure there are no conflicts associated with it. Rules within projects and shells 
as well as within project templates and shell templates can be validated and activated. Rule 
templates cannot be activated or validated. 

Validate a rule 

You can validate rules in projects or shells, and company level rules. You can also validate rules 
in project or shell templates to help ensure that they will work in the project or shell, even if you 
do not immediately activate them. Validation is not available in rule templates, because part of 
the validation process involves verifying that the cost or fund sheet is set up and any referenced 
business processes are active. 

It is good practice to validate a rule before attempting to activate it. If you try to activate a rule 
directly, the system will first validate it anyway, but if there is a conflict, you will simply see an 
error and may not be able to assess what the issue is. By validating first, the system provides 
more information if the validation fails. 

To validate a rule 

1) Select a rule from the Rules log. 

2) Click the Validate button on the toolbar. The Validation Results window opens. 

If the validation failed, the errors will be listed in the window. Edit the rule as necessary and 
revalidate. 
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Activate or Inactivate a rule 

You can activate rules in projects or shells, and company level rules. You can also activate rules 
in project or shell templates. In this way, the rules in the projects or shells that are created from 
these templates will be active as soon as the project or shell is active. 

You cannot activate a rule template. 

To activate a rule 

1) Select one or more rules in the Rules log. Be sure that the rules have passed validation. 

2) Click the Activate button. 

To deactivate a rule 

1) Select one or more activate rules in the Rules log. 

2) Click the Deactivate button. 

Manage Rules 

Rules can be accessed in the following logs in Administration Mode: 

 Company Workspace node > Rules 

 Company > Templates > Rules 

 Project > Rules 

 Project Template > Rules 

 Shell > Rules 

 Shell Template > Rules 

Rules can also be updated in active and on-hold projects and shells by updating ("pushing") the 
changes from a project or shell template using Update Projects Update project cost or fund 
rules) or Update Shells (Updating Shells - Rules Node). 

To edit a rule 

1) Select the rule in the Rules log. If the rule is active, you must deactivate it before editing. 

2) Click the Edit button. The Edit Rule window opens. 

3) Make edits as necessary and click OK. 

To delete a rule 

Select a rule from the Rule Log window. Click Delete, then Yes when prompted to confirm. 

To view a rule audit log 

1) Select a rule from the Rules log. 

2) Click the View menu and choose Audit Log. The Audit Log window opens, listing each 
event associated with the rule. The date and time stamp of each event reflect users’ current 
time zone as set in their User Preferences. 

3) From the Audit Log window, you can double-click a listed event to view the audit record 
detail, which details the action taken. The details also include the user’s current time zone for 
reference. 
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To print the audit log 

1) From the Audit Log window, click the Print button. A PDF file is created. 

2) Do one of the following: 

 Click Open to open the file in Adobe Acrobat Reader. From the Reader window, you can 
view, save, or print the file. 

 Click Save. In the Save As window, navigate to the location in which you want to save 
the PDF file. Open the file in Adobe Acrobat Reader and choose File > Print to print. 

Setting up a Generic Cost Manager 

You can define a Generic Cost Manager to capture cost-related activities for a Generic Shell. 
These include costs like: 

 Rent 

 Lease payments 

 Landscape care 

 Building maintenance and repair 

 Remodel of building interiors 

With this manager, you can capture and view cost transaction information based on a time scale, 
such as quarterly or yearly. Each shell can have one Generic Cost Manager. 

The Generic Cost Manager uses specific Generic Cost business processes and business 
processes with the type Line Items with Multiple Codes as data sources. 

Before you begin. The Generic Cost Manager and the Generic Cost Manager Attribute form 
must first be designed in uDesigner. 

Step 1: Set the permissions for importing the Generic Cost Manager. 

Step 2: Import the Generic Cost Manager. 

Step 3: Import and deploy the Generic Cost Manager Attribute form. 

Step 4: Set template permissions. 

Step 5: Create the Generic Cost Sheet template at the company level. 

Step 6: Create a Generic Cost Sheet. 

Step 7: Work with Generic Cost BPs. 

Step 8: Set up the Commitment Summary Template. 

Note: The name of the Generic Cost Manager you will work with is 
determined by the name given to it in uDesigner. For documentation 
purposes, the manager is referred to as the Generic Cost Manager. 

Setting Generic Cost Manager Permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 
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3) In the right pane, select Configurable Modules > Generic Cost Manager.

The permissions are: 

 Modify: Allows the use to import configurable modules from uDesigner 

 View: Allows the user to view configurable modules imported from uDesigner 

Import Generic Cost Manager 

To import an asset class into Unifier Production environment, see Importing Configuration 
Packages (on page 640). 

Import Generic Cost Manager Attribute form 

To import and deploy an attribute form into Unifier Production environment, see Importing 
Configuration Packages (on page 640). 

Creating a Cost Sheet Template for a Generic Manager 

You can create a Generic Cost Sheet template to use with the Generic Cost Manager. 

Create a Generic Cost Sheet template 

The name of the template is based on whatever name was given to the Generic Cost Manager. 
You create this template at the company level, and use it in shells that are of the type Generic. 

To create a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Click New to create a new Generic Cost Sheet template. You can create multiple templates. 
The Properties window displays. 

4) In the General tab, enter general information for the template: 

a. Enter a unique Title, which is used to identify the template in the log, and when creating a 
new Generic Cost Sheet from the template. 

b. Enter an optional Description for the template. 

c. Choose a default display mode for the sheet. 

 If you choose Flat, the cost sheet will display the codes (rows) in a flat structure, 
with no indented rows. This is useful if you want to display all codes at once. 

 If you choose Tree, you have the option of creating indented, nested rows, which 
can be collapsed into summary, or grouping, rows. This is useful if you will be 
creating a large amount of rows that can be grouped into categories. You can 
check Expand all codes to expand the row structure by default. 

d. Choose a Default View. The choices are: 

 Current Shell 

 Current Shell and sub-shells 

 Subshells 
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5) In the Segments tab, define the segments of the cost codes that will be created on the sheet 
by choosing the Segment Sources. The segment sources are those that were defined in 
uDesigner. After you click Apply, you cannot add or remove any of the segments. If you want 
to use different segments, you must create a new template. 

6) Click Apply to save changes, or OK to save and exit the window. 

Structure a Generic Cost Sheet template 

After you create the template, you can define the structure by adding rows and columns. 

To add rows to a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Select a Generic Cost Template. 

4) Click the Structure button. The Template Structure Setup window opens. 

5) Click Add Row. The Generic Cost Code Details window opens. 

6) To form cost codes (rows) click Select next to the Cost Code field. 

7) Enter the cost code segments and click OK. 

8) Optionally, enter a code name for the cost code. 

9) Select a status (Active or Inactive). 

10) Click Add to add the row and then continue to add rows, or click OK to exit. 

To add columns to a Generic Cost Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Configurable Modules > Generic Cost Manager in the left Navigator. 

3) Select a Generic Cost Template. 

4) Click the Structure button. The Template Structure Setup window displays. 

5) Click Columns. The Cost Sheet Columns window opens. 

6) Click the New button. The Column Properties window opens. 

7) Complete the fields in the Column Properties window as described in the table below. 

8) Click OK when you are done with the column properties. 

In this field: Do this: 

Name 
Enter a column name. The name you choose will appear as the column 
header on the sheet. If you leave the Name field blank, the selection you 
make in the Datasource field will automatically populate the Name field. 

Datasource 

Choose a datasource. All columns must be associated with a data 
source. The data source that you choose will determine which of the 
following options are available. The types of Data sources available are: 

Single Datasource: These values roll up from business processes that 
have these attributes: 

Level: Project/Shell 

Type: Cost 
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Sub-Type: Line Items with Multiple Codes 

Configurable Manager: <name of Generic Cost Manager> 

Logical Datasource: Generic Cost Manager (1-25). 

Entry 
Method 

Choose an entry method. This is applicable for logical data sources. 

Manual Entry, Direct entry into cell: Users enter values by clicking the 
cell and entering values directly into the cell. 

Formula: Values are calculated based on a specified formula entered for 
the column. Formulas can include the values of other columns. Click the 
Create button to create the formula. 

Data Format 

Choose a data format. Applicable for Manual Entry or Formula columns: 

Show as percentage: Display the data in percentages. 

Decimal Places: Number of decimal places to display. 

Use 1000 Separator (,): Use a comma as a separator. 

Negative Number Format: Specify the format for negative numbers. 

Display 
Mode 

Choose a display mode. Refers to whether the column is displayed on 
the cost sheet. 

Show: Default; indicates that column will display by default on the cost 
sheet to all users with at least "view" permission for the cost sheet. 

Hide: Hidden columns are active but not displayed on the cost sheet. 
Hidden columns can be accessed by users with "create" permission on 
the cost sheet. 

Total: Choose to designate the content of the Total row of the column. 
Default is Blank. You can choose Sum of All Rows or Use Formula 
Definition. 

Average: Display the average row of the column. 

Total 

Choose how the total is displayed. Determines what will display in the 
"Total" (bottom) row for the column: 

Blank: The total of this column is not applicable and will not display on 
the cost sheet. Choose this column for percentage columns and other 
columns where it does not make sense to display the sum total. 

Sum of All Rows: The sum total of the column values is displayed. 

Use Formula Definition: For formula columns; the formula will be applied 
to the "Total" row in the same way it is applied to other rows in the 
column. 

Column 
Position 
After 

Choose the column position. The new column will be inserted after the 
column selected. 



Unifier Modules Setup Administration Guide

474

Setting Generic Cost Sheet Template Permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, select Templates > Generic Cost Manager.

4) Select the Generic Cost Sheet template. 

The permissions are: 

 Create: Allows user to create a new Generic Cost Sheet template. 

 Modify Properties: Allows the user to modify the template properties. 

 Modify: Allows the use to modify an existing template. 

 View: Allows the user to view templates. 

Creating a Generic Cost Sheet 

You create a Generic Cost Sheet in the same way you create a standard Cost Sheet. See 
Create a company cost sheet (on page 404) for details. Remember that the Generic Cost 
sheet can only be added to a generic shell, not to a project. 

Setting up the Commitment Summary Template 

When a Generic Cost BP of the Base Commit type reaches Terminal status, it will create a 
record in the Commitment Summary sheet, which tracks commits in the context of a shell. When 
subsequent Change Commits and General Spend Generic Cost BPs that are associated with 
the original Base Commit, BP will update the Base Commit record on the Commitment Summary 
sheet. 

Create a Commitment Summary Sheet Template 

To create a Commitment Summary sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Commitment Summaries in the left Navigator. 

3) Click New to create a new Commitment Summary sheet template. You can create multiple 
templates. 

4) In the General tab, enter a unique Name and an optional Description. 

5) In the Options tab, enter the following column names: Ref, Cost Code, Code Name, 
Breakdown, and Description. 

Depending on design in uDesigner, some columns may not display in the Commitment 
Summary sheet. 

6) Click OK. 

To add columns to a Commitment Summary sheet template 

1) In Administration Mode, go to the Company Workspace tab and click Templates > 
Commitment Summaries in the left Navigator. 
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2) Select a Commitment Summary sheet template. 

3) Click the Columns button. The Columns Log window opens. 

4) Click the New button. The Column Properties window opens. 

5) Complete the fields in the Column Properties window as described in the table below. 

6) Click OK when you are done with the column properties. 

In this 
field: 

Do this: 

Name 
Enter a column name. The name you choose will appear as the column 
header on the sheet. If you leave the Name field blank, the selection you 
make in the Datasource field will automatically populate the Name field. 

Datasourc
e 

Choose a datasource for the column. The data source that you choose will 
determine which of the following options are available. The types of 
Datasources available are: 

Single Datasource: These values roll up from business processes that 
have these attributes: 

 Sub-Type: Line Items with Multiple Codes 

 Classification: Base Commit, Change Commit, or General Spends 

Logical Datasource: 

 Commitment Cost 1 to Commitment Cost 25 

 Commitment Remaining Balance 

Entry 
Method 

This is applicable for logical data sources. 

 Manual Entry, Direct entry into cell: Users enter values by clicking the 
cell and entering values directly into the cell. 

 Formula: Values are calculated based on a specified formula entered 
for the column. Formulas can include the values of other columns. 
Click the Create button to create the formula. 

Data 
Format 

Choose the data format: 

 Currency: Formats data in a currency format with a comma (,) 
separator. 

 Percentage: Formats data as a percentage (%). 

Display 
Mode 

Choose a display mode. This refers to whether the column is displayed on 
the cost sheet. 

 Show: Default; indicates that column will display by default on the cost 
sheet to all users with at least "view" permission for the cost sheet. 

 Hide: Hidden columns are active but not displayed on the cost sheet. 
Hidden columns can be accessed by users with "create" permission on 
the cost sheet. 

Column 
Position 
After 

Choose the column position. The new column will be inserted after the 
column selected. 

Allow Select to be able to manually enter values against breakdowns in lines 
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sub-breakd
own with 
validation 

created on the sheet through Base Commit and Change Commit. 

Create a Commitment Summary Sheet 

To create a Commitment Summary sheet: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Shells > [Shell name] > Cost Manager > Commitment Summary in the 
left Navigator. The Commitment Summary log opens. 

3) Click the Create Structure button. The Select Template window opens. 

4) Choose a template and click OK. 

5) Click Columns to add columns. 

6) Choose File > Properties to edit the sheet properties. 

7) In the General tab, enter a unique Name and an optional Description. 

8) In the Options tab, enter the following column names: Ref, Cost Code, Code Name, 
Breakdown, and Description. 

Depending on the design in uDesigner, some columns may not display in the Commitment 
Summary sheet. 

9) Click OK. 

Update a Commitment Summary Sheet from a template 

To update a Commitment Summary sheet from a template: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates> Shells > [shell] > Cost Manager > Commitment Summary in the left 
Navigator. The Commitment Summary log opens. 

3) Modify the Commitment Summary 

4) Click the Update Shells button. The Update Shells window opens. 

5) Choose the shells to update and click OK. 
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Setting up the Document Manager 

A document attribute form and folder attribute form can be designed in uDesigner. These are 
used as the Properties window for documents and folders in the project-, shell-, and 
company-level Document Manager, which allows you to specify the fields that you want to 
associate with folders and documents (these are reportable). 

Step 1: Import and deploy Document Manager attribute forms. This is an optional step. If you do 
not import these forms, default forms will be used for document and folder properties. 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

Step 3: Create a folder structure template. This can be used to create the folder structures in the 
Document Manager at the project, shell, and company level. 

Step 4: Lock the folder structure. This is an optional step. This locks the first-level folder 
structure in User Mode, which prevents users from creating or editing first-level folders, allowing 
you to maintain a consistent structure across projects and shells and at the company level. 
Users can still add or edit subfolders. You can unlock the folder structure later for editing if 
necessary. 

For security, the Company Administrators can specify the list and size of files that can be 
uploaded to the Company Properties page, by users and per company policy. See Access 
Company Details (Edit Company Window) for more information.  
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Document and Folder Properties 

Users have the ability to create attribute forms to customize the document properties and folder 
properties in the Document Manager, using the uDesigner. The data elements on the Properties 
window are fully reportable through user-defined reports. 
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The project documents, shell documents, and company documents log columns can also be 
customized through uDesigner, as well as the find function for searching on document and 
folders properties. You can import one document properties attribute form and one folder 
properties attribute form. Refer to the Unifier uDesigner User Guide for details about creating 
Document Manager attribute forms. 

Permissions 

The Document Manager permissions are set at the module level through the Permissions 
window or Access Control. Permissions for the Project-level, Shell-level, and company-level 
Document Manager are set separately. When permission is granted to view the Project 
Documents, Shell Documents, or Company Documents node, this only grants the user the ability 
to access the module and potentially to view documents stored there. Users must also be 
granted specific permission to create, modify, or view specific documents and folders in User 
Mode. This can be done by the folder or document’s owner, or an administrator with full access 
permissions. Permissions at the folder or document level can be inherited from permission 
settings in the parent folder. 

A user granted full access permissions will have access with full permissions to create, modify, 
or delete any folder or document, regardless of the permission setting at the folder or document 
level. In addition, a user who is the owner of a folder or document will have full access 
permissions on that folder or document. Any folder or document level permissions are ignored. 
However, if the owner transfers ownership to another user, the permission setting for the former 
owner will be determined by the folder or document level permission setting. 

A user designated as the document administrator should have permission to create and 
maintain folder structure templates. Optionally, it is useful for the document administrator to have 
full access permissions granted for the Project Documents, Shell Documents, Company 
Documents, and Unpublished Documents nodes. 

Categories 

Categories are controlled by the data definition SYS Category. This is managed like other data 
definitions. Category values are added as the data set. 

When entering document or folder properties in the Document Manager, a category can be 
defined by choosing from the values in the data set. Category information is reportable in 
user-defined reports. 

Importing Document Manager Attribute Forms 

You can customize the document and folder properties by creating DMS attribute forms in 
uDesigner. Ensure that you have checked for errors and changed the status to complete in 
uDesigner. 

When deploying the attribute forms, the following will be updated with the customized interface 
designed in uDesigner: 

 Project Documents log 

 Shell Documents log 



Setting up the Document Manager

479

 Company Documents log 

 Search by Properties Criteria 

You can have only one document and folder attribute form per company, which will be used for 
the document and folder properties in the company-level Document Manager and across all 
projects and shells. 

To import and deploy a Document Manager attribute form into Unifier Production environment, 
see Importing Configuration Packages (on page 640). 

Setting Document Manager Administration and User Permissions 

To grant auto-sequencing configuration permission: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select Administration Mode > Configuration > Document Manager. 

4) Select Configure. 

To grant User Mode permissions: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select: 

 User Mode > Company Workspace > Document Manager > Company Documents or 

 User Mode > [project or shell] > Document Manager. 

4) Select Full Access, Create, Organize, or View. 

For Unpublished Documents, the permissions are Publish, Download, Open, View. 

For Document type business process permission settings, refer to the Unifier Reference Guide. 

Working with Folder Structure Templates 

You can standardize the setup of the Document Manager across your projects and shells and at 
the company level by creating folder structure templates. These allow you to create the folders 
and sub-folders that you can then import into the company Document Manager, or into any 
project and shell or project or shell template to organize your documents. 

After importing, you can add, move, rename, or delete folders as needed. You can import a 
folder structure directly under the Project Document, Shell Document, or Company Documents 
node to create the main folder structure, or create specialized structures to import under existing 
folders to create sub-folders. 

Note: By default, files attached to business processes are placed in the 
Unpublished Documents folder in the Document Manager. A Publish 
Path data element can be designed in business processes in uDesigner 
to specify the automatic publishing of documents to a specified path and 
override the default. For document-type business processes With Folder 
Structure, you can specify that a configured folder path be appended to 
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the folder structure. This appended path is based on the path configured 
in the uuu_dm_publish_path data element on the business process form, 
and the selection of the Append Line Items Folder Structure to 
AutoPublish Path option, which is documented in the Unifier uDesigner 
User Guide; see Starting an Upper Form for details. 

To create a folder structure template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Folder Structures in the left Navigator. 

3) Click the New button, or click the File menu and choose New > Create New Template. The 
Create Folder Template window opens. 

4) Enter a name for the template. 

5) Click Add. A sub-folder will be created in the Template Folder. The Template Folder 
corresponds to the folder into which you will import the folder structure in the Document 
Manager. 

6) Continue to add folders. 

Select the parent folder before clicking Add. Clicking Add without selecting a folder will 
default to the last folder created. 

7) To modify the folders, do any of the following: 

 Click + (plus sign) to the left of the folder to expand it and display the sub-folders. 

 Select a folder and click Remove to delete a folder. 

 Select a folder and click Rename to change the name. 

 Select a folder and click Move Up or Move Down to move it. 

8) Click OK. 

To create a folder structure from an existing project or shell 

1) In Administration mode, go to the Company Workspace tab and click Templates > Folder 
Structures in the left Navigator. 

2) Click New > Copy from Project or New > Copy from Shell. The Projects or Shells window 
opens. 

3) Select a project or shell from the list and click Select Project or Select Shell. You can click 
Find to search for the project or shell. The Copy Folder Template window opens, displaying 
the entire folder structure of the project or shell you chose. 

4) Give the new template a name. You can add, modify, delete, or move the listed folders as 
needed. 

5) Click OK to save the template. 

The structure can be imported into the Document Manager. See Import a folder structure 
template. 

To modify a folder structure template 

1) In the Folder Structure Template log, select the folder structure template to modify and click 
the Open button. The View Folder Structure Template opens. 

2) Click + (plus sign) to the left of a folder to expand it and display the sub-folders. 
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3) To modify folders, do any of the following: 

 Select a folder and click Remove to delete a folder. 

 Select a folder and click Rename to change the name. 

 Select a folder and click Move Up or Move Down to move it. 

 Click OK. 

To delete a folder structure template 

In the Folder Structure Template log, select the folder structure to delete and click the Delete
button. Click Yes to confirm. 

Lock and unlock the first-level folder structure 

An administrator with full Document Manager permissions (full access or create permission on 
the Project Documents, Shell Documents, or Company Documents node) has the ability to lock 
or unlock the first-level folder structure. The first-level folder structure refers to the folders 
directly beneath the Project Documents, Shell Documents, or Company Documents node. 

This allows an administrator to establish a standard first-level folder structure that cannot be 
modified. Users will not be able to add, modify, or delete the first-level folders, but can add 
sub-folders or documents. Permissions to lock first-level folders can be modified. 

You can lock the folder structure at the Project Documents, Shell Documents, or Company 
Documents root folders. 

To lock the first-level folder structure 

1) In User Mode, do one of the following: 

 Open a project or shell and click Document Manager > Documents in the left Navigator. 
Be sure the Project or Shell Documents folder is selected. 

 Go to the Company Workspace tab and click Document Manager> Company 
Documents in the left Navigator. Be sure the Company Projects or Company Shells 
folder is selected. 

2) Click Properties. The Folder Properties window opens. 

3) Click the Options tab. 

4) Select the checkbox Lock first level folder structure below Project Documents (or 
Company or Shell) at the bottom of the window. You may need to scroll down. 

Users with permissions will be able to add documents and sub-folders, but cannot add, 
modify, or delete the first-level folders. 

Note: This checkbox is only available in the Project, Shell, and Company 
Documents folder properties. 

5) Click OK. 

To unlock the first-level folder structure 

Open the Folder Properties window, Options tab, and deselect the checkbox. 
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Configuring Document Manager 

When configuring Document Manager, the user can create log views for the Document log.  

All the DM attributes forms available in Folder Properties node (in Document Manager) are 
included in the configuration once the DM design is deployed. For more details on DM attributes 
refer to the: 

 Unifier User Guide, "Working with Multiple Document Manager Attribute Forms." 

 Unifier uDesigner User Guide, "Creating Multiple Attributes Forms." 

Unifier creates the configuration, by default, when the attributes form is deployed in the 
Document Manager, in uDesigner, and marked as Active. 

The configuration for system-defined attribute form will always be Active. The user will be able 
to create log views whether configuration is Active or Inactive. 

Only the active DM configuration forms will be available for selection in shells or shell templates. 

If the user deletes the attribute form related to the DM configuration, then Unifier deletes the 
configuration for the attribute form, once the user deploys the DM design. 

When the user opens a configuration for the Document Manager, a sub-node appears under 
the Document Manager node ("{document manager log name } - Log Views"). This sub-node 
will be available in Document Manager log regardless of status (active or inactive), and the user 
can define log views for the respective DM logs. For example, if the user clicks on EMAAR 
Attributes, then a sub-node appears as "EMAAR Attributes - Log views." 

Permission and Access Control 

Only a user with Configuration permission, for Document Manager, will be able to access this 
node and create views. To set permission, go to Company Workspace tab > Admin mode > 
Access Control > Administration Mode Access > Configuration > Document Manager: 
Permission Settings > Configure. 

Creating Document Manager Log Views in Admin Mode 

The following list of views in the log are included in the OOTB (out of the box) views. These 
views can be modified only at the Admin level. Views defined in the Configuration node will also 
be treated as OOTB views.  

To define log views for Document Manager, use the Document Manager node (Company 
Workspace tab > Admin mode > Configuration). The Document Manager log has the 
following operational options: 

 Create

Enables the administrator to create new view. 

 Actions

Possible actions is status which can be marked as active or inactive.. 

 Status (Active - Inactive)

 Find on Page
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To filter the results seen on Document Manager log and finding a specific view on the 
displayed page. 

Note: The user will not be able to inactivate the DM configuration 
associated with a system-defined attribute form. 

The Document Manager log has the following columns: 

 No.

This is a system-generated number. When populated, it enables the user to know the 
sequence of the views. 

 Name

Name of the view. 

 Description

 Last Modified Date

The date that the View was last modified. For a new view this will be the creation date. For 
existing system-defined views, for the very first time, when no modifications are done, this 
field will be blank. 

 Last modified by

The user who modified the view. For existing system-defined views, for the very first time, 
when no modifications are done, this field will be blank. 

 Status

Can be Active or Inactive. 

The Administrator cannot inactivate all the views. At least one view must be active. 

The 'check for duplicate view' names will be performed per user.  A user will not be allowed to 
create two views with the same name per DM log. 

If a user changes the sequence of the views that was initially provided as per DM configuration, 
or if an Administrator has made few changes to the sequence, the user's view sequence will not 
change. 

The new active views will be appended to the end of the list, in user view, in Document 
Manager. 

Defining new view 

When you click Create, the New View window opens. From top to bottom, this window has the 
following elements: 

 Save View As

 Cancel

 Save

 Columns tab

 Filters tab

 Group By tab

 Sort By tab

 Gear menu



Unifier Modules Setup Administration Guide

484

Enables the user to conduct the following: 

 Move Up

This option is not available for first view. 

 Move Down

This option not available for last view. 

 Delete

This option not available for Active view. 

Changing the sequence will change the number seen for the view. The sequence seen is the 
sequence seen in the log. When a drag and drop is done to re-sequence the views, the 
numbers will change. 

The Actions option enables the user to set: 

 Status

The user will be able to defined the view status as Active or  Inactive. The user can select 
one or more views and click Status to either Activate or inactivate the views. 

 Delete

The user will be able to delete the views. Deletion of views will be possible only for Inactive 
views. If multiple views are selected and one of the views is active then post action only the 
Inactive views will be deleted. 

Document Log Views and Configuration Package 

Use the Log Views node (Company Workspace tab > Admin mode > Configuration Package 
Management > Component Lists > Configuration > Log Views) to include the designs for the 
selected log views, for Document Manager, in your configuration package. 

DM log views in Component list/Configuration Package: 

 The users can include DM log views and deployed designs. 

 The users can include updated DM log views without any changes to the underlying columns 
used in View definition. 

 When the configuration package is imported, it replaces any existing DM log views that were 
created by the administrator. 

Note: The DM log view component will be included as part of impact 
analysis report, error report, and print report. In Impact Analysis Report, 
the name for log view will appear as "{DM configuration name} - Log 
View". In other reports the name will be maintained as is as seen in the 
DM configuration.  

Once a DM log view is included, Unifier will package all of the log Views for that particular DMS 
in the configuration package. When imported, the package replaces all of the log views created 
by the Administrator.  
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Note: The user-created view (the runtime created views) will not be 
impacted by Configuration package import. 

The component name will be listed as Document Manager, for log views, and the location as 
Configuration > Log Views.  
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Setting up the Planning Manager 

Before you begin: Planning types are designed in uDesigner and deployed to Unifier. A 
planning type consists of planning item forms and planning sheet forms. Examples of planning 
types include Capital Planning, IT Planning, etc. The planning item forms are used to create new 
planning initiatives for that type, and the sheet forms are used to create the associated planning 
sheet. The types, forms, and corresponding logs are designed in uDesigner. 

Step 1: Design Planning Type attribute in uDesigner and deploy to Unifier. This is similar to any 
other design deployment in uDesigner. 

Step 2: Grant yourself permissions to create a default sheet structure and configure the planning 
type. 

Step 3: Create a default structure for the planning sheets. This is a template that you will create 
to specify the default columns that should be on the planning sheets. 

Step 4: Configure (activate) each planning type. 

Step 5: Grant Planning Manager permissions to users. In User Mode, the permissions for 
planning items and sheets are Full Access, Create and View. 

Once you have completed these steps, the Planning Manager is ready for use in Unifier (User 
mode). 

In This Section 

Importing a Planning Type ..................................................................................... 487 
Granting Yourself Permissions .............................................................................. 487 
Creating a Default Structure for the Planning Sheet .............................................. 488 
Configuring the planning type ................................................................................ 494 
Deleting a Planning Manager ................................................................................ 494 
Configuring Planning Manager Configuration Package ......................................... 495 
Granting planning setup permissions ..................................................................... 495 
Loading the Planning Manager .............................................................................. 496 
Granting User Permissions .................................................................................... 496 
Master Log - Planning Items for the Planning Manager ......................................... 497 

Importing a Planning Type 

To import and deploy a planning type into Unifier Production environment, see Importing 
Configuration Packages (on page 640). 

Granting Yourself Permissions 

When you import a new planning type, you must grant permission (to yourself, another 
administrator, or group such as Company Administrators) to configure the planning type and 
create a default structure for the planning sheets. 
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To grant configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, select Administration Mode Access > Configuration > All > Planning 
Manager. 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Click OK. Unifier adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Configure and click OK. Unifier adds the name(s) to the 
Permission Settings window. 

8) Click OK. 

Creating a Default Structure for the Planning Sheet 

Creating a sheet structure produces a template that users can use to create a planning sheet. 
You must create a default sheet structure before you can use the Planning Manager at the 
company level, or load the Planning Manager into a shell. 

To create a planning sheet structure 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Planning Manager in the left Navigator. 

3) Select the planning item for which you want to create a structure. 

4) Click the Default Structure button. The Planning Sheet Template window opens. 

5) Add columns by clicking the Columns button. The Column Log opens. 

6) Click New. The Column Properties window opens. 

7) Use the information in the following table to complete the Column Properties window. 

In this field: Do this: 

Data Source

Select the field you want to appear on the sheet. (This list shows 
the fields (data elements) that were included on the Planning Item 
attribute form.) When you select the field, Unifier displays the field 
label in the Name field. 

Entry Method

Specify: 

 Manual Entry if the user must manually enter values into this 
field 

 Formula if the field will be automatically calculated with a 
formula. (To create the formula, see Add a column based on 
a formula calculation (on page 489).) 

 Query to retrieve data from the database that meets specific 
conditions and display it in this column. (To create the query, 
see Add a column based on a database query (on page 
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491).) 

Show as 
percentage

If you chose Formula or Query as the data entry method, use 
these options to specify how the value should be shown. 

Note: If the data element was defined in uDesigner with a specific 
decimal amount, it will override any decimal amount you specify 
here. 

Decimal Places

Use 1000 
Separator(,)

Negative Number 
Format

Display Mode Use this option to hide or display this field on the sheet. 

Total

If you created a formula or query to calculate the values for this 
column, you can specify: 

 Blank to leave the total of this column blank. (Choose "blank" 
for percentage columns and other columns where it does not 
make sense to display a total.) 

 Sum of All Rows to display the sum total of all the column 
values. 

 Use Formula Definition to display the total; that is, the same 
formula will be applied to the total that was applied to all the 
values in this column. 

Average

If you created a formula or query to calculate the values for this 
column, you can specify: 

 Blank to leave the average of this column blank. (Choose 
"blank" for percentage columns and other columns where it 
does not make sense to display an average.) 

 Avg of All Rows to display the value as an average of all the 
rows’ values. 

Column Position 
After

Use this field to specify where the column should appear on the 
sheet. 

Add a column based on a formula calculation 

If you choose Formula as the data entry method, you can create a numeric, a "date add," or a 
"date difference" type of formula to automatically calculate the values for the fields in the column. 

The numeric formula option is only available if the data source you specify has been built on the 
SYS Numeric Logical Datasource data definition. 

A "data add" formula takes the value from a date field and adds the value of another field to it. 
This option is only available if the data source you specify has been built on the SYS Date 
Logical Datasource data definition. 
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A "date difference" formula takes the value from a date or date field and subtracts it from the 
value in another date or date field. This option is only available if the data source you specify 
has been built on the SYS Numeric Logical Datasource data definition. 

To create a numeric formula for a column 

1) In the Data Source field, choose the field that contains the value you want to include in this 
column. 

2) In the Entry Method field, choose Formula and click the Create button. The Formula 
Creation window opens. 

3) In the Data Type field, specify where the field comes from—a planning item, or the planning 
sheet. The Formula Creation window opens, showing a list of the fields from the data type 
you selected. 

4) Create the formula using the field values in this data source, or field values and numeric 
operators, such as add, subtract, or multiply. 

5) Click OK. 

To create a "date add" formula for a column 

1) In the Data Source field, choose the field on the sheet that should show the value you are 
calculating here. 

2) In the Entry Method field, click Formula, then click the Create button. The Create Formula 
window opens. 

3) In the Date field, select the field to which you want to add another value as follows. 

a. Click the Select button. The Date Element Picker window opens. 

b. In the Data Type field, specify where the date field you want to add to comes from—a 
planning item, or the planning sheet. Unifier displays a list of the fields on the planning 
item form, or the planning sheet. 

c. Select the field and click OK. 

4) In the Add field, select the field that contains the value you want to add to the field. 

5) Specify whether the calculation should be based on calendar days or work days. 

6) Click OK. Unifier displays the formula on the Column Properties window. 

To create a "date difference" formula for a column 

1) In the Data Source field, choose the field on the sheet that should show the value you are 
calculating here. 

2) In the Entry Method field, click Formula and select Date Difference from the list. 
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3) Click the Create button. The Date Difference window opens. 

4) For the Earlier and Later Dates, you can use either the last date the Planning Sheet was 
updated, or you can choose another field from the sheet or a planning item to supply the 
date value. 

5) In the Calculation based on field, specify whether the calculation should be based on 
calendar days or workdays. 

6) If you want the value in include fractions of days, select the Show Partial Days check box. 

7) Click OK. 

Add a column based on a database query 

If you choose Query as the data entry method, use these instructions to add a column to the 
Planning Sheet that will contain values extracted from the database. These values will be 
retrieved from the database only if they meet the conditions you specify. (In operation, you will 
be extracting data from the database and testing it to determine whether or not it should be 
included in this column.) 

The Query option is only available if the data source you specify has been built on one of the 
following data definitions: 

 SYS Numeric Datasource

 SYS Date Datasource

To create a query 

1) In the Data Source field, choose the field on the sheet that should show the value you 
retrieve from this query. 
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2) In the Entry Method field, choose Query and click the Define button. The Query Definition 
window opens. 

3) In the Data Type field, select the functional area of Unifier the data should come from. 

This field is the first step in describing where the data resides in the database. For example, 
the data type could be a Cost BP, a fund allocation request, or a cash flow. 

4) In the Datasource field, click the Select button. The Formula Creation window opens, 
showing a list of the fields from the data type you selected. 

You can drill down into the data type for other data sources if you wish by clicking the arrow 
beside this field and selecting other data source areas. 

5) (Optional) Create a formula using the field values in this data source, or field values and 
numeric operators, such as add, subtract, or multiply. Click OK to return to the Query 
Definition window. 

6) Specify the query condition as follows: 

a. Click Add. The Query Condition window opens. 

b. In the Data Element field, click Select to open the Data Element Picker. 

c. In the Data Source field, select the functional area of Unifier the data should come from. 
Unifier displays a list of the fields from the data source you selected. 

d. From the list, select the field that contains the value you want to place conditions on and 
click OK. 

 If the value meets the condition you specify, it will be included in this column on 
the sheet. 

 If the field you select is a date field, Unifier will display an additional field, 
Timescale Units, in which you will need to specify the option that matches the 
column definition. For example, if the column is a yearly budget, you would select 
Years. If the column is to show a quarterly value, you would select Quarters. 

e. In the Condition field, select the condition the value must meet to be included on the 
Planning Sheet, such as equals, or does not contain. For example, the value in the data 
element must equal 10, or the value in the data element must not equal (i.e., "is not") 
Yes. 
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f. In the Values field, enter the value you want to test the condition on (or select the value 
from the list that appears when you click the Select button).  
The Select button may or may not appear, depending on the data element you choose. 
For example, for a data source of "Business Process/Status," you could choose a status 
from the list of statuses associated with that BP. This would limit the column data to 
business process records of that status. 

g. Click OK. 

7) On the Query Definition window, click OK. 

Create a planning column group 

This allows you to group columns together and assign a group name, which is displayed on the 
planning sheet above the columns. Columns in a group must be contiguous. 

Note: If you need to add a column to an existing group, first ungroup the 
existing columns, then create a new group to include the new column. 

To group planning sheet columns 

1) Select Columns. Columns must be contiguous, and cannot belong to more than one group. 

2) Click Group Columns > Group. The Edit Column Groups window opens. 

3) Name the group and click Ok. Group names must be unique. The Group Name will appear in 
the planning sheet log and also on the Planning Sheet above the columns. 

To add or remove columns to the group 

1) Ungroup the columns. 

2) Select a new group of contiguous columns. Add or move columns as necessary. 

3) Group the new columns. 

To change the group name 

1) Select any column in the group. 

2) Click Group Columns > Group. 

3) Enter a new Name and click OK. 

To ungroup columns 

Select grouped columns and click Group Columns > Ungroup. Ungroup will remove group 
name from all columns that are part of that group. 

Edit Planning Sheet Properties 

You can edit the properties in individual planning sheets or the default structure. 

To edit planning sheet properties 

1) Open the planning sheet or default structure. 

2) Click File > Properties. The Properties window opens. 
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3) Complete the General tab: You can enter or change the Name of the sheet, and add an 
optional Description. 

4) Click the Options tab: 

 Sort by Column: Choose the column to sort the planning item rows by. The default is 
Name (planning item name). As you add additional columns to the sheet, these columns 
will be available to select. 

 Sort Order: Choose Ascending or Descending; works in conjunction with Sort By 
Column. 

 Update Planning Items: When this checkbox is selected, it allows planning sheet users 
to manually edit planned item data. This helps to prevent conflicting data from multiple 
planning items. 

This box can be checked on only one sheet per Planning Type. When this box is checked, 
the sheet is moved to the top of the log, and displayed in bold font, thereby acting as a 
master planning sheet. 

5) Click OK. 

Configuring the planning type 

Configuring a planning type makes it active in Unifier, gives it a numbering sequence for the 
records, and specifies an optional Help file and hard copy layout for printing. 

To configure a planning type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Planning Manager in the left Navigator. Each planning type will be 
listed here. 

3) Select a planning item and click Open (or double-click). The Planning Configuration window 
opens. 

4) Complete the General tab: 

 Sequence Format: This will define how planning item records will be numbered under 
this Planning type. 

 Help File: This will allow user to upload a PDF file as help file for Planning Item. This file 
should be available from Planning Item log window and individual planning item record. 

 Status: This defines if this planning type is active or not. If it is not active then it will not 
be visible under User Mode in Unifier even if a user has permission to access it. 

5) Complete the Custom Print tab: You can create a custom printout of planning types. This is 
similar to creating a Create Custom-Designed BP Print Layout (Custom Print tab) (on 
page 223). 

6) Click OK. 

Deleting a Planning Manager 

This section describes how to manually delete a Planning Manager from a shell.  

Note: You can delete a Planning Manager from a specific shell template 
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but not from other Projects/Shells that have been created using the 
template. 

In Administration mode: 

1) Open the project or shell and in the left navigation pane, click Setup > Planning Manager. 

2) Select a Planning Manager for deletion. 

3) Click Delete. 

Note: System prompts the user asking to confirm deletion of the 
Planning Manager. 

4) Click Yes to delete the record from the Planning Manager. 

Configuring Planning Manager Configuration Package 

The following configurations can be included in the Planning Manager Configuration Package:  

 General setup 

All the fields included in the General Configuration (General tab) 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the BIP Custom Print in the Custom Prints and Reports. 

 Default structure  

The default structure of the Planning sheet. 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 

Granting planning setup permissions 

Once you have created a default sheet structure and activated the planning type, you need to 
grant yourself and other users setup permission to the Planning Manager. 

To grant setup permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator to open the Access Control log. Navigate as 
follows: 

 For a Planning Manager at the company level, navigate to User Mode Access > 
Company Workspace > Planning Manager. 

 For a Planning Manager at the project of shell level, navigate to Shells/Projects 
(Standard) > Setup > Planning Manager. 

3) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

4) Click the Add Users/Groups button. The User/Group Picker opens. 
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5) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

Unifier adds the name(s) to the Permission/Access Control window. 

6) Under Permission Settings, select Setup and click OK. Unifier adds the name(s) to the 
Permission Settings window. 

7) Click OK. 

Loading the Planning Manager 

Loading the Planning Manager is part of setting it up. In this step, you will be loading the 
manager into the area where it should reside—the company workspace (Company Workspace 
tab), a shell, or a standard project. 

When you load the Planning Manager, you also load the permission infrastructure and the ability 
to grant permissions for the manager. 

To load the Planning Manager 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, navigate to one of the following: 

 To load the Planning Manager into the company workspace, click Company Workspace 
> Planning Manager in the left Navigator. 

 To load the Planning Manager into a shell, open the shell or sub-shell into which you 
want to load the Planning Manager. Click Setup > Planning Manager in the left 
Navigator. 

3) Click New. The New Business Processes window opens, showing the Planning Managers 
that are available for loading. 

4) Select the planning manager you want to load and click OK. Unifier displays the manager in 
the right pane. 

Granting User Permissions 

Once you have loaded the Planning Manager into the company workspace, or the shell, you 
need to grant user permissions to the Planning Manager. 

To grant user permissions 

1) Open the shell or sub-shell in which the Planning Manager resides. In Administration mode, 
click Access Control in the left Navigator. 

2) In the right pane, under Administration Mode Access, click Access Control. 

3) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

4) Click the Add Users/Groups button. The User/Group Picker opens. 

5) Select the user(s) to whom you want to give permissions and click the Add button. Then 
click OK. Unifier adds the name(s) to the Permission/Access Control window. 

6) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. Unifier adds the name(s) to the Permission Settings window. 



Setting up the Planning Manager

497

7) Click OK. 

8) In the right pane, under User Mode Access, click Planning Manager. 

9) For both the planning items and planning sheets, repeat steps step 3 through 6. 

Master Log - Planning Items for the Planning Manager 

The master log (Master Log - Business Processes node) is located in the Home page, in 
Unifier. The master log enables users to access all or a subset of records of the same type, in a 
single log that spans multiple shells or projects. The master log for Planning items list all 
Planning item types at the shell/project level in separate nodes for each type.  

Note: The name of the master log (Master Log - Business Processes
node) can be customized. 

The master log is available for all Planning Manager logs; however, they are not visible to users 
unless they have permission to view the log. 

Note: The company-level planning items are not listed under the master 
log. 

In order for users to view and work with the master log (Master Log - Business Processes
node), you must grant permissions to it. You can grant permissions for users to access all 
planning items in the master log, or to individual planning items. 

To view planning items, users must also: 

 Be an active member of the project, shell, or sub-shell 

 Have access to at least one business process in the master log 

To set permissions for planning items master log (Master Log - Planning Items node): 

1) Click the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select User Mode Access > Home > Master Log - Planning Items > 
[planning item]. 

4) Add the user(s) and set the permissions as needed: 

 View: Users can view all records across all projects and all records in the shell hierarchy 
(subject to their highest level of shell membership in the hierarchy) independent of 
whether or not they are assignees on or have permissions to view and manage individual 
records within a particular shell or project. These users can also view saved searches. 

 Allow Bulk Edit: Users can select one or more records within a master log and perform 
bulk edits on records. Selected records can potentially span across multiple shells. Users 
having this permission automatically have View permissions. 
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Setting up the Portfolio Manager 

The Portfolio Manager is where the budget forecast planners in your company can gather cost 
and schedule information on projects (both planned and in execution) and perform analyses on 
"what if" scenarios. These scenarios are used to propose an optimal mix of projects for a 
portfolio, based on available budget targets and the strategic goals of the company. 

Portfolio planners can create a portfolio for a specific "planning horizon" (for example, from 2014 
through 2020) and then create multiple scenarios in that portfolio. Each scenario can use 
forecast numbers and actuals, as well as schedule dates, for both planned and active projects in 
a specific shell type across a hierarchy in the company. 

Budget forecast planners create these scenarios on sheets, one for each scenario. The scenario 
sheets can pull in the following data from any shell type in a hierarchy: 

 Project information from the shell attribute form or single-record business process 

 Project start and end dates from the shell attribute form or single-record business process 

 Cash flow data (both forecasted and actual) from each project’s Cost Manager 

With this data, you can forecast costs over a specific time period (called a "period structure"). 
You can then manipulate scenarios by: 

 Including or excluding projects 

 Pushing start dates for planned projects into the future 

 Modify project end dates to change the project’s duration 

 Proposing different cash flow distribution numbers by manually editing the cash flow columns 

 Negotiating proposed budgets with project managers 

Note: The numbers the planner proposes in a scenario will NOT affect a 
project’s live data. The proposed numbers are stored only in the Portfolio 
Manager and will not affect live project data until a scenario has been 
approved by your company management. 

Once these scenario analyses have been completed, the best (or several best) scenario(s) can 
be sent to the executive decision makers for approval. 

Once a scenario has been approved, Unifier: 

 Marks the approved scenario "shared" so that project managers can see the approved dates 
and numbers. The scenario is set to read-only mode and can no longer be modified or 
deleted. 

 Updates each project's original budget numbers with the proposed numbers on the approved 
scenario. 

 Updates each project's monthly or yearly cash flow numbers with the proposed numbers on 
the approved scenario. 

 Updates the project start date (if it was changed) for any planned projects that will begin 
during the portfolio’s planning period. 

 Locks the budget and cash flow numbers to prevent any further changes. 
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To set up the Portfolio Manger 

Before you begin: A portfolio attribute (detail) form is designed in uDesigner and deployed to 
Unifier.  This attribute form is what you and other users will use to create new portfolios in 
Unifier. 

Step 1: Design the Portfolio Manager attribute form in uDesigner and deploy to Unifier. This is 
similar to any other design deployment in uDesigner. 

Step 2: Grant yourself permissions to configure the portfolio and create period structures. See 
Create Period Structures (on page 501). 

Step 3: Create period structures under the Standards & Libraries node. Primavera Unifier 
uses these period structures to calculate costs for the portfolio’s forecasted budget. See Create 
Period Structures (on page 501). 

Step 4: Configure the portfolio. 

Step 5: Grant Portfolio Manager permissions to users. 

Once you have completed these steps, the Portfolio Manager is ready for use in Primavera 
Unifier’s User Mode. 

In This Section 

Import a Portfolio ................................................................................................... 500 
Grant Yourself Permissions ................................................................................... 500 
Create Period Structures ....................................................................................... 501 
Configuring the Portfolio Manager ......................................................................... 503 
Configuring Portfolio Manager Configuration Package .......................................... 509 
Delete Columns From a Sheet .............................................................................. 510 
Grant User Permissions ........................................................................................ 510 
Templates (Shell Attribute Form) ........................................................................... 510 

Import a Portfolio 

To import and deploy a portfolio manager into Unifier Production environment, see Importing 
Configuration Packages (on page 640). 

Grant Yourself Permissions 

When you import a new portfolio, you must grant permission (to yourself, another administrator, 
or group such as Company Administrators) to configure the portfolio and set up period structures 
in the Standards & Libraries. 

To grant configure permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, select Administration Mode Access > Configuration > All > Portfolio 
Manager. 
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4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. 

Unifier adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Configure and click OK. 

Unifier adds the name(s) to the Permission Settings window. 

8) Click OK. 

To grant permissions to create period structures 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, select Administration Mode Access > Standards & Libraries > Period 
Structure. See Create Period Structures (on page 501). 

4) In the Module Permission Settings window, click the Add button. The Permission/Access 
Control window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give configuration permission and click the Add
button. Then click OK. Unifier adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select Create and click OK. Unifier adds the name(s) to the 
Permission Settings window. 

8) On the Permission Settings window, click OK. 

Create Period Structures 

Each portfolio needs a defined period of time in order to be able to calculate costs for the 
forecasted budget. Creating a period structure designates the time scale for the period, the 
format the period should appear in at runtime on the period picker, and whether or not the period 
is active (available for use at runtime). 

Once you have created a period structure, it cannot be deleted. In addition, once a period is in 
use in a deployed Portfolio Manager, it cannot be modified or inactivated. 

To create a period structure 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Standards & Libraries > Period Structure in the left Navigator. 

3) Click New. The Period structure window opens. 

4) Use the information in the table below to complete the fields in the Period Structure window. 

5) Click OK. 

In this field: Do this: 

Period 
Structure 

Enter a name for the period structure. 
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Description 
Enter a description of this period. This is not mandatory, but is 
recommended. 

Status Specify whether this period is active (available for use) or inactive. 

Period Type

"Standard Planning Period" & "Financial Periods"  

For Financial Periods below Period Settings, options will be disabled and 
new Table with Financial Period will appear. 

Period 
Settings 

Specify the time scale for this period. 

Period: Select the time period for the analysis. This list shows years, 
each beginning with a month in the year and ending at the end of the 
month preceding the beginning month. 

Identify Period By: Use this option to accommodate time periods that 
span across two years. For example, if your fiscal planning period is from 
July 2010 to June 2011, use this option to tell Unifier that the planning 
year is based on either a starting month of July or an ending month of 
June. 

Format: Specify the format the date should appear in: 

 For Year, YYYY or YY 

The Period Structures support financial periods, while keeping the current period structures 
intact. The following period types enable the user to create financial periods, in separate tab:  

 Standard Planning Period 

 Financial Periods 

The user can toggle between the period type until saving the Period structure. Once the user 
creates the financial period, and uses it (Shell options or PPM configuration), then the user will 
not be able to delete or modify the financial period. 

The following explains the options:  

Option Description 

Add
Enables you to create a new default row, in the grid below starting from 
today date with end date, as weekly. You can modify the data. 

Remove To remove a row in the grid. 

Generate
Opens a window and enables you to select start and end dates and 
generate group of data. 

There is no gap between the end date and start date for two consecutive periods, while creating 
sub periods. 

The following explains the columns present in the auto generated periods: 

Column Description 

No. The sequence number for the sub period being generated. 

Period Every sub period will have a name automatically assigned to it based on 
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Name the start date. For example, if the sub period start date is 01/08/17, then 
01/08/17 will be the period name. 

Start Date Sub period start date. 

End Date Sub period end date. 

Year Financial year for sub period being generated. 

The date format will depend on the selection made in the User Preferences. 

The following is an example of Financial Period, where: 

No.: The number of Sub Period 

Sub Period Name: Monthly 

Identify Date by: Period Start 

Date: "01/09/17" (It can be any date and not just the start date for the week, month, quarter, etc.) 

No. Sub Period 
Name 

Start Date End Date Year 

1 1-Sep-17 1-Sep-17 30-Sep-17 2017 

2 1-Oct-17 1-Oct-17 31-Oct-17 2017 

The Year will be the year for the start date of first financial period until it reaches the same date 
next year (completes 365 days). Then it will move to next financial year. 

Use the Export option to export data in all of the columns. 

Configuring the Portfolio Manager 

Configuring a portfolio means configuring the scenarios that will be analyzed in a portfolio. By 
configuring a scenario, you create a "template" for the sheets that planners can use to create the 
scenarios for analyzing and forecasting capital budgets. 

The template will contain: 

 The planning options for the scenario sheet, such as the period structure and data linking 
options 

 Project phases that identify a project as planned or in execution 

 The data sources to be used for the analysis, such as project dates and cash flow sources. 

 The query that will extract the project data that should be included in the portfolio 

 The column layout that will appear on the scenario sheet 

To configure: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Portfolio Manager in the left Navigator. Each portfolio will be listed 
here. 

3) Select a portfolio and click Open (or double-click). The portfolio Configuration window 
opens. 

4) Enter values in the fields of the following tabs as explained below. 
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General tab 

1. Use the following table to enter values in the fields: 

In this field: To this: 

Status Specify whether this portfolio is active (available for use) or inactive. 
When you activate a portfolio, Unifier loads it into all shells, but it will 
not be available to users until you grant user permissions to it. (See 
Grant User Permissions.) 

Include Projects 
of Type 

Specify the shell type that contains the project data that should be 
analyzed. The list will show all multiple-instance CBS shell types 
from any hierarchy, and data from all shells of this type will be used 
in the analysis. 

Additional 
attributes from 

The portfolio will automatically include data from the portfolio 
attribute (detail) form; however, you can also include information 
from single-record business processes, if they are appropriate. If 
there is a single-record business process that contains information 
that you want to include in this portfolio, select the name of the 
record you want to include. 

Yearly Planning Fields that specify the following requirements. 

Period Structure Specify the time period this portfolio should use. These period 
structures were created under the Standards & Libraries node after 
the portfolio was imported. The option shows what the period is 
(yearly, quarterly, or monthly) and the format in which the period will 
appear on the Period Structure Picker at runtime. 

Planning Phases If you are including planned projects, you need to specify what 
phases of these projects you want to include in the analysis for this 
portfolio.  

Select the planning phases whose data should be used in the 
portfolio analysis. You can select multiple phases. 

Projects added 
to a scenario are 
initially 

As the administrator, you can specify that projects in a portfolio are 
linked or unlinked to project data when the user first opens the 
scenario sheet. Once the scenario sheet is open, the user can 
choose to link or unlink the projects as appropriate. 

Linked: This option links the project data to the project database 
and updates the data in the portfolio every time the user opens a 
scenario sheet. 

Unlinked: This option unlinks the project data from the database. 
Select this option if you do not want the project data dynamically 
updated. 

Project Data 
Sources 

Specify where the data should come from for the portfolio. In this 
option, you will be choosing the data elements that will provide the 
values for the scenario analyses. 
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In this field: To this: 

Start Date Select the name of the field (data element) that contains the project 
start date. The elements you see on this list come from the project 
attribute form and any single-record business process you included. 

Update project start date upon approval

Select this check box if you want to update a planned project’s start 
date on the attribute form when a scenario is approved for the 
current budget. The approved scenario may contain an adjusted 
start date. If the start date is adjusted on the scenario, Unifier will 
change the date on the project’s/shell’s attribute form to reflect the 
new date. If the Schedule sheet properties are configured to drive 
the schedule start date from the project/shell attribute form, the form 
will then update the start date on the Schedule sheet. 

End Date Select the name of the field (data element) that contains the project 
end date. The elements you see on this list come from the project 
attribute form and any single-record business process you included. 

Budget Source Select the budget source that should be used in the analysis. This 
budget source was defined under Standards & Libraries > Cash 
Flow. 
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In this field: To this: 

Forecast Source Select the forecast source that should be used in the analysis. This 
forecast source was defined under Standards & Libraries > Cash 
Flow. 

If the value of the Forecast Source is Forecast, then the Display 
monthly breakdown of Actuals option is available for you to 
select.  

You have the ability to show monthly breakdown of Actuals by 
selecting the checkbox. 

 If the checkbox remains unchecked, then for the current year the 
existing functionality for the Portfolio Manager will be maintained.  

 If the checkbox is checked, then the user will be able to the see 
the monthly breakdown for Actuals, and the values displayed 
would be read-only for months prior to the current month for the 
current year. 

By default, the checkbox will be unchecked. 

Select the data source according to your business case. 

The curves of the selected data sources must have the same 
currency. 

Portfolio Manager Configuration for Derived Curve

When the user selects the forecast source as a Derived Curve, in 
Portfolio Manager: 

Once the configuration takes place, in User mode, the Portfolio 
Manager scenario sheet synchronizes with CashFlow and displays 
the data through a Derived Curve. 

The user has the ability to show monthly breakdown of actuals by 
selecting the checkbox to display the monthly actuals. 

By default, the checkbox is unchecked. 

If the checkbox is unchecked in the Portfolio Manager configuration, 
then for the current year the existing functionality is maintained, for 
Portfolio Manager. 

Portfolio Manager Configuration for Label on Monthly Actuals

Use the checkbox "Display financial period breakdown of Actuals" 
for breakdown based on financial period. 

Additional 
Information 

Specify the list of users, and groups, who receive notification emails 
when a particular scenario is shared, or approved.  

Notify users or 
groups when a 
scenario is 
shared or 
approved 

Click Select to see a list of company-level users, or groups, and 
select one. 

Unifier sends the email notification to existing users, or groups, at 
the project-level, only. If selected recipients do not exist at the 
project-level, Unifier will not send any notifications. 

2. Click Apply, then click the Query tab. 
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If the financial period type of period structure is selected in the configuration General tab, then 
Unifier hides the following drop-down list items (under Planning horizon in columns tab) 
because: ]

 The number of years will be determined by the number of unique years in the sub periods for 
the financial periods. 

 The number of years planned in months will be same as the number of years planning with 
month as a sub period (the "Apply actuals to each sub period/month" checkbox). 

Query tab 

On the Query tab, you create a query that will search the database and extract the shell records 
to display on the scenario sheets in the portfolio. The query will filter the records returned from 
the database according to a condition or conditions you specify. The condition(s) will "test" a 
field or fields on the form to see if they pass or fail the criteria. If the fields pass the criteria, 
Unifier will make it available for the scenario sheets. 

The query that extracts the projects from the database is a dynamic process that occurs 
whenever users open a scenario sheet. The projects that appear on the sheet will fluctuate, 
depending on whether they still meet the criteria for inclusion. For example, a project that was 
previously on the sheet may be dropped from the sheet if it no longer meets the query criteria. 
Another project may be added to the sheet because it now meets the query criteria. 

The query will search the database and extract the shell records to display on the scenario 
sheet. The query will filter the records returned from the database according to a condition or 
conditions you specify. The condition(s) will "test" a field on the form to see if it passes or fails 
the criteria. If the field passes the criteria, Unifier will include it on the scenario sheet. 

1) Under Projects, select the Auto-add/auto-remove projects to and from the portfolio 
based on the query field if you want Unifier to automatically add and remove projects to and 
from scenario sheets. 

2) Create the query: 

The query will search the database and extract the shell records to display on the scenario 
sheet. The query will filter the records returned from the database according to a condition or 
conditions you specify. The condition(s) will "test" a field on the form to see if it passes or 
fails the criteria. If the field passes the criteria, Unifier will include it on the scenario sheet. 

a. Click the Add button. Unifier displays the Add Query Condition window. 

In the Data Element field, select the field on the attribute form, or single-record business 
process, that you want to test with the condition. For example, the condition might be that 
the status field on the shell attribute form must be "Active." 

The window expands to show an active Condition field and additional fields where you 
can specify the query criteria. 

b. In the Condition field, select the condition the value in the field must meet. 

c. Click OK. 

The remaining fields on this window vary, depending on the data element and the 
condition you specified. For help in completing these fields, use the information in the 
Queries section. 
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Note: If any field in the query or queries is subsequently removed from the shell or 
single-record BP design, the entire query operation will be ignored. That is, if one query 
fails because a field was removed from the design, Unifier will ignore all the queries. If a 
field has been removed from a design, you must amend the query. 

3) Repeat steps a through d to include additional query conditions. 

4) Click Apply, then click the Columns tab. 

Columns tab 

Use the following table to enter values in the fields: 

In this field: To this: 

Scenario 
Columns 

Specify what additional columns you want to appear on the scenario 
sheet. 

You can add the Project Phase Data Element (DE) to the Portfolio 
in order to see the latest value of Project Phase (Planning, 
Conceptual Design, Schematic Design, etc.) in the Portfolio as it 
changes (manually or via Gates) without having to take a manual 
step of saving a single record BP within a Shell. To add the Project 
Phase DE, go to the Configuration window, click Add, and from the 
Data Element drop-down list select Project Phase. 

Initial Sort 
Column 

Use this to specify the column by which the scenario sheet is initially 
sorted when the user opens the sheet. The user can change the 
column sorting. 

Sort Order Specify whether the projects on the sheet should appear in 
ascending or descending alphanumeric order. 

Freeze column 
up to 

This option affects the scrolling behavior of the scenario sheet. 
Scenario sheets contain certain columns that must always appear 
on the sheet. As administrator, you can add more columns to the 
sheet. Of these columns you add, you must specify that 1 of those 
columns must remain fixed when the user scrolls the sheet 
horizontally. 

Number of years 
planning 

Select the number of years to be included in this scenario. 

The default horizon is 10 years. This option designates the year 
columns that will appear on the scenario sheet. 

Number of years 
planned in 
months 

Specify how many years the planner wants to plan by months. For 
example, the planner may want to plan by month for the first two 
years; thereafter, by year. 

Users can define the column width for the Project Portfolio Manager (PPM) columns.  

Defining the column width can be done in the Column Properties window, when adding a new 
column in the Columns tab. The default value is set to 120 characters, and the user can change 
the value to a custom value. For the existing columns in Portfolio Manager (in the Configuration), 
the system sets the width to the default column width. The changes made in Configuration 
(Column width , Freeze column up to, etc.) remain in the new PPM. 
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You can edit the width for the following columns in the PPM configuration: 

 Project Name 

 Start Date 

 End Date 

Configuring Portfolio Manager Configuration Package 

The following configurations can be included in the Portfolio Manager Configuration Package: 

 General setup 

All the fields included in the General Configuration (General tab), including: Yearly Planning 
and Project Data Sources. 

Note: Cash Flows that have been selected in the Budget Source and 
Forecast Source fields are included in the Configuration Package. If data 
sources do not exist in the destination environment, the system will 
create the data sources. 

 Query 

All queries that have been configured based on data sources. 

 Columns structure 

The structure of the Column that has been defined in the Columns tab. 

You can include the portfolios that you want to include in your configuration package. To include 
a Portfolio: 

1) Go to Company Workspace tab > Admin mode > Configuration Package Management > 
Component Catalog > Configuration > Designs > Portfolio Manager. 

2) Select the required portfolio. 

3) Name the component list. 

4) Conduct an Error Check. 

5) Click Save. 

6) Go to Company Workspace tab > Admin mode > Configuration Package Management > 
Configuration Packages > Create. 

7) Select your portfolio manger from the Component Lists. 

8) Enter values in the Package Name and File Name fields and click Next to see the preview. 

9) Click Next and review the contents. 

10) Click Next. 

11) Click Create. 

Note: For a successful inclusion of a portfolio, the shell and 
single-record business process must be a part of the Configuration 
Package. 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 
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If the user selects a Portfolio Manager, then the financial period selected in the configuration is 
included in the Configuration Package.  

Updated Cash Flow and Shell Templates are available for the Configuration Package, also. 

Delete Columns From a Sheet 

You can delete columns from a sheet from either the Portfolio Configuration window, or the 
Column Properties window. 

To delete columns from the Portfolio Configuration window 

1) Click the Columns tab. 

2) In the Scenario Columns section of the configuration window, select the name of the column 
and click the Remove button. 

To delete columns from the Column Properties window 

1) Click the Columns tab. 

2) In the Scenario Columns section of the configuration window, click the Modify button. The 
Column Properties window opens. 

3) Click the Delete button to delete the column. 

Grant User Permissions 

Once the Portfolio Manager is active in a shell, you need to grant user permissions to the 
Portfolio Manager. 

To grant user permissions 

1) Open the shell where the Portfolio Manager resides and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) In the right pane, under User Mode Access, click Portfolio Manager. 

4) Click the portfolio. The Permission Settings window opens. 

5) In the Permission Settings window, click the Add button. The User/Group Permissions 
window opens. 

6) Click the Add Users/Groups button. The User/Group Picker opens. 

7) Select the user(s) to whom you want to give permissions and click the Add button. Unifier 
adds the name(s) to the Permission/Access Control window. 

8) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. Unifier adds the name(s) to the Permission Settings window. 

9) Click OK. 

Templates (Shell Attribute Form) 

In the Shell Attribute Form, Options tab, the user can select a financial period from the Financial 
Period picker. 
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The Financial Period picker has a list of all financial period type of period structures present in 
the Standards & Libraries (standards and libraries). 

The following explains the financial period in: 

 Shell 

 Cash Flow 

Shell 

Depending on the financial period selected at the Shell level, when the user tries to create a 
scenario under Portfolio Manager, the user will see the list of projects with the same financial 
period present in the respective Shell options, only.  

If the user has selected a financial period at the Shell level, then the selected option overrides 
the financial period coming from Portfolio Manager by way of configuration. 

The same selected financial period will also be used under Cash Flow curves, for the time scale 
of the financial period type. 

The user is able to change the financial periods when there are no cashflows associated with 
that financial period. 

Accordingly, when the Cash Flow is refreshed, it uses the new period structure. 

If the user selects a period from the period picker, in the Shell details window, then the selected 
period will be used across Cash Flow curves (if time scale type is financial period) and Portfolio 
Manager. 

Cash Flow 

The Portfolio Budget curves (Shared, Approved, and Original), in Cash Flow, are linked to 
Portfolio Manager scenarios.  

User can attain data from the Portfolio Budget curves (Shared, Approved, and Original), from the 
Portfolio Manager scenario in Parent Shell, into the Cash Flow curves within a Project/Shell. 

During a portfolio analysis, the Portfolio Manager can produce the following Portfolio Budget 
curves: 

 Shared Budget curve

The Shared Budget curve displays the portfolio planner's proposed number for the project. 

The User can include the Shared Budget curve on the Cost worksheet (along with the 
forecast budget or any other budget curve) in order to see the difference between the project 
numbers and the planner's proposed budget numbers. 

 Approved Budget curve

When a scenario is approved in the Portfolio Manager, the budgets for each project in the 
scenario are marked "approved." 

Unifier lock and stores the budgets in Portfolio Manager. 

An Approved Budget curve displays the approved budget for the project for the planning 
period (usually a year). 

 Original Budget curve
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The  Original Budget is the last approved budget for the project before it moves into its 
execution phase. 

The approved  Original Budget becomes the project original budget. This original budget 
(and any changes that occur to the numbers during the life of the project) becomes the 
project approved budget. 

The Portfolio Manager scenario (with Financial Period as the Period Structure) created in the 
parent Shell will push/pull the data from respective curve only. That is to say: 

 For the child Shell, it has the same Financial Period in its options, and 

 It will consolidate the data for only those Cash Flows where the timescale has been 
selected as Financial Period. 

If the user selects a financial period from the ‘by’ drop-down list, then the corresponding 
drop-down list for financial period will get populated with the Financial Period present in the 
Shell options. 

Other options, in timescale, will be disabled (for format and so forth), and it will remain blank 
with other options enabled (for format and so forth). 

For Baseline and Forecast type curves, the summary sheet spreads and schedule manager 
spreads will be assigned to the relevant period. 

For the Actuals, the cost sheet columns and effective dates will be used to assign the values 
to the relevant period. 

For a Cash Flow curve, the X-axis for graph will still remain the same but the points in the curve 
will be based on the Financial Period that has been selected. The columns in the grid will be 
based on the Financial Period that has been selected, also. 
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Setting up the Resource Manager 

The Resource Manager uses Resource Booking business processes and Timesheet business 
processes. The Resource Manager attribute form (used to create resources and roles) has to be 
deployed in uDesigner. 

In addition, Resource Booking and Timesheet business processes can be used with the 
Resource Manager (however, Resource Booking BPs are not available in generic shells). The 
Resource Booking is used for booking resources on the Booking Summary Sheet. When the 
record is approved, the resource is considered to be hard-booked. While the record is pending, 
the resource booking is considered to be soft-booked. One Resource Booking business process 
can exist at the company, project, or shell level. 

If a Resource Booking and a Timesheet business process have been designed and deployed in 
Unifier (to be used with the Resource Manager), then these business processes need 
configuration and setup. 

The Timesheet business process can be designed to roll up hours and costs from the time sheet 
to cost sheets. Required fields are the Resource picker (to pick the resource) and Week of 
(date). In addition to a Role picker and rate/hours fields, the time sheet detail form can include 
an Activity picker (to link the time sheet to a schedule sheet activity), Account Code picker (to 
link to the company accounts sheet), and Project picker (to link to a project). Only one time sheet 
business process can exist at the company level. However, multiple workflow schemas are 
allowed. 

Some of data elements and data definitions used with the Resource Manager need data set 
values. (See Adding and Managing Data Sets (on page 28).) Data definitions that will require 
data set values include: 

 SYS Resc Calendar NW Day Type 

 SYS Resource Proficiency 

 SYS Resc Work Type 

 SYS Resource Skill 

 SYS Resource Interest 

In This Section 

Set Up Resource Manager .................................................................................... 513 
Configuring Resource Manager at Company-level ................................................ 514 
Configuring Resource Manager Configuration Package ........................................ 515 
Creating Roles and Resources .............................................................................. 515 
Setting up the Resource Manager in Projects or Shells ......................................... 519 

Set Up Resource Manager 

The Resource Manager uses Resource Booking business processes and Timesheet business 
processes. 
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Before you begin:  Resource Manager attribute form is designed in uDesigner and deployed to 
Unifier.  

Step 1: Design  Resource Manager attribute form in uDesigner and deploy to Unifier. This is 
similar to any other design deployment in uDesigner. See Importing Configuration Packages
(on page 640). 

Step 2: Configure the Resource Manager at the company level. 

Step 3: Create or import roles and resources at the company level. 

Step 4: Set up the Resource Manager at the project level. 

Step 5: Set permissions at company and project levels. 

Step 6: (Optional) Define the project-level role based on allocation and Resource Sheet default 
values in the Resource Manager (Shell Templates > General Configuration). 

Step 7: Activate the Resource Manager to create the Resource Sheets at company and project 
levels (User Mode*): 

 Allocations Summary 

 Resource Allocation 

 Booking Summary 

 Actuals Summary 

 Utilization Summary 

 Bookings vs. Actuals 

 Availability 

Step 8: Set up the Resource Dashboard (User Mode*). 

Configuring Resource Manager at Company-level 

The Resource Manager can be configured at both the company level and the project or shell 
level. 

To configure the Resource Manager at the company level 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Resource Manager in the left Navigator. Resource Manager is listed 
in the log automatically. 

3) Select Resource Manager and click Open. 

4) Complete the Resource Manager General Configuration window as described in the 
following table and then click OK. 

In this field: Do this: 

Resource Code 

Choose one of the following: 

 Manual: Allows you to enter a resource code manually while 
defining resources. Validation is performed to ensure resource 
codes are unique. 

 Automatic: Automatic numbering generates unique resource 
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codes using a sequence. 

 Sequence Format: For automatic numbering, enter an 
alpha-numeric prefix for the resource code (e.g., RES). 

 Start: Enter a number to start the sequence. Numbers are 
generated from the start number in increments of 1. 

Resource Sheet 
Defaults 

These define default values for resource sheets. These values can 
be changed any time. Choose options for: 

 Timescale Unit: Options are day, week, month. Defines the 
default granularity for the display on all resource sheets at the 
company and project level. 

 Date From: Enter a default start date for the timeline display 
on all resource sheets at the company level. This default does 
not prevent entering transactions before this date. Actual start 
date of the timeline will be driven by the earliest applicable 
transaction date (for booking, assignment, allocation, etc.). 

 Date To: The latest applicable transaction date. 

Resource Booking 

 Allow over-booking of resources: The resource booking 
process will be allowed to overbook a resource (beyond the 
resource’s daily capacity). 

 Maximum Over-booking Percent: This field is enabled if the 
over-booking checkbox is selected. Enter any positive integer 
amount. If a value is not specified, there is no limit on 
over-booking. 

This information can be edited at any time. Changes will be 
reflected on subsequent bookings. 

Note: A resource can never be booked more than 24 hours on any 
day. 

Configuring Resource Manager Configuration Package 

The following configurations can be included in the Resource Manager Configuration Package:  

 General setup 

All the fields included in the General Configuration (General tab) 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 

Creating Roles and Resources 

You create roles and resources in Administration Mode in the Company Workspace tab. These 
can be used with the Resource Manager. 
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Create a role 

To create a role 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Resource Manager > Roles in the left Navigator. The Roles log opens. 

3) Click New. The Create Role window opens. 

4) Complete the General tab. 

5) Click Active when you are ready to activate the role and make it available to assign to a 
resource. 

6) Click the Rates tab. This allows you associate billable rates to a role. See Add a billable 
rate to a role (Rates tab) (on page 516). 

7) Click the Resources tab. This allows you to associate resources to a role. See Add 
resources to a role (Resources tab) (on page 516). 

Resources can be associated with roles from this tab, and also from the Roles tab in the 
Resources Properties. 

8) Click OK. 

Add a billable rate to a role (Rates tab) 

To add a billable rate to a role 

1) In the Create Role window, click the Rates tab. 

2) In the Currency Name field, click the Select button. Select the currency to use and click OK. 

3) Click the Add button. The Role Rates window opens. 

4) In the Roles window: 

 Define an effective date for the rate (click the calendar icon and select the date). 

 Enter a standard rate. 

 Enter an overtime rate. 

5) Click OK. 

Add resources to a role (Resources tab) 

To add resources to the role 

1) In the Create Role window, click the Resources tab. 

2) Click Add and choose a resource from the Resource picker. 

3) Click OK. 

Import roles 

Importing lets you add multiple new roles, or update attributes for existing roles. 
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To import roles 

1) In the Roles log, click the Export button. Save the CSV file. The CSV file columns 
correspond to the attributes on the role attributes form (General tab). 

2) Open the file and add roles as needed. 

3) Click the Import button and browse to the CSV file you saved. Import the file. 

Create a resource 

To create a resource 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Resource Manager > Resources in the left Navigator. The Resources log opens. 

3) Click New. The User Picker window opens, listing active and on-hold users from the sponsor 
company and active partner companies. 

4) Select a user and click OK. The Create Resource window opens. 

5) Complete the General tab. This tab may vary with the design of the resource attribute form 
you imported. Fields may include: 

 Resource Code: Automatically generated, manually entered, based on the configuration. 

 Resource Name: Enter a name to associate with the resource. 

 Description: Enter an optional description. 

 Status: The default is active. 

 Resource Capacity (Hrs): Enter the number of hours users can work in a day. Default 
value is 8. 

 Sunday (Hrs.).....Saturday (Hrs.): Depending on the design of the Resource Attribute 
form, these fields may or may not appear on the General tab. If they do, you can enter 
the number of hours the resource can work on each of these days. Unifier will use these 
values to calculate the resource’s Capacity per week. 

 Default Capacity (Hrs): Default value is 8. Number of hours a person can work in a day. 
This is overridden if the form was designed to include the Sunday through Saturday 
hours fields. 

6) Click the Roles tab. This lets you choose a role to associate with the resource. See Add a 
role to a resource (Roles tab) (on page 518)for details. 

7) Click the Skills tab. This allows you to associate one or more skills to a resource. See Add a 
skill set to a resource (Skills tab) (on page 518) for details. 

8) Click the Calendar tab. The calendar displays bookings, vacation days, etc. for the resource. 
See View and manage resource booking details (Calendar tab) (on page 518) for details. 

9) Click the Projects/Shells tab. The tab displays the projects/shells in which the resource is 
booked and booking specifics. See View resource project/Shell booking information 
(Projects/Shells tab) (on page 519) for details. 

10) Click OK. 
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Add a role to a resource (Roles tab) 

To add a role to a resource 

1) In the Create Resource window, click the Roles tab. 

2) Click Add, select a role from the Role picker and click Open. The role is added to the 
resource. 

To remove a role from a resource 

1) In the Create Resource/Resource Properties window, click the Roles tab. 

2) Select the role and click Delete. 

Add a skill set to a resource (Skills tab) 

To add a skill set to a resource 

1) In the Create Resource window, click the Skills tab. 

2) Click Add. Select a skill name from the drop-down list (defined for the data definition). 

3) Select the proficiency. 

4) Select the interest. 

To remove a skill from a resource 

1) In the Create Resource/Resource Properties window, click the Skills tab. 

2) Select the skill and click Delete. 

View and manage resource booking details (Calendar tab) 

You can view and manage booking dates, unavailable dates (non-project time, such as vacation 
days), and more. The range of dates and total booked hours for each project/shell gives the 
Resource Manager an idea of how long the project/shell engagement is for the resource. 
Hard-bookings and soft-bookings are displayed on the calendar. 

To view and manage the resource booking calendar and details 

1) In the Create Resource window, click the Calendar tab. The calendar displays bookings, 
vacation days, etc. for the resource. 

2) You can click the Month tab or Week tab to change the calendar view. A maximum of five 
projects/shells can be shown for any day in the month view. If a resource is booked for more 
than five projects/shells in a day, you can view them all in the week view. 

3) To view all projects/shells for any given day, select a day and click the Booking Details
button. 

The Resource Booking Details window opens. The window displays the project/shell 
bookings for that resource on the selected date. For each project/shell, it shows project/shell 
number, project/shell name, booking status, dates when the booking starts and ends, total 
hours booked for the resource during this period on the project/shell, and total hours booked 
on the current date on the project/shell. The dates and hours shown include non-project time. 
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4) To make a resource unavailable for booking on a certain date, select the date and check the 
Unavailable checkbox. You can click the drop-down list and select an option. 

 The range of dates and total booked hours for each project gives the Resource Manager 
an idea of how long the project engagement is for the resource. 

 Hard-bookings and soft-bookings for the resource are displayed on the calendar. 

View resource project/Shell booking information (Projects/Shells tab) 

To view project/shell booking information for a resource: 

In the Create Resource window, click the Projects/Shells tab. The tab displays the 
projects/shells in which the resource is booked and the following information: 

 Earlier Booking Date: Earlier date on which a booking exists for the project/shell for the 
current resource. 

 Latest Booking Date: Latest date on which a booking exists for the project/shell for the 
current resource. 

 Hard Booked Hrs.: Total hours resource is hard-booked on the project/shell. 

 Soft Booked Hrs.: Total hours resource is soft-booked on the project/shell. 

Import resources 

Importing lets you add multiple new resources or update attributes for existing roles. 

To import resources 

Importing lets you add multiple new resources, or update attributes for existing roles. 

1) In the Resources log, click the Export button. Save the CSV file. The CSV file columns 
correspond to the attributes on the resource attributes form (General tab). 

2) Open the file and add roles as needed. 

3) Click the Import button and browse to the CSV file you saved. Import the file. 

Update resource information by importing 

To update resources: 

1) Click Export. 

2) Complete the CSV file. 

3) Import the file. The import will support updating attributes of existing resources. You cannot 
add new resources through importing. Below is an example of a CSV file. 

Setting up the Resource Manager in Projects or Shells 

You can set up the Resource Manager in an individual project or shell, or in a project/shell 
template. The Resource Manager is available to both CBS shells and generic shells; however, 
some Resource Manager features are limited in generic shells. 



Unifier Modules Setup Administration Guide

520

Set up the Resource Manager in a project/shell 

Setting up the Resource Manager in a project or shell consists of choosing resource allocation 
options and resource sheet defaults. 

Note: Once you complete and save the Resource Manager setup 
information in a project or shell, the resource sheets will be created 
based on the options you choose. Once saved, you will not be able to 
change the allocation options. (You can change the resource sheet 
defaults.) 

To set up the Resource Manager in a project or shell 

1) Go to Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click: 

 Company Sponsored Project > [project] > Setup > Resource Manager to set up the 
Resource Manager in a project. 

 Company Sponsored Shell > [shell] > Setup > Resource Manager to set up the 
Resource Manager in a shell. 

3) In the right pane, select Resource Manager and click Open. The Configuration window 
opens. Complete the window as described in the following table. 

4) Complete the window as described in the following table. 

5) Click OK. 

In this field: Do this: 

Role Based 
Allocation 

Choose one of the following: 

Allocate via Resource Allocation Sheet at Company level: By default, 
allocations to this project will be done from the company level via the 
resource allocation sheet. Allocated roles will be pushed to the project. 
The project level resource allocation sheet will be disabled. Manual 
booking via the Booking Summary Sheet will be available, as well as 
booking edits. 

Allocate via Resource Allocation Sheet at Project/Shell level: When this 
option is chosen, allocations to this project or shell will be done via the 
project/shell-level resource allocation sheet. Role allocations will be 
initiated (pulled) from the project/shell. This project/shell will not be 
available to allocate from the company level. Manual booking via the 
Booking Summary Sheet will be available, as well as booking edits. 

No Allocation: Choose this option if the project/shell does not require role 
hours to be allocated. If you choose this option, the Allocation and 
Utilization Sheets will not be visible to the user, and Resource Booking 
BPs will not be available in the project/shell. Manual booking via the 
Booking Summary Sheet will be available, as well as booking edits. Note: 
This is the only option available to the Resource Manager in a generic 
shell. 

Resource These default values will apply to all resource sheets at the project level: 
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Sheet 
Defaults 

Timescale Units: Options are day, week, and month. These define the 
default granularity on all resource sheets at the company and project 
level. This value can be changed at any time. 

Date From: Enter a default start date for the timeline display on all 
resource sheets at the company level. This default does not prevent 
entering transactions before this date. Actual start date of the timeline will 
be driven by the earliest applicable transaction date (for booking, 
assignment, allocation, etc.). This value can be changed at any time. 

Date To: Enter an end date for the timeline display on all resource sheets 
at the company level. This default does not prevent entering transactions 
beyond this date. Actual end date of the timeline will be driven by the 
latest applicable transaction date (for booking, assignment, allocation, 
etc.). This value can be changed at any time. 

To edit the Resource Manager setup in a project or shell 

1) Go to Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click: 

 Company Sponsored Project > [project] > Setup > Resource Manager to edit the 
Resource Manager setup in a project. 

 Company Sponsored Shell > [shell] > Setup > Resource Manager to edit the 
Resource Manager setup in a shell. 

3) In the right pane, select Resource Manager and click Open. The Configuration window 
opens. 

4) You can edit the Resource Sheet Default settings. These changes will be reflected on the 
resource sheets for the project or shell. 

You cannot edit the Role Based Allocation settings. 

5) Click OK. 

Set up the Resource Manager in a project or Shell template 

In a project or shell template, you can set up the Resource Manager as you would within a 
project or shell. You can also set up a project/shell level resource allocation sheet if the 
Resource Manager configuration is set to allow allocations at the project/shell level. 

To set up the Resource Manager in a project template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project, click Projects (Standard) > [project]. 

 For a shell, click Shells > [shell]. 

Unifier displays the Template Log in the right pane. 

3) Double-click the name of the template in which you want to set up the Resource Manager. 

4) In the Navigator, click Setup > Resource Manager. 
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5) On the right pane, select Resource Manager and click Open. The Configuration window 
opens. Complete the window as described in the table in Set up the Resource Manager in 
a project/shell (on page 520). 

6) Complete the window as described in the table in Set up the Resource Manager in a 
project/shell (on page 520). 

7) Click OK. 

To set up a resource allocation sheet in a project/shell template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project, click Projects (Standard) > [project]. 

 For a shell, click Shells > [shell]. 

Unifier displays the Template Log in the right pane. 

3) Double-click the name of the template in which you want to set up the allocation sheet. 

4) In the Navigator, click Resource Manager > Resource Sheets. 

5) On the right pane, double-click the Resource Allocation sheet. The Resource Allocation 
sheet opens. 

Unifier automatically creates an allocation sheet when the Resource Manager is activated in 
the project/shell. 

6) To add resource allocations to the template, click the Add button. The Resource Allocation 
window opens. 

7) Complete the window: 

 Role Name: Click Select, choose a role, and click OK. 

 Date From: Click the calendar and choose the start date for the allocation. 

 Date To: Click the calendar and choose the end date for the allocation. 

 Allocated Hours: Unifier automatically calculates the allocated hours and displays them 
in this field. You can edit the hours, if necessary. 

8) Click OK. 

About Resource Manager sheets 

Default Resource Manager sheets are created automatically in User Mode when the Resource 
Manager is activated.  
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Setting up the Schedule Manager 

Here is the overall process for setting up schedule sheets in projects or shells: 

Step 1: Import and deploy the Activity Attribute form in uDesigner. If a configured schedule 
attribute form will be used, import it into Unifier. If a schedule attribute form has not been 
designed, Unifier will use a default attribute forms for the Schedule Manager and the activities. 

Note: Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

Step 2: Set customer calendar permissions, if necessary. 

Step 3: Create a schedule sheet template. There are two places where you can create schedule 
sheet templates: At the company-level, under Templates > Schedule Sheets; and in project/shell 
templates. The process for creating schedule sheets is similar in both types of templates. 

Note: The advantage of creating schedule sheets in a project/shell is 
that when you clone a project/shell template, you can copy all schedule 
sheets in that template. 

Once you have completed these steps, the Schedule Manager is ready for use in Unifier’s User 
Mode. 
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Additional Options for Setting Up the Schedule Manager 

Configure a project/shell template schedule sheet as a Master Schedule Sheet. After cloning 
the project/shell, you can use the Master Schedule Sheet to create other schedule sheets in 
the project/shell that have the same sheet properties, including start and finish dates. 
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 Link schedule sheets in a project/shell template to project/shell schedule sheets. 

 Configure data mapping to allow direct importing of external sources such as Microsoft 
Project or Primavera schedules. 

 Create program level schedule sheets. 

Note: Many of the tasks you might perform as Administrator can also be 
done at the Unifier user level. The tasks you can perform only at the 
Administrator level are completely described in this chapter. For those 
activities that overlap levels, Refer to the Unifier User Guide for detailed 
instructions. 

Importing an Activity Attribute Form 

The Schedule Manager needs attribute forms to define the activities for a project schedule, 
including its start and end dates. 

When creating new activities on the schedule sheet, Unifier opens this form as the General tab 
of the Activity Properties form. 

Note: If there is no attribute form for the Schedule Manager, Unifier will 
create a default schedule sheet with the following columns: ID, Activity 
name, Start date, Finish dates, and Duration. 

The Resource Manager and the Schedule Manager can work together for resource 
management. If you have deployed the Resource Manager, Unifier uses the Resource 
Assignment Attribute form as the Resource tab of the Activity Properties form. 

To import and deploy a schedule attribute form or a resource assignment attribute form into 
Unifier Production environment, see Importing Configuration Packages (on page 640). 

Create Schedule Sheet Templates 

There are three locations for schedule sheet templates in Unifier: in company Templates, in a 
project template, or in a shell template. Project and shell schedule sheet templates are copied 
into a new project or shell during cloning, provided you selected Schedule Sheets in the cloning 
window. 

The creation steps are similar for any schedule sheet template; however, Activity Properties in 
the company-level template only allow you to set up the General and Dependencies tabs. In 
project or shell schedule sheet templates, you can set up all properties. 

To create a schedule sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

 For a company-level template, in the left Navigator, click Templates > Schedule Sheets. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shelltemplate] > Schedule Manager > Schedule Sheets. 
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2) To create the schedule sheet for the template, use the instructions on creating a schedule 
sheet in the Unifier User Guide, Create a project or shell cash flow sheet in Cash Flow. 

The Schedule Sheets can be created by using templates at the company-level. 

Conditions for Creating a Schedule Sheets setup Configuration Package 

When the Setup information is packaged for the first time, then the Schedule Attribute and the 
Resource Assignment attribute designs must also be included in the configuration package.  

This means that the design must be included in the Configuration Package. If this check fails, 
then the package creation will result in an error. 

For subsequent exports, check will be made to ensure that the design which uses the Data 
Element that is specifically used in the setup is present in the Published package. As long as 
this condition is met, the package creation will be successful. If not, the latest design will have to 
be included in the configuration package. 

Schedule Sheets Components in the Configuration Package 

The system includes the following components of Schedule Sheets in the Configuration 
Package (.zip file): 

Component Field / Option 

Schedule Sheet 
Properties/ General 

All fields. Custom calendars should also be included in the 
configuration package. 

Schedule Sheet 
Properties / Gantt Chart

All fields  

Schedule Sheet 
Properties / Tracking 
Gantt 

All fields 

Schedule Sheet 
Properties / Options 

All fields 

Schedule Sheet 
Properties / Schedule 

All fields 

Schedule Sheet / 
Activities 

No activity related information will be packaged, meaning no 
rows will be included. 

<Schedule Sheet 
Name> / Scope 
Management Setup 
(Applicable for shell 
templates) 

No Scope setup will be brought over since the scope is tied to 
an activity.  

Schedule Sheet / Data 
Mapping 

All fields. Dependency checks for inclusion of Schedule 
Attribute and Resource Assignment forms will be performed 
to see if the relevant designs are part of the package.  
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Component Field / Option 

Schedule Sheet / 
Budget and Progress 
Setup 

All applicable options 

Schedule Sheet / 
Column 

All columns defined in the sheet. If column definition is based 
on Cost Sheet definition then the Cost Sheet also must be 
included. If cost sheet column does not exist, then an error 
will be displayed. 

Deleting Schedule Sheets 

This section describes how to manually delete a schedule sheet from a shell.  

Note: You can delete a schedule sheet from a specific shell template but 
not from other Projects/Shells that have been created using the 
template. 

In Administration mode: 

1) Go to Company Workspace tab, open the project or shell and in the left navigation pane, 
click Templates > Shells > {Shell Type} > {Shell Template} > Schedule Manager >
Schedule Sheets. 

2) Select a sheet for deletion. 

3) Click Delete. 

Note: System prompts the user asking to confirm deletion of the 
Schedule sheet. 

4) Click Yes to delete the schedule sheet. 

Grant Schedule Manager and Custom Calendar Permissions to Users 

Once the Schedule Manager is active in a shell, you need to grant user permissions to the 
manager and the custom calendars. 

To grant user permissions to the Schedule Manager 

1) Open the shell where the Schedule Manager resides and switch to Admin mode. 

2) In the left Navigator, click Access Control. 

3) In the right pane, under User Mode Access, click Schedule Manager. The Permission 
Settings window opens. 

4) In the Permission Settings window, click the Add button. The User/Group Permissions 
window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 
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6) Select the user(s) to whom you want to give permissions and click the Add button. Unifier 
adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. Unifier adds the name(s) to the Permission Settings window. 

8) Click OK. 

To grant user permissions to the custom calendars 

1) Open the shell where the Schedule Manager resides and switch to Admin mode. 

2) In the left Navigator, click Access Control. 

3) In the right pane, under User Mode Access, click Schedule Manager > Custom Calendar. 
The Permission Settings window opens. 

4) In the Permission Settings window, click the Add button. The User/Group Permissions 
window opens. 

5) Click the Add Users/Groups button. The User/Group Picker opens. 

6) Select the user(s) to whom you want to give permissions and click the Add button. Unifier 
adds the name(s) to the Permission/Access Control window. 

7) Under Permission Settings, select the permissions you want to grant the user(s) and click 
OK. Unifier adds the name(s) to the Permission Settings window. 

8) Click OK. 

Refresh Schedule Sheet Data 

A schedule sheet refresh updates cost data associated with the schedule sheet. During the 
refresh, Unifier recalculate dates, activity role rates, and costs if there were any changes to the 
schedule sheet, such as copying rows into the sheet. Alternatively, you can set up a schedule to 
automatically refresh the sheet data. 

Note: A scheduled refresh can fail if (1) an activity has more than one 
CBS code, or (2) a cost sheet column to which a schedule sheet column 
is associated is deleted from the cost sheet. 

To manually refresh schedule sheet templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Schedule Sheets in the left Navigator. 

Schedule sheet templates that require refreshing are shown on the Schedule Sheet log with 
a refresh icon: 

3) Select a template and click the Refresh button. 

To set up a refresh schedule 

1) Go to the Company Workspace tab and switch to Admin mode. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 
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 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

2) On the Schedule Sheets log, select one or more schedule sheet templates. 

3) Choose Refresh > Set Frequency. 

4) Select the Enable scheduled refresh checkbox. 

5) Select the Frequency and the Range of Recurrence. 

6) Click OK. 

Manual Schedule of Activities 

When auto-scheduling is disabled, you will be able to manually determine the schedule of 
activities, if desired. You can do this by refreshing it through manual Schedule refresh, Cost 
and Schedule refresh or enabling Schedule refresh. 

When you refresh the schedule, the entire schedule sheet will be re-scheduled, according to the 
latest dates entered in the Activity Property. 

When auto-scheduling is disabled, user will be able to manually determine the schedule of 
activities, if desired. This can be done by refreshing it through manual Schedule refresh, Cost 
and Schedule refresh, or enabling Schedule refresh. 

When you refresh the schedule, the entire schedule sheet will be re-scheduled, according to the 
latest dates entered in the Activity Property. 

Updating Schedule Sheet Properties from Templates 

If you create project or shells with a template, you can update schedule sheet properties in the 
projects and shells from schedule sheets in the template. Both the source and destination 
schedule sheets must have the same name. 

What you can do with schedule sheet update: 

 Change the schedule’s status (active/inactive) 

 Change auto-control (on/off) 

 Change auto-update options 

 Change the scheduled refresh frequency 

 Change the schedule’s calendar 

 Change the schedule start date, unless there are activities already in progress or 
completed 

 Change activity level access 

 Change Gantt chart bar labels and dates 

Note: Updates of linked schedule sheets do not occur to sheets in 
projects or shells that have Inactive or View-Only status. 

Calendars and Linked Schedule Sheets



Setting up the Schedule Manager

529

When a schedule sheet is initially linked, any calendar associated with that schedule sheet is 
copied over with the sheet. However, when there are any subsequent updates to the linked 
sheet from a template, the calendar is not again updated on the sheet. 

To update schedule sheet properties from project or shell templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shelltype] > [shell 
template] > Schedule Manager > Schedule Sheets. 

2) From the Schedule Sheets log, select the schedule sheet to push. 

Both the source and destination schedule sheets must have the same name. 

3) Click the Update button and choose: 

 Properties > [project] or All Projects 

 Properties > [shell] or All Shells 

An Options window opens. 

4) On the Options window, select the properties to update: 

 Description 

 Status 

 Auto-control: You can still manually initiate business processes. Unifier disregards 
predecessor/successor dependency relationships when you manually start an activity, 
even if auto-control is set to On in the schedule sheet properties. 

 Calendar 

 Schedule Start Date: You can only change the schedule start date if there are no 
activities in progress or completed. Changing the start date can prompt Unifier to 
recalculate and roll up resource amounts. 

 Notify users and/or group on errors 

 Enforce Group Permission 

 Auto update activity status based on Actual Start/Finish Date 

 Activity Progress requires an Actual Start date 

 Schedule Refresh Properties 

 Enforce Activity 100% Complete against Actual Finish date 

 Auto-Update % after entering Actual Finish Date 

5) Click OK. You will receive a confirmation of the update. Click OK. 

View schedule sheet properties update history 

To view update history: 

1) From the Schedule Sheets log, select the schedule sheet with the updates you want to see. 

2) Click the Update button and select History. The Update Projects History or Update Shells 
History window opens. This window lists the update history for each submitted update. 

3) Click the Close Window button when you are finished viewing the history. 
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Auto-Scheduling 

If the auto-scheduling is enabled for the template, then the properties (Update > Properties) in 
the destination Shell Schedule Sheets (with the same name as the template Schedule Sheet) 
will be updated. That is to state that the destination will also have automatic re-scheduling 
enabled and refreshed to reschedule the Activity Data.  

If the auto-scheduling is disabled for the template, then the properties (Update > Properties) in 
the destination Shell Schedule Sheets (with the same name as the template Schedule Sheet) 
will be updated. That is to state that the destination will also have automatic re-scheduling 
disabled. 

The Start Date, Duration, or Finish Date of particular Activity can be changed upon template 
push, but because auto-scheduling is disabled, none of the changes will be reflected in 
dependent activities. 

Update Schedule Sheet Activities from Templates 

If you create project or shells with a template, you can update schedule sheet properties in the 
projects and shells from schedule sheets in the template. Updating Schedule Sheet Properties 
from Templates (on page 528). 

You can also update the activities on a schedule sheet by using a separate "linking" function in 
Unifier that links a schedule sheet to a template for the specific purpose of updating activities. 
This feature is also convenient if you have imported a schedule and want to push it to your 
projects or shells. 

Note: Projects or shells that are in Inactive or View-Only status will not 
be updated. 

What you can do with linked templates: 

If you link a schedule sheet to a template in this way, you can use the template schedule sheet 
to push the following changes to sheet columns and activities: 

 Imported CSV or MPP files to the destination sheet 

 Added activities 

 Changes to activity status 

 Changes to column order 

 Added new columns 

 Removed column 

 Hidden columns 

 Column indents and outdents 

What you cannot do with linked templates: 

 Change schedule sheet properties, activity dates, CBS codes, or activity resources. 
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 Delete activities 

 Modify activity name or code associations 

 Modify Scope Management setup 

Once you link a schedule sheet to a template in this way, users can change dates and other 
data on the sheet, but they cannot add activities, delete activities, or otherwise change the 
structure of a sheet. You can only change the structure of the sheet and activities by changing 
the template and pushing the changes to the project/shell sheets. 

Permissions

You do not need to have permission on the destination schedule sheet in order to update the 
sheet via a project/shell template schedule sheet. You must have the Edit Structure and Data 
permission to set up linked schedule sheets. 

Enable and Disable Schedule Sheet Linking 

Before you can link project or shell schedule sheets to a template for updating, you must enable 
the template for linking. 

To enable linking for a schedule sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

3) On the Schedule Sheets log, select a Schedule Sheet template. 

4) From the Edit menu, select Sheet Linking > Enable. 

To disable linking for a schedule sheet template 

1) On the Schedule Sheets log, select a Schedule Sheet template. 

2) From the Edit menu, select Sheet Linking > Disable. 

Disabling Sheet Linking disconnects all project/shell schedule sheets from the linked 
template; the schedule sheets can no longer receive updates from the template. 

Link a Template to a Project or Shell Schedule Sheet 

1) On the Schedule Sheet log, select the schedule sheet template that you want to link. 

This template must have been enabled for linking. (See Enable and Disable Schedule 
Sheet Linking (on page 531).) 

2) Choose View > Linked Schedule Sheets. 

The Linked Schedule Sheets window opens, listing the schedule sheets that are currently 
linked to the template. 

3) Click Add. The Add Schedule Sheets window opens. 
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This window lists Active and On-Hold projects or shells and the corresponding active 
schedule sheets for those projects or shells. 

4) Select one or more schedule sheets and click Select. You will receive a confirmation 
message that the data in the newly linked sheet will be modified when the update is 
completed using the link between the template and the sheet. 

When you link a schedule sheet to the template, Unifier: 

 Deletes the existing data on the project/shell schedule sheet, including all activities, 
columns and cell data 

 Retains the schedule sheet properties, including the Schedule Start Date 

5) To link the sheets, click OK. 

6) When you are finished adding linked sheets, click Close Window. 

Update Linked Schedule Sheets from Project or Shell Templates 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

3) On the Schedule Sheets log, select the Schedule Sheet template that should update the 
activities on the linked schedule sheets. 

4) Click Update > Linked Schedule Sheets. 

Unifier will update the activities and columns on all the schedule sheets that are linked to the 
template. It will not, however, push changes to activity dates. 

Impact on Scope Management 

Scope Management setups that are updated through the use of linked schedule sheets allow 
updates to any activities that are not yet initiated. This includes business process name, 
responsible users, duration flag, completion conditions. 

Unlink a Template From a Project or Shell Schedule 

1) On the Schedule Sheet log, select the schedule sheet template that you want to unlink. 

2) Choose View > Linked Schedule Sheets. The Linked Schedule Sheets window opens, 
listing the schedule sheets that are currently linked to the template. 

3) Select the sheet you want to unlink and click Remove. 

Unifier will disconnect the schedule sheet from the template. 

4) Repeat steps 2 and 3 for any other sheets you want to disconnect from the template. 

5) When you are finished unlinking sheets, click Close Window. 
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View Linked Schedule Sheets 

You can view a list of schedule sheets that have been linked to the template. These are the 
destination schedule sheets that Unifier updates when you push changes from the template. 

To view linked schedule sheets 

1) On the Schedule Sheet log, select the schedule sheet template. 

2) Choose View > Linked Schedule Sheets. Schedule sheets that are available for updating 
from the linked schedule sheet template are listed in the Linked Schedule Sheets window. 
Master schedule sheets are listed as well as non-master sheets. 

3) When you have finished viewing the linked sheets, click Close Window. 

Auto-Scheduling 

If the user clicks on Update > Linked Schedule Sheets, then only the Activity Data will get 
updated on the destination (linked) Schedule Sheets from the template, and not the sheet 
properties.  

 If Auto-scheduling is enabled in the Linked (destination) Schedule Sheet, then after the 
Activity Dates update through Update> Linked Schedule Sheets, the re-scheduling will 
take place. 

 If Auto-scheduling is disabled in the Linked (destination) Schedule Sheet, then only the 
Activity Dates is updated and no re-scheduling occurs. That is to state that the change will 
be reflected in dependent activities. 

When auto-scheduling is disabled, if you push dates to the Master Schedule Sheet from 
Program Activity Sheet, then you can update changes for a particular activity, but there will be 
no impact of your changes reflected in dependent activities. Also, since the Master Schedule 
Sheet is updated by Program Activity Sheet, a Refresh icon appears in the log, next to the 
title. 

Importing Schedule Files 

Unifier supports working with schedule files such as Primavera. Once you import these schedule 
files, your external data becomes available in Unifier. In Unifier, users have access to the 
Schedule Manager’s analytical tools. For example, they can forecast project costs, monitor 
project progress at the activity and resource levels, and track earned value with schedule data. 

If users assign resources in non-Unifier software, Unifier will soft-book those resource 
assignments, provided you created a data set for those assignments (see Add data set values 
to a pull-down (drop-down) menu or radio button (on page 28)). 

Overall steps to import schedule files 

1) Save the schedule files. 

For Primavera XML files 

a. Export the Primavera file to XML. 

b. Modify the XML file to use with web services, as described in the Unifier Integration 
Interface Guide. 
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c. Select Import distribution data from external source (refer to the "Select the activity 
budget distribution profile" section in the Schedule Manager chapter of the Unifier User 
Guide). 

For Microsoft Project files 

d. Save the files as MPP, or export the Microsoft Project file to CSV or XML. Use this file as 
a template. 

2) Define data mapping. 

3) Import the CSV or XML files to create or modify schedule sheet activities. 

Primavera considerations 

 Unifier Schedule Manager integrates with Primavera scheduling software by way of Web 
Services.  

 Unifier honors the Primavera Current Data Date entry when calculating earned value 
(BCWS, BCWP, ACWP, EAC). 

 When importing Primavera XML files into Unifier, you must configure the number of CBS 
code segments, and you can specify a suffix mask. 

 Refer to the Unifier Integration Interface Guide for data elements you can use with Web 
Services. 

Microsoft Project considerations 

Unifier uploads Microsoft Project directly into a schedule sheet. 

 To use the Activity Calendar from Microsoft Project, first create a calendar in Unifier with 
the same name as the external calendar. (See Create a project calendar (Calendar tab). 
Refer to the "Create a custom calendar in the schedule manager" in the Unifier Managers 
User Guide for additional information.) 

 To import Resource Assignments from Microsoft Project, first add the same MPP 
resource types to the SYS Resource Type data set in Unifier. We recommend using MPP 
standard resource types: Work, Material, and Cost. (See Working with Data Definitions
(on page 23).) 

 Configuring CBS code segments is not necessary for Microsoft Project. See CBS code 
options for Primavera XML and Microsoft Project XML (on page 539). 

Overall steps to import third-party schedule files 

1) Save the third part schedule files.  

For Microsoft Project files (this is available through the user interface, only): 

 Save the files as MPP or export the Microsoft Project file to CSV or XML. 

 Use this file as a template (the MPP files do not require mapping). 

For Primavera XML files (this is available through the Web Services, only): 

 Export the Primavera file to XML. 

 Modify the XML file to use with web services, as described in the Unifier Integration 
Interface Guide. 
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 Select Import distribution data from external source (refer to the "Select the activity 
budget distribution profile" topic in Unifier Managers User Guide). 

2) Define data mapping. 

3) Import the CSV or XML files to create or modify schedule sheet activities. 

Define Data Mapping 

Data mapping establishes a 1 to 1 association between fields in a Unifier schedule sheet and a 
schedule sheet, such as Primavera P6. The data map creates a CSV or XML file into which the 
data from the external schedule can be loaded. Once loaded with data values, these files can 
then be imported into a Unifier schedule. 

You can create multiple data maps and select the data mapping you want to use when you 
import the schedule files to create or modify schedule sheet activities. 

Note: You must create at least one mapping. Unifier will use this 
mapping as a default if there are no others. 

Unifier supports multiple data formats: CSV, MPP, MPP XML, P6 XML. You must map any 
specific fields from an external source that you want to see in Unifier. 

Data format Data mapping requirements 

CSV Requires mapping; you can select the mapping when you upload the file.

MPP 

Mapping is not required. Imported fields are limited to Start Date, Finish 
Date, and Duration. 

Do not select a default data mapping if you will be asking Unifier to 
consider an activity calendar. 

Primavera 
XML 

Requires default data mapping. 

Microsoft 
Project SML 

Requires mapping; you can select the mapping when you upload the file.

To define data mapping 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

3) From the Schedule Sheets log, open the Schedule Sheet template you want to map. 

4) Choose File > Data Mapping. The Data Mappings window opens. 

The Data Mappings window lists any mappings created for schedules such as Primavera P6 
or Microsoft ® Project. 
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If a mapping on this list is marked as the default mapping, Unifier will use this mapping when 
the schedule is imported. If you do not mark a mapping as the default, Unifier will prompt the 
users to select a mapping whenever they import a schedule. 

5) Click Add. The Data Mapping window opens. 

6) On the General tab, enter the name and the description for the data mapping and click 
Apply. 

7) Click the Activity tab. 

Use this tab to create the structure of the CSV or XML file for the export and import 
operations. On this tab, you can map Unifier schedule sheet columns to external CSV 
headers and XML tags in order to import or export activity information. 

a. Click the Add button. Another data mapping window opens. 

b. Use the information in the first table below to complete the fields on this window. 

8) (Optional) On the Resources tab, you can map resource information through XML 
integration. Enter the header in the XML element that corresponds to the column. 

Note: Mapping resources is mandatory only if you select Import 
Resource Assignments on the Options tab. 

a. Click the Add button. Another data mapping window opens. 

b. Select the column and enter the header in the XML element that corresponds to the 
column. 

9) Click Apply on the Resources tab. 

10) Click the Options tab. On this tab, you can configure XML options that are used by Unifier 
when importing data. 

11) Use the information in the second table below to complete the fields on the Options tab. 

12) Click OK. 

Data format Data mapping requirements 

Column 
Select the data elements you want to import. Minimum required fields for 
XML import are Activity ID, Activity Name, Start date, Finish date, and 
Duration. 

CSV Header Enter the CSV header from the external source. 

XML 
Element 

Enter the XML from the external source 

In this field: Do this: 

XML Import 
Define options for importing XML activity schedules into Unifier. 
Importing data, from the Unifier Schedule Sheet, supports Microsoft 
XML, only. The P6 XML is supported through Web Services.  

Options 
You can either retain existing schedule information in Unifier, or 
overwrite it complete upon importing an external XML file. 
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 Merge into existing schedule. With this selection, you have a 
sub-option to Delete Activities removed from the source schedule. 

 Overwrite existing schedule replaces the existing schedule. 

Data 
Elements 

Select the appropriate checkboxes if you want to import activities (rows), 

Activity Dependencies: Select this checkbox to retain activities from the 
XML source file. 

Activity Calendar: Select this checkbox to retain the activity calendar 
from the XML source file. If imported, the activity calendar will trigger the 
recalculation of activity dates as needed, and will override any existing 
activity calendar association. If a calendar is not imported, the activity will 
use the existing calendar defined in the Schedule Sheet properties. 

Note: There must be a calendar in Unifier with the same name as the 
calendar in the import file. 

Resource Assignments: Select this checkbox to retain the resource 
assignments from the XML source file. If you want to import resources, 
define the resource types for the data definition SYS Resource Type. For 
Microsoft Project files, use standard resource types: Work, Material, and 
Cost. Upon import, these resource types will soft book. 

CBS Codes: Select this checkbox to import CBS codes. See CBS code 
options for Primavera XML and Microsoft Project XML (on page 
539). 

Number of Levels: (for Primavera XML only) Specify the segments that 
should be considered in the Primavera XML file for the codes (from 1 to 
9) and the CBS code suffix mask. See CBS code options for 
Primavera XML and Microsoft Project XML (on page 539) for details. 

Suffix Mask: (for Primavera XML only) You can use a constant or a data 
element value in the Suffix Mask. 

 To use a constant in the Suffix Mask, click the Constant radio button, 
and enter the suffix you want to have appended to the CBS code. 

 To use the value from a data element in the Suffix Mask, click the 
Data Element radio button and select a data element. 

XML Export Define options for exporting through XML into another application 

Data 
Elements 

Select the appropriate checkboxes if you want to export activities (rows), 
and whether to include dependencies, resource assignments, and/or 
CBS codes. 

CBS Code Options for Primavera XML and Microsoft Project XML

Unifier can recognize the CBS codes imported through XML files and match these codes to 
equivalent codes in a project/shell cost sheet. For Primavera XML files, you need to specify the 
Number of Levels and a Suffix Mask. (The codes in Microsoft Project XML files are 
automatically resolved by Unifier when the file is imported.) 
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The number of levels specifies the number of segments that should be included to build CBS 
codes based on data from the Primavera XML file. The number of segments considered starts 
from the top of the imported XML file. If you specify a number of segments and the data in the 
XML file has fewer segments than that number, then all segments are processed. 

The Suffix Mask you enter is added to the CBS code elements that Integration derives from the 
XML file. The CBS code derived from the XML file with the mask is validated against the CBS 
codes (leaf level) created for the project/shell Cost Sheet. 

While deriving the CBS codes from the XML file, Integration separates segments retrieved from 
the XML file with the cost code separator specified in uDesigner). When specifying the Suffix 
Mask, be sure to use the same cost code separator if the mask contains more than one 
segment. 

Import CSV, XML, or MPP files to create or modify schedule sheet activities 

Once you have saved the schedule files in an importable format (CSV, XML, or MPP) and 
defined the data mapping, you are ready to import the files into the Unifier schedule sheet 
template. 

To import a CSV file 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

From the Schedule Sheets log, open the Schedule Sheet template into which you want to import 
the schedule. The Schedule Sheet template opens. 

1) Choose File > Import > From CSV. 

When you import the file, you can select the data mapping you want to use for the importing 
files. If a default mapping was created, you will not have to select a mapping. If not, Unifier 
will display a Select Data Mapping window. If this window opens, select the data mapping 
you want to use for this import and click OK. 

The File Upload window opens. 

2) Browse to select the CSV file to upload. 

3) Click OK. 

To import XML and MPP files 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 
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3) From the Schedule Sheets log, open the Schedule Sheet template into which you want to 
import the schedule. The Schedule Sheet template opens. 

4) Choose File > Import > From External Source. 

When you import the file, you can select the data mapping you want to use for the importing 
files; however, in some cases, MPP files do not require that you to select a data mapping. 

If a default mapping was created, you will not have to select a mapping. If not, Unifier will 
display a Select Data Mapping window. If this window opens, select the data mapping you 
want to use for this import and click OK. 

5) Use the table below to complete the fields in this window. 

6) Click OK. The File Upload window opens. 

7) Browse to select the file to upload. 

8) Click OK. 

In this field: Do this: 

MPP 
Data mapping is not required; leave the Data Mapping field 
empty. 

MPP XML 
Data mapping is required; select the mapping you want to 
use. 

MPP activity calendar 

Select Consider Activity Calendar. 

Note: This requires an existing calendar in Unifier with the 
same name. See Creating Multiple Calendars (on page 116)

If an activity calendar is not imported and considered, the 
activity will use the existing calendar defined in the schedule 
sheet properties. 

MPP Resource 
assignments 

Data mapping is not required; leave the Data Mapping field 
empty. 

Note: This requires a data set for the SYS Resource Type 
data element. See Add a Basic Data Definition (on page 
26). Use MPP standard resource types: Work, Material, and 
Cost. Upon import, Unifier will soft-book these resource types.

CBS code options for Primavera XML and Microsoft Project XML 

Unifier can recognize the CBS codes imported through XML files and match these codes to 
equivalent codes in a project or shell cost sheet. 

To enter the CBS code options 

1) On the Data Mapping Options tab, select the CBS Codes checkbox. 

2) Enter the Number of Levels (from a minimum of 1 to a maximum of 9). This specifies the 
number of segments that should be included to build CBS codes based on data from the 
Primavera XML file. The number of segments considered starts from the top of the imported 
XML file. If you specify a number of segments and the data in the XML file has fewer 
segments than that number, then all segments are processed. 
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Note: You must enter a number of levels if you select the CBS Codes 
checkbox. However, for Microsoft Project XML files this value is ignored. 
The CBS Codes are resolved automatically by using the CBS code 
element in the MS Project XML schema when the MS Project XML file is 
imported. 

3) Optionally, (for Primavera XML only) enter the Suffix Mask you want to use for the CBS code 
mapping. The mask you enter is added to the CBS code elements that Integration derives 
from the XML file. The CBS code derived from the XML file with the mask is validated 
against the CBS codes (leaf level) created for the project or shell Cost Sheet. 

While deriving the CBS codes from the XML file, Integration separates segments retrieved 
from the XML file with the pre-defined Cost Code Separator (previously defined under Data 
Definitions in uDesigner). When specifying the Suffix Mask, be sure to use the same Cost 
Code Separator if the mask contains more than one segment. You do not need to start the 
Suffix Mask with the Cost Code Separator. Unifier will add this separator to combine the CBS 
codes derived from the XML file and the Suffix Mask you enter. 

You can use a constant suffix, or use the value of a data element as a suffix: 

 To use a constant in the Suffix Mask, click the Constant radio button, and enter the suffix 
you want to have appended to the CBS code. 

 To use a data element values in the Suffix Mask, click the Data Element radio button and 
select a data element. 

4) Click OK. 

Primavera XML and Microsoft Project XML CBS Code interpretation 

The data Unifier derives from the Primavera XML file consists of CBS Code segments, and 
activity and resource data. Upon import, a tree of CBS code elements are combined to form a 
CBS Code. Each element is a segment of a CBS code. The Activity element is attached to last 
node of the CBS Code segment. Activity Resource Assignment information is considered. 

This is an example of CBS code structure during import from an XML file: 

<CBS 1> 

<CBS 11> 

<CBS 111> 

<Activity A> 

In above example, actual CBS Code is <CBS 1>.<CBS 11>.<CBS 111>. Activity A contains a 
reference to its parent (<CBS 111>) CBS code segment. When processing the import of the 
XML data, Unifier first checks the Activity CBS code element and then builds the rest of the CBS 
code by moving up the CBS tree structure. In this example, Activity A has CBS 111 as a 
reference and Unifier use the structure to build the CBS code as CBS 1.CBS 11.CBS 111. 

After this CBS code is built, a Suffix mask (for Primavera XML files) is added to the beginning 
and end of the derived CBS code to create a Unifier CBS code. When the Unifier CBS code is 
created, it is validated against the CBS code created in the project or shell Cost Sheet. 

If an activity is moved from one CBS code to another CBS code, Unifier will move the activity 
during the XML file processing. If an activity or CBS code is deleted in the imported XML file, 
and the same activity exists in Unifier, Unifier will not delete that activity or CBS code. 
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Note: Importing data, from the Unifier Schedule Sheet, supports 
Microsoft XML, only. The P6 XML is supported through Web Services.  

Updating User Information in Schedule Sheet Properties Using Bulk Processing 

You can use bulk processing to update user information in schedule sheet properties for a large 
number of sheets. This user data pertains to the groups or individual users who are notified of 
errors and also the groups who are given activity-level permissions. You can perform this bulk 
processing at the shell or project level. 

Note: You can update 200 records at a time using bulk processing. 

Change user group assignments or add new users in bulk 

To add or remove user group assignments in bulk 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click Company Sponsored Projects (for a project) or Company 
Sponsored Shells (for a shell). 

3) In the log on the right pane, select project(s) or shell(s) you want to update. 

4) Choose File > Export > Export Schedule Sheet Properties. This will export the current 
properties for all of the schedule sheets for the selected shells or projects to a CSV file. 

5) Click Open to open the CSV file, or Save to save the file to your desktop. 

6) Modify the sheet in the CSV file as needed. 

All column values are required, except for Notify Users and Notify Groups. Group and user 
names are separated by semi-colon (;). 

7) Save the CSV file when you are finished modifying the user group assignments or adding 
new users. 

8) Navigate back to the log and choose File > Import > Import Schedule Sheet Properties. 

9) Upload the modified CSV file and click OK. 

You will receive an email notification when the update is finished. 

Creating Activity Sheet Templates 

Activity Sheets are used at the Program level to give program managers visibility into their 
activity data, and give them the ability to manage these activities across projects and shells. 
They are available in the Schedule Manager at the Program level. 

Program managers can use an activity sheet to view, edit, and update a large amount of activity 
data across projects and shells. Activity codes are mapped to activities in the Activity Sheet, and 
the data for the Activity Sheet is gathered only from the projects’ Master Schedule Sheets. 
Project names form the rows of the activity sheet; the activity codes and other data from the 
master sheets form the columns and sub-columns of the sheet. 

Users cannot create Activity Sheets; they are available only from templates that you create. 
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If an activity picker is present on a Cost type BP,  then the picker automatically populates the 
CBS code. Whenever user selects an activity in the form, it will populated the corresponding 
CBS code from Activity Sheet. 

Note: The automation does not require any configuration in uDesigner.   

Create an Activity Sheet template 

To create an Activity Sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Activity Sheets in the left Navigator. The Activity Sheets template log 
opens. 

3) Click New. The Activities Sheet properties window opens. 

4) Use the information in the table below to complete the fields on the General tab. 

5) Click Apply, then click the Activity Codes tab. 

On this tab, you add the rows of activities you want to see on the Activity Sheet. The rows in 
the sheets that are created from this template will list the projects and shells related to the 
activity codes you specify on this tab. 

6) Click the Add button to add activity rows. 

Unifier adds an empty row to the window. 

7) In the Activity Code column, double-click the cell. The cell becomes editable. 

8) Click the down arrow and select the activity for the row. 

9) To change the order of the activity rows, select a row and use the Move Up (Left) or Move 
Down (Right) buttons to move the activity. 

10) Click Apply, then click the Data Elements tab. 

On this tab, you specify the columns you want on the Activity Sheet. 

11) Click the Add button to add a row for the field. Unifier adds an empty row to the window. 

12) In the Data Elements column, double-click the cell. The cell becomes editable. 

13) Click the down arrow and select the field you want to display as a column on the sheet. 

Note: Activities can be affected by calendar selection, if there are 
multiple calendars implemented. You can include a Calendar column on 
the activity sheet, and this column will allow users to select a company 
level or a project/shell calendar per activity (custom calendars are not 
available). When activities are updated through the Activity Sheet, 
Unifier considers the calendar in use for the activity. The Start Dates, 
Finish Dates and Durations can be affected by the calendar used for an 
activity. 

14) To change the order of the fields, select a row and use the Move Up (Left) or Move Down 
(Right) buttons to move the field. 

15) Use the Editable checkbox to designate which data elements will be editable on the Activity 
Sheet. 

Only one of Start Date, Finish Date, or Duration elements in a group of elements can be 
made Editable (the other two elements of the group, if added, are not selectable). 
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The following elements are always read-only, and cannot be marked as editable: 

 Actual Start/Finish/Duration 

 Auto-update Activity checkbox 

 Milestone checkbox 

 Activity Code 

 Activity Status 

 Baseline elements 

16) If you want Unifier to automatically adjust the start and finish dates to reflect a negative lag, 
select the Allow negative lag to accommodate specified Start/Finish Dates checkbox. 

For example, lag could be adjusted to a negative value automatically to accommodate 
manual entries if an activity cannot be normally moved as a result of an existing dependency 
or lag. This could occur if: 

 The Finish Date on Activity 2 is updated to be pulled in by five days 

 The Start Date cannot move to be earlier due to predecessor Activity 1 

 In this case, you can make the lag negative by five days to allow the Start Date to move 
earlier and keep the duration constant 

In another example, the Finish Date on Activity 2 is moved up by five days. 

 The Start Date can be moved earlier only by two days due to predecessor Activity 1 

 In this case, we can make the lag negative by 3 days (-5+2=-3) to allow the Start Date to 
move earlier and keep the duration constant 

17) Click the Move Up (Left) or Move Down (Right) buttons to change the sorting order of the 
columns. 

18) Click OK. The new Activity Sheet template is available in the log. 

In this field Do this 

Title 
Enter a title for the template. This is used as the template 
identifier and must be unique. (up to 120 characters) 

Description Enter an optional description. (up to 400 characters) 

Status 
When you are ready to make the template active and 
available for use, click Active. The default is Active. 

Scope Management Setup 

Scope management is a framework that defines deliverables, responsible roles, actual 
assignees and their schedules. In other words, Scope Management drives coordinated 
production of these deliverables. Scope Management initiates actions for producing deliverables 
based on the completion of dependencies. It routes them to responsible person/group, monitors 
their completion and updates deliverable statuses automatically. It manages different activities 
across schedules for different team members simultaneously. 

Note: Scope Management is not available for launching non-workflow 
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business processes. 

This feature allows you to use existing Schedule Management functionality with added data 
elements to automate the management of a project’s scope and schedule with all associated 
activities, tasks, and deliverables. This feature provides project managers with the ability to 
manage each scope item’s task assignments, ownerships, and durations. 

Project managers can use Scope Management as the solution to manage high volume, 
quick-turn around projects that have standardized scope and scheduled activities. Examples of 
projects that would benefit from the use of Scope Management functionality are retail 
construction projects such as bank branches or chain fast food restaurants. Unifier’s Scope 
Management capabilities are also useful for large capital projects with complex scope and 
schedules, and that have numerous dependent activities and milestones with associated tasks 
and deadlines. 

Scope Management coordinates the creation of the defined deliverables using the schedules of 
the various assignees, and automatically moves tasks to the next assignee. Scope Management 
then routes tasks related to the deliverables to the next responsible assignee (person or group), 
monitors the state of the tasks, and updates deliverable status automatically. Actions for the 
creation of deliverables are based on fixed time durations and the completion of dependencies. 

This functionality can be enabled on any schedule sheet, including a Master schedule sheet. 
Scope Management enables you to link BPs with schedule sheet task activities and route those 
BPs, with automatic update of status as they are routed and worked on. The BPs represent the 
work that needs to be done to complete the task. Also, you can override the automatic routing at 
any time and launch the activity-associated BPs manually. The BP-related task is deemed done 
when specified completion conditions are met. 

Setting up Scope Management for Activities 

After you create the project- or shell-level schedule sheet template at the company level, you 
can set up the following for each activity: 

 Linked BP 

 Responsible users or groups 

 Due date 

 Completion conditions 

To set up Scope Management for an activity 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > [shell 
template] > Schedule Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

3) Select the template from the log and click the Open button, or double-click the selected 
template. The schedule sheet template opens. 
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4) To set up scope management for the template, use the instructions in the Unifier User Guide
on setting up scope management for activities. 

About Activity-level Editing 

At the project shell level, you can configure the Schedule Sheet so that specific cells can be 
edited only by designated groups of users. In a project, the project manager is usually 
responsible for the entire schedule, with various activity owners responsible for managing dates 
on specific project tasks. Enforcing activity-level editing controls the users and groups who can 
edit certain data, such as group-specific start and finish dates for activities. 

Notes: 

 You can set up the activity-level editing restrictions in a template, and 
the editing control configuration will be copied into any schedule 
sheet created from that template. 

 Unifier will ignore any data imported through CSV or XML for 
restricted fields. If there is any failure in validation, Unifier will stop 
the import. 

 The Gantt Chart will be disabled if the Start, Finish, and Duration 
fields are restricted. 

Activity-level editing allows the project manager and other activity owners to collaborate on a 
project and discuss the impact of changes to start and finish dates across the entire schedule. 
This collaboration allows the project manager or activity owners to enter new start and finish 
dates for activities without immediately affecting the start and finish dates for all activities. The 
editing restrictions prevent the proposed dates from affecting the entire schedule before the 
dates are approved or adjusted. Only those users with appropriate permissions can edit 
restricted dates. 

Note: Updates that occur from Activity Sheets are also subject to 
activity-level editing restrictions if the restrictions are configured on the 
corresponding schedule sheet, as are updates from CSV import or Web 
Services Integration. 

The following table shows an example of the impact on dates in a schedule sheet with 
activity-level editing configured, and with activities and group-specific date columns. In this 
example, the groups Const, IT, and ATM all have group-specific start dates and finish dates for 
activities: 
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A less restrictive implementation of activity-level editing allows specific groups to edit all cells in 
selected rows. In this implementation, when project manager changes activity start or finish 
dates, those changes could affect other dates in the schedule, due to dependencies among the 
activities: 

Set up activity-level editing 

Before you set up activity-level editing: 

 Be sure the Activity Attribute form has been designed to include the Filtered Group data 
element and any group-specific start date and finish date data elements (see the 
"Schedule Manager Overview" in the Unifier uDesigner User Guide for more information). 

 Be sure the Add the Filtered Group data element and any group-specific date data 
elements have been included as columns on the schedule sheet. 

 Create the groups who should have permissions for activity-level editing. See Setting up 
the Users (User Administration) (on page 131). Be sure not to include the project 
manager in any of these groups (as the group manager, for example), as this will result in 
conflicting permissions if later you add any restrictions to the columns schedule sheet. 

 Give these groups the View All Sheets permission for the Schedule Sheets for the 
project/shell. Do not grant Full Access permissions, as that will override any activity-level 
configuration to restrict editing. 

To set up activity-level editing 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

3) On the Schedule Sheets log, select the schedule sheet and click the Permissions button on 
the toolbar. The Edit Permission window opens. 

4) Add the group or groups for activity-level permissions and specify Edit Data in the 
Permissions section of the window. 
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5) Give the project manager Modify Permission. 

6) Click OK. 

7) Click the Properties button on the toolbar. 

8) On the General tab, select the Permissions: Enforce Activity Level Permission by Group
checkbox and select a Default Group from the drop-down list. 

9) Open the schedule sheet (either in the template or in the project or shell). 

10) Under the Filtered Group column, click the activity for which you want to specify editing. 

11) From the drop-down list, select the group you want to have activity-level editing permission. 

The group selection you make in the activity row controls the access for editing that activity. 
For example, if you select IT Group as the Filtered Group for an activity, then only users who 
are members of the IT Group can modify data for that activity (in that row). 

Note: For a less restrictive, row-level implementation of activity-level 
editing, you can stop here and not perform the next step, which provides 
further restrictions to the cell level. 

To set up more cell-level editing restrictions 

In addition to activity-level editing permissions, and can use column restrictions to enforce that 
only certain groups can edit certain cells. For example, for project managers, you could restrict 
the group-specific date columns only. For the activity-owner groups, you could restrict access to 
all columns except for the group-specific date columns. For example, for the IT Group, you could 
restrict access to all columns except for IT Start Date and IT End Date. 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates in the left Navigator. 

 For a project template, in the left Navigator, click Templates > Projects (Standard) > 
[project] > [project template] > Schedule Manager > Schedule Sheets. 

 For a shell template, in the left Navigator, click Templates > Shells > [shell type] > 
[shell template] > Schedule Manager > Schedule Sheets. 

The Schedule Sheets log opens. 

3) Open the schedule sheet you want to restrict. 

4) From the File menu, choose Restrictions. The Restrictions Setup window opens. 

5) Under User/Group Name, add the user or group name whose access you want to restrict. 

6) Under Activity Restriction Settings, choose the fields on the sheet that you want to restrict. 

7) (Optional) Under Resource Assignment Restriction Settings, choose the resource-related 
fields on the sheet that you want to restrict. 

Permissions Setting for Activity Sheet 

Note: If the user gets any of the permissions below, then the user can 
access the Activity Sheet node, in the User mode. 

To enable the users create, modify, and view the activity sheets, where the user can manually 
create project schedules, go to the shell, Admin mode and:  
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1) From the left-hand Navigator, click Access Control. 

2) In the Access Control log, click to expand the User Mode Access. 

3) Click Activity Manager to expand. 

4) Click Activity Sheet to open the Permissions Setting for: Activity Sheet window. 

5) Select from the following permission settings: 

 Send System Activity Sheet Data 

To send data to the source from system activity sheet 

 Get System Activity Sheet Data-All 

To create, update, delete, and view all sheets. 

 Get System Activity Sheet Data-Current 

To create, update, delete, and view all sheets. 

 Modify System Activity Sheet-All 

To update the system activity sheet. 

 Modify System Activity Sheet-Current 

To update the system activity sheet. 

 View System Activity Sheet-All 

To view the system activity sheet. 

 View System Activity Sheet-Current 

To view the system activity sheet. 

 Full Access 

To create, update, delete, and view all sheets. A user with Full Access permission can view 
the sheets created by others (for additional schedules) within the project. 

 Create Manual Activity Sheets 

To create, update, delete, and view all sheets. The system activity sheet cannot be 
deleted.  

 View 

Activity Sheet Permissions in the System Activity Sheet Permissions Tab 

Note: If the user gets any of the permissions below, then the user can 
access the Activity Sheet node, in the User mode. 

To enable the users create, modify, and view the activity sheets, where the user can manually 
create project schedules, go to the shell, Admin mode and from the left-hand Navigator click 
Access Control node to open the Access Control window.  

In the Access Control window, the following Activity Sheet permissions will appear in the 
System Activity Sheet Permissions tab: 

 Modify System Activity Sheet-All 

To update the system activity sheet. 

 Modify System Activity Sheet-Current 

To update the system activity sheet. 
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 View System Activity Sheet-All 

To view the system activity sheet. 

 View System Activity Sheet-Current 

To view the system activity sheet. 

Before 21.4 
Upgrade 

After 21.4 Upgrade 

Full Access At module-level: 

 Send System Activity Sheet Data 

 Get System Activity Sheet Date 

 View 

At sheet-level: 

 Modify 

 All 

 Modify 

 Current 

 View 

Send Data At module-level: 

 Send System Activity Sheet Data 

Get Data - 
All

At module-level: 

 Get System Activity Sheet Data 

Get Data 
-Current

At module-level: 

 Get System Activity Sheet Data 

Modify -All At module-level: 

 Modify 

 All 

Modify - 
Current

At module-level: 

 View 

At sheet-level: 

 Modify 

 Current 

View - All At module-level: 

 View 

At sheet-level: 

 View 

 All 

View - 
Current

At module-level: 

 View 

At sheet-level: 
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 View 

 Current 

Permissions for the System WBS Sheet 

Currently, the Unifier administrator can grant the Modify and View permissions for the System 
WBS Sheet that is auto-created through gateway integration from P6, or Primavera Cloud.  

The WBS Sheet permission allows the user to create a manual WBS Sheet, if one does not 
exists. By default, this permission will be unchecked. This permission can be selected for any 
user or group. 

To grant permission to create a manual WBS Sheet from the log to capture the work breakdown 
structure for the project: 

1) From the left-hand Navigator, click Access Control. 

2) In the Access Control log, click to expand the User Mode Access. 

3) Click Activity Manager to expand. 

4) Click WBS Sheet to open the Permissions Settings for: WBS Sheet window. 

5) Select from the following permission settings: 

 Modify 

 View 

 Hide Audit Log 

 Create Manual WBS Sheet 

The "Modify" and "View" permissions are available for System WBS Sheet. 

A user with "Modify" permission can do the following in a manual WBS Sheet, as well as 
conducting edits on a System WBS Sheet: 

 Manage WBS 

 Add new WBS rows 

 Update existing WBS rows 

 Delete the WBS rows that are not used 

 Update column structure 

A user with "View" permission can do the following in a manual WBS Sheet and System WBS 
Sheet: 

 View the data including WBS details and transaction details for costs. 

 Switch between manual WBS Sheet and System WBS views, by using the Project field 
(drop-down). 
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Setting up the Space Manager 

In Unifier, the Space Manager is where you can perform the tasks of facilities management. The 
Space Manager integrates the AutoCAD® application to provide drawing and modeling 
capabilities for your architectural, layout, and design needs. 

Note: The Space Manager is only available to shells; it cannot be used 
for standard projects. 

Using the Space Manager, you can gather data about the levels in your facility (such as floors 
and parking lots) and the spaces that exist on each level (cubicles, offices, conference rooms, 
etc.). Each level is supported by an AutoCAD® drawing. You can enter individual spaces into 
Unifier, or directly onto an AutoCAD® drawing and classify them into categories (such as 
common areas, or usable space) to make managing them more efficient. Similar to the Asset 
Manager, categories (called types) of spaces can be designed in uDesigner, and you can then 
add records of individual spaces to these types and manage them on an electronic sheet. 

The Space Manager is a means of organizing all the square footage in your facility to make 
monitoring, maintaining, and revising your facility more efficient. The Space Manager can be 
integrated with other managers or business processes to give you a broader view of your 
company’s physical capital and resources. For example, the Space Manager can be integrated 
with the Asset Manager to include the computers that reside in each cubicle on a level; or 
integrated with the Resource Manager to include the employees who occupy each space on a 
level. 

In uDesigner, one attribute form is designed for a “level” type in your facility and multiple attribute 
forms for “spaces” types. With these attribute forms, you can create a hierarchy of levels and 
spaces within levels to store the facilities data you choose to collect. 

Notes: 

 In the Space Manager, think of a level as the “platform” on which 
spaces reside. 

 Configuration of the Data Picker and Data Elements (and when 
applicable: Unique and Auto Sequence settings) must be done in 
uDesigner. 

In Unifier, the Sheets node in the Space Manager stores the manager sheet on which all the 
levels in your facility are shown. Unifier automatically creates a level sheet for every level type 
that is created. On these sheets, you can import and export drawing files to and from 
AutoCAD®, and also import and export column data. From the level sheet, you can also 
automatically update individual level records with data added to the sheet, either manually or via 
a formula created for a column. 
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The Stack Plans node is where you can create stack plans to show the actual usage of the 
levels in the company’s building(s). You can choose the information (data elements or specific 
spaces) you want to see on the stack plan and update the plan periodically to keep abreast of 
changes in the levels’ space usage. For example, you might want to know the square footage 
used by each department on each floor (level); or how many square feet of a floor are vacant 
versus leased. 

The Levels node lists all the levels that exist in your facility. Each level is supported by an 
AutoCAD® drawing. This node is where you can create new levels or update existing ones, 
download drawing files, add spaces to the level, attach a drawing to the level, and print the 
drawing. This is where you can create new levels or update existing ones, import data from CSV 
files, export templates to CSV. 

The Spaces node shows a list of all the space types, and under the space type sub-node, all the 
spaces that exist in your facility. This is where you can create new spaces or update existing 
ones, import data from CSV files, export templates to CSV, and select spaces to view on the 
level drawing. 

The Space Manager allows you to identify floors and each space by type and associate 
attributes to the particular spaces. For example, a multi-floor building could have many types of 
spaces, such as offices, cubicles, restrooms, conferences room, laboratories, and eating areas. 

You manage spaces according to space type. Examples of space types are: 

 Gross measured area, which is the entire square footage of a floor, from wall to wall 

 Common area, such as hallways, lobbies, and entrances 

 Usable space, such as cubicles, offices, and conference rooms 

 Vertical penetration, which includes elevators, stairwells, and columns 

The Space Manager is available within a shell. Each shell can have only one Space Manager. A 
building is at the shell level. An example hierarchical arrangement of objects in the Space 
Manager is as follows: 

 Buildings (shell level) 

 Levels (Floors) of the building or other similar structures (in this case, Floor is an example 
of a level record) 

 Spaces in the building. These are the various spaces in the structure, such as 
storage rooms, offices, and other interior spaces (space records). Spaces is a 
fixed node designed in uDesigner. 

The Space Manager includes a sheet to help you manage levels and spaces. The sheet will 
allow you to create formulas to calculate total leasable and rentable space for a facility or 
building. 

uCAD Plug-In 

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in 
application, which can be downloaded from Unifier. uCAD enables: 

 Authoring of space objects in AutoCAD® 

 Identifying spaces on a floor drawing and link them to Unifier space objects 

 Associate a drawing file to a Unifier level record 
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 Transferring changes to level and space records between the Unifier Space Manager 
and AutoCAD® 

In This Section 

About the uCAD Plug-In ........................................................................................ 553 
Space Manager Prerequisites ............................................................................... 553 
Importing and Configuring Levels and Space Types ............................................. 553 
Configuring Levels and Space Types .................................................................... 554 
Configuring Space Manager Configuration Package ............................................. 556 
Creating Level Sheet Templates ........................................................................... 556 
Creating a Stack Plan Template ............................................................................ 557 
Setting Permissions for the Space Manager .......................................................... 559 

About the uCAD Plug-In 

Users can integrate the Unifier Space Manager with AutoCAD® using the uCAD plug-in 
application, which can be downloaded from Unifier. uCAD enables: 

 Authoring of space objects in AutoCAD® 

 Identifying spaces on a floor drawing and link them to Unifier space objects 

 Associate a drawing file to a Unifier level record 

 Transferring changes to level and space records between the Unifier Space Manager and 
AutoCAD® 

Space Manager Prerequisites 

The following is a list of prerequisites: 

 Generic or CBS shells configured 

 Level and space attribute forms defined in uDesigner 

 uCAD plug-in and AutoCAD® installed on your desktop (if you are going to use the Space 
Manager with the optional AutoCAD® integration) 

The Unifier uCAD Installation and User Guide is also available from the Unifier Support 
window, on the Download tab. After you download the uCAD plug-in you can access uCAD 
from the Windows Start menu > Programs> uCAD. When you install the plug-in, the uClient 
Configurator is also installed. The Unifier uClient Configurator Setup Guide is available in the 
uClient Configurator Help menu. The Unifier uCAD Installation and User Guide is available in 
the uCAD Help menu. 



Importing and Configuring Levels and Space Types 

Importing and configuring levels and spaces types for the Space Manager for use in Unifier 
consists of the following steps: 
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Step 1: Import level and space types. Levels and space types are created in uDesigner. 

Step 2: Configure the level and spaces. This configuration enables these types to be set up. 

Step 3: Setup Level Sheet Templates

Step 4: Create stack plan templates

Step 5: Set permissions. After setting up and configuring levels and spaces, you must set User 
Mode permission to all users who will need to work with these components of the Space 
Manager. 

In order to create levels and space types in Unifier, the Space Manager module has to be 
loaded. Contact the Company or Site Administrator.  

The Space Manager can have only one level type design but multiple space type designs. You 
have to first deploy the level design in uDesigner before deploying any Space type designs.  

To import and deploy a level or space attribute form into Unifier Production environment, see 
Importing Configuration Packages (on page 640). 

Configuring Levels and Space Types 

Level and Space configuration allows you to activate the level and space types for use in the 
Space Manager. 

To access the level and space configuration log 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration – Space 
Manager log opens. The log lists the level and space types that were imported into Unifier. 

The newly imported level and space types are inactive by default and can be activated during 
configuration. 

Configuring a Level or Space Type 

The following describes how to activate a level or space types. 

To configure a level or space type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration-Space 
Manager log opens, displaying the level and space types that have been imported into your 
company. 

3) Select a level or space type and click Open. The Configuration window for the level or space 
type opens. 

4) Complete the General tab. In this tab, you can add a custom Help file and change the status 
of the level or space type to Active. 

5) Click the Custom Print tab. This tab is optional; it allows you to customize the layout of a 
PDF document leveraging the XML style design format.  

6) Click OK. 



Setting up the Space Manager

555

Configuring Fill Colors and Text for Space Types 

You can configure fill colors and text for uCAD drawings to support visual analysis of the 
drawings to facilitate space planning. For example, users might want to see a floor plan with 
each space type on that plan highlighted in a different color based on the department using that 
space. 

To configure fill colors and text for a space type 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Configuration > Space Manager in the left Navigator. The Configuration-Space 
Manager log opens, displaying the level and space types that have been imported into your 
company. 

3) Select a space type and click Open. The Configuration window for the space type opens. 

4) For space types, click the Options tab. On this tab, you can enter information regarding 
spaces that enables users to color code spaces shown in uCAD. Users can also specify the 
display text that will appear on drawings. 

5) Complete the CAD Drawing Options as described in the table below. 

6) Click OK. 

In this field: Do this: 

Default Color Click Select to specify the AutoCAD (ACI) Color used by 
default when displaying spaces of this type. The system 
default is white (no color). You can select a color from the 
255 color AutoCAD ACI color palette. This ACI color is 
converted to the corresponding HEX HTML color. The default 
color is used for space outlines. 

Text Element Sort Click Select to specify the sort order of the data elements 
whose text labels will be available to be shown as text on the 
uCAD drawing, as defined in uDesigner. 

You can use Add to select the data elements to display and 
select a data element and click Remove to delete data 
elements from the list of displayed data element text. Use the 
Move Up and Move Down buttons to re-order selected data 
elements. Also, you can re-order the data elements by editing 
the Row number, and clicking Update Order to refresh the 
window. Click OK to exit the Data Element window. 

Fill Display Elements Click Select to specific the drop-down list data elements 
(Input Type Pull-down Menu) that are available to be used for 
visual analysis on the uCAD drawing, and to specify a color 
for each value in the Data Set for that Pull-down Menu. 

Select a Data Element and select Enable Fill By. Select 
colors for the data element data set values. Click OK. 
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Configuring Space Manager Configuration Package 

The following configurations can be included in the Space Manager Configuration Package:  

 General setup 

All the fields included in the General Configuration (General tab). 

 Custom Print 

Word and PDF templates, if any. 

 BIP Custom Print 

All the BIP Custom Print in the Custom Prints and Reports. 

 Space Attributes 

The content of the Options tab for Space Attributes, including Default Color, Text Element 
Sort, and Fill Display Elements. 

Note: If you do not select the Data Structure setup option at the time of 
creating the Configuration Package, the Data Definition selected in the 
Fill Display Elements field will not contain the Value or Label datasets 
and only the colors can be seen. 

For more information, see the Configuration Package Management (on page 597) section in 
this guide. 

Creating Level Sheet Templates 

To open a level sheet 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. The Level Sheets log opens. There is one level sheet per shell. 

3) Select the sheet in the log and click Open. 

To open the Level Sheet properties window 

In the Level Sheets log, select the sheet and click Properties. 

To create a template for a level sheet  

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. 

3) Click New. The Levels Sheet Properties window opens. 

4) Enter an optional description. You cannot change the sheet title. 

5) Choose whether to include all levels on the sheet or just levels with selected statuses. 

6) Click OK. 

To add columns to a level sheet template 

1) Go to the Company Workspace tab and switch to Admin mode. 
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2) Click Templates > Shells > [shell or shells] > Space Manager> Level Sheets in the left 
Navigator. 

3) Select the level sheet, and click Open. 

4) Click Columns. The Columns Log window opens. 

5) Click New. The Column Definition window opens. 

6) In the Datasource drop-down list, select the data source to use. The list includes the data 
elements found on the level forms. 

7) For Entry Method, choose how information is entered in the column. The choices depend 
on the data source selected. 

8) For Data Format, select the format for numeric columns. The options are: 

 Show as Percentage: Displays data in percentage. For example, if 0.25 is entered, it 
displays as 25%. 

 Decimal Places: Select the number of decimal places to display. 

Note: If the data element was defined in uDesigner with a specific 
number of decimal places, it will override any decimal places you specify 
here. 

 Use 1000 Separator (,): Data is formatted using separators. For example, one thousand 
is displayed as 1,000 with a comma, not 1000. 

 Negative Number Format: Select how negative values are displayed: with a negative 
sign or in parentheses. 

9) For Display Mode, select Hide to make the column invisible to users or Show to display it. 

10) For Total, select what is shown in the bottom summary row for each column. The options 
are: 

 Blank: Summary row is blank. 

 Sum of All Rows: Displays the sum total of all row values for this column. 

 User Formula Definition: Displays the result of the formula entered in the Formula field. 

11) For Average, select Blank or the average of all rows. 

12) For Column Position After, select a column from the list to specify its position on the sheet. 

13) Click OK. 

Creating a Stack Plan Template 

A stack plan is a two-dimensional graphical display of facility or building data. Usually, these 
graphs display area calculations by different attributes (for example, rented, leased, vacant, 
occupied by a tenant). Stack plans allow users to view area information across all building levels 
or floors based on defined attributes. Stack plans display only space records. With permissions, 
users can create or modify a stack plan under a shell. 

To create a stack plan 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell] > Space Manager> Stack Plans in the left Navigator. 

3) Click New. The Properties window opens. 
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4) Complete the General tab as described in the first table below. 

5) Click the Options tab and complete as shown in the second table below. 

6) Click Apply to save changes, or OK to save and exit. 

In this field: Do this: 

Name Enter the stack plan name. 

Description Enter an optional description. 

Include: 

 All Levels 

 Levels with statuses 

Select to specify that all levels be included in the stack 
plan, or that only levels of selected status be included in 
the stack plan. 

In this field: Do this: 

Space Types Select a space type. 

Stack By: 

 Space Type 

 Data Element 

Select whether to stack by selected space type or by a 
data element. 

Stacking View Select to specify standard stacking or 100% stacking. 

Sort Floors By: Select to sort floors by a selected data element from the 
Level Attribute form. 

Show Legend Select to display a legend for the stack chart. 

Conditions Add a condition to filter the number of space records 
included in the stack plan calculation. The stack plan 
calculation logic sums up the values from the uuu_area 
data element used on the space-type detail form. 

To modify stack plan properties 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell] > Space Manager> Stack Plans. 

3) Select a stack plan and click Properties. The Properties window opens. 

4) Modify the stack plan properties as needed. 

5) Click OK. 

To update a stack plan across shells 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell ] > Space Manager> Stack Plans. 

3) Select a stack plan in the log. 

4) Click Update Shells. You can choose to update the stack plan in selected shells, or all 
shells. 
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Setting Permissions for the Space Manager 

You must set the user permissions for the various components of the Space Manager. The 
Space Manager components are: 

 Sheets 

 Stack Plans 

 Levels 

 Individual space types 

To set the Space Manager components permissions 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Access Control in the left Navigator. 

3) On the right pane, select User Mode Access > Space Manager. The permissions for each 
component are: 

 Sheets: Create, Modify, View 

 Levels: Create, Modify, View, Allow Bulk Edit 

 Spaces > All > <space types>: Create, Modify, View, Delete, Allow Bulk Edit 

 Stack Plans: Create, Modify, View 

Note: Users with Modify permission can import drawing files into a level 
record. 
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Setting up the User-Defined Reports 

These are the recommended steps to set up the User-Defined Report (UDR) functionality: 

Step 1: Create a UDR template. 

Step 2: Create project or shell UDRs. 

Step 3: Create a program UDR. 

Step 4: Create a company UDR. 

In This Section 

Creating and Setting Up a UDR Template ............................................................. 561 
Access Control Permissions for UDRs .................................................................. 587 
Creating User-Defined Project, Shell, Program, and Company Reports ................ 591 

Creating and Setting Up a UDR Template 

Report templates allow you to create templates that a user can then copy from to create 
User-Defined Reports (UDRs). Report templates are based on specific data types and 
pre-defined data elements that differ depending on the data type. 

Report templates define queries used to search the database for transaction or Project/Shell 
data and report layout. 

You can create UDR templates for the following UDR report types: 

 Tabular 

 Cross Tab 

 Summary 

 Alert 

UDR Data Types 

The following table summarizes data types in user-defined reports. Data types also include 
project- or shell-level and company-level business processes, asset classes, planning items, and 
sheets. 

Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Mainten
ance 
Manage
ment 
Only 

Accounts 
Sheet 

x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Mainten
ance 
Manage
ment 
Only 

Active Task 
Information 

x x x x 

Asset 
Summary 
Sheet 

x 

Audit x x 

Commitment 
Summary 

x x x 

Company 
Cash Flow 

x 

Company 
Cost 

x 

Company 
User 
Information 

x 

Cost Sheet - 
CBS 

x x x x 

Cost 
Transactions 
-CBS 

x x x x 

Cost 
Transactions 
MC - CBS 

x x 

Data Views x x x x x 

Document 
Manager 

x x x x x 

Document 
Manager—C
ompany 

x 

Equipment x x 

Funding x x x x 

Gates x x x x 

Inventory x x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Mainten
ance 
Manage
ment 
Only 

Inventory 
On-hand 
Detail 

x x 

Item Master x x 

Job Plan x x 

Master PM 
Book 

x x 

Master PM 
Meter 
Schedule 

x x 

Master PM 
Time 
Schedule 

x x 

Material 
Transaction 

x x 

Partner User 
Information 

x 

PM Book x x 

PM Meter 
Schedule 

x x 

PM Time 
Schedule 

x x 

Program 
Cash flow 

x 

Program 
Cost 

x 

Program 
Schedule 

x 

Resource 
Booking 

x x 

Resource 
Manager—All 
Actuals 

x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Mainten
ance 
Manage
ment 
Only 

Resource 
Manager—All
ocated Roles

x x x 

Resource 
Manager—B
ooked 
Resources 

x x x 

Resource 
Manager—Pr
oject Actuals 

x x x 

Resource 
Manager - 
Resources 
(Company) 

x 

Resource 
Manager—R
oles 

x 

Resource 
Manager—S
heets 

x x x 

Service 
Center 

x x 

Service 
Request 

x x 

Schedule of 
Values 

x x x x x 

Shell or 
Project Cash 
Flow 

x x x x x 

Shell or 
Project Cost 

x x x x 

Shell or 
Project 
Groups 

x x x x 
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Data Type 
Project 
UDR 

Shell UDR 
Program 
UDR 

Company 
UDR 

UDR 
Template 

Use for 
Mainten
ance 
Manage
ment 
Only 

Shell or 
Project 
Information 

x x x 

Shell or 
Project Users

x x x 

Workflow 
Information 

x x x x x 

Work Order x x 

Work Order 
Items 

x x 

Work Order 
Role 

x x 

(Asset class 
name) 

x 

(Business 
process 
name) 

x x x 

(Planning 
type name) 

x 

Note: The COST SHEET - CBS data source does not support the 
formula columns. Use the Project/Shell Cost data source to view the 
formula column values. 

Accessing UDR Templates 

To access Project UDR templates: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Projects (Standards) > All > [project template]. 

3) Select a project from the log. 

4) From the left-hand Navigator click Reports > User-Defined. 

To access Shell UDR templates: 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click Templates > Shells > [shell type] > [shell template]. 
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3) From the left-hand Navigator, click a shell to open the log, select a shell from the log, and 
click Open. 

4) From the left-hand Navigator click Reports > User-Defined. 

The User-Defined Reports log for the (Shell UDR templates) contains all the UDR templates that 
have been defined for a specific Company, and the log contains the following information:  

 Menu bar 

 File 

 Edit 

 View 

 Help 

 Toolbar 

 New 

 Copy 

 Open 

 Edit 

 Delete 

 Find 

 Save Results 

 Update Shells 

 Import 

 Columns 



 Name 

 Description 

 Data Type 

 Report Type 

 Owner 

 Scheduled 

 Last Run Date 

The following table explains each of the column-headings: 

Column Description 

This icon indicates that reports created based on this template will 
be enabled for web services integration. The integration option is 
available only for project-level, shell-level, and company-level 
reports. 

Name Name of the report template. 

Description Description of the template. 

Data Type The type of data on which the report is being run, for example, 
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business processes, Cost Manager elements, project or shell 
information, workflow information, etc. 

Report Type Tabular, cross tab, summary, or alert. 

Owner The creator of a report is its owner. 

Scheduled Displays the scheduled frequency of a scheduled report. 

Last Run Date The date that the report was run last. 

Creating a UDR Template 

These procedures are applicable for UDR templates or for manually creating a new UDR in User 
mode. 

To create a UDR template 

1) Go to the Company Workspace tab and switch to Admin mode. 

2) Click one of the following in the left Navigator: 

 Templates > Reports

 Templates > Project (Standard)> All > [project template] > Reports > User-Defined

 Templates > Shells > [shell type] > [shell template] > Reports > User-Defined

3) Click the New button. The Create a new report window opens. 

4) Fill in the fields using the information in the table below 

5) Click OK. The Edit Report window opens. This window has multiple tabs for defining the 
report layout and content. The actual tabs that display will depend on the type of report you 
are creating. These tabs are: 

 General tab: In this tab, you enter the report name, the title that displays on the report at 
runtime, and define general settings, such as enabling it for integration, and setting a 
default time zone to use where time stamps appear on the report. 

 Data Elements tab: Allows you to specify the data elements on which to report, and 
which will appear as columns on the report at runtime. The Data Elements tab differs with 
each report type. In addition, the data elements that are available to be added to the 
report depend on the data type chosen during report creation. The data elements can 
include business process fields, columns in cost, funding, SOV, and schedule sheets, 
project data such as project name, status, user name, etc. 

 Query tab: Defines query parameters to input at report runtime. 

 Layout tab: Allows you to customize the layout and presentation of the report. If you do 
not define layout parameters, a default layout will be used. The Layout tab differs with 
each report type. 

 Projects/ Shells tab: This tab appears only in program-level and company-level reports. 
It displays which projects or shells will be included in the report. 

 Shells tab: This tab appears only in shell-level reports. It displays which shells can be 
included in the report. 
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 Permission tab: Enables the report owner to grant permission to other users to run or 
edit the report. This tab is available only in User Mode and not in the report template. 

 Schedule tab: Allows the report owner to schedule and configure automatic report 
generation and optionally save or email the results. 

6) Complete the tabs in the Edit Report window as described in the following sections and click 
OK. 

In this field: Do this: 

Data Type 

Select from the list. The Data Type list includes all available 
business processes (for example, base contracts), 
pre-defined data types (e.g., project users), modules (for 
example, Document Manager), data views in Published 
status (listed in alpha order, project/shell-level requires 
project_id in query), and may also include custom data 
types. 

Element 

If you chose a business process or a uDesigner BP-driven 
feature (such as funding, schedule of values, project 
information) as the data type, the Element drop-down list 
becomes available. Select one of the following options as 
available for your data type choice: 

 All Fields: Makes all fields on the BP available for the 
report. 

 General (Header) Fields: Only the BP header fields will 
be available, which provides a less detailed report. 

 Custom Defined: This is automatically selected for 
uDesigner-created BPs and related functions. This 
enables all the custom data element fields on the BPs 
to be available for the report. 

Report Type Choose a report type. 

Access Type (Read-only) System  

General tab (all reports) 

The General tab defines the report name, title, and description and displays the data type and 
report type (tabular, cross tab, summary, or alert). The General tab is the same for each report 
type. Below is a sample of the General tab. 

In this field: Do this: 

Report Name The name appears on the user-defined reports log. 

Report Title 
The title appears on the report itself. By default, the field is populated 
automatically with the report name and is editable. 

Description Description is optional. 
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Data Type, 
Element, and 
Report Type 

Automatically populated from the options selected during the creation 
of the report. 

Enable for 
Integration 

Selecting this option flags the report as eligible for integration through 
web services (uLink). Contact Oracle Customer Support for more 
information about web services integration and uLink. This option is 
available for project-, shell-, and company-level reports only. 

When the checkbox is selected, the integration icon  appears in the 
UDR log next to the report name. 

Note: Because web services uses the report name to identify reports, 
each report marked for integration must have a unique name. If there 
are two reports with the same name, only one of those reports can be 
marked for integration. This is true even if you cannot see the other 
report with the same name. For example, another user has created a 
report with the same name, for which you do not have view permission, 
and marked it for integration. 

Default Time 
Zone 

This option allows you to choose the default time zone that will be used 
where time stamps appear on the report (such as data/time data 
elements). There are two options: 

 Click the pull-down and choose a specific time zone in which to 
display date/time information in the report at runtime. Use this 
option when you want all instances of the report to display results in 
a fixed time zone, for example, the project location. 

 You can also choose to default to user’s time zone. When this 
option is chosen, users in different locations will see report results 
that reflect their own time zone. 

Note: For scheduled reports, all users will get the same report results. 
If the user time zone option is chosen, then the report owner’s time 
zone is used. 

Data Elements tab (tabular report) 

Each column of a tabular report corresponds to a data element or function (formula, date, or 
date difference). You can add or modify the data elements or functions on this tab. The Data 
Elements tab differs with each report type. The data elements depend on the data type chosen 
during report creation (see below.) The data elements can include business process fields, 
columns in cost, funding, SOV, and schedule sheets, project data such as project name, status, 
user name, etc. 

This button: Does this: 

Add Functions 
Click to open the Data Element Properties window. Allows you to 
create a formula, data difference, or date column in the report. 

Add Elements Click to open the Data Element Picker window. The data sources and 
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elements that are available vary based on the data type that you 
chose when creating the report. 

Modify Modify data element properties. 

Sort Determines which column to sort report results by. 

Remove Select a listed data element and click to remove it. 

Move Up (Left) Select a data element and click to move the column to the left. 

Move Down 
(Right) 

Select a data element and click to move the column to the right. 

Current width 
This field displays the width of the report in pixels. The report width is 
determined by the number and column width of data elements that 
are added. 

Maximum 
available width 

The maximum width of the report is determined by the page size and 
orientation as selected in the Layout tab. 

Data Elements tab (cross tab report) 

Cross tab reports allow the display of data on two axes. For example, the report below is being 
set up to track amount per CBS code per phase, where the CBS codes are the rows, the phases 
are the column headings, and the body data is made up of the line item amount. 

Cross tab reports enable users to run time-series reports defined by two data sources, for 
example, payments made per quarter per vendor. 

In this field: Do this: 

1st Column This determines the data element that will be used for each row. 

Data 
Element 

Click Select and choose the data element. The list will depend upon the 
data type chosen. The data type will be listed before the data element, 
separated with a slash (/). For example: Funding/Funding Type, where 
Funding is the data type chosen on the General tab, and Funding Type is 
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the data element. 

Heading 
The heading will automatically populate with the data element that you 
choose, but you can edit this as necessary. 

Width 
You can specify a column width for the 1st column, or leave it blank to 
use the default width (automatically adjusts depending on the number of 
body columns in the report). 

Body 
Columns 

This determines the series for which the data will be presented. The list 
is pre-defined and will depend on what was chosen for the 1st Column. 
Typically, these are system-defined data elements related to the 1st 
column choice, for example, status, creation date, etc. 

Data 
Element 

 Click Select. The Data Element Picker window opens. 

 Click the Data Source list at the top of the window and select a data 
source. This determines which data elements will be available for the 
report. The choices will include the data type you chose in the 
General tab, as well as related data sources. 

 Select a data element and click OK. Some data sources might not 
have data elements. 

Width 
You may specify body column width or leave it blank to have it 
automatically adjusted. 

Body Data This determines the data that will show up in the body of the report. 

Data 
Element 

The list is dependent on what is chosen for the other parameters, and is 
determined by what is logically reportable. 

Row/Column

 Select Show Total if you want column and row sum totals to be 
included in the report. 

 Choose Left or Right alignment. 

 Choose Ascending or Descending to determine the sorting order of 
the columns and rows. 

Data Elements tab (summary report) 

On this tab, you specify the data that will be reported and how it will be presented on the project 
summary page. In the example below, a cost sheet report is being set up to display the value of 
total commits against CBS code. 

In this field: Do this: 

1st Column 

This determines the data element that will be used for each of the rows. 
In the example above, this is CBS code. Click Select and choose the 
data element. The list will depend upon the data type chosen. The data 
type will be listed before the data element, separated with a slash (/). 
For example: Funding/Funding Type, where Funding is the data type 
chosen on the General tab, and Funding Type is the data element. 
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Heading 
The will automatically populate with the data element that you choose, 
but you can edit this as necessary. 

Width 
You may specify a column width or leave it blank to use the default 
width. 

If the data 
element is a 
date type, 
you can 
specify time 
parameters 

 By: Choose the year, quarter, month, or day to display the data. 

 Format: How the heading will display the date 

 From and To: Establishes the date range to include in the report. 

2nd Column This determines what information is being presented. 

Record Count
Displays the total number of records. For example, for a report on a BP 
type, it will display the number of BP records. 

Summary 
Value 

Displays a value. In the above example, the value is the total value of 
the commits (Contracts + Change Orders) for each CBS code. To enter 
a formula, click the Formula button. 

Summary 
Type 

Choose one of the following: 

 Summary: Provides a summary value. 

 Average: Displays the average value. 

 Maximum: Displays the maximum value. 

Heading Type a heading for the 2nd column. 

Width 
You may specify a column width or leave it blank to use the default 
width. 

Data Elements tab (alert report) 

On this tab, you define the parameters that will trigger the alert that will be sent you. In the 
example below, the alert will be triggered for invoices that are greater than $1,000. 

In this field: Do this: 

Alert Column This determines what information is being presented. 

Record Count Displays the total number of records. 

Summary 
Value 

Displays a value. In the above example, the value is the total value of 
the commits (Contracts + Change Orders) for each CBS code. To enter 
a formula, click the Formula button. 

Summary 
Type 

Choose one of the following: 

 Summary: Provides a summary value. 

 Average: Displays the average value. 

 Maximum: Displays the maximum value. 
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 Minimum: Displays the minimum value. 

Condition 
Specify the condition that will trigger the alert. This can be used for 
record count or summary value. 

Trigger Value
Enter the value of the record count or summary value that will trigger 
the alert. 

Indicator 
Allows you to specify a flag icon (red, yellow, or green) in the alert to 
help you identify the level or type of alert. The flags have no meaning 
other than user-defined identification. 

Data elements 

Data 
Element 

Description 

Query 
parameters 

This data element will allow query parameters to be printed with the 
report result. 

Project/Shel
l list 

This data element will allow project or shell list information to be printed 
with the report result. 

The display of numeric data elements can be formatted. The following formats are available: 

 Decimal place: Number of decimals to display 

 User1000 separator: Display of comma separator 

 Negative number format: Minus sign or parenthesis; for example, -1234 or (1234) 

Query tab (all reports) 

The Query tab defines query parameters to input at report runtime. For example, for a funding 
report, the query can be set to run the report only on specific company funds. You can define the 
funds or allow the user to specify them at runtime. 

The data elements available for the query will depend on the report data type. Defining a query 
is optional. See Define report queries (query condition) (on page 583). 

This button: Does this: 

Add Allows you to add a query condition to the report. 

Modify Select a query condition and click to modify. 

Remove Select a query condition and click to delete it from the report. 

Show results 
matching any 
condition 
(instead of all) 

Select this to show report results matching one or more of the listed 
query conditions. If you do not select this option, the report results will 
include only those that match all listed query conditions. 
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Layout tab (all reports) 

The Layout tab allows you to configure the layout and presentation of the report results. If you 
do not define layout parameters, the default settings will be used. The Layout tab is the same for 
all reports with the following exceptions: Cross tab reports and tabular reports each include an 
additional layout option specific to their report types (see Layout tab (Cross Tab setting) (on 
page 575) and Layout tab (Group By setting) (on page 576)). 

Click on the Report Properties options on the left side of the window to define each layout. 

Layout tab (Page Setup setting) 

The Page Setup on the Layout tab allows you to configure the size and orientation of the report 
(see below.) 

In this field: Do this: 

Report 
Properties 

Choose Page Setup. 

Size 
Choose the paper size from the drop-down list (letter, legal, ledger, or 
A4). 

Orientation Report can be generated as portrait or landscape. 

Layout tab (Title Page, Header, Footer, Summary Page settings) 

The Title Page, Header, Footer and Summary Page options allow you to define general layout 
and presentation of the report results. If you do not define layout parameters, the default settings 
will be used. A number of standard and report-specific data elements are available to add to 
your report. 

Tip: If you want users to be able to add a runtime note, include the data 
element Runtime Notes in the layout. 

Report Properties Description 

Title Page 
You can create an optional title page, which will be the 
first page of the report. 

Header 

You may enter a header for the report. This will display 
at the top of each page of the body of the report. The 
header will not display on the title page or the summary 
page. 

Footer The footer will display at the bottom of each page of the 
body of the report. The footer will not display on the title 



Setting up the User-Defined Reports

575

page or the summary page. 

Summary Page 
The summary page will display as the last page of the 
report. 

For more information about setting up these report properties, see Set up title page, header, 
footer and summary page (on page 584) 

This button: Does this: 

Add 
Click the Add button to add additional rows of text to 
the title page, header, footer, or summary page. 

Modify Select a row and click Modify to edit it. 

Remove Select a row and click Remove to delete it. 

Move Up or Move Down 
Select a row and click Move Up or Move Down to 
change the order of the rows. 

Current Height 
Displays the total height of the text (sum of the pixels 
of all lines) in the header, footer, title page, and 
summary page. 

Maximum Available Height 
Displays the maximum height available, based on the 
paper size and orientation. 

Show Border Select if you want the text to be enclosed in a border. 

Layout tab (Cross Tab setting) 

For cross tab reports. The fields here are applicable for time stamp data element types in the 
first column and body columns, as selected in the Data Elements tab). 

In this field: Do this: 

By Sets the time period for the report by year, quarter, month, or day. 

Format Select the format of the By field. 

From and To 
Specify the date range on which you want to report. You can select 
Auto Range instead. 

From: Auto 
Range 

The Auto Range feature automatically displays data in report results 
without specifying a date range. You can select Auto Range for either 
or both to and from dates. If the From Auto Range option is selected, all 
available data up until the specified end date will display in the report. 
For example, if you want to view all data up to 2005 but want to exclude 
2006, you would click Auto Range From and select a To date of 2005. 

To: Auto 
Range 

If the To Auto Range option is selected, all available data from the 
specified start date until present will display in the report. For example, 
if you want to view data starting from 2004 to present, click Auto Range 
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and select From Date of 2004. 

Layout tab (Group By setting) 

Tabular reports can include grouped data element results, for example, grouping BP record 
results by BP creator. 

Note: For Unifier Mobile users, if the Group By option is set on reports 
(that is, group by user name), you cannot mark these reports as mobile. 
Reports marked as mobile cannot contain groupings of data results. 

This button: Does this: 

Add Click to add a group. 

Modify Select a group and click to modify the Group By properties. 

Remove Select the group and click to remove. 

Projects tab (program-level reports, all types) 

This tab appears only in program-level and company-level reports, and displays which projects 
will be included in the report (see below.) The Projects tab is set up the same way for each 
report type. 

For program-level reports, the projects that are part of the program are listed in the Projects tab 
and are not editable. 

Projects/Shells tab (program-level and company-level reports, all types) 

This tab (see below) appears only in program-level and company-level reports, and displays 
which shells and projects will be included in the report. 

For company-level reports, the Project/Shells tab displays all shells in the company. The report 
can automatically include all active and on-hold projects or shells in each report generated, or it 
can be edited to include a subset of project or shells and optionally allow users to modify the 
project or shell list during runtime. 

This button or option: Does this: 

Automatically add all 
active, view-only, and 
on-hold projects/shells 

When this option is chosen, the generated report will 
automatically include all active, view-only, or on-hold projects 
and shells. Inactive projects and shells are not included in the 
generated report results. 

Only data from 
selected projects/shells

This option allows you to select which projects/shells (with 
Active, On-Hold, or View-Only status) to include in the report. 



Setting up the User-Defined Reports

577

To add a project or shell, click the Add button. In the Select 
Project window, select the project/shell to add and click Add. 

To remove a project or shell from the report, select it from the 
list and click Remove. 

Allow users to modify 
value(s) during 
execution 

This checkbox is enabled if "Only data from selected 
projects/shells" is chosen. When this checkbox is selected, 
users will be able to specify which projects or shells from the 
available list to include in the generated report. 

Shells tab (shell-level reports, all types) 

This tab appears only in shell-level reports, and displays which shells will be included in the 
report. 

This button 
or option: 

Does this: 

Shells 

The options in this field are: 

Current Shell and sub-shells 

Current Shell Only 

Subshells Only 

User-Defined 

The User-Defined option allows you to choose from among the shells in 
which you are a member. 

Exclude 
Inactive 
Shells 

Allows you to exclude shells with the status Inactive. This is checked by 
default. 

Add 
When you click Add, the Select shell window opens. Select the shells 
and click the Add button. This button is available only if you have 
selected the User-Defined option in the Shells field. 

Remove 
Select a shell and click Remove to remove it from the report. This 
button is available only if you have selected the User-Defined option in 
the Shells field. 

Allow users 
to modify 
User-defined 
list during 
execution 

This checkbox is enabled if User-Defined is chosen. When this 
checkbox is selected, users will be able to change which shells from the 
available list to include in the generated report at runtime. 
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Permission tab (all reports) 

In the Permission tab, you can grant permission to other users to run, edit, or modify the 
permissions of this report. This tab is available only in User Mode and not in the report template. 

Schedule tab (all reports) 

The Schedule tab enables report owners to create a schedule to automatically run user-defined 
reports and save the results as PDF or XML files, automatically save the report in the Document 
Manager, and to specify whether to email the report results to the report owner or to specified 
users and groups. 

In this field: Do this: 

Enable Scheduled Report 
Runs 

Select this checkbox to enable scheduling of 
automatic report runs. Define the following 
parameters. 

Output Format 
Specify the format of the scheduled report results: 
PDF or XML. 

Frequency 

Specify the frequency with which the report will be run:

Daily: Runs once at the end of the day (23:59:59). 

Weekly: Specify the day on which the report will be 
generated, e.g., from previous week Saturday 
(00:00:00) to this week Friday (23:59:59). 

Monthly: Specify the date on which the report will be 
generated. If the scheduled date is past the last day of 
the month (e.g., the 31), the report will automatically 
be generated on the last day of that month. E.g., 
monthly (08/04/06) frequency should take last month 
(07/05/06 00:00:00) to this month (08/04/06 23:59:59).

Quarterly: Generated at the end of each calendar 
quarter. E.g., data generated end of Q2 should be Q2 
(04/01/06 00:00:00) to end of quarter Q2 (06/30/06 
23:59:59). Q1 is Jan to March, Q2 is April to June, Q3 
is July to Sept, Q4 is Oct to Dec. 

Yearly: Report is generated at the end of the calendar 
year. E.g., data generated end of 2006 should be 2006 
01/01/06 00:00:00 to 2006 12/31/06 23:59:59. 

Range of Recurrence 

Choose the range of recurrence of the scheduled 
report: 

No end date: The report will be generated according 
to schedule indefinitely. 

End by: A date after which the scheduled report will 
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not be generated. 

Auto-email as attachment to 
report owner 

Select to have a PDF or XML copy of the report 
emailed to the report owner after generation. You can 
select this option and Auto-email as attachments to 
users and groups at the same time. 

Auto-email as attachments to 
users and groups 

Select to have a PDF or XML copy of the report 
emailed to selected users and groups. Click Select, 
specify the users and groups, and click OK. You can 
select this option and Auto-email as attachments to 
report owner at the same time. 

Note: If a user is selected twice, as an individual user 
and as a member of a selected group, the user will 
receive only one email. 

Saved Result Log 
Select this check box to save the report in Unifier, 
where you can view it at your convenience 

Document Manager 

Use these options to save the report in the Document 
Manager. 

In the Save as field, Unifier shows the name of the 
report; however, you can enter another name for the 
report if you want. 

In the Location field, click Select and choose the folder 
in the Document Manager in which the report should 
be saved. (You must have permissions to the folder.) 

Add and manage data elements (columns) to the report 

The following procedures describe how to add data elements to a user-defined report or 
template. These become the columns on the report at runtime, and determine what data will be 
displayed on the report. 

To add data elements to the report 

1) In the Edit Report window, click the Data Elements tab. 

2) Click Add Elements. The Data Element Picker opens. 

3) Choose one or more data elements from the list. (Press the Ctrl or Shift keys to select 
multiple data elements.) 

4) Click OK. 

Add formulas to data elements 

If you want to display the results of calculations based on data elements available for the data 
type you chose, you can create a formula column on the report. 

Note: Use caution when creating a formula with data elements. It is 
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possible to create a formula where the denominator is zero, which can 
cause a data conflict error when the report is run. 

To add a formula 

1) In the Edit Report window, Data Elements tab, click the Add Functions buttons. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Formula. The Data Element Properties 
window expands. 

3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the alignment, column width, 
decimal places, 1000 separator, and negative number format. 

4) If you select Hide Column, the column will not be displayed on the report. 

5) Selecting Summary will display the sum of the column values at the end of the column. 

6) Click Formula to open the Formula Creator. Create the formula and click OK. 

To add a date add column 

1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Date Add. The Data Element Properties 
window expands. 

3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the width (in pixels) and 
alignment. If you select Hide Column, the column will not be displayed on the report. 

4) For the Date field, click Select and choose the date data source. 

5) For the Add field, select the numerical data source. This is the value that will be added to the 
date element to arrive at the final value to display in the report. 

6) If you want the time to also display as well as the date, then select the Display Timestamp
checkbox. 

7) Click OK. 

To add a date difference column 

1) In the Edit Report window, Data Elements tab, click the Add Functions button. The Data 
Element Properties window opens. 

2) From the Data Element drop-down list, choose Date Difference. The Data Element 
Properties window expands. 

3) Enter a column heading, which is displayed on the report. 

You may specify how the column is displayed by specifying the width (in pixels) and 
alignment. If you select Hide Column, the column will not be displayed on the report. 

4) Specify the earlier date and later date. Choose Today if you want to use the current day as 
one of the dates, or click Select to open the Data Element Picker. Select a data source from 
the drop-down list, then select a data element from the resulting list. 

5) If you want to show results with partial days, then select the Show Partial Days checkbox. 
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Note: Date Picker data elements (as opposed to Date Only pickers) 
include timestamps. When calculating the difference between these date 
and times, it is possible to get a result in partial days. If you select this 
checkbox, results will display two decimal places; if you do not select this 
checkbox, results will be in whole numbers. 

6) Click OK. The calculation is Later Date - Earlier Date, in days. 

Manage report column (data element) properties 

You can refine the display of the report columns by modifying the data element properties. You 
can modify the column heading, width and alignment, as well as hide a column, or choose to 
display the timestamp for date pickers. 

To view or modify column properties 

1) In the Edit Report window, Data Elements tab, select the listed data element and click 
Modify. 

2) You can modify the column heading, column width, and alignment for how you want it to 
appear in the report results. 

3) Click OK. 

To hide data elements in the report output 

1) Select the listed data element and click Modify. 

2) Select Hide Column if you do not want the column to appear on the report (for example, 
columns added as part of a formula calculation but do not need to be printed). 

3) Click OK. 

To display the timestamp on date data elements 

1) Select the listed date picker data element and click Modify. For date picker elements that 
include timestamps, the Data Element Properties window displays an additional option: 
Display Timestamp. This option is not available for data elements based on date-only 
pickers, or other elements that do not capture timestamps. 

Note: The Schedule Manager ignores timestamps, therefore, date fields 
associated with the Schedule Manager will not display the time, even if 
this option is selected. 

2) Select Display Timestamp. At runtime, the time displays next to the date. 

3) Click OK. 

To remove a listed data element 

Select the data element to remove from the report and click Remove. 

To change the order of the data element columns 

Select a data element from the list. Click Move Up (Left) to move the element up the list to the 
left on the report), or Move Down (Right) to move it down to the right on the report. 
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To choose the column by which to sort the report 

1) Click the Sort button. 

2) In the Column Heading list box, select the data element column by which you want to sort 
the report findings. For example, choose Creator Name to sort by the creator of each record. 

3) Click the right arrow button >> to move it to the Sort By field. 

4) In the Sort Order list, choose Ascending or Descending. Click OK. 

Set auto range 

The auto range feature for cross tab report types automatically displays report data without 
having to specify a date range. During set up, you select the data types. Only time stamp types 
enable the option for configuring the date range and auto range. 

For example, if 2005 to 2006 is specified as the date range but only values for 2005 have been 
entered, the report will only display data for 2005. If a date range is not specified, all data will be 
displayed in the generated report. 

At runtime, users will have the option to select dates or auto range. 

To enable the auto range option 

1) From the Edit Report window, click the Data Elements tab. 

2) Set time stamp data element (date) under First Column or Body Columns. 

If no timestamp data element is specified, all dates with data will be displayed when the 
report is generated. 

3) Click Apply. 

To set the auto range 

1) Click the Layout tab, then click Cross Tab. There are two checkboxes for auto range. 

Note: Only report columns with data appear for non-time-stamp data 
types. If a data value is not entered, the column will not appear in a 
cross tab report. If you select the time stamp data type, report columns 
appear, even if data is not entered. 

2) For From Date, click the Auto Range radio button. 

The date selection option will be grayed out. If From Date is selected and To Date is 
deselected, all data up until the specified end date will display in the report. For example, to 
view data up to 2005 but exclude 2006, click Auto Range and enter a To Date of 2005. 

Alternatively, to view data from 2004 to present, deselect Auto Range and enter a From Date 
of 2004. 

3) For To Date, click the Auto Range radio button. 

The date selection option will be grayed out. If From Date is deselected, data entered from 
the specified start date until present will display in the report. For example, to view data 
starting from 2004 to the present, click Auto Range and enter a From Date of 2004. 

Alternatively, to view data up to 2005 but exclude 2006, deselect Auto Range and enter a To 
Date of 2005. 
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If you select both options for the Auto Range From and To dates, only the data supplied for 
this period will appear in the report. 

Grant report edit or run permissions to other users 

If you are the creator or owner of a report, or if you are an administrator with full access 
permissions, you can grant permission to other users to access or run a report. 

To grant report permission to other users 

1) In User Mode, navigate to the user-defined report log. Select the UDR and click the Edit
button. The Edit Report window opens. 

2) Click the Permission tab. 

3) Click the Add button. The User/Group Picker opens. 

4) Select users or groups, click Add and OK. 

5) Select the newly added user or group, and select the permissions to grant: 

 Modify Permission: Allows the user to modify other users’ permission settings for the 
report. 

 Edit Report: Allows user to edit report parameters. 

 Run: Enabled by default. Allows the user to run the report. 

6) Click Apply to save your changes and then OK to exit the Edit Report window. 

Define report queries (query condition) 

You can define query parameters that users can input at report runtime. For example, for a 
funding report, the query can be set to run the report only on specific company funds that the 
user specifies at runtime. Defining a query is optional. 

The data elements available for the query will depend on the report data type, and the condition 
options will be dependent upon the data element type chosen. 

To define a query 

1) From the Query tab, click Add. The Query Condition window opens. 

2) Click the Select button to open the Data Element Picker. Choose a data source from the 
drop-down list, and then choose a data element from the list. 

Note: If you choose a date-type data element, the Use timestamp in 
query checkbox becomes available; if you select this option, the 
timestamp as well as the date will be taken into account in the query. 

3) The Label field is populated based on the selection and can be modified. 

4) Select a condition from the resulting list. 

For example, choose equals to generate reports that exactly meet certain conditions or 
since last scheduled report run to generate reports with incremental data between 
scheduled runs. 

5) For Values, click the Select button and select one or more values for the condition (e.g., 
Pending or Approved). 
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For maximum flexibility, choose a list of conditions but leave the value empty. This allows the 
user who runs the report to choose to use one or all of the queries to limit the data on which 
the report will be based. 

6) If you want users to be able to modify these values when running the report, select Allow 
users to modify value(s) during execution. This option is checked by default and 
recommended to provide flexibility at report runtime. 

7) Click OK. 

Set up title page, header, footer and summary page 

You can set up the report’s title page, header, footer, and summary page from the Layout tab. 
These are all set up in a similar way. 

 The title page is printed as the first page of the report. 

 The header is printed at the top of each of the results pages. 

 The footer is printed at the bottom of each of the results pages. 

 The summary page is printed at the end of the report, after the results. 

To set up the title page, header, footer, and summary page 

1) In the Edit Report window, click the Layout tab. 

2) Under Report Properties, click Title Page, Header, Footer, or Summary Page. 

3) Click Content and select from the list. The drop-down options are the same for left, center, 
or right columns. 

 Number of Projects/shells: Displays the number of projects or shells within the phrase 
"This report contains data from n projects or shells." 

 Page: Shows the page number for each page of the report. 

 Project/Shell List: Provides a list of all of the projects or shells from which data is used 
for the report, in the format Project/Shell Number: Project/Shell Name. Can be used for 
reports on one or multiple projects or shells. 

 Project/Shell Name: Displays the project or shell name when the report is for a single 
report. If multiple projects or shells are included in the report, the names will not be 
displayed (use Project/Shell List instead). 

 Project/Shell Number: Displays the project or shell number when the report is for a 
single report. If multiple projects or shells are included in the report, the numbers will not 
be displayed (use Project/Shell List instead). 

 Query Parameters: Displays the query parameters entered from the report. 

 Report Owner: Displays the report owner. 

 Report Run By: Displays the user who ran the report. If the report was generated by 
schedule, the name of the report owner will be displayed. 

 Report Title: Displays the title of the report. 

 Run Date: Displays the date on which the report was run. This date/time reflects server 
time, that is, the time zone in which the server running your Unifier environment is 
located; for most users, this will be Pacific Time (GMT -8). If you have any questions 
regarding server time for your environment, contact your Company Administrator. 
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 Run Date and Time: Displays the date and time on which the report was run. This 
date/time reflects server time. 

 Time Zone: Displays the time zone that is applicable for the report, as chosen in the 
General tab of the Edit Report window (a default time zone or the user’s at runtime). 

 Runtime Notes: Choosing this option does two things: provides a text box in which to 
enter notes that will appear on each report (for example, "Runtime Notes:"), and activates 
a Runtime Notes text box in the Notes tab during runtime in which the user running the 
report can add notes that will appear on the current report only. 

 Text: Provides a text box in which you may enter text to be displayed on the report. 

4) Keep an eye on the fields in the bottom of the window: 

 Current height (pixels): Displays the total height of the text (sum of the pixels of all 
lines) in the header, footer, title page, or summary page. 

 Maximum available height: Total allowable height. 

 Show Border: Selecting this checkbox will display a four-sided border around the title 
page, header, footer, or summary page text. 

The following figures display the default layouts of the header, footer, and summary page 
options. These are customizable. 

Schedule report runs 

Report owners can schedule automatic generation of user-defined reports. The report can be 
scheduled to run daily, weekly, monthly, quarterly, or yearly. Schedule report results will be 
saved and can be retrieved later, or can be optionally emailed. 

Users with run permissions will be able to retrieve the generated reports. Report owners can 
schedule generation of the report. 

To schedule report runs 

1) Open the Edit Report window for the report and choose the Schedule tab. 

2) Select the Enable Scheduled Report Runs checkbox. 

3) Select the output format: 

 PDF: The results will be saved in a PDF file, which can be read using Adobe Acrobat 
Reader. 

 XML: The results will be saved in an XML file. 

4) Specify the frequency with which the report will be run: 

 Daily: Report will be run daily. 

 Weekly: Specify the day on which the report will be generated. 

 Monthly: Specify the date on which the report will be generated. If the scheduled date is 
past the last day of the month (e.g., the 31st), the report will automatically be generated 
on the last day of that month. 

 Quarterly: Generated at the end of each calendar quarter. 

 Yearly: Report is generated at the end of the calendar year. 

5) Specify the range of recurrence of the scheduled report: 

 No end date: The report will be generated according to schedule indefinitely. 
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 End by: A date after which the scheduled report will not be generated. 

6) Select Auto-email as attachment to report owner to have a copy of the report emailed as 
a PDF or XML file attachment, based on your output format selection. 

Or, select Auto-email as attachment to users and groups to have a copy of the report 
emailed as a PDF or XML file attachment, based on your output format selection. Click 
Select, specify the users and groups, and click OK. You can select this option and 
Auto-email as attachments to report owner at the same time. 

Note: Be sure to specify Results from scheduled reports in your user 
preferences email management to receive the email and attachment. 

7) Select the Saved Result Log checkbox to save the report in Unifier, where you can view it 
at your convenience. 

8) Select the Document Manager checkbox to save the report in the Document Manager. 

In the Save as field, Unifier shows the name of the report; however, you can enter another 
name for the report if you want. 

In the Location field, click Select and choose the folder in the Document Manager in which 
the report should be saved. (You must have permissions to the folder.) 

9) Click OK. 

Report Run Times 

Run time reflects server time, that is, the time zone in which the server running your Unifier 
environment is located; for most users, this will be Pacific Time (GMT -8). If you have any 
questions regarding server time for your environment, contact your Company Administrator. 

 Daily: 23:59:59 

 Weekly: E.g., from previous week Saturday (00:00:00) to this week Friday (23:59:59). 

 Monthly: E.g., monthly (08/04/07) frequency should take last month (07/05/07 00:00:00) to 
this month (08/04/07 23:59:59) 

 Quarterly: E.g., data generated end of Q2 should be Q2 (04/01/07 00:00:00) to end of 
quarter Q2 (06/30/07 23:59:59). 

 Q1 is Jan to March, Q2 is April to June, Q3 is July to Sept, Q4 is Oct to Dec. 

 Yearly: E.g., data generated end of 2007 should be 2007 01/01/07 00:00:00 to 2007 
12/31/07 23:59:59. 

Generate reports with incremental data between scheduled runs 

You can generate reports that only include information added since the last scheduled run for 
the report. 

To generate reports with incremental data for every scheduled run 

1) Open the Edit Report window and choose the Query tab. 

2) Click the Condition drop-down list and choose since last scheduled report run. 

3) Click OK. 
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Enable a report for web services integration 

You can flag project or shell and company user-defined reports as eligible for integration. This 
enables report results to be available for integration with other systems through web services 
and uLink. This option is not available for program-level reports. Contact Oracle Customer 
Support for information regarding XML integration via web services. 

To enable a user-defined report for web services integration 

1) Open the Edit Report window and choose the General tab. 

2) Select the Enable for Integration checkbox and click OK. The integration icon  will 
display in the UDR log next to the report. 

Report Names: Because web services uses the report name to identify 
reports, each report marked for integration must have a unique name. 
For project- or shell-level reports, this applies to all UDRs within a 
specific project or shell. For company-level reports, it applies to all 
company-level UDRs. If there are two reports with the same name, only 
one of those reports can be marked for Integration. This is true even if 
you cannot see the other report with the same name. For example, 
another user has created a report with the same name, for which you do 
not have view permission, and marked it for integration. 

Access Control Permissions for UDRs 

You can assign User-Defined permissions in the following permissions-related module:  

 Access Control

1. Go to Company Workspace tab (Admin mode) and click the Access Control node. 

2. Click to expand User Mode Access. 

3. Click to expand Reports. 

Project/Shell, Program, and Company Level 

Use the Create Permission Based permission to define if the User-Defined report (UDR) being 
created will have data sources that are permission-aware. The permission aware data sources 
are defined as data sources that only return data that the user has permissions to see by way of 
the user-interface (UI). This is based on records returned. That is to say, the user will be able to 
see the data that is in hidden blocks or hidden tabs. The following data sources are available to 
create permission-aware UDRs: 

 Business Process (BP) 

 Document Manager  

By default the Create Permission Based permission will be selected when user selects the 
Create permission for the user-defined reports. 

Permission Level Description 

The following permissions are selected: The user will be able to create report for all 
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Permission Level Description 

 Create All

 Create Permission Based

data sources as well as permission aware 
BP data sources. 

The following permissions are selected 
with "Full Access" attribute. 

 Create All

 Create Permission Based

The user will be able to create report for all 
data sources as well as permission aware 
BP data sources. 

The following permission is selected: 

 Create Permission Based

The user will be able to create report for 
permission aware BP data sources, only. 

The "Full Access" attribute is selected. The user will be able to create report for all 
data sources as well as permission aware 
BP data sources. 

 The "Access All Projects" attribute is 
selected. 

The user will be able to create report in all 
projects. 

Notes: 

 The user will not be able to deselect the Create Permission Based 
permission and only select the Create All permission. 

 For Company-level access control changes, the same changes will be 
applicable to Shell/Projects (Standard) node.  

You can assign User-Defined permissions in the following permissions-related module, and the 
Create Permission Based permission is available in these modules: 

Note: Templates (for both Company-level and Project-level UDRs) will 
be able to create system data sources templates, only. 

 User Administration

1. Go to Company Workspace tab (Admin mode) and click the Access Control node. 

2. Click to expand the User Administration. 

3. Assign through Company Users, Partner Users, or Groups sub-nodes. 

 Standards & Libraries

1. Go to Company Workspace tab (Admin mode) and click the Access Control node. 

2. Click to expand Standards & Libraries. 

3. Assign through Permission Templates sub-node. 

Access Control Changes after Upgrade (Migration) 

In both Project/Shell Access Control and Company-level Access control: 

 If the previous Create permission was selected, then after upgrade (migration) both check 
boxes (Create All and Create Permission Based) will be selected. 
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 If the Full Access permission is selected (all 3 check boxes) after upgrade (migration), then 
the Full Access, Create All, and Create Permission Based will be selected, after upgrade 
(migration). 
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Creating User-Defined Project, Shell, Program, and Company Reports 

Before running a report, it must first be created and set up to define its parameters. The 
following procedures describe creating UDRs at the project or shell, program and company 
levels. This section will show you how to: 

 Access project, shell, program, and company UDRs 

 Create a UDR by copying a template 

 Create a UDR by copying an existing report in the same log 

 Create a UDR from scratch 

In This Section 

Accessing User-Defined Reports (UDRs) .............................................................. 591 
Create a UDR from a report template .................................................................... 593 
Editing or Deleting User-Defined Reports .............................................................. 594 
Importing User-Defined Reports into Project or Shell Templates ........................... 594 

Accessing User-Defined Reports (UDRs) 

User-defined reports (UDRs) are set up and run in User mode.  

You can run UDRs at: 

 Project-level 

 Shell-level 

 Program-level 

 Company-level 

When you are running a report based on a permission-aware Document Manager data source, 
Unifier allows you to see the report only if you have permission to see the data source, in case 
of:  

 Document Manager - Company 

 Document Manager - Project/Shell 

To access a project-level user-defined reports 

In User mode, open a project or shell. Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

To access a shell-level user-defined reports 

In User mode, open a project or shell. Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

To access a program-level user-defined reports 

In User mode, open a program. Navigate to Reports > User-Defined. The User-Defined 
Reports log opens. 

To access a company-level user-defined reports 
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In User mode, open the company (User mode). Navigate to Reports > User-Defined. The 
User-Defined Reports log opens. 

The following describes the User-Defined Reports log elements, for the Company Workspace 
tab (Admin mode) > Templates > Project (Standard) > All > click a [project] to open > 
Reports > User-Defined Reports.  

User-Defined Reports log menu options: 

File Enables you to perform the following actions: 

 New

 Copy

 Report

 Template

 Open

 Update Projects

 Projects

 All Projects

 History

 Import

Edit Enables you to edit or Delete a report. 

View Enables you to perform the following actions: 

 All

 Find

 Saved Results

 Audit Log

Help Enables you to access: 

 Unifier Help

 Unifier Library

 User Productivity Kit

 About Unifier

User-Defined Reports log toolbar options: 

New Enables you open the Create a new report (Create User-defined Report) 
window and set up the following fields: 

 Data Type

 Element

 Report Type

 Access Type
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Copy Enables you to copy a: 

 Report

 Template

Open Enables you to open a record. 

Edit Enables you to edit a report. 

Delete Enables you to delete a report. 

Find Enables you to find a report on the log. 

Saved 
Results

Enables you to see the saved results. 

Update 
Project
s

Enables you to access: 

 Projects

 All Projects

 History

Import Enables you to import a report. 

User-Defined Reports log columns: 

The columns provide the following details about each UDR. 

 Name

 Description

 Data Type

 Access Type

 Report Type

 Owner

 Creation Date

 Last Modified By

 Last Modified Date

 Scheduled

 Last Run Date

Create a UDR from a report template 

The following procedure explains how to create a UDR by copying an existing report template. 

To create a user-defined report from a template 

1) Navigate to the project, shell, program, or company User-Defined Reports log. 

2) Click the Copy button and choose Template. The Copy From Report Template window 
opens. 
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3) Select a template from the list and click the Copy button. The Edit Report window opens. 

4) Review the parameters on each of the tabs and edit as necessary. See Creating a UDR 
Template (on page 567) for details on the tabs. 

5) Click Apply to save changes, or OK to save changes and close the Edit Report window. The 
report is listed in the log. 

To create a user-defined report from an existing report 

1) Navigate to the project, shell, program, or company User-Defined Reports log. 

2) Select a report from the log. 

3) Click the Copy button and choose Report. The Edit Report window opens. The default 
name is "Copy of Template Name." 

4) Follow the steps in the procedure Creating a UDR Template (on page 567). 

To create a user-defined report manually 

1) Navigate to the project, shell, program, or company User-Defined Reports log and click New. 

2) Follow the instructions in the procedure Creating a UDR Template (on page 567). 

Editing or Deleting User-Defined Reports 

You can edit most report parameters and assign report permissions to each report in User 
Mode. You can also view the list of projects or shells that will be included in program-level 
reports, and select the projects or shells to include in company-level reports. 

This is applicable if you are the report owner, if you have edit permission, or if you are an 
administrator with full access permissions. 

To edit a user-defined report 

1) Navigate to the UDR log and select the report to edit. 

2) Click the Edit button. The Edit Report window opens. Review or edit the parameters on the 
tabs. For more information about each of the tabs, see Creating a UDR Template (on page 
567). 

3) Click Apply to save changes, or OK to save changes and close the Edit Report window. 

To delete a user-defined report 

Select it from the log and click Delete. 

Importing User-Defined Reports into Project or Shell Templates 

You can import user-defined reports into project templates from project templates in other 
Companies or other Unifier environments. Also, you can import user-defined reports into shell 
templates of the same shell type from other Companies or other Unifier environments. This 
enables you to reuse reports created in other companies or environments. 

To import user-defined reports:  

1) Go to the Company Workspace tab and switch to Admin mode. 

2) In the left Navigator, click:  
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 Templates > Project (Standard) > All > click a [project] to open > Reports > 
User-Defined Reports or 

 Templates > Reports > User-Defined Reports

3) In the User-Defined Reports log, from the toolbar, click Import ( ) to open the 
Unifier Login window opens. 

4) Enter the following information: 

 Company Short Name: this is the identifier used for your company, and was set up at 
the time of company configuration. 

 Authentication Key: this key is set up at the time the company was configured. Contact 
your Site Administrator for further information. 

 Unifier URL: the web address of the Primavera Unifier server. 

 Search For: use to narrow your search for the report you want to import. 

5) Click OK. The Import Report Template from Unifier window opens, listing the user-defined 
reports. 

6) Choose the report or reports and click Import.  

In case of errors, the UDR Import Error window opens, listing any import errors. These are 
some possible report import errors: 

 Source and destination report environments have different versions of Unifier 

 Report already exists in the destination if the report is enabled for Integration 

 Report data sources vary between the report source and destination 

If there are no errors, all reports are imported; if there are errors, none of the reports are 
imported until the errors are rectified. 

Note: If you are importing a user-defined report into a shell template, the 
report you import must be from a shell of the same type as the 
destination shell template. 

7) When the import is complete, click OK. 

8) Click Close to exit the Import Report Template from Unifier window. The reports are 
added to the User-Defined Reports log. When you import a user-defined report, you are 
listed the report owner. For more information about the User-Defined Reports log, see 
"Accessing User-Defined Reports (UDRs)."  
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Configuration Package Management 

You can manage the configuration package creation and import through the Configuration 
Package Management node in the left-hand Navigator.  

To access the Configuration Package Management node, go to Company Workspace tab > 
Admin mode > Configuration Package Management. 

The Configuration Package Management node has the following sub-nodes: 

 Component Lists

A central repository which contains all the component lists designed in a given environment. 

 Add-on Component Lists 

To create add-on component list in order to create configuration package that can be 
imported in to a different development environment. 

Note: The Add-on Component Lists sub-node, along with the 
Component Lists sub-node, is available in the development servers, 
only. 

The Add-on Component Lists sub-node is available for the users who have "enable" 
permission for the Configuration Package Management module.  

 Configuration Packages

The configuration packages in form of zip files that exist in the given environment. The 
packages displayed in the log are the packages that you have created in, or imported from, 
the given environment. 

 Add-on Components Packages 

To create add-on components packages that can be imported in to a different development 
environment. 

Note: The Add-on Components Packages sub-node, along with the 
Component Lists sub-node, is available in the development servers, 
only. 

The Add-on Components Packages sub-node is available for the users who have "enable" 
permission for the Configuration Package Management module.  

The following explains each sub-node in details. 
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Accessing Configuration Package Management Node 

Access to the Configuration Package Management node is controlled by permissions. 
Granting permissions to the Configuration Package Management node is similar to granting 
permissions to the Design Bundles node, under uDesigner.  

To grant permissions to the Configuration Package Management node, go to Access Control
and select Configuration Packages (Company Workspace tab > Admin mode > Access 
Control > Administration Mode Access > Configuration Packages). 

You can use the Module Permission Settings window to add, modify, or remove users groups. 

When you click Add to add a user, the Permission/Access Control window opens. In this 
window (under Permission Settings field), you can grant permissions to both users and groups 
by clicking to select Enable. 

Note: Users are able to view the contents of this node. 

Component Lists 

The sub-node lists all the component lists existing in an environment and has the following 
options:  

 Create

 View

 Filter

Note: When you click the View option to open or edit the component list, 
the system displays the existing selections that were made while saving 
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the report previously. You can proceed with the new list creation. 

The details related to the component lists are presented in the following columns: 

 Name

The name assigned to the component list by the user at the time of creation. 

 Last Error Check Status

The status for component list is determined by the Error Check action. There are three 
different statuses for the component list: 

 Pending: This status will be seen for the list which has not been error checked by the 
user. 

 Complete: This status will be seen when the user has performed the error check and 
there are no errors existing for the component list. 

 Error: This status will be seen when the user performed error check and there are errors 
which need to be resolved for the component list. 

 Last Error Check

The date that the error check was performed. This will honor the user's date preferences. If 
the list is in Pending status then the Last Error Check column will show empty for the 
corresponding list. 

 Creation Date

The date that the component list was created. This will honor the user's date preferences. 

 Last Modified Date

The date the component list was last modified on. 

The gear icon enables you to perform the following functions on each item: 

 Delete

The user can delete the component list; however, if the component list is a part of any Draft 
status configuration package, then the user will not be able to delete the component list, and 
the user will see the following alert message: "The component list is used in a Draft 
Configuration Package and cannot be deleted." 

The Component Lists log is sorted by default on the Creation Date column. All other columns 
can be sorted as desired. 

The component list name will be unique. If the user tries to create a duplicate list the system 
displays an alert message. 

Review the following topics for more information about: 

 Creating Component List 

Add-on Component Lists 

The Add-on Components Lists sub-node lists all of the added component lists existing in the 
development environment and has the following toolbar options:  

Notes: 

 The Add-on Component Lists and the Add-on Configuration 
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Packages follow the same naming convention as regular Component 
Lists and Configuration Packages, for package names. 

 The file names for Add-on and Component Lists cannot contain these 
characters: forward slash (/), backslash (\), colon (:), asterisk (*), 
angle brackets (< >), and vertical bar, or the pipe (|), quotation marks 
(“ ”), and question marks (?). You can use close bracket ([ ]), open 
and close braces, or curly brackets ({ }), apostrophe or single quote 
('), and semicolon (;). 

 The file names for Add-on and Configuration Packages (Package 
Name in Create and Import) cannot contain these characters: 
forward slash (/), backslash (\), colon (:), asterisk (*), angle brackets 
(< >), and vertical bar, or the pipe (|), quotation marks (“ ”), and 
question marks (?). You can use close bracket ([ ]), open and close 
braces, or curly brackets ({ }), apostrophe or single quote ('), and 
semicolon (;). 

Create

Click to create an add-on component list. When you click Create, the Shell Templates window 
opens. 

From the Shell Templates window you must select a shell template. 

Notes: 

 Ensure that the components (from the selected shell template) do not 
contain dependencies on any shell attributes. 

 You must use unique names when you create multiple add-on 
component lists. 

The user can create a configuration package by using the add-on component list, based on a 
selected shell template. 

The Shell Templates window lists all of the available shell templates defined in the server. The 
shell templates are grouped by the shell type, in the Type drop-down list, regardless of the 
status of the shell template. 

The Shell Templates window has the following toolbar options: 

 Type: Enables you to select one of the shell types of multiple instance shells. 

 Search: Enables you to filter the displayed list, based on the search parameters defined in 
uDesigner. 

 Find on Page: To search for a particular item. 

You can select one shell template, only. Once you click on a shell template from the Shell 
Templates window, you can click the Select option to open the New Add-on Component List
window. 

Depending on the shell template that you select, the New Add-on Component List window 
groups the types of components available to export on the left-hand navigator, as grouping 
nodes. The following lists some of such components: 

 Designs 
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 Data Definitions 

 Data Elements 

 Data Structure Setup 

 Configuration 

 Designs, Log Views, Customize Email Subject, Custom Templates 

 Company Workspace: Setup 

 "Shell Template Name:Shell Template Number" 

Note: The Designs component will not show the Shell Manager grouping 
node in add-on packages because you cannot include shell designs in 
the component list. 

If the selected "Shell Template Name:Shell Template Number" is displayed in the grouping 
node, then the components that are available for the shell template are as follows: 

Note: This list is based on the selected shell template. 

 Access Control 

 Setup 

 Folder Structures 

 Sheets 

 Rules 

 User Defined Reports 

 Dashboards 

All of the components available to be selected or tagged will be displayed similar to a regular 
component lists. For example, when you select "Setup," all of the components (such as the 
Business Processes, Dashboards, Gates, Configurable Managers, and so forth) that can be 
tagged will be displayed. 

When you create an add-on component list, you can perform the following additional actions, 
similar to the component lists: 

 Error Check: To open the Add-on Component Analysis window (read below) which 
displays the list of errors or warnings related to the components selected. 

 Save: To save add-on component list, with a user-specified list name. The list name will be 
shown in the log. 

 Save As: To save a component list with a new name. This allows you to work edit a 
component list. When you create an add-on component list and click Save or Save As, a 
unique name validation will take place. 

 Cancel: To discard your changes and close the window. 

Find on Page

To search for a particular item (a component list) in the Add-on Component Lists log. 

The Add-on Component Analysis window is displayed when you tag the components in the 
add-on component list and perform an error check. 
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This window displays all of the dependency errors along with the miscellaneous errors or 
warnings. When you tag a shell template components and run an error check, you will see an 
error if the tagged shell template component has a dependency on the shell attribute design of 
the selected shell template. 

For example, if the BP setup component of the shell template is tagged, and the BP design has 
data elements (such as shell picker, shell data picker, linked elements, or any data element) that 
have a dependency on the shell attribute design of the selected shell template, then the Add-on 
Component Analysis window displays an error which explains why the BP setup component 
cannot be included in the component list. 

At this stage, you will be able to fix the shell attribute design dependency errors either by 
de-selecting the components that have a dependency on the shell attribute design of the 
selected shell template, or by saving it as a draft and making the necessary design changes 
accordingly and proceed to include component back in the add-on component list. This rule 
applies to all tagged shell template components such as BP Setups, Dashboard Setups, User 
Defined Reports, and so forth. 

Note: The published designs will not be included in this add-on 
component list for the selected components. 

When you finish, you can cancel the changes or apply the changes that you have made. 

If the Add-on Component Analysis window displays no errors or warnings (related to the 
add-on component list), then Unifier displays the message: "There are no errors/warnings in the 
add-on component list." 

The Add-on Components Lists sub-node has the following columns: 

List Name The name assigned to the add-on component list, by the user, during 
creation. This is a required field in the add-on component list 
window. 

The List Name column will display the name of the component lists 
that have been created. The error check status will display the status 
of the component list, whether it is complete or in draft, similar to the 
regular component lists. 

Source Shell 
Template

This column will populate with the value "Shell Template Name:Shell 
Template Number" that the user has selected for the component list. 
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Shell Type This column will display the shell type value based on the selected 
shell template. 

The tagged components might have dependency on Cost Manager 
of that shell type. 

The Shell Type field will be populated as either CBS Cost Codes or 
Generic Cost Codes, regardless of the components that are tagged 
with in the shell template. 

Note: The Shell Type field will be populated based on the shell 
template that the user has selected. 

One of the following values will be displayed based on the shell 
template selected. Selected shell template can be of the two types: 

 Generic Cost Codes 

 CBS Cost Codes 

Last Error 
Check Status

The status will be displayed based on the error check. The values 
can be one of the following: 

 Pending 

 Complete 

 Error 

Creation Date The date the add-on component list was created. The date form is 
according to the user preferences. 

Last Error 
Check

The date the last error check was performed. The value will be 
empty if no error check was done for the add-on component list. 

The user can save the add-on component lists with errors. 

The user can also save the add-on component lists without doing an 
error check. 

The date component list is validated for any errors will be displayed 
in the Last Error Check column. 

Last Modified 
Date

The date the add-on component list was last modified. 

The gear menu options for each item in the Add-on Component Lists log: 
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Open To edit the component lists that have been created. When you click 
Open, the Edit Add-Component List window opens. 

From the top right-hand corner, use the Selected Components in 
the List menu (Numbered list icon) to open the Selected 
Components window and view, see the total number of, or update 
the selected components. The function is similar to the function of 
the View > Selected Components option; however, this menu 
option enables you to select or deselect an item from the list and 
click Update to update the list of selected or not selected 
components. 

You can use the Print menu (printer icon) to print the items on the 
Edit Add-Component List window log. 

Use the Name field to change the name of of the component. 

Use the Error Check option to run an error check for the items 
displayed on the log. 

Use Save to save any changes that you have made on an item. 

Use Save As to save an item with a different name. 

The Expand-Collapse option (plus or minus icon) enables you to 
expand or collapse the items on the log. 

The View option enables you to set the log view through the 
following options: 

 All Components: To see all of the components, in the window. 

 Selected Components: To see only the selected components, 
in the window. 

 Not Selected Components: To see only the components that 
have not been selected, in the window. 

Use the Find on Page to search for a specific item on the log. 

Delete To delete the list name if it is not used in a draft of the Add-on 
Configuration Package. 

Print To print the package contents. 

Download last 
checked 
error/warning 
report

To download the last error or warning report. 

Configuration Packages 

The Configuration Packages sub-module contains the following options:  

 Create

 Import

 View
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 Filter

The Configuration Packages log has the following columns: 

 Package Name 

 File Name 

 Description 

 Status 

 User Name 

 Creation Date 

 Published By 

 Published Date 

The Configuration Packages log is sorted based on the Creation Date column. 

The configuration package name (Package Name) is unique and cannot be duplicated. 

The options available under the gear icon ( ) are:  

 Open

 Delete

 Publish for Production (Only for Created status) 

 Download (Only for status Created, Import Success) 

 Impact Analysis Report (Only for Import Success , Import Failed, Import Error) 

 Error/Warning Report

In addition to the regular errors and warnings, you can download the error report to see 
limited information about the exception context. 

Review the following topics for more information about: 

 Creating Configuration Packages (on page 628) 

 Importing Configuration Packages (on page 640) 

 Viewing Configuration Packages (on page 645) 

Note: Pre-17.6 configuration package zip files will not be available in the 
log. If you want to view your pre-17.6 log content, Oracle recommends 
that you print your pre-17.6 log content prior to the upgrade.  

Add-on Configuration Packages 

The Add-on Configuration Packages sub-node is available for the users who have "enable" 
permission for the Configuration Package Management module. This sub-node lists all of the 
added configuration packages existing in the development environment and has the following 
toolbar options:  
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Notes: 

 The Add-on Component Lists and the Add-on Configuration 
Packages follow the same naming convention as regular Component 
Lists and Configuration Packages, for package names. 

 The file names for Add-on and Component Lists cannot contain these 
characters: forward slash (/), backslash (\), colon (:), asterisk (*), 
angle brackets (< >), and vertical bar, or the pipe (|), quotation marks 
(“ ”), and question marks (?). You can use close bracket ([ ]), open 
and close braces, or curly brackets ({ }), apostrophe or single quote 
('), and semicolon (;). 

 The file names for Add-on and Configuration Packages (Package 
Name in Create and Import) cannot contain these characters: 
forward slash (/), backslash (\), colon (:), asterisk (*), angle brackets 
(< >), and vertical bar, or the pipe (|), quotation marks (“ ”), and 
question marks (?). You can use close bracket ([ ]), open and close 
braces, or curly brackets ({ }), apostrophe or single quote ('), and 
semicolon (;). 
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Create To open the New Add-on Configuration Package window and create 
new add-on configuration packages. The process has the following steps 
(wizard interface): 

 Add-on Package Details

 Add-on Package Components - Error/Warnings

 Create

When you are done with each step, click Next to go to the next step. 

Use the Save as Draft option to save your work and change it at a later 
time. 

Add-on Package Details

This step allows you to enter or select the following for the add-on 
configuration package : 

 Add-on Package Name (required field) 

 File Name (required field) 

 Description

 Select an add-on component list (required field): A list of added 
add-on component lists is displayed under this field which enables you 
to select an item in order to include it in the add-on configuration 
package. You cannot select more than one item (add-on component 
list) for the add-on configuration package. The component list must 
have at least one component selected. The Shell Type field is 
read-only and the value is populated based the component list that you 
have selected from the list. The possible values for the Shell Type
field are: CBS Cost Codes and Generic Cost Codes. 

Once you select the required fields in the Add-on Package Details step 
and click Next, the configuration package components are shown from the 
components selected during the first step. This is a read-only view of all of 
the components from the selected component lists. For Example, if you 
select "Add-on Component List1" (including the Designs, Configurations, 
and Setups from Shell Template1), then packaged components will show 
the components from the selected list as follows: 

 Designs 

 Configurations 

 Setups (grouped by Shell Templates node) 

 User Defined Reports 

The left-hand section of the window displays the grouping node of the 
packaged components. This is similar to the regular configuration package 
component view. The right-hand side of the window shows all of the 
packaged components, for each grouping node. 

In the right-hand side of the window, the toolbar options are context 
sensitive and you can expand, collapse, search for the items on the page. 
You can also filter the components seen on the right-hand side. 

Add-on Package Components - Error/Warnings

During this step, first the error check will be performed to determine if the 
package has errors or not. If the package has no errors, then you can see 
the Create step. You will see errors when the packaged components have 
dependency to the shell attribute design. You can resolve the shell design 
dependency errors by removing the elements from the tagged 
components which are dependent on the shell attribute design. In the case 
of seeing errors, you must use Save as Draft, fix the errors at the 
application level, and then proceed to push the package to the Create 
step.
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Import To import the new add-on configuration package in the destination 
development environment. The process has the following steps (wizard 
interface): 

 Select File

 Add-on Package Details

 User Mapping

 Import

When you are done with each step, click Next to go to the next step. 

Select File

The fields seen in the Select File step are as follows: 

 File Name: The exported zip file can be added in this field. 

Note: If you select the add-on package in the regular configuration 
package, then the following message will be displayed: "The Configuration 
Package zip file is an add-on package, not a valid regular package." 

 Add-on Package Name: You can specify the package name that can 
be used for import in this field. 

 Description: You can provide additional description for the add-on 
package details in this field. 

 Source Shell Type: This field shows the selected package to import 
along with the shell type components. Unifier will populate the shell 
type value of the selected package. The shell type value is read-only 
field and can have one of the following values, after you select the file: 
CBS Cost Codes and Generic Cost Codes. 

 Select a destination shell template: This option enables you to 
select the destination shell template, where the components from 
source template can be added. By default, it will not show any shell 
templates. In this shell template log the Shell Number, Shell Name, 
and Status columns will be available. The Shell Number and Shell 
Name columns will display the number and name of the shell template. 
The Status column will show the status of the shell template. All of the 
shell templates seen are grouped by Shell Type. The list of shell 
templates will be displayed once you select the package file name. 
The shell templates list displayed will be based on the source shell 
type. For example, if the add-on configuration package that you have 
created has source shell template components which are based on 
CBS Cost Codes (shell), then the destination shell templates will show 
only the shell templates which are of CBS Cost Codes type. The 
same process applies to the Generic Cost Codes. Based on the 
source shell type the list of destination shell templates will be displayed 
in the Import step of the add-on package window. All active, inactive, 
and on-hold shell templates will be displayed based on the source 
shell type. The Find on Page option will be available to search for the 
shell template based on the name or number. By default, this option 
will not show any shell templates until you select the file name. 

 Destination Shell Template: This field gets populated with the 
selected shell template, from the right-hand side. It displays the "Shell 
Template Name:Shell Template Number." This is a read-only field and 
shows the selected shell template. By default, this field does not show 
any value. If you do not select the destination shell template and click 
Next, then the following alert message is displayed: "Select a 
destination shell template before proceeding to next step." You must 
select all of the required fields before proceeding to next step, in the 
import add-on package wizard.
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Find on 
Page

To filter the rows displayed in the log. 

The Add-on Configuration Packages log has the following columns: 

 Package Name

 File Name

 Shell Type

 Description

 Status

 Last Modified By

 Creation Date

The gear menu for each item in the Add-on Configuration Packages log has the following 
options: 

Delete To delete the item. 

Download Applicable to the items with status: Created or Import Success, only. 

Impact 
Analysis 
Report

Applicable to items with status: Import Success, Import Failed, or Import 
Error, only. 

The Add-on Configuration Packages log items are sorted according to the value of the 
Creation Date column, by default. The configuration package name must be unique and 
duplicated names are not accepted. If a configuration package exists in draft form, the system 
will not allow you to create a new (add-on) configuration package. 

The following restrictions will be applied for the Add-on Configuration Packages: 

 Additional Add-on Component Lists and Add-on Configuration Packages will be 
available only on the development server. 

 The option "Publish to Production" (in the gear menu) will not be available for the Add-on 
Configuration Packages. 

 The add-on configuration packages can be imported only within the development servers, 
from the Add-on Configuration Packages node. 

Add-on Component Lists and Add-on Configuration Packages 

Similar to the component lists and configuration package creation, when a user selects the shell 
template components to create an add-on component list, if the selected components have 
references to the custom user attributes, and the user attribute design is not included, then 
Unifier displays messages regarding the inclusion of the custom user attributes (including 
pickers) when you are creating an add-on component list and add-on configuration packages. 

Note: If the custom user attributes are shell data pickers, then when you click export Unifier 
displays error messages while creating add-on component list or add-on configuration package 
because shell data pickers are dependent on the shell attribute design.  

Example 
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The business process workflow setup filtering conditions has a shell picker as user attribute 'Site 
Picker 1' in the filtering condition. 

Creating Component List 

When you create a new component list, you can perform the following actions:  

 Error Check

When user clicks Error Check, the Component Analysis window opens displaying the list 
of errors/warning related to the component list. 

 Save

When user clicks Save, the component list will be saved with the user entered name. 

 Save As

When user clicks on Save As, a new window will open asking the user to enter the name for 
the new list. After Clicking OK button on the window, the existing component list will show the 
newly displayed name for component list and user will be able to work on the component list 
for further edits. At this point if the previous list has components selected then those will be 
retained for the new list. Also the log will be refreshed to show the new component list 
created using Save as action.The unique validation for component list will be checked when 
the user clicks on OK button. 

 Cancel

When user clicks on Cancel, the window will be closed. 

The left-hand pane of the log displays the components that you can select. When you select a 
particular component, the items for the selected component that can be added are listed, and 
you can select the items individually. You can: 

 Use the check box, on top, to select/deselect all the items. 

 Use the filter option to perform a quick filter. 

 Use the print option to print the list of selected components, in a consolidated format. 

 Use the expand all/collapse all to expand or collapse the component seen in the Grouping.  

The component list name is unique. If the user tries to create a duplicate list, the system displays 
an alert message. 

The left-hand pane (navigation tree) in the window displays the following nodes: 

 Designs 

 Data Structure Setup 

 Company Access Control 

 Configuration 

 Company Workspace 

 Company Templates 

 Shell Templates 

 Single Instance Shells 

 Analytics 

The following explains each node in details. 
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Designs 

The Design components can be selected and included in the component list required for 
creating configuration packages. The selected Design components overwrite, or insert, 
deployed/published versions of design components in the destination environment. 

Displays the following design components, in groups:  

 Business Processes 

 Asset Manager 

 Configurable Modules 

 Cost Manager 

 Document Manager 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Schedule Manager 

 Space Manager 

 Shell Manager 

 User Administration 

The following columns will be seen: 

 Name 

 ID 

 Level 

 Type 

 Status 

 Deployed Version 

 Published Version 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Use the filter option to perform a quick filter of the data for search on a column. 

Use the print option to print the list of selected components, in a consolidated format. 

When the user selects the designs, for any of the design components, the deployed design 
version will be included as part of the component list. 

The published design version will be automatically considered as part of the component list only 
when there is a dependency from another selected component (for example, selected Setup or 
Configuration), in the component list. If user has not selected an existing published design, it will 
not be included in the component list. 

The published design version will not be included as a part of the component list if there are no 
dependencies. If any selected component is dependent upon the current published design 
version, the system displays messages during error check of the component list, or when the 
configuration package is being created. 
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Designs and Document Manager 

When the DMS attributes from of the Document Manager is included in the component list (to 
be further included in the configuration package), all of the folder properties attribute forms must 
be included in the component list with the corresponding document properties attribute forms 
and the document logs. 

Data Structure Setup 

The Data Structure Setup components can be selected and included in the component list 
required for creating configuration packages. The selected Data Structure Setup components 
overwrite, or insert, data set/default values in the destination environment. 

The following are the sub-nodes available under Data Structure Setup: 

 Basic Data Definitions 

 Cost Code Data Definitions 

 Data Cube Definitions 

 Data Views 

 Dynamic Data Sets 

Each node, when selected, displays the columns:  

 Basic Data Definitions 

 Name 

 Input Type 

 Used in Selected Designs 

 Cost Codes Data Definitions 

 Name 

 Input Type 

 Data Cube definitions 

 Name 

 Description 

 Data Views 

 Name 

 Label 

 Description 

 Dynamic Data Sets Configuration 

 Name 

 Description 

 Used in Selected Designs 

The default column sort is the Name column. 

Data Structure Setup - Basic Data Definitions

All basic data definitions are available for selection except for the: 

 Picker type 
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 Data picker type 

 Checkbox type DDs 

When imported, the data sets/default values of the selected data definitions (included in the 
package) overwrite the existing data definitions in the destination environment. 

If the data definitions do not exist in the destination environment, then all of the new data 
definitions imported as a part of the configuration package are inserted into the destination 
environment, by the system. 

The data sets/default values are not included for the data definitions that are not selected. 

If users have defined the data sets/default values in the destination server, then those values 
remain as they are. 

Used in Selected Designs

The column will have a "Yes" value for the Data Definitions (DDs) which are being used in 
the selected designs. If you deselect any particular design in the Design node, then if you go 
back to the Data Definitions node, the value will be empty for respective DDs.  

Note: The data set values are always included for Project phase data 
definition. 

Data Structure Setup - Cost Codes

All cost codes are available for selection. 

The selected Cost Codes (included in the package), when imported, overwrite as data sets 
values for the corresponding Cost Codes existing in the destination environment. If the Cost 
Codes do not exist in the destination environment, the new cost codes, imported in as part of 
the configuration package, are inserted into the destination environment. 

The data sets/default values are not included for the data definitions that are not selected. 

Data Structure Setup - Data Views

All Data Views are available for selection. 

The selected Data Views (included in the package), when imported, overwrite in the 
destination environment. If the Data Views do not exist in the destination environment, the 
new Data Views, imported in as part of the configuration package, are inserted into the 
destination environment. 

The dependency errors related to data views not selected will be checked when component 
analysis is performed during the configuration package creation. 

Note: For a Data View that is dependent on another Data View, there 
are no dependency errors that are when component analysis is 
performed during the configuration package creation; however, 
publishing of the Data View fails because of the dependency and the 
system displays an error message upon import. 

Data Structure Setup - Dynamic Data Sets (DDS)

The DDS are available for selection. 

The selected DDS, included in the configuration package when imported, either create a new 
configuration or overwrite the existing configuration in the destination environment.  
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If the DDS does not exist in the destination environment, then the new DDS imported as a 
part of the configuration package are inserted into the destination environment, by the 
system. 

When a dynamic data set (DDS) is used in a uDesigner object (such as a business process), 
the DDS configuration that exists in the package must match the DDS configuration that 
exists in the destination environment; otherwise, Unifier will mark the process as a data 
definition conflict, and the import will fail.  

Used in Selected Designs

The column will have a "Yes" value for the Dynamic Data Sets (DDS) which are being used 
in the selected designs. If you deselect any particular design in the Design node, then if you 
go back to the Dynamic Data Sets node, the value will be empty for respective DDS.  

Company Access Control 

The Company Access Control permissions can be selected and included in the component list 
required for creating configuration packages. The selected Company Access Control 
permissions overwrite, or insert, permissions related to groups in the destination environment. 

Displays the following access control permissions, in groups:  

 Administrator Mode Access 

 User Mode Access 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User mode access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a warning message 
indicating that the dependent component has not been selected, but the permissions have been 
selected. 

Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions, when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination environment. 

Configuration 

The Configuration can be selected and included in the component list required for creating 
configuration packages. The selected Configuration overwrites, or gets inserted, in the 
destination environment. 

The following sub-nodes are displayed under the Configuration node:  

 Designs

 Log Views 

 Custom Templates (Custom Prints and Reports)
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 User Mode Navigator

 Portal Landing Page

 Stamps

Designs 

Displays the configuration for the design components available for selection. The grouping, by 
headers, are as follows: 

 Business Processes 

 Asset Manager 

 Configurable Module: <CM name> 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Space Manager 

 Shell Manager 

 Document Manager  

The following columns are displayed: 

 Name 

 ID 

 Level 

Log Views 

Displays the log views available for selection. The grouping, by headers, are as follows:  

 Business Processes 

See Creating BP Log Views in Admin Mode (on page 235) (BP Log Views and 
Configuration Package) for more information. 

 Document Manager Log Views 

See Setting up the Document Manager (on page 477) (Document Log Views and 
Configuration Package) for more information. 

The following columns are displayed:  

 Name 

 ID 

 Level 

Custom Templates 

Displays the Custom Templates available for selection. The grouping, by headers, are as 
follows: 

 Custom Print 

 Custom Report 

 Custom Email 
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Note: The system does not display the application type and external 
type of reports. 

The following columns are displayed: 

 Name 

 Key 

 Description 

User Mode Navigator 

Displays the active and inactive user mode navigator available for selection. The following 
columns are displayed: 

 Name 

 Type 

 Status 

Portal Landing Page 

Displays the active or inactive portal landing page setup available for selection. The following 
columns are displayed: 

 Name 

 Status 

Note: To include in the configuration package, you must include all 
image files and hyperlinks. 

Stamps 

Displays the stamps available for selection. The following columns are displayed: 

 Name 

 Description 

All of the sub-nodes logs are sorted by default on the "Name" column and you can sort on any of 
the other columns. 

Additional Information 

Portfolio Manager

As a part of Project Portfolio Manager (PPM) configuration, the "Display monthly breakdown of 
Actuals" option is included for the Configuration Package.  

If the check box for the "Display monthly breakdown of Actuals" option is selected when the 
PPM configuration is being included in the Configuration Package, then upon import to the 
destination environment, the user will see the checkbox checked. 

The Actuals source curve values displayed in the source environment (in the Derived curve 
properties) will be seen in the destination environment as well, when the CashFlow is packaged 
as part of the Configuration Package. 
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Company Workspace 

The components for the Company Workspace node can be selected and included in the 
component list required for creating configuration packages. The selected components for the 
Company Workspace overwrites, or gets inserted, in the destination environment. 

The following are the sub-nodes for the Company Workspace node:  

 Setup

 Rules

 Auto Update Status Setup

 User Defined Reports

Setup

Displays the Setup (Company level) for the design components (Business Process and Planning 
Manager) available for selection. The grouping, by headers, are as follows: 

 Business Process 

 Planning Manager 

The following columns are available: 

 Name 

 ID 

 Status 

Rules

Displays the Rules (Company level) available for selection. The following columns are available: 

 Name 

 Control Source 

 Status 

Auto Update Status Setup

Displays the Auto Update Status Setup (Company level) available for selection. The following 
columns are available: 

 Name 

 Status 

User Defined Reports

Displays the UDRs (Company level) available for selection. The following columns are available: 

 Name 

 Data Type 

 Report Type 

Note: The UDRs listed are in User mode. 

All of the sub-nodes logs are sorted by default on the "Name" column and you can sort on any of 
the other columns. 
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Company Templates 

The components for the Templates (Company level) can be selected and included in the 
component list required for creating configuration packages. The selected components for the 
Templates overwrites, or gets inserted, in the destination environment. 

The following are the sub-nodes for the Company Templates:  

 CashFlow

 Sheets

 Folder Structures

 Rules

 User Defined Reports

CashFlow

Displays the company-level CashFlow templates available for selection. The following columns 
are available: 

 Name 

 Detail Level 

 Time Scale 

Sheets

Displays the company-level Sheets templates available for selection. The grouping, by headers, 
are as follows: 

 Commitment Summaries 

 Configurable Modules : <CM name> 

 Commitment Funding Sheets 

 Cost Sheets (The worksheets will be shown under this same grouping. However the name 
for worksheet will be shown as Worksheet : <worksheet name> ) 

 Funding Sheets 

 General Spends SOV sheets 

 Schedule Sheets 

The following columns are available: 

 Name 

 Description 

Folder Structures

Displays the company-level Folder Structures templates available for selection. The following 
columns are available: 

 Name 
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Note: For Folder structures, under Company Templates, you see the 
name column that correspond to all of the template name entries coming 
from Unifier. Only those templates that the user selects are included in 
the component list. 

Rules

Displays the company-level Rules templates available for selection. The following columns are 
available: 

 Name 

 Control Source 

 Status 

User Defined Reports

Displays the company-level UDRs templates available for selection. The following columns are 
available: 

 Name 

 Data Type 

 Report Type 

All of the sub-nodes logs are sorted by default on the "Name" column and you can sort on any of 
the other columns. 

Shell Templates 

The components for the Shell Templates can be selected and included in the component list 
required for creating configuration packages. The selected components for the Shell Templates 
overwrites, or gets inserted, in the destination environment.  

Note: The respective folder properties and associated document 
properties attributes form and document log must be included as part of 
the configuration package when any shell, or shell template, (shell, or 
shell template that does not use the default form) is included. While 
creating configuration package the user will be notified of the inclusion of 
these attribute forms by a message.  

The Shell Templates displays the available shell templates grouped by their shells. You must 
select a shell template before selecting the following sub-nodes: 

 Access Control

 Setup

 Sheets

 Folder Structures

 Rules

 User Defined Reports

The components are grouped based on the shell template that you have selected. The following 
explains each component under Components: 
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Access Control

The Shell Templates Access Control permissions can be selected and included in the 
component list required for creating configuration packages. The selected Shell Templates 
Access Control permissions overwrite, or insert, permissions related to groups in the destination 
environment. 

Displays the Shell Templates Access Control permissions available for selection. The grouping, 
by headers, are as follows: 

 Administrator Mode Access 

 User Mode Access 

The following columns are available: 

 Module 

The log is sorted by default on the "Module" column and you can sort the other columns. 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User mode access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a message indicating 
that the dependent object have not been selected, but the permissions have been selected.  

Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions,when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination. environment. 

Setup

Displays the Shell Templates Setup available for selection. The grouping, by headers, are as 
follows: 

 Business Process 

 Gates 

 Planning Manager 

 Resource Manager 

 Configurable Modules : <CM name> 

 Dashboard 

For additional details, refer to the Unifier General Administration Guide: "Conditions for 
Creating a Dashboard Setup Configuration Package." 

The following columns are available: 

 Name 

 ID 

 Status 

The log is sorted by default on the "Name" column and you can sort the other columns. 
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Sheets

Displays the Shell Templates Sheets available for selection. The grouping, by headers, are as 
follows: 

 Configurable Modules : <CM name> 

All CM sheets for that specific configurable module will be seen in this group by 

 Cost Manager 

This group will list all the cost sheets , CashFlow sheets . For below sheets 

 Commitment Summaries 

 Commitment Funding sheet 

 General Spends 

 Payment applications 

 <BP name> - SOV 

Only those will be seen for which the structure has been created for that particular template. 

 Space Manager 

All Stack plans and level sheets will be seen under this group by 

 Schedule Manager 

All schedule sheets will be seen under this group by 

The following columns are available: 

 Name 

 Description 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Folder Structures

Displays the Shell Templates Folder Structures available for selection. The following columns 
are available: 

 Name 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: For Folder Structures under Shell Templates, only the "Name" is 
displayed, at the root folder name. For Example if there is a folder 
Test12 available in Documents, then the name for the structure will be 
seen as Documents. 

Rules

Displays the Shell Templates Rules available for selection. The following columns are available: 

 Name 

 Control Source 

 Status 

The log is sorted by default on the "Name" column and you can sort the other columns. 

User Defined Reports
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Displays the Shell Templates UDRs available for selection. The following columns are available: 

 Name 

 Data Type 

 Report Type 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: Based on the shell template selected, only the components related 
to the selected shell template are displayed and available for selection. If 
you deselect a previously selected shell template, the components of the 
deselected shell template do not display; however, if you select the 
deselected shell template, then the components are displayed. 

Defining Shell-Specific Custom Print Templates for Business Processes 

In addition to editing shells that you have permissions for, you can view all Custom Print 
Templates and define them at the shell level. Once you choose a shell template in the Company 
Workspace tab, you must select the Details icon in the upper-right corner of the dashboard. In 
the Details window, a Custom Print Template tab is available.  

The Custom Print Template tab contains a short description detailing its functionality and an 
Add Selective Custom Print Templates checkbox. The checkbox is unchecked by default, 
which means every template that is available for BPs is available at run-time. If the checkbox is 
checked, then only the selected templates are available at run-time. 

Note: For further explanation of the checkbox, hover your cursor over 
the Question Mark icon next to the checkbox. 

Upon checking the checkbox, a grid is displayed with Add Custom Print Template and Find on 
Page options. When you select Add Custom Print Template, a new window is displayed where 
you can select a Business Process from the dropdown. 

After you choose a BP, you can select the custom print templates that you want to add in the 
shell. The options for custom templates include all Published and Legacy templates. 

Once you select one or more templates, you can add them to the Selected Items list by clicking 
the Right arrow. If you want to remove a template from the list, select the template and click the 
Left arrow. After selecting Save, the Add Custom Print Template window is closed and the 
chosen templates are displayed in the previous grid. 

To delete a newly added template, select the Trash Bin icon in the far right column of the grid. 
To find a specific template, select the Find on Page option. 

Supporting Shell Attribute View Forms 

 Since you can include View Forms in shell attributes and restrict users and group (who are 
members of the shell) to view the forms added to the shell properties (View Forms tab), you can 
use the Configuration Package to export and import the View Forms tab information (along 
with other tabs) of the shell properties of your selected shell templates or single instance shells.  
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In general, you can export and import the shell attribute design (which includes both the action 
forms and the view forms), and the view form permission settings (added in the View Forms tab 
of the shell or shell template properties), by way of Configuration Package. 

Configuration Package export for shell templates and single instance shells

When you tag one or more shell templates that have view forms setup in the Component 
List, then along with other shell tabs the View Forms tab information will be exported, when 
you create the Configuration Package. 

Along with the view forms, the users, groups, and shell administrator, who are part of the 
permission settings of view forms, will be exported. For other modules in the BP setup, the 
users, groups, and shell administrator associated to the permission settings will not be 
exported. In other word, the users, groups, and shell administrator associated to the 
permission settings in the View Forms tab of the BP setup will not be exported; however, the 
users, groups, and shell administrator permission settings in the view forms setup (in the 
shell attribute form) will be exported. 

When the published shell design does not have all the view forms added in the tagged shell 
template in the Component List, then the design dependency error is displayed, when you 
conduct error check in the Component List. Add the dependency component to fix this 
error. 

If you tag a shell template (that has view forms) in the Component List, and the published 
design has those view forms already, then the system does not validate for the latest 
deployed design. Also, if the tagged shell template does not have any view forms, and the 
shell design is published, then the system does not validate for any latest deployed design 
while creating the Configuration Package. Similarly, when you tag a single instance shell, 
and the selected shell instance has view forms setup, then along with the other tab 
information all of the view forms and permission settings (for the users, groups, and shell 
administrator) will be exported. 

Import of Configuration Package containing shell templates with view forms

When you import the Configuration Package containing shell templates with view forms 
into the destination server: 

 If the shell template does not exist, then a new template will be created and view forms 
setup information (forms and permission settings for groups) will be added. 

 If the destination server already has the shell template, then the view forms setup 
information will be updated by way of importing the Configuration Package. 

 If Configuration Package created has a single instance shell with the view forms setup, 
then in destination server the single instance shell will be imported when the component 
does not exist. The view forms setup information are also imported along with the other 
tabs. In the case the destination server already has a single instance shell, then the 
single instance shell information will not be updated, including view forms information. 

Single Instance Shells 

The components for the Single Instance Shells can be selected and included in the component 
list required for creating configuration packages. The selected components for the Single 
Instance Shells overwrites, or gets inserted, in the destination environment.  
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The Single Instance Shells displays the available shells for selection. You must select a shell 
from the Single Instance Shells before selecting the following sub-nodes: 

 Access Control

 Setup

 Rules

 User Defined Reports

The components are grouped based on the shell template that you have selected. The following 
explains each component under Components: 

Access Control

The Single Instance Shells Access Control permissions can be selected and included in the 
component list required for creating configuration packages. The selected Single Instance Shells 
Access Control permissions overwrite, or insert, permissions related to groups in the destination 
environment. 

Displays the Single Instance Shells Access Control permissions available for selection. The 
grouping, by headers, are as follows: 

 Administrator Mode Access 

 User Mode Access 

The following columns are available: 

 Module 

The log is sorted by default on the "Module" column and you can sort the other columns. 

For static modules, there are no error check performed during component analysis. For dynamic 
modules (such as BP setup in Admin mode access or Data Cubes as non navigational nodes in 
User mode access), if the user selects modules dependent on components which have not been 
selected, when the component analysis is performed, the system displays a message indicating 
that the dependent object have not been selected, but the permissions have been selected.  

Upon a successful import, the system updates the permissions for the selected modules. If the 
permissions (transferred as a part of the configuration package for dynamic modules) do not 
have the dependent components in the destination environment, and the configuration package, 
then the permissions will not be imported into the destination environment, and the system 
displays a message; however, if the dependent components are present in the destination 
environment, then the system updates the permissions,when imported successfully. By default, 
for "creator users," the permissions will be set to the "importer user" upon the configuration 
package creation, and in the destination. 

Setup

Displays the Single Instance Shell Setup available for selection. The grouping, by headers, are 
as follows: 

 Business Process 

 Gates 

 Planning Manager 

 Resource Manager 

 Configurable Modules : <CM name> 
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 Dashboard 

The following columns are available: 

 Name 

 ID 

 Status 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Rules

Displays the Single Instance Shells Rules available for selection. The following columns are 
available: 

 Name 

 Control Source 

 Status 

The log is sorted by default on the "Name" column and you can sort the other columns. 

User Defined Reports

Displays the Single Instance Shells UDRs available for selection. The following columns are 
available: 

 Name 

 Data Type 

 Report Type 

The log is sorted by default on the "Name" column and you can sort the other columns. 

Note: Based on the Single Instance Shells selected, only the 
components related to the selected Single Instance Shells are displayed 
and available for selection. If you deselect a previously selected Single 
Instance Shells, the components of the deselected Single Instance 
Shells do not display; however, if you select the deselected Single 
Instance Shells, then the components are displayed. 

Defining Shell-Specific Custom Print Templates for Business Processes 

In addition to editing shells that you have permissions for, you can view all Custom Print 
Templates and define them at the shell level. Once you choose a shell template in the Company 
Workspace tab, you must select the Details icon in the upper-right corner of the dashboard. In 
the Details window, a Custom Print Template tab is available. 

The Custom Print Template tab contains a short description detailing its functionality and an 
Add Selective Custom Print Templates checkbox. The checkbox is unchecked by default, 
which means every template that is available for BPs is available at run-time. If the checkbox is 
checked, then only the selected templates are available at run-time. 
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Note: For further explanation of the checkbox, hover your cursor over 
the Question Mark icon next to the checkbox. 

Upon checking the checkbox, a grid is displayed with Add Custom Print Template and Find on 
Page options. When you select Add Custom Print Template, a new window is displayed where 
you can select a Business Process from the dropdown. 

After you choose a BP, you can select the custom print templates that you want to add in the 
shell. The options for custom templates include all Published and Legacy templates. 

Once you select one or more templates, you can add them to the Selected Items list by clicking 
the Right arrow. If you want to remove a template from the list, select the template and click the 
Left arrow. After selecting Save, the Add Custom Print Template window is closed and the 
chosen templates are displayed in the previous grid. 

To delete a newly added template, select the Trash Bin icon in the far right column of the grid. 
To find a specific template, select the Find on Page option. 

Analytics 

The Analytics can be selected and included in the component list required for creating 
configuration packages. The selected Analytics overwrites, or gets inserted, in the destination 
environment.  

When you click Analytics, the system displays a  list of analytics available for selection. 

The log contains the "Name" column only. 

Cost Attributes - Cost Sheet 

Users can export and import the Configuration Package, with the Analytics Cost Sheet node 
checked, to other environments.  

After you defined mappings (in the Data Mapping – Cost Attributes tab), if the option Cost 
Sheet is selected (the Component Lists node > Configuration Package Management > 
Analytics), then the source design, in uDesigner (Cost Code Attributes (Design ID = 
standard_cost)) has to be selected. 

Component Analysis for Component Lists 

You can perform component analysis for the components that you have selected in the 
component list. When you click Error Check, in the component list creation screen, the system 
displays the component analysis screen. 

The following conditions apply when you import a configuration package containing referenced 
user attributes into your destination environment that has user attribute design:  

 You can import a configuration package containing referenced user attributes into your 
destination environment that has user attribute design provided that the user attribute design 
in your destination environment has matching data element names and data definitions. 
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 You cannot import a configuration package containing referenced user attributes into your 
destination environment that has user attribute design, but the user attribute design does not 
have matching data element names and data definitions. 

 To import a configuration package containing referenced user attributes into your destination 
environment that does not have user attribute design, you must first add the user attributes 
to the user attribute design of the destination environment and deploy before you can 
complete the import successfully. 

In case of errors, the system displays the following error types; 

 Dependency errors 

 Miscellaneous errors 

 Warnings 

Dependency Errors 

These errors are displayed when the components available inside the component list have 
dependency errors. Dependency errors occurs when the user has selected primary components 
in the component list but did not select the dependent components. 

Example 

While creating a component list, the user selected a UDR report but did not select the 
dependent BP design. 

The system displays dependency errors as groups, in the Component Analysis screen, and the 
Fix Action column displays a symbol. If you hover over the symbols displayed, the system 
displays the action that you need to take. 

To correct a dependency error, you have two options: 

a) Add the missing component  (Add Missing Component symbol) 

You can add the dependent components (in the error list) and resolve the errors. 

b) Remove the existing component  (Remove Existing Component symbol) 

You can remove the selected components from the list and resolve the errors. 

The system processes the error list and the list can be refreshed by clicking Refresh. 

Miscellaneous Errors 

These errors are encountered when the components have other miscellaneous errors that have 
to be fixed at the application level. 

Warnings 

The system displays warnings related to components present in the component list, using 
(the yellow triangle symbol). 
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Creating Configuration Packages 

In the Configuration Packages log, when you click Create the New Configuration Package
window opens, displaying the Package Details step of the creation wizard, by default.  

The creation wizard has the following steps: 

Note: You cannot create a configuration package with a component list 
that has no components selected. 

 Package Details

Mandatory details related to the configuration package must be entered in this step. 

 Package Components

Displays the configuration package component preview, based on the selected items from 
the Components Lists. 

 Create

Enables you to publish the configuration package for production and download the 
configuration package zip file. 

In the configuration package log, you can create configuration packages that do not have user 
attribute design included in the package but have custom user attributes, including the picker 
elements. All of the referenced processes must be included in the configuration package. If the 
custom user attribute is a data picker, then the data source and display element will be included 
in the package, if created successfully after error resolutions.  

Package Details 

The Package Details contains the following fields, selections, and columns:  

 Package Name (required) 

 File Name (required) 

 Description

 Select one or more component lists (required) followed by two columns listing the 
components lists (find and multiple selection is available) and the creation dates. 

The File Name and Description fields will be auto-populated once you enter the Package 
Name. You will be able to edit both the fields further.   

You can select one or more component lists that have components which refer to the custom 
user attributes. Once you select the component lists and navigate to the next step, The Package 
Components window displays all of the components that are in the selected component list, 
including the user data picker data definitions and custom user attributes data definitions. The 
referenced user attributes will be included in the package. 
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Note: The Designs node (the left-hand navigator of the New 
Configuration Package window) will not have the User Attribute form 
included. 

Package Components 

When you click Next in the Package Details step, you go to the the Package Components step. 
The Package Components page displays the package components from the selected 
components list (from the Package Details step). 

Only two categories, and components, that are part of the selected component list are shown. 

Example 

If the user selected, List 1 (with categories Designs and Analytics) and List 2 (with categories 
Designs and Configuration and Configuration included business processes, only), then the 
following is displayed in the package components: 

Categories 

 Designs 

 Configuration 

 Analytics 

Since the configuration included the component business process, the business process 
components are displayed under Configuration. Based on what is transferred from the 
selected items under Component Lists, you will see: 

 Designs (There will be tab to see the Published designs , if any published designs are 
coming as part of the selected component lists. ) 

 Data Structure Setup 

 Access Control 

 Configuration 

 Company Workspace 

 Company Templates 

 Shell Templates 

 Single Instance Shells 

 Analytics 

You can use the filter option to search data for each column. 

The print option prints the consolidated report, based on the selected components. 

Click Next to go to the Creation step. 

Errors and Warnings 

When you click Next in the Package Components step, the system performs an error check to 
determine if the configuration package is complete, or not.  
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If there are no errors, then you can see the last step, Create. 

If there are errors, then the system displays the Error/Warnings step. In this step, you can 
resolve errors dependency errors dynamically. Once you fix the errors dynamically, click Back to 
see the results. 

For other types of errors, you must save as draft, fix the errors at the application level, and then 
run the step. 

The Refresh option enables you to refresh the dynamically resolved errors and proceed with the 
error processing. 

When all the errors are resolved, or there are no errors in the configuration package, you can 
click Next in the Package Components step and go to the Create step. 

The Errors/Warnings window displays the warning messages related to the: 

 Inclusion of custom user attributes referenced in the selected components.  

 User attribute design that is missing in the selected component list. 

The following additional note will be displayed in the Errors/Warnings top section, if the 
component lists part of this package have references to custom user attributes, but the user 
attribute design is not included: "This package contains component lists which do not have user 
attribute design and therefore cannot be published for production server use." 

Note: The user attribute design will be included when there is a 
published version, in this case. 

For the configuration packages that do not have the user attribute design included but have the 
custom user attributes included, if you click Publish to Production (in the Configuration 
Package log), Unifier displays the following message: "This package contains components that 
have references to custom user attributes but user attribute design is not included and therefore 
cannot be published for production server use." In this case, in the Create step, the option is not 
available. 

Create 

In the Creation step, you can publish your configuration package for production and download 
the configuration package zip file after creation. 

When you click Create, the system creates the configuration package. 

Creating a Configuration Package for Export 

When creating a configuration package for export, if the selected components have references 
to the custom user attributes, you are not required to tag the user attribute design.  
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When you create a component list, or when you edit an existing component list, if the tagged 
components have dependency on the user attribute design, then the Component Analysis
window does not displays the dependency errors, instead the Component Analysis window 
displays the warnings related to the user attribute design that were not selected. 

Note: If there are component lists that are in Error Status because the 
user attribute design was not included before an upgrade, the Error 
Status will remain unless you run the error check again. 

Example 

The "EmployeeID" data element, in the user attributes, is referenced in filtering conditions in 
the "Action Items" BP workflow setup. In this case, the "EmployeeID" data element will be 
included in the packaged components, and the following warning messages will be 
displayed, with the first warning message indicating that the user attribute design is not 
included in the component list: 

 The selected components have references to the custom user attributes and <user 
attribute design name> is missing in the component list. 

 The additional filtering conditions in the component list, defined in the workflow business 
process setup of Action Items, requires the "EmployeeID" data element in user attributes 
and will be included. 

The first warning message indicating that user attribute design will not be included in the 
component list will be shown only when user attribute design is not selected and the design is 
not published. 

 Component Name should be User Administration. 

 Location Column should be shown as Design. 

 Name should be shown as <user attribute name>. 

There will be an additional note displayed in the top section of the Component Analysis
window, and it will be as follows: "Note: The package created using this component list does not 
include user attribute design. You can include the user attribute design by fixing the dependency 
warning to create a package for production." 

In this case, the Component Analysis window will show warning messages detailing the 
inclusion of customer user attributes referenced by user pickers, user data pickers, BP setup 
filter conditions, and so forth that are in the selected components. 

All of the custom user attributes referenced by the selected designs, setups, and so forth, in the 
component list, will be included without including the user attribute design. 

In the Component Analysis window, the Fix Action option  is provided to enable you to 
include the dependent user attribute design into the component list created and apply the 
changes. 

The components which have custom user attributes references will be displayed as warnings in 

the Component Analysis window, and there will be a resolving action  to enable you to 
exclude those components. 

Note: If in the source environment the user attribute design is already 
published, then the design will always be included and no additional 
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warnings will be seen. 

If the published user attribute design does not have all of the data elements that are referenced 
by the selected components (such as BPs), then an error message will be displayed. 

If, in the source server, the components selected in the component list have custom user 
attributes that are data pickers that refer to another design, then Unifier displays errors when you 
are creating the configuration package, or performing error check in the component list. You 
must select the user attribute design if there are pickers in the custom user attributes in the 
package. 

Example 

When a BP WF setup assignee filter conditions have Space DP display as one of the 
conditions, the following error message will display while performing export: "The additional 
filter conditions defined in the workflow for Action Items business process setup requires 
data picker elements Space DP in user attribute design [User Attributes]. The user attribute 
design that has data picker elements must be included in the component list." 

The above error can be resolved by including the user attribute design into the component list. 

Creating a Configuration Package for Import 

In the Configuration Packages log, when you click the Import toolbar option, the Import 
Configuration Package window opens.  

The Import Configuration Package window has the following steps that you can complete 
through corresponding wizards: 

Select 
File

This step has the following fields: 

 File Name (required) 

 Package Name (required) 

 Description

You must select a valid zip file from the local system for the File Name.  

Package 
Details

This is a view-only step enabling you to view the configuration package 
components. 

This step displays the configuration package components, from the 
selected zip file. It also shows only those categories, and components, that 
are in the selected configuration package. 

If available, the "Data Structure Setup" category (on the left-hand 
navigator) shows the additional user attributes data definitions and 
dependent user data picker definitions that are a part of the configuration 
package. 

User 
Mapping

Unifier extracts the user's information for user mapping: 

 Shell Administrator 

 Auto-Creator for Business Process records or line item. 

Only the groups will be extracted from other components. 

Import See below. 
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Import 

In this step you can elect Download the Impact Analysis Report option and click Import. 

In the Import User Attributes window, you will see whether the selected configuration package 
has custom user attributes that are not existing in the user attribute design in destination 
environment, or not. If the custom user attributes already exists in the destination, then the 
Import User Attributes window will not be displayed. 

In the Import User Attributes window, you will be provided with the list of data elements (from 
the configuration package) that do not exist in the destination user attribute design. The Import 
User Attributes window allows you to choose one of the following actions, if in the destination 
user attribute design does not exist: 

 Add the data elements to the <destination user attribute form> user attribute design. 
(selected by default) 

Select this option and proceed with the import of package by clicking Continue. The import 
process might result in an error if, for example, the status of the user attribute design is 
Draft, or if there is a mismatch between the "design" and the "deployed" versions of the 
"design." 

This option enables the import process to continue. If there are no other errors, then the 
custom user attributes will be added to the destination user attribute design if the "design" 
and the "deployed" versions are the same and the "design" is in a complete status. 

 Add the data elements to the Data Structure Setup but not to the user attribute design

Select this option and proceed with the import of package by clicking Continue. The import 
process results in an error because the user attributes are not added to the user attribute 
design. Add the data elements to the user attribute design and try to import again. 

This option enables the import process to continue. The data elements will get added into the 
destination server even if the import fails because of referenced user attributes in the 
configuration package. 

During import, the additional custom user attributes that do not exist in the destination will be 
added to the user attribute design, based on the following conditions: 

 User attribute design in the destination should be in Complete status. 

 In the destination server, the user attributes design and the deployed version should 
match. 

If the above two conditions are met, then the additional custom user attributes will be added 
to the destination user attribute design, after the import.  

Note: In the above case, the destination server user attribute design is 
allowed to have a higher version than the source. 

If any one of the above conditions are not met, then the import fails. 

You have the option to download the impact analysis report and view the import errors and 
warnings, by using the gear menu which will be available for the configuration packages that 
you had selected for import (in the configuration package log page). In addition, if the custom 
user attributes that are coming as part of the configuration package already exists in the 
destination, then: 
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 If the data element name and data type (or data definition) match (and are not currently a 
part of the user attribute design), then the data elements will be added, if the above 
conditions are met. 

 If the data element name and data type (or data definition) match (and are currently a 
part of the destination user attribute design), then no changes are needed. 

 If the data element name and data type (or data definition) do not match, then import 
fails. In the case of adding new data elements (custom user attributes) into the 
destination, and the data definition exists with same name but with different definition, 
then the following error message is displayed in the errors and warnings report: "The 
data element {0} from the Configuration Package cannot be added to the destination 
environment due to conflict in data definition {1}." The "Component" for this message is 
the "User Attributes," and the "Location" will be "Designs." 

If you click Cancel, or close the Import User Attributes window, the following confirmation 
message is displayed: "The import process will be canceled. Do you want to continue?" If you 
click "Yes," then the Import User Attributes window closes, and the import process stops. 

The data elements that do not exist in the destination server are displayed in the grid and will 
have the following columns: 

 Data Element: Displays the name of the data element. 

 Data Definition: Display the data definition of the data element. 

 Data Type: Displays the data type of the data definition. 

 Input Type: Displays the Input Method of the data definition. 

When the destination server does not have user attribute form defined, if in the destination 
server there is no user attribute design, and the configuration package has custom user 
attributes, then the following message appears in the errors and warnings report, after you click 
Import: "Import has failed. The destination server does not have the user attribute design that 
can add the custom user attributes included in your package." 

Data Structure Setup Component in Impact Analysis Report 

The impact analysis report is created whether the configuration package import succeeds or 
fails. When a configuration package has custom user attributes, and you have selected to add 
the custom user attributes (data elements and dependent data definitions) in the Import User 
Attributes window (Add the data elements to the Data Structure Setup but not to the user 
attribute design), then the impact analysis report lists all of the data elements that are added 
into the destination server. That is to state that the Data Structure Setup window lists 
components affected in data structure setup by providing the following information in column 
format: 

 Component

 Status

 Name

 Description

The Data Structure Setup module shows the additional data elements that were included in the 
destination server because of importing the configuration package. In the report: 

 Name column will show data element name that was added 
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 Description column will show as "Included but have not been added to user attribute 
design." 

 Status column shows "Added." The Status column also shows the data elements that are 
not added because of the data definition conflicts as "Not Added" and the corresponding 
Description column cell provides the reason for not adding the data elements to the 
destination server data structure setup. The data elements that are not added, or basically 
not changed, in the destination server will be captured because the elements already exists 
in the destination server. In this case, importing of the configuration package will result in 
error even if the data elements are added to the Data Structure Setup. 

If you select the Add the data elements to the <destination user attribute form> user attribute 
design option in the Import User Attributes window, then the impact analysis report displays 
the user attribute design (in the destination server) as updated. In this case: 

 An additional section for the Data Structure Setup components will be displayed in the 
impact analysis report. The impact analysis report will be the same as seen when the data 
elements are added as a part of the design import. 

 The Description for the data elements added will be displayed as: "Included and have been 
added to user attribute design." 

Similarly, if the import results in error because of the data definition mismatch, then it will be 
captured as a part of the regular error/warnings report. 

In the case when you select the Add the data elements to the Data Structure Setup but not 
to the user attribute design option, but the import fails because of the user attribute design (in 
the destination server) is not in complete status, if the custom user attributes exist in destination 
server, then the user data elements will be added. In this case, the impact analysis report 
displays the list of the data elements that are added, and the data elements that are not 
changed. This is the case where custom user data elements are added successfully in the 
destination server. 

The descriptions for the data elements that are added to the destination server but not to the 
user attribute design will show: "Included and added to the data structure setup." 

The descriptions for the data elements that are added to the destination server but not to user 
attribute design will show: "Ignored because the data element exists in destination server." 

Importing the User Data Pickers 

The data elements and data definitions of the user data picker will be imported into the 
destination server if the user data picker definition is not defined. 

The display element will be added into the user attribute design if you select the option to add 
the display element into the user attribute form of the destination server. 

Unifier ignores the user data picker in the configuration package ("There is a mismatch between 
the package and this server for the the display element of <user data picker> data definition. No 
changes will be done to the existing definition upon import."). 

The errors and warnings report displays the detail of the user data pickers that are ignored 
during the configuration package import, if they already exists in the destination server. 
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Export Configuration Package with Custom User Attributes 

Even if the configuration package components have references to custom user attributes, as an 
administrator you can export (and import to the destination environment) a configuration 
package that includes all types of custom user attributes without the need to include the source 
user attribute design in the configuration package. This includes shell data pickers, BP data 
pickers, and so forth.  

Note: The export process applies to both the configuration packages 
and the add-on configuration packages. 

The following lists the referenced user attributes in a component package that can be imported 
to the destination environment:  

 Data elements that are data pickers and shell pickers and do not exist in the destination 
server. 

 Data elements that are user data pickers and display elements and do not exists in the 
destination server. 

 Data elements that are data pickers, shell pickers, along with referenced data sources and 
display elements that exist in the destination. 

 Data elements that are data pickers, shell pickers, and the referenced data sources that do 
not exist in the destination. 

Note: If the custom user attribute is a user data picker, then both the 
data picker element and its associated display element will be included 
in the configuration package. 

Unifier will display messages if custom user attributes such as data pickers are referenced in the 
following components of the configuration package: 

 Workflow setup filtering conditions 

 User Data Picker query conditions 

 User Defined Report or Data Cube query conditions 

 Auto update Status Setup query conditions 

 Auto populate and reverse auto populate definitions referencing User Data Picker in any 
design 

 Any design that has custom user attributes referenced through User Data Picker 

Import Configuration Package with Custom User Attributes 

This topic explains the importing of a Configuration Package with custom User Attributes that 
includes pickers without user attribute design.  
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Note: The import process applies to both the configuration packages 
and the add-on configuration packages. 

When you select the component package that has custom user attributes without including user 
attribute design in the import wizard, navigate to the last step, and click Import, the Import User 
Attributes window opens. 

Note: The Import User Attributes window will be displayed only if the 
component package have custom user attributes without the source user 
attribute design. 

In Import User Attributes window: 

 The list of data elements will include all the custom user attributes that are a part of the 
source package and do not exist in destination environment user attribute design. 

 The list of data elements will also include the pickers like shell data picker, shell pickers, and 
other data pickers that are referenced in the components in the source server. In case that 
the user data picker is a custom user attribute, the display data element of the user data 
picker will also be seen in the list of data elements. 

 You can see the list of data elements from the component package that do not exist in the 
destination environment user attribute design. 

 You can add the data elements into the destination environment user attribute design by 
selecting the Continue option. If you decide not to change the destination environment user 
attribute design, then you can select Cancel or close the window to cancel the importing 
process. 

Importing Data Elements that are not Pickers 

This topic explains the importing of a Configuration Package with custom User Attributes that do 
not include pickers. 

When you select the component package that has custom user attributes that are not present in 
the destination environment user attribute design, the Import User Attributes window opens. 

In Import User Attributes window, the list of data elements will include all the custom user 
attributes that do not exist in the destination environment user attribute design. You (the 
administrator) will have an option to continue with the import of custom user attributes into 
destination environment user attribute design, or they can cancel the import. 

When importing the data elements into the destination environment user attribute design: 

 If the data elements and data definitions do not exist in destination environment user 
attribute design, then Unifier creates the data elements and data definitions and adds them 
to the destination environment user attribute design. 

 If the data elements do not exist, but the data definitions exist with same definition type, then 
Unifier creates the data elements and adds them to the destination environment user 
attribute design. 

 If the data elements do not exist, but the data definitions exist with a different definition type 
(different than that of the source), then Unifier does not create the data elements, and the 
import fails. 

Impact Analysis Report
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In case of the import being successful, the impact analysis report shows that the user 
attribute design in the destination environment as updated. An additional section for Data 
Structure Setup Components will be included in the impact analysis report, and the custom 
user attributes will be added. 

In the case where the data elements are added, Unifier displays the message: Added to the 
Data Structure Setup and included in the destination user attribute design. 

The Data Structure Setup Components section in the impact analysis report will show the 
user attributes (data elements) that are added or not changed only when the import of adding 
custom user attributes into the destination environment user attribute design is successful. 
The Status column will show the status of the data element  accordingly as either added or 
not changed. The Description column will show the details. 

Importing Data Elements that are Pickers 

This topic explains the importing of a Configuration Package with custom User Attributes that 
include pickers, but the pickers do not exist in destination user attribute design. 

When you select the component package that has custom User Attributes that include pickers, 
but the pickers do not exist in destination user attribute design, the Import User Attributes
window opens. 

In Import User Attributes window, when the custom user attributes are picker elements, the list 
of picker data elements are shown in the Import User Attributes window, similar to other data 
elements if they do not exist in the destination environment user attribute design. The following 
provides more details: 

 When the data picker element, data source, and display element do not exist in the 
destination server

 If in the destination server the custom user attribute which is a data picker element does 
not exist, then the data picker definition will be added to the destination server by adding 
the data source and display element. The user attribute data picker element will be 
created and added to the destination user attribute design. Similarly, the display element 
will be added, if the display element does not exist in the destination.  

 If the display element exists with different definition, then the import will fail and no data 
picker definition will be created in the destination server. 

 If the data source has referenced another design, then the referenced design is imported 
to the destination server. The import will fail if the referenced design exists with different 
ID and so forth. All of the existing import logic for the referenced designs will remain as 
is.  

 When the data picker element and data source do not exist, but the display element 
exists in the destination server

 If in the destination server the custom user attribute which is a data picker element and 
the referenced data source do not exist but the display element exists, then the data 
picker definition will be added by adding the data source. Also, the referenced data picker 
user attribute will be created and added to the destination user attribute design. 

 If the display element does not exist but the data definition of the display element exists 
with different definition from the source, then the import will fail while adding display 
element and no data picker definition will be added. All of the existing import errors will 
be displayed in this case. 
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 When the data picker element does not exists but data source exist in the destination 
server

 If in the destination server the custom user attribute which is a data picker element does 
not exist but the data source exists with the same ID or Design, then the data picker 
definition will be added, and the element will be created successfully. The display 
element will be added if it does not exist in the destination server, and the referenced 
picker element will be added to the destination user attribute design. 

 The import will fail if: 

 The data picker source design does not match with the source, or  

 The display element exists with different data definitions, or 

 The display element data definition name exists with different definitions 

All of the existing import errors will be displayed in this case. 

 When the data picker element exist with different data source in the destination server

If in the destination server the data picker element data definition exists with source 
different that the one in the package, then the data picker element creation will result in 
error, and the import will fail. All of the existing import errors will be displayed in this case. 

 If in the destination server the data picker element with data definition exists but the 
display element is different than the one in the source, then the destination data picker 
element will not change, and the import will be successful after adding the data picker 
element to the destination user attribute design. 

 When the data source has picker elements which refer to another designs

 When the data picker data source has referenced other designs, the referenced designs 
will be imported into the destination along with the data source import. All of the existing 
import errors will be displayed in the case where the referenced design ID or name 
exists, but it does not match with the source. 

Impact Analysis Report

The impact analysis report will show the custom user attributes which are data pickers, or 
shell pickers, that were added, not added, or not changed along with other user attributes, in 
case of successful and failed imports. The Status and Description fields will provide details.  

Component Analysis for Add-on Component Lists 

Similar to the Component Lists, when you select the shell template components to create an 
add-on component list, if the selected components have references to the custom user 
attributes, Unifier displays a warning message informing you that the user attribute design is 
missing in the Add-on Component List and provides the option to include the design through 

Fix Action option .  

The following warning message is displayed in the Add-on Component Analysis window when 
the selected components have references to custom user attributes and user attribute design is 
not selected: "The selected components have references to the custom user attributes and 
<user attribute design name> is missing in the component list." 
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In the Add-on Component Analysis window you can use the Fix Action option  to include 
the dependent user attribute design into the component list created and apply your changes. 
After applying your changes, the warnings (related to user attribute design not included in the 
component list) will not be displayed. 

The Add-on Component Analysis window also displays additional warning messages for the 
referenced custom user attributes in the selected components (such as designs, BP setups, 
UDRs, and so forth) that will be included in the configuration package, when the user attribute 
design is not included. 

Example 

The "Action Items BP" has the user data picker "Assignee DP," and the "Assignee DP" has 
display element name "empEmployeeDepartment" which is a custom user attribute. In this 
case, the following warning message is displayed: "empEmployeeDepartment in User 
Attributes is referenced by data definition Assignee DP will be included." 

The add-on component lists can be saved with or without performing error check, similar to the 
component lists. 

The components that have custom user attributes references will display warnings in the 
Component Analysis window, and there will be a resolving action in order for you to exclude 
those components. 

Importing Configuration Packages 

Click Import to activate the Configuration Package Import wizard. Select a valid zip file and click 
Next. 

When you click Next in the Package Components step, the system displays the package 
components from the selected zip file. 

Only the components available in the zip file are displayed in the Package Components preview. 

Example 

If the user selected a zip file (with categories Designs, Analytics, and Configuration), then the 
Package Components preview displays the following Categories: 

 Designs 

 Configuration 

 Analytics 

Since the configuration include component Business Process, Business Process 
components are displayed under Configuration. 

The Designs node will also have separate sub node Published Designs to show the 
published designs coming in as part of the configuration file. The Group sub node will also 
appear in the categories Shell Templates and Single Instance Shells. For Groups, the 
column that will be seen is the Name where the group name should be seen. 

There will be a filter option available to enable you to filter data for search for every column. 
The print option prints the consolidated report based on the user selected components. 

In the Package Components preview, the Status column is displayed for all the components with 
the following indicators: 
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 Add

When imported successfully, the component will be added in the destination environment. 

 Update

When imported successfully, the component will be updated in the destination environment. 

 No Change

When imported successfully, there will be no changes applied to the component in the 
destination environment. 

When you click Next in the Package Components step, you go to the User Mapping step, and 
the following operations take place:  

 The system extracts the following information, for user mapping: 

 Shell administrator. 

 Auto Creator for Business Process records or line items. 

 BP Auto Creator in the BP Setup. 

 For other component where users/groups are assigned, for example, Workflow Setup, 
Access Control, column restrictions in Cost Sheet, or Portfolio Manager:   

 If all assignees are Groups, then the Groups will be extracted. 

 If the assignees are a mix of users and groups, then only the groups will be extracted and 
the users will be ignored. 

 (Portfolio Manager) If the assignees is a list of users only, then during error check, the 
following error message appears, while creating component list and during export of 
Configuration Package: 

The users assigned to {name of PPM} cannot be extracted. Include at 
least one group to proceed further

 The other creator users for components that the user does not select or cannot be changed, 
for example, creator of Cost sheet, then those creator users are replaced with the user who 
is performing the import. 

 When performing import for the first time in the destination environment, by default, the 
destination login name (present in the destination environment) is displayed in the column for 
users who are present in the environment. The destination login name will be empty for 
users who are not present in the environment.  

 The last entered values for the User Mapping (from the last import) will be remembered in 
the same environment. The system auto-populates the last User Mapping values once the 
user reaches the User Mapping step. 

 You can enter the mapping details. 

 You can edit the destination login name for any value. 

 You can map different imported users to the same user in the destination environment. 

Note: Although group name and the group permission is available, the 
members of the group cannot be extracted. 

After you click Next from the User Mapping step, you go to the Import step. 
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You can select/deselect to download the impact analysis report in the Import step. If you 
deselect this option, you can download the impact analysis report using the gear menu in the 
Configuration Package log. 

Configuration Package Report and Audit Log 

You can view the configuration package contents in a report format by generating a PDF file. 
The print option is displayed when you are viewing the configuration package. 

After you import a configuration package, all included modules that support auditing will continue 
to do so. The following lists the specifics: 

 Auditing is done post import and in the destination environment. 

 New attributes are not added to the Audit log. 

 The Date.  

 The User Name is the user who last imported the configuration package. 

Conditions for User Mapping in Configuration Package 

User Mapping 

Many Unifier modules have user information as a part of setup information. When you create 
and export configuration package, the user information is included in the package; however, 
when you export, the user information will not be created in the Production environment and the 
import process will fail.  

To prevent this, you can map the Development/Test environment users to a user in the 
Production environment.  

Note the following conditions: 

 The user mapping that you set at this point applies to the particular configuration package 
that you are working with. 

 The names that you enter in the Destination Login Name field (Production) must exist in 
the destination environment. 

 The system validates the user names at the time of import. 

 If no user exists by that name, the import fails. 

 The Destination Login Name is a text field and the system validates the character length 
against the existing character length limit for the field. 

 You cannot map a two-source user to the same destination user. 

Configuration Packages Import Rules 

The following explains import rules for the configuration packages. 

Manually, a design object such as a business process can be setup in a Shell template, Single 
Instance Shell, Company Workspace only if the design object has an Active Configuration, which 
is set in the Configuration node. 
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Since the system does not perform checks for the existence of an Active status configuration 
at the time of import, the configuration setup is imported irrespective of configuration status 
(Active or Inactive). As a result, the user must tag the configuration of the corresponding 
design, in the Development/Test environment, so that it is a part of the Configuration 
Package.  

This rule applies to the following components: 

 Business Process 

 Asset Manager 

 Planning Manager 

 Portfolio Manager 

 Resource Manager 

 Shell Manager 

 Space Manager 

 Configurable Manager 

The system imports all content included in the Configuration Package. 

The system aborts the import process if there is an error. 

For a successful import, you must load all necessary modules, for each component, in the 
destination server. For example, if the configuration package includes Cash Flow Curves, then 
the Cash Flow module must be loaded in the Production environment, or destination server. 

If the following objects do not exist in the Production environment, or destination server, then 
the system creates these objects in the Production environment, or destination server, 
automatically: 

 Design 

 Data structure setup components 

 Shell templates 

If a report does not exit in the Production environment, or destination server, then the system 
creates the report after a successful import. 

If your configuration package components already exist in the Production environment, or 
destination server, then the system performs an update upon a successful import. 

System updates result in complete replacement. For example, if the Auto Creation setup has 
changed in the BP setup, then the system applies the updates to all of the tabs in the BP setup. 

If you include BIP reports in your configuration package, ensure that: 

 The application modules have been deployed in the imported environment, prior to import. 

 The BIP reports are at application level. 

If the application modules have not been deployed in the imported environment prior to 
import, then the import process will fail. 

Unifier module options that have associated files are based on the Configuration Package, 
always. 
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The components for the following objects in the Configuration Package overwrite the 
components of the corresponding objects in the Production environment, or destination server, 
after a successful import: 

 Shell templates 

 Templates 

 Company Workspace 

 Single Instance Shells 

If the components of the objects do not exist in the Production environment, or destination 
server, then the system adds the components of the objects in the Production environment, 
or destination server, after a successful import. 

If the components of the objects exist in the Production environment, or destination server, 
then the system updates the components of the corresponding objects in the Production
environment, or destination server, after a successful import. 

When you include the User Mode Navigator setup in the Configuration Package, the system 
deploys the setup after a successful import. 

If external Custom Reports are used in the User Mode Navigator, ensure that the external 
Custom Reports names and locations in the Configuration Package match those existing in the 
Production environment, or destination server; otherwise, the import process will fail. 

If the names of the following components of Cost Manager sheets (Funding), in a Template, do 
not match, then the import process will fail: 

 Funding Sheets 

 Commitment Funding Sheets 

The registry name of Data Views that are imported into the Production environment, or 
destination server, must match those in the Configuration Package. Data Views can only be 
imported between two servers belonging to the same registry. This condition also applies to the 
following components, which use Data Views: 

 Data Cubes 

 UDRs 

 BIP reports 

Impact Analysis Report 

The impact analysis report enables the user to view the impact of component after the import 
has been completed, whether successfully or not. 

An Impact Analysis Report contains the following information: 

 Import Date 

 Imported by 

 Import Status 
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In case of Success, Error, or Failed conditions, the components that will be seen in the report 
are the ones that impacted the destination system. For example if there are no changes related 
to Shell Templates, then the shell template information will not be seen the report. The 
sequence for information seen will be same as seen in the component list screen (the 
left-navigation tree). 

The Status column of the report states the impact on the respective component as follows: 

 Added

When imported, the component has been added in the destination environment. 

 Updated

When imported, the component has been updated in the destination environment. 

 No Change

When imported, no changes are applied to the component in the destination environment. 

Viewing Configuration Packages 

When you click View in configuration package with Draft status, the system displays the wizard 
for the Package Details step. 

When you view a successfully created/imported configuration package, only the components 
and categories are displayed that are a part of the configuration package contents. 

Example 

If the user successfully created a configuration package using List 1 (with categories Designs 
and Analytics) and List 2 (with categories Designs and Configuration and Configuration 
included business processes, only), then the following is displayed in the package 
components Categories: 

 Designs 

 Configuration 

 Analytics 

Since the configuration included the component business process, the business process 
components are displayed under Configuration. 

The Designs node has a separate tab for the published designs that are a part of the 
configuration file. The Group sub node appears in the categories Shell Templates and Single 
Instance Shells. For Groups, the Name column is displayed (group name). 

In case of warnings, the Warnings tab is displayed next to the Components tab listing the 
warnings contained in the configuration package. 

In case of configuration package in Error status, when you click View, all the errors, or warnings, 
related to the configuration package are displayed. 

Transferring Configuration Package 

The following is a workflow for transferring your configuration package from one environment to 
another.  
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Oracle recommends that you follow this workflow: Development > Test and Development > 
Production.  

Development

All the designs, configurations, setups, and any components needed to be transferred to other 
environment must be done in the Development environment. 

Once all the components are ready, create the component list which creates the configuration 
package. The publish for production is optional, based on where you want to transfer the 
configuration package. 

Test

The Test environment can import published and unpublished configuration packages. 

Once the configuration package is transferred to the Test environment successfully, you must 
test all the components of Unifier that have been impacted by the configuration package. 

Any changes made (e.g., setup or configuration) in the Test environment must be made, 
manually, in the Development environment before transferring the configuration package to the 
Production environment. 

Production

Only the published configuration packages that have been tested thoroughly (in both 
Development and Test) must be transferred to the Production environment. 

Installing Base Products 

The Unifier Platform (Basic) is now preloaded in Unifier with the option to install the Project 
Controls and Facilities and Asset Management base products through configuration package 
import.  

Note: See Importing Configuration Packages (on page 640) in this 
guide. 

For the Development environment 

The Unifier Platform (Basic) is preloaded, by default. You have the option to install the 
Project Controls base product or Facilities and Asset Management base product. The base 
products are installed with all of the designs, but the designs are not published. You need to 
create configuration packages, related to each base product, in the Development 
environment, and set them as published before you can use them (transferring, designing, 
configuring, and setting up) in the Production environment. 

Note: Oracle recommends that you follow this workflow: Development > 
Test and Development > Production.  

For the Test environment 
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The Unifier Platform (Basic) is preloaded, by default. You have the option to install the 
Project Controls base product or Facilities and Asset Management base product. The base 
products are installed with all of the designs, but the designs are not published. You need to 
create configuration packages, related to each base product, in the Development 
environment, and set them as published before you can use them (transferring, designing, 
configuring, and setting up) in the Production environment. 

For the Production environment 

The Unifier Platform (Basic) is preloaded, by default. You do not have the option to install the 
Project Controls base product or Facilities and Asset Management base product; however, 
you can transfer the base products by way of the configuration package. 

Including Stamps in Configuration Package 

Multiple stamps can be included in the Configuration Package:  

1) Go to Company Workspace tab > Admin mode > Configuration Package Management > 
Component List. 

2) Click Create. 

3) Go to Company Workspace tab > Configuration Stamps. 

4) Select your stamp. 

5) Enter a value in the Name field (top left). 

6) (Optional) Click Error Check to see if there are any dependencies. 

7) Click Save. 

Note: You can use the Save As option if you want to copy the 
component list. 

8) Go to Company Workspace tab > Admin mode > Configuration Package Management > 
Configuration Packages (to create a configuration package). 

9) Click Create. 

10) Enter values in the Package Name, File name (zip file name), and Components Lists. 

11) Select the component list related to your selected report. 

12) In the New Configuration Package window click Next. The window displays a preview of 
your reports. 

13) Click Next. In case of errors, you will see messages, if no errors are detected, then respond 
to the following: 

 Do you want to publish this package for production? 

 Download package after creation. 

14) Click Create to create the configuration package. 

When the Configuration Package is exported into the next environment, the system adds the 
data elements in to the list of data elements that are available in the stamp. 

The Stamp Elements option enables you to see the Element Label and Element Name of a 
selected stamp. 
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You can use the gear menu ( )  or the Actions option to Delete or Download a selected 
stamp. The Download option enables you to download a zip file containing the image file and 
the "dmstamps.ini" file. 

Note: To select more than one item, click one row, then hold the Control 
(Windows), or Command (Mac), key and select each of the other rows 
you wish to include. To select a continuous list of items, click one row, 
hold the Shift key, and click the last row. 
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