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Preface

Preface
This preface introduces information sources that can help you use the application and this guide.

Using Oracle Applications  

To nd guides for Oracle Applications, go to the Oracle Help Center at hp://docs.oracle.com/.

Documentation Accessibility  

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website.

Contacting Oracle  

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through My Oracle Support. For
information, visit My Oracle Support or visit Accessible Oracle Support if you are hearing impaired.

Comments and Suggestions
Please give us feedback about Oracle Applications Help and guides! You can send an e-mail to:
oracle_fusion_applications_help_ww_grp@oracle.com.

i

http://docs.oracle.com/
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs
mailto:oracle_fusion_applications_help_ww_grp@oracle.com
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1  What’s New in This Release

What’s New in Siebel Events Management Guide, Siebel
CRM 20.1 Update  
No new features have been added to this guide for this release. This guide has been updated to reect only product
name changes.

What’s New in Siebel Events Management Guide, Siebel
CRM 19.1 Update  
No new features have been added to this guide for this release. This guide has been updated to reect only product
name changes.

1



Siebel
Events Management Guide

Chapter 1
What’s New in This Release

2



Siebel
Events Management Guide

Chapter 2
Geing Started

2  Geing Started

Geing Started  
This chapter lists the applications administration tasks that are specic to Siebel Events Management. Use this chapter
in combination with  Siebel Applications Administration Guide .

This chapter contains the following topic:

Administrative Setup Tasks

You can use this manual and the Events Management software interface as a general guide to accomplishing your
business tasks; however, be aware that you may need to make some adjustments to the order in which you enter data
and the ways in which you use Events Management software capabilities.

Siebel Applications Administration Guide  covers the setup tasks that are common to all Siebel Business Applications,
such as using license keys, dening employees, and dening your company’s structure. It also provides the information
you need to implement, congure, and monitor the Siebel sales, service, and marketing products and to perform data
administration and document administration tasks.

Note:  Some tasks discussed in this chapter replace the corresponding ones in the  Siebel Applications
Administration Guide , whereas others are additional tasks. It is recommended that you review the table in
Administrative Setup Tasks before following the procedures in the  Siebel Applications Administration Guide .

This guide assumes that you have already installed or completed the upgrade of Siebel Events Management. If you have
not, go to the Installation/Upgrade section of the  Siebel Bookshelf  CD-ROM and click the links to the guides that are
relevant to your company’s implementation.

The Siebel Database Server installation script creates a Siebel administrator account that can be used to perform the
tasks described in this guide. For more information, see  Siebel System Administration Guide  and the Siebel Installation
Guide for the operating system you are using

CAUTION:  Do not perform system administration functions on your local database. Although there is
nothing to prevent you from doing this, it can have serious results, such as data conicts, an overly large local
database, or a large number of additional transactions to route.

Administrative Setup Tasks  
The following table lists and describes the administrative setup tasks that are specic to Siebel Events Management
and tasks that might dier from those of the other Siebel Business Applications. The following table also directs you to
documentation that provides information about each task.

When seing up your application, use the following table in combination with  Siebel Applications Administration Guide .
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Administrative Task Description For More Information

Conguring the Shopping Cart
 

Set up Web access for Siebel Events for
Finance.
 

Siebel eSales Administration Guide
 

Conguring Email Notication
 

Congure automatic email notications for
events.
 

Siebel Email Administration Guide
 

Reviewing and Modifying Lists of
Values (LOVs)
 

Customize values in picklists.
 

Siebel Applications Administration Guide
 
Reviewing and Modifying Lists of Values
(LOVs)
 

Updating Lookup Tables
 

Populate values for region administration,
 product lines, and session templates.
 

Updating Lookup Tables
 

Using Pricing Models
 

Set up pricing models.
 

Siebel Pricing Administration Guide
 

Using Reports
 

Set up report parameters.
 

Siebel Reports Guide
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3  Installing and Conguring Events
Management

Installing and Conguring Events Management  
Application administrators can use this chapter to understand concepts related to Siebel Events Management
installation and conguration. The chapter provides an overview of server and client installation requirements, browser
requirements, and Shopping Cart requirements. It also includes a discussion of how to congure automatic email
notication.

This chapter includes the following topics:

• Installation Overview

• Shopping Cart Requirements

• Conguring Automatic Email Notication

Installation Overview  
Server software for Siebel Events Management is automatically installed along with your other Siebel Server software
and when the license key for Siebel Events Management is activated. To use Siebel Events Management, you must
enter the Siebel Server component group Marketing. For more information about installing Siebel Servers and about
enabling Siebel Server component groups, see  Siebel Installation Guide for the operating system you are using.

Client software is not required to use administrative or customer-facing functionality, provided that the client computer
has a supported Web browser installed and is connected to a network that communicates with the necessary servers.

Shopping Cart Requirements  
Siebel Events Management is designed to work with the Siebel eSales Shopping Cart, which allows users to pay for
goods and services over the Web. For Siebel Events Management to work properly with the Shopping Cart, Siebel
Business Process Designer must be present, and all Siebel eSales workow processes must be activated. For more
information about the Shopping Cart, see  Siebel eSales Administration Guide .

Note:  Siebel Events implementations running DB2 Universal Database for AS/400 require RSA encryption
for Events Management to work properly with the Shopping Cart. For all other database servers, use of RSA
is strongly encouraged, but not mandatory. You must run separate scripts to enable RSA encryption.For more
information, see the  Siebel Database Upgrade Guide . For information on running the scripts to change the
encryption method to RSA, see  Using Siebel Tools .
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Conguring Automatic Email Notication  
Siebel Events Management is designed to send the following kinds of email messages:

• Invitations to events

• Conrmation messages when registrations for events are completed successfully

• Notication messages that events have no remaining seats open, but that the email recipients have been
placed on waiting lists for any cancellations

• Notication of cancellations

For these messages to be sent automatically, Siebel Events Management must be congured to work with Siebel
Workow Designer and Siebel Communications Server. The general process for seing up automatic email notication
for Events Management is described in this section. For more detailed information about creating communications
proles, restarting servers, and working with workow policies and processes, see  Siebel CTI Administration Guide  and 
Siebel Business Process Framework: Workow Guide  .

This process depends upon a correct email address being included in the Contact information for each person
registered.

Note:  The following procedure assumes that you have already activated the Siebel eSales workow processes
needed for proper operation of the Shopping Cart.

To set up automatic email notication
1. Navigate to the Site Map > Administration - Business Process > Policies view and set an Activation Date and

Expiration Date for each of the following policies:

◦ eEvents Event Conrmation Email

◦ eEvents Event Invitation Email

◦ eEvents Event Waitlisted Email

Note:  For each Activation Date value, use a date that is earlier than the current date. Use an Expiration
Date that is later than the current date.

2. From the link bar, choose Workow Processes and activate the following processes:

◦ Event Conrmation Email (eEvents)

◦ Event Waitlisted Email (eEvents)

◦ Event Invitation Email (eEvents)

◦ Event Cancellation Email (eEvents)

◦ Send Order Accepted Email (eSales)

3. Restart your Siebel Server and Siebel Gateway.
4. Navigate to the Site Map > Administration - Communications > Communications Drivers and Proles view, and

then set up a prole for a supported email server, including appropriate specications for Prole Parameter
Overrides.
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For an Internet SMTP/POP3 mail server parameter, overrides should include entries for any or all of the
following parameters:

◦ From Address

◦ POP3 Account Name

◦ POP3 Account Password

◦ POP3 Server

◦ SMTP Server

◦ POP3 Server Port

◦ SMTP Server Port

5. Navigate to the Administration - Communications screen > All Templates view.
6. In the Templates list, select the Event Conrmation Email Package (eEvents) template.

Then, click the Advanced view tab, and use the Delivery Prole eld to specify the prole you created earlier in
this procedure.

Repeat Step 5 and Step 6 for each of the following templates:

◦ Event Waitlisted Email Package (eEvents)

◦ Event Invitation Email Package (eEvents)

◦ Order Accepted Email Package (eSales)

7. For each of the templates that you updated in the previous step, specify any needed changes to the text that
will appear in your email notications:

◦ For the Events templates, make any needed text changes in the Template Text eld on the Advanced
form.

◦ For the eSales template, click the Template Items view tab, and make the changes in the list that appears.

8. Make sure the Outbound Communications Manager component has been started.
9. Start the Generate Triggers server task.

10. Start the Workow Monitor Agent server task for Events Group.

After email notication is properly congured, your Siebel application generates automatic email messages when event
registration records have a registration status of Invited, Conrmed, or Waitlisted. Automatic email messages are not
generated for session registration records. Workows can be created to send automatic email messages for session
registration records if desired. For more information about registration, including procedures for inviting and registering
event aendees, see Registering for an Event.
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4  Dening an Event

Dening an Event  
Siebel Events Management helps you create and enter information that denes the scope, activities, and budget of an
event. Dening an event is the rst of four phases in the event management process. Because requirements and task
sequences can dier from event to event, the organization of Events Management screens may not exactly match the
sequence or organization of tasks for your particular event.

This chapter includes the following topics:

• Event Management Process Phases

• Business Scenarios for Dening an Event

• Example Process Flow for Dening an Event

• Administrator Setup Procedures for Dening an Event

• End-User Setup Procedures for Dening an Event

Event Management Process Phases  
The event management process has four primary phases:

• Denition

• Preparation

• Implementation

• Evaluation

Siebel Events Management can help you dene, prepare, implement, and evaluate events.

Depending on the size and complexity of your event, you may be tracking large amounts of information, including
the status of many tasks. To simplify the process of learning to use Events Management, this guide discusses the four
phases and provides instructions for business tasks that are typical of each phase. However, if your event is large and
complex, you may nd that the phases actually overlap, or you may nd that changing circumstances occasionally
require you to redo a previously completed task.

Event Plan Denition  
The denition phase typically includes the following business tasks:

• Dening the purpose of the event. Decide what do you want the event to accomplish.

• Dening the type of event. Decide if the event will be a seminar, a conference, a roadshow, or another type of
event.

• Dening the scope of the event. Estimate approximately how many people will aend and for how long. Identify
what types of people will aend.
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• Determining the nature and the logistics of the event. Determine if the event will require specic timing, a
specic location, or a venue.

• Creating an action plan. Identify what activities are required to conduct a successful event.

• Creating a budget for the event. Identify the budget categories and the anticipated costs associated are with
each category.

Event Preparation  
When you know the approximate nature and purpose of your event, your intended audience, and any constraints on
timing and location, you are ready to begin preparing for the event. This phase typically includes the following business
tasks:

• Activity management tasks. These tasks include:

◦ Assigning event preparation and implementation tasks to employees, vendors, or other event sta

◦ Tracking progress of event preparation activities

◦ Designating the event sta and speakers

• Information preparation tasks. These tasks include:

◦ Rening and organizing the information that will be presented at the event

◦ Researching and choosing one or more speakers for the event

◦ Tracking and managing speaker availability for the event

◦ Preparing information for Web site publication

◦ Preparing collateral to be distributed at the event

• Site preparation tasks. These tasks include:

◦ Researching and choosing a venue for the event

◦ Arranging for any needed facilities and equipment within the venue

◦ Doing the required physical setup of the event site prior to beginning the event

• Financial tasks. These tasks include:

◦ Forming partner relationships to improve event quality or defray expenses

◦ Tracking expenditures and revenues in relation to the event budget

• Other tasks. These tasks include:

◦ Researching and choosing vendors for the event

◦ Inviting prospective event aendees

◦ Registering aendees in advance

◦ Preparing status reports concerning preparations for the event

10
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Event Implementation  
When you open the event to the rst registrant, you have moved from the preparation phase into the implementation
phase of the event. This phase typically includes the following business tasks:

• Registering walk-in aendees at the event site. Register walk-in aendees using administration screens, or let
aendees self-register using the Web site (recommended).

• Completing last-minute preparation tasks. Complete last-minute tasks, such as recording the billing parameters
the vendor will use, recording any discounts or special rates you negotiate, and storing le aachments for the
event.

• Coordinating with venue personnel. Coordinate with venue personnel to address any facilities issues that arise
during the event.

• Coordinating with vendor personnel. Coordinate with vendor personnel to make sure that they deliver
contracted goods and services on time, in good condition, and at the correct locations within the venue.

• Coordinating with partner organizations. Coordinate with partner organizations to make sure that they meet
their obligations for the event.

Event Evaluation  
After the event has taken place, you will want to evaluate the event. This phase typically includes the following business
tasks:

• Preparing reports. Create reports on aendance, opportunities generated, and so on for senior management.

• Preparing reviews of the venues and vendors. Review the venues and vendors used for the event to determine
if they should be considered for future events and the reasons why or why not.

• Following up on new business opportunities. Follow up with the contacts that were generated during the event.

Note:  You can analyze a contact’s aendance frequency to target future events and determine areas
of interest by navigating to the Contacts screen and choosing the Consumer list link, then review the
Consumers Activities. For more information, see  Siebel Applications Administration Guide .

Business Scenarios for Dening an Event  
These scenarios provide examples of process ows performed by Siebel application administrators and event planners.
Your company may follow dierent process ows according to its business requirements.

Administrator Event Denition Scenario  
This scenario provides an example of a process ow performed by application administrators. In this scenario, an
administrator works for a company holding a user week conference for a software product used by astronomers. In
order for event planners and team members to eciently manage the event, the administrator needs to set up Siebel
Events Management for the particular informational needs of the event. Also, because Siebel Pricer has been purchased
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along with Siebel Events Management, the administrator needs to set up Events Management and Siebel Pricer to work
together.

Using lists of values (LOVs), the administrator determines the available elds and selections that allow the event planner
and team members to enter and manage the specic information required for this event. For example, the event
planner may need to add a planetarium—which is not typically an available selection—as a room type for a session on a
college campus. To make this possible, the administrator reviews and modies the LOVs that populates the static picklist
for the room type.

Note:  Finance customers, some elds and selections, such as regions, product lines, and sessions, require the
administrator to create them using tables instead of LOVs.

Finally, the administrator performs other procedures that speed data entry by event planners and team members. These
procedures include adding and updating account data, entering contact data, and adding venues.

End-User Event Denition Scenario  
This scenario provides an example of a process ow performed by end users. In this scenario, the end user is an event
planner who, like the administrator described in Administrator Event Denition Scenario, works for a company holding a
user week conference for a software product used by astronomers.

The event planner uses Siebel Events Management to dene the event by entering information about the event, such
as its name, whether it is a conference or seminar, timing, location, and so on. Typically, the event planner waits until
the administrator has dened all of the elds and selections necessary before entering this information. In such cases,
the event planner provides the administrator with enough information to dene the event elds. However, due to the
unusual topic of this event, the event planner decides to work in tandem with the administrator to dene the elds and
enter the event information.

Events often involve featured topics or themes, such as climate change, water pollution, and the ozone layer. In Siebel
Events Management, these are called tracks. Therefore, as part of event denition, the event planner can add any such
event tracks as necessary. To add additional continuity to the event plan, the event planner can also associate related
events.

Next, the event planner creates a budget for the event by entering estimated revenues and expenses, such as
advertising revenues and catering expenses.

Lastly, the event planner creates several activity templates, each of which can be used to associate a set activities, or
action items, with the event.

Example Process Flow for Dening an Event  
The following image shows the recommended event denition tasks to be performed by administrators and end users
in Siebel Events Management.
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Administrator procedures for dening an event include the following:

• Reviewing and Modifying LOVs

• Updating Lookup Tables

• Creating Contacts

• Creating Accounts

• Creating Venues

• Using Price Models

End-User procedures for dening an event include the following:

• Dening Events Plans, Events, and Sessions

• Creating Tracks

• Adding Event Plan Details

• Creating Events

• Adding Budget Details

• Adding Event Activities

Administrator Setup Procedures for Dening an Event  
This section discusses the following topics and procedures:

• Reviewing and Modifying Lists of Values (LOVs)

13
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• Updating Lookup Tables

• Creating Accounts

• Creating Contacts

• Creating Venues

• Using Pricing Models

Siebel Events Management contains elds that depend upon LOVs, existing Accounts, existing Tables or Contacts data.
As an administrator, you can use procedures described in this section to set up and autopopulate many LOVs and tables
before the rst event is added to the database. By rst dening and autopopulating LOVs and tables, entering event
information proceeds more eciently. Also, you may want to verify that businesses and people with whom you interact
when planning and hosting events are added as Accounts and Contacts before you set up events. The sections that
follow contain information about reviewing and modifying these items.

Reviewing and Modifying Lists of Values (LOVs)  
Before you enter information about an event, you may want to review the existing LOVs to determine whether the
values meet the needs of your company and then add or modify LOVs to adapt them to your business processes.

Note:  Certain registration status values, such as Conrmed, Pending, and Waitlisted, are used by
the application to update event seat counts. Developers should excercise caution when changing the
EVENT_REG_STATUS LOV values, and test the application to make sure that it works as expected after any
changes.

To review and modify LOVs for event management
1. Navigate to the Site Map > Administration - Data > Lists of Values view.
2. Refer to the tables in this topic, and review the LOVs for event management.
3. Update the values as required.

For specic instructions on modifying LOVs, see  Siebel Applications Administration Guide .
4. If you add values to the EVENT_FORMAT list of values, also add those values in the List of Values Explorer view:

a. Navigate to the Site Map > Administration - Data > Lists of Values Explorer view.
b. Select the type of SOURCE TYPE (internal).
c. In explorer, navigate to SOURCE TYPE (internal) > Values > EVENT > Child List of Values.
d. In the Child List of Values list, add the values.

Siebel Events Management screens contain elds that display available values from LOVs such as those listed in the
following tables.

The following table shows LOVs for Event Management.

List of Values Comments

EVENT_BILLING_BASIS
 

Indicates whether a venue or vendor rate is calculated hourly, daily, weekly, monthly, or on a per-item
or per-person basis.
 

EVENT_COMMITMENT_TYPE
 

Displays a selection of contribution types a partner organization can make for an event, such as
monetary, promotional, material, and so on.
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List of Values Comments

EVT_FREQUENCY
 

Frequency with which the events occur within an event plan. For example, daily, monthly, or quarterly.
 

EVENT_FEE_TYPE
 

Indicates if a fee is required for the event. Values available by default include Registration, Voluntary,
 Donation, and None.
 

EVENT_FORMAT
 

Displays the format of the session featured, such as Keynote, Roundtable, Workshop, and so on.
 

EVENT_COMMITMENT_TYPE
 

Displays a selection of sponsorship commitment types, such as promotion or resources.
 

EVENT_ORG_TYPE
 

Displays a selection of vendor or partner for an organization type.
 

EVENT_PARTNER_ROLE
 

Identies the role of a partner organization in an event, such as Exhibitor, Sponsor, Contributor, and so
on.
 

EVENT_PARTNER_STATUS
 

Indicates the status of arrangements with a partner organization, such as Requested, Shipped,
 Fullled, and so on.
 

EVENT_REG_STATUS
 

Displays the registration status of a potential aendee, speaker, or sta member for an event or an
individual session.
 

EVENT_REVENUE_TYPE
 

Displays a selection of revenue sources related to an event, such as Partners, Sponsors, Advertisers,
 and so on.
 

EVENT_ROOM_TYPE
 

Displays a selection of room types available at event venues, such as conference rooms, classrooms,
 auditoriums, and so on.
 

EVENT_STAFF_ROLE
 

Displays a selection of sta member roles or areas of responsibility, such as Set-Up, Moderator, Clean-
Up, and so on.
 

EVENT_STATUS
 

Displays the registration status, such as in Planning, Launched, Scheduled, and so on.
 

EVENT_STATUS_CODE
 

Displays the status of an event or session, such as Planned, In Progress, Completed, and so on.
 

EVENT_TYPE
 

Displays the type of parent event plan or event featured, such as Seminar, Deal Roadshow, Non-Deal
Roadshow, and so on.
 

EVENT_VENDOR_ROLE
 

Displays a selection of vendor roles or areas of responsibility, such as Caterer, Audio/Video, Security,
 and so on.
 

EVENT_VENUE_ROLE
 

Displays a selection of venues, such as Convention Center, Hotel, Oce, and so on.
 

MKTG_PLAN_APPR_TYPE
 

Displays a list of approval status values, such as Rejected, Approved, and Submied.
 

OFFER_MATERIAL_TYPE
 

Displays a selection of collateral and literature types, such as Brochure, Map, Hand-out, and so on. This
LOV is used in other areas of your Siebel application.

15



Siebel
Events Management Guide

Chapter 4
Dening an Event

List of Values Comments

 

PARTICIPANT_STATUS
 

Displays a selection of participant status types such as VIP and Guest.
 

SALES_TOOLS_STATUS
 

Indicates whether a collateral or literature item has reached Draft, Final, Approved, and so on. This LOV
is used in other areas of your Siebel application.
 

SRC_ITEM_CATEGORY
 

Displays a list of expense categories, such as Creative, Furnishing, Vendors, Materials, and Venues.
 

SESSION_LOCATION_TYPE
 

Displays a list of session location types, such as Station or Table.
 

TRAVEL_TYPE_CODE
 

Displays a selection of travel types such as Air, Ground, and Hotel.
 

The following table shows LOVs that are specic to Financial Services customers.

List of Values Comments

EVENT_COM_REG_STATUS
 

Displays the registration status of an account for an event or an individual session. Values include
Pending, Conrmed, Waitlisted, Restricted Invite, Invited, Cancelled, and so on.
 

EVENT_RECUR_FREQ_TYPE
 

Indicates the frequency of the auto-generated event of an event plan, such as Daily, Weekly, Quarterly,
and so on.
 

EVENT_VENDOR_FUNCTION
 

Denes the service the vendor is providing. Values include Ads, Music, Lunch, Breakfast, Booths, Limo,
Lodging, Publications, Sound, Table Set-up, Video, and so on.
 

EVT_PARTICIPANT_TYPE
 

Displays values for participant type, such as Analyst, Internal Participant, Competitor, and so on.
 

EVT_SIGNUP_STATUS
 

Displays the event registration status values, such as Open or Closed.
 

FINS_EVENTS_PROD_CAP_SIZE
 

Displays values for the market capitalization size to describe the featured nancial product, such as
Large Cap, Mid Cap, Small Cap, or Micro Cap.
 

Note:  You use the S_REGION table to dene the regions associated with the featured nancial product, such
as Asia, North America, Europe, and so on.

Updating Lookup Tables  
You can enter and maintain some values through LOVs, but you must create other values through tables. The advantage
of using tables to enter values is that each company can establish a unique hierarchy and dene appropriate values for
its business processes.
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Populating tables in your Siebel application is a consistent process when seing up Regions, Product Lines, and
Session templates, which are described in this section. You can update event-related tables from the Administration -
Application screen.

Region Administration  
Because Siebel Events Management is only one of many parts of your Siebel application that uses the concept of
region, you need to dene a regional hierarchy appropriate for your overall business.

There are two region-related elds in Siebel Events Management:

• The Region eld indicates the region in which the Event takes place.

• The Region Origin eld indicates the Region from which the Event's featured investment comes.

Other parts of the Siebel application use region to indicate the investment focus of your salesmen and their coverage
regarding your client companies. Therefore, it is important that you select a region hierarchy that is generic enough to
describe event regions, coverage regions, and investment product regions in a single table.

For global or multinational companies, you need to dene regional hierarchies that relate to the geographical areas
your business serves and in which you conduct events. Application Administrators can manage region hierarchies by
performing the following procedure.

To dene regional hierarchies

1. Navigate to the Administration - Locations > Regions view.
2. In the Parent Region list, dene the region, for example, North America, Asia, and so on.
3. In the Child Region list, you can then dene subsets of the Parent Regions. For example, your Child Regions

could be the individual countries that are associated with the highlighted record in the Parent Region list.

Alternatively, you many choose to use individual cities that are associated with the highlighted Parent Region.
If two levels of region hierarchies are not sucient for your company's business requirements, the Siebel data
model allows a database administrator to create additional levels. You will however, have to congure the user
interface to allow users to dene this hierarchy.

The following list illustrates how multiple regions and areas within regions can be set up in the Region table. For
example, your nancial institution may dene geographies in the following major regions and then areas within a
region:

• Asia-Pacic

◦ Japan

◦ China

◦ Singapore

◦ Malaysia

◦ Indonesia

◦ Australia

• Europe

◦ United Kingdom

◦ France

◦ Spain
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◦ Italy

• Middle East

• North America

• South America

For more information on working with regions, see  Siebel Finance Guide .

Period Administration  
While some organizations use standard calendar reporting periods, other organizations use scal reporting periods.
Siebel Business Applications provide exibility in this area, so organizations can set up periods that make sense for
them. For information about period administration, see  Siebel Forecasting Guide .

Product Lines for Financial Services Customers  
If you are a nancial services customer, Siebel Events Management uses the Product Line table to store Asset Classes.
You will want to add a row to the table for each relevant asset class associated with a product line from the Product Line
Fee view of the Administration - Application screen.

For example, your nancial institution may dene the following four types of Asset Classes within a Product Line:

• Derivative

• Equity

• Fixed Income

• Mutual Fund

For information on Product Administration, see  Siebel Product Administration Guide .

Adding Session Templates  
Siebel Events Management uses Session Templates to store templates for groups of sessions that are similar. For
example, all events that take place in London may follow the same sequence of sessions, including the same start times
and end times. In this case, you may want to save a London template that contains the same sequence of sessions,
which you can reuse each time you host a London event.

Session templates may be used in more than one region, area, or location. You can manage session templates by
navigating to the Marketing Templates screen and choosing Session Templates. For more information, see Event
Management Process Phases.

The following steps describe a recommended workow for seing up session templates and the events and sessions
that dene them.

1. Create the template. An Administrator creates a Session Template and adds session details including City,
Country, and Start Time.

2. Add sessions to the template. The administrator then adds sessions to the template, specifying name, start
date, end date, and format.

3. Save the template. Siebel Events Management saves the session template, which allows you to add, change, or
delete sessions associated with it.

The following table displays sample line items in a session template. For example, your company may dene the
following one-day event in London as part of a session template.
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Session Line Items Details

City
 

London
 

Country
 

United Kingdom
 

Start Time
 

9:00 A.M.
 

After you have created an outline for a London session template, you can add typical sessions that occur during your
London-based events. The following table displays sample sessions within the London session template.

Sample Sessions Details

Registration/Breakfast
 

8:00 A.M.-8:30 A.M.
 

Introductions
 

8:30 A.M.-9:00 A.M.
 

Opening Presentation
 

9:00 A.M.-10:00 A.M.
 

Featured Presentation
 

10:00 A.M.-11:30 A.M.
 

Breakout Session
 

11:30 A.M.-12:30 P.M.
 

Lunch
 

12:30 P.M.-2:00 P.M.
 

One-on-One Analysis
 

2:00 P.M.-3:30 P.M.
 

Roundtable 2
 

3:30 P.M.-5:00 P.M.
 

Group Report Out
 

5:00 P.M.-5:45 P.M.
 

Concluding Remarks
 

5:45 P.M.-6:00 P.M.
 

Creating Contacts  
A few Events Management forms and lists contain elds that depend upon existing contact data entered in the Contacts
screen. A contact is an individual with whom your company conducts business or expects to conduct business with
in the future. A contact can be an employee of another company, a vendor, or professional consultant and may have
relationships with a number of companies. Data entry in Events Management can proceed more smoothly if you have
already entered contact data for:

• Your organization’s employees
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• Potential sta (other than vendors)

• Potential venue personnel

• Potential individual invitees

For more information about entering Contacts, see  Siebel Applications Administration Guide .

Creating Accounts  
Administrators create the supporting data for the events (that is, account information, venues, seing up rooms, and so
on) before creating the event itself. Therefore, many Events Management forms and lists contain elds that depend on
existing account data entered in the Accounts screen. An account represents the relationship between your company
and the companies or individuals with whom you conduct business. To make data entry in Events Management less
time consuming, you can enter account data for event vendors, partners, supporting organizations, and employing
organizations of potential event invitees earlier.

Before adding account data, identify the relationships for which you need to create accounts. Then, use the following
procedure to enter account data for each relationship.

To enter account data
1. Navigate to the Site Map > Accounts view.
2. Before adding a new account, search the accounts list to make sure the account does not already exist.
3. If the account does not exist, in the Add Section complete the elds for the new account, and click Add.
4. In the Recent Records section, drill down on the account name.
5. Click the More Info view tab, click the show more buon and complete additional elds as needed.

As you gain additional information, or as account details evolve or change, you can update the account information.
For more information, including details about adding an account, specifying account details including addresses, and
handling company name changes, see  Siebel Applications Administration Guide .

Creating Venues  
A venue is a physical facility where an event may be held, such as a conference center or hotel. In Siebel Events
Management, you can store information about possible venues ahead of time, including their rental rates, and later
choose which venue or venues to associate with an event. These and other end-user tasks are described further in
Preparing for an Event.

In preparation for working with venue data, you should add possible venues using the Administration - Location screen
as described in the following procedure.

To add a venue
1. Navigate to the Site Map > Administration - Location view.
2. In the Locations list, create a new record, and complete the necessary elds.

The following procedure describes how to enter information about rooms that you may want to use for event venues,
such as conference rooms, meeting rooms, or classrooms.
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To enter room information for a potential event venue
1. Navigate to the Site Map > Administration - Location view.
2. In the Locations list, select the location that you are considering as a possible event venue.
3. Click the Rooms view tab.
4. In the Rooms list, create a new record.

The following table describes some elds in the Room list.

Field Comments

Drops
 

Information describing the network access ports.
 

Name
 

Name of the room you are considering as a possible event or session venue.
 

Room Rate
 

Expense of renting the room, per time unit or other unit identied in the Basis eld.
 

Type
 

Type of the room.
 

The following procedure lets you record information about the equipment that is available in a potential room for an
event.

To add the equipment available in a potential event venue room
1. Navigate to the Site Map > Administration - Location view.
2. In the Locations list, select the location that you are considering as a possible event venue.
3. Click the Rooms view tab.
4. In the Rooms list, select the room for which you want to add equipment.
5. In the Equipment list, create a new record.

Using Pricing Models  
If you have purchased Siebel Pricer along with Siebel Events Management and will be using the Siebel Shopping Cart
view to charge customers event or session registration fees, you can use pricing models to adjust the registration fee
a customer must pay to aend an event or session. The adjusted fee may be based on customer location, customer
account agreements, or other factors.

For more detailed information about seing up and using Siebel Pricer, see  Siebel Pricing Administration Guide .
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End-User Setup Procedures for Dening an Event  
This section discusses the following topics and procedures:

• Dening Event Plans, Events, and Sessions

• Creating Tracks

• Adding Event Plan Details

• Creating Events

• Adding Budget Details

• Adding Event Activities

Dening Event Plans, Events, and Sessions  
Siebel Events Management allows you to dene event plans, events, and sessions. For the purposes of dening and
organizing information for an event, you should note that Siebel Events Management uses a three-level hierarchy of
events:

• Event Plans. Event plans are used to dene the high-level information about an event, including overall date
span, approvals, and summarized nancial metrics. Information from child events, such as expenses and
aendees roll up to the event plan.

• Events. The propagated events, or children of the parent event, which comprise the individual days within the
parent event timeline. An event is usually one day long.

• Sessions. The components of an event. Usually, many sessions make up an event. Sessions are typically
measured in hours.

Event plans include dening the purpose, nature, and scope of the event, and making at least tentative decisions about
when and where the event will be held. In Siebel Events Management, you can record these decisions in an event.

Later in the denition process, you can update the event plan, events, and sessions with detailed information. Also,
prospective event aendees will be able to view information from the listing on your Siebel Events Web site.

Note:  In this release, information that is entered for a specic session is stored separately from information
that is entered for the event that includes the session. For example, to view all information about event
vendors, you would need to review the vendor information under the Participants view tab and the Sessions
screen.

Creating Tracks  
A track in Siebel Events Management is a featured topic or theme at an event. For example, a biotech investment
conference may establish three tracks: Genomics, Computers, and Pharmaceutical.

After tracks are created, they can be associated to events and sessions. For example, using the biotech example, you
could relate several sessions on using computers in biotech with the computers track. As a result, aendees who are
interested in this subject can select from a subset of sessions that are related to the subject.
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The following procedure describes how to add an event track. For information on relating a track to events and sessions,
see Preparing for an Event.

To add an event track
1. Navigate to the Site Map > Events > Tracks view.
2. In the Tracks list, create a new record, and enter a status for the track.

Some status values are In Planning, Scheduled, Launched, Completed, and Cancelled.

Note:  These status values are for descriptive purposes only and do not limit registration to associated
sessions.

Adding Event Plan Details  
This section describes how to create an event plan, which generates events. Creating an event plan also generates an
activity in the Activities screen.

The lists and forms for event plans and events use much of the same information. Many of the elds you enter for the
event plan are inherited by its events. Each event inherits the values in the parent event elds when it is initially saved.
After the initial save, the Status eld and the Display on Website eld inherit changes made to the parent event.

An event plan’s Status eld can be used to hide the event, and its events and sessions, from all users who are not using
an Events Administrator Log In ID. This is accomplished by choosing the value Restricted in the Status eld of an event.
The Restricted status is then copied to that event’s events and sessions. This also works in reverse—if a session’s status
is changed to Restricted, the change aects, or gets copied to, the status of the event or event plan.

Note:  For Finance customers, to hide the event, choose the value of Hidden in the Status eld of an event.
This hides the event from sales people and other employees who do not have administrative log in.

When creating an event plan, you can specify a value in the Event Frequency eld. This eld, along with the event plan
start and end date, determines how many event records will automatically be generated under the event plan. For
example, if the event plan spans 10 days, and the event plan frequency is daily, then 10 events will be generated. When
creating a new event plan, events are automatically generated upon saving the event plan record. To generate events
for existing event plans, use the Create Events buon on the event plan form applet. You can use only the Create Events
buon to generate events if no events exist for the event plan.

The following procedure describes how to create an event plan.

Note:  To avoid manually updating the events that the event plan generates, enter as much information as
possible in the event plan record before you save it for the rst time.

To create an event plan
1. Navigate to the Site Map > Events > Event Plans view.
2. From the visibility lter, select All Event Plans.
3. In the Event Plans list, create a new record, and complete the necessary elds.
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Note:  As the event plan creator, you will automatically be selected as the primary team member.

Siebel Events Management automatically generates events for each day, including the start and end dates for
the parent event. To change the event frequency, in the More Info form, select an event Frequency.

Seing Goals and Assumptions for an Event Plan  
Each event plan can be associated with a set of goals and assumptions. Each goal is a metric against which the
performance of the plan will be measured, given certain quantitative assumptions.

To create a goal for an event plan

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event plan.
3. Click the Plan view tab and then click Goals.
4. In the Goals list, create a new record.
5. In the Metric eld, select the appropriate value and complete the following steps based on that choice.

◦ If the goal is a nancial metric, in the Target Amount eld, complete the target value for the goal.

◦ If the goal is s non-nancial metric, in the Target Quality eld, complete the target value for the goal.

6. If known, in the Forecast Amount column, type the forecast value.

If you do not know the expected forecast value, leave the eld empty and complete the eld after you have
developed a forecast.

Note:  If the goal has a number format of percentage be sure to type whole number values, not decimal
values. For example, an ROI goal of 15% should be completed at 15, not .15.

To create an assumption for an event plan

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event plan.
3. Click the Plan view tab and then click Goals.
4. In the Assumptions list, create a new record.
5. In the Metric eld, select the appropriate value and complete the following steps based on that choice.

◦ If the goal is a nancial metric, in the Target Amount eld, complete the target value for the goal.

◦ If the goal is s nonnancial metric, in the Target Quality eld, complete the target value for the goal.

6. If known, in the Forecast Amount column, type the forecast value.

Note:  If you do not know the expected forecast value, leave the eld empty and complete the eld
after you have developed a forecast.

Deal Roadshow Event Type (Financial Services Customers Only)  
If you are a nancial services customer, you can create an event with a Type = Deal Roadshow, you can also select the
specic deal with which the event is associated and make sure that the deal and the event are not visible to others
outside of your deal team. When you associate the event with the deal, the security for the deal is inherited by that
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event. Users added to the employee list as members of the event team will not be able to view the event unless they are
rst added to the deal team.

Deal visibility is associated with an individual’s position and not with the individual user. Because Siebel applications
typically associate only one position with an employee, this association may aect an employee who leaves a position as
a member of the deal team to work in another department within the company. A new employee would be assigned to
that position, which may result in the possibility that users could lose track of the old employee's knowledge of the deal.
This functionality is required to comply with the securities laws in most countries.

Note:  In order to limit visibility of a deal to designated deal team members, you must rst select the Secure
Flag in the More Info form on the Opportunities Screen. You can designate deal team members in the Sales
Team eld in your Siebel application. The primary deal team member is the only one who can change the
Secure Flag.

Associating a Deal Roadshow with a Specic Deal (Finance Services Customers Only)  
The following procedure describes how to associate a specic deal with an event.

To associate a deal roadshow with a specic deal
1. Navigate to the Site Map > Events view.
2. In the Events list, select and drill down on the event for which you want to associate the deal.
3. In the Event Details form, in the Deal Name eld, click the select buon.
4. In the Opportunity dialog box, select Add, and then click OK.

Updating Event Plans  
The following procedure describes how to make changes to an event plan.

To modify an event plan
1. Navigate to the Site Map > Events > Event Plans view.
2. In the All Event Plans list, modify the event by changing the necessary elds.

Changes made to the parent event will not automatically update in the events’ elds. You can manually change
event data from the Events view.

To delete an event plan
1. Navigate to the Site Map > Event Plans view.
2. In the All Event Plans list, select the event and click Delete.

CAUTION:  If you delete an event plan, all events, sessions, and activities associated with it are also
deleted. Therefore, it is recommended that the only time events should be deleted is when they are
erroneously created. Otherwise, the status of the event should be set to Canceled to indicate that it did
not take place, and no more work needs to be done.

Creating Events  
Events can be manually created or updated with an event plan. Events Management allows you to manage and track the
entire event process.
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To create an event
1. Navigate to the Site Map > Events > Event Plans view.
2. From the visibility lter, select All Event Plans.
3. In the All Event Plans list, select and drill down on the Event Plan Name.
4. Click the Schedule view tab, and then click Events.
5. In the Events list, create a new record, and complete the necessary elds.

Note:  You can automatically generate events on the Event Plans form, using the Create Events buon.

The following two tables describe some elds in the Events form.

Field Comments

# of Aendees
 

Allows you to maintain approximate aendance information.
 

Additional Product Interest
 

A free-form text eld to describe additional sectors, regions, additional capitalization sizes, and other
items of interest about the featured investment security.
 

Asset Class
 

The asset class of the investment security featured by the event. For example, if the event is called
Global Bond Investing, then the featured asset class would be Fixed Income (or Bonds).
 

Capitalization Size
 

Describes the relative size of the market capitalization of the featured investment.
 

Deal Name
 

Name of the deal (IPO or other investment banking-related opportunity) featured by the event.
 

External
 

A check box to indicate whether you an event to be visible to external contacts through the Siebel
Events Web site. If External is not checked (value = FALSE), then no external contacts are able to see
information about the event through the Web site.
 

Fee Type
 

The fee is required for the event. Default values include Registration, Voluntary, Donation, and None.
 

Industry
 

Describes the sector or industry group of the featured investment. For example, if the event features
an automobile company, then the Industry value is Automobiles.
 

Preferences
 

Free-form eld that allows you track any aendee preferences on an aggregated basis. For example, in
this eld you might enter “Order 20 vegetarian meals.
 

Project Code
 

Your company’s internal Project Code for the event.
 

Region Origin
 

Describes the region in which the featured investment originates. For example, if the event features an
automobile company based in Japan, then the Region Origin value is Asia.
 

Symbol
 

The stock ticker or CUSIP of the featured investment.
 

Team
 

The employees responsible for accomplishing event-related tasks, including planning, hosting, and
evaluating the event. By default, the user who creates the event is automatically listed as the primary
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Field Comments

team member. The primary team member or the system administrator can designate a dierent
employee as the primary team member. For more information, see the procedure titled To create an
event plan in the Updating Event Plans section.
 

Field Comments

Capacity
 

Approximate audience range projected for the event. This value is used during registration to help
determine whether or not maximum enrollment for the event has been reached.
 

Display on Website
 

Species whether the event should be displayed on the Events Web site.
 

Description
 

A free-form text eld to describe the event. Information entered here is visible to prospective aendees
as part of the Upcoming Events information on the Home Page.
 

Current Registration Fee
 

Fee to register for the event at the current date and time.
 

End
 

(Required) Date and time that the event ends. The end value cannot be set to a date and time earlier
than the Start value. Also, the end value cannot conict with parent (events, in the case of sessions or
event plans, in the case of events) start and end values.
 

Event Name
 

(Required) Name for the event that will be visible to internal and external users.
 

Event Type
 

(Required) Nature of the event. Typical values include Meeting, Conference, Trade Show, Seminar, and
so on. The list of values that determines the available choices is EVENT_TYPE.
 

Fee Type
 

The fee is required for the event. Default values include Registration, Voluntary, Donation, and None.
 

Frequency
 

The number of times the event takes place.
 

Host Employee
 

The employee responsible for the event.
 

Invitation Deadline
 

Date by which invitations for the event should be sent to prospective aendees. Defaults to 60 days
before the event Start.
 

Lead Partner
 

The partner company aliated with the event.
 

Organization
 

Species which organizations have access to view the event. By default, the event creator’s
organization is added to this list as the primary organization. For more information about
organizations, the  Siebel Applications Administration Guide .
 

Promotional Fee
 

Discounted fee for registering before the promotion and date.
 

Promotion End
 

The date until which the promotional registration fee applies.
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Field Comments

Standard Fee
 

Regular fee for registering into the event.
 

Session Template
 

Species the session template used to generate sessions.
 

Start
 

(Required) Date and time that the event starts. The start value cannot be set to a date and time
later than the end value. For a new event, both elds default to current date and time. The event
automatically appears on the Events Calendar for each date from the start through and the end.
 
Also, the start value cannot conict with parent (events in the case of sessions, event plans in the case
of events) start and end values.
 

Status
 

Status of the event. Values available by default are as follows:
 

• Planned. Visible only in administrative screens. Registration not allowed.

• Launched. Visible in administrative screens and end-user screens. Registration allowed.

• In Progress. Visible in administrative screens and end-user screens. Registration allowed.

• Completed. Visible only in administrative screens.

• Cancelled. Visible only in administrative screens.

Team
 

The employees responsible for accomplishing event-related tasks, including planning, hosting, and
evaluating the event. By default, the user who creates the event is automatically listed as the primary
team member. The primary team member or the system administrator can designate a dierent
employee as the primary team member. For more information, see the procedure titled To create an
event plan in the Updating Event Plans section.
 

URL
 

Location of a Web site providing more information about the event.
 

Venues
 

Main location where the event is held, such as a hotel, conference center, or oce building. You
associate venues with Companies.
 

After you create an event, you can associate one or more tracks with an event.

Updating an Event  
Sometimes in the event planning process it is necessary to add or update information previously recorded based on
changes to the events.

To update an event

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select the event, and make the necessary changes.

Adding Budget Details  
As part of dening an event, you can create a budget for the event. The budget includes estimated revenues and
expenses. Then, as part of preparing for and hosting the event, you can enter actual revenues and expenses. With this
information, Siebel Events Management calculates budget variances (estimated versus actual amounts) so you can
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analyze an event’s nancial performance at each level of the event—event plan, event, and session. This capability
allows your company to maintain a history of line item variances and budget accuracy over time.

Note:  Expenses and revenues for events and sessions can be entered at any level in the hierarchy.

To enter estimated expenses or revenues for an event
1. Navigate to the Site Map > Events > Event view.
2. From the visibility lter, select All Events.
3. In the All Events list, select and drill down on the event for which you want to enter expenses.
4. Click the Plan view tab, and select the appropriate subview.

◦ For estimated expenses, click the Expenses subview tab.

◦ For estimated revenues, click the Revenue subview tab.

5. In the Expenses list, create a new record, and complete the necessary elds.
When you save the record, the Variance amount and running totals for Forecast Expenses and Actual Expenses
are updated at the end of the Expense List.

6. (Optional) To add invoice details to an expense record, create a new invoice record in the Invoices screen, and
make note of the invoice number for use in the remaining steps.
Some invoice record elds are described in the following table.

Field Comments

Type
 

Select Payable. Invoices of type Receivable cannot be selected for cost line items.
 

Invoice #
 

This automatically generated number appears in the Invoice # eld of the Invoice Items
list when you return to the event’s Cost view in the next step in this procedure.
 

7. Navigate back to the Invoice Line Items list for the event.
8. Click Add in the Invoice # eld to copy in the invoice information from the Invoices screen.

The following table describes some elds in the Invoice Line Items list.

Field Comments

Quantity
 

The number of items associated with the cost line item.
 

Invoice Expected?
 

A Yes or No value, based on whether or not a vendor will generate an invoice.
 

Invoice Date
 

The date the Invoice # is entered.
 

Invoice Status
 

The status of the invoice. Typical values are Open, On Hold, Cancelled, Consolidated,
 and Closed.

29



Siebel
Events Management Guide

Chapter 4
Dening an Event

Field Comments

 

Vendor Invoice #
 

The invoice number entered.
 

Vendor Name
 

The account name of the vendor.
 

Cost Code
 

An internal cost code associated with the line item.
 

Estimating Revenues  
You can use Siebel Events Management to track revenue sources for an event. Revenue may come from sources such as
sponsorships, registration fees, advertising, and exhibitors.

To enter estimated revenues for an event

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the Event Name.
3. Click the Plan view tab, and then click Revenue.
4. In the Revenue list, create a new record, and complete the necessary elds.
5. (Optional) Associate the revenue with a session.

You can track expenses at the venue and vendor levels. Expenses created at the venue level, roll up to the event and
have a Cost Type = Venue. Expenses created at the vendor level, roll up to the event and have a Cost Type = Vendor. For
more information on creating expenses for a venue, see Researching and Choosing a Venue. For more information on
creating expenses for a vendor, see Researching and Hiring Vendors.

Financial Information for Events  
Siebel Events Management provides summarized nancial information at all three levels in the hierarchy: Event Plans,
Events, and Sessions. This information includes planning period, budget, expenses, and revenues. Several of these
elds are automatically calculated based on detailed records that are created. See the following three tables for more
information about these elds.

Field Comment

Planning Period
 

User entered
 

Execution Period
 

User entered
 

Requested Budget
 

User entered
 

Assigned Budget
 

User entered
 

Forecast Expenses
 

An autopopulated eld that provides the sum of expense records and forecast expense eld
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Field Comment

Actual Expenses
 

An autopopulated eld that provides the sum of expense records and actual expense eld
 

Forecast Revenue
 

An autopopulated eld and provides the sum of revenue records and forecast revenue eld
 

Actual Revenue
 

An autopopulated eld that provides actual revenue. For more information see  Siebel Marketing User
Guide .
 

Planning Period
 

User entered
 

Field Comment

MDF Requested
 

An autopopulated eld that provides the sum of MDF request
 

Net Expense (forecast)
 

An autopopulated eld that provides the Forecast Expenses-MDF Requested
 

Field Comment

Budget Request
 

Assigned from the Budget Request in a marketing plan; for more information, see  Siebel Marketing
User Guide
 

Approving Event Plans  
During the event planning phase, marketing administrators may be required to submit high-level event plans for
approvals, as a part of the overall planning and budgeting process. Siebel Events Management contains functionality
for geing approvals, whereby users can collaborate on an event plan by submiing the record to dierent individuals
using the approval eld. You can dene further control over the approval process through state models, see  Siebel
Assignment Manager Administration Guide  for further information.

To use the event plan approval eld

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select the event.
3. In the Event Plan form, from the Approval Status eld, click the drop-down list and select Submied.
4. In the Pick Employee dialog box, select the individual to whom you want to submit the plan.
5. Enter any additional comments, and then click Send.

The person to whom you have submied the plan must log in to the Siebel application to approve or reject the
plan.

Note:  You have the ability to track the history of approvals in the Event Plan > Plan > Approvals view.
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Adding Event Activities  
An activity in Events Management is an action item, such as creating collaterals, that needs to be assigned and
completed prior to the start of an event. You enter these action items using the Activities view tab in Siebel Events
Management.

CAUTION:  Some view tabs have names that closely resemble typical event action items, but which are, in fact,
reserved for the products of action items. For example, the Collateral view tab is where collateral, a product,
is stored after an individual creates collateral, an action. Use the Activities view to list action items such as
creating collateral and to assign them to specic individuals.

During this phase of event management, you enter activities for the event. Then, during the next phase of event
management, event preparation, you assign the activities to specic sta members, and track activity progress.

When entering activities, you can enter records individually for each event, or you can create a reusable activity
template, which automatically associates a set of activities with any event you choose.

You can also combine individual activities with activities from an activity template. If some activities in an activity
template do not apply to an individual event, you can remove them from the event without aecting the template.

The following procedure describes how to create a reusable activity template for an event.

To create an Activity Template for an event
1. Navigate to the Site Map > Administration - Data > Activity Templates view.
2. In the Activity Templates list, create a new record.

a. In the Name eld, provide a name for the activity.
b. In the Type eld, select Event Management.
c. Leave the Sales Stage and Sale Method elds blank, because they do not apply to Siebel Events

Management activities.

Note:  Finance customers, be sure to select the Automatic Trigger check box to automatically generate
an activity list when the template is associated with an event.

3. Click the Activity Templates Details view tab.
4. In the Activity Template Details list, create a new record.

Note:  Create a new activity for each activity associated with the activity template.

For information on creating activity templates, see  Siebel Applications Administration Guide .

To associate an Activity Template with an event
1. Navigate to the Site Map > Events > Event view.
2. From the visibility lter, select All Events.
3. In the Events list, select and drill down on the Event Plan Name.
4. Click the Schedule view tab, and then click Events.
5. Click the Plan view tab, and then click Activity Plans.
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6. In the Activity Plans list, create a new record.
7. In the Template eld, choose a predened template from the drop-down list.
8. Complete other elds as needed.
9. Click the Activities link.

10. In the Activities list, drill down on the Type eld to edit details of that activity.

The display changes from the Events screen to the Activities screen, and an Activity form and an Aachments
list are displayed.

The following procedure describes how to add an individual activity to an event.

To add an activity to an event
1. Navigate to the Site Map > Events >Event view.
2. In the Events list, select and drill down on the Event Name.
3. Click the Plan view tab and then click Activities.
4. In the Activities list, create a new record, and complete the necessary elds.

A modied list of activities appears.

For more information on working with activities, see  Siebel Applications Administration Guide .
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5  Preparing for an Event

Preparing for an Event  
This chapter discusses how to organize, schedule, and assign the many tasks required to produce a successful event.
Specically, the chapter provides procedures for organizing and stang sessions, and associating each session with
a track. In addition, you can add detailed activities and assign them to event sta. The chapter also describes other
preparation tasks for physical aspects of the event site and provides procedures for involving external parties, such as
vendors and speakers.

This chapter includes the following topics:

• Event Preparation Tasks

• Business Scenario for Preparing for an Event

• Example Process Flow for Preparing for an Event

• End-User Procedures for Preparing for an Event

Event Preparation Tasks  
A large number of interdependent tasks must be carried out during preparation for an event. In this chapter, these tasks
are grouped into the following categories:

• Track management tasks

• Activity management tasks

• Information preparation tasks

• Site preparation tasks

• Other tasks

The grouping and sequence of tasks presented in this chapter are arbitrary. The order in which end users and event
managers choose venues, vendors, partners, and speakers may vary by company and by event. You may be able to
conrm session information, locations, and schedules early in the event management process, or you may need to
adjust session characteristics shortly before and even during the event.

Note:  Because the order of event preparation tasks varies, it is recommended that you read this entire
chapter at the beginning of your event planning and preparation process. This information allows you to
approach event preparation with an appropriate sequence and schedule for an event.

Business Scenario for Preparing for an Event  
This scenario provides an example of a process ow performed by an event planner. Your company may follow a
dierent process ow according to its business requirements.
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Note:  This scenario continues the example from Business Scenarios for Dening an Event.

At this stage, the event planner has dened several tracks for the event. Now, the event planner completes the following
track management tasks:

• Identifying the sessions that make up each of these tracks and associates the sessions with their respective
track

• Associating related tracks with one another

Next, the event planner completes the following activity management tasks:

• Adding sta to events and sessions

• Assigning event sta members to various activities, and then monitoring the progress of those activities

Concurrent with the activity management tasks, the event planner completes the following information preparation
tasks:

• Adding sessions to events

• Conrming that there are no unintentional gaps or overlaps in the timing of sessions, by viewing session
schedules

• Adding speakers to sessions

• Publishing event information to a Web site

• Preparing event collaterals and adds specic collateral to the appropriate events and sessions

Next, the event planner completes the following site preparation tasks:

• Choosing a venue and enters room information

• Adding information about the equipment available in an event venue room

• Entering a location for a event venue.

◦ Because the location is a hotel where special rates are available for event aendees, the event planner
also associates the venue rate codes with the event.

◦ After entering the venue and its rate codes, she can enter venue billing information.

◦ After entering locations as event venues and having entered rooms associated with those locations, she
assigns specic rooms to individual sessions within the event.

These are just some of the many tasks that the event planner performs to prepare for an event. Other preparation tasks
include associating partner organizations and vendors with events or sessions, recording billing parameters for event
vendors, entering vendor discounts and other special rate codes, and aaching les to events.

Example Process Flow for Preparing for an Event  
The following image shows the recommended end-user procedures for event preparation in Siebel Events
Management.
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End-user procedures for event preparation include the following:

• Track Management Tasks

• Activity Management Tasks

• Preparing Sessions

• Venue Preparation Tasks

• Third-Party Tasks

• Inviting Contacts and Prospects

• Preparing Event Status Reports

End-User Procedures for Preparing for an Event  
This section discusses the tasks shown in the image in the preceding topic:

• Track Management Tasks

• Activity and Sta Management Tasks

• Preparing Sessions

• Venue Preparation Tasks
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• Third-Party Tasks

• Inviting Contacts and Prospects to an Event

• Preparing Event Status Reports

Track Management Tasks  
As described in Dening an Event, a track in Siebel Events Management is a featured topic or theme at an event. For
example, a biotech investment conference may establish three tracks: Genomics, Computers, and Pharmaceutical.

In Dening an Event, you created tracks and associated them with events. In this chapter, you complete the following
additional track-related tasks:

• Associating tracks with events and sessions. Identify a track that needs to have one or more sessions associated
with it, and then select those sessions from a list.

• Associating related tracks. Select a track, identify other tracks that are related to the selected track, and then
associate those related tracks with the selected track.

• Using the Tracks Calendar. Select an event and view all of the event’s tracks, and all of the sessions that make
up those tracks, side by side in a day-planner format.

• Associating contacts with a track. Create a list of the members in a given track by selecting contacts and
associating them with the track.

• Viewing track members. View a list of the contacts associated with a track.

Associating Tracks with Events and Sessions  
A track is typically comprised of one or more sessions. Therefore, after creating tracks and associating them with
events, you need to add one or more sessions to each track of the event.

Note:  Tracks can be related to one another.

The following procedure describes how to associate one or more sessions with a track.

To associate one or more sessions with a track

1. Navigate to the Site Map > Events > Tracks view.
2. In the Tracks list, select the track with which you want to associate the session or sessions.
3. Drill down on the Track Name.
4. Click the Related Events view tab.
5. In the Related Events list, create a new record.
6. To associate the track with a session within the event, in the Sessions list, create a new record.

Associating Related Tracks  
After creating tracks, you may nd it helpful to associate one or more related tracks to a given track.

The following procedure describes how to associate related tracks to events.

To associate related tracks

1. Navigate to the Site Map > Events > Tracks view.
2. In the Tracks list, select the track with which you want to associate.
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3. In the Track form, click the select buon in the Related Tracks eld.

After you have associated related tracks, the Related Tracks eld in the More Info form shows the name of one of the
related tracks.

To view all related tracks

• To view all of the related tracks, click the select buon in the Related Tracks eld.

Using the Track Calendar  
Using the Track Calendar, you can view the scheduled sessions for several tracks side by side in a day-planner format.

The following procedure describes how to use the Track Calendar.

To use the Track Calendar

1. Navigate to the Site Map > Events > Event Plans view.
2. From the visibility lter, select All Events.
3. In the All Events list, select and drill down on the Event Plan Name.
4. Click the Schedule view tab and then click Events.
5. In the Events list, drill down on the Event Name.
6. Click the Schedule view tab, and then click Track Calendar.

Alternatively, you can view track-related events, sessions, and members in the standard list and form views by choosing
the corresponding view tabs on the Tracks screen.

Associating Contacts with a Track  
The following procedure describes how to associate contacts with a track.

To associate contacts with a track

1. Navigate to the Site Map > Events > Tracks view.
2. In the Tracks list, select and drill down on the track with which you want to associate the contact.
3. Click the Members view tab.
4. In the Members list, create a new record, and complete the necessary elds.

Viewing Track Members  
The following procedure describes how to view the contact that are associated with a track, or track members.

To view track members

1. Navigate to the Site Map > Events > Tracks view.
2. In the Tracks list, select and drill down on the Track Name.
3. Click the Members view tab.

Activity and Sta Management Tasks  
An activity in Events Management is an action item, such as create collateral, that needs to be assigned and completed
prior to or during the event.
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In Dening an Event, you created activity templates (optional) and added activities to events. In this chapter, you
can follow-up by adding sta, which includes speakers, and assigning them to sessions and specic activities. After
activities are assigned, you can use your Siebel application to monitor the progress of activities.

Adding Sta to an Event or a Session  
The Sta view in the Events and Sessions screens provides a quick way to add information about individuals with event
responsibilities, including both employees and nonemployees, such as speakers, contractors, and vendors. While you
are adding sta, you can reference the Sta Calendar to view the availability of sta members and speakers.

It is a good business practice to add sta members as contacts and their organizations as accounts before you dene
the event sta. See Dening an Event for more information.

The following procedure describes how to add an existing employee or contact to an event.

To add a sta member to an event

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Events list, select and drill down on the Event Plan Name.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event to which you want to add a sta member.
5. Click the Resources view tab, and then click Sta.
6. In the Sta list for the event, create a new record, and complete the elds.

The following procedure describes how to add a sta member to an individual session. After a sta member is added,
the session appears on the sta member’s calendar.

To add a sta member to a session

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Events list, select and drill down on the Event Name.
3. Click the Schedule view tab, and then click Sessions.
4. In the Sessions list, select and drill down on the session name.
5. Click the Resources view tab, and then click Sta.
6. In the Sta list, create a new record, and complete the elds.

The following procedure describes how to view sta member and speaker availability.

To view sta availability

1. Navigate to the Site Map > Events > Event Plans view.
2. From the visibility lter, select All Events.
3. In the Events list, select and drill down on the event name for which you want to check sta availability.
4. Click the Schedule view tab, and then click Sta Calendar.

The Sta Calendar appears. All sta members, speakers, and contacts associated with an event or session
appear in the rst row of the calendar, and the time slots they are currently assigned are highlighted.

To view speaker availability

1. Navigate to the Site Map > Events > Event Plans view.
2. From the visibility lter, select All Events.
3. In the Events list, select and drill down on the event name for which you want to check sta availability.
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4. Click the Schedule view tab, and then click Speaker Availability.

Working with Event Activities  
Event activities are assigned to event team members—employees from the event-hosting organization who have
operational responsibilities for event planning, preparation, and implementation. Some activities may be more
appropriately assigned to people outside the event-hosting organization, such as vendor or venue representatives, or
organizational employees who are not on the event team. Together, event team members and other people with event
responsibilities are called event sta.

In order to assign an event to an event sta member using Siebel Events Management, the individual must be listed in
the Siebel System Person table.

Note:  An activity related to an event is assigned in the Events list, not in the Sessions list, even if it is for a
particular session within the event.

To assign an event activity

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the Event Name.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event for which you want to assign an activity.
5. Click the Plan view tab, and then click Activities.
6. In the Activities list, select and drill down on the Type eld.
7. Do one of the following:

◦ If you are assigning this activity to an employee of your organization, in the Employees eld of the
Activity form, click the select buon and select an employee.

◦ If you are assigning this activity to a contact outside your organization, in the Contacts eld of the
Activity form, click the select buon and select a contact.

Monitoring Progress on Event Activities  
You can use Siebel Events Management to update and monitor the progress of event activities. The view tab you use
to enter and view activity information depends on whether a given activity is part of an Activity Plan or a stand-alone
activity. The following procedure describes how to track activities.

To monitor progress of event activities

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Events list, select and drill down on the Event Plan Name.
3. Click the Schedule view tab.
4. In the Events list, select and drill down on the event for which you want to monitor activity progress.
5. Click the Plan view tab, and then click Activities.
6. Use one of the following methods to display activity details:

◦ For individual activities that may or may not belong to any Activity Plan, click the Activities link.

◦ For activities that you want to view in the context of an Activity Plan, click the Activity Plans link.

In each case, the display changes to include an Activities list that displays status information.
7. Select an activity to update and complete the necessary elds.
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Preparing Sessions  
Most business events involve the presentation of information. The amount and type of information presented varies
across events, as do the means of presentation. This section describes the processes for organizing the information for
presentation, choosing speakers for the event, and preparing collateral for distribution during the event.

This section provides material on how to prepare information for an event. Later sections of this chapter provide
information about venues, equipment, budgets, vendors, and other aspects of event preparation and implementation.

Basic Questions for Event Organizing  
In the course of organizing the information for an event, you may nd it useful to consider the following questions:

• What kind of audience do you hope to reach?

• What professional challenges do members of your audience face?

• How will the information help the audience meet its challenges?

• What is the size of the audience you intend to reach?

• What kind of presentation will your audience nd most useful and appealing?
For example, is your information appropriate for a lecture format, a hands-on workshop, a demonstration, and
so on?

• How long will it take to present the information?

• What equipment, such as computers, projectors, projection screens, slides, sound systems, and telephone or
network wiring, will you need for your presentation?

• What collateral item do you want audience members to take with them from the event?

• What resources (human and monetary) do you have for the event?

Having at least tentative answers to these questions helps you decide on the basic structure of an event, including
session type and length, speakers, and collateral.

Creating and Using Sessions  
During event preparation, you need to establish sessions within events, allowing aendees to choose which
presentations to aend. It is not mandatory to create sessions for an event with only one presentation, but creating
sessions allows an aendee to synchronize to their personal calendar. Additionally, you can associate a speaker with one
or more sessions, but not with events. You can also record feedback received on a session using the session’s Feedback
Form, as described in the next section of this topic.

Adding a Session to an Event
After you create an event plan, your Siebel application generates the events. You can add one or more sessions to an
event.

To add a session to an event
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event to which you want to add a session.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the Event Name.
5. Click the Schedule view tab and then click Sessions.
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6. In the Sessions list, create a new record.

The session record inherits the start date and end date from the event. Modify the Start and End elds as
necessary.

Note:  A session’s start and end times cannot be outside the range of its Event Plans start and end
times.

7. Drill down on the Session Name.
8. In the Session form, complete the necessary elds.
9. To associate a venue with the session, click the select buon in the Venue eld.

10. To associate a room with the session, click the select buon in the Room eld.

Note:  Repeat this procedure for each additional session you want to add to the event.

The following table describes some of the elds in the session form.

Field Comments

Session Fee
 

Any fee specic to the individual session, in addition to the event Registration Fee. This
eld may not be displayed in the Sessions list by default, but can be made visible by
using the Columns Displayed command.
 

Comments
 

A text eld for notes related to the session. Visible to administrators only. This eld may
not be displayed in the Sessions list by default, but it can be made visible by using the
Columns Displayed command.
 

Description
 

A description of the session. Information stored in this eld is visible to potential event
aendees who request detailed information about the session.
 

Dress Code
 

The recommended session aire. Values available by default include Business Casual,
Business Professional, Evening Dress, Sport, and Casual. This eld may not be displayed
in the Sessions list by default, but it can be made visible by using the Columns Displayed
command.
 
LOV Type: EVENT_DRESS_CODE
 

End
 

(Required) The date and time when the session ends. This eld defaults to the value of
the End eld for the event.
 

Fee Type
 

A description of the kind of fee noted for the session in the Additional Fee eld, if any.
Typical values include Donation, None, Registration, and Voluntary. This eld may
not be displayed in the Sessions list by default, but it can be made visible by using the
Columns Displayed command.
 

Feedback Form An optional eld for entering feedback received about the session.
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Field Comments

   

Format
 

The type of session. Values available by default include Keynote, Lecture, Panel, and so
on.
 
LOV Type: EVENT_FORMAT
 

Session Capacity
 

The maximum number of people who can aend the session. This eld may not be
displayed in the Sessions list by default, but can be made visible by using the Columns
Displayed command. If a value is specied for Room, this eld defaults to the capacity
of the room. If no value is specied for Room, this eld defaults to the Event Capacity
value for the event. For more information about entering room characteristics, see the
procedure titled To enter room information for a potential event venue in the Creating
Venues section.
 

Session Name
 

(Required) A name to identify the session.
 

Related Sessions
 

One or more other sessions that cover related information. Available values are all
sessions for all events. This eld may not be displayed in the Sessions list by default, but
can be made visible by using the Columns Displayed command.
 

Room
 

The specic room in the venue where the session is held. This eld may not be
displayed in the Sessions list by default, but can be made visible by using the Columns
Displayed command. Available values depend upon information entered under the
Rooms view tab of the Accounts screen. For more information about completing this
eld, see Step 10 of the procedure in this topic. For more information about entering
room characteristics, see the procedure titled To enter room information for a potential
event venue in the Creating Venues section.
 

Start
 

(Required) Date and time when the session starts.
 

Status
 

The status of the session. Values available by default include Planned, Launched,
 Completed, and Cancelled.
 
LOV Type: EVENT_STATUS_CODE
 

Venue
 

The location or facility where the session is held, which may or may not be related to
primary venue for the event. For more information about specifying a venue, see Step 9
of the procedure in this topic.
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Creating and Using Session Templates  
Sessions can also be generated automatically using Session Templates. This feature reduces the amount of data entry
required when seing up multiple events with similar session schedules.

To create a session template

1. Navigate to the Site Map > Marketing Templates > Session Templates view.
2. In the Session Templates list, create a new record, and complete the necessary elds.
3. In the lower list, create a new record, and complete the necessary elds.

Repeat this step for each session template created.

To use a session template

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event.
3. In the Details form, from the Session Template eld, click the select buon.
4. In the Sessions dialog box, select the session, and click OK.

Note:  You can only apply a Session Template to an event if no sessions already exist for that event.

You can add a group of sessions to an event using a session template. As application administrator, you must set up a
session template before you can associate it with an event, see Dening an Event.

Note:  You cannot apply a template to an event that already has existing sessions. If you want to change the
template or reapply it, you must delete all existing sessions, delete the template from the event, save the
record, and the reselect the template.

To associate a session template with an event

1. Navigate to the Site Map > Events > Event view.
2. In the Event list, select and drill down on the event.
3. Click the Schedule view tab, and then click Sessions.
4. In the Sessions list, create a new record.
5. In the Sessions list, click the select buon in the Session Template eld to select a session template.

To see the session associated with the event

• Click the Schedule view tab, and then click Sessions.

Note:  The Validate Session buon in the Sessions view can be used to check for schedule conicts across all
sessions in a single event. If one or more sessions have time values that overlap, an error message appears.
This buon is particularly useful when managing large events with many sequential sessions.

Viewing Session Schedules and Aendees  
This section describes procedures for viewing session schedules and aendees. You can view session schedules
using the Session Time Line. This method is helpful for conrming that there are no unintentional gaps or overlaps
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in the timing of sessions. You may also view a session’s list of aendees to determine the session’s popularity or for
informational purposes.

The following procedure describes how to view the Session Time Line.

To view the Session Time Line

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plan list, select and drill down on the event.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event for which you want to check session scheduling.
5. Click the Schedule view tab, and click Session Time Line.

The following procedure describes how to view only the available sessions for an overall event.

To view only the available sessions for an event

1. Navigate to the Site Map > Events > All Events view.
2. In the Events list, select and drill down on an event.
3. Click the Schedule view tab, and then click Sessions.
4. In the Sessions list, conrm that Status is set to Open.

The following procedure describes how to view a list of session aendees.

To view session aendees

1. Navigate to the Site Map > Events > Sessions view.
2. In the Sessions list, select and drill down on the session name for the session for which you want to view

aendees.
3. Click the Participants view tab, and then click Aendees.
4. To see a list of all companies registered for a session, click the Company Aendees link.

Note:  Registering a contact automatically registers that contact’s company.

Assigning Rooms to Sessions  
After you have designated one or more locations as event venues and have entered rooms associated with those
locations, you can assign specic rooms to individual sessions within the event. The following procedure describes how
to assign a room to a session.

To assign a room to a session

1. Navigate to the Site Map > Events > Sessions view.
2. In the Sessions list, select the session to which you want to assign a room.
3. In the Session form, review the current value in the Venue eld.

If necessary, select another venue that is associated with the selected event.
4. In the Room eld, select a room.

Researching and Organizing Speakers  
• Siebel Events Management provides you with the ability to designate one or more speakers per session.

Speakers must be members of the event sta, with speaker as their selected role. They can be employees of
the event-hosting organization, or they can be persons from outside organizations. They may or may not be
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registered as event aendees, according to your preference. Speaker information is always stored in relation to
a specic session, rather than to an event plan or event.

Adding Speakers to Sessions  
The following procedure describes how to add one or more speakers to a session within an event.

When adding a new session sta member with a role of speaker, or changing the role of an existing session sta
member to speaker, Siebel Events checks for overlapping speaking engagements for the sta member based on the
session start and end date. If the speaker is booked for more than one session at the same time, it displays an error
message and prevents the record from being saved.

To add speakers to a session

1. Navigate to the Site Map > Events > Sessions view.
2. In the Sessions list, select and drill down on the session for which you want to specify one or more speakers.
3. Click the Resources view tab, and then click Sta.
4. In the Sta list, create a new record, and complete the necessary elds.

◦ Be sure to select Speaker from the Session Role drop-down list to designate this person is a speaker for
the event.

◦ The Status eld indicates whether or not the speaker has been conrmed to speak at the event. It does
not indicate the speaker’s registration status as an event aendee.

◦ You can only select session sta members who were previously created in the parent event.

Viewing Session Tracks  
You can use the Session Track view to associate tracks to sessions. The following procedure describes how to view
tracks that are associated with a specic session.

To view tracks associated with a specic session

1. Navigate to the Session Tracks view.

The Tracks list displays all the tracks that the session belongs to.
2. Click the Tracks Name to sort the list.

Publishing Event Information to a Web Site  
If your company has purchased the optional Siebel Events for Finance module, you can prepare your event information
for Web site publication.

The combination of Siebel Events Management seings aect whether or not information in the Events and Sessions
screens is visible to prospective event aendees on the Web site. These seings are as follows:

• The status of the event

• The start date of the event

• The type of event

• The Registration Status of the prospective aendee

• The Registration status of the company of the prospective aendee
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• The External ag seing

Both the Event and Session Details forms have check boxes labeled Display on Website. These check boxes
default to true. You can use Display on Website check boxes to designate internal events and sessions that
should not be published to the Web site or events or sessions for which only an administrator can register
aendees:

◦ If you clear an event’s Display on Website check box, the event and its sessions are not displayed on the
Web site, regardless of the status, date, or type.

◦ If you clear a session’s Display on Website check box, the session is not displayed on the Web site.

The following procedures describe how to choose seings for the visibility you want.

To make event information visible to all
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select an event.
3. Set the Status eld to Launched.
4. Set the Start eld to a date in the future or to today’s date.
5. Verify that Type is not set to Restricted.
6. Verify that the Display on Website check box is selected.

To make event information visible to invitees and administrators
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select an event.
3. Set the Status eld to Launched.
4. Set the Start eld to a date in the future or to today’s date.
5. Set Type to Restricted.

Note:  Events of type Restricted are not displayed in the customer site except to aendees who have
been explicitly invited to the event. The aendee can view open invitations from the home page by
clicking the View My Open Invitations link and can then accept an invitation by registering for the
event.

To make event information visible to invited company employees (for Finance
customers only)

1. Navigate to the Site Map > Events > All Events view.
2. In the Events list, make sure the External column check box is selected.
3. In the Event form, set the Status eld to Launched.
4. Set the Start Date eld to a date in the future or to today’s date.
5. Make sure the Event Type eld is not set to Restricted.

To make event information visible to internal employees
1. Navigate to the Site Map > Events > All Events view.
2. In the Events list, make sure the External column check box is not selected.
3. In the Event form, set the Status eld to Launched or Planned.
4. Set the Start Date eld to a date in the future or to today’s date.
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To make event information visible to administrators only
• Set Status to any value except Launched, or set Start to a date earlier than today’s date.

If an event is visible, then the sessions related to it can be visible or not based on the value in the Status eld in
the session itself. As with events, a status of Launched allows all users to see the session information.

Creating and Using Web Banners  
Event managers can use the Web banner functionality to publish rich HTML content describing a particular event on
the Events Web site. HTML templates can be created in Web tools such as Adobe GoLive or Microsoft Front Page, and
then stored in the Siebel le system for use as an event Web banner. The Web banner can also be edited in Siebel Events
Management within a WYSIWYG environment, without requiring knowledge of HTML tags. This capability allows added
control over the look and design of the event detail view by business users.

To create a Web banner

1. Develop your Web banner in an external editor or notepad to create a blank HTML le.
2. Navigate to the Site Map > Events > Web Banner Templates view.
3. In the Web Banner Templates list, create a new record, and complete the necessary elds.

To use a Web banner

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event.
3. Click the Resources view tab and then click Web Banner.
4. In the Web Banner form, create a new record, and in the Template Name eld, click the select buon.
5. From the Pick Event Template dialog box, select the template, and click OK.
6. In the Web Banner form, click Save Template.

Note:  Graphics and other les referenced by the HTML must be accessible for the Web server that is hosting
the Siebel Events Web site.

Using Siebel Microsites  
Similar to Event Web Banners, Microsites can be used to control the look and feel of the event detail view in the
registration Web portal. Microsites, however, oer more capabilities in the area of content management. Event
managers can use Microsites instead of Web banners if they require these capabilities.

Many companies have multiple content managers whose responsibilities include adding and modifying data on Web
pages. The layout and maintenance of data and hypertext links needs to be done as eciently as possible, without
requiring IT resources. The Microsite Management module is designed to simplify creation and maintenance of Web
pages. Everything from site organization and creation of new pages through to editing text and graphics is carried out
from the Microsite Management screen.

To use a Microsite with an event

1. Navigate to the Site Map > Events > Event > Details view.
2. In the Events form, copy the name in the Event Name eld.

You will use this information when creating a Microsite page.
3. Navigate to the Site Map > Administration - Microsite > Page Administration view.
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4. In the Page Administration, click Create New Page.

The Create New Page dialog box appears.
5. In the Parent Page eld, click the multiple select buon to select the Siebel Events Information.
6. In the Default View eld, click the multiple select buon to select the eEvents Event Detail Microsite View.
7. In the Title eld, enter or paste the name of the Event that you want the Microsite to be associated with.

Note:  The text in this eld has to match the name of the event exactly.

8. Click OK.
9. Click the Page Title link of the new page.

10. In the Page Administration form, add the HTML-based content to the Microsite page to be displayed in the
event registration Web portal.

Note:  You can also have a single Microsite page for all Events within an Event Plan. When creating the
Microsite page, use the Event Plan name. Do not create a Microsite for the Events within the Event Plan. The
events Web portal rst checks for event-level microsite pages to display, then checks for Event Plan-level
Microsite pages to display, and nally checks for Web banners to display.

Preparing Collateral  
Another aspect of organizing information for an event is preparing literature such as brochures, white papers,
presentation handouts, trade show exhibit maps, and so on. Collectively, such literature is known as collateral. Collateral
can be a Web page URL or a le.

You can manage collateral preparation using activities in Siebel Events Management. After collateral is prepared, those
electronic les, as well as vendor and venue contracts, can be stored in the Siebel Events Management.

Adding Collateral to an Event or a Session
You can use Siebel Events Management to store collateral for an event or for a specic session.

To add a collateral item to an event or a session

1. Navigate to the Site Map > Events > Events or Sessions view.
2. In the Events or Sessions list, select the event or session with which you want to associate collateral.
3. Click the Resources view tab, and then click Collateral.
4. In the Collateral list, create a new record.
5. Complete the necessary elds.
6. To aach a le to the record, click the select buon in the File eld to display the Add Aachment dialog box,

and then follow these instructions:

a. Click Browse to display a Choose File dialog box.
b. Use standard Windows techniques to select the le you want to designate as collateral, and then click

Open.

The Choose File dialog box closes, and the name of the selected le appears in the File Name eld of the
Add Aachment dialog box.

c. Click Add.

The Add Aachment dialog box closes, and the name of the selected le appears in the File eld of the
Collateral form in the main window.
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Venue Preparation Tasks  
Event management requires site preparation. This section provides information about preparing the event site.
Preparing the event site requires several tasks, including researching and choosing a venue, assigning rooms within a
venue to individual sessions, arranging for needed materials, and seing up the site just before the event begins.

Researching and Choosing a Venue  
A venue is a physical facility where an event may be held, such as a conference center or hotel. In Siebel Events
Management, you can store information about possible venues ahead of time, including their rental rates, and later
choose which venue or venues to associate with an event. An event can be associated with multiple venues. A session
within an event can be associated with only one venue.

During or after an event, you can enter review comments about how well each selected venue functioned for your
event. These comments can be useful for planning future events.

The following procedure lets you record information about the equipment that is available in a potential room for an
event.

To enter a location for an event venue

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you want to enter a venue.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Resources view tab, and then click Venues.
6. In the Venues list, create a new record.

Note:  You can also select a venue on the Details form’s Venue eld on both Events and Sessions lists.

After you enter a location as an event venue, you can specify venue rate codes for an event. If the venue is a hotel where
event aendees stay, or—if you do business with the venue regularly—you may have negotiated special rates for hotel
rooms, conference rooms, and so on. Special rates may be associated with codes that aendees or event managers
mention to the venue representative. The following procedure describes how to store information about venue rate
codes.

To associate venue rate codes with an event

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you want to record venue rate codes.
3. Click the Schedule view tab and then click Events.
4. In the Event list, select and drill down on the event.
5. Click the Resources view tab and then click Venues.
6. In the Venues list, select the venue for which you want to enter information.
7. Scroll down to the Billings list and select Rate Codes from the drop-down list.
8. In the Rate Code list, create a new record.

The following table describes some elds in the Rate Code list.
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Field Comments

Code
 

The code to mention to the venue representative in order to receive the special rate,

 such as SEBL123.

 

Comments
 

A text eld to record other information, such as Customer must mention rate
code at time of check-in.
 

Name
 

A name of your own choosing, to identify the rate code, such as Marrio Siebel
User Week Promotion.

 

Type
 

A description of the special rate, such as 20% discount o lodging rates.

 

At any time during the event management process, you can enter review comments regarding the venues you are
working with. For example, you might want to note the name of a particularly helpful venue representative, or mention
that a particular work crew might need closer supervision if the venue is reused for a future event. For more information
about entering reviews, see Entering Venue and Vendor Performance Reviews.

Entering Venue Expense and Billing Information  
After you have entered a location as an event venue and optionally specied venue rate codes for an event, you can
enter venue expense and billing information. Expense records created at the venue level roll up to the event, with a Cost
Type = Venue. Venue billing records are a detailed breakdown of a single venue expense record, indicating room and
room rate information.

To enter venue expense information

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event plan for which you want to enter venue expense

information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Resources view tab, and then click Venues.
6. In the Venues list, select the venue for which you want to enter expense information.
7. Scroll down to the Expense list, and create a new record.
8. In the Expense list, complete the necessary elds.

To enter venue billing information

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you want to enter billing information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Resources view tab, and then click Venues.
6. In the Venues list, select the venue for which you want to enter billing information.
7. Scroll down to the Expense list and select the expense for which you want to enter billing information.
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Note:  An event must have a venue before you can add a venue to its session. Rooms can only be
selected after a venue for the session is selected.

8. Scroll down to the Billing subview, and create a new record.

The following table describes some elds in the Billing list.

Field Comments

Room
 

A required eld that displays the rooms available within the venue. You can select a
room from the dialog box.
 

Billing Basis
 

A value for the interval at which the room use is charged. The drop-down list displays
typical values of Per Person, Per Item, Hourly, Daily, Weekly, and so forth.
 

Billing Rate
 

The negotiated rate from the account screen for the venue. You can edit the billing rate
amount.
 

Quantity
 

A value for the number of rooms within the venue.
 

Flat Fee
 

The at charge for the room. For example, there may be a setup or booking charge that
is not reected in the Billing Basis or Billing Rate elds.
 

Total Cost
 

The actual room cost calculated by multiplying the billing rate times the quantity plus
the at fee. {(Rate*Quantity)+Flat Fee}
 

Comments
 

A text eld for other information associated with the billing record.
 

After you create one or more billing records, you can update the actual cost of the parent expense record to reect the
total cost of the billing records.

To update the actual cost of the expense record

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event plan for which you want to update venue expense

information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Resources view tab, and then click Venues.
6. In the Venues list, select the venue for which you want to update expense information.
7. Scroll down to the Expense list, and click Update Actual Cost.
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Seing Up at the Venue  
When you have chosen a venue, assigned rooms to sessions, and arranged for materials, most of the remaining
preparation activities take place onsite, within a few hours of the start of the event. Onsite activities may vary across
events, but the following list includes some typical setup activities:

• Seing up chairs

• Seing up and testing computers

• Seing up and testing audiovisual equipment

• Seing up collateral displays

• Seing up a check-in area for registered aendees

• Seing up a registration area for walk-in aendees

Siebel Events Management does not provide special screens, lists, or forms for onsite setup tasks. Use the Activities list
to plan and track these actions, as described in Activity and Sta Management Tasks.

Third-Party Tasks  
This section describes how to use Siebel Events Management to collaborate with partner organizations, work with event
vendors, aach les to an event, invite potential aendees, and generate event status reports.

Collaborating with Partner Organizations  
When your organization prepares for an event, you may nd it useful to collaborate with a partner organization that
may benet from sponsoring an aspect of the event. A partner may sponsor the event through nancial support, or
may provide services, equipment, speakers, and so on. A partner organization may be associated with an event or an
individual session. Siebel Events Management provides lists and forms to help you keep track of partner commitments.

The following procedure describes how to associate a partner organization with an event. This procedure assumes that
the partner organization has already been added through the Partners screen in your Siebel application.

To associate a partner organization with an event

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you wish to associate a partner organization.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, drill down on the event name.
5. Click the Participants view tab, and then click Partners.
6. In the Partners list, create a new record, and complete the elds.

To associate a partner organization with a session

1. Navigate to the Site Map > Sessions view.
2. In the Sessions list, select and drill down on the session for which you wish to associate a partner organization.
3. Click the Participants view tab, and then click Partners.
4. In the Partners list, create a new record, and complete the elds.

For sessions, by default, the Role, Value, and Partner Status elds display the values for the corresponding
partner record for the event. You can change these values at the session level without aecting the partnership
data at the event level.
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The following table describes some elds in the Partners list.

Field Comments

Role
 

The role of the partner organization. Typical values include Exhibitor, Sponsor, Co-Host,
Advertiser, Partner, Strategic Partner, Premier Partner, Base Partner, Gold Sponsor,
Silver Sponsor, and Bronze Sponsor.
 
LOV Type: EVENT_PARTNER_ROLE
 

Partner Status
 

The status of arrangements with the partner organization. Typical values include
Oered, Requested, Paid, Fullled, and Pending. Oered means that the partner
organization has oered to be a partner. Requested means that the event-hosting
organization has asked the partner organization for a partnership.
 

Value
 

The monetary value of the partner organization’s commitment.
 

Researching and Hiring Vendors  
Previous sections describe event-related goods and services that are provided either by your own organization or by
the venue or venues where the event is held. One additional category of providers remains to be discussed—good and
services vendors who are neither in your own organization nor aliated with an event venue.

In Siebel Events Management, the procedures for working with vendors are quite similar to those for venues, except that
the goods or services vendors provide are not as closely related to specic physical locations.

As with venues, a vendor can be associated with an event or a session. To associate a vendor with one or more sessions,
you must rst associate it with the event.

In preparation for working with vendor data, you should enter possible vendors as accounts. The Accounts screen allows
you to enter vendors, vendor addresses, and vendor contacts before you set up an event. When entering vendors as
accounts, choose Vendor in the Account Type eld of the Vendor form. For more information, see Dening an Event.

The following procedure describes how to associate a vendor with an event or session. Prior to associating a vendor
with a session, you should have already associated the vendor with the event.

To associate a vendor with an event
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you want to associate a vendor.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, drill down on the events name.
5. Click the Participants view tab, and then click Vendors.
6. In the Vendors list, create a new record.

To associate a vendor with a session
1. Navigate to the Site Map > Sessions view.
2. In the Session list, select and drill down on the session for which you want to associate a vendor.
3. Click the Participants view tab, and then click Vendors.
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4. In the Vendors list, create a new record.

After you have associated a vendor with an event, you can record the billing parameters the vendor uses, any discounts
or special rates you negotiate, and optional reviews of the vendor’s performance for the event.

The following procedure describes how to record the billing parameters for an event vendor.

To record billing expense information for a vendor

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you wish to record the billing parameters.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Participants view tab, and then lick Vendors.
6. In the Vendors list, select the vendor for which you want to enter billing parameters.
7. Scroll down to the Billings subview and in the Billing list, create a new record.

The following table describes some elds in the Billing list.

Field Comments

Flat Fee
 

The currency eld for any at fee to be charged instead of or in addition to the billing
rate.
 

Qty
 

The actual quantity of basis units used by the event.
 

Rate
 

The currency eld for vendor’s rate per basis unit.
 

Service Type
 

The type of responsibility the vendor has for the event.
 

Total Cost
 

A result of the automatic calculation based on Rate, Qty, and Flat Fee, when you save
the record.
 

Units
 

The basis of the vendor’s rate. Typical values include Per Person, Per Item, Hourly, Daily,
 Weekly, Monthly.
 

Note:  Billing records created at the Vendor level roll up to the event as expense records, with a Cost
Type = Vendor.

The following procedure describes how to enter any discounts or special rates you have negotiated with the vendor.

To enter vendor discounts or other special rate codes

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you wish to enter vendor discount

information.
3. Click the Schedule view tab, and then click Events.
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4. In the Events list, select and drill down on the event.
5. Click the Participants view tab, and then click Vendors.

Billing, Rate Code, and Reviews subviews appear after the Vendors list.
6. Select the vendor for which you want to specify rate code information.
7. In the Billing subview, select Rate Code from the drop-down list.
8. In the Rate Codes list, create a new record.

The following table describes some elds in the Rate Codes list.

Field Comments

Name
 

A name to designate the discount or special rate.
 

Type
 

A description of the discount amount or special rate.
 

Adjacent to the Billing and Rate Code subviews, there is a subview for review information about the selected vendor. For
information about entering a vendor review, see Entering Venue and Vendor Performance Reviews.

Aaching Files  
In the process of preparing for your event, you may want to store certain le aachments for an event, such as contracts
with vendors or oor plans of exhibit halls.

Note:  In this release, event aachments can be stored and retrieved only by users who have access to the
administration screens in Siebel Events Management.

The following procedure describes how to aach a le to event information. This procedure is meant for event
aachments only. Documents that are used for multiple events should be stored as collateral. For more information
about storing collateral items, see Preparing Collateral.

To aach a le to an event

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you wish to aach a le.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select the event.
5. Click the Plan view tab, and then click Documents.
6. In the Documents list, create a new record.

For URL aachments, a link appears in the Aachment Name eld to take you to the Web site. For le
aachments, information about the selected le is now displayed in the Aachment Name, Size, Type, and
Modied elds.
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Inviting Contacts and Prospects to an Event  
This section provides an introduction to inviting prospective aendees. However, prior to inviting aendees, it is
recommended that you read Self-Registering to Aend an Event.

You can invite prospective aendees to an event by adding an individual aendee or a list of aendees for the event and
seing the Registration Status to Invited, which triggers an automatic email to the invitee or invitees. If the registration
status is set to Invited when an invitee logs in to your Siebel Events Web site, then the invitee sees the event listed when
he or she clicks the View My Open Invitations link on the home page.

You can also register prospective aendees directly for events and sessions. For information about registration,
including important descriptions of registration workow rules, see Self-Registering to Aend an Event.

For nancial services customer, if an aendee is registered at the event or session level, an autoregistration process is
triggered that registers the aendee’s employing company for the event with a registration status of Restricted Invite.

An aendee’s registration status eects whether the aendee can:

• See the event listed on the Events home page

• View the event details

• See nothing at all

If the registration status is set to Invited when an invitee logs in to your Siebel Events Web site, then the invitee sees the
event listed on the Events home page. If an account’s registration status is set to Invited, all employees of that company
see that event listed, and all employees can view the event details.

Inviting a Contact to an Event  
The following procedures describes how to invite a contact to an event.

Inviting a contact

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which you want to invite the contact.
3. Click the Participants view tab, and then click Registration.
4. In the Registration list, click Add Aendee.
5. In the Registration list, click Invite.

Note:  After the aendee is invited, you can view the aendee by clicking the Participants view tab.

Inviting a List of Contacts to an Event  
The following procedures describes how to invite a group of people to an event.

To invite a list of contacts

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the Event.
3. Click the Participants view tab, and then click Registration.
4. In the Registration list, click Add List.
5. In the Add Aendee List dialog box, select a list or create a new record, and then click OK.
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6. In the Registration list, click Invite all.

Note:  After the list is invited, you can view the invited aendees by clicking the Participants view tab.

Inviting Contacts and Prospects to an Event Using Siebel Marketing  
Customers who have purchased the required license options for Siebel Marketing, can invite contacts or prospects to
an event through an email marketing campaign. This involves creating a target segment or list of invitees, associating
a related event to a campaign and email oer, and executing the campaign to send out email invitations with an
embedded Event Web site URL. During execution, campaigns that have a related event automatically add the campaign
contacts or prospects to the event as aendees, with a Registration Status of Invited.

Unlike contacts, prospects are not required to log in to the Events Web site in order to register for an event. This method
for inviting prospects may be particularly useful in the case where third-party prospect lists are imported and not
promoted to contacts. Invited prospects are shown in the Events screen, Aendees subview. For more information on
Email Oers and Campaigns, see  Siebel Marketing User Guide .

After you invite the aendees, you can register them using the Events screen, Participants view. For more information
on how to register invited aendees, see Registering for an Event.

Entering and Tracking Travel Arrangements  
As aendees, speakers, and sta are conrmed, travel arrangements for each can be entered using the Participants
view tab. Also, multiple travelers, such as the speakers and sta for a multicity event, can be added to a single travel
arrangement.

Travel arrangements can be associated with all three levels of events—event plans, events, and sessions. For example,
a sta member may involved in a one-day event, in another city, of a week-long event. In this case, you can enter the
travel arrangements using the Events screen.

The following procedures involve travel arrangements for an event using the Events screen. You may nd it helpful to
reference the Calendar screen when scheduling event travel arrangements.

To enter travel arrangements

1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which you wish to enter travel arrangements.
3. Click the Participants view tab, and then click Travel.
4. In the Travel list, create a new record.
5. In the Travel Type eld, select a travel type from the drop-down list.

After you enter the travel type and move to another eld, the Travel Detail form refreshes and show elds
specic to the travel type you selected.

6. Fill in the remaining elds as needed.
7. Scroll down to the Air Travel Detail form, and ll in the elds as needed.
8. In the Aendees list, create a new record to add aendees to this travel arrangement.

Note:  For Finance customers, you can only add people registered for the event, not sta or
employees.

9. In the Aendees list, select the event aendees (press CTRL to select multiple aendees), and then click OK.

The Company Name eld is autopopulated. The Conrmation Number and Comments elds are optional.
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You can track travel arrangements using the All Travel list in the Travel view. The All Travel list is a read-only list and is
for informational viewing purposes only.

To track travel arrangements

1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event you wish to track.
3. Click the Participants view tab, and then click All Travel.

A summary of all travel arrangements for the event, including travel arrangements associated with events and
sessions, is displayed.

Preparing Event Status Reports  
Throughout the event preparations, you may want to use the precongured event status report to summarize current
information about registrations, budget, and revenue. The following procedure describes how to produce an event
status report.

The event status report uses the Registration Status eld to summarize response rate and interest levels among the
invitees.

Note:  Report parameters must be congured before you can select the Reports view. For information about
seing report parameters, see  Siebel Reports Guide .

To prepare an event status (snapshot) report
1. Navigate to the Site Map > Events > Event view.
2. In the Event Plans list, select and drill down on the event for which you wish to prepare a report.
3. Click the Reports buon.
4. In the Select a Report eld, select Event Snapshot.

The event snapshot report appears in a new window.

Note:  Reports are currently not available at the Session or Event Plan level.
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6  Registering for an Event

Registering for an Event  
This chapter describes the dierent approaches to registration, such as registering an individual contact, an individual
account, a list of contacts, or inviting prospected through Siebel Marketing.

This chapter includes the following topics:

• Example Process Flow for Registering for an Event

• Registering One or More Aendees

• Tracking Guests of Aendees

• Registering a Group of Aendees for a Session

• Registering an Account for Financial-Services Customers

• End-User Procedures for Self-Registering for an Event

• Conguring the Register Buon

• Conguring Quantity Selection in Registration

• Customizing Siebel Events Home Page Applets

Example Process Flow for Registering for an Event  
The following image shows the recommended administrator and end-user procedures for registering for an event in
Siebel Events Management.
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Administrator procedures for event registration include the following:

• Registering an Account (for Finance customers)

• Registering Aendees

• Aendee Session Registration

• Account Session Registration (for Finance customers)

• Managing Registration Status

End-user procedures for event registration include the following:

• Registering to Use the Web Site

• Self-Registering to Aend an Event

Registering One or More Aendees  
In Siebel Events Management, you can build lists of aendees and register all of the contacts on the list. This feature is
available for event plans and events, but not for sessions. This capability is particularly useful when the same group of
aendees needs to be registered for multiple events of an event plan.

Registering a List of Aendees for an Event  
The list of aendees that you register is built from within the Event Plans or Events screen, as a part of the aendee
registration process.

The following procedure describes how to register a list of aendees.
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To register an aendee list for an event
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the Event Name.
3. Click the Participants view tab, and then click Registration.
4. In the Registration list, click Add List.
5. In the Add Aendee List dialog box, select a list or create a new record, and then click OK.
6. Click Register All to invite the aendees.

After the list is registered, you can view the registered aendees using the Participants view tab.

Creating Aendee Lists  
You can send out invitations to aendees who came to a specic event or session, or invite specic types of aendees to
an event. For example, you might want to invite registered C-level executives to a special private event. You can create
lists of aendees for this purpose, to be used for registration in other events. Creating an aendee list is dierent from
creating a list of contacts, because you are working with a subset of aendees within a specic event or session.

When the list is created, note that the default format for the list name is “[Event or Session Name]-[Date][Time]. The
name of the list can be changed.

To create a list of aendees
1. Navigate to the appropriate view:

◦ For events, navigate to the Site Map > Events > Event > Aendees view.

◦ For sessions, navigate to the Site Map > Events > Sessions > Aendees view.

2. (Optional) Query for the aendees by the criteria you want to search on, that is Status=Conrmed or Job
Title=C.

3. In the Aendees list, select one or more aendees.
4. Click Create New List.

A message conrms that the list has been saved.
5. Specify the name of the list.

Registering an Aendee  
There are two ways a potential aendee can be registered to aend an event:

• Self-registration. The potential aendee can use a standard Web browser to visit the Siebel Events Web site and
register for an event listed there. For more information on registering for an event, see End-User Procedures for
Self-Registering for an Event.

• Registration by an administrator. A member of your own company can use administrative screens to register
the potential aendee for an event. For more information on registering an aendee for an event or session,
see Registering an Aendee for an Event.

Although self-registration through the Events Web site home page is recommended over registration by an
administrator, there may be times when it is convenient for an employee of the presenting organization to register an
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aendee for an event or a session, rather than requiring the aendee to self-register. This option is particularly useful
for registration at events that allow registration at the door, because employees with access to administration screens
can register walk-in aendees upon their arrival.

Self-registration is preferred because it uses LDAP security systems and authenticates a user’s username and password.
Registration from administrative screens may require site-specic steps to create matching user accounts for both your
Siebel application and the security system.

Note:  Not all event aendees must be customers or clients of your company. If you wish to track the
aendance of event sta, speakers, personnel from partner organizations, and so on, you may do so by
registering them as aendees.

Registering an Aendee for an Event  
The following procedure describes how you can register an aendee for an event or session directly from the
administrative screens. Aendees who are registered for events and sessions are automatically registered for their
parent events.

Note:  Aendees must be registered for an event before they can register for a session.

If an aendee registers for an event prior to the aendee’s account being registered for the event, the account is
automatically registered for the event plan and for the event. The event registration status is set to Restricted Invite.

Siebel Events automatically adds aendees who are not in the system as contacts to the contacts table after the you
complete the following registration procedure.

To register an aendee for an event
1. Navigate to the Site Map > Events > Event view.
2. In the Event Name list, select and drill down on the event for which you want to register an aendee.
3. Click the Participants view tab, and then click Registration.
4. In the Registration list, create a new aendee record.

◦ When a contact record is added in the registration list, its status is blank. The administrator can decide
whether to invite the contact.

◦ If the event does not have a registration fee, and if there is space available, the value of the Registration
Status should be Conrmed.

◦ If the registration status is automatically set to Waitlisted, then all seats are taken for the event or session.
If you want, you can continue registering additional aendees, but they are placed on the waiting list.

◦ If there is a fee for aending the event or session, and if there are seats available, the registration status is
Pending until the fee payment is submied in the next step in this procedure.

◦ After an account or contact is registered, it disappears from the Registration tab. The record is
transferred to the Aendees or All Aendees view, as appropriate. There is no data loss.

5. If this is a fee-based event, to step through the Shopping Cart and complete the purchase transaction with a
credit card, click Finish.

Note:  The Finish buon is available only if there is a fee.
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For Financial-services customers, the following table describes some elds in the Registration list.

Field Comments

Aendee Type
 

A general category representing the type of aendee. Typical values include Standard,
Aendee, Premium, VIP, Guest, Sta-Internal, Sta-External, Sta-VIP, Speaker, and
Speaker-VIP.
 
LOV Type: PARTICIPANT_STATUS
 

Group
 

A text eld for noting how this aendee is grouped with others. For example, one could
group aendees by table number for a mealtime event with xed seating.
 

Registered
 

The autogenerated date and time when the registration record is created. This eld is
not displayed by default in the Registration list, but can be added using the Columns
Displayed menu command.
 

Registration #
 

A unique, read-only, alphanumeric code that is autogenerated for the current
registration.
 

Registration Status
 

The status of the potential aendee’s registration. By default, available values include
Invited, Pending, Conrmed, and so on. When this seing has a value of Invited, the
event appears in the invitee’s My Invitations list on the Web site.
 
LOV Type: EVENT_REG_STATUS
 

The following table describes some typical Registration Status values.

Value Comments

Aended
 

Indicates that the potential aendee actually aended the event plan, event, or session.
Enter this value only after aendance has occurred.
 

Cancelled
 

Indicates that the potential aendee reversed their previous acceptance before the
cancellation deadline.
 

Conrmed
 

Indicates the participant completed the registration process.
 

Invited
 

Causes the event to appear in the invitee’s My Invitations list on the Web site.
 

No-show
 

Indicates the potential aendee was conrmed for the event, but did not aend the
event.
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Value Comments

 

Pending
 

Indicates the potential aendee has been invited but has not yet responded to the
invitation.
 

Walk-In
 

Indicates the aendee was not conrmed prior to the event, but did aend the event.
 

Registering Previously Invited Aendees to an Event  
An event may have one or more previously invited aendees, that need to be either conrmed or canceled as part of the
registration process. Aendees can self-register for an event that they are invited to, or an administrator can manually
conrm their registration.

To conrm or cancel the registration of a previously invited aendee
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event.
3. Click the Participant view tab, and then click Aendees.
4. In the Aendees list, click Query.
5. In the Registration Status eld, selected Invited, and click Go.

Note:  This eld shows Aendees who were previously invited.

6. Select the desired Aendee.
7. Click Conrm Registration or Cancel Registration to conrm or cancel this aendee’s registration.

Note:  The Aendee’s registration status changes accordingly. If this is a fee-based event, the
Shopping Cart appears when you select Conrm Registration.

Tracking Guests of Aendees  
Certain types of events permit aendees to bring guests. You can track guests for each registered aendee.

To specify that an aendee is a guest of another aendee
1. Navigate to the Site Map > Events > Event > Aendees view.
2. In the Aendees list, select the aendee record for the guest you want to specify as a guest of another

aendee.
3. In the Guest Of eld, click the multiple select buon to select the primary aendee.
4. Select the primary aendee, and then click OK.
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Note:  Only registered aendees appear for selection in the Guest Of eld.

Registering a Group of Aendees for a Session  
Sometimes, you may want to select a group of aendees to register for a session. Instead of registering each aendee
for the session individually, you can select multiple aendees to register for the session simultaneously.

To register a group of aendees for a session
1. Navigate to the Site Map > Events > Sessions > Registration view.
2. In the Registration list, click Add Aendees.
3. Select multiple aendees by pressing the CTRL or SHIFT key.
4. When you have selected all the aendees you want, click OK to add the aendees to the Registration list.
5. Click Register All.

Registering an Account for Financial-Services Customers
 
You can control which contacts can register for an event by registering an account and issuing invitations to specic
contacts associated with that account. Control of which contacts can register is determined by the registration status
value you select for the account.

The status value that aects account contacts’ (namely, company employees) ability to register is Invited. If the account
is registered for the event with a status of Invited, all contacts associated with the account can view the event listing on
the Events Web site home page and register for the event.

After an account is registered, the contacts themselves are not registered until action is taken to register individual
aendees or aendee lists. An individual aendee can be registered by yourself, the administrator, as described in
Registering an Aendee, or by the contact, as described in End-User Procedures for Self-Registering for an Event. A
contact list can only be registered by an administrator, as described in Registering One or More Aendees.

Note:  An individual aendee can still be invited directly to an event, whether or not that aendee’s account is
registered for the event. If an aendee registers for an event prior to the aendee’s account being registered
for the event, Siebel Events automatically registers the account for the event with a status of Restricted Invite.

Additional considerations for registering accounts are as follows:

• An account can be registered for an event, which automatically registers the account for the event.

• An account can be registered directly at the session level.

The following procedure describes how to register an account for an event.
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To register an account for an event
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event.
3. Click the Participants view tab, and then click Registration.
4. To register an account, click the Add Aendee buon in the Account Registration list.

The buon appears as available when you set the event Status to Launched.
5. Choose a registration status according to the visibility and registration options you want to make available to

account contacts.

If you want contacts associated with the account to be able to view and register for the event, choose Invited in
the Registration Status eld.

The following table describes typical Registration Status values.

Field Comments

Aended
 

Indicates the potential aendee actually aended the event plan, event, or session.
Enter this value only after aendance has occurred.
 

Cancelled
 

Indicates the potential aendee reversed their previous acceptance before the
cancellation deadline.
 

Conrmed
 

Indicates the participant completed the registration process.
 

Invited
 

Causes the event to appear in the invitee’s My Invitations list on the Web site.
 

No-show
 

Indicates the potential aendee was conrmed for the event, but did not aend the
event.
 

Pending
 

Indicates the potential aendee has been invited, but has not responded.
 

Walk-In
 

Indicates the aendee was not conrmed prior to the event, but did aend the event.
 

Registration Workow  
Siebel Events Management uses workow rules to eliminate redundant data entry during the registration process. The
following image illustrates the process for aendee event registration as follows:

• Registering an aendee for the event will automatically register the account for the event if the aendee is
associated to an account.

• Event Plan aligns with Roll-up, Event for (Step 1) Register for Event and Session (Step 2) Register for Session.
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• Account (Finance users only) lists Roll-up, Register for Event and Auto Registered. Roll-up is connected with a
one-way arrow to Register for Event. Aendee (Register for Session) is connect with a one-way arrow to Auto
Registered.

• If an account has been manually registered for an event then a new contact registration with the same
associated account will not impact the existing account registration.

Note:  The term Pre-Registered in the preceding workow indicates that the aendee has already been
registered.

Aendees cannot register for a session until they have rst registered for an event. Aendee records are rolled up to the
Event Plan level for reporting purposes only.

Session Registration and Activity Records  
As part of session management, the workow performs the following tasks:

• When a session is rst created, the workow creates an Activity record to track that session, and sets the
Activity Type = Session.

• When an event manager registers a person for the session, the workow adds the person’s name to the list
associated with the Activity record.

These workow activities are generated so that all internal employees who are registered for a session can see that
session displayed on their personal calendar within the Siebel application (shown in the Calendar screen). In addition,
for all external contacts who are registered for a session, an Activity of Type = Session shows on the contact-centric
calendar, which is found in the Contacts screen, Calendar view.

The following image illustrates the workow triggered during session registration as follows:

1. The Event Manager registers aendee for a session.
2. The workow adds the person’s name to the list associated with the activity record
3. Then an activity displays on the aendee’s personal calendar.

In addition, the activity displays on the Contacts screen, Calendar view.
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Removing a Session Activity  
If you register an aendee for a session in error, you need to remove the session activity from the aendee’s personal
calendar. Removing a session activity requires deleting the individual from the Aendee’s list for the session, then
removing the aendee’s name from the Contacts eld in the Activities form.

The following procedure describes how to remove a session activity from an aendee’s personal calendar.

To remove a session activity from an aendee’s personal calendar
1. Navigate to the Site Map > Events > Sessions view.
2. In the Sessions list, and select and drill down on the session.
3. Click the Participants view tab, and then click Aendees.
4. In the Aendees list, select and the aendee from the list and click Cancel Registration.
5. Navigate to the Site Map > Activities > All Activities view.
6. In the Activities list, select the activity.
7. In the Activity form, from the Contact’s eld, click the select buon.
8. In the Contacts dialog box, select the aendee, and click Remove.

Troubleshooting Registration  
If you are experiencing diculty submiing credit card information using the Shopping Cart, make sure that Siebel
Events Management is properly congured for the database software in use. For more information, see Installing and
Conguring Events Management.

Canceling Registrations and Using the Waiting List  
In Siebel Events Management, you can cancel registrations only from administrative screens. End users who want to
cancel their event or session registration must contact the organization holding the event and ask that an administrator
cancel the registration.
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When an event registration is canceled, all registrations for specic events and sessions associated with the event are
canceled as well. Likewise, if an event registration is canceled, so are all registrations for specic sessions of the event.
However, if a session registration is canceled, the event registrations are not canceled.

When the administrator cancels a registration for an event or session that is full, a seat becomes available. However, in
some cases, it may be desirable to prevent a seat from becoming available. To prevent a seat from becoming available,
the administrator should reduce the capacity immediately prior to canceling the registration.

If the capacity is not reduced, and a seat becomes available, it is allocated to the next user whose registration is added
by the administrator or whose registration status is changed from Waitlisted to Conrmed, whichever comes rst. In
other words, after a seat becomes available, it is recommended that administrators immediately change the registration
status of the next wait listed person to Conrmed. Otherwise, a new registrant may accidentally be given the seat
designated for the wait-listed person.

The following procedure describes how to cancel an event registration from an administrative screen.

To cancel a potential aendee’s registration for an event
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event name for which you want to cancel a registration.
3. In the Details form, note whether the potential aendee is due any refund of fees, and, if so, the amount to be

refunded.
4. In the Events form, if you want to prevent a seat from becoming available because of the cancellation, reduce

the Event Capacity by one. For example, if the Event Capacity is 100, manually change the eld to 99.
5. Click the Participants view tab, and then click Aendees.
6. In the Aendees list, select the person to be canceled, and click Cancel Registration.
7. Use your organization’s standard procedure to provide any refund due to the person whose registration was

canceled.

Note:  It is possible to delete the registration record, rather than set the registration status to
Cancelled, but this is not recommended. Deleting the record completely removes information about
the registration that can be used to track the number of cancellations, to perform refunds, and so on.

After canceling a registration, the Event form shows that Openings increased by one and Seats Taken decreased by one.

You can give the new seat to the rst person on the waiting list, as described in the following procedure. To do this, you
rst identify the person on the waiting list who has the oldest claim to an open seat. Next, you conrm their interest
and availability for the event, and then, you change that person’s registration status from Waitlisted to Conrmed.
The following procedure is specic to an event; however, the concept can also be applied to an event or a session
registration.

To enable the waitlist for an event or session, make sure that the Allow Waitlist check box is selected. By default, all
events and sessions have the waitlist function enabled.

To allocate an open seat to a person on the waiting list
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which a seat has become available.
3. Click the Participants view tab, and then click Aendees.
4. In the Aendees list, click the menu buon and choose Columns Displayed.
5. In the Columns Displayed list, make sure the Registered column is displayed.
6. In the Aendees list, click Query.

a. In the Registration Status eld, select Waitlisted.
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b. Run the query to display all currently wait-listed aendees.
7. In the Registered column header, click the up arrow to sort the listings by registration date and time.

The person with the oldest listing on the waiting list is displayed in the rst row of the list.
8. Conrm the potential aendee’s interest and availability for the event.
9. In that person’s record, change the Registration Status from Waitlisted to Conrmed.

In certain cases you might want to disable the waitlist function for an event or session. For example, when the capacity
is reached, aendees will no longer be able to register for the event or session. An error message is displayed to users
who aempt to register for an event that is full, and whose waitlist function is disabled.

To disable the waitlist
1. Navigate to the appropriate view:

◦ For an event, navigate to the Site Map > Events > Event > Details view.

◦ For a session, navigate to the Site Map > Events > Sessions > Details view.

2. In the Details form, clear the Allow Waitlist check box.

End-User Procedures for Self-Registering for an Event  
End users can self-register through the Events Web site. However, prior to a potential aendee self-registering for an
event, the hosting organization should complete several tasks.

• Establish the invitee’s User ID

• Register the invitee to aend the event with a status of Invited

• Send an email to the invitee, which includes the address of the Web site and information about the username
and password to be used at the site

After being invited, the potential aendee performs the following tasks:

• Visits the Web site and logs in using the specied username and password

• Views his current event invitations

• Self-registers to aend the event

Note:  If the invitee registers to aend the event, that self-registration replaces the tentative
registration record created by the administrator.

If the potential aendee wants to cancel his or her registration at any point in the process, that person must contact an
administrator who can cancel the registration.

Registering to Use the Web Site  
In order to self-register using a Web browser, a potential aendee must rst be a registered user of the Siebel Events
Web site.
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Note:  For Finance customers, Siebel Events is an optional module that allows customers to use a Web site to
register for events. Your company must purchase this module in order to use Web registration and follow the
procedures described in this section.

End-User Events Visibility (for Finance Customers)
The following visibility rules and information are applied and displayed on the Web site according to the following
criteria:

• Upcoming Events. Displays the next ve events that have a Status Launched, a Start date after today, an Event
Type that is not Restricted, and Display on Website = Y.

• View My Open Invitations. Displays events to which a contact has been personally invited. If the contact’s
account is invited, but not the individual, the event does not appear here.

Events Web Site Registration Process
The rst step in becoming a Siebel Events Web site user is to obtain the address for the site’s home page. This address
may be obtained through one of the following:

• A personal contact within the hosting organization

• A link on the company’s corporate Web site

• An email message sent by the hosting organization

• An advertisement

After obtaining the home page address, and if the event is not restricted, any potential aendee can become a
registered Web site user by clicking the New User link on the home page. After registration on the Web site, the potential
aendee can view event information and self-register for the event. However, if the event is restricted, the company
hosting the event must establish the potential aendee as a registered Web site user and then invite the Web site user to
the event. This invitation allows enable the potential aendee to self-register over the Web site.

Note:  As described in Preparing for an Event, if the External check box is not selected in the Event form, the
event is not visible to Web site users under any circumstances.

The following procedure describes how to self-register as an Events Web site user. You may want to adapt and distribute
these instructions to your event-hosting employees and Web site users who have limited access to documented
procedures.

To self-register as an Events Web site user
1. Use standard Web browser to navigate to the Events home page.
2. Click the New User link in the User Login form.

A Personal Information form appears.
3. Complete the elds on the Personal Information form, noting the username and password values you enter for

future reference, and then click Next.
4. In the Contact Information form, complete the elds, and then click Next.

A Usage Terms dialog box appears, showing a license agreement.
5. Read the terms of the agreement, and then click I Agree to proceed.

A Registration Conrmation message appears.

73



Siebel
Events Management Guide

Chapter 6
Registering for an Event

6. Click Finish.

The Siebel Events Web site reappears, but the User Login form is no longer displayed, as you are now logged in.

Note:  Siebel Events Management administration screens are accessed through Siebel applications
such as Siebel Sales, Siebel Marketing, or Siebel Call Center. Depending on your Siebel application
conguration, Siebel Events end-user screens may or may not be accessible through these Siebel
applications, as well.

Self-Registering to Aend an Event  
An end user can self-register to aend an event when all of the following are true:

• The end user is a registered Events Web site user.

• The event’s Event Type is not set to Restricted.

When these conditions are met, an end user can view the event and register to aend the event. However, if the Event
Type is Restricted, the end user cannot register to aend the event, and he or she can only view the event if they are an
invited aendee.

The following procedures describe how a registered user of the Events Web site can register to aend an event and any
particular sessions within an event that may require separate registration. Note, however, in this release of Siebel Events
Management, aendee registration is no longer required at the Event Plan level. Aendees must rst register for an
event, and then register for the sessions within an event.

Note:  Conrmed registration for the event is required before registration for sessions is possible.

To self-register to aend an event
1. Navigate to the home page of the Events Web site.
2. Log in as a registered user of the site. For more information about new user registration, see Events Web Site

Registration Process.

The Siebel Events home page reappears without the User Login form.
3. Click one of the following links to view event information:

◦ Events link in Browse Events list. Displays the Available Events list, which shows all events that are open
to the general public.

◦ Register for an Event. Also displays the Available Events list, which shows all events that are open to the
general public.

◦ View My Open Invitations. Displays the My Invitations list, which shows all events to which you have been
invited, including restricted events.

◦ Any event listed in the Upcoming Events area of the home page. Displays an Event form and a Sessions
list for the selected event.

4. If you clicked one of the rst three links in the previous step, click the name of an event that interests you.
Otherwise, proceed to the next step.

5. In the Event form, click Register.

74



Siebel
Events Management Guide

Chapter 6
Registering for an Event

If there is no charge for the event, and if there is still space available, the My Events list appears. The list
includes the event you selected, with the Status eld set to Conrmed, showing that you are registered for the
event. Also, an email message is automatically sent to you, reporting that your registration is conrmed for the
event.

If there is no charge for the event, but the maximum enrollment has been reached, the My Events list appears,
but the event listing shows a status of Waitlisted. An email message is automatically sent to you, reporting that
you are on the waiting list and will be informed if space becomes available.

If there is a registration fee for the event, and if there is still space available, the Shopping Cart appears,
containing information about the charge for the event.

6. (Optional) To continue registering for additional events before paying, return to the Events home page and
repeat Step 3 and Step 4 of this procedure.

7. To pay for all of the events you for which are registering, click Check Out.

a. In the Payment Method form, enter your credit card and billing information. If you have used the
Shopping Cart before, your previously entered information displays for you to edit or conrm.

b. Click Continue to display the Order Summary, and verify that all information is correct.
c. Click Conrm Order.

An Order Conrmation message appears.
d. Click Return to Home Page, and then click View Your Registrations to display the My Registered Events

list.

- The list includes the event or events that you selected, with the Status eld set to Conrmed,
indicating you are registered for the event. Also, two email messages are automatically sent to
you, one reporting that your registration is conrmed, the other reporting your Shopping Cart
transaction.

- If there is a registration fee for the event, but maximum enrollment has been reached, the My
Events list appears, but the event listing shows a status of Waitlisted. An email message is
automatically sent to you, reporting that you are on the waiting list and will be informed if space
becomes available.

- If you do not complete the check-out process for the Shopping Cart, your registration status is set
to Pending, by default. This status reserves a seat for you, if a seat is available, but only for a nite
time period. The default length of time that a registration remains pending is four hours. After this
period, Siebel Events automatically deletes pending registrations when you register another user
for the same event.

The following procedure describes how to complete an unconrmed registration for an event, either to convert a status
of Pending to a status of Conrmed or to convert a status of Waitlisted to a status of Conrmed.

To complete a pending or wait listed registration to aend an event
1. On the Home Page in the My Events list, click the View Your Registrations link.
2. Locate the listing for the registration that you want to complete, and click the link in the Event Name column of

that listing.

An Event form, a Sessions list, and a My Sessions form appears.
3. In the Event form, click Register.

◦ If there is no charge for the event, and if there is still space available, the My Events list appears. The list
includes the event you selected, with the Status eld set to Conrmed, showing that you are registered
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for the event. Also, an email message is automatically sent to you, reporting that your registration is
conrmed for the event.

◦ If there is no charge for the event, but the maximum enrollment has been reached, the My Events list
appears, but the event listing shows a status of Waitlisted. An email message is automatically sent to you,
reporting that you are on the waiting list and will be informed if space becomes available.

◦ If there is a registration fee for the event, and if there is still space available, the Shopping Cart appears,
containing information about the charge for the event.

4. (Optional) To continue registering for additional events before paying, return to the Events home page and
repeat Step 3 of the procedure in the procedure titled To self-register to aend an event.

5. To pay for all of the events you for which are registering, click Check Out.
a. In the Payment Method form, enter your credit card and billing information. If you have used the

Shopping Cart before, your previously entered information displays for you to edit or conrm.
b. Click Continue to display the Order Summary, and verify that all information is correct.
c. Click Conrm Order.

An Order Conrmation message appears.
d. Click Return to Home Page, and then click View Your Registrations to display the My Registered Events

list.
- The list includes the event or events you selected, with the Status eld set to Conrmed, indicating

you are registered for the event. Also, two email messages are automatically sent to you, one
reporting that your registration is conrmed, the other reporting your Shopping Cart transaction.

- If there is a registration fee for the event, but maximum enrollment has been reached, the My
Events list appears, but the event listing shows a status of Waitlisted. An email message is
automatically sent to you, reporting that you are on the waiting list and will be informed if space
becomes available.

The following procedure describes how to register for sessions within an event.

To register to aend sessions within an event
1. If you have not already done so, register for the sessions’ event, and make sure that your registration status is

Conrmed.
For instructions on how to register, see Events Web Site Registration Process.

2. From the home page, click the link View your Registration.
3. In the My Registered Events list, click the Events Name.

An Event form, a Sessions list, and a My Conrmed Sessions list appear.
4. In the Sessions list, select the session or sessions you want to register for, and then click Register Session.

◦ If there is no additional fee for the session, and if there is still space available, the Event form, Sessions
list, and My Conrmed Sessions list reappear. The selected session is listed in the My Conrmed Sessions
list with a value of Conrmed in the Status eld.

◦ If there is no additional fee for the session, but maximum enrollment has been reached, the Event form,
Sessions list, and My Conrmed Sessions list reappear. The selected session is listed in the My Conrmed
Sessions list with a value of Waitlisted in the Status eld.

◦ If there is an additional fee for the session, and if there is still space available, the Shopping Cart appears,
containing information about the charge for the session.

5. (Optional) To continue registering for additional sessions before paying, return to the Events home page and
repeat the Step 3 and Step 4 of this procedure.

6. To pay for all of the sessions you for which are registering, click Check Out.

76



Siebel
Events Management Guide

Chapter 6
Registering for an Event

a. In the Payment Method form, enter your credit card and billing information. If you have used the
Shopping Cart before, your previously entered information displays for you to edit or conrm.

b. Click Continue to display the Order Summary, and verify that all information is correct.
c. Click Conrm Order. An Order Conrmation message appears.
d. Click Return to Home Page, and then click View Your Registrations to display the My Registered Events

list.
e. Click the name of the event that includes the session you selected.

- An Events form, Sessions list, and My Conrmed Sessions list reappear. The selected session is
listed in the My Conrmed Sessions list with a value of Conrmed in the Status eld.

- If there is an additional fee for the session, but maximum enrollment has been reached, the Event
form, Sessions list, and My Conrmed Sessions list reappear. The selected session is listed in the
My Conrmed Sessions list with a value of Waitlisted in the Status eld. To register for additional
sessions, repeat Step 4 of this procedure.

- If there is an additional fee for the session, and the user is already registered for one or more
selected session, the Shopping Cart appears, but does not include the sessions that the user is
already registered for.

- If there is a time-conict between two or more overlapping sessions, an error message is displayed.

Registering for Sessions Within a Track  
Users have the choice of browsing and registering for sessions that appear within a specic track. This allows users to
match their interested sessions with the available sessions in large events. For more information on Associating Events
and Sessions with a track, see Associating Tracks with Events and Sessions.

Note:  Before proceeding with the procedure that follows, if you have not already done so, you must register
for the session’s event and make sure that your registration status is Conrmed. If you are not registered for
the event, then you won’t be allowed to register for the session. For instructions on how to self-register to
aend an event, see Self-Registering to Aend an Event.

To register for sessions within a track
1. From the home page, click the link Register for an Event.
2. In the All Available Events list, click the Event Name.

Note:  An event form, a session list, and a track list appear.

Prospect Registration  
Prospects who received an email invitation to the event by way of a marketing campaign, may register for an event
without logging in to the Event Web site. A prospect must click the URL within the email invitation to be able to register
for an event this way. Information about the prospect is embedded within the URL and passed onto the Event Web site.
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If invited through a marketing campaign, any change in an aendee’s registration status results in a registration history
(campaign response) record being created. Registration history records can be viewed in the Events screen, Aendees
subview. For more information, see Inviting Contacts and Prospects to an Event Using Siebel Marketing.

Troubleshooting Registration  
If you are experiencing diculty submiing credit card information using the Shopping Cart, make sure that Events
is properly congured for the database software in use. For more information, see Installing and Conguring Events
Management.

Conguring the Register Buon  
The Register buon in eEvents Event Register Form Applet does not invoke a workow. Instead, this buon invokes a
method that calls the EnrollUser method in the Event Registration business service. The EnrollUser method then calls
additional child methods to perform the following steps:

• Checks if the user is a prospect.

• Checks if the user is eligible for registration based on the event aributes and the user aributes. Also, checks if
space is available for the event.

• Checks if a prior registration record exists for the user. Also, checks if that registration record needs updating or
is conrmed.

• If no prior registration record exists, creates a new registration record to register the user.

• If the registration record is conrmed, updates the space capacity.

• If a quote is needed, calls the Quote method to create a quote and line item.

If you want the Register buon to invoke a workow, you can call the Register Events business service in a workow
step to complete these steps. If you do not call the Register Events business service, your workow must complete these
steps.

The code in the eEvents Event Register Form Applet invokes a business component that populates the input properties
that the EnrollUser method and its child methods use. This applet code also invokes the Event Registration business
service. You can create a script to accomplish these applet code tasks. In this script, you can call only the EnrollUser
method because this method calls the child methods. However, if you want to change the child methods, you can
change all methods using escript.

For more information about the EnrollUser method and its child methods, see Registration Business Service Methods.

Conguring Quantity Selection in Registration  
If you use the Shopping Cart to charge aendees event or session registration fees, the Quantity eld in the Shopping
Cart automatically defaults to a value of 1. If you want to congure Siebel Events Management so that an aendee can
purchase a quantity greater than 1, you can add a script to the write record method in the Quote Item business service.
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The AddToShoppingCart method in the Event Registration Service business service calls the following methods:

• IsItemInShoppingCart in the Shopping Service business service. This method checks to see if the item is
already present in the Shopping Car.

• AddToCart in the Shopping Service business service. This method adds the item to the cart and prices the item.

Customizing Siebel Events Home Page Applets  
The Events Web portal contains navigational applets on the home page that are designed to simplify user navigation.
Some of these navigational applets are not based on business component data, instead Siebel administrators or
developers use Siebel Tools to customize the applets. The applets are as follows:

• Customizing the My Events Applet

• Customizing the Browse Events Applet

• Customizing the Upcoming Events Applet

Customizing the My Events Applet  
The My Events Applet provides links to views where users can register for events, view event invitations, or view events
they have already registered for.

Each link and corresponding bitmap is represented by a control object on the applet. To create or modify a new control,
Siebel administrators or developers should perform the following procedure.

To create or modify new controls on an applet
1. Using Siebel Tools create a link by seing the HTML Type property of the control to “Link and then set the

Method Invoked property to “GotoView.
2. To specify the destination view, create a Control User Property with Name = “View and Value = “Destination

View Name.

Each image is specied in the Control’s HTML Bitmap property, which refers to a Bitmap Category Item. The
layout of the applet is dened by the Applet Web Template.

For more information about working with applets, views, drilldowns, bitmaps, and Web templates, see  Conguring
Siebel Business Applications ,  Using Siebel Tools , and  Siebel Object Interfaces Reference .

Customizing the Browse Events Applet  
The Browse Events Applet provides links to views where end-users can browse a list of events or session or query for a
specic event or session.

The Browse Events Applet is built on the same structure, that is with link and image controls, as the My Events Applet.
For more information, see the to create or modify new controls on an applet procedure in the Customizing the My
Events Applet section.
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Customizing the Upcoming Events Applet  
The Upcoming Events Applet is based on the eEvents Event business component. This applet displays links to the event
detail view.

The applet displays a link for each of the next ve events where Status = “Launched, Start Date > current date, Event
Type is not Restricted, and Display on Website= “Y. The applet is a special type of a list applet, whose Web template
displays a bulleted list for each record. A drilldown object on the applet species that the Name eld should have a
context-sensitive link to an event detail view.

For more information about working with applets, views, drilldowns, bitmaps, and Web templates, see  Conguring
Siebel Business Applications ,  Using Siebel Tools , and  Siebel Object Interfaces Reference .
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7  Managing the Events Calendar

Managing the Events Calendar  
This chapter discusses the requirements for displaying the events calendar. The chapter also describes how to congure
the events calendar user interface for your company. For end users, procedures are provided for managing the events
calendar and viewing sessions in the personal calendar.

This chapter includes the following topics:

• Events Calendar Overview

• End-User Procedures for Managing an Events Calendar

Events Calendar Overview  
Siebel Events Management allows individuals to manage an events calendar and synchronize sessions with their
personal calendars, where the sessions appear as activities. This section provides an overview of the relationships
between the events calendar and personal calendar, as well as providing information about events calendar browser
requirements and icons.

In addition to the personal calendar, there is also the Track Calendar and the Session Timeline or speaker calendar. For
more information on the Track Calendar, see Using the Track Calendar. For more information on the speaker calendar,
see Adding Speakers to Sessions.

Events Calendar and Personal Calendar Relationships  
The following list provides information about the dierences and relationships that exist between the events calendar
and the personal calendar:

• The events calendar only displays events, and not sessions or event plans.

• The personal calendar only displays activities corresponding to events or sessions and not event plans.
When an employee registers for a session, an activity appears on the employee’s personal calendar. For more
information on the dierences between event plans, events, and sessions, see Dening an Event.

• Personal calendar synchronization is a one-way communication from the sessions of an event to the personal
calendar. Changes to the session item that display on the personal calendar are not saved to the session itself.
If a user cannot aend a planned session listed on his or her personal calendar, only you—as the event’s
administrator—can remove that person from any speaker, sta, or aendee lists.

• Personal calendar items do not appear on the events calendar.
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End-User Procedures for Managing an Events Calendar  
End users can see a list of upcoming events at any time by viewing the events calendar. The rst part of this section
describes how you can use the events calendar to learn about new events and sessions for which you may want to
register.

After you register for a session within an event, your Siebel application also displays the session on your personal
calendar. The second part of this section describes how you can view session details from your personal calendar and
set an alarm to receive online session reminders.

Viewing Event Details from the Events Calendar  
You can use the events calendar to view all events that are scheduled for the day, week, or month in a calendar format.
Each event listing displays a link that takes you to details about the event and associated sessions.

In the Events Calendar view, you can nd out details about an event, for example the type, status, and description, by
placing your mouse pointer over the Event Name link. In addition, you can view all the events planned for the day by
placing your mouse pointer over the date in the Events Calendar view.

The following procedure describes how to view event details and associated sessions from the events calendar.

To view event details from the events calendar
1. Navigate to the Site Map > Events > Calendar view.
2. Click the Daily, Weekly, or Monthly view tab.

◦ Clicking the Daily view tab, sorts the calendar by hours in a day.

◦ Clicking the Weekly view tab, sorts the calendar by days in a week.

◦ Clicking the Monthly view tab, sorts the calendar by days of the month.

3. Place your mouse pointer over the name link to view details about the event.
4. Place your mouse pointer over the date to view events that are planned for that day.
5. Click the name link for the event you want to view.

The Events form and Sessions list appear, showing more details about the event.
6. Click the Session Time Line link.

The Event Session Timeline appears, showing an hourly breakdown for each session associated with the event,
as shown in the following gure.

Viewing Session Details from the Personal Calendar  
The following procedure describes how to view session details on your personal calendar.

To view session details from the personal calendar
1. Navigate to the Site Map > Calendar view.
2. Click the Daily, Weekly, or Monthly view tab.
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Your planned sessions appear in your personal calendar.
3. In the Calendar, click the name link for the session you want to view.

The Calendar Detail form appears, showing activity-style details about the session.

Note:  The personal calendar displays an activity for each session. A session activity in the calendar
is a copy of the session information. You may not reschedule or modify sessions from the personal
calendar.

4. In the Calendar Detail form, select the Alarm check box to receive an online reminder for the session.
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8  Hosting an Event

Hosting an Event  
This chapter discusses topics and procedures that help end users manage events onsite at the venue, using a direct
connection to Siebel Events Management. The topics and procedures discussed include system requirements for
hosting an event, managing activities onsite at the event, hosting onsite registration, and viewing venue, vendor, and
partner information.

This chapter includes the following topics:

• System Requirements for Hosting an Event

• Example Process Flow for Hosting an Event

• End-User Procedures for Hosting an Event

• Event Leads and Opportunities

• Correspondence Integration

System Requirements for Hosting an Event  
Using Siebel Events Management at an event site requires that you have a dedicated connection to your Siebel
database. If an event takes place at a venue that allows you to connect directly to Siebel Events Management onsite, you
can establish an event operations center where you can review and update event activities, add or change registrations,
and quickly locate information about event vendors and partners.

Example Process Flow for Hosting an Event  
The following image shows the recommended end-user procedures for hosting an event in Siebel Events Management.
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End-user procedures for hosting an event include the following:

• Activity Management at the Event Venue

• Onsite Registration

• Entering Actual Revenues and Costs

• Viewing Venue, Vendor and Partner Information

End-User Procedures for Hosting an Event  
This section discusses the following topics and procedures:

• Activity Management at the Event Venue

• Onsite Registration

• Entering Actual Revenues and Expenses

• Viewing Venue, Vendor, and Partner Information

Activity Management at the Event Venue  
When you plan the activities that must be completed for your event, as described in Preparing for an Event, some of the
activities may take place before, during, or after the event. To make sure that the event goes smoothly, review the status
of event activities frequently during the preparation process.

If your event takes place at a venue that allows you to use Siebel Events Management onsite, you may want to review,
update, add, and assign activities during the event.
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Onsite Registration  
If an event allows aendees to register onsite at the event, you may want to set up a registration area where event sta
can use Siebel Events Management to register last-minute aendees.

For more information about how to perform this kind of registration, see Registering for an Event.

Entering Actual Revenues and Expenses  
An important aspect of event management is determining whether an event produces a good return on investment.
In order to determine this, you must record actual event income and expenses. In Siebel Events Management, you
can record these amounts using the Revenue and Expenses views. These views are also useful for analyzing budget
variances, if you have established a budget for your event. For information on seing up a budget for an event, see
Adding Budget Details.

Actual revenues and expenses can be entered using the Revenue and Expenses views at the event plan, event, and
session level. Each revenue and expense record is optionally related to an event and session. Records entered in the
child, roll up to the parent. For example, a revenue record entered at the session level also appears at the event and
event plan level.

Actual expenses can also be recorded at the venue and vendor level. For more information about creating expense
for a venue, see Researching and Choosing a Venue. For more information about creating expenses for a vendor, see
Researching and Hiring Vendors.

The following procedure describes how to record actual revenues for an event or session.

To record actual revenues for an event or session
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which you want to record revenue.
3. Click the Plan view tab, and then click Revenue.
4. In the Revenue list, create a new record.
5. To associate the revenue with a session, in the Session eld, click the select buon.

The following procedure describes how to record actual expenses.

To create an invoice for an expense
1. From the application-level menu, select Navigate > Site Map > Invoices.
2. In the Invoices list, create a new record.

Note:  Write down the Invoice # for reference.

3. In the Status eld, select Approved.
4. In the Bill To Account eld, click the select buon to select an account for billing identication purposes.
5. From the Pick Account dialog box, select the account, and click OK.
6. Complete the remaining elds.
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To record an expense
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which you want to record an expense.
3. Click the Plan view tab, and then click Expenses.
4. In the Expense list, create a new record.
5. To associate the expense with an event or session, in the Event or Session eld, click the drop-down list, and

select the event or session.
6. To associate the invoice information, in the Invoice # eld, click the select buon.
7. In the FS Invoice dialog box, select the Invoice number, and then click OK.

Viewing Venue, Vendor, and Partner Information  
During an event, you may need to contact venue, vendor, and partner personnel, either to make sure that planned
activities are carried out, or to address unforeseen needs that arise during the event. If you can access Siebel Events
Management onsite, you can look up contact information for venue, vendor, and partner personnel.

The following procedures briey describe how to look up this type of information. For information about entering new
venue, vendor, and partner information, see Preparing for an Event.

To view venue information
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you need information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event for which you wish to view information.
5. Click the Resources view tab, and then click Venues.
6. Select the venue for which you need information.
7. Review the following areas for the information that you need:

◦ Venues record

◦ Billing subview

◦ Expenses subview

◦ Reviews subview (accessed from the Billings view drop-down list)

8. To view additional information about the venue, including location and account information, click the name link
for the selected record in the Venues list.

9. To display venue room information, drill down on the venue record, and click the Rooms view tab.

To view vendor information
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you need information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, drill down on the event.
5. Click the Participants view tab and then click Vendors.
6. In the Vendors list, select the vendor for which you need information.
7. Review the following areas for the information you need:
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◦ The Vendors list

◦ The Billing subview

◦ The Reviews subview (In the Billings subview drop-down list)

8. To view account or contact information, click the selected record’s name link in the Name or Primary Contact
column of the Vendors list.

To view partner information
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Events list, select and drill down on the event for which you need information.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the Event Name.
5. Click the Participants view tab, and then click Partners.
6. In the Partners list, select the partner for which you need information.
7. To view account or contact information about the selected partner, click the name link in either the Name or

Primary Contact column of the Partners list.

Event Leads and Opportunities  
During an event, or after an event has occurred, leads or opportunities are often captured for distribution to the sales
team. Using Siebel Events Management, you can capture opportunities associated with a particular event.

To create a new opportunity, see  Siebel Applications Administration Guide .

To associate an opportunity to an event
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event.
3. Click the Results view tab, and then click Opportunity.
4. In the Opportunity list, create a new record.
5. In the Name eld, click the select buon.
6. In the Pick Opportunity dialog box, select the opportunity, and click OK.
7. Complete the rest of the elds as necessary.

Correspondence Integration  
Siebel Correspondence allows users to generate template-based correspondence to a group of contacts. You can
leverage this functionality from within Siebel Events to send any type of correspondence to event aendees, for
example, a registration package before the event or session or follow-up literature.

You can only send correspondence to aendees. You cannot send correspondence to prospects.

For information on seing up and administering Correspondence templates, see the  Siebel Correspondence, Proposals,
and Presentations Guide .
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To send correspondence to aendees
1. Navigate to the appropriate view:

◦ For an event, navigate to the Site Map > Events > Event > Aendees view.

◦ For a session, navigate to the Site Map > Events > Sessions > Aendees view.

2. In the Participants list, select one or more aendees.
3. From the File menu, choose Send Leer.
4. In the Correspondence list, select an enclosure to send.
5. Click Submit.
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9  Evaluating an Event

Evaluating an Event  
When an event is over, your company can evaluate the eectiveness of the event using Siebel Events Management.
This chapter discusses features that help end users evaluate events, for example event summary reports, performance
reviews of vendors and venues, and aendee registration records.

This chapter includes the following topics:

• Example Process Flow for Evaluating an Event

• Administrator Procedures for Evaluating an Event

• End-User Procedures for Evaluating an Event

Example Process Flow for Evaluating an Event  
The following image shows the recommended ow for end-user procedures to evaluate an event in Siebel Events
Management.

End-user procedures for event evaluation include the following:

• Viewing the process ow of Budget Variances

• Preparing Reports for an Event
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• Entering Venue and Vendor Performance Reviews

• Event Followup

See End-User Procedures for Evaluating an Event for a discussion of these procedures.

Administrator Procedures for Evaluating an Event  
There are no specic administrator procedures related to evaluating an event. However, as an administrator, you need
to set up reporting parameters during the initial conguration of your Siebel application.

For information on seing report parameters, see  Siebel Reports Guide .

End-User Procedures for Evaluating an Event  
This section discusses the following topics and procedures:

• Viewing Budget Variances

• Preparing Reports for an Event

• Entering Venue and Vendor Performance Reviews

• Event Followup

• Viewing a Contact’s Events

• Viewing a Contact’s Sessions

Viewing Budget Variances  
After recording actual revenues and expenses, as described in Hosting an Event, you can view budget variances at the
event plans, event, or session level. The following procedure describes how to view budget variances for an event.

To view budget variances for an event
1. Navigate to the Site Map > Events > Event view.
2. In the Events list, select and drill down on the event for which you want to view budget variances.
3. Click the Plan view tab.
4. Click the Expenses link to view the expense variance.

Note:  Aggregated budget variances can also be viewed within the Event screen, Details view within
the nancial information elds.

Preparing Reports for an Event  
Siebel Events Management includes a precongured event summary report to assist you in evaluating events. This
report contains information on aendance, budget, revenues, and vendor and venue performance ratings.
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To produce an event summary report
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event plan for which you want to produce a summary report.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select the event for which you want to produce a summary report.
5. Click the Reports buon.
6. From the Select a Report eld, select Event Summary.

Entering Venue and Vendor Performance Reviews  
During or after an event, you can enter performance reviews of the venues and vendors with which you are working.
To make sure the information is available when venues and vendors are considered for future events, enter comments
soon after an event is complete.

The following procedure describes how to enter a venue performance review for an event.

To enter a venue performance review
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select and drill down on the event for which you want to enter a venue performance

review.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Resources tab, and then click Venues.
6. In the Venues list, select the venue that you want to review, and scroll down to the Billings subview.
7. In the Billings subview, from the drop-down list, select Reviews.
8. In the Reviews list, create a new record, and complete the necessary elds. See the table in this topic for more

information.

The following procedure describes how to enter a vendor performance review for an event.

To enter a vendor performance review
1. Navigate to the Site Map > Events > Event Plans view.
2. In the Event Plans list, select the event for which you want to enter a vendor performance review.
3. Click the Schedule view tab, and then click Events.
4. In the Events list, select and drill down on the event.
5. Click the Participants view tab, and then click Vendors.
6. In the Vendors list, select the venue that you want to review, and scroll down to the Billings subview.
7. In the Billings subview, from the drop-down list, select Reviews.
8. In the Reviews list, create a new record, and complete the necessary elds. See the following for more

information.

The following table displays some elds in the Reviews list.

Field Comments

Reviewer Automatically populates with the username of the user who creates the review.
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Field Comments

   

Posted
 

Automatically populates with the date and time when the record is created.
 

Rating (1-10)
 

Allows you specify a numerical rating for the venue. Valid values are 1 through 10, where 10 is the best
rating.
 

Comments
 

Provides space for any comments you have about the venue or vendor.
 

Event Followup  
Siebel Events Management provides information that can be used to follow-up with invitees and aendees based on
their levels and areas of interest. For an event plan with a single event, you can identify those with a strong interest by
comparing the lists of those who were invited with those who aended. For a larger, multievent event, you can identify
areas of interest by reviewing which events and sessions particular contacts aended. You can also gauge event success
based on the percentage of invited accounts that aended.

Viewing a Contact’s Events  
Siebel Events Management provide information that allows you to view events that your contacts have registered to
aend.

To view a contact’s events
1. Navigate to the Site Map > Contacts > Contacts List view.
2. From the Contact List drop-down list, select All Contacts Across Organizations.
3. In the Contacts List, drill down on the Contact’s last name.
4. Click the Events view tab.

Note:  This view must be added to the current user’s responsibility.

Viewing a Contact’s Sessions  
Siebel Events Management provides information that allows you to view sessions that your contacts are aending.

To view a contact’s sessions
1. Navigate to the Site Map > Contacts > Contacts List view.
2. From the Contact List drop-down list, select All Contacts Across Organizations.
3. In the Contacts list, drill down on the Contact’s last name.
4. Click the Sessions view tab.
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Note:  This view must be added to the current user’s responsibility.
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10  Registration Business Service Methods

Registration Business Service Methods  
There are two event business services used for event and session registration respectively: EventRegistrationService
and SessionRegistrationService. These business services contain several methods, which are outlined in the images in
Example Methods of Business Services. The primary method used to register an individual into an event or session is
EnrollAdmin. The other functions are mostly subroutines called by this primary method. They are documented here for
the benet of technical developers who may wish to override specic methods, to add custom functionality. For more
information on business services, see  Using Siebel Tools .

This chapter includes the following topics:

• Example Methods of Business Services

• Descriptions of Business Services Methods

Example Methods of Business Services  
The following image shows the EventRegistrationService ow, which uses the EnrollAdmin method to do the following:

• Enroll User

• Check Previous Registration

• Check Space

• Clean Space

• Create Registration

• Update Registration

• Update Space

• Check Quote

• Add to Shopping Cart
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The following image shows the SessionRegistrationService ow, which uses the EnrollAdmin method to do the
following:

• Enroll User ( includes EnrollEndUser and CheckOverlaps)

• Check Previous Registration

• Check Space

• Clean Space

• Create Registration

• Update Registration

• Update Space

• Check Quote

• Add to Shopping Cart

Descriptions of Business Services Methods  
Siebel Events Management uses business services to perform registration management tasks behind the scenes. If
desired, developers can employ these business services and methods to register individuals into events and sessions
through scripting, workow, or other conguration designs.

This topic includes the following business services:

• EventRegistrationService Business Service Methods

• SessionRegistrationService Business Service Methods

EventRegistrationService Business Service Methods  
This topic describes the EventRegistrationService business services methods.
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EnrollAdmin Method  
This method is used to register one or more individuals. Input Property set is a nested property set where each row is
an input contact or prospect. This method is invoked from RegisterAll buon, where all dummy records in the current
context are registered. See the following table for a description of EnrollAdmin Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

EventId*
 

Input Property - Row Id of the Event.
 

Prospect ID
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Type (‘EVENT’)
 

Input Property - Always set to “EVENT
 

List Id
 

Input Property - List Id that contains the contact, if applicable.
 

List Owner Id
 

Input Property - The list creator Id that contains the contact, if applicable.
 

Dummy Id (Dummy regn Id)
 

Input Property - Dummy registration record Id.
 

Contact Id
 

Input Property - The row Id of the contact being registered.
 

User Type*
 

Input Property - type of individual being registered. “Contact or “Prospect.
 

Return Val*
 

Output Property - “Success or “Failure.
 

Output Type*
 

Output Property - Further information on the result.
 

Shopping Flag
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

Error Regn
 

Output Property - Cumulative error message with additional information.
 

EnrollUser Method  
This method is used to register a single contact or prospect. See the following table for a description of EnrollUser
Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.
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Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Type (‘EVENT’)
 

Input Property - Always set to “EVENT.
 

List Id
 

Input Property - List Id that contains the contact, if applicable.
 

List Owner Id
 

Input Property - List creator Id that contains the contact, if applicable.
 

Registration Date
 

Input Property - Date of registration.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Reg Id (Registration Id)
 

Output Property - Aendee Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Shopping Flag (YES or ““)
 

Output Property - Determines whether the event is fee based and needs to go through the Shopping
Cart process. “YES or Null.
 

CheckPreviousRegn Method  
This method determines if a previous registration or aendee record exists. See the following table for a description of
CheckPreviousRegn Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.
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Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Reg Id (Old regn if it exists)
 

Output Property - Aendee Id.
 

Regn Status (Status of the old regn)
 

Output Property - Status of previous aendee record.
 

CheckSpace Method  
This method checks if there is capacity for registration. See the following table for a description of CheckSpace Method
properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
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Properties Description

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

CleanSpace Method  
This method removes any old pending registration or aendee records that do not belong to the current user, to free up
capacity. The Business Component User Property “Reservation Time Out Hour determines how long these records exist
before being deleted. See the following table for a description of CleanSpace Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
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Properties Description

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

CreateRegistration Method  
This method calls the UpdateSpace method to create a registration and seat counts. Then calls CheckQuote to
determine if a quote needs to be created. See the following table for a description of CreateRegistration Method
properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

List Id
 

ListOwnerId
 

DummyId
 

Input Property - Dummy registration record Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
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Quote Item Id
 

Output Property - Quote Item Row Id.
 

Reg Id
 

Output Property - Aendee Id.
 

Shopping Flag (“Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

UpdateRegistration Method  
This method is called when a pending registration or aendee already exists. Completes the registration by calling other
methods as necessary. See the following table for a description of UpdateRegistration Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

List Id
 

Input Property - List Id that contains the contact, if applicable.
 

List Owner Id
 

Input Property - List creator Id that contains the contact, if applicable.
 

Registration Date
 

Input Property - Date of registration.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id*
 

Output Property - Aendee Id.
 

Status*
 

Input Property - Status of the registration.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered) Output Property - Description of any error encountered.
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Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Quote Item Id
 

Output Property - Quote Item Row Id.
 

Reg Id
 

Output Property - Aendee Id.
 

Shopping Flag (“Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

UpdateSpace Method  
This method creates or updates a regn and updates event counts within a Lock to ensure transaction integrity. See the
following table for a description of UpdateSpace Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Row Id of the Event.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Action* (Mode of Operation to be
performed - create regn, update regn)
 

Input Property - Operation can be performed.
 
Increase count: Enroll an aendee
 
Remove from enroll: Remove an aendee (no functionality present for this currently)
 
Remove from waiting: Remove an WL aendee (no functionality present for this currently)
 
Remove from invited: Remove an invitee (no functionality present for this currently)
 
Waiting to enroll: Enroll an existing aendee (called from Update Regn)
 
Invitee to enroll: Enroll an invitee (called from Update Regn)
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

105



Siebel
Events Management Guide

Chapter 10
Registration Business Service Methods

Properties Description

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Reg Id
 

Output Property - Aendee Id.
 

CheckQuote Method  
This method determines whether the current user needs to be charged. See the following table for a description of
CheckQuote Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id*
 

Input Property - Registration or aendee row Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier) Output Property - Siebel Error Id.
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AddToShoppingCart Method  
This method invokes the shopping service to create a quote item. See the following table for a description of
AddToShoppingCart Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id*
 

Input Property - Registration or aendee row Id.
 

Event Id*
 

Input Property - Event row Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Quote Id
 

Output Property - Quote Row Id (Returns a quote id if a new quote is created).
 

Quote Item Id
 

Output Property - Quote Item Row Id (Returns a quote item Id if the quote item already exists in the
same Web session).
 

Shopping Flag (“Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
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SessionRegistrationService Business Service Methods  
This topic describes the SessionRegistrationService business services methods.

EnrollAdmin Method  
This method is used to register one or more individuals. Input property set is a nested property set where each row is an
input contact or prospect. This method is invoked from the RegisterAll buon, where all dummy records in the current
context are registered. See the following table for a description of EnrollAdmin Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

EventId*
 

Input Property - Event Row Id.
 

Session Id
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by the Siebel Marketing
Server during campaign execution.
 

Type(‘SESSION’)
 

Input Property - Always set to “SESSION.
 

Dummy Id (Dummy regn Id)
 

Input Property - Dummy registration record Id.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - Further information on the result.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Shopping Flag (YES or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

Error Regn (A grouped error message if
applicable)
 

Output Property - Cumulative error message with additional information.
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EnrollEndUser Method  
This method is used for multi-session registration for a contact or a prospect. Check for time overlaps between selected
sessions and existing session registrations. Uses a nested property set. See the following table for a description of
EnrollEndUser Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Event Row Id.
 

Session Id
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign executions.
 

Type (‘SESSION’)
 

Input Property - Always set to “SESSION.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id (Empty)
 

Input Property - Registration or aendee row Id. Not used.
 

Status (Empty)
 

Input Property - Registration or aendee status. Not used.
 

Registration Date (Empty)
 

Input Property - Registration date. Not used.
 

Parent Registration Id (Empty)
 

Input Property - Registration or aendee row Id for the session’s parent event. Not used.
 

Start Date*
 

Input Property - Start Date and Time of the session.
 

End Date*
 

Input Property - End Date and Time of the session.
 

Name*
 

Input Property - Name of the session (used for error messaging).
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error Regn (A grouped error message if
applicable)
 

Output Property - Cumulative error message with additional information.
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Shopping Flag (“YES or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

Parent Reg Id
 

Output Property - Registration or aendee row Id for the session’s parent event.
 

CheckOverlaps Method  
This method is used to determine if any of the sessions selected for registration within the event have time overlaps
or conict with prior registered sessions for the aendee. Uses a nested property set. See the following table for a
description of CheckOverlaps Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Event Row Id.
 

Session Id
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign executions.
 

Type (‘SESSION’)
 

Input Property - Always set to “SESSION.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id (Empty)
 

Input Property - Registration or aendee row Id. Not used.
 

Status (Empty)
 

Input Property - Registration or aendee status. Not used.
 

Registration Date (Empty)
 

Input Property - Registration date. Note used.
 

Parent Registration Id (Empty)
 

Input Property - Registration or aendee row Id for the session’s parent event. Not used.
 

Start Date*
 

Input Property - Start Date and Time of the session.
 

End Date*
 

Input Property - End Date and Time of the session.
 

Name*
 

Input Property - Name of the session (used for error messaging).
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Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Session Id)
 

Output Property - Event Id
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Reg Id
 

Output Property - Aendee Id.
 

Shopping Flag (“Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

EnrollUser Method  
This method is used to register a single contact or prospect. See the following table for a description of EnrollUser
Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Event Id*
 

Input Property - Event Row Id.
 

Session Id
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign executions.
 

Type (‘SESSION’)
 

Input Property - Always set to “SESSION.
 

Status
 

Input Property - Registration or aendee status. Not used.
 

Reg Id (Empty)
 

Input Property - Registration or aendee row Id. Not used.
 

Parent Registration Id*
 

Input Property - Registration or aendee row Id for the sessions’ parent event.
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Registration Date
 

Input Property - Registration date. (Only required if multiple registration records exist for the same
contact.)
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Reg Id (RegistrationId)
 

Output Property - Aendee Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Shopping Flag (YES or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

CheckPreviousRegn Method  
This method is used to determine if a previous registration or aendee record exists. See the following table for a
description of CheckPreviousRegn Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
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Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Reg Id (Old regn if it it exists)
 

Output Property - Aendee Id.
 

Regn Status (Status of the old regn)
 

Output Property - Status of previous aendees record.
 

Parent Reg Id
 

Output Property - Registration or aendee row Id for the session’s parent event.
 

CheckParentRegn Method  
This method determines if the aendee is registered for the session’s parent event. See the following table for a
description of CheckParentRegn Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Event Id*
 

Input Property - Event Row Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value) Output Property - Further information on the result.
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Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Parent Reg Id
 

Output Property - Registration or aendee row Id for the session’s parent event.
 

Parent Status
 

Output Property - Status of the session’s parent event.
 

CheckSpace Method  
This method checks if there is capacity for registration. See the following table for a description of CheckSpace Method
properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
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Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

CleanSpace Method  
This method removes any old pending registration or aendee records that do not belong to the current user, to free up
capacity. The Business Component User Property “Reservation Time Out Hour determines how long these records exist
before being deleted. See the following table for a description of CleanSpace Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

CreateRegistration Method  
This method calls the UpdateSpace method to create a registration and seat count. Then it calls CheckQuote to
determine if a quote needs to be created. See the following table for a description of CreateRegistration Method
properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.
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Event Id
 

Input Property - Event Row Id.
 

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Parent Registration Id
 

Input Property - Registration or aendee Id of the parent event.
 

DummyId
 

Input Property - Dummy Registration Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Quote Item Id
 

Output Property - Quote Item Row Id.
 

Reg Id
 

Output Property - Aendee Id.
 

Shopping Flag (‘Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

UpdateRegistration Method  
This method is called when a pending registration or aendee already exists. Completes the registration by calling other
methods as necessary. See the following table for a description of UpdateRegistration Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.
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Event Id
 

Input Property - Event Row Id.
 

Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Status
 

Input Property - Status for the registration.
 

Registration Date
 

Input Property - Date of the registration.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id*
 

Input Property
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Quote Item Id
 

Output Property - Quote Item Row Id.
 

Shopping Flag (‘Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

Reg Id
 

Output Property - Registration or aendee Id.
 

UpdateSpace Method  
This method creates or updates a regn and updates event counts within a Lock to ensure transaction integrity. See the
following table for a description of UpdateSpace Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.
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Session Id*
 

Input Property - Session Row Id.
 

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Parent Registration Id
 

Input Property - Registration/aendee Id of the parent event.
 

Action* (Mode of operation to be
performed - create regn, update regn)
 

Input Property - Operation can be performed.
 
Increase count: Enroll an aendee
 
Drop from enroll: Drop an aendee (no functionality present for this currently)
 
Drop from waiting: Drop an WL aendee (no functionality present for this currently)
 
Drop from invited: Drop an invitee (no functionality present for this currently)
 
Waiting to enroll: Enroll an existing aendee (called from Update Regn)
 
Invitee to enroll: Enroll an invitee (called from Update Regn)
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Reg Id
 

Output Property - Registration or aendee Id.
 

CheckQuote Method  
This method determines whether the current user needs to be charged. See the following table for a description of
CheckQuote Method properties.
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Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id*
 

Input Property - Registration or aendee row Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

AddToShoppingCart Method  
This method invokes the shopping service to create a quote item. See the following table for a description of
AddToShoppingCart Method properties.

Note:  Input Properties marked by an asterisk(*) indicate a required eld.

Properties Description

Prospect Id
 

Input Property - Row Id of the prospect being registered. This property is used by Siebel Marketing
Server during campaign execution.
 

Contact Id
 

Input Property - Row Id of the contact being registered.
 

User Type* (Contact or Prospect)
 

Input Property - Type of individual being registered. “Contact or “Prospect.
 

Reg Id* Input Property - Registration/aendee row Id.
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Session Id*
 

Input Property - Session Row Id.
 

Return Val* (Success or Failure)
 

Output Property - “Success or “Failure.
 

Output Type* (Info on the return value)
 

Output Property - Further information on the result.
 

Error String (Contains Event Id)
 

Output Property - Event Id.
 

Error Message (Error encountered)
 

Output Property - Description of any error encountered.
 

Error Param (User Id)
 

Output Property - Contact or Prospect Id.
 

Error Code (Contains Error Identier)
 

Output Property - Siebel Error Id.
 

Quote Id
 

Output Property - Quote Row Id. (Returns a quote Id if a new quote is created)
 

Quote Item Id
 

Output Property - Quote Item Row Id. (Returns a quote item Id if the quote item already exists in the
same Web session.)
 

Shopping Flag (‘Y or ““)
 

Output Property - Determines whether the Shopping Cart process is required. “YES or Null.
 

120



Siebel
Events Management Guide

Chapter 11
Event Business Component User Properties

11  Event Business Component User Properties

Event Business Component User Properties  
The following table outlines some commonly-used business component user properties and describes how they can be
used to modify the behavior of the Siebel Events Management application. User properties are changed using Oracle’s
Siebel Tools, and should only be modied by experienced developers. Please test the application thoroughly to ensure
expected results after modifying user properties.

Business
Component

User Property Description Default Value

Cancel Aendees
 

Y = Canceling Event cancels aendees for the event.
N = Aendee status remains.
 

Y
 

Internal Charge Flag
 

Y = Employees are not charged for the fee-based
events. N = Employees are charged.
 

N
 

On Field Update Set
 

To dynamically change the invitation deadline date.
Specify days in value using specied format.
 

Start Date,
“Invitation
Deadline,
“[Start Date] -
60
 

Relate Activity
 

Determine if activity needs to be created, when event
is created. Y = activity created. N = no activity.
 
When an event is created, an error results if the
TODO_TYPE list of values does not include an active
value that has eEvent as language independent code.
 

Y
 

CustomFieldX
 
where X is a number
 

Used to copy a single-value eld value from a parent
event to child events. A user property with the
same number for X must exist on the parent and
child business component. The CustomFieldX user
properties that you use must all be active and in
logical order.
 

None.

eEvents Event
 

CustomMVFX
 
where X is a number
 

Used to copy a multi-value eld value from a parent
event to child events. A user property with the same
number for X must exist on the parent and child
business component.
 

Reservation Time Out Hour
 

Time (in hours) after which pending records can be
deleted if there is a necessity to free up space.
 

4
 

eEvents Event
Aendee
 

Auto Register Company
 

Y = Automatically register the individual’s
company when the individual registers. N = Do not
automatically register the company.

Y
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Business
Component

User Property Description Default Value

 

Cancel Aendees
 

Propagate of cancellation status for aendee from
event to session. Y = Propagate status. N = Do not
propagate.
 

Y
 

Inherit Event Date
 

If event date changes out of scope, this property
determine whether the session will inherit either the
Start or End Date of the event. Y = Inherit date from
event. N = Do not change date.
 

N
 

Internal Charge Flag
 

Y = Employees will not be charged for fee-based
sessions. N = Employees are charged.
 

N
 

eEvent Event
Session
 

Relate Activity
 

Determine if activity needs to be created, when
session is created. Y = Activity created. N = No
activity.
 
When a session is created, an error results if the
TODO_TYPE list of values does not include an active
value that has Session as language independent
code.
 

Y
 

Event Schedule View
 

Determine which view is displayed after the Create
Event buon is selected.
 

eEvent Parent
Event Events
View
 

CustomFieldX
 
where X is a number
 

Used to copy a single-value eld value from a parent
event to child events. A user property with the
same number for X must exist on the parent and
child business component. The CustomFieldX user
properties that you use must all be active and in
logical order.
 

eEvents Parent
Event
 

CustomMVFX
 
where X is a number
 

Used to copy a multi-value eld value from a parent
event to child events. A user property with the same
number for X must exist on the parent and child
business component.
 

eEvent Session
Aendee
 

Reservation Time Out Hour
 

Time (in hours) after which pending records can be
deleted if there is a necessity to free up space.
 

4
 

122


	Events Management Guide
	Preface
	What’s New in This Release
	What’s New in Siebel Events Management Guide, Siebel CRM 20.1 Update
	What’s New in Siebel Events Management Guide, Siebel CRM 19.1 Update

	Getting Started
	Getting Started
	Administrative Setup Tasks

	Installing and Configuring Events Management
	Installing and Configuring Events Management
	Installation Overview
	Shopping Cart Requirements
	Configuring Automatic Email Notification

	Defining an Event
	Defining an Event
	Event Management Process Phases
	Event Plan Definition
	Event Preparation
	Event Implementation
	Event Evaluation

	Business Scenarios for Defining an Event
	Administrator Event Definition Scenario
	End-User Event Definition Scenario

	Example Process Flow for Defining an Event
	Administrator Setup Procedures for Defining an Event
	Reviewing and Modifying Lists of Values (LOVs)
	Updating Lookup Tables
	Region Administration
	Period Administration
	Product Lines for Financial Services Customers
	Adding Session Templates

	Creating Contacts
	Creating Accounts
	Creating Venues
	Using Pricing Models

	End-User Setup Procedures for Defining an Event
	Defining Event Plans, Events, and Sessions
	Creating Tracks
	Adding Event Plan Details
	Setting Goals and Assumptions for an Event Plan
	Deal Roadshow Event Type (Financial Services Customers Only)
	Associating a Deal Roadshow with a Specific Deal (Finance Services Customers Only)
	Updating Event Plans

	Creating Events
	Updating an Event

	Adding Budget Details
	Estimating Revenues
	Financial Information for Events
	Approving Event Plans

	Adding Event Activities


	Preparing for an Event
	Preparing for an Event
	Event Preparation Tasks
	Business Scenario for Preparing for an Event
	Example Process Flow for Preparing for an Event
	End-User Procedures for Preparing for an Event
	Track Management Tasks
	Associating Tracks with Events and Sessions
	Associating Related Tracks
	Using the Track Calendar
	Associating Contacts with a Track
	Viewing Track Members

	Activity and Staff Management Tasks
	Adding Staff to an Event or a Session
	Working with Event Activities
	Monitoring Progress on Event Activities

	Preparing Sessions
	Basic Questions for Event Organizing
	Creating and Using Sessions
	Creating and Using Session Templates
	Viewing Session Schedules and Attendees
	Assigning Rooms to Sessions
	Researching and Organizing Speakers
	Adding Speakers to Sessions
	Viewing Session Tracks

	Publishing Event Information to a Web Site
	Creating and Using Web Banners
	Using Siebel Microsites
	Preparing Collateral

	Venue Preparation Tasks
	Researching and Choosing a Venue
	Entering Venue Expense and Billing Information
	Setting Up at the Venue

	Third-Party Tasks
	Collaborating with Partner Organizations
	Researching and Hiring Vendors
	Attaching Files

	Inviting Contacts and Prospects to an Event
	Inviting a Contact to an Event
	Inviting a List of Contacts to an Event
	Inviting Contacts and Prospects to an Event Using Siebel Marketing
	Entering and Tracking Travel Arrangements

	Preparing Event Status Reports


	Registering for an Event
	Registering for an Event
	Example Process Flow for Registering for an Event
	Registering One or More Attendees
	Registering a List of Attendees for an Event
	Creating Attendee Lists
	Registering an Attendee
	Registering an Attendee for an Event
	Registering Previously Invited Attendees to an Event

	Tracking Guests of Attendees
	Registering a Group of Attendees for a Session
	Registering an Account for Financial-Services Customers
	Registration Workflow
	Session Registration and Activity Records
	Removing a Session Activity
	Troubleshooting Registration
	Canceling Registrations and Using the Waiting List

	End-User Procedures for Self-Registering for an Event
	Registering to Use the Web Site
	Self-Registering to Attend an Event
	Registering for Sessions Within a Track
	Prospect Registration
	Troubleshooting Registration

	Configuring the Register Button
	Configuring Quantity Selection in Registration
	Customizing Siebel Events Home Page Applets
	Customizing the My Events Applet
	Customizing the Browse Events Applet
	Customizing the Upcoming Events Applet


	Managing the Events Calendar
	Managing the Events Calendar
	Events Calendar Overview
	Events Calendar and Personal Calendar Relationships

	End-User Procedures for Managing an Events Calendar
	Viewing Event Details from the Events Calendar
	Viewing Session Details from the Personal Calendar


	Hosting an Event
	Hosting an Event
	System Requirements for Hosting an Event
	Example Process Flow for Hosting an Event
	End-User Procedures for Hosting an Event
	Activity Management at the Event Venue
	Onsite Registration
	Entering Actual Revenues and Expenses
	Viewing Venue, Vendor, and Partner Information

	Event Leads and Opportunities
	Correspondence Integration

	Evaluating an Event
	Evaluating an Event
	Example Process Flow for Evaluating an Event
	Administrator Procedures for Evaluating an Event
	End-User Procedures for Evaluating an Event
	Viewing Budget Variances
	Preparing Reports for an Event
	Entering Venue and Vendor Performance Reviews
	Event Followup
	Viewing a Contact’s Events
	Viewing a Contact’s Sessions


	Registration Business Service Methods
	Registration Business Service Methods
	Example Methods of Business Services
	Descriptions of Business Services Methods
	EventRegistrationService Business Service Methods
	EnrollAdmin Method
	EnrollUser Method
	CheckPreviousRegn Method
	CheckSpace Method
	CleanSpace Method
	CreateRegistration Method
	UpdateRegistration Method
	UpdateSpace Method
	CheckQuote Method
	AddToShoppingCart Method

	SessionRegistrationService Business Service Methods
	EnrollAdmin Method
	EnrollEndUser Method
	CheckOverlaps Method
	EnrollUser Method
	CheckPreviousRegn Method
	CheckParentRegn Method
	CheckSpace Method
	CleanSpace Method
	CreateRegistration Method
	UpdateRegistration Method
	UpdateSpace Method
	CheckQuote Method
	AddToShoppingCart Method



	Event Business Component User Properties
	Event Business Component User Properties



