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1. About this Manual 
This manual provides the required information that Balance Sheet Planning 
Application administrator needs to setup the application. The document 
contains steps to create Hyperion Planning Application with BSP specific 
parameters, Creating Essbase Database, steps for creating Balance Sheet 
Planning relational data model and other required configurations. 

2. Audience 
This Manual is meant for use by the Oracle Financial Services Analytical 
Applications Infrastructure System Administrator or Hyperion System 
Administrator. It provides step-by-step instructions necessary for configuring 
the Oracle Financial Services Balance Sheet Planning v8.0.0.0.0 Product.  

3. Environmental variables configuration 
Set the following environmental variables in the profile for the UNIX user 
where Hyperion Planning has been installed, if not already set: 

 
• EPM_ORACLE_HOME 
• MIDDLEWARE_HOME 
• HYPERION_HOME – Same as EPM_ORACLE_HOME 
• ORACLE_HOME - Oracle Client Home 
• JAVA_HOME 
• ARBORPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 
• ESSBASEPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 
• NLSPATH=$EPM_ORACLE_HOME/products/Planning/bin/nls/msg/en_US/ofs

msg.cat:$EPM_ORACLE_HOME/products/Planning/bin/nls/msg/C/ofsmsg.ca
t 

• INIPATH=$EPM_ORACLE_HOME/products/Planning/config 
• FIC_HOME=$EPM_ORACLE_HOME 
• FIC_DB_HOME=$EPM_ORACLE_HOME/logs/bsplog 
• PATH=$JAVA_HOME/bin:$ARBORPATH/bin:$EPM_ORACLE_HOME/products/P

lanning/bin:$EPM_ORACLE_HOME/products/Planning/config:$EPM_ORACLE_
HOME/products/Planning/lib:$ORACLE_HOME/bin:$PATH:$HOME/bin 

• LD_LIBRARY_PATH=$ORACLE_HOME/lib:$ORACLE_HOME/rdbms/public:$EPM_ORA
CLE_HOME/common/ODBC-
64/Merant/7.0/lib:$EPM_ORACLE_HOME/products/Planning/lib:$ARBORPATH/bin 

• LD_LIBRARY_PATH_64=$LD_LIBRARY_PATH:$LD_LIBRARY_PATH_64 
• ODBCINI=$EPM_ORACLE_HOME/common/ODBC-64/Merant/7.0/odbc.ini 
• ODBCINST=$EPM_ORACLE_HOME/common/ODBC-

64/Merant/7.0/odbcinst.ini 

Note: You need to make the changes into the .profile file of the UNIX account 
where Planning and ESSBASE are installed. Oracle client is required on the 
servers where Hyperion ESSBASE and Planning are installed. BSP uses the Oracle 
drivers. 

Modify BSP_RunOnEssbase.sh file for variable EPM_ORACLE_HOME. 
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4. Prerequisites 
• Hyperion 11.1.2.3  
• Hyperion Patch Set Update: 11.1.2.3.500 

5. Installation of BSP 8.0.0.0.0 on Hyperion 11.1.2.3.500 
After installing Hyperion 11.1.2.3.500, apply patch 19578149 for BSP 8.0.0.0.0 
installation. Installing Hyperion will only deploy the BSP files. BSP needs to be 
subsequently “initialized” in order to access it. 

If CAPEX and/or WORKFORCE applications are required, initialize CAPEX and/or 
WORKFORCE before BSP initialization.  

Note: For Hyperion 11.1.2.3.500, sequence of initialization to be CAPEX and/or 
WORKSPACE and/or BSP. 

Furthermore, after initializing the CAPEX and/or WORKFORCE modules with 
BSP, you need to perform the following activities. 

o Go to Manage->Dimension->Account and Entity Dimensions 

o Edit “No Entity” and “No Account” members and select the option 

“BSP”, “Rates” and “Core” Plan types. Perform a database refresh. 

4.1 Hyperion Planning Application Creation 

Note: Setup Classic Planning Application for Balance Sheet Planning as 
described in Oracle Hyperion Planning, Fusion Edition Administrator’s 
Guide. 
 
Select the value of following options in Create Application Wizard as 
specified below: 

 

Application Type: Generic 

First Fiscal Year -> Start Year: Set the value as per below illustration  

If start year falls in a century between: 

1900-2000 – Then start year will be 1980 

2000-2100 – Then start year will be 2000  

2100-2200 – Then start year will be 2100 and so on. 

Note: Here, Start year should be any centennial year such as, 2000, 
2100, and so on. BSP recommends to use 2000 as the Start year. 

Create 5 Plan Types as given below: 

Plan Type 1: BSP 
Plan Type 2: Rates 
Plan Type 3: Core 
Plan Type 4: WORKFORCE [WRKFORCE] 
Plan Type 5: CAPEX 
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NOTE: You should create all five Plan Types even if you are not planning 
to use Workforce and/or CapEx in your implementation. 

 
Change the Date format in File -> PreferencesDisplay Options to MM-DD-YYYY  

Note: While creating the Hyperion Planning Application, you can use any 
Application Name. BSP does not place any restriction on the Application 
naming convention. It is recommended to not use any special characters, 
like &, *, ‘’, ””, %, and so on. 

4.2 Create Essbase Database 

• Log in to Balance Sheet Planning Application using the administrator 
username and password  

• Go to Administration->Application->Create Database screen and 
selection options specified in the screen and create database. 

 

4.3 Create Balance Sheet Planning Relational Data Model 

• Create a tablespace with the user define name. The same table space 
name should be used in user “Configuration” UI for the variable 

TABLESPACE. TABLESPACE
 

Note: Here, this tablespace refers to Oracle TABLESPACE and all the 
output tables of Cash Flow Engine will be created in this TABLESPACE. 

• Create Oracle database user for Balance Sheet Planning Relational 
Data Model in the tablespace as created in previous step. This 
database user should have ‘create’ privileges on tablespace it belongs 
to 
o This database user is different than Hyperion configuration 

database users and application data source. 
Note: BSP requires a distinct schema that is different from the schema 
created for creation of an application in Hyperion Planning (which is 
created in section 4.1 Hyperion Planning Application Creation). 

o Assign the following specific privileges to the user created for 
Balance Sheet Planning. These privileges are 
 

GRANT MGMT_USER TO <DBUSERNAME>;  
GRANT SELECT_CATALOG_ROLE TO <DBUSERNAME>;  
GRANT CREATE PROCEDURE TO <DBUSERNAME>;  
GRANT CREATE SEQUENCE TO <DBUSERNAME>;  
GRANT CREATE SESSION TO <DBUSERNAME>;  
GRANT CREATE SYNONYM TO <DBUSERNAME>;  
GRANT CREATE TABLE TO <DBUSERNAME>;  
GRANT CREATE TRIGGER TO <DBUSERNAME>;  
GRANT CREATE TYPE TO <DBUSERNAME>;  
GRANT CREATE VIEW TO <DBUSERNAME>; 

4.4 Create Data Source DSN to Database 

Note: BSP requires only one Data Source, this data-source will point to 
the Oracle schema where the BSP application will be initialized. 

• Open $HYPERION_HOME/common/ODBC-64/Merant/7.0/odbc.ini.  
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• Add a new ODBC Data Source entry pointing to the Oracle-schema into 
which BSP was initialized, in section 4.3 Create Balance Sheet Planning 
Relational Model. This name should later be specified in the BSP’s 
configuration UI (available in Planning under Administrator Activities -
> Master Maintenance -> Assumption Forms -> Configuration), as 
mentioned in Section 5 below. 

• The entry should contain information required to connect to the 
schema created for BSP objects.  

• Verify Host Name, Logon ID, Password, Port Number, and SID contain 
the information required to connect to the schema. 

6. Initializing Balance Sheet Planning  
• Login into Hyperion Planning 
• Go to AdministrationApplication-->Properties 
• In the Properties window Add new row  

o Properly Name = APPTYPE Property Value = BSP 
o Restart the Planning Sever 

• Go to AdministrationInitialization->Balance Sheet Planning. 
• Specify the below parameters: 

• Server: Database Server Name/IP Address  
• Port: Database port 
• Database: Database SID 
• User: Username 
• Password: Password for Database schema 
• APS Server: <IPAdress> 

Below is a sample screenshot: 

 

The Model option (in above sample screenshot) allows you to choose the 
number of custom dimensions that you need for initialization of BSP. This 
drop-down list has following options:  

• Standard – No additional custom dimensions 
• Custom 1 - One additional custom dimension 
• Custom 2 - Two additional custom dimensions 

Note: The following errors generated to the bsplog.log during Initialize BSP 
step may be ignored:  

• Error:ORA-00001: unique constraint (PLANBSP.PK_FSI_M_LOOKUP_B) 
violated.  

• Error:ORA-00001: unique constraint 
(PLANBSP.PK_FSI_M_LOOKUP_MASTER) violated. 
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• Error:ORA-00001: unique constraint 
(PLANBSP.PK_FSI_M_LOOKUP_TL) violated.  

• Error:ORA-00955: name is already used by an existing object.  
Error:ORA-01418: specified index does not exist. 

• Error:ORA-01430: column being added already exists in table. 
• Error:ORA-02260: table can have only one primary key.  
• Error:ORA-00911: invalid character 
• Error:ORA-12899: value too large for column.  

"PLANBSP"."FSI_APPLICATIONS"."VERSION" (actual: 11, maximum: 
10)  

• Error:ORA-00942: table or view does not exist for table  
“FSI_DIM_ACCOUNT_SETUP_DETAILS”. 

Note: In case you are planning for an integrated installation of BSP with 
OFSAA applications, you should first initialize BSP as a standalone installation 
and then point BSP to the OFSAA instance.  

• Select “Finish” 
• After successful initialization, click the “Configure” button to launch the 

“Configuration UI”.  

Note: The config.xml file gets updated automatically as the part of 
configuration process.  

• Specify values for the parameters as mentioned under “annexure” 
section and click “save”. 

• Edit the file 
$EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh file to 
specify the path for ORACLE_HOME variable.  

Perform following steps after initializing BSP: 

1) Modify config.xml under path 
$MIDDLEWARE_HOME/user_projects/epmsystem1/Planning/planning1 to add 
below mentioned tag for each BSP Initialized application with correct data for Net 
service name as in tnsnames.ora file against param ID named as "TNS". <PARAM 
ID="TNS" DESCRIPTION="Net Service Name" FLAG="N">XXXXXXXX</PARAM>                                                               
Note: Net service name should not have any dots (".") symbol.                           
For Example to add the new tag for param ID named as "TNS" as below,      
<APPLICATION NAME="BSPAPP1" OWNER="" MODIFIEDBY="">        
 <PARAMS>                                                                                                               
<PARAM ID="SERVICEPROVIDER" DESCRIPTION="APS server "  
FLAG="N">XXXXXXXXXXXX</PARAM>                              
 <PARAM ID="DBSERVERNAME" DESCRIPTION="Database server name" 
FLAG="N">XXXXXXXXXXXX</PARAM>     
 <PARAM ID="SID" DESCRIPTION="Database service name/SID"  
FLAG="N">XXXXXXXXXXXX</PARAM>             
 <PARAM ID="USERNAME" DESCRIPTION="Database User Name"  
FLAG="N">XXXXXXXXXXXX</PARAM>           
 <PARAM ID="PASSWORD" DESCRIPTION="Database Password"  
FLAG="E">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="MODELTYPE" DESCRIPTION="Selected Data Model" 
FLAG="N">XXXXXXXXXXXX</PARAM>      
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  <PARAM ID="DSNNAME" DESCRIPTION="DSN Name"  
FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="LCMDIRPATH" DESCRIPTION="LCM Directory path"  
FLAG="N">XXXXXXXXXXXX</PARAM>      
  <PARAM ID="LCMDIRNAME" DESCRIPTION="LCM Directory Name"  
FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="SERVERNAME" DESCRIPTION="Essbase Server Name"  

FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="ESSUSER" DESCRIPTION="Essbase Uesr Name" 
FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="ESSPWD" DESCRIPTION="Essbase Password" 
FLAG="E">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="FirstYr" DESCRIPTION="First Year"    
FLAG="N">XXXXXXXXXXXX</PARAM>      
  <PARAM ID="EndYr" DESCRIPTION="End Year"   
FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="CurrMonth" DESCRIPTION="Current Month"  
FLAG="N">XXXXXXXXXXXX</PARAM>       
 <PARAM ID="StartPeriod" DESCRIPTION="Start Period"   
FLAG="N">XXXXXXXXXXXX</PARAM>      
 <PARAM ID="EndPeriod" DESCRIPTION="End Period"   
FLAG="N">XXXXXXXXXXXX</PARAM>       
 <PARAM ID="VERSION" DESCRIPTION="VERSION" 
FLAG="N">8.0</PARAM> <PARAM ID="TNS" DESCRIPTION="Net Service 
Name" FLAG="N">XXXXXXXX</PARAM>       
 </PARAMS>             
</APPLICATION>  

  

2) Note $MIDDLEWARE_HOME/user_projects/epmsystem1 is the default Planning 
Instance path on default installation.  

Incase of change, refer the relevant path and modify this path against 
environment variable "EPM_ORACLE_INSTANCE" in    

$EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh ,  

$EPM_ORACLE_HOME/products/Planning/bin/BSP_RunOnPlanning.sh,  

$EPM_ORACLE_HOME/products/Planning/bin/BSP_RunOnPlanning.sh. 

 

5.1 Set Evaluation Order 

Go to Administration->Dimensions->Evaluation Order tab. 

o For BSP Plan type: 
 Set Chart of Account, Attribute Value and then Account 

Dimension. 
o For Rates Plan type:      

 Set Rate Element then Mix Breakout Dimension 
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5.2 Steps to Enable Validation Rules 

Follow the below steps to enable the validation rules: 

1) Go to Manage data form open the Loan Fees form and click on column 

A the Loan_Fees_VR Validation rule is enable open this rule and select 

the Chart of Account dimension against attribute of source type in last 

condition. Then click ok and save the form. 

2) Go to Manage data form open the Loan Fees Annual form and click on 

Grid the Loan_Fees_VR, Loan_Fees_VR1, Validation rules are enable 

open these rules and select the Chart of Account dimension against 

attribute of source type in last condition. Then click ok and save the 

form. 

3) Go to Manage data form open the Deposit Service Charge form and 

click on Grid the Dep_Svc_Chg_VR, Validation rules are enable open 

this rule and select the Chart of Account dimension against attribute of 

source type in last condition. Then click ok and save the form. 

4) Go to Manage data form open the Deposit Service Charge Annual form 

and click on Grid the Dpst_Svc_Chg_Annl_VR, Loan_Fees_VR1, 

Validation rules are enable open these rules and select the Chart of 

Account dimension against attribute of source type in last condition. 

Then click ok and save the form. 

5) Go to Manage data form open the Synchronization for Balance 

Accounts form and click on Row1 the Syn_Assets_VR, Syn_Liabty_VR, 

Validation rules are enable open these rules and select the Chart of 

Account dimension against attribute of source type in last condition. 

Then click ok and save the form 
    

5.3 LCM export and Preparation for Metadata Synchronization. 

1) Post the Loading of Metadata in to BSP Planning Application, the 

administrator should export the Application Metadata to File System in 

Shared Services. 

2) Administrator has to login into Shared Services and Select the BSP 

Planning Application. 

3) In the Artifact Summary Page at the right Bottom, click Select All. 

Exclude Essbase Data check-box and click Export.  
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4) Here the Administrator defines a LCM Directory Name which has to be 

provided in Configuration Custom UI in the BSP Application 

5) Once the LCM export is completed, a .zip file will be created with the 
given name in shared services.  

6) This .zip file will be located in the import_export path of the Hyperion 
Instance chosen during Installation.  

5.4 Metadata Synchronization 

1) After completing the Preparation for Metadata Sync, Login to the BSP 

application, Select Administrator Activities folder in the left pane. 

2) Select Master Maintenance form and then Right Click on the menu 

appeared as large square box. 

3) From the right click menu Select Metadata Synchronization and choose 

the type needed by the Administrator Purpose. 
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8. Distributed Environment Setup 
Perform the below steps when Hyperion Planning is installed in a distributed 
manner, that is, the Hyperion components Planning and ESSBASE are installed 
on separate servers. 

Note:  

- Hyperion ESSBASE should not be installed on Windows 
- Hyperion ESSBASE and Hyperion Shared Services must be installed on 

the same UNIX Server 
- The OS/Version of the server where Planning is installed must be the 

same as the OS/Version of the server where ESSBASE is installed. 
- EPM Oracle instance name (default instance name: epmsystem1 and 

instance path: $MIDDLEWARE_HOME/user_projects/epmsystem1) 
should be same in Hyperion Planning and Essbase servers. 

- Steps mentioned below should be repeated after every  
I. Initialization/re-initialization of Hyperion Planning generic 

application(s) created for Balance Sheet Planning using 
“AdministrationInitializationBalance Sheet Planning”.  

II. Update of Configuration settings for Balance Sheet Planning using 
“Master MaintenanceAssumption FormsConfiguration”. 

Perform the following steps, in the given sequence 

1) Ensure that tnsnames.ora on the ESSBASE Server is configured with the 
same name as on the Planning server, to connect to the database 
specified during initialization of BSP.  

2) Copy the $EPM_ORACLE_HOME/common/ODBC-
64/Merant/7.0/odbc.ini from the Planning server to the corresponding 
folder on ESSBASE Server, and update the odbc.ini for driver path for the 
BSP-specific entry. 

3) Save the Configuration Parameters in Planning; while saving the 
configuration, make sure that LCMDIRPATH is the LCM export path as on 
the ESSBASE server. 

4) Replace “epmsystem1” with EPM oracle instance name in 
“BSP_RunOnPlanning.sh” and “BSP_RunOnEssbase.sh” files, that are 
present at $EPM_ORACLE_HOME/products/Planning/bin, if you are 
not using default EPM Oracle instance name. 

5) Give execute permissions to “BSP_RunOnPlanning.sh” that is present at 
$EPM_ORACLE_HOME/products/Planning/bin location on the 
Planning server and run the script without passing any parameters. The 
script will create a gzip archive “bsp.tar.gz” in the same folder.  

6) Copy “BSP_RunOnEssbase.sh” and “bsp.tar.gz” from 
$EPM_ORACLE_HOME/products/Planning/bin to 
$EPM_ORACLE_HOME in ESSBASE Server, to where ESSBASE is 
installed. 

7) Give execute permissions to “BSP_RunOnEssbase.sh” and run the script 
without passing any parameters. 

8) On the ESSBASE server, modify bsp_user_profile.sh present under 
$EPM_ORACLE_HOME/products/planning/bin, and set the 
ORACLE_HOME as appropriate. 
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9. Annexure  
 

List of Parameters 

Sl. No. Parameter Name Description 

1 PASSWORD  Database Password 

2 USERNAME  Database User 

3 DSNNAME 

DSNNAME
 

 DSN Name (value should be the system DSN 

name configured for ODBC) 

Note: You should use the same DSN name 

which is created using section 4.4. 

DSN Name
 

4 SERVERNAME 

SERVERNAME
 

 Essbase Server Name 

5 ESSUSER 
 Essbase User Name 

Essbase User Na
 

6 
ESSPWD 

ESSPWD
 

 Essbase Password 

7 LCMDIRPATH 

LCMDIRPATH
 

 LCM Directory path 

8 LCMDirName 

LCMDIRNAME
 

 LCM Directory Name  

Note: You can use underscore  

 ("_”) in LCM Directory Name, but hyphen ("-") 

is not allowed.
LCM Directory Na

 

9 
FirstYr 

FirstYr
 

 First Year 

10 EndYr  End Year 

11 CurrMonth 

CurrMonth
 

 Current Month 

12 StartPeriod  Start Period (By Default set to Jan) 

13 EndPeriod 

EndPeriod

 End Period (By Default set to Dec)

End Period
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Sl. No. Parameter Name Description 

StartPeriod
 

14 TABLESPACE 
 DB Table Space 

Table Space
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Setting of Substitution Variable 

Note: If you are attempting to open a Form in BSP and following error 
appears: "A substitution variable required for this calculation is undefined. 
Variable: SecondYr", then set the SecondYr variable in Essbase 
Administration Services. 

SecondYr is a substitution variable. Any other variable can also be appeared in 
the above error message. Follow the below steps to configure the variable: 

1. Log in to EAS Console: http://<hostname>:19000/easconsole 
2. Click on "Launch" 
3. The Essbase Administration Services console will open. 
4. Expand Enterprise View -> Essbase Servers. 
5. Right-click on your server -> Edit -> Variables. 
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6. The Substitution Variables window will open. Go to the variable you are 
looking for and double-click on the value 

7. Enter the value and click on Set. 

 
8. Go back to BSP, and reload the Form.  

Note: Logout and Login are not required. 
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